ActiveReports 10

This is the help file for ActiveReports, reporting software for use in Visual Studio 2010, 2012, 2013 or 2015.

In This Documentation

ActiveReports User Guide
The User Guide has many getting started topics and how-to topics with code samples to copy and paste.
Class Library
This is the API documentation with topics for all of the public members of each assembly included with ActiveReports.

©2017. ComponentOne, a division of GrapeCity. All rights reserved.

Support Forum


ActiveReports User Guide

ActiveReports User Guide
ActiveReports 10 > ActiveReports User Guide

ActiveReports provides fully integrated Visual Studio components which combine user-friendly visual controls with the low-level control of code in Visual Studio .NET programming languages to provide a powerful report designer.

In This Documentation

Welcome to ActiveReports 10
This section provides basic information on installing and using the product, as well as support, licensing, and what's new.
License Your ActiveReports
This topic walks you through how to license your machine and how to add licensing to any projects created during your evaluation.
Upgrading Reports
This topic provides information about upgrading reports from ActiveReports 10 and Data Dynamics Reports, and about converting MS Access Reports and Crystal Reports with the Import Wizard.
Getting Started
This section provides an overview of the interface and where to find everything you need to get started designing reports.
Viewing Reports
Learn how to preview a report at design time or view it in Windows Form, Web, Flash or Silverlight Viewers.
Concepts
This section provides information on what you can do with ActiveReports.
How To
This section provides step-by-step instructions for many features.
Samples and Walkthroughs
This section provides a description of the samples available with ActiveReports and step-by-step walkthroughs explaining key features.
Troubleshooting
This section provides troubleshooting symptoms, causes, and solutions to commonly encountered issues.
See Also

Class Library

Class Library

©2017. ComponentOne, a division of GrapeCity. All rights reserved.

Support Forum


Welcome to ActiveReports 10

Welcome to ActiveReports 10
ActiveReports 10 > ActiveReports User Guide > Welcome to ActiveReports 10

Learn to use and install ActiveReports 10.

This section contains information about

What's New
Learn about the new features in ActiveReports.
ActiveReports Editions
Find out which features can be used with Standard and Professional Edition licenses.
Installation
View requirements for installation of ActiveReports, learn what files are installed and how to verify your installation, and find installation troubleshooting tips.
GrapeCity Copyright Notice
Explains GrapeCity copyright information.
End User License Agreement
Understand the terms of the ActiveReports License Agreement and Limited Warranty.
.NET Framework Client and Full Profile Versions
Provides details of assemblies that are compliant with .NET Framework 3.5 Client Profile and .NET Framework 4.0 Client Profile.
Redistributable Files
Find out the list of files that may be distributed.
See Also
Getting Started
Concepts
How To


What's New

What's New
ActiveReports 10 > ActiveReports User Guide > Welcome to ActiveReports 10 > What's New

We have made a number of changes and added new features since the last version of ActiveReports. Following are some of the major highlights of this release.

Report Parts

Report authors can now take advantage of report parts while designing Page, RDL, or Section reports. Report parts are controls in a report that can be reused in other reports. When you add a report part to a report, you are adding everything that is required for that control to work, such as data sets and data source connection settings. Reports stored on ActiveReports Server can also be used as report parts to design complex layouts with ease. You can start working with report parts by using the new Reports Library window in the End User Designer control and the Visual Studio designer.

Learn More | Working with Report Parts

Shared Images

ActiveReports has enhanced the Image control in Page and RDL reports to allow users to access images stored on an instance of ActiveReports Server. You can access the images shared on the server using the Source and Value properties of the Image control from the Visual Studio designer, End User Designer control and ActiveReports API. This feature empowers ActiveReports Server administrators to share images with multiple ActiveReports developers and report authors.

Learn More| Working with Images

Shared Style Sheets for Page and RDL Reports

ActiveReports has taken style reusability a step further by allowing you to store CSS-like style sheets on an instance of ActiveReports Server. ActiveReports authors can choose between embedding style sheets in reports for portability, storing them locally in external in *.rdlx-styles file format for local reusability, or storing them on ActiveReports Server for even wider reusability. You can save and execute shared style sheets on the server while working with the Visual Studio designer, ActiveReports End User Designer control and ActiveReports API.

Style Sheets for Page and RDL Reports

ActiveReports introduces CSS-like style sheets for Page and RDL reports, enabling the report designers to design consistently themed reports for multiple users. Style sheets make it quick and easy to create cohesive-looking Page and RDL reports. You can easily manipulate report elements such as logos, fonts, colors, background-colors and other style formats independently of the report layout design. You can add multiple style to a style sheet and embed them in your reports for portability, or store them externally in *.rdlx-styles format to reuse them in other reports. You can also add these style sheets to your report at run-time using the Stylesheet.Source and Stylesheet.Value properties and apply style to selected controls using the StyleName property.

Learn More| Working with Styles

Shared Subreports

ActiveReports now provides the ability to access subreports that are hosted on an instance of ActiveReports Server. Report authors can now create or use these shared subreports using the Visual Studio designer, End User Designer control and ActiveReports API. This feature empowers ActiveReports users to share subreports with multiple users or access them from a common server location.

Learn More | Subreport(RDL) | Subreport(Section Report)

Shared Master Reports

ActiveReports has taken master reports a step ahead by tightly integrating them with ActiveReports Server. You can now save and execute master reports on ActiveReports Server while working with the Visual Studio designer, ActiveReports End User Designer control and ActiveReports API. Shared master reports offer the advantages of a local master report, plus:

  • They make your reports portable
  • They allow multiple authors to use them

Learn More | Use a Master Report (RDL Report)

Tablix Data Region

The new Tablix data region supersedes the Matrix data region. It offers all of the features of the Matrix data region that let you visualize cross-tab, pivot tables, and provides exciting new ways to display data in a grid. With the Tablix data region, you can:

  • Create matrix or cross-tab reports
  • Design stepped matrices
  • Use multiple adjacent row and column groupings
  • Merge cells vertically
  • Create other complex layouts and much more.

Learn More | Tablix Reports | Tablix Walkthrough

Word Rendering Extension for Export to DOCX Format

The new Word Rendering Extension available in ActiveReports 10 provides the capability to export Page and RDL reports to Office Open XML document format, more commonly known by the file extension DOCX. The rendering engine supports a natural document flow and automation features like page headers and footers, tables of contents, and more.

Learn More | Rendering to Word

Execute and View Reports from ActiveReports Server

In ActiveReports 10, server side report execution is not limited to only the browser based viewers. Now, even the Windows Forms Viewer and WPF Viewer have the capability to preview, print, and export reports that are designed or hosted on ActiveReports Server. So now even your Windows apps can leverage the server features to execute, cache, schedule and secure reports.

ActiveReports 10 report designers in Visual Studio and the End User Designer control, are now more tightly integrated with ActiveReports Server. We have also enabled the designer to preview reports by executing them on the server. This opens up the possibilities of using server resources and publishing directly to the server with reports that are designed both by developers and by non-technical report authors.

With this functionality, you can:

  • Execute reports on the server while working with the Visual Studio designer, ActiveReports End User Designer control and ActiveReports API.
  • Use managed resources like shared data sources and shared data sets from the server while designing and previewing reports
  • Preview reports with built-in multi-tenancy support within the report designer

Learn More | Connecting to ActiveReports Server

Using Data Resources Stored on ActiveReports Server

Server shared resources allow the administrator to effectively create and control access to data which is handled by ActiveReports Server. This is a powerful feature, which simplifies the process of report designing by allowing developers to quickly access shared data sets for reports instead of setting up a new data source and data set each time.

A shared data source contains a set of data source connection properties and is stored on ActiveReports Server, and is only accessed by the administrator. Server shared data sets retrieve data from shared data sources to provide data that developers and end users can use in multiple reports for publishing on ActiveReports Server. Administrators can also create a shared data set using parameterized queries to retrieve data from a shared data source.

Shared resources enable the following scenarios:

  • The administrator can create, read, update, and delete data sources and data sets
  • The administrator can apply role-based access security to data sets
  • Users can use the shared data sets in their reports
  • Users can, to a limited extent, customize the data provided in shared data sets

Shared Data Sources | Shared Data Sets

Performance Enhancements with the New Layout Engine

Performance optimization has always been a focus area for ActiveReports. Keeping this in mind we have designed a new layout engine, which is lighter and faster for rendering Page and RDL reports. The results are:

  • Up to 20% faster report exporting
  • Substantially faster first page rendering in report viewers
  • Improved performance of report preview

Apart from the performance upgrades, the new layout engine fixes a number of formatting and layout challenges from the past versions.

Connecting to ActiveReports Server

We have made significant improvements in the user interface for the Connect to Server feature. You can connect to ActiveReports Server with the new Connect to Server option available in both the stand-alone designer and the Visual Studio designer. Once connected, you do not have to specify the connection information each time you access a shared resource.

Learn More

See Also

Getting Started

Getting Started
Adding an ActiveReport to a Project

How To

How To

Concepts

Concepts

Walkthroughs

Samples and Walkthroughs


ActiveReports Editions

ActiveReports Editions
ActiveReports 10 > ActiveReports User Guide > Welcome to ActiveReports 10 > ActiveReports Editions
Show All Show All
Hide All Hide All

ActiveReports 10 is an enhancement of the popular ActiveReports engine and report viewers, plus the powerful Data Dynamics Reports designer. It includes the same power and flexibility of ActiveReports and the same integration with the Visual Studio, plus adds many features.

Available in two editions, Standard and Professional, ActiveReports 10 delivers outstanding reporting capabilities. Drop down the sections below to see the features packed into each editions.

Standard Edition Features

The Standard Edition provides a report designer that is fully integrated with the Visual Studio IDE, a report viewer for Windows Forms, and export filters for generating reports in various file formats. The report designer even includes a barcode control with all of the most popular barcode styles, and its own chart control.

Designer

  • Full integration with the .NET environment
  • Familiar user interfaces
  • Choice of section or page or RDL report types
    • C# and VB.NET support with code-based section reports
    • Script support with XML-based section reports
    • Expression support with page reports and RDL reports
  • The ability to compile reports into the application for speed and security or to keep them separate for ease of updating
  • Designer hosting of .NET and user controls

Report Controls

Section Reports Page Reports/RDL Reports
  • ReportInfo
  • Label
  • Line
  • PageBreak
  • OleObject
  • SubReport
  • Shape
  • Picture
  • RichTextBox with HTML tag support
  • ChartControl with separate data source
  • Textbox
  • Barcode with standard styles plus RSS and UPC styles
  • Checkbox
  • CrossSectionBox extends from a header section to the related footer section
  • CrossSectionLine extends from a header section to the related footer section
  • Table data region
  • Tablix data region
  • Map data region
  • Chart data region
  • List data region
  • BandedList data region
  • Calendar data region
  • Sparkline data region
  • FormattedText with mail merge capabilities and XHTML + CSS support
  • Bullet Graph
  • BarCode
  • CheckBox
  • TextBox
  • TableOfContents
  • Line
  • Container
  • Shape
  • Image
  • Subreport(RDL Reports only)
  • Overflow Placeholder

Expressions (page reports/RDL reports)

  • Aggregates
  • Data visualization
    • Data bar
    • Icon set
    • Range bar
    • Color scale

Interactive Features

  • Document map (table of contents)
  • Bookmark links, hyperlinks, and drill through links
  • Parameters
  • Drill-down (page report/RDL reports)
  • Copy, pan, and zoom
  • Jump to previous, next, first, or last group or search result

Reporting Engine

  • Managed code
  • Binding to ADO.NET, XML, iList, and custom data sources
  • Master reports, themes, and styles
  • All of the features of previous versions of ActiveReports and Data Dynamics Reports

Windows Forms Report Viewer

  • Managed C# code
  • Very small deployment assembly, suitable for use on the Internet
  • Table of contents and bookmarks
  • Thumbnail view
  • HyperLinking
  • Annotations (section reports only)
  • Configurable scroll bar jump buttons (like those found in Microsoft® Word®)
  • Parameters
  • Bookmark links, hyperlinks and drillthrough links
  • Interactive sorting (page reports/RDL reports)
  • Touch mode

HTML5 Viewer

  • A Javascript component
  • Preview reports hosted on ActiveReports 10 Server or ActiveReports 10 Web Service
  • Provides multiple UI options
  • Ability to create a customized viewer
  • Touch mode support in Mobile UI

WPF Viewer

  • Managed C# code
  • Table of contents and bookmarks
  • Thumbnail view
  • Parameters
  • Annotations
  • Configurable scroll bar jump buttons (like those found in Microsoft® Word®)
  • Bookmark links, hyperlinks and drillthrough links
  • Interactive sorting

Export Filters

ActiveReports includes export filters to generate output into many popular formats.

Export formats | Section report | Page report/RDL report
Html: Export reports to HTML, DHTML, or MHT formats, all of which open in a Web browser. | ✓ | ✓
Pdf: Export reports to PDF, a portable document format that opens in the Adobe Reader. | ✓ | ✓
Rtf: Export reports to RTF, RichText format that opens in Microsoft Word, and is native to WordPad. | ✓ | ✓
Word: Export reports to DOC, a format that opens in Microsoft Word. | ✘ | ✓
Text: Export reports to TXT, plain text, a format that opens in Notepad or any text editor. Export reports to CSV, comma separated values, a format that you can open in Microsoft Excel. | ✓ | ✓
Image: Export reports to BMP, EMF, GIF, JPEG, or PNG image format. | ✘ | ✓
Tiff: Export reports to TIFF image format for optical archiving and faxing. | ✓ | ✓
Excel: Export reports to formats that open in Microsoft Excel, XLS or XLSX. | ✓ | ✓
Xml: Export reports to XML, a format that opens in a Web browser or delivers data to other applications. | ✘ | ✓

Import Filters

  • Access® Reports
  • Crystal Reports

Stand-Alone Applications

  • The Report Viewer application contains all the functionality of the ReportPreview control. It can be opened from the shortcut provided in the Start menu.
  • The WPF Viewer application contains all the functionality of the WPF Viewer control.

Professional Edition Features

The Professional Edition includes all of the features of the Standard Edition and supports the following additional features:

End-User Report Designer

The control is a run-time designer that may be distributed royalty-free. It allows the ActiveReports designer to be hosted in an application and provides end-user report editing capabilities. The control's methods and properties provide easy access for saving and loading report layouts, monitoring and controlling the design environment, and customizing the look and feel to the needs of end users.

Stand-Alone Applications

  • The Report Designer application contains all the functionality of the integrated Report Designer. It can be opened from the shortcut provided in the Start menu.

ASP.NET Integration

  • The Web server control provides convenience for running and exporting reports in ASP.NET.
  • HTTP Handler extensions allow report files (RPX or RDLX) or compiled assemblies containing reports to be dropped on the server and hyperlinked.

Silverlight Viewer Control

  • The Silverlight viewer control allows you to provide in- or out-of-browser report viewing in your Silverlight applications.
  • Like our other viewers, the Silverlight viewer control offers customization and localization.

WebViewer Control

  • The WebViewer control allows quick viewing of ActiveReports on the web as well as printing capability with the AcrobatReader ViewerType enumeration.
  • Flash ViewerType enumeration supports multiple browsers and offers customization and localization options.

HTTP Handlers

  • The RPX and RDLX HTTPHandler allows the developer to hyperlink ActiveReports on a web page to return HTML format or PDF format reports for viewing and/or printing.
  • The Compiled Report HTTPHandler allows the developer to hyperlink ActiveReports compiled in an assembly on a web page to return HTML format or PDF format reports for viewing and/or printing.

Table of Contents Control

  • TableOfContents control is used to display the document map, an organized hierarchy of the report heading levels and labels along with their page numbers, in the body of a report.
  • TableOfContents control allows you to quickly understand and navigate the data inside a report in all viewers that are supported in ActiveReports

Map Control

  • The Map data region shows your business data against a geographical background.
  • Create different types of map, depending on the type of information you want to communicate in your report.

PdfSignature and TimeStamp Features

  • The PdfSignature class allows you to provide PDF document digital signatures and certification.
  • The PdfStamp class allows you to draw the digital signatures and certification onto the documents.
  • The TimeStamp class allows you to add a TSA (Time Stamping Authority) stamp to your digital signatures.

Font Linking

  • Font linking helps you resolve the situation when fonts on a deployment machine do not have the glyphs that were used in a development environment.
  • By linking fonts, you can resolve the problem with a different PDF output on deployment and development machines that may occur due to the missing glyphs.

Font Fallback

  • If missing glyphs are not found in linked fonts, the PDF export filter looks for the glyphs in fonts declared in the FontFallback property.
  • A default font is used if you do not declare one, or you can declare an empty string for this property to leave out missing glyphs from the exported file.

PDF Export

  • PDF/A support in PDF Export.

Word Export

  • Export your reports in .docx format, a format that opens in Microsoft Word application.

Bold Font Emulation (PDF Export Filter)

Some fonts (for example, Franklin Gothic Medium, Microsoft Sans Serif, most East Asian fonts, etc.) may lose bold style for the PDF output. The Professional Edition provides bold style emulation in the PDF export filter to eliminate this limitation.

Comparison Between Editions

Professional Edition features are disabled or marked with an evaluation banner if you have purchased a Standard Edition license.

Features Standard Professional
Visual Studio Controls
Web Forms WebViewer: Use this control to display your reports on the Web. Includes viewer types HTML, PDF, and Flash. ✘ ✓
Silverlight Viewer: Use this control to display your reports in Silverlight 4 or higher, and for out-of-browser viewing. ✘ ✓
HTML5 Viewer: Use this Javascript component in web applications to preview reports hosted on ActiveReports 10 Server or ActiveReports 10 Web Service. ✓ ✓
HTTP Handlers: PDF and HTML (compiled report, RPX file) ✘ ✓
Windows Forms Viewer: Use this control to offer your users report zoom and preview, multiple tabs for hyperlinks, split-page and multi-page views, a Table of Contents pane, a Thumbnails pane, text searches, and annotations. ✓ ✓
Designer: Use this control to create a royalty-free, custom designer that your end users can use to create and modify their own reports. ✘ ✓
ReportExplorer: Use this control along with the Designer control to provide functionality to your users. ✘ ✓
ToolBox: Use this control along with the Designer control to provide report controls for your users. ✘ ✓
LayerList: Use this control along with the Designer control to provide Layers functionality to your users. ✓ ✓
WPF WPF Viewer: Use this control to display your section, page and RDL reports. The WPF Viewer offers the Thumbnails pane, the Parameters pane, the Document map pane, and the Search results pane. ✓ ✓
Web and Windows Forms HtmlExport: Export reports to HTML, DHTML, or MHT formats that open in a Web browser. ✓ ✓
PdfExport: Export reports to PDF, a portable document format that opens in the Adobe Reader. ✓ ✓
RtfExport: Export reports to RTF, RichText format that opens in Microsoft Word, and is native to WordPad. ✓ ✓
WordExport (.doc): Export reports to DOC (Word HTML), a format that opens in Microsoft Word. ✓ ✓
WordExport (.docx): Export reports to DOCX (Office Open XML), a format that opens in any word processing software. ✘ ✓
TextExport: Export reports to TXT, plain text, a format that opens in Notepad or any text editor.
This export filter can also export reports to CSV, comma separated values, a format that you can open in Microsoft Excel. 		✓ ✓
ImageExport: Export reports to BMP, EMF, GIF, JPEG, TIFF, or PNG image format.
Note that you can only export section reports to the TIFF image type. All other image types are for page reports and RDL reports. 		✓ ✓
XlsExport: Export reports to formats that open in Microsoft Excel, XLS or XLSX. ✓ ✓
XmlExport: Export reports to XML, a format that opens in a Web browser or delivers data to other applications. ✓ ✓
PDF Export Advanced Features Digital signatures ✘ ✓
Time stamp ✘ ✓
EUDC ✘ ✓
Select from Japanese embedded fonts or unembedded fonts ✘ *1 ✓
Bold ✘ ✓
Italic ✓ ✓
Multi Language ✓ *2 ✓
PDF/A Support ✘ ✓
Integrated Report Designer
Design Format

Section reports support banded layouts.
Page reports support fixed page layouts.
RDL reports support continuous page layout.

 ✓ ✓
Script and Code In section reports, you can add C# or VB code to events behind your code-based reports, or add script to events in the script editor in XML-based reports.
In page reports/RDL reports, you can use regular expressions in any property, plus you can add VB.NET methods to the code tab, and call them in your expressions. 		✓ ✓
Report File Formats You can save and load page reports/RDL reports in RDLX (extended RDL) format.
You can save and load section reports in RPX (report XML) format, and you can compile section reports in CS or VB code formats. 		✓ ✓
Report Controls The BarCode control supports all of the following styles:
ANSI 3 of 9 | ANSI Extended 3 of 9 | Code 2 of 5 | Interleaved 2 of 5
Code 25 Matrix | Code 39 | Extended Code 39 | Code 128 A
Code 128 B | Code 128 C | Code 128 Auto | Code 93
Extended Code 93 | MSI | PostNet | Codabar
EAN-8 | EAN-13 | UPC-A | UPC-E0
UPC-E1 | RoMail RM4SCC | UCC/EAN-128 | QRCode
Code 49 | Japanese Postal | Pdf417 | EAN-128 FNC1
RSS-14 | RSS-14 Truncated | RSS-14 Stacked | MicroPdf417
RSS-14 Stacked Omnidirectional | RSS Expanded | RSS Expanded Stacked |
✓ ✓
The Map control allows you to display data against a geographical background on the report. ✘ ✓

The TableofContents control allows you to display a document map in an organized hierarchy of the report heading levels and labels along with there page numbers, in the body of a report.

 ✘ ✓
The Chart control supports all of the following styles:

  • Common Charts: Area, Bar2D, Bezier, Doughnut/Pie, Line, Scatter, StackedArea, StackedBar, StackedArea100Pct, and StackedBar100Pct
  • 3D Charts: Area3D, Bar3D, ClusteredBar, Line3D, Doughnut3D/Pie, StackedBar3D, and StackedBar3D100Pct
  • XY Charts: Bubble, BubbleXY, LineXY, and PlotXY
  • Financial Charts: Candle, HiLo, and HiLoOpenClose
 ✓ ✓
Other report controls include:
Label | TextBox | CheckBox | Picture
Line | Shape | RichText | PageBreak
SubReport | ReportInfo | CrossSectionLine | CrossSectionBox
 ✓ ✓
Styles and Report Settings You can control page settings, printer settings, global settings such as grid display, grid size, and whether to show a verification dialog when deleting controls. You can specify row count or column count in grids, ruler units, and how many pages to display in previews. ✓ ✓
External Style Sheets You can reuse report designer styles by saving and loading style information in external files. ✓ ✓
Others The designer also offers snaplines, report preview, designer zoom, various formatting settings, control and text alignment settings, Z order settings, unbound fields, and parameters support. ✓ ✓
Input and Output
Data Supported data includes: ADO.NET data provider, ADO.NET data class (DataSet, DataTable, DataReader, DataView), Oracle data, XML data, and unbound data ✓ ✓
Printing You can control the page size, orientation, and margins, as well as specifying bound (double page spread), collating, duplex printing, and paper feed trays. ✓ ✓

*1: Japanese fonts can only be output as embedded fonts. *2: Cannot handle output of multiple language fonts in a single control. Please refer to Multi-Language PDF for details.

See Also

Getting Started

Getting Started

©2017. ComponentOne, a division of GrapeCity. All rights reserved.

Support Forum


Installation

Installation
ActiveReports 10 > ActiveReports User Guide > Welcome to ActiveReports 10 > Installation

This section helps you understand the installation process.

In this section:

Requirements
Learn about the hardware and software required to run ActiveReports.
Install ActiveReports
Find out how to install the ActiveReports Setup.
Installed Files
Find out what files are installed with ActiveReports and where to locate them.
Side-by-Side Installation
Learn about working with ActiveReports 9 and ActiveReports 8 on a single machine.
See Also

Getting Started

Getting Started

©2017. ComponentOne, a division of GrapeCity. All rights reserved.

Support Forum


Requirements

Requirements
ActiveReports 10 > ActiveReports User Guide > Welcome to ActiveReports 10 > Installation > Requirements

To install and use ActiveReports 10, you need the following hardware and software.

Hardware requirements (minimum)

  • Hard drive space: 200 MB available

Design Time Supported Environments

Windows Form, WPF, ASP.NET Application, HTML5 Viewer, Silverlight

  • Operating System:Windows 7, 8, 8.1, or 10, or Windows Server 2008, 2008 R2, 2012 or 2012 R2
  • Microsoft Visual Studio:2010, 2012, 2013 or 2015
    Note:
    • The Express Editions of Visual Studio do not work with ActiveReports, as they do not support packages.
    • ActiveReports supports Visual Studio Community 2015 beginning with ActiveReports 9.3.xxxx.x and above.

Run Time Supported Environments

Windows Form, WPF, ASP.NET (Server), HTML5 Viewer, Silverlight

  • Microsoft® .NET Framework Version: 3.5, 3.5 SP1, 4.0, 4.5, 4.5.1 or 4.6
  • .NET Framework Client Profile: 4.0, 4.5, 4.5.1 or 4.6
  • For Web deployment: IIS 7.0, 7.5, 8.0, 8.5, 10
  • Microsoft® Silverlight: 4, 5

ASP.NET Application (Client), HTML5 Viewer (Client)

  • Browser: Microsoft Internet Explorer9 or higher, Mozilla Firefox20 or higher, Google Chrome 30 or higher and Mobile Safari (iOS 6 and higher)
  • Flash Player: Adobe Flash Player 11, 12 and 13
See Also

Getting Started

Getting Started

Concepts

Concepts

©2017. ComponentOne, a division of GrapeCity. All rights reserved.

Support Forum


Install ActiveReports

Install ActiveReports
ActiveReports 10 > ActiveReports User Guide > Welcome to ActiveReports 10 > Installation > Install ActiveReports

Follow the steps below to install GrapeCity ActiveReports on your machine.

Note: Your machine setup may require you to be logged in as an Administrator to install new software. If this is the case and you do not have Administrator privileges, consult your system administrator.
  1. On your system, double-click the ActiveReports-v10.x.x.0.msi file or right-click the file and select Install.
  2. In the GrapeCity ActiveReports Setup window that appears, on the Welcome screen, click Next to continue with installation.
  3. On the End-User License Agreement screen that appears, go through the terms in the License Agreement, select the check-box to accept them and click Next to continue with installation.
  4. On the Installation Options screen that appears, optionally select GrapeCity ActiveReports Samples to install them with the product and click Next to continue with installation.
    Note: These samples help you in understanding different usage scenarios that the product offers.
  5. On the Licensing Options screen that appears, choose out of the three licensing options and click Install.
    • Evaluation
    • Activate now
    • Activate later
  6. Once the installation finishes, a screen notifying the completion of installation appears. Click Finish to close the window and complete the installation process.
See Also
Installed Files
Installation


Installed Files

Installed Files
ActiveReports 10 > ActiveReports User Guide > Welcome to ActiveReports 10 > Installation > Installed Files
Show All Show All
Hide All Hide All

You can verify your package installation by following the steps below:

  1. Open Visual Studio.
  2. From the Visual Studio Help menu, select About Microsoft Visual Studio and verify that ActiveReports 10 appears in the installed products list.

When you install ActiveReports and use all of the default settings, files are installed in the following folders:

C:\ProgramData\Microsoft\Windows\Start Menu\Programs\GrapeCity

File (or Folder) | Description
ActiveReports (folder) | Shortcut to the folder containing stand-alone applications and Samples folder. See the next dropdown for further details.
License Manager | Shortcut to the License Manager application.

C:\ProgramData\Microsoft\Windows\Start Menu\Programs\GrapeCity\ActiveReports 10

File (or Folder) | Description
ActiveReports 10 Designer | Shortcut to the stand-alone designer application.
ActiveReports 10 Import | Shortcut to the ActiveReports Import wizard application.
ActiveReports 10 Samples (folder) | Shortcut to the folder containing sample projects.
ActiveReports 10 Theme Editor | Shortcut to the ActiveReports Theme Editor application.
ActiveReports 10 User Guide(CHM) | Shortcut to the Compiled HTML help file for ActiveReports.
ActiveReports 10 User Guide(PDF) | Shortcut to the PDF help file for ActiveReports.
ActiveReports 10 User Guide(WEB) | Shortcut to the Online help file for ActiveReports.
ActiveReports 10 Viewer | Shortcut to the stand-alone ActiveReports Viewer application.

C:\Users\YourUserName\Documents\GrapeCity Samples\ActiveReports 10

Folder | Description
Data (folder) | Includes sample data files.
HTML5 Viewer (folder) | Includes HTML5 Viewer sample.
Page Reports And RDL Reports (folder) | Includes Page Report samples.
Professional (folder) | Includes Professional edition samples.
Reports Gallery (folder) | Includes ReportsGallery sample.
Section Reports (folder) | Includes Section Report samples.
Standard Edition Web (folder) | Includes Standard Edition Web sample.
WPF Viewer (folder) | Includes WPF Viewer sample.

C:\Program Files\GrapeCity\ActiveReports 10 (C:\Program Files (x86)\GrapeCity\ActiveReports 10 on a 64-bit Windows operating system)

File (or Folder) | Description
Deployment (folder) | Includes Flash viewer file, Flash viewer themes, Silverlight localization resources and templates for redistribution, templates for WPF and JavaScript files for HTML.
Icons (folder) | Includes associated Icons image files.
Localization (folder) | Includes Resource and DOS batch files for localizing ActiveReports components.

C:\Program Files\Common Files\GrapeCity\ActiveReports 10 (C:\Program Files (x86)\Common Files\GrapeCity\ActiveReports 10 on a 64-bit Windows operating system)

File (or Folder) | Description
Design (folder) | Includes GrapeCity.ActiveReports.Viewer.Silverlight.v10.VisualStudio.Design.4.0.dll assembly file.
License (folder) | Includes License Service assembly file.
redist (folder) | Includes native functions assembly for 64-bit machines.
zh-CN (folder) | Includes resource files for the Chinese environment.
ActiveReports.ReportService.asmx | Web service required for Web Site or Web Applications.
ApplicationLicenseGenerator.exe | Application License Generator setup file.
ApplicationLicenseGenerator.exe.config | License Manager setup XML configuration file.
DocumentFormat.OpenXml.dll | OpenXML assembly file.
GrapeCity.ActiveReports.Designer.exe | stand-alone designer setup file
GrapeCity.ActiveReports.Designer.exe.config | stand-alone designer setup XML configuration file
GrapeCity.ActiveReports.Imports.exe | ActiveReports Import application setup file.
GrapeCity.ActiveReports.Imports.exe.config | ActiveReports Import application setup XML configuration file.
GrapeCity.ActiveReports.Imports.Win.exe | ActiveReports Import wizard setup file.
GrapeCity.ActiveReports.Imports.Win.exe.config | ActiveReports Import wizard setup XML configuration file.
GrapeCity.ActiveReports.ThemeEditor.exe | ActiveReports Theme Editor setup file.
GrapeCity.ActiveReports.ThemeEditor.exe.config | ActiveReports Theme Editor setup XML configuration file.
GrapeCity.ActiveReports.Viewer.exe | Stand-Alone ActiveReports Viewer setup file.
GrapeCity.ActiveReports.Viewer.exe.config | Stand-Alone ActiveReports Viewer setup XML configuration file.
GrapeCity.ActiveReports.WpfViewer.exe | Stand-Alone ActiveReports WPF Viewer setup file.
GrapeCity.ActiveReports.WpfViewer.exe.config | Stand-Alone ActiveReports WPF Viewer setup XML configuration file.
ReportDesigner.Switcher.exe | Report Designer Switcher setup file.
ReportDesigner.Switcher.exe.config | Web Key Generator setup XML configuration file.
WebKeyGenerator.exe | Web Key Generator setup file.
WebKeyGenerator.exe.config | Web Key Generator setup XML configuration file.
Grapecity.ActiveReports.config | XML configuration file.
GrapeCity.ActiveReports.Calendar.v10.dll | Calendar control assembly file.
GrapeCity.ActiveReports.Chart.v10.dll | Chart control assembly file.
GrapeCity.ActiveReports.Dashboard.v10.dll | ActiveReports Dashboard assembly file.
GrapeCity.ActiveReports.Design.Win.v10.dll | Windows Designer assembly file.
GrapeCity.ActiveReports.Diagnostics.v10.dll | ActiveReports Diagnostics assembly file.
GrapeCity.ActiveReports.Document.v10.dll | Document assembly file.
GrapeCity.ActiveReports.Export.Document.v10.dll | Document Export assembly file.
GrapeCity.ActiveReports.Export.Html.v10.dll | HTML Export assembly file.
GrapeCity.ActiveReports.Export.Excel.v10.dll | Excel Export assembly file.
GrapeCity.ActiveReports.Export.Image.Unsafe.v10.dll | Image Export assembly file. (Unsafe version)
GrapeCity.ActiveReports.Export.Image.v10.dll | Image Export assembly file.
GrapeCity.ActiveReports.Export.Pdf.v10.dll | PDF Export assembly file.
GrapeCity.ActiveReports.Export.Rdf.v10.dll | RDF Export assembly file.
GrapeCity.ActiveReports.Export.Word.v10.dll | Word Export assembly file.
GrapeCity.ActiveReports.Export.Xaml.v10.dll | XAML Export assembly file.
GrapeCity.ActiveReports.Export.Xml.v10.dll | XML Export assembly file.
GrapeCity.ActiveReports.Extensibility.v10.dll | ActiveReports Extensibility assembly file.
GrapeCity.ActiveReports.Imports.Access.v10.dll | Microsoft Access Import assembly file.
GrapeCity.ActiveReports.Imports.Crystal.v10.dll | Crystal Reports Import assembly file.
GrapeCity.ActiveReports.Interop.v10.dll | Native functions assembly file.
GrapeCity.ActiveReports.OracleClient.v10.dll | Oracle Client assembly file.
GrapeCity.ActiveReports.Serializer.v10.dll | Serializer assembly file.
GrapeCity.ActiveReports.v10.dll | Run time engine assembly file.
GrapeCity.ActiveReports.Viewer.Silverlight.v10.dll | Silverlight Viewer assembly file.
GrapeCity.ActiveReports.Viewer.Win.v10.dll | Windows Viewer assembly file.
GrapeCity.ActiveReports.VisualStudio.v10.dll | Visual Studio assembly file.
GrapeCity.ActiveReports.Web.Design.v10.dll | Web Designer assembly file.
GrapeCity.ActiveReports.Web.v10.dll | Web assembly file.
GrapeCity.ActiveReports.Viewer.Wpf.v10.dll | WPF Viewer assembly file.

C:\Program Files\Common Files\GrapeCity\Components (C:\Program Files (x86)\Common Files\GrapeCity\Components on a 64-bit Windows operating system)

File (or Folder) | Description
GrapeCity.LicenseManager.exe | License Manager setup file.
GrapeCity.LicenseManager.exe.config | License Manager setup XML configuration file.


Side-by-Side Installation

Side-by-Side Installation
ActiveReports 10 > ActiveReports User Guide > Welcome to ActiveReports 10 > Installation > Side-by-Side Installation

Once ActiveReports 10 is installed on your system, it becomes the primary report designer. This means that when Visual Studio opens one of our proprietary file types, RPX or RDLX, it uses the ActiveReports 10 version of the following Visual Studio integrated features:

  • Integrated report designer
  • Report menu
  • ActiveReports toolbar
  • Report Explorer
  • Toolbox tabs

In ActiveReports , ReportDesigner.Switcher tool allows you to change packages which are registered in Visual Studio. You can change between ActiveReports 9 and ActiveReports 10 for the RPX designer and the RDLX designer.

Tip: You can still access some of the integrated features even if they are hidden.

  • Right-click in the Visual Studio toolbar area to select which toolbars to show.
  • The Visual Studio View menu, under Other Windows, lets you select Report Explorer versions.
  • Toolbox tabs are still visible for other versions, but ones that do not work with the current designer are disabled.

In order to work with ActiveReports 9 RPX reports, you must run the Switcher tool and change the Primary RPX designer to ActiveReports 9. If you don't, the reports open in the ActiveReports 10 designer, and the toolbar does not work. Switching between ActiveReports 9 and ActiveReports 10

  1. Close all instances of Visual Studio.
  2. In ...\Common Files\GrapeCity\ActiveReports 10, double-click ReportDesigner.Switcher.exe to run the switcher tool.
  3. In the dialog that appears, under Primary RPX designer, choose the radio button for the product you want to use and click OK.

Similarly, in order to work with RDLX reports, you must run the Switcher tool and choose the radio button for Primary RDLX designer.

See Also
Upgrading Reports
Breaking Changes


GrapeCity Copyright Notice

GrapeCity Copyright Notice
ActiveReports 10 > ActiveReports User Guide > Welcome to ActiveReports 10 > GrapeCity Copyright Notice

Information in this document, including URLs and web site references, is subject to change without notice. Unless otherwise noted, the example companies, organizations, products, domain names, e-mail addresses, logos, people, places and events depicted herein are fictitious, and no association with any real company, organization, product, domain name, e-mail address, logo, person, place or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. No part of this document may be reproduced, stored in, or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photo copying, recording, or otherwise), or for any purpose, without the express written permission of GrapeCity, inc.

The ActiveReports License Agreement constitutes written permission for Professional Edition licensees to copy documentation content for distribution with their end user designer applications so long as GrapeCity is given credit within the distributed documentation.

ActiveReports and the ActiveReports logo are registered trademarks of GrapeCity, inc.

All other trademarks are the property of their respective owners.

The following open source software is used in ActiveReports.

  • PDF Export/ Rendering Extensions
    iTextSharp v4.1.7.7
    Zlib
  • Designer
    jquery v2.1.0
    jQuery-ui v1.10.4
    Bootstrap v3.0.1
    bootstrap-treeview.js v1.0.0
    jQuery.event.drag v2.2
    jQuery.livequery v1.3.6
    jQuery.nicescroll v3.5.4
    Knockout v3.1.0
    knockout-handlebars.js v0.0.6
    korest.js v0.0.7
    Sharp Express
    Irony
    JSON.NET 7.0
  • Web Viewer
    jQuery v1.7.2
    jquery.layout v1.2.0
    JSON2 knockout.js v2.1.0
    SWFObject v2.2
    jQuery UI v1.8.16
    jQuery Timepicker Addon v1.4.5
    jsTree v1.0-rc3
    JSON.NET 7.0
  • HTML5 Viewer
    parseUri v1.2.2
    bootstrapSwitch v1.3
    spin.js v2.3.2
    jquery.spin.js
    Modernizr v2.7.1
  • Samples
    jquery.js v1.10.2
    knockout.js v2.3.0
    bootstrap.js v3.0.0
See Also
End User License Agreement


End User License Agreement

End User License Agreement
ActiveReports 10 > ActiveReports User Guide > Welcome to ActiveReports 10 > End User License Agreement

The End-User license agreement is available online at http://activereports.grapecity.com/Pages/ActiveReportsEULA/.

Please read carefully before installing this software package. Your installation of the package indicates your acceptance of the terms and conditions of this license agreement. Contact GrapeCity Inc. if you have any questions about this license.

See Also
GrapeCity Copyright Notice


.NET Framework Client and Full Profile Versions

.NET Framework Client and Full Profile Versions
ActiveReports 10 > ActiveReports User Guide > Welcome to ActiveReports 10 > .NET Framework Client and Full Profile Versions

All ActiveReports assemblies are compliant with .NET Framework 3.5 Full profile and .NET Framework 4.0 Full profile.

The following assemblies are compliant with .NET Framework 3.5 Client Profile and .NET Framework 4.0 Client Profile:

File | Description
GrapeCity.ActiveReports.v10.dll | Run-time engine assembly file.
GrapeCity.ActiveReports.Chart.v10.dll | Chart control assembly file.
GrapeCity.ActiveReports.Document.v10.dll | Document assembly file.
GrapeCity.ActiveReports.Interop.v10.dll | Native functions assembly file.
GrapeCity.ActiveReports.Export.Pdf.v10.dll | PDF Export assembly file.
GrapeCity.ActiveReports.Export.Word.v10.dll | RTF Export assembly file.
GrapeCity.ActiveReports.Export.Xml.v10.dll | Text Export assembly file.
GrapeCity.ActiveReports.Export.Image.v10.dll | TIFF Export assembly file.
GrapeCity.ActiveReports.Viewer.Win.v10.dll | Viewer assembly file.
GrapeCity.ActiveReports.Export.Excel.v10.dll | Microsoft® Excel® Export assembly file.
GrapeCity.ActiveReports.Extensibility.v10.dll | Extensibility assembly file.
GrapeCity.ActiveReports.Export.Document.v10.dll | Document assembly file.
GrapeCity.ActiveReports.Export.Image.Unsafe.v10.dll | Image Export assembly file. (Unsafe version)
GrapeCity.ActiveReports.Diagnostics.v10.dll | ActiveReports Diagnostics assembly file.
GrapeCity.ActiveReports.Export.Rdf.v10.dll | RDF Export assembly file.
DocumentFormat.OpenXml.dll | OpenXML assembly file.
GrapeCity.ActiveReports.Export.Xaml.v10.dll | XAML Export assembly file.
GrapeCity.ActiveReports.Viewer.Wpf.v10.dll WPF Viewer assembly file.
Note: Does not support .NET Framework 3.5 Full Profile.

The following assemblies are not compliant with .NET Framework 3.5 Client Profile and .NET Framework 4.0 Client Profile:

File | Description
GrapeCity.ActiveReports.Design.Win.v10.dll | Designer assembly file.
GrapeCity.ActiveReports.Export.Html.v10.dll | HTML Export assembly file.
GrapeCity.ActiveReports.Web.v10.dll | Web assembly file.
GrapeCity.ActiveReports.OracleClient.v10.dll | Oracle Client assembly file.
GrapeCity.ActiveReports.Calendar.v10.dll | Calendar control assembly file.
GrapeCity.ActiveReports.Dashboard.v10.dll | ActiveReports Dashboard assembly file.
GrapeCity.ActiveReports.Interop64.v10.dll | Native functions assembly file.（x64）

The End User Report Designer, the WebViewer control, the HTML Export filter, and the WPF Viewer require the full profile.

See Also

Concepts

Designer Control (Pro Edition)


Redistributable Files

Redistributable Files
ActiveReports 10 > ActiveReports User Guide > Welcome to ActiveReports 10 > Redistributable Files

ActiveReports is developed and published by GrapeCity, Inc. You may use it to develop applications in conjunction with Microsoft Visual Studio or any other programming environment that enables the user to use and integrate the control(s). You may also distribute, free of royalties, the following Redistributable Files with any such application you develop to the extent that they are used separately on a single CPU on the client/workstation side of the network:

  • DocumentFormat.OpenXml.dll
  • GrapeCity.ActiveReports.Calendar.v10.dll
  • GrapeCity.ActiveReports.Chart.v10.dll
  • GrapeCity.ActiveReports.Dashboard.v10.dll
  • GrapeCity.ActiveReports.Design.Win.v10.dll
  • GrapeCity.ActiveReports.Diagnostics.v10.dll
  • GrapeCity.ActiveReports.Document.v10.dll
  • GrapeCity.ActiveReports.Export.Document.v10.dll
  • GrapeCity.ActiveReports.Export.Html.v10.dll
  • GrapeCity.ActiveReports.Export.Excel.v10.dll
  • GrapeCity.ActiveReports.Export.Image.Unsafe.v10.dll
  • GrapeCity.ActiveReports.Export.Image.v10.dll
  • GrapeCity.ActiveReports.Export.Pdf.v10.dll
  • GrapeCity.ActiveReports.Export.Rdf.v10.dll
  • GrapeCity.ActiveReports.Export.Word.v10.dll
  • GrapeCity.ActiveReports.Export.Xaml.v10.dll
  • GrapeCity.ActiveReports.Export.Xml.v10.dll
  • GrapeCity.ActiveReports.Extensibility.v10.dll
  • GrapeCity.ActiveReports.Imports.Access.v10.dll
  • GrapeCity.ActiveReports.Imports.Crystal.v10.dll
  • GrapeCity.ActiveReports.Interop.v10.dll
  • GrapeCity.ActiveReports.OracleClient.v10.dll
  • GrapeCity.ActiveReports.Serializer.v10.dll
  • GrapeCity.ActiveReports.v10.dll
  • GrapeCity.ActiveReports.Viewer.Silverlight.v10.dll
  • GrapeCity.ActiveReports.Viewer.Win.v10.dll
  • GrapeCity.ActiveReports.Viewer.Wpf.v10.dll
  • GrapeCity.ActiveReports.VisualStudio.v10.dll
  • GrapeCity.ActiveReports.Web.Design.v10.dll
  • GrapeCity.ActiveReports.Web.v10.dll
  • GrapeCity.ActiveReports.Interop64.v10.dll
  • Grapecity.ActiveReports.Flash.v10.swf
  • Grapecity.ActiveReports.Flash.v10.Resources.swf
  • Themes\FluorescentBlue.swf
  • Themes\Office.swf
  • Themes\OliveGreen.swf
  • Themes\Orange.swf
  • Themes\VistaAero.swf
  • Themes\WindowsClassic.swf
  • Themes\XP.swf
  • DefaultSLViewerTemplates.xaml
  • DefaultWPFViewerTemplates.xaml
  • GrapeCity.ActiveReports.Viewer.Html.css
  • GrapeCity.ActiveReports.Viewer.Html.js
  • GrapeCity.ActiveReports.Viewer.Html.min.js
Note: See Installed Files for the location of the files listed above.
See Also
Welcome to ActiveReports 10


License Your ActiveReports

License Your ActiveReports
ActiveReports 10 > ActiveReports User Guide > License Your ActiveReports
Show All Show All
Hide All Hide All

You can use the GrapeCity License Manager utility to license ActiveReports during installation or if you already have a trial version installed. This topic gives an overview of all aspects of licensing in ActiveReports.

License Types

See ActiveReports Editions to learn which features are exclusive to the Professional Edition.

License Type | Description
Evaluation | Trial key is required. Evaluation banners display on all reports and controls, and the product stops functioning after 30 days from the date of installation. The first key is already activated when you download the trial. If needed, you can request a new key from the Sales department for an additional 30 day trial.
Standard | Standard Edition product key is required. Evaluation banners appear only on features that are exclusive to the Professional Edition. You receive this key by email when you purchase ActiveReports Standard Edition or upgrade from a previous version of ActiveReports Standard Edition.
Professional | Professional Edition product key is required. All reporting functionality and controls appear without any evaluation banners. You receive this key by email when you purchase ActiveReports Professional Edition or upgrade from a previous version of ActiveReports Professional Edition.

If you cannot find your email with the product key, please contact activereports.sales@grapecity.com to have it looked up.

Licensing a Developer Machine

Note that any machine on which ActiveReports are opened in Visual Studio or on which ActiveReports projects are compiled in Visual Studio must be licensed.

Tip: Always run the License Manager as Administrator.

To license a machine with ActiveReports during installation or to license a trial without reinstalling

  1. From the Start menu, go to All Programs > GrapeCity > License Manager, or during installation, select Activate now and the dialog will appear automatically.
  2. In the GrapeCity License Manager window that appears, under Action click Activate.

  3. On the Activate ActiveReports 10 dialog that appears, click the Next button.
  4. In the Enter a Product Key screen that appears next, enter the following information:
    • User Name: Enter your name here.
    • Organization: Enter your company name here.
    • Email: Enter your e-mail address here.
    • Product Key: Enter the product key exactly as you received it from GrapeCity, including any capital letters. When you enter the product key, a green check mark appears next to this field to indicate a valid key.
  5. Click the Next and then the Finish button to complete the licensing process.

To license ActiveReports on a machine without an internet connection

  1. At the time of installation, on the last screen a check box that states Run license manager appears. Select this checkbox and click the Close button to complete the installation.
  2. In the GrapeCity License Manager window that appears, under the Action field, click Activate.
  3. In the Activate ActiveReports 10 screen that appears, click the Next button.
  4. In the Enter a Product Key screen that appears next, enter the following information:
    • User Name: Enter your name here.
    • Organization: Enter your company name here.
    • Email: Enter your e-mail address here.
    • Product Key: Enter the product key exactly as you received it from GrapeCity, including any capital letters. When you enter the product key, a green check mark appears next to this field to indicate a valid key.
  5. Click the Next button to authenticate the license.
  6. If your machine does not have an internet connection, select the Use a browser on another machine with Internet connectivity option from the following screen and click the Next button.
  7. From the Activate using the GrapeCity web site screen that appears, copy the Product Key and Authentication Number.
  8. On another machine with an internet connection, go to https://sas.grapecity.com/activation. Remember not to close the activation dialog on your original machine until the activation process is complete.
  9. Enter the Product Key and Authentication Number you copied in step 7 on this website.
  10. Click the Send Request button to generate a license key.
  11. Copy the license key from the web page that looks like the following image and in the Activate using GrapeCity web site dialog under step 3, enter the key.
  12. Click the Next and then the Finish button to complete the licensing process.

To activate a license for ActiveReports on multiple machines

You can only activate a single developer license key for ActiveReports on three machines for use by one developer.

If you have used all three of the license activations and you want to license a fourth machine, for example, a virtual machine for use by the same licensed developer, you must deactivate the license key from one of the other machines. For more information, drop down the section below titled "To deactivate an ActiveReports license."

After you have deactivated licensing on one of the machines, you can activate ActiveReports on another machine.

Note: Deactivate your ActiveReports license before formatting a machine to avoid loss of activation. If this happens by accident, you can contact our support team for help.

To deactivate an ActiveReports license

To use your ActiveReports license on another machine for your own use when you have used up all three of your activations, you can deactivate it on one machine.

  1. From the Start menu, go to All Programs > GrapeCity > License Manager.
  2. In the GrapeCity License Manager window that appears, under Action click Deactivate.
  3. In the Deactivate ActiveReports 10 page that appears, select the Next button.
  4. In the Confirm the Product screen that appears, confirm that the correct product is getting deactivated and click the Next button.
  5. The Deactivation Successful screen appears with the Product Name as ActiveReports 10 and the Current Status as Trial License (number of days left).

To upgrade or downgrade a license

Note: In order to upgrade or downgrade a license on a machine, you must have installed both a Professional and a Standard license on the machine. If you have not, the Upgrade/Downgrade column does not appear in the License Manager. If you have one and wish to install the other, you must first deactivate the installed license. The Upgrade/Downgrade option is added at that point.

If you want to change your ActiveReports license type you need to do one of the following:

Upgrade from a Standard to a Professional License:

  1. From the Start menu, go to All Programs > GrapeCity > License Manager.
  2. In the GrapeCity License Manager window that appears, under Upgrade/Downgrade click Upgrade to Professional License.
  3. Follow the activation steps from step 3 of To license an ActiveReports Trial without reinstalling to upgrade.

Downgrade from a Professional to a Standard License:

  1. From the Start menu, go to All Programs > GrapeCity > License Manager.
  2. In the GrapeCity License Manager window that appears, under Upgrade/Downgrade, click Downgrade to Standard License.
  3. In the Deactivate ActiveReports 10 page that appears, select the Next button.
  4. In the Confirm the Product screen that appears, confirm that the correct product is being downgraded and click the Next button.
  5. The Deactivation Successful screen appears with the Product Name as ActiveReports 10 and the Current Status as Standard License.

Note: You can upgrade a license only if you buy an upgrade from Standard Edition to Professional Edition.

To determine whether a machine is licensed

  1. In Visual Studio, open any sample from the included samples located in C:\Users\USERNAME\Documents\GrapeCity Samples\ActiveReports 10.
  2. Open one of the reports in the sample and click the Preview tab.
  3. Scroll to the bottom of the report. If there is red evaluation text, the machine is not licensed.

Note: To check for Professional Edition licensing, open a sample from the Professional folder, run it, and look for evaluation messages.

Licensing a Project

Tips:

  • To deploy using XCOPY, you must include the DLLs for all of your ActiveReports references in your bin/debug folder. To do this, in the Visual Studio Solution Explorer, select each reference, and in the Properties window, set Copy Local to True and rebuild your solution.
  • To avoid having to change the version number every time you install an ActiveReports service pack, in the Visual Studio Solution Explorer, select each reference, and in the Properties window, set Specific Version to False.

To license Windows Forms projects made on the trial version

These steps assume that you already have an ActiveReports licensed edition installed on your system.

  1. Open the project in Microsoft Visual Studio.
    Note: If another application calls the one containing ActiveReports features, you must license the calling application to avoid evaluation banners after deployment.
  2. Go to the Visual Studio Build menu and select Rebuild Solution.
  3. To verify that the application is licensed, open the licenses.licx file and compare it to the Required references section below.

The executable application is now licensed, and no nag screens or evaluation banners appear when you run it. You can distribute the application to unlicensed machines and no nag screens or evaluation banners appear.

Required references in the licenses.licx file (for Standard and Professional Editions)

The licenses.licx file must contain the following references to ActiveReports if you were using both Section and Page reports, and both Windows and WPF viewers. See the table below for the references to the ActiveReports version and the reference to the Viewer control.

Note: The Version, Culture, and PublicKeyToken information is added automatically, but can be removed, and should be removed if the version is wrong.
Paste INSIDE the licenses.licx file.
Copy Code
GrapeCity.ActiveReports.SectionReport, GrapeCity.ActiveReports.v10
GrapeCity.ActiveReports.PageReport, GrapeCity.ActiveReports.v10
GrapeCity.ActiveReports.Viewer.Win.Viewer, GrapeCity.ActiveReports.Viewer.Win.v10
GrapeCity.ActiveReports.Viewer.Wpf.Viewer, GrapeCity.ActiveReports.Viewer.Wpf.v10

Here are all of the license strings that you may need:

Component | License String
Section report engine | GrapeCity.ActiveReports.SectionReport, GrapeCity.ActiveReports.v10
Page and RDL report engine | GrapeCity.ActiveReports.PageReport, GrapeCity.ActiveReports.v10
WinForms viewer control | GrapeCity.ActiveReports.Viewer.Win.Viewer, GrapeCity.ActiveReports.Viewer.Win.v10
WPF viewer control | GrapeCity.ActiveReports.Viewer.Wpf.Viewer, GrapeCity.ActiveReports.Viewer.Wpf.v10
PRO (some features) PDF export | GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport, GrapeCity.ActiveReports.Export.Pdf.v10
PRO ONLY: WebViewer, HTTP handlers, Web service | GrapeCity.ActiveReports.Web.WebViewer, GrapeCity.ActiveReports.Web.v10
PRO ONLY: End-user designer | GrapeCity.ActiveReports.Design.Designer, GrapeCity.ActiveReports.Design.Win.v10

Note: When using the PDF export filter in your project, make sure you check the licenses.licx file for reference to the PDF Export Assembly.

To license Web Forms projects made on the trial version

Follow these steps after you license ActiveReports on your machine.

  1. Open the project in Microsoft Visual Studio.
  2. Open the Visual Studio Build menu and select Rebuild Solution.
  3. The web site application is now licensed. You can distribute the web site application to unlicensed machines and no evaluation banners appear.

To license Web Site applications

Follow these steps after you license ActiveReports on your machine.

  1. Open the project in Visual Studio.
  2. Open the Visual Studio Build menu and select Build Runtime Licenses to create the App_Licenses.dll file.
  3. The web site application is now licensed. You can distribute the web site application to unlicensed machines and no evaluation banners appear.

To license medium trust projects

To provide licensing for medium trust projects with ActiveReports, you can generate a web key using the Web Key Generator utility on a machine with licensed ActiveReports.

  1. From the ...\Common Files\GrapeCity\ActiveReports 10 folder, run the WebKeyGenerator.exe.
  2. In the dialog that appears, click Copy.
    Note: In your web.config file, if you already have content in your <configuration> and <appSettings> elements, you can use the first Copy button to copy only the web key. If not, you can use the second Copy button to copy the whole <configuration> section.
  3. In your project web.config file, between the opening and closing <configuration> tags (or in place of them, if they are empty) paste the web key so that it looks like the following.
    XML code. Paste INSIDE the Web.config file
    Copy Code
    <configuration>
<appSettings>
<add key=" ActiveReports 10 License" value="Generated Web Key" />
</appSettings>
</configuration>
Note: If you see the message "Your computer is not currently licensed" in the Web Key Generator dialog, please license your machine.

To license a class library project

Follow these steps after you license ActiveReports on your machine.

  1. Open the project for the root-level calling application, that is, the executable that calls your class library, in Visual Studio.
    Note: If you do not have access to this project, see "To license ActiveReports when you cannot compile the calling application."
  2. From the Project menu, select Add New Item, and the select an ActiveReports report. (You can delete it later. This is only to add the references to the project.)
  3. Open the Visual Studio Build menu and select Rebuild Solution.
  4. Check the licenses.licx file and verify that ActiveReports licensing is added for all of the features used in your project.
Note: If you use other ActiveReports features in your class library that are still showing an evaluation banner, for example, features exclusive to the Professional Edition, you can add those references manually and rebuild the solution.

To license ActiveReports when you cannot compile the calling application or the calling application is COM

When you are not able to compile the calling application in .NET, whether because you don't have access to build a third-party project, or because the calling application is COM, you can still license ActiveReports using the Application License Generator utility.

Definition: A calling application is the root-level application that the user initiates to eventually access your compiled assembly. This could be an executable, a web page, a COM executable, etc.

IMPORTANT: This is the ONLY reason you should ever use the Application License Generator.

Follow these steps after you license ActiveReports on your machine.

  1. From the ...\Common Files\GrapeCity\ActiveReports 10 folder, run the ApplicationLicenseGenerator.exe. If you are using a Windows 7 or higher machine, right click the executable file and select Run As Administrator.

  2. Click the Browse button and select the compiled dll that requires licensing.
  3. In the Assembly description field, enter the description for the assembly that you are licensing. You can later view this description by right-clicking the licensed assembly.
  4. Click the Generate button.
  5. Distribute the generated file <AssemblyName>.GrapeCity.Licenses.dll along with the application.

Licensing Errors

Here are some common licensing errors and their causes.

Error | Cause
Application cannot run because it was built with no license. | Licensing is not present in the application or the calling application. See below for information on how to license the calling application.
License for XXXX (control name) could not be found. | Extra lines for components that you do not use are in the licenses.licx file. Delete unnecessary information and Rebuild the project.
Licensing has not been correctly applied to the application. | Check the three key points below.
Exception (LicenseException) | Check the three key points below.
  1. Ensure that the license file is added to the appropriate project.

    The licenses.licx file is automatically generated in the project where ActiveReports is used. But if your application is composed of multiple projects and another project calls the reports defined in your class library, you need to register it in the calling project rather than just in your report project.

    When you add an ActiveReports web service to a Page report, RDL report, or XML-based Section report project, the licenses.licx file is not created automatically, and the license strings are not added. You also need to manually add licensing to your application if you want to create a control at run time or use the HTTP handlers.

    To manually add licensing to the calling application

    Note: In a C# Windows Forms project, the license file is in the Properties folder. In a Visual Basic project, it is in the My Project folder.

    1. In your application that contains ActiveReports components, check that the proper licensing strings are in the licenses.licx file. (See the table of license strings below.)

    2. Copy the ActiveReports strings from the file into the licenses.licx file in the calling application.
    a. If there is no license file, from the Project menu, select Add New Item.
    b. From the listed templates, select Text file and change the name to "licenses.licx."
    c. In the Solution Explorer, double-click the newly created licenses.licx file to open it, and paste in the licensing strings for all components you use.

    3. From the Build menu, select Rebuild Project to embed the licensing.

    ​Note: If your project is a web site, the bin folder has the licenses embedded in the App_Licenses.dll file.
  2. Ensure that the contents of the license file are correct.

    Depending on which features of ActiveReports you use in your application, the license file may need to contain multiple license strings.

    You will find a full list of license strings that you may need in the Required references in the licenses.licx file (for Standard and Professional Editions) section above.

  3. Ensure that the Build Action property is configured correctly for the license file.

    1. In the Solution Explorer, select licenses.licx (you may need to click the Show all files button to see it).

    2. In the Properties window, ensure that the Build Action property is set to Embedded Resource.


Upgrading Reports

Upgrading Reports
ActiveReports 10 > ActiveReports User Guide > Upgrading Reports
Show All Show All
Hide All Hide All

ActiveReports 10 allows you to upgrade from ActiveReports and Data Dynamics reports.

Upgrading ActiveReports and Data Dynamics Reports Projects

You can automatically update reports and corresponding reference assemblies using the ActiveReports 10 Upgrade tool, and then handle any additional errors in the code.

Important: Be sure to create a backup for your project before starting the upgrade process.

To upgrade project references and reports

  1. In Visual Studio, open an existing ActiveReports or Data Dynamics Reports project that you want to upgrade.
  2. From the Visual Studio Tools menu, select Convert to ActiveReports 10.
  3. In the ActiveReports 10 Upgrade tool window that appears, you can see a list of report files to be converted.
  4. Click OK to upgrade the project.

To handle errors in code

The ActiveReports 10 Upgrade tool upgrade the reports and corresponding reference assemblies, but the updated namespaces, types and types members may break the code.

  1. With the upgraded project open in Visual Studio, from the View menu, select Error List to get the list of errors to be fixed in code.
  2. In the Error List window, double-click each error in turn to jump to the code where you can fix the error.

Examples of code that might break and how to fix it:

  • Update the Viewer control by replacing DataDynamics.ActiveReports.Viewer.Viewer with GrapeCity.ActiveReports.Viewer.Win.Viewer.
  • Replace existing property names with new property names. For example, MultiplePageCols property is changed to MultiPageCols.

For a list of changes from the previous version, see Breaking Changes.

See Also
Breaking Changes


Breaking Changes

Breaking Changes
ActiveReports 10 > ActiveReports User Guide > Upgrading Reports > Breaking Changes
Show All Show All
Hide All Hide All

When you upgrade reports from previous versions of ActiveReports or Data Dynamics Reports, there are several breaking changes.

Control Changes from Previous ActiveReports Versions to ActiveReports 10

The Excel Transformation Device option, the File menu item Microsoft Excel WorkSheet - Data (XLS), is no longer available for RDL reports in the default export dialogs of the viewer and designer applications shipped with the product. For backward compatibility, the Excel Transformation Device API is still available, but it does not support the new Tablix control. In order to successfully export reports using the new Tablix control, please use the Excel Rendering Extension option, the File menu item Microsoft Excel WorkSheet - Layout (XLS, XLSX).

The Matrix data region has been replaced in the toolbox with the new Tablix data region. However, it is still available in the API for backward compatibility. See the Matrix Class in the Class Library.

The OleObject control is now hidden by default in the toolbox for Section reports. To show this control in Visual Studio, open the GrapeCity.ActiveReports.config file and change the EnableOleObject value to true, and include this file with your application. You can find this file in a path like the following. C:\Program Files (x86)\GrapeCity\ActiveReports 10.

To show the OleObject control in the Designer control in your own end users designer applications, select the Designer control and, in the Properties window, change the EnableOleObject property to True.

The WebViewer control is now AJAX-based, and requires ActiveReports.ReportService.asmx to be in the root of the Web site or Web application. This is added automatically when you drop a WebViewer control on a Web form, or you can add it from the Add New Item dialog by selecting ActiveReports 10 Web Service, or manually by copying it from C:\Program Files (x86)\Common Files\GrapeCity\ActiveReports 10. ExceptionOccurring, QueuingReport, ReportCreating and ReportDisposing events are no longer available in WebViewer class.

The Viewer control no longer has Annotations turned on by default. To enable Annotations, set the AnnotationDropDownVisible property of the Viewer control to True. DataDynamics.ActiveReports.Viewer.ReportViewer.MultiplePageMode property is now integrated into ViewType property of Viewer class. Viewer.ReportViewer.PaperColor property has been removed. Viewer.PageOffset property's type has been changed from Integer to System.Drawing.Point.

The Toolbar is now a Windows ToolStrip. Please see the MSDN ToolStrip Class for more information.

Other Changes

Rendering Extensions (Image) - ColorDepth is an obsolete property of GrapeCity.ActiveReports.Export.Image.Page.Settings class.

Classes in Different Namespaces

In ActiveReports 10, some classes have been moved to different namespaces from previous versions of ActiveReports and Data Dynamics Reports. Drop down the table below to see some of the most commonly used classes that are in new namespaces.

Classes that are in new namespaces

Class Name | New Namespace | Former Namespace
Report | GrapeCity.ActiveReports.PageReportModel | DataDynamics.Reports.ReportObjectModel
SectionReport (formerly ActiveReport) | GrapeCity.ActiveReports | DataDynamics.ActiveReports
PageReport (formerly ReportDefinition) | GrapeCity.ActiveReports | DataDynamics.Reports
SectionDocument (formerly Document) | GrapeCity.ActiveReports.Document | DataDynamics.ActiveReports.Document
SystemPrinter | GrapeCity.ActiveReports | DataDynamics.ActiveReports.Interop
Printer | GrapeCity.ActiveReports.Extensibility.Printing | DataDynamics.ActiveReports.Document
Field | GrapeCity.ActiveReports.Data.Field | DataDynamics.ActiveReports.Field
FieldCollection | GrapeCity.ActiveReports.Data.FieldCollection | DataDynamics.ActiveReports.FieldCollection
ReportExplorer | GrapeCity.ActiveReports.Design.ReportExplorer.ReportExplorer | DataDynamics.ActiveReports.Design.ReportExplore
Images | GrapeCity.ActiveReports.Design.Resources.Images | DataDynamics.ActiveReports.Design.Images
Exports |  |
HtmlExport | GrapeCity.ActiveReports.Export.Html.Section | DataDynamics.ActiveReports.Export.Html
PdfExport | GrapeCity.ActiveReports.Export.Pdf.Section | DataDynamics.ActiveReports.Export.Pdf
PdfSignature | GrapeCity.ActiveReports.Export.Pdf.Section.Signing | DataDynamics.ActiveReports.Export.Pdf.Signing
PdfStamp | GrapeCity.ActiveReports.Export.Pdf.Section.Signing | DataDynamics.ActiveReports.Export.Pdf.Signing
RtfExport | GrapeCity.ActiveReports.Export.Word.Section | DataDynamics.ActiveReports.Export.Rtf
TextExport | GrapeCity.ActiveReports.Export.Xml.Section | DataDynamics.ActiveReports.Export.Text
TiffExport | GrapeCity.ActiveReports.Export.Image.Tiff.Section | DataDynamics.ActiveReports.Export.Tiff
XlsExport | GrapeCity.ActiveReports.Export.Excel.Section | DataDynamics.ActiveReports.Export.Xls
ImageRenderingExtension | GrapeCity.ActiveReports.Export.Image.Page | DataDynamics.Reports.Rendering.Graphics
HtmlRenderingExtension | GrapeCity.ActiveReports.Export.Html.Page | DataDynamics.Reports.Rendering.Html
PdfRenderingExtension | GrapeCity.ActiveReports.Export.Pdf.Page | DataDynamics.Reports.Rendering.Pdf
XmlRenderingExtension | GrapeCity.ActiveReports.Export.Xml.Page | DataDynamics.Reports.Rendering.Xml
WordRenderingExtension | GrapeCity.ActiveReports.Export.Word.Page | DataDynamics.Reports.Rendering.Word
ExcelTransformationDevice | GrapeCity.ActiveReports.Export.Excel.Page | DataDynamics.Reports.Rendering.Excel
Report Controls |  |
Barcode ChartControl CheckBox CrossSectionBox CrossSectionLine Label Line OleObject PageBreak Picture ReportInfo RichTextBox Shape SubReport TextBox | GrapeCity.ActiveReports.SectionReportModel | DataDynamics.ActiveReports
Chart CheckBox Container CustomReportItem Image Line List Tablix OverflowPlaceHolder Shape Table TextBox | GrapeCity.ActiveReports.PageReportModel | DataDynamics.Reports.ReportObjectModel

Namespace Changes and Restructuring

Some of the changes that are not picked up by the upgrade tool may cause some issues in your code. The two most frequently encountered changes are:

  • DataDynamics.ActiveReports.ActiveReport is now GrapeCity.ActiveReports.SectionReport
  • DataDynamics.ActiveReports.Document.Document is now GrapeCity.ActiveReports.Document.SectionDocument

These are all of the assemblies and namespaces that have changed, with any major changes noted.

ActiveReports is now GrapeCity.ActiveReports.v10

  • ActiveReport class is now called SectionReport.
  • BarWidth property is now called NarrowBarWidth.
ActiveReports Namespace (previous versions) | ActiveReports 10 Namespace
DataDynamics.ActiveReports
  • GrapeCity.ActiveReports
  • GrapeCity.ActiveReports.SectionReportModel
  • GrapeCity.ActiveReports.Data
DataDynamics.ActiveReports.DataSources | GrapeCity.ActiveReports.Data
DataDynamics.ActiveReports.Interop GrapeCity.ActiveReports
DataDynamics.ActiveReports.Options GrapeCity.ActiveReports.SectionReportModel

ActiveReports.Chart is now GrapeCity.ActiveReports.Chart.v10

ActiveReports Namespace (previous versions) | ActiveReports 10 Namespace
DataDynamics.ActiveReports.Chart | GrapeCity.ActiveReports.Chart
DataDynamics.ActiveReports.Chart.Annotations | GrapeCity.ActiveReports.Chart.Annotations
DataDynamics.ActiveReports.Chart.Graphics | GrapeCity.ActiveReports.Chart.Graphics

ActiveReports.Design is now GrapeCity.ActiveReports.Design.Win.v10

The Report property is now an Object that gets or sets a GrapeCity.ActiveReports.Document.SectionDocument or GrapeCity.ActiveReports.Document.PageDocument.

The ColorTheme property of the Designer class is deprecated.

ActiveReports Namespace (previous versions) | ActiveReports 10 Namespace
DataDynamics.ActiveReports.Design | GrapeCity.ActiveReports.Design
DataDynamics.ActiveReports.Design.ReportExplorer | GrapeCity.ActiveReports.ReportExplorer
DataDynamics.ActiveReports.Design.Toolbox | GrapeCity.ActiveReports.Design.Toolbox

ActiveReports.Document is now GrapeCity.ActiveReports.Document.v10

The Document class is now called SectionDocument.

ActiveReports Namespace (previous versions) | ActiveReports 10 Namespace
DataDynamics.ActiveReports | GrapeCity.ActiveReports
DataDynamics.ActiveReports.Document
  • GrapeCity.ActiveReports.Document
  • GrapeCity.ActiveReports.Document.Section
  • GrapeCity.ActiveReports.Extensibility.Printing(GrapeCity.ActiveReports.Extensibility.v10)
DataDynamics.ActiveReports.Export | GrapeCity.ActiveReports.Export
DataDynamics.ActiveReports.Export.Html | GrapeCity.ActiveReports.Export.Html
DataDynamics.ActiveReports.Document.Annotations | GrapeCity.ActiveReports.Document.Section.Annotations

ActiveReports.HtmlExport is now GrapeCity.ActiveReports.Export.Html.v10

ActiveReports Namespace (previous versions) | ActiveReports 10 Namespace
DataDynamics.ActiveReports.Export.Html | GrapeCity.ActiveReports.Export.Html.Section

ActiveReports.PdfExport is now GrapeCity.ActiveReports.Export.Pdf.v10

ActiveReports Namespace (previous versions) | ActiveReports 10 Namespace
DataDynamics.ActiveReports.Export.Pdf | GrapeCity.ActiveReports.Export.Pdf.Section
DataDynamics.ActiveReports.Export.Pdf.Signing | GrapeCity.ActiveReports.Export.Pdf.Section.Signing

ActiveReports.RtfExport is now GrapeCity.ActiveReports.Export.Word.v10

ActiveReports Namespace (previous versions) | ActiveReports 10 Namespace
DataDynamics.ActiveReports.Export.Rtf | GrapeCity.ActiveReports.Export.Word.Section

ActiveReports.Silverlight is now GrapeCity.ActiveReports.Viewer.Silverlight.v10

ActiveReports Namespace (previous versions) | ActiveReports 10 Namespace
DataDynamics.ActiveReports | GrapeCity.ActiveReports

ActiveReports.TextExport is now GrapeCity.ActiveReports.Export.Xml.v10

ActiveReports Namespace (previous versions) | ActiveReports 10 Namespace
DataDynamics.ActiveReports.Export.Text | GrapeCity.ActiveReports.Export.Xml.Section

ActiveReports.TiffExport is now GrapeCity.ActiveReports.Export.Image.v10

ActiveReports Namespace (previous versions) | ActiveReports 10 Namespace
DataDynamics.ActiveReportsExport.Tiff | GrapeCity.ActiveReports.Export.Image.Tiff.Section

ActiveReports.Viewer is now GrapeCity.ActiveReports.Viewer.Win.v10

  • The History class is now an interface, IHistoryApi, that resides in the GrapeCity.Viewer.Common namespace.
  • The SearchResultsForeColor property now gets applied as the border around the searched text.
  • The DisplayUnits and RulerVisible properties of the Viewer class have been removed as the Viewer no longer uses a ruler.
  • The TabTitleLength property of the Viewer class is not available as the tab function of the Viewer has been removed.
  • The ViewerToolbar.DisplayToolTips property of the Viewer.ViewerToolbar class is now ViewerToolbar.ToolStrip.ShowItemToolTips.
  • The ViewerToolbar.Enabled property of the Viewer.ViewerToolbar class is now ViewerToolbar.ToolStrip.Enabled.
  • The ViewerToolbar.Visible property of the Viewer.ViewerToolbar class is now ViewerToolbar.ToolStrip.Visible.
  • The TargetView enumeration now has two enumeration values (Primary and Secondary).
  • The ToggleVisibility() method is now Visible property that determines whether sidebar is visible or hidden.
  • The Print method is implemented as an extension method of the PrintExtension.Print method, which is present in Grapecity.ActiveReport namespace of GrapeCity.ActiveReports.Viewer.Win.v10 assembly.
ActiveReports Namespace (previous versions) | ActiveReports 10 Namespace
DataDynamics.ActiveReports.Toolbar | The viewer now uses Visual Studio ToolStrips. Please see MSDN ToolStrip Class for more information.
DataDynamics.ActiveReports.Viewer
  • GrapeCity.ActiveReports.Viewer.Win
  • GrapeCity.Viewer.Common
Note: GrapeCity.ActiveReports.Viewer.Win.v10.dll does not get added automatically to the project references when the report layout is added. You need to either add the Viewer control or manually add the reference to this assembly.

ActiveReports.Web is now GrapeCity.ActiveReports.Web.v10

The Report property is now an Object that gets or sets a SectionDocument or ReportDocument.

ActiveReports Namespace (previous versions) | ActiveReports 10 Namespace
DataDynamics.ActiveReports.Web | GrapeCity.ActiveReports.Web
DataDynamics.ActiveReports.Web.Controls | GrapeCity.ActiveReports.Web.Controls
DataDynamics.ActiveReports.Web.ExportOptions | GrapeCity.ActiveReports.Web.ExportOptions
DataDynamics.ActiveReports.Web.Handlers | GrapeCity.ActiveReports.Web.Handlers

ActiveReports.XlsExport is now GrapeCity.ActiveReports.Export.Excel.v10

ActiveReports Namespace (previous versions) | ActiveReports 10 Namespace
DataDynamics.ActiveReports.Export.Xls | GrapeCity.ActiveReports.Export.Excel.Section
DataDynamics.SpreadBuilder | GrapeCity.SpreadBuilder
DataDynamics.SpreadBuilder.Cells | GrapeCity.SpreadBuilder.Cells
DataDynamics.SpreadBuilder.Imaging | GrapeCity.SpreadBuilder.Imaging
DataDynamics.SpreadBuilder.Printing | GrapeCity.SpreadBuilder.Printing
DataDynamics.SpreadBuilder.Style | GrapeCity.SpreadBuilder.Style
See Also
Upgrading Reports


Converting Crystal Reports/MS Access Reports

Converting Crystal Reports/MS Access Reports
ActiveReports 10 > ActiveReports User Guide > Upgrading Reports > Converting Crystal Reports/MS Access Reports
Show All Show All
Hide All Hide All

You can convert a Crystal Reports report or a Microsoft Access report to an ActiveReports format by running the ActiveReports Import Wizard.

Running the ActiveReports Import Wizard

  1. From the Start Menu, go to All Programs > GrapeCity > ActiveReports > ActiveReports Import.
  2. In the ActiveReports Import Wizard that appears, click Next to proceed to the conversion process.
  3. Choose Microsoft Access (mdb) or Crystal Reports (rpt) as the input format and click Next to convert the selected report.
  4. Browse to the location that contains the Microsoft Access file or Crystal Reports using the ellipsis button. Once you select the location, a list of available reports appear in the dialog.
  5. Select the reports to import and click Next to analyze the selected reports.
  6. Use the ellipsis button to select a destination folder to store the converted reports. Also select an output format (Section Report, Page Report, RDL Report or All) for each report in the Output Format column.
  7. Click Next to start the conversion.
  8. Once the conversion process is complete, click Finish to close the wizard and go the destination folder to view the converted reports. You may optionally leave the check on for the Open Log file checkbox to see the results log.

The import wizard converts reports to the closest possible ActiveReports format, but due to differences between products and versions, the extent to which your reports are converted depends on your specific report layout. You may have to partially redesign the report and add script or code to get the same output as Microsoft Access Reports or Crystal Reports.

When converting to Page Reports or RDL Reports, whether a report is imported as a Page Report or RDL Report, depends on the following factors:

  • If a report has a single detail section it is imported as a Page Report.
  • If a report has a SubReport control it is imported as a RDL Report.
  • If a report has a Tablix control and its layout is composed of multiple sections it is imported as a RDL Report.
Note: Sections in a report appear as BandedList.

Please refer to the additional information below, to understand the conversion process in detail.

Converting Crystal Reports

To convert Crystal Reports into ActiveReports format, you need to install Visual Studio and Crystal Reports for Visual Studio on your machine. The supported versions of Visual Studio and corresponding Crystal Reports are as follows:

Visual Studio | Editions | Crystal Reports | Assembly Version
2008 | Professional, Team System | Crystal Reports for Visual Studio 2008 | 10.5.3700.0
2010 | ... | SAP Crystal Reports, developer version for Microsoft Visual Studio | 13.x.x.x
2012 | ... | SAP Crystal Reports, developer version for Microsoft Visual Studio | 13.x.x.x
2013 | ... | SAP Crystal Reports, developer version for Microsoft Visual Studio | 13.x.x.x

Crystal Report controls are converted in ActiveReports as follows:

Crystal Report | Section Report | Page Report/RDL Report | Note
Box | Shape | Container | The LineWidth property and rounded boxes are not imported. If the Box control extends to multiple sections, the box is imported as line controls.
CrossTab | SubReport | BandedList | CrossTab control is not imported as it is.
Line | Line | Line | The size of Dot and Dash (the LineStyle property) is not the same as the original report.
Subreport | SubReport | Subreport | Set the subreport in code after conversion.
TextObject | Label | Textbox | Only page number, total page, page n of m in Special Fields are imported.
FieldObject | TextBox | Textbox | Only page number, total page, page n of m in Special Fields are imported.
Picture | ... | Container | Picture object is not converted.

Converting Microsoft Access Reports

To convert Microsoft® Access® reports into ActiveReports format, you must have Access 97, 2000, 2002, 2003 or 2007 installed on your system.

Microsoft Access report controls are converted in ActiveReports as follows:

Microsoft Access Report | Section Report | Page Report/RDL Report | Note
Rectangle | Shape | Container | Controls placed inside the Rectangle control are also imported along with the parent control.
CheckBox | Label | Textbox | ...
Image | ... | Image | Image control is not converted while converting to a Section Report.
Label | Label | Textbox | ...
Textbox | TextBox | Textbox | ...
Line | Line | Line | ...
Page Break | PageBreak | Container | In Page Reports and RDL Reports, the PageBreakAtEnd property is automatically set to True on importing a Page Break control.
Subform/Subreport | SubReport | Subreport | ...

Limitations in Crystal Report/MS Access conversion

  • Any controls, functions, and text formats which are not supported by ActiveReports are not converted.
  • The shadow property of a control is not imported while converting a report.
  • The OLE object is not in Crystal Reports is not imported as it is treated as PictureObject in the object structure.
  • In Microsoft Access reports, VBA code appears in as commented statements in script. You have to modify the code after importing.
See Also
Upgrading Reports

Concepts

Toolbox
Section Report Toolbox


Getting Started

Getting Started
ActiveReports 10 > ActiveReports User Guide > Getting Started

Quickly begin using ActiveReports by reviewing some of the most commonly used features.

This section contains information about

Adding ActiveReports Controls
Learn how to add ActiveReports controls to the toolbox in Visual Studio.
Adding an ActiveReport to a Project
Learn how to add an ActiveReport to a Visual Studio project. Also in this section, learn about the different types of reports and how to add code or script to each.
Adding a Data Source to a Report
Learn about the different ways that you can add data to each type of report, and where to find more information on each.
Adding an ActiveReports Application
Learn how to add an ActiveReports application to the Visual Studio project and avoid additional implementation rendering the report in the Viewer.
Connecting to ActiveReports Server
Learn how to connect to ActiveReports Server using the stand-alone designer and the Visual Studio designer to access shared resources.

See Also

Concepts

Concepts

Welcome to ActiveReports

Welcome to ActiveReports 10

How To

How To

Walkthroughs

Samples and Walkthroughs


Adding ActiveReports Controls

Adding ActiveReports Controls
ActiveReports 10 > ActiveReports User Guide > Getting Started > Adding ActiveReports Controls

You can add an ActiveReport to a project without using the Visual Studio toolbox, but in order to use the Viewer control, any of the exports, the Designer and related controls, or the WebViewer control, you need to have them in your toolbox.

The installer generally adds the controls to the Visual Studio toolbox in an ActiveReports 10 tab. However, if they are removed for any reason, you can re-add them at any time.

To add the controls

  1. Right-click the Visual Studio toolbox tab where you want to add ActiveReports controls and select Choose Items.
  2. In the Choose Toolbox Items window that appears, on the .NET Framework Components tab, in the Filter textbox, enter GrapeCity.ActiveReports.
  3. Select the check boxes next to any of the controls that you want to add to your toolbox:
    • Viewer
    • WebViewer
    • Designer
    • ReportExplorer
    • Toolbox
    • HtmlExport
    • PdfExport
    • RtfExport
    • TextExport
    • TiffExport
    • XlsExport
  4. For the Silverlight Viewer control, go to the Silverlight Components tab and select Viewer.
  5. Click OK to add the controls to the selected toolbox tab.

.NET Framework Version

The following features all require the .NET Framework full profile version.

  • Designer control
  • WebViewer control
  • HTMLExport
  • Oracle data provider
  • Calendar control
  • Sparkline or Bullet control
  • Native Functions (Interop64)

To ensure that you are using the full profile version in a VB project

  1. From the Visual Studio Project menu, select YourProject Properties.
  2. On the Compile tab, click the Advanced Compile Options button.
  3. In the Advanced Compiler Settings dialog that appears, drop down the Target framework field and select a version that does not specify Client Profile.

To ensure that you are using the full profile version in a C# project

  1. From the Visual Studio Project menu, select YourProject Properties.
  2. On the Application tab, drop down the Target framework field and select a version that does not specify Client Profile.
Caution: ActiveReports controls may not appear in the toolbox unless your project is using .NET 3.5 or later.
See Also
Adding an ActiveReport to a Project
Windows Forms Viewer


Adding an ActiveReport to a Project

Adding an ActiveReport to a Project
ActiveReports 10 > ActiveReports User Guide > Getting Started > Adding an ActiveReport to a Project

To use ActiveReports in a Visual Studio project, you add one of the included report templates.

Show All Show All
Hide All Hide All

To add an ActiveReport to a project

  1. From the Visual Studio Project menu (or Website menu in Web projects), select Add New Item.
  2. Select the type of report that you want to add (for information on the differences, see Report Types):
    • Section Report (code-based)
    • Section Report (xml-based)
    • Page Report
    • RDL Report
  3. In the Name box, type a name for the report, and click Add. The selected report type is added to your project and opens in the report designer.
Note: When you add a report layout the Viewer assembly (GrapeCity.ActiveReports.Viewer.Win.v10.dll) is not added automatically to the project references. You may need to manually add it in your project if required.

To add an ActiveReport to a project at runtime

  1. In Visual Studio, create a new Windows Forms Application or open an existing one.
  2. From the Visual Studio toolbox, drag the Viewer control onto your Windows Form.
  3. Set the Viewer's Dock property to Fill to show the complete Viewer control on the form.
  4. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  5. Add the following code inside the Form_Load event.

Page Report

Visual Basic.NET code. Paste INSIDE the Form Load event.
Copy Code
' Create a new Page report instance
Dim pageReport As New GrapeCity.ActiveReports.PageReport()
Dim Page As New GrapeCity.ActiveReports.PageReportModel.Page()
Dim fixedPage As New GrapeCity.ActiveReports.PageReportModel.FixedPage()

' Add a textbox to your Page report
Dim textbox1 As New GrapeCity.ActiveReports.PageReportModel.TextBox()
textbox1.Name = "TextBox1"
textbox1.Height = "1cm"
textbox1.Width = "10cm"
textbox1.Left = "2cm"
textbox1.Top = "0.5cm"
textbox1.Value = "Sample Page Report"
Page.ReportItems.Add(textbox1)
fixedPage.Pages.Add(Page)
pageReport.Report.Body.ReportItems.Add(fixedPage)

' Create a Page document and load it in Viewer
Dim pageDocument As New GrapeCity.ActiveReports.Document.PageDocument(pageReport)
viewer1.LoadDocument(pageDocument)
C# code. Paste INSIDE the Form Load event.
Copy Code
// Create a new Page report instance
GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport();
GrapeCity.ActiveReports.PageReportModel.Page Page = new GrapeCity.ActiveReports.PageReportModel.Page();
GrapeCity.ActiveReports.PageReportModel.FixedPage fixedPage = new GrapeCity.ActiveReports.PageReportModel.FixedPage();

// Add a textbox to your Page report
GrapeCity.ActiveReports.PageReportModel.TextBox textbox1 = new GrapeCity.ActiveReports.PageReportModel.TextBox();
textbox1.Name = "TextBox1";
textbox1.Height = "1cm";
textbox1.Width = "10cm";
textbox1.Left = "2cm";
textbox1.Top = "0.5cm";
textbox1.Value = "Sample Page Report";
Page.ReportItems.Add(textbox1);
fixedPage.Pages.Add(Page);
pageReport.Report.Body.ReportItems.Add(fixedPage);

// Create a Page document and load it in Viewer
GrapeCity.ActiveReports.Document.PageDocument pageDocument = new GrapeCity.ActiveReports.Document.PageDocument(pageReport);
viewer1.LoadDocument(pageDocument);

RDL Report

Visual Basic.NET code. Paste INSIDE the Form Load event.
Copy Code
' Create a new RDL report instance
Dim rdlReport As New GrapeCity.ActiveReports.PageReport()

' Add a textbox to your RDL report
Dim textbox1 As New GrapeCity.ActiveReports.PageReportModel.TextBox()
textbox1.Name = "TextBox1"
textbox1.Height = "1cm"
textbox1.Width = "10cm"
textbox1.Left = "2cm"
textbox1.Top = "0.5cm"
textbox1.Value = "Sample RDL Report"
rdlReport.Report.Body.ReportItems.Add(textbox1)

' Create an RDL document and load it in Viewer
Dim rdlDocument As New GrapeCity.ActiveReports.Document.PageDocument(rdlReport)
viewer1.LoadDocument(rdlDocument)
C# code. Paste INSIDE the Form Load event.
Copy Code
// Create a new RDL report instance
GrapeCity.ActiveReports.PageReport rdlReport = new GrapeCity.ActiveReports.PageReport();

// Add a textbox to your RDL report
GrapeCity.ActiveReports.PageReportModel.TextBox textbox1 = new GrapeCity.ActiveReports.PageReportModel.TextBox();
textbox1.Name = "TextBox1";
textbox1.Height = "1cm";
textbox1.Width = "10cm";
textbox1.Left = "2cm";
textbox1.Top = "0.5cm";
textbox1.Value = "Sample RDL Report";
rdlReport.Report.Body.ReportItems.Add(textbox1);

// Create an RDL document and load it in Viewer
GrapeCity.ActiveReports.Document.PageDocument rdlDocument = new GrapeCity.ActiveReports.Document.PageDocument(rdlReport);
viewer1.LoadDocument(rdlDocument);

Section Report

Visual Basic.NET code. Paste INSIDE the Form Load event.
Copy Code
' Create a new Section report instance
Dim sectionReport As New GrapeCity.ActiveReports.SectionReport()

' Create a Detail section
sectionReport.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail, "Body")

' Add a textbox to your Section report
Dim textbox1 As New GrapeCity.ActiveReports.SectionReportModel.TextBox()
textbox1.Name = "TextBox1"
textbox1.Height = 1.5F
textbox1.Width = 10.0F
textbox1.Left = 0.5F
textbox1.Top = 0.5F
textbox1.Value = "Sample Section Report"
sectionReport.Sections(0).Controls.Add(textbox1)

' Load the Section report in the Viewer
sectionReport.Run()
viewer1.LoadDocument(sectionReport)
C# code. Paste INSIDE the Form Load event.
Copy Code
// Create a new Section report instance
GrapeCity.ActiveReports.SectionReport sectionReport = new GrapeCity.ActiveReports.SectionReport();

// Create a Detail section
sectionReport.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail, "Body");

// Add a textbox to your Section report
GrapeCity.ActiveReports.SectionReportModel.TextBox textbox1 = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
textbox1.Name = "TextBox1";
textbox1.Height = 1.5F;
textbox1.Width = 10F;
textbox1.Left = 0.5F;
textbox1.Top = 0.5F;
textbox1.Value = "Sample Section Report";
sectionReport.Sections[0].Controls.Add(textbox1);

// Load the Section report in the Viewer
sectionReport.Run();
viewer1.LoadDocument(sectionReport);
See Also
Adding ActiveReports Controls

Concepts

ActiveReports Designer


Adding a Data Source to a Report

Adding a Data Source to a Report
ActiveReports 10 > ActiveReports User Guide > Getting Started > Adding a Data Source to a Report

The first thing you probably want to do when you create a report is to add data. You can accomplish this in a variety of ways, depending on the type of report you are using.

Page Report/RDL Report Data

With page reports or RDL reports, you basically connect to a data source, and then add a dataset. You can also create a shared data source if you use the same one for many reports. For information on how to perform these tasks, see Work with Data in the How To section. For more information on each item in the associated dialogs, see Data Sources and Datasets in the Concepts section.

For more advanced ways to connect data, see the Walkthroughs section for step by step instructions on using Reports with Stored Procedures, or creating a Custom Data Provider.

Section Report Data

With section reports, you bind a report to any of a variety of data sources and select the data using a SQL query or XPath expression in the Data Source Dialog. You can also use code to create an unbound data source or to change the data source at run time. For more information on all of these methods of binding reports to data, see Work with Data in the Section Report How To section.

See Also
Shared Data Sources
Server Shared Data Sets

Concepts

Grouping Data in Section Reports
Grouping Data (Page Layout)


Adding an ActiveReports Application

Adding an ActiveReports Application
ActiveReports 10 > ActiveReports User Guide > Getting Started > Adding an ActiveReports Application

ActiveReports provides an in-built sample application that includes a report template along with the Viewer control. You learnt about creating a report and viewing it in the preceding topics. See Adding an ActiveReport to a Project and Viewing Reports for further details. With this Windows Forms application you only need to create a report layout and run the application to view the report, effectively skipping the manual process of adding a Viewer and template separately and creating an instance of the report.

To add an ActiveReports application to a project

  1. From the Visual Studio File menu, select New, then Project.
  2. In the New Project dialog that appears, under your desired language (VB.NET or C#), click the Reporting node.
  3. Select the type of report application that you want to add (for information on the differences, see Report Types):
    • ActiveReports 10 Page Report Application
    • ActiveReports 10 RDL Report Application
    • ActiveReports 10 Section Report Application (xml-based)
    • ActiveReports 10 Section Report Application (code-based)
  4. In the Name field, enter a name for the report application, and click OK. The selected report type is added to your project.
  5. Go to the Visual Studio Solution Explorer and double-click Form1.cs or Form1.vb. Notice that the Viewer control already appears on the form.
    Note: If you run the application right after the new report project is created, a blank report appears on the Form.
See Also
Getting Started
Adding ActiveReports Controls


Connecting to ActiveReports Server
ActiveReports 10 > ActiveReports User Guide > Getting Started > Connecting to ActiveReports Server

ActiveReports makes the access to shared resources such as, shared datasets, shared data sources, .etc. on the ActiveReports Server easy with a single Connect to Server option. Once connected to ActiveReports Server, the connection information is stored for the current session. Therefore the Connect to Server option reduces the report author’s effort to specify the connection information every time a shared resource is accessed from the ActiveReports Server. Reports designed using shared resources are executed on ActiveReports Server.

Connecting to ActiveReports Server

  1. Access the Connect to Server option from the stand-alone designer or the Visual Studio designer.

    In Stand-alone Designer

    Access the Connect To Server dialog from the Server menu of stand-alone designer.

    In Visual Studio Designer

    Access the Connect To Server dialog from the Report menu of Visual Studio designer.

  2. In the Connect To Server dialog that appears, type the Server URL (Uniform Resource Locator). The server URL is specified as "http://<ServerName>:<PortNumber>/" where the Server Name is the name of the machine on which ActiveReports Server is installed and Port Number is the port on IIS where the server is installed. Example: http://1.0.0.0:8080/

  3. Enter the Username and Password and then click the [image] button for connecting ActiveReports Designer to ActiveReports Server. A green server icon below the design surface indicates that you are connected to ActiveReports Server.The tooltip for the server icon specifies the server URL to which ActiveReports is connected. Once connected, you can access all the shared resources on the ActiveReports Server.

Disconnecting from ActiveReports Server

In the stand-alone designer, click the Server menu and then select Disconnect from server. In Visual Studio Designer, navigate to the Report menu>Server and click Disconnect From Server. A red server icon below the design surface indicates that you are disconnected from ActiveReports Server.

See Also
ActiveReports Server
Shared Data Sources
Server Shared Data Sets


Viewing Reports

Viewing Reports
ActiveReports 10 > ActiveReports User Guide > Viewing Reports

ActiveReports provides a number of ways to view your report output. You have an option of previewing the report as you create it in a Visual Studio project at design time.

Previewing Reports at Design Time

ActiveReports makes it easy for you to preview your report while you are still creating it. Click the Preview tab at the bottom of the designer and see the output as it appears in a viewer. See Designer Tabs for further information.

With the in-built Viewers for Windows Forms, Web and Silverlight, you can view your report in any of these platforms as well in a separate viewer control. In ActiveReports, Windows Forms Viewer and WPF Viewer also supports previewing of reports that are hosted on ActiveReports Server.

The following topics introduce all the available report viewing options.

In this section

Windows Forms
This section explains how to view a report in the Windows Forms Viewer and demonstrates the Viewer's features, touch gestures and shortcut keys.
ASP.NET
This section introduces the Web Viewer where you can view your report output in various types of viewers and provides key features of each viewer type.
HTML5
Learn about the features available with the HTML5 Viewer.
Silverlight
This section describes how to view a report in the Silverlight viewer and introduces its toolbar and features.
WPF
This section describes the WPF Viewer toolbar, its additional features and how to view a report in the WPF viewer.
ReportService Settings
This section describes ReportService settings used in Web Viewers.
ActiveReports Server
This section describes how to view a report that is hosted on ActiveReports Server.
Medium Trust Support
Learn about the features and limitations available in Medium Trust Support environment.


Windows Forms Viewer

Windows Forms Viewer
ActiveReports 10 > ActiveReports User Guide > Viewing Reports > Windows Forms Viewer
Show All Show All
Hide All Hide All

Besides previewing your report at design time, you can also view the reports you design in the Viewer. This viewer contains a toolbar and a sidebar with Thumbnails, Search results, Document map, and Parameters panes.

Viewer Toolbar

The following table lists the actions you can perform through the Viewer toolbar.

Toolbar Element | Name | Description
First page | Takes you to the first page of the report. This button is enabled when a page other than the first page is open.
Last page | Takes you to the last page of the report. This button is disabled on reaching the last page of the report.
Previous page | Takes you to the page prior to the current page. This button is enabled when a page other than the first page is open.
Next page | Takes you to the page following the current page. This button is disabled on reaching the last page of the report.
Current page | Opens a specific page in the report. To view a specific page, type the page number and press the Enter key.
Backward | Takes you to the last viewed page. This button is enabled when you move to any page from the initial report page. Clicking this button for the first time also enables the Forward button.
Forward | Takes you to last viewed page before you clicked the Backward button. This button is enabled once you click the Backward button.
Back to parent report | Returns you to the parent report in a drillthrough report.
Default | Allows you to specify a default mouse pointer mode.
Pan mode | A hand symbol serves as the cursor that you can use to navigate.
Selection mode | Allows you to select contents on the report. Click the Copy icon (see image and description below) to copy the selected content to the clipboard.
Snapshot mode | Allows you to select content on the report that you can paste as an image into any application that accepts pasted images.
Toggle sidebar | Displays the sidebar that includes the Thumbnails, Parameters, Document map and Search results panes.
Print | Displays the Print dialog where you can specify the printing options.
Galley mode | Provides a viewer mode which removes automatic page breaks from a Report Definition Language (RDL) and displays data in a single page. This mode maintains page breaks you create in the report and removes only automatic page breaks.
Copy Copies text that you select in the Selection mode to the clipboard.
Note: In case the GrapeCity.ActiveReports.Export.Xml.v10.dll and GrapeCity.ActiveReports.Export.Word.v10.dll are not available in GAC, you might need to add references to these assembly files to enable the viewer's Copy button.
Find | Displays the Find dialog to find any text in the report.
Zoom out | Decreases the magnification of your report.
Current zoom | Displays the current zoom percentage which can also be edited.
Zoom in | Increases the magnification of your report.
Fit width | Fits the width of the page according to viewer dimensions.
Fit page | Fits the whole page within the current viewer dimensions.
Single page view | Shows one page at a time in the viewer.
Continuous view | Shows all preview pages one below the other.
Multipage view | Offers you an option to select how many pages to preview in the viewer at one time.
Refresh Refreshes the report.

Caution: Refresh button gets disabled when you load a section report in the Viewer control through any of the following:

  • Document Property
  • LoadDocument(SectionDocument) Method
  • LoadDocument(String) Method
Cancel | Cancels the report rendering.
Touch Mode Allows you to select touch mode for the Viewer.
Note: The Touch Mode button only appears on the toolbar while working on touch enabled devices.

Viewer Sidebar

The Viewer sidebar appears on the left of the Viewer control when you click the Toggle sidebar button in the toolbar. By default, this sidebar shows the Thumbnails and Search Results panes. The additional Document map and Parameters also appear in this sidebar. You can toggle between any of the viewer panes by clicking the buttons for each pane at the bottom of the sidebar.

Thumbnails pane

The Thumbnails pane appears by default in the sidebar when you click the Toggle sidebar button in the toolbar.

This pane is composed of a thumbnail view of all the pages in a report. Click any thumbnail to navigate directly to the selected report page. You can also modify the size of the thumbnail when you click (+) or (-) button to zoom in and zoom out.

Search results pane

The Search pane is the other default pane besides Thumbnails that appears in the sidebar when you click the Toggle sidebar button. This pane lets you enter a word or phrase from which to search within the report.

To search in a report:

  • Enter the word or phrase in the search field.
  • Under Use these additional criteria, you may optionally choose to search for the whole word or match the case of the search string while searching in the report.
  • Click the Search button to see the results appear in the Find results list.
  • Click an item in the list to jump to that item in the report and highlight it.

To start a new search or clear the current search results, click the Clear button under the Find results list.

Document map pane

The Documents map pane is enabled for reports where the Label property or the Document map label is set. This pane displays each value for the text box, group, or sub report that you label, and you can click them to navigate to the corresponding area of the report in the Viewer.

If a report does not have the Label property or Document map label set, the Documents map pane does not appear in the sidebar.

Parameters pane

The Viewer allows you to view reports with parameters. In the toolbar, click the Toggle sidebar button to open the Viewer sidebar and if your report contains parameters, the Parameters pane shows up automatically.
  1. In the Parameters pane, you are prompted to enter a value by which to filter the data to display.
  2. Enter a value or set of values and click View report, to filter the report data and display the report.

If a report does not have parameters, the Parameters pane does not appear in the sidebar.

Display Report Output in the Viewer

The following code examples demonstrate how you can display the report output in the Viewer.

  1. In a Visual Studio Windows Forms application, from the Visual Studio toolbox, drag the Viewer control onto your Windows Form.
  2. Set the viewer's Dock property to Fill to show the complete Viewer control on the Form.
  3. Double-click the title bar of the Form to create an event-handling method for the Form_Load event.
  4. In the Form_Load event, add code like the following to run the report and display it in the viewer. Each of these code snippets presumes a report in the project of the type indicated with the default name. (If you have renamed your report, you need to rename it in the code as well)

    To write the code in Visual Basic.NET

    The following example demonstrates how you display a page report in the Viewer control.

    Visual Basic. NET code. Paste INSIDE the Form_Load event.
    Copy Code
    Dim file_name As String = "..\..\PageReport1.rdlx"
Dim pageReport As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(file_name))
Dim pageDocument As New GrapeCity.ActiveReports.Document.PageDocument(pageReport)
Viewer1.LoadDocument(pageDocument)

    The following example demonstrates how you display a RDL Report in the Viewer control.

    Visual Basic. NET code. Paste INSIDE the Form_Load event.
    Copy Code
    Dim file_name As String = "..\..\RdlReport1.rdlx"
Dim pageReport As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(file_name))
Dim pageDocument As New GrapeCity.ActiveReports.Document.PageDocument(pageReport)
Viewer1.LoadDocument(pageDocument)

    The following example demonstrates how you can display a section report (code-based) in the Viewer control.

    Visual Basic. NET code. Paste INSIDE the Form_Load event.
    Copy Code
    Dim sectionReport As New SectionReport1()
Viewer1.LoadDocument(sectionReport)

    The following example demonstrates how you can display a section report (xml-based) in the Viewer control.

    Visual Basic. NET code. Paste INSIDE the Form_Load event.
    Copy Code
    Dim sectionReport As New GrapeCity.ActiveReports.SectionReport()
Dim xtr As New System.Xml.XmlTextReader("..\..\SectionReport1.rpx")
sectionReport.LoadLayout(xtr)
xtr.Close()
Viewer1.LoadDocument(sectionReport)

    To write the code in C#

    The following example demonstrates how you display a page report in the Viewer control.

    C# code. Paste INSIDE the Form_Load event.
    Copy Code
    string file_name = @"..\..\PageReport1.rdlx";
GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(file_name));
GrapeCity.ActiveReports.Document.PageDocument pageDocument = new GrapeCity.ActiveReports.Document.PageDocument(pageReport);
viewer1.LoadDocument(pageDocument);

    The following example demonstrates how you display a RDL Report in the Viewer control.

    C# code. Paste INSIDE the Form_Load event.
    Copy Code
    string file_name = @"..\..\RdlReport1.rdlx";
GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(file_name));
GrapeCity.ActiveReports.Document.PageDocument pageDocument = new GrapeCity.ActiveReports.Document.PageDocument(pageReport);
viewer1.LoadDocument(pageDocument);

    The following example demonstrates how you can display a section report (code-based) in the Viewer control.

    C# code. Paste INSIDE the Form_Load event.
    Copy Code
    SectionReport1 sectionReport = new SectionReport1();
viewer1.LoadDocument(sectionReport);

    The following example demonstrates how you can display a section report (xml-based) in the Viewer control.

    C# code. Paste INSIDE the Form_Load event
    Copy Code
    GrapeCity.ActiveReports.SectionReport sectionReport = new GrapeCity.ActiveReports.SectionReport();
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(@"..\..\SectionReport1.rpx");
sectionReport.LoadLayout(xtr);
xtr.Close();
viewer1.LoadDocument(sectionReport);

Additional Features

Following is an introduction to the additional capabilities of the Viewer to guide you on using it effectively:

Split windows

  1. Run your viewer project.
  2. Click above the vertical scrollbar to grab the splitter control and drag downward.
  3. With the viewer split into two sections, you can easily compare report pages.

Advanced Printing Options

Viewer provides advanced printing options that allow you to control the report page layout and watermark settings through the Page Setup dialog. In this dialog, you can also preview the report as it would appear with each print setting. See Use Advanced Printing Options for further details.

You can also set the PrintingSettings property of the Viewer to directly print without displaying a dialog or to switch from a ActiveReports print dialog to a .NET Framework standard print dialog (System.Windows.Forms.PrintDialog) on clicking the Print button on the Viewer toolbar. You can set the PrintingSettings property of the Viewer control from the Properties window.

PrintingSettings property provides the following options:

PrintingSettings Options | Description
ShowPrintDialog | Displays a dialog in which the user can set the printer options before printing.
ShowPrintProgressDialog | Displays a print progress dialog, in which the user can cancel the printing job.
UsePrintingThread | Specifies whether printing should be performed for individual threads or not.
UseStandardDialog | Specifies whether to use the .NET Framework standard print dialog (System.Windows.Forms.PrintDialog) while printing the document (section or page).

Exporting

Use the Export Filters to export a page or a section report to different formats directly from the Viewer. After you load the document in the Viewer, you can use a sample code like the following which shows one overload of the Export method with a PDF export filter. This code creates an outputPDF.pdf file in the bin\debug folder of your project.

To write the code in Visual Basic.NET

Visual Basic. NET code. Paste INSIDE an event like Button_Click event.
Copy Code
Dim PDFEx As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
Viewer1.Export(PDFEx, New FileInfo(Application.StartupPath + "\outputPDF.pdf"))

To write the code in C#

C# code. Paste INSIDE an event like Button_Click event.
Copy Code
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport PDFEx = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
viewer1.Export(PDFEx, new System.IO.FileInfo (Application.StartupPath + "\\outputPDF.pdf" ));
Note: Make sure that you add a reference to the required export assembly in your project before setting the export filter in code. See Export Filters further details.

Annotations Toolbar

You can use annotations when working with a report in the Viewer and add notes, special instructions or images directly to the reports.

Annotations are added via the Viewer's toolbar, which is hidden by default. You can make the Annotations toolbar available by setting the AnnotationDropDownVisible property to true in the viewer's properties grid.

Annotation Name | Description
AnnotationText | A rectangular box in which you can enter text.
AnnotationCircle | A circle without text. You can change the shape to an oval.
AnnotationRectangle | A rectangular box without text.
AnnotationArrow | A 2D arrow in which you can enter text. You can change the arrow direction.
AnnotationBalloon | A balloon caption in which you can enter text. You can point the balloon's tail in any direction.
AnnotationLine | A line with text above or below it. You can add arrow caps to one or both ends and select different dash styles.
AnnotationImage | A rectangle with a background image and text. You can select an image and its position, and place text on the image.

Keyboard Shortcuts

The following shortcuts are available on the Viewer:

Keyboard Shortcut | Action
Ctrl + F | Shows the find dialog.
Ctrl + P | Shows the print dialog.
Esc | Closes the find or print dialogs.
Page Down | Moves to the next page.
Page Up | Moves to the previous page.
Ctrl + T | Shows or hides the table of contents.
Ctrl + Home | Moves to the first page.
Ctrl + End | Moves to the last page.
Ctrl + Right | Navigates forward.
Ctrl + Left | Navigates backward.
Ctrl + - | Zooms out.
Ctrl + + | Zooms in.
Left, Right, Up, Down | Moves the visible area of the page in the corresponding direction.
Ctrl + 0 (zero) | Sets the zoom level to 100%.
Ctrl + rotate mouse wheel | Changes the zoom level up or down.
Ctrl + M | Turns on the continuous view.
Ctrl + S | Turns off the continuous view.
Ctrl + I | Shows multiple pages.
Ctrl + G | Focuses on PageNumber area and selects content.
F5 | Refreshes the report.
Home | Moves to the start of the current page.
End | Moves to the end of the current page.

Viewer's Thumbnails pane shortcut keys

You can use the following shortcut keys while using the thumbnails pane in the Viewer.

Keyboard Shortcut | Action
Up Arrow | Goes to the previous page.
Down Arrow | Goes to the next page.
Right Arrow | Goes to right page. If no thumbnail exist on the right, it goes to the next page.
Left Arrow | Goes to left page. If no thumbnail exist on the left, it goes to the previous page.
Page Down | Scroll to the next thumbnail's view port. It also keep the current selected page unchanged.
Page Up | Scroll to the previous thumbnail's view port. It also keep the current selected page unchanged.
Home | Goes to the first page.
End | Goes to last page.

Touch Support

ActiveReports introduces touch support for Windows Viewer. This feature gives you the flexibility to interact with the Viewer using simple touch gestures. Now you can install ActiveReports on any touch enabled Windows device and view the reports anywhere you are.

You can switch to the touch mode by just clicking the Touch mode button on the Viewer toolbar.

Note: In touch mode, you can still use the mouse to perform ActiveReports operations.

Touch mode Toolbar

The following table lists the actions you can perform through the Viewer toolbar.

Icon | Function | Details
Sidebar | Displays the sidebar that includes the Thumbnails, Parameters, Document map and Search results panes.
Print | Displays the Print dialog where you can specify the printing options.
Galley mode

Provides a viewer mode which removes automatic page breaks from a Report Definition Language (RDL) and displays data in a single page. This mode maintains page breaks you create in the report and removes only automatic page breaks.

For RDL report only.
Copy Copies text that you select in the Selection mode to the clipboard.
Note: In case the GrapeCity.ActiveReports.Export.Xml.v10.dll and GrapeCity.ActiveReports.Export.Word.v10.dll are not available in GAC, you might need to add references to these assembly files to enable the viewer's Copy button.
Find | Displays the Find dialog to find any text in the report.
Current zoom | Displays the current zoom percentage which can also be edited.
Single page view | Shows one page at a time in the viewer.
Continuous page | Shows all preview pages one below the other.
Multiple page | Offers you an option to select how many pages to preview in the viewer at one time.
Previous page | Takes you to the page prior to the current page. This button is enabled when a page other than the first page is open.
Current page | Opens a specific page in the report. To view a specific page, type the page number and press the Enter key.
Next page | Takes you to the page following the current page. This button is disabled on reaching the last page of the report.
Back to parent report | Returns you to the parent report in a drillthrough report.
Refresh Refreshes the Viewer.

Caution: Refresh button gets disabled when you load a section report in the Viewer control through any of the following:

  • Document Property
  • LoadDocument(SectionDocument) Method
  • LoadDocument(String) Method
Cancel | Cancels the report rendering.
Touch mode | Allows you to select touch mode for the Viewer.

Context menu

To display the context menu, you must tap and hold in the preview area.

Icon | Function | Gesture | Details
 | Pan mode | Tap | Hand cursor used to move the visible portion of the reports. Drag the hand tool in the direction you want to move the report.
 | Selection mode | Tap | Allows you to select contents on the report. Click the Copy icon (see image and description above) to copy the selected content to the clipboard.
 | Snapshot mode | Tap | Allows you to select content on the report that you can paste as an image into any application that accepts pasted images.

Preview

Gesture | Gesture (Image) | Preview Area Element | Details
Flick | Single Page View | Flick in the vertical or horizontal direction moves to the next or previous page. A single flick moves single page.
Continuous Page View | Performs the page scrolling.
Tap | Link | Opens links (URL, drill-though links, etc).
Pan | Slider | Moves the slider.
Border between Sidebar and Preview Area Moves the border.
Note: The pan gesture does not work in the report area where ScrollbarEnabled property is set to False.
Selection mode, Snapshot mode | Pan from selection start point to selection end point.
Pinch

Preview Area

 Pinch to zoom out.
Stretch

Preview Area

 Stretch to zoom in.
Double tap

Preview Area

 Tap twice to change the view mode (from the Single page view to the Multiple page mode).
Tap and hold | Selection mode, Snapshot mode | Displays the context menu where you can select the pan, selection, or snapshot mode.
See Also
ActiveReports Server

Concepts

Parameters

How To

Use Advanced Printing Options
Add and Save Annotations


Customize the Viewer ToolStrip

Customize the Viewer ToolStrip
ActiveReports 10 > ActiveReports User Guide > Viewing Reports > Windows Forms > Customize the Viewer ToolStrip

There are a number of ways in which you can customize the Viewer control to make it a perfect fit for your Windows application. You can add and remove buttons from the toolbars, add and remove menu items, create custom dialogs, and call them from custom click events.

You can use the methods listed in the System.Windows.Forms.ToolStripItemCollection documentation on MSDN to customize each ToolStrip.

ToolStrip

TheToolStrip contains the following ToolStripItems by index number.

  • 0 Toggle sidebar
  • 1 Separator
  • 2 Print
  • 3 Galley mode
  • 4 Separator
  • 5 Copy
  • 6 Find
  • 7 Separator
  • 8 Zoom out
  • 9 Zoom In
  • 10 Current Zoom
  • 11 Separator
  • 12 Fit width
  • 13 Fit page
  • 14 Separator
  • 15 Single page
  • 16 Continuous mode
  • 17 Multipage mode
  • 18 Separator
  • 19 First page
  • 20 Previous page
  • 21 Current
  • 22 Next page
  • 23 Last page
  • 24 Separator
  • 25 History back
  • 26 History forward
  • 27 Separator
  • 28 Back to parent
  • 29 Separator
  • 30 Refresh
  • 31 Cancel button
  • 32 Separator
  • 33 Pan mode
  • 34 Copy select
  • 35 Snapshot
  • 36 Separator
  • 37 Annotations

You can access these ToolStripItems by index with the Insert and RemoveAt methods. Other methods, including Add and AddRange, are described in the System.Windows.Forms.ToolStripItemCollection documentation on MSDN.

ToolStrip Implementation

When you add a new item to a ToolStrip, you need to add an ItemClicked event handler and an ItemClicked event for the ToolStrip with the new item. At run time, when a user clicks the new ToolStrip item, they raise the ItemClicked event of the ToolStrip containing the item

Add the event handler to the Load event of the Form that contains the Viewer control, and use the IntelliSense Generate Method Stub feature to create the related event. For examples of the code to create an event hander, see the Customize the Viewer Control topic, and the Custom Preview sample that is located in ...\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\C#\CustomPreview.

See Also

How To

Customize the Viewer Control


Customize the Viewer Control

Customize the Viewer Control
ActiveReports 10 > ActiveReports User Guide > Viewing Reports > Windows Forms > Customize the Viewer Control
Show All Show All
Hide All Hide All

ActiveReports includes a Viewer control for Windows Forms that lets you show report output in a custom preview form. You can modify both viewer's mouse mode and touch mode toolbars and set custom commands. For example, in the following sample codes we show customization specific to mouse mode toolbar and touch mode toolbar.

To create a basic preview form

  1. In Visual Studio, create a new Windows Forms project.
  2. From the Visual Studio toolbox on the ActiveReports 10 tab, drag the Viewer control onto the form. If you do not have the Viewer in your toolbox, see Adding ActiveReports Controls.
  3. With the viewer control selected, in the Properties window, set the Dock property to Fill.
  4. From the Project menu, select Add New Item.
  5. Select ActiveReports 10 Section Report (code-based) and click the Add button.
  6. Double-click in the title bar of the form to create a Form Load event.
  7. Add the following code to run the report and display the resulting document in the viewer.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form Load event.
    Copy Code
    Dim rpt as new SectionReport1
Viewer1.LoadDocument(rpt)

    To write the code in C#

    C# code. Paste INSIDE the Form Load event.
    Copy Code
    SectionReport1 rpt = new SectionReport1();
viewer1.LoadDocument(rpt);
  8. Press F5 to run the project.

Customize the Mouse Mode Toolbar

  1. Add a second Windows Form to the project created above and name it frmPrintDlg.
  2. Add a label to frmPrintDlg and change the Text property to This is the custom print dialog.
  3. Add a button to frmPrintDlg and change the Text property to OK.
  4. Back on the viewer form, double-click the title bar of the form to go to the Form Load event.
  5. Add the following code to the Form Load event to remove the default print button and add your own.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form Load event.
    Copy Code
    'Remove the print button.
Viewer1.Toolbar.ToolStrip.Items.RemoveAt(2)
'Remove the extra separator.
Viewer1.Toolbar.ToolStrip.Items.RemoveAt(1)
'Add a new button to the end of the tool strip with the caption "Print."
Dim tsbPrint As New ToolStripButton("Print")
Viewer1.Toolbar.ToolStrip.Items.Add(tsbPrint)
'Create a click event handler for the button.
AddHandler tsbPrint.Click, AddressOf tsbPrint_Click

    To write the code in C#

    C# code. Paste INSIDE the Form Load event.
    Copy Code
    //Remove the print button.
viewer1.Toolbar.ToolStrip.Items.RemoveAt(2);
//Remove the extra separator.
viewer1.Toolbar.ToolStrip.Items.RemoveAt(1);
//Add a new button to the end of the tool strip with the caption "Print."
ToolStripButton tsbPrint = new ToolStripButton("Print");
viewer1.Toolbar.ToolStrip.Items.Add(tsbPrint);
//Create a click event handler for the button.
tsbPrint.Click += new EventHandler(tsbPrint_Click);
  6. Add the following code to the Form class below the Load event to display frmPrintDlg when a user clicks the custom print button.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste BELOW the Form Load event.
    Copy Code
    'Call the custom dialog from the new button's click event.
Private Sub tsbPrint_Click(sender As Object, e As EventArgs)
    Me.CustomPrint()
End Sub

'Call the custom print dialog.
Private Sub CustomPrint()
    Dim _printForm As New frmPrintDlg()
    _printForm.ShowDialog(Me)
End Sub

    To write the code in C#

    C# code. Paste BELOW the Form Load event.
    Copy Code
    //Call the custom dialog from the new button's click event.
private void tsbPrint_Click(object sender, EventArgs e)
{
    this.CustomPrint();
}

//Call the custom print dialog.
private void CustomPrint()
{
    frmPrintDlg _printForm = new frmPrintDlg();
    _printForm.ShowDialog(this);
}
  7. Press F5 to run the project and click on the print button of main viewer to view custom print dialog.

Customize the Touch Mode Toolbar

  1. Double-click in the title bar of the Viewer form to create a Form Load event.
  2. Add the following code to add a custom Zoom out button.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form Load event.
    Copy Code
    Dim zoomOutButton = viewer1.TouchModeToolbar.ToolStrip.Items(8)
zoomOutButton.Visible = true

    To write the code in C#

    C# code. Paste INSIDE the Form Load event.
    Copy Code
    var zoomOutButton = viewer1.TouchModeToolbar.ToolStrip.Items[8];
zoomOutButton.Visible = true;

Caution: Any customization done in mouse mode does not apply to the touch mode and vice versa.

Although this topic and the sample both demonstrate using section reports, customized viewers support page reports and RDL reports as well. The only difference is in the way that you load reports. For more information, see Windows Forms Viewer.

See Also

Getting Started

Viewing Reports

Concepts

Customize the Viewer ToolStrip


Localize the Viewer Control

Localize the Viewer Control
ActiveReports 10 > ActiveReports User Guide > Viewing Reports > Windows Forms > Localize the Viewer Control
Show All Show All
Hide All Hide All

You can localize all of the strings and images that appear in the Windows Forms Viewer control in included resource files, and alter and run a batch file to localize the control.

To localize the viewer control

All of the localization files are located in C:\Program Files (x86)\GrapeCity\ActiveReports 10\Localization.

Specify the culture you want to use in the batch file.

  1. Start Notepad or another text editor as an Administrator.
  2. Open the WinViewer.bat file and change the Culture value to the culture you want to use.
  3. Ensure that the path in ProductPath is correct for your installation, but do not alter any of the other properties.
  4. Save and close the file.

Localize strings (and images) in the resource files.

  1. Launch your zip program as an Administrator and open the WinViewer.zip file.
  2. Extract all of the files to
    C:\Program Files (x86)\GrapeCity\ActiveReports 10\Localization.
    A WinViewer subfolder is created.
  3. In the new WinViewer folder, open each subfolder and change the strings in each of the *.resx files.
    Tip: Strings are located between <value> and </value> tags in the resource files.
  4. If you want to change the images, rename your localized images to the names of the ones in the Res\Resources subfolder and replace them with your localized images.

Run the batch file as an Administrator.

  1. From the Start menu, type cmd in the text box, and press CTRL + SHIFT + ENTER to open a command prompt as an Administrator.
  2. To change directories, type:
    cd C:\Program Files (x86)\GrapeCity\ActiveReports 10\Localization
    and press Enter.
  3. Type WinViewer.bat and press Enter to run the file. The NameCompleter.exe application runs, and creates the following.
    • A SatelliteAssembly folder inside the WinViewer folder.
    • A language subfolder with the name of the culture you set inside the SatelliteAssemby folder.
    • A localized GrapeCity.ActiveReports.Viewer.Win.v10.resources.dll file inside the language subfolder.
  4. Copy the language subfolder and paste it into the Debug folder of your application.
    Note: Before you can distribute or put your localization in the Global Assembly Cache (GAC), you must first send the localized GrapeCity.ActiveReports.Viewer.Win.v10.resources.dll file to GrapeCity support and get it signed with a strong name. Then you can drag the language subfolder with the signed dll file into C:\WINDOWS\ASSEMBLY.

Test your localized application on a machine that does not share the culture of the localized DLL.

  1. Add the following code in the form's constructor just before the InitializeComponent method is called.
  2. Replace the "ja" in the example code with the culture you specified in the WinViewer.bat file.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the form's constructor just before the InitializeComponent method.
Copy Code
System.Threading.Thread.CurrentThread.CurrentUICulture = New System.Globalization.CultureInfo("ja")

To write the code in C#

C# code. Paste INSIDE the form's constructor just before the InitializeComponent method.
Copy Code
System.Threading.Thread.CurrentThread.CurrentUICulture = new System.Globalization.CultureInfo("ja");
See Also
Customize the Viewer Control
Localize


Web Viewer (ASP.NET)

Web Viewer (ASP.NET)
ActiveReports 10 > ActiveReports User Guide > Viewing Reports > Web Viewer (ASP.NET)

Professional Edition

With the Professional Edition license, you can use the WebViewer control to quickly display reports in any of four viewer types: HtmlViewer, RawHtml, AcrobatReader, or FlashViewer. You can also use the Silverlight Viewer control in Silverlight projects.

Important: Before using the WebViewer control, you must first Configure HTTPHandlers in IIS 7 and IIS 8.

In this section

Getting Started with the Web Viewer
Explore the ways that the WebViewer control can save you time.
Using the HTML Viewer
Learn about the features available with the HTML viewer, including parameters, table of contents, search, and the toolbar.
Using Javascript with the HTML Viewer
Learn about how you can use HTML Viewer using Javascript.
Flash Viewer
Learn about the features available with the Flash viewer.

Standard Edition

With the Standard Edition license, you can export reports to use on the Web or use Web Services to distribute reports or data sources. For more information on Web exporting, please see the Custom Web Exporting (Std Edition) section.


Getting Started with the Web Viewer

Getting Started with the Web Viewer
ActiveReports 10 > ActiveReports User Guide > Viewing Reports > ASP.NET > Getting Started with the Web Viewer
Show All Show All
Hide All Hide All

The WebViewer control that is licensed with the Professional Edition allows you to quickly display reports in Web applications.

Once you drop the control onto a Web Form, you can look in the Visual Studio Properties grid and select the ViewerType that you want to use.

The WebViewer control supports the following types:

  • HtmlViewer (default): Provides a scrollable view of a single page of the report at a time. Downloads only HTML and javascript to the client browser. Not recommended for printable output. See the Using the HTML Viewer topic for details.
  • RawHTML: Shows all pages in the report document as one continuous HTML page. Provides a static view of the entire report document, and generally printable output, although under some circumstances pagination is not preserved.
  • AcrobatReader: Returns output as a PDF document viewable in Acrobat Reader.
    Client requirements: Adobe Acrobat Reader
  • FlashViewer: Provides an interactive viewing experience and no-touch printing using the widely-adopted Flash Player. See Flash Viewer for details.
    Client requirements: Adobe Flash Player

To use the WebViewer control

  1. In a Visual Studio Web Application, add the WebViewer control to the Visual Studio toolbox. See Adding ActiveReports Controls for more information.
  2. While in Design view of an ASPX page, from the toolbox, drag the WebViewer control and drop it on the page.
  3. With the WebViewer control selected, in the Properties grid, select the ViewerType you want to use. The viewer displays any prerequisites for using the selected ViewerType.
  4. To bind a report to the WebViewer, do one of the following:
    • Set the ReportName property to the name of a report within your solution.
      Note: Alternatively, you can set the ReportName property programmatically to a new instance of an ActiveReport class. For example:
      VB code: WebViewer.ReportName="YourReport.rpx"
      C# code: WebViewer.ReportName="YourReport.rpx";
    • Set the Report property to a new instance of an ActiveReport class as shown in the examples below.

      To write the code in Visual Basic.NET (Page report/RDL report)

      VB code. Paste INSIDE the Page Load event
      Copy Code
      Dim rpt As New GrapeCity.ActiveReports.PageReport()
rpt.Load(New System.IO.FileInfo(Server.MapPath("")+"\invoice.rdlx"))
WebViewer1.Report = rpt

      To write the code in C# (Page report/RDL report)

      C# code. Paste INSIDE the Page Load event
      Copy Code
      GrapeCity.ActiveReports.PageReport rpt = new GrapeCity.ActiveReports.PageReport();
rpt.Load(new System.IO.FileInfo(Server.MapPath("")+"\\invoice.rdlx"));
WebViewer1.Report = rpt;

      To write the code in Visual Basic.NET (Section code-based report)

      VB code. Paste INSIDE the Page Load event
      Copy Code
      Dim rpt As New MyInvoiceReport()
WebViewer1.Report = rpt

      To write the code in C# (Section code-based report)

      C# code. Paste INSIDE the Page Load event
      Copy Code
      MyInvoiceReport rpt = new MyInvoiceReport();
WebViewer1.Report = rpt;

      To write the code in Visual Basic.NET (Section xml-based report)

      VB code. Paste INSIDE the Page Load event
      Copy Code
      Dim sr As New SectionReport()
sr.LoadLayout(Server.MapPath("") + "\Invoice.RPX")
WebViewer1.Report = sr

      To write the code in C# (Section xml-based report)

      C# code. Paste INSIDE the Page Load event
      Copy Code
      SectionReport sr = new SectionReport();
sr.LoadLayout(Server.MapPath("") + "\\Invoice.RPX);
WebViewer1.Report = sr;
  5. You must also Configure HTTPHandlers in IIS 6 on your server so that IIS knows how to associate ActiveReports files in the browser.


Using the HTML Viewer

Using the HTML Viewer
ActiveReports 10 > ActiveReports User Guide > Viewing Reports > ASP.NET > Using the HTML Viewer
Show All Show All
Hide All Hide All

HtmlViewer is the default viewer type of the WebViewer control, and provides a scrollable view of the report one page at a time. It includes HTML representations of the toolbar as well as the sidebar that contains Parameters, Table of Contents and Search panes.

HTML Viewer Properties

These HtmlExportOptions properties on the WebViewer control apply only when you select the HTML ViewerType. If you change the ViewerType property to another value, these settings are ignored.

Property | Description
BookmarkStyle | Specify whether to use HTML bookmarks, or none.
CharacterSet | Select from 15 character sets to use for the report.
IncludePageMargins | Specify whether to keep page margins on reports in the generated HTML.
OutputType | Specify whether to use DHTML or HTML for the output.
RemoveVerticalSpace | Specify whether to keep white space, for example at the end of a page not filled with data before a page break.

The HtmlViewer downloads only HTML and javascript to the client browser.

HTML Viewer Toolbar

The HTML viewer toolbar offers various ways to navigate through reports.

Toolbar Element | Name | Description
 | Toggle Sidebar | Displays the sidebar that includes the Parameters, Table of Contents and Search panes.
 | Find | Displays the Search pane of the sidebar.
 | Go to page | Opens a specific page in the report. To view a specific page, type the page number and press ENTER.
 | Go to Previous/Next page | Navigates through a report page by page.
 | Go to First/Last page | Jumps to the first or last page of a report.
 | Back to parent report | Returns to the parent report in a drill-down page report or RDL report.

HTML Viewer Parameters

The HTML viewer allows you to view reports with parameters. The Parameters pane shows up automatically. To show or hide the Parameters pane in the sidebar, click the Toggle Sidebar button in the Toolbar.

In the Parameters pane, you are asked to enter a value by which to filter the data to display.

To filter the report data, enter a value or set of values and click View report.

If a report does not have parameters, the Parameters pane of the sidebar is disabled.

HTML Viewer Table of Contents

To display the Table of Contents pane, in the toolbar, click Toggle Sidebar. Then at the bottom of the sidebar, click the Table of Contents button.

Note that the Table of Contents pane is only enabled for reports with Bookmarks. The Table of Contents displays each value for the text box, group, or subreport that you bookmark, and you can click them to navigate to the corresponding section of the report in the Viewer.

HTML Viewer Search

The Search pane lets you enter a word or phrase for which to search within the report. Under Use these additional criteria, you may optionally select additional criteria. When you click Search, any results appear in the Find results list. Click an item in the list to jump to the item you selected and highlight it.

To start a new search, click Clear under the Find results list.

See Also
Web Viewer (ASP.NET)

Concepts

Interactive Features


Using Javascript with the HTML Viewer

Using Javascript with the HTML Viewer
ActiveReports 10 > ActiveReports User Guide > Viewing Reports > ASP.NET > Using Javascript with the HTML Viewer
Show All Show All
Hide All Hide All

In order to work with HTML viewer using the Javascript, you need to follow a set of procedures. This involves calling the Loaded event first and then obtaining an instance of the ViewerViewModel. Once you have access to the ViewerViewModel, use its API methods and properties to work with the HTML Viewer.

Loaded Event

HtmlViewer raises a Loaded event to notify the listeners that the internal initialization is complete. Following is the sample code to raise a Loaded event:

$(document).ready(function () {
$('#' + clientId).bind('loaded', function(){
...
});
});
Note: You can obtain the ClientId from the WebViewer control.

ViewerViewModel

In order to work with the API, obtain an instance of the ViewerViewModel first, using the GetViewModel(clientId) javascript function that searches ViewerViewModel array through the clientId. This function throws an exception if there is no ViewerViewModel with the requested clientId available.

Use code like the following to call an instance of the ViewerViewModel:

var viewModel = GetViewModel(clientId);

After obtaining the ViewerViewModel, the code can call API methods and properties.

Methods/Properties | Example | Description
Sidebar | this.Sidebar | Gets the Sidebar view model instance.
Toolbar | this.Toolbar | Gets the Toolbar view model instance.
PageLoaded | this.PageLoaded(false); | Gets the Boolean value indicating whether the page was loaded or not.
Export this.Export(exportType, callback, saveAsDialog, settings) this.Export(ExportType.Pdf, callback, true, {FileName:"report.pdf"});

Exports the loaded page to a specified format. In order to export without any errors, the PageLoaded() property must be True.

  • exportType: Requested output format.
  • callback: Function which obtains the URI of the exported document.
  • saveAsDialog: Optional request to show save as dialog after export.
  • settings: Optional export settings. Here you can specify the exported file name in the FileName keyword that is case-sensitive.
Note: ExportType is an Enumeration.
var ExportType = { Pdf, Html, Word, Xls, Xml };
Print | this.Print() | Prints the report using pdf printing. In order to print without any errors the PageLoaded() property must be True.

SidebarViewModel

SidebarViewModel allows you access to its various properties and methods to get the current state and show/hide sidebar and sidebar panels.

Methods/Properties | Example | Description
IsSidebarVisible | this.IsSidebarVisible(false); | Gets the Boolean value for entire sidebar visibility.
HideShowSidebar | this.HideShowSidebar() | Toggles Sidebar's visibility.
IsBookmarksPaneVisible | this.IsBookmarksPaneVisible(false); | Gets the Bookmarks Pane's visibility.
ShowBookmarksPane | this.ShowBookmarksPane() | Toggles Bookmarks Pane's visibility.
IsParametersPaneVisible | this.IsParametersPaneVisible(false); | Gets the Parameters Pane's visibility.
ShowParametersPane | this.ShowParametersPane() | Toggles Parameters Pane's visibility.
IsSearchPaneVisible | this.IsSearchPaneVisible(false); | Gets the Search Pane's visibility.
ShowSearchPane | this.ShowSearchPane() | Toggles Search Pane's visibility.
HideAll | this.HideAll() | Hides all Sidebar panes.
See Also
Using the HTML Viewer

Walkthroughs

Customizing the HTML Viewer UI


Flash Viewer

Flash Viewer
ActiveReports 10 > ActiveReports User Guide > Viewing Reports > ASP.NET > Flash Viewer
Show All Show All
Hide All Hide All

FlashViewer is one of the viewer types of the WebViewer control. It includes Flash representations of the toolbar as well as the sidebar that contains Table of Contents and Thumbnail tabs.

To use the Flash Viewer, you must copy the following files into your project folder.

  • GrapeCity.ActiveReports.Flash.v10.swf
  • GrapeCity.ActiveReports.Flash.v10.Resources.swf
    Note: GrapeCity.ActiveReports.Flash.v10.Resources.swf is used for localization and is necessary only if you want to use a language resource that is different from the default one. The default locale is U.S. English (en_US).

These files are located in the ...\GrapeCity\ActiveReports 10\Deployment\Flash folder.

In the WebViewer control ViewerType property, when you select FlashViewer, you can customize the viewer using the FlashViewerOptions properties.

Flash Viewer properties

To access the Flash viewer properties, select the WebViewer on your ASPX page and, in the Properties Window, expand the FlashViewerOptions node. If you change the ViewerType property to anything other than FlashViewer, these property settings are ignored.

Property | Description
DisplayTransparency | Specify whether to print transparent objects.
HyperLinkBackColor | Specify the background color of hyperlinks displayed in the viewer.
HyperLinkForeColor | Specify the color of hyperlink text.
HyperLinkUnderline | Specify whether hyperlink text is underlined.
MultiPageViewColumns | Specify the number of columns to show when the ViewType is set to MultiPage.
MultiPageViewRows | Specify the number of rows to show when the ViewType is set to MultiPage.
PageNumber | Specify the page to display initially.
PrintOptions AdjustPaperOrientation

Specify how to handle paper orientation during printing. Select from:

  • None (orientation is not checked)
  • Auto (the Flash viewer checks every page, and changes orientation if necessary)
  • AdjustByFirstPage (the Flash viewer checks the first page, and if the orientation does not match that of the printer, adjusts the entire report without checking additional pages)
ScalePages

Specify how to handle page scaling during printing. Select from:

  • None (pages are not scaled)
  • Auto (pages are scaled down if they do not fit on the paper)
  • AllowScaleUp (pages are scaled up or down to best fit the paper)
StartPrint | Specify whether to print the report after loading for one-touch printing. If you set the WebViewer's Height and Width properties to 0, you can print the report without displaying the Print dialog.
ResourceLocale | Specify the Culture for localization. Separate multiple values with commas.
ResourceUrl | Specify a comma-separated list of URLs to SWF files with resource bundles.
SearchResultsBackColor | Specify the background color used to highlight search results text in report pages.
SearchResultsForeColor | Specify the text color for highlighted search results text in report pages.
ShowSplitter | Specify whether to display the splitter, which allows the user to compare report pages in the viewer.
ThemeUrl Specify the relative URL of a theme to use on the FlashViewer. The following themes are included, and can be found in ...\GrapeCity\ActiveReports 10\Deployment\Flash\Themes. Add them to your project to use them.
  • FluorescentBlue.swf
  • Office.swf
  • OliveGreen.swf
  • Orange.swf
  • VistaAero.swf
  • WindowsClassic.swf
  • XP.swf
TocPanelOptions | Alignment | Specify the alignment of the table of contents pane. Select from Left or Right.
ShowThumbnails | Specify whether to display a pane with thumbnail views of pages.
ShowToc | Specify whether to display the table of contents in the FlashViewer.
Visible | Specify whether to show the table of contents pane initially, without requiring the user to click the Toggle Sidebar button.
Width | Specify the width of the table of contents pane in pixels.
Url | Specify the relative URL of the FlashViewer control. If you leave this value blank, ActiveReports looks in the main Web folder.
UseClientApi | Specify whether to allow the use of the client API (javascript) for the FlashViewer. If set to False, the Flash viewer ignores any javascript commands sent to it.
ViewType | Specify the page view type. Select from Single, MultiPage, or Continuous.
WindowMode

Specify such display options as transparency, layering, and positioning of the FlashViewer in the browser. Select from:

  • Window (displays the Flash viewer in its own rectangular window on the Web page)
  • Opaque (displays the viewer with a filled background so nothing shows through)
  • Transparent (displays the viewer with a transparent background so objects in the background show through) This mode may slow animation performance.
Zoom | Specify the zoom level, between 10% and 800%, at which to display the report.

Flash Viewer shortcut keys

You can use the following shortcut keys with the Flash Viewer.

Keyboard Shortcut | Action | Behavior in Internet Explorer
Ctrl + F | Displays the find dialog. | -
F3 | Displays the next find result. | Displays the browser's find box.
Esc | Closes the find dialog. | -
Page Down | Moves to the next page. | -
Page Up | Moves to the previous page. | -
Ctrl + P | Displays the print dialog. | Displays the browser's print dialog.
Ctrl + T | Displays the table of contents. | Opens a new tab in the browser.
Ctrl + Home | Moves to the first page. | -
Ctrl + End | Moves to the last page. | -
Ctrl + Right | Moves to the next page. | -
Ctrl + Left | Moves to the previous page. | -
Ctrl + - | Zooms out. | -
Ctrl + + | Zooms in. | -
Left, Right, Up, Down | Moves the visible area of the page in the specified direction. | -
Home, End | Moves to the beginning or end of the current page. | -
Ctrl + 0 (zero) | Sets the zoom ratio to 100%. | -
Ctrl + mouse wheel | Changes the zoom level up or down. | -
Ctrl + M | Displays multiple pages. | Not applicable for IE9 and IE10.
Ctrl + S | Displays a single page. | Displays the Save Webpage dialog in IE9 and IE10.

Caution: As with any other Flash application, browser keyboard shortcuts do not work if the Flash Viewer has focus. Click anywhere outside the Flash Viewer to give focus back to the browser to use browser keyboard shortcuts. Likewise, to use the Flash Viewer keyboard shortcuts, click the Flash viewer to give focus back to the Flash Viewer if focus is on the browser.

Also, some shortcut actions are different in Internet Explorer (see Behavior in Internet Explorer in the table above), therefore it is recommended to use FireFox instead.

Flash Viewer printing

Flash Viewer printing limitation: the Google Chrome browser does not support printing reports without margins.

The Flash Viewer toolbar has a Print button and a Page Range button. Note that you cannot set the page range in the Print dialog, so you must set up a page range prior to printing.

Print

  1. On the Flash Viewer toolbar, click the Print button.

  2. In the Print dialog that appears, select the printer settings and click Print.

Page Range

  1. On the Flash Viewer toolbar, click the Page Range button.

  2. In the Page range dialog that appears, select All for all pages, Current Page for the current page, or Range to specify pages for printing and then click OK.

  3. On the Flash Viewer toolbar, click the Print button and then, in the Print dialog that appears, click Print.
Note: With the ViewerType of WebViewer control set to FlashViewer, you can only use hyperlinks and document map interactive features.
Note: You need to modify the IIS Express setting when loading an RDF file in the Flash Viewer using client-side scripts. For more details, go to the Flash Viewer Troubleshooting section in Troubleshooting.
See Also
Web Viewer (ASP.NET)


Localize

Localize
ActiveReports 10 > ActiveReports User Guide > Viewing Reports > ASP.NET > Flash Viewer > Localize
Show All Show All
Hide All Hide All

The FlashViewer, one of the ViewerTypes of the WebViewer control, is localized separately from other ActiveReports resources. You can redistribute the Flash localization resources separately from the application so that you need not recompile the GrapeCity.ActiveReports.Flash.v10.swf file.

You can localize all of the UI strings, error messages, fonts, and images that appear in the FlashViewer in the included resource file, and send it to GrapeCity to be compiled into the SWF resources file.

Note: If you are willing to share your new localization with other customers, let support know so that the updated GrapeCity.ActiveReports.Flash.v10.Resources.swf file can be included in future builds of the product.

Included Localizations

The default locale is en_US, U.S. English, but the included GrapeCity.ActiveReports.Flash.v10.Resources.swf file also contains strings localized for the following languages:

  • ru_RU Russian
  • ja_JP Japanese
  • zh_CN Simplified Chinese

The SWF files are located in C:\Program Files (x86)\GrapeCity\ActiveReports 10\Deployment\Flash.

To use the Russian, Japanese, or Chinese localization

  1. From C:\Program Files (x86)\GrapeCity\ActiveReports 10\Deployment\Flash, copy GrapeCity.ActiveReports.Flash.v10.Resources.swf into the project folder that contains the ASPX file with the WebViewer.
  2. In the Design view of the ASPX file, click the WebViewer control to select it, and in the Properties window, expand the FlashViewerOptions property node.
  3. In the ResourceLocale property, drop down the list of values and select the locale that you want to use.
  4. Run the project to see the localized FlashViewer.

Custom Localizations

The localization file is located in C:\Program Files (x86)\GrapeCity\ActiveReports 10\Localization.

To localize strings (and images) in the resource file.

  1. In C:\Program Files (x86)\GrapeCity\ActiveReports 10\Localization, open the FlashViewer.zip file.
  2. Using Notepad, open the Resources.properties file and localize the strings.
  3. Save and zip the file.
  4. If you want to change the toc.png image for the Table of Contents button icon, rename your localized image to toc.png and add it to the zip file.

To send the localized file to GrapeCity to be compiled into the SWF file.

  1. Attach the localized FlashViewer.zip file to the Submit New Issue form on our web site: http://activereports.grapecity.com/.
  2. Tell support the culture of the localization and ask them to compile it into the GrapeCity.ActiveReports.Flash.v10.Resources.swf.
  3. Support will email you the localized SWF file.

To use your custom localization.

  1. When you receive the new ActiveReports.FlashViewer.Resources.swf file, copy it into the project folder that contains the ASPX file with the WebViewer.
  2. In the Design view of the ASPX file, click the WebViewer control to select it, and in the Properties window, expand the FlashViewerOptions property node.
  3. In the ResourceLocale property, drop down the list of values and select your custom locale.
  4. Run the project to see the localized FlashViewer.
See Also
Customize the Toolbar

Getting Started

Flash Viewer

Concepts

Localization
Cultures


Customize the Toolbar

Customize the Toolbar
ActiveReports 10 > ActiveReports User Guide > Viewing Reports > ASP.NET > Flash Viewer > Customize the Toolbar
Show All Show All
Hide All Hide All

When you use the WebViewer that is licensed with the Professional Edition, one of the ViewerTypes that you can select is FlashViewer. The FlashViewer toolbar is very similar to the Viewer control's toolbar. You can show or hide it, reorder buttons, remove buttons, add custom buttons, or create a custom toolbar. Use the Web.Controls namespace to create custom buttons or a custom toolbar that you can specify in the WebViewer's FlashViewerToolbar property.

The following buttons are provided by default.

Heading | Print | Page Range
Search | Zoom-out | Zoom
Zoom-in | Single Page | Multiple pages
Continuous Page | Previous Page | Next Page
Page Number | Backwards | Forward

Drop down the sections below for code samples.

Note: This code is ignored if the ViewerType property of the WebViewer control is not set to FlashViewer.

To hide the toolbar

  1. In the Visual Studio Solution Explorer, right-click the ASPX file that contains your WebViewer and select View Designer.
  2. In the design view of your web form, double-click on the form below the WebViewer. This creates an event handling method for the Page Load event and takes you to the code view of the page.
  3. Use the following code to hide the toolbar.
    Visual Basic. NET. Paste INSIDE the Page Load event
    Copy Code
    WebViewer1.FlashViewerToolBar.Visible = False
    C#. Paste INSIDE the Page Load event
    Copy Code
    WebViewer1.FlashViewerToolBar.Visible = false;

To add a using or Imports directive

To reduce the amount of code needed for the rest of the customizations, add a using or Imports directive at the top of the ASPX code view.

Visual Basic. NET. Paste at the top of the ASPX code view
Copy Code
Imports GrapeCity.ActiveReports.Web.Controls
C#. Paste near the top of the ASPX code view
Copy Code
using GrapeCity.ActiveReports.Web.Controls;

To reorder buttons in the toolbar

  1. In the Visual Studio Solution Explorer, right-click the ASPX file that contains your WebViewer and select View Designer.
  2. In the design view of your web form, double-click on the form below the WebViewer. This creates an event handling method for the Page Load event and takes you to the code view of the page.
  3. Use the following code to create a new button and add it at the beginning of the toolbar.
    Visual Basic. NET. Paste INSIDE the Page Load event
    Copy Code
    'Get a default tool from the toolbar. (You can also specify the tool index.）
Dim tool As ToolBase = WebViewer1.FlashViewerToolBar.Tools("PageRangeButton")
'Remove the tool from the toolbar.
WebViewer1.FlashViewerToolBar.Tools.Remove(tool)
'Insert the tool in a different position.
WebViewer1.FlashViewerToolBar.Tools.Insert(0, tool)
    C#. Paste INSIDE the Page Load event
    Copy Code
    //Get a default tool from the toolbar. (You can also specify the tool index.）
ToolBase tool =  WebViewer1.FlashViewerToolBar.Tools["PageRangeButton"];
//Remove the tool from the toolbar.
WebViewer1.FlashViewerToolBar.Tools.Remove(tool);
//Insert the tool in a different position.
WebViewer1.FlashViewerToolBar.Tools.Insert(0, tool);

To remove a button from the toolbar

  1. In the Visual Studio Solution Explorer, right-click the ASPX file that contains your WebViewer and select View Designer.
  2. In the design view of your web form, double-click on the form below the WebViewer. This creates an event handling method for the Page Load event and takes you to the code view of the page.
  3. Use the following code to remove a button from the toolbar.
    Visual Basic. NET. Paste INSIDE the Page Load event
    Copy Code
    'Get a default tool from the toolbar by name. （You can also specify the tool index.）
Dim tool As ToolBase = WebViewer1.FlashViewerToolBar.Tools("PageRangeButton")
' Delete the tool from the toolbar.
WebViewer1.FlashViewerToolBar.Tools.Remove(tool)
    C#. Paste INSIDE the Page Load event
    Copy Code
    //Get a default tool from the toolbar by name. （You can also specify the tool index.）
ToolBase tool =  WebViewer1.FlashViewerToolBar.Tools["PageRangeButton"];
//Delete the tool from the toolbar.
WebViewer1.FlashViewerToolBar.Tools.Remove(tool);

To create a custom button and add it to the toolbar

Tip: The ToolsCollection class in the Web.Controls namespace has the standard System.Collections.ObjectModel.Collection methods available, so if you want to just add a button to the end of the toolbar, you can use the Add method instead.
  1. In the Visual Studio Solution Explorer, right-click the ASPX file that contains your WebViewer and select View Designer.
  2. In the design view of your web form, double-click on the form below the WebViewer. This creates an event handling method for the Page Load event and takes you to the code view of the page.
  3. Use the following code to create a button and place it at the beginning of the toolbar.
    Visual Basic. NET. Paste INSIDE the Page Load event
    Copy Code
    Dim customButton As ToolButton = Tool.CreateButton("CustomButton")
customButton.Caption = "Contanct Us"
customButton.ToolTip = "ActiveReports Website"
customButton.ClickNavigateTo = "http://activereports.grapecity.com/"
'Add a button at the specified index.
'An index value of 20 places it second to last, between the Forward and Backward buttons.
'Set the index value to 0 to place it in the first position at the left.
WebViewer1.FlashViewerToolBar.Tools.Insert(20, customButton)
    C#. Paste INSIDE the Page Load event
    Copy Code
    ToolButton customButton = Tool.CreateButton("CustomButton");
customButton.Caption = "Contact Us";
customButton.ToolTip = "ActiveReports Website";
customButton.ClickNavigateTo = "http://activereports.grapecity.com/";
//Add a button at the specified index.
//An index value of 20 places it second to last, between the Forward and Backward buttons.
//Set the index value to 0 to place it in the first position at the left.
WebViewer1.FlashViewerToolBar.Tools.Insert(20, customButton);

To create a custom toolbar and add it to the viewer

  1. In the Visual Studio Solution Explorer, right-click the ASPX file that contains your WebViewer and select View Designer..
  2. In the design view of your web form, double-click on the form below the WebViewer. This creates an event handling method for the Page Load event and takes you to the code view of the page.
  3. Use the following code to create the custom toolbar and add it to viewer.
    Visual Basic. NET. Paste INSIDE the Page Load event
    Copy Code
    'Get the collection of buttons and separators used in the toolbar.
Dim collection As ToolsCollection = WebViewer1.FlashViewerToolBar.Tools
'Delete all of the buttons and separators from the toolbar.
collection.Clear()
'Add pre-defined buttons.
collection.Add(Tool.Create(ToolsCollection.ToolCommands.ZoomOutButton))
collection.Add(Tool.Create(ToolsCollection.ToolCommands.ZoomBox))
collection.Add(Tool.Create(ToolsCollection.ToolCommands.ZoomInButton))
' Add a separator.
collection.Add(Tool.CreateSeparator())
'Add a pre-defined button.
collection.Add(Tool.Create(ToolsCollection.ToolCommands.SearchButton))
'Add a separator.
collection.Add(Tool.CreateSeparator())
'Add custom buttons.
collection.Add(Tool.CreateButton("btn1"))
collection.Add(Tool.CreateButton("btn2"))
    C#. Paste INSIDE the Page Load event
    Copy Code
    //Get the collection of buttons and separators used in the toolbar.
ToolsCollection collection = WebViewer1.FlashViewerToolBar.Tools;
//Delete all of the buttons and separators from the toolbar.
collection.Clear();
//Add pre-defined buttons.
collection.Add(Tool.Create(ToolsCollection.ToolCommands.ZoomOutButton));
collection.Add(Tool.Create(ToolsCollection.ToolCommands.ZoomBox));
collection.Add(Tool.Create(ToolsCollection.ToolCommands.ZoomInButton));
//Add a separator.
collection.Add(Tool.CreateSeparator());
//Add a pre-defined button.
collection.Add(Tool.Create(ToolsCollection.ToolCommands.SearchButton));
//Add a separator.
collection.Add(Tool.CreateSeparator());
//Add custom buttons.
collection.Add(Tool.CreateButton("btn1"));
collection.Add(Tool.CreateButton("btn2"));


HTML5 Viewer

HTML5 Viewer
ActiveReports 10 > ActiveReports User Guide > Viewing Reports > HTML5 Viewer
Show All Show All
Hide All Hide All

The HTML5 Viewer is a Javascript component that can be used in web applications to preview reports hosted on ActiveReports 10 Server or ActiveReports 10 Web Service. The HTML5 Viewer provides several UI types to target the wide range of supported devices. The application can switch between these options using the public API methods and properties.

HTML5 Viewer Mobile UI

HTML5 Viewer Mobile Top Toolbar

Toolbar Element | Name | Description
 | Table of Contents | Displays the Table of Contents pane.
 | Parameters | Displays the Parameters pane.
 | Search | Displays the Search pane.
 | Save As | Displays the drop-down list of formats to export the report. The available options are PDF Document, Word Document, Image File, MHTML Web Archives, and Excel Workbook. Tapping the menu item exports the report to the selected format.

HTML5 Viewer Mobile Bottom Toolbar

Toolbar Element | Name | Description
 | Previous Page | Navigates to the previous page of the displayed report.
 | Next Page | Navigates to the next page of the displayed report.
2/124 | Current Page | Displays the current page number and page total. Enter the page number to view a specific page.
 | Back to Parent | Returns to the parent report in a drill-through page report.

HTML5 Viewer Mobile Table of Contents Pane

The Table of Contents pane appears when you tap the TOC button on the toolbar. Tap any TOC item in the Table of Contents pane to navigate to the corresponding section of the report in the Viewer.

The Table of Contents pane has a Close (x) button that hides the pane and shows the report display area. If a report does not have a Table of Contents, the TOC button in the toolbar is disabled.

HTML5 Viewer Mobile Parameters Pane

The Parameters pane appears automatically if your report contains parameters.

In the Parameters pane, click the [image] button to open the Parameters Value editor where you can choose or enter values depending on the parameter type.

After you select or enter the values, click the Back button to navigate to Parameters Pane. Click the View Report button to view the report according to the selected parameter values.

If a report does not have parameters, the Parameters button in the toolbar is disabled. For more information, see Parameters.

HTML5 Viewer Mobile Search Pane

The Search pane appears when you tap the Search button in the toolbar.

This pane allows you to search for a specific text in the report.

To search in a report:

  • Enter the word or phrase in the search field.
  • Under the search field, you may choose to use the Match case and Whole phrase options while searching in the report.
  • Click the Search button to see the results appear below the Search button.
  • Click an item in the list to jump to that item in the report.

HTML5 Viewer Desktop UI

HTML5 Viewer Desktop Toolbar

Toolbar Element | Name | Description
 | Sidebar | Displays the sidebar with the Table of Contents and Parameters panes.
 | Search | Displays the Search pane.
 | First | Navigates to the first page of the displayed report.
 | Prev | Navigates to the previous page of the displayed report.
2/124 | Current page | Displays the current page number and page total. Enter the page number to view a specific page.
 | Next | Navigates to the next page of the displayed report.
 | Last | Navigates to the last page of the displayed report.
 | Back to Parent | Returns to the parent report in a drill-through page report.
 | Print | Displays the Print dialog to specify printing options.
 | Save As | Displays the drop-down list of formats to export the report. The available options are PDF Document, Word Document, Image File, MHTML Web Archives, and Excel Workbook. Tapping the menu item exports the report to the selected format.

HTML5 Viewer Desktop Table of Contents Pane

The Table of Contents pane appears when you click the Sidebar button in the toolbar. Click any TOC item to navigate to the corresponding section of the report in the Viewer.

HTML5 Viewer Desktop Parameters Pane

The Parameters pane appears when you click the Sidebar button in the toolbar and then click the Parameters tab. In the Parameters pane, enter a value to filter the data to be displayed.

Click View Report button to view the report according to the selected parameter values.

Note: Internet Explorer and Mozilla Firefox browsers do not support the display of DatePicker control in the Parameters panel. However, DatePicker control is available in case of Google Chrome browser.
Caution: For a DateTime type parameter in HTML5 Viewer, the FormatString for the DatePicker is represented with (mm/dd/yyyy) while the TimePicker is represented with dashes (--:--:-- --).

For more information, see Parameters.

HTML5 Viewer Desktop Search Pane

The Search pane appears when you click the Search button on the toolbar. This pane allows you to search for a specific text in the report.

To search in a report:

  • Enter the word or phrase in the search field.
  • Under the search field, you may choose to use the Match case and Whole phrase options while searching the report.
  • Click the Search button to see the results appear below the Search button.
  • Click an item in the search results to jump to that item in the report.

HTML5 Viewer Custom UI

The custom UI option of the HTML5 Viewer provides the ability to create a customized viewer for targeted devices and to meet the specific application requirements.

You can customize the appearance of the HTML5 Viewer using the public API methods and properties, described in Working with HTML5 Viewer using Javascript.

Note: When using input tags in the HTML 5 viewer, please note that due to limitations in certain browsers, the datetime-local type may not appear correctly.
See Also
Using Javascript
Viewing Reports

Sample ReadMe Files

HTML5 Viewer Sample


Using Javascript

Using Javascript
ActiveReports 10 > ActiveReports User Guide > Viewing Reports > HTML5 > Using Javascript
Show All Show All
Hide All Hide All

Initialization Options

The following options can be set during initialization or at runtime while working with the HTML5 Viewer.

uiType

Description: Sets the UI mode of the HTML5 Viewer.

Type: String

Accepted Value: 'Custom', 'Mobile' or 'Desktop'

Example:
viewer.option('uiType', 'Mobile');

element

Description: JQuery selector that specifies the element that hosts the HTML5 Viewer control.

Note: This option is used during initialization only.

Type: String

Example:
var viewer = GrapeCity.ActiveReports.Viewer(
{
   element: '#viewerContainer2',
   reportService: {
      url: '/ActiveReports.ReportService.asmx'
   },
});

reportService

Description: The report service that can use ActiveReports Server or ActiveReports Web Report Service.

Type: Object that has the url and optional securityToken properties

Example:
reportService: {
   url: 'http://remote-ar-server.com',
   securityToken: '42A9CD80A4F3445A9BB60A221D042FCC',
   resourceHandler: 'http://remote-ar-server.com/resourceHandler.aspx'
};

reportService.url

Description: The url of AR10 Server instance of the AR10 Web service that provides the reportInfo and output.

Type: String

Example:
reportService: {
   url: 'http://remote-ar-server.com'
};

reportService.securityToken

Description: The security key needed to login to the AR10 server.

Type: String

Example:
reportService: {
   securityToken: '42A9CD80A4F3445A9BB60A221D042FCC'
};

reportService.resourceHandler

Description: The url of the AR10 Server resource handler.

Type: String

Example:
reportService: {
   resourceHandler: 'http://remote-ar-server.com/resourceHandler.aspx'
};

report

Description: The report that is displayed in ActiveReports Server or ActiveReports Web Report Service.

Type: An object that has id and parameters properties.

Example:
report: {
   id: 'CustomersList',
   parameters: [
   {
      name: 'CustomerID',
      value: 'ALFKI'
   }]
};

reportID

Description: The id of the report to be shown by the HTML5 Viewer.

Type: String

Example:

Example:
report: {
   id: 'CustomersList',
   parameters: [
   {
      name: 'CustomerID',
      value: 'ALFKI'
   }]
};

reportParameters

Description: The array of the {name, value} pairs that describe the parameters values used to run the report.

Type: Array

Example:
report: {
   id: 'CustomersList',
   parameters: [
   {
      name: 'CustomerID',
      value: 'ALFKI'
   }]
};

reportLoaded

Description: The callback that is invoked when the HTML5 Viewer obtains the information about the requested report. The reportInfo object is passed in the callback including the TOC info, Parameters info and the link to the rendered report result.

Type: function(reportInfo)

Example:
var reportLoaded = function reportLoaded(reportInfo)
   {
      console.log(reportInfo.parameters);
   }
viewer.option('reportLoaded', reportLoaded);

action

Description: The callback that is invoked before the HTML5 Viewer opens the hyperlink, bookmark link, drill down report or toggles the report control visibility.

Type: function(actionType, actionParams)

Example:
function onAction(actionType, actionParams)
{
   if (actionType === 0)
   {
      window.open(params.url, "Linked from report", "height=200,width=200");
   }
}
viewer.option('action', onAction);

availableExports

Description: The array of export types available via Export functionality of HTML5 Viewer. By default, PDF, Word, Image, Mht, and Excel exports are available.

Type: Array

Example:
viewer.option("availableExports", ['Pdf']);

maxSearchResults

Description: The number of search results received for a single search invoke.

Type: Number

Example:
maxSearchResults: 10

error

Description: The callback that is invoked when an error occurs in the process of displaying the report. The default error panel does not appear if the callback returns true. The error parameter is an object that has a message property which allows the users to customize the error message.

Type: function(error)

Example: To hide the default error panel
var options = {
  error: function(error){
    if (error.message) {
      // show error message.
      alert("Internal error! Please ask administrator.");
      return true; // do not show default error message.
    }
  },
  // other properties.
};
var viewer = GrapeCity.ActiveReports.Viewer(options);
Example: To customize the error message
var options = {
  error: function(error){
    error.message = "My error message";
  },
  // other properties
};
var viewer = GrapeCity.ActiveReports.Viewer(options);

documentLoaded

Description: The callback that is invoked when a document is loaded entirely on the server.

Type: function()

Example:
var documentLoaded = function documentLoaded()
   {
      setPaginator();
   }
viewer.option('documentLoaded', documentLoaded);

localeUri

Description: The url of the file containing the localization strings.

Note: This option is used during initialization only.

Type: String

Example:
var viewer = GrapeCity.ActiveReports.Viewer(
{
   localeUri: 'Scripts/i18n/ru.txt'
});

showOnlyLastError

Description: Removes the Show Details button in the error panel and shows only the last error.

Type: String

Example: To hide the Show Details button

var viewer = GrapeCity.ActiveReports.Viewer({
   showOnlyLastError: true
});

Public API Methods and Properties

After initializing the HTML5 Viewer, the following API methods and properties can be used.

Methods

option

Description: Gets or sets the option value by name if the value parameter is specified.

Syntax: option(name,[value])Object

Parameters:

  • name: The option name to get or set.
  • value: (optional) The option value to set. If this argument is omitted than the method returns the current option value.
Example:
viewer.option('uiType', 'mobile');
viewer.option('report', {
   id: 'my report'
});

Return Value: The current option value.

refresh

Description: Refreshes the report preview.

Syntax: option(name,[value])Object

Example:
viewer.refresh()

Return Value: Void

print

Description: Prints the currently displayed report if any.

Syntax: print()Void

Example:
viewer.print()

Return Value: Void

goToPage

Description: Makes the viewer to display the specific page, scroll to the specific offset (optional) and invokes the callback once it's done.

Syntax: goToPage(number, offset, callback)Void

Parameters:

  • number: The number of pages to go to.
  • offset object: The object such as {left:12.2, top:15}.
  • callback: The function to call after perform action.
Example:
viewer.goToPage(1, {
   2, 3
}, function onPageOpened()
{});

Return Value: Void

backToParent

Description: Makes the viewer to display the parent report of the drill-down report.

Syntax: backToParent()Void

Example:
viewer.backToParent()

Return Value: Void

destroy

Description: Removes the viewer content from the element.

Syntax: destroy()Void

Example:
viewer.destroy()

Return Value: Void

export

Description: Exports the currently displayed report.

Syntax: export(exportType,callback,saveAsDialog,settings)Void

Parameters:

  • exportType: Specifies export format.
  • callback: Function that is invoked once the export result is available (its Url is passed in the callback).
  • saveAsDialog: Indicates whether the save as dialog should be shown immediately once the export result is ready.
  • settings: The export settings are available for RenderingExtensions.
    Note: In section reports, the export settings are not enabled when exporting files using the rendering extensions. In Page report and RDL report, the export settings are not enabled when exporting files to PDF using the export filter.

Example:
function exportToExcel()

{
viewer.export('Xls', downloadReport, true, { FileName: "DefaultName.xls" });
}
// function fetches the report from uri(callback function)
var downloadReport = function (uri) {
    var newWin = null;
    // open uri in new window
    try {
        newWin = window.open(uri);
    } catch (e) { }
    // if browser rejects opening new window, open uri in current window
    if (!newWin) {
        window.location = uri;
    }
};

Return Value: Void

search

Description: Performs the search of a specific term with specific search options (match case, whole word) and invokes the specific callback with the search result passed.

Syntax: search(searchTerm, searchOptions, callback)Void

Parameters:

  • searchTerm: String to find.
  • searchOptions: The object optionally defines the search options:
    • matchCase: Whether the search should respect the case.
    • wholePhrase: Whether the search should look for a whole phrase.
  • callback: The function to call after performing search.
Example:
viewer.search('a', {
   matchCase: true,
   wholePhrase: false
}, function (results)
{
   console.log(results);
});

Return Value: Void

getToc

Description: Obtains the part of the report TOC specified by parent(node), startChild(index), count parameters and invokes callback function passing the result as parameter.

Syntax: getToc(callback) Void

Parameters:

  • callback: The callback to handle TOC tree.
Example:
viewer.getToc(function (toc)
{
   console.log(toc);
})

Return Value: Void

Properties

pageCount

Description: Gets the page count of the currently displayed report.

Syntax: viewer.pageCount

Example:
console.log(viewer.pageCount)

Return Value: An integer representing page count.

currentPage

Description: Gets the currently displayed page number.

Syntax: viewer.currentPage

Example:
console.log(viewer.currentPage)

Return Value: An integer representing currently displayed page number.

Toolbar

Description: Returns the HTML element that displays the toolbar in desktop UI mode.

Syntax: viewer.Toolbar

Example:
// Toolbar, MobileToolbarTop, MobileToolbarBottom
$(viewer.toolbar).hide();
$(viewer.toolbarTop).hide();
$(viewer.toolbarBottom).hide();

ToolbarTop

Description: Returns the HTML element that displays the top toolbar in mobile UI mode.

Syntax: viewer.ToolbarTop

Example:
// Toolbar, MobileToolbarTop, MobileToolbarBottom
$(viewer.toolbar).hide();
$(viewer.toolbarTop).hide();
$(viewer.toolbarBottom).hide();

ToolbarBottom

Description: Returns the HTML element that displays the bottom toolbar in mobile UI mode.

Syntax: viewer.ToolbarBottom

Example:
// Toolbar, MobileToolbarTop, MobileToolbarBottom
$(viewer.toolbar).hide();
$(viewer.toolbarTop).hide();
$(viewer.toolbarBottom).hide();
See Also
HTML5 Viewer

Sample ReadMe Files

HTML5 Viewer Sample


Viewing Reports

Viewing Reports
ActiveReports 10 > ActiveReports User Guide > Viewing Reports > HTML5 > Viewing Reports

Viewing Reports in HTML5 Viewer

The following steps describe how to view reports in HTML5 Viewer.

  1. Create a new Visual Studio Web Application project.
  2. Copy and place GrapeCity.ActiveReports.Viewer.Html.js, GrapeCity.ActiveReports.Viewer.Html.min.js and GrapeCity.ActiveReports.Viewer.Html.css files at a suitable location near the target HTML page.
    Note: In ActiveReports, these files are located in the C:\Program Files\GrapeCity\ActiveReports 10\Deployment\Html
  3. In the target HTML page, add the references to the GrapeCity.ActiveReports.Viewer.Html.css, GrapeCity.ActiveReports.Viewer.Html.js and its following dependencies:
    • jQuery 1.9.0 or higher
    • Bootstrap 3.0
    • Knockout.js 2.3.0 or higher
    Note: You can obtain the dependencies like jQuery from Content Delivery Network (CDN) or copy them locally.
    Paste inside the <head></head> tags
    Copy Code
    <link rel="stylesheet" href="css/GrapeCity.ActiveReports.Viewer.Html.css" />
<script src="Scripts/GrapeCity.ActiveReports.Viewer.Html.js" type="text/javascript"></script>
    <script src="//ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js" type="text/javascript"></script>
    <script src="//netdna.bootstrapcdn.com/bootstrap/3.3.1/js/bootstrap.min.js" type="text/javascript"></script>
    <script src="//cdnjs.cloudflare.com/ajax/libs/knockout/3.2.0/knockout-min.js" type="text/javascript"></script>
  4. Add the reference to the bootstrap.min.css in the target HTML page.
    Paste inside the <head></head> tags
    Copy Code
    <link rel="stylesheet" href="//maxcdn.bootstrapcdn.com/bootstrap/3.3.1/css/bootstrap.min.css" />
  5. In the target HTML page, add the DIV element that will contain the HTML5 Viewer.
    Paste inside the <body></body> tags
    Copy Code
    <div id="viewer" style="width:800px;height:600px;"></div>
  6. From the Project menu, select Add New Item.
  7. Open the licenses.licx file, and add the following references to it.
    Paste inside the licenses.licx file
    Copy Code
    GrapeCity.ActiveReports.SectionReport, GrapeCity.ActiveReports.v10, Version=9.99.1979.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff
    GrapeCity.ActiveReports.PageReport, GrapeCity.ActiveReports.v10, Version=9.99.1979.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport, GrapeCity.ActiveReports.Export.Pdf.v10, Version=9.99.1979.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff
    GrapeCity.ActiveReports.Web.WebViewer, GrapeCity.ActiveReports.Web.v10, Version=9.99.1979.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff
  8. In the Add New Item dialog that appears, select ActiveReports 10 Web Service and click Add. The ActiveReports 10 Web Service is required for the proper functioning of the HTML5 Viewer.
  9. Add an ActiveReport to the Visual Studio project. See Adding an ActiveReport to a Project for information on adding different report layouts.
  10. Add the following code to view your report in the HTML5 Viewer. The code might vary depending on the technology that you use to develop the HTML5 Viewer component.
    Paste inside the <script></script> tags
    Copy Code
    $(function ()
{
   var viewer = GrapeCity.ActiveReports.Viewer(
   {
      element: '#viewer',
      report: {
         id: "PageReport.rdlx"

      },
      reportService: {
         url: '/ActiveReports.ReportService.asmx'
      },
      uiType: 'desktop'

   });
});
  11. Press F5 to run the project.

Viewing reports from different domains using CORS

Cross-Origin Resource Sharing is a technology for the web that provides async web operations to directly access reports from different domains. CORS works by adding a special header to responses from a server to the client. If a response contains the Access-Control-Allow-Origin header, then you can directly access the reports from another domain. If you get error 404 or 500 on the report preview, please make sure that your browser supports CORS.

The following steps describe how to access reports from different domain using CORS.

  1. Add Global Application Class file (Global.asax) in your application on the service side.
  2. Open the Global.asax.cs file, and add the following code to access reports using cross websites.
    Paste inside the Global.asax.cs
    Copy Code
     protected void Application_BeginRequest(object sender, EventArgs e)
     {
       HttpContext.Current.Response.AddHeader("Access-Control-Allow-Origin", "*");
       if (HttpContext.Current.Request.HttpMethod == "OPTIONS")
         {
           HttpContext.Current.Response.AddHeader("Access-Control-Allow-Methods", "GET, POST, OPTIONS");
           HttpContext.Current.Response.AddHeader("Access-Control-Allow-Headers", "Content-Type, Accept");
           HttpContext.Current.Response.End();
         }
    Paste inside the Global.asax.vb
    Copy Code
    Sub Application_BeginRequest(ByVal sender As Object, ByVal e As EventArgs)
        HttpContext.Current.Response.AddHeader("Access-Control-Allow-Origin", "*")
        If HttpContext.Current.Request.HttpMethod = "OPTIONS" Then
            HttpContext.Current.Response.AddHeader("Access-Control-Allow-Methods", "GET, POST, OPTIONS")
            HttpContext.Current.Response.AddHeader("Access-Control-Allow-Headers", "Content-Type, Accept")
            HttpContext.Current.Response.End()
        End If
    End Sub

    Note: In case of Internet Explorer 9, you need to add $.support.cors = true; code on the client side while initializing the HTML5 Viewer to access reports from a different domain.

See Also

Getting Started

HTML5 Viewer
Using Javascript


Customize

Customize
ActiveReports 10 > ActiveReports User Guide > Viewing Reports > HTML5 > Customize
Show All Show All
Hide All Hide All

ActiveReports HTML5 Viewer is a fully customizable control. You can easily change the look of the viewer and show or hide the components using its public API.

The following example demonstrates few of the many modifications possible in the HTML5 Viewer. It shows setting the Custom uiType, adding the custom buttons for Print and Export and adding the Paginator control that allows you to display the number of report pages and to navigate through them.

Note: These steps assume that you have already created a new ASP.Net Web Application and added a sample report to display in the viewer.
  1. Add a new HTML page item to the project and in the Name field, rename the page item as HTML5Viewer.html.
  2. Copy and place GrapeCity.ActiveReports.Viewer.Html.js and GrapeCity.ActiveReports.Viewer.Html.css files in the project folder and add them to your project.
    Note: In ActiveReports, these files are located in the C:\Program Files\GrapeCity\ActiveReports 10\Deployment\Html folder.
  3. In the HTML5Viewer page item, add references to the stylesheets that will control the styling and appearance of the HTML5 Viewer.
    Note: You can obtain the source of Bootstrap.min.js from Content Delivery Network (CDN) like shown in the code below. You can also download the file from the source website and add the file to the project locally.

    Code

    Paste inside the <head></head> tags
    Copy Code
    <link href="//netdna.bootstrapcdn.com/bootstrap/3.0.0/css/bootstrap.min.css" rel="stylesheet" />
<link href="/GrapeCity.ActiveReports.Viewer.Html.css" rel="stylesheet" />
  4. Add the following DIV element inside the <body></body> tags that will contain the HTML5 Viewer and the Paginator control.

    Code

    Paste inside the <body></body> tags
    Copy Code
    <div class="container">
    <div id="paginator" class="pagination"></div>
    <div id="viewer" style="width: auto; height: 600px"></div>
</div>
  5. Add the following Style element inside the <body></body> tags to make the viewer fill the entire browser window.

    Code

    Paste inside the <body></body> tags
    Copy Code
    <style>
    #viewer {
    position: absolute;
    left: 5px;
    right: 5px;
    top: auto;
    bottom: 5px;
    font-family: 'segoe ui', 'ms sans serif';
    overflow: hidden;
   }
</style>
  6. Add the following DIV element inside the <body></body> tags that will contain the buttons for Print and Export.

    Code

    Paste inside the <body></body> tags
    Copy Code
    <div class="panel panel-default">
    <div class="panel-heading">
        <div id="appToolbar" class="btn-toolbar" style="margin-bottom: 10px">
            <button type="button" class="btn" id="btnPrint">
                Print</button>
           <button type="button" class="btn" id="btnExport">
                Export to PDF</button>
        </div>
    </div>
</div>
  7. In the Project menu, click Add New Item, select ActiveReports 10 Web Service and then click the Add button. This adds the ActiveReports.ReportService.asmx file to the project.
  8. Add the reference to the GrapeCity.ActiveReports.Viewer.Html.js and its following dependencies:
    • jQuery 1.10.2 or higher
    • Bootstrap 3.1.0 or higher
    • Knockout 2.3.0 or higher
    Note: You can obtain the source of dependencies like jQuery from Content Delivery Network (CDN). You can also download and add them to the project locally.

    Code

    Paste inside the <head></head> tags
    Copy Code
    <script src="//cdnjs.cloudflare.com/ajax/libs/jquery/1.10.2/jquery.js" type="text/javascript"></script>
<script src="//cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/3.1.0/js/bootstrap.js" type="text/javascript"></script>
<script src="//cdnjs.cloudflare.com/ajax/libs/knockout/2.3.0/knockout-debug.js" type="text/javascript"></script>
<script src="/GrapeCity.ActiveReports.Viewer.Html.js" type="text/javascript"></script>
  9. Add the following script element below other script elements to create the HTML5 Viewer for the viewer <div> element we have added above.

    Code

    Paste inside the <body></body> tags
    Copy Code
    <script type="text/javascript">
   $(function () {
       var paginator = $('#paginator');
       var viewer = GrapeCity.ActiveReports.Viewer(
           {
               element: '#viewer',
               report: {
                   id: "SampleReport.rdlx"
               },
               reportService: {
                   url: '/ActiveReports.ReportService.asmx'
               },
               //Setting the uiType to Custom
               uiType: 'custom',
               documentLoaded: function () {
                   setPaginator();
               }
           });
     //Creating the function for Printing
       $('#btnPrint').click(function () {
             viewer.print();
       });
     //Creating the function for Exporting
       $('#btnExport').click(function () {
           viewer.export('Pdf', function (uri) {
               window.open(uri);
           }, false, {});
       });

       //Creating the function for using Paginator control to display report pages and to navigate through them
       function setPaginator() {
           if (viewer.pageCount > 0) {
               for (var i = 1; i <= viewer.pageCount; i++) {
                   $('<li data-bind="' + i + '"><a class="js-page" href="javascript:void(0)">' + i + '</a></li>').appendTo(paginator);
               }
               paginator.children(":first").addClass('active');
               paginator.children().click(function () {
                   var self = $(this);
                   viewer.goToPage(self.attr('data-bind'), 0, function () {
                     paginator.children().removeClass('active');
                     self.addClass('active');
                   });
               });
           }
       }
   });
</script>
  10. Press F5 to run the project and navigate to the webpage containing the HTML5 Viewer that we have just created.
  11. As the report gets loaded in the viewer, use the paginator control to navigate through the all the report pages and click Print or Export to PDF to print or export the displayed report.


Localize and Deploy

Localize and Deploy
ActiveReports 10 > ActiveReports User Guide > Viewing Reports > HTML5 > Localize and Deploy

Localization

The HTML5 viewer can be localized by localizing the strings present in the en.txt file and then using it through the localeUri option while initializing the viewer. The en.txt file contains strings for viewer's toolbar items, panes, dialogs and errors. These strings can be localized to any culture and should be saved in the UTF-8 format. Follow these steps to learn localizing the HTML5 viewer:

  1. Go to C:\Program Files\GrapeCity\ActiveReports 10\Deployment\Html\i18n and open the en.txt file in a Notepad.
  2. Localize the strings in the file to any desired culture and save the file in the UTF-8 format as jp.txt.
  3. Add the newly created localized file to the project containing the HTML5 viewer. See Using Javascript to learn creating the HTML5 viewer.
  4. In the targeted HTML page that contains code to create the HTML5 viewer, paste the following code:
    XML
    Copy Code
    var viewer = GrapeCity.ActiveReports.Viewer(
{
   localeUri: 'Scripts/i18n/jp.txt'
});
  5. Press F5 to run the project and navigate to the webpage containing the HTML5 Viewer with localized strings.

Deployment

You can deploy the HTML5 viewer on IIS by deploying the ActiveReports Web Application that contains the viewer.

See Using Javascript to learn creating the HTML5 viewer in a ASP.Net Web Application project and Deploy Web Applications to learn deploying an ActiveReport Web Application.


Silverlight Viewer

Silverlight Viewer
ActiveReports 10 > ActiveReports User Guide > Viewing Reports > Silverlight Viewer
Show All Show All
Hide All Hide All

ActiveReports provides a Silverlight Viewer to where you can load and view your reports. This viewer contains a toolbar and a sidebar with Search, Table of Contents and Parameters panes.

Note: Microsoft Silverlight 4 Tools are required for application development with the ActiveReports Silverlight Viewer.

Silverlight Viewer toolbar

Toolbar element | Name | Description
 | Toggle Sidebar | Displays the sidebar that includes the Search, TOC (Table of Contents), and Parameters panes.
 | Print | Displays the Print dialog where you can specify the printing options.
 | Find | Displays the Search pane in the sidebar.
 | Zoom out | Decreases the magnification of your report.
 | Zoom reset | Resets the magnification to default
 | Zoom slider | Allows you to drag the slider to increase or decrease the magnification of your report.
 | Zoom in | Increases the magnification of your report.
 | Fit page width | Fits the width of the page according to viewer dimensions.
 | Fit whole page | Fits the whole page within the current viewer dimensions.
 | First page | Takes you to the first page of the report. This button is enabled when a page other than the first page is open.
 | Previous page | Takes you to the page prior to the current page. This button is enabled when a page other than the first page is open.
 | Current page | Shows the current page number and opens a specific page in the report. To view a specific page, type the page number and press the Enter key.
 | Next page | Takes you to the page following the current page. This button is disabled on reaching the last page of the report.
 | Last page | Takes you to the last page of the report. This button is disabled on reaching the last page of the report.
 | Backward | Takes you to the last viewed page. This button is enabled when you move to any page from the initial report page. Clicking this button for the first time also enables the Forward button.
 | Forward | Takes you to last viewed page before you clicked the Backward button. This button is enabled once you click the Backward button.
 | Back to Parent Report | Returns to the parent report in a drillthrough page or RDL report.
 | Export Format | Allows you to specify the export format for a report. You can select from the following options: PDF, Excel, HTML, Word, or XML.
 | Export Report | Exports a report into the selected format.

Silverlight Viewer Sidebar

Search Pane

The Search pane appears by default in the sidebar when you click the Toggle Sidebar button. This pane lets you enter a word or phrase to search within the report.

To search in a report:

  1. Enter the word or phrase in the search field.
  2. Under Use this additional criteria, you may optionally choose to search for the whole word or match the case of the search string while searching in the report.
  3. Click the Search button to see the results appear in the Find results list.
  4. Click an item in the list to jump to that item in the report and highlight it.

To start a new search or clear the current search results, click the Clear button under the Find results list.

Table of Contents (TOC) Pane

To display the Table of Contents pane, in the toolbar, click Toggle Sidebar. Then at the bottom of the sidebar, click the Table of Contents button.

If a report does not have the Label property or Document map label set, the Table of Contents (TOC) pane does not appear in the sidebar.

Parameters Pane

The Silverlight Viewer allows you to view reports with parameters. In the toolbar, click the Toggle sidebar button to open the sidebar and if your report contains parameters, the Parameters pane shows up automatically.

  1. In the Parameters pane, you are prompted to enter a value by which to filter the data to display.
  2. Enter a value or set of values and click View report, to filter the report data and display the report.

If a report does not have parameters, the Parameters pane does not appear in the sidebar.

Display the report in the Viewer

Set up your Silverlight project using the following steps: (see the Silverlight walkthrough for more details)

  1. Create a new Silverlight project or open an existing one, ensuring that the Silverlight Version option is set to Silverlight 4 or higher.
  2. In the Visual Studio Solution Explorer, right-click YourProject.Web and select Add, then New Item.
  3. In the Add New Item dialog that appears, select the Reporting template, then select ActiveReports 10 Web Service. This adds ActiveReports.ReportService1.asmx to your project.
  4. From the Toolbox tab, drag the Viewer control and drop it on the design view of MainPage.xaml.
  5. In the Solution Explorer, right-click YourProject.Web and select Add, then Existing Item and select an existing report to load in the viewer.
  6. On MainPage.xaml, with the viewer selected, go to the Properties window and double click the Loaded event.
  7. In the MainPage code view that appears, add code like the following to the viewer1_loaded event to bind the report to the viewer. This code shows an .rdlx report being loaded but you can use a .rpx report as well.
    Visual Basic.NET code. Paste INSIDE the viewer1_Loaded event in MainPage.xaml.vb.
    Copy Code
    Viewer1.LoadFromService("YourReportName.rdlx")
    C# code. Paste INSIDE the viewer1_Loaded event in MainPage.xaml.cs.
    Copy Code
    viewer1.LoadFromService("YourReportName.rdlx");

To avoid evaluation banners appearing at runtime, license your ActiveReports Silverlight project. You can find information on licensing ActiveReports Silverlight in License Your ActiveReports under To license an ActiveReports Silverlight project.

Silverlight Viewer printing

  1. In the Silverlight viewer toolbar, click the Print button.
  2. In the Print dialog that appears, select the printer settings and click Print.

In addition to the standard Silverlight print option, you can setup PDF printing in your Silverlight project and print a document from Silverlight to the PDF format directly.

Note: PDF printing is not supported in the Silverlight Out-of-Browser applications.

See Provide PDF Printing in the Silverlight Viewer (Pro Edition) to learn how you can set up and print a report from the Silverlight Viewer to PDF format.

Silverlight feature limitations

  • Limitations on printing:
    • ActiveReports Silverlight Viewer does not provide the one-touch printing option.
    • The maximum value for the print range is 2000 pages.
  • Vertical text is not supported in the ActiveReports Silverlight Viewer.
  • Horizontal and vertical text of MS PMincho and some other ideographic characters may render incorrectly in the ActiveReports Silverlight Viewer.
  • The use of the Silverlight Viewer control in layout panels has a limitation related to the default size of the panel.
  • The multipage mode is not available in the ActiveReports Silverlight Viewer.
  • To display a report with annotations in the Thumbnails view correctly, hide the Thumbnails view by clicking the Show TOC/Thumbnails icon in the Toolbar and then open the report in the Silverlight Viewer.
  • IIS Express setting needs to be done when loading an RDF file in the Viewer. For more details, go to the Silverlight Viewer Troubleshooting section in Troubleshooting.
  • Some Silverlight properties and events are not supported in XAML. However, you can still use these properties by setting them in code as follows:
    Visual Basic.NET code. Add this code in an event like Button_Click.
    Copy Code
    Viewer1.FontStyle = FontStyles.Italic
    C# code. Add this code in an event like Button_Click.
    Copy Code
    viewer1.FontStyle = FontStyles.Italic;

    Silverlight properties and events that are not supported

    Properties

    • FontStyle
    • FontWeight
    • FontFamily
    • FontSize
    • Foreground
    • FontStretch
    • Padding
    • VerticalContentAlignment
    • HorizontalContentAlignment
    • IsTabStop

    Events

    • GotFocus
    • LostFocus
See Also
Web Viewer (ASP.NET)

How To

Provide PDF Printing in the Silverlight Viewer (Pro Edition)
License Your ActiveReports


WPF Viewer

WPF Viewer
ActiveReports 10 > ActiveReports User Guide > Viewing Reports > WPF Viewer
Show All Show All
Hide All Hide All

ActiveReports provides the WPF Viewer that you can use to load and view your reports. This viewer contains a toolbar and a sidebar with Thumbnails, Search results, Document map and Parameters panes.

Warning: The TargetInvocationException occurs on running a WPF browser application in Partial Trust. Refer to Running WPF Viewer in Partial Trust section given below to run your WPF Browser Application in Partial Trust. To ensure that you are using Full Trust:

  1. From the Visual Studio Project menu, select YourProject Properties.
  2. On the Security tab, under Enable ClickOnce security settings, select the This is a full trust application option.

WPF Viewer Toolbar

The following table lists the actions you can perform through the WPF Viewer toolbar.

Toolbar Element | Name | Description
 | Toggle Sidebar | Displays the sidebar that includes the Thumbnails, Parameters, Document map and Search results panes.
 | Print | Displays the Print dialog where you can specify the printing options.
 | Find | Displays the Find dialog to find any text in the report.
 | Zoom out | Decreases the magnification of your report.
 | Zoom in | Increases the magnification of your report.
 | Current zoom | Displays the current zoom percentage which can also be edited.
 | Fit page width | Fits the width of the page according to viewer dimensions.
 | Fit whole page | Fits the whole page within the current viewer dimensions.
 | First page | Takes you to the first page of the report. This button is enabled when a page other than the first page is open.
 | Previous page | Takes you to the page prior to the current page. This button is enabled when a page other than the first page is open.
 | Current page | Opens a specific page in the report. To view a specific page, type the page number and press the Enter key.
 | Next page | Takes you to the page following the current page. This button is disabled on reaching the last page of the report.
 | Last page | Takes you to the last page of the report. This button is disabled on reaching the last page of the report.
 | Backward | Takes you to the last viewed page. This button is enabled when you move to any page from the initial report page. Clicking this button for the first time also enables the Forward button.
 | Forward | Takes you to last viewed page before you clicked the Backward button. This button is enabled once you click the Backward button.
 | Back to parent report | Returns you to the parent report in a drillthrough report.
 | Refresh | Refreshes the report.
 | Cancel | Cancels rendering of the report.

WPF Viewer Sidebar

The WPF Viewer sidebar appears on the left of the Viewer control when you click the Toggle sidebar button in the toolbar. By default, this sidebar shows the Thumbnails and Search Results panes. The additional Document map and Parameters also appear in this sidebar. You can toggle between any of the viewer panes by clicking the buttons for each pane at the bottom of the sidebar.

Thumbnails pane

The Thumbnails pane appears by default in the sidebar when you click the Toggle sidebar button in the toolbar.

This pane is composed of a thumbnail view of all the pages in a report. Click any thumbnail to navigate directly to the selected report page. You can also modify the size of the thumbnail when you click (+) or (-) button to zoom in and zoom out.

Search results pane

The Search pane is the other default pane besides Thumbnails that appears in the sidebar when you click the Toggle sidebar button. This pane lets you enter a word or phrase from which to search within the report.

To search in a report:

  • Enter the word or phrase in the search field.
  • Under Use these additional criteria, you may optionally choose to search for the whole word or match the case of the search string while searching in the report.
  • Click the Search button to see the results appear in the Find results list.
  • Click an item in the list to jump to that item in the report and highlight it.

To start a new search or clear the current search results, click the Clear button under the Find results list.

Document map pane

The Documents map pane sis enabled for reports where the Label property or the Document map label is set. This pane displays each value for the text box, group, or sub report that you label, and you can click them to navigate to the corresponding area of the report in the Viewer.

If a report does not have the Label property or Document map label set, the Documents map panes does not appear in the sidebar.

Parameters pane

The WPF Viewer allows you to view reports with parameters. In the toolbar, click the Toggle sidebar button to open the WPF Viewer sidebar and if your report contains parameters, the Parameters pane shows up automatically.
  1. In the Parameters pane, you are prompted to enter a value by which to filter the data to display.
  2. Enter a value or set of values and click View report, to filter the report data and display the report.

If a report does not have parameters, the Parameters pane does not appear in the sidebar.

Display the report in the WPF Viewer

Set up your WPF Application project by using the following steps.

  1. Create a new WPF Application project or open an existing one.
  2. For a new project, in the Visual Studio Solution Explorer, right-click YourProject and select Add, then New Item.
  3. In the Add New Item dialog that appears, select the ActiveReports 10 Page Report, ActiveReports 10 RDL Report, ActiveReports 10 Section Report (code-based) or ActiveReports 10 Section Report (xml-based). This adds the necessary references to your project.
  4. From the Toolbox ActiveReports 10 tab, drag the Viewer control and drop it on the design view of MainWindow.xaml.
    Note: Dragging the Viewer control to the design view of MainWindow.xaml automatically adds the corresponding reference to the licenses.licx file.
  5. In the Properties window, with the report selected, set Copy to Output Directory to Copy Always.
  6. On MainWindow.xaml, with the viewer selected, go to the Properties window and double click the Loaded event.
  7. In the MainWindow code view that appears, add code like the following to the viewer1_loaded event to bind the report to the viewer. Each of these code snippets presumes a report in the project of the type indicated with the default name. (If you have renamed your report, you need to rename it in the code as well).
    Note:
    • Refer to the LoadDocument method to see other ways to load a report in WPF Viewer.
    • Microsoft .NET Framework version 4.0 or higher is required to view reports in WPF Viewer.

    To write the code in Visual Basic.NET

    The following example demonstrates how you display a page report or RDL Report in the WPF Viewer control.

    Visual Basic.NET code. Paste INSIDE the viewer1_Loaded event in MainWindow.xaml.vb.
    Copy Code
    Viewer1.LoadDocument("YourReportName.rdlx")

    The following example demonstrates how you can display a section report (code-based) in the WPF Viewer control.

    Visual Basic.NET code. Paste INSIDE the viewer1_Loaded event in MainWindow.xaml.vb.
    Copy Code
    viewer1.LoadDocument(new YourReportName())

    The following example demonstrates how you can display a section report (xml-based) in the WPF Viewer control.

    Visual Basic.NET code. Paste INSIDE the viewer1_Loaded event in MainWindow.xaml.vb.
    Copy Code
    Viewer1.LoadDocument("YourReportName.rpx")

    To write the code in C#

    The following example demonstrates how you display a page report or RDL report in the WPF Viewer control.

    C# code. Paste INSIDE the viewer1_Loaded event in MainWindow.xaml.cs.
    Copy Code
    viewer1.LoadDocument("YourReportName.rdlx");

    The following example demonstrates how you can display a section report (code-based) in the WPF Viewer control.

    C# code. Paste INSIDE the viewer1_Loaded event in MainWindow.xaml.cs.
    Copy Code
    viewer1.LoadDocument(new YourReportName());

    The following example demonstrates how you can display a section report (xml-based) in the WPF Viewer control.

    C# code. Paste INSIDE the viewer1_Loaded event in MainWindow.xaml.cs.
    Copy Code
    viewer1.LoadDocument("YourReportName.rpx");

Additional Features

Following is an introduction to the additional capabilities of the Viewer to guide you on using it effectively.

Keyboard Shortcuts

The following shortcuts are available on the WPF Viewer.

Keyboard Shortcut | Action
Ctrl + F | Shows the search pane.
Ctrl + P | Shows the print dialog.
Esc | Closes the print dialog.
Page Down | Moves to the next page.
Page Up | Moves to the previous page.
Ctrl + T | Shows or hides the table of contents.
Ctrl + Home | Moves to the first page.
Ctrl + End | Moves to the last page.
Ctrl + Right | Navigates forward.
Ctrl + Left | Navigates backward.
Ctrl + - | Zooms out.
Ctrl + + | Zooms in.
Left, Right, Up, Down | Moves the visible area of the page in the corresponding direction.
Ctrl + 0 (zero) | Sets the zoom level to 100%.
Ctrl + rotate mouse wheel | Changes the zoom level up or down.
Ctrl + G | Moves the focus to current page toolbar option.
F5 | Refreshes the report.

Advance Printing Options

You can set the PrintingSettings property of the Viewer to directly print without displaying a dialog or to switch from a ActiveReports print dialog to a .NET Framework standard print dialog (System.Windows.Forms.PrintDialog) on clicking the Print button on the Viewer toolbar. You can set the PrintingSettings property of the Viewer control from the Properties window.

PrintingSettings property provides the following options:

PrintingSettings Options | Description
ShowPrintDialog | Displays a dialog in which the user can set the printer options before printing.
ShowPrintProgressDialog | Displays a print progress dialog, in which the user can cancel the printing job.
UsePrintingThread | Specifies whether printing should be performed for individual threads or not.
UseStandardDialog | Specifies whether to use the .NET Framework standard print dialog (System.Windows.Forms.PrintDialog) while printing the document (section or page).

Running WPF Viewer in Partial Trust

You can run a WPF Viewer Browser Application in Partial Trust by customizing the permission set in the app.mainfest file. While customizing the permission set, some of the permissions are to be set explicitly like MediaPermission, UIPermission, etc. Follow these steps to learn how to run a WPF Viewer application in partial trust.

Note: These steps assume that you have already created a WPF Browser Application that contains the WPF Viewer control.
  1. In the Solution Explorer, right-click your WPF Browser Application and select Properties.
  2. On the properties page that opens, go to the Security tab.
  3. On the Security tab, set Zone your application will be installed from to Custom and click the Edit Permissions XML button. This opens the app.mainfest file.
  4. In the app.manifest file, replace the existing xml code inside the <applicationRequestMinimum> </applicationRequestMinimum> tags with the following code.

    Code

    XML
    Copy Code
    <defaultAssemblyRequest permissionSetReference="Custom" />
<PermissionSet class="System.Security.PermissionSet" version="1" ID="Custom" SameSite="site">
  <IPermission class="System.Data.SqlClient.SqlClientPermission, System.Data, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" Unrestricted="true" />
  <IPermission class="System.Data.OleDb.OleDbPermission, System.Data, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" Unrestricted="true" />
  <IPermission class="System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" Unrestricted="true" />
  <IPermission class="System.Security.Permissions.MediaPermission, WindowsBase, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" version="1" Audio="SafeAudio" Video="SafeVideo" Image="SafeImage" />
  <IPermission class="System.Security.Permissions.UIPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" Unrestricted="true" />
  <IPermission class="System.Security.Permissions.EnvironmentPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" Unrestricted="true" />
  <IPermission class="System.Security.Permissions.FileIOPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" Unrestricted="true" />
  <IPermission class="System.Security.Permissions.ReflectionPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" Unrestricted="true" />>
  <IPermission class="System.Security.Permissions.StrongNameIdentityPermission, , mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" version="1" Unrestricted="true" />
</PermissionSet>
  5. Press F5 to run your WPF Browser Application.
Note: The Partial Trust Limitations are applicable to the WPF viewer running in Partial Trust. For more information, see Medium Trust Support.
See Also
ActiveReports Server

Walkthroughs

WPF Viewer


ReportService Settings

ReportService Settings
ActiveReports 10 > ActiveReports User Guide > Viewing Reports > ReportService Settings

ActiveReports ReportService supports some external settings, which are useful while previewing reports in Web Viewers. The following table describes each of these settings with an example.

Setting | Description | Example
accessPoint | It is the path to report service descriptor. This setting should be used in a Web Viewer to override the default web service. This setting is only required for Web/Flash Viewer. | <ActiveReports10> <WebService accessPoint="http.../*.asmx" /> </ActiveReports10>
reportsFolder | It is the relative path to reports on the server. Supported in all viewers. | <ActiveReports10> <WebService reportsFolder="~" /> </ActiveReports10>
publicURI | It is a special setting to support redirection because report service results contain absolute URIs. Supported in all viewers. | <ActiveReports10> <WebService publicURI="http.../" /> </ActiveReports10>
reportLifetime | It is the current report lifetime if the report tab is not closed. The default report lifetime is 10 minutes, but it can be set to any value. It is not recommended to make the report lifetime less than 2 minutes. Supported in all viewers. | <ActiveReports10> <WebService reportLifetime="00:10:00" /> </ActiveReports10>
maxReportLifetime | It is the maximum allowed report lifetime, after which the report is destroyed on the server. The default maximum report lifetime is 24 hours; it can be set to any value. Supported in all viewers. | <ActiveReports10> <WebService reportLifetime="24:00:00" /> </ActiveReports10>
assemblyFolder | It is the temporary folder path, specified only if required. Supported in all viewers. | <ActiveReports10> <WebService assemblyFolder="~" /> </ActiveReports10>
Note: ReportService settings do not work in obsolete Medium trust environment.


ActiveReports Server

ActiveReports Server
ActiveReports 10 > ActiveReports User Guide > Viewing Reports > ActiveReports Server

The ActiveReports WinForms Viewer and WPF Viewer let you print, and export reports that are hosted on ActiveReports Server. You can view reports in both the Viewers from the File menu using the Open from server command, or through code by invoking the ViewerExtension.LoadDocument method.

You can also view a specific report revision from ActiveReports Server. See Report Versions, for more information.

View Reports from ActiveReports Server

  1. From the Start menu, run the ActiveReports Viewer.
    Note: You can also find the Viewer.exe along with the WpfViewer.exe in the ...\Program Files\Common Files\GrapeCity\ActiveReports 10 folder.
  2. In the viewer, from the File menu, select Open from server.
  3. In the Open report from server dialog that appears, enter the Server URL.
    Note: The server address syntax is http://<ServerName>:<PortNumber>/ where ServerName is the name of the machine on which ActiveReports Server is installed and PortNumber is the port on IIS where the server is installed. Example: http://1.0.0.0:8080/

  4. Enter the User Name and Password, and click Connect. The Connection status message changes to indicate when you are connected.
  5. Double click to navigate through the report folders below, select a report to view, and click Open.
    Note : The folders are Report Categories in ActiveReports Server. You can also view a specific version of a report from the server. Click the drop-down arrow next to the Open button to see a list of report revisions.

View Reports from ActiveReports Server Through Code

The following code example demonstrates how you can view reports that are hosted on ActiveReports Server in the Windows Forms Viewer or WPF Viewer.

Note : To view reports remotely from ActiveReports Server through code, add a reference to Json.NET (installed with ActiveReports).
  1. In Visual Studio, create a new Windows Forms or WPF application.
  2. From the toolbox, drag the Viewer control and drop it on the Windows Form or on the design view of MainWindow.xaml.
  3. Select the Viewer control, and in the Properties window, select the Events tab. Double click the Load (or Loaded event in case of WPF application) to create an event handling method.
  4. In the event handling method, add code like the following.
    Visual Basic.NET code. Paste at beginning of code view.
    Copy Code
    Imports GrapeCity.ActiveReports.ArsClient
    Visual Basic. NET code. Paste INSIDE Form_Load event.
    Copy Code
    Dim serverReport As New RemoteReportDescriptor()
' Specify the Server URL and Credentials
serverReport.ReportServerUrl = "http://1.0.0.0:8080/"
serverReport.UserName = "admin_user"
serverReport.Password = "password@123"

' Specify the Report Name
serverReport.ReportName = "Customer List"
serverReport.RevisionNumber = 1
Viewer1.LoadDocument(serverReport)
    C# code. Paste at beginning of code view.
    Copy Code
    using GrapeCity.ActiveReports.ArsClient;
    C# code. Paste INSIDE Form_Load event.
    Copy Code
    RemoteReportDescriptor serverReport = new RemoteReportDescriptor();
// Specify the Server URL and Credentials
serverReport.ReportServerUrl = "http://1.0.0.0:8080/";
serverReport.UserName = "admin_user";
serverReport.Password = "password@123";

// Specify the Report Name
serverReport.ReportName = "Customer List";
serverReport.RevisionNumber = 1;
viewer1.LoadDocument(serverReport);
See Also
GrapeCity.ActiveReports.ArsClient Namespace

Getting Started

Windows Forms Viewer
WPF Viewer


Medium Trust Support

Medium Trust Support
ActiveReports 10 > ActiveReports User Guide > Viewing Reports > Medium Trust Support
Show All Show All
Hide All Hide All

All features of ActiveReports are available without restrictions in a Full trust environment. You can also use ActiveReports under Medium trust, but with limitations on some of the features.

Caution: Medium trust does not adequately protect your application and should not be used. For more information see MSDN link.

Note:

  • If you see an evaluation banner when deploying your ActiveReports project, you should use the Web Key Generator utility to create the Web Key and integrate the license information into your project.
  • Assemblies placed in the Global Assembly Cache, or GAC (C:\WINDOWS\ASSEMBLY), have Full trust permissions, so the results on your deployment machine may differ from those on your development machine.

Feature Limitations

  1. Exporting
    • RTF, Text, TIFF and Excel filters are not supported in Medium trust.
    • Digital signatures cannot be used in case of PDF rendering extension and PDF export.
    • Chart and Tablix control of Page Reports and RDL Reports are not displayed properly in case of PDF rendering extension and PDF export.

  2. The End User Designer and Windows Form Viewer controls require Full trust.
  3. The Picture control does not support metafiles, which require Full trust.
  4. The ImageType property of the Chart control must be set to PNG.
  5. OleObject, FormattedText and Custom controls require Full trust.
  6. Scripting requires Full trust, so if you need to use code in reports under Medium trust, use code-based reports rather than RPX format.
  7. WebViewer
    • Bullet, Sparkline and Calendar control of PageReports and RDLReports are not displayed in all the Viewer types.
    • Report containing the Image control of PageReports and RDLReports is not displayed properly in case of HTML type.

Recommended Development Environment for Medium Trust Tests

To set up a Medium trust environment

Open the Web.config file and paste the following code between the <system.web> and </system.web> tags.

XML code. Paste BETWEEN the system.web tags.
Copy Code
<trust level="Medium"></trust>

To set up the PrintingPermission level

Most hosting providers disable the printing permissions in a partially trusted environment.

  1. Open the web_mediumtrust. config file (located in the \Windows\Microsoft.NET\Framework\v4.0.30319\Config folder).
  2. Set the PrintingPermission level to NoPrinting.
XML code. Paste BETWEEN the system.web tags.
Copy Code
<IPermission class="PrintingPermission"version="1"Level="NoPrinting"/>
Note: The default set of medium trust permissions is available in the web_mediumtrust.config.default file.
See Also

How To

License Your ActiveReports


Concepts

Concepts
ActiveReports 10 > ActiveReports User Guide > Concepts

Learn about concepts that help you to understand how best to use ActiveReports.

This section contains information about

ActiveReports Designer
Learn what each of the tools and UI items on the report designer can help you to accomplish.
Report Types
Learn which type of ActiveReport best suits your needs.
Page Report/RDL Report Concepts
Learn basic concepts that apply to Page reports and RDL reports.
Section Report Concepts
Learn basic concepts that apply to Section reports.
Exporting
Learn about rendering extensions and exports, and which formats are available with Page and Section reports.
Visual Query Designer
Learn about Visual Query Designer features and it's SQL capabilities.
Server Reports
Learn how to open and save reports in the ActiveReports designer from the from ActiveReports Server.
Interactive Features
Learn about various interactive features that affect your report output.
Report Parts
Learn about the concept of report parts and how to use them in ActiveReports.
Shared Subreport
Learn about the concept of shared subreport and how to use them in ActiveReports.
Text Justification
Learn how to use the TextJustify property.
Multiline in Report Controls
Learn how to enter multiline text in a report.
Line Spacing and Character Spacing
Learn how to control line spacing and character spacing in TextBox and Label report controls.
Designer Control (Pro Edition)
Learn how you can provide a Windows Forms report designer for your end users.
Shrink Text to Fit in a Control
Learn how to shrink text to fit in a TextBox control.
Stand-Alone Designer and Viewers
Learn about the stand-alone designer and Viewer applications that help you create, edit and view a report quickly.
Localization
Learn about the ActiveReports localization model.
Section 508 Compliance
Learn about Section 508 compliance.
See Also

How To

How To

Getting Started

Getting Started

Walkthroughs

Samples and Walkthroughs


ActiveReports Designer

ActiveReports Designer
ActiveReports 10 > ActiveReports User Guide > Concepts > ActiveReports Designer
Show All Show All
Hide All Hide All

ActiveReports offers an integrated designer that lets you create report layouts in Visual Studio and edit them at design time, visually, and through code, script, or regular expressions. Like any form in Visual Studio, it includes a Property Window with extensive properties for each element of the report, and also adds its own Toolbox filled with report controls, and a Report Explorer with a tree view of report controls.

The designer supports two types of report layouts: section layout and page layout.

Section Report Layout

This layout presents reports in three banded sections by default: page header, detail and page footer. You can remove the page header and footer, add a report header and footer, and add up to 32 group headers and footers. Drag controls onto these sections to display your report data. Reports designed in this layout are saved in RPX format.

Page Report Layout

This layout defines reports in pages where the same page layout can be used throughout the report or separate layout pages are designed for complex reports. Reports designed in this layout are saved in Rdlx format.

RDL Report Layout

This layout defines reports where controls grow vertically to accommodate data.Reports designed in this layout are saved in Rdlx format.

In this section

Design View
Explore the elements of the design tab that appear with both types of reports.
Report Menu
Learn about the options available in the Report menu in Visual Studio.
Designer Tabs
Find general information about the Designer, Script, and Preview tabs of the designer.
Designer Buttons
Learn to control grid settings, drag and drop settings, and mouse modes on the designer.
Page Tabs
Explore the ways that you can use different page layouts in the same report in Page Reports.
Toolbar
Learn about the commands available in the ActiveReports Toolbar.
Report Explorer
Learn how you can use the Report Explorer to manage the report controls, data regions, parameters, and other items in your reports.
Layers List
Learn how you can use layers for tracing pre-printed layouts, performing target specific printing and exporting in Page Reports and RDL Reports.
Toolbox
Find information on controls you can use to design report layouts.
Properties Window
See an overview of how to access properties for report controls, data regions, report sections, and the report itself.
Rulers
Learn how you can use rulers to align your controls on the report design surface.
Scroll Bars
See an explanation of scroll bars including the new auto scrolling feature.
Snap Lines
Find information about snap lines, and how they work.
Zoom Support
Get the ability to zoom in or zoom out of your report layout.
See Also

Getting Started

Adding ActiveReports Controls
Adding an ActiveReport to a Project


Design View

Design View
ActiveReports 10 > ActiveReports User Guide > Concepts > ActiveReports Designer > Design View
Show All Show All
Hide All Hide All

The report designer is fully integrated with the Microsoft Visual Studio IDE. In this topic, we introduce the main parts of the designer in section and page reports to help you select the one to best suit your specific needs.

Report designer in section reports

In a section report, the designer offers the following features that you can use to create, design and edit a report.

Design Surface

The design surface offers a default report structure that contains a page header, a detail section, and a page footer along with some grey area below these sections. Drag report controls and fields onto these sections to display your data. Use section grab handles to drag a section's height up or down. Right click the report and select Insert to add other types of header and footer section pairs.

DataSource Icon

The DataSource icon is located in the band along the top of the detail section. Click this icon to open the Report Data Source dialog, where you can bind your report to any OLE DB, SQL, or XML data source. See Report Data Source Dialog for more information

Section Collapse Icon

A Section Collapse icon (-) appears on each band adjacent to the section header. When you click the collapse icon the section collapses and an expand icon (+) appears. Please note that section collapse is only available in the Designer tab. All sections of the report are visible in the Preview tab or when the report is rendered.

Tip: In order to make a section invisible, set the Height property of the section to 0 or the Visible property to False.

Rulers

Rulers are located at the top and left of the design view. They help a user visualize the placement of controls in the report layout and how they appear in print. Please note that you have to add the right and left margin widths to determine whether your report fits on the selected paper size. The left ruler includes a grab handle for each section to resize the section height. See Rulers for more information.

Grab Handles

Grab handles on the vertical ruler indicate the height of individual sections. You can drag them up or down to change section heights, or double-click to automatically resize the section to fit the controls in it.

Designer Tabs

The designer provides three tabs: Designer, Script and Preview. You can create your report layout visually in the Designer tab, add script to report events in the Script tab to implement .NET functionality, and see the result in the Preview tab. See Designer Tabs for more information.

Designer Buttons

Designer buttons are located below the design surface next to the designer tabs. Dimension Lines, Hide Grid, Dots, Lines, Snap to Lines, and Snap to Grid buttons help you to align report controls and data regions. The Select Mode and Pan Mode buttons determine whether you select controls on the design surface, or move the visible area of a zoomed-in report. See Designer Buttons for more information.

Connect to Server Icon

The Connect to Server icon is located below the design surface next to the designer buttons. A green server icon indicates that you are connected and a red server icon indicates that you are disconnected from ActiveReports Server. See Connecting to ActiveReports Server for more information.

Zoom Bar

The zoom bar provides a slider that you drag to zoom in and out of the design surface, or you can use the Zoom in and Zoom out buttons at either end of the slider. See Zoom Support for more information.

Report designer in page reports/RDL reports

In a page report or a RDL report, the designer offers the following features that you can use to create, design and edit a report.

Design Surface

The design surface of a report appears initially as a blank page and grid lines. You can create your own layout and drag report controls and fields onto the design surface to display your data.

Rulers

Use the ruler to determine how your report will look on paper. Please note that you have to add the right and left margin widths to determine whether your report will fit on the selected paper size. See Rulers for more information.

Designer Tabs

The designer provides three tabs: Designer, Script and Preview. You can create your report layout visually in the Designer tab, add script to report events in the Script tab to implement .NET functionality, and see the result in the Preview tab. See Designer Tabs for more information.

Page Tabs(Page Report)

By default, the designer provides two page tabs, Page 1 and New, below the design surface. Each page tab represents a layout page of the report. Page 1 represents the first page of your report, and you can click New to add another page to your report. See Page Tabs for more information.

Designer Buttons

Designer buttons are located below the design surface next to the designer tabs. Dimension Lines, Hide Grid, Dots, Lines, Snap to Lines, and Snap to Grid buttons help you to align report controls and data regions. The Select Mode and Pan Mode buttons determine whether you select controls on the design surface, or move the visible area of a zoomed-in report. See Designer Buttons for more information.

Connect to Server Icon

The Connect to Server icon is located below the design surface next to the designer buttons. A green server icon indicates that you are connected and a red server icon indicates that you are disconnected from ActiveReports Server. See Connecting to ActiveReports Server for more information.

Zoom Bar

The Zoom Bar provides a slider that you drag to zoom in and out of the design surface, or you can use the Zoom in and Zoom out buttons at either end of the slider. See Zoom Support for more information.

Tip: ActiveReports provides some useful keyboard shortcuts for the controls placed on the design surface.

  • Arrow Keys: To move control by one grid line.
  • [Ctrl] + Arrow Keys: To move control by 1/100 inch (around 0.025 cms)
  • [Shift] + Arrow Keys: To increase or decrease the size of the control by one grid line.
See Also
ActiveReports Designer
Report Explorer
Properties Window
Toolbox


Report Menu

Report Menu
ActiveReports 10 > ActiveReports User Guide > Concepts > ActiveReports Designer > Report Menu
Show All Show All
Hide All Hide All

The Report menu provides access to common reporting operations. To show the Report Menu in the Visual Studio menu bar, select the Design View of the report in the ActiveReports Designer. This menu does not appear in the menu bar when the report is not selected.

The following drop-down sections describe the Report menu items. Menu items differ based on the type of report layout in use.

Report Menu for Section Reports

Menu Item | Description
Save Layout | Opens the Save As dialog to save the newly created report in RPX file format.
Save Layout To Server | Opens the Save report to server dialog to save reports to ActiveReports Server. See Server Reports for more information.
Load Layout | Opens the Open dialog where you can navigate to any RPX file and open it in the designer. Note that any changes to the current report are lost, as the layout file replaces the current report in the designer.
Load Layout From Server | Opens the Open report from server dialog to open reports from ActiveReports Server. See Server Reports for more information.
Connect to Server | Opens the Connect To Server dialog that allows you to connect ActiveReports to ActiveReports Server to access shared resources. See Connecting to ActiveReports Server for more information.
Disconnect from Server | Disconnects from ActiveReports Server. This option is only enabled when connected to ActiveReports Server.
Data Source | Opens the Report Data Source dialog to bind a data source to the report.
Settings | Opens the Report Settings dialog. See Report Settings Dialog for more information.
Data
  • Shared Data Sources
  • Shared Data Sets
 Select the Shared Data Sources option to open the Server Shared Data Sources dialog to create or edit shared data sources. See Server Shared Data Sources for more information.

Select the Shared Data Sets option to open the Server Shared Data Sets dialog to create or edit shared data sets. See Server Shared Data Sets for more information.
View
  • Designer
  • Script
  • Preview
 Opens the Designer, Script or Preview tab. See Designer Tabs for more details.

Report Menu for Page and RDL Reports

Menu Item | Description
Save Layout | Opens the Save As dialog to save the newly created report in RDLX file format.
Save Layout To Server | Opens the Save report to server dialog to save reports to ActiveReports Server. See Server Reports for more information.
Load Layout | Opens the Open dialog where you can navigate to any RDL, RDLX, RDLX-master file and open it in the designer. Note that any changes to the current report are lost, as the layout file replaces the current report in the designer.
Load Layout From Server | Opens the Open report from server dialog to open reports from ActiveReports Server. See Server Reports for more information.
Connect to Server | Opens the Connect To Server dialog that allows you to connect ActiveReports to ActiveReports Server to access shared resources. See Connecting to ActiveReports Server for more information.
Disconnect from Server | Disconnects from ActiveReports Server. This option is only enabled when connected to ActiveReports Server.
Convert to Master Report (RDL Reports only)

Converts a RDL report to a Master Report.

It disappears from the Report menu when a master report is applied to the report through Set Master Report. See Master Reports (RDL) for more details.
Report Parameters | Opens the Report dialog to the Parameters page where you can manage, add and delete parameters.
Embedded Images | Opens the Report dialog to the Images page, where you can select images to embed in a report. Once you add images to the collection, they appear in the Report Explorer under the Embedded Images node.
Report Properties | Opens the Report dialog to the General page where you can set report properties such as the author, description, page header and footer properties, and grid spacing.
Stylesheet Editor | Opens the Stylesheet Editor dialog, where you can create, edit or remove styles. You can also embed these styles in a style sheet or save them externally in *.rdlx-styles format. Embedded style sheets appear under the Embedded Stylesheets node in the Report Explorer.
Set Master Report (RDL Reports only)
  • Open From Server
  • Open Local File

Select Open From Server option to open the Open report from server dialog, and then select a master report (RDLX-master file format).

Select Open Local File option to open the Open dialog, and then select a master report.
Generate Excel Template (RDL Reports only) | Creates an Excel template of the report that you or the end user can customize for use with Excel exports to control the way the exported reports appear.
Data
  • Shared Data Sources
  • Shared Data Sets
 Select Shared Data Sources option to open Server Shared Data Sources dialog to create or edit shared data sources. See Server Shared Data Sources for more information.

Select Shared Data Sets option to open Server Shared Data Sets dialog to create or edit shared data sets. See Server Shared Data Sets for more information.
View
  • Designer
  • Script
  • Preview
 Opens the Designer, Script or Preview tab. See Designer Tabs for more details.
Page Header (RDL Reports only) | Toggles the report Page Header on or off.
Page Footer (RDL Reports only) | Toggles the report Page Footer on or off.
See Also
Report Explorer
ActiveReports Designer


Designer Tabs

Designer Tabs
ActiveReports 10 > ActiveReports User Guide > Concepts > ActiveReports Designer > Designer Tabs
Show All Show All
Hide All Hide All

The Designer has three tabs located at the bottom of the report design surface. Create a report layout in the Designer tab, write a script in the Script tab to implement .NET functionality and see the result in the Preview tab.

Designer Tab

The Designer tab appears by default on your designer. This tab is used to design your report layout visually. You can implement most of the design-time features here, drag controls from the toolbox to create a layout, bind data regions to data, and set properties for the report and controls through the context menu.

Tip: Layout-related features like designer buttons and zoom slider can be used in this tab to help you manage your report display efficiently.

Script Tab

The Script tab opens the script editor, where you can provide VB.NET or C# functionality to the reports without compiling the .vb or .cs files. You may use either Visual Basic or C# script in this tab with section reports, or Visual Basic with page reports and RDL reports.

The generated reports serve as stand-alone reports which you can load, run, and display in the viewer control without the designer. This feature is useful when distributing reports without recompiling.

In page reports/RDL reports, you can embed code blocks that you can reference in the expressions you use on report controls. See Using Script for more information about using script.

In section reports, you can add code to object events. The two drop-down boxes in the script editor allow you to select any section of the ActiveReport and any events associated with that section, or the report itself and related events. When you select an event, the script editor generates a method stub for the event. See Add Code to Layouts Using Script for more information about scripting in section reports.

Preview Tab

The Preview tab allows you to view your report without the need to actually run your project. This makes it easy to quickly see the run-time impact of changes you make in the designer or the code.

This tab does not display data in the following conditions:

  • Code or script in the report class is incorrect.
  • Report class constructor has been changed.
  • Report data source has not been set correctly.
  • Settings have been implemented outside the report class
  • .mdb file is being copied in the project

When the report is inherited from a class other than ActiveReports, preview is possible only when the base class is in the same project. If the base class is not in the same project and is referencing an external class library, you will not get a preview in the Preview tab.

When adding a report directly to ASP.NET Web site in Visual Studio 2010／2012, the Preview tab is not visible and thus you cannot preview.


Designer Buttons

Designer Buttons
ActiveReports 10 > ActiveReports User Guide > Concepts > ActiveReports Designer > Designer Buttons
Show All Show All
Hide All Hide All

Designer buttons are located to the right of the designer tabs along the bottom of the designer, and are enabled when you are on the Designer tab. They allow you to control settings for the design surface.

Grid Settings

Dimension Lines

Dimension lines appear during a drag operation, and run from the borders of the report control or data region being moved or resized to the edges of the report designer surface. Dimension lines let you track the location of the control as you move it by displaying the distance between the control and the edge of the writable area of the report.

Button Type | Behavior
Note: With section reports, you can change the number of grid columns and rows in the Report Settings dialog on the Global Settings tab. With page reports and RDL reports, you can change the grid spacing in the Report Properties dialog on the General tab.

Hide Grid

By default, grid lines and dots appear on the report design surface. You can click this button to hide the grid and design your report on a blank page. Lines or dots are also removed from the design surface when you hide the grid, but Snap to Lines or Snap to Grid settings remain unaffected.

Button Type | Behavior

Show Dots

You can click this button to have dots appear on the design surface in between the grid lines to guide you in the placement of controls.

Button Type | Behavior

Show Lines

You can click this button to have faint grey lines appear on the design surface in between the grid lines to guide you in the placement of controls.

Button Type | Behavior
Note: Only one option out of Hide Grid, Show Dots and Show Lines can be selected at one time.

Control Drag and Drop Settings

These settings allow you to specify how you want controls to behave when you drag and drop them on the design surface.

Tip: If you plan to export a report to Excel format, use Snap Lines or Snap to Grid to ensure that your controls are aligned in columns and rows as it prevents overlapping. This makes the export to excel closer to how a report looks at run or design time.

Snap Lines

This setting aligns the control you are dragging with other controls on the report design surface. When you drag the control around, snap lines appear when it is aligned with other controls or with the edges of the report, and when you drop it, it snaps into place in perfect alignment. See Snap Lines for more information.

Button Type | Behavior

Snap to Grid

This setting aligns the control you are dragging with grid lines on the report design surface. When you drop the control, it snaps into place in alignment with the nearest grid mark. To place your controls freely on the report design surface, turn this setting off.

Button Type | Behavior

Mouse Modes

These settings allow you to specify how you want the mouse to behave in the designer.

Select Mode

In Select mode, when you click items on the report designer surface, you select them. Use this mode for editing, data binding and styling in the Designer tab. An arrow cursor appears in the Select mode.

Button Type | Behavior

Pan Mode

Use the Pan mode to make navigation easier. In this mode, you cannot select, edit, or delete a control from the design surface. A hand cursor appears in Pan mode and you can navigate through your report by pressing the left mouse button and dragging the report to the desired position.

Tip: To enable Pan mode while you are in Select Mode, hold down the middle mouse button and move to the desired location with the hand cursor.
Button Type | Behavior
See Also
Designer Tabs


Page Tabs

Page Tabs
ActiveReports 10 > ActiveReports User Guide > Concepts > ActiveReports Designer > Page Tabs
Show All Show All
Hide All Hide All

Page tabs appear in an Excel-like bar below the report design surface. This feature is only available in page reports, where report layouts are designed on separate pages and you can control the way each page appears. Using page tabs, you can select which page to view or edit, add new pages, remove existing pages, reorder pages, and create duplicate pages.

By default, a new report has a Page 1 tab and a New tab.

  • Page 1: This is the layout for the first page of the report. If no other page layouts exist, the layout on this page is applied to the entire report.
  • New: Click to add a new page where you can create a layout for pages displayed after the first page.

Right-click any page tab (except the New tab) to get a context menu that allows you to Insert a new page, Duplicate the page, or Delete the page.

Adding a new page

To add a new page, click the New tab.

A new page tab with an incremented page number appears to the right of any existing page tabs. This page has the same page size and margins as the previous page. The New tab moves to the right of the newly added page.

Inserting a page

To insert a page, right-click the page tab and select Insert. A page is inserted to the left of the selected page. It has the same page size and margins as the selected page.

Deleting a page

To delete a page, right-click the page tab that you want to remove and select Delete. This option is disabled if there is only one page in the report.

Creating a copy of a page

To create a copy of a page, right-click on the page tab that you want to copy and select Duplicate. A copy of the selected page appears to the right of the selected page.

Note: When the duplicate page contains a data region, ActiveReports replaces the data region with an OverflowPlaceHolder on the new page. Reset the OverflowName property for the duplicated page to maintain the overflow data chain between page tabs.

Reordering pages

To change the order of page tabs, drag a tab and drop it at the desired location. The tab is inserted in the chosen location and the page number is updated according to its position. The page numbers of other tabs also change automatically.

You can cancel the move operation by pressing the [Esc] key while dragging the tab.

See Also
OverflowPlaceHolder


Toolbar

Toolbar
ActiveReports 10 > ActiveReports User Guide > Concepts > ActiveReports Designer > Toolbar
Show All Show All
Hide All Hide All

ActiveReports provides a toolbar integrated with the Visual Studio IDE for quick access to report designing commands. This toolbar is composed of buttons and dropdown lists which offer functions for a number of commonly used commands.

To Show or Hide the Toolbar in Visual Studio

  1. Create a new project or open an existing project in Visual Studio.
  2. Right click on the Visual Studio toolbar and from the context menu that appears, select ActiveReports.

The ActiveReports toolbar appears under the Visual Studio menu bar. The toolbar options may differ based on whether you have a section report, page report or a RDL report open.

See the description of each toolbar option in the tables below.

Note: Toolbar descriptions are grouped in a logical order for understanding. The buttons and dropdowns may appear in a different order in the ActiveReports toolbar.

Text Decoration

Command Description

Style

Sets the style for the selected report control.

For details on settting styles in Page and RDL reports, see Working with Styles.

For details on setting styles in Section report, see Use External Style Sheets.

Font

Sets the typeface of all the text in a control.

In a section report, for the RichTextBox control, typeface of only the selected text changes. In a page report or a RDL report, in a data region like Tablix or Table, you can change the typeface of the entire data region or only the selected TextBox within the region.

Font Size

Sets the font size of all the text in a control.

In a section report, for the RichTextBox control, font size of only the selected text changes. In a page report or a RDL report, for a data region like Tablix or Table, you can change the font size of the entire data region or only the selected TextBox within the region.

Fore Color

 Opens a Choose Color dialog to set the text color of controls.

Back Color

 Opens a Choose Color dialog to set the background color of controls.

Bold

Sets or removes text emphasis from the entire text of the control.

In section report, for the RichTextBox control, bold applies to the selected text only. In a page report or a RDL report, for a data region like Tablix or Table, you can change the emphasis of the entire text or only the text of the selected TextBox within the region.

Italic

Sets or removes text slant for the entire text of the control.

In a section report, for the RichTextBox control, italic applies to the selected text only. In a page report or a RDL report, for a data region like Tablix or Table, you can italicize the entire text or only the text of the selected TextBox within the region.

Underline

Sets or removes the text underline for the entire text of the control.

In a section report, for the RichTextBox control, underline applies to the selected text only. In a page report or a RDL report, for a data region like Tablix or Table, you can also underline the entire text or only the text of the selected TextBox within the region.

Text Alignment

Command | Description
Align Left | Aligns the text to the left in the control area.
Center | Aligns the text to the center in the control area.
Align Right | Aligns the text to the right in the control area.
Align Justify | Justifies the text in the control area.

Layout Editing

Command | Description
Zoom Out | Reduces the magnification level of the design surface and any elements within it.
Zoom In | Increases the magnification level of the design surface and any elements within it.
Zoom | Opens a dropdown list to set the magnification level of the design surface between 50% and 400%. Zoom percentage is set to 100% by default.

Control Alignment

Command | Description
Align to Grid | Snaps the top left of the selected control to the closest gridline.
Align Lefts | Aligns the selected controls with their left border coinciding with the left border of the primary control. The vertical space separating the controls remains the same.
Align Rights | Aligns the selected controls with their right border coinciding with the right border of the primary control. The vertical space separating the controls remains the same.
Align Tops | Aligns the selected controls with their top border coinciding with the top border of the primary control. The horizontal space separating the controls remains the same.
Align Middles | Aligns the selected controls vertically to the middle with respect to the primary control. The horizontal space separating the controls remains the same.
Align Bottoms | Aligns the selected controls with their bottom border coinciding with bottom border of the primary control. The horizontal space separating the controls remains the same.

Control Resizing

Command | Description
Make Same Width | Resizes the width of the selected controls to the width of the primary control.
Make Same Height | Resizes the height of the selected controls to the height of the primary control.
Make Same Size | Resizes the size (width and height) of the selected controls to the size of the primary control.
Size to Grid | Snaps the selected control to the closest gridline by resizing the control on all four sides.

Control Spacing

Command | Description
Make Horizontal Spacing Equal | Creates equal space between the selected controls with respect to the primary control, using the outermost edges of the controls as end points.
Increase Horizontal Spacing | Increases the horizontal spacing by one grid unit with respect to the primary control.
Decrease Horizontal Spacing | Decreases the horizontal spacing by one grid unit with respect to the primary control.
Remove Horizontal Spacing | Removes the horizontal space so that the selected controls move to the nearest edge of the top-left control.
Make Vertical Spacing Equal | Creates equal space between the selected controls with respect to the primary control, using the top and bottom edges of the control as the end points.
Increase Vertical Spacing | Increases the vertical spacing by one grid unit with respect to the primary control.
Decrease Vertical Spacing | Decreases the vertical spacing by one grid unit with respect to the primary control.
Remove Vertical Spacing | Removes the vertical spacing so that the selected controls move to the nearest edge of the top-left control.

Z-order Alignment

Command | Description
Bring to Front | Moves the selected controls to the front of all other controls on the report.
Send to Back | Moves the selected controls behind all other controls on the report.

RichTextBox commands

Command | Description
Bullets | Adds or removes bullets from the selected text inside a RichTextBox control in a section report.
Indent | Increases the indent of selected text in the RichTextBox control area in a section report.
Outdent | Decreases the indent of selected text in the RichTextBox control area in a section report.

Others

Command | Description
View ReportExplorer | Shows or hides the Report Explorer window. See Report Explorer for further details.
Reorder Groups | Opens the Group Order dialog, where you can drag and drop groups to rearrange them. This button is enabled when you have multiple groups in a section report.
Layer List | Opens the Layer List window to displays a list of Layers in the report along with their visiblity and lock options. Layer List Explorer also allows you to add or remove Layers from your reports. See Working with Layers for further details.
Note: Primary control is the control in a selected group of controls, to which you align all other controls. It is generally the first control selected in the group and has sizing handles (white boxes) which are different from the rest of the selected controls.
See Also
ActiveReports Designer


Report Explorer

Report Explorer
ActiveReports 10 > ActiveReports User Guide > Concepts > ActiveReports Designer > Report Explorer
Show All Show All
Hide All Hide All

The Report Explorer gives you a visual overview of the report elements in the form of a tree view where each node represents a report element.

Using the Report Explorer with any type of report, you can remove controls, add, edit or remove parameters, add a data source, and drag fields onto the report. You can also select the report or any element in the report to display in the Properties Window, where you can modify its properties.

ActiveReports supports three types of reports:

  • Section reports (in your choice of XML-based RPX or code-based CS or VB files)
  • Page reports (in XML-based RDLX files)
  • RDL reports

Section reports, RDL reports and page reports are composed of different types of report elements, so the Report Explorer shows different elements in the report tree depending on the type of report you have open. For more information on how to use the Report Explorer with each, see Exploring Page and RDL Reports and Exploring Section Reports .

To show or hide the Report Explorer in Visual Studio

Once you add the Report Explorer in Visual Studio, it appears every time you create a new Windows application. Use the steps below to hide it when you do not need it.

  1. Right-click on the Visual Studio toolbar and select ActiveReports to display the report designer toolbar. See Toolbar for further details.
  2. On the Designer toolbar, click the View ReportExplorer button. The Report Explorer window appears.
  3. To hide the Report Explorer, follow the steps above and toggle View ReportExplorer back off.

Tip: Another way to show the Report Explorer window in Visual Studio, is from the View menu, select Other Windows, then Report Explorer 10.

To change a report using the Report Explorer

More actions specific to each report type can be found in Exploring Page and RDL Reports and Exploring Section Reports .

To change control properties

  1. In the Report Explorer, select the control for which properties are to be changed. In the Properties Window, all of the properties for the item appear.
  2. Change property values by entering text or selecting values from drop-down lists. With some properties, for example, OutputFormat or Filters, when you click the property, an ellipsis button appears to the right. Click the ellipsis button to open a dialog where you can make changes.

To delete a control

  1. In the Report Explorer, expand the node that contains the control that you want to remove.
  2. Right-click the control and select Delete.
  3. In the dialog that appears, click Yes to confirm the deletion.
See Also
Exploring Section Reports
Exploring Page and RDL Reports


Exploring Page and RDL Reports

Exploring Page and RDL Reports
ActiveReports 10 > ActiveReports User Guide > Concepts > ActiveReports Designer > Report Explorer > Exploring Page and RDL Reports
Show All Show All
Hide All Hide All

When you have a Page or RDL report open in the ActiveReports Designer, you can see nodes like the following in the Report Explorer.

  • Document Outline
    • Each report page (or the body for RDL reports)
      • Each control, for example:
        • BandedList
        • Tablix
        • Table
  • Data Sources
    • DataSource (right-click to add a data source; you can have more than one)
      • DataSet (right-click the DataSource to add a data set)
        • Fields (drag onto the report or onto a data region)
      • Another DataSet (you can have more than one)
  • Server Data Sets (right-click to open a dialog and add a server shared data set)
  • Parameters (right-click to open a dialog and add a parameter)
  • Embedded Images (right-click to browse for an image to add)
  • Embedded StyleSheets (right-click to open and add a style sheet)
  • Common Values (drag onto the report to display the value in a textbox)

In the Report Explorer, you can

  • remove controls
  • add, edit or remove parameters
  • add a data source
  • drag fields onto the report
  • share a data source
  • add data sets
  • add, edit, or remove embedded images
  • drag common values like page numbers, current date, or report name onto the report as a textbox
  • select the report or any element in the report to display in the Properties window, where you can modify its properties

To add a DataSource

  1. In the Report Explorer, right-click the Data Sources node and select Add Data Source. The Report Data Source dialog appears, open to the General page.
  2. On the General page, drop down the Type list and select Microsoft OleDb Provider.
  3. Under Connection, on the Connection Properties tab, drop down the OLE DB Provider list and select Microsoft.Jet.OLEDB.4.0.
  4. In the Server or file name box, enter the path and file name to your Access database, for example,
    C:\Users\YourUserName\Documents\GrapeCity Samples\ActiveReports 10\Data\NWIND.MDB.
  5. Click the Accept button. The new data source is added to the Data Sources node. To use fields from the data source, add a data set.

To share a DataSource

  1. In the Report Explorer, expand the DataSources node, right-click the node for the data source that you want to share, and select Share Data Source. The Save Shared Data Source File dialog appears.
  2. Navigate to the folder where you want to save the file, enter a name for the file, and click Save.
  3. The type of data source as well as the connection string are saved to a file of type RDSX that you can use in other reports.

To add a DataSet

  1. In the Report Explorer, expand the DataSources node, right-click the node for the data source that you want to use, and select Add DataSet. The DataSet dialog appears.
  2. In the list to the left, select Query to show the Query page.
  3. In the Query box to the right, enter a SQL query to pull the data you want for your report.
    Example Query
    Copy Code
    SELECT * FROM Customers
  4. Click the Accept button to create the data set. The data fields appear in the data set node.

To bind a DataSet field to a TextBox control

  1. In the Report Explorer, expand the DataSources node, then the node for the data source, then the DataSet that you want to use.
  2. From the DataSet node, click the DataSet field that you want to bind to a TextBox control, drag it onto the report surface or onto a data region and drop it.
  3. A TextBox control is created and bound to the field with the proper expression in the Value property. For example, if you drag the City field onto the report, the Value property of the TextBox contains the expression =Fields!City.Value.

To add a Server Data Set

In ActiveReports, you can create and access data sets that are hosted on ActiveReports Server. Server shared data sets retrieve data from server shared data sources to provide data to multiple reports. ActiveReports allows you to use only one type of data set for your report, either local or shared.

A server shared data set that you add to your report is an instance of data set hosted on ActiveReports Server. If you make any changes to the data sets that are added to your report, the changes are not reflected on the server.

You can override the following server shared data set settings in ActiveReports.

  • Create additional calculated fields
  • Create additional filters
  • Override data set options
  • Override parameter options and values

Use the following steps to add a Server Data Set to your report.

  1. Connect your Stand-Alone Designer to ActiveReports Server if you are not already connected to the server. See Connecting to ActiveReports Server for further information.
  2. In the Report Explorer, right-click the Server Data Sets node, and then select Add Data Set or select Shared Data Set from the Add button. The Add Server Data Set dialog appears.
  3. In the Add Server Data Set dialog that appears, select a data set from the list.
  4. Click OK to add the data set. The Server Data Sets node is populated with fields returned by the query.
    Once you add a server shared data set to your report, ActiveReports automatically marks the report as a remote report. Remote reports are executed on ActiveReports Server.
    Note: Users should at least have Read permission to access the Server Shared Data Set. For more information, see Managing Data Sets.

To add parameters

  1. In the Report Explorer, right-click the Parameters node and select Add Parameter. The Report Parameters dialog appears.
  2. On the General tab of the dialog, enter text for prompting users for a value.
  3. On the Available Values tab, you can select values from a DataSet to populate a list from which users can select a value.
  4. On the Default Values tab, you can provide default values to use if the user does not select a value.
  5. Click Accept to save the parameter. The new parameter appears in the Report Explorer under the Parameters node.
  6. From the Report Explorer, drag the parameter to report design area to create a TextBox that is bound to the parameter. When you run the report, the value that the user supplies in the prompt dialog displays in the bound TextBox on the report.
See Also
Server Reports
Exploring Section Reports


Exploring Section Reports

Exploring Section Reports
ActiveReports 10 > ActiveReports User Guide > Concepts > ActiveReports Designer > Report Explorer > Exploring Section Reports
Show All Show All
Hide All Hide All

By default, when you have a section report open in the ActiveReports Designer, you can see nodes like the following.

  • The Report
    • Each report section, for example:
    • Detail (default, cannot be removed)
    • Report Header and Footer (default, can be removed)
    • Page Header and Footer (can be added)
    • Group Header and Footer (can be added)
      • Each control, for example:
      • TextBox
      • Picture
      • PageBreak
      • SubReport
  • Fields
    • Bound (lists fields from the bound data source)
    • Calculated (right-click to add calculated fields)
  • Parameters (right-click to add parameters)
  • Report Settings (opens a dialog for page setup, printer settings, styles and global settings)

In the Report Explorer, in addition to removing controls, adding, editing or removing parameters, adding a data source, and dragging fields onto the report, you can also add, edit, or remove calculated fields; drag bound data fields onto the report as textbox controls; change report settings like margins, printer settings, styles, and ruler and grid settings. You can also select the report or any element in the report to display in the Properties window, where you can modify its properties.

To add a DataSource

  1. Click the gray report DataSource icon on the Detail section band to open the Report Data Source dialog.
  2. On the OLE DB tab, next to Connection String, click the Build button.
  3. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button. Click the ellipsis (...) button to browse to your database or the sample Northwind database, nwind.mdb.
  4. Once you have selected your *.mdb file, click Open.
  5. Click OK to close the window and fill in the Connection String field.
  6. In the Query field, enter a SQL query to select the data that you want, for example
    Example Query
    Copy Code
    SELECT * FROM Customers
  7. Click OK to save the data source and return to the report design surface. In the Report Explorer, under the Fields node, the Bound node is populated with fields returned by the query.

To add a calculated field

  1. In the Report Explorer, expand the Fields node.
  2. Right-click the Calculated node and select Add. The new calculated field is displayed in the Report Explorer and in the Properties window.
  3. In the Properties window, set the Formula property to a calculation, for example: = UnitPrice * 1.07
  4. Drag the field from the Report Explorer onto the design surface of your report to create a textbox that is bound to the field.

To bind a Field to a TextBox control

  1. In the Report Explorer, expand the Fields node, then the Bound or Calculated node that you want to use.
  2. Click the field that you want to bind to a TextBox control, drag it onto the report surface and drop it into the section where you want the TextBox to appear.
  3. A TextBox control is created and bound to the field with the filed name in the DataField property, and a related value in the Name and Text properties. For example, if you drag the City field onto the report, the DataField property of the TextBox becomes City, the Name and Text properties become txtCity1.

To add parameters

  1. In the Report Explorer, right-click the Parameters node and select Add. The new parameter is displayed in the Report Explorer and in the Properties window.
  2. In the Properties window, set the Prompt property to a string value to ask users for data.
  3. Leave the PromptUser property set to True. When you run the report, a dialog displays the Prompt to the user.
  4. From the Report Explorer, drag the parameter to the report design area to create a TextBox that is bound to the parameter. When you run the report, the value that the user supplies in the prompt dialog displays in the bound TextBox on the report.

To change report settings

  1. In the Report Explorer, double-click the Settings node. The Report Settings dialog appears.
  2. You can set a number of options on the four tabs in the dialog.
  3. When you have finished changing report settings, click OK.


Toolbox

Toolbox
ActiveReports 10 > ActiveReports User Guide > Concepts > ActiveReports Designer > Toolbox

In ActiveReports, the Visual Studio integrated toolbox tabs display all of the controls specific to the type of report that has focus, or the ActiveReports controls that you can use on Web Forms or Windows Forms.

When a Section report has focus, the ActiveReports 10 Section Report toolbox becomes available. For information about the report controls available in this toolbox, please see the Section Report Toolbox topic.

When a Page report has focus, the ActiveReports 10 Page Report toolbox becomes available. For information about the report controls available in this toolbox, please see the Toolbox topic.

When a RDL report has focus, the ActiveReports 10 RDL Report toolbox becomes available. For information about the report controls available in this toolbox, please see the Toolbox topic.

When a Windows Form has focus, the ActiveReports 10 toolbox group offers the following Windows Forms controls:

  • ReportExplorer (requires Professional Edition license)
  • Toolbox (requires Professional Edition license)
  • Designer (requires Professional Edition license)
  • Viewer

When a Web Form has focus, the ActiveReports 10 toolbox group offers one Web control: the WebViewer (requires Professional Edition license). For more information, see Getting Started with the Web Viewer.

See Also
Toolbar
Report Explorer

Getting Started

Adding ActiveReports Controls


Properties Window

Properties Window
ActiveReports 10 > ActiveReports User Guide > Concepts > ActiveReports Designer > Properties Window

The Visual Studio Properties window is an important tool when you design a report. Select any page, section, data region, control or the report itself to gain access to its properties in the Properties window. By default, this window is placed to the right of the report design area, or wherever you may have placed it in Visual Studio. You can show the list of properties by category or in alphabetical order by clicking the buttons at the top of the Properties window.

Select a property to reveal a description at the bottom of the window. Just above the description is a commands section that contains commands, links to dialogs that give you access to further properties for the item. You can resize the commands or description sections by dragging the top or bottom edges up or down.

Tip: If the commands or description section is missing in Visual Studio, you can toggle it back on by right-clicking anywhere in the Properties window and clicking Commands or Description.

In the image below, you can see a chart control selected on the designer surface, revealing its properties in the Properties window, along with any associated commands, and a description of the selected property.
See Also
ActiveReports Designer

Getting Started

Adding an ActiveReport to a Project


Rulers

Rulers
ActiveReports 10 > ActiveReports User Guide > Concepts > ActiveReports Designer > Rulers

In ActiveReports, rulers appear to the top and left of the Design View to guide you in vertically and horizontally aligning items in the report. They have large tick marks to indicate half inch points and smaller tick marks to indicate eighths of an inch.

Note: The numbers indicate the distance in inches from the left margin, not from the edge of the page.

Section Reports

In Section Reports, the white area on the ruler indicates the designable area of the report. The grey area at the bottom of the vertical ruler and at the right of the horizontal ruler indicate the report margins. Grab handles on the vertical ruler indicate the height of individual sections. You can drag them up or down to change section heights, or double-click to automatically resize the section to fit the controls in it.

In a section layout, you can change ruler measurements from inches to centimeters and centimeters to inches. Use the following instructions to modify ruler measurements at design- time.

To change ruler measurements at design-time in Section Report

At design time, you can change the ruler measurements from the Report Settings Dialog.

  1. In the Report Explorer, double-click the Settings node.
  2. In the Report Settings dialog that appears, click Global Settings.
  3. From the Ruler Units dropdown select Centimeters or Inches.

In section reports, you can change the units of measure for the rulers. See Change Ruler Measurements for further details.

Page/RDL Reports

In Page Reports or RDL Reports, margin markers indicate the designable area of the report. The area inside the margin markers is designable, and the areas outside the markers are the margins. To change the margins, you can drag the margin markers to the desired locations.

In a page layout, you can change ruler measurements from inches to centimeteres and centimeteres to inches. Use the following instructions to modify ruler measurements in page reports.

To change ruler measurements at design-time in Page Report

At design time, you can change the ruler measurements from the Report Dialog .

  1. In the Report Explorer, select the Report node.
  2. In the command section of the Properties Window, click Property dialog.
  3. In the dialog that appears, go to the General tab.
  4. From the Ruler Units dropdown select Centimeters or Inches.
See Also
Design View


Scroll Bars

Scroll Bars
ActiveReports 10 > ActiveReports User Guide > Concepts > ActiveReports Designer > Scroll Bars

Scroll Bars appear automatically when controls or data regions do not fit the visible area of the report design surface. A scroll bar consists of a shaded column with a scroll arrow at each end and a scroll box (also called a thumb) between the arrows. You can scroll up, down, right or left using the scroll arrow buttons, scroll box or mouse wheel.

Auto Scrolling

When a user drags a control beyond the edge of the design surface and the mouse pointer reaches near the surface edge, scrolling starts automatically in the direction of the mouse movement. Auto scrolling works in all four directions. This feature is useful while designing reports with a magnified design view.

Note: In Section Layout and Report Definition Language (RDL), when the mouse button is released during auto scrolling at a location outside the design surface, the surface extends to accommodate the control.

Scrolling stops in the following scenarios:

  • The user stops dragging the mouse (Mouse Up).
  • The user moves the mouse in the opposite direction.
  • The [Esc] key is pressed while dragging the mouse.
Tip: To enable auto scrolling for multiple controls, hold down the [Ctrl] or [Shift] key to select the controls. Drag them together to the edge of the design surface and enable auto scrolling.
See Also
Zoom Support
Design View


Snap Lines

Snap Lines
ActiveReports 10 > ActiveReports User Guide > Concepts > ActiveReports Designer > Snap Lines
Show All Show All
Hide All Hide All

Snap lines assist in accurate positioning of elements on a report design surface while you drag report controls on it. These dynamic horizontal and vertical layout guidelines are similar to the ones found in Visual Studio. You can see snap lines on the ActiveReports Designer as well as the Stand-alone designer application.

Snap lines appear on the design surface by default. In order to disable them, click the Snap Lines button below the design surface, or in section reports, hold down the [Alt] key while dragging a control to temporarily hide the snap lines.

When you drag a control on the design surface, blue snap lines appear and the control slows down as it aligns with another control or a section edge. Unless you are also using the Snap to Grid setting, with Snap Lines, the control can move freely around the report and can be placed anywhere on the design surface.

Tip: If you plan to export a report to Excel format, use snap lines to ensure that your controls are aligned in columns and rows to avoid empty cells or overlapping of controls in the spreadsheet.

Snap Line Behavior

On dragging with a mouse

When you drag report controls across the design surface, they snap to other controls, report and section edges. Snap lines appear when the control you are dragging aligns with any edge of any of the following:

  • Any control inside any section of the report.
  • Another control inside the same data region.
  • Parts of a data region (bands in a BandedList, or columns and rows in a Table).
  • Report edges and section edges.
  • Other control edges while resizing with a mouse.
  • On selecting multiple items where all the items move as a single unit, snap lines appear for all items in the selection.

With keyboard actions

  • Use [Ctrl] + [Shift] + Arrow keys to resize the selected control from one snap line to the next.
  • Use [Ctrl] + Arrow keys to move the selected control to the next snap line.
  • Use [Ctrl] + Left mouse button to copy the control and see snap lines appear between the edges of the copied control being dragged and the original control.
Note: Snap lines do not appear when you move a control with arrow keys.
See Also
Designer Buttons
ActiveReports Designer


Zoom Support

Zoom Support
ActiveReports 10 > ActiveReports User Guide > Concepts > ActiveReports Designer > Zoom Support

ActiveReports allows you to zoom in or out on the report design surface for better control over your report layout. As you zoom in or out, the size of every item on the design surface changes.

In the designer, you can access the zoom feature from the Zoom bar below the report design surface where the slider thumb is set to 100% by default. The slider allows you to zoom in and out of the report designer surface. Using this slider you can magnify the layout from 50% to 400%. You can also use the zoom in (+) and zoom out (-) buttons at either end of the slider to change the zoom level.

Zoom settings are also available on the ActiveReports toolbar where you can change the zoom percentage or use the zoom in/zoom out buttons. See Toolbar for further information.

Keyboard Shortcuts

You can hold down the Ctrl key and use the mouse wheel to zoom in and zoom out of the design surface.

You can also use keyboard shortcuts for the following functions:

  • [Ctrl] + [+] : Zoom in
  • [Ctrl] + [-] : Zoom out
  • [Ctrl] + 0 : Return to 100%
See Also
Design View


Report Types

Report Types
ActiveReports 10 > ActiveReports User Guide > Concepts > Report Types
Show All Show All
Hide All Hide All

ActiveReports provides a number of ways to design a report. You can choose a report type based on your layout requirements. Depending on the type of report you select, you also get various file formats to create your reports.

In this section

Report Definition Language (RDL) Report

Page Report

Code-Based Section Report

XML-Based Section Report

Report Layout Types

You can design reports using different layouts depending on your requirements. This section introduces these layout types and describes the differences between them to allow you to select the one that suits your report.

Page Layout

In a Page Layout, you design reports at the page level without any banded sections. This lets you place controls anywhere on the report.

In a Page report, controls do not change in size based on the data, but you can use an OverflowPlaceHolder to handle any extra data.

RDL Layout

In a RDL report, controls grow vertically to accommodate data.Controls can grow and shrink, you can set up interactive sorting, you can set up drill-down reports in which detail data is initially hidden, and can be toggled by other items, and you can add drill-through links to other reports and to bookmark links within reports.

Section Layout

In a Section Layout, you design reports in banded sections. A PageHeader, Detail and PageFooter section appear by default, and you can remove any but the detail section. Right-click the report and select Insert to add other section pairs like ReportHeader and ReportFooter, or GroupHeader and GroupFooter.

A report section contains a group of controls that are processed and printed at the same time as a single unit. All sections except the detail section come in pairs, above and below the detail section. When you use group headers and footers, the detail section processes for each group, and then the next group processes a group header, related details, and group footer. See Grouping Data for more information.

You can hide any section that you do not want shown by setting the Visible property of the section to False.

Report File Format Types

You can create reports in a number of file formats with a varied set of features. This section describes the use of each of these file formats.

Report Template Formats

To create a report, a user must select one of the following templates containing the report layout. See Adding an ActiveReport to a Project for details on how to access report templates.

  • RDLX: This is an XML-based proprietary file format that provides custom extensions to the Report Definition Language (RDL) files used by SQL Server Reporting Services. These are stand-alone files that you can process without compiling them into your application. You can customize the report through the Script Tab by embedding script in the report.
    See this msdn page for more on RDL report.
  • VB or CS: These are code-based reports, and are saved as C# or Visual Basic files that are compiled into your applications. They have corresponding code views similar to Windows forms and provide a design and coding experience in line with Visual Studio. This format is ideal for developers who are comfortable with coding in .NET programming languages and would like to use the extensive event-based API provided by ActiveReports in the code-behind rather than design view. You may also use the scripts in the Script Tab instead of the code behind.
  • RPX: This is an XML-based proprietary file format that the ActiveReports engine can process without compiling it into an application. Instead of Visual Basic or C# code behind, you can customize the report with script embedded in the report XML using the Script Tab. You can also use an RPX file with script as a stand-alone file in a Web project.

Additional File Formats

ActiveReports also provides some additional file formats for reports. Each of these formats is used for a specific purpose as described below.

  • RDLX-master: This is a master report file that you can reference from other RDLX report files for a standard layout, for example, you can add company logo and address sections. This file is loaded each time the report is executed, so you can change the logo on all of your reports by just changing it on the master report. You can also save a master report (RDLX-master file format) to ActiveReports Server. See Master Reports (RDL) for further details.
  • RDLX-theme: This is a theme file that consists of a collection of styles that you can apply to a report. See Themes for further details.
  • RDSX: This is a proprietary format that is created when you share a data source, making it available to multiple reports.
  • RDF: This is the Report Document Format, in which the data is static. You can save a report in this format to display the data that is retrieved. Once a report has been saved to an RDF file, it can be loaded into the viewer control. See Save and Load RDF Report Files for further details.

See the following list of file formats available in each layout.

Format | Page Layout/RDL Layout | Section Layout
RDLX | ✓ | ✘
VB or CS | ✘ | ✓
RPX | ✘ | ✓
RDLX-Master | ✓ | ✘
RDLX-Theme | ✓ | ✘
RDSX | ✓ | ✘
RDF | ✘ | ✓

Features comparison between report types

In ActiveReports, the features available in a report depend on the type of report you select. See the following comparison list of features with each report type:

Feature | Section report | Page report | RDL report
Viewers & Editors |  |  |
Visual Studio Integrated Designer | ✓ | ✓ | ✓
Expressions Editor | ✘ | ✓ | ✓
Designer Script Editor | ✓ | ✓ | ✓
Windows Form Viewer | ✓ | ✓ | ✓
WebViewer (Pro Edition). Includes viewer types HTML, RawHTML, PDF and Flash. | ✓ | ✓ | ✓
HTTP Handlers (Pro Edition) | ✓ | ✓ | ✓
Silverlight Viewer (Pro Edition) | ✓ | ✓ | ✓
Report Controls |  |  |
BandedList | ✘ | ✓ | ✓
List | ✘ | ✓ | ✓
Tablix | ✘ | ✓ | ✓
Table | ✘ | ✓ | ✓
OverflowPlaceHolder | ✘ | ✓ | ✘
Chart | ✓ | ✓ | ✓
Barcode | ✓ | ✓ | ✓
Bullet | ✘ | ✓ | ✓
Calendar | ✘ | ✓ | ✓
CheckBox | ✓ | ✓ | ✓
Container | ✘ | ✓ | ✓
CrossSectionLine | ✓ | ✘ | ✘
CrossSectionBox | ✓ | ✘ | ✘
FormattedText | ✘ | ✓ | ✓
Image | ✘ | ✓ | ✓
Label | ✓ | ✘ | ✘
Line | ✓ | ✓ | ✓
OleObject | ✓ | ✘ | ✘
Pagebreak | ✓ | ✘ | ✘
Picture | ✓ | ✘ | ✘
ReportInfo | ✓ | ✘ | ✘
RichTextBox | ✓ | ✘ | ✘
Shape | ✓ | ✓ | ✓
Sparkline | ✘ | ✓ | ✓
Subreport | ✓ | ✘ | ✓
TextBox | ✓ | ✓ | ✓
Interactivity |  |  |
Hyperlinks | ✓ | ✓ | ✓
Parameters | ✓ | ✓ | ✓
Drill through | ✘ | ✓ | ✓
Drill down | ✓ | ✘ | ✓
Filtering | ✘ | ✓ | ✓
Grouping | ✓ | ✓ | ✓
Sorting | ✘ | ✓ | ✓
Data Connections |  |  |
Standard Data Sources supported (e.g. SQL, OleDB, XML) | ✓ | ✓ | ✓
Unbound Data Source | ✓ | ✓ | ✓
Shared Data Source | ✘ | ✓ | ✓
Export |  |  |
Export Filters | ✓ | ✓ | ✓
Rendering Extensions | ✘ | ✓ | ✓
PDF advanced export features: digital signatures, time stamp, bold font emulation (Pro Edition) | ✓ | ✓ | ✓
Miscellaneous |  |  |
Master Reports | ✓ | ✘ | ✓
Themes | ✘ | ✓ | ✓
Collation | ✘ | ✓ | ✓
Styles (through Report Settings dialog) | ✓ | ✘ | ✘
Printing | ✓ | ✓ | ✓
Stand-alone Applications |  |  |
ActiveReports Viewer | ✓ | ✓ | ✓
ActiveReports Theme Editor | ✘ | ✓ | ✓
ActiveReports Designer (stand-alone application) | ✓ | ✓ | ✓
See Also
Concepts


Report Definition Language (RDL) Report

Report Definition Language (RDL) Report
ActiveReports 10 > ActiveReports User Guide > Concepts > Report Types > Report Definition Language (RDL) Report

The Report Definition Language (RDL) report is the most interactive type of report that we offer. Controls can grow and shrink, you can set up interactive sorting, you can set up drill-down reports in which detail data is initially hidden, and can be toggled by other items, and you can add drill-through links to other reports and to bookmark links within reports.

When you add a RDL report to a project, the OverflowPlaceholder control disappears from the toolbox, and the page tabs disappear from below the report design surface.

Master Reports

One way in which RDL reports differ from Page reports is the ability to create and use master reports. A master report is one that you use to add common report functionality like data, company logos, and page headers or footers, while using the ContentPlaceHolder control to designate areas where content reports can add data. In this way, you can quickly change the data source or company address and logo for an entire suite of reports in one convenient place. For more information, see Master Reports.

Themes

Both Page and RDL reports can use themes to apply standard formatting to a range of report controls. Like using a master report, this allows you to change the look of a whole suite of reports in one place. You can specify colors for text and background, hyperlink colors, major and minor fonts, images, and constants, and then specify theme values in report control properties. When you want to change the look, you can do it all in the *.rdlx-theme file and it will apply to each report when it runs. For more information, see Create and Add Themes.

Data

RDL reports are ideal when you need to show data from different data sets, and when you do not need to control where the data appears on the page. Use data regions to display data in the report, and after the controls grow to accommodate your data, ActiveReports breaks it down into pages. For more information, see Data Sources and Datasets.

Shared Data Sources

RDL reports allow you to create and use shared data sources, so that you need not enter the same connection string every time you create a report.

Custom Resource Locators

You can create a custom resource locator for items to use in your reports. In this way, you can locate images for reports, or even reports to use in subreports or in drill-through links. For more information, see Custom Resource Locator.

Data Regions and Report Controls

All Rdl reports have controls that can display data differently than in section reports. You can use Sparkline and Bullet report controls for dashboard reports, plus there is a Calendar report control, and List, Table, and Tablix data regions to display your data. You can use expressions in many of the properties to determine what to display and how to display it. For more information on these and other report controls, see Toolbox.

Note: The PageHeader and PageFooter sections of RDL Reports do not display controls bound to dataset values at runtime. These sections only display controls with static data like labels or, you can also add parameters using dataset values and use controls bound to parameter value in order to display dataset field values in these sections.

Data Visualizers

The Image and TextBox report controls have a Data Visualizer feature that allows you to display data in small, easy-to-comprehend graphs. This is a powerful tool to really make your data pop. For more information, see Data Visualizers.

Grouping

You can group data within data regions by fields or expressions, control the scope of aggregates, and even create recursive hierarchies in data with parent-child relationships. The Level function allows you to indent by level to show these relationships visually. For more information, see Grouping Data (Page Layout).

Interactivity

Interactive Sorting

You can allow users to sort data in List, BandedList, Table, or Tablix data regions using the Interactive Sort properties of a TextBox report control. For more information, see Allow Users to Sort Data in the Viewer.

Parameters

You can add parameters to reports that allow users to select which values to display in the report. These are also useful in creating drill-through reports. For more information, see Add Parameters.

Drill Down

You can use the Visibility settings available on report controls, data regions, table rows, and tablix row and column groups to create drill-down reports. With these settings, you can initially hide items and set a toggle item that users can click to drill into more detailed data. For more information, see Create a Drill-Down Report.

Drill Through

You can use the Action property in the Navigation settings available on text boxes, images, and chart data values to create drill-through reports that let users click links to more detailed reports with parameters. Although you can create drill-through links to reports without parameters, this may leave users searching a huge detailed report for relevant information.

Bookmark Links

You can also use the Action property in the Navigation settings to jump to a bookmark or URL.

Pagination

You can control where pages break in RDL reports using PageSize settings, as well as PageBreakBefore and PageBreakAfter properties on data regions, groups, and rectangles.

See Also
Page Report


Page Report

Page Report
ActiveReports 10 > ActiveReports User Guide > Concepts > Report Types > Page Report

The new Page report offers you a way to create very specific styles of reports that are very difficult, if not impossible, in other .NET reporting tools. You design this type of report on a page where none of the report controls can grow or shrink at run time, making it ideal for duplicating legacy paper forms.

As with all Page reports, instead of report sections where you place report controls, you place data regions and controls directly on the page. But with Page reports, there is no need to use code or add measurements to make sure that everything fits. Unlike the RDL Report, the controls remain fixed at run time, so you can drop a table on the report, set a property to size it exactly how you want it, and have something very close to a WYSIWYG report at design time.

One row of data per page or one group per page

By default, all of the records are in one group, but you can set page level grouping to render one row of data on each page. This is ideal for something like a tax form that you want to print for every client or every employee, or an invoice that you want to print for every customer. For more information, see Grouping in a fixed page.

Where does the rest of the data go?

If there is data that does not fit within the space allocated for the data region at design time, you can assign it to flow into an OverflowPlaceholder control. This can go on the same page in a different area, for example, in the form of columns, or it can go on a separate page. For more information, see OverflowPlaceholder and Overflow Data in a Single Page.

Additional pages

You can run an entire report using the same page layout for every page, which is useful for something like an invoice, but does not satisfy every reporting need.

For other types of reports, you can add pages and create different layouts for each one, or duplicate a page you have already created. This can save a lot of time and effort when you have a report with many precisely placed controls, and you need additional pages that duplicate many of them. For example, when you need to provide employees with federal, state, and city copies of tax forms that have only one label changed. For more information, see Overflow Data in Multiple Pages.

You can also insert new pages between existing ones, and drag page tabs to rearrange them. With multiple pages, you can also choose how to collate the pages at run time. For more information, see how to Set Up Collation and Collate Multiple Copies of a Report.

Caution: Page Reports do not support nested data regions. A red border indicating overlapping of controls appears around the nested data region, on placing one data region inside another.
See Also
Toolbox

Walkthroughs

Page Report/RDL Report Walkthroughs

How To

Work with Report Controls and Data Regions


Code-Based Section Report

Code-Based Section Report
ActiveReports 10 > ActiveReports User Guide > Concepts > Report Types > Code-Based Section Report

When you add an ActiveReports 10 Section Report (code-based) to your Visual Studio project, report layouts are saved as C# or Visual Basic files within the project in which they are created. these files are compiled into the application when you build it. Each report is composed of three files:

  • rptYourReportName.vb or .cs
  • rptYourReportName.Designer.vb or .cs
  • rptYourReportName.resx

In this way, layout information models the behavior of Windows Forms in the .NET framework.

The design surface of a section report has banded sections that repeat depending on the data and the type of section. For more information, see Section Report Structure and Section Report Events.

Code

This type of report is the most flexible in terms of what a .NET developer can achieve using code. It has an extensive API and is event-based, which allows you to control all aspects of the report and how it is generated. If you like, you can even build a report completely in code. See details about the API in the Class Library section of the help.

The API is also available with XML-based section reports, but you use VB or C# script instead of Windows Forms-like code. For more information, see XML-Based Section Report .

Data

Code-based section reports connect to data either via settings that you specify in the Report Data Source dialog, or through code. You can find more information on all of the ways to connect to data in a section report in the Work with Data in Section Reports topic.

Viewing and Exporting

To display a code-based report in the viewer, you use the LoadDocument method of the viewer. See Viewing Reports for more information. To export a code-based report, you use the Export method of the export you choose.

See Also

How To

Section Report How To

Concepts

Section Report Concepts


XML-Based Section Report

XML-Based Section Report
ActiveReports 10 > ActiveReports User Guide > Concepts > Report Types > XML-Based Section Report

When you add an ActiveReports 10 Section Report (xml-based) report to your Visual Studio project, the layout is saved as a stand-alone Report XML (RPX) file. Since these files are not compiled into your application, they are a good option for solutions in which you need to update or add reports frequently.

The RPX format cannot contain Visual Basic.NET or C# code. Instead, you can add VB.NET or C# script in the Script view of the report.

For more information on using script with a layout file, see Scripting in Section Reports.

XML-based section reports are the same as Code-Based Section Report with regard to data, events, structure, and exports, but everything is contained in a single, portable RPX file.

End User Report Designer

If you want to allow end users to edit and create section reports in a Windows Forms application you create with the Designer control, these are XML-based, as there is nowhere to put Visual Studio code and no way to handle multiple files for a code-based section report. For more information, see Creating a Basic End User Report Designer (Pro Edition).

See Also
Report Types


Page Report/RDL Report Concepts

Page Report/RDL Report Concepts
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts

There are a number of concepts that apply to page reports and RDL reports.

In this section

Toolbox
This section provides information on each of the report controls and data regions available in the ActiveReports 10 Page Report and ActiveReports 10 RDL Report group in the Visual Studio toolbox.
Data Sources and Datasets
Find out about the Data Sources you can access through ActiveReports and fetch data through DataSets along with an overview of the Report DataSource and DataSet dialogs.
Shared Data Sources
Learn about the concept of shared data sources and how to use them in ActiveReports.
Server Shared Data Sets
Learn about the concept of server shared data sets and how to use them in ActiveReports.
Expressions
Learn about setting expressions in reports and creating expression through the Expression Editor.
Layers
Learn about using Layers a in reports and it's advantages.
Styles
Learn about using Styles in a reports and it's advantages.
Using Script
Embed code in the script tab to extend the features in your reports.
Report Dialog
See the various options provided in Report Dialog.
FixedPage Dialog
See the various options provided in FixedPage Dialog.
Grouping Data (Page Layout)
See the various options provided for grouping data in ActiveReports.
Add Page Numbering
Select out of a list of pre-defined formats or create custom formats to display page numbers in reports.
Themes
Create themes to define the appearance of reports, and apply the themes to any number of reports for a consistent look.
Master Reports (RDL)
Use master reports to create a reusable template of common elements you can apply to other reports.
Data Visualizers
Learn about a number of ways to make your data pop using small graphs in images and background colors.
Custom Resource Locator
Find information about the ResourceLocator class that allows you to find resources on your machine for use in your RDL reports.
See Also
Section Report Concepts

How To

Page Report/RDL Report How To


Toolbox

Toolbox
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox

When a Page report or RDL report has focus in Visual Studio, the ActiveReports 10 Page Report and ActiveReports 10 RDL Report toolbox group offers a number of report controls and data regions that you can use when creating a report. You can drag these from the toolbox and drop them onto your reports. These tools are different than those in the Section Report Toolbox.

Note: Take care in naming report controls, as they are displayed to end users in the advanced search feature of the Viewer.

In this section

BandedList
The BandedList is a data region with freeform bands in which you can place report controls. With a detail band that repeats data for every row in the dataset, this data region resembles the Section report design surface.
Barcode
The BarCode report control renders scannable barcodes in any of 25 popular symbologies. You can bind it to data, control the bar width, rotation, quiet zones, caption locations, whether check sum is enabled, and many other properties.
Bullet
The Bullet report control is an easy-to-read linear gauge that is a good alternative to using a dashboard for data visualization. You can bind it to data and set best, worst, and satisfactory values as well as labels and ranges.
Calendar
The Calendar report control displays date-based data or events in a calendar format in your report. You can modify the appearance of the calendar and events.
Chart
The Chart is a graphic data region which allows you to display data in a variety of chart styles with 3D effects and colors, and provides many options for customization. You can choose from numerous chart types.
CheckBox (Page Report)
The CheckBox report control can display Boolean data, or you can set its Checked property. You can also enter static text to display.
Container

The Container report control is a graphical element that is used as a container for other items. The Container report control has no data associated with it. As a container, this control serves to keep the report controls it contains together when they might otherwise grow apart due to the growth of adjacent report controls.

FormattedText

The FormattedText report control displays data, and allows you to format selected areas of text within the control in different ways. This report control accepts XHTML input, and allows you to set up mail merge.

Image
The Image report control allows you to specify any image file to display from an external source, a database or an embedded image.
Line
The Line report control, a graphical element that has no data associated with it, visually marks boundaries or highlights specific areas of a report. You can use lines of various weight, color, and style to highlight regions of your reports and to add style and polish.
List
The List is a freeform data region in which you can place other report controls. It repeats any report control it contains for every record in the dataset.
Map
The Map data region shows your business data against a geographical background. You can select different types of map, depending on the type of information you want to communicate in your report.
OverflowPlaceHolder
The Overflow Placeholder report control is only available with page reports. It is a simple rectangle that you link to a List, BandedList, Tablix, or Table data region to display data that extends beyond one page.
Shape
The Shape report control, a graphical element that has no data associated with it, allows you to mark visual boundaries or highlight specific areas of a report with rectangles, rounded rectangles, or elliptical shapes. Unlike the Container report control, it cannot contain other controls.
Sparkline
The Sparkline report control displays a data trend over time in a graph small enough to be used inline, with a height similar to the surrounding text. It presents the most recent measurement as the right-most data point and compares it with earlier measurements to the left. You can select from line, area, stacked bar, column, and whisker sparkline types.
Subreport(RDL)
The Subreport control displays data from a separate report that you specify. You can pass a parameter to the subreport from the main report to filter data displayed in a subreport. Please note that each subreport instance is run as a separate report, which can cause a noticeable difference in performance when processing large reports, in which case a data region may be more efficient.
Table
The Table is a data region that shows data in rows. By default, it has three columns and three rows. Once set at design time, the columns are static, while the rows repeat for each row of data. The default rows are the header, detail, and footer. The header and footer can be removed, and group headers and footers can be added to suit your needs. Each cell contains a TextBox by default, but you can replace the TextBox with any report control.
TableOfContents
The TableOfContents (ToC) report control is used to display the document map, an organized hierarchy of the report bookmarks and labels along with their page numbers, in the body of a report. The TableOfContents control allows you to quickly understand and navigate the data inside a report in all viewers that are supported in ActiveReports. Unlike the Document Map that is only available in the Viewers and cannot be rendered or printed, you can use the TableOfContents control to embed the ToC structure in the report body for printing and rendering purposes.
TextBox
The TextBox report control displays data, and is the default report control that appears in each cell of a table or tablix. It is also the report control that is created automatically when you drag a field from the Data Explorer onto your report. You can use expressions to modify the data that appears in a TextBox.
Tablix
Tablix data region displays data in cells that are arranged in rows and columns. Tablix is mainly a combination of two data regions- table and a matrix. Therefore, it provides all the features of a table and a matrix along with added capabilities which includes support for multiple adjacent groups on rows or columns and improved layout flexibility with stepped group layouts.
See Also
Section Report Toolbox


BandedList

BandedList
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > BandedList
Show All Show All
Hide All Hide All

The BandedList data region is a collection of free-form bands. By default, it is composed of three bands: a header, a footer and a detail band. Bound report controls in the detail band repeat for every row of data. The header and footer rows render once at the beginning and end of the BandedList, respectively, and are a good place for titles and grand totals.

Click inside each band to reveal its properties in the Properties window, or click the four-way arrow to select the entire data region and reveal its properties. Properties for this data region include the following.

Band Properties

Property | Description
CanGrow | Change to True to allow the data region to grow vertically to accommodate data.
CanShrink | Change to True to allow the data region to shrink if there is not enough data to fill it.
KeepTogether | Change to True to have ActiveReports attempt to keep all of the data in the band together on one page.
PageBreakAtEnd | Change to True to insert a page break after rendering all of the data in the band.
PageBreakAtStart | Change to True to insert a page break before rendering any of the data in the band.
RepeatOnNewPage | With header and footer bands, repeats the band on every page when the related details span multiple pages.

BandedList Properties

Property | Description
DataSetName | Select the dataset to use in the data region.
KeepTogether | Change to True to have ActiveReports attempt to keep all of the data in the data region together on one page.
NewSection | Change to True to render the data region in a new section.
OverflowName | Select the name of the OverflowPlaceHolder control in which to render data that exceeds the allowed space for the data region on the first page of the report.

You can add group header and group footer bands. Report controls in these bands repeat once for each group instance. You can also nest groups, plus, in RDL reports, you can nest other data regions in any header or footer band. Grouping in the BandedList is similar to grouping in the Table data region. You can provide a grouping expression for each group, and also sort the groups.

Caution: You cannot sort the detail data in a BandedList, so any sorting of this type must be done at the query level.

BandedList Dialog

Properties for the BandedList data region are available in the BandedList dialog. To open it, with the BandedList selected on the report, under the Properties Window, click the Property dialog link.

The BandedList dialog lets you set properties on the data region with the following pages.

Note: You can click <Expression...> in many of these properties to open the Expression Editor where you can create an expression to determine the value.

General

Name: Enter a name for the banded list that is unique within the report.

Tooltip: Enter the value or expression you want to appear when a user hovers the cursor over the banded list in the viewer at run time.

Dataset name: Select a dataset to associate with the banded list. The combo box is populated with all of the datasets in the report's dataset collection.

Has own page numbering: Select to indicate whether this banded list is in its own section with regards to pagination.

Page Breaks: Select any of the following options to apply to each instance of the banded list.

  • Insert a page break before this banded list
  • Insert a page break after this banded list
  • Fit banded list on a single page if possible

Header and Footer: Select any of the following options.

  • Repeat header band on each page
  • Repeat footer band on each page

Visibility

By default, the banded list is visible when the report runs, but you can hide it, hide it only when certain conditions are met, or toggle its visibility with another report control.

Initial visibility

  • Visible: The banded list is visible when the report runs.
  • Hidden: The banded list is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the BandedList is visible. True for hidden, False for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the BandedList. The user can click the toggle item to show or hide this BandedList.

Navigation

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this BandedList. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Groups

Click the plus sign button to add a new group to the BandedList, and delete them using the X button. Once you add one or more groups, you can reorder them using the arrow buttons, and set up information for each group on the following tabs.

General

Name: Enter a name for the group that is unique within the report. This property cannot be set until after a Group on expression is supplied.

Group on: Enter an expression to use for grouping the data.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Parent group: For use in recursive hierarchies. Enter an expression to use as the parent group.

Filters

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Sorting

Click the plus sign button to enter new sort expressions, and remove them using the X button.

Expression: Enter an expression by which to sort the data in the group.

Direction: Select Ascending or Descending.

Visibility

By default, the group is visible when the report runs, but you can hide a group, hide it when certain conditions are met, or toggle its visibility with another report control.

Initial visibility

  • Visible: The group is visible when the report runs.
  • Hidden: The group is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the group is visible. True for hidden, False for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report item. The user can click the toggle item to show or hide this band group. This enables the drop-down list where you can select the report control that users can click to show or hide this group.

Data Output

Element name: Enter a name to be used in the XML output for this group.

Collection: Enter a name to be used in the XML output for the collection of all instances of this group.

Output: Choose Yes or No to decide whether to include this group in the XML output.

Layout

Page break at start: Inserts a page break before the group.

Page break at end: Inserts a page break after the group.

Include group header: Adds a group header band (selected by default).

Include group footer: Adds a group footer band (selected by default).

Repeat group header: Repeats the group header band on each page.

Repeat group footer: Repeats the group footer band on each page.

Has own page numbering: Used in conjunction with the "Page Number in Section" and "Total Pages in Section" properties, tells the report that the group constitutes a new page numbering section.

Filters

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Data Output

The Data Output page of the BandedList dialog allows you to control the following properties when you export to XML.

  • Element name: Enter a name to be used in the XML output for this BandedList.
  • Output: Choose Auto, Yes, or No to decide whether to include this BandedList in the XML output. Choosing Auto exports the contents of the BandedList.
See Also

How To

Page Report/RDL Report How To


Barcode

Barcode
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Barcode
Show All Show All
Hide All Hide All

The Barcode report control offers 39 different barcode styles to choose from. This saves you the time and expense of finding and integrating a separate component. As with other data-bound report controls, you can use an expression to bind the value of a field to the Barcode Value property.

Apart from the barcode style, you can manage the alignment, direction, color, background color, bar width, caption position, font, text, and check whether checksum is enabled in the Properties Window. There are more properties available with the Code49, PDF417, and QRCode barcode styles. Click the Barcode to reveal its properties in the Properties window. All of the properties specific to this report control are also available in the Barcode dialog.

Note: This barcode is ported from the Section report Barcode control, so if you create reports programmatically, the Page report/RDL report barcode is treated as a CustomReportItem.

Barcode Dialog

Properties for the Barcode are available in the Barcode dialog. To open it, with the Barcode selected in the report, under the Properties Window, click the Property dialog link.

The Barcode dialog lets you set properties on the report control with the following pages.

Note: You can select the <Expression...> option in many of these properties to open the Expression Editor where you can create an expression to determine the value.

General

Name: Enter a name for the barcode that is unique within the report.

Tooltip: Enter the value or expression you want to appear when a user hovers the cursor over the barcode in the viewer at run time.

Value: Enter an expression or a static label, or choose a field expression from the drop-down list. You can access the expression editor by selecting <Expression...> in the list. The value of this expression or text is used to render the barcode in the report.

Invalid Barcode Text: Enter a message to display if the barcode contains invalid values (content, character, length).

Caption

Location: Select whether to display the caption above or below the barcode, or select None to display the barcode without a caption.

Text Alignment: Select the horizontal alignment of the caption. The default value of General centers the caption.

Barcode Settings

Symbology: Enter the type of barcode to use. ActiveReports supports all of the most popular symbologies:

Table of all included symbologies

Notes: The RSS and QRCode styles have fixed height-to-width ratios. When you resize the width, the height is automatically calculated.

When you choose a style that offers supplemental options, the additional options appear below.
Symbology Name | Example | Description
Ansi39 | ANSI 3 of 9 (Code 39) uses upper case, numbers, - , * $ / + %. This is the default barcode style.
Ansi39x | ANSI Extended 3 of 9 (Extended Code 39) uses the complete ASCII character set.
Codabar | Codabar uses A B C D + - : . / $ and numbers.
Code_128_A | Code 128 A uses control characters, numbers, punctuation, and upper case.
Code_128_B | Code 128 B uses punctuation, numbers, upper case and lower case.
Code_128_C | Code 128 C uses only numbers.
Code_128auto | Code 128 Auto uses the complete ASCII character set. Automatically selects between Code 128 A, B and C to give the smallest barcode.
Code_2_of_5 | Code 2 of 5 uses only numbers.
Code_93 | Code 93 uses uppercase, % $ * / , + -, and numbers.
Code25intlv | Interleaved 2 of 5 uses only numbers.
Code39 | Code 39 uses numbers, % * $ /. , - +, and upper case.
Code39x | Extended Code 39 uses the complete ASCII character set.
Code49 | Code 49 is a 2D high-density stacked barcode containing two to eight rows of eight characters each. Each row has a start code and a stop code. Encodes the complete ASCII character set.
Code93x | Extended Code 93 uses the complete ASCII character set.
DataMatrix | Data Matrix is a high density, two-dimensional barcode with square modules arranged in a square or rectangular matrix pattern.
EAN_13 | EAN-13 uses only numbers (12 numbers and a check digit). It takes only 12 numbers as a string to calculate a check digit (CheckSum) and add it to the thirteenth position. The check digit is an additional digit used to verify that a bar code has been scanned correctly. The check digit is added automatically when the CheckSum property is set to True.
EAN_13 with the add-on code | EAN-13 may include the add-on code to the right of the main code. The add-on code may include up to 5 supplemental characters.
EAN_8 | EAN-8 uses only numbers (7 numbers and a check digit).
EAN128FNC1 EAN-128 is an alphanumeric one-dimensional representation of Application Identifier (AI) data for marking containers in the shipping industry.

This type of bar code contains the following sections:

  • Leading quiet zone (blank area)
  • Code 128 start character
  • FNC (function) 1 character which allows scanners to identify this as an EAN-128 barcode
  • Data (AI plus data field)
  • Symbol check character (Start code value plus product of each character position plus value of each character divided by 103. The checksum is the remainder value.)
  • Stop character
  • Trailing quiet zone (blank area)

The AI in the Data section sets the type of the data to follow (i.e. ID, dates, quantity, measurements, etc.). There is a specific data structure for each type of data. This AI is what distinguishes the EAN-128 code from Code 128.

Multiple AIs (along with their data) can be combined into a single bar code.

EAN128FNC1 is a UCC/EAN-128 (EAN128) type barcode that allows you to insert FNC1 character at any place and adjust the bar size, etc., which is not available in UCC/EAN-128.

To insert FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at runtime.
IntelligentMail | Intelligent Mail, formerly known as the 4-State Customer Barcode, is a 65-bar code used for domestic mail in the U.S.
JapanesePostal | This is the barcode used by the Japanese Postal system. Encodes alpha and numeric characters consisting of 18 digits including a 7-digit postal code number, optionally followed by block and house number information. The data to be encoded can include hyphens.
Matrix_2_of_5 | Matrix 2 of 5 is a higher density barcode consisting of 3 black bars and 2 white bars.
MicroPDF417

MicroPDF417 is two-dimensional (2D), multi-row symbology, derived from PDF417. Micro-PDF417 is designed for applications that need to encode data in a two-dimensional (2D) symbol (up to 150 bytes, 250 alphanumeric characters, or 366 numeric digits) with the minimal symbol size.

MicroPDF417 allows you to insert an FNC1 character as a field separator for variable length Application Identifiers (AIs).

To insert FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at runtime.
MSI | MSI Code uses only numbers.
Pdf417 | Pdf417 is a popular high-density 2-dimensional symbology that encodes up to 1108 bytes of information. This barcode consists of a stacked set of smaller barcodes. Encodes the full ASCII character set. It has ten error correction levels and three data compaction modes: Text, Byte, and Numeric. This symbology can encode up to 1,850 alphanumeric characters or 2,710 numeric characters.
PostNet | PostNet uses only numbers with a check digit.
QRCode | QRCode is a 2D symbology that is capable of handling numeric, alphanumeric and byte data as well as Japanese kanji and kana characters. This symbology can encode up to 7,366 characters.
RM4SCC | Royal Mail RM4SCC uses only letters and numbers (with a check digit). This is the barcode used by the Royal Mail in the United Kingdom.
RSS14 | RSS14 is a 14-digit Reduced Space Symbology that uses EAN.UCC item identification for point-of-sale omnidirectional scanning.
RSS14Stacked RSS14Stacked uses the EAN.UCC information with Indicator digits as in the RSS14Truncated, but stacked in two rows for a smaller width.
RSS14Stacked allows you to set Composite Options, where you can select the type of the barcode in the Type drop-down list and the value of the composite barcode in the Value field.
RSS14Stacked CCA | RSS14Stacked with Composite Component - Version A.
RSS14StackedOmnidirectional | RSS14StackedOmnidirectional uses the EAN.UCC information with omnidirectional scanning as in the RSS14, but stacked in two rows for a smaller width.
RSS14Truncated | RSS14Truncated uses the EAN.UCC information as in the RSS14, but also includes Indicator digits of zero or one for use on small items not scanned at the point of sale.
RSSExpanded

RSSExpanded uses the EAN.UCC information as in the RSS14, but also adds AI elements such as weight and best-before dates.

RSSExpanded allows you to insert an FNC1 character as a field separator for variable length Application Identifiers (AIs).

To insert FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at runtime.
RSSExpandedStacked

RSSExpandedStacked uses the EAN.UCC information with AI elements as in the RSSExpanded, but stacked in two rows for a smaller width.

RSSExpandedStacked allows you to insert an FNC1 character as a field separator for variable length Application Identifiers (AIs).

To insert FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at runtime.
RSSLimited RSS Limited uses the EAN.UCC information as in the RSS14, but also includes Indicator digits of zero or one for use on small items not scanned at the point of sale.
RSSLimited allows you to set Composite Options, where you can select the type of the barcode in the Type drop-down list and the value of the composite barcode in the Value field.
RSSLimited CCA | RSS Limited with Composite Component - Version A.
UCCEAN128 | UCC/EAN –128 uses the complete ASCII character Set. This is a special version of Code 128 used in HIBC applications.
UPC_A | UPC-A uses only numbers (11 numbers and a check digit).
UPC_A with the add-on code | UPC_A may include the add-on code to the right of the main code. The add-on code may include up to 5 supplemental characters.
UPC_E0 | UPC-E0 uses only numbers. Used for zero-compression UPC symbols. For the Caption property, you may enter either a six-digit UPC-E code or a complete 11-digit (includes code type, which must be zero) UPC-A code. If an 11-digit code is entered, the Barcode control will convert it to a six-digit UPC-E code, if possible. If it is not possible to convert from the 11-digit code to the six-digit code, nothing is displayed.
UPC_E0 with the add-on code | UPC_E0 may include the add-on code to the right of the main code. The add-on code may include up to 5 supplemental characters.
UPC_E1 | UPC-E1 uses only numbers. Used typically for shelf labeling in the retail environment. The length of the input string for U.P.C. E1 is six numeric characters.
UPC_E1 with the add-on code | UPC_E1 may include the add-on code to the right of the main code. The add-on code may include up to 5 supplemental characters.

When you choose a symbology which offers supplemental options, the additional options appear below the Symbology drop-down box.

Bar Height: Enter a value in inches (for example, .25in) for the height of the barcode.

Narrow Bar Width (also known as X dimension): This is a value defining the width of the narrowest part of the barcode. Before using an extremely small value for this width, ensure that the scanner can read it. This value is specified in Length units (for example, '10cm', '4mm', '1in').

Tip: For accurate scanning, the quiet zone should be ten times the Narrow Bar Width value.

Narrow Width Bar Ratio (also known as N dimension): Enter a value to define the multiple of the ratio between the narrow and wide bars in symbologies that contain bars in only two widths. For example, if it is a 3 to 1 ratio, this value is 3. Commonly used values are 2, 2.5, 2.75, and 3.

Quiet Zone

A quiet zone is an area of blank space on either side of a barcode that tells the scanner where the symbology starts and stops.

Left: Enter a size in inches of blank space to leave to the left of the barcode.

Right: Enter a size in inches of blank space to leave to the right of the barcode.

Top: Enter a size in inches of blank space to leave at the top of the barcode.

Bottom: Enter a size in inches of blank space to leave at the bottom of the barcode.

Note: The units of measure listed for all of these properties are the default units of measure used if you do not specify. You may also specify cm, mm, in, pt, or pc.

Checksum

A checksum provides greater accuracy for many barcode symbologies.

Compute Checksum: Select whether to automatically calculate a checksum for the barcode.

Note: If the symbology you choose requires a checksum, setting this value to False has no effect.

Code49 Options

Code49 Options are available for the Code49 barcode style.

Use Grouping: Indicates whether to use grouping for the Code49 barcode. The possible values are True or False.

Group Number: Enter a number between 0 and 8 for the barcode grouping.

DataMatrix Options

DataMatrix Options are available for the DataMatrix barcode style.

EccMode: Select the Ecc mode from the drop-down list. The possible values are ECC000, ECC050, ECC080, ECC100, ECC140 or ECC200.

Ecc200 Symbol Size: Select the size of the ECC200 symbol from the drop-down list. The default value is SquareAuto.

Ecc200 Encoding Mode: Select the encoding mode for ECC200 from the drop-down list. The possible values are Auto, ASCII, C40, Text, X12, EDIFACT or Base256.

Ecc000_140 Symbol Size: Select the size of the ECC000_140 barcode symbol from the drop-down list.

Structured Append: Select whether the barcode symbol is part of the structured append symbols. The possible values are True or False.

Structure Number: Enter the structure number of the barcode symbol within the structured append symbols.

File Identifier: Enter the file identifier of a related group of the structured append symbols. If you set the value to 0, the file identifier symbols are calculated automatically.

EAN Supplementary Options

EAN Supplementary Options are available for the EAN_13 and EAN_8 barcode styles.

Supplement Value: Enter the expression to set the value of the barcode supplement.

Caption Location: Select the location for the supplement caption from the drop-down list. The possible values are None, Above or Below.

Supplement Bar Height: Enter the bar height for the barcode supplement.

Supplement Spacing: Enter the spacing between the main and the supplement barcodes.

EAN128FNC1 Options

EAN128FNC1 Options are available for the EAN128FNC1 barcode style.

DPI: Specify the resolution of the printer as dots per inch to create an optimized barcode image with the specified Dpi value.

Module Size: Enter the horizontal size of the barcode module.

Bar Adjust: Enter the adjustment size by dot units, which affects the size of the module and not the entire barcode.

GS1Composite Options

GS1Composite Options are available for the RSS14Stacked and RSSLimited barcode styles.

Type: Select the type of the composite barcode from the drop-down list. The possible values are None or CCA. CCA (Composite Component - Version A) is the smallest variant of the 2-dimensional composite component.

Value: Enter the expression to set the value of the composite barcode.

MicroPDF417 Options

MicroPDF417 Options are available for the MicroPDF417 barcode style.

Compaction Mode: Select the type of the compaction mode from the drop-down list. The possible values are Auto, TextCompactionMode, NumericCompactionMode, or ByteCompactionMode.

Version: Select the version from the drop-down box to set the symbol size.

Segment Index: The segment index of the structured append symbol. The valid value is from 0 to 99998, and less than the value in Segment Count.

Segment Count: The segment count of the structured append symbol. The valid value is from 0 to 99999.

File ID: The file id of the structured append symbol. The valid value is from 0 to 899.

PDF417 Options

PDF417 Options are available for the Pdf417 barcode style.

Columns: Enter column numbers for the barcode.

Rows: Enter row numbers for the barcode.

Error Correction Level: Enter the error correction level for the barcode.

PDF 417 Barcode Type: Select the PDF417 barcode type form the drop-down list. The possible values are Normal or Simple.

QRCode Options

QRCode Options are available for the QRCode barcode style.

Model: Select the model for the QRCode barcode style from the drop-down list. The possible values are Model1 or Model2.

Error Level: Select the error correction level for the barcode from the drop-down list. The possible values are M, L, H or Q.

Version: Enter the version of the QRCode barcode style.

Mask: Select the pattern for the barcode masking form the drop-down list.

Use Connection: Select whether to use the connection for the barcode. The possible values are True or False.

ConnectionNumber: Enter the connection number for the barcode.

Encoding: Select the barcode encoding from the drop-down list.

RssExpandedStacked Options

RssExpandedStacked Options are available for the RSSExpandedStacked barcode style.

Row Count: Enter the number of the barcode stacked rows.

UPC Supplementary Options

UPC Supplementary Options are available for the UPC_A, UPC_E0 and UPC_E1 barcode styles.

Supplement Value: Enter the expression to set the value of the barcode supplement.

Caption Location: Select the location for the supplement caption from the drop-down list. The possible values are None, Above or Below.

Supplement Bar Height: Enter the bar height for the barcode supplement.

Supplement Spacing: Enter the spacing between the main and supplement barcodes.

Appearance

Font

Family: Select a font family name or a theme font.

Size: Choose the size in points for the font or use a theme.

Style: Choose Normal or Italic or select a theme.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, or Bolder.

Color: Choose a color to use for the text.

Decoration: Choose from None, Underline, Overline, or LineThrough.

Border

Style: Select a style for the border.

Width: Enter a value in points to set the width of the border.

Color: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Background

Color: Select a color to use for the background, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Format

Format code: Select one of the common numeric formats provided or use a custom .NET formatting code to format dates or numbers. For more information, see MSDN's Formatting Types topic.

Amount of space to leave around report control

Top margin: Set the top padding in points.

Left margin: Set the left padding in points.

Right margin: Set the right padding in points.

Bottom margin: Set the bottom padding in points.

Rotation: Choose None, Rotate90Degrees, Rotate180Degrees, or Rotate270Degrees.

Visibility

Initial visibility

  • Visible: The barcode is visible when the report runs.
  • Hidden: The barcode is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the barcode is visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. This enables the drop-down box where you can select the TextBox control that users can click to show or hide this barcode in the viewer.

Navigation

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this barcode. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Data Output

Element Name: Enter a name to be used in the XML output for this barcode.

Output: Choose Auto, Yes, or No to decide whether to include this barcode in the XML output. Auto exports the contents of the barcode only when the value is not a constant.

Render as: Choose Auto, Element, or Attribute to decide whether to render barcodes as Attributes or Elements in the exported XML file. Auto uses the report's setting for this property.


Bullet

Bullet
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Bullet
Show All Show All
Hide All Hide All

The Bullet report control is an easy-to-read linear gauge that is a good alternative to using a dashboard for data visualization.

A bullet graph has a pointer that shows a key measure. With this control, you can take a single value, the year-to-date revenue for example, and compare it to a target value that you define in the control's properties. You can also define the beginning of the graph as the worst value and the end of the graph as the best value. To make the data visualization even more intuitive, you can define a qualitative range (bad, satisfactory and good) for segments on the bullet graph and immediately see the position of the key measure within the bullet graph range.

You can combine multiple Bullets into a data region, a table for example, to show single values side by side. You can orient Bullets horizontally or vertically, and put them together as a stack to analyze several data dimensions at once.

Bullet Dialog

Properties for the Bullet are available in the Bullet dialog. To open it, with the Bullet control selected on the report, under the Properties Window, click the Property dialog link.

The Bullet dialog lets you set properties on the report control with the following pages.

Note: You can click <Expression...> in many of these properties to open the Expression Editor where you can create an expression to determine the value. For properties with enumerated values, the values are listed under Constants in the Fields tree view on the left side of the Expression Editor.

General

Name: Enter a name for the Bullet that is unique within the report.

Data

Value: Enter an expression to use as the bullet value.

Target Value: Enter an expression to use as the target value of the bullet graph.

Appearance

Bullet Graph Orientation

Horizontal: Select to display a horizontal bullet graph.

Vertical: Select to display a vertical bullet graph.

Value Style

Color: Select a color to use for the value marker, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color. The default value is Black.

Target Style

Target Type: Choose Line, Dot or Square. The default value is Line.

Color: Select a color to use for the target value marker, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color. The default value is Black.

Width: Enter a value in points to set the width of the target value marker. The default value is 3pt.

Note: The Width setting applies only when the Target Type is set to Line.

Tick Marks

Position: Choose None, Inside or Outside. The default value is Outside.

Color: Select a color to use for the tick marks, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color. The default value is LightGray.

Width: Enter a value in points to set the width of the tick marks. The default value is 1pt.

Interval between tick marks: Set the interval at which you want to show tick marks.

Ranges

Worst Value: Enter a value or expression to define the lowest value on the graph.

Bad/Satisfactory Boundary: Enter a value or expression to define the boundary between bad and satisfactory values.

Display 3 Sections: Select this check box to show three separate value ranges (bad, satisfactory, and good) instead of two (bad and satisfactory). This enables the Satisfactory/Good Boundary.

Satisfactory/Good Boundary: Enter a value or expression to define the boundary between satisfactory and good values.

Best Value: Enter a value or expression to define the highest value on the graph.

Labels

Display Labels: Select this check box to display axis labels for the bullet graph. Selecting this box enables the rest of the properties on this page.

Format: Select one of the provided format codes or use a custom .NET formatting code to format dates or numbers. For more information, see MSDN's Formatting Types topic.

Font

Family: Choose the font family name. The default value is Arial.

Size: Choose the size in points for the font. The default value is 10pt.

Style: Choose Regular, Bold, Italic, Underline or Strikeout. The default value is Regular.

Color: Select a Web or custom color for the font. The default value is Black.

Navigation

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this Bullet. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Visibility

Initial visibility

  • Visible: The bullet graph is visible when the report runs.
  • Hidden: The bullet graph is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the bullet graph is visible. True for hidden, False for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the bullet. The user can click the toggle item to show or hide this bullet.

Data Output

Element Name: Enter a name to be used in the XML output for this Bullet.

Output: Choose Auto, Yes, No, or Content only to decide whether to include this Bullet in the XML output. Auto exports the contents of the bullet graph only when the value is not a constant.

See Also

How To

Create a Bullet Graph


Calendar

Calendar
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Calendar
Show All Show All
Hide All Hide All

The Calendar report control is used to display date-based data or events in a calendar format in your report. In the Properties Window or the Calendar Dialog, you can modify the appearance of the days, months, weekends, and events in the calendar, and create events for it.

Calendar Dialog

Properties for the Calendar are available in the Calendar dialog. To open it, with the Calendar control selected on the report, under the Properties Window, click the Property dialog link.

The Calendar dialog lets you set properties on the report control with the following pages.

Note: You can select the <Expression...> option in many of these properties to create an expression to determine the value. For properties with enumerated values, the values are listed under Constants in the Fields tree view on the left side of the Expression Editor.

General

Name: Enter a name for the calendar that is unique within the report.

Data

Dataset Name: Select a dataset to associate with the calendar. The list is populated with all of the datasets in the report's dataset collection.

Event Settings

Start Date: Enter an expression to use to identify the Start Date value(s) of the events to be displayed.

End Date: Enter an expression to use to identify the End Date value(s) of the events to be displayed.

Value: Enter an expression to use to identify the event text value(s) of the events to be displayed.

Detail Grouping

Name: Enter a name for the detail group that is unique within the report. A name is created automatically if you do not enter one.

Group on: Enter an expression to use for grouping the data. If you have already assigned a dataset name in the Dataset Name property, you can select a field from the dataset.

Filters

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Event Appearance

Format: Select one of the common numeric formats provided or use a custom .NET formatting code to format dates or numbers. For more information, see MSDN's Formatting Types topic.

Alignment: Select the horizontal alignment of the event text.

Font

Family: Choose the font family name.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

Color: Select a Web or custom color for the font.

Decoration: Choose from None, Underline, Overline, and LineThrough.

Background

Fill Color: Select a color to use for the background of the calendar event.

Border Color: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Image

You can display an image on all calendar events using the following options to define the image.

Source: Choose from External, Embedded, or Database.

MIME Type: Select the MIME type of the image chosen.

Value: Enter the name of the image to display.

Calendar Appearance

The Calendar Appearance page has the following tabs: Month Appearance, Day, Day Headers, Weekend, and Filler Day.

All but Day Headers have the same properties. (There is no Formatting section on the Day Headers tab.)

Font

Family: Choose the font family name.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

Color: Select a Web or custom color for the font.

Decoration: Choose from None, Underline, Overline, and LineThrough.

Border

Style: Select a style for the border.

Width: Enter a value in points to set the width of the border.

Color: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Background Fill Color: Select a color to use for the background of the calendar's month section.

Formatting

Alignment: Select the horizontal alignment of the calendar month text.

Format: Select one of the common numeric formats provided or use a custom .NET formatting code to format dates or numbers. For more information, see MSDN's Formatting Types topic.

Navigation

Action

Select one of the following actions to perform when a user clicks on an event in the calendar.

None: The default behavior is to do nothing when a user clicks the textbox at run time.

Jump to report: For drill-through reporting, select this option and provide the name of a local report, the relative path of a report in another folder, or the full path of a report on another server.

Parameters: Supply parameters to the targeted report by entering the Name of each parameter, the Value to send to the targeted report, or whether to Omit the parameter. Note that parameter names you supply must exactly match parameters in the target report.

Tip: You can remove or change the order of parameters using the X and arrow buttons.

Jump to bookmark: Select this option and provide a valid Bookmark ID to allow the user to jump to the report control with that Bookmark ID.

Jump to URL: Select this option and provide a valid URL to create a hyperlink to a Web page.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this calendar. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Data Output

Element Name: Enter a name to be used in the XML output for this calendar.

Output: Choose Auto, Yes, No, or Content only to decide whether to include this calendar in the XML output. Auto exports the contents of the calendar only when the value is not a constant.

See Also

How To

Page Report/RDL Report How To


Chart

Chart
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Chart
Show All Show All
Hide All Hide All

The Chart data region shows your data in a graphical representation that often makes it easier for users to comprehend large amounts of data quickly. Different types of charts are more efficient for different types of information, so we offer a wide variety of chart types. This makes it easy and cost effective to add charting to your reports, as there is no need to purchase and integrate a separate charting tool.

To hone in on your needs, when you first drag the Chart report control onto a page report/RDL report, you can select the broad category of chart type to use: Bar, Column, Scatter, Line, or Dot Plot.

Once you select a chart category, there are a number of dialogs to help you to customize your chart.

Note: You can select <Expression...> within many of these properties to create an expression to determine the value, or you can select a theme value to keep reports consistent.

Chart Appearance

To open the Chart Appearance dialog, select the Chart on the report, and below the Properties window, click the Chart appearance command. This dialog has the following pages.

Tip: To go directly to the Plot Area page, click in the middle of the chart to select the Plot Area, then under the Properties Window, click Property dialog.

Gallery

The Gallery page of the Chart dialog, in basic mode, displays each of the broad categories of chart types, plus subtypes so that you can refine your choice. For even more chart types, click the Advanced button.

Basic Chart Types

Bar Charts

Bar charts present each series as a horizontal bar, and group the bars by category. The x-axis values determine the lengths of the bars, while the y-axis displays the category labels. With a bar chart, you can select from the following subtypes.

  • Plain: Compares values of items across categories.
  • Stacked: A bar chart with two or more data series stacked one on top of the other that shows how each value contributes to the total.
  • Percent Stacked: A bar chart with two or more data series stacked one on top of the other to sum up to 100% that shows how each value contributes to the total with the relative size of each series representing its contribution to the total.

Column Charts

Column charts present each series as a vertical column, and group the columns by category. The y-axis values determine the heights of the columns, while the x-axis displays the category labels. With a column chart, you can select from the following subtypes.

  • Plain: Compares values of items across categories.
  • Stacked: A column chart with two or more data series stacked one on top of the other that shows how each value contributes to the total.
  • Percent Stacked: A column chart with two or more data series stacked one on top of the other to sum up to 100% that shows how each value contributes to a total with the relative size of each series representing its contribution to the total.

Scatter Charts

Scatter charts present each series as a point or bubble. The y-axis values determine the heights of the points, while the x-axis displays the category labels. With a scatter chart, you can select from the following subtypes.

  • Plain: Shows the relationships between numeric values in two or more series sets of XY values.
  • Connected: Plots points on the X and Y axes as one series and uses a line to connect points to each other.
  • Smoothly Connected: Plots points on the X and Y axes as one series and uses a line with the angles smoothed out to connect points to each other.
  • Bubble: Shows each series as a bubble. The y-axis values determine the height of the bubble, while the x-axis displays the category labels. This chart type is only accessible in Advanced chart types.

Line Charts

Line charts present each series as a point, and connect the points with a line. The y-axis values determine the heights of the points, while the x-axis displays the category labels. With a line chart, you can select from the following subtypes.

  • Plain: Compares trends over a period of time or in certain categories.
  • Smooth: Plots curves rather than angled lines through the data points in a series to compare trends over a period of time or in certain categories. Also known as a Bezier chart.

Dot Plot Charts

A Dot Plot chart is a statistical chart containing group of data points plotted on a simple scale. Dot Plot chart are used for continuous, quantitative, univariate data. The dot plot chart has one subtype.

Plain: Displays simple statistical plots. It is ideal for small to moderate sized data sets. You can also highlight clusters and gaps, as well as outliers, while conserving numerical information.

Advanced Chart Types

Area Charts

Area charts present each series as a point, connect the points with a line, and fill the area below the line. The y-axis values determine the heights of the points, while the x-axis displays the category labels. With an area chart, you can select from the following subtypes.

  • Plain: Compare trends over a period of time or in specific categories.
  • Stacked: An area chart with two or more data series stacked one on top of the other, shows how each value contributes to the total.
  • Percent Stacked: An area chart with two or more data series stacked one on top of the other to sum up to 100%, shows how each value contributes to the total with the relative size of each series representing its contribution to the total.

Pie Charts

Pie charts present each category as a slice of pie or doughnut, sized according to value. Series groups are not represented in pie charts. With a pie chart, you can select from the following subtypes.

  • Pie: Shows how the percentage of each data item contributes to the total.
  • Exploded: Shows how the percentage of each data item contributes to the total, with the pie slices pulled out from the center to show detail.
  • Doughnut: Shows how the percentage of each data item contributes to a total percentage.
  • Exploded Doughnut: Shows how the percentage of each data item contributes to the total, with the pie slices pulled out from the center to show detail.

Financial Charts

Stock charts present each series as a line with markers showing some combination of high, low, open, and close values. The y-axis values determine the heights of the lines, while the x-axis displays the category labels. With a financial chart, you can select from the following subtypes.

  • High Low Close: Displays stock information using High, Low, and Close values. High and low values are displayed using vertical lines, while tick marks on the right indicate closing values.
  • Open High Low Close: Displays stock information using Open, High, Low, and Close values. Opening values are displayed using lines to the left, while lines to the right indicate closing values. The high and low values determine the top and bottom points of the vertical lines.
  • Candlestick: Displays stock information using High, Low, Open and Close values. The height of the wick line is determined by the High and Low values, while the height of the bar is determined by the Open and Close values. The bar is displayed using different colors, depending on whether the price of the stock has gone up or down.
  • Renko: Bricks of uniform size chart price movement. When a price moves to a greater or lesser value than the preset BoxSize value required to draw a new brick, a new brick is drawn in the succeeding column. A change in box color and direction signifies a trend reversal.
  • Kagi: Displays supply and demand trends using a sequence of linked vertical lines. The thickness and direction of the lines vary depending on the price movement. If closing prices go in the direction of the previous Kagi line, then that Kagi line is extended. However, if the closing price reverses by the preset reversal amount, a new Kagi line is charted in the next column in the opposite direction. Thin lines indicate that the price breaks the previous low (supply) while thick lines indicate that the price breaks the previous high (demand).
  • Point and Figure: Stacked columns of Xs indicate that demand exceeds supply and columns of Os indicate that supply exceeds demand to define pricing trends. A new X or O is added to the chart if the price moves higher or lower than the BoxSize value you set. A new column is added when the price reverses to the level of the BoxSize value multiplied by the ReversalAmount you set. This calculation of pricing trends is best suited for long-term financial analysis.
  • Three Line Break: Vertical boxes or lines illustrate price changes of an asset or market. The price in a three line break graph must break the prior high or low set in the NewLineBreak property in order to reverse the direction of the graph.

Other Charts

Other chart types may be used for special functions like charting the progress of individual tasks. You can select from the following subtypes.

  • Funnel: Shows how the percentage of each data item contributes to the whole, with the largest value at the top and the smallest at the bottom. This chart type works best with relatively few data items.
  • Pyramid: Shows how the percentage of each data item contributes to the whole, with the smallest value at the top and the largest at the bottom. This chart type works best with relatively few data items.
  • Gantt: This project management tool charts the progress of individual project tasks. The chart compares project task completion to the task schedule.

Title

Chart title: Enter an expression or text to use for the title.

Font

Family: Choose the font family name.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

Color: Select a Web or custom color for the font.

Decoration: Choose from None, Underline, Overline, and LineThrough.

Palette

Default: The same as Subdued below, the recommended palette for charts.

EarthTones: A palette of autumnal browns, oranges, and greens.

Excel: A palette of muted plums, blues, and creams.

GrayScale: A palette of patterns suitable for printing to a black and white printer.

Light: A palette of pale pinks and peaches.

Pastel: A palette of blues, greens, and purples.

SemiTransparent: A palette of primary and tertiary colors that allows the backdrop to show through.

Subdued: A palette of muted tones of browns, greens, blues, and grays.

Vivid: The same as Subdued, but with richer tones.

Custom: A palette of colors that you define. When you select Custom, you can list colors that are used in the order you specify.

Area

Border

Style: Choose an enumerated style for the border.

Width: Set a width value in points between 0.25pt and 20pt.

Color: Select a Web or Custom color.

Background Fill Color

Fill Color: Select a Web or Custom color.

Gradient: Choose from one of the following gradient styles.

  • None: No gradient is used. The Fill Color is used to fill the area and the Gradient End Color property is ignored.
  • LeftRight: A gradient is used. The Fill Color property defines the color at the left, and the Gradient End Color property defines the color at the right. The two colors are gradually blended in between these areas.
  • TopBottom: A gradient is used. The Fill Color property defines the color at the top, and the Gradient End Color property defines the color at the bottom. The two colors are gradually blended in between these areas.
  • Center: A gradient is used. The Fill Color property defines the color at the center, and the Gradient End Color property defines the color at the edges. The two colors are gradually blended in between these areas.
  • DiagonalLeft: A gradient is used. The Fill Color property defines the color at the top left, and the Gradient End Color property defines the color at the bottom right. The two colors are gradually blended in between these areas.
  • DiagonalRight: A gradient is used. The Fill Color property defines the color at the top right, and the Gradient End Color property defines the color at the bottom left. The two colors are gradually blended in between these areas.
  • HorizontalCenter: A gradient is used. The Gradient End Color property defines the horizontal band of color across the center, and the Fill Color property defines the color at the top and bottom. The two colors are gradually blended in between these areas.
  • VerticalCenter: A gradient is used. The Gradient End Color property defines the vertical band of color across the center, and the Fill Color property defines the color at the left and right. The two colors are gradually blended in between these areas.

Gradient End Color: When you choose any gradient style other than None, this property becomes available. Choose a Web or Custom color.

Plot Area

Border

Style: Choose an enumerated style for the border.

Width: Choose a width value between 0.25pt and 20pt.

Color: Select a Web or Custom color.

Background Fill Color

Fill Color: Select a Web or Custom color.

Gradient: Choose from one of the following gradient styles.

  • None: No gradient is used. The Fill Color is used to fill the area and the Gradient End Color property is ignored.
  • LeftRight: A gradient is used. The Fill Color property defines the color at the left, and the Gradient End Color property defines the color at the right. The two colors are gradually blended in between these areas.
  • TopBottom: A gradient is used. The Fill Color property defines the color at the top, and the Gradient End Color property defines the color at the bottom. The two colors are gradually blended in between these areas.
  • Center: A gradient is used. The Fill Color property defines the color at the center, and the Gradient End Color property defines the color at the edges. The two colors are gradually blended in between these areas.
  • DiagonalLeft: A gradient is used. The Fill Color property defines the color at the top left, and the Gradient End Color property defines the color at the bottom right. The two colors are gradually blended in between these areas.
  • DiagonalRight: A gradient is used. The Fill Color property defines the color at the top right, and the Gradient End Color property defines the color at the bottom left. The two colors are gradually blended in between these areas.
  • HorizontalCenter: A gradient is used. The Gradient End Color property defines the horizontal band of color across the center, and the Fill Color property defines the color at the top and bottom. The two colors are gradually blended in between these areas.
  • VerticalCenter: A gradient is used. The Gradient End Color property defines the vertical band of color across the center, and the Fill Color property defines the color at the left and right. The two colors are gradually blended in between these areas.

Gradient End Color: When you choose any gradient style other than None, this property becomes available. Choose a Web or Custom color.

3D Effects

These properties are enabled when you select the 3D checkbox on the Gallery page.

Display the chart with 3D visual effects: Select this check box to enable all of the following properties.

Horizontal rotation: Move the slider to rotate the chart to left and right. All the way to the left (-90°) shows the chart from the left side, while all the way to the right (90°) shows it from the right side. The default value is 20°.

Vertical rotation: Move the slider to rotate the chart up and down. All the way to the left (-90°) shows the chart from the bottom, while all the way to the right (90°) shows it from the top. The default value is 20°.

Wall thickness: Move the slider to change the thickness of the walls at the axes. The default value is 0% and the range of values is 0% (left) to 100% (right). If the chart type is pie or doughnut, this property is ignored.

Perspective: Move the slider to change the perspective from which the chart is displayed. The default value is 0% and the range of values is 0% (left) to 100% (right). If you select Orthographic Projection, this property is ignored.

Shading: Select the type of shading to apply to the chart. The default value is Real.

  • None: Colors are uniform.
  • Simple: Colors are darkened in areas where the light source does not hit them.
  • Real: Colors are darkened in areas where the light source does not hit them, and lightened in areas where the light source is strongest.

Orthographic Projection: Select this check box to use orthographic or "true drawing" projection. This type of projection is ignored with pie and doughnut chart types.

Clustered: With chart types of bar and column, select this check box to cluster series groups. Other chart types ignore this setting.

Display bars as cylinders: With chart types of bar and column, select this check box to display cylinders instead of bars or columns.

Defaults (button): Click this button when you want to set all of the 3D effect properties back to their default values.

Chart Data

See the Chart Data Dialog topic for all of the pages and tabs available for customizing your chart data.

Chart Legend

To open the Chart Legend dialog, select the Chart on the report, and below the Properties window, click the Chart legend command. This dialog has the following pages.

General

Show chart legend: Clear this check box to disable the legend. This also disables all of the other properties on this page.

Use Smart Settings: Check this option to apply smart settings or clear this checkbox to activate the properties given below.

Layout: Choose the layout style for the legend.

  • Column: This option displays legend items in a single vertical column.
  • Row: This option displays legend items in a single horizontal row.
  • Table: This option displays legend items in a table of vertical columns, and is best when you have a large number of values.

Position: Select an enumerated value to determine the position of the legend relative to the chart area. The default value is RightCenter.

Display legend inside plot area: Select this check box to display the legend inside the plot area along with your data elements.

Style

The Style page of the Chart Legend dialog allows you to control the Font, Border, and Fill properties for the legend.

Font

Family: Choose the font family name.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

Color: Select a Web or custom color for the font.

Decoration: Choose from None, Underline, Overline, and LineThrough.

Border

Style: Choose an enumerated style for the border.

Width: Enter a width value between 0.25pt and 20pt.

Color: Select a Web or Custom color.

Background Fill Color

Fill Color: Select a Web or Custom color.

Gradient: Choose from one of the following gradient styles.

  • None: No gradient is used. The Fill Color is used to fill the area and the Gradient End Color property is ignored.
  • LeftRight: A gradient is used. The Fill Color property defines the color at the left, and the Gradient End Color property defines the color at the right. The two colors are gradually blended in between these areas.
  • TopBottom: A gradient is used. The Fill Color property defines the color at the top, and the Gradient End Color property defines the color at the bottom. The two colors are gradually blended in between these areas.
  • Center: A gradient is used. The Fill Color property defines the color at the center, and the Gradient End Color property defines the color at the edges. The two colors are gradually blended in between these areas.
  • DiagonalLeft: A gradient is used. The Fill Color property defines the color at the top left, and the Gradient End Color property defines the color at the bottom right. The two colors are gradually blended in between these areas.
  • DiagonalRight: A gradient is used. The Fill Color property defines the color at the top right, and the Gradient End Color property defines the color at the bottom left. The two colors are gradually blended in between these areas.
  • HorizontalCenter: A gradient is used. The Gradient End Color property defines the horizontal band of color across the center, and the Fill Color property defines the color at the top and bottom. The two colors are gradually blended in between these areas.
  • VerticalCenter: A gradient is used. The Gradient End Color property defines the vertical band of color across the center, and the Fill Color property defines the color at the left and right. The two colors are gradually blended in between these areas.

Gradient End Color: When you choose any gradient style other than None, this property becomes available. Choose a Web or Custom color.

Chart Axis

Click the Axis X or Axis Y line of the chart to select AxisXLine or AxisYLine, then under the Properties Window, click Property dialog. The Chart Axis dialogs let you set axis properties on the data region with the following pages.

Note: The X and Y Axis dialogs are disabled if your chart type is doughnut or pie.

Title

Axis X or Axis Y

X- or Y-Axis title: Enter text to display near the X or Y axis of the chart.

Text alignment: Choose Center, Near, or Far.

Font

Family: Choose the font family name.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

Color: Select a Web or custom color for the font.

Decoration: Choose from None, Underline, Overline, and LineThrough.

Line Style

Axis Line Appearance

Style: Choose from an enumerated style for the axis line.

Color: Select a Web or Custom color.

End Cap: Choose either None or Arrow as the End Cap style, or enter an expression using Expression Editor dialog.

Labels

Show x- or y-axis labels: Select this check box to show labels along the axis and to enable the rest of the properties on this page.

Format code: Select a format code from the list or use a custom .NET formatting code to format dates or numbers. For more information, see MSDN's Formatting Types topic.

Font

Family: Choose the font family name.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

Color: Select a Web or custom color for the font.

Decoration: Choose from None, Underline, Overline, and LineThrough.

Major Grid Lines

Show major grid lines: Select this check box to show grid lines for the axis.

Interval: Set the interval at which you want to show major grid lines or tick marks or both.

Border

Style: Choose one from the enumerated styles for the border.

Width: Enter a width value between 0.25pt and 20pt.

Color: Select a color for the border.

Tick mark: Choose one of the following values to determine whether and where to display major tick marks. The style and interval of the tick marks are set with the above properties.

  • None: No tick mark is displayed.
  • Inside: Tick marks are displayed inside the axis.
  • Outside: Tick marks are displayed outside the axis.
  • Cross: Tick marks are displayed crossing the axis.

Minor Grid Lines

Show minor grid lines: Select this check box to show minor grid lines for the axis.

Interval: Set the interval at which you want to show minor grid lines or tick marks or both.

Border

Style: Choose one from the enumerated styles for the border.

Width: Enter a width value between 0.25pt and 20pt.

Color: Select a color for the border.

Tick mark: Choose one of the following values to determine whether and where to display minor tick marks. The style and interval of the tick marks are set with the above properties.

  • None: No tick mark is displayed.
  • Inside: Tick marks are displayed inside the axis.
  • Outside: Tick marks are displayed outside the axis.
  • Cross: Tick marks are displayed crossing the axis.

Scale

Minimum: Leave this value blank to allow the data to determine the minimum value to use.

Maximum: Leave this value blank to allow the data to determine the maximum value to use.

Logarithmic scale: Select this check box to display axis data as a percentage of change instead of as absolute arithmetic values.

Numeric or time scale values: Select this check box to indicate that the data on the X axis is scalar so that the chart fills in missing numbers or dates between data values. This property is only available on the X axis.

Other

Cross at: Leave this value blank to allow the chart type to determine where the axis should cross the other axis, or you can enter a custom value.

Side margins: Select this check box to add padding between the data and the edges of the chart.

Interlaced strips: Select this check box to display alternating light and dark strips between major intervals specified on the Major Grid Lines page. If none are specified, a default value of 1 is used.

Reversed: Select this check box to reverse the direction of the chart. This will have different effects depending on chart type.

Reference Line (Y Axis only)

Value: Enter a value.

Line/Border

Style: Choose one from the enumerated styles.

Width: Set a width of the axis line.

Color: Select a color for the axis line.

Legend Label: Enter a label for the legend to display in the viewer.

See Also
ChartControl


Chart Data Dialog

Chart Data Dialog
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Chart > Chart Data Dialog
Show All Show All
Hide All Hide All

When you first open the Chart Data dialog, you can select a Dataset name to associate with the chart. The list is populated with all of the datasets in the report's dataset collection.

This dialog also gives you access to the following related pages.

General Page

Name: Enter a name for the chart that is unique within the report. This name is displayed in the Document Outline and in XML exports.

Tooltip: Enter the value or expression you want to appear when a user hovers the cursor over the chart in the viewer at run time.

Dataset Name: Select a dataset to associate with the chart. The combo box is populated with all of the datasets in the report's dataset collection.

Series Values Page

Add at least one Value series to determine the size of the chart element. Click the plus sign button to enable the General tab. Once you have one or more value series in place, you can use the arrow buttons to change the order or the X button to delete them.

Another way to add Chart Series Values is to drag fields from the Report Explorer onto the tray along the top edge of the chart that reads Drop data fields here.

If you have already added values, you can right-click any value displayed in the UI along the top of the chart and choose Edit to open this dialog.

The Series Values page has the following tabs.

General

The General tab of the Series Values page allows you to control different items depending on the Chart Type you have chosen.

All Chart Types

Series label: Enter an expression to use as a series label to display in the legend.

Scatter or Bubble Chart Types

X: Enter an expression to use as an X value.

Y: Enter an expression to use as a Y value.

Size: If the chart type is bubble, enter an expression to use as the bubble size value.

Stock Chart Type

High: Enter an expression to use as the high value.

Low: Enter an expression to use as the low value.

Open: Enter an expression to use as the open value.

Close: Enter an expression to use as the close value.

Column, Bar, Line, Pie, Area, or Doughnut Chart Types

Value: Enter an expression to use as a series value.

Styles

Line/Border

These properties control the appearance of the border of bars or columns, or the lines, depending on the type of chart.

Style: Choose one of the enumerated styles for the lines.

Width: Choose a width value between 0.25pt and 20pt for the thickness of the lines.

Color: Choose a Web or Custom color to use for the lines.

Background Fill Color

These properties control the appearance of the background of the series values.

Fill Color: Choose a Web or Custom color to fill the background.

Gradient: Choose from one of the following gradient styles.

  • None: No gradient is used. A single color (defined by the Fill Color property above) is used to fill the area and the Gradient End Color property remains disabled.
  • LeftRight: A gradient is used. The Fill Color property defines the color at the left, and the Gradient End Color property defines the color at the right. The two colors are gradually blended in between these areas.
  • TopBottom: A gradient is used. The Fill Color property defines the color at the top, and the Gradient End Color property defines the color at the bottom. The two colors are gradually blended in between these areas.
  • Center: A gradient is used. The Fill Color property defines the color at the center, and the Gradient End Color property defines the color at the edges. The two colors are gradually blended in between these areas.
  • DiagonalLeft: A gradient is used. The Fill Color property defines the color at the top left, and the Gradient End Color property defines the color at the bottom right. The two colors are gradually blended in between these areas.
  • DiagonalRight: A gradient is used. The Fill Color property defines the color at the top right, and the Gradient End Color property defines the color at the bottom left. The two colors are gradually blended in between these areas.
  • HorizontalCenter: A gradient is used. The Gradient End Color property defines the horizontal band of color across the center, and the Fill Color property defines the color at the top and bottom. The two colors are gradually blended in between these areas.
  • VerticalCenter: A gradient is used. The Gradient End Color property defines the vertical band of color across the center, and the Fill Color property defines the color at the left and right. The two colors are gradually blended in between these areas.

Gradient End Color: When you choose any gradient style other than None, this property becomes available. Choose a Web or Custom color to blend with the Fill Color in the background of the series.

Markers

Marker type: Choose one of the following values to determine the shape of the marker or whether one is displayed.

  • None - Markers are not used. (Default)
  • Square - Markers are square.
  • Circle - Markers are circular.
  • Diamond - Markers are diamond shaped.
  • Triangle - Markers are triangular.
  • Cross - Markers are cross shaped.
  • Auto - A shape is chosen automatically.

Marker size: Enter a value between 2pt and 10pt to determine the size of the plotting area of the markers.

Plot data as secondary: If the chart type is column, you can select this check box and select whether to use a Line or Points to show the data.

Labels

Show point labels: Select this check box to display a label for each chart value. Selecting this box enables the disabled properties on this page.

Data label: Enter a value to use as the label, or select <Expression...> to open the Expression Editor.

Format code: Select one of the provided format codes or use a custom .NET formatting code to format dates or numbers. For more information, see MSDN's Formatting Types topic.

Position: Leave Auto selected to use the default point label position for the chart type, or select an enumerated value to position the labels.

Angle: Enter the value in tenths of degrees to use for the angle of the point label text. The default (0°) position denotes no angle and renders regular horizontal text.

Font

Family: Choose the font family name.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

Color: Select a Web or custom color for the font.

Decoration: Choose from None, Underline, Overline, and LineThrough.

Action

Choose from the following actions to perform when the user clicks on the chart element.

None: The default behavior is to do nothing when a user clicks the chart element at run time.

Jump to report: For drill-through reporting, select this option and provide the name of a local report, the relative path of a report in another folder, or the full path of a report on another server.

Parameters

  • Name: Supply the exact names of any parameters required for the targeted report. Note that parameter names you supply in this must match parameters in the target report.
    Important: The Parameter Name must exactly match the name of the parameter in the detail report. If any parameter is spelled differently, capitalized differently, or if an expected parameter is not supplied, the drill-through report will fail.
  • Value: Enter a Parameter Value to pass to the detail report. This value must evaluate to a valid value for the parameter.
  • Omit: Select this check box to omit this parameter from the report.

Jump to bookmark: Select this option and provide a valid Bookmark ID to allow the user to jump to the report control with that Bookmark ID.

Jump to URL: Select this option and provide a valid URL to create a hyperlink to a Web page.

Data Output

Element name: Enter a name to be used in the XML output for this chart element.

Output: Choose Yes or No to decide whether to include this chart element in the XML output.

Category Groups Page

Add Category Groups to group data and provide labels for the chart elements. Click the Add button to enable the General tab. Once you have one or more category groups in place, you can use the arrow buttons to change the order or the X button to delete them.

Another way to add Category Groups is to drag fields from the Report Explorer onto the tray along the bottom edge of the chart that reads Drop category fields here.

If you have already added values, you can right-click the value displayed in the UI along the bottom of the chart and choose Edit to open this dialog.

The Category Groups page has the following tabs.

General

Name: Enter a name for the group that is unique within the report. This name can be called in code.

Group on: Enter an expression to use for grouping the data.

Label: Enter an expression to use as a label for the group. You can select <Expression...> to open the Expression Editor.

Parent group: For use in recursive hierarchies. Enter an expression to use as the parent group.

Filters

The Filters tab of Category Groups page allows you to control the Filter grid collection for the group. Use the arrow and X buttons to move or delete filters. You need to provide three values to add a new filter to the collection.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right:

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Sorting

The Sorting tab of Category Groups page allows you to enter new sort expressions and remove or change the order of them using the X or arrow buttons. For each sort expression in this list, you can also choose the direction.

Expression: Enter an expression by which to sort the data in the group.

Direction: Select whether you want to sort the data in an Ascending or Descending direction.

Data Output

Element name: Enter a name to be used in the XML output for this group.

Collection: Enter a name to be used in the XML output for the collection of all instances of this group.

Output: Choose Yes or No to decide whether to include this group in the XML output.

Series Groups Page

Optionally add Series Groups for extra levels of data (for example, Orders by Country can be broken down by year as well). Labels for the series are displayed in the chart legend. Click the Add button to open the General page. Once you have one or more series groups in place, you can use the arrow buttons to change the order or the X button to delete them.

Another way to add Series Groups is to drag fields from the Report Explorer onto the tray along the right edge of the chart that reads Optionally drop series fields here.

If you have already added values, you can right-click the value displayed in the UI along the right edge of the chart and choose Edit to open this dialog.

The Series Groups page has the following tabs.

General

Name: Enter a name for the group that is unique within the report. This name can be called in code.

Group on: Enter an expression to use for grouping the data.

Label: Enter an expression to use as a label for the group. You can select <Expression...> to open the Expression Editor.

Parent group: For use in recursive hierarchies. Enter an expression to use as the parent group.

Filters

The Filters tab of Series Groups page allows you to control the Filter grid collection for the group. Use the arrow and X buttons to move or delete filters. You need to provide three values to add a new filter to the collection.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right:

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Sorting

The Sorting tab of Series Groups page allows you to enter new sort expressions and remove or change the order of them using the X or arrow buttons. For each sort expression in this list, you can also choose the direction.

Expression: Enter an expression by which to sort the data in the group.

Direction: Select whether you want to sort the data in an Ascending or Descending direction.

Data Output

Element name: Enter a name to be used in the XML output for this group.

Collection: Enter a name to be used in the XML output for the collection of all instances of this group.

Output: Choose Yes or No to decide whether to include this group in the XML output.

Filters Page

Chart Data Filters Page

The Filters page of the Chart Data dialog allows you to filter the data that is included in the chart. Use the plus sign button to add a filter, and the arrow and X buttons to move or delete filters. You need to provide three values to add a new filter to the collection.

Expression: Enter the expression to use for evaluating whether data should be included in the chart.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right:

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values (used with the In and Between operators) separate values using commas.

Data Output Page

Chart Data Output Page

Element name: Enter a name to be used in the XML output for the chart.

Output: Choose one between Auto, Yes, No or Contents Only to decide whether to include this group in the XML output.

See Also

Concepts

Chart


CheckBox (Page Report)

CheckBox (Page Report)
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > CheckBox (Page Report)
Show All Show All
Hide All Hide All

In ActiveReports, you can use the CheckBox control to represent a Boolean value in a report. By default, it appears as a small box with text to the right. If the value evaluates to True, the small box appears with a check mark; if False, the box is empty. By default, the checkbox is empty.

Checkbox Dialog

Properties for the CheckBox are available in the Checkbox dialog. To open it, with the CheckBox control selected on the report, under the Properties Window, click the Property dialog link.

The Checkbox dialog lets you set properties on the report control with the following pages.

Note: You can select the <Expression...> option in many of these properties to create an expression to determine the value. For properties with enumerated values, the values are listed under Constants in the Fields tree view on the left side of the Expression Editor.

General

Name: Enter a name for the checkbox that is unique within the report. This name is displayed in the Document Outline and in XML exports.

Tooltip: Enter the value or expression you want to appear when a user hovers the cursor over the checkbox in the viewer at run time.

Value: Enter an expression or a static label, or choose a field expression from the drop-down list. You can access the expression editor by selecting <Expression...> in the list. The value of this expression or text is displayed in the report to the right of the checkbox.

Visibility

Initial visibility

  • Visible - The checkbox is visible when the report runs.
  • Hidden - The checkbox is hidden when the report runs.
  • Expression - Use an expression with a Boolean result to decide whether the checkbox is visible. For example, on a "Free Shipping" checkbox, you could use the expression to see whether the ShippingCountry is international. A value of true hides the checkbox, false shows it.

Visibility can be toggled by another report control: Select this checkbox to specify a report control to use as a toggle to show or hide the checkbox. Then specify the TextBox control to display with a toggle image button. When the user clicks the TextBox control, the checkbox changes between visible and hidden.

Appearance

Border

Style: Select a style for the border.

Width: Enter a value in points to set the width of the border.

Color: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Background

Color: Select a color to use for the background of the checkbox.

Image: Enter an image to use for the background of the checkbox.

Font

Family: Select a font family name or a theme font.

Size: Choose the size in points for the font or use a theme.

Style: Choose Normal or Italic or select a theme.

Weight: Choose an enumerated weight value or select a theme.

Color: Choose a color to use for the text.

Decoration: Choose from None, Underline, Overline, or LineThrough.

Format

Format code: Select one of the common numeric formats provided or use a custom .NET formatting code to format dates or numbers. For more information, see MSDN's Formatting Types topic.

Line Spacing: This property sets the space between lines of text.

Line height: This property sets the height of each line of text.

Note: This property only affects HTML output.

Character Spacing: This property sets the space between characters of text.

Text direction and writing mode

Direction: Choose LTR for left to right, or RTL for right to left.

Mode: Choose lr-tb for left right top bottom (normal horizontal text) or tb-rl for top bottom right left (vertical text on its side).

Alignment

Alignment

Vertical alignment: Choose Top, Middle, Bottom, or the <Expression...> option.

Horizontal alignment: Choose General, Left, Center, Right, Justify, or the <Expression...> option.

Justification method: Choose Auto, Distribute, DistributAllLines, or the <Expression...> option.

Wrap mode: Choose NoWrap, WordWrap, or CharWrap.

Note: You must select Justify in the Horizontal alignment property to enable the Justification method property options.

Amount of space to leave around report control

  • Top padding: Set the top padding in points.
  • Left padding: Set the left padding in points.
  • Right padding: Set the right padding in points.
  • Bottom padding: Set the bottom padding in points.

Data Output

Element Name: Enter a name to be used in the XML output for this checkbox.

Output: Choose Auto, Yes, or No to decide whether to include this checkbox in the XML output. Auto exports the contents of the checkbox only when the value is not a constant.

Render as: Choose Auto, Element, or Attribute to decide whether to render checkboxes as Attributes or Elements in the exported XML file. Auto uses the report's setting for this property.

Attribute example: <table1 checkbox3="Report created on: 7/26/2005 1:13:00 PM">

Element example: <table1> <checkbox3>Report created on: 7/26/2005 1:13:28 PM</checkbox3>

See Also
CheckBox (Section Report)


Container

Container
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Container
Show All Show All
Hide All Hide All

The Container report control is a container for other items. There are a number of ways in which you can use it to enhance your reports.

Visual Groupings

You can place report controls within the Container to group them visually, and to make it easier at design time to move a group of report controls.

Note: Drawing a container around existing items does not contain them. Instead you must drag the items into the container.

You can use a container as a border for your report pages, and set border properties to create purely visual effects within your report, and even display an image behind a group of report controls by setting the BackgroundImage property of the Container.

Anchoring Items

Probably the best usage of the Container report control is to anchor report controls which may otherwise be pushed down by a vertically expanding data region. For example, if you have a group of textboxes below a table with some of them to the left or right, any of them directly below the table are pushed down below the expanded table at run time, while the upper textboxes remain where you placed them at design time. To prevent this from happening, place the group of textboxes within a container.

Container Dialog

Properties for the Container are available in the Container dialog. To open it, with the Container control selected on the report, under the Properties Window, click the Property dialog link.

The Container dialog lets you set properties on the report control with the following pages.

Note: You can select the <Expression...> option in many of these properties to create an expression to determine the value. For properties with enumerated values, the values are listed under Constants in the Fields tree view on the left side of the Expression Editor.

General

Name: Enter a name for the container that is unique within the report. This name can be called in code.

Page breaks:

  • Insert a page break before this container: Insert a page break before the container.
  • Insert a page break after this container: Insert a page break after the container.

Appearance

Background

Color: Select a color to use for the background of the container.

Image: Enter an image to use for the background of the container.

Border

Style: Select a style for the border.

Width: Enter a value in points to set the width of the border.

Color: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Rounded Rectangle: Specify the radius for each corner of the shape independently. Drag the handlers [image] available at each corner of the shape to set the value of the radius at each corner.

Note: To enable specific corners, check the CheckBox available near each corner of the Container control.

Visibility

Initial visibility

  • Visible: The container is visible when the report runs.
  • Hidden: The container is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the container is visible. True for hidden, False for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the container. The user can click the toggle item to show or hide this container.

Navigation

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this container. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Data Output

The Data Output page of the Container dialog allows you to control the following properties when you export to XML:

  • Element name: Enter a name to be used in the XML output for this container.
  • Output: Choose Auto, Yes, No, or Contents only to decide whether to include the contents of this container in the XML output. Choosing Auto exports the contents of the container only when the value is not a constant.
See Also
Exploring Page and RDL Reports
Shape


FormattedText

FormattedText
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > FormattedText
Show All Show All
Hide All Hide All

The FormattedText report control can perform mail merge operations, plus it displays richly formatted text in XHTML. To format text in the FormattedText report control, enter XHTML code into the Html property.

Supported XHTML Tags

If you use valid HTML tags that are not in this list, ActiveReports ignores them.

Important: All text used in the Html property must be enclosed in <body></body> tags.
Tag | Description
<%MergeFieldName%> | Inserts a mail merge field.
<!-- -- > | Defines a comment
<!DOCTYPE> | Defines the document type
<a> | Defines an anchor
<abbr> | Defines an abbreviation
<acronym> | Defines an acronym
<address> | Defines an address element
<b> | Defines bold text
<base /> | Defines a base URL for all the links in a page
<bdo> | Defines the direction of text display
<big> | Defines big text
<blockquote> | Defines a long quotation
<body> | Defines the body element (Required)
<br /> | Inserts a single line break
<caption> | Defines a table caption
<center> | Defines centered text
<cite> | Defines a citation
<code> | Defines computer code text
<col> | Defines attributes for table columns
<dd> | Defines a definition description
<del> | Defines deleted text
<dir> | Defines a directory list
<div> | Defines a section in a document
<dfn> | Defines a definition term
<dl> | Defines a definition list
<dt> | Defines a definition term
<em> | Defines emphasized text
<h1> to <h6> | Defines header 1 to header 6
<head> | Defines information about the document
<hr /> | Defines a horizontal rule
<html> | Defines an html document
<i> | Defines italic text
<img /> | Defines an image
<ins> | Defines inserted text
<kbd> | Defines keyboard text
<li> | Defines a list item
<map> | Defines an image map
<menu> | Defines a menu list
<ol> | Defines an ordered list
<p> | Defines a paragraph
<pre> | Defines preformatted text
<q> | Defines a short quotation
<s> | Defines strikethrough text
<samp> | Defines sample computer code
<small> | Defines small text
<span> | Defines a section in a document
<strike> | Defines strikethrough text
<strong> | Defines strong text
<style> | Defines a style definition
<sub> | Defines subscripted text
<sup> | Defines superscripted text
<table> | Defines a table
<tbody> | Defines a table body
<td> | Defines a table cell
<tfoot> | Defines a table footer
<th> | Defines a table header
<thead> | Defines a table header
<tr> | Defines a table row
<tt> | Defines teletype text
<u> | Defines underlined text
<ul> | Defines an unordered list
Caution: To enter & in the HTML property, you need to use &amp;.

Formatted Text Dialog

Properties for the FormattedText report control are available in the Formatted Text dialog. To open it, with the control selected on the report, under the Properties Window, click the Property dialog link.

The Formatted Text dialog lets you set properties on the report control with the following page.

General

Name: Enter a name for the FormattedText that is unique within the report. This name can be called in code.

Tooltip: Enter the value or expression you want to appear when a user hovers the cursor over the FormattedText in the viewer at run time.

Visibility

Initial visibility

  • Visible: The FormattedText is visible when the report runs.
  • Hidden: The FormattedText is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the FormattedText is visible. True for hidden, false for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the FormattedText. The user can click the toggle item to show or hide this FormattedText.

Navigation

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this FormattedText. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Appearance

Background

Color: Select a color to use for the background of the FormattedText.

Image: Enter an image to use for the background of the FormattedText.

Border

Style: Select a style for the border.

Width: Enter a value in points to set the width of the border.

Color: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Data Output

Element name: Enter a name to be used in the XML output for this FormattedText report control.

Output: Choose Auto, Yes, No, Contents Only to decide whether to include this FormattedText in the XML output. Choosing Auto exports the contents of the FormattedText report control.

Mail Merge

Click the plus sign button to add a new mail merge field to the FormattedText, and delete them using the X button. Once you add one or more fields, you can reorder them using the arrow buttons.

Field: Enter a name for the field that is unique within the report. This is used in the Html property inside <%FieldName%> tags to display the field in the formatted text.

Value: Enter an expression to pull data into the control for mail merge operations.

Here is a very simple example of HTML code that you can use to add mail merge fields to formatted text. This example assumes that you have added two mail merge fields named Field1 and Field2.

Paste this code in the Html property of the FormattedText control.
Copy Code
<body><p>This is <%Field1/%> and this is <%Field2/%>.</p></body>
See Also
RichTextBox


Image

Image
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Image
Show All Show All
Hide All Hide All

The Image report control displays an image that you embed in a report, add to a Visual Studio project, store in a database, access through a URL or access in ActiveReports Server. You can choose an Image Source in the Properties window after you place the Image report control on a report. For more information, see Working with Images.

Image Dialog

Properties for the Image are available in the Image dialog. To open it, with the Image control selected on the report, under the Properties Window, click the Property dialog link.

The Image dialog lets you set properties on the report control with the following pages.

Note: You can select <Expression...> within many of these properties to open the Expression Editor.

General

Name: Enter a name for the image that is unique within the report. This name can be called in code.

Tooltip: Enter a string or expression that you want to appear when a user hovers the cursor over the image in the viewer at run time.

Image Value: Enter the name of the image to display. Depending on the Image Source chosen below, you can give a path to the image, select an image to embed, pull images from a database, or access shared images stored on ActiveReports Server.
This property also allows you to choose the <Data Visualizer...> option to launch a dialog that will let you build a data visualization expression.

Image Source: Select whether the image comes from a source that is External, Embedded, or Database.

MIME Type: Select the MIME type of the image chosen.

Visibility

Initial visibility

  • Visible: The image is visible when the report runs.
  • Hidden: The image is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the image is visible. True for hidden, False for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the image. The user can click the toggle item to show or hide this image.

Navigation

Action

Select one of the following actions to perform when a user clicks on this image.

None: The default behavior is to do nothing when a user clicks the image at run time.

Jump to report: For drill-through reporting, select this option and provide the name of a local report, the relative path of a report in another folder, or the full path of a report on another server.

Parameters: Supply parameters to the targeted report by entering the Name of each parameter, the Value to send to the targeted report, or whether to Omit the parameter. Note that parameter names you supply must exactly match parameters in the target report.

Tip: You can remove or change the order of parameters using the X and arrow buttons.

Jump to bookmark: Select this option and provide a valid Bookmark ID to allow the user to jump to the report control with that Bookmark ID.

Jump to URL: Select this option and provide a valid URL to create a hyperlink to a Web page.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this image. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

See Also
Picture
Working with Images


Line

Line
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Line
Show All Show All
Hide All Hide All

The Line report control can be used to visually separate data regions in a report layout. You can set properties in the Properties grid or the Line Dialog to control the appearance of the line, and to control when the line is rendered.

Line Dialog

Properties for the Line are available in the Line dialog. To open it, with the Line control selected on the report, under the Properties Window, click the Property dialog link.

The Line dialog lets you set properties on the report control with the following pages.

General

Name: Enter a name for the line that is unique within the report. This name can be called in code.

Visibility

The Visibility page of the Line dialog allows you to control the following items:

Initial visibility

  • Visible: The line is visible when the report runs.
  • Hidden: The line is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the line is visible. True for hidden, False for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the line. The user can click the toggle item to show or hide this line.

Navigation

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this line. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

See Also
Line (Section Report)


List

List
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > List
Show All Show All
Hide All Hide All

The List data region repeats any report controls it contains for every record in the dataset. Unlike other data regions, the List is free-form, so you can arrange report controls in any configuration you like.

Grouping in the list is done on the details group.

List Dialog

Properties for the List are available in the List dialog. To open it, with the List control selected on the report, under the Properties Window, click the Property dialog link.

The List dialog lets you set properties on the report control with the following pages.

Note: You can select <Expression...> within these properties to create an expression to determine the value.

General

Name: Enter a name for the list that is unique within the report. This name can be called in code.

Tooltip: Enter the value or expression you want to appear when a user hovers the cursor over the list in the viewer at run time.

Dataset name: Select a dataset to associate with the list. The drop-down list is populated with all of the datasets in the report's dataset collection.

Has own page numbering: Select to indicate whether this List is in its own section with regards to pagination.

Page Breaks: Select any of the following options to apply to each instance of the list.

  • Insert a page break before this list
  • Insert a page break after this list
  • Fit list on a single page if possible

Detail Grouping

Detail grouping is useful when you do not want to repeat values within the details. When a detail grouping is set, the value repeats for each distinct result of the grouping expression instead of for each row of data. For example, if you use the Customers table of the NorthWind database to create a list of countries without setting the details grouping, each country is listed as many times as there are customers in that country. If you set the details grouping to =Fields!Country.Value each country is listed only once.

Note: If the detail grouping expression you use results in a value that is distinct for every row of data, a customer number for example, you will see no difference in the results.

The Detail Grouping page of the List dialog has the following tabs.

General

Name: Enter a name for the group that is unique within the report. This property cannot be set until after a Group on expression is supplied.

Group on: Enter an expression to use for grouping the data.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Parent group: For use in recursive hierarchies. Enter an expression to use as the parent group.

Filters

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Sorting

Click the plus sign button to enter new sort expressions, and remove them using the X button.

In the Expression box, enter an expression by which to sort the data in the group, and under Direction, select Ascending or Descending for the selected sort expression.

Data Output

Element name: Enter a name to be used in the XML output for this group.

Collection: Enter a name to be used in the XML output for the collection of all instances of this group.

Output: Choose Yes or No to decide whether to include this group in the XML output.

Layout

Page break at start: Inserts a page break before the group.

Page break at end: Inserts a page break after the group.

Has own page numbering: Used in conjunction with the "Page Number in Section" and "Total Pages in Section" properties, tells the report that the group constitutes a new page numbering section.

Visibility

Initial visibility

  • Visible: The list is visible when the report runs.
  • Hidden: The list is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the list is visible. True for hidden, false for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the list. The user can click the toggle item to show or hide this list.

Navigation

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this list. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Filters

The Filters page of the List dialog allows you to control the Filter collection for the list. You can also access the Filters collection by clicking the ellipsis (...) button next to the Filters property in the property grid. Use the plus sign button to add a filter, and the arrow and X buttons to move or delete filters. You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Sorting

Click the plus sign button to enter new sort expressions, and remove them using the X button.

In the Expression box, enter an expression by which to sort the data in the group, and under Direction, select Ascending or Descending for the selected sort expression.

Data Output

Element name: Enter a name to be used in the XML output for this list.

Output: Choose Auto, Yes, or No to decide whether to include this List in the XML output. Choosing Auto exports the contents of the list.

Instance element name: Enter a name to be used in the XML output for the data element for instances of the list. This name is ignored if you have specified a detail grouping.

Instance element output: Choose Yes or No to decide whether to include the instances of the list in the XML output. This is ignored if you have specified a detail grouping.

See Also
Grouping Data (Page Layout)
Grouping Data in Section Reports


Map

Map
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Map
Show All Show All
Hide All Hide All

The Map data region is a professional edition feature that shows your business data against a geographical background. You can create different types of map, depending on the type of information you want to communicate in your report.

The Map data region consists of the following basic elements:

Title

Map Title describes the theme or subject of the map. The purpose of map title is to tell the viewer of what he is looking at. You can add multiple titles to the Map using the MapTitleDesigner Collection Editor.

For more information, see Create a Map.

Viewport

Viewport refers to the area on the map where data is displayed against a geographical background. It specifies the coordinates, projection system, parallels and meridians, center point, and scale of the map. In other words, it is a map element that actually displays geographical data and occupies most area of the map control depending on the location and dock position of other map elements. For more information, see Create a Map.

The Map Viewport dialog lets you set properties with the following pages.

General

Coordinate system: Specify the coordinate system of the viewport. Select from Planar, Geographic, or select the <Expression...> option to open the Expression Editor and create an expression.

Projection: Specify the projection of the map. Tile layers must use the Mercator projection.

Minimum X: Specify the minimum X coordinate of the map in degrees.

Maximum X: Specify the maximum X coordinate of the map in degrees.

Minimum Y: Specify the minimum Y coordinate of the map in degrees.

Maximum Y: Specify the maximum Y coordinate of the map in degrees.

Projection Center X: Specify the X coordinate of the projection center in degrees.

Projection Center Y: Specify the Y coordinate of the projection center in degrees.

Minimum zoom: Specify the minimum zoom value.

Maximum zoom: Specify the maximum zoom value.

Map resolution: Enables the viewport to simplify vector data for polygon and line layers.

Show grid lines below the map: Specify whether to show the grid lines above or below the content of the map.

Meridians

Hide meridians: Specify whether to hide meridians.

Interval: Specify the spacing between the grid lines in degrees.

Line

  • Style: Choose from None, Dotted, Dashed, Solid, Double, Groove, Ridge, Inset, WindowInset, Outset, or select the <Expression...> option to open the Expression Editor and create an expression.
  • Width: Specify the width of the line.
  • Color: Select a Web or custom color for the line.

Show labels: Specify whether to show labels for meridians on the map.

Format: Specify the format string to display numeric labels.

Position: Specify the position of the meridians on the map.

Font

  • Family: Choose the font family name.
  • Size: Choose the size in points for the font.
  • Style: Choose Normal or Italic.
  • Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.
  • Color: Select a Web or custom color for the font.
  • Decoration: Choose from None, Underline, Overline, LineThrough, or select the <Expression...> option to open the Expression Editor and create an expression.

Parallels

Hide parallels: Specify whether to hide parallels.

Interval: Specify the spacing between the grid lines in degrees.

Line

  • Style: Choose from None, Dotted, Dashed, Solid, Double, Groove, Ridge, Inset, WindowInset, Outset, or select the <Expression...> option to open the Expression Editor and create an expression.
  • Width: Specify the width of the line.
  • Color: Select a Web or custom color for the line.

Show labels: Specify whether to show labels for parallels on the map.

Format: Specify the format string to display numeric labels.

Position: Specify the position of the parallels on the map.

Font

  • Family: Choose the font family name.
  • Size: Choose the size in points for the font.
  • Style: Choose Normal or Italic.
  • Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.
  • Color: Select a Web or custom color for the font.
  • Decoration: Choose from None, Underline, Overline, LineThrough, or select the <Expression...> option to open the Expression Editor and create an expression.

View

Center and zoom: Specify how the map viewport zooms and centers during the report processing.

  • Custom
  • Center map to show a map element
  • Center map to show a map layer
  • Center map to show all map elements

View Center X: Specify the X coordinate of the current view center.

View Center Y: Specify the Y coordinate of the current view center.

Zoom level: Specify the zoom level of the map view.

Appearance

Border

  • Style: Choose an enumerated style for the border.
  • Width: Set a width value in points between 0.25pt and 20pt.
  • Color: Select a Web or custom color for the border.

Background

  • Color: Select a color to use for the background of the Viewport.
  • Gradient: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.
  • Gradient End Color: Select a color to use for the end color of the background gradient.
  • Pattern: Select the hatching pattern of a report control.

Shadow offset: Specify the size of the shadow. Shadow offsets are drawn to the right and below an element.

Legend

A legend on a map provides valuable information to users for interpreting the map data visualization rules such as color, size, and marker type differences for map elements on a layer. By default, a single Legend item already exists in the legends collection which can be used by all layers to display items. You can also create additional legends to use them individually with layers that have associated rules to display items in the legend.

Legends are added in the LegendDesigner Collection Editor. For more information, see Create a Map.

Distance Scale

A distance scale helps a user to understand the scale of the map. Distance on a map is not the same as the actual real-world distance, so a distance scale shows that a certain distance on the map equals a certain distance in a real-world. In distance scale, the distance is displayed in both miles and kilometers. The scale range and values are automatically calculated using the viewport boundaries, projection type, and zoom level. For more information, see Create a Map.

The Map Distance Scale dialog lets you set properties with the following pages.

Note: You can select <Expression...> within these properties to create an expression to determine the value.

General

Location

  • Position: Specify the docking position of the distance scale panel. Choose from TopCenter, TopLeft, TopRight, LeftTop, LeftCenter, LeftBottom, RightTop, RightCenter, RightBottom, BottomRight, or select the <Expression...> option to open the Expression Editor and create an expression.
  • Show distance scale outside the viewport: Specify whether the panel is docked inside or outside of the map viewport.

Scale

  • Color: Select the fill color for the distance scale bar.
  • Border color: Select the border color for the distance scale bar.

Appearance

Border

  • Style: Choose from None, Dotted, Dashed, Solid, Double, Groove, Ridge, Inset, WindowInset, or Outset.
  • Width: Choose the width of the border line.
  • Color: Select a color for the border.

Background

  • Color: Select a color to use for the background of the distance scale.
  • Gradient: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.
  • Gradient End Color: Select a color to use for the end color of the background gradient.
  • Pattern: Select the hatching pattern of the distance scale panel from the list of patterns, or select the <Expression...> option to open the Expression Editor and create an expression.

Shadow offset: Specify the size of the shadow of the distance scale panel. Shadow offsets are drawn to the right and below an element.

Font

Family: Choose the font family name.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic, or select the <Expression...> option to open the Expression Editor and create an expression.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

Color: Select a Web or custom color for the font.

Decoration: Choose from None, Underline, Overline and LineThrough, or select the <Expression...> option to open the Expression Editor and create an expression.

Visibility

Initial visibility

  • Visible: The distance scale is visible when the report runs.
  • Hidden: The distance scale is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the distance scale is visible. True for hidden, false for visible.

Navigation

Action

Select one of the following actions to perform when a user clicks on the distance scale element.

  • None: The default behavior is to do nothing when a user clicks the distance scale element at run time.
  • Jump to URL: Select this option and provide a valid URL to create a hyperlink to a Web page.
  • Jump to bookmark: Select this option and provide a valid Bookmark ID to allow the user to jump to the report control with that Bookmark ID.
  • Jump to report: For drill-through reporting, select this option and provide the name of a local report, the relative path of a report in another folder, or the full path of a report on another server.

Color Scale

A color scale helps a user to understand the range of colors that are used for data visualization on a layer. A map has just one color scale and multiple layers can provide data for it. For more information, see Create a Map.

The Map Color Scale dialog lets you set properties with the following pages.

Note: You can select <Expression...> within these properties to create an expression to determine the value.

General

Location

  • Position: Specify the docking position of the color scale panel. Choose from TopCenter, TopLeft, TopRight, LeftTop, LeftCenter, LeftBottom, RightTop, RightCenter, RightBottom, BottomRight, or select the <Expression...> option to open the Expression Editor and create an expression.
  • Show color scale outside the viewport: Specify whether the panel is docked inside or outside of the map viewport.

Color bar

  • Border color: Specify the outline color for color scale divisions.
  • Range gap color: Specify color to fill color divisions for undefined range values.

Labels

Display: Specify whether to display color scale labels on the color scale panel. Select from Auto, ShowMiddleValue, ShowBorderValue, or select the <Expression...> option to open the Expression Editor and create an expression.

Hide end labels: Specify whether to display first and last labels on the color scale panel.

Format: Specify the format string to display numeric labels.

Placement: Speciy the position of the color scale labels on the color scale panel. Select from Alternate, Top, Bottom, or select the <Expression...> option to open the Expression Editor and create an expression.

Interval: Specify the frequency of the labels on the color scale panel. A value of 0 means no labels are displayed.

Tick mark length: Specify the length of the tick marks on the color scale panel.

Title

Text: Specify the text of the color scale panel.

Font

  • Family: Choose the font family name.
  • Size: Choose the size in points for the font.
  • Style: Choose Normal, Italic or select the <Expression...> option to open the Expression Editor and create an expression.
  • Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.
  • Color: Select a Web or custom color for the font.
  • Decoration: Choose from None, Underline, Overline, LineThrough, or select the <Expression...> option to open the Expression Editor and create an expression.

Appearance

Border

  • Style: Choose from None, Dotted, Dashed, Solid, Double, Groove, Ridge, Inset, WindowInset, or Outset.
  • Width: Specify the width of the border.
  • Color: Specify a color for the border.

Background

  • Color: Select a color to use for the background of the distance scale.
  • Gradient: Specify whether and how to use color gradients in the color scale background. Select from None, LeftRight, TopBottom, Center, DiagonalLeft, DiagonalRight, HorizontalCenter, VerticalCenter, or select the <Expression...> option to open the Expression Editor and create an expression.
  • Gradient End Color: Select a color to use for the end color of the background gradient.
  • Pattern: Select the hatching pattern of the color scale panel from the list of patterns, or select the <Expression...> option to open the Expression Editor and create an expression.

Shadow offset: Specify the size of the shadow of the color scale panel. Shadow offsets are drawn to the right and below an element.

Font

Family: Choose the font family name.

Size: Choose the size in points for the font.

Style: Choose Normal, Italic or select the <Expression...> option to open the Expression Editor and create an expression.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder.

Color: Select a Web or custom color for the font.

Decoration: Choose from None, Underline, Overline, LineThrough, or select the <Expression...> option to open the Expression Editor and create an expression.

Visibility

Initial visibility

  • Visible: The color scale is visible when the report runs.
  • Hidden: The color scale is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the color scale is visible. True for hidden, false for visible.

Navigation

Action

Select one of the following actions to perform when a user clicks on the color scale element.

  • None: The default behavior is to do nothing when a user clicks the color scale element at run time.
  • Jump to URL: Select this option and provide a valid URL to create a hyperlink to a Web page.
  • Jump to bookmark: Select this option and provide a valid Bookmark ID to allow the user to jump to the report control with that Bookmark ID.
  • Jump to report: For drill-through reporting, select this option and provide the name of a local report, the relative path of a report in another folder, or the full path of a report on another server.

Map Dialog
Properties for the Map are available in the Map dialog. To open it, with the Map control selected on the report, under the Properties Window, click the Property dialog link.

The Map dialog lets you set properties on the report control with the following pages.

Note: You can select <Expression...> within these properties to create an expression to determine the value.

General

Name: Enter a name for the map that is unique within the report. This name is called in code.

Tooltip: Enter the value or expression you want to display when a user hovers the cursor over the map in the viewer at run time.

Antialiasing: Select the smoothing mode to apply to all map control elements. Choose All, None, Text, Graphic, or select the <Expression...> option to open the Expression Editor and create an expression.

Antialiasing quality: Select the quality for antialiasing. Choose High, Normal, SystemDefault, or select the <Expression...> option to open the Expression Editor and create an expression.

Visibility

Initial visibility

  • Visible: The map is visible when the report runs.
  • Hidden: The map is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the map is visible. True for hidden, false for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. This enables the drop-down box below where you can specify the TextBox control that toggles the visibility of the map. The user can click the toggle item to show or hide this map.

Appearance

Border

  • Style: Choose from None, Dotted, Dashed, Solid, Double, Groove, Ridge, Inset, WindowInset, or Outset.
  • Width: Specify the width of the border.
  • Color: Select a Web or custom color for the font.

Background

  • Color: Select a color to use for the background of the map.
  • Gradient: Specify whether and how to use color gradients in the color scale background. Select from None, LeftRight, TopBottom, Center, DiagonalLeft, DiagonalRight, HorizontalCenter, VerticalCenter, or select the <Expression...> option to open the Expression Editor and create an expression.
  • Gradient End Color: Select a color to use for the end color of the background gradient.
  • Pattern: Select the hatching pattern of a report control.

Data Output

Element name: Enter a name to be used in the XML output for this map.

Output: Choose Auto, Yes, or No to decide whether to include this map in the XML output. Choosing Auto exports the contents of the map.

Layers

A map is a collection of layers that display data on the map control.

  • Polygon layer: Display outlines of areas or markers for the polygon center point. See, Use a Polygon Layer for more information.
  • Point layer: Display markers for point locations. See, Use a Point Layer for more information.
  • Line layer: Display lines for paths or routes. See, Use a Line Layer for more information.
  • Tile layer: Adds a Bing map tiles background. See, Use a Tile Layer for more information.

A map can have one or more layers. You can load these layers on top of each other to create a more detailed map. For example, a polygon layer can represent the borders of a country, a line can represent transportation routes, a point can represent the locations and a tile can add a virtual earth background on the map. See, Use Layers for more information.

Map layer element appearance:

  • Properties that you set on a polygon layer, line layer and a point layer apply to all map elements on that layer, whether or not the map elements are embedded in the report definition.
  • Properties that you set for rules apply to all map elements on a layer. All data visualization options apply only to map elements that are associated with spatial data.

Map Layer Data Dialog

The Map layer Data dialog is used to set up spatial and analytical data for the map control. For more information on spatial and analytical data, see Work with Data.

To access Map Layer Data Properties dialog

  1. Click the map until the map panes appears.
  2. Right click the layers pane and select Add <layerName> Layer. This adds a new layer to the map and opens the Map Layer Data Properties dialog

Or, in case you already have a layer added to the map control, then follow these steps:

  1. Click the map until the map panes appears.
  2. In the layer pane, right-click the existing layer and select Layer Data to open Map Layer Data Properties dialog.

General

Spatial data source: Select one of the spatial data source connection types:

  • Embedded: The map layer data is loaded from the .shp data source that you embed into the map layer by indicating the .shp file in the Import spatial data from file: field. This field appears below when you select this option.

    Spatial fields: Use the plus sign button to add a field, and the X button to delete a field. For each newly added spatial field, you must specify the name and type in the corresponding fields below.

    Field name: Enter a name of a spatial field.

    Field type: Select the type of a spatial field from the list.

  • Linked: The map layer data is linked to the .shp file and is uploaded at report rendering. You select this type of data source by indicating the .shp file in the File Name field that appears.
  • Dataset: The map layer data is loaded from the data source of the report. In the Dataset field and in the Field name field that appear below, select a dataset from the bound data source and a dataset field.
    Caution: In Field name, simply type the name of the dataset field that contains spatial data. For example, enter the dataset field name as StateName, not as =[StateName].
  • Analytical data: The map layer data is loaded from the the analytical dataset of the bound report data source. In the Field name field that appears below, you must set the name of the data field that contains spatial data in the Analytical dataset.
    Caution: In Field name, enter the data field name as =[StateName], not as StateName.

Analytical Data

Dataset: Select the dataset for the analytical data to be displayed on the map layer.

Match: Use the plus sign button to add a relationship between a spatial data field and an analytical data field.

Spatial field: A field with spatial data that specifies an element on the map surface, for example, boundaries of a country.

Analytical field: A field with analytical data that displays information on the related map element, for example, the country population.

Filters

The Filters page of the Map Layer Data Properties dialog allows you to filter the data that is included in the map. Use the plus sign button to add a filter, and the arrow and X buttons to move or delete filters. You need to provide three values to add a new filter to the collection.

Expression: Enter the expression to use for evaluating whether data should be included in the map.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right:

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values (used with the In and Between operators) separate values using commas.

See Also

How To

Create a Map
Work with Data
Use Layers

Walkthroughs

Reports with Map


OverflowPlaceHolder

OverflowPlaceHolder
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > OverflowPlaceHolder
Show All Show All
Hide All Hide All

In a Page report, the OverflowPlaceHolder control is a rectangular placeholder for data that does not fit inside the fixed size of a List, BandedList, Tablix or Table data region. When you link a data region to an OverflowPlaceHolder, this control gets its Size property values from the FixedSize of the data region it is linked with.

You can also place multiple OverflowPlaceHolder controls in a report to create different looks for your data output. Link a data region to an OverflowPlaceHolder control and then link that OverflowPlaceHolder control to another OverflowPlaceHolder control. Two common layouts that you can create through this process are:

  • Multiple Page Layout: Place the data region on the first page of the report and OverflowPlaceHolder controls on subsequent pages to create a layout with overflow data on multiple pages.

    Note: If a page contains only an OverflowPlaceHolder with no data to display, the empty page does not render. However, if the page also contains any control with static data, the page renders. To skip rendering the page, set the ThrowIfPlaceHoldersEmpty property to True.
  • Columnar Report Layout: Place the data region and the OverflowPlaceHolder on the same page of the report to create a layout that displays data in a columnar format like the one in the following image.

Data overflow to an OverflowPlaceHolder

You can bind overflow data from a data region to an OverflowPlaceHolder control or from an OverflowPlaceHolder control to another OverflowPlaceHolder control in a report. The following steps take you through the process:

These steps assume that you have already added a Page Report template to your project, connected it to a data source and added a DataSet. See Connect to a Data Source and Add a Dataset for more information.

To link a data region to an OverflowPlaceHolder control

When your data goes beyond the fixed size of a data region, you can create a link from the data region to enable flow of data into the OverflowPlaceHolder.

  1. From the Visual Studio toolbox, on the Page1 tab of the report, drag and drop a data region like List onto the design surface and set its FixedSize property.
  2. If the data goes beyond the fixed size of the data region, from the Visual Studio toolbox, on Page2 tab of the report, drag and drop an OverflowPlaceHolder control (OverflowPlaceHolder1 by default) onto the design surface.
  3. On the Page1 design surface, select the data region placed above and go to the Properties Window.
  4. In the Properties Window, go to the OverflowName Property and from the dropdown list, select the name of the OverflowPlaceHolder control you added earlier.

    The following image shows the Properties Window of a List data region (List1) where OverflowPlaceHolder1 is set in the OverflowName property.

    Tip: Depending on your layout requirements, you can place the OverflowPlaceHolder control on the same page tab as the data region or a different page tab.

To link an OverflowPlaceHolder control to another OverflowPlaceHolder control

You can place additional OverflowPlaceHolder controls, to display data that flows beyond the first OverflowPlaceHolder control.

  1. From the Visual Studio toolbox, drag and drop another OverflowPlaceHolder control like OverflowPlaceHolder2 onto the design surface.
  2. In the Designer, select the OverflowPlaceHolder1 control that contains overflow data and go to the properties window.
  3. In the Properties Window, go to the OverflowName Property and select the name of the new OverflowPlaceHolder control you placed above. For e.g., in OverflowPlaceHolder1, set the OverflowName property to OverflowPlaceHolder2.

    The following image shows the Properties Window of OverflowPlaceHolder1 where the OverflowPlaceHolder2 is set in the OverflowName property.

Caution: In a report with multiple OverflowPlaceHolder controls, link the OverflowPlaceHolder controls to their respective data regions and other OverflowPlaceHolder controls such that the overflow chain does not break.
See Also
Page Report Toolbox
Page Report

Walkthroughs

Overflow Data in a Single Page(Page Report)
Overflow Data in Multiple Pages(Page Report)


Shape

Shape
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Shape
Show All Show All
Hide All Hide All

The Shape report control is used to display one of the available shape types on a report. You can add a shape report control to a report by dragging it from the toolbox and dropping it onto the report design surface.

In the ShapeStyle property of the Shape report control, you can select Rectangle, RoundRect or Ellipse, or you can use an expression to assign fields, datasets, parameters, constants, operations or common values to it. You can highlight different sections or parts of a report using a shape report control. For example, you can use a Rectangle as border around different report controls or the entire page or you can use an Ellipse to highlight a note on your report.

Shape Dialog

Properties for the Shape are available in the Shape dialog. To open it, with the Shape control selected on the report, under the Properties Window, click the Property dialog link.

The Shape dialog lets you set properties on the report control with the following pages.

Note: You can select <Expression...> within many of these properties to open the Expression Editor.

General

Name: Enter a name for the image that is unique within the report. This name can be called in code.

Shape Style: Choose Rectangle, RoundRect or Ellipse from the dropdown list.

Rounded Rectangle: When the Shape type is set to RoundRect, you can specify the radius for each corner of the shape independently. Drag the handlers [image] available at each corner of the shape to set the value of the radius at each corner.

Note: To enable specific corners, check the CheckBox available near each corner of the Shape control.

Appearance

Background

Color: Select a color to use for the background of the Shape.

Image: Enter an image to use for the background of the Shape.

Border

Style: Select a style for the border.

Width: Enter a value in points to set the width of the border.

Color: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Visibility

Initial visibility

  • Visible: The shape is visible when the report runs.
  • Hidden: The shape is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the shape is visible. True for hidden, false for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle shape next to another report control. This enables the drop-down box where you can specify the TextBox control which, if clicked, toggles the visibility of the shape.

Navigation

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this shape. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Data Output

Element name: Enter a name to be used in the XML output for this shape report control.

Output: Choose Auto, Yes, No, Contents Only to decide whether to include this Shape in the XML output. Choosing Auto exports the contents of the Shape report control.

See Also
Shape
Container


Sparkline

Sparkline
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Sparkline
Show All Show All
Hide All Hide All

You can use the Sparkline report control as a simple means of displaying the trend of data in a small graph. The Sparkline displays the most recent value as the rightmost data point and compares it with earlier values on a scale, allowing you to view general changes in data over time. With the height similar to the surrounding text and the width not more than 14 letters wide, the sparkline fits well in dashboards, reports, and other documents.

Customize the Sparkline control with the following types.

Type | Description
Line | The Line sparkline is widely used in financial and economic data analysis and is based on a continuous flow of data. The currency exchange rates, changes in price are the examples of application of this type of sparklines.
Columns | The Column sparkline is used for sports scores, cash register receipts, and other cases where previous values and the current value do not closely influence one another. In this case you are dealing with discrete data points, and not a continuous flow of data as in the Line sparkline.
Whiskers | The Whisker sparkline is typically used in win/loss/tie or true/false scenarios. This type is similar to the Column sparkline, but it renders a tie (0 value) in a different manner. The bars in a whisker sparkline render below the baseline for a negative value, above the baseline for a positive value, and on the baseline for a zero value.
Area | The Area sparkline is similar to the Line sparkline but visually you see the space under the line as shaded.
StackedBar | The Stacked Bar sparkline is presented as a horizontal bar with different segment lengths marked by distinct color hues. The Stacked bar illustrates how the various segments of a part-to-whole relationship correspond to one another - the largest segment represents the highest value and the change in brightness indicates a new value on a scale.

Sparkline Dialog

Properties for the Sparkline are available in the Sparkline dialog. To open it, with the Sparkline control selected on the report, under the Properties Window, click the Property dialog link.

The Sparkline dialog lets you set properties on the report control with the following pages.

General

Name: Enter a name for the sparkline that is unique within the report. This name can be called in code.

Data

Value: Enter an expression to use as the sparkline value.

Name: Enter a name for the sparkline that is unique within the report. This name can be called in code. A name is created automatically if you do not enter one.

Group on: Enter an expression to use for grouping the data. If you open the expression editor, you can select a field from the dataset.

Detail Grouping: Enter an expression to use if you do not want to repeat values within the details. If you open the expression editor, you can select a field from the dataset.

Parent Group: For use in recursive hierarchies. Enter an expression to use as the parent group.

Appearance

Sparkline Type: Choose Line, Columns, Whiskers, Area or StackedBar. Each of these types has its own set of Appearance properties that appears when you select the type.

Line Type Appearance Properties

Last point marker is visible: Select to display a marker at the last point on the sparkline.

Marker Color: Select a color to use for the last point marker, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Line Style

Color: Select a color to use for the line, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Width: Enter a value in points to set the width of the line.

Enable Wall Range: Select this check box to display a wall range for the sparkline. Selecting this box enables the rest of the properties in this section.

Lower Bound: Select a value or enter an expression that defines the lower bound of the wall range.

Upper Bound: Select a value or enter an expression that defines the upper bound of the wall range.

Wall Range Backdrop

Fill Color: Select a color to use for the wall range, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Gradient: Choose the type of gradient to use for the backdrop: None, LeftRight, TopBottom, Center, DiagonalLeft, DiagonalRight, HorizontalCenter or VerticalCenter.

Gradient End Color: Select a color to use for the end of the wall range gradient, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Columns Type Appearance Properties

Fill Color: Select a color to use for the fill of the sparkline, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Maximum Column Width: Select the maximum width of columns in the sparkline. If blank, all columns are sized to fit.

Enable Wall Range: Select this check box to display a wall range for the sparkline. Selecting this box enables the rest of the properties in this section.

Lower Bound: Select a value or enter an expression that defines the lower bound of the wall range.

Upper Bound: Select a value or enter an expression that defines the upper bound of the wall range.

Wall Range Backdrop

Fill Color: Select a color to use for the wall range, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Gradient: Choose the type of gradient from these choices: None, LeftRight, TopBottom, Center, DiagonalLeft, DiagonalRight, HorizontalCenter or VerticalCenter.

Gradient End Color: Select a color to use for the end of the wall range gradient, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Whiskers Type Appearance Properties

Fill Color: Select a color to use for the fill of the sparkline, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Maximum Column Width: Select the maximum width of columns in the sparkline. If blank, all columns are sized to fit.

Enable Wall Range: Select this check box to display a wall range for the sparkline. Selecting this box enables the rest of the properties in this section.

Lower Bound: Select a value or enter an expression that defines the lower bound of the wall range.

Upper Bound: Select a value or enter an expression that defines the upper bound of the wall range.

Wall Range Backdrop

Fill Color: Select a color to use for the wall range, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Gradient: Choose the type of gradient from these choices: None, LeftRight, TopBottom, Center, DiagonalLeft, DiagonalRight, HorizontalCenter or VerticalCenter.

Gradient End Color: Select a color to use for the end of the wall range gradient, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Area Type Appearance Properties

Fill Color: Select a color to use for the fill of the sparkline, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Enable Wall Range: Select this check box to display a wall range for the sparkline. Selecting this box enables the rest of the properties in this section.

Lower Bound: Select a value or enter an expression that defines the lower bound of the wall range.

Upper Bound: Select a value or enter an expression that defines the upper bound of the wall range.

Wall Range Backdrop

Fill Color: Select a color to use for the wall range, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Gradient: Choose the type of gradient from these choices: None, LeftRight, TopBottom, Center, DiagonalLeft, DiagonalRight, HorizontalCenter or VerticalCenter.

Gradient End Color: Select a color to use for the end of the wall range gradient, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

StackedBar Type Appearance Properties

Fill Color: Select a color to use for the base color of the stacked bars, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color. The other colors of the stacked bars are calculated using this based color.

Visibility

Initial visibility

  • Visible: The sparkline is visible when the report runs.
  • Hidden: The sparkline is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the sparkline is visible. True for hidden, False for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report item. This enables the drop-down box below where you can specify the TextBox control which, if clicked, toggles the visibility of the sparkline in the Viewer.

Navigation

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this sparkline. You will then be able to provide a bookmark link to this item from another report item using a Jump to bookmark action.

Filters

The Filters page of the Sparkline dialog allows you to control the Filter grid collection for the sparkline. Use the plus sign button to add a filter, and the arrow and X buttons to move or delete filters. You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Sorting

Click the plus sign button to enter new sort expressions, and remove them using the X button.

In the Expression box, enter an expression by which to sort the data in the group, and under Direction, select Ascending or Descending for the selected sort expression.

Data Output

Element name: Enter a name to be used in the XML output for this sparkline report control.

Output: Choose Auto, Yes, No, Contents Only to decide whether to include this Sparkline in the XML output. Choosing Auto exports the contents of the Sparkline report control.

See Also

How To

Create a Whisker Sparkline


Subreport(RDL)

Subreport(RDL)
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Subreport(RDL)
Show All Show All
Hide All Hide All

The Subreport control is a placeholder for data from a separate report. In ActiveReports, we recommend that you use data regions instead of Subreport controls wherever possible for better performance. The reason is that the report server must process every instance of each subreport, which can become burdensome in very large reports with a large number of subreports processed many times per report. Using data regions to display separate groups of data can be much more efficient in such reports. For more information, see Work with Report Controls and Data Regions.

Note: The Subreport control is not supported in Page reports, only RDL. Also, you cannot use a Section report as the target of a Subreport in a RDL report, and vice versa. But you can export any type of report to RDF and use that as the target of a Subreport in a section report.

Subreports make sense when you need to nest groups of data from different data sources within a single data region, or when you can reuse a subreport in a number of reports. Here are some things to keep in mind while designing subreports.

  • If you make changes to the subreport without changing the main report, click Refresh to re-run the subreport in the Preview tab.
  • If you design the parent report in a stand-alone Report Designer application, save the parent report to the same directory as the subreport to render it in the Preview tab.
  • If you set borders on the Subreport control and the body of the report hosted in it, ActiveReports does not merge the two borders.
  • If the report hosted in the Subreport control cannot be found or contains no rows, only the border of the Subreport control is rendered.
  • If the hosted report is found and does contain rows, the border of the hosted report body is rendered.

Parameters

You can use parameters supplied by the parent report to filter data displayed in a subreport. You can also pass parameters to a repeating subreport nested in a data region to filter each instance.

Subreport Dialog

Properties for the Subreport are available in the Subreport dialog. To open it, with the Subreport control selected on the report, under the Properties Window, click the Property dialog link.

The Subreport dialog lets you set properties on the report control with the following pages.

Note: You can select <Expression...> within any of these properties to open the Expression Editor.

General

Name: Enter a name for the subreport that is unique within the report. This name can be called in code.

Tooltip: Enter the value or expression you want to appear when a user hovers the cursor over the subreport in the viewer at run time.

Subreport:
Select the <From File...> option to open the Open dialog, and then select a report to display within the Subreport control.

Select the <From Server...> option to open the Open report from server dialog, and then select a report stored on ActiveReports Server to display within the Subreport control.

Use this report’s theme when rendering subreport: Select this check box to have the subreport automatically use the same theme as the hosting report.

Visibility

Initial visibility

  • Visible: The subreport is visible when the report runs.
  • Hidden: The subreport is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the subreport is visible. True for hidden, false for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. This enables the drop-down box where you can specify the TextBox control which, if clicked, toggles the visibility of the subreport.

Navigation

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this subreport. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Parameters

The Parameters page of the Subreport dialog allows you to enter new parameters and remove or change the order of parameters using the X and arrow buttons. For each parameter in this list, there is a Parameter Name and a Parameter Value.

Each Parameter Name must exactly match the name of a parameter in the target report.

For the Parameter Value, enter an expression to use to send information from the summary or main report to the subreport target.

Data Output

Element name: Enter a name to be used in the XML output for this subreport.

Output: Choose Auto, Yes, or No to decide whether to include this subreport in the XML output. Choosing Auto exports the contents of the subreport.

See Also
SubReport (Section Report)
Shared Subreports


Table

Table
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Table
Show All Show All
Hide All Hide All

The Table data region consists of columns and rows that organize data. A Table has three columns and three rows by default, a total of nine cells, each of which is filled with a text box. At design time, you can add or remove columns, rows and groupings to suit your needs. In RDL reports, you can embed other data regions in table cells.

Adding Data

Once you place the Table data region on a report, you can add data to its cells. As with any data region, you can drag fields from your Fields list onto cells in the table. Although the default report control within each cell of the table is a text box, you can replace it with any other report control, and on RDL reports, you can even add a data region. When you drag a field into a cell in the detail row, ActiveReports automatically provides a label in the table header. As with all report controls, you can use expressions to further manipulate the data within the cells of the table. For more information, see Expressions.

Grouping

One of the types of rows you can add to the table is the group header or group footer. This is useful when you need to create, for example, a report which is grouped by country. You just add a group, and in the Group On expression, choose the Country field from your dataset.

You can also group the data in your detail section, and you can add multiple rows to any group in the table. You can use aggregate functions in group footer rows to provide subtotals. For more information, see Grouping in a Data Region.

Appearance

There are many ways in which you can control the appearance of the table data region. You can merge cells, control visibility, text color, background color. You can use graphical elements within the cells and borders on the cells themselves.

Table Dialog

Properties for the Table are available in the Table dialog. To open it, with the Table data region selected on the report, under the Properties Window, click the Property dialog link.

The Table dialog lets you set properties on the report control with the following pages.

Note: You can select <Expression...> within these properties to create an expression to determine the value.

General

Name: Enter a name for the table that is unique within the report. This name can be called in code.

Tooltip: Enter the value or expression you want to appear when a user hovers the cursor over the table in the viewer at run time.

Dataset name: Select a dataset to associate with the table. The combo box is populated with all of the datasets in the report's dataset collection.

Header and Footer: Select any of the following options.

  • Repeat header row on each page
  • Repeat footer row on each page
  • Prevent orphaned footer on next page

Visibility

Initial visibility

  • Visible: The table is visible when the report runs.
  • Hidden: The table is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the table is visible. True for hidden, false for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. This enables the drop-down box where you can specify the report control which, if clicked, toggles the visibility of the table.

Navigation

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this table. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Sorting

Click the plus sign button to enter new sort expressions, and remove them using the X button.

In the Expression box, enter an expression by which to sort the data in the group, and under Direction, select Ascending or Descending for the selected sort expression.

Groups

The Groups page of the Table dialog allows you to remove or change the order of items in the Group list using the X and arrow buttons. Click the Add button to add a new group to the table and set up information for each group on the following tabs.

General

Name: Enter a name for the group that is unique within the report. This property cannot be set until after a Group on expression is supplied.

Group on: Enter an expression to use for grouping the data.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Parent group: For use in recursive hierarchies. Enter an expression to use as the parent group.

Filters

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Sorting

Click the plus sign button to enter new sort expressions, and remove them using the X button.

In the Expression box, enter an expression by which to sort the data in the group, and under Direction, select Ascending or Descending for the selected sort expression.

Visibility

Initial visibility

  • Visible: The group is visible when the report runs.
  • Hidden: The group is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the group is visible. True for hidden, False for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. The user can click the toggle item to show or hide this band group. This enables the drop-down list where you can select the TextBox control that users can click to show or hide this group.

Data Output

Element name: Enter a name to be used in the XML output for this group.

Collection: Enter a name to be used in the XML output for the collection of all instances of this group.

Output: Choose Yes or No to decide whether to include this group in the XML output.

Layout

Page break at start: Inserts a page break before the group.

Page break at end: Inserts a page break after the group.

Include group header: Adds a group header band (selected by default).

Include group footer: Adds a group footer band (selected by default).

Repeat group header: Repeats the group header band on each page.

Repeat group footer: Repeats the group footer band on each page.

Prevent orphaned footer:　Prints the last detailed row with the footer in order to prevent orphaned footer on the next page.

Detail Grouping

Detail grouping is useful when you do not want to repeat values within the details. When a detail grouping is set, the value repeats for each distinct result of the grouping expression instead of for each row of data. For example, if you use the Customers table of the NorthWind database to create a list of countries without setting the details grouping, each country is listed as many times as there are customers in that country. If you set the details grouping to =Fields!Country.Value each country is listed only once.

Note: If the detail grouping expression you use results in a value that is distinct for every row of data, a customer number for example, you will see no difference in the results.

Go to the Detail Grouping page has the following tabs.

General

Name: Enter a name for the group that is unique within the report. This property cannot be set until after a Group on expression is supplied.

Group on: Enter an expression to use for grouping the data.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Parent group: For use in recursive hierarchies. Enter an expression to use as the parent group.

Filters

You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the group.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right.

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Visibility

Initial visibility

  • Visible: The group is visible when the report runs.
  • Hidden: The group is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the group is visible. True for hidden, False for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle image next to another report control. The user can click the toggle item to show or hide this band group. This enables the drop-down list where you can select the report control that users can click to show or hide this group.

Data Output

Element name: Enter a name to be used in the XML output for this group.

Collection: Enter a name to be used in the XML output for the collection of all instances of this group.

Output: Choose Yes or No to decide whether to include this group in the XML output.

Layout

Page break at start: Inserts a page break before the group.

Page break at end: Inserts a page break after the group.

Has own page numbering: Used in conjunction with the "Page Number in Section" and "Total Pages in Section" properties, tells the report that the group constitutes a new page numbering section.

Filters

The Filters page of the Table dialog allows you to control the Filter grid collection for the table. Use the arrow and X buttons to move or delete filters. You need to provide three values to add a new filter to the collection: Expression, Operator, and Value.

Expression: Enter the expression to use for evaluating whether data should be included in the table.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right:

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right.
    For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

Data Output

Element name: Enter a name to be used in the XML output for this table.

Output: Choose Auto, Yes, or No to decide whether to include this table in the XML output. Choosing Auto exports the contents of the table.

Detail element name: Enter a name to be used in the XML output for the data element for instances of the table. This name is ignored if you have specified a details grouping.

Detail collection name: Enter a name to be used in the XML output for the data element for the collection of all instances of the detail grouping.

Data element output: Choose Yes or No to decide whether to include the details in the XML output.


TableOfContents

TableOfContents
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > TableOfContents
Show All Show All
Hide All Hide All

The TableOfContents report control is used to display the document map, an organized hierarchy of the report heading levels and labels along with their page numbers, in the body of a report. The TableOfContents control allows you to quickly understand and navigate the data inside a report in all viewers that are supported in ActiveReports. Unlike the Document Map that is only available in the Viewers and cannot be rendered or printed, you can use the TableOfContents control to embed the TableOfContents structure in the report body for printing and rendering purposes. You can add a TableOfContents report control to a report by dragging it from the toolbox and dropping it onto the report design surface.

In the Properties Window, there are a number of properties that you can use to control the appearance and behavior of the TableOfContents report control. For example, you can use the OverflowName property to specify the OverflowPlaceHolder control name to link it with the TableOfContents control. The FixedHeight property allows you to set the maximum height of the TableOfContents control on each page, similar to the FixedSize property that is available with other report controls. The StyleName property allows you to apply the selected styles from a style sheet. These styles can be applied to the TableOfContents report control using the StyleName property or to Table Of Contents levels using the LevelDesigner Collection Editor dialog. For more information on how to set styles, see Add TableofContents.

The Levels property contains the collection of TableOfContents levels and allows you to access the LevelDesigner Collection Editor dialog, where you can set up the report TableOfContents levels and their properties. The MaxLevel property restricts the maximum number of levels in the document map.

Any customization made to the Document Map like setting Numbering Style for document map levels using the Report dialog or using the DocumentMap property gets directly applied to the TableOfContents control. For more information, see Add Items to the Document Map.

Table Of Contents properties Dialog

Properties for the TableOfContents are available in the Table Of Contents dialog. To open it, with the TableOfContents control selected on the report, under the Properties Window, click the Property dialog link.

The Table Of Contents Properties dialog lets you set properties on the report control with the following pages.

Note: You can click <Expression...> in many of these properties to open the Expression Editor where you can create an expression to determine the value.

General

Name: Enter a name for the table of contents that is unique within the report. This name can be called in code.

Tooltip: Enter the value or expression you want to display when a user hovers the cursor over the TableOfContents in the viewer at run time.

Visibility

By default, the TableOfContents is visible when the report runs, but you can hide it, hide it only when certain conditions are met, or toggle its visibility with another report control.

Initial visibility

Visible: The TableOfContents is visible when the report runs.

Hidden: The TableOfContents is hidden when the report runs.

Expression: Use an expression with a Boolean result to decide whether the TableOfContents is visible. True for hidden, false for visible.

Visibility can be toggled by another report control: Select this check box to display a toggle TableOfContents next to another report control. This enables the drop-down box where you can specify the TextBox control which, if clicked, toggles the visibility of the TableOfContents.

Appearance

Border

Style: Select a style for the border.

Width: Enter a value in points to set the width of the border.

Color: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Background

Color: Select a color to use for the background.

Data Output

Element name: Enter a name to be used in the XML output for the TableOfContents report control.

Output: Choose Auto, Yes, No to decide whether to include this TableOfContents in the XML output. Choosing Auto exports the contents of the TableOfContents report control.

LevelDesigner Collection Editor

The LevelDesigner Collection Editor is used to set up the report TableOfContents levels and their properties. To access the LevelDesigner Collection Editor dialog, go to the Properties Window and in the Levels property, click (Collection).

You can set the TableOfContents level properties from the following locations:

  • The Properties grid of the LevelDesigner Collection Editor.
  • The Level properties dialog that gets displayed if you click the Property Pages button above the LevelDesigner Collection Editor Properties grid.

The LevelDesigner Collection Editor lets you set the properties of a TableOfContents level as follows.

Appearance

BackgoundColor: Select a color to use for the background of the TableOfContents level.

Color: Select the color of the text.

Font: Select the font to render the TableOfContents level text.

Style: Choose Normal, Italic or select the <Expression...> option to open the Expression Editor and create an expression.

Family: Choose the font family name.

Size: Choose the size in points for the font.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, and Bolder, or select the <Expression...> option to open the Expression Editor and create an expression.

Padding: Specify left, right, top and bottom values for the padding to apply to a TableOfContents level.

StyleName: Select a style to apply to the TableOfContents level.

TextAlign: Specify the horizontal alignment of the text.

TextDecoration: Choose from None, Underline, Overline, and LineThrough, or select the <Expression...> option to open the Expression Editor and create an expression.

Data

DataElementName: Enter a name to be used in the XML output for this TableOfContents level.

General

DisplayFillCharacters: Specifies whether to display a leading character. The Default value is True.

DisplayPageNumber: Specifies whether to display a page number. The Default value is True.

FillCharacter: Use the expression to specify a fill character for a leading character.

Layout

TextIndent: Specify the text indent.

Misc

Name: Specify a name for the TableOfContents level.

See Also
Document Map


TextBox

TextBox
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > TextBox
Show All Show All
Hide All Hide All

The Textbox is the most commonly used report control that displays data. By default, the TextBox appears in each cell of a Table or Tablix data region. Also, the TextBox is what is created when you drag a field from the Data Explorer onto the report.

In the Value property of the TextBox, you can enter static text or an expression. An expression can display fields from a database, calculate a value, or visually display data.

Tip: You can enter text directly into the TextBox on the design surface of the report by double-clicking inside it.

In the Properties Window are a number of properties that you can use to control the appearance and behavior of the TextBox. For example, you can set the Action property to have the viewer jump to a bookmark within the report, another report, or a URL when a user clicks the TextBox at run time. The DataElement properties allow you to control how and whether the TextBox displays in XML exports.

By default, in RDL Reports, the TextBox can grow vertically to accommodate the data it displays, and it cannot shrink smaller than it appears at design time. To change this behavior, set the CanShrink and CanGrow properties in the Properties grid. (These properties are not available in Page Reports.)

Data Fields

When you drag a field from a dataset in the Data Explorer and drop it onto the report surface, a TextBox report control with an expression is automatically created. The type of expression that is created depends upon the context where you drop the field. The following table describes the various contexts and expressions created if you drag a field named SalesAmount onto the report.

Expressions created for fields in different contexts

Note: The expression created is different for a field with a string or unknown data type. In these cases, the First aggregate is used in place of the Sum aggregate in the expressions below. At run time, the first value found within the scope is displayed instead of a summary.
Context | Expression | Run-Time Behavior
Directly on the report surface | =Sum(Fields!SalesAmount.Value) | Displays a summary of the sales amount for the entire dataset.
List data region | =Fields!SalesAmount.Value | Displays a value for each row of data, in a list running down the page.
BandedList data region, header or footer band | =Sum(Fields!SalesAmount.Value) | Displays a summary of the sales amount for the dataset associated with the BandedList.
BandedList data region, detail band | =Fields!SalesAmount.Value | Displays a value for each row of data, in a list running down the page.
BandedList data region, group header or footer band | =Sum(Fields!SalesAmount.Value) | Displays a summary of the sales amount for the grouping.
Table data region, header or footer row | =Sum(Fields!SalesAmount.Value) | Displays a summary of the sales amount for the dataset associated with the Table.
Table data region, detail row | =Fields!SalesAmount.Value | Displays a value for each row of data, in a list running down the page.
Table data region, group header or footer row | =Sum(Fields!SalesAmount.Value) | Displays a summary of the sales amount for the grouping.
Tablix data region, corner cell | none | Displays a blank cell. You can add a label or even use this area to embed other report control.
Tablix data region, column group cell | =Fields!SalesAmount.Value | Displays the value at the top of a new column for each row of data running to the right.
Tablix data region, row group cell | =Fields!SalesAmount.Value | Displays the value to the left of a new row for each row of data running down the page.
Tablix data region, body cell | =Sum(Fields!SalesAmount.Value) | Displays a summary of the sales amount for the intersection of the column and row.

Textbox Dialog

Properties for the Textbox are available in the Textbox dialog. To open it, with the Textbox control selected on the report, under the Properties Window, click the Property dialog link.

The Textbox dialog lets you set properties on the report control with the following pages.

Note: You can select <Expression...> within many of these properties to open the Expression Editor.

General

Name: Enter a name for the textbox that is unique within the report. This name is displayed in the Document Outline and in XML exports.

Tooltip: Enter the value or expression you want to appear when a user hovers the cursor over the textbox in the viewer at run time.

Note: You must select Print Preview mode in order to see this property working in the viewer.

Value: Enter an expression or a static label, or choose a field expression from the drop-down list.

Note: When the group or dataset breaks to a new page, the first instance of the repeated value is printed.

Visibility

Initial visibility allows you to select from the following options:

  • Visible: The textbox is visible when the report runs.
  • Hidden: The textbox is hidden when the report runs.
  • Expression: Use an expression with a Boolean result to decide whether the textbox is visible. For example, on a "Free Shipping" textbox, you could use the expression to see whether the ShippingCountry is international. A value of True hides the textbox, False shows it.

Visibility can be toggled by another report control: If you select this check box, it enables the drop-down box where you can specify the TextBox control that users can click to toggle the visibility of the textbox.

Initial appearance of the toggle image: allows you to select from the following options:

  • Expanded: The toggle image shows as a minus sign, and all instances of this textbox are visible.
  • Collapsed: The toggle image shows as a plus sign, and all instances of this textbox are hidden.
  • Expression: Use an expression with a Boolean result to decide whether the toggle image is expanded. A value of True expands the toggle image, False collapses it.

Navigation

Action

Select one of the following actions to perform when a user clicks on the textbox.

None: The default behavior is to do nothing when a user clicks the textbox at run time.

Jump to report: For drill-through reporting, select this option and provide the name of a local report, the relative path of a report in another folder, or the full path of a report on another server.

Parameters: Supply parameters to the targeted report by entering the Name of each parameter, the Value to send to the targeted report, or whether to Omit the parameter. Note that parameter names you supply must exactly match parameters in the target report. You can remove or change the order of parameters using the X and arrow buttons.

Jump to bookmark: Select this option and provide a valid Bookmark ID to allow the user to jump to the report control with that Bookmark ID.

Jump to URL: Select this option and provide a valid URL to create a hyperlink to a Web page.

Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Bookmark ID: Enter an expression to use as a locator for this textbox. You will then be able to provide a bookmark link to this item from another report control using a Jump to bookmark action.

Appearance

Border

Style: Select a style for the border.

Width: Enter a value in points to set the width of the border.

Color: Select a color to use for the border, or select the <Expression...> option to open the Expression Editor and create an expression that evaluates to a .NET color.

Background

Color: Select a color to use for the background of the textbox.

Image: Enter an image to use for the background of the textbox.

Note: The Background Color and Background Image properties allow you to choose the <Data Visualizer...> option as well to launch the dialog that let you build a data visualization expression.

Font

Family: Select a font family name or a theme font.

Size: Choose the size in points for the font or use a theme.

Style: Choose Normal or Italic or select a theme.

Weight: Choose from Lighter, Thin, ExtraLight, Light, Normal, Medium, SemiBold, Bold, ExtraBold, Heavy, or Bolder.

Color: Choose a color to use for the text.

Decoration: Choose from None, Underline, Overline, or LineThrough.

Format

Format code: Select one of the common numeric formats provided or use a custom .NET formatting code to format dates or numbers. For more information, see MSDN's Formatting Types topic.

Line Spacing: This property sets the space between lines of text.

Line Height: This property sets the height of lines of text with leading and ascending space.

Note: This property only affects HTML output.

Character Spacing: This property sets the space between characters.

Textbox height

Can increase to accommodate contents: Select this check box to set CanGrow to True.

Can decrease to accommodate contents: Select this check box to set CanShrink to True.

Can shrink text to fit fixed size control: Select this check box to set ShrinkToFit to True.

Text direction and writing mode

Direction: Choose LTR for left to right, or RTL for right to left.

Mode: Choose lr-tb for left right top bottom (normal horizontal text) or tb-rl for top bottom right left (vertical text on its side).

Angle: Enter the number of degrees to rotate the text in a counter-clockwise direction. Enter a negative number to rotate the text in a clockwise direction.

Alignment

Vertical alignment: Choose Top, Middle, Bottom, or the <Expression...> option.

Horizontal alignment: Choose General, Left, Center, Right, Justify, or the <Expression...> option.

Justify method: Set Horizontal alignment to Justify to enable this property. Choose Auto, Distribute, DistributeAllLines, or the <Expression...> option.

Wrap mode: Choose NoWrap, WordWrap, or CharWrap.

Amount of space to leave around report control

  • Top padding: Set the top padding in points.
  • Left padding: Set the left padding in points.
  • Right padding: Set the right padding in points.
  • Bottom padding: Set the bottom padding in points.

Interactive Sort

Select the checkbox next to Add an interactive sort action to this textbox to enable the following controls which allow end users to sort the report data in the viewer.

Sort expression: Enter an expression to use for determining the data to sort.

Data region or group to sort: Select the grouping level or data region within the report to sort. The default value is Current scope, but you may also elect to choose an alternate data region or grouping.

Evaluate sort expression in this scope: Select the grouping level within the report on which to evaluate an aggregate sorting expression. The default value is Current scope, but you may also elect to choose an alternate data region or grouping.

Data Output

Element Name: Enter a name to be used in the XML output for this textbox.

Output: Choose Auto, Yes, or No to decide whether to include this textbox in the XML output. Auto exports the contents of the textbox only when the value is not a constant.

Render as: Choose Auto, Element, or Attribute to decide whether to render textboxes as Attributes or Elements in the exported XML file. Auto uses the report's setting for this property.

Attribute example: <table1 textbox3="Report created on: 7/26/2005 1:13:00 PM">

Element example: <table1> <textbox3>Report created on: 7/26/2005 1:13:28 PM</textbox3>

See Also
Text Justification
TextBox (Section Report)


Tablix

Tablix
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Tablix

A Tablix data region displays data in cells that are arranged in rows and columns. It provides enhanced layout capabilities ranging from creation of simple tables to advanced matrices. Tablix is essentially a combination of two data regions, the table and the matrix. Therefore, it provides all the features of a table and a matrix along with added capabilities including support for multiple adjacent groups on rows or columns and improved layout flexibility with stepped group layouts.

This topic describes how the elements of the Tablix data region work together and explains its basic operations.

  • Areas of Tablix Data Region
  • Row Column Handles

Areas of the Tablix Data Region

The Tablix data region is composed of four areas denoted by dotted lines on the design surface: the corner, the row group area, the column group area, and the body. By default, each tablix cell contains a TextBox control and the function for each cell is determined by its location. The layout of the Tablix data region can be changed using the LayoutDirection property.

ActiveReports includes a Group Editor window that is specifically designed to manage the tablix structure. In the Visual Studio integrated designer as well as in applications using the Designer control, the Group Editor window is located below the report design surface. Developers can use it in custom designer applications as well.

Note: In case the Group Editor window does not appear automatically in your application, select View > Other Windows > Group Editor 10 in your Visual Studio project.

The image below demonstrates the areas of a Tablix data region, where column groups are set to TheoryScore and PracticalScore, and the row group is set to SubjectName.

Tablix Data Region Areas

The Group Editor window contains the following groups:

  • Row Groups: The Row Groups section in the Group Editor displays all the groups that are applied in the row group area of the Tablix data region.

    Subject
    The left center cell of the Tablix data region =[SubjectName] represents the Subject group in the Group Editor window. This group displays the subject names for the current semester.

  • Column Groups : The Column Groups section in the Group Editor window displays all the groups that are applied in the column group area of the Tablix data region.

    Theory
    The center left cell of the Tablix data region =[TheoryScore] represents the Theory group in the Group Editor window. This group displays theory scores for the student in each subject.

    Practical
    The center right cell of the Tablix data region =[PracticalScore] represents the Practical group in the Group Editor window. This group displays practical scores for the student in each subject.

  • Static Cells: Static cells in the Row Groups and Column Groups are not represented in the Group Editor window because these cells are not associated with any grouped data. Static row and column cells are used to display labels and totals in a Tablix data region.

    The static column cell displays the label ASSESSMENT and TOTAL ASSESSMENT in the Tablix data region. The static row cell displays the label Total in the Tablix data region.

The image below displays the subjects in a row group. Nested column groups display practical and theory scores for the students. The total row displays the total scores for all of the subjects.

Tablix Data Region Areas

To perform basic operations in the Tablix data region, we need to first understand the concept of static and dynamic rows and columns.

Rows or columns in the Tablix data region can be static or dynamic. The Tablix data region contains multiple rows and columns that provide a grid type layout, where you can add or remove static or dynamic rows and columns in order to display your data efficiently.

  • Static Rows and Columns - A static row or column is not associated with any group data. When the report runs, a static row or column is rendered only once. Labels and totals are displayed using static rows or columns in Tablix data region. You can use the Group Editor window to identify the static rows and columns.

  • Dynamic Rows and Columns - A dynamic row or column is associated with one or more groups, and renders once for every unique value in the group. You can use the Group Editor window to identify the dynamic rows and columns in a Tablix data region. You can also create dynamic group rows or columns by adding a row group or a column group.

Row and Column Handles

When you select a Tablix data region, the row and column handles appear. These handles help you to work with the data region and visually specify the type of data added in your tablix layout.

The following table shows the different types of handles that appear in a Tablix data region.

Handle Icon | Description
OuterGroup | Row or column with one outer group.
ParentChildGroup | One outer group and one inner group.
OuterInnerGroup | One outer group with an extra row for totals and one inner group.

See Also
Tablix Reports


Tablix Reports

Tablix Reports
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Toolbox > Tablix > Tablix Reports

Tablix data region can be used to display complex data using row groups and column groups. Let us look at a few scenarios to understand how Tablix data region works.

Using Multiple Adjacent Groups

In Tablix data region, unlike Matrix and Table data regions, it is possible to create multiple adjacent groups. Let us take an example of a Sales report to understand how grouping works in a Tablix data region.

Scenario

An organization wants to create a Sales report that displays sales data by year and media type. To design such a report using Tablix data region, you need to create multiple adjacent groups in column group area, a single group in row group area, and display aggregated data in the body area.

Let us see how each area of Tablix data region works to create the desired output given below.

Column group area
The column group area contains two adjacent groups, namely Year and Media Type. The Year group displays the grouped data according to the year 2004 and 2005 and the Media Type group displays the grouped data values according to DVD, VHS, LaserDisc, HD-DVD media types stored in the database.

Row group area
The row group area contains a single group that is StoreName. Cells in the row group area display row group values and represent members of the row group hierarchy.

Body area
This area displays the aggregate sum of the TotalAmount in the Tablix. Cells in the tablix body area display detail data when the cells are in detail row or column and aggregated group data when the cell are in a group row or column.

Refer to Grouping in Tablix Walkthrough for detailed steps on how to create the above report using Tablix data region.

Using Cell Merging

In Tablix data region, it is possible to merge cells having duplicate values. Let us take an example of a Store Mangers report to understand how cell merging works in a Tablix data region.

Scenario

An organization wants to create a report to display names of all the store managers, using the concept of cell merging where cells with same value are merged automatically to avoid clutter.

To design such a report, you need to create nested groups in Tablix data region to display the name of managers according to the Region, District and StoreName.

Let us see how each area of Tablix data region works to create the desired output given below.

Column group area
The column group area contains no groups, however there are static labels for each column. There are four column labels, namely Region, District, Store, and Manager that are added as headers to describe information about the data.

Row group area
The row group area contains three groups that are nested in a parent/child relationship to display the row group data. The Region (parent) and District group (child) values are merged automatically to remove duplicate data values.

Body area
This area displays the full name of store managers. The body area displays the managers full name by concatenating two fields FirstName and LastName using the & operator in the expression.

Refer to Cell Merging in Tablix Walkthrough for detailed steps on how to create the above report using Tablix data region.

See Also
Tablix

Walkthroughs

Cell Merging in Tablix
Grouping in Tablix


Data Sources and Datasets

Data Sources and Datasets
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Sources and Datasets

Setting up a connection to the data source is the first step in binding data to the report. Once a connection is established, a data set is required to get the data you want to show on the report.

Data Sources

In ActiveReports, you can set the data source information in the Report Data Source Dialog.

The Report Data Source dialog is where you select the type of data to use, provide a connection string, and choose other options for your data source. You can also decide to use a shared data source, use a single transaction, and select a method for handling credentials. Once you add a data source, it appears in the Report Explorer under the Data Sources node. You can also add multiple data sources in a single report.

Datasets

A dataset fetches data from the data source to display in a report. The DataSet Dialog is where you provide a command type and query string and choose other options for your dataset.

You can also control the timeout period and other data options, and add fields, parameters, and filters to fetch the data you need. With the XML data type, you have to add fields manually with XPath expressions. Once you have added a dataset, its fields appear under the Data Source node in the Report Explorer. You can add multiple datasets for a data source.

See Also

How To

Bind a Page Report to a Data Source at Run Time

Page Report/RDL Report Concepts

Report Data Source Dialog

Report Page Concepts

DataSet Dialog

Concepts

Server Shared Data Sources
Server Shared Data Sets


Report Data Source Dialog

Report Data Source Dialog
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Sources and Datasets > Report Data Source Dialog
Show All Show All
Hide All Hide All

You can access the Report Data Source dialog from the Report Explorer by doing one of the following:

  • Click the Add icon on the top left and select Data Source.
  • Right-click the Data Sources node and select Add Data Source.

The Report Data Source dialog provides the following pages where you can set data source properties:

General

The General page of the Report Data Source dialog is where you can set the Name, Type and Connection string of a new data source, or choose to use a shared data source reference.

  • In the Name field, you can enter a name for the data source. This name must be unique within the report. By default, the name is set to DataSource1.
  • In the Shared Reference checkbox, you can select a shared data source reference. See Connect to a Data Source for further information. Once you have chosen the Shared Reference option, the Reference field to select a Shared Data Source becomes available.
  • If the Shared Reference checkbox is clear, you can select a data source type from the Type dropdown field. ActiveReports supports the following providers:
    • Microsoft SQL Client Provider
    • DataSet Provider
    • Microsoft ODBC Provider
    • Microsoft OleDB Provider
    • Object Provider
    • Oracle Client Provider
    • XML Provider
  • You can also select to execute datasets that use this data source in a single transaction by checking the Use Single Transaction checkbox.
  • If you select SQL, OleDB, or Oracle as the data source Type value, the Connection Properties, Connection String and Advanced Settings pages appear under the Connection section. In other data source types, only the Connection String page appears.

    Connection Properties

    The Connection Properties page gives access to properties specific to the following data types.

    SQL

    • Server name: This field requires you to enter a server name.
    • Log on to server: Through this field, you can select whether to use Windows authentication or server authentication which requires a user name and password
    • Connect to a database: Through this field, you can select whether to enter a database name or attach a database file.
    • Below this field you can also check the Save My Password option for future reference.

    OleDB

    • OLE DB Provider: This field requires you to select one among the list of OLE DB Providers provided in the drop down list.
    • Enter a server or file name: This field requires you to enter a server or a file name along with its location.
    • Log on to server: Through this field you can select whether to use Windows NT integrated security or use a specific user name and password.

    Oracle

    • Server name: This field requires you to enter a server name.
    • Log on to server: This field requires you to enter a user name and a password for server authentication.
    • Below this field you can also check the Save My Password option for future reference.

    Connection String

    Enter a connection string in the provided text box, or use the Connection Properties page to create one for SQL, OleDB, or Oracle data types.

    Following is the sample connection string to access the Northwind database in the C directory:

    Sample connection string
    Copy Code
    provider=Microsoft.Jet.OLEDB.4.0;data source=c:\nwind.mdb;

    Advanced Settings

    The Advanced Settings page gives access to properties specific to each data type.

    SQL

    With the SQL data type, the Advanced Settings page gives access to the following properties:

    • Application Name: Indicates the client application name.
    • Auto Translate: Indicates whether the OEM/ANSI characters are converted. You can set this property to True or False. By default, the value is set to True. If True then SQLOLEDB performs the OEM/ANSI character conversion when multi-byte character strings are retrieved from, or sent to, the SQL Server.
    • Current Language: Indicates the SQL Server language name. It also identifies the language used for system message selection and formatting. The language must be installed on the SQL Server, otherwise opening the connection will fail.
    • Network Address: Indicates the network address of the SQL Server, specified by the Location property.
    • Network Library: Indicates the name of the network library (DLL) used to communicate with the SQL Server. The name should not contain the path or the .dll file name extension. The default name is provided by the SQL Server client configuration.
    • Packet Size: Indicates a network packet size in bytes. The Packet Size property value must be between 512 and 32767. By default, the SQLOLEDB network packet size is 4096.
    • Trusted Connection: Indicates the user authentication mode. You can set this property to Yes or No. By default, the property value is set to No. If Yes, the SQLOLEDB uses the Microsoft Windows NT Authentication Mode to authorize user access to the SQL Server database, specified by the Location and Datasource property values. If this property is set to No, then the SQLOLEDB uses the Mixed mode to authorize user access to the SQL Server database. The SQL Server login and password are specified in the User Id and Password properties.
    • Use Procedure for Prepare: Determines whether the SQL Server creates temporary stored procedures when Commands are prepared by the Prepared property.
    • Workstation ID: Denotes a string that identifies the workstation.

    OleDB

    With the OleDB data type, the Advanced Settings page gives access to the Microsoft Jet OLEDB provider-specific connection parameters.

    • Jet OLEDB: Compact Reclaimed Space Amount: Indicates an estimate of the amount of space, in bytes, that can be reclaimed by compacting the database. This value is only valid after a database connection has been established.
    • Jet OLEDB: Connection Control: Indicates whether users can connect to the database.
    • Jet OLEDB: Create System Database: Indicates whether to create a system database when creating a new data source.
    • Jet OLEDB: Database Locking Mode: Indicates the locking mode for this database. The first user to open the database determines what mode to use when the database is open.
    • Jet OLEDB: Database Password: Indicates the database password.
    • Jet OLEDB: Don't Copy Locale on Compact: Indicates whether the Jet should copy locale information when compacting a database.
    • Jet OLEDB: Encrypt Database: Indicates whether a compacted database should be encrypted. If this property is not set, the compacted database will be encrypted if the original database was encrypted.
    • Jet OLEDB: Engine Type: Indicates the storage engine to access the current data store.
    • Jet OLEDB: Exclusive Async Delay: Indicates the maximum length of time, in milliseconds, that the Jet can delay asynchronous writes to disk when the database is opened exclusively. This property is ignored unless Jet OLEDB: Flush Transaction Timeout is set to 0.
    • Jet OLEDB: Flush Transaction Timeout: Indicates the amount of time before data stored in a cache for asynchronous writing is actually written to disk. This setting overrides the values for Jet OLEDB:Shared Async Delay and jet OLEDB: Exclusive Async Delay.
    • Jet OLEDB: Global Bulk Transactions: Indicates whether the SQL bulk transactions are transacted.
    • Jet OLEDB: Global Partial Bulk Ops: Indicates the password to open the database.
    • Jet OLEDB: Implicit Commit Sync: Indicates whether the changes made in internal implicit transactions are written in synchronous or asynchronous mode.
    • Jet OLEDB: Lock Delay: Indicates the number of milliseconds before attempting to acquire a lock after a previous attempt has failed.
    • Jet OLEDB: Lock Retry: Indicates the frequency of attempts to access a locked page.
    • Jet OLEDB: Max Buffer Size: Indicates the maximum amount memory, in kilobytes, the Jet can use before it starts flushing changes to disk.
    • Jet OLEDB: MaxLocksPerFile: Indicates the maximum number of locks the Jet can place on a database. The default value is 9500.
    • Jet OLEDB: New Database Password: Indicates the new password for this database. The old password is stored in Jet OLEDB: Database Password.
    • Jet OLEDB: ODBC Command Time Out: Indicates the number of milliseconds before a remote ODBC query from the Jet will timeout.
    • Jet OLEDB: Page Locks to Table Lock: Indicates how many pages to lock within a transaction before the Jet attempts to promote the lock to a table lock. If this value is 0, then the lock is never promoted.
    • Jet OLEDB: Page Timeout: Indicates the number of milliseconds before the Jet will check if its cache is out of date with the database file.
    • Jet OLEDB: Recycle Long-Valued Pages: Indicates whether the Jet should aggressively try to reclaim BLOB pages when they are freed.
    • Jet OLEDB: Registry Path: Indicates the Windows registry key that contains values for the Jet database engine.
    • Jet OLEDB: Reset ISAM Stats: Indicates whether the schema Recordset DBSCHEMA_JETOLEDB_ISAMSTATS should reset its performance counters after returning performance information.
    • Jet OLEDB: Shared Async Delay: Indicates the maximum amount of time, in milliseconds, the Jet can delay asynchronous writes to disk when the database is opened in the multi-user mode.
    • Jet OLEDB: System Database: Indicates the path and file name for the workgroup information file (system database).
    • Jet OLEDB: Transaction Commit Mode: Indicates whether the Jet writes data to disk synchronously or asynchronously when a transaction is committed.
    • Jet OLEDB: User Commit Sync: Indicates whether changes made in transactions are written in the synchronous or the asynchronous mode.
    Note: You can see the description of each property at the bottom of the dialog when the property is selected. To provide more room for longer descriptions, drag the grab handle above the description.

Credentials

The Credentials page gives you the following four options for the level of security you need for the data in your report.

Use Windows Authentication

Select this option when you know that any users with a valid Windows account are cleared for access to the data, and you do not want to prompt them for a user name and password.

Use a specific user name and password

Select this option when you want to allow only a single user name and password to access the data in the report.

Prompt for credentials

Select this option when there is a subset of users who can access the data. The Prompt string textbox allows you to customize the text requesting a user name and password from users.

No credentials

Select this option only if the data in the report is for general public consumption.

See Also
Shared Data Sources


DataSet Dialog

DataSet Dialog
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Sources and Datasets > DataSet Dialog
Show All Show All
Hide All Hide All

You can access the DataSet dialog from the Report Explorer by doing one of the following:

  • With the Data Source node (like DataSource1) selected, click the Add icon on the top left and select Data Set.
  • Right-click an existing data source and select Add Data Set.

The DataSet dialog provides the following pages where you can set dataset properties:

General

The General page of the DataSet dialog is where you can set the Name of the dataset.

Name: In the Name field, you can enter a name for the dataset. By default, the name is set to DataSet1. The name of the dataset appears in the tree view of the Report Explorer. It is also used to call the dataset in code so it should be unique within the report.

Query

The Query page of the DataSet dialog is where you set the SQL query, stored procedure or table to define the data you want to fetch in the dataset of your report.

Command type: You can choose from the three enumerated command types.

Type | Description
Text | Choose Text if you want to write a SQL query to retrieve data.
StoredProcedure | Choose StoredProcedure if you want to use a stored procedure.
TableDirect | Choose TableDirect if you want to return all rows and columns from one or more tables.

Query: Based on the command type you select above, you can set the query string in this field.

Note: If you select the TableDirect command type, you may need to use escape characters or qualifying characters in case any of the table names include special characters.

Timeout: You can set the number of seconds that you want the report server to wait for the query to return the data before it stops trying.

Options

The Options page is where you select one of the various options available to the dataset.

CaseSensitivity: Set this value to Auto, True, or False to indicate whether to make distinctions between upper and lower case letters. Auto, the default value, causes the report server to get the value from the data provider. If the data provider does not set the value, the report runs without case sensitivity.

Collation: Choose from Default or a country from the list to indicate which collation sequence to use to sort data. The Default value causes the report server to get the value from the data provider. If the data provider does not set the value, the report uses the server locale. This is important with international data, as the sort order for different languages can be different from the machine sort.

KanaTypeSensitivity: Set this value to Auto, True, or False with Japanese data to indicate whether distinctions are made between Hiragana and Katakana kana types. Auto, the default value, causes the report server to get the value from the data provider. If the data provider does not set the value, the report runs without kana type sensitivity.

WidthSensitivity: Set this value to Auto, True, or False with Japanese data to indicate whether distinctions are made between single-byte (half-width) characters and double-byte (full-width) characters. Auto, the default value, causes the report server to get the value from the data provider. If the data provider does not set the value, the report runs without width sensitivity.

AccentSensitivity: Set this value to Auto, True, or False to indicate whether distinctions are made between accented and unaccented letters. Auto, the default value, causes the report server to get the value from the data provider. If the data provider does not set the value, the report runs without accent sensitivity.

Fields

The Fields page of the Dataset dialog populates automatically for OleDb, ODBC, SQL and Oracle data providers. To see list of fields in the Name and Value columns of the Fields page, enter a valid query, table name, or stored procedure on the Query page.

You can edit the populated fields, delete them by using the Remove (X) icon, or add new ones by using the Add (+) icon above the Fields list. Any fields you add in this list show up in the Report Explorer tree view and you can drag and drop them onto the design surface. The field name must be unique within the dataset.

When working with Fields, the meaning of the value varies depending on the data source type. In most cases this is simply the name of the field. The following table describes the meaning of the field value and gives some examples of how to use the value.

Data Provider | Description | Example
SQL, Oracle, OleDb | The field value is the name of a field returned by the query. | OrderQuantity FirstName
Dataset | The field value can be the name of a field in the DataTable specified by the query. You can also use DataRelations in a DataSet, specify the name of the relation followed by a period and then the name of a field in the related DataTable. | Quantity OrdersToOrderDetails.CustomerID
XML | The field value is an XPath expression that returns a value when evaluated with the query. | ./OrderQuantity ../OrderInfo/OrderDate
Object | The field value can be the name of a property of the object contained in the collection returned by the data provider. You may also use properties available for the object returned from a property. | Quantity Order.Customer.FirstName

Parameters

The Parameters page of the Dataset dialog is where you can pass a Report Parameter into the parameter you enter in the Query page. Enter a Name that matches the name of the Report Parameter and a Value for each parameter in this page.

  • You can edit the parameters by selecting a parameter in the list and editing its Name and Value.
  • You can delete the parameters by using the Remove (X) icon above the Parameters list.
  • You can add new parameters by using the Add (+) icon above the Parameters list. The parameter name must be unique within the dataset.

The Value of a parameter can be a static value or an expression referring to an object within the report. The Value cannot refer to a report control or field.

Filters

The Filters page of the Dataset dialog allows you to filter data after it is returned from the data source. This is useful when you have a data source (such as XML) that does not support query parameters.

A filter is composed of three fields:

Expression: Type or use the expression editor to provide the expression on which to filter data.

Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right:

  • Equal Only choose data for which the value on the left is equal to the value on the right.
  • Like Only choose data for which the value on the left is similar to the value on the right. For more information on using the Like operator, see the MSDN Web site.
  • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
  • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
  • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
  • LessThan Only choose data for which the value on the left is less than the value on the right.
  • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
  • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
  • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
  • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
  • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
  • In Only choose items from the value on the left which are in the array of values specified on the right.
    Selecting this operator enables the Values list at the bottom.
  • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

Values: When you choose the In operator, you can enter as many values as you need in this list.

See Also
Report Data Source Dialog
Data Sources and Datasets

How To

Add a Dataset


Shared Data Sources

Shared Data Sources
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Shared Data Sources
A shared data source contains a set of data source connection properties that are referenced by multiple reports. In ActiveReports, a shared data source refers to a file in RDSX format that contains data connection information. RDSX (Report Data Source XML) is a proprietary file format that functions as a data source for a single report or multiple reports.

  • Advantages of a Shared Data Source
  • Accessing the Server Shared Data Sources dialog
  • Elements of the Server Shared Data Sources dialog
  • Elements of the Server Shared Data Source dialog
  • Create a Shared Data Source
  • Edit a Server Shared Data Source

Advantages of a Shared Data Source

  • The data connection is reusable so you can use it in multiple reports.
  • The information is saved in a separate file in RDSX format that you can access from any report, move to different folders, or rename.
  • It provides one place to update the connection for all reports referencing it.
  • It supports any data type connection.

There are two types of Shared Data Source in ActiveReports.

Local Shared Data Sources

The local shared data sources are embedded in the application resources or shared through a file system. Local shared data sources can be used in Page or RDL reports. See Create and Edit a Shared Data Source for information on how to create a shared data source or modify an existing one.

Server Shared Data Sources

Server shared data sources allow the administrator to create and control access to data sources that are hosted on an instance of ActiveReports Server. You can reference server shared data sources using the DataSourceReference element in Page or RDL reports that are stored and run in ActiveReports Server.

Note: Server Shared Data Sources feature is only available with Professional Edition license.

It is beneficial to use server shared data sources when working with multiple reports referencing the same data. For example, if there is a change in connection properties such as, server name, database name, etc., in case of local shared data sources, you need to open each report and update the connection properties individually. Whereas for reports using the server shared data source, the change is only required in one place.

Accessing the Server Shared Data Sources dialog

You can access the Shared Data Source option from the stand-alone designer or the Visual Studio designer. In order to access the server shared data sources, make sure you are connected to ActiveReports Server. See Connecting to ActiveReports Server for further information.

In the Stand-Alone Designer

Access the Server Shared Data Sources dialog from the Server menu of the stand-alone designer.

In the Visual Studio Designer

Access the Server Shared Data Sources dialog from the Report menu (Report > Server > Edit Shared Data Sources) of the Visual Studio designer.

Elements of the Server Shared Data Sources dialog

The dialog appears when you click the Shared Data Sources option from the Server menu of the stand-alone designer or Report menu of the Visual Studio designer. Using the options available in this dialog, you can add, edit or refresh a server shared data source.

The Server Shared Data Sources dialog consists of the following elements:

Elements | Description
Add | Opens the Server Shared Data Source dialog, where you can create a new data source using the specified properties for each data type.
Edit | Allows you to modify the data source properties of the selected data source.
Refresh | Allows you to refresh the list of data sources on ActiveReports Server.

Elements of the Server Shared Data Source dialog

This dialog appears when you click the Add button on the Server Shared Data Sources dialog. Using the options available in this dialog, you can modify connection properties for each data source type.

Following are the properties corresponding to each data type.

Data Source Type | Property Names | Property Description
Microsoft Sql Client Provider | Name | Enter a name for the data source. This name must be unique within the server.
Description

Allows you to provide a description related to the data source connection.
Server Name | Enter a SQL server name or URL.
Database Name | Enter the name of the database you want to connect.
Use Windows Authentication | Select this option when you know that any users with a valid Windows account are cleared for access to the data, and you do not want to prompt them for a user name and password.
Use Server Authentication | Select this option to enter a user name and password for server authentication.
User Name | Enter the username to access the database.
Password | Enter the password to log in to the database.
Connection String In the Connection String tab, enter a connection string for the data source. The Connection String box displays the connection information based on your server and database connection.

Sample Microsoft Sql Connection String

data source=in-data-sql\sql_2012;initial catalog=ADventurewORKS2012;user id=user1;password=password@123
Test connection | Click to verify that the data source connection works using the specified credentials. If the test fails, verify the credentials and server availability.
Oracle Client Provider | Name | Enter a name for the data source. This name must be unique within the server.
Description | Allows you to provide a description related to the data source connection.
Server Name | Specify the name of the Oracle server.
User Name | Enter the username to access the database.
Password | Enter the password to log in to the database.
Connection String In the Connection String tab, enter a connection string for the data source. The Connection String box displays the connection information based on your server and database connection.

Sample Oracle Connection String

provider=ORACLE;data source=in-data-sql/orcl.grapecity.net;user id=user1;password=password@123;
Test connection | Click to verify that the data source connection works using the specified credentials. If the connection cannot be made, you need to verify your credentials and the server availability.
Microsoft OleDb Provider

Microsoft Odbc Provider

Xml Provider 		Name Enter a name for the data source. This name must be unique within the server.
Description | Allows you to provide a description related to the data source connection.

Connection String

Enter a connection string for the data source. The Connection String box displays the connection information based on your server and database connection.
Following are the sample connection strings for the specified data source type.

Sample OleDb Connection String

provider=Microsoft.ACE.OLEDB.12.0;data source=c:\nwind.mdb;

Sample Odbc Connection String

Driver=Microsoft Access Driver (*.mdb);Dbq=C:\nwind.mdb;

Sample Xml Connection String

  • XmlDoc: Refers to a specific XML file located on either the file system or at a web-accessible location. For example, XmlDoc=C:\MyXmlFile.xml;
  • XmlData: Provides specific XML data in the Connection String itself. For example,
    XmlData=<people>
      <person>
        <name>
          <given>John</given>
          <family>Doe</family>
        </name>
      </person>
      <person>
        <name>
          <given>Jane</given>
          <family>Smith</family>
        </name>
      </person>
    </people>;
  • TransformationDoc: Refers to a specific XSLT file to apply to the XML data.
Test connection | Click to verify that the data source connection works using the specified credentials. If the connection cannot be made, you need to verify your credentials and the server availability.

ActiveReports allows ActiveReports Server administrator to work with server shared data sources that are hosted on an instance of ActiveReports Server. The following section explains how the administrator can add or edit server shared data sources using the Server Shared Data Source dialog.

Create a Shared Data Source

  1. Access the Server Shared Data Sources dialog from the stand-alone designer or the Visual Studio designer. See Accessing Server Shared Data Source dialog for more details.
  2. Connect to ActiveReports Server, if you are not already connected to the server. See Connecting to ActiveReports Server for further information.
  3. In the Server Shared Data Sources dialog that appears, click Add to create a new data source connection.
  4. In the Server Shared Data Source dialog that appears, select Data Source Type from the drop-down list. Once you select the Data Source Type, properties corresponding to that data type are listed below.
  5. Set the properties or enter a connection string to create a data source connection. See Server Shared Data Source dialog for further details.

    SharedDataSources
  6. Click the Test Connection button to see if you have successfully connected to the database.
  7. Click Save to save the data source connection properties and return to Server Shared Data Sources dialog.

Edit a Server Shared Data Source

  1. Access the Server Shared Data Sources dialog from the stand-alone designer or the Visual Studio designer. See Accessing Server Shared Data Source dialog for details.
  2. Connect to ActiveReports Server, if you are not already connected to the server. See Connecting to ActiveReports Server for further information.
  3. In the Server Shared Data Sources dialog that appears, select the data source from the list of data sources, and then click Edit.
  4. In the Server Shared Data Source dialog that appears, edit the data source connection properties.
  5. Click Save to save the updated data source connection properties and return to Server Shared Data Sources dialog.
See Also
Server Shared Data Sets
ActiveReports Server


Server Shared Data Sets

Server Shared Data Sets
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Server Shared Data Sets

ActiveReports provides you with the ability to create and access data sets that are hosted on an instance of ActiveReports Server. Server shared data sets retrieve data from shared data sources and these data sets can be used in multiple Page or RDL reports.

Using shared data sets, you can update the data set options from one location. For example, if you have multiple reports that use the same shared data set, you only need to update the data set options in one place.

  • Elements of Server Shared Data Sets dialog
  • Create a Shared Data Set
  • Edit a Server Shared Data Set

Accessing Server Shared Data Sets dialog

You can access the Shared Data Sets option from the stand-alone designer or the Visual Studio designer. In order to access the server shared data sets, make sure you are connected to ActiveReports Server. See Connecting to ActiveReports Server for further information.

In the Stand-Alone Designer

Access the Server Shared Data Sets dialog from the Server menu of the stand-alone designer.

In the Visual Studio Designer

Access the Server Shared Data Sets dialog from the Report menu (Report > Server> Edit Shared Data Sets) of the Visual Studio designer.

Elements of Server Shared Data Sets dialog

The dialog appears when you click the Shared Data Sets option from the Server menu of the stand-alone designer or the Report menu of the Visual Studio designer. Using the options available in this dialog, users can add, edit or refresh a server shared data set. Operations such as deleting and granting permissions for shared data set can be performed from the Administrator dashboard. For more information, see Managing Data Sets.

Server Shared Data Sets dialog consists of the following elements:

Elements | Description
Add | Opens the Server Shared Data Set dialog, that allows users to create a new data set based on the available options for server shared data sets.
Edit | Allows users to modify the data set properties of the selected data set.
Refresh | Allows users to refresh the list of data sets on ActiveReports Server.

ActiveReports allows the ActiveReports Server administrator to work with server shared data sets that are hosted on an instance of ActiveReports Server. This section explains how the administrator can add or edit shared data sets using the Server Shared Data Set dialog.

Create a Shared Data Set

  1. Access the Server Shared Data Sets dialog from the stand-alone designer or the Visual Studio designer. See Accessing Server Shared Data Set dialog for more details.
  2. Connect your stand-alone designer to ActiveReports Server, if you are not already connected to the server. See Connecting to ActiveReports Server for further information.
  3. In the Server Shared Data Sets dialog that appears, click Add to create a new data set.
  4. On the General tab of this dialog, select the Data Source from the drop-down list box, and then enter a name for the data set. For example, Reels Data Source.

    You can also choose from the following options available on General page.

    Property Names Property Description
    Data Source

    Select a server data source from the drop-down list box. See Server Shared Data Sources, for more information.
    Name

    Specify a name for the Server Data Set.
    Description

    Provide a description related to the data set. The description for shared data set is optional.
  5. Next on the Query tab of this dialog, select a Command Type from the drop-down list box. For example, select Text and enter Select *from Movie in the query box.

    You can also choose from the following options available on Query page.

    Property Names | Property Description
    Query | Set the query string based on the selected command type.
    Edit | Open the Visual Query Designer to create SQL queries. For more information, see Visual Query Designer.
    Validate | Validate the query.
    Command Type You can choose from the three enumerated command types.
    Text - Choose Text if you want to write a SQL query to retrieve data.
    StoredProcedure - Choose StoredProcedure if you want to use a stored procedure.
    TableDirect - Choose TableDirect if you want to return all rows and columns from one or more tables.
  6. Click the Validate button to validate the query.
  7. Next on the Options tab of this dialog, click the Case sensitivity drop down box, and then select True to make distinctions between upper and lower case letters.

    You can also choose from the following options available on Options page.

    Property Names | Property Description
    CaseSensitivity | Set this value to Auto, True, or False to indicate whether to make distinctions between upper and lower case letters. Auto, the default value, causes the report server to get the value from the data provider. If the data provider does not set the value, the report runs without case sensitivity.
    Collation | Choose from Default or a country from the list to indicate which collation sequence to use to sort data. The Default value causes the report server to get the value from the data provider. If the data provider does not set the value, the report uses the server locale. This is important with international data, as the sort order for different languages can be different from the machine sort.
    KanaTypeSensitivity | Set this value to Auto, True, or False with Japanese data to indicate whether distinctions are made between Hiragana and Katakana kana types. Auto, the default value, causes the report server to get the value from the data provider. If the data provider does not set the value, the report runs without kana type sensitivity.
    WidthSensitivity | Set this value to Auto, True, or False with Japanese data to indicate whether distinctions are made between single-byte (half-width) characters and double-byte (full-width) characters. Auto, the default value, causes the report server to get the value from the data provider. If the data provider does not set the value, the report runs without width sensitivity.
    AccentSensitivity | Set this value to Auto, True, or False to indicate whether distinctions are made between accented and unaccented letters. Auto, the default value, causes the report server to get the value from the data provider. If the data provider does not set the value, the report runs without accent sensitivity.
  8. Next on the Fields tab of this dialog, you can Add or Delete a field according to your requirements in your data set.

    You can also choose from the following options available on Fields page.

    Property Names | Property Description
    Fields | Displays a list of fields in the Fields box. To see the fields in the field box, enter a valid query, table name, or stored procedure on the Query page. For more information, see Use Fields in Reports.
    Add | Create a new field in the data set.

    Delete

             Remove the selected field from a data set.
    Name | Specify a name for the field.
    Value | Enter a value for the field or create an expression using the expression editor to determine the value.
  9. Similarly on the Parameters tab of this dialog, you can Add or Delete a parameter according to your requirements in your data set. See Parameters, for more information.

    You can also choose from the following options available on Parameters page.

    Property Names | Property Description
    Name | Set a name for the parameter in this field. The value you supply here appears in the parameters list and must match the corresponding query parameter.
    Data type Set the data type for the parameter which must match the data type of the field that it filters. The interface presented might also differ depending on the data type.
    • Boolean: Presents the user with two options True or False
    • DateTime: Presents the user with a calendar picker to select a date and a time picker to select the time in cases where you do not supply a default value or a drop-down selection of available values
    • Integer: Presents the user with a text box or a drop-down selection of available values
    • Float: Presents the user with a text box or a drop-down selection of available values
    • String: Presents the user with a text box or a drop-down selection of available values.

    Prompt

             Enter the text you want to see on the user interface to request information from the user in this field. By default this is the same as the Name property.
    Name | Specify the name of the field.
    Multivalue | Select this check-box to allow the user to select multiple items in the available values list.
    Multiline | Select this check-box to allow multiline values in the parameter. The control automatically adjusts to accommodate multiple lines.
    Hidden | Select this check-box to hide the parameter interface from the user and instead provide a default value or pass in values from a subreport or drill-through link. Please note that if you hide the user interface and do not provide a default value, the report will not run.
    Allow null value | Select this check-box if you want to allow null values to be passed for the parameter. It is not selected by default.
    Allow blank value | Select this check-box if you want to allow blank values to be passed for the parameter. It is not selected by default.

  10. Next on the Filters tab of this dialog, click Add to add a new filter for the data set. By default, an empty filter expression gets added to the filter list.
    You can also choose from the following options available on Filters page.

    Property Names | Property Description
    Add | Create a new filter for the data set.
    Delete | Remove a filter from the data set.

    Expression

             Type or use the expression editor to provide the expression on which to filter data.
    Operator | Select a operator from the drop-down box to compare the expression. See Operator options, for further information.
    Value | Enter a value to compare with the expression based on the selected operator.
  11. Under Expression, enter an valid expression or use the Expression Editor to provide an expression on which to filter your data. For example, =Fields!YearReleased.Value
  12. Under Operator, select an operator from the list to decide how to compare the Expression with the value. For example, set a GreaterThan operator on the Expression above.
  13. Under Value, enter a value or set an expression using the Expression Editor with which to compare the expression results. For example, 2000 to represent the year 2000.
  14. Click Save to add the shared data set to the server. The shared data set appears in the Server Shared Data Sets dialog and can be used while designing reports.

Edit a Server Shared Data Set

  1. Access the Server Shared Data Sets dialog from the stand-alone designer or the Visual Studio designer. See Accessing Server Shared Data Set dialog for more details.
  2. Connect your stand-alone designer to the ActiveReports Server if you are not already connected to the server. See Connecting to ActiveReports Server for further information.
  3. In the Server Shared Data Sets dialog that appears, select a data set from the list, and then click Edit.
  4. In the Server Shared Data Set dialog that appears, edit the data set properties with the help of this dialog.
  5. Click Save to update the data set properties and return to Server Shared Data Sets dialog.
See Also
Shared Data Sources
ActiveReports Server


Expressions

Expressions
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Expressions
Show All Show All
Hide All Hide All

In ActiveReports, you can use an expression to set the value of a control in the report, or set conditions under which certain styles apply. You can set Microsoft Visual Basic® .NET in expressions through

  • Properties in the properties window
  • Expression Editor dialog

All expressions begin with an equal sign (=). Even the expression for a field value for a TextBox is set as follows:
=Fields!LastName.Value

Expression Editor Dialog

You can build expressions quickly using the Expression Editor dialog. This dialog allows you to choose from a number of fields available to the report as well as to a particular property. You can access the Expression Editor by selecting nearly any property of a control and choosing <Expression...> from the drop-down list.

There are seven types of fields available in the Expression Editor:

  • Constants
    Constants available for properties which have enumerated values such as TextDecoration or BorderStyle.
  • Common Values
    Run time values available to every property in every report. There are two variables in this list which come from the User collection: User ID and User Language. See Common Values for further information.
  • Parameters
    Parameters fields available in reports which contain report parameters. If available, you can choose a parameter from this field to retrieve the current value of the parameter.
  • Fields (DataSet name)
    All fields from a dataset which is linked to the report control.
  • Datasets
    All fields in each dataset associated with the report. However, the report retrieves only the sum or the first value of any field that is not within the current dataset scope.
  • Operations
    Arithmetic, comparison, concatenation, logical/bitwise, bit shift operators for creating custom expressions.
  • Common Functions
    Predefined Visual Basic .NET functions for which ActiveReports provides intrinsic support. See Common Functions for more information.

To create an Expression in the Expression Editor

The Expression Editor dialog is composed of two panes, Fields and Expression.

  • From the Fields pane, select a field you want to use in your expression.
  • Click the Replace, Insert or Append button to add the field to the Expression pane. The expression pane shows the fields in a valid expression format.
  • Click OK to close the dialog.

The expression appears as the property value in the properties grid.

Tip: While building an expression, you can directly add the entire expression or part of it in the Expression pane of the Expression Editor. Then use the Insert or Append buttons to create a complete expression.

Using Expressions in Reports

In the raw form, your data may not be ideally suited for display in a report. You can customize it and bring it into shape using expressions. Following are some examples of how expressions are set in different scenarios.

Concatenating Fields and Strings

You can concatenate fields with strings and with other fields. For e.g., use the following expression to get a result like Customer Name: Bossert, Lewis.

="Customer Name: " & Fields!LastName.Value & "," & Fields!FirstName.Value

Conditional Formatting

You can use expressions in properties like Color, Font, Border etc. on specific field values based on a condition, to highlight a part of data. The formula for conditional formatting is:
=iif( Fields!YourFieldName.Value operator "Value to compare", "If condition is met, use this value.", "If not, use this one."

For e.g., if you enter the following expression in the Font > FontWeight property of a textbox that displays names of people, you get the name "Denise" in bold.

=iif(Fields!FirstName.Value = "Denise", "Bold", "Normal")

Functions

You can use a number of aggregate and other functions in your expressions. ActiveReports includes a range of functions, including running value, population standard variance, standard deviation, count, minimum and maximum. For e.g., use the following expression to get a count of employees.

=Count(Fields!EmployeeID.Value, Nothing)

Displaying Expressions at Design Time

As you design the report, the full text of an expression can get very long. ActiveReports makes expressions easier to read by shortening them.

When an expression is in the form:
=Fields!<FieldName>.Value

On the design surface, you see this text inside that TextBox:
=[<FieldName>]

Double-click the TextBox to view the full expression in edit mode.

For aggregates too, when the Expression value is:
=<Aggregate>(Fields!<FieldName>.Value)

On the design surface, you see this text inside the TextBox:
=<Aggregate>([<FieldName>])

This shortened expression value is only a visual change to allow you to see the field name easily. It shows up in both the TextBox on the design surface as well as any dropdown boxes inside the dialogs.

Note: You can type the format as listed above for either field name values or aggregates on field names. This evaluates the full expression when the report is viewed.

Besides the shorthand for field names, you can also type shorthand like [@Param] for parameters and [&Value] for Globals such as [&PageNumber] on the design surface. Please note that you cannot use shorthand in the Expression Editor.

See Also
Common Values
Common Functions


Common Values

Common Values
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Expressions > Common Values

Common Values are run time values available to every property in every report. You can directly drag and drop these common values from the Report Explorer onto the design surface or add and modify the values from the Expression Editor. Following is a list of the values that you can see under the Common Values node in the Report Explorer and the Expression Editor.

Value | Description | Expression
Page N of M | Gets both the current page and the total number of pages in the report. | ="Page " & Globals!PageNumber & " of" & Globals!TotalPages
Page N of M (Section) | Gets both the current page and the total number of pages in the report section. | ="Page " & Globals!PageNumberInSection & " of " & Globals!TotalPagesInSection
Page N of M (Cumulative) | Gets both the current page and the total number of cumulative pages in a report. | ="Page " & Globals!CumulativePageNumber & " of " & Globals!CumulativeTotalPages
Current Date and Time | Gets the date and time when the report began to run. | =Globals!ExecutionTime
User ID | Gets the machine name/user name of the current user. | =User!UserID
Page Number | Gets the current page number in the report. | =Globals!PageNumber
Page Number (Section) | Gets the current page number in the report section. | =Globals!PageNumberInSection
Total Pages | Gets the total number of pages in the report. | =Globals!TotalPages
Total Pages (Section) | Gets the total number of pages in the report section. | =Globals!TotalPagesInSection
Cumulative Page Number | Gets the current cumulative page number. | =Globals!CumulativePageNumber
Cumulative Total Pages | Gets the total number of cumulative pages in the report. | =Globals!CumulativeTotalPages
Report Folder | Gets the name of the folder containing the report. | =Globals!ReportFolder
Report Name | Gets the name of the report. | =Globals!ReportName
User Language | Gets the language settings of the current user. | =User!Language
Note: Page N of M (Section), Page Number (Section) or Total Pages (Section) is applied to page numbering when you set grouping in a report. Each section represents a group, not to be confused with sections in a section report.
Note: Page N of M (Cumulative), Page Number (Cumulative) or Total Pages (Cumulative) is applied to page numbering when you use collation in a report.
See Also
Expressions


Common Functions

Common Functions
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Expressions > Common Functions
Show All Show All
Hide All Hide All

You can use a function in an expression to perform actions on data in data regions, groups and datasets. You can access these functions in the Expression Editor dialog. In any property that accepts expressions, you can drop down the property and select <Expression...> to open the dialog.

Within the Expression Editor dialog, there is a tree view of Fields. Expand the Common Functions node to view the available functions. The following tables contain details about each of the functions included in ActiveReports for use in property expressions.

Date & Time

These are all methods from the DateAndTime class in Visual Basic. Please see the msdn DateAndTime Class topic for information on overloads for each method.

  • DateAdd
  • DateDiff
  • DatePart
  • DateSerial
  • DateString
  • DateValue
  • Now
  • Today
  • Day
  • Hour
  • Minute
  • Month
  • MonthName
  • Second
  • TimeSerial
  • TimeValue
  • TimeOfDay
  • Timer
  • TimeString
  • Weekday
  • WeekdayName
  • Year

Math

These are all methods and fields from the System.Math class. Please see the msdn Math Class topic for information on overloads for each method.

  • Abs
  • Acos
  • Asin
  • Atan
  • Atan2
  • BigMul
  • Ceiling
  • Cos
  • Cosh
  • E
  • Exp
  • Fix
  • Floor
  • IEEERemainder
  • Log
  • Log10
  • Max
  • Min
  • PI
  • Pow
  • Round
  • Sign
  • Sin
  • Sinh
  • Sqrt
  • Tan
  • Tanh

Inspection

These are all methods from the Information class in Visual Basic. Please see the msdn Information Class topic for more information.

  • IsArray
  • IsDate
  • IsDBNull
  • IsError
  • IsNothing
  • IsNumeric

Program Flow

These are all methods from the Interaction class in Visual Basic. Please see the msdn Interaction Class topic for more information.

  • Choose
  • IIf
  • Switch
  • Partition

Aggregate

You can use aggregate functions within report control value expressions to accrue data. ActiveReports supports aggregate functions from RDL 2005, plus some proprietary extended set of functions. For all of the functions, you can add an optional <Scope> parameter.

These are all the available aggregate functions:

Function | Description | Example
AggregateIf | Decides whether to calculate a custom aggregate from the data provider of the values returned by the expression based on a Boolean expression. | =AggregateIf(Fields!Discontinued.Value=True, Sum, Fields!InStock.Value)
Avg | Calculates the average of the non-null values returned by the expression. | =Avg(Fields!Cost.Value, Nothing)
Count | Calculates the number of non-null values returned by the expression. | =Count(Fields!EmployeeID.Value, Nothing)
CountDistinct | Calculates the number of non-repeated values returned by the expression. | =CountDistinct(Fields!ManagerID.Value, "Department")
CountRows | Calculates the number of rows in the scope returned by the expression. | =CountRows("Department")
CumulativeTotal | Calculates the sum of page-level aggregates returned by the expression for current and previous pages. | =CumulativeTotal(Fields!OrderID.Value, Count)
DistinctSum | Calculates the sum of the values returned by an expression using only the rows when the value of another expression is not repeated. | =DistinctSum(Fields!OrderID.Value, Fields!OrderFreight.Value, "Order")
First | Shows the first value returned by the expression. | =First(Fields!ProductNumber.Value, "Category")
Last | Shows the last value returned by the expression. | =Last(Fields!ProductNumber.Value, "Category")
Max | Shows the largest non-null value returned by the expression. | =Max(Fields!OrderTotal.Value, "Year")
Median | Shows the value that is the mid-point of the values returned by the expression. Half of the values returned will be above this value and half will be below it. | =Median(Fields!OrderTotal.Value)
Min | Shows the smallest non-null value returned by the expression | =Min(Fields!OrderTotal.Value)
Mode | Shows the value that appears most frequently in the values returned by the expression. | =Mode(Fields!OrderTotal.Value)
RunningValue | Shows a running aggregate of values returned by the expression (Takes one of the other aggregate functions as a parameter), | =RunningValue(Fields!Cost.Value, Sum, Nothing)
StDev | Calculates the dispersion (standard deviation) of all non-null values returned by the expression. | =StDev(Fields!LineTotal.Value, "Order")
StDevP | Calculates the population dispersion (population standard deviation) of all non-null values returned by the expression. | =StDevP(Fields!LineTotal.Value, "Order")
Sum | Calculates the sum of the values returned by the expression. | =Sum(Fields!LineTotal.Value, "Order")
Var | Calculates the variance (standard deviation squared) of all non-null values returned by the expression. | =Var(Fields!LineTotal.Value, "Order")
VarP | Calculates the population variance (population standard deviation squared) of all non-null values returned by the expression. | =VarP(Fields!LineTotal.Value, "Order")

Conversion

These are all methods from the Convert class in the .NET Framework. Please see the msdn Convert Class topic for more information.

  • ToBoolean
  • ToByte
  • ToDateTime
  • ToDouble
  • ToInt16
  • ToInt32
  • ToInt64
  • ToSingle
  • ToUInt16
  • ToUInt32
  • ToUInt64

Miscellaneous

ActiveReports also offers several functions which do not aggregate data, but which you can use with an IIf function to help determine which data to display or how to display it.

The first four are miscellaneous functions from the RDL 2005 specifications. Please see the msdn Built-in Functions for ReportViewer Reports topic for more information. GetFields is a proprietary function to extend RDL specifications.

Function Description Syntax and Example
InScope Determines whether the current value is in the indicated scope.
=InScope(<Scope>)
=InScope("Order")
Level Returns the level of the current value in a recursive hierarchy.
=Level(optional <Scope>)
=Level()
Previous Returns the previous value within the indicated scope.
=Previous(<Expression>)
=Previous(Fields!OrderID.Value)
RowNumber Shows a running count of all the rows in the scope returned by the expression.
=RowNumber(optional <Scope>)
=RowNumber()
GetFields

Returns an IDictionary<string,Field> object that contains the current contents of the Fields collection. Only valid when used within a data region. This function makes it easier to write code that deals with complex conditionals. To write the equivalent function without GetFields() would require passing each of the queried field values into the method which could be prohibitive when dealing with many fields.

=GetFields()
=Code.DisplayAccountID(GetFields())
Custom function. Paste in the Code tab.
Copy Code
'Within the Code tab, add this function.
Public Function DisplayAccountID( flds as Object) as Object
  If flds("FieldType").Value = "ParentAccount" Then
    Return flds("AccountID").Value
  Else
    Return flds("ParentAccountID").Value
  End If
End Function

Scope

All functions have a Scope parameter which determines the grouping, data region, or dataset to be considered when calculating the aggregate or other function. Within a data region, the Scope parameter's default value is the innermost grouping to which the report control belongs. Alternately, you can specify the name of another grouping, dataset, or data region, or you can specify Nothing, which sets it to the outermost data region to which the report control belongs.

The Scope parameter must be a data region, grouping, or dataset that directly or indirectly contains the report control using the function in its expression. If the report control is outside of a data region, the Scope parameter refers to a dataset. If there is only one dataset in the report, you can omit the Scope parameter. If there are multiple datasets, you must specify which one to use to avoid ambiguity.

Note: You cannot set the Scope parameter to Nothing outside of a data region.
See Also
Expressions

How To

Data Visualizers


Layers

Layers
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Layers
  • What are Layers?
  • Why Use Layers?
  • Other Advantages

What are Layers?

Layers can be understood as a named group of controls. You can lock or unlock, add or remove, show or hide these groups of controls. When you create a new report, a Default Layer is automatically added to it.

Layers are supported in the following types of reports:

  • Page Report
  • Rdl Report

Why Use Layers?

You can trace the layout of a pre-printed form accurately using Layers. This feature is useful where you use the scanned copy of the form to trace that you can place on one Layer and you want use it to print.

Let us understand this concept with an example of a school diploma certificate. The requirement is to print the name of graduating students on a pre-printed school diploma certificates. We already have a set format for this certificate and a list of names in our data base that need to be printed at the correct location on the certification in the correct style.

Step1: Scan a copy of the school diploma certificate.

The scanned image is placed on a Layer and acts as the base image to identify the location where the name is to be placed.

As a best practice, avoid placing images of pre-printed forms on the Default Layer because this Layer cannot be deleted. Instead, create a new Layer to place the scanned image so that you can delete the Layer if you want to remove the scanned image from the background.

The Layer with the image of a pre-printed form is now ready for tracing.

Step 2: Trace a field that contains the names of graduating students.

On the Default Layer, place a TextBox control that is bound to a list of graduating students on the report designer. Placing the StudentName field at the accurate location becomes easy with the scanned image Layer displayed in the background.

Step 3: Printing the names of graduating students on the school diploma certificate.

Now, that the field has been placed at the correct location and bound to a list of student names, the last step is to print the names on the actual certificates.

Assuming that pre-printed certificates are already placed in the printer, the image Layer that contains the scanned certificate image need not be printed. This can be done using the TargetDevice property in Layers.

The TargetDevice property applies to each layer separately and you can choose from screen, paper, export, all or none options. See View, Export or Print Layers for further details. For this example, set the TargetDevice property of Default Layer to Paper for printing the name field on pre-printed certificates.

In this scenario, Layers are used to trace the layout of a field on a pre-printed certificate.

However, Layers are useful in some other scenarios as well.

Other Advantages

Creating Template Reports

Leverage the advantage of Layers in scenarios where you do not want to make changes to an existing report but want to perform minor modifications to the layout.

With Layers, it is possible to make modifications to the same report without changing the original report layout. Let's take an example of a sales receipt to see how Layers can help in this scenario.

Illustrative Example

The requirement is that a hard copy of the report is printed with a Customer Copy watermark and the soft copy of the same report is exported in a PDF format with a Merchant Copy watermark.

Lock the Default Layer to use the original sales receipt report as a template. This step is necessary to make sure that the existing layout of the template report is not modified while making changes or adding controls to the layout. Please see Working with Layers for details on how to lock a Layer.

Add two Layers on the existing report template, one for the Customer Copy watermark image and the other for the Merchant Copy watermark image. Set the TargetDevice property of Customer Layer to Paper for printing a hard copy of the sales receipt and Merchant Layer to Export for exporting it to a PDF format. Please see View, Export or Print Layers for details on how to export Layers.

In this scenario an existing report is used as a template to output two different versions of the same report without having to create and save two copies separately.

Replicating a Layout

Layers can be used to replicate the layout of a pre-printed form. This is particularly useful when you want to replicate a layout of a pre-printed form which is either uneditable or unavailable in soft copy.

Let us take an example of an order summary letter sent to the customers to see how Layers can help replicate the Layout of the scanned image easily.

Illustrative Example

Place the scanned image of the letter that needs to be replicated on Layer1 and set the DesignerLock property of this Layer to True to make sure the image being traced is not modified or changed by mistake. Please see Working with Layers for details on how to lock a Layer.

While designing any report, it is advisable to separate the layout, data and logic of your report. In this example, we have placed all the static labels like the logo, header, footer on Layer2 and data bound fields on the Default Layer. This is particularly useful when designing complex report layouts such as tax forms, regulatory notices or bill of lading forms. Working on different Layers makes report designing easier as you can modify one aspect of the report, such as static labels or bound data fields without modifying the entire report layout.

On the Default Layer, place the data bound fields like Order ID, Order Date and Amount. Notice the DesignerTransparency of Layer2 above and the Default Layer below is set to 0.5 to display the scanned image placed on Layer1 in the background.

Once the layout being used to copy the layout (scanned image in Layer1) is no longer required, set the DesignerVisible property of Layer1 to False to hide the Layer or you can also delete this Layer. DesignerVisible property helps in checking the accuracy of the layout by quickly showing or hiding the controls on the selected layer. In this case we have hidden the visibility of Layer1 to verify the layout of the final output.

In this scenario, Layers are used to replicate the layout of a scanned image and also separate the layout and the data to help organize our report better.

See Also
Working with Layers


Working with Layers

Working with Layers
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Layers > Working with Layers

When you begin working with Layers, access the Layers List window to handle basic functions like adding or removing a Layer from a report at design time. You may also change the settings for each Layer at design time through a set of in-built properties.

Using the Layers List

The Layers List window displays a list of Layers in the report along with their visibility and lock options. You can also add or remove Layers and even send the Layer back or bring it to the front in the Layers List.

In the Layers List window,

  • A Default Layer is automatically added when you create a new page report. This Layer cannot be deleted or renamed.
  • Any Layer can be set as an Active Layer in the report by selecting it in the Layers List 9 window. There is only one Active Layer at any given time in a report.
    Note: Modifications can only be made to the Active Layer in the report. No modifications are possible on the inactive Layers.

Show or Hide the Layers List

When ActiveReports is installed on your system, a Layers List button is automatically added to the Visual Studio toolbar and it appears every time you create a new application.

  1. Right-click the Visual Studio toolbar and select ActiveReports 10 to display the report designer toolbar. See Toolbar for further details.
  2. On the report designer toolbar, click the View Layers List button. The Layers List 9 window appears.
  3. Click the View Layers List button again to hide the Layers List 9 window.

Note:

  • In case the Layers List window does not appear automatically in your application, select View > Other Windows > Layers List 9 in Visual Studio.
  • A LayerList control is also available in the Visual Studio toolbar and can be used to add the Layers feature in the End User Designer application. See how to add the Layer List control in the walkthrough on Creating a Basic End User Report Designer (Pro Edition).
  • The stand-alone designer application (GrapeCity.ActiveReports.Designer.exe) also contains a Layers List window. See Stand-alone Designer and Viewer for more information.

Add a Layer

Once a report is created, a Default Layer is automatically added in the Layers List.

  1. In the report, select the page on which the Layer is to be added.
  2. On the Layers List toolbar, click the New button.
  3. A new Layer with the name 'Layer1' gets added to the report and the Layers List.

Remove a Layer

All Layers, except the Default Layer, can be removed.

  1. In the Layers List, select the Layer to be removed.
  2. On the Layers List toolbar, click the Remove button to remove the selected Layer.

This removes the selected Layer along with the controls placed on it from the report and the Layers List.

Send to Back/Bring to Front

Use the Send to Back or Bring to Front buttons to send a group of controls placed on a selected Layer to the front or to the back of the controls on other layers.

  1. In the Layers List, select the Layer for which the order is to be set.
  2. In the Layers List toolbar, click the Bring to Front or Send to Back button to send the controls placed on a Layer to the front or the back.

Using the Layers Properties

Select a Layer from the Layers List to access the following properties in the property grid.

Property | Value | Description
DesignerLock True/False

Locks or unlocks controls placed on a Layer.

You cannot move or resize the controls placed on the design surface of a locked Layer through a keyboard or a mouse. Other editing functions like cut, copy or paste and addition or deletion of controls are possible.

This property can also be set using the check-box for Lock in the Layers List.
DesignerTransparency | 0 to 1 | Sets the transparency of the controls on a Layer at design time to a value between 0 and 1. A Layer with transparency set to 1 is not visible on the designer.
DesignerVisible True/False

Determines if the controls placed on a Layer are visible on the designer or not.

This property can also be set using the check-box for Visibility in the Layers List.
Name Layer Name (string)

Sets the name of a Layer (except the Default Layer).
TargetDevice None, Screen, Paper, Export, All

Specifies or limits the visibility of controls placed on a Layer based on the selected target.

  • None: Layer is not visible on any target device
  • Screen: Layer is visible on the viewers
  • Paper: Layer is visible on printing
  • Export: Layer is visible on export
  • All: Layer is visible on all targets i.e. Screen, Paper and Export

See View, Export or Print Layers for information on TargetDevice specific outputs.

See Also
Layers
View, Export or Print Layers


View, Export or Print Layers

View, Export or Print Layers
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Layers > View, Export or Print Layers

The TargetDevice property determines whether you can view, export or print the controls placed on a Layer. It allows you to show or hide the controls that belong to a Layer on a specific target device. For example, if you want to display controls placed on Layer1 in the WinViewer and export the output to PDF, you can select the Screen and Export options of the TargetDevice property simultaneously.
Note: TargetDevice property only determines the target (i.e. Screen, Export or Print) where the group of controls placed on a Layer appear. In order to get the output on a viewer or export or print the controls, you need to add code for exporting or printing or adding a viewer to the application.

TargetDevice property allows you to select from the following options:

  • None
  • Screen
  • Paper
  • Export
  • All

Setting the TargetDevice Property

Use the following steps to set or change the TargetDevice property of a Layer:

  1. Select a Layer from the Layers List window. This becomes the Active Layer of the control.
  2. In the Properties window, select the TargetDevice property.
  3. From the dropdown, select out of the options: None, Screen, Paper, Export or All.
    You can also select more than one option out of Screen, Paper and Export at the same time.

TargetDevice | Output Type | Description
None | - | Controls placed on a Layer cannot be viewed, exported or printed.
Screen | WinViewer | Controls placed on a Layer can be viewed on any of the supported viewers.
 | WebViewer
 | HTML5Viewer
 | SilverLight Viewer
 | WPF Viewer
Paper | Physical/ Virtual Printer | Controls placed on a Layer are can be printed to physical or virtual printers.
Export | RenderingExtensions - HTML, PDF, Word, Image, Xml, Excel | Controls placed on a Layer are exported to any of the supported file formats.
 | Export Filters - HTML, PDF, Tiff, Text, Rft, Excel
All | All Outputs | Controls placed on a Layer can be viewed, exported and printed.
See Also
Layers
Working with Layers


Tracing Layers

Tracing Layers
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Layers > Tracing Layers

In Page Reports and Rdl reports, you can trace the layout of a pre-printed form to a pixel perfect accuracy using Layers.

This walkthrough illustrates how you can trace data fields accurately from a scanned image of a boarding pass. These steps show the results on a Page Report but are applicable to Rdl Reports also.

Note: Right-click and save the image below in your project folder before starting the walkthrough.

The walkthrough is split up into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to an XML data source
  • Adding a dataset
  • Creating a report layout on different layers
  • Viewing the report

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

Adding an ActiveReport to a Visual Studio project

  1. In Visual Studio, create a new Windows Forms Application project.
  2. In the Solution Explorer window, right-click Form1, and rename it to MainForm.
  3. From the Project menu, select Add New Item.
  4. In the Add New Item dialog that appears, select ActiveReports 10 Page Report and in the Name field, rename the file to Boarding.
  5. Click the Add button to open a new Page Report in the designer.
See Adding an ActiveReport to a Project for information on adding different report layouts.

Connecting the report to an XML data source

  1. From the Solution Explorer, open Boarding.rdlx created earlier.
  2. In the Report Explorer, right-click the Data Sources node and select Add Data Source or select Data Source from the Add button dropdown.
  3. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like CustomDS.
  4. In the Type drop down to select a data provider, choose Xml Provider.
  5. In the connection string section, add the following custom data to your project.
    Xml
    Copy Code
     XmlData =

    <Flight ID="31">
      <Passengers>
        <Passenger>

          <PassengerName>Maria Anders</PassengerName>
          <Seat>23A</Seat>
          <Tracking>2322- 030-0074321</Tracking>
        </Passenger>

        <Passenger>
          <PassengerName>Ana Trujillo</PassengerName>
          <Seat>18E</Seat>
          <Tracking>2322- 030-0074343</Tracking>
        </Passenger>

        <Passenger>
          <PassengerName>Antonio Moreno</PassengerName>
          <Seat>25A</Seat>
          <Tracking>6722- 034-6784349</Tracking>
        </Passenger>

        <Passenger>
          <PassengerName>Christina Berglund</PassengerName>
          <Seat>14B</Seat>
          <Tracking>5678- 543-6784349</Tracking>
        </Passenger>
        <Passenger>
          <PassengerName>Thomas Hardy</PassengerName>
          <Seat>28F</Seat>
          <Tracking>9834- 413-6784569</Tracking>
        </Passenger>
      </Passengers>
    </Flight>
  6. Click OK to close the dialog box.

Adding a dataset

  1. In the Report Explorer, right-click the data source created in the previous step and select Add Data Set or select Data Set option from the Add button dropdown.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as BoardingData.
  3. On the Query page, select Text under Command Type and enter the following XML path into the Query text box to access the data of each passenger.
    //Passenger
  4. On the Fields page, enter the values from the table below to create fields for your report. Values for XML data fields must be a valid XPath expression.
    Field Name | Type | Value
    Tracking | Database Field | Tracking
    PassengerName | Database Field | PassengerName
    Seat | Database Field | Seat
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

See Adding a DataSet for more information on adding dataset to a data source.

Creating a report layout on different layers

  1. In the LayerList window, click the [image] icon to add a new Layer to the report. Notice that a default Layer is already added in the Layer List.
  2. Select Layer1 to make it the Active Layer, and from the Properties window, change the Layer Name to ImgLayer.
  3. In the Layer List window, check the Lock check-box to lock ImgLayer to make sure the image being traced is not modified or changed by mistake.
  4. In the Layer List window,click the Send To Back button to move ImgLayer behind the Default Layer.
  5. In the LayerList window, select Default to make it the Active Layer.
  6. From the Properties window, set the DesignerTransparency of the Default Layer to 0.5 to display the scanned image to be placed on ImgLayer in the background.
  7. From the toolbox, drag a List data region onto the design surface of the report.
  8. In the Properties window of the List data region set the following values.
    Property Name | Values
    DataSetName | BoardingData
    FixedSize Width: 6.27in
    Height: 3in
    Location Left: 0in
    Top: 0.125in
    Size Width: 6.27in
    Height: 2.87in
  9. In the Report Explorer window, right-click the Embedded Images node and select Add Embedded Image.
  10. In the Open dialog box that appears, browse to the project folder location and select the BoardingPass.jpg image you saved earlier.
  11. Click Open to embed the image in your project.
  12. From the Report Explorer, drag the embedded BoardingPass image onto the List data region and set the properties as described in the following table.
    Property Name | Property Value
    LayerName | ImgLayer
    Location | 0in, 0.125in
    Size | 6.27in, 2.875in
  13. From the Report Explorer, drag the following fields onto the List data region and set the following properties.
    Field Name Property Values
    PassengerName

    LayerName: Default

    Location: 2.91in, 0.35in

    Size: 1.375in, 0.25in
    PassengerName

    LayerName: Default

    Location: 0.15in, 0.9in

    Size: 1.37in, 0.25in
    PassengerName

    LayerName: Default

    Location: 4.5in, 0.9in

    Size: 1.25in, 0.25in
    Tracking

    LayerName: Default

    Location: 0.15in, 2.19in

    Size: 1.5in, 0.25in
    Seat

    LayerName: Default

    Location: 4.5in, 1.45in

    Size: 1in, 0.375in

    Font > FontSize: 22pt
  14. In the Layer List window, select the Default Layer and then the ImgLayer and change their TargetDevice property to Screen from the Properties window. See View, Export or Print Layers for more information.

Viewing the report

  • Click the preview tab to view the report.

OR

  • See Windows Forms Viewer to display report in the Viewer at runtime.
Go to Top
See Also

Concepts

Layers
Working with Layers
View, Export or Print Layers


Styles

Styles
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Styles

What are Styles?

Styles are a set of properties that you can apply to selected controls in your Page or RDL reports to quickly change their appearance. A single style can define properties for font, background color, line spacing, border color, padding, and many more. You can create four different types of styles, namely Common, Text, Table Of Contents and Table Of Contents Level. For more information on the type of styles and how they differ from each other, see Working with Styles.

What are Style Sheets?

ActiveReports provides you with the ability to create multiple styles and store them in a style sheet. A style sheet can be understood as a collection of styles. You can add the style sheet to your Page or RDL reports using the Stylesheet.Source and Stylesheet.Value properties and apply the styles to selected controls using the StyleName property. You can either embed the style sheet within your report or save it externally in the *.rdlx-styles format. For more information, see Working with Styles.

There are two ways to use these style sheets:

  • Embed the style sheets within the report and use its styles on controls in that report
  • Save the style sheets externally in *.rdlx-styles format and use it in multiple reports

Why use Styles?

Using styles gives you more control over how you format the report. Let us look at a few scenarios to understand how styles are helpful while designing reports.

Reusing Styles

An organization wants to create an Annual Sales Report that consists of multiple subreports, representing Sales by District and Sales by Product. Since all the subreports are a part of the Annual Sales Report, the formatting needs to be consistent. You normally have to manually set properties for each control on the report to format it and then replicate those same set of properties for the two subreports. This can be time consuming and can lead to inconsistent styling in your reports. Let us see how the ActiveReports Style feature can help you generate consistent styles in all reports similar to the screenshot below.

Report author can create a style sheet for designing the Annual Sales Report (main report), add styles to the style sheet using the Stylesheet Editor dialog. After creating the styles, these styles can be applied to various controls on Annual Sales Report using the StyleName property. For more information, see Working with Styles.

Once the Annual Sales Report has been designed, the InheritStyleSheet property can be set to True (by default) for each subreport.

By setting the InheritStyleSheet property to True, the style sheet used for the Annual Sales Report is automatically inherited in the subreports. This makes all the styles in the style sheet available to the two subreports. To apply the styles to the report controls in a subreport, you simply need to select the report control and specify the name of the style you want to use in the StyleName property.

In this example we can see how styles can help save time and maintain consistent formatting by giving you the flexibility to use the same style sheet in multiple subreports.

You can also use the same style sheet in multiple reports by saving the style sheets externally in *.rdlx-styles format. For more information on how to work with external style sheets, see Working with Styles.

Enhancing Report Portability

In ActiveReports, you can embed external style sheets in a report. This is particularly useful when you want to send reports that are styled using multiple style sheets. Let us take an example of a Sales Report to see how embedded style sheets can help improve the report portability.

Scenario

An organization wants to send a Sales report that is styled using 4 different external style sheets. While sending the styled report, 5 files have to be sent together, i.e. one report and 4 external style sheets. The person receiving these files needs to maintain and store 5 different files. Moreover, if the location of a style sheet is changed from the path set in the report, the style sheet will no longer be applied to the report until the path is modified in the report.

By embedding the external style sheets within the Sales report, only 1 file needs to be sent which in turn improves the portability of the report. For more information on how to embed external style sheets, see Embed External style sheet into a report

See Also
Working with Styles


Working with Styles

Working with Styles
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Styles > Working with Styles

ActiveReports provides you with the ability to create styles and store them in a style sheet. You can add these style sheets to your Page or RDL reports and apply the styles to selected controls using the StyleName property. Save style sheets locally or on ActiveReports Server, or embed them in the report.

The styles feature consists of the following elements.

  • Style Sheet Properties
  • Stylesheet Editor Dialog
  • Add New Style Dialog
  • Embed Stylesheet Dialog
  • Open Embedded Stylesheet Dialog
  • Open Server Shared Stylesheet Dialog
  • Save Stylesheet to Server Dialog

Here is some guidance on how to work with style sheets

  • Working with Styles within a Style Sheet
  • Working with Embedded Style Sheets
  • Working with External Style Sheets
  • Working with Shared Style Sheets
  • Applying Styles Through Code

Style Sheet Properties

Define the style sheet of a report in the Properties window using the Source property and the Value property. For subreports, use the InheritStyleSheet property.

Property Name Description
Source

The source of a report's style sheet. You can choose from the following options:

External - Choose this option if the style sheet (*.rdlx-styles format) is located as an external source, such as a local file, an http location or a custom resource. To learn how to create external style sheets, see Working with External Style Sheets.

Embedded - Choose this option if style sheet is embedded in the report. The embedded style sheets are displayed under the Embedded StyleSheets node of the Report Explorer.To learn how to create embedded style sheets, see Working with Embedded Style Sheets.
Value

The style sheet to apply to the report. You can choose from the following options:

Expression - Opens the Expression Editor dialog to create a valid expression.

New - Opens the New Stylesheet Editor dialog to create an external or embedded style sheet.

Open file - Opens the Open Stylesheet from file dialog to navigate to a local style sheet file. This option is only available for external style sheets.

Open from Server - Opens the Open Server Shared Stylesheet dialog to open a shared style sheet stored on ActiveReports Server. This option is only available for external style sheets.

For embedded style sheets, a list of available style sheets in the report is provided.
InheritStyleSheet

The style sheet to inherit in a subreport. Set the InheritStyleSheet property to True (default value) to use the style sheet from the main report in the subreport.

Note: Field values are not evaluated when used as an expression in Stylesheet Value, StyleName and Styles properties.

Stylesheet Editor Dialog

To open the Stylesheet Editor dialog in the stand-alone designer or the Visual Studio designer, from the Report menu, select the Stylesheet Editor option.

The Stylesheet Editor dialog consists of the following elements.

Element | Description
Open Stylesheet from file | Opens a style sheet (*.rdlx-styles format) located externally.
Open Embedded Stylesheet | Opens a style sheet embedded in the report.
Open Stylesheet from Server | Opens a shared style sheet from the server.
Save Stylesheet to file | Saves the current style sheet as an external style sheet in *.rdlx-styles format.
Save Stylesheet to Server | Saves the current style sheet as a shared style sheet to the server in *.rdlx-styles format.
Embed Stylesheet | Embeds the current style sheet in the report.
New Style | Creates a new style in the current style sheet.
Remove Style | Removes a style from the current style sheet.
Property window | Modifies the properties of the selected style based on the selected style type. Available style properties change depending on the type of style selected. You set the style type when you create a new style. The style type is selected when a new style is created.
OK | Saves the current style.
Cancel | Closes the dialog without saving the changes.
Go to Top

Note: The values set in the Properties window override the values defined in the report's style sheet. The overridden values are displayed in bold in the Properties window.

Add New Style Dialog

To open the Add New Style dialog, click the New Style option in the Stylesheet Editor dialog.

The Add New Style dialog consists of the following elements.

Element | Description
Name | Contains the name of the new style.
Type

Sets the type of control to which you can apply the style, which determines the options that are available in the Properties window of the Stylesheet Editor dialog.

Common
Apply this style type to the following report controls:
  • CheckBox
  • Image
  • List
  • Tablix
  • Shape
  • Table
  • TableOfContents
  • TextBox
Text
Apply this style type to the TextBox report control. It includes all properties of the Common style type, plus it offers properties specific to the TextBox control.
TOC
Apply this style type to the TableOfContents control.
TOC Level
Apply this style type to the ToC.Level object of the TableOfContents control.
Parent | Represents the parent style of a new style. If the parent style is specified, the property values are taken from the selected parent style values. By default, the parent style is set to None.

Embed Stylesheet Dialog

To open the Embed Stylesheet dialog, from the Stylesheet Editor dialog, select the Save current Stylesheet option, and then select Embed Stylesheet option.

The Embed Stylesheet dialog consists of the following elements.

Element | Description
Style Sheet Name | Enter a name for the embedded style sheet, or choose an existing style sheet from the drop-down list box to overwrite.

Go to Top

Open Embedded Stylesheet Dialog

To open the Open Embedded Stylesheet dialog, from the Stylesheet Editor dialog, select the Open stylesheet option, and then select Open embedded stylesheet option.

The Open Embedded Stylesheet dialog consists of the following elements.

Element | Description
Style Sheet Name | Provides a drop-down list box to choose an existing style sheet to overwrite. You can also enter a new name for the style sheet here.

Open Server Shared Stylesheet

To open the Open Server Shared Stylesheet dialog, from the Stylesheet Editor dialog, select Open stylesheet option, and then select Open Stylesheet from Server option.

The Open Server Shared Stylesheet dialog consists of the following elements.

Element | Description
Stylesheets | A list of all available style sheets on the server
OK | Select a style sheet, and then click OK to open the style sheet in the Stylesheet Editor dialog.
Cancel | Closes the dialog without saving the changes.
Refresh | Allows you to refresh the list of style sheets on ActiveReports Server.

Go to Top

Save Stylesheet to Server Dialog

To open the Save Stylesheet to Server dialog, from the Stylesheet Editor dialog, select Save current Stylesheet option, and then select Save Stylesheet to Server option.

The Save Stylesheet to Server dialog consists of the following elements.

Element | Description
Stylesheet Name | Enter a name for the style sheet. This name must be unique within the server.
Description | Allows you to provide a description related to the style sheet.
Save | Saves the current style sheet.
Cancel | Closes the dialog without saving the changes.
Refresh | Allows you to refresh the list of style sheets on ActiveReports Server.

Go to Top

Here is some guidance on how to work with style sheets

  • Working with Styles within a Style Sheet
  • Working with Embedded Style Sheets
  • Working with External Style Sheets
  • Working with Shared Style Sheets
  • Applying Styles Through Code

Working with Styles within a Style Sheet

For any of these operations, you first need to open the style sheet in the editor.

To open the editor for embedded style sheets

  1. In the Report Explorer, expand the Embedded StyleSheets node and select the existing style sheet you want to edit.
  2. Right-click and select Edit to open it in the Stylesheet Editor dialog.

Go to Top

To open the editor for external style sheets

  1. In the stand-alone designer or Visual Studio designer, from the Report menu, select Stylesheet Editor option.
  2. In the Stylesheet Editor dialog, click the Open button and select the Open Stylesheet from File option.
  3. In the Open dialog, navigate to the *.rdlx-styles file that you want to open.
  4. Click Open to open the external stylesheet in the Stylesheet Editor.

Go to Top

To add a new style to a style sheet

  1. In the Stylesheet Editor dialog, click the New Style button to add a new style.
  2. In the Add New Style dialog, enter the Name of the style, and then select the Type and Parent style.
    Tip: For more information on the style types, see Working with Styles. To create style types for TableOfContents controls and heading levels, see Apply styles to the TableOfContents control and Apply styles to the TableOfContents levels.

To modify a style in a style sheet

  1. In the Stylesheet Editor, select the existing style that you want to modify and use the property fields on the right to make the changes.
  2. Click OK to save the changes.

To remove a style from a style sheet

  1. In the Stylesheet Editor, select the style that you want to remove and click Remove Style.
  2. Click OK to save the changes.

To use a style from a style sheet at design time

  1. Click the gray area around the report to select it, and under the Properties window, click the Property dialog link in the Commands section. See Properties Window for more information on how to access commands.
  2. In the Report dialog, go to the Appearance page.
  3. In the Appearance page, set the Stylesheet Source to Embedded and in the Value field select an existing embedded style sheet. (Or select External and select the <Open File> option and navigate to an *.rdlx-styles external style sheet.)
    Tip: You can also access the Source and Value properties in the Properties window by expanding the Stylesheet node. For more details on the Source and Value properties, see Working with Styles.
  4. Click OK to close the dialog.
  5. On the design surface, select the control you want to apply the style to.
  6. In the Properties Window, from the StyleName property drop-down, select a style to apply to the controls.

Go to Top

Working with Embedded Style Sheets

Create and save a style sheet

  1. In the Report Explorer, right-click the Embedded StyleSheets node, and select the Add Embedded Stylesheet option to access the Stylesheet Editor dialog.

    Tip: You can also access the Stylesheet Editor dialog from the Report Explorer by clicking the Add button and selecting Embedded Stylesheet. In the stand-alone designer or Visual Studio designer, from the Report menu, select Stylesheet Editor.
  2. Click the Save button and select Embed Stylesheet to embed the style sheet into the report.
  3. Enter a name for the style sheet or choose an existing style sheet from the drop-down to overwrite, and then click OK to save the embedded style sheet.

All the saved style sheets embedded in the report appear under the Embedded StyleSheets node in the Report Explorer.

Go to Top

Save an embedded style sheet as an external style sheet

  1. In the Report Explorer, expand the Embedded StyleSheets node and select the embedded style sheet.
  2. Right-click and select Edit to open the Stylesheet Editor dialog.
  3. In the Stylesheet Editor dialog, click the Save button and select the Save Stylesheet to file option to save the embedded style sheet externally.

  4. In the Save As dialog, navigate to the location where you want to save the style sheet, provide a name for the style sheet and click the Save button to save it as an external *.rdlx-styles file.

Working with External Style Sheets

Create and save a style sheet

  1. In the stand-alone designer or Visual Studio designer, from the Report menu, select Stylesheet Editor.
  2. In the Stylesheet Editor dialog, click the Save button and select the Save Stylesheet to file option.
  3. In the Save As dialog, navigate to the location where you want to save the style sheet, provide a name for the style sheet and click the Save button to save it as an external *.rdlx-styles file.

Go to Top

Embed an external style sheet into a report

  1. In the stand-alone designer or Visual Studio .NET designer, from the Report menu, select Stylesheet Editor.
  2. In the Stylesheet Editor dialog, click the Open button and select the Open Stylesheet from file option.
  3. In the Open dialog, navigate to the external style sheet (*.rdlx-styles file) that you want to load and click the Open button to load it in the Stylesheet Editor dialog.
  4. In the Stylesheet Editor dialog, click the Save button and then select the Embed Stylesheet option.
  5. In the Embedded Stylesheet dialog, enter a name for the style sheet and then click OK to embed the loaded style sheet into your report.

All the saved style sheets embedded in the report appear under the Embedded StyleSheets node in the Report Explorer.

Working with Shared Style Sheets

Save a style sheet to the server

  1. In the stand-alone designer or Visual Studio designer, from the Report menu, select Stylesheet Editor.
  2. In the Stylesheet Editor dialog, click the Save button and select the Save Stylesheet to server option.
  3. Connect your stand-alone designer to ActiveReports Server, if you are not already connected. See Connecting to ActiveReports Server for further information.
  4. In the Save Stylesheet to Server dialog that appears, enter the Stylesheet Name and add a brief description of the style sheet in the Description section.
  5. Click the Save button to save the style sheet on ActiveReports Server.

Go to Top

Open a style sheet from the server

  1. In the stand-alone designer or Visual Studio designer, from the Report menu, select Stylesheet Editor.
  2. In the Stylesheet Editor dialog, click the Open button and select the Open Stylesheet from Server option.
  3. Connect your stand-alone designer to ActiveReports Server, if you are not already connected. See Connecting to ActiveReports Server for further information.
    Note: Users need Read permission to access style sheets stored on ActiveReports Server.
  4. In the Open Server Shared Stylesheet dialog that appears, select a style sheet from the list.
  5. Click OK to open the style sheet in the Stylesheet Editor dialog. In the Stylesheet Editor dialog, you can modify the existing styles using the property fields on the right.

Apply style from a shared style sheet at design time

  1. Click the gray area around the report to select it, and under the Properties window, click the Property dialog link in the Commands section. See Properties Window for more information on how to access commands.
  2. In the Report dialog that appears, go to the Appearance page.
  3. In the Appearance page, set the Stylesheet Source to External and in the Value field select the <Open from Server> option.
  4. Connect your stand-alone designer to ActiveReports Server, if you are not already connected. See Connecting to ActiveReports Server for further information.
  5. In the Open Server Shared Stylesheet that appears, select the style sheet that you want to apply to your report.
  6. Click OK to close the dialog.
  7. On the design surface, select the control you want to apply the style to.
  8. In the Properties Window, from the StyleName property drop-down, select a style to apply to the controls. Once you use a shared style sheet in your report, ActiveReports automatically marks the report as a remote report.

Go to Top

Applying Styles Through Code

  1. In Visual Studio, create a new Page Report Application or open an existing one.
  2. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  3. Add the following code inside the Form_Load event.

    Visual Basic

    Visual Basic.NET code. Paste INSIDE the Form Load event.
    Copy Code
    'Path and Name of the loaded PageReport
Dim filePath As String = "C:\SampleReport.rdlx"
Dim pageReport As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(filePath))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(pageReport)

' Set the style sheet source and value using external style sheets
reportDocument.PageReport.Report.StyleSheetSource = GrapeCity.ActiveReports.PageReportModel.StyleSheetSource.External
reportDocument.PageReport.Report.StyleSheetValue = "C:\ExternalStyle.rdlx-styles"

' Set the style sheet source and value using embedded style sheets
reportDocument.PageReport.Report.StyleSheetSource = GrapeCity.ActiveReports.PageReportModel.StyleSheetSource.Embedded
reportDocument.PageReport.Report.StyleSheetValue = "EmbeddedStylesheet1

' Add a Textbox control and apply style
Dim text As New GrapeCity.ActiveReports.PageReportModel.TextBox()
text.Value = "Sample Text"
text.Style.StyleName = "Style1"
pageReport.Report.Body.ReportItems.Add(text)
viewer1.LoadDocument(reportDocument)

    C#

    C# code. Paste INSIDE the Form Load event.
    Copy Code
    //Path and Name of the loaded PageReport
string filePath = @"C:\SampleReport.rdlx";
GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(filePath));
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(pageReport);

// Set the style sheet source and value using external style sheets
reportDocument.PageReport.Report.StyleSheetSource = GrapeCity.ActiveReports.PageReportModel.StyleSheetSource.External;
reportDocument.PageReport.Report.StyleSheetValue = @"C:\ExternalStyle.rdlx-styles";

// Set the style sheet source and value using embedded style sheets
reportDocument.PageReport.Report.StyleSheetSource = GrapeCity.ActiveReports.PageReportModel.StyleSheetSource.Embedded;
reportDocument.PageReport.Report.StyleSheetValue = "EmbeddedStylesheet1";

// Add a Textbox control and apply style
GrapeCity.ActiveReports.PageReportModel.TextBox text = new GrapeCity.ActiveReports.PageReportModel.TextBox();
text.Value = "Sample Text";
text.Style.StyleName = "Style1";
pageReport.Report.Body.ReportItems.Add(text);
viewer1.LoadDocument(reportDocument);
Go to Top
See Also
Styles


Using Script

Using Script
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Using Script
Show All Show All
Hide All Hide All

In a page report or a RDL report, you can use custom code in your expressions to extend the capabilities of your report. However, for complex functions, or functions you plan to use many times in the report, you also have the facility to embed the code within the report. You can also create and maintain a custom assembly for code that you want to use in multiple reports and refer to its methods in expressions.

Embed Code in the Report

Add a page report/RDL report template to your project and in the ActiveReports Designer that appears, add code like the following in the Script tab.

To call a function from the control's property

This is a simple example of a single method code block:
Public Function GetDueDate() as Date
    Return DateTime.Now.AddDays(30)
End Function

This is an expression used to call the method in the code block from the control's property. For example, you can call this function in the Value property of the Textbox control:
=Code.GetDueDate()

To use the custom constant and variable from the control's property

This is a simple example of how to define custom constants and variables in your code block:
Public Dim MyVersion As String = "123.456"
Public Dim MyDoubleVersion As Double = 123.456
Public Const MyConst As String = "444"

This is an expression to use the custom constant and variable in the code block from the control's property. For example, you can get the value of a variable or a constant in the Value property of the Textbox control:
=Code.MyVersion
=Code.MyDoubleVersion
=Code.MyConst

To call a global collection from the control's property

This is a simple example of a global collection code block where the code block references the report object to access the report parameter value:
Public Function ReturnParam() As String
    Return "param value = " + Report.Parameters!ReportParameter1.value.ToString()
End Function

This is an expression used to call a global collection in the code block from the control's property. For example, you can call the global collection in the Value property of the Textbox control:
=Code.ReturnParam()

Use instance-based Visual Basic .NET code in the form of a code block. You can include multiple methods in your code block, and access those methods from expressions in the control properties.

Note: In a page report or a RDL report, you can use Visual Basic.NET as the script language. However, you can use both Visual Basic.Net and C# in your script for a section report.

Create custom assemblies

You can create custom assemblies in C# or Visual Basic .NET to make code available to multiple reports:

  1. Create or find the assembly you wish to use.
  2. Make the assembly available to the report engine.
    • If you are embedding the designer or viewer controls in your own application, copy the assembly to the same location as your executable.
    • If you are using the included designer or viewer, copy the assembly into the ActiveReports assembly folder located at ...\Common Files\GrapeCity\ActiveReports 10 by default.
      Note: To make the assembly available for use in your own application and for use in designing reports for your application, copy it to both locations listed above. Alternatively, you can place the assembly in the Global Assembly Cache (C:\Windows\assembly).
  3. Add an assembly reference to the report.
    • From the Report Menu, choose Report Properties.
    • In the Report dialog that appears, select the References and click the Open icon above the assembly name list to add your own assembly.
    • Go to the Class list below the assembly names and under Class name, enter the namespace and class name. Similarly, under Instance name, enter the name you want to use in your expressions.
  4. Access the assembly through expressions.
    • To access static members (member denoted as public static in C# assemblies, or as Public Shared in Visual Basic assemblies):
      =Namespace.Class.Member
    • To access class instances:
      =Code.InstanceName
See Also
Designer Tabs


Report Dialog

Report Dialog
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Report Dialog
Show All Show All
Hide All Hide All

In a page report or a RDL report, you can set the basic report properties in the Report dialog. You can access this dialog by doing one of the following:

  • Go to the Visual Studio Report menu and select Report Properties.
  • In the Report Explorer, right-click the Report node and from the context menu that appears, select Report Properties.
  • In the Report Explorer, select the Report node and in the Commands section at the bottom of the Properties Window, click the Property dialog command.
  • Right-click the gray area outside the design surface to select the Report and in the Commands section at the bottom of the Properties Window, click the Property dialog command.

The Report dialog provides the following pages where you can set report properties:

General

The General page of the Report dialog allows you to control the following items:

  • Author: Enter the name of the report author here.
  • Description: Enter a description of the report here.
  • Draw grid: Clear this check box to remove the grid lines from the report design surface.
  • Snap to grid: Clear this check box to allow free placement of report items on the report design surface instead of the automatic alignment of report items with grid lines.
  • Grid spacing: Enter the spacing between grid lines in inches. The default value is 0.125 inches.
  • Page headers: These options are enabled when you set a Page Header in a Report Definition Language (RDL) report.
    • Print on first page - Select this check box to set the page header on the first page of the report.
    • Print on last page - Select this check box to set the page header on the last page of the report.
  • Page footers: These options are enabled when you set a Page Footer in a RDL report.
    • Print on first page - Select this check box to set the page footer on the first page of the report.
    • Print on last page - Select this check box to set the page footer on the last page of the report.
  • Auto refresh: Select this check box to automatically refresh the pages of the report at regular intervals. When this check box is selected, you can supply the interval in seconds.
  • Ruler Units: Set the ruler units in Inches or Centimeters.
  • Preview Pages: Set the number of pages to display in the Preview tab. Minimum values is 0 and maximum is 10000 pages. If the value is set to 0, the Preview tab displays all the pages. By default, the Preview tab displays all the pages.

Appearance

The Appearance page of the Report dialog allows you to control the page layout for your report.

Columns

  • Number of columns: Enter the number of columns you want to use in your report.
  • Spacing: Enter the number of inches of space to use between columns.

Page Layout

  • Paper Size: Select one among the standard paper sizes from the dropdown.
  • Width: Specify the width of the layout.
  • Height: Specify the height of the layout.
  • Left margin: Specify the Left margin for the layout.
  • Right margin: Specify the Right margin for the layout.
  • Top margin: Specify the Top margin for the layout.
  • Bottom margin: Specify the Bottom margin for the layout.
  • Orientation: Select one among Portrait and Landscape as your page orientation.

Design

  • Output background only at design-time: Select the checkbox to display background (for example, background image or background color) in the design tab only.

Stylesheet

  • Source: Select one among Embedded and External as your style sheet source.
  • Value: Select the style sheet to apply to the report. Following options are available:

    Expression - opens the Expression Editor dialog to set an expression.

    New - opens the New Stylesheet Editor dialog for creating an external or embedded style sheet.

    Open file - opens the Open Stylesheet from file dialog for navigating to a local style sheet file. This option is only available for external style sheets.

    In case of embedded style sheets, a list of available style sheets in the report is provided.

Parameters

The Parameters page of the Report dialog allows you to control how a user interface is presented to your users for each parameter. See Parameters for further information.

Images

The Images page of the Report dialog allows you to add and modify images for your report. Click the Open button located at the top left of the page to display the Open file dialog, where you can navigate to an image. Once you select an image file and click the Open button, a thumbnail of the image is displayed in the Image column, and the Name and MIME Type values are automatically populated in their respective columns.

You can use the images you add here in the Image control. The MIME Type column provides a combo-box with a list of image file extensions, where you can change default file filter of the added image.

You can also use the Remove button located at the top right of the page to remove any added image.

References

The References page of the Report dialog allows you to add references to assemblies and classes so that you can call methods from them in expressions throughout your report. You can also access the References dialog from the Properties Window by selecting the Classes (Collection) or References (Collection) property of a report and clicking the ellipsis button that appears.

Caution: If you are using the ActiveReports stand-alone report designer application, make sure the assembly you load is created using .NET 3.5 framework or below as the stand-alone report designer is a .NET 3.5 application.

Assembly Name

This is a list of the assemblies available for use in your report. You can delete assemblies using the Remove button, or add them using the Open button which presents the Open file dialog.

Note: Any assemblies you reference must be copied to the ActiveReports 10 folder (...Common Files\GrapeCity\ActiveReports 10) on your development machine as well as on any server to which you deploy your reports.

Classes

This is a list of instance-based classes you can create for use in your report.

  • Class name: Enter the namespace and name of the class here. (i.e. Invoicing.GetDueDate)
  • Instance name: Enter a name for the instance of the class here. (i.e. m_myGetDueDate)

Data Output

The Data Output page of the Report dialog allows you to control how the report's data is rendered in XML exports.

  • Element name: Enter the name you want to appear as the top level data element in your exported XML file.
  • Data transform (.xsl file): Enter the name of the XSL file you want to use as a style sheet for the exported XML file.
  • Data schema: Enter the schema or namespace to use for validating data types in the exported XML file.
  • Render textboxes as: Choose whether to render textboxes as Attributes or Elements in the exported XML file.
    • Attributes example: <table1 textbox3="Report created on: 7/26/2005 1:13:00 PM">
    • Elements example: <table1> <textbox3>Report created on: 7/26/2005 1:13:28 PM</textbox3>

Themes

The Themes page of the Report dialog displays the report's themes. This dialog allows you to create a new theme, add, modify or remove an existing one, as well as rearrange the order of themes if a report has many themes. When you select to create or modify a theme, the Theme Editor is opened. See Themes for further information.

See Also
Page Report/RDL Report Concepts


FixedPage Dialog

FixedPage Dialog
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > FixedPage Dialog
Show All Show All
Hide All Hide All

In a Page Report, you can set the basic properties for your page from the FixedPage dialog. You can access the FixedPage dialog by doing one of the following:

  • Right-click the gray area outside the design surface and from the context menu that appears, select Fixed Layout Settings.
  • Click the gray area outside the design surface to select the Report and in the commands section at the bottom of the Properties Window, click the Fixed Layout Settings command.
  • Click the design surface to select the Page and in the Commands section at the bottom of the Properties Window, click the Property dialog command.
  • In the Report Explorer, select the Report node or the page node and in the commands section at the bottom of the Properties Window, click the Fixed Layout Settings or Property dialog command respectively.

The FixedPage dialog provides the following pages where you can set the page properties:

General

The General page of the FixedPage dialog allows you to control the following properties:

  • Name: Enter a name for the Page report. This name is used to call the page in code so it should be unique within the report.
  • Dataset name: Select a dataset to associate with the page report. The dropdown list is automatically populated with all the datasets in the report's dataset collection.

Grouping

The Grouping page is useful when you want to show data grouped on a field or an expression on report's pages. See Grouping in a FixedPage for more information.

The Grouping page contains following tabs which provide access to various grouping properties:

General

  • Name: Enter a name for the Fixed Layout group that is unique within the report. This property cannot be set until after a Group on expression is supplied. A name is created automatically if you do not enter one.
  • Group On: Enter an expression to use for grouping the data.
  • Document map label: Enter an expression to use as a label to represent this item in the table of contents (document map).

Filters

The Filters tab allows you to add and control the Filter collection for the Fixed Layout Group. Use the + button to add a filter and the X button to delete a filter. You need to provide three values to add a new filter to the collection:

  • Expression: Enter the expression to use for evaluating whether data should be included in the group.
  • Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right:
    • Equal Only choose data for which the value on the left is equal to the value on the right.
    • Like Only choose data for which the value on the left is similar to the value on the right. For more information on using the Like operator, see the MSDN Web site.
    • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
    • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
    • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
    • LessThan Only choose data for which the value on the left is less than the value on the right.
    • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
    • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
    • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
    • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
    • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
    • In Only choose items from the value on the left which are in the array of values specified on the right. Selecting this operator enables the Values list at the bottom.
    • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.
  • Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

  • Values: When you choose the In operator, you can enter as many values as you need in this list.

Data Output

The Data Output tab allows you to control the following properties when you export to XML:

  • Element name: Enter a name to be used in the XML output for this group.
  • Collection: Enter a name to be used in the XML output for the collection of all instances of this group.
  • Output: Choose Yes or No to decide whether to include this group in the XML output.

Layout

  • Has own page numbering: Check this box to enable section page numbering like Page N of M (Section). See Add Page Numbering for further information on setting page numbering in Page Report.

Sorting

The Sorting page of the FixedPage dialog allows you to enter sort expressions for sorting data alphabetically or numerically.

Expression: Enter an expression by which to sort the data.

Direction: Select whether you want to sort the data in an Ascending or Descending order.

Filters

The Filters page of the FixedPage dialog allows you to control the Filter collection for the Fixed Layout. Use the + button to add filters and X buttons to delete them. You need to provide three values to add a new filter to the collection:

  • Expression: Enter the expression to use for evaluating whether data should be included in the Fixed Layout.
  • Operator: Select from the following operators to decide how to compare the expression to the left with the value to the right:
    • Equal Only choose data for which the value on the left is equal to the value on the right.
    • Like Only choose data for which the value on the left is similar to the value on the right. For more information on using the Like operator, see the MSDN Web site.
    • NotEqual Only choose data for which the value on the left is not equal to the value on the right.
    • GreaterThan Only choose data for which the value on the left is greater than the value on the right.
    • GreaterThanOrEqual Only choose data for which the value on the left is greater than or equal to the value on the right.
    • LessThan Only choose data for which the value on the left is less than the value on the right.
    • LessThanOrEqual Only choose data for which the value on the left is less than or equal to the value on the right.
    • TopN Only choose items from the value on the left which are the top number specified in the value on the right.
    • BottomN Only choose items from the value on the left which are the bottom number specified in the value on the right.
    • TopPercent Only choose items from the value on the left which are the top percent specified in the value on the right.
    • BottomPercent Only choose items from the value on the left which are the bottom percent specified in the value on the right.
    • In Only choose items from the value on the left which are in the array of values specified on the right. Selecting this operator enables the Values list at the bottom.
    • Between Only choose items from the value on the left which fall between the pair of values you specify on the right. Selecting this operator enables two Value boxes instead of one.

  • Value: Enter a value to compare with the expression on the left based on the selected operator. For multiple values used with the Between operator, the lower two value boxes are enabled.

  • Values: When you choose the In operator, you can enter as many values as you need in this list.

Data Output

The Data Output page of the FixedPage dialog allows you to control the following properties when you export to XML:

  • Element name: Enter a name to be used in the XML output for the Page report.
  • Output: Choose Auto, Yes, or No to decide whether to include the fixed page layout in the XML output. Choosing Auto exports the contents of the fixed layout.
See Also
Sorting


Grouping Data (Page Layout)

Grouping Data (Page Layout)
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Grouping Data (Page Layout)

In a page report and RDL report, you can set grouping to organize data in your reports. The most common grouping scenario is to create groups by fields or expressions in a data region.
Depending on the data region you select, you can group data in one of the following ways:

  • In a Table or BandedList, you can add group header and footer rows. You can also set detail grouping in the Table data region.
  • In a List, you can set detail grouping.
  • In a Tablix, you can add columns and rows either dynamically or manually to group data.
  • In a Chart , you can group data by categories or series.

See Grouping in a Data Region for further information.

Note: In this topic, the data displayed in the screenshots is from the Movie table available in the Reels database. By default, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.

In a Page Report, you can also group data on a report page. See Grouping in a FixedPage for further information.

Detail Grouping

Detail grouping is available in the List and Table data regions. It is useful when you do not want to repeat values within the details. When you set detail grouping, the value repeats for each distinct result of the grouping expression instead of each row of data.

For example, if you use the Movie table of the Reels database to display movie titles by year without setting detail grouping, you see each year as many times as there are movies from that year.

If you set detail grouping to =Fields!YearReleased.Value, each year appears only once.
Note: If the detail grouping expression you use results in a value that is distinct for every row of data, MovieID for example, you will see no difference in the results.

Recursive Hierarchies

If you want to display parent-child relationships in your data, you can create a recursive hierarchy. To do this, you need a unique ID field for the child group and an ID field for the parent group.

For example, if you have pulled data from the Reels database using the following SQL query:

SQL Query
Copy Code
SELECT EmployeePosition.*, Employee.*, Employee_1.PositionID AS ManagerPosition FROM Employee AS Employee_1 RIGHT JOIN (EmployeePosition INNER JOIN Employee ON EmployeePosition.PositionID = Employee.PositionID) ON Employee_1.EmployeeID = Employee.ManagementID;

You can set Detail Grouping in a Table data region using the =Fields.Item("EmployeePosition.PositionID").Value field, and the =Fields!ManagerPosition.Value field as the parent group to display parent-child relationships in your data.
Note: You can use only one group expression when you set a parent group.

Level Function

To better visualize data in a recursive hierarchy, you can use the Level function. This function indents text and further clarifies the relationships between parent and child data. To do this, you set an expression in the Padding - Left property of the text box you want to indent.

For example, in a Table data region, for the recursive hierarchy example above, you can set the following expression in the Padding - Left property of the text box that contains the Title to indent values according to levels:

=Convert.ToString(2 + (Level()*10)) & "pt"
See Also

How To

Grouping in a FixedPage
Grouping in a Data Region


Add Page Numbering

Add Page Numbering
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Add Page Numbering
Show All Show All
Hide All Hide All

You can choose the page numbering format for your Page reports/RDL reports by selecting from a list of pre-defined formats or by creating a custom page numbering expression.

Adding page numbers to a report

There are two ways to add page numbering to a report.

  • From the Report Explorer, under the Common Values node, drag a pre-defined page numbering format and drop it directly onto the report design surface.
  • Or add a TextBox control to the report design surface and in the Value property of the control, use the Expression Editor Dialog to select a page numbering expression from the Common Values node.

Usually a page number is added to a report header or footer, but you can add it anywhere on the layout page.

Pre-defined page numbering formats

You can find the pre-defined page numbering formats listed in the Report Explorer under the Common Values node, and in the Expression Editor under the Common Values field.

Predefined Format Descriptions

Numbering Format | Description
Page N of M | This format displays the current page out of the total number of pages in the report. Here N signifies the current page of a report and M the total number of report pages. Use the following expression to set this page numbering format: ="Page " & Globals!PageNumber & " of " & Globals!TotalPages
Page N of M (Section) | This format displays the current page out of the total number of pages of a grouped report section. Here N signifies the current page of a grouped report section and M signifies the total number of pages in a grouped report section. Use the following expression to set this page numbering format: ="Page " & Globals!PageNumberInSection & " of " & Globals!TotalPagesInSection
Page N of M (Cumulative) | This format displays the current page out of the total number of cumulative pages in a report. Here N signifies the current page of the report and M signifies the total number of cumulative pages in a report. Use the following expression to set this page numbering format: ="Page " & Globals!CumulativePageNumber & " of " & Globals!CumulativeTotalPages
Page Number | This format displays only the current page number of a report. Use the following expression to set this page numbering format: =Globals!PageNumber
Page Number (Section) | This format displays only the current page number of a specific grouped report section. Use the following expression to set this page numbering format: =Globals!PageNumberInSection
Total Pages | This format displays only the total number of pages in the report. Use the following expression to set this page numbering format: =Globals!TotalPages
Total Pages (Section) | This format displays only the total number of pages in specific grouped report section. Use the following expression to set this page numbering format: =Globals!TotalPagesInSection
Cumulative Page Number | This format displays only the current cumulative page number of the report. Use the following expression to set this page numbering format: =Globals!CumulativePageNumber
Cumulative Total Pages | This format displays only the total number of cumulative pages in a report. Use the following expression to set this page numbering format: =Globals!CumulativeTotalPages
Tip: In addition to modifying the page numbering expression in the Expression Editor, you can also modify the pre-defined formats directly in the control on the design surface.

Custom page numbering formats

Use the following steps to create your own page numbering format.

To create a custom page numbering format

  1. From the toolbox, drag and drop a Textbox control onto the report design surface.
  2. With the Textbox selected on the report, under the Properties window, click the Property dialog link. This is a command to open the TextBox dialog. See Properties Window for more on how to access commands.
  3. In the TextBox - General dialog that appears, in the Value field, enter a page numbering expression like the following: =Globals!PageNumber & "/" & Globals!TotalPages
  4. Click OK to close the dialog.
  5. Select the Preview tab. Page numbers appear in the expression format you set in the Value field above, in this case, for a one-page report, "1/1."
See Also

Concepts

Common Values
Expressions


Themes

Themes
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Themes
Show All Show All
Hide All Hide All

A theme is a collection of properties that defines the appearance of a report. A theme includes colors, fonts, images, and constant expressions that you can apply to report elements once you add a theme to a report.

You can add one or many themes to a report. If a report has multiple themes, you can use the report's CollateBy Enumeration to control the page order in a report. See Set Up Collation for more information.

The Theme Editor and the Report - Themes dialog allow you to manage themes in a report.

In the Theme Editor, you can create a new theme by setting colors, fonts, images, and Use Constant Expressions in a Theme and then saving a new theme as an .rdlx-theme file on your local machine. Then you can add this theme to your report in the Report – Themes dialog. Also, in the File menu, select Open to open and modify an existing theme and select Save or Save As to save the changes on your local machine.

To access the Theme Editor

From the Start menu, go to All Programs > GrapeCity > ActiveReports and select ActiveReports Theme Editor.

The Report – Themes dialog displays the report's themes. This dialog allows you to create a new theme, add, modify or remove an existing one, as well as rearrange the order of themes if a report has many themes. When you select to create or modify a theme, the Theme Editor is opened.

To access the Theme - Report dialog

  1. In the Designer, click the gray area around the report page to select a report.
  2. Do one of the following:
    • In the Properties window, select the Themes property and click the ellipsis (…) button to open the Report - Themes dialog.
    • With the report selected, in the Properties window under properties where the commands are displayed, click the Property dialog link. In the Report dialog that appears, go to Themes. See Properties Window for further information on commands.
    • On the Report menu, select Report Properties and go to Themes in the Report dialog that appears.

See Also

How To

Create and Add Themes
Customize and Apply a Theme
Use Constant Expressions in a Theme
Set Up Collation


Master Reports (RDL)

Master Reports (RDL)
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Master Reports (RDL)
Show All Show All
Hide All Hide All

Master Reports are like dynamic templates you can design for use with content reports. This assists users in creating reports that share common elements such as a logo in the page header or a web site link in the page footer. You design the master report with controls, code, data sources, and layout properties that cannot be modified from content reports.

Master Reports differ from templates in that they are loaded each time the report is executed. Therefore, you can modify a master report and the changes to the master report automatically appear in any reports that reference it.

You can also save and execute shared master reports on ActiveReports Server while working with the Visual Studio designer or the ActiveReports End User Designer control. Shared master reports are RDLX master reports (*.rdlx-master) that are hosted on an instance of ActiveReports Server. Once you save the master report on the server and use it to create a content report, ActiveReports automatically marks the report as a remote report. You can set a master report that is stored on the server using the Set MasterReport>Open From Server option in the Report Menu.

Advantages of a Master Report

  • Implement common report functionality such as adding consistent page headers and footers within master reports.
  • Apply company-wide changes in information such as address changes to a single master instead of modifying each report individually.
  • Apply widespread data-related changes (such as data source location) to a single master report instead of modifying each report.
  • Create code, data sources, themes and page layouts that are shared across the application or enterprise.
  • Hide report complexity from end users who can use the stand-alone designer application to create content reports.

Advantages of a Shared Master Report

Shared master reports offer the advantages of a local master report, plus:

  • They make your reports portable
  • They allow multiple authors to use them

Designing Master Reports

When designing a master report, you use controls, code, data sources, and layout properties in the same way that you do in a normal report. A master report is valid on its own, and can be run without a content report. To prevent end users from modifying a master report, you can set permissions on the file to Read Only for that user or group.

In an RDL report, you can create a master report by saving it as an RDLX-master file. You can then apply it like a template to content reports.

A ContentPlaceHolder control appears in the toolbox when you convert an RDL report to a Master Report. This control defines regions where users can add content after applying a master report template.

Note: In a section report (code-based report), there is a concept similar to Master Reports. However, here you create a base report class in a standard report that other reports inherit. See Inherit a Report Template for further information.

Creating Content Reports

The reports to which you apply the master report are content reports. A content report is not valid on its own, and cannot be run without its specified master report.

When the user creates a new report and sets a master report on it, the design view is effectively the opposite of the design view of the master report. Any report controls overlaid by ContentPlaceHolder controls are not visible in the content report at design time, but are visible at run time. These are the only areas where users can add report controls.

While designing the content report the user can

  • Add elements that do not exist in the master report.
  • Add new data sources that do not exist in the master report.
  • Add new datasets from a data source in the master report.
  • Add images to the EmbeddedImages collection.
  • Add parameters to the ReportParameter collection.
  • Add any number of report controls into placeholder rectangles designated by the master report.
  • Modify the report name and description.
  • Add new custom code that does not exist in the master report.

While designing the content report the user cannot

  • Modify or remove elements that exist in the master report (disabled grey area).
  • Remove a master report data source.
  • Remove a master report dataset or modify its query.
  • Modify the sort or filter on a master report dataset.
  • Remove images from the EmbeddedImages collection.
  • Remove parameters from the ReportParameter collection.
  • Modify the margins or page settings of the master report.
    Note: Code in the master report is hidden in the content report, so in order to allow content report users to access code, the master report developer must provide information.

Run-Time Sequence of Events

This is what happens behind the scenes when you run a content report.

  1. ActiveReports loads the content report.
  2. The loader parses the master report tag on the content report and requests the master report from the resource resolver.
  3. The master report is loaded into the definition.
  4. As each ContentPlaceHolder in the content report is parsed, it finds the corresponding placeholder in the master report and loads the content from the content report into it.
  5. Data sources, datasets, and fields are merged. The master report has higher priority if there is a conflict.
  6. Themes are merged. The master report has higher priority if there is a conflict.
  7. Report properties from the content report are added to those of the master report. For the following properties, the content report has a higher priority in case of conflict:
    • Report Description
    • Report Author
    • Report AutoRefresh
    • Report Custom
    • Report Language
    • Report DataTransform
    • Report DataSchema
    • Report ElementName
    • Report DataElementStyle
    • Dataset filters
    • Report Theme
    • Report Code
    • All content inside the ContentPlaceHolder controls

Modifying an Aggregated Report Definition

When you run a content report, the content report and its master combine to form an aggregated report definition. Using the ReportDefinition API, you can save this aggregate at run time as a third report definition which has no master or content report. Once this aggregate is saved as a normal report definition (*.rdlx file) you can edit it like any other report definition.

See Also

How To

Create and Use a Master Report (RDL Report)
Inherit a Report Template


Data Visualizers

Data Visualizers
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Visualizers
Show All Show All
Hide All Hide All

The Image and TextBox report controls support a type of expression called Data Visualizers that allow you to create small graphs to make your data easier to understand. For example, you can red flag an overdue account using the Flags Icon Set as a background image. There are several types of Data Visualizers available through a dialog linked to properties on the Image and TextBox report controls.

Image Data Visualizers

These Data Visualizers are supported in the Image report control Value property, and also in the TextBox report control BackgroundImage Value property. See the topics below to learn more.

Caution: In the following topics, the terms "argument" and "parameter" may seem interchangeable, but within an expression, an argument refers to the returned value of a parameter, while a parameter may be a variable.
Icon Set
Learn about the included image strips from which you can select using arguments. These include traffic lights, arrows, flags, ratings, symbols, and more, plus you can create your own custom image strips.
Range Bar
Learn how you can provide minimum, maximum, and length arguments to render a 96 by 96 dpi bar image in line with your text to show a quick visual representation of your data values.
Range Bar Progress
Learn about using a second bar to show progress along with the data range.
Data Bar
Learn about data bars, which are similar to range bars with a few different arguments.

Background Color Data Visualizer

These Data Visualizers are available in the TextBox report control BackgroundColor property. See the topics below to learn more.

Color Scale 2
Learn about displaying TextBoxes with a range of background colors that are keyed to the value of the data.
Color Scale 3
Learn about color scales with an additional middle color value.
See Also
Value Property (Image Class)


Icon Set

Icon Set
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Visualizers > Icon Set
Show All Show All
Hide All Hide All

The Icon Set data visualization allows you to use arguments to select an image from an image strip and display it either as a TextBox BackgroundImage, or as an Image Value. You can use the standard image strips included with ActiveReports, or create custom image strips.

Standard Image Strips

Name | Image
Checkbox |
3TrafficLights |
Arrows |
Blank |
Flags |
GrayArrows |
Quarters |
Ratings |
RedToBlack |
Signs |
Symbols1 |
Symbols2 |
TrafficLights |

To use these image strips, place code like the following in the BackgroundImage property of a TextBox report control, or in the Value property of an Image report control.

Note: When using icon sets, you must set the Source property to Database.

Parameters

  • Icon Set. This designates the name of the icon set to use.
  • Icon 1 Value. A Boolean expression that, if it evaluates to True, renders this icon from the strip.
  • Icon 2 Value. A Boolean expression that, if it evaluates to True, renders this icon from the strip.
  • Icon 3 Value. A Boolean expression that, if it evaluates to True, renders this icon from the strip.
  • Icon 4 Value. A Boolean expression that, if it evaluates to True, renders this icon from the strip.
  • Icon 5 Value. A Boolean expression that, if it evaluates to True, renders this icon from the strip.

You can use static values or any expression that evaluates to a Boolean value. For icon sets with fewer than five icons, set the unused values to False.

Syntax

=IconSet("Flags", False, True, False, False, False)

Usage

Following the Icon Set argument, there are five Boolean arguments. The first argument to evaluate to True displays the corresponding image. Use data expressions that evaluate to a Boolean value to replace the literal values in the code above.

Example

This expression displays the first symbol (the green flag) on each row in which the Difference exceeds 10, displays the second symbol (the yellow flag) on each row in which the quantity is greater than 0, and displays the third symbol (the red flag) on each row in which the quantity is equal to or below 0. Notice that we provide literal False values in the fourth and fifth arguments, which have no images in this strip.

Paste in the BackgroundImage Value property of a Textbox
Copy Code
=IconSet("Flags",Fields!Difference.Value > 10,Fields!Difference.Value > 0,Fields!Difference.Value <= 0,False,False)

In several of the included image strips, the last spots are empty. When using the Checkbox, 3TrafficLights, Flags, RedToBlack, Signs, Symbols1, Symbols2, or TrafficLights image strip, it generally makes sense to set the Boolean values for all of the unused icon spaces to False.

Custom Image Strips

The Blank image strip is included so that you can customize it. Drop down the section below for details.

Custom image strips

Custom image strips must conform to the following rules.

  1. The format must be of a type that is handled by the .NET framework.
  2. The size of the strip must be 120 x 24 pixels.
  3. Each image must be 24 x 24 pixels in size.
  4. There must be no more than five images in the strip.
  5. If there are fewer than five images in the strip, there must be blank spaces in the image to fill in.

Types of Custom Images

Here is the syntax for various types of custom images, followed by examples of each.

External image syntax

=IconSet(location of image strip, condition#1, condition#2, condition#3, condition#4, condition#5)
External image path example
Copy Code
=IconSet("C:\Images\customstrip.bmp", 4 > 9, 5 > 9, 10 > 9, False, False)
External image URL example
Copy Code
=IconSet("http://mysite.com/images/customstrip.gif", 4 > 9, 5 > 9, 10 > 9, False, False)

Image from an assembly resource syntax

=IconSet("res:[Assembly Name]/Resource name", condition#1, condition#2, condition#3, condition#4, condition#5)
Assembly resource image example
Copy Code
=IconSet("res:ReportAssembly, Version=1.1.1.1./ReportAssembly.Resources.Images.CustomImage.png", 4 > 9, 5 > 9, 10 > 9, False, False)

Embedded image syntax

=IconSet("embeddedImage:ImageName", condition#1, condition#2, condition#3, condition#4, condition#5)
Embedded image example
Copy Code
=IconSet("embeddedImage:Grades", Fields!Score.Value >=90, Fields!Score.Value >=80, Fields!Score.Value >=70, Fields!Score.Value >=60, True)

Theme image syntax

=IconSet("theme:ThemeImageName", condition#1, condition#2, condition#3, condition#4, condition#5)
Theme image example
Copy Code
=IconSet("theme:Grades", Fields!Score.Value >=90, Fields!Score.Value >=80, Fields!Score.Value >=70, Fields!Score.Value >=60, True)

Data Visualizers Dialog

To open the dialog, drop down the BackgroundImage property of a TextBox report control, or the Value property of an Image report control, and select <Data Visualizer...>. To build the data visualizer expression, select the appropriate values for each of the options in the dialog.

Icon Set Data Visualizer dialog

See Also

How To

Data Visualizers


Range Bar

Range Bar
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Visualizers > Range Bar
Show All Show All
Hide All Hide All

The Range Bar data visualization displays a 96 by 96 dpi bar image. The colored bar renders as half the height of the image, centered vertically. The amount of colored bar to render to the right of the Start argument (or to the left in the case of a negative value) is based on the Length argument. If the Length argument is zero, a diamond renders.

The Minimum and Maximum arguments determine the range of data. The area between the Length argument and the Maximum argument is transparent (or between the Length and the Minimum in the case of a negative value).

Parameters

  • Minimum. The lowest value in the range of data. This value corresponds to the leftmost edge of the image. If this argument is greater than the Start argument, Start becomes equal to Minimum. The data type is Single.
  • Maximum. The highest value in the range of data. This value corresponds to the rightmost edge of the image. If this argument is less than the Start argument, Start becomes equal to Maximum. The data type is Single.
  • Color. The HTML color string to use in rendering the Length in the bar image.
  • Start. The point from which the Range Bar begins to be rendered. The data type is Single.
  • Length. The width of the bar to render within the control. Setting this value to 0 renders a diamond shape instead of a bar. The data type is Single.

You can use static values or aggregate functions (e.g. Min or Max) to set the parameters. For more information on these and other aggregate functions, see the Common Functions topic.

Syntax

=RangeBar(Minimum, Maximum, Color, Start, Length)

Usage

Use an expression with this syntax in the BackgroundImage Value property of a TextBox or the Value property of an Image. This renders a bar in the color specified, the length of which changes depending on the number returned by the Length parameter, in the case of the simple example, GrossProfit. If your data contains only positive values, Start corresponds with Minimum at the left edge of the DataBar. The area between the Length and the Maximum is transparent.

Simple Example

Set the Length parameter to the value of a field in your dataset to display the field values visually.

Paste into a TextBox BackgroundImage property
Copy Code
=RangeBar(0,15000,"BlueViolet",0,Fields!GrossProfit.Value)

Example Using Negative Values

When your data contains negative as well as positive values, you can use an Immediate If expression for the Color parameter. In this example, if the Projected Stock value is negative, it renders in Crimson, while positive values render in BlueViolet. You can also see that negative values render to the left of Zero and positive values render to the right. A Length value of exactly zero renders as a diamond.

Paste into a TextBox BackgroundImage property
Copy Code
=RangeBar(-5,20,IIf((Fields!InStock.Value - 5) < 0, "Crimson", "BlueViolet"),0,Fields!InStock.Value-5)

Default Behavior

The function returns null (i.e. no image is rendered) in the following cases:

  1. The Maximum is less than or equal to the Minimum.
  2. The expression is placed in a property which does not take an image.
  3. The Source property of the image is not set to Database.

The Start value changes in the following cases:

  1. If the Start value is less than the Minimum value, Start is the same as Minimum.
  2. If the Start value is greater than the Maximum value, Start is the same as Maximum.

The Length value changes in the following cases:

  1. If the Start value plus the Length value is less than the Minimum value, Length becomes Minimum minus Start.
  2. If the Start value plus the Length value is greater than the Maximum value, Length becomes Maximum minus Start.

If the argument for any of the parameters cannot be converted to the required data type, the default value is used instead.

Parameter | Default Value
Minimum | 0
Maximum | 0
Color | Green
Start | 0
Length | 0

Dialog

When you select a TextBox control on your report, in the Properties window or Properties dialog, you can drop down the BackGroundImage Value property and select <Data Visualizer...> to launch the dialog. The same is true if you select an Image control and drop down the Value property. To build the data visualizer expression, select the appropriate values for each of the options in the dialog.

Range Bar Data Visualizer dialog

See Also

How To

Data Visualizers


Range Bar Progress

Range Bar Progress
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Visualizers > Range Bar Progress
Show All Show All
Hide All Hide All

The Range Bar Progress data visualization displays a 96 by 96 dpi double bar image. The first colored bar renders as half the height of the image, centered vertically. The amount of colored bar to render to the right of the Start argument (or to the left in the case of a negative value) is based on the Length argument. If the Length argument is zero, a diamond renders.

The second colored bar renders using the ProgressColor as one fourth of the height of the image, centered vertically over the Length bar. The amount of colored bar to render to the right of the Start argument (or to the left in the case of a negative value) is based on the Progress argument. If the Progress argument is zero, a smaller diamond renders.

The Minimum and Maximum arguments determine the range of data. The area between the Length and Progress arguments and the Maximum argument is transparent (or between the Length and Progress and the Minimum in the case of a negative value).

Parameters

  • Minimum. The lowest value in the range of data. This value corresponds to the leftmost edge of the image. If this argument is greater than the Start argument, Start becomes equal to Minimum. The data type is Single.
  • Maximum. The highest value in the range of data. This value corresponds to the rightmost edge of the image. If this argument is less than the Start argument, Start becomes equal to Maximum. The data type is Single.
  • Color. The HTML color string to use in rendering the Length, the thicker bar in the bar image.
  • Start. The point from which the Range Bar Progress begins to be rendered. The data type is Single.
  • Length. The length of the thicker bar to render within the control. Setting this value to 0 renders a diamond shape instead of a bar. The data type is Single.
  • ProgressColor. The HTML color string to use in rendering the Progress, the thinner bar in the bar image.
  • Progress. The length of the thinner bar to render within the control. Setting this value to 0 renders a diamond shape instead of a bar. The data type is Single.

You can use static values or aggregate functions (e.g. Min or Max) to set the parameters. For more information on these and other aggregate functions, see the Common Functions topic.

Syntax

=RangeBarProgress(Minimum, Maximum, Color, Start, Length, ProgressColor, Progress)

Usage

Use an expression with this syntax in the BackgroundImage property of a TextBox or the Value property of an Image. This renders a double bar in the colors specified, the length of which changes depending on the number returned by the Length parameter for the thick bar, in the case of the simple example, GrossSales. The thin bar length is based on the value returned by the Progress parameter, in this case, GrossProfit. If your data contains only positive values, Start corresponds with Minimum at the left edge of the Range Bar. The area between the Length or Progress and the Maximum is transparent.

Simple Example

Set the Length and Progress parameters to the values of fields in your dataset to display the field values visually.

Paste into a TextBox BackgroundImage property
Copy Code
=RangeBarProgress(0,30000,"BlueViolet",0,Fields!GrossSales.Value,"Gold",Fields!GrossProfit.Value)

Example Using Negative Values

When your data contains negative as well as positive values, you can use an Immediate If expression for the Color parameter. In the example below, if the Difference value is negative, it is rendered in red, while positive values are rendered in gold. You can also see that negative values are rendered to the left of Zero and positive values are rendered to the right. A Length value of exactly zero is rendered as a diamond. The thicker blue violet bar represents the InStock value.

Paste into a TextBox BackgroundImage property
Copy Code
=RangeBarProgress(-10,20,"BlueViolet",0,Fields!InStock.Value,IIf(Fields!Difference.Value < 0, "Red", "Gold"),Fields!Difference.Value)

Default Behavior

The function returns null (i.e. no image is rendered) in any of the following cases:

  1. The Maximum is less than or equal to the Minimum.
  2. The expression is placed in a property which does not take an image.
  3. The Source property of the image is not set to Database.

The Start value changes in the following cases:

  1. If the Start value is less than the Minimum value, Start is the same as Minimum.
  2. If the Start value is greater than the Maximum value, Start is the same as Maximum.

The Length value changes in the following cases:

  1. If the Start value plus the Length value is less than the Minimum value, Length becomes Minimum minus Start.
  2. If the Start value plus the Length value is greater than the Maximum value, Length becomes Maximum minus Start.

The Progress value changes in the following cases:

  1. If the Start value plus the Progress value is less than the Minimum value, Progress becomes Minimum minus Start.
  2. If the Start value plus the Progress value is greater than the Maximum value, Progress becomes Maximum minus Start.

If the argument for any of the parameters cannot be converted to the required data type, the default value is used instead.

Parameter | Default Value
Minimum | 0
Maximum | 0
Color | Green
Start | 0
Length | 0
ProgressColor | Red
Progress | 0

Dialog

When you select a TextBox control on your report, in the Properties window or Properties dialog, you can drop down the BackgroundImage Value property and select <Data Visualizer...> to launch the dialog. To build the data visualizer expression, select the appropriate values for each of the options on the dialog.

For a Range Bar Progress expression, be sure to select the Display a progress indicator check box. This enables the progress options.

Range Bar Data Visualizer dialog

See Also

How To

Data Visualizers


Data Bar

Data Bar
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Visualizers > Data Bar
Show All Show All
Hide All Hide All

The Data Bar data visualization displays a 96 by 96 dpi bar image. The colored bar fills the Image top to bottom, while the Value argument determines the amount of colored bar to render to the right of the Zero argument (or to the left in the case of a negative value).

The Minimum and Maximum arguments determine the range of data. The area between the Value argument and the Maximum argument is transparent (or between the Value and the Minimum in the case of a negative value).

Parameters

  • Value. This is the field value in the report to be evaluated. The data type is Single.
  • Minimum. The lowest value in the range of data against which the Value argument is compared. This value corresponds to the leftmost edge of the image. If this argument is greater than the Zero argument, Zero becomes equal to Minimum. The data type is Single.
  • Maximum. The highest value in the range of data against which the Value argument is compared. This value corresponds to the rightmost edge of the image. If this argument is less than the Zero argument, Zero becomes equal to Maximum. The data type is Single.
  • Zero. This value determines the zero point to the left of which negative data is rendered, and to the right of which positive data is rendered. The data type is Single.
  • Color. The HTML color string to use in rendering the Value in the bar image.
  • Alternate Color. The HTML color string to use when the Value is less than the Zero value (optional).

Select the Use Alternate Color when Value is less than Zero Value check box to enable the Alternate Color parameter. You can use static values or aggregate functions (e.g. Min or Max) to set parameters. For more information on these and other aggregate functions, see the Common Functions topic.

Syntax

=DataBar(Value, Minimum, Maximum, Zero, Color)

=DataBar(Value, Minimum, Maximum, Zero, Color, Alternate Color)

Usage

Use an expression with this syntax in either the BackgroundImage Value property of a TextBox or the Value property of an Image. This renders a bar in the color specified, the length of which changes depending on the number returned by the Value parameter, in the case of the simple example, InStock. If your data contains only positive values, Zero corresponds with Minimum at the left edge of the Data Bar. The area between the Value and the Maximum is transparent.

Simple Example

Set the Value parameter to the value of a field in your dataset to display the field values visually.

Paste into the BackgroundImage Value property of a TextBox
Copy Code
=DataBar(Fields!InStock.Value,0,20,0,"BlueViolet")

Example Using Negative Values

When your data contains negative as well as positive values, you can select the Use Alternate Color when Value is less than Zero Value check box, and then select an Alternate Color. In this example, if the Difference value is negative, it is rendered in Crimson, while positive values are rendered in BlueViolet. You can also see that negative values are rendered to the left of Zero and positive values are rendered to the right.

Paste in the BackgroundImage Value property of a TextBox
Copy Code
=DataBar(Fields!Difference.Value,-10,20,0,"BlueViolet","Crimson")

Default Behavior

The function returns null (i.e. no image is rendered) in any of the following cases:

  1. The Maximum is less than or equal to the Minimum.
  2. The expression is placed in a property which does not take an image.
  3. The Source property of the image is not set to Database.

If the argument for any of the parameters cannot be converted to the required data type, the default value is used instead.

Parameter | Default Value
Value | 0
Minimum | 0
Maximum | 0
Zero | 0
Color | Green
Alternate Color | null

Dialog

When you select a TextBox control on your report, in the Properties window or Properties dialog, you can drop down the BackGroundImage Value property and select <Data Visualizer...> to launch the dialog. The same is true if you select an Image control and drop down the Value property. To build the data visualizer expression, select the appropriate values for each of the options in the dialog.

Data Bar Data Visualizer dialog

See Also

How To

Data Visualizers


Color Scale 2

Color Scale 2
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Visualizers > Color Scale 2
Show All Show All
Hide All Hide All

The ColorScale2 data visualization displays a background color in a range of colors to indicate minimum and maximum values, and all shades in between.

Parameters

  • Value. This is the field value in the report to evaluate. The data type is Single.
  • Minimum. If the Value evaluates to this number, the StartColor renders.
  • Maximum. If the Value evaluates to this number, the EndColor renders.
  • StartColor. The HTML color string to use if the Value evaluates to the Minimum value.
  • EndColor. The HTML color string to use if the Value evaluates to the Maximum value.

You can use static values or aggregate functions (e.g. Min or Max) to set the Minimum and Maximum parameters. For more information on these and other aggregate functions, see the Common Functions topic.

Syntax

=ColorScale2(Value, Minimum, Maximum, StartColor, EndColor)

Usage

Use an expression with this syntax in the BackgroundColor property of a Textbox control. This causes the background color to change depending on the value of the field you specified in the Value parameter, in the case of the example, InStock. Any values falling between the Minimum value and the Maximum render with a color between the StartColor and EndColor.

Example

Set the Value parameter to the value of a field in your dataset to display the field values visually.

Paste into the BackgroundColor property of a TextBox
Copy Code
=ColorScale2(Fields!InStock.Value,0,20,"Crimson","MidnightBlue")

Default Behavior

The function returns Transparent in any of the following cases:

  1. The Value is out of range (i.e. does not fall between the Minimum and Maximum values).
  2. The Maximum is less than the Minimum.

If the argument for any of the parameters cannot be converted to the required data type, the default value is used instead.

Parameter | Default Value
Value | 0
Minimum | 0
Maximum | 0
StartColor | Silver
EndColor | WhiteSmoke

Dialog

When you select a TextBox control on your report, in the Properties window or Properties dialog, you can drop down the BackGroundColor property and select <Data Visualizer...> to launch the dialog. To build the data visualizer expression, select the appropriate values for each of the options in the dialog.

Note: If you select the Use a middle color check box, the expression used in the BackgroundColor property changes to ColorScale3. For more information, see ColorScale3.

Color Scale Data Visualizer dialog

See Also
Color Scale 3

How To

Data Visualizers


Color Scale 3

Color Scale 3
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Data Visualizers > Color Scale 3
Show All Show All
Hide All Hide All

The ColorScale3 data visualization displays a TextBox background color in a range of colors to indicate minimum, middle, and maximum values, and all shades in between.

Parameters

  • Value. This is the field value in the report to be evaluated. The data type is Single.
  • Minimum. If the Value evaluates to this number, the StartColor is rendered.
  • Middle. If the Value evaluates to this number, the MiddleColor is rendered.
  • Maximum. If the Value evaluates to this number, the EndColor is rendered.
  • StartColor. The HTML color string to use if the Value evaluates to the Minimum value.
  • MiddleColor. The HTML color string to use if the Value evaluates to the Middlevalue.
  • EndColor. The HTML color string to use if the Value evaluates to the Maximum value.

You can use static values or aggregate functions (e.g. Min, Avg, or Max) to set the Minimum, Middle, and Maximum parameters. For more information on these and other aggregate functions, see the Common Functions topic.

Syntax

=ColorScale3(Value, Minimum, Middle, Maximum, StartColor, MiddleColor, EndColor)

Usage

Use an expression with this syntax in the BackgroundColor property of a Textbox control. This causes the background color to change depending on the value of the field you specified in the Value parameter, in the case of the example, InStock. Any values falling between the Minimum value and the Middle value render with a gradient scale color between the StartColor and MiddleColor. The closer the value is to the Minimum, the closer to Crimson the color renders. In the same way, values falling between the Middle and Maximum render with a color between the MiddleColor and EndColor, in this case, varying shades of yellow-green.

Example

Set the Value parameter to the value of a field in your dataset to display the field values visually.

Paste into the BackgroundColor property of a TextBox
Copy Code
=ColorScale3(Fields!InStock.Value,0,10,20,"Crimson","Yellow","MidnightBlue")

Default Behavior

The function returns Transparent in any of the following cases:

  1. The Value is out of range (i.e. does not fall between the Minimum and Maximum values).
  2. The Maximum is less than the Minimum.
  3. The Middle is not between the Minimum and the Maximum.

If the argument for any of the parameters cannot be converted to the required data type, the default value is used instead.

Parameter | Default Value
Value | 0
Minimum | 0
Middle | 0
Maximum | 0
StartColor | Silver
MiddleColor | Gainsboro
EndColor | WhiteSmoke

Dialog

When you select a TextBox control on your report, in the Properties window or Properties dialog, you can drop down the BackGroundColor property and select <Data Visualizer...> to launch the dialog. To build the data visualizer expression, select the appropriate values for each of the options in the dialog.

Note: If you clear the Use a middle color check box, the expression used in the BackgroundColor property changes to ColorScale2. For more information, see ColorScale2.

Color Scale Data Visualizer dialog

See Also
Color Scale 2

How To

Data Visualizers


Custom Resource Locator

Custom Resource Locator
ActiveReports 10 > ActiveReports User Guide > Concepts > Page Report/RDL Report Concepts > Custom Resource Locator
Show All Show All
Hide All Hide All

Page reports and RDL reports can resolve resources from your file system using file paths, but sometimes resources are preserved in very specific sources, such as a database. With RDL report, you can create a custom resource locator to read any resources that might be required by your reports from any type of location. You can use it for resources such as images and theme files, or for reports to use in drillthrough links, subreports, or master reports.

API

You can implement a custom resource locator by deriving from the ResourceLocator Class and overriding the GetResource method.

The GetResource method returns ParentUri and Value properties. The Value property contains the located resource as a memory stream. The ParentUri property contains the string URI of the parent of the resource within the resource hierarchy.

Here is the GetResource method used in the sample.

C# MyPicturesLocator.cs code showing usage of the GetResource Method from the Sample

C# code. Paste inside a class.
Copy Code
using System;
using System.Collections.Generic;
using System.Drawing;
using System.Globalization;
using System.IO;
using System.Runtime.InteropServices;
using System.Text;
using GrapeCity.ActiveReports.Extensibility;
using GrapeCity.ActiveReports.Samples.CustomResourceLocator.Properties;
namespace GrapeCity.ActiveReports.Samples.CustomResourceLocator
{
    /// Implementation of ResourceLocator which looks for resources in the My Pictures folder.
    internal sealed class MyPicturesLocator : ResourceLocator
    {
        private const string UriSchemeMyImages = "MyPictures:";
        /// Obtains and returns the resource, or returns null if it is not found.
        public override Resource GetResource(ResourceInfo resourceInfo)
        {

            Resource resource;
            string name = resourceInfo.Name;
            if (name == null || name.Length == 0)
            {
                throw new ArgumentException(Resources.ResourceNameIsNull, "name");
            }
            Uri uri = new Uri(name);
            if (uri.GetLeftPart(UriPartial.Scheme).StartsWith(UriSchemeMyImages, true, CultureInfo.InvariantCulture))
            {
                Stream stream = GetPictureFromSpecialFolder(uri);
                if (stream == null)
                {
                    stream = new MemoryStream();
                    Resources.NoImage.Save(stream, Resources.NoImage.RawFormat);
                }
                resource = new Resource(stream, uri);
            }
            else
            {
                throw new InvalidOperationException(Resources.ResourceSchemeIsNotSupported);
            }
            return resource;
        }
        /// Returns a stream containing the specified image from the My Pictures folder, or null if the picture is not found.
                /// The path parameter is the URI of the image located in My Pictures, e.g. MyImages:logo.gif
        private static Stream GetPictureFromSpecialFolder(Uri path)
        {
            int startPathPos = UriSchemeMyImages.Length;
            if (startPathPos >= path.ToString().Length)
            {
                return null;
            }
            string pictureName = path.ToString().Substring(startPathPos);
            string myPicturesPath = Environment.GetFolderPath(Environment.SpecialFolder.MyPictures);
            if (!myPicturesPath.EndsWith("\\")) myPicturesPath += "\\";
             string picturePath = Path.Combine(myPicturesPath, pictureName);
            if (!File.Exists(picturePath)) return null;
            MemoryStream stream = new MemoryStream();
            try
            {
                Image picture = Image.FromFile(picturePath);
                picture.Save(stream, picture.RawFormat);
                stream.Position = 0;
            }
            catch(OutOfMemoryException)
                        /// The file is not a valid image, or GDI+ doesn't support the image type.
            {
                return null;
            }
            catch(ExternalException)
                        /// The image can't be saved.
            {
                return null;
            }
            return stream;
        }
    }
}

Visual Basic MyPicturesLocator.vb code showing usage of the GetResource Method from the Sample

Visual Basic code. Paste inside a class.
Copy Code
Imports GrapeCity.ActiveReports.Extensibility
Imports System.Globalization
Imports System.IO
Imports System.Runtime.InteropServices

Public Class MyPicturesLocator
    Inherits ResourceLocator

    Const UriSchemeMyImages As String = "MyPictures:"

    ' Obtains and returns the resource, or null if it is not found.
        ' The resourceInfo parameter contains the information about the resource to obtain.

    Public Overrides Function GetResource(ByVal resourceInfo As ResourceInfo) As Resource
        Dim resource As Resource
        Dim name As String = resourceInfo.Name

        If (String.IsNullOrEmpty(name)) Then

            Throw New ArgumentException(My.Resources.ResourceNameIsNull, "name")

        End If

        Dim uri As New Uri(name)
        If (Uri.GetLeftPart(UriPartial.Scheme).StartsWith(UriSchemeMyImages, True, CultureInfo.InvariantCulture)) Then

            Dim stream As Stream = GetPictureFromSpecialFolder(uri)
            If (stream Is Nothing) Then
                stream = New MemoryStream()
                My.Resources.NoImage.Save(stream, My.Resources.NoImage.RawFormat)
            End If
            resource = New Resource(stream, uri)

        Else
            Throw New InvalidOperationException(My.Resources.ResourceSchemeIsNotSupported)
        End If
        Return resource
    End Function

    Function GetPictureFromSpecialFolder(ByVal path As Uri) As Stream
        Dim startPathPos As Integer = UriSchemeMyImages.Length

        If (startPathPos >= path.ToString().Length) Then
            Return Nothing
        End If

        Dim pictureName As String = path.ToString().Substring(startPathPos)
        Dim myPicturesPath As String = Environment.GetFolderPath(Environment.SpecialFolder.MyPictures)

        If (Not myPicturesPath.EndsWith("\\")) Then
            myPicturesPath += "\\"
        End If

        Dim picturePath As String = System.IO.Path.Combine(myPicturesPath, pictureName)

        If (Not File.Exists(picturePath)) Then
            Return Nothing
        End If

        Dim stream As New MemoryStream()

        Try
            Dim picture As Image = Image.FromFile(picturePath)
            picture.Save(stream, picture.RawFormat)
            stream.Position = 0
        Catch ex As OutOfMemoryException
                ' The file is not a valid image, or GDI+ doesn't support the image type.
            Return Nothing
        Catch ex As ExternalException
                ' The image can't be saved.
            Return Nothing
        End Try

        Return stream
    End Function

End Class

Sample

In the Samples folder installed with the product, there is a Custom Resource Locator sample in a path like:

C:\Users\MyUserName\Documents\GrapeCity Samples\ActiveReports 10\Page Reports\RDL\API\C#\CustomResourceLocator

This sample contains a custom resource locator that looks for files in the current user’s My Pictures folder. It does this by looking for special MyPictures protocol.

See Also

Walkthroughs

Custom Resource Locator


Section Report Concepts

Section Report Concepts
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts

There are a number of concepts that only apply to section reports.

In this section

Section Report Toolbox
This section provides information on each of the report controls available in the ActiveReports 10 Section Report group of the Visual Studio toolbox.
Section Report Structure
Learn about the report structure in a section layout.
Section Report Events
Learn about events that you can use to customize section reports.
Scripting in Section Reports
Learn how to use scripts in a section layout.
Report Settings Dialog
See the various options provided in Report Settings dialog.
Grouping Data in Section Reports
Learn about grouping data in section layout.
Date, Time, and Number Formatting
Learn how you can customize formatting with .NET strings.
Optimizing Section Reports
Learn about ways to optimize section reports to reduce memory consumption and increase speed.
CacheToDisk and Resource Storage
Learn about IsolatedStorage and other considerations when you use CacheToDisk to reduce memory consumption.
See Also
Page Report/RDL Report Concepts

Getting Started

Getting Started

©2017. ComponentOne, a division of GrapeCity. All rights reserved.

Support Forum


Section Report Toolbox

Section Report Toolbox
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox

When a Section report has focus in Visual Studio, the ActiveReports 10 Section Report toolbox group offers a number of report controls that you can use when creating a section report. You can drag these from the toolbox and drop them onto your section reports. These tools are different than those in the Toolbox.

Note: Take care in naming report controls, as they are displayed to end users in the advanced search feature of the Viewer.

In this section

Label
The label is used to display descriptive text for a control and helps the user to describe the data displayed in a report.
TextBox (Section Report)
The text box is a basic reporting control that allows direct display and editing of unformatted text.
CheckBox (Section Report)
The checkbox gives the user an option of yes or no and true or false.
RichTextBox
The rich text box control allows the user to enter rich text in the form of formatted text, tables, hyperlinks, images, etc.
Shape (Section Report)
The shape is a user interface element that allows to draw shapes on the screen.
Picture
This control displays images files on the screen and also performs functions like resizing and cropping of images being used.
Line (Section Report)
The line visually draws boundaries or highlights specific areas of a report.
PageBreak
The PageBreak control is used when you need to stop printing a report inside the selected section and resume it on a new page.
Barcode (Section Report)
The BarCode control allows you to choose from several barcode styles available, and bind them to a data source.
SubReport (Section Report)
Use the subreport control as a placeholder for data from a separate report. Use code to connect the separate report to the subreport control.
OleObject
You can add an OLE object, bound to a database or unbound, directly to your report.
Note: The OleObject control is not displayed in the toolbox by default, because it is obsolete, and is only available for backward compatibility.
ChartControl

You can use the ChartControl for a graphical presentation of data in a report. There are numerous chart types that you can use to easily design and render data.

ReportInfo
The ReportInfo control allows you to quickly display page numbers, page counts and report dates.
Cross Section Controls
The CrossSectionLine and CrossSectionBox controls provide visual boundaries and highlight specific areas of your report that span multiple report sections. This CrossSectionLine control is a vertical line that starts in the header section and spans the intervening sections until it ends in the footer. (For a horizontal or diagonal line, use the Line control.) The CrossSectionBox control starts in the header section and spans any intervening sections to end in the related footer section.
See Also
Toolbox


Label

Label
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Label
Show All Show All
Hide All Hide All

The Label control for Section reports is very similar to the standard Visual Studio Label control. Since, by inheriting from the ARControl object, it can bind to data with the DataField property, and since you can enter static text in the TextBox control, the main difference between the two controls is the Angle property of the Label control, and the following properties of the TextBox control: CanGrow, CanShrink, CountNullValues, Culture, DistinctField, OutputFormat, SummaryFunc, SummaryGroup, SummaryRunning, and SummaryType.

This control may become obsolete if the Angle property is added to the TextBox, and then will be kept only for compatibility with previous versions.

Important Properties

Property | Description
Angle | Gets or sets the angle (slope) of the text within the control area. Set the Angle property to 900 to display text vertically.
CharacterSpacing | Gets or sets the space between characters in points.
DataField | Gets or sets the field name from the data source to bind to the control.
HyperLink | Gets or sets a URL to which the viewer navigates when the user clicks the label at run time. The URL becomes an anchor tag or a hyperlink in HTML and PDF exports.
LineSpacing | Gets or sets the space between lines in points.
MultiLine | Gets or sets a value indicating whether to allow text to break to multiple lines within the control.
ShrinkToFit | Gets or sets a value indicating whether to decrease the font size so that all of the text shows within the boundaries of the control.
Style | Gets or sets a style string for the label.
Text | Gets or sets the text to show on the report.
TextJustify | Specifies how to distribute text when the Alignment property is set to Justify. With any other Alignment setting, this property is ignored.
VerticalAlignment | Gets or sets the vertical position of the label's text within the bounds of the control.
VerticalText | Indicates whether to render the label's text vertically.
WrapMode | Indicates whether a multi-line label control wraps words or characters to the beginning of the next line when necessary.

You can double-click in the Label control to enter edit mode and enter text directly in the control, or you can enter text in the Properties window or in code through the Text property.

You can format text in the Label control in edit mode using the ActiveReports toolbar, or you can modify properties in the Properties window. Formats apply to all of the text in the control. Text formatting changes in the Properties window immediately appear in the control, and changes made in the toolbar are immediately reflected in the Properties window.

Note: In edit mode for a Label with the Alignment property set to Justify, the Alignment value temporarily changes to the default value, Left. Once you leave edit mode, it automatically changes back to Justify.

Keyboard Shortcuts

In edit mode, you can use the following keyboard shortcuts.

Key Combination | Action
Enter | New line.
Alt + Enter | Saves modifications and exits edit mode.
Esc | Cancels modifications and exits edit mode.

In the End User Designer, you can disable this feature in the EditModeEntering and EditModeExit events.

Label Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

General

Name: Enter a name for the label that is unique within the report. This name is displayed in the Document Outline and in XML exports.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

DataField: Select a field from the data source to bind to the control.

Text: Enter static text to show in the label.

HyperLink: Enter a URL to use in the Viewer HyperLink event. The URL automatically converts to an anchor tag or hyperlink in PDF and HTML exports.

Appearance

Background Color: Select a color to use for the background of the label.

Angle: Use the slider to set the degree of slope for the text within the control area.

Font

Name: Select a font family name or a theme font.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic.

Weight: Choose from Normal or Bold.

Color: Choose a color to use for the text.

Decoration: Select check boxes for Underline and Strikeout.

GDI Charset: Enter a value to indicate the GDI character set to use. For a list of valid values, see MSDN Font.GDICharSet Property.

GDI Vertical: Select this checkbox to indicate that the font is derived from a GDI vertical font.

Format

Line spacing: Enter a value in points to use for the amount of space between lines.

Character spacing: Enter a value in points to use for the amount of space between characters.

Multiline: Select this check box to allow text to render on multiple lines within the control.

Text direction

RightToLeft: Select this check box to reverse the text direction.

Vertical text: Select this check box for top to bottom text.

Alignment

Vertical alignment: Choose Top, Middle, or Bottom.

Horizontal alignment: Choose Left, Center, Right, or Justify.

Justify method: Choose Auto, Distribute, or DistributeAllLines.

Note: You must select Justify in the Horizontal alignment property to enable the Justification method property options.

Wrap mode: Choose NoWrap, WordWrap, or CharWrap to determine whether and how text breaks to the next line.

Padding

Enter values in points to set the amount of space to leave around the label.

  • Top
  • Left
  • Right
  • Bottom


TextBox (Section Report)

TextBox (Section Report)
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > TextBox (Section Report)
Show All Show All
Hide All Hide All

The TextBox control is the basis of reporting as it is used to display text in section reports. You can bind it to data or set it at run time. It is the same control that forms when you drag a field onto a report from the Report Explorer.

Important Properties

Property | Description
CharacterSpacing | Gets or sets a character spacing in points.
LineSpacing | Gets or sets a line spacing in points.
OutputFormat | Gets or sets the mask string used to format the Value property before placing it in the Text property.
Style | Gets or sets a style string for the textbox.
TextJustify | Specifies text justification with TextAlign set to Justify.
VerticalAlignment | Gets or sets the position of the textbox's text vertically within the bounds of the control.
VerticalText | Gets or sets whether to render text according to vertical layout rules.
CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
CanShrink | Determines whether ActiveReports should decrease the height of the control based on its value.
MultiLine | Gets or sets a value indicating whether this is a multi-line textbox control.
ShrinkToFit | Determines whether ActiveReports decreases the font size when text values exceed available space.
WrapMode | Indicates whether a multi-line textbox control automatically wraps words or characters to the beginning of the next line when necessary.
CountNullValues | Boolean which determines whether DBNull values should be included as zeroes in summary fields.
Culture | Gets or sets CultureInfo used for value output formatting.
DataField | Gets or sets the field name from the data source to bind to the control.
HyperLink | Gets or sets the hyperlink for the text control.
Text | Gets or sets the formatted text value to be rendered in the control.
DistinctField | Gets or sets the name of the data field used in a distinct summary function.
SummaryFunc | Gets or sets the summary function type used to process the DataField Values.
SummaryGroup | Gets or sets the name of the group header section that is used to reset the summary value when calculating subtotals.
SummaryRunning | Gets or sets a value that determines whether that data field summary value will be accumulated or reset for each level (detail, group or page).
SummaryType | Gets or sets a value that determines the summary type to be performed.

You can double-click in the TextBox control to enter edit mode and enter text directly in the control, or you can enter text in the Properties window or in code through the Text property.

You can format text in the TextBox control in edit mode using the ActiveReports toolbar, or you can modify properties in the Properties window. Formats apply to all of the text in the control. Text formatting changes in the Properties window immediately appear in the control, and changes made in the toolbar are immediately reflected in the Properties window.

Note: In edit mode for a TextBox with the Alignment property set to Justify, the Alignment value temporarily changes to the default value, Left. Once you leave edit mode, it automatically changes back to Justify.

Keyboard Shortcuts

In edit mode, you can use the following keyboard shortcuts.

Key Combination | Action
Enter | New line.
Alt + Enter | Saves modifications and exits edit mode.
Esc | Cancels modifications and exits edit mode.

In the End User Designer, you can disable this feature in the EditModeEntering and EditModeExit events.

TextBox Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

General

Name: Enter a name for the textbox that is unique within the report. This name is displayed in the Document Outline and in XML exports.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

DataField: Select a field from the data source to bind to the control.

Text: Enter static text to show in the textbox. If you specify a DataField value, this property is ignored.

HyperLink: Enter a URL to use in the Viewer HyperLink event. The URL automatically converts to an anchor tag or hyperlink in PDF and HTML exports.

Appearance

Background Color: Select a color to use for the background of the textbox.

Font

Name: Select a font family name or a theme font.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic.

Weight: Choose from Normal or Bold.

Color: Choose a color to use for the text.

Decoration: Select check boxes for Underline and Strikeout.

GDI Charset: Enter a value to indicate the GDI character set to use. For a list of valid values, see MSDN Font.GDICharSet Property.

GDI Vertical: Select this checkbox to indicate that the font is derived from a GDI vertical font.

Format

Line spacing: Enter a value in points to use for the amount of space between lines.

Character spacing: Enter a value in points to use for the amount of space between characters.

Multiline: Select this check box to allow text to render on multiple lines within the control.

Textbox height

Can increase to accommodate contents: Select this check box to set CanGrow to True.

Can decrease to accommodate contents: Select this check box to set CanShrink to True.

Can shrink text to fit fixed size control: Select this check box to set ShrinkToFit to True.

Text direction

RightToLeft: Select this check box to reverse the text direction.

Vertical text: Select this check box for top to bottom text.

Alignment

Vertical alignment: Choose Top, Middle, or Bottom.

Horizontal alignment: Choose Left, Center, Right, or Justify.

Justify method: Choose Auto, Distribute, or DistributeAllLines.

Wrap mode: Choose NoWrap, WordWrap, or CharWrap to select whether to wrap words or characters to the next line.

Note: You must select Justify in the Horizontal alignment property to enable the Justification method property options.

Wrap mode: Choose NoWrap, WordWrap, or CharWrap to determine whether and how text breaks to the next line.

Padding

Enter values in points to set the amount of space to leave around the label.

  • Top
  • Left
  • Right
  • Bottom

Summary

SummaryFunc: Select a type of summary function to use if you set the SummaryRunning and SummaryType properties to a value other than None. For descriptions of the available functions, see the SummaryFunc Enumeration.

SummaryGroup: Select a section group that you have added to the report. If you also set the SummaryRunning property to Group, the textbox summarizes only the values for that group.

SummaryRunning: Select None, Group, or All. If None, the textbox shows the value for each record. If Group, the textbox summarizes the value for the selected SummaryGroup. If All, the textbox summarizes the value for the entire report.

SummaryType: Select the type of summary to use. For descriptions of the available types, see the SummaryType Enumeration.

Distinct Field: Select a field to use with one of the SummaryFunc distinct enumerated values.

Count null values: Select this check box to include null values as zeroes in summary fields.

See Also
TextBox


CheckBox (Section Report)

CheckBox (Section Report)
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > CheckBox (Section Report)
Show All Show All
Hide All Hide All

In ActiveReports, you can use the CheckBox control to represent a Boolean value in a report. By default, it appears as a small box with text to the right. If the DataField value evaluates to True, the small box appears with a check mark; if False, the box is empty. By default, the checkbox is empty.

Important Properties

Property | Description
CheckAlignment | Gets or sets the alignment of the check box text within the control drawing area.
Checked | Gets or sets a value indicating whether the check box is in the checked state. You can also set the Checked property of the check box in code or bind it to a Boolean database value.
DataField | Gets or sets the field from the data source to bind to the control.
Text | Gets or sets the printed caption of the check box.

You can double-click in the CheckBox control to enter edit mode and enter text directly in the control, or you can enter text in the Properties window or you can assign data to display in code through the Text property.

You can format text in the CheckBox control in edit mode using the ActiveReports toolbar, or you can modify properties in the Properties window. Formats apply to all of the text in the control. Text formatting changes in the Properties window immediately appear in the control, and changes made in the toolbar are immediately reflected in the Properties window.

Note: In edit mode for a CheckBox with the Alignment property set to Justify, the Alignment value temporarily changes to the default value, Left. Once you leave edit mode, it automatically changes back to Justify.

Keyboard Shortcuts

In edit mode, you can use the following keyboard shortcuts.

Key Combination | Action
Enter | New line.
Alt + Enter | Saves modifications and exits edit mode.
Esc | Cancels modifications and exits edit mode.

In the End User Designer, you can disable this feature in the EditModeEntering and EditModeExit events.

CheckBox Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

General

Name: Enter a name for the CheckBox that is unique within the report. This name is displayed in the Document Outline and in XML exports.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

DataField: Select a field that returns a Boolean value from the data source to bind to the control. The value of this field determines how to set the Checked property at run time.

Text: Enter static text to show in the textbox. If you specify a DataField value, this property is ignored.

Check Alignment: Drop down the visual selector to choose the vertical and horizontal position for the check box within the control.

Checked: Select this check box to have the CheckBox control appear with a check mark in the box.

Appearance

Background Color: Select a color to use for the background of the textbox.

Font

Name: Select a font family name or a theme font.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic.

Weight: Choose from Normal or Bold.

Color: Choose a color to use for the text.

Decoration: Select check boxes for Underline and Strikeout.

GDI Charset: Enter a value to indicate the GDI character set to use. For a list of valid values, see MSDN Font.GDICharSet Property.

GDI Vertical: Select this checkbox to indicate that the font is derived from a GDI vertical font.

Alignment

Wrap mode: Choose NoWrap, WordWrap, or CharWrap to select whether to wrap words or characters to the next line.

Padding

Enter values in points to set the amount of space to leave around the check box.

  • Top
  • Left
  • Right
  • Bottom
See Also
CheckBox (Page Report)


RichTextBox

RichTextBox
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > RichTextBox
Show All Show All
Hide All Hide All

In ActiveReports, the RichTextBox control is used to display, insert and manipulate formatted text. It is different from the TextBox control in a number of ways. The most obvious is that it allows you to apply different formatting to different parts of its content.

You can also load an RTF file or an HTML file into the RichTextBox control at design time or at run time, and you can use it to create field merged reports with field placeholders that you replace with values at run time. You can add fields to the text you enter directly in the control by right-clicking and choosing Insert Fields and providing a field name.

For more information, see Load a File into a RichTextBox Control and Mail Merge with RichTextBox.

Important Properties

Property | Description
AutoReplaceFields | If True, any fields in the RTF control are replaced with fields from the data source.
CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
CanShrink | Determines whether ActiveReports should decrease the height of the field based on its value.
MultiLine | Gets or sets a value that determines whether the RichTextBox prints multiple lines or a single line.
DataField | Gets or sets the field name from the data source to bind to the control.

Keyboard Shortcuts

In edit mode, you can use the following keyboard shortcuts.

Key Combination | Action
Enter | New line.
Alt + Enter | Saves modifications and exits edit mode.
Esc | Cancels modifications and exits edit mode.

In the End User Designer, you can disable this feature in the EditModeEntering and EditModeExit events.

Load File Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Load file command to open the dialog. This allows you to select a file to load into the control at design time. Supported file types are as follows.

  • Text (*.txt)
  • RichText (*.rtf)
  • HTML (*.htm, *.html)

To load a file into the report at run time, use the Load method. For more information, see Load Method.

Supported Tags

HTML Tags

The following HTML tags are supported in the RichTextBox control.

Tip: In order to show special characters in an HTML file loaded into the control, use the character entity reference (for example, &egrave; for è or &amp; for &).
Tag | Description | Attributes
<B> | Bold | none
<I> | Italic | none
<P> | Paragraph | align, style
<STRONG> | Strong (looks like bold) | none
<BIG> | Big | none
<SMALL> | Small | none
<PRE> | Preformatted | none
<FONT> | Font | face, size, color, style (see notes for style attributes)
<BODY> | The body tag | background, text, leftmargin
<H1> - <H6> | Heading levels one through six | none
<BR> | Line break | none
<EM> | Emphasized (looks like Italics) | none
<U> | Underlined | none
<IMG> | Image | align, height, src, width
<SUP> | Superscript | none
<SUB> | Subscript | none
<CENTER> | Center alignment | none
<TABLE> | Table | align, border, cellpadding, cellspacing, height, style, width
<TR> | Table row | align
<TH> | Table head | none
<TD> | Table datum | align, border, colspan, rowspan, width
<LI> | List item | none (nested levels automatically use disc, then circle, then square bullets)
<OL> | Ordered list | type
<UL> | Unordered list | type
<STRIKE> | Strike through | none

Style Attribute Properties

The style attribute of <FONT>, <P>, and <TABLE> tags supports the following properties.

  • border-bottom
  • border-bottom-width
  • border-color
  • border-left
  • border-left-width
  • border-right
  • border-right-width
  • border-style
  • border-top
  • border-top-width
  • border-width
  • font-family
  • font-size
  • height
  • line-height
  • margin-bottom
  • margin-left
  • margin-right
  • margin-top
  • padding-bottom
  • padding-left
  • padding-right
  • padding-top
  • table-layout
  • text-align
  • text-indent
  • width

RichTextBox Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

General

Name: Enter a name for the RichTextBox that is unique within the report. This name is displayed in the Document Outline and in XML exports.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

DataField: Select a field from the data source to bind to the control.

Max length: Enter the maximum number of characters to display in the control. If you do not specify a value, it displays an unlimited number of characters.

AutoReplaceFields: Select this check box to have ActiveReports replace any fields in the control with values from the data source.

Appearance

Background Color: Select a color to use for the background of the control.

Format

RichTextBox height

Can increase to accommodate contents: Select this check box to set CanGrow to True.

Can decrease to accommodate contents: Select this check box to set CanShrink to True.

Multiline: Select this check box to allow the control to display multiple lines of text.


Shape (Section Report)

Shape (Section Report)
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Shape (Section Report)
Show All Show All
Hide All Hide All

In ActiveReports, the Shape control is used to add simple shapes to a report.

Important Properties

Property | Description
LineColor | Gets or sets the color of the shape lines.
LineStyle | Gets or sets the pen style used to draw the line.
LineWeight | Gets or sets the pen width used to draw the shape in pixels.
Style | Gets or sets the shape type to draw. You can select from Rectangle, Ellipse and a RoundedRect.
RoundingRadius | Sets the radius of each corner for the RoundRect shape type. You can select Default, TopLeft, TopRight, BottomLeft or BottomRight. Selecting Default sets the radius of all the corners of the Shape control to a specified percentage. Default value = 10 (percent).

Shape Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

General

Name: Enter a name for the shape that is unique within the report. This name is displayed in the Document Outline and in XML exports.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

Appearance

Shape type: Select the type of shape to display. You can choose from Rectangle, Ellipse, or RoundRect. For a circle, set the control width and height properties to the same value, and choose Ellipse, or choose RoundRect and set the Rounding radius to 100%.

Rounded Rectangle: When the Shape type is set to RoundRect, you can specify the radius for each corner of the shape independently. Drag the handlers [image] available at each corner of the shape to set the value of the radius at each corner.

Note: To enable specific corners, check the CheckBox available near each corner of the Shape control.

  • Use the same radius on specified corners: Select this option to apply the same radius to all selected corners of the shape.

  • Use different radius on specified corners: Select this option to apply a different radius to each selected corner of the shape.

Line style: Select a line style to use for the shape line. You can set it to Transparent, Solid, Dash, Dot, DashDot, or DashDotDot.

Line weight: Enter the width in pixels for the shape line.

Line color: Select a color to use for the shape line.

Background color: Select a color to use for the background of the shape.

See Also
Shape Class (Page Report)
Shape


Picture

Picture
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Picture
Show All Show All
Hide All Hide All

In section reports, the Picture control is used to print an image on the report. In the Image property of the Picture control, you can select any image file to display on your report.

Note: Use the PictureAlignment and SizeMode properties to control cropping and alignment.

Important Properties

Property | Description
LineColor | Gets or sets the border line color around the Picture control.
LineStyle | Gets or sets the pen style used to paint the border around the Picture control.
LineWeight | Gets or sets the pen width of the border line in pixels.
PictureAlignment | Gets or sets the position of the image within the control area.
Description | Gets or sets the alternate description for the picture. Used in the Html Export for the "alt" img tag property.
HyperLink | Gets or sets a URL address that can be used in the viewer's Hyperlink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Image | Gets or sets the image to print.
SizeMode | Gets or sets a value that determines how the image is sized to fit the Picture control area.

Picture Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

General

Name: Enter a name for the picture control that is unique within the report. This name is displayed in the Document Outline and in XML exports.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

DataField: Select a field from the data source to bind to the control.

Choose image: Click this button open a dialog where you can navigate to a folder from which to select an image file to display.

HyperLink: Enter a URL to use in the Viewer HyperLink event. The URL automatically converts to an anchor tag or hyperlink in PDF and HTML exports.

Title: Enter static text for the picture.

Description: Enter text to describe the image for those who cannot see it. This is used in the HTML export for the "alt" attribute of the img tag.

Appearance

Line style: Select a line style to use for the border line. You can set it to Transparent, Solid, Dash, Dot, DashDot, or DashDotDot.

Line weight: Enter the width in pixels for the border line.

Line color: Select a color to use for the border line.

Background color: Select a color to use for the background of the picture control.

Picture alignment: Select how to align the image within the control. You can select from TopLeft, TopRight, Center, BottomLeft, or BottomRight.

Size mode: Select how to size the image within the control. You can select from Clip, Stretch, or Zoom. Clip uses the original image size and clips off any excess, Stretch fits the image to the size and shape of the control, and Zoom fits the image into the control while maintaining the aspect ratio of the original image.

See Also
Image (Page Report)


Line (Section Report)

Line (Section Report)
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Line (Section Report)
Show All Show All
Hide All Hide All

In ActiveReports, the Line control allows you to draw vertical, horizontal or diagonal lines that visually separate or highlight areas within a section on a report.

Note: If you need lines to span across report sections, please see the CrossSectionLine control.

You can use your mouse to visually move and resize the Line, or you can use the Properties window to change its X1, X2, Y1, and Y2 properties to specify the coordinates for its starting and ending points.

Important Properties

Property | Description
AnchorBottom | Anchors the line to the bottom of the containing section so that the line grows along with the section.
LineColor | Gets or sets the color of the line.
LineStyle | Gets or sets the pen style used to draw the line.
LineWeight | Gets or sets the pen width of the line in pixels.
X1 | Gets or sets the horizontal coordinate of the line's starting point.
X2 | Gets or sets the horizontal coordinate of the line's end point.
Y1 | Gets or sets the vertical coordinate of the line's starting point.
Y2 | Gets or sets the vertical coordinate of the line's end point.

Line Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

General

Name: Enter a name for the line that is unique within the report. This name is displayed in the Document Outline and in XML exports.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

Appearance

Line style: Select a line style to use for the line. You can set it to Transparent, Solid, Dash, Dot, DashDot, or DashDotDot.

Line weight: Enter the width in pixels for the line.

Line color: Select a color to use for the line.

Anchor at bottom: Select this check box to automatically change the Y2 value to the value of the bottom edge of the containing section after it has grown to accommodate data at run time.

See Also
Line Class (Page Report)
Line (Page Report)
Cross Section Controls


PageBreak

PageBreak
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > PageBreak
Show All Show All
Hide All Hide All

You can cause ActiveReports to break to a new page at any point within any section using the PageBreak control. All controls placed below the PageBreak in the section render to a new page.

Tip: Another way to cause ActiveReports to break to a new page is by setting the NewPage property of a section to Before, After, or BeforeAfter. This property is available on any section except for PageHeader and PageFooter.

Important Properties

Property | Description
Enabled | Determines whether to enable the PageBreak.
Location - X | Gets or sets the horizontal location of an object.
Location - Y | Gets or sets the vertical location of an object.

PageBreak Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

General

Name: Enter a name for the PageBreak that is unique within the report. This name is displayed in the Document Outline and in XML exports.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Enabled: Select a field from the data source to bind to the control.


Barcode (Section Report)

Barcode (Section Report)
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Barcode (Section Report)
Show All Show All
Hide All Hide All

The Barcode report control offers 39 different barcode styles to choose from. This saves you the time and expense of finding and integrating a separate component. As with other data-bound report controls, you can bind a barcode to data using the DataField property.

Apart from the barcode style, you can manage the alignment, color, background color, caption position, font, text, and check whether checksum is enabled in the Properties Window. There are more properties available with the Code49, PDF417, and QRCode barcode styles. Click the Barcode to reveal its properties in the Properties window. All of the properties specific to this report control are also available in the Barcode dialog.

Important Properties

The following properties help you to customize the specific barcode you need for your application:

Property | Description
Alignment | The horizontal alignment of the caption in the control. Select from Near, Center, or Far. See CaptionPosition for vertical alignment.
AutoSize | When set to True, the barcode automatically stretches to fit the control.
BackColor | Select a background fill color for the barcode.
BarHeight | Set the height, in inches, of the barcode's bars. If the bar height exceeds the height of the control, this property is ignored.
CaptionGrouping | Gets or sets a value indicating whether to add spaces between groups of characters in the caption to make long numbers easier to read. This property is only available with certain styles of barcode, and is ignored with other styles.
CaptionPosition | The vertical alignment of the caption in the control. Select from None, Above, or Below. See Alignment for horizontal alignment. None is selected by default, and no caption is displayed.
CheckSumEnabled | Some barcode styles require a checksum and some have an optional checksum. CheckSumEnabled has no effect if the style already requires a check digit or if the style does not offer a checksum option.
Code128 Code128 has three settings that work in conjunction: Dpi, BarAdjust, and ModuleSize. This property only applies to the barcode style EANFNC1. You can improve the readability of the barcode by setting all three properties.
  • Dpi sets the printer resolution. Specify the resolution of the printer as dots per inch to create an optimized barcode image with the specified Dpi value.
  • BarAdjust sets the adjustment size by dot units, which affects the size of the module and not the entire barcode.
  • ModuleSize sets the horizontal size of the barcode module.
Code49 | Code49 options include Grouping and Group. If Grouping is set to True, any value not expressed by a single barcode is expressed by splitting it into several barcodes, and the Group property may be set to a number between 0 and 8. The default values are False and 0, respectively. When the Group property is set to 2, the grouped barcode's second symbol is created. When invalid group numbers are set, the BarCodeDataException is thrown.
DataMatrix | DataMatrix options include EccMode, Ecc200SymbolSize, Ecc200EncodingMode, Ecc000_140SymbolSize, StructuredAppend, StructureNumber, and FileIdentifier. Select from supplied values, or enter a number for the StructureNumber and FileIdentifier.
Font | Set the font for the caption. Only takes effect if you set the CaptionPosition property to a value other than None.
ForeColor | Select a color for the barcode and caption.
GS1Composite GS1Composite Options only apply to the barcode styles RSS14Stacked and RSSLimited.
  • Type sets the composite symbol type.
  • Value sets the CCA character data.
MicroPDF417 MicroPDF417 Options only apply to the MicroPDF417 barcode style.
  • CompactionMode sets the type of the compaction mode. The possible values are Auto (default), TextCompactionMode, NumericCompactionMode, or ByteCompactionMode.
  • FileID sets the file id of the structured append symbol. The valid value is from 0 to 899.
  • SegmentCount sets the segment count of the structured append symbol. The valid value is from 0 to 99999.
  • SegmentIndex sets the segment index of the structured append symbol. The valid value is from 0 to 99998, and less than the value in Segment Count.
  • Version sets the symbol size.
NarrowBarWidth

Also known as the X dimension, this is a value defining the width of the narrowest part of the barcode. Before using an extremely small value for this width, ensure that the scanner can read it. This value is specified in pixels (for example, 10 pixels).
NWRatio | Also known as the N dimension, this is a value defining the multiple of the ratio between the narrow and wide bars in symbologies that contain bars in only two widths. For example, if it is a 3 to 1 ratio, this value is 3.
PDF417 PDF417 Options only apply to the barcode style PDF417.
  • Column sets column numbers for the barcode. Values for this property range from 1 to 30. The default value is -1 which automatically determines row numbers.
  • ErrorLevel sets the error correction level for the barcode. Values range between 0 and 8. The error correction capability increases as the value increases. With each increase in the ErrorLevel value, the size of the barcode increases. The default value is -1 for automatic configuration.
  • Row sets row numbers for the barcode. Values range between 3 and 90. The default value is -1 which automatically determine row numbers.
  • Type sets the barcode type to Normal or Simple. Simple is the compact type in which the right indicator is neither displayed nor printed.
QRCode QRCode Options only apply to the barcode style QRCode.
  • Connection allows any value which cannot be expressed by a single barcode to split into several barcodes. This property is used in conjunction with the ConnectionNumber property.
  • ConnectionNumber Use this property with the Connection property to set the number of barcodes it can split into. Values between 0 and 15 are valid. An invalid number raises the BarCodeData Exception.
  • ErrorLevel values are L (7% restorable), M (15% restorable), Q (25% restorable), and H (30% restorable). The higher the percentage, the larger the barcode becomes.
  • Mask is used to balance brightness and offers 8 patterns in the QRCodeMask enumeration. The default value is Auto, which sets the masking pattern automatically, and is recommended for most uses.
    • Mask000 (i+j) mod 2 = 0
    • Mask001 i mod 2 = 0
    • Mask010 j mod 3 = 0
    • Mask011 (i+j) mod 3 = 0
    • Mask100 (( i div 2)+(j div 3)) mod 2 = 0
    • Mask101 (ij) mod 2 + (ij) mod 3 = 0
    • Mask110 ((ij) mod 2 +(ij) mod 3) mod 2 = 0
    • Mask111 ((ij)mod 3 + (i+j) mod 2) mod 2 = 0
  • Model sets Model1, the original model, or Model2, the extended model.
  • Version indicates the size of the barcode. As the value increases, the barcode's size increases, enabling more information to be stored. Specify any value between 1 and 14 when the Model property is set to Model1 and 1 to 40 for Model2. The default value is -1, which automatically determines the version most suited to the value.
QuietZone | Sets an area of blank space on each side of a barcode that tells the scanner where the symbology starts and stops. You can set separate values for the Left, Right, Top, and Bottom.
Rotation | Sets the amount of rotation to use for the barcode. You can select from None, Rotate90Degrees, Rotate180Degrees, or Rotate270Degrees.
RssExpandedStacked | Sets the number of stacked rows to use.
Style | Sets the symbology used to render the barcode. See the table below for details about each style.
SupplementOptions | Sets the 2/5-digit add-ons for EAN/UPC symbologies. You can specify Text, DataField, BarHeight, CaptionPosition, and Spacing for the supplement.
Text | Sets the value to print as a barcode symbol and caption. ActiveReports fills this value from the bound data field if the control is bound to the data source.

Limitations

Some barcode types may render incorrectly and contain white lines in the Html and RawHtml views. However, this limitation does not affect printing and scanning. The list of barcode types that may render with white lines in the Html and RawHtml views:

  • Code49
  • QRCode
  • Pdf417
  • RSSExpandedStacked
  • RSS14Stacked
  • RSS14StackedOmnidirectional

Barcode Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

General

Name: Enter a name for the control that is unique within the report. This name is displayed in the Document Outline and in XML exports.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

DataField: Select a field from the data source to bind to the control.

Text: Enter static text to show in the textbox. If you specify a DataField value, this property is ignored.

Autosize: Clear this check box to prevent the barcode from automatically resizing to fit the control.

Caption

Location: Select a value to indicate whether and where to display a caption for the barcode. You can select from Above, Below, or None.

Text alignment: Select a value to indicate how to align the caption text. You can select from Center, Near, or Far.

Barcode Settings

Style: Enter the type of barcode to use. ActiveReports supports all of the most popular symbologies:

Table of all included symbologies

Notes: The RSS and QRCode styles have fixed height-to-width ratios. When you resize the width, the height is automatically calculated.

When you choose a style that offers supplemental options, the additional options appear below.
Symbology Name | Example | Description
Ansi39 | ANSI 3 of 9 (Code 39) uses upper case, numbers, - , * $ / + %. This is the default barcode style.
Ansi39x | ANSI Extended 3 of 9 (Extended Code 39) uses the complete ASCII character set.
Codabar | Codabar uses A B C D + - : . / $ and numbers.
Code_128_A | Code 128 A uses control characters, numbers, punctuation, and upper case.
Code_128_B | Code 128 B uses punctuation, numbers, upper case and lower case.
Code_128_C | Code 128 C uses only numbers.
Code_128auto | Code 128 Auto uses the complete ASCII character set. Automatically selects between Code 128 A, B and C to give the smallest barcode.
Code_2_of_5 | Code 2 of 5 uses only numbers.
Code_93 | Code 93 uses uppercase, % $ * / , + -, and numbers.
Code25intlv | Interleaved 2 of 5 uses only numbers.
Code39 | Code 39 uses numbers, % * $ /. , - +, and upper case.
Code39x | Extended Code 39 uses the complete ASCII character set.
Code49 | Code 49 is a 2D high-density stacked barcode containing two to eight rows of eight characters each. Each row has a start code and a stop code. Encodes the complete ASCII character set.
Code93x | Extended Code 93 uses the complete ASCII character set.
DataMatrix | Data Matrix is a high density, two-dimensional barcode with square modules arranged in a square or rectangular matrix pattern.
EAN_13 | EAN-13 uses only numbers (12 numbers and a check digit). It takes only 12 numbers as a string to calculate a check digit (CheckSum) and add it to the thirteenth position. The check digit is an additional digit used to verify that a bar code has been scanned correctly. The check digit is added automatically when the CheckSumEnabled property is set to True.
EAN_13 with the add-on code | EAN-13 may include the add-on code to the right of the main code. The add-on code may include up to 5 supplemental characters.
EAN_8 | EAN-8 uses only numbers (7 numbers and a check digit).
EAN128FNC1 EAN-128 is an alphanumeric one-dimensional representation of Application Identifier (AI) data for marking containers in the shipping industry.

This type of bar code contains the following sections:

  • Leading quiet zone (blank area)
  • Code 128 start character
  • FNC (function) 1 character which allows scanners to identify this as an EAN-128 barcode
  • Data (AI plus data field)
  • Symbol check character (Start code value plus product of each character position plus value of each character divided by 103. The checksum is the remainder value.)
  • Stop character
  • Trailing quiet zone (blank area)

The AI in the Data section sets the type of the data to follow (i.e. ID, dates, quantity, measurements, etc.). There is a specific data structure for each type of data. This AI is what distinguishes the EAN-128 code from Code 128.

Multiple AIs (along with their data) can be combined into a single bar code.

EAN128FNC1 is a UCC/EAN-128 (EAN128) type barcode that allows you to insert FNC1 character at any place and adjust the bar size, etc., which is not available in UCC/EAN-128.

To insert FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at runtime.
IntelligentMail | Intelligent Mail, formerly known as the 4-State Customer Barcode, is a 65-bar code used for domestic mail in the U.S.
JapanesePostal | This is the barcode used by the Japanese Postal system. Encodes alpha and numeric characters consisting of 18 digits including a 7-digit postal code number, optionally followed by block and house number information. The data to be encoded can include hyphens.
Matrix_2_of_5 | Matrix 2 of 5 is a higher density barcode consisting of 3 black bars and 2 white bars.
MicroPDF417

MicroPDF417 is two-dimensional (2D), multi-row symbology, derived from PDF417. Micro-PDF417 is designed for applications that need to encode data in a two-dimensional (2D) symbol (up to 150 bytes, 250 alphanumeric characters, or 366 numeric digits) with the minimal symbol size.

MicroPDF417 allows you to insert an FNC1 character as a field separator for variable length Application Identifiers (AIs).

To insert FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at runtime.
MSI | MSI Code uses only numbers.
Pdf417 | Pdf417 is a popular high-density 2-dimensional symbology that encodes up to 1108 bytes of information. This barcode consists of a stacked set of smaller barcodes. Encodes the full ASCII character set. It has ten error correction levels and three data compaction modes: Text, Byte, and Numeric. This symbology can encode up to 1,850 alphanumeric characters or 2,710 numeric characters.
PostNet | PostNet uses only numbers with a check digit.
QRCode | QRCode is a 2D symbology that is capable of handling numeric, alphanumeric and byte data as well as Japanese kanji and kana characters. This symbology can encode up to 7,366 characters.
RM4SCC | Royal Mail RM4SCC uses only letters and numbers (with a check digit). This is the barcode used by the Royal Mail in the United Kingdom.
RSS14 | RSS14 is a 14-digit Reduced Space Symbology that uses EAN.UCC item identification for point-of-sale omnidirectional scanning.
RSS14Stacked RSS14Stacked uses the EAN.UCC information with Indicator digits as in the RSS14Truncated, but stacked in two rows for a smaller width.
RSS14Stacked allows you to set Composite Options, where you can select the type of the barcode in the Type drop-down list and the value of the composite barcode in the Value field.
RSS14Stacked CCA | RSS14Stacked with Composite Component - Version A.
RSS14StackedOmnidirectional | RSS14StackedOmnidirectional uses the EAN.UCC information with omnidirectional scanning as in the RSS14, but stacked in two rows for a smaller width.
RSS14Truncated | RSS14Truncated uses the EAN.UCC information as in the RSS14, but also includes Indicator digits of zero or one for use on small items not scanned at the point of sale.
RSSExpanded

RSSExpanded uses the EAN.UCC information as in the RSS14, but also adds AI elements such as weight and best-before dates.

RSSExpanded allows you to insert an FNC1 character as a field separator for variable length Application Identifiers (AIs).

To insert FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at runtime.
RSSExpandedStacked

RSSExpandedStacked uses the EAN.UCC information with AI elements as in the RSSExpanded, but stacked in two rows for a smaller width.

RSSExpandedStacked allows you to insert an FNC1 character as a field separator for variable length Application Identifiers (AIs).

To insert FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at runtime.
RSSLimited RSS Limited uses the EAN.UCC information as in the RSS14, but also includes Indicator digits of zero or one for use on small items not scanned at the point of sale.
RSSLimited allows you to set Composite Options, where you can select the type of the barcode in the Type drop-down list and the value of the composite barcode in the Value field.
RSSLimited CCA | RSS Limited with Composite Component - Version A.
UCCEAN128 | UCC/EAN –128 uses the complete ASCII character Set. This is a special version of Code 128 used in HIBC applications.
UPC_A | UPC-A uses only numbers (11 numbers and a check digit).
UPC_A with the add-on code | UPC_A may include the add-on code to the right of the main code. The add-on code may include up to 5 supplemental characters.
UPC_E0 | UPC-E0 uses only numbers. Used for zero-compression UPC symbols. For the Caption property, you may enter either a six-digit UPC-E code or a complete 11-digit (includes code type, which must be zero) UPC-A code. If an 11-digit code is entered, the Barcode control will convert it to a six-digit UPC-E code, if possible. If it is not possible to convert from the 11-digit code to the six-digit code, nothing is displayed.
UPC_E0 with the add-on code | UPC_E0 may include the add-on code to the right of the main code. The add-on code may include up to 5 supplemental characters.
UPC_E1 | UPC-E1 uses only numbers. Used typically for shelf labeling in the retail environment. The length of the input string for U.P.C. E1 is six numeric characters.
UPC_E1 with the add-on code | UPC_E1 may include the add-on code to the right of the main code. The add-on code may include up to 5 supplemental characters.

Bar Height: Enter a value in inches (for example, .25in) for the height of the barcode.

Narrow Bar Width (also known as X dimension): Enter a value in points (for example, 0.8pt) for the width of the narrowest part of the barcode. Before using an extremely small value for this width, ensure that the scanner can read it.

Tip: For accurate scanning, the quiet zone should be ten times the Narrow Bar Width value.

Narrow Width Bar Ratio: Enter a value to define the multiple of the ratio between the narrow and wide bars in symbologies that contain bars in only two widths. For example, if it is a 3 to 1 ratio, this value is 3. Commonly used values are 2, 2.5, 2.75, and 3.

Quiet Zone

A quiet zone is an area of blank space on either side of a barcode that tells the scanner where the symbology starts and stops.

Left: Enter a size in inches of blank space to leave to the left of the barcode.

Right: Enter a size in inches of blank space to leave to the right of the barcode.

Top: Enter a size in inches of blank space to leave at the top of the barcode.

Bottom: Enter a size in inches of blank space to leave at the bottom of the barcode.

Note: The units of measure listed for all of these properties are the default units of measure used if you do not specify. You may also specify cm, mm, in, pt, or pc.

Checksum

A checksum provides greater accuracy for many barcode symbologies.

Compute Checksum: Select whether to automatically calculate a checksum for the barcode.

Note: If the symbology you choose requires a checksum, setting this value to False has no effect.

Code49 Options

Code49 Options are available for the Code49 barcode style.

Use Grouping: Indicates whether to use grouping for the Code49 barcode. The possible values are True or False.

Group Number: Enter a number between 0 and 8 for the barcode grouping.

DataMatrix Options

DataMatrix Options are available for the DataMatrix barcode style.

EccMode: Select the Ecc mode from the drop-down list. The possible values are ECC000, ECC050, ECC080, ECC100, ECC140 or ECC200.

Ecc200 Symbol Size: Select the size of the ECC200 symbol from the drop-down list. The default value is SquareAuto.

Ecc200 Encoding Mode: Select the encoding mode for ECC200 from the drop-down list. The possible values are Auto, ASCII, C40, Text, X12, EDIFACT or Base256.

Ecc000_140 Symbol Size: Select the size of the ECC000_140 barcode symbol from the drop-down list.

Structured Append: Select whether the barcode symbol is part of the structured append symbols. The possible values are True or False.

Structure Number: Enter the structure number of the barcode symbol within the structured append symbols.

File Identifier: Enter the file identifier of a related group of the structured append symbols. If you set the value to 0, the file identifier symbols are calculated automatically.

EAN Supplementary Options

EAN Supplementary Options are available for the EAN_13 and EAN_8 barcode styles.

Supplement DataField: Select the data field for the barcode supplement.

Supplement Value: Enter the expression to set the value of the barcode supplement.

Caption Location: Select the location for the supplement caption from the drop-down list. The possible values are None, Above or Below.

Supplement Bar Height: Enter the bar height for the barcode supplement.

Supplement Spacing: Enter the spacing between the main and the supplement barcodes.

EAN128FNC1 Options

EAN128FNC1 Options are available for the EAN128FNC1 barcode style.

DPI: Specify the printer resolution.

Module Size: Enter the horizontal size of the barcode module.

Bar Adjust: Enter the adjustment size by dot units, which affects the size of the module and not the entire barcode.

GS1Composite Options

GS1Composite Options are available for the RSS14Stacked and RSSLimited barcode styles.

Type: Select the type of the composite barcode from the drop-down list. The possible values are None or CCA. CCA (Composite Component - Version A) is the smallest variant of the 2-dimensional composite component.

Value: Enter the expression to set the value of the composite barcode.

MicroPDF417 Options

MicroPDF417 Options are available for the MicroPDF417 barcode style.

Compaction Mode: Select the type of the compaction mode from the drop-down list. The possible values are Auto, TextCompactionMode, NumericCompactionMode, or ByteCompactionMode.

Version: Select the version from the drop-down box to set the symbol size.

Segment Index: The segment index of the structured append symbol. The valid value is from 0 to 99998, and less than the value in Segment Count.

Segment Count: The segment count of the structured append symbol. The valid value is from 0 to 99999.

File ID: The file id of the structured append symbol. The valid value is from 0 to 899.

PDF417 Options

PDF417 Options are available for the Pdf417 barcode style.

Columns: Enter column numbers for the barcode.

Rows: Enter row numbers for the barcode.

Error Correction Level: Enter the error correction level for the barcode.

PDF 417 Barcode Type: Select the PDF417 barcode type form the drop-down list. The possible values are Normal or Simple.

QRCode Options

QRCode Options are available for the QRCode barcode style.

Model: Select the model for the QRCode barcode style from the drop-down list. The possible values are Model1 or Model2.

ErrorLevel: Select the error correction level for the barcode from the drop-down list. The possible values are M, L, H or Q.

Version: Enter the version of the QRCode barcode style.

Mask: Select the pattern for the barcode masking form the drop-down list.

Use Connection: Select whether to use the connection for the barcode. The possible values are True or False.

ConnectionNumber: Enter the connection number for the barcode.

Encoding: Select the barcode encoding from the drop-down list.

RssExpandedStacked Options

RssExpandedStacked Options are available for the RSSExpandedStacked barcode style.

Row Count: Enter the number of the barcode stacked rows.

UPC Supplementary Options

UPC Supplementary Options are available for the UPC_A, UPC_E0 and UPC_E1 barcode styles.

Supplement DataField: Select the data field for the barcode supplement.

Supplement Value: Enter the expression to set the value of the barcode supplement.

Caption Location: Select the location for the supplement caption from the drop-down list. The possible values are None, Above or Below.

Supplement Bar Height: Enter the bar height for the barcode supplement.

Supplement Spacing: Enter the spacing between the main and supplement barcodes.

Appearance

Fore color: Select a color to use for the bars in the barcode.

Background color: Select a color to use for the background of the control.

Rotation: Select a value indicating the degree of rotation to apply to the barcode. You can select from None, Rotate90Degrees, Rotate180Degrees, or Rotate270Degrees.

Font

Name: Select a font family name to use for the caption.

Size: Choose the size in points for the font.

Style: Choose from Normal or Italic.

Weight: Choose from Normal or Bold.

Decoration: Select check boxes for Underline and Strikeout.

GDI Charset: Enter a value to indicate the GDI character set to use. For a list of valid values, see MSDN Font.GDICharSet Property.

GDI Vertical: Select this checkbox to indicate that the font is derived from a GDI vertical font.


SubReport (Section Report)

SubReport (Section Report)
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > SubReport (Section Report)
Show All Show All
Hide All Hide All

In section reports, you can use the SubReport control to embed a report into another report. Once you place the Subreport control on a report, use code to create an instance of the report you want to load in it, and to attach the report object to the SubReport.

You can also pass parameters to the subreport from the main report so that data related to the main report displays in each instance of the subreport.

When to use a subreport

Due to the high overhead of running a second report and embedding it in the first, it is generally best to consider whether you need to use subreports. Some good reasons to use subreports include:

  • Multiple data sources
  • Multiple detail sections
  • Side-by-side charts or tables

Remove page-dependent features from reports to be used as subreports

Subreports are disconnected from any concept of a printed page because they render inside the main report. For this reason, page-dependent features are not supported for use in subreports. Keep any such logic in the main report. Page-related concepts that are not supported in subreports include:

  • Page numbers
  • Page header and footer sections (delete these sections to save processing time)
  • KeepTogether properties
  • GroupKeepTogether properties
  • NewPage properties

Coding best practices

In the Format event of the containing section, use the Report property of the SubReport control to attach a report object to the SubReport control.

Caution: It is not a recommended practice to initialize the subreport in the Format event. Doing so creates a new instance of the subreport each time the section processes. This consumes a lot of memory and processing time, especially in a report that processes a large amount of data.

Important Properties

Property | Description
CanGrow | Determines whether ActiveReports increases the height of the control based on its content.
CanShrink | Determines whether ActiveReports decreases the height of the control based on its value.
CloseBorder | By default, the bottom border of the control does not render until the end of the subreport. Set this property to True to have it render at the bottom of each page. (Only available in code.)
Report | Attaches a report object to the control. (Only available in code.)

SubReport Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

General

Name: Enter a name for the SubReport that is unique within the report. This name is displayed in the Document Outline and in XML exports.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

ReportName: This property is not used by ActiveReports, but you can use it to store the path or relative path to an RPX report file that you want to load into a generic report instance in code.

Open From Server: Click this button to open the Open report from server dialog, and then select a section report stored on ActiveReports Server to display within the SubReport control.

Format

SubReport Height

Can increase to accommodate contents: Clear this check box to set CanGrow to False.

Can decrease to accommodate contents: Clear this check box to set CanShrink to False.

See Also
SubReport Class (Section Reports)
Subreport Class (Page Reports)
Shared Subreports

How To

Embed Subreports


OleObject

OleObject
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > OleObject
Show All Show All
Hide All Hide All

The OleObject control is hidden from the toolbox by default, and is only retained for backward compatibility. You can enable the OleObject control in the Visual Studio toolbox only.

To enable the control in the Visual Studio toolbox, you must change the EnableOleObject property to true. This property can be found here: C:\Program Files\GrapeCity\ActiveReports 10\Grapecity.ActiveReports.config

Once enabled, you can add the OleObject control to reports. When you drop the control onto your report, the Insert Object dialog appears. This dialog allows you to create a new object or select one from an existing file.

Note: When you deploy reports that use the OleObject, you must also deploy the GrapeCity.ActiveReports.Interop.v10.dll, or for 64-bit machines, the GrapeCity.ActiveReports.Interop64.v10.dll.
Caution: The WPF Viewer does not support the OLE object. If you preview a report containing the OLE object in the WPF Viewer, the OLE object will not be displayed.

Important Properties

Property | Description
PictureAlignment | Gets or sets the position of the object's content within the control area.
Class | Specifies the class name of the Ole object.
SizeMode | Gets or sets a value that determines how the object is sized to fit the OleObject control area.

Insert Object Dialog

The Insert Object dialog provides the following two options:

  • Create New lets you select from a list of object types that you can insert into your report.

    Object Types

    • Adobe Acrobat Document
    • Microsoft Equation 3.0
    • Microsoft Excel 97-2003 Worksheet
    • Microsoft excel Binary Worksheet
    • Microsoft Excel Chart
    • Microsoft Excel Macro-Enabled Worksheet
    • Microsoft Excel Worksheet
    • Microsoft Graph Chart
    • Microsoft PowerPoint 97-2003 Presentation
    • Microsoft PowerPoint 97-2003 Slide
    • Microsoft PowerPoint Macro-Enabled Presentation
    • Microsoft PowerPoint Macro-Enabled Slide
    • Microsoft PowerPoint Presentation
    • Microsoft PowerPoint Slide
    • Microsoft Word 97-2003 Document
    • Microsoft Word Document
    • Microsoft Macro-Enabled Document
    • OpenDocument Presentation
    • OpenDocument Spreadsheet
    • OpenDocument Text
    • Package
    • Paintbrush Picture
    • Wordpad Document
  • Create from File allows you to insert the contents of the file as an object into your document so that you can display it while printing.


ChartControl

ChartControl
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl
Show All Show All
Hide All Hide All

In ActiveReports, you can use the ChartControl to present data graphically in a report. The chart offers you 17 core chart types along with all of their variations, plus access to properties that control every aspect of your chart's appearance.

The ChartControl presents a series of points in different ways depending upon the chart type you choose. Some chart types display multiple series of data points in a single chart. Add more information to your chart by configuring data points, axes, titles, and labels. You can modify all of these elements in the Properties Window.

When you first drop a ChartControl onto a report, the Chart Wizard appears, and you can set up your chart type, appearance, series, titles, axes, and legend on the pages of the wizard. You can specify a data source on the Series page.

Important Properties

Property | Description
BlackAndWhiteMode | Gets or sets a value indicating whether the chart is drawn in black and white using hatch patterns and line dashing to designate colors.
AutoRefresh | Gets or sets a value indicating whether the chart is automatically refreshed (redrawn) after every property change.
Backdrop | Gets or sets the chart's background style.
ChartAreas | Opens the ChartArea Collection Editor where you can set properties such as axes and wall ranges, and you can add more chart areas.
ChartBorder | Gets or sets the chart's border style.
ColorPalette | Gets or sets the chart's color palette.
DataSource | Gets or sets the data source for the chart.
GridLayout | Gets or sets the layout of the chart's areas in columns and rows.
Legends | Opens the Legend Collection Editor where you can set up the chart's legends.
Series | Opens the Series Collection Editor where you can set up the series collection for the chart.
Titles | Opens the Titles Collection Editor where you can set up titles in the header and footer of the chart.
UIOptions | Gets or sets user interface features for the chart. Choose from None, ContextCustomize, UseCustomTooltips, or ForceHitTesting.
Culture | Gets or sets the chart's culture used for value output formatting.
ImageType | Sets or returns the image generated by the chart. Choose from Metafile or PNG.

Chart Commands and Dialogs

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click any of the commands to open a dialog. Commands in this section include:

  • Clear Chart clears all of the property settings from the chart so that you can begin with a clean slate. You are given an opportunity to cancel this action.
  • Load allows you to load a saved XML file containing a chart that you created using the ChartControl.
  • Save As allows you to save the current chart to an XML file that you can load into a ChartControl on any section report.
  • Customize opens the main Chart Designer dialog where you can access Chart Areas, Titles, Series, Legends, and Appearance tabs. This dialog has access to more of the customizable areas than the wizard, but all of the properties in this dialog are also available in the Properties window.
  • Wizard reopens the Chart Wizard that appears by default when you first drop a ChartControl onto a report.
  • Data Source opens the Chart Data Source dialog where you can build a connection string and create a query.

Chart Elements

The ActiveReports ChartControl elements help you to easily analyze the visual information and interpret numerical and relational data. The following image illustrates the elements that make up the ActiveReports ChartControl.

Axis Label

A label along an axis that lets you label the units being shown.

Axis Title

The axis title allows you to provide a title for the information being shown on the axis.

Chart Backdrop

The chart backdrop is the background for the whole chart that is created. You can create your own backdrop using the different styles and colors available or you can use an image as a backdrop for your chart.

Chart Title

The chart title serves as the title for the chart control.

Footer Title

The footer title allows you to add a secondar title for the chart control along the bottom.

Grid Line

Grid lines can occur on horizontal and vertical axes and normally correlate to the major or minor tick marks for the axes.

Legend

The legend serves as a key to the specific colors or patterns being used to show series values in the chart.

Marker

The marker is used to annotate a specific plotted point in a data series.

Marker Label

The marker label allows you to display the value of a specific plotted point in a data series.

Major Tick

Major tick marks can occur on horizontal and vertical axes and normally correlate to the major gridlines for the axes.

Minor Tick

Minor tick marks can occur on horizontal and vertical axes and normally correlate to the minor gridlines for the axes.

Series

The series is a related group of data values that are plotted on the chart. Each plotted point is a data point that reflects the specific values charted. Most charts, such as the above bar chart, can contain more than one series, while others, such as a pie chart, can contain only one.

Wall Backdrop

The wall is the back section of the chart on which data is plotted.


Chart Wizard

Chart Wizard
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Wizard
Show All Show All
Hide All Hide All

The ChartControl features a Chart Wizard which takes you through the basic steps of creating a chart. The Chart Wizard automatically appears when you first add a chart control to a report. If you prefer not to have the wizard appear automatically, clear the Auto Run Wizard checkbox at the bottom of the wizard.

The Chart Wizard has the following pages:

Chart Type

In the Chart Wizard that appears, the Chart Type page displays all available 2D and 3D chart types, along with a preview of the selected chart to the right. You can select the type of chart that you want to create and change the axes by selecting the Swap Axes checkbox. If you are using a 3D chart, you can also change the projection and light settings.

Note: See ChartType for more information.

Appearance

The Appearance page has two tabs. The Palette tab allows you to select a color scheme. The Appearance tab allows you to select individual elements in the chart preview, such as its title, footer, legend, legend title, backdrop, and the chart itself and select appearance settings for them.

Series

The Series page has two tabs. The Series Settings tab allows you to set the data source for the chart and bind data fields to X and Y values for each series in the chart, and to add and remove chart series. You can even set different chart types for each series. The Data Points tab allows you to set static data values when you choose not to bind the X and Y values to data fields.

Title

The Title Page helps you to set properties for the header and footer titles. You can change the title text, font size and color, border settings, background color and visibility.

Axes

The Axes page has two tabs, one for Axis X and the other for Axis Y. On these tabs, you can enter titles for the axes and set the font size and other font properties. This page also allows you to add and format labels, add tick marks and grid lines, and select whether to show the axis inside or outside the chart area.

Legend

The Legend page allows you to set up the appearance of the legend. You can change its visibility, label appearance, header and footer text and appearance, layout, and location within the chart. You can also place the legend inside the chart by checking the Legend inside check box in the Position section.
See Also
ChartControl


Chart Types (Section Reports)

Chart Types (Section Reports)
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Types (Section Reports)

These topics introduce you to the different Chart Types you can create with the Chart control.

Area Chart
Area2D, StackedArea, StackedArea100Pct, and Area3D
Bar Chart
Bar2D and Bar3D
Line Chart
Bezier, Line, LineXY and Line3D
Pie and Doughnut Charts
Doughnut/Pie and Doughnut3D/Pie
Financial Chart
Candle, HiLo, Renko, Point and Figure, Kagi, Stock, StockOpenClose, and Three Line Break
Point and Bubble Charts
Bubble, BubbleXY, Scatter, and PlotXY
Pyramid Chart Renko Chart Bubble Chart Funnel Chart Multiple Chart Types Stacked Area Chart Stacked Bar Chart Doughnut 3D Chart Point and Figure Chart Kagi Chart Plot XY Chart 3D Area Chart Gantt Chart Candle Chart Bubble XY Chart 3D Stacked Bar Chart Bezier Chart Chart Annotations Line XY Chart HiLoOpenClose Chart Line XY Chart 2 Plot XY Chart 2 Multiple Chart Types 2 Bar Chart with Markers 100 Percent Stacked Bar Chart 3D Line Chart 3D Bar Chart with Custom BarType and 6 Vertices Clustered 3D Bar Chart HiLo Financial Chart Bar Chart with Constant Lines and Stripes


Area Chart

Area Chart
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Types (Section Reports) > Area Chart

The Area Chart displays quantitive data and is based on the Line chart. In Area charts, the space between axis and line are commonly emphasized with colors, textures and hatchings.

2D Area Charts
This section describes 2D charts that fall under the Area Chart category.
3D Area Charts
This section describes 3D charts that fall under the Area Chart category.
See Also

Charts

Chart Types (Section Reports)


2D Area Charts

2D Area Charts
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Types (Section Reports) > Area Chart > 2D Area Charts
Show All Show All
Hide All Hide All

Given below is the list of 2D charts that fall under the Area Chart category:

Area Chart

An area chart is used to compare trends over a period of time or across categories.

Chart Information
ChartType | Area2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | None

Stacked Area Chart

A stacked area chart is an area chart with two or more data series stacked one on top of the other. Use this chart to show how each value contributes to a total.

Chart Information
ChartType | Area2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | None

Stacked Area 100% Chart

A stacked area chart (100%) is an 100% area chart with two or more data series stacked one on top of the other. Use this chart to show how each value contributes to a total.

Chart Information
ChartType | Area2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | None
See Also
Area Chart


3D Area Charts

3D Area Charts
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Types (Section Reports) > Area Chart > 3D Area Charts
Show All Show All
Hide All Hide All

Given below is the list of 3D charts that fall under the Area Chart category:

Area Chart

Use a 3D area chart to compare trends in two or more data series over a period of time or in specific categories, so that data can be viewed side by side.

Note: To view a chart in 3D, in the ChartAreas property open the ChartArea Collection Editor and set the ProjectionType property to Orthogonal.
Chart Information
ChartType | Area3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The LineBackdrop property gets or sets the backdrop information for the 3D line. The Thickness property gets or sets the thickness of the 3D line. The Width property gets or sets the width of the 3D line.

Below is an example of how to set the custom chart properties at run time for a 3D area chart as shown for the first series in the image above.

Visual Basic
Copy Code
Me.ChartControl1.Series(0).Properties("LineBackdrop") = New GrapeCity.ActiveReports.Chart.Graphics.Backdrop(Color.Red, CType(150, Byte))
Me.ChartControl1.Series(0).Properties("Thickness") = 5.0F
Me.ChartControl1.Series(0).Properties("Width") = 30.0F
C#
Copy Code
this.ChartControl1.Series[0].Properties["LineBackdrop"] = new GrapeCity.ActiveReports.Chart.Graphics.Backdrop(System.Drawing.Color.Red, ((System.Byte)(150)));
this.ChartControl1.Series[0].Properties["Thickness"] = 5f;
this.ChartControl1.Series[0].Properties["Width"] = 30f;

Stacked Area Chart

3D stacked area chart displays stacked area chart in 3D.

Chart Information
ChartType | Area3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The Width property gets or sets the width of the 3D stacked area.

Stacked Area 100%

3D stacked area chart (100%) displays stacked area chart in 3D (100%).

Chart Information
ChartType | Area3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | 3
Custom Properties | The Width property gets or sets the width of the 3D stacked area.
See Also
Area Chart


Bar Chart

Bar Chart
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Types (Section Reports) > Bar Chart

The Bar Chart is a chart with rectangular bars where the lengths of bars are proportional to the values they represent. The bars can be plotted vertically or horizontally.

2D Bar Charts
This section describes 2D charts that fall under the Bar Chart category.
3D Bar Charts
This section describes 3D charts that fall under the Bar Chart category.
See Also

Charts

Chart Types (Section Reports)


2D Bar Charts

2D Bar Charts
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Types (Section Reports) > Bar Chart > 2D Bar Charts
Show All Show All
Hide All Hide All

Given below is the list of 2D charts that falls under the Bar Chart category.

Bar Chart

In a Bar Chart, values are represented by the height of the bar shaped marker as measured by the y-axis. Category labels are displayed on the x-axis. Use a bar chart to compare values of items across categories.

Chart Information
ChartType | Bar2D
Number of Y values per data point | 1
Number of series | 1 or more
Marker support | Series or Data Point
Custom Properties | The Gap property gets or sets the space between the bars of each X axis value.

Below is an example of how to set the custom chart properties at run time for a bar chart.

Visual Basic
Copy Code
Me.ChartControl1.Series(0).Properties("Gap") = 50.0F
C#
Copy Code
this.ChartControl1.Series[0].Properties["Gap"] = 50f;

Gantt Chart

The Gantt chart is a project management tool used to chart the progress of individual project tasks. The chart compares project task completion to the task schedule.

Caution: In a Gantt chart, the X and Y axes are reversed. AxisX is vertical and AxisY is horizontal.
Chart Information
ChartType | Bar2D
Number of Y values per data point | 2
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The Gap property gets or sets the space between the bars of each X axis value.

Below is an example of how to set the custom chart properties at run time for a Gantt chart.

Visual Basic
Copy Code
Me.ChartControl1.Series(0).Properties("Gap") = 50.0F
C#
Copy Code
this.ChartControl1.Series[0].Properties["Gap"] = 50f;

Horizontal Bar Chart

In a Horizontal Bar Chart, both the axes are swapped and therefore the bars appears horizontally. Although, values are represented by the height of the bar shaped marker as measured by the y-axis and the Category labels are displayed on the x-axis. Use a horizontal bar chart to compare values of items across categories.

Chart Information
ChartType | Bar2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The Gap property gets or sets the space between the bars of each X axis value.

Below is an example of how to set the custom chart properties at run time for a horizontal bar chart.

Visual Basic
Copy Code
Me.ChartControl1.Series(0).Properties（"Gap") = 65.0F
C#
Copy Code
this.ChartControl1.Series[0].Properties["Gap"] = 65f；

Stacked Bar Chart

A stacked bar chart is a bar chart with two or more data series stacked one on top of the other. Use this chart to show how each value contributes to a total.

Chart Information
ChartType | Bar2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The Gap property gets or sets the space between the bars of each X axis value.

Below is an example of how to set the custom chart properties at run time for a StackedBar chart.

Visual Basic
Copy Code
Me.ChartControl1.Series(0).Properties("Gap") = 100.0F
C#
Copy Code
this.ChartControl1.Series[0].Properties["Gap"] = 100f;

Stacked Bar Chart 100%

A StackedBar100Pct chart is a bar chart with two or more data series stacked one on top of the other to sum up to 100%. Use this chart to show how each value contributes to a total with the relative size of each series representing its contribution to the total.

Chart Information
ChartType | Bar2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The Gap property gets or sets the space between the bars of each X axis value

Below is an example of how to set the custom chart properties at run time for a StackedBar100Pct chart.

Visual Basic
Copy Code
Me.ChartControl1.Series(0).Properties("Gap") = 100.0F
C#
Copy Code
this.ChartControl1.Series[0].Properties["Gap"] = 100f;
See Also
Bar Chart


3D Bar Charts

3D Bar Charts
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Types (Section Reports) > Bar Chart > 3D Bar Charts
Show All Show All
Hide All Hide All

Given below is the list of 3D charts that fall under the Bar Chart category.

Caution: To view a chart in 3D, open the ChartArea Collection Editor in the ChartAreas property and set the ProjectionType property to Orthogonal.

Bar Chart

In a Bar Chart, values are represented by the height of the bar shaped marker as measured by the y-axis. Category labels are displayed on the x-axis. Use a 3D bar chart to compare values of items across categories, allowing the data to be viewed in a convenient 3D format.

Chart Information
ChartType | Bar3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The BarTopPercent property gets or sets the percentage of the top of the bar that is shown for Cone or Custom BarTypes. The BarType property gets or sets the type of bars that is displayed.Use BarType enumeration value. The Gap property gets or sets the space between the bars of each X axis value. The RotationAngle propertygets or sets the starting horizontal angle for custom 3D bar shapes. Can only be used with the Custom BarType. The VertexNumber property gets or sets the number of vertices for the data point, used to create custom 3D bar shapes. Can only be used with the Custom BarType. Bars must contain 3 or more vertices.

Gantt Chart

The 3D gantt chart displays a gantt chart in 3D.

Caution: In a 3D Gantt chart the X and Y axes are reversed. AxisX is vertical and AxisY is horizontal.
Chart Information
ChartType | Bar3D
Number of Y values per data point | 2
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The BarTopPercent property gets or sets the percentage of the top of the bar that is shown for Cone or Custom BarTypes. The BarType property gets or sets the type of bars that are displayed. Use BarType enumeration value. The Gap property gets or sets the space between the bars of each X axis value. The VertexNumber property gets or sets the number of vertices for the data point, used to create custom 3D bar shapes. Can only be used with the Custom BarType. Bars must contain 3 or more vertices.

Horizontal Bar Chart

In a Horizontal Bar Chart, both the axes are swapped and therefore the bars appears horizontally. Although, values are represented by the height of the bar shaped marker as measured by the y-axis and the Category labels are displayed on the x-axis. Use a horizontal 3D bar chart to compare values of items across categories, allowing the data to be viewed in a convenient 3D format.

Chart Information
ChartType | Bar3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The BarTopPercent property gets or sets the percentage of the top of the bar that is shown for Cone or Custom BarTypes. The BarType propertygets or sets the type of bars that is displayed. Use BarType enumeration value. The Gap property gets or sets the space between the bars of each X axis value. The RotationAngle property gets or sets the starting horizontal angle for custom 3D bar shapes. Can only be used with the Custom BarType. The VertexNumber property gets or sets the number of vertices for the data point, used to create custom 3D bar shapes. Can only be used with the Custom BarType. Bars must contain 3 or more vertices.

Below is an example of how to set the custom chart properties at run time for a horizontal 3D bar chart as shown above.

Visual Basic
Copy Code
Me.ChartControl1.Series(0).Properties("BarTopPercent") = 80.0F
Me.ChartControl1.Series(0).Properties("BarType") = GrapeCity.ActiveReports.Chart.BarType.Custom
Me.ChartControl1.Series(0).Properties("Gap") = 65.0F
Me.ChartControl1.Series(0).Properties("PointBarDepth") = 100.0F
Me.ChartControl1.Series(0).Properties("RotationAngle") = 0.0F
Me.ChartControl1.Series(0).Properties("VertexNumber") = 6
C#
Copy Code
this.ChartControl1.Series[0].Properties["BarTopPercent"] = 80f;
this.ChartControl1.Series[0].Properties["BarType"] = GrapeCity.ActiveReports.Chart.BarType.Custom;
this.ChartControl1.Series[0].Properties["Gap"] = 65f;
this.ChartControl1.Series[0].Properties["PointBarDepth"] = 100.0f;
this.ChartControl1.Series[0].Properties["RotationAngle"] = 0f;
this.ChartControl1.Series[0].Properties["VertexNumber"] = 6;

Stacked Bar Chart

Use a 3D bar graph to compare values of items across categories, allowing the data to be viewed conveniently in a 3D format. A stacked bar graph is a bar graph with two or more data series stacked on top of each other. Use this graph to show how each value contributes to a total.

Chart Information
ChartType | Bar3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The BarTopPercent property gets or sets the percentage of the top of the bar that is shown for Cone or Custom BarTypes. The BarType property gets or sets the type of bars that are displayed. Use BarType enumeration value. The Gap property gets or sets the space between the bars of each X axis value. The VertexNumber property gets or sets the number of vertices for the data point, used to create custom 3D bar shapes. Can only be used with the Custom BarType. Bars must contain 3 or more vertices.

Below is an example of how to set the custom chart properties at run time for a StackedBar3D chart.

Visual Basic
Copy Code
Me.ChartControl1.Series(0).Properties("BarTopPercent") = 80.0F
Me.ChartControl1.Series(0).Properties("BarType") = GrapeCity.ActiveReports.Chart.BarType.Custom
Me.ChartControl1.Series(0).Properties("Gap") = 65.0F
Me.ChartControl1.Series(0).Properties("VertexNumber") = 6
C#
Copy Code
this.ChartControl1.Series[0].Properties["BarTopPercent"] = 100f;
this.ChartControl1.Series[0].Properties["BarType"] = GrapeCity.ActiveReports.Chart.BarType.Custom;
this.ChartControl1.Series[0].Properties["Gap"] = 65f;
this.ChartControl1.Series[0].Properties["VertexNumber"] = 6

Stacked Bar Chart 100%

A Stacked Bar 3D 100% chart is a bar chart with two or more data series in 3D stacked one on top of the other to sum up to 100%. Use this chart to show how each value contributes to a total with the relative size of each series representing its contribution to the total.

Chart Information
ChartType | Bar3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties

The BarTopPercent property gets or sets the percentage of the top of the bar that is shown for Cone or Custom BarTypes.

The BarType property gets or sets the type of bars that are displayed. Use BarType enumeration value.
The Gap property gets or sets the space between the bars of each X axis value.

The VertexNumber property gets or sets the number of vertices for the data point, used to create custom 3D bar shapes. Can only be used with the Custom BarType. Bars must contain 3 or more vertices.

Below is an example of how to set the custom chart properties at run time for a StackedBar3D100Pct chart.

Visual Basic
Copy Code
Me.ChartControl1.Series(0).Properties("BarTopPercent") = 80.0F
Me.ChartControl1.Series(0).Properties("BarType") = GrapeCity.ActiveReports.Chart.BarType.Custom
Me.ChartControl1.Series(0).Properties("Gap") = 65.0F
Me.ChartControl1.Series(0).Properties("VertexNumber") = 6
C#
Copy Code
this.ChartControl1.Series[0].Properties["BarTopPercent"] = 100f;
this.ChartControl1.Series[0].Properties["BarType"] = GrapeCity.ActiveReports.Chart.BarType.Custom;
this.ChartControl1.Series[0].Properties["Gap"] = 65f;
this.ChartControl1.Series[0].Properties["VertexNumber"] = 6

Bar/Cylinder Chart

It is almost similar to a bar chart and values are represented by the height of the bar shaped marker as measured by the y-axis. Category labels are displayed on the x-axis. The only difference is that in a Bar/Cylinder Chart the data is represented through cylindrical shaped markers.

Chart Information
ChartType | Bar3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The BarTopPercent property gets or sets the percentage of the top of the bar that is shown for Cone or Custom BarTypes. The BarType property gets or sets the type of bars that is displayed. Use BarType enumeration value. The Gap property gets or sets the space between the bars of each X axis value. The RotationAngle property gets or sets the starting horizontal angle for custom 3D bar shapes. Can only be used with the Custom BarType. The VertexNumber property gets or sets the number of vertices for the data point, used to create custom 3D bar shapes. Can only be used with the Custom BarType. Bars must contain 3 or more vertices.

Bar/Pyramid Chart

In a Bar/Pyramid Chart the data is represented through pyramid shaped bars and values are represented by the height of the bars as measured by the y-axis. Category labels are displayed on the x-axis.

Chart Information
ChartType | Bar3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The BarTopPercent property gets or sets the percentage of the top of the bar that is shown for Cone or Custom BarTypes. The BarType property gets or sets the type of bars that is displayed. Use BarType enumeration value. The Gap property gets or sets the space between the bars of each X axis value. The RotationAngle property gets or sets the starting horizontal angle for custom 3D bar shapes. Can only be used with the Custom BarType. The VertexNumber property gets or sets the number of vertices for the data point, used to create custom 3D bar shapes. Can only be used with the Custom BarType. Bars must contain 3 or more vertices.

Clustered Bar chart

Use a 3D clustered bar chart to compare values of items across categories, allowing the data to be viewed in a convenient 3D format.

Chart Information
ChartType | Bar3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The BarTopPercent property gets or sets the percentage of the top of the bar that is shown for Cone or Custom BarTypes. The BarType property gets or sets the type of bars that are displayed. Use BarType enumeration value. The Gap property gets or sets the space between the bars of each X axis value. The RotationAngle property gets or sets the starting horizontal angle for custom 3D bar shapes. Can only be used with the Custom BarType. The VertexNumber property gets or sets the number of vertices for the data point, used to create custom 3D bar shapes. Can only be used with the Custom BarType. Bars must contain 3 or more vertices.

Below is an example of how to set the custom chart properties at run time for a 3D clustered bar chart as shown above.

Visual Basic
Copy Code
' set the custom properties for series 1.
Me.ChartControl1.Series(0).Properties("BarTopPercent") = 50.0F
Me.ChartControl1.Series(0).Properties("BarType") = GrapeCity.ActiveReports.Chart.BarType.Custom
Me.ChartControl1.Series(0).Properties("Gap") = 300.0F
Me.ChartControl1.Series(0).Properties("RotationAngle") = 0.0F
Me.ChartControl1.Series(0).Properties("VertexNumber") = 6

' set the custom properties for series 2.
Me.ChartControl1.Series(1).Properties("BarTopPercent") = 20.0F
Me.ChartControl1.Series(1).Properties("BarType") = GrapeCity.ActiveReports.Chart.BarType.Custom
Me.ChartControl1.Series(1).Properties("Gap") = 300.0F
Me.ChartControl1.Series(1).Properties("RotationAngle") = 90.0F
Me.ChartControl1.Series(1).Properties("VertexNumber") = 3
C#
Copy Code
// set the custom properties for series 1.
this.ChartControl1.Series[0].Properties["BarTopPercent"] = 50f;
this.ChartControl1.Series[0].Properties["BarType"] = GrapeCity.ActiveReports.Chart.BarType.Custom;
this.ChartControl1.Series[0].Properties["RotationAngle"] = 0f;
this.ChartControl1.Series[0].Properties["VertexNumber"] = 6;

// set the custom properties for series 2.
this.ChartControl1.Series[1].Properties["BarTopPercent"] = 20f;
this.ChartControl1.Series[1].Properties["BarType"] = GrapeCity.ActiveReports.Chart.BarType.Custom;
this.ChartControl1.Series[1].Properties["Gap"] = 300f;
this.ChartControl1.Series[1].Properties["RotationAngle"] = 90f;
this.ChartControl1.Series[1].Properties["VertexNumber"] = 3;
See Also
Bar Chart


Line Chart

Line Chart
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Types (Section Reports) > Line Chart

The Line Chart is a type of chart that displays information as a series of data points, connected by straight line segments.

2D Line Charts
This section describes 2D charts that fall under the Line Chart category.
3D Line Charts
This section describes 3D charts that fall under the Line Chart category.
See Also

Charts

Chart Types (Section Reports)


2D Line Charts

2D Line Charts
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Types (Section Reports) > Line Chart > 2D Line Charts
Show All Show All
Hide All Hide All

Given below is the list of 2D charts that fall under the Line Chart category.

Bezier Chart

Use a Bezier or spline chart to compare trends over a period of time or across categories. It is a line chart that plots curves through the data points in a series.

Chart Information
ChartType | Line2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The Line property gets or sets the line element. Used to set color, thickness and shape of a line. The Tension property gets or sets the tension of the curved lines.

Bezier XY Chart

A Bezier XY chart connects DataPoints on X and Y with curved lines.

Chart Information
ChartType | Line2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The Line property gets or sets the line element. Used to set color, thickness and shape of a line. The Tension property gets or sets the tension of the curved lines.

Line Chart

Use a 2D line chart to compare trends over a period of time or in certain categories in a 2D format.

Chart Information
ChartType | Line2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The Line property gets or sets the line element. Used to set color, thickness and shape of a line. The LineJoin property sets the type of join to draw when two lines connect.

Line XY Chart

A line XY chart plots points on the X and Y axes as one series and uses a line to connect points to each other.

Chart Information
ChartType | Line2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The Line property gets or sets line elements. Used for setting color, thickness and shape of a line. The LineJoin property gets or sets the type of join to draw when two lines connect.
See Also
Line Chart


3D Line Charts

3D Line Charts
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Types (Section Reports) > Line Chart > 3D Line Charts
Show All Show All
Hide All Hide All

Given below is the list of 3D charts that fall under the Line Chart category.

Bezier Chart

Render a Bezier or Spline chart in 3D format.

Chart Information
ChartType | Line3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The LineBackdrop property gets or sets the backdrop information for the 3D curved line. The Tension property gets or sets the tension of the curved lines. The Width property gets or sets the width of the 3D curved line.

Line Chart

Use a 3D line chart to compare trends over a period of time or in certain categories in a 3D format.

Caution: To view a chart in 3D, open the ChartArea Collection Editor in the ChartAreas property and set the ProjectionType property to Orthogonal.
Chart Information
ChartType | Line3D
Number of Y values per data point | 1
Number of Series | 1or more
Marker Support | Series or Data Point
Custom Properties | The LineBackdrop property gets or sets the backdrop information for the 3D line. The Thickness property gets or sets the thickness of the 3D line. The Width property gets or sets the width of the 3D line.

Below is an example of how to set the custom chart properties at run time for a horizontal 3D bar chart as shown above.

Visual Basic
Copy Code
Me.ChartControl1.Series(0).Properties("LineBackdrop") = New Backdrop(Color.GreenYellow)
Me.ChartControl1.Series(0).Properties("Thickness") = 8.0F
Me.ChartControl1.Series(0).Properties("Width") = 40.0F
C#
Copy Code
this.chartControl1.Series[0].Properties["LineBackdrop"] = new Backdrop(Color.GreenYellow);
this.chartControl1.Series[0].Properties["Thickness"] = 8f;
this.chartControl1.Series[0].Properties["Width"] = 40f;
See Also
Line Chart


Pie and Doughnut Charts

Pie and Doughnut Charts
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Types (Section Reports) > Pie and Doughnut Charts

A Pie Chart is a circular chart divided into sectors to illustrate proportion.

A Doughnut Chart is functionally identical to a Pie Charts. It also has single-series and multi-series versions, with the only difference that it has a hole in the middle.

2D Pie/Doughnut Charts
This section describes 2D charts that fall under the Pie/Doughnut Chart category.
3D Pie/Doughnut Charts
This section describes 3D charts that fall under the Pie/Doughnut Chart category.
See Also

Charts

Chart Types (Section Reports)


2D Pie/Doughnut Charts

2D Pie/Doughnut Charts
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Types (Section Reports) > Pie and Doughnut Charts > 2D Pie/Doughnut Charts
Show All Show All
Hide All Hide All

Given below is the list of 2D charts that fall under the Pie/Doughnut Chart category.

Doughnut Chart

A doughnut chart shows how the percentage of each data item contributes to the total.

In order to show each section of the pie in a different color, set the Background property for each data point.
Chart Information
ChartType | Pie/Doughnut 2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The Clockwise property gets or sets a value indicating whether to display the data in clockwise order. The ExplodeFactor property gets or sets the amount of separation between data point values. The HoleSize property gets or sets the inner radius of the chart. The OutsideLabels property gets or sets a value indicating whether the data point labels appear outside the chart. The StartAngle property gets or sets the horizontal start angle for the series.

Below is an example of how to set custom chart properties at run time for a doughnut chart.

Visual Basic
Copy Code
Me.ChartControl1.Series(0).Properties("ExplodeFactor") = 0.0F
Me.ChartControl1.Series(0).Properties("HoleSize") = 0.25F
Me.ChartControl1.Series(0).Properties("OutsideLabels") = False
Me.ChartControl1.Series(0).Properties("Radius") = 2.0F
Me.ChartControl1.Series(0).Properties("StartAngle") = 0.0F
C#
Copy Code
this.ChartControl1.Series[0].Properties["ExplodeFactor"] = 0f;
this.ChartControl1.Series[0].Properties["HoleSize"] = 0.25f;
this.ChartControl1.Series[0].Properties["OutsideLabels"] = false;
this.ChartControl1.Series[0].Properties["Radius"] = 2.0f;
this.ChartControl1.Series[0].Properties["StartAngle"] = 0f;

Funnel Chart

A funnel chart shows how the percentage of each data item contributes as a whole.

Chart Information
ChartType | Pie/Doughnut 2D
Number of Y values per data points | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties The CalloutLine property gets or sets the style for a line connecting the marker label to its corresponding funnel section. The default value is a black one-point line.
The FunnelStyle property gets or sets the Y value for the series points to the width or height of the funnel. The default value is YIsHeight.
The MinPointHeight property gets or sets the minimum height allowed for a data point in the funnel chart. The height is measured in relative coordinates.
The NeckHeight property gets or sets the neck height for the funnel chart. This property can only be used with the FunnelStyle property set to YIsHeight. The default value is 5.
The NeckWidth property gets or sets the neck width for the funnel chart. This property can only be used with the FunnelStyle property set to YIsHeight. The default value is 5.
The OutsideLabels property gets or sets a value indicating whether the labels are placed outside of the funnel chart. The default value is True.
The OutsideLabelsPlacement property gets or sets a value indicating whether the data point labels appear on the left or right side of the funnel. This property can only be used with the OutsideLabels property set to True.
The PointGapPct property gets or sets the amount of space between the data points of the funnel chart. The PointGapPct is measured in relative coordinates. The default value is 0, and valid values range from 0 to 100.

Pyramid Chart

A Pyramid chart shows how the percentage of each data item contributes as a whole.

Chart Information
ChartType | Pie/Doughnut 2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Points
Custom Properties | The CalloutLine property gets or sets the style for a line connecting the marker label to its corresponding pyramid section. The default value is a black one-point line. The MinPointHeight property gets or sets the minimum height allowed for a data point in the pyramid chart. The height is measured in relative coordinates. The OutsideLabels property gets or sets a value indicating whether the labels are placed outside of the pyramid chart. The default value is True. The OutsideLabelsPlacement property gets or sets a value indicating whether the data point labels appear on the left or right side of the pyramid. This property can only be used with the OutsideLabels property set to True. The PointGapPct property gets or sets the amount of space between the data points of the pyramid chart. The PointGapPct is measured in relative coordinates. The default value is 0, and valid values range from 0 to 100.
See Also
Pie and Doughnut Charts


3D Pie/Doughnut Charts

3D Pie/Doughnut Charts
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Types (Section Reports) > Pie and Doughnut Charts > 3D Pie/Doughnut Charts
Show All Show All
Hide All Hide All

Given below is the list of 3D charts that fall under the Pie/Doughnut Chart category.

Caution: To view a chart in 3D, open the ChartArea Collection Editor in the ChartAreas property and set the ProjectionType property to Orthogonal.

Doughnut Chart

A 3D doughnut chart shows how the percentage of each data item contributes to a total percentage, allowing the data to be viewed in a 3D format.

Chart Information
ChartType | Pie/Doughnut 3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The Clockwise property gets or sets a value indicating whether to display the data in clockwise order. The ExplodeFactor property gets or sets the amount of separation between data point values. The value must be less than or equal to 1. To explode one section of the doughnut chart, set ExplodeFactor to the data point instead of the series. The HoleSize property gets or sets the inner radius of the chart. If set to 0, the chart looks like a pie chart. The value must be less than or equal to 1. The OutsideLabels property gets or sets a value indicating whether the data point labels appear outside the chart. The Radius property gets or sets the size of the doughnut within the chart area. The StartAngle property gets or sets the horizontal start angle for the series data points.

Below is an example of how to set the custom chart properties at run time for a 3D doughnut chart as shown in the image above.

To write the code in Visual Basic.NET

Visual Basic
Copy Code
Me.ChartControl1.Series(0).Properties("ExplodeFactor") = 0.0F
Me.ChartControl1.Series(0).Properties("HoleSize") = 0.33F
Me.ChartControl1.Series(0).Properties("OutsideLabels") = False
Me.ChartControl1.Series(0).Properties("Radius") = 2.0F
Me.ChartControl1.Series(0).Properties("StartAngle") = 50.0F

To write the code in C#

C#
Copy Code
this.chartControl1.Series[0].Properties["ExplodeFactor"] = 0f;
this.chartControl1.Series[0].Properties["HoleSize"] = .33f;
this.chartControl1.Series[0].Properties["OutsideLabels"] = false;
this.chartControl1.Series[0].Properties["StartAngle"] = 50f;

Funnel Chart

A 3D funnel chart shows how the percentage of each data item contributes to the whole, allowing the data to be viewed in a 3D format.

Chart Information
ChartType | Pie/Doughnut 3D
Number of Y values per data points | 1
Number of Series | 1 or more
Marker Support | Series or Data Point

Custom Properties

The BaseStyle property gets or sets a circular or square base drawing style for the 3D funnel chart.
The CalloutLine property gets or sets the style for a line connecting the marker label to its corresponding funnel section. The default value is a black one-point line.
The FunnelStyle property gets or sets the Y value for the series points to the width or height of the funnel. The default value is YIsHeight.
The MinPointHeight property gets or sets the minimum height allowed for a data point in the funnel chart. The height is measured in relative coordinates.
The NeckHeight property gets or sets the neck height for the funnel chart. This property can only be used with the FunnelStyle property set to YIsHeight. The default value is 5.
The NeckWidth property gets or sets the neck width for the funnel chart. This property can only be used with the FunnelStyle property set to YIsHeight. The default value is 5.
The OutsideLabels property gets or sets a value indicating whether the labels are placed outside of the funnel chart. The default value is True.
The OutsideLabelsPlacement property gets or sets a value indicating whether the data point labels appear on the left or right side of the funnel. This property can only be used with the OutsideLabels property set to True.
The PointGapPct property gets or sets the amount of space between the data points of the funnel chart. The PointGapPct is measured in relative coordinates. The default value is 0, and valid values range from 0 to 100.
The RotationAngle property gets or sets the left-to-right rotation angle of the funnel. The valid values range from -180 to 180 degrees. This property is only effective with the Projection property set to Orthogonal and the BaseStyle property set to SquareBase.

Below is an example of how to set the custom chart properties at run time for a 3D funnel chart.

To write the code in Visual Basic.NET

Visual Basic
Copy Code
Imports GrapeCity.ActiveReports.Chart
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic
Copy Code
With Me.ChartControl1.Series(0)
    .Properties("BaseStyle") = BaseStyle.SquareBase
    .Properties("CalloutLine") = New Line(Color.Black, 2, LineStyle.Dot)
    .Properties("FunnelStyle") = FunnelStyle.YIsWidth
    .Properties("MinPointHeight") = 10.0F
    .Properties("NeckWidth") = 20.0F
    .Properties("NeckHeight") = 5.0F
    .Properties("OutsideLabels") = True
    .Properties("OutsideLabelsPlacement") = LabelsPlacement.Right
    .Properties("PointGapPct") = 3.0F
    .Properties("RotationAngle") = 3.0F
End With

To write the code in C#

C#
Copy Code
using GrapeCity.ActiveReports.Chart;
using GrapeCity.ActiveReports.Chart.Graphics;
C#
Copy Code
this.ChartControl1.Series[0].Properties["BaseStyle"] = BaseStyle.SquareBase;
this.ChartControl1.Series[0].Properties["CalloutLine"] = new Line(Color.Black, 2, LineStyle.Dot);
this.ChartControl1.Series[0].Properties["FunnelStyle"] = FunnelStyle.YIsWidth;
this.ChartControl1.Series[0].Properties["MinPointHeight"] = 10f;
this.ChartControl1.Series[0].Properties["NeckWidth"] = 20f;
this.ChartControl1.Series[0].Properties["NeckHeight"] = 5f;
this.ChartControl1.Series[0].Properties["OutsideLabels"] = true;
this.ChartControl1.Series[0].Properties["OutsideLabelsPlacement"] = LabelsPlacement.Right;
this.ChartControl1.Series[0].Properties["PointGapPct"] = 3f;
this.ChartControl1.Series[0].Properties["RotationAngle"] = 3f;

Pyramid Chart

A 3D Pyramid chart shows how the percentage of each data item contributes to the whole, allowing the data to be viewed in a 3D format.

Chart Information
ChartType | Pie/Doughnut 3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Points
Custom Properties

The BaseStyle property gets or sets a circular or square base drawing style for the 3D pyramid chart.
The CalloutLine property gets or sets the style for a line connecting the marker label to its corresponding pyramid section. The default value is a black one-point line.
The MinPointHeight property gets or sets the minimum height allowed for a data point in the pyramid chart. The height is measured in relative coordinates.
The OutsideLabels property gets or sets a value indicating whether the labels are placed outside of the pyramid chart. The default value is True.
The OutsideLabelsPlacement property gets or sets a value indicating whether the data point labels appear on the left or right side of the pyramid. This property can only be used with the OutsideLabels property set to True.
The PointGapPct property gets or sets the amount of space between the data points of the pyramid chart. The PointGapPct is measured in relative coordinates. The default value is 0, and valid values range from 0 to 100.
The RotationAngle property gets or sets the left-to-right rotation angle of the pyramid. The valid values range from -180 to 180 degrees. This property is only effective with the Projection property set to Orthogonal and the BaseStyle property set to SquareBase.

Below is an example of how to set the custom chart properties at run time for a Pyramid chart.

To write the code in Visual Basic.NET

Visual Basic
Copy Code
Imports GrapeCity.ActiveReports.Chart
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic
Copy Code
With Me.ChartControl1.Series(0)
    .Properties("BaseStyle") = BaseStyle.SquareBase
    .Properties("MinPointHeight") = 10.0F
    .Properties("OutsideLabels") = True
    .Properties("OutsideLabelsPlacement") = LabelsPlacement.Right
    .Properties("PointGapPct") = 3.0F
    .Properties("RotationAngle") = 3.0F
End With

To write the code in C#

C#
Copy Code
using GrapeCity.ActiveReports.Chart;
using GrapeCity.ActiveReports.Chart.Graphics;
C#
Copy Code
this.ChartControl1.Series[0].Properties["BaseStyle"] = BaseStyle.SquareBase;
this.ChartControl1.Series[0].Properties["MinPointHeight"] = 10f;
this.ChartControl1.Series[0].Properties["OutsideLabels"] = true;
this.ChartControl1.Series[0].Properties["OutsideLabelsPlacement"] = LabelsPlacement.Right;
this.ChartControl1.Series[0].Properties["PointGapPct"] = 3f;
this.ChartControl1.Series[0].Properties["RotationAngle"] = 3f;

Pie Chart

This type of chart displays the contribution of each value to a total.

Chart Information
ChartType | Pie/Doughnut 3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties |

Ring Chart

This chart type uses rings (inner and outer) to represent data.

Chart Information
ChartType | Pie/Doughnut 3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties |
See Also
Pie and Doughnut Charts


Financial Chart

Financial Chart
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Types (Section Reports) > Financial Chart

Financial charts are those which are specific to representing data related to financial activities. The ActiveReports Chart control can draw a number of financial chart types:

  • Candle, High Low, High Low Open Close
  • Kagi, Renko
  • Point and Figure, Three Line Break
2D Financial Charts
This section describes 2D charts that fall under the Financial Chart category.
3D Financial Charts
This section describes 3D charts that fall under the Financial Chart category.
See Also

Charts

Chart Types (Section Reports)


2D Financial Charts

2D Financial Charts
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Types (Section Reports) > Financial Chart > 2D Financial Charts
Show All Show All
Hide All Hide All

Given below is the list of 2D charts that fall under the Financial Chart category.

Candle Stick Chart

A candle chart displays stock information, using High, Low, Open and Close values. The size of the wick line is determined by the High and Low values, while the size of the bar is determined by the Open and Close values. The bar is displayed using different colors, depending on whether the price of the stock has gone up or down.

Chart Information
ChartType | Financial2D
Number of Y values per data point | 4 (The first value is the high figure, the second is the low figure, the third is the opening figure, and the fourth is the closing figure.)
Number of Series | 1 or more
Marker Support | Series or Data Point. Marker labels use the first Y value as the default value.
Custom Properties | The BodyDownswingBackdrop property gets or sets the backdrop information used to fill the rectangle for data points in which the closing figure is lower than the opening figure. The BodyUpswingBackdrop property gets or sets the backdrop information used to fill the rectangle for data points in which the closing figure is higher than the opening figure. The BodyWidth property gets or sets the width of the rectangle used to show upswing or downswing. The WickLine property gets or sets the line information for the wick line.

Below is an example of how to set the custom chart properties at run time for a candle chart as shown in the image above.

To write the code in Visual Basic.NET

Visual Basic
Copy Code
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic
Copy Code
With Me.ChartControl1.Series(0)
.Properties("BodyDownswingBackdrop") = New Chart.Graphics.Backdrop(Color.FromArgb(255, 192, 255))
.Properties("BodyUpswingBackdrop") = New Chart.Graphics.Backdrop(Color.FromArgb(192, 192, 255))
.Properties("WickLine") = New Chart.Graphics.Line(Color.Indigo)
.Properties("BodyWidth") = 7.0F
End With

To write the code in C#

C# code
Copy Code
Using GrapeCity.ActiveReports.Chart.Graphics
C# Code
Copy Code
this.ChartControl1.Series[0].Properties["BodyDownswingBackdrop"]= new Chart.Graphics.Backdrop
(Color.FromArgb(255, 192, 255));
this.ChartControl1.Series[0].Properties["BodyUpswingBackdrop"] = new Chart.Graphics.Backdrop
(Color.FromArgb(192, 192, 255));
this.ChartControl1.Series(0).Properties("WickLine") = new Chart.Graphics.Line(Color.Indigo);
this.ChartControl1.Series[0].Properties["BodyWidth"] = 7f;

HiLo Chart

A HiLo chart displays stock information using High and Low, or Open and Close, values. The length of the HiLo line is determined by the High and Low values, or the Open and Close values.

Chart Information
ChartType | Financial2D
Number of Y values per data point | 2
Number of Series | 1 or more
Marker Support | Series or Data Point. Marker labels use the first Y value as the default value.
Custom Properties | The HiloLine property gets or sets the line information for the HiLo line.

Below is an example of how to set the custom chart properties at run time for a HiLo chart as shown in the image above.

To write the code in Visual Basic.NET

Visual Basic
Copy Code
Me.ChartControl1.Series(0).Properties("HiloLine") = New GrapeCity.ActiveReports.Chart.Graphics.Line(Color.DeepSkyBlue, 4)

To write the code in C#

C#
Copy Code
this.ChartControl1.Series[0].Properties["HiloLine"] = new GrapeCity.ActiveReports.Chart.Graphics.Line(Color.DeepSkyBlue, 4);

Point and Figure Chart

The point and figure chart uses stacked columns of X's to indicate that demand exceeds supply and columns of O's to indicate that supply exceeds demand to define pricing trends. A new X or O is added to the chart if the price moves higher or lower than the BoxSize value. A new column is added when the price reverses to the level of the BoxSize value multiplied by the ReversalAmount. The use of these values in the point and figure chart to calculate pricing trends makes this chart best suited for long-term financial analysis.

Chart Information
ChartType | Financial2D
Number of Y values per data point | 2
Number of Series | 1 or more
Marker Support | Series or Data Points
Custom Properties | The BoxSize property gets or sets the amount a price must change in order to create another X or O. The DownswingLine property gets or sets the style and color settings for the downswing O's. The ReversalAmount property gets or sets the amount that a price must shift in order for a new column to be added. The UpswingLine property gets or sets the style and color settings for the upswing X's.

Below is an example of how to set the custom chart properties at run time for a Point and Figure chart.

To write the code in Visual Basic.NET

Visual Basic
Copy Code
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic
Copy Code
With Me.ChartControl1.Series(0)
    .Properties("DownswingLine") = New Chart.Graphics.Line(Color.Red)
    .Properties("UpswingLine") = New Chart.Graphics.Line(Color.Blue)
    .Properties("BoxSize") = 3.0F
End With

To write the code in C#

C#
Copy Code
using GrapeCity.ActiveReports.Chart.Graphics;
C#
Copy Code
this.ChartControl1.Series[0].Properties["DownswingLine"] = new Chart.Graphics.Line(Color.Red);
this.ChartControl1.Series[0].Properties["UpswingLine"] = new Chart.Graphics.Line(Color.Blue);
this.ChartControl1.Series[0].Properties["BoxSize"] = 3f;

Renko Chart

The Renko chart uses bricks of uniform size to chart price movement. When a price moves to a greater or lesser value than the preset BoxSize value required to draw a new brick, a new brick is drawn in the succeeding column. The change in box color and direction signifies a trend reversal.

Chart Information
ChartType | Financial2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Points
Custom Properties | The BodyDownswingBackdrop property gets or sets the style and color settings for the downswing bricks. The BodyUpswingBackdrop property gets or sets the style and color settings for the upswing bricks. The BoxSize property gets or sets the amount a price must change in order to create another brick.

Below is an example of how to set the custom chart properties at run time for a Renko chart.

To write the code in Visual Basic.NET

Visual Basic
Copy Code
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic
Copy Code
With Me.ChartControl1.Series(0)
    .Properties("BodyDownswingBackdrop") = New Backdrop(Color.BlueViolet)
    .Properties("BodyUpswingBackdrop") = New Backdrop(Color.Navy)
    .Properties("BoxSize") = 3.0F
End With

To write the code in C#

CS
Copy Code
using GrapeCity.ActiveReports.Chart.Graphics;
CS
Copy Code
this.ChartControl1.Series[0].Properties["BodyDownswingBackdrop"] = new Backdrop(Color.BlueViolet);
this.ChartControl1.Series[0].Properties["BodyUpswingBackdrop"] = new Backdrop(Color.Navy);
this.ChartControl1.Series[0].Properties["BoxSize"] = 3f;

Kagi Chart

A Kagi chart displays supply and demand trends using a sequence of linked vertical lines. The thickness and direction of the lines vary depending on the price movement. If closing prices go in the direction of the previous Kagi line, then that Kagi line is extended. However, if the closing price reverses by the preset reversal amount, a new Kagi line is charted in the next column in the opposite direction. Thin lines indicate that the price breaks the previous low (supply) while thick lines indicate that the price breaks the previous high (demand).

Chart Information
ChartType | Financial2D
Number of Y values per data point | 1
Number of Series | 1
Marker Support | Series or Data Points
Custom Properties | The DownswingLine property gets or sets the style and color settings to use for a Kagi line which charts a price decrease. The ReversalAmount property gets or sets the amount that a price must shift in order for the Kagi line to change direction. The UpswingLine property gets or sets the style and color settings to use for a Kagi line which charts a price increase.

Below is an example of how to set the custom chart properties at run time for a Kagi chart.

To write code in Visual Basic.NET

Visual Basic
Copy Code
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic
Copy Code
With Me.ChartControl1.Series(0)
    .Properties("BodyDownswingBackdrop") = New Backdrop(Color.Red)
    .Properties("BodyUpswingBackdrop") = New Backdrop(Color.Blue)
    .Properties("DownswingLine") = New Chart.Graphics.Line(Color.DarkRed)
    .Properties("ReversalAmount") = "25"
    .Properties("UpswingLine") = New Chart.Graphics.Line(Color.DarkBlue)
    .Properties("Width") = 50.0F
End With

To write code in C#

C#
Copy Code
using GrapeCity.ActiveReports.Chart.Graphics;
C#
Copy Code
this.ChartControl1.Series[0].Properties["BodyDownswingBackdrop"] = new Backdrop(Color.Red);
this.ChartControl1.Series[0].Properties["BodyUpswingBackdrop"] = new Backdrop(Color.Blue);
this.ChartControl1.Series[0].Properties["DownswingLine"] = new Chart.Graphics.Line(Color.DarkRed);
this.ChartControl1.Series[0].Properties["ReversalAmount"] = "25";
this.ChartControl1.Series[0].Properties["UpswingLine"] = new Chart.Graphics.Line(Color.DarkBlue);
this.ChartControl1.Series[0].Properties["Width"] = 50f;

Stock Chart

In a stock chart, series are displayed as a set of lines with markers for high, low, close, and open values. Values are represented by the height of the marker as measured by the y-axis. Category labels are displayed on the x-axis.

Stock chart is a visual representation of data related to the stock market. It may be used to represent data like stock prices and stock activities.

Chart Information
ChartType | Financial2D
Number of Y values per data point | 4
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The CloseLine property gets or sets the information for the close value line. The HiLoLine property gets or sets the line information for the HiLo line. The OpenLine property property gets or sets the information for the open value line. The TickLen property property gets or sets the tick length for the close value and open value lines.

Stock Close Only Chart

A Stock chart is a visual representation of data related to the stock market. This type of chart requires four series of values in the correct order (open, high, low, and then close).

Chart Information
ChartType | Financial2D
Number of Y values per data point | 4
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | The CloseLine property gets or sets the information for the close value line. The HiLoLine property gets or sets the line information for the HiLo line. The OpenLine property property gets or sets the information for the open value line. The TickLen property property gets or sets the tick length for the close value and open value lines.

Stock Open Only Chart

A Stock chart is a visual representation of data related to the stock market. This type of chart requires four series of values in the correct order (open, high, low, and then close), low, and then close).

Chart Information
ChartType | Financial2D
Number of Y values per data point | 4
Number of Series | 3
Marker Support | Series or Data Point
Custom Properties | The CloseLine property gets or sets the information for the close value line. The HiLoLine property gets or sets the line information for the HiLo line. The OpenLine property property gets or sets the information for the open value line. The TickLen property property gets or sets the tick length for the close value and open value lines.

Three Line Break Chart

A Three Line Break chart uses vertical boxes or lines to illustrate price changes of an asset or market. Movements are depicted with box colors and styles; movements that continue the trend of the previous box paint similarly while movements that trend oppositely are indicated with a different color and/or style. The opposite trend is only drawn if its value exceeds the extreme value of the previous three boxes or lines. The below Three Line Break depicts upward pricing movement with black boxes and downward pricing movement with red boxes.

Chart Information
ChartType | Financial2D
Number of Y values per data point | 1
Number of Series | 1
Marker Support | Series or Data Points
Chart-Specific Properties | The BodyDownswingBackdrop property gets or sets the style and color settings for the downswing boxes. The BodyUpswingBackdrop property gets or sets the style and color settings for the upswing boxes. The NewLineBreak property gets or sets the number of previous boxes/lines that must be compared before a new box/line is drawn. The default value is 3.

Below is an example of how to set the custom chart properties at run time for a Three Line Break chart.

To write code in Visual Basic.NET

Visual Basic
Copy Code
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic
Copy Code
With Me.ChartControl1.Series(0)
    .Properties("BodyDownswingBackdrop") = New Backdrop(Color.Red)
    .Properties("BodyUpswingBackdrop") = New Backdrop(Color.Black)
    .Properties("NewLineBreak") = 3
End With

To write code in C#

C#
Copy Code
using GrapeCity.ActiveReports.Chart.Graphics;
C#
Copy Code
this.ChartControl1.Series[0].Properties["BodyDownswingBackdrop"] = new Backdrop(Color.Red);
this.ChartControl1.Series[0].Properties["BodyUpswingBackdrop"] = new Backdrop(Color.Black);
this.ChartControl1.Series[0].Properties["NewLineBreak"] = 3;
See Also
Financial Chart


3D Financial Charts

3D Financial Charts
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Types (Section Reports) > Financial Chart > 3D Financial Charts
Show All Show All
Hide All Hide All

Given below is the list of 3D charts that fall under the Financial Chart category.

Kagi Chart

A Kagi chart displays supply and demand trends using a sequence of linked vertical lines. The thickness and direction of the lines vary depending on the price movement. If closing prices go in the direction of the previous Kagi line, then that Kagi line is extended. However, if the closing price reverses by the preset reversal amount, a new Kagi line is charted in the next column in the opposite direction. Thin lines indicate that the price breaks the previous low (supply) while thick lines indicate that the price breaks the previous high (demand).

Chart Information

ChartType

 Financial3D

Number of Y values per data point

 1

Number of Series

 1

Marker Support

 Series or Data Points

Custom Properties

 The BodyDownswingBackdrop property gets or sets the style and color settings for the three-dimensional side view of downswing Kagi lines. This property is only available with the Kagi 3D chart type, and is only effective when the Width property is set to a value higher than 25.
The BodyUpswingBackdrop property gets or sets the style and color settings for the three-dimensional side view of upswing Kagi lines. This property is only available with the Kagi 3D chart type, and is only effective when the Width property is set to a value higher than 25.
The DownswingLine property gets or sets the style and color settings to use for a Kagi line which charts a price decrease.
The ReversalAmount property gets or sets the amount that a price must shift in order for the Kagi line to change direction.
The UpswingLine property gets or sets the style and color settings to use for a Kagi line which charts a price increase.
The Width property gets or sets the width of the three-dimensional side view of the Kagi lines.This property is only available with the Kagi 3D chart type, and must be set higher than its default value of 1 in order to display body downswing and upswing backdrops.

Below is an example of how to set the custom chart properties at run time for a Kagi chart.

To write code in Visual Basic.NET

Visual Basic
Copy Code
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic
Copy Code
With Me.ChartControl1.Series(0)
    .Properties("BodyDownswingBackdrop") = New Backdrop(Color.Red)
    .Properties("BodyUpswingBackdrop") = New Backdrop(Color.Blue)
    .Properties("DownswingLine") = New Chart.Graphics.Line(Color.DarkRed)
    .Properties("ReversalAmount") = "25"
    .Properties("UpswingLine") = New Chart.Graphics.Line(Color.DarkBlue)
    .Properties("Width") = 50.0F
End With

To write code in C#

C#
Copy Code
using GrapeCity.ActiveReports.Chart.Graphics;
C#
Copy Code
this.ChartControl1.Series[0].Properties["BodyDownswingBackdrop"] = new Backdrop(Color.Red);
this.ChartControl1.Series[0].Properties["BodyUpswingBackdrop"] = new Backdrop(Color.Blue);
this.ChartControl1.Series[0].Properties["DownswingLine"] = new Chart.Graphics.Line(Color.DarkRed);
this.ChartControl1.Series[0].Properties["ReversalAmount"] = "25";
this.ChartControl1.Series[0].Properties["UpswingLine"] = new Chart.Graphics.Line(Color.DarkBlue);
this.ChartControl1.Series[0].Properties["Width"] = 50f;

Renko Chart

The Renko chart uses bricks of uniform size to chart price movement. When a price moves to a greater or lesser value than the preset BoxSize value required to draw a new brick, a new brick is drawn in the succeeding column. The change in box color and direction signifies a trend reversal.

Chart Information
ChartType | Financial3D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Points
Custom Properties | The BodyUpswingBackdrop property gets or sets the style and color settings for the upswing bricks. BodyDownswingBackdrop Gets or sets the style and color settings for the downswing bricks. The BoxSize property gets or sets the amount a price must change in order to create another brick.

Below is an example of how to set the custom chart properties at run time for a Renko chart.

To write code in Visual Basic.NET

Visual Basic
Copy Code
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic
Copy Code
With Me.ChartControl1.Series(0)
    .Properties("BodyDownswingBackdrop") = New Backdrop(Color.Red)
    .Properties("BodyUpswingBackdrop") = New Backdrop(Color.Blue)
    .Properties("BoxSize") = 3.0F
End With

To write code in C#

CS
Copy Code
using GrapeCity.ActiveReports.Chart.Graphics;
C#
Copy Code
this.ChartControl1.Series[0].Properties["BodyDownswingBackdrop"] = new Backdrop(Color.Red);
this.ChartControl1.Series[0].Properties["BodyUpswingBackdrop"] = new Backdrop(Color.Blue);
this.ChartControl1.Series[0].Properties["BoxSize"] = 3f;

Three Line Break Chart

Three line break 3D chart is a chart rendered in 3D.

Chart Information
ChartType | Financial3D
Number of Y values per data point | 1
Number of Series | 1
Marker Support | Series or Data Points
Custom Properties | The BodyDownswingBackdrop property gets or sets the style and color settings for the downswing boxes. The BodyUpswingBackdrop property gets or sets the style and color settings for the upswing boxes. The NewLineBreak property gets or sets the number of previous boxes/lines that must be compared before a new box/line is drawn. The default value is 3.
See Also
Financial Chart


Point and Bubble Charts

Point and Bubble Charts
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Types (Section Reports) > Point and Bubble Charts

Point or Bubble charts represent data by means of points and bubbles.

The ActiveReports Chart control can draw a number of point/bubble chart types:

  • Bubble, BubbleXY, PlotXY and Scatter.
2D Point/Bubble Charts
This section describes 2D charts that fall under the Point/Bubble Chart category.
See Also

Charts

Chart Types (Section Reports)


2D Point/Bubble Charts

2D Point/Bubble Charts
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Types (Section Reports) > Point and Bubble Charts > 2D Point/Bubble Charts
Show All Show All
Hide All Hide All

Given below is the list of 2D charts that fall under the Point/Bubble Chart category.

Bubble Chart

The Bubble chart is an XY chart in which bubbles represent data points. The first Y value is used to plot the bubble along the Y axis, and the second Y value is used to set the size of the bubble. The bubble shape can be changed using the series Shape property.

Chart Information
ChartType | Point/Bubble2D
Number of Y values per data point | 2
Number of Series | 1 or more
Marker Support | Series or Data Point. Marker labels use the second Y value as the default value.
Custom Properties | The MaxSizeFactor property gets or sets the maximum size of the bubble radius. Values must be less than or equal to 1. Default is .25. The MaxValue property gets or sets the bubble size that is used as the maximum. The MinValue property gets or sets the bubble size that is used as the minimum. The Shape property gets or sets the shape of the bubbles. Uses or returns a valid MarkerStyle enumeration value.

Below is an example of setting the custom chart properties at run time for a bubble chart as shown in the image above.

To write code in Visual Basic.NET

Visual Basic
Copy Code
Me.ChartControl1.Series(0).Properties("MaxSizeFactor") = 0.25F
Me.ChartControl1.Series(0).Properties("MaxValue") = 55.0R
Me.ChartControl1.Series(0).Properties("MinValue") = 5.0R
Me.ChartControl1.Series(0).Properties("Shape") = GrapeCity.ActiveReports.Chart.MarkerStyle.Circle

To write code in C#

C#
Copy Code
this.ChartControl1.Series[0].Properties["MaxSizeFactor"] = .25f;
this.ChartControl1.Series[0].Properties["MaxValue"] = 55D;
this.ChartControl1.Series[0].Properties["MinValue"] = 5D;
this.ChartControl1.Series[0].Properties["Shape"] = GrapeCity.ActiveReports.Chart.MarkerStyle.Circle;

Bubble XY Chart

The Bubble XY chart is an XY chart in which bubbles represent data points. The BubbleXY uses a numerical X axis and plots the x values and first set of Y values on the chart. The second Y value is used to set the size of the bubble.

Chart Information
ChartType | Point/Bubble2D
Number of Y values per data point | 2
Number of Series | 1 or more
Marker Support | Series or Data Point. Marker labels use the second Y value as the default value.
Custom Properties | The MaxSizeFactor gets or sets the maximum size of the bubble radius. Values must be less than or equal to 1. Default is .25. The MaxValue property gets or sets the bubble size that is used as the maximum. The MinValue property gets or sets the bubble size that is used as the minimum. The Shape property gets or sets the shape of the bubbles. Uses or returns a valid MarkerStyle enumeration value.

Below is an example of setting the custom chart properties at run time for a bubble XY chart as shown in the image above.

To write code in Visual Basic.NET

Visual Basic
Copy Code
Me.ChartControl1.Series(0).Properties("MaxSizeFactor") = 0.25F
Me.ChartControl1.Series(0).Properties("MaxValue") = 50.0R
Me.ChartControl1.Series(0).Properties("MinValue") = 0.0R
Me.ChartControl1.Series(0).Properties("Shape") = GrapeCity.ActiveReports.Chart.MarkerStyle.InvTriangle

To write code in C#

C#
Copy Code
this.ChartControl1.Series[0].Properties["MaxSizeFactor"] = .25f;
this.ChartControl1.Series[0].Properties["MinValue"] = 0D;
this.ChartControl1.Series[0].Properties["MaxValue"] = 50D;
this.ChartControl1.Series[0].Properties["Shape"] = GrapeCity.ActiveReports.Chart.MarkerStyle.InvTriangle;

Plot XY Chart

A plot XY chart shows the relationships between numeric values in two or more series sets of XY values.

Chart Information
ChartType | Point/Bubble2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | None

Scatter Chart

Use a scatter chart to compare values across categories.

Chart Information
ChartType | Point/Bubble2D
Number of Y values per data point | 1
Number of Series | 1 or more
Marker Support | Series or Data Point
Custom Properties | None
See Also
Point and Bubble Charts


Chart Series

Chart Series
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Series
Show All Show All
Hide All Hide All

A chart series is the key to showing data in a chart. All data is plotted in a chart as a series and all charts contain at least one series. The bars in the image below depict two series in a simple bar chart.

Each series is made up of a set of data points consisting of an X value that determines where on the X axis the data is plotted, and one or more Y values. Most charts use one Y value but a few charts such as the Bubble, BubbleXY, and the financial charts take multiple Y values.

When you bind data to a series, the X value is bound using the ValueMembersX property on the Series object, and the Y value is bound using the ValueMembersY property.

The Series object also contains properties for each individual series, including chart type, custom chart properties, annotations, containing chart area, and more. Each chart type in the ActiveReports Chart control contains series-specific properties that apply to it. You can set the chart type and these series-specific properties in the Series Collection Editor dialog, which opens when you click the ellipsis button next to the Series (Collection) property in the Visual Studio Properties window.

You can manipulate each data point in the DataPoint Collection dialog box. You can access the dialog from the Series Collection Editor by clicking the ellipsis button next to the Points (Collection) property.

When you set a property on the Series object, it is applied to all data point objects in the series unless a different value for the property is set on a specific data point. In that case, the data point property setting overrides the series property setting for that particular data point. Note that for charts bound to a data source, you do not have access to the DataPoint collection in the dialog.

If you specify the value for any of the custom properties, this value is not cleared when you change the ChartType. Although this will show properties that do not apply to certain ChartTypes, it has the advantage of keeping your settings in case you accidentally change the ChartType.

Setting chart and series-specific properties at run time

To set custom properties for a chart on the series programmatically, reference the series by name or index and use the string Properties attribute name you wish to set.

The following code samples set the shape for bubbles on a bubble chart to diamond.

To write code in Visual Basic.Net

Visual Basic.NET code. Paste INSIDE the section Format event.
Copy Code
Me.ChartControl1.Series(0).Properties("Shape") = Chart.MarkerStyle.Diamond

To write the code in C#

C# code. Paste INSIDE the section Format event.
Copy Code
this.chartControl1.Series[0].Properties["Shape"] = GrapeCity.ActiveReports.Chart.MarkerStyle.Diamond;

To set custom properties for a chart on the data points object programmatically, reference the series by name or index, reference the data point by index, and use the string Properties attribute name you wish to set.

The following code samples set the explode factor on a doughnut chart for the second point in the series.

To write code in Visual Basic.Net

Visual Basic.NET code. Paste INSIDE the section Format event.
Copy Code
Me.ChartControl1.Series(0).Points(1).Properties("ExplodeFactor") = 0.5F

To write the code in C#

C# code. Paste INSIDE the section Format event.
Copy Code
this.chartControl1.Series[0].Points[1].Properties["ExplodeFactor"] = .5f;
See Also

Concepts

ChartControl


Chart Appearance

Chart Appearance
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Appearance

The following section explains in what ways you can modify the chart appearance.

Chart Effects
This section describes the visual effects that are available for the ChartControl.
Chart Control Items
This section describes the chart elements that you can use to customize the ChartControl.
Chart Axes and Walls
This section provides basic information about the ChartControl axes and walls.


Chart Effects

Chart Effects
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Appearance > Chart Effects

These topics introduce some basic information on the visual effects of the ChartControl.

Colors
Learn about the different ways you can change the color and gradients to enhance the visual appearance of a chart.
3D Effect
This section describes 3D effects that you can use to customize the chart.
Alpha Blending
This section explains about alpha blending property of the chart.
Lightning
Learn about directional light ratio, line type and line source of the chart.


Colors

Colors
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Appearance > Chart Effects > Colors
Show All Show All
Hide All Hide All

In the ChartControl, colors can be used in different ways to enhance the chart's appearance, distinguish different series, point out or draw attention to data information such as averages, and more.

Color Palettes

The ChartControl includes several pre-defined color palettes that can be used to automatically set the colors for data values in a series. The pre-defined palettes are as follows.

  • Default The default palette.
  • Cascade A cascade of eight cool colors ranging from deep teal down through pale orchid.
  • Springtime The colors of spring, in deep green, two vivid colors and five pastels.
  • Iceberg A range of the soft blues and greys found in an iceberg.
  • Confetti A sprinkling of bright and pastel colors.
  • Greens A palette of greens.
  • Berries The colors of berries.
  • Autumn A quiet palette of autumn colors.
  • Murphy A range of the soft blues and greens.

These enumerated values are accessed through the Series class with code like the following.

To write code in Visual Basic.NET

Visual Basic
Copy Code
Me.ChartControl1.Series(0).ColorPalette = Chart.ColorPalette.Iceberg

To write code in C#

C#
Copy Code
this.ChartControl1.Series[0].ColorPalette = GrapeCity.ActiveReports.Chart.ColorPalette.Iceberg;

Gradients

Gradients can be used in object backdrops to enhance the visual appearance of various chart items. Gradients can be used in the following chart sections:

  • Chart
  • Chart area
  • Wall
  • Title
  • Legend
  • Legend item (for custom legend items)
  • WallRange
  • Series
  • Data point
  • Marker
  • Marker Label
  • Annotation TextBar

You can set gradients for a backdrop at run time by creating a BackdropItem, setting its Style property to Gradient, setting the GradientType, and setting the two colors to use for the gradient as shown in the following example.

To write code in Visual Basic.NET

Visual Basic
Copy Code
Imports GrapeCity.ActiveReports.Chart.Graphics
Visual Basic
Copy Code
Dim bItem As New GrapeCity.ActiveReports.Chart.BackdropItem
bItem.Style = Chart.Graphics.BackdropStyle.Gradient
bItem.Gradient = Chart.Graphics.GradientType.Vertical
bItem.Color = Color.Purple
bItem.Color2 = Color.White
Me.ChartControl1.Backdrop = bItem

To write code in C#

C#
Copy Code
using GrapeCity.ActiveReports.Chart.Graphics;
C#
Copy Code
GrapeCity.ActiveReports.Chart.BackdropItem bItem = new GrapeCity.ActiveReports.Chart.BackdropItem();
bItem.Style = GrapeCity.ActiveReports.Chart.Graphics.BackdropStyle.Gradient;
bItem.Gradient = GrapeCity.ActiveReports.Chart.Graphics.GradientType.Vertical;
bItem.Color = System.Drawing.Color.Purple;
bItem.Color2 = System.Drawing.Color.White;
this.ChartControl1.Backdrop = bItem;
See Also
Chart Effects


3D Effects

3D Effects
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Appearance > Chart Effects > 3D Effects

Using the projection and viewpoint settings, you can display your 3D chart at any angle to provide the desired view or call attention to a specific chart section.

Projection

Determine the projection for a 3D chart using the following properties.

Property Name | Description
ZDepthRatio | The Z depth ratio is the level of depth the Z axis has in the chart. The ratio of the length specified in the X-axis of Z-axis Values range from 0 (for a 2D chart) to 1.0. This property is useful in adjusting the size of 3D chart.
ProjectionDX | The origin position of the Z axis in relation to the X axis. This property is valid only when the ProjectionType is Orthogonal.
ProjectionDY | The origin position of the Z axis in relation to the Y axis. This property is valid only when the ProjectionType is Orthogonal.
ProjectionType | The type of projection used for the chart. In order to show charts three dimensionally, the ProjectionType in the ChartArea Collection editor must be set to Orthogonal. To access this dialog box, click the ellipsis button next to the ChartAreas (Collection) property in the Properties Window.
HorizontalRotation | The HorizontalRotation property allows you to set the degree (-90° to 90°) of horizontal rotation from which the chart is seen.
VerticalRotation | The VerticalRotation property allows you to set the degree (-90° to 90°) of vertical rotation from which the chart is seen.
See Also
Chart Effects


Alpha Blending

Alpha Blending
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Appearance > Chart Effects > Alpha Blending
Show All Show All
Hide All Hide All

The Backdrop class in the Chart control has an Alpha property which employs GDI+, and is used to set the transparency level of each object's backdrop. GDI+ uses 32 bits overall and 8 bits per alpha, red, green, and blue channels respectively to indicate the transparency and color of an object. Like a color channel's levels of color, the alpha channel represents 256 levels of transparency.

The default value of the Alpha property is 255, which represents a fully opaque color. For a fully transparent color, set this value to 0. To blend the color of the object's backdrop with the background color, use a setting between 0 and 255.

In the Chart control, you can use the Color.FromArgb method provided by standard Color constructor of .NET Framework class library to set the alpha and color levels for a particular chart element.

The following example shows how you can use the method to set the alpha and color values for the chart backdrop.

To write code in Visual Basic.NET

Visual Basic
Copy Code
Me.ChartControl1.Backdrop = New GrapeCity.ActiveReports.Chart.BackdropItem(Color.FromArgb(100, 0, 11, 220))

To write code in C#

C#
Copy Code
this.ChartControl1.Backdrop = new GrapeCity.ActiveReports.Chart.BackdropItem(System.Drawing.Color.FromArgb(100, 0, 11, 220));

Changing the alpha level of a chart element reveals other items that are beneath the object. Because you can set the alpha level for any chart element that supports color, you can also create custom effects for any chart. For example, you can use alpha blending to combine background images with a semi-transparent chart backdrop to create a watermark look.

See Also
Chart Effects


Lighting

Lighting
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Appearance > Chart Effects > Lighting
Show All Show All
Hide All Hide All

The Chart control allows you to completely customize lighting options for 3D charts.

Directional Light Ratio

Using the DirectionalLightRatio property, you can control the directional or ambient intensity ratio.

Light Type

By setting the Type property to one of the enumerated LightType values, you can control the type of lighting used in the chart. The settings are as follows:

  • Ambient：An ambient light source is used. It is equal to DirectionalLightRatio = 0.
  • Directional：An infinite directional light source (like the sun, the light source having the same angle of incidence from each side) is used.
  • Point：A point light source (light is generated from one point and light source having different angle of incidence according to the sides) is used.

Light Source

You can also set the Source property to a Point3d object, which controls the location of the light source.

See Also
Chart Appearance


Chart Control Items

Chart Control Items
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Appearance > Chart Control Items

The following topics review the chart control items that you can use to customize your chart.

Chart Annotation
This topic explains how you can add annotations to your chart.
Chart Titles and Footers
This topic explains how you can add a title or a footer to your chart.
Legends
This topic explains how you can add legends to your chart.
Markers
This topic explains how to create markers for showing specific data series values.
Label Symbols
This topic describes how to set format strings to display data in a legend, a marker or a symbol to be used as placeholders.
Constant Lines and Stripes
This topic explains how to add constant lines and stripes to your chart.


Chart Annotations

Chart Annotations
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Appearance > Chart Control Items > Chart Annotations
Show All Show All
Hide All Hide All

The Chart control offers a built-in annotation tool to allow you to include floating text bars or images in your charts or call attention to specific items or values in your charts using the line and text bar controls included in the Annotations Collection Editor. You can find the Annotations Collection Editor under the Series properties of the Chart Designer.

The following properties are important while setting up annotations for your chart:

  • StartPoint Sets the starting point (X and Y axis values) for an annotation line.
  • EndPoint Sets the end point (X and Y axis values) for an annotation line.
  • AnchorPlacement Sets the position of the anchor point for the text bar on the chart surface.
  • AnchorPoint Sets the point (X and Y axis values) where the text bar will be anchored based on the anchor placement selected.

The following code demonstrates creating annotation lines and annotation text, setting their properties, and adding them to the series annotations collection at run time.

To write code in Visual Basic.NET

Visual Basic
Copy Code
' create the annotation lines and text bar.
Dim aLine1 As New GrapeCity.ActiveReports.Chart.Annotations.AnnotationLine
Dim aLine2 As New GrapeCity.ActiveReports.Chart.Annotations.AnnotationLine
Dim aText1 As New GrapeCity.ActiveReports.Chart.Annotations.AnnotationTextBar
Dim aText2 As New GrapeCity.ActiveReports.Chart.Annotations.AnnotationTextBar

' set the properties for each line and text bar.
With aLine1
        .EndPoint = New GrapeCity.ActiveReports.Chart.Graphics.Point2d(1.5F, 30.0F)
        .Line = New GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.Red, 2)
        .StartPoint = New GrapeCity.ActiveReports.Chart.Graphics.Point2d(1.5F, 15.0F)
End With
With aLine2
        .EndPoint = New GrapeCity.ActiveReports.Chart.Graphics.Point2d(4.6F, 47.0F)
        .Line = New GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.Red, 2)
        .StartPoint = New GrapeCity.ActiveReports.Chart.Graphics.Point2d(3.6F, 45.0F)
End With
With aText1
        .AnchorPlacement = GrapeCity.ActiveReports.Chart.Annotations.AnchorPlacementType.Bottom
        .AnchorPoint = New GrapeCity.ActiveReports.Chart.Graphics.Point2d(1.5F, 31.0F)
        .Height = 25.0F
        .Line = New GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.Red, 2)
        .Text = "Min Value"
        .Width = 100.0F
End With
With aText2
        .AnchorPlacement = GrapeCity.ActiveReports.Chart.Annotations.AnchorPlacementType.Left
        .AnchorPoint = New GrapeCity.ActiveReports.Chart.Graphics.Point2d(4.7F, 47.0F)
        .Height = 25.0F
        .Line = New GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.Red, 2)
        .Text = "Max Value"
        .Width = 100.0F
End With

' add the annotation lines and text bars to the annotations collection for the series
Me.ChartControl1.Series(0).Annotations.AddRange(New GrapeCity.ActiveReports.Chart.Annotations.Annotation() {aLine1, aLine2, aText1, aText2})

To write code in C#

C#
Copy Code
// create the annotation lines and text bar.
GrapeCity.ActiveReports.Chart.Annotations.AnnotationLine aLine1 = new GrapeCity.ActiveReports.Chart.Annotations.AnnotationLine();
GrapeCity.ActiveReports.Chart.Annotations.AnnotationLine aLine2 = new GrapeCity.ActiveReports.Chart.Annotations.AnnotationLine();
GrapeCity.ActiveReports.Chart.Annotations.AnnotationTextBar aText1 = new GrapeCity.ActiveReports.Chart.Annotations.AnnotationTextBar();
GrapeCity.ActiveReports.Chart.Annotations.AnnotationTextBar aText2 = new GrapeCity.ActiveReports.Chart.Annotations.AnnotationTextBar();

// set the properties for each line and text bar.
aLine1.EndPoint = new GrapeCity.ActiveReports.Chart.Graphics.Point2d(1.5F, 30F);
aLine1.Line = new GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.Red, 2);
aLine1.StartPoint = new GrapeCity.ActiveReports.Chart.Graphics.Point2d(1.5F, 15F);
aLine2.EndPoint = new GrapeCity.ActiveReports.Chart.Graphics.Point2d(4.6F, 47F);
aLine2.Line = new GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.Red, 2);
aLine2.StartPoint = new GrapeCity.ActiveReports.Chart.Graphics.Point2d(3.6F, 45F);
aText1.AnchorPlacement = GrapeCity.ActiveReports.Chart.Annotations.AnchorPlacementType.Bottom;
aText1.AnchorPoint = new GrapeCity.ActiveReports.Chart.Graphics.Point2d(1.5F, 31F);
aText1.Height = 25F;
aText1.Line = new GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.Red, 2);
aText1.Text = "Min Value";
aText1.Width = 100F;
aText2.AnchorPlacement = GrapeCity.ActiveReports.Chart.Annotations.AnchorPlacementType.Left;
aText2.AnchorPoint = new GrapeCity.ActiveReports.Chart.Graphics.Point2d(4.7F, 47F);
aText2.Height = 25F;
aText2.Line = new GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.Red, 2);
aText2.Text = "Max Value";
aText2.Width = 100F;

// add the annotation lines and text bars to the annotations collection for the series
this.ChartControl1.Series[0].Annotations.AddRange(
new GrapeCity.ActiveReports.Chart.Annotations.Annotation[] {aLine1, aLine2, aText1, aText2});
See Also
Chart Control Items


Chart Titles and Footers

Chart Titles and Footers
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Appearance > Chart Control Items > Chart Titles and Footers
Show All Show All
Hide All Hide All

The Chart control allows you to add custom titles to your charts. The Titles collection is accessible from the Chart object. With the ability to add as many titles as needed, dock them to any side of a chart area, change all of the font properties, add borders and shadows, make the background look the way you want it, and change the location of the text, you can easily make your titles look the way you want them to look.

The following code demonstrates creating header and footer titles, setting their properties, and adding them to the titles collection at run time.

  1. In design view of the report, double-click the section where you placed your chart. This creates a Format event handling method for the section.
  2. Add code to the handler to create header and footer titles.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the section Format event.
Copy Code
' create the header and footer titles
Dim tHeader As New GrapeCity.ActiveReports.Chart.Title
Dim tFooter As New GrapeCity.ActiveReports.Chart.Title

' set the properties for the header
tHeader.Alignment = Chart.Alignment.Center
tHeader.Backdrop = New GrapeCity.ActiveReports.Chart.Graphics.Backdrop(System.Drawing.Color.Thistle)
tHeader.Border = New GrapeCity.ActiveReports.Chart.Border(New GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.DimGray), 3)
tHeader.DockArea = Me.ChartControl1.ChartAreas(0)
tHeader.Docking = Chart.DockType.Top
tHeader.Font = New GrapeCity.ActiveReports.Chart.FontInfo(System.Drawing.Color.White, New System.Drawing.Font("Arial", 25.0F))
tHeader.Text = "Chart Title"
tHeader.Visible = True

' set the properties for the footer
tFooter.Alignment = Chart.Alignment.Center
tFooter.Backdrop = New GrapeCity.ActiveReports.Chart.Graphics.Backdrop(System.Drawing.Color.Thistle)
tFooter.Border = New GrapeCity.ActiveReports.Chart.Border(New GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.Indigo), 0, System.Drawing.Color.Black)
tFooter.DockArea = Me.ChartControl1.ChartAreas(0)
tFooter.Docking = Chart.DockType.Bottom
tFooter.Font = New GrapeCity.ActiveReports.Chart.FontInfo(System.Drawing.Color.DimGray, New System.Drawing.Font("Arial", 12.0F, System.Drawing.FontStyle.Bold))
tFooter.Text = "Chart Footer"
tFooter.Visible = True

' add the header and footer titles to the titles collection
Me.ChartControl1.Titles.AddRange(New GrapeCity.ActiveReports.Chart.Title() {tHeader, tFooter})

To write the code in C#

C# code. Paste INSIDE the section Format event.
Copy Code
// create the header and footer titles
GrapeCity.ActiveReports.Chart.Title tHeader = new GrapeCity.ActiveReports.Chart.Title();
GrapeCity.ActiveReports.Chart.Title tFooter = new GrapeCity.ActiveReports.Chart.Title();

// set the properties for the header
tHeader.Alignment = Chart.Alignment.Center;
tHeader.Backdrop = new GrapeCity.ActiveReports.Chart.Graphics.Backdrop(System.Drawing.Color.Thistle);
tHeader.Border = new GrapeCity.ActiveReports.Chart.Border(new GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.DimGray), 3);
tHeader.DockArea = this.ChartControl1.ChartAreas[0];
tHeader.Docking = Chart.DockType.Top;
tHeader.Font = new GrapeCity.ActiveReports.Chart.FontInfo(System.Drawing.Color.White, new System.Drawing.Font("Arial", 25F));
tHeader.Text = "Chart Title";
tHeader.Visible = true;

// set the properties for the footer
tFooter.Alignment = Chart.Alignment.Center;
tFooter.Backdrop = new GrapeCity.ActiveReports.Chart.Graphics.Backdrop(System.Drawing.Color.Thistle);
tFooter.Border = new GrapeCity.ActiveReports.Chart.Border(new GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.Indigo), 0, System.Drawing.Color.Black);
tFooter.DockArea = this.ChartControl1.ChartAreas[0];
tFooter.Docking = Chart.DockType.Bottom;
tFooter.Font = new GrapeCity.ActiveReports.Chart.FontInfo(System.Drawing.Color.DimGray, new System.Drawing.Font("Arial", 12F, System.Drawing.FontStyle.Bold));
tFooter.Text = "Chart Footer";
tFooter.Visible = true;

// add the header and footer titles to the titles collection
this.ChartControl1.Titles.AddRange(new GrapeCity.ActiveReports.Chart.Title[] {tHeader,tFooter});
See Also

Charts

Chart Control Items


Legends

Legends
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Appearance > Chart Control Items > Legends
Show All Show All
Hide All Hide All

The Chart control automatically creates a legend item for each series added to a chart at design time and sets the Legend property for each series by default. However, the legend's Visible property must be set to True for getting it displayed with the chart. The text for legend caption is taken from the Name property on the series.

Note: Each Series displayed in the Legend must have a Name. If the Name property is not set, the Series does not show up in the Legend.

The following code demonstrates how to create a legend at run time, add it to the Legends collection of the Chart object and set the legend property of the series to the new legend, resulting in the legend shown above.

To write code in Visual Basic.NET

Visual Basic code. Paste INSIDE the section Format event
Copy Code
' create the legend and title for the legend
Dim legend1 As New GrapeCity.ActiveReports.Chart.Legend
Dim lHeader As New GrapeCity.ActiveReports.Chart.Title

' set the properties for the legend title
lHeader.Backdrop = New GrapeCity.ActiveReports.Chart.Graphics.Backdrop(Chart.Graphics.BackdropStyle.Transparent, _Color.White, Color.White, Chart.Graphics.GradientType.Vertical, Drawing2D.HatchStyle.DottedGrid, Nothing, _Chart.Graphics.PicturePutStyle.Stretched)
lHeader.Border = New GrapeCity.ActiveReports.Chart.Border(New Chart.Graphics.Line(Color.White, 2, _Chart.Graphics.LineStyle.None), 0, Color.Black)
lHeader.Font = New GrapeCity.ActiveReports.Chart.FontInfo(Color.White, New System.Drawing.Font("Arial", 10.0F, _FontStyle.Bold))
lHeader.Text = "Series:"

' set the properties for the legend and add it to the legends collection
legend1.Alignment = GrapeCity.ActiveReports.Chart.Alignment.TopRight
legend1.Backdrop = New GrapeCity.ActiveReports.Chart.BackdropItem(Chart.Graphics.BackdropStyle.Transparent, _Color.Gray, Color.White, Chart.Graphics.GradientType.Vertical, Drawing2D.HatchStyle.DottedGrid, Nothing, _Chart.Graphics.PicturePutStyle.Stretched)
legend1.Border = New GrapeCity.ActiveReports.Chart.Border(New Chart.Graphics.Line(Color.Navy, 2), _0, Color.Black)
legend1.DockArea = Me.ChartControl1.ChartAreas(0)
legend1.LabelsFont = New GrapeCity.ActiveReports.Chart.FontInfo(Color.White, New System.Drawing.Font("Arial", 9.0F))
legend1.Header = lHeader
legend1.MarginX = 5
legend1.MarginY = 5
Me.ChartControl1.Legends.Add(legend1)

' Generate legend items
Dim legenditem As New GrapeCity.ActiveReports.Chart.LegendItem
Dim legenditem2 As New GrapeCity.ActiveReports.Chart.LegendItem

' Set properties of legend item
legenditem.Text = "High Range"
legenditem2.Text = "Low Range"
legenditem.Marker.Style = Chart.MarkerStyle.None
legenditem2.Marker.Style = Chart.MarkerStyle.None
legenditem.Border.Line.Style = Chart.Graphics.LineStyle.None
legenditem2.Border.Line.Style = Chart.Graphics.LineStyle.None
legenditem.Backdrop = New GrapeCity.ActiveReports.Chart.BackdropItem(System.Drawing.Color.LightSteelBlue, Chart.Graphics.AntiAliasMode.Auto)
legenditem2.Backdrop = New GrapeCity.ActiveReports.Chart.BackdropItem(System.Drawing.Color.LightGray, Chart.Graphics.AntiAliasMode.Auto)

' Add to legend collection
legend1.LegendItems.Add(legenditem)
legend1.LegendItems.Add(legenditem2)

' Set the legend property of the series to the legend you created
Me.ChartControl1.Series(0).Legend = legend1
Me.ChartControl1.Series(1).Legend = legend1
Me.ChartControl1.Series(2).Legend = legend1

To write code in C#

C# code. Paste INSIDE the section Format event
Copy Code
// create the legend and title for the legend
GrapeCity.ActiveReports.Chart.Legend legend1 = new GrapeCity.ActiveReports.Chart.Legend();
GrapeCity.ActiveReports.Chart.Title lHeader = new GrapeCity.ActiveReports.Chart.Title();

// set the properties for the legend title
lHeader.Backdrop = new GrapeCity.ActiveReports.Chart.Graphics.Backdrop(GrapeCity.ActiveReports.Chart.Graphics.BackdropStyle.Transparent,System.Drawing.Color.White,System.Drawing.Color.White, GrapeCity.ActiveReports.Chart.Graphics.GradientType.Vertical,
System.Drawing.Drawing2D.HatchStyle.DottedGrid, null, GrapeCity.ActiveReports.Chart.Graphics.PicturePutStyle.Stretched);

lHeader.Border = new GrapeCity.ActiveReports.Chart.Border(new GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.White, 2, GrapeCity.ActiveReports.Chart.Graphics.LineStyle.None), 0, System.Drawing.Color.Black);

lHeader.Font = new GrapeCity.ActiveReports.Chart.FontInfo(System.Drawing.Color.White,
new System.Drawing.Font("Arial", 10.0F, System.Drawing.FontStyle.Bold));
lHeader.Text = "Series:";

// set the properties for the legend and add it to the legends collection.
legend1.Alignment = GrapeCity.ActiveReports.Chart.Alignment.TopRight;
legend1.Backdrop = new GrapeCity.ActiveReports.Chart.BackdropItem(GrapeCity.ActiveReports.Chart.Graphics.BackdropStyle.Transparent, System.Drawing.Color.Gray,
System.Drawing.Color.White, GrapeCity.ActiveReports.Chart.Graphics.GradientType.Vertical,
System.Drawing.Drawing2D.HatchStyle.DottedGrid, null, GrapeCity.ActiveReports.Chart.Graphics.PicturePutStyle.Stretched);

legend1.Border = new GrapeCity.ActiveReports.Chart.Border(new GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.Navy, 2),0, System.Drawing.Color.Black);
legend1.DockArea = this.ChartControl1.ChartAreas[0];
legend1.LabelsFont = new GrapeCity.ActiveReports.Chart.FontInfo(System.Drawing.Color.White, new System.Drawing.Font("Arial", 9F));
legend1.Header = lHeader;
legend1.MarginX = 5;
legend1.MarginY = 5;
this.ChartControl1.Legends.Add(legend1);

// Generate legend items
GrapeCity.ActiveReports.Chart.LegendItem legenditem = new GrapeCity.ActiveReports.Chart.LegendItem();
GrapeCity.ActiveReports.Chart.LegendItem legenditem2 = new GrapeCity.ActiveReports.Chart.LegendItem();

// Set properties of legend item
legenditem.Text = "High Range";
legenditem2.Text = "Low Range";
legenditem.Marker.Style = GrapeCity.ActiveReports.Chart.MarkerStyle.None;
legenditem2.Marker.Style = GrapeCity.ActiveReports.Chart.MarkerStyle.None;
legenditem.Border.Line.Style = GrapeCity.ActiveReports.Chart.Graphics.LineStyle.None;
legenditem2.Border.Line.Style = GrapeCity.ActiveReports.Chart.Graphics.LineStyle.None;
legenditem.Backdrop = new GrapeCity.ActiveReports.Chart.BackdropItem(System.Drawing.Color.LightSteelBlue, GrapeCity.ActiveReports.Chart.Graphics.AntiAliasMode.Auto);
legenditem2.Backdrop = new GrapeCity.ActiveReports.Chart.BackdropItem(System.Drawing.Color.LightGray, GrapeCity.ActiveReports.Chart.Graphics.AntiAliasMode.Auto);

// Add to legend collection
legend1.LegendItems.Add(legenditem);
legend1.LegendItems.Add(legenditem2);

// set the legend property of the series to the legend you created.
this.ChartControl1.Series[0].Legend = legend1;
this.ChartControl1.Series[1].Legend = legend1;
this.ChartControl1.Series[2].Legend = legend1;
See Also
Chart Control Items


Markers

Markers
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Appearance > Chart Control Items > Markers
Show All Show All
Hide All Hide All

Use markers to show specific data series values in a chart. Markers are created by setting the Marker property of the series.

The following code demonstrates how to create a marker object at run time and assign it to the Marker property of the Series object. The results are shown in the image above.

To write code in Visual Basic.NET

Visual Basic code. Paste INSIDE the section Format event
Copy Code
' create the marker object
Dim marker1 As New GrapeCity.ActiveReports.Chart.Marker

' set the marker properties.
marker1.Backdrop = New Chart.Graphics.Backdrop(Chart.Graphics.GradientType.Horizontal, Color.Navy, Color.Black)
marker1.Line = New Chart.Graphics.Line(Color.White)
marker1.Label = New Chart.LabelInfo(New Chart.Graphics.Line(Color.Transparent, 0, Chart.Graphics.LineStyle.None), New Chart.Graphics.Backdrop(Chart.Graphics.BackdropStyle.Transparent, Color.White, Color.White, _ Chart.Graphics.GradientType.Vertical,
System.Drawing.Drawing2D.HatchStyle.DottedGrid, Nothing, _Chart.Graphics.PicturePutStyle.Stretched), New Chart.FontInfo(Color.White, New Font("Arial", 8.0F)), "{Value}", Chart.Alignment.Center)
marker1.Size = 24
marker1.Style = Chart.MarkerStyle.Diamond

' assign the marker to the series Marker property
Me.ChartControl1.Series(0).Marker = marker1

To write code in C#

C# code. Paste INSIDE the section Format event
Copy Code
// create the marker object
GrapeCity.ActiveReports.Chart.Marker marker1 = new GrapeCity.ActiveReports.Chart.Marker();

// set the marker properties
marker1.Backdrop = new GrapeCity.ActiveReports.Chart.Graphics.Backdrop(GrapeCity.ActiveReports.Chart.Graphics.GradientType.Horizontal, System.Drawing.Color.Navy, System.Drawing.Color.Black);
marker1.Line = new GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.White);
marker1.Label = new GrapeCity.ActiveReports.Chart.LabelInfo(new GrapeCity.ActiveReports.Chart.Graphics.Line(System.Drawing.Color.Transparent, 0, GrapeCity.ActiveReports.Chart.Graphics.LineStyle.None),
new GrapeCity.ActiveReports.Chart.Graphics.Backdrop(GrapeCity.ActiveReports.Chart.Graphics.BackdropStyle.Transparent, System.Drawing.Color.White, System.Drawing.Color.White, GrapeCity.ActiveReports.Chart.Graphics.GradientType.Vertical,
System.Drawing.Drawing2D.HatchStyle.DottedGrid, null, GrapeCity.ActiveReports.Chart.Graphics.PicturePutStyle.Stretched), new GrapeCity.ActiveReports.Chart.FontInfo(System.Drawing.Color.White, new System.Drawing.Font("Arial", 8F)), "{Value}",
GrapeCity.ActiveReports.Chart.Alignment.Center); marker1.Size = 24; marker1.Style = GrapeCity.ActiveReports.Chart.MarkerStyle.Diamond;

// assign the marker to the series Marker property
this.ChartControl1.Series[0].Marker = marker1;
See Also
Chart Control Items


Label Symbols

Label Symbols
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Appearance > Chart Control Items > Label Symbols
Show All Show All
Hide All Hide All

You can use Labels in Chart markers or legends.

By default, marker labels display Y value of data points, whereas legend labels display series name or data name.

Setting Strings

You can change a string (format string) displayed in a marker or legend label.

To change a string in a marker label

  1. Display the Series collection editor of properties window.
  2. Select the series that sets marker. (By default the first series (Series1) gets selected.
  3. Expand the Properties property.
  4. Expand the Marker property.
  5. Expand the Label property.
  6. Set the string to display in the Format property.

To change a string in a legend label

  1. Display the Series collection editor of properties window.
  2. Set the string you want to set in legend label using the LegendText property.

When the LegendItemMode property of Series is set to Series, series are displayed in legend. Data point will be displayed when set to Point. By default, in each graph the common setting will get displayed. For example, in case of bar chart it is series and in case of pie chart it is data point that gets displayed in legends.

Symbols

It is possible to easily display constant strings by simply performing the above mentioned settings. To display data, you need to embed the section (placeholder) that displays the value within format string at runtime.

A placeholder is a particular symbol enclosed within brackets {}.

The following symbols can be used. The sections enclosed within {} are changed by values.

Value

Data Value（Y value）

Pct

Percentage within series

PPct

Percentage having 100% as sum of multiple series for data points.

Name

X value of data

Index

Index of data point

Total

Total number of series

PTotal

Total number of multiple series for data points

When displaying numeric value, it is possible to set format specifying string similar to System.String.Format method used when displaying numeric values. For example, when format string is {Value}, numeric value is displayed in default format but when ":" (colon) format specifying string is added after Value, it is possible to insert comma or specify decimal place digits.

For example, the format string for "inserting comma in numeric value and displaying 2 digits after decimal place" would be as follows.

{Value:#,##0.00}

Please refer to the technical information posted on Microsoft site for details on format specifying string after continued numeric value after comma.

  • [Format Function]
  • [User defined numeric value format (Format function)]

Sample Image

The following image displays a bar chart with the following values.

X Value | abc | def | ghi
Y value of series 1（Red） | 1 | 2 | 3
Y value of series 2（green） | 4 | 3 | 2

String displayed below the image is a string set in Label.Format property of marker.

Value={Value}

Pct={Pct:0.0}

PPct={PPct:0.0}

Name={Name}

Total={Total}

PTotal={PTotal}

{Name}:{Value}

In case you wish to add a line break in between, as it is not possible to add a line break from Series collection editor, the following format string needs to be set at runtime.

To write code in Visual Basic.NET

Visual Basic
Copy Code
Private Sub rptLabelSymbol4_ReportStart(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart

Dim m As GrapeCity.ActiveReports.Chart.Marker
m = CType(Me.ChartControl1.Series(0).Properties("Marker"), GrapeCity.ActiveReports.Chart.Marker)
m.Label.Format = "{Name}" & vbCrLf & "{Value}"
End Sub

To write code in C#

C#
Copy Code
private void NewActiveReport1_ReportStart(object sender, EventArgs e)
{
GrapeCity.ActiveReports.Chart.Marker m;
m = (GrapeCity.ActiveReports.Chart.Marker)
this.ChartControl1.Series[0].Properties["Marker"];
m.Label.Format = "{Name}\n{Value}";
}

Specific symbols

The specific symbols that are used according to the chart type.

Bubble Charts

Value

Y2 value

Value0

Y value

Value1

Y2value

Bubble XY Chart

Value0

X value

Value1

Y value

Value2

Y2 value

Candle or Hilo Chart

For a Candle chart or HiLo chart, symbols are not enabled for legend or marker labels.

See Also
Chart Control Items


Constant Lines and Stripes

Constant Lines and Stripes
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Appearance > Chart Control Items > Constant Lines and Stripes
Show All Show All
Hide All Hide All

The Chart control supports constant lines and stripes through the use of the WallRanges collection. It allows you to display horizontal or vertical lines or stripes in a chart to highlight certain areas. For example, you could draw a stripe in a chart to draw attention to a high level in the data or draw a line to show the average value of the data presented.
Note: The Chart control does not aggregate average values. Please aggregate the average values beforehand and then render the line.

Important properties

  • StartValue Sets the start value on the primary axis for the wall range.
  • EndValue Sets the end value on the primary axis for the wall range.
  • PrimaryAxis Sets the axis on which the wall range appears.

The following code demonstrates how to create wall ranges, set their properties, and assign them to a chart area at run time. The results are shown in the image above.

To write code in Visual Basic.NET

Visual Basic code. Paste INSIDE the section Format event
Copy Code
' Create the WallRange objects
Dim wallRange1 As New GrapeCity.ActiveReports.Chart.WallRange
Dim wallRange2 As New GrapeCity.ActiveReports.Chart.WallRange
Dim wallRange3 As New GrapeCity.ActiveReports.Chart.WallRange

' Set WallRange property
With wallRange1
    .Backdrop = New GrapeCity.ActiveReports.Chart.Graphics.Backdrop(Color.White)
    .Border = New GrapeCity.ActiveReports.Chart.Border(New GrapeCity.ActiveReports.Chart.Graphics.Line(Color.Transparent, 0, GrapeCity.ActiveReports.Chart.Graphics.LineStyle.None), 0, Color.Black)
    .EndValue = 40
    .PrimaryAxis = ((CType(Me.ChartControl1.ChartAreas(0).Axes("AxisY"), GrapeCity.ActiveReports.Chart.Axis)))
    .StartValue = 30
End With
With wallRange2
    .Backdrop = New GrapeCity.ActiveReports.Chart.Graphics.Backdrop(Color.Lime)
    .Border = New GrapeCity.ActiveReports.Chart.Border(New GrapeCity.ActiveReports.Chart.Graphics.Line(Color.Transparent, 0, GrapeCity.ActiveReports.Chart.Graphics.LineStyle.None), 0, Color.Black)
    .EndValue = 34
    .PrimaryAxis = ((CType(Me.ChartControl1.ChartAreas(0).Axes("AxisY"), GrapeCity.ActiveReports.Chart.Axis)))
    .StartValue = 33
End With
With wallRange3
    .Backdrop = New GrapeCity.ActiveReports.Chart.Graphics.Backdrop(Color.DarkGreen, CType(150, Byte))
    .Border = New GrapeCity.ActiveReports.Chart.Border(New GrapeCity.ActiveReports.Chart.Graphics.Line(Color.Transparent, 0, GrapeCity.ActiveReports.Chart.Graphics.LineStyle.None), 0, Color.Black)
    .EndValue = 40
    .PrimaryAxis = ((CType(Me.ChartControl1.ChartAreas(0).Axes("AxisZ"), GrapeCity.ActiveReports.Chart.Axis)))
    .StartValue = 20
End With

' Add the WallRange to the chart area and set wall and Z axis properties to show lines.
With ChartControl1.ChartAreas(0)
    .WallRanges.AddRange(New GrapeCity.ActiveReports.Chart.WallRange() {wallRange1, wallRange2, wallRange3})
    .WallXY.Backdrop.Alpha = 100
    .WallXZ.Backdrop.Alpha = 100
    .WallYZ.Backdrop.Alpha = 100
    .Axes(4).MajorTick.Step = 20
    .Axes(4).Max = 60
    .Axes(4).Min = 0
    .Axes(4).Visible = True
End With

To write code in C#

C# code. Paste INSIDE the section Format event
Copy Code
// Create the WallRange objects
GrapeCity.ActiveReports.Chart.WallRange wallRange1 = new GrapeCity.ActiveReports.Chart.WallRange();
GrapeCity.ActiveReports.Chart.WallRange wallRange2 = new GrapeCity.ActiveReports.Chart.WallRange();
GrapeCity.ActiveReports.Chart.WallRange wallRange3 = new GrapeCity.ActiveReports.Chart.WallRange();

// Set WallRange property
wallRange1.Backdrop = new GrapeCity.ActiveReports.Chart.Graphics.Backdrop(System.Drawing.Color.White);
wallRange1.Border = new GrapeCity.ActiveReports.Chart.Border(new GrapeCity.ActiveReports.Chart.Graphics.Line
(System.Drawing.Color.Transparent, 0, GrapeCity.ActiveReports.Chart.Graphics.LineStyle.None),
0, System.Drawing.Color.Black);
wallRange1.EndValue = 40;
wallRange1.PrimaryAxis = (GrapeCity.ActiveReports.Chart.Axis)this.ChartControl1.ChartAreas[0].Axes["AxisY"];
wallRange1.StartValue = 30;
wallRange2.Backdrop = new GrapeCity.ActiveReports.Chart.Graphics.Backdrop(System.Drawing.Color.Lime);
wallRange2.Border = new GrapeCity.ActiveReports.Chart.Border(new GrapeCity.ActiveReports.Chart.Graphics.Line
(System.Drawing.Color.Transparent, 0, GrapeCity.ActiveReports.Chart.Graphics.LineStyle.None),
0, System.Drawing.Color.Black);
wallRange2.EndValue = 34;
wallRange2.PrimaryAxis = (GrapeCity.ActiveReports.Chart.Axis)this.ChartControl1.ChartAreas[0].Axes["AxisY"];
wallRange2.StartValue = 33;
wallRange3.Backdrop = new GrapeCity.ActiveReports.Chart.Graphics.Backdrop(System.Drawing.Color.DarkGreen);
wallRange3.Border = new GrapeCity.ActiveReports.Chart.Border(new GrapeCity.ActiveReports.Chart.Graphics.Line
(System.Drawing.Color.Transparent, 0, GrapeCity.ActiveReports.Chart.Graphics.LineStyle.None),
0, System.Drawing.Color.Black);
wallRange3.EndValue = 40;
wallRange3.PrimaryAxis = (GrapeCity.ActiveReports.Chart.Axis)this.ChartControl1.ChartAreas[0].Axes["AxisZ"];
wallRange3.StartValue = 20;

// Add the WallRange to the chart area and set wall and Z axis properties to show lines.
this.ChartControl1.ChartAreas[0].WallRanges.AddRange(
new GrapeCity.ActiveReports.Chart.WallRange[] {wallRange1,wallRange2,wallRange3});
this.ChartControl1.ChartAreas[0].WallXY.Backdrop.Alpha = 100;
this.ChartControl1.ChartAreas[0].WallXZ.Backdrop.Alpha = 100;
this.ChartControl1.ChartAreas[0].WallYZ.Backdrop.Alpha = 100;
this.ChartControl1.ChartAreas[0].Axes[4].MajorTick.Step = 20;
this.ChartControl1.ChartAreas[0].Axes[4].Max = 60;
this.ChartControl1.ChartAreas[0].Axes[4].Min = 0;
this.ChartControl1.ChartAreas[0].Axes[4].Visible = true;
See Also
Chart Control Items


Chart Axes and Walls

Chart Axes and Walls
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Appearance > Chart Axes and Walls

This section explains about the axis and walls of the ChartControl.

Standard Axes
This section explains about standard axis properties or special characteristics.
Custom Axes
This section explains about the method to create custom axis.
Gridlines and Tick Marks
This section explains about the usage of grid lines and ticks.


Standard Axes

Standard Axes
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Appearance > Chart Axes and Walls > Standard Axes
Show All Show All
Hide All Hide All

The Chart control provides the means to change axis settings at design time or at run time. Chart axes make it possible to view and understand the data plotted in a graph.

Axis Types

Most 2D charts contain a numerical axis (AxisY) and a categorical axis (AxisX). 3D charts include another numerical axis (AxisZ). These axes are accessible at run time from the ChartArea object and allow you to control the settings for each, including scaling, labels, and various formatting properties. For any of the scaling or labeling properties you set to show up at run time, you will need to set the Visible property of the axis to True.

Changing Axis Settings

Axis settings can be changed at design time by clicking on a Chart control and using the Properties Window or at run time in code from the chart's ChartArea object.

Scaling

For normal linear scaling on a numeric axis, set the Max and Min properties for the axis, which correspond to the numerical values in the chart's data series. Also, set the Step property of the MajorTick to show the major numerical unit values. The Step property controls where labels and tick marks are shown on the numerical axis.

To write code in Visual Basic.NET

Visual Basic code. Paste INSIDE the section Format event
Copy Code
With Me.ChartControl1.ChartAreas(0).Axes("AxisY")
   .Max = 100
   .Min = 0
   .MajorTick.Step = 10
End With

To write code in C#

C# code. Paste INSIDE the section Format event
Copy Code
this.ChartControl1.ChartAreas[0].Axes["AxisY"].Max = 100;
this.ChartControl1.ChartAreas[0].Axes["AxisY"].Min = 0;
this.ChartControl1.ChartAreas[0].Axes["AxisY"].MajorTick.Step = 10;

The Chart control also supports logarithmic scaling which allows you to show the vertical spacing between two points that corresponds to the percentage of change between those numbers. You can set your numeric axis to scale logarithmically by setting the IsLogarithmic property on the axis to True and setting the Max and Min properties of the axis.

Labeling

To show labels on an axis, you will need to specify the value for the LabelsGap property, set your LabelsFont properties, and set LabelsVisible to True. These properties can be set in the AxisBase Collection editor, which is accessed at design time by clicking the ellipsis button next to the ChartAreas (Collection) property, then the Axes (Collection) property of the ChartArea.

Tip: Labels render first, and then the chart fills in the remaining area, so be sure to make the chart large enough if you use angled labels.

You can specify strings to be used for the labels instead of numerical values on an axis by using the Labels collection property at design time or assigning a string array to the Labels property at run time. You can also specify whether you want your axis labels to appear on the outside or inside of the axis line using the LabelsInside property. By default, labels appear outside the axis line.

Format for numeric value axis label

You can use the LabelFormat property to set the label format of numeric value axis. The LabelFormat property can be referenced from the AxisBase collection editor.

For example, if you want to display a digit separator as shown in the image above, you should specify "{0:c}" in the LabelFormat property to output the "\1,213" value. When "{0:#,###円}" is specified, the output value is "1,213円". The LabelFormat property uses the same format as the ListControl.DataFormatString property of .NET Framework standard control.

Tip: To set a specific tick interval using the LabelFormat property, the SmartLabels property should be set to False.

Secondary Axes

By default, a Chart object includes secondary X and Y axes (AxisX2 and AxisY2). At design time or run time, you can specify a secondary axis to plot data against by setting all of the appropriate properties for AxisX2 or AxisY2, including the Visible property.For example, if you want to use two axes to show the same data as it appears on two different scales, you can set the primary axis to show the actual data value scale, for example, and set the secondary axis to show a logarithmic scale.

To write code in Visual Basic.NET

Visual Basic code. Paste INSIDE the section Format event
Copy Code
' set properties for AxisY (primary axis)
With Me.ChartControl1.ChartAreas(0).Axes("AxisY")
   .Max = 25
   .Min = 0
   .MajorTick.Step = 5
End With

' set properties for AxisY2 (secondary Y axis)
With Me.ChartControl1.ChartAreas(0).Axes("AxisY2")
   .Max = 1000
   .Min = 0
   .MajorTick.Step = 200
' set the scaling for the secondary axis to logarithmic
   .AxisType = GrapeCity.ActiveReports.Chart.AxisType.Logarithmic
   .Visible = True
End With

To write code in C#

C# code. Paste INSIDE the section Format event
Copy Code
// set properties for AxisY (primary axis)
this.ChartControl1.ChartAreas[0].Axes["AxisY"].Max = 25;
this.ChartControl1.ChartAreas[0].Axes["AxisY"].Min = 0;
this.ChartControl1.ChartAreas[0].Axes["AxisY"].MajorTick.Step = 5;

// set properties for AxisY2 (secondary Y axis)
this.ChartControl1.ChartAreas[0].Axes["AxisY2"].Max = 1000;
this.ChartControl1.ChartAreas[0].Axes["AxisY2"].Min = 0;
this.ChartControl1.ChartAreas[0].Axes["AxisY2"].MajorTick.Step = 200;

// set the scaling for the secondary axis to logarithmic
this.ChartControl1.ChartAreas[0].Axes["AxisY2"].AxisType = GrapeCity.ActiveReports.Chart.AxisType.Logarithmic;
this.ChartControl1.ChartAreas[0].Axes["AxisY2"].Visible = true;

See Also
Chart Axes and Walls


Custom Axes

Custom Axes
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Appearance > Chart Axes and Walls > Custom Axes
Show All Show All
Hide All Hide All

The Chart control supports the creation of additional custom axes through the use of the chart's CustomAxes collection. Once a custom axis has been added to the collection, in addition to setting the normal axis properties, you will need to set the following properties:

  • Parent - The Parent property allows you to choose the primary or secondary axis on which your custom axis resides.
  • PlacementLength - The PlacementLength property allows you to set the length of the custom axis in proportion to the Min and Max property values you have already set for the parent axis.
  • PlacementLocation - The PlacementLocation property allows you to set the starting location value for the custom axis to appear in relation to the parent axis.

The following code sample demonstrates creating a custom axis, adding it to the Axes collection for the ChartArea, and setting its properties.

To write code in Visual Basic.NET

Visual Basic code. Paste INSIDE the section Format event
Copy Code
' create the custom axis and add it to the ChartArea's Axes collection
Dim customAxisY As New GrapeCity.ActiveReports.Chart.CustomAxis
Me.ChartControl1.ChartAreas(0).Axes.Add(customAxisY)

' set the basic axis properties for customAxisY
customAxisY.LabelFont = New GrapeCity.ActiveReports.Chart.FontInfo(Color.Red, New Font("Arial", 7.0!))
customAxisY.LabelsGap = 1
customAxisY.LabelsVisible = True
customAxisY.Line = New GrapeCity.ActiveReports.Chart.Graphics.Line(Color.Red, 1, GrapeCity.ActiveReports.Chart.Graphics.LineStyle.Solid)
customAxisY.Max = 100
customAxisY.Min = 0
customAxisY.MaxDerived = False
customAxisY.Visible = True

' set major tick
customAxisY.MajorTick = New GrapeCity.ActiveReports.Chart.Tick(New GrapeCity.ActiveReports.Chart.Graphics.Line(Color.Red, 1), New GrapeCity.ActiveReports.Chart.Graphics.Line(Color.Red, 1), 20, 5, True)
customAxisY.MajorTick.Visible = True

' set minor tick
customAxisY.MinorTick.Visible = False
customAxisY.MinorTick.GridLine.Style = Chart.Graphics.LineStyle.None

' set custom axis property
customAxisY.Parent = ((CType(Me.ChartControl1.ChartAreas(0).Axes("AxisY"), GrapeCity.ActiveReports.Chart.Axis)))
customAxisY.PlacementLength = 20
customAxisY.PlacementLocation = 45

To write code in C#

C# code. Paste INSIDE the section Format event
Copy Code
// create the custom axis and add it to the ChartArea's Axes collection
GrapeCity.ActiveReports.Chart.CustomAxis customAxisY = new GrapeCity.ActiveReports.Chart.CustomAxis();
this.ChartControl1.ChartAreas[0].Axes.Add(customAxisY);

// set the basic axis properties for customAxisY
customAxisY.LabelFont = new GrapeCity.ActiveReports.Chart.FontInfo(Color.Red, new Font("Arial", 7F, FontStyle.Regular, GraphicsUnit.Point, ((System.Byte)(0))));
customAxisY.LabelsGap = 1;
customAxisY.LabelsVisible = true;
customAxisY.Line = new GrapeCity.ActiveReports.Chart.Graphics.Line(Color.Red);
customAxisY.MajorTick = new GrapeCity.ActiveReports.Chart.Tick(new GrapeCity.ActiveReports.Chart.Graphics.Line(Color.Red, 1), new GrapeCity.ActiveReports.Chart.Graphics.Line(Color.Red, 1), 1, 2F, true);
customAxisY.MajorTick.GridLine = new GrapeCity.ActiveReports.Chart.Graphics.Line(Color.Red, 1, GrapeCity.ActiveReports.Chart.Graphics.LineStyle.Solid);
customAxisY.MajorTick.Visible = true;
customAxisY.Max = 5;
customAxisY.MaxDerived = false;
customAxisY.Min = 0;
customAxisY.Visible = true;

// set the special custom axis properties
customAxisY.Parent = (GrapeCity.ActiveReports.Chart.Axis)this.ChartControl1.ChartAreas[0].Axes["AxisY"];
customAxisY.PlacementLength = 20;
customAxisY.PlacementLocation = 30;
See Also
Chart Axes and Walls


Gridlines and Tick Marks

Gridlines and Tick Marks
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ChartControl > Chart Appearance > Chart Axes and Walls > Gridlines and Tick Marks
Show All Show All
Hide All Hide All

Gridlines and tick marks are generally used to help increase the readability of a chart.

Types

There are two kinds of gridlines and tick marks in the Chart control: major and minor. The properties for the major gridlines and tick marks are set on the MajorTick object of the particular axis and the properties for minor gridlines and ticks are set on the MinorTick object of the axis. The location for any labels shown for the axis are determined by the Step property of the MajorTick object.

Step and TickLength

For either the MajorTick or MinorTick objects, you can define where the tick marks and gridlines will appear by setting the Step property. The TickLength property allows you to set the region the tick mark will extend outside of the axis line.

Tip: To set a specific tick interval using the Step property, you should set the SmartLabels property to False.

Visible

To make any defined major or minor tick marks to show up at design time or run time, the Visible property of the MajorTick or MinorTick object must be set to True. To show major or minor gridlines at design time or run time, the Visible property of the WallXY object as well as that of the MajorTick or MinorTick object must be set to True.

See Also
Chart Axes and Walls


ReportInfo

ReportInfo
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > ReportInfo
Show All Show All
Hide All Hide All

In ActiveReports, the ReportInfo control allows you to quickly display page numbers, page counts, and report dates. The ReportInfo control is a text box with a selection of preset FormatString options. You can set page counts to count the pages for the entire report, or for a specified group.

You can customize the preset values by editing the string after you select it. For example, if you want to display the total number of pages in the ReportHeader section, you can enter a value like:

Total of {PageCount} pages.
Caution: With large reports using the CacheToDisk property, placing page counts in header sections may have an adverse effect on memory as well as rendering speed. Since the rendering of the header is delayed until ActiveReports determines the page count of the following sections, CacheToDisk is unable to perform any optimization. For more information on this concept, see Optimizing Section Reports.

For more information on creating formatting strings, see the Date, Time, and Number Formatting topic.

Important Properties

Property | Description
FormatString | Gets or sets the string used to display formatted page numbering or report date and time values in the control.
Style | Gets or sets the style string for the control. This property reflects any settings you choose in the Font and ForeColor properties.
SummaryGroup | Gets or sets the name of the GroupHeader section that is used to reset the number of pages when displaying group page numbering.

Displaying page numbers and report dates

  1. From the toolbox, drag the ReportInfo control to the desired location on the report.

  2. With the ReportInfo control selected in the Properties window, drop down the FormatString property and select the preset value that best suits your needs.

Displaying group level page counts

  1. From the toolbox, add the ReportInfo control to the GroupHeader or GroupFooter section of a report and set the FormatString property to a value that includes PageCount.
  2. With the ReportInfo control still selected, in the Properties window, drop down the SummaryGroup property and select the group for which you want to display a page count.

ReportInfo Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

General

Name: Enter a name for the control that is unique within the report. This name is displayed in the Document Outline and in XML exports.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

DataField: Select a field name from the data source to which to bind the control.

Appearance

Background Color: Select a color to use for the background of the control.

Font

Name: Select a font family name or a theme font.

Size: Choose the size in points for the font.

Style: Choose Normal or Italic.

Weight: Choose from Normal or Bold.

Color: Choose a color to use for the text.

Decoration: Select check boxes for Underline and Strikeout.

GDI Charset: Enter a value to indicate the GDI character set to use. For a list of valid values, see MSDN Font.GDICharSet Property.

GDI Vertical: Select this checkbox to indicate that the font is derived from a GDI vertical font.

Format

Format string: Select a formatted page numbering or report date and time value to display in the control. You may also type in this box to change or add text to display along with the formatted date and page number values.

Multiline: Select this check box to allow text to render on multiple lines within the control.

ReportInfo height

Can increase to accommodate contents: Select this check box to set CanGrow to True.

Can decrease to accommodate contents: Select this check box to set CanShrink to True.

Text direction

RightToLeft: Select this check box to reverse the text direction.

Alignment

Vertical alignment: Choose Top, Middle, or Bottom.

Horizontal alignment: Choose Left, Center, Right, or Justify.

Wrap mode: Choose NoWrap, WordWrap, or CharWrap to select whether to wrap words or characters to the next line.

Summary

SummaryGroup: Select a GroupHeader section in the report to display the number of pages in each group when using the PageCount.

SummaryRunning: Select None, Group, or All to display a summarized value.

See Also
Optimizing Section Reports


Cross Section Controls

Cross Section Controls
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Toolbox > Cross Section Controls
Show All Show All
Hide All Hide All

In section reports, you can use the CrossSectionLine and CrossSectionBox report controls to display a frame, borders, and vertical lines that run from a header section through its related footer section, spanning all details that come between. You can specify line appearance using properties on the report controls, and even round the corners of the CrossSectionBox.

You can only place the cross section controls in header sections in the designer. They automatically span intervening sections to end in the related footer section. (You can also place them in footer sections, but they automatically associate themselves with the related header section in the Report Explorer.)

CrossSectionLine

The CrossSectionLine control draws a vertical line from a header section to the corresponding footer section. At runtime, this vertical line stretches through any intervening sections. You can change the appearance of CrossSectionLine by changing the following properties.

Property | Description
LineColor | Allows you to get or set color of the line.
LineStyle | Allows you to select the line style from solid, dash or dotted.
LineWeight | Allows you to specify the thickness of the line in pixel units.

CrossSectionBox

The CrossSectionBox control draws a rectangle from a header section to its corresponding footer section. To change the appearance of the rectangle, you can use the following properties in addition to the ones mentioned above.

Property | Description
Radius | Sets the radius of each corner for the RoundRect shape type. You can select Default, TopLeft, TopRight, BottomLeft or BottomRight. Selecting Default sets the radius of all the corners of the CrossSectionBox control to a specified percentage. Default value = 0 (point).
BackColor | Sets the back color.
Note: At run time, the BackColor property renders first and the LineColor property renders last.
Caution: The CrossSectionBox and CrossSectionLine controls do not render properly in multi-column reports, that is, those in which a GroupHeader section has the ColumnLayout property set to True.

CrossSectionLine Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

General

Name: Enter a name for the control that is unique within the report. This name is displayed in the Document Outline and in XML exports.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

Appearance

Line style: Select a line style to use for the control. You can set it to Transparent, Solid, Dash, Dot, DashDot, or DashDotDot.

Line weight: Enter the width in pixels for the line.

Line color: Select a color to use for the line.

CrossSectionBox Dialog

With the control selected on the report, in the Commands section at the bottom of the Properties window, you can click the Property dialog command to open the dialog.

General

Name: Enter a name for the control that is unique within the report. This name is displayed in the Document Outline and in XML exports.

Tag: Enter a string that you want to persist with the control. If you access this property in code, it is an object, but in the Properties window or Property dialog, it is a string.

Visible: Clear this check box to hide the control.

Appearance

Line style: Select a line style to use for the border line. You can set it to Transparent, Solid, Dash, Dot, DashDot, or DashDotDot.

Line weight: Enter the width in pixels for the border line.

Line color: Select a color to use for the border line.

Background color: Select a color to use for the background of the picture control.

Rounded Rectangle: Specify the radius for each corner of the CrossSectionBox individually. Drag the handlers [image] available at each corner of the CrossSectionBox to set the value of the radius at each corner.

Note: To enable specific corners, check the CheckBox available near each corner of the CrossSectionBox control.

  • Use the same radius on specified corners: Select this option to apply the same radius to all selected corners of the CorssSectionBox.

  • Use different radius on specified corners: Select this option to apply a different radius to each selected corner of the CorssSectionBox.

See Also
Shape (Section Report)
Line (Section Report)


Section Report Structure

Section Report Structure
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Structure
Show All Show All
Hide All Hide All

By default, a section report is composed of three banded sections: a PageHeader, a Detail section, and a PageFooter. You can right-click the report and select Insert and choose other section pairs to add: ReportHeader and Footer, or GroupHeader and Footer.

All sections except the detail section come in pairs, above and below the detail section. You can hide any section that you are not using by setting the Visible property of the section to False.

ActiveReports defines the following section types:

Report Header

A report can have one report header section that prints at the beginning of the report. You generally use this section to print a report title, a summary table, a chart or any information that only needs to appear once at the report's start. This section has a NewPage property that you can use to add a new page before or after it renders.

The Report Header does not appear on a section report by default. In order to add this section, right-click the report and select Insert > Report Header/Footer to add a Report Header and Footer pair.

Page Header

A report can have one page header section that prints at the top of each page. Unless the page contains a report header section, the page header is the first section that prints on the page. You can use the page header to print column headers, page numbers, a page title, or any information that needs to appear at the top of each page.

Group Header

A report can include single or nested groups, with each group having its own header and footer sections. You can insert and print the header section immediately before the detail section. For more information on grouping, see Grouping Data in Section Reports.

In Columnar Reports, you can use ColumnGroupKeepTogether, and select whether to start a NewColumn before or after a group.

You can also specify whether to print a NewPage before or after the section, and have the section print on every page until the group details complete with the RepeatStyle property. The UnderlayNext property allows you to show group header information inside the group details, so long as you keep the BackColor property of the Detail section set to Transparent.

See GroupHeader for further information on properties.

Detail

A report has one detail section. The detail section is the body of the report and one instance of the section is created for each record in the report. You can set the CanShrink property to True to eliminate white space after controls, and you can set up Columnar Reports using ColumnCount, ColumnDirection, ColumnSpacing and NewColumn properties.

The KeepTogether property attempts to keep the section together on a single page, and the RepeatToFill property allows you to fill each page with the same number of formatted rows, regardless of whether there is enough data to fill them. This is especially useful for reports such as invoices in which you want consistent formatting like lines or green bars or back colors to fill each page down to the Footer section at the bottom.

See Detail for further information on properties.

Note: You cannot use the RepeatToFill property if you are using the PageBreak or SubReport control in the Detail section, or if you have set the NewPage or NewColumn property to any value other than None. When you use this property in a report where two groups are present, the ReportFooter section prints on the next page. This property processes correctly only with single grouping.

Group Footer

A report can include single or nested groups, with each group having its own header and footer sections. You can insert and print the footer section immediately after the detail section. For more information on grouping, see Grouping Data in Section Reports.

Page Footer

A report can have one page footer section that prints at the bottom of each page. You can use the page footer to print page totals, page numbers, or any other information that needs to appear at the bottom of each page.

Report Footer

A report can have one report footer section that prints at the end of the report. Use this section to print a summary of the report, grand totals, or any information that needs to print once at the end of the report.

The Report Footer does not appear on a section report by default. In order to add this section, right-click the report and select Insert > Report Header/Footer to add a Report Header and Footer pair.

Note: If the report contains a Page Footer on the last page, the Report Footer appears above the Page Footer.
See Also
Section Report Events

How To

Add Grouping in Section Reports


Section Report Events

Section Report Events
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Section Report Events
Show All Show All
Hide All Hide All

Section reports use events to allow you to control report behavior.

Single-Occurrence Events

The following events are all of the events that are raised only once during a Section report's processing. These events are raised at the beginning or at the end of the report processing cycle.

Events raised once

ReportStart

Use this event to initialize any objects or variables needed while running a report. This event is also used to set any Subreport control objects to a new instance of the report assigned to the Subreport control.

Caution: Be sure to add dynamic items to the report before this event finishes.

DataInitialize

This event is raised after ReportStart. Use it to add custom fields to the report's Fields collection. Custom fields can be added to a bound report (one that uses a Data Control to connect and retrieve records) or an unbound report (one that does not depend on a data control to get its records). In a bound report the dataset is opened and the dataset fields are added to the custom fields collection, then the DataInitialize event is raised so new custom fields can be added. The DataInitialize event can also be used to make adjustments to the DataSource or to set up database connectivity.

ReportEnd

This event is raised after the report finishes processing. Use this event to close or free any objects that you were using while running a report in unbound mode, or to display information or messages to the end user. This event can also be used to export reports.

Multiple-Occurrence Events

The following events are raised multiple times during a Section report's processing.

Events raised more than once

FetchData

This event is raised every time a new record is processed. The FetchData has an EOF parameter indicating whether the FetchData event should be raised. This parameter is not the same as the Recordset's EOF property and is defaulted to True. When working with bound reports (reports using a DataControl), the EOF parameter is automatically set by the report; however, when working with unbound reports this parameter needs to be controlled manually.

Use the FetchData event with unbound reports to set the values of custom fields that were added in the DataInitialize event or with bound reports to perform special functions, such as combining fields together or performing calculations. The FetchData event should not have any references to controls on the report.

If you need to use a value from a Dataset with a control in the Detail section, set a variable in the FetchData event and use the variable in the section's Format event to set the value for the control. Please note that this method of setting a variable in the FetchData event and using it to set a control's value is only supported in the Detail_Format event.

Also use the FetchData event to increment counters when working with arrays or collections.

PageStart

This event fires before a page is rendered. Use this event to initialize any variables needed for each page when running an unbound report.

PageEnd

This event is raised after each page in the report is rendered. Use this event to update any variables needed for each page when running an unbound report.

When Bound and Unbound Data Values Are Set

  1. The Fields collection is populated from the dataset that is bound to the report after the DataInitialize event is raised. (In an unbound report, the Fields collection values are not set to anything at this point.)
  2. The FetchData event is raised, giving the user a chance to modify the Fields collection.
  3. Any fields that are bound have the values transferred over.
  4. The Format event is raised.

Events that Occur for Each Instance of Each Section

In a Section report, regardless of the type or content of the various sections, there are three events for each section: Format, BeforePrint and AfterPrint.

Section Events

Because there are many possible report designs, the event-raising sequence is dynamic in order to accommodate individual report demands. The only guaranteed sequence is that a section's Format event is raised before the BeforePrint event, which in turn occurs before the AfterPrint event but not necessarily all together. Reports should not be designed to rely on these events being raised in immediate succession.

Important: Never reference the report's Fields collection in these section events. Only reference the Fields collection in theDataInitialize and FetchData events.

Format

ActiveReports raises this event after the data is loaded and bound to the controls contained in a section, but before the section is rendered to a page.

The Format event is the only event in which you can change the section's height. Use this section to set or change the properties of any controls or the section itself.

Also use the Format event to pass information, such as an SQL String, to a Subreport.

If the CanGrow or CanShrink property is True for the section or any control within the section, all of the growing and shrinking takes place in the Format event. Because of this, you cannot obtain information about a control or section's height in this event.

Because a section's height is unknown until the Format event finishes, it is possible for a section's Format event to be raised while the report is on a page to which the section is not rendered. For example, the Detail Format event is raised but the section is too large to fit on the page. This causes the PageFooter events and the PageEnd event to be raised on the current page, and the PageStart, any other Header events, and possibly the FetchData event to be raised before the section is rendered to the canvas on the next page.

BeforePrint

ActiveReports raises this event before the section is rendered to the page.

The growing and shrinking of the section and its controls have already taken place. Therefore, you can use this event to get an accurate height of the section and its controls. You can modify values and resize controls in the BeforePrint event, but you cannot modify the height of the section itself.

Also use this event to do page-specific formatting since the report knows which page the section will be rendered to when this event is raised. Once this event has finished, the section cannot be changed in any way because the section is rendered to the canvas immediately after this event.

Note: If a section contains the SubReport control that occupies more than one page, the SubReport gets split into smaller parts at rendering. In this case, you can use the BeforePrint event - it will fire multiple times to get the height of each part of the rendered SubReport.

AfterPrint

ActiveReports raises this event after the section is rendered to the page.

Although AfterPrint was an important event prior to ActiveReports Version 1 Service Pack 3, it is rarely used in any of the newer builds of ActiveReports. This event is still useful, however, if you want to draw on the page after text has already been rendered to it.

Event Sequence

Multi-threaded, single-pass processing enables Section reports to surpass other reports in processing and output generation speed. ActiveReports processes and renders each page as soon as the page is ready. If a page has unknown data elements or its layout is not final, it places the page in cache until the data is available.

Sequence of Events

Summary fields and KeepTogether constraints are two reasons why a page might not render immediately. The summary field is not complete until all the data needed for calculation is read from the data source. When a summary field such as a grand total is placed ahead of its completion level, such as in the report header, the report header and all following sections are delayed until all of the data is read.

There are ten report events in the code behind a Section report, or seven in a ActiveReport script.

Because there are so many ways in which you can customize your reports, not all reports execute in the same way. However, when you run a report, this is generally what happens:

  1. ActiveReports raises the ReportStart event. The report validates any changes made to the report structure in ReportStart. In some cases, data source properties raise the DataInitialize event.
  2. Printer settings are applied. If none are specified, the local machine's default printer settings are used.
  3. If the DataInitialize event was not already raised, ActiveReports raises it and opens the data source.
  4. If the data source contains Parameters with unset values and the ShowParameterUI property is set to True, ActiveReports displays a parameters dialog to request values from the user.
  5. Closing the dialog raises the ParameterUIClosed event. If the report is a subreport that requires parameters, ActiveReports binds the subreport parameters to any fields in the parent report.
  6. ActiveReports raises the FetchData event.
  7. If there is no data, the NoData event is raised.
  8. The PageStart event raises, and then raises again after each PageEnd event until the final page.
  9. Group sections are bound and sections begin rendering on pages.
  10. ActiveReports raises Section Events to process sections in (roughly) the following order:
    • Report header
    • Page header
    • Group header
    • Detail
    • Group footer
    • Page footer
    • Report footer
  11. After each event, ActiveReports checks the Cancel flag to ensure that it should continue.
  12. Other events may raise, depending on the report logic.
  13. The PageEnd event raises after each page becomes full, and the PageStart raises if the report has not finished.
  14. Finally, ActiveReports raises the ReportEnd event.

Events that May Occur

These events occur in response to user actions, or when there is no data for a report.

Other Events

DataSourceChanged

This event occurs if the report's data source is changed. This is mainly useful with the end-user designer control.

NoData

This event occurs if the report's data source returns no records.

ParameterUIClosed

This event occurs when the user closes the parameter dialog.

PrintAborted

This event occurs when the user cancels a print job.

PrintProgress

This event occurs once for each page while the report document is printing.

See Also

How To

Add Code to Layouts Using Script


Scripting in Section Reports

Scripting in Section Reports
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Scripting in Section Reports
In a section report, ActiveReports allows you to use VB.NET or C# script to port your custom logic to report layouts. This permits layouts saved to report XML (RPX) files to serve as stand-alone reports. By including scripting before you save the report layout as an RPX file, you can later load, run, and display the report directly to the viewer control without using the designer. In conjunction with report files, scripting allows you to update distributed reports without recompiling your project.

Script Editor

To access the script editor, click the script tab below the report design surface. The script tab contains two drop-downs (Object and Event).

  • Object: Drop down the list and select one of the report sections, or the report itself.
  • Event: Drop down the list and select from the list of events generated based on your selection in the Object drop down. If you select a report section as the Object, there are three events: Format, BeforePrint, and AfterPrint. If you select ActiveReport as the Object, there are seven events. See Section Report Events for further information.

Add script to the events in the same way that you add code to events in the code view of the report. When you select an event, the script editor generates a method stub for the event.

Using the ScriptLanguage property of the report, you can set the script language that you want to use.

Select the scripting language to use

  • In design view of the report, click in the grey area below the report to select it.
  • In the Properties window, drop down the ScriptLanguage property and select C# or VB.NET.

You can also add scripts at runtime using the Script property.

Caution: Since the RPX file can be read with any text editor, use the AddCode or AddNamedItem method to add secure information such as a connection string.

Tips for Using Script

  • Keep the section report class public: If the Section Report class is private, the script cannot recognize the items in your report. The Section Report class is public by default.
  • Set the Modifiers property of any control referenced in script to Public: If the control's Modifiers property is not set to Public, the control cannot be referenced in script and an error occurs when the report is run. The Modifiers property has a default value of Private, so you must set this property in the designer.
  • Use "this" (as in C# code-behind) or "Me" (as in VB code-behind) to reference the report. Using "rpt" to reference the report is also possible but it is recommended to use the "this" and "Me" keywords.
    Note: The basic approach of using the "this/Me" and "rpt" keywords is as follows - use "this/Me" to access the properties and controls added to the sections of the report, whereas use "rpt" within the instance of the ActiveReports class only to access its public properties, public events and public methods.
  • Use Intellisense support: The script tab supports IntelliSense that helps in inserting the language elements and provides other helpful options when adding script to a report.
  • Use Run-time error handling: When run-time errors occur, a corresponding error message is displayed in the Preview tab stating the problem.
    Note: A declared variable is not static by default. Use the static keyword to declare static variables.

Difference in script and code-behind event handler

Code-behind and the script tab require a different syntax for the event handler method definition. Use the Private modifier in code-behind and the Public modifier in the script editor.

See the following examples of the ReportStart event handler definition in Visual Basic and C#:

Script and code-behind examples in Visual Basic

The ReportStart event handler definition in the script editor:

Visual Basic.NET
Copy Code
Sub ActiveReport_ReportStart End Sub

The ReportStart event handler definition in code-behind:

Visual Basic.NET
Copy Code
Private Sub SectionReport1_ReportStart(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart End Sub

Script and code-behind examples in C#

The ReportStart event handler definition in the script editor:

CS
Copy Code
public void ActiveReport_ReportStart() { }

The ReportStart event handler definition in code-behind:

CS
Copy Code
private void SectionReport1_ReportStart(object sender, EventArgs e) { }

See Also

How To

Add Code to Layouts Using Script


Report Settings Dialog

Report Settings Dialog
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Report Settings Dialog
Show All Show All
Hide All Hide All

With ActiveReports, you can modify facets of your report, such as the page setup, printer settings, styles, and global settings at design time, as well as at run time. To make changes at design time, access the Report Settings dialog through any of the following:

  • With the report selected, go to the Visual Studio toolbar select Report menu > Settings.
  • In the Report Explorer, right-click the Settings node and select Show or double-click the Settings node.
  • Click the gray area outside the design surface to select the report and in the Commands section at the bottom of the Properties Window, click the Property dialog command.

The Report Settings dialog provides the following pages where you can set or modify various settings of your report.

Page Setup

On the Page Setup page, you can make changes to the report margins (left, right, top, and bottom), specify a gutter, and select the Mirror margins option. This page also shows a preview of how each setting appears on the report page.

  • Top margin: Set the Top margin for report pages.
  • Bottom margin: Set the Bottom margin for report pages.
  • Left margin: Set the Left margin for report pages.
  • Right margin: Set the Right margin for report pages.
  • Gutter: Set Gutter to give extra space between the edge of the page and the margins. This allows reports to be bound.
  • Mirror Margins: Select this option to set same inner and outside margins for opposite pages in the report.

By setting a gutter and selecting Mirror margins, you can easily set up reports for publishing.

Printer Settings

On the Printer Settings page, you can make changes to the printer paper size and orientation.

  • Paper Size: Select a paper size from the list of pre-defined paper sizes or choose Custom paper from the list to enable the Width and Height options for defining your own custom paper size.
  • Width: Set the width of your custom paper size.
  • Height: Set the height of your custom paper size.
  • Orientation: Select one among Default, Portrait or Landscape as your paper orientation.
  • Collate: Select whether to use collation or not.
  • Duplex: Select whether the report should be printed in Simplex, Horizontal or Vertical duplex.
  • Paper Source: Set the location of the paper source from the dropdown list.
Important: For items set to Printer Default, default printer settings are used from the printer installed on the environment where the report is being created. The paper size might also change based on the runtime environment so in case the paper size of your report is fixed, please specify it beforehand.

Styles

On the Styles page, you can change the appearance of text associated with controls, either by creating a new style sheet, or by modifying and applying an existing style.

  • New: Use this button to create a new style.
  • Delete: Use this button to delete an existing style.
  • Export styles to file: Use this button to export an existing style to an external XML *.reportstyle file.
  • Import styles from file: Use this button to import styles a *.reportstyle file.
  • Font name: Set or modify the font in your new or existing style.
  • Font size: Set or modify the font size in your new or existing style.
  • Bold: Enable or disable Bold text for your new or existing style.
  • Italic: Enable or disable Italic text in your new or existing style.
  • Underline: Enable or disable Underlined text in your new or existing style.
  • Strikethrough: Enable or disable Strikethrough text in your new or existing style.
  • BackColor: Set the Backcolor to use in your new or existing style.
  • ForeColor: Set the Forecolor to use in your new or existing style.
  • Horizontal Alignment: Set the horizontal alignment to Left, Center, Right, Justify for your new or existing style.
  • Vertical Alignment: Set the vertical alignment to Top, Middle, Bottom for your new or existing style.
  • Script: Select the script to use in your new or existing style.

Global Settings

On the Global Settings page, you can change the design layout of your report.

  • Snap Lines: Select whether to use snap lines at design time or not.
  • Snap to Grid: Select whether the control moves from one snap line to another at design time.
  • Show Grid: Select whether to show or hide the grid at design time.
  • Grid Columns: Set the count of columns in a grid.
  • Grid Rows: Set the count of rows in a grid.
  • Dimension Lines: Set whether to use dimension lines at design time or not.
  • Grid Mode: Select whether to show gridlines as Dots or Lines.
  • Show Delete Prompt: Select this option to get a warning when you try to delete a parameter or calculated field from the Report Explorer.
  • Ruler Units: Set the ruler units in Inches or Centimeters.
  • Preview Pages: Set the number of pages to display in the Preview tab. Minimum values is 1 and maximum is 10000 pages. By default, the Preview tab displays 10 pages.
    Note: This property allows you to set number of pages to display in the Preview tab only. To set the number of pages for viewer/export, you can use MaxPages property.
See Also
Designer Buttons
Report Explorer


Grouping Data in Section Reports

Grouping Data in Section Reports
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Grouping Data in Section Reports
Show All Show All
Hide All Hide All

In a section report, you can group data by adding a pair of group header and group footer sections to the report. These sections appear immediately above and below the detail section. See Add Grouping in Section Reports for further information on how to group data.

Caution: You cannot add a header section without a corresponding footer section. If you try to do so in code, the results are unstable.

You can set the properties for the GroupHeader and GroupFooter sections in their corresponding dialogs. Following is a list of properties you can set through the options in these dialogs. Each option in the GroupHeader dialog corresponds to a property in the properties window. To access the properties directly, select the section and open the properties window. See the associated property names in parenthesis with each dialog option below.

GroupHeader Dialog

To access the GroupHeader dialog, right click the group header and in the Properties window under the properties list where the commands are displayed, click the Property dialog link. See Properties Window for further information on commands.

General

  • Name (Name): Indicates the name of the GroupHeader in code. It is unique for a report.
  • Tag (Tag): Indicates the user-defined information persisted with the GroupHeader section.
  • Visible (Visible): Checkbox to specify the visibility of the GroupHeader section.
  • DataField (DataField): Field or expression on which you group the data.

Appearance

  • Background color (BackColor): Dropdown list to set the background color of the GroupHeader section.

Layout

  • Insert new page (NewPage): Dropdown list to determine whether a new page is inserted before and/or after displaying the GroupHeader section.
  • Insert new column (NewColumn): Dropdown list to determine whether a new column (in a multi-column report) appears before and/or after displaying the GroupHeader section.
  • Repeat section (RepeatStyle): Dropdown list to specify whether the GroupHeader section appears with every column or page that the Detail section or associated footer appears on.
  • Keep section and its footer on a single page (GroupKeepTogether): Dropdown list to specify whether the GroupHeader section and its footer appear as a single block on the same page or not.
  • Keep section on a single page (KeepTogether): Checkbox to specify whether the GroupHeader section appears on a single page.
  • Keep section and its footer in a single column (ColumnGroupKeepTogether): Checkbox to specify whether the GroupHeader section and its footer appear as a single block in the same column.
  • Keep section underneath the following section (UnderlayNext): Checkbox to specify whether the GroupHeader section appears in the following section or not. It allows you to show group header information inside the group details, so long as you keep the BackColor property of the Detail section set to Transparent.
  • Use column layout (ColumnLayout): Checkbox to determine whether the GroupHeader section uses the same column layout as the Detail section.
  • Can increase to accommodate contents (CanGrow): Checkbox to specify whether the height of the GroupHeader section can grow when its controls extend beyond its original height.
  • Can decrease to accommodate contents (CanShrink): Checkbox to specify whether the height of the GroupHeader section can adjust to the total height of controls placed in it.

GroupFooter Dialog

To access the GroupFooter dialog, right click the group footer and in the Properties window under the properties list where the commands are displayed, click the Property dialog link. See Properties Window for further information on commands.

General

  • Name (Name): Indicates the name of the GroupFooter in code. It is unique for a report.
  • Tag (Tag): Indicates the user-defined information persisted with the GroupFooter section.
  • Visible (Visible): Checkbox to specify the visibility of the GroupFooter section.

Appearance

  • Background color (BackColor): Dropdown list to set the background color of the GroupFooter section.

Layout

  • Insert new page (NewPage): Dropdown list to determine whether a new page is inserted before and/or after displaying the GroupFooter section.
  • Insert new column (NewColumn): Dropdown list to determine whether a new column (in a multi-column report) appears before and/or after displaying the GroupFooter section.
  • Keep section on a single page (KeepTogether): Checkbox to determine whether the GroupFooter section appears on a single page.
  • Use column layout (ColumnLayout): Checkbox to specify whether the GroupFooter section uses the same column layout as the Detail section.
  • Print at the bottom of page (PrintAtBottom): Checkbox to specify whether the GroupFooter section is printed at the bottom of the page immediately before the PageFooter section.
  • Can increase to accommodate contents (CanGrow): Checkbox to specify whether the height of the GroupFooter section can grow when its controls extend beyond its original height.
  • Can decrease to accommodate contents (CanShrink): Checkbox to specify whether the height of the GroupFooter section can adjust to the total height of controls placed in it.

When you run the report, it renders the group header, followed by all related instances of the detail section, and then the group footer. It renders a new group header section for each instance of the grouping field.

Controls in the group header render once for each instance of the group, so you can place the column header labels to describe the data in the detail fields here.

Multiple Grouping

In a section report, you can nest group header and footer pairs and group each on a different field. You can add up to 32 groupings in one report.

Note: As with any group header and footer pair, group your data on the fields that you specify in the DataField property of the group header, but in the order of your groups. For example: SELECT * FROM Customers ORDER BY GroupHeader1DataField, GroupHeader2DataField, GroupHeader3DataField

See the image below for the order in which report sections appear on the report. GroupHeader1 in the image was added first and appears above the other two group headers, while its pair GroupFooter1, appears below the other two group footers.

When you run a report with multiple groupings like the one above, the sections print in the following order:

  1. ReportHeader1 prints once and does not repeat.
  2. PageHeader1 prints once at the top of each page.
  3. GroupHeader1 prints once for the first value its DataField returns.
  4. GroupHeader2 prints once for the first value its DataField returns within the context of GroupHeader1's DataField value.
  5. GroupHeader3 prints once for the first value its DataField returns within the context of GroupHeader2's DataField value.
  6. Detail1 prints once for each record that falls within the context of GroupHeader3's DataField value.
  7. GroupFooter3 prints once at the end of the records that fall within the context of GroupHeader3's DataField value.
  8. GroupHeader3 may print again, if more values return within the context of GroupHeader2's DataField value.
  9. Each time GroupHeader3 prints again, it is followed by Detail1 (once for each related record) and GroupFooter3.
  10. GroupFooter2 prints once after GroupFooter3.
  11. GroupHeader2 may print again, if more values return within the context of GroupHeader1's DataField value.
  12. Each time GroupHeader2 prints again, it is followed by Detail1 (once for each related record) and GroupFooter2.
  13. GroupFooter1 prints once after GroupFooter2.
  14. GroupHeader1 prints once for the second value its DataField returns, followed by GroupHeader2, and so on in a pattern similar to the one above.
  15. ReportFooter1 prints once on the last page where the data displayed in the report ends.
  16. PageFooter1 prints once at the bottom of each page. Also, its position within groups varies.
    Note: At design time, although the PageFooter section is located above the ReportFooter section, at runtime it appears after the ReportFooter section on the last page.

With many groupings, you might find the need to rearrange the order of your groups. If your report has more than one group, you can right-click the report surface, and select Reorder Groups. This opens the Group Order dialog, where you can drag the groups and set them in any order you want.

Alternatively, you can also click the Reorder Groups button in the ActiveReports toolbar, to open the Group Order dialog. See Toolbar for further information.

See Also

How To

Add Grouping in Section Reports


Date, Time, and Number Formatting

Date, Time, and Number Formatting
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Date, Time, and Number Formatting

In Section Reports, you can set formatting strings for date, time, currency, and other numeric values using the OutputFormat property on the TextBox control. The OutputFormat dialog also allows you to select international currency values and select from various built-in string expressions. In addition to the built-in string expressions, you may use any .NET standard formatting strings. You can find information about these strings (Numerics and Date/Time formats) on MSDN.

Note: The ReportInfo control has many preformatted options in the FormatString property for RunDateTime and Page Numbers. For more information, see Display Page Numbers and Report Dates.
Caution:
  • The format from the OutputFormat property is applied to the value set in the DataField property of the Value property. It is not applied when a string is set in the Text property.
  • OutputFormat property settings are valid only for Double or DateTime type values. In case of a String or when no data type is set, the format is automatically applied to only those values that can be converted to Double or DateTime, otherwise no format is applied.

The OutputFormat property allows four sections delimited by a semicolon. Each section contains the format specifications for a different type of number:

  • The first section provides the format for positive numbers.
  • The second section provides the format for negative numbers.
  • The third section provides the format for Zero values.
  • The fourth section provides the format for Null or System.DBNull values.

For example: $#,#00.00; ($#,#00.00_); $0.00; #

Dates:

  • dddd, MMMM d, yyyy = Saturday, December 25, 2012
  • dd/MM/yyyy = 25/12/2012
  • d or dd = day in number format
  • ddd = day in short string format (for example, Sat for Saturday)
  • dddd = day in string format (for example, Saturday)
  • MM = month in number format
  • MMM = month in short string format (for example, Dec for December)
  • MMMM = month in string format (for example, December)
  • y or yy = year in two digit format (for example, 12 for 2012)
  • yyyy or yyyy = year in four digit format (for example, 2012)

Times:

  • hh:mm tt = 09:00 AM
  • HH:mm = 21:00 (twenty-four hour clock)
  • HH = hours in 24 hour clock
  • hh = hours in 12 hour clock
  • mm = minutes
  • ss = seconds
  • tt = AM or PM

Currency and numbers:

  • $0.00 = $6.25
  • $#,#00.00 = $06.25
  • 0 = digit or zero
  • # = digit or nothing
  • % = percent-multiplies the string expression by 100
Note: Underscore (_) keycode can be used in OutputFormat property to skip the width of the next character. This code is commonly used as _) to leave space for a closing parenthesis in a positive number format when the negative number format includes parentheses. This allows both positive and negative values to line up at the decimal point.
See Also

How To

Display Page Numbers and Report Dates


Optimizing Section Reports

Optimizing Section Reports
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > Optimizing Section Reports
Show All Show All
Hide All Hide All

Optimization can be crucial for large reports (i.e. over 100 pages). Here is some information which will help you to achieve the best possible results for such reports. To optimize ActiveReports for the web, please refer to the memory considerations section.

Memory Considerations

  • Images: Limit the use of large images when exporting to RTF and TIFF formats. Note that even one image uses a lot of memory if it's repeated on every page of a very long report exported to TIFF or RTF. If you are not exporting, or if you are exporting to Excel, PDF, or HTML, repeated images are stored only once to save memory, but the comparison necessary to detect duplicate images slows the processing time for the report.
  • SubReports: Limit the use of subreports in repeating sections because each subreport instance consumes memory. For example, consider that a subreport in the Detail section of a report in which the Detail section is repeated 2,000 times will have 2,000 instances of the subreport. Nested subreports will compound the number of instances. If you need to use subreports in repeating sections, instantiate them in the ReportStart event instead of the Format event of the repeating section so that they will be instantiated only once and use less memory.
  • CacheToDisk: Set the CacheToDisk property of the Document object to True. Although it slows down the processing time, this allows the document to be cached to disk instead of loading the whole report in memory. The PDF export also detects this setting and exports the cached report. Please note that only the PDF export is affected by the CacheToDisk property; other exports may run out of memory with very large reports. By default, CacheToDisk uses IsolatedStorage, which requires IsolatedStorageFilePermission.
    It is recommended that you use the CacheToDiskLocation property to specify the physical path instead of using isolated storage so that you do not run into the size limit.
  • Summary: Placing summaries (primarily page count and report totals) in header sections will have an adverse effect on memory as well as rendering speed with large reports using the CacheToDisk property. Since the rendering of the header is delayed until ActiveReports determines the total or page count of the following sections, CacheToDisk is unable to perform any optimization. The greater the number of affected sections, the longer rendering is delayed and the less optimization CacheToDisk will offer. Therefore, a group total in a group header section does not affect performance and memory as much as a report total in the report header.

Speed Considerations

  • Image: An image repeated on every page of a very long report is stored only once to improve memory, but the comparison necessary to detect duplicate images slows performance. This is not only the case with the report document itself, but also with the Excel, PDF, and HTML exports as they perform their own comparisons.
  • Summaries: Placing summaries (primarily page count and report totals) in header sections will slow report processing. ActiveReports must determine the total or page count of the following sections before it can render the header section. The greater the number of affected sections, the longer rendering is delayed. Therefore, a group total in a group header section does not affect performance and memory as much as a report total in the report header.
  • CacheToDisk: Be sure that the CacheToDisk property of the Document object is not set to True. Setting it to True increases the amount of time the report takes to load, and should only be used with very large reports that use a lot of memory. If this is used with smaller reports of less than 100 pages, it may actually cause more memory to be used.
  • SELECT *：Using the SELECT * statement is only recommended when you actually want to use all of the data returned by this statement. Contact your database administrator for other methods to speed up your queries.

Printing Considerations

  • Virtual Printer：We recommend use of virtual printer in case report generate environment differs from the environment in which the report is viewed or printed like in the case of Web applications.
  • Line：Please be careful as Line control has been used to draw borders within a report. An issue has been observed that spool size is increased (when comparing with Solid) during printing in case LineStyle property is set to an any value e.g. Dash or Dot etc. other than Solid that is the default value. As a result, time is taken for spooling by the report thus hindering the performance while printing. Same issue is observed when rendering a line using GDI+ in PrintDocument of .NET Framework.


CacheToDisk and Resource Storage

CacheToDisk and Resource Storage
ActiveReports 10 > ActiveReports User Guide > Concepts > Section Report Concepts > CacheToDisk and Resource Storage

The CacheToDisk property of the SectionDocument object tells ActiveReports whether to hold resources in memory, or cache them somewhere on your disk. Caching resources slows processing time, but can save you from running out of memory with very large reports.

Isolated Storage

If you use the CacheToDisk property without setting a CacheToDiskLocation, the default location in which it caches resources is IsolatedStorage, so you must have IsolatedStorageFilePermission in order to use it. The cache capacity for IsolatedStorage may depend on your configuration, but does not exceed 3 GB.

Important: Temporary files and folders created in IsolatedStorage are not deleted automatically.

Cache to Disk Location

To avoid using IsolatedStorage, you can specify a folder in the CacheToDiskLocation property. The cache capacity for a disk location is 3 GB.

For an example of the code used to turn on CacheToDisk and specify a folder, see the CacheToDiskLocation property in the Class Library documentation.

See Also
Optimizing Section Reports


Exporting

Exporting
ActiveReports 10 > ActiveReports User Guide > Concepts > Exporting

ActiveReports provides three independent ways to export a report to different formats:

  • Rendering Extensions: You can use the Render method in Rendering Extensions of the PageDocument class to render a page report and RDL Report to Image, Html, Pdf, Xml, Word and Excel formats.
  • Export Filters: You can use the Export method of the corresponding ExportFilter class to export a section report, page report and RDL Reports. Exporting in Section Report is only possible through Export Filters.

The following table illustrates the supported export formats for section, page and an RDL report.

Click the ✓ mark to see the implementation of the corresponding Export format.

Export formats |  | Section report | Page report | RDL report
HTML: Export reports to HTML or MHT formats, all of which open in a Web browser. | Rendering Extension | ✘ | ✓ | ✓
 | Export Filter | ✓ | ✓ | ✓
Pdf: Export reports to PDF, a portable document format that opens in the Adobe Reader. | Rendering Extension | ✘ | ✓ | ✓
 | Export Filter | ✓ | ✓ | ✓
Rtf: Export reports to RTF, RichText Format that opens in Microsoft Word, and is native to WordPad. |  | ✓ | ✓ | ✓
Word: Export reports to DOC, a format that opens in Microsoft Word. | Word HTML (.doc) | ✘ | ✓ | ✓
 | Office Open XML (.docx) | ✘ | ✓ | ✓
Text: Export reports to TXT, plain text format that opens in Notepad or any text editor. Export reports to CSV, comma separated values, a format that you can open in Microsoft Excel. |  | ✓ | ✓ | ✓
Image: Export reports to BMP, EMF, GIF, JPEG, TIFF, and PNG image formats |  | ✘ | ✓ | ✓
Tiff: Export reports to TIFF image format for optical archiving and faxing. |  | ✓ | ✓ | ✓
Excel | Export Filter(XLS, XLSX) | ✓ | ✓ | ✓
 | Rendering Extension - Microsoft Excel Worksheet - Layout(XLS, XLSX) | ✘ | ✓ | ✓
Xml: Export reports to XML, a format that opens in a Web browser or delivers data to other applications. |  | ✘ | ✓ | ✓

See Also

How To

Exporting Reports using Export Filters
Export Filters


Rendering Extensions

Rendering Extensions
ActiveReports 10 > ActiveReports User Guide > Concepts > Exporting > Rendering Extensions

In ActiveReports, you can use the Render method in Rendering Extensions of the PageDocument class to render in any one of the following formats. Each exporting format provides it's own set of properties to control how the report is rendered.

  • Rendering to HTML
  • Rendering to PDF
  • Rendering to Image
  • Rendering to XML
  • Rendering to Excel
  • Rendering to Word
See Also
Exporting


Rendering to HTML

Rendering to HTML
ActiveReports 10 > ActiveReports User Guide > Concepts > Exporting > Rendering Extensions > Rendering to HTML
Show All Show All
Hide All Hide All

HTML, or hypertext markup language, is a format that opens in a Web browser. You can export your reports to HTML or MHT formats. It is a good format for delivering content because virtually all users have an HTML browser. You can use the HTMLRenderingExtension to render your report in this format.

In order to render your report in HTML, add reference to the following assemblies in the project:

  • GrapeCity.ActiveReports.Export.Html.v10.dll
  • GrapeCity.ActiveReports.Extensibility.v10.dll
Note: Rendering to HTML requires the .NET Framework full profile version. To ensure you are using the full profile version, go to the Visual Studio Project menu > Properties > Compile tab > Advanced Compile Options (for Visual Basic projects) or to the Project menu > Properties > Application tab (for C# projects) and under Target framework select a full profile version.

The following steps provide an example of rendering a report in the HTML format.

  1. In Visual Studio, create a new Windows Forms Application or open an existing one.
  2. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  3. Add the following code inside the Form_Load event.
    Visual Basic.NET code. Paste INSIDE the Form Load event.
    Copy Code
    ' Provide the page report you want to render.
Dim report As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo("C:\Sample_PageReport.rdlx"))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

' Create a directory
Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyHTML")
outputDirectory.Create()

' Provide settings for your rendering output.
Dim htmlSetting As New GrapeCity.ActiveReports.Export.Html.Page.Settings()
Dim setting As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings = htmlSetting

' Set the rendering extension and render the report.
Dim htmlRenderingExtension As New GrapeCity.ActiveReports.Export.Html.Page.HtmlRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))
reportDocument.Render(htmlRenderingExtension, outputProvider, htmlSetting)
    C# code. Paste INSIDE the Form Load event.
    Copy Code
    // Provide the page report you want to render.
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(@"C:\Sample_PageReport.rdlx"));
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Create a directory
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyHTML");
outputDirectory.Create();

// Provide settings for your rendering output.
GrapeCity.ActiveReports.Export.Html.Page.Settings htmlSetting = new GrapeCity.ActiveReports.Export.Html.Page.Settings();
GrapeCity.ActiveReports.Extensibility.Rendering.ISettings setting = htmlSetting;

//Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Html.Page.HtmlRenderingExtension htmlRenderingExtension = new GrapeCity.ActiveReports.Export.Html.Page.HtmlRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));
reportDocument.Render(htmlRenderingExtension, outputProvider, htmlSetting);

HTML Rendering Properties

ActiveReports offers several options to control how reports render to HTML.

Property | Description
Fragment | Determine whether or not the full html text will be returned or just the contents contained inside the body tag will be returned. True indicates only the content inside the body tag will be return; otherwise false. The default is false.
MhtOutput | Gets or sets whether or not the output should be in Mht format. True indicates the output should be in Mht format; otherwise false. The default is false.
StyleStream | Set the StyleStream to True to create an external .css file containing style information from your report controls' style properties. If you prefer to have style information embedded in the HTML file, set the StyleStream property to False.
JavaScript | Gets or sets whether or not JavaScript will be included in the html. True indicates JaveScript will be used; otherwise false. The default is true.
LinkTarget | Specify a link target to control whether drill down reports and other links open in a new window or reuse the current window. By default, no value is set and links open in the same window. A value of _blank opens the link in a new window, or you can specify a window using window_name. By default this value is not set.
Mode | Galley mode renders the report in one HTML stream. Select Paginated mode to render each page as a section inside the HTML document.
Output TOC | Indicates whether the report's existing TOC should be added in the output.

Limitations

  • HTML is not the best format for printing. Use the PDF rendering extension instead.
  • TextIndent property and FillCharacter property of the TableOfContents control's Level setting are not supported.

Interactivity

Reports rendered in HTML support a number of interactive features. Hyperlinks, Bookmarks and Drill through links can be rendered to HTML. However, Document Maps are not available in this format. For a drill down report, make sure that the data you want to display is expanded before rendering, otherwise it renders in the hidden state.

See Also

Concepts

Exporting


Rendering to PDF

Rendering to PDF
ActiveReports 10 > ActiveReports User Guide > Concepts > Exporting > Rendering Extensions > Rendering to PDF
Show All Show All
Hide All Hide All

Portable Document Format (PDF), is a format recommended for printing and exports. You can use the PDFRenderingExtension to render your report in this format. With the PDF rendering extension, you can use features such as font linking, digital signatures and end-user defined characters (EUDC). These features are only available in the Professional Edition of ActiveReports.

In order to render your report in PDF, add reference to the following assemblies in the project:

  • GrapeCity.ActiveReports.Export.Pdf.v10.dll
  • GrapeCity.ActiveReports.Extensibility.v10.dll

The following steps provide an example of rendering a report in PDF format.

  1. In Visual Studio, create a new Windows Forms Application or open an existing one.
  2. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  3. Add the following code inside the Form_Load event.
Visual Basic.NET code. Paste INSIDE the Form Load event.
Copy Code
' Provide the page report you want to render.
Dim report As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo("C:\Sample_PageReport.rdlx"))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

' Create a output directory
Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyPDF")
outputDirectory.Create()

' Provide settings for your rendering output.
Dim pdfSetting As New GrapeCity.ActiveReports.Export.Pdf.Page.Settings()
Dim setting As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings = pdfsetting

' Set the rendering extension and render the report.
Dim pdfRenderingExtension As New GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))
reportDocument.Render(pdfRenderingExtension, outputProvider, pdfSetting)
C# code. Paste INSIDE the Form Load event.
Copy Code
// Provide the page report you want to render.
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(@"C:\Sample_PageReport.rdlx"));
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Create a output directory
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyPDF");
outputDirectory.Create();

 // Provide settings for your rendering output.
GrapeCity.ActiveReports.Export.Pdf.Page.Settings pdfSetting = new GrapeCity.ActiveReports.Export.Pdf.Page.Settings();
GrapeCity.ActiveReports.Extensibility.Rendering.ISettings setting = pdfSetting;

 //Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension pdfRenderingExtension = new GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));
reportDocument.Render(pdfRenderingExtension, outputProvider, pdfSetting);

PDF Rendering Properties

ActiveReports offers several options to control how reports render to PDF.

Property | Description
Application | Set the value that appears for application in the Document Properties dialog of the PDF viewer application.
Author | Enter the name of the author to appear in the Document Properties dialog of the PDF viewer application.
CenterWindow | Set to True to position the document's window in the center of the screen.
Columns | Set the number of columns to use in the report. This value overrides the report's original settings. The default value of -1 uses the report's original settings.
ColumnSpacing | Enter a value in inches to set the amount of space between columns. This value overrides the report's original settings.
DisplayMode | Specifies how the document is displayed when opened. FullScreen mode displays the document with no menu bar, window controls, or any other window visible.
DisplayTitle | Set to True to display text you enter in the Title property. When set to False it displays the name of the PDF file.
DpiX | Set the horizontal resolution of the rendered PDF file.
DpiY | Set the vertical resolution of the rendered PDF file.
Encrypt | Determines whether the document is encrypted or not. Note: If Encrypt is set to False, permissions and passwords have no effect.
EndPage | The last page of the report to render. The default value is the value for StartPage, that is, 0.
FallbackFonts | Gets or sets a comma-delimited string of font families to locate missing glyphs from the original font.
FitWindow | True to resize the document’s window to fit the size of the first displayed page. Default value: false.
HideMenubar | True to hide the viewer application’s menu bar when the document is active. Default value: false.
HideToolbar | True to hide the viewer application’s toolbars when the document is active. Default value: false.
HideWindowUI | True to hide user interface elements in the document’s window (such as scroll bars and navigation controls), leaving only the document’s contents displayed. Default value: false.
ImageInterpolation | Interpolation value of images. Allows to enable/disable image interpolation, when exporting the file to PDF.
Keywords | Keywords associated with the document.
MarginBottom | The bottom margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
MarginLeft | The left margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
MarginRight | The right margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
MarginTop | The top margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
OwnerPassword | The owner password that can be entered in the reader that permits full access to the document regardless of the specified user permissions.
PageHeight | The page height value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
PageWidth | The page width value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Permissions | Specifies the user permissions for the document. Permissions can be combined using a comma between values. In order to use AllowFillin, AllowAccessibleReaders, and AllowAssembly permissions, you must set the Use128Bit property to True.
PrintLayoutMode | Specifies layout mode to be used for PDF document.
SizeToFit | Determines whether PDF pages are fit to the selected paper size or not.
StartPage | The first page of the report to render. A value of 0 indicates that all pages are rendered.
Subject | The subject of the document.
Title | The title of the document.
Use128Bit | True to use 128 bit encryption with full permissions capability. False to use 40 bit encryption with limited permissions
UserPassword | The user password that can be entered in the reader. If this value is left empty, the user will not be prompted for a password, however the user will be restricted by the specified permissions.
WatermarkAngle | Specify the degree of angle for the watermark text on the PDF document. Valid values range from 0 to 359, where 0 is horizontal, left to right.
WatermarkColor | Select a color for the watermark text on the PDF document. The default value for the watermark color is gray, but you can select any Web, System, or Custom color.
WatermarkFont | Set the font to use for the watermark to any valid System.Drawing.Font.
WatermarkTitle | Enter text (i.e. CONFIDENTIAL) to use as the watermark on the PDF document.

PDF/A Support Limitations

  • The NeverEmbedFonts property is ignored, so all fonts of a report are embedded into the PDF document.
  • The Security.Encrypt property is ignored and the PDF export behaves as if this property is always set to False.
  • The OnlyForPrint property is ignored and the PDF export behaves as if this property is always set to False.
  • The DocumentToAddBeforeReport and DocumentToAddAfterReport properties of the PDF Rendering Extension settings are ignored.
  • Transparent images lose their transparency when exported to PDF/A-1.
  • External hyperlinks are exported as plain text.

Interactivity

PDF is considered as the best format for printing and it also supports interactive features like Document Map, Bookmarks and Hyperlinks. However, in case you have any data hidden (like in a drill-down report) at the time of rendering, it does not show up in the output. Therefore, it is recommended to expand all toggle items prior to rendering.

See Also

Concepts

Font Linking
Exporting


Rendering to Images

Rendering to Images
ActiveReports 10 > ActiveReports User Guide > Concepts > Exporting > Rendering Extensions > Rendering to Images
Show All Show All
Hide All Hide All

Image is the format that converts your report to an image file. You can use the ImageRenderingExtension to your render you report in this format. Make sure that you select an ImageType to any of the six different image formats available: BMP, EMF, GIF, JPEG, TIFF, and PNG.

In order to render your report as an Image, add reference to the following assemblies in the project:

  • GrapeCity.ActiveReports.Export.Image.v10.dll
  • GrapeCity.ActiveReports.Extensibility.v10.dll
Note: By default, the image rendering extension creates a separate file for each page in a report and adds an index to each corresponding file name (for example, image001.PNG, image002.PNG, etc).

To render the entire report as a single image, set the Pagination setting to False.

The following steps provide an example of rendering a report in Image format.

  1. In Visual Studio, create a new Windows Forms Application or open an existing one.
  2. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  3. Add the following code inside the Form_Load event.
Visual Basic.NET code. Paste INSIDE the Form Load event.
Copy Code
' Provide the page report you want to render.
Dim report As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo("C:\Sample_PageReport.rdlx"))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

' Create a output directory
Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyImage")
outputDirectory.Create()

' Provide settings for your rendering output.
Dim imageSetting As New GrapeCity.ActiveReports.Export.Image.Page.Settings()
Dim setting As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings = imageSetting' Set the rendering extension and render the report.
Dim imageRenderingExtension As New GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension()Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))reportDocument.Render(imageRenderingExtension, outputProvider, imageSetting)
C# code. Paste INSIDE the Form Load event.
Copy Code
// Provide the page report you want to render.
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(@"C:\Sample_PageReport.rdlx"));
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Create a output directory
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyImage");
outputDirectory.Create();

// Provide settings for your rendering output.
GrapeCity.ActiveReports.Export.Image.Page.Settings imageSetting = new GrapeCity.ActiveReports.Export.Image.Page.Settings();
GrapeCity.ActiveReports.Extensibility.Rendering.ISettings setting = imageSetting;//Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension imageRenderingExtension = new GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));reportDocument.Render(imageRenderingExtension, outputProvider, imageSetting);

Image Rendering Properties

ActiveReports offers several options to control how reports render to Image.

Property | Description
Compression | Sets or returns a value which specifies the compression to be used when exporting.
Dither | Specifies whether the image should be dithered when saving to a black and white output format, like CCITT3 or Rle. This property has no effect if the CompressionScheme property is set to Lzw or None(represents color output).
DpiX | Adjust the horizontal resolution of rendered images. The default value is 96.
DpiY | Adjust the vertical resolution of rendered images.
EndPage | The default value of 0 in this property renders all of the report pages. Otherwise, set this value to the number of the last page to render. Please note that if the StartPage property is set to 0, all of the pages of the report render. In order to use the EndPage property, you must set the StartPage property to a valid non-zero number.
ImageType | Select the type of image to which you want to render the report. Supported types are BMP, EMF, GIF, JPEG, TIFF, and PNG.
MarginBottom | Set the value in inches to use for the bottom margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
MarginLeft | Set the value in inches to use for the left margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
MarginRight | Set the value in inches to use for the right margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
MarginTop | Set the value in inches to use for the top margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
PageHeight | Set the value in inches to use for the height of the image. The format is an integer or decimal with "in" as the suffix, for example "11in" for 11 inches. The value set in this property overrides the report's settings.
PageWidth | Set the value in inches to use for the height of the image. The format is an integer or decimal with "in" as the suffix, for example "11in" for 11 inches. The value set in this property overrides the report's settings.
Pagination | By default, each page of a report is rendered as a separate image. Set this value to False to render the entire report as a single image.
PrintLayoutMode Select how to lay out the pages of the report in the image.
  • OneLogicalPageOnSinglePhysicalPage
  • TwoLogicalPagesOnSinglePhysicalPage
  • FourLogicalPagesOnSinglePhysicalPage
  • EightLogicalPagesOnSinglePhysicalPage
  • BookletMode (lays the pages out for booklet printing)
Quality | Gets or sets the quality of the report to be rendered as an image.
SizeToFit | By default, rendered report pages are not resized to fit within the selected image size. Set this value to True to resize the report pages.
Start Page | The default value of zero in this and the EndPage properties render all of the report pages to images. Otherwise, set this value to the number of the first page to render.
WatermarkAngle | Specify the degree of angle for the watermark text on the image. Valid values range from 0 to 359, where 0 is horizontal, left to right.
WatermarkColor | Select a color for the watermark text on the image. The default value for the watermark color is gray, but you can select any Web, System, or Custom color.
WatermarkFont | Set the font to use for the watermark to any valid System.Drawing.Font.
WatermarkTitle | Sets text (i.e. CONFIDENTIAL) to use as the watermark on the image.

Interactivity

Reports rendered as images do not support any of the interactive features of Data Dynamics Reports. Any data hidden at the time of export is hidden in the image. To display all data in a drill-down report, expand all toggle items prior to exporting.

See Also

Concepts

Exporting


Rendering to XML

Rendering to XML
ActiveReports 10 > ActiveReports User Guide > Concepts > Exporting > Rendering Extensions > Rendering to XML
Show All Show All
Hide All Hide All

XML is a useful format for delivering data to other applications as the resulting XML file opens in an internet browser. You can use the XmlRenderingExtension to render your report in this format. XML is a good format for delivering data to other applications. The resulting XML file opens in an internet browser

In order to render your report in XML, add reference to the following assemblies in the project:

  • GrapeCity.ActiveReports.Export.Xml.v10.dll
  • GrapeCity.ActiveReports.Extensibility.v10.dll

The following steps provide an example of rendering a report in the Xml format.

  1. In Visual Studio, create a new Windows Forms Application or open an existing one.
  2. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  3. Add the following code inside the Form_Load event.
Visual Basic.NET code. Paste INSIDE the Form Load event.
Copy Code
' Provide the page report you want to render.
Dim report As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo("C:\Sample_PageReport.rdlx"))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

' Create a output directory
Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyXml")
outputDirectory.Create()

' Provide settings for your rendering output.
Dim xmlSetting As New GrapeCity.ActiveReports.Export.Xml.Page.Settings()
Dim setting As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings = xmlSetting' Set the rendering extension and render the report.
Dim xmlRenderingExtension As New GrapeCity.ActiveReports.Export.Xml.Page.XmlRenderingExtension()Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))reportDocument.Render(xmlRenderingExtension, outputProvider, xmlSetting)
C# code. Paste INSIDE the Form Load event.
Copy Code
// Provide the page report you want to render.
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(@"C:\Sample_PageReport.rdlx"));
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Create a output directory
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyXml");
outputDirectory.Create();

// Provide settings for your rendering output.
GrapeCity.ActiveReports.Export.Xml.Page.Settings xmlSetting = new GrapeCity.ActiveReports.Export.Xml.Page.Settings();
GrapeCity.ActiveReports.Extensibility.Rendering.ISettings setting = xmlSetting;

//Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Xml.Page.XmlRenderingExtension xmlRenderingExtension = new GrapeCity.ActiveReports.Export.Xml.Page.XmlRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));
reportDocument.Render(xmlRenderingExtension, outputProvider, xmlSetting);

Xml Rendering Properties

ActiveReports offers several options to control how reports render to Xml.

Property | Description
Encoding | Select the encoding schema to use in the XML transformation.
XslStylesheet | Select the existing XSL Stylesheet file to use to transform the resulting XML file. Note: When using the XslStylesheet option, be sure to save the file in the correct file format, such as HTML.

Controlling XML Output

You can also control XML output through properties on the individual report controls. These properties are:

  • DataElementName Indicates the name to use for the data element or attribute.
  • DataElementOutput Indicates whether the report controls renders in the XML output.
  • DataElementStyle Indicates whether a text box renders as an element or an attribute.
  • DetailDataCollectionName Indicates the name to use for the collection of all instances of the detail group in the XML output.
  • DetailDataElementName Indicates the name to use for instances of the detail group in the XML output.
  • DetailDataElementOutput Indicates whether the details appear in the XML output.
  • DataInstanceElementOutput Indicates whether a list appears in the XML output. (This property is ignored if there is a grouping in the list.)
  • DataInstanceName Indicates the name to use for instances of the list in the XML output.

Interactivity

XML format does not support interactive features except that when rendering a report to XML, complete drill-down data is shown regardless of whether the data is rendered in expanded state or not.
See Also

Concepts

Exporting


Rendering to Excel

Rendering to Excel
ActiveReports 10 > ActiveReports User Guide > Concepts > Exporting > Rendering Extensions > Rendering to Excel

Microsoft Excel is one of the formats to which you can render your report using ExcelRenderingExtension. You can export excel files in two formats, i.e. Xls and Xlsx.

In order to render your report to Excel, add reference to the following assemblies in the project:

  • GrapeCity.ActiveReports.Export.Excel.v10.dll
  • GrapeCity.ActiveReports.Extensibility.v10.dll

The following steps provide an example of rendering a report in the Microsoft Excel format.

  1. In Visual Studio, create a new WindowsForms application or open an existing one.
  2. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  3. Add the following code inside the Form_Load event.
    Visual Basic.NET code. Paste INSIDE the Form Load event.
    Copy Code
    ' Provide the page report you want to render.
Dim report As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo("C:\Sample_PageReport.rdlx"))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

' Create an output directory
Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyExcel")
outputDirectory.Create()

' Provide settings for your rendering output.
Dim excelSetting As New GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionSettings()
excelSetting.FileFormat = GrapeCity.ActiveReports.Export.Excel.Page.FileFormat.Xls
Dim setting As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings = excelSetting

' Set the rendering extension and render the report.
Dim excelRenderingExtension As New GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))
reportDocument.Render(excelRenderingExtension, outputProvider, excelSetting.GetSettings())
    C# code. Paste INSIDE the Form Load event.
    Copy Code
    // Provide the page report you want to render.
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(@"C:\Sample_PageReport.rdlx"));
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Create an output directory
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyExcel");
outputDirectory.Create();

// Provide settings for your rendering output.
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionSettings excelSetting = new GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionSettings();
excelSetting.FileFormat = GrapeCity.ActiveReports.Export.Excel.Page.FileFormat.Xls;
GrapeCity.ActiveReports.Extensibility.Rendering.ISettings setting = excelSetting;

//Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtension excelRenderingExtension = new GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));
reportDocument.Render(excelRenderingExtension, outputProvider, excelSetting.GetSettings());

Excel Rendering Properties

ActiveReports offers several options to control how reports render to Microsoft Excel.

Property | Description
PageSettings | Returns an ExcelRenderingExtensionPageSettings object for initializing Excel file print setting.
Pagination | Forces pagination or galley report layout mode.
Security | Returns an ExcelRenderingExtensionSecurity object for initializing document security.
UseDefaultPalette | Indicates whether to export the document with the default Excel palette.
FileFormat | Specifies the output format of the Excel document, i.e. Xls or Xlsx.
OpenXmlStandard

Specifies the level of Open XML document conformance on exporting in Xlsx file format. You can choose between following values:

Strict

The default value.

Transitional

The Excel file generated by scheduled task execution using Strict (the default value of OpenXMLStandard) cannot be viewed on IOS devices. To change the default value of OpenXMLStandard, add following configuration settings in GrapeCity.ActiveReports.config file:
<ReportingConfiguration>
<Extensions>
<Render>
<Extension Name="Excel" Type="GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtension, GrapeCity.ActiveReports.Export.Excel.v10, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" >
<Settings>
<Property Name="OpenXmlStandard" Value="Transitional" Type="GrapeCity.ActiveReports.Export.Excel.Page.OpenXmlStandard, GrapeCity.ActiveReports.Export.Excel.v10, Culture=neutral, PublicKeyToken=cc4967777c49a3ff"/>
</Settings>
</Extension>
</Render>
</Extensions>
</ReportingConfiguration>
MultiSheet | Indicates whether to generate a single-sheet or multi-sheet Excel document.

Interactivity

Reports rendered in Excel support a number of interactive features like Bookmarks and Hyperlinks. However, in case you have any data hidden at the time of rendering (like in a drill-down report), it does not show up in the output. It is recommended that you expand all toggle items prior to rendering.

Limitations

  • BackgroundImage, overlapping controls, rounded corners (for Shape and Container) are not exported.
  • LineSpacing is not retained after export.
  • Exported FormattedText control does not preserve styles and formatting. It exports FormattedText as TextBox with plain text without any tags.
  • Barcodes are exported as an image object so scanning of barcode image may fail in some cases. It depends on printer settings and the scanner quality. Barcodes may be blurred on export and the caption may get truncated in case of physical printing.
  • Exported boolean values are displayed in uppercase in both Xls and Xlsx files.
  • TextIndent property and FillCharacter property of the TableOfContents control's Level setting are not supported.
  • Text decoration (Underline and LineThrough) gets applied to the indented area, when left padding is applied to the TableOfControl's levels.
See Also

Concepts

Exporting


Rendering to Word

Rendering to Word
ActiveReports 10 > ActiveReports User Guide > Concepts > Exporting > Rendering Extensions > Rendering to Word
Show All Show All
Hide All Hide All

The WordRenderingExtension class renders your reports to the native Microsoft Word file formats. You can export Page reports and RDL reports to the Office Open XML (OOXML) format (.Docx) or Word HTML format (.Doc) using the FileFormat property.

The .Doc format provides greater layout accuracy for Page and RDL Reports in Microsoft Word, on the other hand, .Docx format provides excellent editing experience for the exported reports.

The OOXML format (.Docx) is recommended in the following scenarios:

  • Open exported reports in a wide range of applications: Users can open and modify the exported Word document in any of the following applications.
    • Microsoft Office 2007 - 2013
    • Microsoft Office for Mac 2008 - 2011
    • iWord and Pages v4 or higher for OS X
    • Apache OpenOffice
    • Google Quickoffice for Android
    • Documents Free (Mobile Office Suite) by SavySoda for iOS
      Note: Besides the applications listed above, .Docx files exported through ActiveReports WordRenderingExtension class might work in other applications that support the .Docx format.
  • Customize reports after exporting: Positioning and arrangement of report elements in the exported document is implemented using the OOXML format which provides a natural document flow for editing the exported documents.
  • Use Word automation features: With support for automation features in the OOXML format, tasks that previously required manual adjustments in the exported Word document are now handled automatically. Report elements such as page header and footer, expressions, heading levels, and table of contents are automatically transformed to the OOXML format.
  • Set compatiblity mode: You can render a report as a Word document that is compatible with Microsoft Word 2007-2010 as well as Microsoft Word 2013 using the DocumentCompatibleVersion property.

In order to render the report in Microsoft Word (.HTML or .OOXML), add reference to the following assemblies in the project:

  • GrapeCity.ActiveReports.Export.Word.v10.dll
  • GrapeCity.ActiveReports.Extensibility.v10.dll

The following steps provide an example of rendering a report in the Word format.

  1. In Visual Studio, create a new Windows Forms Application or open an existing one.
  2. On the Form.cs or Form.vb that opens, double-click the title bar to create the Form_Load event.
  3. Add the following code inside the Form_Load event to render your report in .OOXML or .HTML file format.
Note: To export your report in .HTML format, change the FileFormat property option from .OOXML to .HTML format as depicted below.
wordSetting.FileFormat = GrapeCity.ActiveReports.Export.Word.Page.FileFormat.HTML

To export a report in .Docx file format

Visual Basic.NET code. Paste INSIDE the Form Load event.
Copy Code
' Provide the page report you want to render.
Dim report As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo("C:\Sample_PageReport.rdlx"))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

' Create an output directory
Dim outputDirectory As New System.IO.DirectoryInfo("C:\MyWord")
outputDirectory.Create()

' Provide settings for your rendering output.
Dim wordSetting As New GrapeCity.ActiveReports.Export.Word.Page.Settings()

' Set the FileFormat property to .docx
wordSetting.FileFormat = GrapeCity.ActiveReports.Export.Word.Page.FileFormat.OOXML

' Set the rendering extension and render the report.
Dim wordRenderingExtension As New GrapeCity.ActiveReports.Export.Word.Page.WordRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name))
reportDocument.Render(wordRenderingExtension, outputProvider, wordSetting)

C# code. Paste INSIDE the Form Load event.
Copy Code
// Provide the page report you want to render
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(@"C:\Sample_PageReport.rdlx"));
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Create an output directory
System.IO.DirectoryInfo outputDirectory = new System.IO.DirectoryInfo(@"C:\MyWord");
outputDirectory.Create();

// Provide settings for your rendering output
GrapeCity.ActiveReports.Export.Word.Page.Settings wordSetting = new GrapeCity.ActiveReports.Export.Word.Page.Settings();

// Set the FileFormat property to .docx
wordSetting.FileFormat = GrapeCity.ActiveReports.Export.Word.Page.FileFormat.OOXML;

//Set the rendering extension and render the report
GrapeCity.ActiveReports.Export.Word.Page.WordRenderingExtension wordRenderingExtension = new GrapeCity.ActiveReports.Export.Word.Page.WordRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(outputDirectory, System.IO.Path.GetFileNameWithoutExtension(outputDirectory.Name));
reportDocument.Render(wordRenderingExtension, outputProvider, wordSetting);

Word Rendering Extension Properties

ActiveReports offers several options to control how reports render to Microsoft Word.

Common properties (.HTML and .OOXML)

Property | Description
Author | Sets the name of the author that appears in the Author field of the Properties dialog in the rendered Word document.
FileFormat | Sets the output file format to .HTML (Doc) or .OOXML (Docx). By default the file format is set to .HTML format.
Title | Sets the title for a document that appears in the Title field of properties dialog in the rendered Word document.

.HTML format

Property | Description
BaseUrl | Sets the base URL for any relative hyperlinks that appear in the Hyperlink base field of the Properties dialog in the rendered Word document.
Generator | Sets the identity of the document generator in the rendered Word document.
PageHeight | Sets the height of the report pages in inches for the rendered Word document. The value in this property overrides the original settings in the report.
PageWidth | Sets the width of the report pages in inches for the rendered Word document. The value in this property overrides the original settings in the report.
UseMhtOutput | Indicates whether Mht output is to be used for the resultant Word document or not.

.OOXML format

Property | Description
CompanyName | Sets the name of the organization or company that appears in the Company field of Properties dialog in the rendered Word document.
DocumentCompatibilityVersion | Sets the compatibility mode of the document to the latest version (Microsoft Word 2013) or to previous versions (Microsoft Word 2007 - 2010) of Word. By default the compatibility version is set to Word2007.
DpiX | Sets the horizontal resolution of the images in the rendered Word document. By default DpiX is set to 96.
DpiY | Sets the vertical resolution of the images in the rendered Word document. By default DpiY is set to 96.
PageOrientation | Sets a value that specifies whether the document pages should be printed in portrait or landscape in the rendered Word document.
PaperSize | Sets the paper size for the page.
Password | Sets a password that must be provided to open the rendered Word document.
ReadOnlyRecommended | Sets a value that indicates whether Microsoft Office Word displays a message whenever a user opens the document, suggesting that the document is read-only.
WritePassword | Sets the write password that is required for saving changes in the rendered Word document.
TOCAutoUpdate | Automatically updates the TableOfContents control while opening the Word document. By default TOCAutoUpdate is set to False.

Limitations

.HTML format

  • Although background colors for controls export to Word documents, background colors for sections such as Body and Page Header or Footer do not.
  • KeepTogether is not supported.
  • Some FormattedText tags, for example <b>bi</b> and <s>es</s>, are not exported to Word.
  • Image alignments other than the defaults (HorizontalAlignment: Left and VerticalAlignment: Top) are not supported.
  • EMF text in the Image report item is blurred when exported to Word.

.OOXML format

Report properties

  • The LineSpacing property of a report's style sheet, StartPageNumber property of the report, PrintOnLastPage property of the PageHeader and PageFooter are not supported.
  • For Page reports, some of the NumberingStyle property (DocumentMap settings) options are not supported. The supported NumberingStyle options are Decimal, DecimalZero, LowerLetter, UpperLetter, LowerRoman, UpperRoman.
  • The BackgroundRepeat property of the BackgroundImage is not supported in Page (Page reports) and Body (RDL reports).
  • For RDL reports, Background and Border properties of Page Header or Page Footer are not supported.
  • Microsoft Word calculates the columns width by the document width. A RDL report calculates the columns width based on the body width, therefore the width of columns in an exported RDL report may differ from an original RDL report.
  • In Microsoft Word, the maximum supported page size is 22 inches (55.87 cm) wide and 22 inches (55.87 cm) high. If an exported report exceeds the maximum size, some data may be lost during export.
  • In Microsoft Word, a table can have a maximum of 63 columns. If an exported report table has more than 63 columns, then the table is split and therefore an exported document may differ from an original report.
  • A repeated Table Footer (the RepeatOnNewPage property of Table Footer) or multiple repeated headers on a single page are not supported.
  • The OverflowPlaceHolder control is not supported.
  • If the PrintOnFirstPage property of PageHeader or PageFooter is set to False, then both PageHeader and PageFooter will not be available on the first page of the exported document.

Report controls

  • The Background image is not supported in any report control except Shape.
  • The Inset option of the BorderStyle property is not supported.
  • The Map, Chart, Image, Barcode, SparkLine, Bullet, and CustomControl report controls are exported as an image. If a report control uses the BorderColor, BorderStyle or BorderWidth properties, a report is exported as a table.
  • The BorderWidth property of report controls is not exported as is and may differ from the original BorderWidth value.
  • PageBreaks are not fully supported. PageBreaks in nested tables and inside the cell's content are not supported. Only a PageBreak at the beginning of a root table cell is suported.
  • Custom line styles for the LineStyle property set through the ExpressionEditor are exported as a solid line.
  • For Shape report control, if the BorderStyle property is set to Double, it is exported as solid.
  • For BandedList data region, only the BandedList Header is repeated on each page. The BandedList Footer, GroupHeaders and GroupFooters are not supported.
  • Tablix data region is exported as a single table without horizontal split.
  • For Tablix and Table data region, the maximum supported table width in Microsoft Word is 22 inches. All columns exceeding this limit are not supported.
  • Horizontally aligned images may overlap in iWord application.
  • For Image control, Border properties and Padding properties are not supported if the Sizing property is set to Clip.
  • For Container report control, rounding corners (the RoundingRadius property) are not supported.

    FormattedText

    • FormattedText is exported as it is. The HTML and CSS features are not supported.
    • The <a> tag without a href attribute, <abbr> and <q> tags are exported as simple text.
    • The BackgroundColor, BackgroundImage, BorderColor, BorderStyle and BorderWidth properties are not supported.
    • Anchors with an href attribute are exported as hyperlinks.
    • Headers like h1, h2, etc. are exported as corresponding Microsoft Word built-in header styles.

    TableOfContents

    • The TextAlign, DisplayPageNumber, TextIndent, Overline TextDecoration and DisplayPageNumber properties are not supported.
    • The Source property of the Document Map settings is not fully supported. Only the Headings Only option of the Source property is supported.
    • If a report uses more than one TableOfContents controls, the properties of the first TableOfContents are applied to the other TableOfContents controls in the exported document.
    • The FillCharacter property is exported as dots.

    TextBox/CheckBox

    • If the Format property is set to Numeric or Date, the exported TextBox has a right alignment. Other Format values are exported with the left alignment.
    • The Transparent color for text is exported as white.
    • The Underline for numbered lists, Right-To-Left (RTL) option of the Direction, Angle, ShrinkToFit and Overline TextDecoration properties are not supported.
    • The action Jump to report is not supported.
    • The tb-rl (vertical text) option of the WritingMode property is not supported. TextBoxes with the WritingMode property set to tb-rl are exported as lr-tb.
    • The NoWrap option of the WrapMode property is exported as WordWrap.
    • The LineSpacing property of an exported document will differ from the original report. This is because in Microsoft Word, the line spacing is calculated by the font size value of a report control plus the line spacing value of a report control.
    • For CheckBox control, the CheckAlignment property is exported as MiddleRight for TopRight, MiddleRight, and BottomRight options. Other CheckAlignment options are exported as MiddleLeft.
    • Paddings exceeding 31 inches is exported as border spaces.

Interactivity

.HTML format

Reports rendered in a Word format supports both Bookmarks and Hyperlinks. However, if visibility toggling (like in a drill-down report) is essential to your report, it is recommended to use the HTML rendering extension. If a Document map is essential to your report, it is recommended to use the PDF rendering extension.

.OOXML format

  • Hyperlinks - Hyperlinks on TextBox and Image controls are rendered as hyperlinks in the Microsoft Word.
  • Bookmarks - Bookmarks in the report are rendered as Microsoft Word bookmarks. Bookmark links are rendered as hyperlinks that link to the bookmark labels within the document.
  • TOC AutoUpdate - TableofContents control in the report is rendered as Microsoft Word table of contents.
See Also

Concepts

Exporting


Export Filters

Export Filters
ActiveReports 10 > ActiveReports User Guide > Concepts > Exporting > Export Filters

ActiveReports provides custom components for exporting reports into six formats. Each export format has special features, however, not all formats support all of the features that you can use in your reports. Here are the unique usage possibilities of each format, along with any limitations inherent in each.

  • HTML Export
  • PDF Export
  • Text Export
  • RTF Export
  • Excel Export
  • TIFF Export

See Exporting Reports using Export Filters for exporting Page Report, RDL Report or Section Report using the export filters.

See Also

Concepts

Exporting


HTML Export

HTML Export
ActiveReports 10 > ActiveReports User Guide > Concepts > Exporting > Export Filters > HTML Export
Show All Show All
Hide All Hide All

HTML, or hypertext markup language, is a format that opens in a Web browser. The HTML export filter has a number of useful properties that allow you to control your output. You can set the properties either in code using the HTMLExport object after adding reference to the following assembly in your project, or by selecting the object in the toolbox and adding it to the component tray below the Form which automatically adds this assembly to the project:

GrapeCity.ActiveReports.Export.Html.v10.dll

Note: HTML Export requires the .NET Framework full profile version. To ensure you are using the full profile version, go to the Visual Studio Project menu > Properties > Compile tab > Advanced Compile Options (for Visual Basic projects) or to the Project menu > Properties > Application tab (for C# projects) and under Target framework select a full profile version.

HTML Export Properties

Property | Valid Values | Description
BookmarkStyle | Html (default) or None | Set to Html to generate a page of bookmarks from the bookmarks in the report. If the report has no bookmarks, this setting is ignored.
CharacterSet | Big5, EucJp, HzGb2312, Ibm850, Iso2022Jp, Iso2022Kr, Iso8859_1, Iso8859_2, Iso8859_5, Iso8859_6, Koi8r, Ksc5601, ShiftJis, UnicodeUtf16, UnicodeUtf8 (default) | Select the IANA character set that you want to use in the meta tag in the header section of the HTML output. This property only takes effect if the IncludeHtmlHeader property is set to True.
CreateFramesetPage | True or False (default) | Set to True to generate a set of frames that display a page of bookmarks (if available) in the left frame and the report document in the right frame. The HTML output uses the specified filename with the extension .frame.html.
IncludeHtmlHeader | True (default) or False | Set to False if you want to embed the HTML output in another HTML document. Otherwise, the HTML output includes the usual HTML, HEAD, and BODY elements.
IncludePageMargins | True or False (default) | Set to True to include the report's margins in the HTML output.
MultiPage | True or False (default) | Set to True to create a separate HTML page for each page of the report. Otherwise, the HTML output is a single page.
OutputType | DynamicHtml (default) or LegacyHtml | Set to LegacyHtml to use tables for positioning and avoid the use of cascading style sheets (CSS). Otherwise, positioning of controls is handled in the CSS.
RemoveVerticalSpace | True or False (default) | Set to True if the OutputType property is set to LegacyHtml and you plan to print the output from a browser. This removes white space from the report to help improve pagination. Otherwise, vertical white space is kept intact.
Title | Any String | Enter the text to use in the header section's title. This is displayed in the title bar of the browser.

More information on output types

By default, the report is exported as DynamicHtml (DHTML), with cascading style sheets (CSS). Using the OutputType property, you can change the output to LegacyHtml (HTML). Neither of the output types creates a report that looks exactly like the one you display in the viewer because of differences in formats. Following is the usage of each output type and controls to avoid in each.

DynamicHtml (DHTML)

Usage:

  • Create Web reports with Cascading Style Sheets (CSS)
  • Open in Web browsers

Does not support:

  • Diagonal line control
  • Control borders

LegacyHtml (HTML)

Usage:

  • Create archival reports
  • Open in Web browsers

Does not support:

  • Line control
  • Control borders
  • CrossSectionLine controls
  • Overlapping controls
See Also
Exporting Reports using Export Filters
Exporting


PDF Export

PDF Export
ActiveReports 10 > ActiveReports User Guide > Concepts > Exporting > Export Filters > PDF Export
Show All Show All
Hide All Hide All

PDF, or portable document format, opens in the Adobe Reader. The PDF export filter has a number of useful properties that allow you to control your output. You can set the properties either in code using the PDFExport object after adding reference to the following assembly in your project, or by selecting the object in the toolbox and adding it to the component tray below the Form which automatically adds this assembly to the project:

GrapeCity.ActiveReports.Export.Pdf.v10.dll

With the PDF export filter, you can use the feature Font Linking.

Note: These features are only available in the Professional Edition of ActiveReports.

PDF Export Properties

Property | Valid Values | Description
ConvertMetaToPng | True or False (default) | Set to True to change any Windows metafile images to PNG format to keep the file size down. If the report has no metafiles, this setting is ignored.
ExportBookmarks | True (default) or False | Set to True to generate bookmarks from the bookmarks in the report. If the report has no bookmarks, this setting is ignored. To control how the exported bookmarks are displayed, use Options.DisplayMode detailed below.
FontFallback | String of font families | Set a comma-delimited string of font families to be used to lookup glyphs missing in the original font.
ImageQuality | Lowest, Medium (default), or Highest | Set to Highest in combination with a high value in the ImageResolution property to yield the best printing results when converting Windows metafiles (.wmf and .emf). Set to Lowest to keep the file size down. If the report has no metafiles, this setting is ignored.
ImageResolution | 75 - 2400 dpi | Set to 75 dpi to save space, 150 dpi for normal screen viewing, and 300 dpi or higher for print quality. Use this property in combination with ImageQuality (highest) to yield the best results when the report contains metafiles or the Page.DrawPicture API is used. Neither property has any effect on other image types.
NeverEmbedFonts | A semicolon-delimited string of font names | List all of the fonts that you do not want to embed in the PDF file to keep the file size down. This can make a big difference if you use a lot of fonts in your reports.
Options | See below | Expand this property to see a group of sub properties. These settings control how the Adobe Reader displays the output PDF file when it is first opened. See the table below for details.
Security | See below | Expand this property to see a group of sub properties. These settings control encryption and permissions on the output PDF file. See the table below for details.
Signature | A valid PdfSignature object | This must be set up in code. For more information, see Digital Signature .
Version | Pdf11, Pdf12, Pdf13, Pdf14, Pdf15, Pdf16, Pdf17, PdfA1a, PdfA1b, PdfA2a, PdfA2b, or PdfA2u | Sets the version of the PDF format the exported document is saved in.

PDF (Portable Document Format)

Usage:

  • Create printable reports whose formats do not change from machine to machine.
  • Open in Adobe Reader.

Does not support:

  • Dash and dot border patterns appear to look longer in the PDF output than in the ActiveReports Window Forms Viewer.
  • Multiple lines of vertical text is not supported in Page and RDL reports.
  • Transparent background-color in charts are not supported.

PDF/A Support Limitations

  • The NeverEmbedFonts property is ignored, so all fonts of a report are embedded into the PDF document.
  • The Security.Encrypt property is ignored and the PDF export behaves as if this property is always set to False.
  • The OnlyForPrint property is ignored and the PDF export behaves as if this property is always set to False.
  • Transparent images lose their transparency when exported to PDF/A-1.
  • External hyperlinks are exported as plain text.

Options and Security

When you expand the Options or Security properties in the Properties window, the following sub properties are revealed.

PDF Options Properties

Property | Valid Values | Description
Application | String | Set to the string value that you want to display in the Adobe Document Properties dialog, Description tab, Application field.
Author | String | Set to the string value that you want to display in the Adobe Document Properties dialog, Description tab, Author field.
CenterWindow | True or False (default) | Set to True to position the Adobe Reader window in the center of the screen when the document is first opened.
DisplayMode None (default), Outlines, Thumbs, or FullScreen

Select how to display bookmarks when the document is first opened.

  • None (default) bookmarks are not displayed until opened by the user.
  • Outlines shows bookmarks in outline format.
  • Thumbs shows bookmarks as thumbnails.
  • FullScreen shows the document in full screen, and bookmarks are not displayed.
DisplayTitle | True or False (default) | Set to True to use the Title string entered in the Title property below. Otherwise, the file name is used.
FitWindow | True or False (default) | Set to True to expand the window to fit the size of the first displayed page.
HideMenubar | True or False (default) | Set to True to hide the menu in the Adobe Reader when the document is first opened.
HideToolbar | True or False (default) | Set to True to hide the toolbars in the Adobe Reader when the document is first opened.
HideWindowUI | True or False (default) | Set to True to hide the scrollbars and navigation controls in the Adobe Reader when the document is first opened, displaying only the document.
Keywords | String | Enter keywords to display in the Adobe Document Properties dialog, Description tab, Keywords field.
OnlyForPrint | True or False (default) | Set to indicate whether the PDF is only for print.
Subject | String | Enter a subject to display in the Adobe Document Properties dialog, Description tab, Subject field.
Title String

Enter a title to display in the Adobe Document Properties dialog, Description tab, Title field.

Set DisplayTitle to True to display this text in the title bar of the Adobe Reader when the document is opened.

PDF Security Properties

Property | Valid Values | Description
Encrypt | True or False (default) | Sets or returns a value indicating whether the document is encrypted.
OwnerPassword | String | Enter the string to use as a password that unlocks the document regardless of specified permissions.
Permissions | None, AllowPrint, AllowModifyContents, AllowCopy, AllowModifyAnnotations, AllowFillIn, AllowAccessibleReaders, or AllowAssembly | Combine multiple values by dropping down the selector and selecting the check boxes of any permissions you want to grant. By default, all of the permissions are granted.
Use128Bit | True (default) or False | Set to False to use 40 bit encryption with limited permissions. (Disables AllowFillIn, AllowAccessibleReaders, and AllowAssembly permissions.)
UserPassword | String | Enter the string to use as a password that unlocks the document using the specified permissions. Leave this value blank to allow anyone to open the document using the specified permissions.
See Also
Exporting Reports using Export Filters
Exporting


Text Export

Text Export
ActiveReports 10 > ActiveReports User Guide > Concepts > Exporting > Export Filters > Text Export
Show All Show All
Hide All Hide All

Plain Text is a format that opens in Notepad or Microsoft Excel depending on the file extension you use in the filePath parameter of the Export method. Use the extension .txt to open files in Notepad, or use .csv to open comma separated value files in Excel. The Text export filter has a number of useful properties that allow you to control your output. You can set the properties either in code using the TextExport object after adding reference to the following assembly in your project, or by selecting the object in the toolbox and adding it to the component tray below the Form which automatically adds this assembly to the project:

  • GrapeCity.ActiveReports.Export.Xml.v10.dll

Text Export Properties

Property | Valid Values | Description
Encoding | System.Text.ASCIIEncoding (default), System.Text.UnicodeEncoding, System.Text.UTF7Encoding, or System.Text.UTF8Encoding | This property can only be set in code. Enter an enumerated system encoding value to use for character encoding.
PageDelimiter | String | Enter a character or sequence of characters to mark the end of each page.
SuppressEmptyLines | True (default) or False | Set to False if you want to keep empty lines in the exported text file. Otherwise, white space is removed.
TextDelimiter | String | Enter a character or sequence of characters to mark the end of each text field. This is mainly for use with CSV files that you open in Excel.

Text

Usage:

  • Create plain text files
  • Create comma (or other character) delimited text files
  • Feed raw data to spreadsheets or databases
  • Open in Notepad or Excel (comma delimited)

Does not support anything but plain fields and labels:

  • Supports plain text only with no formatting other than simple delimiters
  • Supports encoding for foreign language support
See Also
Exporting Reports using Export Filters
Exporting


RTF Export

RTF Export
ActiveReports 10 > ActiveReports User Guide > Concepts > Exporting > Export Filters > RTF Export

RTF, or RichText format, opens in Microsoft Word, and is native to WordPad. This export does not render reports exactly as they appear in the Viewer due to inherent differences in the formats.

You can set the property either in code using the RTFExport object after adding reference to the following assembly in your project, or by selecting the object in the toolbox and adding it to the component tray below the Form which automatically adds this assembly to the project:

  • GrapeCity.ActiveReports.Export.Word.v10.dll

Usage:

  • Create word-processing files
  • Open in Word or WordPad

Does not support:

  • Section or Page back colors
  • Angled text
See Also
Exporting Reports using Export Filters
Exporting


Excel Export

Excel Export
ActiveReports 10 > ActiveReports User Guide > Concepts > Exporting > Export Filters > Excel Export
Show All Show All
Hide All Hide All

XLSX is a format that opens in Microsoft Excel as a spreadsheet. This export does not render reports exactly as they appear in the Viewer due to inherent differences in the formats. The XLSX export filter has a number of useful properties that allow you to control your output. You can set the properties either in code using the XLSExport object after adding reference to the following assembly in your project, or by selecting the object in the toolbox and adding it to the component tray below the Form which automatically adds this assembly to the project:

  • GrapeCity.ActiveReports.Export.Excel.v10.dll

Excel Export Properties

Property | Valid Values | Description
AutoRowHeight | True or False (default) | Set to True to have Excel set the height of rows based on the contents. Otherwise XlsExport calculates the height of rows. In some cases this may make the output look better inside Excel. However, a value of True may adversely affect pagination when printing, as it may stretch the height of the page.
DisplayGridLines | True (default) or False | Set to False to hide grid lines in Excel.
FileFormat | Xls97Plus (default) or Xls95 or Xlsx | Set to Xls95 to use Microsoft Excel 95, Xls95Plus to use Microsoft Excel 97and Xlsx to use Microsoft Excel 2007 or newer.
MinColumnWidth | Single (VB) or float (C#) | Set the number of inches that is the smallest width for a column in the exported spreadsheet. Tip: Larger values reduce the number of empty columns in a sheet. Set this value to 1 inch or more to get rid of small empty columns.
MinRowHeight | Single (VB) or float (C#) | Set the number of inches that is the smallest height for a row in the exported spreadsheet. Tip: Larger values force the export to place more controls on a single line by reducing the number of rows added to match blank space. Set this value to .25 inches or more to get rid of small empty rows.
MultiSheet | True or False (default) | Set to True to export each page of your report to a separate sheet within the Excel file. This can increase performance and output quality at the cost of memory consumption for reports with complex pages and a lot of deviation between page layouts. In general, use False for reports with more than 30 pages.
PageSettings |  | Set a print orientation and paper size of Excel sheet.
RemoveVerticalSpace | True or False (default) | Set to True to remove vertical empty spaces from the spreadsheet. This may improve pagination for printing.
Security |  | Set a password and username to protect the excel spreadsheet.
UseCellMerging | True or False (default) | Set to True to merge cells where applicable.
UseDefaultPalette | True or False (default) | Set to True to export document with Excel default palette.

Usage:

  • Create spreadsheets
  • Open in Microsoft Excel

Does not support:

  • Line control
  • Shapes (other than filled rectangles)
  • CrossSectionBox and CrossSectionLine controls
  • Overlapping controls
  • Borders on controls with angled text
  • Angled text
  • CheckBox control (only its text element is exported)
See Also
Exporting Reports using Export Filters
Exporting


TIFF Export

TIFF Export
ActiveReports 10 > ActiveReports User Guide > Concepts > Exporting > Export Filters > TIFF Export
Show All Show All
Hide All Hide All

TIFF, or tagged image file format, opens in the Windows Picture and Fax Viewer or any TIFF viewer. This export looks very much like the report as it displays in the viewer, but it is a multi-page image, so the text cannot be edited. The TIFF export filter has a couple of useful properties that allow you to control your output. You can set the properties either in code using the TIFFExport object after adding reference to the following assembly in your project, or by selecting the object in the toolbox and adding it to the component tray below the Form which automatically adds this assembly to the project:

  • GrapeCity.ActiveReports.Export.Image.v10.dll

TIFF Export Properties

Property | Valid Values | Description
CompressionScheme None, Rle, Ccitt3 (default), Ccitt4 or Lzw

Select an enumerated value to use for color output control:

  • None delivers color output with no compression.
  • Rle (run-length encoding) is for 1, 4, and 8 bit color depths.
  • Ccitt3 and Ccitt4 are for 1 color depth, and are used in old standard faxes.
  • Lzw (based on Unisys patent) is for 1, 4, and 8 bit color depths with lossless compression.
Dither | True or False (default) | Set to True to dither the image when you save it to a black and white format (Ccitt3, Ccitt4 or Rle). This property has no effect if the CompressionScheme is set to Lzw or None.
DpiX Integer (VB) or int (C#) greater than 0

Set the horizontal resolution of a report when exporting to TIFF format. The default value is 200.

Setting the DpiX or DpiY property to large values can cause the rendered image to be too large and not enough memory in system can be allocated to the bitmap.
DpiY Integer (VB) or int (C#) greater than 0

Set the vertical resolution of a report when exporting to TIFF format. The default value is 196.

Setting the DpiX or DpiY property to large values can cause the rendered image to be too large and not enough memory in system can be allocated to the bitmap.

Usage:

  • Create optical archive reports
  • Send reports via fax machines
  • Open in image viewers
  • Generates an image of each page. 100% WYSIWYG.
See Also
Exporting Reports using Export Filters
Exporting


Exporting Reports using Export Filters

Exporting Reports using Export Filters
ActiveReports 10 > ActiveReports User Guide > Concepts > Exporting > Export Filters > Exporting Reports using Export Filters
Show All Show All
Hide All Hide All

ActiveReports provides various export filters that can be used to export Page, Section and Rdl Reports to the supported file formats. Here are the export formats that are included with ActiveReports:

  • HTML For displaying on Web browsers or e-mail. You can access the HTML Export filter by adding the reference to GrapeCity.ActiveReports.Export.Html.v10.dll in your project.
  • PDF For preserving formatting on different computers. You can access the PDF Export filter by adding the reference to GrapeCity.ActiveReports.Export.Pdf.v10.dll in your project.
  • RTF For preserving some formatting, but allowing reports to be opened with Word or WordPad. You can access the RTF Export filter by adding the reference to GrapeCity.ActiveReports.Export.Word.v10.dll in your project.
  • Text For transmitting raw data, with little or no formatting. You can access the Text Export filter by adding the reference to GrapeCity.ActiveReports.Export.Xml.v10.dll in your project.
  • TIFF For transmitting faxes. You can access the Image Export filter by adding the reference to GrapeCity.ActiveReports.Export.Image.v10.dll in your project.
  • Excel For displaying as spreadsheets. You can access the Excel Export filter by adding the reference to GrapeCity.ActiveReports.Export.Excel.v10.dll in your project.
Note: HTML Export requires the .NET Framework full profile version. To ensure you are using the full profile version, go to the Visual Studio Project menu > Properties > Compile tab > Advanced Compile Options (for Visual Basic projects) or to the Project menu > Properties > Application tab (for C# projects) and under Target framework select a full profile version.
Note: In ActiveReports, by default, the assemblies are located in the ...\Common Files\GrapeCity\ActiveReports 10 folder.

Use the following steps to export reports through export filters. These steps assume that you have already created a Windows Application and added the export controls to your Visual Studio toolbox. For more information, see Adding ActiveReports Controls.

To export a report

  1. In your project's Bin>Debug folder, place the report.rpx (Section Report) or report.rdlx (Page/Rdl Report).
  2. In the Solution Explorer, right-click the References node and select Add Reference.
  3. In the Reference Manager dialog that appears, select the following references and click OK to add them to your project.
    GrapeCity.ActiveReports.Export.Excel.v10
    GrapeCity.ActiveReports.Export.Html.v10
    GrapeCity.ActiveReports.Export.Image.v10
    GrapeCity.ActiveReports.Export.Pdf.v10
    GrapeCity.ActiveReports.Export.Word.v10
    GrapeCity.ActiveReports.Export.Xml.v10
  4. On the Form.cs or Form.vb, double-click the title bar to create the Form_Load event.
  5. In Form_Load event, add the following code to add a report to your project.

    To add Page/Rdl report to your project

    Visual Basic.NET code. Paste INSIDE the Form_Load event.
    Copy Code
    ' Create a page/Rdl report.
Dim rpt As New GrapeCity.ActiveReports.PageReport()
' Load the report you want to export.
' For the code to work, this report must be stored in the bin\debug folder of your project.
rpt.Load(New System.IO.FileInfo ("report.rdlx"))
Dim MyDocument As New GrapeCity.ActiveReports.Document.PageDocument (rpt)
    C# code. Paste INSIDE the Form_Load event.
    Copy Code
    // Create a page/Rdl report.
GrapeCity.ActiveReports.PageReport rpt = new GrapeCity.ActiveReports.PageReport();
// Load the report you want to export.
// For the code to work, this report must be stored in the bin\debug folder of your project.
rpt.Load(new System.IO.FileInfo ("report.rdlx"));
GrapeCity.ActiveReports.Document.PageDocument MyDocument = new GrapeCity.ActiveReports.Document.PageDocument (rpt);

    To add Section report to your project

    Visual Basic.NETcode. Paste INSIDE the Form_Load event.
    Copy Code
    ' Create a Section report.
    Dim rpt As New GrapeCity.ActiveReports.SectionReport()
    ' For the code to work, report.rpx must be placed in the bin\debug folder of your project.
    Dim xtr As New System.Xml.XmlTextReader(Application.StartupPath + "\report.rpx")
    rpt.LoadLayout(xtr)
    rpt.Run()
    C# code. Paste INSIDE the Form_Load event.
    Copy Code
    // Create a Section report.
    GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
// For the code to work, report.rpx must be placed in the bin\debug folder of your project.
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(Application.StartupPath + "\\report.rpx");
rpt.LoadLayout(xtr);
rpt.Run();
  6. Add the following code to export Page, Rdl and Section Reports to multiple format.
    This code is common for all the report types (.rpx and .rdlx).

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form_Load event.
    Copy Code
    ' Export the report in HTML format.
Dim HtmlExport1 As New GrapeCity.ActiveReports.Export.Html.Section.HtmlExport()
HtmlExport1.Export(MyDocument, Application.StartupPath + "\HTMLExpt.html")

' Export the report in PDF format.
Dim PdfExport1 As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport()
PdfExport1.Export(MyDocument, Application.StartupPath + "\PDFExpt.pdf")

' Export the report in RTF format.
Dim RtfExport1 As New GrapeCity.ActiveReports.Export.Word.Section.RtfExport()
RtfExport1.Export(MyDocument, Application.StartupPath + "\RTFExpt.rtf")

' Export the report in text format.
Dim TextExport1 As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport()
TextExport1.Export(MyDocument, Application.StartupPath + "\TextExpt.txt")

' Export the report in TIFF format.
Dim TiffExport1 As New GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport()
TiffExport1.Export(MyDocument, Application.StartupPath + "\TIFFExpt.tiff")

' Export the report in Excel format.
Dim XlsExport1 As New GrapeCity.ActiveReports.Export.Excel.Section.XlsExport()
' Set a file format of the exported excel file to Xlsx to support Microsoft Excel 2007 and newer versions.
XlsExport1.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xlsx
XlsExport1.Export(MyDocument, Application.StartupPath + "\XLSExpt.xlsx")

    To write the code in C#

    C# code. Paste INSIDE the Form_Load event.
    Copy Code
    // Export the report in HTML format.
GrapeCity.ActiveReports.Export.Html.Section.HtmlExport HtmlExport1 = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
HtmlExport1.Export(MyDocument, Application.StartupPath + "\\HTMLExpt.html");

// Export the report in PDF format.
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport PdfExport1 = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
PdfExport1.Export(MyDocument, Application.StartupPath + "\\PDFExpt.pdf");

// Export the report in RTF format.
GrapeCity.ActiveReports.Export.Word.Section.RtfExport RtfExport1 = new GrapeCity.ActiveReports.Export.Word.Section.RtfExport();
RtfExport1.Export(MyDocument, Application.StartupPath + "\\RTFExpt.rtf");

// Export the report in text format.
GrapeCity.ActiveReports.Export.Xml.Section.TextExport TextExport1 = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport();
TextExport1.Export(MyDocument, Application.StartupPath + "\\TextExpt.txt");

// Export the report in TIFF format.
GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport TiffExport1 = new GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport();
TiffExport1.Export(MyDocument, Application.StartupPath + "\\TIFFExpt.tiff");

// Export the report in XLSX format.
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport XlsExport1 = new GrapeCity.ActiveReports.Export.Excel.Section.XlsExport();
// Set a file format of the exported excel file to Xlsx to support Microsoft Excel 2007 and newer versions.
XlsExport1.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xlsx;
XlsExport1.Export(MyDocument, Application.StartupPath + "\\XLSExpt.xlsx");
    Note: When exporting a report to .MHT file by Export filters use htmlExport.Export(Document doc, Stream outputStream);
    For more information, see HTML Export Method.
  7. Press F5 to run the application. The exported files are saved in the bin\debug folder.
See Also
Export Filters

Concepts

Exporting


Font Linking

Font Linking
ActiveReports 10 > ActiveReports User Guide > Concepts > Exporting > Font Linking

Font linking helps resolve the situation when fonts on a deployment machine do not have the glyphs that are used in a development environment. When you find such a glyph mismatch, there is a possibility that the PDF output on development and deployment machines may be different.

In order to resolve this issue, the PDF export filter or the PDF rendering extension looks for the missing glyphs in the installed fonts as follows:
  • Checks the system font link settings for each font that is used in the report. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontLink\SystemLink registry key stores the information on font links.
  • If font links are not set or the needed glyphs are not found, searches for the glyphs in the fonts declared in the FontFallback Property.
  • Uses glyphs from the font links collection to replace fonts that do not have their own declared linked fonts.
  • If necessary glyphs are not found by font links or in the fonts declared in the FontFallback property, glyphs from Microsoft Sans Serif font are taken as the predefined font.
Note: Font Linking is only possible in the Professional Edition of ActiveReports.
See Also
PDF Export


Custom Font Factory (Pro Edition)

Custom Font Factory (Pro Edition)
ActiveReports 10 > ActiveReports User Guide > Concepts > Exporting > Custom Font Factory (Pro Edition)
Show All Show All
Hide All Hide All

When you use the PDF export filter in a Medium trust environment, ActiveReports does not have access to the System Fonts folder due to security restrictions. So if your reports use special glyphs or non-ASCII characters that are only found in certain fonts, the PDF output may be incorrect on some machines.

The ActiveReports custom font factory allows you to embed any fonts you need in PDF in the Medium trust environment. To deploy the necessary fonts with your Medium trust solution, you must add the used font files in the specific folder and set up your web.config file.

ActiveReports looks for the custom fonts in the order as follows:

  1. A font specified in the control.
  2. A mapped specified font in the Substitute setting.
  3. A font specified in the the AddFontLink setting (Pro Edition only).
  4. A font specified in the SetFallbackFont setting (Pro Edition only).

Notice that you need to copy the required font files (.ttc, .ttf) manually into the font folder you are accessing.

Custom Font Factory in Windows Azure

For your Azure project, you need to set the properties for all fonts in the project Fonts folder as follows:

  1. Set Copy to Output Directory to Copy always.
  2. Set BuildAction to Content.

To add a font factory section group

XML code. Paste INSIDE the configSections tags of the web.config file.
Copy Code
<sectionGroup name="ActiveReports.PdfExport">    <section name="FontFactory"           type="GrapeCity.ActiveReports.Web.FontFactorySectionHandler,           GrapeCity.ActiveReports.Web.v7,           Version=7.99.10395.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff"           requirePermission="false" /></sectionGroup>

To create a font factory

Required fonts or the folder containing the required fonts are set in the font factory. Paste code like the following after the configSections tag, but before the appSettings tag.

Note: Please make the required changes for the font that you wish to use. In case of the following sample code, create a Font folder and copy the required font files (arial.ttf, tahoma.ttf, msgothic.ttc, simsun.ttc, gulim.ttc, mingliu.ttc, micross.ttf).
XML code. Paste between configSections and appSettings tags of the web.config file.
Copy Code
<ActiveReports.PdfExport>
    <FontFactory Mode="File">
        <AddFolder VirtualPath="~/Fonts" Recurse="true"/>
        <Substitute Font="Helv" To="Helvetica"/>
        <SetFallbackFont Font="Arial"/>
        <!-- font link nodes -->
        <AddFontLink Font="Arial" List="SimSun,gulim,PMingLiU"/>
        <AddFontLink Font="Tahoma" List="MS UI Gothic,SimSun,gulim,PMingLiU"/>
        <AddFontLink Font="MS UI Gothic" List="SimSun,gulim,PMingLiU,Microsoft Sans Serif" IsDefault="true"/>
    </FontFactory>
</ActiveReports.PdfExport>
Note: For the Azure worker role project, use an absolute path instead of a virtual path in the code above: <AddFolder Path="~/Fonts" Recurse="true"/>.
Copy Code

Configuration settings

FontFactory

Description: This is the main font factory node to which you can add fonts.

Attributes

Element | Description
Mode | Setting the Mode attribute to File allows to use a file based factory, or remove the attribute for a Windows GDI factory.

Child Elements

None.

Parent Elements

Element | Description
ActiveReports.PdfExport | The assembly that contains the PdfExport namespace (PDF export, document options, and security classes).

Example

<FontFactory Mode="File">

AddFolder

Description: Adds all TrueType fonts (.ttc, .ttf) from the specified folder.

Attributes

Element | Description
Path | Specifies the absolute path to the folder.
VirtualPath | Specifies the relative path to the folder.
Recurse | When set to True, it can read the subfolder. When set to False, it cannot read the subfolder.

Child Elements

None.

Parent Elements

Element | Description
FontFactory | This is the main font factory node to which you can add fonts.

Example

<AddFolder VirtualPath="~/Fonts" Recurse="true"/>

Substitute

Description: Maps an alternate name of fonts to their official names.

Attributes

Element | Description
Font | Specifies the abbreviated font name (e.g. "Helv").
To | Specifies the official font name (e.g. "Helvetica").

Child Elements

None.

Parent Elements

Element | Description
FontFactory | This is the main font factory node to which you can add fonts.

Example

 <Substitute Font="Helv" To="Helvetica"/>

SetFallbackFont (Professional Edition only)

Description: In the Professional Edition, sets the font to use if a) the specified font is not installed, b) the Substitute font is not specified or not installed, or c) the font links are not set or the needed glyphs are not found in the AddFontLink setting.

Attributes

Element | Description
Font | Specifies the font name.

Child Elements

None.

Parent Elements

Element | Description
FontFactory | This is the main font factory node to which you can add fonts.

Example

 <SetFallbackFont Font="Arial"/>

AddFontLink (Professional Edition only)

Description: In the Professional Edition, there is the extra support for CJK glyphs. You can add font links that allow the PdfExport to look up any glyphs missing from the specified font in the list of other fonts to check.

Attributes

Element | Description
Font

Specifies the font used in the reports.
List Specifies the comma-separated list of fonts to be used in case the glyph is not found.
Caution: The character style of the link won't be outputted in case the alternate font file does not exist in the specified folder of the AddFolder setting.
IsDefault | When set to True, indicates to use the specified list for any fonts that do not have their own font links.

Child Elements

None.

Parent Elements

Element | Description
FontFactory | This is the main font factory node to which you can add fonts.

Example

 <AddFontLink Font="Tahoma" List="MS UI Gothic,SimSun,gulim,PMingLiU"/>
See Also
PDF Export


Visual Query Designer

Visual Query Designer
ActiveReports 10 > ActiveReports User Guide > Concepts > Visual Query Designer
  • Access the Visual Query Designer
  • Elements of Visual Query Designer

Visual Query Designer is a graphical interface that simplifies data binding by allowing users to interactively build queries and view the results. With the Visual Query Designer's interactive interface, users who are unfamiliar with SQL can easily design, edit and preview queries.

Visual Query Designer supports the following SQL capabilities:

  • Selecting fields
  • Custom expression
  • Inner, left outer and right outer joins
  • Filtering Data
  • Grouping and aggregate functions
  • Sorting
  • Setting aliases for the selected fields and tables

For more information on how to use these capabilites in Visual Query Designer, refer to Query Building With Visual Query Designer.

Note: You need to have Microsoft Internet Explorer 9 or higher installed on the system to run the Visual Query Designer.

See the graphic below to understand how a simple SQL query is generated in the Visual Query Designer.

Limitations
  1. Queries for XML, Object, DataSet Provider or any other specific data providers cannot be created in Visual Query Designer.
  2. Unions, nested queries and stored procedures are not supported in Design Tab.
  3. Crosses, full joins, provider-specific joins, and other SQL-specific implementation capabilities are not supported in the Design Tab.

Accessing the Visual Query Designer

  1. Connect a Page/RDL Report to a data source. See Connect to a Data Source for details on how to connect to a data source in Page/Rdl Reports and Bind Reports to a Data Source for Section Reports.
  2. Right-click the data source node (DataSource1 by default) and select the Add Data Set option or select Data Set from the Add button on the Report Explorer toolbar to add a data set to the report.
  3. In the DataSet Dialog that appears, select the Query page and then select the edit with visual query designer button [image] .

    This opens the Visual Query Designer in a Page Report or Rdl Report.

In a Section Report

  1. Connect a Section Report to a data source through the Report Data Source dialog. The Query Designer button is disabled until the report connects to a data source. For more information see, Bind Reports to a Data Source.

  2. Once enabled, click the [image] button.

    This opens the Visual Query Designer in a Section Report.

Elements of Visual Query Designer

Database View

Database View contains the structure of a database including namespaces, tables, views and columns. You can drag and drop or double click the elements in the Database View to add them to the Design tab. Alternatively, you can double click the crossed arrows icon on the right hand side of each element in the Database View to add it to the Design tab.

This is the first step in query building through the Visual Query Designer. A SQL query is generated as you add the database elements to the Design tab.

Query Tools

The Visual Query Designer provides several tools to generate a query. The Query Tools section is divided into three major areas: Design tab, SQL tab and Toolbar buttons.

Design Tab

The Design tab is the area of the Visual Query Designer where you set up queries. It provides a visual interface for the SQL query you want to generate.

  • Selected Fields panel

    Displays the fields, tables or any other element selected from the Database view. Each field in the Selected Fields panel has its own set of editable options.

    Option | Description
    Output

    Checkbox to determine whether the field is included in the result set. The checkbox is selected by default when a field is added to the Selected Fields panel. You can clear this checkbox if you do not want the field to be displayed in the Results panel.
    Table | Displays the name of the table the selected field belongs to.
    Alias | Allows the user to provide an alternative name for the field.
    Total

    Applies grouping or aggregates on a field. Total (expression) is used to perform a calculation, retrieve the value of a control, define regulations, create calculated fields, and define a group level for a report.

    • Expression - Allows selection of fields from a table. Custom expressions can also be specified here.
    • GroupBy - Groups data based on the selected field.
    • Count - Returns the number of items in a group. Implements the SQL COUNT aggregate.
    • Avg - Returns the average of the values in a group. Implements the SQL AVG aggregate.
    • Sum - Returns the sum of all the values in the group. Implements the SQL SUM aggregate.
    • Min - Returns the minimum value in a group. Implements the SQL MIN aggregate.
    • Max - Returns the maximum value in a group. Implements the SQL MAX aggregate.
    • StDev - Returns the statistical standard deviation of all values in a group. Implements the SQL STDEV aggregate.
    • Var - Returns the statistical variance of all values in the group. Implements the SQL VAR aggregate.
    Sort | Arranges data in a prescribed sequence i.e. in Ascending or Descending order.
    Sort Order | Allows the user to set the order of sorting in case multiple fields are to be sorted.
    Where | Allows the user to set a filtering condition for the column data. The WHERE clause can be used when you want to fetch any specific data from a table omitting other unrelated data.
    Note: When you add a table to the Selected Fields panel, all the fields in that table are added to the query. In effect you get a query like Select * from Customers.
  • Tables and Relationships

    The Tables and Relationships panel displays a list of all the tables with fields in the Selected Fields panel. In case the Selected Fields panel has fields from multiple tables, a Relations button appears at the bottom of the related table's name to show the relationship between two tables.

    Tables and Relationships panel provides the following options for each table:

    Option | Description
    Table | Displays the names of all the tables with fields in the Selected Fields panel.
    Alias | Allows the user to provide an alternative name for the table.

SQL Tab

The SQL Tab displays the SQL statement for the current query. Users can edit the query directly in the SQL Tab.

When you switch to the SQL Tab, the Visual Query Designer automatically formats your query in the correct syntax with highlighted keywords.

In the SQL Tab you can:

  • Add new queries by directly typing SQL statements.
  • Modify the SQL statement created by Visual Query Designer.

Tool Bar Buttons

Option | Description
Distinct Checkbox | Distinct Checkbox is used to remove duplicates from the result set of a SELECT statement. If checked, it allows users to display only distinct values.
Execute | Allows users to execute their query and display the result in Results panel.
Save | Allows users to save the query to a DataSet dialog.
Clear | Allows users to clear all the panels in the Visual Query Designer and the SQL tab along with it.

The Query Tools section also has a dropdown on the top right corner with two options:

  1. Toggle Panels: To expand or collapse the Selected Fields and the Tables and Relationships panel.
  2. Show Hints: To show or hide hints on how to use the Visual Query Designer effectively.
    Example: "Double click the table or field name in the database view or drag and drop it here." appears at the top of the Selected Fields panel.

Result panel

Displays the result of the query set in the Visual Query Designer.

This panel is populated when you click the Execute button on the Visual Query Designer toolbar after adding the required fields or tables in the Selected Fields panel.

Go to Top
See Also
Tables and Relations
Query Building With Visual Query Designer


Query Building With Visual Query Designer

Query Building With Visual Query Designer
ActiveReports 10 > ActiveReports User Guide > Concepts > Visual Query Designer > Query Building With Visual Query Designer

The topic takes you through the query building process in the Visual Query Designer. Query building in Visual Query Designer can be accomplished in a few simple steps:

Step 1: Adding fields from a table to generate a simple query

Step 2: Setting relationships (only applicable to queries using multiple tables)

Step 3: Setting options for individual fields or tables

Step 4: Executing a query

Step 5: Previewing a query

  • Create and Execute a Query (Single Table)
  • Create and Execute a Query (Multiple Tables)
  • Preview a Query
  • Save a Query
  • Edit a Query
  • Clear a Query
  • Access the Visual Query Designer
  • Delete a field
  • Sort data
  • Display Distinct Values
  • Aggregate Functions and Grouping
  • Hide Fields from a Query
  • Set filter condition
  • Create a parameterized query

The following steps assume that you have already added a Page Report or an Rdl Report template and connected it to a data source. See Adding an ActiveReport to a Project and Connect to a Data Source for further information.
For more information on how to access Visual Query Designer, see Accessing Visual Query Designer.

Note: This topic uses the Reels database. By default, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.

Create and Execute a Query (Single Table)

Go to Top

In the Visual Query Designer, you get a visual interface to assist you in quickly designing simple queries that reference a single table.

Query Result in SQL

SQL Query
Copy Code
select Movie.MovieID, Movie.Title
from Movie

Steps to create the Query in Visual Query Designer

  1. From the Movie table in the Database view, drag and drop the field MovieID to the Selected Fields panel.

  2. Add another field, Movie.Title from the same table, to the Selected Fields panel.
  3. On the Toolbar of the Visual Query Designer, click the Execute button.

    Result data similar to the following appears in Results panel.

Create and Execute a Query (Multiple Tables)

Go to Top

In the Visual Query Designer, you get a visual interface to reference multiple tables and set up relationships between them.

The following example shows how to implement a right outer join using the tables Movie and MovieCrew from Reels database and apply a filter condition to your result set using the WHERE clause. For more information about table relationships and joins in Visual Query Designer, see Tables and Relations.

Query Result in SQL

SQL Query
Copy Code
select Movie.MovieID, Movie.Country, Movie.Title, MovieCrew.CastID,
MovieCrew.TitleID from Movie right join MovieCrew on
MovieCrew.MovieID = Movie.MovieID
where (Movie.Country = 'USA' and MovieCrew.CastID =1)

Steps to create the Query in Visual Query Designer

  1. From the Movie table in the Database view, drag and drop the fields MovieID, Country and Title to the Selected Fields panel.
  2. From the MovieCrew table in Database view, drag and drop the fields CastID and TitleID to the Selected Fields panel.
  3. When you add the first field in step 2, a Tables relations dialog automatically appears on the screen.
    In Tables relations dialog, you can also select any other field from MovieCrew table which matches the related table's field to form a join between the both.
  4. In Tables relations dialog, select the Right Outer Join Type for joining the two tables Movie and Movie Crew. The Right Outer tab is highlighted.
    Refer to Tables And Relations for more information on types of joins.

  5. In Tables relations dialog, click OK to save the relationship between tables.
    Once the relationship has been set up between tables, you may also access the Tables relations dialog from the Relations button in the Tables and Relationships panel.
  6. In the Selected Fields panel, under the Where option, add a filter condition to Country field in the Movie table and set the value to "= 'USA'".
  7. Again, in the Selected Fields panel, under the Where option, add a filter condition to CastID field in the MovieCrew table and set the value to "= 1".
  8. On the Toolbar of the Visual Query Designer, click the Execute button.

    Result data similar to the following appears in Results panel.

Preview a Query

Go to Top

When you have finished designing your query, you can execute it and then preview the result in the Visual Query Designer.

  1. In the Query Tools section of the Visual Query Designer, go to the Toolbar.
  2. Click the [image] button.

    You can preview the result in the Results panel at the bottom of the Visual Query Designer dialog.

Note: When previewing a query, Visual Query Designer shows only a part of the data from the database.

Save a Query

Go to Top

Page Report/Rdl Report

Once a query is created in the Visual Query Designer, the Save button allows you to save the query into the DataSet dialog.

  1. Once your query is created in Visual Query Designer, in the Query Tools section of the Visual Query Designer, go to the Toolbar.
  2. Click the [image] button. Your query appears in Query field of the Query page in the DataSet dialog.
  3. Click OK to close the dialog.
    Your data set and queried fields appear as nodes in the Report Explorer.

Section Report

Once a query is created in the Visual Query Designer, the Save button allows you to save the query into the Report Data Source dialog.

  1. Once the query is created in Visual Query Designer, in the Query Tools section of the Visual Query Designer, go to the Toolbar.
  2. Click the [image] button.
    Your query appears in Query field of the Report Data Source dialog.
  3. Click OK to close the dialog. Your queried fields appear as bound field nodes in the Report Explorer.

Clear a Query

Go to Top

Once a query is created, the Selected Fields panel is populated with fields and Tables and Relationship panel displays the tables to which the fields used in the query belong.

  1. In the Query Tools section of the Visual Query Designer, go to the Toolbar.
  2. Click the [image] button.

    This clears the Query Tools section completely including Selected Fields and Tables and Relationships panel. It also removes the SQL query from the SQL tab and any data appearing in the Results panel.

Edit a Query

Go to Top

There are two ways to edit a query in the Visual Query Designer:

  • Edit a query created in the Visual Query Designer directly in the SQL tab.

    Follow the steps below to edit a query created in the Visual Query Designer manually in the SQL:
  1. From the Movie table in Database view, drag and drop the fields MovieID and Title onto the Selected Fields panel.
  2. Under Query Tools, switch to the SQL tab to edit the query manually.

  3. Enter the field name Movie.Length in the SQL tab.
    SQL Query
    Copy Code
    select Movie.MovieID, Movie.Title, Movie.Length
from Movie
  4. On the Toolbar of the Visual Query Designer, click the Execute button.

    The additional Length column appears in Results panel.

  • Edit an existing SQL query in the Visual Query Designer.

    This approach has some limitations based on the type of queries that can be handled in the Visual Query Designer.

  • Assuming that a query like the following already exists in the Data Set dialog of a Page/Rdl Report or the Report Data Source dialog of a Section Report, follow the steps below to edit it in the Visual Query Designer.
    SQL Query
    Copy Code
    select Movie.MovieID, Movie.Title
from Movie
  1. Open the Visual Query Designer and under Query Tools, go to the SQL tab. Notice that the SQL query is already present in the this tab.
  2. Go to the Design tab and notice that the Selected Fields panel already contains the fields MovieID and Title.
  3. From the Database view, drag and drop a field, Length from the Movie table onto the Selected Fields panel.
  4. Go to the SQL tab again and see that the query now appears as follows:
    SQL Query
    Copy Code
    select Movie.MovieID, Movie.Title, Movie.Length
from Movie
  5. On the Toolbar of the Visual Query Designer, click the Execute button.

    Result data similar to the following appears in Results panel.

Delete a field

Go to Top

You can delete any field from a query in the Visual Query Designer. When you delete a field from a query, the field remains in the database, but is no longer used in the query.

  1. From the Movie table in the Database view, drag and drop the fields MovieID, Country and Title onto the Selected Fields panel.
  2. Hover your mouse over the MovieID field in Selected Fields panel to display the Delete icon.
  3. Click the Delete icon to delete the field.
    Please note that once you delete a field, it is also removed from the SQL query in the SQL tab.

Sort data

Go to Top

You can sort the records in a table, query, form, or a report on one or more fields in the Visual Query Designer. For example, you can sort the Movie table by Title in ascending order and Country in descending order. In case multiple fields are being sorted, you can also determine which field is sorted first and which is sorted later.

Query Result in SQL

SQL Query
Copy Code
select Movie.MovieID, Movie.Title, Movie.Countryfrom Movieorder by Movie.Country desc, Movie.Title asc

Steps to create the Query in Visual Query Designer

  1. In the Database view, from the Movie table, drag and drop the fields MovieID, Title and Country onto the Selected Fields panel.
  2. In the Selected Fields panel, go to the Title field and set the Sort option to ascending. Sort Order option is automatically set to 1.
  3. Go to the Country field next and set the Sort option to ascending. Sort Order option is automatically set to 2.
    Based on steps 2 and 3, the table values sort on the Title field first and then on the Country field in ascending order.
  4. In Country field, change the Sort Order value to 1. Sort Order value of the Title field automatically changes to 2.
    The table values now sort on the Country field first in and then on the Title field in ascending order.
  5. In the Toolbar of the Visual Query Designer, click the Execute button.

    Result data similar to the following appears in Results panel.

Display Distinct Values

Go to Top

When retrieving data from a table, you may get duplicate records. Use the Distinct operator in the Select statement of your query to remove such values.

In the Visual Query Designer, you can use the Distinct checkbox available in the Toolbar to eliminate duplicate records. For example, you can retrieve unique records from YearReleased field of the Movie table.

Query Result in SQL

SQL Query
Copy Code
select DISTINCT Movie.Title, Movie.YearReleased
from Movie

Steps to create the Query in Visual Query Designer

  1. From the Movie table in the Database view, drag and drop the Title and YearReleased fields onto the Selected Fields panel.
  2. In the Toolbar of the Visual Query Designer, check the [image] checkbox to display unique values from the YearReleased field.
  3. Click the Execute button.

    Result data similar to the following appears in Results panel.

Aggregate Functions and Grouping

Go to Top

You can group data on a field and create an aggregate query that involves a function such as Sum or Avg in the Visual Query Designer. For example, you can group the movies in the Movie table by Country and calculate the average movie ratings for different countries using the Visual Query Designer.

Query Result in SQL

SQL Query
Copy Code
select Movie.Country, Avg(Movie.UserRating) as [Average Ratings]
from Movie group by Movie.Country

Steps to create the Query in Visual Query Designer

  1. From the Movie table in the Database view, drag and drop the Country and UserRating fields onto Selected Fields panel.
  2. In the Selected Fields panel, under the Country field, select GroupBy from the Total dropdown list. This groups the data by country name.
  3. In the Selected Fields panel under the UserRating field, select the option Alias and set its alternate name to Average Ratings.
  4. Under the UserRating field again, select Avg from a list of pre-defined aggregate functions in the Total dropdown list. This provides average user ratings for movies.
  5. In the Toolbar of the Visual Query Designer, click the Execute button.

    Result data similar to the following appears in Results panel.

Hide Fields from a Query

Go to Top

The Hide option in the Visual Query Designer allows you to hide part of the data that a query retrieves. For example, you can hide the MovieID field in the Movie table, from the result set of your query.

Follow the steps below to hide a field through the Visual Query Designer:

  1. From the Movie table in the Database view, drag and drop the fields Title, UserRating and Country onto the Selected Fields panel.
  2. In the Selected Fields panel, go to the Country field and select the Where option and set it's value to " = 'USA' "
  3. In the Selected Fields panel, go to the Title field and set the value of the Alias option to Movies from USA.
  4. Clear the Output check box for the Country field as shown in the image below to hide the field from the result set.

  5. In the Toolbar of the Visual Query Designer, click the Execute button.

    The data for the Country field does not appear in the in the Results panel anymore.

Set filter condition

Go to Top

The SQL Where clause is used to filter results that match a given criteria. The Where clause can be used when you want to fetch any specific data from a table omitting other unrelated data.

For example if you want to display UserRating of only those movies where the MovieID is either 1 or 2, you can use the Where clause with an '=' operator in the Visual Query Designer.

Query Result in SQL

SQL Query
Copy Code
select Movie.MovieID, Movie.UserRating
from Movie
where (Movie.MovieID = 1 or Movie.MovieID = 2)

Steps to create the Query in Visual Query Designer

  1. Form the Movie table in Database view, drag and drop the MovieID and UserRating fields onto the Selected Fields panel.
  2. In the Selected Fields panel under the MovieID field, select the Where option and set the value to "=1".
  3. Add an OR condition in MovieID field and set the value to "=2".

    Rows which have either have MovieID = 1 or MovieID = 2 are displayed in the Result set.
  4. In the Toolbar of the Visual Query Designer, click the Execute button.

    Result data similar to the following appears in Results panel.

Create a parameterized query

Go to Top

You can set parameters in your query using the Visual Query Designer. A parameterized query generally prompts the user to enter a value before the query is executed, to determine the type of data to be displayed in the result set.

As an example of a simple parameterized query, you can create a query parameter that prompts a user for a Movie ID and displays the Title, UserRating and Length of the movie based on the ID entered.

Query Result in SQL

SQL Query
Copy Code
select Movie.MovieID, Movie.Title, Movie.Country, Movie.UserRating
from Movie
where Movie.Country = ?

Steps to create the Query in Visual Query Designer

  1. From the Movie table in the Database view, drag and drop the MovieID, Title, UserRating and Country fields onto the Selected Fields panel.
  2. In the Selected Fields panel under the Country field, select the option Where and set its value to "= @Country".
    This creates a parameter Country.
  3. In the Toolbar of the Visual Query Designer, click the Execute button. The Parameters dialog automatically appears on the screen.
  4. Enter the parameter value USA in the dialog box and click OK.

    Result data similar to the following appears in Results panel.
Go to Top
See Also
Visual Query Designer
Tables And Relations


Tables And Relations

Tables And Relations
ActiveReports 10 > ActiveReports User Guide > Concepts > Visual Query Designer > Query Building With Visual Query Designer > Tables And Relations

Queries can incorporate fields from different tables. It is the relationship you set up between the data in these tables that determines how the data appears in the result set.

Users can set up these relationships between tables using SQL Joins like Inner Join, Left Join and Right Join in the Visual Query Designer.

  1. Inner Join (simple join) - Inner Join matches rows from Table1 with rows in Table2, and allows the user to retrieve records that show a relationship in both the tables. Inner join produces a set of data that matches both Table1 and Table2.

    Syntax for the SQL Inner Join:
    SELECT columns
    FROM table1
    INNER JOIN table2
    ON table1.column = table2.column;

    Visual Illustration
    SQL Inner Join returns the records where table1 and table2 intersect.
  2. Left Outer Join (left join) - Left Outer Join allows users to select rows that match from both the left and right tables, plus all the rows from the left table (table 1). This means only those rows from table2 that intersect with table1 appear in the result set.

    Syntax for SQL Left Outer Join:
    SELECT columns
    FROM table1
    LEFT [OUTER] JOIN table2
    ON table1.column = table2.column;

    Visual Illustration
    SQL Left Outer Join returns the records from table1 and only those records from table2 that intersect with table1.
  3. Right Outer Join (right join) - Right outer join allows users to select rows that match from the both the left and right tables, plus all the rows from right table (table 2). This means that only those rows from table 1 that intersect with table 2. appear in the result set

    Syntax for SQL Right Outer Join:
    SELECT columns
    FROM table1
    RIGHT [OUTER] JOIN table2
    ON table1.column = table2.column;

    Visual Illustration

    SQL Right Outer Join returns the records from table 2 and only those records from table 1 that intersect with table2.

Tables relations dialog

The Tables relations dialog allows users to set up a relationship between two different tables with at least one common field.

Complete the following steps to access the Tables relations dialog:

  1. In the Visual Query Designer, drag and drop a field or fields from a table in the Database view to the Selection Fields panel.
  2. Add another field from a different table in the Database tab to the Selected Fields panel. Make sure that at least one field between these two tables' matches i.e. the second table contains a foreign key.
  3. When the field in step 2 is added, the Tables relations dialog automatically pops up on the screen.

Once the relationship has been set up between tables, you may also access the Tables relations dialog from the Relations button in the Tables and Relationships panel.

Tables Relations

Option | Description
Join Type | Enables selection of an appropriate Join type out of Inner Join, Left Outer Join and Right Outer Join. Example: Inner Join tab is highlighted in the image above.
<Table Name> Field | Displays the name of the field that is common between tables i.e. the foreign key name in the second table. Example: "Products" Field contains the 'Category ID' field in the image above.
Related Table | Displays the name of the table to which the relationship has been set up. Example: 'Categories' table is listed in the image above.
Related Table's Field | Displays the name of the field from the table to which the relationship has been set up. Example: 'Category ID' is the field from the Categories tables listed in the image above.
Delete | Icon adjacent to the Related Table's Field to delete the currently added relation.
Add Relation | Button that allows users to add another relationship to the table.
Cancel | Closes the Tables relations window.
OK | Saves the relationship between tables as a SQL query in the SQL tab.
Go to Top
See Also
Visual Query Designer
Query Building With Visual Query Designer

Walkthroughs

Using the Visual Query Designer


Using the Visual Query Designer

Using the Visual Query Designer
ActiveReports 10 > ActiveReports User Guide > Concepts > Visual Query Designer > Using the Visual Query Designer
The following walkthrough shows how to implement an Inner Join using the tables Categories and Products from the Nwind database. It also explains how to use a parameter and sort data in a Visual Query Designer.

Note:

  • This walkthrough uses the Products and Categories table from the NWIND database. By default, in ActiveReports, the NWIND.mdb file is located in [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb.
  • This walkthrough uses Page Reports, but the same steps can be used to generate queries in Rdl or Section reports also. See Accessing the Visual Query Designer, for more information on how to access the Visual Query Designer in Rdl and Section reports.
​
  • Add an ActiveReport to a Visual Studio Project
  • Access the Visual Query Designer
  • Create a Query
  • Save a Query
  • View the Report

Add an ActiveReport to a Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Page Report and in the Name field, rename the file as VisualQueryDesigner.
  4. Click the Add button to open a new Page Report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

Access the Visual Query Designer

  1. Connect a Page Report to a data source. See Connect to a Data Source for details on how to connect to a data source in Page Reports.
  2. Right-click the data source node (DataSource1 by default) and select the Add Data Set option or select Data Set from the Add button on the Report Explorer toolbar to add a data set to the report.
  3. In the DataSet Dialog that appears, select the Query page and then select the Edit with visual query designer button [image] .
    This opens the Visual Query Designer.

Create a Query

Visual Query Designer provides you with an interface to reference multiple tables, set up relationships, sort the data and add parameters to your query.
Follow the steps below to create a query like the following using the Visual Query Designer.

Query Result in SQL

SQL Query
Copy Code
select Products.ProductName, Products.UnitPrice, Categories.CategoryName
from Products inner join Categories on Products.CategoryID = Categories.CategoryID
where Categories.CategoryName = ?
order by Products.UnitPrice desc

Steps to create a Query in Visual Query Designer

  1. From the Products table in the Database view, drag and drop the fields ProductName and UnitPrice to the Selected Fields panel.
  2. From the Categories table in Database view, drag and drop the field CategoryName to the Selected Fields panel.
  3. When you add the field in step 2, a Tables relations dialog automatically appears on the screen.
  4. In Tables relations dialog, select the Inner Join Type for joining the two tables Products and Categories. The Inner Join tab is selected by default.
    Refer to Tables And Relations for more information on types of joins.
  5. In Tables relations dialog, click OK to save the relationship between tables.
    Once the relationship has been set up between tables, you may also access the Tables relations dialog from the Relations button in the Tables and Relationships panel under the Query Tools section.
  6. In the Selected Fields panel under the CategoryName field, select the option Where and set its value to "= @CategoryName". This creates a parameter on the CategoryName field.

  7. In the Selected Fields panel, go to the UnitPrice field and set the Sort option to descending. This sorts the data in descending order on UnitPrice.
  8. On the Toolbar of the Visual Query Designer, click the Execute button. A Parameters dialog appears on the screen.
  9. Enter any parameter value, for example, Produce in the dialog box and click OK.

    Result data similar to the following appears in Results panel.

Save a Query

  1. Once your query is created in Visual Query Designer, go to the Toolbar in the Query Tools section of the Visual Query Designer.
  2. Click the [image] button. Your query appears in the Query field of the Query page in the DataSet dialog.
    Note: On clicking the Save button, your query is automatically validated by the Visual Query Designer.

View the Report

  1. Place a data region like a Table onto the design surface and add fields to it. For more information on how to add fields to a table, see the Adding Data on the Table data region page.
  2. Click the preview tab to view the report with the Parameters panel displayed in the sidebar.
    OR
    Open the report in the Viewer to view the report with the Parameters panel displayed in the sidebar. See Windows Forms Viewer for further information.


Server Reports

Server Reports
ActiveReports 10 > ActiveReports User Guide > Concepts > Server Reports

ActiveReports allows you to save and open Page reports, RDL reports and XML-based Section reports directly from ActiveReports Server. This feature allows you to save a new report or open an existing report in the designer and make changes to it before saving the report back to the server. Each time you save a report to the server, it stores a revision for that report that you can later use to open specific versions of the report.

Note:

  • You cannot save or open code-based Section reports in ActiveReports Server.
  • You must be connected to ActiveReports Server to access Open from server or Save to server dialogs. For more details, see Connecting to ActiveReports Server.
  • Accessing the Save and Open from Server Options
  • Elements of the Open report from server dialog
  • Elements of the Open report revision dialog
  • Elements of the Save report to server dialog

Accessing the Save and Open from Server Options

You can access the Open from server or Save to server options from the Standalone Designer or the Visual Studio designer.

In the Standalone Designer

Access the Open from server or Save to server dialog from the File menu of the Standalone Designer.

In the Visual Studio Designer

Access the Open from server or Save to server dialog from the Report menu of the Visual Studio designer.

Elements of the Open Report from Server Dialog

This dialog appears when you click the Open from server option from the File menu of the Standalone Designer or the Report menu of the Visual Studio designer. Using the dialog options, users can open any specific revision of the report from ActiveReports Server and make modifications to it in the designer.
The Open report from server dialog consists of the following elements:
Elements | Description
Breadcrumb | Indicates the current location in the category folder hierarchy. Example: \\ActiveTunes\Invoice, where Invoice is a sub-category of the ActiveTunes folder.
Refresh | Allows users to refresh the list of reports on ActiveReports Server.
Up one level | Allows users to move up by one folder level.
Name | Displays a list of report names, categories, and sub-categories which are stored on ActiveReports Server. For more details, see Report Categories.
Revision | Displays the most recent revision number of the report.
Modification Date | Displays the date when the report was last updated.
Modified By | Displays the name of the most recent author to modify the report.
Comment | Displays the most recent revision comment entered by an author.
Open | Allows users to open the most recent version of the report in ActiveReports Designer.
Open revision | Allows users to open a specific revision of the report. For more details, see Open report revision dialog.
Open As Library | Allows users to add report parts in the Reports Library window. For more details, see Report Parts.
Cancel | Allows users to close the dialog without opening any report.

Elements of the Open report revision dialog

This dialog appears when you click the Open revision button in the Open report from server dialog. The Open report revision dialog allows users to open any specific revision of a report from ActiveReports Server.

The Open report revision dialog consists of the following elements:
Elements | Description
Revision | Displays the revision number of the report.
Modification Date | Displays the date when the changes were made to the report.
Modified By | Displays the name of the most recent author to modify the report.
Comment | Displays the most recent revision comment entered by an author.
Open | Allows users to open a specific revision of the report in the ActiveReports Designer.
Cancel | Allows users to close the dialog without opening any report.

Elements of the Save report to server dialog

This dialog appears when you click the Save to server option from the File menu of the Standalone Designer or the Report menu of the Visual Studio designer. These reports are directly saved on ActiveReports Server and a revision is created each time the report is saved. These reports can be previewed in ActiveReports Server. See Previewing Reports for more information.
The Save report to server dialog consists of the following elements:
Elements | Description
Breadcrumb | Indicates the current location in the category folder hierarchy. Example: \\ActiveTunes\Invoice, where Invoice is a sub-category of the ActiveTunes folder.
Refresh | Allows users to refresh the list of reports on ActiveReports Server.
Up one level | Allows users to move up by one folder level.
Name | Displays a list of report names, categories, and sub-categories which are stored on ActiveReports Server. For more details, see Report Categories.
Revision | Displays the most recent revision number of the report.
Modification Date | Displays the date when the report was last updated.
Modified By | Displays the name of the most recent author to modify the report.
Comment | Displays the most recent revision comment entered by the user while saving the report.
Report Name | Allows users to enter a name for the report to be saved on ActiveReports Server.
Description | Allows users to type a short description about their report.
Comment | Displays the most recent revision comment entered by an author.
Save | Allows users to directly save a report under the selected category on ActiveReports Server. The report gets added to the report list and a revision is created each time the report is saved on ActiveReports Server.
Cancel | Allows users to close the dialog without saving the report.

See Also
Working with Server Reports
ActiveReport Server User Guide
ActiveReports Server End User Guide
Report Parts

Concepts

Report Menu
Stand-Alone Designer and Viewers


Working with Server Reports

Working with Server Reports
ActiveReports 10 > ActiveReports User Guide > Concepts > Server Reports > Working with Server Reports

This topic explains how to open reports from ActiveReports Server, save existing reports to the server after modifications and also how to save new reports to the server.

  • Open a report from the server
  • Open a report revision from the server
  • Save a report to the server
Note: In the following steps, Open from server and Save to server options are accessed using the File menu of the stand-alone designer. However, you can also access these dialogs from the Report menu of the Visual Studio designer. See Accessing the Save and Open from Server Options for details.

Open a report from the server

  1. In the stand-alone designer, click the File menu and then select Open from server.
  2. Connect your Stand-Alone Designer to ActiveReports Server in case you are not connected to the server. See Connecting to ActiveReports Server for further information.
  3. In the Open report from server dialog that appears, double-click to navigate through the categories hierarchy and then select the report that you want to open.
  4. Click Open to load the report in the designer.

Open a report revision from the server

  1. In the Open report from server dialog that appears, click the dropdown arrow next to the Open button and then select Open revision.
    To access the Open report from server dialog, see Accessing Save and Open from Server Options for details.

  2. In the Open report revision dialog that appears, select any revision of the report that you want to work on and click the Open button.

Save a report to the server

  1. From the File menu, select Save to server.
  2. Connect your Standalone Designer to ActiveReports Server in case you are not connected to the server. See Connecting to ActiveReports Server for further information.
  3. In the Save report to server dialog that appears, double-click to navigate through the categories hierarchy and then select a location where you want to save the report.
  4. Enter the Report name and add a brief description of the report in the Description section. Entering the Report name and Description is only required when saving the report for the first time on ActiveReports Server. When modifying a report that is already on ActiveReports Server, the Report name and Description fields are already filled in.
  5. In the Comment section, enter a revision comment to explain the type of changes made to the report. See Report Versions for further information.
  6. Click the Save button to save the report under the selected category on ActiveReports Server.
See Also
Server Reports
ActiveReports Server User Guide
ActiveReports Server End User Guide

Concepts

Report Menu
Stand-Alone Designer and Viewers


Interactive Features

Interactive Features
ActiveReports 10 > ActiveReports User Guide > Concepts > Interactive Features
Show All Show All
Hide All Hide All

ActiveReports supports features like parameters, filters, drill-down, links, document map and sorting to provide an interactive look to your report at run-time.

Parameters

ActiveReports allows you to set parameters in your report to filter the data displayed. Parameters make navigation of the report easier for the user at runtime. See Parameters for further details.

Filters

The filtering feature is only available with page layout reports. By using filters in your page report or RDL report you can limit the information you want to display on your report. See Filtering for further details.

Drill-Down Reports

When you open a report with drill-down features, part of the data is hidden so that you only see high-level data until you request more detail. See Drill-Down Reports for more information.

Bookmark, Hyperlinks and Drill-Through Links

Bookmark Links

When you click a bookmark link, the viewer navigates to a bookmarked item within the current report.

Hyperlinks

When you click a hyperlink, your machine's default internet browser opens to display a Web page.

Drill-Through

Using the drill-through link feature in your report you can navigate to another report for details about the item you clicked.

See Linking in Reports for further details.

Document Map

The Document Map (Table of Contents) feature allows you to navigate to a particular item in a report. See Document Map for further details.

Sorting

The sorting feature allows you to organize your data and present it in a logical order at run-time. Using this feature you can sort the data alphabetically or numerically in ascending or descending order. See Sorting for further details.

Note: You cannot use the interactive features in the following cases:
  • With Adobe Acrobat Reader and RawHTML types of the WebViewer.
  • With reports that use the collation feature, i.e. reports that have two or more themes.
  • With the ViewerType of WebViewer control set to FlashViewer, you can only use hyperlinks and document map interactive features.

Annotations

The annotations feature allows you to add floating text bars or images to call attention to specific items or values or to add notes and special instructions directly to the reports. These annotations are accessible through the Annotation button present on the Viewer toolbar which is hidden by default. Annotations added via the viewer's toolbar are temporary and are destroyed when the report closes. See Annotations for further details.

See Also
Concepts


Parameters

Parameters
ActiveReports 10 > ActiveReports User Guide > Concepts > Interactive Features > Parameters
Show All Show All
Hide All Hide All

ActiveReports allows you to use parameters to filter or add the data to display in reports at runtime. You can either prompt users for parameters so that they control the output, or supply the parameters behind the scenes.

Adding parameter for different data sources

A query parameter can get its value from the Report Parameters collection (entered by the user or from a value you supply), a field in another dataset, or an expression. Syntax for adding a parameter in your query might differ depending upon the data source that you are using. Use the syntax specific to your data source type to create a parameter.

Parameterized query for different data sources are as follows:

Data Source | Parameter Syntax | Example
OleDB | (?) | SELECT * FROM Customer WHERE (CustomerID = ? AND AccountNumber = ?)
ODBC | @ParameterName | SELECT * FROM Customer WHERE (CustomerID = @CustomerID AND AccountNumber = @AccountNumber)
SQL Client | @ParameterName | SELECT * FROM Customer WHERE (CustomerID = @CustomerID AND AccountNumber = @AccountNumber)
OracleDB | :ParameterName | SELECT * FROM Customer WHERE CustomerID = :CustomerID AND AccountNumber = :AccountNumber

Page Report/RDL Report

In a page report or a RDL report, the easiest way to build queries with parameters is to use the Visual Query Designer, as it automatically sets up each parameter.
In the DataSet dialog, click on [image] to access Visual Query Designer for creating SQL queries. See Query Building With Visual Query Designer for further information on how to create a parameterized query using the interactive query designer.

However, if you would like to do it manually, you must enter each parameter in three locations: the Report Parameters dialog (for filtering data at run time), the Parameters page of the DataSet dialog, and the Query page of the DataSet dialog.

Report - Parameters dialog

The Report - Parameters dialog allows you to control how and whether a user interface is presented to your users for each parameter. You have to set the following properties in the dialog to create a parameter:

  • Enter a report parameter name. Each report parameter in the collection must have a unique name, and the name must match the name you call in the Parameters page of the DataSet dialog. In the example above, the name is MPAA.
  • Set the data type, the text used to prompt the user, whether to allow null, blank, multiple values or multiline text, and whether to hide the user interface.
  • Select the default value or populate a list of available values from which users can choose.

Parameter values are collected in the order they appear in the Report Parameters collection. You can change the order using the arrows in the Report - Parameters dialog.

General Tab

  • Name: Set the name for the parameter in this field. The value you supply here appears in the parameters list and must match the corresponding query parameter.
  • Data type: Set the data type for your parameter which must match the data type of the field that it filters. The interface presented might also differ depending on the data type.
    • Boolean: Presents the user with two options True or False
    • Date: Presents the user with a calendar picker to select a date if you do not supply a default value or a drop-down selection of available values
    • DateTime: Presents the user with a calendar picker to select a date and a time picker to select the time in cases where you do not supply a default value or a drop-down selection of available values
    • Integer: Presents the user with a text box or a drop-down selection of available values
    • Float: Presents the user with a text box or a drop-down selection of available values
    • String: Presents the user with a text box or a drop-down selection of available values
  • Text for prompting users for a value: Enter the text you want to see on the user interface to request information from the user in this field. By default this is the same as the Name property.
  • Allow null value: Select this check box if you want to allow null values to be passed for the parameter. It is not selected by default.
  • Allow blank value: Select this check box if you want to allow blank values to be passed for the parameter. It is not selected by default.
  • Multivalue: Select this check box to allow the user to select multiple items in the available values list.
  • Multiline: Select this check box to allow multiline values in the parameter. The control will automatically adjust to accommodate multiple lines.
  • Hidden: Select this check box to hide the parameter interface from the user and instead provide a default value or pass in values from a subreport or drill-through link. Please note that if you hide the user interface and do not provide a default value, the report will not run.

Available Values

These values are used to fill a drop-down list from which the end user can choose.

  • Non-queried: You can supply Labels and Values by typing in static values or using expressions.
  • From query: You can select a Dataset from which to select a Value field and Label field.

Default Values

This is the value that you give for the parameter if the user does not supply one, or if you hide the parameter user interface.
  • Non-queried: You can supply a default Value by entering a static value or using an expression.
  • From query: You can select a Dataset from which to select a Value field.
  • None: You can have your users provide a value for the parameter.
Note: In the Available Values tab , the Value is what is passed to the query parameter, and the Label is what is shown to the user. For example, if the Value is an Employee Number, you might want to supply a more user-friendly Label showing Employee Names.

To access the Report - Parameters Dialog

You can access the Report - Parameters dialog through any one of the following:

  • In the Report Explorer, click the Add (+) icon and select the Parameter option.
  • In the Report Explorer, right-click the Parameters node and select Add Parameter.
  • In the Report Explorer, right-click the Report node and select Report Parameters.
  • From the Report Menu, select Report Parameters.

The Report Parameters dialog contains a parameters page with a list of parameters and three tabs to set parameter properties. To add a parameter to the list, click the Add (+) icon and set the parameter properties in the three tabs described below.

Parameters page of the DataSet dialog

On the Parameters page of the DataSet Dialog, pass a Report Parameter into the parameter in your query. You can click the Add (+) icon at the top of the parameters list, enter parameter name, and supply a value like:

=Parameters!MPAA.Value

Query page of the DataSet dialog

On the Query page of the DataSet Dialog, enter the parameter in the SQL query. Use the syntax specific to your data source type to create a parameter. For example, with an OleDB data source, add a query like the following for a multi-value Movie Rating parameter:

SELECT * FROM Movie WHERE (MPAA = ? AND YearReleased = ?)

If you want to run a report without prompting the user for a value at runtime, you need to set a default value for each parameter and the Hidden check box should be selected in the Report - Parameters dialog, General tab.

Subreport parameters are also considered as hidden parameters as a user can easily synchronize a subreport's data with that of the parent report . See Subreports in RDL Reports for further details.

Drill-Through parameters are also hidden parameters as drill-through links are used to navigate from one report to another. When you select Jump to report for the action, the parameters list is enabled.

Section Report

In section report, you can use the Parameters collection to pass values directly into a control at runtime, or you can also use it to display a subset of data in a particular instance of a report.

There are several ways for setting up parameters in a report:

  • You can enter syntax like the following in your SQL query to filter the data displayed in a report at runtime: <%Name | PromptString | DefaultValue | DataType | PromptUser%>
  • You can add parameters through the Report Explorer and place them on the report as TextBox controls to pass values in them at runtime.
  • You can also add parameters through the code behind the report, inside the ReportStart event. See Add Parameters for more information.

Prompting for Parameter Values

In order to prompt the user for parameter values, all of the following must be in place:

  • At least one parameter should exist in the Parameters collection of the report.
  • The PromptUser property for at least one parameter must be set to True.
  • On the report object, the ShowParameterUI property must be set to True.

When there are parameters in the collection and the ShowParameterUI property is set to True, the user prompt automatically displays when the report is run. When the user enters the requested values and clicks the OK button, the report gets displayed using the specified values.

Values of a parameter added through the Report Explorer can be applied to a parameter in the SQL query by specifying the param: prefix for a parameter in the SQL query. This prefix relates the current parameter to the one in the Report Explorer.

For e.g., select * from CUSTOMERS where CustomerName = '<%param:Parameter1%>'. In this case, the parameter with the param: prefix in the SQL query is updated with values of the corresponding parameter in the Report Explorer.

Note: Within the same report, you can prompt users for some parameters and not for others by setting the PromptUser property to True on some and False on others. However, if the report object's ShowParameterUI property is set to False, the user prompt does not display for any parameters regardless of its PromptUser setting.

Adding Parameters to the Parameters Collection via the SQL Query

When you add a single parameter to a report's Parameters collection via the SQL query, the query looks like this:

SQL Query.
Copy Code
SELECT * FROM Products
INNER JOIN Categories ON Products.CategoryID = Categories.CategoryID
WHERE Products.SupplierID = <%SupplierID|Enter a Supplier ID|1|S|True%>

You can also create a parameterized query from the Visual Query Desinger. See Query Building With Visual Query Designer for further information on how to create a parameterized query using the interactive query designer.

There are five values in the parameter syntax, separated by the pipe character: |

Only the first value (Name) is required, but if you do not specify the third value (DefaultValue), the field list is not populated at design time. You can provide only the Name value and no pipes, or if you wish to provide some, but not all of the values, simply provide pipes with no space between them for the missing values. For example, <%ProductID||||False%>

Name: This is the unique name of the parameter, and corresponds to the Key property in parameters entered via code.
PromptString: This string is displayed in the user prompt to let the user know what sort of value to enter.
DefaultValue: Providing a default value to use for the parameter allows ActiveReports to populate the bound fields list while you are designing your report, enabling you to drag fields onto the report. It also populates the user prompt so that the user can simply click the OK button to accept the default value.
DataType: This value, which defaults to S for string, tells ActiveReports what type of data the parameter represents. It also dictates the type of control used in the user prompt. The type can be one of three values.

  • S (string) provides a textbox into which the user can enter the string.
    Depending on your data source, you may need to put apostrophes (single quotes) or quotation marks around the parameter syntax for string values.
    For example, '<%MyStringParameter%>'
    Also, if you provide a default value for a string parameter that is enclosed in apostrophes or quotation marks, ActiveReports sends the apostrophes or quotation marks along with the string to SQL.
    For example, <%MyStringParameter||"DefaultValue"|S|False%>
  • D (date) provides a drop-down calendar control from which the user can select a date.
    Depending on your data source, you may need to put number signs around the parameter syntax.
    For example, #<%MyDateParameter%>#
  • B (Boolean) provides a checkbox which the user can select or clear.
    If you provide a default value of True or False, or 0 or 1 for a Boolean parameter, ActiveReports sends it to SQL in that format.
    Note: With Microsoft Access databases, the values for Boolean parameters are specified as -1 (true) or 0 (false).
PromptUser: This Boolean allows you to tell ActiveReports whether to prompt the user for a value. This can be set to True for some parameters and False for others. If you set the report's ShowParameterUI property to False, users are not prompted for any parameters, regardless of the PromptUser value set for any parameter in the report.
See Also
Interactive Features


Filtering

Filtering
ActiveReports 10 > ActiveReports User Guide > Concepts > Interactive Features > Filtering

In page layout, ActiveReports allows you to set filters on a large set of data that has already been retrieved from the data source and use them with datasets or data regions to limit the information you want to display on your report.

Although not as efficient performance-wise as query parameters which filter data at the source, there are still scenarios which demand filters. The obvious case is when the data source does not support query parameters. Another case for using filters is when users who require different sets of data view the same report.

You can set filters on a Filters page or a tab similar to the one in the following image.

There are three major elements that constitute a filter:

  • Expression: Type or use the expression editor to provide the expression on which to filter data.
  • Operator: Select the operator to compare the expression results with the Value.
  • Value: Enter the value with which to compare the expression results.

For example, in the filter =Fields!YearReleased.Value = 1997 applied on a dataset from the Movies table of the Reels.mdb database, =Fields!YearReleased.Value is set under expression, = is the operator and 1997 is the value on which filter is set. See Setting Filters for further instructions on adding filters in reports.

You can also use multiple values with the In and Between operators. Two fields with an And in the middle appear for the Between operator, and another Expression field is available at the bottom of the Filters page or tab for the In operator. The following table lists all available filtering operators.

Filtering Operators

Filter | Description
Equal | Select this operator if you want to choose data for which the value on the left is equal to the value on the right.
Like | Select this operator if you want to choose data for which the value on the left is similar to the value on the right. See the MSDN Web site for more information on the Like operator.
NotEqual | Select this operator if you want to choose data for which the value on the left is not equal to the value on the right.
GreaterThan | Select this operator if you want to choose data for which the value on the left is greater than the value on the right.
GreaterThanOrEqual | Select this operator if you want to choose data for which the value on the left is greater than or equal to the value on the right.
LessThan | Select this operator if you want to choose data for which the value on the left is less than the value on the right.
LessThanOrEqual | Select this operator if you want to choose data for which the value on the left is less than or equal to the value on the right.
TopN | Select this operator if you want to choose items from the value on the left which are the top number specified in the value on the right.
BottomN | Select this operator if you want to choose items from the value on the left which are the bottom number specified in the value on the right.
TopPercent | Select this operator if you want to choose items from the value on the left which are the top percent specified in the value on the right.
BottomPercent | Select this operator if you want to choose items from the value on the left which are the bottom percent specified in the value on the right.
In | Select this operator if you want to choose items from the value on the left which are in the array of values on the right. This operator enables the Values list at the bottom of the Filters page.
Between | Select this operator if you want to choose items from the value on the left which fall between pair of values you specify on the right. This operator enables two Value boxes instead of one.
See Also
Expressions


Drill-Down Reports

Drill-Down Reports
ActiveReports 10 > ActiveReports User Guide > Concepts > Interactive Features > Drill-Down Reports

The drill-down feature helps in temporarily hiding a part of your report. That hidden part can be controls, groups, columns or rows. When you open a drill-down report, part of the data is hidden so that you can only see high-level data until you request for more detail. In such reports you find an expand icon (plus-sign image) next to the toggle item in the report. Clicking the toggle image, or plus sign, expands hidden content into view and the expand icon changes to a collapse icon (minus-sign). When you click the minus-sign image, it hides the content and returns the report to its previous state.

To create a drill-down report, use the Visibility properties of controls, groups, columns, or rows. Simply set the Visibility-hidden property to True and set the toggle item to the name of another item in the report, usually a text box in the group containing the hidden item. At run time, this puts a plus sign next to the toggle item which the user can click to display the hidden data.

If you export a drill-down report or render it through rendering extensions, any content which is hidden at the time of export remains hidden in the exported file. If you want all of the content to appear in the exported file, you must first expand all hidden data.

Only when you render a report using the XML using the XmlRenderingExtension, all hidden data is exported regardless of whether it is hidden at the time of export.

See Also
Interactive Features

How To

Create a Drill-Down Report


Linking in Reports

Linking in Reports
ActiveReports 10 > ActiveReports User Guide > Concepts > Interactive Features > Linking in Reports

You can enhance the interactivity in your report by adding different types of links to it. ActiveReports provides the ability to add bookmarks, hyperlinks, drill-through links to reports.

The following topic explains the links you can create in page and section reports.

Page Report/RDL Report

Hyperlinks

Hyperlinks take you to a web page that opens in the default browser of the system. You can set hyperlinks in the Textbox, Image, Chart, Calendar and Map controls to access a Web page from your report. See Add Hyperlinks for further information.

Hyperlinks are displayed when you preview a page report or a RDL report in the Viewer, export a report in HTML , PDF, RTF and Excel formats. You can also see hyperlinks in Word, HTML and PDF formats when you render reports using rendering extensions.

Bookmarks

A bookmark link is similar to a hyperlink, except that it moves the viewer to another area in the report instead of linking to a web page. You can create these links on a control using a Bookmark ID that connects to another target control. See Adding Bookmarks for further information.

Bookmarks are displayed when you preview a page report/RDL report in the Viewer or render a report through rendering extensions in Word, HTML and PDF formats.

Drill through links

A drill-through link takes you to another report with more detail. Drill-through links appear as a hyperlink that you can click to move to a completely different report. You can also create more complex links where you pass parameters to the report called by the link.

Drill-through links are displayed when you preview a page report/RDL report in the Viewer or render a report through rendering extensions in HTML format.

Note: While rendering a report to HTML, drill-through links are broken unless the target report is also exported to the same directory with the same name as the original.

Section Layout

Hyperlinks

Hyperlinks take you to a web page that opens in the default browser of the system. You can set the HyperLink property available with the Label, Textbox, Picture and OleObject controls that allow you to add hyperlinks that connect to a Web page. You can also use the HyperLink property to open an e-mail or jump to a bookmark. See Add Hyperlinks for further details.

Hyperlinks are supported when you preview a section report in the Viewer, export a report in HTML , PDF, RTF and Excel formats.

Bookmarks

Bookmark links take you to a location where the bookmark is set on your report. Unlike hyperlinks, these links take you within the report. Bookmarks and nested bookmarks appear in the document map for fields, groups and subreports. You can also add special bookmarks at run-time. You can use hyperlinks for simulating a drill through like feature similar to Page Layout. See Add Bookmarks for further details.

Bookmarks are supported when you preview a section report in the Viewer, export a report in HTML and PDF formats.

Note: When you export a report to HTML, a*.TOC file is created in the folder where you export the report. Use this file to reach the bookmarked locations.
See Also
Interactive Features
Document Map


Document Map

Document Map
ActiveReports 10 > ActiveReports User Guide > Concepts > Interactive Features > Document Map
Show All Show All
Hide All Hide All

When you click an item in the document map, the viewer jumps to that item in the report.

A document map functions as a table of contents for a page report or a RDL report and as a bookmarks panel for a section report. It provides a convenient way to navigate a lengthy report.

Page Reports/RDL Reports

In a page report or a RDL Report, you can add report controls, data regions, groups and detail groups to the document map by:

  • Assigning a value to the Document map label on the Navigation page of the corresponding dialog.
  • Setting the value of the Label property in the properties window.
  • Setting the value of the HeadingLevel property in the properties window.

See Add Items to the Document Map for more information.

Section Reports

In a section report, when you add a bookmark on any control it appears in the document map while viewing the report. In order to navigate to a bookmark you need to open the document map and click that bookmark.

See Add Bookmarks for more information.

Viewing the Document Map in the Viewer

  1. On the Viewer toolbar, click the Toggle sidebar button to display the sidebar.
  2. At the bottom of the sidebar pane, click the Document map button to display the document map.

    If there is no document map associated with the report, the button does not appear at the bottom of the sidebar pane.
  3. In the Document map that appears, click the item you want to view in the report.
Note: You can also access the Document map from the Toggle sidebar button on the preview tab toolbar.

Exporting document maps

In the Viewer, the document map appears in a sidebar to the left of the report, but when you export your page or section report to various file formats, they handle document maps differently.

Export Filter | Effect on Document Map
HTML | A .toc file containing the document map is exported along with the HTML report.
PDF | Document map appears in the bookmarks panel.
Text | Document map does not appear in the exported report.
Rich Text Format | Document map does not appear in the exported report.
TIFF | Document map does not appear in the exported report.
Excel | Document map does not appear in the exported report.

In a page report or a RDL report, if you use rendering extensions to export your report, the document map is not available in any rendering type except PDF where it appears in the bookmarks panel.

Note: For printing and rendering purposes use TableOfContents control in your page report and RDL report.
See Also

How To

Add Bookmarks


Sorting

Sorting
ActiveReports 10 > ActiveReports User Guide > Concepts > Interactive Features > Sorting
Show All Show All
Hide All Hide All

In order to better organize and present data in your report, you can sort it alphabetically or numerically in ascending or descending order. You can also use sorting effectively with grouped data to present an easy to understand, comprehensive view of report data.

Sorting in Page Reports/RDL Reports

In a page report or a RDL report, you can sort data in the data region, along with grouping, on a fixed page in Page report or sort data directly in the SQL query. You can also set interactive sorting for your data on a TextBox control.

Sorting at different levels in a Report

You can apply sorting at different levels on your report data. ActiveReports provides a Sorting page in the dialogs of a data region, grouped data and fixed page to determine where you want to display sorted data.

Sorting data in a Data Region

In Table and List data regions, you can sort data within the data region. To sort data within these data regions, set sorting in the Sorting page of the specific data region's dialog.

In Tablix, BandedList and Chart data regions, sorting is only possible on grouped data therefore there is no independent Sorting page available in their specific dialogs.

Sorting grouped data

A Sorting tab is available inside the Groups page of all the data region dialogs and the Detail Grouping page of the List dialog. It allows you to set the sort order of grouped data. This tab is enabled once grouping is set inside the data region.

Sorting on a Fixed Page

In a Page report, sorting is also possible on a fixed page grouped on a dynamic value. Sorting data on a fixed page is similar to sorting grouped data in a data region. The only difference is when you sort data on the fixed page you apply sorting to all the data regions that are placed on the design surface. See, Sort Data for more information.

Sorting data through SQL Query

When you connect to a data source and create a data set to fetch data for your report, you define a query. Set the ORDER BY keyword in the query to sort data in ascending or descending order.

By default, the ORDER BY keyword usually sorts the data in ascending order, but you can include the DESC keyword in your query to sort data in descending order. For example, if you want to fetch data from the Movie table of the Reels database and sort it on the Title field, your query looks like the following:
SELECT * FROM Movie ORDER BY Title
OR
SELECT * FROM Movie ORDER BY Title ASC

In case you want the Title field sorted in descending order, your query looks like the following:
SELECT * FROM Movie ORDER BY Title DESC

Interactive Sorting

You can add interactive sorting on a TextBox control to allow users to sort columns of data within a data region on a published report.

The interactive sorting feature is set through the Interactive Sort page which available in the TextBox dialog.

Once you set interactive sorting on a TextBox control, while viewing the report in the Viewer or in the Preview Tab the textbox control displays a sort icon inside it. A user can sort data that appears inside the textbox in ascending or descending order by clicking the icons.

On the Interactive Sort page of the TextBox dialog you can find following fields available for entering values:

  • Sort Expression: An expression specifying the sort value for data contained in the column.
  • Data region or group to sort: Select the grouping level or data region within the report to sort. The default value is Current scope, but you may also choose an alternate data region or grouping.
  • Evaluate sort expression in this scope: Select the grouping level within the report on which to evaluate an aggregate sorting expression. The default value is Current scope, but you may also choose an alternate data region or grouping.

See Allow Users to Sort Data in the Viewer for more information.

Sorting in Section Reports

In a section report, sorting is not explicitly available. However, you can modify the SQL Query to order your data while fetching it from the database.

Sorting data through SQL Query

When you connect the report to a data source and enter a query to fetch data, you can include the ORDER BY keyword in your query to get sorted data.

By default, the ORDER BY keyword usually sorts data in ascending order, but you can include the DESC keyword in your query to sort data in descending order. For example, if you want to fetch data from the Customers table of the NWind database and sort it on the CompanyName field, your query looks like the following:
SELECT * FROM Customers ORDER BY CompanyName
OR
SELECT * FROM Customers ORDER BY CompanyName ASC

In case you want the CompanyName field sorted in descending order, your query looks like the following:
SELECT * FROM Customers ORDER BY CompanyName DESC

See Also

How To

Sort Data
Allow Users to Sort Data in the Viewer


Annotations

Annotations
ActiveReports 10 > ActiveReports User Guide > Concepts > Interactive Features > Annotations

Annotations are floating text bars or images to call attention to specific items or values or to add notes and special instructions directly to the reports. Annotations added via the viewer's toolbar are temporary and are destroyed when the report closes.

These annotations are accessible through the Annotation button present on the Viewer toolbar which is hidden by default. You can make the Annotations toolbar visible by setting the AnnotationDropDownVisible property to True in the viewer's properties window.

Available Annotations

Each annotation type allows you to change the colors, transparency, border, font, and alignment, plus other properties specific to the type of annotation. Available annotations include:

Annotation Name | Description
AnnotationText | A rectangular box to enter text using the Text property.
AnnotationCircle | A circle without text. You can change the shape to an oval by dragging its corners.
AnnotationRectangle | A rectangular box without text. You can change the shape to a square by dragging its corners.
AnnotationArrow | A 2D arrow to enter text using the Text property. You can also change the arrow direction using the ArrowDirection property.
AnnotationBalloon | A balloon caption to enter text using its Text property. You can also point the balloon's tail in any direction using its Quadrant property.
AnnotationLine | A line to enter text above or below it using its Text and LineLocation properties. You can also add arrow caps to one or both ends and select different dash styles using DashCap, DashStyle, and ShowArrowCaps properties.
AnnotationImage | A rectangle with a background image and text. You can select an any image inside it using the BackgroundImage property. You can also place text on the image using the Text property.

To add annotations using the Viewer

These steps assume that you have already placed the Viewer control onto a Windows Form and loaded a report in it. See Windows Forms Viewer for more information.
  1. In your Visual Studio project, on the Form where the Viewer control is placed, select the Viewer control an right-click to choose Properties.
  2. In the Properties Window that appears, set the AnnotationDropDownVisible property to True to get an additional toolbar in the viewer control.
  3. Run the report application and select the annotation you want use from the Annotation toolbar on the Viewer.
  4. Drag the annotation to the desired location on the report design surface. The annotation appears with a Delete and a Properties button on the top left corner.
  5. Inside the annotation, click the Properties button to view its properties in the Properties Window and use those properties to enter text, change color or transparency, set border or font, alignment etc.
  6. Close the Properties Window to apply changes to the annotation.
  7. Drag the corners to resize the annotation as needed. You can also select entire annotation to move it to another location on the report.
  8. Right-click the annotation to display the annotation context menu. The context menu includes the Properties and Delete commands.
Note: You can print a page, RDL or section report that contains annotations. In a section report, you can also save a report with annotations in RDF format. See Add and Save Annotations for further details.
See Also
Interactive Features


Report Parts

Report Parts
ActiveReports 10 > ActiveReports User Guide > Concepts > Report Parts

What are Report Parts?

Report parts are groups of controls (with data and settings) in a report that you can reuse in other reports. Report parts are supported in Page, RDL, and Section reports. You can also use report parts from a report that is hosted on an instance of ActiveReports Server. For example, you can use Chart and Tablix data regions from Report1, and a Table data region from Report2 to create a new report.

Note: The Report Parts feature is only available with the Professional Edition license.

Why use report parts?

Enhanced reusability: With Report Parts, you can reuse report controls along with their associated data resources such as data sets and data source connections. In earlier versions, you could copy controls from one report to another, but not the resources associated with them. Using report parts, you can add everything that is required for that control to work.

Automatic conflict resolution: ActiveReports automatically resolves name conflicts for report parts. For example, if a report already contains a Tablix1 data region and you add a report part named Tablix1, it automatically changes the new report part's name to Tablix2.

Zero dependency: After adding a report part to a report, you can modify it independent of the original report part. For example, if you add Table1 as a report part in your current report, you can modify its properties without impacting the Table1 settings in your original report.

Here is some guidance on how to work with Report Parts

  • Show or hide the Reports Library
  • Add report parts from local reports
  • Add report parts from remote reports
  • Hide report parts from the Reports Library
  • Clear report parts from the Reports Library
  • Use report parts in your reports
  • Limitations

Show or Hide the Reports Library

When ActiveReports is installed on your system, a View Reports Library button is automatically added to the Visual Studio toolbar. It appears every time you create a new application.

  1. Right-click the Visual Studio toolbar and select ActiveReports 10 to display the report designer toolbar. See Toolbar for further details.
  2. On the report designer toolbar, click the View Reports Library button. The Reports Library 10 window appears.
  3. Click the View Reports Library button again to hide the Reports Library 10 window.
Note:
  • If the Reports Library window does not appear automatically in your application, select View > Other Windows > Reports Library 10 in Visual Studio.
  • The stand-alone designer application (GrapeCity.ActiveReports.Designer.exe) also contains a Reports Library window. See Stand-alone Designer and Viewer for more information.
  • Report authors can place reports in the GrapeCity Reports Library folder to show them as report parts in the Reports Library window. By default, the GrapeCity Reports Library folder is located in the User Documents folder.

Add report parts from local reports

  1. In the stand-alone designer, click the File menu and select Open. Alternatively, to add a report part from the Reports Library window, right-click the Reports Library node and select Add.
  2. In the Open dialog that appears, navigate through the folder hierarchy and select the report you want to use for report parts.

  3. Click the dropdown arrow next to the Open button and select Open As Library to add report parts to the Reports Library 10 window. Once the report parts are added to your Report Library, you can use them to design new or existing reports.

Add report parts from remote reports

  1. In the stand-alone designer, click the File menu and select Open from server. Alternatively, to add a report part from the Reports Library window, right-click the Reports Library node and then select Add from Server.
  2. Connect your stand-alone designer to ActiveReports Server, if you are not already connected. See Connecting to ActiveReports Server for further information.

  3. In the Open report from server dialog that appears, select a report and click the dropdown arrow next to the Open button and then select Open As Library. Report parts are added to the Reports Library 10 window. Once you add these server report parts to your report, ActiveReports automatically marks the report as a remote report.

Hide report parts from the Reports Library

  1. Open the Reports Library window. For more information on how to open Reports Library window, see Show or Hide the Reports Library
  2. In the Reports Library window, select the report part that you want to hide.

  3. Right-click on the selected report part and then select Hide option from the context menu to hide the selected report part from Reports Library window.

Clear report parts from the Reports Library

  1. Right-click anywhere inside the Reports Library window and select the Clear option from the context menu to completely clear the Reports Library window.

Use report parts in your reports

  1. Once you have added the Report Parts to the Reports Library window, you can drag and drop the control from the Report Library window onto the design surface. The report part is added to your report along with its dependencies such as data sources, data sets, and parameters.

    Note: If you are working with a Page or RDL report, Section report parts are disabled in the Reports Library window and vice versa.

Limitations

  • Page and RDL reports: CheckBox and Shape controls are not supported as report parts.
  • RDL reports: Subreport controls are not supported as report parts.
  • Section reports: Label, TexBox, CheckBox, Shape, Line, SubReport, CrossSectionLine, and CrossSectionBox controls are not supported as report parts.
See Also
ReportPartsDirectory Property
Creating a report using Report Parts


Shared Subreports

Shared Subreports
ActiveReports 10 > ActiveReports User Guide > Concepts > Shared Subreports

ActiveReports provides you with the ability to save and execute shared subreports on ActiveReports Server while working with the Visual Studio designer or the ActiveReports End User Designer control. Shared subreports are subreports that are hosted on an instance of ActiveReports Server. For further information on subreports, see Subreport(RDL) and Subreport(Section Report).

Note: Shared subreports are only supported in RDL and Section reports. Moreover, you cannot use a Section report as the target of a subreport in an RDL report, and vice versa.

Advantages of Shared Subreports

Shared subreports have the same advantages as local subreports, plus:

  • They make reports more portable.
  • They allow multiple report authors to use them.
  • They let you avoid duplication of effort.

Parameters

You can use parameters supplied by the parent report to filter data displayed in a shared subreport. You can also pass parameters to a repeating subreport nested in a data region to filter each instance.

Use a shared subreport from the server

You access a shared subreport that is stored on ActiveReports Server from the main report in which you want to use it. Once you add a shared subreport to your main report, ActiveReports automatically marks the main report as a remote report.

  1. Create a new RDL or Section report from the Visual Studio designer or stand-alone designer. This is the main report. See Adding an ActiveReport to a Project for information on adding different report layouts.

  2. From the toolbox, drag a Subreport control onto the design surface of the report. If it is a Section report, drag the Subreport control onto the Detail section of the report.

  3. With the Subreport control selected, in the Properties grid, or Subreport Property dialog, select the ReportName property and click <From Server...> to open the Open report from server dialog.

  4. Connect your Visual Studio designer or stand-alone designer to ActiveReports Server if you are not already connected to the server. See Connecting to ActiveReports Server for further information.
    Note:
    • Users require Read permission to access reports that are stored on ActiveReports Server.
    • In case the shared subreport is using any shared resources, you will need Read permissions to access those resources from ActiveReports Server. For example, if you are accessing a shared sub-report that uses shared data set for displaying the data, then you need to have Read permissions for the shared data set.
  5. In the Open report from server dialog that appears, navigate through the categories hierarchy to the location where you saved the subreport and open it. The report is added to your main report as a shared subreport and the main report is marked as a remote report.

See Also
Connecting to ActiveReports Server

Concepts

Subreport(RDL)
SubReport (Section Report)


Text Justification

Text Justification
ActiveReports 10 > ActiveReports User Guide > Concepts > Text Justification
Show All Show All
Hide All Hide All

The TextJustify Property of a Textbox control provides you justification options for aligning your text within a control. It is important that the TextAlign property (Alignment property in a Section Report) must be set to Justify' for TextJustify property to affect the text layout.

Note: In section layout, the TextJustify property is also available in the Label control.

You can choose from the following values of the TextJustify property:

Auto

Results in Standard MSWord like justification where space at the end of a line is spread across other words in that line. This is the default value.

Distribute

Spaces individual characters within a word, except for the last line.

DistributeAllLines

Spaces individual characters within words and also justifies the last line according to the length of others lines.

To set Text Justification

  1. On design surface, select the control to view it's properties in Properties window.
  2. In the properties window, set the TextAlign property (Alignment property in a Section Report) to Justify.
  3. Go to the TextJustify property and from the drop down list select any one option.

Text justification is supported when you preview a report in the Viewer, print a report or export a page, RDL or section report in PDF and TIFF formats. In page reports and RDL reports, it is also supported while rendering a report in Word, HTML, PDF and Image formats using rendering extensions. See Rendering Extensions for more information on rendering extensions.

See Also
Exporting


Multiline in Report Controls

Multiline in Report Controls
ActiveReports 10 > ActiveReports User Guide > Concepts > Multiline in Report Controls

ActiveReports allows you to display text within a control on multiple lines.

Multiline in Section Reports

In a section report, to enable multiline display in your report control, you need to set the Multiline Property to True. Then, with your control in edit mode, insert line breaks at the desired location using the Enter key or Ctrl + Enter keys to create multiline text. However, when the MultiLine property is set to False, text entered into the control is displayed on a single line.

You can display multiline text in TextBox, RichTextBox and Label controls.

Multiline in Page Reports/RDL Reports

In a page report or a RDL Report, with your control in edit mode, insert line breaks at the desired location using the Enter key or Ctrl + Enter key to create multiline text. You can also insert line breaks in the Expression Editor through the Value property of the control.

You can display multiline text in the TextBox and CheckBox controls.

Note: In edit mode, scrollbars appear automatically to fit multiline content within a control. However, these are not displayed in the preview tab, so you may need to adjust the Size property of the control to display all of the text.
See Also
Toolbox
Section Report Toolbox


Line Spacing and Character Spacing

Line Spacing and Character Spacing
ActiveReports 10 > ActiveReports User Guide > Concepts > Line Spacing and Character Spacing

In ActiveReports, in order to make your report output clearly visible during export or printing you can set character and line spacing. In order to use line spacing you must first set the MultiLine property for the control to True.

The CharacterSpacing and LineSpacing properties are available in the following controls for this purpose:

Page Report/RDL Report

  • TextBox

Section Report

  • TextBox
  • Label

To set line or character spacing

  1. On the design surface, click the control to display it in the Properties Window.
  2. In the Properties window, click the Property Dialog command at the bottom to open the control dialog.
  3. In the TextBox dialog, go to the Format page and set the Line Spacing or Character Spacing values in points.
Note: You can also set the CharacterSpacing and LineSpacing property directly in the Properties Window.

Line and character spacing is supported when you preview a report in the Viewer, print a report or export a section report in HTML , PDF and TIFF formats.

In page reports and RDL reports, it is also supported while rendering a report through rendering extensions in Word, HTML, PDF and Image formats. See Rendering Extensions for further information on rendering extensions.

See Also
Exporting
CharacterSpacing Property (PageReportModel Style Class)
LineSpacing Property (PageReportModel Style Class)
CharacterSpacing Property (SectionReportModel TextBox Class)
LineSpacing Property (SectionReportModel TextBox Class)


Designer Control (Pro Edition)

Designer Control (Pro Edition)
ActiveReports 10 > ActiveReports User Guide > Concepts > Designer Control (Pro Edition)

With the Professional Edition of ActiveReports, you can host the ActiveReports Designer control in your Windows Forms application and provide your end users with report editing capabilities. The control's methods and properties allow you to save and load report layouts, monitor and control the design environment, and customize the look and feel.

In addition to the Designer control, ActiveReports offers a CreateToolStrips method to help you add default toolbars to the designer and add and remove individual tool bars and commands. This gives your designer a finished look and allows you to quickly create a functioning report designer application.

Note: You cannot host the ActiveReports Designer control in the Web application and Web site project types.
See Also

Walkthroughs

Creating a Basic End User Report Designer (Pro Edition)


Shrink Text to Fit in a Control

Shrink Text to Fit in a Control
ActiveReports 10 > ActiveReports User Guide > Concepts > Shrink Text to Fit in a Control

In ActiveReports, when working with the Textbox control in a page report and RDL report or a TextBox or Label control in a section report, you can use the ShrinkToFit property to reduce the size of the text so that it fits within the bounds of the control. The text shrinks at runtime, so you can see the reduced font size when you preview, print or export the report.

The following image illustrates the result when the ShrinkToFit property is set to True on Title.

You can use other text formatting properties in combination with the ShrinkToFit property.

Caution: When both CanGrow and ShrinkToFit are set to True, CanGrow setting is ignored and only ShrinkToFit is applied to the report.

Export Support

While exporting a report, various file formats handle ShrinkToFit differently.

ShrinkToFit gets exported in all formats except Text. While rendering a page report or RDL report using rendering extensions, ShrinkToFit is not supported in XML. However, all other rendering extensions allow ShrinkToFit display as it is. See Rendering Extensions for more on rendering extensions.


Stand-Alone Designer and Viewers

Stand-Alone Designer and Viewers
ActiveReports 10 > ActiveReports User Guide > Concepts > Stand-Alone Designer and Viewers

ActiveReports provides executable files for the Designer and the Viewer controls (Windows and WPF) in the startup menu. These executable files function as stand-alone applications to help create, edit, and view a report quickly. The stand-alone designer supports opening and saving reports directly from the ActiveReports Server. For more information, see Save and Open Reports from Server.

Use the stand-alone designer application to create a report layout, save it in .rpx or .rdlx format and then load it in the stand-alone viewer application to view the report.

To access the stand-alone designer or viewer application

From the Start Menu, go to All Programs > GrapeCity > ActiveReports and select ActiveReports Designer or ActiveReports Viewer.

OR

Select the following applications located under ...\Common Files\GrapeCity\ActiveReports 10.

  • GrapeCity.ActiveReports.Designer.exe
  • GrapeCity.ActiveReports.Viewer.exe
  • GrapeCity.ActiveReports.WpfViewer.exe

Stand-alone designer

Stand-alone designer refers to the GrapeCity.ActiveReports.Designer.exe application installed with ActiveReports installer. This application provides a user interface that includes a Designer along with a toolbox, toolbar, menu, Report Explorer and Properties Window to mimic the Visual Studio look and feel.

The stand-alone designer supports all page, RDL and section reports. By default, the designer appears with a section layout loaded. To open a page report or RDL report, do one of the following:

  • From the File menu > New menu option, open the Create New Report dialog and select Page Report or RDL report.
  • On the toolbar, select the New menu option to open the Create New Report dialog and select Page Report or RDL report.

Use the File menu > Save As option to save the report in .rpx or .rdlx format depending on the type of layout you are using. The Report menu that appears in the menu bar is similar to the one in Visual Studio. See Report Menu for more information.

Stand-alone viewer

Stand-alone viewer refers to the GrapeCity.ActiveReports.Viewer.exe application installed with ActiveReports. This is a Windows Forms application with an ActiveReports Viewer control and a menu bar.

You can open a .rdlx or .rpx report in the stand-alone viewer application, by going to the File menu > Open menu option and selecting a report to load in the viewer.

This application is compiled with the basic code to load reports. Please note that any additional features activated through code like the annotation toolbar, are not available in the stand-alone viewer application. See Windows Forms Viewer for more information on how to implement these features in the Viewer control.

Stand-alone WPF viewer

Stand-alone WPF viewer refers to the GrapeCity.ActiveReports.WpfViewer.exe application installed with ActiveReports. This is a WPF application with an ActiveReports WPF Viewer control and a menu bar.

You can open an .rdlx or .rpx report in the stand-alone WPF Viewer application, by going to the File menu > Open menu option and selecting a report to load in the viewer.

This application is compiled with the basic code to load reports. Please note that features like customizing the toolbar through code, are not implemented in the stand-alone WPF Viewer application. See Using the WPF Viewer for more information on how to implement these features in the Viewer control.

See Also
Designer Control (Pro Edition)

Walkthroughs

Creating a Basic End User Report Designer (Pro Edition)

Getting Started

Windows Forms Viewer


Localization

Localization
ActiveReports 10 > ActiveReports User Guide > Concepts > Localization

ActiveReports uses the Hub and Spoke model for localizing resources. The hub is the main executing assembly and the spokes are the satellite DLLs that contain localized resources for the application.

For example, if you want to localize the Viewer Control, the hub is GrapeCity.ActiveReports.Viewer.Win.v10.dll and the spoke is GrapeCity.ActiveReports.Viewer.Win.v10.resources.dll.

In your Program Files folder, the Localization folder is in a path like ....\GrapeCity\ActiveReports 10\Localization, and contains all of the ActiveReports components that you can localize.

There are 16 ActiveReports components in the Localization folder and most have two files.

  • A .bat file that is used to set the Cultures to which you want to localize. (The Flash viewer does not have a .bat file.)
  • A .zip file that contains the resource files (.resx) in which you update or change the strings.

There is one application in the Localization folder: NameCompleter.exe. When you run your .bat file after updating your culture, it runs this application to create a SatelliteAssembly folder with a language sub-folder containing the localized GrapeCity.ActiveReports.AssemblyName.v10.resources.dll file.

Place the language folder containing the *.resources.dll file inside your main executing assembly folder to implement changes.

Note: Before you can distribute or put your localization in the Global Assembly Cache (GAC), you must first send the localized GrapeCity.ActiveReports.AssemblyName.v10.resources.dll file to GrapeCity support and get it signed with a strong name. Once you receive the signed DLL file, you can drag the language subfolder with the signed DLL file into C:\WINDOWS\ASSEMBLY, or distribute it with your solution.

When the main executing assembly needs a resource, it uses a ResourceManager object to load the required resource. The ResourceManager uses the thread's CurrentUICulture property.

The common language runtime sets the CurrentUICulture property or you can set it in code to force a certain UI Culture so that you can test whether your satellite DLL is loading properly. The ResourceManager class uses the CurrentUICulture property to locate subdirectories that contain a satellite DLL for the current culture. If no subdirectory exists, the ResourceManager uses the resource that is embedded in the assembly. US English ("en-US") is the default culture for ActiveReports.

Tip: For more detailed information about how the Framework locates satellite DLLs, please refer to the help system in Visual Studio® or the book Developing International Software, 2nd edition by MS Press that contains information on localizing applications using the .NET Framework.
See Also

How To

Localize
Localize the Viewer Control
Localize the End User Report Designer
Localize ActiveReports Resources
Localize Reports, TextBoxes, and Chart Controls
Customize, Localize, and Deploy


Cultures

Cultures
ActiveReports 10 > ActiveReports User Guide > Concepts > Localization > Cultures

For your convenience, here is a list of predefined System.Globalization cultures. (Source: MSDN.) For ActiveReports localization purposes, use the Culture and Language Name value in the first column.

Culture and Language Name | Culture Identifier | Culture
"" (empty string) | 0x007F | Invariant culture
af | 0x0036 | Afrikaans
af-ZA | 0x0436 | Afrikaans (South Africa)
sq | 0x001C | Albanian
sq-AL | 0x041C | Albanian (Albania)
ar | 0x0001 | Arabic
ar-DZ | 0x1401 | Arabic (Algeria)
ar-BH | 0x3C01 | Arabic (Bahrain)
ar-EG | 0x0C01 | Arabic (Egypt)
ar-IQ | 0x0801 | Arabic (Iraq)
ar-JO | 0x2C01 | Arabic (Jordan)
ar-KW | 0x3401 | Arabic (Kuwait)
ar-LB | 0x3001 | Arabic (Lebanon)
ar-LY | 0x1001 | Arabic (Libya)
ar-MA | 0x1801 | Arabic (Morocco)
ar-OM | 0x2001 | Arabic (Oman)
ar-QA | 0x4001 | Arabic (Qatar)
ar-SA | 0x0401 | Arabic (Saudi Arabia)
ar-SY | 0x2801 | Arabic (Syria)
ar-TN | 0x1C01 | Arabic (Tunisia)
ar-AE | 0x3801 | Arabic (U.A.E.)
ar-YE | 0x2401 | Arabic (Yemen)
hy | 0x002B | Armenian
hy-AM | 0x042B | Armenian (Armenia)
az | 0x002C | Azeri
az-Cyrl-AZ | 0x082C | Azeri (Azerbaijan, Cyrillic)
az-Latn-AZ | 0x042C | Azeri (Azerbaijan, Latin)
eu | 0x002D | Basque
eu-ES | 0x042D | Basque (Basque)
be | 0x0023 | Belarusian
be-BY | 0x0423 | Belarusian (Belarus)
bg | 0x0002 | Bulgarian
bg-BG | 0x0402 | Bulgarian (Bulgaria)
ca | 0x0003 | Catalan
ca-ES | 0x0403 | Catalan (Catalan)
zh-HK | 0x0C04 | Chinese (Hong Kong SAR, PRC)
zh-MO | 0x1404 | Chinese (Macao SAR)
zh-CN | 0x0804 | Chinese (PRC)
zh-Hans | 0x0004 | Chinese (Simplified)
zh-SG | 0x1004 | Chinese (Singapore)
zh-TW | 0x0404 | Chinese (Taiwan)
zh-Hant | 0x7C04 | Chinese (Traditional)
hr | 0x001A | Croatian
hr-HR | 0x041A | Croatian (Croatia)
cs | 0x0005 | Czech
cs-CZ | 0x0405 | Czech (Czech Republic)
da | 0x0006 | Danish
da-DK | 0x0406 | Danish (Denmark)
dv | 0x0065 | Divehi
dv-MV | 0x0465 | Divehi (Maldives)
nl | 0x0013 | Dutch
nl-BE | 0x0813 | Dutch (Belgium)
nl-NL | 0x0413 | Dutch (Netherlands)
en | 0x0009 | English
en-AU | 0x0C09 | English (Australia)
en-BZ | 0x2809 | English (Belize)
en-CA | 0x1009 | English (Canada)
en-029 | 0x2409 | English (Caribbean)
en-IE | 0x1809 | English (Ireland)
en-JM | 0x2009 | English (Jamaica)
en-NZ | 0x1409 | English (New Zealand)
en-PH | 0x3409 | English (Philippines)
en-ZA | 0x1C09 | English (South Africa)
en-TT | 0x2C09 | English (Trinidad and Tobago)
en-GB | 0x0809 | English (United Kingdom)
en-US | 0x0409 | English (United States)
en-ZW | 0x3009 | English (Zimbabwe)
et | 0x0025 | Estonian
et-EE | 0x0425 | Estonian (Estonia)
fo | 0x0038 | Faroese
fo-FO | 0x0438 | Faroese (Faroe Islands)
fa | 0x0029 | Farsi
fa-IR | 0x0429 | Farsi (Iran)
fi | 0x000B | Finnish
fi-FI | 0x040B | Finnish (Finland)
fr | 0x000C | French
fr-BE | 0x080C | French (Belgium)
fr-CA | 0x0C0C | French (Canada)
fr-FR | 0x040C | French (France)
fr-LU | 0x140C | French (Luxembourg)
fr-MC | 0x180C | French (Monaco)
fr-CH | 0x100C | French (Switzerland)
gl | 0x0056 | Galician
gl-ES | 0x0456 | Galician (Spain)
ka | 0x0037 | Georgian
ka-GE | 0x0437 | Georgian (Georgia)
de | 0x0007 | German
de-AT | 0x0C07 | German (Austria)
de-DE | 0x0407 | German (Germany)
de-LI | 0x1407 | German (Liechtenstein)
de-LU | 0x1007 | German (Luxembourg)
de-CH | 0x0807 | German (Switzerland)
el | 0x0008 | Greek
el-GR | 0x0408 | Greek (Greece)
gu | 0x0047 | Gujarati
gu-IN | 0x0447 | Gujarati (India)
he | 0x000D | Hebrew
he-IL | 0x040D | Hebrew (Israel)
hi | 0x0039 | Hindi
hi-IN | 0x0439 | Hindi (India)
hu | 0x000E | Hungarian
hu-HU | 0x040E | Hungarian (Hungary)
is | 0x000F | Icelandic
is-IS | 0x040F | Icelandic (Iceland)
id | 0x0021 | Indonesian
id-ID | 0x0421 | Indonesian (Indonesia)
it | 0x0010 | Italian
it-IT | 0x0410 | Italian (Italy)
it-CH | 0x0810 | Italian (Switzerland)
ja | 0x0011 | Japanese
ja-JP | 0x0411 | Japanese (Japan)
kn | 0x004B | Kannada
kn-IN | 0x044B | Kannada (India)
kk | 0x003F | Kazakh
kk-KZ | 0x043F | Kazakh (Kazakhstan)
kok | 0x0057 | Konkani
kok-IN | 0x0457 | Konkani (India)
ko | 0x0012 | Korean
ko-KR | 0x0412 | Korean (Korea)
ky | 0x0040 | Kyrgyz
ky-KG | 0x0440 | Kyrgyz (Kyrgyzstan)
lv | 0x0026 | Latvian
lv-LV | 0x0426 | Latvian (Latvia)
lt | 0x0027 | Lithuanian
lt-LT | 0x0427 | Lithuanian (Lithuania)
mk | 0x002F | Macedonian
mk-MK | 0x042F | Macedonian (Macedonia, FYROM)
ms | 0x003E | Malay
ms-BN | 0x083E | Malay (Brunei Darussalam)
ms-MY | 0x043E | Malay (Malaysia)
mr | 0x004E | Marathi
mr-IN | 0x044E | Marathi (India)
mn | 0x0050 | Mongolian
mn-MN | 0x0450 | Mongolian (Mongolia)
no | 0x0014 | Norwegian
nb-NO | 0x0414 | Norwegian (Bokmål, Norway)
nn-NO | 0x0814 | Norwegian (Nynorsk, Norway)
pl | 0x0015 | Polish
pl-PL | 0x0415 | Polish (Poland)
pt | 0x0016 | Portuguese
pt-BR | 0x0416 | Portuguese (Brazil)
pt-PT | 0x0816 | Portuguese (Portugal)
pa | 0x0046 | Punjabi
pa-IN | 0x0446 | Punjabi (India)
ro | 0x0018 | Romanian
ro-RO | 0x0418 | Romanian (Romania)
ru | 0x0019 | Russian
ru-RU | 0x0419 | Russian (Russia)
sa | 0x004F | Sanskrit
sa-IN | 0x044F | Sanskrit (India)
sr-Cyrl-CS | 0x0C1A | Serbian (Serbia, Cyrillic)
sr-Latn-CS | 0x081A | Serbian (Serbia, Latin)
sk | 0x001B | Slovak
sk-SK | 0x041B | Slovak (Slovakia)
sl | 0x0024 | Slovenian
sl-SI | 0x0424 | Slovenian (Slovenia)
es | 0x000A | Spanish
es-AR | 0x2C0A | Spanish (Argentina)
es-BO | 0x400A | Spanish (Bolivia)
es-CL | 0x340A | Spanish (Chile)
es-CO | 0x240A | Spanish (Colombia)
es-CR | 0x140A | Spanish (Costa Rica)
es-DO | 0x1C0A | Spanish (Dominican Republic)
es-EC | 0x300A | Spanish (Ecuador)
es-SV | 0x440A | Spanish (El Salvador)
es-GT | 0x100A | Spanish (Guatemala)
es-HN | 0x480A | Spanish (Honduras)
es-MX | 0x080A | Spanish (Mexico)
es-NI | 0x4C0A | Spanish (Nicaragua)
es-PA | 0x180A | Spanish (Panama)
es-PY | 0x3C0A | Spanish (Paraguay)
es-PE | 0x280A | Spanish (Peru)
es-PR | 0x500A | Spanish (Puerto Rico)
es-ES | 0x0C0A | Spanish (Spain)
es-ES_tradnl | 0x040A | Spanish (Spain, Traditional Sort)
es-UY | 0x380A | Spanish (Uruguay)
es-VE | 0x200A | Spanish (Venezuela)
sw | 0x0041 | Swahili
sw-KE | 0x0441 | Swahili (Kenya)
sv | 0x001D | Swedish
sv-FI | 0x081D | Swedish (Finland)
sv-SE | 0x041D | Swedish (Sweden)
syr | 0x005A | Syriac
syr-SY | 0x045A | Syriac (Syria)
ta | 0x0049 | Tamil
ta-IN | 0x0449 | Tamil (India)
tt | 0x0044 | Tatar
tt-RU | 0x0444 | Tatar (Russia)
te | 0x004A | Telugu
te-IN | 0x044A | Telugu (India)
th | 0x001E | Thai
th-TH | 0x041E | Thai (Thailand)
tr | 0x001F | Turkish
tr-TR | 0x041F | Turkish (Turkey)
uk | 0x0022 | Ukrainian
uk-UA | 0x0422 | Ukrainian (Ukraine)
ur | 0x0020 | Urdu
ur-PK | 0x0420 | Urdu (Pakistan)
uz | 0x0043 | Uzbek
uz-Cyrl-UZ | 0x0843 | Uzbek (Uzbekistan, Cyrillic)
uz-Latn-UZ | 0x0443 | Uzbek (Uzbekistan, Latin)
vi | 0x002A | Vietnamese
vi-VN | 0x042A | Vietnamese (Vietnam)


Section 508 Compliance

Section 508 Compliance
ActiveReports 10 > ActiveReports User Guide > Concepts > Section 508 Compliance
Show All Show All
Hide All Hide All

Section 508 requires that when Federal agencies develop, procure, maintain, or use electronic and information technology, Federal employees with disabilities have access to and use of information and data that is comparable to the access and use by Federal employees without disabilities, unless an undue burden would be imposed on the agency. Section 508 also requires that individuals with disabilities seeking information or services from a Federal agency have access to and use of information and data that is comparable to that provided to the general public, unless an undue burden would be imposed on the agency.

Summary

Guideline |  | Applicable | ActiveReports Area
Section 1194.21 | Software Applications and Operating Systems | Applicable | End User Designer, Windows Viewer, WPF Viewer, Web controls (HTML5 Viewer, HTML/Flash Viewer, Silverlight).
Section 1194.22 | Web-Based Intranet and Internet Information and Applications | Applicable | Web controls (HTML5 Viewer, HTML/Flash Viewer, Silverlight).
Section 1194.23 | Telecommunications Products | Not applicable | none
Section 1194.24 | Video and Multimedia Products | Not applicable | none
Section 1194.25 | Self-Contained, Closed Products | Not applicable | none
Section 1194.26 | Desktop and Portable Computers | Not applicable | none
Section 1194.31 | Functional Performance Criteria | Applicable | End User Designer, Windows Viewer, WPF Viewer, Web controls (HTML5 Viewer, HTML/Flash Viewer, Silverlight).
Section 1194.41 | Information, Documentation and Support | Applicable | Documentation and Support.

Accessibility Summary:

All major features of ActiveReports software are accessible via keyboard navigation.

DISCLAIMER:

GRAPECITY MAKES NO WARRANTIES, EXPRESS OR IMPLIED, IN THIS DOCUMENT. The following information reflects the general accessibility features of GrapeCity software components as related to the Section 508 standards. If you find that the information is not accurate, or if you have specific accessibility needs that our products do not meet, please contact us and we will attempt to rectify the problem, although we cannot guarantee that we will be able to do so in every case.

Software Applications and Operating Systems

Section 1194.21

Criteria | Status | Remarks
(a) When software is designed to run on a system that has a keyboard, product functions shall be executable from a keyboard where the function itself or the result of performing a function can be discerned textually. | Supported with exceptions | ActiveReports partially supports keyboard navigation. Users cannot execute report functions completely using the keyboard.
(b) Applications shall not disrupt or disable activated features of other products that are identified as accessibility features, where those features are developed and documented according to industry standards. Applications also shall not disrupt or disable activated features of any operating system that are identified as accessibility features where the application programming interface for those accessibility features has been documented by the manufacturer of the operating system and is available to the product developer. | Supported | The controls do not disrupt or disable industry standard accessibility features of other products.
(c) A well-defined on-screen indication of the current focus shall be provided that moves among interactive interface elements as the input focus changes. The focus shall be programmatically exposed so that Assistive Technology can track focus and focus changes. | Supported with exceptions | Some elements in ActiveReports cannot track focus. Focus is not exposed to screen readers like NVDA.
(d) Sufficient information about a user interface element including the identity, operation and state of the element shall be available to Assistive Technology. When an image represents a program element, the information conveyed by the image must also be available in text. | Supported with exceptions | The images representing program elements do not support alternative text. Partial support for Assistive Technology is provided for some interface elements.
(e) When bitmap images are used to identify controls, status indicators, or other programmatic elements, the meaning assigned to those images shall be consistent throughout an application's performance. | Supported | Any image used to identify a programmatic element has a consistent meaning throughout an application's performance.
(f) Textual information shall be provided through operating system functions for displaying text. The minimum information that shall be made available is text content, text input caret location, and text attributes. | Supported | Textual information such as text content, caret location, and any text attribute (i.e. bold, italic, size, color, etc.) is available for all the viewer elements.
(g) Applications shall not override user selected contrast and color selections and other individual display attributes. | Supported with exceptions | User selected contrast and color settings are not overridden, except for some minor exceptions in End User Designer.
(h) When animation is displayed, the information shall be displayable in at least one non-animated presentation mode at the option of the user. | Supported | Animated image is only used when a report is being loaded in the viewer. The users can provide a static text for the animation using the loadCompleted event of the Viewer.
(i) Color coding shall not be used as the only means of conveying information, indicating an action, prompting a response, or distinguishing a visual element. | Supported | Any interface element that uses color to indicate an action, prompt a response, or distinguish a visual element also provides a textual cue.
(j) When a product permits a user to adjust color and contrast settings, a variety of color selections capable of producing a range of contrast levels shall be provided. | Supported | ActiveReports supports a variety of colors, themes and styles that can be applied to controls in a report.
(k) Software shall not use flashing or blinking text, objects, or other elements having a flash or blink frequency greater than 2 Hz and lower than 55 Hz. | Supported | The controls do not use flashing or blinking text or objects.
(l) When electronic forms are used, the form shall allow people using Assistive Technology to access the information, field elements, and functionality required for completion and submission of the form, including all directions and cues. | Supported | Any form-type dialogs or windows associated with the controls provide Assistive Technology with access to information on all directions, cues, field elements, and functionality required for completion.

Web-based Internet Information and Applications

Section 1194.22

Criteria | Status | Remarks
(a) A text equivalent for every non-text element shall be provided (e.g., via "alt", "longdesc", or in element content). | Supported | Each non-text element has a text equivalent.
(b) Equivalent alternatives for any multimedia presentation shall be synchronized with the presentation. | Not applicable | ActiveReports web controls do not include multimedia.
(c) Web pages shall be designed so that all information conveyed with color is also available without color, for example from context or markup. | Not applicable | ActiveReports web controls do not provide any information using color.
(d) Documents shall be organized so they are readable without requiring an associated style sheet. | Supported with exceptions | Toolbar icons in some web controls are not visible when the associated styles are disabled.
(e) Redundant text links shall be provided for each active region of a server-side image map. | Not applicable | There are no server-side image maps in ActiveReports web controls.
(f) Client-side image maps shall be provided instead of server-side image maps except where the regions cannot be defined with an available geometric shape. | Not applicable | ActiveReports Server does not use client-side image maps in ActiveReports web controls.
(g) Row and column headers shall be identified for data tables. | Not applicable | By default, there are no data tables associated with the ActiveReports web controls.
(h) Markup shall be used to associate data cells and header cells for data tables that have two or more logical levels of row or column headers. | Not applicable | By default, there are no data tables associated with the ActiveReports web controls.
(i) Frames shall be titled with text that facilitates frame identification and navigation. | Not applicable | By default, there are no frames associated with ActiveReports web controls.
(j) Pages shall be designed to avoid causing the screen to flicker with a frequency greater than 2 Hz and lower than 55 Hz. | Supported | ActiveReports Web controls do not contain any feature that causes page flickering.
(k) A text-only page, with equivalent information or functionality, shall be provided to make a web site comply with the provisions of this part, when compliance cannot be accomplished in any other way. The content of the text-only page shall be updated whenever the primary page changes. | Not applicable | Text-only page is not available in ActiveReports Web Viewer or Web controls.
(l) When pages utilize scripting languages to display content, or to create interface elements, the information provided by the script shall be identified with functional text that can be read by Assistive Technology. | Supported | The ActiveReports HTML5 Viewer control uses scripting that is supported by Assistive Technology.
(m) When a web page requires that an applet, plug-in or other application be present on the client system to interpret page content, the page must provide a link to a plug-in or applet that complies with §1194.21(a) through (l). | Supported | ActiveReports provides a link to install the Silverlight plug-in when an application using ActiveReports Silverlight viewer control is executed.
(n) When electronic forms are designed to be completed on-line, the form shall allow people using Assistive Technology to access the information, field elements, and functionality required for completion and submission of the form, including all directions and cues. | Supported with exceptions | The components used in ActiveReports have been configured for maximum compliance. Some form controls may not support Assistive Technology.
(o) A method shall be provided that permits users to skip repetitive navigation links. | Not applicable | ActiveReports does not support repetitive navigation links.
(p) When a timed response is required, the user shall be alerted and given sufficient time to indicate more time is required. | Not applicable | Timed response is not required.

Performance Criteria

Section 1194.31

Criteria | Status | Remarks
(a) At least one mode of operation and information retrieval that does not require user vision shall be provided, or support for assistive technology used by people who are blind or visually impaired shall be provided. | Supported with exceptions | Partial support is provided for assistive technologies like screen readers.
(b) At least one mode of operation and information retrieval that does not require visual acuity greater than 20/70 shall be provided in audio and enlarged print output working together or independently, or support for assistive technology used by people who are visually impaired shall be provided. | Supported | ActiveReports does not require visual acuity greater than 20/70. It is exposed to magnification tools like the Screen Magnifier that can be used for magnifying the screen.
(c) At least one mode of operation and information retrieval that does not require user hearing shall be provided, or support for assistive technology used by people who are deaf or hard of hearing shall be provided. | Not applicable | ActiveReports does not use any sound output. Hearing is not necessary to use the product.
(d) Where audio information is important for the use of a product, at least one mode of operation and information retrieval shall be provided in an enhanced auditory fashion, or support for assistive hearing devices shall be provided. | Not applicable | ActiveReports does not provide functionalities that require audio or video aids.
(e) At least one mode of operation and information retrieval that does not require user speech shall be provided, or support for assistive technology used by people with disabilities shall be provided. | Not applicable | ActiveReports does not provide any functionality that make use of user speech.
(f) At least one mode of operation and information retrieval that does not require fine motor control or simultaneous actions and that is operable with limited reach and strength shall be provided. | Supported | ActiveReports does not provide any functionality that requires fine motor control or simultaneous action.

Information, Documentation and Support

Section 1194.41

Criteria | Status | Remarks
(a) Product support documentation provided to end-users shall be made available in alternate formats upon request, at no additional charge. | Supported | Documentation is available in four formats: HTML(Web), *.chm, *.PDF, and Help3(Visual Studio help content)
(b) End-users shall have access to a description of the accessibility and compatibility features of products in alternate formats or alternate methods upon request, at no additional charge. | Supported | ActiveReports provides information about accessibility and compatibility features in the documentation. The documentation is exposed to screen readers.
(c) Support services for products shall accommodate the communication needs of end-users with disabilities. | Supported | Support services such as telephone, email and forum support are provided to the customers.
See Also

How To

How To

©2017. ComponentOne, a division of GrapeCity. All rights reserved.

Support Forum


How To

How To
ActiveReports 10 > ActiveReports User Guide > How To

Learn to perform common tasks with ActiveReports with quick how-to topics.

This section contains information about

Page Report/RDL Report How To
Learn how to work with both Page report and RDL report, and perform various page report tasks.
Section Report How To
Learn how to work with Section reports and perform various reporting tasks specific to this type of report.
Customize, Localize, and Deploy
Learn how to customize each of the Windows and Web controls, how to localize reports and controls, and how to deploy Windows, Web, and Silverlight applications.
Use Fields in Reports
Learn how to utilize bound or database fields and calculated fields in reports.
Use Advanced Printing Options
Learn how to access and set up the advanced printing options provided with the ActiveReports Viewer.
Provide One-Touch Printing in the WebViewer (Pro Edition)
Learn how to use One-Touch printing in the Web Viewer.
Provide PDF Printing in the Silverlight Viewer (Pro Edition)
Learn how to use PDF printing in the Silverlight Viewer.
Print Methods In ActiveReports
Learn about various Print methods in ActiveReports.
See Also

Getting Started

Getting Started

Concepts

Concepts

Walkthroughs

Samples and Walkthroughs


Page Report/RDL Report How To

Page Report/RDL Report How To
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To

Learn to perform common tasks with ActiveReports with quick how-to topics.

This section contains information about how to

Work with Data
Learn how to connect to different data sources and add a data set in a page report or a RDL report.
Work with Report Controls and Data Regions
Learn how to use controls like the TextBox, Map or Image, and data regions like the Tablix or Table on Page Reports/RDL reports.
Create Common Page Reports
Learn how to work with both Page report and RDL report, and perform various report tasks.
Add Parameters
Learn how to add a parameters to your report so that the users can filter data.
Create and Add Themes
Learn how to create and add new themes.
Customize and Apply a Theme
Learn how to modify an existing theme and apply them in your report.
Use Constant Expressions in a Theme
Learn how to set a constant expression in a theme and display it on your report.
Set Up Collation
Learn how a report renders when multiple themes are applied.
Add Hyperlinks
Learn how to add hyperlinks and improve interactivity in your report.
Add Bookmarks
Learn how to add bookmark links and improve interactivity in your report.
Create and Use a Master Report (RDL Report)
Learn how to create a master report and apply common features to any number of reports.
Working with Images
Learn how to work with different types of images in ActiveReports.
Sort Data
Learn how to sort data in page layout.
Allow Users to Sort Data in the Viewer
Learn how to use the Interactive Sort settings on a TextBox report control.
Create a Drill-Down Report
Learn how to use the Visibility settings to toggle detail data within a report.
Set a Drill-Through Link
Learn how to set a drill-through link.
Add Items to the Document Map
Learn how to add items in the Document Map.
Change Page Size
Learn how to change page size in page layout.
Add Page Breaks in RDL (RDL Report)
Learn how to add page breaks in RDL reports.
Add Totals and Subtotals in a Data Region
Learn how to set totals and subtotals in all the data regions with illustrative examples.
See Also
Section Report How To

Concepts

Page Report/RDL Report Concepts


Work with Data

Work with Data
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Data

See step-by-step instructions for performing common tasks in Page Reports and RDL Reports.

This section contains information about how to:

Connect to a Data Source
Learn how to bind reports to various data sources.
Add a Dataset
Learn how to add a dataset in a report.
Create and Edit a Shared Data Source
Learn how to create and edit a shared data source.
Bind Reports to a Data Source at run time
Learn how to bind a page report to a data source at run time.
See Also

How To

Page Report/RDL Report How To


Connect to a Data Source

Connect to a Data Source
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Data > Connect to a Data Source
Show All Show All
Hide All Hide All

In a page report or a RDL report, you can connect to a data source at design time through the Report Explorer. Use the following instructions to connect to various data providers supported in ActiveReports.

These steps assume that you have already added a Page Report/RDL Report template in a Visual Studio project. See Adding an ActiveReport to a Project further information.

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the add button.
  2. In the Report Data Source dialog that appears, select the General page and enter the name of the data source. By default, the data source name is set to Data Source1. This name appears as a child node to the Data Sources node in the Report Explorer.
  3. Under Type, select the type of data source you want to use.
  4. Under Connection, enter a Connection String. If you select SQL, OleDB, or Oracle as the data source Type value, Connection Properties, Connection String and Advanced Settings pages appear under Connection. See Report Data Source Dialog for further details.

    Note: When you select an XML Provider under Type, the connection string must include XmlDoc or XmlData. Use of TransformationDoc is optional. See details of each of these connection string types below:

    Connection String

    • XmlDoc: Refers to a specific XML file located on either the file system or at a web-accessible location. For example, XmlDoc=C:\MyXmlFile.xml;
    • XmlData: Provides specific XML data in the Connection String itself. For example,
      XmlData=<people>
        <person>
          <name>
            <given>John</given>
            <family>Doe</family>
          </name>
        </person>
        <person>
          <name>
            <given>Jane</given>
            <family>Smith</family>
          </name>
        </person>
      </people>;
    • TransformationDoc: Refers to a specific XSLT file to apply to the XML data.

    Note that elements in the Connection String must be terminated with a semicolon (;) character.
  5. Click the Validate Data Source icon to confirm the connection string. This icon becomes inactive to indicate success, while an error message indicates an invalid connection string.
  6. On the Credentials page, you can specify password, credentials, or Windows authentication.
  7. Click the OK button on the lower right corner to close the dialog. You have successfully connected the report to a data source.

In ActiveReports, you can connect to most data sources with these steps. However, you need to follow the instructions below to connect to a Shared Data Source.

Connect to a Shared Data Source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source dialog that appears, select the General page and enter the name of the data source. This name appears as a child node to the Data Sources node in the Report Explorer.
  3. Check the Shared Reference checkbox on.
  4. Under Reference, click the Browse button and from the Shared Data Source File dialog that appears, go to the folder where your shared data source file is located and select it. A file path appears in the field adjacent to the Browse button.
  5. Click the OK button on the lower right corner to close the dialog. A shared data source node appears in the Report Explorer.
See Also
Add a Dataset

Concepts

Report Data Source Dialog


Add a Dataset

Add a Dataset
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Data > Add a Dataset

In a page report or a RDL report, once you connect your report to a data source, in order to get a list of fields to use in the report, you need to add a dataset. Use the following instructions to add a dataset to the report.

These steps assume that you have already added a Page Report/RDL Report template and connected it to a data source. See Adding an ActiveReport to a Project and Connect to a Data Source for further information.

  1. In the Report Explorer, right-click the data source node (DataSource1 by default) and select the Add Data Set option or select Data Set... from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, select a Command Type from the dropdown list.

    • Text - Allows the user to enter a SQL query or XML path in the Query box. See Visual Query Designer for further information on how to create a query using the interactive query designer.
    • StoredProcedure - Allows the user to enter the name of the stored procedure in the Query box.
    • TableDirect - Allows the user to enter the name of the table in the Query box.
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  5. The fields are automatically added to the Fields page in the DataSet dialog. For XML data, manually enter fields on the Fields page using valid XPath expressions.
  6. You can also set parameters, filters, and data options on the other pages of the dialog.
  7. Click the OK button to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.
Note: In case you are using an XML data source provider, you have to provide an XML path on the Query page and generate fields using XPath expressions on the Fields page of the DataSet dialog. See the following example for details.

Query and Field settings for XML Data

The XML provider supports the use of XPath 1.0 in building queries and selecting Fields. Following is an example of how the query string and fields are set with an XMLData connection string.

Connection String

Example of an XmlData connection string.
XmlData=<people>
  <person>
    <name>
      <given>John</given>
      <family>Doe</family>
    </name>
  </person>
  <person>
    <name>
      <given>Jane</given>
      <family>Smith</family>
    </name>
  </person>
</people>;

Query String

Set the query like /people/person/name

Fields

Once the query is set, build the Fields collection with two fields that contain the following name and value pairs:
Name: Given; Value: given
Name: Family; Value: family

See Use Fields in Reports to understand fields further.
See Also
Connect to a Data Source

Concepts

DataSet Dialog


Create and Edit a Shared Data Source

Create and Edit a Shared Data Source
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Data > Create and Edit a Shared Data Source

You can save a data connection type such as an OleDb connection or an XML connection as a Shared Data Source (RDSX). This topic provides the steps to create a shared data source with an OleDb data connection.

To create a shared data source

  1. Create a new Visual Studio project or open an existing one.
  2. In the Visual Studio project, add a Page Report or a RDL Report template to create a new report. See Adding an ActiveReport to a Project for further details.
  3. In the Report Explorer, click the Add icon on the top left and select Data Source...
  4. In the Report Data Source dialog that appears, go to the General page and set the following properties to create a connection to an OleDb data source.
    • Name: Any Name
    • Type: Microsoft OleDB Provider

    Under Connection, go to the Connection Properties tab and set:

    • OLE DB Provider: Microsoft.Jet.OLEDB.4.0
    • Server or file Name: Your .mdb file location
  5. In the Report Data Source dialog, click the OK button to close the dialog. A data source node appears in the Report Explorer.
  6. In the Report Explorer, right-click the data source and select Share Data Source.
  7. In the Save Shared Data Source File dialog that appears, enter the file name and click the Save button to save the file in RDSX format. Notice that the data source icon changes to show sharing.
    Data Source Icon Shared Data Source Icon

To edit a shared data source

These steps assume that you have already connected your report to a shared data source. See Connect to a Data Source for further information.

  1. To open the Report Data Source dialog, do one of the following:
    • In the Report Explorer, right-click a shared data source node and in the context menu that appears, select Edit.
    • In the Report Explorer toolbar, click the Edit Shared Data Source button.
  2. In the Report Data Source dialog that appears, edit the data connection information.
See Also

Concepts

Report Explorer


Bind a Page Report to a Data Source at Run Time

Bind a Page Report to a Data Source at Run Time
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Data > Bind a Page Report to a Data Source at Run Time
Show All Show All
Hide All Hide All

ActiveReports allows you to modify a data source at run time. See the following set of sample codes to connect your page report or RDL report to a data source at run time.

OleDB Data Source

To connect to an OleDB data source at run time

Use the API to set a data source and dataset on a report at run time. These steps assume that you have already added a Page Report template and placed a Viewer control on a Windows Form in your Visual Studio project. See Adding an ActiveReport to a Project and Windows Forms Viewer for further information.

Note: You can use the code example below for the SQL, Odbc, OleDB or Oracle data source binding. To do that, modify the Data Provider Type and Connection String according to the data source.
  1. From the Visual Studio toolbox, drag and drop a Table data region onto the design surface of the report.
  2. In the Table, select the following cells and go to Properties Window to set their Value property.
    Cell | Value Property
    Left Cell | =Fields!ProductID.Value
    Middle Cell | =Fields!InStock.Value
    Right Cell | =Fields!Price.Value
  3. Go to the Visual Studio Report Menu, and select Save Layout.
  4. In the Save As window that appears navigate to your project's folder and save the layout (like RuntimeBinding.rdlx) inside the bin/debug folder.
  5. Double-click the title bar of the Windows Form to create an event-handling method for the Form_Load event.
  6. Add the following code to the handler to connect to a data source, add a dataset and to supply data in the report.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form_Load event.
    Copy Code
    'create an empty page report
Dim def As New PageReport
'load the report layout
def.Load(New System.IO.FileInfo(Application.StartupPath + "\RuntimeBinding.rdlx"))
'create and setup the data source
Dim myDataSource As New GrapeCity.ActiveReports.PageReportModel.DataSource
myDataSource.Name = "Example Data Source"
myDataSource.ConnectionProperties.DataProvider = "OLEDB"
myDataSource.ConnectionProperties.ConnectString = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=[User Documents folder]\GrapeCity\ActiveReports 10\Samples\Data\Reels.mdb"
'setup the dataset
Dim myDataSet As New GrapeCity.ActiveReports.PageReportModel.DataSet()
Dim myQuery As New GrapeCity.ActiveReports.PageReportModel.Query()
myDataSet.Name = "Example Data Set"
myQuery.DataSourceName = "Example Data Source"
myQuery.CommandType = GrapeCity.ActiveReports.PageReportModel.QueryCommandType.TableDirect
myQuery.CommandText = GrapeCity.ActiveReports.Expressions.ExpressionInfo.FromString("Product")
myDataSet.Query = myQuery
' add fields
Dim _field As New GrapeCity.ActiveReports.PageReportModel.Field("ProductID", "ProductID", Nothing)
myDataSet.Fields.Add(_field)
_field = New GrapeCity.ActiveReports.PageReportModel.Field("InStock", "InStock", Nothing)
myDataSet.Fields.Add(_field)
_field = New GrapeCity.ActiveReports.PageReportModel.Field("Price", "Price", Nothing)
myDataSet.Fields.Add(_field)
'bind the data source and the dataset to the report
def.Report.DataSources.Add(myDataSource)
def.Report.DataSets.Add(myDataSet)
def.Run()
Viewer1.LoadDocument(def.Document)

    To write the code in C#

    C# code. Paste INSIDE the Form_Load event.
    Copy Code
    //create an empty page report
GrapeCity.ActiveReports.PageReport def = new GrapeCity.ActiveReports.PageReport();
//load the report layout
def.Load(new System.IO.FileInfo(Application.StartupPath + "\RuntimeBinding.rdlx"));
//create and setup the data source
GrapeCity.ActiveReports.PageReportModel.DataSource myDataSource = new GrapeCity.ActiveReports.PageReportModel.DataSource();
myDataSource.Name = "Example Data Source";
myDataSource.ConnectionProperties.DataProvider = "OLEDB";
myDataSource.ConnectionProperties.ConnectString = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=[User Documents folder]\\GrapeCity\\ActiveReports 10\\Samples\\Data\\Reels.mdb";
//setup the dataset
GrapeCity.ActiveReports.PageReportModel.DataSet myDataSet = new GrapeCity.ActiveReports.PageReportModel.DataSet();
GrapeCity.ActiveReports.PageReportModel.Query myQuery = new GrapeCity.ActiveReports.PageReportModel.Query();
myDataSet.Name = "Example Data Set";
myQuery.DataSourceName = "Example Data Source";
myQuery.CommandType = GrapeCity.ActiveReports.PageReportModel.QueryCommandType.TableDirect;
myQuery.CommandText = GrapeCity.ActiveReports.Expressions.ExpressionInfo.FromString("Product");
myDataSet.Query = myQuery;
// add fields
GrapeCity.ActiveReports.PageReportModel.Field _field = new
GrapeCity.ActiveReports.PageReportModel.Field("ProductID", "ProductID", null);
myDataSet.Fields.Add(_field);
_field = new GrapeCity.ActiveReports.PageReportModel.Field("InStock", "InStock", null);
myDataSet.Fields.Add(_field);
_field = new GrapeCity.ActiveReports.PageReportModel.Field("Price", "Price", null);
myDataSet.Fields.Add(_field);
//bind the data source and the dataset to the report
def.Report.DataSources.Add(myDataSource);
def.Report.DataSets.Add(myDataSet);
def.Run();
viewer1.LoadDocument(def.Document);
  7. Press F5 to run the Application.

Unbound Data Source

To connect to unbound data sources at run time, you can use the DataSet provider or the Object provider with the LocateDataSource event. The reporting engine raises the LocateDataSource event when it needs input on the data to use.

DataSet provider

With the DataSet provider, the ConnectionString and Query settings vary depending on how you connect to data.

To use the LocateDataSource event to bind the report to data, leave the ConnectionString blank.

  • If LocateDataSource returns a DataSet, the Query is set to the DataSet table name.
  • If LocateDataSource returns a DataTable or DataView, the Query is left blank.

To bind a report to a dataset located in a file, set the ConnectionString to the path of the file, and set the Query to the DataSet table name.

Limitations of the Dataset Provider

  • Relationship names that have periods in them are not supported.
  • Fields in nested relationships only traverse parent relationships (e.g. FK_Order_Details_Orders.FK_Orders_Customers.CompanyName).

Parent Table Fields

To request a field from a parent table, prefix the field name with the name of the relation(s) that must be traversed to navigate to the appropriate parent table. Separate field names and relations with periods.

For example, consider a main table named OrderDetails which has a parent table named Orders. A relation named Orders_OrderDetails defines the relationship between the two tables. Use a field with the syntax below to access the OrderDate from the parent table:

Orders_OrderDetails.OrderDate

Use this same technique to traverse multiple levels of table relations. For example, consider that the Orders table used in the prior example has a parent table named Customers and a relation binding the two called Customers_Orders. If the CommandText specifies the main table as OrderDetails, use the following syntax to get the CustomerName field from the parent table:

Customers_Orders.Orders_OrderDetails.CustomerName
Note: Ambiguity can occur if a field and a relation have the same name. This is not supported.

To use the Dataset Provider

You can use the API to set a dataset on a report at run time.

The Dataset provider returns a data table. All fields in the data table are available. To use the Dataset provider as a report's data source, set up a report definition and runtime, and attach the page document to a LocateDataSourceEventHandler.

These steps assume that you have already added a Page Report template and placed a Viewer control on a Windows Form in your Visual Studio project. See Adding an ActiveReport to a Project and Windows Forms Viewer for further information.

  1. In the Report Explorer, go to the DataSources node and right-click to select Add Data Source.
  2. In the Report Data Source dialog that appears, set Type to DataSetProvider and close the dialog. A data source node appears in the ReportExplorer.
  3. Right-click the data source node and to select Add Data Set.
  4. In the DataSet dialog that appears select the Fields page.
  5. On the Fields page, add a fields like =Fields!ProductID.Value and =Fields!InStock.Value.
  6. Click OK to close the dialog. Nodes with the field names appear under the dataset name.
  7. From the Visual Studio toolbox ActiveReports 10 Page Report tab, drag a Table data region onto the design surface of the report.
  8. From the ReportExplorer, add the newly added fields onto cells in the detail row of the Table and save the report.
  9. In the Visual Studio Solution Explorer, right-click YourProjectName and select Add > Class.
  10. In the Add New Item window that appears, rename the class to DataLayer.cs or .vb and click Add.
  11. In the Solution Explorer, double-click the DataLayer.cs or .vb to open the code view of the class and paste the following code inside it.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste inside the DataLayer class.
    Copy Code
    Imports GrapeCity.ActiveReports.Expressions.ExpressionObjectModel
Imports System.Globalization
Imports System.Data.OleDb

Friend NotInheritable Class DataLayer
    Private _datasetData As System.Data.DataSet

    Public Sub New()
        LoadDataToDataSet()
    End Sub

    Public ReadOnly Property DataSetData() As System.Data.DataSet
        Get
           Return _datasetData
        End Get
    End Property

    Private Sub LoadDataToDataSet()
        Dim connStr As String = "Provider=Microsoft.Jet.OLEDB.4.0;Persist Security Info=False;
                Data Source=[User Documents folder]\\GrapeCity\\ActiveReports 10\\Samples\\Data\\Reels.mdb"
        Dim productSql As String = "SELECT top 100 * FROM Product"

        _datasetData = New DataSet()
        Dim conn As New OleDbConnection(connStr)
        Dim cmd As OleDbCommand = Nothing
        Dim adapter As New OleDbDataAdapter

       cmd = New OleDbCommand(productSql, conn)
       adapter.SelectCommand = cmd
       adapter.Fill(_datasetData, "Products")
    End Sub

End Class

    To write the code in C#

    C# code. Paste inside the DataLayer class.
    Copy Code
    using System;
using System.Data;
using System.Data.OleDb;

internal sealed class DataLayer
{
    private DataSet dataSetData;
        public DataLayer()
        {
                LoadDataToDataSet();
        }

        public DataSet DataSetData
        {
                get { return dataSetData; }
        }

        private void LoadDataToDataSet()
        {
        string connStr = @"Provider=Microsoft.Jet.OLEDB.4.0;Persist Security Info=False;
                Data Source=[User Documents folder]\\GrapeCity\\ActiveReports 10\\Samples\\Data\\Reels.mdb";
        string productSql = "SELECT * From Product";

                dataSetData = new DataSet();
        OleDbConnection conn = new OleDbConnection(connStr);
        OleDbCommand cmd = new OleDbCommand(productSql, conn);
        OleDbDataAdapter adapter = new OleDbDataAdapter();
        adapter.SelectCommand = cmd;
        adapter.Fill(dataSetData, "Products");
        }
}
    Note: The DataSetDataSource sample provides context on how to create the DataLayer class, used in the code below. The DataSetDataSource sample is included in the ActiveReports installation and is located in the [UserDocumentFolder]\GrapeCity Samples\ActiveReports 10\Page Reports\RDL\API folder.
  12. Double-click the title bar of the Windows Form to create an event-handling method for the Form_Load event and add the following code to the handler.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form_Load event.
    Copy Code
    LoadReport()
    Visual Basic.NET code. Paste INSIDE the class declaration of the form.
    Copy Code
    Dim WithEvents runtime As GrapeCity.ActiveReports.Document.PageDocument

Private Sub LoadReport()
    Dim rptPath As New System.IO.FileInfo("..\..\YourReportName.rdlx")
    'Create a report definition that loads an existing report.
    Dim definition As New GrapeCity.ActiveReports.PageReport(rptPath)
    'Load the report definition into a new page document.
    runtime = New GrapeCity.ActiveReports.Document.PageDocument(definition)
    'Attach the runtime to an event. This line of code creates the event shell below.
    Viewer1.LoadDocument(runtime)
End Sub

'ActiveReports raises this event when it cannot locate a report's data source in the usual ways.
Private Sub runtime_LocateDataSource(ByVal sender As Object, ByVal args As GrapeCity.ActiveReports.LocateDataSourceEventArgs) Handles Runtime.LocateDataSource
    Dim dl = New DataLayer
    args.Data = dl.DataSetData.Tables("Products")
End Sub

    To write the code in C#

    C# code. Paste INSIDE the Form_Load event.
    Copy Code
    LoadReport();
    C# code. Paste INSIDE the class declaration of the form.
    Copy Code
    private void LoadReport()

{
   System.IO.FileInfo rptPath = new System.IO.FileInfo("..\\..\\YourReportName.rdlx");
   //Create a report definition that loads an existing report.
   GrapeCity.ActiveReports.PageReport definition = new GrapeCity.ActiveReports.PageReport(rptPath);
   //Load the report definition into a new page document.
   GrapeCity.ActiveReports.Document.PageDocument runtime = new GrapeCity.ActiveReports.Document.PageDocument(definition);
   //Attach the runtime to an event. This line of code creates the event shell below.
   runtime.LocateDataSource += new GrapeCity.ActiveReports.LocateDataSourceEventHandler(runtime_LocateDataSource);
   viewer1.LoadDocument(runtime);
}

//ActiveReports raises this event when it cannot locate a report's data source in the usual ways.
private void runtime_LocateDataSource(object sender, GrapeCity.ActiveReports.LocateDataSourceEventArgs args)
{

   DataLayer dl = new DataLayer();
   args.Data = dl.DataSetData.Tables["Products"];
}

Object Provider

Use the API to bind a report data source to a collection of objects. To bind the Object provider to a report, set up a report definition and a page document, and attach the page document to a LocateDataSourceEventHandler. Create a public class which sets up a property name to which the data field can bind.

The Object provider data source must have a dataset with the Query left blank and fields that correspond to the fields of your Object provider data source. Add these fields manually in the DataSet Dialog under Fields.

When using the Object provider, always leave the report's ConnectionString blank because it uses the LocateDataSource event to bind to an Object. Set the Query to one of these values:

To use the Object Provider

These steps assume that you have already added a Page Report template and placed a Viewer control on a Windows Form in your Visual Studio project. See Adding an ActiveReport to a Project and Windows Forms Viewer for further information.

  1. In the Report Explorer, go to the DataSources node and right-click to select Add Data Source.
  2. In the Report Data Source dialog that appears, set Type to ObjectProvider and close the dialog. A data source node appears in the ReportExplorer.
  3. Right-click the data source node and in the DataSet dialog that appears select the Fields page.
  4. In the Fields page, add a field like =Fields!name.Value and click ok to close the dialog. A node with the field name appears under the dataset name.
  5. From the Visual Studio toolbox ActiveReports 10 Page Report tab, drag a Table data region onto the design surface of the report.
  6. From the ReportExplorer, add the newly added field onto a cell in the detail row of the Table.
  7. Save the report as DogReport.rdlx.
  8. In the Solution Explorer, right-click the Form and select View Code to open the Code View.
  9. In the Code View of the form, paste the following code inside the class declaration.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the class declaration of the form.
    Copy Code
    ' Create a class from which to call a property.
Public Class dog
   Private _name As String
   Public Property name() As String
      Get
         Return _name
      End Get
      Set(ByVal value As String)
         _name = Value
      End Set
   End Property
End Class
' Create an array to contain the data.
Dim dogArray As System.Collections.ArrayList
' Create a method to populate the data array.
Private Sub LoadData()
   dogArray = New System.Collections.ArrayList()
   Dim dog1 As New dog()
   dog1.name = "border collie"
   dogArray.Add(dog1)
   dog1 = New dog()
   dog1.name = "cocker spaniel"
   dogArray.Add(dog1)
   dog1 = New dog()
   dog1.name = "golden retriever"
   dogArray.Add(dog1)
   dog1 = New dog()
   dog1.name = "shar pei"
   dogArray.Add(dog1)
End Sub

    To write the code in C#

    C# code. Paste INSIDE the class declaration of the form.
    Copy Code
    // Create a class from which to call a property.
public class dog
{
   private string _name;
   public string name
  {
      get { return _name; }
      set { _name = value; }
   }
}
// Create an array to contain the data.
System.Collections.ArrayList dogArray;
// Create a method to populate the data array.
private void LoadData()
{
   dogArray = new System.Collections.ArrayList();
   dog dog1 = new dog();
   dog1.name = "border collie";
   dogArray.Add(dog1);
   dog1 = new dog();
   dog1.name = "cocker spaniel";
   dogArray.Add(dog1);
   dog1 = new dog();
   dog1.name = "golden retriever";
   dogArray.Add(dog1);
   dog1 = new dog();
   dog1.name = "shar pei";
   dogArray.Add(dog1);
}
  10. Set up the report and add a handler for the LocateDataSource event.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form_Load event.
    Copy Code
    Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
   ' Create file info with a path to the report in your project.
   Dim fi As New System.IO.FileInfo("..\\..\\DogReport.rdlx")
   ' Create a report definition using the file info.
   Dim repDef As New GrapeCity.ActiveReports.PageReport(fi)
   ' Create a page document using the report definition.
   Dim runt As New GrapeCity.ActiveReports.Document.PageDocument(repDef)
   ' Create a LocateDataSource event for the runtime.
   AddHandler runt.LocateDataSource, AddressOf runt_LocateDataSource
  ' Display the report in the viewer. The title can be any text.
   Viewer1.LoadDocument(runt)
End Sub

    To write the code in C#

    C# code. Paste INSIDE the Form_Load event.
    Copy Code
    private void Form1_Load(object sender, EventArgs e)
{
   // Create file info with a path to the report in your project.
   System.IO.FileInfo fi = new System.IO.FileInfo("..\\..\\DogReport.rdlx");
   // Create a report definition using the file info.
   GrapeCity.ActiveReports.PageReport repDef = new GrapeCity.ActiveReports.PageReport(fi);
   // Create a page document using the report definition.
   GrapeCity.ActiveReports.Document.PageDocument runt = new GrapeCity.ActiveReports.Document.PageDocument(repDef);
   // Create a LocateDataSource event for the runtime.
   runt.LocateDataSource += new GrapeCity.ActiveReports.LocateDataSourceEventHandler(runt_LocateDataSource);
   // Display the report in the viewer. The title can be any text.
   viewer1.LoadDocument(runt);
}
  11. Use the LocateDataSource event to load data from the object.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the class declaration of the form.
    Copy Code
    Private Sub runt_LocateDataSource(ByVal sender As Object, ByVal args As GrapeCity.ActiveReports.LocateDataSourceEventArgs)
   If dogArray Is Nothing Then LoadData()
   args.Data = dogArray
End Sub

    To write the code in C#

    C# code. Paste INSIDE the class declaration of the form.
    Copy Code
    void runt_LocateDataSource(object sender, GrapeCity.ActiveReports.LocateDataSourceEventArgs args)
{
   if (dogArray == null)
   {
      LoadData();
   }
   args.Data = dogArray;
}
  12. Press F5 to run the application.
See Also

Concepts

Data Sources and Datasets


Work with Report Controls and Data Regions

Work with Report Controls and Data Regions
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions

Learn to perform common tasks with ActiveReports with quick how-to topics.

This section contains information about how to

Grouping in a FixedPage
Learn how group data on the fixed page to apply grouping on the entire report instead of a single control.
Grouping in a Data Region
Learn how to group data in a data region like Table, List, BandedList, Tablix and Chart.
Set Detail Grouping In Sparklines
Learn how to set detail grouping to reflect a trend in your data with sparklines.
Setting Filters
Learn how set filters in your report and limit the data you want to display.
Set FixedSize of a Data Region
Learn how to set the FixedSize property of a Data Region using the resize handler and the Properties window.
Work with Map
Learn how to work with layers and data in a Map control.
Add Table Of Contents
Learn how to use the TableOfContents control to create an organized hierarchy.
See Also
Create Common Page Reports


Grouping in a FixedPage

Grouping in a FixedPage
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Grouping in a FixedPage

In a Page Report, you can group your data on the fixed page. A group set on the fixed page, applies to the entire report including the controls within the report. Therefore, once you set grouping here, you may decide not to group individual data regions.

Use the following steps to understand grouping on a fixed page. These steps assume that you have already added a Page Report template, connected it to a data source and created a dataset. See Adding an ActiveReport to a Project and Connect to a Data Source for further information.

Note: This topic uses the Movie table in the Reels database. By default, the Reels.mdb file is located in [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.

To set grouping on a Fixed Page

  1. Right-click the gray area outside the design surface and select Fixed Layout Settings or with the fixed page selected, under the Properties Window, click the Property dialog link to open the FixedPage dialog.
  2. On the Grouping page, in the General tab, under Group on enter the field name or expression on which you want to group the data. For example, =Fields!YearReleased.Value.
    Note: A default group name like FixedPage1_Group appears under Name, once you set the group. To modify the group name, add a field name or expression under Group on to enable the Name option and enter a new name.
  3. Under the Document map label field, you can optionally set a label to add the item to the document map.
  4. Click OK to close the dialog.
  5. Drag and drop a data region, like a Table onto the design surface and set data inside its cells.
  6. Go to the Preview Tab to view the result. You'll notice that the data appears in groups sorted according the YearReleased field on each report page.
See Also
Grouping in a Data Region

Concepts

Grouping Data (Page Layout)


Grouping in a Data Region

Grouping in a Data Region
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Grouping in a Data Region
Show All Show All
Hide All Hide All

In a page report/RDL report, group your data from a data region on fields and expressions. Each data region provides grouping in a different way.

Use the steps below to learn how to set groups in each data region. These steps assume that you have already added a Page Report/RDL Report template and connected it to a data source. See Adding an ActiveReport to a Project, Connect to a Data Source and Add a Dataset for more information.

Note: This topic uses examples from the Movie table in the Reels database. By default, in ActiveReports, the Reels.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\Reels.mdb.

To set grouping in a Table

To group data in a Table data region, add group header and footer rows to the table or set detail grouping.

To add groups in a Table

  1. From the Visual Studio toolbox, drag and drop a Table data region onto the design surface.
  2. With the Table selected on the report, under the Properties window, click the Property dialog link to open the Table dialog.
  3. In the table dialog that appears go to the Groups page and click the Add (+) button to add a group manually.
  4. In this dialog, on the General tab, under Group on enter the field name or expression on which you want to group the data. For e.g., =Fields!YearReleased.Value.
    Note: A default group name like Table1_Group1 appears under Name, until you set the grouping expression under Group On, after which you can modify the group name.
  5. Under the Document map label, you can optionally set a label to add the item to the document map. See Document Map for further information.
  6. Under Parent group, you can optionally set the parent group for a recursive hierarchy.
  7. Click OK to close the dialog. Group header and group footer rows appear right above and below the table details row.
  8. Drag and drop fields onto the Table data region and in the group header row, add the field on which the grouping is set.
  9. Preview the report to see the result.
Tip: You can sort, filter, set page breaks or repeat headers for your grouped data in the other tabs of the Table-Groups dialog.

To set detail grouping in a Table

Detail Grouping is useful when you do not want to repeat values within the data on display in the report.

  1. From the Visual Studio toolbox, drag and drop a Table data region onto the design surface.
  2. With the Table selected on the report, under the Properties Window, click the Property dialog link to open the Table dialog > Detail Grouping page.
  3. In the Detail Grouping page, under Group on enter the expression on which you want to group the data. For e.g., =Fields!YearReleased.Value
    Note: A default group name like Table1_Detail_Group1 appears under Name, until you set the grouping expression under Group On, after which you can modify the group name.
  4. Under the Document map label, you can optionally set a label to add the item to the document map. See Document Map for further information.
  5. Under Parent group, you can optionally set the parent group for a recursive hierarchy.
  6. Click OK to close the dialog.
  7. Drag and drop fields onto the Table data region and go to the preview tab to see grouped data.
Tip: You can filter, set page breaks or set visibility for your grouped data in the other tabs of the Table-Detail Grouping page.

To set detail grouping in a List

To group data in a List data region, set detail grouping. Detail Grouping is useful when you do not want to repeat values within the data on display in the report.

  1. From the Visual Studio toolbox, drag and drop a List data region onto the design surface.
  2. With the List selected on the report, under the Properties window, click the Property dialog link to open the List dialog > Detail Grouping page.
  3. In the Detail Grouping page, under Group on enter the expression on which you want to group the data. For e.g., =Fields!YearReleased.Value.
    Note: A default group name like List1_Detail_Group appears under Name, until you set the grouping expression under Group On, after which you can modify the group name.
  4. Under the Document map label field, you can optionally set a label to add the item to the document map. See Document Map for further information.
  5. Under the Parent group field, you can optionally set the parent group for a recursive hierarchy.
  6. Click OK to close the dialog.
  7. Drag and drop fields or other data regions onto the List data region and go to the preview tab to see grouped data.
Tip: You can place lists within lists to create nested grouping. You can also filter, set page breaks or set sorting for your grouped data in the other tabs of the List-Detail Grouping page.

To set grouping in a BandedList

To group data in a BandedList data region, add the BandedList group header and footer row.

  1. From the Visual Studio toolbox, drag and drop a BandedList data region onto the design surface.
  2. Right-click the BandedList data region and select Insert Group to open the Banded List-Groups dialog.
    OR
    With the BandedList selected on the report, under the Properties Window, click the Property dialog link to open the Banded List dialog > Groups page. However, you have to click the Add (+) button and add the group manually in this case.
  3. In the Groups page, under Group on enter the field name or expression on which you want to group the data. For e.g., =Fields!YearReleased.Value.
    Note: A default group name like BandedList1_Group1 appears under Name, until you set the grouping expression under Group On, after which you can modify the group name.
  4. Under the Document map label field, you can optionally set a label to add the item to the document map. See Document Map for further information.
  5. Under Parent group you can set the parent group for a recursive hierarchy.
  6. Click the OK to close the dialog.
  7. Drag and drop fields onto the BandedList data region and go to the preview tab to see grouped data.

To set grouping in a Chart

To group data in a Chart data region, set grouping for categories or series. In a Chart, you can set groups directly on the design surface or add category groups and series groups manually.

To dynamically group a Chart category or series

  1. From the Visual Studio toolbox, drag and drop a Chart data region onto the design surface.
  2. From the Report Explorer,
  3. Drag a field near the lower edge of the Chart and drop it onto the part that reads Drop category fields here. This action groups the categorized chart data on the field set here.
  4. Drag a field near the upper edge of the Chart and drop it onto the part that reads Drop data fields here. This adds data which is to be grouped to the chart.
  5. Drag a field near the right edge of the Chart and drop it onto the part that reads Optionally drop series fields here. This action groups data on series.

To manually group a Chart category or series

  1. From the Visual Studio toolbox, drag and drop a Chart data region onto the design surface.
  2. With the Chart data region selected on the report, under the Properties Window, click the Chart Data link to open the Chart Data dialog.
  3. In the Chart Data dialog, go to the Category Groups page and click the Add button to add a new group.
  4. Enter an expression under Group on on which you want to categorize the data. For e.g., =Fields!Title.Value.
  5. In the Chart Data dialog, go to the Series Groups page and click the Add button to add a new group.
  6. Enter an expression under Group on on which you want to group your series data. For e.g., =Fields!Country.Value.
  7. Click OK to close the dialog.
  8. Drag the UserRating field near the upper edge of the Chart and drop it onto the part that reads, Drop data fields here. This adds data which is to be grouped to the chart.
Note: A default group name like Chart1_CategoryGroup1 or Chart1_SeriesGroup1 appear under Name, until you set the grouping expression under Group On, after which you can modify the group name.

To set grouping in a Tablix

To group data in a Tablix data region, set row and column group expressions.

  1. From the Visual Studio toolbox, drag a Tablix data region and drop it onto the report design surface.
  2. Right-click the row or column where you want to insert a group, click Add Column Group, and select the type of grouping you want to implement. The group is added and appears in the Group Editor window.
  3. In the Group Editor, select the new group so that its properties display in the Properties window.
  4. In the Properties window, expand the Group property node and click the ellipsis button next to the GroupExpressions property to open the ExpressionDesigner Collection Editor.
  5. In the ExpressionDesigner Collection Editor that appears, click Add to create a new group hierarchy member.

  6. Select the group member from the Members list and in the property grid to the right, enter an expression to group the data. For example: =Fields!YearReleased.Value
  7. Click OK to close the dialog.
  8. Drag and drop fields in the body area (bottom right corner) of the Tablix data region and go to the Preview Tab to view the result.
See Also
Grouping in a FixedPage
Tablix
Tablix Reports

Concepts

Grouping Data (Page Layout)


Set Detail Grouping In Sparklines

Set Detail Grouping In Sparklines
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Set Detail Grouping In Sparklines

Applying detail grouping to a sparkline helps to visualize data clearly – the sparkline value is displayed as a set of sparklines grouped by a detail grouping value. The following steps take you through how to show trends in analyzed data when detail grouping is set with Sparklines.

These steps assume that you have already added a Page Report/RDL Report template to your project, connected it to a data source and added a dataset. See Adding an ActiveReport to a Project, Connect to a Data Source and Add a Dataset for more information.

Note: This topic uses examples from the SalesByGenre table in the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.
  1. From the toolbox, drag a Table data region onto the report design surface.
  2. With the table selected, set the following:
    • Set the DataSetName property (For example, SalesByGenre).
    • Right-click the table handle to the left of the Detail row and select Insert Row Below or Insert Row Above from the menu and add another detail row to the table.
    • Hover your mouse over the first Textbox located in the Detail row column to make the Field Selection Adorner appear. Click this adorner to display a list of available fields from the data set, select a field (For example, GenreName).
      Note: This automatically places an expression in the detail row and simultaneously places a static label Genre Name in the header row of the same column.
  3. From the toolbox, drag a Sparkline control to the second detail row of the table on your report and set the following in the Properties Window.
    • Set the SparklineType property to Line (by default).
    • Set the DataSetName property to a data set (For example, SalesByGenre).
    • Set the SeriesValue property by selecting <Expression...>. In the Expression Editor under Fields, expand the Fields (SalesByGenre) node and select a numeric field from the connected data set (for example, =Fields!Profit.Value). Click the OK button to accept the change.
    • Set the LineColor property to Gray.
    • Set the MarkerColor property to Blue.
  4. To apply the detail grouping to the sparkline, right-click the Table data region and go to Properties Window to select the Properties dialog command at the bottom.
  5. In the Table dialog that appears, select the Detail Grouping.
  6. In the General tab, under Group on, select an expression from the drop-down list on which to group the data (for example, =Fields!GenreName.Value).
  7. Click the OK button to close the dialog and save the changes.
  8. Go to the preview tab to view the sparkline you have added to your report.

This set of sparklines display the profit value grouped by the movie genres.


Setting Filters

Setting Filters
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Setting Filters
Show All Show All
Hide All Hide All

Normally you can filter your data using parameters in a query, but if your data source does not support parameters you can use filters. You can set filters on the following:

  • DataSet
  • Data Region
  • Groups in a Data Region

In a Page Report, you can also set filters on the page through the FixedPage dialog.

Use the following steps to create filters in a page report and RDL report. These steps assume that you have already added a Page Report/RDL Report template and have a data connection and a dataset in place. See Adding an ActiveReport to a Project, Connect to a Data Source and Add a Dataset for more information.

Set filters on a DataSet

When you set a filter on a dataset, any control you add to the design surface can utilize this filtered data.

  1. In the Report Explorer, right-click the DataSet node and select Edit.
  2. In the DataSet dialog that appears, select the Filters page and click the Add (+) icon to add a new filter for the data set. By default, an empty filter expression gets added to the filter list.
  3. Under Expression, enter an expression or use the Expression Editor to provide the expression on which to filter data. For example, =Fields!YearReleased.Value
  4. Under Operator, select an operator from the list to decide how to compare the Expression with the Value. For example, set a GreaterThan operator on the Expression above. See Filtering for a list of available operators and their description.
  5. Under Value, enter a value or set an expression using the Expression Editor with which to compare the expression results. For example, 2000 to represent the year 2000.

The resultant filter looks like the following.
=Fields!YearReleased.Value > 2000

Set filters in a Data Region

When you set a filter in a data region, you can limit the amount of data available for use inside that data region.

  1. With the data region selected on the report, under the Properties window, click the Property dialog link. This is a command to open the corresponding data region dialog. See Properties Window for more on how to access commands.
    Note: In a Chart data region, right-click the data region and choose the Chart data option to open the Chart Data dialog.
  2. In the data region dialog that appears, select the Filters page and click the Add (+) icon to add a new filter for the data region. By default, an empty filter expression gets added to the filter list.
  3. Under Expression, enter an expression or use the Expression Editor to provide the expression on which to filter data. For example, =Fields!UserRating.Value
  4. Under Operator, select an operator from the list to decide how to compare the Expression with the Value. For example, set a LessThan operator on the Expression above. See Filtering for a list of available operators and their description.
  5. Under Value, enter a value or set an expression using the Expression Editor with which to compare the expression results. For example, 6 to represent the Rating 6.

The resultant filter looks like the following.
=Fields!UserRating.Value < 6

Set filters on groups in a Data Region

You can also set filters on grouped data in a data region. The following example uses the Table data region to show filtering on groups.

  1. In the report, set grouping on a data region. For example, on a Table data region, set grouping on the =Fields!YearReleased.Value field. See Grouping in a Data Region for further details.
  2. With the data region selected on the report, under the Properties window, click the Property dialog link. This is a command to open the corresponding data region dialog. See Properties Window for more on how to access commands.
    Note: In a Chart data region, right-click the data region and choose the Chart data option to open the Chart Data dialog.
  3. In the Table dialog, go to the Groups tab and select the Group.
  4. After selecting the group, go to the Filters tab and click the Add (+) icon to add a new filter. By default, an empty filter expression gets added to the filter list.
  5. Under Expression, enter an expression or use the Expression Editor to provide the expression on which to filter data. For example, =Fields!YearReleased.Value
  6. Under Operator, select an operator from the list to decide how to compare the Expression with the Value. For example, GreaterThan operator set on the Expression above. See Filtering for a list of available operators and their description.
  7. Under Value, enter a value or set an expression using the Expression Editor with which to compare the expression results. For example, 2000 to represent the year 2000.

The resultant filter looks like the following.
=Fields!YearReleased.Value > 2000
See Also

Concepts

Filtering


Set FixedSize of a Data Region

Set FixedSize of a Data Region
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Set FixedSize of a Data Region

FixedSize property of a Page Report is used to set the exact height or width (or both) that the data region will occupy at runtime. Using this property, you can control the number of records that are displayed on each page.

In case there are more records to display than what FixedSize can accommodate, the remaining records get displayed on the next page. However, in case there is an OverflowPlaceHolder control bound to a data region on the same page, the remaining records are displayed at the location where the OverflowPlaceHolder control is placed. When you link a data region to an OverflowPlaceHolder, this control gets its Size property value from the Size of the data region it is linked with. However, it is also possible to change the Size (Height and Width) property values of OverflowPlaceHolder control based on the requirement of your Page Report.

Caution: The Size of an OverflowPlaceHolder cannot be changed to a value which is less than the Size of a data region it is linked with.

Using the FixedSize Property in Data Region

The significance of the FixedHeight and FixedWidth property depends on the data region that is being used. For example, in case of Table data region, only the FixedHeight property holds importance as the Table control always grows vertically to accommodate excessive data, while in case of Tablix data region both FixedHeight and FixedWidth properties are important as the control expands both vertically and horizontally to fit excessive data.

The table below show the data regions that contains the FixedSize property and their support for FixedHeight and FixedWidth properties:

Data Region | Supported Property
Table | FixedHeight
Tablix | FixedHeight and FixedWidth both
List | FixedHeight
BandedList | FixedHeight
Calendar | FixedHeight

Setting FixedSize Property

You can use the Properties Window to set the FixedHeight and FixedWidth properties of a data region manually, or use the resize handlers that appears around the data region to set the FixedSize.

Follow these steps to set FixedSize through the Properties window:

  1. From the Visual Studio toolbox, drag and drop a data region like List or a Table control onto the design surface.
  2. On the design surface, click the data region to select it and go to the Properties Window.
  3. In the Properties Window, locate and expand the FixedSize property node to assign values for the Height and Width.

Follow these steps to set FixedSize using the resize handlers:

  1. From the Visual Studio toolbox, drag and drop a data region like List or a Table control onto the design surface. Notice the resize handlers that appear around the data region.
  2. Use mouse to drag the resize handlers to set the FixedSize area of a data region.


Work with Map

Work with Map
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Work with Map

Learn using Map data region in Page Reports/RDL Reports.

This section contains information about how to:

Create a Map
Learn how to add and create a Map in a Report.
Work with Data
Learn how to add and work with data in a Map control.
Work with Layers
Learn how to use different layers to display different data on a Map data region.


Create a Map

Create a Map
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Work with Map > Create a Map
Show All Show All
Hide All Hide All

The Map data region shows your business data against a geographical background. This topic illustrates how to create a Map and modify its appearance.

These steps assume that you have added a page layout template to your project and have a data connection in place. See Adding an ActiveReport to a Project and Connect to a Data Source for further information.

To add a map to the report

  1. From the Visual Studio toolbox, drag a Map control onto the design surface.

  2. In the Select a Map Template wizard that appears, select a map template from the following options:
    • Empty map: An empty map without any predefined data.
    • USA map: A map with the predefined polygon layer that contains the embedded spatial data with the USA map.
    • From ESRI file: Select from your local .shp file, the shapefile spatial data format that complies with the Environmental Systems Research Institute, Inc. (ESRI). An ESRI Shapefile is a collection of files, where a .shp file defines the geographical or geometrical shapes and the .dbf file provides attributes for the shapes in the .shp file. To successfully add spatial data using this option, both files (.shp and .dbf) must be copied to the same folder. ESRI files are available on public domain data sources on the Web, including government and university sites. For more information, go to www.census.gov/geo/maps-data/data/tiger.html.

To modify the appearance of the map

  1. On the design surface, select the Map control and click the Property dialog link in the command section that appears below the properties window.

  2. In the Map dialog that appears, on the General page, enter "Map" in the Name textbox. You can also make modifications in properties that control the smoothing mode of all map elements (Antialiasing and Antialiasing quality).

  3. On the Visibility page of the dialog, you can setup the visibility mode of the map.

  4. On the Appearance page of the dialog, you can make modifications to the border width, style, color and background color.

  5. On the Data Output page of the dialog, choose from Auto, Yes or No to decide whether to include this map in the XML output. Also, if you choose to include this map in the XML output, then in Element Name, enter a name to be used in the XML output for this map. Choosing Auto will include the map in the XML output.

  6. Click OK to close the dialog.

To add a legend to the map

A legend on a map provides valuable information to users for interpreting the map data visualization rules such as color, size, and marker type differences for map elements on a layer. By default, a single Legend item already exists in the legends collection which can be used by all layers to display items. You can also create additional legends to use them individually with layers that have associated rules to display items in the legend. Use these steps to learn adding and setting a legend on a map:

  1. On the design surface, select the Map control.
  2. In the Properties window, click the Legends (Collection) property and then click the ellipsis (...) button that appears.

  3. In the LegendDesigner Collection Editor that appears, click Add under the Members list of legends. Legend1 with the default legend settings appears in the Members list.

  4. With Legend1 selected in the Members list of legends, you can make modifications to its font, border and background color settings.

  5. Click OK to close the dialog.

    Note: You can associate the newly added legend to a layer by specifying its name in the Legend Name field that appears in the Legend tab on a specific rule page of a Layer dialog. See, Use Color Rule, Marker Rule and Size Rule for more information.

To add a title to the map

Map Title describes the theme or subject of the map. The purpose of map title is to tell the viewer of what he is looking at. Use these steps to learn adding a title on a map control.

  1. On the design surface, select the Map control.
  2. In the Properties window, click the Titles (Collection) property and then click the ellipsis (...) button that appears.

  3. In the MapTitleDesigner Collection Editor that appears, in the Members list of titles, Title with the default property settings already exist.

  4. In the Properties Window, you can modify the text, font, border and the background color settings of the map title.

  5. Click OK to close the dialog.

To set the distance scale

A distance scale helps a user to understand the scale of the map. Distance on a map is not the same as the actual real-world distance, so a distance scale shows that a certain distance on the map equals a certain distance in a real-world. In distance scale, the distance is displayed in both miles and kilometers. The scale range and values are automatically calculated using the viewport boundaries, projection type, and zoom level. Use these steps to learn setting a distance scale on a map:

  1. On the design surface, select the Map control.
  2. In the Properties window, click the DistanceScale property and then click the ellipsis (...) button that appears.

  3. In the Map Distance Scale dialog that appears, on the General page, you can set the location and the color of the distance scale.
  4. On the Appearance page of the dialog, you can make modifications to the border width, style, color and background color.
  5. On the Font page of the dialog, you can make modifications to the font properties of the distance scale.
  6. On the Visibility page of the dialog, you can setup the visibility mode of the distance scale.
  7. On the Navigation page of the dialog, you can setup the interactivity features for the distance scale.
  8. Click OK to close the dialog.

To set the color scale

A color scale helps a user to understand the range of colors that are used for data visualization on a layer. A map has just one color scale and multiple layers can provide data for it. Use these steps to learn setting a color scale on a map.

  1. On the design surface, select the Map control.
  2. In the Properties window, click the ColorScale property and then click the ellipsis (...) button that appears.

  3. In the Map Color Scale dialog that appears, on the General page, you can set the location and the color of the color scale.
  4. On the Labels page of the dialog, you can make modifications to the properties of the color scale labels.
  5. On the Title page of the dialog, you can make modifications to title text and font properties of the color scale.
  6. On to the Appearance page, you can make modifications to the border width, style, color and background color.
  7. On the Font page, you can make modifications to the font properties of the color scale.

  8. On the Visibility page, you can setup the visibility mode of the color scale.

  9. On the Navigation page, you can setup the interactivity features for the color scale.

  10. Click OK to close the dialog.

To modify the appearance of the Viewport

Viewport refers to the area on the map where map data is displayed against a geographical background. It specifies the coordinates, projection system, parallels and meridians, center point, and scale of the map. In other words, it is a map element that actually display geographical data and occupies most area of the map control depending on the location and dock position of other map elements. See Map for more information.

You can modify Viewport properties to make the map look more attractive.

  1. On the design surface, select the Map control.
  2. Go to the Properties window, click the Viewport property and then click the ellipsis (...) button that appears.

  3. In the Map Viewport dialog that appears, on the General page, choose the Coordinate system. The map viewport supports the following two coordinate system:
    • Geographic: Specifies Earth coordinates by defining longitude and latitude values. If you set the CoordinateSystem property to Geographic, then you must specify the Projection property. A projection is a set of rules on how to locate three-dimensional objects onto a planar surface.
    • Planar: Specifies geometric coordinates on a two-dimensional surface by using X and Y values. and in case you set it to Geographic then set the Projection.
  4. Go to the Meridians page, set its visibility and its line and font style and color.
  5. Similarly, go to the Parallels page, set its visibility and its line and font style and color.
  6. On the View page of the dialog, choose a Center and Zoom mode. The map viewport supports the following four center and zoom modes:
    • Custom: Choose this option to specify custom values for the view center and the zoom level.
    • Center map to show a map layer: Choose this option to specify a layer and automatically, center the view on its map data. For example, center the view on LineLayer1.
    • Center map to show a map element: Choose this option to center the view on a specific data bound map element. For example, center the view on the map element where the name of the match field is [StateName] and the match value is "Washington".
    • Center map to show all map elements: Choose this option to center the view on all map elements in the layer.
    Note: Zoom and View Center level can also be set from the design surface using the zoom slider and arrow keys that appears in the View Pane of the Map control.
  7. On the Appearance page, set the Border and Background style and color of the viewport.

  8. Click OK to close the dialog.

See Also
Use Layers

Concepts

Map

Walkthroughs

Reports with Map


Work with Data

Work with Data
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Work with Map > Work with Data
Show All Show All
Hide All Hide All

The Map data region uses the following two types of data:

Spatial Data

Spatial data is a set of coordinates that defines a map element. Each map layer must have spatial data of one of the following types - a polygon, a line, or a point.

Spatial data can be either embedded in a map or can be linked to a map layer. The only difference between the two is that while having the spatial data embedded in a map, there is no separate file to locate or to keep track of when you move the report between projects or machines.

  • Embedded Spatial Data:

    Embedded spatial data can refer to the following:

    • Embedded ESRI shapefile or dataset: When you use the Embedded option in Map Layer Data Properties dialog or the From ESRI file option in the Map Wizard to import spatial data from an ESRI shapefile, the ESRI shapefile gets embedded in the Map. Similarly, if a report dataset is been used to provide spatial data to a map layer, you always have an option of embedding that spatial data in the map using the Embed Spatial Data option that appears in the layers pane. See, Use Layers to learn embedding spatial data to a map.
    • Custom data: When you add an empty layer to a map and enter spatial data manually in the LayerDesigner Collection Editor, the data entered gets embedded to the map automatically.

  • External Spatial Data:

    External spatial data can refer to the following:

    • Remote or Local ESRI shapefile: When you use the Linked option in Map Layer Data Properties dialog or use the File property in the Properties Window to specify the local or remote path/location of an ESRI shapefile, the ESRI shapefile gets linked to the Map layer. However, it remains an external source as the dependent ESRI shapefile needs to moved along with the report between projects or machines.
    • Report Dataset: When you use a report dataset to provide spatial data to a map layer and you don't embed the spatial data, it remains an external source. This requires the dependent database file to moved along with the report between projects or machines.

ActiveReports provide numerous ways to add spatial data to the map. You can either use the Map Wizard and add data from an ESRI shapefile or use the Map Layer Data Properties dialog for using advance options. You can also add spatial data from the Properties Window.

To add spatial data using Map Wizard

  1. From the Visual Studio toolbox, drag and drop a Map control onto the design surface.
  2. In the Select a Map Template wizard that appears, select From ESRI file.
  3. In the Open dialog that appears, navigate to the folder that contains the .shp and .dbf files, select the .shp file, use the Map Resolution slider to simplify vector data and click Open.

This option automatically imports the spatial data stored in the shapefile and adds a related layer to the map control.

To add spatial data using the Map Layer Data Properties dialog

The Map Layer Data Properties dialog provide the following advance options to add spatial data. For more information on Map Layer Data Properties dialog, see Map.

  • Embedded : Use this option where you want to add spatial data from an ESRI file along with an additional option of adding custom spatial data fields if required.

    To add Spatial data from an ESRI file using the Embedded option

    1. In the Map Layer Data Properties dialog, on the General page, select the Embedded option and click the Browse button.
    2. In the Open dialog that appears, navigate to the folder that contains the .shp and .dbf files.
    3. Select the .shp file, use the Map Resolution slider to simplify vector data and click Open. The fields list gets populated with spatial data fields that are added from the shapefile.
    4. In Dataset, set the name of the dataset.
    5. In the Fields list, click the Add (+) button to add a new empty spatial data field.
    6. With the newly added spatial data field selected in the list, in Field name, enter the name of the field.
    7. In Field type, set the field type of newly added spatial data field.
    8. Click OK to close the dialog.
    Note : In order to apply the new spatial data field on a layer, you must provide its value for each map layer element like polygons, points or lines in the added map layer Designer Collection Editor dialog.

  • Linked : Use this option when you just want to add spatial data from an ESRI shapefile without any additional modifications or additions .

    To add Spatial data from an ESRI file using the Linked option

    1. In the Map Layer Data Properties dialog, on the General page, select the Linked option and click the Browse button.
    2. In the Open dialog that appears, navigate to the folder that contains the .shp and .dbf files.
    3. Select the .shp file and click Open.
    4. Click OK to close the dialog.

  • Dataset : Use this option when you have a dataset that stores a spatial data field to provide spatial data to the Map. You can directly use the data fields from the dataset to display data on a map layer without setting the match fields for analytical data. Therefore, it also provides you an additional option of having different dataset for analytical data and spatial data respectively.

    To add Spatial data from a Dataset

    1. In the Map Layer Data Properties dialog, on the General page, select the Dataset option.
    2. In Dataset, set the name of the dataset.
    3. In Field name, enter the data field name that contains the spatial data.
      Caution: Simply type the name of the dataset field that contains spatial data. For example, enter value as StateName, not as =[StateName].
    4. Click OK to close the dialog.

  • Analytical : Use this option when you want to use the spatial data field from the same dataset that you may use for adding Analytical data to the layer. For using this option you need to first set the dataset for analytical data and then use the spatial data field from the dataset to provide spatial data to the map layer.

    To add spatial data from Analytical data

    1. Configure Analytical data for the Map control. See the dropdown section below to learn adding Analytical data.

      Note : Once the Analytical data has been set, the Analytical option on the General page of the Map Layer Data Properties dialog becomes active.
    2. In the Map Layer Data Properties dialog, on the General page, select the Analytical option.
    3. In Field name, enter the data field name that contains the spatial data.
      Caution: In Field name, enter the data field name as =[StateName], not as StateName.
    4. Click OK to close the dialog.

To add spatial data using Properties Window

These steps assume that you have a Map control containing at least one map data layer placed on the design surface. To learn how to add a layer to the Map control, see Use Layers.

  1. With the Map control selected, go to the Properties window, click the Layers (Collection) property and then click the ellipsis button that appears.
  2. In the LayerDesigner Collection Editor that appears, under Members, select the map data layer you want to use and expand the SpatialData property.
  3. In Type, choose the spatial data source of the layer from the following supported options:
    • Embedded: Use this option when you want to add custom spatial data to the map data layer. This can be done by first adding the spatial data fields for the embedded spatial data using the MapFieldDefinitionDesigner Collection Editor which can be accessed through the FieldDefinitions property. And then later adding spatial data (points, polygons or lines) using the PolygonDesigner Collection Editor, PointsDesigner Collection Editor or LineDesigner Collection Editor depending on the layer in use. These Editor dialogs can be accessed using the SpatialData > Polygons, SpatialData > Points or SpatialData > Lines property.
    • File: Use this option when you want to add spatial data from an ESRI file. Use the Source property to specify the location of the shapefile.
      Note: The specified location must contain the shape format (.shp) and attribute format (.dbf) files.
    • DataSet: Use this option when you have a dataset that stores a spatial data field to provide spatial data to the Map. This option is equivalent to the DataSet option in the Map Layer Data Properties dialog. Use the SpatialData > DataSetName property to specify the name of the dataset and the SpatialData > SpatialField property to specify the data field that contains spatial data.
    • DataRegion: Use this option when you have a dataset that stores a spatial data field to provide spatial data to the Map. This option is equivalent to the Analytical option in the Map Layer Data Properties dialog. Use the LayerData > DataSetName property to specify the name of the dataset and the SpatialData > VectorData property to specify the data field or expression that contains spatial data.
  4. Click OK to close the dialog.

Analytical Data

Analytical data is the data that you want to visualize on the map, for example, tourist attractions in a city or product sales by region. For analytical data, you can associate it with map elements by indicating match fields in the Match box of the Map Layer Data Properties dialog. You can use one or more fields in the Match box of the Map Layer Data Properties dialog; for each spatial data field you must indicate a unique analytical data field. This data is optional.

You can get analytical data from the following types of data sources.

  • Dataset field: A field from a dataset.
  • Spatial data source field: A field from the spatial data source. For example, you can often find that an ESRI Shapefile contains both spatial and analytical data. Field names from the spatial data source are marked with the # sign in the drop-down list of fields.
  • Embedded data for a map element: After you embed polygons, lines, or points in a report, you can select the data fields for map elements and define custom values.

To add Analytical Data to the Map control

Use the following steps to add analytical data to the map. These steps assume that you have added a page layout template to your report and have a data connection in place. See Adding an ActiveReport to a Project and Connect to a Data Source for further information.

  1. Add spatial data to the map control. See the dropdown sections above to learn adding spatial data to the map control.
  2. In the Map Layer Data Properties dialog, go to the Analytical data page.
  3. Select the dataset that you want to use from the Dataset dropdown list and click the Add (+) button located next to the Match field. This creates an empty match field expression and enables the Spatial and Analytical field properties.
  4. In the Spatial field and Analytical field options set data fields that contain same data in both Spatial and Analytical databases. This builds the match field expression and relates analytical data to map elements on a map layer.
    Note: It is necessary to set match fields if you want to use a spatial data field from analytical data, or if you want to visualize analytical data on the map layer. Match fields enable the report processor to build a relationship between the analytical data and the spatial data.
  5. Click OK to close the dialog.


Work with Layers

Work with Layers
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Work with Map > Work with Layers

See step-by-step instructions for using map layers in a Map data region to display data.

Use Layers
Learn adding and removing layers, adding bookmarks and hyperlinks to map layer elements and embedding spatial data on a map.
Use a Polygon Layer
Learn how to use a polygon layer to display data on a map.
Use a Point Layer
Learn how to use a point layer to display data on a map.
Use a Line Layer
Learn how to use a line layer to display data on a map.
Use a Tile Layer
Learn how to use a tile layer to display data on a map.
Use Color Rule, Marker Rule and Size Rule
Learn how to use Color, Marker and Size rules to modify appearance of the data displayed on a map.


Use Layers

Use Layers
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Work with Map > Work with Layers > Use Layers
Show All Show All
Hide All Hide All

A map is a collection of layers that display data on the map control. See, Map for more information.

This topic illustrates how to add, remove and change order of layers. It also shows how to add interactive navigational feature to map layer elements.

To add a map layer

To add a map layer from the design surface

  1. From the Visual Studio toolbox, drag and drop a Map control onto the design surface.
  2. In the Select a Map Template wizard that appears, select a map template.
  3. Click the Map until the map panes appear.
  4. Right click inside the area labeled "Right click to add the new layer." and select the map layer you want to use.

To add a map layer using the LayerDesigner Collection Editor

  1. From the Visual Studio toolbox, drag and drop a Map control onto the design surface.
  2. In the Select a Map Template wizard that appears, select a map template.
  3. With the Map control selected, go to the Properties window, click the Layers (Collection) property and then click the ellipsis button that appears.
  4. In the LayerDesigner Collection Editor that appears, use the Add combo-box to view the list of available layers and select the map layer you want to use.

To delete a map layer

To delete a map layer from the design surface

  1. On the design surface, click the map until the map panes appear.
  2. In the layers pane, right click the layer you want to remove and select Delete.

To delete a map layer using the LayerDesigner Collection Editor

  1. On the design surface, with the Map control selected, go to the Properties window, click the Layers (Collection) property and then click the ellipsis button that appears.
  2. In the LayerDesigner Collection Editor that appears, under the members list, select the map layer you want to delete and click the Remove button.

To change order of layers

Map layers are rendered from left to right in the order that they appear in the map panes. In the image below, the polygon layer is drawn first and the line layer is rendered last. Layers that are rendered later might hide map elements on layers that are rendered earlier. You can change rendering order of layers added to the map control using the LayerDesigner Collection Editor. Follow these to steps learn re-ordering the layers on a map.

  1. On the design surface, with the Map control selected, go to the Properties window.
  2. In the Properties Window, click the Layers (Collection) property and then click the ellipsis button that appears.
  3. In the LayerDesigner Collection Editor that appears, under the members list, select the map layer you want to reorder and use the up or down arrow to change the rendering order of each layer.
  4. Click OK to close the Collection Editor.

To embed layer spatial data or tiles in a map

When you embed map elements or map tiles in a report, the spatial data is stored in the report definition.

  1. Click the map until the map panes appear.
  2. In the layers pane, right click the added layer that contains spatial data, select Embed Spatial Data and then select All Spatial Data or Currently Visible Data. In case of Tile layer select Embed Tiles.
    Note: All Spatial Data refers to all the spatial data fields, while Currently Visible Data refers to the spatial data field that is set in the Field property.

To add Hyperlinks, Bookmarks and drill-through links

Map layer elements like point, polygon and line provides you a functionality to set interactive navigational features like a bookmark link to jump to other areas in the same report, a hyperlink to jump to a Web address, or a drill-through link to jump to another report. Follow these steps to learn adding hyperlinks, bookmarks and drill-through links to a layer element:

  1. On the design surface, click the map until the map panes appear.
  2. In the layers pane, right click the layer in use and select Edit.
  3. In the selected layer's dialog that appears, go to the Navigation page.
  4. On the Navigation page, select from the following actions to perform when a user clicks a data layer element :
    • None: The default behavior to indicate that the item has no action.
    • Jump to report: For drill-through reporting, select this option and provide the name of a local report, the relative path of a report in another folder, or the full path of a report on another server.
      • Parameters: Supply parameters to the targeted report by entering the Name of each parameter, the Value to send to the targeted report, or whether to Omit the parameter. Note that parameter names you supply must exactly match parameters in the target report. You can remove or change the order of parameters using the X and arrow buttons.

      For detailed steps on adding a drill-through link, see Set a Drill-Through Link.

    • Jump to bookmark: Select this option and provide a valid Bookmark ID to allow the user to jump to another report control with the same Bookmark ID.
      For more information on adding bookmarks, see Add Bookmarks.

    • Jump to URL: Select this option and provide a valid URL to create a hyperlink to a Web page.
      For more information on adding hyperlinks, see Add Hyperlinks.

  5. Click OK to close the dialog.
See Also
Use a Polygon Layer
Use a Point Layer
Use a Line Layer
Use a Tile Layer


Use a Polygon Layer

Use a Polygon Layer
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Work with Map > Work with Layers > Use a Polygon Layer

A Polygon layer display outlines of areas or site boundaries that can be linked to Locations and can be used to select records that fall within the boundary for reporting usage.

Use the following steps for creating a basic map using the Polygon layer. These steps assume that you have added a page layout template to your project and have a data connection in place. See Adding an ActiveReport to a Project and Connect to a Data Source for further information.

  1. From the Visual Studio toolbox, drag and drop a Map control onto the design surface.
  2. In the Select a Map Template wizard that appears, select the New Map template.
  3. Click the map until the map panes appear.
  4. Right click inside the area labeled "Right click to add the new layer." and select Add Polygon Layer. This adds a polygon layer to the map and opens the Map Layer Data Properties dialog.
  5. In the Map Layer Data Properties dialog that appears, on the General page, import the spatial data (polygons) from a shape file or use a data field from the analytical data to specify the spatial data source.
  6. In case you want to visualize analytical data on the map, go to the Analytical data page of the dialog, select your dataset from the Dataset dropdown list and click the Add (+) button located next to the Match field. This creates an empty match field expression and enables the Spatial and Analytical field properties. See, Work with Data for more information.
  7. In the Spatial field and Analytical field options set data fields that contain similar data in both Spatial and Analytical databases. This builds the match field expression and relates analytical data to map elements on a polygon layer.
    Note: It is necessary to set match fields if you want to use a spatial data field from analytical data, or if you want to visualize analytical data on the map layer. Match fields enable the report processor to build a relationship between the analytical data and the spatial data.
  8. Go to the Filters page and set filters if any.
  9. Click OK to close the dialog.
  10. In the layers pane, right click on PolygonLayer1 and select Edit to open Map Polygon Layer dialog.
  11. In the General page of the dialog, select any data field from the Label Text combo box to display as labels inside polygons at runtime.
  12. Go to the Color Rule page of the dialog, to set rules to visualize data using color pallets, color ranges or custom colors for polygons or polygon center points that gets displayed on the map or keep it set to the default "Use Appearance settings". See, Use Color Rule, Marker Rule and Size Rule for more information.
  13. Go to the Visibility page of the dialog and make sure the layer visibility is set to Show. You can also select options to show or hide layer based on any expression or zoom value.
  14. In the Navigation page of the dialog, you can optionally link the polygon to a URL, bookmark or a report.
  15. The Appearance page of the dialog either reflects the default appearance of the polygons or the color rule settings if any.
  16. In the Font page of the dialog, you can optionally set the font family, size, weight, style, set and color for the label text that you had set in the General page of the dialog.
  17. Go to the Data Output page and specify the Data Element Name of the layer to be used while rendering to XML and also specify whether the layer should be included in output while rendering or not.
  18. Click OK to close the dialog and go to the preview tab to view the map.
See Also
Use a Point Layer
Use a Line Layer
Use a Tile Layer

Walkthroughs

Reports with Map


Use a Point Layer

Use a Point Layer
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Work with Map > Work with Layers > Use a Point Layer

A Point layer displays markers for point locations such as a city or an address for a store, restaurant, or school.

Use the following steps for creating a basic map using the Point layer. These steps assume that you have added a page layout template to your project and have a data connection in place. See Adding an ActiveReport to a Project and Connect to a Data Source for further information.

  1. From the Visual Studio toolbox, drag and drop a Map control onto the design surface.
  2. In the Select a Map Template wizard that appears, select the New Map template.
  3. Click the map until the map panes appear.
  4. Right click inside the area labeled "Right click to add the new layer." and add either a Tile layer or a Polygon layer. One of these layers that you add serves as the geographic base to plot points on. See, Use a Polygon Layer or Use a Tile Layer for steps to add these layers on a Map control.
  5. Right click again inside the area labeled "Right click to add the new layer." and select Add Point Layer. This adds a point layer to the map and opens the Map Layer Data Properties dialog.
  6. In the Map Layer Data Properties dialog that appears, on the General page, import the spatial data (points) from a shape file or use a data field from the analytical data to specify the spatial data source.
  7. In case you want to visualize analytical data on the map, go to the Analytical data page of the dialog, select your dataset from the Dataset dropdown list and click the Add (+) button located next to the Match field. This makes the Spatial field and Analytical field options active. See, Work with Data for more information.
  8. In the Spatial field and Analytical field options set data fields that contain similar data in both Spatial and Analytical databases. Match fields are used to relate the spatial data with the analytical data.
    Note: It is necessary to set match fields if you want to use a data field from the analytical data to set spatial data for the layer, or if you want to visualize analytical data on the map.
  9. Go to the Filters page and set filters if any.
  10. Click OK to close the dialog and return to design surface.
  11. In the layers pane, right click on PointLayer1 and select Edit to open Map Point Layer dialog.
  12. In the General page of the dialog, select any data field from the Label Text dropdown list to display as label for each point that gets displayed on the map at runtime. You can also set the label placement, size and marker type.
  13. Go to the Marker Rule page to set rules to visualize data using markers or keep it set to "Use default marker type".
  14. Go to the Size Rule page to set rules to visualize data using different marker sizes or keep it set to "Use default marker size". See, Use Color Rule, Marker Rule and Size Rule for more information.
  15. Go to the Color Rule page to set rules to visualize data using color pallets, color ranges or custom colors for markers that gets displayed on the map or keep it set to "Use Appearance settings".
  16. Go to the Visibility page of the dialog and make sure the layer visibility is set to Show. You can also select options to show or hide layer based on any expression or zoom value.
  17. In the Navigation page of the dialog, you can optionally link the layer to a URL, bookmark or a report.
  18. The Appearance page of the dialog either reflects the default appearance of the polygons or the color rule settings if any.
  19. In the Font page of the dialog, you can optionally set the font family, size, weight, style, set and color for the label text that you had set in the General page of the dialog.
  20. Go to the Data Output page and specify the Data Element Name of the layer to be used while rendering to XML and also specify whether the layer should be included in output while rendering or not.
  21. Click OK to close the dialog and go to the preview tab to view the map.
See Also
Use a Line Layer
Use a Tile Layer
Use a Polygon Layer


Use a Line Layer

Use a Line Layer
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Work with Map > Work with Layers > Use a Line Layer

A Line layer displays routes and paths between different locations, for example, transportation route between two stores.

Use the following steps for creating a basic map using the Point layer. These steps assume that you have added a page layout template to your project and have a data connection in place. See Adding an ActiveReport to a Project and Connect to a Data Source for further information.

  1. From the Visual Studio toolbox, drag and drop a Map control onto the design surface.
  2. In the Select a Map Template wizard that appears, select the New Map template.
  3. Click the map until the map panes appear.
  4. Right click inside the area labeled "Right click to add the new layer." and add either a Tile layer or a Polygon layer. One of these layers that you add serves as the geographic base to plot lines on. See, Use a Polygon Layer or Use a Tile Layer for steps to add these layers on a Map control.
  5. Right click again inside the area labeled "Right click to add the new layer." and select Add Line Layer. This adds a Line layer to the map and opens the Map Layer Data Properties dialog.
  6. In the Map Layer Data Properties dialog that appears, on the General page, import the spatial data (lines) from a shape file or use a data field from the analytical data to specify the spatial data source.
  7. In case you want to visualize analytical data on the map, go to the Analytical data page of the dialog, select your dataset from the Dataset dropdown list and click the Add (+) button located next to the Match field. This makes the Spatial field and Analytical field options active. See, Work with Data for more information.
  8. In the Spatial field and Analytical field options set data fields that contain similar data in both Spatial and Analytical databases. Match fields are used to relate the spatial data with the analytical data.
    Note: It is necessary to set match fields if you want to use a data field from the analytical data to set spatial data for the layer, or if you want to visualize analytical data on the map.
  9. Go to the Filters page and set filters if any.
  10. Click OK to close the dialog and return to design surface.
  11. In the layers pane, right click on LineLayer1 and select Edit to open Map Line Layer dialog.
  12. In the General page of the dialog, select any data field from the Label Text dropdown list to display as label for each line that gets displayed on the map at runtime. You can also set the label placement.
  13. Go to the Color Rule page to set rules to visualize data using color pallets, color ranges or custom colors for lines that gets displayed on the map or keep it set to "Use Appearance settings". See, Use Color Rule, Marker Rule and Size Rule for more information.
  14. Go to the Size Rule page to set rules to visualize data using line width or keep it set to the default line width.
  15. Go to the Visibility page of the dialog and make sure the layer visibility is set to Show. You can also select options to show or hide layer based on any expression or zoom value.
  16. In the Navigation page of the dialog, you can optionally link the layer to a URL, bookmark or a report.
  17. Go to the Appearance page of the dialog and set the style, width and color of the layer border and the layer background.
  18. In the Font page of the dialog, you can optionally set the font family, size, weight, style, set and color for the label text that you had set in the General page of the dialog.
  19. Go to the Data Output page and specify the Data Element Name of the layer to be used while rendering to XML and also specify whether the layer should be included in output while rendering or not.
  20. Click OK to close the dialog and go to the preview tab to view the map.
See Also
Use a Polygon Layer
Use a Point Layer
Use a Tile Layer


Use a Tile Layer

Use a Tile Layer
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Work with Map > Work with Layers > Use a Tile Layer
Show All Show All
Hide All Hide All

A Tile layer displays the virtual earth tile background on the map.

Use the following steps for creating a basic map using the Polygon layer. These steps assume that you have added a page layout template to your report and have a data connection in place. See Adding an ActiveReport to a Project and Connect to a Data Source for further information.

  1. From the Visual Studio toolbox, drag and drop a Map control onto the design surface.
  2. In the Select a Map Template wizard that appears, select the New Map template.
  3. Click the map until the map panes appear.
  4. Right click inside the area labeled "Right click to add the new layer." and select Add Tile Layer. This adds a tile layer to the map and opens the Map Tile Properties dialog.
  5. In the Map Tile Properties dialog that appears, on the General page, set the layer name and choose its Source and Type. The default values in these fields also work fine.
  6. In the Provider property, choose one from the following supported tile providers:
    • Bing: The Microsoft Bing Map server offers static map images. This requires an Application key for authentication. The default key provided by ActiveReports is for demo purpose and can't be used by 3rd party applications. In order to obtain a Bing Map Key, see HowTo - Create a Bing Map Account and HowTo - Get a Bing Map Key.
      Note: After generating the key, add the following script in the Grapecity.ActiveReports.config file to configure embedded Bing tile provider with Application key.

      Script

      Paste inside the <Configuration></Configuration> tags.
      Copy Code
      <MapTileServerConfiguration>
   <Timeout>5</Timeout>
   <AppID>"Your Application Key"</AppID>
</MapTileServerConfiguration>

    • Caution: The Grapecity.ActiveReports.config file should always be placed in the same folder as the EndUserDesigner.exe file for displaying a Bing tile layer on a Map.
    • Google: The Google Map server creates your map tiles based on URL parameters sent through a standard HTTP request that returns the map tiles as an image.
    • CloudMade: The CloudMade tile server allows you to access it through the HTTP Tile API. The URL structure for this API is straightforward, and is instantly recognizable to anyone familiar with the OpenStreetMap tile numbering convention. To use a CloudMade Tile server you require an API key for authentication which can be obtained by registering at CloudMade.
      Note: After generating the key, add the following script in the Grapecity.ActiveReports.config file to configure embedded CloudMade tile provider with ApiKey.

      Script

      Paste inside the <Configuration></Configuration> tags.
      Copy Code
      <!-- Configure embedded CloudMade tile provider with ApiKey -->
<MapTileProvider Name="CloudMade" DisplayName="CloudMade Tiles Provider">
    <Settings>
      <add key="ApiKey" value="API Key" />
    </Settings>
</MapTileProvider>
    • MapQuest: The MapQuest tile server provides the tiles in a format similar to Google. This tile server requires an API Key for authentication which can be obtained by registering at MapQuest.
      Note: After generating the key, add the following script in the Grapecity.ActiveReports.config file to configure embedded MapQuest tile provider with ApiKey.

      Script

      Paste inside the <Configuration></Configuration> tags.
      Copy Code
      <!-- Configure embedded MapQuest tile provider with ApiKey -->
<MapTileProvider Name="MapQuest" DisplayName="Map Quest Tiles Provider">
    <Settings>
      <add key="ApiKey" value="API Key" />
      <add key="Timeout" value="3000" />
    </Settings>
</MapTileProvider>
    • OpenStreetMap: The OpenStreetMap server provides the tiles in an index based format. This tile server provides only the roadmap and returns fixed size images (256x256). Before using the OpenStreetMap server, go through the Copyright and License and Tile usage policy pages.
  7. Go to the Visibility page of the dialog and make sure the layer visibility is set to Show. You can also select options to show or hide layer based on any expression or zoom value.
  8. Click OK to close the dialog and go to the preview tab to view the map.

Note
If you are using proxy server connection to see the map tile images, you need to set credentials for the proxy server in the application config file for authentication. To use your default proxy server credentials, you can do the following:

For Visual Studio Designer (IDE)

  1. Find devenv.exe.config (the devenv.exe configuration file) in: ProgramFiles(x86)\Microsoft Visual Studio 12.0\Common7\IDE
  2. In the configuration file, find the <system.net> block, and add this code:
    Paste inside the <system.net></system.net> tags.
    Copy Code
    <defaultProxy useDefaultCredentials="true" />

For Visual Studio Application

  1. On the menu bar, choose Project, Add New Item and then choose the Application Configuration File template.
  2. In the Name text box, enter a name, and then click Add button.
  3. In the configuration file, add this code:
    Paste inside the <configuration></configuration> tags.
    Copy Code
    <system.net>
    <defaultProxy useDefaultCredentials="true" />
    </system.net>
Note: Grapecity.ActiveReports.config file should be kept inside the project Debug folder and added to a Visual Studio project for displaying a Tile layer on a Map in any Viewer control.
See Also
Use a Polygon Layer
Use a Point Layer
Use a Line Layer
Add a Custom Tile Provider


Add a Custom Tile Provider

Add a Custom Tile Provider
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Work with Map > Work with Layers > Use a Tile Layer > Add a Custom Tile Provider
Show All Show All
Hide All Hide All

You can add and configure a Custom Tile Provider in the Map control using the IMapTileProvider and IMapTile interfaces.

The IMapTileProvider interface contains detailed settings that are required to communicate with the tile server, whereas the IMapTile interface represents a single tile of a Map's tile layer that fetches the tile image based on the configurations in the IMapTileProvider interface.

Adding a custom tile provider also requires making some modifications in the Grapecity.ActiveReports.config file. Follow these steps to learn how to set a custom tile provider:

  1. Create a Class Library Project, for example MyClassLib, in Visual Studio.
  2. Add a new Class to the project and name the class, for example, MyTileProvider. You may add functions and features to this class for getting the Tile images based on your tile server settings and details. This class serves as the interface between your Map control and your custom tile server. Replace the existing code with the following in the MyTileProvider class to implement the IMapTileProvider interface.

    To write the code in Visual Basic.NET

    VB code. Paste on TOP
    Copy Code
    Imports System
Imports System.Collections.Specialized
Imports GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map
    VB code. Paste BELOW the Imports statements
    Copy Code
    Namespace MyClassLib
   Public Class MyTileProvider Implements IMapTileProvider
        ' Tile provider settings, like ApiKey, Language, Style and etc.
        Public Property Settings() As NameValueCollection
        ' Add your code here.
        End Property
        ' Get instance of tile by specifying tile coordinates and details.
        Public Sub GetTile(key As MapTileKey, success As Action(Of IMapTile), [error] As Action(Of Exception))
        ' Add your code here.
        End Sub
    End Class

    End Namespace

    To write the code in C#

    C# code. Paste on TOP
    Copy Code
    using System;
using System.Collections.Specialized;
using GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map;
    C# code. Paste BELOW the Using statements
    Copy Code
    namespace MyClassLib
{
    public Class MyTileProvider :IMapTileProvider
    {// Tile provider settings, like ApiKey, Language, Style and etc.
    public NameValueCollection Settings { get; private set;}
    // Get instance of tile by specifying tile coordinates and details.
    public void GetTile(MapTileKey key, Action<IMapTile> success, Action<Exception> error);
    // Add your code here.
    }
}

  3. Add a new Class to the project and name the class, for example, MyMapTile. Replace the existing code with the following in the MyMapTile class to implement the IMapTile interface.

    To write the code in Visual Basic.NET

    VB code. Paste on TOP
    Copy Code
    Imports System.IO
Imports GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map
    VB code. Paste BELOW the Imports statements
    Copy Code
    Namespace MyClassLib
   Public Class MyMapTile Implements IMapTile
       ' Gets the tile identifier
       Public Property Id() As MapTileKey
       ' Add your code here
       End Property
       ' Gets the tile image stream.
       Public Property Image() As Stream
       ' Add your code here.
       End Property
   End Class
End Namespace

    To write the code in C#

    C# code. Paste on TOP
    Copy Code
    using System.IO;
using GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map;
    C# code. Paste BELOW the Using statements
    Copy Code
    namespace MyClassLib
   public class MyMapTile : IMapTile
   {   // Gets the tile identifier.
       public MapTileKey Id { get; private set; }
       // Gets the tile image stream.
       public Stream Image { get; private set; }
       // Add your code here.
    }
}
  4. Add another Class to the project and name the class, for example, WebRequestHelper. Replace the existing code with the following in the WebRequestHelper class to implement the loading of raw website data into the System.IO.MemoryStream class.

    To write the code in Visual Basic.NET

    VB code. Paste on TOP
    Copy Code
    Imports System.IO
Imports System.Net
    VB code. Paste BELOW the Imports statements
    Copy Code
    Namespace MyClassLib
    Module StringExtensions
        Public Sub CopyTo(ByVal input As Stream, ByVal output As Stream)
        'Add your code here
        End Sub
        Private Function InlineAssignHelper(Of T)(ByRef target As T, value As T) As T
        'Add your code here
        End Function
    End Module
    Friend NotInheritable Class WebRequestHelper
        Private Sub New()
        End Sub
        ' Load raw data into MemoryStream from specified Url.
        Public Shared Function DownloadData(url As String, timeoutMilliseconds As Integer) As Stream
        'Add your code here
        End Function
        'oad raw data into MemoryStream from specified Url.
        Public Shared Sub DownloadDataAsync(url As String, timeoutMilliseconds As Integer, success As Action(Of MemoryStream), [error] As Action(Of Exception))
        'Add your code here
        End Sub
        Private Shared Function InlineAssignHelper(Of T)(ByRef target As T, value As T) As T
        'Add your code here
        End Function
    End Class
End Namespace

    To write the code in C#

    C# code. Paste on TOP
    Copy Code
    using System.IO;
using System.Net;
    C# code. Paste BELOW the Using statements
    Copy Code
    namespace MyClassLib
{
    internal static class WebRequestHelper
    {   // Load raw data into MemoryStream from specified Url.
        public static Stream DownloadData(string url, int timeoutMilliseconds)
        {//Add your code here  }
        public static void DownloadDataAsync(string url, int timeoutMilliseconds, Action<MemoryStream> success, Action<Exception> error)
        {//Add your code here  }
        public static void CopyTo(this Stream input, Stream output)
        {//Add your code here  }
    }
}
  5. Save and build your class library project and locate the new .dll file in its Bin>Debug folder. This file has the same name as your class library project, with a .dll extension.
  6. Create a Basic End User Designer in a new solution following the steps in Creating a Basic End User Designer.
  7. Run your Basic End User Designer project to create a EndUserDesigner.exe in your projects Bin>Debug folder.
  8. Copy the Grapecity.ActiveReports.config file from the C:\Program Files\Common Files\GrapeCity\ActiveReports 10\ location and paste it into your End User Designer project's Bin>Debug folder.
    Caution: Grapecity.ActiveReports.config file should always be placed inside the same folder as the EndUserDesigner.exe file for displaying a tile layer on a Map.
  9. Right-click on the Grapecity.ActiveReports.config file and select Include in this Project to make changes in the config file.
  10. Double-click to open the Grapecity.ActiveReports.config file and paste the following code between the <Configuration> and </Configuration> tags:
    Paste between the <Configuration></Configuration> tags.
    Copy Code
    <!-- Register and configure custom tile provider. -->
<MapTileProvider Name="Custom" DisplayName="Custom Provider" type="YourTileProvider, AssemblyName, Version = x.x.x.x">
    <Settings>
      <add key="ApiKey" value="API Key" />
    </Settings>
</MapTileProvider>
    Note: Replace YourTileProvider with fully qualified class name and AssemblyName with the name of the assembly created after implementing IMapTileProvider and IMapTile interfaces.
  11. Add the Class Library project created in step 5 to your Basic End User Designer project.
  12. Copy the YourProjectName.dll created in step 5 and paste it to the current project's Bin>Debug folder together with the EndUserDesigner.exe.
  13. Save and Run the project.
  14. Create a Report containing a Map control in the Basic End User Designer. See Reports with Map for more information.
  15. Add a Tile layer to the Map control. Right click the Tile layer and select Edit to view the custom tile provider added in the Provider drop-down. See Use a Tile Layer for more information.


Use Color Rule, Marker Rule and Size Rule

Use Color Rule, Marker Rule and Size Rule
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Work with Map > Work with Layers > Use Color Rule, Marker Rule and Size Rule
Show All Show All
Hide All Hide All

You can visualize the data displayed on a map by setting rules to control color, size or marker type for all map elements on a layer. You can set three types of rules depending on the type of layer in use.

  1. Color Rule

    Color Rule is set to fill colors for map elements like polygons, markers (points or polygon center points) and lines while using a Polygon, Point or Line layer.
    Color Rule provides four options:
    1. Apply Appearance Settings : Use the default appearance settings that are set in the Appearance page of the map layer dialog.
    2. Visualize data by using color palette : This option uses an in-built palette that you specify. Based on related analytical data, each map element is assigned a different color from the palette.
    3. Visualize data by using color ranges : This option, combined with the start, middle, and end colors that you specify on this page and the options that you specify on the Distribution page, divide the related analytical data into ranges. The report then assigns the appropriate color to each map element based on its associated data and the range that it falls into. For example, in a map which uses color to display temperatures on a scale of 0 to 100, low values are blue to represent cold and high values are red to represent hot.
    4. Visualize data by using custom colors : This option uses the list of custom colors that you specify. Based on related analytical data, each map element is assigned a color from the list.

    To set Color Rule for polygons, lines and markers

    To visualize polygons, lines or markers using color palette

    1. Click the Map until the map panes appear.
    2. In the layers pane, right click on the added map layer and select Edit to open the selected map layer dialog.
    3. In the selected map layer dialog that appears, go to the Color Rule page.
    4. In the Color Rule page, select the Visualize data by using color palette option.
    5. In Data field, set the name of the field or expression that contains the analytical data that you want to visualize by color.
    6. In Palette, set the name of the palette to use.
    7. Click OK to close the dialog.

    To visualize polygons, lines or markers using color ranges

    1. Click the Map until the map panes appear.
    2. In the layers pane, right click on the added map layer and select Edit to open the selected map layer dialog.
    3. In the selected map layer dialog that appears, go to the Color Rule page.
    4. In the Color Rule page, select the Visualize data by using color ranges option.
    5. In Data field, set the name of the field or expression that contains the analytical data that you want to visualize by color.
    6. In Start color, set the color to be used for the color range.
    7. In Middle color, set the color to be used for the color range.
    8. In End color, set the color to be used for the color range.
    9. Click OK to close the dialog.

    To visualize polygons, lines or markers using custom colors

    1. Click the Map until the map panes appear.
    2. In the layers pane, right click on the added map layer and select Edit to open the selected map layer dialog.
    3. In the selected map layer dialog that appears, go to the Color Rule page.
    4. In the Color Rule page, select the Visualize data by using custom colors option.
    5. In Data field, set the name of the field that contains the analytical data that you want to visualize by color.
    6. Click Add to specify each custom color.
    7. Click OK to close the dialog.

  2. Marker Rule

    Marker Rule is set on markers that represent points or polygon center points on a map while using a Point layer.
    Marker Rule support two options:
    1. Use a default marker type : You specify one of the available marker types.
    2. Visualize data using markers : This option uses a set of markers in an order in which you want them to be used. Marker types include Rectangle, Circle, Diamond, Triangle, Trapezoid, Star, Wedge, Pentagon, PushPin and Image.

    To set Marker Rule for points

    To visualize points using default marker type

    1. Click the Map until the map panes appear.
    2. In the layers pane, right click on the added map layer and select Edit to open the selected map layer dialog.
    3. In the selected map layer dialog that appears, go to the Marker Rule page.
    4. In Default, set a default marker type that will appear in place of each point on a map.
    5. Click OK to close the dialog.

    To visualize points using specific marker types

    1. Click the Map until the map panes appear.
    2. In the layers pane, right click on the added map layer and select Edit to open the selected map layer dialog.
    3. In the selected map layer dialog that appears, go to the Marker Rule page.
    4. In the Marker Rule page, select the Visualize data using markers option.
    5. In Data field, set the name of the field that contains the analytical data that you want to visualize using different marker types.
    6. Click Add and specify each Marker type in an order in which you want them to be used.
    7. Click OK to close the dialog.

    To visualize points using Image as marker type

    ActiveReports provides Image as one of the many available marker types to use from. You can set this marker type and use any image as a marker on a map layer. Like other marker types, you can either use it as a default marker or use it as one of the member in the markers collection.

    Use Image as Default marker type

    1. Click the Map until the map panes appear.
    2. In the layers pane, right click on the added map layer and select Edit to open the selected map layer dialog.
    3. In the selected map layer dialog that appears, on the General page, set Marker Type to Image. A new set of properties appears on the page.
    4. In Image Source, choose the source of image from the provided options:
      • External: Select this option and set a path or url of the image file in Image Value.
      • Embedded: Choose from the list of embedded images added to your report. Once you set this option, the Image Value provides you the list of embedded images to choose from.
      • Database: Select this option and set the data field containing the image in the Image Value property.
    5. In MIME Type, set the MIME type of the image chosen. In case you are using the Embedded image source the MIME Type gets set automatically as you select the image in the Image Value property.
    6. Set the Transparent Color and the Resize Mode.
    7. Click OK to close the dialog.

    Use Image in markers collection

    1. Click the Map until the map panes appear.
    2. In the layers pane, right click on the added map layer and select Edit to open the selected map layer dialog.
    3. In the selected map layer dialog that appears, go to the Marker Rule page.
    4. In the Marker Rule page, select the Visualize data using markers option.
    5. In Data field, set the name of the field that contains the analytical data that you want to visualize using different marker types.
    6. Click Add and set Marker type to Image. A new set of properties for image marker types appears on the page.
    7. In Image Source, choose the source of image from the provided options:
      • External: Select this option and set a path or url of the image file in Image Value.
      • Embedded: Choose from the list of embedded images added to your report. Once you set this option, the Image Value provides you the list of embedded images to choose from.
      • Database: Select this option and set the data field containing the image in the Image Value property.
    8. In MIME Type, set the MIME type of the image chosen. In case you are using the Embedded image source the MIME Type gets set automatically as you select the image in the Image Value property.
    9. Set the Transparent Color and the Resize Mode.
    10. Click OK to close the dialog.

  3. Size Rule

    Size Rule is set on markers, polygon center points or line width while using a Polygon, Point or a Line layer.
    Size Rule support two options:
    1. Use a default marker size or Use a default line width : You specify the marker size or line width in points.
    2. Visualize data by using size or Visualize data by using line width : In this option, you set the minimum (start) and maximum (end) sizes or width for marker or line, specify the data field to be used for varying the marker size or line width and then specify the distribution options to apply to that data.

    To set Size Rule for markers and line width

    To visualize marker or line using default marker size or line width

    1. Click the Map until the map panes appear.
    2. In the layers pane, right click on the added map layer and select Edit to open the selected map layer dialog.
    3. In the selected map layer dialog that appears, go to the Size Rule page.
    4. In Default, set default size or width for each marker or line that appears on a map.
    5. Click OK to close the dialog.

    To visualize marker or line using specific marker size or line width

    1. Click the Map until the map panes appear.
    2. In the layers pane, right click on the added map layer and select Edit to open the selected map layer dialog.
    3. In the selected map layer dialog that appears, go to the Size Rule page.
    4. In the Size Rule page, select Visualize data by using size or Visualize data by using line width depending on the layer type in use.
    5. In Data field, set the name of the field that contains the analytical data that you want to visualize using different marker sizes or line width.
    6. Set Start size and End size in case of Point Layer or Minimum line width and Maximum line width in case of Line Layer.
    7. Click OK to close the dialog.

Distribution Options

The distribution values are used by the rules to differ the map element display values.

To create a distribution of values, you divide your data into ranges by specifying the distribution method, the number of sub-ranges, and the range start and end values.

To set distribution values for rules

  1. Click the Map until the map panes appear.
  2. In the layers pane, right click on the added map layer and select Edit to open the selected map layer dialog.
  3. In the selected map layer dialog that appears, go to the rule page(Color Rule, Marker Rule or Size Rule) where you need to specify distribution values.
  4. In the rule page of the dialog, select any option to visualize data using the selected rule type and go to the Distribution tab.
  5. On the Distribution tab, select one of the following distribution types:
    • EqualInterval : Create ranges that divide the data into equal range intervals. For the example, the three ranges would be 0-2999, 3000-5999, 6000-8999. Sub-range 1: 1, 10, 200, 500. Sub-range 2: 4777. Sub-range 3: 8999.
    • EqualDistribution : Create ranges that divide that data so that each range has an equal number of items. For example, the three ranges would be 0-10, 11-500, 501-8999. Sub-range 1: 1, 10. Sub-range 2: 200, 500. Sub-range 3: 4777, 8999.
    • Optimal : Specifies ranges that automatically adjust distribution to create balanced sub-ranges. The number of Sub-ranges is determined by the algorithm.
    • Custom : Specify your own number of ranges to control the distribution of values. For example, you can specify your own custom ranges 0-5000 and 5001-10000.
  6. In Number of Sub-ranges, type the number of sub-ranges to use.
  7. In Range start, type a minimum range value. All values less than this number are the same as the range minimum.
  8. In Range end, type a maximum range value. All values larger than this number are the same as the range maximum.
  9. Click OK to close the dialog.

Displaying Rule results in Legend

To display rule results in Legend

  1. Click the Map until the map panes appear.
  2. In the layers pane, right click on the added map layer and select Edit to open the selected map layer dialog.
  3. In the selected map layer dialog that appears, go to the rule page(Color Rule, Marker Rule or Size Rule) where you need to specify displaying rule results in a legend.
  4. In the rule page of the dialog, select any option to visualize data using the selected rule type and go to the Legend tab.
  5. Select Show in legend checkbox and set Legend name.
  6. In Legend text, enter text that specify which data should appear in the legend. Use map keywords and custom formats to help control the format of legend text. For example, #VALUE {C2} specifies a currency format with two decimal places. Following are the supported formats that you can use:
    Format | Description | Example
    #Value | Displays a numeric value calculated using "(EndRangeValue - StartRangeValue)/2" formula.
    #FROMVALUE {C0} | Displays the currency of the total value with no decimal places. | $100
    #FROMVALUE {C2} | Displays the currency of the total value to two decimal places. | $40.25
    #TOVALUE | Displays the actual numeric value of the data field. | 100
    #FROMVALUE{N0} - #TOVALUE{N0} | Displays the actual numeric values of the beginning of the range and end of the range. | 10 - 500
  7. Click OK to close the dialog.


Add TableOfContents

Add TableOfContents
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Work with Report Controls and Data Regions > Add TableOfContents

The TableOfContents control allows you to display the document map, an organized hierarchy of the report bookmark labels and heading levels along with their page numbers, in the body of a report.

To add items to the Document Map using HeadingLevel Property

You can define an hierarchical structure for your report using the HeadingLevel property of the TextBox control. For example, you can set the HeadingLevel property of the TextBox displaying the report title to Heading1 and then set the HeadingLevel property of the TextBox displaying a group header to Heading2, this will club all the Heading2 entries under the Heading1 entry in the Document Map.

These steps assume that you have already set the HeadingLevel property of the TextBox controls that your report contains. See, Add Items to the Document Map for more information.

  1. In the Report Explorer, right-click the Report item and select Report Properties...
  2. In the Report Properties dialog that appears, go to the Document Map page.
  3. On the Document Map page, set Source to Headings Only and optionally select the Numbering Style from the dropdown list.
    Tip: You can also set Source to Labels and Headings to include both labels and headings in the Document Map.
  4. Click OK to close the dialog.

To add items to the Document Map using Label Property or Document Map Labels

By setting the Label property or Document Map Label of the controls in your page report/RDL report, you can show a hierarchical structure based on the parent - child relationship between the controls in the Document Map. For example, set the Label property or Document Map Label of a List data region and a TextBox control and then place the TextBox control inside the List data region. When you view the Document Map, the TextBox label appears nested inside the List data region label, thereby displaying a hierarchical structure. Similarly, if you set a Document map label on multiple Groups of a data region, they appear nested below each other in the document map displaying the same hierarchy in which they were set.

These steps assume that you have already set the Label property or Document Map Label of the controls that your report contains. See, Add Items to the Document Map for more information.

  1. In the Report Explorer, right-click the control and select Report Properties...
  2. In the Report Properties dialog that appears, go to the Document Map page.
  3. In the Document Map page, set Source to Labels Only and optionally select the Numbering Style from the dropdown list.
    Tip: You can also set Source to Labels and Headings to include both labels and headings in the Document Map.
  4. Click OK to close the dialog.

To add items to the Document Map using

  1. On the design surface, select a control you want to add to the Document map.
  2. In the command section of the Properties Window, click the Property dialog. This is a command to open the control's dialog. See Properties Window for more information on how to access commands.
  3. In the dialog that appears, go to the Navigation page and under the Document map label, enter a text or an expression representing the control in the Document map.
  4. Click OK to close the dialog.

To add and configure TableOfContents

Follow these steps to setup the TableOfContents control in the report layout displaying the document map set in the procedures above.

To add a TableOfContents control in Page Report

  1. In the Report designer, click the New tab to add a new page to the report layout.
  2. From the toolbox, drag and drop the TableOfContents control onto Page 1 while use Page 2 to create layout for displaying the main content of the report. Using the same page that contains the TableOfContents may disrupt the flow of data displayed in the report.
  3. On the design surface, select the TableOfContents control and go to the Properties window to set its FixedHeight property. The use of the FixedHeight property is similar to the use of the FixedSize property that is available with other report controls.
    Note: You can also place the OverflowPlaceHolder control and link it with the TableOfContents control using its OverflowName property to display data that does not fit inside the fixed size of the TableOfContents control.
  4. With the TableOfContents control selected, click the Levels (Collection) property and then click the ellipsis button that appears.
  5. In the LevelDesigner Collection Editor that appears, consider the hierarchy of entries that appear in the Document Map and add as many levels required using the Add button. This allows you to customize entries at different nested levels. Using just a single Level will list down all the TableOfContents entries at the same level. You can also set various numbering styles for all levels or an individual level by setting the Numbering Style for document map levels using the Report dialog or using the DocumentMap property that gets directly applied to the TableOfContents control. For more information see Add Items to the Document Map.
  6. Select each level and set its related properties available in the LevelDesigner Collection Editor. These properties could be general properties like DisplayPageNumber or DisplayFillCharacter, or they could be related to the level's appearance like BackgroundColor, Font, Padding etc. These properties directly affect all the entries that appear in the selected level, thereby allowing you to customize them. For information on the important properties of the TableOfContents control, see TableOfContents.
  7. Click OK to close the dialog and return to the design surface.
  8. Go to the Preview Tab to view the Table of Contents appear in the report output.
  9. Click any TableOfContents entry and navigate to the targeted report control in the report.

To add a TableOfContents control in Report Definition Language (RDL)

  1. From the toolbox, drag and drop the TableOfContents control onto the report design surface, preferably at the start or end of the report layout to justify the significance of the control.

To configure TableOfContents Appearance

  1. With the TableOfContents control selected, click the Levels (Collection) property and then click the ellipsis button that appears.
  2. In the LevelDesigner Collection Editor that appears, consider the hierarchy of entries that appear in the Document Map and add as many levels required using the Add button. This allows you to customize entries at different nested levels. Using just a single Level will list down all the TableOfContents entries at the same level.
  3. Select each level and set its related properties available in the LevelDesigner Collection Editor. These properties could be general properties like DisplayPageNumber or DisplayFillCharacter, or they could be related to the level's appearance like BackgroundColor, Font, Padding etc. These properties directly affect all the entries that appear in the selected level, thereby allowing you to customize them. For information on the important properties of the TableOfContents control, see TableOfContents.
    Note: You can also set various numbering styles for all levels or individual level by setting the Numbering Style for document map levels using the Report dialog or using the DocumentMap property that gets directly applied to the TableOfContents control. For more information see Add Items to the Document Map.
  4. Click OK to close the dialog and return to the design surface.
  5. Go to the Preview Tab to view the Table of Contents appear in the report output.
  6. Click any TableOfContents entry and navigate to that targeted report control in the report.

To apply styles to the TableOfContents control

In the TableOfContents control, styles can be applied using the StyleName property.

  1. Create a new style sheet and add styles that you want to apply to the TableOfContents control. For more information on creating style sheets and style types, see Working with Styles and Style Elements.
  2. Apply the style sheet to the report. For details on how to apply style sheets to reports at design time, see Working with Styles.
  3. From the toolbox, drag and drop the TableOfContents control onto the report design surface, preferably at the start or end of the report layout to justify the significance of the control.
  4. On the design surface, select the TableOfContents control.
  5. In the Properties Window, from the StyleName property drop-down, select a style to apply to the TableOfContents control.

To apply styles to the TableOfContents levels

In the TableOfContents control, styles can be applied to each TableOfContents level using the StyleName property available in the LevelDesigner Collection Editor dialog.

  1. Create a new style sheet and add styles that you want to apply for the TableOfContents level. For more information on creating style sheets and and the type of styles available for TableOfContents level, see Working with Styles and Style Elements.
  2. From the toolbox, drag and drop the TableOfContents control onto the report design surface, preferably at the start or end of the report layout to justify the significance of the control.
  3. With the TableOfContents control selected, click the Levels (Collection) property from the Properties window and then click the ellipsis button that appears.
  4. In the LevelDesigner Collection Edior dialog that appears, select a TableOfContents level on which to want to apply the style.
  5. From the list of properties on the right, drop-down the StyleName property to select a style to apply.
See Also
Add Items to the Document Map

Concepts

TableOfContents
Document Map


Create Common Page Reports

Create Common Page Reports
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Create Common Page Reports

See step-by-step instructions for creating commonly used reports in a Page Layout.

This section contains information about how to:

Create Top N Report
Learn how to display top N data on a report.
Create Red Negatives Report
Learn to highlight negative values in red on a report.
Create Green Bar Report
Learn to create alternate background colors for report details.
Create a Bullet Graph
Learn how to create a Bullet Graph.
Create a Whisker Sparkline
Learn how to create a Whisker Sparkline.
See Also

Concepts

Expressions


Create Top N Report

Create Top N Report
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Create Common Page Reports > Create Top N Report

A Top N Report displays details for the top results in your report. You can create this report by modifying the SQL query while creating a dataset.

The following steps demonstrate how to create a Top N report. These steps assume that you have already added a Page Report/RDL Report template to your project and connected it to a data source. See Adding an ActiveReport to a Project and Connect to a Data Source for more information.

  1. In the Report Explorer, right-click the data source node (DataSource1 by default) and select the Add Data Set option or select Data Set from the add button.
  2. In the DataSet dialog that appears, go to the Query page and enter a query in the Query textbox in the following format : Select Top N FieldNames From TableName
    Note: In the query above TableName refers to the table you want to get from the database. FieldNames and N refer to the fields you want to fetch from the table and the number of records to display from that field. Following is an example of a Top N Report SQL query : Select Top 10 * From Movie
  3. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query and then click OK to close the dialog.
  4. In the Report Explorer, expand the DataSet node and drag and drop fields onto the design surface. In an Page report, you need to place these fields inside a data region.
  5. Go to the Preview tab and view the result. You'll notice only N number of records displaying in your report.

The following image is an example of a Top N Report displaying top 10 movie records:

See Also
Create Common Page Reports


Create Red Negatives Report

Create Red Negatives Report
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Create Common Page Reports > Create Red Negatives Report

A Red Negatives report shows negative values in red color if those values meet the requirements set in a conditional expression. The following steps demonstrate how to create a report with negative values in red negatives.

These steps assume that you have already added a Page Report/RDL Report template to your project, connected it to a data source and added a DataSet. See Adding an ActiveReport to a Project, Connect to a Data Source and Add a Dataset for more information.

  1. From the Visual Studio toolbox, drag and drop a Table data region onto the design surface and place fields inside the cells of the details row.
  2. In the same Table, select any cell (Textbox) that displays integer values and right click to select Properties.
  3. In the Properties Window that appears, set the following expression in the Color property: =iif(Fields!FieldName.Value < 0, "Red", "Black")
    Note: In the expression above, FieldName refers to field that the textbox contains. For example, if a textbox contains the Rollup field, the expression looks like: =iif(Fields!Rollup.Value < 0, "Red", "Black")
  4. Go to the Preview tab and view the result.

The following image illustrates a report that contains negative values in red:
See Also
Create Common Page Reports


Create Green Bar Report

Create Green Bar Report
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Create Common Page Reports > Create Green Bar Report

You can create a Green Bar report by alternating the background color of a data region like a Table using conditional formatting. The following steps demonstrate Follow the steps below to learn creating a Green Bar Report.

These steps assume that you have already added a Page Report/RDL Report template to your project, connected it to a data source and added a dataset. See Adding an ActiveReport to a Project, Connect to a Data Source and Add a Dataset for more information.

  1. From the Visual Studio toolbox, drag and drop a Table data region onto the design surface.
  2. In the Table data region, click the row handle to the left of the detail row and right-click to select Properties.
  3. In the Properties Window dialog that appears, set the following expression in the BackgroundColor property: =iif(RowNumber(Nothing) Mod 2, "PaleGreen", "White")
  4. On the design surface, set fields the detail row of the table data region.
  5. Go to Preview tab and view the result. You will notice that every alternate detail the report displays has a green background.

The following image shows an example of a Green Bar report:


Create a Bullet Graph

Create a Bullet Graph
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Create Common Page Reports > Create a Bullet Graph
You can create a bullet graph based on aggregated data from the data source. The following steps demonstrate how to create a bullet graph.

These steps assume that you have already added a Page Report/RDL Report template to your project and connected it to a data source. See Adding an ActiveReport to a Project and Connect to a Data Source for more information.

  1. From the Visual Studio toolbox, drag a drop Table control onto the design surface.
  2. From the Visual Studio toolbox, drag a Bullet control onto the detail row of the table and in the properties window, set its Value property to a numeric field (like =Fields!SalesAmount.Value). This Value property is used to define the key measure displayed on the graph.
  3. With the Bullet control selected on the design surface:
    • Set its Target Value property to 200. This property defines a target for the Value to be compared to.
    • Set its Best Value property to 500 and the Worst Value property to 0. The Best Value and Worst Value properties define the value range on the graph.
    • You can also optionally encode the segments on the graph as qualitative ranges indicating bad, satisfactory and good sections.
      • The Range1Boundary property defines a value for the bad/satisfactory boundary on the graph. Set this property to 150.
      • The Range2Boundary property defines a value for the satisfactory/good boundary on the graph. Set this property to 300.
    • You can also optionally define the Interval property for the graph value range. So, set this property to 100.
  4. Go to the Preview tab to view the bullet graph you have added to your report.
    As the bullet graph is based on aggregated data, you get a stack of bullet graphs indicating the Sales Amount value for different customers.

See Also
Create Common Page Reports


Create a Whisker Sparkline

Create a Whisker Sparkline
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Create Common Page Reports > Create a Whisker Sparkline

You can use a whisker Sparkline to render “win/loss/tie” scenarios (for example, sport statistics) or “true/false” scenarios (for example, was the sales goal met or was the temperature above average), based on the numeric data from a data set.

The bars in a whisker sparkline render below the baseline for a negative value, above the baseline for a positive value and on the baseline for a zero value, for example, in a "profit/loss/no profit, no loss" scenario.

The following steps demonstrate how to create a whisker sparkline. These steps assume that you have already added a Page Report/RDL Report template to your project, connected it to a data source and added a dataset. See Adding an ActiveReport to a Project, Connect to a Data Source and Add a Dataset for more information.

Note: These steps use the AccountsChartData table from the Reels database. The sample Reels.mdb database file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.
  1. From the Visual Studio toolbox, drag a Sparkline control onto the design surface.
  2. With the sparkline selected on the design surface, go to the properties window and:
    • Set the Sparkline Type property to Whiskers.
    • Set the SeriesValue property to a numeric field (like =Fields!RollUp.Value) from the connected data set.
    • Set the FillStyle/FillColor property to Red.
  3. Go to the Preview tab to view the whisker sparkline.
See Also
Create Common Page Reports


Add Parameters

Add Parameters
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Add Parameters

You can add parameters to a page report/RDL report to allow users to select the data to display, or to use in creating drill-through reports.

To add a parameter

  1. In the Report Explorer, right-click the Parameters node and select Add Parameter. The Report Parameters dialog appears.
  2. On the General tab of the dialog, set the name, data type and prompt text for the parameter. For example:
    • Name: MPAA
    • Data type: String
    • Text for prompting users for a value: Enter value

    Select out of the checkbox options to allow null values, multivalues, blank value, multiline values or set hidden parameters.

  3. On the Available Values tab, you can select From query populate a list from the data set from which users can select a value. Alternatively, you can select Non-queried to enter your own values.
  4. On the Default Values tab, you can provide default values to use if the user does not select a value. This is useful when you are creating a hidden parameter.
  5. Click OK to save the parameter. The new parameter appears in the Report Explorer under the Parameters node.
  6. From the Report Explorer, drag the parameter to report design surface to create a TextBox that is bound to the parameter. When you run the report, the value that the user supplies in the prompt dialog displays in the bound TextBox on the report.

For a step by step description of adding parameters in different scenarios look at the following pages:

Create an ALL Parameter
Learn how to create a multi-value parameter with an ALL value.
Add a Cascading Parameter
Learn how to create cascading parameters where one parameter value is dependent on the selection of another.
Set a Hidden Parameter
Learn how to set a hidden parameter to allow data to fetched using the parameter value without prompting the user.
See Also

Concepts

Parameters


Create an ALL Parameter

Create an ALL Parameter
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Add Parameters > Create an ALL Parameter
Show All Show All
Hide All Hide All

In a page report or a RDL report, when you create a Multivalue list in a parameter, you can add an ALL value which removes the parameter filter to this list. Set the following to create an ALL parameter:

  • A dataset to populate the parameter values
  • A report parameter
  • A list of values for the report parameter
  • A dataset with a parameter

The following procedures take you through a step by step process of how to set an ALL parameter. These steps assume that you have added a Page Report/RDL Report template to your report and have a data connection in place. See Adding an ActiveReport to a Project and Connect to a Data Source for further information.

Note: This topic uses the Producers and Movie table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\Reels.mdb.

To create a dataset to populate the parameter values

  1. In the Report Explorer, right-click the Data Source (DataSource1 by default) node and select Add Data Set.
  2. In the DataSet dialog that appears, select the Query page.
  3. Enter a SQL query like the following into the Query text box where a UNION SELECT statement combines the results of the ALL query with those of the query for the individual values.
    SELECT -1 AS ProductionID, "(All)" AS Name
    FROM Producers
    UNION
    SELECT ProductionID, Name
    FROM Producers;
  4. Click the OK button on the lower right corner to close the dialog and see the dataset and the selected fields appear in the Report Explorer.

To add a Report Parameter

  1. In the Report Explorer, right-click the Parameters node and select Add Parameter.
  2. In the Report - Parameters dialog that appears, add a name for the parameter (i.e. ProdID) and ensure that the Data type matches that of the field (i.e. Integer for ProductionID).
  3. Enter Text for prompting users for a value.
  4. Select the check box next to Multivalue to allow users to select more than one item from the list.

To provide a list of values for the Report Parameter

  1. In the Report - Parameters dialog, go to the Available Values tab and select the From query radio button.
  2. Under the Dataset field, select the dataset created above (i.e. DataSet1).
  3. Under the Value field, select the field given for -1 (i.e. ProductionID).
  4. Under Label field, select the field given for "All" (i.e. Name).
  5. Click the OK button on the lower right corner to close the dialog and add the parameter to the collection.

To add a dataset with a parameter

  1. In the Report Explorer, right-click the Data Source (DataSource1 by default) node and select Add Data Set.
  2. In the DataSet dialog that appears, on the Parameters page, click the Add (+) icon above the parameters list and add the following to the dataset to provide values for the parameters we add to the query in step 3 below.
    Name: Param1; Value: =Parameters!ProdID.Value
    Name: Param2; Value: =Parameters!ProdID.Value
  3. On the Query page, enter a SQL query like the following in the Query text box:
    SELECT Movie.Title, Movie.YearReleased, Movie.UserRating, Producers.Name
    FROM Producers INNER JOIN (Movie INNER JOIN MovieProducers ON Movie.MovieID = MovieProducers.MovieID) ON Producers.ProductionID = MovieProducers.ProductionID
    WHERE (MovieProducers.ProductionID IN (?)) OR (-1 IN (?))
    ORDER BY MovieProducers.ProductionID, Movie.YearReleased
  4. Click the Validate DataSet icon to validate the query and to populate the Fields list.
  5. Click the OK button on the lower right corner to close the dialog and see the dataset and the selected fields appear in the Report Explorer.

Place a control like a Table onto the design surface and add fields to it. View the report in the preview tab and see the Parameters in the sidebar with an ALL option at the top.
Note: In a page report, when you have multiple datasets in the report, you need to set the DataSet property on the General tab of the FixedPage dialog in order to specify which dataset is used to display data in the report.
See Also

Concepts

Parameters


Add a Cascading Parameter

Add a Cascading Parameter
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Add Parameters > Add a Cascading Parameter

When a parameter’s value list depends on the value of another parameter, the report collects the required parameter value and uses it to create the value list for the second parameter. This cascade of parameter values is sometimes also called dependent or hierarchical parameters.

Use the following instructions to create your own cascading parameters. These steps assume that you have added a Page Report/RDL template to your report and have a data connection in place. See Adding an ActiveReport to a Project and Connect to a Data Source for further information. Also refer to Add a Dataset before reading this topic.

Note: This topic uses the Reels database. By default, in ActiveReports, the Reels.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\Reels.mdb.
  1. In the Report Explorer, right-click the Data Source (DataSource1 by default) node and select Add Data Set to create a dataset named Regions.
  2. On the Query page of the DataSet Dialog, use the following SQL Query to fetch data from the Regions table.
    SELECT RegionID, Region FROM Regions
  3. Click OK to close the Regions DataSet dialog.
  4. Follow step 1 to create another dataset named Districts and on the Parameters page of the DataSet Dialog, click the Add(+) icon to add a parameter named Region with the value set to:
    =Parameters!Region.Value
    This parameter is added to the Report Parameters collection later.
  5. In the Districts dataset dialog, on the Query page, add the following SQL query to fetch data from the Districts table. This query depends on the Region parameter.
    SELECT DistrictID, District FROM Districts WHERE Region = ?
  6. Click OK to close the Districts DataSet dialog.
  7. Follow step 1 and create another dataset named StoreNames and on the Parameters page of the DataSet Dialog, click the Add(+) icon to add a parameter named DistrictID with the value set to:
    =Parameters!DistrictID.Value
    This parameter is added to the Report Parameters collection later.
  8. In the StoreNames dataset, on the Query page, add the following SQL query to retrieve data for the selected region from the selected district. This query depends on the DistrictID parameter.
    SELECT StoreID, StoreName, OpenDate FROM Store WHERE NOT StoreID = 0 AND DistrictID = ?
  9. Click OK to close the StoreNames DataSet dialog.
  10. In the Report Explorer, right-click the Parameters node and select Add Parameter
  11. In the Report - Parameters dialog that appears, add a parameter named Region with an Integer data type. On the Available Values tab, select From query and set the dataset to Regions, the value field to RegionID, and the label field to Region.
  12. Click OK to close the Report - Parameters dialog.
  13. Follow the same process as steps 10 and 11 to add a second parameter named DistrictID with an Integer data type. On the Available Values tab, select From query and set the dataset to Districts, DistrictID for the value field, and District for the label field.
  14. From the Visual Studio toolbox, drag and drop a Table data region (or any other data region) onto the design surface, and drag the StoreID, StoreName and OpenDate fields onto the table details row.
  15. Click the Preview Tab to view the result.

Notice that the two drop down lists, for regions and districts appear in the Parameters sidebar while the second drop down list remains disabled until a region is selected. Click the View Report button to see the StoreID, StoreName and OpenDate values returned for the selected region and district.
Note: In a Page Report, when you have multiple datasets in the report, you need to set the DataSet property on the General tab of the FixedPage dialog in order to specify which dataset is used to display data in the report.
See Also

Concepts

Parameters


Set a Hidden Parameter

Set a Hidden Parameter
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Add Parameters > Set a Hidden Parameter

If you want to run a report without prompting the user for a value at runtime, you need to set a default value for each parameter. The report collects the required parameter value from the default value and uses it to generate the report.

Default values can be queried or non-queried. A non-queried default value can be a static value or an expression. A queried default value is a field value from a dataset.

Use the following instructions to create your own hidden parameters. These steps assume that you have added a Page Report/RDL Report template to your report and have a data connection in place. See Adding an ActiveReport to a Project and Connect to a Data Source for further information. Also refer to Add a Dataset before reading this topic.

Note: This topic uses the DVDStock table in the Reels database. By default, in ActiveReports, the Reels.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.
  1. In the Report Explorer, right-click the Parameters node and select Add Parameter.
  2. In the Report - Parameters dialog that appears, add a parameter named StorePrice with an Integer data type. Click the checkbox next to Hidden to hide the parameter UI at runtime.
  3. On the Default Values tab, select Non-queried and click the Add(+) icon to add an empty expression for the value.
    Note: When you use From query to provide a default value, only the first returned row value is used as the default value.
  4. In the Value field enter 5 and click OK to close the Report - Parameters dialog.
    Note: When adding multiple default values, in the Report - Parameters dialog, General tab, check the Multivalue check box, otherwise the report collects only the first default value from the list and uses it to generate the report.
  5. In the Report Explorer, right-click Data Source (DataSource1 by default) node and select Add Data Set to create a dataset.
  6. In the DataSet Dialog that appears, on the Parameters page, click the Add(+) icon to add an empty expression for the parameter.
  7. In the Name field, enter the same parameter name (StorePrice) you had added in the steps above and set its value to:
    =Parameters!StorePrice.Value
  8. On the Query page of the DataSet Dialog, use the following SQL query to fetch data from the DvDStock table.
    SELECT * FROM DvDStock WHERE StorePrice IN (?).
  9. From the Visual Studio toolbox, drag and drop a Table data region (or any other data region) onto the design surface, and from the Report Explorer, drag the Title, StorePrice and In Stock fields onto the table details row.
  10. Click the Preview Tab to view the result.

Notice that the report collects the required parameter value from the default value (i.e. 5) and uses it to display the list of Movie DVDs with Store Price $5.
See Also

Concepts

Parameters


Create and Add Themes

Create and Add Themes
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Create and Add Themes
Show All Show All
Hide All Hide All

A theme is a collection of properties that defines the appearance of a report. A theme includes colors, fonts, images, and expressions that you can apply to report elements once you add a theme to a report.

You can add one or many themes to a report. If a report has multiple themes, you can use the report's CollateBy property to control the page order in a report. For more information, see Collation.

Use the following instructions to create and add themes.

To create a new theme

  1. From the Start menu, go to All Programs > GrapeCity > ActiveReports and select ActiveReports Theme Editor.
  2. In the Theme Editor that opens, define the colors, fonts, images, and constant expressions properties for your new theme under the corresponding tabs.
  3. On the File menu, select Save.
  4. Choose a directory on your local machine and enter the name of a new theme, then click Save.

To add a theme to the report

  1. In the Designer, click the gray area around the report page to select a report.
  2. In the Properties window, select the Themes property and click the ellipsis (…) button to open the Report - Themes dialog.
  3. In the Report - Themes dialog that opens, click the Open... icon above the list of themes.
  4. In the Open dialog that appears, select a theme file from your local files and click Open.
See Also
Customize and Apply a Theme
Use Constant Expressions in a Theme

Concepts

Themes


Customize and Apply a Theme

Customize and Apply a Theme
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Customize and Apply a Theme
Show All Show All
Hide All Hide All

Use the following instructions to customize an existing theme and apply it to your report.

To modify a theme

  1. In the Designer, click the gray area around the report page to select a report.
  2. In the Properties window, select the Themes property and click the ellipsis (…) button to open the Report - Themes dialog.
  3. In the Report - Themes dialog that opens, select an existing report theme.
  4. Click the Edit... icon above the list of themes.
  5. In the Theme Editor that opens, modify the theme properties and click OK to close the dialog.

To apply a theme color

  1. In the Designer, select the report’s control (for example, a TextBox).
  2. In the Properties window, go to the color-related property (for example, the BackgroundColor property) and click the arrow to display the drop-down list of values.
  3. In the list that appears, go to the Theme tab and select the color you want.

To apply a theme font

  1. In the Designer, select the report’s control (for example, a TextBox).
  2. In the Properties window, go to a property from the Font properties group (for example, the Font property) and click the arrow to display the drop-down list of values.
  3. In the values list that appears, select a font defined in a theme (for example, =Theme.Fonts!MinorFont.Family).
See Also
Create and Add Themes
Use Constant Expressions in a Theme

Concepts

Themes


Use Constant Expressions in a Theme

Use Constant Expressions in a Theme
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Use Constant Expressions in a Theme
Show All Show All
Hide All Hide All

In the Theme Editor, you can define constant expressions to be used in a theme. Later, you can apply a constant expression to the report’s control by selecting it in the Value field of that control.

Also, you can apply a constant expression to a report’s control in code by using the following syntax (VB code example):

=Theme.Constants!Header
=Theme.Constants("Header")

Constant expressions allow you to define a name and an associated value to be used in themes.

Use the following instructions to create and use constant expressions in themes.

To define a constant expression

  1. In the Theme Editor, go to Constants.
  2. Double-click the field under Name and enter the Constant name (for example, Header).
  3. In the next field to the right, under Value, enter the Constant value (for example, Invoice#).

To use a constant expression

  1. In the Designer, select the report’s control (for example, a TextBox).
  2. In the Properties Window, go to the Values field and select the <Expression> option from the drop-down list to open the Expression Editor.
  3. In the Expression Editor, expand the Themes node with the constant expressions defined in the report theme.
  4. In the Themes node, select a constant and then click the Replace or Insert button.
  5. Click OK to add the constant expression in the TextBox.
See Also
Create and Add Themes
Customize and Apply a Theme

Concepts

Themes


Set Up Collation

Set Up Collation
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Set Up Collation

You can add multiple themes to the report. In this case, the report renders a combination of multiple outputs for each theme. For example, if a report has two themes, then the report output includes a combination of the first and the second themes, applied to each report page. You can control the combination rules of the report output in the CollateBy property.

Caution: If you are using collation in a report, you cannot use interactive features, such as drill down, links, document map, and sorting.

You can control the page order of a rendered report with multiple themes by selecting the collation mode in the CollateBy property of the report:

Note: The collection of constant expressions must be the same in all themes of a report. See Use Constant Expressions in a Theme for further information.
  1. In the Designer, click the gray area around the report page to select the report.
  2. In the Properties Window, go to the CollateBy property and select one of the available options:
    • Simple. Renders report pages without any specific sorting. For example, if you have a report with 2 themes, the report renders all pages with theme 1, then all pages with theme 2.
    • ValueIndex. Sorts report pages by page number. For example, if you have a report with 2 themes, the report renders page 1 for theme 1 and 2, then page 2 for theme 1 and 2, and so on.
    • Value. Sorts report pages by the grouping expression that you specify in the report's FixedPage dialog. For example, if you have a report with 2 themes with grouping, the report renders group1 (pages 1 and 2 of theme1, then pages 1 and 2 of theme2), then group 2 (pages 1 and 2 of theme1, then pages 1 and 2 of theme2), and so on.
      Note: In RDL Reports, the Value collation mode is not available by design.

See Add Page Numbering for information on setting cumulative page count formats for Page Report.

See Also
Add Page Numbering

Concepts

Themes
Interactive Features
Expressions


Add Hyperlinks

Add Hyperlinks
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Add Hyperlinks

In a page report or a RDL report, you can set hyperlinks in the TextBox or Image controls to access a Web page from your report. You can also set hyperlinks on Map layer data elements. These hyperlinks open in the default browser of the system.

To add a hyperlink in the Textbox or Image control

  1. Add a Textbox or Image control to the design surface.
  2. With the control selected, under the Properties window, click the Property dialog link to open the respective control's dialog and go to the Navigation page.
    OR
    With the control selected, go to the Properties window and click the ellipses near the Action property to open the Navigation page in the dialog.
  3. On the Navigation page, select the Jump to URL radio button to enable the field below it.
  4. Type or use the expression editor to provide a valid Web page address. For example, http://activereports.grapecity.com/
  5. Click OK to close the dialog.
  6. In the Properties window, enter text in the Value property of the respective control to set the display text for the Web page hyperlink. For example, GrapeCity PowerTools.

To add a hyperlink on Map layer elements

Map layer elements like point, polygon and line provides you a functionality to set hyperlinks on them to access a Web page from your report.

  1. On the design surface, click the map until the map panes appear.
  2. In the layers pane, right click the layer in use and select Edit.
  3. In the selected layer's dialog that appears, go to the Navigation page.
  4. On the Navigation page, select the Jump to URL radio button to enable the field below it.
  5. Type or use the expression editor to provide a valid Web page address. For example, http://activereports.grapecity.com/
  6. Click OK to close the dialog.
See Also

Concepts

Interactive Features


Add Bookmarks

Add Bookmarks
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Add Bookmarks

A bookmark link is similar to a hyperlink, except that it moves the viewer to another area in the report instead of opening a web page. You can add bookmarks in a two-step process:

  • Identify the place (target control) where you want to allow a user to jump to with the help of a Bookmark ID.
  • Share that Bookmark ID with another control that links to the target control.

Use the following steps to create a Bookmark ID on a Textbox control and create a bookmark link on another Textbox control at the bottom of the page.

These steps assume that you have already added a Page Report/RDL Report template to your project. See Adding an ActiveReport to a Project for further details.

To add a Bookmark ID on a control

Bookmark ID is like a URL that provides information required by the report viewer to locate the report control. You need to provide a Bookmark ID for any control to which you want to allow users to jump to via a Bookmark Link.

  1. From the Visual Studio toolbox, drag and drop a Textbox control onto the design surface.
  2. Select the Textbox to view its properties in the Properties window and enter any text in the Value property (For e.g., Top).
  3. Click the Property dialog link below the Properties window to open the Textbox dialog.
  4. In the TextBox dialog that appears, select the Navigation page and in the Bookmark ID field enter text like Link Text.
  5. Click OK to close the dialog.
Tip: You can also set the Bookmark ID through the Bookmark property in the Properties window.

To set a bookmark link

Bookmark Link is a simple link you create to jump to the location where the Bookmark ID is set.

  1. From the Visual Studio toolbox, drag and drop another Textbox control onto the design surface. Place it at the bottom of the page for this example.
  2. Select the Textbox to view its properties in the Properties window and in the Value property enter Go to Top.
  3. Click the Property dialog link below the Properties window to open the Textbox dialog.
  4. In the Textbox dialog that appears, click on the Navigation page and select the Jump To Bookmark radio button to activate it.
  5. Under Jump To Bookmark, enter the same text (i.e. Link Text) you assigned as Bookmark ID in the steps above.
  6. Click OK to close the dialog.
  7. Go to the Preview Tab, and click Go to Top.

You move to the top of the page where the Bookmark ID was set on the control.

Tip: You can also access the Navigation page of a control to set the bookmark link through the ellipsis button next to the Action property in the Properties window.
See Also

Concepts

Interactive Features


Create and Use a Master Report (RDL Report)

Create and Use a Master Report (RDL Report)
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Create and Use a Master Report (RDL Report)
Show All Show All
Hide All Hide All

In an RDL report, you can create a master report and apply it to any number of content reports to keep common styles in one easy-to-maintain location. You can save the master report locally on your system or on ActiveReports Server. See Master Reports for more information.

To design a master report

Note: These steps assume that you have already added an RDL Report template and connected it to a data source. The Master Report feature is only available with RDL Reports. See the topic, Adding an ActiveReport to a Project for further information.
  1. With focus on the report, from the Report Menu, select Convert to Master Report to create a master report.
  2. Right-click the ruler area to the top or left of the report and choose Page Header. Repeat and choose Page Footer.
  3. From the toolbox, drag and drop controls into the page header and footer sections. These controls appear on every page of a content report when you apply the master report. For example, a company logo image, or a textbox with the company Web site address.

  4. A ContentPlaceHolder control appears in the toolbox when you convert an RDL report to a Master Report. This control defines regions where users can add content. Use the following instructions to add the ContentPlaceHolder control in the master report.

    • From the toolbox, drag and drop the ContentPlaceHolder control onto the report design surface.
    • Right-click the control and from the context menu that appears, select Properties to open the properties window.
    • Set the following properties for the ContentPlaceHolder control.

      Property | Description
      Location | To position the control with respect to the top left corner of the container.
      Size | To set the control size for determining the space available to design a content report.
      Text | To add instructive text for the user. E.g. "Design your content report here." This caption appears in the design view and not in the final output.

  5. Save the master report locally on your system or on ActiveReports Server.

    To save a master report locally

    1. In Visual Studio, select the report, and from the Report menu, select Save Layout. In the stand-alone designer, the option is in the File menu. You can also save the master report from File menu of the stand-alone designer.
    2. In the Save As dialog that appears, navigate to the location where you want to save the report and click Save to save the report in rdlx-master file format.

    To save a master report to the server

    1. In Visual Studio, select the report, and from the Report menu, select Save Layout to Server. In the stand-alone designer, in the File menu, select Save to server.
    2. Connect your Visual Studio designer or stand-alone designer to ActiveReports Server if you are not already connected. See Connecting to ActiveReports Server for further information.
    3. In the Save to server dialog that appears, double-click to navigate through the categories hierarchy and then select a location where you want to save the report.
    4. Enter the Report name and add a brief description of the report in the Description section. In the Comment section, enter a revision comment to explain the type of changes made to the report. See Report Versions for further information.
    5. Click the Save button to save the master report under the selected category on ActiveReports Server. Once you save the master report on the server, ActiveReports automatically marks the report as a remote report.

To use a master report

  1. With focus on the report to which you want to apply the master report, from the Report menu, select Set Master Report, then Open Local File.
  2. In the Open dialog that appears, navigate to the location where you saved the master report and open it. The master report layout is applied to the content report with all areas locked except for the region with the ContentPlaceHolder, which is available for use.

To use a shared master report

  1. With focus on the report to which you want to apply the master report, from the Report menu select Set Master Report, then Open From Server.
  2. Connect your stand-alone designer to ActiveReports Server if you are not already connected. See Connecting to ActiveReports Server for further information.
    Note: Users require Read permission to access a shared master report.
  3. In the Open report from server dialog that appears, navigate through the categories hierarchy to the location where you saved the master report and open it. The master report layout is applied to the content report with all areas locked except for the region with the ContentPlaceHolder, which is available for use.
See Also

Concepts

Master Reports (RDL)
Report Types


Working with Images

Working with Images
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Working with Images

The Image report control displays an image that you embed in a report, add to a Visual Studio project, store in a database, access through a URL or access in ActiveReports Server. You can choose an Image Source in the Properties window after you place the Image report control on a report.

To embed an image in your report

The benefit of using an embedded image is that there is no separate image file to locate or keep track of when you move the report between projects. The drawback of using embedded images is that when you use large images, it increases the size of your report.

  1. In the Report menu, select Embedded Images.
  2. Click under the Image column to reveal an ellipsis button (...) and select an image file from your local files. The Name and MimeType columns are filled in automatically and the image is stored in the report definition.
  3. With the Image report control selected, in the Properties grid, set the Source property to Embedded.
  4. In the Value property, select the embedded image from the drop-down list box.

To add a data visualizer image to your report

You can use a data visualizer to display data in small graphs that are easy to comprehend.

  1. With the Image report control selected, in the Properties grid, drop down the Value property and select <Data Visualizer...>.
  2. In the Data Visualizers dialog that appears, select the Visualizer Type that you want to use, Icon Set, Range Bar, or Data Bar.
  3. Use expressions related to your data to set the other values in the dialog.

To store an image in your Visual Studio project.

You may have an image that you want to use in multiple reports, for example a logo. In such cases, you can store your image as a project image. This not only allows you to quickly locate the correct image for new reports in the project, but also makes it easier when you update your logo, as you will not need to search through every report to replace embedded images. Another benefit is that the images are distributed with your application.

  1. From the Project menu, select Add Existing Item and navigate to the image file that you want to add to the project.
  2. With the Image report control selected, in the Properties grid, set the Source property to External.
  3. In the Value property, select project image from the drop-down list box.

To use a database image in an Image report control

Product catalogues are probably the most common scenario in which images stored in a database are used in reports. Place the Image report control in a data region to use database images that repeat for every row of data.

Note:
  • You cannot use database images in Page Headers and Page Footers because these sections cannot use the value expressions that refer to fields.
  • Microsoft Access database images are generally stored as OLE objects which the Image report control cannot read.
  1. With the Image report control selected, in the Properties grid, set the Source property to Database.
  2. In the Value property, select the field containing the image.

To use a Web image

You can also use any image to which you can navigate via a URL. The advantage of using web images is that images stored in this way add nothing to the file size of the project or of the report, but the drawback is that if the web based image is moved, it will no longer show up in your report.

  1. With the Image report control selected, in the Properties grid, set the Source property to External.
  2. In the Value property, enter the URL for the image.

To use a shared image

You can also use images that are stored on an instance of ActiveReports Server. The advantage of using shared images is that you can simultaneously access these images in multiple reports and share them with multiple report authors.

  1. With the Image report control selected, in the Properties grid, set the Source property to External.
  2. In the Value property, from the drop-down list box select <Open from Server...> to open the Open Server Shared Image dialog.
  3. Connect your Visual Studio designer or stand-alone designer to ActiveReports Server if you are not already connected. See Connecting to ActiveReports Server for further information.
  4. In the Open Server Shared Image dialog that appears, select the image that you want to use in your report.
  5. Click OK to add the image to your report.
See Also
Connecting to ActiveReports Server

Concepts

Image


Sort Data

Sort Data
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Sort Data
Show All Show All
Hide All Hide All

In a page report and a RDL report, you can apply sorting on a data region, grouped data or fixed page.

Use the following steps to determine how to sort your data. These steps assume that you have already added a Page Report (xml-based)/RDL Report template to your project and connected it to a data source. See Adding an ActiveReport to a Project, Connect to a Data Source and Add a Dataset for more information.

Sorting in a Data Region

You can set the sorting expression on the Sorting page of a data region dialog.

  1. Right-click the data region and select Properties to open the Properties window. Select the Property dialog link under properties where the commands are displayed to open the data region dialog. See Properties Window for more information.
  2. In the dialog that appears, go to the Sorting page and click the Add(+) icon to add an empty expression to the sorting list below.
  3. In the Expression field, enter the expression directly or use <Expression...> from the dropdown to open the Expression Editor and select the field on which you want to sort your data.
  4. Under Direction, select Ascending or Descending to set the order in which to sort your data.
  5. Click OK to close the dialog.
  6. From the Report Explorer, drag and drop the field on which the sorting expression is set and go to the Preview Tab to view the result.

The following image shows the result after setting sorting in a Table data region on the Title field in Ascending order:

Sorting on Grouped Data

You can sort the order of groups through the Sorting tab of the Groups page or the Detail Grouping page of the List data region. The following steps assume that you have already grouped data in the data region. See Grouping in a Data Region for further information on grouping.

Note: In a Chart data region dialog, the Sorting tab is available on the Category Groups and Series Groups pages.
  1. On the Groups or the Detail Grouping page of the data region dialog, select the Sorting tab.
  2. In the Sorting tab, click the Add(+) icon to add an empty expression to the sorting list.
  3. In the Expression field, enter the expression directly or use <Expression...> from the dropdown to open the Expression Editor and select the field on which you want to sort your data. The expression set here should be the same as the grouping expression.
  4. Under Direction, select Ascending or Descending to set the order in which to sort your data.
  5. Click OK to close the dialog.
  6. From the Report Explorer, drag and drop the field on which sorting is set and go to the Preview Tab to view the result.

The following image shows the result on a Table data region where grouping and sorting is set on the StorePrice field in Descending order:

Sorting on a Fixed Page

In a Page Report , if the fixed page is grouped on a dynamic value, you can sort the order of the groups through the Sorting page of the FixedPage Dialog. Follow the steps below to learn setting up sorting on a Fixed Page:

  1. Right-click the gray area of the report and select Fixed Layout Settings to open the FixedPage dialog.
    OR
    Right click the report page and select Properties to open the Properties window. Select the Property dialog link under properties where the commands are displayed to open the FixedPage dialog. See Properties Window for more information on commands.
  2. In the FixedPage dialog that appears, go to the Grouping page and in the Expression field, enter the expression directly or use <Expression...> from the dropdown to open the Expression Editor and select the field on which you want to group your data.
  3. In the FixedPage dialog, now go to the Sorting page and click the Add(+) icon to add an empty expression to the sorting list below and in the Expression field enter the same expression you used for grouping the data.
  4. Under Direction, select Ascending or Descending to set the order in which to sort your data.
  5. Click OK to close and apply the settings.
  6. From the Report Explorer, drag and drop the field on which sorting is set and go to the Preview Tab to view the result.
Note: The difference in setting sorting on a Fixed Page is that it affects every data region placed on the report layout, whereas sorting on a data region is limited to the data region only.

The following images shows the result when sorting is set on a fixed page on the StorePrice field in descending order:

Page 1 Page 2
See Also

Concepts

Sorting


Allow Users to Sort Data in the Viewer

Allow Users to Sort Data in the Viewer
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Allow Users to Sort Data in the Viewer
Show All Show All
Hide All Hide All

In a page report or a RDL report, you can allow the end-user to sort columns of data in the Viewer by setting interactive sorting on a TextBox control within a data region. Follow the steps below to set interactive sorting in a TextBox control.

To set interactive sort properties on a TextBox

These steps assume that you have already added a Page Report (xml-based)/RDL Report template to your project and connected it to a data source and a data set. See Connect to a Data Source and Add a Dataset for further information.

  1. From the toolbox, drag a Table data region onto the report.
  2. From the Report Explorer, drag fields into the detail row of the table. Labels appear in the table header row, and expressions appear in the detail row.
  3. Click to select a TextBox in the header row on which you want to allow users to sort, and in the Commands section at the bottom of the Properties Window, click the Property dialog command.
  4. In the TextBox dialog that appears, select the Interactive Sort page.
  5. Select the checkbox next to Add an interactive sort action to this textbox and enable the other properties on the page.
  6. Under Sort expression, drop down the list and select the expression containing the value of the field on which you want to provide sorting.
    Note: Under Data region or group to sort, and Evaluate sort expression in this scope, you can optionally choose a different a scope from the Choose data region or grouping drop down list.
  7. Click OK to close the dialog and accept the changes.

When you preview the report, you can see a sort icon next to the TextBox control, the User Rating header in this case.

You can click the icon to sort in descending order. The icon changes to an up arrow that you can click to sort ascending.
See Also

Concepts

TextBox


Create a Drill-Down Report

Create a Drill-Down Report
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Create a Drill-Down Report

In a page layout, you can set up data regions, report controls, table rows, and tablix row and column groups to collapse, so that users can drill down into the data they choose to view.

In order to collapse an item, you use the Visibility settings available in the Properties Window or in the control dialog. You set the initial visibility of the report controls to Hidden and allow the user to toggle them by clicking other report controls (usually a TextBox).

When the report is initially displayed at run-time, the toggle items display with plus sign icons that you can click to display the detail data. Use the following steps to set a drill-down link.

  1. From the Visual Studio toolbox, drag and drop a TextBox control and a Table data region onto the report design surface.
  2. Place the TextBox control such that it appears as a header on your report.
  3. From the Report Explorer, expand your data set and drag fields and place them inside the detail row of the Table data region. Expressions for these fields appear in the detail row, and labels appear in the table header row.
  4. With the Table data region selected on the design surface, under the Properties window, click the Property dialog link. This is a command to open the respective control's dialog. See Properties Window for more on how to access commands.
  5. In the Table dialog that appears, go to the Visibility page, change the Initial visibility to Hidden, and select the check box next to Visibility can be toggled by another report control.
  6. From the drop-down list that appears, select the TextBox that you added in step 1. The TextBox is now used to toggle items in the Table and show detail data.
  7. Click OK to save the changes.

When you view the report, the Textbox displays an Expand/Collapse icon to its left.

Click the icon to view the hidden data.
See Also

Concepts

Drill-Down Reports


Set a Drill-Through Link

Set a Drill-Through Link
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Set a Drill-Through Link

In a page report or a RDL report, you can use drill-through links to connect one report to another detailed report. Follow the steps to set a drill-through link:

  1. On the design surface, select a report control (like a TextBox) on which you want set the link and under the Properties window, click the Property dialog link. This is a command to open the TextBox dialog. See Properties Window for more on how to access commands.
  2. In the control dialog that appears, go to the Navigation page and under Action, select the Jump to report radio button. Doing this activates the fields below it.
  3. Under the Jump to Report field, enter the name of the report (like BasicReport.rdlx) that you want to navigate to on clicking the drill-through link.
    Note: Under the Jump to Report field, when you enter just a report name, the targeted report should be kept in the same directory as the parent report. Else, you can also enter the relative path to the location of the report. You can also use a report from your connected database using the Custom Resource Locator.

  4. After setting the detail report to drill-through, on the Navigation page, under Parameters, you can optionally enter a valid parameter Name and Value to pass to the detail report. This value must evaluate to a valid value for the parameter. By setting parameters you can jump right to the desired information. For example, if your summary report contains a list of invoice numbers and delivery dates for each customer, you could use a drill-through link with the invoice number as the parameter to allow the user to jump to the relevant invoice.

    Caution: The Parameter Name must exactly match the name of the parameter in the detail report. If any parameter is spelled differently, capitalized differently, or if an expected parameter is not supplied, the drill-through report fails.

  5. Go to the preview tab and click the drill-through link to navigate to the targeted report.
  6. On the Viewer toolbar, click the Back to Parent Report button to return to the main report.

The following images show a simple drill-through link set on a list displaying years. Click any year to drill-through to a report that contains top movies in that year.

Report With a Drill-Through Link

Target Report
See Also

Concepts

Linking in Reports


Add Items to the Document Map

Add Items to the Document Map
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Add Items to the Document Map

In a page report or a RDL report, use the following steps to add report controls, groups and detail groups to the document map.

To add a control to the Document Map

Using Document Map Label or Label Property

  1. On the design surface, select a control you want to add to the Document map and right-click to choose Properties from the context menu.
  2. In the command section of the Properties Window, click Property dialog. This is a command to open the control's dialog. See Properties Window for more information on how to access commands.
  3. In the dialog that appears, go to the Navigation page and under the Document map label, enter a text or an expression representing the control in the Document map.

Alternatively,

  1. On the design surface, select the report control you want to add to the Document map and right-click to choose Properties from the context menu.
  2. In the Properties window that appears, enter a text or an expression in the Label property to represent the report control in the Document map.

Using HeadingLevel Property

  1. On the design surface, select the report control you want to add to the Document map and right-click to choose Properties from the context menu.
  2. In the Properties window that appears, set the HeadingLevel property to represent the report control in the Document map.
    Note The HeadingLevel property defines the DocumentMap level for that control.

Go to the preview tab or the Viewer to view the document map.

To add a group or a detail group to the Document Map

  1. Open a report that contains a group. See Grouping in a Data Region for further information.
  2. On the design surface, select the data region on which grouping or detail grouping has been set and go to the command section which appears below the Properties Window.
  3. Click Property dialog to open the data region dialog. See Properties Window for more information on how to access commands.
  4. In the dialog that appears, go to the Grouping or Detail Grouping page, and under the Document map label, enter a text or an expression representing the group or detail group in the Document Map.

Go to the preview tab or the Viewer to view the document map.

To create a hierarchical Document Map

  1. Open a report that contains a data region like a Table.
  2. With the data region selected, right-click to open the context menu and select Properties.
  3. In the Properties Window that appears, select the Property dialog command at the bottom of the window to open the data region dialog. See Properties Window for further information on how to access commands.
  4. On the data region dialog, on the Groups page, set the grouping expression. For example, group the data on StorePrice (=Fields!StorePrice.Value). See Grouping in a Data Region for further information.
  5. On the same Groups page, set the Document map label to the value of the grouping expression. For example, =Fields!StorePrice.Value.
  6. On the design surface, select a control inside the data region. For example, the TextBox in the detail row of the Table data region.
  7. Right-click the control and select properties to open the Properties Window. In the command section of the Properties Window, click Property dialog.
  8. In the dialog that appears, go to the Navigation page and under the Document map label, enter a text or an expression representing the control in the Document map.

Go to the preview tab or the Viewer to view the document map.
Note: In an Page report, you can also set grouping and set the document map label on the FixedPage dialog > Groups page. See Grouping in a FixedPage to learn how to set groups on a fixed page.

To set the numbering style for Document Map levels

You can the set the numbering style for all document map levels using the Report dialog or in the Properties Window using the DocumentMap property.

  1. In the Report Explorer select the Report item.
  2. In the command section of the Properties Window, click Property dialog. This is a command to open the Report dialog. See Properties Window for more information on how to access commands.
  3. In the Report dialog that appears, go to the Document Map page and set the Source property to one of the available value.
  4. Set the Numbering Style to one of the available formats. The selected style would get applied to all the document levels and only to the selected source that you had set above.
  5. Click OK to close the dialog.

You can also set separate numbering style to different document map levels using the DocumentMapLevelDesigner Collection Editor dialog.

  1. In the Report Explorer select the Report item.
  2. Go to the Properties Window, click the Levels (Collection) property and then click the ellipsis button that appears.
  3. In the DocumentMapLevelDesigner Collection Editor dialog that appears, consider the hierarchy of report bookmarks that appears in Document Map and add as many levels required using the Add button.
  4. Select each level and set its NumberingStyle to any of the available format.
  5. Click OK to close the dialog.
Note: Any customization made here gets directly applied to the TableOfContents control.


Change Page Size

Change Page Size
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Change Page Size

You can change the size of your page through the Appearance page of the Report Dialog.

To change the page size

  1. Click the gray area outside the design surface to select the report and under the Properties Window, click the Property dialog command.
  2. In the Report dialog that appears, on the Appearance page, select from a list of pre-defined Paper Size options from the dropdown list. This automatically changes the Height and Width values of the page based on the selected size.
  3. Set the Orientation of the page to Portrait or Landscape. This also modifies the Height and Width values of the page.

You can also set the page size through the PageSize property in the Properties Window.

Note: The unit of measure is based on your locale, but you can change it by typing in a different unit designator such as cm or pt after the number.
See Also

Concepts

Report Dialog


Add Page Breaks in RDL (RDL Report)

Add Page Breaks in RDL (RDL Report)
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Add Page Breaks in RDL (RDL Report)

In a page layout, you can add page breaks in a RDL report, using the PageBreakAtStart and PageBreakAtEnd properties of the report control.

You can set a page break before or after the Container control. It is also possible to force a page break before or after the following data regions or their groups:

  • List
  • Table
  • Tablix
  • Chart

Use the following steps to set page breaks in the report from the control dialogs:

To add a page break before or after a report control

  1. On the design surface, select the report control on which you want to add a page break and in the command section of the Properties Window, click Property dialog. This is a command to open the control's dialog. See Properties Window for more information on how to access commands.
  2. In the control's dialog that appears, on the General page, under Page Breaks, select the check box for Insert a page break before this control or Insert a page break after this control or both.
  3. Click the OK button to save the changes and to close the dialog.
  4. Go to the preview tab to view the result.

To add a page break before or after a group

  1. On the design surface, select the report control containing a group and in the command section of the Properties Window, click Property dialog. This is a command to open the control's dialog. See Properties Window for more information on how to access commands.
  2. In the control's dialog that appears, go to the Groups or Detail Grouping page whichever is available.
  3. On the Groups or Detail Grouping page, go the Layout tab and select the check box for Page break at start or Page break at end or both.
  4. Click the OK button to save the changes and to close the dialog.
  5. Go to the preview tab to view the result.
See Also

Concepts

Report Definition Language (RDL) Report


Add Totals and Subtotals in a Data Region

Add Totals and Subtotals in a Data Region
ActiveReports 10 > ActiveReports User Guide > How To > Page Report/RDL Report How To > Add Totals and Subtotals in a Data Region
Show All Show All
Hide All Hide All

You can add subtotals and grand totals in a data region to add meaning to the data it displays.

Use the steps below to learn how to set subtotals and totals in each data region. These steps assume that you have already added a Page Report/RDL Report template and connected it to a data source. See Adding an ActiveReport to a Project, Connect to a Data Source and Add a Dataset for more information.

Note: This topic uses examples from the tables in the Reels database. By default, in ActiveReports, the Reels.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\Reels.mdb.

To add Totals and Subtotals in a Table

To add a subtotals to a table group

  1. From the Visual Studio toolbox, drag and drop a Table data region onto the design surface.
  2. From the Report Explorer, drag a numeric field (like InStock) onto the detail row of the Table. This is the field for which you want to display subtotals.
  3. Follow the steps below to add groups to the Table data region.
    • Click inside the Table to reveal the row and column handles along the left and top edges.
    • Right-click in the row handles along the left edge of the table and select Insert Group.
    • In the Groups dialog that appears, set a Group on expression (like StorePrice) on which you want to group the data.
    • Click the OK button to close the dialog and add the group. A new pair of rows for group header and footer appear on the Table.
  4. From the Report Explorer, drag and drop the numeric field (like InStock) you added to the detail row in step 2, onto the GroupFooter row.
  5. Double click the textbox containing the field you just dropped onto the GroupFooter row and add a Sum function to its expression to calculate the total [for example, =Sum(Fields!InStock.Value)].
  6. Go to the Preview Tab to see the subtotals appearing below each group of data in the Table.

To add a grand total to a table

  1. Drag the numeric field (like InStock) you used to set subtotals on in the procedure above onto the Table Footer row.
  2. Double click the textbox containing the field you just dropped onto the Table Footer row and add a Sum function to its expression to calculate the total [for example, =Sum(Fields!InStock.Value)].
  3. Go to the Preview Tab and notice that at the end of the table, the Textbox from the Table Footer row supplies the grand total.

To add Totals and Subtotals in a List

To add a subtotals to a list

  1. From the Visual Studio toolbox, drag and drop a List data region onto the design surface.
  2. From the Report Explorer, drag and drop a numeric field (like Price) onto the List data region.
  3. Double click the textbox containing the field you just dropped and add a Sum function to its expression to calculate the total [for example, =Sum([Price] * [Quantity])].
    Note: If you preview the report at this point, you will notice that the field renders the grand total for the dataset after each sales amount.
  4. Follow the steps below to add detail grouping to the List data region.
    • Right-click the list and select Properties.
    • In the Detail Grouping page, select a Group on expression (like AccountNumber) on which you want to group the data.
    • Click the OK button to close the dialog and apply grouping.
  5. Go to the Preview Tab to view the report, you can see a subtotal on price for each account number.

To add a grand total to a list

  1. Drag the numeric field that shows subtotals in your list (like Price) just below the List data region.
  2. Double click the textbox containing the field you just dropped and add a Sum function to its expression to calculate the grand total [for example, =Sum([Price] * [Quantity], "List1")].
  3. Go to the Preview Tab and notice that below the List there is a Textbox that supplies the grand total.

To add Totals and Subtotals in a BandedList

To add a subtotal to a banded list

  1. From the Visual Studio toolbox, drag and drop a BandedList data region onto the design surface.
  2. From the Report Explorer, drag a numeric field (Like InStock) onto the detail band of the banded list.
  3. Follow the steps below to add groups to the BandedList data region.
    • Right-click the BandedList and select Insert Group.
    • In the Groups dialog that appears, select a Group on expression (like StorePrice) on which you want to group the data.
    • Click the OK button to close the dialog and add a group. A new pair of group bands appear on the data region.
  4. From the Report Explorer, the numeric field (like InStock) you added to the detail band in step 2, onto the GroupFooter band.
  5. Double click the textbox containing the field you just dropped and add a Sum function to its expression to calculate the subtotal[for example, =Sum(Fields!InStock.Value)].
  6. Go to the Preview Tab to view the report to see the subtotals appearing below each group of data in the BandedList.

To add a grand total to a banded list

  1. Drag the numeric field (like InStock) you used to set subtotals on in the procedure above onto the BandedListFooter band.
  2. Double click the textbox containing the field you just dropped onto the BandedListFooter band and add a Sum function to its expression to calculate the total [for example, =Sum(Fields!InStock.Value)].
  3. Go to Preview Tab and notice that at the end of the BandedList, the Textbox from the BandedListFooter band supplies the grand total.

To add Totals and Subtotals in a Tablix

Note: In this example, we are using the Sale table from the Reels database.

To add a subtotal to a Tablix group

  1. From the Visual Studio toolbox, drag and drop a Tablix data region onto the design surface.
  2. Drag and drop the Store field from the Report Explorer to the row group area (bottom left corner) of the Tablix data region. This is the row header, and dragging a field into it automatically adds a row group.
  3. Drag and drop the SaleDate field from the Report Explorer to the column group area (top right corner) of the Tablix data region. This is the column header, and dragging a field into it automatically adds a column group. Modify the SaleDate field expression to =[SaleDate].Year to provide yearly data.
  4. Drag and drop the SalesAmount field from the Report Explorer to the body area (bottom right corner) of the Tablix data region. This will automatically set expression of the cell to =Sum(Fields!SalesAmount.Value).
  5. Right-click the column group area, select Add Total, and then click After. A new column appears to the right with the text Total. This displays the subtotals for each row group.
  6. Right-click the row group area, select Add Total, and then click After. A new row appears at the bottom with the text Total. This displays the subtotals for each column group.

  7. Go to the Preview tab to view the subtotals for each year.

To add a grand total to a Tablix

  1. The row and columns subtotals set in the previous procedure, intersect at the rightmost cell of the Tablix that contains the grand total of the combined sales amount for years 2004 and 2005 in all the stores.
  2. Go to the Preview tab to view the result.
See Also
Tablix
Tablix Reports

Concepts

Expressions
Common Functions


Section Report How To

Section Report How To
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To

Learn to perform common tasks in Section reports with quick how-to topics.

This section contains information about how to

Work with Data in Section Reports
Learn how to work with Section reports and perform various reporting tasks specific to this type of report.
Work with Report Controls
Learn how to work with fields, display page numbers, add charts, and many other tasks with Section report controls.
Create Common Section Reports
Learn what the tools and UI items on the report designer can help you to accomplish.
Inherit a Report Template
Learn how to inherit a report template in other reports to share common features with multiple reports.
Change Ruler Measurements
Learn how to change ruler measurements at design time and runtime.
Print Multiple Copies, Duplex and Landscape
Learn how to set duplex and landscape printing from the Report Settings dialog and also set printing for multiple copies.
Conditionally Show or Hide Details
Learn how to conditionally show or hide details in a section layout report.
Add Parameters in a Section Report
Learn how to use parameters to filter data in the report.
Add and Save Annotations
Learn how you can save a report with annotations to RDF and add annotations in a report at runtime.
Add Bookmarks
Learn how to set bookmarks.
Add Hyperlinks
Learn how to add hyperlinks in a section layout report.
Use External Style Sheets
Learn how to use external style sheets in a section layout report.
Insert or Add Pages
Learn how to insert or add pages in section layout report.
Embed Subreports
Learn how to create add a subreport to a child report in the project.
Add Code to Layouts Using Script
Learn how to add code to the layouts using script.
Save and Load RDF Report Files
Learn how to save and load a .rdf report file.
Save and Load RPX Report Files
Learn how to save and load a .rpx report file.
See Also
Page Report/RDL Report How To


Work with Data in Section Reports

Work with Data in Section Reports
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Work with Data in Section Reports

See step-by-step instructions for performing common tasks using ActiveReports.

This section contains information about how to:

Bind Reports to a Data Source
Learn how to bind reports to various data sources.
Add Grouping in Section Reports
Learn how to use the GroupHeader section to group data in a section report.
Modify Data Sources at Run Time
Learn to use code to modify a report's data source.


Bind Reports to a Data Source

Bind Reports to a Data Source
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Work with Data in Section Reports > Bind Reports to a Data Source
Show All Show All
Hide All Hide All

At design time, you can connect a section report to a data source through the Report Data Source dialog. You can access the Report Data Source dialog by doing one of the following:

  • On the detail section band, click the Data Source Icon.
  • Click the gray area around the design surface and in the commands section at the bottom of the Properties Window, click the Edit Data Source command.

There are four tabs in the dialog for the four most commonly used data sources.

The following steps take you through the process of binding reports to each data source. These steps assume that you have already added an ActiveReports 10 Section Report template in a Visual Studio project. See Adding an ActiveReport to a Project further information on adding different report layouts.

To use the OLE DB data source

  1. In the Report Data Source dialog, on the OLE DB tab, next to Connection String, click the Build button.
  2. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button to move to the Connection tab.
  3. Click the ellipsis (...) button to browse to your database, for example the NWind.mdb sample database. Click Open once you have selected the appropriate database path.
  4. Click the Test Connection button to see if you have successfully connected to the database.
  5. Click OK to close the Data Link Properties window and return to the Report Data Source dialog. Notice that the Connection String field gets filled automatically.
  6. In the Query field on the OLE DB tab, enter a SQL query to select the data that you want use from the connected database. For example, Select * From CUSTOMERS
    OR
    In the Report Data Source dialog, click on [image] to access Visual Query Designer for creating SQL queries. See Visual Query Designer for further information on how to create a query using the interactive query designer.
  7. Click OK to save the data source and return to the report design surface.

To use the ODBC data source

Before you connect to a ODBC data source, you must install a ODBC driver and set up a ODBC data source. For more information, see How To: Setup an ODBC Data Source.

  1. In the Report Data source dialog, click the ODBC tab.
  2. In the Connection String field on the ODBC tab, enter a connection string to connect to the database. For example, Provider=MSDASQL;Persist Security Info=False;DSN=MS Access Database
  3. In the Query field on the ODBC tab, enter a SQL query to select the data that you want use from the connected database. For example, Select * From CUSTOMERS
  4. Click OK to save the data source and return to the report design surface.

To use the SQL data source

  1. In the Report Data Source dialog, on the SQL tab, next to Connection String, click the Build button.
  2. In the Data Link Properties window that appears, select Microsoft OLE DB Provider for SQL Server and click the Next button to move to the Connection tab.
  3. On the Connection tab of the Data Link Properties window:
    • In the Select or enter server name field, select your server from the drop down list.
    • Under Enter information to log on to the server, select the Windows NT security credentials or your specific user name and password.
    • Under Select the database on the server, select a database from the server or attach a database file.
    • Click the Test Connection button to see if you have successfully connected to the database.
  4. Click OK to close the Data Link Properties window and to return to the Report Data Source dialog. Notice that the Connection String field gets filled automatically.
  5. In the Query field on the SQL tab, enter a SQL query to select the data that you want use from the connected database. For example, Select * From CUSTOMERS
    OR
    In the Report Data Source dialog, click on [image] to access Visual Query Designer for creating SQL queries. See Visual Query Designer for further information on how to create a query using the interactive query designer.
  6. Click OK to save the data source and return to the report design surface.

To use the XML data source

  1. In the Report Data Source dialog, on the XML tab, click the ellipsis (...) button next to File URL field.
  2. In the Open File window that appears, navigate to your XML data file to select it and click the Open button. You can use a sample XML data file located at C:\Users\YourUserName\Documents\GrapeCity Samples\ActiveReports 10\Data\customer.xml.
  3. In the Recordset Pattern field, enter a valid XPath expression like the following. //CUSTOMER
  4. Click OK to save the data source and return to the report design surface.

You also have the option to use an unbound or an IEnumerable data source. See the following procedures to implement these data source connections in code.

To use an Unbound data source

To create a data connection

  1. Add an Imports (VisualBasic.NET) or using (C#) statement for System.Data and System.Data.Oledb namespaces.
  2. Right-click the gray area outside the design surface to select the report and select Properties.
  3. In the Properties window that appears, click the Events icon to view the available events for the report.
  4. In the events list, double-click the ReportStart event. This creates an event-handling method for the ReportStart event in code.
  5. Add the following code to the handler.

    To write code in VisualBasic.NET

    Visual Basic.NET code. Paste above the ReportStart event.
    Copy Code
    Dim m_cnnString As String
Dim sqlString As String
Dim m_reader As OleDbDataReader
Dim m_cnn As OleDbConnection
    Visual Basic.NET code. Paste inside the ReportStart event.
    Copy Code
    'Set data source connection string.
m_cnnString = "Provider=Microsoft.Jet.OLEDB.4.0;" _
        + "Data Source=C:\Users\YourUserName\Documents\GrapeCity Samples\ActiveReports 10\Data\Nwind.mdb;Persist Security Info=False"
'Set data source SQL query.
sqlString = "SELECT * FROM categories INNER JOIN products ON categories.categoryid " _
        + "= products.categoryid ORDER BY products.categoryid, products.productid"
'Open connection and create DataReader.
m_cnn = New OleDb.OleDbConnection(m_cnnString)
Dim m_Cmd As New OleDb.OleDbCommand(sqlString, m_cnn)
If m_cnn.State = ConnectionState.Closed Then
   m_cnn.Open()
End If
m_reader = m_Cmd.ExecuteReader()

    To write code in C#

    C# code. Paste above the ReportStart event.
    Copy Code
    private static OleDbConnection m_cnn;
private static OleDbDataReader m_reader;
private string sqlString;
private string m_cnnString;
    C# code. Paste inside the ReportStart event.
    Copy Code
    //Set data source connection string.
m_cnnString = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source="
        + @"C:\Users\YourUserName\Documents\GrapeCity Samples\ActiveReports 10\Data\Nwind.mdb;Persist Security Info=False";
//Set data source SQL query.
sqlString = "SELECT * FROM categories INNER JOIN products"
        + " ON categories.categoryid = products.categoryid"
        + " ORDER BY products.categoryid, products.productid";
//Open connection and create DataReader.
m_cnn = new OleDbConnection(m_cnnString);
OleDbCommand m_Cmd = new OleDbCommand(sqlString,m_cnn);
if(m_cnn.State == ConnectionState.Closed)
{
  m_cnn.Open();
}
m_reader = m_Cmd.ExecuteReader();

To close the data connection

  1. Right-click the gray area outside the design surface to select the report and select Properties.
  2. In the Properties window that appears, click the Events icon to view the available events for the report.
  3. In the events list, double-click the ReportEnd event. This creates an event-handling method for the ReportEnd event.
  4. Add the following code to the handler.

    To write the code in Visual Basic

    Visual Basic.NET code. Paste inside the ReportEnd event.
    Copy Code
    m_reader.Close()
m_cnn.Close()

    To write the code in C#

    C# code. Paste inside the ReportEnd event.
    Copy Code
    m_reader.Close();
m_cnn.Close();

To create a fields collection

  1. Right-click the gray area around the design surface to select the report and select Properties.
  2. In the Properties window that appears, click the Events icon to view the available events for the report.
  3. In the events list, double-click DataInitialize event. This creates an event-handling method for the report's DataInitialize event.
  4. Add code to the handler to add fields to the report's fields collection.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste inside the DataInitialize event.
    Copy Code
    Fields.Add("CategoryName")
Fields.Add("ProductName")
Fields.Add("UnitsInStock")
Fields.Add("Description")

    To write the code in C#

    C# code. Paste inside the DataInitialize event.
    Copy Code
    Fields.Add("CategoryName");
Fields.Add("ProductName");
Fields.Add("UnitsInStock");
Fields.Add("Description");

To populate the fields

  1. Right-click the gray area around the design surface to select the report and select Properties.
  2. In the Properties window that appears, click the Events icon to view the available events for the report.
  3. In the events list, double-click the FetchData event. This creates an event-handling method for the report's FetchData event.
  4. Add the following code to the handler to retrieve information to populate the report fields.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste inside the FetchData event.
    Copy Code
    Try
    m_reader.Read()
    Me.Fields("CategoryName").Value = m_reader("CategoryName")
    Me.Fields("ProductName").Value = m_reader("ProductName")
    Me.Fields("UnitsInStock").Value = m_reader("UnitsInStock")
    Me.Fields("Description").Value = m_reader("Description")
    eArgs.EOF = False
Catch ex As Exception
    eArgs.EOF = True
End Try

    To write the code in C#

    C# code. Paste inside the FetchData event.
    Copy Code
    try
{
    m_reader.Read();
    Fields["CategoryName"].Value = m_reader["CategoryName"].ToString();
    Fields["ProductName"].Value = m_reader["ProductName"].ToString();
    Fields["UnitsInStock"].Value = m_reader["UnitsInStock"].ToString();
    Fields["Description"].Value = m_reader["Description"].ToString();
    eArgs.EOF = false;
}
catch
{
    eArgs.EOF = true;
}
Tip: In order to view the added data at runtime, add controls to your report and assign their DataField property to the name of the fields you added in code while creating a field collection.
Caution: Do not access the Fields collection outside the DataInitialize and FetchData events. Accessing the Fields collection outside of these events is not supported, and has unpredictable results.

To use the IEnumerable data source

  1. Right-click the design surface and select View Code.
  2. Add the following code inside the class declaration of the report:

    To create a data source in Visual Basic

    Visual Basic.NET code. Paste inside the class declaration of the report.
    Copy Code
    Private datasource1 As IEnumerator(Of String) = Nothing
Dim list As List(Of String)= Nothing
    Visual Basic.NET code. Paste inside the class declaration of the report.
    Copy Code
    Private Function GetIEnumerableData() As IEnumerable(Of String)
    For i As Integer = 1 To 10
       list.Add(String.Format("TestData_{0}", i.ToString()))
    Next
    Return list
End Function

    To create a data source in C#

    C# code. Paste inside the class declaration of the report.
    Copy Code
    private IEnumerator<string> datasource = null;
    C# code. Paste inside the class declaration of the report.
    Copy Code
    private IEnumerable<string> GetIEnumerableData()
{
    for (int i = 1; i <= 10; i++)
    {
        yield return string.Format("TestData_{0}", i.ToString());
    }
}
  3. On the design surface, right-click the gray area around the design surface to select the report and select Properties.
  4. In the Properties window that appears, click the Events icon to view the available events for the report.
  5. Double-click the DataInitialize event. This creates an event-handling method for the report's DataInitialize event.
  6. Add the following code to the handler to add fields to the report's Fields collection.

    To add fields in Visual Basic

    Visual Basic.NET code. Paste inside the DataInitialize event.
    Copy Code
    Me.Fields.Add("TestField")
Me.list = New List(Of String)
datasource1 = GetIEnumerableData().GetEnumerator()

    To add fields in C#

    C# code. Paste inside the DataInitialize event.
    Copy Code
    this.Fields.Add("TestField");
datasource = GetIEnumerableData().GetEnumerator();
  7. Repeat steps 3 and 4 to open the events list in the property window.
  8. Double-click the FetchData event. This creates an event-handling method for the report's FetchData event.
  9. Add code to the handler to retrieve information to populate the report fields.

    To populate fields in Visual Basic

    Visual Basic.NET code. Paste inside the FetchData event.
    Copy Code
    If datasource1.MoveNext() Then
          Me.Fields("TestField").Value = datasource1.Current
          eArgs.EOF = False
    Else
          eArgs.EOF = True
    End If

    To populate fields in C#

    C# code. Paste inside the FetchData event.
    Copy Code
    if (datasource.MoveNext())
{
    this.Fields["TestField"].Value = datasource.Current;
    eArgs.EOF = false;
}
else
    eArgs.EOF = true;
Tip: In order to view the added data at runtime, add controls to your report and assign their DataField property to the name of the fields you added in code while creating a field collection.
See Also
Modify Data Sources at Run Time


Add Grouping in Section Reports

Add Grouping in Section Reports
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Work with Data in Section Reports > Add Grouping in Section Reports

In a section report, you can set grouping on a field or a field expression. Use the following steps to understand grouping in a section report.

These steps assume that you have already added a Section Report (xml-based) or Section Report (code based) template and connected it to a data source. See Adding an ActiveReport to a Project for further information.

To set grouping in a Section Report

  1. Right-click the design surface of a report and select Insert, then Group Header/Footer. Group Header and Footer sections appear immediately above and below the detail section.
  2. With the GroupHeader section selected, go to the Properties window and set the DataField to a field on which you want to group the data. For example, Country from Customers table in the NWind database.
    Note: You can also set a field expression in the DataField property. For example, =Country + City.
  3. Drag and drop the grouping field onto the GroupHeader section to see the grouping field while previewing the report.
  4. Drag and drop data fields onto the detail section. All the data placed inside the detail section gets grouped according to grouping field.
  5. Preview the report to see the result.

The following image shows a customer list grouped on the Country field.

Tip: In a section report, data is grouped in the order in which it is fetched in the raw form. Therefore, for best results, while setting the SQL query in your report data source, order the data by the grouping field. For example., SELECT * FROM Customers ORDER BY Country
See Also

Concepts

Grouping Data (Section Layout)


Modify Data Sources at Run Time

Modify Data Sources at Run Time
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Work with Data in Section Reports > Modify Data Sources at Run Time
Show All Show All
Hide All Hide All

In a section report, you can modify your data source at run time. Follow the steps below to connect your report to the NWind.mdb sample database at run time.

To find the database path

Note: These steps assume that the data path is defined in the following registry key.
  1. Right-click the design surface, and select View Code to display the code view for the report.
  2. Add the following code to the report to access the sample database path from the registry.

To write the code in Visual Basic

The following example shows what the code for the function looks like.

Visual Basic.NET code. Paste below the Imports GrapeCity.ActiveReports statement at the top of the code view.
Copy Code
Imports System
Imports Microsoft.Win32
Visual Basic.NET code. Paste inside the report class.
Copy Code
Private Function getDatabasePath() As String

End Function

This creates a function for getDatabasePath.

Visual Basic.NET code. Paste inside the getDatabasePath function.
Copy Code
Dim regKey As RegistryKey
regKey = Registry.LocalMachine
regKey = regKey.CreateSubKey("SOFTWARE\\GrapeCity\\ActiveReports\\v10")
getDatabasePath = CType(regKey.GetValue(""), String)

To write the code in C#

The following example shows what the code for the function looks like.

C# code. Paste below the using GrapCity.ActiveReports statement at the top of the code view.
Copy Code
using Microsoft.Win32;
using System;
C# code. Paste inside the report class and hit Enter.
Copy Code
private string getDatabasePath()

This creates a function for getDatabasePath.

C# code. Paste BELOW the getDatabasePath function.
Copy Code
{
RegistryKey regKey = Registry.LocalMachine;
regKey = regKey.CreateSubKey("SOFTWARE\\GrapeCity\\ActiveReports\\v10");
return ((string)(regKey.GetValue("")));
}

To change the data source at run time

  1. Double-click the gray area outside the design surface to create an event-handling method for the ReportStart event.
  2. Add the following code to the handler to change the data source at run time.

To write the code in Visual Basic.NET

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste above the ReportStart event.
Copy Code
Dim conn As System.Data.OleDb.OleDbConnection
Dim reader As System.Data.OleDb.OleDbDataReader
Visual Basic.NET code. Paste inside the ReportStart event.
Copy Code
Dim dbPath As String = getDatabasePath()
Dim connString As String = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=" + dbPath + "\NWIND.mdb"
conn = New System.Data.OleDb.OleDbConnection(connString)
Dim cmd As New System.Data.OleDb.OleDbCommand("SELECT * FROM Products WHERE UnitPrice = 18", conn)
conn.Open()
reader = cmd.ExecuteReader()
Me.DataSource = reader

To write the code in C#

The following example shows what the code for the method looks like.

C# code. Paste above the ReportStart event.
Copy Code
private static System.Data.OleDb.OleDbConnection conn;
private static System.Data.OleDb.OleDbDataReader reader;
C# code. Paste inside the ReportStart event.
Copy Code
string dbPath = getDatabasePath();
string connString = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=" + dbPath + "\\NWIND.mdb";
conn = new System.Data.OleDb.OleDbConnection(connString);
System.Data.OleDb.OleDbCommand cmd = new System.Data.OleDb.OleDbCommand("SELECT * FROM Products WHERE UnitPrice = 18", conn);
conn.Open();
reader = cmd.ExecuteReader();
this.DataSource = reader;

To close the data connection

  1. Right-click the gray area outside the design surface and select Properties.
  2. In the Properties Window that appears, click the Events button. A list of report events appear.
  3. Select the ReportEnd event and double click to create an event-handling method.
  4. Add the following code to the handler to close the data connection.

To write the code in Visual Basic

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste inside the ReportEnd event.
Copy Code
reader.Close()
conn.Close()

To write the code in C#

The following example shows what the code for the method looks like.

C# code. Paste inside the ReportEnd event.
Copy Code
reader.Close();
conn.Close();
See Also
Bind Reports to a Data Source


Work with Report Controls

Work with Report Controls
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Work with Report Controls

See step-by-step instructions on using Section report controls.

This section contains information about how to

Add Field Expressions
Learn how to add field expressions to a text box data field.
Display Page Numbers and Report Dates
Learn how to quickly add page numbering or report dates to Section reports using the ReportInfo control.
Load a File into a RichTextBox Control
Learn how to save and load an HTML or RTF file in a RichTextBox.
Use Custom Controls on Reports
Learn how to access a third party custom control in ActiveReports.
See Also
Work with Data in Section Reports
Section Report How To
Page Report/RDL Report How To


Add Field Expressions

Add Field Expressions
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Work with Report Controls > Add Field Expressions
Show All Show All
Hide All Hide All

In a section report, expressions can be used in the DataField property to specify textbox output in a report, such as date/time, mathematical calculations or conditional values. All field expressions used in the DataField property begin with the equals sign (=).

Using Field Expressions

To use a mathematical expression

Set the DataField property of a textbox control to a mathematical calculation.

Example:

=UnitPrice+5

=Quantity-5

=Quantity*UnitPrice

=UnitPrice/QuantityPerUnit

To use a substring

Set the DataField property of a textbox control to the required substring. While setting up grouping, change the GroupHeader's DataField property to the same substring.

Example:

=ProductName.Substring(0, 1)

To use date/time

Set the DataField property of a textbox control similar to the following expression to display date/time values.

Example:

=System.DateTime.Now.ToString()

To create a conditional value

Set the DataField property of a textbox control to the conditional statement as desired.

Example:

=(UnitsInStock > 0)?"In Stock":"Backorder"

To concatenate fields

Set the DataField property of a textbox control similar to the following expression to display concatenated fields.

Example:

="There are " + UnitsInStock + " units of " + ProductName + " in stock."

=TitleOfCourtesy + " " + FirstName + " " + LastName

Note: ActiveReports automatically handles null values, replacing them with an empty string.

To round a calculation

Set the DataField Property of a textbox control like the following example.

Example:

=(double)System.Math.Round(UnitsInStock/10)

To use modular division

Set the DataField property of a textbox control like the following example to get the remainder (2 in this case).

Example: =22%(5)

To replace a null value

Set the DataField property of a textbox control like the following example to replace null with your own value.

Example:

=(UnitsInStock == System.DBNull.Value) ? "No Units In Stock" : UnitsInStock


Display Page Numbers and Report Dates

Display Page Numbers and Report Dates
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Work with Report Controls > Display Page Numbers and Report Dates
Show All Show All
Hide All Hide All

With the ReportInfo control available in a section report, you can display page numbers and report dates and times by selecting a value in the FormatString property. This property provides the following pre-defined options for page numbering and date and time formatting.

Predefined Options and their Description

Numbering Format | Description
Page {PageNumber} of {PageCount} on {RunDateTime} | Display the page numbers along with Date and Time in the following format : Page 1 of 100 on 1/31/2012 2:45:50 PM
Page {PageNumber} of {PageCount} | Display the only the page numbers in the following format : Page 1 of 100
{RunDateTime:} | Display the Date and Time in the following format : 1/31/2012 2:45:50 PM
{RunDateTime: M/d} | Display the Date in the following format : 1/31
{RunDateTime: M/d/yy} | Display the Date in the following format : 1/31/12
{RunDateTime: M/d/yyyy} | Display the Date in the following format : 1/31/2012
{RunDateTime: MM/dd/yy} | Display the Date in the following format : 01/31/12
{RunDateTime: MM/dd/yyyy} | Display the Date in the following format : 01/31/2012
{RunDateTime: d-MMM} | Display the Date in the following format : 31-Jan
{RunDateTime: d-MMM-yy} | Display the Date in the following format : 31-Jan-12
{RunDateTime: d-MMM-yyyy} | Display the Date in the following format : 31-Jan-2012
{RunDateTime: dd-MMM-yy} | Display the Date in the following format : 31-Jan-12
{RunDateTime: dd-MMM-yyyy} | Display the Date in the following format : 31-Jan-2012
{RunDateTime: MMM-yy} | Display the Date in the following format : Jan-12
{RunDateTime: MMM-yyyy} | Display the Date in the following format : Jan-2012
{RunDateTime: MMMM-yy} | Display the Date in the following format : January-12
{RunDateTime: MMMM-yyyy} | Display the Date in the following format : January-2012
{RunDateTime: MMMM d,yyyy} | Display the Date in the following format : January 31, 2012
{RunDateTime: M/d/yy h:mm tt} | Display the Date and Time in the following format : 1/31/12 2:45 PM
{RunDateTime: M/d/yyyy h:mm tt} | Display the Date and Time in the following format : 1/31/2012 2:45 PM
{RunDateTime: M/d/yy h:mm} | Display the Date and Time in the following format : 1/31/12 2:45
{RunDateTime: M/d/yyyy h:mm} | Display the Date and Time in the following format : 1/31/2012 2:45

Page numbering can also be set to a group level using the SummaryGroup and SummaryRunning properties.

These steps assume that you have already added a Section Report to a project in Visual Studio. See Adding an ActiveReport to a Project for more information.

To display page numbers and report dates on a report

  1. From the ActiveReports 10 Section Report tab in the toolbox, drag the ReportInfo control to the desired location on the design surface.
  2. With the ReportInfo control selected in the Properties Window, drop down the FormatString property.
  3. Select the pre-defined format that best suits your needs.
    Tip: You can customize the pre-defined formats in the Properties Window. For example, if you change the FormatString property to Page {PageNumber} / {PageCount}, it shows the first page number as Page 1/1. For more information on creating formatting strings, see the Date, Time, and Number Formatting topic.

To display page numbers and page count at the group level

  1. From the ActiveReports 10 Section Report tab in the toolbox, drag the ReportInfo control to the GroupHeader or GroupFooter section of the report and set the FormatString property as above.
  2. With the ReportInfo control still selected in the Properties Window, drop down the SummaryGroup property and select the group for which you want to display a page count.
  3. Drop down the SummaryRunning property and select Group.
See Also
Add Page Numbering

Concepts

ReportInfo
Common Values


Load a File into a RichTextBox Control

Load a File into a RichTextBox Control
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Work with Report Controls > Load a File into a RichTextBox Control
Show All Show All
Hide All Hide All

In a section layout, you can load an RTF or an HTML file into the RichTextBox control both at design time and at run time . Following is a step-by-step process that helps you load these files into the RichTextBox control.

These steps assume that you have already added a Section Report (code based) template in a Visual Studio project and have placed a RichTextBox control inside its detail section. See Adding an ActiveReport to a Project for more information.

Caution: Do not attempt to load a file into a RichTextBox in a section that repeats. After the first iteration of the section, the RTF or HTML file is already in use by that first iteration and returns "file in use" errors when that section is processed again.

To write an RTF file to load into a RichTextBox control

  1. Open wordpad, and paste the following formatted text into it.

    Paste into an RTF File

    Customer List by Country

    Argentina

    • Rancho grande
    • Océano Atlántico Ltda.
    • Cactus Comidas para llevar

    Austria

    • Piccolo und mehr
    • Ernst Handel

    Belgium

    • Suprêmes délices
    • Maison Dewey

    Brazil

    • Familia Arquibaldo
    • Wellington Improtadora
    • Que Delícia
    • Tradição Hipermercados
    • Ricardo Adocicados
    • Hanari Carnes
    • Queen Cozinha
    • Comércio Mineiro
    • Gourmet Lanchonetes
  2. Save the file as sample.rtf in the debug directory inside the bin folder of your project.
Note: The RichTextBox control is limited in its support for advanced RTF features such as the ones supported by Microsoft Word. In general, the features supported by WordPad are supported in this control.

To load an RTF file into the RichTextBox control at design time

  1. On the report design surface, add a RichTextBox control.
  2. With the RichTextBox control selected, at the botton of the Properties Window, click the Load File command. See Properties Window for a description of commands.
  3. In the Open dialog that appears, browse to an *.RTF file (For example, sample.rtf) and click the Open button to load the file in the RichTextBox control.

To load an RTF file into the RichTextBox control at run time

Note: The RichTextBox control has limited support for advanced RTF features such as the ones supported by Microsoft Word. Therefore, use a WordPad for obtaining best results.

These steps assume that the RTF file (for example, sample.rtf) to load has been saved in the bin/debug directory of your project.

  1. Right-click the report and select View Code to open the code view.
  2. Add an Imports (Visual Basic.NET) or using (C#) statement at the top of the code view for the GrapeCity.ActiveReports.SectionReportModel namespace.
  3. In the design view, double-click the detail section of the report to create an event-handling method for the Detail Format event.
  4. Add the following code to the handler to load the RTF file into the RichTextBox control.

The following example shows what the code for the method looks like.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Detail1_Format event.
Copy Code
Dim streamRTF As New System.IO.FileStream(System.Windows.Forms.Application.StartupPath + "\sample.rtf", System.IO.FileMode.Open)
Me.RichTextBox1.Load(streamRTF, RichTextType.Rtf)

To write the code in C#

C# code. Paste INSIDE the detail_Format event.
Copy Code

System.IO.FileStream streamRTF = new System.IO.FileStream(System.Windows.Forms.Application.StartupPath + "\\sample.rtf", System.IO.FileMode.Open);
this.richTextBox1.Load(streamRTF, RichTextType.Rtf);
Note: The Application.Startup path code does not work in preview mode. You must run the project in order to see the file load.

To write an HTML file to load into a RichTextBox control

  1. Open a Notepad, and paste the following HTML code into it.

    HTML code

    HTML code. Paste in a NotePad file.
    Copy Code
    <html>
<body>
<center><h1>Customer List by Country</h1></center>
<h1>Argentina</h1>
<ul>
<li>Rancho grande
<li>Océano Atlántico Ltda.
<li>Cactus Comidas para llevar
</ul>
<h1>Austria</h1>
<ul>
<li>Piccolo und mehr
<li>Ernst Handel
</ul>
<h1>Belgium</h1>
<ul>
<li>Suprêmes délices
<li>Maison Dewey
</ul>
<h1>Brazil</h1>
<ul>
<li>Familia Arquibaldo
<li>Wellington Improtadora
<li>Que Delícia
<li>Tradição Hipermercados
<li>Ricardo Adocicados
<li>Hanari Carnes
<li>Queen Cozinha
<li>Comércio Mineiro
<li>Gourmet Lanchonetes
</ul>
</body>
</html>
  2. Save the file as sample.html.

To load an HTML file into the RichTextBox control at design time

  1. On the report design surface, add a RichTextBox control.
  2. With the RichTextBox control selected, at the bottom of the Properties Window, click the Load File command. See Properties Window for a description of commands.
  3. In the Open dialog that appears, browse to an *.html file (For example, sample.html) and click the Open button to load the file in the RichTextBox control.

To load an HTML file into a RichTextBox control at run time

These steps assume that the HTML file (for example, sample.html) to load has been saved in the bin/debug directory of your project.

  1. Right-click the report and select View Code to open the code view.
  2. Add an Imports (Visual Basic.NET) or using (C#) statement at the top of the code view for the GrapeCity.ActiveReports.SectionReportModel namespace.
  3. In the design view, double-click the detail section of the report to create an event-handling method for the Detail Format event.
  4. Add code to the handler to load the HTML file into the RichText control.

The following example shows what the code for the method looks like.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Detail1_Format event.
Copy Code
Dim streamHTML As New System.IO.FileStream(System.Windows.Forms.Application.StartupPath + "\sample.HTML", System.IO.FileMode.Open)
Me.RichTextBox1.Load(streamHTML, RichTextType.Html)

To write the code in C#

C# code. Paste INSIDE the detail_Format event.
Copy Code
System.IO.FileStream streamHTML = new System.IO.FileStream(System.Windows.Forms.Application.StartupPath + "\\sample.html", System.IO.FileMode.Open);
this.richTextBox1.Load(streamHTML, RichTextType.Html);
Note: The Application.Startup path code does not work in preview mode. You must run the project in order to see the file load.
See Also

Concepts

RichTextBox


Use Custom Controls on Reports

Use Custom Controls on Reports
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Work with Report Controls > Use Custom Controls on Reports
Show All Show All
Hide All Hide All

In a section report, ActiveReports allows you to drop a third party control onto the report design surface where it is recognized as a custom control. You can access its properties using type casting.

In the following steps, we use hidden textbox controls to populate a Visual Studio TreeView control. These steps assume that you have already added a Section Report (code-based) template in a Visual Studio project. See Adding an ActiveReport to a Project for more information.

To add the TreeView control to a report

  1. From the Visual Studio toolbox Common Controls tab, drag and drop a TreeView control onto the detail section of a report.
  2. Notice that in the Properties window, the control is called CustomControl1.

To add data and hidden TextBox controls to the report

  1. Connect the report to the sample Nwind.mdb. The following steps use the Orders table from the NWind database. By default, in ActiveReports, the Nwind.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\Nwind.mdb.
  2. From the Report Explorer, drag and drop the following fields onto the detail section of the report:
    • ShipCountry
    • ShipCity
    • CustomerID
    • EmployeeID
  3. On the design surface, select all four TextBox controls, and in the Properties window, change their Visible property to False.

To create a function to add nodes to the TreeView control

  1. Right-click the design surface and select View Code to see the code view for the report.
  2. Add the following code inside the report class to add a function to the report for adding nodes to the TreeView control.

The following examples show what the code for the function looks like.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the report class.
Copy Code
Private Function AddNodeToTreeView(ByVal colNodes As TreeNodeCollection, ByVal sText As String) As TreeNode
   Dim objTreeNode As TreeNode
   objTreeNode = New TreeNode(sText)
   colNodes.Add(objTreeNode)
   Return objTreeNode
End Function

To write the code in C#

C# code. Paste INSIDE the report class.
Copy Code
private TreeNode AddNodeToTreeView(TreeNodeCollection colNodes, string sText)
{
    TreeNode objTreeNode;
    objTreeNode = new TreeNode(sText);
    colNodes.Add(objTreeNode);
    return objTreeNode;
}

To access the TreeView control properties in code and assign data

  1. On the report design surface, double-click the detail section to create an event-handling method for the Detail_Format event.
  2. Add the following code to the handler to access the TreeView properties and assign data from the hidden TextBox controls.

The following example shows what the code for the method looks like.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Detail Format event.
Copy Code

'Type cast the custom control as a TreeView
Dim TreeView1 As New TreeView
TreeView1 = CType(Me.CustomControl1.Control, TreeView)

'Create a tree node
Dim objCountryTreeNode As TreeNode
'Assign the text from a hidden textbox to the node
objCountryTreeNode = AddNodeToTreeView(TreeView1.Nodes, Me.txtShipCountry1.Text)
'Add a second-level node
AddNodeToTreeView(objCountryTreeNode.Nodes, Me.txtShipCity1.Text)
'Expand the top-level node so the second-level node is in view
objCountryTreeNode.Expand()

'Create a second top-level node
Dim objCustomerTreeNode As TreeNode
objCustomerTreeNode = AddNodeToTreeView(TreeView1.Nodes, Me.txtCustomerID1.Text)
AddNodeToTreeView(objCustomerTreeNode.Nodes, Me.txtEmployeeID1.Text)
objCustomerTreeNode.Expand()

To write the code in C#

C# code. Paste INSIDE the Detail Format event.
Copy Code
//Type cast the custom control as a TreeView
TreeView TreeView1 = new TreeView();
TreeView1 = (TreeView)this.customControl1.Control;
//Create a tree node
TreeNode objCountryTreeNode;
//Assign the text from a hidden textbox to the node
objCountryTreeNode = AddNodeToTreeView(TreeView1.Nodes, this.txtShipCountry1.Text);
//Add a second-level node
AddNodeToTreeView(objCountryTreeNode.Nodes, this.txtShipCity1.Text);
//Expand the top-level node so the second-level node is in view
objCountryTreeNode.Expand();
//Create a second top-level node
TreeNode objCustomerTreeNode;
objCustomerTreeNode = AddNodeToTreeView(TreeView1.Nodes, this.txtCustomerID1.Text);
AddNodeToTreeView(objCustomerTreeNode.Nodes, this.txtEmployeeID1.Text);
objCustomerTreeNode.Expand();
See Also
Bind Reports to a Data Source


Create Common Section Reports

Create Common Section Reports
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Create Common Section Reports

See step-by-step instructions for creating commonly used reports with Section Layout.

This section contains information about how to:

Create Top N Reports
Learn to display top 10 data on a report.
Create a Summary Report
Learn to display summary data on a report.
Create Green Bar Reports
Learn to alternate background colors on the detail section.
See Also
Section Report How To


Create Top N Reports

Create Top N Reports
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Create Common Section Reports > Create Top N Reports
Show All Show All
Hide All Hide All

In a section report, in order to display only the top N number of details on a report, you can manipulate the data pulled by your SQL query.

To set an access data source to pull Top N data

  1. On the design surface, click the DataSource Icon in the detail section band to open the Report Data Source dialog.
  2. On the OLE DB tab of the Report Data Source dialog, next to Connection String, click the Build button.
  3. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button.
  4. Click the ellipsis (...) button to browse to the NWind database. Click Open once you have selected the appropriate access path.
    Note: The sample NWind.mdb data file is located in: [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWind.mdb
  5. Click OK to close the window and fill in the Connection String field.
  6. Back in Report Data Source dialog, paste the following SQL query in the Query field to fetch Top 10 records from the database.
    SQL Query
    Copy Code
    SELECT TOP 10 Customers.CompanyName, Sum([UnitPrice]*[Quantity])
AS Sales
FROM (Customers INNER JOIN Orders ON Customers.CustomerID = Orders.CustomerID)
INNER JOIN [Order Details] ON Orders.OrderID = [Order Details].OrderID
GROUP BY Customers.CompanyName
ORDER BY Sum([UnitPrice]*[Quantity])
DESC
  7. Click OK to return to the report design surface.

To add controls to display the Top N data

  1. In the Report Explorer, expand the Fields node, then the Bound node.
  2. Drag and drop the following fields onto the detail section and set the properties of each textbox as indicated.
    Field | Text | Location | Miscellaneous
    CompanyName | Company Name | 0.5, 0
    Sales | Sales | 5, 0 | OutputFormat = Currency
  3. Go to Preview tab, to view the result.

A report with the Top 10 companies' data similar to the following will appear in the preview.

See Also
Create Common Section Reports


Create a Summary Report

Create a Summary Report
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Create Common Section Reports > Create a Summary Report
Show All Show All
Hide All Hide All

In a section layout, you can display totals and subtotals by modifying the summary fields of a TextBox control. Use the following steps to learn how to add totals and subtotals in a report.

These steps assume that you have already added a Section Report template in a Visual Studio project and connected it to a data source. See Adding an ActiveReport to a Project and Bind Reports to a Data Source for further information.

Note: These steps use the Products table from the NWind database. The sample NWind.mdb database file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.

To calculate and display subtotals in a report

  1. Right-click the design surface and select Insert, then Group Header/Footer to add group header and group footer sections to the layout.
  2. With the GroupHeader section selected in the Properties Window, set its DataField property to CategoryID. This groups the data on the report according to the set field.
  3. From the Report Explorer, drag and drop the following fields onto the corresponding sections of the report.

    Fields

    • Field Name = CategoryID
      Section = GroupHeader

    • Field Name = ProductName
      Section = Detail

    • Field Name = UnitsInStock
      Section = Detail

    • Field Name = UnitsInStock
      Section = GroupFooter

  4. With the UnitsInStock field in the GroupFooter selected, go to the Properties Window and set the following:
    • SummaryFunc: Sum
    • SummaryType: Sub Total
    • SummaryRunning: Group
    • SummaryGroup: GroupHeader1
  5. Go to the Preview tab to view the report and see the Sub Total appear below each group of data similar to the following image.

To calculate and display grand total in a report

These steps are a continuation of the procedure above. The report generated at the end of this procedure contains totals and subtotals.

  1. Right-click the design surface and select Insert, then Report Header/Footer to add report header and footer sections to the layout.
  2. From Report Explorer, drag and drop the UnitsInStock field onto the ReportFooter section go to the Properties Window and set the following:
    • SummaryFunc: Sum
    • SummaryType: GrandTotal
    • SummaryRunning: All
  3. Go to the Preview tab to view the report and see the Grand Total appear on the last page of the report.
See Also
Create Common Section Reports


Create Green Bar Reports

Create Green Bar Reports
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Create Common Section Reports > Create Green Bar Reports
Show All Show All
Hide All Hide All

In a section report, green bar printouts can be created by setting alternate shades or background color in the report's detail section in the Format event. The following steps demonstrate how to create a Green Bar report.

  1. On the design surface, double-click the detail section of the report to create an event handling method for the Detail Format event.
  2. Add the following code to the handler to alternate background colors.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste JUST ABOVE the Detail Format event.
    Copy Code
    Dim color As Boolean
    Visual Basic.NET code. Paste INSIDE the Detail Format event.
    Copy Code
    If color = True Then
    Me.Detail1.BackColor = System.Drawing.Color.DarkSeaGreen
    color = False
Else
    Me.Detail1.BackColor = System.Drawing.Color.Transparent
    color = True
End If

    To write the code in C#

    C# code. Paste JUST ABOVE the Detail Format event.
    Copy Code
    bool color;
    C# code. Paste INSIDE the Detail Format event.
    Copy Code
    if(color)
{
    this.detail.BackColor = System.Drawing.Color.DarkSeaGreen;
    color = false;
}
else
{
    this.detail.BackColor = System.Drawing.Color.Transparent;
    color = true;
}
  3. Add controls like TextBox to the report design surface and preview the report.

The following image shows a Green Bar report alternating between Transparent and Dark Sea Green backgrounds:
See Also
Create Common Section Reports


Inherit a Report Template

Inherit a Report Template
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Inherit a Report Template
Show All Show All
Hide All Hide All

In a section layout, you can create a base report as a template from which other reports can inherit. This behavior is similar to creating a master report and is available in a Section Report (code-based) layout.

Inheriting reports is useful when multiple reports share common features, such as identical page headers and footers. Instead of recreating the look every time, create template headers and footers once and use inheritance to apply them to other reports.

Use the following instructions to create a base report and inherit it in other reports.

Caution: Base reports and the reports that inherit from them cannot contain controls with duplicate names. You can compile and run your project with duplicate control names, but you cannot save the layout until you change the duplicate names.

To create a base report

  1. In a Visual Studio project, add a Section Report (code-based) template and name it rptLetterhead. See Adding an ActiveReport to a Project for more information.
  2. In the report template that appears, add the following controls from the Visual Studio toolbox to the indicated section of rptLetterhead and set the properties.

    Controls for rptLetterhead

    Control Section Location Size Miscellaneous
    Picture PageHeader 0, 0 in 3, 0.65 in Image = (click ellipsis and navigate to the location of your image file)
    PictureAlignment = TopLeft
    Label PageHeader 1.16, 0.65 in 1.8, 0.25 in Text = Inheritance
    Font = Arial, 15pt, style=Bold
    Label PageFooter 0, 0 in 6.5, 0.19 in Text = http://www.grapecity.com
    HyperLink = http://www.grapecity.com
    Font/Bold = True
    Alignment = Center
  3. Right-click the gray area below the design surface and choose properties, to open the Properties window.
  4. In the Properties window, set the MasterReport property to True. Setting the MasterReport property to True locks the Detail section.

You can use the Page Header and Page Footer sections to design the base report. When you create reports that inherit the layout from this base report, only the detail section is available for editing.

Caution: Do not set the MasterReport property to True until you have finished designing or making changes to the report. Setting this property to True triggers major changes in the designer file of the report.

To inherit layout from a base report

These steps assume that you have already added another Section Report (code-based) template. This report functions like a content report where you can create the layout of the Detail section.

  1. In a Visual Studio project, add a Section Report (code-based) template and name it rptLetter.
  2. In the Solution Explorer, right-click the new report and select the View Code option to open the code behind of the report.
  3. In the code view, modify the inheritance statement as shown below. The content report inherits from the base report instead of GrapeCity.ActiveReports.SectionReport.
    Caution: The existing report layout in the content report is lost once you inherit the base report. Even if you change it back to GrapeCity.ActiveReports.SectionReport, the original layout in content report will not be retrieved.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Replace YourContentReport, YourProjectName and YourMasterReportName with relevant names.
    Copy Code
    Partial Public Class rptLetter Inherits YourProjectName.rptLetterhead

    To write the code in C#

    C# code. Replace YourContentReport, YourProjectName and YourMasterReportName with relevant names.
    Copy Code
    public partial class rptLetter : YourProjectName.rptLetterhead
  4. Close the reports and from the Build menu on the Visual Studio menu bar, select Rebuild. When you reopen the report, the inherited sections and controls are disabled.

    Note: To apply further changes from the base report to the content report, you might have to rebuild the project again.


Change Ruler Measurements

Change Ruler Measurements
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Change Ruler Measurements
Show All Show All
Hide All Hide All

In a section layout, you can change ruler measurements from inches to centimeters and centimeters to inches. Use the following instructions to modify ruler measurements at design- time and run-time.

To change ruler measurements at design-time

At design time, you can change the ruler measurements from the Report Settings Dialog.

  1. In the Report Explorer, double-click the Settings node.
  2. In the Report Settings dialog that appears, click Global Settings.
  3. From the Ruler Units dropdown select Centimeters or Inches.

To call a measurement conversion at run-time

Call the CmToInch method or InchToCm method at run-time to change measurements. For example, you can use the following code when you are working in centimeters and need to convert a Label's position measurements from centimeters to inches at run-time.

  1. On the design surface select the section containing a control like a Label.
  2. In the Properties Window, click the Events button to get a list of report events.
  3. Select the Format event and double-click to create an event-handling method.
  4. Add code like the following to the handler to set the size of the control using centimeters to inches.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste inside the Format event.
    Copy Code
    Me.Label1.Left = SectionReport1.CmToInch(2)
    Me.Label1.Top = SectionReport1.CmToInch(2)

    To write the code in C#

    C# code. Paste inside the Format event.
    Copy Code
    this.label1.Left = SectionReport1.CmToInch(2);
    this.label1.Top = SectionReport1.CmToInch(2);
See Also

Concepts

Rulers


Print Multiple Copies, Duplex and Landscape

Print Multiple Copies, Duplex and Landscape
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Print Multiple Copies, Duplex and Landscape
Show All Show All
Hide All Hide All

In a section report, you can modify various printer settings or print multiple copies of a report at design time and at runtime.

Printer Settings

At design time, you can set up duplex printing, page orientation, collation, and page size in the Printer Settings tab of the Report Settings Dialog.

Duplex Printing

To set up duplex printing in Printer Settings

  1. In the Report Explorer, double-click the Settings node.
  2. In the Report Settings dialog that appears, click Printer Settings.
  3. On the Printer Settings page, next to Duplex, select one of the following options:
    • Printer Default: The report uses the default settings of the selected printer.
    • Simplex: Turns off duplex printing.
    • Horizontal: Prints horizontally on both sides of the paper.
    • Vertical: Prints vertically on both sides of the paper.
  4. Click OK to return to the report.

To use code to set up duplex printing

  1. Double-click the gray area below the design surface to create an event-handling method for the report's ReportStart event.
  2. Add the following code to the handler to set up duplexing.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the ReportStart event.
    Copy Code
    Me.PageSettings.Duplex = System.Drawing.Printing.Duplex.Horizontal

    To write the code in C#

    C# code. Paste INSIDE the ReportStart event.
    Copy Code
    this.PageSettings.Duplex = System.Drawing.Printing.Duplex.Horizontal;

Page Orientation

To set page orientation on the Printer Settings page

  1. In the Report Explorer, double-click the Settings node.
  2. In the Report Settings dialog that appears, click Printer Settings.
  3. On the Printer Settings page, in the Orientation section, select either Default, Portrait or Landscape.
  4. Click OK to return to the report.

To use code to change page orientation

  1. Double-click the gray area below the design surface to create an event-handling method for the report's ReportStart event.
  2. Add the following code to the handler to change the page orientation of the report for printing.
    Note: Page orientation can only be modified before the report runs. Otherwise, changes made to the page orientation are not used during printing.

    The following example shows what the code for the method looks like.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the ReportStart event.
    Copy Code
    Me.PageSettings.Orientation = GrapeCity.ActiveReports.Document.Section.PageOrientation.Landscape

    To write the code in C#

    C# code. Paste INSIDE the ReportStart event.
    Copy Code
    this.PageSettings.Orientation = GrapeCity.ActiveReports.Document.Section.PageOrientation.Landscape;

Multiple Copies

You can print multiple copies using the Print dialog in the Preview tab or in the Viewer, or you can use code to set the number of copies to print.

To set multiple copies in the print dialog

  1. With a report displayed in the viewer or in the preview tab, click Print.
  2. In the Print dialog that appears, next to Number of copies, set the number of copies that you want to print.

To use code to set multiple copies

  1. Double-click in the gray area below the design surface to create an event-handling method for the report's ReportStart event.
  2. Add the following code to the handler to set multiple copies of the report for printing.

    The following example shows what the code for the method looks like for printing five copies.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the ReportStart event.
    Copy Code
    Me.Document.Printer.PrinterSettings.Copies = 5
    Visual Basic.NET code. Paste INSIDE the ReportEnd event.
    Copy Code
    Me.Document.Printer.Print()

    To write the code in C#

    C# code. Paste INSIDE the ReportStart event.
    Copy Code
    this.Document.Printer.PrinterSettings.Copies = 5;
    C# code. Paste INSIDE the ReportEnd event.
    Copy Code
    this.Document.Printer.Print();


Conditionally Show or Hide Details

Conditionally Show or Hide Details
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Conditionally Show or Hide Details
Show All Show All
Hide All Hide All

In a section layout, you can use conditions in the Format event to control the display of report's detail section at runtime.

These steps assume that you have already added a Section Report (code-based) template in a Visual Studio project and connected it to a data source. See Adding an ActiveReport to a Project and Bind Reports to a Data Source for further information.

Note: These steps use the Products table from the NWind database. By default, in ActiveReports, the NWind.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWind.mdb.
  1. From the Report Explorer, drag and drop the following fields onto the detail section of the report and set their properties in the Properties Window.
    Field Name Properties
    ProductName Location: 0, 0.104 in
    Size: 2.667, 0.2 in
    Discontinued Location: 2.667, 0.104 in
    Size: 2.021, 0.2 in
    ReorderLevel Location: 4.688, 0.104 in
    Size: 1.812, 0.2 in
  2. Double-click the detail section of the report to create an event-handling method for the Format event.
  3. Add the following code to the handler to hide the details of a product which is discontinued.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Detail_Format event.
    Copy Code
    If Me.txtReorderLevel1.Value = 0 And Me.txtDiscontinued1.Value = False Then
          Me.Detail1.Visible = True
          Me.txtReorderLevel1.Text = "Need to Reorder"
          Me.txtReorderLevel1.ForeColor = System.Drawing.Color.DarkRed
    Else
          Me.Detail1.Visible = False
    End If

    To write the code in C#

    C# code. Paste INSIDE the detail_Format event.
    Copy Code
    if (int.Parse(txtReorderLevel1.Value.ToString()) == 0 && txtDiscontinued1.Text == "False")
    {
    this.detail1.Visible = true;
    this.txtReorderLevel1.Text = "Need to Reorder";
    this.txtReorderLevel1.ForeColor = System.Drawing.Color.DarkRed;
    }
    else
    {
    this.detail1.Visible = false;
    }
  4. In Form1 of the Visual Studio project, add a Viewer control and load the report you created above in it. See Windows Forms Viewer for further details.
  5. Press F5 to debug and see a report with discontinued products hidden from view.
See Also
Bind Reports to a Data Source


Add Parameters in a Section Report

Add Parameters in a Section Report
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Add Parameters in a Section Report
Show All Show All
Hide All Hide All

There are several ways to add parameters in a section report. The following sections provide a step by step overview of adding parameters in a report.

To add parameters using the Report Explorer

  1. In the Report Explorer, right-click the Parameters node and select Add. This adds a parameter (Parameter1) as a child to the Parameters node.

  2. Select the added parameter to open the Properties Window and set values in the following properties:
    • Name: This is the unique name of the parameter which appears as Parameter1 by default. It corresponds to the Key property in parameters entered via code.
    • Default Value: Sets/returns the value displayed when the user is prompted to enter a value at runtime.
    • Prompt: Sets/returns a string displayed when a user is prompted for the value at runtime.
    • PromptUser: Boolean value that indicates whether to prompt the user for a value or not. This is set True to use parameters at runtime.
    • Type: This value which defaults to String defines the type of data the parameter represents. You can also set data type to Date or Boolean.
  3. Pass the parameter to a field on the report, or access it programmatically as described in the run time procedure below.

To add parameters directly using a SQL query

When you add SQL parameters to a report, ActiveReports displays an Enter Report Parameters dialog where the user can enter the values to fetch from the database.

  1. In the detail section band, click the DataSource icon to view the Report Data Source dialog.
  2. Connect the report to a data source, for example, OleDb data source. See Bind Reports to a Data Source for further details.
  3. In the Query field, enter a SQL query like the one below, which contains the parameter syntax to prompt for parameter values at runtime.
    SELECT * FROM Products
    INNER JOIN (Orders INNER JOIN [Order Details] ON Orders.OrderID= [Order Details].OrderID) ON Products.ProductID = [Order Details].ProductID WHERE Products.SupplierID = <%SupplierID|Enter Supplier ID|7%>
    AND OrderDate >= #<%OrderDate|Order date from|11/1/1994|D%>#
    AND Discontinued = <%Discontinued|Is this checked?|true|B%>
  4. Click OK to save the data source and return to the report design surface.

The SQL query above causes ActiveReports to display the following dialog to the user. The user can accept these or input other values to select report data.

To add parameters at run time

You can add, edit, and delete parameters at run time. The following code demonstrates how to add a parameter and display its value in a Textbox control.

  1. Double-click in the gray area below the report to create an event-handling method for the ReportStart event.
  2. Add code to the handler to set parameters at run time.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste at beginning of code view.
    Copy Code

    Imports GrapeCity.ActiveReports.SectionReportModel
    Visual Basic.NET code. Paste INSIDE the ReportStart event.
    Copy Code

    Dim myParam1 As New Parameter()
    myParam1.Key = "myParam1"
    myParam1.Type = Parameter.DataType.String
    'Set to False if you do not want input from user.
    myParam1.PromptUser = True
    myParam1.Prompt = "Enter Data:"
    myParam1.DefaultValue = "Default Value"
    Me.Parameters.Add(myParam1)

    To write the code in C#

    C# code. Paste at beginning of code view.
    Copy Code

    using GrapeCity.ActiveReports.SectionReportModel;
    C# code. Paste INSIDE the ReportStart event.
    Copy Code

    Parameter myParam1 = new Parameter();
    myParam1.Key = "myParam1";
    myParam1.Type = Parameter.DataType.String;
    //Set to False if you do not want input from user.
    myParam1.PromptUser = true;
    myParam1.Prompt = "Enter Data:";
    myParam1.DefaultValue = "Default Value";
    this.Parameters.Add(myParam1);
  3. In the design view, click the gray area below the report to select it and open the Properties Window.
  4. Click the events icon in the Properties Window to display available events for the report.
  5. Double-click FetchData. This creates an event-handling method for the report's FetchData event.
  6. Add code to the handler to pass the parameter at run time.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the FetchData event.
    Copy Code
    'Set textbox text equal to the value of the parameter.
    Me.txtParam1.Text = Me.Parameters("myParam1").Value

    To write the code in C#

    C# code. Paste INSIDE the FetchData event.
    Copy Code
    //Set textbox text equal to the value of the parameter.
    this.txtParam1.Text = this.Parameters["myParam1"].Value;
The runtime implementation above causes ActiveReports to display the following dialog to the user. The user can enter any text in this prompt dialog and display it on the report.

Viewing a Parameterized Report

The parameter prompt dialog for a parameterized report depending on how you view the report.

To get a Parameter Dialog box

  1. In the Visual Studio project, add a Viewer control to the Form.
  2. Double-click the Form title bar to create a Form_Load event.
  3. Add the following code to the handler to view the report in the Viewer.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form_Load event.
    Copy Code
    Dim rpt As New SectionReport1
    Viewer1.Document = rpt.Document
    rpt.Run()

    To write the code in C#

    C# code. Paste INSIDE the Form_Load event.
    Copy Code
    SectionReport1 rpt = new SectionReport1();
    viewer1.Document = rpt.Document;
    rpt.Run();

To get a Parameter Panel in the Viewer sidebar

  1. In the Visual Studio project, add a Viewer control to the Form.
  2. Double-click the Form title bar to create a Form_Load event.
  3. Add the following code to the handler to view the report in the Viewer.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form_Load event.
    Copy Code
    Dim rpt As New SectionReport1
    Me.Viewer1.LoadDocument(rpt)

    To write the code in C#

    C# code. Paste INSIDE the Form_Load event.
    Copy Code
    SectionReport1 rpt = new SectionReport1();
    viewer1.LoadDocument(rpt);
See Also

Concepts

Parameters


Add and Save Annotations

Add and Save Annotations
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Add and Save Annotations
Show All Show All
Hide All Hide All

In a section report, you can save a report containing annotations along with the report data into an RDF file. You can also add annotations at runtime. The following steps demonstrate how to accomplish these tasks in code.

These steps assume that you have already added a Section Report (code based) template in a Visual Studio project. See Adding an ActiveReport to a Project for more information.

To save annotations

The following example shows how to add a Save Annotated Report button to the viewer and save a report with annotations in RDF.

  1. From the Visual Studio toolbox, drag a Button control onto the viewer.
  2. Set the Text property of the button to Save Annotated Report.
  3. Double-click the button. This creates an event-handling method for the button Click event.
  4. Add code to the click handler to save the document to an RDF file. See Save and Load RDF Report Files for more information on loading the saved RDF file into the viewer.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the button Click event.
    Copy Code
    Me.Viewer1.Document.Save("C:\UserAnnotations.rdf")

    To write the code in C#

    C# code. Paste INSIDE the button Click event.
    Copy Code
    this.viewer1.Document.Save("C:\\UserAnnotations.rdf");

To add annotations in code

The following example shows how to add annotations at run time and save the report data and annotations to an RDF file.

  1. Double-click the title bar of the Form in which you host the viewer. This creates an event-handling method for the Form_Load event.
  2. Add code to the handler to run the report, add annotations, display the report in the viewer, and save it into an RDF file.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste ABOVE the class.
    Copy Code
    Imports GrapeCity.ActiveReports.Document.Section.Annotations
    Visual Basic.NET code. Paste INSIDE the Form Load event.
    Copy Code
       Dim rpt As New SectionReport1
   'Run the report first.
   rpt.Run()

   'Assign the viewer.
   Me.Viewer1.Document = rpt.Document

   'Create an annotation and assign property values.
   Dim circle As New AnnotationCircle
   circle.Color = System.Drawing.Color.GreenYellow
   circle.Border.Color = System.Drawing.Color.Chartreuse

   'Add the annotation.
   circle.Attach(1,1) 'screen location
   Me.Viewer1.Document.Pages(0).Annotations.Add(circle)

   'Set the size properties. The annotation must be added to the page first.
   circle.Height = 0.25
   circle.Width = 0.50

   'Save annotations with the report in an RDF file.
   rpt.Document.Save("C:\AnnotatedReport.rdf")

    To write the code in C#

    C# code. Paste ABOVE the class.
    Copy Code
    using GrapeCity.ActiveReports.Document.Section.Annotations;
    C# code. Paste INSIDE the Form Load event.
    Copy Code
       SectionReport1 rpt = new SectionReport1();
   //Run the report first.
   rpt.Run();

   //Assign the viewer
   this.viewer1.Document = rpt.Document;

   //Create an annotation and assign property values.
   AnnotationCircle circle = new AnnotationCircle();
   circle.Color = System.Drawing.Color.GreenYellow;
   circle.Border.Color = System.Drawing.Color.Chartreuse;

   //Add the annotation.
   circle.Attach(1,1); //screen location
   this.viewer1.Document.Pages[0].Annotations.Add(circle);

   //Set the size properties. The annotation must be added to the page first.
   circle.Height = 0.25f;
   circle.Width = 0.50f;

   //Save annotations with the report in an RDF file.
   rpt.Document.Save("C:\\AnnotatedReport.rdf");
See Also

Concepts

Annotations


Add Bookmarks

Add Bookmarks
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Add Bookmarks
Show All Show All
Hide All Hide All

In a section report, you can display bookmarks and nested bookmarks in the viewer's table of contents for fields, groups, and subreports. You can also add special bookmarks at run time.

To set up basic bookmarks

  1. From the Visual Studio toolbox, drag and drop a TextBox control onto the detail section.
  2. Double-click the Detail section of the report. This creates an event-handling method for the report's Detail_Format event.
  3. Add code to the handler to set up bookmarks.

The following example shows what the code for the method looks like.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Detail Format event.
Copy Code
Me.Detail1.AddBookmark(textBox1.text)

To write the code in C#

C# code. Paste INSIDE the Detail Format event.
Copy Code
Detail.AddBookmark(TextBox1.Text);

To set up leveled or nested bookmarks

  1. From the Report Explorer, drag and drop CustomerID and ContactName onto the detail section.
  2. Double-click the Detail section of the report. This creates an event-handling method for the report's Detail_Format event.
  3. Add code to the handler to set up bookmarks.

The following example shows what the code to set up leveled or nested Bookmarks looks like.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Detail Format event.
Copy Code
Me.Detail1.AddBookmark(txtCustomerID.Text + "\" + txtContactName.Text)

To write the code in C#

C# code. Paste INSIDE the Detail Format event.
Copy Code
detail.AddBookmark(txtCustomerID.Text + "\\" + txtContactName.Text);

To nest grandchild bookmarks and use bookmarks in grouping

  1. From the Report Explorer, drag and drop CustomerID, ContactName and City fields onto the detail section.
  2. Double-click in the Detail section of the report. This creates an event-handling method for the report's Detail_Format event.
  3. Add code to the handler to set up a bookmark for each ContactName and nest ContactName bookmarks within each CustomerID, and CustomerID bookmarks in each City.

    The following example shows what the code for the detail section looks like.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Detail_Format event.
    Copy Code
    Me.Detail1.AddBookmark(txtCity.Text + "\" + txtCustomerID.Text + "\" + txtContactName.Text)

    To write the code in C#

    C# code. Paste INSIDE the Detail_Format event.
    Copy Code
    this.detail.AddBookmark(txtCity.Text + "\\" + txtCustomerID.Text + "\\" + txtContactName.Text);
  4. Add a GroupHeader section to the layout and set its DataField property to City.
  5. Double-click in the Group Header section of the report. This creates an event-handling method for the report's Group Header Format event.
  6. Add code to the handler to set up a bookmark for each instance of the City group.

    The following example shows what the code for the group header looks like.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Group Header Format event.
    Copy Code
    Me.GroupHeader1.AddBookmark(txtCity.Text)

    To write the code in C#

    C# code. Paste INSIDE the Group Header Format event.
    Copy Code
    this.groupHeader1.AddBookmark(txtCity.Text);

To combine parent report and subreport bookmarks

  1. From the Report Explorer, drag and drop the CustomerID field onto the detail section of the Parent report.
  2. Double-click the Detail section to create an event-handling method for the report's Detail Format event.
  3. Add code to the handler to create a bookmark for each instance of the CustomerID field in the main report.

    The following example shows what the code for the method looks like for the main report.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Detail Format event of the main report.
    Copy Code
    Me.Detail1.AddBookmark(txtCustomerID.Text)

    To write the code in C#

    C# code. Paste INSIDE the Detail Format event of the main report.
    Copy Code
    detail1.AddBookmark(txtCustomerID.Text);
  4. From the Report Explorer, drag and drop the ContactName field onto the detail section of the Subreport.
  5. Double-click in the Detail section to create an event-handling method for the report's Detail Format event.
  6. Add code to the handler to create a bookmark for each instance of the ContactName field in the subreport.

    The following example shows what the code for the method looks like for the subreport.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Detail Format event of the subreport.
    Copy Code
    Me.Detail1.AddBookmark(CType(Me.ParentReport.Sections("Detail1").Controls("txtCustomerID"), TextBox).Text + "\" + Me.txtContactName.Text)

    To write the code in C#

    C# code. Paste INSIDE the Detail Format event of the subreport.
    Copy Code
    this.detail1.AddBookmark(((TextBox)(this.ParentReport.Sections["Detail1"].Controls["txtCustomerID"])).Text + "\\" + this.txtContactName.Text);

To add special bookmarks at run time

To create and add special bookmarks to the bookmarks collection at run time, add the bookmarks to the report document's pages collection.

Caution: Remember that the page collection does not exist until the report runs, so use this code in the ReportEnd event or in form code after the report has run.

To write the code in Visual Basic.NET

  1. Click in the gray area outside the report and right-click to select Properties from the context menu.
  2. Click the Events icon in the Properties Window to display events available for the report.
  3. Double-click ReportEnd. This creates an event-handling method for the ReportEnd event.
  4. Add code to the handler to add a bookmark.

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste INSIDE the ReportEnd event.
Copy Code
Me.Document.Pages(0).AddBookmark("New Bookmark", 1)

To write the code in C#

C# code. Paste INSIDE the ReportEnd event.
Copy Code
this.Document.Pages[0].AddBookmark("New Bookmark", 1);

To view a report bookmarks in the Viewer or Preview tab

  1. Add the ActiveReports Viewer control to your Windows Form.
  2. Add code to display the report in the Viewer. See Viewing Reports for further information.
  3. Press F5 to run the report.
  4. On the Viewer toolbar, select Toggle Sidebar to open the sidebar and click the Document Map button to view the list of bookmarks.
See Also

Concepts

Document Map


Add Hyperlinks

Add Hyperlinks
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Add Hyperlinks
Show All Show All
Hide All Hide All

In a section report, you can add hyperlinks in a report using the Hyperlink property available with the following controls:

  • Label
  • TextBox
  • Picture

You can add hyperlinks that connect to a Web page, open an e-mail, or jump to a bookmark.

Note: Specify the full URL address (for example, "http://www.grapecity.com") for the Hyperlink property to avoid broken links while viewing reports.

To link to a Web page

  1. Select an existing control or drag and drop a control from the Visual Studio toolbox onto the design surface.
  2. Right-click the control to open the Properties Window.
  3. In the Properties Window, set the HyperLink property to any valid URL. For example, for example, http://www.grapecity.com.

To link to an e-mail address

  1. Select an existing control or drag and drop a control from the Visual Studio toolbox onto the design surface.
  2. Right-click the control to open the Properties Window.
  3. In the Properties Window, set the HyperLink property to mailto: any valid e-mail address.

To parse the URL out of a database field for a hyperlink

  1. From the Report Explorer, drag and drop the link field onto the design surface.
  2. Double-click the section where you had placed the link field. This creates an event-handling method for the section's Format event.
  3. Add code to the Format event to,
    • Parse the URL out of the Link field
    • Assign it to the HyperLink property of TextBox
    • Remove the URL markers from the text displayed in TextBox

The following example shows what the code for the method looks like.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Format event.
Copy Code
Dim iStart As Integer
Dim sHTML As String
If textBox1.Text <> "" Then
    iStart = InStr(1, textBox1.Text, "#", CompareMethod.Text)
    sHTML = Right(textBox1.Text, (Len(textBox1.Text) - iStart))
    sHTML = Replace(sHTML, "#", "", 1, -1, CompareMethod.Text)
    textBox1.HyperLink = sHTML
    textBox1.Text = Replace(textBox1.Text, "#", "", 1, -1, CompareMethod.Text)
End If

To write the code in C#

C# code. Paste INSIDE the Format event.
Copy Code
int iStart;
string sHTML;
if (textBox1.Text != "")
    {
     iStart = textBox1.Text.IndexOf("#",0);
     sHTML = textBox1.Text.Substring(iStart, textBox1.Text.Length - iStart);
     sHTML = sHTML.Replace("#", "");
     textBox1.HyperLink = sHTML;
     textBox1.Text = textBox1.Text.Replace("#", "");
    }

To create a hyperlink that jumps to a bookmark

  1. From the Report Explorer, drag and drop a field onto the design surface.
  2. Double-click the section where you had placed the field. This creates an event-handling method for the section's Format event.
  3. Add the following code inside the Format event.

The following example shows what the code for the method looks like.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste JUST ABOVE the Format event.
Copy Code
Public pBM As New BookmarksCollection()
Dim iEntry As Integer
Visual Basic.NET code. Paste INSIDE the Format event.
Copy Code
Me.Detail1.AddBookmark(Me.textBox1.Text)
Me.txtEntry.HyperLink = "toc://" + pBM(iEntry - 1).Label
Me.txtEntry.Text = pBM(iEntry - 1).Label
Me.txtPage.Text = pBM(iEntry - 1).PageNumber

To write the code in C#

C# code. Paste JUST ABOVE the Format event.
Copy Code
public BookmarksCollection pBM = new BookmarksCollection();
int iEntry;
C# code. Paste INSIDE the Format event.
Copy Code
this.detail.AddBookmark(this.textBox.Text);
this.txtEntry.HyperLink = "toc://" + pBM[iEntry - 1].Label;
this.txtEntry.Text = pBM[iEntry - 1].Label;
this.txtPage.Text = pBM[iEntry - 1].PageNumber.ToString();

To display the page number of the bookmark in the table of contents

  1. Select the gray area outside the report and right-click to choose Properties option from the context menu.
  2. In the Properties Window that appears, click the Events button to get the list of events for the report.
  3. Select the FetchData event from that list and double-click it. This creates an event-handling method for the report's FetchData event in the code behind.
  4. Add code to the handler to retrieve information to populate the report fields.

The following example shows what the code for the method looks like.

To write the code in Visual Basic

Visual Basic.NET code. Paste INSIDE the FetchData event.
Copy Code
If iEntry > pBM.Count - 1 Then
    eArgs.EOF = True
Else
    eArgs.EOF = False
    iEntry += 1
End If

To write the code in C#

C# code. Paste INSIDE the FetchData event.
Copy Code
if (iEntry > pBM.Count - 1)
{
    eArgs.EOF = true;
}
else
{
    eArgs.EOF = false;
    iEntry += 1;
}
See Also

Concepts

Interactive Features


Use External Style Sheets

Use External Style Sheets
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Use External Style Sheets
Show All Show All
Hide All Hide All

In a section layout, you can set custom style values in the Styles page of the Report Settings Dialog, and then apply the styles to controls using the ClassName property from the Properties Window.

You can also apply these same styles to controls in other reports, by exporting them to a XML file of type *.reportstyle and selecting it in other reports using the Report Settings dialog.
Note: You can apply styles to the CheckBox, Label, TextBox, and ReportInfo controls only.

To modify or create a style and save it to an external style sheet

  1. In the Report Explorer, right-click the Settings node and select Show.
  2. In the Report Settings dialog that appears, go to the Styles page. On the Styles page, there are four predefined styles: Normal, Heading1, Heading2 and Heading3.
  3. Click any of these styles in the list to modify them using the fields on the right, or click the New button to add a new style.
  4. Click the Export styles to file button to save the existing styles in a style sheet.
  5. In the Save As dialog that appears, navigate to the location where you want to save the style sheet, provide an name for the file and click the Save button to save it as an external *.reportstyle file.
  6. In the Report Settings dialog, click the OK button to close the dialog and save the styles in the current report.

To load and apply an external style sheet at design time

  1. In the Report Explorer, right-click the Settings node and select Show.
  2. In the Report Settings dialog that appears, go to the Styles page.
  3. On the Style page, click the Import styles from file button.
  4. A message box warns that current styles will be deleted. Click Yes to continue.
  5. In the Open dialog that appears, navigate to the *.reportstyle file that you want to use and click the Open button to load the external style sheet.
  6. On the design surface, select the control you want to apply the style to and right-click to choose Properties.
  7. In the Properties Window, from the Class Name property drop down select a style to apply (like Heading1).

To load an external style sheet at runtime and apply it

  1. Right-click the gray area outside the design surface and select Properties.
  2. In the Properties Window that appears, click the Events button. A list of report events appear.
  3. Select the ReportStart event and double click to create an event-handling method.
  4. Add the following code to the handler to load an external style sheet.
    Visual Basic.NET code. Paste INSIDE the ReportStart event.
    Copy Code
    Me.LoadStyles("C:\MyStyleSheet.reportstyle")
    C# code. Paste INSIDE the ReportStart event.
    Copy Code
    this.LoadStyles(@"C:\MyStyleSheet.reportstyle");

To apply a style to a control at runtime

The following steps assume that you have already loaded an external style sheet to the report.

  1. On the design surface select the section containing the control.
  2. In the Properties Window, click the Events button. A list of report events appear.
  3. Select the Format event and double click to create an event-handling method.
  4. Add the following code to the handler to apply a style to a control.
    Visual Basic.NET code. Paste INSIDE the Format event.
    Copy Code
    Me.TextBox.ClassName = "Heading1"
    C# code. Paste INSIDE the Format event.
    Copy Code
    this.textBox.ClassName = "Heading1";
See Also

Concepts

Report Explorer


Insert or Add Pages

Insert or Add Pages
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Insert or Add Pages
Show All Show All
Hide All Hide All

In a section layout, you can run multiple reports, merge their entire page collection or specific portions and view it as a single report. You can save the document containing merged reports to an RDF file or even export them.

These steps assume that you have already placed a Viewer control on a Windows Form and your Visual Studio project contains two section layout (code based) reports (rptOne and rptTwo). See Adding an ActiveReport to a Project and Using the Viewer for more information.

To add pages from one report to another

To add an entire report to another, use code like the one in the example below to iterate through the entire pages collection of a report and append it to the first report. The Add of the PagesCollection takes one parameter (value), which references a report document page.

  1. In the design view of the Form containing the Viewer, double-click the title bar of the Form to create an event-handling method for the Form_Load event.
  2. Add the following code to the handler to add the entire rptTwo page collection to rptOne.

The following example shows what the code for the Add() method looks like.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Form Load event.
Copy Code
Dim i As Integer
Dim rpt As New rptOne()
rpt.Run()
Dim rpt2 As New rptTwo()
rpt2.Run()
For i = 0 To rpt2.Document.Pages.Count - 1
rpt.Document.Pages.Add(rpt2.Document.Pages(i))
Next
Viewer1.Document = rpt.Document

To write the code in C#

C# code. Paste INSIDE the Form Load event.
Copy Code
int i;
rptOne rpt1 = new rptOne();
rpt1.Run();
rptTwo rpt2 = new rptTwo();
rpt2.Run();
for(i = 0; i < rpt2.Document.Pages.Count; i++)
{
rpt1.Document.Pages.Add(rpt2.Document.Pages[i]);
}
viewer1.Document = rpt1.Document;

To add a range of pages from one report to another

To add a range of pages from one report to another, use the AddRange. This method has two overloads, each with one parameter. The first overload takes an array of page objects which you can use to append only the specified pages from the second report onto the first (as in the example below).

  1. In the design view of the Form containing the Viewer, double-click the title bar of the Form to create an event-handling method for the Form_Load event.
  2. Add the following code to the handler to use the AddRange() method to add pages from rptTwo to rptOne.

The following example shows what the code for the AddRange() method looks like.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Form Load event.
Copy Code
Dim rpt1 As New rptOne()

rpt1.Run()

Dim rpt2 As New rptTwo()

rpt2.Run()

rpt1.Document.Pages.AddRange(New GrapeCity.ActiveReports.Document.Section.Page() {rpt2.Document.Pages(1), rpt2.Document.Pages(2)})

Viewer1.Document = rpt1.Document

To write the code in C#

C# code. Paste INSIDE the Form Load event.
Copy Code
rptOne rpt1 = new rptOne();
rpt1.Run();
rptTwo rpt2 = new rptTwo();
rpt2.Run();
rpt1.Document.Pages.AddRange(new GrapeCity.ActiveReports.Document.Section.Page[] {rpt2.Document.Pages[0],rpt2.Document.Pages[1]} );
viewer1.Document = rpt1.Document;

To insert pages from one report into another

To insert pages from one report to another, use the Insert that takes two parameters, an index, which determines where to insert the pages in the main report, and a value which references the report page to insert.

  1. In the design view of the Form containing the Viewer, double-click the title bar of the Form to create an event-handling method for the Form_Load event.
  2. Add the following code to the handler to insert page 1 of rptTwo at the beginning of rptOne.

The following example shows what the code for the Insert() method looks like.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Form Load event.
Copy Code
Dim rpt1 As New rptOne()

rpt1.Run()

Dim rpt2 As New rptTwo()

rpt2.Run()

rpt1.Document.Pages.Insert(0, rpt2.Document.Pages(0))

Viewer1.Document = rpt1.Document

To write the code in C#

C# code. Paste INSIDE the Form Load event.
Copy Code
rptOne rpt1 = new rptOne();

rpt1.Run();

rptTwo rpt2 = new rptTwo();

rpt2.Run();

rpt1.Document.Pages.Insert(0, rpt2.Document.Pages[0]);

viewer1.Document = rpt1.Document;

To insert a new page at a specific report location

To insert a new blank page at a specific location in the report, use the InsertNew which takes one parameter, index, which specifies the page after which you want to insert a new blank page.

  1. In the design view of the viewer form, double-click the title bar of the Form to create an event-handling method for the Form_Load event.
  2. Add the following code to the handler to insert a blank page at the beginning of rptOne.

The following example shows what the code for the InsertNew() method looks like.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Form Load event.
Copy Code
Dim rpt1 As New rptOne()

rpt1.Run()

rpt1.Document.Pages.InsertNew(0)

Viewer1.Document = rpt1.Document

To write the code in C#

C# code. Paste INSIDE the Form Load event.
Copy Code
rptOne rpt1 = new rptOne();

rpt1.Run();

rpt1.Document.Pages.InsertNew(0);

viewer1.Document = rpt1.Document;


Embed Subreports

Embed Subreports
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Embed Subreports
Show All Show All
Hide All Hide All

To embed a subreport into a parent report, you add two reports (one parent and one child report) to a Visual Studio project, and from the ActiveReports 10 Section Report toolbox, drag the SubReport control onto the parent report. The following steps take you through the process of adding a subreport in a section report.

These steps assume that you have already added a Section Report (code-based) template in a Visual Studio project. See Adding an ActiveReport to a Project for further information.

To add code to create an instance of the child report in the parent report

  1. Double-click the gray area around the parent report to create an event-handling method for the ReportStart event.
  2. Add code like the following to the handler to create a new instance of the child report.

    To write the code in Visual Basic

    Visual Basic.NET code. Paste JUST ABOVE the ReportStart event.
    Copy Code
    Dim rpt As rptYourChildReportName
    Visual Basic.NET code. Paste INSIDE the ReportStart event.
    Copy Code
    rpt = New rptYourChildReportName()

    To write the code in C#

    C# code. Paste JUST ABOVE the ReportStart event.
    Copy Code
    private rptYourChildReportName rpt;
    C# code. Paste INSIDE the ReportStart event.
    Copy Code
    rpt = new rptYourChildReportName();
Caution: It is recommended that you do not create a new instance of the subreport in the Format event. Doing so creates a new subreport each time the section Format code is run, using a lot of memory.

To add code to display the child report in a subreport control on a parent report

  1. Add the SubReport control onto the design surface of the parent report.
  2. Double-click the detail section of the report to create a detail_Format event.
  3. Add code like the following to the handler to display a report in the SubReport control.

    To write the code in Visual Basic

    Visual Basic.NET code. Paste INSIDE the Format event.
    Copy Code
    Me.SubReport1.Report = rpt

    To write the code in C#

    C# code. Paste INSIDE the Format event.
    Copy Code
    this.subReport1.Report = rpt;
See Also

Concepts

SubReport (Section Report)


Add Code to Layouts Using Script

Add Code to Layouts Using Script
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Add Code to Layouts Using Script
Show All Show All
Hide All Hide All

In a section report, you can use script to access controls, functions in a class, namespaces, etc. You can also create classes inside the script to call methods or add code to a report's script from a Windows Form. The following sections illustrate simple scripting scenarios with examples.

These steps assume that you have already added a Section Report (code based) template in a Visual Studio project. See Adding an ActiveReport to a Project for more information.

To access controls in script

To add script to a report to access a textbox named TextBox1 in the detail section and assign the text "Hello" to it:

  1. On the script tab of the report, drop down the Object list and select Detail. This populates the Event drop-down list with section events.
  2. Drop down the Event list and select Format. This creates script stubs for the event.

    To access a textbox in the detail section in VB.NET script

    Visual Basic.NET script. Paste INSIDE the Detail Format event.
    Copy Code
    Me.TextBox1.Text = "Hello"

    Or

    Visual Basic.NET script. Paste INSIDE the Detail Format event.
    Copy Code
    CType(rpt.Sections("Detail1").Controls("TextBox1"), TextBox).Text = "Hello"

    To access a textbox in the detail section in C# script

    C# script. Paste INSIDE the Detail Format event.
    Copy Code
    this.textBox1.Text = "Hello";

    Or

    C# script. Paste INSIDE the Detail Format event.
    Copy Code
    ((TextBox)rpt.Sections["detail"].Controls["TextBox1"]).Text = "Hello";

To give a script access to functions in a class in your project

Using the AddNamedItem method, you can allow the script to access functions in a class file within your project. This allows you to keep secure information such as a database connection string or a SQL query string in the code instead of saving it in the RPX file.

  1. In the Code View of the Form, add a class to your project named clsMyItem.

    To add a class in Visual Basic.NET

    Visual Basic.NET code.
    Copy Code
    Public Class clsMyItem
End Class

    To add a class in C#

    C# code.
    Copy Code
    public partial class clsMyItem
{
}
  2. Add a public function to your class using code like the following:

    To create a public function in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the new class.
    Copy Code
    Public Function getMyItem() As String
    getMyItem = "Hello"
End Function

    To create a public function in C#

    C# code. Paste INSIDE the new class.
    Copy Code
    public string getMyItem()
{
    return "Hello";
}
  3. Go to the design view of the report and double-click the gray area around the design surface to create an event-handling method for the ReportStart event.
  4. Add the following code to the handler:

    To access the class in Visual Basic.NET

    Visual Basic.NET code. Paste before or in the ReportStart event.
    Copy Code
    Me.AddNamedItem("myItem", new clsMyItem())

    To access the class in C#

    C# code. Paste before or in the ReportStart event.
    Copy Code

    this.AddNamedItem("myItem", new clsMyItem());
  5. From the Visual Studio toolbox, drag and drop a TextBox control onto the detail section of the report.
  6. Go to the script tab and drop down the Object list to select Detail. This populates the Event drop-down list with section events.
  7. Drop down the Event list and select Format. This creates script stubs for the event.
  8. Add the following script to the event to access a control on the report and populate it using the named item.

    To access the control in VB.NET script

    VB.NET script. Paste INSIDE the Detail Format event.
    Copy Code

    Me.TextBox1.Text = myItem.getMyItem()

    Or

    VB.NET script. Paste INSIDE the Detail Format event.
    Copy Code
    CType(rpt.Sections("Detail1").Controls("TextBox1"), TextBox).Text = myItem.getMyItem()

    To access the control in C# script

    C# script. Paste INSIDE the Detail Format event.
    Copy Code

    this.textBox1.Text = myItem.getMyItem();

    Or

    C# script. Paste INSIDE the Detail Format event.
    Copy Code
    ((TextBox)rpt.Sections["detail"].Controls["textBox1"]).Text = myItem.getMyItem();
  9. Go to the preview tab to view the result.

To access namespaces

Using the AddScriptReference method, you can gain access to .NET or other namespaces. This is only necessary if you need a reference, such as System.Data.dll, that is not initialized in the project before the script runs.

To access a namespace in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Form code. Replace YourReportName with the name of your report.
Copy Code
Private Sub runReport()
      Dim rpt as new YourReportName
      rpt.AddScriptReference("System.Data.dll")
      rpt.Run()
End Sub

To access a namespace in C#

C# code. Paste INSIDE the Form code. Replace YourReportName with the name of your report.
Copy Code
private void runReport()
{
      YourReportName rpt = new YourReportName;
      rpt.AddScriptReference("System.Data.dll");
      rpt.Run();
}

To add code to a report's script from a Windows Form

Using the AddCode method in the Code View of the Form, you can add code into the script. The AddCode method allows you to add actual code segments to the script at run time. This is useful for allowing secure information, such as a database connection string or SQL query string, to be used inside the script without saving it in the RPX file.

  1. Go to the Code View of your report and add a public function like the following:

    To add code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the report class.
    Copy Code
    Public Function addThisCode() As String
   Dim sCode As String = "Public Function ShowACMessage() As String" + Environment.NewLine + "ShowACMessage = ""my Added Code""" + Environment.NewLine + "End Function"
   addThisCode = sCode
End Function

    To add code in C#

    C# code. Paste INSIDE the report class.
    Copy Code
    public string addThisCode()
{
   string sCode = "public string ShowACMessage(){return \"my Added Code\";}";
   return sCode;
}
  2. In the design view of your report double-click the gray area around the design surface to create an event-handling method for the ReportStart event.
  3. Add the following code to the handler:

    To access the class in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the ReportStart event.
    Copy Code
    Me.AddCode(addThisCode())

    To access the class in C#

    C# code. Paste INSIDE the ReportStart event.
    Copy Code
    this.AddCode(addThisCode());
  4. Go to the script tab and drop down the Object list to select Detail. This populates the Event drop-down list with section events.
  5. Drop down the Event list and select Format. This creates script stubs for the event.
  6. Add the following script to the event:

    To write the script in Visual Basic.NET

    VB.NET script. Paste INSIDE the Detail1_Format event.
    Copy Code
    Me.TextBox1.Text = ShowACMessage()

    Or

    VB.NET script. Paste INSIDE the Detail1_Format event.
    Copy Code
    CType(rpt.Sections("Detail1").Controls("TextBox1"), TextBox).Text = ShowACMessage()

    To write the script in C#

    C# script. Paste INSIDE the detail_Format event.
    Copy Code
    this.textBox1.Text = ShowACMessage();

    Or

    C# script. Paste INSIDE the detail_Format event.
    Copy Code
    ((TextBox)rpt.Sections["detail"].Controls["textBox1"]).Text = ShowACMessage();

To create classes inside the script to call methods

If the script requires a method to be called, you can construct a class inside the script.

  1. Go to the script tab and add the following code at the top:

    To create a class inside the script in VB.NET script

    VB.NET script. Paste INSIDE the script tab.
    Copy Code
    Public Class MyFuncs
   Public  Sub New()
   End Sub
   Public Function ShowMyString() As String
      Return "This is my string"
   End Function
End Class

    To create a class inside the script in C#

    C# script. Paste INSIDE the script tab.
    Copy Code
    public class MyFuncs
{
   public MyFuncs()
   {
   }
   public string ShowMyString()
   {
      return "This is my string";
   }
}
  2. On the script tab, now drop down the Object list and select Detail. This populates the Event drop-down list with section events.
  3. Drop down the Event list and select Format. This creates script stubs for the event.
  4. Add the following script to the event:

    To create a class inside the script in VB.NET script

    VB.NET script. Paste INSIDE the Detail1_Format event.
    Copy Code
    Dim f As MyFuncs =  New MyFuncs()
Me.TextBox1.Text = f.ShowMyString

    Or

    VB.NET script. Paste INSIDE the Detail1_Format event.
    Copy Code
    Dim f As MyFuncs =  New MyFuncs()
CType(rpt.Sections("Detail1").Controls("TextBox1"), TextBox).Text = f.ShowMyString

    To create a class inside the script in C#

    C# script. Paste INSIDE the detail_Format event.
    Copy Code
    MyFuncs f = new MyFuncs();
this.textBox1.Text = f.ShowMyString();

    Or

    C# script. Paste INSIDE the detail_Format event.
    Copy Code
    MyFuncs f = new MyFuncs();
((TextBox)rpt.Sections["detail"].Controls["textBox1"]).Text = f.ShowMyString();
Note: Use the examples with the "this" (C#) and "Me"(Visual Basic.NET) keywords, as they are recommended rather than the ones with "rpt".
See Also

Concepts

Scripting in Section Reports


Save and Load RDF Report Files

Save and Load RDF Report Files
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Save and Load RDF Report Files
Show All Show All
Hide All Hide All

ActiveReports allows reports to be saved in their own standard format called an RDF file (Report Document Format). In this format, the data is static. The saved report displays the data that is retrieved when you run the report. You can save a report to an RDF file and load it into the viewer control.

To save a report as a static RDF file

  1. Double-click the title bar of the Windows Form to create an event-handling method for the Form_Load event.
  2. Add the following code to the handler to save the report.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form_Load event.
    Copy Code
    Dim rpt As New YourReportName()
    rpt.Run()
rpt.Document.Save(Application.StartupPath + \NewRDF.RDF)

    To write the code in C#

    C# code. Paste INSIDE the Form_Load event.
    Copy Code
    YourReportName rpt = new YourReportName();
    rpt.Run();
rpt.Document.Save(Application.StartupPath + \\NewRDF.RDF);

To load a saved RDF file into the ActiveReports viewer

  1. Double-click the title bar of the Windows Form to create an event-handling method for the Form_Load event.
  2. Add the following code to the handler to load the saved report.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form_Load event.
    Copy Code
    Viewer1.Document.Load("Location of the .RDF File")

    To write the code in C#

    C# code. Paste INSIDE the Form_Load event.
    Copy Code
    viewer1.Document.Load(@"Location of the .RDF File");
Note: The Windows Form Viewer can display RDF files made with any version of ActiveReports, including COM versions. The FlashViewer viewer type of the WebViewer (Professional Edition) may be able to display RDF files made with previous versions, but this is not guaranteed for every RDF.

To save or load report files to a memory stream

  1. Double-click the title bar of the Windows Form to create an event-handling method for the Form_Load event.
  2. Add the following code to the handler to save the report to a memory stream and load the memory stream into the ActiveReports viewer.

    The following examples show what the code for the method looks like.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Form_Load event.
    Copy Code
    Dim strm As New System.IO.MemoryStream()
Dim rpt As New YourReportName()
rpt.Run()
rpt.Document.Save(strm)
Dim theBytes(strm.Length) As Byte
strm.Read(theBytes, 0, Int(strm.Length))
strm.Position = 0
Viewer1.Document.Load(strm)

    To write the code in C#

    C# code. Paste INSIDE the Form_Load event.
    Copy Code
    System.IO.MemoryStream strm = new System.IO.MemoryStream();
YourReportName rpt = new YourReportName();
rpt.Run();
rpt.Document.Save(strm);
byte[] theBytes = new byte[strm.Length];
strm.Read(theBytes, 0, (int)strm.Length);
strm.Position =0;
viewer1.Document.Load(strm);
See Also
Save and Load RPX Report Files


Save and Load RPX Report Files

Save and Load RPX Report Files
ActiveReports 10 > ActiveReports User Guide > How To > Section Report How To > Save and Load RPX Report Files
Show All Show All
Hide All Hide All

Although ActiveReports writes report layouts in either C# or Visual Basic.NET, you can save the layout of your report as a report XML (RPX) file for portability. If you make changes to the RPX file and load it back into an ActiveReport in Visual Studio, you can see the changes you made reflected in the C# or Visual Basic.NET code in the YourReportName.Designer.vb or YourReportName.Designer.cs file.

Caution: When you load an RPX layout into a report object, it overwrites everything in the report object. In order to avoid overwriting important layouts, add a new blank ActiveReport and load the RPX file onto it.

To save a report as an RPX file at design time

  1. From the Visual Studio Report menu, select Save Layout.
  2. In the Save As dialog that appears, set the file name and select the location where you want to save it. The file extension is *.rpx.
  3. Click the Save button to save the report layout and close the dialog.
Note: When you save a layout that contains a dataset, ActiveReports saves the data adapter and data connection in the component tray, but not the dataset itself. When the saved layout is loaded into another report, you can regenerate the dataset with the data adapter and data connection.

To load an RPX file at design time

  1. From the Visual Studio Report menu, select Load Layout.
  2. In the Open dialog that appears, navigate to the location of the .rpx file and select it.
  3. Click the Open button to load the report layout.

To save a report as an RPX file at runtime

Use the SaveLayout method to save your report layout at runtime.

Note: When you save a report layout, ActiveReports only saves the code in the script editor to the file. Any code behind the report in the .cs or .vb file is not saved to the RPX file.
  1. Right-click the Windows Form and select View Code to see the code view for the Windows form.
  2. Add the following code to the Form class to save the report.

The following example shows what the code for the method looks like.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Form class.
Copy Code
Dim rpt As New SectionReport1()
Dim xtw As New System.Xml.XmlTextWriter(Application.StartupPath + "\report.rpx", Nothing)
rpt.SaveLayout(xtw)
xtw.Close()

To write the code in C#

C# code. Paste INSIDE the Form class.
Copy Code
SectionReport1 rpt = new SectionReport1();
System.Xml.XmlTextWriter xtw = new System.Xml.XmlTextWriter(Application.StartupPath + "\\report.rpx", null);
rpt.SaveLayout(xtw);
xtw.Close();

Save report layouts before they run. If you save a layout after the report runs, you also save any dynamic changes made to properties or sections in the report. To avoid this when you call SaveLayout inside the report code, use the ReportStart event.

Note: The SaveLayout method uses utf-16 encoding when you save to a stream, and utf-8 encoding when you save to a file.

To load an RPX file into the ActiveReports viewer at runtime

  1. Right-click on the Windows Form and select View Code to see the code view for the Windows form.
  2. Add the following code to the form class to load a report.

The following examples show what the code for the method looks like.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Form class.
Copy Code
Dim rpt As New GrapeCity.ActiveReports.SectionReport()
' For the code to work, this report.rpx must be stored in the bin\debug folder of your project.
Dim xtr As New System.Xml.XmlTextReader(Application.StartupPath + "\report.rpx")
rpt.LoadLayout(xtr)
xtr.Close()
Viewer1.Document = rpt.Document
rpt.Run()

To write the code in C#

C# code. Paste INSIDE the Form class.
Copy Code
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
// For the code to work, this report.rpx must be stored in the bin\debug folder of your project.
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(Application.StartupPath + "\\Sample.rpx");
rpt.LoadLayout(xtr);
xtr.Close();
viewer1.Document = rpt.Document;
rpt.Run();
See Also
Save and Load RDF Report Files


Customize, Localize, and Deploy

Customize, Localize, and Deploy
ActiveReports 10 > ActiveReports User Guide > How To > Customize, Localize, and Deploy

ActiveReports uses an English locale by default, and includes localization resources for Japanese and Russian locales. You can also localize all of the components into any language you need. GrapeCity may, from time to time and on the agreement of users who localize components, include additional locales with future hot fixes and service packs. If you are willing to share your localized resources with other users, please inform technical support staff so that they can pass on your resource files to development.

There are several ways to deploy your ActiveReports applications. See the topics listed below for more information on customizing, localizing and deploying your applications.

In this section

Localize Reports, TextBoxes, and Chart Controls
Learn how to localize individual textboxes, chart controls, and entire reports.
Localize ActiveReports Resources
Learn to localize ActiveReports dialogs, error messages, and images.
Deploy Windows Applications
Learn to deploy ActiveReports Windows applications.
Deploy Web Applications
Learn to deploy ActiveReports Windows applications.
Localize the End User Report Designer
Learn to localize the strings and images in the End User Report Designer.
Configure HTTPHandlers in IIS 6
Learn to deploy ActiveReports Windows applications.
Configure HTTPHandlers in IIS 7 and IIS 8
Learn to deploy ActiveReports Windows applications.
See Also

Walkthroughs

Customizing the Flash Viewer UI


Localize Reports, TextBoxes, and Chart Controls

Localize Reports, TextBoxes, and Chart Controls
ActiveReports 10 > ActiveReports User Guide > How To > Customize, Localize, and Deploy > Localize Reports, TextBoxes, and Chart Controls
Show All Show All
Hide All Hide All

In a section layout report, the Report object, TextBox control, and Chart control have a public Culture property that allows you to localize data when the OutputFormat property is set to D (date), C (currency), or other .NET formats.

Note: The default value for the Culture property is (default, inherit). For the Report object, this is the culture of the current thread and for the TextBox control and the ChartControl, this is the culture of the Report object.

In a page layout report, the Report object, TextBox control, and Chart control all have a Language property that works in the same way. The default value for the Language property is Default, which is the culture of the current thread.

Design Time

At design time, you can set the culture or language in the Visual Studio Properties window.

To localize a Report at design time

  1. Click the gray area around the design surface to select the Report in the Properties window.
  2. In the Properties window, drop down the Culture or Language property and select the culture that you want to apply to the report.

To localize a TextBox control at design time

  1. Click the TextBox control that you want to localize to select it.
  2. In the Properties window, drop down the Culture or Language property and select the culture that you want to apply to the textbox.

To localize a Chart control at design time

  1. Click the Chart control to select it.
  2. In the Properties window, drop down the Culture or Language property and select the culture that you want to apply to the chart.

Run Time

You can also specify a culture in code for section reports. For a list of System.Globalization culture codes, see Cultures.

To localize a Report at run time

  1. Double-click the gray area around the design surface, to create an event handling method for the ReportStart event.
  2. In the code view of the report that appears, paste code like the following.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the ReportStart event.
    Copy Code
    YourReportName.Culture = System.Globalization.CultureInfo.CreateSpecificCulture("en-US")

    To write the code in C#

    C# code. Paste INSIDE the ReportStart event.
    Copy Code
    YourReportName.Culture = System.Globalization.CultureInfo.CreateSpecificCulture("en-US");

To localize a TextBox at run time

  1. On the design surface, double-click the section containing the TextBox control that you want to localize to create an event handling method for the section Format event.
  2. In the code view of the report that appears, paste code like the following inside the Format event.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Format event.
    Copy Code
    TextBox.Culture = System.Globalization.CultureInfo.CreateSpecificCulture("en-US")

    To write the code in C#

    C# code. Paste INSIDE the Format event.
    Copy Code
    textBox.Culture = System.Globalization.CultureInfo.CreateSpecificCulture("en-US");

To localize a Chart at run time

  1. On the design surface, double-click the section containing the ChartControl that you want to localize to create an event handling method for the section Format event.
  2. In the code view of the report that appears, paste code like the following in the Format event.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the Format event.
    Copy Code
    ChartControl.Culture = System.Globalization.CultureInfo.CreateSpecificCulture("en-US")

    To write the code in C#

    C# code. Paste INSIDE the Format event.
    Copy Code
    chartControl.Culture = System.Globalization.CultureInfo.CreateSpecificCulture("en-US");
See Also
Localize ActiveReports Resources

Concepts

Localization


Localize ActiveReports Resources

Localize ActiveReports Resources
ActiveReports 10 > ActiveReports User Guide > How To > Customize, Localize, and Deploy > Localize ActiveReports Resources
Show All Show All
Hide All Hide All

You can localize all of the UI strings, error messages, and images that appear in ActiveReports in included resource files, and alter and run a batch file to localize each resource.

To localize ActiveReports Resources

All of the localization files are located in C:\Program Files (x86)\GrapeCity\ActiveReports 10\Localization.

Specify the culture you want to use in the batch files.

  1. Start Notepad or another text editor as an Administrator.
  2. Open *.bat file for each resource you want to localize and change the Culture value to the culture you want to use.
  3. Ensure that the path in ProgamFilesAssemblyDir is correct for your installation, but do not alter any of the other properties.
  4. Save and close each file.

Localize strings (and images) in the resource files.

  1. Launch your zip program as an Administrator and open the *.zip file for each resource you want to localize.
  2. Extract all of the files to
    C:\Program Files (x86)\GrapeCity\ActiveReports 10\Localization.
    A resource subfolder with the same name as the zip file is created.
  3. In the new folder, open each subfolder and change the strings in each of the *.resx files.
    Tip: Strings are located between <value> and </value> tags in the resource files.
  4. If you want to change the images, rename your localized images to the names of the ones in the Res\Resources subfolder and replace them with your localized images.

Run the batch files as an Administrator.

  1. From the Start menu, type cmd in the text box, and press CTRL + SHIFT + ENTER to open a command prompt as an Administrator.
  2. To change directories, type:
    cd C:\Program Files (x86)\GrapeCity\ActiveReports 10\Localization
    and press Enter.
  3. Type the name of the *.bat file and press Enter to run the file. The NameCompleter.exe application runs, and creates the following.
    • A SatelliteAssembly folder inside the resource subfolder.
    • A language subfolder with the name of the culture you set inside the SatelliteAssemby folder.
    • A localized GrapeCity.ActiveReports.AssemblyName.v10.resources.dll file inside the language subfolder.
  4. Copy the language subfolder and paste it into the Debug folder of your application.
    Note: Before you can distribute or put your localization in the Global Assembly Cache (GAC), you must first send the localized GrapeCity.ActiveReports.AssemblyName.v10.resources.dll file to GrapeCity support and get it signed with a strong name. Then you can drag the language subfolder with the signed dll file into C:\WINDOWS\ASSEMBLY, or distribute it with your solution.

Test your localized application on a machine that does not share the culture of the localized DLLs.

  1. Add the following code in the form's constructor just before the InitializeComponent method is called.
  2. Replace the "ja" in the example code with the culture you specified in the *.bat file.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the form's constructor just before the InitializeComponent method.
Copy Code
System.Threading.Thread.CurrentThread.CurrentUICulture = New System.Globalization.CultureInfo("ja")

To write the code in C#

C# code. Paste INSIDE the form's constructor just before the InitializeComponent method.
Copy Code
System.Threading.Thread.CurrentThread.CurrentUICulture = new System.Globalization.CultureInfo("ja");
See Also
Localize Reports, TextBoxes, and Chart Controls
Localize the End User Report Designer

Concepts

Localization


Deploy Windows Applications

Deploy Windows Applications
ActiveReports 10 > ActiveReports User Guide > How To > Customize, Localize, and Deploy > Deploy Windows Applications
Show All Show All
Hide All Hide All

Before you begin

Before deploying a Windows application, there are a few settings that can be helpful.

  • On report files, in the Properties window, change the Copy to Output Directory property to Copy always.
  • For ActiveReports references, change the Copy Local property to True. This puts all of the needed reference assemblies into the Release folder when you build your project.

It is also good to be sure that all of the references you need for your reports are included. Here is a table listing features and required DLLs.

Features and References

These assemblies are added automatically when you add controls to forms or report controls to code-based section reports, but Visual Studio does not do this with XML-based (RPX and RDLX) reports.

Feature | Required Assembly
Export: Excel, Html, Image/Tiff, Pdf, Word/Rtf, Text/Xml | GrapeCity.ActiveReports.Export.*.v10.dll (replace * with Excel, Html, Image, Pdf, Word, or Xml)
Chart report control | GrapeCity.ActiveReports.Chart.v10.dll
Calendar report control | GrapeCity.ActiveReports.Calendar.v10.dll
Sparkline or Bullet report control | GrapeCity.ActiveReports.Dashboard.v10.dll
Viewer control (or printing without the Viewer control) | GrapeCity.ActiveReports.Viewer.Win.v10.dll
Designer, Toolbox, or ReportExplorer control | GrapeCity.ActiveReports.Design.Win.v10.dll
Working with Open report from server dialog | GrapeCity.ActiveReports.ArsClient.v10.dll Newtonsoft.Json.dll
Preview remote reports from ActiveReports Server using code | GrapeCity.ActiveReports.Viewer.Win.v10.dll Newtonsoft.Json.dll

XCopy Deployment

  1. Open your project in Visual Studio, and set the Solution Configuration to Release.
  2. From the Build menu, select Build Solution.
  3. In Windows Explorer, navigate to the project's bin directory, and copy the files from the Release folder into a zip file.
  4. Distribute the zip file.

MSI Installer Deployment

To create an installer project

  1. Open an existing ActiveReports project or create a new one.
  2. From the Visual Studio Build menu, select Build YourActiveReportsProjectName to build your report project.
  3. From the File menu, select Add, then New Project to open the Add New Project dialog.
  4. In the Add New Project dialog under Project Types, expand the Other Project Types node and select Setup and Deployment.
  5. Under Visual Studio Installer, select Setup Project, rename the file and click OK. The ProductName that you enter determines the name that is displayed for the application in folder names and in the Programs and Features control panel item.
  6. In the File System editor that appears, under File System on Target Machine, select the Application Folder.
    Note: To show the File System editor at any time, drop down the View menu and select Editor, then File System.
  7. From the Visual Studio Action menu, select Add, then Project Output.
  8. In the Add Project Output Group dialog that appears, choose your ActiveReports project name from the drop-down list.
  9. In the list, select Primary Output and click OK. This adds all of the existing assembly dependencies to your project.
  10. If you want to add other ActiveReports DLLs to the installer (e.g. if you use OleObjects on reports, you need to include the Interop.dll or Interop64.dll for 64-bit machines), in the Solution Explorer, right-click the installer project name, select Add, then Assembly.
    Note: If you would rather use the ActiveReports .msm file, please contact our technical support team.
  11. In the Select Component dialog that appears, select any components that you want to add and click the OK button.
  12. From the Visual Studio Build menu, select Build YourInstallerProjectName to build your Installer project.

To deploy the installer application

  1. Select the Installer project in the Solution Explorer.
  2. From the Visual Studio Project menu, click Install.
  3. The Installer application runs and installs the project on your computer. The distributable exe and msi setup files appear in your installer project Debug folder.
See Also
Deploy Web Applications
Localize the Viewer Control


Deploy Web Applications

Deploy Web Applications
ActiveReports 10 > ActiveReports User Guide > How To > Customize, Localize, and Deploy > Deploy Web Applications

Show All Show All
Hide All Hide All

Follow this guide to deploy ActiveReports Web projects to your Web server. For Web projects using the Professional Edition HttpHandlers, see Configure HTTPHandlers in IIS 6 or Configure HTTPHandlers in IIS 7 and IIS 8.

Before you begin

To deploy ActiveReports Web projects, you must have access to the Microsoft .NET Framework version 3.5 SP1 or higher and the coordinating version of ASP.NET. You must also have access to Internet Information Services version 5.1 or higher, and you need administrative access to the server.

It is also good to be sure that all of the references you need for your reports are included. Here is a table listing features and required DLLs.

Features and References

These assemblies are added automatically when you add controls to forms or report controls to code-based section reports, but Visual Studio does not do this with XML-based (RPX and RDLX) reports.

Feature | Required Assembly
Export: Excel | GrapeCity.ActiveReports.Export.Excel.v10.dll DocumentFormat.OpenXml.dll
Export: HTML | GrapeCity.ActiveReports.Export.Html.v10.dll
Export: Image | GrapeCity.ActiveReports.Export.Image.v10.dll
Export: PDF | GrapeCity.ActiveReports.Export.Pdf.v10.dll
Export: Word/RTF | GrapeCity.ActiveReports.Export.Word.v10.dll DocumentFormat.OpenXml.dll
Export: Xml | GrapeCity.ActiveReports.Export.Xml.v10.dll
Export: Rdf | GrapeCity.ActiveReports.Export.Rdf.v10.dll
Export: XAML | GrapeCity.ActiveReports.Export.Xaml.v10.dll
Chart report control | GrapeCity.ActiveReports.Chart.v10.dll
Calendar report control | GrapeCity.ActiveReports.Calendar.v10.dll
Sparkline or Bullet report control | GrapeCity.ActiveReports.Dashboard.v10.dll
WebViewer or HttpHandlers (Pro Edition only) | GrapeCity.ActiveReports.Web.v10.dll

Other important assemblies that are required for deploying web applications are as follows:
  • GrapeCity.ActiveReports.v10.dll
  • GrapeCity.ActiveReports.Extensibility.v10.dll
  • GrapeCity.ActiveReports.Export.Document.v10.dll
  • GrapeCity.ActiveReports.Diagnostics.v10.dll

To copy referenced DLLs to your project

  1. In the Visual Studio Solution Explorer, if the References node is not showing, click the Show All Files button.
  2. Expand the References node, and select one of the ActiveReports references.
  3. In the Properties window, change the CopyLocal property to True. The corresponding DLL is stored in the Bin folder of your project.
  4. Set the CopyLocal property to True for each ActiveReports reference used in your project.

To install prerequisites on the server

Follow Microsoft's instructions to install each of the following on your Web server:

  • The Microsoft .NET Framework version 3.5 SP1 or higher
  • Internet Information Services (IIS) version 5.1 or 6.0
  • ASP.NET version 3.5 or higher (must be the same version as the Framework)

To copy your project to the server

  1. Copy the entire directory containing your project to the server.
  2. If your project is in a virtual directory on your local machine (i.e. C:\Inetpub\wwwroot\YourProject), you must set up a virtual directory in IIS on the server as well.

To set permissions on the server

Depending on your project, you may need to set permissions to allow ActiveReports access to data or folders.

Some examples of required permissions on the server:

  • If you are saving files (e.g. PDF or RDF exports) to a folder on Windows XP or 2000 machines, the ASPNET user ID needs Write access to that folder.
  • Windows 2003 is user configurable, so use the name assigned to the ASPNET user instead.
  • If your application reads anything from any folder, assign Read access to it.
  • If your reports run on any networked data source (e.g. SQL, Access, etc.) assign Read access to it.
  • If you use CacheToDisk, assign IsolatedStorageFilePermission to it.
See Also

Walkthroughs

Custom Web Exporting Section Reports (Std Edition)
Custom Web Exporting


Localize the End User Report Designer

Localize the End User Report Designer
ActiveReports 10 > ActiveReports User Guide > How To > Customize, Localize, and Deploy > Localize the End User Report Designer
Show All Show All
Hide All Hide All

You can localize all of the UI strings, error messages, and images that appear in the ActiveReports Windows Forms Designer control in included resource files, and alter and run a batch file to localize the assembly.

To localize the Designer control

All of the localization files are located in C:\Program Files (x86)\GrapeCity\ActiveReports 10\Localization.

Specify the culture you want to use in the batch file.

  1. Start Notepad or another text editor as an Administrator.
  2. Open the ARDesigner.bat file and change the Culture value to the culture you want to use.
  3. Ensure that the path in ProgamFilesAssemblyDir is correct for your installation, but do not alter any of the other properties.
  4. Save and close the file.

Localize strings (and images) in the resource files.

  1. Launch your zip program as an Administrator and open the ARDesigner.zip file.
  2. Extract all of the files to
    C:\Program Files (x86)\GrapeCity\ActiveReports 10\Localization.
    An ARDesigner subfolder is created.
  3. In the new folder, open each subfolder and change the strings in each of the *.resx files.
    Tip: Strings are located between <value> and </value> tags in the resource files.
  4. If you want to change the images, rename your localized images to the names of the ones in the Res\Resources subfolder and replace them with your localized images.

Run the batch file as an Administrator.

  1. From the Start menu, type cmd in the text box, and press CTRL + SHIFT + ENTER to open a command prompt as an Administrator.
  2. To change directories, type:
    cd C:\Program Files (x86)\GrapeCity\ActiveReports 10\Localization
    and press Enter.
  3. Type ARDesigner.bat and press Enter to run the file. The NameCompleter.exe application runs, and creates the following.
    • A SatelliteAssembly folder inside the ARDesigner subfolder.
    • A language subfolder with the name of the culture you set inside the SatelliteAssemby folder.
    • A localized GrapeCity.ActiveReports.Design.Win.v10.resources.dll file inside the language subfolder.
  4. Copy the language subfolder and paste it into the Debug folder of your application.
    Note: Before you can distribute or put your localization in the Global Assembly Cache (GAC), you must first send the localized GrapeCity.ActiveReports.Design.Win.v10.resources.dll file to GrapeCity support and get it signed with a strong name. Then you can drag the language subfolder with the signed dll file into C:\WINDOWS\ASSEMBLY, or distribute it with your solution.

Test your localized application on a machine that does not share the culture of the localized DLLs.

  1. Add the following code in the form's constructor just before the InitializeComponent method is called.
  2. Replace the "ja" in the example code with the culture you specified in the ARDesigner.bat file.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the form's constructor just before the InitializeComponent method.
Copy Code
System.Threading.Thread.CurrentThread.CurrentUICulture = New System.Globalization.CultureInfo("ja")

To write the code in C#

C# code. Paste INSIDE the form's constructor just before the InitializeComponent method.
Copy Code
System.Threading.Thread.CurrentThread.CurrentUICulture = new System.Globalization.CultureInfo("ja");
See Also
Customize, Localize, and Deploy


Configure HTTPHandlers in IIS 6

Configure HTTPHandlers in IIS 6
ActiveReports 10 > ActiveReports User Guide > How To > Customize, Localize, and Deploy > Configure HTTPHandlers in IIS 6
Show All Show All
Hide All Hide All

HttpHandlers are included in the Professional edition of ActiveReports to allow you to quickly and easily display reports in the browser. In order to use ActiveReports HTTP handlers on the Web with ASP.NET, you must first configure the machine to use the handlers.

For information on how to configure ActiveReports handler mappings in IIS 7.x, see the section Configure HTTPHandlers in IIS 7 and IIS 8 of this Guide.

Follow these steps to configure the ActiveReports HTTP handlers in IIS 6.x so that you can link directly to reports in your Web applications. Once the handlers are configured, you can automatically run a report and view it in the browser from a URL.

To configure ActiveReports HTTP handlers to enable report linking on your machine

  1. In the Control Panel, open Administrative Tools, then Internet Information Services (IIS) Manager.
  2. In the Internet Information Services (IIS) Manager window that appears, in the left pane, expand the Sites node, right-click the Web application you want to configure, and select Properties.
  3. On the Directory tab of the YourWebSite Properties dialog that appears, click the Configuration button.
  4. In the Application Configuration dialog that appears, select the list item with .aspx in the Extension column and click Edit.
    Note: If your machine does not have the ASP.NET server components installed, the .aspx handler does not appear in the Application Mappings list.
  5. In the Executable field, select and copy all of the text, and click Cancel to return to the Application Configuration dialog.
  6. Click the Add button to add a new Application Mapping.
  7. In the Add/Edit Application Extension Mapping dialog that appears, enter the information from the first row of the table below.
    Executable | Extension | Check that file exists
    Paste the text copied from the *.aspx script map. | .AR10 | Clear this checkbox.
    Paste the text copied from the *.aspx script map. | .AR10Web | Clear this checkbox.
    Paste the text copied from the *.aspx script map. | .rpx | Select this checkbox.
    Paste the text copied from the *.aspx script map. | .rdlx | Select this checkbox.
    Paste the text copied from the *.aspx script map. | .rdl | Select this checkbox.
    Paste the text copied from the *.aspx script map. | .ActiveReport | Select this checkbox.
  8. Click OK to close the window and add the script mapping.
  9. Repeat for each script mapping in the table above.

To enable HTTP handlers in your project

In your Web application, open the Web.config file and add code like the following between the <system.web> and </system.web> tags, changing the Version number on each line to match the version installed on your machine.

Paste inside the <system.web> tags.
Copy Code
<httpHandlers>
    <add verb="*" path="*.AR10" type="GrapeCity.ActiveReports.Web.Handlers.ReportBinariesStreamer, GrapeCity.ActiveReports.Web.v10, Version=8.0.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
    <add verb="*" path="*.ActiveReport" type="GrapeCity.ActiveReports.Web.Handlers.CompiledReportHandler, GrapeCity.ActiveReports.Web.v10, Version=8.0.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
    <add verb="*" path="*.rpx" type="GrapeCity.ActiveReports.Web.Handlers.RpxHandler, GrapeCity.ActiveReports.Web.v10, Version=8.0.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
    <add verb="*" path="*.rdl" type="GrapeCity.ActiveReports.Web.Handlers.RdlxHandler, GrapeCity.ActiveReports.Web.v10, Version=8.0.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
    <add verb="*" path="*.rdlx" type="GrapeCity.ActiveReports.Web.Handlers.RdlxHandler, GrapeCity.ActiveReports.Web.v10, Version=8.0.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
    <add verb="*" path="*.AR10Web" type="GrapeCity.ActiveReports.Web.Handlers.WebCacheAccessHandler, GrapeCity.ActiveReports.Web.v10, Version=8.0.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
</httpHandlers>
See Also
Configure HTTPHandlers in IIS 7 and IIS 8
Deploy Web Applications


Configure HTTPHandlers in IIS 7 and IIS 8

Configure HTTPHandlers in IIS 7 and IIS 8
ActiveReports 10 > ActiveReports User Guide > How To > Customize, Localize, and Deploy > Configure HTTPHandlers in IIS 7 and IIS 8
Show All Show All
Hide All Hide All

HttpHandlers are included in the Professional edition of ActiveReports to allow you to quickly and easily display reports in the browser.

Follow these steps to configure the ActiveReports HTTP handlers in IIS 7.x so that you can link directly to reports in your Web applications. Once the handlers are configured, you can automatically run a report and view it in the browser from a URL.

Classic Mode

If any part of your Web application is not supported in Integrated Mode, you can run it using the Classic .NET AppPool.

To run your Web application in the Classic .NET Application Pool

  1. In the Control Panel, open Administrative Tools, then Internet Information Services (IIS) Manager.
  2. In the Internet Information Services (IIS) Manager window that appears, in the left pane under Connections, expand the Sites node and select the Web application you want to configure.
  3. To the right of the Handler Mappings pane that appears, under Actions, click Basic Settings.
  4. In the Edit Site dialog that appears, click the Select button.
  5. In the Select Application Pool dialog that appears, drop down the Application pool, select Classic .NET AppPool, and click OK.
  6. Back in the Edit Site dialog, click OK to accept the changes.

To configure ActiveReports HTTP handlers to enable report linking in your Web applications

  1. In the Control Panel, open Administrative Tools, then Internet Information Services (IIS) Manager.
  2. In the Internet Information Services (IIS) Manager window that appears, in the left pane under Connections, expand the Sites node and select the Web application you want to configure.
  3. In the site's Home pane that appears, under IIS, double-click Handler Mappings.
  4. To the right of the Handler Mappings pane that appears, under Actions, click Add Script Map.
  5. In the Add Script Map dialog that appears, enter the information from the first row of the table below.
    Note: If you have a 64 bit app pool, add script mappings for the 64 bit version of the aspnet_isapi.dll by navigating to C:\Windows\Microsoft.NET\Framework64\v*\aspnet_isapi.dll.
    Request path | Executable | Name
    *.AR10 | aspnet_isapi.dll version to match your app pool | ActiveReports 10 Script Mapping
    *.AR10Web | aspnet_isapi.dll version to match your app pool | ActiveReports 10 Cache Item Script Mapping
    *.rpx | aspnet_isapi.dll version to match your app pool | ActiveReports 10 RPX Script Mapping
    *.rdlx | aspnet_isapi.dll version to match your app pool | ActiveReports 10 RDLX Script Mapping
    *.rdl | aspnet_isapi.dll version to match your app pool | ActiveReports 10 RDL Script Mapping
    *.ActiveReport | aspnet_isapi.dll version to match your app pool | ActiveReports 10 Script Mapping
  6. Click the Request Restrictions button and ensure that the Invoke handler only if request is mapped to check box is cleared.
  7. Click OK to close the window and add the script mapping.
  8. Repeat for each script mapping in the table above.

To add handlers without configuring IIS 7 or IIS 8 using the Classic .NET AppPool

  1. In your Web application, open the Web.config file and add code like the following between the <system.web> and </system.web> tags, changing the ActiveReports Version number on each line to match the version installed on your machine.
    Paste inside the <system.web> tags.
    Copy Code
    <httpHandlers>
    <add verb="*" path="*.AR10" type="GrapeCity.ActiveReports.Web.Handlers.ReportBinariesStreamer, GrapeCity.ActiveReports.Web.v10, Version=8.0.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
    <add verb="*" path="*.ActiveReport" type="GrapeCity.ActiveReports.Web.Handlers.CompiledReportHandler, GrapeCity.ActiveReports.Web.v10, Version=8.0.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
    <add verb="*" path="*.rpx" type="GrapeCity.ActiveReports.Web.Handlers.RpxHandler, GrapeCity.ActiveReports.Web.v10, Version=8.0.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
    <add verb="*" path="*.rdl" type="GrapeCity.ActiveReports.Web.Handlers.RdlxHandler, GrapeCity.ActiveReports.Web.v10, Version=8.0.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
    <add verb="*" path="*.rdlx" type="GrapeCity.ActiveReports.Web.Handlers.RdlxHandler, GrapeCity.ActiveReports.Web.v10, Version=8.0.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
    <add verb="*" path="*.AR10Web" type="GrapeCity.ActiveReports.Web.Handlers.WebCacheAccessHandler, GrapeCity.ActiveReports.Web.v10, Version=8.0.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
</httpHandlers>
  2. In your Web application, open the Web.config file and add code like the following between the <system.webServer> and </system.webServer> tags depending on the .Net Framework version 2.0 or 4.0 installed on your machine:

    .Net 2.0

    Paste inside the <system.webServer> tags.
    Copy Code
    <handlers>
      <add name="AR10Rpx" path="*.rpx" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv2.0,bitness32"/>
      <add name="AR10Rdlx" path="*.rdlx" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv2.0,bitness32"/>
      <add name="AR10" path="*.AR10" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv2.0,bitness32"/>
      <add name="AR10Web" path="*.AR10Web" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv2.0,bitness32"/>
      <add name="AR10Rdl" path="*.rdl" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv2.0,bitness32"/>
      <add name="ActiveReport" path="*.ActiveReport" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv2.0,bitness32"/>
</handlers>

    .Net 4.0

    Paste inside the <system.webServer> tags.
    Copy Code
    <handlers>
          <add name="AR10Rpx" path="*.rpx" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv4.0,bitness32"/>
          <add name="AR10Rdlx" path="*.rdlx" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv4.0,bitness32"/>
          <add name="AR10Rdl" path="*.rdl" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv4.0,bitness32"/>
          <add name="AR10" path="*.AR10" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv4.0,bitness32"/>
          <add name="AR10Web" path="*.AR10Web" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv4.0,bitness32"/>
          <add name="ActiveReport" path="*.ActiveReport" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv4.0,bitness32"/>
    </handlers>

    Note: If you have a 64 bit Web application, change the preCondition attribute on each line to classicMode,runtimeVersionv2.0,bitness64, or in ASP.NET 4, change it to classicMode,runtimeVersion4.0,bitness64.

Integrated Mode

To configure ActiveReports HTTP handlers to enable report linking in your Web applications

  1. In the Control Panel, open Administrative Tools, then Internet Information Services (IIS) Manager.
  2. In the Internet Information Services (IIS) Manager window that appears, in the left pane under Connections, expand the Sites node and select the Web application you want to configure.
  3. In the site's Home pane that appears, under IIS, double-click Handler Mappings.
  4. To the right of the Handler Mappings pane that appears, under Actions, click Add Managed Handler.
  5. In the Add Managed Handler dialog that appears, enter the information from the first row of the table below.
    Request path | Type | Name
    *.AR10 | GrapeCity.ActiveReports.Web.Handlers.ReportBinariesStreamer | ActiveReports 10 integrated handler mapping
    *.AR10Web | GrapeCity.ActiveReports.Web.Handlers.WebCacheAccessHandler | ActiveReports 10 cache item integrated handler mapping
    *.rpx | GrapeCity.ActiveReports.Web.Handlers.RpxHandler | ActiveReports 10 RPX integrated handler mapping
    *.rdlx | GrapeCity.ActiveReports.Web.Handlers.RdlxHandler | ActiveReports 10 RDLX integrated handler mapping
    *.rdl | GrapeCity.ActiveReports.Web.Handlers.RdlxHandler | ActiveReports 10 RDL integrated handler mapping
    *.ActiveReport | GrapeCity.ActiveReports.Web.Handlers.CompiledReportHandler | ActiveReports 10 integrated handler mapping
  6. Click the Request Restrictions button and ensure that the Invoke handler only if request is mapped to check box is cleared.
  7. Click OK to close the window and add the handler mapping.
  8. Repeat for each handler mapping in the table above.

To add handlers without configuring IIS 7 or IIS 8 using the DefaultAppPool

In your Web application, open the Web.config file and add code like the following between the <system.webServer> and </system.webServer> tags, changing the ActiveReports Version number on each line to match the version installed on your machine.

Paste inside the <system.webServer> tags.
Copy Code
<add verb="*" path="*.ar10" type="GrapeCity.ActiveReports.Web.Handlers.ReportBinariesStreamer, GrapeCity.ActiveReports.Web.v10, Version=10.x.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" name="AR10_ReportBinariesStreamer" resourceType="Unspecified" preCondition="integratedMode"/>
<add verb="*" path="*.ar10Web" type="GrapeCity.ActiveReports.Web.Handlers.WebCacheAccessHandler, GrapeCity.ActiveReports.Web.v10, Version=10.x.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" name="AR10_WebCacheAccessHandler" resourceType="Unspecified" preCondition="integratedMode"/>
<add verb="*" path="*.ActiveReport" type="GrapeCity.ActiveReports.Web.Handlers.CompiledReportHandler, GrapeCity.ActiveReports.Web.v10, Version=10.x.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" name="AR10_CompiledReportHandler" resourceType="Unspecified" preCondition="integratedMode"/>
<add verb="*" path="*.rpx" type="GrapeCity.ActiveReports.Web.Handlers.RpxHandler, GrapeCity.ActiveReports.Web.v10, Version=10.x.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" name="AR10_RpxHandler" resourceType="Unspecified" preCondition="integratedMode"/>
<add verb="*" path="*.rdl,*.rdlx" type="GrapeCity.ActiveReports.Web.Handlers.RdlxHandler, GrapeCity.ActiveReports.Web.v10, Version=10.x.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" name="AR10_RdlxHandler" resourceType="Unspecified" preCondition="integratedMode"/>

Note: If you have a 64 bit Web application, change the preCondition attribute on each line to integratedMode,runtimeVersionv2.0,bitness64, or in ASP.NET 4, change it to integratedMode,runtimeVersion4.0,bitness64.
See Also
Configure HTTPHandlers in IIS 6


Use Fields in Reports

Use Fields in Reports
ActiveReports 10 > ActiveReports User Guide > How To > Use Fields in Reports
Show All Show All
Hide All Hide All

Fields provide data to display on a report page. ActiveReports has two types of fields; a bound or database field and a calculated field.

  • Bound or Database field: A field where the value is returned by a query. See the Query dropdown in the Dataset Dialog for further information on queries in page reports and RDL reports.
  • Calculated field: A field where the value is an expression created with functions, formulas and operators. Use the following instructions to add calculated fields in a report.

To create a calculated field in a Section Report

In a section report, once you connect to a data source, bound fields automatically appear under the Fields > Bound node in the Report Explorer. However, you have to add calculated fields manually under the Fields > Calculated node. The following steps guide you through the process.

  1. In the Report Explorer, expand the Fields node.
  2. Right-click the Calculated node and select Add. This action creates an unbound field with a default name like field1.

  3. In the Report Explorer, with field1 selected, go to the Properties Window and set a value for the field in the Formula property. For e.g., for a calculated field Inventory, in the Formula field, enter the expression =UnitsInStock - ReorderLevel.

    You can change the name of the field in the Name property.
  4. Drag the field from the Calculated node onto the detail section of the report. This action creates a TextBox object, and sets its DataField property to the name of the calculated field.
Note: You can also add C# expressions in a Bound Field's DataField property to modify it. See Add Field Expressions for more information.

To create a calculated field in a Page Report/RDL Report

In a page report or a RDL report, all fields irrespective of their type appear under the corresponding DataSet node in the Report Explorer. To create a calculated field, you can add the new field in the DataSet dialog.

The following steps guide you through the process.

Note: These steps assume that you have added a DataSet in your report. See Add a Dataset for further information.
  1. In the Report Explorer, right-click the data set node and select Edit.
  2. In the DataSet dialog that appears, go to the Fields page and click the Add (+) button to add an empty field to the list.
  3. Under Name, enter the name of the field. By default it appears as Field1.
  4. Under Value, click the dropdown arrow and select <Expression...>, to open the Expression Editor dialog.
  5. In the Expression Editor dialog, create an expression you want to use as the value for the calculated field. For e.g., for a calculated field Cost, in the Formula field, enter the expression =[Quantity]*[Price]. See Expressions for further information.
  6. Click OK to close the Expression Editor and then the DataSet dialogs.
  7. From the Report Explorer, drag the calculated field from that now appears as a field under the DataSet node onto the design surface. This action creates a TextBox object, and sets its Value property to the name of the calculated field expression.
See Also
Add Field Expressions


Use Advanced Printing Options

Use Advanced Printing Options
ActiveReports 10 > ActiveReports User Guide > How To > Use Advanced Printing Options
Show All Show All
Hide All Hide All

The advanced printing options in the ActiveReports Viewer, allow you to change page scaling, set page margins and add a watermark when printing a report.

To access the advanced printing options

  1. In the Viewer toolbar, click the Print button. See Windows Forms Viewer for information on the Viewer toolbar.
  2. In the Print dialog that appears, click Advanced.
  3. In the Page Setup dialog that appears, go to the Layout and Watermark tabs to set page scaling, page margins and watermark options.

To modify page scaling

  1. In the Page Setup dialog, on the Layout tab under the Page Handling group, select a value from the Page Scaling drop-down list.
  2. In case you select Multiple pages per sheet under Page Scaling, you can specify the Pages per sheet and Page Order options.
  3. Click OK to close the dialog.
Note: You may also check the Print page border or Auto-Rotate Pages check box for further customization of your print setup.

To change page margins

  1. In the Page Setup dialog, on the Layout tab under the Margins group, enter values for the Left, Top, Right and Bottom margins.
  2. Click OK to close the dialog.

To add a watermark to the report

  1. In the Page Setup dialog, on the Watermark tab, under the textbox named Text, enter the text you want to display in your watermark.
  2. Select the Font, Size, and Color for the text.
  3. In the Angle field, enter a numeric value between 0 and 360 (A value of 0 renders straight left-to-right text. A value of 180 renders inverted text).
  4. Click OK to close the dialog.
See Also

Getting Started

Windows Forms Viewer
WPF Viewer


Provide One-Touch Printing in the WebViewer (Pro Edition)

Provide One-Touch Printing in the WebViewer (Pro Edition)
ActiveReports 10 > ActiveReports User Guide > How To > Provide One-Touch Printing in the WebViewer (Pro Edition)

In the WebViewer control, when the ViewerType is set to FlashViewer, you can provide one-touch printing. This opens the Print dialog as soon as you run your application. This feature is available in the Professional Edition only.

The following steps assume that you have already created a Web Application in Visual Studio and added a WebViewer control on the aspx page. See Adding ActiveReports Controls and Getting Started with the WebViewer for further information.

To provide one-touch printing

  1. Add an ActiveReport to the project. See Adding an ActiveReport to a Project for further details.
  2. Go to the aspx page of your application which contains the WebViewer.
  3. With the WebViewer control selected, go to the Properties Window, and make the following changes:
    • Set the ReportName property to the name of your report.
    • Set the ViewerType property to FlashViewer.
    • Expand the FlashViewerOptions > PrintOptions node, and set the StartPrint property to True.
    • If you do not want to display the report to the user, set the Height and Width properties to 0.
  4. Copy the ActiveReports.FlashViewer.swf file into your project folder where your aspx file is located. You can get this file from the ...\GrapeCity\ActiveReports 10\Deployment\Flash folder.
  5. Run the project to see the Print dialog box and send the report to print by clicking the Print button.
See Also

Getting Started

Flash Viewer


Provide PDF Printing in the Silverlight Viewer (Pro Edition)

Provide PDF Printing in the Silverlight Viewer (Pro Edition)
ActiveReports 10 > ActiveReports User Guide > How To > Provide PDF Printing in the Silverlight Viewer (Pro Edition)

You can set PDF printing in your Silverlight project to allow printing a document from Silverlight to the PDF format directly. This is a good alternative to the default Silverlight printing with its large print spool size issue.

If PDF printing is set up in the Silverlight project, you see a Print dialog appear on clicking the Print button in the SilverlightViewer toolbar:

When you print to PDF, the exceptions that occur at printing cannot be caught. Thus, if there is a printing exception, no Print dialog appears after you click the Print button.

Caution: If your Web browser does not support JavaScript and Adobe Reader, the Silverlight Viewer will use its default printing instead of the PDF printing. Also, PDF printing is not supported in the Silverlight Out-of-Browser applications.

To set up PDF printing in the Silverlight Viewer project

  1. Open your Silverlight project or create a new Silverlight project as described in Using the SilverlightViewer.
  2. In Solution Explorer, open the Web.config file.
  3. Make sure that the http handlers have been added to the Web.config file. The http handlers are added to the Web config automatically when you add ActiveReports 10 Web Service - see Using the Silverlight Viewer for details:
    XML code. Handlers appear in the XML view of the Web.config file inside the system.web section.
    Copy Code
    <httpHandlers>
      <add verb="*" path="*.AR10" type="GrapeCity.ActiveReports.Web.Handlers.ReportBinariesStreamer, GrapeCity.ActiveReports.Web.v10, Version=8.0.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
      <add verb="*" path="*.AR10Web" type="GrapeCity.ActiveReports.Web.Handlers.WebCacheAccessHandler, GrapeCity.ActiveReports.Web.v10, Version=8.0.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
      <add verb="*" path="*.ActiveReport" type="GrapeCity.ActiveReports.Web.Handlers.CompiledReportHandler, GrapeCity.ActiveReports.Web.v10, Version=8.0.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
      <add verb="*" path="*.rpx" type="GrapeCity.ActiveReports.Web.Handlers.RpxHandler, GrapeCity.ActiveReports.Web.v10, Version=8.0.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
      <add verb="*" path="*.RDL,*.rdlx" type="GrapeCity.ActiveReports.Web.Handlers.RdlxHandler, GrapeCity.ActiveReports.Web.v10, Version=8.0.xxxx.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
      <remove verb="*" path="*.asmx" />
      <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    </httpHandlers>
    Note: You might need to update the Version and PublicKeyToken values to reflect the current version of ActiveReports installed on your machine. You can find the Version and PublicKeyToken values in the Global Assembly Cache (GAC), C:\Windows\assembly.
  4. On MainPage.xaml, go to the Properties window and then to the Events view.
  5. In the list of events, double-click the viewer1_Loaded event.
  6. On MainPage.xaml.cs/vb that opens, add the following code to the viewer1_Loaded event:

    To write code in Visual Basic.NET

    Visual Basic.NET Code. Paste to MainPage.xaml.vb to the Viewer1_Loaded event.
    Copy Code
    Viewer1.PdfPrint = True

    To write code in C#

    C# Code. Paste to MainPage.xaml.cs to the viewer1_Loaded event.
    Copy Code
    viewer1.PdfPrint = true;
See Also

Getting Started

Silverlight Viewer


Print Methods In ActiveReports

Print Methods In ActiveReports
ActiveReports 10 > ActiveReports User Guide > How To > Print Methods In ActiveReports
Show All Show All
Hide All Hide All

ActiveReports provides access to Print methods to enable printing of page and section reports. You can access Print methods in any of the following ways:

  • Viewer.Print method (using the Viewer control)
  • Print methods in SectionDocument or PageDocument
  • Print methods in the PrintExtension class

Viewer.Print method

The code sample illustrate how to access the the print method using the Viewer conrol.

You can use the Print method of the Viewer class to print a report loaded in the Viewer control. Make sure that the report is loaded completely before Print is executed.

Visual Basic.NET code. Add this code INSIDE the LoadCompleted event of the Viewer
Copy Code
Viewer1.Print(True, True, True)

C# code. Add this code INSIDE the LoadCompleted event of the Viewer
Copy Code
viewer1.Print(true, true, true);

Print methods in SectionDocument or PageDocument

SectionDocument and PageDocument types have Print methods that can be used directly on the document object. The following code samples illustrate how to access the print methods that can be used directly on the document object.

Note: The Print method is implemented as an extension method of the PrintExtension.Print method, which is present in Grapecity.ActiveReport namespace of GrapeCity.ActiveReports.Viewer.Win.v10 assembly.

In order to access Print method through SectionDocument or PageDocument class, you need to add GrapeCity.ActiveReports.Viewer.Win.v10 reference to the project. Also, as mentioned in the code, make sure that you add a reference for the GrapeCity.ActiveReports namespace in your project using Imports (Visual Basic.NET) or using (C#) statement.

Section Report

Visual Basic.NET code. Paste at the top of the code view.
Copy Code
Imports GrapeCity.ActiveReports
Visual Basic.NET code. Paste INSIDE the Form_Load event.
Copy Code
Dim rpt = New SectionReport1()
rpt.Run(False)
Dim sectionDocument = rpt.Document
sectionDocument.Print(True, True, False)

C# code. Paste at the top of the code view.
Copy Code
using GrapeCity.ActiveReports;
C# code. Paste INSIDE the Form_Load event.
Copy Code
var rpt = new SectionReport1();
rpt.Run(false);
var sectionDocument = rpt.Document;
sectionDocument.Print(true, true, false);

Page Report

Visual Basic.NET code. Paste at the top of the code view.
Copy Code
Imports GrapeCity.ActiveReports
Visual Basic.NET code. Paste INSIDE the Form_Load event.
Copy Code
Dim file_name As String = "..\..\PageReport1.rdlx"
Dim pageReport As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(file_name))
Dim pageDocument As New GrapeCity.ActiveReports.Document.PageDocument(pageReport)
pageDocument.Print(True, True, False)

C# code. Paste at the top of the code view.
Copy Code
using GrapeCity.ActiveReports;
C# code. Paste INSIDE the Form_Load event.
Copy Code
string file_name = @"..\..\PageReport1.rdlx";
GrapeCity.ActiveReports.PageReport pageReport = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(file_name));
GrapeCity.ActiveReports.Document.PageDocument pageDocument = new GrapeCity.ActiveReports.Document.PageDocument(pageReport);
pageDocument.Print(true, true, false);

Print methods in the PrintExtension class

You can use the Print method of the PrintExtension class to print a report loaded in the Viewer control. Make sure that the report is loaded completely before Print is executed. The following code samples illustrate how to access the print method of the PrintExtension class.

Note: The Print method is implemented as an extension method of the PrintExtension.Print method, which is present in Grapecity.ActiveReport namespace of GrapeCity.ActiveReports.Viewer.Win.v10 assembly.

In order to access Print method through SectionDocument or PageDocument class, you need to add GrapeCity.ActiveReports.Viewer.Win.v10 reference to the project. Also, as mentioned in the code, make sure that you add a reference for the GrapeCity.ActiveReports namespace in your project using Imports (Visual Basic.NET) or using (C#) statement.

Section Report

Visual Basic.NET code. Paste INSIDE an event like Button_Click.
Copy Code
GrapeCity.ActiveReports.PrintExtension.Print(sectionDocument, True, True)

C# code. Paste INSIDE an event like Button_Click.
Copy Code
GrapeCity.ActiveReports.PrintExtension.Print(sectionDocument, true, true);

Page Report

Visual Basic.NET code. Paste INSIDE an event like Button_Click.
Copy Code
GrapeCity.ActiveReports.PrintExtension.Print(pageDocument, True, True)

C# code. Paste INSIDE an event like Button_Click.
Copy Code
GrapeCity.ActiveReports.PrintExtension.Print(pageDocument, true, true);
See Also

Getting Started

Windows Forms Viewer


Samples and Walkthroughs

Samples and Walkthroughs
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs

To understand some of the more complex tasks you can accomplish using ActiveReports, you can open included sample projects, or you can follow walkthroughs, step-by-step tutorials that walk you through every step required to create a specific type of report.

This section contains information about

Samples
Browse brief descriptions of included samples, and follow links that open sample projects in Visual Studio.
Walkthroughs
Look through tutorials that teach you all of the steps involved in creating various types of ActiveReports projects, from the basic report through more complex unbound reports and Web options.
See Also
Walkthroughs


Samples

Samples
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples

Learn about the samples provided with the ActiveReports installation standard and professional editions. The samples folder is located at the following location:

[User Documents folder]\GrapeCity Samples\ActiveReports 10

Each sample has a C# and a Visual Basic.NET version for Visual Studio 2010 and 2012. You can also see the comments within the sample projects throughout code.

This section contains information about:

HTML5 Viewer Sample
This sample demonstrates the HTML 5 Viewer with its various options of loading Basic or Customized UI and Page, RDL and RDLX reports.
Page Reports And RDL Reports
This section provides information on each of the Page report and RDL report sample provided with the ActiveReports installation.
Professional
This section provides information on each of the sample provided with the ActiveReports professional edition installation.
Reports Gallery
This section provides information on Page, RDL and Section reports provided with the ActiveReports installation.
Section Reports
This section provides information on each of the Section report sample provided with the ActiveReports installation.
Standard Edition Web
Demonstrates exporting an ActiveReports report to the HTML or PDF format in your Web application.
WPF Viewer
Demonstrates the WPF Viewer and its options to view rdlx and rpx reports.
See Also

Walkthroughs

Samples and Walkthroughs


HTML5 Viewer Sample

HTML5 Viewer Sample
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > HTML5 Viewer Sample
Show All Show All
Hide All Hide All

The HTML5 Viewer sample demonstrates the use of HTML5 Viewer and its options to load different report types in basic or customized viewer.

Basic UI

Custom UI

Sample Location

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\HTML5 Viewer

Runtime Features

When you run the sample, the index.html containing the HTML5 Viewer appears on your browser with the following options to choose from:

  • Basic or Custom UI Viewer

The Basic UI Viewer appears by default with an option of switching to Custom UI Viewer by clicking the Custom UI option.

The Custom UI option loads the CustomUI.html in the browser. On the Custom UI Viewer page, you can click on any Genre category button to pass parameter to the MoviesReport.rdlx report and load the report in the viewer specific to the passed parameter value.

While working on the Custom UI Viewer, you can always switch back to the Basic UI Viewer by clicking the Basic option.

  • Choose Report: Page Report, RDL Report , RPX Report and Code-based Report

These options are a part of the Basic UI Viewer. Click on any of these buttons to load a report of specific format.

  • Choose UI Type: Desktop or Mobile

These options are a part of the Basic UI Viewer and are related to the Viewer report preview area. When you run this project, the HTML5 Viewer Desktop UI appears in the browser by default. You can switch to the HTML5 Viewer Mobile UI by clicking the Mobile button.

Project Details

Css folder

The Css folder contains the following css files that store styles for the HTML5 viewer application:

  • bootstrap.css
  • GrapeCity.ActiveReports.Viewer.Html.css
  • site.css
  • theme-cosmo.css

Fonts folder

The fonts folder contains the following font files to provide styles to the text that gets displayed in the HTML5 viewer at runtime:

  • glyphicons-halflings-regular.eot
  • glyphicons-halflings-regular.svg
  • glyphicons-halflings-regular.ttf
  • glyphicons-halflings-regular.woff

images folder

The images folder contain images for the buttons used in the Custom UI Viewer.

Reports folder

The reports folder contains the following reports:

  • BillingInvoice.rdlx: This page based report gets loaded in the viewer when you select the Page Report type in the Basic UI viewer. This report uses the NWind shared data source connection to provide data. This report showcases a billing invoice layout commonly used in convenience stores. The report mostly contains Label, TextBox and Line controls in its layout. The EAN128FNC1 barcode is used in this report due to its high reading accuracy in convenience stores.
  • Invoice.rpx: This section based report gets loaded in the viewer when you select the RPX report type in the Basic UI viewer. This report uses the NWind data source connection to provide data. This report uses TextBox controls to create the Invoice layout for displaying customer transactions. One of the TexBox uses the Sum function to display the GrandTotal of all transactions.
  • MoviesReport.rdlx: This page based report appears in the Custom UI viewer. This report uses the Reels database to provide data to showcase the list of movies based on different genres using the parameter set on the GenereName field.
  • OilProducingCountries.rdlx: This page based report gets loaded in the viewer when you select the RDL report type in the Basic UI viewer. This report uses the FactBook database to provide data to the Map control that visualizes the oil production for different parts of the world.
  • rpt2DBar: This code-based section report gets loaded in the viewer when you select the Code-based report type in the Basic UI viewer. This report displays bar chart and retrieves the data to be displayed in a chart from Orders table of NWind database.

Scripts folder

The scripts folder contains the following javascript files and its dependencies required to build this application:

  • bootstrap-3.0.0.js
  • GrapeCity.ActiveReports.Viewer.Html.js
  • jquery-1.10.2.js
  • knockout-2.3.0.js

ActiveReports.ReportService.asmx

ActiveReports.ReportService.asmx is an ASP.NET Webservices Source file that is required for creating and proper functioning of the HTML5 Viewer. You can add this service using the Add New Item in the Visual Studio Project menu and then selecting ActiveReports 10 Web Service.

customUI.html

The customUI.html hosts the Custom UI page on the browser. It contains html code for the appearance and functioning of the Custom Ul page.

index.html

The index.html is the main page that gets hosted on the browser when you run this sample. It contains html code for the appearance and functioning of the main page.
See Also

Getting Started

HTML5 Viewer
Using Javascript


Page Reports And RDL Reports

Page Reports And RDL Reports
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Page Reports And RDL Reports

Learn about the different Page and RDL Report RDL samples categorized under API

This section contains:

API
This section contains samples that showcase working with ActiveReports API to create a RDL report.
Data
This section contains samples that explain various ways of working with data sources.


API

API
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Page Reports And RDL Reports > API

Learn about the samples that fall under the API category.

This section contains:

CreateReport
This sample demonstrates how to create a page report layout in code. It further shows creating a table control, adding table rows and table columns inside it, adding cells inside the table rows and columns and adding text boxes inside the cells.
Custom Resource Locator
This Custom Resource Locator sample showcases a custom implementation of the resource locator to load pictures from the user's "My Pictures" directory.
Layer
This sample demonstrates how to use Layers in a report.
ReportWizard
This sample demonstrates how to create a custom Report Wizard that allows you to select a report from the list of multiple reports and then allows you to select the data that you want to display in the selected report.
StyleSheets
The Stylesheets sample demonstrates how to work with embedded and external style sheets in Page and RDL reports.


Create Report

Create Report
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Page Reports And RDL Reports > API > Create Report
Show All Show All
Hide All Hide All

The Create Report sample demonstrates how to create a RDL report using code and display it in the ActiveReports Designer.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Page Reports And RDL Reports\API\CreateReport\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Page Reports And RDL Reports\API\CreateReport\C#

Runtime Features

When you run this sample, the ActiveReports Designer appears with a RDL report that is bound to a database. To view the report, go to the Preview tab of the Designer.
Note: To run this sample, you must have access to the Reels.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

Project Details

ReportsForm

This is the main form of the sample that contains the Designer, ReportExplorer, PropertyGrid, Toolbox and ToolStrip controls, used to create the ActiveReports Designer at runtime. See Creating a Basic End User Report Designer (Pro Edition) for information on creating a basic ActiveReports Designer.

Right-click the form and select View Code to see how to set up the Designer and attach the ReportExplorer, PropertyGrid and Toolbox controls to it. It also contains code that loads a layout created in the LayoutBuilder class to a page report object; then loads the page report object to a stream, which is loaded to the Designer.

Constants

This file is an internal class that contains string values that are required for creating a dataset of the report.

LayoutBuilder

This file is an internal class that contains code for creating a RDL report layout and adding a data source and a dataset to it.


Custom Resource Locator

Custom Resource Locator
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Page Reports And RDL Reports > API > Custom Resource Locator
Show All Show All
Hide All Hide All

The Custom Resource Locator sample demonstrates a custom implementation of the resource locator to load pictures from the user's My Pictures directory. In general, you can use a resource locator in a report to find any resources that a report may require.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Page Reports And RDL Reports\API\CustomResourceLocator\C#

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Page Reports And RDL Reports\API\CustomResourceLocator\VB.NET

Runtime Features

When you run this sample, you see the MainForm with the list of images from the My Pictures directory. Select any image and click the Show Report button. A report with the selected image opens in the PreviewForm.
Caution: To run this sample properly, you must have image files in your My Pictures directory. If the directory does not contain any pictures, you should add them to the folder manually.

Project Details

Resources folder

This folder contains the Description.rtf file that contains a summarized content of the resource locator that gets displayed inside the RichTextBox control on the MainForm at runtime.

This folder also contains the NoImage.bmp image file that is used if there is no image in the My Pictures directory.

DemoReport.rdlx

The DemoReport.rdlx displays the selected image. This report contains two TextBox controls and one Image control, which display the image name, the image type and the image at runtime after you click the Show Report button on the MainForm.

MainForm

This is the main form of this sample that appears when you run the sample. This form contains the RichTextBox, the ListView and the Button controls.

The RichTextBox control displays the summarized information saved in the Description.rtf file about the resource locator and the sample.

The ListView control gets populated with the images located in the My Pictures directory; the Button control is used to generate the report with the selected image.

Right-click the form and select View Code to see how to load text in the RichTextBox control and images in the ListView control. It also contains code that displays the DemoReport.rdlx on the showReport_Click event.

MyPicturesLocator

This file is an internal class that contains code that looks for resources in the My Pictures directory.

PreviewForm

This form uses the ActiveReports Viewer control to display the DemoReport.rdlx with the selected image.

Right-click the form and select View Code to see how to load the report into the Viewer.

See Also
DataSet DataSource
Reports Gallery

Getting Started

Windows Forms Viewer


Layer

Layer
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Page Reports And RDL Reports > API > Layer
Show All Show All
Hide All Hide All

The Layer sample demonstrates how to work with Layers in four different reporting scenarios.

  • Sample Location
  • Runtime Features
  • Project Details

Sample Location

Visual Basic.NET
Copy Code
<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Page Reports And RDL Reports\API\Layer\VB.NET
C#
Copy Code
<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Page Reports And RDL Reports\API\Layer\C#

Runtime Features

When you run this sample, the End User Designer shows a list of .rdlx reports on the bottom left of the form. Expand the Reports node to view reports under it and double-click a report to load it into the designer. Once the report is loaded in the designer, a Layers List window showing all the Layers used in the report is displayed as a tab next to the Report Explorer tab. See Working with Layers for further details on the Layers List window.

Project Details

ReportForm

This is the main form that appears when you run the Layers sample. This form uses controls such as Designer, ReportExplorer, LayerList, Toolbox, PropertyGrid, ToolStripPanel, ToolStripContentPanel and TreeView to create a customized report designer.

Right-click the form and select View Code to see how to set up the report designer. It also contains code that adds reports to the TreeView control, loads a report into the Designer when it is double-clicked in the Reports node, and shows the Layer List window if the report type is Page or RDL.

Reports Folder

AccountStatementSheet.rdlx: This report uses the XML data source connection to provide custom data. Controls such as Image, FormattedTextBox, Table and Label are used to display the statement of an account holder. The FormattedTextBox control contains text in HTML tags to display the content.

This report is contains three Layers besides the Default Layer with the following controls and TargetDevice settings.

Layer Name | Target Device | Description
Default | All | This is a default layer. It does not contain any control.
Layer1 | Screen | Contains the Header and Footer section.
Layer2 | Screen, Paper | Contains a FormattedTextBox control to display the account information of the account holder.
Layer3 | All | Contains a Table data region and an OverflowPlaceHolder control to display the account transactions.

SalesRevenueReport.rdlx: This report uses the Reels shared data source connection to provide the data. The layout of the report uses a Chart data region to graphically display sales and profit for each month and two Table data regions to display the chart data. The first Table data region (Layer2) contains the sales revenue for each month and the second Table data region (Layer3) lists down the detailed figures for the monthly sales along with a DataBar to visually depict the profits.

This report contains three Layers besides the Default Layer with the following controls and TargetDevice settings.

Layer Name | Target Device | Description
Default | All | This is a default layer. It does not contain any control.
Layer1 | All | Contains a Chart data region to display the annual sales by month.
Layer2 | Paper | Contains a Table data region to display the sales by month. Visibility of this Layer has been set to hidden.
Layer3 | Screen, Export | Contains a Table data region to display the detailed sales and a DataBar to depict the profits.

SchoolStudentReportCard.rdlx: This report uses the XML data source connection to provide custom data. This report includes an Image control that acts as a background layout of the report. It also includes a few TextBox controls to display the name and the grades obtained by the student.

This report contains two Layers besides the Default Layer with the following controls and TargetDevice settings.

Layer Name | Target Device | Description
Default | All | This is a default layer. It does not contain any control.
Layer1 | Screen, Export | Contains an Image control with an image of a school graduation certificate.
Layer2 | All | Contains few TextBox controls to display the name and grades obtained by the student.

UserConferenceLabels.rdlx: This report uses the Nwind shared data source connection to provide data. This report uses the Image, TextBox, BarCode and Label controls to create a layout for the User Conference 2014 ticket.

This report contains two Layers besides the Default Layer with the following controls and TargetDevice settings.

Layer Name | Target Device | Description
default | All | This is a default layer. It does not contain any control.
Layer1 | Screen, Export | Contains Image controls to display the conference logo and sponsors and Label controls to display conference name and details.
Layer2 | All | Contains bound TextBox fields to display the conference attendee details and a BarCode control to display a unique BarCode for each attendee.
See Also

Concepts

Layers
Working with Layers
View, Export or Print Layers

Walkthroughs

Tracing Layers


Report Wizard

Report Wizard
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Page Reports And RDL Reports > API > Report Wizard
Show All Show All
Hide All Hide All

The Report Wizard sample demonstrates how to create and customize a report, using the report wizard.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Page Reports And RDL Reports\API\ReportWizard\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Page Reports And RDL Reports\API\ReportWizard\C#

Runtime Features

When you run this sample, the form with the Report Wizard appears. On the Select Report Type page, select the report type you want to analyze and click the Next button.

On the next Choose grouping options page of the wizard that appears, you are asked to choose a field for grouping the report data and click the Next button. You can also enable the checkbox at the bottom of the page if you like to include the last detail of the report as separate group. If you leave it unchecked, the checkbox automatically adds the last detail to a previous group.

On the next Select output fields page of the wizard that appears, you are asked to choose the fields you want to display in your report and click the Next button.

On the next Summarization and Review page, you can review the settings you have selected previously. You can also set the summary options if you want to display a grand total or a sub-total in the report.

Finally, when you click the Finish button, the GrapeCity Unified ReportDesigner appears and displays the report.

Project Details

MetaData folder

This folder contains two internal classes, FieldMetaData and ReportMetaData. The FieldMetaData class contains information on the fields used in the report string values. This file provides this information when required by the application.

Similarly, the ReportMetaData class contains information on the reports used in this sample. This file provides this information when required by the application.

Resources folder

This folder contains images and icons used by the the Report Wizard API.

UI folder

WizardSteps

This folder contains templates of the Report Wizard pages, which get displayed inside the Panel control on the WizardForm at runtime.

DesignerForm

This form appears when you click the Finish button on the last page of the Report Wizard. This form uses the ToolStripPanel, ToolStripContentPanel, Designer, Toolbox, ReportExplorer and a PropertyGrid controls to create the Unified ReportDesigner.

Right-click the form and select View Code to see how to set the designer and create a blank page report. It also contains code that attaches the Toolbox, ReportExplorer and PropertyGrid controls to the Designer, inserts DropDown items to the ToolStripDropDownItem, sets their functions, and checks for any modifications that have been made to the report in the designer.

DragDropListBox

This file contains code to override methods that enable and handle the drag-and-drop feature in the ListBox, which appears on the wizard page where you select the grouping and the output fields. Thus, instead of selecting a field and clicking the Add button in the ListBox control, you can directly drag fields as well.

TipControl

This file contains the design of the Tip that appears on the first page of the report wizard.

WizardDialog

This is the main form that appears when you run the sample. It uses the PictureBox, two Labels, Panel and two Button controls to create the Report Wizard. The PictureBox displays the logo while the two Label controls display the Page Title and Page Description respectively. The Panel control loads the design of different pages of the Report Wizard. The two Button controls handle the last page and next page functions.

Right-click the form and select View Code to see how to define functions of different controls used on the form.

Constants

This is an internal class that contains fields in string values that are summarizable.

GenreSales.rdlx-master

This is the master report for the Genre Sales report. It uses the Image, two Textbox and ContentPlaceholder controls to design the report. The Image control displays the logo on the top of the report while the two Textbox controls display the report execution time and page number information respectively. The ContentPlaceholder control displays its content report.

LayoutBuilder

This is the internal class file that contains code for creating the layout of both child reports and loading data in it.

Reports.xml

This XML file is used as a database to provide data for the reports in this sample.

ReportWizardState

This is the internal class file that contains code for handling the UI of the Report Wizard.

StoreSales.rdlx-master

This is the master report for the Store Sales report. It uses the Image, two Textbox and ContentPlaceholder controls to design the report. The Image control displays the logo on the top of the report while the two Textbox controls display the report execution time and page number information respectively. The ContentPlaceholder control displays its content report.
See Also

Concepts

Master Reports (RDL)

How To

Create and Use a Master Report (RDL Report)


Stylesheets

Stylesheets
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Page Reports And RDL Reports > API > Stylesheets

The Stylesheets sample demonstrates how to work with embedded and external style sheets in Page and RDL reports.

  • Sample Location
  • Runtime Features
  • Project Details

Sample Location

Visual Basic.NET
Copy Code
<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Page Reports And RDL Reports\API\Stylesheets\VB.NET
C#
Copy Code
<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Page Reports And RDL Reports\API\Stylesheets\C#

Runtime Features

When you run this sample, the main StyleSheetsForm interface displaying the following options appears:

  1. Choose Report: Select the type of report you want to display in the Viewer.
  2. Choose Style: Select a style sheet; embedded or external to apply to the report.

Click on Run Report button to load the report with the selected options in the Viewer. See Working with Styles for more information about style sheets.

Project Details

StyleSheetsForm

This is the main form of the sample that displays reports in the ActiveReports Viewer control in the bottom section of the form, and options such as Choose report,Choose style and Run report button at the top of the form.

Delivery Slip.rdlx: This is a Page report, that contains TextBox, Label, Container controls and two Table data regions to display the invoice information. The report uses Theme1.rdlx-theme file and BaseStyle as an embedded style sheet. Some TextBox controls on the report also use the Sum function to display the total price information for each invoice. This report uses the Seikyu2 shared data source.

ReorderList.rdlx: This is an RDL report, that contains Table data region to display data from Reels shared data source. The Reels logo in the report is embedded within the Reels.rdlx-theme.

External Stylesheet: Following external style sheets are provided in this folder:

External Stylesheet Location - <User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Page Reports And RDL Reports\API\Stylesheets\Reports

  • BaseStyle.rdlx-styles
  • FaxSheetStyle.rdlx-styles
  • HighContrastStyle.rdlx-styles
  • ModernStyle.rdlx-styles


Data

Data
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Page Reports And RDL Reports > Data

Learn about the samples that fall under the Data category.

This section contains:

DataSet DataSource
This sample demonstrates how to use a dataset as a data source for a report.
OleDbDataSource
This sample demonstrates how to connect to an OleDb data source at runtime and pass data to the report using LocateDataSource event.
PageUnboundData
The PageUnboundData sample demonstrates how to connect a page report to an unbound data source at runtime, using the DataSet provider with the LocateDataSource event.
XMLDataSource
This sample demonstrates how to connect to a XML data source at runtime and pass data to the report using LocateDataSource event.


OleDb DataSource

OleDb DataSource
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Page Reports And RDL Reports > Data > OleDb DataSource
Show All Show All
Hide All Hide All

The OleDB Data Source sample demonstrates how to use the OleDb data provider for binding a report to data.

Sample Location

Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 10\Page Reports And RDL Reports\Data\OleDbDataSource\VB.NET

C#

<User Folder>\GrapeCity Samples\ActiveReports 10\Page Reports And RDL Reports\Data\OleDbDataSource\C#

Runtime Features

When you run this sample, the MainForm with the ActiveReports Viewer appears. The Viewer displays the report with the list of movies, their ratings and the release year information.
Note: To run this sample, you must have access to the Reels.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

Project Details

DataLayer

This file is an internal class that contains code to create a data connection. It creates the OleDb data reader to read data from the Reels database and add it to an array to provide data for the report.

MainForm

This is the main form that appears when you run this sample. It uses the ActiveReports Viewer control to display the report at runtime.

Right-click the form and select View Code to see how to load and show the report at runtime.

OleDBReport.rdlx

This is the report that gets displayed in the Viewer at runtime.

The report uses the header with the Textbox to display the report heading and the footer with the Textbox to display the page number information. The body of the report has the Table data region to display data obtained from the OleDb data provider. For that, the Textbox controls of the Table are bound to the OleDB data source in the Value property.

See Also

Walkthroughs

Single Layout Reports

How To

Bind a Page Report to a Data Source at Run Time


Object Data Source

Object Data Source
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Page Reports And RDL Reports > Data > Object Data Source

The Object Data Source sample demonstrates how to use Object provider for binding a report that contains a subreport.

  • Sample Location
  • Runtime Features
  • Project Details

Sample Location

Visual Basic.NET
Copy Code
<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Page Reports And RDL Reports\Data\ObjectDataSource\VB.NET
C#
Copy Code
<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Page Reports And RDL Reports\Data\ObjectDataSource\C#

Runtime Features

When you run this sample, the MainForm with the ActiveReports Viewer appears. The viewer displays the report where YearReleased column is a part of the main report (ObjectsReport.rdlx) whereas other columns such as ID, Title and MPAA are part of the subreport (SubObjectsReport.rdlx).

Project Details

DataLayer

This file is an internal class that contains code to provide data for the report.

MainForm

This is the main form that appears when you run this sample. It uses the ActiveReports Viewer control to display the report at runtime.

Right-click the form and select View Code to see how to load and show the report at runtime.

ObjectsReport.rdlx

This is the report that gets displayed in the Viewer at runtime.

The report uses the header with the Textbox to display the report heading and the footer with a Textbox to display the page number information. The body of the report has the Table data region to display data where only first column is obtained from the Objects data provider. For that, the Textbox controls of the Table are bound to the Objects data source in the Value property. For rest three columns, subreport control is used.

SubObjectsReport.rdlx

This is the subreport that is placed on Table data region of the main report.

The report has a Table data region to display data obtained from the Objects data provider. Here also, the Textbox controls of the Table are bound to the Objects data source in the Value property.


DataSet DataSource

DataSet DataSource
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Page Reports And RDL Reports > Data > DataSet DataSource
Show All Show All
Hide All Hide All

The PageUnboundData sample demonstrates how to connect a page report to an unbound data source at runtime, using the DataSet provider with the LocateDataSource event. The reporting engine raises the LocateDataSource event when it needs input on the data to use.

Sample Location

Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 10\Page Reports And RDL Reports\Data\PageUnboundData\VB.NET

C#

<User Folder>\GrapeCity Samples\ActiveReports 10\Page Reports And RDL Reports\Data\PageUnboundData\C#

Runtime Features

When you run this sample, the Invoice2.rdlx report is displayed in the Viewer control. The report displays the Invoice form with the list of products along with the product ID, quantity and price of the products.

The report connects to an unbound data source at runtime using the LocateDataSource event and the DataSet provider.

Project Details

Invoice2.rdlx

In the Report Data Source dialog, the type of the report data source is set to DataSetProvider and the ConnectionString is left blank. In the DataSet dialog, data fields used on the report are added to the DataSet on the Fields page.

This report uses the Table, TextBox, Label and Shape controls to create an Invoice layout for displaying the customer transactions. The Container control at the bottom of the report contains a label, a textbox and line control. The textbox uses the Sum function to display the sum of the values returned by the expression indicated in the Value property.

ViewerForm

This is the main form that appears when you run this sample. It uses the ActiveReports Viewer control to display the report at runtime. The code-behind the form contains the code with the LocateDataSource event that connects the Invoice2.rdlx report to unbound data and the code that populates fields for the data table.

See Also

Sample ReadMe Files

Custom Resource Locator
Reports Gallery


Xml Data Source

Xml Data Source
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Page Reports And RDL Reports > Data > Xml Data Source
Show All Show All
Hide All Hide All

The XML Data Source sample demonstrates how to use the XML data provider for supplying data to the report.

Sample Location

Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 10\Page Reports And RDL Reports\Data\XmlDataSource\VB.NET

C#

<User Folder>\GrapeCity Samples\ActiveReports 10\Page Reports And RDL Reports\Data\XmlDataDataSource\C#

Runtime Features

When you run this sample, you will see the MainForm appear. The MainForm contains the ActiveReports Viewer that displays a report with data from the xml data provider.

Project Details

BandedListXML.rdlx

This is the main report that gets displayed in the Viewer at runtime. It uses the BandedList and Textbox controls, and the Subreport control inside the BandedList data region to display data.

The BandedList data region uses two groups to group the report data by the fields City and Country.

The Subreport control, placed in the GroupFooter section of the BandedList, displays the CountrySales report.

CountrySales.rdlx

This is the report that gets displayed by the Subreport control of the BandedListXML report.

It uses the Chart data region to display data. The Chart Type property is set to Doughnut (Pie Exploded Doughnut), which shows the analysis of companies sales amount for different countries.

See Also

Concepts

Grouping Data (Page Layout)
Subreport(RDL)
Chart


Professional

Professional
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Professional

This section provides information on each of the sample provided with the ActiveReports professional edition installation.

This section contains:

Active Reports Web Pro
The Active Reports Web Pro Sample demonstrates the use of Professional Edition ASP.NET features, such as HTTP handlers, Flash Viewer options, parameterized reports and more.
ActiveReports with MVC
The ActiveReports with MVC Sample demonstrates an MVC web application using the ActiveReports Web Viewer with the options of loading section and page report layouts.
ActiveReports with MVC5 and HTML5Viewer
The ActiveReports with MVC Sample demonstrates an MVC web application using the HTML5 Viewer with the options of loading section and page report layouts.
Custom Data Provider Sample
This sample demonstrates how to create a project using custom data provider and how to pull data from a comma separated value (CSV) file.
Custom Tile Provider Sample
This sample demonstrates how to create a custom tile provider.
Digital Signature
This sample demonstrates how you can digitally sign or set time stamp for a section report when exporting it to PDF format.
End User Designer
Demonstrates a custom end-user report designer that can be integrated in your applications to allow users to modify report layouts.
Map
The Map sample demonstrates how to work with Map control in ActiveReports.
Silverlight Viewer
This sample demonstrates the Silverlight Viewer with its various options of loading RPX, RDLX and RDF reports.
Table of Contents
The TableofContents sample demonstrates how to use TableofContents control in ActiveReports.
See Also
Section Report Samples


Active Reports Web Pro

Active Reports Web Pro
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Professional > Active Reports Web Pro
Show All Show All
Hide All Hide All

The Active Reports Web Pro Sample describes the standard ActiveReports web features as well as other features available in the Professional Edition only, such as HTTP handlers, Flash Viewer options, parameterized reports and more.
Note: Before running this sample, in the Solution Explorer, click the Licenses.licx file and then, from the Build menu, select Build Runtime License. Please see To license Web Forms projects made on the trial version for details.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Professional\ActiveReportsWebPro\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Professional\ActiveReportsWebPro\C#

Runtime Features

When you run the sample, the Default.aspx page appears in your browser. This page provides links to other sample pages that demonstrate the following web features.

WebControl for ASP.NET

This link opens the WebControl.aspx page that allows you to select any of the four Viewer Types and it also allows you to select from Section, Page and RDL Report Type.

The four Viewer Types that are available are as follows:
  • HtmlViewer
  • FlashViewer
  • PDF Reader
  • RawHtml

Flash Viewer Control

This link opens the FlashViewerIntro.aspx page where you can adjust settings, select a report and then click the "View Report" button to be redirected to a WebForm with the Flash Viewer.

HTTPHandlers

This link opens the HttpHandlers.aspx page with the http handler examples.

Custom Exporting PDF Example

This link opens the Invoice report in the PDF Reader by exporting it to memory stream and then outputting it in the browser.

Custom Exporting HTML Example

This link opens the NWindLabels report. This report is outputted to the ReportOutput folder by using the MyCustomHtmlOutputter class and the exported HTML is displayed in the browser.

Parameterized Report Example

This link opens the page that demonstrates how to generate a report by passing a parameter to the report.

Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

Project Details

CodeReports

The CodeReports folder contains the following reports - Invoice, InvoiceFiltered, NwindLabels and NwindLabelsFiltered.

The code reports are used to demonstrate how the ActiveReports Compiled Report HttpHandler functions. For more details, see HttpHandlers.aspx below.

images

The images folder contains the logo.png. This image file is used in the header of the FlashViewerIntro.aspx page.

PageReports

The PageReprorts folder contains the Invoice_Grouped and PurchaseReport report.

RDLReports

The RdlxReports folder contains the SalesReceipt report.

RPXReports

The RpxReports folder contains the following reports - Invoice, InvoiceFiltered, NwindLabels, NwindLabelsFiltered and Params.

The Invoice.rpx report is used to demonstrate the Web Viewer control options and is opened by clicking WebControl for ASP.NET on the Default.aspx page. This report is also opened by clicking the Custom Exporting PDF Example option on the Default.aspx page. For detailed information on the Invoice report, see the Cross Section Control Sample.

The NwindLabels report is opened by clicking the Custom Exporting HTML Example option on the Default.aspx page.

The Params report is used by the ParameterReport.aspx page to demonstrate how to generate a report by passing a parameter to the report.

All reports from this folder are used to demonstrate the Flash Viewer options. You can select one of these reports from the list on the FlashViewer.aspx page.

Themes

The Themes folder contains themes to use on the Flash Viewer. Following themes can be used for the Flash Viewer.

  • FluorescentBlue.swf
  • Office.swf
  • OliveGreen.swf
  • Orange.swf
  • VistaAero.swf
  • WindowsClassic.swf
  • XP.swf

ActiveReports.ReportService.asmx

The report web service is required for proper functioning of the Web Viewer. The ActiveReports.ReportService.asmx is added automatically to the project when you place the WebViewer control on the form. You can also add this service by using Add New Item in the Visual Studio 2010 Project menu.

For the information on how to use the WebViewer control, see Getting Started with the Web Viewer.

CustomExportHtml.aspx

This Web form is displayed by clicking the Custom Exporting HTML Example option on the Default.aspx page.

In CustomExportHtml.aspx, the NWindLabels report is outputted to the ReportOutput folder using the CustomHtmlOutput class and the exported HTML is displayed in the browser.

Note: This sample requires write permissions to the ReportOutput folder that is located in the web samples directory.

CustomExportPdf.aspx

This Web form is displayed by clicking the Custom Exporting PDF Example option on the Default.aspx page. In CustomExportPdf.aspx, the Invoice report is exported to memory stream and then outputted in the browser.

Note: This sample requires write permissions to the ReportOutput folder that is located in the web samples directory.

CustomHtmlOutput class

This class is used for exporting a report to the HTML format. The CustomHtmlOutput class implements the required IOutputHtml in the HTML export and saves the output results to a file with a unique name.

Default.aspx

This is the main Web form of the sample that shows the introductory text and links to the following sample pages.

  • WebControl for ASP.NET (WebControl.aspx)
  • FlashViewer Control (FlashViewerIntro.aspx)
  • HTTPHandlers (HttpHandlers.aspx)
  • Custom Exporting PDF Example (Invoice report)
  • Custom Exporting HTML Example (NWindLabels report)
  • Parameterized Report Example(ParameterReport.aspx)

FlashViewer.aspx

This is a web form with the Web Viewer that is displayed after you click the View Report button on the ActiveReports 10 Flash WebViewer Sample.

In the Properties window, notice that the ViewerType property is set to FlashViewer, and the Height and Width properties are set to 100%. (This ensures that the viewer resizes to fill the browser window.)

For information on the Flash Viewer, see Using the Flash Viewer.

FlashViewerIntro.aspx

This web form displays the introductory text for the ActiveReports 10 Flash WebViewer Sample. On this page, you can adjust the Flash Viewer settings, select a language, a theme and a report for the Flash Viewer from the drop-down lists. The report is opened in the Flash Viewer by clicking the View Report button that you see on this page.
This sample uses the reports from the RPXReports folder of the Sample project.
Right-click the file and select View Code to see the code used to populate the Themes drop-down list and to redirect to the FlashViewer form.

Grapecity.ActiveReports.Flash.v10.Resources.swf

This file is used for localization and is necessary only if you want to use a language resource that is different from the default one. The default locale is U.S. English (en_US).

This file is located in the ...\GrapeCity\ActiveReports 10\Deployment\Flash folder.

Grapecity.ActiveReports.Flash.v8.swf

This file is required for using the Flash Viewer and is located in the ...\GrapeCity\ActiveReports 10\Deployment\Flash folder.

HttpHandlers.aspx

ActiveReports provides HttpHandler components that allow ASP.NET to automatically process reports that have been placed into an ASP.NET web site folder. ActiveReports' HttpHandler components enable easily deployable reports in both HTML and PDF file formats. ActiveReports includes a simple configuration utility to properly register the HttpHandler components with IIS and ASP.NET.

The RPX and RDLX HttpHandler processes and outputs reports from ActiveReports layout files (ending in the .rpx/.rdlx extension). When the ASP.NET receives a request for an ActiveReport file ending with the .rpx/.rdlx extension, the RPX/RDLX HttpHandler will run, and return the report's output in a format of your choice.

The compiled Report HttpHandler enables easy distribution of ActiveReports that use compiled .NET source code. Compiled reports are exposed as a .NET class in a .NET assembly file. When ASP.NET receives a request for a file with the .ActiveReport extension, the Compiled Report handler will load the ActiveReports from the assembly, run it, and return the output in a format of your choice.

For information on configuring the http handlers, see Configure HttpHandlers in IIS 6.x and Configure HttpHandlers in IIS 7 and IIS 8. The required mapping for each feature has been listed below.

WebViewer control | ActiveReports 10 Cache Item Script Mapping is required
Compiled Report Handler (the report explorer is embedded in the assembly after compiling the report ) | ActiveReport Script Mapping is required
RPX HTTP Handler (when the *.rpx report is placed on the Web) | ActiveReports 10 RPX Script Mapping is required
RDLX HTTP Handler (when the *.rdlx report is placed on the Web) | ActiveReports 10 RDLX Script Mapping is required

ParameterReport.aspx

The web form that demonstrates how to generate a report by passing a parameter to the report. This sample uses the Params report from the RpxReports folder of this Sample project.
The date list is created by changing the SQL query of the report at runtime. In this sample, when the date is selected from the Calendar control, the SQL query is updated and the report is generated. The report is generated dynamically in the SelectedIndexChanged event of the Calendar control.
On this form, you can select the Viewer to display the report - HTML, Flash, AcrobatReader, or RawHTML.
Note: This sample requires write permissions to the ReportOutput folder that is located in the web samples directory.

Web.config

The configuration file that contains the httpHandlers that allow ActiveReports to process reports on the Web.

Note that you need to manually update version information here when you update your version of ActiveReports.

WebControl.aspx

This page is opened by clicking WebControl for ASP.NET on the Default.aspx page. By default it displays the Web Viewer control with the Invoice report.
In this page, you can select from HTMLViewer, FlashViewer, AcrobatReader, RawHtml viewer types and can also select from Page, Section and RDL report types to be displayed.
See Also
Standard Edition Web Sample

Concepts

Report Types
Parameters

Getting Started

Web Viewer (ASP.NET)


ActiveReports with MVC

ActiveReports with MVC
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Professional > ActiveReports with MVC
Show All Show All
Hide All Hide All

The ActiveReports10 with MVC sample demonstrates an MVC web application with the ActiveReports Web Viewer. This Sample is part of the ActiveReports Professional Edition.

Note: Before running this sample, you must first install the ASP.NET MVC 3 framework on your machine.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Professional\ActiveReportsWithMVC\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Professional\ActiveReportsWithMVC\C#

Runtime Features

When you run the project, the page with the Customer Index view appears. On this page, you can click a customer in the list to open a new page with the Customer Details information. At the bottom of the page, there are two links - Freight Summary (section report) and Order Summary (page report). Clicking the Freight Summary (section report) link opens a page with the OrderReport report. Clicking the Order Summary (page report) link opens a page with the OrderDetailsReport.rdlx report.

Project Details

Controllers

This folder contains the HomeController that handles the user interaction and returns the main Index view, the CustomerDetails view and the views with Freight Summary (section report) and Order Summary (page report).

DBContext

This folder contains the NWindData class that gets the Customer, Orders, Order Details tables of the NWIND.mdb and populates the data into the components of this sample project.

Models

This folder contains the following classes.

Customer - a container for the rows in the Customers table of NWind.mdb.

Order - a container for the rows in the Orders table of NWind.mdb.

OrderDetails - a container for the rows in the Order Details table of NWind.mdb.

ReportDescriptor - the class representation of the ReportType (section or page layout) and the CustomerID.

Repository - a container for data required by the application.

Reports

OrderDetailsReport.rdlx: This report uses the object provider to connect to data at runtime. It uses the Table data region to display order details and the Plain Line chart to display sales by order id. The Table data is grouped by OrderID. Some TextBox controls of the Table use the Sum function to display the total price information for each order.

This is the report that opens in a separate view when you click the Order Summary (page report) link on the Customer Details page.

OrderReport: This report binds to data at runtime. The report uses the Textbox and Label controls to display the order details and the Bar chart to display the freight amounts by ship date.

This is the report that opens in a separate view when you click the Freight Summary (section report) link on the Customer Details page.

Views

Home folder

This folder contains the following views.

_Layout.cshtml. The default layout file.

_ViewStart.cshtml. The default view start file.

Details.cshtml. The Customer Details view file.

Index.cshtml. The Index view file.

StartPage.cshtml. The template for the Index view.

Viewer.cshtml. The template for the section report and page report views.

WebViewer.ascx. The form that contains the ActiveReports WebViewer control.

Web.config

The configuration file that contains the httpHandlers that allow ActiveReports to process view pages on the Web.

ActiveReports.ReportService.asmx

The report web service required for the proper functioning of the Web Viewer. The ActiveReports.ReportService.asmx is added automatically to the project when you place the Viewer control on the form. You can also can add this service by using Add New Item in the Visual Studio 2010 Project menu.

Global.asax

The default class that sets global URL routing values for this web application.

Web.config

The configuration file that contains the httpHandlers that allow ActiveReports to process this web application.

Note that you need to manually update version information here when you update your version of ActiveReports.

See Also

Getting Started

Web Viewer (ASP.NET)


ActiveReports with MVC5 and HTML5Viewer

ActiveReports with MVC5 and HTML5Viewer
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Professional > ActiveReports with MVC5 and HTML5Viewer
Show All Show All
Hide All Hide All

This sample demonstrates how to use ActiveReports HTML5 Viewer in ASP.NET MVC5 framework. This Sample is part of the ActiveReports Professional Edition.

Note: Before running this sample, you must first install the ASP.NET MVC5 framework on your system.

Sample Location

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Professional\ActiveReportsWithMVC5WebAPI\C#

Runtime Features

When you run the sample, the page with the main view appears. On the left side of the main view, you can click a customer name under the Customer List. On the right side of the main view, you have the Customer Info tab and the Reports tab. Following options are available on this page.

  • Customer List

    Displays a list of customer names. You can use the search box on the top to search for customer names.

  • Customer Info tab

    Displays details of the customer name selected from the customer list.

  • Reports tab

    Displays a report for the selected customer in the HTML5 Viewer. You can choose from the following options.

    • Choose Report: You can choose from Orders report (Page Report) or Product Details (Section Report). The selected report is displayed in the HTML5 Viewer.
    • Choose UI type: You can choose from Desktop or Mobile options. The default mode is set to Desktop. On selecting the Mobile UI type, the layout adapts itself to the mobile device display.

Project Details

App_Start folder

This folder contains the following cs files that are required to run the application.

  • BundleConfig.cs

  • FilterConfig.cs

  • RouteConfig.cs

  • Startup.Auth.cs

  • WebApiConfig.cs

Content folder

Image folder

This folder contains the images used for the viewer buttons.

Also contains .css files which define the style of the application.

  • bootstrap.css
  • bootstrap.min.css
  • SideBar.css
  • Site.css

Controllers

This folder contains the HomeController and CustomersController files. The HomeController handles the user interaction and returns the main view. The CustomersController handles the customer details information that is displayed when a customer is selected.

css folder

The css folder contains the following css files that store styles for the HTML5 viewer application.
  • GrapeCity.ActiveReports.Viewer.Html.css
  • theme-cosmo.css

Fonts folder

The fonts folder contains the following font files to provide styles to the text that gets displayed in the HTML5 viewer at runtime.
  • glyphicons-halflings-regular.eot
  • glyphicons-halflings-regular.svg
  • glyphicons-halflings-regular.ttf
  • glyphicons-halflings-regular.woff

Models

This folder contains the following classes.

Customer - Contains information for the rows in the Customers table of Reels.mdb.

CustomerContext - Contains information for the rows in the CustomerOrders table of Reels.mdb.

Reports

OrderDetailsReport.rdlx: This page report loads in the HTML5 Viewer when you select the Orders report for the Desktop UI type. This report uses the Table data region to display the order details. The Sum function is used to display the totals.

ProductDetail.rpx: This section report loads in the HTML5 Viewer when you select Product Details for the Desktop UI type. This report uses the Textbox and Label controls to display the data. The Sum function is used to display the total price information for each customer order.

Scripts folder

The Scripts folder contains the following javascript files and its dependencies required to build this application.
  • bootstrap-3.0.0.js
  • GrapeCity.ActiveReports.Viewer.Html.js
  • jquery-1.10.2.js
  • knockout-2.3.0.js

Views folder

Home folder

The default view start file.

Index.cshtml: The Index view file.

Shared folder

_Layout.cshtml: The default layout file.

ViewStart.cshtml

The default view start file.

Web.config

This file contains settings for the HTTP handler.

ActiveReports.ReportService.asmx

This is the report web service required for the proper functioning of the WebViewer control. The ActiveReports.ReportService.asmx is added automatically to the project when you place the Viewer control on the form. You can also can add this service by using Add New Item in the Visual Studio Project menu.

Global.asax

The is the default class that sets global URL routing values for this web application.

Startup.cs

This is the default startup file.

Web.config

The configuration file that contains the httpHandlers that allow ActiveReports to process this web application.

Note that you need to manually update version information here when you update your version of ActiveReports.


CustomDataProvider

CustomDataProvider
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Professional > CustomDataProvider
Show All Show All
Hide All Hide All

The Custom Data Provider sample demonstrates how to create a project that use a custom data provider and how to pull data from a comma separated value (CSV) file. This sample is part of the ActiveReports Professional Edition.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Professional\CustomDataProvider\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Professional\CustomDataProvider\C#

Runtime Features

When you run this sample, a DesignerForm displaying the DemoReport.rdlx report in ActiveReports Designer and a HelperForm explaining the steps to connect a report to the comma separated value (CSV) file appears.

In the ActiveReports Designer, you can add a dataset with a comma separated values (CSV) file. For adding this file,in the Report Explorer, expand the DataSources node, right-click the node for the data source and select Add DataSet. In the DataSet dialog that appears, under Query section, go to the Query String field and click the drop-down arrow to display the custom query editor. In the custom query editor, click the Select CSV File button and select the Categories.csv file kept within the project.

Go to the Preview tab of the Designer to view the report with the data pulled from the custom data provider.

Project Details

CustomDataProvider folder

CSVDataProvider folder

This folder contains the following classes.

  • CsvColumn - this class represents information about fields in the data source.
  • CsvCommand - this class provides the IDbCommand implementation for the .NET Framework CSV Data Provider.
  • CsvConnection - this class provides an implementation of IDbConnection for the .NET Framework CSV Data Provider.
  • CsvDataProviderFactory - this class implements the DataProviderFactory for .NET Framework CSV Data Provider.
  • CsvDataReader - this class provides an implementation of IDataReader for the .NET Framework CSV Data Provider.

CustomDataProviderUI folder

CSVFileSelector

This is the form that contains the Select CSV File button. This button is displayed in the CVS data provider query editor when you open the DataSet dialog and under Query, in the Query String field and click the drop-down arrow to display the custom query editor.

Clicking the Select CSV File button allows you to select the Categories.csv file that is used as a custom data provider for the sample report.

QueryEditor

This is the class that reads the content of the specified file and builds the CSV data provider query string.

CustomDataProviderUITest folder

Categories.csv

This is the comma separated values (CSV) file that serves as a custom data provider for the sample report.

This file is selected in the Please, select CSV File dialog that appears when you click the Select CSV File button in the Query String field under Query in the DataSet dialog.

DemoReport.rdlx

The DemoReport.rdlx displays the custom data. This report contains one Table data region with the TextBox controls, which display the name, the role and the city information of an employee.

DesignerForm

This is the main form of this sample that appears when you run the sample. On this form, you can connect the sample report to a custom data provider by adding a dataset with a comma separated values (CSV) file.

Right-click the form and select View Code to see the code implementation for the ActiveReports Designer.

GrapeCity.ActiveReports.config

The configuration file that configures the project to use the custom data provider.

HelperForm

This form appears on top of the main DesignerForm when you run the sample. This form contains the explanatory text with the steps on how to bind the sample report to the comma separated value (CSV) file. You can close the Help form by clicking the X button in the upper-right corner of the form.

See Also

Walkthroughs

Custom Data Provider

Concepts

ActiveReports Designer

How To

Add a Dataset


Custom Tile Provider

Custom Tile Provider
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Professional > Custom Tile Provider
Show All Show All
Hide All Hide All

The CustomTileProvider sample demonstrates how to create a custom tile provider using IMapTileProvider and IMapTile interface and configure it in a Map Control which is placed on a RDL report. This sample makes use of two projects - CustomTileProviders and TileProviderEndUserDesigner in a single Visual Studio solution. The CustomTileProviders project contains the tile server configurations for the tile providers, whereas the TileProviderEndUserDesigner project references the created CustomTileProviders project assemblies.

Note: CustomTileProvider is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Professional\CustomTileProvider\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Professional\CustomTileProvider\C#

Runtime Features

When you run this sample, the ActiveReports End User Designer appears with an overlaying Help-Creating a Custom Tile Provider dialog. This dialog gives you step-by-step instructions to create a new tile provider for a Map control with custom settings.
The End User Designer displays a RDL report containing a Map control with MapQuest set as the default tile provider. To change the existing tile provider, double-click on the Map control to display the existing tile layer and right click to select Edit. In the Map Tile Properties - General dialog that appears, click the Provider drop-down to select the tile provider you want to apply to the Map control. Go to the Preview tab to view the data in the selected tile provider. You can choose from the following tile provider options:
  • Google-Sample
  • Cloud-Made Sample
  • MapQuest-Sample
  • OpenStreetMap-Sample
Note: The Microsoft Bing Map server offers static map images. This requires an Application key for authentication. The default key provided by ActiveReports is for demo purpose and can not be used by 3rd party applications. In order to obtain a Bing Map Key, see HowTo - Create a Bing Map Account and HowTo - Generate a Bing Map Key.

Project Details

CustomTileProviders folder

This folder contain files that are used in the CustomTileProvider project.

CloudMadeTileProvider.cs

This class implements the IMapTileProvider interface and contains the settings for the map tile images provided from http://cloudmade.com.

GoogleMapsTileProvider.cs

This class implements the IMapTileProvider interface and contains the settings for the map tile images provided from http://maps.google.com.

MapQuestTileProvider.cs

This class implements the IMapTileProvider interface and contains the settings for the map tile images provided from http://www.mapquest.com.

MapTile.cs

This class represents a single map tile, implementing the IMapTile interface. For more information on ImapTile interface, see Add a Custom Tile Provider.

OpenStreetMapTileProvider.cs

This class implements the IMapTileProvider interface and contains the settings for the map tile images provided from http://www.openstreetmap.org.

WebRequestHelper.cs

This class picks the raw data from the tile providers and loads them into the System.IO.MemoryStream class.

TileProviderEndUserDesigner folder

This folder contain files that are used in the TileProviderEndUserDesigner project.

CustomTileProvider.rdlx

This report contains the Map control that visualizes the oil production in different parts of the world on a virtual earth background. The map control uses the color rule set on a polygon layer to differentiate parts of world as per their oil production capacity. These colors are defined using a color rule which is described in the legend at runtime. The report gets the data from Factbook.rdsx shared data source.

DesignerForm.cs

This is the main form that gets displayed when you run the sample. This form uses multiple controls like the ToolStripPanel, ToolStripContainerPanel, SplitContainer, Designer, Toolbox, ReportExplorer and PropertyGrid controls to create a customized End User Designer. It also contains code to load CustomTileProvider.rdlx report into the Designer.

GrapeCity.ActiveReports.config

This configuration file contains the settings for the various tile providers, and is located in the same folder as the EndUserDesigner.exe file for the tile provider settings to work.

HelperForm.cs

This form uses the HelperForm class to display a screen containing step-by-step instructions for the user to create a custom tile provider.


Digital Signature

Digital Signature
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Professional > Digital Signature
Show All Show All
Hide All Hide All

This sample demonstrates how you can digitally sign or set time stamp for a section report when exporting it to PDF format.

Note: PDF digital signatures is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Professional\DigitalSignature\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Professional\DigitalSignature\C#

Runtime Features

When you run this sample, the Invoice report is displayed in the Viewer control.

Clicking the Generate Digitally Signed PDF button in the Viewer toolbar creates a PDF file with a time stamp or digital signatures, based on the settings you have specified in the Viewer toolbar. You can change the content of signatures in the Signature Format box and you can add the time stamp to the generated pdf file by checking the Set TimeStamp checkbox, in the Viewer toolbar.

When you click the Generate Digitally Signed PDF button, a dialog for saving the destination file appears. After you indicate the location for a new PDF file, the PDF report file is created. Digital signature certificates dynamically reference and use GrapeCity.pfx, included in the project. Also, digital signatures dynamically load and use the gc.bmp file that you can find in the Image folder of this sample project.

Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

Project Details

Image folder

This folder stores the gc.bmp file with the GrapeCity logo that digital signatures dynamically load and use.

Invoice report

The Invoice report is the Sample report that uses three GroupHeader sections, a Detail section and a GroupFooter section as well as a label in the PageFooter section to display data.

See The Bound Data Sample topic for details on the Invoice report.

GrapeCity.pfx

In order to create a digital signature, you must have a valid PKCS#12 certificate (*.pfx) file.

For information on creating a self-signed certificate, see the Adobe Acrobat Help topic "Create a self-signed digital ID."

You can also create a PFX file from the Visual Studio command line. For more information and links to SDK downloads, see http://www.source-code.biz/snippets/vbasic/3.htm.

PDFDigitalSignature form

This is the main form of the Sample that uses the ActiveReports Viewer control in the bottom section of the form, and a panel docked to the top contains the Create Digitally Signed PDF button, the Signature Format box with the drop-down list and the Set TimeStamp checkbox.

Clicking the Generate Digitally Signed PDF button opens a dialog for saving the destination file. After you indicate the location for a new PDF file, the PDF report file is created.

The drop-down list of the Signature Format box contains the following options.

  • Invisible - the invisible pdf digital signature.
  • Text - the pdf digital signature that contains text only.
  • Image - the pdf digital signature that contains graphics only.
  • ImageText - the pdf digital signature that contains text and graphics.

Checking the Set TimeStamp checkbox allows you to add the time stamp to the signature of the generated pdf file. The time stamp contains the Time Stamp Server address, its login and password information.

Right-click PDFDigitalSignature in the Solution Explorer and select View Code to see the code implementation for the pdf digital signature options.

Resource1.resx

This file contains the string for the message box that appears after the PDF file is generated.
See Also

Concepts

PDF Export


End User Designer

End User Designer
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Professional > End User Designer
Show All Show All
Hide All Hide All

The EndUserDesigner Sample demonstrates how to set up a custom end-user report designer using the Designer, ReportExplorer, Layer List and ToolBox controls. This Sample is part of the ActiveReports Professional Edition.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Professional\EndUserDesigner\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Professional\EndUserDesigner\C#

Runtime Features

When you run the sample, the End User Designer appears in the Viewer control. This report designer provides the functionality of the ActiveReports Designer and supports three types of report layouts: Page Report, RDL Report and Section Report.

The End User Designer lets you create report layouts and edit them at design time or runtime. The Designer includes the Property Window with extensive properties for each element of the report, the Toolbox is filled with report controls and the Report Explorer with a tree view of report controls. Page reports and RDL reports provide the Layer List in a tabbed window with the Report Explorer. The Layer List window displays a list of layers in the report along with their visibility and lock options.

The End User Designer provides the following menu items:

File menu

  • New - Creates a new report in the designer with the default report template.
  • Open - Opens Open File Dialog to load a report.
  • Open from server - Opens Open report from server dialog to open reports from the ActiveReports Server. See Server Reports for more information.
  • Export - Exports a report to one of the available formats. This menu option is active during report preview only.
  • Save - Saves a report.
  • Save as - Saves a report at the path that you specify.
  • Save to server - Opens Save report to server dialog to save reports to the ActiveReports Server. See Server Reports for more information.
  • Exit - Closes the End User Designer.

Edit menu

  • Undo - Undoes your last action and enables the Redo button.
  • Redo - Redoes an undone action.
  • Cut - Removes the selected item(s) and places them on the clipboard.
  • Copy - Copies the selected item(s) to the clipboard.
  • Paste - Adds the last item on the clipboard to the design surface.
  • Delete - Deletes a selected control from your report layout.
  • Select All- Selects all items in case of section reports or all items on the Active Layer of Page or RDL reports.

Report menu

  • Convert to Master Report - (for RDL Report) Converts a RDL report to a Master Report.This menu item is enabled when you have a RDL report open. It disappears from the Report menu when a master report is applied to the report through Set Master Report.
  • Report Parameters - opens the Parameters page of the Report dialog where you can manage, add and delete parameters.
  • Embedded Images - opens Images page of the Report dialog, where you can select images to embed in a report. Once you add images to the collection, they appear in the Report Explorer under the Embedded Images node.
  • Report Properties - opens the General page of the Report dialog where you can set report properties such as author, description and grid spacing for Page reports. For RDL reports, you can set the page header and footer properties, once you have added them to your report layout.
  • Set Master Report (for RDL Report)- This menu item is enabled when you have an RDL report open. It is disabled when an RDL report is open or when a Master Report is created with the Convert to Master Report menu item.
    • Open From Server
      Select Open From Server option to open the Open report from server dialog, and then select a master report (RDLX-master file format).
    • Open Local File
      Select Open Local File option to open the Open dialog, and then select a master report.
  • Generate Excel Template - (for RDL Report) creates an Excel template of the report that you or the end user can customize for use with Excel exports to control the way the exported reports appear.
  • View - opens the Designer, Script or Preview tab. See Designer Tabs for more details.
  • Page Header - (for RDL Report) toggles the report Page Header on or off.
  • Page Footer - (for RDL Report) toggles the report Page Footer on or off.
Note: Except for View option, all other options in Report menu are disabled for a Section report.

For more information on the Designer features, please see ActiveReports Designer.

Project Details

ExportForm

This is the form with the Export dialog for Page report, Rdl report and Section report.

A user sees the Export dialog under the Preview tab in the File menu > Export. This dialog allows to select the export type and to browse for the file location in local folders where the report is exported. See Exporting for details on the type of export formats supported in Section report, Page report and RDL report.

ExportForm controls

Control | Name | Description
ComboBox | cmbExportFormat | The Export Format combo box that allows to select options for the report export type.
Button | btnOK | The OK button in the lower part of the ExportForm.
Button | btnCancel | The Cancel button in the lower part of the ExportForm.
PropertyGrid | exportPropertyGrid | Provides interface for export options of each export type.
SaveFileDialog | exportSaveFileDialog | The Save File dialog that allows to specify the file name for saving an exported report file.
Label | lblExport | The Export label in the header of the ExportForm.
Label | lblExportFormat | The Export Format label of the Export Format combo box.
Label | lblExportOptions | The Export Options label of the Export property grid.
Label | lblSelectExportTxt | The Select Export text that describes the purpose of the ExportForm.
SplitContainer | exportSettings SplitContainer | Represents a movable bar that divides the display area of the ExportForm into two resizable panels - the ExportForm header panel and the ExportForm panel with the Export Format combo box and the Property Grid.
SplitContainer | exportHeader SplitContainer | Represents a movable bar that divides the Export Format section consisting of the Export Format combo box with the Export Format label and the Property Grid of ExportForm.

Right-click the ExportForm in the Solution Explorer and select View Code to see the code implementation for the Export form.

EndUserDesigner form

This is the form with a basic end-user report designer that contains the following elements. These elements are dragged from the Visual Studio toolbox onto the form.

End User Designer controls

Control | Name | Description
Designer | reportDesigner | The Designer control that allows you to create and modify a report.
ReportExplorer | reportExplorer | Gives you a visual overview of the report elements in the form of a tree view where each node represents a report element.
TabControl | reportExplorerTabControl | Represents a movable bar that divides the display area of the designer into two tabs -the Report Explorer and the Layer List
PropertyGrid | reportPropertyGrid | Provides an interface for each element of the report.
Toolbox | reportToolbox | Displays all of the controls specific to the type of report that has focus.
LayerList | layerList | Represents a list of Layers in the report along with their visibility and lock options.
SplitContainer | mainContainer | Represents a movable bar that divides the display area of the Designer into two resizable panels.
SplitContainer | designerExplorerPropertyGridContainer | Represents a movable bar that divides the display area of the designer into two resizable panels -the toolbox and the toolstrip.
SplitContainer | bodyContainer | Represents a movable bar that divides the display area of the Viewer into two resizable panels.
SplitContainer | explorerPropertyGridContainer | Represents a movable bar that divides the display area of the designer into two resizable panels - the report explorer and the property grid.
ToolStripContainer | toolStripContainer | Provides a central panel on top of the Designer to hold the Toolstrip element with the menu items.

Right-click the EndUserDesigner form in the Solution Explorer and select View Code to see the code implementation for the End User Designer.

See Also

Concepts

ActiveReports Designer
Exporting


Map

Map
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Professional > Map

The Map sample demonstrates the basic functioning of the Map control with the help of four reports that explain the different features of the control. This sample is part of the ActiveReports Professional Edition.

  • Sample Location
  • Runtime Features
  • Project Details

Sample Location

Visual Basic.NET
Copy Code
<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Professional\Map\VB.NET
C#
Copy Code
<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Professional\Map\C#

Runtime Features

When you run this sample, the End User Designer shows a list of .rdlx reports at the bottom left of the form. Expand the Reports node to view reports under it and double-click a report to load it into the designer.

Project Details

Report Form

This is the main form that appears when you run the sample. This form uses the ToolStripPanel, ToolStripContentPanel, Designer, Toolbox, ReportExplorer and PropertyGrid controls to create a customized ReportDesigner.

Right-click the form and select View Code to see how to set up the designer and create a blank page report. It also contains code that adds the reports to the TreeView control, loads a report into the Designer when the report is double-clicked, and checks for any modifications that have been made to the report in the designer.

Reports Folder

OilProducingCountries.rdlx: This report uses the FactBook shared data source connection to provide data.

It contains a Map control that visually displays the oil production in different countries of the world on a virtual earth background. The map control uses the color rule set on a polygon layer to differentiate parts of world according to their oil production capacity. These colors are defined using a color rule which is described in the legend at runtime.

RomePlaces.rdlx: This report contains a Map control that visually displays famous places in Rome.

The map control uses Google maps in a Tile layer to provide a virtual earth background and a Point layer to plot famous places on the map using image markers. Clicking the image marker opens the web page for the selected place in Wikipedia.

StoreSales.rdlx: This report contains a Map control that visually displays the sales of different stores in the US.

The Map control uses the built-in USA map template. The polygon layer defines the country and state boundaries while the point layer is used to plot store locations. The Point layer uses the marker size rule to differentiate stores according to their profits. The different sized markers used for plotting stores are defined in a legend that appears on the map at runtime. The point layer also uses the drill-through link (the Action is set to Jump to report) that opens a specific store report (StoreReport2.rdlx) when the marker is clicked.

StoreReport2.rdlx: This report uses the Reels shared data source connection to provide data.

It opens on clicking a specific store location that is indicated with a marker. The Table data region in the report uses a drill-down link to display the list of employees in the selected store. The report uses the chart data region to display the sales for the store. The Reels logo that appears on the report in the Image control is embedded within the Reels theme.

See Also

Concepts

Map


Silverlight Viewer

Silverlight Viewer
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Professional > Silverlight Viewer
Show All Show All
Hide All Hide All

The Silverlight Viewer sample demonstrates the Silverlight Viewer with its various options of loading RPX, RDLX and RDF reports. This Sample is part of the ActiveReports Professional Edition.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Professional\SilverLightViewer\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Professional\SilverLightViewer\C#

Runtime Features

When you run the project, the MainPage.xaml page with the Silverlight Viewer displaying the MainReport.rpx appears in your browser, and you will see a number of report options that the Silverlight Viewer will display.

  • RDF
  • RDLX
  • RPX
  • Code

Project Details

Images

The Images folder contains images that are used in the header of the ActiveReports 10 Silverlight Viewer, including the images for the buttons to load and display an RDF, an RDLX, an RPX and a Code report in the Silverlight Viewer.

MainPage.xaml

The user control that contains the Silverlight Viewer. The code behind this file, MainPage.xaml.vb (or .cs), handles the customization of the Silverlight Viewer application.

It contains code that handles the display of RDF, RDLX, RPX, and Code reports in the ActiveReports 10 Silverlight Viewer.

SilverlightViewer.Web Project

Reports

The Reports folder that contains the RDF, RDLX and RPX files of reports used in the sample. You can alter the project and add your own reports to this folder.

RDF

The EmployeeSales.rdf report that is displayed in the Silverlight Viewer by clicking the RDF button in the header of the Viewer.

The report displays the Sales by Employee chart and the list of employee names in the alphabetical order along with their total sales.

RDLX

The SalesReport.rpx is displayed in the Silverlight Viewer by clicking the RDLX button in the header of the Viewer. This report presents the Sales over time line chart along with the list of chart data.

The report contains two parameters, StartDate and EndDate. The report also has one TextBox with the Label property set to the expression, thus you can see the Document map of the report in the sidebar pane.

RPX

The Invoice1.rpx and MainReport.rpx reports. The Invoice1.rpx report is displayed in the Silverlight Viewer by clicking the RPX button in the header of the Viewer. The report displays the invoice form and the invoice details.

The MainReport.rpx report is the default report to be displayed in the Viewer when you run the sample project.

ActiveReports.ReportService.asmx

The report web service required for the proper functioning of the Silverlight Viewer. The ActiveReports.ReportService.asmx is added automatically to the project when you place the Viewer control on the form. You can also can add this service by using Add New Item in the Visual Studio 2010 Project menu.

For the information on how to use the Silverlight Viewer, see Using the Silverlight Viewer.

CodeReport

The Invoice report that is displayed in the Silverlight Viewer by clicking the Code button in the header of the Viewer.

Invoice Report

The Invoice report uses a PageHeader, a GroupHeader, a Detail section, a GroupFooter and a PageFooter section.

PageHeader

This section contains Label, Textbox, Shape and Line controls to create the report page header.

customerGroupHeader

The DataField property of this section is set to OrderID. This setting, in conjunction with data ordered by the OrderID field, causes the report to print all of the information for one order ID value, including all of the related details and footers, before moving on to the next order ID. For more information on grouping, see Grouping Data in Section Reports.

This section also contains the Line, Shape, CrossSection controls, a number of Label controls, and two bound TextBox controls. The TextBoxes are bound using the DataField property in the Properties window.

In the lower part, the section contains labels for the data to follow in the Detail section.

Detail

This section contains bound TextBox controls. These TextBoxes render once for each row of data found in the current OrderID before the report moves on to the GroupFooter section.

customerGroupFooter

The NewPage property of this section is set to After. This causes the report to break to a new page and generate a new invoice after this section prints its subtotals.

This section contains several labels and several TextBoxes. The subtotalTextBox control uses the following properties to summarize the detail data: SummaryRunning, SummaryGroup, and SummaryType. For more information, Create a Summary Report.

The Total TextBox does not use the DataField property or any of the summary properties, or even any code. To find the functionality of this TextBox, in design view, click the Script tab at the bottom of the report.

PageFooter

This section has one simple ReportInfo control. For more information about report sections and the order in which they print, see Section Report Structure and Section Report Events.

Default.html

This is the html page that hosts the Silverlight Viewer in the browser.

Report.aspx

This report contains the code to run the CodeReport, generate it in the rdf format and pass it to the Silverlight Viewer for display. This report is processed by the code of MainPage.xaml when you click the Code button in the Silverlight Viewer header.

Web.config

The configuration file that contains the httpHandlers that allow ActiveReports to process reports on the Web.

Note that you need to manually update version information here when you update your version of ActiveReports.

See Also

Getting Started

Silverlight Viewer

Concepts

Interactive Features
Parameters


Table of Contents

Table of Contents
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Professional > Table of Contents

The TableofContents sample demonstrates the basic features of the TableofContents control. This sample is part of the ActiveReports Professional Edition.

  • Sample Location
  • Runtime Features
  • Project Details

Sample Location

Visual Basic.NET
Copy Code
<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Professional\TableOfContents\VB.NET

C#
Copy Code
<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Professional\TableOfContents\C#

Runtime Features

When you run this sample, the End User Designer appears with a MovieCatalog.rdlx under the Reports node. The report contains a TableOfContents control which displays a list of movie titles along with their page numbers under each genre. On clicking the movie title, the details on the selected movie are displayed.

Project Details

Report Form

This is the main form that appears when you run this sample. This form uses the ToolStripPanel, LayerList, TreeView, ToolStripContentPanel, Designer, Toolbox, ReportExplorer and PropertyGrid controls to create a customized ReportDesigner.

Right-click the form and select View Code to see how to set up the designer. It also contains code that adds the reports to the TreeView control, loads a report into the Designer when it is double-clicked, and checks for any modifications that have been made to the report in the designer.

Reports Folder

MovieCatalog.rdlx: This report uses the Reels data source connection to provide data.

The report makes use of TableOfContents, Image, TextBox, Label and List controls to display the layout of the report. TableofContents control displays an organized hierarchy of movie titles under each genre with two heading levels. Clicking the genre name or the movie title takes you to the corresponding page number that contains the details. The Reels logo that appears on the report is embedded within the Reels theme.

See Also

Concepts

TableOfContents


Reports Gallery

Reports Gallery
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Reports Gallery

The Reports Gallery sample demonstrates how to customize the End User Designer application by adding the TreeView control to display a list of categorized reports. At runtime, the user can double-click any report out of the three categories: Page, Rdl and Section, and load it into the designer.

  • Sample Location
  • Runtime Features
  • Project Details

Sample Location

Visual Basic.NET
Copy Code
<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Reports Gallery\VB.NET
C#
Copy Code
<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Reports Gallery\C#

Runtime Features

When you run this sample, the End User Designer appears with a list of report categories at the bottom left of the Form. Expand each category to view the reports under it and double-click any report to load it into the designer. You can also go to the Preview Tab to view the report.

Project Details

ReportsForm

This is the main form that appears when you run this sample. This form uses the ToolStripPanel, ToolStripContentPanel, Designer, Toolbox, ReportExplorer, TreeView, PropertyGrid and LayerList controls to create a customized unified ReportDesigner.

Right-click the Form and select View Code to see how to set up the designer and create a blank page report. It also contains code that attaches the Toolbox, ReportExplorer, PropertyGrid and LayerList controls to the Designer, inserts DropDown items to the ToolStripDropDownItem and sets their functions. Finally, it also contains code that adds the reports to the TreeView control, loads a report into the Designer when the report is double-clicked, and checks for any modifications that have been made to the report in the designer.

Reports folder

Reports folder consists of three subfolders - Page Report, RDL Report and Section Report, each containing a set of reports that highlight the major features of the corresponding report types.

Page Report folder

This folder contains several subfolders that illustrate the use of Page Reports in different scenarios.

DrillDown folder

AllCustomers report: This report uses the NWind shared data source. It uses the Table data region to display customer's contact details. The Textbox displaying the CustomerID field in the detail row of the Table is used to set a drill-through link to navigate to the CustomerDetails report.

Invoice folder

BillingInvoice report: This report uses the NWind shared data source. It showcases a billing invoice layout commonly used in convenience stores. The report mostly contains Label, TextBox and Line controls in its layout. It also includes an EAN128FNC1 barcode due to its high reading accuracy.

Invoice1 report: This report uses the NWind shared data source. It includes a BandedList and few TextBox controls to create the Invoice layout for displaying customer transactions. Both the page and the BandedList control are grouped by the OrderID field. One of the text boxes in the footer section of the BandedList control uses the Sum function to display the grand total of all transactions.

Invoice2 report: This report uses the NWind shared data source. It uses a Table, few TextBoxes and Shape controls to create the Invoice layout for displaying customer transactions. The report page is grouped by the CustomerID field, therefore all transactions made by a customer appear together based on the ID. One of the text boxes placed inside the Container control at the bottom of the report uses the Sum function to display the grand total of all transactions.

Invoice_Grouped report: This report uses the NWind shared data source. It uses the Table, few TextBox and Label controls to display customer transactions in an Invoice. The data is grouped on the CustomerID field, so that all transactions made by a customer appear together based on their ID.

Invoice_Parameters report: This report uses the NWind shared data source connection and two datasets to provide data. It is similar to the Invoice_Grouped report with an additional parameters feature. It uses parameters set on the CompanyName field to filter data on report preview.

Other folder

BarCode report: This report demonstrates all barcode types that are supported by ActiveReports. The barcode types are presented in the Table data region, using a single page layout. The rows of the table use alternate background colors (grey and white). At runtime, the Barcode report displays one page that fits the table with all the sample barcodes.

Catalog report: This report uses the NWind shared data source. It shows a multi page layout spread over four pages in the report. The layout in Page1 and Page2 contains Image, Label and Textbox controls to display introductory text. The layout on Page3 contains a List data region with TextBox controls and a Table to display product details for each product category. The List is grouped by the CategoryID field to filter products by their category and its FixedSize property is set to fit in excess data. The layout on Page4 (that appears as page 9 at runtime) uses Textbox, Shape and Line controls amongst others to create an Order Form, which a user is to fill manually.

CellMerging report: This report uses the NWind shared data source. This report demonstrates cell merging in Tablix data region, where cells with same values are merged automatically to avoid showing duplicate values. The row group area contains three groups that are nested in a parent/child relationship to display the row group data. The Country (parent) and City group (child) values are merged automatically to remove duplicate data values.

DeliverySlip_theme report: This report uses the Seikyu2 shared data source. It uses the TextBox, Label, Container controls and two Table data regions to display the invoice information. The report uses two themes and has its CollateBy property set to ValueIndex to determine the order in which the report pages are rendered. Some TextBox controls on the report also use the Sum function to display the total price information for each Invoice. The page is grouped on the EstimateID field, so the invoices are sorted by EstimateID.

EmployeeSales report: This report uses the NWind shared data source. It contains the Chart and Table data regions to display sales by each employee for the year 1997. A column chart shows the graphical representation of sales by each employee while the Table lists down the exact sales figures. One of the TextBox controls on the report also uses the Sum function to display the grand total of all sales.

IRS-W4 report: This report uses the IRS XML data source to provide data to the report. It mainly contains Textbox, CheckBox, Shape and Line controls to create the layout of a tax form used in the US.

Letter report: This report uses the NWind shared data source. It contains an Image, FormattedTextBox, Table and an OverflowPlaceholder controls to create a layout for a letter. The FormattedTextBox control uses text with HTML tags to display content. The Table displays OrderID with order dates and order amount and is linked with the OverflowPlaceholder control to display excess data on the same page. The Reels logo, displayed on the report inside the Image control, is embedded within the Reels theme and the TextBox placed below the Image control uses a Global expression to display the current date. The layout page is grouped by the CustomerID field to filter data on each report page according to individual customers.

Tablix Sample report: This report uses the NWind shared data source. It contains the Tablix data region that displays an orders report with product category and names showing quarterly and yearly orders. The Tablix uses a nested row grouping to group the Tablix data region by CategoryName and ProductName, and nested column grouping to group the Tablix data region by Years and Quarter. The tablix body area displays the aggregate Sum for each category and the grand total of order amount.

PurchaseReport report: This report uses the NWind shared data source. It contains the Textbox and Table controls to display purchase details for each company. The layout page is grouped by the Company_CD field to filter data on each report page according to the company. The Textbox control placed below each table column uses the Sum function to display totals. The FixedSize property of the Table is set to fit in excess data.

ReelsTablix: This report uses the Reels shared data source. It contains the Tablix data region to display a sales report for each country, city and media type by year. The Tablix data region uses row grouping to group the data by Country, City and MediaType, and column grouping to group the data by Years and Quarters.

SalesReport report: This report uses the Reels data source connection and two datasets that fetch data through a Stored Procedure. The layout of the report uses the Chart to display sales and profit for the selected date range and the Table to display the numeric values of the same. The table also uses the DataBar function to plot profits graphically. The Reels logo, displayed on the report inside the Image control, is embedded within the Reels theme. This report also uses two nullable parameters to select the range of dates.

TackSeal: This report uses the NWind shared data source. It contains the OverflowPlaceholder control and the List data region to create a columnar display of tack seals with postal barcodes. The List data region has its OverflowName property set to OverflowPlaceHolder1 and the OverflowPlaceHolder1 control has its OverflowName property set to OverflowPlaceHolder2 to assure correct display of columnar data display within the report page.

RDL Report folder

This folder contains several subfolders that illustrate the use of RDL Reports in different scenarios.

Calendar folder

Events: This report uses XML data containing event details entered directly in the connection string of the data source and accessed by the dataset. It contains a Calendar control to display events.

EventTypes: This report uses XML data containing event details entered directly in the connection string of the data source and accessed by the dataset. It contains a Calendar control to display Family, Music and Cultural events. A custom event background color is also set for each event type in the Script tab.

Vacations: This report uses XML data containing event details entered directly in the connection string of the data source and accessed by the dataset. It contains a Calendar control to display employee's vacations.

DashBoard folder

CallCenterDashBoard: This report uses the CallCenter shared data source. It contains uses the Bullet control to indicate when the data is approaching or past a warning range and the Sparkline controls to indicate daily trends in key pieces of performance and sales data. It also uses the Icon Set data visualizer to indicate the warning levels for key performance data.

MarketDashBoard: This report uses the MarketData shared data source. It contains the Sparkline control to display stock price trends over the last 30 days. The Sparkline allows investors to see trends without knowing what actual values are associated with each point.

TeamList: This report uses the FootballStatistics shared data source. It contains the List control that displays a list of team names with drill-through links to navigate to the TeamStatisticsDashboard.rdlx report that displays the selected team's statistics.

FactBook folder

CountryFacts: This report uses the Factbook shared data source. It contains a List data region grouped on CountryID that groups data by Country. The report also contains a map image whose Value property is set to the expression with the MapCode data field from the XML data source. It contains a hidden parameter that is used to accept the Country ID. This report is called in other reports by drill-through links or as a subreport, so the Country ID is passed silently. The default ID is the World. The dataset has a filter that retrieves only countries, specified by the report parameter. From each textbox with category under Energy Production / Consumption you can see the Image control that uses the Icon Set data visualizer to flag energy categories where consumption is greater than production.

LifeExpectancyByGdpAndMedianAge: This report uses the Factbook shared data source. It contains the Tablix data region to compare the average life expectancy based on the category where the Median age and GDP fall. The tablix data region consist of a row group GDP of country and a column group Median Age to display the data.

Top10CountriesByGdp: This report uses the FactbookSortedByGdp shared data source and shows the Top 10 countries by GDP. It contains a List data region with an image in the Image control that uses the RangeBar function to create an ad-hoc horizontal bar chart.

Reels folder

CustomerMailingList: This report uses the Reels shared data source. It includes a Container control along with TextBox and Barcode controls to display a mailing list of customers. The Columns property of the Body section is set to 3 to display mailing labels in three columns.

CustomerOrders: This report uses the Reels shared data source. It contains the List and Table data regions that group data by CustomerID and SaleID respectively to display order information. The SalesAmount textbox of the Table has its Value property set to Sum function to calculate the total for each order (as a table group subtotal). The YearTotal textbox of the Table also has its Value property set to Sum function to calculate the total of pre-tax sales. The Reels logo that is displayed on the report is embedded within the Reels theme. The page number in the PageHeader section is reset every time a new customer is displayed. This report also contains a subreport, CustomerOrdersCoupon.rdlx.

DistrictReport: This report uses the Reels shared data source. It contains the Chart and Tablix data region to display the number of sold items and the profit for each month during the two year span (2004-2005) for the selected district. The Tablix data region consists of a row group SaleDate and a column group StoreName. The report parameter determines which district to display and uses the available values from the second report dataset SalesData.The StoreName textbox in the report body uses the drill-through link (the Action is set to Jump to report) that opens the StoreReport.rdlx with more information.

DistrictSales: This report uses the Reels shared data source. It contains the BandedList data region that groups data by SaleYear, DistrictID and RegionID to display district sales details. Sum function is used to get the total sales at the District, Region, Year levels and also to display a grand total. The Reels logo that is displayed on the report is embedded within the Reels theme.

Filmography: This report uses the Reels shared data source. It contains nested List data regions that group data by MovieID and MoviePersonID to return a distinct number of movies with the selected actors. The report contains two cascading parameters that narrow down the number of actors displayed in the list first based on the alphabet with which the actor's name begins and then based on the actor's name. The Reels logo that is displayed on the report is embedded within the Reels theme.

GenreSales: This report uses the Reels shared data source. It contains a Tablix data region to display the units sold for each genre, in each year and each quarter. The Tablix report data consist of a row group GenreName and a column group SaleDate.Year to display the data. The report also uses the plain column Chart to display the number of titles sold for each genre. This report uses the multi value parameter that allows you to select more than one genre for displaying sales data.

GenreStatistics: This report uses the Reels shared data source. Median and Mode aggregate functions are used to show the middle values in a set of data as well as the most commonly occurring value. It also uses the ReelsConfidential.rdlx-master report to provide standard page headers and footers. The Reels logo that is displayed on the report is embedded within the Reels theme.

MonthlySalesReport: This report uses the Reels shared data source. It contains a Table data region that groups data by DistrictID. The Textbox controls in the Table have their Value property set to expressions to display the total of sales for each district and region as well as the totals of all districts within a region for a given month. It also uses the Plain Line Chart with the data grouped and sorted by Day for each SaleDate to display sales and profit for the selected month. This report uses query based parameters to select the month and region for displaying data. The Reels logo that is displayed on the report is embedded within the Reels theme.

MovieCatalog: This report uses the Reels shared data source. It contains the Image, TextBox, TableofContents and List controls to display the list of movies in a catalog. This report uses the TableofContents control to display, an organized hierarchy of the report heading levels and labels along with their page numbers, in the body of a report. It also uses the TextBox and Image control to display the layout of the report. The Reels logo that is displayed on the report is embedded within the Reels theme.

MovieReport: This report uses the Reels shared data source. It contains four List data regions with groupings. The MovieList is grouped by MovieID, the GenreList is used to display the genre names and is grouped by GenreID, the CrewList is used to display the title and is grouped by CrewTitleID, and finally the CastNameList is used to display the cast and crew and is grouped by MoviePersonID. This report uses cascading parameters. The first parameter asks to select which letter the movie titles starts with, and then the second parameter asks to select a movie to display. The CrewName textbox in the report Body uses the drill-through link (the Action is set to Jump to report) that opens Filmography.rdlx with more information on the selected person. The parameters of this report are passed to the Filmography.rdlx report. The Reels logo that is displayed on the report is embedded within the Reels theme.

RegionPerformance: This report uses NWind.mdb database. It contains the Table data region that uses the Region value to group the report data and the SalesAmount value to sort the report data. It also uses filtering to filter the report data by the RegionID value. Textbox controls in the Table have their Value properties set to Sum functions to display the total of sales amount for each region. The Reels logo that is displayed on the report is embedded within the Reels theme.

ReorderList: This report uses Reels shared data source. It contains the Table data region without any grouping. The Table detail row has its BackgroundColor property set to the expression to create a light yellow bar report. The Reels logo that appears on the report is embedded within the Reels theme.

SalesByMediaType: This report uses the Reels shared data source. It contains the List data region that is grouped by Image to display data. The list also includes the Table data region that groups its data by MediaID. The report also contains the Plain Column Chart to display sales and profit by media type and embedded images for each category. This report uses the ReelsConfidential.rdlx-master report to render the report page header and footer.

SalesByRegion: This report uses the Reels shared data source. It contains the Tablix data region and subtotals to display the number of units sold and profit for each region by year and quarter. The Tablix report data consist of a row group Region and a column group SaleDate.Year to display the data. The report also uses the Plain Column Chart to display the annual profit for each region. Data in the Chart is also grouped by Region and SaleDate.Year.

SalesReceipt: This report uses the Reels shared data source. It contains a Table data region and three Container controls nested in the List data region. The List is grouped by SaleID to produce the body of the receipt. The salesTaxLabel and totalSalesTax text boxes use the Sum function that totals the amount due in the list and adds tax to the sum of a field for the grand total due. The Reels logo that is displayed on the report is embedded within the Reels theme.

SalesReport: This report uses the Reels shared data source. It contains a Table and Chart data regions to display totals of sales and profit for the selected date range. The Table also uses the Data Bar function to plot the profits. The Chart and Table data is grouped by Month and Year. The Month textbox uses the drill-through link to display MonthlySalesReport.rdlx with more information on the selected month. This report uses parameters that allow the null value to select the range of dates. The Reels logo that is displayed on the report is embedded within the Reels theme.

StorePerformance: This report uses the Reels shared data source. It identifies stores with profits above or below expectations. It also has two Image controls that display the database images and use the IconSet function. This report uses the ReelsConfidential.rdlx-master report to render page headers and footers.

StoreReport: This report uses the Reels shared data source. It contains the Table, List and Chart data regions to display sales for each employee. The Table and Chart data is grouped by EmployeeID. The Table uses hierarchical grouping to show the relationship between employee and supervisor for each store. The FirstName textbox has its Padding> Left property set to the Level function that leaves a space 15 pixels wide to the left of the control. This is the drill-down report where the Visibility > Hidden property of the Table detail row is set to =Fields!Supervisor.Value <> 0 and the Visibility > ToggleItem property is set to the FirstName data field. The expression in the Visibility > Hidden property calculates whether the supervisor field returns 0, so only the supervisor's name is displayed initially. By clicking the toggle image next to the supervisor's name, the rows with details about employees are displayed. The report uses a cascade of parameter values - Region, District and StoreNumber. Each parameter depends on the value of the previous parameter and each comes from a separate dataset. The Reels logo that is displayed on the report is embedded within the Reels theme.

TopPerformers: This report uses the Reels shared data source. It contains two Table data regions to display the top and bottom performers based on the movies sales. Each Table data is grouped by MoviePersonID and MovieID (nested grouping). The TopN filter is applied to one table and the BottomN filter is applied to another. The number of items returned by each of the filters is specified in report parameters. This report also uses two integer parameters to alter the number of items displayed in each table. The parameters use default values, which are passed to textboxes of the Table Headers. This is the drill-down report where the second Table Group Header in each Table has its Visibility > Hidden property set to True and the ToggleItem property set to the PerformerName textbox. By clicking the toggle image next to the name, the rows containing details about performers are displayed.

Section Report folder

BarCode Report

This report displays all barcode types that are supported by ActiveReports.

  • PageHeader section: This section contains the table columns to display the report header. The Text property of the two Textbox controls, define the name of the two table columns.
  • Detail section: This section contains a list of all the Barcode types that are supported by ActiveReports. The barcodes are presented in a table that contains two columns, the one with the Textbox control displays the barcode name, and the other one with the Barcode control displays the barcode image.

Invoice1 Report
This report calculates the total amount for each customer along with purchase details. The report also displays the average of the previous invoice amount, the current invoice amount and the consumption tax. This report uses Bill.mdb database to provide data.

  • PageHeader section: This section contains the Label and Textbox controls. It uses the bound data fields to calculate the invoice information in the header. The values of the Excise and BillTotal Textbox controls are set in the Script tab and are calculated in the BeforePrint event.

Note: This sample uses bound fields on the PageHeader section, assuming that the value of all records to be displayed on a page does not change.

However, it is not recommend that you place bound fields in the PageHeader or PageFooter sections because these sections are displayed on a page once. For the same reason it is not recommended that you place bound fields on the GroupHeader and GroupFooter sections.

  • GroupHeader section: This section (ghColumnCaption) contains the Label controls that are captions for the information displayed in the Detail section. This section also uses the CrossSectionBox and the Shape controls.
  • Detail section: This section contains the bound TextBox controls that display each row of data associated with the current ghColumnCaption. The Shape control is used to alternate row colors in the Detail section. Go to the Script tab and see the shpDetailBack.BackColor property in the Detail_Format event.
  • PageFooter: This section contains the Label controls that explain codes used in the Category column of the invoice details.

Invoice2 Report
This report shows another invoice layout and uses Seikyu2.mdb database to provide data.

  • GroupHeader1 section: This section contains the Label and Textbox controls. It uses the bound data fields to calculate the invoice information in the header. The values of the Year, Month and Day Textbox controls are set under the Script tab and are calculated in the ReportStart event. It also uses the CrossSectionLine and the CrossSectionBox controls that span the GroupHeader1 section to Detail section. The CrossSection Box ends in the GroupFooter1 section. These controls form vertical lines between columns of the invoice details and a rectangle around the details of the invoice at runtime.
  • Detail section: This section uses the data table tb_Main for the main report data and the data table tb_Count to retrieve the number of data items within a group. The Detail data in each group is retrieved beforehand to calculate the required number of empty rows. For the required empty row count, substitute data with "" in the FetchData event. The Shape control is used to alternate row colors in the Detail section. Go to the Script tab and see the shpDetailBack.BackColor property in the Detail_Format event.
  • GroupFooter1 section: This section contains the Label and Textbox controls that display the totals of the invoice. The values of the Tax and Pretax Textbox controls are set under the Script tab and are calculated in the Format event.

Label Report
This report displays the tack seal, which is commonly used in postal services. This multi-column report uses the customer barcode that is bound to data by using the DataField property. This report uses Nwind.mdb database to provide data.

  • Detail1 section: This section contains the bound data fields to display the contact information and the Barcode control that is bound to data by using the DataField property. The ColumnCount property is set to 3, which allows the report to display the tack seal in 3 columns.

PaymentSlip Report
The report displays the salary payment slip where the EAN128FNC1 barcode is used for barcode bound to a data field. This report uses Bill.mdb data source connection to provide data.

  • Detail section: This section contains bound data fields to display the payment information and the Barcode control that is bound to data by using the DataField property.

PurchaseOrder Report
The report displays purchase slips created with bound data. It groups data for each purchase slip. The detail count is not fixed but the number of rows in the report layout is fixed. In this case, when the RepeatToFill property of the Detail section is set to True, the detail data is repeatedly displayed on the entire page. The report uses the RepeatToFill property and calculated fields to demonstrate how to create the report layout without any code. Calculated fields are used to calculate the total cost and the total selling price. This report uses Shiire.mdb data source.

  • groupHeader1 section: This section contains the Label and Textbox controls. It uses the bound data fields to calculate the company information in the header.
  • Detail section: This section contains Textbox controls. It uses bound data fields to calculate the product information in the body of the report. The detail.BackColor property is used to alternate row colors in the Detail section. Go to the Script tab and see the detailBack.BackColor property in the detail_Format event.
  • groupFooter1 section: This section contains the Label and Textbox controls. It uses the bound data fields to calculate the total information in the footer of the report group.

Schedule Report:
The sample report displays the weekly schedule of employees in the gantt chart format. The report displays six day report schedules on a single page in the Viewer control. This report uses Schedule.mdb database to provide data.

  • GroupHeader1 section: This section contains the Label and Textbox controls. It uses the bound data fields to calculate the employee information in the header.
  • Detail section: The Gantt chart view is created by using the Label, Shape and Line control. You can display the horizontal bars like in the gantt chart by modifying the size of the Label control. To add horizonal bars, you can dynamically add twenty four (12 x 2) Label controls within the 9-20 hours time frame that will become the horizontal bars of gantt chart in the ReportStart event. Once they are added, set the Visible property to False to hide them.

You can adjust the width of horizontal bars by setting calculated values from the time width in the Tag property of the Label control within Detail_Format event. For the horizontal adjustment of bars, change the width of the Label control to match with the value in the Tag property.

UnderlayNext Report:
This report displays the bound data. It uses Nwind.mdb database to provide data.

  • PageHeader section: This section contains the Label and Line controls to create the header for report data.
  • GroupHeader1 section: This section contains a TextBox control bound to the Country field and the CrossSectionLine controls to create the table for the body data of the report. UnderlayNext Property of this section is set to True to align the beginning position of the report data in the Detail section with the GroupHeader1 section.
  • Detail section: This section contains the bound Textbox controls to display report data. This section displays the name of the city, contact name and postal code for each customer according to their countries.
See Also
Custom Resource Locator
DataSet DataSource

How To

Create and Edit a Shared Data Source
Add Parameters
Grouping in a Data Region

Concepts

Expressions
Section Report Toolbox
Toolbox


Section Report

Section Report
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report

Learn about the different section report samples categorized under Data, Layout, Preview, Summary and Web respectively.

This section contains:

Data
This section contains samples that showcase working with different data sources.
Layout
This section contains samples that showcase creating different layouts in a section report.
Preview
This section contains samples that showcase creating an interactive section report during preview.
Summary
This section contains samples that showcase displaying summarized data in a section report.
See Also
Professional Samples


Data

Data
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report > Data

Learn working with different data sources.

This section contains:

Bound Data
Demonstrates binding to ADO.NET Data objects.
IList Binding
Demonstrates creating a custom collection that stores data from the database in the List. The custom collection is displayed by binding data to the DataGridView control by using the DataSource property of this control.
LINQ
The LINQ sample demonstrates how to use LINQ in an ActiveReports report.
Unbound Data
The Unbound Data sample demonstrates how to create a dataset for a section report and use the FetchData event to populate the Fields collection to display the report unbound data.
XML
This sample demonstrates how to create a report with XML data, using a SubReport or using the XML hierarchical structure.
See Also
Layout
Preview
Summary
Web
WPF Viewer


Bound Data

Bound Data
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report > Data > Bound Data
Show All Show All
Hide All Hide All

The Bound Data sample demonstrates various ways to bind data in a section report.

When you run the sample, the Viewer control displays the form with seven tabs, each with a different data binding technique. Click to select a tab, and then click the Bind To button to create the report.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Data\BoundData\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Data\BoundData\C#

Runtime Features

The top panel of the MainForm is composed of seven tabs:

Bind to DataSet
Creates a DataSet from the sample database and binds it to a SectionReport object.

Bind to DataReader
Creates a DataReader from the sample database and binds it to a SectionReport object.

Bind to DataView
Creates a DataView from the sample database and binds it to a SectionReport object. This tab contains a ComboBox which lets you choose the company name from the NWind database.

Bind to DataTable
Creates a DataTable from the sample database and binds it to a SectionReport object.

Bind to SQL Server
Creates a SQL Server DataSource from a SQL server instance and binds it to a SectionReport object. The ComboBox present in this tab lets you populate the dropdown list with the existing SQL servers on the network.

Bind to OleDb
Creates an Oledb DataSource and binds it to a SectionReport object.

Bind to XML
Creates a XML DataSource from a file and binds it to a SectionReport object. The XML tab also features a Generate XML button that generates a DataSet and saves it as an XML data file. The generated file is then used as a data source for the report.

Project Details

MainForm

The MainForm uses the ActiveReports Viewer control in the bottom section of the form, and a panel docked to the top contains seven tabs, each with a different data binding technique.

Click to select a tab, and then double-click the button on the tab to jump to the button's Click event in the code.

Invoice Report

The Invoice report uses three GroupHeader sections, a Detail section and a GroupFooter section as well as a label in the PageFooter section to display data.

Note: Except for the Detail section, all sections come in header and footer pairs. Unused sections have their Height properties set to 0 and their Visible properties set to False.

ghOrderHeader

The DataField property of this section is set to OrderID. This setting, in conjunction with data ordered by the OrderID field, causes the report to print all of the information for one order ID value, including all of the related details and footers, before moving on to the next order ID. For more information on grouping, see Grouping Data in Section Reports.

This section also contains a Picture control, a number of Label controls, and two bound TextBox controls. The TextBoxes are bound using the DataField property in the Properties window, and the date is formatted using the OutputFormat property.

ghOrderID

The DataField property of this section is also set to OrderID. This allows subtotal summary functions in the related GFOrderID section to calculate properly.

This section contains a number of labels and bound text boxes, as well as two Line controls.

ghTableHeader

This section contains only labels for the data to follow in the Detail section.

Detail

This section contains bound TextBox controls. These TextBoxes render once for each row of data found in the current OrderID before the report moves on to the GroupFooter sections.

GFOrderID

The NewPage property of this section is set to After. This causes the report to break to a new page and generate a new invoice after this section prints its subtotals.

This section contains several labels and several TextBoxes. Two of the TextBox controls use the following properties to summarize the detail data: SummaryFunc, SummaryGroup, and SummaryType. For more information, Create a Summary Report.

The Total TextBox does not use the DataField property or any of the summary properties, or even any code. To find the functionality of this TextBox, in design view, click the Script tab at the bottom of the report.

PageFooter

This section has one simple Label control. For more information about report sections and the order in which they print, see Section Report Structure and Section Report Events.
See Also

How To

Bind Reports to a Data Source

Concepts

Grouping Data in Section Reports


IList Binding

IList Binding
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report > Data > IList Binding
Show All Show All
Hide All Hide All

The IList Binding sample uses CollectionBase class, with implementation of IList interface to create a ProductCollection class which gets populated from the Products table of the NWind database. The created ProductCollection is used as a database for binding data to the DataGridView control.The data from ProductCollection class gets displayed using the DataSource property of DataGridView control. On clicking the Generate Report button, the ProductCollection class is again used to display the data of the generated report in a Viewer control. Similarly, you can display a report by binding to the DataSource property of a report.

Data from ProductCollection class displayed in DataGridView control

Generated report displayed in Viewer control

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Data\IListBinding\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Data\IListBinding\C#

Runtime Features

When you run this sample, DataGridView, which is a standard Windows Forms control displays the custom collection. To display a report with the bound custom collection, click the Generate Report button.

Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

Project Details

The IList Binding sample consists of two projects: IListBinding and IListBinding.DataLayer.

IListBinding Project

BindIListToDataGridSample

This form contains a DataGridView control, a Label control and a Generate Report button. It displays output results by binding data of a custom collection to the DataGridView control. On clicking the Generate Report button, ViewerForm displays a report bound to this custom collection.

IlistReportSample report

The report uses the ReportHeader, GroupHeader1 and Detail sections for the report output.

ReportHeader section
The ReportHeader section contains a Label that displays the title of the report.

GroupHeader1 section
The GroupHeader1 section contains nine Label controls that define the layout of the report data.

Detail section
The Detail section contains TextBox controls to display the report data. Following settings have been performed to enhance the appearance of the report output.
  • Change the background color of alternate rows
    Use the BackColor property of the Detail section (set in the Format event of the Detail section) to change the background color of each row for better visibility of the table.
  • Change the background color for selected rows
    Use the BackColor property of the Detail section (set in the Format event of the Detail section) to change the background color of selected rows. The background color changes when Reorder Level is below Ordered Units.

ViewerForm

Setting the Dock property of the Viewer control to Fill ensures that the viewer resizes along with the form at run time. Right-click the form and select View Code to see the code used to run the report and display it in the viewer.

IListBinding.DataLayer project

DataProvider Class
Implements the connection to the data base.

Product Class
Defines custom collection class.

ProductCollection Class
Implements the CollectionBase class to create a collection of Product class. The list of this collection stores data from the Products table.
See Also

How To

Bind Reports to a Data Source


LINQ

LINQ
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report > Data > LINQ
Show All Show All
Hide All Hide All

The LINQ sample demonstrates how to use LINQ in an ActiveReports report.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Data\LINQ\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Data\LINQ\C#

Runtime Features

This sample uses a LINQ Query to sort recordsets in descending order of age. The resultant recordsets are converted to an IList and used as a datasource for the report which is displayed in Viewer control.

Project Details

ViewerForm

Displays the report output results. ToList method is set in DataSource property of the report to extract objects that use LINQ.

rptLINQtoObject report

The report DataSource is a list of Person constructor created from generic class. Creates a query to sort in descending order of Age.
See Also

How To

Bind Reports to a Data Source


Unbound Data

Unbound Data
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report > Data > Unbound Data
Show All Show All
Hide All Hide All

The Unbound Data sample demonstrates how to create a dataset for a section report and use the FetchData event to populate the Fields collection to display the report unbound data.

When you run the sample, the Viewer control displays the form with four tabs, each with a different dataset binding technique. Click to select a tab, and then click the Build Report From button to create the report with unbound data.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Data\UnboundData\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Data\UnboundData\C#

Runtime Features

  • Unbound data with a DataSet
    Creates a data set from the included Northwind sample database inside the SectionReport object and uses the FetchData event to populate the internal Fields collection to display the report data.
  • Unbound data with a DataReader
    Creates a data reader from the included Northwind sample database inside the SectionReport object and uses the FetchData event to populate the internal Fields collection to display the report data.
  • Unbound data with a Text File
    Sets the Invoice.txt file as a datasource for the SectionReport object and uses the FetchData event to populate the internal Fields collection to display the report data.
  • Unbound data with a Data Array
    Creates a data array from the included sample text file inside the SectionReport object and uses the FetchData event to populate the internal Fields collection to display the report data.

Project Details

MainForm

This is the main form of the sample that uses the ActiveReports Viewer control in the bottom section of the form, and a panel docked to the top contains four tabs, each with a different data binding technique. Click to select a tab, and then click the button on the tab to display the report with unbound data.

UnboundDAInvoice report

The Invoice report for the Unbound data with a Data Array option. The report consists of the page header, group header, detail, group footer and page footer sections. The detail section contains information on the order details, the group header provides grouping data functions by using its DataField property.

For the details on the Invoice report, see the Bound Data Sample topic.

UnboundDRInvoice report

The Invoice report for the Unbound data with a DataReader option. The report consists of the page header, group header, detail, group footer and page footer sections. The detail section contains information on the order details, the group header provides grouping data functions by using its DataField property.

For the details on the Invoice report, see the Bound Data Sample topic.

UnboundDSInvoice report

The Invoice report for the Unbound data with a DataSet option. The report consists of the page header, group header, detail, group footer and page footer sections. The detail section contains information on the order details, the group header provides grouping data functions by using its DataField property.

For the details on the Invoice report, see the Bound Data Sample topic.

UnboundTFInvoice report

The Invoice report for the Unbound data with a Text File option. The report consists of the page header, group header, detail, group footer and page footer sections. The detail section contains information on the order details, the group header provides grouping data functions by using its DataField property.

For the details on the Invoice report, see the Bound Data Sample topic.

See Also

How To

Bind Reports to a Data Source

Sample ReadMe Files

Bound Data

Concepts

Grouping Data in Section Reports


XML

XML
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report > Data > XML
Show All Show All
Hide All Hide All

The XML sample displays customer order list using the XML data source. The sample demonstrates how to create a report with XML data, using a SubReport or using the XML hierarchical structure.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Data\XML\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Data\XML\C#

Runtime Features

When you run the sample, you will be asked to select between the following.

Run Customers XML Report
Demonstrates a two level Master/Detail XML Data Source. Uses a SubReport to print the orders of each customer. By selecting any of the radio buttons - Show All Data, Show Report where ID = 2301, or Show All Data with an E-Mail address, you can change the creation option of the generated report.

Customer Orders (Leveled)
Displays customer's orders by using the XML hierarchical structure. The Master/Detail is implemented using the XML hierarchy XPath selection patterns without any SubReports.

Project Details

StartForm

This is the main form of the sample. You see this form after you run the project and where you can select how to display XML data.

  • Run Customers XML Report
    Displays the customers order list by using SubReports.To bind the CustomersOrders report to the XML data source, the valid XPath expression is entered in the RecordsetPattern field on the XML tab of the Report Data Source dialog.
  • Customer Orders (Leveled)
    Displays customer's orders by using the XML hierarchical structure, which is demonstrated by the OrdersLeveled report. To bind this report to XML data, the path to the XML file is entered in the File URL field on the XML tab of the Report Data Source dialog and also the XML hierarchical structure like "../../@email" is specified in each field.

CustomersOrders report

This report embeds the srptOrders SubReport. Following settings are performed in this report.

  • Embed the SubReport control
    Places the SubReport control in the Detail section and connects it to the Orders SubReport for displaying the orders list.

OrderItems SubReport

This report binds to the Subreport control of Orders report.

Orders SubReport

This is the report with a SubReport control that is bound to the OrderItems report. Following settings are performed in this report.

  • Embed the SubReport control
    Places the SubReport control in the Detail section and connects it to the OrderItems report for displaying the list of orders.
    The Report property of the Subreport control is specified in the Orders_ReportStart event.
  • Set the XML data source included in the SubReport
    Indicates a method to retrieve the record set using the NodeList property instead of the RecordsetPattern property of the XML data source on OrderItems report at design time.
    The NodeList property of the XML data source is set in the Detail_Format event.

OrdersLeveled report

Displays the list of customer's orders. Following settings are performed in this report.

  • Groups data
    Groups data using the XPath pattern that represents the hierarchical structure of XML. DataField property of ghCustomers section and ghOrders section is set at design time.

ViewerForm

The Viewer control has its Dock property set to Fill. This ensures that the viewer resizes along with the form at run time. Right-click the form and select View Code to see the code used to run the report and display it in the viewer.

See Also

How To

Bind Reports to a Data Source

Concepts

SubReport (Section Report)


Layout

Layout
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report > Layout

Learn to create different layouts in a section report.

This section contains:

Annual Report
Demonstrates how to use subreports and nested subreports, how to modify data source properties at run time, how to use parameters in the chart control, how to create alternate row highlighting and how to use the page break control.
Category Selection
Demonstrates using the ad hoc report filter by modifying the report's SQL query at run time.
Charting
Demonstrates the use of the Chart control in both bound and unbound modes.
Cross Section Control
Demonstrates the use of the new cross section lines and boxes.
Cross Tab Report
Demonstrates using unbound data, conditional highlighting and distributing data across columns to create a cross-tab view and data aggregation.
Inheritance
Demonstrates using the method that inherits a report at runtime and design time.
Style Sheets
Demonstrates changing styles at run time to provide a different look to a same report.
Subreport
Demonstrates using subreports in an ActiveReports report.
See Also
Data
Preview
Summary
Web
WPF Viewer


Annual Report

Annual Report
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report > Layout > Annual Report
Show All Show All
Hide All Hide All

The AnnualReport sample demonstrates the use of SubReports, section report properties, and Chart control. It includes a StartupForm and AnnualReport, ProductSalesByCategory, Top10, Top10Customers, Top10Products reports.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Layout\AnnualReport\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Layout\AnnualReport\C#

Runtime features

When you run this sample, a three page report appears wherein the first page mentions the name of the trader and year of the report, the second page displays company information along with a SubReport displaying category wise sales and the third page displays data in form of charts. The AnnualReport fetches data from ProductSalesByCategory report and Top10 report and displays it in the Viewer control. The Top10 report further fetches data from Top10Customers subreport and Top10Products subreport.

Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

Project Details

StartupForm

This form contains the ActiveReports Viewer control. The Dock property of the viewer is set to Fill so that it resizes automatically with the form at run time. Right-click and select View Code to see the code that displays the AnnualReport when the form loads.

AnnualReport report

This is the main report for the project.

ReportHeader section

This report features a two-page ReportHeader section that uses a PageBreak control to separate the two pages, and breaks to the second page by setting the ReportHeader section's NewPage property to After. This report shows how you can use the BackColor and ForeColor properties of labels to create a distinctive look for your reports.

The ReportHeader section also has a SubReport control that links to the ProductSalesByCategory report in the code behind the report, in the ReportStart event.

Tip: It is recommended that you initialize reports in the ReportStart event rather than a section Format event so that a new report is not initialized every time the section runs. If the SubReport control is in a section that prints multiple times, you need to assign the report in the section Format event while still initializing in the ReportStart event.

The yellow background in the right half of the ReportHeader section below the page break control is achieved by using the Shape control and setting its BackColor property. The image to the left is a Picture control.

Detail section

The Detail section contains one SubReport control that link in the code behind the report to the Top10 reports. In most reports, the Detail section would run multiple times. In this report, the Detail section has only labels, and no bound textboxes, so it will only run once. Therefore, the Top10 report can be assigned to the SubReport control in the ReportStart event where it is initialized.

Notice that the ReportFooter section has its Height property set to 0. This is because, except for the Detail section, all sections come in pairs. In order to use the ReportHeader section, you must also have a ReportFooter section. If you do not want to use it, you can set its Height to 0.

ProductSalesByCategory report

This is the report that is assigned to the SubReport control in the ReportHeader section of the Annual Report.

Tip: This report has the ReportHeader/Footer and PageHeader/Footer sections removed. These sections are not printed within the SubReport control, so removing the sections saves processing time.

Notice also that the PrintWidth property of this report is only 2.677 inches. This is so that it fits easily within the SubReport control on the Annual Report.

This report uses the GroupHeader section to display labels for the data fields that fill the Detail section. The fields in the Detail section repeat once for each row of data in the database.

Right-click in the grey area around the report and select View Code to see the code that sets the data source for the report. Notice that the background color of the Detail section is set to yellow on every second row of data.

Top10 report

This report only has a Detail section. The Detail section contains two SubReport controls that linked to Top10Customers and Top10Products reports in code.

Top10Customers and Top10Products reports

The Top10Customers and Top10Products reports use only two sections, GroupHeader and Detail. The PrintWidth property of each report is set to 3.135 inches so that it fits into the SubReport control in the Top10 report. The GroupHeader section of each report is filled with a Chart control. The Detail section of each report has two bound TextBoxes and a Label controls. Right-click and select View Code to see the code that sets the data source for the report, passes data to the Chart control, alternates the background color of the Detail section, and sets the Text property of the label.

See Also

Concepts

SubReport (Section Report)


Category Selection

Category Selection
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report > Layout > Category Selection
Show All Show All
Hide All Hide All

The CategorySelection sample demonstrates passing a SQL string into a report at run time. It consists of a CategorySelectForm and CategoryProducts report.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Layout\CategorySelection\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Layout\CategorySelection\C#

Runtime Features

When you run this sample, a form containing a Viewer control and a ComboBox control within a panel is displayed. The Select a Product Category ComboBox at the top of the form allows the users to select the type of data they want to display in the Viewer control.

Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

Project Details

CategorySelectForm

The Viewer control fills most of the form, and a ComboBox at the top allows the user to select which data to send to the Viewer control.

To see how all of this works, right-click the form and select View Code.

  • The getCategories code populates the ComboBox with the category names.
  • The runCategoryReport code runs the report with a SQL string with the CategoryName passed in by the ComboBox selection.
  • The SelectIndexChanged event calls runCategoryReport and passes the CategoryName.

CategoryProducts

This report lists the products in the selected category, and summarizes the number of products.

ReportHeader section

This section cannot be deleted, because the related ReportFooter section is used and thus the Height property is set to 0.

PageHeader section

This section uses Label controls, Line controls and a TextBox. DataField property of txtCategory TextBox is set to CategoryName. Two Line controls and three Label controls create the report title and the column headers for this report.

Detail section

This section contains two bound TextBox controls to display each product in the selected category along with its price. Although the form passes data to the report at run time, the report's data source is set for design time use. At design time, it is easier to drag bound fields onto the report from the Report Explorer than it is to create them and set their properties. The data source also allows you to preview the report while you are designing it.

PageFooter section

This section uses the ReportInfo control to display Page N of M. In the Properties window, you can select a way to display the page number and run date using the FormatString property.

ReportFooter section

This section contains a Label control and a bound TextBox. The TextBox has the SummaryType set to GrandTotal and DataField property set to ProductName to display the total number of products in the selected category.
See Also

How To

Bind Reports to a Data Source


Charting

Charting
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report > Layout > Charting
Show All Show All
Hide All Hide All

The Charting sample provides an option to choose from various chart types and a button to display the selected chart in a Viewer control.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Layout\Charting\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Layout\Charting\C#

Runtime Features

Chart type combobox
Select from the following ChartType options.

  • 2D Bar Chart - Use this chart to compare values of items across categories.
  • 3D Pie Chart - Use this chart to display data in 3D format to depict how percentage of each data item contributes to a total percentage. Selecting this ChartType provides an option to set the Direction of rotation of 3D Pie chart to Clockwise or Counterclockwise.
  • 3D Bar Chart - Use this chart to compare values of items across categories and to display the data in a 3D format.
  • Finance Chart -Use this chart to display the stock information using High, Low, Open and Close values. The size of the wick line is determined by the High and Low values, while the size of the bar is determined by the Open and Close values.
  • Stacked Area Chart - Use this chart to demonstrate how each value contributes to the total.

Report Display button
Click this button to display the selected chart type in a Viewer control.

Note: To run rpt2DBar, rpt3DPie and rpt3DBar report, you must have access to the Nwind.mdb database. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

Project Details

ViewerForm
The ViewerForm contains the Viewer control, with the Dock property set to Fill. This enables the viewer to automatically resize along with the form. Right-click the form and select View Code to see the code used to run the report and display it in the viewer.

rpt2DBar report
Displays bar chart on a report. Retrieves the data to be displayed in a chart from Orders table in Nwind.mbd database. Settings for chart data source can be done using the Chart DataSource dialog.

rpt3DBar report
Displays 3D bar chart on a report. Retrieves the data to be displayed in a chart from Orders table in Nwind.mbd database. Generates a DataSet for the chart in ReportStart event and sets it in DataSource property of Chart control.

rpt3DPie report
Displays 3D pie chart on a report. Retrieves the data to be displayed in a chart from each of the Employees, Categories, Products, Orders, Order Details tables in Nwind.mdb database. Generates a DataTable for the chart in a ReportStart event and sets it in DataSource property of Chart control. Rotational direction of 3D pie chart can be set to Clockwise or Counterclockwise.

rptCandle report
Displays candle chart on a report. Chart data is set at design time using DataPoint Collection Editor. DataSource property is not used for this chart.

rptStackedArea report
Displays stacked area chart on a report. Chart data is set at design time using DataPoint Collection Editor. DataSource property is not used for this chart.

See Also

Concepts

ChartControl


Cross Section Controls

Cross Section Controls
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report > Layout > Cross Section Controls
Show All Show All
Hide All Hide All

This CrossSectionControls sample displays the invoice report of a company in detail. This sample uses the CrossSectionBox and CrossSectionLine controls to demonstrate the lines and display the Invoice report in a tabular form. It includes a ViewerForm with three tabs, three Viewer controls and an Invoice report to highlight several report features. Run the project and click the tab to see these features in action.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Layout\CrossSectionControls\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Layout\CrossSectionControls\C#

Runtime Features

When you run this sample, a form with three different tab options and each tab option displaying a report in a Viewer control is displayed. Click any tab option at the bottom of the form to display the selected tab feature applied to the report in a Viewer control. Select from the following tab options.

Cross Section Controls
Draws table style gridlines easily through multiple sections without any gap.

Detail RepeatToFill
The Detail RepeatToFill tab has the RepeatToFill property set to True. This ensures that the formatting (alternating purple and white rows and CrossSection controls) fills space as needed to keep the same layout between pages.

GroupFooter PrintAtBottom
The GroupFooter section has the PrintAtBottom property set to True. This pulls the GroupFooter section to the bottom of the page, just above the PageFooter section.

Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

Project Details

ViewerForm

The ViewerForm has three tabs-Cross Section Controls, Detail RepeatToFill, GroupFooter PrintAtBottom, each with an ActiveReports Viewer control on it. Right-click the form and select View Code to see the code used to change the Invoice report's section properties at run time.

Invoice Report

The Invoice report demonstrates the usage of the following features.

PageHeader section

This section contains Shape, Label and TextBox controls. The Shape control provides a border around the Order ID and Order Date fields and labels. The orderDateTextBox has the OutputFormat property set to d to display a short date. The Label controls use the BackColor, ForeColor, and Font properties to add a distinctive style to the report.

customerGroupHeader section

The CrossSectionBox control is hosted in the GroupHeader section, and spans the Detail section to end in the GroupFooter section, forming a rectangle around the details of the invoice at run time. Three of the CrossSectionLine controls are hosted in the GroupHeader section, and span the Detail section to end in the GroupFooter section, forming vertical lines between columns of invoice details at run time.

Note: If you try to drop a CrossSectionBox or CrossSectionLine control into a section other than a header or footer, the mouse pointer changes to unavailable, and you cannot drop the control.

Two of the TextBox controls use a CalculatedField in the DataField property.

Tip: In the Report Explorer, expand the Fields node, then Calculated to see all of the calculated fields. Select BillingAddress or ShippingAddress to take a look at the Formula used in the Properties window.

The Line control is used below the column header labels to draw a horizontal line across the width of the report. (It is not visible at design time unless you make the Height of the GroupHeader section larger.) The DataField property of the customerGroupHeader section is set to the OrderID field, so that the section (followed by related details and GroupFooter) prints once per order.

Detail section

This section contains four bound TextBox controls. The four TextBox controls display each row of data associated with the current GroupHeader OrderID. The OutputFormat property of the UnitPrice and Total fields is set to C to display currency. The Line control is used below the TextBox controls to draw horizontal lines across the width of the report under each row of data. (It is not visible at design time unless you make the Height of the Detail section larger.)

Right-click the report and select View Code to see the code used in the Detail Format event to create a colored bar (in this case, purple bar) report by alternating the BackColor property of the section. Click the Data Source Icon on the Detail band to view the Connection String used in the report.

customerGroupFooter section

This section has the NewPage property set to After so that a new page is printed for each OrderID (the associated GroupHeader's DataField). The Subtotal TextBox uses the following properties.

  • The DataField property uses a Total CalculatedField.
  • The SummaryFunc property is set to Sum, to add the values of the field in the detail section.
  • The SummaryGroup property is set to the name of the customerGroupHeader, to reset the summary value each time the GroupHeader section runs.
  • The SummaryRunning property is set to Group so that the value accumulates for the group rather than for the entire report or not at all.
  • The SummaryType property is set to GrandTotal.

Right-click the report and select View Code to see the code used in the customerGroupFooter Format event to calculate the value for the Grand Total TextBox, and to format it as currency.

PageFooter section

The ReportInfo control uses a FormatString property value of Page {PageNumber} of {PageCount}, one of the preset values you can use for quick page numbering.

Tip: In order to easily select a control within the report, in the Report explorer, expand the section node and select the control. The control is highlighted in the Report Explorer and on the report design surface.
See Also

Concepts

Cross Section Controls


Cross Tab Report

Cross Tab Report
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report > Layout > Cross Tab Report
Show All Show All
Hide All Hide All

The CrossTabReport sample displays hierarchical information in a cross tabular structure. This sample consists of a StartForm with an ActiveReports Viewer control and a ProductWeeklySales report.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Layout\CrossTabReport\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Layout\CrossTabReport\C#

Runtime Features

When you run the sample, a report displaying a list of weekly sales for current week, month, quarter or year for each product category is displayed in the Viewer control. The values highlighted in red represent negative values.

Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

Project Details

StartForm

The Viewer control has the Dock property set to Fill. This ensures that the viewer resizes along with the form at run time. Right-click the form and select View Code to see the code used to run the report and display it in the viewer.

ProductWeeklySales Report

This report features a number of accumulated values using summary function property settings and calculated values in the code.

The summary function displays a list of summary values only for weekly sales total in group footer without displaying the Detail section. By setting the Height property of Detail section to 0 and/or hiding the Detail section by setting Visible property to False, you can create a summary report that only displays sections other than the Detail section.

Based on the order date of Detail section data, you can determine whether it will be included in a week, month, quarter, year or previous year's quarter and set the values by sorting in unbound fields. Value of each unbound field is automatically summarized by each Field placed in the group footer section.

ReportHeader section

This section of the report features static controls including Labels, a Picture, a Line, and a Shape control. The report header prints only once on the first page of the report, thus report title, company information, and a logo are added in this section.

PageHeader section

The page header section contains static Label controls that print at the top of each page and serve as column headers for the group header sections.

ghCategory section

This group header section has the DataField property set to CategoryName. This setting, along with data sorted by the same field, produces a report grouped by category. The section contains one bound TextBox control to display the category name at the beginning of each group. The section's UnderlayNext property is set to True so that the category prints to the left of the top line of data instead of above it.

ghProduct section

Although this group header contains no controls and is hidden by setting the Height property to 0 and Visible property to False, it still performs two important functions. First, the DataField property is set to ProductName, to sort the data inside each category by product, and second, the related group footer section displays the bulk of the data for the report.

Detail section

The detail section of this report is hidden by setting the Height property to 0 and Visible property to False, but it does contain four bound fields whose values are used in the code. In the Detail Format event, the value from the hidden txtDetProduct TextBox is collected and passed to the _sProductName variable. For more information on section events, see Section Report Events.

gfProduct section

This group footer section displays the bulk of the data for the report in TextBox controls that have values passed in code, or are bound to fields from the report's Fields collection (see FetchData and DataInitialize events in the code) using the DataField property.

In the gfProduct Format event for the inner group footer section, the product name collected from the Detail Format event is passed to the txtProduct TextBox. The Value for the txtPQTDChange TextBox is calculated by subtracting the prior year's quarter-to-date sales figure from the current quarter-to-date sales figure. The BackColor of the txtPQTDChange TextBox is set to Red if the value is negative.

The total units and sales for each product is summarized using the following properties.

  • SummaryFunc: Sum (the default value)
    Adds values rather than counting or averaging them.
  • SummaryGroup: ghProduct
    Summarizes the values that fall within the current product group.
  • SummaryRunning: None (the default value)
    Ensures that this value is reset each time the product group changes.
  • SummaryType: SubTotal
    Summarizes the current group rather than a page or report total.

gfCategory section

This group footer section displays totals of the gfProduct data in TextBox controls that have values passed in code, or are bound to fields from the report's Fields collection (see FetchData and DataInitialize events in the code) using the DataField property.

The total units and sales for each category is summarized using the following properties.

  • SummaryFunc: Sum (the default value)
    Adds values rather than counting or averaging them.
  • SummaryGroup: ghCategory
    Summarizes the values that fall within the current category group.
  • SummaryRunning: None (the default value)
    Ensures that this value is reset each time the category group changes.
  • SummaryType: SubTotal
    Summarizes the current group rather than a page or report total.

PageFooter section

This section is not used, so it is hidden by setting the Height property to 0 and/or Visible property to False. Otherwise, it would print at the bottom of each page. The section cannot be deleted, because the related PageHeader section is in use.

ReportFooter section

This section is not used, so it is hidden by setting the Height property to 0 and/or Visible property to False. Otherwise, it would print once at the end of the report. The section cannot be deleted, because its related ReportHeader section is in use.

See Also

Concepts

Section Report Structure
Section Report Events
Grouping Data in Section Reports


Inheritance

Inheritance
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report > Layout > Inheritance
Show All Show All
Hide All Hide All

This sample explains the method to inherit a report at runtime and design time. The Inheritance sample solution is composed of two classes - the parent class and the child class for both inheritance at runtime and design time.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Layout\Inheritance\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Layout\Inheritance\C#

Runtime Features

When you run the sample, the report is created and displayed, providing you with the choice of two options - Inheritance Report created at RunTime and Inheritance Report created at Design Time. By clicking a button on the form, you get a report that inherits another class at runtime or at design time.

Inheritance Report created at RunTime
The rptInheritBase class is the inheritance class for the generated report when the Inheritance Report created at RunTime button is clicked on the form. The rptInheritBase class inherits the SectionReport class of the GrapeCity.ActiveReports namespace as parent class. It is possible to use DataInitialize event or FetchData event in this class and also possible to load csv file and set values for csv files. It defines the CsvPath property which gets csv file path.
The rptInheritChild class inherits the rptInheritBase class and is a class which only defines the report design. By adding the event handler for inheritance in the constructor and setting for csv file in CsvPath property, it is possible to perform rendering of data executed by event of BaseReport which is the inheritance class.

Inheritance Report created at Design Time
The rptDesignBase class is the inheritance class for the generated report when the Inheritance Report created at Design Time button is clicked on the form. The rptDesignBase class inherits SectionReport class of the GrapeCity.ActiveReports namespace as parent class. Using this class, you can place any control (ReportInfo controls etc. to display report title, page number, page count) you wish to inherit in PageHeader section and PageFooter section. The rptDesignChild class is inherited from rptDesignBase class. It only defines the design of Detail section. PageHeader section and PageFooter section use the design of rptDesignBase class which is an inherited class. DataSource setting can be performed from rptDesignChild class.

Caution: If you have not run the project even once, an error occurs when you try to open the report designers of the inherited classes rptInheritChild or rptDesignChild from the solution explorer. In case this error occurs, Build the project once before opening the report.

Project Details

ViewerForm

Creates an instance of specified report and display the report in Viewer control.

rptDesignBase

The rptDesignBase class that defines the layout of PageHeader section and PageFooter section.

rptDesignChild

The rptDesignChild designer defines the layout on Detail section and sets the value of DataField property of the controls placed in Detail section. Also set the data source to output using Report Data Source dialog.

rptInheritBase

The class to set values for data field and rendering of csv file using DataInitialize event FetchData event.

rptInheritChild

The designer that sets layout for each control and it's DataField property.
See Also

Concepts

Grouping Data in Section Reports
Section Report Structure


Stylesheets

Stylesheets
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report > Layout > Stylesheets
Show All Show All
Hide All Hide All

This sample demonstrates how you can change styles at run time to provide a different look to a same report. The project includes two reports, three reportstyles and a form containing the ActiveReports Viewer control and other controls that allow you to select any combination of styles and reports.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Layout\Stylesheets\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Layout\Stylesheets\C#

Runtime Features

Choose Report
Choose between the type of report, Categories and Product List, you want to display in the Viewer control.

Choose Style
Choose between Classic, Colored and External style sheet options to apply the style to the selected report.
Clicking the Choose button option for External style sheet displays the Open dialog that shows only *.reportstyle files, and passes the selected reportstyle path and file name string to the externalStyleSheet variable.

Run Report button
Click this button to display the selected report with the applied style in a Viewer control. Clicking this button creates an SectionReport object, assigns the selected report to it, and assigns a path and file name string to the styleSheet variable. It then assigns the style sheet to the report using the LoadStyles(styleSheet) method, runs the report, and displays it in the viewer.

Project Details

Report Style Sheets

Look in Solution Explorer to see several *.reportstyle files. These are XML-based files that hold styles that you can apply to TextBox, Label, CheckBox, and ReportInfo controls on ActiveReports. Double-click one to open it. Each reportstyle contains a set of values for each of the standard style names:

  • Normal
  • Heading1
  • Heading2
  • Heading3
  • DetailRecord
  • ReportTitle

When you select one of these style names on a report control, ActiveReports retrieves the style values, such as font size and color, from the specified style sheet when it runs the report.

For more information on creating your own style sheets, see Use External Style Sheets.

Reports

Two reports, CategoryReport and ProductsReport, are included in this sample so that you can apply styles in different ways. Open one of the reports, and select the TextBox and Label controls on it to see which style is used for each.

StyleSheetsForm

The form in this project features radio buttons for choosing the report and style you want, a Choose button that opens a standard Windows Open dialog where you can select a reportstyle, and a Run report button that runs the selected report, applies the selected reportstyle, and displays the results in the ActiveReports viewer control below.

To see how all of this works, right-click the form and select View Code.

Choose Button Click Event

This event contains code that sets up an Open dialog that shows only *.reportstyle files, and passes the selected reportstyle path and file name string to the externalStyleSheet variable.

Run Report Button Click Event

This event contains code that creates an empty SectionReport object, assigns the selected report to it, and assigns a path and file name string to the styleSheet variable. It then assigns the style sheet to the report using the LoadStyles(styleSheet) method, runs the report, and displays it in the viewer.

See Also

How To

Use External Style Sheets


SubReport

SubReport
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report > Layout > SubReport
Show All Show All
Hide All Hide All

The SubReports sample demonstrates how SubReport control can be used to generate nested and hierarchical reports.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Layout\SubReport\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Layout\SubReport\C#

Runtime Features

When you run this sample, the blank Viewer form appears, with the drop-down list of the sample reports on the top of the form. Select the report from the drop-down list to have it displayed in the Viewer control. You can select from the following options.

  • Simple SubReport - the basic sample report that demonstrates how to embed a report into another report. See rptSimpleMain and rptSimpleSub for details.
  • Nested SubReport - the report demonstrates how to nest subreports to display main, child, and grandchild levels in a report. See rptNestedParent, rptNestedChildMain and rptNestedChildSub for details.
  • Hierarchical SubReport - the main report dataset with the SHAPE statement defines the hierarchical structure of the report that uses a subreport. See rptHierarchicalMain and rptHierarchicalSub for details.
  • SubReport using the data set that contains relationship - the main report having dataset with the relation that is defined in code, in the DataSet.Relations property of the main rptDSRelationParent report. See rptDSRelationParent, rptDSRelationChildMain and rptDSRelationChildSub for details.
  • Master-detail report containing a SubReport - the sample report that demonstrates how to create a master detail report that uses a subreport. See rptMasterMain and rptMasterSub for details.
  • Bookmark in SubReport - the sample report that uses bookmarks from the subreport. See rptBookmarkMain and rptBookmarkSub for details.
  • Use a parameter in the SubReport - the sample report demonstrates how to set up a parameter in the data source of the subreport. See rptParamMain and rptParamSub for details.
  • To view the Dataset with multiple tables using SubReports - the sample report with the dataset that contains multiple data tables. The main report uses subreports to output multiple tables in a single report. See rptUnboundDSMain and rptUnboundDSSub for details.

    Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

Project Details

ViewerForm

The ViewerForm uses the ActiveReports Viewer control in the bottom section of the form, and a panel docked to the top with the drop-down list. The Viewer displays a report once it is selected from the list.

rptBookmarkMain

This report is displayed when you select the Bookmark in SubReport option in the drop-down list of the ViewerForm.

This report uses bookmarks that you can see in the Document map of the Viewer sidebar, which is displayed if you click the Toggle sidebar button in the Viewer's toolbar. See Linking in Reports and Add Bookmarks for details on using bookmarks in ActiveReports.

The report uses the PageHeader section to display the name of the report, the Detail section to display data and the PageFooter section to display the report information. The Detail section contains the Subreport control that displays data from rptBookmarkSub.

The report is bound to Nwind.mdb at runtime.

rptBookmarkSub

This report contains the Product List information for the Subreport control in rptBookmarkMain.

This report also contains bookmarks, which are setup in code in the Detail Format event.

rptDSRelationChildMain

This report displays the Product Name information and is the subreport for rptDSRelationParent.

The report uses the GroupHeader section to group data by Product Name and to display the label for the data in the Detail section, and the Detail section to display data. The Detail section contains the Subreport control that displays data from rptDSRelationChildSub.

The report is bound to the data row collection.

rptDSRelationChildSub

This report displays the Order Details information and is the subreport for rptDSRelationChildMain.

rptDSRelationParent

This report is displayed when you select the SubReport using the data set that contains relationship option in the drop-down list of the ViewerForm. This report demostrates how to bind a subreport to a dataset with a relation, defined in the DataSet.Relations property in code, and how to work with nested data relations.

The report uses the PageHeader section to display the name of the report, the groupHeader1 section to provide labels for the report data, the ghCategories to group data by Category Name, the Detail section to display data, and the PageFooter section to display the report information. The Detail section contains the Subreport control that displays the Product Name data from rptDSRelationChildMain.

The report is bound to the data row collection.

rptHierarchicalMain

This report is displayed when you select the Hierarchical SubReport option in the drop-down list of the ViewerForm.

The report uses the Detail section to display data and the PageFooter section to display the report information. The Detail section contains the Subreport control that displays data from rptHierarchicalSub.

The report is bound to Nwind.mdb at runtime.

rptHierarchicalSub

This report displays the Order information and is the subreport for rptHierarchicalMain.

rptMasterMain

This report is displayed when you select the Master-detail report containing a SubReport option in the drop-down list of the ViewerForm. This report displays orders with the general information, the order details in this report are taken from rptMasterSub.

The report uses the PageHeader section to display the name of the report, the Detail section to display data and the PageFooter section to display the report information. The Detail section contains the bound Textbox controls that display information for each order and the Subreport control that displays order details from rptMasterSub.

The report is bound to Nwind.mdb at runtime.

rptMasterSub

This report displays the Order Details information and is the subreport for rptMasterMain.

rptNestedChildMain

This report displays the Order Details information and is the subreport for rptNestedParent.

The report uses the groupHeader1 section to group the data by Orders ID, the groupHeader2 section to display static labels for the data in the Detail section, and the Detail section to display data. The groupHeader2 section contains the Subreport control that displays data from rptNestedChildSub.

The report is bound to Nwind.mdb at runtime.

rptNestedChildSub

This report displays the Contact information and is the subreport for rptNestedChildMain.

The report is bound to Nwind.mdb at runtime.

rptNestedParent

This report is displayed when you select the Nested SubReport option in the drop-down list of the ViewerForm. This report demonstrates how to set up embedded subreports to display main, child, and grandchild levels in a report.

The report uses the PageHeader section to display the name of the report, the groupHeader section to group the report data by Employee ID and to display static labels for the data in the Detail section, the Detail section that displays data on each employee, and the PageFooter section to display the report information. The Detail section contains the Subreport control that displays data from rptNestedChildMain.

The report is bound to Nwind.mdb at runtime.

rptParamMain

This report is displayed when you select the Use a parameter in the SubReport option in the drop-down list of the ViewerForm. This report demonstrates how to set up a parameter in the subreport. See Parameters for more details.

The report uses the PageHeader section to display the name of the report, the groupHeader section to group data by Country and to display static labels for the report data, the Detail section to display Contact information, and the PageFooter section to display the report information. The Detail section contains the Subreport control that displays data from rptParamSub.

The report is bound to Nwind.mdb at runtime.

rptParamSub

This report displays the Product Name information and is the subreport for rptParamMain.

The report is bound to Nwind.mdb at runtime.

The parameter is added to the sql query at runtime. Right-click rptParamSub in the Solution Explorer and select View Code to see the code implementation for the subreport parameter.

See Add Parameters in a Section Report for more details.

rptSimpleMain

This report is displayed when you select the Simple SubReport option in the drop-down list of the ViewerForm.

The report uses the PageHeader section to display the name of the report, the Detail section and the PageFooter section to display the report information. The Detail section contains the bound Textbox control to display the Category Name information and the Subreport control to display data from rptSimpleSub.

The report is bound to Nwind.mdb at runtime.

rptSimpleSub

This report displays the Product Name information and is the subreport for rptSimpleMain.

The Detail section contains the Barcode control.

rptUnboundDSMain

This report is displayed when you select the To view the DataSet with multiple tables using SubReports option in the drop-down list of the ViewerForm.

The report uses the PageHeader section to display the name of the report, the Detail section and the PageFooter section to display the report information. The Detail section contains the bound Textbox controls to display Customer ID and Company Name, and the Subreport control to display data from rptUnboundDSSub.

The report is bound to the DataSet with multiple tables at runtime. Right-click rptUnboundDSMain in the Solution Explorer and select View Code to see the code implementation for the dataset connection.

rptUnboundDSSub

This report displays the Order Detail information and is the subreport for rptUnboundDSMain.

The report uses the GroupHeader section to display static labels for Order List details in the Detail section.

See Also

How To

Embed Subreports
Bind Reports to a Data Source

Concepts

Interactive Features


Preview

Preview
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report > Preview

Learn to create an interactive section report during preview.

This section contains:

Custom Annotation
Demonstrates adding the Custom Annotation button to the report Viewer toolbar and adding a new annotation to the report.
Custom Preview
Demonstrates using Viewer control customization, export filters, rich edit control and mail-merge, parameters in the chart control, and grouping.
Hyperlinks and Drill Down
Demonstrates using hyperlinks and the viewer hyperlink event to simulate drill-down from one report to another.
Print Multiple Pages Per Sheet
Demonstrates printing a document with multiple pages per sheet by using the common PrintDocument class of the NET.Framework.
RDF Viewer
Demonstrates creating the Rdf Viewer with an ActiveReports Viewer control and an ExportForm with a Property Grid.
See Also
Data
Layout
Summary
Web
WPF Viewer


Custom Annotation

Custom Annotation
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report > Preview > Custom Annotation
Show All Show All
Hide All Hide All

The Custom Annotation sample demonstrates how to add the Custom Annotation button to the Viewer toolbar and depicts the method to add any annotation (seal image in this case) to the report. Only one annotation can be used per page.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Preview\CustomAnnotation\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Preview\CustomAnnotation\C#

Runtime Features

When you run the sample, the report appears in the Viewer control. The Viewer control toolbar contains the Custom Annotation button that opens the report annotation.

Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

Project Details

AnnotationForm

Add Custom Annotation button in Form_Load event. The behavior on clicking the Custom Annotation button is mentioned in the description of the Click event.

Annotation report

ghOrderID section
Product order receipt is grouped according to OrderID.

Detail section
Use RepeatToFill property to output empty rows till the end and perform page break group wise.

GFOrderID section
This group footer section displays the bulk of the data for the report in TextBox controls that have values passed in code, or are bound to fields from the report's Fields collection (see FetchData and DataInitialize events in the code) using the DataField property. The total units and sales for each product are summarized using the following properties:

  • SummaryFunc: Sum (the default value) adds values rather than counting or averaging them.
    Caution: SummaryFunc has no effect unless the SummaryType property is set to either SubTotal or GrandTotal.
  • SummaryGroup: ghOrderID summarizes the values that fall within the current order id.
  • SummaryRunning: None (the default value) ensures that this value is reset each time the order id changes.
  • SummaryType: SubTotal summarizes the current group rather than a page or report total.

Resources folder

This folder holds the icon used for adding annotation (seal image) to the report.

Resource1.resx

This file contains the string for the message box that appears when Custom Annotation button is clicked again to add the annotation.
See Also

Concepts

Annotations

How To

Add and Save Annotations


Custom Preview

Custom Preview
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report > Preview > Custom Preview
Show All Show All
Hide All Hide All

The Custom Preview sample demonstrates how to create various type of reports, customize the Viewer toolbar, load or save a report document file (RDF). The sample also provides six types of export options and demonstrates the use of print settings.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Preview\CustomPreview\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Preview\CustomPreview\C#

Runtime Features

The Custom Preview sample consists of the parent CustomPreviewForm with menus, the child PreviewForm with the Viewer control, the ExportForm with the Properties window, the Reports folder, and the Resources folder.

When you run the sample, the CustomPreviewForm appears. It has three menus - File, Reports and Window.

The File menu allows you to perform the following operations.

  • Open: Loads the report document file (RDF).
  • Spreaduilder API: Creates an Excel file by the Spreadbuilder API.
  • Export... This option is available with an opened report. Exports a report to six formats - HTML, Excel, Text, PDF, RTF, and TIFF.
  • Save: This option is available with an opened report. Saves the opened report in the report document format (RDF).
  • Exit: Closes the Custom Preview Sample form.

The Reports menu allows opening the sample reports by selecting them from the list. The available reports are described in detail below under Reports folder.

The Window menu allows navigating between the opened reports.

Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data. If you are unable to access the data files in the sample, create the above folder to place all the data files or change the reference path to the data files within the folder according to your environment.

Project Details

CustomPreviewForm

This is the main form that gets displayed when you run the sample.

The CustomPreviewForm has its IsMdiContainer property set to True. This ensures that the child PreviewForm is embedded into the parent CustomPreviewForm.

This form has a menu bar, mnuMain, with three menus: File, Reports, and Window. The MergeType property of the File menu is set to MergeItems, which adds the menu items from any child PreviewForms to the CustomPreviewForm. The form also has two dialogs: dlgOpenFile, and dlgPrint.

Right-click the form and select View Code to see how reports selected from the Reports menu are run and passed to the PreviewForm, using the ShowReport method.

PreviewForm

This is the form that gets displayed when you select a report in the Reports menu of the main Custom Preview Sample form (CustomPreviewForm).

The PreviewForm has the ActiveReports Viewer control with it Dock property set to Fill. This ensures that the viewer resizes along with the form at run time.

The form has the File menu with its MergeType set to MergeItems. This ensures that the File menu on the CustomPreviewForm displays the Export, Save menu items when a report is open. The form also has one dialog: dlgPrint.

Right-click the form and select View Code to see how two custom buttons are added to the toolbar in the PreviewForm_Load event. The ToolClick event of the Viewer calls the SaveDocument and ExportDocument functions for the new buttons. The menu item click events call the same functions for the related menu items.

The SaveDocument function opens the dialog dlgSave, while the ExportDocument function opens the new ExportForm.

ExportForm

This is the form that gets displayed when you select Export in the File menu of the opened report. In the Export form, you can select from the following export file format options.

  • HTML
  • Excel
  • Text
  • PDF
  • RTF
  • TIFF

The Export Report Document form opens by the ExportDocument function on the PreviewForm. The form features the Export Format combo box, cboExportFormat, that populates the PropertyGrid control based on the selected item. The export types are added to cboExportFormat via the Items (collection) property.

Right-click the form and select View Code to see how the property grid control's SelectedObject is set to the selected export in the cboExportFormat SelectedIndexChanged event. This ensures that only the properties related to each export type are displayed in the Properties window.

See the btnOK Click event for the code that exports the report to the selected file name and format, and the btnSaveFile Click event for the code that opens the Save dialog.

Resources folder

This folder contains the icons that are used in the File menu of the Custom Preview Sample form.

Reports folder

The Reports folder contains the following reports that demonstrate the Viewer and Export features.

Catalog

The Catalog report uses the PageBreak control and the NewPage property to create a cover at the beginning and an order form at the end of the catalog. It uses grouping to list products by Category.

ReportHeader section

At the top of the ReportHeader section, the Picture, Line, and Label controls are used to create a static cover page for the catalog. The PageBreak control allows a second page of static labels to be set in the same section. Setting the section's NewPage property to After ensures that the report breaks to a new page before rendering the next section. The ReportHeader section prints once per report.

PageHeader section

This section is not in use, so the Height property is set to 0. This section cannot be deleted because its related PageFooter section is in use.

ghCategoryName section

This GroupHeader section has its DataField property set to CategoryName. This, along with sorting the data by the same field, ensures that all details for one category are printed before the report moves on to the next category. Also, the section's GroupKeepTogether property is set to All. This causes ActiveReports to attempt to print the group header, related details, and the group footer together on one page.

The controls in this section include two bound TextBox controls and a bound Picture control, along with a row of labels to serve as column headers for the Detail section to follow.

Detail section

Click the gray report DataSource icon on the Detail section band to open the Report Data Source dialog, where you can see the Connection String and SQL Query that provide data for the bound fields.

The Detail section has four bound TextBox controls. Select a textbox and go to the DataField property in the Properties window to see a bound data field for this textbox. The UnitPrice textbox also uses the OutputFormat to display the data in the currency format. This section prints once for each row of data.

gfCategoryName section

This section is used only to render a horizontal Line control after each category grouping is completed.

PageFooter section

This section is used to display the document title and the page number at the bottom of each page.

ReportFooter section

This section has the NewPage property set to Before to ensure that it begins at the top of a new page.

The Label, Shape, and Line controls are used to create the static order form layout in this page-long report section that prints once at the end of the report.

CustomerLabels

Detail section

Click the gray report DataSource icon on the Detail section band to open the Report Data Source dialog, where you can see the Connection String and SQL Query that provide data for the bound fields.

The Detail section has bound TextBox and Label controls. Select a textbox and go to the DataField property in the Properties window to see a bound data field for this textbox.

The ColumnCount property is set to 2, which allows the report to display the labels in 2 columns. The ColumnDirection property is set to AcrossDown to have labels print in the left-to-right order instead of the top-to-bottom order.

EmployeeProfiles

PageHeader section

This section is used to display the document title and the text description at the top of each page.

Detail section

Click the gray report DataSource icon on the Detail section band to open the Report Data Source dialog, where you can see the Connection String and SQL Query that provide data for the bound fields.

The Detail section has a bound Picture control, bound TextBox and Label controls. Select a textbox and go to the DataField property in the Properties window to see a bound data field for this textbox.

This report uses bookmarks that you can see in the Document map of the Viewer sidebar, which is displayed if you click the Toggle sidebar button in the Viewer's toolbar. Right-click the report and select View Code to see how to use the unbound Textbox control and the Add.Bookmark method in the Detail_BeforePrint event to set the bookmarks in this report. See Linking in Reports and Add Bookmarks for details on using bookmarks in ActiveReports.

The KeepTogether property is set to True to print the section content on a single page.

PageFooter section

This section is not in use, so the Height property is set to 0. This section cannot be deleted because its related PageHeader section is in use.

EmployeeSales

ReportHeader section

This section contains Label controls, a bound Textbox control and a bound Chart control to display the title, total sales and the bar graph representation of the data.

GroupHeader1 section

The controls in this section include two Label controls to serve as column headers for the Detail section to follow.

Detail section

Click the gray report DataSource icon on the Detail section band to open the Report Data Source dialog, where you can see the Connection String and SQL Query that provide data for the bound fields.

The Detail section has bound TextBox and Label controls. Select a textbox and go to the DataField property in the Properties window to see a bound data field for this textbox.

GroupFooter1 section

This section is not in use, so the Height property is set to 0. This section cannot be deleted because its related GroupHeader1 section is in use.

Report Footer section

This section is not in use, so the Height property is set to 0. This section cannot be deleted because its related ReportHeader section is in use.

Invoice

PageHeader section

This section contains a Picture control with a logo, a number of Label controls, and two bound TextBox controls. The TextBoxes are bound using the DataField property in the Properties window, and the date is formatted using the OutputFormat property.

ghOrderID section

The DataField property of this section is also set to OrderID. This allows subtotal summary functions in the related GFOrderID section to calculate properly.

This section contains a number of labels and bound text boxes, as well as two Line controls.

The KeepTogether property is set to True to print the section content on a single page.

Detail section

Click the gray report DataSource icon on the Detail section band to open the Report Data Source dialog, where you can see the Connection String and SQL Query that provide data for the bound fields.

This section contains bound TextBox controls. These controls render once for each row of data found in the current OrderID before the report moves on to the Footer sections.

GFOrderID section

The NewPage property of this section is set to After. This causes the report to break to a new page and generate a new invoice after this section prints its subtotals.

This section contains several labels and several TextBoxes. Two of the TextBox controls use the following properties to summarize the detail data: SummaryFunc, SummaryGroup, and SummaryType. For more information, Create a Summary Report.

The Total TextBox does not use the DataField property or any of the summary properties, or even any code. Go to the Script tab at the bottom of the report to see how this TextBox is set.

The KeepTogether property is set to True to print the section content on a single page.

PageFooter section

This section has one simple Label control that contains a "Thank you" note. For more information about report sections and the order in which they print, see Section Report Structure and Section Report Events.

Letter

PageHeader section

This section contains the Picture control with a logo, the Line control, and the Label controls.

The CanGrow property is set to False to indicate that the controls are to be clipped to the section's height.

ghCustomerID section

This section has its DataField property set to CustomerID. This ensures that all details for one customer id are printed before the report moves on to the next customer id.

The section contains the Label controls, the RichTextBox control, and bound TextBox controls.

The RichTextBox control allows to create a mail-merge report where field place holders are replaced with values (merged) at run time. Right-click the report and select View Code to see how to use the ReplaceField method in the BeforePrint event to calculate total fields in the RichTextBox control.

The CanShrink property is set to True to have the section shrink to fit its controls.

The KeepTogether property is set to True to print the section content on a single page.

Detail section

Click the gray report DataSource icon on the Detail section band to open the Report Data Source dialog, where you can see the Connection String and SQL Query that provide data for the bound fields.

This section contains three bound TextBox controls.

The KeepTogether property is set to True to print the section content on a single page.

gfCustomerID section

This section contains two Label controls that display the note at the end of each letter to a customer.

The NewPage property is set to After to ensure that the report breaks to a new page before rendering the next section.

PageFooter section

This section contains the Label control that displays the address of the company.

The CanGrow property is set to False to indicate that the controls are to be clipped to the section's height.

See Also

How To

Customize the Viewer Control

Concepts

Section Report Events


Hyperlinks and DrillThrough

Hyperlinks and DrillThrough
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report > Preview > Hyperlinks and DrillThrough
Show All Show All
Hide All Hide All

The Hyperlinks and DrillThrough sample consists of three reports and a ViewerForm. The reports use the Hyperlink event of the Viewer control to pass a value from the Hyperlink property of a TextBox control to a Parameter value in a more detailed report.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Preview\Hyperlinks and DrillThrough\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Preview\Hyperlinks and DrillThrough\C#

Runtime Features

When you run this sample, a report displaying bound fields with a link created on CustomerID is displayed in a Viewer control. DrillThrough feature allows users to navigate to another report containing detailed data. Clicking the CustomerID hyperlink takes you to the second report which displays detailed information of the selected CustomerID. On further clicking the OrderID hyperlink the third report displaying the details of the selected order is opened in the Viewer. This feature enables the users to systematically go through the detailed data of the desired CustomerID.

Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

Project Details

ViewerForm

This form contains only the Viewer control with its Dock property set to Fill. This ensures that the viewer resizes along with the form at run time.

Right-click the form and select View Code to see the code that allows multiple ViewerForms to display for the reports, and see the Form Load event for the code that loads the main report into the viewer.

See the Viewer Hyperlink event for the code that collects a string value from the Hyperlink property of the clicked TextBox on the main report and passes it into the customerID Parameter of the report DrillThrough1, or collects a numeric value and passes it to the orderID Parameter of the report DrillThrough2. This code then runs the report with the parameter value and displays it in another instance of the ViewerForm.

DrillThroughMain Report

The main report that is loaded in the ViewerForm by default uses the PageHeader and Detail sections.

PageHeader section

This section contains three Label controls to serve as column headers for the details, and a CrossSectionBox control. For more information, see Cross Section Controls.

Detail section

The Detail section has the BackColor property set to Thistle, and its RepeatToFill property set to True. This ensures that the background color reaches all the way to the bottom of the page when there is not enough data to fill it.

Right click on the form, select View code to see the Connection String and SQL Query that provide data for the bound fields.

The Detail section has three bound TextBox controls that display a list of customer information. Select CustomerID and you will see that the HyperLink property is not set in the Properties window. To see the code that assigns the data from the TextBox to its HyperLink property, right-click the report and select View Code. The HyperLink property is set in the Detail BeforePrint event.

Note: This hyperlink does not work in Preview mode, because it relies on code in the ViewerForm to pass the value to DrillThrough1 report's parameter.

PageFooter Section

This section is not in use, so it is hidden by setting the Visible property to False. This section cannot be deleted, because its related PageHeader section is in use.

DrillThrough1 Report

This report looks similar to the DrillThroughMain report, but the main difference is that it has a CustomerID parameter in its SQL Query.

GroupHeader section

Since this report only displays order information for the CustomerID from the clicked hyperlink, the PageHeader section could have been used, but this report uses the GroupHeader section. To make this section print at the top of each page, the RepeatStyle property is set to OnPage. This section consists of five label controls to serve as column headers for the Detail section and a CrossSectionBox control.

Detail section

Right click on the form, select View code to see the parameter in the SQL Query that collects the value from the ViewerForm.

Parameters in SQL Queries are denoted by the <% and %> symbols that trigger ActiveReports to add them to the report's Parameters collection. For more information, see Parameters.

The Detail section has five bound TextBox controls that display a list of order information for the customer. Select OrderID and you will see that the HyperLink property is not set in the Properties window. To see the code that assigns the data from the TextBox to its HyperLink property, right-click the report and select View Code. The HyperLink property is set in the Detail BeforePrint event.

GroupFooter section

This section is not in use, so it is hidden by setting the Visible property to False. This section cannot be deleted, because it is related GroupHeader section is in use.

DrillThrough2 Report

Like DrillThrough1, this report has a parameter in a SQL Query, but unlike the other two reports, this one has no hyperlink. It displays order details for the OrderID value passed into it from the clicked hyperlink in DrillThroguh1.

GroupHeader section

Like in the previous report, this section contains Label controls to serve as column headers for the details, and a CrossSectionBox control.

Detail section

Right click on the form, select View code to see the parameter in the SQL Query that collects the value from the ViewerForm.
See Also

How To

Create Common Section Reports
Add Hyperlinks

Concepts

Section Report Events


Print Mutliple Pages per Sheet

Print Mutliple Pages per Sheet
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report > Preview > Print Mutliple Pages per Sheet
Show All Show All
Hide All Hide All

The PrintMultiplePagesPerSheet sample demonstrates how you can print a document with multiple pages per sheet using the common PrintDocument class or PrintOptions class from .NET Framework. This sample project consists of the　PrintMultiplePagesForm and the Invoice report.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Preview\PrintMultiplePagesPerSheet\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Preview\PrintMultiplePagesPerSheet\C#

Runtime features

When you run this sample, you will see the PrintMultiplePagesForm with the Invoice report. On this form, you can select the number of pages to be printed on each sheet using the Select Numer of Pages to Print on One Sheet ComboBox. You can also select from PrintMultiple Pages using PrintOptions API and PrintMultiple Pages using Custom Code tabs options and click the Print button on each of these tab to print the selected number of pages in one sheet.

Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

Project details

PrintMultiplePagesForm

This form contains the ActiveReports Viewer control. The Dock property of the viewer is set to Fill so that it resizes automatically with the form at run time. The top section of Viewer contains a panel in which two tabs, ComboBox control, Label and two Print buttons are placed. ComboBox control lets you select the number of pages per sheet (2,4 or 8)and the Print button in PrintMultiple Pages using PrintOptions API and PrintMultiple Pages using Custom Code tab, print the selected number of pages in one sheet. The form also has two dialogs - dlgPrint and PrintDocument which assist in displaying the Print dialog box and printing the document.

Right-click and select View Code to see the code that displays the Invoice report when the form loads. Also the code demonstrates the different ways of printing a document - the Print button in PrintMultiple Pages using Custom Code tab uses the PrintDocument class and the Print button in PrintMultiple Pages using PrintOptions API tab uses the PrintOptions class.

Invoice report

The Invoice report uses a PageHeader section, GroupHeader section, Detail section, GroupFooter section as well as a PageFooter section to display data in a Label control.

PageHeader section

This section contains a Picture control to display the logo along with several Label and TextBox controls to display company name, order date, address, Order number etc.

ghOrderID section

The DataField property of this section is set to OrderID. This allows subtotal summary functions in the related GFOrderID section to calculate properly. This section contains a number of labels and bound TextBox controls, as well as two Line controls.

Detail section

This section contains bound TextBox controls. These render once for each row of data found in the current OrderID before the report moves on to the Footer sections.

GFOrderID section

The NewPage property of this section is set to After. This causes the report to break to a new page and generate a new invoice after this section prints its subtotals.

This section contains several Label and TextBoxe controls. Subtotal and Freight TextBox use the following properties to summarize the detail data: SummaryFunc, SummaryGroup, and SummaryType. However, the Total TextBox does not use the DataField property or any of the summary properties, or even any code. To find the functionality of this TextBox, in the design view, click the Script tab at the bottom of the report.

PageFooter section

This section has one simple Label control. The CanGrow property is set to False.
See Also

How To

Print Multiple Copies, Duplex and Landscape
Use Advanced Printing Options


RDF Viewer

RDF Viewer
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report > Preview > RDF Viewer
Show All Show All
Hide All Hide All

The RDF Viewer sample is used to view RDF files. It consists of an RdfViewerForm with an ActiveReports Viewer control and an ExportForm with a Property Grid. The sample also contains a RDFs folder of saved reports.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Preview\RDFViewer\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Preview\RDFViewer\C#

Runtime features

When you run the sample, a Viewer control containing File and View menu appears on the top. Following options are available in given menus.

File menu

  • Open: Loads any of the six given RDF files
  • Export: Exports file to HTML, Excel, Text, PDF, RTF or TIFF format
  • Print: Prints the loaded RDF file
  • Exit: Closes the application

View menu

  • TocView: Shows or hides all the report pages as thumbnails in the left pane
  • Toolbar: Shows or hides Viewer toolbar

Project Details

ExportForm

This form contains a Combobox to collect the user-selected export format, a property grid to display properties for the selected format, and an OK button to export the report to the selected format. It also contains a Save dialog. Right-click the form and select View Code to see how this is done.

The Export Format ComboBox's SelectedIndexChanged event sets the cmbExportFormat variable to the selected export type. The cmbExportFormat variable is picked up in the OK button Click event, and then the report Document is pulled from the Viewer and exported to the selected format.

RdfViewerForm

This form contains an ActiveReports Viewer control with its Dock property set to Fill. This ensures that the viewer resizes along with the form at run time. It also contains a MenuStrip and an OpenFile dialog. To see the code implementation of this form, right-click the form and select View Code.

The Click event of the Open option in the File menu filters to show only RDF files and opens the Open File dialog to the RDFs folder. The dlgOpenFile_FileOK event loads the selected RDF file into the Viewer control. The Click event of the Export option in the File menu opens a new ExportForm. For more information on the Viewer control, see Using the Viewer.

RDFs folder

An RDF file is a static copy of a report saved to the native Report Document Format. This can be loaded into the Viewer control without running it or accessing data. For more information, see Save and Load RDF Report Files.

The following five reports are included in this sample:

  • Catalog.rdf
  • Customer Labels.rdf
  • Employee Profiles.rdf
  • Employee Sales.rdf
  • Invoice.rdf
  • Letter.rdf
See Also

Getting Started

Windows Forms Viewer


Summary

Summary
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report > Summary

Learn to display summarized data in a section report.

This section contains:

Calculated Fields
Demonstrates using an unbound data field to perform a calculation which can then be aggregated.
Data Field Expressions
Demonstrates the use of expressions in the DataField properties of controls.
See Also
Data
Layout
Preview
Web
WPF Viewer


Calculated Fields

Calculated Fields
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report > Summary > Calculated Fields
Show All Show All
Hide All Hide All

The CalculatedFields sample demonstrates the use of calculated fields in a report, where the field values are calculated in code. A custom field is added to the Fields collection in the DataInitialize event and the field value is calculated in the FetchData event.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Summary\CalculatedFields\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Summary\CalculatedFields\C#

Runtime Features

When you run the sample, a report displaying ProductID, UnitPrice, Quantity, Discount, Extended Price and Total value for each OrderID is displayed in the Viewer control. The Extended Price value is a calculated field that displays the result of the formula specified in FetchData event.

Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

Project Details

StartForm

The Viewer control has the Dock property set to Fill. This ensures that the viewer resizes along with the form at run time. Right-click the form and select View Code to see the code used to run the report and display it in the viewer.

OrdersReport

The OrdersReport uses a GroupHeader section, a Detail section and a GroupFooter section as well as a Label in the PageFooter section to display data.

Note: Except for the Detail section, all sections come in header and footer pairs. Unused sections have their Height properties set to 0 and their Visible properties set to False.

ghOrderID section

This group header section has the DataField property set to OrderID. This setting, along with data sorted by the same field, displays a report grouped by OrderID. The section contains one bound TextBox control to display the OrderID at the beginning of each group.

Detail section

Detail section of this report contains 5 bound TextBox controls that render for each row of data of the OrderID.

gfOrderID section

This group footer section displays total of the gfOrderID data in TextBox controls that have values passed in code, or are bound to fields from the report's Fields collection using the DataField property. The total extended price for the OrderID is summarized using the following properties:

  • SummaryFunc: Sum (the default value)
    Adds values rather than counting or averaging them.
  • SummaryGroup: ghOrderID
    Summarizes the values that fall within the current OrderID group.
  • SummaryRunning: Group
    Calculates a running summary (each value is the sum of the current value and all preceding values) within the same group level.
  • SummaryType: SubTotal
    Summarizes the current group rather than a page or report total.

PageFooter section

The page footer section contains a static Label control that prints at the bottom of each page and contains the note on the number of pages in the report.
See Also

How To

Add Field Expressions


Data Field Expressions

Data Field Expressions
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Section Report > Summary > Data Field Expressions
Show All Show All
Hide All Hide All

The DataFieldExpressions sample demonstrates the use of data field expressions for simple calculations within the same section of the unbound report using known Fields collection values. These data field expressions cannot be used with the built in summary functions of ActiveReports 10.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Summary\DataFieldExpressions\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Section Reports\Summary\DataFieldExpressions\C#

Runtime Features

When you run the sample, the DataFieldExpressionsReport appears in the Viewer control. The DataFieldExpressionsReport displays data, using the Fields collection from the OrderDetail class.

The report data under ExtendedPrice is calculated by the data field expression, specified in the DataField property of the txtExtendedPrice TextBox at the design time.

Project Details

StartForm

The Viewer control has its Dock property set to Fill. This ensures that the viewer resizes along with the form at run time. Right-click the form and select View Code to see the code used to run the report and display it in the viewer.

DataFieldExpressionsReport

The DataFieldExpressionsReport is an unbound report that uses the field values from the OrderDetail file for displaying the report data.

PageHeader section

This section contains one Label control with the note text and four labels with the names of the report data fields.

Detail section

This section contains four textboxes that use the Fields collection values to display the report data.

The DataField property of the txtExtendedPrice textbox in the Detail section demonstrates how to format your data field expression.

OrderDetail

This file contains the class with data that is used in the fields of the report. When the report is run, the values of these fields are used to display data of the report.

The field values are bound to the fields in the DataInitilize event and the data is bound to the field values in the FetchData event of the DataFieldExpressionsReport.

See Also

How To

Add Field Expressions


Standard Edition Web

Standard Edition Web
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > Standard Edition Web
Show All Show All
Hide All Hide All

The Standard Edition Web sample demonstrates a method to view a report at client side in HTML or PDF format. Application structure consists of ASP.NET website, using which the report is streamed to the client as HTML or PDF. This sample describes custom exporting without the Pro Edition server controls or RPX handlers as well as running reports on the server. The PDF and HTML exports allow you to manually control exporting by writing a little code in ASP.NET language. Steps explained in this sample can be used for both Standard and Professional editions.
Note: Before running this sample, in the Solution Explorer, click the Licenses.licx file and then, from the Build menu, select Build Runtime License. Please see To license Web Forms projects made on the trial version for details.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Standard Edition Web\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\Standard Edition Web\C#

Runtime Features

When you run the sample, the Default.aspx page appears in your browser. This page provides two links to other reports that demonstrate custom PDF or HTML export options.

Clicking the Custom Exporting PDF Example option opens the Invoice report and clicking Custom Exporting HTML Example option opens NwindLabels report in the Default.aspx page.

Note: To run this sample, you must have access to the Nwind.mdb. A copy is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb. If you are unable to access the data files in the sample, create the Data folder and place all the data files to this folder, or change the reference path to the data files within the folder according to your environment.

Project Details

Reports folder

The Reports folder contains two rpx reports - the Invoice report and the NwindLabels report.

Invoice Report

The Invoice report uses three GroupHeader sections, a Detail section and a GroupFooter section as well as a label in the PageFooter section to display data.

Note: Except for the Detail section, all sections come in header and footer pairs. Unused sections have their Height properties set to 0 and their Visible properties set to False.

ghOrderHeader section

The DataField property of this section is set to OrderID. This setting, in conjunction with data ordered by the OrderID field, causes the report to print all of the information for one order ID value, including all of the related details and footers, before moving on to the next order ID. For more information on grouping, see Grouping Data in Section Reports.

This section also contains a Picture control, a number of Label controls, and two bound TextBox controls. The TextBoxes are bound using the DataField property in the Properties window, and the date is formatted using the OutputFormat property.

ghOrderID section

The DataField property of this section is also set to OrderID. This allows subtotal summary functions in the related GFOrderID section to calculate properly.

This section contains a number of labels and bound text boxes, as well as two Line controls.

ghTableHeader section

This section contains only labels for the data to follow in the Detail section.

Detail section

This section contains bound TextBox controls. These TextBoxes render once for each row of data found in the current OrderID before the report moves on to the GroupFooter sections.

GFOrderID section

The NewPage property of this section is set to After. This causes the report to break to a new page and generate a new invoice after this section prints its subtotals.

This section contains several labels and several TextBoxes. Two of the TextBox controls use the following properties to summarize the detail data: SummaryFunc, SummaryGroup, and SummaryType. For more information, Create a Summary Report.

The Total TextBox does not use the DataField property or any of the summary properties, or even any code. To find the functionality of this TextBox, in design view, click the Script tab at the bottom of the report.

PageFooter section

This section has one simple Label control. For more information about report sections and the order in which they print, see Section Report Structure and Section Report Events.

NwindLabels Report

TheNwindLabels report only uses the Detail section to display the report data.

Note: Except for the Detail section, all sections come in header and footer pairs. Unused sections have their Height properties set to 0 and their Visible properties set to False.

Detail section

This section contains bound TextBox controls and Label controls. This section prints 30 labels per 8½ x 11 sheet.

The Detail section uses the CanGrow property set to False to maintain the label size and the ColumnCount, ColumnDirection, and ColumnSpacing properties to accommodate multiple labels in a single page.

ActiveReports.ReportService.asmx

The report web service required for the proper functioning of the Web Viewer. The ActiveReports.ReportService.asmx is added automatically to the project when you place the WebViewer control on the form. You can also add this service by using Add New Item in the Visual Studio Project menu.

For the information on how to use the WebViewer control, see Getting Started with the Web Viewer.

CustomExportHtml.aspx

This Web form is displayed by clicking the Custom Exporting HTML Example option on the Default.aspx page.

In CustomExportHtml.aspx, report is outputted to the ReportOutput folder using the CustomHtmlOutput class and the exported HTML is displayed in the browser. The CustomHtmlOutput class implements the required IOutputHtml in the HTML export and saves the output results to a file with a unique name.

Note: This sample requires write permissions to the ReportOutput folder that is located in the web samples directory.

CustomExportPdf.aspx

The Web form is displayed by clicking the Custom Exporting PDF Example option on the Default.aspx page.

In CustomExportPdf.aspx, the report is exported to memory stream and then outputted in the browser.

Note: This sample requires write permissions to the ReportOutput folder that is located in the web samples directory.

Default.aspx

This is the main Web form of the sample that shows the introductory text and links to other sample pages that demonstrate the following web features.

  • Custom Exporting PDF Example - This link opens the Invoice report in the PDF Reader by exporting it to memory stream and then outputting it in the browser.
  • Custom Exporting HTML Example - This link opens the NWindLabels report. This report is outputted to the ReportOutput folder by using the CustomHtmlOutput class and the exported HTML is displayed in the browser.

Web.config

This configuration file contains the httpHandlers that allow ActiveReports to process reports on the Web.

Note that you need to manually update version information here when you update your version of ActiveReports.

See Also
Active Reports Web Pro

Walkthroughs

Address Labels

Getting Started

Getting Started with the Web Viewer


WPF Viewer

WPF Viewer
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Samples > WPF Viewer
Show All Show All
Hide All Hide All

The WPF Viewer samples demonstrates the use of WPF Viewer and its options to view the rdlx and rpx reports.

Sample Location

Visual Basic.NET

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\WPF Viewer\VB.NET

C#

<User Folder>\Documents\GrapeCity Samples\ActiveReports 10\WPF Viewer\C#

Runtime Features

When you run the sample, MainWindow.xaml containing the WPF Viewer, Select Report ComboBox, Preview button and Add Custom Button CheckBox appears.

Select Report

In the Select Report ComboBox, you can select from a list of 6 sample reports. The ComboBox contains the following reports - Catalog.rdlx, EmployeeSales.rdlx, Invoice1.rdlx, Invoice2.rpx, LabelReport.rpx, and PaymentSlip.rpx.

Preview

The Preview button opens the report selected in Select Report ComboBox in the WPF Viewer.

Add custom button

The Add custom button CheckBox demonstrates the customization options of the WPF Viewer. To see the About Us custom button appear in the WPF Viewer toolbar, select the Add custom button CheckBox and click the Preview button. To remove the About Us custom button from the WPF Viewer toolbar, click to clear the Add custom button CheckBox and then click the Preview button.

Note: Preview button and Add custom button CheckBox are only enabled when a report is selected from the Select Report ComboBox.

Project Details

Reports folder

The folder contains the following reports.

Catalog.rdlx: This is a sample layout for the product catalog. This report uses multiple page layouts to create a catalog. The layout of this report is spread over 4 pages, which appear one after another at runtime. Page1 and Page2 layouts simply display introductive text. The layout on Page3 contains a List data region with TextBox controls and a Table to display product details for each product category. The List is grouped by the CategoryID field to filter products by their category. The layout on Page4 uses Textbox, Shape and Line controls to create a Order Form, which a user is to fill manually.

EmployeeSales.rdlx: This is a sample layout to display sales by each employee for the year 1997. The Chart control is used to display a graphical analysis of sales by each employee and the Table data region lists down the exact numbers.

Invoice1.rdlx: This report uses a BandedList and few TextBox controls to create the Invoice layout for displaying customer transactions. Both page and the BandedList control are grouped by the OrderID field. Texboxes in the footer section of the BandedList control use the Sum function to display the total of the transactions. For detailed information on the Invoice2.rpx report, see the Reports Gallery Sample.

Invoice2.rpx: This is a sample layout for the invoice report. The report page is grouped by the EstimateID field. Sum function is used to display the GrandTotal of all transactions. For detailed information on the Invoice2.rpx report, see the Reports Gallery Sample.

LabelReport.rpx: This report displays the tack seal, which is commonly used in postal services. This multi-column report uses the customer barcode that is bound to the data using the DataField property. For detailed information on the LabelReport.rpx report, see the Reports Gallery Sample.

PaymentSlip.rpx: This report displays the invoice payment slip with the GS1-128 barcode that is used for payment services in convenience stores. GS1-128 is the convenience store barcode, formerly called UCC/EAN-128. For detailed information on the PaymentSlip.rpx report, see the Reports Gallery Sample.

DefaultWPFViewerTemplates.Xaml

The DefaultWPFViewerTemplates.xaml is used for the WPF Viewer customization. For steps on the WPF Viewer customization, see the WPF Viewer walkthrough.

MainWindow.xaml

The MainWindow.xaml is displayed when you run the sample. It contains the WPF Viewer, the Select Report ComboBox, the Preview button and the Add custom button CheckBox.

The code behind of MainWindow.xaml.vb (or .cs), handles the display of RDLX and RPX reports in the WPF Viewer and the customization of the WPF Viewer application.

MyCommand

This class contains the text that is displayed when you click the About Us custom button in the WPF Viewer toolbar.

See Also

Getting Started

WPF Viewer

Walkthroughs

WPF Viewer


Walkthroughs

Walkthroughs
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs

The Walkthroughs section of the User Guide provides you with step-by-step tutorials that you can follow as you create projects in Visual Studio. These walkthroughs cover the key features of Page Reports, RDL Reports and Section Reports in different scenarios. The walkthroughs progress from basic through advanced for Standard and Professional Editions of ActiveReports.

This section contains information about:

Page Report/RDL Report Walkthroughs
Learn the dynamic features through easy to implement scenarios for Page Report and RDL Report.
Section Report Walkthroughs
Use the walkthroughs under this section to understand key features of a section report through simple scenarios.
Common Walkthroughs
Common walkthroughs cover scenarios to introduce the key features of page, RDL and section reports.
See Also
Samples and Walkthroughs


Page Report/RDL Report Walkthroughs

Page Report/RDL Report Walkthroughs
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs

Page Report walkthroughs cover scenarios to introduce the key features of Page Reports and RDL reports. Learn about different walkthroughs categorized as follows.

Data
This section contains the walkthroughs that explain various ways of working with data sources.
Layout
This section contains the walkthroughs that explain how to create different report layouts.
Chart
This section contains the walkthrough that demonstrates how to work with the ActiveReports Chart control.
Map
This section contains the walkthrough that demonstrates how to work with the ActiveReports Map control.
Tablix
This section contains the walkthroughs that demonstrates how to work with the ActiveReports Tablix data region.
Export
This section contains the walkthrough that demonstrates how to export your reports into several popular formats like PDF, HTML, Excel, Image and Word.
Preview
This section contains the walkthrough that demonstrates how to work with custom data and custom code.
Advanced
This section contains the walkthroughs that demonstrate interactive features of ActiveReports reports.
See Also
Walkthroughs


Data

Data
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Data

This section contains the following walkthroughs that fall under the Data category.

Master Detail Reports
This walkthrough demonstrates how to create a master detail report using the Table control and grouping.
Reports with Parameterized Queries
This walkthrough demonstrates how to create a simple dynamic query.
Reports with Stored Procedures
This walkthrough demonstrates how to create a report that uses a stored procedure as a data set.
Reports with XML Data
This walkthrough demonstrates how to connect a report to an XML data source and to create a data set.
Expressions in Reports
This walkthrough demonstrates how to use expressions to achieve different effects in a report.
See Also
Page Report Walkthroughs


Master Detail Reports

Master Detail Reports
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Data > Master Detail Reports
Show All Show All
Hide All Hide All

You can create a master detail report using the Table control and grouping. The following walkthrough takes you through the step by step procedure of creating a Master Detail report.

The walkthrough is split into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a data source
  • Adding a dataset to the report
  • Adding controls to the report to contain data
  • Viewing the report
Note:
  • This walkthrough uses the Customer table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Page Report and in the Name field, rename the file as rptMasterDetail.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as CustomerOrders. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query
    Copy Code
    SELECT CustomerID, Title, LastName, Quantity, Price, [Quantity]*[Price] AS
Total FROM CustomerOrders WHERE CustomerID < 1010
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To create a layout for the report

To add a table with grouping to the report

  1. From the toolbox, drag a Table data region onto the report design surface and go to the Properties Window to set its Location property to 0in, 1in.
  2. Click inside the table to display the column and row handles along the top and left sides of the table.
  3. To visually group the data within the report, right-click the row handle to the left of the detail row and select Insert Group.
  4. In the Table - Groups dialog that appears, under Expression select =Fields!CustomerID.Value.
    This groups the details from each customer.
  5. Change the Name to Customer.
    Note: You cannot change the name of a table group until after you have set the expression.
  6. Click OK to close the dialog. The group header and footer rows are added to the table.

To add a fourth column to the table

  1. Select the second column and in the Properties Window, change its Width property to 0.92in.
  2. Select the third column and in the Properties Window, change its Width property to 1.04in.
  3. Select the first column and in the Properties Window, change its Width property to 3.5in.
    Tip: Making some columns narrower before making other columns wider prevents your report width from changing.
  4. Right-click the column handle above the third column and select Insert Column to the Right. The inserted fourth column has the same width as the third column, which is 1.04in.

To add data to the table

  1. Place your mouse over the Textbox located in the first column of the group header row of the table to display the field selection adorner.
  2. Click the adorner to display the list of available fields from the DataSet and select LastName. This automatically places an expression in the group header row and simultaneously places a static label in the table header row.
  3. In the Properties window, set the FontSize property of this textbox to 12pt.
  4. In the table header row, delete the static label Last Name.
  5. To display static labels at the beginning of each new group, right-click the row handle to the left of the group header row and select Insert Row Below.
  6. In the first column of the detail row, use the field selector adorner to select the Title field.
  7. In the textbox immediately above it, type Title.
  8. In the table header row, delete the static label Title.
  9. In the second column of the detail row, use the field selector adorner to select the Quantity field. This automatically places an expression in the detail row and simultaneously places a static label in the header row of the same column.
  10. In the Properties window, set the TextAlign property of the Quantity field to Left.
  11. Cut the static label and paste it into the inserted row immediately above the detail row.
  12. In the third column of the detail row, use the field selector adorner to select the Price field.
  13. In the Properties window, set the following properties.
    Property Name | Property Value
    TextAlign | Left
    Format | C (uses currency formatting)
  14. Cut the static label from the group header and paste it into the inserted row immediately above the detail row.
  15. Select the Total field for the fourth column of the detail row of the table.
  16. In the Properties window, set the following properties.
    Property Name | Property Value
    TextAlign | Left
    Format | C (uses currency formatting)
  17. Cut the static label from the group header and paste it into the inserted row immediately above the detail row.

To refine the look of the report

  1. Right-click any row handle to the left of the table and select Table Header to remove the table header row since it is not being used.
  2. Select the Header row containing the labels by clicking the table handle to the left of the row.
  3. In the Properties window, set the following properties.
    Property Name | Property Value
    RepeatOnNewPage | True
    FontWeight | Bold
  4. From the Report Explorer, drag the Total field into the group footer row in the fourth column to add subtotaling to the group. Notice that the expression automatically uses the Sum function.
  5. Go to the Properties window to set the following properties.
    Property Name | Property Value
    Format | C (uses currency formatting)
    FontWeight | Bold
  6. From the Report Explorer, drag the Total field into the table footer row in the fourth column. This adds grand totaling to the table.
  7. Go to the Properties window to set the following properties.
    Property Name | Property Value
    Format | C (uses currency formatting)
    FontWeight | Bold
  8. Delete the static label Total from the top row.
  9. In the Report Explorer select the Table data region and set its FixedSize property to 6.5in, 7in.
    Note: This step is valid only for Page report. For RDL report, follow steps 10-12.
  10. For RDL reports, click the gray area below the design surface to give report the focus and from the Report menu, select Page Header.
  11. From the toolbox, drag the TextBox control onto the PageHeader section to span the entire width of the report.
  12. Go to the Properties Window to set the following properties.
    Property Name | Property Value
    TextAlign | Center
    FontSize | 14pt
    Value | Customer Orders

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.
See Also
Drilldown Reports

Concepts

Grouping Data (Page Layout)


Reports with Parameterized Queries

Reports with Parameterized Queries
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Data > Reports with Parameterized Queries
Show All Show All
Hide All Hide All

You can create dynamic queries to change the structure of a query at run time. This advanced walkthrough illustrates how to create a simple dynamic query.

The walkthrough is split into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a data source
  • Adding a dataset
  • Adding controls to the report to contain data
  • Creating a second dataset for use by the parameter list
  • Adding parameters to the report
  • Changing the Products dataset to use a dynamic query
  • Adding a header to display the chosen parameter label
  • Viewing the report
Note:
  • This walkthrough uses the MovieType table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\Reels.mdb.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Page Report and in the Name field, rename the file as DynamicQueries.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as Products. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query
    Copy Code
    SELECT Movie.Title, Product.InStock, Product.StorePrice
FROM MediaType
INNER JOIN
(Movie INNER JOIN
(Product INNER JOIN MovieProduct
  ON Product.ProductID = MovieProduct.ProductID)
 ON Movie.MovieID = MovieProduct.MovieID)
ON MediaType.MediaID = MovieProduct.MediaType
WHERE (((MediaType.MediaID)=1))
ORDER BY Movie.Title
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To create a layout for the report

  1. From the toolbox, drag a Table data region onto the report design surface and set the following properties in the Properties Window:
    Property Name | Property Value
    Location | 0in, 0.5in
    Size | 5.5in, 0.75in
    FixedSize (only for FixedPageLayout reports) | 6.5in, 7in
  2. In the Report Explorer from the Products dataset, drag the following fields onto the detail row of the table.
    Data Field | Column Name
    Title | TableColumn1
    InStock | TableColumn2
    StorePrice | TableColumn3
    Note: This automatically places an expression in the detail row and simultaneously places a static label in the header row of the same column.
  3. Select the header row, click the table handle to the left of the row and in the Properties Window, set the following properties:
    Property Name | Property Value
    FontWeight | Bold
    BackgroundColor | DarkSeaGreen
    RepeatOnNewPage | True

  4. Select the StorePrice field in the detail row and in the Properties Window, set its Format property to Currency.

  5. Click the column handle at the top of each column in turn to select it, and in the Properties Window, set the Width property as indicated in the table.
    Column | Width
    First | 4.5in
    Second | 1in
    Third | 1in

To create a second dataset for use by the parameter list

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as MediaType.
  3. On the Query page, paste the following SQL command into the Query text box:
    SQL Query
    Copy Code
    SELECT 0 AS MediaID, "All" AS Description
FROM MediaType
UNION SELECT MediaID, Description
FROM MediaType
ORDER BY Description
  4. Click the Validate icon to validate the query and to populate the Fields list.
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To add parameters to the report

  1. In the Report Explorer, select the Parameters node.
  2. Right-click the node and select Add Parameter to open the Report - Parameters dialog.
  3. In the dialog box that appears, select the parameter from the parameters list.
  4. Set properties in the following fields below the parameters list.

    In the General tab:

    • Name: MediaType
    • DataType: String
    • Text for prompting users for a value: Select a media type

    In the Available Values tab select From query:

    • DataSet: MediaType
    • Value: MediaID
    • Label: Description
  5. Click OK to close the dialog and add the parameter to the collection. This parameter appears under the Parameters node in the Report Explorer.

To modify the Products dataset to use a dynamic query

  1. In the Report Explorer, right-click the Products dataset and select Edit.
  2. In the DataSet dialog that appears, select the Query page.
  3. In the Query field, change the query to the following expression:
    Query
    Copy Code
    ="SELECT Movie.Title, Product.InStock, Product.StorePrice, MediaType.Description FROM MediaType INNER JOIN (Movie INNER JOIN (Product INNER JOIN MovieProduct ON Product.ProductID = MovieProduct.ProductID) ON Movie.MovieID = MovieProduct.MovieID) ON MediaType.MediaID = MovieProduct.MediaType" & IIf(Parameters!MediaType.Value = 0, ""," WHERE (MediaType = " & Parameters!MediaType.Value & ")") & " ORDER BY Movie.Title"
  4. Click OK to close the dialog.

To add a header to display the chosen parameter label

  1. From the toolbox, drag and drop a Textbox control onto the report design surface. In RDL reports, you can place the Textbox control in the PageHeader.
  2. Select the Textbox and set the following properties in the Properties window.
    Property Name | Property Value
    TextAlign | Center
    FontSize | 14pt
    Location | 0in, 0in
    Size | 6.5in, 0.25in
    Value | =Parameters!MediaType.Label & " Movies in Stock"
    Note: Using Label instead of Value in the expression displays a more readily understandable Description field instead of the MediaID field we used for the parameter's value.

To view the report

  • Go to the preview tab and select a parameter in the Parameters pane to view the report at design time.

OR

  • Open the report in the Viewer and select a parameter in the Parameters pane to view the report. See Windows Forms Viewer for further information.
See Also
Page Report/RDL Report Walkthroughs


Reports with Stored Procedures

Reports with Stored Procedures
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Data > Reports with Stored Procedures
Show All Show All
Hide All Hide All

You can create a report using a stored procedure as a dataset. A stored procedure is a group of SQL statements that are used to encapsulate a set of operations or queries to execute on a database.

This walkthrough illustrates how to create a report that uses a stored procedure as a data set. The walkthrough is split into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a data source
  • Adding a dataset (stored procedure) with a parameter
  • Creating a layout for the report
  • Viewing the report
Note:
  • This walkthrough uses a table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Page Report and in the Name field, rename the file as StoredProcedure.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like Reels.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

To add a dataset with a parameter

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as SalesDataForStore. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, set the Command Type to Stored Procedure.
  4. On the Query page of this dialog, in the Query field enter the stored procedure name (e.g. SalesDataForStore).
  5. Click the Validate icon to validate the query. You may receive an error at this point since the required parameters have not yet been added.
  6. Go to the Parameters page and add a Parameter using the Add(+) button.
  7. On the same page, enter Name as StoreID and Value as 1002.
  8. Select the Query page of DataSet dialog, and click the Validate icon to validate the query and load the fields.
  9. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To create a layout for the report

  1. From the toolbox, drag a Table data region onto the report design surface.
  2. In the Table data region, place your mouse over the cells of the table details row to display the field selection adorner.
  3. With the Table selected, right-click and open the Properties Window to set the following properties:
    Property Name | Property Value
    Location | 0in, 0.5in
    Size | 6.5in, 0.75in
    FixedSize | 6.5in, 7in
  4. Click the adorner to show a list of available fields from the SalesDataForStore dataset and add the following fields to the cells of the table details row.
    Cell | Field
    Left Cell | StoreID
    Middle Cell | UnitsSold
    Right Cell | NetSales
    This automatically places an expression in the detail row and simultaneously places a static label in the header row of the same column.
  5. Select the Header row by clicking the table handle to the left of the row and go to the Properties Window to set the following properties:
    Property Name | Property Value
    FontWeight | Bold
    RepeatOnNewPage | True
  6. Click the column handle at the top of each column in turn to select it, and in the Properties Window, set the Width property as indicated in the table:
    Column | Width
    First | 3.5in
    Second | 2in
    Third | 1in
  7. Set the TextAlign property of all the columns to Left.
  8. From the toolbox, drag the Textbox onto the design surface to span the entire width of the report and go to the Properties Window to set the following properties:
    Property Name | Property Value
    TextAlign | Center
    Size | 6.5in, 0.35in
    Location | 0in, 0.125in
    FontSize | 14pt
    Value | Net Sales by Store
    Tip: In a RDL report, you can also add a Page Header to place the Textbox control.

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.
See Also
Page Report/RDL Report Walkthroughs


Reports with XML Data

Reports with XML Data
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Data > Reports with XML Data
Show All Show All
Hide All Hide All

This walkthrough explains the steps involved in connecting a page report to an XML data source and creating a dataset. It also demonstrates the use of the List control.

The walkthrough is split up into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to an XML data source
  • Adding a dataset
  • Adding controls to the report to contain data
  • Viewing the report
Note:
  • This walkthrough uses the Factbook sample database. By default, in ActiveReports, the Factbook.rdsx file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\Factbook.rdsx.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Page Report and in the Name field, rename the file as ExchangeRates.
  4. Click the Add button to open a new page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like Factbook.
  3. On this page, check the Shared Reference checkbox.
  4. Click the Browse button and select Factbook.rdsx, which is located in [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data. See Connect to a Data Source for information on connecting to a data source.

To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as ExchangeRates.
  3. On the Query page, enter the following XML path into the Query text box to access data for every country except "World":
    //country [@name != 'World']
  4. On the Fields page, enter the values in the table below to create fields for your report. Values for XML data fields must be valid XPath expressions.
    Field Name | Type | Value
    Names | Database Field | @name
    Currencies | Database Field | ./ExchangeRates/Currency
    2004 | Database Field | ./ExchangeRates/VsUSD2004
    2003 | Database Field | ./ExchangeRates/VsUSD2003
    2002 | Database Field | ./ExchangeRates/VsUSD2002
    2001 | Database Field | ./ExchangeRates/VsUSD2001
    2000 | Database Field | ./ExchangeRates/VsUSD2000
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To add controls to the report

  1. From the toolbox, drag a List data region onto the design surface of the report and go to the Properties window to set the DataSetName property to ExchangeRates.
  2. From the Report Explorer, drag the Names field onto the list, center it at the top and go to the Properties window to set the FontSize property to 14pt.
  3. From the Report Explorer, drag the following fields onto the list with properties set as described in the table below.
    Field Name Property Name
    Currencies Location: 1.125in, 0.5in
    Size: 2.25in, 0.25in
    2004 Location: 4.5in, 0.875in
    Size: 1in, 0.25in
    2003 Location: 4.5in, 1.25in
    Size: 1in, 0.25in
    2002 Location: 4.5in, 1.625in
    Size: 1in, 0.25in
    2001 Location: 4.5in, 2in
    Size: 1in, 0.25in
    2000 Location: 4.5in, 2.375in
    Size: 1in, 0.25in
    Note: You will notice that the expressions created for these fields are different than usual. Because Visual Basic syntax does not allow an identifier that begins with a number, any numeric field names must be treated as strings in expressions.
  4. From the toolbox, drag a TextBox onto the list and go to the Properties window to set the properties as described in the table below to combine static text with a field value.
    Property Name | Property Value
    Location | 0.145in, 0.875in
    Size | 3in, 0.25in
    Value | ="Value of " & Fields!Currency.Value & " versus US$ for year:"
  5. From the toolbox, drag TextBox controls onto the list and go to the Properties window to set the properties as described in the table below to create static labels.

    TextBox1

    Property Name | Property Value
    Location | 0.125in, 0.5in
    Size | 0.75in, 0.25in
    FontWeight | Bold
    Value | Currency:

    TextBox2

    Property Name | Property Value
    Location | 3.375in, 0.875in
    Size | 1in, 0.25in
    TextAlign | Right
    Value | 2004:

    TextBox3

    Property Name | Property Value
    Location | 3.375in, 1.25in
    Size | 1in, 0.25in
    TextAlign | Right
    Value | 2003:

    TextBox4

    Property Name | Property Value
    Location | 3.375in, 1.625in
    Size | 1in, 0.25in
    TextAlign | Right
    Value | 2002:

    TextBox5

    Property Name | Property Value
    Location | 3.375in, 2in
    Size | 1in, 0.25in
    TextAlign | Right
    Value | 2001:

    TextBox6

    Property Name | Property Value
    Location | 3.375in, 2.375in
    Size | 1in, 0.25in
    TextAlign | Right
    Value | 2000:

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.
See Also
Page Report/RDL Report Walkthroughs


Expressions in Reports

Expressions in Reports
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Data > Expressions in Reports
Show All Show All
Hide All Hide All

You can use expressions in the control's properties to calculate values. You can also use expressions to concatenate fields, to concatenate strings with fields, to aggregate data, to set formatting based on field values, to show or hide other controls based on field values and even to display a graphical representation of the data. This walkthrough illustrates the how to use expressions to achieve different effects.

The walkthrough is split into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a data source
  • Adding a dataset
  • Adding controls to the report to contain data
  • Adding a field expression to a text box to multiply two field values
  • Adding an Immediate If expression to show or hide a control
  • Adding a Data Visualization expression to display data graphically
  • Viewing the report
Note:
  • This walkthrough uses the MovieProduct table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Page Report and in the Name field, rename the file as rptExpressions.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as DVDStock. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query
    Copy Code
    SELECT * FROM DVDStock
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To create a layout for the report

  1. From the toolbox, drag a Table data region onto the design surface and go to the Properties Window to set the DataSetName property to DVDStock.
  2. Right-click in the column handle at the top of the third column and choose Insert Column to the Right to add a fourth column of the same width.
  3. Click inside the table to display the row and column handles along the left and top edges of the table and set the column width as follows:
    Table Column | Width
    TableColumn1 | 3.5in
    TableColumn2 | 1in
    TableColumn3 | 1in
    TableColumn4 | 1in
  4. In the Report Explorer from the DVDStock dataset, drag the following fields into the detail row and set their properties as follows.
    Data Field | Column Name
    TableColumn1 | Title
    TableColumn2 | StorePrice
    TableColumn3 | InStock
  5. Select detail row cell containing the StorePrice values in the TableColumn2 and in the Properties Window, set the Format property to Currency.
  6. Select the header row using the row handle to the left and in the Properties Window, set the FontWeight property to Bold.
  7. For an Page report, in the Report Explorer select the Table control and in the Properties window, set the FixedSize property to 6.5in, 7in.

To add a field expression to a text box to multiply two field values

  1. In the detail row of the fourth column, enter the following expression: = Fields!InStock.Value* Fields!StorePrice.Value
  2. Go to the Properties Window to set the Format property of the textbox to Currency formatting.
  3. In the header row immediately above this Textbox, enter Stock Value for the static label.

To add an Immediate If expression to show or hide a report control

  1. Select the cell in which we multiplied two field values (in the detail row of the fourth column) and in the Properties window, expand the Visibility property.
  2. In the Hidden property, enter the following immediate if expression to hide the textbox if there is no stock for the item. =iif(Fields!InStock.Value=0, True, False)

To add a Data Visualization expression to display data graphically

The ColorScale3 visualizer function displays a range of colors to indicate minimum, average, and maximum values in the data. See the Data Visualizers topic for further information.

Select the cell in the detail row under the In Stock label and in the Properties window, set the BackgroundColor property to the following expression: =ColorScale3(Fields!InStock.Value, 0, Avg(Fields!InStock.Value), Max(Fields!InStock.Value), "Red", "Yellow", "Green")

Note: The parameters of the ColorScale3 function evaluate to Value, Minimum, Average, Maximum, StartColor, MiddleColor and EndColor. Note that aggregate functions (Avg and Max) are used within the ColorScale3 function. See Functions for details on these and other aggregate functions.

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.
See Also
Page Report/RDL Report Walkthroughs

Concepts

Expressions


Layout

Layout
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Layout

This section contains the following walkthroughs that fall under the Layout category.

BandedList Reports
This walkthrough demonstrates how to create a grouped BandedList report.
Collate Multiple Copies of a Report
This walkthrough demonstrates how to use the collation feature in a report that contains layouts on two page tabs.
Columnar Layout Reports (RDL)
This walkthrough demonstrates how to create a RDL report using columns.
Overflow Data in a Single Page(Page Report)
This walkthrough demonstrates how to use the OverflowPlaceHolder controls at any location on the same page to build a rich report layout.
Overflow Data in Multiple Pages(Page Report)
This walkthrough demonstrates how to create two different layouts using the OverflowPlaceHolder control.
Recursive Hierarchy Reports
This walkthrough demonstrates how to create a report using a recursive hierarchy and the Level function to show parent-child relationships in data.
Single Layout Reports
This walkthrough demonstrates how to create a layout at design time on a single page tab and apply it to the entire report.
Subreports in RDL Reports
This walkthrough demonstrates how to create a report using a subreport.
See Also
Page Report/RDL Report Walkthroughs


BandedList Reports

BandedList Reports
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Layout > BandedList Reports
Show All Show All
Hide All Hide All

You can create a freeform report with groups using the BandedList control. This walkthrough illustrates how to create a grouped BandedList report.

The walkthrough is split up into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a data source
  • Adding a dataset
  • Adding a banded list with grouping
  • Adding controls to the banded list
  • Viewing the report
Note:
  • This walkthrough uses the Movie table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Page Report and in the Name field, rename the file as rptBandedList.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as Movies. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, change the Command Type to TableDirect and enter Movie into the Query text box.
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To add the BandedList with grouping

  1. From the toolbox, drag a BandedList data region onto the design surface and go to the properties window to set the DataSetName property to Movies.
    Note: To select the banded list, click inside any band in the list and click the four-way arrow that appears at the top left of the control.
  2. Right-click inside the banded list and select Footer. This removes the footer band that we are not using in this walkthrough.
  3. Right-click inside the banded list and select Insert Group. This adds a group header between the BandedList header and the detail section, and a group footer below the detail section, and opens the BandedList - Groups dialog.
  4. In the BandedList - Groups dialog, drop down the list of expressions in the Group on expression box and select =Fields!YearReleased.Value to group the movies based on the year in which they were released.
  5. In the same dialog, change the Name to Year.
  6. In the same dialog under Layout, clear the Include group footer checkbox to remove the group footer.
  7. Click the Add icon. This adds a second group header under the first, and a group footer below the detail section.
  8. In the same dialog, select the newly added group from the list of groups, drop down the list of expressions in the Group on expression box and select =Fields!MPAA.Value to group the movies based on the rating (for example, G, PG, etc).
  9. In the same dialog, change the Name to MPAA.
  10. In the same dialog under Layout, clear the Include group footer checkbox to remove the group footer.
  11. Click OK to close the dialog.

To add controls to the BandedList

  1. From the toolbox, drag a TextBox control onto the top-most band (BandedList1_Header) and in the Properties window, set the following properties:
    Property Name | Property Value
    BackgroundColor | Gray
    Color | White
    FontSize | 14pt
    FontWeight | Bold
    Location | 0in, 0in
    Size | 6.5in, 0.25in
    TextAlign | Center
    Value | Movie Details
  2. Click the BandedList1_Header band adorner (the grey bar along the top of the band) to select the banded list header.
  3. In the Properties window, set the following properties for the banded list header:
    Property Name | Property Value
    RepeatOnNewPage | True
    Height | 0.25in
  4. From the Report Explorer drag the YearReleased field onto the first grouping band (Year_Header) of the banded list.
  5. With this field selected, go to the Properties window to set the following properties:
    Property Name | Property Value
    BackgroundColor | DarkGray
    FontWeight | Bold
    Location | 0in, 0in
    Size | 6.5in, 0.25in
    TextAlign | Left
    Value | =First(Fields!YearReleased.Value)
  6. Click the Year_Header band adorner (the grey bar along the top of the band) to select it and go to the properties window to set the Height property of the header band to 0.25in.
  7. From the Report Explorer, drag the MPAA field into the second grouping band (MPAA_Header) of the banded list.
  8. Go to the Properties window to set the following properties:
    Property Name | Property Value
    BackgroundColor | Silver
    BorderColor | Gray
    BorderStyle | Solid
    FontWeight | Bold
    Location | 0in, 0in
    Size | 6.5in, 0.25in
    Note: The Value property is automatically set to an expression using the First aggregate. This displays the movie rating for each group.
  9. Click the MPAA_Header band adorner (the grey bar along the top of the band) to select it and go to the properties window to set the Height property of the header band to 0.25in.
  10. Click inside the detail band to select it and in the properties window, set its Height property to 1.2in.
  11. From the Report Explorer, drag the following six fields onto the detail band and in the properties window, set their properties as indicated.
    Data Field Property Name
    Title Location: 0in, 0.25in
    Size: 3.75in, 0.25in
    Country Location: 1.25in, 0.5in
    Size: 1in, 0.25in
    Language Location: 1.25in, 0.75in
    Size: 1in, 0.25in
    Length Location: 5.375in, 0in
    Size: 1in, 0.25in
    TextAlign = Left
    UserRating Location: 5.375in, 0.5in
    Size: 1in, 0.25in
    TextAlign = Left
    IsColor Location: 5.375in, 0.75in
    Size: 1in, 0.25in
    Note: When you drag and drop fields from a dataset in the Report Explorer onto the design surface, these fields are automatically converted to Textbox controls that you can modify by setting the control properties in the Properties Window.
  12. Once you've arranged the fields, select the IsColor field and in the properties window, change the Value property to the following expression so that instead of "True" or "False," it will read "Color" or "Black and White."
    =Iif(Fields!IsColor.Value=True, "Color", "Black and White")
  13. From the toolbox, drag six TextBox controls onto the detail band and in the properties window, set their properties as indicated.

    TextBox1

    Property Name | Property Value
    Value | Movie Title:
    Location | 0in, 0in
    Size | 1in, 0.25in
    FontWeight | Bold

    TextBox2

    Property Name | Property Value
    Value | Country of origin:
    Location | 0in, 0.5in
    Size | 1.25in, 0.25in
    FontWeight | Bold

    TextBox3

    Property Name | Property Value
    Value | Language:
    Location | 0in, 0.75in
    Size | 1in, 0.25in
    FontWeight | Bold

    TextBox4

    Property Name | Property Value
    Value | Length:
    Location | 4.25in, 0in
    Size | 1in, 0.25in
    FontWeight | Bold
    TextAlign | Right

    TextBox5

    Property Name | Property Value
    Value | User Rating:
    Location | 4.25in, 0.5in
    Size | 1in, 0.25in
    FontWeight | Bold
    TextAlign | Right

    TextBox6

    Property Name | Property Value
    Value | Format:
    Location | 4.25in, 0.75in
    Size | 1in, 0.25in
    FontWeight | Bold
    TextAlign | Right
  14. From the toolbox, drag a Line control onto the detail band and in the Properties window, set the properties.
    Property Name | Property Value
    LineColor | Gray
    LineWidth | 3pt
    Location | 0in, 1.12in
    EndPoint | 6.5in, 1.12in
  15. For a Page report, in the Report Explorer select the BandedList control and in the Properties window, set its FixedSize property to 6.5in, 7in.

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.
See Also

Concepts

Grouping Data (Page Layout)


Collate Multiple Copies of a Report

Collate Multiple Copies of a Report
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Layout > Collate Multiple Copies of a Report
Show All Show All
Hide All Hide All

In a Page Report you can create reports with multiple themes, where you can control the page order of a rendered report by selecting the collation mode. This walkthrough uses a report that contains layouts on two page tabs in order to illustrate the collation feature.

This walkthrough is split into the following activities:

  • Creating report layout on multiple pages
  • Adding themes
  • Applying themes
  • Setting up collation
  • Viewing the report
Note:
  • This walkthrough uses the CustomerOrders table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\Reels.mdb.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a report that looks similar to the following. These images show the result of the Value collation mode.

Page 1 Page 2 Page 3 Page 4

To create a report layout on multiple pages

In a Page Report, you can apply more than one layout to a single report by using page tabs. See the walkthrough Overflow Data in Multiple Pages, to learn how to create a report that consists of a first page with a different layout from all subsequent pages.

Note: The information provided henceforth is an extension of the Overflow Data in Multiple Pages walkthrough, so we recommend that you go through this topic before moving to the next procedure.

To add themes to the report

  1. In the Designer, click the gray area around the report page to select a report.
  2. In the Properties window, select the Themes property and click the ellipsis (…) button to open the Report - Themes dialog.
  3. In the Report - Themes dialog that opens, click the New icon above the list of themes.
  4. In the Theme Editor that opens, define the colors and constant expressions for your new theme under the corresponding tabs as follows:

    Theme 1

    Property Name | Property Value | Description
    Text/Background - Light1 (Colors tab) | Default (white) | To set the background color for the theme.
    Name (Constants tab) | Constant1 | To define a name for the constant expression to be used within in a theme.
    Value (Constants tab) | Theme1 | To associate a value to be used as a constant in the expression.
    Description (Constants tab) | Default Theme | To describe a constant expression.
  5. In the Theme Editor, click OK and in the Save As dialog that opens, choose a directory on your local machine and enter the name, Default Theme for your new theme.
  6. Click Save to save the theme at the desired location.
  7. Repeat steps 3-6 above to add another theme to the report. Define the colors and constant expressions of the theme under the corresponding tabs as follows:

    Theme 2

    Property Name | Property Value | Description
    Text/Background - Light1 (Colors tab) | Yellow | To set the background color for the theme.
    Name (Constants tab) | Constant1 | To define a name for the constant expression to be used within in a theme.
    Value (Constants tab) | Theme2 | To associate a value to be used as a constant in the expression.
    Description (Constants tab) | Yellow Theme | To describe a constant expression.

To apply themes to the report

In order to apply themes to a report, you need to set the theme as a value of a property. In this walkthrough we set the theme in the BackgroundColor property.

  1. In the Report Explorer, select the Page 1 node to open the layout for the first page of the report.
  2. In the Properties window, go to the BackgroundColor property and click the arrow to display the drop-down list of values.
  3. In the list that appears, go to the Theme button and select Light1.
  4. In the Report Explorer, select Page 2 node to open the layout for the second page of the report.
  5. In the Properties window, go to the BackgroundColor property and click the arrow to display the drop-down list of values.
  6. In the list that appears, go to the Theme button and select Light1.
  7. From the Visual Studio toolbox, ActiveReports 10 Page Report tab, drag the Textbox control and drop it onto the Page 1 design surface.
  8. With this TextBox control selected, set the following properties in the properties window. This is to display a constant value associated with the Theme.
    Property Name | Property Value
    Location | 4.4in, 0in
    Size | 2.1in, 0.25in
    Value

    = Theme.Constants("Constant1")

    Note: To set this value, enter it in the Value field of the Properties window. You may also use the Expression Editor option that appears when you click the ellipses (...) button adjacent to the Value property.
  9. From the Visual Studio toolbox, drag the Textbox control and drop it onto the Page 2 design surface. Set the properties specified in step 8 above in the properties window.

Your layout now contains two themes and a constant expression displaying the theme you are using on the top left corner of the page.

To set up collation

Collation is set to determine the order in which the report pages are rendered when you have multiple themes in the report. In order to define the order, you need to set the CollateBy property.

  1. In the Designer, click the gray area around the report page to select the report.
  2. In the Properties Window, go to the CollateBy property and select the Simple mode. The report will be rendered in the following way - the report renders all pages with theme 1, then all pages with theme 2.
  3. In the Properties Window, go to the CollateBy property and select the ValueIndex mode. The report will be rendered by page number. For example, if you have a report with 2 themes, the report renders page 1 for theme 1 and 2, then page 2 for theme 1 and 2, and so on.
  4. In the Properties Window, go to the CollateBy property and select the Value mode. The report will be rendered by the grouping expression that you specify in the FixedPage dialog. For example, if you have a report comprising of 2 themes with grouping, the report renders group1 (pages 1 and 2 of theme1, then pages 1 and 2 of theme2), then group 2 (pages 1 and 2 of theme1, then pages 1 and 2 of theme2), and so on.

To view the report

  • Click the preview tab to view the report.

OR

  • See Windows Forms Viewer to display report in the Viewer at runtime.
See Also

Concepts

Themes

How To

Create and Add Themes
Customize and Apply a Theme
Use Constant Expressions


Columnar Layout Reports (RDL)

Columnar Layout Reports (RDL)
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Layout > Columnar Layout Reports (RDL)
Show All Show All
Hide All Hide All

In RDL report, you can create a columnar report layout by using the Columns property of the report. This walkthrough illustrates how to create a RDL report using columns, and is split up into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting to a the data source
  • Adding a dataset
  • Creating a column report layout
  • Viewing the report
Note: This walkthrough uses the CustomerMailingList table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 RDL Report and in the Name field, rename the file as rptRDLColumnLayout.
  4. Click the Add button to open a new RDL report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as CustomerList. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query
    Copy Code
    SELECT TOP 100 * FROM CustomerMailingList
UNION
SELECT TOP 100 * FROM CustomerMailingList WHERE Country = "USA"
ORDER BY 8 DESC
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To create a column layout for the report

  1. In the Report Explorer, select Body and set the following properties in the properties window.
    Property Name | Property Value
    Columns | 2
    ColumnSpacing | 0.25in
    Size | 2.625in, 1in
  2. In the Visual Studio toolbox, go to the ActiveReports 10 Page Report tab and drag the List data region onto the design surface.
  3. In the Properties Window, set the following properties for the List.
    Property Name | Property Value
    DataSetName | CustomerList
    Size | 2.5in, 1in
  4. In the Visual Studio toolbox, go to the ActiveReports 10 Page Report tab and drag three TextBox controls onto the List data region added above.
  5. In the Properties Window, set the following properties for TextBox1.
    Property Name | Property Value
    Location | 0in, 0in
    Size | 2.5in, 0.25in
    DataElementName | FirstName
    Name | FirstName
    Value | =Fields!FirstName.Value & IIF( Fields!MiddleInitial.Value Is Nothing, "", " " & Fields!MiddleInitial.Value ) & " " & Fields!LastName.Value
    CanGrow | False
  6. In the Properties Window, set the following properties for TextBox2.
    Property Name | Property Value
    Location | 0in, 0.25in
    Size | 2.5in, 0.25in
    DataElementName | CustomerAddress1
    Name | CustomerAddress1
    Value | =Fields!Address1.Value & IIF( Fields!Address2.Value is Nothing, "", vbCrLf & Fields!Address2.Value )
    CanGrow | False
    CanShrink | True
  7. In the Properties window, set the following properties for TextBox3.
    Property Name | Property Value
    Location | 0in, 0.50in
    Size | 2.5in, 0.25in
    DataElementName | CustomerCity
    Name | CustomerCity
    Value | =Fields!City.Value & ", " & Fields!Region.Value & " " & Fields!PostalCode.Value & " " & IIf( Fields!Country.Value = "USA", "", Fields!Country.Value )
    CanGrow | False

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.
If you want to create a similar layout in Page report, see Overflow Data in a Single Page.
See Also
Overflow Data in a Single Page(Page Report)
Overflow Data in Multiple Pages(Page Report)
Page Report Walkthroughs


Overflow Data in a Single Page(Page Report)

Overflow Data in a Single Page(Page Report)
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Layout > Overflow Data in a Single Page(Page Report)
Show All Show All
Hide All Hide All

In a Page Report, ActiveReports allows you to arrange the OverflowPlaceHolder controls at any location on the same page along with the host data region to build a rich report layout. The following walkthrough demonstrates this by using a Table data region and three OverflowPlaceHolder controls on a single page to create a columnar display.

This walkthrough is split into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting to a data source
  • Adding a dataset
  • Creating a columnar layout
  • Viewing the report
Note: This topic uses the Movie table in the Reels database. By default, in ActiveReports, the Reels.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\Reels.mdb.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Notice that the runtime report layout below is similar to the one you see at design time except for the data which you see at runtime or when you preview the report.

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Page Report and in the Name field, rename the file as rptColumnarLayout.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialogthat appears, select the General page and in the Name field, enter a name like ColumnData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as MovieList. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query
    Copy Code
    SELECT * FROM Movie
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To create a layout for the report

  1. In the Visual Studio toolbox, go to ActiveReports 10 Page Report tab and drag a TextBox control onto the design surface.
  2. Select the TextBox control and go to the properties window to set the following properties. This TextBox functions as the title in the report layout.
    Property Name | Property Value
    Location | 0in, 0in
    BackgroundColor | DarkCyan
    Font | Normal, Arial, 20pt, Bold
    Size | 6.5in, 0.5in
    TextAlign | Center
    Value | Movie Database
    VerticalAlign | Middle
  3. From the Visual Studio toolbox, drag and drop a Table data region onto the design surface and set its following properties in the properties window.
    Property Name | Property Value
    Location | 0.125in, 1in
    BackgroundColor | Azure
    RepeatHeaderOnNewPage | True
    Size | 3in, 0.66in
    FixedSize | 3in, 3.5in
    OverflowName OverflowPlaceHolder1
    Note: Set this property after you add the OverflowPlaceHolder1 to the design surface in the next step, to handle the data that exceeds the fixed size of the Table data region.
  4. In the Table data region, right click the footer row and select Table Footer from the context menu to delete the unnecessary footer row.
  5. In the table details row, add the following fields using the field selection adorner:
    Cell | Field Name
    Left | Title
    Center | YearReleased
    Right | UserRating
  6. In the table details row, select the left cell containing the Title field and go to the Properties window to set the ShrinkToFit property to True. This will avoid clipping of longer movie titles and fit the string in the same cell in a smaller font size.
  7. In the design view, select the following rows of the Table data region by clicking the table handle to the left of the row and go to the Properties window to set the following properties:
    Row Property Name
    TableHeader BackgroundColor: PaleTurquoise
    BorderStyle: Solid
    FontSize: 10pt
    FontWeight: Bold
    TextAlign: Left
    TableDetail BorderStyle: Solid
    TextAlign: Left
    FontSize: 9pt
  8. From the Visual Studio toolbox, drag and drop three OverflowPlaceHolder controls onto the design surface and the set the following properties in the Properties window for each of them so that the data appears in a columnar format.
    Control Name | Property
    OverflowPlaceHolder1 Location: 3.375in, 1in
    OverflowName: OverflowPlaceHolder2
    Note: Set this property after you add the OverflowPlaceHolder2 to the design surface.
    OverflowPlaceHolder2 Location: 0.125in, 5in
    OverflowName: OverflowPlaceHolder3
    Note: Set this property after you add the OverflowPlaceHolder3 to the design surface.
    OverflowPlaceHolder3 | Location: 3.375in, 5in
    Note: Notice that the OverflowName property is set to link each OverflowPlaceHolder control to the next one.

To view the Report

  • Click the preview tab to view the report.

OR

  • See Windows Forms Viewer to display report in the Viewer at runtime.
See Also
Single Layout Reports
Overflow Data in Multiple Pages(Page Report)


Overflow Data in Multiple Pages(Page Report)

Overflow Data in Multiple Pages(Page Report)
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Layout > Overflow Data in Multiple Pages(Page Report)
Show All Show All
Hide All Hide All

In a Page Report you can create different layouts in a single report by designing your report on more than one page tab. This walkthrough describes the steps to create two different layouts and how data flows from the first layout to the next using the OverflowPlaceHolder control.

This walkthrough is split into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting to a the data source
  • Adding a dataset
  • Creating a layout for the first page
  • Creating a layout for subsequent pages
  • Viewing the Report
Note: This walkthrough uses the CustomerOrders table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\Reels.mdb.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design Time Layout

Page 1 Page 2

Notice that the runtime report layout below is similar to the one you see at design time except for the data which is added to the report at runtime or when you preview it.

Runtime Layout

Page 1 Page 2

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Page Report and in the Name field, rename the file as rptMultipleLayout.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like CustomerData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as OrdersList. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query
    Copy Code
    Select * from customerorders
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To create a layout for the first page

  1. Click the design surface to select the page, go to the properties window and set the FixedLayout - Grouping property to =Fields!SalesID.Value. See Grouping in a FixedPage to understand grouping further.
  2. In the Report Explorer, right-click the Embedded Images node to select Add Embedded Image.
    OR
    Alternatively, you can also select the Embedded Images option by clicking the Add (+) icon at the top on the Report Explorer.
    This opens the Open dialog where you can select an image to embed in the report.
  3. Drag and drop the embedded image, which now appears as a node in the Report Explorer, onto the Page 1 design surface and in the properties window set its Location property to 0in, 0in.
  4. From the Visual Studio toolbox, drag the following controls from the ActiveReports 10 Page Report tab, drop it onto the Page 1 design surface and set the following properties in the properties window.

    Controls

    Control Properties
    Textbox Color: DarkSlateBlue
    Font: Normal, Arial, 11pt, Bold
    Location: 0in, 1in
    Size: 2in, 0.25in
    TextAlign: Center
    Value: 5473 Sidelong Street
    Textbox Color: DarkSlateBlue
    Font: Normal, Arial, 11pt, Bold
    Location: 0in, 1.25in
    Size: 2in, 0.25in
    TextAlign: Center
    Value: Siler City, NC. 27344
    Textbox Font: Normal, Arial, 10pt, SemiBold
    Location: 0in, 2in
    Size: 1in, 0.25in
    TextAlign: Right
    Value: Sales Date :
    Textbox Font: Normal, Arial, 10pt, SemiBold
    Location: 0in, 2.25in
    Size: 1in, 0.25in
    TextAlign: Right
    Value: Sales ID :
    Textbox Font: Normal, Arial, 10pt, SemiBold
    Location: 3in, 2in
    Size: 1.5in, 0.25in
    TextAlign: Right
    Value: Customer Name :
    Textbox Font: Normal, Arial, 10pt, SemiBold
    Location: 3in, 2.25in
    Size: 1.5in, 0.25in
    TextAlign: Right
    Value: Address :
    Textbox Font: Normal, Arial, 10pt, SemiBold
    Location: 3in, 2.50in
    Size: 1.5in, 0.25in
    TextAlign: Right
    Value: City :
    Textbox Font: Normal, Arial, 10pt, SemiBold
    Location: 3in, 2.75in
    Size: 1.5in, 0.25in
    TextAlign: Right
    Value: Country :
    Textbox Font: Normal, Arial, 10pt, SemiBold
    Location: 0in, 4in
    Size: 1.5in, 0.25in
    TextAlign: Right
    Value: Account Number:
    Table BorderStyle: Solid
    FixedSize: 6.5in, 2in
    Location: 0in, 5in
    OverflowName: OverflowPlaceHolder1
    Note: Set this property after you add the OverflowPlaceHolder1 control to the design surface to handle the data that exceeds the fixed size of the Table data region.
    RepeatHeaderOnNewPage: True
    Size: 6.5in, 0.75in
  5. From the Report Explorer drag and drop the following fields onto the Page 1 design surface and set the following properties in the properties window.

    Fields

    Field Properties
    SaleDate Format: D
    Location: 1in, 2in
    Size: 2in, 0.25in
    TextAlign: Left
    SalesID Location: 1in, 2.25in
    Size: 2in, 0.25in
    TextAlign: Left
    FirstName Location: 4.5in, 2in
    Size: 2in, 0.25in
    TextAlign: Left
    Address1 Location: 4.5in, 2.25in
    Size: 2in, 0.25in
    TextAlign: Left
    City Location: 4.5in, 2.5in
    Size: 2in, 0.25in
    TextAlign: Left
    Country Location: 4.5in, 2.75in
    Size: 2in, 0.25in
    TextAlign: Left
    AccountNumber Location: 1.5in, 4in
    Size: 2in, 0.25in
    TextAlign: Left
  6. Hover your mouse over the columns of the Table Details row to access the field selection adorner and set the following fields in the table cells along with their properties.
    Cell Field Properties
    Left Cell Title BorderStyle: Solid
    TextAlign: Center
    Middle Cell Quantity BorderStyle: Solid
    TextAlign: Center
    Right Cell Price BorderStyle: Solid
    Format: c
    TextAlign: Center

    This automatically places an expression in the details row and simultaneously places a static label in the header row of the same column.

  7. Select the Table Header row and set the following properties in the properties window.
    Property Name | Value
    BackgroundColor | Silver
    Font | Normal, Arial, 11pt, Bold
    RepeatOnNewPage | True
    TextAlign | Center
  8. Set the properties of the following cells on the Table Footer row through the properties window.
    Cell Properties
    Middle Cell Font: Normal, Arial, 10pt, Bold
    TextAlign: Right
    Value: Total:
    Right Cell Font: Normal, Arial, 10pt, Bold
    Format: c
    TextAlign: Center
    Value: =Sum(Fields!Price.Value)
  9. In the Report Explorer, expand the Common Values node and drag and drop the Page N of M (Section) field onto the Page 1 design surface and set its Location property to 0in, 8in in the properties window.

To create a layout for subsequent Pages

  1. Click the New tab to add a new page to the report layout. This page is named Page 2 by default.
  2. From the Visual Studio toolbox, drag the following controls from the ActiveReports 10 Page Report tab, drop it onto the Page 2 design surface and set the properties in the properties window.

    Controls

    Control | Properties
    Textbox Font: Normal, Arial, 12pt, Bold
    Location: 0in, 1in
    Size: 2.625in, 0.25in
    TextAlign: Right
    Value: Account Details:
    Textbox Font: Normal, Arial, 12pt, Bold
    Location: 2.625in, 1in
    Size: 3.25in, 0.25in
    Value: =Fields!FirstName.Value + ", " + Fields!AccountNumber.Value
    OverflowPlaceHolder | Location: 0in, 2in
    Textbox Location: 1.75in, 5in
    Size: 3in, 0.25in
    TextAlign: Center
    Value: Thank You For Your Business!
  3. In the Report Explorer, expand the Common Values node and drag and drop the Page N of M (Section) field onto the Page 2 design surface and set its Location property to 0in, 8in in the properties window.

To view the report

  • Click the preview tab to view the report.

OR

  • See Windows Forms Viewer to display report in the Viewer at runtime.
See Also
Overflow Data in a Single Page(Page Report)
Single Layout Reports


Recursive Hierarchy Reports

Recursive Hierarchy Reports
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Layout > Recursive Hierarchy Reports
Show All Show All
Hide All Hide All

You can create a report using a recursive hierarchy and the Level function to show parent-child relationships in data. This walkthrough illustrates how to create a recursive hierarchy report.

The walkthrough is split into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a data source
  • Creating a dataset to populate the parameter values
  • Adding a report parameter
  • Adding a dataset for the report
  • Adding controls to the report to contain data
  • Setting up a recursive hierarchy
  • Using the Level function to display the hierarchy
  • Viewing the report
Note:
  • This walkthrough uses the Store table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Samples\Data folder.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Page Report and in the Name field, rename the file as rptRecursiveHierarchy.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

To create a dataset to populate the parameter values

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as Stores. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query
    Copy Code
    SELECT StoreID FROM Store
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To add a report parameter

  1. In the Report Explorer, right-click the data source node and select the Parameters node or select Parameter from the Add button.
  2. In the Report - Parameters dialog that appears, set the following values:

    In the General tab

    • Name: StoreID
    • DataType: Integer
    • Text for prompting users for a value: Select a store number

    In the Available Values tab select From query

    • Dataset: Stores
    • Value: StoreID
    • Label: StoreID
  3. Click OK to close the dialog and add the parameter under the Parameters node of the Report Explorer.

To add a dataset for the report

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as Employees. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Parameters page, add a parameter with the following properties.
    • Parameter Name: @StoreID
    • Value: =Parameters!StoreID.Value
  4. On the Query page of this dialog, change the Command Type to StoredProcedure and enter the following stored procedure into the Query text box (the question mark denotes the parameter)
    StoredProcedure Query
    Copy Code
    EmployeesForStore ?
    EmployeesForStore ?
  5. Click the Validate icon to validate the query and to populate the Fields list.
  6. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To create a layout for the report

  1. From the toolbox, drag a Table control onto the body of the report and go to the Properties window to set the following properties.
    Property Name | Property Value
    Location | 0in, 0in
    DataSetName | Employees
    FixedSize (only for Page reports) | 6.5in, 9in
  2. Click inside the table to display the row and column handles along the left and top edges of the table.
  3. Select the columns by clicking the grey column header above the column and change the Width property in the order as follows.
    Column | Property Name
    Second Column | Width: 1.5in
    Third Column | Width: 1.05in
    First Column | Width: 2.2in
  4. Right-click the grey column header above the third column and select Insert Column to the Right.
  5. Select the fourth column and change its Width property to 1.75in.
    Tip: Making some columns narrower before adding columns or making other columns wider prevents your report width from changing.
  6. In the Report Explorer from the Employees dataset, drag the following fields onto the detail row of the table.
    Data Field | Column Name
    Title | TableColumn1
    LastName | TableColumn2
    Supervisor | TableColumn3
    Department | TableColumn4
  7. Select the LastName field in the second column of the detail row and in the Properties window, set the Value property to =Fields!LastName.Value & " " & Fields!EmployeeID.Value. This will display the Employee ID number along with each employee's last name.
  8. Select the static label in the second column of the header row of the table and in the properties window, set its Value property to Last Name and ID.
  9. Select the Supervisor field in the third column of the detail row and in the Properties window, set its TextAlign property to Center.
  10. Select the static label in the third column of the detail row and in the Properties window, set its Value property to Supervisor ID.
  11. Select the header row by clicking the table handle to the left of the row and in the Properties window, set the following properties.
    Property Name | Property Value
    TextAlign | Center
    FontWeight | Bold
    BackgroundColor | DarkSlateBlue
    Color | White
  12. Select the detail row and in the Properties window, set the BorderStyle property to Solid.
  13. Right-click the table handle to the left of the header row and select Insert Row Above.
  14. While holding down the SHIFT key, click each of the cells in the newly added top row.
  15. Right-click inside the selected cells and select Merge Cells to create a cell that spans the table.
  16. Go to the Properties window to set the following properties.
    Property Name | Property Value
    TextAlign | Center
    FontSize | 14pt
    Value | ="Store Number " & Parameters!StoreID.Value
  17. Right-click the table handle to the left of the row and select Table Footer to remove the footer row from the table.
Note: In case you are setting a recursive hierarchy on a Page report, set the DataSetName property in the FixedPage Dialog to Employees.

To set up a recursive hierarchy

  1. Right-click the table handle to the left of the Detail row and select Edit Group to open the Table-Detail Grouping dialog.
  2. Under Group on: Expression, select =Fields!EmployeeID.Value.
  3. Under Parent group:, select =Fields!Supervisor.Value.
  4. Click OK to close the dialog.

To use the Level function to display the hierarchy

  1. Select the cell in the first column of the Detail row that reads =Fields!Title.Value and in the Properties window, expand the Padding property.
  2. In the Padding > Left property, enter the expression =2 + (Level() * 15) & "pt".
    Note: Adding 2 to the result ensures that a normal amount of padding is always used.

To use the Level function with themes in the BackgroundColor property of a textbox

  1. Go to C:\Users\<User>\Documents\GrapeCity Samples\ActiveReports 10\Reports Gallery\<C# or VB.NET>\Reports\RDL Report\Reels.
  2. Copy the file Reels.rdlx-theme and paste it into the folder in which you saved your report.
  3. In the Report Explorer, select Report.
  4. In the Properties window in the Theme property, enter the theme file name: Reels.rdlx-theme.
  5. Click the table handle to the left of the detail row to select the entire row.
  6. In the Properties window, set the BackgroundColor property to =Theme.Colors(Level() + 1, 4).

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.
See Also

Concepts

Expressions


Single Layout Reports

Single Layout Reports
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Layout > Single Layout Reports
Show All Show All
Hide All Hide All

A Page Report, allows you to create a layout at design time on a single page tab and apply it to the entire report. Designing a layout in this format gives you the advantage of creating a layout that appears exactly the same at design time and runtime. This walkthrough illustrates how to create a report that contains a single layout and preview it.

This walkthrough is split into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting to a the data source
  • Adding a dataset
  • Creating a layout
  • Viewing the report
Note:
  • This walkthrough uses the DVDStock table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Samples\Data\Reels.mdb.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Notice that the runtime report layout below is similar to the one you see at design time except for the data which you see at runtime or when you preview the report.

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Page Report and in the Name field, rename the file as rptSingleLayout.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as DVDList. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query
    Copy Code
    Select * from dvdstock
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To create a layout for the report

  1. In the Visual Studio toolbox, go to the ActiveReports 10 Page Report tab and drag a TextBox control onto the design surface.
  2. Select the TextBox control and go to the Properties window to set the following properties.
    Property Name | Property Value
    Location | 0.25in, 0.5in
    BackgroundColor | Khaki
    Color | Maroon
    Font | Normal, Arial, 16pt, Bold
    Size | 6in, 0.5in
    TextAlign | Center
    Value | DVD STOCK
  3. From the Visual Studio toolbox, drag a Table data region and place it on the design surface.
  4. Select the Table and go to the Properties window to set the following properties.
    Property Name | Property Value
    Location | 0.25in, 1in
    BackgroundColor | Khaki
    FixedSize | 6in, 7.5in
    RepeatHeaderOnNewPage | True
    Size | 6in, 0.75in
  5. In the Table data region, place your mouse over the cells of the table details row to display the field selection adorner.

  6. Click the adorner to show a list of available fields from the DataSet and add the following fields to the cells of the table details row.

    Cell | Field
    Left Cell | Title
    Middle Cell | InStock
    Right Cell | StorePrice
    This automatically places an expression in the details row and simultaneously places a static label in the header row of the same column.
    Tip: You can also directly drag fields from the Report Explorer onto the textbox cells of the Table data region.
  7. Select the columns of the Table and set their Width property as follows:
    Cell | Field
    Left Cell | 2.5in
    Middle Cell | 1.75in
    Right Cell | 1.75in
  8. Select the following table rows and go to the Properties window to set their following properties.
    Row Properties
    Table Header BorderStyle: Solid
    Color: Maroon
    Font: Normal, Arial, 12pt, Bold
    TextAlign: Left
    Table Details BorderStyle: Solid
    Font: Normal, Arial, 10pt, Bold
    TextAlign: Left

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.
See Also
Overflow Data in Multiple Pages
Overflow Data in a Single Page


Subreports in RDL Reports

Subreports in RDL Reports
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Layout > Subreports in RDL Reports
Show All Show All
Hide All Hide All

You can create a RDL report that hosts a subreport. This walkthrough illustrates how to create a report using a subreport.

The walkthrough is split up into the following activities:

  • Creating a report for the subreport
  • Connecting the subreport to a data source
  • Adding a dataset with a parameter to the subreport
  • Adding a report parameter to the subreport
  • Adding controls to display data on the subreport
  • Creating the main report
  • Connecting the main report to a data source
  • Adding a dataset to the main report
  • Adding controls to display data on the main report
  • Viewing the report
Note: This topic uses the Employee, Sale and SaleDetails tables in the Reels database. By default, in ActiveReports, the Reels.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\Reels.mdb.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add a report for the subreport

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 RDL Report and in the Name field, rename the file as Sales.rdlx.
  4. Click the Add button to open a new RDL report in the designer.
  5. In the Solution Explorer, select Sales.rdlx and set the Build Action property to Content and the Copy to Output Directory property to Copy Always.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the subreport to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like Reels.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

To add a report parameter to the subreport

  1. In the Report Explorer, right-click the Parameters node and select the Add Parameter option or select Parameter from the Add button.
  2. Under Name, enter EmployeeID.
  3. Under Data type, select Integer.
  4. Click OK to close the dialog.

To add a dataset with a parameter to the subreport

When you add a query parameter using the syntax required by your database you must add a parameter to the Parameters page to ensure that the parameter value is passed to the query from the Report Parameters collection.

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as EmployeeSales. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Parameters page under Parameter Name enter EmployeeID.
  4. Under Value enter =Parameters!EmployeeID.Value
  5. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query
    Copy Code
    SELECT * FROM EmployeeSales
  6. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  7. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To add controls to display data on the subreport

  1. From the toolbox, drag a Table data region onto the body of the report and go to the properties window to set the DataSetName property to EmployeeSales.
  2. Click inside the table to display the column and row handles along the top and left sides of the table.
  3. Right-click the handle above the rightmost column and select Insert Column to the Right to add another column.
  4. Click the column handle at the top of each column in turn to select it, and in the property grid, set the Width property as indicated in the table.
    Column | Width
    First | 1.5in
    Second | 1.5in
    Third | 1.2in
    Fourth | 1.55in
    Tip: In most cases it is easier to resize existing columns before adding new columns because this prevents the table from growing horizontally and pushing the report width beyond what will fit on paper.
  5. Right-click the handle to the left of the table detail row and select Insert Group to open the Table-Groups dialog.
  6. Under Expression select =Fields!EmployeeID.Value. This groups all details from each employee.
  7. Change the Name to Employee and click OK to close the dialog. A grouping row is added to the table.
    Note: You cannot change the name of a table group until after you have set the expression.
  8. Right-click the handle to the left of the table detail row and select Edit Group to access the Table-Detail Grouping dialog.
  9. Under Expression select =Fields!SaleID.Value and click OK to close the dialog. This lists the total amount of each sale instead of listing each item sold within each SaleID.
  10. Right-click the handle to the left of the grouping row and select Insert Row Below. We will use this new row for static labels that repeat at the top of each new group.
  11. Right-click any handle to the left of the table and select Table Header to toggle off the table header.
  12. Right-click any handle to the left of the table and select Table Footer to toggle off the table footer.
  13. In the Report Explorer, select the Body node and go to the Properties window to set the Size property to 5.75in, 1in so that it fits inside the subreport control on the main report.

To add data fields to the Table data region

  1. In the Report Explorer, from the EmployeeSales dataset, drag the following field onto the first group header row of the table.
    Data Field | Column Name | Property Name
    Name | TableColumn1 | FontWeight: Bold
  2. Use the Shift key and the mouse to select the first two cells in the first group header row, right-click and select Merge Cells. This allows the employee name to span two columns in the table.
  3. Using the handle to the left of the first group header row, select the row and set the BackgroundColor property to LightSteelBlue.
    Tip: Even if you do not want to use colors in your finished report, it is often helpful to do so during the design of a report to make identification of the various sections easier for troubleshooting when you preview it.
  4. Enter the following text into the cells in the second group header row of the table.
    Data Field Column Name Property Name
    Sale Date TableColumn1 FontWeight: Bold
    TextAlign: Right
    Sale Number TableColumn2 FontWeight: Bold
    TextAlign: Right
    Quantity TableColumn3 FontWeight: Bold
    TextAlign: Right
    Total TableColumn4 FontWeight: Bold
    TextAlign: Right
  5. Using the handle to the left of the second group header row, select the row and set the BackgroundColor property to LightGray.
  6. In the Report Explorer, drag the following fields from the EmployeeSales dataset onto the detail row of the table.
    Data Field | Column Name | Property Name
    Sale Date | TableColumn1 | Format: Short date
    SaleID | TableColumn2
    Quantity | TableColumn3
    Total | TableColumn4 | Format: Currency
  7. In the detail row of the table, select the textbox with the Quantity data field and go to the Properties window to change the Value property to =Sum(Fields!Quantity.Value). This adds the Sum aggregate to the expression for the field and shows a summary of the quantity field for each SalesID.
  8. In the detail row of the table, select the textbox with the Total data field and go to the Properties window to change the Value property to =Sum(Fields!Total.Value). This adds the Sum aggregate to the expression for the field and shows a summary of the total field for each SalesID.
  9. In the Report Explorer, from the EmployeeSales dataset, drag the following fields onto the group footer row of the table.
    Data Field | Column Name | Property Name
    Quantity | TableColumn3 | Value: =Sum(Fields!Quantity.Value)
    Total TableColumn4 Format: Currency
    Value: =Sum(Fields!Total.Value)
  10. Enter the following text into the indicated cell in the group footer row of the table.
    Text Column Name Property Name
    Employee Total: TableColumn2 FontWeight: Bold
    TextAlign: Right
  11. Using the handle to the left of the group footer row, select the row and in the BackgroundColor property select LightGray.
  12. Go to the preview tab, enter 1035 for the Employee ID, and click the View Report button. You get a layout that looks similar to the following at design time and at runtime.
    Design Time Layout Runtime Layout
  13. From the File menu, select Save and save this file. This report functions as the subreport you use in the main report.

To create the main report

  1. From the Visual Studio Project menu, select Add New Item.
  2. In the Add New Item dialog that appears, select ActiveReports 10 RDL Report and in the Name field, rename the file as Employees.rdlx.
  3. Click the Add button to open a new fixed RDL report in the designer.
  4. In the Report Explorer, select the Body node and go to the Properties window to set the Size property to 6.5in, 3.6in.

To connect the main report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like Reels.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

To add a dataset to the main report

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as EmployeeInfo. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query
    Copy Code
    SELECT * FROM EmployeeInfo
  4. Click the Validate icon to validate the query and to populate the Fields list.
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To add controls to display data on the main report

The following steps demonstrate how you can add controls and create the main report:

To add a static label to the top of the main report

From the toolbox, drag a TextBox control onto the body of the report and set the following properties:

Property Name | Property Value
Font | Normal, Arial, 14pt, Bold
Location | 0in, 0in
Size | 6.5in, 0.3in
TextAlign | Center
Value | Employee Report by City and Store

To add a List data region that repeats data for each city

  1. Drag a List data region from the toolbox onto the body of the report and with the data region selected, go to the Properties Window to set the following properties:
    Property Name | Property Value
    BackgroundColor | Silver
    DataSetName | EmployeeInfo
    Location

    0in, 0.5in
    Size | 6.5in, 3.1in
  2. At the bottom of the Properties Window, select the Property dialog command. See Properties Window for further details on accessing commands.
  3. In the List dialog that appears, select Detail Grouping.
  4. Under Expression, select =Fields!City.Value
  5. Click OK to close the dialog.
  6. From the Report Explorer, drag the City field onto the List data region and set the following properties:
    Property Name | Property Value
    FontSize | 12pt
    Location | 0in, 0in
    Size | 6.5in, 0.25in
    TextAlign | Center

To nest a second List data region that repeats data for each store within the city

  1. Drag a List data region from the toolbox onto the the first list and with the data region selected, go to the Properties Window to set the following properties:
    Property Name | Property Value
    BackgroundColor | Beige
    DataSetName | EmployeeInfo
    Location | 0.125in, 0.3in
    Size | 6.25in, 2.7in
  2. At the bottom of the Properties Window, select the Property dialog command. See Properties Window for further details on accessing commands.
  3. In the List dialog that appears, select Detail Grouping.
  4. Under Expression, select =Fields!StoreName.Value
  5. Click OK to close the dialog.
  6. From the Report Explorer, drag the StoreName field onto the list and set the following properties:
    Property Name | Property Value
    FontWeight | Bold
    Location | 0in, 0in
    Size | 2in, 0.25in

To nest a third List data region that repeats data for each employee in the store

  1. Drag a List data region from the toolbox onto the second list and with the data region selected, go to the Properties Window to set the following properties:
    Property Name | Property Value
    BackgroundColor | White
    DataSetName | EmployeeInfo
    Location | 0in, 0.25in
    Size | 6.125in, 2.125in
  2. At the bottom of the Properties Window, select the Property dialog command. See Properties Window for further details on accessing commands.
  3. In the List dialog, select Detail Grouping.
  4. Under Expression, select =Fields!EmployeeID.Value
  5. Click OK to close the dialog.
  6. From the Report Explorer, drag the following fields onto the list and set the following properties:
    Data Field Property Name
    Name Location: 1.125in, 0in
    Size: 2.625in, 0.25in
    Education Location: 1.125in, 0.25in
    Size: 2.625in, 0.25in
    DateOfBirth Location: 5in, 0in
    Size: 0.875in, 0.25in
    Format: Short date
    PhoneNumber Location: 4.875in, 0.25in
    Size: 1in, 0.25in
  7. From the toolbox, drag five text boxes onto the List and set the following properties:
    TextBox Name Value Property Property Name
    TextBox 1 Name: Location: 0.125in, 0in
    Size: 0.625in, 0.25in
    FontWeight: Bold
    TextBox 2 Education: Location: 0.125in, 0.25in
    Size: 0.875in, 0.25in
    FontWeight: Bold
    TextBox 3 Date of Birth: Location: 3.875in, 0in
    Size: 1in, 0.25in
    FontWeight: Bold
    TextBox 4 Phone: Location: 3.875in, 0.25in
    Size: 0.875in, 0.25in
    FontWeight: Bold
    TextBox 5 Sales Record Location: 0.125in, 0.5in
    Size: 1in, 0.25in
    FontWeight: Bold

To add a Subreport control to the main report

  1. From the toolbox, drag a Subreport control onto the third list and with the control selected, go to the Properties Window to set the following properties:
    Property Name | Property Value
    Location | 0.125in, 0.75in
    NoRows | No sales recorded for this employee during 2005.
    ReportName

    Sales (ensure that this report is saved in the same directory as the Sales report)

    Note: To view the report in the preview tab, you should specify the full path to the subreport.
    Size | 5.75in, 1.3in
    Visibility: Hidden | True (hides the subreport initially)
    Visibility: ToggleItem | Sales Record text box added in the previous procedure (puts a toggle image next to the text that shows the subreport when clicked)
  2. At the bottom of the Properties Window, select the Property dialog command. See Properties Window for further details on accessing commands.
  3. On the Parameters page of the Subreport dialog, set the Parameter Name to EmployeeID. This name must match the parameter in the subreport exactly.
  4. Set the Parameter Value to =Fields!EmployeeID.Value.
    Note: You can use the option of having the subreport automatically apply the same theme as the hosting report. This option is available on the General page of the Subreport Properties.
  5. Click OK to close the dialog.

To view the report

  • Click the preview tab to view the report.

OR

  • See Windows Forms Viewer to display report in the Viewer at runtime.
Note: Click the + to the left of Sales Record to see the subreport.


Chart

Chart
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Chart

This section contains the following walkthroughs that fall under the Chart category.

Charts
This walkthrough demonstrates how to create a report with a chart.
See Also
Page Report/RDL Report Walkthroughs


Charts

Charts
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Chart > Charts
Show All Show All
Hide All Hide All

You can create a page report with a chart using the ActiveReports Chart control. This walkthrough illustrates how to create a report with a chart.

The walkthrough is split into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a data source
  • Adding a dataset
  • Adding a chart control with data and grouping to the report
  • Configuring the appearance of the chart
  • Viewing the report
Note:
  • This walkthrough uses the Sales table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Page Report and in the Name field, rename the file as ProfitsByGenre.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as ProfitsByGenre. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query
    Copy Code
    SELECT Profit, SalesID, SaleDate, GenreName FROM SalesByGenre WHERE (SalesID < 1090) AND (GenreName = "Comedy" OR GenreName = "Drama" OR GenreName = "Adventure") ORDER BY SalesID
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.
  5. On the Fields page, add a new field by clicking the Add (+) button above the fields list.
  6. Set the Name to Month and the Value of the new field to =Fields!SaleDate.Value.Month
    This parses out the month from the date field.
  7. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To add chart control with data and grouping to the report

  1. From the toolbox, drag the Chart control onto of the report design surface.
  2. In the wizard Select a Chart Type that appears, select the chart type Column and go to the Properties Window to set the following properties:
    Property Name | Property Value
    Location | 0in, 0in
    Size | 6.5in, 4.5in
  3. Double-click inside the chart to display the UI along the top, right, and bottom of the chart to drop fields in.
  4. From the Report Explorer, drag the Month field into the area below the chart labeled "Drop category fields here." This automatically binds the Month field to the X axis.
  5. Right-click the month category group and select Edit to open the Chart Data - Category Groups dialog.
  6. In the dialog that appears on the General page, go to the Label field and enter the following expression: =MonthName(Fields!Month.Value) and click OK to close the dialog.
  7. From the ReportExplorer, drag the Profit field into the area above the chart labeled "Drop data fields here." This plots the profits to the Y axis of the chart.
  8. In the Report Explorer, drag the GenreName field into the area to the right of the chart labeled "Drop series fields here." This sets the series to be charted in the chart area.
  9. Right-click the genre series group and select Edit to open the Chart Data - Series Groups dialog.
  10. In the dialog that appears on the General page, go to the Label field and enter the following expression: =Fields!GenreName.Value. This shows genre names in the legend.
  11. Click OK to close the dialog.
  12. Select the chart and at the bottom of the Properties Window, select the Chart Data command. See Properties Window for further details on accessing commands.
  13. In the Chart Data dialog that appears, under Series Values go to the Value field and make sure it is set to =Sum(Fields!Profit.Value).

To configure the appearance of the chart

  1. Select the chart and at the bottom of the Properties Window, select the Chart appearance command.
  2. In the Chart Appearance dialog that appears set the following:

    Title Page

    On the Title page enter Profits by Genre in the Chart title text box and change the Size property to 14pt.

    Palette Page

    On the Palette page and select Light in the drop down list. This is a good color choice because it differentiates between genres without highlighting one of them unintentionally.

    Plot Area Page

    On the Plot Area page set the Background Fill Color > Fill Color to Silver.
  3. Click OK to close the dialog.
  4. Select the Chart Legends and at the bottom of the Properties Window, select the Property dialog command.
  5. In the Chart Legend - General dialog that appears, uncheck the Use smart settings option.
  6. Click OK to close the dialog.
  7. Select the X-Axis label in the chart and at the bottom of the Properties Window, select the Property dialog command.
  8. In the Chart X-Axis - Title dialog that appears set the following properties:

    Title Page

    On the Title page, in the X-Axis Title field remove the default "Axis X" text.

    Labels Page

    On the Labels page, set the Size property to 10pt.
  9. Click OK to close the dialog.
  10. Select the chart and at the bottom of the Properties Window, select the Chart Y-axis command.
  11. In the Chart Y-Axis - Title dialog that appears set the following properties:

    Title Page

    On the Title page, in the Y-Axis Title field remove the default "Axis Y" text if available.

    Labels Page

    On the Labels page and in the Format code field, select Currency in the Format drop-down list. Set the Size property to 10pt.

    Scale Page

    On the Scale page and in the Minimum field enter 0 (zero). This sets the currency labels to start at zero on the Y axis.
  12. Click OK to close the dialog.

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.
See Also

Concepts

Chart


Map

Map
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Map

This section contains the following walkthrough that fall under the Map category.

Reports with Map
This walkthrough demonstrates how to create a report with a map.
See Also
Page Report/RDL Report Walkthroughs


Reports with Map

Reports with Map
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Map > Reports with Map
Show All Show All
Hide All Hide All

You can create a page report that contains a map using the ActiveReports Map control. The Map data region shows your data on a geographical background. This walkthrough illustrates how to create a report that uses a Map to display data.

The walkthrough is split into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a data source
  • Adding a dataset
  • Adding Map control to the report and configuring its data
  • Configuring appearance of the Map
  • Viewing the report
Note:
  • This walkthrough use tables from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Page Report and in the Name field, rename the file to CustomersPopulation.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as Customers. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query
    Copy Code
    SELECT Address.Region, Customer.CustomerID FROM (Address INNER JOIN Person ON Address.[AddressID] = Person.[AddressID]) INNER JOIN Customer ON Person.[PersonID] = Customer.[PersonID];
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To add a Map data region and configure its data

  1. From the Visual Studio toolbox, drag and drop a Map control onto the design surface.
  2. In the Select a Map Template wizard that appears, select the USA Map template.
  3. Click the Map until the map panes appear.
  4. In the layers pane, right click PolygonLayer1 and select Layer Data to open Map Layer Data Properties dialog.
  5. In the Map Layer Data Properties dialog that appears, go to the Analytical data page.
  6. Select Customers from the Dataset property combo box and then click the Add (+) button located next to the Match label. This creates an empty match item and enables its Spatial and Analytical fields editor.
    Note: It is necessary to set match fields if you want to use a spatial data field from analytical data, or if you want to visualize analytical data on the map layer. Match fields enable the report processor to build a relationship between the analytical data and the spatial data.
  7. In the Spatial field property, select STATE_ABBR from the combo box; and similarly, select =Fields!Region.Value in the Analytical field property. This builds the match field expression and relates the analytical data to map elements on a polygon layer.
  8. Click OK to close the dialog.

To configure appearance of the Map

  1. In the layers pane, right click PolygonLayer1 and select Edit to open Map Polygon Layer dialog.
  2. In the General page of the dialog, select #STATE_NAME from the Label Text combo box to display as label inside polygons at runtime.
  3. Go to the Color Rule page of the dialog, and select Visualize data by using color palette option. This activates the tabs below.
  4. On the General tab, enter the following expression =Count([CustomerID]) in the Data field property and set Palette property to SemiTransparent.
  5. On the Distribution tab, set the Method property to EqualInterval.
  6. On the Legends tab, click to select Show in Legend.
  7. In Legend Name, enter Legend. This name relates to the default legend that appears in the Legend collection.
  8. Click OK to close the dialog.
  9. On the design surface, click on the Map control to select it and go to the Properties Window to set the following properties:

    Properties

    Property Name | Property Value
    BackgroundColor | White
    BackgroundGradientEndColor | White
    BorderStyle | Solid
    ColorScale > Hidden | True
    DistanceScale > Hidden | True
    Location | 0in, 0.625in
    Size | 6.5in, 4.75in
    ViewPort > BackgroundColor | LightSteelBlue
    ViewPort > BackgroundGradientEndColor | White
    ViewPort > BorderStyle | None
    ViewPort > CoordinateSystem | Planar
    ViewPort > Margin > Right | 20pt
    ViewPort > Meridians > Hidden | True
    ViewPort > Parallels > Hidden | True
    ViewPort > View > Zoom | 115
  10. With the Map control selected, go to the Properties window, click the Legends (Collection) property and then click the ellipsis button that appears.
  11. In the LegendDesigner Collection Editor that appears, under the Members list, select the existing legend and set the following properties:

    Properties

    Property Name | Property Value
    BackgroundColor | LightSteelBlue
    BackgroundGradientEndColor | White
    Location > DockOutsideViewport | False
    Location > DockPosition | RightBottom
    Title > (Caption) | Number of Customers
    Title > Font | Normal, Arial, 10pt, Bold
  12. Click OK to close the dialog.
  13. With the Map control selected, go to the Properties window, click the Titles (Collection) property and then click the ellipsis button that appears.
  14. In the MapTitleDesigner Collection Editor that appears, with Title selected in the Members list set the following properties:

    Properties

    Property Name | Property Value
    (Text) | Customers Population
    Color | Black
  15. Click OK to close the dialog.

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.


Tablix

Tablix
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Tablix

This section contains the following walkthrough that fall under the Tablix category.

Grouping in Tablix
This walkthrough demonstrates how to use grouping in Tablix.
Cell Merging in Tablix
This walkthrough demonstrates cells with duplicate values are merged in Tablix.


Grouping in Tablix

Grouping in Tablix
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Tablix > Grouping in Tablix

This walkthrough illustrates a step-by-step implementation for creating a report which uses the Tablix data region to display regional product sales.

The walkthrough is split into the following activities:

  • Creating an ActiveReports project in Visual Studio
  • Connecting the report to a data source
  • Adding a dataset
  • Creating a layout for the report
  • Enhancing the appearance of the report
  • Viewing the report
Note:
  • This walkthrough uses the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.
  • Although this walkthrough uses RDL reports, you can also implement this using page reports.

When you complete this walkthrough, you will have a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

Create an ActiveReports project in Visual Studio

  1. Create a new Visual Studio project.
  2. In the New Project dialog that appears, select ActiveReports 10 RDL Report Application and in the Name field, name the file rptTablix.
  3. Click OK to create a new ActiveReports 10 RDL Report Application. By default an RDL report is added to the project.

    See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

To add a dataset

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and name the dataset SalesData. This name appears as a child node of the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query
    Copy Code
    SELECT Sale.SaleDate, Sale.TotalAmount, MediaType.Description, MediaType.MediaID, Sale.SalesID,
Sale.Store, Store.StoreName FROM Store INNER JOIN
(Sale INNER JOIN (MediaType INNER JOIN (MovieProduct INNER JOIN SaleDetails
ON MovieProduct.ProductID = SaleDetails.ProductID) ON MediaType.MediaID =
MovieProduct.MediaType) ON Sale.SalesID = SaleDetails.SaleID)
ON Store.StoreID = Sale.Store;
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To create a layout for the report

  1. From the toolbox, drag a Tablix data region onto the designer surface of the report.
  2. Hover over TextBox2 to reveal the field selection adorner, click it to display a list of available fields, and select the SaleDate field. This is a column group cell, so selecting a field in it automatically adds a column group.
  3. With TextBox2 selected, in the Properties window set the Value to =Year(Fields!SaleDate.Value) using expressions. This groups and displays the data by Year.
  4. In the Group Editor, select the SaleDate group, and in the Properties window expand the Group property node and click the ellipsis button next to the GroupExporessions property to open the ExpressionDesigner Collection Editor.
  5. In the ExpressionDesigner Collection Editor that appears, select the group member from the Members list and in the property grid to the right, enter the expression =Year(Fields!SaleDate.Value) to group the data by year and then click OK to close the dialog.
  6. Right-click TextBox2 where SaleDate field is added in the Tablix data region, select Add Column Group, and then select the Adjacent Right option. The adjacent column group is added to the right and is listed under the Group Editor window.
  7. Hover over TextBox5 to reveal the field selection adorner, click it to display a list of available fields, and select the Description field. This is a column group cell, so selecting a field in it automatically adds a column group.
  8. Right-click TextBox5 where Description field is added in the Tablix data region, select Insert Row, and then select Outside Group - Above. The row is added above the new column group and is listed under the Group Editor window.
  9. In TextBox7 and TextBox8 above the SaleDate and Description fields, set the value property to Year and Media Type.
  10. Hover over TextBox3 to reveal the field selection adorner, click it to display a list of available fields, and select the StoreName field. This is a row group cell, and selecting a field in it automatically adds a row group.
  11. Hover over TextBox4 to reveal the field selection adorner, click it to display the list of available fields, and select the TotalAmount field.
  12. Hover over TextBox6 to reveal the field selection adorner, click it to display the list of available fields, and select the TotalAmount field.

To enhance the appearance of the report

When you preview the report at this point, you will notice the data from the fields is displayed in the Tablix data region. We can enhance the layout of the Tablix data region by setting cell properties in the Properties Window as follows:

  1. Cell | Property Name | Property Value
    =Year([SaleDate]) | BackgroundColor | WhiteSmoke
    BorderStyle | Solid
    FontWeight | Bold
    TextAlign | Center
    Year | BackgroundColor | LightSteelBlue
    BorderStyle | Solid
    FontWeight | Bold
    TextAlign | Center
    =[Description] | BackgroundColor | SlateGray
    BorderStyle | Solid
    FontWeight | Bold
    TextAlign | Center
    Media Type | BackgroundColor | LightSteelBlue
    BorderStyle | Solid
    FontWeight | Bold
    TextAlign | Center
    =[StoreName] | BackgroundColor | WhiteSmoke
    BorderStyle | Solid
    TextAlign | Center
    =Sum([TotalAmount]) | Format | c
    BorderStyle | Solid
    TextAlign | Center
  2. Select the two empty cells in the corner area (top left corner), right-click the selected area, and then select Merge Cells option to merge the cells.
  3. With the merged cell selected, in the Properties window set the Value property to Sales by Year and Media Type . This is the heading for the report.
  4. In the Tablix data region, select the textbox that contains Sales by Year and Media Type text and then go to Properties Window to set the following properties.
    Property Name | Property Value
    BackgroundColor | LightSteelBlue
    BorderStyle | Solid
    FontWeight | Bold
    TextAlign | Center
  5. Select the Tablix data region and go to the Properties window to set the following properties.
    Property Name | Property Value
    Location | 0in, 0in
    Size | 3in, 1.125in

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.


Cell Merging in Tablix

Cell Merging in Tablix
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Tablix > Cell Merging in Tablix

This walkthrough illustrates a step-by-step implementation for creating a report which uses the Tablix data region to display store numbers and managers by region and district. The report in this walkthrough demonstrates how Tablix cells with same value automatically merge to avoid clutter.

The walkthrough is split into the following activities:

  • Creating an ActiveReports project in Visual Studio
  • Connecting the report to a data source
  • Adding a dataset
  • Creating a layout for the report
  • Enhancing the appearance of the report
  • Viewing the report
Note:
  • This walkthrough uses the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.
  • Although this walkthrough uses RDL reports, you can also implement this using page reports.

When you complete this walkthrough, you will have a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To create an ActiveReports project in Visual Studio

  1. Create a new Visual Studio project.
  2. In the New Project dialog that appears, select ActiveReports 10 RDL Report Application and in the Name field, name the file rptTablix.
  3. Click OK to create a new ActiveReports 10 RDL Report Application. By default an RDL report is added to the project.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect a report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

To add a dataset

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and name the dataset StoreDetails. This name appears as a child node of the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query
    Copy Code
    SELECT Regions.RegionID, Regions.Region, Districts.DistrictID, Districts.District,
Store.StoreName, Person.FirstName, Person.LastName FROM ((Regions INNER JOIN
Districts ON Regions.RegionID = Districts.Region) INNER JOIN Store ON
Districts.DistrictID = Store.DistrictID) INNER JOIN Person ON Store.Manager =
Person.PersonID;
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To create a layout for the report

  1. From the toolbox, drag a Tablix data region onto the designer surface of the report.
  2. Hover over TextBox3 to reveal the field selection adorner, click it to display a list of available fields, and select the Region field. This a row group cell, and selecting a field in it automatically adds a row group.
  3. Select TextBox1 above the Region row group cell, and in the Properties window set the Value property to Region. This is the heading for the row group.
  4. Right-click TextBox3 where the Region field was added in the Tablix data region, select Add Row Group, and then select the Child Group option. The child group is added to the right of the row header and is listed under the Group Editor window.
  5. Hover over TextBox5 to reveal the field selection adorner, click it to display a list of available fields, and select the District field. This a row group cell, and selecting a field in it automatically adds a row group.
  6. Select Textbox6 above the District row group cell, and in the Properties window set the Value property to District. This is the heading for the row group.
  7. Right-click TextBox5 where the District field was added in the Tablix data region, select Add Row Group, and then select the Child Group option. The child group is added next to the new row group and is listed under the Group Editor window.
  8. Hover over TextBox7 to reveal the field selection adorner, click it to display a list of available fields, and select the StoreName field. This a row group cell, and selecting a field in it automatically adds a row group.
  9. Select Textbox8 above the StoreName row group cell, and in the Properties window set the Value property to Store. This is the heading for row group.
  10. Right click Textbox8 above the StoreName row group cell, select Insert Column, and then select Right. This adds a new static column.
  11. Hover over TextBox9 to reveal the field selection adorner, click it to display a list of available fields, and select the FirstName field.
  12. With TextBox9 selected, in the Properties window set the Value property to =Fields!FirstName.Value & " " & Fields!LastName.Value using expressions.
  13. Select Textbox10 above the =[FirstName] & " " & [LastName] column cell, and in the Properties window set the Value property to Manager. This is the heading for the static column.

To enhance the appearance of the report

When you preview the report at this point, you will notice the data from the fields is displayed in the Tablix data region. We can enhance the layout of the Tablix data region by setting cell properties in the Properties Window as follows:

Cell | Property Name | Property Value
=[Region] | BackgroundColor | Gainsboro
 | BorderStyle | Solid
 | FontWeight | Bold
 | TextAlign | Center
 | VerticalAlign | Middle
Region | BackgroundColor | Gray
 | BorderStyle | Solid
 | FontWeight | Bold
 | TextAlign | Center
=[District] | BackgroundColor | LightSteelBlue
 | BorderStyle | Solid
 | FontWeight | Bold
 | TextAlign | Center
 | VerticalAlign | Middle
District | BackgroundColor | Gray
 | BorderStyle | Solid
 | FontWeight | Bold
 | TextAlign | Center
=[StoreName] | BackgroundColor | WhiteSmoke
 | BorderStyle | Solid
 | TextAlign | Center
Store | BackgroundColor | Gray
 | BorderStyle | Solid
 | FontWeight | Bold
 | TextAlign | Center
=[FirstName] & " " & [LastName] | BorderStyle | Solid
 | TextAlign | Center
Manager | BackgroundColor | Gray
 | BorderStyle | Solid
 | FontWeight | Bold
 | TextAlign | Center

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.


Export

Export
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Export

This section contains the following walkthroughs that fall under the Export category.

Custom Web Exporting
This walkthrough demonstrates how to export your report into several popular formats like PDF, HTML, Excel, Image and Word.
See Also
Page Report/RDL Report Walkthroughs


Custom Web Exporting

Custom Web Exporting
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Export > Custom Web Exporting
Show All Show All
Hide All Hide All

ActiveReports provides components that allow you to export your reports into several popular formats like PDF, HTML, Excel, Image, Word and XML.

The walkthrough is split up into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Adding code to the Web Form to create the PDF, HTML, Excel, Word, XML and Image Export objects and export a report.
  • Running the project
Note: Although this walkthrough uses Page reports, you can also implement this using RDL reports.

To add an ActiveReport to the Visual Studio project

  1. Create a new ASP.NET Web Application project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Page Report and in the Name field, rename the file as CustomWebExporting.
  4. Click the Add button to open a new fixed page report in the designer.
  5. In the Solution Explorer, right-click the References node and select Add Reference.
  6. In the Add Reference dialog that appears, select the following references and click OK to add them to your project.
    GrapeCity.ActiveReports.Export.Pdf.v10
    GrapeCity.ActiveReports.Export.Html.v10
    GrapeCity.ActiveReports.Export.Excel.v10
    GrapeCity.ActiveReports.Export.Word.v10
    GrapeCity.ActiveReports.Export.Image.v10
    GrapeCity.ActiveReports.Export.Xml.v10

See Adding an ActiveReport to a Project for information on adding different report layouts.

To add code to the Web Form to create the PDF Export object and export a report

  1. Double-click on the design view of the aspx page. This creates an event-handling method for the Page_Load event.
  2. Add code like the following to the Page_Load event.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Page Load event.
Copy Code
'Provide the page report you want to render.
Dim report As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(Server.MapPath("") + "\CustomWebExporting.rdlx"))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

'Set the rendering extension and render the report.
Dim pdfRenderingExtension As New GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider()
reportDocument.Render(pdfRenderingExtension, outputProvider)

Response.ContentType = "application/pdf"
Response.AddHeader("content-disposition", "inline;filename=MyExport.pdf")
Dim ms As New System.IO.MemoryStream()
CType(outputProvider.GetPrimaryStream().OpenStream(), System.IO.MemoryStream).WriteTo(ms)
Response.BinaryWrite(ms.ToArray())
Response.End()

To write the code in C#

C# code. Paste INSIDE the Page Load event.
Copy Code
// Provide the page report you want to render.
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(Server.MapPath("") + "\\CustomWebExporting.rdlx"));
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension pdfRenderingExtension = new GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider();
reportDocument.Render(pdfRenderingExtension, outputProvider);

Response.ContentType = "application/pdf";
Response.AddHeader("content-disposition", "inline;filename=MyExport.pdf");
System.IO.MemoryStream ms = new System.IO.MemoryStream();
outputProvider.GetPrimaryStream().OpenStream().CopyTo(ms);
Response.BinaryWrite(ms.ToArray());
Response.End();

Note: To use the one-touch printing option, add the following to the code above.

Visual Basic.NET code. Paste INSIDE the Page Load event.
Copy Code
' Replace the line reportDocument.Render(pdfRenderingExtension, outputProvider) in the code above with the following

Dim setting As New GrapeCity.ActiveReports.Export.Pdf.Page.Settings()
setting.PrintOnOpen = True
reportDocument.Render(pdfRenderingExtension, outputProvider,setting)
C# code. Paste INSIDE the Page Load event.
Copy Code
// Replace the line reportDocument.Render(pdfRenderingExtension, outputProvider); in the code above with the following

GrapeCity.ActiveReports.Export.Pdf.Page.Settings setting = new GrapeCity.ActiveReports.Export.Pdf.Page.Settings();
setting.PrintOnOpen = true;
reportDocument.Render(pdfRenderingExtension, outputProvider,setting);
Warning: You need to manually license your application in order to use PDF export.

To add code to the Web Form to create the HTML Export object and export a report

  1. Double-click on the design view of the aspx page. This creates an event-handling method for the Page_Load event.
  2. Add code like the following to the Page_Load event.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Page Load event.
Copy Code
' Provide the page report you want to render.
Dim report As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(Server.MapPath("") + "\CustomWebExporting.rdlx"))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

' Set the rendering extension and render the report.
Dim htmlRenderingExtension As New GrapeCity.ActiveReports.Export.Html.Page.HtmlRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider()
Dim setting As New GrapeCity.ActiveReports.Export.Html.Page.Settings()
setting.Mode = GrapeCity.ActiveReports.Export.Html.Page.RenderMode.Galley
setting.MhtOutput = True

reportDocument.Render(htmlRenderingExtension, outputProvider, setting)

Response.ContentType = "message/rfc822"
Response.AddHeader("content-disposition", "inline;filename=MyExport.mht")
Dim ms As New System.IO.MemoryStream()
CType(outputProvider.GetPrimaryStream().OpenStream(), System.IO.MemoryStream).WriteTo(ms)
Response.BinaryWrite(ms.ToArray())
Response.End()

To write the code in C#

C# code. Paste INSIDE the Page Load event.
Copy Code
// Provide the page report you want to render.
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(Server.MapPath("") + "\\CustomWebExporting.rdlx"));
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Html.Page.HtmlRenderingExtension htmlRenderingExtension = new GrapeCity.ActiveReports.Export.Html.Page.HtmlRenderingExtension();GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider();GrapeCity.ActiveReports.Export.Html.Page.Settings setting = new GrapeCity.ActiveReports.Export.Html.Page.Settings();
setting.Mode = GrapeCity.ActiveReports.Export.Html.Page.RenderMode.Galley;
setting.MhtOutput = true;

reportDocument.Render(htmlRenderingExtension, outputProvider, setting);

Response.ContentType = "message/rfc822";
Response.AddHeader("content-disposition", "inline;filename=MyExport.html");
System.IO.MemoryStream ms = new System.IO.MemoryStream();
outputProvider.GetPrimaryStream().OpenStream().CopyTo(ms);
Response.BinaryWrite(ms.ToArray());
Response.End();

To add code to the Web Form to create the Excel Export

  1. Double-click on the design view of the aspx page. This creates an event-handling method for the Page_Load event.
  2. Add code like the following to the Page_Load event.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Page Load event.
Copy Code
' Provide the page report you want to render.
Dim report As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(Server.MapPath("") + "\CustomWebExporting.rdlx"))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

' Provide settings for your rendering output.
Dim excelSetting As New GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionSettings()
excelSetting.FileFormat = GrapeCity.ActiveReports.Export.Excel.Page.FileFormat.Xlsx
Dim setting As GrapeCity.ActiveReports.Extensibility.Rendering.ISettings = excelSetting

' Set the rendering extension and render the report.
Dim excelRenderingExtension As New GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider()
reportDocument.Render(excelRenderingExtension, outputProvider, setting.GetSettings())

Response.ContentType = "application/vnd.ms-excel"
Response.AddHeader("content-disposition", "inline;filename=MyExport.xls")
Dim ms As New System.IO.MemoryStream()
outputProvider.GetPrimaryStream().OpenStream().CopyTo(ms)
Response.BinaryWrite(ms.ToArray())
Response.[End]()

To write the code in C#

C# code. Paste INSIDE the Page Load event.
Copy Code
// Provide the page report you want to render.
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(Server.MapPath("") + "\\CustomWebExporting.rdlx"));
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Provide settings for your rendering output.
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionSettings excelSetting = new GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionSettings();
excelSetting.FileFormat = GrapeCity.ActiveReports.Export.Excel.Page.FileFormat.Xlsx;
GrapeCity.ActiveReports.Extensibility.Rendering.ISettings setting = excelSetting;

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtension excelRenderingExtension = new GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider();
reportDocument.Render(excelRenderingExtension, outputProvider, setting.GetSettings());

Response.ContentType = "application/vnd.ms-excel";
Response.AddHeader("content-disposition", "inline;filename=MyExport.xls");
System.IO.MemoryStream ms = new System.IO.MemoryStream();
outputProvider.GetPrimaryStream().OpenStream().CopyTo(ms);
Response.BinaryWrite(ms.ToArray());
Response.End();

To add code to the Web Form to create the Word Export object and export a report

  1. Double-click on the design view of the aspx page. This creates an event-handling method for the Page_Load event.
  2. Add code like the following to the Page_Load event.
    Note: To export your report in .Doc format, change the FileFormat property option from .Docx to .Doc format as depicted below.
    wordSetting.FileFormat = GrapeCity.ActiveReports.Export.Word.Page.FileFormat.Doc

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Page Load event.
Copy Code
' Provide the page report you want to render
Dim report As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(Server.MapPath("") + "\CustomWebExporting.rdlx"))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

' Set the rendering extension and render the report
Dim wordRenderingExtension As New GrapeCity.ActiveReports.Export.Word.Page.WordRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider()

' Set FileFormat property to .Docx
Dim wordSetting As New GrapeCity.ActiveReports.Export.Word.Page.Settings()
wordSetting.FileFormat = GrapeCity.ActiveReports.Export.Word.Page.FileFormat.OOXML

reportDocument.Render(wordRenderingExtension, outputProvider, wordSetting)
Response.ContentType = "application/msword"
Response.AddHeader("content-disposition", "inline;filename=MyExport.docx")
Dim ms As New System.IO.MemoryStream()
CType(outputProvider.GetPrimaryStream().OpenStream(), System.IO.MemoryStream).WriteTo(ms)
Response.BinaryWrite(ms.ToArray())
Response.End()

To write the code in C#

C# code. Paste INSIDE the Page Load event.
Copy Code
// Provide the page report you want to render
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(Server.MapPath("") + "\\CustomWebExporting.rdlx"));
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Set the rendering extension and render the report
GrapeCity.ActiveReports.Export.Word.Page.WordRenderingExtension wordRenderingExtension = new GrapeCity.ActiveReports.Export.Word.Page.WordRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider();

// Set the FileFormat property to .Docx
GrapeCity.ActiveReports.Export.Word.Page.Settings wordSetting = new GrapeCity.ActiveReports.Export.Word.Page.Settings();
wordSetting.FileFormat = GrapeCity.ActiveReports.Export.Word.Page.FileFormat.OOXML;

reportDocument.Render(wordRenderingExtension, outputProvider, wordSetting);
Response.ContentType = "application/msword";
Response.AddHeader("content-disposition", "inline;filename=MyExport.OOXML");
System.IO.MemoryStream ms = new System.IO.MemoryStream();
outputProvider.GetPrimaryStream().OpenStream().CopyTo(ms);
Response.BinaryWrite(ms.ToArray());
Response.End();

To add code to the Web Form to create the Image Export object and export a report

  1. Double-click on the design view of the aspx page. This creates an event-handling method for the Page_Load event.
  2. Add code like the following to the Page_Load event.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Page Load event.
Copy Code
' Provide the page report you want to render.
Dim report As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(Server.MapPath("") + "\CustomWebExporting.rdlx"))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

' Set the rendering extension and render the report.
Dim imageRenderingExtension As New GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider()
Dim setting As New GrapeCity.ActiveReports.Export.Image.Page.Settings()
setting.ImageType = GrapeCity.ActiveReports.Export.Image.Page.Renderers.ImageType.JPEG
reportDocument.Render(imageRenderingExtension, outputProvider, setting)

Response.ContentType = "image/jpeg"
Response.AddHeader("content-disposition", "inline;filename=MyExport.jpg")
Dim ms As New System.IO.MemoryStream()

' Get the first page of the report
CType(outputProvider.GetSecondaryStreams()(0).OpenStream(), System.IO.MemoryStream).WriteTo(ms)
Response.BinaryWrite(ms.ToArray())
Response.End()

To write the code in C#

C# code. Paste INSIDE the Page Load event.
Copy Code
// Provide the page report you want to render.
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(Server.MapPath("") + "\\CustomWebExporting.rdlx"));
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension imageRenderingExtension = new GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider();
GrapeCity.ActiveReports.Export.Image.Page.Settings setting = new GrapeCity.ActiveReports.Export.Image.Page.Settings();
setting.ImageType = GrapeCity.ActiveReports.Export.Image.Page.Renderers.ImageType.JPEG;

reportDocument.Render(imageRenderingExtension, outputProvider, setting);

Response.ContentType = "image/jpeg";
Response.AddHeader("content-disposition", "inline;filename=MyExport.jpg");
System.IO.MemoryStream ms = new System.IO.MemoryStream();
// Get the first page of the report
outputProvider.GetSecondaryStreams()[0].OpenStream().CopyTo(ms);
Response.BinaryWrite(ms.ToArray());
Response.End();

To add code to the Web Form to create the XML Export object and export a report.

  1. Double-click on the design view of the aspx page. This creates an event-handling method for the Page_Load event.
  2. Add code like the following to the Page_Load event.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Page Load event.
Copy Code
' Provide the page report you want to render.
Dim report As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(Server.MapPath("") + "\CustomWebExporting.rdlx"))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(report)

' Set the rendering extension and render the report.
Dim xmlRenderingExtension As New GrapeCity.ActiveReports.Export.Xml.Page.XmlRenderingExtension()
Dim outputProvider As New GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider()
reportDocument.Render(xmlRenderingExtension, outputProvider)

Response.ContentType = "application/xml"
Response.AddHeader("content-disposition", "inline;filename=MyExport.xml")
Dim ms As New System.IO.MemoryStream()
outputProvider.GetPrimaryStream().OpenStream().CopyTo(ms)
Response.BinaryWrite(ms.ToArray())
Response.[End]()

To write the code in C#

C# code. Paste INSIDE the Page Load event.
Copy Code
// Provide the page report you want to render.
GrapeCity.ActiveReports.PageReport report = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(Server.MapPath("") + "\\CustomWebExporting.rdlx"));
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(report);

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Xml.Page.XmlRenderingExtension xmlRenderingExtension = new GrapeCity.ActiveReports.Export.Xml.Page.XmlRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider outputProvider = new GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider();
reportDocument.Render(xmlRenderingExtension, outputProvider);

Response.ContentType = "application/xml";
Response.AddHeader("content-disposition", "inline;filename=MyExport.xml");
System.IO.MemoryStream ms = new System.IO.MemoryStream();
outputProvider.GetPrimaryStream().OpenStream().CopyTo(ms);
Response.BinaryWrite(ms.ToArray());
Response.End();

To run the project

Press F5 to run the project.

See Also
Custom Web Exporting (Std Edition)


Preview

Preview
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Preview

This section contains the following walkthroughs that fall under the Preview category.

Drilldown Reports
This walkthrough demonstrates how to create a drilldown report using the Hidden and ToggleItem properties.
Drill-Through Reports
This walkthrough demonstrates how to create a drill-through link to another report containing details about the linked item.
Parameterized Reports
This walkthrough demonstrates how to create a report with multivalue parameters and an option to select all of the data.
Reports with Bookmarks
This walkthrough demonstrates how to set up bookmarks and links in a report.
Reports with TableOfContents
This walkthrough demonstrates how to create a report that includes the TableOfContents (ToC) control and displays the document map on a report page.
See Also
Page Report/RDL Report Walkthroughs


Drilldown Reports

Drilldown Reports
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Preview > Drilldown Reports
Show All Show All
Hide All Hide All

This walkthrough expands upon the report created in the Master Detail Reports walkthrough. If you have not created the Master Detail report (CustomerOrders.rdlx) already, please do so before continuing.

This walkthrough illustrates how to create a drilldown report using the Hidden and ToggleItem properties.

The walkthrough is split up into the following activities:

  • Opening the Master Detail Report
  • Hiding table rows and setting a toggle item
  • Viewing the report
Note: This walkthrough uses the Customer table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.

When you complete this walkthrough you get a layout that looks similar to the following at runtime.

Design Time Layout

Runtime Layout

To open the report in Visual Studio

  1. Open the Master Detail Report project in Visual Studio.
  2. In the Visual Studio Solution Explorer, double-click CustomerOrders.rdlx.

To hide table rows and set a toggle item

  1. In the designer, click inside the table to display the column and row handles along the top and left sides of the table.
  2. Select the second group header row containing the static labels (Title, Quantity, Price and Total) by clicking the row handle to the left of it.
  3. Hold the CTRL key and select the Detail row containing field expressions to add to the selection.
  4. In the Properties window, expand the Visibility property and set its properties as follows.
    Property Name | Property Value
    Visibility Hidden | True
    Visibility Toggle Item | TextBox10 (the textbox containing the expression =First(Fields!LastName.Value))

To view the report

  • Click the preview tab to view the report at design time.
  1. Click the Preview tab of the report designer.
  2. Click the + icon next to a customer to display order details for that customer.
  3. Click the - icon to hide the details.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.


Drill-Through Reports

Drill-Through Reports
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Preview > Drill-Through Reports
Show All Show All
Hide All Hide All

The following procedures illustrate how to create a drill-through link to another report containing details about the linked item.

The walkthrough is split into the following activities:

  • Creating a main report
  • Connecting the main report to a data source and adding a dataset
  • Adding controls to the main report to contain data
  • Creating a detail report
  • Connecting the detail report to a data source
  • Adding a dataset with a parameter
  • Creating a dataset to populate the parameter values
  • Adding a report parameter
  • Adding controls to the detail report to contain data
  • Adding a drill-through link in the main report
  • Viewing the report
Note:
  • This walkthrough uses tables from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at runtime.

Runtime Layout (main report)

Runtime Layout (detail report)

To create the main report

  1. Create a new Visual Studio project.
  2. From the Visual Studio Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Page Report and in the Name field, rename the file as MainReport.rdlx.
  4. Click the Add button to open a new page report in the designer.

To connect the main report to a data source and add a dataset

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like MainReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.
  4. In the Report Explorer, right-click the data source node and select the Add Data Set option.
  5. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as Movie. This name appears as a child node to the data source icon in the Report Explorer.
  6. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query
    Copy Code
    SELECT * FROM Movie ORDER BY MovieID ASC
  7. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  8. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To create a layout for the main report

  1. In the Visual Studio toolbox, go to the ActiveReports 10 Page Report tab and drag a TextBox control onto the design surface.
  2. Select the TextBox control and go to the Properties window to set the following properties.
    Property Name | Property Value
    Location | 0.75in, 0.125in
    Font | Normal, Arial, 18pt, Bold
    Size | 5in, 0.5in
    TextAlign | Center
    Value | MOVIES INFORMATION
  3. From the Visual Studio toolbox, drag a Table data region and place it on the design surface.
  4. Select the Table and go to the Properties window to set the following properties.
    Property Name | Property Value
    Location | 0in, 1.125in
    FixedSize | 6.5in, 7in
    BorderStyle | Solid
    RepeatHeaderOnNewPage | True
    Size | 6.5in, 0.75in
  5. In the Table data region, place your mouse over the cells of the table details row to display the field selection adorner.

  6. Click the adorner to show a list of available fields from the DataSet and add the following fields to the cells of the table details row.

    Cell | Field
    Left Cell | MovieID
    Middle Cell | Title
    Right Cell | YearReleased
    This automatically places an expression in the details row and simultaneously places a static label in the header row of the same column.
    Tip: You can also directly drag fields from the Report Explorer onto the textbox cells of the Table data region.
  7. Select the following table rows and go to the Properties window to set their properties.

    Table Header

    Property Name | Property Value
    BorderStyle | Solid
    Font | Normal, Arial, 12pt, Bold
    TextAlign | Center

    Table Details

    Property Name | Property Value
    BorderStyle | Solid
    Font | Normal, Arial, 10pt, Bold
    TextAlign | Center

To create the detail report

  1. From the Visual Studio Project menu, select Add New Item.
  2. In the Add New Item dialog that appears, select ActiveReports 10 Page Report and in the Name field, rename the file as MovieDetails.rdlx.
  3. Click the Add button to open a new page report in the designer.

To connect the detail report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

To add a dataset with a parameter

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as MovieInfo. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Parameters page under Parameter Name enter MovieID.
  4. Under Value enter =Parameters!MovieID.Value
  5. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query
    Copy Code
    Select * from MovieCastInformation
  6. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  7. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.
  8. In an Page report, set the Dataset name in the FixedPage dialog > General tab to MovieInfo. For more information, see FixedPage Dialog.
Caution: In an Page report, you may get an error if the Dataset name for the FixedPage is not be specified explicitly.

To add a dataset to populate the parameter values

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as MovieTitles. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query
    Copy Code
    SELECT MovieID, Title FROM Movie ORDER BY Title ASC
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To add a parameter to the report

  1. In the Report Explorer, select the Parameters node.
  2. Right-click the node and select Add Parameter to open the Report - Parameters dialog.
  3. Set properties in the following fields below the parameters list.

    In the General tab:

    • Name: MovieID
    • DataType: Integer

    In the Available Values tab select From query:

    • DataSet: MovieTitles
    • Value: MovieID
    • Label: Title
  4. Click OK to close the dialog and add the parameter to the collection. This parameter appears under the Parameters node in the Report Explorer.

To create a layout for the detail report

  1. Click the gray area below the design surface to select the report.
  2. Go to the Properties window, expand the PageSize property and set the Width to 8.5in and Height to 3in.
  3. From the toolbox, drag a List control onto the design surface and in the Properties window, set the following properties:
    Property Name | Property Value
    DataSetName | MovieInfo
    Location | 0in, 0in
    Name | MovieList
    Size | 6.5in, 1in
    FixedSize (only for Page reports) | 6.5in, 1in
  4. With the List control selected, at the bottom of the Properties Window, select the Property dialog command.
  5. In the List dialog that appears, on the Detail Grouping page, set the Group on: Expression to =Fields!MovieID.Value.
  6. Click OK to close the dialog.
  7. From the Report Explorer, go to the MovieInfo dataset and drag the following five fields onto the MovieList data region. In the properties window, set their properties as indicated.

    Title

    Property Name | Property Value
    Name | MovieTitle
    Location | 0in, 0in
    Size | 6.5in, 0.375in
    TextAlign | Center
    FontSize | 14pt

    YearReleased

    Property Name | Property Value
    Name | YearReleased
    Location | 1in, 0.375in
    Size | 0.75in, 0.25in
    TextAlign | Left

    MPAA

    Property Name | Property Value
    Name | MPAA
    Location | 6in, 0.375in
    Size | 0.5in, 0.25in

    UserRating

    Property Name | Property Value
    Name | UserRating
    Location | 1in, 0.625in
    Size | 0.25in, 0.25in
    TextAlign | Left

    Length

    Property Name | Property Value
    Name | Length
    Location | 4.75in, 0.625in
    Size | 1.75in, 0.25in
    TextAlign | Left
    Value | =Fields!Length.Value & " minutes"
    Note: When you drag and drop fields from a dataset in the Report Explorer onto the design surface, these fields are automatically converted to Textbox controls that you can modify by setting the control properties in the Properties Window.
  8. From the Report Explorer, drag four TextBox controls onto the MovieList data region and in the properties window, set their properties as indicated.

    TextBox1

    Property Name | Property Value
    Location | 0in, 0.375in
    Size | 1in, 0.25in
    Name | ReleaseLabel
    Value | Released in:
    FontWeight | Bold

    TextBox2

    Property Name | Property Value
    Location | 3.625in, 0.375in
    Size | 1.875in, 0.25in
    Name | MPAALabel
    Value | The MPAA rated this film:
    FontWeight | Bold

    TextBox3

    Property Name | Property Value
    Location | 0in, 0.625in
    Size | 1in, 0.25in
    Name | UserRatingLabel
    Value | User rating:
    FontWeight | Bold

    TextBox4

    Property Name | Property Value
    Location | 4.125in, 0.625in
    Size | 0.625in, 0.25in
    Name | LengthLabel
    Value | Length:
    FontWeight | Bold

To add a drill-through link to the main report

  1. On the design surface, select the cell containing the Title field inside the table data region and at the bottom of the Properties Window, click the Property dialog command.
  2. In the Textbox dialog that appears, go to the Navigation page.
  3. Under Action, select Jump to report and set the report name MovieDetails.rdlx.
  4. Under Jump to report set the Name of the parameter to MovieID.
    Caution: The parameter name must exactly match the parameter in the target report.
  5. Set the Value to =Fields!MovieID.Value.
  6. Click OK to close the dialog.

To view the report

Open the report in the Viewer. See Windows Forms Viewer for further information.


Parameterized Reports

Parameterized Reports
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Preview > Parameterized Reports
Show All Show All
Hide All Hide All

You can create a parameterized report with ActiveReports and provide an "All" choice for users who want to see all of the data as well as the ability to select multiple values for those who want to see data for several items.

This walkthrough illustrates how to create a report with multivalue parameters and an option to select all of the data.

The walkthrough is split up into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a data source
  • Adding a Dataset with a parameter
  • Creating a Dataset to populate the parameter values
  • Adding a Report Parameter
  • Adding controls to the report to contain data
  • Viewing the report
Note:
  • This walkthrough uses the Movie table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Page Report and in the Name field, rename the file as MoviesByProducer.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

To add a dataset to populate the parameter values

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as Producers. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query
    Copy Code
    SELECT -1 AS ProductionID, "(All)" AS Name
FROM Producers
UNION
SELECT ProductionID, Name
FROM Producers;
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To add a parameter to the report

  1. In the Report Explorer, select the Parameters node.
  2. Right-click the node and select Add Parameter to open the Report - Parameters dialog.
  3. In the dialog box that appears, click the Add(+) button to add a new parameter in the list.
  4. Set properties in the following fields below the parameters list.

    In the General tab:

    • Name: ProductionID
    • DataType: Integer
    • Text for prompting users for a value: Select a production company.
    • Select the check box next to Multivalue to allow users to select more than one production company from the list.

    In the Available Values tab select From query:

    • DataSet: Producers
    • Value: ProductionID
    • Label: Name
      Note: The name of the parameter you enter must exactly match the name of the parameter in the linked report, and it is case sensitive. You can pass a value from the current report to the parameter in the Value column of the list. If a value is not supplied for an expected parameter in the linked report, or if the parameter names do not match, the linked report will not run.
  5. Click OK to close the dialog and add the parameter to the collection. This parameter appears under the Parameters node in the Report Explorer.

To add a dataset with a parameter

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as Movies. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Parameters page under Parameter Name enter Param1.
  4. Under Value enter =Parameters!ProductionID.Value
  5. On the Parameters page under Parameter Name enter Param2.
  6. Under Value enter =Parameters!ProductionID.Value
  7. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query
    Copy Code
    SELECT Movie.Title, Movie.YearReleased, Movie.UserRating, Producers.Name
FROM Producers INNER JOIN (Movie INNER JOIN MovieProducers ON Movie.MovieID = MovieProducers.MovieID) ON Producers.ProductionID = MovieProducers.ProductionID
WHERE (MovieProducers.ProductionID IN (?)) OR (-1 IN (?))
ORDER BY MovieProducers.ProductionID, Movie.YearReleased;
  8. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  9. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To create a layout for the report

  1. From the toolbox, drag a Table control onto the design surface and in the Properties window, set the following properties.
    Property Name | Property Value
    Location | 0in, 1in
    DataSetName | Movies
    FixedSize (only for Page reports) | 6.5in, 7.5in
  2. Click inside the table to display the column and row handles along the top and left sides of the table.
  3. To visually group the data within the report, right-click the icon to the left of the detail row and select Insert Group.
  4. In the Table - Groups dialog that appears, under Expression select =Fields!Name.Value to group all details from each producer.
  5. Change the Name to Producer.
    Note: You cannot change the name of a table group until after you have set the expression.
  6. On the Layout tab of the Table - Groups dialog, select the check box next to Repeat group header to ensure that the header is printed at the top of each page.
  7. Clear the check box next to Include group footer as we will not be using it for this report.
  8. Click OK to close the dialog.
  9. In the Report Explorer, from the Movies dataset drag the following fields into the detail row of the table and set their properties as in the following table.
    Field | Column | Width
    Title | TableColumn1 | 3.9in
    YearReleased | TableColumn2 | 1.3in
    UserRating | TableColumn3 | 1.3in
  10. Static labels with the field names are automatically created in the table header row. To improve the appearance of the report, select the table header row, and set the text to Bold and change the FontSize to 11pt.
  11. From the Report Explorer, the Movies dataset drag the Name field into the first column of the group header row of the table and set the following properties.
    Property Name | Property Value
    FontWeight | Bold
    BackgroundColor | Thistle
    Tip: Use the Ctrl key to select all three text boxes in the group header row, right-click and select Merge Cells to prevent long production company names from wrapping.

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.


Reports with Bookmarks

Reports with Bookmarks
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Preview > Reports with Bookmarks
Show All Show All
Hide All Hide All

You can assign a bookmark ID to any report control and link a text box or image to it to allow users to easily navigate between items in the finished report. The bookmark link works like a hyperlink, except that clicking a bookmark link jumps to another page or area of the report instead of to a Web page.

This walkthrough explains the steps involved in setting up bookmarks and links.

The walkthrough is split up into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to an XML data source
  • Adding a Dataset
  • Adding controls to the report to contain data
  • Assigning a bookmark ID to a report control
  • Adding a bookmark link to a report control
  • Viewing the report
Note:
  • This walkthrough uses the Factbook sample database. By default, in ActiveReports, the Factbook.rdsx file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\Factbook.rdsx.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.
Note: If you have already created the report outlined in the Reports with XML Data walkthrough, you can open that report and go directly to the Assigning a Bookmark ID section of this walkthrough.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add an ActiveReport to a Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Page Report and in the Name field, rename the file as ExchangeRates.rdlx.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like Factbook.
  3. On this page, check the Shared Reference checkbox.
  4. Click the Browse button and select Factbook.rdsx, which is located in [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data. See Connect to a Data Source for information on connecting to a data source.

To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as ExchangeRates.
  3. On the Query page, enter the following XML path into the Query text box to access data for every country except "World":
    //country [@name != 'World']
  4. On the Fields page, enter the values in the table below to create fields for your report. Values for XML data fields must be valid XPath expressions.
    Field Name | Type | Value
    Names | Database Field | @name
    Currencies | Database Field | ./ExchangeRates/Currency
    2004 | Database Field | ./ExchangeRates/VsUSD2004
    2003 | Database Field | ./ExchangeRates/VsUSD2003
    2002 | Database Field | ./ExchangeRates/VsUSD2002
    2001 | Database Field | ./ExchangeRates/VsUSD2001
    2000 | Database Field | ./ExchangeRates/VsUSD2000
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To add controls to the report

  1. From the toolbox, drag a List data region onto the design surface of the report and go to the Properties window to set the DataSetName property to ExchangeRates, Location property to 0in, 0in and Size property to 6.5in, 3in.
  2. From the Report Explorer, drag the Names field onto the list, center it at the top and go to the Properties window to set the FontSize property to 14pt and the BorderStyle property to Solid.
  3. From the Report Explorer, drag the following fields onto the list with properties set as described in the table below.
    Field Name Property Name
    Currencies Location: 1.125in, 0.5in
    Size: 2.25in, 0.25in
    2004 Location: 4in, 0.875in
    Size: 1in, 0.25in
    2003 Location: 4in, 1.25in
    Size: 1in, 0.25in
    2002 Location: 4in, 1.625in
    Size: 1in, 0.25in
    2001 Location: 4in, 2in
    Size: 1in, 0.25in
    2000 Location: 4in, 2.375in
    Size: 1in, 0.25in
    Note: You will notice that the expressions created for these fields are different than usual. Because Visual Basic syntax does not allow an identifier that begins with a number, any numeric field names must be treated as strings in expressions.
  4. From the toolbox, drag a TextBox onto the list and go to the Properties window to set the properties as described in the table below to combine static text with a field value.
    Property Name | Property Value
    Location | 0.125in, 0.875in
    Size | 3.125in, 0.25in
    Value | ="Value of " & Fields!Currency.Value & " versus US$ for year:"
    Font | Normal, Arial, 10pt, Bold
    TextAlign | Right
  5. From the toolbox, drag TextBox controls onto the list and go to the Properties window to set the properties as described in the table below to create static labels.

    TextBox1

    Property Name | Property Value
    Location | 0.125in, 0.5in
    Size | 0.75in, 0.25in
    FontWeight | Bold
    Value | Currency:

    TextBox2

    Property Name | Property Value
    Location | 3.375in, 0.875in
    Size | 0.5in, 0.25in
    TextAlign | Right
    Value | 2004:

    TextBox3

    Property Name | Property Value
    Location | 3.375in, 1.25in
    Size | 0.5in, 0.25in
    TextAlign | Right
    Value | 2003:

    TextBox4

    Property Name | Property Value
    Location | 3.375in, 1.625in
    Size | 1in, 0.25in
    TextAlign | Right
    Value | 2002:

    TextBox5

    Property Name | Property Value
    Location | 3.375in, 2in
    Size | 0.5in, 0.25in
    TextAlign | Right
    Value | 2001:

    TextBox6

    Property Name | Property Value
    Location | 3.375in, 2.375in
    Size | 0.5in, 0.25in
    TextAlign | Right
    Value | 2000:

To assign a bookmark ID to the report control

A bookmark ID marks any report control as something to which a bookmark link can navigate.

  1. On the designer surface, select the Names textbox at the top of the list and at the bottom of the Properties Window, select the Property dialog command.
  2. In the Textbox dialog that appears, go to the Navigation page.
  3. On the Navigation page, enter Names in the Bookmark ID field.
    Note: Every bookmark ID in a report must be a unique string. If you have duplicates, a link to it will navigate only to the first one it finds.
  4. Click OK to close the dialog.

To add a bookmark link to the report control

A bookmark link is like a hyperlink that navigates to a report control marked with a bookmark ID instead of to a URL. We will add a text box below the list we already created to display at the bottom of the report. This text box will have a bookmark link to the bookmark ID we created in the last procedure.

  1. From the toolbox, drag a text box onto the report below the list and in the Properties window, set the properties as follows.
    Property Name | Property Value
    Value | Back to Top
    Location | 0in, 3in
    Size | 6.5in, .5in
    TextAlign | Center
  2. At the bottom of the Properties Window, select the Property dialog command.
  3. In the Textbox dialog that appears, go to the Navigation page.
  4. On the Navigation page, select the Jump to Bookmark radio button and enter the bookmark ID (Names) created in the procedure above.
  5. Click OK to close the dialog.

To view the report

Open the report in the Viewer. See Windows Forms Viewer for further information.


Reports with TableOfContents

Reports with TableOfContents
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Preview > Reports with TableOfContents
Show All Show All
Hide All Hide All

This walkthrough illustrates how to create a report that includes the TableOfContents (ToC) control and displays the document map on a report page.

The TableOfContents control allows you to quickly navigate to desired data inside a report. You can use the TableOfContents control to embed the list of contents in the report body for printing and rendering, unlike the Document Map that is only available in the Viewers and cannot be rendered or printed.

  • To add an ActiveReports to the Visual Studio project
  • To connect the report to a data source
  • To add a dataset
  • To create a layout for the report
  • To configure the appearance of Table of Contents
  • To view the report

When you complete this walkthrough you get a layout that looks similar to the following at design time and at run time.

Design-Time Layout

Run-Time Layout

To add an ActiveReports to the Visual Studio project

  1. Create a new Visual Studio Windows Forms Application project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 RDL Report and in the Name field, rename the file as ReportsWithToC.rdlx.
  4. Click the Add button to open a new RDL report.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

This walkthrough uses the Movies table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as MovieCatalog. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query
    Copy Code
    SELECT Genre.GenreName, Movie.Title, Movie.YearReleased, Movie.UserRating, Movie.Country FROM Genre INNER JOIN (Movie INNER JOIN MovieGenres ON Movie.MovieID = MovieGenres.MovieID) ON Genre.GenreID = MovieGenres.GenreID ORDER BY YearReleased ASC
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To create a layout for the report

  1. From the toolbox, drag the List control onto the design surface and in the Properties window, set the following properties.
    Property Name | Property Value
    DataSetName | MovieCatalog
    Location | 0.25in, 1.875in
    Size | 6in, 4in
    PageBreakAtStart

    True

    Note: Applicable for RDL reports only.

  2. With the List data region selected, under the Properties window, click the Property dialog link to open the List dialog
  3. Go to the Detail Grouping page and on the General tab, under Group on, set the Expression field to =Fields!GenreName.Value.
  4. Click OK to close the dialog
  5. In the Report Explorer, from the MovieCatalog dataset, drag and drop the GenreName field inside the List data region and in the Properties window, set the following properties.
    Property Name | Property Value
    Location | 0.25in, 0.375in
    Font | Normal, Arial, 12pt, Bold
    TextAlign | Center
    Size | 5.625in, 0.25in
    Label =Fields!GenreName.Value
    Note: Setting the control's Label property adds an entry of the control in the document map.
  6. From the toolbox, drag and drop the Table data region inside the List data region and in the Properties window, set the following properties.
    Property Name | Property Value
    Location | 0.125in, 1in
    Size | 6in, 0.75in
    DataSetName | MovieCatalog
    BorderStyle | Solid
    RepeatHeaderOnNewPage | True
  7. In the Table data region, place your mouse over the cells of the table details row to display the field selection adorner.

  8. Click the adorner to show a list of available fields from the MovieCatalog dataset and add the following fields to the cells of the table details row.

    Cell | Field
    Left Cell | Title
    Middle Cell | Country
    Right Cell | UserRating
    This automatically places an expression in the details row and simultaneously places a static label in the header row of the same column.
    Tip: You can also directly drag fields from the Report Explorer onto the textbox cells of the Table data region.
  9. Select the table header row using the row handle to the left and in the Properties Window set the following properties.
    Property Name | Property Value
    Font > FontWeight | Bold
    TextAlign | Left
    BackgroundColor | Silver
    BoderStyle | Solid
  10. Select the table detail row using the row handle to the left, and in the Properties Window set the following properties.
    Property Name | Property Value
    TextAlign | Left
    BorderStyle | Solid
  11. Right-click the table detail row using the row handle to the left, and select Insert Group...
  12. In the Table - Groups dialog that appears, on the General tab, under Group on, set the Expression field to =Fields!YearReleased.Value.
  13. Click OK to close the dialog.
  14. Select the textboxes inside the table group row using the CTRL key and left mouse button, right-click the selection and select Merge Cells.
  15. Select the merged cell and in the Properties window, set the following properties.
    Property Name | Property Value
    Font | Normal, Arial, 10pt, Bold
    HeadingLevel Heading 2
    Note: Setting the control's HeadingLevel property adds an entry of the control in the document map.
    TextAlign | Center
    Value | ="Movies Released in " & Fields !YearReleased.Value
  16. From the Visual Studio toolbox, drag a TableOfContents control onto the design surface and in the Properties window, set the following properties.
    Property Name | Property Value
    Location | 0.25in, 0.5in
    Size | 6in, 0.875in
    BorderStyle | Solid

To configure the appearance of Table of Contents

  1. With the TableOfContents control selected, select the Levels (Collection) property and then click the ellipsis button that appears.
  2. In the LevelDesigner Collection Editor dialog that appears, under Members, use the Add button to add Level2 to the TableOfContents.
  3. Under Members, select Level1 and click the Property Pages button above the LevelDesigner Collection Editor properties grid.
  4. In the Level Properties dialog that appears, set the following properties.

    Properties

    Property Name | Property Value
    Font > Size | 14
    Font > Weight | Bold
    Color | DarkBlue
    Padding > Left | 10pt
    Padding > Top | 10pt
    Padding > Right | 10pt
    Padding > Bottom | 10pt
    Fill character .
  5. In the LevelDesigner Collection Editor, select the Level2 entry under Members and click the Property Pages button above the LevelDesigner Collection Editor Properties grid.
  6. In the Level Properties dialog that appears, set the following properties.

    Properties

    Property Name | Property Value
    Font > Weight | Bold
    Padding > Left | 20pt
    Padding > Top | 10pt
    Padding > Right | 0pt
    Padding > Bottom | 0pt
    DisplayPageNumber | False
  7. Click OK to close the LevelDesigner Collection Editor dialog.
  8. In the Report Explorer, select the Report node and in the Properties window set the following properties:

    Properties

    Property Name | Property Value
    DocumentMap > Source | Labels and Headings
    DocumentMap > NumberingStyle | 1, 2, 3, 4, 5

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.
See Also

Concepts

TableOfContents

How To

Add TableOfContents
Add Items to the Document Map


Advanced

Advanced
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Advanced

This section contains the following walkthroughs that fall under the Advanced category.

Reports with Custom Code
This walkthrough demonstrates how to create a simple report with custom code.
Custom Resource Locator
This walkthrough is based on the Custom Resource Locator sample and illustrates how to load pictures from the user's My Pictures directory.
Custom Data Provider
This walkthrough demonstrates how to create a solution with projects that create a custom data provider and demonstrate how it pulls data from a comma separated values (CSV) file.
See Also
Page Report/RDL Report Walkthroughs

Concepts

Interactive Features


Reports with Custom Code

Reports with Custom Code
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Advanced > Reports with Custom Code
Show All Show All
Hide All Hide All

This walkthrough illustrates how to create a simple report with custom code.

The walkthrough is split up into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a data source
  • Adding a dataset
  • Adding controls to the report to contain data
  • Embedding code in a report and referencing it in a field expression
  • Viewing the report
Note:
  • This walkthrough uses the Store table from the Reels database. By default, in ActiveReports, the Reels.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\Reels.mdb.
  • Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Page Report and in the Name field, rename the file as CustomCode.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as Districts. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query
    Copy Code
    SELECT Store.StoreName, Address.City, Address.Region AS StateProvince, Address.Country, Districts.District
FROM Address INNER JOIN (Districts INNER JOIN Store ON Districts.DistrictID = Store.DistrictID) ON Address.AddressID = Store.Address WHERE NOT Districts.DistrictID = 0 ORDER BY Districts.District
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To create a layout for the report

  1. From the toolbox, drag the TextBox control onto the design surface and go to the Properties window to set the following properties:
    Property Name | Property Value
    Location | 0in, 0in
    Size | 6.5in, 0.5in
    TextAlign | Center
    FontSize | 14pt
    Value | District Locations
  2. From the toolbox, drag a Table data region onto the design surface and go to the Properties window to set the DataSetName property to Districts.
  3. Set the following properties for the table:
    Property Name | Property Value
    Location | 0in, 0.5in
    FixedSize 6in, 7in
    Note: FixedSize property is set only in Page report.
  4. Click inside the table to display the column handles at the top and in the Properties window, set the Width property of following columns:
    Column | Width
    TableColumn1 | 3in
    TableColumn2 | 1.5in
    TableColumn3 | 1.5in
  5. Click inside the table to display the row handles along the left of the table and right-click any of the row handles to select Insert Group.
  6. In the Table - Groups dialog that appears, under Group on, select the following expression: =Fields!District.Value
  7. On the same dialog set the Name to District and click OK to close the dialog. The header and footer rows for the new group appear.
  8. In the Report Explorer from the Districts dataset, drag the District field into the second column of the group header row of the table. This automatically places an expression in the group header row and simultaneously places a static label in the table header row.
  9. In the first column of the group header row, just to the left of the District field, in the Properties window set the Value property to District Name:.
  10. Click the row handle to the left of the group header row to select the entire row and in the Properties window, set the properties as follows:
    Property Name | Property Value
    FontSize | 12pt
    FontWeight | Bold
    BackgroundColor | MediumPurple
    Color | White
  11. Right-click any row handle to the left of the table and select Table Header to remove the table header.
  12. Right-click any row handle to the left of the table and select Table Footer to remove the table footer.
  13. In the Report Explorer, drag the following fields from the Districts dataset onto the detail row of the table as follows.
    Field | Column
    StoreName | TableColumn1
    City | TableColumn2
    StateProvince | TableColumn3
  14. Remove the static label State Province from the group header for the third column.
  15. Right-click the row handle for the group header row and select Insert Row Below to add a row for static labels that will appear once for each group.
  16. In the new row, enter the following values for static label in table columns.

    TableColumn1

    Property Name | Property Value
    Value | Store Name
    FontWeight | Bold

    TableColumn2

    Property Name | Property Value
    Value | City
    FontWeight | Bold

    TableColumn3

    Property Name | Property Value
    Value | =iif(Fields!Country.Value="USA", "State", "Province")
    FontWeight | Bold
    Note: The expression in the third column displays the label "State" when the country is USA, and displays "Province" when it is not.

To embed code in a report and reference it in a field expression

This custom code creates a URL to Yahoo!® Maps for each city in the report.

  1. On the Script tab of the report, enter the following code to create a URL.
    Visual Basic.NET code. Add to the Script tab.
    Copy Code
    Public Function MapLink(ByVal Country, ByVal City, ByVal StateProvince) As String
        Dim Link As String
        Dim _Country As String = Country.ToString()
        Dim _City As String = City.ToString()
        Dim _StateProvince As String = StateProvince.ToString()

        Select Case _Country
                Case "USA"
                  Link = "http://maps.yahoo.com/maps_result?addr=&csz=" & _City & "%2C+" & _StateProvince & "&country=us&new=1&name=&qty="
                Case "Canada"
                  Link = "http:file://ca.maps.yahoo.com/maps_result?csz=%2C+" & _StateProvince & "&country=ca"
                Case Else
                  Link = ""
        End Select

        Return Link
End Function
    Note: Custom code is helpful if you intend to reuse code throughout the report or if code is too complex to use in an expression. Code must be instance based and written in Visual Basic.NET. You can include multiple methods, but if you want to use classes or other .NET languages, create a custom assembly. See Using Script in a Page Report for further details.

To reference embedded code in a field expression

  1. On the Designer tab of the report, click the detail cell in the second table column (containing the expression =Fields!City.Value) to select it and under the Properties window, click the Property dialog link. This is a command to open the respective control's dialog. See Properties Window for more on how to access commands. .
  2. In the Textbox - General dialog that appears, go to the Navigation page.
  3. Select the radio button next to Jump to URL, and enter the following expression in the combo box below it. = Code.MapLink(Fields!Country.Value, Fields!City.Value, Fields!StateProvince.Value)
  4. Click OK to close the dialog and use the code to create a hyperlink for the field.

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.
See Also

Concepts

Using Script


Custom Resource Locator

Custom Resource Locator
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Advanced > Custom Resource Locator
Show All Show All
Hide All Hide All

Page reports can get resources from your file system using file paths, but sometimes resources are preserved in very specific sources, such as a database. With page reports, you can create a custom resource locator to read any resources that might be required by your reports from any location. This walkthrough is based on the Custom Resource Locator sample and illustrates how to load pictures from the user's My Pictures directory.

This walkthrough is split into the following procedures:

  • Adding an ActiveReports to the Visual Studio project
  • Creating a layout for the report
  • Adding the new MyPicturesLocator class
  • Creating the PreviewForm that contains the Viewer control to view the report.
Note: Although this walkthrough uses Page reports, you can also implement this using RDL reports.

When you complete this walkthrough you get a layout that looks similar to the following at runtime.

To add an ActiveReports to the Visual Studio project

  1. Create a new Visual Studio Windows Forms Application project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Page Report and in the Name field, rename the file as DemoReport.rdlx.
  4. Click the Add button to open a new fixed page report.

To create a layout for the report

  1. From the toolbox, drag an Image control onto the design surface and in the Properties window, set the following properties.
    Property Name | Property Value
    Name | Image1
    Location | 0.1in, 0.1in
    Size | 2.8in, 2.8in
    Value | MyPictures:Penguins.jpg
  2. From the toolbox, drag another Image control onto the design surface and in the Properties window, set the following properties.
    Property Name | Property Value
    Name | Image2
    Location | 3.1in, 0.1in
    Size | 2.8in, 2.8in
    Value | MyPictures:Desert.jpg
  3. In the Solution Explorer, select DemoReport.rdlx and in the Properties window, set Build Action to Embedded Resource.

To add the new MyPicturesLocator class

  1. In the Solution Explorer window, right-click on your project name and select Add and then New Item.
  2. In the Add New Item dialog that appears, select Class.
  3. Change the name of the class to MyPicturesLocator and click the Add button.
  4. Replace the existing code with the following code to the new class.

    To write the code in Visual Basic.NET

    VB code. Paste on TOP
    Copy Code
    Imports System
Imports System.Drawing
Imports GrapeCity.ActiveReports.Extensibility
Imports System.Globalization
Imports System.IO
Imports System.Runtime.InteropServices
    VB code. Paste INSIDE the class
    Copy Code
     Inherits ResourceLocator

    Private Const UriSchemeMyImages As String = "MyPictures:"

    ' Obtain and return the resource.
    Public Overrides Function GetResource(resourceInfo As ResourceInfo) As Resource
        Dim name As String = resourceInfo.Name
        If name Is Nothing OrElse name.Length = 0 Then
            Throw New ArgumentException("The name of resource to be obtained should be non-empty string.", "name")
        End If
        Dim uri As New Uri(name)
        Dim stream As Stream = GetPictureFromSpecialFolder(name)
        If stream Is Nothing Then
            stream = New MemoryStream()
        End If
        Return New Resource(stream, uri)
    End Function

    ' Returns the specified image from Public Pictures folder.
    Private Shared Function GetPictureFromSpecialFolder(path As String) As Stream
        Dim startPathPos As Integer = UriSchemeMyImages.Length
        If startPathPos >= path.Length Then
            Return Nothing
        End If
        Dim pictureName As String = path.Substring(startPathPos)
        Dim myPicturesPath As String = Environment.GetEnvironmentVariable("public") & "\Pictures"
        If Not myPicturesPath.EndsWith("\") Then
            myPicturesPath += "\"
        End If
        Dim picturePath As String = System.IO.Path.Combine(myPicturesPath, pictureName)
        If Not File.Exists(picturePath) Then
            Return Nothing
        End If
        Dim stream As New MemoryStream()
        Try
            Dim picture As Image = Image.FromFile(picturePath)
            picture.Save(stream, picture.RawFormat)
            stream.Position = 0
        Catch generatedExceptionName As OutOfMemoryException
            ' The file is not valid image, or GDI+ doesn't support such images.
            Return Nothing
        Catch generatedExceptionName As ExternalException
            Return Nothing
    End Try
    Return stream
End Function

    To write the code in C#

    C# code. Paste on TOP
    Copy Code
    using System;
using System.Drawing;
using System.Globalization;
using System.IO;
using System.Runtime.InteropServices;
using System.Windows.Forms;
using GrapeCity.ActiveReports.Extensibility;
using your_project_name.Properties;
    C# code. Paste BELOW the Using statements
    Copy Code
    namespace your_project_name
{
    // Look for the resources in My Pictures folder.
    internal sealed class MyPicturesLocator : ResourceLocator
    {
        private const string UriSchemeMyImages = "MyPictures:";
        // Obtain and return the resource.
        public override Resource GetResource(ResourceInfo resourceInfo)
        {
            string name = resourceInfo.Name;
            if (name == null || name.Length == 0)
            {
                throw new ArgumentException("The name of resource to be obtained should be non-empty string.", "name");
            }
            Uri uri = new Uri(name);
            Stream stream = GetPictureFromSpecialFolder(name);
            if (stream == null)
            {
               stream = new MemoryStream();
            }
            return new Resource(stream, uri);
        }
        // Returns the specified image from Public Pictures folder.
        private static Stream GetPictureFromSpecialFolder(string path)
        {
            int startPathPos = UriSchemeMyImages.Length;
            if (startPathPos >= path.ToString().Length)
            {
                return null;
            }
            string pictureName = path.ToString().Substring(startPathPos);
            string myPicturesPath = Environment.GetEnvironmentVariable("public") + \\Pictures;
            if (!myPicturesPath.EndsWith("\\")) myPicturesPath += "\\";
            string picturePath = Path.Combine(myPicturesPath, pictureName);
                        if (!File.Exists(picturePath)) return null;
            MemoryStream stream = new MemoryStream();
            try
            {
                Image picture = Image.FromFile(picturePath);
                picture.Save(stream, picture.RawFormat);
                stream.Position = 0;
            }
            catch (OutOfMemoryException) // The file is not valid image, or GDI+ doesn't support such images.
            {
                return null;
            }
            catch (ExternalException)
            {
                return null;
            }
            return stream;
        }
    }
}

To create the PreviewForm

  1. In the Solution Explorer, select the Form1 in the Design view and in the Properties window, set the properties as follows.
    Property Name | Property Value
    Name | PreviewForm
    Text | Preview Form
    Size | 1015, 770
  2. From the Visual Studio toolbox, drag the Viewer control onto the PreviewForm and in the Properties window, set the following properties.
    Property Name | Property Value
    Name | reportPreview1
    Dock | Fill
  3. Double-click the PreviewForm to create an instance for the Load event and add the following code.

    To write the code in Visual Basic.NET

    VB code. Paste BELOW the Import statements
    Copy Code
    Imports GrapeCity.ActiveReports.Document
Imports System.IO
Imports GrapeCity.ActiveReports
    VB code. Paste INSIDE the Load event
    Copy Code
    Dim reportData As Stream = [GetType]().Assembly.GetManifestResourceStream("your_project_name.DemoReport.rdlx")
reportData.Position = 0
Dim reader As New StreamReader(reportData)
Dim def As New PageReport(reader)
def.ResourceLocator = New MyPicturesLocator()
Dim runtime As New PageDocument(def)
reportPreview1.ReportViewer.LoadDocument(runtime)

    To write the code in C#

    C# code. Paste BELOW the Using statements
    Copy Code
    using GrapeCity.ActiveReports.Document;
using System.IO;
using GrapeCity.ActiveReports;
    C# code. Paste INSIDE the Load event
    Copy Code
    string myPicturesPath = Environment.GetFolderPath(Environment.SpecialFolder.MyPictures);
Stream reportData = GetType().Assembly.GetManifestResourceStream("your_project_name.DemoReport.rdlx");
reportData.Position = 0;
StreamReader reader = new StreamReader(reportData);
PageReport def = new PageReport(reader);
def.ResourceLocator = new MyPicturesLocator();
PageDocument runtime = new PageDocument(def);
reportPreview1.ReportViewer.LoadDocument(runtime);
  4. Press F5 to run the project.
See Also

Concepts

Custom Resource Locator

Page Report Walkthroughs

Drill-Through Reports

Sample ReadMe Files

Custom Resource Locator


Custom Data Provider

Custom Data Provider
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Page Report/RDL Report Walkthroughs > Advanced > Custom Data Provider
Show All Show All
Hide All Hide All

A custom data provider allows you to use non-traditional data sources in your page reports, both at run time and at design time. This walkthrough illustrates how to create a solution with projects that create a custom data provider and demonstrate how it pulls data from a comma separated values (CSV) file.

This walkthrough is split into the following activities:

  • Creating a Designer project to demonstrate the custom data provider
  • Configuring the project to use a custom data provider
  • Adding a report to show the data
  • Adding a second project to contain the custom data provider
  • Adding a button to the query editor

When you complete this walkthrough, you will have a designer pre-loaded with a report that pulls data from a CSV file and looks like the following.

To create a Designer project to demonstrate the custom data provider

  1. In Visual Studio, create a Windows Forms project and name it CustomDataProviderDemo.
  2. From the Visual Studio toolbox ActiveReports 10 tab, drag a ReportExplorer and drop it onto the default Windows form, resizing the form to a comfortable working area.
  3. In the Properties window, set the Dock property of the ReportExplorer control to Left.
  4. From the toolbox Common Controls tab, drag a RichTextBox control onto the form and set the Dock property to Top.
  5. Add the following text to the Text property. (Drop down the box to ensure that all of the lines of text are added.)
    Text. Paste in the Text property of the RichTextBox.
    Copy Code
    1. In the Report Explorer, right-click the Data Sources node and select Add Data Source.
2. In the Report Data Source dialog that appears, on the General tab, drop down the Type box, select CSV Data Provider, and click OK.
3. In the Report Explorer, right-click DataSource1 and select Add Data Set.
4. In the dialog that appears, select the Query page.
5. Drop down the Query String box to display the custom query editor.
6. Click the Select CSV File button and open the Categories.csv file in this project.
7. Click OK to save the changes and close the dialog.
8. Click Preview to see the report with data from the csv file.
  6. From the toolbox ActiveReports 10 tab, drag a Designer control and drop it on the empty part of the form.
  7. Set the Dock property to Fill, then right-click the Designer control on the form and select Bring to front.
  8. Select the ReportExplorer control and in the Properties window, drop down the ReportDesigner property and select Designer1.
  9. Double-click on the form's title bar to create a form Load event, and add code like the following above the class.
    Visual Basic code. Paste above the class.
    Copy Code
    Imports System.Xml
Imports System.IO
Imports GrapeCity.ActiveReports.Design
    C# code. Paste above the class.
    Copy Code
    using System.Xml;
using System.IO;
using GrapeCity.ActiveReports.Design;
  10. Add the following code to the form Load event.
    Visual Basic code. Paste inside the form Load event.
    Copy Code
    Using reportStream = File.OpenRead("DemoReport.rdlx")
        Using reader = XmlReader.Create(reportStream)
                Designer1.LoadReport(reader, DesignerReportType.Page)
        End Using
End Using
    C# code. Paste inside the form Load event.
    Copy Code
    using (var reportStream = File.OpenRead("DemoReport.rdlx"))
 {
     using (var reader = XmlReader.Create(reportStream))
      {
         designer1.LoadReport(reader, DesignerReportType.Page);
      }
 }

To configure the project to use a custom data provider

  1. In the Solution Explorer, right-click the project and select Add, then New Item.
  2. In the dialog that appears, select Text File, name it GrapeCity.ActiveReports.config, and click Add.
  3. In the Solution Explorer, select the new file and in the Properties window, set its Copy to Output Directory property to Copy always.
  4. Paste the following text into the file and save it. (You can safely ignore the warning that the 'Configuration' element is not declared.)
    Paste into the config file.
    Copy Code
    <?xml version="1.0" encoding="utf-8" ?>
<Configuration>
  <Extensions>
    <Data>
      <Extension Name="CSV" DisplayName="CSV Data Provider"
        Type="CustomDataProvider.CsvDataProvider.CsvDataProviderFactory,
          CustomDataProvider"
          CommandTextEditorType="CustomDataProvider.CSVDataProvider.QueryEditor,
        CustomDataProvider"/>
    </Data>
     </Extensions>
</Configuration>
  5. In the Solution Explorer, right-click the project and select Add, then New Item.
  6. In the dialog that appears, select Text File, name it Categories.csv, and click Add.
  7. In the Solution Explorer, click to select the file, and in the Properties window, change the Copy to Output Directory property to Copy always.
  8. Paste the following text into the file and save it.
    Paste into the text file.
    Copy Code
    EmployeeID(int32),LastName,FirstName,Role,City
1,James,Yolanda,Owner,Columbus
7,Reed,Marvin,Manager,Newton
9,Figg,Murray,Cashier,Columbus
12,Snead,Lance,Store Keeper,Columbus
15,Halm,Jeffry,Store Keeper,Columbus
17,Hames,Alma,Store Keeper,Oak Bay
18,Nicki,Aubrey,Store Keeper,Columbus
24,Cliett,Vikki,Store Keeper,Newton

To add a report to show the data from the custom data provider

  1. In the Solution Explorer, right-click the project and select Add, then New Item.
  2. In the dialog that appears, select ActiveReports 10 RDL Report, name it DemoReport, and click Add.
  3. In the Solution Explorer, click to select the report, and in the Properties window, change the Copy to Output Directory property to Copy always.
  4. From the ActiveReports 10 RDL Report Toolbox, drag a Table report control onto the report.
    Note: In case you are still working on Page report layout, set the FixedSize property of the Table control to display all data on one page.
  5. Click inside the table to reveal the table adorners, then right-click the table adorner to the left of the footer row and select Delete Rows. The footer row is removed from the table.
  6. In the Report Explorer, select each of the textboxes in turn and set the properties as in the following table. (If you do not see the Report Explorer, from the View menu, select Other Windows, then Report Explorer 10.)
    TextBox Name | Value Property | BackgroundColor Property
    TextBox1 | Name | MediumSlateBlue
    TextBox2 | Role | MediumSlateBlue
    TextBox3 | City | MediumSlateBlue
    TextBox4 | =Fields!FirstName.Value & " " & Fields!LastName.Value
    TextBox5 | =Fields!Role.Value
    TextBox6 | =Fields!City.Value
  7. In the Report Explorer, select the Table1 node and in the Properties window, set the Location property to 0in, 1in and the Size property to 6in, 0.5in to make the table wide enough to see all of the data.
  8. With Table1 still selected in the Properties window, in the DataSetName property, enter the text DataSet1.

To add a class library project to the solution to contain the custom data provider

  1. From the File menu, select Add, then New Project.
  2. In the Add New Project dialog, select Class Library, and name the project CustomDataProvider.
  3. In the Solution Explorer, right-click the default class and select Delete. (We will add our classes to a folder below.)
  4. Right-click the CustomDataProvider project and select Add Reference, and in the Reference Manager dialog that appears, select the following references to add, holding down the Ctrl button to select multiple references.
    • GrapeCity ActiveReports 10 (GrapeCity.ActiveReports.v10)
    • GrapeCity ActiveReports Extensibility Library (GrapeCity.ActiveReports.Extensibility.v10)
    • System.Drawing
    • System.Windows.Forms
  5. Right-click the CustomDataProvider project and select Add, then New Folder, and name the folder CSVDataProvider.
  6. Right-click the folder and select Add, then Class, then name the class CsvColumn and add code like the following to replace the default stub in the class.

    Visual Basic code

    Visual Basic code. Paste it to replace the default stub in the class.
    Copy Code
    Namespace CSVDataProvider
        ' Represents information about fields in the data source.
        Friend Structure CsvColumn
                Private ReadOnly _fieldName As String
                Private ReadOnly _dataType As Type

                ' Creates a new instance of the CsvColumn class.
                ' The fieldName parameter is the name of the field represented by this instance of the CsvColumn.
                ' The dataType parameter is the Type of the field represented by this instance of the CsvColumn.
                Public Sub New(fieldName As String, dataType As Type)
                        If fieldName Is Nothing Then
                                Throw New ArgumentNullException("fieldName")
                        End If
                        If dataType Is Nothing Then
                                Throw New ArgumentNullException("dataType")
                        End If
                        _fieldName = fieldName
                        _dataType = dataType
                End Sub

                ' Gets the name of the field represented by this instance of the CsvColumn.
                Public ReadOnly Property FieldName() As String
                        Get
                                Return _fieldName
                        End Get
                End Property

                ' Gets the the Type of the field represented by this instance of the CsvColumn.
                Public ReadOnly Property DataType() As Type
                        Get
                                Return _dataType
                        End Get
                End Property

                ' Returns a String that represents this instance of the CsvColumn.
                Public Overrides Function ToString() As String
                        Return [String].Concat(New String() {FieldName, "(", DataType.ToString(), ")"})
                End Function

                ' Determines whether two CsvColumn instances are equal.
                ' The obj represents the CsvColumn to compare with the current CsvColumn.
                ' Returns True if the specified CsvColumn is equal to the current CsvColumn; otherwise, False.
                Public Overrides Function Equals(obj As Object) As Boolean
                        Dim flag As Boolean

                        If TypeOf obj Is CsvColumn Then
                                flag = Equals(CType(obj, CsvColumn))
                        Else
                                flag = False
                        End If
                        Return flag
                End Function

                Private Overloads Function Equals(column As CsvColumn) As Boolean
                        Return column.FieldName = FieldName
                End Function

                ' Serves as a hash function for a CsvColumn, suitable for use in hashing algorithms and data structures like a hash table.
                ' Returns a hash code for the current CsvColumn instance.
                Public Overrides Function GetHashCode() As Integer
                        Return (FieldName.GetHashCode() + DataType.GetHashCode())
                End Function
        End Structure
End Namespace

    C# code

    C# code. Paste it to replace the default stub in the class.
    Copy Code
    using System;

namespace CustomDataProvider.CSVDataProvider
{
        // Represents information about fields in the data source.
        internal struct CsvColumn
        {
                private readonly string _fieldName;
                private readonly Type _dataType;

                // Creates a new instance of the CsvColumn class.
                // The fieldName parameter is the name of the field represented by this instance of the CsvColumn.
                // The dataType parameter is the Type of the field represented by this instance of the CsvColumn.
                public CsvColumn(string fieldName, Type dataType)
                {
                        if (fieldName == null)
                                throw new ArgumentNullException("fieldName");
                        if (dataType == null)
                                throw new ArgumentNullException("dataType");
                        _fieldName = fieldName;
                        _dataType = dataType;
                }

                // Gets the name of the field represented by this instance of the CsvColumn.
                public string FieldName
                {
                        get { return _fieldName; }
                }

                // Gets the the Type of the field represented by this instance of the CsvColumn.
                public Type DataType
                {
                        get { return _dataType; }
                }

               // Returns a String that represents this instance of the CsvColumn.
                public override string ToString()
                {
                        return String.Concat(new string[] {FieldName, "(", DataType.ToString(), ")"});
                }

                // Determines whether two CsvColumn instances are equal.
                // The obj represents the CsvColumn to compare with the current CsvColumn.
                // Returns True if the specified CsvColumn is equal to the current CsvColumn; otherwise, False.
                public override bool Equals(object obj)
                {
                        bool flag;

                        if (obj is CsvColumn)
                        {
                                flag = Equals((CsvColumn) obj);
                        }
                        else
                        {
                                flag = false;
                        }
                        return flag;
                }

                private bool Equals(CsvColumn column)
                {
                        return column.FieldName == FieldName;
                }

                // Serves as a hash function for a CsvColumn, suitable for use in hashing algorithms and data structures like a hash table.
               // Returns a hash code for the current CsvColumn instance.
                public override int GetHashCode()
                {
                        return (FieldName.GetHashCode() + DataType.GetHashCode());
                }
        }
}
  7. Right-click the CSVDataProvider folder and select Add, then Class, then name the class CsvDataReader and add code like the following to replace the default stub in the class.

    Visual Basic code

    Visual Basic code. Paste it to replace the default stub in the class.
    Copy Code
    Imports System
Imports System.Collections
Imports System.Globalization
Imports System.IO
Imports System.Text.RegularExpressions
Imports GrapeCity.ActiveReports.Extensibility.Data

Namespace CSVDataProvider

    ' Provides an implementation of IDataReader for the .NET Framework CSV Data Provider.
    Friend Class CsvDataReader
        Implements IDataReader
        'NOTE: HashcodeProvider and Comparer need to be case-insensitive since TypeNames are capitalized differently in places.
        'Otherwise data types end up as strings when using Int32 vs int32.
        Private _typeLookup As New Hashtable(StringComparer.Create(CultureInfo.InvariantCulture, False))

        Private _columnLookup As New Hashtable()
        Private _columns As Object()
        Private _textReader As TextReader
        Private _currentRow As Object()

        'The regular expressions are set to be pre-compiled to make it faster. Since we were concerned about
        'multi-threading, we made the properties read-only so no one can change any properties on these objects.
        Private Shared ReadOnly _rxDataRow As New Regex(",(?=(?:[^""]*""[^""]*"")*(?![^""]*""))", RegexOptions.Compiled)
        'Used to parse the data rows.

        Private Shared ReadOnly _rxHeaderRow As New Regex("(?<fieldName>(\w*\s*)*)\((?<fieldType>\w*)\)", RegexOptions.Compiled)
        'Used to parse the header rows.

        ' Creates a new instance of the CsvDataReader class.
        ' The textReader parameter represents the TextReader to use to read the data.
        Public Sub New(textReader As TextReader)
            _textReader = textReader
            ParseCommandText()
        End Sub

        ' Parses the passed-in command text.
        Private Sub ParseCommandText()
            If _textReader.Peek() = -1 Then
                Return
            End If
            'Command text is empty or at the end already.
            FillTypeLookup()

            Dim header As String = _textReader.ReadLine()
            header = AddDefaultTypeToHeader(header)

            If Not ParseHeader(header) Then
                Throw New InvalidOperationException( _
                "Field names and types are not defined. " & _
                "The first line in the CommandText must contain the field names and data types. e.g FirstName(string)")
            End If
        End Sub

        'A hashtable is used to return a type for the string value used in the header text.
        Private Sub FillTypeLookup()
            _typeLookup.Add("string", GetType([String]))
            _typeLookup.Add("byte", GetType([Byte]))
            _typeLookup.Add("boolean", GetType([Boolean]))
            _typeLookup.Add("datetime", GetType(DateTime))
            _typeLookup.Add("decimal", GetType([Decimal]))
            _typeLookup.Add("double", GetType([Double]))
            _typeLookup.Add("int16", GetType(Int16))
            _typeLookup.Add("int32", GetType(Int32))
            _typeLookup.Add("int", GetType(Int32))
            _typeLookup.Add("integer", GetType(Int32))
            _typeLookup.Add("int64", GetType(Int64))
            _typeLookup.Add("sbyte", GetType([SByte]))
            _typeLookup.Add("single", GetType([Single]))
            _typeLookup.Add("time", GetType(DateTime))
            _typeLookup.Add("date", GetType(DateTime))
            _typeLookup.Add("uint16", GetType(UInt16))
            _typeLookup.Add("uint32", GetType(UInt32))
            _typeLookup.Add("uint64", GetType(UInt64))
        End Sub

        ' Returns a type based on the string value passed in from the header text string. If no match is found,
        ' a string type is returned.
        ' The fieldType parameter represents the String value from the header command text string.
        Private Function GetFieldTypeFromString(fieldType As String) As Type
            If _typeLookup.Contains(fieldType) Then
                Return TryCast(_typeLookup(fieldType), Type)
            End If
            Return GetType([String])
        End Function

        ' Parses the first line in the passed-in command text string to create the field names and field data types.
        ' The field information is stored in a CsvColumn struct, and these column info items are stored
        ' in an ArrayList. The column name is also added to a hashtable for easy lookup later.
        ' The header parameter represents the header string that contains all the fields.
        ' Returns True if it can parse the header string; otherwise False.
        Private Function ParseHeader(header As String) As Boolean
            Dim fieldName As String
            Dim index As Integer = 0
            If header.IndexOf("(") = -1 Then
                Return False
            End If

            Dim matches As MatchCollection = _rxHeaderRow.Matches(header)
            _columns = New Object(matches.Count - 1) {}
            For Each match As Match In matches
                fieldName = match.Groups("fieldName").Value
                Dim fieldType As Type = GetFieldTypeFromString(match.Groups("fieldType").Value)
                _columns.SetValue(New CsvColumn(fieldName, fieldType), index)
                _columnLookup.Add(fieldName, index)
                index += 1
            Next

            Return True
        End Function

        ' Ensures that the header contains columns in the form of name(type)
        ' The line parameter represents the raw header line from the file to fix up.
        ' Returns a modified header with default types appended to column names.
        Private Shared Function AddDefaultTypeToHeader(line As String) As String
            Const ColumnWithDataTypeRegex As String = "[""]?\w+[\""]?\(.+\)"
            Dim columns As String() = line.Split(New String() {","}, StringSplitOptions.None)
            Dim ret As String = Nothing
            For Each column As String In columns
                If Not String.IsNullOrEmpty(ret) Then
                    ret += ","
                End If
                If Not Regex.Match(column, ColumnWithDataTypeRegex).Success Then
                    ret += column + "(string)"
                Else
                    ret += column
                End If
            Next
            Return ret
        End Function

        ' Parses a row of data using a regular expression and stores the information inside an object
        ' array that is the current row of data.
        ' If the row does not have the correct number of fields, an exception is raised.
        ' The dataRow parameter represents the String value representing a comma delimited data row.
        ' Returns True if it can parse the data string; otherwise False.
        Private Function ParseDataRow(dataRow As String) As Boolean
            Dim index As Integer = 0
            Dim tempData As String() = _rxDataRow.Split(dataRow)

            _currentRow = New Object(tempData.Length - 1) {}
            If tempData.Length <> _columns.Length Then
                Dim [error] As String = String.Format(CultureInfo.InvariantCulture, _
                                "Invalid row ""{0}"". The row does not contain the same number of data columns as the table header definition.", dataRow)
                Throw New InvalidOperationException([error])
            End If
            For i As Integer = 0 To tempData.Length - 1
                Dim value As String = tempData(i)

                If value.Length > 1 Then
                    If value.IndexOf(""""c, 0) = 0 AndAlso value.IndexOf(""""c, 1) = value.Length - 1 Then
                        value = value.Substring(1, value.Length - 2)
                    End If
                End If
                _currentRow.SetValue(ConvertValue(GetFieldType(index), value), index)
                index += 1
            Next
            Return True
        End Function

        ' Coverts the string value coming from the command text to the appropriate data type, based on the field's type.
        ' This also checks a few string value rules to decide if a String.Empty of System.Data.DBNull needs to be returned.
        ' The type parameter represents the Type of the current column the data belongs to.
        ' The originalValue parameter represents the String value coming from the command text.
        ' Returns the object resulting from the converted string, based on the type.
        Private Function ConvertValue(type As Type, originalValue As String) As Object
            Dim fieldType As Type = type
            Dim invariantCulture As CultureInfo = CultureInfo.InvariantCulture
            Try
                If originalValue = """""" OrElse originalValue = " " Then
                    Return String.Empty
                End If
                If originalValue = "" Then
                    Return DBNull.Value
                End If
                If originalValue = "DBNull" Then
                    Return DBNull.Value
                End If
                If fieldType.Equals(GetType([String])) Then
                    Return originalValue.Trim()
                End If
                If fieldType.Equals(GetType(Int32)) Then
                    Return Convert.ToInt32(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType([Boolean])) Then
                    Return Convert.ToBoolean(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType(DateTime)) Then
                    Return Convert.ToDateTime(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType([Decimal])) Then
                    Return Convert.ToDecimal(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType([Double])) Then
                    Return Convert.ToDouble(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType(Int16)) Then
                    Return Convert.ToInt16(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType(Int64)) Then
                    Return Convert.ToInt64(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType([Single])) Then
                    Return Convert.ToSingle(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType([Byte])) Then
                    Return Convert.ToByte(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType([SByte])) Then
                    Return Convert.ToSByte(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType(UInt16)) Then
                    Return Convert.ToUInt16(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType(UInt32)) Then
                    Return Convert.ToUInt32(originalValue, invariantCulture)
                End If
                If fieldType.Equals(GetType(UInt64)) Then
                    Return Convert.ToUInt64(originalValue, invariantCulture)
                End If
            Catch e As Exception
                Throw New InvalidOperationException(String.Format("Input value '{0}' could not be converted to the type '{1}'.", originalValue, type), e)
            End Try
            'If no match is found return DBNull instead.
            Return DBNull.Value
        End Function

#Region "IDataReader Members"

       ' Advances the CsvDataReader to the next record.
        ' Returns True if there are more rows; otherwise, False.
        Public Function Read() As Boolean Implements IDataReader.Read
            If _textReader.Peek() > -1 Then
                ParseDataRow(_textReader.ReadLine())
            Else
                Return False
            End If

            Return True
        End Function

#End Region

#Region "IDisposable Members"

        ' Releases the resources used by the CsvDataReader.
        Public Sub Dispose() Implements IDisposable.Dispose
            Dispose(True)
            GC.SuppressFinalize(Me)
        End Sub

        Private Sub Dispose(disposing As Boolean)
            If disposing Then
                If _textReader IsNot Nothing Then
                    _textReader.Close()
                End If
            End If

            _typeLookup = Nothing
            _columnLookup = Nothing
            _columns = Nothing
            _currentRow = Nothing
        End Sub

        ' Allows an Object to attempt to free resources and perform
        ' other cleanup operations before the Object is reclaimed by garbage collection.
        Protected Overrides Sub Finalize()
            Try
                Dispose(False)
            Finally
                MyBase.Finalize()
            End Try
        End Sub

#End Region

#Region "IDataRecord Members"

        ' Gets the number of columns in the current row.
        Public ReadOnly Property FieldCount() As Integer Implements IDataRecord.FieldCount
            Get
                Return _columns.Length
            End Get
        End Property

        ' The i parameter represents the index of the field to find.
        ' Returns the Type information corresponding to the type of Object that would be returned from GetValue.
        Public Function GetFieldType(i As Integer) As Type Implements IDataReader.GetFieldType
            If i > _columns.Length - 1 Then
                Return Nothing
            End If

            Return DirectCast(_columns.GetValue(i), CsvColumn).DataType
        End Function

        ' Gets the name for the field to find.
        ' The i parameter represents the index of the field to find.
        ' Returns the name of the field or an empty string (""), if there is no value to return.
        Public Function GetName(i As Integer) As String Implements IDataRecord.GetName
            If i > _columns.Length - 1 Then
                Return String.Empty
            End If

            Return DirectCast(_columns.GetValue(i), CsvColumn).FieldName
        End Function

        ' The name parameter represents the name of the field to find.
        ' Returns the index of the named field.
        Public Function GetOrdinal(name As String) As Integer Implements IDataRecord.GetOrdinal
            Dim value As Object = _columnLookup(name)
            If value Is Nothing Then
                Throw New IndexOutOfRangeException("name")
            End If
            Return CInt(value)
        End Function

        ' The i parameter represents the index of the field to find.
        ' Returns the Object which contains the value of the specified field.
        Public Function GetValue(i As Integer) As Object Implements IDataRecord.GetValue
            If i > _columns.Length - 1 Then
                Return Nothing
            End If

            Return _currentRow.GetValue(i)
        End Function

        Public Overridable Function GetData(fieldIndex As Integer) As IDataReader Implements IDataReader.GetData
            Throw New NotSupportedException()
        End Function

#End Region
    End Class
End Namespace

    C# code

    C# code. Paste it to replace the default stub in the class.
    Copy Code
    using System;
using System.Collections;
using System.Globalization;
using System.IO;
using System.Text.RegularExpressions;
using GrapeCity.ActiveReports.Extensibility.Data;

namespace CustomDataProvider.CSVDataProvider
{

        // Provides an implementation of IDataReader for the .NET Framework CSV Data Provider.
        internal class CsvDataReader : IDataReader
        {
                //NOTE: HashcodeProvider and Comparer need to be case-insensitive since TypeNames are capitalized differently in places.
                                //Otherwise data types end up as strings when using Int32 vs int32.
                private Hashtable _typeLookup =
                        new Hashtable(StringComparer.Create(CultureInfo.InvariantCulture, false));
                private Hashtable _columnLookup = new Hashtable();
                private object[] _columns;
                private TextReader _textReader;
                private object[] _currentRow;

                //The regular expressions are set to be pre-compiled to make it faster. Since we were concerned about
                //multi-threading, we made the properties read-only so no one can change any properties on these objects.
                private static readonly Regex _rxDataRow = new Regex(@",(?=(?:[^""]*""[^""]*"")*(?![^""]*""))", RegexOptions.Compiled);
                        //Used to parse the data rows.

                private static readonly Regex _rxHeaderRow =
                        new Regex(@"(?<fieldName>(\w*\s*)*)\((?<fieldType>\w*)\)", RegexOptions.Compiled);
                        //Used to parse the header rows.

                // Creates a new instance of the CsvDataReader class.
                // The textReader parameter represents the TextReader to use to read the data.
                public CsvDataReader(TextReader textReader)
                {
                        _textReader = textReader;
                        ParseCommandText();
                }

                // Parses the passed-in command text.
                private void ParseCommandText()
                {
                        if (_textReader.Peek() == -1)
                                return; //Command text is empty or at the end already.

                        FillTypeLookup();

                        string header = _textReader.ReadLine();
                        header = AddDefaultTypeToHeader(header);

                        if (!ParseHeader(header))
                                throw new InvalidOperationException(
                                        "Field names and types are not defined. The first line in the CommandText must contain the field names and data types. e.g FirstName(string)");
                }

                //A hashtable is used to return a type for the string value used in the header text.
                private void FillTypeLookup()
                {
                        _typeLookup.Add("string", typeof (String));
                        _typeLookup.Add("byte", typeof (Byte));
                        _typeLookup.Add("boolean", typeof (Boolean));
                        _typeLookup.Add("datetime", typeof (DateTime));
                        _typeLookup.Add("decimal", typeof (Decimal));
                        _typeLookup.Add("double", typeof (Double));
                        _typeLookup.Add("int16", typeof (Int16));
                        _typeLookup.Add("int32", typeof (Int32));
                        _typeLookup.Add("int", typeof (Int32));
                        _typeLookup.Add("integer", typeof (Int32));
                        _typeLookup.Add("int64", typeof (Int64));
                        _typeLookup.Add("sbyte", typeof (SByte));
                        _typeLookup.Add("single", typeof (Single));
                        _typeLookup.Add("time", typeof (DateTime));
                        _typeLookup.Add("date", typeof (DateTime));
                        _typeLookup.Add("uint16", typeof (UInt16));
                        _typeLookup.Add("uint32", typeof (UInt32));
                        _typeLookup.Add("uint64", typeof (UInt64));
                }

                // Returns a type based on the string value passed in from the header text string. If no match is found, a string type is returned.
                // The fieldType parameter represents the String value from the header command text string.
                private Type GetFieldTypeFromString(string fieldType)
                {
                        if (_typeLookup.Contains(fieldType))
                                return _typeLookup[fieldType] as Type;
                        return typeof (String);
                }

                // Parses the first line in the passed-in command text string to create the field names and field data types. The field information
                // is stored in a CsvColumn struct, and these column info items are stored in an ArrayList. The column name is also added
                // to a hashtable for easy lookup later.

                // The header parameter represents the header string that contains all the fields.
                // Returns True if it can parse the header string; otherwise False.
                private bool ParseHeader(string header)
                {
                        string fieldName;
                        int index = 0;
                        if (header.IndexOf("(") == -1)
                                return false;

                        MatchCollection matches = _rxHeaderRow.Matches(header);
                        _columns = new object[matches.Count];
                        foreach (Match match in matches)
                        {
                                fieldName = match.Groups["fieldName"].Value;
                                Type fieldType = GetFieldTypeFromString(match.Groups["fieldType"].Value);
                                _columns.SetValue(new CsvColumn(fieldName, fieldType), index);
                                _columnLookup.Add(fieldName, index);
                                index++;
                        }

                        return true;
                }

                // Ensures that the header contains columns in the form of name(type)
                // The line parameter represents the raw header line from the file to fix up.
                // Returns a modified header with default types appended to column names.
                private static string AddDefaultTypeToHeader(string line)
                {
                        const string ColumnWithDataTypeRegex = @"[""]?\w+[\""]?\(.+\)";
                        string[] columns = line.Split(new string[] { "," }, StringSplitOptions.None);
                        string ret = null;
                        foreach (string column in columns)
                        {
                                if (!string.IsNullOrEmpty(ret))
                                        ret += ",";
                                if (!Regex.Match(column, ColumnWithDataTypeRegex).Success)
                                {
                                        ret += column + "(string)";
                                }
                                else
                                {
                                        ret += column;
                                }
                        }
                        return ret;
                }

                // Parses a row of data using a regular expression and stores the information inside an object array that is the current row of data.
                // If the row does not have the correct number of fields, an exception is raised.
                // The dataRow parameter represents the String value representing a comma delimited data row.
                // Returns True if it can parse the data string; otherwise False.
                private bool ParseDataRow(string dataRow)
                {
                        int index = 0;
                        string[] tempData = _rxDataRow.Split(dataRow);

                        _currentRow = new object[tempData.Length];
                        if (tempData.Length != _columns.Length)
                        {
                                string error =
                                        string.Format(CultureInfo.InvariantCulture,
                                                      "Invalid row \"{0}\". The row does not contain the same number of data columns as the table header definition.",
                                                      dataRow);
                                throw new InvalidOperationException(error);
                        }
                        for (int i = 0; i < tempData.Length; i++)
                        {
                                string value = tempData[i];

                                if (value.Length > 1)
                                {
                                        if (value.IndexOf('"', 0) == 0 && value.IndexOf('"', 1) == value.Length - 1)
                                                value = value.Substring(1, value.Length - 2);
                                }
                                _currentRow.SetValue(ConvertValue(GetFieldType(index), value), index);
                                index++;
                        }
                        return true;
                }

                // Coverts the string value coming from the command text to the appropriate data type, based on the field's type.
                // This also checks a few string value rules to decide if a String.Empty of System.Data.DBNull needs to be returned.
                // The type parameter represents the Type of the current column the data belongs to.
                // The originalValue parameter represents the String value coming from the command text.
                // Returns the object resulting from the converted string, based on the type.
                private object ConvertValue(Type type, string originalValue)
                {
                        Type fieldType = type;
                        CultureInfo invariantCulture = CultureInfo.InvariantCulture;
                        try
                        {
                                if (originalValue == "\"\"" || originalValue == " ")
                                        return string.Empty;
                                if (originalValue == "")
                                        return DBNull.Value;
                                if (originalValue == "DBNull")
                                        return DBNull.Value;
                                if (fieldType.Equals(typeof (String)))
                                        return originalValue.Trim();
                                if (fieldType.Equals(typeof (Int32)))
                                        return Convert.ToInt32(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (Boolean)))
                                        return Convert.ToBoolean(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (DateTime)))
                                        return Convert.ToDateTime(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (Decimal)))
                                        return Convert.ToDecimal(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (Double)))
                                        return Convert.ToDouble(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (Int16)))
                                        return Convert.ToInt16(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (Int64)))
                                        return Convert.ToInt64(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (Single)))
                                        return Convert.ToSingle(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (Byte)))
                                        return Convert.ToByte(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (SByte)))
                                        return Convert.ToSByte(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (UInt16)))
                                        return Convert.ToUInt16(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (UInt32)))
                                        return Convert.ToUInt32(originalValue, invariantCulture);
                                if (fieldType.Equals(typeof (UInt64)))
                                        return Convert.ToUInt64(originalValue, invariantCulture);
                        }
                        catch (Exception e)
                        {
                                throw new InvalidOperationException(
                                        string.Format("Input value '{0}' could not be converted to the type '{1}'.", originalValue, type), e);
                        }
                        //If no match is found return DBNull instead.
                        return DBNull.Value;
                }

                #region IDataReader Members

                // Advances the CsvDataReader to the next record.
                // Returns True if there are more rows; otherwise, False.
                public bool Read()
                {
                        if (_textReader.Peek() > -1)
                                ParseDataRow(_textReader.ReadLine());
                        else
                                return false;

                        return true;
                }

                #endregion

                #region IDisposable Members

                // Releases the resources used by the CsvDataReader.
                public void Dispose()
                {
                        Dispose(true);
                        GC.SuppressFinalize(this);
                }

                private void Dispose(bool disposing)
                {
                        if (disposing)
                        {
                                if (_textReader != null)
                                        _textReader.Close();
                        }

                        _typeLookup = null;
                        _columnLookup = null;
                        _columns = null;
                        _currentRow = null;
                }

                // Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
                ~CsvDataReader()
                {
                        Dispose(false);
                }

                #endregion

                #region IDataRecord Members

                // Gets the number of columns in the current row.
                public int FieldCount
                {
                        get { return _columns.Length; }
                }

                // The i parameter represents the index of the field to find.
                // Returns the Type information corresponding to the type of Object that would be returned from GetValue.
                public Type GetFieldType(int i)
                {
                        if (i > _columns.Length - 1)
                                return null;

                        return ((CsvColumn) _columns.GetValue(i)).DataType;
                }

                // Gets the name for the field to find.
                // The i parameter represents the index of the field to find.
                // Returns the name of the field or an empty string (""), if there is no value to return.
                public string GetName(int i)
                {
                        if (i > _columns.Length - 1)
                                return string.Empty;

                        return ((CsvColumn) _columns.GetValue(i)).FieldName;
                }

                // The name parameter represents the name of the field to find.
                // Returns the index of the named field.
                public int GetOrdinal(string name)
                {
                        object value = _columnLookup[name];
                        if (value == null)
                                throw new IndexOutOfRangeException("name");
                        return (int) value;
                }

                // The i parameter represents the index of the field to find.
                // Returns the Object which contains the value of the specified field.
                public object GetValue(int i)
                {
                        if (i > _columns.Length - 1)
                                return null;

                        return _currentRow.GetValue(i);
                }

                public virtual IDataReader GetData(int fieldIndex)
                {
                        throw new NotSupportedException();
                }

                #endregion
        }
}
  8. Right-click the CSVDataProvider folder and select Add, then Class, then name the class CsvCommand and add code like the following to replace the default stub in the class.

    Visual Basic code

    Visual Basic code. Paste it to replace the default stub in the class.
    Copy Code
    Imports System
Imports System.IO
Imports GrapeCity.ActiveReports.Extensibility.Data

Namespace CSVDataProvider

    ' Provides the IDbCommand implementation for the .NET Framework CSV Data Provider.
    Public NotInheritable Class CsvCommand
        Implements IDbCommand
        Private _commandText As String
        Private _connection As IDbConnection
        Private _commandTimeout As Integer
        Private _commandType As CommandType

        ' Creates a new instance of the CsvCommand class.
        Public Sub New()
            Me.New(String.Empty)
        End Sub

        ' Creates a new instance of the CsvCommand class with command text.
        ' The commandText parameter represents the command text.
        Public Sub New(commandText As String)
            Me.New(commandText, Nothing)
        End Sub

        ' Creates a new instance of the CsvCommand class with command text and a CsvConnection.
        ' The commandText parameter represents the command text.
        ' The connection parameter represents a CsvConnection to a data source.
        Public Sub New(commandText As String, connection As CsvConnection)
            _commandText = commandText
            _connection = connection
        End Sub

        ' Gets or sets the command to execute at the data source.
        Public Property CommandText() As String Implements IDbCommand.CommandText
            Get
                Return _commandText
            End Get
            Set(value As String)
                _commandText = value
            End Set
        End Property

        ' Gets or sets the wait time before terminating an attempt to execute the command and generating an error.
        Public Property CommandTimeout() As Integer Implements IDbCommand.CommandTimeout
            Get
                Return _commandTimeout
            End Get

            Set(value As Integer)
                _commandTimeout = value
            End Set
        End Property

        ' Gets or sets a value indicating how the CommandText property is interpreted.
        ' Remarks: We don't use this one for the Csv Data Provider.
        Public Property CommandType() As CommandType Implements IDbCommand.CommandType
            Get
                Return _commandType
            End Get

            Set(value As CommandType)
                _commandType = value
            End Set
        End Property

        ' Gets or sets the CsvConnection used by this instance of the CsvCommand.
        Public Property Connection() As IDbConnection
            Get
                Return _connection
            End Get

            Set(value As IDbConnection)
                _connection = value
            End Set
        End Property

       ' Sends the CommandText to the CsvConnection, and builds a CsvDataReader using one of the CommandBehavior values.
        ' The behavior parameter represents a CommandBehavior value.
        ' Returns a CsvDataReader object.
        Public Function ExecuteReader(behavior As CommandBehavior) As IDataReader Implements IDbCommand.ExecuteReader
            Return New CsvDataReader(New StringReader(_commandText))
        End Function

        ' Returns a string that represents the command text with the parameters expanded into constants.
        Public Function GenerateRewrittenCommandText() As String Implements IDbCommand.GenerateRewrittenCommandText
            Return _commandText
        End Function

        ' Sends the CommandText to the CsvConnection and builds a CsvDataReader.
        ' Returns a CsvDataReader object.
        Public Function ExecuteReader() As IDataReader Implements IDbCommand.ExecuteReader
            Return ExecuteReader(CommandBehavior.SchemaOnly)
        End Function

#Region "Non implemented IDbCommand Members"

        Public ReadOnly Property Parameters() As IDataParameterCollection Implements IDbCommand.Parameters
            Get
                Throw New NotImplementedException()
            End Get
        End Property

        Public Property Transaction() As IDbTransaction Implements IDbCommand.Transaction
            Get
                Throw New NotImplementedException()
            End Get

            Set(value As IDbTransaction)
                Throw New NotImplementedException()
            End Set
        End Property

        Public Sub Cancel() Implements IDbCommand.Cancel

        End Sub

        Public Function CreateParameter() As IDataParameter Implements IDbCommand.CreateParameter
            Throw New NotImplementedException()
        End Function

#End Region

#Region "IDisposable Members"

        ' Releases the resources used by the CsvCommand.
        Public Sub Dispose() Implements IDisposable.Dispose
            Dispose(True)
            GC.SuppressFinalize(Me)
        End Sub

        Private Sub Dispose(disposing As Boolean)
            If disposing Then
                If _connection IsNot Nothing Then
                    _connection.Dispose()
                    _connection = Nothing
                End If
            End If
        End Sub

#End Region
    End Class
End Namespace

    C# code

    C# code. Paste it to replace the default stub in the class.
    Copy Code
    using System;
using System.IO;
using GrapeCity.ActiveReports.Extensibility.Data;

namespace CustomDataProvider.CSVDataProvider
{

       // Provides the IDbCommand implementation for the .NET Framework CSV Data Provider.
        public sealed class CsvCommand : IDbCommand
        {
                private string _commandText;
                private IDbConnection _connection;
                private int _commandTimeout;
                private CommandType _commandType;

                /// Creates a new instance of the CsvCommand class.
                public CsvCommand()
                        : this(string.Empty)
                {
                }

                // Creates a new instance of the CsvCommand class with command text.
                // The commandText parameter represents the command text.
                public CsvCommand(string commandText)
                        : this(commandText, null)
                {
                }

                // Creates a new instance of the CsvCommand class with command text and a CsvConnection.
                // The commandText parameter represents the command text.
                // The connection parameter represents a CsvConnection to a data source.?
                public CsvCommand(string commandText, CsvConnection connection)
                {
                        _commandText = commandText;
                        _connection = connection;
                }

                // Gets or sets the command to execute at the data source.
                public string CommandText
                {
                        get { return _commandText; }
                        set { _commandText = value; }
                }

                // Gets or sets the wait time before terminating an attempt to execute the command and generating an error.
                public int CommandTimeout
                {
                        get { return _commandTimeout; }

                        set { _commandTimeout = value; }
                }

                // Gets or sets a value indicating how the CommandText property is interpreted.
               // Remarks: We don't use this one for the Csv Data Provider.
                public CommandType CommandType
                {
                        get { return _commandType; }

                        set { _commandType = value; }
                }

               // Gets or sets the CsvConnection used by this instance of the CsvCommand.
                public IDbConnection Connection
                {
                        get { return _connection; }

                        set { _connection = value; }
                }

                // Sends the CommandText to the CsvConnection, and builds a CsvDataReader using one of the CommandBehavior values.
                // The behavior parameter represents a CommandBehavior value.
                // Returns a CsvDataReader object.
                public IDataReader ExecuteReader(CommandBehavior behavior)
                {
                        return new CsvDataReader(new StringReader(_commandText));
                }

               // Returns a string that represents the command text with the parameters expanded into constants.
                public string GenerateRewrittenCommandText()
                {
                        return _commandText;
                }

                // Sends the CommandText to the CsvConnection and builds a CsvDataReader.
                // Returns a CsvDataReader object.
                public IDataReader ExecuteReader()
                {
                        return ExecuteReader(CommandBehavior.SchemaOnly);
                }

                #region Non implemented IDbCommand Members

                public IDataParameterCollection Parameters
                {
                        get { throw new NotImplementedException(); }
                }

                public IDbTransaction Transaction
                {
                        get { throw new NotImplementedException(); }

                        set { throw new NotImplementedException(); }
                }

                public void Cancel()
                {

                }

                public IDataParameter CreateParameter()
                {
                        throw new NotImplementedException();
                }

                #endregion

                #region IDisposable Members

                // Releases the resources used by the CsvCommand.
                public void Dispose()
                {
                        Dispose(true);
                        GC.SuppressFinalize(this);
                }

                private void Dispose(bool disposing)
                {
                        if (disposing)
                        {
                                if (_connection != null)
                                {
                                        _connection.Dispose();
                                        _connection = null;
                                }
                        }
                }

                #endregion
        }
}
  9. Right-click the CSVDataProvider folder and select Add, then Class, then name the class CsvConnection and add code like the following to replace the default stub in the class. (You can safely ignore the errors, as they will go away when you add the CsvConnection class.)

    Visual Basic code

    Visual Basic code. Paste it to replace the default stub in the class.
    Copy Code
    Imports System
Imports System.Collections.Specialized
Imports GrapeCity.ActiveReports.Extensibility.Data

Namespace CSVDataProvider

    ' Provides an implementation of IDbConnection for the .NET Framework CSV Data Provider.
    Public NotInheritable Class CsvConnection
        Implements IDbConnection
        Private _localizedName As String

        ' Creates a new instance of the CsvConnection class.
        Public Sub New()
            _localizedName = "Csv"
        End Sub

       ' Creates a new instance of the CsvConnection class.
       ' The localizedName parameter represents the localized name for the CsvConnection instance.
        Public Sub New(localizeName As String)
            _localizedName = localizeName
        End Sub

#Region "IDbConnection Members"

        ' Gets or sets the string used to open the connection to the data source.
        ' Remarks: We don't use this one for the Csv Data Provider.
        Public Property ConnectionString() As String Implements IDbConnection.ConnectionString
            Get
                Return String.Empty
            End Get

            Set(value As String)

            End Set
        End Property

        ' Gets the amount of time to wait while trying to establish a connection before terminating
        ' the attempt and generating an error.
        ' Remarks: We don't use this one for the Csv Data Provider.
        Public ReadOnly Property ConnectionTimeout() As Integer Implements IDbConnection.ConnectionTimeout
            Get
                Throw New NotImplementedException()
            End Get
        End Property

        ' Begins a data source transaction.
        ' Returns an object representing the new transaction.
        ' Remarks: We don't use this one for the Csv Data Provider.
        Public Function BeginTransaction() As IDbTransaction Implements IDbConnection.BeginTransaction
            Return Nothing
        End Function

        ' Opens a data source connection.
        ' Remarks: We don't use this one for the Csv Data Provider.
        Public Sub Open() Implements IDbConnection.Open

        End Sub

        ' Closes the connection to the data source. This is the preferred method of closing any open connection.
        Public Sub Close() Implements IDbConnection.Close
            Dispose()
        End Sub

        ' Creates and returns a CsvCommand object associated with the CsvConnection.
        Public Function CreateCommand() As IDbCommand Implements IDbConnection.CreateCommand
            Return New CsvCommand(String.Empty)
        End Function

        Public Property DataProviderService() As IDataProviderService Implements IDbConnection.DataProviderService
            Get
                Return Nothing
            End Get
            Set(value As IDataProviderService)
            End Set
        End Property

#End Region

#Region "IDisposable Members"

        ' Releases the resources used by the CsvConnection.
        Public Sub Dispose() Implements IDisposable.Dispose
            Dispose(True)
            GC.SuppressFinalize(Me)
        End Sub

        Private Sub Dispose(disposing As Boolean)
        End Sub

       ' Allows an Object to attempt to free resources and perform other cleanup operations
        ' before the Object is reclaimed by garbage collection.
        Protected Overrides Sub Finalize()
            Try
                Dispose(False)
            Finally
                MyBase.Finalize()
            End Try
        End Sub

#End Region

#Region "IExtension Members"

       ' Gets the localized name of the CsvConnection.
        Public ReadOnly Property LocalizedName() As String Implements IDbConnection.LocalizedName
            Get
                Return _localizedName
            End Get
        End Property

       ' Specifies any configuration information for this extension.
       ' The configurationSettings parameter represents a NameValueCollection of the settings.
        Public Sub SetConfiguration(configurationSettings As NameValueCollection) Implements IDbConnection.SetConfiguration
        End Sub

#End Region
    End Class
End Namespace

    C# code

    C# code. Paste it to replace the default stub in the class.
    Copy Code
    using System;
using System.Collections.Specialized;
using GrapeCity.ActiveReports.Extensibility.Data;

namespace CustomDataProvider.CSVDataProvider
{

        // Provides an implementation of IDbConnection for the .NET Framework CSV Data Provider.
        public sealed class CsvConnection : IDbConnection
        {
                private string _localizedName;

                // Creates a new instance of the CsvConnection class.
                public CsvConnection()
                {
                        _localizedName = "Csv";
                }

                // Creates a new instance of the CsvConnection class.
                // The localizedName parameter represents the localized name for the CsvConnection instance.
                public CsvConnection(string localizeName)
                {
                        _localizedName = localizeName;
                }

                #region IDbConnection Members

               // Gets or sets the string used to open the connection to the data source.
               // Remarks: We don't use this one for the Csv Data Provider.
                public string ConnectionString
                {
                        get { return string.Empty; }

                        set { ; }
                }

                // Gets the amount of time to wait while trying to establish a connection before terminating the attempt and generating an error.
                // Remarks: We don't use this one for the Csv Data Provider.
                public int ConnectionTimeout
                {
                        get { throw new NotImplementedException(); }
                }

               // Begins a data source transaction.
               // Returns an object representing the new transaction.
               // Remarks: We don't use this one for the Csv Data Provider.
                public IDbTransaction BeginTransaction()
                {
                        return null;
                }

               // Opens a data source connection.
               // Remarks: We don't use this one for the Csv Data Provider.
                public void Open()
                {
                        ;
                }

                // Closes the connection to the data source. This is the preferred method of closing any open connection.
                public void Close()
                {
                        Dispose();
                }

               // Creates and returns a CsvCommand object associated with the CsvConnection.
                public IDbCommand CreateCommand()
                {
                        return new CsvCommand(string.Empty);
                }

                public IDataProviderService DataProviderService
                {
                        get { return null; }
                        set { }
                }

                #endregion

                #region IDisposable Members

               // Releases the resources used by the CsvConnection.
                public void Dispose()
                {
                        Dispose(true);
                        GC.SuppressFinalize(this);
                }

                private void Dispose(bool disposing)
                {
                }

                // Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
                ~CsvConnection()
                {
                        Dispose(false);
                }

                #endregion

                #region IExtension Members

                // Gets the localized name of the CsvConnection.
                public string LocalizedName
                {
                        get { return _localizedName; }
                }

                // Specifies any configuration information for this extension.
                // The configurationSettings parameter represents a NameValueCollection of the settings.
                public void SetConfiguration(NameValueCollection configurationSettings)
                {
                }

                #endregion
        }
}
  10. Right-click the CSVDataProvider folder and select Add, then Class, then name the class CsvDataProviderFactory and add code like the following to replace the default stub in the class.

    Visual Basic code

    Visual Basic code. Paste it to replace the default stub in the class.
    Copy Code
    Imports GrapeCity.ActiveReports.Extensibility.Data
Imports GrapeCity.BI.Data.DataProviders

Namespace CSVDataProvider

       ' Implements the DataProviderFactory for .NET Framework CSV Data Provider.
        Public Class CsvDataProviderFactory
                Inherits DataProviderFactory

                ' Creates new instance of the CsvDataProviderFactory class.
                Public Sub New()
                End Sub

               ' Returns a new instance of the the CsvCommand.
                Public Overrides Function CreateCommand() As IDbCommand
                        Return New CsvCommand()
                End Function

                ' Returns a new instance of the the CsvConnection.
                Public Overrides Function CreateConnection() As IDbConnection
                        Return New CsvConnection()
                End Function
        End Class
End Namespace

    C# code

    C# code. Paste it to replace the default stub in the class.
    Copy Code
    using GrapeCity.ActiveReports.Extensibility.Data;
using GrapeCity.BI.Data.DataProviders;

namespace CustomDataProvider.CSVDataProvider
{

       // Implements the DataProviderFactory for .NET Framework CSV Data Provider.
        public class CsvDataProviderFactory : DataProviderFactory
        {

                // Creates new instance of the CsvDataProviderFactory class.
                public CsvDataProviderFactory()
                {
                }

               // Returns a new instance of the the CsvCommand.
                public override IDbCommand CreateCommand()
                {
                        return new CsvCommand();
                }

               // Returns a new instance of the the CsvConnection.
                public override IDbConnection CreateConnection()
                {
                        return new CsvConnection();
                }
        }
}

To add a button to the query editor

  1. In the Solution Explorer, right-click the CSVDataProvider folder and select Add, then Class, then name the class QueryEditor and add code like the following to replace the default stub in the class.

    Visual Basic code

    Visual Basic code. Paste it to replace the default stub in the class.
    Copy Code

    Imports System.Collections.Generic
    Imports System.Drawing.Design
    Imports System.IO
    Imports System.Linq
    Imports System.Text
    Imports System.Text.RegularExpressions
    Imports System.Windows.Forms
    Imports System.Windows.Forms.Design

    Namespace CustomDataProvider.CSVDataProvider
    Public NotInheritable Class QueryEditor
    Inherits UITypeEditor
    Public Overrides Function GetEditStyle(context As System.ComponentModel.ITypeDescriptorContext) As UITypeEditorEditStyle
    Return UITypeEditorEditStyle.DropDown
    End Function
    Public Overrides Function EditValue(context As System.ComponentModel.ITypeDescriptorContext, provider As System.IServiceProvider, value As Object) As Object
    Dim edSvc As IWindowsFormsEditorService = DirectCast(provider.GetService(GetType(IWindowsFormsEditorService)), IWindowsFormsEditorService)
    Dim path = ""
    Dim btn = New Button()
    btn.Text = "Select CSV File..."
    Dim pdg = btn.Padding
    pdg.Bottom += 2
    btn.Padding = pdg
    btn.Click += Sub() Using openDlg = New OpenFileDialog()
    openDlg.Filter = "CSV Files (*.csv)|*.csv|All Files (*.*)|*.*"
    If openDlg.ShowDialog() <> DialogResult.OK Then
    path = ""
    Else
    path = openDlg.FileName
    End If
    End Using
    edSvc.DropDownControl(btn)
    If String.IsNullOrEmpty(path) Then
    Return String.Empty
    End If
    If Not File.Exists(path) Then
    Return String.Empty
    End If
    Return GetCSVQuery(path)
    End Function

    Private Function GetCSVQuery(path As String) As Object
    Dim sr As StreamReader = Nothing
    Try
    sr = New StreamReader(path)
    Dim ret As String = String.Empty
    Dim currentLine As String
    Dim line As Integer = 0
    While (InlineAssignHelper(currentLine, sr.ReadLine())) IsNot Nothing
    If line = 0 Then
    ret += ProcessColumnsDefinition(currentLine) & Convert.ToString(vbCr & vbLf)
    Else
    ret += currentLine & Convert.ToString(vbCr & vbLf)
    End If
    line += 1
    End While
    Return ret
    Catch generatedExceptionName As IOException
    Return String.Empty
    Finally
    If sr IsNot Nothing Then
    sr.Close()
    End If
    End Try
    End Function
    Private Function ProcessColumnsDefinition(currentLine As String) As String
    Const ColumnWithDataTypeRegex As String = "[""]?\w+[\""]?\(.+\)"
    Dim columns As String() = currentLine.Split(New String() {","}, StringSplitOptions.None)
    Dim ret As String = Nothing
    For Each column As String In columns
    If Not String.IsNullOrEmpty(ret) Then
    ret += ","
    End If
    If Not Regex.Match(column, ColumnWithDataTypeRegex).Success Then
    ret += column & Convert.ToString("(string)")
    Else
    ret += column
    End If
    Next
    Return ret
    End Function
    Private Shared Function InlineAssignHelper(Of T)(ByRef target As T, value As T) As T
    target = value
    Return value
    End Function
    End Class
    End Namespace

    C# code

    C# code. Paste it to replace the default stub in the class.
    Copy Code

    using System;
    using System.Collections.Generic;
    using System.Drawing.Design;
    using System.IO;
    using System.Linq;
    using System.Text;
    using System.Text.RegularExpressions;
    using System.Windows.Forms;
    using System.Windows.Forms.Design;
    namespace CustomDataProvider.CSVDataProvider
    {
    public sealed class QueryEditor : UITypeEditor
    {
    public override UITypeEditorEditStyle GetEditStyle(System.ComponentModel.ITypeDescriptorContext context)
    {
    return UITypeEditorEditStyle.DropDown;
    }

    public override object EditValue(System.ComponentModel.ITypeDescriptorContext context, System.IServiceProvider provider, object value)
    {
    IWindowsFormsEditorService edSvc = (IWindowsFormsEditorService)provider.GetService(typeof(IWindowsFormsEditorService));
    var path = "";
    var btn = new Button();
    btn.Text = "Select CSV File...";
    var pdg = btn.Padding;
    pdg.Bottom += 2;
    btn.Padding = pdg;
    btn.Click += delegate
    {
    using (var openDlg = new OpenFileDialog())
    {
    openDlg.Filter = "CSV Files (*.csv)|*.csv|All Files (*.*)|*.*";
    if (openDlg.ShowDialog() != DialogResult.OK)
    path = "";
    else
    path = openDlg.FileName;
    }
    };
    edSvc.DropDownControl(btn);
    if (string.IsNullOrEmpty(path)) return string.Empty;
    if (!File.Exists(path)) return string.Empty;
    return GetCSVQuery(path);
    }
    private object GetCSVQuery(string path)
    {
    StreamReader sr = null;
    try
    {
    sr = new StreamReader(path);
    string ret = string.Empty;
    string currentLine;
    int line = 0;
    while ((currentLine = sr.ReadLine()) != null)
    {
    if (line == 0)
    ret += ProcessColumnsDefinition(currentLine) + "\r\n";
    else
    ret += currentLine + "\r\n";
    line++;
    }
    return ret;
    }
    catch (IOException)
    {
    return string.Empty;
    }
    finally
    {
    if (sr != null)
    sr.Close();
    }
    }
    private string ProcessColumnsDefinition(string currentLine)
    {
    const string ColumnWithDataTypeRegex = @"[""]?\w+[\""]?\(.+\)";
    string[] columns = currentLine.Split(new string[] { "," }, StringSplitOptions.None);
    string ret = null;
    foreach (string column in columns)
    {
    if (!string.IsNullOrEmpty(ret))
    ret += ",";
    if (!Regex.Match(column, ColumnWithDataTypeRegex).Success)
    {
    ret += column + "(string)";
    }
    else
    {
    ret += column;
    }
    }
    return ret;
    }
    }
    }
  2. In the Solution Explorer, right-click the CustomDataProviderDemo project and select Add Reference. In the Reference Manager dialog that appears, on the Projects tab, select CustomDataProvider and click OK.
  3. Run the project, and follow the instructions in the RichTextBox to see the custom data provider in action.


Section Report Walkthroughs

Section Report Walkthroughs
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs

Section Report walkthroughs cover scenarios to introduce the key features of code-based and XML-based section reports. Learn about different section report walkthroughs categorized as follows.

Data
This section contain the walkthroughs that explain various ways of working with data sources.
Layout
This section contain the walkthroughs that explain how to create different section report layouts.
Chart
This section contain the walkthroughs that demonstrate how to work with the ActiveReports Chart control in a section report.
Export
This section contains the walkthrough that demonstrates how to set up report custom exporting to PDF, Excel, TIFF, RTF, and plain text formats.
Script
This section contain the walkthroughs that demonstrate how to embed script in reports so that code becomes portable when you save a report layout to XML-based RPX format.
Parameters
This section contain the walkthroughs that demonstrate how to use parameters in SubReport and Chart controls.
Web
This section contains the walkthroughs that explain how to create a simple web service for each scenario and how to create a Document Windows application.
See Also
Walkthroughs
Page Report Walkthroughs


Data

Data
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Data

This section contains the following walkthroughs that fall under the Data category.

Basic Data Bound Reports
This walkthrough demonstrates the basics of setting up bound section reports.
Basic XML-Based Reports (RPX)
This walkthrough demonstrates how to create a simple section report, using the XML-based report template.
Run Time Data Sources
Describes how to change the report data source at run time using the ReportStart event.
See Also
Section Report Walkthroughs


Basic Data Bound Reports

Basic Data Bound Reports
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Data > Basic Data Bound Reports
Show All Show All
Hide All Hide All

In ActiveReports, the simplest reporting style is a tabular listing of fields from a data source.

This walkthrough illustrates the basics of setting up bound reports by introducing the ideas of using the DataSource icon and dragging fields from the Report Explorer onto the report.

The walkthrough is split up into the following activities:

  • Adding an ActiveReport to the Visual Studio project
  • Connecting to a data source
  • Adding controls to the report
  • Viewing the report
Note: This walkthrough uses the Northwind database. By default, in ActiveReports, the Northwind.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Section Report (code-based) and in the Name field, rename the file as rptBound.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

  1. On the detail section band, click the Data Source Icon.
  2. In the Report Data Source dialog that appears, on the OLE DB tab, next to Connection String, click the Build button.
  3. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button to move to the Connection tab.
  4. Click the ellipsis (...) button to browse to your database, for example the NWind.mdb sample database. Click Open once you have selected the appropriate database path.
  5. Click the Test Connection button to see if you have successfully connected to the database.
  6. Click OK to close the Data Link Properties window and return to the Report Data Source dialog. Notice that the Connection String field gets filled automatically.
  7. In the Query field on the OLE DB tab, enter the following SQL query.
    SQL Query
    Copy Code
    SELECT * FROM Products
  8. Click OK to save the data source and return to the report design surface.

To create a layout for the report

  1. In the Visual Studio toolbox, expand the ActiveReports 10 Section Report node and drag three TextBox controls onto the detail section and set the properties of each textbox as indicated:

    TextBox1

    Property Name | Property Value
    DataField | ProductName
    Text | Product Name
    Location | 0, 0in
    Size | 2.3, 0.2in

    TextBox2

    Property Name | Property Value
    DataField | QuantityPerUnit
    Text | Quantity
    Location | 2.4, 0in
    Size | 1.5, 0.2in

    TextBox3

    Property Name | Property Value
    DataField | UnitsInStock
    Text | Stock
    Location | 4, 0in
    Size | 1, 0.2in
  2. Click just below the fields to select the Detail section, and in the Properties Window, set the CanShrink property to True to eliminate white space in the rendered report.

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.


Basic XML-Based Reports (RPX)

Basic XML-Based Reports (RPX)
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Data > Basic XML-Based Reports (RPX)
Show All Show All
Hide All Hide All

ActiveReports allows you to create reports with embedded script and save them to the XML-based RPX file format. By embedding script in reports saved as RPX files, you can later load, run, and display reports directly in the viewer control without rebuilding the application. This walkthrough illustrates how to create a simple report, using the XML-based report template.

This walkthrough is split into the following activities:

  • Adding an ActiveReport to the Visual Studio project
  • Creating a layout for the report
  • Adding scripting to supply data for the controls
  • Applying scripting to set alternate row colors in the detail section
  • Loading an XML-based report from resources
Note: This walkthrough uses the Northwind database. By default, in ActiveReports, the NWind.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.

When you have finished this walkthrough, you get a report that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Section Report (xml-based) and in the Name field, rename the file as rptScript.
  4. Click the Add button to open a new section report in the designer.
  5. In the Solution Explorer click the rptScript.rpx item and in the properties window set the Build Action property to Embedded Resource.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To create a layout for the report

  1. In the Visual Studio toolbox, expand the ActiveReports 10 Section Report node and drag three TextBox controls onto the detail section and set the properties of each textbox as indicated:

    TextBox1

    Property Name | Property Value
    DataField | ProductName
    Text | Product Name
    Location | 0, 0in
    Size | 2.3, 0.2in

    TextBox2

    Property Name | Property Value
    DataField | QuantityPerUnit
    Text | Quantity
    Location | 2.4, 0in
    Size | 1.5, 0.2in

    TextBox3

    Property Name | Property Value
    DataField | UnitsInStock
    Text | Stock
    Location | 4, 0in
    Size | 1, 0.2in
  2. Click just below the fields to select the Detail section, and in the Properties Window, set the CanShrink property to True to eliminate white space in the rendered report.

To add scripting to the report to supply data for the controls

  1. Click the Script tab located at the bottom of the report designer to access the script editor.
  2. Add the scripting code.

    The following example shows what the scripting code looks like.

    Warning: Do not access the Fields collection outside the DataInitialize and FetchData events. Accessing the Fields collection outside of these events is not supported, and has unpredictable results.

    To write the script in Visual Basic.NET

    Visual Basic.NET script. Paste in the script editor window.
    Copy Code
    Private Shared m_cnn As System.Data.OleDb.OleDbConnection

Public Sub ActiveReport_ReportStart()
  'Set up a data connection for the report
  Dim connString As String = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Users\[User Folder]\Documents\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb"
  Dim sqlString As String = "SELECT * FROM products"

  m_cnn = new System.Data.OleDb.OleDbConnection(connString)
  Dim m_Cmd As System.Data.OleDb.OleDbCommand = new System.Data.OleDb.OleDbCommand(sqlString, m_cnn)

  If m_cnn.State = System.Data.ConnectionState.Closed Then
     m_cnn.Open
  End If
  rpt.DataSource = m_Cmd.ExecuteReader
End Sub

Public Sub ActiveReport_ReportEnd()
  'Close the data reader and connection
  m_cnn.Close
End Sub

    To write the script in C#

    C# script. Paste in the script editor window.
    Copy Code
    private static System.Data.OleDb.OleDbConnection m_cnn;

public void ActiveReport_ReportStart()
{
    //Set up a data connection for the report
    string m_cnnString = @"Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Users\[User Folder]\Documents\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb";
    string sqlString = "SELECT * FROM products";
    m_cnn = new System.Data.OleDb.OleDbConnection(m_cnnString);
    System.Data.OleDb.OleDbCommand m_Cmd = new System.Data.OleDb.OleDbCommand(sqlString, m_cnn);

    if(m_cnn.State == System.Data.ConnectionState.Closed)
    {
        m_cnn.Open();
    }
    rpt.DataSource = m_Cmd.ExecuteReader();
}

public void ActiveReport_ReportEnd()
{
    //Close the data reader and connection
    m_cnn.Close();
}

To add scripting to alternate colors in the detail section

  1. Click the Script tab located at the bottom edge of the report designer to access the scripting editor.
  2. Add the scripting code to set alternate colors in the rows of the detail section.

    The following example shows what the scripting code looks like.

    To write the script in Visual Basic.NET

    Visual Basic.NET script. Paste in the script editor window.
    Copy Code
    Dim b as boolean = true

Sub Detail_Format
 if b then
  Me.Detail.BackColor = Color.AliceBlue
  b= false
  else
  me.Detail.BackColor = Color.Cyan
  b = true
 End If
End Sub

    To write the script in C#

    C# script. Paste in the script editor window.
    Copy Code
    bool color = true;
public void Detail_Format()
{
  if(color)
  {
      this.Detail.BackColor = System.Drawing.Color.AliceBlue;
      color = false;
  }
  else
  {
      this.Detail.BackColor = System.Drawing.Color.Cyan;
      color = true;
  }
}

Loading the report to the Viewer

You can quickly view your report at design time by clicking the Preview tab at the bottom of the designer. You can also load the report to the Viewer control.

  • Drag the ActiveReports Viewer control from the Visual Studio toolbox onto the Windows Form and set its Dock property to Fill.
  • Double-click the title bar of the Windows Form containing the viewer to create a Form_Load event and add the code needed to load the RPX into a generic ActiveReport and display it in the viewer.

    The following example shows what the code for the method looks like.

    To write the script in Visual Basic.NET

    Visual Basic.NET script. Paste INSIDE the Form_Load event.
    Copy Code
    Dim sectionReport As New GrapeCity.ActiveReports.SectionReport()
Dim xtr As New System.Xml.XmlTextReader("..\..\rptScript.rpx")
sectionReport.LoadLayout(xtr)
xtr.Close()
Viewer1.LoadDocument(sectionReport)

    To write the script in C#

    C# script. Paste INSIDE the Form_Load event.
    Copy Code
    GrapeCity.ActiveReports.SectionReport sectionReport = new GrapeCity.ActiveReports.SectionReport();
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(@"..\..\rptScript.rpx");
sectionReport.LoadLayout(xtr);
xtr.Close();
viewer1.LoadDocument(sectionReport);
See Also
Section Report Walkthroughs
Walkthroughs


Run Time Data Sources

Run Time Data Sources
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Data > Run Time Data Sources
Show All Show All
Hide All Hide All

ActiveReports allows you to change the data source of a report at run time. This walkthrough illustrates how to change the data source at run time.

This walkthrough is split up into the following activities:

  • Adding an ActiveReports to the Visual Studio project
  • Connecting the report to a design time data source
  • Adding controls to the report to display data
  • Adding code to change the data source at run time
  • Adding code to close the data connection
  • Viewing the report
Note: This walkthrough uses the Northwind database. By default, in ActiveReports, the Northwind.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Section Report (code-based) and in the Name field, rename the file as rptModifyDS.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

Tip: Even if you will change the data source at run time, setting a design time data source allows you to drag fields onto the report from the Report Explorer.
  1. On the detail section band, click the Data Source Icon.
  2. In the Report Data Source dialog that appears, on the OLE DB tab, next to Connection String, click the Build button.
  3. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button to move to the Connection tab.
  4. Click the ellipsis (...) button to browse to your database, for example the NWind.mdb sample database. Click Open once you have selected the appropriate database path.
  5. Click the Test Connection button to see if you have successfully connected to the database.
  6. Click OK to close the Data Link Properties window and return to the Report Data Source dialog. Notice that the Connection String field gets filled automatically.
  7. In the Query field on the OLE DB tab, enter the following SQL query.
    SQL Query
    Copy Code
    SELECT * FROM Products
  8. Click OK to save the data source and return to the report design surface.

To create a layout for the report

  1. On the design surface of the report, select the detail section and in the Properties window, set the CanShrink property to True.
  2. In the Report Explorer, expand the Fields node, then the Bound node. Drag the following fields onto the detail section and in the Properties window, set the following properties.

TextBox1 (ProductID)

Property Name | Property Value
Location | 0, 0 in
Size | 0.5, 0.2 in

TextBox2 (ProductName)

Property Name | Property Value
Location | 0.6, 0 in
Size | 2.8, 0.2 in

TextBox3 (UnitsInStock)

Property Name | Property Value
Location | 3.5, 0 in
Size | 0.5, 0.2 in
Alignment | Right

TextBox4 (UnitsOnOrder)

Property Name | Property Value
Location | 4.1, 0 in
Size | 0.5, 0.2 in
Alignment | Right

TextBox5 (UnitPrice)

Property Name | Property Value
Location | 4.7, 0 in
Size | 0.9, 0.2 in
Alignment | Right
OutputFormat | Currency

To change the data source at run time

To change the data source at run time

  1. Double-click in the gray area below rptModifyDS to create an event-handling method for the ReportStart event.
  2. Add code to the handler to change the data source at run time.

To write the code in Visual Basic.NET

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste JUST ABOVE the ReportStart event.
Copy Code
Dim conn As System.Data.OleDb.OleDbConnection
Dim reader As System.Data.OleDb.OleDbDataReader
Visual Basic.NET code. Paste INSIDE the ReportStart event.
Copy Code
Dim connString As String = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=" + "C:\Users\[YourUserName]\Documents\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb"
conn = New System.Data.OleDb.OleDbConnection(connString)
Dim cmd As New System.Data.OleDb.OleDbCommand("SELECT * FROM Products WHERE UnitPrice = 18", conn)
conn.Open()
reader = cmd.ExecuteReader()
Me.DataSource = reader

To write the code in C#

The following example shows what the code for the method looks like.

C# code. Paste JUST ABOVE the ReportStart event.
Copy Code
private static System.Data.OleDb.OleDbConnection conn;
private static System.Data.OleDb.OleDbDataReader reader;
C# code. Paste INSIDE the ReportStart event.
Copy Code
string connString = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=" + @"C:\Users\[YourUserName]\Documents\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb";
conn = new System.Data.OleDb.OleDbConnection(connString);
System.Data.OleDb.OleDbCommand cmd = new System.Data.OleDb.OleDbCommand("SELECT * FROM Products WHERE UnitPrice = 18", conn);
conn.Open();
reader = cmd.ExecuteReader();
this.DataSource = reader;

To close the data connection

To write the code in Visual Basic

  1. In design view of rptModifyDS, drop down the field at the top left of the code view and select (rptModifyDS Events).
  2. Drop down the field at the top right of the code view and select ReportEnd. This creates an event-handling method for ReportEnd event.
  3. Add code to the handler to close the data connection.

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste INSIDE the ReportEnd event.
Copy Code
reader.Close()
conn.Close()

To write the code in C#

  1. Click in the gray area below rptModifyDS to select the report.
  2. Click the events icon in the Properties Window to display available events for the report.
  3. Double-click ReportEnd. This creates an event-handling method for the ReportEnd event.
  4. Add code to the handler to close the data connection.

The following example shows what the code for the method looks like.

C# code. Paste INSIDE the ReportEnd event.
Copy Code
reader.Close();
conn.Close();

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.
See Also
Run Time Layouts

Samples

Unbound Data


Layout

Layout
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Layout

This section contains the following walkthroughs that fall under the Layout category.

Address Labels
This walkthrough demonstrates how to create a report that repeats labels using the LayoutAction property.
Columnar Reports
This walkthrough demonstrates how to create a simple report using columns.
Group On Unbound Fields
This walkthrough demonstrates how to set up grouping in an unbound section report.
Mail Merge with RichText
This walkthrough demonstrates how to create a mail-merge report using the RichText control.
Overlaying Reports (Letterhead)
This walkthrough demonstrates how to overlay an ActiveReport with a static letterhead report.
Run Time Layouts
Describes how to create and modify report layouts dynamically.
Subreports with XML Data
Learn how to use XML data with subreports.
Subreports with Run-Time Data Sources
Learn how to embed a subreport in a main report, passing the data source from the main report to the subreport at run time.
See Also
Section Report Walkthroughs


Address Labels

Address Labels
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Layout > Address Labels
Show All Show All
Hide All Hide All

ActiveReports can be used to print any label size by using the newspaper column layout.

This walkthrough illustrates how to create a report that repeats labels using the LayoutAction property and prints labels to a laser printer. The labels in this example are 1" x 2.5" and print 30 labels per 8½" x 11" sheet.

The walkthrough is split up into the following activities:

  • Connecting the report to a data source
  • Adding controls to the report to display data
  • Adding code to the detail_Format event to repeat labels
  • Viewing the report
Note: This walkthrough uses the Northwind database. By default, in ActiveReports, the NWind.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.

When you have finished this walkthrough, you get a report that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Section Report (code-based) and in the Name field, rename the file as rptLabels.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

  1. On the detail section band, click the Data Source Icon.
  2. In the Report Data Source dialog that appears, on the OLE DB tab, next to Connection String, click the Build button.
  3. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button to move to the Connection tab.
  4. Click the ellipsis (...) button to browse to your database, for example the NWind.mdb sample database. Click Open once you have selected the appropriate database path.
  5. Click the Test Connection button to see if you have successfully connected to the database.
  6. Click OK to close the Data Link Properties window and return to the Report Data Source dialog. Notice that the Connection String field gets filled automatically.
  7. In the Query field on the OLE DB tab, enter the following SQL query.
    SQL Query
    Copy Code
    SELECT ContactName, CompanyName, Address, City, PostalCode, Country FROM Customers
  8. Click OK to save the data source and return to the report design surface.

To create a layout for the report

  1. Right-click the PageHeader section and select Delete to remove the PageHeader and Footer sections from the report.
  2. In the Report menu, select Settings and change the margins as follows:
    • Top margin: 0.5
    • Bottom margin: 0.5
    • Left margin: 0.2
    • Right margin: 0.2
  3. In the Report Explorer, select Report and in the Properties Window, set the PrintWidth property to 8.1 (the width of the label sheet less the Left and Right margins).
  4. Click the detail section of the report to select it and in the Properties window, set the properties as follows.
    Property Name | Property Value
    CanGrow | False
    ColumnCount | 3
    ColumnDirection | AcrossDown
    ColumnSpacing | 0.2
    Height | 1
  5. From the toolbox, drag six TextBox controls onto the detail section and set the properties of each textbox as follows.

    TextBox1

    Property Name | Property Value
    DataField | ContactName
    Location | 0, 0 in
    Size | 2.5, 0.2 in
    Font > Bold | True

    TextBox2

    Property Name | Property Value
    DataField | CompanyName
    Location | 0, 0.2 in
    Size | 2.5, 0.2 in

    TextBox3

    Property Name | Property Value
    DataField | Address
    Location | 0, 0.4 in
    Size | 2.5, 0.2 in

    TextBox4

    Property Name | Property Value
    DataField | City
    Location | 0, 0.6 in
    Size | 2.5, 0.2 in

    TextBox5

    Property Name | Property Value
    DataField | PostalCode
    Location | 0, 0.8 in
    Size | 1.45, 0.2 in

    TextBox6

    Property Name | Property Value
    DataField | Country
    Location | 1.5, 0.8 in
    Size | 1, 0.2 in
  6. Select all of the textboxes, and in the Properties Window, set the CanGrow property to False. This prevents overlapping text, but may crop data if one of the fields contains more data than the control size allows.

If you preview the report at this point, one copy of each label appears on the page.

To add code to the detail_Format event to repeat labels

  1. Double-click in the detail section to create a detail_Format event.
  2. Add the following code to the event to repeat each label across all three columns.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Format event.
Copy Code
'print each label three times
Static counter As Integer
counter = counter + 1
If counter <= 2 Then
    Me.LayoutAction = GrapeCity.ActiveReports.LayoutAction.MoveLayout Or GrapeCity.ActiveReports.LayoutAction.PrintSection
Else
    Me.LayoutAction = GrapeCity.ActiveReports.LayoutAction.MoveLayout Or GrapeCity.ActiveReports.LayoutAction.NextRecord Or GrapeCity.ActiveReports.LayoutAction.PrintSection
    counter = 0
End If

To write the code in C#

C# code. Paste JUST ABOVE the Format event.
Copy Code
int counter=0;
C# code. Paste INSIDE the Format event.
Copy Code
//print each label three times
counter = counter + 1;
if (counter <= 2)
{
    this.LayoutAction =  GrapeCity.ActiveReports.LayoutAction.MoveLayout|GrapeCity.ActiveReports.LayoutAction.PrintSection;
}
else
{
    this.LayoutAction = GrapeCity.ActiveReports.LayoutAction.MoveLayout|GrapeCity.ActiveReports.LayoutAction.NextRecord|GrapeCity.ActiveReports.LayoutAction.PrintSection;
    counter = 0;
}

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.


Columnar Reports

Columnar Reports
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Layout > Columnar Reports
Show All Show All
Hide All Hide All

ActiveReports supports newspaper column layouts in both the Detail and Group sections. You can render the columns either horizontally or vertically in the section with options to break the column on the Group section (i.e. start a new column on the change of a group).

There is also a Boolean ColumnGroupKeepTogether property on the GroupHeader. When set to True, the ColumnGroupKeepTogether property attempts to prevent a group from splitting across columns. If a group cannot fit in the current column, it tries the next. If the group is too large for a single column, the property is ignored.

Note: The ColumnGroupKeepTogether property only works when the GroupHeader's GroupKeepTogether property is set to All.

This walkthrough illustrates how to create a simple report using columns, and is split up into the following activities:

  • Connecting the report to a data source
  • Adding controls to the report to display data
  • Viewing the report
Note: This walkthrough uses the Northwind database. By default, in ActiveReports, the Northwind.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Section Report (code-based) and in the Name field, rename the file as rptColumnar.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

  1. On the detail section band, click the Data Source Icon.
  2. In the Report Data Source dialog that appears, on the OLE DB tab, next to Connection String, click the Build button.
  3. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button to move to the Connection tab.
  4. Click the ellipsis (...) button to browse to your database, for example the NWind.mdb sample database. Click Open once you have selected the appropriate database path.
  5. Click the Test Connection button to see if you have successfully connected to the database.
  6. Click OK to close the Data Link Properties window and return to the Report Data Source dialog. Notice that the Connection String field gets filled automatically.
  7. In the Query field on the OLE DB tab, enter the following SQL query.
    SQL Query
    Copy Code
    SELECT Country, CompanyName, ContactName, Phone FROM Customers ORDER BY Country
  8. Click OK to save the data source and return to the report design surface.

To create a layout for the report

  1. Right-click the design surface of the report and select Insert, then Group Header/Footer to add a GroupHeader/Footer section.
  2. Select the group header and in the Properties Window, set the properties as follows.
    Property Name | Property Value
    Name | ghCountry
    BackColor | Gold
    DataField | Country
    ColumnGroupKeepTogether | True
    GroupKeepTogether | All
  3. Select the group footer and in the Properties window, set the BackColor property to Goldenrod.
  4. In the Report Explorer, drag the Country field onto the GroupHeader section and in the Properties window, set its properties as follows.
    Property Name | Property Value
    Location | 0, 0 in
    Size | 3.25, 0.2 in
    Alignment | Center
    Font > Size | 12
    Font > Bold | True
  5. Select the PageHeader section and in the Properties window, set the BackColor property to Linen.
  6. From the toolbox, drag a Label control onto the PageHeader section and in the Properties window, set the properties as follows:
    Property Name | Property Value
    Location | 0, 0 in
    Size | 6.5, 0.25 in
    Alignment | Center
    Font > Size | 14
    Text | Customer Telephone List by Country
  7. Select the Detail section and in the Properties window, set the properties as follows.
    Property Name | Property Value
    CanShrink | True
    ColumnCount | 2
  8. In the Report Explorer, expand the Fields node, then the Bound node. Drag the following fields onto the Detail section and set the properties of each textbox as indicated.

    TextBox1

    Property Name | Property Value
    DataField | CompanyName
    Location | 0, 0 in
    Size | 1.15, 0.2 in
    Font > Size | 8pt

    TextBox2

    Property Name | Property Value
    DataField | ContactName
    Location | 1.15, 0 in
    Size | 1.15, 0.2 in
    Font > Size | 8pt

    TextBox3

    Property Name | Property Value
    DataField | Phone
    Location | 2.3, 0 in
    Size | 0.95, 0.2 in
    Font > Size | 8pt

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.


Group On Unbound Fields

Group On Unbound Fields
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Layout > Group On Unbound Fields
Show All Show All
Hide All Hide All

ActiveReports allows you to set up grouping in unbound reports. When setting up grouping, the group header's DataField property is used to retrieve the grouping data from the database in the same manner as a textbox's DataField property. This walkthrough illustrates how to set up grouping in an unbound report.

This walkthrough is split into the following activities:

  • Adding code to connect the report to a data source
  • Adding controls to contain the data
  • Using the DataInitialize event to add fields to the report's fields collection
  • Using the FetchData event to populate the report fields
  • Adding code to close the connection to the data source
  • Viewing the report
Note: This walkthrough uses the Northwind database. By default, in ActiveReports, the Northwind.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Section Report (code-based) and in the Name field, rename the file as rptGroupUnbound.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To add code to connect the report to a data source

  1. Double-click the gray area below the report. This creates an event-handling method for the report's ReportStart event.
  2. Add code to the handler to:
    • Set the data source connection string
    • Set the data source SQL query
    • Open the connection and retrieve the data with the data reader

The following examples show what the code for the method looks like in Visual Basic.NET and C#.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste JUST ABOVE the ReportStart event.
Copy Code
Dim connection As System.Data.OleDb.OleDbConnection
Dim reader As System.Data.OleDb.OleDbDataReader
Visual Basic.NET code. Paste INSIDE the ReportStart event.
Copy Code
'Create the data connection and change the data source path as necessary
Dim connectionString As String
connectionString = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Users\[User Folder]\Documents\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb"
connection = New System.Data.OleDb.OleDbConnection(connectionString)
connection.Open()

Dim sqlString As String
sqlString = "SELECT * FROM categories INNER JOIN products ON categories.categoryid= products.categoryid ORDER BY categories.CategoryID"
Dim command As New System.Data.OleDb.OleDbCommand(sqlString, connection)
'Retrieve data
reader = command.ExecuteReader()

To write the code in C#

C# code. Paste JUST ABOVE the ReportStart event.
Copy Code
private System.Data.OleDb.OleDbConnection connection;
private System.Data.OleDb.OleDbDataReader reader;
C# code. Paste INSIDE the ReportStart event.
Copy Code
//Create the data connection and change the data source path as necessary
string connectionString = @"Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Users\[User Folder]\Documents\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb";
connection=new System.Data.OleDb.OleDbConnection(connectionString);
connection.Open();

string sqlString = "SELECT * FROM categories INNER JOIN products ON categories.categoryid = products.categoryid ORDER BY categories.CategoryID";
System.Data.OleDb.OleDbCommand command = new System.Data.OleDb.OleDbCommand(sqlString, connection);

//Retrieve data
reader = command.ExecuteReader();

To create a layout for the report

  1. On the design surface of the report, right-click and select Insert, then Group Header/Footer to add group header and footer sections.
  2. Select the group header and in the Properties window, set the properties as follows.
    Property Name | Property Value
    Name | ghCategories
    BackColor | Silver
    CanShrink | True
    DataField | CategoryID
    GroupKeepTogether | All
    KeepTogether | True
  3. Select the group footer, and in the Properties Window, change the Name property to gfCategories.
  4. Select the Detail section, and in the Properties Window, change the CanShrink property to True.
  5. From the toolbox, drag the following controls to the Group Header section (drag the bottom edge of the section down to display all of the controls) and in the Properties window, set the properties of each control as follows.

    TextBox1

    Property Name | Property Value
    DataField | CategoryName
    Name | txtCategoryName
    Text | Category Name
    Location | 0, 0 in
    Size | 2, 0.2 in
    ForeColor | Blue
    BackColor | Silver
    Font > Size | 12
    Font > Bold | True

    TextBox2

    Property Name | Property Value
    DataField | Description
    Name | txtDescription
    Text | Description
    Location | 0, 0.3 in
    Size | 6, 0.2 in

    Label1

    Property Name | Property Value
    Name | lblProductName
    Text | Product Name
    Location | 0, 0.6 in
    Font > Bold | True

    Label2

    Property Name | Property Value
    Name | lblUnitsInStock
    Text | Units In Stock
    Location | 4.4, 0.6 in
    Font > Bold | True
    Alignment | Right
  6. From the toolbox, drag two Textbox controls to the Detail section and in the Properties window, set the properties of each control as follows.

    TextBox1

    Property Name | Property Value
    DataField | ProductName
    Name | txtProductName
    Text | Product Name
    Location | 0, 0 in
    Size | 4, 0.2 in

    TextBox2

    Property Name | Property Value
    DataField | UnitsInStock
    Name | txtUnitsInStock
    Text | Units In Stock
    Location | 4.4, 0 in
    Alignment | Right

  7. From the toolbox, drag the following controls to the Group Footer section and in the Properties window, set the properties of each control as follows.

    Label

    Property Name | Property Value
    DataField | TotalLabel
    Name | lblTotalLabel
    Location | 2, 0 in
    Size | 2.4, 0.2 in

    TextBox

    Property Name | Property Value
    DataField | ProductName
    Name | txtTotalItems
    Text | Total Items
    Location | 4.4, 0 in
    SummaryType | SubTotal
    SummaryFunc | Count
    SummaryRunning | Group
    SummaryGroup | ghCategories
    Alignment | Right

    Line

    Property Name | Property Value
    Name | Line1
    LineWeight | 3
    X1 | 1.2
    X2 | 6.45
    Y1 | 0
    Y2 | 0

  8. Right-click the Page Header section and select Delete.

To add fields using the DataInitialize event

Warning: Do not access the Fields collection outside the DataInitialize and FetchData events. Accessing the Fields collection outside of these events is not supported, and has unpredictable results.

To write the code in Visual Basic

  1. Right-click in any section of the design surface of the report, and select View Code to display the code view for the report.
  2. At the top left of the code view of the report, click the drop-down arrow and select (YourReportName Events).
  3. At the top right of the code window, click the drop-down arrow and select DataInitialize. This creates an event-handling method for the report's DataInitialize event.
  4. Add code to the handler to add fields to the report's Fields collection.

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste INSIDE the DataInitialize event.
Copy Code
Fields.Add("CategoryID")
Fields.Add("CategoryName")
Fields.Add("ProductName")
Fields.Add("UnitsInStock")
Fields.Add("Description")
Fields.Add("TotalLabel")

To write the code in C#

  1. Click in the gray area below the report to select it.
  2. Click the events icon in the Properties Window to display available events for the report.
  3. Double-click DataInitialize. This creates an event-handling method for the report's DataInitialize event.
  4. Add code to the handler to add fields to the report's Fields collection.

The following example shows what the code for the method looks like.

C# code. Paste INSIDE the DataInitialize event.
Copy Code
Fields.Add("CategoryID");
Fields.Add("CategoryName");
Fields.Add("ProductName");
Fields.Add("UnitsInStock");
Fields.Add("Description");
Fields.Add("TotalLabel");

To populate the fields using the FetchData event

To write the code in Visual Basic

  1. At the top left of the code view for the report, click the drop-down arrow and select (YourReportName Events).
  2. At the top right of the code window, click the drop-down arrow and select FetchData. This creates an event-handling method for the report's FetchData event.
  3. Add code to the handler to retrieve information to populate the report fields.

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste INSIDE the FetchData event.
Copy Code
Try
   reader.Read()
   Me.Fields("CategoryID").Value = reader("categories.CategoryID")
   Me.Fields("CategoryName").Value = reader("CategoryName")
   Me.Fields("ProductName").Value = reader("ProductName")
   Me.Fields("UnitsInStock").Value = reader("UnitsInStock")
   Me.Fields("Description").Value = reader("Description")
   Me.Fields("TotalLabel").Value = "Total Number of " + reader("CategoryName") + ":"
   eArgs.EOF = False
Catch
   eArgs.EOF = True
End Try

To write the code in C#

  1. Back in design view, click in the gray area below the report to select it.
  2. Click the events icon in the Properties window to display available events for the report.
  3. Double-click FetchData. This creates an event-handling method for the report's FetchData event.
  4. Add code to the handler to retrieve information to populate the report fields.

The following example shows what the code for the method looks like.

C# code. Paste INSIDE the FetchData event.
Copy Code
try
   {
      reader.Read();
      Fields["CategoryID"].Value = reader["categories.CategoryID"].ToString();
      Fields["CategoryName"].Value = reader["CategoryName"].ToString();
      Fields["ProductName"].Value = reader["ProductName"].ToString();
      Fields["UnitsInStock"].Value = reader["UnitsInStock"].ToString();
      Fields["Description"].Value = reader["Description"].ToString();
      Fields["TotalLabel"].Value = "Total Number of " + reader["CategoryName"].ToString() + ":";
      eArgs.EOF = false;
   }
catch
   {
      eArgs.EOF = true;
   }

To add code to close the connection to the data source

To write the code in Visual Basic

  1. At the top left of the code view for the report, click the drop-down arrow and select (YourReportName Events).
  2. At the top right of the code window, click the drop-down arrow and select ReportEnd. This creates an event-handling method for the report's ReportEnd event.
  3. Add code to the handler to close the connection.
Visual Basic.NET code. Paste INSIDE the ReportEnd event.
Copy Code
reader.Close()
connection.Close()

To write the code in C#

  1. Back in design view, click in the gray area below the report to select it.
  2. Click the events icon in the Properties window to display available events for the report.
  3. Double-click ReportEnd. This creates an event-handling method for the report's ReportEnd event.
  4. Add code to the handler to close the connection.

The following example shows what the code for the method looks like.

C# code. Paste INSIDE the ReportEnd event.
Copy Code
reader.Close();
connection.Close();

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.


Mail Merge with RichText

Mail Merge with RichText
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Layout > Mail Merge with RichText
Show All Show All
Hide All Hide All

ActiveReports supports field merged reports using the RichText control. The RichText control can contain field place holders that can be replaced with values (merged) at run time. This walkthrough illustrates how to create a mail-merge report using the RichText control.

This walkthrough is split up into the following activities:

  • Adding an ActiveReports to the Visual Studio project
  • Connecting the report to a data source
  • Adding controls and formatting the report
  • Adding fields and text to the RichText control
  • Using the FetchData event to conditionally format data
  • Adding code to update RichText fields with current date and conditional values
  • Adding code to send the group subtotal value to the RichText field
  • Viewing the report
Note: This walkthrough uses the Northwind database. By default, in ActiveReports, the Northwind.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Section Report (code-based) and in the Name field, rename the file as rptLetter.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

  1. On the detail section band, click the Data Source Icon.
  2. In the Report Data Source dialog that appears, on the OLE DB tab, next to Connection String, click the Build button.
  3. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button to move to the Connection tab.
  4. Click the ellipsis (...) button to browse to your database, for example the NWind.mdb sample database. Click Open once you have selected the appropriate database path.
  5. Click the Test Connection button to see if you have successfully connected to the database.
  6. Click OK to close the Data Link Properties window and return to the Report Data Source dialog. Notice that the Connection String field gets filled automatically.
  7. In the Query field on the OLE DB tab, enter the following SQL query.
    SQL Query
    Copy Code
    SELECT Customers.CustomerID, Customers.CompanyName, Customers.ContactName, Customers.Address, Customers.City, Customers.Region, Customers.Country, Customers.PostalCode, Orders.OrderID, Orders.OrderDate, [Order Subtotals].Subtotal
    FROM Customers INNER JOIN ([Order Subtotals] INNER JOIN Orders ON [Order Subtotals].OrderID = Orders.OrderID) ON Customers.CustomerID = Orders.CustomerID
  8. Click OK to save the data source and return to the report design surface.

To create a layout for the report

  1. On the design surface of the report, right-click and select Insert, then Group Header/Footer to add group header and footer sections.
  2. On the design surface, select the grey area outside the report and in the Properties window, set the PrintWidth property to 6.5.
  3. Select the group header and in the Properties window, set the properties as follows.
    Property Name | Property Value
    DataField | CustomerID
    Height | 2.5
    KeepTogether | True
  4. On the design surface of the report, select the group footer section and in the Properties window, set the following properties.
    Property Name | Property Value
    Height | 1.1
    KeepTogether | True
    NewPage | After
  5. On the design surface of the report, select the detail section and in the Properties window, set the CanShrink property to True.
  6. On the design surface of the report, select the pageHeader section and in the Properties window, set the following properties.
    Property Name | Property Value
    Height | 0.8
    BackColor | Coral
  7. From the toolbox, drag the Label control to the pageHeader section and in the Properties window, set the properties as follows.

    Label

    Property Name | Property Value
    Location | 0, 0 in
    Size | 6.5, 0.65 in
    Text | GrapeCity
    Font > Size | 36
    Font > Bold | True
  8. In the Report Explorer, expand the Fields node, then the Bound node. Drag the SubTotal field onto the groupHeader section and in the Properties window, set the following properties.
    Property Name | Property Value
    Location | 4, 0 in
    Size | 1, 0.2 in
    Name | txtSubtotal1
    OutputFormat | Currency
    Visible | False
    SummaryType | SubTotal
    SummaryGroup | groupHeader1
    Note: Even though txtSubtotal1 is hidden, setting its properties is important as it provides the value and the formatting that is displayed in the RichText control.
  9. From the toolbox, drag the following controls to the groupHeader section and in the Properties window, set the properties as follows.

    RichTextBox

    Property Name | Property Value
    Location | 0, 0 in
    Size | 6.5, 2.1 in
    AutoReplaceFields | True

    Label1

    Property Name | Property Value
    Location | 0.875, 2.25 in
    Size | 1, 0.2 in
    Text | Order ID
    Font > Bold | True

    Label2

    Property Name | Property Value
    Location | 1.875, 2.25 in
    Size | 1, 0.2 in
    Text | Order Date
    Font > Bold | True

    Label3

    Property Name | Property Value
    Location | 4.375, 2.25 in
    Size | 1, 0.2 in
    Text | Amount
    Font > Bold | True
    Alignment | Right
  10. In the Report Explorer, expand the Fields node, then the Bound node. Drag the following fields onto the detail section and in the Properties window, set the properties of each textbox as follows.

    TextBox1 (OrderID)

    Property Name | Property Value
    Location | 0.875, 0 in
    Size | 1, 0.2 in

    TextBox2 (OrderDate)

    Property Name | Property Value
    Location | 1.875, 0 in
    Size | 1, 0.2 in
    OutputFormat | Date (MM/dd/yy)

    TextBox3 (Subtotal)

    Property Name | Property Value
    Location | 4.375, 0 in
    Size | 1, 0.2 in
    OutputFormat | Currency
    Alignment | Right
  11. From the toolbox, drag the following controls to the groupFooter section and in the Properties window, set the properties as follows.

    Label1

    Property Name | Property Value
    Location | 5.15, 0.15 in
    Size | 1.35, 0.2 in
    Text | Best regards,
    Alignment | Right

    Label2

    Property Name | Property Value
    Location | 5.15, 0.8 in
    Size | 1.35, 0.2 in
    Text | Accounts Receivable

To add fields to the RichText control

  1. Double-click the RichTextBox control box and delete the default text.
  2. Right-click the box and choose Insert Fields.
  3. In the Insert Field dialog that appears, enter Date and click OK.
  4. Place the cursor in front of the text [!Date] that appears in the RichText control, and add spaces until the text is at the right edge of the control (but not overlapping to the next line).
  5. Place the cursor at the end of the text, and press the Enter key to move to the next line.
  6. Insert each of the following fields using the Insert Field dialog (see design time image above for fields arrangement):
    • CompanyName
    • ContactName
    • Address
    • City
    • Region
    • Country
    • PostalCode
    • SubTotal
  7. Add the following text to the RichText control box after all of the fields.
    Paste into the RichText control
    Copy Code
    Dear [!ContactName],

Thank you for your business. Below is a list of your orders for the past year with a total of [!SubTotal].
Please take this opportunity to review each order and total for accuracy. Call us at 1-800-DNT-CALL with
any questions or concerns.
  8. Arrange the text and fields within the control as you would in any text editor.

To use the FetchData event to conditionally format data

To write the code in Visual Basic

  1. At the top left of the code view for the report, click the drop-down arrow and select (rptLetter Events).
  2. At the top right of the code window, click the drop-down arrow and select FetchData. This creates an event-handling method for the report's FetchData event.
  3. Add code to the handler to add a comma and a space if there is a Region value for the customer's address.

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste JUST ABOVE the FetchData event.
Copy Code
Dim region As String
Visual Basic.NET code. Paste INSIDE the FetchData event.
Copy Code
'If there is no region for the customer, display nothing
If Fields("Region").Value Is System.DBNull.Value Then
    region = ""
Else
'If there is a region, add a comma and a space
    region = ", " + Fields("Region").Value
End If

To write the code in C#

  1. Back in design view, click in the gray area below the report to select it.
  2. Click the events icon in the Properties window to display available events for the report.
  3. Double-click FetchData. This creates an event-handling method for the report's FetchData event.
  4. Add code to the handler to add a comma and a space if there is a Region value for the customer's address.

The following example shows what the code for the method looks like.

C# code. Paste JUST ABOVE the FetchData event.
Copy Code
string region;
C# code. Paste INSIDE the FetchData event.
Copy Code
if(Fields["Region"].Value is System.DBNull)
  region = "";
else
  region = ", " + Fields["Region"].Value.ToString();

To add code to update RichText fields with the current date and conditional values

  1. Double-click in the group header section of the report to create an event-handling method for the group header's Format event.
  2. Add code to the handler to:
    • Replace the Date field in the RichText control with the current system date
    • Replace the Region field with the conditional value created in the FetchData event

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Group Header Format event.
Copy Code
'Use the current date in the letter
Me.RichTextBox1.ReplaceField("Date", System.DateTime.Today.Date.ToShortDateString())
'Use the value returned by the FetchData event
Me.RichTextBox1.ReplaceField("Region", region)

To write the code in C#

C# code. Paste INSIDE the Group Header Format event.
Copy Code
//Use the current date in the letter
this.richTextBox1.ReplaceField("Date", System.DateTime.Today.Date.ToShortDateString());
//Use the value returned by the FetchData event
this.richTextBox1.ReplaceField("Region", region);

To add code to send the group subtotal value to the RichText field

To write the code in Visual Basic.NET

  1. Right-click in any section of the design window of rptLetter, and click on View Code to display the code view for the report.
  2. At the top left of the code view for rptLetter, click the drop-down arrow and select GroupHeader1.
  3. At the top right of the code window, click the drop-down arrow and select BeforePrint. This creates an event-handling method for rptLetter's GroupHeader1_BeforePrint event.
    Note: We use the BeforePrint event instead of the Format event to get the final value of the subtotal field just prior to printing. For more information on section event usage, see the Section Events topic.
  4. Add code to the handler to replace the value of the Subtotal field in the RichText control with the value of the hidden textbox in the group header.
    Visual Basic.NET code. Paste INSIDE the Group Header BeforePrint event.
    Copy Code
    'Use the value from the hidden group subtotal field
Me.RichTextBox1.ReplaceField("SubTotal", Me.txtSubtotal1.Text)

To write the code in C#

  1. Back in design view, click the group header section to select it.
  2. Click the events icon in the Properties window to display available events for the group header.
  3. Double-click BeforePrint. This creates an event-handling method for the report's BeforePrint event.
    Add code to the handler to replace the value of the Subtotal field in the RichText control with the value of the hidden textbox in the group header.
    The following example shows what the code for the method looks like.
    C# code. Paste INSIDE the Group Header BeforePrint event.
    Copy Code
    //Use the value from the hidden group subtotal field
this.richTextBox1.ReplaceField("SubTotal", this.txtSubtotal1.Text);

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.


Overlaying Reports (Letterhead)

Overlaying Reports (Letterhead)
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Layout > Overlaying Reports (Letterhead)
Show All Show All
Hide All Hide All

ActiveReports allows you to overlay static report formats over data reports. This walkthrough illustrates how to overlay an ActiveReport with a static letterhead report.

This walkthrough is split up into the following activities:

  • Adding an ActiveReports to the Visual Studio project
  • Connecting the data report to a data source
  • Adding controls to the letterhead and data reports
  • Adding code to overlay the data report pages with the letterhead report
  • Viewing the report
Note: This walkthrough uses the Northwind database. By default, in ActiveReports, the Northwind.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout (rptLetterhead)

Design Time Layout (rptData)

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Section Report (code-based) and in the Name field, rename the file as rptLetterhead.
  4. Click the Add button to open a new section report in the designer.
  5. From the Project menu, select Add New Item.
  6. In the Add New Item dialog that appears, select ActiveReports 10 Section Report (code-based) and in the Name field, rename the file as rptData.
  7. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the rptData to a data source

  1. On the detail section band, click the Data Source Icon.
  2. In the Report Data Source dialog that appears, on the OLE DB tab, next to Connection String, click the Build button.
  3. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button to move to the Connection tab.
  4. Click the ellipsis (...) button to browse to your database, for example the NWind.mdb sample database. Click Open once you have selected the appropriate database path.
  5. Click the Test Connection button to see if you have successfully connected to the database.
  6. Click OK to close the Data Link Properties window and return to the Report Data Source dialog. Notice that the Connection String field gets filled automatically.
  7. In the Query field on the OLE DB tab, enter the following SQL query.
    SQL Query
    Copy Code
    SELECT * FROM Customers ORDER BY Country
  8. Click OK to save the data source and return to the report design surface.

To create a layout for the rptData

  1. Select the PageHeader section and in the Properties Window, set the Height property to 0.65. (This will match the height of the page header in the template.)
  2. On the design surface, select the grey area outside the report and in the Properties window, set the PrintWidth property to 6.5.
  3. Right-click the report and select Insert > GroupHeader/Footer to add group header and group footer sections.
  4. Select the group header and in the Properties window, set the properties as follows.
    Property Name | Property Value
    Name | ghCustomers
    BackColor | MediumSlateBlue
    CanShrink | True
    DataField | Country
    GroupKeepTogether | FirstDetail
    KeepTogether | True
  5. From the toolbox, drag the following controls to ghCustomers and in the Properties window, set the properties as follows.

    TextBox1

    Property Name | Property Value
    DataField ="Customers in " + Country
    (DataField)
    Size | 2, 0.2 in
    Location | 0, 0 in
    Font Bold | True
    ForeColor | White
    Font Size | 12

    Label1

    Property Name | Property Value
    Text | ID
    Size | 0.6, 0.2 in
    Location | 0, 0.2 in
    Font Bold | True
    ForeColor | DarkSlateBlue

    Label2

    Property Name | Property Value
    Text | Company Name
    Size | 1.1, 0.2 in
    Location | 0.7, 0.2 in
    Font Bold | True
    ForeColor | DarkSlateBlue

    Label3

    Property Name | Property Value
    Text | Address
    Size | 1, 0.2 in
    Location | 2.7, 0.2 in
    Font Bold | True
    ForeColor | DarkSlateBlue

    Label4

    Property Name | Property Value
    Text | City
    Size | 1, 0.2 in
    Location | 5.5, 0.2 in
    Font Bold | True
    ForeColor | DarkSlateBlue
  6. Click the Detail section and in the Properties window, set the properties as follows.
    Property Name | Property Value
    BackColor | LightGray
    CanShrink | True
  7. From the toolbox, drag four TextBox controls onto the Detail section and set the properties of each textbox as follows.

    TextBox1

    Property Name | Property Value
    DataField | CustomerID
    Size | 0.6, 0.2 in
    Location | 0, 0 in

    TextBox2

    Property Name | Property Value
    DataField | CompanyName
    Size | 2, 0.2 in
    Location | 0.7, 0 in

    TextBox3

    Property Name | Property Value
    DataField | Address
    Size | 2.8, 0.2 in
    Location | 2.7, 0 in

    TextBox4

    Property Name | Property Value
    DataField | City
    Size | 1, 0.2 in
    Location | 5.5, 0.2 in
  8. Select the group footer and in the Properties window, set the Height property to 0.

To create a layout for the rptLetterhead

  1. Select the Page Header and in the Properties window, set the properties as follows.
    Property Name | Property Value
    BackColor | DarkSlateBlue
    Height | 0.65
  2. From the toolbox, drag a Label control onto the Page Header and in the Properties window, set the properties as follows.

    Label1

    Property Name | Property Value
    Size | 6.5, 0.65 in
    Location | 0, 0 in
    Font Size | 36
    Font Bold | True
    ForeColor | White
    Text | GrapeCity
  3. Select the Page Footer and in the Properties window, set the BackColor property to DarkSlateBlue.
  4. From the toolbox, drag a Label control onto the Page Footer and in the Properties window, set the properties as follows.
    Property Name | Property Value
    Size | 6.5, 0.2 in
    Location | 0, 0 in
    Alignment | Center
    Font Bold | True
    ForeColor | White
    Text | 984-242-0700, http://activereports.grapecity.com, activereports.sales@grapecity.com

To add code to overlay the data report pages with the letterhead report

To write the code in Visual Basic.NET

  • Add the ActiveReports viewer control to the Windows Form. Then, double-click the top of the Windows Form to create an event-handling method for the form's Load event. Add code to the handler to:
    • Set the viewer to display the rptData report document
    • Overlay rptLetterhead on rptData

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste INSIDE the Form Load event.
Copy Code
   Dim rpt As New rptData()
   rpt.Run()
   Dim rpt2 As New rptLetterhead()
   rpt2.Run()
   Dim i As Integer
   For i = 0 To rpt.Document.Pages.Count - 1
      rpt.Document.Pages(i).Overlay(rpt2.Document.Pages(0))
   Next
   Viewer1.Document = rpt.Document

To write the code in C#

  • Add the ActiveReports viewer control to the Windows Form. Then, double-click the top of the Windows Form to create an event-handling method for the form's Load event. Add code to the handler to:
    • Set the viewer to display the rptData report document
    • Overlay rptLetterhead on rptData

The following example shows what the code for the method looks like.

C# code. Paste INSIDE the Form Load event.
Copy Code
   rptData rpt = new rptData();
   rpt.Run();
   rptLetterhead rpt2 = new rptLetterhead();
   rpt2.Run();
   for(int i = 0; i < rpt.Document.Pages.Count; i++)
   {
      rpt.Document.Pages[i].Overlay(rpt2.Document.Pages[0]);
   }
   viewer1.Document = rpt.Document;

To view the report

Open the report in the Viewer. See Windows Forms Viewer for further information.


Run Time Layouts

Run Time Layouts
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Layout > Run Time Layouts
Show All Show All
Hide All Hide All

ActiveReports objects and controls are completely accessible at run time. You can modify the properties of any of the report sections or controls to produce a dynamic report. The section Format event allows you to modify the properties of the section and its controls, including height, visibility, and other visual properties. The Format event is the only event in which you can modify the printable area of a section. Once this event has run, any changes to the section's height are not reflected in the report output.

This walkthrough illustrates how to create a report layout at run time based on user input.

Note: Add controls dynamically in the ReportStart event, otherwise, results may be unpredictable. For more information on events, see the Section Report Events topic.

This walkthrough is split into the following activities:

  • Adding an ActiveReport to the Visual Studio project
  • Adding controls to the Windows Form to display fields and a viewer
  • Generating a dataset for the Windows Form
  • Adding code to create the report layout
  • Adding code to fill the check list with fields and to launch the report
  • Adding code to alternate colors in the detail section
  • Adding code to the ReportStart event to call the report layout code
  • Adding code to the button's Click event to collect the selected values and launch the report
  • Adding code to enable the button when fields are selected
  • Adding code to the Form_Load event to call the fill check list code
  • Viewing the report
Note: This walkthrough uses the NWind database. By default, in ActiveReports, the Nwind.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout (Windows form)

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Section Report (code-based) and in the Name field, rename the file as rptRunTime.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To add controls to the form

  1. Resize the Windows Form so that it is large enough to accommodate a number of controls.
  2. From the Visual Studio toolbox, drag the Panel control to the Windows Form and in the Properties Window, set the properties as follows.

    Panel

    Property Name | Property Value
    Dock | Left
    Name | Panel1
  3. From the Visual Studio toolbox, drag the following controls onto the Panel1 and in the Properties Window, set the properties listed below.

    Label

    Property Name | Property Value
    Dock | Top
    Name | lblSelectFields
    Text | Select Fields for Your Report

    CheckedListBox

    Property Name | Property Value
    Dock | Fill
    Name | clbFields

    Button

    Property Name | Property Value
    Dock | Bottom
    Name | btnGenRep
    Text | Generate Report

    CheckBox

    Property Name | Property Value
    Dock | Bottom
    Name | chkGroup
    Text | Group By Category ID
  4. From the Visual Studio toolbox, drag the Viewer control to the Windows Form and in the Properties Window, set the properties as follows.

    Viewer

    Property Name | Property Value
    Dock | Fill
    Name | Viewer1

To generate a dataset for the Form

  1. From the Project menu, select Add New Item.
  2. Select DataSet, rename the file NWINDDataSet.xsd and click the Add button.
  3. In the DataSet Designer that appears, click the Server Explorer link.
  4. In the Server Explorer, expand the node for your local copy of the Northwind database, then the Tables node, and drag the Products table onto the DataSet designer.
    Tip: If you do not see a copy of the Northwind database, click the Connect to Database icon on top of the Server Explorer and follow the prompts.
  5. Open the Form and from the Visual Studio toolbox, drag DataSet onto the Form.
  6. From the Add DataSet dialog that appears, select Typed dataset and click OK.

To add code to create the report layout

  1. Right-click on rptRunTime and select View Code.
  2. Add the following code within the class declaration of the report to:
    • Create an array of fields
    • Create an option for whether to use groups
    • Set properties on the report sections
    • Add textboxes and labels to the report based on the array of fields
    • Handle exceptions

To write the code in Visual Basic.NET

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste JUST BELOW the statements at the top of the code view
Copy Code
Imports GrapeCity.ActiveReports.SectionReportModel
Visual Basic.NET code. Paste INSIDE the class declaration of the report.
Copy Code
Private m_arrayFields As ArrayList
Private m_useGroups As Boolean
'Create an array to hold the fields selected by the user
Public WriteOnly Property FieldsList() As ArrayList
   Set(ByVal Value As ArrayList)
       m_arrayFields = Value
   End Set
End Property
'Create a property to hold the user's grouping choice
Public WriteOnly Property UseGroups() As Boolean
   Set(ByVal Value As Boolean)
       m_useGroups = False
       m_useGroups = Value
   End Set
End Property
Private m_defaultHeight As Single = 0.2F
Private m_defaultWidth As Single = 4.0F
Private m_currentY As Single = 0.0F
'Set up report formatting and add fields based on user choices
Private Sub constructReport()
   Try
      Me.Detail1.CanGrow = True
      Me.Detail1.CanShrink = True
      Me.Detail1.KeepTogether = True
      If m_useGroups = True Then
         'If the user wants grouping, add a group header and footer and set the grouping field
          Me.Sections.InsertGroupHF()
          CType(Me.Sections("GroupHeader1"), GroupHeader).DataField = "CategoryID"
          Me.Sections("GroupHeader1").BackColor = System.Drawing.Color.Gray
          Me.Sections("GroupHeader1").CanGrow = True
          Me.Sections("GroupHeader1").CanShrink = True
          CType(Me.Sections("GroupHeader1"), GroupHeader).RepeatStyle = RepeatStyle.OnPageIncludeNoDetail
          'Add a textbox to display the group's category ID
          Dim txt As New TextBox
          txt.DataField = "CategoryID"
          txt.Location = New System.Drawing.PointF(0.0F, 0)
          txt.Width = 2.0F
          txt.Height = 0.3F
          txt.Style = "font-weight: bold; font-size: 16pt"
          Me.Sections("GroupHeader1").Controls.Add(txt)
      End If
      Dim i As Integer
      For i = 0 To m_arrayFields.Count - 1
          'For all fields selected by the user (except CategoryID) create a label and a textbox
          If m_arrayFields(i).ToString <> "CategoryID" Then
              Dim lbl As New Label
              'Set the label to display the name of the selected field
              lbl.Text = m_arrayFields(i) + ":"
              'Set the location of each label
               '(m_currentY gets the height of each control added on each iteration)
              lbl.Location() = New System.Drawing.PointF(0.0F, m_currentY)
              lbl.Width = 0.9F
              lbl.Height = m_defaultHeight
              Me.Detail1.Controls.Add(lbl)
              Dim txt As New TextBox
               'Set the textbox to display data
              txt.DataField = m_arrayFields(i)
               'Set the location of the textbox
              txt.Location = New System.Drawing.PointF(1.0F, m_currentY)
              txt.Width = m_defaultWidth
              txt.Height = m_defaultHeight
              Me.Detail1.Controls.Add(txt)
               'Set the textbox to use currency formatting if the field is UnitPrice
              If m_arrayFields(i) = "UnitPrice" Then
                 txt.OutputFormat = "$#.00"
              End If
               'Increment the vertical location by adding the height of the added controls
              m_currentY = m_currentY + m_defaultHeight
           End If
       Next
   Catch ex As Exception
       System.Windows.Forms.MessageBox.Show("Error in Report-constructReport: " + ex.Message, "Project Error", System.Windows.Forms.MessageBoxButtons.OK, System.Windows.Forms.MessageBoxIcon.Error)
   End Try
End Sub

To write the code in C#

The following example shows what the code for the method looks like.

C# code. Paste JUST BELOW the statements at the top of the code view
Copy Code
using GrapeCity.ActiveReports.SectionReportModel;
C# code. Paste INSIDE the class declaration of the report.
Copy Code
private ArrayList m_arrayFields;
 //Create an array to hold the fields selected by the user
public ArrayList FieldsList
{
   set{m_arrayFields = value;}
}
private bool m_useGroups = false;
 //Create a property to hold the user's grouping choice
public bool UseGroups
{
   set{m_useGroups = value;}
}
float m_defaultHeight = .2f;
float m_defaultWidth = 4f;
float m_currentY = 0f;
 //Set up report formatting and add fields based on user choices
private void constructReport()
{
   try
   {
      this.detail.CanGrow = true;
      this.detail.CanShrink = true;
      this.detail.KeepTogether = true;
      if(m_useGroups)
      {
         //If the user wants grouping, add a group header and footer and set the grouping field
        this.Sections.InsertGroupHF();
        ((GroupHeader)this.Sections["GroupHeader1"]).DataField = "CategoryID";
        this.Sections["GroupHeader1"].BackColor = System.Drawing.Color.Gray;
        this.Sections["GroupHeader1"].CanGrow = true;
        this.Sections["GroupHeader1"].CanShrink = true;
        ((GroupHeader)this.Sections["GroupHeader1"]).RepeatStyle = RepeatStyle.OnPageIncludeNoDetail;
        this.Sections["GroupFooter1"].Height = 0;
         //Add a textbox to display the group's category ID
        TextBox txt = new TextBox();
        txt.DataField = "CategoryID";
        txt.Location = new System.Drawing.PointF(0f,0);
        txt.Width =2f;
        txt.Height = .3f;
        txt.Style = "font-weight: bold; font-size: 16pt;";
        this.Sections["GroupHeader1"].Controls.Add(txt);
      }
      for(int i=0;i<m_arrayFields.Count;i++)
      {
        if(!m_useGroups || (m_useGroups && m_arrayFields[i].ToString() != "CategoryID"))
          //'For all fields selected by the user (except CategoryID) create a label and a textbox
          {
           Label lbl = new Label();
            //Set the label to display the name of the selected field
           lbl.Text = m_arrayFields[i].ToString() + ":";
            //Set the location of each label
            //(m_currentY gets the height of each control added on each iteration)
           lbl.Location = new System.Drawing.PointF(0f,m_currentY);
           lbl.Width =.9f;
           lbl.Height = m_defaultHeight;
           this.detail.Controls.Add(lbl);
           TextBox txt = new TextBox();
            //Set the textbox to display data
           txt.DataField = m_arrayFields[i].ToString();
            //Set the location of the textbox
           txt.Location = new System.Drawing.PointF(1f,m_currentY);
           txt.Width = m_defaultWidth;
           txt.Height = m_defaultHeight;
           this.detail.Controls.Add(txt);
           //Set the textbox to use currency formatting if the field is UnitPrice
           if (m_arrayFields[i].ToString().Equals("UnitPrice"))
          {
              txt.OutputFormat = "$#.00";
          }
            //Increment the vertical location by adding the height of the added controls
           m_currentY = m_currentY + m_defaultHeight;
        }
      }
   }
   catch(Exception ex)
   {
      System.Windows.Forms.MessageBox.Show("Error in Report-constructReport: " + ex.Message,"Project Error",System.Windows.Forms.MessageBoxButtons.OK,System.Windows.Forms.MessageBoxIcon.Error);
   }
}

To add code to fill the check list with fields and to launch the report

  1. Right-click the Windows Form and select View Code.
  2. Add code within the class declaration of the form to:
    • Fill the check list with fields
    • Launch the report

To write the code in Visual Basic.NET

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste JUST BELOW the statements at the top of the code view
Copy Code
Imports System.Collections
Visual Basic.NET code. Paste INSIDE the class declaration of the form.
Copy Code
Dim i As Integer
Dim c As Integer
Dim m_arrayField As New ArrayList()
Private Sub fillCheckBox()
   For i = 0 To Me.NwindDataSet1.Tables.Count - 1
      For c = 0 To Me.NwindDataSet1.Tables(i).Columns.Count - 1
        Me.clbFields.Items.Add(Me.NwindDataSet1.Tables(i).Columns(c).ColumnName)
      Next
   Next
End Sub
Private Sub launchReport()
   Dim rpt As New rptRunTime()
   Dim dataAdapter As New NWINDDataSetTableAdapters.ProductsTableAdapter
      Try
           rpt.FieldsList = m_arrayField
           rpt.UseGroups = chkGroup.Checked
           dataAdapter.Fill(NwindDataSet1.Products)
           rpt.DataSource = Me.NwindDataSet1.Products
           Viewer1.Document = rpt.Document
           rpt.Run()
        Catch ex As Exception
           System.Windows.Forms.MessageBox.Show(Me, "Error in launchReport: " + ex.Message, "Project Error", MessageBoxButtons.OK, MessageBoxIcon.Error)
      End Try
End Sub

To write the code in C#

The following example shows what the code for the method looks like.

C# code. Paste JUST BELOW the statements at the top of the code view
Copy Code
using System.Collections;
C# code. Paste INSIDE the class declaration of the form.
Copy Code
ArrayList m_arrayField = new ArrayList();
private void fillCheckBox()
{
   for(int i = 0; i < this.nwindDataSet1.Tables.Count; i++)
   {
      for(int c = 0; c < this.nwindDataSet1.Tables[i].Columns.Count; c++)
      {
        this.clbFields.Items.Add(this.nwindDataSet1.Tables[i].Columns[c].ColumnName);
      }
   }
}
private void launchReport()
{
   try
   {
      rptRunTime rpt = new rptRunTime();
      rpt.FieldsList = m_arrayField;
      rpt.UseGroups = chkGroup.Checked;
      NWINDDataSetTableAdapters.ProductsTableAdapter dataAdapter = new NWINDDataSetTableAdapters.ProductsTableAdapter();
      dataAdapter.Fill(this.nwindDataSet1.Products);
      rpt.DataSource = this.nwindDataSet1.Products;
      this.Viewer1.Document = rpt.Document;
      rpt.Run();
   }
   catch(Exception ex)
   {
      MessageBox.Show(this,"Error in launchReport: " + ex.Message,"Project Error",MessageBoxButtons.OK,MessageBoxIcon.Error);
   }
}

To add code to alternate colors in the detail section

  1. Double-click the detail section of rptRunTime. This creates an event-handling method for rptRunTime's Detail_Format event.
  2. Add code to the handler to alternate colors for a green bar report effect.

To write the code in Visual Basic.NET

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste JUST ABOVE the Detail Format event.
Copy Code
Dim m_count As Integer
Visual Basic.NET code. Paste INSIDE the Detail Format event.
Copy Code
If m_count Mod 2 = 0 Then
  Me.Detail1.BackColor = System.Drawing.Color.SlateGray
Else
  Me.Detail1.BackColor = System.Drawing.Color.Gainsboro
End If
m_count = m_count + 1

To write the code in C#

The following example shows what the code for the method looks like.

C# code. Paste JUST ABOVE the Detail Format event.
Copy Code
int m_count;
C# code. Paste INSIDE the Detail Format event.
Copy Code
if(m_count % 2 == 0)
{
  this.detail.BackColor = System.Drawing.Color.SlateGray;
}
else
{
  this.detail.BackColor = System.Drawing.Color.Gainsboro;
}
  m_count++;

To add code to the ReportStart event to call the report layout code

  1. Double-click the gray area below rptRunTime to create an event-handling method for rptRunTime's ReportStart event.
  2. Add code to call the constructReport method.

To write the code in Visual Basic.NET

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste INSIDE the ReportStart event.
Copy Code
constructReport()

To write the code in C#

The following example shows what the code for the method looks like.

C# code. Paste INSIDE the ReportStart event.
Copy Code
constructReport();

To add code to the button's Click event to collect the selected values and launch the report

  1. Double-click btnGenRep to create an event-handling method for the button click event.
  2. Add code to the handler to collect the selected values and launch the report.

To write the code in Visual Basic.NET

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste INSIDE the button click event.
Copy Code
Me.m_arrayField.Clear()
For Me.i = 0 To Me.clbFields.CheckedItems.Count - 1
   m_arrayField.Add(Me.clbFields.CheckedItems(i).ToString)
Next
launchReport()

To write the code in C#

The following example shows what the code for the method looks like.

C# code. Paste INSIDE the button click event.
Copy Code
this.m_arrayField.Clear();
for(int i = 0; i < this.clbFields.CheckedItems.Count; i++)
{
  m_arrayField.Add(this.clbFields.CheckedItems[i].ToString());
}
launchReport();

To add code to enable the button when fields are selected

  1. Select the checked list box (clbFields) and go to the Properties Window.
  2. At the top of Properties Window, select the Events icon to open the events list.
  3. Double-click the SelectedIndexChanged event. This creates an event-handling method for the clbFields_SelectedIndexChanged event.
  4. Add code to the handler to enable the button when fields are selected.

The following example shows what the code for the method looks like.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the SelectedIndexChanged event.
Copy Code
If Me.clbFields.CheckedItems.Count < 0 Then
    Me.btnGenRep.Enabled = False
Else
    Me.btnGenRep.Enabled = True
End If

To write the code in C#

C# code. Paste INSIDE the SelectedIndexChanged event.
Copy Code
if(this.clbFields.CheckedItems.Count>0)
{
  this.btnGenRep.Enabled = true;
}
else
{
  this.btnGenRep.Enabled = false;
}

To add code to the Form_Load event to call the fill check list code

  1. Double-click the title bar of the form. This creates an event-handling method for the Windows Form_Load event.
  2. Add code to the handler to call the fillCheckBox() method to populate clbFields with field values and to handle exceptions.

To write the code in Visual Basic.NET

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste INSIDE the Form Load event.
Copy Code
Try
  fillCheckBox()
Catch ex As Exception
  System.Windows.Forms.MessageBox.Show(Me, "Error in Form1_Load: " + ex.Message, "Project Error", MessageBoxButtons.OK, MessageBoxIcon.Error)
End Try

To write the code in C#

The following example shows what the code for the method looks like.

C# code. Paste INSIDE the Form Load event.
Copy Code
try
{
  fillCheckBox();
}
catch(Exception ex)
{
  MessageBox.Show(this,"Error in Form1_Load: " + ex.Message,"Project Error", MessageBoxButtons.OK,MessageBoxIcon.Error);
}

To view the report

  • Press F5 to run the project.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.


Subreports with XML Data

Subreports with XML Data
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Layout > Subreports with XML Data
Show All Show All
Hide All Hide All

Using XML data requires some setup that is different from other types of data. This walkthrough illustrates how to set up a subreport bound to the XML DataSource in the parent report.

This walkthrough is split up into the following activities:

  • Adding an ActiveReport to the Visual Studio project
  • Connecting the parent report to an XML data source
  • Adding controls to display the data
  • Adding code to create a new instance of the subreport
  • Adding code to pass a subset of the parent report's data to the subreport
  • Viewing the report
Note: This walkthrough uses Customer.xml. By default, in ActiveReports, the Customer.xml file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Samples\Data folder.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Section Report (code-based) and in the Name field, rename the file as rptMain.
  4. Click the Add button to open a new section report in the designer.
  5. From the Project menu, select Add New Item.
  6. In the Add New Item dialog that appears, select ActiveReports 10 Section Report (code-based) and in the Name field, rename the file as rptSub.
  7. Click the Add button to open a second new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the Parent Report (rptMain) to a data source

  1. On the detail section band, click the Data Source Icon.
  2. In the Report Data Source dialog, on the XML tab, click the ellipsis (...) button next to File URL field.
  3. In the Open File window that appears, navigate to Customer.xml and click the Open button. (The default installation path is C:\Users\YourUserName\Documents\GrapeCity Samples\ActiveReports 10\Data\customer.xml).
  4. In the Recordset Pattern field, enter //CUSTOMER.
  5. Click OK to save the data source and return to the report design surface.

To create a layout for the Parent Report (rptMain)

  1. On the design surface, select the pageHeader section and in the Properties window, set the Height property to 0.3.
  2. On the design surface, select the grey area outside the report and in the Properties window, set the PrintWidth property to 6.5.
  3. On the design surface, select the detail section and in the Properties window, set the CanShrink property to True to eliminate white space.
  4. From the toolbox, drag the Label control onto the pageHeader section and in the Properties window, set the properties as follows.
    Property Name | Property Value
    Text | Orders by Customer
    Location | 0, 0 in
    Size | 6.5, 0.25 in
    Font | Arial, 14pt, style=Bold
    Alignment | Center
  5. From the toolbox, drag the controls onto the detail section and in the Properties window, set the properties of each control as follows.

    TextBox1

    Property Name | Property Value
    DataField | NAME
    Location | 1.2, 0 in
    Size | 2, 0.2 in

    Label1

    Property Name | Property Value
    Text | Customer Name:
    Location | 0, 0 in
    Size | 1.2, 0.2 in
    Font Bold | True

    Label2

    Property Name | Property Value
    Text | Orders:
    Location | 1.2, 0.25 in
    Size | 1, 0.2 in
    Font Bold | True

    Subreport

    Property Name | Property Value
    Location | 2.3, 0.25 in
    Size | 4, 1 in

To create a layout for the Child Report (rptSub)

  1. On the design surface, select the detail section and in the Properties window, set the properties as follows.
    Property Name | Property Value
    CanShrink | True
    BackColor | LightSteelBlue
    Tip: Even if you do not want colors in your finished reports, using background colors on subreports can help in troubleshooting layout issues.
  2. On the design surface, right-click the pageHeader or pageFooter section and select Delete. Subreports do not render these sections, so deleting them saves processing time.
  3. From the toolbox, drag the following controls to the detail section and in the Properties window, set the properties as follows.

    TextBox1

    Property Name | Property Value
    DataField | TITLE
    Name | txtTitle
    Location | 0, 0 in
    Size | 2.9, 0.2 in

    TextBox2

    Property Name | Property Value
    DataField | PRICE
    Name | txtPrice
    Location | 3, 0 in
    Size | 1, 0.2 in
    Alignment | Right
    OutputFormat | $#,##0.00 (or select Currency in the dialog)

To add code to create a new instance of the Child Report (rptSub)

Warning: Do not create a new instance of the subreport in the Format event. Doing so creates a new subreport each time the section Format code is run, which uses a lot of memory.

To write the code in Visual Basic

  1. Right-click the design surface of rptMain and select View Code.
  2. At the top left of the code view of the report, click the drop-down arrow and select (rptMain Events).
  3. At the top right of the code window, click the drop-down arrow and select ReportStart. This creates an event-handling method for the ReportStart event.
  4. Add code to the handler to create an instance of rptSub.

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste JUST ABOVE the ReportStart event.
Copy Code
Dim rpt As rptSub
Visual Basic.NET code. Paste INSIDE the ReportStart event.
Copy Code
rpt = New rptSub

To write the code in C#

  1. Click in the gray area below rptMain to select it.
  2. Click the events icon in the Properties Window to display available events for the report.
  3. Double-click ReportStart. This creates an event-handling method for the report's ReportStart event.
  4. Add code to the handler to create a new instance of rptSub.

The following example shows what the code for the method looks like.

C# code. Paste JUST ABOVE the ReportStart event.
Copy Code
private rptSub rpt;
C# code. Paste INSIDE the ReportStart event.
Copy Code
rpt = new rptSub();

To add code to pass a subset of the Parent Report's data to the Child Report

To add code to pass a subset of the parent report's data to the subreport

  1. Double-click in the detail section of the design surface of rptMain to create a detail_Format event.
  2. Add code to the handler to:
    • Create a new GrapeCity XMLDataSource
    • Type cast the new data source as rptMain's data source and set the NodeList to the "ORDER/ITEM" field
    • Display rptSub in the subreport control
    • Pass the new data source to the subreport

To write the code in Visual Basic

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste INSIDE the Format event.
Copy Code
    Dim xmlDS As New GrapeCity.ActiveReports.Data.XMLDataSource
    xmlDS.NodeList = CType(CType(Me.DataSource, GrapeCity.ActiveReports.Data.XMLDataSource).Field("ORDER/ITEM", True), System.Xml.XmlNodeList)
    rpt.DataSource = xmlDS
    SubReport1.Report = rpt

To write the code in C#

The following example shows what the code for the method looks like.

C# code. Paste INSIDE the Format event.
Copy Code
   GrapeCity.ActiveReports.Data.XMLDataSource xmlDS = new GrapeCity.ActiveReports.Data.XMLDataSource();
   xmlDS.NodeList = (System.Xml.XmlNodeList)((GrapeCity.ActiveReports.Data.XMLDataSource) this.DataSource).Field("ORDER/ITEM", true);
   rpt.DataSource = xmlDS;
   subReport1.Report = rpt;

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.
See Also

Concepts

SubReport (Section Report)

How To

Bind Reports to a Data Source


Subreports with Run-Time Data Sources

Subreports with Run-Time Data Sources
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Layout > Subreports with Run-Time Data Sources
Show All Show All
Hide All Hide All

ActiveReports allows section reports to contain any number of child reports using the Subreport control. Child reports, or subreports, are executed each time the parent section (i.e. the section in which the Subreport control is placed) is processed. This walkthrough illustrates how to modify the subreport record source from the data in the parent report to retrieve the correct information.

This walkthrough is split up into the following activities:

  • Adding a main report and a subreport to a Visual Studio project
  • Connecting the main report to a data source
  • Adding controls to the main report to display data and contain the subreport
  • Adding controls to the subreport to display data
  • Adding code to save the current record's CategoryID for use in the subreport's SQL query
  • Adding code to create an instance of the subreport
  • Adding code to assign a data source for the subreport
  • Viewing the report
Note: This walkthrough uses tables from the NWind database. By default, in ActiveReports, the NWind.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Samples\Data folder.

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Section Report (code-based) and in the Name field, rename the file as rptMain.
  4. Click the Add button to open a new section report in the designer.
  5. From the Project menu, select Add New Item.
  6. In the Add New Item dialog that appears, select ActiveReports 10 Section Report (code-based) and in the Name field, rename the file as rptSub.
  7. Click the Add button to open a second new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the Parent Report (rptMain) to a data source

  1. On the detail section band, click the Data Source Icon.
  2. In the Report Data Source dialog that appears, from the OLE DB tab, create a data source connection. See Bind Reports to a Data Source for further details.
  3. Once the connection string field is populated, in the Query field, enter the following SQL query.
    SQL Query
    Copy Code
    SELECT * FROM Categories
  4. Click OK to save the data source and return to the report design surface.

To create a layout for the Parent Report (rptMain)

  1. In the Report Explorer, select the report and in the Properties window, set the PrintWidth property to 5.75.
  2. On the design surface, select the detail section and in the Properties window, set the CanShrink property to True to eliminate white space.
  3. From the toolbox, drag a Label control onto the pageHeader section and in the Properties window, set the properties as follows.
    Property Name | Property Value
    Name | lblProductsbyCategory
    Text | Products by Category
    Location | 0, 0 in
    Size | 5.75, 0.25 in
    Font Size | 14
    Alignment | Center
  4. From the toolbox, drag the following controls onto the detail section and in the Properties window, set the properties as follows.

    TextBox1

    Property Name | Property Value
    Name | txtCategoryID1
    DataField | CategoryID
    Visible | False

    TextBox2

    Property Name | Property Value
    Name | txtCategoryName1
    DataField | CategoryName
    Location | 1.15, 0.05 in

    Label1

    Property Name | Property Value
    Name | lblCategoryName
    Text | CategoryName:
    Location | 0, 0.05 in
    Size | 1.15, 0.2 in
    Font Bold | True

    Label2

    Property Name | Property Value
    Name | lblProducts
    Text | Products:
    Location | 2.4, 0.05 in
    Font Bold | True

    Subreport

    Property Name | Property Value
    Name | SubReport1
    Location | 3.5, 0.05 in
    Size | 2.25, 1 in

To create a layout for the Child Report (rptSub)

  1. On the design surface, select the detail section and in the Properties window, set the following properties.
    Property Name | Property Value
    CanShrink | True
    BackColor | AliceBlue
    Tip: Even if you do not want colors in your finished reports, using background colors on subreports can help in troubleshooting layout issues.
  2. On the design surface, right-click the pageHeader or pageFooter section and select Delete. Subreports do not render these sections, so deleting them saves processing time.
  3. From the toolbox, drag a TextBox control to the detail section and in the Properties window, set the following properties.
    Property Name | Property Value
    DataField | ProductName
    Name | txtProductName
    Text | Product Name
    Location | 0, 0 in
    Size | 2.25, 0.2 in

To add code to create an instance of the subreport

Warning: Do not create a new instance of the subreport in the Format event. Doing so creates a new subreport each time the section Format code is run, which uses a lot of memory.

To write the code in Visual Basic

  1. At the top left of the code view for the report, click the drop-down arrow and select (rptMain Events).
  2. At the top right of the code window, click the drop-down arrow and select ReportStart. This creates an event-handling method for the report's ReportStart event.
  3. Add code to the handler to create a new instance of the subreport.

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste JUST ABOVE the ReportStart event.
Copy Code
Private rpt As rptSub
Private childDataSource As New GrapeCity.ActiveReports.Data.OleDBDataSource()
Visual Basic.NET code. Paste INSIDE the ReportStart event.
Copy Code
rpt = New rptSub()

To write the code in C#

  1. Click in the gray area below rptMain to select it.
  2. Click the events icon in the Properties Window to display available events for the report.
  3. Double-click ReportStart. This creates an event-handling method for the report's ReportStart event.
  4. Add code to the handler to create a new instance of the subreport.

The following example shows what the code for the method looks like.

C# code. Paste JUST ABOVE the ReportStart event.
Copy Code
private rptSub rpt;
private GrapeCity.ActiveReports.Data.OleDBDataSource childDataSource = new GrapeCity.ActiveReports.Data.OleDBDataSource();
C# code. Paste INSIDE the ReportStart event.
Copy Code
rpt = new rptSub();

To add code to assign a data source for the Child Report (rptSub)

  1. Back in design view of the Parent report (rptMain), double-click the detail section. This creates the Detail_Format event handler.
  2. Add code to the handler to:
    • Set the connection string for the OleDBDataSource for the subreport
    • Set the SQL query for the new data source and pass in the current record's CategoryID
    • Set the data source of the subreport to the data source
    • Assign rptSub to the SubReport control

To write the code in Visual Basic

The following example shows what the code for the method looks like.

Visual Basic.NET code. Paste INSIDE the Format event.
Copy Code
childDataSource.ConnectionString = CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString
childDataSource.SQL = "SELECT * FROM Products WHERE CategoryID = " + Me.txtCategoryID1.Value.ToString
rpt.DataSource = childDataSource
SubReport1.Report = rpt

To write the code in C#

C# code. Paste INSIDE the Format event.
Copy Code
childDataSource.ConnectionString = ((GrapeCity.ActiveReports.Data.OleDBDataSource)this.DataSource).ConnectionString;
childDataSource.SQL = "SELECT * FROM Products WHERE CategoryID = " + this.txtCategoryID1.Value.ToString();
rpt.DataSource = childDataSource;
SubReport1.Report = rpt;

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.
See Also
Subreport Walkthroughs

Concepts

SubReport (Section Report)


Chart

Chart
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Chart

This section contains the following walkthroughs that fall under the Chart category.

Bar Chart
This walkthrough demonstrates how to create a bar chart which compares items across categories.
3D Pie Chart
This walkthrough demonstrates how to a three dimensional pie chart which shows how the percentage of each data item contributes to a total percentage.
Financial Chart
This walkthrough demonstrates how to create a financial chart which lets you plot high, low, opening, and closing prices.
Unbound Chart
This walkthrough demonstrates how to create a simple unbound chart.
See Also
Section Report Walkthroughs


Bar Chart

Bar Chart
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Chart > Bar Chart
Show All Show All
Hide All Hide All

Bar charts are useful in comparing items across categories. This walkthrough illustrates how to create a simple bar chart using the ActiveReports chart control.

The walkthrough is split up into the following activities:

  • Adding a chart control to the report
  • Setting a data source for the chart
  • Setting the chart's properties
Note: This walkthrough uses the Northwind database. By default, in ActiveReports, the Northwind.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb.

When you complete this walkthrough you get a layout that looks similar to the following at runtime.

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Section Report (code-based) and in the Name field, rename the file as BarChart.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To add the Chart control to the report

  1. From the toolbox, drag the ChartControl to the body of the report.
  2. If the chart wizard appears, click Cancel.
    Tip: If you do not want the chart wizard to appear each time you add a chart, clear the Auto Run Wizard checkbox. You can still access the wizard via the command verbs (see below).
  3. On the design surface, select the grey area outside the report and in the Properties window, set the PrintWidth property to 6.5.
  4. In the Properties window, set the following properties.
    Property Name | Property Value
    Location | 0, 0 in
    Size | 6.5, 3.5 in
  5. In the Report Explorer, select Detail1 and go to the properties window to set the Height property to 3.5.

To connect the Chart to a data source

  1. Select the Chart control and at the bottom of the Properties window, select the Data Source command. See Properties Window for further details on accessing commands.
    Tip: If the verb is not visible, right-click an empty space in the Properties Window and select Commands to display verbs.
  2. In the Chart DataSource dialog box that appears, click the Build button.
  3. In the Data Link Properties window, select Microsoft Jet 4.0 OLE DB Provider and click the Next button.
  4. Click the ellipsis button (...) to browse to the Northwind database. Click Open once you have selected the file.
  5. Click the OK button to close the window and fill in the Connection String.
  6. In the Query field, enter the following SQL query.
    SQL Query
    Copy Code
    SELECT ShipCountry, SUM(Freight) AS FreightSum FROM Orders GROUP BY ShipCountry
  7. Click OK to save the data source.

To configure the appearance of the Chart

  1. Select the Chart control and at the bottom of the Properties window, select the Customize command. See Properties Window for further details on accessing commands.
  2. In the Chart Designer dialog that appears set the following.

    Chart Areas

    1. Click the Axes bar on the left to expand it.
    2. Click Axis X, and on the Common tab in the pane to the right, type Country in the Title textbox and set the Font size to 12.
    3. On the Labels tab, select the Staggered Labels checkbox to avoid overlapping labels and set the Text angle property to 45.
    4. Click Axis Y on the left, and on the Common tab in the pane to the right, type Freight in the Title textbox and set the Font size to 12.

    Titles

    1. Click the Titles bar on the left to expand it. In the list of titles, the header is selected by default.
    2. In the Caption textbox, type Simple Bar Chart and increase the Font size to 14.
    3. In the list of titles to the left, select the footer and delete it by clicking the Delete icon on top of the list.

    Series

    1. Click the Series bar on the left. The Series1 is selected by default.
    2. In the Data Binding box, set X (Name) to ShipCountry, and set Y to FreightSum.
    3. In the list of series to the left, select Series2 and Series3 and delete them by clicking the Delete icon on top of the list.

    Legend

    1. Click the Legend bar on the left to expand it. The defaultLegend is selected by default.
    2. On the Common tab, clear the Visible checkbox to hide the legend.
  3. Click Finish to exit the Chart Designer.

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.
See Also
Chart

Concepts

ChartControl


3D Pie Chart

3D Pie Chart
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Chart > 3D Pie Chart
Show All Show All
Hide All Hide All

Pie charts are useful in showing how the percentage of each data item contributes to the total. This walkthrough illustrates how to create a three dimensional pie chart.

The walkthrough is split up into the following activities:

  • Adding a chart control to the report
  • Adding a series and data points to the chart
  • Setting the chart's properties

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Section Report (code-based) and in the Name field, rename the file as 3DPieChart.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To add the Chart control to the report

  1. From the toolbox, drag the ChartControl to the body of the report.
  2. If the chart wizard appears, click Cancel.
    Tip: If you do not want the chart wizard to appear each time you add a chart, clear the Auto Run Wizard checkbox. You can still access the wizard via the command verbs (see below).
  3. In the Properties window, set the following properties.
    Property Name | Property Value
    Location | 0, 0in
    Size | 6.5, 3.5in
  4. In the Report Explorer, select Detail1 and go to the properties window to set the Height property to 3.5.
  5. On the design surface, select the grey area outside the report and in the Properties window, set the PrintWidth property to 6.5.

To add a series and data points to the Chart

  1. With the chart control selected, go to the Properties window and click the Series (Collection) property , then click the ellipsis button (...) that appears.
  2. In the Series Collection Editor that appears, Series1 is selected by default. There, under Series1 properties, change the following.
    Property Name | Property Value
    ColorPalette | Confetti
    Type | Doughnut3D
  3. Click the Points (Collection) property, then click the ellipsis button that appears.
  4. In the DataPoint Collection that appears, click the Add button to add a data point.
  5. In the DataPoint Collection Editor that appears, go to the Properties window to set the following properties.
    Property Name | Property Value
    LegendText | Figs
    YValues | 19
    Properties>ExplodeFactor | 0.5
  6. Click the Add button to add another data point.
  7. In the DataPoint Collection Editor that appears, go to the Properties window to set the following properties.
    Property Name | Property Value
    LegendText | Raspberries
    YValues | 15
  8. Click the Add button to add another data point.
  9. In the DataPoint Collection Editor that appears, go to the Properties window to set the following properties.
    Property Name | Property Value
    LegendText | Blueberries
    YValues | 37
  10. Click the Add button to add another data point.
  11. In the DataPoint Collection Editor that appears, go to the Properties window to set the following properties.
    Property Name | Property Value
    LegendText | Bananas
    YValues | 21
  12. Click OK to save the data points and return to the Series Collection Editor.
  13. In the Series Collection Editor under Members, select Series2 and Series3 and click the Remove button.
  14. Click OK to save the changes and return to the report design surface.

To configure the appearance of the Chart

  1. With the chart control selected, go to the Properties window and click the ChartAreas (Collection) property and then click the ellipsis button that appears.
  2. In the ChartArea Collection Editor that appears, expand the Projection property node and set the VerticalRotation property to 50. This allows you to see more of the top of the pie.
  3. Click OK to return to the report design surface.
  4. With the chart control highlighted, go to the Properties window and click the Titles (Collection) property and then click the ellipsis button that appears.
  5. In the Title Collection Editor that appears, under header properties, set the following properties.
    Property Name | Property Value
    Text | 3D Pie Chart
    Font Size | 14
  6. Under Members, select the footer and click the Remove button.
  7. Click OK to return to the report design surface.

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.
See Also
Chart

Concepts

ChartControl


Financial Chart

Financial Chart
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Chart > Financial Chart
Show All Show All
Hide All Hide All

Financial charts are useful for displaying stock information using High, Low, Open and Close values. This walkthrough illustrates how to create a Candle chart.

The walkthrough is split up into the following activities:

  • Adding a chart control to the report
  • Adding a series and data points to the chart
  • Setting the chart's properties

When you complete this walkthrough you get a layout that looks similar to the following at design time and at runtime.

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Section Report (code-based) and in the Name field, rename the file as FinancialChart.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To add the Chart control to the report

  1. From the toolbox, drag the ChartControl to the body of the report.
  2. If the chart wizard appears, click Cancel.
    Tip: If you do not want the chart wizard to appear each time you add a chart, clear the Auto Run Wizard checkbox. You can still access the wizard via the command verbs (see below).
  3. In the Properties window, set the following properties.
    Property Name | Property Value
    Location | 0, 0in
    Size | 6.5, 3.5in
  4. In the Report Explorer, select Detail1 and go to the properties window to set the Height property to 3.5.On the design surface, select the grey area outside the report and in the Properties window, set the PrintWidth property to 6.5.

To add a series and data points to the Chart

  1. With the chart control selected, go to the Properties window and click the Series (Collection) property and then click the ellipsis button.
  2. In the Series Collection Editor that appears, Series1 is selected by default. There, under Series1 properties, change the following.
    Property Name | Property Value
    Type | Candle
    Properties>BodyDownswingBackdrop | (Default)
    Properties>BodyDownswingBackdrop>Color | Fuchsia
    Properties>BodyUpswingBackdrop | (Default)
    Properties>BodyUpswingBackdrop>Color | DarkViolet
    Properties>BodyWidth | 5
    Properties>WickLine | (Default)
    Legend | (none)
  3. Click the Points (Collection) property, then click the ellipsis button that appears.
  4. In the DataPoint Collection window that appears, click Add to add a data point and set its YValues property to 99; 37; 53; 88.
    Note: The first Y value is the high figure or top of the wick; the second is the low figure, or bottom of the wick; the third is the opening figure; the fourth is the closing figure. If the fourth figure is higher than the third, the candle is DarkViolet, the BodyUpswingBackdrop.
  5. Click Add to add another data point and set its YValues property to 115; 22; 101; 35.
  6. Click Add to add another data point, and set its YValues property to 87; 1; 7; 80.
  7. Click Add to add another data point, and set its YValues property to 63; 14; 57; 25.
  8. Click Add to add another data point, and set its YValues property to 130; 25; 25; 120.
  9. Click OK to save the data points and close the window.
  10. In the Series Collection Editor under Members, select Series2 and Series3 and click the Remove button.
  11. Click OK to return to the report design surface.

To configure the appearance of the Chart

  1. With the chart control selected, go to the Properties window and click the ChartAreas (Collection) property and then click the ellipsis button that appears.
  2. In the ChartArea Collection Editor that appears, under defaultArea properties, click the Axes (Collection) property, then click the ellipsis button that appears.
  3. In the AxisBase Collection Editor that appears, set the following properties.

    AxisBase

    1. Under AxisX properties, in the Title property delete the default text.
    2. Click the Labels (Collection) property, then click the ellipsis button that appears. This is where you add the labels that appear along the X axis, the line across the bottom of the chart.
    3. In the Array Data Editor that appears, enter the following into the editor, each item on a separate line:
      • Monday
      • Tuesday
      • Wednesday
      • Thursday
      • Friday
    4. Click the OK button to return to the AxisBase Collection Editor.
    5. Under Members, select the AxisY member, and under AxisY properties set the following properties.
      Property Name | Property Value
      MajorTick>Step | 10
      LabelsVisible | True
      Min | 0
      Title | $,000
    6. Click OK to return to the ChartArea Collection Editor.
  4. Click OK to return to the report design surface and see the changes reflected in the chart.
  5. With the chart control selected, go to the Properties window and click the Titles (Collection) property and then click the ellipsis button that appears.
  6. In the Title Collection Editor that appears, set the following properties.

    Titles

    1. Under header properties, set the Text property to Candle Chart.
    2. Expand the Font property and set Font Size to 14.
    3. Under Members, select footer and click the Remove button.

  7. Click OK to return to the report design surface.
  8. With the Chart control selected, go to the Properties window and click the Legends (Collection) property and then click the ellipsis button that appears.
  9. In the Legend Collection Editor that appears, set the following properties.

    Legends

    1. In the Properties window, set the Visible property to False.
    2. Click OK to return to the report design surface and see the completed chart.

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.
See Also
Chart

Concepts

ChartControl


Unbound Chart

Unbound Chart
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Chart > Unbound Chart
Show All Show All
Hide All Hide All

The Chart control allows you to bind charts to any type of data source, including arrays. You can create a chart without setting its data source and load the data into the control at run time. This walkthrough illustrates how to create a simple unbound chart.

The walkthrough is split up into the following activities:

  • Adding the chart control to the report and setting chart properties
  • Adding code to create the chart at run time
Note: This walkthrough uses the Northwind database. By default, in ActiveReports, the Northwind.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb.

When you complete this walkthrough you get a layout that looks similar to the following at runtime.

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Section Report (code-based) and in the Name field, rename the file as UnboundChart.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To add the Chart control to the report

  1. From the toolbox, drag the ChartControl to the body of the report.
  2. If the chart wizard appears, click Cancel.
    Tip: If you do not want the chart wizard to appear each time you add a chart, clear the Auto Run Wizard checkbox. You can still access the wizard via the command verbs (see below).
  3. In the Properties window, set the following properties.
    Property Name | Property Value
    Location | 0, 0in
    Size | 6.5, 3.5in
  4. In the Report Explorer, select Detail and go to the properties window to set the Height property to 3.5.
  5. On the design surface, select the grey area outside the report and in the Properties window, set the PrintWidth property to 6.5.

To configure the appearance of the Chart

  1. Select the Chart control and at the bottom of the Properties window, select the Customize command. See Properties Window for further details on accessing commands.
    Tip: If the verb is not visible, right-click an empty space in the Properties Window and select Commands to display verbs.
  2. In the ChartAreas view which displays by default, click the Axes bar to expand it.
  3. Click Axis X, and on the Common tab in the pane to the right, type Company Name in the Title textbox and set the font size to 12.
  4. Click Axis Y on the left, and on the Common tab in the pane to the right, type Freight in US$ in the Title textbox and increase the Font size to 12.
  5. Click the Titles bar on the left. In the list of titles, header is selected by default.
  6. On the Title properties page, type Unbound Chart in the Caption textbox and set the Font size to 14.
  7. Under Titles, select the footer and delete it by clicking the Delete icon on top of the list.
  8. Click the Series bar on the left.
  9. Under Series, select Series1, Series2 and Series3 and delete them by clicking the Delete icon on top of the list.
  10. Click the Legends bar on the left. The defaultLegend is selected by default.
  11. On the Common page, clear the Visible checkbox to hide the legend.
  12. Click the Finish button to exit the Chart Designer.

Back on the design surface of the report, the chart appears empty except for the title.

To add the code to create a chart at run time chart in Visual Basic or C#

Double-click the gray area below the report. This creates an event-handling method for rptUnboundChart's ReportStart event. Add code to the handler to:

  • Create the series
  • Create the dataset
  • Set the chart properties
  • Angle the labels to avoid overlap

The following examples show what the code for the methods look like in Visual Basic.NET and C#.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the ReportStart event.
Copy Code
'create the series
Dim series As New GrapeCity.ActiveReports.Chart.Series
series.Type = Chart.ChartType.Bar3D

'connection string and data adapter
Dim dbPath As String = "C:\Users\YourUserName\Documents\GrapeCity Samples\ActiveReports 10\Data\NWIND.MDB"
Dim connString As String = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source= " + dbPath"
Dim da As New System.Data.OleDb.OleDbDataAdapter("SELECT * from Orders WHERE OrderDate < #08/17/1994#", connString)

'create the dataset
Dim ds As New DataSet
da.Fill(ds, "Orders")

'set chart properties
Me.ChartControl1.DataSource = ds
Me.ChartControl1.Series.Add(series)
Me.ChartControl1.Series(0).ValueMembersY = ds.Tables("Orders").Columns(7).ColumnName
Me.ChartControl1.Series(0).ValueMemberX = ds.Tables("Orders").Columns(8).ColumnName

'angle the labels to avoid overlapping
Me.ChartControl1.ChartAreas(0).Axes(0).LabelFont.Angle = 45

To write the code in C#

C# code. Paste INSIDE the ReportStart event.
Copy Code
//create the series
GrapeCity.ActiveReports.Chart.Series series = new GrapeCity.ActiveReports.Chart.Series();
series.Type = GrapeCity.ActiveReports.Chart.ChartType.Bar3D;

//connection string and data adapter
string dbPath = "C:\Users\YourUserName\Documents\GrapeCity Samples\ActiveReports 10\Data\NWIND.MDB";
string connString = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source= " + dbPath;
System.Data.OleDb.OleDbDataAdapter da = new System.Data.OleDb.OleDbDataAdapter
("SELECT * from Orders WHERE OrderDate < #08/17/1994#", connString);

// create the dataset
System.Data.DataSet ds = new System.Data.DataSet();
da.Fill(ds, "Orders");

// set chart properties
this.chartControl1.DataSource = ds;
this.chartControl1.Series.Add(series);
this.chartControl1.Series[0].ValueMembersY = ds.Tables["Orders"].Columns[7].ColumnName;
this.chartControl1.Series[0].ValueMemberX = ds.Tables["Orders"].Columns[8].ColumnName;

// angle the labels to avoid overlapping
this.chartControl1.ChartAreas[0].Axes[0].LabelFont.Angle = 45;

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.
See Also
Chart

Samples

Unbound Data

Concepts

ChartControl


Export

Export
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Export

This section contains the following walkthroughs that fall under the Export category.

Custom Web Exporting (Std Edition)
This walkthrough demonstrates how to set up report custom exporting to PDF, Excel, TIFF, RTF, and plain text formats.
Custom HTML Outputter
This walkthrough demonstrates how to create a custom HTML outputter for your ActiveReports ASP.NET Web Application.
See Also
Section Report Walkthroughs


Custom Web Exporting (Std Edition)

Custom Web Exporting (Std Edition)
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Export > Custom Web Exporting (Std Edition)
Show All Show All
Hide All Hide All

ActiveReports provides components that allow you to set up report custom exporting to PDF, Excel, TIFF, RTF, and plain text formats. You can similarly export to HTML, or you can create a custom HTML outputter.

To add a report and export references to the Web project

  1. From the View menu, select Component Designer to go to the design view of the aspx file.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item window that appears, select the ActiveReports 10 Section Report (xml-based) template, set the report's name to SectionReport1, and click the Add button.
  4. From the Project menu, select Add Reference.
  5. In the Reference Manager dialog that appears, select the following references and click OK to add them to your project.
    GrapeCity.ActiveReports.Export.Pdf.v10
    GrapeCity.ActiveReports.Export.Html.v10
    GrapeCity.ActiveReports.Export.Excel.v10
    GrapeCity.ActiveReports.Export.Word.v10
    GrapeCity.ActiveReports.Export.Xml.v10
    GrapeCity.ActiveReports.Export.Image.v10
  6. Design your report.

To add code to the Web Form to export a report to PDF

  1. Double-click on the design view of the aspx page. This creates an event-handling method for the Page_Load event.
  2. Add code like the following to the Page_Load event.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Page Load event.
Copy Code
Dim m_stream As New System.IO.MemoryStream()
Dim rpt As New GrapeCity.ActiveReports.SectionReport
Dim xtr As New System.Xml.XmlTextReader("\SectionReport1.rpx")
rpt.LoadLayout(xtr)
xtr.Close()
rpt.Run()
Dim PdfExport1 As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
PdfExport1.Export(rpt.Document, m_stream)
m_stream.Position = 0
Response.ContentType = "application/pdf"
Response.AddHeader("content-disposition", "attachment;filename=MyExport.pdf")
Response.BinaryWrite(m_stream.ToArray())
Response.End()

To write the code in C#

C# code. Paste INSIDE the Page Load event.
Copy Code
System.IO.MemoryStream m_stream = new System.IO.MemoryStream();
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();

System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(Server.MapPath("") + "\\SectionReport1.rpx");
rpt.LoadLayout(xtr);
xtr.Close();

rpt.Run();
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport pdfExport1 = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
pdfExport1.Export(rpt.Document, m_stream);
Response.ContentType = "application/pdf";
Response.AddHeader("content-disposition", "inline;filename=MyExport.pdf");
Response.BinaryWrite(m_stream.ToArray());
Response.End();

Note: To use the one-touch printing option, add the following to the code above.

Visual Basic.NET code. Paste INSIDE the Page Load event.
Copy Code
pdfExport1.Options.OnlyForPrint = True
C# code. Paste INSIDE the Page Load event.
Copy Code
pdfExport1.Options.OnlyForPrint = true;

To add code to the Web Form to export a report to Excel

  1. Double-click on the design view of the aspx page. This creates an event-handling method for the Page_Load event.
  2. Add code like the following to the Page_Load event.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Page Load event.
Copy Code
Dim m_stream As New System.IO.MemoryStream()
Dim rpt As New GrapeCity.ActiveReports.SectionReport
Dim xtr As New System.Xml.XmlTextReader("\SectionReport1.rpx")
rpt.LoadLayout(xtr)
xtr.Close()
rpt.Run()
Dim XlsExport1 As New GrapeCity.ActiveReports.Export.Excel.Section.XlsExport
XlsExport1.MinColumnWidth = 0.5
XlsExport1.Export(rpt.Document, m_stream)
m_stream.Position = 0
Response.ContentType = "application/vnd.ms-excel"
Response.AddHeader("content-disposition", "inline; filename=MyExport.xls")
Response.BinaryWrite(m_stream.ToArray())
Response.End()

To write the code in C#

C# code. Paste INSIDE the Page Load event.
Copy Code
System.IO.MemoryStream m_stream = new System.IO.MemoryStream();
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(Server.MapPath("") + "\\SectionReport1.rpx");
rpt.LoadLayout(xtr);
xtr.Close();
rpt.Run();
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport XlsExport1 = new GrapeCity.ActiveReports.Export.Excel.Section.XlsExport();
XlsExport1.MinColumnWidth = 0.5f;
XlsExport1.Export(rpt.Document, m_stream);
m_stream.Position = 0;
Response.ContentType = "application/vnd.ms-excel";
Response.AddHeader("content-disposition","inline; filename=MyExport.xls");
Response.BinaryWrite(m_stream.ToArray());
Response.End();

To add code to the Web Form to export a report to TIFF

  1. Double-click on the design view of the aspx page. This creates an event-handling method for the Page_Load event.
  2. Add code like the following to the Page_Load event.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Page Load event.
Copy Code
Dim m_stream As New System.IO.MemoryStream()
Dim rpt As New GrapeCity.ActiveReports.SectionReport
Dim xtr As New System.Xml.XmlTextReader(Server.MapPath("\SectionReport1.rpx"))
rpt.LoadLayout(xtr)
xtr.Close()
rpt.Run()
Dim TiffExport1 As New GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport
Me.TiffExport1.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.None
Me.TiffExport1.Export(rpt.Document, m_stream)m_stream.Position = 0
Response.ContentType = "image/tiff"
Response.AddHeader("content-disposition", "inline; filename=MyExport.tiff")
Response.BinaryWrite(m_stream.ToArray())
Response.End()

To write the code in C#

C# code. Paste INSIDE the Page Load event.
Copy Code
System.IO.MemoryStream m_stream = new System.IO.MemoryStream();
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(Server.MapPath("") + "\\SectionReport1.rpx");
rpt.LoadLayout(xtr);
xtr.Close();
rpt.Run();
GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport tiffExport1 = new GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport();
tiffExport1.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.None;
tiffExport1.Export(rpt.Document, m_stream);
m_stream.Position = 0;
Response.ContentType = "image/tiff";
Response.AddHeader("content-disposition","inline; filename=MyExport.tiff");
Response.BinaryWrite(m_stream.ToArray());
Response.End();

To add code to the Web Form to export a report to RTF

  1. Double-click on the design view of the aspx page. This creates an event-handling method for the Page_Load event.
  2. Add code like the following to the Page_Load event.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Page Load event.
Copy Code
Dim m_stream As New System.IO.MemoryStream()
Dim rpt As New GrapeCity.ActiveReports.SectionReport
Dim xtr As New System.Xml.XmlTextReader("\SectionReport1.rpx")
rpt.LoadLayout(xtr)
xtr.Close()
rpt.Run()
Dim RtfExport1 As New GrapeCity.ActiveReports.Export.Word.Section.RtfExport
RtfExport1.Export(rpt.Document, m_stream)
m_stream.Position = 0
Response.ContentType = "application/msword"
Response.AddHeader("content-disposition", "inline; filename=MyExport.rtf")
Response.BinaryWrite(m_stream.ToArray())
Response.End()

To write the code in C#

C# code. Paste INSIDE the Page Load event.
Copy Code
System.IO.MemoryStream m_stream = new System.IO.MemoryStream();
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(Server.MapPath("") + "\\SectionReport1.rpx");
rpt.LoadLayout(xtr);
xtr.Close();
rpt.Run();
GrapeCity.ActiveReports.Export.Word.Section.RtfExport rtfExport1  = new GrapeCity.ActiveReports.Export.Word.Section.RtfExport();
rtfExport1.Export(rpt.Document, m_stream);
m_stream.Position = 0;
Response.ContentType = "application/msword";
Response.AddHeader("content-disposition","inline; filename=MyExport.rtf");
Response.BinaryWrite(m_stream.ToArray());
Response.End();

To add code to the Web Form to export a report to Plain Text

  1. Double-click on the design view of the aspx page. This creates an event-handling method for the Page_Load event.
  2. Add code like the following to the Page_Load event.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Page Load event.
Copy Code
Dim m_stream As New System.IO.MemoryStream()
Dim rpt As New GrapeCity.ActiveReports.SectionReport
Dim xtr As New System.Xml.XmlTextReader("\SectionReport1.rpx")
rpt.LoadLayout(xtr)
xtr.Close()
rpt.Run()
Dim TextExport1 As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport
TextExport1.Export(rpt.Document, m_stream)
m_stream.Position = 0
Response.ContentType = "text/plain"
Response.AddHeader("content-disposition", "attachment; filename=MyExport.txt")
Response.BinaryWrite(m_stream.ToArray())
Response.End()

To write the code in C#

C# code. Paste INSIDE the Page Load event.
Copy Code
System.IO.MemoryStream m_stream = new System.IO.MemoryStream();
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader(Server.MapPath("") + "\\SectionReport1.rpx");
rpt.LoadLayout(xtr);
xtr.Close();
rpt.Run();
GrapeCity.ActiveReports.Export.Xml.Section.TextExport textExport1 = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport ();
textExport1.Export(rpt.Document, m_stream);
m_stream.Position = 0;
Response.ContentType = "text/plain";
Response.AddHeader("content-disposition", "attachment; filename=MyExport.txt");
Response.BinaryWrite(m_stream.ToArray());
Response.End();

To run the project

Press F5 to run the project.


Custom HTML Outputter

Custom HTML Outputter
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Export > Custom HTML Outputter
Show All Show All
Hide All Hide All

You can create a custom HTML outputter for your ActiveReports ASP.NET Web Application.

Note: You cannot create a custom HTML outputter for a page report because the html rendering extension does not support the custom output formatter.

This walkthrough is split up into the following activities:

  • Creating a public class for the HTML outputter
  • Adding code to create the Html Export object and export the report
  • Adding a folder for report output

To create a public class for the HTML outputter

  1. In the Solution Explorer window, right-click on your project name and select Add, then New Item.
  2. In the Add New Item dialog that appears, select Class.
  3. Change the name of the class to MyCustomHtmlOutputter and click the Add button.
  4. This opens the code view of the class file where you can add the code needed to create the public class.
  5. For C# code, add the IOutputHtml interface to MyCustomHtmlOutputter class.
    C# code.
    Copy Code
    public class MyCustomHtmlOutputter: IOutputHtml

The following example shows what the complete code for the method looks like.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste JUST ABOVE the class.
Copy Code
Imports System
Imports System.IO
Imports System.Web
Imports System.Text
Imports GrapeCity.ActiveReports
Imports GrapeCity.ActiveReports.Export.Html
Visual Basic.NET code. Paste INSIDE the class.
Copy Code
Implements IOutputHtml
'The http context of the request.
Private context As System.Web.HttpContext = Nothing
'The directory in which to save filename--this ensures that the filename
'is unique.
Private dirToSave As System.IO.DirectoryInfo = Nothing
Public mainPage As String = ""
Public Sub New(ByVal context As System.Web.HttpContext)
If context Is Nothing Then
Throw New ArgumentNullException("context")
End If
Me.context = context
Dim dirName As String = context.Server.MapPath("ReportOutput")
Me.dirToSave = New DirectoryInfo(dirName)
End Sub
#Region "Implementation of IOutputHtml"
Public Function OutputHtmlData(ByVal info As HtmlOutputInfoArgs) As String Implements IOutputHtml.OutputHtmlData
Dim temp As String = ""
Select Case info.OutputKind
Case HtmlOutputKind.BookmarksHtml
Case HtmlOutputKind.FramesetHtml
temp = Me.GenUniqueFileNameWithExtension(".html")
Dim fs As New FileStream(temp, FileMode.CreateNew)
Me.WriteStreamToStream(info.OutputStream, fs)
fs.Close()
Return temp
Case HtmlOutputKind.HtmlPage
'Store the name of the main page so we can redirect the
'browser to it
Me.mainPage = Me.GenUniqueFileNameWithExtension(".html")
Dim fs As New FileStream(Me.mainPage, FileMode.CreateNew)
Me.WriteStreamToStream(info.OutputStream, fs)
fs.Close()
Return Me.mainPage
Case HtmlOutputKind.ImageJpg
'Create a file with a .jpg extension:
temp = Me.GenUniqueFileNameWithExtension(".jpg")
Dim fs As New FileStream(temp, FileMode.CreateNew)
fs = File.Create(temp)
Me.WriteStreamToStream(info.OutputStream, fs)
fs.Close()
Return temp
Case HtmlOutputKind.ImagePng
'Create a file with a .png extension:
temp = Me.GenUniqueFileNameWithExtension(".png")
Dim fs As New FileStream(temp, FileMode.CreateNew)
Me.WriteStreamToStream(info.OutputStream, fs)
fs.Close()
Return temp
Case Else
'Default to html:
temp = Me.GenUniqueFileNameWithExtension(".html")
Dim fs As New FileStream(temp, FileMode.CreateNew)
Me.WriteStreamToStream(info.OutputStream, fs)
fs.Close()
Return temp
End Select
End Function Public Sub Finish() Implements IOutputHtml.Finish
End Sub
#End Region
Private Sub WriteStreamToStream(ByVal sourceStream As Stream, ByVal targetStream As Stream)
'Find the size of the source stream:
Dim size As Integer = CType(sourceStream.Length, Integer)
'Create a buffer that same size
Dim buffer(size) As Byte
'Move the source stream to the beginning
sourceStream.Seek(0, SeekOrigin.Begin)
'Copy the sourceStream into our buffer
sourceStream.Read(buffer, 0, size)
'Write out the buffer to the target stream
targetStream.Write(buffer, 0, size)
End Sub
Private Function GenUniqueFileNameWithExtension(ByVal extensionWithDot As String) As String
Dim r As New System.Random()
Dim unique As Boolean = False
Dim filePath As String = ""
Dim iRandom As Integer = 0
'Generate a random name until it's unique
While Not unique
iRandom = r.Next()
'Build the full filename
Dim sb = New StringBuilder()
sb.Append(Me.dirToSave.FullName)
sb.Append(Path.DirectorySeparatorChar)
sb.Append(iRandom.ToString())
sb.Append(extensionWithDot)
filePath = sb.ToString()
If File.Exists(filePath) = False Then
unique = True
Else
unique = False
End If
End While
Return filePath
End Function
End Class

To write the code in C#

C# code. Paste JUST ABOVE the class.
Copy Code
using System;
using System.IO;
using System.Web;
using System.Text;
using GrapeCity.ActiveReports;
using GrapeCity.ActiveReports.Export.Html;
C# code. Paste INSIDE the class.
Copy Code
   //The http context of the request
   private System.Web.HttpContext context = null;
    //The directory in which to save filename--this ensures that the filename
    //is unique.
   private System.IO.DirectoryInfo dirToSave = null;
   public string mainPage = "";
   public MyCustomHtmlOutputter(System.Web.HttpContext context)
   {
      if(context == null)
      {
        throw new ArgumentNullException("context");
          }
        this.context = context;
        string dirName = context.Server.MapPath("ReportOutput");
        this.dirToSave = new DirectoryInfo(dirName);
    }

#region Implementation of IOutputHtml
public string OutputHtmlData(HtmlOutputInfoArgs info)
{
   string temp = "";
   switch(info.OutputKind)
   {
      case HtmlOutputKind.BookmarksHtml:
      case HtmlOutputKind.FramesetHtml:
      {
        temp = this.GenUniqueFileNameWithExtension(".html");
        FileStream fs = File.Create(temp);
        this.WriteStreamToStream(info.OutputStream, fs);
        fs.Close();
        return temp;
      }

      case HtmlOutputKind.HtmlPage:
      {
         //Store the name of the main page so we can
         //redirect the browser to it
        this.mainPage = this.GenUniqueFileNameWithExtension(".html");
        FileStream fs = File.Create(this.mainPage);
        this.WriteStreamToStream(info.OutputStream, fs);
        fs.Close();
        return this.mainPage;
      }

      case HtmlOutputKind.ImageJpg:
      {
         // Create a file with a .jpg extension:
         temp = this.GenUniqueFileNameWithExtension(".jpg");
        FileStream fs = File.Create(temp);
        this.WriteStreamToStream(info.OutputStream, fs);
        fs.Close();
        return temp;
      }

      case HtmlOutputKind.ImagePng:
      {
        //Create a file with a .png extension:
        temp = this.GenUniqueFileNameWithExtension(".png");
        FileStream fs = File.Create(temp);
        this.WriteStreamToStream(info.OutputStream, fs);
        fs.Close();
        return temp;
      }

      default:
      {
        //Default to html:
        temp = this.GenUniqueFileNameWithExtension(".html");
        FileStream fs = File.Create(temp);
        this.WriteStreamToStream(info.OutputStream, fs);
        fs.Close();
        return temp;
      }
   }
}

public void Finish()
{
}
#endregion

private void WriteStreamToStream(Stream sourceStream, Stream targetStream)
{
   //Find the size of the source stream
   int size = (int)sourceStream.Length;

   //Create a buffer that same size
   byte[] buffer = new byte[size];

   //Move the source stream to the beginning
   sourceStream.Seek(0, SeekOrigin.Begin);

   //Copy the sourceStream into our buffer
   sourceStream.Read(buffer, 0, size);

   //Write out the buffer to the target stream
   targetStream.Write(buffer, 0, size);
}

private string GenUniqueFileNameWithExtension(string extensionWithDot)
{
    System.Random r = new Random();
    bool unique = false;
    string filePath = "";
    int iRandom = 0;
    //Generate a random name until it's unique
    while(!unique)
    {
       iRandom = r.Next();
       //Buld the full filename
       System.Text.StringBuilder sb = new System.Text.StringBuilder();
       sb.Append(this.dirToSave.FullName);
       sb.Append(Path.DirectorySeparatorChar);
       sb.Append(iRandom.ToString());
       sb.Append(extensionWithDot);
       filePath = sb.ToString();
       unique = !File.Exists(filePath);
     }
     return filePath;
  }

To add code to the Web Form to export to HTML

  1. Add an Section Report (Code-based) to the project, and name it rptCustHTML.
  2. Now add a Web form and double-click on the design view of the ASPX. This creates an event-handling method for the Web Form's Page Load event.
  3. Add the following code to the Page Load event.

The following example shows what the code for the method looks like.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Page Load event.
Copy Code
Dim rpt As New rptCustHTML()
Try

rpt.Run(False)
Catch eRunReport As Exception
'If the report fails to run, report the error to the user

Response.Clear()
Response.Write("<h1>Error running report:</h1>")
Response.Write(eRunReport.ToString())
Return
End Try

'Buffer this page's output until the report output is ready.

Response.Buffer = True

'Clear any part of this page that might have already been buffered for output.

Response.ClearContent()

'Clear any headers that might have already been buffered (such as the content type

'for an HTML page)

Response.ClearHeaders()

'Tell the browser and the "network" that the resulting data of this page should be

'cached since this could be a dynamic report that changes upon each request.

Response.Cache.SetCacheability(HttpCacheability.NoCache)

'Tell the browser this is an Html document so it will use an appropriate viewer.

Response.ContentType = "text/HTML"

'Create the Html export object

Dim HtmlExport1 As New GrapeCity.ActiveReports.Export.Html.Section.HtmlExport()

Dim outputter As New MyCustomHtmlOutputter(Me.Context)
HtmlExport1.Export(rpt.Document, outputter, "")
Response.Redirect("ReportOutput" + "/" + System.IO.Path.GetFileName(outputter.mainPage))

To write the code in C#

C# code. Paste INSIDE the Page Load event.
Copy Code
   rptCustHTML rpt = new rptCustHTML();
   try
   {
      rpt.Run(false);
   }
   catch (Exception eRunReport)
   {
      //If the report fails to run, report the error to the user
      Response.Clear();
      Response.Write("<h1>Error running report:</h1>");
      Response.Write(eRunReport.ToString());
      return;
   }
   //Buffer this page's output until the report output is ready.
   Response.Buffer = true;

   //Clear any part of this page that might have already been buffered for output.
   Response.ClearContent();

   //Clear any headers that might have already been buffered (such as the content
   //type for an HTML page)
   Response.ClearHeaders();

   //Tell the browser and the "network" that the resulting data of this page should
   //be cached since this could be a dynamic report that changes upon each request.
   Response.Cache.SetCacheability(HttpCacheability.NoCache);

   //Tell the browser this is an Html document so it will use an appropriate viewer.
   Response.ContentType = "text/html";

   //Create the HTML export object
   GrapeCity.ActiveReports.Export.Html.Section.HtmlExport htmlExport1 = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();

   //Export the report to HTML in this session's webcache
   MyCustomHtmlOutputter outputter = new MyCustomHtmlOutputter(this.Context);
   htmlExport1.Export(rpt.Document, outputter, "");
   Response.Redirect("ReportOutput" + "/" + System.IO.Path.GetFileName(outputter.mainPage));

To add a folder to the project for report output

  1. In the Solution Explorer, right-click your solution and select Add, then New Folder.
  2. Name the folder ReportOutput.
  3. Ensure that you have write permissions for this folder.
  4. To view the results in your Web browser, run the project.
See Also
Custom Web Exporting (Std Edition)


Script

Script
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Script

This section contains the following walkthroughs that fall under the Script category.

ActiveReports allows you to embed script in reports so that code becomes portable when you save a report layout to XML-based RPX format. This characteristic allows the options of stand-alone reporting and web reporting without the need to distribute related .vb or .cs files.

By embedding script when the report is saved as an RPX file, it can later by loaded, run and displayed directly to the viewer control without using the designer. Script can also be used in conjunction with RPX files to allow distributed reports to be updated without recompiling the Visual Studio project.

Script for Simple Reports
This walkthrough demonstrates how to embed script in a simple stand-alone report.
Script for Subreports
This walkthrough demonstrates how to embed script to pass a parameter to a subreport.
See Also
Section Report Walkthroughs


Script for Simple Reports

Script for Simple Reports
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Script > Script for Simple Reports
Show All Show All
Hide All Hide All

ActiveReports allows you to use scripting to embed code in reports saved to the XML-based RPX file format. By embedding script in reports saved as RPX files, you can later load, run, and display reports directly in the viewer control without using the designer. This walkthrough illustrates how to include scripting in a simple report.

This walkthrough is split into the following activities:

  • Temporarily connecting the report to a data source
  • Adding controls to a report to display data
  • Adding scripting to supply data for the controls
  • Saving the report to an RPX file
Tip: For basic steps like adding a report to a Visual Studio project and viewing a report, please see the Basic Data Bound Reports walkthrough.
Note: This walkthrough uses the the Northwind database. By default, in ActiveReports, the NWind.mdb file is located in [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.

When you have finished this walkthrough, you will have a report that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Section Report (code-based) and in the Name field, rename the file as rptSimpleScript.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

Note: The following steps are just for convenience so that the fields list in the Report Explorer can be populated at design time.
  1. In the Report Data Source dialog, on the OLE DB tab, next to Connection String, click the Build button.
  2. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button to move to the Connection tab.
  3. Click the ellipsis (...) button to browse to your database, for example the NWind.mdb sample database. Click Open once you have selected the appropriate database path.
  4. Click the Test Connection button to see if you have successfully connected to the database.
  5. Click OK to close the Data Link Properties window and return to the Report Data Source dialog. Notice that the Connection String field gets filled automatically.
  6. In the Query field on the OLE DB tab, enter the following SQL query.
    SQL Query
    Copy Code
    SELECT * FROM categories INNER JOIN products ON categories.categoryid =
products.categoryid ORDER BY products.categoryid, products.productid
  7. Click OK to save the data source and return to the report design surface.

To create a layout for the report

  1. Right-click the design surface of the report and select Insert then Group Header/Footer to add group header and footer sections to your report.
  2. Increase the group header section's height so that you have room to work.
  3. With the GroupHeader section selected, go to the Properties Window to set the following properties.
    Property Name | Property Value
    BackColor | LightBlue
    CanShrink | True
    DataField | CategoryName
    GroupKeepTogether | All
    KeepTogether | True
  4. From the toolbox, drag the following controls to the GroupHeader section and set the properties of each control as indicated.

    TextBox1

    Property Name | Property Value
    DataField | CategoryName
    Location | 0, 0 in
    Size | 6.5, 0.2 in
    BackColor | CadetBlue
    Font Bold | True
    Font Size | 12

    TextBox2

    Property Name | Property Value
    DataField | Description
    Location | 0, 0.2 in
    Size | 6.5, 0.2 in
    BackColor | CadetBlue

    Label1

    Property Name | Property Value
    Text | Product Name
    Location | 0, 0.4 in
    Size | 1, 0.2 in
    Font Bold | True

    Label2

    Property Name | Property Value
    Text | Units in Stock
    Location | 5.5, 0.4 in
    Size | 1, 0.2 in
    Font Bold | True
    Alignment | Right
  5. From the toolbox, drag the following controls onto the detail section and set the properties of each as indicated.

    TextBox1

    Property Name | Property Value
    DataField | ProductName
    Location | 0, 0 in
    Size | 5.5, 0.2 in

    TextBox2

    Property Name | Property Value
    DataField | UnitsInStock
    Location | 5.5, 0 in
    Size | 1, 0.2 in
    Alignment | Right
  6. Click just below the fields to select the Detail section, and in the Properties Window, set the CanShrink property to True to eliminate white space in the rendered report.
  7. In the Detail section, select both TextBox1 and TextBox2, right-click and select Format Border.
    • Select DarkCyan in the color combo box.
    • Select the solid line in the Line Styles pane.
    • Click the bottom edge in the Preview pane.
    • Click the OK button to add a solid cyan line to the bottom edge of the text boxes.
  8. Increase the group footer section's height so that you have room to work.
  9. With the GroupFooter section selected, go to the properties window and set the following properties.
    Property Name | Property Value
    BackColor | PaleGreen
    CanShrink | True
  10. From the toolbox, drag the following controls to the GroupFooter Section and set the properties of each control as indicated.

    TextBox1

    Property Name | Property Value
    DataField | TotalLabel
    Location | 2.5, 0 in
    Size | 3, 0.2 in
    Font Bold | True

    TextBox2

    Property Name | Property Value
    DataField | ProductName
    Location | 5.5, 0 in
    SummaryType | Subtotal
    SummaryFunc | Count
    SummaryRunning | Group
    SummaryGroup | GroupHeader1
    Alignment | Right

    Label1

    Property Name | Property Value
    Location | 0, 0.25 in
    Size | 6.5, 0.2 in
    BackColor | White (creates white space after the subtotal)
    Text
    Note: Delete the default text.

To add scripting to the report to supply data for the controls

  1. Click in the grey area below the report to select it, and in the Properties Window, change the ScriptLanguage property for the report to the scripting language you want to use. The default setting is C#.
  2. Click the Script tab located at the bottom edge of the report designer to access the scripting editor. Add the scripting code.

The following example shows what the scripting code looks like.

Warning: Do not access the Fields collection outside the DataInitialize and FetchData events. Accessing the Fields collection outside of these events is not supported, and has unpredictable results.

To write the script in Visual Basic.NET.

Visual Basic.NET script. Paste in the script editor window.
Copy Code
Private Shared m_reader As System.Data.OleDb.OleDbDataReader
Private Shared m_cnn As System.Data.OleDb.OleDbConnection

Public Sub ActiveReport_ReportStart()
  'Set up a data connection for the report
  rpt.DataSource = ""
  Dim connString As String = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Users\[User Folder]\Documents\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb"
  Dim sqlString As String = "SELECT * FROM categories INNER JOIN products ON categories.categoryid = products.categoryid ORDER BY products.categoryid, products.productid"

  m_cnn = new System.Data.OleDb.OleDbConnection(connString)
  Dim m_Cmd As System.Data.OleDb.OleDbCommand = new System.Data.OleDb.OleDbCommand(sqlString, m_cnn)

  If m_cnn.State = System.Data.ConnectionState.Closed Then
     m_cnn.Open
  End If
  m_reader = m_Cmd.ExecuteReader
End Sub

Public Sub ActiveReport_DataInitialize()
  'Add data fields to the report
  rpt.Fields.Add("CategoryID")
  rpt.Fields.Add("CategoryName")
  rpt.Fields.Add("ProductName")
  rpt.Fields.Add("UnitsInStock")
  rpt.Fields.Add("Description")
  rpt.Fields.Add("TotalLabel")
End Sub

Public Function ActiveReport_FetchData(ByVal eof As Boolean) As Boolean
  Try
    m_reader.Read
    'Populated the fields with data from the data reader
    rpt.Fields("CategoryID").Value = m_reader("categories.CategoryID")
    rpt.Fields("CategoryName").Value = m_reader("CategoryName")
    rpt.Fields("ProductName").Value = m_reader("ProductName")
    rpt.Fields("UnitsInStock").Value = m_reader("UnitsInStock")
    rpt.Fields("Description").Value = m_reader("Description")
    'Concatenate static text with data
    rpt.Fields("TotalLabel").Value = "Total Number of " + m_reader("CategoryName")+ " Products:"
    eof = False
  Catch
    'If the end of the data file has been reached, tell the FetchData function
    eof = True
  End Try
 Return eof
End Function

Public Sub ActiveReport_ReportEnd()
  'Close the data reader and connection
  m_reader.Close
  m_cnn.Close
End Sub

To write the script in C#.

C# script. Paste in the script editor window.
Copy Code
//C#
private static System.Data.OleDb.OleDbDataReader m_reader;
private static System.Data.OleDb.OleDbConnection m_cnn;

public void ActiveReport_ReportStart()
{
   //Set up a data connection for the report
   rpt.DataSource = "";
   string m_cnnString = @"Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Users\[User Folder]\Documents\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb";
   string sqlString = "SELECT * FROM categories INNER JOIN products ON categories.categoryid = products.categoryid ORDER BY products.categoryid, products.productid";
   m_cnn = new System.Data.OleDb.OleDbConnection(m_cnnString);
   System.Data.OleDb.OleDbCommand m_Cmd = new System.Data.OleDb.OleDbCommand(sqlString,m_cnn);

   if(m_cnn.State == System.Data.ConnectionState.Closed)
   {
      m_cnn.Open();
   }
   m_reader = m_Cmd.ExecuteReader();
}

public void ActiveReport_DataInitialize()
{
   //Add data fields to the report
   rpt.Fields.Add("CategoryID");
   rpt.Fields.Add("CategoryName");
   rpt.Fields.Add("ProductName");
   rpt.Fields.Add("UnitsInStock");
   rpt.Fields.Add("Description");
   rpt.Fields.Add("TotalLabel");
}

public bool ActiveReport_FetchData(bool eof)
{
   try
   {
     m_reader.Read();
     //Populated the fields with data from the data reader
     rpt.Fields["CategoryID"].Value = m_reader["categories.CategoryID"].ToString();
     rpt.Fields["CategoryName"].Value = m_reader["CategoryName"].ToString();
     rpt.Fields["ProductName"].Value = m_reader["ProductName"].ToString();
     rpt.Fields["UnitsInStock"].Value = m_reader["UnitsInStock"].ToString();
     rpt.Fields["Description"].Value = m_reader["Description"].ToString();
     //Concatenate static text with data
     rpt.Fields["TotalLabel"].Value = "Total Number of " + m_reader["CategoryName"].ToString() + " Products:";
     eof = false;
   }
   catch
   {
     //If the end of the data file has been reached, tell the FetchData function
     eof = true;
   }
   return eof;
}

public void ActiveReport_ReportEnd()
{
   //Close the data reader and connection
   m_reader.Close();
   m_cnn.Close();
}

To save the report to an XML-based RPX file

  1. From the Report menu, select Save Layout.
  2. In the Save dialog that appears, enter a name for the report, i.e. rptScript.rpx, and click the Save button.

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.
See Also

Samples

Unbound Data


Script for Subreports

Script for Subreports
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Script > Script for Subreports
Show All Show All
Hide All Hide All

ActiveReports allows you to use scripting to permit reports saved to an XML file to contain code. By including scripting when reports are saved into XML, the reports later can be loaded, run, and displayed directly to the viewer control without needing to use the designer.

This walkthrough illustrates how to use scripting when creating a subreport.

This walkthrough is split up into the following activities:

  • Temporarily connecting the main report to a data source
  • Connecting the subreport to a data source
  • Adding controls to each report to display data
  • Adding the scripting code for rptMain
  • Viewing the report
Tip: For basic steps like adding a report to a Visual Studio project and viewing a report, please see the Basic Data Bound Reports walkthrough.
Note: This walkthrough uses the Northwind database. By default, in ActiveReports, the Northwind.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb.

When you have finished this walkthrough, you will have a report that looks similar to the following at design time and at runtime.

Design Time Layout (main report)

Runtime Layout (main report)

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Section Report (xml-based) and in the Name field, rename the file as rptMain.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

Note: The following steps are just for convenience so that the fields list in the Report Explorer can be populated at design time.
  1. In the Report Data Source dialog, on the OLE DB tab, next to Connection String, click the Build button.
  2. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button to move to the Connection tab.
  3. Click the ellipsis (...) button to browse to your database, for example the NWind.mdb sample database. Click Open once you have selected the appropriate database path.
  4. Click the Test Connection button to see if you have successfully connected to the database.
  5. Click OK to close the Data Link Properties window and return to the Report Data Source dialog. Notice that the Connection String field gets filled automatically.
  6. In the Query field on the OLE DB tab, enter the following SQL query.
    SQL Query
    Copy Code
    SELECT * FROM Orders INNER JOIN Customers ON Orders.CustomerID = Customers.CustomerID ORDER BY CompanyName, OrderDate
  7. Click OK to save the data source and return to the report design surface.

To add a report for the subreport

  1. From the Project menu, select Add New Item.
  2. In the Add New Item dialog that appears, select ActiveReports 10 Section Report (xml-based) and in the Name field, rename the file as rptSub.
  3. Click the Add button to open a new section report in the designer.
  4. Right-click the PageHeader or PageFooter section and select Delete. Subreports do not render these sections, so deleting them saves processing time.
  5. Click in the grey area below the report to select it, and in the Properties window, change the report's ShowParameterUI property to False. This prevents the subreport from requesting a parameter from the user.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the subreport to a data source

Note: The following steps are just for convenience so that the fields list in the Report Explorer can be populated at design time.
  1. In the Report Data Source dialog, on the OLE DB tab, next to Connection String, click the Build button.
  2. In the Data Link Properties window that appears, select Microsoft Jet 4.0 OLE DB Provider and click the Next button to move to the Connection tab.
  3. Click the ellipsis (...) button to browse to your database, for example the NWind.mdb sample database. Click Open once you have selected the appropriate database path.
  4. Click the Test Connection button to see if you have successfully connected to the database.
  5. Click OK to close the Data Link Properties window and return to the Report Data Source dialog. Notice that the Connection String field gets filled automatically.
  6. In the Query field on the OLE DB tab, enter the following SQL query.
    SQL Query
    Copy Code
    SELECT * FROM [order details] inner join products on [order details].productid = products.productid
  7. Click OK to save the data source and return to the report design surface.

To create a layout for the main report

  1. Right-click the design surface of rptMain and select Insert then Group Header/Footer to add group header and footer sections to the report.
  2. In the Properties Window, make the following changes to the group header.
    Property Name | Property Value
    Name | ghCompanies
    BackColor | LemonChiffon
    CanShrink | True
    DataField | CompanyName
    GroupKeepTogether | All
    KeepTogether | True
  3. In the Report Explorer, expand the Fields node, then the Bound node. Drag the CompanyName field onto ghCompanies and in the Properties window, set the properties as follows.
    Property Name | Property Value
    Size | 4, 0.2 in
    Location | 0, 0 in
    Font Bold | True
    Font Size | 12
  4. Right-click the design surface of rptMain and select Insert then Group Header/Footer to add the second group header and footer sections to the report.
  5. In the Properties Window, make the following changes to the second group header.
    Property Name | Property Value
    Name | ghOrders
    BackColor | LightYellow
    CanShrink | True
    DataField | OrderDate
    GroupKeepTogether | All
    KeepTogether | True
  6. From the toolbox, drag three TextBox controls onto ghOrders and set the properties for each control as follows.

    TextBox1

    Property Name | Property Value
    DataField | OrderDate
    Location | 1.1, 0 in
    Size | 1, 0.2 in
    OutputFormat | MM/dd/yy

    TextBox2

    Property Name | Property Value
    DataField | RequiredDate
    Location | 3.5, 0 in
    Size | 1, 0.2 in
    OutputFormat | MM/dd/yy

    TextBox3

    Property Name | Property Value
    DataField | ShippedDate
    Location | 5.5, 0 in
    Size | 1, 0.2 in
    OutputFormat | MM/dd/yy
    Alignment | Right
  7. From the toolbox, drag three Label controls onto ghOrders and set the properties for each control as follows.

    Label1

    Property Name | Property Value
    Location | 0, 0 in
    Size | 1, 0.2 in
    Text | Ordered:
    Font Bold | True

    Label2

    Property Name | Property Value
    Location | 2.5, 0 in
    Size | 1, 0.2 in
    Text | Required:
    Font Bold | True

    Label3

    Property Name | Property Value
    Location | 4.8, 0 in
    Size | 0.65, 0.2 in
    Text | Shipped:
    Font Bold | True
  8. Select the Detail section and in the Properties window, set the CanShrink property to True.
  9. From the toolbox, drag the Subreport control onto the Detail section and in the Properties window, set the properties as follows.
    Property Name | Property Value
    ReportName | full project path\rptSub.rpx
    Name | SubReport1
    Size | 6.5, 1 in
    Location | 0, 0 in

To create a layout for the subreport

  1. Right-click the design surface of rptSub and select Insert then Group Header/Footer to add group header and footer sections to the report.
  2. In the Properties window, make the following changes to the group header.
    Property Name | Property Value
    Name | ghOrderDetails
    BackColor | LightSteelBlue
    CanShrink | True
    DataField | OrderID
  3. From the toolbox, drag four label controls to ghOrderDetails and set the properties for each label as follows.

    Label1

    Property Name | Property Value
    Location | 0, 0 in
    Text | Product Name
    Font Bold | True
    Alignment | Left

    Label2

    Property Name | Property Value
    Location | 3.25, 0 in
    Text | Quantity
    Font Bold | True
    Alignment | Right

    Label3

    Property Name | Property Value
    Location | 4.4, 0 in
    Text | Unit Price
    Font Bold | True
    Alignment | Right

    Label4

    Property Name | Property Value
    Location | 5.5, 0 in
    Text | Discount
    Font Bold | True
    Alignment | Right
  4. From the toolbox, drag four Line controls to ghOrderDetails and set the properties for each line as follows.

    Line1

    Property Name | Property Value
    X1 | 3.2
    X2 | 3.2
    Y1 | 0
    Y2 | 0.2

    Line2

    Property Name | Property Value
    X1 | 4.3
    X2 | 4.3
    Y1 | 0
    Y2 | 0.2

    Line3

    Property Name | Property Value
    X1 | 5.45
    X2 | 5.45
    Y1 | 0
    Y2 | 0.2

    Line4

    Property Name | Property Value
    X1 | 0
    X2 | 6.5
    Y1 | 0.2
    Y2 | 0.2
  5. Click the Detail section and in the Properties window, set the following properties.
    Property Name | Property Value
    BackColor | Gainsboro
    CanShrink | True
  6. From the toolbox, drag four TextBox controls onto onto the Detail section and set the properties as follows.

    TextBox1

    Property Name | Property Value
    DataField | ProductName
    Location | 0, 0 in
    Size | 3.15, 0.2 in
    Alignment | Left

    TextBox2

    Property Name | Property Value
    DataField | Quantity
    Location | 3.25, 0 in
    Size | 1, 0.2 in
    Alignment | Right

    TextBox3

    Property Name | Property Value
    DataField | Products.UnitPrice
    Location | 4.4, 0 in
    Size | 1, 0.2 in
    Alignment | Right
    OutputFormat | Currency

    TextBox4

    Property Name | Property Value
    DataField | Discount
    Location | 5.5, 0 in
    Size | 1, 0.2 in
    Alignment | Right
    OutputFormat | Percentage
  7. From the toolbox, drag four Line controls to the Detail section and set the properties as follows.

    Line5

    Property Name | Property Value
    X1 | 3.2
    X2 | 3.2
    Y1 | 0
    Y2 | 0.2

    Line6

    Property Name | Property Value
    X1 | 4.3
    X2 | 4.3
    Y1 | 0
    Y2 | 0.2

    Line7

    Property Name | Property Value
    X1 | 5.45
    X2 | 5.45
    Y1 | 0
    Y2 | 0.2

    Line8

    Property Name | Property Value
    X1 | 0
    X2 | 6.5
    Y1 | 0.2
    Y2 | 0.2

To embed script in the main report

  1. Change the ScriptLanguage property for the report to the appropriate scripting language. The default setting is C#.
  2. Click the Script tab located below the report designer to access the scripting editor.
  3. Embed script to set the data source for the main report and pass data into the subreport.

The following example shows what the script looks like.

To write the script in Visual Basic.NET

Visual Basic.NET script. Paste in the script editor window.
Copy Code
Dim rptSub As GrapeCity.ActiveReports.SectionReport
Sub ActiveReport_ReportStart
  'Create a new instance of the generic report
  rptSub = new GrapeCity.ActiveReports.SectionReport()
  'Load the rpx file into the generic report
  rptSub.LoadLayout(me.SubReport1.ReportName)
  'Connect data to the main report
  Dim connString As String = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Users\[User Folder]\Documents\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb;Persist Security Info=False"
  Dim sqlString As String = "Select * from orders inner join customers on orders.customerid = customers.customerid order by CompanyName,OrderDate"
  Dim ds As new GrapeCity.ActiveReports.Data.OleDBDataSource()
  ds.ConnectionString = connString
  ds.SQL = sqlString
  rpt.DataSource = ds
End Sub

Sub Detail_Format
  Dim rptSubCtl As GrapeCity.ActiveReports.SubReport = me.SubReport1
  Dim childDataSource As New GrapeCity.ActiveReports.Data.OleDBDataSource()
  childDataSource.ConnectionString = CType(rpt.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString
  'Set a parameter in the SQL query
  childDataSource.SQL = "Select * from [order details] inner join products on [order details].productid = products.productid where [order details].orderid = <%OrderID%>"
  'Pass the data to the subreport
  rptSub.DataSource = childDataSource
  'Display rptSub in the subreport control
  rptSubCtl.Report = rptSub
End Sub

To write the script in C#

C# code. Paste in the script editor window.
Copy Code
GrapeCity.ActiveReports.SectionReport rptSub;
public void Detail_Format()
{
  GrapeCity.ActiveReports.SectionReportModel.SubReport rptSubCtl = this.SubReport1;
  GrapeCity.ActiveReports.Data.OleDBDataSource childDataSource = new GrapeCity.ActiveReports.Data.OleDBDataSource();
  childDataSource.ConnectionString = ((GrapeCity.ActiveReports.Data.OleDBDataSource) rpt.DataSource).ConnectionString;
  //Set a parameter in the SQL query
  childDataSource.SQL = "Select * from [order details] inner join products on [order details].productid = products.productid where [order details].orderid = <%OrderID%>";
  //Pass the data to the subreport
  rptSub.DataSource = childDataSource;
  //Display rptSub in the subreport control
  rptSubCtl.Report = rptSub;
}

public void ActiveReport_ReportStart()
{
  //Create a new instance of the generic report
  rptSub = new GrapeCity.ActiveReports.SectionReport();
  //Load the rpx file into the generic report
  rptSub.LoadLayout(this.SubReport1.ReportName);
  //Connect data to the main report
  string connString = @"Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Users\[User Folder]\Documents\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb;Persist Security Info=False";
  string sqlString = "Select * from orders inner join customers on orders.customerid = customers.customerid order by CompanyName,OrderDate";
  GrapeCity.ActiveReports.Data.OleDBDataSource ds = new GrapeCity.ActiveReports.Data.OleDBDataSource();
  ds.ConnectionString = connString;
  ds.SQL = sqlString;
  rpt.DataSource = ds;
}

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information on how to load the xml-based section report onto the viewer.
See Also
Subreport Walkthroughs


Parameters

Parameters
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Parameters

This section contains the following walkthroughs that fall under the Parameter category.

Using Parameters in SubReports
This walkthrough demonstrates how to link a report with a SubReport using parameters.
Parameters for Charts
This walkthrough demonstrates how to link a report with a chart using parameters.


Using Parameters in SubReports

Using Parameters in SubReports
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Parameters > Using Parameters in SubReports
Show All Show All
Hide All Hide All

Using parameters in SubReport, you can connect a SubReport to the parent report. By setting the parameter on the field that binds the parent report to SubReport, the parent report passes the data to display in SubReport through a parameter. This walkthrough illustrates the method to link the main report with a SubReport using parameters.

This walkthrough is split up into the following activities:

  • Adding a parent report and a SubReport to a Visual Studio project
  • Connecting the parent report to a data source
  • Connecting the SubReport to a data source using parameter
  • Adding controls to create layout of the parent report (rptParent)
  • Adding controls to create a layout of the child report (rptChild)
  • Adding code to embed the SubReport to the SubReport control in parent report
  • Adding code to set the ShowParametersUI property of SubReport to False.
  • Viewing the report
Note: This walkthrough uses tables from the NorthWind database. By default, in ActiveReports, the NWind.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.
Caution: SubReports do not render PageHeader and PageFooter sections.

When you complete this walkthrough you get a layout that looks similar to the following:

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Section Report (code-based) and in the Name field, rename the file as rptParent.
  4. Click the Add button to open a new section report in the designer.
  5. From the Project menu, select Add New Item.
  6. In the Add New Item dialog that appears, select ActiveReports 10 Section Report (code-based) and in the Name field, rename the file as rptChild.
  7. Click the Add button to open a second new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the parent report (rptParent) to a data source

  1. On the detail section band, click the Data Source Icon.
  2. In the Report Data Source dialog that appears, from the OLE DB tab, create a data source connection. See Bind Reports to a Data Source for further details.
  3. Once the connection string field is populated, in the Query field, enter the following SQL query.
    SQL Query
    Copy Code
    Select * from suppliers order by country
  4. Click OK to save the data source and return to the report design surface.

To connect the child report (rptChild) to a data source using parameter

  1. On the detail section band, click the Data Source Icon.
  2. In the Report Data Source dialog that appears, from the OLE DB tab, create a data source connection. See Bind Reports to a Data Source for further details.
  3. Once the connection string field is populated, in the Query field, enter the following parameterized SQL query.
    SQL Query
    Copy Code
    SELECT * FROM products INNER JOIN categories ON products.categoryid = categories.categoryid WHERE Products.SupplierID = <%SupplierID%>
  4. Click OK to save the data source and return to the report design surface.

To create a layout for the parent report (rptParent)

  1. On the design surface, right click the PageHeader or PageFooter section and select Delete to remove the PageHeader/Footer pair.
  2. Right click on the design surface of the parent report and insert GroupHeader/Footer section pair.
  3. Click the GroupHeader section to select it and go to the Properties window to set the following properties.
    Property Name | Property Value
    Name | ghSuppliers
    DataField | Country
  4. From the toolbox, drag a TextBox control onto the groupHeader section and in the Properties window, set the properties as follows:
    Property Name | Property Value
    DataField | Country
    Name | txtCountry
    Text | Country
    Location | 0, 0
    Font | Name:Arial, Size:13pt, Bold:True
  5. Click the Detail section to select it and go to the Properties window to set the CanShrink property to True.
  6. From the Visual Studio toolbox, drag and drop the following controls onto the detail section of the report and in the Properties window, set their properties as given below:

    TextBox1

    Property Name | Property Value
    DataField | CompanyName
    Name | txtCompanyName
    Text | Company Name
    Location | 0.0625, 0.0625
    Size | 2.25, 0.2 in
    BackColor | Silver
    Font | Bold:True

    TextBox2

    Property Name | Property Value
    DataField | ContactName
    Name | txtContactName
    Text | Contact Name
    Location | 2.312, 0.0625
    Size | 1.708, 0.2 in
    BackColor | Silver
    Font | Bold:True

    TextBox3

    Property Name | Property Value
    DataField | Phone
    Name | txtPhone
    Text | Phone
    Location | 4.562, 0.0625
    Size | 1.542, 0.2 in
    BackColor | Silver
    Font | Bold:True

    SubReport

    Property Name | Property Value
    Name | Subreport1
    ReportName | ProductName
    Location | 0.0625, 0.312

To create a layout for the child report (rptChild)

  1. On the design surface, right click the PageHeader or PageFooter section and select Delete to remove the PageHeader/Footer pair.
  2. Right click on the design surface of the child report and insert GroupHeader/Footer section pair.
  3. Click the GroupHeader section to select it and go to the Properties window to set the following properties.
    Property Name | Property Value
    Name | ghProducts
    DataField | CategoryName
  4. From the toolbox, drag and drop a TextBox control onto the groupHeader section and in the Properties window, set the following properties.
    Property Name | Property Value
    DataField | CategoryName
    Name | txtCategoryName
    Text | Category Name
    Location | 0.0625, 0.0625
    Size | 2.042, 0.2 in
    ForeColor | Maroon
    Font | Bold:True
  5. Click the Detail section to select it and go to the Properties window to set the CanShrink property to True.
  6. From the toolbox, drag and drop a TextBox control onto the detail section and in the Properties window, set the following properties.
    Property Name | Property Value
    DataField | ProductName
    Name | txtProductName
    Text | Product Name
    Location | 0.0625, 0.0625
    Size | 1.99, 0.2 in
    ForeColor | Red

To connect the child report (rptChild) to the SubReport control in parent report (rptParent)

  1. Double-click the gray area around the parent report (rptParent) to create an event-handling method for the ReportStart event.
  2. Add code like the following to the handler to create a new instance of the child report (rptChild).

    To write the code in Visual Basic

    Visual Basic.NET code. Paste JUST ABOVE the ReportStart event.
    Copy Code
    Dim rpt As rptChild
    Visual Basic.NET code. Paste INSIDE the ReportStart event.
    Copy Code
    rpt = New rptChild()

    To write the code in C#

    C# code. Paste JUST ABOVE the ReportStart event.
    Copy Code
    private rptChild rpt;
    C# code. Paste INSIDE the ReportStart event.
    Copy Code
    rpt = new rptChild();
  3. Double-click the detail section of the parent report (rptParent) to create a detail_Format event.
  4. Add code like the following to the handler to display a report in the SubReport control.

    To write the code in Visual Basic

    Visual Basic.NET code. Paste INSIDE the Format event.
    Copy Code
    Me.SubReport1.Report = rpt

    To write the code in C#

    C# code. Paste INSIDE the Format event.
    Copy Code
    this.subReport1.Report = rpt;

To set the ShowParametersUI property of SubReport to False

  1. Click the gray area around the child report (rptChild) and go to the Properties window to set the ShowParameterUI property to False.

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

See Also
SubReport Class
ParameterCollection Class

Concepts

Parameters
SubReport (Section Report)


Parameters for Charts

Parameters for Charts
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Parameters > Parameters for Charts
Show All Show All
Hide All Hide All

Using parameters you can connect your report to the chart control. By setting the parameter on the field that connects the report to the chart, the report passes the data to display in the chart. This walkthrough illustrates how to link report with chart using parameters.

The walkthrough is split up into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a data source
  • Adding controls to the report to display data
  • Connecting the Chart control to a data source using parameter
  • Setting the Chart's properties
  • Viewing the report.

When you complete this walkthrough you get a layout that looks similar to the following at runtime:
Note: This topic uses table from the NorthWind database. By default, in ActiveReports, the NWind.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Section Report (code-based) and in the Name field, rename the file as rptChartParams.
  4. Click the Add button to open a new section report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report (rptChartParams) to a data source

  1. On the detail section band, click the Data Source Icon.
  2. In the Report Data Source dialog that appears, from the OLE DB tab, create a data source connection. See Bind Reports to a Data Source for further details.
  3. Once the connection string field is populated, in the Query field, enter the following SQL query.
    SQL Query
    Copy Code
    SELECT * FROM Products ORDER BY CategoryID, ProductName
  4. Click OK to save the data source and return to the report design surface.

To add controls to the report to display data

  1. On the design surface, right click the PageHeader or PageFooter section and select Delete to remove the PageHeader/Footer pair.
  2. Right click on the design surface and insert GroupHeader/Footer section pair.
  3. Click the GroupHeader section to select it and go to the Properties window to set the following properties:
    Property Name | Property Value
    Name | ghCategoryID
    DataField | CategoryID
    GroupKeepTogether | All
    Height | 5.65 inches
  4. Set Height property of Detail section to 0.23 inches and of GroupFooter section to 0 inch.
  5. From the Visual Studio toolbox, drag and drop the following controls onto the GroupHeader section and set their properties as given below:

    Label1

    Property Name | Property Value
    Name | lblCategoryID
    Text | CategoryID
    Location | 1.78, 0

    Label2

    Property Name | Property Value
    Name | lblProductName
    Text | Product Name
    Location | 0.23, 5.43

    Label3

    Property Name | Property Value
    Name | lblUnitsInStock
    Text | Inventory stock
    Location | 5, 5.43

    TextBox

    Property Name | Property Value
    DataField | CategoryID
    Name | txtCategoryID
    Text | CategoryID
    Location | 3.72, 0

    Chart

    Property Name | Property Value
    Name | ChartControl
    Location | 0, 0.313
    Size | 6.5, 4.66
  6. From the Visual Studio toolbox, drag and drop the following controls onto the detail section and set their properties as given below:

    TextBox1

    Property Name | Property Value
    DataField | ProductName
    Name | txtProductName
    Text | ProductName
    Location | 0.23, 0

    TextBox2

    Property Name | Property Value
    DataField | UnitsInStock
    Name | txtUnitsInStock
    Text | UnitsInStock
    Location | 5, 0

To connect the Chart to a data source

  1. Select the Chart control and at the bottom of the Properties window, select the Data Source command. See Properties Window for further details on accessing commands.
    Tip: If the verb is not visible, right-click an empty space in the Properties Window and select Commands to display verbs.
  2. In the Chart DataSource dialog box that appears, click the Build button.
  3. In the Data Link Properties window, select Microsoft Jet 4.0 OLE DB Provider and click the Next button.
  4. Click the ellipsis button (...) to browse to the NorthWind database. Click Open once you have selected the file.
  5. Click the OK button to close the window and fill in the Connection String.
  6. In the Query field, enter the following parameterized SQL query.
    SQL Query
    Copy Code
    SELECT * FROM Products WHERE CategoryID = <%CategoryID||1%> ORDER BY ProductName
    Note: The chart data cannot be arranged if ORDER is not set in both the SQL statements (report and chart statement).
  7. Click OK to save the data source.

To configure the appearance of the Chart

  1. With the chart control selected, go to the Properties window, click the ChartAreas (Collection) property and then click the ellipsis button that appears.
  2. In the ChartArea Collection Editor that appears with defaultArea selected under the members list, click its Axes (Collection) property and then click the ellipsis button.
  3. In the AxesBase Collection Editor that appears, set the following properties.

    AxisBase

    1. With AxisX selected under members list, set Angle property of LabelFont to -90.
    2. Delete text from Title property to make sure that the ProductName label (lblProductName) does not overlap.
    3. Click AxisY under the members list and set its Title property to Unit Stock.
    4. With AxisY selected under the members list, expand the GridLine section under MajorTick property tree view and set its following sub-properties.
      Property Name | Property Value
      Style | Dot
      Color | Silver
      Weight | 1

    5. Click OK to return back to ChartArea collection editor and then click OK again to return back to report design surface.
  4. With the chart control selected, go to the Properties window, click the ChartSeries (Collection) property and then click the ellipsis button that appears.
  5. In the Series Collection Editor that appears, set the following properties:

    Series

    1. With Series1 selected under the members list, set its following properties:
      Property Name | Property Value
      ValueMembersY | UnitsInStock
      ValueMembersX | ProductName

    2. Click OK to return back to report design surface.
  6. With the chart control selected, go to the Properties window, click the Titles (Collection) property and then click the ellipsis button that appears.
  7. In the Title Collection Editor that appears, set the following properties:

    Titles

    1. With Header selected under the members list, set its Text property to Product Inventory.
    2. Delete/Remove Footer from the members list.
    3. Click OK to return back to report design surface.
  8. With the chart control selected, go to the Properties window, click the Legends (Collection) property and then click the ellipsis button that appears.
  9. In the Legend Collection Editor that appears, set the following properties:

    Legends

    1. With defaultLegend selected under the members list, set its Visible property to False.
    2. Click OK to return back to report design surface.

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.


Web

Web
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Web

This section contains the following walkthroughs that fall under the Web category.

Document Web Service
This walkthrough describes how to set up a simple web service that returns an ActiveReports document.
Document Windows Application
This walkthrough describes how to set up a Windows client application for the ActiveReports Document Web Service
Important: In order to consume Web services in your Windows applications, you must set permissions to allow the ASP.NET user to consume the services. Ask your server administrator for help with this.


Document Web Service

Document Web Service
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Web > Document Web Service

Show All Show All
Hide All Hide All

With ASP.NET and ActiveReports, you can set up a Web Service that returns a report document which can be shown in a report viewer control.

This walkthrough illustrates how to create a Web Service that returns the contents of an ActiveReports as a byte array.

This walkthrough is split up into the following activities:

  • Creating an ASP.NET Web Service project
  • Adding code to create the Web Method
  • Testing the Web Service
  • Publishing the Web Service
  • Creating a virtual directory in IIS
Note: For the information on how to connect your report to data and how to create the report layout, please see Basic Data Bound Reports for a section report.

When you have completed this walkthrough, you will have a Web Service that returns the contents of an ActiveReports as a byte array.

To create an ASP.NET Web Service project

  1. From the File menu, select New Project.
  2. In the New Project dialog that appears, select ASP.NET Web Service Application.
  3. Change the name of the project.
  4. Click OK to open the new project in Visual Studio.

To write the code to create the Web Method

  1. On the Service.vb or Service.cs tab is the code view of the Service.asmx file.
  2. Replace the existing WebMethod and HelloWorld function with the following code.

The following code demonstrates how you create the Web Method for a section report.

Visual Basic.NET code. REPLACE the existing WebMethod and function with this code.
Copy Code
<WebMethod( _Description:="Returns a products report grouped by category")> _
Public Function GetProductsReport() As Byte()
     Dim rpt As New rptProducts()
     rpt.Run()
     Return rpt.Document.Content
End Function
C# code. REPLACE the existing WebMethod and function with this code.
Copy Code
[WebMethod(_Description = "Returns a products report grouped by category")]
public byte[] GetProductsReport()
{
    rptProducts rpt = new rptProducts();
    rpt.Run();
    return rpt.Document.Content;
}

To test the Document Web Service

  1. Press F5 to run the project. The Service page appears in your browser.
  2. In the list of supported operations at the top, click GetProductsReport.
  3. Click the Invoke button to test the Web Service operation.
  4. If the test is successful, you will see the binary version of the contents of rptProducts.

To publish the Document Web Service

  1. In the Solution Explorer, right-click the project name and select Publish.
  2. In the Publish Web window that appears, enter locahost in the Service URL field and "SiteName"/WebService in the Site/application field.
    Note: Get the SiteName from the Internet Information Services Manager.
  3. Select the Mark an IIS application on destination option and click the OK button.

To check the configuration in IIS

  1. Open Internet Information Services Manager.
  2. In the Internet Information Services Manager window that appears, expand the tree view in the left pane until you see the Web Service you had added in the steps above.
  3. Right-click the Web Service select Manage Application then Browse.
  4. In the browser that appears, go to the Address bar and add \Service1 to the url.

For information on consuming the Document Web Service in a viewer, see Document Windows Application.

See Also
Document Windows Application
DataSet Web Service


Document Windows Application

Document Windows Application
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Section Report Walkthroughs > Web > Document Windows Application
Show All Show All
Hide All Hide All

In ActiveReports, you can use a Web Service that returns the content of a Section report to show in the Windows Forms viewer control.

This walkthrough illustrates how to create a Windows client application that returns the content of a Section report in the Windows Forms viewer.

This walkthrough builds on the Document Web Service walkthrough and is split up into the following activities:

  • Creating a Visual Studio project
  • Adding the ActiveReports Windows Forms viewer control to the form
  • Adding a reference to a Web service to the project
  • Displaying the content returned by the Document Web Service in the viewer
  • Running the project
Note: Refer to Document Web Service to set up Web service that returns an ActiveReports document.

To create a Visual Studio project

  1. From the File menu, select New, then Project.
  2. In the Templates section of the New Project dialog, select Windows Application.
  3. Change the name of the application to ARDocumentClient.
  4. Click OK to open the project.

To add the Viewer control

  1. From the Visual Studio toolbox, drag the ActiveReports Viewer control onto the form.
  2. Change the Dock property for the viewer control to Fill, and resize the form to accommodate a report.

To add a web reference

To add a reference to a web service in Visual Studio 2010 that is compatible with .NET Framework 2.0 Web service

  1. From the Project menu, select Add Service Reference.
  2. In the Add Service Reference window that appears, click the Advanced button.
  3. In the Service Reference Settings window that appears, click Add Web Reference button.
  4. From the Project menu, select Add Web Reference.
  5. Type in the address of the .asmx file for the ActiveReports Document Web Service you created in the previous walkthrough. For example: http://localhost/ARDocumentWS/Service.asmx
  6. Click the Add Reference button when the Web Service is recognized.

To add a reference to a web service in Visual Studio 2010

  1. From the Project menu, select Add Service Reference.
  2. In the Add Service Reference that appears, type in the address of the .asmx file for the ActiveReports Document Web Service you created in the previous walkthrough. For example: http://localhost/ARDocumentWS/Service.asmx
  3. Click the Go button, and then click the OK button when the Web Service is recognized.

To display the content returned by the Document Web Service in the viewer

To display the report content (for Visual Studio 2010 compatible with .NET Framework 2.0 Web service)

  1. Double-click Form1 to create an event-handling method for the Form1_Load event.
  2. Add code to the handler to display the document Web service content in the viewer.

The following example shows what the code for the method looks like.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Form Load event.
Copy Code
Dim ws As New localhost.Service
Me.Viewer1.Document.Content = ws.GetProductsReport()

To write the code in C#

C# code. Paste INSIDE the Form Load event.
Copy Code
localhost.Service ws = new localhost.Service();
this.viewer1.Document.Content = ws.GetProductsReport();

To display the report content (for Visual Studio 2010)

  1. Double-click on Form1 to create an event-handling method for the Form1_Load event.
  2. Add code to the handler to display the document Web service content in the viewer.

The following example shows what the code for the method looks like.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste INSIDE the Form Load event.
Copy Code
Dim ws As New ServiceReference1.ServiceSoapClient()
Me.Viewer1.Document.Content = ws.GetProductsReport()

To write the code in C#

C# code. Paste INSIDE the Form Load event.
Copy Code
ServiceReference1.ServiceSoapClient ws = new ServiceReference1.ServiceSoapClient();
this.viewer1.Document.Content = ws.GetProductsReport();

To update the app.config file

Note: You need to update the app.config file if you added the Service Reference to the Visual Studio 2010 project in the previous section.
  1. In the Solution Explorer, open the app.config file.
  2. In the tag <binding name = "ServiceSoap"...>, set maxBufferSize and maxReceivedMessageSize to some large number, for example, 200500.
  3. In the next tag <readerQuotas...>, set maxArrayLength to some large number, for example, 60500.

To run the project

Press F5 to run the project.

See Also
Document Web Service
DataSet Web Service


Common Walkthroughs

Common Walkthroughs
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs

Common walkthroughs cover scenarios to introduce the key features of page and section reports. Learn about different page and section report walkthroughs categorized as follows.

Professional
This section contains the walkthroughs explaining features that are part of the ActiveReports Professional Edition.
Export
This section contains the walkthrough that explains how to create a simple custom spreadsheet and save it to an Excel file.
Web
This section contains the walkthroughs that explain how to create a simple web service for each scenario and how to create a Windows client application for each web service.
WPF
This section contains the walkthrough that explains how to use the ActiveReports WPF Viewer in a WPF application project.
Layout
This section contains the walkthroughs that explain how to create different report layouts.
See Also
Walkthroughs


Professional

Professional
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > Professional

This section contains the following walkthroughs that fall under the Professional category.

Creating a Basic End User Designer
This walkthrough demonstrates how to set up a basic end-user report designer on a Windows Forms application.
Customizing the Flash Viewer UI
This walkthrough demonstrates how to customize the look and feel of the Flash Viewer.
Customizing the HTML Viewer UI
This walkthrough demonstrates how to customize the HTML Viewer interface using JQuery methods.
See Also
Common Walkthroughs


Creating a Basic End User Report Designer (Pro Edition)

Creating a Basic End User Report Designer (Pro Edition)
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > Professional > Creating a Basic End User Report Designer (Pro Edition)

This walkthrough illustrates how to set up a basic End-User Report Designer on a Windows Forms application in the Professional Edition of ActiveReports.

At the end of this walkthrough, the End-User Report Designer appears like the following image.
Note: See Adding ActiveReports Controls, if you need help with adding the Designer control or any other ActiveReports controls to your Visual Studio toolbox.

Adding controls to the Form

  1. In a Windows Forms application, select a Form and go to the Properties Window to change the Name property to formDesigner and Text property to ActiveReports.
  2. Resize the Form so that you can accommodate the controls listed in the next step.
  3. From the Visual Studio toolbox, drag the following controls onto the Form in the order listed below. The order is important because some of the controls are placed inside other container controls. Also, set the properties as indicated in the list below.

    Controls Placed on a Form

    Control | Parent | Name | Dock | Property Value
    ToolStripContainer formDesigner toolStripContainer Fill LeftToolStripPanel - Enabled = False
    RightToolStripPanel - Enabled = False
    SplitContainer | toolStripContainer | splitContainer | Fill | FixedPanel = Panel1
    Designer splitContainer.Panel2 arDesigner None Anchor = Top, Bottom, Left, Right
    Resize and move as necessary.
    TabControl splitContainer.Panel2 tabControl None Anchor = Top, Bottom, Left, Right
    Resize and move as necessary.
    ReportExplorer tabControl.tabPage1 arReportExplorer None

    ReportDesigner = arDesigner
    This binds the ActiveReports Designer to the ReportExplorer control.

    Anchor = Top, Bottom, Left, Right
    Resize and move as necessary. You can control the visibility of Report Explorer nodes using VisibleNodes property.
    LayerList tabControl.tabPage2 arLayerList None

    ReportDesigner = arDesigner
    This binds the ActiveReports Designer to the LayerList control.
    Resize and move as necessary.
    PropertyGrid splitContainer.Panel2 arPropertyGrid None Anchor = Top, Bottom, Right
    Resize and move as necessary.
    Toolbox splitContainer.Panel1 arToolbox Fill -

  4. Select arDesigner and in the Properties window go to the PropertyGrid property and select arPropertyGrid. This attaches the Property Grid to the Designer to display properties of the selected item.
  5. Select tabControl and in the Properties window, click the ellipses button in the TabPages property.
  6. In the TabPage Collection Editor dialog that appears, select tabPage1 and change the Text property to Report Explorer.
  7. Select tabPage2 and change its Text property to Layer List.

    The Form now looks like the image below:

Creating a Data toolbox group

Add the following code to create a data group in the toolbox. This code creates a LoadTools method that you can call in the formDesigner_Load event to load the data toolbox group into the toolbox.

The following examples show what the code looks like.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste ABOVE the formDesigner class.
Copy Code
Imports GrapeCity.ActiveReports.Design.Toolbox
Imports GrapeCity.ActiveReports.Design
Visual Basic.NET code. Paste INSIDE the formDesigner class.
Copy Code
Private Sub LoadTools(ByVal arToolbox As Toolbox)
   'Add Data Providers
   Me.arToolbox.AddToolboxItem(New System.Drawing.Design.ToolboxItem(GetType(System.Data.DataSet)), "Data")
   Me.arToolbox.AddToolboxItem(New System.Drawing.Design.ToolboxItem(GetType(System.Data.DataView)), "Data")
   Me.arToolbox.AddToolboxItem(New System.Drawing.Design.ToolboxItem(GetType(System.Data.OleDb.OleDbConnection)), "Data")
   Me.arToolbox.AddToolboxItem(New System.Drawing.Design.ToolboxItem(GetType(System.Data.OleDb.OleDbDataAdapter)), "Data")
   Me.arToolbox.AddToolboxItem(New System.Drawing.Design.ToolboxItem(GetType(System.Data.Odbc.OdbcConnection)), "Data")
   Me.arToolbox.AddToolboxItem(New System.Drawing.Design.ToolboxItem(GetType(System.Data.Odbc.OdbcDataAdapter)), "Data")
   Me.arToolbox.AddToolboxItem(New System.Drawing.Design.ToolboxItem(GetType(System.Data.SqlClient.SqlConnection)), "Data")
   Me.arToolbox.AddToolboxItem(New System.Drawing.Design.ToolboxItem(GetType(System.Data.SqlClient.SqlDataAdapter)), "Data")
End Sub

To write the code in C#

C# code. Paste ABOVE the formDesigner class.
Copy Code
using GrapeCity.ActiveReports.Design.Toolbox;
using GrapeCity.ActiveReports.Design;
C# code. Paste INSIDE the formDesigner class.
Copy Code
private void LoadTools(Toolbox arToolbox)
{
   //Add Data Providers
   this.arToolbox.AddToolboxItem(new System.Drawing.Design.ToolboxItem(typeof(System.Data.DataSet)), "Data");
   this.arToolbox.AddToolboxItem(new System.Drawing.Design.ToolboxItem(typeof(System.Data.DataView)), "Data");
   this.arToolbox.AddToolboxItem(new System.Drawing.Design.ToolboxItem(typeof(System.Data.OleDb.OleDbConnection)), "Data");
   this.arToolbox.AddToolboxItem(new System.Drawing.Design.ToolboxItem(typeof(System.Data.OleDb.OleDbDataAdapter)), "Data");
   this.arToolbox.AddToolboxItem(new System.Drawing.Design.ToolboxItem(typeof(System.Data.Odbc.OdbcConnection)), "Data");
   this.arToolbox.AddToolboxItem(new System.Drawing.Design.ToolboxItem(typeof(System.Data.Odbc.OdbcDataAdapter)), "Data");
   this.arToolbox.AddToolboxItem(new System.Drawing.Design.ToolboxItem(typeof(System.Data.SqlClient.SqlConnection)), "Data");
   this.arToolbox.AddToolboxItem(new System.Drawing.Design.ToolboxItem(typeof(System.Data.SqlClient.SqlDataAdapter)), "Data");
}

Adding an OnExit method

  1. Right-click anywhere on the formDesigner, and select View Code.
  2. In the code view that appears, add the following code to create an OnExit method that you can call from the Exit menu item we create later.

    The following examples show what the code looks like.

    To write the code in Visual Basic.NET
    Visual Basic.NET code. Paste INSIDE the formDesigner class.
    Copy Code
    Private Sub OnExit(ByVal sender As Object, ByVal e As EventArgs)
   MyBase.Close()
End Sub
    To write the code in C#
    C# code. Paste INSIDE the formDesigner class.
    Copy Code
    private void OnExit(object sender, EventArgs e)
{
    Close();
}

Adding code to set up the toolbox, menus, and toolstrips

  1. In the Design view of the form, double-click the title bar on the formDesigner. This creates formDesigner_Load event handling method.
  2. Add code to the handler to:
    • Set up the toolbox
    • Set up the menu and tool strips
    • Add an Exit command to the menu

    The following examples show what the code for the method looks like.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the formDesigner Load event.
    Copy Code
    ' Add controls to the toolbox
LoadTools(arToolbox)
arDesigner.Toolbox = arToolbox

' Add Menu and ToolStrips to the Form
Dim menuStrip As ToolStrip = arDesigner.CreateToolStrips(DesignerToolStrips.Menu)(0)
Dim fileMenu As ToolStripDropDownItem = CType(menuStrip.Items(0), ToolStripDropDownItem)

' Add an Exit command to the File menu
fileMenu.DropDownItems.Add(New ToolStripMenuItem("Exit", Nothing, AddressOf OnExit))

Dim panel As ToolStripPanel = (New ToolStripContainer()).TopToolStripPanel
panel.Join(menuStrip, 0)
panel.Join(arDesigner.CreateToolStrips(DesignerToolStrips.Zoom)(0), 1)
panel.Join(arDesigner.CreateToolStrips(DesignerToolStrips.Undo)(0), 1)
panel.Join(arDesigner.CreateToolStrips(DesignerToolStrips.Edit)(0), 1)
panel.Join(arDesigner.CreateToolStrips(DesignerToolStrips.Report)(0), 1)

panel.Join(arDesigner.CreateToolStrips(DesignerToolStrips.Layout)(0), 2)
panel.Join(arDesigner.CreateToolStrips(DesignerToolStrips.Format)(0), 2)
    To write the code in C#
    C# code. Paste INSIDE the formDesigner Load event.
    Copy Code
    // Add controls to the toolbox
LoadTools(arToolbox);
arDesigner.Toolbox = arToolbox;

// Add Menu and ToolStrip to the Form
ToolStrip menuStrip = arDesigner.CreateToolStrips(DesignerToolStrips.Menu)[0];
ToolStripDropDownItem fileMenu = (ToolStripDropDownItem)menuStrip.Items[0];

// Add an Exit command to the File menu
fileMenu.DropDownItems.Add(new ToolStripMenuItem("Exit", null, this.OnExit));
ToolStripPanel panel = (new ToolStripContainer()).TopToolStripPanel;
panel.Join(menuStrip, 0);
panel.Join(arDesigner.CreateToolStrips(DesignerToolStrips.Zoom)[0], 1);
panel.Join(arDesigner.CreateToolStrips(DesignerToolStrips.Undo)[0], 1);
panel.Join(arDesigner.CreateToolStrips(DesignerToolStrips.Edit)[0], 1);
panel.Join(arDesigner.CreateToolStrips(DesignerToolStrips.Report)[0], 1);

panel.Join(arDesigner.CreateToolStrips(DesignerToolStrips.Layout)[0], 2);
panel.Join(arDesigner.CreateToolStrips(DesignerToolStrips.Format)[0], 2);

Removing Layer List from Section Report

Layers are supported in Page Reports and Rdl Reports, so the Layer List options appear disabled in Section Reports. Follow the steps below to remove the Layer List from Section Report.

  1. In the Code view of formDesigner, add the OnLayoutChanged event handler to modify the report layout.

    To write the code in Visual Basic.NET
    Visual Basic.NET code. Paste INSIDE the formDesigner class.
    Copy Code
    ' Create the event handler

Public Sub New()
InitializeComponent()
AddHandler Me.arDesigner.LayoutChanged, AddressOf OnLayoutChanged
End Sub
    To write the code in C#
    C# code. Paste INSIDE the formDesigner method.
    Copy Code
    // Create the event handler
this.arDesigner.LayoutChanged += new LayoutChangedEventHandler(OnLayoutChanged);

  2. Add the following code to create OnLayoutChanged function. This code creates a method that you can call in the formDesigner_Load event. The following example shows what the code for the method looks like:

    To write the code in Visual Basic.NET
    Visual Basic.NET code. Paste INSIDE the formDesigner class.
    Copy Code
    Private Sub OnLayoutChanged(ByVal sender As System.Object, ByVal e As LayoutChangedArgs) Handles arDesigner.LayoutChanged

End Sub
    To write the code in C#
    C# code. Paste INSIDE the formDesigner class.
    Copy Code
    private void OnLayoutChanged(object sender, LayoutChangedArgs e){}
  3. Go to the OnLayoutChanged function and add the following code to remove the Layer List from Section Report and add it to the Page Report or Rdl Report. The following example shows what the code for the method looks like:

    To write the code in Visual Basic.NET
    Visual Basic.NET code. Paste INSIDE the OnLayoutChanged function.
    Copy Code
    If arDesigner.ReportType = DesignerReportType.Section Then
    tabControl.TabPages.Remove(TabPage1)
    tabControl.TabPages.Remove(TabPage2)
    tabControl.TabPages.Add(TabPage1)
    tabControl.Refresh()
End If
If arDesigner.ReportType = DesignerReportType.Page Then
    tabControl.TabPages.Remove(TabPage1)
    tabControl.TabPages.Remove(TabPage2)
    tabControl.TabPages.Add(TabPage1)
    tabControl.TabPages.Add(TabPage2)
    tabControl.Refresh()
    LoadTools(arToolbox)
    arDesigner.Toolbox = arToolbox
End If
If arDesigner.ReportType = DesignerReportType.Rdl Then
    tabControl.TabPages.Remove(TabPage1)
    tabControl.TabPages.Remove(TabPage2)
    tabControl.TabPages.Add(TabPage1)
    tabControl.TabPages.Add(TabPage2)
    tabControl.Refresh()
End If
    To write the code in C#
    C# code. Paste INSIDE the OnLayoutChanged function.
    Copy Code
    if (arDesigner.ReportType == DesignerReportType.Section)
{
    tabControl.TabPages.Remove(tabPage1);
    tabControl.TabPages.Remove(tabPage2);
    tabControl.TabPages.Add(tabPage1);
    tabControl.Refresh();
}
if (arDesigner.ReportType == DesignerReportType.Page)
{
    tabControl.TabPages.Remove(tabPage1);
    tabControl.TabPages.Remove(tabPage2);
    tabControl.TabPages.Add(tabPage1);
    tabControl.TabPages.Add(tabPage2);
    tabControl.Refresh();
    LoadTools(arToolbox);
    arDesigner.Toolbox = arToolbox;
}
if (arDesigner.ReportType == DesignerReportType.Rdl)
{
    tabControl.TabPages.Remove(tabPage1);
    tabControl.TabPages.Remove(tabPage2);
    tabControl.TabPages.Add(tabPage1);
    tabControl.TabPages.Add(tabPage2);
    tabControl.Refresh();
}
  4. Add the following code in formDesigner Load event to call the OnLayoutChanged function.

    To write the code in Visual Basic.NET
    Visual Basic.NET code. Paste INSIDE the OnLayoutChanged function
    Copy Code
    OnLayoutChanged(Nothing, Nothing)

    To write the code in C#

    C# code. Paste INSIDE the OnLayoutChanged function
    Copy Code
    OnLayoutChanged(null, null);

Viewing the End User Report Designer

  1. Press F5 to run the project. The End User Report Designer opens with a Section Report.
  2. Go to the File menu and select New to open the Create New Report dialog.
  3. From Templates, you can select Page Report or Rdl Report to open in the designer along with its corresponding toolbox controls, Report Explorer and Layer List items.Ok
  4. Go to the File menu again. Notice that an Exit menu item has been added to the listed menu items.

You can also customize the End User Report Designer further by disabling the Section Report tab in the Page or RDL report toolbox. For this and other customizations refer to the End User Designer product sample.

See Also

Concepts

Designer Control (Pro Edition)


Customizing the Flash Viewer UI

Customizing the Flash Viewer UI
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > Professional > Customizing the Flash Viewer UI
Show All Show All
Hide All Hide All

You can customize the Flash Viewer UI, using javascript functions. This walkthrough illustrates how to customize the look and feel of the Flash Viewer.

The walkthrough is split up into the following activities:

  • Adding code to customize the Flash Viewer options
  • Adding code to handle the Flash Viewer events

To follow the steps of this walkthrough, you must first complete the steps on creating an ASP.NET Web site and setting up the FlashViewer, described in the Flash Viewer walkthrough.

To customize the Flash Viewer options

  1. Select the WebViewer on your .aspx page, and in the Properties window, expand the FlashViewerOptions node.
  2. Set the property UseClientApi (FlashViewerOptions) to True (this property is set to False by default).

  3. Declare a variable and attach the FlashViewer by adding the following code onto the .aspx source view.

    Paste the code into .aspx source
    Copy Code
    <script language="javascript" type="text/javascript">
var viewer;

function init() { GrapeCity.ActiveReports.Viewer.OnLoad ("WebViewer1", function() {
  viewer = GrapeCity.ActiveReports.Viewer.Attach("WebViewer1"); });
}
</script>

...

<body onload="return init()">

  4. Drag the Html Input (button) control from the Visual Studio toolbox onto the .aspx design view, containing the WebViewer control.

  5. Double-click the Button control and paste the following code:

    Paste the code into .aspx source
    Copy Code
    <input id="button1" type="button" value="button" onclick="return Button1_onclick()" />

  6. Add the following function for this button:

    Paste the code into .aspx source
    Copy Code
    function Button1_onclick() {
        var zoom = viewer.getZoom();
                alert("Check that zoom property is changed from " + zoom);
                zoom += 0.1;
                viewer.setZoom(zoom);
                alert("to " + zoom);
}
    Note: You can declare a variable and attach the FlashViewer in the event handler directly.
    Paste the code into .aspx source
    Copy Code
    function Button1_onclick()
{
var viewer;
viewer = GrapeCity.ActiveReports.Viewer.Attach("WebViewer1");
...
}

Available Flash Viewer properties

The properties below use a pair of the getter and setter functions, which names are formed as {get|set}<PropertyName>().

Property Name

 Description

CurrentPage

Integer. Gets or sets the page for a currently selected view.

HyperLinkBackColor

String. Gets or sets the background color for all hyperlinks in a document. This value is applied only after a new document is loaded. The format is "#FF0000" (#RRGGBB).
HyperLinkForeColor | String. Gets or sets the color for all hyperlinks in a document. This value is applied only after a new document is loaded. The format is "#FF0000" (#RRGGBB).

HyperLinkUnderline

 Boolean. Gets or sets a value determining whether the text of all hyperlinks in a document is underlined. This value is applied only after a new document is loaded.

SearchResultsBackColor

 String. Gets or sets the background color of the highlighted text when using the Find dialog. The format is "#FF0000" (#RRGGBB).
SearchResultsForeColor | String. Gets or sets the color of the highlighted text when using the Find dialog. The format is "#FF0000" (#RRGGBB).
PaperColor | String. Gets or sets the paper color of the report. The format is "#FF0000" (#RRGGBB).
ShowSplitter

Boolean. Gets or sets a value determining whether to display a splitter. If set to True, the splitter is shown.
TargetView | String. Gets or sets a value that specifies which view - Primary or Secondary, is currently active. If the ShowSplitter property is set to False, then you cannot switch to the Secondary view.
ThemeUrl | String. Gets or sets a value specifying the relative URL of a skin to use on the Flash Viewer.
Zoom | Integer. Gets or sets a value that specifies the zoom level at which to display the report.
TocPanel

Object. Gets the Table of Contents Panel object. This property is read-only.

  • Alignment To align the TOC panel.
  • ShowThumbnails To specify whether to display a pane with thumbnail views of pages.
  • ShowToc To specify whether to display the table of contents pane.
  • Visible To specify whether to display the Table of contents.
  • Width To specify the Table of contents width.
ViewType | String. Gets or sets the current ViewType value.
EventsHandler | Object. Gets or sets the events handler container.

Available Flash Viewer methods

Note: Except for the below mentioned methods, {get|set}<Property Name>() method can be used for all the properties. See Flash Viewer topic for details.
Method Name | Description

LoadDocument(string documentUrl)

Loads the RDF document. You may use an RDF file that resides on a server, RpxHandler, CompiledReportHandler or custom Http handler implementation to provide a streamed document. This method cancels the current document's loading.

Code example

Paste the code into .aspx source
Copy Code
function btnLoadDoc_onclick()
{
    viewer.LoadDocument("RpxHandler/NwindLabels.rpx?&OutputFormat=Rdf3");
}

CancelDocumentLoad()

Cancels the loading of a current document.
Print(PrintOptions options) | Causes the Viewer to wait until all required pages are loaded, displayed in the Print dialog and starts printing. The PrintOptions are similar to the WebViewer.PrintOptions, except that the PageRangesCollection methods are merged into the PrintOptions class.

CreatePrintOptions()

 Creates options for the Print() method.

setViewType(string viewType, int multiPageRows, int multiPageCols)

Specifies the view mode.

Possible values for the first parameter are specified in the ViewType enumeration. The last two parameters are applied for ViewType.MultiPage only.

To handle Flash Viewer Events

  1. Declare a variable, attach the Flash Viewer and add event handlers by adding the following code onto the .aspx source view.
Paste the code into .aspx source
Copy Code
<script language="javascript" type="text/javascript">
var viewer;
function init() {
GrapeCity.ActiveReports.Viewer.OnLoad("WebViewer1", function() {
viewer = GrapeCity.ActiveReports.Viewer.Attach("WebViewer1");
    viewer.setEventsHandler({
       <EVENTS>

    });
});
}
</script>
...

<body onload="return init()">
Note: <EVENTS> are described in detail in the Available events list below.

Available events

Event Description

OnLinkClick(LinkEventArgs)

Specifies the URL value of a linked item or a string. This event is raised when a report object with a hyperlink is clicked; this event overrides the default Hyperlinks behavior that simply opens another browser window. Cancelable.

The event handler receives an argument of type LinkEventArgs containing data related to this event. The handler argument has the field "Link". The field "Link" returns the hyperlink URL value.

Code example
Copy Code
OnLinkClick: function(e)
        {
                alert(e.Link);//specifies url of the link item, string
                  return true;
        }

OnError(ErrorEventArgs)

Fires when an application fires an error or a warning. Use this event to customize FlashViewer error messages and warnings.

The event handler receives an argument of type ErrorEventArgs containing data related to this event. The handler argument has the following fields - "ErrorType" and "Message".

The field "ErrorType" contains the error type value; the field "Message" contains a description of a Flash Viewer problem.

This event allows suppressing any notifications to a user.

Code example
Copy Code
OnError: function(e)
        {
                alert(e.Message);       //error message, string
                alert(e.ErrorType);     //possible types are "Error" and "Warning", string
                return false;
        }
OnLoadProgress(LoadProgressArgs)

Raised during the processing of a report.

The event handler receives an argument of type LoadProgressArgs containing data related to this event. The handler argument has the following fields - "PageCount", "PageNumber" and "State". Return value is ignored in case of this event.

The field "PageCount" returns the total count of report pages.

The field "PageNumber" returns the page number of the processed report.

The field "State" returns the value, indicating the state of the report's processing; the possible values are "Completed", "InProgress" and "Cancelled".

In Progress: Indicates the loading state of the report.

Cancelled: Indicates a states where loading of a report is cancelled.

Completed: Indicates a state where loading of a report is complete.

Code example
Copy Code
OnLoadProgress: function(e)
{
        if(e.State == "InProgress") {
                if(e.PageNumber == 10) {
                        alert("10 pages are loaded");
                }
        }

        if(e.State == "Cancelled"){
                alert("Report processing is cancelled");
        }

        if(e.State == "Completed")// possible value are Completed, InProgress and Cancelled
        {
                alert("Report loading is completed, total page count is" + e.PageCount);
        }

        //return value is ignored in this event
}

OnTargetViewChanging(TargetViewChangeEventArgs)

Raised while a report's view is changing.

The event handler receives an argument of type TargetViewChangedEventArgs containing data related to this event. The handler argument has the following fields - "CurrentView" and "NewView".

The field "CurrentView" returns the currently selected view value.

The field "NewView" returns the newly selected view value.

Code example
Copy Code
OnTargetViewChanging: function(e)
        {
                alert("Currently selected view is " + e.CurrentView);   //gets currently selected view, string
                alert("Newly selected view is " + e.NewView);           //gets newly selected view, string
                return false;                                           //cancelable event
        }

OnToolClick(ToolClickEventArgs)

Raised by clicking the toolbar button. Cancelable.

The event handler receives an argument of type ToolClickEventArgs containing data related to this event. The handler argument has the following field - "Tool".

The field "Tool" returns the name of a clicked button.

Code example
Copy Code
OnToolClick: function(e)
        {
                alert(e.Tool);
                return false;
        }
OnCurrentPageChanged(CurrentPageChangeEventArgs)

Raised each time a current page is changed within the current view programmatically or by any user navigation command. This event is also raised when the current view (primary or secondary) is changed.

The event handler receives an argument of type CurrentPageChangedEventArgs containing data related to this event. The handler argument has the following fields - "PageNumber" and "ViaApi".

The field "PageNumber" contains the 1-based page number. The field "ViaApi" specifies whether the event is raised by setting the page number in the CurrentPage property.
Note: Use the "return true;" value to show that the client side has handled the event. The "return false;" value indicates that the event was not handled.


Customizing the HTML Viewer UI

Customizing the HTML Viewer UI
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > Professional > Customizing the HTML Viewer UI
Show All Show All
Hide All Hide All

You can customize the HTMLViewer interface using JQuery methods. WebViewer control adds JQuery library in page scripts. Use the code in this walkthrough to remove a button from the HTMLViewer toolbar and add a client side PDF export implementation.

This walkthrough is split into the following activities:

  • Loading an ActiveReport to a Visual Studio ASP.NET Web application.
  • Adding the jQuery library to the Web application project.
  • Accessing WebViewer's view model.
  • Removing an existing toolbar button.
  • Adding a function for PDF exporting.
  • Binding the Custom UI to WebViewer's view model.

When you complete this walkthrough you get an HTMLViewer that looks similar to the following at runtime.

To load an ActiveReport in the Web application

  1. Create a new Visual Studio ASP.NET Web application.
  2. In the Default.aspx that gets created, go to the Visual Studio toolbox ActiveReports 10 Page Report tab and drag a WebViewer control onto the Design view.
  3. Load the report generated at the end of the Single Layout Reports walkthrough.
    Note: You may load any report, section or page in the HTMLViewer. See Getting Started with the Web Viewer for information on loading a report.

To add the jQuery library to the Web application project

Follow the steps below to add the jQuery library to your Web application project.

  1. In the Source view of the Default.aspx file, add the following code.
    Add this code after the <head> tag
    Copy Code
    <script src="https://code.jquery.com/jquery-2.1.4.min.js"></script>
  2. In the Source view of the Default.aspx file, add the following code.
    Add this code before the </script> tag
    Copy Code
    var clientID = ...;
$(document).ready(function ()
{
$('#' + clientID).on('loaded', viewer_loaded);
});

To access the WebViewer view model

The HTML Web Viewer is created using the MVVM pattern that provides a view model which does not depend on the UI. The code can access the Viewer's view model and bind the custom UI to it by using well-documented properties and methods. For MVVM support, the code can use knockout.js which is the standard MVVM library for JavaScript. Knockout.js provides declarative bindings, observable objects and collections in HTML markup. See Using Javascript with the HTML Viewerfor more information.

Follow the steps below to access the ViewModel.

  1. In the Source view of the Default.aspx file, add a <script> tag.
    Add a <script> tag in <Head> tag
    Copy Code

    <script language="javascript" type="text/javascript"></script>
  2. Add the following Javascript code inside the document_onload event handler to bind WebViewer's Loaded event to client side viewer_loaded event:
    Paste the code into .aspx source
    Copy Code
    <script language="javascript" type="text/javascript">
    function viewer_loaded()
    {
    };
    var clientID = ...;
    $(document).ready(function () {
      $('#' + clientID).on('loaded', viewer_loaded);
    });
    </script>

    <body onload="return document_onload()">
  3. Add the following Javascript code inside the viewer_loaded event handler to access WebViewer's view model:
    Paste the code into .aspx source
    Copy Code
    var viewModel = GetViewModel('WebViewer1');
  4. Add the following Javascript code inside the document_onload event handler to bind WebViewer's Loaded event to client side viewer_loaded event:
    Paste the code into .aspx source
    Copy Code
    $('#WebViewer1').bind('loaded', viewer_loaded);

To remove a button from the WebViewer toolbar

In the Source view of the Default.aspx file, add the following Javascript code inside the viewer_loaded event handler to access the WebViewer toolbar and remove the Next Page button from the toolbar:

Paste the code into .aspx source
Copy Code
var toolbar = $('#WebViewer1').find('.arvToolBar');
toolbar.find('.btnNext').remove();

Note: In order to access the child elements of the WebViewer toolbar you need their css class names. Following is a list for reference:

Toolbar Child Elements

Toggle Sidebar button: btnToggleSidebar
Find button: btnFind
First page button: btnFirst
Previous page button: btnPrev
Page label: toolbarLabel
Page number input box: toolbarInput
Next page button: btnNext
Last page button: btnLast
Back to parent report button: btnBack

To add a function for exporting to PDF

The steps below illustrate how to build a custom UI.

  1. In the Source view of the Default.aspx file, add following Javascript code inside <script> tag to create a function. This function accesses the view model and exports the report in PDF format :
    Paste the code into .aspx source
    Copy Code
    function exportPDF()
    {

        var viewModel = GetViewModel('WebViewer1');

        if (viewModel.PageLoaded())
        {
            viewModel.Export(ExportType.Pdf, function (uri)
            {
                window.location = uri;
            }, true);
        }
    }
  2. In the Source view of the Default.aspx file, add the following Javascript code inside <form> tag to add a button on a custom toolbar. This button is enabled once the report is loaded and calls the exportPDF() function at runtime:
    Paste the code into .aspx source
    Copy Code

    <div id="customToolbar" style = "display:inline">
    <button data-bind='enable: PageLoaded, click: exportPDF' style=" width: 105px; font-size: medium; height: 22px;">Export</button>
    </div>
  3. In the Source view of the Default.aspx file, add the following Javascript code inside the viewer_loaded event handler to attach the custom toolbar with the built-in toolbar:
    Paste the code into .aspx source
    Copy Code

    $('#customToolbar').appendTo(toolbar);

To bind the custom UI to the WebViewer view model and run the application

  1. Add the following Javascript code inside the viewer_loaded event handler to bind the custom UI to WebViewer view model:
    Paste the code into .aspx source
    Copy Code
    ko.applyBindings(viewModel, document.getElementById("customToolbar"));
  2. Press F5 to run the application.
Note: Replace 'WebViewer1' in the code snippets above, with the actual ID of the WebViewer control in your application.
See Also
Walkthroughs

Getting Started

Using the HTML Viewer
Using Javascript with the HTML Viewer


Export

Export
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > Export

This section contains the following walkthroughs that fall under the Export category.

Basic Spreadsheet with SpreadBuilder
This walkthrough demonstrates how to create a simple custom spreadsheet and save it to an Excel file.
See Also
Common Walkthroughs


Basic Spreadsheet with SpreadBuilder

Basic Spreadsheet with SpreadBuilder
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > Export > Basic Spreadsheet with SpreadBuilder
Show All Show All
Hide All Hide All

Included with the ActiveReports Excel export filter is the SpreadBuilder API. With this utility, you can create Excel spreadsheets cell by cell for maximum control. This walkthrough illustrates how to create a simple custom spreadsheet and save it to an Excel file.

This walkthrough is split into the following activities:

  • Adding an ActiveReport to your project
  • Adding an GrapeCity.ActiveReports.Export.Excel.v10 assembly reference
  • Creating a Workbook using code
  • Viewing the Excel File

When you have completed this walkthrough, a custom Excel file like the following is created in the Bin/Debug subfolder of your project's folder.

To add an GrapeCity.ActiveReports.Export.Excel.v10 assembly reference to your project

  1. Create a new Visual Studio project.
  2. From the Visual Studio Project menu, select Add Reference.
  3. In the Add Reference window that appears, select GrapeCity.ActiveReports.Export.Excel.v10 assembly reference and click OK.
    Note: In ActiveReports, by default, the assemblies are located in the ...\Common Files\GrapeCity\ActiveReports 10 folder.

To add code to create a workbook

Double-click the title bar of the Windows Form to create an event-handling method for the Form_Load event. Add code to the handler to:

  • Create a Workbook, and add a sheet to the Workbook's Sheets collection
  • Set properties on columns and rows in the sheet
  • Set values of cells in the sheet
  • Use the Save method to create an Excel file

The following example shows what the code for the method looks like.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste inside the form Load event.
Copy Code
'Create a Workbook and add a sheet to its Sheets collection
Dim sb As New GrapeCity.SpreadBuilder.Workbook()
sb.Sheets.AddNew()

'Set up properties and values for columns, rows, and cells as desired
With sb.Sheets(0)
   .Name = "Customer Call List" 'sets the name of the sheet
   .Columns(0).Width = 2 * 1440 'sets the width of the 1st column
   .Columns(1).Width = 1440
   .Columns(2).Width = 1440
   .Rows(0).Height = 1440 / 4

'Header row
    .Cell(0, 0).SetValue("Company Name")
    .Cell(0, 0).FontBold = True
    .Cell(0, 1).SetValue("Contact Name")
    .Cell(0, 1).FontBold = True
    .Cell(0, 2).SetValue("Phone")
    .Cell(0, 2).FontBold = True

'First row of data
    .Cell(1, 0).SetValue("GrapeCity")
    .Cell(1, 1).SetValue("Mortimer")
    .Cell(1, 2).SetValue("(425) 880-2601")
End With

'Save the Workbook to an Excel file
sb.Save(Application.StartupPath & "\x.xls")
MessageBox.Show("Your Spreadsheet has been saved to " & Application.StartupPath & "\x.xls")

To write the code in C#

C# code. Paste inside the form Load event.
Copy Code
//Create a Workbook and add a sheet to its Sheets collection
GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
sb.Sheets.AddNew();

//Set up properties and values for columns, rows and cells as desired
sb.Sheets[0].Name = "Customer Call List";
sb.Sheets[0].Columns(0).Width = 2 * 1440;
sb.Sheets[0].Columns(1).Width = 1440;
sb.Sheets[0].Columns(2).Width = 1440;
sb.Sheets[0].Rows(0).Height = 1440/4;

//Header row
sb.Sheets[0].Cell(0,0).SetValue("Company Name");
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
sb.Sheets[0].Cell(0,1).FontBold = true;
sb.Sheets[0].Cell(0,2).SetValue("Phone");
sb.Sheets[0].Cell(0,2).FontBold = true;

//First row of data
sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
sb.Sheets[0].Cell(1,2).SetValue("(425) 880-2601");

//Save the Workbook to an Excel file
sb.Save (Application.StartupPath + @"\x.xls");
MessageBox.Show("Your Spreadsheet has been saved to " + Application.StartupPath + @"\x.xls");

To view the Excel File

  1. Press F5 to run the project. A message box informs you of the exact location of the exported x.xls file.
  2. Navigate to the Bin/Debug subfolder of your project's folder and open the XLS file.
See Also
Section Report Walkthroughs
Walkthroughs


Web

Web
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > Web

This section contains the following walkthroughs that fall under the Web category.

DataSet Web Service
This walkthrough describes how to set up a simple web service that returns a dataset.
DataSet Windows Application
This walkthrough describes how to set up a Windows client application for the dataset Web Service.
Important: In order to consume Web services in your Windows applications, you must set permissions to allow the ASP.NET user to consume the services. Ask your server administrator for help with this.
See Also
Common Walkthroughs


DataSet Web Service

DataSet Web Service
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > Web > DataSet Web Service
Show All Show All
Hide All Hide All

With ASP.NET, you can set up a Web Service that returns a dataset to use in ActiveReports. This walkthrough illustrates how to create one.

This walkthrough is split into the following activities:

  • Creating an ASP.NET Web Service project
  • Adding code to create the Web method
  • Testing the Web service
  • Publishing the Web service
  • Creating a virtual directory in IIS
Note: For the information on how to connect your report to data and how to create the report layout, please see Single Layout Reports (for a page report) or Basic Data Bound Reports (for a section report).

To create an ASP.NET Web Service project

  1. From the File menu, select New Project.
  2. In the New Project dialog that appears, select ASP.NET Web Application to create a empty web application.
  3. Change the name of the project.
  4. Click OK to open the new project in Visual Studio.

To create the Web Method

  1. From the Project menu, select Add New Item.
  2. In the Add New Item dialog that appears, select Web Service (asmx) and change the name of the web service.

In the WebService, replace the existing <WebMethod()> _ and HelloWorld function with code like the following.

To write the code in Visual Basic.NET

Visual Basic.NET code. Paste OVER the existing WebMethod.
Copy Code
Private connString As String
<WebMethod(Description:="Returns a DataSet containing all Products")> _
Public Function GetProduct() As Data.DataSet
connString = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Users\[User Name]\Documents\GrapeCity Samples\ActiveReports 10\Data\nwind.mdb"
Dim adapter As New Data.OleDb.OleDbDataAdapter("select * from products", connString)
Dim ds As New Data.DataSet()
adapter.Fill(ds, "Products")
Return ds
End Function

To write the code in C#

C# code. Paste OVER the existing WebMethod.
Copy Code
private static string connString = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source = C:\\Users\\[User Name]\\Documents\\GrapeCity Samples\\ActiveReports 10\\Data\\nwind.mdb";
[WebMethod(Description="Returns a DataSet containing all Products")]
public Data.DataSet GetProduct()
{
   System.Data.OleDb.OleDbDataAdapter adapter;
   System.Data.DataSet ds;
   adapter = new System.Data.OleDb.OleDbDataAdapter("select * from products", connString);
   ds = new System.Data.DataSet();
   adapter.Fill(ds, "Products");
   return ds;
}

To test the Web Service

  1. Press F5 to run the project.
  2. If the Debugging Not Enabled dialog appears, select the option that enables debugging and click OK to continue.
  3. In the list of supported operations, click the GetProduct link. (The description string from the code above appears below the link.)
  4. Click the Invoke button to test the Web Service operation.
  5. If the test is successful, a valid XML schema of the Northwind products table displays in a new browser window.
  6. Copy the URL from the browser for use in the Web Reference of your DataSet Windows Application.

To publish the Web Service

  1. In the Solution Explorer, right-click the project name and select Publish.
  2. In the Publish Web window that appears, select Custom option to create a custom profile and click OK.
  3. Enter localhost in the Server field and "SiteName"/WebServiceName in the Site name field.
    Note: Get the SiteName from the Internet Information Services Manager.
  4. Click the Publish button.

To check the configuration in IIS

  1. Open Internet Information Services Manager.
  2. In the Internet Information Services Manager window that appears, expand the tree view in the left pane until you see the Web Service you had added in the steps above.
  3. Right-click the Web Service select Manage Application then Browse.
  4. In the browser that appears, go to the Address bar to add WebServiceName.asmx to the url and press Enter.

For information on consuming the DataSet Web Service in an ActiveReport, see DataSet Windows Application.

See Also
DataSet Windows Application
Document Web Service


DataSet Windows Application

DataSet Windows Application
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > Web > DataSet Windows Application
Show All Show All
Hide All Hide All

You can use a Web Service that returns a dataset as the data source for your reports in Windows applications. This walkthrough illustrates how to create a Windows client application that uses the dataset Web Service as the data source for an ActiveReports.

This walkthrough builds on the DataSet Web Service walkthrough and is split up into the following activities:

  • Adding a reference to a Web service to the project
  • Setting the report data source to the one returned by the Web service
Note: For the information on how to connect your report to data and how to create the report layout, please see Single Layout Reports (for a page report) or Basic Data Bound Reports (for a section report).

To add a reference to a web service to the project

To add a reference to a web service in Visual Studio that is compatible with .NET Framework 2.0 Web service

  1. From the Project menu, select Add Service Reference.
  2. In the Add Service Reference window that appears, click Advanced button.
  3. In the Service Reference Settings window that appears, click Add Web Reference button.
  4. In the Add Web Reference window that appears, click the Web services on the local machine link.
  5. Click the link to the virtual directory you created in the previous walkthrough. You can get the address by running the project from the previous walkthrough and copying the url from the address in the browser. (It will look something like http://localhost:####/DataSetWS/Service.asmx where #### is the port number.)
  6. Click the Go button, and then click the Add Reference button when the Web Service is recognized.

To add a reference to a web service in Visual Studio

  1. From the Project menu, select Add Service Reference.
  2. In the Add Service Reference window that appears, type in the address of the virtual directory you created in the previous walkthrough. You can get the address by running the project from the previous walkthrough and copying the url from the address in the browser. (It will look something like http://localhost:####/DataSetWS/Service.asmx where #### is the port number.)
  3. Click the Go button, and then click the OK button when the Web Service is recognized.

To set the report data source to the one returned by the Web service

To set the report data source (for Visual Studio 2010 compatible with .NET Framework 2.0 Web service)

  1. Double-click the gray area below the report. This creates an event-handling method for the ReportStart event.
  2. Add code to the handler to use the web service dataset in the report.

    The following example shows what the code for the method looks like.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the ReportStart event
    Copy Code
    Dim ws As New localhost.Service
Dim ds As DataSet()= ws.GetProduct()
Me.DataSource = ds
Me.DataMember = "Products"

    To write the code in C#

    C# code. Paste INSIDE the ReportStart event.
    Copy Code
    localhost.DataSetWS ws = new localhost.Service;
DataSet ds = ws.GetProduct();
this.DataSource = ds;
this.DataMember = "Products";

To set the report data source

  1. Double-click the gray area below the report. This creates an event-handling method for the ReportStart event.
  2. Add code to the handler to use the web service dataset in the report.

    The following example shows what the code for the method looks like.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Paste INSIDE the ReportStart event.
    Copy Code
    Dim ws As New ServiceReference1.ServiceSoapClient()
Dim ds As DataSet = ws.GetProduct()
Me.DataSource = ds
Me.DataMember = "Products"

    To write the code in C#

    C# code. Paste INSIDE the ReportStart event.
    Copy Code
    ServiceReference1.ServiceSoapClient ws = new ServiceReference1.ServiceSoapClient();
DataSet ds = ws.GetProduct();
this.DataSource = ds;
this.DataMember = "Products";

To update the app.config file

Note: You need to update the app.config file if you added the Service Reference to the Visual Studio 2010 project in the previous section.
  1. In the Solution Explorer, open the app.config file.
  2. In the tag <binding name = "ServiceSoap"...>, set maxBufferSize and maxReceivedMessageSize to some large number, for example, 200500.
  3. In the next tag <readerQuotas...>, set maxArrayLength to some large number, for example, 60500.


WPF

WPF
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > WPF

This section contains the following walkthroughs that fall under the WPF category.

WPF Viewer
This walkthrough explains how to use the ActiveReports WPF Viewer in a WPF application project.
See Also
Common Walkthroughs


WPF Viewer

WPF Viewer
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > WPF > WPF Viewer
Show All Show All
Hide All Hide All

The ActiveReports WPF Viewer is a custom control that allows to easily view section, RDL and page report layouts.

This walkthrough is split up into the following activities.

  • Creating a WPF Application project in Visual Studio
  • Adding the ActiveReports WPF Viewer control to the xaml page
  • Loading a report to the ActiveReports WPF Viewer
  • Previewing a report
  • Customizing the ActiveReports WPF Viewer

When you have completed this walkthrough, you will have the ActiveReports WPF Viewer displaying a report that looks similar to the following.

To create a WPF application in Visual Studio

  1. On the Visual Studio File menu, click New Project.
  2. In the New Project dialog that appears, select WPF Application in the list of templates.
  3. Specify the name and location of the project and then сlick the OK button.
  4. In the Visual Studio Solution Explorer, right-click YourProject and select Add, then New Item.
  5. In the Add New Item dialog that appears, select the ActiveReports 10 Page Report and create the rptSingleLayout report as described in the Single Layout Reports walkthrough.

To add the WPF Viewer control

  1. In Solution Explorer, open MainWindow.xaml.
  2. From the Toolbox ActiveReports 10 tab, drag the Viewer control and drop it on the design view of MainWindow.xaml.
  3. In the Properties window, set the properties of the Viewer control as follows.
    Property Name | Property Value
    HorizontalAlignment | Stretch
    VerticalAlignment | Stretch
    Margin | 0
  4. In the Properties window, rename the Viewer control to viewer1.

To load a report to the WPF Viewer

  1. In the Solution Explorer, select the rptSingleLayout report you have created.
  2. In the Properties window, set Copy to Output Directory to Copy Always.
  3. On MainWindow.xaml, with the viewer selected, go to the Properties window and double click the Loaded event.
  4. In the MainWindow code view that appears, add code like the following to the viewer1_loaded event to bind the report to the viewer. This code shows an .rdlx report being loaded but you can use an .rpx report as well.
    Visual Basic.NET code. Paste INSIDE the viewer1_Loaded event in MainWindow.xaml.vb.
    Copy Code
    Viewer1.LoadDocument("rptSingleLayout.rdlx")
    C# code. Paste INSIDE the viewer1_Loaded event in MainWindow.xaml.cs.
    Copy Code
    viewer1.LoadDocument("rptSingleLayout.rdlx");
Note: For an example of other ways to bind a report to the WPF Viewer, see the LoadDocument method in the Class Library documentation.
Note: To avoid evaluation banners appearing at runtime, license your ActiveReports WPF Application project. You can find information on licensing in License Your ActiveReports.

To view the report

Press F5 to run the project. The WPF Viewer displaying a report appears.

To customize the WPF Viewer

The ActiveReports WPF Viewer is a customizable control. You can easily change the look of the WPF Viewer and its elements, such as the error panel, search panel, sidebar and toolbar by modifying properties in the default WPF Viewer template (DefaultWPFiewerTemplates.xaml).

To add the customization template to the WPF project

  1. Open your WPF project.
  2. In Solution Explorer, select the YourProjectName node.
  3. On the Visual Studio Project menu, click Add Existing Item.
  4. In the dialog that appears, locate and select DefaultWPFViewerTemplates.xaml and click OK. You can find DefaultWPFViewerTemplates.xaml at [systemdrive]\Program Files\GrapeCity\ActiveReports 10\Deployment\WPF\Templates folder (on a 64-bit Windows operating system, this file is located in [systemdrive]\Program Files (x86)\GrapeCity\ActiveReports 10\Deployment\WPF\Templates).
  5. On MainWindow.xaml before the opening <Grid> tag, add the following code.
    Paste to the XAML view of MainWindow.xaml before the opening <Grid> tag
    Copy Code
    <Window.Resources>
<ResourceDictionary Source="DefaultWPFViewerTemplates.xaml" />
</Window.Resources>

To customize the WPF Viewer sidebar

  1. In Solution Explorer, double-click DefaultWPFViewerTemplates.xaml.
  2. In the file that opens, search for "thumbnails tab".
  3. In the GroupBox Header property of <!-- thumbnails tab -->, remove "{Binding Source.ThumbnailsPane.Text}" and type "THUMBNAILS".
  4. Search for "TabControl x:Name="Sidebar".
  5. Add Background="Yellow" after TabControl x:Name="Sidebar".
  6. Press F5 to see the customized viewer sidebar.

To add a customized button to the WPF Viewer toolbar

  1. In Solution Explorer, select the YourProjectName node.
  2. On the Visual Studio Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select Class, rename it to MyCommand and click Add.
  4. In the MyCommand.cs/vb that opens, add the following code to implement a command.

    To write the code in Visual Basic.NET

    Visual Basic.NET code. Add to MyCommand.vb
    Copy Code
    Implements ICommand
Public Function CanExecute(ByVal parameter As Object) As Boolean Implements System.Windows.Input.ICommand.CanExecute
    Return True
End Function

Public Event CanExecuteChanged(ByVal sender As Object, ByVal e As System.EventArgs) Implements System.Windows.Input.ICommand.CanExecuteChanged

Public Sub Execute(ByVal parameter As Object) Implements System.Windows.Input.ICommand.Execute
    MessageBox.Show("GrapeCity is the world's largest component vendor.", "About Us", MessageBoxButton.OK)
End Sub

    To write the code in C#

    C# code. Add after the statement using System.Text;
    Copy Code
    using System.Windows.Input;
using System.Windows;
    C# code. Add to MyCommand.cs
    Copy Code
    public class MyCommand : ICommand
    {
        public bool CanExecute(object parameter)
        {
            return true;
        }

        public void Execute(object parameter)
        {
            MessageBox.Show("GrapeCity is the world's largest component vendor.", "About Us", MessageBoxButton.OK);
        }

        public event EventHandler CanExecuteChanged;
    }
  5. In Solution Explorer, double-click DefaultWpfViewerTemplates.xaml.
  6. In the file that opens, add the following code.
    XML code. Add to DefaultWpfViewerTemplates.xaml
    Copy Code
    <ResourceDictionary>
 ...
xmlns:YourProjectName="clr-namespace:YourProjectName">
<YourProjectName:MyCommand x:Key="MyCommand" />
...
</ResourceDictionary>

  7. In the same file, add the following code to add a button.
    XML code. Add to DefaultWpfViewerTemplates.xaml before the closing Toolbar tag
    Copy Code
    <Button Command="{StaticResource MyCommand}" Content="About Us" />
  8. Press F5 to see the new customized button About Us in the Viewer toolbar.

To remove the Refresh button from the WPF Viewer toolbar

  1. In Solution Explorer, double-click DefaultWpfViewerTemplates.xaml.
  2. In the file that opens, search for "<!--Refresh btn-->".
  3. Replace the existing content in Visiblity="..." with the following.
    XML code. Add to DefaultWpfViewerTemplates.xaml
    Copy Code
    <Button Command=... Visibility="Collapsed">
See Also

Getting Started

WPF Viewer

Page Report Walkthroughs

Single Layout Reports


Layout

Layout
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > Layout

This section contains the following walkthroughs that fall under the layout category.

Creating a report using Report Parts
This walkthrough explains how to create reports using report parts.


Creating a report using Report Parts

Creating a report using Report Parts
ActiveReports 10 > ActiveReports User Guide > Samples and Walkthroughs > Walkthroughs > Common Walkthroughs > Layout > Creating a report using Report Parts

The walkthrough illustrates a step-by-step implementation for creating a report using Report Parts to display annual sales of an organization.

The walkthrough is spilt into the following activities:

  • Creating an ActiveReports project in Visual Studio
  • Creating a layout for the report
  • Enhancing the appearance of the report
  • Viewing the report
Note:
  • This walkthrough uses the SalesReport.rdlx report file. By default, in ActiveReports, the SalesReport.rdlx file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Reports Gallery\C#\Reports\Page Report\Other.
  • Although this walkthrough uses Page reports, you can also implement report parts in RDL and Section reports.

When you complete this walkthrough, you will have a layout that looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To create an ActiveReports project in Visual Studio

  1. Create a new Visual Studio project.
  2. In the New Project dialog that appears, select ActiveReports 10 Page Report Application and in the Name field, name the file as rptReportParts.
  3. Click OK to create a new ActiveReports 10 Page Report Application. By default a Page report is added to the project.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To create a layout for the report

  1. Select PageReport1.rdlx from the Solution Explorer.
  2. Open the Reports Library window. For more information on how to open the Reports Library window, see Show or Hide the Reports Library.
  3. To add a report part from the Reports Library window, right-click the Library node and select Add.
  4. In the Open dialog that appears, navigate through the GrapeCity Samples folder hierarchy and select Sales Report.rdlx. Controls from Sales Report.rdlx are added as Report parts to your Report Library 10 window.
  5. Drag and drop the salesOverTime chart control from the Reports Library window onto the design surface. The report part is added to your report along with its data sources, data sets and parameters.
  6. Drag and drop the Image1 image from the Reports Library window onto the design surface.
  7. From the Visual Studio toolbox, drag and drop a Table data region onto the design surface.
  8. Hover over TextBox4 to reveal the field selection adorner, click it to display a list of available fields, and select the SaleDate field.
  9. Hover over TextBox5 to reveal the field selection adorner, click it to display a list of available fields, and select the Quantity field.
  10. Hover over TextBox6 to reveal the field selection adorner, click it to display a list of available fields, and select the Profit field.
  11. From the Visual Studio toolbox, drag and drop a Textbox control onto the design surface.
  12. Select the Textbox to view its properties in the Properties window and enter the text Annual Sales Report (2004-2005) in the Value property.

To enhance the appearance of the report

When you preview the report at this point, you will notice the data from the fields is displayed in the Table data region. Let us now work on the report appearance to further enhance the layout.

  1. From the designer, select the Image control and then go to Properties Window to set the following properties.
    Property Name | Property Value
    Location | 0.095in, 0.156in
    Size | 1.3in, 1.1in
  2. From the designer, select TextBox10 and then go to Properties Window to set the following properties.
    Property Name | Property Value
    Location | 1.5in, 0.5in
    Size | 4.3in, 0.3in
    BorderStyle | Solid
    FontWeight | Bold
    TextAlign | Center
    FontSize | 16pt
  3. From the designer, select the Chart control and then go to Properties Window to set the following properties.
    Property Name | Property Value
    Location | 0.1in, 1.3in
    Size | 6in, 4.125in
  4. From the designer, select the Table control and then go to Properties Window to set the following properties.
    Property Name | Property Value
    Location | 1.25in, 5.5in
    Size | 4.25in, 1in
    FixedSize | 4.25in, 3.35in
    RepeatHeaderOnNewPage | True
  5. In the Table data region, select the textbox that contains the following fields and go to the Properties window to set the following properties:
    Cell | Property Name | Property Value
    Sale Date | BackgroundColor | LightCyan
    BorderStyle | Solid
    FontWeight | Bold
    TextAlign | Center
    =[SaleDate] | BorderStyle | Solid
    TextAlign | Center
    Quantity | BackgroundColor | LightCyan
    BorderStyle | Solid
    FontWeight | Bold
    TextAlign | Center
    =[Quantity] | BorderStyle | Solid
    TextAlign | Center
    Profit | BackgroundColor | LightCyan
    BorderStyle | Solid
    FontWeight | Bold
    TextAlign | Center
    =[Profit] | BorderStyle | Solid
    TextAlign | Center
    Format | Currency

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.

See Also
Report Parts


Troubleshooting

Troubleshooting
ActiveReports 10 > ActiveReports User Guide > Troubleshooting
Show All Show All
Hide All Hide All

If you run into an issue while using ActiveReports, you will probably find the solution within this section. Click any short description below to drop down the symptoms, cause, and solution. Or click a link to another section of the troubleshooting guide.

General Troubleshooting

References missing from Visual Studio Add Reference dialog

Symptoms: When you try to add references to your project, only a few of the ActiveReports references are available.

Cause: The project's target framework is set to an old version of the .NET framework that does not support the new assemblies.

Solution:

  1. In the Solution Explorer, right click the project and choose Properties.
  2. On the Application tab in C# projects (or the Compile tab, then the Advanced Compile Options button in Visual Basic projects), drop down the Target framework box and select .NET Framework 4.0.

Errors after installing a new build

Symptoms: When you open a project created with a previous build of ActiveReports after installing a new build, there are errors related to being unable to find the previous build.

Cause: Visual Studio has a property on references called Specific Version. If this property is set to True, the project looks for the specific version that you had installed when you created the report, and throws errors when it cannot find it.

Solution: For each of the ActiveReports references in the Solution Explorer, select the reference and change the Specific Version property to False in the Properties Window.

The project does not work if Integrated Managed Pipeline Mode is enabled

Symptoms: The web project does not work in the application pool if Integrated Managed Pipeline Mode is enabled.

Cause: The application configuration is incorrect for being used in Integrated mode.

Solution: Migrate the application configuration. Here is a sample command.

Paste the following on the command line.
Copy Code
"%SystemRoot%\system32\inetsrv\appcmd migrate config YourWebSite/"

GrapeCity.ActiveReports.Interop64.v10.dll is not available in the default "Add Reference" dialog

Symptoms: The GrapeCity.ActiveReports.Interop64.v10.dll is not available in the default "Add Reference" dialog.

Cause: The GrapeCity.ActiveReports.Interop64.v10.dll is located in the distribution folder.

Solution: The GrapeCity.ActiveReports.Interop64.v10.dll is located in C:\Program Files (x86)\Common Files\GrapeCity\ActiveReports 10\redist.

GrapeCity.ActiveReports.Extensiblity.v10.dll is added to the list of unused dlls in Visual Studio

Symptoms: GrapeCity.ActiveReports.Extensiblity.v10.dll is added to the references folder when the viewer is dragged and dropped on the form, however it is present in the list of unused dll in Visual Studio.

Cause: GrapeCity.ActiveReports.Extensiblity.v10.dll is used internally for certain features in ActiveReports and is present in the Global Assembly Cache. Therefore, Visual Studio can resolve the dependency and cannot find the direct references due to which it gets listed as a unused dll in Visual Studio.

Reports are not associated with the designer in Visual Studio when adding ActiveReports to a TFS-bound project

Symptoms: When adding ActiveReports to a Web site project that is bound to TFS (where reports are added to the App_Code folder), the report does not open in the designer in Visual Studio.

Cause: The FileAttributes.xml file that contains attribute information to associate ActiveReports files with the Designer is usually loaded and maintained in memory when a new ActiveReports file is added. However, if a Web site is bound to TFS, the FileAttributes.xml file is not maintained in memory. As a result, Visual Studio treats all the newly added files as normal code files.

Solution: Add the newly added reports to FileAttributes.xml manually.

  1. From the Website menu, select Add New Item.
  2. Select ActiveReports 10 Section Report (code-based) and click OK.
  3. Close the project.
  4. From Windows Explorer, open the FileAttributes.xml file in an editor and add the new ActiveReports file, setting the subtype to Component, using code like the following.

    Note: The FileAttributes.xml is located at C:\Documents and Settings\[username]\Local Settings\Application Data\Microsoft\WebsiteCache\[WebSite1]\ (Windows XP), or at C:\Users\[username]\AppData\Local\Microsoft\WebsiteCache\[WebSite1]\ (Windows 7).
    XML code. Paste inside FileAttributes.xml
    Copy Code
    <?xml version="1.0" encoding="utf-16" ?>
<DesignTimeData>
   <File RelativeUrl="App_Code/NewActiveReport1.cs" subtype="Component" />
   <File RelativeUrl="Default.aspx.cs" subtype="ASPXCodeBehind" codebehindowner="Default.aspx" />
   <File RelativeUrl="Default.aspx" subtype="ASPXCodeBehind" />
</DesignTimeData>
  5. Save the FileAttributes.xml file.
  6. Reopen the Web site project.

The SystemNotSupportedException occurs when running ActiveReports with scripts on .NET Framework 4.0

Symptoms: The SystemNotSupportedException occurs when running ActiveReports with scripts on .NET Framework 4.0.

Cause: This exception occurs because of the CAS policy, which is obsolete in the .NET Framework 4.0.

Solution: To resolve this issue, the configuration file needs to be updated. To do this, in the Solution Explorer, open the app.config file (for Windows Forms applications) or the Web.config file (for ASP.NET Web applications) and add the following code.

(Windows Forms Applications) XML code. Paste inside the app.config file
Copy Code
<configuration>
  <runtime>
    <NetFx40_LegacySecurityPolicy enabled="true"/>
  </runtime>
</configuration>
(ASP.NET Web Applications) XML code. Paste inside the Web.config file
Copy Code
<system.web>
   <trust legacyCasModel="true"/>
</system.web>

Error occurs when running an MVC 4 or higher application with ActiveReports and scripts on .NET Framework 4.0

Symptoms: When running an MVC application with ActiveReports and scripts on .NET Framework 4.0, an error occurs with the following message "Dynamic Operations can only be performed in homogenous AppDomain".

Cause: This exception occurs because of the CAS policy, which is obsolete in the .NET Framework 4.0.

Solution: To resolve this issue, you need to set the EnableScriptDebugging property of the Section report to False.

Microsoft Access OLE DB provider in a 64-bit system

Symptoms: Microsoft Access OLE DB provider, Microsoft.Jet.OLEDB.4.0 does not work on a 64-bit system.

Cause: In Visual Studio 2010, by default, projects are set to use 32 bit or 64 bit, depending on the environment on which they are run. The Microsoft Access OLE DB provider, Microsoft.Jet.OLEDB.4.0, is not compatible with 64 bit, so it fails with Visual Studio 2010 on a 64-bit system.

Solution: To avoid this situation, change the project settings to use only 32 bit.

  1. With the project open in Visual Studio, from the Project menu, select Project Properties.
  2. In the page that appears, select the Compile tab in a VB project, or the Build tab in a C# project.
  3. Scroll to the bottom of the page and click the Advanced Compile Options button in VB, or skip this step in C#.
  4. Drop down the Target CPU list in VB, or Platform target in C#, (set to use AnyCPU by default) and select x86.
  5. Click OK to save the changes, or skip this step in C#.

The printing thread dies before the report finishes printing

Symptoms: The printing thread dies before the report is printed.

Cause: If printing is done in a separate thread and the application is shut down right after the print call, the separate thread dies before the report is printed.

Solution: Set the usePrintingThread parameter of the Print() method to False to keep the printing on the same thread. This applies to all Page reports, RDL reports and Section reports.

  1. In the project where you call the Print method, add a reference to the GrapeCity.ActiveReports.Viewer.Win.v10 assembly.
  2. At the top of the code file where you call the Print method, add a using directive (Imports for VB) for GrapeCity.ActiveReports.
  3. Call the Print method with the usePrintingThread parameter (the third parameter) set to false with code like the following.
C# code.
Copy Code
document.Print(false, false, false);
Visual Basic code.
Copy Code
document.Print(False, False, False)

Exception thrown when using Viewer.Print to print a report

Symptoms: An exception is thrown when the Viewer.Print method is used to print a report.

Cause: Print method was called before the page was loaded completely.

Solution: Use the Viewer.Print method in the LoadCompleted event.

ActiveReports controls do not appear in the toolbox

Symptoms: ActiveReport controls do not appear in the toolbox even when they are added manually using the steps in Adding ActiveReports Controls.

Cause: The project is using .NET 2.0 or lower.

Solution: Confirm if the project is using .NET 3.5 or later. .NET 2.0 is not supported in ActiveReports.

Error occurs while working with Open reports from server

Symptoms: An error occurs while working with the Open reports from server dialog.

Cause: GrapeCity ActiveReports Viewer and Json.NET 3.5 are not referenced in your project.

Solution: While working with the Open reports from server dialog, make sure you have access to GrapeCity.ActiveReports.ArsClient.v10.dll and Newtonsoft.Json.dll on your system. By default, GrapeCity.ActiveReports.ArsClient.v10.dll and Newtonsoft.Json.dll both are located in C:\Program Files (x86)\Common Files\GrapeCity\ActiveReports 10. To reference them in your project, in the Reference Manager, search for GrapeCity ActiveReports Viewer and Json.NET 3.5.

Error occurs while previewing remote reports through code

Symptoms: An error occurs while viewing remote reports through code.

Cause: Json.NET 3.5 are not referenced in your project.

Solution: To view reports remotely from ActiveReports Server through code, add a reference to Json.NET 3.5 Newtonsoft.Json.dll in your project.

Section Report Troubleshooting

Blank pages printed between pages, or a red line appears in the viewer

Symptoms: Blank pages are printed between pages of the report.

Cause: This problem occurs when the PrintWidth plus the left and right margins exceeds the paper width. For example, if the paper size were set to A4, the PrintWidth plus the left and right margins cannot exceed 8.27"; otherwise blank pages will be printed. At run time, ActiveReports marks a page overflow by displaying a red line in the viewer at the position in which the breach has occurred.

Solution: Adjust the PrintWidth in the report designer using either the property grid or by dragging the right edge of the report. Adjust page margins, height, and width either through the print properties dialog box (in the Report menu under Settings), or programmatically in the Report_Start event.

Copying reports results in stacked controls

Symptoms: A report file copied into a new project has all of its controls piled up at location 0, 0.

Cause: The report has become disconnected from its resource file. When you set a report"s Localizable property to True, the Size and Location properties of the report"s controls are moved to the associated *.resx file, so if you copy or move the report, you must move the *.resx file along with it.

Solution: When you copy a report"s *.vb or *.cs file from one project's App_Code folder into the App_Code folder of a new project, you need to also copy its *.resx file from the original project"s App_GlobalResources folder into the new project's App_GlobalResources folder.

No data appears in a report containing the OleObject control

Symptoms: No data appears in a report containing the OleObject control.

Cause: This issue occurs when the Microsoft .NET Framework 4.0 Client Profile or .NET Framework 4.0 Full Profile is used and the useLegacyV2RuntimeActivationPolicy attribute is not set to True.

Solution: Open the app.config file and set the useLegacyV2RuntimeActivationPolicy attribute to true.

XML code. Paste INSIDE the app.config file.
Copy Code
<configuration>
<startup useLegacyV2RuntimeActivationPolicy="true">
<supportedRuntime version="MyRunTimeVersion"/>
</startup>
</configuration>

An error message appears in the Fields list

Symptoms: An error message is displayed in the Fields list in the Report Explorer instead of the fields.

Cause: This is an expected error if no default value is given for a parameter. If the field is a data type other than text, memo, or date/time in Access, the report still runs normally.

Solution: To display the fields in the Fields list in the Report Explorer, supply a default value for the parameter in the Properties Window, or in the SQL query as below:

SQL Query
Copy Code
<%Name | PromptString | DefaultValue | DataType | PromptUser%>

Only the Name parameter is required. To use some, but not all, of the optional parameters, use all of the separator characters but with no text between one and the next for unused parameters. For example:

SQL Query
Copy Code
<%Name | | DefaultValue | |%>

An unhandled exception of type "System.Data..." occurs when the report is run

Symptoms: When the report is run, an exception like the following occurs: "An unhandled exception of type "System.Data.OleDb.OleDbException" occurred in system.data.dll"

Cause: If the field is a text, memo, or date/time data type in Access, the parameter syntax requires single quotes for text or memo fields, or pound signs for date/time fields. Please note that for different data sources, these requirements may differ.

Solution: To avoid the exception when the report is run against an Access database, use pound signs for date/time values, or single quotes for string values in your SQL query, for example:

SQL Query
Copy Code
#<%InvoiceDate | Choose invoice date: | 11/2/04 | D | True%>#

or

SQL Query
Copy Code
"<%Country | Country: | Germany | S | True%>"

User is prompted for parameters for subreports even though they are supplied by the main report

Symptoms: The parameter user interface pops up at run time asking for a value even though the main report is supplying the parameter values for the subreports.

Cause: The default value of the ShowParameterUI property of the report is True.

Solution: Set the ShowParameterUI property of the report to False. This can be done in the property grid or in code in the ReportStart event.

The viewer shows the report on the wrong paper size

Symptoms: In the viewer, the report renders to a different paper size than the one specified.

Cause: ActiveReports polls the printer driver assigned to the report to check for clipping, margins, and paper sizes supported by the printer. If the paper size specified for the report is not supported by the printer, ActiveReports uses the printer's default paper size to render the report.

Solution: If the report is to be printed, the printer assigned to the report must support the paper size and margins. Please note that any changes to the print settings in code must be made in or before the ReportStart event. To use custom paper sizes not supported by the driver, set the PrinterName to an empty string to use the ActiveReports virtual print driver. This does not allow printing, but is recommended for reports that are only exported or viewed. This prevents ActiveReports from making a call to the default printer driver. Use the following code in the ReportStart event, or just before .Run is called.

C# code. Paste INSIDE the ReportStart event.
Copy Code
this.Document.Printer.PrinterName = '';
Visual Basic.NET code. Paste INSIDE the ReportStart event.
Copy Code
Me.Document.Printer.PrinterName = ''

The PaperHeight and PaperWidth properties, which take a float value defined in inches, have no effect unless you set the PaperKind property to Custom. Here is some sample code which can be placed in the ReportStart event, or just before .Run.

C# code. Paste INSIDE the ReportStart event.
Copy Code
this.PageSettings.PaperKind = Drawing.Printing.PaperKind.Custom;
this.PageSettings.PaperHeight = 2;
//sets the height to two inches
this.PageSettings.PaperWidth = 4;
//sets the width to four inches
Visual Basic.NET code. Paste INSIDE the ReportStart event.
Copy Code
Me.PageSettings.PaperKind = Drawing.Printing.PaperKind.Custom
Me.PageSettings.PaperHeight = 2
'sets the height to two inches
Me.PageSettings.PaperWidth = 4
'sets the width to four inches

Custom paper sizes do not work

Symptoms: Custom paper sizes do not work.

Cause: You can create more than one custom paper size, so setting only the PaperKind property is not enough to create a custom paper size.

Solution: In addition to setting the PaperKind property to Custom, you must also set the PaperName property to a unique string.

Page/RDL Report Troubleshooting

An expression containing a numeric field name does not display any data at run time.

Symptoms: An expression containing a numeric field name does not display any data at runtime.

Cause: Visual Basic syntax does not allow an identifier that begins with a number.

i.e. =Fields!2004.Value

Solution: Make the numeric field name a string.

i.e. =Fields("2004").Value or, =Fields.Item("2004").Value

DataSet field in PageHeader of an RDL report

Symptoms: Cannot set a dataset field (bound field) in the PageHeader of an RDL report.

Cause: ActiveReports is based on the RDL 2005 specifications, therefore, referencing datasets in the PageHeader of an RDL report is not supported.

Solution: There is no direct way to add a DataField in a PageHeader, however, as a workaround you can create a hidden report parameter that is bound to your dataset and has the default value set to your expression. For example, ="*" & First(Fields!name.Value). You can then use this parameter in the page header.
Alternatively, you can use a Page report, which lets you place data fields anywhere on a page.

Exception thrown when using Viewer.Document property

Symptoms: An exception is raised when Viewer.Document is used with a page report or RDL report.

Cause: Document property is available for section reports only.

Cannot add assembly reference created in .NET Framework 4.0 or above in PageReports/RDLReports

Symptoms: Cannot add assembly reference created in .NET Framework 4.0 or above in PageReports/RDLReports of the stand-alone designer application.

Cause: The Stand-alone Designer application was created using the .NET 3.5 framework, therefore it cannot load .NET 4.0 assemblies.

Flash Viewer Troubleshooting

Swfobject undefined error

Symptoms: With the Flash viewer, my page throws a swfobject is undefined error.

Cause: The ActiveReports Handler Mappings are not set up correctly in IIS 7.0.

Solution: Configure HTTPHandlers in IIS 7.x.

IOError while loading document. Error #2032

Symptoms: When running the Flash viewer in IIS, an error occurs with the following message: "IOError while loading document. Reason: Error #2032."

Cause: The ActiveReports Handler Mappings are not set up correctly in IIS or in the web.config file.

Solution: Update Configure HTTPHandlers in IIS 7.x or if that is already done, ensure that the handlers are enabled in your web.config file.

FireFox displays white pages

Symptoms: When running the Flash viewer in FireFox, reports display white pages, but Internet Explorer renders reports correctly.

Cause: The height and width of the Flash viewer control is set to 100%. FireFox does not support this setting, so it does not resize the Flash Viewer at all.

Solution: Use cascading style sheets (CSS) to set the properties.

To use CSS in your Flash viewer ASPX

ASPX CSS code
Copy Code
<style type="text/css">
html, body, #WebViewer1, #WebViewer1_controlDiv
{
  width: 100%;
  height: 100%;
  margin: 0;
}
</style>

To use an external CSS file

  1. Assign the Flash viewer control a CSS class of report-viewer.
  2. Add code like the following to the CSS file.
    ASPX CSS code. Paste in the external CSS file
    Copy Code
    .report-viewer, .report-viewer div, .report-viewer object {height: 100%; width: 100%;}

Cannot load an rdf file in Flash Viewer using client scripting

Symptoms: An rdf file is not loaded in Flash Viewer when using client scripting.

Cause: You have to modify the setting of IIS Express to allow an rdf file to load correctly when using client scripting.

Solution: There are two ways to resolve this issue.

Open a Command Prompt window. Navigate to the IIS Express installation folder (the default location of this folder is C:\Program Files\IIS Express) and run the following command.

Paste the following on the command line
Copy Code
appcmd set config /section:staticContent /+[fileExtension='.rdf',mimeType='application/octet-stream']

The other one is to modify the IIS Express configuration file.

  1. In your local folders, find the IIS Express configuration file (the default location is C:\Users\[username]\Documents\IISExpress\config\applicationhost.config).
  2. Using Notepad, open the file and find the configuration/system.webServer/staticContent element.
  3. Add the following content to the staticContent node.
    Paste inside the IIS Express configuration file to the staticContent node
    Copy Code
    <mimeMap fileExtension=".rdf" mimeType="application/octet-stream" />
  4. Save the IIS Express configuration file.

An error occurs on running a report in Flash Viewer in cross-domain environment

Symptoms: En error occurs on running a report in Flash Viewer in the cross-domain environment.

Cause: The Flash Viewer needs permission to access content across domains.

Solution: You should create and place the crossdomain.xml together with the ActiveReports.ReportService.asmx file in the site or application root folder. For more information, see Setting a crossdomain.xml file.

Silverlight Viewer Troubleshooting

JScript error while using the Silverlight Viewer in Silverlight 5

Symptoms: When using the Silverlight Viewer in Silverlight 5, the JScript error may occur with the following message: "Unhandled Error in Silverlight Application The invocation of the constructor on type 'DataDynamics.ActiveReports.Viewer' that matches the specified binding constraints threw an exception."

Cause: The Silverlight Viewer is based on Silverlight 4, and it adds reference to System.Windows.Controls.dll (2.0.5.0). In Silverlight 5, adding the Silverlight Viewer control does not automatically add reference to System.Windows.Controls.dll to the project because the Silverlight Viewer adds reference to the Silverlight 4 version.

Solution: Add a reference to System.Windows.Controls.dll (in Silverlight 4 SDK or Silverlight 5 SDK) to the project.

Pan Mode does not work if the Silverlight viewer is placed in layout panels

Symptoms: Pan Mode does not work in horizontal/vertical directions, if the Silverlight viewer is placed in layout panels such as StackPanel, Canvas etc.

Cause: The default size of the Silverlight viewer is set to infinite according to the layout panel properties.

Solution: Go to the properties window and set a custom value in the Height and Width property of the layout panel.

Cannot load an rdf file in Silverlight Viewer

Symptoms: An rdf file is not loaded in Silverlight Viewer.

Cause: You have to modify the setting of IIS Express to allow an rdf file to load correctly.

Solution: There are two ways to resolve this issue.

Open a Command Prompt window. Navigate to the IIS Express installation folder (the default location of this folder is C:\Program Files\IIS Express) and run the following command.

Paste the following on the command line
Copy Code
appcmd set config /section:staticContent /+[fileExtension='.rdf',mimeType='application/octet-stream']

The other one is to modify the IIS Express configuration file.

  1. In your local folders, find the IIS Express configuration file (the default location is C:\Users\[username]\Documents\IISExpress\config\applicationhost.config).
  2. Using Notepad, open the file and find the configuration/system.webServer/staticContent element.
  3. Add the following content to the staticContent node.
    Paste inside the IIS Express configuration file to the staticContent node
    Copy Code
    <mimeMap fileExtension=".rdf" mimeType="application/octet-stream" />
  4. Save the IIS Express configuration file.

WPF Viewer Troubleshooting

TargetInvocationException occurs when running the WPF browser application

Symptoms: When running the WPF browser application, the TargetInvocationException occurs.

Cause: The WPF browser application does not support Partial Trust.

Solution: Make sure that the WPF browser application uses Full Trust. To do that, in the Visual Studio Project menu, go to YourProject Properties and on the Security tab, under EnableClickOnce security settings, select the option This is a full trust application.

Memory Troubleshooting

Note: According to Microsoft it is not necessary to call GC.Collect and it should be avoided. However, if calling GC.Collect reduces the memory leak, then this indicates that it is not a leak after all. A leak in managed code is caused by holding a reference to an object indefinitely. If ActiveReports is holding a reference to an object, then the object cannot be collected by the garbage collector.

Symptoms: ActiveReports is consuming too much memory; CPU usage always goes to 100% when using ActiveReports.

Cause: There are several reasons why too much memory may be consumed:

The report is not being disposed of properly

Cause: The report is not being disposed of properly. The incorrect syntax is as follows.

C# code.
Copy Code
//Incorrect!
rpt.Dispose();
rpt=null;
Visual Basic code.
Copy Code
'Incorrect!
rpt.Dispose()
rpt=Nothing

Solution: The correct syntax for disposing of a section report is as follows.

C# code.
Copy Code
//Correct!
rpt.Document.Dispose();
rpt.Dispose();
rpt=null;
Visual Basic code.
Copy Code
'Correct!
rpt.Document.Dispose()
rpt.Dispose()
rpt=Nothing

Machine.Config MemoryLimit setting is insufficient

Cause: Large reports in an ASP.NET application can easily use up the 60% of memory allocated to the ASP.NET worker process by default, which produces an error. In Machine.Config, MemoryLimit specifies the maximum allowed memory size, as a percentage of total system memory, that the worker process can consume before ASP.NET launches a new process and reassigns existing requests.

Solution: Set the CacheToDisk property of the document to True.

This caches the report to disk instead of holding it in memory. This setting is also detected by the PDF Export, which follows suit, but any other exports still consume memory. Although it is not advised, the ASP.NET worker process memory allocation can also be changed in your Machine.Config file, which is located in a path like: C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\Config\. Search the Machine.Config file for memoryLimit, which is located in the processModel.

Report never finishes processing

Cause: In some cases, very large reports can consume so much memory that the report never finishes processing. Some of the things that can cause this include:

  1. Many non-repeating images, or a high resolution repeating image
  2. Instantiating a new instance of a subreport each time the format event of a section fires
  3. Using a lot of subreports instead of grouping with joins in the SQL query
  4. Pulling in all of the data when only a few fields are needed (e.g. Select * from db instead of Select First, Last, Address from db)

Solution: In cases where the report is too large to run any other way, the CacheToDisk property may be set to True. This property should only be used when there is no other way to run the report to completion. Before resorting to this method, please see the Optimizing Section Reports topic.

Task manager indicates the current "working set" of the process

Cause: If inflated memory usage is seen in the Task Manager it is not necessarily in use by the code. Task manager indicates the current "working set" of the process and, upon request, other processes can gain access to that memory. It is managed by the Operating System.

Solution: For an example of some working set behavior anomalies (which are considered normal), create a WinForms application and run it. Look in Task Manager at the working set for that process (it should be several megabytes), then minimize and maximize the form and notice that the working set reclaims to <1MB. Obviously, the code was not using all that memory even though Task Manager showed that it was allocated to that process. Similarly, you'll see ASP.NET and other managed service processes continue to gradually grow their working set even though the managed code in that process is not using all of it. To see whether this is the case, try using the two lines of code below in a button Click event after running the project.

System.Diagnostics.Process pc = System.Diagnostics.Process.GetCurrentProcess();
pc.MaxWorkingSet = pc.MinWorkingSet;

If that reclaims the memory then the Operating System trimmed the working set down to the minimum amount necessary and this indicates that the extra memory was not actually in use.

WebViewer Troubleshooting

The WebViewer will not print without displaying the report

Symptoms: The WebViewer will not automatically print a report without displaying it.

Cause: Only the new FlashViewer ViewerType of the WebViewer offers this functionality.

Solution:

  1. Set the ViewerType property to FlashViewer.
  2. Expand the FlashViewerOptions property, and expand the PrintOptions subproperty.
  3. Under the PrintOptions subproperty, set the StartPrint property to True.

PDF opens in a new window when an application contains the WebViewer

Symptoms: When using Internet Explorer and Acrobat Reader to view a page containing a WebViewer in PDF mode, the resulting PDF always opens in a new window.

Cause: Acrobat Reader is only available in a 32-bit version. When the 64-bit version of Internet Explorer is used, it opens up an instance of the 32-bit version of Internet Explorer so that the plug-in and the PDF can load, rendering the resulting PDF in a new window.

Solution:

  • Install a PDF reader plug-in that is 64-bit compatible.
    OR
  • Use the 32-bit version of Internet Explorer.

The report in the HTML viewer type does not look exactly like the other viewer types

Symptoms: The report in the HTML viewer type does not look exactly like the other viewer types.

Cause: The HTML format is not WYSIWYG. It does not support the following items:

  • Line control
  • Control borders
  • Shapes (other than filled rects)
  • CrossSectionBox and CrossSectionLine controls
  • Overlapping controls

Solution: Try to avoid using the above items in reports which are shown in HTML format.

Blank reports with the AcrobatReader viewer type on the production web server

Symptoms: In the WebViewer, reports render correctly with the HTML ViewerType but they show up blank with the AcrobatReader ViewerType on the production web server.

Cause: .ArCacheItem is not set up in your IIS extension mappings.

Solution:

  1. From the Start menu, choose Control Panel, then Administrative Tools, then Internet Information Services.
  2. Right-click your Default Web Site and choose Properties.
  3. On the Home Directory tab, click the Configuration button.
  4. On the Mapping tab, check the Extension column to see whether .ArCacheItem appears. If not, click Add.
  5. In the Add/Edit Application Extension Mapping dialog that appears, click Browse and navigate to (Windows)\Microsoft.NET\Framework\v2.0.50727 or v3.0 or v3.5.
  6. In the Open dialog, change Files of type to Dynamic Link libraries (*.dll).
  7. Select aspnet_isapi.dll and click Open.
  8. In the Extension textbox type .ArCacheItem.
  9. Click the Limit to radio button and type GET,HEAD,POST,DEBUG.
  10. Ensure that the Script engine check box is selected and the Check that file exists check box is cleared.
  11. Click OK.

Issue while previewing reports in HTML5 using redirection

Symptoms: When a url, such as an image path, a drill-through path, or a toggle path in a report points to an intranet location, the element specified in the url is not displayed properly.

Cause: One server can not access the paths specified from another server. For example, when HTML5 Viewer gets the report in HTML, the images use the img element and the src attribute of the image is built on the server side which uses default intranet url instead of the internet url.

Solution: Specify the following settings:

  1. Reverse the proxy server by providing the url of ActiveReports10 Server instance of the ActiveReports10 Web service in GrapeCity.ActiveReports.Viewer.Html.js as follows:
    .js code. Paste inside the GrapeCity.ActiveReports.Viewer.Html.js file
    Copy Code
    reportService: {url: 'http://remote-ar-server.com'};
  2. Specify publicURL setting in Web.config file as follows:
    XML code. Paste inside the Web.config file
    Copy Code
    <ActiveReports10><WebService publicURL="https://..." /></ActiveReports10>
See Also

How To

How To

Concepts

Concepts

©2017. ComponentOne, a division of GrapeCity. All rights reserved.

Support Forum


Class Library

Class Library
ActiveReports 10 > Class Library

The Class Library contains documentation and code samples for the entire ActiveReports API.

This section contains information about

GrapeCity.ActiveReports.Chart.v10 Assembly
This assembly contains the namespaces Chart (including all axes, data, data points, legends, series, titles, and other configurable items in the charts), Annotations, Graphics, Styling, and Wizard.
GrapeCity.ActiveReports.Design.Win.v10 Assembly
This assembly contains the Design namespace (including all End User Report Designer features).
GrapeCity.ActiveReports.Document.v10 Assembly
This assembly contains the namespaces ActiveReports (border classes), Document.Section (including canvas drawing classes, bookmarks, paper sizes, etc.), and Export.Html (for HTML output types).
GrapeCity.ActiveReports.Export.Excel.v10 Assembly
This assembly contains the Export.Excel namespace (Excel export class with export methods and properties).
GrapeCity.ActiveReports.Export.Html.v10 Assembly
This assembly contains the Export.Html namespace (HTML export class with export methods and properties).
GrapeCity.ActiveReports.Export.Image.v10 Assembly
This assembly contains the Export.Image namespace (Image export class with export methods and properties).
GrapeCity.ActiveReports.Export.Pdf.v10 Assembly
This assembly contains the Export.Pdf namespace (PDF export, document options, and security classes).
GrapeCity.ActiveReports.Export.Word.v10 Assembly
This assembly contains the Export.Word namespace (Word export class with export methods and properties).
GrapeCity.ActiveReports.Export.Xml.v10 Assembly
This assembly contains the Export.Xml namespace (XML export class with export methods and properties).
GrapeCity.ActiveReports.Extensibility.v10 Assembly
This assembly contains the Extensibility namespace (ResourceLocator class and interfaces used with the page report designer).
GrapeCity.ActiveReports.v10 Assembly
This assembly contains the namespaces ActiveReports, Data, Expressions, PageReportModel, and SectionReportModel.
GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly
This assembly contains the namespaces ActiveReports (including the Silverlight Viewer), and ViewModel.
GrapeCity.ActiveReports.Viewer.Win.v10 Assembly
This assembly contains the Windows.Forms namespace (Viewer class with methods and properties).
GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly
This assembly contains Viewer.Wpf namespace (classes similar to Viewer.Win namespace).
GrapeCity.ActiveReports.Web.v10 Assembly
This assembly contains the namespaces Web (including the WebViewer), ExportOptions, and Handlers.
See Also

Welcome to ActiveReports

ActiveReports User Guide


GrapeCity.ActiveReports.Chart Namespace

GrapeCity.ActiveReports.Chart Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Chart.v10 Assembly : GrapeCity.ActiveReports.Chart Namespace
The GrapeCity.ActiveReports.Chart namespace contains the chart classes.
Classes
 | Class | Description
Class | AxesCollection | Represents a collection of axis.
Class | Axis | Represents the axis of the chart.
Class | AxisBase | Represents the set of properties of an axis.
Class | AxisScroll | Represents the scroll bar on an axis.
Class | BackdropItem | Represents the backdrop that acts as a separate item and handles mouse events.
Class | Border | Represents the information required to draw the borders of the graph.
Class | BorderSizes | Describes the size of the border around the rectangular area.
Class | ChartArea | Specifies the properties of the chart area.
Class | ChartAreasCollection | Specifies the settings for the chart areas collection.
Class | ChartTypeConfig | Represents the settings for the ChartTypeConfig object.
Class | CustomAxis | Represents the properties of a custom axis.
Class | CustomDrawEventArgs | Represents the properties of the custom draw event arguments for the chart.
Class | CustomProperties | Represents the set of custom properties for the chart.
Class | DataPoint | Represents the set of properties for a data point.
Class | DataPointsCollection | Specifies the settings for the DataPoints collection.
Class | DoubleArray | Represents the settings for the DoubleArray class.
Class | FontInfo | Represents the settings for the FontInfo class.
Class | GraphMouseEventArgs | Represents the properties of the mouse event arguments for the chart.
Class | GridLayout | Represents the settings for the GridLayout object.
Class | HitTest | Represents the properties of the HitTest object.
Class | KeyValuePair | Represents the settings for the KeyValuePair object.
Class | LabelInfo | Represents the settings for the LabelInfo class.
Class | LabelsCollection | Specifies the settings for the labels collection.
Class | Legend | Represents the settings for the Legend object.
Class | LegendItem | Represents the settings for the LegendItem object.
Class | LegendItemsCollection | Represents the settings for the LegendItemsCollection class.
Class | LegendsCollection | Represents the settings for the LegendsCollection class.
Class | Light | Represents the settings of the Light object.
Class | Marker | Represents the settings for the Marker object.
Class | PlaneItem | Represents the settings for the PlaneItem object used for the chart walls.
Class | Projection | Represents the settings of the geometric Projection object.
Class | Series | Represents the settings for the Series object.
Class | SeriesCollection | Represents the settings for the SeriesCollection class.
Class | SharpGraph | Represents the settings for the SharpGraph object.
Class | Tick | Represents the settings of the Tick object.
Class | Title | Represents the settings for the Title object.
Class | TitlesCollection | Represents the settings for the TitlesCollection object.
Class | WallRange | Represents the settings of the WallRange object.
Class | WallRangesCollection | Represents the settings of the WallRangesCollection object.
Class | XmlDataProvider | Provides access to XML data.
Interfaces
 | Interface | Description
Interface | IChartMemberNameProvider | Provides a name for the chart member name provider.
Structures
 | Structure | Description
Structure | Padding | Provides the settings used to set a margin (four edges) inside a control.
Delegates
 | Delegate | Description
Delegate | CustomDrawEventHandler | Represents the method that handles the CustomDraw event.
Delegate | GraphMouseEventHandler | Represents the method that handles the GraphMouse event.
Enumerations
 | Enumeration | Description
Enumeration | Alignment | Specifies how the text item anchors to its position.
Enumeration | ArrowType | Specifies the arrow type used for the axis line.
Enumeration | AxisType | Specifies the axis type.
Enumeration | BarType | Specifies the type of bars to use.
Enumeration | BaseStyle | Gets or sets a circular or square base drawing style for the 3D funnel chart or 3D pyramid chart.
Enumeration | ChartType | Specifies the ChartType used for the Series.
Enumeration | ColorPalette | Specifies what color palette is used.
Enumeration | DeviceModes | Specifies the device drawing mode used to render the chart.
Enumeration | DockType | Specifies the docking area.
Enumeration | FunnelStyle | Specifies whether the Y value for the series points to the width or the height of the funnel. The default value is YIsHeight.
Enumeration | LabelsPlacement | Specifies whether the data point labels appear on the left or right side of the funnel or pyramid chart.
Enumeration | LegendMode | Specifies the mode used to render legend items.
Enumeration | LightType | Specifies the type of light source used.
Enumeration | MarkerStyle | Specifies the shape of the marker.
Enumeration | StandardAxis | Specifies which axis is the standard axis.
Enumeration | StdLegendMarker | Specifies the standard legend marker shape to use.
Enumeration | UICommand | Specifies the command to be used for the DoCommand method of the Chart control.
Enumeration | UIOptions | Specifies the user interface settings for the Chart control.
Remarks

See Also

Reference

GrapeCity.ActiveReports.Chart.v10 Assembly


AxesCollection Class

AxesCollection Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : AxesCollection Class
Represents a collection of axis.
Object Model
AxesCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class AxesCollection
   Inherits System.Collections.CollectionBase
public sealed class AxesCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.AxesCollection

See Also

Reference

AxesCollection Members
GrapeCity.ActiveReports.Chart Namespace


AxesCollection Class Members

AxesCollection Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : AxesCollection Class

The following tables list the members exposed by AxesCollection.

Public Properties
 | Name | Description
Public Property | Item | Overloaded. Gets or sets the specified axis in the collection.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an axis to the collection.
Public Method | AddRange | Adds a set of axes to the collection.
Public Method | Clear | Clears all axes from the collection. (Inherited from System.Collections.CollectionBase)
Public Method | Clone | Creates a clone of the axes collection.
Public Method | Contains | Determines whether the collection contains the specified AxisBase.
Public Method | Dispose | Releases from memory resources associated with AxisCollection object.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts the specified axis into the collection at the specified index.
Public Method | Remove | Removes the specified axis from the collection.
Public Method | RemoveAt | Removes the specified axis from the collection. (Inherited from System.Collections.CollectionBase)
Public Method | ToArray | Copies the elements of the axis collection to a new array.
Top
See Also

Reference

AxesCollection Class
GrapeCity.ActiveReports.Chart Namespace


AxesCollection Class Methods

AxesCollection Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : AxesCollection Class

For a list of all members of this type, see AxesCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an axis to the collection.
Public Method | AddRange | Adds a set of axes to the collection.
Public Method | Clear | Clears all axes from the collection. (Inherited from System.Collections.CollectionBase)
Public Method | Clone | Creates a clone of the axes collection.
Public Method | Contains | Determines whether the collection contains the specified AxisBase.
Public Method | Dispose | Releases from memory resources associated with AxisCollection object.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts the specified axis into the collection at the specified index.
Public Method | Remove | Removes the specified axis from the collection.
Public Method | RemoveAt | Removes the specified axis from the collection. (Inherited from System.Collections.CollectionBase)
Public Method | ToArray | Copies the elements of the axis collection to a new array.
Top
See Also

Reference

AxesCollection Class
GrapeCity.ActiveReports.Chart Namespace


Add Method (AxesCollection)

Add Method (AxesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class : Add Method
The axis to add.
Adds an axis to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As AxisBase _
) As System.Integer
public System.int Add(
   AxisBase value
)

Parameters

value
The axis to add.
See Also

Reference

AxesCollection Class
AxesCollection Members


AddRange Method (AxesCollection)

AddRange Method (AxesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class : AddRange Method
The axes to add to the collection.
Adds a set of axes to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddRange( _
   ByVal value() As AxisBase _
)
public void AddRange(
   AxisBase[] value
)

Parameters

value
The axes to add to the collection.
See Also

Reference

AxesCollection Class
AxesCollection Members


Clone Method (AxesCollection)

Clone Method (AxesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class : Clone Method
Creates a clone of the axes collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Clone() As System.Object
public System.object Clone()
See Also

Reference

AxesCollection Class
AxesCollection Members


Contains Method (AxesCollection)

Contains Method (AxesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class : Contains Method

The AxisBase to find in the collection.

Determines whether the collection contains the specified AxisBase.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal value As AxisBase _
) As System.Boolean
public System.bool Contains(
   AxisBase value
)

Parameters

value

The AxisBase to find in the collection.

Return Value

Boolean. Returns True if the collection contains the parameter given; otherwise, False.
See Also

Reference

AxesCollection Class
AxesCollection Members


Dispose Method (AxesCollection)

Dispose Method (AxesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class : Dispose Method
Releases from memory resources associated with AxisCollection object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()

Return Value

Releases resources associated with this object.
See Also

Reference

AxesCollection Class
AxesCollection Members


IndexOf Method (AxesCollection)

IndexOf Method (AxesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class : IndexOf Method

The object to locate in the collection.

Returns the index of the first occurrence of a value in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As AxisBase _
) As System.Integer
public System.int IndexOf(
   AxisBase value
)

Parameters

value

The object to locate in the collection.

Return Value

Returns the index of the first occurrence of a value in the collection.
See Also

Reference

AxesCollection Class
AxesCollection Members


Insert Method (AxesCollection)

Insert Method (AxesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class : Insert Method
Index of the axis.
The axis to be inserted

Inserts the specified axis into the collection at the specified index.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As AxisBase _
)
public void Insert(
   System.int index,
   AxisBase value
)

Parameters

index
Index of the axis.
value
The axis to be inserted
See Also

Reference

AxesCollection Class
AxesCollection Members


Remove Method (AxesCollection)

Remove Method (AxesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class : Remove Method
The axis to remove.
Removes the specified axis from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As AxisBase _
)
public void Remove(
   AxisBase value
)

Parameters

value
The axis to remove.
See Also

Reference

AxesCollection Class
AxesCollection Members


ToArray Method (AxesCollection)

ToArray Method (AxesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class : ToArray Method
Copies the elements of the axis collection to a new array.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToArray() As AxisBase()
public AxisBase[] ToArray()
See Also

Reference

AxesCollection Class
AxesCollection Members


AxesCollection Class Properties

AxesCollection Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : AxesCollection Class

For a list of all members of this type, see AxesCollection members.

Public Properties
 | Name | Description
Public Property | Item | Overloaded. Gets or sets the specified axis in the collection.
Top
See Also

Reference

AxesCollection Class
GrapeCity.ActiveReports.Chart Namespace


Item Property (AxesCollection)

Item Property (AxesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class : Item Property
Gets or sets the specified axis in the collection.
Overload List
Overload | Description
Item(Int32) | Gets or sets the axis at the specified index.
Item(String) | Gets the index of the axis with the specified name in the collection.
See Also

Reference

AxesCollection Class
AxesCollection Members


Item(Int32) Property

Item(Int32) Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class > Item Property : Item(Int32) Property

The index of the axis.

Gets or sets the axis at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Property Item( _
   ByVal index As System.Integer _
) As AxisBase
public AxisBase Item(
   System.int index
) {get; set;}

Parameters

index

The index of the axis.

See Also

Reference

AxesCollection Class
AxesCollection Members
Overload List


Item(String) Property

Item(String) Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class > Item Property : Item(String) Property
The name of the axis.
Gets the index of the axis with the specified name in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal axisName As System.String _
) As AxisBase
public AxisBase Item(
   System.string axisName
) {get;}

Parameters

axisName
The name of the axis.

Property Value

AxisBase.
See Also

Reference

AxesCollection Class
AxesCollection Members
Overload List


Axis Class

Axis Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Axis Class
Represents the axis of the chart.
Object Model
Axis Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Axis
   Inherits AxisBase
public sealed class Axis : AxisBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.AxisBase
GrapeCity.ActiveReports.Chart.Axis

See Also

Reference

Axis Members
GrapeCity.ActiveReports.Chart Namespace


Axis Class Members

Axis Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Axis Class

The following tables list the members exposed by Axis.

Public Constructors
 | Name | Description
Public Constructor | Axis Constructor | Initializes an instance of the Axis class.
Top
Public Properties
 | Name | Description
Public Property | Arrow | Gets or sets the arrow type on the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | AxisType | Gets or sets the axis type. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | DisplayScale | Gets or sets a value indicating whether to display the scale value on the title of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | LabelFont | Gets or sets the font info used to draw the labels of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | LabelFormat | Gets or sets the format used to output the values of the labels. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Labels | Gets the contents of the labels collection, used for categorical axes. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | LabelsAtBottom | Gets or sets a value to render axis labels, tickmarks and secondary axes at the bottom of the axis, regardless the Position property. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | LabelsGap | Gets or sets a value indicating how many labels to skip on the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | LabelsInside | Gets or sets the position of labels against the axis line. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | LabelsVisible | Gets or sets a value indicating whether axis labels will be drawn on the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Line | Gets or sets the line used to draw the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | MajorTick | Gets or sets the major tick of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Max | Gets or sets the maximum value for the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Min | Gets or sets the minimum value for the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | MinorTick | Gets or sets the minor tick of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Name | Overridden. Gets or sets the name of the axis as string.
Public Property | Position | Gets or sets the position along the adjacent axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Scale | Gets or sets the scale value used to draw labels. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | SmartLabels | Gets or sets a value indicating whether smart labels are enabled on the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | StaggerLabels | Gets or sets a value indicating whether labels on the axis are staggered. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | TickOffset | Gets or sets the offset of the first tick from the Min value of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Title | Gets or sets the text string for the title of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | TitleFont | Gets or sets the font information used to draw the title of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Visible | Gets or sets a value indicating whether the axis is visible. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the axis.
Top
See Also

Reference

Axis Class
GrapeCity.ActiveReports.Chart Namespace


Axis Constructor

Axis Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Axis Class : Axis Constructor
Initializes an instance of the Axis class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Axis()
See Also

Reference

Axis Class
Axis Members


Axis Class Methods

Axis Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Axis Class

For a list of all members of this type, see Axis members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the axis.
Top
See Also

Reference

Axis Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method (Axis)

Clone Method (Axis)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Axis Class : Clone Method
Creates a clone of the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

A clone of the axis.
See Also

Reference

Axis Class
Axis Members


Axis Class Properties

Axis Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Axis Class

For a list of all members of this type, see Axis members.

Public Properties
 | Name | Description
Public Property | Arrow | Gets or sets the arrow type on the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | AxisType | Gets or sets the axis type. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | DisplayScale | Gets or sets a value indicating whether to display the scale value on the title of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | LabelFont | Gets or sets the font info used to draw the labels of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | LabelFormat | Gets or sets the format used to output the values of the labels. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Labels | Gets the contents of the labels collection, used for categorical axes. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | LabelsAtBottom | Gets or sets a value to render axis labels, tickmarks and secondary axes at the bottom of the axis, regardless the Position property. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | LabelsGap | Gets or sets a value indicating how many labels to skip on the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | LabelsInside | Gets or sets the position of labels against the axis line. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | LabelsVisible | Gets or sets a value indicating whether axis labels will be drawn on the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Line | Gets or sets the line used to draw the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | MajorTick | Gets or sets the major tick of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Max | Gets or sets the maximum value for the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Min | Gets or sets the minimum value for the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | MinorTick | Gets or sets the minor tick of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Name | Overridden. Gets or sets the name of the axis as string.
Public Property | Position | Gets or sets the position along the adjacent axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Scale | Gets or sets the scale value used to draw labels. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | SmartLabels | Gets or sets a value indicating whether smart labels are enabled on the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | StaggerLabels | Gets or sets a value indicating whether labels on the axis are staggered. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | TickOffset | Gets or sets the offset of the first tick from the Min value of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Title | Gets or sets the text string for the title of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | TitleFont | Gets or sets the font information used to draw the title of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Visible | Gets or sets a value indicating whether the axis is visible. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Top
See Also

Reference

Axis Class
GrapeCity.ActiveReports.Chart Namespace


Name Property (Axis)

Name Property (Axis)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Axis Class : Name Property
Gets or sets the name of the axis as string.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Property Name As System.String
public override System.string Name {get; set;}

Property Value

The name.
Exceptions
Exception | Description
System.InvalidOperationException | Can't change name for standard axis
See Also

Reference

Axis Class
Axis Members


AxisBase Class

AxisBase Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : AxisBase Class
Represents the set of properties of an axis.
Object Model
AxisBase Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class AxisBase
   Inherits MouseEnabledComponent
public abstract class AxisBase : MouseEnabledComponent
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.AxisBase
GrapeCity.ActiveReports.Chart.Axis
GrapeCity.ActiveReports.Chart.CustomAxis

See Also

Reference

AxisBase Members
GrapeCity.ActiveReports.Chart Namespace


AxisBase Class Members

AxisBase Class Members
Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : AxisBase Class

The following tables list the members exposed by AxisBase.

Public Properties
 | Name | Description
Public Property | Arrow | Gets or sets the arrow type on the axis.
Public Property | AxisType | Gets or sets the axis type.
Public Property | DisplayScale | Gets or sets a value indicating whether to display the scale value on the title of the axis.
Public Property | LabelFont | Gets or sets the font info used to draw the labels of the axis.
Public Property | LabelFormat | Gets or sets the format used to output the values of the labels.
Public Property | Labels | Gets the contents of the labels collection, used for categorical axes.
Public Property | LabelsAtBottom | Gets or sets a value to render axis labels, tickmarks and secondary axes at the bottom of the axis, regardless the Position property.
Public Property | LabelsGap | Gets or sets a value indicating how many labels to skip on the axis.
Public Property | LabelsInside | Gets or sets the position of labels against the axis line.
Public Property | LabelsVisible | Gets or sets a value indicating whether axis labels will be drawn on the axis.
Public Property | Line | Gets or sets the line used to draw the axis.
Public Property | MajorTick | Gets or sets the major tick of the axis.
Public Property | Max | Gets or sets the maximum value for the axis.
Public Property | Min | Gets or sets the minimum value for the axis.
Public Property | MinorTick | Gets or sets the minor tick of the axis.
Public Property | Position | Gets or sets the position along the adjacent axis.
Public Property | Scale | Gets or sets the scale value used to draw labels.
Public Property | SmartLabels | Gets or sets a value indicating whether smart labels are enabled on the axis.
Public Property | StaggerLabels | Gets or sets a value indicating whether labels on the axis are staggered.
Public Property | TickOffset | Gets or sets the offset of the first tick from the Min value of the axis.
Public Property | Title | Gets or sets the text string for the title of the axis.
Public Property | TitleFont | Gets or sets the font information used to draw the title of the axis.
Public Property | Visible | Gets or sets a value indicating whether the axis is visible.
Top
See Also

Reference

AxisBase Class
GrapeCity.ActiveReports.Chart Namespace


AxisBase Class Properties

AxisBase Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : AxisBase Class

For a list of all members of this type, see AxisBase members.

Public Properties
 | Name | Description
Public Property | Arrow | Gets or sets the arrow type on the axis.
Public Property | AxisType | Gets or sets the axis type.
Public Property | DisplayScale | Gets or sets a value indicating whether to display the scale value on the title of the axis.
Public Property | LabelFont | Gets or sets the font info used to draw the labels of the axis.
Public Property | LabelFormat | Gets or sets the format used to output the values of the labels.
Public Property | Labels | Gets the contents of the labels collection, used for categorical axes.
Public Property | LabelsAtBottom | Gets or sets a value to render axis labels, tickmarks and secondary axes at the bottom of the axis, regardless the Position property.
Public Property | LabelsGap | Gets or sets a value indicating how many labels to skip on the axis.
Public Property | LabelsInside | Gets or sets the position of labels against the axis line.
Public Property | LabelsVisible | Gets or sets a value indicating whether axis labels will be drawn on the axis.
Public Property | Line | Gets or sets the line used to draw the axis.
Public Property | MajorTick | Gets or sets the major tick of the axis.
Public Property | Max | Gets or sets the maximum value for the axis.
Public Property | Min | Gets or sets the minimum value for the axis.
Public Property | MinorTick | Gets or sets the minor tick of the axis.
Public Property | Position | Gets or sets the position along the adjacent axis.
Public Property | Scale | Gets or sets the scale value used to draw labels.
Public Property | SmartLabels | Gets or sets a value indicating whether smart labels are enabled on the axis.
Public Property | StaggerLabels | Gets or sets a value indicating whether labels on the axis are staggered.
Public Property | TickOffset | Gets or sets the offset of the first tick from the Min value of the axis.
Public Property | Title | Gets or sets the text string for the title of the axis.
Public Property | TitleFont | Gets or sets the font information used to draw the title of the axis.
Public Property | Visible | Gets or sets a value indicating whether the axis is visible.
Top
See Also

Reference

AxisBase Class
GrapeCity.ActiveReports.Chart Namespace


Arrow Property

Arrow Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : Arrow Property
Gets or sets the arrow type on the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Arrow As ArrowType
public ArrowType Arrow {get; set;}

Property Value

A valid ArrowType enumeration value.
Exceptions
Exception | Description
System.ComponentModel.InvalidEnumArgumentException | Arrow
See Also

Reference

AxisBase Class
AxisBase Members


AxisType Property

AxisType Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : AxisType Property
Gets or sets the axis type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AxisType As AxisType
public AxisType AxisType {get; set;}

Property Value

A valid AxisType enumeration value, either numerical or categorical.
See Also

Reference

AxisBase Class
AxisBase Members


DisplayScale Property

DisplayScale Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : DisplayScale Property
Gets or sets a value indicating whether to display the scale value on the title of the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DisplayScale As System.Boolean
public System.bool DisplayScale {get; set;}

Property Value

Boolean. True if the scale value on the title of the axis is displayed; otherwise False.
See Also

Reference

AxisBase Class
AxisBase Members


LabelFont Property

LabelFont Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : LabelFont Property
Gets or sets the font info used to draw the labels of the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LabelFont As FontInfo
public FontInfo LabelFont {get; set;}
See Also

Reference

AxisBase Class
AxisBase Members


LabelFormat Property (AxisBase)

LabelFormat Property (AxisBase)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : LabelFormat Property
Gets or sets the format used to output the values of the labels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LabelFormat As System.String
public System.string LabelFormat {get; set;}
Remarks
The ActiveReports chart control uses standard Visual Studio .NET formatting syntax. The format is {Tag : Format}. For example, {Value:C} formats the text as currency. {Value:D} formats the text as a date.
Example
Tag（variable） | Explanation | Example
Index | Index of points. |
Value | Data value. Same as Value0 of the renderer of category base, Value2 of BubbleXY chart etc. | {Value}
Value# [1] | Variable that represents the data set value(zero base). | {Value0}
Total | The total of the data set（the total sum of all the points of this data set）. |
Pct | Corresponds to Value/Total. |
Pct[#] | Corresponds to Value#/Total. |
Xvalue | X value of point. X value of the XY chart. Same as the point instance of category base chart. |
PTotal | Sum Total of all the data set values of this point, and on this layer. |
PPct | Corresponds to Value/PointTotal. |
See Also

Reference

AxisBase Class
AxisBase Members


Labels Property

Labels Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : Labels Property
Gets the contents of the labels collection, used for categorical axes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Labels As LabelsCollection
public LabelsCollection Labels {get;}
See Also

Reference

AxisBase Class
AxisBase Members


LabelsAtBottom Property

LabelsAtBottom Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : LabelsAtBottom Property
Gets or sets a value to render axis labels, tickmarks and secondary axes at the bottom of the axis, regardless the Position property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LabelsAtBottom As System.Boolean
public System.bool LabelsAtBottom {get; set;}

Property Value

true if [labels at bottom]; otherwise, false.
See Also

Reference

AxisBase Class
AxisBase Members


LabelsGap Property

LabelsGap Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : LabelsGap Property
Gets or sets a value indicating how many labels to skip on the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LabelsGap As System.Integer
public System.int LabelsGap {get; set;}
See Also

Reference

AxisBase Class
AxisBase Members


LabelsInside Property

LabelsInside Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : LabelsInside Property
Gets or sets the position of labels against the axis line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LabelsInside As System.Boolean
public System.bool LabelsInside {get; set;}
See Also

Reference

AxisBase Class
AxisBase Members


LabelsVisible Property

LabelsVisible Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : LabelsVisible Property
Gets or sets a value indicating whether axis labels will be drawn on the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LabelsVisible As System.Boolean
public System.bool LabelsVisible {get; set;}

Property Value

Boolean. True if axis labels will be drawn on the axis; otherwise False.
See Also

Reference

AxisBase Class
AxisBase Members


Line Property (AxisBase)

Line Property (AxisBase)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : Line Property
Gets or sets the line used to draw the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Line As Line
public Line Line {get; set;}
See Also

Reference

AxisBase Class
AxisBase Members


MajorTick Property

MajorTick Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : MajorTick Property
Gets or sets the major tick of the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MajorTick As Tick
public Tick MajorTick {get; set;}
See Also

Reference

AxisBase Class
AxisBase Members


Max Property (AxisBase)

Max Property (AxisBase)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : Max Property
Gets or sets the maximum value for the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Max As System.Double
public System.double Max {get; set;}
Remarks
The Max and Min properties do not work with a DateTime axis.
See Also

Reference

AxisBase Class
AxisBase Members


Min Property (AxisBase)

Min Property (AxisBase)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : Min Property
Gets or sets the minimum value for the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Min As System.Double
public System.double Min {get; set;}
Remarks
The Max and Min properties do not work with a DateTime axis.
See Also

Reference

AxisBase Class
AxisBase Members


MinorTick Property

MinorTick Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : MinorTick Property

Gets or sets the minor tick of the axis.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinorTick As Tick
public Tick MinorTick {get; set;}
See Also

Reference

AxisBase Class
AxisBase Members


Position Property (AxisBase)

Position Property (AxisBase)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : Position Property
Gets or sets the position along the adjacent axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Position As System.Double
public System.double Position {get; set;}
See Also

Reference

AxisBase Class
AxisBase Members


Scale Property

Scale Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : Scale Property
Gets or sets the scale value used to draw labels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Scale As System.Double
public System.double Scale {get; set;}
See Also

Reference

AxisBase Class
AxisBase Members


SmartLabels Property

SmartLabels Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : SmartLabels Property
Gets or sets a value indicating whether smart labels are enabled on the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SmartLabels As System.Boolean
public System.bool SmartLabels {get; set;}

Property Value

Boolean. True if smart labels are enabled on the axis; otherwise False.
See Also

Reference

AxisBase Class
AxisBase Members


StaggerLabels Property

StaggerLabels Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : StaggerLabels Property
Gets or sets a value indicating whether labels on the axis are staggered.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StaggerLabels As System.Boolean
public System.bool StaggerLabels {get; set;}

Property Value

Boolean. True if labels on the axis are staggered; otherwise False.
See Also

Reference

AxisBase Class
AxisBase Members


TickOffset Property

TickOffset Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : TickOffset Property
Gets or sets the offset of the first tick from the Min value of the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TickOffset As System.Double
public System.double TickOffset {get; set;}
See Also

Reference

AxisBase Class
AxisBase Members


Title Property (AxisBase)

Title Property (AxisBase)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : Title Property
Gets or sets the text string for the title of the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Title As System.String
public System.string Title {get; set;}
See Also

Reference

AxisBase Class
AxisBase Members


TitleFont Property

TitleFont Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : TitleFont Property
Gets or sets the font information used to draw the title of the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TitleFont As FontInfo
public FontInfo TitleFont {get; set;}
See Also

Reference

AxisBase Class
AxisBase Members


Visible Property (AxisBase)

Visible Property (AxisBase)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisBase Class : Visible Property
Gets or sets a value indicating whether the axis is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}
See Also

Reference

AxisBase Class
AxisBase Members


AxisScroll Class

AxisScroll Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : AxisScroll Class
Represents the scroll bar on an axis.
Object Model
AxisScroll Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class AxisScroll
   Inherits ItemComponent
public sealed class AxisScroll : ItemComponent
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.AxisScroll

See Also

Reference

AxisScroll Members
GrapeCity.ActiveReports.Chart Namespace


AxisScroll Class Members

AxisScroll Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : AxisScroll Class

The following tables list the members exposed by AxisScroll.

Public Constructors
 | Name | Description
Public Constructor | AxisScroll Constructor | Initializes a new instance of the AxisScroll class.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the backcolor of the scroll bar.
Public Property | ButtonColor | Gets or sets the button color of the scroll bar.
Public Property | Enabled | Gets or sets a value indicating whether the axis scroll bar is enabled.
Public Property | Name | Gets or sets the name of the axis scroll bar as string.
Public Property | OutlineColor | Gets or sets the outline color of the axis scroll bar.
Public Property | ScrollLength | Gets or sets the scroll length of the axis scroll bar.
Public Property | ScrollPosition | Gets or sets the scroll position of the axis scroll bar.
Public Property | ScrollStepSize | Gets or sets the scroll step size of the axis scroll bar.
Public Property | Visible | Gets or sets a value indicating whether the axis scroll bar is visible.
Public Property | Width | Gets or sets the width of the axis scroll bar.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the axis scroll bar.
Top
See Also

Reference

AxisScroll Class
GrapeCity.ActiveReports.Chart Namespace


AxisScroll Constructor

AxisScroll Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class : AxisScroll Constructor
Initializes a new instance of the AxisScroll class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public AxisScroll()
See Also

Reference

AxisScroll Class
AxisScroll Members


AxisScroll Class Methods

AxisScroll Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : AxisScroll Class

For a list of all members of this type, see AxisScroll members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the axis scroll bar.
Top
See Also

Reference

AxisScroll Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method (AxisScroll)

Clone Method (AxisScroll)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class : Clone Method
Creates a clone of the axis scroll bar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

System.Object.
See Also

Reference

AxisScroll Class
AxisScroll Members


AxisScroll Class Properties

AxisScroll Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : AxisScroll Class

For a list of all members of this type, see AxisScroll members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the backcolor of the scroll bar.
Public Property | ButtonColor | Gets or sets the button color of the scroll bar.
Public Property | Enabled | Gets or sets a value indicating whether the axis scroll bar is enabled.
Public Property | Name | Gets or sets the name of the axis scroll bar as string.
Public Property | OutlineColor | Gets or sets the outline color of the axis scroll bar.
Public Property | ScrollLength | Gets or sets the scroll length of the axis scroll bar.
Public Property | ScrollPosition | Gets or sets the scroll position of the axis scroll bar.
Public Property | ScrollStepSize | Gets or sets the scroll step size of the axis scroll bar.
Public Property | Visible | Gets or sets a value indicating whether the axis scroll bar is visible.
Public Property | Width | Gets or sets the width of the axis scroll bar.
Top
See Also

Reference

AxisScroll Class
GrapeCity.ActiveReports.Chart Namespace


BackColor Property (AxisScroll)

BackColor Property (AxisScroll)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class : BackColor Property
Gets or sets the backcolor of the scroll bar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackColor As Color
public Color BackColor {get; set;}

Property Value

System.Drawing.Color.
See Also

Reference

AxisScroll Class
AxisScroll Members


ButtonColor Property

ButtonColor Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class : ButtonColor Property
Gets or sets the button color of the scroll bar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ButtonColor As Color
public Color ButtonColor {get; set;}

Property Value

System.Drawing.Color.
See Also

Reference

AxisScroll Class
AxisScroll Members


Enabled Property (AxisScroll)

Enabled Property (AxisScroll)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class : Enabled Property
Gets or sets a value indicating whether the axis scroll bar is enabled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Enabled As System.Boolean
public System.bool Enabled {get; set;}

Property Value

Boolean. True if the axis scroll bar is enabled; otherwise False.
See Also

Reference

AxisScroll Class
AxisScroll Members


Name Property (AxisScroll)

Name Property (AxisScroll)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class : Name Property
Gets or sets the name of the axis scroll bar as string.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Property Name As System.String
public new System.string Name {get; set;}

Property Value

The name.
See Also

Reference

AxisScroll Class
AxisScroll Members


OutlineColor Property

OutlineColor Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class : OutlineColor Property
Gets or sets the outline color of the axis scroll bar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OutlineColor As Color
public Color OutlineColor {get; set;}

Property Value

System.Drawing.Color.
See Also

Reference

AxisScroll Class
AxisScroll Members


ScrollLength Property

ScrollLength Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class : ScrollLength Property
Gets or sets the scroll length of the axis scroll bar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ScrollLength As System.Double
public System.double ScrollLength {get; set;}
See Also

Reference

AxisScroll Class
AxisScroll Members


ScrollPosition Property

ScrollPosition Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class : ScrollPosition Property
Gets or sets the scroll position of the axis scroll bar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ScrollPosition As System.Double
public System.double ScrollPosition {get; set;}
See Also

Reference

AxisScroll Class
AxisScroll Members


ScrollStepSize Property

ScrollStepSize Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class : ScrollStepSize Property
Gets or sets the scroll step size of the axis scroll bar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ScrollStepSize As System.Double
public System.double ScrollStepSize {get; set;}
See Also

Reference

AxisScroll Class
AxisScroll Members


Visible Property (AxisScroll)

Visible Property (AxisScroll)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class : Visible Property

Gets or sets a value indicating whether the axis scroll bar is visible.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}

Property Value

Boolean. True if the axis scroll bar is visible; otherwise False.
See Also

Reference

AxisScroll Class
AxisScroll Members


Width Property (AxisScroll)

Width Property (AxisScroll)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxisScroll Class : Width Property
Gets or sets the width of the axis scroll bar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As System.Integer
public System.int Width {get; set;}
See Also

Reference

AxisScroll Class
AxisScroll Members


BackdropItem Class

BackdropItem Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : BackdropItem Class
Represents the backdrop that acts as a separate item and handles mouse events.
Object Model
BackdropItem Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class BackdropItem
   Inherits GrapeCity.ActiveReports.Chart.Graphics.Backdrop
public sealed class BackdropItem : GrapeCity.ActiveReports.Chart.Graphics.Backdrop
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Graphics.Backdrop
GrapeCity.ActiveReports.Chart.BackdropItem

See Also

Reference

BackdropItem Members
GrapeCity.ActiveReports.Chart Namespace


BackdropItem Class Members

BackdropItem Class Members
Properties Methods Events

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : BackdropItem Class

The following tables list the members exposed by BackdropItem.

Public Constructors
 | Name | Description
Public Constructor | BackdropItem Constructor | Overloaded. Initializes a new instance of the BackdropItem class.
Top
Public Properties
 | Name | Description
Public Property | Alpha | Gets or sets the alpha level (transparency). (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Public Property | Color | Gets or sets the primary color used to fill the backdrop. (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Public Property | Color2 | Gets or sets the secondary color used for gradient effects and patterns. (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control.
Public Property | Gradient | Gets or sets the enumerated GradientType used for the Backdrop. (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Public Property | Pattern | Gets or sets the HatchStyle used for the Backdrop pattern. (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Public Property | Picture | Gets or sets the image used for the Backdrop. (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Public Property | PictureAlignment | Gets or sets the image alignment for the Backdrop. (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Public Property | Style | Gets or sets the type of backdrop to use (i.e. solid, gradient, etc.). (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Top
Public Methods
 | Name | Description
Public Method | Clone | Creates a clone of the Backdrop. (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Public Method | CopyFrom | Initializes the specified Backdrop object with settings. (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Public Method | Dispose | Releases the Backdrop instance from memory. (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Public Method | Equals | Compares the BackdropItem object to another System.Object to see if they are equal.
Public Method | FitToRectangle | Overloaded. Sets the bounding rectangle of the Backdrop. (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table. (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Public Method | OnMouseDown | Raises the MouseDown event.
Public Method | OnMouseEnter | Raises the MouseEnter event.
Public Method | OnMouseHover | Raises the MouseHover event.
Public Method | OnMouseLeave | Raises the MouseLeave event.
Public Method | OnMouseMove | Raises the MouseMove event.
Public Method | OnMouseUp | Raises the MouseUp event.
Public Method | OnMouseWheel | Raises the MouseWheel event.
Public Method | Serialize | Creates XML encoding for the Backdrop object or reconstructs the object state from XML encoding. (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Top
Public Events
 | Name | Description
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed.
Public Event | MouseEnter | Occurs when the mouse pointer enters the control.
Public Event | MouseHover | Occurs when the mouse pointer hovers over the control.
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control.
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control.
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released.
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus.
Top
See Also

Reference

BackdropItem Class
GrapeCity.ActiveReports.Chart Namespace


BackdropItem Constructor

BackdropItem Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : BackdropItem Constructor
Initializes a new instance of the BackdropItem class.
Overload List
Overload | Description
BackdropItem Constructor() | Initializes a new instance of the BackdropItem class.
BackdropItem Constructor(AntiAliasMode) | Initializes a new instance of the BackdropItem class with the AntiAliasMode specified.
BackdropItem Constructor(Color) | Initializes a new instance of the BackdropItem class with the specified color.
BackdropItem Constructor(Color,AntiAliasMode) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(Color,Byte) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(Color,Byte,AntiAliasMode) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(GradientType,Color,Color) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(GradientType,Color,Color,AntiAliasMode) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(HatchStyle,Color,Color) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(HatchStyle,Color,Color,AntiAliasMode) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(Image,PicturePutStyle) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(Image,PicturePutStyle,AntiAliasMode) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,AntiAliasMode) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte,AntiAliasMode) | Initializes a new instance of the BackdropItem class with the parameters specified.
BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte,AntiAliasMode,ContextMenu) | Initializes a new instance of the BackdropItem class with the parameters specified.
See Also

Reference

BackdropItem Class
BackdropItem Members


BackdropItem Constructor()

BackdropItem Constructor()

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor()
Initializes a new instance of the BackdropItem class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public BackdropItem()
See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(AntiAliasMode)

BackdropItem Constructor(AntiAliasMode)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(AntiAliasMode)

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Initializes a new instance of the BackdropItem class with the AntiAliasMode specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal antiAliasMode As AntiAliasMode _
)
public BackdropItem(
   AntiAliasMode antiAliasMode
)

Parameters

antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(Color)

BackdropItem Constructor(Color)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(Color)
Specifies the primary color.
Initializes a new instance of the BackdropItem class with the specified color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal color As Color _
)
public BackdropItem(
   Color color
)

Parameters

color
Specifies the primary color.
See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(Color,AntiAliasMode)

BackdropItem Constructor(Color,AntiAliasMode)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(Color,AntiAliasMode)
Specifies the primary color.

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Initializes a new instance of the BackdropItem class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal color As Color, _
   ByVal antiAliasMode As AntiAliasMode _
)
public BackdropItem(
   Color color,
   AntiAliasMode antiAliasMode
)

Parameters

color
Specifies the primary color.
antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(Color,Byte)

BackdropItem Constructor(Color,Byte)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(Color,Byte)
Specifies the primary color.
Specifies the alpha level (transparency) to use.
Initializes a new instance of the BackdropItem class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal color As Color, _
   ByVal alpha As System.Byte _
)
public BackdropItem(
   Color color,
   System.byte alpha
)

Parameters

color
Specifies the primary color.
alpha
Specifies the alpha level (transparency) to use.
See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(Color,Byte,AntiAliasMode)

BackdropItem Constructor(Color,Byte,AntiAliasMode)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(Color,Byte,AntiAliasMode)
Specifies the primary color.
Specifies the alpha level (transparency) to use.

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Initializes a new instance of the BackdropItem class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal color As Color, _
   ByVal alpha As System.Byte, _
   ByVal antiAliasMode As AntiAliasMode _
)
public BackdropItem(
   Color color,
   System.byte alpha,
   AntiAliasMode antiAliasMode
)

Parameters

color
Specifies the primary color.
alpha
Specifies the alpha level (transparency) to use.
antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(GradientType,Color,Color)

BackdropItem Constructor(GradientType,Color,Color)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(GradientType,Color,Color)
Specifies the type of gradient used (used with GradientType).
Specifies the primary color.
Specifies the secondary color (used with hatch and gradient styles).
Initializes a new instance of the BackdropItem class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal gradient As GradientType, _
   ByVal color As Color, _
   ByVal color2 As Color _
)
public BackdropItem(
   GradientType gradient,
   Color color,
   Color color2
)

Parameters

gradient
Specifies the type of gradient used (used with GradientType).
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(GradientType,Color,Color,AntiAliasMode)

BackdropItem Constructor(GradientType,Color,Color,AntiAliasMode)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(GradientType,Color,Color,AntiAliasMode)
Specifies the type of gradient used (used with GradientType).
Specifies the primary color.
Specifies the secondary color (used with hatch and gradient styles).

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Initializes a new instance of the BackdropItem class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal gradient As GradientType, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal antiAliasMode As AntiAliasMode _
)
public BackdropItem(
   GradientType gradient,
   Color color,
   Color color2,
   AntiAliasMode antiAliasMode
)

Parameters

gradient
Specifies the type of gradient used (used with GradientType).
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(HatchStyle,Color,Color)

BackdropItem Constructor(HatchStyle,Color,Color)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(HatchStyle,Color,Color)
Specifies the hatch pattern (used with HatchStyle).
Specifies the primary color.
Specifies the secondary color (used with hatch and gradient styles).
Initializes a new instance of the BackdropItem class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal pattern As System.Drawing.Drawing2D.HatchStyle, _
   ByVal color As Color, _
   ByVal color2 As Color _
)
public BackdropItem(
   System.Drawing.Drawing2D.HatchStyle pattern,
   Color color,
   Color color2
)

Parameters

pattern
Specifies the hatch pattern (used with HatchStyle).
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(HatchStyle,Color,Color,AntiAliasMode)

BackdropItem Constructor(HatchStyle,Color,Color,AntiAliasMode)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(HatchStyle,Color,Color,AntiAliasMode)
Specifies the hatch pattern (used with HatchStyle).
Specifies the primary color.
Specifies the secondary color (used with hatch and gradient styles).

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Initializes a new instance of the BackdropItem class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal pattern As System.Drawing.Drawing2D.HatchStyle, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal antiAliasMode As AntiAliasMode _
)
public BackdropItem(
   System.Drawing.Drawing2D.HatchStyle pattern,
   Color color,
   Color color2,
   AntiAliasMode antiAliasMode
)

Parameters

pattern
Specifies the hatch pattern (used with HatchStyle).
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(Image,PicturePutStyle)

BackdropItem Constructor(Image,PicturePutStyle)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(Image,PicturePutStyle)
Specifies the image used for the backdrop.
Specifies the image alignment used.
Initializes a new instance of the BackdropItem class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle _
)
public BackdropItem(
   Image picture,
   PicturePutStyle pictureAlignment
)

Parameters

picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(Image,PicturePutStyle,AntiAliasMode)

BackdropItem Constructor(Image,PicturePutStyle,AntiAliasMode)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(Image,PicturePutStyle,AntiAliasMode)
Specifies the image used for the backdrop.
Specifies the image alignment used.

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Initializes a new instance of the BackdropItem class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle, _
   ByVal antiAliasMode As AntiAliasMode _
)
public BackdropItem(
   Image picture,
   PicturePutStyle pictureAlignment,
   AntiAliasMode antiAliasMode
)

Parameters

picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle)

BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle)
Specifies the backdrop style.
Specifies the primary color.
Specifies the secondary color (used with hatch and gradient styles).
Specifies the type of gradient used (used with GradientType).
Specifies the hatch pattern (used with HatchStyle).
Specifies the image used for the backdrop.
Specifies the image alignment used.
Initializes a new instance of the BackdropItem class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal style As BackdropStyle, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal gradient As GradientType, _
   ByVal pattern As System.Drawing.Drawing2D.HatchStyle, _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle _
)
public BackdropItem(
   BackdropStyle style,
   Color color,
   Color color2,
   GradientType gradient,
   System.Drawing.Drawing2D.HatchStyle pattern,
   Image picture,
   PicturePutStyle pictureAlignment
)

Parameters

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the type of gradient used (used with GradientType).
pattern
Specifies the hatch pattern (used with HatchStyle).
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,AntiAliasMode)

BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,AntiAliasMode)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,AntiAliasMode)
Specifies the backdrop style.
Specifies the primary color.
Specifies the secondary color (used with hatch and gradient styles).
Specifies the type of gradient used (used with GradientType).
Specifies the hatch pattern (used with HatchStyle).
Specifies the image used for the backdrop.
Specifies the image alignment used.

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Initializes a new instance of the BackdropItem class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal style As BackdropStyle, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal gradient As GradientType, _
   ByVal pattern As System.Drawing.Drawing2D.HatchStyle, _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle, _
   ByVal antiAliasMode As AntiAliasMode _
)
public BackdropItem(
   BackdropStyle style,
   Color color,
   Color color2,
   GradientType gradient,
   System.Drawing.Drawing2D.HatchStyle pattern,
   Image picture,
   PicturePutStyle pictureAlignment,
   AntiAliasMode antiAliasMode
)

Parameters

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the type of gradient used (used with GradientType).
pattern
Specifies the hatch pattern (used with HatchStyle).
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte)

BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte)
Specifies the backdrop style.
Specifies the primary color.
Specifies the secondary color (used with hatch and gradient styles).
Specifies the type of gradient used (used with GradientType).
Specifies the hatch pattern (used with HatchStyle).
Specifies the image used for the backdrop.
Specifies the image alignment used.
Specifies the alpha level (transparency) to use.
Initializes a new instance of the BackdropItem class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal style As BackdropStyle, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal gradient As GradientType, _
   ByVal pattern As System.Drawing.Drawing2D.HatchStyle, _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle, _
   ByVal alpha As System.Byte _
)
public BackdropItem(
   BackdropStyle style,
   Color color,
   Color color2,
   GradientType gradient,
   System.Drawing.Drawing2D.HatchStyle pattern,
   Image picture,
   PicturePutStyle pictureAlignment,
   System.byte alpha
)

Parameters

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the type of gradient used (used with GradientType).
pattern
Specifies the hatch pattern (used with HatchStyle).
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
alpha
Specifies the alpha level (transparency) to use.
See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte,AntiAliasMode)

BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte,AntiAliasMode)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte,AntiAliasMode)
Specifies the backdrop style.
Specifies the primary color.
Specifies the secondary color (used with hatch and gradient styles).
Specifies the type of gradient used (used with GradientType).
Specifies the hatch pattern (used with HatchStyle).
Specifies the image used for the backdrop.
Specifies the image alignment used.
Specifies the alpha level (transparency) to use.

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Initializes a new instance of the BackdropItem class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal style As BackdropStyle, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal gradient As GradientType, _
   ByVal pattern As System.Drawing.Drawing2D.HatchStyle, _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle, _
   ByVal alpha As System.Byte, _
   ByVal antiAliasMode As AntiAliasMode _
)
public BackdropItem(
   BackdropStyle style,
   Color color,
   Color color2,
   GradientType gradient,
   System.Drawing.Drawing2D.HatchStyle pattern,
   Image picture,
   PicturePutStyle pictureAlignment,
   System.byte alpha,
   AntiAliasMode antiAliasMode
)

Parameters

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the type of gradient used (used with GradientType).
pattern
Specifies the hatch pattern (used with HatchStyle).
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
alpha
Specifies the alpha level (transparency) to use.
antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte,AntiAliasMode,ContextMenu)

BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte,AntiAliasMode,ContextMenu)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class > BackdropItem Constructor : BackdropItem Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte,AntiAliasMode,ContextMenu)
Specifies the backdrop style.
Specifies the primary color.
Specifies the secondary color (used with hatch and gradient styles).
Specifies the type of gradient used (used with GradientType).
Specifies the hatch pattern (used with HatchStyle).
Specifies the image used for the backdrop.
Specifies the image alignment used.
Specifies the alpha level (transparency) to use.

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Specifies the shortcut menu associated with the control.
Initializes a new instance of the BackdropItem class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal style As BackdropStyle, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal gradient As GradientType, _
   ByVal pattern As System.Drawing.Drawing2D.HatchStyle, _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle, _
   ByVal alpha As System.Byte, _
   ByVal antiAliasMode As AntiAliasMode, _
   ByVal contextMenu As System.Windows.Forms.ContextMenu _
)
public BackdropItem(
   BackdropStyle style,
   Color color,
   Color color2,
   GradientType gradient,
   System.Drawing.Drawing2D.HatchStyle pattern,
   Image picture,
   PicturePutStyle pictureAlignment,
   System.byte alpha,
   AntiAliasMode antiAliasMode,
   System.Windows.Forms.ContextMenu contextMenu
)

Parameters

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the type of gradient used (used with GradientType).
pattern
Specifies the hatch pattern (used with HatchStyle).
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
alpha
Specifies the alpha level (transparency) to use.
antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

contextMenu
Specifies the shortcut menu associated with the control.
See Also

Reference

BackdropItem Class
BackdropItem Members
Overload List


BackdropItem Class Methods

BackdropItem Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : BackdropItem Class

For a list of all members of this type, see BackdropItem members.

Public Methods
 | Name | Description
Public Method | Clone | Creates a clone of the Backdrop. (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Public Method | CopyFrom | Initializes the specified Backdrop object with settings. (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Public Method | Dispose | Releases the Backdrop instance from memory. (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Public Method | Equals | Compares the BackdropItem object to another System.Object to see if they are equal.
Public Method | FitToRectangle | Overloaded. Sets the bounding rectangle of the Backdrop. (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table. (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Public Method | OnMouseDown | Raises the MouseDown event.
Public Method | OnMouseEnter | Raises the MouseEnter event.
Public Method | OnMouseHover | Raises the MouseHover event.
Public Method | OnMouseLeave | Raises the MouseLeave event.
Public Method | OnMouseMove | Raises the MouseMove event.
Public Method | OnMouseUp | Raises the MouseUp event.
Public Method | OnMouseWheel | Raises the MouseWheel event.
Public Method | Serialize | Creates XML encoding for the Backdrop object or reconstructs the object state from XML encoding. (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Top
See Also

Reference

BackdropItem Class
GrapeCity.ActiveReports.Chart Namespace


Equals Method (BackdropItem)

Equals Method (BackdropItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : Equals Method
The System.Object to which the BackdropItem object is being compared.
Compares the BackdropItem object to another System.Object to see if they are equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The System.Object to which the BackdropItem object is being compared.

Return Value

Boolean. Returns True if the BackdropItem object is equal to the System.Object; otherwise False.
See Also

Reference

BackdropItem Class
BackdropItem Members


OnMouseDown Method

OnMouseDown Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : OnMouseDown Method
A GraphMouseEventArgs that contains the event data.

Raises the MouseDown event.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub OnMouseDown( _
   ByVal e As GraphMouseEventArgs _
)
public void OnMouseDown(
   GraphMouseEventArgs e
)

Parameters

e
A GraphMouseEventArgs that contains the event data.
See Also

Reference

BackdropItem Class
BackdropItem Members


OnMouseEnter Method

OnMouseEnter Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : OnMouseEnter Method
A GraphMouseEventArgs that contains the event data.
Raises the MouseEnter event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub OnMouseEnter( _
   ByVal e As GraphMouseEventArgs _
)
public void OnMouseEnter(
   GraphMouseEventArgs e
)

Parameters

e
A GraphMouseEventArgs that contains the event data.
See Also

Reference

BackdropItem Class
BackdropItem Members


OnMouseHover Method (BackdropItem)

OnMouseHover Method (BackdropItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : OnMouseHover Method
A GraphMouseEventArgs that contains the event data.
Raises the MouseHover event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub OnMouseHover( _
   ByVal e As GraphMouseEventArgs _
)
public void OnMouseHover(
   GraphMouseEventArgs e
)

Parameters

e
A GraphMouseEventArgs that contains the event data.
See Also

Reference

BackdropItem Class
BackdropItem Members


OnMouseLeave Method (BackdropItem)

OnMouseLeave Method (BackdropItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : OnMouseLeave Method
A GraphMouseEventArgs that contains the event data.
Raises the MouseLeave event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub OnMouseLeave( _
   ByVal e As GraphMouseEventArgs _
)
public void OnMouseLeave(
   GraphMouseEventArgs e
)

Parameters

e
A GraphMouseEventArgs that contains the event data.
See Also

Reference

BackdropItem Class
BackdropItem Members


OnMouseMove Method (BackdropItem)

OnMouseMove Method (BackdropItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : OnMouseMove Method
A GraphMouseEventArgs that contains the event data.
Raises the MouseMove event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub OnMouseMove( _
   ByVal e As GraphMouseEventArgs _
)
public void OnMouseMove(
   GraphMouseEventArgs e
)

Parameters

e
A GraphMouseEventArgs that contains the event data.
See Also

Reference

BackdropItem Class
BackdropItem Members


OnMouseUp Method

OnMouseUp Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : OnMouseUp Method
A GraphMouseEventArgs that contains the event data.
Raises the MouseUp event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub OnMouseUp( _
   ByVal e As GraphMouseEventArgs _
)
public void OnMouseUp(
   GraphMouseEventArgs e
)

Parameters

e
A GraphMouseEventArgs that contains the event data.
See Also

Reference

BackdropItem Class
BackdropItem Members


OnMouseWheel Method

OnMouseWheel Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : OnMouseWheel Method
A GraphMouseEventArgs that contains the event data.
Raises the MouseWheel event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub OnMouseWheel( _
   ByVal e As GraphMouseEventArgs _
)
public void OnMouseWheel(
   GraphMouseEventArgs e
)

Parameters

e
A GraphMouseEventArgs that contains the event data.
See Also

Reference

BackdropItem Class
BackdropItem Members


BackdropItem Class Properties

BackdropItem Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : BackdropItem Class

For a list of all members of this type, see BackdropItem members.

Public Properties
 | Name | Description
Public Property | Alpha | Gets or sets the alpha level (transparency). (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Public Property | Color | Gets or sets the primary color used to fill the backdrop. (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Public Property | Color2 | Gets or sets the secondary color used for gradient effects and patterns. (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control.
Public Property | Gradient | Gets or sets the enumerated GradientType used for the Backdrop. (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Public Property | Pattern | Gets or sets the HatchStyle used for the Backdrop pattern. (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Public Property | Picture | Gets or sets the image used for the Backdrop. (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Public Property | PictureAlignment | Gets or sets the image alignment for the Backdrop. (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Public Property | Style | Gets or sets the type of backdrop to use (i.e. solid, gradient, etc.). (Inherited from GrapeCity.ActiveReports.Chart.Graphics.Backdrop)
Top
See Also

Reference

BackdropItem Class
GrapeCity.ActiveReports.Chart Namespace


ContextMenu Property (BackdropItem)

ContextMenu Property (BackdropItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : ContextMenu Property

Gets or sets the shortcut menu associated with the control.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ContextMenu As System.Windows.Forms.ContextMenu
public System.Windows.Forms.ContextMenu ContextMenu {get; set;}
See Also

Reference

BackdropItem Class
BackdropItem Members


BackdropItem Class Events

BackdropItem Class Events

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : BackdropItem Class

For a list of all members of this type, see BackdropItem members.

Public Events
 | Name | Description
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed.
Public Event | MouseEnter | Occurs when the mouse pointer enters the control.
Public Event | MouseHover | Occurs when the mouse pointer hovers over the control.
Public Event | MouseLeave | Occurs when the mouse pointer leaves the control.
Public Event | MouseMove | Occurs when the mouse pointer is moved over the control.
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released.
Public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus.
Top
See Also

Reference

BackdropItem Class
GrapeCity.ActiveReports.Chart Namespace


MouseDown Event (BackdropItem)

MouseDown Event (BackdropItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : MouseDown Event
Occurs when the mouse pointer is over the control and a mouse button is pressed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseDown As GraphMouseEventHandler
public event GraphMouseEventHandler MouseDown
Event Data

The event handler receives an argument of type GraphMouseEventArgs containing data related to this event. The following GraphMouseEventArgs properties provide information specific to this event.

Property | Description
Button | (Inherited from System.Windows.Forms.MouseEventArgs)
Clicks | (Inherited from System.Windows.Forms.MouseEventArgs)
Control | Gets or sets the control on which the mouse event occurred.
Delta | (Inherited from System.Windows.Forms.MouseEventArgs)
ItemCount | Gets a count of the number of times the item was clicked.
Location | (Inherited from System.Windows.Forms.MouseEventArgs)
PointIndex | Gets a count of the number of times the item was clicked.
UserX | Gets the X coordinate of the mouse.
UserY | Gets the Y coordinate of the mouse.
X | (Inherited from System.Windows.Forms.MouseEventArgs)
Y | (Inherited from System.Windows.Forms.MouseEventArgs)
See Also

Reference

BackdropItem Class
BackdropItem Members


MouseEnter Event (BackdropItem)

MouseEnter Event (BackdropItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : MouseEnter Event
Occurs when the mouse pointer enters the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseEnter As GraphMouseEventHandler
public event GraphMouseEventHandler MouseEnter
Event Data

The event handler receives an argument of type GraphMouseEventArgs containing data related to this event. The following GraphMouseEventArgs properties provide information specific to this event.

Property | Description
Button | (Inherited from System.Windows.Forms.MouseEventArgs)
Clicks | (Inherited from System.Windows.Forms.MouseEventArgs)
Control | Gets or sets the control on which the mouse event occurred.
Delta | (Inherited from System.Windows.Forms.MouseEventArgs)
ItemCount | Gets a count of the number of times the item was clicked.
Location | (Inherited from System.Windows.Forms.MouseEventArgs)
PointIndex | Gets a count of the number of times the item was clicked.
UserX | Gets the X coordinate of the mouse.
UserY | Gets the Y coordinate of the mouse.
X | (Inherited from System.Windows.Forms.MouseEventArgs)
Y | (Inherited from System.Windows.Forms.MouseEventArgs)
See Also

Reference

BackdropItem Class
BackdropItem Members


MouseHover Event (BackdropItem)

MouseHover Event (BackdropItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : MouseHover Event
Occurs when the mouse pointer hovers over the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseHover As GraphMouseEventHandler
public event GraphMouseEventHandler MouseHover
Event Data

The event handler receives an argument of type GraphMouseEventArgs containing data related to this event. The following GraphMouseEventArgs properties provide information specific to this event.

Property | Description
Button | (Inherited from System.Windows.Forms.MouseEventArgs)
Clicks | (Inherited from System.Windows.Forms.MouseEventArgs)
Control | Gets or sets the control on which the mouse event occurred.
Delta | (Inherited from System.Windows.Forms.MouseEventArgs)
ItemCount | Gets a count of the number of times the item was clicked.
Location | (Inherited from System.Windows.Forms.MouseEventArgs)
PointIndex | Gets a count of the number of times the item was clicked.
UserX | Gets the X coordinate of the mouse.
UserY | Gets the Y coordinate of the mouse.
X | (Inherited from System.Windows.Forms.MouseEventArgs)
Y | (Inherited from System.Windows.Forms.MouseEventArgs)
See Also

Reference

BackdropItem Class
BackdropItem Members


MouseLeave Event (BackdropItem)

MouseLeave Event (BackdropItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : MouseLeave Event
Occurs when the mouse pointer leaves the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseLeave As GraphMouseEventHandler
public event GraphMouseEventHandler MouseLeave
Event Data

The event handler receives an argument of type GraphMouseEventArgs containing data related to this event. The following GraphMouseEventArgs properties provide information specific to this event.

Property | Description
Button | (Inherited from System.Windows.Forms.MouseEventArgs)
Clicks | (Inherited from System.Windows.Forms.MouseEventArgs)
Control | Gets or sets the control on which the mouse event occurred.
Delta | (Inherited from System.Windows.Forms.MouseEventArgs)
ItemCount | Gets a count of the number of times the item was clicked.
Location | (Inherited from System.Windows.Forms.MouseEventArgs)
PointIndex | Gets a count of the number of times the item was clicked.
UserX | Gets the X coordinate of the mouse.
UserY | Gets the Y coordinate of the mouse.
X | (Inherited from System.Windows.Forms.MouseEventArgs)
Y | (Inherited from System.Windows.Forms.MouseEventArgs)
See Also

Reference

BackdropItem Class
BackdropItem Members


MouseMove Event (BackdropItem)

MouseMove Event (BackdropItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : MouseMove Event
Occurs when the mouse pointer is moved over the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseMove As GraphMouseEventHandler
public event GraphMouseEventHandler MouseMove
Event Data

The event handler receives an argument of type GraphMouseEventArgs containing data related to this event. The following GraphMouseEventArgs properties provide information specific to this event.

Property | Description
Button | (Inherited from System.Windows.Forms.MouseEventArgs)
Clicks | (Inherited from System.Windows.Forms.MouseEventArgs)
Control | Gets or sets the control on which the mouse event occurred.
Delta | (Inherited from System.Windows.Forms.MouseEventArgs)
ItemCount | Gets a count of the number of times the item was clicked.
Location | (Inherited from System.Windows.Forms.MouseEventArgs)
PointIndex | Gets a count of the number of times the item was clicked.
UserX | Gets the X coordinate of the mouse.
UserY | Gets the Y coordinate of the mouse.
X | (Inherited from System.Windows.Forms.MouseEventArgs)
Y | (Inherited from System.Windows.Forms.MouseEventArgs)
See Also

Reference

BackdropItem Class
BackdropItem Members


MouseUp Event (BackdropItem)

MouseUp Event (BackdropItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : MouseUp Event
Occurs when the mouse pointer is over the control and a mouse button is released.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseUp As GraphMouseEventHandler
public event GraphMouseEventHandler MouseUp
Event Data

The event handler receives an argument of type GraphMouseEventArgs containing data related to this event. The following GraphMouseEventArgs properties provide information specific to this event.

Property | Description
Button | (Inherited from System.Windows.Forms.MouseEventArgs)
Clicks | (Inherited from System.Windows.Forms.MouseEventArgs)
Control | Gets or sets the control on which the mouse event occurred.
Delta | (Inherited from System.Windows.Forms.MouseEventArgs)
ItemCount | Gets a count of the number of times the item was clicked.
Location | (Inherited from System.Windows.Forms.MouseEventArgs)
PointIndex | Gets a count of the number of times the item was clicked.
UserX | Gets the X coordinate of the mouse.
UserY | Gets the Y coordinate of the mouse.
X | (Inherited from System.Windows.Forms.MouseEventArgs)
Y | (Inherited from System.Windows.Forms.MouseEventArgs)
See Also

Reference

BackdropItem Class
BackdropItem Members


MouseWheel Event (BackdropItem)

MouseWheel Event (BackdropItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BackdropItem Class : MouseWheel Event
Occurs when the mouse wheel moves while the control has focus.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseWheel As GraphMouseEventHandler
public event GraphMouseEventHandler MouseWheel
Event Data

The event handler receives an argument of type GraphMouseEventArgs containing data related to this event. The following GraphMouseEventArgs properties provide information specific to this event.

Property | Description
Button | (Inherited from System.Windows.Forms.MouseEventArgs)
Clicks | (Inherited from System.Windows.Forms.MouseEventArgs)
Control | Gets or sets the control on which the mouse event occurred.
Delta | (Inherited from System.Windows.Forms.MouseEventArgs)
ItemCount | Gets a count of the number of times the item was clicked.
Location | (Inherited from System.Windows.Forms.MouseEventArgs)
PointIndex | Gets a count of the number of times the item was clicked.
UserX | Gets the X coordinate of the mouse.
UserY | Gets the Y coordinate of the mouse.
X | (Inherited from System.Windows.Forms.MouseEventArgs)
Y | (Inherited from System.Windows.Forms.MouseEventArgs)
See Also

Reference

BackdropItem Class
BackdropItem Members


Border Class

Border Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Border Class
Represents the information required to draw the borders of the graph.
Object Model
Border Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Border
   Inherits Item
public sealed class Border : Item
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Border

See Also

Reference

Border Members
GrapeCity.ActiveReports.Chart Namespace


Border Class Members

Border Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Border Class

The following tables list the members exposed by Border.

Public Constructors
 | Name | Description
Public Constructor | Border Constructor | Overloaded. Initializes a new instance of the Border class.
Top
Public Properties
 | Name | Description
Public Property | Line | Gets or sets the line style used to draw the border of the graph.
Public Property | ShadowColor | Gets or sets the color of the shadow outlining the border.
Public Property | ShadowWeight | Gets or sets the width of the shadow outlining the border.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the border.
Public Method | Equals | Compares the Border object to another System.Object to see if they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Top
See Also

Reference

Border Class
GrapeCity.ActiveReports.Chart Namespace


Border Constructor

Border Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Border Class : Border Constructor
Initializes a new instance of the Border class.
Overload List
Overload | Description
Border Constructor() | Initializes a new instance of the Border class.
Border Constructor(Line) | Initializes a new instance of the Border class with the Line info specified.
Border Constructor(Line,Int32) | Initializes a new instance of the Border class with the parameters specified.
Border Constructor(Line,Int32,Color) | Initializes a new instance of the Border class with the parameters specified.
See Also

Reference

Border Class
Border Members


Border Constructor()

Border Constructor()

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Border Class > Border Constructor : Border Constructor()
Initializes a new instance of the Border class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Border()
See Also

Reference

Border Class
Border Members
Overload List


Border Constructor(Line)

Border Constructor(Line)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Border Class > Border Constructor : Border Constructor(Line)
Specifies the Line info for the border.
Initializes a new instance of the Border class with the Line info specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal line As Line _
)
public Border(
   Line line
)

Parameters

line
Specifies the Line info for the border.
See Also

Reference

Border Class
Border Members
Overload List


Border Constructor(Line,Int32)

Border Constructor(Line,Int32)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Border Class > Border Constructor : Border Constructor(Line,Int32)
Specifies the Line info for the border.
Specifies the shadow weight of the border.
Initializes a new instance of the Border class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal line As Line, _
   ByVal shadowWeight As System.Integer _
)
public Border(
   Line line,
   System.int shadowWeight
)

Parameters

line
Specifies the Line info for the border.
shadowWeight
Specifies the shadow weight of the border.
See Also

Reference

Border Class
Border Members
Overload List


Border Constructor(Line,Int32,Color)

Border Constructor(Line,Int32,Color)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Border Class > Border Constructor : Border Constructor(Line,Int32,Color)
Specifies the Line info for the border.
Specifies the shadow weight of the border.
Specifies the shadow color of the border.
Initializes a new instance of the Border class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal line As Line, _
   ByVal shadowWeight As System.Integer, _
   ByVal shadowColor As Color _
)
public Border(
   Line line,
   System.int shadowWeight,
   Color shadowColor
)

Parameters

line
Specifies the Line info for the border.
shadowWeight
Specifies the shadow weight of the border.
shadowColor
Specifies the shadow color of the border.
See Also

Reference

Border Class
Border Members
Overload List


Border Class Methods

Border Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Border Class

For a list of all members of this type, see Border members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the border.
Public Method | Equals | Compares the Border object to another System.Object to see if they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Top
See Also

Reference

Border Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method (Border)

Clone Method (Border)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Border Class : Clone Method
Creates a clone of the border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

A clone of the Border.
See Also

Reference

Border Class
Border Members


Equals Method (Border)

Equals Method (Border)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Border Class : Equals Method
The System.Object to which the Border object is being compared.
Compares the Border object to another System.Object to see if they are equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The System.Object to which the Border object is being compared.

Return Value

Boolean. True if the Border object is equal to the System.Object; otherwise False.
See Also

Reference

Border Class
Border Members


GetHashCode Method (Border)

GetHashCode Method (Border)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Border Class : GetHashCode Method
Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

Border Class
Border Members


GetObjectData Method (Border)

GetObjectData Method (Border)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Border Class : GetObjectData Method

The SerializationInfo to populate with data.

The destination for the serialization.
Populates a SerializationInfo with the data needed to serialize the target object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info

The SerializationInfo to populate with data.

context
The destination for the serialization.
See Also

Reference

Border Class
Border Members


Border Class Properties

Border Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Border Class

For a list of all members of this type, see Border members.

Public Properties
 | Name | Description
Public Property | Line | Gets or sets the line style used to draw the border of the graph.
Public Property | ShadowColor | Gets or sets the color of the shadow outlining the border.
Public Property | ShadowWeight | Gets or sets the width of the shadow outlining the border.
Top
See Also

Reference

Border Class
GrapeCity.ActiveReports.Chart Namespace


Line Property (Border)

Line Property (Border)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Border Class : Line Property
Gets or sets the line style used to draw the border of the graph.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Line As Line
public Line Line {get; set;}
See Also

Reference

Border Class
Border Members


ShadowColor Property

ShadowColor Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Border Class : ShadowColor Property
Gets or sets the color of the shadow outlining the border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShadowColor As Color
public Color ShadowColor {get; set;}
See Also

Reference

Border Class
Border Members


ShadowWeight Property

ShadowWeight Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Border Class : ShadowWeight Property

Gets or sets the width of the shadow outlining the border.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShadowWeight As System.Integer
public System.int ShadowWeight {get; set;}
See Also

Reference

Border Class
Border Members


BorderSizes Class

BorderSizes Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : BorderSizes Class
Describes the size of the border around the rectangular area.
Object Model
BorderSizes Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class BorderSizes
public sealed class BorderSizes
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.BorderSizes

See Also

Reference

BorderSizes Members
GrapeCity.ActiveReports.Chart Namespace


BorderSizes Class Members

BorderSizes Class Members
Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : BorderSizes Class

The following tables list the members exposed by BorderSizes.

Public Constructors
 | Name | Description
Public Constructor | BorderSizes Constructor | Overloaded. Initializes a new instance of the BorderSizes class.
Top
Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the margin between the inner and outer edges on the bottom side of a border.
Public Property | Left | Gets or sets the margin between the inner and outer edges on the left side of a border.
Public Property | Right | Gets or sets the margin between the inner and outer edges on the right side of a border.
Public Property | Top | Gets or sets the margin between the inner and outer edges on the top side of a border.
Top
See Also

Reference

BorderSizes Class
GrapeCity.ActiveReports.Chart Namespace


BorderSizes Constructor

BorderSizes Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BorderSizes Class : BorderSizes Constructor
Initializes a new instance of the BorderSizes class.
Overload List
Overload | Description
BorderSizes Constructor() | Initializes a new instance of the BorderSizes class.
BorderSizes Constructor(Single,Single,Single,Single) | Initializes a new instance of the BorderSizes class with the border margins specified.
See Also

Reference

BorderSizes Class
BorderSizes Members


BorderSizes Constructor()

BorderSizes Constructor()

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BorderSizes Class > BorderSizes Constructor : BorderSizes Constructor()
Initializes a new instance of the BorderSizes class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public BorderSizes()
See Also

Reference

BorderSizes Class
BorderSizes Members
Overload List


BorderSizes Constructor(Single,Single,Single,Single)

BorderSizes Constructor(Single,Single,Single,Single)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BorderSizes Class > BorderSizes Constructor : BorderSizes Constructor(Single,Single,Single,Single)
Specifies the left border margin.
Specifies the right border margin.
Specifies the top border margin.
Specifies the bottom border margin.
Initializes a new instance of the BorderSizes class with the border margins specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal left As System.Single, _
   ByVal right As System.Single, _
   ByVal top As System.Single, _
   ByVal bottom As System.Single _
)
public BorderSizes(
   System.float left,
   System.float right,
   System.float top,
   System.float bottom
)

Parameters

left
Specifies the left border margin.
right
Specifies the right border margin.
top
Specifies the top border margin.
bottom
Specifies the bottom border margin.
See Also

Reference

BorderSizes Class
BorderSizes Members
Overload List


BorderSizes Class Properties

BorderSizes Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : BorderSizes Class

For a list of all members of this type, see BorderSizes members.

Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the margin between the inner and outer edges on the bottom side of a border.
Public Property | Left | Gets or sets the margin between the inner and outer edges on the left side of a border.
Public Property | Right | Gets or sets the margin between the inner and outer edges on the right side of a border.
Public Property | Top | Gets or sets the margin between the inner and outer edges on the top side of a border.
Top
See Also

Reference

BorderSizes Class
GrapeCity.ActiveReports.Chart Namespace


Bottom Property (BorderSizes)

Bottom Property (BorderSizes)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BorderSizes Class : Bottom Property
Gets or sets the margin between the inner and outer edges on the bottom side of a border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Bottom As System.Single
public System.float Bottom {get; set;}
See Also

Reference

BorderSizes Class
BorderSizes Members


Left Property (BorderSizes)

Left Property (BorderSizes)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BorderSizes Class : Left Property
Gets or sets the margin between the inner and outer edges on the left side of a border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Left As System.Single
public System.float Left {get; set;}
See Also

Reference

BorderSizes Class
BorderSizes Members


Right Property (BorderSizes)

Right Property (BorderSizes)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BorderSizes Class : Right Property
Gets or sets the margin between the inner and outer edges on the right side of a border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Right As System.Single
public System.float Right {get; set;}
See Also

Reference

BorderSizes Class
BorderSizes Members


Top Property (BorderSizes)

Top Property (BorderSizes)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > BorderSizes Class : Top Property
Gets or sets the margin between the inner and outer edges on the top side of a border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Top As System.Single
public System.float Top {get; set;}
See Also

Reference

BorderSizes Class
BorderSizes Members


ChartArea Class

ChartArea Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartArea Class
Specifies the properties of the chart area.
Object Model
ChartArea Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ChartArea
   Inherits DrawCustomizableComponent
public sealed class ChartArea : DrawCustomizableComponent
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.ChartArea

See Also

Reference

ChartArea Members
GrapeCity.ActiveReports.Chart Namespace


ChartArea Class Members

ChartArea Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartArea Class

The following tables list the members exposed by ChartArea.

Public Constructors
 | Name | Description
Public Constructor | ChartArea Constructor | Overloaded. Initializes a new instance of the ChartArea class.
Top
Public Properties
 | Name | Description
Public Property | Axes | Gets the user-defined custom axes.
Public Property | Backdrop | Gets or sets the backdrop information used to draw the chart area.
Public Property | Border | Gets or sets the border information for the chart area.
Public Property | Light | Gets or sets the lighting information for the chart area.
Public Property | Padding | Gets or sets chart area's padding information.
Public Property | Projection | Gets or sets the geometric projection details for the chart area.
Public Property | SwapAxesDirection | Determines whether the chart axes are inverted. The default is false.
Public Property | ViewPoint | Gets or sets the point from which the chart is seen.
Public Property | WallRanges | Gets the wall ranges (strip lines) for the chart area.
Public Property | WallXY | Gets or sets the XY wall settings for the chart area.
Public Property | WallXZ | Gets or sets the XZ wall settings for the chart area.
Public Property | WallYZ | Gets or sets the YZ wall settings for the chart area.
Public Property | ZDepthRatio | Gets or sets the chart area depth, specified as the ratio of z to x.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the chart area.
Top
See Also

Reference

ChartArea Class
GrapeCity.ActiveReports.Chart Namespace


ChartArea Constructor

ChartArea Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : ChartArea Constructor
Initializes a new instance of the ChartArea class.
Overload List
Overload | Description
ChartArea Constructor() | Initializes a new instance of the ChartArea class without axes.
ChartArea Constructor(Boolean) | Initializes a new instance of the ChartArea class.
See Also

Reference

ChartArea Class
ChartArea Members


ChartArea Constructor()

ChartArea Constructor()

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class > ChartArea Constructor : ChartArea Constructor()
Initializes a new instance of the ChartArea class without axes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ChartArea()
See Also

Reference

ChartArea Class
ChartArea Members
Overload List


ChartArea Constructor(Boolean)

ChartArea Constructor(Boolean)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class > ChartArea Constructor : ChartArea Constructor(Boolean)
Specifies whether or not the axes should be initialized.
Initializes a new instance of the ChartArea class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal initializeAxes As System.Boolean _
)
public ChartArea(
   System.bool initializeAxes
)

Parameters

initializeAxes
Specifies whether or not the axes should be initialized.
See Also

Reference

ChartArea Class
ChartArea Members
Overload List


ChartArea Class Methods

ChartArea Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartArea Class

For a list of all members of this type, see ChartArea members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the chart area.
Top
See Also

Reference

ChartArea Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method (ChartArea)

Clone Method (ChartArea)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : Clone Method
Creates a clone of the chart area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

A clone of the ChartArea object.
See Also

Reference

ChartArea Class
ChartArea Members


ChartArea Class Properties

ChartArea Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartArea Class

For a list of all members of this type, see ChartArea members.

Public Properties
 | Name | Description
Public Property | Axes | Gets the user-defined custom axes.
Public Property | Backdrop | Gets or sets the backdrop information used to draw the chart area.
Public Property | Border | Gets or sets the border information for the chart area.
Public Property | Light | Gets or sets the lighting information for the chart area.
Public Property | Padding | Gets or sets chart area's padding information.
Public Property | Projection | Gets or sets the geometric projection details for the chart area.
Public Property | SwapAxesDirection | Determines whether the chart axes are inverted. The default is false.
Public Property | ViewPoint | Gets or sets the point from which the chart is seen.
Public Property | WallRanges | Gets the wall ranges (strip lines) for the chart area.
Public Property | WallXY | Gets or sets the XY wall settings for the chart area.
Public Property | WallXZ | Gets or sets the XZ wall settings for the chart area.
Public Property | WallYZ | Gets or sets the YZ wall settings for the chart area.
Public Property | ZDepthRatio | Gets or sets the chart area depth, specified as the ratio of z to x.
Top
See Also

Reference

ChartArea Class
GrapeCity.ActiveReports.Chart Namespace


Axes Property

Axes Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : Axes Property
Gets the user-defined custom axes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Axes As AxesCollection
public AxesCollection Axes {get;}
See Also

Reference

ChartArea Class
ChartArea Members


Backdrop Property (ChartArea)

Backdrop Property (ChartArea)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : Backdrop Property
Gets or sets the backdrop information used to draw the chart area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Backdrop As BackdropItem
public BackdropItem Backdrop {get; set;}
See Also

Reference

ChartArea Class
ChartArea Members


Border Property (ChartArea)

Border Property (ChartArea)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : Border Property
Gets or sets the border information for the chart area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Border As Border
public Border Border {get; set;}
See Also

Reference

ChartArea Class
ChartArea Members


Light Property

Light Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : Light Property
Gets or sets the lighting information for the chart area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Light As Light
public Light Light {get; set;}
See Also

Reference

ChartArea Class
ChartArea Members


Padding Property (ChartArea)

Padding Property (ChartArea)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : Padding Property
Gets or sets chart area's padding information.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Padding As Padding
public Padding Padding {get; set;}
See Also

Reference

ChartArea Class
ChartArea Members


Projection Property (ChartArea)

Projection Property (ChartArea)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : Projection Property
Gets or sets the geometric projection details for the chart area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Projection As Projection
public Projection Projection {get; set;}
See Also

Reference

ChartArea Class
ChartArea Members


SwapAxesDirection Property

SwapAxesDirection Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : SwapAxesDirection Property
Determines whether the chart axes are inverted. The default is false.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SwapAxesDirection As System.Boolean
public System.bool SwapAxesDirection {get; set;}

Property Value

Boolean. False if the chart is rendered with horizontal X and vertical Y axes; otherwise True.
See Also

Reference

ChartArea Class
ChartArea Members


ViewPoint Property

ViewPoint Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : ViewPoint Property
Gets or sets the point from which the chart is seen.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ViewPoint As Point3d
public Point3d ViewPoint {get; set;}
See Also

Reference

ChartArea Class
ChartArea Members


WallRanges Property

WallRanges Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : WallRanges Property
Gets the wall ranges (strip lines) for the chart area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property WallRanges As WallRangesCollection
public WallRangesCollection WallRanges {get;}
See Also

Reference

ChartArea Class
ChartArea Members


WallXY Property

WallXY Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : WallXY Property
Gets or sets the XY wall settings for the chart area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WallXY As PlaneItem
public PlaneItem WallXY {get; set;}
See Also

Reference

ChartArea Class
ChartArea Members


WallXZ Property

WallXZ Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : WallXZ Property
Gets or sets the XZ wall settings for the chart area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WallXZ As PlaneItem
public PlaneItem WallXZ {get; set;}
See Also

Reference

ChartArea Class
ChartArea Members


WallYZ Property

WallYZ Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : WallYZ Property
Gets or sets the YZ wall settings for the chart area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WallYZ As PlaneItem
public PlaneItem WallYZ {get; set;}
See Also

Reference

ChartArea Class
ChartArea Members


ZDepthRatio Property

ZDepthRatio Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartArea Class : ZDepthRatio Property
Gets or sets the chart area depth, specified as the ratio of z to x.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ZDepthRatio As System.Single
public System.float ZDepthRatio {get; set;}
See Also

Reference

ChartArea Class
ChartArea Members


ChartAreasCollection Class

ChartAreasCollection Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartAreasCollection Class
Specifies the settings for the chart areas collection.
Object Model
ChartAreasCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ChartAreasCollection
   Inherits System.Collections.CollectionBase
public sealed class ChartAreasCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.ChartAreasCollection

See Also

Reference

ChartAreasCollection Members
GrapeCity.ActiveReports.Chart Namespace


ChartAreasCollection Class Members

ChartAreasCollection Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartAreasCollection Class

The following tables list the members exposed by ChartAreasCollection.

Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Gets or sets the specified chart area in the collection.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a chart area to the collection.
Public Method | AddRange | Adds a set of chart areas to the collection.
Public Method | Clear | Clears all items from the collection.
Public Method | Clone | Creates a clone of the chart areas collection.
Public Method | Contains | Determines whether the collection contains the specified ChartArea.
Public Method | CopyTo | Copies the collection to an array, starting at the specified index.
Public Method | Dispose | Releases resources associated with this object.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts the specified chart area into the collection at the specified index.
Public Method | Remove | Removes the specified chart area from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ChartAreasCollection Class
GrapeCity.ActiveReports.Chart Namespace


ChartAreasCollection Class Methods

ChartAreasCollection Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartAreasCollection Class

For a list of all members of this type, see ChartAreasCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a chart area to the collection.
Public Method | AddRange | Adds a set of chart areas to the collection.
Public Method | Clear | Clears all items from the collection.
Public Method | Clone | Creates a clone of the chart areas collection.
Public Method | Contains | Determines whether the collection contains the specified ChartArea.
Public Method | CopyTo | Copies the collection to an array, starting at the specified index.
Public Method | Dispose | Releases resources associated with this object.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts the specified chart area into the collection at the specified index.
Public Method | Remove | Removes the specified chart area from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ChartAreasCollection Class
GrapeCity.ActiveReports.Chart Namespace


Add Method (ChartAreasCollection)

Add Method (ChartAreasCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : Add Method
The chart area to add.
Adds a chart area to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As ChartArea _
) As System.Integer
public System.int Add(
   ChartArea value
)

Parameters

value
The chart area to add.
See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


AddRange Method (ChartAreasCollection)

AddRange Method (ChartAreasCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : AddRange Method
The chart areas to add to the collection.
Adds a set of chart areas to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddRange( _
   ByVal areas() As ChartArea _
)
public void AddRange(
   ChartArea[] areas
)

Parameters

areas
The chart areas to add to the collection.
See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


Clear Method (ChartAreasCollection)

Clear Method (ChartAreasCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : Clear Method
Clears all items from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Sub Clear()
public new void Clear()
See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


Clone Method (ChartAreasCollection)

Clone Method (ChartAreasCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : Clone Method

Creates a clone of the chart areas collection.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Clone() As System.Object
public System.object Clone()
See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


Contains Method (ChartAreasCollection)

Contains Method (ChartAreasCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : Contains Method
The chart area to find in the collection.
Determines whether the collection contains the specified ChartArea.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal value As ChartArea _
) As System.Boolean
public System.bool Contains(
   ChartArea value
)

Parameters

value
The chart area to find in the collection.

Return Value

Boolean. True if the collection contains the specified ChartArea; otherwise False.
See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


CopyTo Method (ChartAreasCollection)

CopyTo Method (ChartAreasCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : CopyTo Method
The array to which to copy the collection.
The index from which to start.
Copies the collection to an array, starting at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal array() As ChartArea, _
   ByVal index As System.Integer _
)
public void CopyTo(
   ChartArea[] array,
   System.int index
)

Parameters

array
The array to which to copy the collection.
index
The index from which to start.
See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


Dispose Method (ChartAreasCollection)

Dispose Method (ChartAreasCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : Dispose Method
Releases resources associated with this object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


IndexOf Method (ChartAreasCollection)

IndexOf Method (ChartAreasCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : IndexOf Method
The object to locate in the collection.
Returns the index of the first occurrence of a value in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As ChartArea _
) As System.Integer
public System.int IndexOf(
   ChartArea value
)

Parameters

value
The object to locate in the collection.

Return Value

The index of the first occurrence of value within the entire array, if found; otherwise, the lower bound of the array - 1.
See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


Insert Method (ChartAreasCollection)

Insert Method (ChartAreasCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : Insert Method
The index at which to insert the chart area.
The ChartArea to insert.
Inserts the specified chart area into the collection at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As ChartArea _
)
public void Insert(
   System.int index,
   ChartArea value
)

Parameters

index
The index at which to insert the chart area.
value
The ChartArea to insert.
See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


Remove Method (ChartAreasCollection)

Remove Method (ChartAreasCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : Remove Method
The chart area to remove.
Removes the specified chart area from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As ChartArea _
)
public void Remove(
   ChartArea value
)

Parameters

value
The chart area to remove.
See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


ChartAreasCollection Class Properties

ChartAreasCollection Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartAreasCollection Class

For a list of all members of this type, see ChartAreasCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Gets or sets the specified chart area in the collection.
Top
See Also

Reference

ChartAreasCollection Class
GrapeCity.ActiveReports.Chart Namespace


Item Property (ChartAreasCollection)

Item Property (ChartAreasCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : Item Property
Gets or sets the specified chart area in the collection.
Overload List
Overload | Description
Item(Int32) | Gets or sets the chart area at the specified index.
Item(String) | Gets the index of the chart area with the specified name in the collection.
See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


Item(Int32) Property

Item(Int32) Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class > Item Property : Item(Int32) Property
The index of the chart area.
Gets or sets the chart area at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Property Item( _
   ByVal index As System.Integer _
) As ChartArea
public ChartArea Item(
   System.int index
) {get; set;}

Parameters

index
The index of the chart area.
See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members
Overload List


Item(String) Property

Item(String) Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class > Item Property : Item(String) Property
The name of the ChartArea.
Gets the index of the chart area with the specified name in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal chartAreaName As System.String _
) As ChartArea
public ChartArea Item(
   System.string chartAreaName
) {get;}

Parameters

chartAreaName
The name of the ChartArea.

Property Value

ChartArea.
See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members
Overload List


ChartTypeConfig Class

ChartTypeConfig Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartTypeConfig Class
Represents the settings for the ChartTypeConfig object.
Object Model
ChartTypeConfig Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ChartTypeConfig
public sealed class ChartTypeConfig
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.ChartTypeConfig

See Also

Reference

ChartTypeConfig Members
GrapeCity.ActiveReports.Chart Namespace


ChartTypeConfig Class Members

ChartTypeConfig Class Members
Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartTypeConfig Class

The following tables list the members exposed by ChartTypeConfig.

Public Properties
 | Name | Description
Public Property | ApplyColorPaletteOnDataPoint | Gets a value indicating whether the color palette is applied to the data point.
Public Property | CoreRendererType | Gets the core renderer type for the chart.
Public Property | CoreStyleType | Gets the core style type for the chart.
Public Property | IsCategorical | Gets a value indicating whether the chart is categorical.
Public Property | IsXY | Gets a value indicating whether the chart is an XY chart.
Public Property | PropertiesTypes | Gets the property types for the chart.
Public Property | RequiredSeriesCount | Gets the count of required series for the chart.
Top
See Also

Reference

ChartTypeConfig Class
GrapeCity.ActiveReports.Chart Namespace


ChartTypeConfig Class Properties

ChartTypeConfig Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartTypeConfig Class

For a list of all members of this type, see ChartTypeConfig members.

Public Properties
 | Name | Description
Public Property | ApplyColorPaletteOnDataPoint | Gets a value indicating whether the color palette is applied to the data point.
Public Property | CoreRendererType | Gets the core renderer type for the chart.
Public Property | CoreStyleType | Gets the core style type for the chart.
Public Property | IsCategorical | Gets a value indicating whether the chart is categorical.
Public Property | IsXY | Gets a value indicating whether the chart is an XY chart.
Public Property | PropertiesTypes | Gets the property types for the chart.
Public Property | RequiredSeriesCount | Gets the count of required series for the chart.
Top
See Also

Reference

ChartTypeConfig Class
GrapeCity.ActiveReports.Chart Namespace


ApplyColorPaletteOnDataPoint Property

ApplyColorPaletteOnDataPoint Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartTypeConfig Class : ApplyColorPaletteOnDataPoint Property
Gets a value indicating whether the color palette is applied to the data point.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ApplyColorPaletteOnDataPoint As System.Boolean
public System.bool ApplyColorPaletteOnDataPoint {get;}

Property Value

Boolean. True if the color palette is applied to the data point; otherwise False.
See Also

Reference

ChartTypeConfig Class
ChartTypeConfig Members


CoreRendererType Property

CoreRendererType Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartTypeConfig Class : CoreRendererType Property
Gets the core renderer type for the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CoreRendererType As System.Type
public System.Type CoreRendererType {get;}
See Also

Reference

ChartTypeConfig Class
ChartTypeConfig Members


CoreStyleType Property

CoreStyleType Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartTypeConfig Class : CoreStyleType Property
Gets the core style type for the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CoreStyleType As System.Type
public System.Type CoreStyleType {get;}
See Also

Reference

ChartTypeConfig Class
ChartTypeConfig Members


IsCategorical Property

IsCategorical Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartTypeConfig Class : IsCategorical Property
Gets a value indicating whether the chart is categorical.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsCategorical As System.Boolean
public System.bool IsCategorical {get;}

Property Value

Boolean. True if the chart is categorical; otherwise False.
See Also

Reference

ChartTypeConfig Class
ChartTypeConfig Members


IsXY Property

IsXY Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartTypeConfig Class : IsXY Property
Gets a value indicating whether the chart is an XY chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsXY As System.Boolean
public System.bool IsXY {get;}

Property Value

Boolean. True if the chart is an XY chart; otherwise False.
See Also

Reference

ChartTypeConfig Class
ChartTypeConfig Members


PropertiesTypes Property

PropertiesTypes Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartTypeConfig Class : PropertiesTypes Property
Gets the property types for the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PropertiesTypes As KeyValuePair()
public KeyValuePair[] PropertiesTypes {get;}
See Also

Reference

ChartTypeConfig Class
ChartTypeConfig Members


RequiredSeriesCount Property

RequiredSeriesCount Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartTypeConfig Class : RequiredSeriesCount Property
Gets the count of required series for the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property RequiredSeriesCount As System.Integer
public System.int RequiredSeriesCount {get;}
See Also

Reference

ChartTypeConfig Class
ChartTypeConfig Members


CustomAxis Class

CustomAxis Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : CustomAxis Class
Represents the properties of a custom axis.
Object Model
CustomAxis Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class CustomAxis
   Inherits AxisBase
public sealed class CustomAxis : AxisBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.AxisBase
GrapeCity.ActiveReports.Chart.CustomAxis

See Also

Reference

CustomAxis Members
GrapeCity.ActiveReports.Chart Namespace


CustomAxis Class Members

CustomAxis Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : CustomAxis Class

The following tables list the members exposed by CustomAxis.

Public Constructors
 | Name | Description
Public Constructor | CustomAxis Constructor | Initializes a new instance of the CustomAxis class.
Top
Public Properties
 | Name | Description
Public Property | Arrow | Gets or sets the arrow type on the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | AxisType | Gets or sets the axis type. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | DisplayScale | Gets or sets a value indicating whether to display the scale value on the title of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | LabelFont | Gets or sets the font info used to draw the labels of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | LabelFormat | Gets or sets the format used to output the values of the labels. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Labels | Gets the contents of the labels collection, used for categorical axes. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | LabelsAtBottom | Gets or sets a value to render axis labels, tickmarks and secondary axes at the bottom of the axis, regardless the Position property. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | LabelsGap | Gets or sets a value indicating how many labels to skip on the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | LabelsInside | Gets or sets the position of labels against the axis line. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | LabelsVisible | Gets or sets a value indicating whether axis labels will be drawn on the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Line | Gets or sets the line used to draw the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | MajorTick | Gets or sets the major tick of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Max | Gets or sets the maximum value for the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | MaxDerived | Gets or sets a value indicating whether the axis automatically calculates its maximum value based on its position against the parent axis.
Public Property | Min | Gets or sets the minimum value for the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | MinDerived | Gets or sets a value indicating whether the axis automatically calculates its minimum value based on its position against the parent axis.
Public Property | MinorTick | Gets or sets the minor tick of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Parent | Gets or sets the main axis (X, Y or Z) on which to draw the custom axis.
Public Property | PlacementLength | Gets or sets the length of the custom axis in terms of its parent axis.
Public Property | PlacementLocation | Gets or sets the position of the origin of the custom axis in terms of its parent axis.
Public Property | Position | Gets or sets the position along the adjacent axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Scale | Gets or sets the scale value used to draw labels. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | SmartLabels | Gets or sets a value indicating whether smart labels are enabled on the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | StaggerLabels | Gets or sets a value indicating whether labels on the axis are staggered. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | TickOffset | Gets or sets the offset of the first tick from the Min value of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Title | Gets or sets the text string for the title of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | TitleFont | Gets or sets the font information used to draw the title of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Visible | Gets or sets a value indicating whether the axis is visible. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the custom axis.
Top
See Also

Reference

CustomAxis Class
GrapeCity.ActiveReports.Chart Namespace


CustomAxis Constructor

CustomAxis Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomAxis Class : CustomAxis Constructor
Initializes a new instance of the CustomAxis class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public CustomAxis()
See Also

Reference

CustomAxis Class
CustomAxis Members


CustomAxis Class Methods

CustomAxis Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : CustomAxis Class

For a list of all members of this type, see CustomAxis members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the custom axis.
Top
See Also

Reference

CustomAxis Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method (CustomAxis)

Clone Method (CustomAxis)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomAxis Class : Clone Method
Creates a clone of the custom axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

A clone of the CustomAxis object.
See Also

Reference

CustomAxis Class
CustomAxis Members


CustomAxis Class Properties

CustomAxis Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : CustomAxis Class

For a list of all members of this type, see CustomAxis members.

Public Properties
 | Name | Description
Public Property | Arrow | Gets or sets the arrow type on the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | AxisType | Gets or sets the axis type. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | DisplayScale | Gets or sets a value indicating whether to display the scale value on the title of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | LabelFont | Gets or sets the font info used to draw the labels of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | LabelFormat | Gets or sets the format used to output the values of the labels. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Labels | Gets the contents of the labels collection, used for categorical axes. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | LabelsAtBottom | Gets or sets a value to render axis labels, tickmarks and secondary axes at the bottom of the axis, regardless the Position property. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | LabelsGap | Gets or sets a value indicating how many labels to skip on the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | LabelsInside | Gets or sets the position of labels against the axis line. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | LabelsVisible | Gets or sets a value indicating whether axis labels will be drawn on the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Line | Gets or sets the line used to draw the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | MajorTick | Gets or sets the major tick of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Max | Gets or sets the maximum value for the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | MaxDerived | Gets or sets a value indicating whether the axis automatically calculates its maximum value based on its position against the parent axis.
Public Property | Min | Gets or sets the minimum value for the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | MinDerived | Gets or sets a value indicating whether the axis automatically calculates its minimum value based on its position against the parent axis.
Public Property | MinorTick | Gets or sets the minor tick of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Parent | Gets or sets the main axis (X, Y or Z) on which to draw the custom axis.
Public Property | PlacementLength | Gets or sets the length of the custom axis in terms of its parent axis.
Public Property | PlacementLocation | Gets or sets the position of the origin of the custom axis in terms of its parent axis.
Public Property | Position | Gets or sets the position along the adjacent axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Scale | Gets or sets the scale value used to draw labels. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | SmartLabels | Gets or sets a value indicating whether smart labels are enabled on the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | StaggerLabels | Gets or sets a value indicating whether labels on the axis are staggered. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | TickOffset | Gets or sets the offset of the first tick from the Min value of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Title | Gets or sets the text string for the title of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | TitleFont | Gets or sets the font information used to draw the title of the axis. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Public Property | Visible | Gets or sets a value indicating whether the axis is visible. (Inherited from GrapeCity.ActiveReports.Chart.AxisBase)
Top
See Also

Reference

CustomAxis Class
GrapeCity.ActiveReports.Chart Namespace


MaxDerived Property

MaxDerived Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomAxis Class : MaxDerived Property
Gets or sets a value indicating whether the axis automatically calculates its maximum value based on its position against the parent axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaxDerived As System.Boolean
public System.bool MaxDerived {get; set;}
See Also

Reference

CustomAxis Class
CustomAxis Members


MinDerived Property

MinDerived Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomAxis Class : MinDerived Property
Gets or sets a value indicating whether the axis automatically calculates its minimum value based on its position against the parent axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinDerived As System.Boolean
public System.bool MinDerived {get; set;}
See Also

Reference

CustomAxis Class
CustomAxis Members


Parent Property (CustomAxis)

Parent Property (CustomAxis)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomAxis Class : Parent Property
Gets or sets the main axis (X, Y or Z) on which to draw the custom axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Property Parent As Axis
public new Axis Parent {get; set;}
See Also

Reference

CustomAxis Class
CustomAxis Members


PlacementLength Property

PlacementLength Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomAxis Class : PlacementLength Property
Gets or sets the length of the custom axis in terms of its parent axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PlacementLength As System.Double
public System.double PlacementLength {get; set;}
See Also

Reference

CustomAxis Class
CustomAxis Members


PlacementLocation Property

PlacementLocation Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomAxis Class : PlacementLocation Property
Gets or sets the position of the origin of the custom axis in terms of its parent axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PlacementLocation As System.Double
public System.double PlacementLocation {get; set;}
See Also

Reference

CustomAxis Class
CustomAxis Members


CustomDrawEventArgs Class

CustomDrawEventArgs Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : CustomDrawEventArgs Class
Represents the properties of the custom draw event arguments for the chart.
Object Model
CustomDrawEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class CustomDrawEventArgs
   Inherits System.EventArgs
public sealed class CustomDrawEventArgs : System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Chart.CustomDrawEventArgs

See Also

Reference

CustomDrawEventArgs Members
GrapeCity.ActiveReports.Chart Namespace


CustomDrawEventArgs Class Members

CustomDrawEventArgs Class Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : CustomDrawEventArgs Class

The following tables list the members exposed by CustomDrawEventArgs.

Public Constructors
 | Name | Description
Public Constructor | CustomDrawEventArgs Constructor | Initializes a new instance of the CustomDrawEventArgs class.
Top
See Also

Reference

CustomDrawEventArgs Class
GrapeCity.ActiveReports.Chart Namespace


CustomDrawEventArgs Constructor

CustomDrawEventArgs Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomDrawEventArgs Class : CustomDrawEventArgs Constructor
Initializes a new instance of the CustomDrawEventArgs class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public CustomDrawEventArgs()
See Also

Reference

CustomDrawEventArgs Class
CustomDrawEventArgs Members


CustomProperties Class

CustomProperties Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : CustomProperties Class
Represents the set of custom properties for the chart.
Object Model
CustomProperties Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class CustomProperties
   Inherits Item
public sealed class CustomProperties : Item
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.CustomProperties

See Also

Reference

CustomProperties Members
GrapeCity.ActiveReports.Chart Namespace


CustomProperties Class Members

CustomProperties Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : CustomProperties Class

The following tables list the members exposed by CustomProperties.

Public Constructors
 | Name | Description
Public Constructor | CustomProperties Constructor | Overloaded. Initializes a new instance of the CustomProperties class.
Top
Public Properties
 | Name | Description
Public Property | Item | Gets or sets the specified item as a custom attribute.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the custom attributes.
Public Method | Equals | Compares the CustomAttributes object to another System.Object to see if they are equal.
Public Method | GetAttributes | Gets the attributes collection of the custom properties object.
Public Method | GetClassName | Gets the class name as string of the custom attributes object.
Public Method | GetComponentName | Gets the component name as string of the custom attributes object.
Public Method | GetDefaultEvent | Returns the default event for this object.
Public Method | GetDefaultProperty | Returns the default property for this object.
Public Method | GetEvents | Overloaded. Gets the events that are declared or inherited by the current attributes.
Public Method | GetProperties | Overloaded. Gets the properties for this instance of a component.
Public Method | GetPropertyOwner | Returns the object of which this value is a member.
Top
See Also

Reference

CustomProperties Class
GrapeCity.ActiveReports.Chart Namespace


CustomProperties Constructor

CustomProperties Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : CustomProperties Constructor
Initializes a new instance of the CustomProperties class.
Overload List
Overload | Description
CustomProperties Constructor() | Initializes a new instance of the CustomProperties class.
CustomProperties Constructor(KeyValuePair[]) | Initializes a new instance of the CustomProperties class with the KeyValuePair array specified.
See Also

Reference

CustomProperties Class
CustomProperties Members


CustomProperties Constructor()

CustomProperties Constructor()

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class > CustomProperties Constructor : CustomProperties Constructor()
Initializes a new instance of the CustomProperties class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public CustomProperties()
See Also

Reference

CustomProperties Class
CustomProperties Members
Overload List


CustomProperties Constructor(KeyValuePair[])

CustomProperties Constructor(KeyValuePair[])

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class > CustomProperties Constructor : CustomProperties Constructor(KeyValuePair[])
The array of string attribute values.
Initializes a new instance of the CustomProperties class with the KeyValuePair array specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal initialValues() As KeyValuePair _
)
public CustomProperties(
   KeyValuePair[] initialValues
)

Parameters

initialValues
The array of string attribute values.
See Also

Reference

CustomProperties Class
CustomProperties Members
Overload List


CustomProperties Class Methods

CustomProperties Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : CustomProperties Class

For a list of all members of this type, see CustomProperties members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the custom attributes.
Public Method | Equals | Compares the CustomAttributes object to another System.Object to see if they are equal.
Public Method | GetAttributes | Gets the attributes collection of the custom properties object.
Public Method | GetClassName | Gets the class name as string of the custom attributes object.
Public Method | GetComponentName | Gets the component name as string of the custom attributes object.
Public Method | GetDefaultEvent | Returns the default event for this object.
Public Method | GetDefaultProperty | Returns the default property for this object.
Public Method | GetEvents | Overloaded. Gets the events that are declared or inherited by the current attributes.
Public Method | GetProperties | Overloaded. Gets the properties for this instance of a component.
Public Method | GetPropertyOwner | Returns the object of which this value is a member.
Top
See Also

Reference

CustomProperties Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method (CustomProperties)

Clone Method (CustomProperties)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : Clone Method
Creates a clone of the custom attributes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

System.Object.
See Also

Reference

CustomProperties Class
CustomProperties Members


Equals Method (CustomProperties)

Equals Method (CustomProperties)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : Equals Method
The System.Object to which the CustomAttributes object is being compared.
Compares the CustomAttributes object to another System.Object to see if they are equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The System.Object to which the CustomAttributes object is being compared.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.
See Also

Reference

CustomProperties Class
CustomProperties Members


GetAttributes Method

GetAttributes Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : GetAttributes Method
Gets the attributes collection of the custom properties object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetAttributes() As System.ComponentModel.AttributeCollection
public System.ComponentModel.AttributeCollection GetAttributes()

Return Value

An System.ComponentModel.AttributeCollection containing the attributes for this object.
See Also

Reference

CustomProperties Class
CustomProperties Members


GetClassName Method

GetClassName Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : GetClassName Method
Gets the class name as string of the custom attributes object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetClassName() As System.String
public System.string GetClassName()

Return Value

The class name of the object, or null if the class does not have a name.
See Also

Reference

CustomProperties Class
CustomProperties Members


GetComponentName Method

GetComponentName Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : GetComponentName Method
Gets the component name as string of the custom attributes object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetComponentName() As System.String
public System.string GetComponentName()

Return Value

The name of the object, or null if the object does not have a name.
See Also

Reference

CustomProperties Class
CustomProperties Members


GetDefaultEvent Method

GetDefaultEvent Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : GetDefaultEvent Method
Returns the default event for this object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetDefaultEvent() As System.ComponentModel.EventDescriptor
public System.ComponentModel.EventDescriptor GetDefaultEvent()

Return Value

An System.ComponentModel.EventDescriptor that represents the default event for this object, or null if this object does not have events.
See Also

Reference

CustomProperties Class
CustomProperties Members


GetDefaultProperty Method

GetDefaultProperty Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : GetDefaultProperty Method
Returns the default property for this object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetDefaultProperty() As System.ComponentModel.PropertyDescriptor
public System.ComponentModel.PropertyDescriptor GetDefaultProperty()

Return Value

A System.ComponentModel.PropertyDescriptor that represents the default property for this object, or null if this object does not have properties.
See Also

Reference

CustomProperties Class
CustomProperties Members


GetEvents Method

GetEvents Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : GetEvents Method
Gets the events that are declared or inherited by the current attributes.
Overload List
Overload | Description
GetEvents(Attribute[]) | Gets the event descriptor collection for the specified custom attributes array.
GetEvents() | Gets the event descriptor collection of the custom attributes object.
See Also

Reference

CustomProperties Class
CustomProperties Members


GetEvents(Attribute[]) Method

GetEvents(Attribute[]) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class > GetEvents Method : GetEvents(Attribute[]) Method
The attributes array.
Gets the event descriptor collection for the specified custom attributes array.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetEvents( _
   ByVal attributes() As System.Attribute _
) As System.ComponentModel.EventDescriptorCollection
public System.ComponentModel.EventDescriptorCollection GetEvents(
   System.Attribute[] attributes
)

Parameters

attributes
The attributes array.

Return Value

An System.ComponentModel.EventDescriptorCollection that represents the filtered events for this component instance.
See Also

Reference

CustomProperties Class
CustomProperties Members
Overload List


GetEvents() Method

GetEvents() Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class > GetEvents Method : GetEvents() Method
Gets the event descriptor collection of the custom attributes object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetEvents() As System.ComponentModel.EventDescriptorCollection
public System.ComponentModel.EventDescriptorCollection GetEvents()

Return Value

An System.ComponentModel.EventDescriptorCollection that represents the events for this component instance.
See Also

Reference

CustomProperties Class
CustomProperties Members
Overload List


GetProperties Method

GetProperties Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : GetProperties Method
Gets the properties for this instance of a component.
Overload List
Overload | Description
GetProperties(Attribute[]) | Gets the properties for this instance of a component.
GetProperties() | Gets the properties for this instance of a component.
See Also

Reference

CustomProperties Class
CustomProperties Members


GetProperties(Attribute[]) Method

GetProperties(Attribute[]) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class > GetProperties Method : GetProperties(Attribute[]) Method
The attributes array.
Gets the properties for this instance of a component.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetProperties( _
   ByVal attributes() As System.Attribute _
) As System.ComponentModel.PropertyDescriptorCollection
public System.ComponentModel.PropertyDescriptorCollection GetProperties(
   System.Attribute[] attributes
)

Parameters

attributes
The attributes array.

Return Value

A System.ComponentModel.PropertyDescriptorCollection that represents the filtered properties for this component instance.
See Also

Reference

CustomProperties Class
CustomProperties Members
Overload List


GetProperties() Method

GetProperties() Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class > GetProperties Method : GetProperties() Method
Gets the properties for this instance of a component.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetProperties() As System.ComponentModel.PropertyDescriptorCollection
public System.ComponentModel.PropertyDescriptorCollection GetProperties()

Return Value

A System.ComponentModel.PropertyDescriptorCollection that represents the properties for this component instance.
See Also

Reference

CustomProperties Class
CustomProperties Members
Overload List


GetPropertyOwner Method

GetPropertyOwner Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : GetPropertyOwner Method

A property descriptor that represents the property whose owner is to be found.

Returns the object of which this value is a member.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetPropertyOwner( _
   ByVal pd As System.ComponentModel.PropertyDescriptor _
) As System.Object
public System.object GetPropertyOwner(
   System.ComponentModel.PropertyDescriptor pd
)

Parameters

pd

A property descriptor that represents the property whose owner is to be found.

Return Value

An System.Object that represents the owner of the specified property.
See Also

Reference

CustomProperties Class
CustomProperties Members


CustomProperties Class Properties

CustomProperties Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : CustomProperties Class

For a list of all members of this type, see CustomProperties members.

Public Properties
 | Name | Description
Public Property | Item | Gets or sets the specified item as a custom attribute.
Top
See Also

Reference

CustomProperties Class
GrapeCity.ActiveReports.Chart Namespace


Item Property (CustomProperties)

Item Property (CustomProperties)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > CustomProperties Class : Item Property
The property name as string.
Gets or sets the specified item as a custom attribute.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal propertyName As System.String _
) As System.Object
public System.object this[
   System.string propertyName
]; {get; set;}

Parameters

propertyName
The property name as string.
See Also

Reference

CustomProperties Class
CustomProperties Members


DataPoint Class

DataPoint Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : DataPoint Class
Represents the set of properties for a data point.
Object Model
DataPoint Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DataPoint
   Inherits Item
public sealed class DataPoint : Item
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.DataPoint

See Also

Reference

DataPoint Members
GrapeCity.ActiveReports.Chart Namespace


DataPoint Class Members

DataPoint Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : DataPoint Class

The following tables list the members exposed by DataPoint.

Public Constructors
 | Name | Description
Public Constructor | DataPoint Constructor | Overloaded. Initializes a new instance of the DataPoint class.
Top
Public Properties
 | Name | Description
Public Property | Backdrop | Gets or sets the backdrop information for the DataPoint.
Public Property | BorderLine | Gets or sets the line information for the border line of the DataPoint.
Public Property | DisplayInLegend | Gets or sets a value indicating whether to display the data point in the legend.
Public Property | IsEmpty | Gets or sets a value indicating whether the DataPoint is empty.
Public Property | LegendText | Gets or sets the text as string to display for the DataPoint in the legend.
Public Property | Line | Gets or sets the line information for the line of the DataPoint.
Public Property | Marker | Gets or sets the marker information for the DataPoint.
Public Property | Properties | Gets or sets the custom properties for the DataPoint.
Public Property | Tooltip | Gets or sets the tooltip text as string for the DataPoint.
Public Property | XValue | Gets or sets the X value for the DataPoint.
Public Property | YValues | Gets or sets the Y values for the DataPoint.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the DataPoint.
Top
See Also

Reference

DataPoint Class
GrapeCity.ActiveReports.Chart Namespace


DataPoint Constructor

DataPoint Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : DataPoint Constructor
Initializes a new instance of the DataPoint class.
Overload List
Overload | Description
DataPoint Constructor() | Initializes a new instance of the DataPoint class.
DataPoint Constructor(Object,DoubleArray,Boolean) | Initializes a new instance of the DataPoint class with the parameters specified.
DataPoint Constructor(Object,DoubleArray,Boolean,Boolean,String) | Initializes a new instance of the DataPoint class with the parameters specified.
DataPoint Constructor(Object,DoubleArray,Boolean,CustomProperties) | Initializes a new instance of the DataPoint class with the parameters specified.
DataPoint Constructor(Object,DoubleArray,Boolean,CustomProperties,Boolean,String) | Initializes a new instance of the DataPoint class with the parameters specified.
See Also

Reference

DataPoint Class
DataPoint Members


DataPoint Constructor()

DataPoint Constructor()

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class > DataPoint Constructor : DataPoint Constructor()
Initializes a new instance of the DataPoint class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DataPoint()
See Also

Reference

DataPoint Class
DataPoint Members
Overload List


DataPoint Constructor(Object,DoubleArray,Boolean)

DataPoint Constructor(Object,DoubleArray,Boolean)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class > DataPoint Constructor : DataPoint Constructor(Object,DoubleArray,Boolean)
Specifies the x value.
The y values for the DataPoint.
Specifies whether the DataPoint is empty.
Initializes a new instance of the DataPoint class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal xValue As System.Object, _
   ByVal yValues As DoubleArray, _
   ByVal isEmpty As System.Boolean _
)
public DataPoint(
   System.object xValue,
   DoubleArray yValues,
   System.bool isEmpty
)

Parameters

xValue
Specifies the x value.
yValues
The y values for the DataPoint.
isEmpty
Specifies whether the DataPoint is empty.
See Also

Reference

DataPoint Class
DataPoint Members
Overload List


DataPoint Constructor(Object,DoubleArray,Boolean,Boolean,String)

DataPoint Constructor(Object,DoubleArray,Boolean,Boolean,String)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class > DataPoint Constructor : DataPoint Constructor(Object,DoubleArray,Boolean,Boolean,String)
Specifies the x value.
The y values for the DataPoint.
Specifies whether the DataPoint is empty.
Specifies whether the DataPoint information should be displayed in the legend.

Specifies the text as string to display for the DataPoint in the legend.

Initializes a new instance of the DataPoint class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal xValue As System.Object, _
   ByVal yValues As DoubleArray, _
   ByVal isEmpty As System.Boolean, _
   ByVal displayInLegend As System.Boolean, _
   ByVal legendText As System.String _
)
public DataPoint(
   System.object xValue,
   DoubleArray yValues,
   System.bool isEmpty,
   System.bool displayInLegend,
   System.string legendText
)

Parameters

xValue
Specifies the x value.
yValues
The y values for the DataPoint.
isEmpty
Specifies whether the DataPoint is empty.
displayInLegend
Specifies whether the DataPoint information should be displayed in the legend.
legendText

Specifies the text as string to display for the DataPoint in the legend.

See Also

Reference

DataPoint Class
DataPoint Members
Overload List


DataPoint Constructor(Object,DoubleArray,Boolean,CustomProperties)

DataPoint Constructor(Object,DoubleArray,Boolean,CustomProperties)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class > DataPoint Constructor : DataPoint Constructor(Object,DoubleArray,Boolean,CustomProperties)
Specifies the x value.
The y values for the DataPoint.
Specifies whether the DataPoint is empty.
Specifies the custom properties for the DataPoint.
Initializes a new instance of the DataPoint class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal xValue As System.Object, _
   ByVal yValues As DoubleArray, _
   ByVal isEmpty As System.Boolean, _
   ByVal properties As CustomProperties _
)
public DataPoint(
   System.object xValue,
   DoubleArray yValues,
   System.bool isEmpty,
   CustomProperties properties
)

Parameters

xValue
Specifies the x value.
yValues
The y values for the DataPoint.
isEmpty
Specifies whether the DataPoint is empty.
properties
Specifies the custom properties for the DataPoint.
See Also

Reference

DataPoint Class
DataPoint Members
Overload List


DataPoint Constructor(Object,DoubleArray,Boolean,CustomProperties,Boolean,String)

DataPoint Constructor(Object,DoubleArray,Boolean,CustomProperties,Boolean,String)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class > DataPoint Constructor : DataPoint Constructor(Object,DoubleArray,Boolean,CustomProperties,Boolean,String)
Specifies the x value.
The y values for the DataPoint.
Specifies whether the DataPoint is empty.
Specifies the custom properties for the DataPoint.
Specifies whether the DataPoint information should be displayed in the legend.

Specifies the text as string to display for the DataPoint in the legend.

Initializes a new instance of the DataPoint class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal xValue As System.Object, _
   ByVal yValues As DoubleArray, _
   ByVal isEmpty As System.Boolean, _
   ByVal properties As CustomProperties, _
   ByVal displayInLegend As System.Boolean, _
   ByVal legendText As System.String _
)
public DataPoint(
   System.object xValue,
   DoubleArray yValues,
   System.bool isEmpty,
   CustomProperties properties,
   System.bool displayInLegend,
   System.string legendText
)

Parameters

xValue
Specifies the x value.
yValues
The y values for the DataPoint.
isEmpty
Specifies whether the DataPoint is empty.
properties
Specifies the custom properties for the DataPoint.
displayInLegend
Specifies whether the DataPoint information should be displayed in the legend.
legendText

Specifies the text as string to display for the DataPoint in the legend.

See Also

Reference

DataPoint Class
DataPoint Members
Overload List


DataPoint Class Methods

DataPoint Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : DataPoint Class

For a list of all members of this type, see DataPoint members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the DataPoint.
Top
See Also

Reference

DataPoint Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method (DataPoint)

Clone Method (DataPoint)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : Clone Method
Creates a clone of the DataPoint.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

System.Object.
See Also

Reference

DataPoint Class
DataPoint Members


DataPoint Class Properties

DataPoint Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : DataPoint Class

For a list of all members of this type, see DataPoint members.

Public Properties
 | Name | Description
Public Property | Backdrop | Gets or sets the backdrop information for the DataPoint.
Public Property | BorderLine | Gets or sets the line information for the border line of the DataPoint.
Public Property | DisplayInLegend | Gets or sets a value indicating whether to display the data point in the legend.
Public Property | IsEmpty | Gets or sets a value indicating whether the DataPoint is empty.
Public Property | LegendText | Gets or sets the text as string to display for the DataPoint in the legend.
Public Property | Line | Gets or sets the line information for the line of the DataPoint.
Public Property | Marker | Gets or sets the marker information for the DataPoint.
Public Property | Properties | Gets or sets the custom properties for the DataPoint.
Public Property | Tooltip | Gets or sets the tooltip text as string for the DataPoint.
Public Property | XValue | Gets or sets the X value for the DataPoint.
Public Property | YValues | Gets or sets the Y values for the DataPoint.
Top
See Also

Reference

DataPoint Class
GrapeCity.ActiveReports.Chart Namespace


Backdrop Property (DataPoint)

Backdrop Property (DataPoint)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : Backdrop Property
Gets or sets the backdrop information for the DataPoint.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Backdrop As Backdrop
public Backdrop Backdrop {get; set;}

Property Value

The backdrop.
See Also

Reference

DataPoint Class
DataPoint Members


BorderLine Property (DataPoint)

BorderLine Property (DataPoint)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : BorderLine Property
Gets or sets the line information for the border line of the DataPoint.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BorderLine As Line
public Line BorderLine {get; set;}

Property Value

The border line.
See Also

Reference

DataPoint Class
DataPoint Members


DisplayInLegend Property (DataPoint)

DisplayInLegend Property (DataPoint)
Example

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : DisplayInLegend Property
Gets or sets a value indicating whether to display the data point in the legend.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DisplayInLegend As NullableBoolean
public NullableBoolean DisplayInLegend {get; set;}
Remarks

The DisplayInLegend property applies to both the Series and DataPoint objects. When set to Auto for a one figure chart (e.g., funnel, pyramid, or doughnut) the property equals False for the Series object and True for the DataPoint object. When set to Auto for all other chart types, the property equals True for the Series object and False for the DataPoints object.

Example
  • C#
private void detail_Format(object sender, EventArgs e)
{
   this.chartControl1.Series[1].Points[3].DisplayInLegend = true;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ChartControl1.Series[1].Points[3].DisplayInLegend = True
End Sub
See Also

Reference

DataPoint Class
DataPoint Members


IsEmpty Property (DataPoint)

IsEmpty Property (DataPoint)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : IsEmpty Property
Gets or sets a value indicating whether the DataPoint is empty.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsEmpty As System.Boolean
public System.bool IsEmpty {get; set;}

Property Value

true if this instance is empty; otherwise, false.
See Also

Reference

DataPoint Class
DataPoint Members


LegendText Property (DataPoint)

LegendText Property (DataPoint)
Example

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : LegendText Property
Gets or sets the text as string to display for the DataPoint in the legend.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LegendText As System.String
public System.string LegendText {get; set;}

Property Value

The legend text.
Remarks

The LegendText property applies to both the Series and DataPoint objects. The LegendText property is treated as a {Value} by default when the data point appears in the legend and the LegendText property is set to an empty string. The {Value} is the original point value of the data point.

To render the x value for the data points in the legend for a one figure chart (i.e., funnel, pyramid, or doughnut), the LegendText property must be set to {Name}.

Example
  • C#
private void detail_Format(object sender, EventArgs e)
{
   if(checkBoxSales.Checked)
   {
      this.chartControl1.Series["Sales"].Points[0].LegendText = "";
   }
   else
   {
      this.chartControl1.Series["Sales"].Points[0].LegendText = "Twenty";
   }
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   If (CheckBoxSales.Checked) Then
       Me.ChartControl1.Series("Sales").Points(0).LegendText = ""
   Else
       Me.ChartControl1.Series("Sales").Points(0).LegendText = "Twenty"
   End If
End Sub
See Also

Reference

DataPoint Class
DataPoint Members


Line Property (DataPoint)

Line Property (DataPoint)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : Line Property
Gets or sets the line information for the line of the DataPoint.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Line As Line
public Line Line {get; set;}
See Also

Reference

DataPoint Class
DataPoint Members


Marker Property (DataPoint)

Marker Property (DataPoint)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : Marker Property
Gets or sets the marker information for the DataPoint.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Marker As Marker
public Marker Marker {get; set;}
See Also

Reference

DataPoint Class
DataPoint Members


Properties Property (DataPoint)

Properties Property (DataPoint)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : Properties Property
Gets or sets the custom properties for the DataPoint.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Properties As CustomProperties
public CustomProperties Properties {get; set;}

Property Value

The properties.
See Also

Reference

DataPoint Class
DataPoint Members


Tooltip Property (DataPoint)

Tooltip Property (DataPoint)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : Tooltip Property
Gets or sets the tooltip text as string for the DataPoint.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Tooltip As LabelInfo
public LabelInfo Tooltip {get; set;}
See Also

Reference

DataPoint Class
DataPoint Members


XValue Property

XValue Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : XValue Property
Gets or sets the X value for the DataPoint.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property XValue As System.Object
public System.object XValue {get; set;}
See Also

Reference

DataPoint Class
DataPoint Members


YValues Property

YValues Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPoint Class : YValues Property
Gets or sets the Y values for the DataPoint.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property YValues As DoubleArray
public DoubleArray YValues {get; set;}
See Also

Reference

DataPoint Class
DataPoint Members


DataPointsCollection Class

DataPointsCollection Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : DataPointsCollection Class
Specifies the settings for the DataPoints collection.
Object Model
DataPointsCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DataPointsCollection
   Inherits System.Collections.CollectionBase
public sealed class DataPointsCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.DataPointsCollection

See Also

Reference

DataPointsCollection Members
GrapeCity.ActiveReports.Chart Namespace


DataPointsCollection Class Members

DataPointsCollection Class Members
Properties Methods Events

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : DataPointsCollection Class

The following tables list the members exposed by DataPointsCollection.

Public Constructors
 | Name | Description
Public Constructor | DataPointsCollection Constructor | Initializes a new instance of the DataPointsCollection class.
Top
Public Properties
 | Name | Description
Public Property | Item | Gets or sets the DataPoint at the specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a DataPoint to the collection.
Public Method | AddRange | Adds a set of DataPoints to the collection.
Public Method | AddXY | Adds a DataPoint with the specified parameters to the DataPointsCollection.
Public Method | AddY | Adds a DataPoint with the specified y value to the DataPointsCollection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Clone | Creates a clone of the DataPointsCollection.
Public Method | Contains | Determines whether the collection contains the specified DataPoint.
Public Method | CopyTo | Copies the collection to an array, starting at the specified index.
Public Method | DataBindXY | Overloaded. Binds the X value and Y values of the collection's DataPoints to a specified data source.
Public Method | DataBindY | Overloaded. Binds the Y value(s) of the collection's DataPoints to a specified data source.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts the specified DataPoint into the collection at the specified index.
Public Method | Remove | Removes the specified DataPoint from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
Public Events
 | Name | Description
Public Event | Change | Occurs when the content of the DataPointsCollection changes.
Top
See Also

Reference

DataPointsCollection Class
GrapeCity.ActiveReports.Chart Namespace


DataPointsCollection Constructor

DataPointsCollection Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : DataPointsCollection Constructor
Initializes a new instance of the DataPointsCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DataPointsCollection()
See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


DataPointsCollection Class Methods

DataPointsCollection Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : DataPointsCollection Class

For a list of all members of this type, see DataPointsCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a DataPoint to the collection.
Public Method | AddRange | Adds a set of DataPoints to the collection.
Public Method | AddXY | Adds a DataPoint with the specified parameters to the DataPointsCollection.
Public Method | AddY | Adds a DataPoint with the specified y value to the DataPointsCollection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Clone | Creates a clone of the DataPointsCollection.
Public Method | Contains | Determines whether the collection contains the specified DataPoint.
Public Method | CopyTo | Copies the collection to an array, starting at the specified index.
Public Method | DataBindXY | Overloaded. Binds the X value and Y values of the collection's DataPoints to a specified data source.
Public Method | DataBindY | Overloaded. Binds the Y value(s) of the collection's DataPoints to a specified data source.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts the specified DataPoint into the collection at the specified index.
Public Method | Remove | Removes the specified DataPoint from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

DataPointsCollection Class
GrapeCity.ActiveReports.Chart Namespace


Add Method (DataPointsCollection)

Add Method (DataPointsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : Add Method
The DataPoint to add.
Adds a DataPoint to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As DataPoint _
) As System.Integer
public System.int Add(
   DataPoint value
)

Parameters

value
The DataPoint to add.
See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


AddRange Method (DataPointsCollection)

AddRange Method (DataPointsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : AddRange Method
The DataPoints to add to the collection.
Adds a set of DataPoints to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddRange( _
   ByVal value() As DataPoint _
)
public void AddRange(
   DataPoint[] value
)

Parameters

value
The DataPoints to add to the collection.
See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


AddXY Method

AddXY Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : AddXY Method
Specifies the X value.

Specifies the Y values.

Adds a DataPoint with the specified parameters to the DataPointsCollection.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function AddXY( _
   ByVal xValue As System.Object, _
   ByVal ParamArray yValue() As System.Double _
) As System.Integer
public System.int AddXY(
   System.object xValue,
   params System.double[] yValue
)

Parameters

xValue
Specifies the X value.
yValue

Specifies the Y values.

Return Value

System.Int32.
See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


AddY Method

AddY Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : AddY Method
Specifies the Y value.
Adds a DataPoint with the specified y value to the DataPointsCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function AddY( _
   ByVal ParamArray yValue() As System.Double _
) As System.Integer
public System.int AddY(
   params System.double[] yValue
)

Parameters

yValue
Specifies the Y value.
See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


Clone Method (DataPointsCollection)

Clone Method (DataPointsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : Clone Method
Creates a clone of the DataPointsCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Clone() As System.Object
public System.object Clone()

Return Value

A clone of the DataPointsCollection.
See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


Contains Method (DataPointsCollection)

Contains Method (DataPointsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : Contains Method
The DataPoint to find in the collection.
Determines whether the collection contains the specified DataPoint.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal value As DataPoint _
) As System.Boolean
public System.bool Contains(
   DataPoint value
)

Parameters

value
The DataPoint to find in the collection.

Return Value

True if the collection contains the parameter given; otherwise False.
See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


CopyTo Method (DataPointsCollection)

CopyTo Method (DataPointsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : CopyTo Method
The array to which to copy the collection.
The index from which to start.
Copies the collection to an array, starting at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal array() As DataPoint, _
   ByVal index As System.Integer _
)
public void CopyTo(
   DataPoint[] array,
   System.int index
)

Parameters

array
The array to which to copy the collection.
index
The index from which to start.
See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


DataBindXY Method

DataBindXY Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : DataBindXY Method
Binds the X value and Y values of the collection's DataPoints to a specified data source.
Overload List
Overload | Description
DataBindXY(Object,String,Object,String) | Binds the X value and Y values of the collection's DataPoints to the specified columns of the specified data sources.
DataBindXY(IEnumerable,IEnumerable[]) | Binds the X value and Y values of the collection's DataPoints to the first column(s) of the specified data source(s).
DataBindXY(Object[],Double[]) | Binds the X value and Y values of the collection's DataPoints to a specified data source.
See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


DataBindXY(Object,String,Object,String) Method

DataBindXY(Object,String,Object,String) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class > DataBindXY Method : DataBindXY(Object,String,Object,String) Method
Specifies the data source that will supply the X values for the DataPoints.
Specifies the name as string of the column that will supply the X values for the DataPoints.
Specifes the Y value(s) of the DataPoint object added to the collection (one or more comma-separated values).
Specifies the comma-separated column name(s) that will supply the Y value(s) for the DataPoints.
Binds the X value and Y values of the collection's DataPoints to the specified columns of the specified data sources.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DataBindXY( _
   ByVal xDataSource As System.Object, _
   ByVal xField As System.String, _
   ByVal yDataSource As System.Object, _
   ByVal yFields As System.String _
)
public void DataBindXY(
   System.object xDataSource,
   System.string xField,
   System.object yDataSource,
   System.string yFields
)

Parameters

xDataSource
Specifies the data source that will supply the X values for the DataPoints.
xField
Specifies the name as string of the column that will supply the X values for the DataPoints.
yDataSource
Specifes the Y value(s) of the DataPoint object added to the collection (one or more comma-separated values).
yFields
Specifies the comma-separated column name(s) that will supply the Y value(s) for the DataPoints.
See Also

Reference

DataPointsCollection Class
DataPointsCollection Members
Overload List


DataBindXY(IEnumerable,IEnumerable[]) Method

DataBindXY(IEnumerable,IEnumerable[]) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class > DataBindXY Method : DataBindXY(IEnumerable,IEnumerable[]) Method
Specifies the data source that will supply the X values for the DataPoints. The first available column will be used.
Specifies the Y value(s) of the DataPoint object added to the collection (one or more comma-separated values).
Binds the X value and Y values of the collection's DataPoints to the first column(s) of the specified data source(s).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DataBindXY( _
   ByVal xValueEnumerable As System.Collections.IEnumerable, _
   ByVal ParamArray yEnumerableValues() As System.Collections.IEnumerable _
)
public void DataBindXY(
   System.Collections.IEnumerable xValueEnumerable,
   params System.Collections.IEnumerable[] yEnumerableValues
)

Parameters

xValueEnumerable
Specifies the data source that will supply the X values for the DataPoints. The first available column will be used.
yEnumerableValues
Specifies the Y value(s) of the DataPoint object added to the collection (one or more comma-separated values).
See Also

Reference

DataPointsCollection Class
DataPointsCollection Members
Overload List


DataBindXY(Object[],Double[]) Method

DataBindXY(Object[],Double[]) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class > DataBindXY Method : DataBindXY(Object[],Double[]) Method
Specifies the array of X values of the DataPoint object added to the collection.
Specifies the array of Y values of the DataPoint object added to the collection.
Binds the X value and Y values of the collection's DataPoints to a specified data source.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DataBindXY( _
   ByVal xValues() As System.Object, _
   ByVal ParamArray yValues() As System.Double _
)
public void DataBindXY(
   System.object[] xValues,
   params System.double[] yValues
)

Parameters

xValues
Specifies the array of X values of the DataPoint object added to the collection.
yValues
Specifies the array of Y values of the DataPoint object added to the collection.
See Also

Reference

DataPointsCollection Class
DataPointsCollection Members
Overload List


DataBindY Method

DataBindY Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : DataBindY Method
Binds the Y value(s) of the collection's DataPoints to a specified data source.
Overload List
Overload | Description
DataBindY(Object,String) | Binds the Y value(s) of the collection's DataPoints to the specified column(s) of the specified data source.
DataBindY(IEnumerable[]) | Binds the Y value(s) of the collection's DataPoints to the first column of the specified data source(s).
DataBindY(Double[]) | Binds the Y values of the collection's DataPoints to a specified data source.
See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


DataBindY(Object,String) Method

DataBindY(Object,String) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class > DataBindY Method : DataBindY(Object,String) Method
Specifies the data source object that provides the Y value(s).
Specifies the data souce field(s) to which to bind DataPoints.
Binds the Y value(s) of the collection's DataPoints to the specified column(s) of the specified data source.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DataBindY( _
   ByVal yDataSource As System.Object, _
   ByVal yFields As System.String _
)
public void DataBindY(
   System.object yDataSource,
   System.string yFields
)

Parameters

yDataSource
Specifies the data source object that provides the Y value(s).
yFields
Specifies the data souce field(s) to which to bind DataPoints.
See Also

Reference

DataPointsCollection Class
DataPointsCollection Members
Overload List


DataBindY(IEnumerable[]) Method

DataBindY(IEnumerable[]) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class > DataBindY Method : DataBindY(IEnumerable[]) Method
Specifies one or more comma-separated IEnumerable data sources.
Binds the Y value(s) of the collection's DataPoints to the first column of the specified data source(s).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DataBindY( _
   ByVal ParamArray yEnumerableValues() As System.Collections.IEnumerable _
)
public void DataBindY(
   params System.Collections.IEnumerable[] yEnumerableValues
)

Parameters

yEnumerableValues
Specifies one or more comma-separated IEnumerable data sources.
See Also

Reference

DataPointsCollection Class
DataPointsCollection Members
Overload List


DataBindY(Double[]) Method

DataBindY(Double[]) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class > DataBindY Method : DataBindY(Double[]) Method
Specifies an array of Y values of the DataPoint object that has been added to the collection.
Binds the Y values of the collection's DataPoints to a specified data source.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DataBindY( _
   ByVal ParamArray yValues() As System.Double _
)
public void DataBindY(
   params System.double[] yValues
)

Parameters

yValues
Specifies an array of Y values of the DataPoint object that has been added to the collection.
See Also

Reference

DataPointsCollection Class
DataPointsCollection Members
Overload List


IndexOf Method (DataPointsCollection)

IndexOf Method (DataPointsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : IndexOf Method

The data point to locate in the collection.

Returns the index of the first occurrence of a value in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As DataPoint _
) As System.Integer
public System.int IndexOf(
   DataPoint value
)

Parameters

value

The data point to locate in the collection.

Return Value

The index of the first occurrence of the value within the entire array, if found; otherwise, the lower bound of the array - 1.
See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


Insert Method (DataPointsCollection)

Insert Method (DataPointsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : Insert Method
The index at which to insert the DataPoint.
The DataPoint to insert.
Inserts the specified DataPoint into the collection at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As DataPoint _
)
public void Insert(
   System.int index,
   DataPoint value
)

Parameters

index
The index at which to insert the DataPoint.
value
The DataPoint to insert.
See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


Remove Method (DataPointsCollection)

Remove Method (DataPointsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : Remove Method

The DataPoint to remove.

Removes the specified DataPoint from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As DataPoint _
)
public void Remove(
   DataPoint value
)

Parameters

value

The DataPoint to remove.

See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


DataPointsCollection Class Properties

DataPointsCollection Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : DataPointsCollection Class

For a list of all members of this type, see DataPointsCollection members.

Public Properties
 | Name | Description
Public Property | Item | Gets or sets the DataPoint at the specified index.
Top
See Also

Reference

DataPointsCollection Class
GrapeCity.ActiveReports.Chart Namespace


Item Property (DataPointsCollection)

Item Property (DataPointsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : Item Property
The index of the DataPoint.
Gets or sets the DataPoint at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As DataPoint
public DataPoint this[
   System.int index
]; {get; set;}

Parameters

index
The index of the DataPoint.
See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


DataPointsCollection Class Events

DataPointsCollection Class Events

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : DataPointsCollection Class

For a list of all members of this type, see DataPointsCollection members.

Public Events
 | Name | Description
Public Event | Change | Occurs when the content of the DataPointsCollection changes.
Top
See Also

Reference

DataPointsCollection Class
GrapeCity.ActiveReports.Chart Namespace


Change Event (DataPointsCollection)

Change Event (DataPointsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : Change Event

Occurs when the content of the DataPointsCollection changes.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Change As System.EventHandler
public event System.EventHandler Change
See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


DoubleArray Class

DoubleArray Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : DoubleArray Class
Represents the settings for the DoubleArray class.
Object Model
DoubleArray Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DoubleArray
   Inherits Item
public sealed class DoubleArray : Item
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.DoubleArray

See Also

Reference

DoubleArray Members
GrapeCity.ActiveReports.Chart Namespace


DoubleArray Class Members

DoubleArray Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : DoubleArray Class

The following tables list the members exposed by DoubleArray.

Public Constructors
 | Name | Description
Public Constructor | DoubleArray Constructor | Overloaded. Initializes a new instance of the DoubleArray class.
Top
Public Properties
 | Name | Description
Public Property | Item | Gets or sets the value at the index specified.
Public Property | Length | Gets the length of the double array.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the double array.
Public Method | IsDateTime | Gets a value indicating whether the double array is a DateTime array.
Public Method | SetIsDateTime | Sets the specified value at the specified index as a DateTime value.
Public Method | ToString | Overloaded. Converts the value of the current instance to its string representation.
Top
See Also

Reference

DoubleArray Class
GrapeCity.ActiveReports.Chart Namespace


DoubleArray Constructor

DoubleArray Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class : DoubleArray Constructor
Initializes a new instance of the DoubleArray class.
Overload List
Overload | Description
DoubleArray Constructor(Double[]) | Initializes a new instance of the DoubleArray class.
DoubleArray Constructor(DateTime[]) | Initializes a new instance of the DoubleArray class.
DoubleArray Constructor(Double[],Boolean[]) | Initializes a new instance of the DoubleArray class.
DoubleArray Constructor(String,IFormatProvider) | Initializes a new instance of the DoubleArray class.
DoubleArray Constructor(String) | Initializes a new instance of the DoubleArray class.
See Also

Reference

DoubleArray Class
DoubleArray Members


DoubleArray Constructor(Double[])

DoubleArray Constructor(Double[])

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class > DoubleArray Constructor : DoubleArray Constructor(Double[])
Specifies the data for the array.
Initializes a new instance of the DoubleArray class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal data() As System.Double _
)
public DoubleArray(
   System.double[] data
)

Parameters

data
Specifies the data for the array.
See Also

Reference

DoubleArray Class
DoubleArray Members
Overload List


DoubleArray Constructor(DateTime[])

DoubleArray Constructor(DateTime[])

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class > DoubleArray Constructor : DoubleArray Constructor(DateTime[])
Specifies the date time data for the array.
Initializes a new instance of the DoubleArray class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal data() As System.Date _
)
public DoubleArray(
   System.DateTime[] data
)

Parameters

data
Specifies the date time data for the array.
See Also

Reference

DoubleArray Class
DoubleArray Members
Overload List


DoubleArray Constructor(Double[],Boolean[])

DoubleArray Constructor(Double[],Boolean[])

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class > DoubleArray Constructor : DoubleArray Constructor(Double[],Boolean[])

Specifies the data for the array.

Specifies whether the array values are DateTime values.
Initializes a new instance of the DoubleArray class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal data() As System.Double, _
   ByVal isDateTime() As System.Boolean _
)
public DoubleArray(
   System.double[] data,
   System.bool[] isDateTime
)

Parameters

data

Specifies the data for the array.

isDateTime
Specifies whether the array values are DateTime values.
See Also

Reference

DoubleArray Class
DoubleArray Members
Overload List


DoubleArray Constructor(String,IFormatProvider)

DoubleArray Constructor(String,IFormatProvider)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class > DoubleArray Constructor : DoubleArray Constructor(String,IFormatProvider)
Specifies the data as string.
Specifies the culture of the data.
Initializes a new instance of the DoubleArray class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal data As System.String, _
   ByVal culture As System.IFormatProvider _
)
public DoubleArray(
   System.string data,
   System.IFormatProvider culture
)

Parameters

data
Specifies the data as string.
culture
Specifies the culture of the data.
See Also

Reference

DoubleArray Class
DoubleArray Members
Overload List


DoubleArray Constructor(String)

DoubleArray Constructor(String)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class > DoubleArray Constructor : DoubleArray Constructor(String)
Specifies the data as string.
Initializes a new instance of the DoubleArray class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal data As System.String _
)
public DoubleArray(
   System.string data
)

Parameters

data
Specifies the data as string.
See Also

Reference

DoubleArray Class
DoubleArray Members
Overload List


DoubleArray Class Methods

DoubleArray Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : DoubleArray Class

For a list of all members of this type, see DoubleArray members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the double array.
Public Method | IsDateTime | Gets a value indicating whether the double array is a DateTime array.
Public Method | SetIsDateTime | Sets the specified value at the specified index as a DateTime value.
Public Method | ToString | Overloaded. Converts the value of the current instance to its string representation.
Top
See Also

Reference

DoubleArray Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method (DoubleArray)

Clone Method (DoubleArray)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class : Clone Method
Creates a clone of the double array.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()
See Also

Reference

DoubleArray Class
DoubleArray Members


IsDateTime Method

IsDateTime Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class : IsDateTime Method

Specifies the index of the double array.

Gets a value indicating whether the double array is a DateTime array.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IsDateTime( _
   ByVal index As System.Integer _
) As System.Boolean
public System.bool IsDateTime(
   System.int index
)

Parameters

index

Specifies the index of the double array.

See Also

Reference

DoubleArray Class
DoubleArray Members


SetIsDateTime Method

SetIsDateTime Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class : SetIsDateTime Method

Specifies the index of the value to set.

Specifies the value.

Sets the specified value at the specified index as a DateTime value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetIsDateTime( _
   ByVal index As System.Integer, _
   ByVal value As System.Boolean _
)
public void SetIsDateTime(
   System.int index,
   System.bool value
)

Parameters

index

Specifies the index of the value to set.

value

Specifies the value.

See Also

Reference

DoubleArray Class
DoubleArray Members


ToString Method (DoubleArray)

ToString Method (DoubleArray)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class : ToString Method
Converts the value of the current instance to its string representation.
Overload List
Overload | Description
ToString(IFormatProvider) | Converts the value of the current instance to its string representation according to the specified culture.
ToString() | Converts the value of the current instance to its string representation.
See Also

Reference

DoubleArray Class
DoubleArray Members


ToString(IFormatProvider) Method

ToString(IFormatProvider) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class > ToString Method : ToString(IFormatProvider) Method
Specifies the culture to use.
Converts the value of the current instance to its string representation according to the specified culture.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function ToString( _
   ByVal culture As System.IFormatProvider _
) As System.String
public System.string ToString(
   System.IFormatProvider culture
)

Parameters

culture
Specifies the culture to use.
See Also

Reference

DoubleArray Class
DoubleArray Members
Overload List


ToString() Method

ToString() Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class > ToString Method : ToString() Method
Converts the value of the current instance to its string representation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overrides Function ToString() As System.String
public override System.string ToString()
See Also

Reference

DoubleArray Class
DoubleArray Members
Overload List


DoubleArray Class Properties

DoubleArray Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : DoubleArray Class

For a list of all members of this type, see DoubleArray members.

Public Properties
 | Name | Description
Public Property | Item | Gets or sets the value at the index specified.
Public Property | Length | Gets the length of the double array.
Top
See Also

Reference

DoubleArray Class
GrapeCity.ActiveReports.Chart Namespace


Item Property (DoubleArray)

Item Property (DoubleArray)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class : Item Property

Specifies the index of the value to get or set.

Gets or sets the value at the index specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal i As System.Integer _
) As System.Double
public System.double this[
   System.int i
]; {get; set;}

Parameters

i

Specifies the index of the value to get or set.

See Also

Reference

DoubleArray Class
DoubleArray Members


Length Property (DoubleArray)

Length Property (DoubleArray)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DoubleArray Class : Length Property
Gets the length of the double array.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Length As System.Integer
public System.int Length {get;}
See Also

Reference

DoubleArray Class
DoubleArray Members


FontInfo Class

FontInfo Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : FontInfo Class
Represents the settings for the FontInfo class.
Object Model
FontInfo Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class FontInfo
   Inherits Item
public sealed class FontInfo : Item
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.FontInfo

See Also

Reference

FontInfo Members
GrapeCity.ActiveReports.Chart Namespace


FontInfo Class Members

FontInfo Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : FontInfo Class

The following tables list the members exposed by FontInfo.

Public Constructors
 | Name | Description
Public Constructor | FontInfo Constructor | Overloaded. Initializes a new instance of the FontInfo class.
Top
Public Properties
 | Name | Description
Public Property | Angle | Gets or sets the clockwise rotation angle of the text in degrees.
Public Property | Color | Gets or sets the color of the text.
Public Property | Font | Gets or sets the font to use.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the FontInfo object.
Public Method | Equals | Compares the FontInfo object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Top
See Also

Reference

FontInfo Class
GrapeCity.ActiveReports.Chart Namespace


FontInfo Constructor

FontInfo Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > FontInfo Class : FontInfo Constructor

Initializes a new instance of the FontInfo class.

Overload List
Overload | Description
FontInfo Constructor(Color,Font,Single) | Initializes a new instance of the FontInfo class with the parameters specified.
FontInfo Constructor(Color,Font) | Initializes a new instance of the FontInfo class with the parameters specified.
FontInfo Constructor() | Initializes a new instance of the FontInfo class.
See Also

Reference

FontInfo Class
FontInfo Members


FontInfo Constructor(Color,Font,Single)

FontInfo Constructor(Color,Font,Single)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > FontInfo Class > FontInfo Constructor : FontInfo Constructor(Color,Font,Single)

Specifies the text color to use.

Specifies the System font to use.
Specifies the text angle in degrees.
Initializes a new instance of the FontInfo class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal color As Color, _
   ByVal font As Font, _
   ByVal angle As System.Single _
)
public FontInfo(
   Color color,
   Font font,
   System.float angle
)

Parameters

color

Specifies the text color to use.

font
Specifies the System font to use.
angle
Specifies the text angle in degrees.
See Also

Reference

FontInfo Class
FontInfo Members
Overload List


FontInfo Constructor(Color,Font)

FontInfo Constructor(Color,Font)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > FontInfo Class > FontInfo Constructor : FontInfo Constructor(Color,Font)

Specifies the text color to use.

Specifies the System font to use.
Initializes a new instance of the FontInfo class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal color As Color, _
   ByVal font As Font _
)
public FontInfo(
   Color color,
   Font font
)

Parameters

color

Specifies the text color to use.

font
Specifies the System font to use.
See Also

Reference

FontInfo Class
FontInfo Members
Overload List


FontInfo Constructor()

FontInfo Constructor()

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > FontInfo Class > FontInfo Constructor : FontInfo Constructor()

Initializes a new instance of the FontInfo class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public FontInfo()
See Also

Reference

FontInfo Class
FontInfo Members
Overload List


FontInfo Class Methods

FontInfo Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : FontInfo Class

For a list of all members of this type, see FontInfo members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the FontInfo object.
Public Method | Equals | Compares the FontInfo object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Top
See Also

Reference

FontInfo Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method (FontInfo)

Clone Method (FontInfo)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > FontInfo Class : Clone Method
Creates a clone of the FontInfo object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

A clone of the FontInfo.
See Also

Reference

FontInfo Class
FontInfo Members


Equals Method (FontInfo)

Equals Method (FontInfo)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > FontInfo Class : Equals Method
The System.Object to which the FontInfo object is being compared
Compares the FontInfo object to another System.Object to see whether they are equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The System.Object to which the FontInfo object is being compared
See Also

Reference

FontInfo Class
FontInfo Members


GetHashCode Method (FontInfo)

GetHashCode Method (FontInfo)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > FontInfo Class : GetHashCode Method
Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()
See Also

Reference

FontInfo Class
FontInfo Members


GetObjectData Method (FontInfo)

GetObjectData Method (FontInfo)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > FontInfo Class : GetObjectData Method

The SerializationInfo to populate with data.

The destination for the serialization.
Populates a SerializationInfo with the data needed to serialize the target object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info

The SerializationInfo to populate with data.

context
The destination for the serialization.
See Also

Reference

FontInfo Class
FontInfo Members


FontInfo Class Properties

FontInfo Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : FontInfo Class

For a list of all members of this type, see FontInfo members.

Public Properties
 | Name | Description
Public Property | Angle | Gets or sets the clockwise rotation angle of the text in degrees.
Public Property | Color | Gets or sets the color of the text.
Public Property | Font | Gets or sets the font to use.
Top
See Also

Reference

FontInfo Class
GrapeCity.ActiveReports.Chart Namespace


Angle Property (FontInfo)

Angle Property (FontInfo)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > FontInfo Class : Angle Property
Gets or sets the clockwise rotation angle of the text in degrees.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Angle As System.Single
public System.float Angle {get; set;}
See Also

Reference

FontInfo Class
FontInfo Members


Color Property (FontInfo)

Color Property (FontInfo)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > FontInfo Class : Color Property
Gets or sets the color of the text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Color As Color
public Color Color {get; set;}

Property Value

System.Drawing.Color.
See Also

Reference

FontInfo Class
FontInfo Members


Font Property (FontInfo)

Font Property (FontInfo)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > FontInfo Class : Font Property
Gets or sets the font to use.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Font As Font
public Font Font {get; set;}
See Also

Reference

FontInfo Class
FontInfo Members


GraphMouseEventArgs Class

GraphMouseEventArgs Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : GraphMouseEventArgs Class
Represents the properties of the mouse event arguments for the chart.
Object Model
GraphMouseEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class GraphMouseEventArgs
   Inherits System.Windows.Forms.MouseEventArgs
public sealed class GraphMouseEventArgs : System.Windows.Forms.MouseEventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
System.Windows.Forms.MouseEventArgs
GrapeCity.ActiveReports.Chart.GraphMouseEventArgs

See Also

Reference

GraphMouseEventArgs Members
GrapeCity.ActiveReports.Chart Namespace


GraphMouseEventArgs Class Members

GraphMouseEventArgs Class Members
Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : GraphMouseEventArgs Class

The following tables list the members exposed by GraphMouseEventArgs.

Public Properties
 | Name | Description
Public Property | Button | (Inherited from System.Windows.Forms.MouseEventArgs)
Public Property | Clicks | (Inherited from System.Windows.Forms.MouseEventArgs)
Public Property | Control | Gets or sets the control on which the mouse event occurred.
Public Property | Delta | (Inherited from System.Windows.Forms.MouseEventArgs)
Public Property | ItemCount | Gets a count of the number of times the item was clicked.
Public Property | Location | (Inherited from System.Windows.Forms.MouseEventArgs)
Public Property | PointIndex | Gets a count of the number of times the item was clicked.
Public Property | UserX | Gets the X coordinate of the mouse.
Public Property | UserY | Gets the Y coordinate of the mouse.
Public Property | X | (Inherited from System.Windows.Forms.MouseEventArgs)
Public Property | Y | (Inherited from System.Windows.Forms.MouseEventArgs)
Top
See Also

Reference

GraphMouseEventArgs Class
GrapeCity.ActiveReports.Chart Namespace


GraphMouseEventArgs Class Properties

GraphMouseEventArgs Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : GraphMouseEventArgs Class

For a list of all members of this type, see GraphMouseEventArgs members.

Public Properties
 | Name | Description
Public Property | Button | (Inherited from System.Windows.Forms.MouseEventArgs)
Public Property | Clicks | (Inherited from System.Windows.Forms.MouseEventArgs)
Public Property | Control | Gets or sets the control on which the mouse event occurred.
Public Property | Delta | (Inherited from System.Windows.Forms.MouseEventArgs)
Public Property | ItemCount | Gets a count of the number of times the item was clicked.
Public Property | Location | (Inherited from System.Windows.Forms.MouseEventArgs)
Public Property | PointIndex | Gets a count of the number of times the item was clicked.
Public Property | UserX | Gets the X coordinate of the mouse.
Public Property | UserY | Gets the Y coordinate of the mouse.
Public Property | X | (Inherited from System.Windows.Forms.MouseEventArgs)
Public Property | Y | (Inherited from System.Windows.Forms.MouseEventArgs)
Top
See Also

Reference

GraphMouseEventArgs Class
GrapeCity.ActiveReports.Chart Namespace


Control Property (GraphMouseEventArgs)

Control Property (GraphMouseEventArgs)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphMouseEventArgs Class : Control Property
Gets or sets the control on which the mouse event occurred.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Control As System.Windows.Forms.Control
public System.Windows.Forms.Control Control {get;}
See Also

Reference

GraphMouseEventArgs Class
GraphMouseEventArgs Members


ItemCount Property (GraphMouseEventArgs)

ItemCount Property (GraphMouseEventArgs)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphMouseEventArgs Class : ItemCount Property
Gets a count of the number of times the item was clicked.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ItemCount As System.Integer
public System.int ItemCount {get;}
See Also

Reference

GraphMouseEventArgs Class
GraphMouseEventArgs Members


PointIndex Property

PointIndex Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphMouseEventArgs Class : PointIndex Property
Gets a count of the number of times the item was clicked.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PointIndex As System.Integer
public System.int PointIndex {get;}
Remarks
This property was previously called ItemCount. ItemCount is now an obsolete property.
See Also

Reference

GraphMouseEventArgs Class
GraphMouseEventArgs Members


UserX Property

UserX Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphMouseEventArgs Class : UserX Property
Gets the X coordinate of the mouse.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property UserX As System.Single
public System.float UserX {get;}
See Also

Reference

GraphMouseEventArgs Class
GraphMouseEventArgs Members


UserY Property

UserY Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphMouseEventArgs Class : UserY Property
Gets the Y coordinate of the mouse.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property UserY As System.Single
public System.float UserY {get;}
See Also

Reference

GraphMouseEventArgs Class
GraphMouseEventArgs Members


GridLayout Class

GridLayout Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : GridLayout Class
Represents the settings for the GridLayout object.
Object Model
GridLayout Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class GridLayout
   Inherits Item
public sealed class GridLayout : Item
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.GridLayout

See Also

Reference

GridLayout Members
GrapeCity.ActiveReports.Chart Namespace


GridLayout Class Members

GridLayout Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : GridLayout Class

The following tables list the members exposed by GridLayout.

Public Constructors
 | Name | Description
Public Constructor | GridLayout Constructor | Overloaded. Initializes a new instance of the GridLayout class.
Top
Public Properties
 | Name | Description
Public Property | Columns | Gets or sets the number of columns for the GridLayout.
Public Property | Rows | Gets or sets the number of rows for the GridLayout.
Public Property | Size | Gets the size of the GridLayout.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the GridLayout object.
Public Method | DecreaseSize | Decreases the grid layout size by one column or one row at a time.
Public Method | Equals | Compares the GridLayout object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | IncreaseSize | Increases the grid layout size by one column or one row at a time.
Top
See Also

Reference

GridLayout Class
GrapeCity.ActiveReports.Chart Namespace


GridLayout Constructor

GridLayout Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > GridLayout Class : GridLayout Constructor
Initializes a new instance of the GridLayout class.
Overload List
Overload | Description
GridLayout Constructor() | Initializes a new instance of the GridLayout class.
GridLayout Constructor(Int32,Int32) | Initializes a new instance of the GridLayout class with the specified number of rows and columns.
See Also

Reference

GridLayout Class
GridLayout Members


GridLayout Constructor()

GridLayout Constructor()

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > GridLayout Class > GridLayout Constructor : GridLayout Constructor()
Initializes a new instance of the GridLayout class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public GridLayout()
See Also

Reference

GridLayout Class
GridLayout Members
Overload List


GridLayout Constructor(Int32,Int32)

GridLayout Constructor(Int32,Int32)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > GridLayout Class > GridLayout Constructor : GridLayout Constructor(Int32,Int32)

Specifies the number of rows.

Specifies the number of columns.
Initializes a new instance of the GridLayout class with the specified number of rows and columns.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal rows As System.Integer, _
   ByVal columns As System.Integer _
)
public GridLayout(
   System.int rows,
   System.int columns
)

Parameters

rows

Specifies the number of rows.

columns
Specifies the number of columns.
See Also

Reference

GridLayout Class
GridLayout Members
Overload List


GridLayout Class Methods

GridLayout Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : GridLayout Class

For a list of all members of this type, see GridLayout members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the GridLayout object.
Public Method | DecreaseSize | Decreases the grid layout size by one column or one row at a time.
Public Method | Equals | Compares the GridLayout object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | IncreaseSize | Increases the grid layout size by one column or one row at a time.
Top
See Also

Reference

GridLayout Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method (GridLayout)

Clone Method (GridLayout)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > GridLayout Class : Clone Method
Creates a clone of the GridLayout object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

A clone of the GridLayout object.
See Also

Reference

GridLayout Class
GridLayout Members


DecreaseSize Method

DecreaseSize Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > GridLayout Class : DecreaseSize Method
Decreases the grid layout size by one column or one row at a time.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub DecreaseSize()
public void DecreaseSize()
Remarks
For example, if a GridLayout has two rows and two columns, the first call to the DecreaseSize method will subtract one column, and the second call will subtract one row. If a GridLayout has two rows and three columns, the first call to the DecreaseSize method will subtract one column, and the second call will subtract one row.
See Also

Reference

GridLayout Class
GridLayout Members


Equals Method (GridLayout)

Equals Method (GridLayout)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > GridLayout Class : Equals Method

The System.Object to which the GridLayout object is being compared.

Compares the GridLayout object to another System.Object to see whether they are equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj

The System.Object to which the GridLayout object is being compared.

See Also

Reference

GridLayout Class
GridLayout Members


GetHashCode Method (GridLayout)

GetHashCode Method (GridLayout)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > GridLayout Class : GetHashCode Method
Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()
See Also

Reference

GridLayout Class
GridLayout Members


IncreaseSize Method

IncreaseSize Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > GridLayout Class : IncreaseSize Method
Increases the grid layout size by one column or one row at a time.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub IncreaseSize()
public void IncreaseSize()
Remarks
For example, if a GridLayout has one row and one column, the first call to the IncreaseSize method will add one column, and the second call will add one row. If a GridLayout has one row and two columns, the first call to the IncreaseSize method will add one row, and the second call will add one column.
See Also

Reference

GridLayout Class
GridLayout Members


GridLayout Class Properties

GridLayout Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : GridLayout Class

For a list of all members of this type, see GridLayout members.

Public Properties
 | Name | Description
Public Property | Columns | Gets or sets the number of columns for the GridLayout.
Public Property | Rows | Gets or sets the number of rows for the GridLayout.
Public Property | Size | Gets the size of the GridLayout.
Top
See Also

Reference

GridLayout Class
GrapeCity.ActiveReports.Chart Namespace


Columns Property (GridLayout)

Columns Property (GridLayout)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > GridLayout Class : Columns Property
Gets or sets the number of columns for the GridLayout.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Columns As System.Integer
public System.int Columns {get; set;}
See Also

Reference

GridLayout Class
GridLayout Members


Rows Property (GridLayout)

Rows Property (GridLayout)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > GridLayout Class : Rows Property
Gets or sets the number of rows for the GridLayout.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Rows As System.Integer
public System.int Rows {get; set;}
See Also

Reference

GridLayout Class
GridLayout Members


Size Property (GridLayout)

Size Property (GridLayout)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > GridLayout Class : Size Property
Gets the size of the GridLayout.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Size As System.Integer
public System.int Size {get;}
See Also

Reference

GridLayout Class
GridLayout Members


HitTest Class

HitTest Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : HitTest Class
Represents the properties of the HitTest object.
Object Model
HitTest Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class HitTest
public sealed class HitTest
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.HitTest

See Also

Reference

HitTest Members
GrapeCity.ActiveReports.Chart Namespace


HitTest Class Members

HitTest Class Members
Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : HitTest Class

The following tables list the members exposed by HitTest.

Public Properties
 | Name | Description
Public Property | Item | Gets the chart item that is located at specified coordinates.
Public Property | ItemCount | Gets or sets the ordinal number of the item, applicable only for series views, and denotes column number (sector number, etc.).
Top
See Also

Reference

HitTest Class
GrapeCity.ActiveReports.Chart Namespace


HitTest Class Properties

HitTest Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : HitTest Class

For a list of all members of this type, see HitTest members.

Public Properties
 | Name | Description
Public Property | Item | Gets the chart item that is located at specified coordinates.
Public Property | ItemCount | Gets or sets the ordinal number of the item, applicable only for series views, and denotes column number (sector number, etc.).
Top
See Also

Reference

HitTest Class
GrapeCity.ActiveReports.Chart Namespace


Item Property (HitTest)

Item Property (HitTest)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > HitTest Class : Item Property
Gets the chart item that is located at specified coordinates.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Item As Item
public Item Item {get;}
See Also

Reference

HitTest Class
HitTest Members


ItemCount Property (HitTest)

ItemCount Property (HitTest)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > HitTest Class : ItemCount Property
Gets or sets the ordinal number of the item, applicable only for series views, and denotes column number (sector number, etc.).
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ItemCount As System.Integer
public System.int ItemCount {get;}
See Also

Reference

HitTest Class
HitTest Members


KeyValuePair Class

KeyValuePair Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : KeyValuePair Class
Represents the settings for the KeyValuePair object.
Object Model
KeyValuePair Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class KeyValuePair
public sealed class KeyValuePair
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.KeyValuePair

See Also

Reference

KeyValuePair Members
GrapeCity.ActiveReports.Chart Namespace


KeyValuePair Class Members

KeyValuePair Class Members
Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : KeyValuePair Class

The following tables list the members exposed by KeyValuePair.

Public Constructors
 | Name | Description
Public Constructor | KeyValuePair Constructor | Overloaded. Initializes a new instance of the KeyValuePair class.
Top
Public Properties
 | Name | Description
Public Property | IsPointOverridable | Gets a value indicating whether the point can be overriden.
Public Property | Key | Gets the name of the custom property as string.
Public Property | Validator | Gets the property validator.
Public Property | Value | Gets the value of the object.
Top
See Also

Reference

KeyValuePair Class
GrapeCity.ActiveReports.Chart Namespace


KeyValuePair Constructor

KeyValuePair Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > KeyValuePair Class : KeyValuePair Constructor
Initializes a new instance of the KeyValuePair class.
Overload List
Overload | Description
KeyValuePair Constructor(String,Object) | Initializes a new instance of the KeyValuePair class with the parameters specified.
KeyValuePair Constructor(String,Object,Boolean) | Initializes a new instance of the KeyValuePair class with the parameters specified.
KeyValuePair Constructor(String,Object,ICustomPropertyValueValidator) | Initializes a new instance of the KeyValuePair class with the parameters specified.
KeyValuePair Constructor(String,Object,ICustomPropertyValueValidator,Boolean) | Initializes a new instance of the KeyValuePair class with the parameters specified.
See Also

Reference

KeyValuePair Class
KeyValuePair Members


KeyValuePair Constructor(String,Object)

KeyValuePair Constructor(String,Object)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > KeyValuePair Class > KeyValuePair Constructor : KeyValuePair Constructor(String,Object)
Specifies the name of the custom property as string.
Specifies the value of the object.
Initializes a new instance of the KeyValuePair class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal key As System.String, _
   ByVal value As System.Object _
)
public KeyValuePair(
   System.string key,
   System.object value
)

Parameters

key
Specifies the name of the custom property as string.
value
Specifies the value of the object.
See Also

Reference

KeyValuePair Class
KeyValuePair Members
Overload List


KeyValuePair Constructor(String,Object,Boolean)

KeyValuePair Constructor(String,Object,Boolean)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > KeyValuePair Class > KeyValuePair Constructor : KeyValuePair Constructor(String,Object,Boolean)
Specifies the name of the custom property as string.
Specifies the value of the object.
Specifies whether the point is overridable.
Initializes a new instance of the KeyValuePair class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal key As System.String, _
   ByVal value As System.Object, _
   ByVal isPointOverridable As System.Boolean _
)
public KeyValuePair(
   System.string key,
   System.object value,
   System.bool isPointOverridable
)

Parameters

key
Specifies the name of the custom property as string.
value
Specifies the value of the object.
isPointOverridable
Specifies whether the point is overridable.
See Also

Reference

KeyValuePair Class
KeyValuePair Members
Overload List


KeyValuePair Constructor(String,Object,ICustomPropertyValueValidator)

KeyValuePair Constructor(String,Object,ICustomPropertyValueValidator)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > KeyValuePair Class > KeyValuePair Constructor : KeyValuePair Constructor(String,Object,ICustomPropertyValueValidator)
Specifies the name of the custom property as string.
Specifies the value of the object.
Specifies the property validator.
Initializes a new instance of the KeyValuePair class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal key As System.String, _
   ByVal value As System.Object, _
   ByVal validator As ICustomPropertyValueValidator _
)
public KeyValuePair(
   System.string key,
   System.object value,
   ICustomPropertyValueValidator validator
)

Parameters

key
Specifies the name of the custom property as string.
value
Specifies the value of the object.
validator
Specifies the property validator.
See Also

Reference

KeyValuePair Class
KeyValuePair Members
Overload List


KeyValuePair Constructor(String,Object,ICustomPropertyValueValidator,Boolean)

KeyValuePair Constructor(String,Object,ICustomPropertyValueValidator,Boolean)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > KeyValuePair Class > KeyValuePair Constructor : KeyValuePair Constructor(String,Object,ICustomPropertyValueValidator,Boolean)
Specifies the name of the custom property as string.
Specifies the value of the object.
Specifies the property validator.
Specifies whether the point is overridable.
Initializes a new instance of the KeyValuePair class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal key As System.String, _
   ByVal value As System.Object, _
   ByVal validator As ICustomPropertyValueValidator, _
   ByVal isPointOverridable As System.Boolean _
)
public KeyValuePair(
   System.string key,
   System.object value,
   ICustomPropertyValueValidator validator,
   System.bool isPointOverridable
)

Parameters

key
Specifies the name of the custom property as string.
value
Specifies the value of the object.
validator
Specifies the property validator.
isPointOverridable
Specifies whether the point is overridable.
See Also

Reference

KeyValuePair Class
KeyValuePair Members
Overload List


KeyValuePair Class Properties

KeyValuePair Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : KeyValuePair Class

For a list of all members of this type, see KeyValuePair members.

Public Properties
 | Name | Description
Public Property | IsPointOverridable | Gets a value indicating whether the point can be overriden.
Public Property | Key | Gets the name of the custom property as string.
Public Property | Validator | Gets the property validator.
Public Property | Value | Gets the value of the object.
Top
See Also

Reference

KeyValuePair Class
GrapeCity.ActiveReports.Chart Namespace


IsPointOverridable Property

IsPointOverridable Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > KeyValuePair Class : IsPointOverridable Property
Gets a value indicating whether the point can be overriden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsPointOverridable As System.Boolean
public System.bool IsPointOverridable {get;}
See Also

Reference

KeyValuePair Class
KeyValuePair Members


Key Property (KeyValuePair)

Key Property (KeyValuePair)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > KeyValuePair Class : Key Property
Gets the name of the custom property as string.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Key As System.String
public System.string Key {get;}
See Also

Reference

KeyValuePair Class
KeyValuePair Members


Validator Property

Validator Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > KeyValuePair Class : Validator Property
Gets the property validator.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Validator As ICustomPropertyValueValidator
public ICustomPropertyValueValidator Validator {get;}
See Also

Reference

KeyValuePair Class
KeyValuePair Members


Value Property (KeyValuePair)

Value Property (KeyValuePair)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > KeyValuePair Class : Value Property
Gets the value of the object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Value As System.Object
public System.object Value {get;}
See Also

Reference

KeyValuePair Class
KeyValuePair Members


LabelInfo Class

LabelInfo Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : LabelInfo Class
Represents the settings for the LabelInfo class.
Object Model
LabelInfo Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class LabelInfo
   Inherits DrawCustomizableItem
public sealed class LabelInfo : DrawCustomizableItem
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.LabelInfo

See Also

Reference

LabelInfo Members
GrapeCity.ActiveReports.Chart Namespace


LabelInfo Class Members

LabelInfo Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : LabelInfo Class

The following tables list the members exposed by LabelInfo.

Public Constructors
 | Name | Description
Public Constructor | LabelInfo Constructor | Overloaded. Initializes a new instance of the LabelInfo class.
Top
Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the label alignment around the anchor point.
Public Property | Backdrop | Gets or sets the backdrop information to be used for the label.
Public Property | Border | Gets or sets the border information used to outline the label.
Public Property | Font | Gets or sets the FontInfo information used to draw the text of the label.
Public Property | Format | Gets or sets the format string used to draw the label.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the LabelInfo object.
Public Method | Equals | Compares the LabelInfo object to another System.Object to see if they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top
See Also

Reference

LabelInfo Class
GrapeCity.ActiveReports.Chart Namespace


LabelInfo Constructor

LabelInfo Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class : LabelInfo Constructor
Initializes a new instance of the LabelInfo class.
Overload List
Overload | Description
LabelInfo Constructor() | Initializes a new instance of the LabelInfo class.
LabelInfo Constructor(AntiAliasMode) | Initializes a new instance of the LabelInfo class with the AntiAliasMode specified.
LabelInfo Constructor(Line,Backdrop,FontInfo,String,Alignment) | Initializes a new instance of the LabelInfo class with the parameters specified.
LabelInfo Constructor(Line,Backdrop,FontInfo,String,Alignment,AntiAliasMode) | Initializes a new instance of the LabelInfo class with the parameters specified.
See Also

Reference

LabelInfo Class
LabelInfo Members


LabelInfo Constructor()

LabelInfo Constructor()

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class > LabelInfo Constructor : LabelInfo Constructor()
Initializes a new instance of the LabelInfo class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public LabelInfo()
See Also

Reference

LabelInfo Class
LabelInfo Members
Overload List


LabelInfo Constructor(AntiAliasMode)

LabelInfo Constructor(AntiAliasMode)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class > LabelInfo Constructor : LabelInfo Constructor(AntiAliasMode)

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Initializes a new instance of the LabelInfo class with the AntiAliasMode specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal antiAliasMode As AntiAliasMode _
)
public LabelInfo(
   AntiAliasMode antiAliasMode
)

Parameters

antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

See Also

Reference

LabelInfo Class
LabelInfo Members
Overload List


LabelInfo Constructor(Line,Backdrop,FontInfo,String,Alignment)

LabelInfo Constructor(Line,Backdrop,FontInfo,String,Alignment)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class > LabelInfo Constructor : LabelInfo Constructor(Line,Backdrop,FontInfo,String,Alignment)
Specifies the border information used to outline the label.
Specifies the backdrop information to use for the label.
Specifies the font information used to draw the text of the label.
Specifies the format string used to draw the label.

Specifies the label alignment around the anchor point.

Initializes a new instance of the LabelInfo class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal border As Line, _
   ByVal backdrop As Backdrop, _
   ByVal font As FontInfo, _
   ByVal format As System.String, _
   ByVal alignment As Alignment _
)
public LabelInfo(
   Line border,
   Backdrop backdrop,
   FontInfo font,
   System.string format,
   Alignment alignment
)

Parameters

border
Specifies the border information used to outline the label.
backdrop
Specifies the backdrop information to use for the label.
font
Specifies the font information used to draw the text of the label.
format
Specifies the format string used to draw the label.
alignment

Specifies the label alignment around the anchor point.

See Also

Reference

LabelInfo Class
LabelInfo Members
Overload List


LabelInfo Constructor(Line,Backdrop,FontInfo,String,Alignment,AntiAliasMode)

LabelInfo Constructor(Line,Backdrop,FontInfo,String,Alignment,AntiAliasMode)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class > LabelInfo Constructor : LabelInfo Constructor(Line,Backdrop,FontInfo,String,Alignment,AntiAliasMode)
Specifies the border information used to outline the label.
Specifies the backdrop information to use for the label.
Specifies the font information used to draw the text of the label.
Specifies the format string used to draw the label.

Specifies the label alignment around the anchor point.

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

Initializes a new instance of the LabelInfo class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal border As Line, _
   ByVal backdrop As Backdrop, _
   ByVal font As FontInfo, _
   ByVal format As System.String, _
   ByVal alignment As Alignment, _
   ByVal antiAliasMode As AntiAliasMode _
)
public LabelInfo(
   Line border,
   Backdrop backdrop,
   FontInfo font,
   System.string format,
   Alignment alignment,
   AntiAliasMode antiAliasMode
)

Parameters

border
Specifies the border information used to outline the label.
backdrop
Specifies the backdrop information to use for the label.
font
Specifies the font information used to draw the text of the label.
format
Specifies the format string used to draw the label.
alignment

Specifies the label alignment around the anchor point.

antiAliasMode

Specifies the AntiAliasMode to use. Value can be Auto, None, Graphics, Text, or Both.

See Also

Reference

LabelInfo Class
LabelInfo Members
Overload List


LabelInfo Class Methods

LabelInfo Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : LabelInfo Class

For a list of all members of this type, see LabelInfo members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the LabelInfo object.
Public Method | Equals | Compares the LabelInfo object to another System.Object to see if they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top
See Also

Reference

LabelInfo Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method (LabelInfo)

Clone Method (LabelInfo)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class : Clone Method
Creates a clone of the LabelInfo object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

A clone of the LabelInfo object.
See Also

Reference

LabelInfo Class
LabelInfo Members


Equals Method (LabelInfo)

Equals Method (LabelInfo)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class : Equals Method
The System.Object to which the LabelInfo object is being compared.
Compares the LabelInfo object to another System.Object to see if they are equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The System.Object to which the LabelInfo object is being compared.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.
See Also

Reference

LabelInfo Class
LabelInfo Members


GetHashCode Method (LabelInfo)

GetHashCode Method (LabelInfo)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class : GetHashCode Method
Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

LabelInfo Class
LabelInfo Members


LabelInfo Class Properties

LabelInfo Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : LabelInfo Class

For a list of all members of this type, see LabelInfo members.

Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the label alignment around the anchor point.
Public Property | Backdrop | Gets or sets the backdrop information to be used for the label.
Public Property | Border | Gets or sets the border information used to outline the label.
Public Property | Font | Gets or sets the FontInfo information used to draw the text of the label.
Public Property | Format | Gets or sets the format string used to draw the label.
Top
See Also

Reference

LabelInfo Class
GrapeCity.ActiveReports.Chart Namespace


Alignment Property (LabelInfo)

Alignment Property (LabelInfo)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class : Alignment Property
Gets or sets the label alignment around the anchor point.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Alignment As Alignment
public Alignment Alignment {get; set;}
See Also

Reference

LabelInfo Class
LabelInfo Members
Alignment Enumeration


Backdrop Property (LabelInfo)

Backdrop Property (LabelInfo)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class : Backdrop Property
Gets or sets the backdrop information to be used for the label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Backdrop As Backdrop
public Backdrop Backdrop {get; set;}
See Also

Reference

LabelInfo Class
LabelInfo Members


Border Property (LabelInfo)

Border Property (LabelInfo)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class : Border Property
Gets or sets the border information used to outline the label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Border As Line
public Line Border {get; set;}
See Also

Reference

LabelInfo Class
LabelInfo Members


Font Property (LabelInfo)

Font Property (LabelInfo)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class : Font Property
Gets or sets the FontInfo information used to draw the text of the label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Font As FontInfo
public FontInfo Font {get; set;}
See Also

Reference

LabelInfo Class
LabelInfo Members


Format Property (LabelInfo)

Format Property (LabelInfo)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelInfo Class : Format Property
Gets or sets the format string used to draw the label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Format As System.String
public System.string Format {get; set;}
Remarks

The ActiveReports chart control use standard Visual Studio .NET formatting syntax. The format is {Tag : Format}. For example, {Value:C} would format the text as currency. {Value:D} would format the text as a date.

Tag (variable) | Description | Example
Index | Point's index |
Value | Data value. The same as Value0 for category-based renderers, Value2 - for BubbleXY graphs, etc. | {Value}
Value# [1] | Zero-based integer indicating series value. | {Value0}
Total | Series total (sum of all points in this series) |
Pct | Is equal to Value/Total |
Pct[#] | Is equal to Value#/Total |
Xvalue | Point's X-value. X-value for XY-charts. The same as point index for category based charts. |
PTotal | Sum of all series values on this layer for this point |
PPct | Is equal to Value/PointTotal |

See Also

Reference

LabelInfo Class
LabelInfo Members


LabelsCollection Class

LabelsCollection Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : LabelsCollection Class
Specifies the settings for the labels collection.
Object Model
LabelsCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class LabelsCollection
public sealed class LabelsCollection
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.LabelsCollection

See Also

Reference

LabelsCollection Members
GrapeCity.ActiveReports.Chart Namespace


LabelsCollection Class Members

LabelsCollection Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : LabelsCollection Class

The following tables list the members exposed by LabelsCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the count of labels in the collection.
Public Property | Item | Gets or sets the specified label in the collection.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a label to the collection.
Public Method | AddRange | Adds a set of labels to the collection.
Public Method | Clear | Clears all labels from the collection.
Public Method | Clone | Creates a clone of the labels collection.
Public Method | Contains | Determines whether the collection contains the specified label.
Public Method | CopyTo | Copies the collection to an array, starting at the specified index.
Public Method | GetLabels | Gets a string array of the labels in the collection.
Public Method | IndexOf | Returns the index of the first occurrence of a label in the collection.
Public Method | Insert | Inserts the specified label into the collection at the specified index.
Public Method | Remove | Removes the specified label from the collection.
Public Method | RemoveAt | Removes the label at the specified location from the collection.
Top
See Also

Reference

LabelsCollection Class
GrapeCity.ActiveReports.Chart Namespace


LabelsCollection Class Methods

LabelsCollection Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : LabelsCollection Class

For a list of all members of this type, see LabelsCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a label to the collection.
Public Method | AddRange | Adds a set of labels to the collection.
Public Method | Clear | Clears all labels from the collection.
Public Method | Clone | Creates a clone of the labels collection.
Public Method | Contains | Determines whether the collection contains the specified label.
Public Method | CopyTo | Copies the collection to an array, starting at the specified index.
Public Method | GetLabels | Gets a string array of the labels in the collection.
Public Method | IndexOf | Returns the index of the first occurrence of a label in the collection.
Public Method | Insert | Inserts the specified label into the collection at the specified index.
Public Method | Remove | Removes the specified label from the collection.
Public Method | RemoveAt | Removes the label at the specified location from the collection.
Top
See Also

Reference

LabelsCollection Class
GrapeCity.ActiveReports.Chart Namespace


Add Method (LabelsCollection)

Add Method (LabelsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : Add Method
The label to add to the collection.
Adds a label to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As System.String _
) As System.Integer
public System.int Add(
   System.string value
)

Parameters

value
The label to add to the collection.
See Also

Reference

LabelsCollection Class
LabelsCollection Members


AddRange Method (LabelsCollection)

AddRange Method (LabelsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : AddRange Method
The labels to add to the collection.
Adds a set of labels to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddRange( _
   ByVal value() As System.String _
)
public void AddRange(
   System.string[] value
)

Parameters

value
The labels to add to the collection.
See Also

Reference

LabelsCollection Class
LabelsCollection Members


Clear Method (LabelsCollection)

Clear Method (LabelsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : Clear Method
Clears all labels from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

LabelsCollection Class
LabelsCollection Members


Clone Method (LabelsCollection)

Clone Method (LabelsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : Clone Method

Creates a clone of the labels collection.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Clone() As System.Object
public System.object Clone()
See Also

Reference

LabelsCollection Class
LabelsCollection Members


Contains Method (LabelsCollection)

Contains Method (LabelsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : Contains Method

The label for which to check.

Determines whether the collection contains the specified label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal value As System.String _
) As System.Boolean
public System.bool Contains(
   System.string value
)

Parameters

value

The label for which to check.

Return Value

True if the collection contains the parameter given; otherwise False.
See Also

Reference

LabelsCollection Class
LabelsCollection Members


CopyTo Method (LabelsCollection)

CopyTo Method (LabelsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : CopyTo Method
The array to which to copy the collection.
The index from which to start.
Copies the collection to an array, starting at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal array() As CustomAxis, _
   ByVal index As System.Integer _
)
public void CopyTo(
   CustomAxis[] array,
   System.int index
)

Parameters

array
The array to which to copy the collection.
index
The index from which to start.
See Also

Reference

LabelsCollection Class
LabelsCollection Members


GetLabels Method

GetLabels Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : GetLabels Method
Gets a string array of the labels in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLabels() As System.String()
public System.string[] GetLabels()
See Also

Reference

LabelsCollection Class
LabelsCollection Members


IndexOf Method (LabelsCollection)

IndexOf Method (LabelsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : IndexOf Method
The label to locate in the collection.
Returns the index of the first occurrence of a label in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As System.String _
) As System.Integer
public System.int IndexOf(
   System.string value
)

Parameters

value
The label to locate in the collection.

Return Value

The index of the first occurrence of the value within the entire array, if found; otherwise, the lower bound of the array - 1.

See Also

Reference

LabelsCollection Class
LabelsCollection Members


Insert Method (LabelsCollection)

Insert Method (LabelsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : Insert Method
The index at which to insert the label.
The label to insert.
Inserts the specified label into the collection at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As System.String _
)
public void Insert(
   System.int index,
   System.string value
)

Parameters

index
The index at which to insert the label.
value
The label to insert.
See Also

Reference

LabelsCollection Class
LabelsCollection Members


Remove Method (LabelsCollection)

Remove Method (LabelsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : Remove Method
The label to remove
Removes the specified label from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As System.String _
)
public void Remove(
   System.string value
)

Parameters

value
The label to remove
See Also

Reference

LabelsCollection Class
LabelsCollection Members


RemoveAt Method (LabelsCollection)

RemoveAt Method (LabelsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : RemoveAt Method
The index of the label to remove.
Removes the label at the specified location from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The index of the label to remove.
See Also

Reference

LabelsCollection Class
LabelsCollection Members


LabelsCollection Class Properties

LabelsCollection Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : LabelsCollection Class

For a list of all members of this type, see LabelsCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the count of labels in the collection.
Public Property | Item | Gets or sets the specified label in the collection.
Top
See Also

Reference

LabelsCollection Class
GrapeCity.ActiveReports.Chart Namespace


Count Property (LabelsCollection)

Count Property (LabelsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : Count Property
Gets the count of labels in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

LabelsCollection Class
LabelsCollection Members


Item Property (LabelsCollection)

Item Property (LabelsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LabelsCollection Class : Item Property
Specifies the index of the label.
Gets or sets the specified label in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As System.String
public System.string this[
   System.int index
]; {get; set;}

Parameters

index
Specifies the index of the label.
See Also

Reference

LabelsCollection Class
LabelsCollection Members


Legend Class

Legend Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Legend Class
Represents the settings for the Legend object.
Object Model
Legend Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Legend
   Inherits DrawCustomizableComponent
public sealed class Legend : DrawCustomizableComponent
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Legend

See Also

Reference

Legend Members
GrapeCity.ActiveReports.Chart Namespace


Legend Class Members

Legend Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Legend Class

The following tables list the members exposed by Legend.

Public Constructors
 | Name | Description
Public Constructor | Legend Constructor | Initializes a new instance of the Legend class.
Top
Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the floating legend alignment within the chart area.
Public Property | Backdrop | Gets or sets the backdrop information with which to fill the legend box.
Public Property | Border | Gets or sets the border information with which to outline the legend box.
Public Property | CustomBorderDrawer | Gets or sets the custom draw object.
Public Property | DockArea | Gets or sets the chart area to which the legend is docked.
Public Property | DockInsideArea | Gets or sets a value indicating whether the legend will be docked inside the containing area.
Public Property | Footer | Gets or sets the footer title for the Legend.
Public Property | GridLayout | Gets or sets the grid layout for the Legend.
Public Property | Header | Gets or sets the header title for the legend.
Public Property | LabelsFont | Gets or sets the label font information used for the Legend.
Public Property | LegendItems | Gets the custom legend items collection.
Public Property | MarginX | Gets or sets the floating legend horizontal margin.
Public Property | MarginY | Gets or sets the floating legend vertical margin.
Public Property | Visible | Gets or sets a value indicating whether the legend is visible.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Legend object.
Top
See Also

Reference

Legend Class
GrapeCity.ActiveReports.Chart Namespace


Legend Constructor

Legend Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : Legend Constructor
Initializes a new instance of the Legend class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Legend()
See Also

Reference

Legend Class
Legend Members


Legend Class Methods

Legend Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Legend Class

For a list of all members of this type, see Legend members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Legend object.
Top
See Also

Reference

Legend Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method (Legend)

Clone Method (Legend)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : Clone Method
Creates a clone of the Legend object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

A clone of the Legend object.
See Also

Reference

Legend Class
Legend Members


Legend Class Properties

Legend Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Legend Class

For a list of all members of this type, see Legend members.

Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the floating legend alignment within the chart area.
Public Property | Backdrop | Gets or sets the backdrop information with which to fill the legend box.
Public Property | Border | Gets or sets the border information with which to outline the legend box.
Public Property | CustomBorderDrawer | Gets or sets the custom draw object.
Public Property | DockArea | Gets or sets the chart area to which the legend is docked.
Public Property | DockInsideArea | Gets or sets a value indicating whether the legend will be docked inside the containing area.
Public Property | Footer | Gets or sets the footer title for the Legend.
Public Property | GridLayout | Gets or sets the grid layout for the Legend.
Public Property | Header | Gets or sets the header title for the legend.
Public Property | LabelsFont | Gets or sets the label font information used for the Legend.
Public Property | LegendItems | Gets the custom legend items collection.
Public Property | MarginX | Gets or sets the floating legend horizontal margin.
Public Property | MarginY | Gets or sets the floating legend vertical margin.
Public Property | Visible | Gets or sets a value indicating whether the legend is visible.
Top
See Also

Reference

Legend Class
GrapeCity.ActiveReports.Chart Namespace


Alignment Property (Legend)

Alignment Property (Legend)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : Alignment Property
Gets or sets the floating legend alignment within the chart area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Alignment As Alignment
public Alignment Alignment {get; set;}
See Also

Reference

Legend Class
Legend Members
Alignment Enumeration


Backdrop Property (Legend)

Backdrop Property (Legend)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : Backdrop Property
Gets or sets the backdrop information with which to fill the legend box.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Backdrop As BackdropItem
public BackdropItem Backdrop {get; set;}
See Also

Reference

Legend Class
Legend Members


Border Property (Legend)

Border Property (Legend)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : Border Property
Gets or sets the border information with which to outline the legend box.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Border As Border
public Border Border {get; set;}
See Also

Reference

Legend Class
Legend Members


CustomBorderDrawer Property (Legend)

CustomBorderDrawer Property (Legend)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : CustomBorderDrawer Property
Gets or sets the custom draw object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CustomBorderDrawer As ICustomBorderDrawer
public ICustomBorderDrawer CustomBorderDrawer {get; set;}
See Also

Reference

Legend Class
Legend Members


DockArea Property (Legend)

DockArea Property (Legend)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : DockArea Property

Gets or sets the chart area to which the legend is docked.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DockArea As ChartArea
public ChartArea DockArea {get; set;}

Property Value

The dock area.
See Also

Reference

Legend Class
Legend Members


DockInsideArea Property

DockInsideArea Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : DockInsideArea Property
Gets or sets a value indicating whether the legend will be docked inside the containing area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DockInsideArea As System.Boolean
public System.bool DockInsideArea {get; set;}

Property Value

Boolean. True if the legend will be docked inside the containing area; otherwise False.
See Also

Reference

Legend Class
Legend Members


Footer Property (Legend)

Footer Property (Legend)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : Footer Property
Gets or sets the footer title for the Legend.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Footer As Title
public Title Footer {get; set;}
See Also

Reference

Legend Class
Legend Members


GridLayout Property (Legend)

GridLayout Property (Legend)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : GridLayout Property
Gets or sets the grid layout for the Legend.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GridLayout As GridLayout
public GridLayout GridLayout {get; set;}

Property Value

The grid layout.
See Also

Reference

Legend Class
Legend Members


Header Property (Legend)

Header Property (Legend)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : Header Property
Gets or sets the header title for the legend.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Header As Title
public Title Header {get; set;}
See Also

Reference

Legend Class
Legend Members


LabelsFont Property

LabelsFont Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : LabelsFont Property
Gets or sets the label font information used for the Legend.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LabelsFont As FontInfo
public FontInfo LabelsFont {get; set;}
See Also

Reference

Legend Class
Legend Members


LegendItems Property (Legend)

LegendItems Property (Legend)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : LegendItems Property
Gets the custom legend items collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property LegendItems As LegendItemsCollection
public LegendItemsCollection LegendItems {get;}
See Also

Reference

Legend Class
Legend Members


MarginX Property

MarginX Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : MarginX Property
Gets or sets the floating legend horizontal margin.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MarginX As System.Integer
public System.int MarginX {get; set;}
See Also

Reference

Legend Class
Legend Members


MarginY Property

MarginY Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : MarginY Property
Gets or sets the floating legend vertical margin.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MarginY As System.Integer
public System.int MarginY {get; set;}
See Also

Reference

Legend Class
Legend Members


Visible Property (Legend)

Visible Property (Legend)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Legend Class : Visible Property
Gets or sets a value indicating whether the legend is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}
See Also

Reference

Legend Class
Legend Members


LegendItem Class

LegendItem Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendItem Class
Represents the settings for the LegendItem object.
Object Model
LegendItem Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class LegendItem
   Inherits ItemComponent
public sealed class LegendItem : ItemComponent
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.LegendItem

See Also

Reference

LegendItem Members
GrapeCity.ActiveReports.Chart Namespace


LegendItem Class Members

LegendItem Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendItem Class

The following tables list the members exposed by LegendItem.

Public Constructors
 | Name | Description
Public Constructor | LegendItem Constructor | Initializes a new instance of the LegendItem class.
Top
Public Properties
 | Name | Description
Public Property | Backdrop | Gets or sets the backdrop information to draw under the legend marker shape.
Public Property | Border | Gets or sets the border to draw around the legend item.
Public Property | Line | Gets or sets the line information to display.
Public Property | Marker | Gets or sets the series marker information to draw inside the legend marker.
Public Property | Style | Gets or sets the marker style.
Public Property | Text | Gets or sets the text as string to display in the legend.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the LegendItem.
Public Method | ToString | Returns a string that represents the LegendItem object.
Top
See Also

Reference

LegendItem Class
GrapeCity.ActiveReports.Chart Namespace


LegendItem Constructor

LegendItem Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItem Class : LegendItem Constructor
Initializes a new instance of the LegendItem class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public LegendItem()
See Also

Reference

LegendItem Class
LegendItem Members


LegendItem Class Methods

LegendItem Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendItem Class

For a list of all members of this type, see LegendItem members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the LegendItem.
Public Method | ToString | Returns a string that represents the LegendItem object.
Top
See Also

Reference

LegendItem Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method (LegendItem)

Clone Method (LegendItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItem Class : Clone Method
Creates a clone of the LegendItem.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

A clone of the LegendItem.
See Also

Reference

LegendItem Class
LegendItem Members


ToString Method (LegendItem)

ToString Method (LegendItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItem Class : ToString Method
Returns a string that represents the LegendItem object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()
See Also

Reference

LegendItem Class
LegendItem Members


LegendItem Class Properties

LegendItem Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendItem Class

For a list of all members of this type, see LegendItem members.

Public Properties
 | Name | Description
Public Property | Backdrop | Gets or sets the backdrop information to draw under the legend marker shape.
Public Property | Border | Gets or sets the border to draw around the legend item.
Public Property | Line | Gets or sets the line information to display.
Public Property | Marker | Gets or sets the series marker information to draw inside the legend marker.
Public Property | Style | Gets or sets the marker style.
Public Property | Text | Gets or sets the text as string to display in the legend.
Top
See Also

Reference

LegendItem Class
GrapeCity.ActiveReports.Chart Namespace


Backdrop Property (LegendItem)

Backdrop Property (LegendItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItem Class : Backdrop Property
Gets or sets the backdrop information to draw under the legend marker shape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Backdrop As Backdrop
public Backdrop Backdrop {get; set;}
See Also

Reference

LegendItem Class
LegendItem Members


Border Property (LegendItem)

Border Property (LegendItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItem Class : Border Property
Gets or sets the border to draw around the legend item.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Border As Border
public Border Border {get; set;}
See Also

Reference

LegendItem Class
LegendItem Members


Line Property (LegendItem)

Line Property (LegendItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItem Class : Line Property
Gets or sets the line information to display.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Line As Line
public Line Line {get; set;}
See Also

Reference

LegendItem Class
LegendItem Members


Marker Property (LegendItem)

Marker Property (LegendItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItem Class : Marker Property
Gets or sets the series marker information to draw inside the legend marker.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Marker As Marker
public Marker Marker {get; set;}
See Also

Reference

LegendItem Class
LegendItem Members


Style Property (LegendItem)

Style Property (LegendItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItem Class : Style Property
Gets or sets the marker style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As StdLegendMarker
public StdLegendMarker Style {get; set;}
See Also

Reference

LegendItem Class
LegendItem Members


Text Property (LegendItem)

Text Property (LegendItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItem Class : Text Property
Gets or sets the text as string to display in the legend.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Text As System.String
public System.string Text {get; set;}
Remarks
To display the X value in the legend, set the LegendText property on the Series to "{Name}."
See Also

Reference

LegendItem Class
LegendItem Members


LegendItemsCollection Class

LegendItemsCollection Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendItemsCollection Class
Represents the settings for the LegendItemsCollection class.
Object Model
LegendItemsCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class LegendItemsCollection
   Inherits System.Collections.CollectionBase
public sealed class LegendItemsCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.LegendItemsCollection

See Also

Reference

LegendItemsCollection Members
GrapeCity.ActiveReports.Chart Namespace


LegendItemsCollection Class Members

LegendItemsCollection Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendItemsCollection Class

The following tables list the members exposed by LegendItemsCollection.

Public Constructors
 | Name | Description
Public Constructor | LegendItemsCollection Constructor | Initializes new instance of the LegendItemsCollection class
Top
Public Properties
 | Name | Description
Public Property | Item | Overloaded. Get or sets the custom LegendItem at the given index.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a legend item to the collection.
Public Method | AddRange | Adds an array of legend items to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Clone | Creates a clone of the LegendItems collection.
Public Method | Contains | Determines whether the collection contains the specified LegendItem.
Public Method | CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Public Method | Equals | Compares the LegendItemsCollection object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts a LegendItem into the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific object from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

LegendItemsCollection Class
GrapeCity.ActiveReports.Chart Namespace


LegendItemsCollection Constructor

LegendItemsCollection Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : LegendItemsCollection Constructor
The array whose elements are copied in the new collection.
Initializes new instance of the LegendItemsCollection class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal itemsArray() As LegendItem _
)
public LegendItemsCollection(
   LegendItem[] itemsArray
)

Parameters

itemsArray
The array whose elements are copied in the new collection.
See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


LegendItemsCollection Class Methods

LegendItemsCollection Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendItemsCollection Class

For a list of all members of this type, see LegendItemsCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a legend item to the collection.
Public Method | AddRange | Adds an array of legend items to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Clone | Creates a clone of the LegendItems collection.
Public Method | Contains | Determines whether the collection contains the specified LegendItem.
Public Method | CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Public Method | Equals | Compares the LegendItemsCollection object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts a LegendItem into the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific object from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

LegendItemsCollection Class
GrapeCity.ActiveReports.Chart Namespace


Add Method (LegendItemsCollection)

Add Method (LegendItemsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : Add Method
The legend item to add to the collection.
Adds a legend item to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal item As LegendItem _
) As System.Integer
public System.int Add(
   LegendItem item
)

Parameters

item
The legend item to add to the collection.
See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


AddRange Method (LegendItemsCollection)

AddRange Method (LegendItemsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : AddRange Method
The legend items to add.
Adds an array of legend items to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddRange( _
   ByVal items() As LegendItem _
)
public void AddRange(
   LegendItem[] items
)

Parameters

items
The legend items to add.
See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


Clone Method (LegendItemsCollection)

Clone Method (LegendItemsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : Clone Method

Creates a clone of the LegendItems collection.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Clone() As System.Object
public System.object Clone()

Return Value

A new object that is a copy of this instance.
See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


Contains Method (LegendItemsCollection)

Contains Method (LegendItemsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : Contains Method
The legend item to check.
Determines whether the collection contains the specified LegendItem.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal value As LegendItem _
) As System.Boolean
public System.bool Contains(
   LegendItem value
)

Parameters

value
The legend item to check.

Return Value

True if the collection contains the parameter given; otherwise False.
See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


CopyTo Method (LegendItemsCollection)

CopyTo Method (LegendItemsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : CopyTo Method
The one-dimensional array that is the destination of the LegendItems copied from the collection. The array must have zero-based indexing.
The zero-based index in the array at which copying begins.
Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal array() As LegendItem, _
   ByVal index As System.Integer _
)
public void CopyTo(
   LegendItem[] array,
   System.int index
)

Parameters

array
The one-dimensional array that is the destination of the LegendItems copied from the collection. The array must have zero-based indexing.
index
The zero-based index in the array at which copying begins.

Return Value

`
See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


Equals Method (LegendItemsCollection)

Equals Method (LegendItemsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : Equals Method
The System.Object to which the LegendItemsCollection object is being compared.
Compares the LegendItemsCollection object to another System.Object to see whether they are equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The System.Object to which the LegendItemsCollection object is being compared.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.
See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


GetHashCode Method (LegendItemsCollection)

GetHashCode Method (LegendItemsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : GetHashCode Method
Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


IndexOf Method (LegendItemsCollection)

IndexOf Method (LegendItemsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : IndexOf Method
The object to locate in the array.
Returns the index of the first occurrence of a value in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As LegendItem _
) As System.Integer
public System.int IndexOf(
   LegendItem value
)

Parameters

value
The object to locate in the array.

Return Value

The index of the first occurrence of the value within the entire array, if found; otherwise, the lower bound of the array - 1.
See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


Insert Method (LegendItemsCollection)

Insert Method (LegendItemsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : Insert Method
The zero-based index at which the LegendItem should be inserted.
The LegendItem to insert.
Inserts a LegendItem into the collection at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As LegendItem _
)
public void Insert(
   System.int index,
   LegendItem item
)

Parameters

index
The zero-based index at which the LegendItem should be inserted.
item
The LegendItem to insert.
See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


Remove Method (LegendItemsCollection)

Remove Method (LegendItemsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : Remove Method
The LegendItem to remove from the collection.
Removes the first occurrence of a specific object from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal item As LegendItem _
)
public void Remove(
   LegendItem item
)

Parameters

item
The LegendItem to remove from the collection.
See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


LegendItemsCollection Class Properties

LegendItemsCollection Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendItemsCollection Class

For a list of all members of this type, see LegendItemsCollection members.

Public Properties
 | Name | Description
Public Property | Item | Overloaded. Get or sets the custom LegendItem at the given index.
Top
See Also

Reference

LegendItemsCollection Class
GrapeCity.ActiveReports.Chart Namespace


Item Property (LegendItemsCollection)

Item Property (LegendItemsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : Item Property
Get or sets the custom LegendItem at the given index.
Overload List
Overload | Description
Item(Int32) | Gets or sets the legend item in the collection.
Item(String) | Gets or sets the collection item by the given legend item name.
See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


Item(Int32) Property

Item(Int32) Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class > Item Property : Item(Int32) Property
Index of the item.
Gets or sets the legend item in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Property Item( _
   ByVal index As System.Integer _
) As LegendItem
public LegendItem Item(
   System.int index
) {get; set;}

Parameters

index
Index of the item.
See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members
Overload List


Item(String) Property

Item(String) Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class > Item Property : Item(String) Property
Name of the item.
Gets or sets the collection item by the given legend item name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal legendItemName As System.String _
) As LegendItem
public LegendItem Item(
   System.string legendItemName
) {get;}

Parameters

legendItemName
Name of the item.
See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members
Overload List


LegendsCollection Class

LegendsCollection Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendsCollection Class
Represents the settings for the LegendsCollection class.
Object Model
LegendsCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class LegendsCollection
   Inherits System.Collections.CollectionBase
public sealed class LegendsCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.LegendsCollection

See Also

Reference

LegendsCollection Members
GrapeCity.ActiveReports.Chart Namespace


LegendsCollection Class Members

LegendsCollection Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendsCollection Class

The following tables list the members exposed by LegendsCollection.

Public Constructors
 | Name | Description
Public Constructor | LegendsCollection Constructor | Initializes a new instance of the LegendsCollection class.
Top
Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Gets or sets the LegendsCollection item by the specified parameter.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a Legend to the collection.
Public Method | AddRange | Adds an array of Legends to the collection.
Public Method | Clear | Releases the LegendsCollection object from memory.
Public Method | Clone | Creates a clone of the LegendsCollection.
Public Method | Contains | Determines whether the collection contains the specified legend.
Public Method | CopyTo | Copies the entire collection to an array, starting at the specified index of the target array.
Public Method | Equals | Compares the LegendsCollection object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts a legend into the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific Legend from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

LegendsCollection Class
GrapeCity.ActiveReports.Chart Namespace


LegendsCollection Constructor

LegendsCollection Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : LegendsCollection Constructor
Initializes a new instance of the LegendsCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public LegendsCollection()
See Also

Reference

LegendsCollection Class
LegendsCollection Members


LegendsCollection Class Methods

LegendsCollection Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendsCollection Class

For a list of all members of this type, see LegendsCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a Legend to the collection.
Public Method | AddRange | Adds an array of Legends to the collection.
Public Method | Clear | Releases the LegendsCollection object from memory.
Public Method | Clone | Creates a clone of the LegendsCollection.
Public Method | Contains | Determines whether the collection contains the specified legend.
Public Method | CopyTo | Copies the entire collection to an array, starting at the specified index of the target array.
Public Method | Equals | Compares the LegendsCollection object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts a legend into the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific Legend from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

LegendsCollection Class
GrapeCity.ActiveReports.Chart Namespace


Add Method (LegendsCollection)

Add Method (LegendsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : Add Method
The Legend to add to the collection.
Adds a Legend to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As Legend _
) As System.Integer
public System.int Add(
   Legend value
)

Parameters

value
The Legend to add to the collection.
See Also

Reference

LegendsCollection Class
LegendsCollection Members


AddRange Method (LegendsCollection)

AddRange Method (LegendsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : AddRange Method
The Legends to add.
Adds an array of Legends to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddRange( _
   ByVal range() As Legend _
)
public void AddRange(
   Legend[] range
)

Parameters

range
The Legends to add.
See Also

Reference

LegendsCollection Class
LegendsCollection Members


Clear Method (LegendsCollection)

Clear Method (LegendsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : Clear Method
Releases the LegendsCollection object from memory.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Sub Clear()
public new void Clear()
See Also

Reference

LegendsCollection Class
LegendsCollection Members


Clone Method (LegendsCollection)

Clone Method (LegendsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : Clone Method
Creates a clone of the LegendsCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Clone() As System.Object
public System.object Clone()
See Also

Reference

LegendsCollection Class
LegendsCollection Members


Contains Method (LegendsCollection)

Contains Method (LegendsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : Contains Method
The legend to check.
Determines whether the collection contains the specified legend.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal value As Legend _
) As System.Boolean
public System.bool Contains(
   Legend value
)

Parameters

value
The legend to check.

Return Value

True if the collection contains the parameter given; otherwise False.
See Also

Reference

LegendsCollection Class
LegendsCollection Members


CopyTo Method (LegendsCollection)

CopyTo Method (LegendsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : CopyTo Method
The array to which to copy the collection.
The index from which to start copying.
Copies the entire collection to an array, starting at the specified index of the target array.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal array() As Legend, _
   ByVal index As System.Integer _
)
public void CopyTo(
   Legend[] array,
   System.int index
)

Parameters

array
The array to which to copy the collection.
index
The index from which to start copying.
See Also

Reference

LegendsCollection Class
LegendsCollection Members


Equals Method (LegendsCollection)

Equals Method (LegendsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : Equals Method
The System.Object to which the LegendsCollection object is being compared.
Compares the LegendsCollection object to another System.Object to see whether they are equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The System.Object to which the LegendsCollection object is being compared.
See Also

Reference

LegendsCollection Class
LegendsCollection Members


GetHashCode Method (LegendsCollection)

GetHashCode Method (LegendsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : GetHashCode Method
Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()
See Also

Reference

LegendsCollection Class
LegendsCollection Members


IndexOf Method (LegendsCollection)

IndexOf Method (LegendsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : IndexOf Method
The object to locate in the collection.
Returns the index of the first occurrence of a value in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As Legend _
) As System.Integer
public System.int IndexOf(
   Legend value
)

Parameters

value
The object to locate in the collection.

Return Value

The index of the first occurrence of the value within the entire array, if found; otherwise, the lower bound of the array - 1.
See Also

Reference

LegendsCollection Class
LegendsCollection Members


Insert Method (LegendsCollection)

Insert Method (LegendsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : Insert Method
The index at which the legend is inserted.
The legend to insert.
Inserts a legend into the collection at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As Legend _
)
public void Insert(
   System.int index,
   Legend value
)

Parameters

index
The index at which the legend is inserted.
value
The legend to insert.
See Also

Reference

LegendsCollection Class
LegendsCollection Members


Remove Method (LegendsCollection)

Remove Method (LegendsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : Remove Method
The legend to remove.
Removes the first occurrence of a specific Legend from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As Legend _
)
public void Remove(
   Legend value
)

Parameters

value
The legend to remove.
See Also

Reference

LegendsCollection Class
LegendsCollection Members


LegendsCollection Class Properties

LegendsCollection Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendsCollection Class

For a list of all members of this type, see LegendsCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Gets or sets the LegendsCollection item by the specified parameter.
Top
See Also

Reference

LegendsCollection Class
GrapeCity.ActiveReports.Chart Namespace


Item Property (LegendsCollection)

Item Property (LegendsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : Item Property

Gets or sets the LegendsCollection item by the specified parameter.

Overload List
Overload | Description
Item(Int32) | Gets or sets the collection item by the given index.
Item(String) | Gets or sets the collection item by the given legend name.
See Also

Reference

LegendsCollection Class
LegendsCollection Members


Item(Int32) Property

Item(Int32) Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class > Item Property : Item(Int32) Property
The index of the item.
Gets or sets the collection item by the given index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Property Item( _
   ByVal index As System.Integer _
) As Legend
public Legend Item(
   System.int index
) {get; set;}

Parameters

index
The index of the item.
See Also

Reference

LegendsCollection Class
LegendsCollection Members
Overload List


Item(String) Property

Item(String) Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class > Item Property : Item(String) Property
The name of the legend.
Gets or sets the collection item by the given legend name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal legendName As System.String _
) As Legend
public Legend Item(
   System.string legendName
) {get;}

Parameters

legendName
The name of the legend.
See Also

Reference

LegendsCollection Class
LegendsCollection Members
Overload List


Light Class

Light Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Light Class
Represents the settings of the Light object.
Object Model
Light Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Light
   Inherits Item
public sealed class Light : Item
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Light

See Also

Reference

Light Members
GrapeCity.ActiveReports.Chart Namespace


Light Class Members

Light Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Light Class

The following tables list the members exposed by Light.

Public Constructors
 | Name | Description
Public Constructor | Light Constructor | Overloaded. Initializes a new instance of the Light class.
Top
Public Properties
 | Name | Description
Public Property | DirectionalRatio | Gets or sets the directional/ambient intensity ratio.
Public Property | Source | Gets or sets the position of the light source (direction for infinite source).
Public Property | Type | Gets or sets the type of light source.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Light object.
Public Method | Equals | Compares the Light object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top
See Also

Reference

Light Class
GrapeCity.ActiveReports.Chart Namespace


Light Constructor

Light Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Light Class : Light Constructor
Initializes a new instance of the Light class.
Overload List
Overload | Description
Light Constructor() | Initializes a new instance of the Light class.
Light Constructor(Point3d,LightType,Single) | Initializes a new instance of the Light class with the specified parameters.
See Also

Reference

Light Class
Light Members


Light Constructor()

Light Constructor()

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Light Class > Light Constructor : Light Constructor()
Initializes a new instance of the Light class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Light()
See Also

Reference

Light Class
Light Members
Overload List


Light Constructor(Point3d,LightType,Single)

Light Constructor(Point3d,LightType,Single)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Light Class > Light Constructor : Light Constructor(Point3d,LightType,Single)
Specifies the position of the light source.
Specifies the type of light source.
Specifies the directional/ambient intensity ratio.
Initializes a new instance of the Light class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal source As Point3d, _
   ByVal type As LightType, _
   ByVal directionalRatio As System.Single _
)
public Light(
   Point3d source,
   LightType type,
   System.float directionalRatio
)

Parameters

source
Specifies the position of the light source.
type
Specifies the type of light source.
directionalRatio
Specifies the directional/ambient intensity ratio.
See Also

Reference

Light Class
Light Members
Overload List


Light Class Methods

Light Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Light Class

For a list of all members of this type, see Light members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Light object.
Public Method | Equals | Compares the Light object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top
See Also

Reference

Light Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method (Light)

Clone Method (Light)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Light Class : Clone Method
Creates a clone of the Light object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

A clone of the Light object.
See Also

Reference

Light Class
Light Members


Equals Method (Light)

Equals Method (Light)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Light Class : Equals Method
The System.Object to which the Light object is being compared.
Compares the Light object to another System.Object to see whether they are equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The System.Object to which the Light object is being compared.
See Also

Reference

Light Class
Light Members


GetHashCode Method (Light)

GetHashCode Method (Light)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Light Class : GetHashCode Method
Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()
See Also

Reference

Light Class
Light Members


Light Class Properties

Light Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Light Class

For a list of all members of this type, see Light members.

Public Properties
 | Name | Description
Public Property | DirectionalRatio | Gets or sets the directional/ambient intensity ratio.
Public Property | Source | Gets or sets the position of the light source (direction for infinite source).
Public Property | Type | Gets or sets the type of light source.
Top
See Also

Reference

Light Class
GrapeCity.ActiveReports.Chart Namespace


DirectionalRatio Property

DirectionalRatio Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Light Class : DirectionalRatio Property
Gets or sets the directional/ambient intensity ratio.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DirectionalRatio As System.Single
public System.float DirectionalRatio {get; set;}
See Also

Reference

Light Class
Light Members


Source Property (Light)

Source Property (Light)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Light Class : Source Property
Gets or sets the position of the light source (direction for infinite source).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Source As Point3d
public Point3d Source {get; set;}
See Also

Reference

Light Class
Light Members


Type Property (Light)

Type Property (Light)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Light Class : Type Property
Gets or sets the type of light source.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Type As LightType
public LightType Type {get; set;}
See Also

Reference

Light Class
Light Members


Marker Class

Marker Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Marker Class
Represents the settings for the Marker object.
Object Model
Marker Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Marker
   Inherits MouseEnabledItem
public sealed class Marker : MouseEnabledItem
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Marker

See Also

Reference

Marker Members
GrapeCity.ActiveReports.Chart Namespace


Marker Class Members

Marker Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Marker Class

The following tables list the members exposed by Marker.

Public Constructors
 | Name | Description
Public Constructor | Marker Constructor | Overloaded. Initializes a new instance of the Marker class.
Top
Public Properties
 | Name | Description
Public Property | Backdrop | Gets or sets the backdrop information used to fill the Marker.
Public Property | Label | Gets or sets the label information for the Marker.
Public Property | LabelDistanceFactor | Gets or sets the value to set the distance of the label of the marker from the graph.
Public Property | Line | Gets or sets the line information used to draw the outline of the Marker.
Public Property | Size | Gets or sets the size of the Marker, in pixels.
Public Property | Style | Gets or sets the shape of the Marker.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Marker object.
Public Method | Equals | Compares the Marker object to another System.Object to see if they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top
See Also

Reference

Marker Class
GrapeCity.ActiveReports.Chart Namespace


Marker Constructor

Marker Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class : Marker Constructor
Initializes a new instance of the Marker class.
Overload List
Overload | Description
Marker Constructor() | Initializes a new instance of the Marker class.
Marker Constructor(AntiAliasMode) | Initializes a new instance of the Marker class with the specified AntiAliasMode.
Marker Constructor(Int32,MarkerStyle,Backdrop,Line,LabelInfo) | Initializes a new instance of the Marker class with the specified parameters.
Marker Constructor(Int32,MarkerStyle,Backdrop,Line,LabelInfo,Single) | Initializes new instance of the MarkerInfo class
Marker Constructor(Int32,MarkerStyle,Backdrop,Line,LabelInfo,AntiAliasMode) | Initializes a new instance of the Marker class with the specified parameters.
See Also

Reference

Marker Class
Marker Members


Marker Constructor()

Marker Constructor()

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class > Marker Constructor : Marker Constructor()
Initializes a new instance of the Marker class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Marker()
See Also

Reference

Marker Class
Marker Members
Overload List


Marker Constructor(AntiAliasMode)

Marker Constructor(AntiAliasMode)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class > Marker Constructor : Marker Constructor(AntiAliasMode)
Specifies the antialias mode to use.
Initializes a new instance of the Marker class with the specified AntiAliasMode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal antiAliasMode As AntiAliasMode _
)
public Marker(
   AntiAliasMode antiAliasMode
)

Parameters

antiAliasMode
Specifies the antialias mode to use.
See Also

Reference

Marker Class
Marker Members
Overload List


Marker Constructor(Int32,MarkerStyle,Backdrop,Line,LabelInfo)

Marker Constructor(Int32,MarkerStyle,Backdrop,Line,LabelInfo)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class > Marker Constructor : Marker Constructor(Int32,MarkerStyle,Backdrop,Line,LabelInfo)
Specifies the size of the Marker, in pixels.
Specifies the style of the Marker.
Specifies the backdrop information used to fill the Marker.
Specifies the line information used to draw the outline of the Marker.
Specifies the label information used for the Marker.
Initializes a new instance of the Marker class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal size As System.Integer, _
   ByVal style As MarkerStyle, _
   ByVal backdrop As Backdrop, _
   ByVal line As Line, _
   ByVal label As LabelInfo _
)
public Marker(
   System.int size,
   MarkerStyle style,
   Backdrop backdrop,
   Line line,
   LabelInfo label
)

Parameters

size
Specifies the size of the Marker, in pixels.
style
Specifies the style of the Marker.
backdrop
Specifies the backdrop information used to fill the Marker.
line
Specifies the line information used to draw the outline of the Marker.
label
Specifies the label information used for the Marker.
See Also

Reference

Marker Class
Marker Members
Overload List


Marker Constructor(Int32,MarkerStyle,Backdrop,Line,LabelInfo,Single)

Marker Constructor(Int32,MarkerStyle,Backdrop,Line,LabelInfo,Single)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class > Marker Constructor : Marker Constructor(Int32,MarkerStyle,Backdrop,Line,LabelInfo,Single)
Specifies the size of the Marker, in pixels.
Specifies the style of the Marker.
Specifies the backdrop information used to fill the Marker.
Specifies the line information used to draw the outline of the Marker.
Specifies the label information used for the Marker.
Label distance factor.
Initializes new instance of the MarkerInfo class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal size As System.Integer, _
   ByVal style As MarkerStyle, _
   ByVal backdrop As Backdrop, _
   ByVal line As Line, _
   ByVal label As LabelInfo, _
   ByVal labelDistanceFactor As System.Single _
)
public Marker(
   System.int size,
   MarkerStyle style,
   Backdrop backdrop,
   Line line,
   LabelInfo label,
   System.float labelDistanceFactor
)

Parameters

size
Specifies the size of the Marker, in pixels.
style
Specifies the style of the Marker.
backdrop
Specifies the backdrop information used to fill the Marker.
line
Specifies the line information used to draw the outline of the Marker.
label
Specifies the label information used for the Marker.
labelDistanceFactor
Label distance factor.
See Also

Reference

Marker Class
Marker Members
Overload List


Marker Constructor(Int32,MarkerStyle,Backdrop,Line,LabelInfo,AntiAliasMode)

Marker Constructor(Int32,MarkerStyle,Backdrop,Line,LabelInfo,AntiAliasMode)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class > Marker Constructor : Marker Constructor(Int32,MarkerStyle,Backdrop,Line,LabelInfo,AntiAliasMode)
Specifies the size of the Marker, in pixels.
Specifies the style of the Marker.
Specifies the backdrop information used to fill the Marker.
Specifies the line information used to draw the outline of the Marker.
Specifies the label information used for the Marker.
Specifies the antialias mode to use.
Initializes a new instance of the Marker class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal size As System.Integer, _
   ByVal style As MarkerStyle, _
   ByVal backdrop As Backdrop, _
   ByVal line As Line, _
   ByVal label As LabelInfo, _
   ByVal antiAliasMode As AntiAliasMode _
)
public Marker(
   System.int size,
   MarkerStyle style,
   Backdrop backdrop,
   Line line,
   LabelInfo label,
   AntiAliasMode antiAliasMode
)

Parameters

size
Specifies the size of the Marker, in pixels.
style
Specifies the style of the Marker.
backdrop
Specifies the backdrop information used to fill the Marker.
line
Specifies the line information used to draw the outline of the Marker.
label
Specifies the label information used for the Marker.
antiAliasMode
Specifies the antialias mode to use.
See Also

Reference

Marker Class
Marker Members
Overload List


Marker Class Methods

Marker Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Marker Class

For a list of all members of this type, see Marker members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Marker object.
Public Method | Equals | Compares the Marker object to another System.Object to see if they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top
See Also

Reference

Marker Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method (Marker)

Clone Method (Marker)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class : Clone Method
Creates a clone of the Marker object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

A clone of the Marker object.
See Also

Reference

Marker Class
Marker Members


Equals Method (Marker)

Equals Method (Marker)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class : Equals Method
The System.Object to which the Marker object is being compared.
Compares the Marker object to another System.Object to see if they are equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The System.Object to which the Marker object is being compared.
See Also

Reference

Marker Class
Marker Members


GetHashCode Method (Marker)

GetHashCode Method (Marker)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class : GetHashCode Method
Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()
See Also

Reference

Marker Class
Marker Members


Marker Class Properties

Marker Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Marker Class

For a list of all members of this type, see Marker members.

Public Properties
 | Name | Description
Public Property | Backdrop | Gets or sets the backdrop information used to fill the Marker.
Public Property | Label | Gets or sets the label information for the Marker.
Public Property | LabelDistanceFactor | Gets or sets the value to set the distance of the label of the marker from the graph.
Public Property | Line | Gets or sets the line information used to draw the outline of the Marker.
Public Property | Size | Gets or sets the size of the Marker, in pixels.
Public Property | Style | Gets or sets the shape of the Marker.
Top
See Also

Reference

Marker Class
GrapeCity.ActiveReports.Chart Namespace


Backdrop Property (Marker)

Backdrop Property (Marker)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class : Backdrop Property
Gets or sets the backdrop information used to fill the Marker.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Backdrop As Backdrop
public Backdrop Backdrop {get; set;}
See Also

Reference

Marker Class
Marker Members


Label Property (Marker)

Label Property (Marker)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class : Label Property
Gets or sets the label information for the Marker.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Label As LabelInfo
public LabelInfo Label {get; set;}
See Also

Reference

Marker Class
Marker Members


LabelDistanceFactor Property

LabelDistanceFactor Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class : LabelDistanceFactor Property
Gets or sets the value to set the distance of the label of the marker from the graph.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LabelDistanceFactor As System.Single
public System.float LabelDistanceFactor {get; set;}
See Also

Reference

Marker Class
Marker Members


Line Property (Marker)

Line Property (Marker)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class : Line Property
Gets or sets the line information used to draw the outline of the Marker.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Line As Line
public Line Line {get; set;}
See Also

Reference

Marker Class
Marker Members


Size Property (Marker)

Size Property (Marker)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class : Size Property
Gets or sets the size of the Marker, in pixels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Size As System.Integer
public System.int Size {get; set;}
See Also

Reference

Marker Class
Marker Members


Style Property (Marker)

Style Property (Marker)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Marker Class : Style Property
Gets or sets the shape of the Marker.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As MarkerStyle
public MarkerStyle Style {get; set;}
See Also

Reference

Marker Class
Marker Members


PlaneItem Class

PlaneItem Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : PlaneItem Class
Represents the settings for the PlaneItem object used for the chart walls.
Object Model
PlaneItem Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class PlaneItem
   Inherits MouseEnabledItem
public sealed class PlaneItem : MouseEnabledItem
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.PlaneItem

See Also

Reference

PlaneItem Members
GrapeCity.ActiveReports.Chart Namespace


PlaneItem Class Members

PlaneItem Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : PlaneItem Class

The following tables list the members exposed by PlaneItem.

Public Constructors
 | Name | Description
Public Constructor | PlaneItem Constructor | Overloaded. Initializes a new instance of the PlaneItem class.
Top
Public Properties
 | Name | Description
Public Property | Backdrop | Gets or sets the backdrop information for the chart wall.
Public Property | Visible | Gets or sets a value indicating whether the chart wall is visible.
Public Property | Width | Gets or sets the width (thickness) of the chart wall.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the PlaneItem object.
Public Method | Equals | Overridden.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top
See Also

Reference

PlaneItem Class
GrapeCity.ActiveReports.Chart Namespace


PlaneItem Constructor

PlaneItem Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class : PlaneItem Constructor

Initializes a new instance of the PlaneItem class.

Overload List
Overload | Description
PlaneItem Constructor() | Initializes a new instance of the PlaneItem class.
PlaneItem Constructor(AntiAliasMode) | Initializes a new instance of the PlaneItem class with the specified AntiAliasMode.
PlaneItem Constructor(Backdrop) | Initializes a new instance of the PlaneItem class with the specified backdrop info.
PlaneItem Constructor(Backdrop,AntiAliasMode) | Initializes a new instance of the PlaneItem class with the specified parameters.
PlaneItem Constructor(Backdrop,Single) | Initializes a new instance of the PlaneItem class with the specified parameters.
PlaneItem Constructor(Backdrop,Single,AntiAliasMode) | Initializes a new instance of the PlaneItem class with the specified parameters.
PlaneItem Constructor(Backdrop,Boolean,Single) | Initializes a new instance of the PlaneItem class with the specified parameters.
PlaneItem Constructor(Backdrop,Boolean,Single,AntiAliasMode) | Initializes a new instance of the PlaneItem class with the specified parameters.
PlaneItem Constructor(AntiAliasMode,Backdrop,Boolean,Single,ContextMenu) | Initializes a new instance of the PlaneItem class with the specified parameters.
See Also

Reference

PlaneItem Class
PlaneItem Members


PlaneItem Constructor()

PlaneItem Constructor()

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class > PlaneItem Constructor : PlaneItem Constructor()

Initializes a new instance of the PlaneItem class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public PlaneItem()
See Also

Reference

PlaneItem Class
PlaneItem Members
Overload List


PlaneItem Constructor(AntiAliasMode)

PlaneItem Constructor(AntiAliasMode)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class > PlaneItem Constructor : PlaneItem Constructor(AntiAliasMode)
Specifies the antialias mode to use.
Initializes a new instance of the PlaneItem class with the specified AntiAliasMode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal antiAliasMode As AntiAliasMode _
)
public PlaneItem(
   AntiAliasMode antiAliasMode
)

Parameters

antiAliasMode
Specifies the antialias mode to use.
See Also

Reference

PlaneItem Class
PlaneItem Members
Overload List


PlaneItem Constructor(Backdrop)

PlaneItem Constructor(Backdrop)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class > PlaneItem Constructor : PlaneItem Constructor(Backdrop)
Specifies the backdrop information used to fill the wall rectangle.
Initializes a new instance of the PlaneItem class with the specified backdrop info.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal backdrop As Backdrop _
)
public PlaneItem(
   Backdrop backdrop
)

Parameters

backdrop
Specifies the backdrop information used to fill the wall rectangle.
See Also

Reference

PlaneItem Class
PlaneItem Members
Overload List


PlaneItem Constructor(Backdrop,AntiAliasMode)

PlaneItem Constructor(Backdrop,AntiAliasMode)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class > PlaneItem Constructor : PlaneItem Constructor(Backdrop,AntiAliasMode)
Specifies the backdrop information used to fill the wall rectangle.
Specifies the antialias mode to use.
Initializes a new instance of the PlaneItem class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal backdrop As Backdrop, _
   ByVal antiAliasMode As AntiAliasMode _
)
public PlaneItem(
   Backdrop backdrop,
   AntiAliasMode antiAliasMode
)

Parameters

backdrop
Specifies the backdrop information used to fill the wall rectangle.
antiAliasMode
Specifies the antialias mode to use.
See Also

Reference

PlaneItem Class
PlaneItem Members
Overload List


PlaneItem Constructor(Backdrop,Single)

PlaneItem Constructor(Backdrop,Single)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class > PlaneItem Constructor : PlaneItem Constructor(Backdrop,Single)
Specifies the backdrop information used to fill the wall rectangle.
Specifies the width of the chart wall.
Initializes a new instance of the PlaneItem class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal backdrop As Backdrop, _
   ByVal width As System.Single _
)
public PlaneItem(
   Backdrop backdrop,
   System.float width
)

Parameters

backdrop
Specifies the backdrop information used to fill the wall rectangle.
width
Specifies the width of the chart wall.
See Also

Reference

PlaneItem Class
PlaneItem Members
Overload List


PlaneItem Constructor(Backdrop,Single,AntiAliasMode)

PlaneItem Constructor(Backdrop,Single,AntiAliasMode)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class > PlaneItem Constructor : PlaneItem Constructor(Backdrop,Single,AntiAliasMode)
Specifies the backdrop information used to fill the wall rectangle.
Specifies the width of the chart wall.
Specifies the antialias mode to use.
Initializes a new instance of the PlaneItem class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal backdrop As Backdrop, _
   ByVal width As System.Single, _
   ByVal antiAliasMode As AntiAliasMode _
)
public PlaneItem(
   Backdrop backdrop,
   System.float width,
   AntiAliasMode antiAliasMode
)

Parameters

backdrop
Specifies the backdrop information used to fill the wall rectangle.
width
Specifies the width of the chart wall.
antiAliasMode
Specifies the antialias mode to use.
See Also

Reference

PlaneItem Class
PlaneItem Members
Overload List


PlaneItem Constructor(Backdrop,Boolean,Single)

PlaneItem Constructor(Backdrop,Boolean,Single)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class > PlaneItem Constructor : PlaneItem Constructor(Backdrop,Boolean,Single)
Specifies the backdrop information used to fill the wall rectangle.
Specifies whether the chart wall is visible.
Specifies the width of the chart wall.
Initializes a new instance of the PlaneItem class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal backdrop As Backdrop, _
   ByVal visible As System.Boolean, _
   ByVal width As System.Single _
)
public PlaneItem(
   Backdrop backdrop,
   System.bool visible,
   System.float width
)

Parameters

backdrop
Specifies the backdrop information used to fill the wall rectangle.
visible
Specifies whether the chart wall is visible.
width
Specifies the width of the chart wall.
See Also

Reference

PlaneItem Class
PlaneItem Members
Overload List


PlaneItem Constructor(Backdrop,Boolean,Single,AntiAliasMode)

PlaneItem Constructor(Backdrop,Boolean,Single,AntiAliasMode)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class > PlaneItem Constructor : PlaneItem Constructor(Backdrop,Boolean,Single,AntiAliasMode)
Specifies the backdrop information used to fill the wall rectangle.
Specifies whether the chart wall is visible.
Specifies the width of the chart wall.
Specifies the antialias mode to use.
Initializes a new instance of the PlaneItem class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal backdrop As Backdrop, _
   ByVal visible As System.Boolean, _
   ByVal width As System.Single, _
   ByVal antiAliasMode As AntiAliasMode _
)
public PlaneItem(
   Backdrop backdrop,
   System.bool visible,
   System.float width,
   AntiAliasMode antiAliasMode
)

Parameters

backdrop
Specifies the backdrop information used to fill the wall rectangle.
visible
Specifies whether the chart wall is visible.
width
Specifies the width of the chart wall.
antiAliasMode
Specifies the antialias mode to use.
See Also

Reference

PlaneItem Class
PlaneItem Members
Overload List


PlaneItem Constructor(AntiAliasMode,Backdrop,Boolean,Single,ContextMenu)

PlaneItem Constructor(AntiAliasMode,Backdrop,Boolean,Single,ContextMenu)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class > PlaneItem Constructor : PlaneItem Constructor(AntiAliasMode,Backdrop,Boolean,Single,ContextMenu)
Specifies the antialias mode to use.
Specifies the backdrop information used to fill the wall rectangle.
Specifies whether the chart wall is visible.
Specifies the width of the chart wall.
Specifies the menu to be used as the context menu for the chart wall.
Initializes a new instance of the PlaneItem class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal antiAliasMode As AntiAliasMode, _
   ByVal backdrop As Backdrop, _
   ByVal visible As System.Boolean, _
   ByVal width As System.Single, _
   ByVal contextMenu As System.Windows.Forms.ContextMenu _
)
public PlaneItem(
   AntiAliasMode antiAliasMode,
   Backdrop backdrop,
   System.bool visible,
   System.float width,
   System.Windows.Forms.ContextMenu contextMenu
)

Parameters

antiAliasMode
Specifies the antialias mode to use.
backdrop
Specifies the backdrop information used to fill the wall rectangle.
visible
Specifies whether the chart wall is visible.
width
Specifies the width of the chart wall.
contextMenu
Specifies the menu to be used as the context menu for the chart wall.
See Also

Reference

PlaneItem Class
PlaneItem Members
Overload List


PlaneItem Class Methods

PlaneItem Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : PlaneItem Class

For a list of all members of this type, see PlaneItem members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the PlaneItem object.
Public Method | Equals | Overridden.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top
See Also

Reference

PlaneItem Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method (PlaneItem)

Clone Method (PlaneItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class : Clone Method
Creates a clone of the PlaneItem object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

A clone of the PlaneItem object.
See Also

Reference

PlaneItem Class
PlaneItem Members


Equals Method (PlaneItem)

Equals Method (PlaneItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class : Equals Method

The System.Object to which the PlaneItem object is being compared.

Overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj

The System.Object to which the PlaneItem object is being compared.

Return Value

Compares the PlaneItem object to another System.Object to see whether they are equal.
See Also

Reference

PlaneItem Class
PlaneItem Members


GetHashCode Method (PlaneItem)

GetHashCode Method (PlaneItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class : GetHashCode Method
Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

PlaneItem Class
PlaneItem Members


PlaneItem Class Properties

PlaneItem Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : PlaneItem Class

For a list of all members of this type, see PlaneItem members.

Public Properties
 | Name | Description
Public Property | Backdrop | Gets or sets the backdrop information for the chart wall.
Public Property | Visible | Gets or sets a value indicating whether the chart wall is visible.
Public Property | Width | Gets or sets the width (thickness) of the chart wall.
Top
See Also

Reference

PlaneItem Class
GrapeCity.ActiveReports.Chart Namespace


Backdrop Property (PlaneItem)

Backdrop Property (PlaneItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class : Backdrop Property
Gets or sets the backdrop information for the chart wall.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Backdrop As Backdrop
public Backdrop Backdrop {get; set;}
See Also

Reference

PlaneItem Class
PlaneItem Members


Visible Property (PlaneItem)

Visible Property (PlaneItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class : Visible Property
Gets or sets a value indicating whether the chart wall is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}
See Also

Reference

PlaneItem Class
PlaneItem Members


Width Property (PlaneItem)

Width Property (PlaneItem)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > PlaneItem Class : Width Property

Gets or sets the width (thickness) of the chart wall.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As System.Single
public System.float Width {get; set;}
See Also

Reference

PlaneItem Class
PlaneItem Members


Projection Class

Projection Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Projection Class
Represents the settings of the geometric Projection object.
Object Model
Projection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Projection
   Inherits Item
public sealed class Projection : Item
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Projection

See Also

Reference

Projection Members
GrapeCity.ActiveReports.Chart Namespace


Projection Class Members

Projection Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Projection Class

The following tables list the members exposed by Projection.

Public Constructors
 | Name | Description
Public Constructor | Projection Constructor | Overloaded. Initializes a new instance of the Projection class.
Top
Public Properties
 | Name | Description
Public Property | HorizontalRotation | Gets or sets the horizontal rotation from which the chart is viewed.
Public Property | PerspectiveRatioPct | Gets or sets the perspective ratio (0-100%) if the ProjectionType property is set to Perspective.
Public Property | ProjectionDX | Gets or sets the world origin offset by the X axis. For use with orthogonal projection only.
Public Property | ProjectionDY | Gets or sets the world origin offset by the Y axis. For use with orthogonal projection only.
Public Property | ProjectionType | Gets or sets the type of projection.
Public Property | VerticalRotation | Gets or sets the vertical rotation from which the chart is viewed.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Projection object.
Public Method | Equals | Compares the Projection object with another System.Object, and checks whether they both are equal.
Top
See Also

Reference

Projection Class
GrapeCity.ActiveReports.Chart Namespace


Projection Constructor

Projection Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class : Projection Constructor
Initializes a new instance of the Projection class.
Overload List
Overload | Description
Projection Constructor() | Initializes a new instance of the Projection class.
Projection Constructor(ProjectionType,Single,Single) | Initializes a new instance of the Projection class with the specified parameters.
Projection Constructor(ProjectionType,Single,Single,Single,Single) | Initializes a new instance of the Projection class with the specified parameters.
Projection Constructor(ProjectionType,Single,Single,Single,Single,Single) | Initializes a new instance of the Projection class with the specified parameters.
See Also

Reference

Projection Class
Projection Members


Projection Constructor()

Projection Constructor()

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class > Projection Constructor : Projection Constructor()
Initializes a new instance of the Projection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Projection()
See Also

Reference

Projection Class
Projection Members
Overload List


Projection Constructor(ProjectionType,Single,Single)

Projection Constructor(ProjectionType,Single,Single)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class > Projection Constructor : Projection Constructor(ProjectionType,Single,Single)
Specifies the type of projection.
Specifies the world origin offset by the X axis. For use with orthogonal projection only.
Specifies the world origin offset by the Y axis. For use with orthogonal projection only.
Initializes a new instance of the Projection class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal projectionType As ProjectionType, _
   ByVal projectionDX As System.Single, _
   ByVal projectionDY As System.Single _
)
public Projection(
   ProjectionType projectionType,
   System.float projectionDX,
   System.float projectionDY
)

Parameters

projectionType
Specifies the type of projection.
projectionDX
Specifies the world origin offset by the X axis. For use with orthogonal projection only.
projectionDY
Specifies the world origin offset by the Y axis. For use with orthogonal projection only.
See Also

Reference

Projection Class
Projection Members
Overload List


Projection Constructor(ProjectionType,Single,Single,Single,Single)

Projection Constructor(ProjectionType,Single,Single,Single,Single)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class > Projection Constructor : Projection Constructor(ProjectionType,Single,Single,Single,Single)
Specifies the type of projection.
Specifies the world origin offset by the X axis. For use with orthogonal projection only.
Specifies the world origin offset by the Y axis. For use with orthogonal projection only.
Specifies the horizontal rotation from which the chart is viewed.
Specifies the vertical rotation from which the chart is viewed.
Initializes a new instance of the Projection class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal projectionType As ProjectionType, _
   ByVal projectionDX As System.Single, _
   ByVal projectionDY As System.Single, _
   ByVal horizontalRotation As System.Single, _
   ByVal verticalRotation As System.Single _
)
public Projection(
   ProjectionType projectionType,
   System.float projectionDX,
   System.float projectionDY,
   System.float horizontalRotation,
   System.float verticalRotation
)

Parameters

projectionType
Specifies the type of projection.
projectionDX
Specifies the world origin offset by the X axis. For use with orthogonal projection only.
projectionDY
Specifies the world origin offset by the Y axis. For use with orthogonal projection only.
horizontalRotation
Specifies the horizontal rotation from which the chart is viewed.
verticalRotation
Specifies the vertical rotation from which the chart is viewed.
See Also

Reference

Projection Class
Projection Members
Overload List


Projection Constructor(ProjectionType,Single,Single,Single,Single,Single)

Projection Constructor(ProjectionType,Single,Single,Single,Single,Single)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class > Projection Constructor : Projection Constructor(ProjectionType,Single,Single,Single,Single,Single)
Specifies the type of projection.
Specifies the world origin offset by the X axis. For use with orthogonal projection only.
Specifies the world origin offset by the Y axis. For use with orthogonal projection only.
Specifies the horizontal rotation from which the chart is viewed.
Specifies the vertical rotation from which the chart is viewed.
The perspective ratio of the perspective projection type.
Initializes a new instance of the Projection class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal projectionType As ProjectionType, _
   ByVal projectionDX As System.Single, _
   ByVal projectionDY As System.Single, _
   ByVal horizontalRotation As System.Single, _
   ByVal verticalRotation As System.Single, _
   ByVal perspectiveRatio As System.Single _
)
public Projection(
   ProjectionType projectionType,
   System.float projectionDX,
   System.float projectionDY,
   System.float horizontalRotation,
   System.float verticalRotation,
   System.float perspectiveRatio
)

Parameters

projectionType
Specifies the type of projection.
projectionDX
Specifies the world origin offset by the X axis. For use with orthogonal projection only.
projectionDY
Specifies the world origin offset by the Y axis. For use with orthogonal projection only.
horizontalRotation
Specifies the horizontal rotation from which the chart is viewed.
verticalRotation
Specifies the vertical rotation from which the chart is viewed.
perspectiveRatio
The perspective ratio of the perspective projection type.
See Also

Reference

Projection Class
Projection Members
Overload List


Projection Class Methods

Projection Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Projection Class

For a list of all members of this type, see Projection members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Projection object.
Public Method | Equals | Compares the Projection object with another System.Object, and checks whether they both are equal.
Top
See Also

Reference

Projection Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method (Projection)

Clone Method (Projection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class : Clone Method
Creates a clone of the Projection object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

A clone of the Projection object.
See Also

Reference

Projection Class
Projection Members


Equals Method (Projection)

Equals Method (Projection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class : Equals Method
The System.Object to which the Projection object is being compared.
Compares the Projection object with another System.Object, and checks whether they both are equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The System.Object to which the Projection object is being compared.

Return Value

Compares the Projection object to another System.Object to see whether they are equal.
See Also

Reference

Projection Class
Projection Members


Projection Class Properties

Projection Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Projection Class

For a list of all members of this type, see Projection members.

Public Properties
 | Name | Description
Public Property | HorizontalRotation | Gets or sets the horizontal rotation from which the chart is viewed.
Public Property | PerspectiveRatioPct | Gets or sets the perspective ratio (0-100%) if the ProjectionType property is set to Perspective.
Public Property | ProjectionDX | Gets or sets the world origin offset by the X axis. For use with orthogonal projection only.
Public Property | ProjectionDY | Gets or sets the world origin offset by the Y axis. For use with orthogonal projection only.
Public Property | ProjectionType | Gets or sets the type of projection.
Public Property | VerticalRotation | Gets or sets the vertical rotation from which the chart is viewed.
Top
See Also

Reference

Projection Class
GrapeCity.ActiveReports.Chart Namespace


HorizontalRotation Property

HorizontalRotation Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class : HorizontalRotation Property
Gets or sets the horizontal rotation from which the chart is viewed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HorizontalRotation As System.Single
public System.float HorizontalRotation {get; set;}
Remarks
Use this property in conjunction with the VerticalRotation property.
See Also

Reference

Projection Class
Projection Members
VerticalRotation Property


PerspectiveRatioPct Property

PerspectiveRatioPct Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class : PerspectiveRatioPct Property
Gets or sets the perspective ratio (0-100%) if the ProjectionType property is set to Perspective.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PerspectiveRatioPct As System.Single
public System.float PerspectiveRatioPct {get; set;}
See Also

Reference

Projection Class
Projection Members


ProjectionDX Property

ProjectionDX Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class : ProjectionDX Property
Gets or sets the world origin offset by the X axis. For use with orthogonal projection only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ProjectionDX As System.Single
public System.float ProjectionDX {get; set;}
See Also

Reference

Projection Class
Projection Members


ProjectionDY Property

ProjectionDY Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class : ProjectionDY Property
Gets or sets the world origin offset by the Y axis. For use with orthogonal projection only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ProjectionDY As System.Single
public System.float ProjectionDY {get; set;}
See Also

Reference

Projection Class
Projection Members


ProjectionType Property

ProjectionType Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class : ProjectionType Property
Gets or sets the type of projection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ProjectionType As ProjectionType
public ProjectionType ProjectionType {get; set;}
See Also

Reference

Projection Class
Projection Members


VerticalRotation Property

VerticalRotation Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Projection Class : VerticalRotation Property
Gets or sets the vertical rotation from which the chart is viewed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property VerticalRotation As System.Single
public System.float VerticalRotation {get; set;}
Remarks
Use this property in conjunction with the VerticalRotation property.
See Also

Reference

Projection Class
Projection Members
HorizontalRotation Property


Series Class

Series Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Series Class
Represents the settings for the Series object.
Object Model
Series Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Series
   Inherits MouseEnabledComponent
public sealed class Series : MouseEnabledComponent
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Series

See Also

Reference

Series Members
GrapeCity.ActiveReports.Chart Namespace


Series Class Members

Series Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Series Class

The following tables list the members exposed by Series.

Public Constructors
 | Name | Description
Public Constructor | Series Constructor | Initializes a new instance of the Series class.
Top
Public Properties
 | Name | Description
Public Property | Annotations | Returns the collection of Annotations which is used with the Series.
Public Property | AxisX | Sets or returns the axis the Layer will be based on horizontally.
Public Property | AxisY | Sets or returns the axis the Layer will be based on vertically.
Public Property | Backdrop | Gets or sets the backdrop information used to fill the Series.
Public Property | BorderLine | Gets or sets the line information used for the border line of the Series.
Public Property | ChartArea | Sets or returns the ChartArea for the Series.
Public Property | ChartConfig | Returns the ChartTypeConfig for the Series.
Public Property | ColorPalette | Gets or sets the color palette enumeration used for the series.
Public Property | DisplayInLegend | Gets or sets a value indicating whether the Series is displayed in the graph legend.
Public Property | Legend | Gets or sets the Legend object for the series.
Public Property | LegendItemsMode | Gets or sets the mode used to display legend items.
Public Property | LegendText | Gets or sets the text that will be displayed for the series in the legend.
Public Property | Line | Gets or sets the line information used for the series.
Public Property | Marker | Gets or sets the marker information used for the series.
Public Property | Name | Overridden. Gets or sets the name of the series as a string.
Public Property | Points | Gets a DataPointsCollection object.
Public Property | Properties | Gets or sets the CustomProperties settings for the series.
Public Property | Tooltip | Gets or sets the tooltip text for the series.
Public Property | Type | Gets or sets the chart type for the series.
Public Property | ValueMembersY | Gets or sets the binding formula for the Y values in the series.
Public Property | ValueMemberX | Gets or sets the binding formula for the X values in the series.
Public Property | Visible | Sets or returns a value indicating whether the series is visible.
Public Property | ZOrder | Gets or sets the Z position of the series on the chart.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Series object.
Public Method | OnMouseHover | Overridden. Fires the MouseHover event.
Public Method | OnMouseLeave | Overridden. Raises the MouseLeave event.
Public Method | OnMouseMove | Overridden. Raises the MouseMove event.
Top
See Also

Reference

Series Class
GrapeCity.ActiveReports.Chart Namespace


Series Constructor

Series Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Series Constructor
Initializes a new instance of the Series class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Series()
See Also

Reference

Series Class
Series Members


Series Class Methods

Series Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Series Class

For a list of all members of this type, see Series members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Series object.
Public Method | OnMouseHover | Overridden. Fires the MouseHover event.
Public Method | OnMouseLeave | Overridden. Raises the MouseLeave event.
Public Method | OnMouseMove | Overridden. Raises the MouseMove event.
Top
See Also

Reference

Series Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method (Series)

Clone Method (Series)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Clone Method
Creates a clone of the Series object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

A clone of the Series object.
See Also

Reference

Series Class
Series Members


OnMouseHover Method (Series)

OnMouseHover Method (Series)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : OnMouseHover Method
A GraphMouseEventArgs that contains the event data.
Fires the MouseHover event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Sub OnMouseHover( _
   ByVal e As GraphMouseEventArgs _
)
public override void OnMouseHover(
   GraphMouseEventArgs e
)

Parameters

e
A GraphMouseEventArgs that contains the event data.

Return Value

Raises the MouseHover event.
See Also

Reference

Series Class
Series Members


OnMouseLeave Method (Series)

OnMouseLeave Method (Series)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : OnMouseLeave Method
A GraphMouseEventArgs that contains the event data.
Raises the MouseLeave event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Sub OnMouseLeave( _
   ByVal e As GraphMouseEventArgs _
)
public override void OnMouseLeave(
   GraphMouseEventArgs e
)

Parameters

e
A GraphMouseEventArgs that contains the event data.
See Also

Reference

Series Class
Series Members


OnMouseMove Method (Series)

OnMouseMove Method (Series)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : OnMouseMove Method
A GraphMouseEventArgs that contains the event data.
Raises the MouseMove event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Sub OnMouseMove( _
   ByVal e As GraphMouseEventArgs _
)
public override void OnMouseMove(
   GraphMouseEventArgs e
)

Parameters

e
A GraphMouseEventArgs that contains the event data.
See Also

Reference

Series Class
Series Members


Series Class Properties

Series Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Series Class

For a list of all members of this type, see Series members.

Public Properties
 | Name | Description
Public Property | Annotations | Returns the collection of Annotations which is used with the Series.
Public Property | AxisX | Sets or returns the axis the Layer will be based on horizontally.
Public Property | AxisY | Sets or returns the axis the Layer will be based on vertically.
Public Property | Backdrop | Gets or sets the backdrop information used to fill the Series.
Public Property | BorderLine | Gets or sets the line information used for the border line of the Series.
Public Property | ChartArea | Sets or returns the ChartArea for the Series.
Public Property | ChartConfig | Returns the ChartTypeConfig for the Series.
Public Property | ColorPalette | Gets or sets the color palette enumeration used for the series.
Public Property | DisplayInLegend | Gets or sets a value indicating whether the Series is displayed in the graph legend.
Public Property | Legend | Gets or sets the Legend object for the series.
Public Property | LegendItemsMode | Gets or sets the mode used to display legend items.
Public Property | LegendText | Gets or sets the text that will be displayed for the series in the legend.
Public Property | Line | Gets or sets the line information used for the series.
Public Property | Marker | Gets or sets the marker information used for the series.
Public Property | Name | Overridden. Gets or sets the name of the series as a string.
Public Property | Points | Gets a DataPointsCollection object.
Public Property | Properties | Gets or sets the CustomProperties settings for the series.
Public Property | Tooltip | Gets or sets the tooltip text for the series.
Public Property | Type | Gets or sets the chart type for the series.
Public Property | ValueMembersY | Gets or sets the binding formula for the Y values in the series.
Public Property | ValueMemberX | Gets or sets the binding formula for the X values in the series.
Public Property | Visible | Sets or returns a value indicating whether the series is visible.
Public Property | ZOrder | Gets or sets the Z position of the series on the chart.
Top
See Also

Reference

Series Class
GrapeCity.ActiveReports.Chart Namespace


Annotations Property (Series)

Annotations Property (Series)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Annotations Property
Returns the collection of Annotations which is used with the Series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Annotations As AnnotationsCollection
public AnnotationsCollection Annotations {get;}
See Also

Reference

Series Class
Series Members


AxisX Property

AxisX Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : AxisX Property
Sets or returns the axis the Layer will be based on horizontally.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AxisX As AxisBase
public AxisBase AxisX {get; set;}
See Also

Reference

Series Class
Series Members


AxisY Property

AxisY Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : AxisY Property
Sets or returns the axis the Layer will be based on vertically.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AxisY As AxisBase
public AxisBase AxisY {get; set;}
See Also

Reference

Series Class
Series Members


Backdrop Property (Series)

Backdrop Property (Series)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Backdrop Property
Gets or sets the backdrop information used to fill the Series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Backdrop As Backdrop
public Backdrop Backdrop {get; set;}
See Also

Reference

Series Class
Series Members


BorderLine Property (Series)

BorderLine Property (Series)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : BorderLine Property
Gets or sets the line information used for the border line of the Series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BorderLine As Line
public Line BorderLine {get; set;}
See Also

Reference

Series Class
Series Members


ChartArea Property

ChartArea Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : ChartArea Property
Sets or returns the ChartArea for the Series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ChartArea As ChartArea
public ChartArea ChartArea {get; set;}
See Also

Reference

Series Class
Series Members


ChartConfig Property

ChartConfig Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : ChartConfig Property
Returns the ChartTypeConfig for the Series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ChartConfig As ChartTypeConfig
public ChartTypeConfig ChartConfig {get;}
See Also

Reference

Series Class
Series Members


ColorPalette Property (Series)

ColorPalette Property (Series)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : ColorPalette Property
Gets or sets the color palette enumeration used for the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ColorPalette As ColorPalette
public ColorPalette ColorPalette {get; set;}
See Also

Reference

Series Class
Series Members
ColorPalette Enumeration


DisplayInLegend Property (Series)

DisplayInLegend Property (Series)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : DisplayInLegend Property
Gets or sets a value indicating whether the Series is displayed in the graph legend.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DisplayInLegend As System.Boolean
public System.bool DisplayInLegend {get; set;}

Property Value

Boolean. True if the Series is displayed in the graph legend; otherwise False.
See Also

Reference

Series Class
Series Members


Legend Property (Series)

Legend Property (Series)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Legend Property
Gets or sets the Legend object for the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Legend As Legend
public Legend Legend {get; set;}
See Also

Reference

Series Class
Series Members


LegendItemsMode Property

LegendItemsMode Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : LegendItemsMode Property
Gets or sets the mode used to display legend items.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LegendItemsMode As LegendMode
public LegendMode LegendItemsMode {get; set;}
Remarks
The default value is Auto, which specifies that legend items be displayed as points for one figure charts (e.g., doughnut, pyramid, and funnel) and series for all others.
See Also

Reference

Series Class
Series Members


LegendText Property (Series)

LegendText Property (Series)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : LegendText Property
Gets or sets the text that will be displayed for the series in the legend.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LegendText As System.String
public System.string LegendText {get; set;}
See Also

Reference

Series Class
Series Members


Line Property (Series)

Line Property (Series)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Line Property
Gets or sets the line information used for the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Line As Line
public Line Line {get; set;}
See Also

Reference

Series Class
Series Members


Marker Property (Series)

Marker Property (Series)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Marker Property
Gets or sets the marker information used for the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Marker As Marker
public Marker Marker {get; set;}
See Also

Reference

Series Class
Series Members


Name Property (Series)

Name Property (Series)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Name Property
Gets or sets the name of the series as a string.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Property Name As System.String
public override System.string Name {get; set;}
See Also

Reference

Series Class
Series Members


Points Property (Series)

Points Property (Series)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Points Property
Gets a DataPointsCollection object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Points As DataPointsCollection
public DataPointsCollection Points {get;}
See Also

Reference

Series Class
Series Members


Properties Property (Series)

Properties Property (Series)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Properties Property
Gets or sets the CustomProperties settings for the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Properties As CustomProperties
public CustomProperties Properties {get; set;}
See Also

Reference

Series Class
Series Members


Tooltip Property (Series)

Tooltip Property (Series)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Tooltip Property
Gets or sets the tooltip text for the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Tooltip As LabelInfo
public LabelInfo Tooltip {get; set;}
Remarks
Tooltip property does not work for Chart control.
See Also

Reference

Series Class
Series Members


Type Property (Series)

Type Property (Series)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Type Property
Gets or sets the chart type for the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Type As ChartType
public ChartType Type {get; set;}
See Also

Reference

Series Class
Series Members


ValueMembersY Property

ValueMembersY Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : ValueMembersY Property
Gets or sets the binding formula for the Y values in the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ValueMembersY As System.String
public System.string ValueMembersY {get; set;}
See Also

Reference

Series Class
Series Members


ValueMemberX Property

ValueMemberX Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : ValueMemberX Property
Gets or sets the binding formula for the X values in the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ValueMemberX As System.String
public System.string ValueMemberX {get; set;}
See Also

Reference

Series Class
Series Members


Visible Property (Series)

Visible Property (Series)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : Visible Property
Sets or returns a value indicating whether the series is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}
See Also

Reference

Series Class
Series Members


ZOrder Property

ZOrder Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Series Class : ZOrder Property
Gets or sets the Z position of the series on the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ZOrder As System.Single
public System.float ZOrder {get; set;}
Remarks
The LayersSchemeManager may modify this property automatically.
See Also

Reference

Series Class
Series Members


SeriesCollection Class

SeriesCollection Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : SeriesCollection Class
Represents the settings for the SeriesCollection class.
Object Model
SeriesCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class SeriesCollection
   Inherits System.Collections.CollectionBase
public sealed class SeriesCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.SeriesCollection

See Also

Reference

SeriesCollection Members
GrapeCity.ActiveReports.Chart Namespace


SeriesCollection Class Members

SeriesCollection Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : SeriesCollection Class

The following tables list the members exposed by SeriesCollection.

Public Constructors
 | Name | Description
Public Constructor | SeriesCollection Constructor | Initializes a new instance of the SeriesCollection class.
Top
Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Gets or sets the collection item based on the specified parameter.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a series to the collection.
Public Method | AddRange | Adds an array of Series objects to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Clone | Creates a clone of the SeriesCollection.
Public Method | Contains | Determines whether the collection contains the specified series.
Public Method | CopyTo | Copies the entire collection to an array, starting at the specified index of the target array.
Public Method | Dispose | Releases resources associated with this object.
Public Method | Equals | Compares the SeriesCollection object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts a series into the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific series from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

SeriesCollection Class
GrapeCity.ActiveReports.Chart Namespace


SeriesCollection Constructor

SeriesCollection Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : SeriesCollection Constructor
Initializes a new instance of the SeriesCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public SeriesCollection()
See Also

Reference

SeriesCollection Class
SeriesCollection Members


SeriesCollection Class Methods

SeriesCollection Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : SeriesCollection Class

For a list of all members of this type, see SeriesCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a series to the collection.
Public Method | AddRange | Adds an array of Series objects to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Clone | Creates a clone of the SeriesCollection.
Public Method | Contains | Determines whether the collection contains the specified series.
Public Method | CopyTo | Copies the entire collection to an array, starting at the specified index of the target array.
Public Method | Dispose | Releases resources associated with this object.
Public Method | Equals | Compares the SeriesCollection object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts a series into the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific series from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

SeriesCollection Class
GrapeCity.ActiveReports.Chart Namespace


Add Method (SeriesCollection)

Add Method (SeriesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : Add Method
The series to add to the collection.
Adds a series to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As Series _
) As System.Integer
public System.int Add(
   Series value
)

Parameters

value
The series to add to the collection.
See Also

Reference

SeriesCollection Class
SeriesCollection Members


AddRange Method (SeriesCollection)

AddRange Method (SeriesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : AddRange Method
The set of Series objects to add to the collection.
Adds an array of Series objects to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddRange( _
   ByVal value() As Series _
)
public void AddRange(
   Series[] value
)

Parameters

value
The set of Series objects to add to the collection.
See Also

Reference

SeriesCollection Class
SeriesCollection Members


Clone Method (SeriesCollection)

Clone Method (SeriesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : Clone Method
Creates a clone of the SeriesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Clone() As System.Object
public System.object Clone()

Return Value

A clone of the SeriesCollection.
See Also

Reference

SeriesCollection Class
SeriesCollection Members


Contains Method (SeriesCollection)

Contains Method (SeriesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : Contains Method

The series to check.

Determines whether the collection contains the specified series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal value As Series _
) As System.Boolean
public System.bool Contains(
   Series value
)

Parameters

value

The series to check.

Return Value

True if the collection contains the parameter given; otherwise False.
See Also

Reference

SeriesCollection Class
SeriesCollection Members


CopyTo Method (SeriesCollection)

CopyTo Method (SeriesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : CopyTo Method
The array to which to copy the collection.
The index from which to start.
Copies the entire collection to an array, starting at the specified index of the target array.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal array() As Series, _
   ByVal index As System.Integer _
)
public void CopyTo(
   Series[] array,
   System.int index
)

Parameters

array
The array to which to copy the collection.
index
The index from which to start.

Return Value

`
See Also

Reference

SeriesCollection Class
SeriesCollection Members


Dispose Method (SeriesCollection)

Dispose Method (SeriesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : Dispose Method
Releases resources associated with this object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

SeriesCollection Class
SeriesCollection Members


Equals Method (SeriesCollection)

Equals Method (SeriesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : Equals Method
The System.Object to which the SeriesCollection object is being compared.
Compares the SeriesCollection object to another System.Object to see whether they are equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The System.Object to which the SeriesCollection object is being compared.
See Also

Reference

SeriesCollection Class
SeriesCollection Members


GetHashCode Method (SeriesCollection)

GetHashCode Method (SeriesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : GetHashCode Method
Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

SeriesCollection Class
SeriesCollection Members


IndexOf Method (SeriesCollection)

IndexOf Method (SeriesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : IndexOf Method
The object to locate in the collection.
Returns the index of the first occurrence of a value in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As Series _
) As System.Integer
public System.int IndexOf(
   Series value
)

Parameters

value
The object to locate in the collection.

Return Value

The index of the first occurrence of the value within the entire array, if found; otherwise, the lower bound of the array - 1.
See Also

Reference

SeriesCollection Class
SeriesCollection Members


Insert Method (SeriesCollection)

Insert Method (SeriesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : Insert Method
The index at which the series should be inserted.
The series to insert.
Inserts a series into the collection at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As Series _
)
public void Insert(
   System.int index,
   Series value
)

Parameters

index
The index at which the series should be inserted.
value
The series to insert.
See Also

Reference

SeriesCollection Class
SeriesCollection Members


Remove Method (SeriesCollection)

Remove Method (SeriesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : Remove Method
The series to remove.
Removes the first occurrence of a specific series from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As Series _
)
public void Remove(
   Series value
)

Parameters

value
The series to remove.
See Also

Reference

SeriesCollection Class
SeriesCollection Members


SeriesCollection Class Properties

SeriesCollection Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : SeriesCollection Class

For a list of all members of this type, see SeriesCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Gets or sets the collection item based on the specified parameter.
Top
See Also

Reference

SeriesCollection Class
GrapeCity.ActiveReports.Chart Namespace


Item Property (SeriesCollection)

Item Property (SeriesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : Item Property
Gets or sets the collection item based on the specified parameter.
Overload List
Overload | Description
Item(Int32) | Gets or sets the collection item by the given index.
Item(String) | Gets or sets the collection item by the given series name.
See Also

Reference

SeriesCollection Class
SeriesCollection Members


Item(Int32) Property

Item(Int32) Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class > Item Property : Item(Int32) Property
The index of the item.
Gets or sets the collection item by the given index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Property Item( _
   ByVal index As System.Integer _
) As Series
public Series Item(
   System.int index
) {get; set;}

Parameters

index
The index of the item.
See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


Item(String) Property

Item(String) Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class > Item Property : Item(String) Property
The name of the series.
Gets or sets the collection item by the given series name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal seriesName As System.String _
) As Series
public Series Item(
   System.string seriesName
) {get;}

Parameters

seriesName
The name of the series.
See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


SharpGraph Class

SharpGraph Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : SharpGraph Class
Represents the settings for the SharpGraph object.
Object Model
SharpGraph Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class SharpGraph
   Inherits System.Windows.Forms.Control
public sealed class SharpGraph : System.Windows.Forms.Control
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
GrapeCity.ActiveReports.Chart.SharpGraph

See Also

Reference

SharpGraph Members
GrapeCity.ActiveReports.Chart Namespace


SharpGraph Class Members

SharpGraph Class Members
Properties Methods Events

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : SharpGraph Class

The following tables list the members exposed by SharpGraph.

Public Constructors
 | Name | Description
Public Constructor | SharpGraph Constructor | Initializes a new instance of the SharpGraph object.
Top
Public Properties
 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AreaCustomBorderDrawer | Gets or sets the custom border drawer object for the ChartAreas.
Public Property | AutoRefresh | Gets or sets a value indicating whether the chart will be automatically refreshed (redrawn) for every property change.
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | Backdrop | Gets or sets the backdrop information for the chart.
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.Control)
Public Property | Border | Gets or sets the border information for the chart.
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | ChartAreas | Gets the ChartAreasCollection for the Chart control.
Public Property | ChartCustomBorderDrawer | Gets or sets the custom border drawer object for the entire control.
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | ColorPalette | Gets or sets ColorPalette enumeration for the chart.
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | Overridden. Gets or sets the cursor used for the chart.
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DataSource | Gets or sets the global data source for the chart.
Public Property | DeviceMode | Gets or sets an enumerated value specifying the graphics device options.
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | GridLayout | Gets or sets the GridLayout object for the chart.
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDesignMode | Gets a value that indicates whether the Chart is currently in design mode.
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Legends | Gets or sets the legend object for the Chart control.
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | Series | Gets the series collection for the Chart object.
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Titles | Gets the titles collection for the Chart object.
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | UIOptions | Gets or sets enumerated user interface features for the chart.
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Top
Public Methods
 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoCommand | Executes a command for the SharpGraph object.
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawContent | Draws the chart on the provided graphics object.
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | HitTest | Returns information about the chart item that is placed in the specified coordinates.
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | QuickLoad | Loads a chart from primitive data types as binary values.
Public Method | QuickSave | Saves the chart to primitive types in binary to a stream.
Public Method | ReadXml | Reads a chart from an XmlElement.
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | WriteXml | Writes the chart from an XmlElement.
Top
Public Events
 | Name | Description
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

SharpGraph Class
GrapeCity.ActiveReports.Chart Namespace


SharpGraph Constructor

SharpGraph Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : SharpGraph Constructor
Initializes a new instance of the SharpGraph object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public SharpGraph()
See Also

Reference

SharpGraph Class
SharpGraph Members


SharpGraph Class Methods

SharpGraph Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : SharpGraph Class

For a list of all members of this type, see SharpGraph members.

Public Methods
 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoCommand | Executes a command for the SharpGraph object.
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawContent | Draws the chart on the provided graphics object.
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | HitTest | Returns information about the chart item that is placed in the specified coordinates.
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | QuickLoad | Loads a chart from primitive data types as binary values.
Public Method | QuickSave | Saves the chart to primitive types in binary to a stream.
Public Method | ReadXml | Reads a chart from an XmlElement.
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | WriteXml | Writes the chart from an XmlElement.
Top
See Also

Reference

SharpGraph Class
GrapeCity.ActiveReports.Chart Namespace


DoCommand Method

DoCommand Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : DoCommand Method
Specifies the enumerated command to execute.
Specifies optional parameters for the command.
Executes a command for the SharpGraph object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub DoCommand( _
   ByVal command As UICommand, _
   ByVal ParamArray parameters() As System.Object _
)
public void DoCommand(
   UICommand command,
   params System.object[] parameters
)

Parameters

command
Specifies the enumerated command to execute.
parameters
Specifies optional parameters for the command.
See Also

Reference

SharpGraph Class
SharpGraph Members
UICommand Enumeration


DrawContent Method

DrawContent Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : DrawContent Method
The specified graphics object.
The rectangle to draw.
Draws the chart on the provided graphics object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub DrawContent( _
   ByVal graphics As Graphics, _
   ByVal rectangle As Rectangle _
)
public void DrawContent(
   Graphics graphics,
   Rectangle rectangle
)

Parameters

graphics
The specified graphics object.
rectangle
The rectangle to draw.
Remarks
OnPaint calls this method.
See Also

Reference

SharpGraph Class
SharpGraph Members


HitTest Method (SharpGraph)

HitTest Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : HitTest Method
The specified X axis coordinate.
The specified Y axis coordinate.
Returns information about the chart item that is placed in the specified coordinates.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function HitTest( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer _
) As HitTest
public HitTest HitTest(
   System.int x,
   System.int y
)

Parameters

x
The specified X axis coordinate.
y
The specified Y axis coordinate.

Return Value

A reference to HitTestInfo or null if the item is not found.
Remarks
Please consider using UIOptions.ForceHitTesting before calling the HitTest method.
See Also

Reference

SharpGraph Class
SharpGraph Members


QuickLoad Method

QuickLoad Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : QuickLoad Method
The System.IO.BinaryReader from which to load the chart.

Loads a chart from primitive data types as binary values.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub QuickLoad( _
   ByVal binReader As System.IO.BinaryReader _
)
public void QuickLoad(
   System.IO.BinaryReader binReader
)

Parameters

binReader
The System.IO.BinaryReader from which to load the chart.
See Also

Reference

SharpGraph Class
SharpGraph Members


QuickSave Method

QuickSave Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : QuickSave Method
The System.IO.BinaryWriter to which to save the chart.

Saves the chart to primitive types in binary to a stream.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub QuickSave( _
   ByVal binWriter As System.IO.BinaryWriter _
)
public void QuickSave(
   System.IO.BinaryWriter binWriter
)

Parameters

binWriter
The System.IO.BinaryWriter to which to save the chart.
See Also

Reference

SharpGraph Class
SharpGraph Members


ReadXml Method (SharpGraph)

ReadXml Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : ReadXml Method
The System.Xml.XmlElement from which to read the chart.
Reads a chart from an XmlElement.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ReadXml( _
   ByVal controlNode As System.Xml.XmlElement _
)
public void ReadXml(
   System.Xml.XmlElement controlNode
)

Parameters

controlNode
The System.Xml.XmlElement from which to read the chart.
See Also

Reference

SharpGraph Class
SharpGraph Members


WriteXml Method (SharpGraph)

WriteXml Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : WriteXml Method
The System.Xml.XmlElement to which to write the chart.
Writes the chart from an XmlElement.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub WriteXml( _
   ByVal controlNode As System.Xml.XmlElement _
)
public void WriteXml(
   System.Xml.XmlElement controlNode
)

Parameters

controlNode
The System.Xml.XmlElement to which to write the chart.
See Also

Reference

SharpGraph Class
SharpGraph Members


SharpGraph Class Properties

SharpGraph Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : SharpGraph Class

For a list of all members of this type, see SharpGraph members.

Public Properties
 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AreaCustomBorderDrawer | Gets or sets the custom border drawer object for the ChartAreas.
Public Property | AutoRefresh | Gets or sets a value indicating whether the chart will be automatically refreshed (redrawn) for every property change.
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | Backdrop | Gets or sets the backdrop information for the chart.
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.Control)
Public Property | Border | Gets or sets the border information for the chart.
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | ChartAreas | Gets the ChartAreasCollection for the Chart control.
Public Property | ChartCustomBorderDrawer | Gets or sets the custom border drawer object for the entire control.
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | ColorPalette | Gets or sets ColorPalette enumeration for the chart.
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | Cursor | Overridden. Gets or sets the cursor used for the chart.
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DataSource | Gets or sets the global data source for the chart.
Public Property | DeviceMode | Gets or sets an enumerated value specifying the graphics device options.
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | GridLayout | Gets or sets the GridLayout object for the chart.
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDesignMode | Gets a value that indicates whether the Chart is currently in design mode.
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Legends | Gets or sets the legend object for the Chart control.
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | Series | Gets the series collection for the Chart object.
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Titles | Gets the titles collection for the Chart object.
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | UIOptions | Gets or sets enumerated user interface features for the chart.
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

SharpGraph Class
GrapeCity.ActiveReports.Chart Namespace


AreaCustomBorderDrawer Property

AreaCustomBorderDrawer Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : AreaCustomBorderDrawer Property
Gets or sets the custom border drawer object for the ChartAreas.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AreaCustomBorderDrawer As ICustomBorderDrawer
public ICustomBorderDrawer AreaCustomBorderDrawer {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


AutoRefresh Property (SharpGraph)

AutoRefresh Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : AutoRefresh Property
Gets or sets a value indicating whether the chart will be automatically refreshed (redrawn) for every property change.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoRefresh As System.Boolean
public System.bool AutoRefresh {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


Backdrop Property (SharpGraph)

Backdrop Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Backdrop Property
Gets or sets the backdrop information for the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Backdrop As BackdropItem
public BackdropItem Backdrop {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


Border Property (SharpGraph)

Border Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Border Property
Gets or sets the border information for the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Border As Border
public Border Border {get; set;}
Remarks
This border spans the whole Chart control area.
See Also

Reference

SharpGraph Class
SharpGraph Members


ChartAreas Property (SharpGraph)

ChartAreas Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : ChartAreas Property
Gets the ChartAreasCollection for the Chart control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ChartAreas As ChartAreasCollection
public ChartAreasCollection ChartAreas {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


ChartCustomBorderDrawer Property

ChartCustomBorderDrawer Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : ChartCustomBorderDrawer Property
Gets or sets the custom border drawer object for the entire control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ChartCustomBorderDrawer As ICustomBorderDrawer
public ICustomBorderDrawer ChartCustomBorderDrawer {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


ColorPalette Property (SharpGraph)

ColorPalette Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : ColorPalette Property
Gets or sets ColorPalette enumeration for the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ColorPalette As ColorPalette
public ColorPalette ColorPalette {get; set;}

Property Value

ColorPalette enumeration.
See Also

Reference

SharpGraph Class
SharpGraph Members
ColorPalette Enumeration


Cursor Property (SharpGraph)

Cursor Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Cursor Property
Gets or sets the cursor used for the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Property Cursor As System.Windows.Forms.Cursor
public override System.Windows.Forms.Cursor Cursor {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


DataSource Property (SharpGraph)

DataSource Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : DataSource Property
Gets or sets the global data source for the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataSource As System.Object
public System.object DataSource {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


DeviceMode Property

DeviceMode Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : DeviceMode Property
Gets or sets an enumerated value specifying the graphics device options.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DeviceMode As DeviceModes
public DeviceModes DeviceMode {get; set;}

Property Value

DeviceModes enumeration. Values are BlackWhite or None.
See Also

Reference

SharpGraph Class
SharpGraph Members
DeviceModes Enumeration


GridLayout Property (SharpGraph)

GridLayout Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : GridLayout Property

Gets or sets the GridLayout object for the chart.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GridLayout As GridLayout
public GridLayout GridLayout {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


IsDesignMode Property

IsDesignMode Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : IsDesignMode Property

Gets a value that indicates whether the Chart is currently in design mode.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsDesignMode As System.Boolean
public System.bool IsDesignMode {get; set;}

Property Value

true if this instance is design mode; otherwise, false.
See Also

Reference

SharpGraph Class
SharpGraph Members


Legends Property (SharpGraph)

Legends Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Legends Property
Gets or sets the legend object for the Chart control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Legends As LegendsCollection
public LegendsCollection Legends {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


Series Property (SharpGraph)

Series Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Series Property
Gets the series collection for the Chart object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Series As SeriesCollection
public SeriesCollection Series {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


Titles Property (SharpGraph)

Titles Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Titles Property
Gets the titles collection for the Chart object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Titles As TitlesCollection
public TitlesCollection Titles {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


UIOptions Property (SharpGraph)

UIOptions Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : UIOptions Property
Gets or sets enumerated user interface features for the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UIOptions As UIOptions
public UIOptions UIOptions {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members
UIOptions Enumeration


Tick Class

Tick Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Tick Class
Represents the settings of the Tick object.
Object Model
Tick Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Tick
   Inherits Item
public sealed class Tick : Item
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Tick

See Also

Reference

Tick Members
GrapeCity.ActiveReports.Chart Namespace


Tick Class Members

Tick Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Tick Class

The following tables list the members exposed by Tick.

Public Constructors
 | Name | Description
Public Constructor | Tick Constructor | Overloaded. Initializes a new instance of the Tick class.
Top
Public Properties
 | Name | Description
Public Property | GridLine | Gets or sets the line used to draw the grid on the chart walls.
Public Property | Length | Gets or sets the length of the line used to draw the tick.
Public Property | Line | Gets or sets the line used to draw the tick.
Public Property | Step | Gets or sets the step between two subsequent ticks in the units of measure of the axis.
Public Property | Visible | Gets or sets a value indicating whether the tick is visible.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Tick object.
Public Method | Equals | Compares the Tick object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top
See Also

Reference

Tick Class
GrapeCity.ActiveReports.Chart Namespace


Tick Constructor

Tick Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class : Tick Constructor
Initializes a new instance of the Tick class.
Overload List
Overload | Description
Tick Constructor() | Initializes a new instance of the Tick class.
Tick Constructor(Double) | Initializes a new instance of the Tick class with the step parameter specified.
Tick Constructor(Line,Double,Single) | Initializes a new instance of the Tick class with the parameters specified.
Tick Constructor(Line,Line,Double,Single,Boolean) | Initializes a new instance of the Tick class with the parameters specified.
See Also

Reference

Tick Class
Tick Members


Tick Constructor()

Tick Constructor()

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class > Tick Constructor : Tick Constructor()
Initializes a new instance of the Tick class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Tick()
See Also

Reference

Tick Class
Tick Members
Overload List


Tick Constructor(Double)

Tick Constructor(Double)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class > Tick Constructor : Tick Constructor(Double)
Specifies the tick step.
Initializes a new instance of the Tick class with the step parameter specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal step As System.Double _
)
public Tick(
   System.double step
)

Parameters

step
Specifies the tick step.
See Also

Reference

Tick Class
Tick Members
Overload List


Tick Constructor(Line,Double,Single)

Tick Constructor(Line,Double,Single)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class > Tick Constructor : Tick Constructor(Line,Double,Single)
Specifies the line information used to draw the tick line.
Specifies the tick step.
Specifies the tick length.
Initializes a new instance of the Tick class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal line As Line, _
   ByVal step As System.Double, _
   ByVal length As System.Single _
)
public Tick(
   Line line,
   System.double step,
   System.float length
)

Parameters

line
Specifies the line information used to draw the tick line.
step
Specifies the tick step.
length
Specifies the tick length.
See Also

Reference

Tick Class
Tick Members
Overload List


Tick Constructor(Line,Line,Double,Single,Boolean)

Tick Constructor(Line,Line,Double,Single,Boolean)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class > Tick Constructor : Tick Constructor(Line,Line,Double,Single,Boolean)
Specifies the line information used to draw the tick line.
Specifies the line information used to draw the grid line.
Specifies the tick step.
Specifies the tick length.
Specifies whether the tick and grid lines are visible.
Initializes a new instance of the Tick class with the parameters specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal line As Line, _
   ByVal gridLine As Line, _
   ByVal step As System.Double, _
   ByVal length As System.Single, _
   ByVal visible As System.Boolean _
)
public Tick(
   Line line,
   Line gridLine,
   System.double step,
   System.float length,
   System.bool visible
)

Parameters

line
Specifies the line information used to draw the tick line.
gridLine
Specifies the line information used to draw the grid line.
step
Specifies the tick step.
length
Specifies the tick length.
visible
Specifies whether the tick and grid lines are visible.
See Also

Reference

Tick Class
Tick Members
Overload List


Tick Class Methods

Tick Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Tick Class

For a list of all members of this type, see Tick members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Tick object.
Public Method | Equals | Compares the Tick object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Top
See Also

Reference

Tick Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method (Tick)

Clone Method (Tick)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class : Clone Method
Creates a clone of the Tick object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

A clone of the Tick object.
See Also

Reference

Tick Class
Tick Members


Equals Method (Tick)

Equals Method (Tick)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class : Equals Method
The System.Object to which the Tick object is being compared.
Compares the Tick object to another System.Object to see whether they are equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The System.Object to which the Tick object is being compared.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.
See Also

Reference

Tick Class
Tick Members


GetHashCode Method (Tick)

GetHashCode Method (Tick)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class : GetHashCode Method
Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

Tick Class
Tick Members


Tick Class Properties

Tick Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Tick Class

For a list of all members of this type, see Tick members.

Public Properties
 | Name | Description
Public Property | GridLine | Gets or sets the line used to draw the grid on the chart walls.
Public Property | Length | Gets or sets the length of the line used to draw the tick.
Public Property | Line | Gets or sets the line used to draw the tick.
Public Property | Step | Gets or sets the step between two subsequent ticks in the units of measure of the axis.
Public Property | Visible | Gets or sets a value indicating whether the tick is visible.
Top
See Also

Reference

Tick Class
GrapeCity.ActiveReports.Chart Namespace


GridLine Property

GridLine Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class : GridLine Property
Gets or sets the line used to draw the grid on the chart walls.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GridLine As Line
public Line GridLine {get; set;}
See Also

Reference

Tick Class
Tick Members


Length Property (Tick)

Length Property (Tick)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class : Length Property
Gets or sets the length of the line used to draw the tick.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Length As System.Single
public System.float Length {get; set;}
See Also

Reference

Tick Class
Tick Members


Line Property (Tick)

Line Property (Tick)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class : Line Property
Gets or sets the line used to draw the tick.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Line As Line
public Line Line {get; set;}
See Also

Reference

Tick Class
Tick Members


Step Property

Step Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class : Step Property
Gets or sets the step between two subsequent ticks in the units of measure of the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Step As System.Double
public System.double Step {get; set;}
See Also

Reference

Tick Class
Tick Members


Visible Property (Tick)

Visible Property (Tick)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Tick Class : Visible Property
Gets or sets a value indicating whether the tick is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}
See Also

Reference

Tick Class
Tick Members


Title Class

Title Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Title Class
Represents the settings for the Title object.
Object Model
Title Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Title
   Inherits MouseEnabledComponent
public sealed class Title : MouseEnabledComponent
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Title

See Also

Reference

Title Members
GrapeCity.ActiveReports.Chart Namespace


Title Class Members

Title Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Title Class

The following tables list the members exposed by Title.

Public Constructors
 | Name | Description
Public Constructor | Title Constructor | Initializes new instance of the Title object.
Top
Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the text alignment for the title object.
Public Property | Backdrop | Gets or sets the Backdrop object for the title.
Public Property | Border | Gets or sets the border to draw around the title object.
Public Property | CustomBorderDrawer | Gets or sets the custom border draw implementation class.
Public Property | DockArea | Gets or sets the chart area to which the title will be docked.
Public Property | Docking | Gets or sets the enumerated dock type value for the title.
Public Property | Font | Gets or sets the font information used to draw the title text.
Public Property | Name | Overridden. Gets or sets the name of the Title object as string.
Public Property | Text | Gets or sets the text to display for the Title object.
Public Property | Visible | Gets or sets a value indicating whether the Title object is visible.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Title object.
Public Method | GetObjectData | Gets serialization information with all of the data needed to reinstantiate this object.
Public Method | ToString | Returns a string that represents the current Title object.
Top
See Also

Reference

Title Class
GrapeCity.ActiveReports.Chart Namespace


Title Constructor

Title Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : Title Constructor
Initializes new instance of the Title object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Title()
See Also

Reference

Title Class
Title Members


Title Class Methods

Title Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Title Class

For a list of all members of this type, see Title members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Title object.
Public Method | GetObjectData | Gets serialization information with all of the data needed to reinstantiate this object.
Public Method | ToString | Returns a string that represents the current Title object.
Top
See Also

Reference

Title Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method (Title)

Clone Method (Title)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : Clone Method
Creates a clone of the Title object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

A clone of the Title object.
See Also

Reference

Title Class
Title Members


GetObjectData Method (Title)

GetObjectData Method (Title)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : GetObjectData Method
The object to be populated with serialization information.
The destination context of the serialization.
Gets serialization information with all of the data needed to reinstantiate this object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
The object to be populated with serialization information.
context
The destination context of the serialization.
See Also

Reference

Title Class
Title Members


ToString Method (Title)

ToString Method (Title)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : ToString Method
Returns a string that represents the current Title object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()

Return Value

A System.String that represents this instance.
See Also

Reference

Title Class
Title Members


Title Class Properties

Title Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Title Class

For a list of all members of this type, see Title members.

Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the text alignment for the title object.
Public Property | Backdrop | Gets or sets the Backdrop object for the title.
Public Property | Border | Gets or sets the border to draw around the title object.
Public Property | CustomBorderDrawer | Gets or sets the custom border draw implementation class.
Public Property | DockArea | Gets or sets the chart area to which the title will be docked.
Public Property | Docking | Gets or sets the enumerated dock type value for the title.
Public Property | Font | Gets or sets the font information used to draw the title text.
Public Property | Name | Overridden. Gets or sets the name of the Title object as string.
Public Property | Text | Gets or sets the text to display for the Title object.
Public Property | Visible | Gets or sets a value indicating whether the Title object is visible.
Top
See Also

Reference

Title Class
GrapeCity.ActiveReports.Chart Namespace


Alignment Property (Title)

Alignment Property (Title)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : Alignment Property
Gets or sets the text alignment for the title object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Alignment As Alignment
public Alignment Alignment {get; set;}
See Also

Reference

Title Class
Title Members
Alignment Enumeration


Backdrop Property (Title)

Backdrop Property (Title)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : Backdrop Property
Gets or sets the Backdrop object for the title.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Backdrop As Backdrop
public Backdrop Backdrop {get; set;}
See Also

Reference

Title Class
Title Members


Border Property (Title)

Border Property (Title)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : Border Property
Gets or sets the border to draw around the title object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Border As Border
public Border Border {get; set;}
See Also

Reference

Title Class
Title Members


CustomBorderDrawer Property (Title)

CustomBorderDrawer Property (Title)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : CustomBorderDrawer Property
Gets or sets the custom border draw implementation class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CustomBorderDrawer As ICustomBorderDrawer
public ICustomBorderDrawer CustomBorderDrawer {get; set;}
See Also

Reference

Title Class
Title Members


DockArea Property (Title)

DockArea Property (Title)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : DockArea Property
Gets or sets the chart area to which the title will be docked.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DockArea As ChartArea
public ChartArea DockArea {get; set;}

Property Value

The dock area.
See Also

Reference

Title Class
Title Members


Docking Property

Docking Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : Docking Property
Gets or sets the enumerated dock type value for the title.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Docking As DockType
public DockType Docking {get; set;}

Property Value

The docking.
See Also

Reference

Title Class
Title Members
DockType Enumeration


Font Property (Title)

Font Property (Title)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : Font Property
Gets or sets the font information used to draw the title text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Font As FontInfo
public FontInfo Font {get; set;}
See Also

Reference

Title Class
Title Members


Name Property (Title)

Name Property (Title)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : Name Property
Gets or sets the name of the Title object as string.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Property Name As System.String
public override System.string Name {get; set;}

Property Value

The name.
Exceptions
Exception | Description
System.ArgumentException | Name
See Also

Reference

Title Class
Title Members


Text Property (Title)

Text Property (Title)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : Text Property
Gets or sets the text to display for the Title object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Text As System.String
public System.string Text {get; set;}
See Also

Reference

Title Class
Title Members


Visible Property (Title)

Visible Property (Title)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : Visible Property
Gets or sets a value indicating whether the Title object is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}
See Also

Reference

Title Class
Title Members


TitlesCollection Class

TitlesCollection Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : TitlesCollection Class
Represents the settings for the TitlesCollection object.
Object Model
TitlesCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class TitlesCollection
   Inherits System.Collections.CollectionBase
public sealed class TitlesCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.TitlesCollection

See Also

Reference

TitlesCollection Members
GrapeCity.ActiveReports.Chart Namespace


TitlesCollection Class Members

TitlesCollection Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : TitlesCollection Class

The following tables list the members exposed by TitlesCollection.

Public Constructors
 | Name | Description
Public Constructor | TitlesCollection Constructor | Initializes a new instance of the TitlesCollection class.
Top
Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Gets or sets the collection item by the specified parameter.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a title to the collection.
Public Method | AddRange | Adds an array of titles to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Clone | Creates a clone of the TitlesCollection.
Public Method | Contains | Determines whether the collection contains the specified title.
Public Method | CopyTo | Copies the entire collection to an array, starting at the specified index of the target array.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts a title into the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific title from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

TitlesCollection Class
GrapeCity.ActiveReports.Chart Namespace


TitlesCollection Constructor

TitlesCollection Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : TitlesCollection Constructor
Initializes a new instance of the TitlesCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public TitlesCollection()
See Also

Reference

TitlesCollection Class
TitlesCollection Members


TitlesCollection Class Methods

TitlesCollection Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : TitlesCollection Class

For a list of all members of this type, see TitlesCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a title to the collection.
Public Method | AddRange | Adds an array of titles to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Clone | Creates a clone of the TitlesCollection.
Public Method | Contains | Determines whether the collection contains the specified title.
Public Method | CopyTo | Copies the entire collection to an array, starting at the specified index of the target array.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts a title into the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific title from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

TitlesCollection Class
GrapeCity.ActiveReports.Chart Namespace


Add Method (TitlesCollection)

Add Method (TitlesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : Add Method
Specifies the title to add to the collection.
Adds a title to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As Title _
) As System.Integer
public System.int Add(
   Title value
)

Parameters

value
Specifies the title to add to the collection.
See Also

Reference

TitlesCollection Class
TitlesCollection Members


AddRange Method (TitlesCollection)

AddRange Method (TitlesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : AddRange Method
The set of titles to add to the collection.
Adds an array of titles to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddRange( _
   ByVal value() As Title _
)
public void AddRange(
   Title[] value
)

Parameters

value
The set of titles to add to the collection.
See Also

Reference

TitlesCollection Class
TitlesCollection Members


Clone Method (TitlesCollection)

Clone Method (TitlesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : Clone Method
Creates a clone of the TitlesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Clone() As System.Object
public System.object Clone()

Return Value

A clone of the TitlesCollection.
See Also

Reference

TitlesCollection Class
TitlesCollection Members


Contains Method (TitlesCollection)

Contains Method (TitlesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : Contains Method
The title to check.
Determines whether the collection contains the specified title.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal value As Title _
) As System.Boolean
public System.bool Contains(
   Title value
)

Parameters

value
The title to check.

Return Value

Boolean. Returns True if the collection contains the parameter given; otherwise False.
See Also

Reference

TitlesCollection Class
TitlesCollection Members


CopyTo Method (TitlesCollection)

CopyTo Method (TitlesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : CopyTo Method
The array to which to copy the collection.
The index from which to start.
Copies the entire collection to an array, starting at the specified index of the target array.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal array() As Title, _
   ByVal index As System.Integer _
)
public void CopyTo(
   Title[] array,
   System.int index
)

Parameters

array
The array to which to copy the collection.
index
The index from which to start.
See Also

Reference

TitlesCollection Class
TitlesCollection Members


IndexOf Method (TitlesCollection)

IndexOf Method (TitlesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : IndexOf Method
The object to locate in the collection.
Returns the index of the first occurrence of a value in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As Title _
) As System.Integer
public System.int IndexOf(
   Title value
)

Parameters

value
The object to locate in the collection.

Return Value

The index of the first occurrence of the value within the entire array, if found; otherwise, the lower bound of the array - 1.
See Also

Reference

TitlesCollection Class
TitlesCollection Members


Insert Method (TitlesCollection)

Insert Method (TitlesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : Insert Method
The index at which the title should be inserted.
The title to insert.
Inserts a title into the collection at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As Title _
)
public void Insert(
   System.int index,
   Title value
)

Parameters

index
The index at which the title should be inserted.
value
The title to insert.
See Also

Reference

TitlesCollection Class
TitlesCollection Members


Remove Method (TitlesCollection)

Remove Method (TitlesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : Remove Method
The title to remove.
Removes the first occurrence of a specific title from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As Title _
)
public void Remove(
   Title value
)

Parameters

value
The title to remove.
See Also

Reference

TitlesCollection Class
TitlesCollection Members


TitlesCollection Class Properties

TitlesCollection Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : TitlesCollection Class

For a list of all members of this type, see TitlesCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Gets or sets the collection item by the specified parameter.
Top
See Also

Reference

TitlesCollection Class
GrapeCity.ActiveReports.Chart Namespace


Item Property (TitlesCollection)

Item Property (TitlesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : Item Property
Gets or sets the collection item by the specified parameter.
Overload List
Overload | Description
Item(Int32) | Gets or sets the collection item by the given index.
Item(String) | Gets or sets the collection item by the given title name.
See Also

Reference

TitlesCollection Class
TitlesCollection Members


Item(Int32) Property

Item(Int32) Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class > Item Property : Item(Int32) Property
The index of the item.
Gets or sets the collection item by the given index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Property Item( _
   ByVal index As System.Integer _
) As Title
public Title Item(
   System.int index
) {get; set;}

Parameters

index
The index of the item.
See Also

Reference

TitlesCollection Class
TitlesCollection Members
Overload List


Item(String) Property

Item(String) Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class > Item Property : Item(String) Property
The name of the title.
Gets or sets the collection item by the given title name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal titleName As System.String _
) As Title
public Title Item(
   System.string titleName
) {get;}

Parameters

titleName
The name of the title.

Property Value

Title.
See Also

Reference

TitlesCollection Class
TitlesCollection Members
Overload List


WallRange Class

WallRange Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : WallRange Class
Represents the settings of the WallRange object.
Object Model
WallRange Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class WallRange
   Inherits MouseEnabledComponent
public sealed class WallRange : MouseEnabledComponent
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.WallRange

See Also

Reference

WallRange Members
GrapeCity.ActiveReports.Chart Namespace


WallRange Class Members

WallRange Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : WallRange Class

The following tables list the members exposed by WallRange.

Public Constructors
 | Name | Description
Public Constructor | WallRange Constructor | Initializes a new instance of the WallRange object.
Top
Public Properties
 | Name | Description
Public Property | AdjacentAxes | Gets or sets the adjacent axes collection.
Public Property | Backdrop | Gets or sets the Backdrop information with which to fill the wall range.
Public Property | Border | Gets or sets the border information used to outline the WallRange.
Public Property | DrawOnTopOfGridLines | Gets or sets a value indicating whether to draw the current WallRange after the grid lines are drawn.
Public Property | EndValue | Gets or sets the end value of the wall range.
Public Property | PrimaryAxis | Gets or sets the primary axis for the WallRange.
Public Property | StartValue | Gets or sets the start value of the wall range.
Public Property | Visible | Gets or sets a value indicating whether the wall range is visible.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the WallRange object.
Top
See Also

Reference

WallRange Class
GrapeCity.ActiveReports.Chart Namespace


WallRange Constructor

WallRange Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRange Class : WallRange Constructor
Initializes a new instance of the WallRange object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public WallRange()
See Also

Reference

WallRange Class
WallRange Members


WallRange Class Methods

WallRange Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : WallRange Class

For a list of all members of this type, see WallRange members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the WallRange object.
Top
See Also

Reference

WallRange Class
GrapeCity.ActiveReports.Chart Namespace


Clone Method (WallRange)

Clone Method (WallRange)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRange Class : Clone Method
Creates a clone of the WallRange object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

A clone of the WallRange object.
See Also

Reference

WallRange Class
WallRange Members


WallRange Class Properties

WallRange Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : WallRange Class

For a list of all members of this type, see WallRange members.

Public Properties
 | Name | Description
Public Property | AdjacentAxes | Gets or sets the adjacent axes collection.
Public Property | Backdrop | Gets or sets the Backdrop information with which to fill the wall range.
Public Property | Border | Gets or sets the border information used to outline the WallRange.
Public Property | DrawOnTopOfGridLines | Gets or sets a value indicating whether to draw the current WallRange after the grid lines are drawn.
Public Property | EndValue | Gets or sets the end value of the wall range.
Public Property | PrimaryAxis | Gets or sets the primary axis for the WallRange.
Public Property | StartValue | Gets or sets the start value of the wall range.
Public Property | Visible | Gets or sets a value indicating whether the wall range is visible.
Top
See Also

Reference

WallRange Class
GrapeCity.ActiveReports.Chart Namespace


AdjacentAxes Property

AdjacentAxes Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRange Class : AdjacentAxes Property
Gets or sets the adjacent axes collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property AdjacentAxes As AxesCollection
public AxesCollection AdjacentAxes {get;}
Remarks

The WallRange is displayed on the visible walls based on primary and adjacent axes.

See Also

Reference

WallRange Class
WallRange Members


Backdrop Property (WallRange)

Backdrop Property (WallRange)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRange Class : Backdrop Property
Gets or sets the Backdrop information with which to fill the wall range.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Backdrop As Backdrop
public Backdrop Backdrop {get; set;}
See Also

Reference

WallRange Class
WallRange Members


Border Property (WallRange)

Border Property (WallRange)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRange Class : Border Property
Gets or sets the border information used to outline the WallRange.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Border As Border
public Border Border {get; set;}
See Also

Reference

WallRange Class
WallRange Members


DrawOnTopOfGridLines Property

DrawOnTopOfGridLines Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRange Class : DrawOnTopOfGridLines Property
Gets or sets a value indicating whether to draw the current WallRange after the grid lines are drawn.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DrawOnTopOfGridLines As System.Boolean
public System.bool DrawOnTopOfGridLines {get; set;}
See Also

Reference

WallRange Class
WallRange Members


EndValue Property (WallRange)

EndValue Property (WallRange)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRange Class : EndValue Property
Gets or sets the end value of the wall range.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EndValue As System.Double
public System.double EndValue {get; set;}
See Also

Reference

WallRange Class
WallRange Members


PrimaryAxis Property

PrimaryAxis Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRange Class : PrimaryAxis Property
Gets or sets the primary axis for the WallRange.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrimaryAxis As AxisBase
public AxisBase PrimaryAxis {get; set;}
See Also

Reference

WallRange Class
WallRange Members


StartValue Property (WallRange)

StartValue Property (WallRange)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRange Class : StartValue Property
Gets or sets the start value of the wall range.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartValue As System.Double
public System.double StartValue {get; set;}
See Also

Reference

WallRange Class
WallRange Members


Visible Property (WallRange)

Visible Property (WallRange)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRange Class : Visible Property
Gets or sets a value indicating whether the wall range is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}
See Also

Reference

WallRange Class
WallRange Members


WallRangesCollection Class

WallRangesCollection Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : WallRangesCollection Class

Represents the settings of the WallRangesCollection object.

Object Model
WallRangesCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class WallRangesCollection
   Inherits System.Collections.CollectionBase
public sealed class WallRangesCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.WallRangesCollection

See Also

Reference

WallRangesCollection Members
GrapeCity.ActiveReports.Chart Namespace


WallRangesCollection Class Members

WallRangesCollection Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : WallRangesCollection Class

The following tables list the members exposed by WallRangesCollection.

Public Properties
 | Name | Description
Public Property | Item | Overloaded. Gets or sets the collection item by the specified parameter.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a WallRange to the collection.
Public Method | AddRange | Adds an array of WallRanges to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Clone | Creates a clone of the WallRanges collection.
Public Method | Contains | Determines whether the collection contains the specified WallRange.
Public Method | CopyTo | Copies the entire collection to an array, starting at the specified index of the target array.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts a WallRange into the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific WallRange from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

WallRangesCollection Class
GrapeCity.ActiveReports.Chart Namespace


WallRangesCollection Class Methods

WallRangesCollection Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : WallRangesCollection Class

For a list of all members of this type, see WallRangesCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a WallRange to the collection.
Public Method | AddRange | Adds an array of WallRanges to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Clone | Creates a clone of the WallRanges collection.
Public Method | Contains | Determines whether the collection contains the specified WallRange.
Public Method | CopyTo | Copies the entire collection to an array, starting at the specified index of the target array.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts a WallRange into the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific WallRange from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

WallRangesCollection Class
GrapeCity.ActiveReports.Chart Namespace


Add Method (WallRangesCollection)

Add Method (WallRangesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class : Add Method
The WallRange to add.
Adds a WallRange to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As WallRange _
) As System.Integer
public System.int Add(
   WallRange value
)

Parameters

value
The WallRange to add.
See Also

Reference

WallRangesCollection Class
WallRangesCollection Members


AddRange Method (WallRangesCollection)

AddRange Method (WallRangesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class : AddRange Method
The set of WallRanges to add to the collection.
Adds an array of WallRanges to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddRange( _
   ByVal value() As WallRange _
)
public void AddRange(
   WallRange[] value
)

Parameters

value
The set of WallRanges to add to the collection.
See Also

Reference

WallRangesCollection Class
WallRangesCollection Members


Clone Method (WallRangesCollection)

Clone Method (WallRangesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class : Clone Method
Creates a clone of the WallRanges collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Clone() As System.Object
public System.object Clone()

Return Value

A clone of the WallRanges collection.
See Also

Reference

WallRangesCollection Class
WallRangesCollection Members


Contains Method (WallRangesCollection)

Contains Method (WallRangesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class : Contains Method
The wall range to check.
Determines whether the collection contains the specified WallRange.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal value As WallRange _
) As System.Boolean
public System.bool Contains(
   WallRange value
)

Parameters

value
The wall range to check.

Return Value

Boolean. True if the collection contains the parameter given; otherwise False.
See Also

Reference

WallRangesCollection Class
WallRangesCollection Members


CopyTo Method (WallRangesCollection)

CopyTo Method (WallRangesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class : CopyTo Method
The array to which to copy the collection.
The index from which to start.
Copies the entire collection to an array, starting at the specified index of the target array.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal array() As WallRange, _
   ByVal index As System.Integer _
)
public void CopyTo(
   WallRange[] array,
   System.int index
)

Parameters

array
The array to which to copy the collection.
index
The index from which to start.
See Also

Reference

WallRangesCollection Class
WallRangesCollection Members


IndexOf Method (WallRangesCollection)

IndexOf Method (WallRangesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class : IndexOf Method
The object to locate in the collection.

Returns the index of the first occurrence of a value in the collection.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As WallRange _
) As System.Integer
public System.int IndexOf(
   WallRange value
)

Parameters

value
The object to locate in the collection.

Return Value

The index of the first occurrence of value within the entire array, if found; otherwise, the lower bound of the array - 1.
See Also

Reference

WallRangesCollection Class
WallRangesCollection Members


Insert Method (WallRangesCollection)

Insert Method (WallRangesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class : Insert Method
The index at which the WallRange should be inserted.
The WallRange to insert.
Inserts a WallRange into the collection at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As WallRange _
)
public void Insert(
   System.int index,
   WallRange value
)

Parameters

index
The index at which the WallRange should be inserted.
value
The WallRange to insert.
See Also

Reference

WallRangesCollection Class
WallRangesCollection Members


Remove Method (WallRangesCollection)

Remove Method (WallRangesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class : Remove Method
The WallRange to remove.
Removes the first occurrence of a specific WallRange from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As WallRange _
)
public void Remove(
   WallRange value
)

Parameters

value
The WallRange to remove.
See Also

Reference

WallRangesCollection Class
WallRangesCollection Members


WallRangesCollection Class Properties

WallRangesCollection Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : WallRangesCollection Class

For a list of all members of this type, see WallRangesCollection members.

Public Properties
 | Name | Description
Public Property | Item | Overloaded. Gets or sets the collection item by the specified parameter.
Top
See Also

Reference

WallRangesCollection Class
GrapeCity.ActiveReports.Chart Namespace


Item Property (WallRangesCollection)

Item Property (WallRangesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class : Item Property
Gets or sets the collection item by the specified parameter.
Overload List
Overload | Description
Item(Int32) | Gets or sets the collection item by the given index.
Item(String) | Gets or sets the collection item by the given wall range name.
See Also

Reference

WallRangesCollection Class
WallRangesCollection Members


Item(Int32) Property

Item(Int32) Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class > Item Property : Item(Int32) Property
The index of the item.
Gets or sets the collection item by the given index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Property Item( _
   ByVal index As System.Integer _
) As WallRange
public WallRange Item(
   System.int index
) {get; set;}

Parameters

index
The index of the item.

Property Value

WallRange.
See Also

Reference

WallRangesCollection Class
WallRangesCollection Members
Overload List


Item(String) Property

Item(String) Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class > Item Property : Item(String) Property
The name of the WallRange.
Gets or sets the collection item by the given wall range name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal wallRangeName As System.String _
) As WallRange
public WallRange Item(
   System.string wallRangeName
) {get;}

Parameters

wallRangeName
The name of the WallRange.

Property Value

WallRange.
See Also

Reference

WallRangesCollection Class
WallRangesCollection Members
Overload List


XmlDataProvider Class

XmlDataProvider Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : XmlDataProvider Class
Provides access to XML data.
Object Model
XmlDataProvider Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class XmlDataProvider
public sealed class XmlDataProvider
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.XmlDataProvider

See Also

Reference

XmlDataProvider Members
GrapeCity.ActiveReports.Chart Namespace


XmlDataProvider Class Members

XmlDataProvider Class Members
Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : XmlDataProvider Class

The following tables list the members exposed by XmlDataProvider.

Public Constructors
 | Name | Description
Public Constructor | XmlDataProvider Constructor | Initializes a new instance of the XMLDataProvider class.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the number of data values.
Public Property | Item | Gets the data values at the specified index. If the index exceeds the maximum allowed value, null will be returned.
Top
See Also

Reference

XmlDataProvider Class
GrapeCity.ActiveReports.Chart Namespace


XmlDataProvider Constructor

XmlDataProvider Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > XmlDataProvider Class : XmlDataProvider Constructor
The data source object.
The name of the column to read the rows of the data from.
Initializes a new instance of the XMLDataProvider class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal dataSource As System.Object, _
   ByVal columnName As System.String _
)
public XmlDataProvider(
   System.object dataSource,
   System.string columnName
)

Parameters

dataSource
The data source object.
columnName
The name of the column to read the rows of the data from.
See Also

Reference

XmlDataProvider Class
XmlDataProvider Members


XmlDataProvider Class Properties

XmlDataProvider Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : XmlDataProvider Class

For a list of all members of this type, see XmlDataProvider members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of data values.
Public Property | Item | Gets the data values at the specified index. If the index exceeds the maximum allowed value, null will be returned.
Top
See Also

Reference

XmlDataProvider Class
GrapeCity.ActiveReports.Chart Namespace


Count Property (XmlDataProvider)

Count Property (XmlDataProvider)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > XmlDataProvider Class : Count Property
Gets the number of data values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

XmlDataProvider Class
XmlDataProvider Members


Item Property (XmlDataProvider)

Item Property (XmlDataProvider)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > XmlDataProvider Class : Item Property
The index of the item.
Gets the data values at the specified index. If the index exceeds the maximum allowed value, null will be returned.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As System.Object
public System.object this[
   System.int index
]; {get;}

Parameters

index
The index of the item.
See Also

Reference

XmlDataProvider Class
XmlDataProvider Members


Alignment Enumeration

Alignment Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Alignment Enumeration
Specifies how the text item anchors to its position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Alignment
   Inherits System.Enum
public enum Alignment : System.Enum
Members
Member | Description
Bottom | The text item anchors to the bottom.
BottomLeft | The text item anchors to the bottom left.
BottomRight | The text item anchors to the bottom right.
Center | The text item anchors to the center.
Left | The text item anchors to the left.
Right | The text item anchors to the right.
Top | The text item anchors to the top.
TopLeft | The text item anchors to the top left.
TopRight | The text item anchors to the top right.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.Alignment

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


ArrowType Enumeration

ArrowType Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : ArrowType Enumeration
Specifies the arrow type used for the axis line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ArrowType
   Inherits System.Enum
public enum ArrowType : System.Enum
Members
Member | Description
Lines | Lines are used to create an arrow.
None | No arrow type is used.
Triangle | A triangle is used as the arrow.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.ArrowType

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


AxisType Enumeration

AxisType Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : AxisType Enumeration
Specifies the axis type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum AxisType
   Inherits System.Enum
public enum AxisType : System.Enum
Members
Member | Description
Categorical | The axis is used to place categories.
Logarithmic | A logarithmic axis is used.
Numerical | A numerical axis is used.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.AxisType

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


BarType Enumeration

BarType Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : BarType Enumeration
Specifies the type of bars to use.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum BarType
   Inherits System.Enum
public enum BarType : System.Enum
Members
Member | Description
Bar | A filled rectangular shape is used.
Cone | A cone shape is used.
Custom | A custom shape is used.
Cylinder | A cylindrical shape is used.
Pyramid | A pyramidal shape is used.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.BarType

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


BaseStyle Enumeration

BaseStyle Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : BaseStyle Enumeration
Gets or sets a circular or square base drawing style for the 3D funnel chart or 3D pyramid chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum BaseStyle
   Inherits System.Enum
public enum BaseStyle : System.Enum
Members
Member | Description
CircularBase | Renders the base of the funnel or pyramid in a circular shape.
SquareBase | Renders the base of the funnel or pyramid in a square shape.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.BaseStyle

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


ChartType Enumeration

ChartType Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : ChartType Enumeration

Specifies the ChartType used for the Series.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ChartType
   Inherits System.Enum
public enum ChartType : System.Enum
Members
Member | Description
Area | An area chart is drawn.
Area3D | A 3D area chart is drawn.
Bar2D | A bar chart is drawn.
Bar3D | A 3D bar chart is drawn.
Bezier | A bezier chart is drawn.
Bezier3D | A bezier 3D chart is drawn.
BezierXY | A bezier XY chart is drawn.
BezierXY3D | A bezier XY 3D chart is drawn.
Bubble | A bubble chart is drawn.
BubbleXY | A bubble XY chart is drawn.
Candle | A candle chart is drawn.
ClusteredBar | A clustered bar chart is drawn.
Doughnut | A doughnut chart is drawn.
Doughnut3D | A 3D doughnut chart is drawn.
Funnel | A funnel chart is drawn.
Funnel3D | A funnel 3D chart is drawn.
Gantt | A Gantt chart is drawn.
Gantt3D | A Gantt 3D chart is drawn.
HiLo | A HiLo chart is drawn.
HiLoOpenClose | A HiLoOpenClose chart is drawn.
HorizontalBar | A HorizontalBar chart is drawn.
HorizontalBar3D | A HorizontalBar3D chart is drawn.
Kagi | A Kagi chart is drawn.
Kagi3D | A Kagi 3D chart is drawn.
Line | A line chart is drawn.
Line3D | A 3D line chart is drawn.
LineXY | A line XY chart is drawn.
LineXY3D | A line XY 3D chart is drawn.
PlotXY | A plot XY chart is drawn.
PointAndFigure | A point and figure chart is drawn.
Pyramid | A pyramid chart is drawn.
Pyramid3D | A pyramid 3D chart is drawn.
Renko | A Renko chart is drawn.
Renko3D | A Renko 3D chart is drawn.
Scatter | A scatter chart is drawn.
StackedArea | A stacked area chart is drawn.
StackedArea100Pct | A stacked area chart filling 100% of the chart area is drawn.
StackedArea3D | A stacked area 3D chart is drawn.
StackedArea3D100Pct | A stacked area 3D 100% chart is drawn.
StackedBar | A stacked bar chart is drawn.
StackedBar100Pct | A stacked bar chart filling 100% of the chart area is drawn.
StackedBar3D | A 3D stacked bar chart is drawn.
StackedBar3D100Pct | A 3D stacked bar chart filling 100% of the chart area is drawn.
ThreeLineBreak | A three line break chart is drawn.
ThreeLineBreak3D | A three line break 3D chart is drawn.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.ChartType

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


ColorPalette Enumeration

ColorPalette Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : ColorPalette Enumeration
Specifies what color palette is used.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ColorPalette
   Inherits System.Enum
public enum ColorPalette : System.Enum
Members
Member | Description
Autumn | The rich browns and golds of autumn.
Berries | A range of colors from blueberry through raspberry.
Cascade | A cascade of eight cool colors ranging from deep teal down through pale orchid.
Confetti | A sprinkling of bright and pastel colors.
Default | The same color scheme as Cascade.
Greens | A medley of greens from 70's refrigerator green through evergreen.
Iceberg | A range of the soft blues and greys found in an iceberg.
Murphy | Muted greens, rusts and beiges.
None | All data is drawn using the same teal color.
Springtime | The colors of spring, in deep green, two vivid colors and five pastels.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.ColorPalette

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


DeviceModes Enumeration

DeviceModes Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : DeviceModes Enumeration
Specifies the device drawing mode used to render the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DeviceModes
   Inherits System.Enum
public enum DeviceModes : System.Enum
Members
Member | Description
BlackWhite | Hatch patterns and dashed lines are used to designate colors.
None | The standard mode, in which colors are used.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.DeviceModes

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


DockType Enumeration

DockType Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : DockType Enumeration
Specifies the docking area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DockType
   Inherits System.Enum
public enum DockType : System.Enum
Members
Member | Description
Bottom | Bottom docking is used.
Left | Left docking is used.
Right | Right docking is used.
Top | Top docking is used.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.DockType

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


FunnelStyle Enumeration

FunnelStyle Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : FunnelStyle Enumeration
Specifies whether the Y value for the series points to the width or the height of the funnel. The default value is YIsHeight.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum FunnelStyle
   Inherits System.Enum
public enum FunnelStyle : System.Enum
Members
Member | Description
YIsHeight | The Y value of the series points determines the Height of the funnel.
YIsWidth | The Y value of the series points determines the Width of the funnel.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.FunnelStyle

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


LabelsPlacement Enumeration

LabelsPlacement Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : LabelsPlacement Enumeration
Specifies whether the data point labels appear on the left or right side of the funnel or pyramid chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LabelsPlacement
   Inherits System.Enum
public enum LabelsPlacement : System.Enum
Members
Member | Description
Left | Labels appear to the left of the funnel or pyramid.
Right | Labels appear to the right of the funnel or pyramid.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.LabelsPlacement

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


LegendMode Enumeration

LegendMode Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : LegendMode Enumeration
Specifies the mode used to render legend items.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LegendMode
   Inherits System.Enum
public enum LegendMode : System.Enum
Members
Member | Description
Auto | Renders legend items for each data point for one figure charts (e.g., doughnut, funnel, and pyramid) and legend items for each series for all other chart types.
Points | Renders legend items for each data point in the series.
Series | Renders legend items for each series.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.LegendMode

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


LightType Enumeration

LightType Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : LightType Enumeration
Specifies the type of light source used.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LightType
   Inherits System.Enum
public enum LightType : System.Enum
Members
Member | Description
Ambient | An ambient light source is used. It is equal to DirectionalLightRatio = 0.
FiniteDirectional | A point light source is used.
InfiniteDirectional | An infinite directional light source (like the sun) is used.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.LightType

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


MarkerStyle Enumeration

MarkerStyle Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : MarkerStyle Enumeration
Specifies the shape of the marker.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MarkerStyle
   Inherits System.Enum
public enum MarkerStyle : System.Enum
Members
Member | Description
Circle | A circle shape is displayed.
Cross | An X-like cross shape is displayed.
Diamond | A diamond shape is displayed.
InvTriangle | An inverted triangle shape is displayed.
None | No shape is displayed.
Point | A dot shape is displayed.
Pyramid | A pyramid shape is displayed.
Square | A square shape is displayed.
Triangle | A triangle shape is displayed.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.MarkerStyle

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


StandardAxis Enumeration

StandardAxis Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : StandardAxis Enumeration
Specifies which axis is the standard axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum StandardAxis
   Inherits System.Enum
public enum StandardAxis : System.Enum
Members
Member | Description
AxisX | The X axis is the standard axis.
AxisX2 | The secondary X axis is the standard axis.
AxisY | The Y axis is the standard axis.
AxisY2 | The secondary Y axis is the standard axis.
AxisZ | The Z axis is the standard axis.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.StandardAxis

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


StdLegendMarker Enumeration

StdLegendMarker Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : StdLegendMarker Enumeration
Specifies the standard legend marker shape to use.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum StdLegendMarker
   Inherits System.Enum
public enum StdLegendMarker : System.Enum
Members
Member | Description
Area | A filled area shape is used.
Bar | A filled rectangular shape is used.
Line | A line is used.
None | No shape is used.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.StdLegendMarker

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


UICommand Enumeration

UICommand Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : UICommand Enumeration
Specifies the command to be used for the DoCommand method of the Chart control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum UICommand
   Inherits System.Enum
public enum UICommand : System.Enum
Members
Member | Description
Clear | The chart reverts to an empty state.
Copy | Copies the chart to the clipboard.
Customize | Displays the Chart Designer dialog.
Designer | Displays the Chart Designer dialog.
New | Creates a new chart.
OpenXml | Displays the Open File dialog to load a chart from an XML file.
PrintPreview | Displays a chart print preview.
RefreshData | Refreshes the chart data.
SaveXml | Displays the Save File dialog to save a chart to an XML file.
Wizard | Displays the chart wizard.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.UICommand

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


UIOptions Enumeration

UIOptions Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : UIOptions Enumeration
Specifies the user interface settings for the Chart control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum UIOptions
   Inherits System.Enum
public enum UIOptions : System.Enum
Members
Member | Description
ContextCustomize | Adds a "Customize" menu under the context menu.
ForceHitTesting | Allows the HitTest function to be used. By default the control applies optimization so that only objects that have mouse event handlers (or context menus or tooltips) attached are visible through hit testing.
None | No UI options are used.
UseCustomTooltips | Allows the drawn tooltips of the control to be used instead of System.Windows.Forms.Tooltip.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.UIOptions

See Also

Reference

GrapeCity.ActiveReports.Chart Namespace


Padding Structure

Padding Structure
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Padding Structure
Provides the settings used to set a margin (four edges) inside a control.
Object Model
Padding Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure Padding
   Inherits System.ValueType
public struct Padding : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Chart.Padding

See Also

Reference

Padding Members
GrapeCity.ActiveReports.Chart Namespace


Padding Structure Members

Padding Structure Members
Fields Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Padding Structure

The following tables list the members exposed by Padding.

Public Constructors
 | Name | Description
Public Constructor | Padding Constructor | Overloaded. Initializes a new instance of the Padding structure.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | Returns a Padding object with no padding.
Top
Public Properties
 | Name | Description
Public Property | All | Gets or sets the padding value for all of the edges.
Public Property | Bottom | Gets or sets the padding value for the bottom edge.
Public Property | Horizontal | Gets or sets the combined padding value for the left and right edges.
Public Property | Left | Gets or sets the padding value for the left edge.
Public Property | Right | Gets or sets the padding value for the right edge.
Public Property | Size | Gets the padding information for the control as a System.Drawing.Size structure.
Public Property | Top | Gets or sets the padding value for the top edge.
Public Property | Vertical | Gets or sets the combined padding value for the top and bottom edges.
Top
Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Determines whether the value of the specified Padding object equals the current Padding object.
Public Method | GetHashCode | Generates a hash code for the Padding object.
Top
Public Operators
public Operator Equality | Tests whether two Padding objects are equivalent.
public Operator Inequality | Tests whether two Padding objects are not equivalent.
Top
See Also

Reference

Padding Structure
GrapeCity.ActiveReports.Chart Namespace


Padding Constructor

Padding Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : Padding Constructor
Initializes a new instance of the Padding structure.
Overload List
Overload | Description
Padding Constructor(Int32) | Initializes a new instance of the Padding structure using the same value for all edges.
Padding Constructor(Int32,Int32,Int32,Int32) | Initializes a new instance of the Padding structure using the specified value for each edge.
See Also

Reference

Padding Structure
Padding Members


Padding Constructor(Int32)

Padding Constructor(Int32)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure > Padding Constructor : Padding Constructor(Int32)
Applies the same value to all four edges of the control.
Initializes a new instance of the Padding structure using the same value for all edges.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal all As System.Integer _
)
public Padding(
   System.int all
)

Parameters

all
Applies the same value to all four edges of the control.
See Also

Reference

Padding Structure
Padding Members
Overload List


Padding Constructor(Int32,Int32,Int32,Int32)

Padding Constructor(Int32,Int32,Int32,Int32)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure > Padding Constructor : Padding Constructor(Int32,Int32,Int32,Int32)
The value to set for the left edge of the control.
The value to set for the top edge of the control.
The value to set for the right edge of the control.
The value to set for the bottom edge of the control.
Initializes a new instance of the Padding structure using the specified value for each edge.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal left As System.Integer, _
   ByVal top As System.Integer, _
   ByVal right As System.Integer, _
   ByVal bottom As System.Integer _
)
public Padding(
   System.int left,
   System.int top,
   System.int right,
   System.int bottom
)

Parameters

left
The value to set for the left edge of the control.
top
The value to set for the top edge of the control.
right
The value to set for the right edge of the control.
bottom
The value to set for the bottom edge of the control.
See Also

Reference

Padding Structure
Padding Members
Overload List


Padding Structure Methods

Padding Structure Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Padding Structure

For a list of all members of this type, see Padding members.

Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Determines whether the value of the specified Padding object equals the current Padding object.
Public Method | GetHashCode | Generates a hash code for the Padding object.
Top
See Also

Reference

Padding Structure
GrapeCity.ActiveReports.Chart Namespace


Equals Method (Padding)

Equals Method (Padding)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : Equals Method
Determines whether the value of the specified Padding object equals the current Padding object.
Overload List
Overload | Description
Equals(Padding) | Determines whether the value of the specified Padding object equals the current Padding object.
Equals(Object) | Determines whether the value of the specified object equals the current Padding object.
See Also

Reference

Padding Structure
Padding Members


Equals(Padding) Method

Equals(Padding) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure > Equals Method : Equals(Padding) Method
The Padding object to compare to the current Padding object.
Determines whether the value of the specified Padding object equals the current Padding object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Equals( _
   ByVal padding As Padding _
) As System.Boolean
public System.bool Equals(
   Padding padding
)

Parameters

padding
The Padding object to compare to the current Padding object.
See Also

Reference

Padding Structure
Padding Members
Overload List


Equals(Object) Method

Equals(Object) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure > Equals Method : Equals(Object) Method
The object to compare to the current Padding object.
Determines whether the value of the specified object equals the current Padding object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The object to compare to the current Padding object.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.
See Also

Reference

Padding Structure
Padding Members
Overload List


GetHashCode Method (Padding)

GetHashCode Method (Padding)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : GetHashCode Method
Generates a hash code for the Padding object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

Padding Structure
Padding Members


Padding Structure Properties

Padding Structure Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Padding Structure

For a list of all members of this type, see Padding members.

Public Properties
 | Name | Description
Public Property | All | Gets or sets the padding value for all of the edges.
Public Property | Bottom | Gets or sets the padding value for the bottom edge.
Public Property | Horizontal | Gets or sets the combined padding value for the left and right edges.
Public Property | Left | Gets or sets the padding value for the left edge.
Public Property | Right | Gets or sets the padding value for the right edge.
Public Property | Size | Gets the padding information for the control as a System.Drawing.Size structure.
Public Property | Top | Gets or sets the padding value for the top edge.
Public Property | Vertical | Gets or sets the combined padding value for the top and bottom edges.
Top
See Also

Reference

Padding Structure
GrapeCity.ActiveReports.Chart Namespace


All Property (Padding)

All Property (Padding)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : All Property
Gets or sets the padding value for all of the edges.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property All As System.Integer
public System.int All {get; set;}

Property Value

An integer in points.
See Also

Reference

Padding Structure
Padding Members


Bottom Property (Padding)

Bottom Property (Padding)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : Bottom Property
Gets or sets the padding value for the bottom edge.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Bottom As System.Integer
public System.int Bottom {get; set;}

Property Value

An integer in points.
See Also

Reference

Padding Structure
Padding Members


Horizontal Property (Padding)

Horizontal Property (Padding)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : Horizontal Property
Gets or sets the combined padding value for the left and right edges.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Horizontal As System.Integer
public System.int Horizontal {get;}

Property Value

An integer value in points.
See Also

Reference

Padding Structure
Padding Members


Left Property (Padding)

Left Property (Padding)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : Left Property
Gets or sets the padding value for the left edge.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Left As System.Integer
public System.int Left {get; set;}

Property Value

An integer in points.
See Also

Reference

Padding Structure
Padding Members


Right Property (Padding)

Right Property (Padding)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : Right Property
Gets or sets the padding value for the right edge.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Right As System.Integer
public System.int Right {get; set;}

Property Value

An integer in points.
See Also

Reference

Padding Structure
Padding Members


Size Property (Padding)

Size Property (Padding)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : Size Property
Gets the padding information for the control as a System.Drawing.Size structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Size As Size
public Size Size {get;}

Property Value

A System.Drawing.Size structure.
See Also

Reference

Padding Structure
Padding Members


Top Property (Padding)

Top Property (Padding)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : Top Property
Gets or sets the padding value for the top edge.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Top As System.Integer
public System.int Top {get; set;}

Property Value

An integer in points.
See Also

Reference

Padding Structure
Padding Members


Vertical Property (Padding)

Vertical Property (Padding)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : Vertical Property
Gets or sets the combined padding value for the top and bottom edges.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Vertical As System.Integer
public System.int Vertical {get;}

Property Value

An integer value in points.
See Also

Reference

Padding Structure
Padding Members


Padding Structure Fields

Padding Structure Fields

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : Padding Structure

For a list of all members of this type, see Padding members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | Returns a Padding object with no padding.
Top
See Also

Reference

Padding Structure
GrapeCity.ActiveReports.Chart Namespace


Empty Field (Padding)

Empty Field (Padding)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : Empty Field
Returns a Padding object with no padding.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Empty As Padding
public static readonly Padding Empty
See Also

Reference

Padding Structure
Padding Members


Equality Operator (Padding)

Equality Operator (Padding)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : Equality Operator
The first Padding object to compare.
The second Padding object to compare.
Tests whether two Padding objects are equivalent.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator =( _
   ByVal p1 As Padding, _
   ByVal p2 As Padding _
) As System.Boolean
public System.bool operator ==(
   Padding p1,
   Padding p2
)

Parameters

p1
The first Padding object to compare.
p2
The second Padding object to compare.
See Also

Reference

Padding Structure
Padding Members


Inequality Operator (Padding)

Inequality Operator (Padding)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Padding Structure : Inequality Operator
The first Padding object to compare.
The second Padding object to compare.
Tests whether two Padding objects are not equivalent.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator <>( _
   ByVal p1 As Padding, _
   ByVal p2 As Padding _
) As System.Boolean
public System.bool operator !=(
   Padding p1,
   Padding p2
)

Parameters

p1
The first Padding object to compare.
p2
The second Padding object to compare.
See Also

Reference

Padding Structure
Padding Members


IChartMemberNameProvider Interface

IChartMemberNameProvider Interface
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : IChartMemberNameProvider Interface
Provides a name for the chart member name provider.
Object Model
IChartMemberNameProvider Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IChartMemberNameProvider
public interface IChartMemberNameProvider
See Also

Reference

IChartMemberNameProvider Members
GrapeCity.ActiveReports.Chart Namespace


IChartMemberNameProvider Interface Members

IChartMemberNameProvider Interface Members
Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : IChartMemberNameProvider Interface

The following tables list the members exposed by IChartMemberNameProvider.

Public Methods
 | Name | Description
Method | GetName | Gets the name for the field that should be found.
Top
See Also

Reference

IChartMemberNameProvider Interface
GrapeCity.ActiveReports.Chart Namespace


IChartMemberNameProvider Interface Methods

IChartMemberNameProvider Interface Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : IChartMemberNameProvider Interface

For a list of all members of this type, see IChartMemberNameProvider members.

Public Methods
 | Name | Description
Method | GetName | Gets the name for the field that should be found.
Top
See Also

Reference

IChartMemberNameProvider Interface
GrapeCity.ActiveReports.Chart Namespace


GetName Method (IChartMemberNameProvider)

GetName Method (IChartMemberNameProvider)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > IChartMemberNameProvider Interface : GetName Method
The index of the field to find.
Gets the name for the field that should be found.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetName( _
   ByVal i As System.Integer _
) As System.String
System.string GetName(
   System.int i
)

Parameters

i
The index of the field to find.

Return Value

The name of the field or the empty string (""), if there is no value to return.
See Also

Reference

IChartMemberNameProvider Interface
IChartMemberNameProvider Members


CustomDrawEventHandler Delegate

CustomDrawEventHandler Delegate

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : CustomDrawEventHandler Delegate
Source of the event
CustomDrawEventArgs class which contains the event data.
Represents the method that handles the CustomDraw event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub CustomDrawEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As CustomDrawEventArgs _
)
public delegate void CustomDrawEventHandler(
   System.object sender,
   CustomDrawEventArgs e
)

Parameters

sender
Source of the event
e
CustomDrawEventArgs class which contains the event data.
See Also

Reference

CustomDrawEventHandler Members
GrapeCity.ActiveReports.Chart Namespace


GraphMouseEventHandler Delegate

GraphMouseEventHandler Delegate

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : GraphMouseEventHandler Delegate
Source of the event.
GraphMouseEventArgs class which contains the event data.
Represents the method that handles the GraphMouse event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub GraphMouseEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As GraphMouseEventArgs _
)
public delegate void GraphMouseEventHandler(
   System.object sender,
   GraphMouseEventArgs e
)

Parameters

sender
Source of the event.
e
GraphMouseEventArgs class which contains the event data.
See Also

Reference

GraphMouseEventHandler Members
GrapeCity.ActiveReports.Chart Namespace


GrapeCity.ActiveReports.Chart.Annotations Namespace

GrapeCity.ActiveReports.Chart.Annotations Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Chart.v10 Assembly : GrapeCity.ActiveReports.Chart.Annotations Namespace
The GrapeCity.ActiveReports.Chart.Annotations namespace contains the chart annotations classes.
Classes
 | Class | Description
Class | Annotation | Represents the base class for all of the annotation classes.
Class | AnnotationLine | Represents the settings for the AnnotationLine class.
Class | AnnotationsCollection | Represents the settings of the AnnotationsCollection class.
Class | AnnotationTextBar | Represents the settings for the AnnotationTextBar class.
Enumerations
 | Enumeration | Description
Enumeration | AnchorPlacementType | Specifies how an annotation bar anchors to the position of an Annotation.
See Also

Reference

GrapeCity.ActiveReports.Chart.v10 Assembly


Annotation Class

Annotation Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : Annotation Class
Represents the base class for all of the annotation classes.
Object Model
Annotation Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class Annotation
   Inherits GrapeCity.ActiveReports.Chart.MouseEnabledComponent
public abstract class Annotation : GrapeCity.ActiveReports.Chart.MouseEnabledComponent
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Annotations.Annotation
GrapeCity.ActiveReports.Chart.Annotations.AnnotationLine
GrapeCity.ActiveReports.Chart.Annotations.AnnotationTextBar

See Also

Reference

Annotation Members
GrapeCity.ActiveReports.Chart.Annotations Namespace


Annotation Class Members

Annotation Class Members
Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : Annotation Class

The following tables list the members exposed by Annotation.

Public Properties
 | Name | Description
Public Property | AnnotationClass | Gets the name of the annotation type.
Top
See Also

Reference

Annotation Class
GrapeCity.ActiveReports.Chart.Annotations Namespace


Annotation Class Properties

Annotation Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : Annotation Class

For a list of all members of this type, see Annotation members.

Public Properties
 | Name | Description
Public Property | AnnotationClass | Gets the name of the annotation type.
Top
See Also

Reference

Annotation Class
GrapeCity.ActiveReports.Chart.Annotations Namespace


AnnotationClass Property (Annotation)

AnnotationClass Property (Annotation)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > Annotation Class : AnnotationClass Property
Gets the name of the annotation type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property AnnotationClass As System.String
public abstract System.string AnnotationClass {get;}
See Also

Reference

Annotation Class
Annotation Members


AnnotationLine Class

AnnotationLine Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationLine Class
Represents the settings for the AnnotationLine class.
Object Model
AnnotationLine Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class AnnotationLine
   Inherits Annotation
public sealed class AnnotationLine : Annotation
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Annotations.Annotation
GrapeCity.ActiveReports.Chart.Annotations.AnnotationLine

See Also

Reference

AnnotationLine Members
GrapeCity.ActiveReports.Chart.Annotations Namespace


AnnotationLine Class Members

AnnotationLine Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationLine Class

The following tables list the members exposed by AnnotationLine.

Public Constructors
 | Name | Description
Public Constructor | AnnotationLine Constructor | Initializes a new instance of the AnnotationLine class.
Top
Public Properties
 | Name | Description
Public Property | AnnotationClass | Overridden. Gets the name of the annotation type.
Public Property | EndConnection | Gets or sets the object to which to connect the end point of the annotation line.
Public Property | EndConnectionIndex | Gets or sets the index of the anchor point of the destination annotation to which to connect the end point.
Public Property | EndPoint | Gets or sets the end point of the line.
Public Property | Line | Get or sets the line information used to draw this annotation.
Public Property | Name | Overridden. Gets or sets the name of the AnnotationLine as string.
Public Property | StartConnection | Gets or sets the object to which to connect the start point of the annotation line.
Public Property | StartConnectionIndex | Gets or sets the index of the anchor point of the destination annotation to which to connect the start point.
Public Property | StartPoint | Get or sets start point of the line.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the AnnotationLine object.
Public Method | ToString | Converts the value of the current instance to its string representation.
Top
See Also

Reference

AnnotationLine Class
GrapeCity.ActiveReports.Chart.Annotations Namespace


AnnotationLine Constructor

AnnotationLine Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class : AnnotationLine Constructor
Initializes a new instance of the AnnotationLine class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public AnnotationLine()
See Also

Reference

AnnotationLine Class
AnnotationLine Members


AnnotationLine Class Methods

AnnotationLine Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationLine Class

For a list of all members of this type, see AnnotationLine members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the AnnotationLine object.
Public Method | ToString | Converts the value of the current instance to its string representation.
Top
See Also

Reference

AnnotationLine Class
GrapeCity.ActiveReports.Chart.Annotations Namespace


Clone Method (AnnotationLine)

Clone Method (AnnotationLine)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class : Clone Method
Creates a clone of the AnnotationLine object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

A clone of the AnnotationLine object.
See Also

Reference

AnnotationLine Class
AnnotationLine Members


ToString Method (AnnotationLine)

ToString Method (AnnotationLine)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class : ToString Method
Converts the value of the current instance to its string representation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()

Return Value

A System.String that represents this instance.
See Also

Reference

AnnotationLine Class
AnnotationLine Members


AnnotationLine Class Properties

AnnotationLine Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationLine Class

For a list of all members of this type, see AnnotationLine members.

Public Properties
 | Name | Description
Public Property | AnnotationClass | Overridden. Gets the name of the annotation type.
Public Property | EndConnection | Gets or sets the object to which to connect the end point of the annotation line.
Public Property | EndConnectionIndex | Gets or sets the index of the anchor point of the destination annotation to which to connect the end point.
Public Property | EndPoint | Gets or sets the end point of the line.
Public Property | Line | Get or sets the line information used to draw this annotation.
Public Property | Name | Overridden. Gets or sets the name of the AnnotationLine as string.
Public Property | StartConnection | Gets or sets the object to which to connect the start point of the annotation line.
Public Property | StartConnectionIndex | Gets or sets the index of the anchor point of the destination annotation to which to connect the start point.
Public Property | StartPoint | Get or sets start point of the line.
Top
See Also

Reference

AnnotationLine Class
GrapeCity.ActiveReports.Chart.Annotations Namespace


AnnotationClass Property (AnnotationLine)

AnnotationClass Property (AnnotationLine)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class : AnnotationClass Property
Gets the name of the annotation type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable ReadOnly Property AnnotationClass As System.String
public override System.string AnnotationClass {get;}
See Also

Reference

AnnotationLine Class
AnnotationLine Members


EndConnection Property

EndConnection Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class : EndConnection Property
Gets or sets the object to which to connect the end point of the annotation line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EndConnection As AnnotationTextBar
public AnnotationTextBar EndConnection {get; set;}
See Also

Reference

AnnotationLine Class
AnnotationLine Members


EndConnectionIndex Property

EndConnectionIndex Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class : EndConnectionIndex Property
Gets or sets the index of the anchor point of the destination annotation to which to connect the end point.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EndConnectionIndex As System.Integer
public System.int EndConnectionIndex {get; set;}
See Also

Reference

AnnotationLine Class
AnnotationLine Members


EndPoint Property

EndPoint Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class : EndPoint Property
Gets or sets the end point of the line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EndPoint As Point2d
public Point2d EndPoint {get; set;}
Remarks
The EndPoint value is not used if the end of the line is connected to another annotation.
See Also

Reference

AnnotationLine Class
AnnotationLine Members


Line Property (AnnotationLine)

Line Property (AnnotationLine)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class : Line Property
Get or sets the line information used to draw this annotation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Line As Line
public Line Line {get; set;}
See Also

Reference

AnnotationLine Class
AnnotationLine Members


Name Property (AnnotationLine)

Name Property (AnnotationLine)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class : Name Property
Gets or sets the name of the AnnotationLine as string.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Property Name As System.String
public override System.string Name {get; set;}

Property Value

The name.
See Also

Reference

AnnotationLine Class
AnnotationLine Members


StartConnection Property

StartConnection Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class : StartConnection Property
Gets or sets the object to which to connect the start point of the annotation line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartConnection As AnnotationTextBar
public AnnotationTextBar StartConnection {get; set;}
See Also

Reference

AnnotationLine Class
AnnotationLine Members


StartConnectionIndex Property

StartConnectionIndex Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class : StartConnectionIndex Property
Gets or sets the index of the anchor point of the destination annotation to which to connect the start point.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartConnectionIndex As System.Integer
public System.int StartConnectionIndex {get; set;}
See Also

Reference

AnnotationLine Class
AnnotationLine Members


StartPoint Property

StartPoint Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationLine Class : StartPoint Property
Get or sets start point of the line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartPoint As Point2d
public Point2d StartPoint {get; set;}
Remarks
The StartPoint value is not used if the beginning of the line is connected to another annotation.
See Also

Reference

AnnotationLine Class
AnnotationLine Members


AnnotationsCollection Class

AnnotationsCollection Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationsCollection Class
Represents the settings of the AnnotationsCollection class.
Object Model
AnnotationsCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class AnnotationsCollection
   Inherits System.Collections.CollectionBase
public sealed class AnnotationsCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Annotations.AnnotationsCollection

See Also

Reference

AnnotationsCollection Members
GrapeCity.ActiveReports.Chart.Annotations Namespace


AnnotationsCollection Class Members

AnnotationsCollection Class Members
Properties Methods Events

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationsCollection Class

The following tables list the members exposed by AnnotationsCollection.

Public Constructors
 | Name | Description
Public Constructor | AnnotationsCollection Constructor | Overloaded. Initializes a new instance of the AnnotationsCollection class.
Top
Public Properties
 | Name | Description
Public Property | Item | Overloaded. Gets or sets the collection item by the given index.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an Annotation to the collection.
Public Method | AddRange | Adds an array of annotations to the collection.
Public Method | Clear | Clears all items from the collection.
Public Method | Clone | Creates a clone of the AnnotationsCollection.
Public Method | Contains | Determines whether the collection contains the specified annotation.
Public Method | CopyTo | Copies the entire collection to an array, starting at the specified index of the target array.
Public Method | Dispose | Releases resources associated with this object.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts an Annotation into the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific Annotation from the collection.
Public Method | RemoveAt | Removes the specified annotation from the collection.
Public Method | ToArray | Copies the elements of the AnnotationsCollection to a new array.
Top
Public Events
 | Name | Description
Public Event | Change | Occurs when the content of the collection changes.
Top
See Also

Reference

AnnotationsCollection Class
GrapeCity.ActiveReports.Chart.Annotations Namespace


AnnotationsCollection Constructor

AnnotationsCollection Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : AnnotationsCollection Constructor
Initializes a new instance of the AnnotationsCollection class.
Overload List
Overload | Description
AnnotationsCollection Constructor() | Initializes a new instance of the AnnotationsCollection class.
AnnotationsCollection Constructor(Annotation[]) | Initializes a new instance of the AnnotationsCollection class with the specified array.
See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


AnnotationsCollection Constructor()

AnnotationsCollection Constructor()

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class > AnnotationsCollection Constructor : AnnotationsCollection Constructor()
Initializes a new instance of the AnnotationsCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public AnnotationsCollection()
See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members
Overload List


AnnotationsCollection Constructor(Annotation[])

AnnotationsCollection Constructor(Annotation[])

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class > AnnotationsCollection Constructor : AnnotationsCollection Constructor(Annotation[])

Specifies the array of annotations to use.

Initializes a new instance of the AnnotationsCollection class with the specified array.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal annArray() As Annotation _
)
public AnnotationsCollection(
   Annotation[] annArray
)

Parameters

annArray

Specifies the array of annotations to use.

See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members
Overload List


AnnotationsCollection Class Methods

AnnotationsCollection Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationsCollection Class

For a list of all members of this type, see AnnotationsCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an Annotation to the collection.
Public Method | AddRange | Adds an array of annotations to the collection.
Public Method | Clear | Clears all items from the collection.
Public Method | Clone | Creates a clone of the AnnotationsCollection.
Public Method | Contains | Determines whether the collection contains the specified annotation.
Public Method | CopyTo | Copies the entire collection to an array, starting at the specified index of the target array.
Public Method | Dispose | Releases resources associated with this object.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts an Annotation into the collection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific Annotation from the collection.
Public Method | RemoveAt | Removes the specified annotation from the collection.
Public Method | ToArray | Copies the elements of the AnnotationsCollection to a new array.
Top
See Also

Reference

AnnotationsCollection Class
GrapeCity.ActiveReports.Chart.Annotations Namespace


Add Method (AnnotationsCollection)

Add Method (AnnotationsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : Add Method
The annotation to add.
Adds an Annotation to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As Annotation _
) As System.Integer
public System.int Add(
   Annotation value
)

Parameters

value
The annotation to add.
See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


AddRange Method (AnnotationsCollection)

AddRange Method (AnnotationsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : AddRange Method
The set of annotations to add to the collection.
Adds an array of annotations to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddRange( _
   ByVal value() As Annotation _
)
public void AddRange(
   Annotation[] value
)

Parameters

value
The set of annotations to add to the collection.
See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


Clear Method (AnnotationsCollection)

Clear Method (AnnotationsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : Clear Method
Clears all items from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Sub Clear()
public new void Clear()
See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


Clone Method (AnnotationsCollection)

Clone Method (AnnotationsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : Clone Method
Creates a clone of the AnnotationsCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Clone() As System.Object
public System.object Clone()

Return Value

A clone of the AnnotationsCollection.
See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


Contains Method (AnnotationsCollection)

Contains Method (AnnotationsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : Contains Method
The annotation to check.
Determines whether the collection contains the specified annotation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal value As Annotation _
) As System.Boolean
public System.bool Contains(
   Annotation value
)

Parameters

value
The annotation to check.

Return Value

Boolean. Returns True if the collection contains the parameter given; otherwise False.
See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


CopyTo Method (AnnotationsCollection)

CopyTo Method (AnnotationsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : CopyTo Method
The array to which to copy the collection.
The index from which to start.
Copies the entire collection to an array, starting at the specified index of the target array.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal array() As Annotation, _
   ByVal index As System.Integer _
)
public void CopyTo(
   Annotation[] array,
   System.int index
)

Parameters

array
The array to which to copy the collection.
index
The index from which to start.
See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


Dispose Method (AnnotationsCollection)

Dispose Method (AnnotationsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : Dispose Method
Releases resources associated with this object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


IndexOf Method (AnnotationsCollection)

IndexOf Method (AnnotationsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : IndexOf Method
The object to locate in the collection.
Returns the index of the first occurrence of a value in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As Annotation _
) As System.Integer
public System.int IndexOf(
   Annotation value
)

Parameters

value
The object to locate in the collection.

Return Value

The index of the first occurrence of value within the entire array, if found; otherwise, the lower bound of the array - 1.
See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


Insert Method (AnnotationsCollection)

Insert Method (AnnotationsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : Insert Method
The index at which the Annotation is inserted.
The Annotation to insert.
Inserts an Annotation into the collection at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As Annotation _
)
public void Insert(
   System.int index,
   Annotation value
)

Parameters

index
The index at which the Annotation is inserted.
value
The Annotation to insert.
See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


Remove Method (AnnotationsCollection)

Remove Method (AnnotationsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : Remove Method
The Annotation to remove.
Removes the first occurrence of a specific Annotation from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As Annotation _
)
public void Remove(
   Annotation value
)

Parameters

value
The Annotation to remove.
See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


RemoveAt Method (AnnotationsCollection)

RemoveAt Method (AnnotationsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : RemoveAt Method
The index of the Annotation to remove.
Removes the specified annotation from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Sub RemoveAt( _
   ByVal index As System.Integer _
)
public new void RemoveAt(
   System.int index
)

Parameters

index
The index of the Annotation to remove.
See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


ToArray Method (AnnotationsCollection)

ToArray Method (AnnotationsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : ToArray Method
Copies the elements of the AnnotationsCollection to a new array.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToArray() As Annotation()
public Annotation[] ToArray()
See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


AnnotationsCollection Class Properties

AnnotationsCollection Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationsCollection Class

For a list of all members of this type, see AnnotationsCollection members.

Public Properties
 | Name | Description
Public Property | Item | Overloaded. Gets or sets the collection item by the given index.
Top
See Also

Reference

AnnotationsCollection Class
GrapeCity.ActiveReports.Chart.Annotations Namespace


Item Property (AnnotationsCollection)

Item Property (AnnotationsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : Item Property
Gets or sets the collection item by the given index.
Overload List
Overload | Description
Item(Int32) | Gets or sets the collection item by the specified index.
Item(String) | Gets or sets the collection item by the specified name.
See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


Item(Int32) Property

Item(Int32) Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class > Item Property : Item(Int32) Property
The index of the item.
Gets or sets the collection item by the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Property Item( _
   ByVal index As System.Integer _
) As Annotation
public Annotation Item(
   System.int index
) {get; set;}

Parameters

index
The index of the item.
See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members
Overload List


Item(String) Property

Item(String) Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class > Item Property : Item(String) Property
Name of the annotation.
Gets or sets the collection item by the specified name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal annotationName As System.String _
) As Annotation
public Annotation Item(
   System.string annotationName
) {get;}

Parameters

annotationName
Name of the annotation.
See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members
Overload List


AnnotationsCollection Class Events

AnnotationsCollection Class Events

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationsCollection Class

For a list of all members of this type, see AnnotationsCollection members.

Public Events
 | Name | Description
Public Event | Change | Occurs when the content of the collection changes.
Top
See Also

Reference

AnnotationsCollection Class
GrapeCity.ActiveReports.Chart.Annotations Namespace


Change Event (AnnotationsCollection)

Change Event (AnnotationsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationsCollection Class : Change Event
Occurs when the content of the collection changes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Change As System.EventHandler
public event System.EventHandler Change
See Also

Reference

AnnotationsCollection Class
AnnotationsCollection Members


AnnotationTextBar Class

AnnotationTextBar Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationTextBar Class
Represents the settings for the AnnotationTextBar class.
Object Model
AnnotationTextBar Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class AnnotationTextBar
   Inherits Annotation
public sealed class AnnotationTextBar : Annotation
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Annotations.Annotation
GrapeCity.ActiveReports.Chart.Annotations.AnnotationTextBar

See Also

Reference

AnnotationTextBar Members
GrapeCity.ActiveReports.Chart.Annotations Namespace


AnnotationTextBar Class Members

AnnotationTextBar Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationTextBar Class

The following tables list the members exposed by AnnotationTextBar.

Public Constructors
 | Name | Description
Public Constructor | AnnotationTextBar Constructor | Initializes a new instance of the AnnotationTextBar class.
Top
Public Properties
 | Name | Description
Public Property | AnchorPlacement | Gets or sets the position of the AnchorPoint to stick to the ChartArea surface.
Public Property | AnchorPoint | Gets or sets the anchor point in the coordinate system of the corresponding ChartArea.
Public Property | AnnotationClass | Overridden. Gets the name of the annotation type.
Public Property | Backdrop | Gets or sets the backdrop information used to fill the AnnotationTextBar.
Public Property | Font | Gets or sets the font information used to display text for the AnnotationTextBar.
Public Property | Height | Gets or sets the height of the text bar.
Public Property | Line | Gets or sets the line information used to draw the border for the text bar.
Public Property | Name | Overridden. Gets or sets the name of the AnnotationTextBar as string.
Public Property | RotationAngle | Gets or sets the rotation angle (in degrees) of the text bar around the AnchorPoint.
Public Property | Text | Gets or sets the text string that is displayed in the text bar.
Public Property | Width | Gets or sets the width of the AnnotationTextBar.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the AnnotationTextBar object.
Top
See Also

Reference

AnnotationTextBar Class
GrapeCity.ActiveReports.Chart.Annotations Namespace


AnnotationTextBar Constructor

AnnotationTextBar Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : AnnotationTextBar Constructor
Initializes a new instance of the AnnotationTextBar class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public AnnotationTextBar()
See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


AnnotationTextBar Class Methods

AnnotationTextBar Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationTextBar Class

For a list of all members of this type, see AnnotationTextBar members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the AnnotationTextBar object.
Top
See Also

Reference

AnnotationTextBar Class
GrapeCity.ActiveReports.Chart.Annotations Namespace


Clone Method (AnnotationTextBar)

Clone Method (AnnotationTextBar)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : Clone Method
Creates a clone of the AnnotationTextBar object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

A clone of the AnnotationTextBar object.
See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


AnnotationTextBar Class Properties

AnnotationTextBar Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnnotationTextBar Class

For a list of all members of this type, see AnnotationTextBar members.

Public Properties
 | Name | Description
Public Property | AnchorPlacement | Gets or sets the position of the AnchorPoint to stick to the ChartArea surface.
Public Property | AnchorPoint | Gets or sets the anchor point in the coordinate system of the corresponding ChartArea.
Public Property | AnnotationClass | Overridden. Gets the name of the annotation type.
Public Property | Backdrop | Gets or sets the backdrop information used to fill the AnnotationTextBar.
Public Property | Font | Gets or sets the font information used to display text for the AnnotationTextBar.
Public Property | Height | Gets or sets the height of the text bar.
Public Property | Line | Gets or sets the line information used to draw the border for the text bar.
Public Property | Name | Overridden. Gets or sets the name of the AnnotationTextBar as string.
Public Property | RotationAngle | Gets or sets the rotation angle (in degrees) of the text bar around the AnchorPoint.
Public Property | Text | Gets or sets the text string that is displayed in the text bar.
Public Property | Width | Gets or sets the width of the AnnotationTextBar.
Top
See Also

Reference

AnnotationTextBar Class
GrapeCity.ActiveReports.Chart.Annotations Namespace


AnchorPlacement Property

AnchorPlacement Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : AnchorPlacement Property
Gets or sets the position of the AnchorPoint to stick to the ChartArea surface.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AnchorPlacement As AnchorPlacementType
public AnchorPlacementType AnchorPlacement {get; set;}
See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


AnchorPoint Property

AnchorPoint Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : AnchorPoint Property
Gets or sets the anchor point in the coordinate system of the corresponding ChartArea.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AnchorPoint As Point2d
public Point2d AnchorPoint {get; set;}
See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


AnnotationClass Property (AnnotationTextBar)

AnnotationClass Property (AnnotationTextBar)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : AnnotationClass Property
Gets the name of the annotation type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable ReadOnly Property AnnotationClass As System.String
public override System.string AnnotationClass {get;}
See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


Backdrop Property (AnnotationTextBar)

Backdrop Property (AnnotationTextBar)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : Backdrop Property
Gets or sets the backdrop information used to fill the AnnotationTextBar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Backdrop As Backdrop
public Backdrop Backdrop {get; set;}
See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


Font Property (AnnotationTextBar)

Font Property (AnnotationTextBar)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : Font Property

Gets or sets the font information used to display text for the AnnotationTextBar.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Font As FontInfo
public FontInfo Font {get; set;}
See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


Height Property (AnnotationTextBar)

Height Property (AnnotationTextBar)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : Height Property
Gets or sets the height of the text bar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As System.Single
public System.float Height {get; set;}
See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


Line Property (AnnotationTextBar)

Line Property (AnnotationTextBar)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : Line Property
Gets or sets the line information used to draw the border for the text bar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Line As Line
public Line Line {get; set;}
See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


Name Property (AnnotationTextBar)

Name Property (AnnotationTextBar)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : Name Property
Gets or sets the name of the AnnotationTextBar as string.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Property Name As System.String
public override System.string Name {get; set;}
See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


RotationAngle Property

RotationAngle Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : RotationAngle Property
Gets or sets the rotation angle (in degrees) of the text bar around the AnchorPoint.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RotationAngle As System.Single
public System.float RotationAngle {get; set;}
See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


Text Property (AnnotationTextBar)

Text Property (AnnotationTextBar)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : Text Property
Gets or sets the text string that is displayed in the text bar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Text As System.String
public System.string Text {get; set;}
See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


Width Property (AnnotationTextBar)

Width Property (AnnotationTextBar)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace > AnnotationTextBar Class : Width Property
Gets or sets the width of the AnnotationTextBar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As System.Single
public System.float Width {get; set;}
See Also

Reference

AnnotationTextBar Class
AnnotationTextBar Members


AnchorPlacementType Enumeration

AnchorPlacementType Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Annotations Namespace : AnchorPlacementType Enumeration
Specifies how an annotation bar anchors to the position of an Annotation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum AnchorPlacementType
   Inherits System.Enum
public enum AnchorPlacementType : System.Enum
Members
Member | Description
Bottom | The bar is anchored by its bottom side.
BottomLeft | The bar is anchored by its bottom left corner.
BottomRight | The bar is anchored by its bottom right corner.
Center | The bar is anchored by its center.
Left | The bar is anchored by its left side.
Right | The bar is anchored by its top right side.
Top | The bar is anchored by its top side.
TopLeft | The bar is anchored by its top left corner.
TopRight | The bar is anchored by its top right corner.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.Annotations.AnchorPlacementType

See Also

Reference

GrapeCity.ActiveReports.Chart.Annotations Namespace


GrapeCity.ActiveReports.Chart.Graphics Namespace

GrapeCity.ActiveReports.Chart.Graphics Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Chart.v10 Assembly : GrapeCity.ActiveReports.Chart.Graphics Namespace
The GrapeCity.ActiveReports.Chart.Graphics namespace contains the chart graphics components and settings.
Classes
 | Class | Description
Class | Backdrop | Specifies the settings used to draw the background of the Chart object.
Class | Line | Holds all of the visual attributes of a Line object.
Class | Point2d | Specifies a point in two dimensions.
Class | Point3d | Specifies a point in 3 dimensional geometric space.
Structures
 | Structure | Description
Structure | Bar | Stores the location and size of the Bar area.
Enumerations
 | Enumeration | Description
Enumeration | AntiAliasMode | Specifies the antialiasing settings used to draw the object.
Enumeration | BackdropStyle | Specifies the style used to draw the backdrop of an object.
Enumeration | GradientType | Specifies the type of gradient to draw.
Enumeration | LineStyle | Specifies the line style to use.
Enumeration | PicturePutStyle | Specifies how the image is aligned inside the backdrop.
Enumeration | ProjectionType | Specifies the projection type used.
Enumeration | TextAlign | Specifies how text is aligned within its rectangle.
Enumeration | TextAnchor | Specifies how the text shape anchors to its position.
See Also

Reference

GrapeCity.ActiveReports.Chart.v10 Assembly


Backdrop Class

Backdrop Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Backdrop Class
Specifies the settings used to draw the background of the Chart object.
Object Model
Backdrop Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Backdrop
   Inherits GrapeCity.ActiveReports.Chart.DrawCustomizableItem
public class Backdrop : GrapeCity.ActiveReports.Chart.DrawCustomizableItem
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Graphics.Backdrop
GrapeCity.ActiveReports.Chart.BackdropItem

See Also

Reference

Backdrop Members
GrapeCity.ActiveReports.Chart.Graphics Namespace


Backdrop Class Members

Backdrop Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Backdrop Class

The following tables list the members exposed by Backdrop.

Public Constructors
 | Name | Description
Public Constructor | Backdrop Constructor | Overloaded. Initializes a new instance of the Backdrop class.
Top
Public Properties
 | Name | Description
Public Property | Alpha | Gets or sets the alpha level (transparency).
Public Property | Color | Gets or sets the primary color used to fill the backdrop.
Public Property | Color2 | Gets or sets the secondary color used for gradient effects and patterns.
Public Property | Gradient | Gets or sets the enumerated GradientType used for the Backdrop.
Public Property | Pattern | Gets or sets the HatchStyle used for the Backdrop pattern.
Public Property | Picture | Gets or sets the image used for the Backdrop.
Public Property | PictureAlignment | Gets or sets the image alignment for the Backdrop.
Public Property | Style | Gets or sets the type of backdrop to use (i.e. solid, gradient, etc.).
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Backdrop.
Public Method | CopyFrom | Initializes the specified Backdrop object with settings.
Public Method | Dispose | Releases the Backdrop instance from memory.
Public Method | Equals | Compares the Backdrop object to another System.Object to see whether they are equal.
Public Method | FitToRectangle | Overloaded. Sets the bounding rectangle of the Backdrop.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | Serialize | Creates XML encoding for the Backdrop object or reconstructs the object state from XML encoding.
Top
See Also

Reference

Backdrop Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Backdrop Constructor

Backdrop Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : Backdrop Constructor
Initializes a new instance of the Backdrop class.
Overload List
Overload | Description
Backdrop Constructor() | Initializes a new instance of the Backdrop class.
Backdrop Constructor(AntiAliasMode) | Initializes a new instance of the Backdrop class with the AntiAliasMode value specified.
Backdrop Constructor(Color) | Initializes a new instance of the Backdrop class with the specified color.
Backdrop Constructor(Color,AntiAliasMode) | Initializes a new instance of the Backdrop class with the specified parameters.
Backdrop Constructor(Color,Byte) | Initializes a new instance of the Backdrop class with the specified parameters.
Backdrop Constructor(Color,Byte,AntiAliasMode) | Initializes a new instance of the Backdrop class with the specified parameters.
Backdrop Constructor(GradientType,Color,Color) | Initializes a new instance of the Backdrop class with the specified parameters.
Backdrop Constructor(GradientType,Color,Color,AntiAliasMode) | Initializes a new instance of the Backdrop class with the specified parameters.
Backdrop Constructor(HatchStyle,Color,Color) | Initializes a new instance of the Backdrop class with the specified parameters.
Backdrop Constructor(HatchStyle,Color,Color,AntiAliasMode) | Initializes a new instance of the Backdrop class with the specified parameters.
Backdrop Constructor(Image,PicturePutStyle) | Initializes a new instance of the Backdrop class with the specified parameters.
Backdrop Constructor(Image,PicturePutStyle,AntiAliasMode) | Initializes a new instance of the Backdrop class with the specified parameters.
Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle) | Initializes a new instance of the Backdrop class with the specified parameters.
Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,AntiAliasMode) | Initializes a new instance of the Backdrop class with the specified parameters.
Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte) | Initializes a new instance of the Backdrop class with the specified parameters.
Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte,AntiAliasMode) | Initializes a new instance of the Backdrop class with the specified parameters.
See Also

Reference

Backdrop Class
Backdrop Members


Backdrop Constructor()

Backdrop Constructor()

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor()
Initializes a new instance of the Backdrop class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Backdrop()
See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(AntiAliasMode)

Backdrop Constructor(AntiAliasMode)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(AntiAliasMode)
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.
Initializes a new instance of the Backdrop class with the AntiAliasMode value specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal antiAliasMode As AntiAliasMode _
)
public Backdrop(
   AntiAliasMode antiAliasMode
)

Parameters

antiAliasMode
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.
See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(Color)

Backdrop Constructor(Color)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(Color)
Specifies the primary color.
Initializes a new instance of the Backdrop class with the specified color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal color As Color _
)
public Backdrop(
   Color color
)

Parameters

color
Specifies the primary color.
See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(Color,AntiAliasMode)

Backdrop Constructor(Color,AntiAliasMode)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(Color,AntiAliasMode)
Specifies the primary color.
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.
Initializes a new instance of the Backdrop class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal color As Color, _
   ByVal antiAliasMode As AntiAliasMode _
)
public Backdrop(
   Color color,
   AntiAliasMode antiAliasMode
)

Parameters

color
Specifies the primary color.
antiAliasMode
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.
See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(Color,Byte)

Backdrop Constructor(Color,Byte)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(Color,Byte)
Specifies the primary color.
Specifies the alpha level (transparency) used.
Initializes a new instance of the Backdrop class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal color As Color, _
   ByVal alpha As System.Byte _
)
public Backdrop(
   Color color,
   System.byte alpha
)

Parameters

color
Specifies the primary color.
alpha
Specifies the alpha level (transparency) used.
See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(Color,Byte,AntiAliasMode)

Backdrop Constructor(Color,Byte,AntiAliasMode)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(Color,Byte,AntiAliasMode)
Specifies the primary color.
Specifies the alpha level (transparency) used.
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.
Initializes a new instance of the Backdrop class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal color As Color, _
   ByVal alpha As System.Byte, _
   ByVal antiAliasMode As AntiAliasMode _
)
public Backdrop(
   Color color,
   System.byte alpha,
   AntiAliasMode antiAliasMode
)

Parameters

color
Specifies the primary color.
alpha
Specifies the alpha level (transparency) used.
antiAliasMode
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.
See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(GradientType,Color,Color)

Backdrop Constructor(GradientType,Color,Color)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(GradientType,Color,Color)
Specifies the enumerated GradientType.
Specifies the primary color.
Specifies the secondary color (used with hatch and gradient styles).
Initializes a new instance of the Backdrop class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal gradient As GradientType, _
   ByVal color As Color, _
   ByVal color2 As Color _
)
public Backdrop(
   GradientType gradient,
   Color color,
   Color color2
)

Parameters

gradient
Specifies the enumerated GradientType.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(GradientType,Color,Color,AntiAliasMode)

Backdrop Constructor(GradientType,Color,Color,AntiAliasMode)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(GradientType,Color,Color,AntiAliasMode)
Specifies the enumerated GradientType.
Specifies the primary color.
Specifies the secondary color (used with hatch and gradient styles).
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.
Initializes a new instance of the Backdrop class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal gradient As GradientType, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal antiAliasMode As AntiAliasMode _
)
public Backdrop(
   GradientType gradient,
   Color color,
   Color color2,
   AntiAliasMode antiAliasMode
)

Parameters

gradient
Specifies the enumerated GradientType.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
antiAliasMode
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.
See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(HatchStyle,Color,Color)

Backdrop Constructor(HatchStyle,Color,Color)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(HatchStyle,Color,Color)
Specifies the enumerated HatchStyle.
Specifies the primary color.
Specifies the secondary color (used with hatch and gradient styles).
Initializes a new instance of the Backdrop class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal pattern As System.Drawing.Drawing2D.HatchStyle, _
   ByVal color As Color, _
   ByVal color2 As Color _
)
public Backdrop(
   System.Drawing.Drawing2D.HatchStyle pattern,
   Color color,
   Color color2
)

Parameters

pattern
Specifies the enumerated HatchStyle.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(HatchStyle,Color,Color,AntiAliasMode)

Backdrop Constructor(HatchStyle,Color,Color,AntiAliasMode)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(HatchStyle,Color,Color,AntiAliasMode)
Specifies the enumerated HatchStyle.
Specifies the primary color.
Specifies the secondary color (used with hatch and gradient styles).
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.
Initializes a new instance of the Backdrop class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal pattern As System.Drawing.Drawing2D.HatchStyle, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal antiAliasMode As AntiAliasMode _
)
public Backdrop(
   System.Drawing.Drawing2D.HatchStyle pattern,
   Color color,
   Color color2,
   AntiAliasMode antiAliasMode
)

Parameters

pattern
Specifies the enumerated HatchStyle.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
antiAliasMode
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.
See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(Image,PicturePutStyle)

Backdrop Constructor(Image,PicturePutStyle)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(Image,PicturePutStyle)
Specifies the image used for the backdrop.
Specifies the image alignment used.
Initializes a new instance of the Backdrop class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle _
)
public Backdrop(
   Image picture,
   PicturePutStyle pictureAlignment
)

Parameters

picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(Image,PicturePutStyle,AntiAliasMode)

Backdrop Constructor(Image,PicturePutStyle,AntiAliasMode)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(Image,PicturePutStyle,AntiAliasMode)
Specifies the image used for the backdrop.
Specifies the image alignment used.
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.
Initializes a new instance of the Backdrop class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle, _
   ByVal antiAliasMode As AntiAliasMode _
)
public Backdrop(
   Image picture,
   PicturePutStyle pictureAlignment,
   AntiAliasMode antiAliasMode
)

Parameters

picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
antiAliasMode
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.
See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle)

Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle)
Specifies the backdrop style.
Specifies the primary color.
Specifies the secondary color (used with hatch and gradient styles).
Specifies the enumerated GradientType.
Specifies the enumerated HatchStyle.
Specifies the image used for the backdrop.
Specifies the image alignment used.
Initializes a new instance of the Backdrop class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal style As BackdropStyle, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal gradient As GradientType, _
   ByVal pattern As System.Drawing.Drawing2D.HatchStyle, _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle _
)
public Backdrop(
   BackdropStyle style,
   Color color,
   Color color2,
   GradientType gradient,
   System.Drawing.Drawing2D.HatchStyle pattern,
   Image picture,
   PicturePutStyle pictureAlignment
)

Parameters

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the enumerated GradientType.
pattern
Specifies the enumerated HatchStyle.
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,AntiAliasMode)

Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,AntiAliasMode)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,AntiAliasMode)
Specifies the backdrop style.
Specifies the primary color.
Specifies the secondary color (used with hatch and gradient styles).
Specifies the enumerated GradientType.
Specifies the enumerated HatchStyle.
Specifies the image used for the backdrop.
Specifies the image alignment used.
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.
Initializes a new instance of the Backdrop class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal style As BackdropStyle, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal gradient As GradientType, _
   ByVal pattern As System.Drawing.Drawing2D.HatchStyle, _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle, _
   ByVal antiAliasMode As AntiAliasMode _
)
public Backdrop(
   BackdropStyle style,
   Color color,
   Color color2,
   GradientType gradient,
   System.Drawing.Drawing2D.HatchStyle pattern,
   Image picture,
   PicturePutStyle pictureAlignment,
   AntiAliasMode antiAliasMode
)

Parameters

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the enumerated GradientType.
pattern
Specifies the enumerated HatchStyle.
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
antiAliasMode
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.
See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte)

Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte)
Specifies the backdrop style.
Specifies the primary color.
Specifies the secondary color (used with hatch and gradient styles).
Specifies the enumerated GradientType.
Specifies the enumerated HatchStyle.
Specifies the image used for the backdrop.
Specifies the image alignment used.
Specifies the alpha level (transparency) used.
Initializes a new instance of the Backdrop class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal style As BackdropStyle, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal gradient As GradientType, _
   ByVal pattern As System.Drawing.Drawing2D.HatchStyle, _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle, _
   ByVal alpha As System.Byte _
)
public Backdrop(
   BackdropStyle style,
   Color color,
   Color color2,
   GradientType gradient,
   System.Drawing.Drawing2D.HatchStyle pattern,
   Image picture,
   PicturePutStyle pictureAlignment,
   System.byte alpha
)

Parameters

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the enumerated GradientType.
pattern
Specifies the enumerated HatchStyle.
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used.
alpha
Specifies the alpha level (transparency) used.
See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte,AntiAliasMode)

Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte,AntiAliasMode)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > Backdrop Constructor : Backdrop Constructor(BackdropStyle,Color,Color,GradientType,HatchStyle,Image,PicturePutStyle,Byte,AntiAliasMode)
Specifies the backdrop style.
Specifies the primary color.
Specifies the secondary color (used with hatch and gradient styles).
Specifies the enumerated GradientType.
Specifies the enumerated HatchStyle.
Specifies the image used for the backdrop.
Specifies the image alignment used with image style.
Specifies the alpha level (transparency) used.
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.
Initializes a new instance of the Backdrop class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal style As BackdropStyle, _
   ByVal color As Color, _
   ByVal color2 As Color, _
   ByVal gradient As GradientType, _
   ByVal pattern As System.Drawing.Drawing2D.HatchStyle, _
   ByVal picture As Image, _
   ByVal pictureAlignment As PicturePutStyle, _
   ByVal alpha As System.Byte, _
   ByVal antiAliasMode As AntiAliasMode _
)
public Backdrop(
   BackdropStyle style,
   Color color,
   Color color2,
   GradientType gradient,
   System.Drawing.Drawing2D.HatchStyle pattern,
   Image picture,
   PicturePutStyle pictureAlignment,
   System.byte alpha,
   AntiAliasMode antiAliasMode
)

Parameters

style
Specifies the backdrop style.
color
Specifies the primary color.
color2
Specifies the secondary color (used with hatch and gradient styles).
gradient
Specifies the enumerated GradientType.
pattern
Specifies the enumerated HatchStyle.
picture
Specifies the image used for the backdrop.
pictureAlignment
Specifies the image alignment used with image style.
alpha
Specifies the alpha level (transparency) used.
antiAliasMode
Specifies the enumerated AntiAliasMode to use. Possible values are Auto, None, Graphics, Text, or Both.
See Also

Reference

Backdrop Class
Backdrop Members
Overload List


Backdrop Class Methods

Backdrop Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Backdrop Class

For a list of all members of this type, see Backdrop members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Backdrop.
Public Method | CopyFrom | Initializes the specified Backdrop object with settings.
Public Method | Dispose | Releases the Backdrop instance from memory.
Public Method | Equals | Compares the Backdrop object to another System.Object to see whether they are equal.
Public Method | FitToRectangle | Overloaded. Sets the bounding rectangle of the Backdrop.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | Serialize | Creates XML encoding for the Backdrop object or reconstructs the object state from XML encoding.
Top
See Also

Reference

Backdrop Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Clone Method (Backdrop)

Clone Method (Backdrop)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : Clone Method
Creates a clone of the Backdrop.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Clone() As System.Object
public override System.object Clone()

Return Value

A clone of the Backdrop.
See Also

Reference

Backdrop Class
Backdrop Members


CopyFrom Method

CopyFrom Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : CopyFrom Method
The Backdrop object from which to copy settings.
Initializes the specified Backdrop object with settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyFrom( _
   ByVal backdrop As Backdrop _
)
public void CopyFrom(
   Backdrop backdrop
)

Parameters

backdrop
The Backdrop object from which to copy settings.
See Also

Reference

Backdrop Class
Backdrop Members


Dispose Method (Backdrop)

Dispose Method (Backdrop)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : Dispose Method
Releases the Backdrop instance from memory.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Backdrop Class
Backdrop Members


Equals Method (Backdrop)

Equals Method (Backdrop)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : Equals Method
The System.Object to which the Backdrop object is being compared.
Compares the Backdrop object to another System.Object to see whether they are equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The System.Object to which the Backdrop object is being compared.

Return Value

Boolean. Returns True if the objects are equal; otherwise False.
See Also

Reference

Backdrop Class
Backdrop Members


FitToRectangle Method

FitToRectangle Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : FitToRectangle Method
Sets the bounding rectangle of the Backdrop.
Overload List
Overload | Description
FitToRectangle(RectangleF) | Sets the bounding rectangle of the Backdrop.
FitToRectangle(PointF[]) | Sets the bounding rectangle of the Backdrop.
See Also

Reference

Backdrop Class
Backdrop Members


FitToRectangle(RectangleF) Method

FitToRectangle(RectangleF) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > FitToRectangle Method : FitToRectangle(RectangleF) Method
A rectangle to fit.
Sets the bounding rectangle of the Backdrop.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub FitToRectangle( _
   ByVal rectangle As RectangleF _
)
public void FitToRectangle(
   RectangleF rectangle
)

Parameters

rectangle
A rectangle to fit.
See Also

Reference

Backdrop Class
Backdrop Members
Overload List


FitToRectangle(PointF[]) Method

FitToRectangle(PointF[]) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class > FitToRectangle Method : FitToRectangle(PointF[]) Method

The array contains the top left, top right, bottom right and bottom left points of the rectangle.

Sets the bounding rectangle of the Backdrop.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub FitToRectangle( _
   ByVal points() As PointF _
)
public void FitToRectangle(
   PointF[] points
)

Parameters

points

The array contains the top left, top right, bottom right and bottom left points of the rectangle.

See Also

Reference

Backdrop Class
Backdrop Members
Overload List


GetHashCode Method (Backdrop)

GetHashCode Method (Backdrop)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : GetHashCode Method
Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

Backdrop Class
Backdrop Members


Serialize Method

Serialize Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : Serialize Method
Specifies the data needed to serialize or deserialize the Backdrop object.
Specifies whether to reconstruct the object (True) or create XML encoding (False).
Creates XML encoding for the Backdrop object or reconstructs the object state from XML encoding.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Serialize( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal isLoading As System.Boolean _
)
public void Serialize(
   System.Runtime.Serialization.SerializationInfo info,
   System.bool isLoading
)

Parameters

info
Specifies the data needed to serialize or deserialize the Backdrop object.
isLoading
Specifies whether to reconstruct the object (True) or create XML encoding (False).
See Also

Reference

Backdrop Class
Backdrop Members


Backdrop Class Properties

Backdrop Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Backdrop Class

For a list of all members of this type, see Backdrop members.

Public Properties
 | Name | Description
Public Property | Alpha | Gets or sets the alpha level (transparency).
Public Property | Color | Gets or sets the primary color used to fill the backdrop.
Public Property | Color2 | Gets or sets the secondary color used for gradient effects and patterns.
Public Property | Gradient | Gets or sets the enumerated GradientType used for the Backdrop.
Public Property | Pattern | Gets or sets the HatchStyle used for the Backdrop pattern.
Public Property | Picture | Gets or sets the image used for the Backdrop.
Public Property | PictureAlignment | Gets or sets the image alignment for the Backdrop.
Public Property | Style | Gets or sets the type of backdrop to use (i.e. solid, gradient, etc.).
Top
See Also

Reference

Backdrop Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Alpha Property (Backdrop)

Alpha Property (Backdrop)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : Alpha Property
Gets or sets the alpha level (transparency).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Alpha As System.Byte
public System.byte Alpha {get; set;}
See Also

Reference

Backdrop Class
Backdrop Members


Color Property (Backdrop)

Color Property (Backdrop)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : Color Property
Gets or sets the primary color used to fill the backdrop.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Color As Color
public Color Color {get; set;}

Property Value

System.Drawing.Color.
See Also

Reference

Backdrop Class
Backdrop Members


Color2 Property

Color2 Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : Color2 Property
Gets or sets the secondary color used for gradient effects and patterns.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Color2 As Color
public Color Color2 {get; set;}

Property Value

System.Drawing.Color.
See Also

Reference

Backdrop Class
Backdrop Members


Gradient Property

Gradient Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : Gradient Property
Gets or sets the enumerated GradientType used for the Backdrop.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Gradient As GradientType
public GradientType Gradient {get; set;}
See Also

Reference

Backdrop Class
Backdrop Members
GradientType Enumeration


Pattern Property

Pattern Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : Pattern Property

Gets or sets the HatchStyle used for the Backdrop pattern.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Pattern As System.Drawing.Drawing2D.HatchStyle
public System.Drawing.Drawing2D.HatchStyle Pattern {get; set;}
See Also

Reference

Backdrop Class
Backdrop Members


Picture Property

Picture Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : Picture Property
Gets or sets the image used for the Backdrop.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Picture As Image
public Image Picture {get; set;}

Property Value

System.Drawing.Image.
See Also

Reference

Backdrop Class
Backdrop Members


PictureAlignment Property (Backdrop)

PictureAlignment Property (Backdrop)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : PictureAlignment Property
Gets or sets the image alignment for the Backdrop.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PictureAlignment As PicturePutStyle
public PicturePutStyle PictureAlignment {get; set;}

Property Value

A valid PicturePutStyle enumeration.
See Also

Reference

Backdrop Class
Backdrop Members
PicturePutStyle Enumeration


Style Property (Backdrop)

Style Property (Backdrop)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Backdrop Class : Style Property

Gets or sets the type of backdrop to use (i.e. solid, gradient, etc.).

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As BackdropStyle
public BackdropStyle Style {get; set;}

Property Value

A valid BackdropStyle enumeration.

See Also

Reference

Backdrop Class
Backdrop Members
BackdropStyle Enumeration


Line Class

Line Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Line Class
Holds all of the visual attributes of a Line object.
Object Model
Line Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Line
   Inherits GrapeCity.ActiveReports.Chart.Item
public sealed class Line : GrapeCity.ActiveReports.Chart.Item
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Graphics.Line

See Also

Reference

Line Members
GrapeCity.ActiveReports.Chart.Graphics Namespace


Line Class Members

Line Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Line Class

The following tables list the members exposed by Line.

Public Constructors
 | Name | Description
Public Constructor | Line Constructor | Overloaded. Initializes a new instance of the Line class.
Top
Public Properties
 | Name | Description
Public Property | Color | Gets or sets the color of the line.
Public Property | Style | Gets or sets the style used to draw the line.
Public Property | Weight | Gets or sets the line thickness in points.
Top
Public Methods
 | Name | Description
Public Method | Equals | Compares the Line object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | GetObjectData | Populates a SerializationInfo object with the data needed to serialize the target object.
Top
See Also

Reference

Line Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Line Constructor

Line Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line Class : Line Constructor
Initializes a new instance of the Line class.
Overload List
Overload | Description
Line Constructor() | Initializes a new instance of the Line class.
Line Constructor(Color) | Initializes a new instance of the Line class with a solid, 1 pt line, and the color specified.
Line Constructor(Color,Int32) | Initializes a new instance of the Line class with a solid line of the weight and color specified.
Line Constructor(Color,LineStyle) | Initializes a new instance of the Line class with a 1 pt line of the color and style specified.
Line Constructor(Color,Int32,LineStyle) | Initializes a new instance of the Line class with the color, weight, and style specified.
See Also

Reference

Line Class
Line Members


Line Constructor()

Line Constructor()

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line Class > Line Constructor : Line Constructor()
Initializes a new instance of the Line class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Line()
See Also

Reference

Line Class
Line Members
Overload List


Line Constructor(Color)

Line Constructor(Color)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line Class > Line Constructor : Line Constructor(Color)
Specifies the line color.
Initializes a new instance of the Line class with a solid, 1 pt line, and the color specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal color As Color _
)
public Line(
   Color color
)

Parameters

color
Specifies the line color.
See Also

Reference

Line Class
Line Members
Overload List


Line Constructor(Color,Int32)

Line Constructor(Color,Int32)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line Class > Line Constructor : Line Constructor(Color,Int32)
Specifies the line color.
Specifies the line weight.

Initializes a new instance of the Line class with a solid line of the weight and color specified.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal color As Color, _
   ByVal weight As System.Integer _
)
public Line(
   Color color,
   System.int weight
)

Parameters

color
Specifies the line color.
weight
Specifies the line weight.
See Also

Reference

Line Class
Line Members
Overload List


Line Constructor(Color,LineStyle)

Line Constructor(Color,LineStyle)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line Class > Line Constructor : Line Constructor(Color,LineStyle)
Specifies the line color.
Specifies the LineStyle.
Initializes a new instance of the Line class with a 1 pt line of the color and style specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal color As Color, _
   ByVal style As LineStyle _
)
public Line(
   Color color,
   LineStyle style
)

Parameters

color
Specifies the line color.
style
Specifies the LineStyle.
See Also

Reference

Line Class
Line Members
Overload List


Line Constructor(Color,Int32,LineStyle)

Line Constructor(Color,Int32,LineStyle)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line Class > Line Constructor : Line Constructor(Color,Int32,LineStyle)
Specifies the line color.
Specifies the line weight.
Specifies the LineStyle.
Initializes a new instance of the Line class with the color, weight, and style specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal color As Color, _
   ByVal weight As System.Integer, _
   ByVal style As LineStyle _
)
public Line(
   Color color,
   System.int weight,
   LineStyle style
)

Parameters

color
Specifies the line color.
weight
Specifies the line weight.
style
Specifies the LineStyle.
See Also

Reference

Line Class
Line Members
Overload List


Line Class Methods

Line Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Line Class

For a list of all members of this type, see Line members.

Public Methods
 | Name | Description
Public Method | Equals | Compares the Line object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | GetObjectData | Populates a SerializationInfo object with the data needed to serialize the target object.
Top
See Also

Reference

Line Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Equals Method (Line)

Equals Method (Line)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line Class : Equals Method
The System.Object to which the Line object is being compared.
Compares the Line object to another System.Object to see whether they are equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The System.Object to which the Line object is being compared.

Return Value

Boolean. Returns True if they are equal; otherwise False.
See Also

Reference

Line Class
Line Members


GetHashCode Method (Line)

GetHashCode Method (Line)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line Class : GetHashCode Method
Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()
See Also

Reference

Line Class
Line Members


GetObjectData Method (Line)

GetObjectData Method (Line)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line Class : GetObjectData Method
The SerializationInfo to populate with data.
The destination for the serialization.
Populates a SerializationInfo object with the data needed to serialize the target object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
The SerializationInfo to populate with data.
context
The destination for the serialization.
See Also

Reference

Line Class
Line Members


Line Class Properties

Line Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Line Class

For a list of all members of this type, see Line members.

Public Properties
 | Name | Description
Public Property | Color | Gets or sets the color of the line.
Public Property | Style | Gets or sets the style used to draw the line.
Public Property | Weight | Gets or sets the line thickness in points.
Top
See Also

Reference

Line Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Color Property (Line)

Color Property (Line)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line Class : Color Property
Gets or sets the color of the line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Color As Color
public Color Color {get; set;}

Property Value

System.Drawing.Color.
See Also

Reference

Line Class
Line Members


Style Property (Line)

Style Property (Line)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line Class : Style Property
Gets or sets the style used to draw the line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As LineStyle
public LineStyle Style {get; set;}

Property Value

A valid LineStyle enumeration.
See Also

Reference

Line Class
Line Members
LineStyle Enumeration


Weight Property (Line)

Weight Property (Line)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Line Class : Weight Property
Gets or sets the line thickness in points.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Weight As System.Integer
public System.int Weight {get; set;}
See Also

Reference

Line Class
Line Members


Point2d Class

Point2d Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Point2d Class
Specifies a point in two dimensions.
Object Model
Point2d Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Point2d
   Inherits GrapeCity.ActiveReports.Chart.Item
public sealed class Point2d : GrapeCity.ActiveReports.Chart.Item
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Graphics.Point2d

See Also

Reference

Point2d Members
GrapeCity.ActiveReports.Chart.Graphics Namespace


Point2d Class Members

Point2d Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Point2d Class

The following tables list the members exposed by Point2d.

Public Constructors
 | Name | Description
Public Constructor | Point2d Constructor | Overloaded. Initializes a new instance of the Point2d class.
Top
Public Properties
 | Name | Description
Public Property | Length | Gets the vector length of the Point2d object.
Public Property | X | Gets or sets the point's x coordinate
Public Property | Y | Gets or sets the point's y coordinate
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Point2d object.
Public Method | Equals | Compares the Point2d object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | ToString | Converts the value of the current instance to its string representation.
Top
See Also

Reference

Point2d Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Point2d Constructor

Point2d Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point2d Class : Point2d Constructor
Initializes a new instance of the Point2d class.
Overload List
Overload | Description
Point2d Constructor() | Initializes a new instance of the Point2d class.
Point2d Constructor(Single,Single) | Initializes a new instance of the Point2d class.
Point2d Constructor(PointF) | Initializes a new instance of the Point2d class.
See Also

Reference

Point2d Class
Point2d Members


Point2d Constructor()

Point2d Constructor()

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point2d Class > Point2d Constructor : Point2d Constructor()
Initializes a new instance of the Point2d class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Point2d()
See Also

Reference

Point2d Class
Point2d Members
Overload List


Point2d Constructor(Single,Single)

Point2d Constructor(Single,Single)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point2d Class > Point2d Constructor : Point2d Constructor(Single,Single)
The x coordinate of a point in a two-dimensional plane.
The y coordinate of a point in a two-dimensional plane.
Initializes a new instance of the Point2d class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal x As System.Single, _
   ByVal y As System.Single _
)
public Point2d(
   System.float x,
   System.float y
)

Parameters

x
The x coordinate of a point in a two-dimensional plane.
y
The y coordinate of a point in a two-dimensional plane.
See Also

Reference

Point2d Class
Point2d Members
Overload List


Point2d Constructor(PointF)

Point2d Constructor(PointF)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point2d Class > Point2d Constructor : Point2d Constructor(PointF)
An ordered pair of floating point x and y coordinates that defines a point in a two-dimensional plane.
Initializes a new instance of the Point2d class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal p As PointF _
)
public Point2d(
   PointF p
)

Parameters

p
An ordered pair of floating point x and y coordinates that defines a point in a two-dimensional plane.
See Also

Reference

Point2d Class
Point2d Members
Overload List


Point2d Class Methods

Point2d Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Point2d Class

For a list of all members of this type, see Point2d members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Point2d object.
Public Method | Equals | Compares the Point2d object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | ToString | Converts the value of the current instance to its string representation.
Top
See Also

Reference

Point2d Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Clone Method (Point2d)

Clone Method (Point2d)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point2d Class : Clone Method
Creates a clone of the Point2d object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

A clone of the Point2d object.
See Also

Reference

Point2d Class
Point2d Members


Equals Method (Point2d)

Equals Method (Point2d)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point2d Class : Equals Method
The System.Object to which the Point2d object is being compared.
Compares the Point2d object to another System.Object to see whether they are equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The System.Object to which the Point2d object is being compared.
See Also

Reference

Point2d Class
Point2d Members


GetHashCode Method (Point2d)

GetHashCode Method (Point2d)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point2d Class : GetHashCode Method
Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()
See Also

Reference

Point2d Class
Point2d Members


ToString Method (Point2d)

ToString Method (Point2d)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point2d Class : ToString Method
Converts the value of the current instance to its string representation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()
See Also

Reference

Point2d Class
Point2d Members


Point2d Class Properties

Point2d Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Point2d Class

For a list of all members of this type, see Point2d members.

Public Properties
 | Name | Description
Public Property | Length | Gets the vector length of the Point2d object.
Public Property | X | Gets or sets the point's x coordinate
Public Property | Y | Gets or sets the point's y coordinate
Top
See Also

Reference

Point2d Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Length Property (Point2d)

Length Property (Point2d)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point2d Class : Length Property
Gets the vector length of the Point2d object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Length As System.Single
public System.float Length {get;}
See Also

Reference

Point2d Class
Point2d Members


X Property (Point2d)

X Property (Point2d)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point2d Class : X Property
Gets or sets the point's x coordinate
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property X As System.Single
public System.float X {get; set;}
See Also

Reference

Point2d Class
Point2d Members


Y Property (Point2d)

Y Property (Point2d)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point2d Class : Y Property
Gets or sets the point's y coordinate
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Y As System.Single
public System.float Y {get; set;}
See Also

Reference

Point2d Class
Point2d Members


Point3d Class

Point3d Class
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Point3d Class
Specifies a point in 3 dimensional geometric space.
Object Model
Point3d Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Point3d
   Inherits GrapeCity.ActiveReports.Chart.Item
public sealed class Point3d : GrapeCity.ActiveReports.Chart.Item
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Chart.Graphics.Point3d

See Also

Reference

Point3d Members
GrapeCity.ActiveReports.Chart.Graphics Namespace


Point3d Class Members

Point3d Class Members
Properties Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Point3d Class

The following tables list the members exposed by Point3d.

Public Constructors
 | Name | Description
Public Constructor | Point3d Constructor | Overloaded. Initializes a new instance of the Point3d class.
Top
Public Properties
 | Name | Description
Public Property | X | Gets or sets the point's x coordinate
Public Property | Y | Gets or sets the point's y coordinate
Public Property | Z | Gets or sets the point's z coordinate
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Point3d object.
Public Method | Equals | Compares the Point3d object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | ToString | Converts the value of the current instance to its string representation.
Top
See Also

Reference

Point3d Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Point3d Constructor

Point3d Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point3d Class : Point3d Constructor
Initializes a new instance of the Point3d class.
Overload List
Overload | Description
Point3d Constructor() | Initializes a new instance of the Point3d class.
Point3d Constructor(Single,Single,Single) | Initializes a new instance of the Point3d class.
See Also

Reference

Point3d Class
Point3d Members


Point3d Constructor()

Point3d Constructor()

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point3d Class > Point3d Constructor : Point3d Constructor()
Initializes a new instance of the Point3d class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Point3d()
See Also

Reference

Point3d Class
Point3d Members
Overload List


Point3d Constructor(Single,Single,Single)

Point3d Constructor(Single,Single,Single)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point3d Class > Point3d Constructor : Point3d Constructor(Single,Single,Single)
The x coordinate of a point in a three-dimensional plane.
The y coordinate of a point in a three-dimensional plane.
The z coordinate of a point in a three-dimensional plane.
Initializes a new instance of the Point3d class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal x As System.Single, _
   ByVal y As System.Single, _
   ByVal z As System.Single _
)
public Point3d(
   System.float x,
   System.float y,
   System.float z
)

Parameters

x
The x coordinate of a point in a three-dimensional plane.
y
The y coordinate of a point in a three-dimensional plane.
z
The z coordinate of a point in a three-dimensional plane.
See Also

Reference

Point3d Class
Point3d Members
Overload List


Point3d Class Methods

Point3d Class Methods

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Point3d Class

For a list of all members of this type, see Point3d members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a clone of the Point3d object.
Public Method | Equals | Compares the Point3d object to another System.Object to see whether they are equal.
Public Method | GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
Public Method | ToString | Converts the value of the current instance to its string representation.
Top
See Also

Reference

Point3d Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


Clone Method (Point3d)

Clone Method (Point3d)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point3d Class : Clone Method
Creates a clone of the Point3d object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

A clone of the Point3d object.
See Also

Reference

Point3d Class
Point3d Members


Equals Method (Point3d)

Equals Method (Point3d)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point3d Class : Equals Method
The System.Object to which the Point3d object is being compared.
Compares the Point3d object to another System.Object to see whether they are equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The System.Object to which the Point3d object is being compared.
See Also

Reference

Point3d Class
Point3d Members


GetHashCode Method (Point3d)

GetHashCode Method (Point3d)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point3d Class : GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()
See Also

Reference

Point3d Class
Point3d Members


ToString Method (Point3d)

ToString Method (Point3d)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point3d Class : ToString Method
Converts the value of the current instance to its string representation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()
See Also

Reference

Point3d Class
Point3d Members


Point3d Class Properties

Point3d Class Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Point3d Class

For a list of all members of this type, see Point3d members.

Public Properties
 | Name | Description
Public Property | X | Gets or sets the point's x coordinate
Public Property | Y | Gets or sets the point's y coordinate
Public Property | Z | Gets or sets the point's z coordinate
Top
See Also

Reference

Point3d Class
GrapeCity.ActiveReports.Chart.Graphics Namespace


X Property (Point3d)

X Property (Point3d)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point3d Class : X Property
Gets or sets the point's x coordinate
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property X As System.Single
public System.float X {get; set;}
See Also

Reference

Point3d Class
Point3d Members


Y Property (Point3d)

Y Property (Point3d)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point3d Class : Y Property
Gets or sets the point's y coordinate
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Y As System.Single
public System.float Y {get; set;}
See Also

Reference

Point3d Class
Point3d Members


Z Property (Point3d)

Z Property (Point3d)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Point3d Class : Z Property
Gets or sets the point's z coordinate
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Z As System.Single
public System.float Z {get; set;}
See Also

Reference

Point3d Class
Point3d Members


AntiAliasMode Enumeration

AntiAliasMode Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : AntiAliasMode Enumeration
Specifies the antialiasing settings used to draw the object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum AntiAliasMode
   Inherits System.Enum
public enum AntiAliasMode : System.Enum
Members
Member | Description
Auto | The antialiasing settings of the parent object are used.
Both | Both graphics and text are antialiased.
Graphics | Only graphics are antialiased.
None | No antialiasing settings are used.
Text | Only text is antialiased.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.Graphics.AntiAliasMode

See Also

Reference

GrapeCity.ActiveReports.Chart.Graphics Namespace


BackdropStyle Enumeration

BackdropStyle Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : BackdropStyle Enumeration
Specifies the style used to draw the backdrop of an object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum BackdropStyle
   Inherits System.Enum
public enum BackdropStyle : System.Enum
Members
Member | Description
Gradient | A gradient fill is used for the backdrop.
Pattern | A pattern fill is used for the backdrop.
Picture | A System.Drawing.Image is used for the backdrop.
Solid | A solid fill is used for the backdrop.
Transparent | The backdrop is transparent.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.Graphics.BackdropStyle

See Also

Reference

GrapeCity.ActiveReports.Chart.Graphics Namespace


GradientType Enumeration

GradientType Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : GradientType Enumeration
Specifies the type of gradient to draw.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum GradientType
   Inherits System.Enum
public enum GradientType : System.Enum
Members
Member | Description
DiagonalDown | The gradient is drawn from top left to bottom right.
DiagonalUp | The gradient is drawn from bottom left to top right.
FromCenter | A radial gradient is drawn from the center.
FromCorner | A radial gradient is drawn to the center.
Horizontal | A horizontal gradient is drawn.
Vertical | A vertical gradient is drawn.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.Graphics.GradientType

See Also

Reference

GrapeCity.ActiveReports.Chart.Graphics Namespace


LineStyle Enumeration

LineStyle Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : LineStyle Enumeration
Specifies the line style to use.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LineStyle
   Inherits System.Enum
public enum LineStyle : System.Enum
Members
Member | Description
Dash | A dashed line is drawn.
DashDot | A line of alternating dashes and dots is drawn.
DashDotDot | A line of dashes alternated with two dots is drawn.
Dot | A dotted line is drawn.
None | No line style is used.
Solid | A solid line is drawn.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.Graphics.LineStyle

See Also

Reference

GrapeCity.ActiveReports.Chart.Graphics Namespace


PicturePutStyle Enumeration

PicturePutStyle Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : PicturePutStyle Enumeration
Specifies how the image is aligned inside the backdrop.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PicturePutStyle
   Inherits System.Enum
public enum PicturePutStyle : System.Enum
Members
Member | Description
Bottom | The image is aligned to the bottom.
Centered | The image is centered.
Left | The image is aligned to the left.
Right | The image is aligned to the right.
Stretched | The image is stretched to fill the backdrop.
Tiled | The image is tiled.
Top | The image is aligned to the top.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.Graphics.PicturePutStyle

See Also

Reference

GrapeCity.ActiveReports.Chart.Graphics Namespace


ProjectionType Enumeration

ProjectionType Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : ProjectionType Enumeration
Specifies the projection type used.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ProjectionType
   Inherits System.Enum
public enum ProjectionType : System.Enum
Members
Member | Description
Identical | Flat projection is used (i.e. the z coordinate is ignored).
Orthogonal | Orthogonal projection is used.
Perspective | Perspective projection is used.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.Graphics.ProjectionType

See Also

Reference

GrapeCity.ActiveReports.Chart.Graphics Namespace


TextAlign Enumeration

TextAlign Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : TextAlign Enumeration
Specifies how text is aligned within its rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TextAlign
   Inherits System.Enum
public enum TextAlign : System.Enum
Members
Member | Description
Center | The text is centered.
Left | The text is aligned left.
Right | The text is aligned right.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.Graphics.TextAlign

See Also

Reference

GrapeCity.ActiveReports.Chart.Graphics Namespace


TextAnchor Enumeration

TextAnchor Enumeration

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : TextAnchor Enumeration
Specifies how the text shape anchors to its position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TextAnchor
   Inherits System.Enum
public enum TextAnchor : System.Enum
Members
Member | Description
BottomLeft | The text anchors by the bottom left corner.
BottomMiddle | The text anchors by the center of the bottom.
BottomRight | The text anchors by the bottom right corner.
Center | The text anchors by the center.
MiddleLeft | The text anchors by the center of the left side.
MiddleRight | The text anchors by the center of the right side.
TopLeft | The text anchors by the top left corner.
TopMiddle | The text anchors by the center of the top.
TopRight | The text anchors by the top right corner.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Chart.Graphics.TextAnchor

See Also

Reference

GrapeCity.ActiveReports.Chart.Graphics Namespace


Bar Structure

Bar Structure
Members

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Bar Structure
Stores the location and size of the Bar area.
Object Model
Bar Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure Bar
   Inherits System.ValueType
public struct Bar : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Chart.Graphics.Bar

See Also

Reference

Bar Members
GrapeCity.ActiveReports.Chart.Graphics Namespace


Bar Structure Members

Bar Structure Members
Fields Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Bar Structure

The following tables list the members exposed by Bar.

Public Constructors
 | Name | Description
Public Constructor | Bar Constructor | Initializes a new instance of the Bar class with the specified parameters.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | Represents an instance of the bar structure with its properties uninitialized.
Top
Public Properties
 | Name | Description
Public Property | Depth | Gets the depth of the bar.
Public Property | Height | Gets the height of the bar.
Public Property | IsEmpty | Gets or sets a value indicating whether the bar is empty.
Public Property | Width | Gets the width of the bar.
Top
See Also

Reference

Bar Structure
GrapeCity.ActiveReports.Chart.Graphics Namespace


Bar Constructor

Bar Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Bar Structure : Bar Constructor
Width of the bar.
Height of the bar.
Depth of the bar.
Initializes a new instance of the Bar class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal width As System.Integer, _
   ByVal height As System.Integer, _
   ByVal depth As System.Integer _
)
public Bar(
   System.int width,
   System.int height,
   System.int depth
)

Parameters

width
Width of the bar.
height
Height of the bar.
depth
Depth of the bar.
See Also

Reference

Bar Structure
Bar Members


Bar Structure Properties

Bar Structure Properties

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Bar Structure

For a list of all members of this type, see Bar members.

Public Properties
 | Name | Description
Public Property | Depth | Gets the depth of the bar.
Public Property | Height | Gets the height of the bar.
Public Property | IsEmpty | Gets or sets a value indicating whether the bar is empty.
Public Property | Width | Gets the width of the bar.
Top
See Also

Reference

Bar Structure
GrapeCity.ActiveReports.Chart.Graphics Namespace


Depth Property

Depth Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Bar Structure : Depth Property
Gets the depth of the bar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Depth As System.Integer
public System.int Depth {get;}
See Also

Reference

Bar Structure
Bar Members


Height Property (Bar)

Height Property (Bar)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Bar Structure : Height Property

Gets the height of the bar.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Height As System.Integer
public System.int Height {get;}
See Also

Reference

Bar Structure
Bar Members


IsEmpty Property (Bar)

IsEmpty Property (Bar)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Bar Structure : IsEmpty Property
Gets or sets a value indicating whether the bar is empty.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsEmpty As System.Boolean
public System.bool IsEmpty {get;}
See Also

Reference

Bar Structure
Bar Members


Width Property (Bar)

Width Property (Bar)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Bar Structure : Width Property

Gets the width of the bar.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Width As System.Integer
public System.int Width {get;}
See Also

Reference

Bar Structure
Bar Members


Bar Structure Fields

Bar Structure Fields

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace : Bar Structure

For a list of all members of this type, see Bar members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | Represents an instance of the bar structure with its properties uninitialized.
Top
See Also

Reference

Bar Structure
GrapeCity.ActiveReports.Chart.Graphics Namespace


Empty Field (Bar)

Empty Field (Bar)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart.Graphics Namespace > Bar Structure : Empty Field
Represents an instance of the bar structure with its properties uninitialized.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Empty As Bar
public static readonly Bar Empty
See Also

Reference

Bar Structure
Bar Members


GrapeCity.ActiveReports.Design Namespace

GrapeCity.ActiveReports.Design Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Design.Win.v10 Assembly : GrapeCity.ActiveReports.Design Namespace
The GrapeCity.ActiveReports.Design namespace contains the designer classes and designer controls.
Classes
 | Class | Description
Class | ChartDataSourceClickedEventArgs | Provides data for the Designer.ChartDataSourceClicked event.
Class | ContextMenuOpenArgs | The ContextMenuOpenArgs class provides data needed for the ContextMenuOpen event.
Class | DataSourceIconClickedEventArgs | This class retrieves the value from the DialogResult after the data source icon is clicked.
Class | DataSourceIconClickEventArgs | DatasourceClickEventArgs holds the cancel value to stop the default Datasource dialog from showing.
Class | Designer | The Designer class is the base class for the End-User Report Designer control.
Class | DesignerTabChangedEventArgs | Contains the active tab information.
Class | EditModeEnteringEventArgs | This class retrieves the type of control to be edited when the user enters edit mode, allowing you to cancel editing for specified types of controls.
Class | EditModeExitEventArgs | This class retrieves the type of control edited when the user exits edit mode.
Class | LayerList | ActiveReports Layer List.
Class | LayerSelectionChangedEventArgs | Provides data for the SelectionChanged event of the LayerList
Class | LayoutChangedArgs | The LayoutChangedArgs class provides data required for the LayoutChanged event.
Class | LayoutChangingArgs | The LayoutChangingArgs class provides data required for the LayoutChanging event.
Class | OpenFileDialogExtension | For internal use only. This extension allows to show OpenFileDialog with customized split button.
Class | Selection | Indicates the currently selected items in the report layout.
Class | ServerConnectionChangedEventArgs | Information about connection with ARS
Class | UndoManager | The UndoManager class allows users to undo and redo changes.
Interfaces
 | Interface | Description
Interface | ITrackSelectionService | Defines the common interface that enables the transmission of events related to change in selection in the host environment.
Interface | IVsPackageIntegration | Provides an interface for the IVsPackageIntegration service.
Delegates
 | Delegate | Description
Delegate | ContextMenuOpenEventHandler | Represents a method that handles the ContextMenuOpen event.
Delegate | DataSourceIconClickedEventHandler | Represents a method that handles the DataSourceIconClicked event.
Delegate | DataSourceIconClickEventHandler | Represents a method that handles the DataSourceIconClick event.
Delegate | DesignerTabChangedEventHandler | Represents the method that handles the event, containing the active tab information.
Delegate | EditModeEnteringEventHandler | Represents a method that handles the EditModeEntering event.
Delegate | EditModeExitEventHandler | Represents a method that handles the EditModeExit event.
Delegate | LayoutChangedEventHandler | Represents a method that handles the LayoutChanged event.
Delegate | LayoutChangingEventHandler | Represents a method that handles the LayoutChanging method.
Delegate | ScriptChangedEventHandler | Represents a method that handles the ScriptChanged event.
Delegate | SelectionChangedEventHandler | Represents a method that handles the SelectionChanged event.
Delegate | ServerConnectionChangedEventHandler | Delegate for ServerConnectionChanged event
Delegate | StatusChangedEventHandler | Represents a method that handles the StatusChanged event.
Delegate | ToolboxItemChangedEventHandler | Represents a method that will handle the ToolboxItemChanged event.
Enumerations
 | Enumeration | Description
Enumeration | ContextMenuTypes | Specifies the type of menu that will be opened for this sourceObject.
Enumeration | DebugMode | Specifies the type of debugging.
Enumeration | DesignerAction | List of available designer commands (actions)
Enumeration | DesignerReportType | Available report types.
Enumeration | DesignerTab | Lists the available designer tab options.
Enumeration | DesignerToolStrips | Enumeration of the types of tool strips to use with the designer.
Enumeration | ExitType | Specifies the action to perform when the user exits edit mode.
Enumeration | GridMode | Specifies the type of the grid to draw in the designer surface.
Enumeration | LayoutChangeType | Enumeration of change settings for the report layout.
Enumeration | LayoutMode | Enumeration of modes for laying out controls on the report designer.
Enumeration | MeasurementUnits | Specifies the ruler measurement units.
Enumeration | MouseMode | Available designer MouseMode types.
Enumeration | ReportExplorerNodes | The visibility of the nodes in ReportExplorer
Enumeration | ToolPanelButton | Controls the visibility of ToolPanelButton controls on the Designer.
See Also

Reference

GrapeCity.ActiveReports.Design.Win.v10 Assembly


ChartDataSourceClickedEventArgs Class

ChartDataSourceClickedEventArgs Class
Members

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : ChartDataSourceClickedEventArgs Class
Provides data for the Designer.ChartDataSourceClicked event.
Object Model
ChartDataSourceClickedEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ChartDataSourceClickedEventArgs
   Inherits System.EventArgs
public sealed class ChartDataSourceClickedEventArgs : System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.ChartDataSourceClickedEventArgs

See Also

Reference

ChartDataSourceClickedEventArgs Members
GrapeCity.ActiveReports.Design Namespace


ChartDataSourceClickedEventArgs Class Members

ChartDataSourceClickedEventArgs Class Members
Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : ChartDataSourceClickedEventArgs Class

The following tables list the members exposed by ChartDataSourceClickedEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ChartDataSourceClickedEventArgs Constructor | Initializes a new instance of the ChartDataSourceClickedEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Cancel | Indicates that the default action should be skipped.
Public Property | Chart | Provides access to the control.
Top
See Also

Reference

ChartDataSourceClickedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


ChartDataSourceClickedEventArgs Constructor

ChartDataSourceClickedEventArgs Constructor

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > ChartDataSourceClickedEventArgs Class : ChartDataSourceClickedEventArgs Constructor
Control whose data source icon is clicked.
Initializes a new instance of the ChartDataSourceClickedEventArgs class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal control As ChartControl _
)
public ChartDataSourceClickedEventArgs(
   ChartControl control
)

Parameters

control
Control whose data source icon is clicked.
See Also

Reference

ChartDataSourceClickedEventArgs Class
ChartDataSourceClickedEventArgs Members


ChartDataSourceClickedEventArgs Class Properties

ChartDataSourceClickedEventArgs Class Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : ChartDataSourceClickedEventArgs Class

For a list of all members of this type, see ChartDataSourceClickedEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Indicates that the default action should be skipped.
Public Property | Chart | Provides access to the control.
Top
See Also

Reference

ChartDataSourceClickedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


Cancel Property (ChartDataSourceClickedEventArgs)

Cancel Property (ChartDataSourceClickedEventArgs)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > ChartDataSourceClickedEventArgs Class : Cancel Property
Indicates that the default action should be skipped.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Cancel As System.Boolean
public System.bool Cancel {get; set;}
See Also

Reference

ChartDataSourceClickedEventArgs Class
ChartDataSourceClickedEventArgs Members


Chart Property

Chart Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > ChartDataSourceClickedEventArgs Class : Chart Property
Provides access to the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Chart As ChartControl
public ChartControl Chart {get;}
See Also

Reference

ChartDataSourceClickedEventArgs Class
ChartDataSourceClickedEventArgs Members


ContextMenuOpenArgs Class

ContextMenuOpenArgs Class
Members

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : ContextMenuOpenArgs Class

The ContextMenuOpenArgs class provides data needed for the ContextMenuOpen event.

Object Model
ContextMenuOpenArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ContextMenuOpenArgs
   Inherits System.EventArgs
public class ContextMenuOpenArgs : System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.ContextMenuOpenArgs

See Also

Reference

ContextMenuOpenArgs Members
GrapeCity.ActiveReports.Design Namespace


ContextMenuOpenArgs Class Members

ContextMenuOpenArgs Class Members
Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : ContextMenuOpenArgs Class

The following tables list the members exposed by ContextMenuOpenArgs.

Public Properties
 | Name | Description
Public Property | Cancel | Determines whether the default menu handler should be cancelled.
Public Property | MenuType | Specifies the type of menu that will be opened for this sourceObject.
Public Property | Source | A reference to the object that is opening the menu.
Top
See Also

Reference

ContextMenuOpenArgs Class
GrapeCity.ActiveReports.Design Namespace


ContextMenuOpenArgs Class Properties

ContextMenuOpenArgs Class Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : ContextMenuOpenArgs Class

For a list of all members of this type, see ContextMenuOpenArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Determines whether the default menu handler should be cancelled.
Public Property | MenuType | Specifies the type of menu that will be opened for this sourceObject.
Public Property | Source | A reference to the object that is opening the menu.
Top
See Also

Reference

ContextMenuOpenArgs Class
GrapeCity.ActiveReports.Design Namespace


Cancel Property (ContextMenuOpenArgs)

Cancel Property (ContextMenuOpenArgs)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > ContextMenuOpenArgs Class : Cancel Property
Determines whether the default menu handler should be cancelled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Cancel As System.Boolean
public System.bool Cancel {get; set;}

Property Value

Boolean value.
Remarks
This parameter should be set to True to disable or replace built-in context menus.
See Also

Reference

ContextMenuOpenArgs Class
ContextMenuOpenArgs Members


MenuType Property

MenuType Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > ContextMenuOpenArgs Class : MenuType Property
Specifies the type of menu that will be opened for this sourceObject.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MenuType As ContextMenuTypes
public ContextMenuTypes MenuType {get;}
See Also

Reference

ContextMenuOpenArgs Class
ContextMenuOpenArgs Members
ActiveReports.Design6~GrapeCity.ActiveReports.Design.ContextMenuTypes


Source Property (ContextMenuOpenArgs)

Source Property (ContextMenuOpenArgs)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > ContextMenuOpenArgs Class : Source Property

A reference to the object that is opening the menu.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Source As System.Object
public System.object Source {get;}
See Also

Reference

ContextMenuOpenArgs Class
ContextMenuOpenArgs Members


DataSourceIconClickedEventArgs Class

DataSourceIconClickedEventArgs Class
Members

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : DataSourceIconClickedEventArgs Class
This class retrieves the value from the DialogResult after the data source icon is clicked.
Object Model
DataSourceIconClickedEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DataSourceIconClickedEventArgs
   Inherits System.EventArgs
public class DataSourceIconClickedEventArgs : System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.DataSourceIconClickedEventArgs

See Also

Reference

DataSourceIconClickedEventArgs Members
GrapeCity.ActiveReports.Design Namespace


DataSourceIconClickedEventArgs Class Members

DataSourceIconClickedEventArgs Class Members
Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : DataSourceIconClickedEventArgs Class

The following tables list the members exposed by DataSourceIconClickedEventArgs.

Public Constructors
 | Name | Description
Public Constructor | DataSourceIconClickedEventArgs Constructor | Initializes a new instance of the DatasourceClickEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | DialogResult | Gets the value from the data source dialog.
Top
See Also

Reference

DataSourceIconClickedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


DataSourceIconClickedEventArgs Constructor

DataSourceIconClickedEventArgs Constructor

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > DataSourceIconClickedEventArgs Class : DataSourceIconClickedEventArgs Constructor
The enumerated DialogResult value returned from the dialog.
Initializes a new instance of the DatasourceClickEventArgs class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal dialogResult As System.Windows.Forms.DialogResult _
)
public DataSourceIconClickedEventArgs(
   System.Windows.Forms.DialogResult dialogResult
)

Parameters

dialogResult
The enumerated DialogResult value returned from the dialog.
See Also

Reference

DataSourceIconClickedEventArgs Class
DataSourceIconClickedEventArgs Members


DataSourceIconClickedEventArgs Class Properties

DataSourceIconClickedEventArgs Class Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : DataSourceIconClickedEventArgs Class

For a list of all members of this type, see DataSourceIconClickedEventArgs members.

Public Properties
 | Name | Description
Public Property | DialogResult | Gets the value from the data source dialog.
Top
See Also

Reference

DataSourceIconClickedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


DialogResult Property

DialogResult Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > DataSourceIconClickedEventArgs Class : DialogResult Property
Gets the value from the data source dialog.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DialogResult As System.Windows.Forms.DialogResult
public System.Windows.Forms.DialogResult DialogResult {get;}

Property Value

An enumerated System.Windows.Forms.DialogResult value:

  • None
  • OK
  • Cancel
  • Abort
  • Retry
  • Ignore
  • Yes
  • No
See Also

Reference

DataSourceIconClickedEventArgs Class
DataSourceIconClickedEventArgs Members


DataSourceIconClickEventArgs Class

DataSourceIconClickEventArgs Class
Members Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : DataSourceIconClickEventArgs Class
DatasourceClickEventArgs holds the cancel value to stop the default Datasource dialog from showing.
Object Model
DataSourceIconClickEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DataSourceIconClickEventArgs
   Inherits System.EventArgs
public class DataSourceIconClickEventArgs : System.EventArgs
Example
  • C#
//Create the DataSourceClick event handler
this.arDesigner.DataSourceIconClick += new DataSourceIconClickEventHandler(arDesigner_DataSourceIconClick);

//Create the event handling method to respond to the user clicking the Datasource Icon
//Set Cancel to True to stop the default Datasource dialog from showing
private void arDesigner_DataSourceIconClick(object sender, DataSourceIconClickArgs e)
{
    e.Cancel = true;

    Form f = new Form();
    f.ShowDialog(this);

    // Add custom code to modify the report data source based on user preference
}
  • Visual Basic
'Create the DataSourceClick event handler
Me.arDesigner.DataSourceIconClick += New DataSourceIconClickEventHandler(arDesigner_DataSourceIconClick)

'Create the event handling method to respond to the user clicking the Datasource Icon
'Set Cancel to True to stop the default Datasource dialog from showi
Private Sub arDesigner_DataSourceIconClick(ByVal sender As Object, ByVal e As DataSourceIconClickArgs)
    e.Cancel = True

    Dim f As Form = New Form()
    f.ShowDialog(Me)

    ' Add custom code to modify the report data source based on user preference
End Sub
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.DataSourceIconClickEventArgs

See Also

Reference

DataSourceIconClickEventArgs Members
GrapeCity.ActiveReports.Design Namespace


DataSourceIconClickEventArgs Class Members

DataSourceIconClickEventArgs Class Members
Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : DataSourceIconClickEventArgs Class

The following tables list the members exposed by DataSourceIconClickEventArgs.

Public Constructors
 | Name | Description
Public Constructor | DataSourceIconClickEventArgs Constructor | Initializes a new instance of the DatasourceClickEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Cancel | Determines whether the default DataSource dialog is displayed. If the value is set to True, the DataSource dialog will not open when the DataSource Icon is clicked in the End-User Designer.
Top
See Also

Reference

DataSourceIconClickEventArgs Class
GrapeCity.ActiveReports.Design Namespace


DataSourceIconClickEventArgs Constructor

DataSourceIconClickEventArgs Constructor

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > DataSourceIconClickEventArgs Class : DataSourceIconClickEventArgs Constructor
Initializes a new instance of the DatasourceClickEventArgs class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DataSourceIconClickEventArgs()
See Also

Reference

DataSourceIconClickEventArgs Class
DataSourceIconClickEventArgs Members


DataSourceIconClickEventArgs Class Properties

DataSourceIconClickEventArgs Class Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : DataSourceIconClickEventArgs Class

For a list of all members of this type, see DataSourceIconClickEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Determines whether the default DataSource dialog is displayed. If the value is set to True, the DataSource dialog will not open when the DataSource Icon is clicked in the End-User Designer.
Top
See Also

Reference

DataSourceIconClickEventArgs Class
GrapeCity.ActiveReports.Design Namespace


Cancel Property (DataSourceIconClickEventArgs)

Cancel Property (DataSourceIconClickEventArgs)
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > DataSourceIconClickEventArgs Class : Cancel Property
Determines whether the default DataSource dialog is displayed. If the value is set to True, the DataSource dialog will not open when the DataSource Icon is clicked in the End-User Designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Cancel As System.Boolean
public System.bool Cancel {get; set;}
Remarks
For End-User Designer only. The DataSourceClick event must be attached to the Designer in order for this to take effect. If the value is set to True, the default Datasource dialog will not open when the Datasource Icon is clicked in End-User Designer. In a typical scenario a custom dialog can be showed instead.
Example
  • C#
//Create the DataSourceClick event handler
this.arDesigner.DataSourceIconClick += new DataSourceIconClickEventHandler(arDesigner_DataSourceIconClick);

//Create the event handling method to respond to the user clicking the Datasource Icon
//Set Cancel to True to stop the default Datasource dialog from showing
private void arDesigner_DataSourceIconClick(object sender, DataSourceIconClickArgs e)
{
    e.Cancel = true;

    Form f = new Form();
    f.ShowDialog(this);

    // Add custom code to modify the report data source based on user preference
}
  • Visual Basic
'Create the DataSourceClick event handler
Me.arDesigner.DataSourceIconClick += New DataSourceIconClickEventHandler(arDesigner_DataSourceIconClick)

'Create the event handling method to respond to the user clicking the Datasource Icon
'Set Cancel to True to stop the default Datasource dialog from showi
Private Sub arDesigner_DataSourceIconClick(ByVal sender As Object, ByVal e As DataSourceIconClickArgs)
    e.Cancel = True

    Dim f As Form = New Form()
    f.ShowDialog(Me)

    ' Add custom code to modify the report data source based on user preference
End Sub
See Also

Reference

DataSourceIconClickEventArgs Class
DataSourceIconClickEventArgs Members


Designer Class

Designer Class
Members Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : Designer Class
The Designer class is the base class for the End-User Report Designer control.
Object Model
Designer Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Designer
   Inherits System.Windows.Forms.UserControl
public class Designer : System.Windows.Forms.UserControl
Remarks
The designer control is used to customize report layouts at run time.
Example
  • C#
private void designer1_Load(object sender, System.EventArgs e)
{
this.designer1.DesignerUnits = GrapeCity.ActiveReports.Design.MeasurementUnits.Inches;
this.designer1.DrawGrid = true;
this.designer1.GridX = 16;
this.designer1.GridY = 16;
this.designer1.LockControls = false;
this.designer1.ShowDataSourceIcon = true;
this.designer1.LayoutMode = GrapeCity.ActiveReports.Design.LayoutMode.SnapGrid;
this.designer1.ToolBoxItem = null;
}
  • Visual Basic
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.Designer1.DesignerUnits = GrapeCity.ActiveReports.Design.MeasurementUnits.Inches
    Me.Designer1.DrawGrid = True
    Me.Designer1.GridX = 16
    Me.Designer1.GridY = 16
    Me.Designer1.LockControls = False
    Me.Designer1.ShowDataSourceIcon = True
    Me.designer1.LayoutMode = GrapeCity.ActiveReports.Design.LayoutMode.SnapGrid
    Me.Designer1.ToolBoxItem = Nothing
End Sub
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
GrapeCity.ActiveReports.Design.Designer

See Also

Reference

Designer Members
GrapeCity.ActiveReports.Design Namespace

Walkthroughs

Creating a Basic End User Report Designer


Designer Class Members

Designer Class Members
Properties Methods Events

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : Designer Class

The following tables list the members exposed by Designer.

Public Constructors
 | Name | Description
Public Constructor | Designer Constructor | Creates a new Instance of Designer class.
Top
Public Properties
 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | ColorTheme | Gets or sets the colors of the report designer's section bands and ruler.
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DesignerUnits | Gets or sets the measurement units for the designer.
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | DrawGrid | Gets or sets a value indicating whether a grid is drawn in the designer.
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | EnableOleObject | Enable or disable the OleObject control in the Visual Studio Toolbox.
Public Property | EnablePreview | Gets or sets a value determining whether the preview tab on the Designer control is enabled or disabled.
Public Property | EnableScripting | Sets or returns a value indicating whether scripting is enabled for the designer.
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | GridMode | Gets or sets the GridMode in the designer.
Public Property | GridX | Determines how coarse the designer grid should be.
Public Property | GridY | Determines how coarse the designer grid should be.
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutMode | Gets or sets the value that determines how the end user can lay out controls on the report design surface.
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | LockControls | Specifies whether the controls are locked in place.
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | PreviewPages | Gets or sets the number of pages of report that should be generated for preview.
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | PromptUser | Determines whether to display a dialog when a control is deleted.
Public Property | PropertyGrid | Attaches a System.Windows.Forms.PropertyGrid to the designer to display the properties of an item selected within the designer.
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Report | Returns a reference to the designer's report object.
Public Property | ReportPartsDirectory | Gets or sets the path to load reports in to the report items library. By default it's current user's Documents folder.
Public Property | ReportTabsVisible | Sets or returns a value indicating whether the report tabs are shown below the designer.
Public Property | ReportType | Temporary report type indicator. Used by Report Explorer and (potentially) by Toolbox.
Public Property | ResourceLocator | Gets or sets the resource locator implementation that used to locate the custom resources.
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | Selection | Returns the collection of selected objects.
Public Property | ShowDataSourceIcon | Specifies whether the Datasource icon will be visible on the detail section bar to allow the user to modify the report's data source settings.
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | SnapGrid | Sets or returns a value indicating whether the controls should be snapped to the grid points.
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Toolbox | Gets or Sets the IToolboxService for the Report Designer.
Public Property | ToolBoxItem | Sets the type of control in the toolbox.
Public Property | ToolPanel | Gets or sets the value that indicate the tools that are available in the designer tool panel.
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | UndoManager | The UndoManager allows users to undo and redo changes.
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Public Property | Zoom | Gets or sets the zoom value for the Designer.
Top
Public Methods
 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | ConnectToServer | Shows ConnectToServer dialog.
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | CreateToolStrips | Creates ActiveReports ToolStrips in a ToolStrip or ToolStripContainer control.
Public Method | DisconnectFromServer | Disconnects from server
Public Method | Dispose | Disposes objects referenced by the designer. (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | ExecuteAction | Overloaded. Executes a specified DesignerAction command.
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | LoadReport | Overloaded. Loads an existing report XML layout into the designer.
Public Method | LoadReportFromServer | Load report from active reports server
Public Method | NewReport | Overloaded. Initializes the designer with a new report layout.
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PointToSection | Returns the screen coordinates of a specified point in a given section.
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | QueryActionChecked | Queries the object for the checked status of one or more commands.
Public Method | QueryActionEnabled | Queries the object for the enabled status of one or more commands.
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SaveReport | Overloaded. Saves a report XML layout to the filename or stream specified.
Public Method | SaveReportToServer | Save report to active reports server
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SectionAt | Returns the section at the specified point.
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top
Public Events
 | Name | Description
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | ChartDataSourceClicked | Fires after a chart data source item has been clicked.
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuOpen | Fires before a context menu is opened.
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DataSourceIconClick | Raised when the Datasource icon is clicked in the designer.
Public Event | DataSourceIconClicked | Gets the value from the DialogResult when the data source icon is clicked.
Public Event | DesignerTabChanged | Raised when the designer tab changes.
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EditModeEntering | This event occurs when the end user clicks inside a TextBox, Label, CheckBox or RichTextBox control in the End User Designer and enters edit mode.
Public Event | EditModeExit | This event occurs when an end user leaves edit mode in a TextBox, Label, CheckBox or RichTextBox control in the End User Designer.
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | LayoutChanged | Raised when the layout is changed.
Public Event | LayoutChanging | Raised when the layout is changing and passes the sender a new EventArgs class called LayoutChangingArgs.
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.UserControl)
Public Event | LocateCredentials | Occurs when the report is previewed and credentials are needed.
Public Event | LocateDataSource | Occurs when a data provider of the previewed report needs to locate the data at runtime.
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ScriptChanged | Raised when the script for a report in the End User Report Designer is changed.
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SelectionChanged | Raised when the selection changes.
Public Event | ServerConnectionChanged | Raises ServerConnectionChanged event. Occurs after changing connection to ActiveReports Server.
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StatusChanged | This event is raised for each change in the status of the designer actions.
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ToolboxItemChanged | Raised when a toolbox control is drawn on the Report Designer.
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

Designer Class
GrapeCity.ActiveReports.Design Namespace

Walkthroughs

Creating a Basic End User Report Designer


Designer Constructor

Designer Constructor

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Designer Constructor
Creates a new Instance of Designer class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Designer()
See Also

Reference

Designer Class
Designer Members


Designer Class Methods

Designer Class Methods

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : Designer Class

For a list of all members of this type, see Designer members.

Public Methods
 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | ConnectToServer | Shows ConnectToServer dialog.
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | CreateToolStrips | Creates ActiveReports ToolStrips in a ToolStrip or ToolStripContainer control.
Public Method | DisconnectFromServer | Disconnects from server
Public Method | Dispose | Disposes objects referenced by the designer. (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | ExecuteAction | Overloaded. Executes a specified DesignerAction command.
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | LoadReport | Overloaded. Loads an existing report XML layout into the designer.
Public Method | LoadReportFromServer | Load report from active reports server
Public Method | NewReport | Overloaded. Initializes the designer with a new report layout.
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PointToSection | Returns the screen coordinates of a specified point in a given section.
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | QueryActionChecked | Queries the object for the checked status of one or more commands.
Public Method | QueryActionEnabled | Queries the object for the enabled status of one or more commands.
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SaveReport | Overloaded. Saves a report XML layout to the filename or stream specified.
Public Method | SaveReportToServer | Save report to active reports server
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SectionAt | Returns the section at the specified point.
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top
See Also

Reference

Designer Class
GrapeCity.ActiveReports.Design Namespace

Walkthroughs

Creating a Basic End User Report Designer


ConnectToServer() Method

ConnectToServer() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ConnectToServer() Method
Shows ConnectToServer dialog.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ConnectToServer()
public void ConnectToServer()
See Also

Reference

Designer Class
Designer Members


CreateToolStrips Method

CreateToolStrips Method
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CreateToolStrips Method
The ToolStrip or ToolStripContainer control in which to create the ToolStrips.
Creates ActiveReports ToolStrips in a ToolStrip or ToolStripContainer control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateToolStrips( _
   ByVal ParamArray strips() As DesignerToolStrips _
) As System.Windows.Forms.ToolStrip()
public System.Windows.Forms.ToolStrip[] CreateToolStrips(
   params DesignerToolStrips[] strips
)

Parameters

strips
The ToolStrip or ToolStripContainer control in which to create the ToolStrips.
Example
  • Visual Basic
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
        Dim menuStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Menu)(0)
        Dim editStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Edit)(0)
        Dim formatStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Format)(0)
        Dim layoutStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Layout)(0)
        Dim reportStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Report)(0)
        Dim undoStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Undo)(0)
        Dim zoomStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Zoom)(0)
        Me.ToolStripContainer1.TopToolStripPanel.Join(menuStrip, 0)
        Me.ToolStripContainer1.TopToolStripPanel.Join(editStrip, 1)
        Me.ToolStripContainer1.TopToolStripPanel.Join(formatStrip, 2)
        Me.ToolStripContainer1.TopToolStripPanel.Join(layoutStrip, 3)
        Me.ToolStripContainer1.TopToolStripPanel.Join(reportStrip, 4)
        Me.ToolStripContainer1.TopToolStripPanel.Join(undoStrip, 5)
        Me.ToolStripContainer1.TopToolStripPanel.Join(zoomStrip, 6)
    End Sub
  • C#
private void designer1_Load(object sender, EventArgs e)
       {
           ToolStrip menuStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Menu)[0];
           ToolStrip editStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Edit)[0];
           ToolStrip formatStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Format)[0];
           ToolStrip layoutStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Layout)[0];
           ToolStrip reportStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Report)[0];
           ToolStrip undoStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Undo)[0];
           ToolStrip zoomStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Zoom)[0];
           this.toolStripContainer1.TopToolStripPanel.Join(menuStrip, 0);
           this.toolStripContainer1.TopToolStripPanel.Join(editStrip, 1);
           this.toolStripContainer1.TopToolStripPanel.Join(formatStrip, 2);
           this.toolStripContainer1.TopToolStripPanel.Join(layoutStrip, 3);
           this.toolStripContainer1.TopToolStripPanel.Join(reportStrip, 4);
           this.toolStripContainer1.TopToolStripPanel.Join(undoStrip, 5);
           this.toolStripContainer1.TopToolStripPanel.Join(zoomStrip, 6);
       }
See Also

Reference

Designer Class
Designer Members


DisconnectFromServer() Method

DisconnectFromServer() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DisconnectFromServer() Method
Disconnects from server
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub DisconnectFromServer()
public void DisconnectFromServer()
See Also

Reference

Designer Class
Designer Members


ExecuteAction Method

ExecuteAction Method
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ExecuteAction Method
Executes a specified DesignerAction command.
Overload List
Overload | Description
ExecuteAction(DesignerAction) | Executes a specified DesignerAction command. This method can be used when implementing a custom toolbar or menu. This method will perform the report actions in response to the toolbar or menu items.
ExecuteAction(DesignerAction,Object) | Executes a specified DesignerAction command. This method can be used when implementing a custom toolbar or menu. This method will perform the report actions in response to the toolbar or menu items.
Remarks
This method can be used when implementing a custom toolbar or menu. This method will perform the report actions in response to the toolbar or menu items.
Example
  • C#
private void mnuLoadLayout_Click(object sender, System.EventArgs e)
{
    this.designer1.ExecuteAction(GrapeCity.ActiveReports.Design.DesignerAction.FileOpen);
}

private void mnuSaveLayout_Click(object sender, System.EventArgs e)
{
    this.designer1.ExecuteAction(GrapeCity.ActiveReports.Design.DesignerAction.FileSave);
}

private void mnuPageSetup_Click(object sender, System.EventArgs e)
{
    this.designer1.ExecuteAction(GrapeCity.ActiveReports.Design.DesignerAction.ReportSettings);
}
  • Visual Basic
Private Sub mnuLoadLayout_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuLoadLayout.Click
    Me.Designer1.ExecuteAction(DesignerAction.FileOpen)
End Sub

Private Sub mnuSaveLayout_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuSaveLayout.Click
    Me.Designer1.ExecuteAction(DesignerAction.FileSave)
End Sub

Private Sub mnuPageSetup_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuPageSetup.Click
    Me.Designer1.ExecuteAction(DesignerAction.ReportSettings)
End Sub
See Also

Reference

Designer Class
Designer Members
DesignerAction Enumeration

Walkthroughs

Creating a Basic End User Report Designer


ExecuteAction(DesignerAction) Method

ExecuteAction(DesignerAction) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > ExecuteAction Method : ExecuteAction(DesignerAction) Method
DesignerAction
Executes a specified DesignerAction command. This method can be used when implementing a custom toolbar or menu. This method will perform the report actions in response to the toolbar or menu items.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ExecuteAction( _
   ByVal action As DesignerAction _
)
public void ExecuteAction(
   DesignerAction action
)

Parameters

action
DesignerAction
See Also

Reference

Designer Class
Designer Members
Overload List


ExecuteAction(DesignerAction,Object) Method

ExecuteAction(DesignerAction,Object) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > ExecuteAction Method : ExecuteAction(DesignerAction,Object) Method
DesignerAction
parameter
Executes a specified DesignerAction command. This method can be used when implementing a custom toolbar or menu. This method will perform the report actions in response to the toolbar or menu items.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ExecuteAction( _
   ByVal action As DesignerAction, _
   ByVal parameter As System.Object _
)
public void ExecuteAction(
   DesignerAction action,
   System.object parameter
)

Parameters

action
DesignerAction
parameter
parameter
See Also

Reference

Designer Class
Designer Members
Overload List


LoadReport Method

LoadReport Method
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LoadReport Method
Loads an existing report XML layout into the designer.
Overload List
Overload | Description
LoadReport(FileInfo) | Loads an existing report XML layout from the specified file name into the designer.
LoadReport(Stream) | Loads an existing report XML layout from the specified Stream into the designer.
LoadReport(XmlReader,DesignerReportType) | Loads existing report XML layout into the designer.
Example
  • C#
// SetReportViaStream - sets a report design stream to the Designer
public System.IO.Stream ReportViaStream
{
    set
    {
        this.ardMain.LoadReport(value);
    }
    get
    {
        System.IO.Stream _stream = new System.IO.MemoryStream();
        this.ardMain.SaveReport(_stream);
        _stream.Position = 0;
        return _stream;
    }
}
  • Visual Basic
'SetReportViaStream - sets a report design stream to the Designer
Public Property ReportViaStream() As System.IO.Stream
    Get
        Dim _stream As New System.IO.MemoryStream()
        Me.ardMain.SaveReport(_stream)
        _stream.Position = 0
        Return _stream
    End Get
    Set(ByVal Value As System.IO.Stream)
        Me.ardMain.LoadReport(Value)
    End Set
End Property
See Also

Reference

Designer Class
Designer Members


LoadReport(FileInfo) Method

LoadReport(FileInfo) Method
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > LoadReport Method : LoadReport(FileInfo) Method
File containing section or page report.
Loads an existing report XML layout from the specified file name into the designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadReport( _
   ByVal file As System.IO.FileInfo _
)
public void LoadReport(
   System.IO.FileInfo file
)

Parameters

file
File containing section or page report.
Example
  • C#
/// <summary>
/// OpenReportFile - opens the Open File dialog box to select and open a report rpx file
/// </summary>
private void OpenReportFile()
{
    try
    {
        this.dlgOpenFile.Filter = "ActiveReport Report Design (RPX) (*.rpx)|*.rpx";
        this.dlgOpenFile.FilterIndex = 2;
        this.dlgOpenFile.RestoreDirectory = true ;
        this.dlgOpenFile.DefaultExt = ".rpx";

        if(dlgOpenFile.ShowDialog() == DialogResult.OK)
        {
            this._alreadySaved = true;

            //Add opened report to the opened report recent cache
            if(System.IO.File.Exists(Application.StartupPath + @"\Settings\recent.xml"))
            {

                DataSet _reportsDS = new DataSet();
                _reportsDS.Locale = CultureInfo.InvariantCulture;
                _reportsDS.ReadXml(Application.StartupPath + @"\Settings\recent.xml");
                DataTable _reportsTable = _reportsDS.Tables["Reports"];
                _reportsTable.Locale = CultureInfo.InvariantCulture;

                //Create a Row
                DataRow _rowReports = _reportsTable.NewRow();
                object [] _myArray = new object[2];
                this._savedPath = this.dlgOpenFile.FileName;
                _myArray[0] = this.dlgOpenFile.FileName;
                _myArray[1] = System.DateTime.Now;
                _rowReports.ItemArray = _myArray;
                _reportsTable.Rows.Add(_rowReports);
                _reportsDS.WriteXml(Application.StartupPath + @"\Settings\recent.xml", XmlWriteMode.WriteSchema);
            }

            //Load the Report
            this.ardMain.LoadReport(this._savedPath);
        }

        //Fill the designer combo boxes
        this.FillCombo();

    }
    catch(System.IO.IOException ex)
    {
        MessageBox.Show(ex.ToString());
    }
}
  • Visual Basic
'OpenReportFile - opens the Open File dialog box to select and open a report rpx file
Private Sub OpenReportFile()
    Try
        Me.dlgOpenFile.Filter = "ActiveReport Report Design (RPX) (*.rpx)|*.rpx"
        Me.dlgOpenFile.FilterIndex = 2
        Me.dlgOpenFile.RestoreDirectory = True
        Me.dlgOpenFile.DefaultExt = ".rpx"

        If dlgOpenFile.ShowDialog() = DialogResult.OK Then
            Me._alreadySaved = True

            'Add opened report to the opened report recent cache
            If System.IO.File.Exists((Application.StartupPath + "\Settings\recent.xml")) Then

                Dim _reportsDS As New DataSet()
                _reportsDS.Locale = CultureInfo.InvariantCulture
                _reportsDS.ReadXml((Application.StartupPath + "\Settings\recent.xml"))
                Dim _reportsTable As DataTable = _reportsDS.Tables("Reports")
                _reportsTable.Locale = CultureInfo.InvariantCulture

                'Create a Row
                Dim _rowReports As DataRow = _reportsTable.NewRow()
                Dim _myArray(1) As Object
                Me._savedPath = Me.dlgOpenFile.FileName
                _myArray(0) = Me.dlgOpenFile.FileName
                _myArray(1) = System.DateTime.Now
                _rowReports.ItemArray = _myArray
                _reportsTable.Rows.Add(_rowReports)
                _reportsDS.WriteXml(Application.StartupPath + "\Settings\recent.xml", XmlWriteMode.WriteSchema)
            End If

            'Load the Report
            Me.ardMain.LoadReport(Me._savedPath)
        End If

        'Fill the designer combo boxes
        Me.FillCombo()

    Catch ex As System.IO.IOException
        MessageBox.Show(ex.ToString())
    End Try
End Sub 'OpenReportFile
See Also

Reference

Designer Class
Designer Members
Overload List


LoadReport(Stream) Method

LoadReport(Stream) Method
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > LoadReport Method : LoadReport(Stream) Method
Specifies the Stream object that contains the report layout.The stream to be loaded.
Loads an existing report XML layout from the specified Stream into the designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadReport( _
   ByVal stream As System.IO.Stream _
)
public void LoadReport(
   System.IO.Stream stream
)

Parameters

stream
Specifies the Stream object that contains the report layout.The stream to be loaded.
Example
  • C#
/// <summary>
/// SetReportViaStream - sets a report design stream to the Designer
/// </summary>
/// <param name="memStream">Report Memory Stream to set to the designer</param>
public System.IO.Stream ReportViaStream
{
    set
    {
        this.ardMain.LoadReport(value);
    }
    get
    {
        System.IO.Stream _stream = new System.IO.MemoryStream();
        this.ardMain.SaveReport(_stream);
        _stream.Position = 0;
        return _stream;
    }
}
  • Visual Basic
'SetReportViaStream - sets a report design stream to the Designer
'Parameter Name: memStream - Report Memory Stream to set to the designer
Public Property ReportViaStream() As System.IO.Stream
    Get
        Dim _stream As New System.IO.MemoryStream()
        Me.ardMain.SaveReport(_stream)
        _stream.Position = 0
        Return _stream
    End Get
    Set(ByVal Value As System.IO.Stream)
        Me.ardMain.LoadReport(Value)
    End Set
End Property
See Also

Reference

Designer Class
Designer Members
Overload List


LoadReport(XmlReader,DesignerReportType) Method

LoadReport(XmlReader,DesignerReportType) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > LoadReport Method : LoadReport(XmlReader,DesignerReportType) Method
Reader containing section or page report.
Section or Page report.
Loads existing report XML layout into the designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadReport( _
   ByVal reader As System.Xml.XmlReader, _
   ByVal type As DesignerReportType _
)
public void LoadReport(
   System.Xml.XmlReader reader,
   DesignerReportType type
)

Parameters

reader
Reader containing section or page report.
type
Section or Page report.
See Also

Reference

Designer Class
Designer Members
Overload List


LoadReportFromServer Method

LoadReportFromServer Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LoadReportFromServer Method
Report name or null if report not opened
Load report from active reports server
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function LoadReportFromServer( _
   ByRef reportName As System.String _
) As System.Windows.Forms.DialogResult
public System.Windows.Forms.DialogResult LoadReportFromServer(
   out System.string reportName
)

Parameters

reportName
Report name or null if report not opened

Return Value

The result of the opening of the form
See Also

Reference

Designer Class
Designer Members


NewReport Method

NewReport Method
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : NewReport Method
Initializes the designer with a new report layout.
Overload List
Overload | Description
NewReport() | Initializes the designer with a new report layout.
NewReport(DesignerReportType) | Initializes the designer with a new report layout with specified type.
Example
  • C#
/// <summary>
/// NewReport - an Interface function from IPlugInHost
/// </summary>
/// <param name="name">Name to use for the Document</param>
/// <returns>Current report object in the designer</returns>
public object NewReport(string name)
{
    try
    {
        this.ardMain.NewReport();
        this.ardMain.Report.Document.Name = name;
        return this.ardMain.Report;
    }
    catch(GrapeCity.ActiveReports.ReportException)
    {
        MessageBox.Show("Error occurred while creating new report", "Error in Diamond Reports");
        return null;
    }

}
  • Visual Basic
'NewReport - an Interface function from IPlugInHost
'Parameter Name: name - Name to use for the Document
'Returns: Current report object in the designer
Public Function NewReport(ByVal name As String) As Object Implements IPlugInHost.NewReport
    Try
        Me.ardMain.NewReport()
        Me.ardMain.Report.Document.Name = name
        Return Me.ardMain.Report
    Catch ex As GrapeCity.ActiveReports.ReportException
        MessageBox.Show("Error occurred while creating new report", "Error in Diamond Reports")
        Return Nothing
    End Try
End Function 'NewReport
See Also

Reference

Designer Class
Designer Members


NewReport() Method

NewReport() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > NewReport Method : NewReport() Method
Initializes the designer with a new report layout.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub NewReport()
public void NewReport()
See Also

Reference

Designer Class
Designer Members
Overload List


NewReport(DesignerReportType) Method

NewReport(DesignerReportType) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > NewReport Method : NewReport(DesignerReportType) Method
Section or Page report.
Initializes the designer with a new report layout with specified type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub NewReport( _
   ByVal type As DesignerReportType _
)
public void NewReport(
   DesignerReportType type
)

Parameters

type
Section or Page report.
See Also

Reference

Designer Class
Designer Members
Overload List


PointToSection Method

PointToSection Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PointToSection Method
The section that contains the specified point.
Point within designer coordinates
Returns the screen coordinates of a specified point in a given section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PointToSection( _
   ByVal section As System.Object, _
   ByVal point As Point _
) As Point
public Point PointToSection(
   System.object section,
   Point point
)

Parameters

section
The section that contains the specified point.
point
Point within designer coordinates

Return Value

Point within a section with
See Also

Reference

Designer Class
Designer Members


QueryActionChecked Method

QueryActionChecked Method
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : QueryActionChecked Method
DesignerAction Types
Queries the object for the checked status of one or more commands.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function QueryActionChecked( _
   ByVal action As DesignerAction _
) As System.Boolean
public System.bool QueryActionChecked(
   DesignerAction action
)

Parameters

action
DesignerAction Types
Example
  • C#
/// <summary>
/// SetStatus - Updates a toolbutton's status, based on a designer action
/// </summary>
/// <param name="action">DesignerAction to take in string format</param>
/// <param name="toolButton">ToolButton to update</param>
private void SetStatus(string action,System.Windows.Forms.ToolBarButton toolButton)
{
    DesignerAction daAction = GetActionFromString(action);
    //Do the following if the DesignerAction isn't a FileOpen
    if(daAction != DesignerAction.FileOpen)
    {
        //Set toolButton attributes based on the Designer Action
        toolButton.Enabled = this.ardMain.QueryActionEnabled(daAction);
        toolButton.Pushed = this.ardMain.QueryActionChecked(daAction);
    }
}
  • Visual Basic
'SetStatus - Updates a toolbutton's status, based on a designer action
'Parameter Name: action - DesignerAction to take in string format
'Parameter Name: toolButton - ToolButton to update
Private Sub SetStatus(ByVal action As String, ByVal toolButton As System.Windows.Forms.ToolBarButton)
    Dim daAction As DesignerAction = GetActionFromString(action)
    'Do the following if the DesignerAction isn't a FileOpen
    If daAction <> DesignerAction.FileOpen Then
        'Set toolButton attributes based on the Designer Action
        toolButton.Enabled = Me.ardMain.QueryActionEnabled(daAction)
        toolButton.Pushed = Me.ardMain.QueryActionChecked(daAction)
    End If
End Sub 'SetStatus
See Also

Reference

Designer Class
Designer Members
DesignerAction Enumeration


QueryActionEnabled Method

QueryActionEnabled Method
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : QueryActionEnabled Method
DesignerAction Types
Queries the object for the enabled status of one or more commands.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function QueryActionEnabled( _
   ByVal action As DesignerAction _
) As System.Boolean
public System.bool QueryActionEnabled(
   DesignerAction action
)

Parameters

action
DesignerAction Types

Return Value

True, if the enabled status is true, else False.
Example
  • C#
/// <summary>
/// SetStatus - Updates a toolbutton's status, based on a designer action
/// </summary>
/// <param name="action">DesignerAction to take in string format</param>
/// <param name="toolButton">ToolButton to update</param>
private void SetStatus(string action,System.Windows.Forms.ToolBarButton toolButton)
{
    DesignerAction daAction = GetActionFromString(action);
    //Do the following if the DesignerAction isn't a FileOpen
    if(daAction != DesignerAction.FileOpen)
    {
        //Set toolButton attributes based on the Designer Action
        toolButton.Enabled = this.ardMain.QueryActionEnabled(daAction);
        toolButton.Pushed = this.ardMain.QueryActionChecked(daAction);
    }
}
  • Visual Basic
'SetStatus - Updates a toolbutton's status, based on a designer action
'Parameter Name: action - DesignerAction to take in string format
'Parameter Name: toolButton - ToolButton to update
Private Sub SetStatus(ByVal action As String, ByVal toolButton As System.Windows.Forms.ToolBarButton)
    Dim daAction As DesignerAction = GetActionFromString(action)
    'Do the following if the DesignerAction isn't a FileOpen
    If daAction <> DesignerAction.FileOpen Then
        'Set toolButton attributes based on the Designer Action
        toolButton.Enabled = Me.ardMain.QueryActionEnabled(daAction)
        toolButton.Pushed = Me.ardMain.QueryActionChecked(daAction)
    End If
End Sub 'SetStatus
See Also

Reference

Designer Class
Designer Members
DesignerAction Enumeration


SaveReport Method

SaveReport Method
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SaveReport Method
Saves a report XML layout to the filename or stream specified.
Overload List
Overload | Description
SaveReport(FileInfo) | Saves a report layout as an XML file to the specified file name.
SaveReport(Stream) | Saves a report layout as an XML file to the specified Stream.
SaveReport(XmlWriter) | Saves a report XML layout to the writer.
Example
  • C#
// SetReportViaStream - sets a report design stream to the Designer
public System.IO.Stream ReportViaStream
{
    set
    {
        this.ardMain.LoadReport(value);
    }
    get
    {
        System.IO.Stream _stream = new System.IO.MemoryStream();
        this.ardMain.SaveReport(_stream);
        _stream.Position = 0;
        return _stream;
    }
}
  • Visual Basic
'SetReportViaStream - sets a report design stream to the Designer
Public Property ReportViaStream() As System.IO.Stream
    Get
        Dim _stream As New System.IO.MemoryStream()
        Me.ardMain.SaveReport(_stream)
        _stream.Position = 0
        Return _stream
    End Get
    Set(ByVal Value As System.IO.Stream)
        Me.ardMain.LoadReport(Value)
    End Set
End Property
See Also

Reference

Designer Class
Designer Members


SaveReport(FileInfo) Method

SaveReport(FileInfo) Method
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > SaveReport Method : SaveReport(FileInfo) Method
Specifies the File object to contain the report layout.
Saves a report layout as an XML file to the specified file name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SaveReport( _
   ByVal file As System.IO.FileInfo _
)
public void SaveReport(
   System.IO.FileInfo file
)

Parameters

file
Specifies the File object to contain the report layout.
Example
  • C#
/// <summary>
/// SaveReportFile - opens the Save File Dialog to save the report out to an rpx file
/// </summary>
private void SaveReportFile()
{
    //If the Report was saved once, we already have a valid path, call Save on it.
    if(this._alreadySaved)
    {
        this.ardMain.SaveReport(this._savedPath);
    }
    else
    {
        //Open Save dialog to retrieve a file and path to save to
        this.dlgSaveFile.Filter = "ActiveReport Report Design (RPX) (*.rpx)|*.rpx";
        this.dlgSaveFile.FileName = "Report.rpx";
        this.dlgSaveFile.FilterIndex = 2;
        this.dlgSaveFile.RestoreDirectory = true ;
        this.dlgSaveFile.DefaultExt = ".rpx";

        if(dlgSaveFile.ShowDialog() == DialogResult.OK)
        {
            //Add new saved report to the recent documents cache
            if(System.IO.File.Exists(Application.StartupPath + @"\Settings\recent.xml"))
            {
                DataSet _reportsDS = new DataSet();
                _reportsDS.Locale = CultureInfo.InvariantCulture;
                _reportsDS.ReadXml(Application.StartupPath + @"\Settings\recent.xml");
                DataTable _reportsTable = _reportsDS.Tables["Reports"];
                _reportsTable.Locale = CultureInfo.InvariantCulture;

                //Create a Row
                DataRow _rowReports = _reportsTable.NewRow();
                object [] _myArray = new object[2];
                this._savedPath = this.dlgSaveFile.FileName;
                _myArray[0] = this.dlgSaveFile.FileName;
                _myArray[1] = System.DateTime.Now;
                _rowReports.ItemArray = _myArray;
                _reportsTable.Rows.Add(_rowReports);
                _reportsDS.WriteXml(Application.StartupPath + @"\Settings\recent.xml", XmlWriteMode.WriteSchema);
            }
            this.ardMain.SaveReport(this._savedPath);
        }
    }
}
  • Visual Basic
'SaveReportFile - opens the Save File Dialog to save the report out to an rpx file
Private Sub SaveReportFile()
    'If the Report was saved once, we already have a valid path, call Save on it.
    If Me._alreadySaved Then
        Me.ardMain.SaveReport(Me._savedPath)
    Else
        'Open Save dialog to retrieve a file and path to save to
        Me.dlgSaveFile.Filter = "ActiveReport Report Design (RPX) (*.rpx)|*.rpx"
        Me.dlgSaveFile.FileName = "Report.rpx"
        Me.dlgSaveFile.FilterIndex = 2
        Me.dlgSaveFile.RestoreDirectory = True
        Me.dlgSaveFile.DefaultExt = ".rpx"

        If dlgSaveFile.ShowDialog() = DialogResult.OK Then
            'Add new saved report to the recent documents cache
            If System.IO.File.Exists((Application.StartupPath + "\Settings\recent.xml")) Then
                Dim _reportsDS As New DataSet()
                _reportsDS.Locale = CultureInfo.InvariantCulture
                _reportsDS.ReadXml((Application.StartupPath + "\Settings\recent.xml"))
                Dim _reportsTable As DataTable = _reportsDS.Tables("Reports")
                _reportsTable.Locale = CultureInfo.InvariantCulture

                'Create a Row
                Dim _rowReports As DataRow = _reportsTable.NewRow()
                Dim _myArray(1) As Object
                Me._savedPath = Me.dlgSaveFile.FileName
                _myArray(0) = Me.dlgSaveFile.FileName
                _myArray(1) = System.DateTime.Now
                _rowReports.ItemArray = _myArray
                _reportsTable.Rows.Add(_rowReports)
                _reportsDS.WriteXml(Application.StartupPath + "\Settings\recent.xml", XmlWriteMode.WriteSchema)
            End If
            Me.ardMain.SaveReport(Me._savedPath)
        End If
    End If
End Sub 'SaveReportFile
See Also

Reference

Designer Class
Designer Members
Overload List


SaveReport(Stream) Method

SaveReport(Stream) Method
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > SaveReport Method : SaveReport(Stream) Method
Specifies the Stream object to contain the report layout.
Saves a report layout as an XML file to the specified Stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SaveReport( _
   ByVal stream As System.IO.Stream _
)
public void SaveReport(
   System.IO.Stream stream
)

Parameters

stream
Specifies the Stream object to contain the report layout.
Example
  • C#
/// <summary>
/// SetReportViaStream - sets a report design stream to the Designer
/// </summary>
/// <param name="memStream">Report Memory Stream to set to the designer</param>
public System.IO.Stream ReportViaStream
{
    set
    {
        this.ardMain.LoadReport(value);
    }
    get
    {
        System.IO.Stream _stream = new System.IO.MemoryStream();
        this.ardMain.SaveReport(_stream);
        _stream.Position = 0;
        return _stream;
    }
}
  • Visual Basic
'SetReportViaStream - sets a report design stream to the Designer
'Parameter Name: memStream - Report Memory Stream to set to the designer
Public Property ReportViaStream() As System.IO.Stream
    Get
        Dim _stream As New System.IO.MemoryStream()
        Me.ardMain.SaveReport(_stream)
        _stream.Position = 0
        Return _stream
    End Get
    Set(ByVal Value As System.IO.Stream)
        Me.ardMain.LoadReport(Value)
    End Set
End Property
See Also

Reference

Designer Class
Designer Members
Overload List


SaveReport(XmlWriter) Method

SaveReport(XmlWriter) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > SaveReport Method : SaveReport(XmlWriter) Method
The writer used to save the report.
Saves a report XML layout to the writer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SaveReport( _
   ByVal writer As System.Xml.XmlWriter _
)
public void SaveReport(
   System.Xml.XmlWriter writer
)

Parameters

writer
The writer used to save the report.
See Also

Reference

Designer Class
Designer Members
Overload List


SaveReportToServer Method

SaveReportToServer Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SaveReportToServer Method
Save report to active reports server
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SaveReportToServer()
public void SaveReportToServer()
See Also

Reference

Designer Class
Designer Members


SectionAt Method

SectionAt Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SectionAt Method
Screen point.
Returns the section at the specified point.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function SectionAt( _
   ByVal point As Point _
) As System.Object
public System.object SectionAt(
   Point point
)

Parameters

point
Screen point.

Return Value

object
See Also

Reference

Designer Class
Designer Members


Designer Class Properties

Designer Class Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : Designer Class

For a list of all members of this type, see Designer members.

Public Properties
 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | ColorTheme | Gets or sets the colors of the report designer's section bands and ruler.
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DesignerUnits | Gets or sets the measurement units for the designer.
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | DrawGrid | Gets or sets a value indicating whether a grid is drawn in the designer.
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | EnableOleObject | Enable or disable the OleObject control in the Visual Studio Toolbox.
Public Property | EnablePreview | Gets or sets a value determining whether the preview tab on the Designer control is enabled or disabled.
Public Property | EnableScripting | Sets or returns a value indicating whether scripting is enabled for the designer.
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | GridMode | Gets or sets the GridMode in the designer.
Public Property | GridX | Determines how coarse the designer grid should be.
Public Property | GridY | Determines how coarse the designer grid should be.
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutMode | Gets or sets the value that determines how the end user can lay out controls on the report design surface.
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | LockControls | Specifies whether the controls are locked in place.
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | PreviewPages | Gets or sets the number of pages of report that should be generated for preview.
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | PromptUser | Determines whether to display a dialog when a control is deleted.
Public Property | PropertyGrid | Attaches a System.Windows.Forms.PropertyGrid to the designer to display the properties of an item selected within the designer.
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Report | Returns a reference to the designer's report object.
Public Property | ReportPartsDirectory | Gets or sets the path to load reports in to the report items library. By default it's current user's Documents folder.
Public Property | ReportTabsVisible | Sets or returns a value indicating whether the report tabs are shown below the designer.
Public Property | ReportType | Temporary report type indicator. Used by Report Explorer and (potentially) by Toolbox.
Public Property | ResourceLocator | Gets or sets the resource locator implementation that used to locate the custom resources.
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | Selection | Returns the collection of selected objects.
Public Property | ShowDataSourceIcon | Specifies whether the Datasource icon will be visible on the detail section bar to allow the user to modify the report's data source settings.
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | SnapGrid | Sets or returns a value indicating whether the controls should be snapped to the grid points.
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Toolbox | Gets or Sets the IToolboxService for the Report Designer.
Public Property | ToolBoxItem | Sets the type of control in the toolbox.
Public Property | ToolPanel | Gets or sets the value that indicate the tools that are available in the designer tool panel.
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | UndoManager | The UndoManager allows users to undo and redo changes.
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Public Property | Zoom | Gets or sets the zoom value for the Designer.
Top
See Also

Reference

Designer Class
GrapeCity.ActiveReports.Design Namespace

Walkthroughs

Creating a Basic End User Report Designer


ColorTheme Property

ColorTheme Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ColorTheme Property
Gets or sets the colors of the report designer's section bands and ruler.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ColorTheme As ColorTheme
public ColorTheme ColorTheme {get; set;}
Remarks

Select an enumerated value for the color theme:

  • Normal
  • SystemTheme
See Also

Reference

Designer Class
Designer Members


DesignerUnits Property

DesignerUnits Property
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DesignerUnits Property
Gets or sets the measurement units for the designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DesignerUnits As MeasurementUnits
public MeasurementUnits DesignerUnits {get; set;}

Property Value

Integer.
Example
  • C#
private void designer1_Load(object sender, System.EventArgs e)
{
    this.designer1.DesignerUnits = GrapeCity.ActiveReports.Design.MeasurementUnits.Inches;
    this.designer1.ToolBoxItem = null;
}
  • Visual Basic
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.Designer1.DesignerUnits = GrapeCity.ActiveReports.Design.MeasurementUnits.Inches
    Me.Designer1.ToolBoxItem = Nothing
End Sub
See Also

Reference

Designer Class
Designer Members
MeasurementUnits Enumeration


DrawGrid Property

DrawGrid Property
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DrawGrid Property
Gets or sets a value indicating whether a grid is drawn in the designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DrawGrid As System.Boolean
public System.bool DrawGrid {get; set;}

Property Value

Boolean value.
Example
  • C#
private void designer1_Load(object sender, System.EventArgs e)
{
    this.designer1.DrawGrid = true;
    this.designer1.GridX = 16;
    this.designer1.GridY = 16;
}
  • Visual Basic
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.Designer1.DrawGrid = True
    Me.Designer1.GridX = 16
    Me.Designer1.GridY = 16
End Sub
See Also

Reference

Designer Class
Designer Members


EnableOleObject Property

EnableOleObject Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : EnableOleObject Property
Enable or disable the OleObject control in the Visual Studio Toolbox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EnableOleObject As System.Boolean
public System.bool EnableOleObject {get; set;}
See Also

Reference

Designer Class
Designer Members


EnablePreview Property

EnablePreview Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : EnablePreview Property
Gets or sets a value determining whether the preview tab on the Designer control is enabled or disabled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EnablePreview As System.Boolean
public System.bool EnablePreview {get; set;}
See Also

Reference

Designer Class
Designer Members


EnableScripting Property

EnableScripting Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : EnableScripting Property
Sets or returns a value indicating whether scripting is enabled for the designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EnableScripting As System.Boolean
public System.bool EnableScripting {get; set;}
See Also

Reference

Designer Class
Designer Members
ReportTabsVisible Property


GridMode Property

GridMode Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : GridMode Property
Gets or sets the GridMode in the designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GridMode As GridMode
public GridMode GridMode {get; set;}
See Also

Reference

Designer Class
Designer Members


GridX Property

GridX Property
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : GridX Property
Determines how coarse the designer grid should be.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GridX As System.Integer
public System.int GridX {get; set;}

Property Value

An integer value that represents the number of horizontal grid points per ruler unit.
Example
  • C#
private void designer1_Load(object sender, System.EventArgs e)
{
    this.designer1.DrawGrid = true;
    this.designer1.GridX = 16;
    this.designer1.GridY = 16;
}
  • Visual Basic
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.Designer1.DrawGrid = True
    Me.Designer1.GridX = 16
    Me.Designer1.GridY = 16
End Sub
See Also

Reference

Designer Class
Designer Members


GridY Property

GridY Property
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : GridY Property
Determines how coarse the designer grid should be.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GridY As System.Integer
public System.int GridY {get; set;}

Property Value

An integer value that represents the number of vertical grid points per ruler unit.
Example
  • C#
private void designer1_Load(object sender, System.EventArgs e)
{
    this.designer1.DrawGrid = true;
    this.designer1.GridX = 16;
    this.designer1.GridY = 16;
}
  • Visual Basic
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.Designer1.DrawGrid = True
    Me.Designer1.GridX = 16
    Me.Designer1.GridY = 16
End Sub
See Also

Reference

Designer Class
Designer Members


LayoutMode Property

LayoutMode Property
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LayoutMode Property
Gets or sets the value that determines how the end user can lay out controls on the report design surface.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LayoutMode As LayoutMode
public LayoutMode LayoutMode {get; set;}
Remarks

Select from an enumerated value:

  • None allows free movement of controls.
  • SnapGrid snaps controls to the grid.
  • SnapLines snaps controls to lines showing alignment to other controls.
Example
  • C#
private void designer1_Load(object sender, System.EventArgs e)
{
    this.designer1.LayoutMode = GrapeCity.ActiveReports.Design.LayoutMode.SnapGrid;
}
  • VB.NET
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.Designer1.LayoutMode = GrapeCity.ActiveReports.Design.LayoutMode.SnapGrid
End Sub
See Also

Reference

Designer Class
Designer Members


LockControls Property

LockControls Property
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LockControls Property
Specifies whether the controls are locked in place.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LockControls As System.Boolean
public System.bool LockControls {get; set;}

Property Value

Boolean value. If True, the controls cannot be moved or sized. If False, the controls can be moved or sized.
Example
  • C#
private void designer1_Load(object sender, System.EventArgs e)
{
    this.designer1.DrawGrid = true;
    this.designer1.GridX = 16;
    this.designer1.GridY = 16;
    this.designer1.LockControls = false;
    this.designer1.ShowDataSourceIcon = true;
    this.designer1.ToolBoxItem = null;
}
  • Visual Basic
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.Designer1.DrawGrid = True
    Me.Designer1.GridX = 16
    Me.Designer1.GridY = 16
    Me.Designer1.LockControls = False
    Me.Designer1.ShowDataSourceIcon = True
    Me.Designer1.ToolBoxItem = Nothing
End Sub
See Also

Reference

Designer Class
Designer Members


PreviewPages Property (Designer)

PreviewPages Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PreviewPages Property
Gets or sets the number of pages of report that should be generated for preview.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PreviewPages As System.Integer
public System.int PreviewPages {get; set;}
Remarks
Note: This property does not determine the total number of pages generated when the report is run to completion. If this value is set to 0, all pages of the report is generated.
See Also

Reference

Designer Class
Designer Members


PromptUser Property (Designer)

PromptUser Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PromptUser Property
Determines whether to display a dialog when a control is deleted.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PromptUser As System.Boolean
public System.bool PromptUser {get; set;}
Remarks
If set to true, the dialog is presented when a control is deleted at report design time.
See Also

Reference

Designer Class
Designer Members


PropertyGrid Property

PropertyGrid Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PropertyGrid Property
Attaches a System.Windows.Forms.PropertyGrid to the designer to display the properties of an item selected within the designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PropertyGrid As System.Windows.Forms.PropertyGrid
public System.Windows.Forms.PropertyGrid PropertyGrid {get; set;}
See Also

Reference

Designer Class
Designer Members


Report Property (Designer)

Report Property (Designer)
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Report Property
Returns a reference to the designer's report object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Report As System.Object
public System.object Report {get; set;}

Property Value

ActiveReport

Remarks
This report object is used to gain access to the layout and controls properties.
Example
  • C#
public object NewReport(string name)
{
    try
    {
     this.ardMain.NewReport();
      GrapeCity.ActiveReports.SectionReport rpt = (GrapeCity.ActiveReports.SectionReport)this.ardMain.Report;
      rpt.Document.Name = name;
      return this.ardMain.Report;
     }

    catch(GrapeCity.ActiveReports.ReportException)
    {
        MessageBox.Show("Error occurred while creating new report", "Error in Diamond Reports");
        return null;
    }

}
  • Visual Basic
Public Function NewReport(ByVal name As String) As Object Implements IPlugInHost.NewReport
    Try
        Me.ardMain.NewReport()
        Me.ardMain.Report.Document.Name = name
        Return Me.ardMain.Report
    Catch ex As GrapeCity.ActiveReports.ReportException
        MessageBox.Show("Error occurred while creating new report", "Error in Diamond Reports")
        Return Nothing
    End Try
End Function
See Also

Reference

Designer Class
Designer Members


ReportPartsDirectory Property

ReportPartsDirectory Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ReportPartsDirectory Property
Gets or sets the path to load reports in to the report items library. By default it's current user's Documents folder.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportPartsDirectory As System.String
public System.string ReportPartsDirectory {get; set;}
See Also

Reference

Designer Class
Designer Members


ReportTabsVisible Property

ReportTabsVisible Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ReportTabsVisible Property
Sets or returns a value indicating whether the report tabs are shown below the designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportTabsVisible As System.Boolean
public System.bool ReportTabsVisible {get; set;}
Remarks
The report tabs allow the user to choose between the preview, the script view and the designer view.
See Also

Reference

Designer Class
Designer Members
EnableScripting Property


ReportType Property

ReportType Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ReportType Property
Temporary report type indicator. Used by Report Explorer and (potentially) by Toolbox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ReportType As DesignerReportType
public DesignerReportType ReportType {get;}
See Also

Reference

Designer Class
Designer Members


ResourceLocator Property (Designer)

ResourceLocator Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ResourceLocator Property
Gets or sets the resource locator implementation that used to locate the custom resources.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ResourceLocator As ResourceLocator
public ResourceLocator ResourceLocator {get; set;}
See Also

Reference

Designer Class
Designer Members


Selection Property

Selection Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Selection Property
Returns the collection of selected objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Selection As Selection
public Selection Selection {get;}
See Also

Reference

Designer Class
Designer Members


ShowDataSourceIcon Property

ShowDataSourceIcon Property
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ShowDataSourceIcon Property
Specifies whether the Datasource icon will be visible on the detail section bar to allow the user to modify the report's data source settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShowDataSourceIcon As System.Boolean
public System.bool ShowDataSourceIcon {get; set;}

Property Value

Boolean. If True, the data source icon will be visible; otherwise, False.

Remarks
You can use this property to hide the Data Source icon and provide your own interface for manipulating the report's data source.
Example
  • C#
private void designer1_Load(object sender, System.EventArgs e)
{
    this.designer1.ShowDataSourceIcon = false;
}
  • Visual Basic
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.Designer1.ShowDataSourceIcon = False
End Sub
See Also

Reference

Designer Class
Designer Members


SnapGrid Property

SnapGrid Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SnapGrid Property
Sets or returns a value indicating whether the controls should be snapped to the grid points.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SnapGrid As System.Boolean
public System.bool SnapGrid {get; set;}

Property Value

Boolean value. If True, the controls are snapped to the grid points. If False, the controls can be sized and positioned freely.
See Also

Reference

Designer Class
Designer Members


Toolbox Property

Toolbox Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Toolbox Property
Gets or Sets the IToolboxService for the Report Designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Toolbox As System.Drawing.Design.IToolboxService
public System.Drawing.Design.IToolboxService Toolbox {get; set;}
See Also

Reference

Designer Class
Designer Members


ToolBoxItem Property

ToolBoxItem Property
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ToolBoxItem Property
Sets the type of control in the toolbox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ToolBoxItem As System.Object
public System.object ToolBoxItem {get; set;}
Remarks
This property is used to implement a custom toolbox toolbar.
Example
  • C#
private GrapeCity.ActiveReports.Design.Toolbox.Toolbox arToolbox;
private void formDesigner_Load(object sender, System.EventArgs e)
{
    this.arDesigner.Toolbox = this.arToolbox;
    System.Drawing.Design.ToolboxItem tbItem = new System.Drawing.Design.ToolboxItem(typeof(GrapeCity.ActiveReports.Viewer.Win.Viewer));
    this.arToolbox.AddToolboxItem(tbItem, "General");
}
  • Visual Basic
Private arToolbox As GrapeCity.ActiveReports.Design.Toolbox.Toolbox
Private Sub formDesigner_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
    Me.arDesigner.Toolbox = Me.arToolbox
    Dim tbItem As System.Drawing.Design.ToolboxItem = New System.Drawing.Design.ToolboxItem(GetType(GrapeCity.ActiveReports.Viewer.Win.Viewer))
    arToolbox.AddToolboxItem(tbItem, "General")
End Sub
See Also

Reference

Designer Class
Designer Members


ToolPanel Property

ToolPanel Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ToolPanel Property
Gets or sets the value that indicate the tools that are available in the designer tool panel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ToolPanel As ToolPanelButton
public ToolPanelButton ToolPanel {get; set;}
See Also

Reference

Designer Class
Designer Members


UndoManager Property

UndoManager Property
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : UndoManager Property
The UndoManager allows users to undo and redo changes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property UndoManager As UndoManager
public UndoManager UndoManager {get;}
Example
  • C#
private void mnuEditUndo_Click(object sender, System.EventArgs e)
{
    this.ardMain.UndoManager.Undo();
}
  • Visual Basic
'mnuEditUndo_Click - calls the UndoManager.Undo command from the Designer
Private Sub mnuEditUndo_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles mnuEditUndo.Click
    Me.ardMain.UndoManager.Undo()
End Sub 'mnuEditUndo_Click
See Also

Reference

Designer Class
Designer Members


Zoom Property (Designer)

Zoom Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Zoom Property
Gets or sets the zoom value for the Designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Zoom As System.Single
public System.float Zoom {get; set;}
Remarks
Values can range from >= 1.0f to <= 8.0f.
See Also

Reference

Designer Class
Designer Members


Designer Class Events

Designer Class Events

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : Designer Class

For a list of all members of this type, see Designer members.

Public Events
 | Name | Description
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | ChartDataSourceClicked | Fires after a chart data source item has been clicked.
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuOpen | Fires before a context menu is opened.
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DataSourceIconClick | Raised when the Datasource icon is clicked in the designer.
Public Event | DataSourceIconClicked | Gets the value from the DialogResult when the data source icon is clicked.
Public Event | DesignerTabChanged | Raised when the designer tab changes.
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EditModeEntering | This event occurs when the end user clicks inside a TextBox, Label, CheckBox or RichTextBox control in the End User Designer and enters edit mode.
Public Event | EditModeExit | This event occurs when an end user leaves edit mode in a TextBox, Label, CheckBox or RichTextBox control in the End User Designer.
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | LayoutChanged | Raised when the layout is changed.
Public Event | LayoutChanging | Raised when the layout is changing and passes the sender a new EventArgs class called LayoutChangingArgs.
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.UserControl)
Public Event | LocateCredentials | Occurs when the report is previewed and credentials are needed.
Public Event | LocateDataSource | Occurs when a data provider of the previewed report needs to locate the data at runtime.
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ScriptChanged | Raised when the script for a report in the End User Report Designer is changed.
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SelectionChanged | Raised when the selection changes.
Public Event | ServerConnectionChanged | Raises ServerConnectionChanged event. Occurs after changing connection to ActiveReports Server.
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StatusChanged | This event is raised for each change in the status of the designer actions.
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ToolboxItemChanged | Raised when a toolbox control is drawn on the Report Designer.
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

Designer Class
GrapeCity.ActiveReports.Design Namespace

Walkthroughs

Creating a Basic End User Report Designer


ChartDataSourceClicked Event

ChartDataSourceClicked Event
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ChartDataSourceClicked Event
Fires after a chart data source item has been clicked.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ChartDataSourceClicked As System.EventHandler(Of ChartDataSourceClickedEventArgs)
public event System.EventHandler<ChartDataSourceClickedEventArgs> ChartDataSourceClicked
Event Data

The event handler receives an argument of type ChartDataSourceClickedEventArgs containing data related to this event. The following ChartDataSourceClickedEventArgs properties provide information specific to this event.

Property | Description
Cancel | Indicates that the default action should be skipped.
Chart | Provides access to the control.
Example
  • Visual Basic
'Disable the Chart DataSource dialog
Private Sub arDesigner_ChartDataSourceClicked(ByVal sender As System.Object, ByVal e As GrapeCity.ActiveReports.Design.ChartDataSourceClickedEventArgs) Handles arDesigner.ChartDataSourceClicked
    e.Cancel = True
    System.Windows.Forms.MessageBox.Show("The chart datasource can not be changed!")
End Sub
  • C#
//Disable the Chart DataSource dialog
void arDesigner_ChartDataSourceClicked(object sender, ChartDataSourceClickedEventArgs e)
{
    e.Cancel = true;
    System.Windows.Forms.MessageBox.Show("The chart datasource can not be changed!");
}
See Also

Reference

Designer Class
Designer Members


ContextMenuOpen Event

ContextMenuOpen Event

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ContextMenuOpen Event
Fires before a context menu is opened.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ContextMenuOpen As ContextMenuOpenEventHandler
public event ContextMenuOpenEventHandler ContextMenuOpen
See Also

Reference

Designer Class
Designer Members


DataSourceIconClick Event

DataSourceIconClick Event

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DataSourceIconClick Event
Raised when the Datasource icon is clicked in the designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DataSourceIconClick As DataSourceIconClickEventHandler
public event DataSourceIconClickEventHandler DataSourceIconClick
Event Data

The event handler receives an argument of type DataSourceIconClickEventArgs containing data related to this event. The following DataSourceIconClickEventArgs properties provide information specific to this event.

Property | Description
Cancel | Determines whether the default DataSource dialog is displayed. If the value is set to True, the DataSource dialog will not open when the DataSource Icon is clicked in the End-User Designer.
See Also

Reference

Designer Class
Designer Members


DataSourceIconClicked Event

DataSourceIconClicked Event

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DataSourceIconClicked Event
Gets the value from the DialogResult when the data source icon is clicked.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DataSourceIconClicked As DataSourceIconClickedEventHandler
public event DataSourceIconClickedEventHandler DataSourceIconClicked
Event Data

The event handler receives an argument of type DataSourceIconClickedEventArgs containing data related to this event. The following DataSourceIconClickedEventArgs properties provide information specific to this event.

Property | Description
DialogResult | Gets the value from the data source dialog.
See Also

Reference

Designer Class
Designer Members


DesignerTabChanged Event

DesignerTabChanged Event

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DesignerTabChanged Event
Raised when the designer tab changes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DesignerTabChanged As DesignerTabChangedEventHandler
public event DesignerTabChangedEventHandler DesignerTabChanged
Event Data

The event handler receives an argument of type DesignerTabChangedEventArgs containing data related to this event. The following DesignerTabChangedEventArgs properties provide information specific to this event.

Property | Description
ActiveTab | Gets the DesignerTab enumeration that indicates what tab is currently active.
See Also

Reference

Designer Class
Designer Members


EditModeEntering Event

EditModeEntering Event
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : EditModeEntering Event
This event occurs when the end user clicks inside a TextBox, Label, CheckBox or RichTextBox control in the End User Designer and enters edit mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event EditModeEntering As EditModeEnteringEventHandler
public event EditModeEnteringEventHandler EditModeEntering
Event Data

The event handler receives an argument of type EditModeEnteringEventArgs containing data related to this event. The following EditModeEnteringEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether to cancel edit mode for the control.
Control | Gets the type of control that enters edit mode.
Example
This code allows you to disable edit mode for the TextBox control.
  • C#
private void arDesigner_EditModeEntering(object sender, EditModeEnteringEventArgs e)
        {
            if (e.Control is GrapeCity.ActiveReports.SectionReportModel.TextBox)
            {
                e.Cancel = true;
            }
        }
This code allows you to disable edit mode for the TextBox control.
  • Visual Basic
Private Sub arDesigner_EditModeEntering(ByVal sender As System.Object, ByVal e As GrapeCity.ActiveReports.Design.EditModeEnteringEventArgs) Handles arDesigner.EditModeEntering
        If Typeof e.Control Is GrapeCity.ActiveReports.SectionReportModel.TextBox Then
            e.Cancel = True
        End If
    End Sub
See Also

Reference

Designer Class
Designer Members


EditModeExit Event

EditModeExit Event
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : EditModeExit Event
This event occurs when an end user leaves edit mode in a TextBox, Label, CheckBox or RichTextBox control in the End User Designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event EditModeExit As EditModeExitEventHandler
public event EditModeExitEventHandler EditModeExit
Event Data

The event handler receives an argument of type EditModeExitEventArgs containing data related to this event. The following EditModeExitEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the type of control that is exiting edit mode.
Type | Gets the exit type.
Example
  • C#
private void arDesigner_EditModeExit(object sender, EditModeExitEventArgs e)
        {
            string a=((GrapeCity.ActiveReports.SectionReportModel.ARControl)e.Control).Name;
            if (e.Type == ExitType.Save && a == "txtDocumentOwner")
            {
                // save the new value of textbox control in the temporary field
                _global_do = (e.Control as TextBox).Text;
            }
        }
  • Visual Basic
Private Sub arDesigner_EditModeExit(ByVal sender As System.Object, ByVal e As GrapeCity.ActiveReports.Design.EditModeExitEventArgs) Handles arDesigner.EditModeExit
        If (e.Type = ExitType.Save) And (((GrapeCity.ActiveReports.SectionReportModel.ARControl)e.Control).Name = "txtDocumentOwner") Then
            ' save the new value of textbox control in the temporary field
            _global_do = CType(e.Control, TextBox).Text
        End If
    End Sub
See Also

Reference

Designer Class
Designer Members


LayoutChanged Event

LayoutChanged Event
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LayoutChanged Event
Raised when the layout is changed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LayoutChanged As LayoutChangedEventHandler
public event LayoutChangedEventHandler LayoutChanged
Remarks
You can use this event to monitor changes to the report layout and update any dependent data such as SQL queries or custom user interfaces (report explorers, group sections dialog, etc).
Example
  • C#
// ardMain_LayoutChanged - runs when a control/section in the layout is added/deleted/moved

private void ardMain_LayoutChanged(object sender, GrapeCity.ActiveReports.Design.LayoutChangedArgs e)
{
    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.ControlAdd)  //Control Added
    {
        this._controlAdded = true;
        ResetToolbox();
        tbToolbox.Buttons[0].Pushed = true;
    }
    else
    {
        this._controlAdded = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.ControlDelete)  //Control Deleted
    {
        this._controlDeleted = true;
    }
    else
    {
        this._controlDeleted = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.SectionAdd)  //Section Added
    {
        this._sectionAdded = true;
    }
    else
    {
        this._sectionAdded = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.SectionDelete)  //Section Deleted
    {
        this._sectionDeleted = true;
    }
    else
    {
        this._sectionDeleted = false;
    }
}
  • Visual Basic
'ardMain_LayoutChanged - runs when a control/section in the layout is added/deleted/moved
Private Sub ardMain_LayoutChanged(ByVal sender As Object, ByVal e As GrapeCity.ActiveReports.Design.LayoutChangedArgs) Handles ardMain.LayoutChanged
    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.ControlAdd Then 'Control Added
        Me._controlAdded = True
        ResetToolbox()
        tbToolbox.Buttons(0).Pushed = True
    Else
        Me._controlAdded = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.ControlDelete Then 'Control Deleted
        Me._controlDeleted = True
    Else
        Me._controlDeleted = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.SectionAdd Then 'Section Added
        Me._sectionAdded = True
    Else
        Me._sectionAdded = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.SectionDelete Then 'Section Deleted
        Me._sectionDeleted = True
    Else
        Me._sectionDeleted = False
    End If
End Sub
See Also

Reference

Designer Class
Designer Members


LayoutChanging Event

LayoutChanging Event
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LayoutChanging Event
Raised when the layout is changing and passes the sender a new EventArgs class called LayoutChangingArgs.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LayoutChanging As LayoutChangingEventHandler
public event LayoutChangingEventHandler LayoutChanging
Example
  • Visual Basic
Private Sub ardMain_LayoutChanging(ByVal sender As Object, ByVal e As Design.LayoutChangingArgs) Handles ardMain.LayoutChanging
    If e.Type = Design.LayoutChangeType.SectionDelete Then
        Dim Result As DialogResult
        Result = MessageBox.Show("Are you sure you want to delete this section?", "Delete?", MessageBoxButtons.OKCancel, MessageBoxIcon.Question, MessageBoxDefaultButton.Button1)
        If Result = DialogResult.Cancel Then
            e.AllowChange = False
        Else
            e.AllowChange = True
        End If
    End If
End Sub
  • C#
private void ardMain_LayoutChanging(object sender, GrapeCity.ActiveReports.Design.LayoutChangingArgs e)
{
    if (e.Type == Design.LayoutChangeType.SectionDelete)
    {
        DialogResult Result;
        Result = MessageBox.Show("Are you sure you want to delete this section?", "Delete?", MessageBoxButtons.OKCancel, MessageBoxIcon.Question, MessageBoxDefaultButton.Button1);
        if (Result == DialogResult.Cancel)
        {
            e.AllowChange = false;
        }
        else
        {
            e.AllowChange = true;
        }
    }
}
See Also

Reference

Designer Class
Designer Members


LocateCredentials Event (Designer)

LocateCredentials Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LocateCredentials Event
Occurs when the report is previewed and credentials are needed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LocateCredentials As LocateCredentialsEventHandler
public event LocateCredentialsEventHandler LocateCredentials
Event Data

The event handler receives an argument of type LocateCredentialsEventArgs containing data related to this event. The following LocateCredentialsEventArgs properties provide information specific to this event.

Property | Description
DataSourceName | Gets the name of the data source to locate credentials for.
Password | Gets ot sets the password of the credentials to be located.
PromptText | Gets the text of prompt of the locate credentials request.
ReportPath | Gets the name of the report to locate credentials for.
UserName | Gets ot sets the user name of the credentials to be located.
See Also

Reference

Designer Class
Designer Members


LocateDataSource Event (Designer)

LocateDataSource Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LocateDataSource Event
Occurs when a data provider of the previewed report needs to locate the data at runtime.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LocateDataSource As LocateDataSourceEventHandler
public event LocateDataSourceEventHandler LocateDataSource
Event Data

The event handler receives an argument of type LocateDataSourceEventArgs containing data related to this event. The following LocateDataSourceEventArgs properties provide information specific to this event.

Property | Description
Data | The data returned by the event handler.
DataSetName | Gets the name of data set to be located.
DataSourceName | Gets the name of data source that contains the data set to be located.
Report | Gets the Report that is trying to locate the data set.
See Also

Reference

Designer Class
Designer Members


ScriptChanged Event

ScriptChanged Event

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ScriptChanged Event
Raised when the script for a report in the End User Report Designer is changed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ScriptChanged As ScriptChangedEventHandler
public event ScriptChangedEventHandler ScriptChanged
Remarks
This event is raised when the user switches from the Design view to the Script view of the report. It is not raised by changes to the script.
See Also

Reference

Designer Class
Designer Members


SelectionChanged Event (Designer)

SelectionChanged Event (Designer)
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SelectionChanged Event
Raised when the selection changes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event SelectionChanged As SelectionChangedEventHandler
public event SelectionChangedEventHandler SelectionChanged
Remarks
You can use the Selection property to inspect the current selection.
Example
  • C#
// ardMain_SelectionChanged - runs when a control/section in the layout is selected

private void ardMain_SelectionChanged()
{
    //Update the property grid with the new control/section properties
    this.SelChangePropGrid();

    if(this._controlAdded)  //Control is newly added
    {
        //Add item to ComboBox and PropGrid
        this._isCboDirty = true;
        this._controlAdded = false;
    }

    if(this._controlDeleted)  //Control is newly deleted
    {
        this._isCboDirty = true;
    }

    if(this._sectionAdded)  //Section is newly added
    {
        this._isCboDirty = true;
    }

    if(this._sectionDeleted)  //Section is newly deleted
    {
        this._isCboDirty = true;
    }
}
  • Visual Basic
'ardMain_SelectionChanged - runs when a control/section in the layout is selected
Private Sub ardMain_SelectionChanged() Handles ardMain.SelectionChanged
    'Update the property grid with the new control/section properties
    Me.SelChangePropGrid()

    If Me._controlAdded Then 'Control is newly added
        'Add item to ComboBox and PropGrid
        Me._isCboDirty = True
        Me._controlAdded = False
    End If

    If Me._controlDeleted Then 'Control is newly deleted
        Me._isCboDirty = True
    End If

    If Me._sectionAdded Then 'Section is newly added
        Me._isCboDirty = True
    End If

    If Me._sectionDeleted Then 'Section is newly deleted
        Me._isCboDirty = True
    End If
End Sub 'ardMain_SelectionChanged
See Also

Reference

Designer Class
Designer Members

Walkthroughs

Creating a Basic End User Report Designer


ServerConnectionChanged Event

ServerConnectionChanged Event

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ServerConnectionChanged Event
Raises ServerConnectionChanged event. Occurs after changing connection to ActiveReports Server.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ServerConnectionChanged As ServerConnectionChangedEventHandler
public event ServerConnectionChangedEventHandler ServerConnectionChanged
Event Data

The event handler receives an argument of type ServerConnectionChangedEventArgs containing data related to this event. The following ServerConnectionChangedEventArgs properties provide information specific to this event.

Property | Description
Connected | Gets the connection state.
ServerUrl | Gets the server URL.
See Also

Reference

Designer Class
Designer Members


StatusChanged Event

StatusChanged Event
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : StatusChanged Event
This event is raised for each change in the status of the designer actions.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event StatusChanged As StatusChangedEventHandler
public event StatusChangedEventHandler StatusChanged
Remarks
Designer actions represent the commands that are typically invoked from UI elements such as a toolbar or a menu. You can use the QueryAction methods to check the status of the changed action and update your custom UI elements.
Example
  • C#
// ardMain_StatusChanged - runs with the status of the Designer has changed
// (button is pressed)

private void ardMain_StatusChanged(object sender, System.EventArgs e)
{
    for(int i=0;i<this.tbAlign.Buttons.Count;i++)
    {
        System.Windows.Forms.ToolBarButton tb = this.tbAlign.Buttons[i];
        if(tb.Tag != null)
        {
            //If Alignment toolbar button is pressed, call SetStatus()
            SetStatus (tb.Tag.ToString(),tb);
        }
    }
    for(int i=0;i<this.tbFormat.Buttons.Count;i++)
    {
        System.Windows.Forms.ToolBarButton tb = this.tbFormat.Buttons[i];
        if(tb.Tag != null)
        {
            //if Format toolbar button is pressed, call SetStatus()
            SetStatus (tb.Tag.ToString(),tb);
        }
    }

    //Update Menus and other toolbars
    StatusStandardToolbar();
    UpdateFormatMenus();
}
  • Visual Basic
'ardMain_StatusChanged - runs with the status of the Designer has changed
'(button is pressed)
Private Sub ardMain_StatusChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles ardMain.StatusChanged
    Dim i As Integer
    For i = 0 To (Me.tbAlign.Buttons.Count) - 1
        Dim tb As System.Windows.Forms.ToolBarButton = Me.tbAlign.Buttons(i)
        If Not (tb.Tag Is Nothing) Then
            'If Alignment toolbar button is pressed, call SetStatus()
            SetStatus(tb.Tag.ToString(), tb)
        End If
    Next i

    For i = 0 To (Me.tbFormat.Buttons.Count) - 1
        Dim tb As System.Windows.Forms.ToolBarButton = Me.tbFormat.Buttons(i)
        If Not (tb.Tag Is Nothing) Then
            'if Format toolbar button is pressed, call SetStatus()
            SetStatus(tb.Tag.ToString(), tb)
        End If
    Next i

    'Update Menus and other toolbars
    StatusStandardToolbar()
    UpdateFormatMenus()
End Sub 'ardMain_StatusChanged
See Also

Reference

Designer Class
Designer Members

Walkthroughs

Creating a Basic End User Report Designer


ToolboxItemChanged Event

ToolboxItemChanged Event

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ToolboxItemChanged Event
Raised when a toolbox control is drawn on the Report Designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ToolboxItemChanged As ToolboxItemChangedEventHandler
public event ToolboxItemChangedEventHandler ToolboxItemChanged
See Also

Reference

Designer Class
Designer Members


DesignerTabChangedEventArgs Class

DesignerTabChangedEventArgs Class
Members

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : DesignerTabChangedEventArgs Class
Contains the active tab information.
Object Model
DesignerTabChangedEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DesignerTabChangedEventArgs
   Inherits System.EventArgs
public sealed class DesignerTabChangedEventArgs : System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.DesignerTabChangedEventArgs

See Also

Reference

DesignerTabChangedEventArgs Members
GrapeCity.ActiveReports.Design Namespace


DesignerTabChangedEventArgs Class Members

DesignerTabChangedEventArgs Class Members
Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : DesignerTabChangedEventArgs Class

The following tables list the members exposed by DesignerTabChangedEventArgs.

Public Properties
 | Name | Description
Public Property | ActiveTab | Gets the DesignerTab enumeration that indicates what tab is currently active.
Top
See Also

Reference

DesignerTabChangedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


DesignerTabChangedEventArgs Class Properties

DesignerTabChangedEventArgs Class Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : DesignerTabChangedEventArgs Class

For a list of all members of this type, see DesignerTabChangedEventArgs members.

Public Properties
 | Name | Description
Public Property | ActiveTab | Gets the DesignerTab enumeration that indicates what tab is currently active.
Top
See Also

Reference

DesignerTabChangedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


ActiveTab Property

ActiveTab Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > DesignerTabChangedEventArgs Class : ActiveTab Property
Gets the DesignerTab enumeration that indicates what tab is currently active.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ActiveTab As DesignerTab
public DesignerTab ActiveTab {get;}
See Also

Reference

DesignerTabChangedEventArgs Class
DesignerTabChangedEventArgs Members


EditModeEnteringEventArgs Class

EditModeEnteringEventArgs Class
Members Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : EditModeEnteringEventArgs Class
This class retrieves the type of control to be edited when the user enters edit mode, allowing you to cancel editing for specified types of controls.
Object Model
EditModeEnteringEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class EditModeEnteringEventArgs
   Inherits System.EventArgs
public sealed class EditModeEnteringEventArgs : System.EventArgs
Remarks

Edit mode applies to the following types of controls:

  • RichTextBox
  • TextBox
  • CheckBox
  • Label
Example
  • Visual Basic
Private Sub arDesigner_EditModeEntering(ByVal sender As System.Object, ByVal e As GrapeCity.ActiveReports.Design.EditModeEnteringEventArgs) Handles arDesigner.EditModeEntering
        If Typeof e.Control Is GrapeCity.ActiveReports.SectionReportModel.TextBox Then
            e.Cancel = True
        End If
    End Sub
  • C#
private void arDesigner_EditModeEntering(object sender, EditModeEnteringEventArgs e)
        {
            if (e.Control is GrapeCity.ActiveReports.SectionReportModel.TextBox)
            {
                e.Cancel = true;
            }
        }
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.EditModeEnteringEventArgs

See Also

Reference

EditModeEnteringEventArgs Members
GrapeCity.ActiveReports.Design Namespace


EditModeEnteringEventArgs Class Members

EditModeEnteringEventArgs Class Members
Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : EditModeEnteringEventArgs Class

The following tables list the members exposed by EditModeEnteringEventArgs.

Public Constructors
 | Name | Description
Public Constructor | EditModeEnteringEventArgs Constructor | Initializes a new instance of the EditModeEnteringEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether to cancel edit mode for the control.
Public Property | Control | Gets the type of control that enters edit mode.
Top
See Also

Reference

EditModeEnteringEventArgs Class
GrapeCity.ActiveReports.Design Namespace


EditModeEnteringEventArgs Constructor

EditModeEnteringEventArgs Constructor

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > EditModeEnteringEventArgs Class : EditModeEnteringEventArgs Constructor

The type of control that is entering edit mode.

Initializes a new instance of the EditModeEnteringEventArgs class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal control As System.Object _
)
public EditModeEnteringEventArgs(
   System.object control
)

Parameters

control

The type of control that is entering edit mode.

See Also

Reference

EditModeEnteringEventArgs Class
EditModeEnteringEventArgs Members


EditModeEnteringEventArgs Class Properties

EditModeEnteringEventArgs Class Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : EditModeEnteringEventArgs Class

For a list of all members of this type, see EditModeEnteringEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether to cancel edit mode for the control.
Public Property | Control | Gets the type of control that enters edit mode.
Top
See Also

Reference

EditModeEnteringEventArgs Class
GrapeCity.ActiveReports.Design Namespace


Cancel Property (EditModeEnteringEventArgs)

Cancel Property (EditModeEnteringEventArgs)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > EditModeEnteringEventArgs Class : Cancel Property
Gets or sets a value indicating whether to cancel edit mode for the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Cancel As System.Boolean
public System.bool Cancel {get; set;}
See Also

Reference

EditModeEnteringEventArgs Class
EditModeEnteringEventArgs Members


Control Property (EditModeEnteringEventArgs)

Control Property (EditModeEnteringEventArgs)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > EditModeEnteringEventArgs Class : Control Property
Gets the type of control that enters edit mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Control As System.Object
public System.object Control {get;}
See Also

Reference

EditModeEnteringEventArgs Class
EditModeEnteringEventArgs Members


EditModeExitEventArgs Class

EditModeExitEventArgs Class
Members Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : EditModeExitEventArgs Class
This class retrieves the type of control edited when the user exits edit mode.
Object Model
EditModeExitEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class EditModeExitEventArgs
   Inherits System.EventArgs
public sealed class EditModeExitEventArgs : System.EventArgs
Remarks

Edit mode applies to the following types of controls:

  • RichTextBox
  • TextBox
  • CheckBox
  • Label
Example
  • C#
private void arDesigner_EditModeExit(object sender, EditModeExitEventArgs e)
        {
            if (e.Control is GrapeCity.ActiveReports.SectionReportModel.Label)
            {
                (e.Control as GrapeCity.ActiveReports.SectionReportModel.Label).Text = "Trial version!";
            }
        }
  • Visual Basic
Private Sub arDesigner_EditModeExit(ByVal sender As System.Object, ByVal e As GrapeCity.ActiveReports.Design.EditModeExitEventArgs) Handles arDesigner.EditModeExit
        If Typeof e.Control Is GrapeCity.ActiveReports.SectionReportModel.Label Then
            CType(e.Control, GrapeCity.ActiveReports.SectionReportModel.Label).Text = "Trial version!"
        End If
    End Sub
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.EditModeExitEventArgs

See Also

Reference

EditModeExitEventArgs Members
GrapeCity.ActiveReports.Design Namespace


EditModeExitEventArgs Class Members

EditModeExitEventArgs Class Members
Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : EditModeExitEventArgs Class

The following tables list the members exposed by EditModeExitEventArgs.

Public Constructors
 | Name | Description
Public Constructor | EditModeExitEventArgs Constructor | Initializes a new instance of the EditModeExitEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Control | Gets the type of control that is exiting edit mode.
Public Property | Type | Gets the exit type.
Top
See Also

Reference

EditModeExitEventArgs Class
GrapeCity.ActiveReports.Design Namespace


EditModeExitEventArgs Constructor

EditModeExitEventArgs Constructor

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > EditModeExitEventArgs Class : EditModeExitEventArgs Constructor

The type of control that is exiting edit mode.

Exit type.
Initializes a new instance of the EditModeExitEventArgs class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal control As System.Object, _
   ByVal type As ExitType _
)
public EditModeExitEventArgs(
   System.object control,
   ExitType type
)

Parameters

control

The type of control that is exiting edit mode.

type
Exit type.
See Also

Reference

EditModeExitEventArgs Class
EditModeExitEventArgs Members


EditModeExitEventArgs Class Properties

EditModeExitEventArgs Class Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : EditModeExitEventArgs Class

For a list of all members of this type, see EditModeExitEventArgs members.

Public Properties
 | Name | Description
Public Property | Control | Gets the type of control that is exiting edit mode.
Public Property | Type | Gets the exit type.
Top
See Also

Reference

EditModeExitEventArgs Class
GrapeCity.ActiveReports.Design Namespace


Control Property (EditModeExitEventArgs)

Control Property (EditModeExitEventArgs)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > EditModeExitEventArgs Class : Control Property
Gets the type of control that is exiting edit mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Control As System.Object
public System.object Control {get;}
See Also

Reference

EditModeExitEventArgs Class
EditModeExitEventArgs Members


Type Property (EditModeExitEventArgs)

Type Property (EditModeExitEventArgs)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > EditModeExitEventArgs Class : Type Property
Gets the exit type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Type As ExitType
public ExitType Type {get;}
See Also

Reference

EditModeExitEventArgs Class
EditModeExitEventArgs Members


LayerList Class

LayerList Class
Members

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : LayerList Class
ActiveReports Layer List.
Object Model
LayerList Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class LayerList
   Inherits System.Windows.Forms.UserControl
public sealed class LayerList : System.Windows.Forms.UserControl
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
GrapeCity.ActiveReports.Design.LayerList

See Also

Reference

LayerList Members
GrapeCity.ActiveReports.Design Namespace


LayerList Class Members

LayerList Class Members
Properties Methods Events

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : LayerList Class

The following tables list the members exposed by LayerList.

Public Constructors
 | Name | Description
Public Constructor | LayerList Constructor | Initializes a new instance of layer list.
Top
Public Properties
 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | ReportDesigner | Gets or sets the Designer instance to bind to this control.
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Top
Public Methods
 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top
Public Events
 | Name | Description
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SelectionChanged | Fired when selected layer changed.
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

LayerList Class
GrapeCity.ActiveReports.Design Namespace


LayerList Constructor

LayerList Constructor

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : LayerList Constructor
Initializes a new instance of layer list.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public LayerList()
See Also

Reference

LayerList Class
LayerList Members


LayerList Class Properties

LayerList Class Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : LayerList Class

For a list of all members of this type, see LayerList members.

Public Properties
 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | ReportDesigner | Gets or sets the Designer instance to bind to this control.
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

LayerList Class
GrapeCity.ActiveReports.Design Namespace


ReportDesigner Property (LayerList)

ReportDesigner Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ReportDesigner Property
Gets or sets the Designer instance to bind to this control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportDesigner As Designer
public Designer ReportDesigner {get; set;}
See Also

Reference

LayerList Class
LayerList Members


LayerList Class Events

LayerList Class Events

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : LayerList Class

For a list of all members of this type, see LayerList members.

Public Events
 | Name | Description
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SelectionChanged | Fired when selected layer changed.
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

LayerList Class
GrapeCity.ActiveReports.Design Namespace


SelectionChanged Event (LayerList)

SelectionChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : SelectionChanged Event
Fired when selected layer changed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event SelectionChanged As System.Action(Of LayerSelectionChangedEventArgs)
public event System.Action<LayerSelectionChangedEventArgs> SelectionChanged
See Also

Reference

LayerList Class
LayerList Members


LayerSelectionChangedEventArgs Class

LayerSelectionChangedEventArgs Class
Members

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : LayerSelectionChangedEventArgs Class

Provides data for the SelectionChanged event of the LayerList

Object Model
LayerSelectionChangedEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class LayerSelectionChangedEventArgs
   Inherits System.EventArgs
public sealed class LayerSelectionChangedEventArgs : System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.LayerSelectionChangedEventArgs

See Also

Reference

LayerSelectionChangedEventArgs Members
GrapeCity.ActiveReports.Design Namespace


LayerSelectionChangedEventArgs Class Members

LayerSelectionChangedEventArgs Class Members
Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : LayerSelectionChangedEventArgs Class

The following tables list the members exposed by LayerSelectionChangedEventArgs.

Public Constructors
 | Name | Description
Public Constructor | LayerSelectionChangedEventArgs Constructor | Initializes a new instance of the LayoutSelectionChangedEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | SelectedLayer | Gets the currently selected Layer.
Top
See Also

Reference

LayerSelectionChangedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


LayerSelectionChangedEventArgs Constructor

LayerSelectionChangedEventArgs Constructor

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerSelectionChangedEventArgs Class : LayerSelectionChangedEventArgs Constructor
The selected layer.

Initializes a new instance of the LayoutSelectionChangedEventArgs class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal selectedLayer As System.ComponentModel.IComponent _
)
public LayerSelectionChangedEventArgs(
   System.ComponentModel.IComponent selectedLayer
)

Parameters

selectedLayer
The selected layer.
See Also

Reference

LayerSelectionChangedEventArgs Class
LayerSelectionChangedEventArgs Members


LayerSelectionChangedEventArgs Class Properties

LayerSelectionChangedEventArgs Class Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : LayerSelectionChangedEventArgs Class

For a list of all members of this type, see LayerSelectionChangedEventArgs members.

Public Properties
 | Name | Description
Public Property | SelectedLayer | Gets the currently selected Layer.
Top
See Also

Reference

LayerSelectionChangedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


SelectedLayer Property

SelectedLayer Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerSelectionChangedEventArgs Class : SelectedLayer Property

Gets the currently selected Layer.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property SelectedLayer As System.ComponentModel.IComponent
public System.ComponentModel.IComponent SelectedLayer {get;}
See Also

Reference

LayerSelectionChangedEventArgs Class
LayerSelectionChangedEventArgs Members


LayoutChangedArgs Class

LayoutChangedArgs Class
Members Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangedArgs Class

The LayoutChangedArgs class provides data required for the LayoutChanged event.

Object Model
LayoutChangedArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class LayoutChangedArgs
   Inherits System.EventArgs
public class LayoutChangedArgs : System.EventArgs
Example
  • C#
// ardMain_LayoutChanged - runs when a control/section in the layout is added/deleted/moved

private void ardMain_LayoutChanged(object sender, GrapeCity.ActiveReports.Design.LayoutChangedArgs e)
{
    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.ControlAdd)  //Control Added
    {
        this._controlAdded = true;
        ResetToolbox();
        tbToolbox.Buttons[0].Pushed = true;
    }
    else
    {
        this._controlAdded = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.ControlDelete)  //Control Deleted
    {
        this._controlDeleted = true;
    }
    else
    {
        this._controlDeleted = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.SectionAdd)  //Section Added
    {
        this._sectionAdded = true;
    }
    else
    {
        this._sectionAdded = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.SectionDelete)  //Section Deleted
    {
        this._sectionDeleted = true;
    }
    else
    {
        this._sectionDeleted = false;
    }
}
  • Visual Basic
'ardMain_LayoutChanged - runs when a control/section in the layout is added/deleted/moved
Private Sub ardMain_LayoutChanged(ByVal sender As Object, ByVal e As GrapeCity.ActiveReports.Design.LayoutChangedArgs) Handles ardMain.LayoutChanged
    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.ControlAdd Then 'Control Added
        Me._controlAdded = True
        ResetToolbox()
        tbToolbox.Buttons(0).Pushed = True
    Else
        Me._controlAdded = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.ControlDelete Then 'Control Deleted
        Me._controlDeleted = True
    Else
        Me._controlDeleted = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.SectionAdd Then 'Section Added
        Me._sectionAdded = True
    Else
        Me._sectionAdded = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.SectionDelete Then 'Section Deleted
        Me._sectionDeleted = True
    Else
        Me._sectionDeleted = False
    End If
End Sub 'ardMain_LayoutChanged
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.LayoutChangedArgs

See Also

Reference

LayoutChangedArgs Members
GrapeCity.ActiveReports.Design Namespace
LayoutChangeType Enumeration


LayoutChangedArgs Class Members

LayoutChangedArgs Class Members
Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangedArgs Class

The following tables list the members exposed by LayoutChangedArgs.

Public Constructors
 | Name | Description
Public Constructor | LayoutChangedArgs Constructor | Initializes a new instance of the LayoutChangedArgs class.
Top
Public Properties
 | Name | Description
Public Property | Type | Gets or sets the type of layout change that caused the event to be raised.
Top
See Also

Reference

LayoutChangedArgs Class
GrapeCity.ActiveReports.Design Namespace
LayoutChangeType Enumeration


LayoutChangedArgs Constructor

LayoutChangedArgs Constructor

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayoutChangedArgs Class : LayoutChangedArgs Constructor
Specifies the type of layout change.

Initializes a new instance of the LayoutChangedArgs class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal type As LayoutChangeType _
)
public LayoutChangedArgs(
   LayoutChangeType type
)

Parameters

type
Specifies the type of layout change.
See Also

Reference

LayoutChangedArgs Class
LayoutChangedArgs Members


LayoutChangedArgs Class Properties

LayoutChangedArgs Class Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangedArgs Class

For a list of all members of this type, see LayoutChangedArgs members.

Public Properties
 | Name | Description
Public Property | Type | Gets or sets the type of layout change that caused the event to be raised.
Top
See Also

Reference

LayoutChangedArgs Class
GrapeCity.ActiveReports.Design Namespace
LayoutChangeType Enumeration


Type Property (LayoutChangedArgs)

Type Property (LayoutChangedArgs)
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayoutChangedArgs Class : Type Property
Gets or sets the type of layout change that caused the event to be raised.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Type As LayoutChangeType
public LayoutChangeType Type {get;}

Property Value

LayoutChangeType enumeration value that determines the type of change.
Example
  • C#
/// <summary>
/// ardMain_LayoutChanged - runs when a control/section in the layout is added/deleted/moved
/// </summary>
private void ardMain_LayoutChanged(object sender, GrapeCity.ActiveReports.Design.LayoutChangedArgs e)
{
    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.ControlAdd)  //Control Added
    {
        this._controlAdded = true;
        ResetToolbox();
        tbToolbox.Buttons[0].Pushed = true;
    }
    else
    {
        this._controlAdded = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.ControlDelete)  //Control Deleted
    {
        this._controlDeleted = true;
    }
    else
    {
        this._controlDeleted = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.SectionAdd)  //Section Added
    {
        this._sectionAdded = true;
    }
    else
    {
        this._sectionAdded = false;
    }

    if(e.Type == GrapeCity.ActiveReports.Design.LayoutChangeType.SectionDelete)  //Section Deleted
    {
        this._sectionDeleted = true;
    }
    else
    {
        this._sectionDeleted = false;
    }
}
  • Visual Basic
'ardMain_LayoutChanged - runs when a control/section in the layout is added/deleted/moved
Private Sub ardMain_LayoutChanged(ByVal sender As Object, ByVal e As GrapeCity.ActiveReports.Design.LayoutChangedArgs) Handles ardMain.LayoutChanged
    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.ControlAdd Then 'Control Added
        Me._controlAdded = True
        ResetToolbox()
        tbToolbox.Buttons(0).Pushed = True
    Else
        Me._controlAdded = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.ControlDelete Then 'Control Deleted
        Me._controlDeleted = True
    Else
        Me._controlDeleted = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.SectionAdd Then 'Section Added
        Me._sectionAdded = True
    Else
        Me._sectionAdded = False
    End If

    If e.Type = GrapeCity.ActiveReports.Design.LayoutChangeType.SectionDelete Then 'Section Deleted
        Me._sectionDeleted = True
    Else
        Me._sectionDeleted = False
    End If
End Sub 'ardMain_LayoutChanged
See Also

Reference

LayoutChangedArgs Class
LayoutChangedArgs Members
LayoutChangeType Enumeration


LayoutChangingArgs Class

LayoutChangingArgs Class
Members Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangingArgs Class

The LayoutChangingArgs class provides data required for the LayoutChanging event.

Object Model
LayoutChangingArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class LayoutChangingArgs
   Inherits System.EventArgs
public class LayoutChangingArgs : System.EventArgs
Example
  • Visual Basic
Private Sub ardMain_LayoutChanging(ByVal sender As Object, ByVal e As Design.LayoutChangingArgs) Handles ardMain.LayoutChanging
    If e.Type = Design.LayoutChangeType.SectionDelete Then
        Dim Result As DialogResult
        Result = MessageBox.Show("Are you sure you want to delete this section?", "Delete?", MessageBoxButtons.OKCancel, MessageBoxIcon.Question, MessageBoxDefaultButton.Button1)
        If Result = DialogResult.Cancel Then
            e.AllowChange = False
        Else
            e.AllowChange = True
        End If
    End If
End Sub
  • C#
private void ardMain_LayoutChanging(object sender, GrapeCity.ActiveReports.Design.LayoutChangingArgs e)
{
    if (e.Type == Design.LayoutChangeType.SectionDelete)
    {
        DialogResult Result;
        Result = MessageBox.Show("Are you sure you want to delete this section?", "Delete?", MessageBoxButtons.OKCancel, MessageBoxIcon.Question, MessageBoxDefaultButton.Button1);
        if (Result == DialogResult.Cancel)
        {
            e.AllowChange = false;
        }
        else
        {
            e.AllowChange = true;
        }
    }
}
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.LayoutChangingArgs

See Also

Reference

LayoutChangingArgs Members
GrapeCity.ActiveReports.Design Namespace


LayoutChangingArgs Class Members

LayoutChangingArgs Class Members
Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangingArgs Class

The following tables list the members exposed by LayoutChangingArgs.

Public Constructors
 | Name | Description
Public Constructor | LayoutChangingArgs Constructor | Initializes a new instance of the LayoutChangingArgs class.
Top
Public Properties
 | Name | Description
Public Property | AllowChange | Sets or returns a value indicating whether to allow the change.
Public Property | Name | The array of names of the controls or sections to be updated or changed.
Public Property | NewSectionName | Gets the name of the new section.
Public Property | NewValue | The array of controls or sections to be added.
Public Property | OldSectionName | Gets the name of the old section.
Public Property | OldValue | The array of controls or sections to be deleted.
Public Property | Type | Returns the type of layout change that is to occur.
Top
See Also

Reference

LayoutChangingArgs Class
GrapeCity.ActiveReports.Design Namespace


LayoutChangingArgs Constructor

LayoutChangingArgs Constructor

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayoutChangingArgs Class : LayoutChangingArgs Constructor
The type of layout change that is to occur.
The selection type.
The array of names of the controls or sections to be updated or changed.
The array of controls or sections to be added.
The array of controls or sections to be deleted.
Name of the old section.
Name of the new section.
Initializes a new instance of the LayoutChangingArgs class.

Initializes a new instance of the LayoutChangingArgs class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal type As LayoutChangeType, _
   ByVal selectionType As SelectionType, _
   ByVal name As System.String, _
   ByVal newValue As System.Object, _
   ByVal oldValue As System.Object, _
   ByVal oldSectionName As System.String, _
   ByVal newSectionName As System.String _
)
public LayoutChangingArgs(
   LayoutChangeType type,
   SelectionType selectionType,
   System.string name,
   System.object newValue,
   System.object oldValue,
   System.string oldSectionName,
   System.string newSectionName
)

Parameters

type
The type of layout change that is to occur.
selectionType
The selection type.
name
The array of names of the controls or sections to be updated or changed.
newValue
The array of controls or sections to be added.
oldValue
The array of controls or sections to be deleted.
oldSectionName
Name of the old section.
newSectionName
Name of the new section.
Remarks
In the type parameter, any of the enumerated values except ReportClear, ReportLoad, and ReportSize may be used.
See Also

Reference

LayoutChangingArgs Class
LayoutChangingArgs Members
LayoutChangeType Enumeration


LayoutChangingArgs Class Properties

LayoutChangingArgs Class Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangingArgs Class

For a list of all members of this type, see LayoutChangingArgs members.

Public Properties
 | Name | Description
Public Property | AllowChange | Sets or returns a value indicating whether to allow the change.
Public Property | Name | The array of names of the controls or sections to be updated or changed.
Public Property | NewSectionName | Gets the name of the new section.
Public Property | NewValue | The array of controls or sections to be added.
Public Property | OldSectionName | Gets the name of the old section.
Public Property | OldValue | The array of controls or sections to be deleted.
Public Property | Type | Returns the type of layout change that is to occur.
Top
See Also

Reference

LayoutChangingArgs Class
GrapeCity.ActiveReports.Design Namespace


AllowChange Property

AllowChange Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayoutChangingArgs Class : AllowChange Property
Sets or returns a value indicating whether to allow the change.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AllowChange As System.Boolean
public System.bool AllowChange {get; set;}

Property Value

Boolean.
Remarks
The default value of this property is True.
See Also

Reference

LayoutChangingArgs Class
LayoutChangingArgs Members


Name Property (LayoutChangingArgs)

Name Property (LayoutChangingArgs)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayoutChangingArgs Class : Name Property
The array of names of the controls or sections to be updated or changed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Name As System.String
public System.string Name {get;}
See Also

Reference

LayoutChangingArgs Class
LayoutChangingArgs Members


NewSectionName Property

NewSectionName Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayoutChangingArgs Class : NewSectionName Property
Gets the name of the new section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property NewSectionName As System.String
public System.string NewSectionName {get;}
See Also

Reference

LayoutChangingArgs Class
LayoutChangingArgs Members


NewValue Property

NewValue Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayoutChangingArgs Class : NewValue Property
The array of controls or sections to be added.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property NewValue As System.Object
public System.object NewValue {get;}
See Also

Reference

LayoutChangingArgs Class
LayoutChangingArgs Members


OldSectionName Property

OldSectionName Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayoutChangingArgs Class : OldSectionName Property
Gets the name of the old section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property OldSectionName As System.String
public System.string OldSectionName {get;}
See Also

Reference

LayoutChangingArgs Class
LayoutChangingArgs Members


OldValue Property

OldValue Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayoutChangingArgs Class : OldValue Property
The array of controls or sections to be deleted.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property OldValue As System.Object
public System.object OldValue {get;}
See Also

Reference

LayoutChangingArgs Class
LayoutChangingArgs Members


Type Property (LayoutChangingArgs)

Type Property (LayoutChangingArgs)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayoutChangingArgs Class : Type Property
Returns the type of layout change that is to occur.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Type As LayoutChangeType
public LayoutChangeType Type {get;}

Property Value

LayoutChangeType enumeration.
See Also

Reference

LayoutChangingArgs Class
LayoutChangingArgs Members
LayoutChangeType Enumeration


OpenFileDialogExtension Class

OpenFileDialogExtension Class
Members

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : OpenFileDialogExtension Class
For internal use only. This extension allows to show OpenFileDialog with customized split button.
Object Model
OpenFileDialogExtension Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit NotInheritable Class OpenFileDialogExtension
public static class OpenFileDialogExtension
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Design.OpenFileDialogExtension

See Also

Reference

OpenFileDialogExtension Members
GrapeCity.ActiveReports.Design Namespace


OpenFileDialogExtension Class Members

OpenFileDialogExtension Class Members
Methods

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : OpenFileDialogExtension Class

The following tables list the members exposed by OpenFileDialogExtension.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | ShowDialog | Show the OpenFileDialog with split button.
Top
See Also

Reference

OpenFileDialogExtension Class
GrapeCity.ActiveReports.Design Namespace


OpenFileDialogExtension Class Methods

OpenFileDialogExtension Class Methods

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : OpenFileDialogExtension Class

For a list of all members of this type, see OpenFileDialogExtension members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | ShowDialog | Show the OpenFileDialog with split button.
Top
See Also

Reference

OpenFileDialogExtension Class
GrapeCity.ActiveReports.Design Namespace


ShowDialog Method

ShowDialog Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > OpenFileDialogExtension Class : ShowDialog Method
Show the OpenFileDialog with split button.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function ShowDialog( _
   ByVal dlgOpen As System.Windows.Forms.OpenFileDialog, _
   ByVal owner As System.Windows.Forms.IWin32Window, _
   ByVal stripItems() As System.String, _
   ByRef selectedIndex As System.Integer _
) As System.Windows.Forms.DialogResult
public static System.Windows.Forms.DialogResult ShowDialog(
   System.Windows.Forms.OpenFileDialog dlgOpen,
   System.Windows.Forms.IWin32Window owner,
   System.string[] stripItems,
   out System.int selectedIndex
)

Parameters

dlgOpen
owner
stripItems
selectedIndex
See Also

Reference

OpenFileDialogExtension Class
OpenFileDialogExtension Members


Selection Class

Selection Class
Members Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : Selection Class

Indicates the currently selected items in the report layout.

Object Model
Selection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Selection
public class Selection
Example
  • C#
// cboPropList_SelectedIndexChanged - runs when the Property List Drop Down is changed

private void cboPropList_SelectedIndexChanged(object sender, System.EventArgs e)
{
    this.ardMain.Selection.Select(((ARComboItem)this.comboHashTable[this.cboPropList.SelectedItem.ToString()]).Item);
}
  • Visual Basic
'cboPropList_SelectedIndexChanged - runs when the Property List Drop Down is changed
Private Sub cboPropList_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles cboPropList.SelectedIndexChanged
    Me.ardMain.Selection.Select(CType(Me.comboHashTable(Me.cboPropList.SelectedItem.ToString()), ARComboItem).Item)
End Sub 'cboPropList_SelectedIndexChanged
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Design.Selection

See Also

Reference

Selection Members
GrapeCity.ActiveReports.Design Namespace


Selection Class Members

Selection Class Members
Properties Methods

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : Selection Class

The following tables list the members exposed by Selection.

Public Properties
 | Name | Description
Public Property | Count | Returns the number of selected objects.
Public Property | Item | Returns a reference to the specified selected item.
Top
Public Methods
 | Name | Description
Public Method | Clear | Clears the current selection in the Report Designer.
Public Method | CopyTo | Copies the selected items to an Array, starting at a particular Array index.
Public Method | Select | Overloaded. The Select method allows one or more objects to be selected in the designer.
Top
See Also

Reference

Selection Class
GrapeCity.ActiveReports.Design Namespace


Selection Class Methods

Selection Class Methods

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : Selection Class

For a list of all members of this type, see Selection members.

Public Methods
 | Name | Description
Public Method | Clear | Clears the current selection in the Report Designer.
Public Method | CopyTo | Copies the selected items to an Array, starting at a particular Array index.
Public Method | Select | Overloaded. The Select method allows one or more objects to be selected in the designer.
Top
See Also

Reference

Selection Class
GrapeCity.ActiveReports.Design Namespace


Clear Method (Selection)

Clear Method (Selection)
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Selection Class : Clear Method
Clears the current selection in the Report Designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
Example
  • C#
/// <summary>
/// DesignView - updates the Design tab, sets defaults for the menu
/// </summary>
private void DesignView()
{
    this.sb.Text = "Loading Report";
    this.ardMain.Selection.Clear();
    this.ardMain.Selection.Select(this.ardMain.Report);
    this.mnuFilePrint.Enabled = false;

    //Reset Menu Items
    this.mnuFileNew.Enabled = true;
    this.mnuFileOpen.Enabled = true;
    this.mnuFileSave.Enabled = true;
    this.mnuFilePrint.Enabled = false;
    this.mnuFileExport.Enabled = false;
    this.mnuFilePrintPreview.Enabled = true;
    this.mnuFormat.Enabled = true;
    this.mnuInsert.Enabled = true;
    this.mnuEditCopyPage.Enabled = false;
    this.mnuEditFind.Enabled = false;
    this.mnuFileExport.Enabled = false;
    this.mnuEditProperties.Enabled = true;
    this.mnuFileSaveAs.Enabled = true;
    this.mnuFileReportProperties.Enabled = true;
    this.sb.Text = "Ready";
}
  • Visual Basic
'DesignView - updates the Design tab, sets defaults for the menu
Private Sub DesignView()
    Me.sb.Text = "Loading Report"
    Me.ardMain.Selection.Clear()
    Me.ardMain.Selection.Select(Me.ardMain.Report)
    Me.mnuFilePrint.Enabled = False

    'Reset Menu Items
    Me.mnuFileNew.Enabled = True
    Me.mnuFileOpen.Enabled = True
    Me.mnuFileSave.Enabled = True
    Me.mnuFilePrint.Enabled = False
    Me.mnuFileExport.Enabled = False
    Me.mnuFilePrintPreview.Enabled = True
    Me.mnuFormat.Enabled = True
    Me.mnuInsert.Enabled = True
    Me.mnuEditCopyPage.Enabled = False
    Me.mnuEditFind.Enabled = False
    Me.mnuFileExport.Enabled = False
    Me.mnuEditProperties.Enabled = True
    Me.mnuFileSaveAs.Enabled = True
    Me.mnuFileReportProperties.Enabled = True
    Me.sb.Text = "Ready"
End Sub 'DesignView
See Also

Reference

Selection Class
Selection Members


CopyTo Method (Selection)

CopyTo Method (Selection)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Selection Class : CopyTo Method
The array to which to copy the collection.
The array index from which to start.

Copies the selected items to an Array, starting at a particular Array index.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal array As System.Array, _
   ByVal index As System.Integer _
)
public void CopyTo(
   System.Array array,
   System.int index
)

Parameters

array
The array to which to copy the collection.
index
The array index from which to start.
See Also

Reference

Selection Class
Selection Members


Select Method (Selection)

Select Method (Selection)
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Selection Class : Select Method
The Select method allows one or more objects to be selected in the designer.
Overload List
Overload | Description
Select(Object) | Allows one object to be selected in the designer.
Select(Object,Boolean) | Allows more than one item to be selected in the designer.
Example
  • C#
/// <summary>
/// cboPropList_SelectedIndexChanged - runs with the Property List Drop Down is changed
/// </summary>
private void cboPropList_SelectedIndexChanged(object sender, System.EventArgs e)
{
    this.ardMain.Selection.Select(((ARComboItem)this.comboHashTable[this.cboPropList.SelectedItem.ToString()]).Item);
}
  • Visual Basic
'cboPropList_SelectedIndexChanged - runs with the Property List Drop Down is changed
Private Sub cboPropList_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles cboPropList.SelectedIndexChanged
    Me.ardMain.Selection.Select(CType(Me.comboHashTable(Me.cboPropList.SelectedItem.ToString()), ARComboItem).Item)
End Sub 'cboPropList_SelectedIndexChanged
See Also

Reference

Selection Class
Selection Members


Select(Object) Method

Select(Object) Method
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Selection Class > Select Method : Select(Object) Method
Object to select.
Allows one object to be selected in the designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Select( _
   ByVal selectedObject As System.Object _
)
public void Select(
   System.object selectedObject
)

Parameters

selectedObject
Object to select.
Example
  • C#
/// <summary>
/// cboPropList_SelectedIndexChanged - runs with the Property List Drop Down is changed
/// </summary>
private void cboPropList_SelectedIndexChanged(object sender, System.EventArgs e)
{
    this.ardMain.Selection.Select(((ARComboItem)this.comboHashTable[this.cboPropList.SelectedItem.ToString()]).Item);
}
  • Visual Basic
'cboPropList_SelectedIndexChanged - runs with the Property List Drop Down is changed
Private Sub cboPropList_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles cboPropList.SelectedIndexChanged
    Me.ardMain.Selection.Select(CType(Me.comboHashTable(Me.cboPropList.SelectedItem.ToString()), ARComboItem).Item)
End Sub 'cboPropList_SelectedIndexChanged
See Also

Reference

Selection Class
Selection Members
Overload List


Select(Object,Boolean) Method

Select(Object,Boolean) Method
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Selection Class > Select Method : Select(Object,Boolean) Method
Object to select.
Boolean.
Allows more than one item to be selected in the designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Select( _
   ByVal selectedObject As System.Object, _
   ByVal continuous As System.Boolean _
)
public void Select(
   System.object selectedObject,
   System.bool continuous
)

Parameters

selectedObject
Object to select.
continuous
Boolean.

Return Value

Boolean value. If true, more than one object can be selected in the designer. If false, only one object can be selected in the designer.
Example
  • C#
/// <summary>
/// cboPropList_SelectedIndexChanged - runs with the Property List Drop Down is changed
/// </summary>
private void cboPropList_SelectedIndexChanged(object sender, System.EventArgs e)
{
    this.ardMain.Selection.Select(((ARComboItem)this.comboHashTable[this.cboPropList.SelectedItem.ToString()]).Item, false);
}
  • Visual Basic
'cboPropList_SelectedIndexChanged - runs with the Property List Drop Down is changed
Private Sub cboPropList_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles cboPropList.SelectedIndexChanged
    Me.ardMain.Selection.Select(CType(Me.comboHashTable(Me.cboPropList.SelectedItem.ToString()), ARComboItem).Item, False)
End Sub 'cboPropList_SelectedIndexChanged
See Also

Reference

Selection Class
Selection Members
Overload List


Selection Class Properties

Selection Class Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : Selection Class

For a list of all members of this type, see Selection members.

Public Properties
 | Name | Description
Public Property | Count | Returns the number of selected objects.
Public Property | Item | Returns a reference to the specified selected item.
Top
See Also

Reference

Selection Class
GrapeCity.ActiveReports.Design Namespace


Count Property (Selection)

Count Property (Selection)
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Selection Class : Count Property
Returns the number of selected objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
Example
  • C#
/// <summary>
/// SetClassName - sets the ClassName of the selected object to the name in the drop down list
/// </summary>
private void SetClassName()
{
    for(int i=0;i<this.ardMain.Selection.Count;i++)
    {
        string ctl = this.ardMain.Selection[i].GetType().ToString();
        if((ctl.IndexOf("TextBox") >0)||(ctl.IndexOf("CheckBox") >0)||(ctl.IndexOf("Label") >0))
        {
            switch(ctl)
            {
                case "GrapeCity.ActiveReports.SectionReportModel.TextBox":  //Control type is TextBox
                    ((GrapeCity.ActiveReports.SectionReportModel.TextBox)this.ardMain.Selection[i]).ClassName = this.cboClassName.Text;
                    break;
                case "GrapeCity.ActiveReports.SectionReportModel.Label":  //Control type is Label
                    ((GrapeCity.ActiveReports.SectionReportModel.Label)this.ardMain.Selection[i]).ClassName = this.cboClassName.Text;
                    break;
                case "GrapeCity.ActiveReports.SectionReportModel.CheckBox":  //Control type is CheckBox
                    ((GrapeCity.ActiveReports.SectionReportModel.CheckBox)this.ardMain.Selection[i]).ClassName = this.cboClassName.Text;
                    break;
            }
        }
    }
}
  • Visual Basic
'SetClassName - sets the ClassName of the selected object to the name in the drop down list
Private Sub SetClassName()
    Dim i As Integer
    For i = 0 To (Me.ardMain.Selection.Count) - 1
        Dim ctl As String = Me.ardMain.Selection(i).GetType().ToString()
        If ctl.IndexOf("TextBox") > 0 OrElse ctl.IndexOf("CheckBox") > 0 OrElse ctl.IndexOf("Label") > 0 Then
            Select Case ctl
                Case "GrapeCity.ActiveReports.SectionReportModel.TextBox" 'Control type is TextBox
                    CType(Me.ardMain.Selection(i), GrapeCity.ActiveReports.SectionReportModel.TextBox).ClassName = Me.cboClassName.Text
                Case "GrapeCity.ActiveReports.SectionReportModel.Label" 'Control type is Label
                    CType(Me.ardMain.Selection(i), GrapeCity.ActiveReports.SectionReportModel.Label).ClassName = Me.cboClassName.Text
                Case "GrapeCity.ActiveReports.SectionReportModel.CheckBox" 'Control type is CheckBox
                    CType(Me.ardMain.Selection(i), GrapeCity.ActiveReports.SectionReportModel.CheckBox).ClassName = Me.cboClassName.Text
            End Select
        End If
    Next i
End Sub 'SetClassName
See Also

Reference

Selection Class
Selection Members


Item Property (Selection)

Item Property (Selection)
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Selection Class : Item Property
Specifies the index of the selected item.
Returns a reference to the specified selected item.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As System.Object
public System.object this[
   System.int index
]; {get;}

Parameters

index
Specifies the index of the selected item.
Example
  • C#
/// <summary>
/// SetClassName - sets the ClassName of the selected object to the name in the drop down list
/// </summary>
private void SetClassName()
{
    for(int i=0;i<this.ardMain.Selection.Count;i++)
    {
        string ctl = this.ardMain.Selection[i].GetType().ToString();
        if((ctl.IndexOf("TextBox") >0)||(ctl.IndexOf("CheckBox") >0)||(ctl.IndexOf("Label") >0))
        {
            switch(ctl)
            {
                case "GrapeCity.ActiveReports.SectionReportModel.TextBox":  //Control type is TextBox
                    ((GrapeCity.ActiveReports.SectionReportModel.TextBox)this.ardMain.Selection[i]).ClassName = this.cboClassName.Text;
                    break;
                case "DGrapeCity.ActiveReports.SectionReportModel.Label":  //Control type is Label
                    ((GrapeCity.ActiveReports.SectionReportModel.Label)this.ardMain.Selection[i]).ClassName = this.cboClassName.Text;
                    break;
                case "GrapeCity.ActiveReports.SectionReportModel.CheckBox":  //Control type is CheckBox
                    ((GrapeCity.ActiveReports.SectionReportModel.CheckBox)this.ardMain.Selection[i]).ClassName = this.cboClassName.Text;
                    break;
            }
        }
    }
}
  • Visual Basic
'SetClassName - sets the ClassName of the selected object to the name in the drop down list
Private Sub SetClassName()
    Dim i As Integer
    For i = 0 To (Me.ardMain.Selection.Count) - 1
        Dim ctl As String = Me.ardMain.Selection(i).GetType().ToString()
        If ctl.IndexOf("TextBox") > 0 OrElse ctl.IndexOf("CheckBox") > 0 OrElse ctl.IndexOf("Label") > 0 Then
            Select Case ctl
                Case "GrapeCity.ActiveReports.SectionReportModel.TextBox" 'Control type is TextBox
                    CType(Me.ardMain.Selection(i), GrapeCity.ActiveReports.SectionReportModel.TextBox).ClassName = Me.cboClassName.Text
                Case "GrapeCity.ActiveReports.SectionReportModel.Label" 'Control type is Label
                    CType(Me.ardMain.Selection(i), GrapeCity.ActiveReports.SectionReportModel.Label).ClassName = Me.cboClassName.Text
                Case "GrapeCity.ActiveReports.SectionReportModel.CheckBox" 'Control type is CheckBox
                    CType(Me.ardMain.Selection(i), GrapeCity.ActiveReports.SectionReportModel.CheckBox).ClassName = Me.cboClassName.Text
            End Select
        End If
    Next i
End Sub 'SetClassName
See Also

Reference

Selection Class
Selection Members


ServerConnectionChangedEventArgs Class

ServerConnectionChangedEventArgs Class
Members

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : ServerConnectionChangedEventArgs Class
Information about connection with ARS
Object Model
ServerConnectionChangedEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ServerConnectionChangedEventArgs
   Inherits System.EventArgs
public class ServerConnectionChangedEventArgs : System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.ServerConnectionChangedEventArgs

See Also

Reference

ServerConnectionChangedEventArgs Members
GrapeCity.ActiveReports.Design Namespace


ServerConnectionChangedEventArgs Class Members

ServerConnectionChangedEventArgs Class Members
Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : ServerConnectionChangedEventArgs Class

The following tables list the members exposed by ServerConnectionChangedEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ServerConnectionChangedEventArgs Constructor | Initializes a new instance of the ServerConnectionChangedEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Connected | Gets the connection state.
Public Property | ServerUrl | Gets the server URL.
Top
See Also

Reference

ServerConnectionChangedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


ServerConnectionChangedEventArgs Constructor

ServerConnectionChangedEventArgs Constructor

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > ServerConnectionChangedEventArgs Class : ServerConnectionChangedEventArgs Constructor
The connection state.
The server URL.
Initializes a new instance of the ServerConnectionChangedEventArgs class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal connected As System.Boolean, _
   ByVal serverUrl As System.String _
)
public ServerConnectionChangedEventArgs(
   System.bool connected,
   System.string serverUrl
)

Parameters

connected
The connection state.
serverUrl
The server URL.
See Also

Reference

ServerConnectionChangedEventArgs Class
ServerConnectionChangedEventArgs Members


ServerConnectionChangedEventArgs Class Properties

ServerConnectionChangedEventArgs Class Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : ServerConnectionChangedEventArgs Class

For a list of all members of this type, see ServerConnectionChangedEventArgs members.

Public Properties
 | Name | Description
Public Property | Connected | Gets the connection state.
Public Property | ServerUrl | Gets the server URL.
Top
See Also

Reference

ServerConnectionChangedEventArgs Class
GrapeCity.ActiveReports.Design Namespace


Connected Property

Connected Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > ServerConnectionChangedEventArgs Class : Connected Property
Gets the connection state.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Connected As System.Boolean
public System.bool Connected {get;}
See Also

Reference

ServerConnectionChangedEventArgs Class
ServerConnectionChangedEventArgs Members


ServerUrl Property (ServerConnectionChangedEventArgs)

ServerUrl Property (ServerConnectionChangedEventArgs)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > ServerConnectionChangedEventArgs Class : ServerUrl Property
Gets the server URL.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ServerUrl As System.String
public System.string ServerUrl {get;}
See Also

Reference

ServerConnectionChangedEventArgs Class
ServerConnectionChangedEventArgs Members


UndoManager Class

UndoManager Class
Members Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : UndoManager Class
The UndoManager class allows users to undo and redo changes.
Object Model
UndoManager Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class UndoManager
public sealed class UndoManager
Example
  • C#
// tbStandard_ButtonClick - calls ExecuteDesignerAction, or the associated function
// based on the button clicked.

private void tbStandard_ButtonClick(object sender, System.Windows.Forms.ToolBarButtonClickEventArgs e)
{
    if((string)e.Button.Tag == "NewReport")  //New Report was Clicked
    {
        this.ardMain.NewReport();
        this.FillCombo();
    }
    if((string)e.Button.Tag == "Open")  //Open Report was Clicked
    {
        this.OpenReportFile();
    }
    if((string)e.Button.Tag == "Save")  //Save Report was Clicked
    {
        this.SaveReportFile();
    }
    if((string)e.Button.Tag == "SaveAs")  //SaveAs was Clicked
    {
        this.SaveAsReportFile();
    }
    if((string)e.Button.Tag == "ReportSettings")  //ReportSettings was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.ReportSettings);
    }
    if((string)e.Button.Tag == "Undo")  //Undo was Clicked
    {
        this.ardMain.UndoManager.Undo();
    }
    if((string)e.Button.Tag == "Cut")  //Cut was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.EditCut);
    }
    if((string)e.Button.Tag == "Copy")  //Copy was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.EditCopy);
    }
    if((string)e.Button.Tag == "Paste")  //Paste was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.EditPaste);
    }
    if((string)e.Button.Tag == "Delete")  //Delete was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.EditDelete);
    }
    if((string)e.Button.Tag == "ReorderGroups")  //ReorderGroups was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.ReorderGroups);
    }
}
  • Visual Basic
'tbStandard_ButtonClick - calls ExecuteDesignerAction, or the associated function
'based on the button clicked.
Private Sub tbStandard_ButtonClick(ByVal sender As Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles tbStandard.ButtonClick
    If CStr(e.Button.Tag) = "NewReport" Then 'New Report was Clicked
        Me.ardMain.NewReport()
        Me.FillCombo()
    End If
    If CStr(e.Button.Tag) = "Open" Then 'Open Report was Clicked
        Me.OpenReportFile()
    End If
    If CStr(e.Button.Tag) = "Save" Then 'Save Report was Clicked
        Me.SaveReportFile()
    End If
    If CStr(e.Button.Tag) = "SaveAs" Then 'SaveAs was Clicked
        Me.SaveAsReportFile()
    End If
    If CStr(e.Button.Tag) = "ReportSettings" Then 'ReportSettings was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.ReportSettings)
    End If
    If CStr(e.Button.Tag) = "Undo" Then 'Undo was Clicked
        Me.ardMain.UndoManager.Undo()
    End If
    If CStr(e.Button.Tag) = "Cut" Then 'Cut was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.EditCut)
    End If
    If CStr(e.Button.Tag) = "Copy" Then 'Copy was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.EditCopy)
    End If
    If CStr(e.Button.Tag) = "Paste" Then 'Paste was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.EditPaste)
    End If
    If CStr(e.Button.Tag) = "Delete" Then 'Delete was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.EditDelete)
    End If
    If CStr(e.Button.Tag) = "ReorderGroups" Then 'ReorderGroups was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.ReorderGroups)
    End If
End Sub 'tbStandard_ButtonClick
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Design.UndoManager

See Also

Reference

UndoManager Members
GrapeCity.ActiveReports.Design Namespace


UndoManager Class Members

UndoManager Class Members
Properties Methods Events

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : UndoManager Class

The following tables list the members exposed by UndoManager.

Public Properties
 | Name | Description
Public Property | RedoCount | Returns the number of repeated actions.
Public Property | UndoCount | Returns the number of undone actions.
Top
Public Methods
 | Name | Description
Public Method | Clear | Clears the Undo stack.Clears the Redo stack.
Public Method | Dispose | Releases the UndoManager instance from the memory.
Public Method | Redo | Repeats the last action.
Public Method | RedoDescription | Returns a description of the last repeated action.
Public Method | Undo | Undoes the last action.
Public Method | UndoDescription | Returns a description of the last undone action.
Top
Public Events
 | Name | Description
Public Event | Changed | Raised when the Undo stack has changed.
Top
See Also

Reference

UndoManager Class
GrapeCity.ActiveReports.Design Namespace


UndoManager Class Methods

UndoManager Class Methods

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : UndoManager Class

For a list of all members of this type, see UndoManager members.

Public Methods
 | Name | Description
Public Method | Clear | Clears the Undo stack.Clears the Redo stack.
Public Method | Dispose | Releases the UndoManager instance from the memory.
Public Method | Redo | Repeats the last action.
Public Method | RedoDescription | Returns a description of the last repeated action.
Public Method | Undo | Undoes the last action.
Public Method | UndoDescription | Returns a description of the last undone action.
Top
See Also

Reference

UndoManager Class
GrapeCity.ActiveReports.Design Namespace


Clear Method (UndoManager)

Clear Method (UndoManager)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > UndoManager Class : Clear Method
Clears the Undo stack.Clears the Redo stack.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

UndoManager Class
UndoManager Members


Dispose Method (UndoManager)

Dispose Method (UndoManager)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > UndoManager Class : Dispose Method
Releases the UndoManager instance from the memory.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

UndoManager Class
UndoManager Members


Redo Method

Redo Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > UndoManager Class : Redo Method
Repeats the last action.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Redo()
public void Redo()
See Also

Reference

UndoManager Class
UndoManager Members


RedoDescription Method

RedoDescription Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > UndoManager Class : RedoDescription Method
Specifies the index of the RedoDescription.
Returns a description of the last repeated action.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function RedoDescription( _
   ByVal index As System.Integer _
) As System.String
public System.string RedoDescription(
   System.int index
)

Parameters

index
Specifies the index of the RedoDescription.
See Also

Reference

UndoManager Class
UndoManager Members


Undo Method

Undo Method
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > UndoManager Class : Undo Method
Undoes the last action.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Undo()
public void Undo()
Example
  • C#
// <summary>
/// tbStandard_ButtonClick - calls ExecuteDesignerAction, or the associated function
/// based on the button clicked.
/// </summary>
private void tbStandard_ButtonClick(object sender, System.Windows.Forms.ToolBarButtonClickEventArgs e)
{
    if((string)e.Button.Tag == "NewReport")  //New Report was Clicked
    {
        this.ardMain.NewReport();
        this.FillCombo();
    }
    if((string)e.Button.Tag == "Open")  //Open Report was Clicked
    {
        this.OpenReportFile();
    }
    if((string)e.Button.Tag == "Save")  //Save Report was Clicked
    {
        this.SaveReportFile();
    }
    if((string)e.Button.Tag == "SaveAs")  //SaveAs was Clicked
    {
        this.SaveAsReportFile();
    }
    if((string)e.Button.Tag == "ReportSettings")  //ReportSettings was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.ReportSettings);
    }
    if((string)e.Button.Tag == "Undo")  //Undo was Clicked
    {
        this.ardMain.UndoManager.Undo();
    }
    if((string)e.Button.Tag == "Cut")  //Cut was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.EditCut);
    }
    if((string)e.Button.Tag == "Copy")  //Copy was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.EditCopy);
    }
    if((string)e.Button.Tag == "Paste")  //Paste was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.EditPaste);
    }
    if((string)e.Button.Tag == "Delete")  //Delete was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.EditDelete);
    }
    if((string)e.Button.Tag == "ReorderGroups")  //ReorderGroups was Clicked
    {
        this.ardMain.ExecuteAction(DesignerAction.ReorderGroups);
    }
}
  • Visual Basic
'tbStandard_ButtonClick - calls ExecuteDesignerAction, or the associated function
'based on the button clicked.
Private Sub tbStandard_ButtonClick(ByVal sender As Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles tbStandard.ButtonClick
    If CStr(e.Button.Tag) = "NewReport" Then 'New Report was Clicked
        Me.ardMain.NewReport()
        Me.FillCombo()
    End If
    If CStr(e.Button.Tag) = "Open" Then 'Open Report was Clicked
        Me.OpenReportFile()
    End If
    If CStr(e.Button.Tag) = "Save" Then 'Save Report was Clicked
        Me.SaveReportFile()
    End If
    If CStr(e.Button.Tag) = "SaveAs" Then 'SaveAs was Clicked
        Me.SaveAsReportFile()
    End If
    If CStr(e.Button.Tag) = "ReportSettings" Then 'ReportSettings was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.ReportSettings)
    End If
    If CStr(e.Button.Tag) = "Undo" Then 'Undo was Clicked
        Me.ardMain.UndoManager.Undo()
    End If
    If CStr(e.Button.Tag) = "Cut" Then 'Cut was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.EditCut)
    End If
    If CStr(e.Button.Tag) = "Copy" Then 'Copy was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.EditCopy)
    End If
    If CStr(e.Button.Tag) = "Paste" Then 'Paste was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.EditPaste)
    End If
    If CStr(e.Button.Tag) = "Delete" Then 'Delete was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.EditDelete)
    End If
    If CStr(e.Button.Tag) = "ReorderGroups" Then 'ReorderGroups was Clicked
        Me.ardMain.ExecuteAction(DesignerAction.ReorderGroups)
    End If
End Sub 'tbStandard_ButtonClick
See Also

Reference

UndoManager Class
UndoManager Members


UndoDescription Method

UndoDescription Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > UndoManager Class : UndoDescription Method
Specifies the index of the UndoDescription.
Returns a description of the last undone action.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function UndoDescription( _
   ByVal index As System.Integer _
) As System.String
public System.string UndoDescription(
   System.int index
)

Parameters

index
Specifies the index of the UndoDescription.
See Also

Reference

UndoManager Class
UndoManager Members


UndoManager Class Properties

UndoManager Class Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : UndoManager Class

For a list of all members of this type, see UndoManager members.

Public Properties
 | Name | Description
Public Property | RedoCount | Returns the number of repeated actions.
Public Property | UndoCount | Returns the number of undone actions.
Top
See Also

Reference

UndoManager Class
GrapeCity.ActiveReports.Design Namespace


RedoCount Property

RedoCount Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > UndoManager Class : RedoCount Property
Returns the number of repeated actions.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property RedoCount As System.Integer
public System.int RedoCount {get;}

Property Value

Integer.
See Also

Reference

UndoManager Class
UndoManager Members


UndoCount Property

UndoCount Property
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > UndoManager Class : UndoCount Property
Returns the number of undone actions.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property UndoCount As System.Integer
public System.int UndoCount {get;}

Property Value

Integer.
Example
  • C#
If(this.ardMain.UndoManager.UndoCount == 0 )
{
    this.tSTDUndo.Enabled = False;
    this.mnuEditUndo.Enabled = False;
}
Else
{
    this.tSTDUndo.Enabled = True;
    this.mnuEditUndo.Enabled = True;
}
  • Visual Basic
If Me.ardMain.UndoManager.UndoCount = 0 Then
    Me.tSTDUndo.Enabled = False
    Me.mnuEditUndo.Enabled = False
Else
    Me.tSTDUndo.Enabled = True
    Me.mnuEditUndo.Enabled = True
End If
See Also

Reference

UndoManager Class
UndoManager Members


UndoManager Class Events

UndoManager Class Events

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : UndoManager Class

For a list of all members of this type, see UndoManager members.

Public Events
 | Name | Description
Public Event | Changed | Raised when the Undo stack has changed.
Top
See Also

Reference

UndoManager Class
GrapeCity.ActiveReports.Design Namespace


Changed Event (UndoManager)

Changed Event (UndoManager)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > UndoManager Class : Changed Event
Raised when the Undo stack has changed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Changed As System.EventHandler
public event System.EventHandler Changed
See Also

Reference

UndoManager Class
UndoManager Members


ContextMenuTypes Enumeration

ContextMenuTypes Enumeration

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : ContextMenuTypes Enumeration
Specifies the type of menu that will be opened for this sourceObject.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ContextMenuTypes
   Inherits System.Enum
public enum ContextMenuTypes : System.Enum
Members
Member | Description
Control | Control context menu.
Page | Page context menu.
PageTab | Page tab context menu.
Report | Report object context menu.
RichText | RichText context menu.
Section | Section context menu.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.ContextMenuTypes

See Also

Reference

GrapeCity.ActiveReports.Design Namespace
MenuType Property


DebugMode Enumeration

DebugMode Enumeration

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : DebugMode Enumeration
Specifies the type of debugging.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DebugMode
   Inherits System.Enum
public enum DebugMode : System.Enum
Members
Member | Description
Break | Debugging during a break in run time.
Design | Design time debugging.
Run | Run time debugging.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.DebugMode

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


DesignerAction Enumeration

DesignerAction Enumeration

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : DesignerAction Enumeration
List of available designer commands (actions)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DesignerAction
   Inherits System.Enum
public enum DesignerAction : System.Enum
Members
Member | Description
AddLayer | Adds and activates new layer.
BackColorDlg | Opens the back color editor.
BorderBottom | Sets bottom border.
BorderLeft | Sets left border.
BorderRight | Sets right border.
BordersAll | Sets all borders.
BordersNone | Sets no borders.
BorderTop | Sets top border.
ConnectToServer | The connect to server
ConvertToMaster | Converts the regular RDL report to the RDL Master report.
DataSourceSetup | View: Data Source setup.
DeleteLayer | Removes active layer.
DisconnectFromServer | The disconnect from server
EditCopy | Edit: Copy.
EditCut | Edit: Cut.
EditDelete | Edit: Delete.
EditDesigner | View report Designer tab.
EditOleObject | Edit: Ole object.
EditPaste | Edit: Paste.
EditPreview | View report Preview tab.
EditRedo | Edit: Redo.
EditScript | View: Script code editor.
EditUndo | Edit: Undo.
EnableChartWizard | Enable the chart wizard.
FileOpen | File: Open.
FileSave | File: Save.
ForeColorDlg | Opens the dialog for setting the foreground color for a control.
FormatAlignBottom | Format: Align control bottom.
FormatAlignCenter | Format: Align control center.
FormatAlignLeft | Format: Align control left.
FormatAlignMiddle | Format: Align control middle.
FormatAlignRight | Format: Align control right.
FormatAlignToGrid | Format: Align controls to grid.
FormatAlignTop | Format: Align control top.
FormatBackColor | Format: Background color. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatBorder | Format: Border.
FormatBringToFront | Brings a control to the front of the z-order.
FormatCenterHorizontally | Format: Center control horizontally.
FormatCenterVertically | Format: Center control vertically.
FormatFontBold | Format: Bold. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatFontItalic | Format: Italic. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatFontName | Format: Font name. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatFontSize | Format: Font size. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatFontUnderline | Format: Underline. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatForeColor | Format: Foreground color. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatLineColor | Format: Line color. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatLineStyle | Format: Line style. Note: Font and color actions are not supported in the ExecuteAction method. In order to set font and color properties you should directly access the selected object and set those properties.
FormatLockControls | Format: Lock control size and position.
FormatOrderBringToFront | Format: Bring control to the foreground.
FormatOrderSendToBack | Format: Send control to the background.
FormatRTFBullets | Format: Set RTF bullet style.
FormatRTFIndent | Format: Indent RTF text.
FormatRTFOutdent | Format: Outdent RTF text.
FormatSendToBack | Sends a control to the back of the z-order.
FormatSizeBoth | Format: Size controls to the same width and height.
FormatSizeSameHeight | Format: Size controls to the same height.
FormatSizeSameWidth | Format: Size controls to the same width.
FormatSizeToGrid | Format: Make control sizes correspond to grid marks.
FormatSpaceDecreaseHorizontal | Format: Decrease horizontal spacing.
FormatSpaceDecreaseVertical | Format: Decrease vertical spacing.
FormatSpaceEquallyHorizontal | Format: Space horizontal controls evenly.
FormatSpaceEquallyVertical | Format: Space vertical controls evenly.
FormatSpaceIncreaseHorizontal | Format: Increase horizontal spacing.
FormatSpaceIncreaseVertical | Format: Increase vertical spacing.
FormatSpaceRemoveHorizontal | Format: Remove horizontal spacing.
FormatSpaceRemoveVertical | Format: Remove vertical spacing.
FormatStyle | Format: Style.
FormatTextAlignBottom | Format : Align text bottom
FormatTextAlignCenter | Format: Align text center.
FormatTextAlignJustify | Format: Justify text.
FormatTextAlignLeft | Format: Align text left.
FormatTextAlignMiddle | Format: Align text middle.
FormatTextAlignRight | Format: Align text right.
FormatTextAlignTop | Format: Align text top
GenerateExcelTemplate | Generates the excel template for the RDL reports.
GridMode | Switches the grid mode.
InsertGroupHF | Edit: Insert a Group Header/Footer section pair.
InsertPageHF | Edit: Insert a Page Header/Footer section pair.
InsertReportHF | Edit: Insert a Report Header/Footer section pair.
InsertRTFField | Edit: Insert an RTF Field.
LayerBringToFront | Brings all layers of active layer to the foreground.
LayerSendToBack | Send all controls of active layer to the background.
LayerSetActive | Sets active layer by name.
MouseModePan | Sets the pan mouse mode.
MouseModeSelect | Sets the selection mouse mode
NewReport | Displays the new report dialog.
OpenOutputFormatDialog | Open the OutputFormat dialog.
OpenReportFromServer | Displays the open from server report dialog.
PageFooter | Adds or removes the page footer of the RDL report.
PageHeader | Adds or removes the page header of the RDL report.
ReorderGroups | Edit: Reorder Groups.
ReportImages | Displays the page report images dialog.
ReportParams | Displays the page report parameters dialog.
ReportProperties | Displays the page report properties dialog.
ReportSettings | File: Report Settings.
SaveReportToServer | Displays the save to server report dialog.
SelectAll | Selects all the report controls.
SetMasterReport | Sets the master report of the RDL report.
SetMasterReportFromServer | The set master report from server
SharedDataSets | The shared data sets
SharedDataSources | The shared data sources
ToggleDimensionLines | Turns on/off the dimensions helper lines.
ToggleSnapToGrid | View: Snap to grid instead of using snap lines.
ToggleSnapToLines | View: Use Snap Lines instead of snap to grid. .
ToggleViewGrid | View: Grid.
ZoomActual | Resets the zoom.
ZoomIn | Zooms the report design surface in.
ZoomOut | Zooms the report design surface out.
ZoomValue | Sets the zoom value of the report design surface.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.DesignerAction

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


DesignerReportType Enumeration

DesignerReportType Enumeration

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : DesignerReportType Enumeration
Available report types.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DesignerReportType
   Inherits System.Enum
public enum DesignerReportType : System.Enum
Members
Member | Description
Page | Specifies page report type.
Rdl | Rdl report type.
Section | Specifies section report type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.DesignerReportType

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


DesignerTab Enumeration

DesignerTab Enumeration

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : DesignerTab Enumeration
Lists the available designer tab options.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DesignerTab
   Inherits System.Enum
public enum DesignerTab : System.Enum
Members
Member | Description
Designer | Designer tab.
Preview | Preview tab.
Script | Script tab.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.DesignerTab

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


DesignerToolStrips Enumeration

DesignerToolStrips Enumeration
Example Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : DesignerToolStrips Enumeration
Enumeration of the types of tool strips to use with the designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DesignerToolStrips
   Inherits System.Enum
public enum DesignerToolStrips : System.Enum
Members
Member | Description
All | Adds all of the available tool strips.
Borders | The toolstrip contains the border editors.
Edit | The Edit tool strip includes these tools: Cut, Copy, Paste, and Delete.
Format | The Format tool strip includes these tools: Font Name, Font Size, Bold, Italic, Underline, Fore Color, Back Color, Align Left, Align Center, Align Right, Align Justify, Indent and Outdent.
Layout | The Layout tool strip includes these tools: Align to Grid, Align Lefts, Align Centers, Align Rights, Align Tops, Align Middles, Align Bottoms, Bring to Front, and Send to Back.
Menu | Adds the menu tool strip, which includes the File and Edit menus. The File menu includes these commands: New, Open, Save, and Export. The Edit menu includes these commands: Undo, Redo, Cut, Copy, Paste, Delete, and Select All.
Report | The Report tool strip includes these tools: New, Open, and Save.
Undo | The Undo tool strip includes these tools: Undo and Redo.
Zoom | The Zoom tool strip includes these tools: Zoom Out, Zoom In, Zoom %, and Actual Size.
Example
  • Visual Basic
Private Sub Designer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Designer1.Load
        Dim menuStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Menu)(0)
        Dim editStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Edit)(0)
        Dim formatStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Format)(0)
        Dim layoutStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Layout)(0)
        Dim reportStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Report)(0)
        Dim undoStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Undo)(0)
        Dim zoomStrip As ToolStrip = Me.Designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Zoom)(0)
        Me.ToolStripContainer1.TopToolStripPanel.Join(menuStrip, 0)
        Me.ToolStripContainer1.TopToolStripPanel.Join(editStrip, 1)
        Me.ToolStripContainer1.TopToolStripPanel.Join(formatStrip, 2)
        Me.ToolStripContainer1.TopToolStripPanel.Join(layoutStrip, 3)
        Me.ToolStripContainer1.TopToolStripPanel.Join(reportStrip, 4)
        Me.ToolStripContainer1.TopToolStripPanel.Join(undoStrip, 5)
        Me.ToolStripContainer1.TopToolStripPanel.Join(zoomStrip, 6)
    End Sub
  • C#
private void designer1_Load(object sender, EventArgs e)
        {
            ToolStrip menuStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Menu)[0];
            ToolStrip editStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Edit)[0];
            ToolStrip formatStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Format)[0];
            ToolStrip layoutStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Layout)[0];
            ToolStrip reportStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Report)[0];
            ToolStrip undoStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Undo)[0];
            ToolStrip zoomStrip = this.designer1.CreateToolStrips(GrapeCity.ActiveReports.Design.DesignerToolStrips.Zoom)[0];
            this.toolStripContainer1.TopToolStripPanel.Join(menuStrip, 0);
            this.toolStripContainer1.TopToolStripPanel.Join(editStrip, 1);
            this.toolStripContainer1.TopToolStripPanel.Join(formatStrip, 2);
            this.toolStripContainer1.TopToolStripPanel.Join(layoutStrip, 3);
            this.toolStripContainer1.TopToolStripPanel.Join(reportStrip, 4);
            this.toolStripContainer1.TopToolStripPanel.Join(undoStrip, 5);
            this.toolStripContainer1.TopToolStripPanel.Join(zoomStrip, 6);
        }
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.DesignerToolStrips

See Also

Reference

GrapeCity.ActiveReports.Design Namespace
CreateToolStrips Method


ExitType Enumeration

ExitType Enumeration

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : ExitType Enumeration
Specifies the action to perform when the user exits edit mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ExitType
   Inherits System.Enum
public enum ExitType : System.Enum
Members
Member | Description
Cancel | Restore the previous state of the control.
Save | Save any changes made to the control during edit mode.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.ExitType

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


GridMode Enumeration

GridMode Enumeration

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : GridMode Enumeration
Specifies the type of the grid to draw in the designer surface.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum GridMode
   Inherits System.Enum
public enum GridMode : System.Enum
Members
Member | Description
Dots | Specifies the dots grid type.
Lines | Specifies the lines grid type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.GridMode

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


LayoutChangeType Enumeration

LayoutChangeType Enumeration

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangeType Enumeration
Enumeration of change settings for the report layout.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LayoutChangeType
   Inherits System.Enum
public enum LayoutChangeType : System.Enum
Members
Member | Description
ControlAdd | A control has been added.
ControlDelete | A control has been deleted.
ControlMove | A control has been moved.
ControlSize | The size of a control has changed.
ControlZOrder | A control's ZOrder has been changed.
ReportClear | The report has been cleared.
ReportLoad | A report has been loaded.
ReportSize | A report's size has changed.
SectionAdd | A section has been added.
SectionDelete | A section has been deleted.
SectionMove | A section has been moved.
SectionSize | The size of a section has changed.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.LayoutChangeType

See Also

Reference

GrapeCity.ActiveReports.Design Namespace
LayoutChangedArgs Class


LayoutMode Enumeration

LayoutMode Enumeration

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutMode Enumeration
Enumeration of modes for laying out controls on the report designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LayoutMode
   Inherits System.Enum
public enum LayoutMode : System.Enum
Members
Member | Description
DimHelperLines | Specifies dimensions helper line layout mode.
None | Allow free movement of controls.
SnapGrid | Snap controls to the grid.
SnapLines | Snap controls to lines showing alignment to other controls.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.LayoutMode

See Also

Reference

GrapeCity.ActiveReports.Design Namespace
LayoutMode Property


MeasurementUnits Enumeration

MeasurementUnits Enumeration

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : MeasurementUnits Enumeration
Specifies the ruler measurement units.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MeasurementUnits
   Inherits System.Enum
public enum MeasurementUnits : System.Enum
Members
Member | Description
Inches | Inches.
Metric | Centimeters.
Point | Points.
System | Unit specified in the system.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.MeasurementUnits

See Also

Reference

GrapeCity.ActiveReports.Design Namespace
DesignerUnits Property


MouseMode Enumeration

MouseMode Enumeration

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : MouseMode Enumeration
Available designer MouseMode types.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MouseMode
   Inherits System.Enum
public enum MouseMode : System.Enum
Members
Member | Description
Pan | Pan Mode.
Select | Select Mode.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.MouseMode

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


ReportExplorerNodes Enumeration

ReportExplorerNodes Enumeration

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : ReportExplorerNodes Enumeration
The visibility of the nodes in ReportExplorer
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ReportExplorerNodes
   Inherits System.Enum
public enum ReportExplorerNodes : System.Enum
Members
Member | Description
All | Show all.
DataSourceAndFields | Show datasources and fields.
None | Hide all.
Parameters | Show parameters.
Settings | Show settings.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.ReportExplorerNodes

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


ToolPanelButton Enumeration

ToolPanelButton Enumeration

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : ToolPanelButton Enumeration
Controls the visibility of ToolPanelButton controls on the Designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ToolPanelButton
   Inherits System.Enum
public enum ToolPanelButton : System.Enum
Members
Member | Description
All | Show or hide all the available buttons
ConnectionStatus | Show or hide the ConnectionStatus icon.
DimensionLines | Show or hide the DimensionLines button
GridMode | Show or hide the GridMode button
MouseMode | Show or hide the MouseMode button
None | Displays no button
SnapGrid | Show or hide the SnapGrid button
SnapLines | Show or hide the SnapLines button
ZoomSlider | Show or hide the ZoomSlider button
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Design.ToolPanelButton

See Also

Reference

GrapeCity.ActiveReports.Design Namespace


ITrackSelectionService Interface

ITrackSelectionService Interface
Members

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : ITrackSelectionService Interface
Defines the common interface that enables the transmission of events related to change in selection in the host environment.
Object Model
ITrackSelectionService Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITrackSelectionService
public interface ITrackSelectionService
See Also

Reference

ITrackSelectionService Members
GrapeCity.ActiveReports.Design Namespace


ITrackSelectionService Interface Members

ITrackSelectionService Interface Members
Methods Events

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : ITrackSelectionService Interface

The following tables list the members exposed by ITrackSelectionService.

Public Methods
 | Name | Description
Method | OnSelectChange | Reports that the currently selected container has been changed.
Method | RefreshPropertyBrowser | Updates all the properties within the properties browser.
Method | ShowFrame | Checks whether the focus or the routing of command has been updated correctly, based on the activation of the hosting window frame.
Top
Public Events
 | Name | Description
Event | SelectionChange | This event is fired when there is a change in the state of the currently selected container.
Top
See Also

Reference

ITrackSelectionService Interface
GrapeCity.ActiveReports.Design Namespace


ITrackSelectionService Interface Methods

ITrackSelectionService Interface Methods

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : ITrackSelectionService Interface

For a list of all members of this type, see ITrackSelectionService members.

Public Methods
 | Name | Description
Method | OnSelectChange | Reports that the currently selected container has been changed.
Method | RefreshPropertyBrowser | Updates all the properties within the properties browser.
Method | ShowFrame | Checks whether the focus or the routing of command has been updated correctly, based on the activation of the hosting window frame.
Top
See Also

Reference

ITrackSelectionService Interface
GrapeCity.ActiveReports.Design Namespace


OnSelectChange Method

OnSelectChange Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > ITrackSelectionService Interface : OnSelectChange Method
Reports that the currently selected container has been changed.
Syntax
  • Visual Basic
  • C#
'Declaration

Function OnSelectChange() As System.Integer
System.int OnSelectChange()
See Also

Reference

ITrackSelectionService Interface
ITrackSelectionService Members


RefreshPropertyBrowser Method

RefreshPropertyBrowser Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > ITrackSelectionService Interface : RefreshPropertyBrowser Method
Updates all the properties within the properties browser.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub RefreshPropertyBrowser()
void RefreshPropertyBrowser()
See Also

Reference

ITrackSelectionService Interface
ITrackSelectionService Members


ShowFrame Method

ShowFrame Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > ITrackSelectionService Interface : ShowFrame Method
Checks whether the focus or the routing of command has been updated correctly, based on the activation of the hosting window frame.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub ShowFrame()
void ShowFrame()
See Also

Reference

ITrackSelectionService Interface
ITrackSelectionService Members


ITrackSelectionService Interface Events

ITrackSelectionService Interface Events

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : ITrackSelectionService Interface

For a list of all members of this type, see ITrackSelectionService members.

Public Events
 | Name | Description
Event | SelectionChange | This event is fired when there is a change in the state of the currently selected container.
Top
See Also

Reference

ITrackSelectionService Interface
GrapeCity.ActiveReports.Design Namespace


SelectionChange Event

SelectionChange Event

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > ITrackSelectionService Interface : SelectionChange Event
This event is fired when there is a change in the state of the currently selected container.
Syntax
  • Visual Basic
  • C#
'Declaration

Event SelectionChange As System.EventHandler
event System.EventHandler SelectionChange
See Also

Reference

ITrackSelectionService Interface
ITrackSelectionService Members


IVsPackageIntegration Interface

IVsPackageIntegration Interface
Members

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : IVsPackageIntegration Interface
Provides an interface for the IVsPackageIntegration service.
Object Model
IVsPackageIntegration Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IVsPackageIntegration
public interface IVsPackageIntegration
See Also

Reference

IVsPackageIntegration Members
GrapeCity.ActiveReports.Design Namespace


IVsPackageIntegration Interface Members

IVsPackageIntegration Interface Members
Methods

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : IVsPackageIntegration Interface

The following tables list the members exposed by IVsPackageIntegration.

Public Methods
 | Name | Description
Method | GetStyleSheets | Returns the Stylesheets.
Method | OnDebugModeChanged | Specifies the function that is called if the debugging mode changes.
Method | OnSolutionBuilding | Specifies the function that is called before any solution build action is initialized.
Top
See Also

Reference

IVsPackageIntegration Interface
GrapeCity.ActiveReports.Design Namespace


IVsPackageIntegration Interface Methods

IVsPackageIntegration Interface Methods

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : IVsPackageIntegration Interface

For a list of all members of this type, see IVsPackageIntegration members.

Public Methods
 | Name | Description
Method | GetStyleSheets | Returns the Stylesheets.
Method | OnDebugModeChanged | Specifies the function that is called if the debugging mode changes.
Method | OnSolutionBuilding | Specifies the function that is called before any solution build action is initialized.
Top
See Also

Reference

IVsPackageIntegration Interface
GrapeCity.ActiveReports.Design Namespace


GetStyleSheets Method

GetStyleSheets Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > IVsPackageIntegration Interface : GetStyleSheets Method
Returns the Stylesheets.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetStyleSheets() As System.String()
System.string[] GetStyleSheets()
See Also

Reference

IVsPackageIntegration Interface
IVsPackageIntegration Members


OnDebugModeChanged Method

OnDebugModeChanged Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > IVsPackageIntegration Interface : OnDebugModeChanged Method
A value from the DebugMode enumeration, indicating the new debugger mode.
Specifies the function that is called if the debugging mode changes.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub OnDebugModeChanged( _
   ByVal dbgmodeNew As DebugMode _
)
void OnDebugModeChanged(
   DebugMode dbgmodeNew
)

Parameters

dbgmodeNew
A value from the DebugMode enumeration, indicating the new debugger mode.
See Also

Reference

IVsPackageIntegration Interface
IVsPackageIntegration Members


OnSolutionBuilding Method

OnSolutionBuilding Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > IVsPackageIntegration Interface : OnSolutionBuilding Method
Specifies the function that is called before any solution build action is initialized.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub OnSolutionBuilding()
void OnSolutionBuilding()
See Also

Reference

IVsPackageIntegration Interface
IVsPackageIntegration Members


ContextMenuOpenEventHandler Delegate

ContextMenuOpenEventHandler Delegate

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : ContextMenuOpenEventHandler Delegate
The source of the event.
ContextMenuOpenArgs class which contains the event data.
Represents a method that handles the ContextMenuOpen event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub ContextMenuOpenEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As ContextMenuOpenArgs _
)
public delegate void ContextMenuOpenEventHandler(
   System.object sender,
   ContextMenuOpenArgs e
)

Parameters

sender
The source of the event.
e
ContextMenuOpenArgs class which contains the event data.
See Also

Reference

ContextMenuOpenEventHandler Members
GrapeCity.ActiveReports.Design Namespace


DataSourceIconClickedEventHandler Delegate

DataSourceIconClickedEventHandler Delegate

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : DataSourceIconClickedEventHandler Delegate
The source of the event.
DataSourceIconClickedEventArgs class which contains the event data.
Represents a method that handles the DataSourceIconClicked event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub DataSourceIconClickedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As DataSourceIconClickedEventArgs _
)
public delegate void DataSourceIconClickedEventHandler(
   System.object sender,
   DataSourceIconClickedEventArgs e
)

Parameters

sender
The source of the event.
e
DataSourceIconClickedEventArgs class which contains the event data.
See Also

Reference

DataSourceIconClickedEventHandler Members
GrapeCity.ActiveReports.Design Namespace


DataSourceIconClickEventHandler Delegate

DataSourceIconClickEventHandler Delegate

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : DataSourceIconClickEventHandler Delegate
The source of the event.
DataSourceIconClickArgs class which contains the event data.
Represents a method that handles the DataSourceIconClick event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub DataSourceIconClickEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As DataSourceIconClickEventArgs _
)
public delegate void DataSourceIconClickEventHandler(
   System.object sender,
   DataSourceIconClickEventArgs e
)

Parameters

sender
The source of the event.
e
DataSourceIconClickArgs class which contains the event data.
See Also

Reference

DataSourceIconClickEventHandler Members
GrapeCity.ActiveReports.Design Namespace


DesignerTabChangedEventHandler Delegate

DesignerTabChangedEventHandler Delegate

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : DesignerTabChangedEventHandler Delegate
The source of the event.
A DesignerTabChangedEventArgs that does not contain any event data.
Represents the method that handles the event, containing the active tab information.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub DesignerTabChangedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As DesignerTabChangedEventArgs _
)
public delegate void DesignerTabChangedEventHandler(
   System.object sender,
   DesignerTabChangedEventArgs e
)

Parameters

sender
The source of the event.
e
A DesignerTabChangedEventArgs that does not contain any event data.
See Also

Reference

DesignerTabChangedEventHandler Members
GrapeCity.ActiveReports.Design Namespace


EditModeEnteringEventHandler Delegate

EditModeEnteringEventHandler Delegate

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : EditModeEnteringEventHandler Delegate
The source of the event.
A EditModeEnteringEventArgs that does not contain any event data.
Represents a method that handles the EditModeEntering event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub EditModeEnteringEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As EditModeEnteringEventArgs _
)
public delegate void EditModeEnteringEventHandler(
   System.object sender,
   EditModeEnteringEventArgs e
)

Parameters

sender
The source of the event.
e
A EditModeEnteringEventArgs that does not contain any event data.
See Also

Reference

EditModeEnteringEventHandler Members
GrapeCity.ActiveReports.Design Namespace


EditModeExitEventHandler Delegate

EditModeExitEventHandler Delegate

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : EditModeExitEventHandler Delegate
The source of the event.
A EditModeExitEventArgs that does not contain any event data.
Represents a method that handles the EditModeExit event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub EditModeExitEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As EditModeExitEventArgs _
)
public delegate void EditModeExitEventHandler(
   System.object sender,
   EditModeExitEventArgs e
)

Parameters

sender
The source of the event.
e
A EditModeExitEventArgs that does not contain any event data.
See Also

Reference

EditModeExitEventHandler Members
GrapeCity.ActiveReports.Design Namespace


LayoutChangedEventHandler Delegate

LayoutChangedEventHandler Delegate

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangedEventHandler Delegate
The source of the event.
A LayoutChangedArgs that does not contain any event data.
Represents a method that handles the LayoutChanged event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub LayoutChangedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As LayoutChangedArgs _
)
public delegate void LayoutChangedEventHandler(
   System.object sender,
   LayoutChangedArgs e
)

Parameters

sender
The source of the event.
e
A LayoutChangedArgs that does not contain any event data.
See Also

Reference

LayoutChangedEventHandler Members
GrapeCity.ActiveReports.Design Namespace


LayoutChangingEventHandler Delegate

LayoutChangingEventHandler Delegate

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : LayoutChangingEventHandler Delegate
The source of the event.
A LayoutChangingArgs that does not contain any event data.
Represents a method that handles the LayoutChanging method.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub LayoutChangingEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As LayoutChangingArgs _
)
public delegate void LayoutChangingEventHandler(
   System.object sender,
   LayoutChangingArgs e
)

Parameters

sender
The source of the event.
e
A LayoutChangingArgs that does not contain any event data.
See Also

Reference

LayoutChangingEventHandler Members
GrapeCity.ActiveReports.Design Namespace


ScriptChangedEventHandler Delegate

ScriptChangedEventHandler Delegate

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : ScriptChangedEventHandler Delegate
The source of the event.
A ScriptEditorEventArgs that does not contain any event data.
Represents a method that handles the ScriptChanged event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub ScriptChangedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As ScripEditorEventArgs _
)
public delegate void ScriptChangedEventHandler(
   System.object sender,
   ScripEditorEventArgs e
)

Parameters

sender
The source of the event.
e
A ScriptEditorEventArgs that does not contain any event data.
See Also

Reference

ScriptChangedEventHandler Members
GrapeCity.ActiveReports.Design Namespace


SelectionChangedEventHandler Delegate

SelectionChangedEventHandler Delegate

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : SelectionChangedEventHandler Delegate
Represents a method that handles the SelectionChanged event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub SelectionChangedEventHandler()
public delegate void SelectionChangedEventHandler()
See Also

Reference

SelectionChangedEventHandler Members
GrapeCity.ActiveReports.Design Namespace


ServerConnectionChangedEventHandler Delegate

ServerConnectionChangedEventHandler Delegate

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : ServerConnectionChangedEventHandler Delegate
Delegate for ServerConnectionChanged event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub ServerConnectionChangedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As ServerConnectionChangedEventArgs _
)
public delegate void ServerConnectionChangedEventHandler(
   System.object sender,
   ServerConnectionChangedEventArgs e
)

Parameters

sender
e
See Also

Reference

ServerConnectionChangedEventHandler Members
GrapeCity.ActiveReports.Design Namespace


StatusChangedEventHandler Delegate

StatusChangedEventHandler Delegate

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : StatusChangedEventHandler Delegate
The source of the event.
LayoutChangingArgs class which contains the event data.
Represents a method that handles the StatusChanged event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub StatusChangedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)
public delegate void StatusChangedEventHandler(
   System.object sender,
   System.EventArgs e
)

Parameters

sender
The source of the event.
e
LayoutChangingArgs class which contains the event data.
See Also

Reference

StatusChangedEventHandler Members
GrapeCity.ActiveReports.Design Namespace


ToolboxItemChangedEventHandler Delegate

ToolboxItemChangedEventHandler Delegate

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : ToolboxItemChangedEventHandler Delegate
The source of the event.
ToolboxItemChangedArgs class which contains the event data.
Represents a method that will handle the ToolboxItemChanged event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub ToolboxItemChangedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)
public delegate void ToolboxItemChangedEventHandler(
   System.object sender,
   System.EventArgs e
)

Parameters

sender
The source of the event.
e
ToolboxItemChangedArgs class which contains the event data.
See Also

Reference

ToolboxItemChangedEventHandler Members
GrapeCity.ActiveReports.Design Namespace


GrapeCity.ActiveReports.Design.ReportExplorer Namespace

GrapeCity.ActiveReports.Design.ReportExplorer Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Design.Win.v10 Assembly : GrapeCity.ActiveReports.Design.ReportExplorer Namespace
The GrapeCity.ActiveReports.Design.ReportExplorer namespace includes the ReportExplorer class which is the base class for the ReportExplorer control.
Classes
 | Class | Description
Class | ReportExplorer | Represents ActiveReports Report Explorer.
Remarks
The ReportExplorer control can be used in conjunction with the End-User Report Designer control to show the report sections and controls as well as a list of available data source fields based on the report's current database connection.
See Also

Reference

GrapeCity.ActiveReports.Design.Win.v10 Assembly


ReportExplorer Class

ReportExplorer Class
Members

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace : ReportExplorer Class
Represents ActiveReports Report Explorer.
Object Model
ReportExplorer Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ReportExplorer
   Inherits System.Windows.Forms.UserControl
public class ReportExplorer : System.Windows.Forms.UserControl
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
GrapeCity.ActiveReports.Design.ReportExplorer.ReportExplorer

Requirements

See Also

Reference

ReportExplorer Members
GrapeCity.ActiveReports.Design.ReportExplorer Namespace


ReportExplorer Class Members

ReportExplorer Class Members
Properties Methods Events

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace : ReportExplorer Class

The following tables list the members exposed by ReportExplorer.

Public Constructors
 | Name | Description
Public Constructor | ReportExplorer Constructor | Initializes a new instance of the ReportExplorer class.
Top
Public Properties
 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContentsVisible | Determines whether the ReportExplorer's Report Contents window is visible.
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | ParametersModifiable | Gets or sets a value indicating whether the end user may modify parameters.
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Report | Binds the ReportExplorer control to the specified report.
Public Property | ReportDesigner | Binds the ReportExplorer control to the End-User Report Designer control.
Public Property | ReportSettingsVisible | Gets or sets a value indicating whether the Report Settings window is visible.
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | VisibleNodes | The visibility of the nodes.
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Top
Public Methods
 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top
Public Events
 | Name | Description
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SelectionChanged | Raised when selection being changed or new model was set.
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

ReportExplorer Class
GrapeCity.ActiveReports.Design.ReportExplorer Namespace


ReportExplorer Constructor

ReportExplorer Constructor

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ReportExplorer Constructor
Initializes a new instance of the ReportExplorer class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ReportExplorer()
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ReportExplorer Class Properties

ReportExplorer Class Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace : ReportExplorer Class

For a list of all members of this type, see ReportExplorer members.

Public Properties
 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContentsVisible | Determines whether the ReportExplorer's Report Contents window is visible.
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | ParametersModifiable | Gets or sets a value indicating whether the end user may modify parameters.
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Report | Binds the ReportExplorer control to the specified report.
Public Property | ReportDesigner | Binds the ReportExplorer control to the End-User Report Designer control.
Public Property | ReportSettingsVisible | Gets or sets a value indicating whether the Report Settings window is visible.
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | VisibleNodes | The visibility of the nodes.
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

ReportExplorer Class
GrapeCity.ActiveReports.Design.ReportExplorer Namespace


ContentsVisible Property

ContentsVisible Property
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ContentsVisible Property
Determines whether the ReportExplorer's Report Contents window is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ContentsVisible As System.Boolean
public System.bool ContentsVisible {get; set;}

Property Value

Boolean value. If True, the ReportExplorer's Report Contents window is visible. If False, the ReportExplorer's Report Contents window is not visible.
Example
  • C#
private void Form1_Load(object sender, System.EventArgs e)
{
    this.reportExplorer1.ContentsVisible = true;
}
  • Visual Basic
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Me.ReportExplorer1.ContentsVisible = True
End Sub
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ParametersModifiable Property

ParametersModifiable Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ParametersModifiable Property
Gets or sets a value indicating whether the end user may modify parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ParametersModifiable As System.Boolean
public System.bool ParametersModifiable {get; set;}

Property Value

Boolean value. If True, the parameters may be modified. If False, the parameters cannot be modified.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Report Property (ReportExplorer)

Report Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Report Property
Binds the ReportExplorer control to the specified report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Report As SectionReport
public SectionReport Report {get; set;}

Property Value

An ActiveReport object.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ReportDesigner Property (ReportExplorer)

ReportDesigner Property (ReportExplorer)
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ReportDesigner Property
Binds the ReportExplorer control to the End-User Report Designer control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportDesigner As Designer
public Designer ReportDesigner {get; set;}

Property Value

A Designer object.
Example
  • C#
private void Form1_Load(object sender, System.EventArgs e)
{
    this.reportExplorer1.ReportDesigner = this.designer1;
}
  • Visual Basic
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Me.ReportExplorer1.ReportDesigner = Me.Designer1
End Sub
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ReportSettingsVisible Property

ReportSettingsVisible Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ReportSettingsVisible Property
Gets or sets a value indicating whether the Report Settings window is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportSettingsVisible As System.Boolean
public System.bool ReportSettingsVisible {get; set;}

Property Value

Boolean value. If True, the Report Settings window is visible. If False, the window cannot be seen by the end user.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


VisibleNodes Property

VisibleNodes Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : VisibleNodes Property
The visibility of the nodes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property VisibleNodes As ReportExplorerNodes
public ReportExplorerNodes VisibleNodes {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ReportExplorer Class Events

ReportExplorer Class Events

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace : ReportExplorer Class

For a list of all members of this type, see ReportExplorer members.

Public Events
 | Name | Description
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SelectionChanged | Raised when selection being changed or new model was set.
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

ReportExplorer Class
GrapeCity.ActiveReports.Design.ReportExplorer Namespace


SelectionChanged Event (ReportExplorer)

SelectionChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : SelectionChanged Event
Raised when selection being changed or new model was set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event SelectionChanged As System.Action
public event System.Action SelectionChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


GrapeCity.ActiveReports.Design.Toolbox Namespace

GrapeCity.ActiveReports.Design.Toolbox Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Design.Win.v10 Assembly : GrapeCity.ActiveReports.Design.Toolbox Namespace
The GrapeCity.ActiveReports.Design.Toolbox namespace contains classes for adding controls to the designer toolbox.
Classes
 | Class | Description
Class | Group | Represents a grouping of related tools within the Toolbox control.
Class | GroupChangedEventArgs | Provides data for the GroupChanged event of the GroupListBar object.
Class | Toolbox | The base class for the Toolbox control that provides the methods and properties to manage and query the Designer toolbox.
Class | ToolClickEventArgs | Provides data for the ToolClick event.
See Also

Reference

GrapeCity.ActiveReports.Design.Win.v10 Assembly


Group Class

Group Class
Members

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : Group Class
Represents a grouping of related tools within the Toolbox control.
Object Model
Group Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Group
   Inherits System.ComponentModel.Component
public sealed class Group : System.ComponentModel.Component
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Design.Toolbox.Group

See Also

Reference

Group Members
GrapeCity.ActiveReports.Design.Toolbox Namespace


Group Class Members

Group Class Members
Properties Methods Events

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : Group Class

The following tables list the members exposed by Group.

Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the group caption. The default value is 'Group'.
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Group Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


Group Class Properties

Group Class Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : Group Class

For a list of all members of this type, see Group members.

Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the group caption. The default value is 'Group'.
Top
See Also

Reference

Group Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


Text Property (Group)

Text Property (Group)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Group Class : Text Property
Gets or sets the group caption. The default value is 'Group'.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Text As System.String
public System.string Text {get; set;}
See Also

Reference

Group Class
Group Members


GroupChangedEventArgs Class

GroupChangedEventArgs Class
Members

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : GroupChangedEventArgs Class
Provides data for the GroupChanged event of the GroupListBar object.
Object Model
GroupChangedEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class GroupChangedEventArgs
   Inherits System.EventArgs
public sealed class GroupChangedEventArgs : System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.Toolbox.GroupChangedEventArgs

See Also

Reference

GroupChangedEventArgs Members
GrapeCity.ActiveReports.Design.Toolbox Namespace


GroupChangedEventArgs Class Members

GroupChangedEventArgs Class Members
Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : GroupChangedEventArgs Class

The following tables list the members exposed by GroupChangedEventArgs.

Public Properties
 | Name | Description
Public Property | Group | Gets the currently selected group.
Top
See Also

Reference

GroupChangedEventArgs Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


GroupChangedEventArgs Class Properties

GroupChangedEventArgs Class Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : GroupChangedEventArgs Class

For a list of all members of this type, see GroupChangedEventArgs members.

Public Properties
 | Name | Description
Public Property | Group | Gets the currently selected group.
Top
See Also

Reference

GroupChangedEventArgs Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


Group Property (GroupChangedEventArgs)

Group Property (GroupChangedEventArgs)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > GroupChangedEventArgs Class : Group Property
Gets the currently selected group.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Group As System.String
public System.string Group {get;}
See Also

Reference

GroupChangedEventArgs Class
GroupChangedEventArgs Members


Toolbox Class

Toolbox Class
Members

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : Toolbox Class
The base class for the Toolbox control that provides the methods and properties to manage and query the Designer toolbox.
Object Model
Toolbox Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Toolbox
   Inherits GroupListbar
public sealed class Toolbox : GroupListbar
Remarks
The Toolbox control can be used in conjunction with the End-User Report Designer control to provide a drag-and-drop interface of the tools available for use on reports.
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
GrapeCity.ActiveReports.Design.Toolbox.Toolbox

See Also

Reference

Toolbox Members
GrapeCity.ActiveReports.Design.Toolbox Namespace


Toolbox Class Members

Toolbox Class Members
Properties Methods Events

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : Toolbox Class

The following tables list the members exposed by Toolbox.

Public Constructors
 | Name | Description
Public Constructor | Toolbox Constructor | Initializes a new instance of the Toolbox class.
Top
Public Properties
 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CategoryNames | Gets the System.Drawing.Design CategoryNameCollection containing the categories available in the toolbox.
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DesignerHost | DesignerHost provides additional features for toolbox then it used as part of designer application
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | Groups | Returns groups collection.
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | SelectedCategory | Gets or sets the currently selected toolbox category.
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Top
Public Methods
 | Name | Description
Public Method | AddCreator | Overloaded. Adds a System.Drawing.Design ToolboxItemCreatorCallback delegate that you can use to convert data that was pasted or dropped onto the toolbox into a ToolboxItem.
Public Method | AddLinkedToolboxItem | Overloaded. Adds a ToolboxItem that is only available in the current project to the specified category in the toolbox.
Public Method | AddToolboxItem | Overloaded. Adds a ToolboxItem to the specified category in the toolbox.
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | DeserializeToolboxItem | Overloaded. Gets a ToolboxItem from the specified serialized object.
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EnableCategory | Specifies a category name to enable or disable.
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetGroups | Returns a read-only wrapper for the Groups collection.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | GetSelectedToolboxItem | Overloaded. Gets the currently selected ToolboxItem.
Public Method | GetToolboxItems | Overloaded. Gets the ToolboxItemCollection associated with the specified host from the specified category in the toolbox.
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | IsSupported | Overloaded. Indicates whether the ToolboxItem in the specified serialized object is matches the specified attributes.
Public Method | IsToolboxItem | Overloaded. Indicates whether the item in the specified serialized object that is supported by the specified host is a ToolboxItem.
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | RemoveToolboxItem | Overloaded. Removes the specified ToolboxItem from the specified category in the toolbox.
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectedToolboxItemUsed | Signals the toolbox that the selected ToolboxItem has been used.
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SerializeToolboxItem | Creates a serialized System.Object representing the specified ToolboxItem.
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetCursor | Sets the cursor to a cursor that represents the current ToolboxItem.
Public Method | SetSelectedToolboxItem | Selects the specified ToolboxItem.
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top
Public Events
 | Name | Description
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

Toolbox Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


Toolbox Constructor

Toolbox Constructor

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Toolbox Constructor
Initializes a new instance of the Toolbox class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Toolbox()
See Also

Reference

Toolbox Class
Toolbox Members


Toolbox Class Methods

Toolbox Class Methods

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : Toolbox Class

For a list of all members of this type, see Toolbox members.

Public Methods
 | Name | Description
Public Method | AddCreator | Overloaded. Adds a System.Drawing.Design ToolboxItemCreatorCallback delegate that you can use to convert data that was pasted or dropped onto the toolbox into a ToolboxItem.
Public Method | AddLinkedToolboxItem | Overloaded. Adds a ToolboxItem that is only available in the current project to the specified category in the toolbox.
Public Method | AddToolboxItem | Overloaded. Adds a ToolboxItem to the specified category in the toolbox.
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | DeserializeToolboxItem | Overloaded. Gets a ToolboxItem from the specified serialized object.
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EnableCategory | Specifies a category name to enable or disable.
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetGroups | Returns a read-only wrapper for the Groups collection.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | GetSelectedToolboxItem | Overloaded. Gets the currently selected ToolboxItem.
Public Method | GetToolboxItems | Overloaded. Gets the ToolboxItemCollection associated with the specified host from the specified category in the toolbox.
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | IsSupported | Overloaded. Indicates whether the ToolboxItem in the specified serialized object is matches the specified attributes.
Public Method | IsToolboxItem | Overloaded. Indicates whether the item in the specified serialized object that is supported by the specified host is a ToolboxItem.
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | RemoveToolboxItem | Overloaded. Removes the specified ToolboxItem from the specified category in the toolbox.
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectedToolboxItemUsed | Signals the toolbox that the selected ToolboxItem has been used.
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SerializeToolboxItem | Creates a serialized System.Object representing the specified ToolboxItem.
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetCursor | Sets the cursor to a cursor that represents the current ToolboxItem.
Public Method | SetSelectedToolboxItem | Selects the specified ToolboxItem.
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top
See Also

Reference

Toolbox Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


AddCreator Method

AddCreator Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AddCreator Method
Adds a System.Drawing.Design ToolboxItemCreatorCallback delegate that you can use to convert data that was pasted or dropped onto the toolbox into a ToolboxItem.
Overload List
Overload | Description
AddCreator(ToolboxItemCreatorCallback,String,IDesignerHost) | Adds a System.Drawing.Design ToolboxItemCreatorCallback delegate that you can use to convert data that was pasted or dropped onto the toolbox into a ToolboxItem.
AddCreator(ToolboxItemCreatorCallback,String) | Adds a System.Drawing.Design ToolboxItemCreatorCallback delegate that you can use to convert data that was pasted or dropped onto the toolbox into a ToolboxItem.
See Also

Reference

Toolbox Class
Toolbox Members


AddCreator(ToolboxItemCreatorCallback,String,IDesignerHost) Method

AddCreator(ToolboxItemCreatorCallback,String,IDesignerHost) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > AddCreator Method : AddCreator(ToolboxItemCreatorCallback,String,IDesignerHost) Method
A System.Drawing.Design ToolboxItemCreatorCallback delegate.
A String that describes the data format that the creator handles.
A System.ComponentModel.Design IDesignerHost interface to associate with the creator. (This is not available in Visual Studio 2008.) If null (or Nothing in VB), the creator is available to any designer.
Adds a System.Drawing.Design ToolboxItemCreatorCallback delegate that you can use to convert data that was pasted or dropped onto the toolbox into a ToolboxItem.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddCreator( _
   ByVal creator As System.Drawing.Design.ToolboxItemCreatorCallback, _
   ByVal format As System.String, _
   ByVal host As System.ComponentModel.Design.IDesignerHost _
)
public void AddCreator(
   System.Drawing.Design.ToolboxItemCreatorCallback creator,
   System.string format,
   System.ComponentModel.Design.IDesignerHost host
)

Parameters

creator
A System.Drawing.Design ToolboxItemCreatorCallback delegate.
format
A String that describes the data format that the creator handles.
host
A System.ComponentModel.Design IDesignerHost interface to associate with the creator. (This is not available in Visual Studio 2008.) If null (or Nothing in VB), the creator is available to any designer.
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


AddCreator(ToolboxItemCreatorCallback,String) Method

AddCreator(ToolboxItemCreatorCallback,String) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > AddCreator Method : AddCreator(ToolboxItemCreatorCallback,String) Method
A System.Drawing.Design ToolboxItemCreatorCallback delegate.
A String that describes the data format that the creator handles.
Adds a System.Drawing.Design ToolboxItemCreatorCallback delegate that you can use to convert data that was pasted or dropped onto the toolbox into a ToolboxItem.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddCreator( _
   ByVal creator As System.Drawing.Design.ToolboxItemCreatorCallback, _
   ByVal format As System.String _
)
public void AddCreator(
   System.Drawing.Design.ToolboxItemCreatorCallback creator,
   System.string format
)

Parameters

creator
A System.Drawing.Design ToolboxItemCreatorCallback delegate.
format
A String that describes the data format that the creator handles.
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


AddLinkedToolboxItem Method

AddLinkedToolboxItem Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AddLinkedToolboxItem Method
Adds a ToolboxItem that is only available in the current project to the specified category in the toolbox.
Overload List
Overload | Description
AddLinkedToolboxItem(ToolboxItem,String,IDesignerHost) | Adds a ToolboxItem that is only available in the current project to the specified category in the toolbox.
AddLinkedToolboxItem(ToolboxItem,IDesignerHost) | Adds a ToolboxItem that is only available in the current project to the toolbox.
See Also

Reference

Toolbox Class
Toolbox Members


AddLinkedToolboxItem(ToolboxItem,String,IDesignerHost) Method

AddLinkedToolboxItem(ToolboxItem,String,IDesignerHost) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > AddLinkedToolboxItem Method : AddLinkedToolboxItem(ToolboxItem,String,IDesignerHost) Method
The System.Drawing.Design ToolboxItem in the current project to add to the toolbox.
A String that describes the toolbox category where you want to add the ToolboxItem.
The System.ComponentModel.Design IDesignerHost interface associated with the ToolboxItem. (This is not available in Visual Studio 2008.)
Adds a ToolboxItem that is only available in the current project to the specified category in the toolbox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddLinkedToolboxItem( _
   ByVal toolboxItem As System.Drawing.Design.ToolboxItem, _
   ByVal category As System.String, _
   ByVal host As System.ComponentModel.Design.IDesignerHost _
)
public void AddLinkedToolboxItem(
   System.Drawing.Design.ToolboxItem toolboxItem,
   System.string category,
   System.ComponentModel.Design.IDesignerHost host
)

Parameters

toolboxItem
The System.Drawing.Design ToolboxItem in the current project to add to the toolbox.
category
A String that describes the toolbox category where you want to add the ToolboxItem.
host
The System.ComponentModel.Design IDesignerHost interface associated with the ToolboxItem. (This is not available in Visual Studio 2008.)
Remarks
If the specified category does not exist, this method creates it.
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


AddLinkedToolboxItem(ToolboxItem,IDesignerHost) Method

AddLinkedToolboxItem(ToolboxItem,IDesignerHost) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > AddLinkedToolboxItem Method : AddLinkedToolboxItem(ToolboxItem,IDesignerHost) Method
The System.Drawing.Design ToolboxItem in the current project to add to the toolbox.
The System.ComponentModel.Design IDesignerHost interface associated with the ToolboxItem. (This is not available in Visual Studio 2008.)
Adds a ToolboxItem that is only available in the current project to the toolbox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddLinkedToolboxItem( _
   ByVal toolboxItem As System.Drawing.Design.ToolboxItem, _
   ByVal host As System.ComponentModel.Design.IDesignerHost _
)
public void AddLinkedToolboxItem(
   System.Drawing.Design.ToolboxItem toolboxItem,
   System.ComponentModel.Design.IDesignerHost host
)

Parameters

toolboxItem
The System.Drawing.Design ToolboxItem in the current project to add to the toolbox.
host
The System.ComponentModel.Design IDesignerHost interface associated with the ToolboxItem. (This is not available in Visual Studio 2008.)
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


AddToolboxItem Method

AddToolboxItem Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AddToolboxItem Method
Adds a ToolboxItem to the specified category in the toolbox.
Overload List
Overload | Description
AddToolboxItem(ToolboxItem,String) | Adds a ToolboxItem to the specified category in the toolbox.
AddToolboxItem(ToolboxItem) | Adds a ToolboxItem to the toolbox.
See Also

Reference

Toolbox Class
Toolbox Members


AddToolboxItem(ToolboxItem,String) Method

AddToolboxItem(ToolboxItem,String) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > AddToolboxItem Method : AddToolboxItem(ToolboxItem,String) Method
The System.Drawing.Design ToolboxItem to add to the toolbox.
A String that describes the toolbox category where you want to add the ToolboxItem.
Adds a ToolboxItem to the specified category in the toolbox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddToolboxItem( _
   ByVal toolboxItem As System.Drawing.Design.ToolboxItem, _
   ByVal category As System.String _
)
public void AddToolboxItem(
   System.Drawing.Design.ToolboxItem toolboxItem,
   System.string category
)

Parameters

toolboxItem
The System.Drawing.Design ToolboxItem to add to the toolbox.
category
A String that describes the toolbox category where you want to add the ToolboxItem.
Remarks
If the specified category does not exist, this method creates it.
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


AddToolboxItem(ToolboxItem) Method

AddToolboxItem(ToolboxItem) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > AddToolboxItem Method : AddToolboxItem(ToolboxItem) Method
The System.Drawing.Design ToolboxItem to add to the toolbox.
Adds a ToolboxItem to the toolbox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddToolboxItem( _
   ByVal toolboxItem As System.Drawing.Design.ToolboxItem _
)
public void AddToolboxItem(
   System.Drawing.Design.ToolboxItem toolboxItem
)

Parameters

toolboxItem
The System.Drawing.Design ToolboxItem to add to the toolbox.
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


DeserializeToolboxItem Method

DeserializeToolboxItem Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DeserializeToolboxItem Method
Gets a ToolboxItem from the specified serialized object.
Overload List
Overload | Description
DeserializeToolboxItem(Object,IDesignerHost) | Gets a ToolboxItem from the specified serialized object.
DeserializeToolboxItem(Object) | Gets a ToolboxItem from the specified serialized object.
See Also

Reference

Toolbox Class
Toolbox Members


DeserializeToolboxItem(Object,IDesignerHost) Method

DeserializeToolboxItem(Object,IDesignerHost) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > DeserializeToolboxItem Method : DeserializeToolboxItem(Object,IDesignerHost) Method
The System.Object that contains the ToolboxItem to get.
The System.ComponentModel.Design IDesignerHost interface associated with the ToolboxItem. (This is not available in Visual Studio 2008.)
Gets a ToolboxItem from the specified serialized object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function DeserializeToolboxItem( _
   ByVal serializedObject As System.Object, _
   ByVal host As System.ComponentModel.Design.IDesignerHost _
) As System.Drawing.Design.ToolboxItem
public System.Drawing.Design.ToolboxItem DeserializeToolboxItem(
   System.object serializedObject,
   System.ComponentModel.Design.IDesignerHost host
)

Parameters

serializedObject
The System.Object that contains the ToolboxItem to get.
host
The System.ComponentModel.Design IDesignerHost interface associated with the ToolboxItem. (This is not available in Visual Studio 2008.)
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


DeserializeToolboxItem(Object) Method

DeserializeToolboxItem(Object) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > DeserializeToolboxItem Method : DeserializeToolboxItem(Object) Method
The System.Object that contains the ToolboxItem to get.
Gets a ToolboxItem from the specified serialized object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function DeserializeToolboxItem( _
   ByVal serializedObject As System.Object _
) As System.Drawing.Design.ToolboxItem
public System.Drawing.Design.ToolboxItem DeserializeToolboxItem(
   System.object serializedObject
)

Parameters

serializedObject
The System.Object that contains the ToolboxItem to get.
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


EnableCategory Method

EnableCategory Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : EnableCategory Method
Value that indicates whether to enable the category with the specified name.
Indicates whether the category is enabled.
Specifies a category name to enable or disable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub EnableCategory( _
   ByVal category As System.String, _
   ByVal enable As System.Boolean _
)
public void EnableCategory(
   System.string category,
   System.bool enable
)

Parameters

category
Value that indicates whether to enable the category with the specified name.
enable
Indicates whether the category is enabled.
See Also

Reference

Toolbox Class
Toolbox Members


GetGroups Method

GetGroups Method
Example

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : GetGroups Method
Returns a read-only wrapper for the Groups collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetGroups() As System.Collections.ObjectModel.ReadOnlyCollection(Of Group)
public System.Collections.ObjectModel.ReadOnlyCollection<Group> GetGroups()
Example
  • Visual Basic
' change the name of the first group of tools in the default End User Report Designer Toolbox
arToolbox.GetGroups()(0).Text = "ARTools"
  • C#
// change the name of the first group of tools in the default End User Report Designer Toolbox
arToolbox.GetGroups()[0].Text = "ARTools";
See Also

Reference

Toolbox Class
Toolbox Members


GetSelectedToolboxItem Method

GetSelectedToolboxItem Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : GetSelectedToolboxItem Method
Gets the currently selected ToolboxItem.
Overload List
Overload | Description
GetSelectedToolboxItem(IDesignerHost) | Gets the currently selected ToolboxItem.
GetSelectedToolboxItem() | Gets the currently selected ToolboxItem.
See Also

Reference

Toolbox Class
Toolbox Members


GetSelectedToolboxItem(IDesignerHost) Method

GetSelectedToolboxItem(IDesignerHost) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > GetSelectedToolboxItem Method : GetSelectedToolboxItem(IDesignerHost) Method
The System.ComponentModel.Design IDesignerHost interface associated with the ToolboxItem. (This is not available in Visual Studio 2008.)
Gets the currently selected ToolboxItem.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetSelectedToolboxItem( _
   ByVal host As System.ComponentModel.Design.IDesignerHost _
) As System.Drawing.Design.ToolboxItem
public System.Drawing.Design.ToolboxItem GetSelectedToolboxItem(
   System.ComponentModel.Design.IDesignerHost host
)

Parameters

host
The System.ComponentModel.Design IDesignerHost interface associated with the ToolboxItem. (This is not available in Visual Studio 2008.)
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


GetSelectedToolboxItem() Method

GetSelectedToolboxItem() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > GetSelectedToolboxItem Method : GetSelectedToolboxItem() Method
Gets the currently selected ToolboxItem.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetSelectedToolboxItem() As System.Drawing.Design.ToolboxItem
public System.Drawing.Design.ToolboxItem GetSelectedToolboxItem()
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


GetToolboxItems Method

GetToolboxItems Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : GetToolboxItems Method
Gets the ToolboxItemCollection associated with the specified host from the specified category in the toolbox.
Overload List
Overload | Description
GetToolboxItems(String,IDesignerHost) | Gets the ToolboxItemCollection associated with the specified host from the specified category in the toolbox.
GetToolboxItems(String) | Gets the ToolboxItemCollection from the specified category in the toolbox.
GetToolboxItems(IDesignerHost) | Gets the ToolboxItemCollection associated with the specified host from the toolbox.
GetToolboxItems() | Gets the entire ToolboxItemCollection from the toolbox.
See Also

Reference

Toolbox Class
Toolbox Members


GetToolboxItems(String,IDesignerHost) Method

GetToolboxItems(String,IDesignerHost) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > GetToolboxItems Method : GetToolboxItems(String,IDesignerHost) Method
A String that describes the toolbox category from which to get the ToolboxItem.
The System.ComponentModel.Design IDesignerHost interface associated with the ToolboxItem. (This is not available in Visual Studio 2008.)
Gets the ToolboxItemCollection associated with the specified host from the specified category in the toolbox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetToolboxItems( _
   ByVal category As System.String, _
   ByVal host As System.ComponentModel.Design.IDesignerHost _
) As System.Drawing.Design.ToolboxItemCollection
public System.Drawing.Design.ToolboxItemCollection GetToolboxItems(
   System.string category,
   System.ComponentModel.Design.IDesignerHost host
)

Parameters

category
A String that describes the toolbox category from which to get the ToolboxItem.
host
The System.ComponentModel.Design IDesignerHost interface associated with the ToolboxItem. (This is not available in Visual Studio 2008.)

Return Value

A System.Drawing.Design.ToolboxItemCollection that contains the current toolbox items that are associated with the specified category and designer host.
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


GetToolboxItems(String) Method

GetToolboxItems(String) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > GetToolboxItems Method : GetToolboxItems(String) Method
A String that describes the toolbox category from which to get the ToolboxItem.
Gets the ToolboxItemCollection from the specified category in the toolbox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetToolboxItems( _
   ByVal category As System.String _
) As System.Drawing.Design.ToolboxItemCollection
public System.Drawing.Design.ToolboxItemCollection GetToolboxItems(
   System.string category
)

Parameters

category
A String that describes the toolbox category from which to get the ToolboxItem.

Return Value

A System.Drawing.Design.ToolboxItemCollection that contains the current toolbox items that are associated with the specified category.
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


GetToolboxItems(IDesignerHost) Method

GetToolboxItems(IDesignerHost) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > GetToolboxItems Method : GetToolboxItems(IDesignerHost) Method
The System.ComponentModel.Design IDesignerHost interface associated with the ToolboxItem. (This is not available in Visual Studio 2008.)
Gets the ToolboxItemCollection associated with the specified host from the toolbox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetToolboxItems( _
   ByVal host As System.ComponentModel.Design.IDesignerHost _
) As System.Drawing.Design.ToolboxItemCollection
public System.Drawing.Design.ToolboxItemCollection GetToolboxItems(
   System.ComponentModel.Design.IDesignerHost host
)

Parameters

host
The System.ComponentModel.Design IDesignerHost interface associated with the ToolboxItem. (This is not available in Visual Studio 2008.)

Return Value

A System.Drawing.Design.ToolboxItemCollection that contains the current toolbox items that are associated with the specified designer host.
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


GetToolboxItems() Method

GetToolboxItems() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > GetToolboxItems Method : GetToolboxItems() Method
Gets the entire ToolboxItemCollection from the toolbox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetToolboxItems() As System.Drawing.Design.ToolboxItemCollection
public System.Drawing.Design.ToolboxItemCollection GetToolboxItems()

Return Value

The System.Drawing.Design ToolboxItemCollection that contains the current toolbox items.
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


IsSupported Method

IsSupported Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : IsSupported Method
Indicates whether the ToolboxItem in the specified serialized object is matches the specified attributes.
Overload List
Overload | Description
IsSupported(Object,ICollection) | Indicates whether the ToolboxItem in the specified serialized object is matches the specified attributes.
IsSupported(Object,IDesignerHost) | Indicates whether the ToolboxItem in the specified serialized object is supported by the specified host.
See Also

Reference

Toolbox Class
Toolbox Members


IsSupported(Object,ICollection) Method

IsSupported(Object,ICollection) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > IsSupported Method : IsSupported(Object,ICollection) Method
The System.Object that contains the ToolboxItem to check.
The System.Collections.ICollection that contains the attributes to check against.
Indicates whether the ToolboxItem in the specified serialized object is matches the specified attributes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function IsSupported( _
   ByVal serializedObject As System.Object, _
   ByVal filterAttributes As System.Collections.ICollection _
) As System.Boolean
public System.bool IsSupported(
   System.object serializedObject,
   System.Collections.ICollection filterAttributes
)

Parameters

serializedObject
The System.Object that contains the ToolboxItem to check.
filterAttributes
The System.Collections.ICollection that contains the attributes to check against.
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


IsSupported(Object,IDesignerHost) Method

IsSupported(Object,IDesignerHost) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > IsSupported Method : IsSupported(Object,IDesignerHost) Method
The System.Object that contains the ToolboxItem to check.
The System.ComponentModel.Design IDesignerHost interface associated with the ToolboxItem. (This is not available in Visual Studio 2008.)
Indicates whether the ToolboxItem in the specified serialized object is supported by the specified host.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function IsSupported( _
   ByVal serializedObject As System.Object, _
   ByVal host As System.ComponentModel.Design.IDesignerHost _
) As System.Boolean
public System.bool IsSupported(
   System.object serializedObject,
   System.ComponentModel.Design.IDesignerHost host
)

Parameters

serializedObject
The System.Object that contains the ToolboxItem to check.
host
The System.ComponentModel.Design IDesignerHost interface associated with the ToolboxItem. (This is not available in Visual Studio 2008.)
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


IsToolboxItem Method

IsToolboxItem Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : IsToolboxItem Method
Indicates whether the item in the specified serialized object that is supported by the specified host is a ToolboxItem.
Overload List
Overload | Description
IsToolboxItem(Object,IDesignerHost) | Indicates whether the item in the specified serialized object that is supported by the specified host is a ToolboxItem.
IsToolboxItem(Object) | Indicates whether the item in the specified serialized object is a ToolboxItem.
See Also

Reference

Toolbox Class
Toolbox Members


IsToolboxItem(Object,IDesignerHost) Method

IsToolboxItem(Object,IDesignerHost) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > IsToolboxItem Method : IsToolboxItem(Object,IDesignerHost) Method
The System.Object to check.
The System.ComponentModel.Design IDesignerHost interface associated with the ToolboxItem. (This is not available in Visual Studio 2008.)
Indicates whether the item in the specified serialized object that is supported by the specified host is a ToolboxItem.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function IsToolboxItem( _
   ByVal serializedObject As System.Object, _
   ByVal host As System.ComponentModel.Design.IDesignerHost _
) As System.Boolean
public System.bool IsToolboxItem(
   System.object serializedObject,
   System.ComponentModel.Design.IDesignerHost host
)

Parameters

serializedObject
The System.Object to check.
host
The System.ComponentModel.Design IDesignerHost interface associated with the ToolboxItem. (This is not available in Visual Studio 2008.)
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


IsToolboxItem(Object) Method

IsToolboxItem(Object) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > IsToolboxItem Method : IsToolboxItem(Object) Method
The System.Object to check.
Indicates whether the item in the specified serialized object is a ToolboxItem.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function IsToolboxItem( _
   ByVal serializedObject As System.Object _
) As System.Boolean
public System.bool IsToolboxItem(
   System.object serializedObject
)

Parameters

serializedObject
The System.Object to check.
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


RemoveToolboxItem Method

RemoveToolboxItem Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : RemoveToolboxItem Method
Removes the specified ToolboxItem from the specified category in the toolbox.
Overload List
Overload | Description
RemoveToolboxItem(ToolboxItem,String) | Removes the specified ToolboxItem from the specified category in the toolbox.
RemoveToolboxItem(ToolboxItem) | Removes the specified ToolboxItem from the toolbox.
See Also

Reference

Toolbox Class
Toolbox Members


RemoveToolboxItem(ToolboxItem,String) Method

RemoveToolboxItem(ToolboxItem,String) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > RemoveToolboxItem Method : RemoveToolboxItem(ToolboxItem,String) Method
The System.Drawing.Design ToolboxItem to remove from the toolbox.
A String that describes the toolbox category from which you want to remove the ToolboxItem.
Removes the specified ToolboxItem from the specified category in the toolbox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub RemoveToolboxItem( _
   ByVal toolboxItem As System.Drawing.Design.ToolboxItem, _
   ByVal category As System.String _
)
public void RemoveToolboxItem(
   System.Drawing.Design.ToolboxItem toolboxItem,
   System.string category
)

Parameters

toolboxItem
The System.Drawing.Design ToolboxItem to remove from the toolbox.
category
A String that describes the toolbox category from which you want to remove the ToolboxItem.
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


RemoveToolboxItem(ToolboxItem) Method

RemoveToolboxItem(ToolboxItem) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > RemoveToolboxItem Method : RemoveToolboxItem(ToolboxItem) Method
The System.Drawing.Design ToolboxItem to remove from the toolbox.
Removes the specified ToolboxItem from the toolbox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub RemoveToolboxItem( _
   ByVal toolboxItem As System.Drawing.Design.ToolboxItem _
)
public void RemoveToolboxItem(
   System.Drawing.Design.ToolboxItem toolboxItem
)

Parameters

toolboxItem
The System.Drawing.Design ToolboxItem to remove from the toolbox.
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


SelectedToolboxItemUsed Method

SelectedToolboxItemUsed Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : SelectedToolboxItemUsed Method
Signals the toolbox that the selected ToolboxItem has been used.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SelectedToolboxItemUsed()
public void SelectedToolboxItemUsed()
See Also

Reference

Toolbox Class
Toolbox Members


SerializeToolboxItem Method

SerializeToolboxItem Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : SerializeToolboxItem Method
The System.Drawing.Design ToolboxItem to serialize.
Creates a serialized System.Object representing the specified ToolboxItem.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function SerializeToolboxItem( _
   ByVal toolboxItem As System.Drawing.Design.ToolboxItem _
) As System.Object
public System.object SerializeToolboxItem(
   System.Drawing.Design.ToolboxItem toolboxItem
)

Parameters

toolboxItem
The System.Drawing.Design ToolboxItem to serialize.

Return Value

A System.Object.
See Also

Reference

Toolbox Class
Toolbox Members


SetCursor Method

SetCursor Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : SetCursor Method
Sets the cursor to a cursor that represents the current ToolboxItem.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function SetCursor() As System.Boolean
public System.bool SetCursor()

Return Value

Boolean. True if a ToolboxItem is selected and the cursor is set. Otherwise, False, and the default cursor is used.
See Also

Reference

Toolbox Class
Toolbox Members


SetSelectedToolboxItem Method

SetSelectedToolboxItem Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : SetSelectedToolboxItem Method
The System.Drawing.Design ToolboxItem to select.
Selects the specified ToolboxItem.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetSelectedToolboxItem( _
   ByVal toolboxItem As System.Drawing.Design.ToolboxItem _
)
public void SetSelectedToolboxItem(
   System.Drawing.Design.ToolboxItem toolboxItem
)

Parameters

toolboxItem
The System.Drawing.Design ToolboxItem to select.
See Also

Reference

Toolbox Class
Toolbox Members


Toolbox Class Properties

Toolbox Class Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : Toolbox Class

For a list of all members of this type, see Toolbox members.

Public Properties
 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CategoryNames | Gets the System.Drawing.Design CategoryNameCollection containing the categories available in the toolbox.
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DesignerHost | DesignerHost provides additional features for toolbox then it used as part of designer application
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | Groups | Returns groups collection.
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | SelectedCategory | Gets or sets the currently selected toolbox category.
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

Toolbox Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


CategoryNames Property

CategoryNames Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : CategoryNames Property
Gets the System.Drawing.Design CategoryNameCollection containing the categories available in the toolbox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CategoryNames As System.Drawing.Design.CategoryNameCollection
public System.Drawing.Design.CategoryNameCollection CategoryNames {get;}
See Also

Reference

Toolbox Class
Toolbox Members


DesignerHost Property

DesignerHost Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DesignerHost Property
DesignerHost provides additional features for toolbox then it used as part of designer application
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DesignerHost As System.ComponentModel.Design.IDesignerHost
public System.ComponentModel.Design.IDesignerHost DesignerHost {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


Groups Property (Toolbox)

Groups Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Groups Property
Returns groups collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows ReadOnly Property Groups As System.Collections.Generic.IList(Of Group)
public new System.Collections.Generic.IList<Group> Groups {get;}
See Also

Reference

Toolbox Class
Toolbox Members


SelectedCategory Property

SelectedCategory Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : SelectedCategory Property
Gets or sets the currently selected toolbox category.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SelectedCategory As System.String
public System.string SelectedCategory {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


ToolClickEventArgs Class

ToolClickEventArgs Class
Members

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : ToolClickEventArgs Class
Provides data for the ToolClick event.
Object Model
ToolClickEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ToolClickEventArgs
   Inherits System.EventArgs
public sealed class ToolClickEventArgs : System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.Toolbox.ToolClickEventArgs

See Also

Reference

ToolClickEventArgs Members
GrapeCity.ActiveReports.Design.Toolbox Namespace


ToolClickEventArgs Class Members

ToolClickEventArgs Class Members
Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : ToolClickEventArgs Class

The following tables list the members exposed by ToolClickEventArgs.

Public Properties
 | Name | Description
Public Property | Clicks | Number of clicks on the toolbox item.
Public Property | ToolText | Gets clicked tool text.
Top
See Also

Reference

ToolClickEventArgs Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


ToolClickEventArgs Class Properties

ToolClickEventArgs Class Properties

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : ToolClickEventArgs Class

For a list of all members of this type, see ToolClickEventArgs members.

Public Properties
 | Name | Description
Public Property | Clicks | Number of clicks on the toolbox item.
Public Property | ToolText | Gets clicked tool text.
Top
See Also

Reference

ToolClickEventArgs Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


Clicks Property (ToolClickEventArgs)

Clicks Property (ToolClickEventArgs)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > ToolClickEventArgs Class : Clicks Property
Number of clicks on the toolbox item.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Clicks As System.Integer
public System.int Clicks {get;}
See Also

Reference

ToolClickEventArgs Class
ToolClickEventArgs Members


ToolText Property

ToolText Property

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > ToolClickEventArgs Class : ToolText Property
Gets clicked tool text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ToolText As System.String
public System.string ToolText {get;}
See Also

Reference

ToolClickEventArgs Class
ToolClickEventArgs Members


GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports.Document.v10)

GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports.Document.v10)
Inheritance Hierarchy
GrapeCity.ActiveReports.Document.v10 Assembly : GrapeCity.ActiveReports Namespace
The GrapeCity.ActiveReports namespace contains the Border class and its settings.
Classes
 | Class | Description
Class | Border | Paints a border around the control area.
Class | Border.BorderMargins | Gets the amount of padding around the content of the control.
Structures
 | Structure | Description
Structure | PaddingEx | Provides the settings used to set a margin (four edges) inside a control.
Enumerations
 | Enumeration | Description
Enumeration | BorderLineStyle | Specifies the line style used to draw the border line.
See Also

Reference

GrapeCity.ActiveReports.Document.v10 Assembly


Border Class

Border Class
Members Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace : Border Class
Paints a border around the control area.
Object Model
Border Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Border
public class Border
Remarks
Borders are painted outside the control area.
Example
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Border.BottomColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.LeftColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.LeftStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.RightColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.RightStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.TopColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.TopStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.Shadow = true;
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.TextBox1.Border.BottomColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.LeftColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.LeftStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.RightColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.RightStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.TopColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.TopStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.Shadow = True
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Border

See Also

Reference

Border Members
GrapeCity.ActiveReports Namespace


Border Class Members

Border Class Members
Properties Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace : Border Class

The following tables list the members exposed by Border.

Public Constructors
 | Name | Description
Public Constructor | Border Constructor | Initializes a new instance of the Border class.
Top
Public Properties
 | Name | Description
Public Property | BottomColor | Gets or sets the line color of the bottom edge of the border.
Public Property | BottomStyle | Gets or sets the line style of the bottom edge of the border.
Public Property | Color | Sets or returns the color of a control's border.
Public Property | LeftColor | Gets or sets the line color of the left edge of the border.
Public Property | LeftStyle | Gets or sets the line style of the left edge of the border.
Public Property | RightColor | Gets or sets the line color of the right edge of the border.
Public Property | RightStyle | Gets or sets the line style of the right edge of the border.
Public Property | Shadow | Determines whether ActiveReports should paint a shadow around the right bottom edges of the control.
Public Property | Style | Sets or returns the BorderLineStyle of the border.
Public Property | TopColor | Gets or sets the line color of the top edge of the border.
Public Property | TopStyle | Gets or sets the line style of the top edge of the border.
Top
Public Methods
 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance of the Border class.
Public Method | CopyTo | Copies the border to the specified border.
Top
See Also

Reference

Border Class
GrapeCity.ActiveReports Namespace


Border Constructor

Border Constructor
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > Border Class : Border Constructor
Initializes a new instance of the Border class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Border()
Example
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Border.BottomColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.LeftColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.LeftStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.RightColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.RightStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.TopColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.TopStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.Shadow = true;
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.TextBox1.Border.BottomColor = System.Drawing.Color.Blue
    Me.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot
    Me.TextBox1.Border.LeftColor = System.Drawing.Color.Blue
    Me.TextBox1.Border.LeftStyle = BorderLineStyle.DashDot
    Me.TextBox1.Border.RightColor = System.Drawing.Color.Blue
    Me.TextBox1.Border.RightStyle = BorderLineStyle.DashDot
    Me.TextBox1.Border.TopColor = System.Drawing.Color.Blue
    Me.TextBox1.Border.TopStyle = BorderLineStyle.DashDot
    Me.TextBox1.Border.Shadow = True
End Sub
See Also

Reference

Border Class
Border Members


Border Class Methods

Border Class Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace : Border Class

For a list of all members of this type, see Border members.

Public Methods
 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance of the Border class.
Public Method | CopyTo | Copies the border to the specified border.
Top
See Also

Reference

Border Class
GrapeCity.ActiveReports Namespace


Clone Method (Border)

Clone Method (Border)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > Border Class : Clone Method
Creates a new object that is a copy of the current instance of the Border class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Clone() As Border
public Border Clone()

Return Value

Border.
Example
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Dim b As New GrapeCity.ActiveReports.Border
   Me.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.TopStyle = BorderLineStyle.DashDot
   b = Me.TextBox1.Border.Clone()
   Me.TextBox2.Border.BottomStyle = b.BottomStyle
   Me.TextBox2.Border.TopStyle = b.TopStyle
End Sub
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    GrapeCity.ActiveReports.Border b = new GrapeCity.ActiveReports.Border();
    this.TextBox1.Border.BottomStyle = BorderLineStyle.ThickDash;
    this.TextBox1.Border.TopStyle = BorderLineStyle.ThickDash;
    b = this.TextBox1.Border.Clone();
    this.TextBox2.Border.BottomStyle = b.BottomStyle;
    this.TextBox2.Border.TopStyle = b.TopStyle;
}
See Also

Reference

Border Class
Border Members


CopyTo Method (Border)

CopyTo Method (Border)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > Border Class : CopyTo Method
GrapeCity.ActiveReports.Border object.
Copies the border to the specified border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal border As Border _
)
public void CopyTo(
   Border border
)

Parameters

border
GrapeCity.ActiveReports.Border object.
See Also

Reference

Border Class
Border Members


Border Class Properties

Border Class Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace : Border Class

For a list of all members of this type, see Border members.

Public Properties
 | Name | Description
Public Property | BottomColor | Gets or sets the line color of the bottom edge of the border.
Public Property | BottomStyle | Gets or sets the line style of the bottom edge of the border.
Public Property | Color | Sets or returns the color of a control's border.
Public Property | LeftColor | Gets or sets the line color of the left edge of the border.
Public Property | LeftStyle | Gets or sets the line style of the left edge of the border.
Public Property | RightColor | Gets or sets the line color of the right edge of the border.
Public Property | RightStyle | Gets or sets the line style of the right edge of the border.
Public Property | Shadow | Determines whether ActiveReports should paint a shadow around the right bottom edges of the control.
Public Property | Style | Sets or returns the BorderLineStyle of the border.
Public Property | TopColor | Gets or sets the line color of the top edge of the border.
Public Property | TopStyle | Gets or sets the line style of the top edge of the border.
Top
See Also

Reference

Border Class
GrapeCity.ActiveReports Namespace


BottomColor Property

BottomColor Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > Border Class : BottomColor Property
Gets or sets the line color of the bottom edge of the border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BottomColor As Color
public Color BottomColor {get; set;}

Property Value

The color of the bottom.
Example
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Border.BottomColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.LeftColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.RightColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.TopColor = System.Drawing.Color.Blue;
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.TextBox1.Border.BottomColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.LeftColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.RightColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.TopColor = System.Drawing.Color.Blue
End Sub
See Also

Reference

Border Class
Border Members


BottomStyle Property

BottomStyle Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > Border Class : BottomStyle Property
Gets or sets the line style of the bottom edge of the border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BottomStyle As BorderLineStyle
public BorderLineStyle BottomStyle {get; set;}

Property Value

The bottom style.
Example
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.LeftStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.RightStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.TopStyle = BorderLineStyle.DashDot;
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.LeftStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.RightStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.TopStyle = BorderLineStyle.DashDot
End Sub
See Also

Reference

Border Class
Border Members


Color Property (Border)

Color Property (Border)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > Border Class : Color Property
Sets or returns the color of a control's border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Color As Color
public Color Color {get; set;}

Property Value

System.Drawing.Color.
Example
  • C#
Private void GroupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.txtShipCountry.Border.Color = System.Drawing.Color.Purple;
}
  • Visual Basic
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
    Me.txtShipCountry.Border.Color = System.Drawing.Color.Purple
End Sub
See Also

Reference

Border Class
Border Members


LeftColor Property

LeftColor Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > Border Class : LeftColor Property
Gets or sets the line color of the left edge of the border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LeftColor As Color
public Color LeftColor {get; set;}

Property Value

The color of the left.
Example
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Border.BottomColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.LeftColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.RightColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.TopColor = System.Drawing.Color.Blue;
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.TextBox1.Border.BottomColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.LeftColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.RightColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.TopColor = System.Drawing.Color.Blue
End Sub
See Also

Reference

Border Class
Border Members


LeftStyle Property

LeftStyle Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > Border Class : LeftStyle Property
Gets or sets the line style of the left edge of the border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LeftStyle As BorderLineStyle
public BorderLineStyle LeftStyle {get; set;}

Property Value

The left style.
Example
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.LeftStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.RightStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.TopStyle = BorderLineStyle.DashDot;
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.LeftStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.RightStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.TopStyle = BorderLineStyle.DashDot
End Sub
See Also

Reference

Border Class
Border Members


RightColor Property

RightColor Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > Border Class : RightColor Property
Gets or sets the line color of the right edge of the border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RightColor As Color
public Color RightColor {get; set;}

Property Value

The color of the right.
Example
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Border.BottomColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.LeftColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.RightColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.TopColor = System.Drawing.Color.Blue;
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.TextBox1.Border.BottomColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.LeftColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.RightColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.TopColor = System.Drawing.Color.Blue
End Sub
See Also

Reference

Border Class
Border Members


RightStyle Property

RightStyle Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > Border Class : RightStyle Property
Gets or sets the line style of the right edge of the border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RightStyle As BorderLineStyle
public BorderLineStyle RightStyle {get; set;}

Property Value

The right style.
Example
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.LeftStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.RightStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.TopStyle = BorderLineStyle.DashDot;
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.LeftStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.RightStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.TopStyle = BorderLineStyle.DashDot
End Sub
See Also

Reference

Border Class
Border Members


Shadow Property

Shadow Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > Border Class : Shadow Property

Determines whether ActiveReports should paint a shadow around the right bottom edges of the control.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Shadow As System.Boolean
public System.bool Shadow {get; set;}

Property Value

true if shadow; otherwise, false.
Example
  • C#
private void viewer1_Load(object sender, System.EventArgs e)
{
         SectionReport1 rpt = new SectionReport1();
         rpt.Sections[0].Controls[0].Border.Shadow = true;
         rpt.Run();
         viewer1.Document = rpt.Document;
}
  • Visual Basic
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    rpt.Sections(0).Controls(0).Border.Shadow = True
    rpt.Run()
    Viewer1.Document = rpt.Document
End Sub
See Also

Reference

Border Class
Border Members


Style Property (Border)

Style Property (Border)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > Border Class : Style Property
Sets or returns the BorderLineStyle of the border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As BorderLineStyle
public BorderLineStyle Style {get; set;}

Property Value

GrapeCity.ActiveReports.BorderLineStyle enumeration.
Example
  • C#
Private void PageHeader_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Border.Style = BorderLineStyle.ThickDashDotDot;
}
  • Visual Basic
Private Sub PageHeader_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles PageHeader.Format
    With Me.TextBox1.Border.Style = BorderLineStyle.ThickDashDotDot
    End With
End Sub
See Also

Reference

Border Class
Border Members
BorderLineStyle Enumeration


TopColor Property

TopColor Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > Border Class : TopColor Property
Gets or sets the line color of the top edge of the border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TopColor As Color
public Color TopColor {get; set;}
Example
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Border.BottomColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.LeftColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.RightColor = System.Drawing.Color.Blue;
    this.TextBox1.Border.TopColor = System.Drawing.Color.Blue;
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.TextBox1.Border.BottomColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.LeftColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.RightColor = System.Drawing.Color.Blue
   Me.TextBox1.Border.TopColor = System.Drawing.Color.Blue
End Sub
See Also

Reference

Border Class
Border Members


TopStyle Property

TopStyle Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > Border Class : TopStyle Property
Gets or sets the line style of the top edge of the border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TopStyle As BorderLineStyle
public BorderLineStyle TopStyle {get; set;}
Example
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.LeftStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.RightStyle = BorderLineStyle.DashDot;
    this.TextBox1.Border.TopStyle = BorderLineStyle.DashDot;
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.TextBox1.Border.BottomStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.LeftStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.RightStyle = BorderLineStyle.DashDot
   Me.TextBox1.Border.TopStyle = BorderLineStyle.DashDot
End Sub
See Also

Reference

Border Class
Border Members


Border.BorderMargins Class

Border.BorderMargins Class
Members

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace : Border.BorderMargins Class
Gets the amount of padding around the content of the control.
Object Model
Border.BorderMargins Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Border.BorderMargins
public class Border.BorderMargins
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Border.BorderMargins

See Also

Reference

Border.BorderMargins Members
GrapeCity.ActiveReports Namespace


Border.BorderMargins Class Members

Border.BorderMargins Class Members
Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace : Border.BorderMargins Class

The following tables list the members exposed by Border.BorderMargins.

Public Properties
 | Name | Description
Public Property | Bottom | Gets the amount of padding at the bottom edge of the control.
Public Property | Left | Gets the amount of padding at the left edge of the control.
Public Property | Right | Gets the amount of padding at the right edge of the control.
Public Property | Top | Gets the amount of padding at the top edge of the control.
Top
See Also

Reference

Border.BorderMargins Class
GrapeCity.ActiveReports Namespace


Border.BorderMargins Class Properties

Border.BorderMargins Class Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace : Border.BorderMargins Class

For a list of all members of this type, see Border.BorderMargins members.

Public Properties
 | Name | Description
Public Property | Bottom | Gets the amount of padding at the bottom edge of the control.
Public Property | Left | Gets the amount of padding at the left edge of the control.
Public Property | Right | Gets the amount of padding at the right edge of the control.
Public Property | Top | Gets the amount of padding at the top edge of the control.
Top
See Also

Reference

Border.BorderMargins Class
GrapeCity.ActiveReports Namespace


Bottom Property (Border.BorderMargins)

Bottom Property (Border.BorderMargins)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > Border.BorderMargins Class : Bottom Property
Gets the amount of padding at the bottom edge of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Bottom As System.Integer
public System.int Bottom {get;}
See Also

Reference

Border.BorderMargins Class
Border.BorderMargins Members


Left Property (Border.BorderMargins)

Left Property (Border.BorderMargins)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > Border.BorderMargins Class : Left Property
Gets the amount of padding at the left edge of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Left As System.Integer
public System.int Left {get;}
See Also

Reference

Border.BorderMargins Class
Border.BorderMargins Members


Right Property (Border.BorderMargins)

Right Property (Border.BorderMargins)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > Border.BorderMargins Class : Right Property
Gets the amount of padding at the right edge of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Right As System.Integer
public System.int Right {get;}
See Also

Reference

Border.BorderMargins Class
Border.BorderMargins Members


Top Property (Border.BorderMargins)

Top Property (Border.BorderMargins)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > Border.BorderMargins Class : Top Property
Gets the amount of padding at the top edge of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Top As System.Integer
public System.int Top {get;}
See Also

Reference

Border.BorderMargins Class
Border.BorderMargins Members


BorderLineStyle Enumeration

BorderLineStyle Enumeration

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace : BorderLineStyle Enumeration
Specifies the line style used to draw the border line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum BorderLineStyle
   Inherits System.Enum
public enum BorderLineStyle : System.Enum
Members
Member | Description
Dash | Dashed one pixel line.
DashDot | Dash dot one pixel line.
DashDotDot | Dash dot dot one pixel line.
Dot | Dotted one pixel line.
Double | Double line.
ExtraThickSolid | Extra thick solid line.
None | No line.
Solid | Solid one pixel line.
ThickDash | Thick dash line.
ThickDashDot | Thick dash dot line.
ThickDashDotDot | Thick dash dot dot line.
ThickDot | Thick dotted line.
ThickDouble | Thick double line.
ThickSolid | Thick solid line.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.BorderLineStyle

See Also

Reference

GrapeCity.ActiveReports Namespace
Style Property


PaddingEx Structure

PaddingEx Structure
Members

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace : PaddingEx Structure
Provides the settings used to set a margin (four edges) inside a control.
Object Model
PaddingEx Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure PaddingEx
   Inherits System.ValueType
public struct PaddingEx : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.PaddingEx

See Also

Reference

PaddingEx Members
GrapeCity.ActiveReports Namespace


PaddingEx Structure Members

PaddingEx Structure Members
Fields Properties Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace : PaddingEx Structure

The following tables list the members exposed by PaddingEx.

Public Constructors
 | Name | Description
Public Constructor | PaddingEx Constructor | Overloaded.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | Returns a PaddingEx object with no padding.
Top
Public Properties
 | Name | Description
Public Property | All | Gets or sets the padding value for all of the edges.
Public Property | Bottom | Gets or sets the padding value for the bottom edge.
Public Property | Horizontal | Gets or sets the combined padding value for the left and right edges.
Public Property | Left | Gets or sets the padding value for the left edge.
Public Property | Right | Gets or sets the padding value for the right edge.
Public Property | Size | Gets the padding information for the control as a System.Drawing.Size structure.
Public Property | Top | Gets or sets the padding value for the top edge.
Public Property | Vertical | Gets or sets the combined padding value for the top and bottom edges.
Top
Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Determines whether the value of the specified PaddingEx object equals the current PaddingEx object.
Public Method | GetHashCode | Generates a hash code for the PaddingEx object.
Top
Public Operators
public Operator Equality | Tests whether two PaddingEx objects are equivalent.
public Operator Inequality | Tests whether two PaddingEx objects are not equivalent.
Top
See Also

Reference

PaddingEx Structure
GrapeCity.ActiveReports Namespace


PaddingEx Constructor

PaddingEx Constructor

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : PaddingEx Constructor
Initializes a new instance of the PaddingEx structure.
Overload List
Overload | Description
PaddingEx Constructor(Int32) | Initializes a new instance of the PaddingEx structure using the same value for all edges.
PaddingEx Constructor(Int32,Int32,Int32,Int32) | Initializes a new instance of the PaddingEx structure using the specified value for each edge.
See Also

Reference

PaddingEx Structure
PaddingEx Members


PaddingEx Constructor(Int32)

PaddingEx Constructor(Int32)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure > PaddingEx Constructor : PaddingEx Constructor(Int32)
Applies the same value to all four edges of the control.
Initializes a new instance of the PaddingEx structure using the same value for all edges.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal all As System.Integer _
)
public PaddingEx(
   System.int all
)

Parameters

all
Applies the same value to all four edges of the control.
See Also

Reference

PaddingEx Structure
PaddingEx Members
Overload List


PaddingEx Constructor(Int32,Int32,Int32,Int32)

PaddingEx Constructor(Int32,Int32,Int32,Int32)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure > PaddingEx Constructor : PaddingEx Constructor(Int32,Int32,Int32,Int32)
The value to set for the left edge of the control.
The value to set for the top edge of the control.
The value to set for the right edge of the control.
The value to set for the bottom edge of the control.
Initializes a new instance of the PaddingEx structure using the specified value for each edge.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal left As System.Integer, _
   ByVal top As System.Integer, _
   ByVal right As System.Integer, _
   ByVal bottom As System.Integer _
)
public PaddingEx(
   System.int left,
   System.int top,
   System.int right,
   System.int bottom
)

Parameters

left
The value to set for the left edge of the control.
top
The value to set for the top edge of the control.
right
The value to set for the right edge of the control.
bottom
The value to set for the bottom edge of the control.
See Also

Reference

PaddingEx Structure
PaddingEx Members
Overload List


PaddingEx Structure Methods

PaddingEx Structure Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace : PaddingEx Structure

For a list of all members of this type, see PaddingEx members.

Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Determines whether the value of the specified PaddingEx object equals the current PaddingEx object.
Public Method | GetHashCode | Generates a hash code for the PaddingEx object.
Top
See Also

Reference

PaddingEx Structure
GrapeCity.ActiveReports Namespace


Equals Method (PaddingEx)

Equals Method (PaddingEx)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Equals Method
Determines whether the value of the specified PaddingEx object equals the current PaddingEx object.
Determines whether the value of an object equals the current PaddingEx object.
Overload List
Overload | Description
Equals(PaddingEx) | Determines whether the value of the specified PaddingEx object equals the current PaddingEx object.
Equals(Object) | Determines whether the value of the specified object equals the current PaddingEx object.
See Also

Reference

PaddingEx Structure
PaddingEx Members


Equals(PaddingEx) Method

Equals(PaddingEx) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure > Equals Method : Equals(PaddingEx) Method
The PaddingEx object to compare to the current PaddingEx object.
Determines whether the value of the specified PaddingEx object equals the current PaddingEx object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Equals( _
   ByVal paddingEx As PaddingEx _
) As System.Boolean
public System.bool Equals(
   PaddingEx paddingEx
)

Parameters

paddingEx
The PaddingEx object to compare to the current PaddingEx object.

Return Value

true if the specified PaddingEx is equal to this instance; otherwise, false.
See Also

Reference

PaddingEx Structure
PaddingEx Members
Overload List


Equals(Object) Method

Equals(Object) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure > Equals Method : Equals(Object) Method
The object to compare to the current PaddingEx object.
Determines whether the value of the specified object equals the current PaddingEx object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The object to compare to the current PaddingEx object.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.
See Also

Reference

PaddingEx Structure
PaddingEx Members
Overload List


GetHashCode Method (PaddingEx)

GetHashCode Method (PaddingEx)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : GetHashCode Method
Generates a hash code for the PaddingEx object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

PaddingEx Structure
PaddingEx Members


PaddingEx Structure Properties

PaddingEx Structure Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace : PaddingEx Structure

For a list of all members of this type, see PaddingEx members.

Public Properties
 | Name | Description
Public Property | All | Gets or sets the padding value for all of the edges.
Public Property | Bottom | Gets or sets the padding value for the bottom edge.
Public Property | Horizontal | Gets or sets the combined padding value for the left and right edges.
Public Property | Left | Gets or sets the padding value for the left edge.
Public Property | Right | Gets or sets the padding value for the right edge.
Public Property | Size | Gets the padding information for the control as a System.Drawing.Size structure.
Public Property | Top | Gets or sets the padding value for the top edge.
Public Property | Vertical | Gets or sets the combined padding value for the top and bottom edges.
Top
See Also

Reference

PaddingEx Structure
GrapeCity.ActiveReports Namespace


All Property (PaddingEx)

All Property (PaddingEx)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : All Property
Gets or sets the padding value for all of the edges.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property All As System.Integer
public System.int All {get; set;}

Property Value

An integer in points.
See Also

Reference

PaddingEx Structure
PaddingEx Members


Bottom Property (PaddingEx)

Bottom Property (PaddingEx)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Bottom Property
Gets or sets the padding value for the bottom edge.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Bottom As System.Integer
public System.int Bottom {get; set;}

Property Value

An integer in points.
See Also

Reference

PaddingEx Structure
PaddingEx Members


Horizontal Property (PaddingEx)

Horizontal Property (PaddingEx)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Horizontal Property
Gets or sets the combined padding value for the left and right edges.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Horizontal As System.Integer
public System.int Horizontal {get;}

Property Value

An integer value in points.
See Also

Reference

PaddingEx Structure
PaddingEx Members


Left Property (PaddingEx)

Left Property (PaddingEx)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Left Property
Gets or sets the padding value for the left edge.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Left As System.Integer
public System.int Left {get; set;}

Property Value

An integer in points.
See Also

Reference

PaddingEx Structure
PaddingEx Members


Right Property (PaddingEx)

Right Property (PaddingEx)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Right Property
Gets or sets the padding value for the right edge.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Right As System.Integer
public System.int Right {get; set;}

Property Value

An integer in points.
See Also

Reference

PaddingEx Structure
PaddingEx Members


Size Property (PaddingEx)

Size Property (PaddingEx)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Size Property
Gets the padding information for the control as a System.Drawing.Size structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Size As Size
public Size Size {get;}

Property Value

A System.Drawing.Size structure.
See Also

Reference

PaddingEx Structure
PaddingEx Members


Top Property (PaddingEx)

Top Property (PaddingEx)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Top Property
Gets or sets the padding value for the top edge.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Top As System.Integer
public System.int Top {get; set;}

Property Value

An integer in points.
See Also

Reference

PaddingEx Structure
PaddingEx Members


Vertical Property (PaddingEx)

Vertical Property (PaddingEx)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Vertical Property
Gets or sets the combined padding value for the top and bottom edges.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Vertical As System.Integer
public System.int Vertical {get;}

Property Value

An integer value in points.
See Also

Reference

PaddingEx Structure
PaddingEx Members


PaddingEx Structure Fields

PaddingEx Structure Fields

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace : PaddingEx Structure

For a list of all members of this type, see PaddingEx members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | Returns a PaddingEx object with no padding.
Top
See Also

Reference

PaddingEx Structure
GrapeCity.ActiveReports Namespace


Empty Field (PaddingEx)

Empty Field (PaddingEx)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Empty Field
Returns a PaddingEx object with no padding.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Empty As PaddingEx
public static readonly PaddingEx Empty
See Also

Reference

PaddingEx Structure
PaddingEx Members


Equality Operator (PaddingEx)

Equality Operator (PaddingEx)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Equality Operator
The first PaddingEx object to compare.
The second PaddingEx object to compare.
Tests whether two PaddingEx objects are equivalent.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator =( _
   ByVal p1 As PaddingEx, _
   ByVal p2 As PaddingEx _
) As System.Boolean
public System.bool operator ==(
   PaddingEx p1,
   PaddingEx p2
)

Parameters

p1
The first PaddingEx object to compare.
p2
The second PaddingEx object to compare.

Return Value

The result of the operator.
See Also

Reference

PaddingEx Structure
PaddingEx Members


Inequality Operator (PaddingEx)

Inequality Operator (PaddingEx)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports Namespace > PaddingEx Structure : Inequality Operator
The first PaddingEx object to compare.
The second PaddingEx object to compare.
Tests whether two PaddingEx objects are not equivalent.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator <>( _
   ByVal p1 As PaddingEx, _
   ByVal p2 As PaddingEx _
) As System.Boolean
public System.bool operator !=(
   PaddingEx p1,
   PaddingEx p2
)

Parameters

p1
The first PaddingEx object to compare.
p2
The second PaddingEx object to compare.

Return Value

The result of the operator.
See Also

Reference

PaddingEx Structure
PaddingEx Members


GrapeCity.ActiveReports.Document Namespace (GrapeCity.ActiveReports.Document.v10)

GrapeCity.ActiveReports.Document Namespace (GrapeCity.ActiveReports.Document.v10)
Inheritance Hierarchy
GrapeCity.ActiveReports.Document.v10 Assembly : GrapeCity.ActiveReports.Document Namespace
The GrapeCity.ActiveReports.Document namespace contains many classes which give control over various aspects of the final output of the report.
Classes
 | Class | Description
Class | SectionDocument | The Document object represents the generated output of a report.
Delegates
 | Delegate | Description
Delegate | LoadCompletedEventHandler | Represents the method that will handle the LoadCompleted event of a Document.
Delegate | StateChangedHandler | Specifies the type of the StateChanged event of a Document.
See Also

Reference

GrapeCity.ActiveReports.Document.v10 Assembly


SectionDocument Class

SectionDocument Class
Members

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace : SectionDocument Class
The Document object represents the generated output of a report.
Object Model
SectionDocument Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class SectionDocument
public class SectionDocument
Remarks

ActiveReports renders its output to the pages of a document object. The document can be used with any of the viewer controls, saved for later retrieval or exported using any of ActiveReports export filters.

Implements the ISerializable interface.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.SectionDocument

See Also

Reference

SectionDocument Members
GrapeCity.ActiveReports.Document Namespace


SectionDocument Class Members

SectionDocument Class Members
Properties Methods Events

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace : SectionDocument Class

The following tables list the members exposed by SectionDocument.

Public Constructors
 | Name | Description
Public Constructor | SectionDocument Constructor | Overloaded. Creates a new instance of the Document class.
Top
Public Properties
 | Name | Description
Public Property | Bookmarks | Gets or sets a reference to the document's bookmarks.
Public Property | CacheToDisk | Sets or returns a value indicating whether to optimize the amount of memory used by the document by caching the report to disk instead of holding it in memory.
Public Property | CacheToDiskLocation | Gets or set the location of CacheToDisk files. The location can be a physical path or IsolateStorage.
Public Property | Content | Allows a document to be assigned to a web service.
Public Property | InProgress | Determines whether the document is currently being loaded with pages.
Public Property | LoadUrl | Gets or sets a URL from which to download the document asynchronously using internet protocols.
Public Property | Name | Gets or sets the name of the document.
Public Property | Pages | Gets a reference to the document's pages.
Public Property | Password | Gets or sets a password string used to protect the saved document file.
Public Property | Printer | Gets a reference to the document's printer settings.
Public Property | PrintOptions | Print options
Public Property | UserPreferences | Gets or sets user preferences in the viewer such as hyperlink and background colors.
Top
Public Methods
 | Name | Description
Public Method | CopyToClipboard | Exports the page(s) to Text and Rtf data and copies it to clipboard.
Public Method | Dispose | If you call dispose on this level that means that you are not suppose to use anything that is contained below this level. That means no pages, no fonts, etc.
Public Method | Find | Overloaded. Searches for the specified string in the Document's pages collection.
Public Method | Load | Overloaded. Loads a Document from a stream or a file.
Public Method | ResetPrinter | Resets the printer defaults.
Public Method | Save | Overloaded. Saves the Document content to a stream or a file.
Top
Public Events
 | Name | Description
Public Event | DownloadError | Occurs when an exception is thrown while downloading a document asynchronously from the LoadUrl location.
Public Event | LoadCompleted | Occurs after all the document pages have been fully loaded.
Public Event | PrintAborted | Occurs when printing of the document pages is cancelled.
Public Event | PrintingThreadErrorEvent | Occurs when an exception is thrown by the printing thread.
Public Event | PrintProgress | Occurs when the document pages are printing.
Public Event | StateChanged | Raised when the state is changed.
Top
See Also

Reference

SectionDocument Class
GrapeCity.ActiveReports.Document Namespace


SectionDocument Constructor

SectionDocument Constructor

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : SectionDocument Constructor
Creates a new instance of the Document class.
Overload List
Overload | Description
SectionDocument Constructor() | Creates a new instance of the Document class.
SectionDocument Constructor(String) | Creates a new instance of the Document class with a specified Document name.
See Also

Reference

SectionDocument Class
SectionDocument Members


SectionDocument Constructor()

SectionDocument Constructor()

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > SectionDocument Constructor : SectionDocument Constructor()
Creates a new instance of the Document class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public SectionDocument()
See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List


SectionDocument Constructor(String)

SectionDocument Constructor(String)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > SectionDocument Constructor : SectionDocument Constructor(String)
The name of the Document.
Creates a new instance of the Document class with a specified Document name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As System.String _
)
public SectionDocument(
   System.string name
)

Parameters

name
The name of the Document.
See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List


SectionDocument Class Methods

SectionDocument Class Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace : SectionDocument Class

For a list of all members of this type, see SectionDocument members.

Public Methods
 | Name | Description
Public Method | CopyToClipboard | Exports the page(s) to Text and Rtf data and copies it to clipboard.
Public Method | Dispose | If you call dispose on this level that means that you are not suppose to use anything that is contained below this level. That means no pages, no fonts, etc.
Public Method | Find | Overloaded. Searches for the specified string in the Document's pages collection.
Public Method | Load | Overloaded. Loads a Document from a stream or a file.
Public Method | ResetPrinter | Resets the printer defaults.
Public Method | Save | Overloaded. Saves the Document content to a stream or a file.
Top
See Also

Reference

SectionDocument Class
GrapeCity.ActiveReports.Document Namespace


CopyToClipboard Method (SectionDocument)

CopyToClipboard Method (SectionDocument)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : CopyToClipboard Method
The zero-based starting page index.
The number of pages, copied to clipboard.
Exports the page(s) to Text and Rtf data and copies it to clipboard.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyToClipboard( _
   ByVal firstPageIndex As System.Integer, _
   ByVal count As System.Integer _
)
public void CopyToClipboard(
   System.int firstPageIndex,
   System.int count
)

Parameters

firstPageIndex
The zero-based starting page index.
count
The number of pages, copied to clipboard.
See Also

Reference

SectionDocument Class
SectionDocument Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : Dispose() Method
If you call dispose on this level that means that you are not suppose to use anything that is contained below this level. That means no pages, no fonts, etc.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

SectionDocument Class
SectionDocument Members


Find Method (SectionDocument)

Find Method (SectionDocument)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : Find Method
Searches for the specified string in the Document's pages collection.
Searches for text in the document.
Overload List
Overload | Description
Find(String,Int32) | Searches the text in the document for a specified string starting at a specified location.
Find(String,FindOptions,Int32,Single) | Searches the text in the document for a specified string starting at a specified location and with specific options applied to the search.
Remarks
If found, returns the location of the string in the currentIndex parameter. To continue searching after the first occurrence, call the method again with the returned currentIndex.
Example
  • C#
private void btnFind_Click(object sender, System.EventArgs e)
{
    int i = 0;
    if (viewer1.Document.Find("Coyote", ref i) == true)
    {
        MessageBox.Show ("This document contains the word Coyote.");
        viewer1.Document.ClearFindTextSelection();
    }
}
  • Visual Basic
Private Sub btnFind_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnFind.Click
    If Viewer1.Document.Find("Coyote", 0) Then
        MsgBox("This document contains the word Coyote.")
        Viewer1.Document.ClearFindTextSelection()
    End If
End Sub
See Also

Reference

SectionDocument Class
SectionDocument Members


Find(String,Int32) Method

Find(String,Int32) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > Find Method : Find(String,Int32) Method

String to search for in the document.

Starting position of the search. If the string was found, currentIndex is set to the position where the string was found.
Searches the text in the document for a specified string starting at a specified location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Find( _
   ByVal searchString As System.String, _
   ByRef currentIndex As System.Integer _
) As System.Boolean
public System.bool Find(
   System.string searchString,
   ref System.int currentIndex
)

Parameters

searchString

String to search for in the document.

currentIndex
Starting position of the search. If the string was found, currentIndex is set to the position where the string was found.
See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List


Find(String,FindOptions,Int32,Single) Method

Find(String,FindOptions,Int32,Single) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > Find Method : Find(String,FindOptions,Int32,Single) Method
The string you are searching for
which direction you are searching
The page's collection zero based index
The current offset into the text string
Searches the text in the document for a specified string starting at a specified location and with specific options applied to the search.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Find( _
   ByVal searchString As System.String, _
   ByVal options As FindOptions, _
   ByRef currentIndex As System.Integer, _
   ByRef currentOffset As System.Single _
) As FindResult
public FindResult Find(
   System.string searchString,
   FindOptions options,
   ref System.int currentIndex,
   ref System.float currentOffset
)

Parameters

searchString
The string you are searching for
options
which direction you are searching
currentIndex
The page's collection zero based index
currentOffset
The current offset into the text string
See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List


Load Method (SectionDocument)

Load Method (SectionDocument)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : Load Method
Loads a Document from a stream or a file.
Overload List
Overload | Description
Load(Stream) | Loads the report document from a stream.
Load(String) | Loads a document from the specified file.
Example
  • C#
private void Form1_Load(object sender, System.EventArgs e)
{
    System.IO.MemoryStream strm = new System.IO.MemoryStream();
    rptMemoryStream rpt = new rptMemoryStream();
    rpt.Run();
    rpt.Document.Save(strm);
    byte[] theBytes = new byte[strm.Length];
    strm.Read(theBytes, 0, (int)strm.Length);
    strm.Position =0;
    viewer1.Document.Load(strm);
}
  • Visual Basic
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim strm As New System.IO.MemoryStream()
    Dim rpt As New rptMemoryStream()
    rpt.Run()
    rpt.Document.Save(strm)
    Dim theBytes(strm.Length) As Byte
    strm.Read(theBytes, 0, Int(strm.Length))
    strm.Position = 0
    Viewer1.Document.Load(strm)
End Sub
See Also

Reference

SectionDocument Class
SectionDocument Members

How To

Save and Load Report Files (RDF)


Load(Stream) Method

Load(Stream) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > Load Method : Load(Stream) Method
A Stream that contains a valid persisted report document.
Loads the report document from a stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Load( _
   ByVal stream As System.IO.Stream _
)
public void Load(
   System.IO.Stream stream
)

Parameters

stream
A Stream that contains a valid persisted report document.
Example
  • C#
private void Form1_Load(object sender, System.EventArgs e)
{
    System.IO.MemoryStream strm = new System.IO.MemoryStream();
    rptMemoryStream rpt = new rptMemoryStream();
    rpt.Run();
    rpt.Document.Save(strm);
    byte[] theBytes = new byte[strm.Length];
    strm.Read(theBytes, 0, (int)strm.Length);
    strm.Position =0;
    viewer1.Document.Load(strm);
}
  • Visual Basic
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim strm As New System.IO.MemoryStream()
    Dim rpt As New rptMemoryStream()
    rpt.Run()
    rpt.Document.Save(strm)
    Dim theBytes(strm.Length) As Byte
    strm.Read(theBytes, 0, Int(strm.Length))
    strm.Position = 0
    Viewer1.Document.Load(strm)
End Sub
See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List


Load(String) Method

Load(String) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > Load Method : Load(String) Method
Document file name.
Loads a document from the specified file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Load( _
   ByVal fileName As System.String _
)
public void Load(
   System.string fileName
)

Parameters

fileName
Document file name.
Example
  • C#
private void btnLoad_Click(object sender, System.EventArgs e)
{
    arv.Document.Load(Application.StartupPath + "\\Document.rdf");
}
  • Visual Basic
Private Sub btnLoad_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSave.Click
    arv.Document.Load(Application.StartupPath & "\Document.rdf")
End Sub
See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List


ResetPrinter Method (SectionDocument)

ResetPrinter Method (SectionDocument)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : ResetPrinter Method
Resets the printer defaults.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ResetPrinter()
public void ResetPrinter()
See Also

Reference

SectionDocument Class
SectionDocument Members


Save Method (SectionDocument)

Save Method (SectionDocument)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : Save Method
Saves the Document content to a stream or a file.
Overload List
Overload | Description
Save(String,RdfFormat) | Saves the report document to the specified file using the specified file format.
Save(String,RdfFormat,SaveOptions) | Saves the report document to the specified file using the specified file format with the specified compression.
Save(String) | Saves the report document to the specified file.
Save(Stream,RdfFormat) | Saves the Document content to a stream in the specified file format.
Save(Stream,RdfFormat,SaveOptions) | Saves the Document content to a stream in the specified file format with the specified compression.
Save(Stream) | Saves the Document content to a Stream.
Example
  • C#
private void Form1_Load(object sender, System.EventArgs e)
{
    System.IO.MemoryStream strm = new System.IO.MemoryStream();
    rptMemoryStream rpt = new rptMemoryStream();
    rpt.Run();
    rpt.Document.Save(strm);
    byte[] theBytes = new byte[strm.Length];
    strm.Read(theBytes, 0, (int)strm.Length);
    strm.Position =0;
    viewer1.Document.Load(strm);
}
  • Visual Basic
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim strm As New System.IO.MemoryStream()
    Dim rpt As New rptMemoryStream()
    rpt.Run()
    rpt.Document.Save(strm)
    Dim theBytes(strm.Length) As Byte
    strm.Read(theBytes, 0, Int(strm.Length))
    strm.Position = 0
    Viewer1.Document.Load(strm)
End Sub
See Also

Reference

SectionDocument Class
SectionDocument Members
Load method
LoadUrl property

How To

Save and Load Report Files (RDF)


Save(String,RdfFormat) Method

Save(String,RdfFormat) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > Save Method : Save(String,RdfFormat) Method
File path where the document will be saved.
Uses the RdfFormat enumeration to specify the file format in which to save the report.
Saves the report document to the specified file using the specified file format.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Save( _
   ByVal fileName As System.String, _
   ByVal fmt As RdfFormat _
)
public void Save(
   System.string fileName,
   RdfFormat fmt
)

Parameters

fileName
File path where the document will be saved.
fmt
Uses the RdfFormat enumeration to specify the file format in which to save the report.
Example
  • C#
private void btnSave_Click(object sender, System.EventArgs e)
{
    arv.Document.Save(Application.StartupPath + "\\Document.rdf", GrapeCity.ActiveReports..Document.Section.RdfFormat.AR20);
}
  • Visual Basic
Private Sub btnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSave.Click
    arv.Document.Save(Application.StartupPath & "\Document.rdf", GrapeCity.ActiveReports.Document.Section.RdfFormat.AR20)
End Sub
See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List
Load method
LoadUrl property


Save(String,RdfFormat,SaveOptions) Method

Save(String,RdfFormat,SaveOptions) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > Save Method : Save(String,RdfFormat,SaveOptions) Method
File path where the document will be saved.
Uses the RdfFormat enumeration to specify the file format in which to save the report.

Uses the SaveOptions enumeration to specify the compression to use on the document.

Saves the report document to the specified file using the specified file format with the specified compression.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Save( _
   ByVal fileName As System.String, _
   ByVal fmt As RdfFormat, _
   ByVal options As SaveOptions _
)
public void Save(
   System.string fileName,
   RdfFormat fmt,
   SaveOptions options
)

Parameters

fileName
File path where the document will be saved.
fmt
Uses the RdfFormat enumeration to specify the file format in which to save the report.
options

Uses the SaveOptions enumeration to specify the compression to use on the document.

Example
  • C#
private void btnSave_Click(object sender, System.EventArgs e)
{
    arv.Document.Save(Application.StartupPath + "\\Document.rdf", GrapeCity.ActiveReports.Document.Section.RdfFormat.AR20, GrapeCity.ActiveReports.Document.Section.SaveOptions.Compressed);
}
  • Visual Basic
Private Sub btnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSave.Click
    arv.Document.Save(Application.StartupPath & "\Document.rdf", GrapeCity.ActiveReports.Document.Secction.RdfFormat.AR20, GrapeCity.ActiveReports.Document.Section.SaveOptions.Compressed)
End Sub
See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List
SaveOptions Enumeration


Save(String) Method

Save(String) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > Save Method : Save(String) Method
File path where the document will be saved.
Saves the report document to the specified file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Save( _
   ByVal fileName As System.String _
)
public void Save(
   System.string fileName
)

Parameters

fileName
File path where the document will be saved.
Remarks
Default file format is ARNet RDF file.
Example
  • C#
private void btnSave_Click(object sender, System.EventArgs e)
{
    arv.Document.Save(Application.StartupPath + "\\Document.rdf");
}
  • Visual Basic
Private Sub btnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSave.Click
    arv.Document.Save(Application.StartupPath & "\Document.rdf")
End Sub
See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List
Load method
LoadUrl property


Save(Stream,RdfFormat) Method

Save(Stream,RdfFormat) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > Save Method : Save(Stream,RdfFormat) Method
Specifies the Stream object where the document should be saved.
Uses the RdfFormat enumeration to specify the file format in which to save the report.
Saves the Document content to a stream in the specified file format.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Save( _
   ByVal stream As System.IO.Stream, _
   ByVal fmt As RdfFormat _
)
public void Save(
   System.IO.Stream stream,
   RdfFormat fmt
)

Parameters

stream
Specifies the Stream object where the document should be saved.
fmt
Uses the RdfFormat enumeration to specify the file format in which to save the report.
Example
  • C#
private void Form1_Load(object sender, System.EventArgs e)
{
    System.IO.MemoryStream strm = new System.IO.MemoryStream();
    rptMemoryStream rpt = new rptMemoryStream();
    rpt.Run();
    rpt.Document.Save(strm, GrapeCity.ActiveReports.Document.Section.RdfFormat.AR20);
    byte[] theBytes = new byte[strm.Length];
    strm.Read(theBytes, 0, (int)strm.Length);
    strm.Position =0;
}
  • Visual Basic
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim strm As New System.IO.MemoryStream()
    Dim rpt As New rptMemoryStream()
    rpt.Run()
    rpt.Document.Save(strm, GrapeCity.ActiveReports.Document.Section.RdfFormat.AR20)
    Dim theBytes(strm.Length) As Byte
    strm.Read(theBytes, 0, Int(strm.Length))
    strm.Position = 0
End Sub
See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List
Load Method
LoadUrl property
RdfFormat Enumeration


Save(Stream,RdfFormat,SaveOptions) Method

Save(Stream,RdfFormat,SaveOptions) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > Save Method : Save(Stream,RdfFormat,SaveOptions) Method
Specifies the Stream object where the document should be saved.
Uses the RdfFormat enumeration to specify the file format in which to save the report.

Uses the SaveOptions enumeration to specify the compression to use on the document.

Saves the Document content to a stream in the specified file format with the specified compression.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Save( _
   ByVal stream As System.IO.Stream, _
   ByVal fmt As RdfFormat, _
   ByVal options As SaveOptions _
)
public void Save(
   System.IO.Stream stream,
   RdfFormat fmt,
   SaveOptions options
)

Parameters

stream
Specifies the Stream object where the document should be saved.
fmt
Uses the RdfFormat enumeration to specify the file format in which to save the report.
options

Uses the SaveOptions enumeration to specify the compression to use on the document.

Example
  • C#
private void Form1_Load(object sender, System.EventArgs e)
{
    System.IO.MemoryStream strm = new System.IO.MemoryStream();
    rptMemoryStream rpt = new rptMemoryStream();
    rpt.Run();
    rpt.Document.Save(strm, GrapeCity.ActiveReports.Document.Section.RdfFormat.AR20, GrapeCity.ActiveReports.Document.Section.SaveOptions.Compressed);
    byte[] theBytes = new byte[strm.Length];
    strm.Read(theBytes, 0, (int)strm.Length);
    strm.Position =0;
}
  • Visual Basic
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim strm As New System.IO.MemoryStream()
    Dim rpt As New rptMemoryStream()
    rpt.Run()
    rpt.Document.Save(strm, GrapeCity.ActiveReports.Document.Section.RdfFormat.AR20, GrapeCity.ActiveReports.Document.Section.SaveOptions.Compressed)
    Dim theBytes(strm.Length) As Byte
    strm.Read(theBytes, 0, Int(strm.Length))
    strm.Position = 0
End Sub
See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List
SaveOptions
RdfFormat Enumeration


Save(Stream) Method

Save(Stream) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class > Save Method : Save(Stream) Method
Specifies the Stream object where the document should be saved.
Saves the Document content to a Stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Save( _
   ByVal stream As System.IO.Stream _
)
public void Save(
   System.IO.Stream stream
)

Parameters

stream
Specifies the Stream object where the document should be saved.
Remarks

Default document file format is ARNet file.

Example
  • C#
private void Form1_Load(object sender, System.EventArgs e)
{
    System.IO.MemoryStream strm = new System.IO.MemoryStream();
    rptMemoryStream rpt = new rptMemoryStream();
    rpt.Run();
    rpt.Document.Save(strm);
    byte[] theBytes = new byte[strm.Length];
    strm.Read(theBytes, 0, (int)strm.Length);
    strm.Position =0;
    viewer1.Document.Load(strm);
}
  • Visual Basic
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim strm As New System.IO.MemoryStream()
    Dim rpt As New rptMemoryStream()
    rpt.Run()
    rpt.Document.Save(strm)
    Dim theBytes(strm.Length) As Byte
    strm.Read(theBytes, 0, Int(strm.Length))
    strm.Position = 0
    Viewer1.Document.Load(strm)
End Sub
See Also

Reference

SectionDocument Class
SectionDocument Members
Overload List
Load method
LoadUrl property


SectionDocument Class Properties

SectionDocument Class Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace : SectionDocument Class

For a list of all members of this type, see SectionDocument members.

Public Properties
 | Name | Description
Public Property | Bookmarks | Gets or sets a reference to the document's bookmarks.
Public Property | CacheToDisk | Sets or returns a value indicating whether to optimize the amount of memory used by the document by caching the report to disk instead of holding it in memory.
Public Property | CacheToDiskLocation | Gets or set the location of CacheToDisk files. The location can be a physical path or IsolateStorage.
Public Property | Content | Allows a document to be assigned to a web service.
Public Property | InProgress | Determines whether the document is currently being loaded with pages.
Public Property | LoadUrl | Gets or sets a URL from which to download the document asynchronously using internet protocols.
Public Property | Name | Gets or sets the name of the document.
Public Property | Pages | Gets a reference to the document's pages.
Public Property | Password | Gets or sets a password string used to protect the saved document file.
Public Property | Printer | Gets a reference to the document's printer settings.
Public Property | PrintOptions | Print options
Public Property | UserPreferences | Gets or sets user preferences in the viewer such as hyperlink and background colors.
Top
See Also

Reference

SectionDocument Class
GrapeCity.ActiveReports.Document Namespace


Bookmarks Property (SectionDocument)

Bookmarks Property (SectionDocument)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : Bookmarks Property
Gets or sets a reference to the document's bookmarks.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Bookmarks As BookmarksCollection
public BookmarksCollection Bookmarks {get;}
Example
  • C#
private void viewer1_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    viewer1.Document=rpt.Document;
    MessageBox.Show("There are " + viewer1.Document.Bookmarks.Count.ToString() + " bookmarks.");
}
  • Visual Basic
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New rptDocument
    rpt.Run()
    Viewer1.Document = rpt.Document
    MsgBox("There are " & Viewer1.Document.Bookmarks.Count.ToString & " bookmarks.")
End Sub
See Also

Reference

SectionDocument Class
SectionDocument Members
Bookmark Class


CacheToDisk Property

CacheToDisk Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : CacheToDisk Property
Sets or returns a value indicating whether to optimize the amount of memory used by the document by caching the report to disk instead of holding it in memory.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CacheToDisk As System.Boolean
public System.bool CacheToDisk {get; set;}

Property Value

Boolean. The default value is False.
Remarks

Temporary files are written when this property is set to True. If there is an unhandled exception during report execution, these temporary files may remain on the system. The location of these files is:

WinForms: C:\Documents and Settings\All Users\Application Data\IsolatedStorage

WebForms: C:\Documents and Settings\<machine name>\ASPNET\ Local Settings\Application Data\IsolatedStorage

CacheToDisk uses IsolatedStorage to store a page’s canvasItems to disk. To use CacheToDisk you must have permissions set for the IsolatedStorage folder.

Temporary files and folders created in IsolatedStorage are not deleted automatically.

Note: This property should only be set to True for reports that consume large amounts of memory, as it slows processing time. The property was created to be used with reports for which there is a danger of being unable to finish processing due to memory usage.

The PDF export will also detect this setting and export the cached report. Other exports will ignore this setting, so very large reports may cause them to run out of memory.

Note that the ClearCanvasItems method does not work correctly if this property is set to True.

Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Document.CacheToDisk = true;
    rpt.Run();
    arv.Document=rpt.Document;
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Document.CacheToDisk = True
    rpt.Run()
    arv.Document = rpt.Document
End Sub
See Also

Reference

SectionDocument Class
SectionDocument Members
ClearCanvasItems Method


CacheToDiskLocation Property

CacheToDiskLocation Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : CacheToDiskLocation Property
Gets or set the location of CacheToDisk files. The location can be a physical path or IsolateStorage.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CacheToDiskLocation As System.String
public System.string CacheToDiskLocation {get; set;}
Remarks
Temporary files and folders created in IsolatedStorage are not deleted automatically.
Example
  • C#
private void viewer1_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Document.CacheToDisk = true;
    rpt.Document.CacheToDiskLocation = "C:\\Temp";
    rpt.Run();
    viewer1.Document=rpt.Document;
}
  • Visual Basic
Private Sub viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Document.CacheToDisk = True
    rpt.Document.CacheToDiskLocation = "C:\\Temp
    rpt.Run()
    viewer1.Document = rpt.Document
End Sub
See Also

Reference

SectionDocument Class
SectionDocument Members


Content Property (SectionDocument)

Content Property (SectionDocument)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : Content Property
Allows a document to be assigned to a web service.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Content As System.Byte()
public System.byte[] Content {get; set;}

Property Value

A valid xml schema of the report.

Remarks
This is for XML Serialization used in retrieving a report from a web service. It is basically the same information that the viewer loads from an RDF file.
See Also

Reference

SectionDocument Class
SectionDocument Members

Walkthroughs

Document Web Service


InProgress Property

InProgress Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : InProgress Property

Determines whether the document is currently being loaded with pages.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property InProgress As System.Boolean
public System.bool InProgress {get; set;}

Property Value

A Boolean value. True if the document loading is currently in progress; otherwise, false.
Example
  • C#
private void viewer1_Load(object sender, System.EventArgs e)
{
    if (arv.Document.InProgress)
    {
        this.progressBar1.Visible = true;
    }
    else
    {
        this.progressBar1.Visible = false;
    }
}
  • Visual Basic
Private Sub viewer1_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Load
    If arv.Document.InProgress Then
        Me.ProgressBar1.Visible = True
    Else
        Me.ProgressBar1.Visible = False
    End If
End Sub
See Also

Reference

SectionDocument Class
SectionDocument Members


LoadUrl Property

LoadUrl Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : LoadUrl Property
Gets or sets a URL from which to download the document asynchronously using internet protocols.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LoadUrl As System.String
public System.string LoadUrl {get; set;}
Example
  • C#
private void Form1_Load(object sender, EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Run();
    rpt.Document.Save(@"C:\Inetpub\wwwroot\LoadURLTest\report_Normal.rdf", GrapeCity.ActiveReports.Document.Section.RdfFormat.ARNet, GrapeCity.ActiveReports.Document.Section.SaveOptions.Normal);
    this.viewer1.Document.LoadUrl = "http://localhost/Loadurltest/report_Normal.rdf";

}
  • Visual Basic
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

    Dim rpt As New SectionReport1
    rpt.Run()
    rpt.Document.Save("C:\Inetpub\wwwroot\LoadURLTest\report_Normal.rdf", GrapeCity.ActiveReports.Document.Section.RdfFormat.ARNet, GrapeCity.ActiveReports.Document.Section.SaveOptions.Normal)
    Me.Viewer1.Document.LoadUrl = "http://localhost/Loadurltest/report_Normal.rdf"

End
See Also

Reference

SectionDocument Class
SectionDocument Members


Name Property (SectionDocument)

Name Property (SectionDocument)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : Name Property
Gets or sets the name of the document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}

Property Value

A string value that represents the name of the document.
Remarks
The name of the document appears in the print job listing of the printer when the document is printed.
Example
  • C#
private void btnPrint_Click(object sender, System.EventArgs e)
{
    arv.Document.Name = System.Windows.Forms.SystemInformation.UserName;
    arv.Document.Print();
}
  • Visual Basic
Private Sub btnPrint_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnPrint.Click
    arv.Document.Name = System.Windows.Forms.SystemInformation.UserName
    arv.Document.Print()
End Sub
See Also

Reference

SectionDocument Class
SectionDocument Members


Pages Property (SectionDocument)

Pages Property (SectionDocument)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : Pages Property
Gets a reference to the document's pages.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Pages As PagesCollection
public PagesCollection Pages {get;}
Remarks
Use this collection to add, remove or modify the pages of the document.
Example
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    for(int i = 0; i<Document.Pages.Count;i++)
    {
        this.Document.Pages[i].AddBookmark("New Bookmark", 25);
    }
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Dim i As Integer
    Try
        For i = 0 To Me.Document.Pages.Count - 1
            Me.Document.Pages(1).AddBookmark("New Bookmark", 8)
        Next
    Catch ex As Exception
    End Try
End Sub
See Also

Reference

SectionDocument Class
SectionDocument Members


Password Property (SectionDocument)

Password Property (SectionDocument)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : Password Property
Gets or sets a password string used to protect the saved document file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Password As System.String
public System.string Password {get; set;}

Property Value

String.
Remarks
The password is used with the ActiveReports RDF file format.
Example
  • C#
private void btnSave_Click(object sender, System.EventArgs e)
{
    arv.Document.Password = "Mortimer";
    arv.Document.Save(Application.StartupPath + "\\Document.rdf");
}
  • Visual Basic
Private Sub btnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSave.Click
    arv.Document.Password = "Mortimer"
    arv.Document.Save(Application.StartupPath & "Document.rdf")
End Sub
See Also

Reference

SectionDocument Class
SectionDocument Members


Printer Property (SectionDocument)

Printer Property (SectionDocument)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : Printer Property
Gets a reference to the document's printer settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Printer As Printer
public Printer Printer {get;}

Property Value

A GrapeCity.ActiveReports.Document.Printer value that represents the current document printing options.
Remarks
Use this property to set the printer options before displaying a print dialog or directly printing the document to the printer with the specified options.
Example
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.Document.Printer.PrinterSettings.Copies=5;
}

private void SectionReport1_ReportEnd(object sender, System.EventArgs eArgs)
{
    this.Document.Print(false, false);
}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Document.Printer.PrinterSettings.Copies = 5
End Sub

Private Sub SectionReport1_ReportEnd(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Document.Print(False, False)
End Sub
See Also

Reference

SectionDocument Class
SectionDocument Members
Printer class


PrintOptions Property (SectionDocument)

PrintOptions Property (SectionDocument)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : PrintOptions Property
Print options
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PrintOptions As PrintOptions
public PrintOptions PrintOptions {get;}
See Also

Reference

SectionDocument Class
SectionDocument Members


UserPreferences Property

UserPreferences Property

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : UserPreferences Property
Gets or sets user preferences in the viewer such as hyperlink and background colors.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UserPreferences As UserPreferences
public UserPreferences UserPreferences {get; set;}

Property Value

The user preferences.
See Also

Reference

SectionDocument Class
SectionDocument Members


SectionDocument Class Events

SectionDocument Class Events

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace : SectionDocument Class

For a list of all members of this type, see SectionDocument members.

Public Events
 | Name | Description
Public Event | DownloadError | Occurs when an exception is thrown while downloading a document asynchronously from the LoadUrl location.
Public Event | LoadCompleted | Occurs after all the document pages have been fully loaded.
Public Event | PrintAborted | Occurs when printing of the document pages is cancelled.
Public Event | PrintingThreadErrorEvent | Occurs when an exception is thrown by the printing thread.
Public Event | PrintProgress | Occurs when the document pages are printing.
Public Event | StateChanged | Raised when the state is changed.
Top
See Also

Reference

SectionDocument Class
GrapeCity.ActiveReports.Document Namespace


DownloadError Event

DownloadError Event

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : DownloadError Event
Occurs when an exception is thrown while downloading a document asynchronously from the LoadUrl location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DownloadError As UrlErrorEventHandler
public event UrlErrorEventHandler DownloadError
Event Data

The event handler receives an argument of type UrlErrorEventArgs containing data related to this event. The following UrlErrorEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets or sets a value that specifies the exception that caused the download error.
See Also

Reference

SectionDocument Class
SectionDocument Members
LoadUrl


LoadCompleted Event (SectionDocument)

LoadCompleted Event (SectionDocument)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : LoadCompleted Event
Occurs after all the document pages have been fully loaded.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LoadCompleted As LoadCompletedEventHandler
public event LoadCompletedEventHandler LoadCompleted
See Also

Reference

SectionDocument Class
SectionDocument Members
Load method
LoadUrl property


PrintAborted Event (SectionDocument)

PrintAborted Event (SectionDocument)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : PrintAborted Event
Occurs when printing of the document pages is cancelled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PrintAborted As PrintAbortedEventHandler
public event PrintAbortedEventHandler PrintAborted
See Also

Reference

SectionDocument Class
SectionDocument Members


PrintingThreadErrorEvent Event (SectionDocument)

PrintingThreadErrorEvent Event (SectionDocument)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : PrintingThreadErrorEvent Event
Occurs when an exception is thrown by the printing thread.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PrintingThreadErrorEvent As PrintingThreadErrorEventHandler
public event PrintingThreadErrorEventHandler PrintingThreadErrorEvent
Event Data

The event handler receives an argument of type PrintingThreadErrorEventArgs containing data related to this event. The following PrintingThreadErrorEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets or sets a value that specifies the exception that caused the printing thread error.
See Also

Reference

SectionDocument Class
SectionDocument Members


PrintProgress Event (SectionDocument)

PrintProgress Event (SectionDocument)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : PrintProgress Event
Occurs when the document pages are printing.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PrintProgress As PrintProgressEventHandler
public event PrintProgressEventHandler PrintProgress
Event Data

The event handler receives an argument of type PrintProgressEventArgs containing data related to this event. The following PrintProgressEventArgs properties provide information specific to this event.

Property | Description
CurrentPage | Gets the currently printing page.
See Also

Reference

SectionDocument Class
SectionDocument Members


StateChanged Event

StateChanged Event

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : StateChanged Event
Raised when the state is changed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event StateChanged As StateChangedHandler
public event StateChangedHandler StateChanged
See Also

Reference

SectionDocument Class
SectionDocument Members


LoadCompletedEventHandler Delegate

LoadCompletedEventHandler Delegate

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace : LoadCompletedEventHandler Delegate
Source of the event.
An LoadCompletedEventArgs value that contains the event data.
Represents the method that will handle the LoadCompleted event of a Document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub LoadCompletedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)
public delegate void LoadCompletedEventHandler(
   System.object sender,
   System.EventArgs e
)

Parameters

sender
Source of the event.
e
An LoadCompletedEventArgs value that contains the event data.
See Also

Reference

LoadCompletedEventHandler Members
GrapeCity.ActiveReports.Document Namespace


StateChangedHandler Delegate

StateChangedHandler Delegate

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace : StateChangedHandler Delegate
Source of the event.
An EventArgs value that contains the event data.
Specifies the type of the StateChanged event of a Document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub StateChangedHandler( _
   ByVal sender As System.Object, _
   ByVal e As StateChangedArgs _
)
public delegate void StateChangedHandler(
   System.object sender,
   StateChangedArgs e
)

Parameters

sender
Source of the event.
e
An EventArgs value that contains the event data.
See Also

Reference

StateChangedHandler Members
GrapeCity.ActiveReports.Document Namespace


GrapeCity.ActiveReports.Document.Section Namespace

GrapeCity.ActiveReports.Document.Section Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Document.v10 Assembly : GrapeCity.ActiveReports.Document.Section Namespace
The GrapeCity.ActiveReports.Document.Section Namespace contains various classes that can be set in the report document.
Classes
 | Class | Description
Class | ActiveReportPrintControllerWithStatusDialog | Controls how a document is printed.
Class | Bookmark | Specifies a named location in the report document or page that can be reached by name using hyperlinks or using the table of contents outline tree.
Class | BookmarksCollection | Specifies a collection of Bookmark objects.
Class | Margins | Used to specify the printed page margins.
Class | Page | Represents a printed page in the report document.
Class | PagesCollection | Manages a set of pages in the Document object.
Class | RText.TabStop | Represents the custom tab stop.
Class | StringFormatProvider | Provide local factory which create own instances of StringFormat.GenericDefault and StringFormat.GenericTypographic, independent of changes in GDI+ StringFormat getter factories.
Class | UrlErrorEventArgs | Specifies the arguments of a downloadError event.
Class | UserPreferences | Specifies the look of hyperlinks and the controls that host them in the Viewer control.
Delegates
 | Delegate | Description
Delegate | UrlErrorEventHandler | Represents the method that will handle the downloadError event of a Document.
Enumerations
 | Enumeration | Description
Enumeration | BackgroundStyle | Specifies the background style when using the low level page drawing APIs.
Enumeration | PageOrientation | Specifies the orientation of a page when rendered to the printer.
Enumeration | PenStyles | Specifies the pen style used to draw lines on a page.
Enumeration | RdfFormat | Specifies the file format used to save the report document.
Enumeration | RText.TabType | Specifies tab stop types.
Enumeration | SaveOptions | Specifies the compression type used to save the report document.
Enumeration | TextAlignment | Specifies the horizontal alignment of text within the control area.
Enumeration | TextJustify | Specifies how to justify text when the TextAlignment property is set to Justify.
Enumeration | Units | Specifies the document measurement units when using low level drawing API on a document page.
Enumeration | VerticalTextAlignment | Specifies the vertical alignment of text within the control area.
Enumeration | WrapMode | Specifies whether the text is written from left to right or right to left.
Remarks

See Also

Reference

GrapeCity.ActiveReports.Document.v10 Assembly


ActiveReportPrintControllerWithStatusDialog Class

ActiveReportPrintControllerWithStatusDialog Class
Members

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ActiveReportPrintControllerWithStatusDialog Class
Controls how a document is printed.
Object Model
ActiveReportPrintControllerWithStatusDialog Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ActiveReportPrintControllerWithStatusDialog
   Inherits System.Drawing.Printing.StandardPrintController
   Implements GrapeCity.ActiveReports.Extensibility.Printing.IActiveReportPrintController
public class ActiveReportPrintControllerWithStatusDialog : System.Drawing.Printing.StandardPrintController, GrapeCity.ActiveReports.Extensibility.Printing.IActiveReportPrintController
Remarks
Implements a StandardPrintController and adds a print status dialog.
Inheritance Hierarchy

System.Object
System.Drawing.Printing.PrintController
System.Drawing.Printing.StandardPrintController
GrapeCity.ActiveReports.Document.Section.ActiveReportPrintControllerWithStatusDialog

See Also

Reference

ActiveReportPrintControllerWithStatusDialog Members
GrapeCity.ActiveReports.Document.Section Namespace


ActiveReportPrintControllerWithStatusDialog Class Members

ActiveReportPrintControllerWithStatusDialog Class Members
Properties Methods Events

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ActiveReportPrintControllerWithStatusDialog Class

The following tables list the members exposed by ActiveReportPrintControllerWithStatusDialog.

Public Constructors
 | Name | Description
Public Constructor | ActiveReportPrintControllerWithStatusDialog Constructor | Initializes a new instance of the ActiveReportPrintControllerWithStatusDialog class.
Top
Public Properties
 | Name | Description
Public Property | IsPreview | (Inherited from System.Drawing.Printing.PrintController)
Top
Public Methods
 | Name | Description
Public Method | OnEndPage | Overridden. Completes the control sequence that determines when and how to print a page of a document.
Public Method | OnEndPrint | Overridden. Completes the control sequence that determines when and how to print a document.
Public Method | OnStartPage | Overridden. Begins the control sequence that determines when and how to print a page in a document.
Public Method | OnStartPrint | Overridden. Begins the control sequence that determines when and how to print a document.
Top
Public Events
 | Name | Description
Public Event | PrintAborted | Occurs if the user clicks the Abort button on the status dialog.
Public Event | PrintingProgress | Raised for each page printed in the print controller.
Top
See Also

Reference

ActiveReportPrintControllerWithStatusDialog Class
GrapeCity.ActiveReports.Document.Section Namespace


ActiveReportPrintControllerWithStatusDialog Constructor

ActiveReportPrintControllerWithStatusDialog Constructor

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ActiveReportPrintControllerWithStatusDialog Class : ActiveReportPrintControllerWithStatusDialog Constructor
Initializes a new instance of the ActiveReportPrintControllerWithStatusDialog class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ActiveReportPrintControllerWithStatusDialog()
See Also

Reference

ActiveReportPrintControllerWithStatusDialog Class
ActiveReportPrintControllerWithStatusDialog Members


ActiveReportPrintControllerWithStatusDialog Class Methods

ActiveReportPrintControllerWithStatusDialog Class Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ActiveReportPrintControllerWithStatusDialog Class

For a list of all members of this type, see ActiveReportPrintControllerWithStatusDialog members.

Public Methods
 | Name | Description
Public Method | OnEndPage | Overridden. Completes the control sequence that determines when and how to print a page of a document.
Public Method | OnEndPrint | Overridden. Completes the control sequence that determines when and how to print a document.
Public Method | OnStartPage | Overridden. Begins the control sequence that determines when and how to print a page in a document.
Public Method | OnStartPrint | Overridden. Begins the control sequence that determines when and how to print a document.
Top
See Also

Reference

ActiveReportPrintControllerWithStatusDialog Class
GrapeCity.ActiveReports.Document.Section Namespace


OnEndPage Method

OnEndPage Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ActiveReportPrintControllerWithStatusDialog Class : OnEndPage Method
A System.Drawing.Printing.PrintDocument that represents the document being printed.
A System.Drawing.Printing.PrintPageEventArgs that contains data about how to print a page in the document.
Completes the control sequence that determines when and how to print a page of a document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Sub OnEndPage( _
   ByVal prnDoc As System.Drawing.Printing.PrintDocument, _
   ByVal ppea As System.Drawing.Printing.PrintPageEventArgs _
)
public override void OnEndPage(
   System.Drawing.Printing.PrintDocument prnDoc,
   System.Drawing.Printing.PrintPageEventArgs ppea
)

Parameters

prnDoc
A System.Drawing.Printing.PrintDocument that represents the document being printed.
ppea
A System.Drawing.Printing.PrintPageEventArgs that contains data about how to print a page in the document.
Remarks
See the System.Drawing.Printing namespace for additional information.
See Also

Reference

ActiveReportPrintControllerWithStatusDialog Class
ActiveReportPrintControllerWithStatusDialog Members


OnEndPrint Method

OnEndPrint Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ActiveReportPrintControllerWithStatusDialog Class : OnEndPrint Method
A System.Drawing.Printing.PrintDocument that represents the document being printed.
A System.Drawing.Printing.PrintPageEventArgs that contains data about how to print a page in the document.
Completes the control sequence that determines when and how to print a document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Sub OnEndPrint( _
   ByVal prnDoc As System.Drawing.Printing.PrintDocument, _
   ByVal ppea As System.Drawing.Printing.PrintEventArgs _
)
public override void OnEndPrint(
   System.Drawing.Printing.PrintDocument prnDoc,
   System.Drawing.Printing.PrintEventArgs ppea
)

Parameters

prnDoc
A System.Drawing.Printing.PrintDocument that represents the document being printed.
ppea
A System.Drawing.Printing.PrintPageEventArgs that contains data about how to print a page in the document.
Remarks
See the System.Drawing.Printing namespace for additional information.
See Also

Reference

ActiveReportPrintControllerWithStatusDialog Class
ActiveReportPrintControllerWithStatusDialog Members


OnStartPage Method

OnStartPage Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ActiveReportPrintControllerWithStatusDialog Class : OnStartPage Method
A System.Drawing.Printing.PrintDocument that represents the document being printed.
A System.Drawing.Printing.PrintPageEventArgs that contains data about how to print a page in the document.
Begins the control sequence that determines when and how to print a page in a document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function OnStartPage( _
   ByVal prnDoc As System.Drawing.Printing.PrintDocument, _
   ByVal ppea As System.Drawing.Printing.PrintPageEventArgs _
) As Graphics
public override Graphics OnStartPage(
   System.Drawing.Printing.PrintDocument prnDoc,
   System.Drawing.Printing.PrintPageEventArgs ppea
)

Parameters

prnDoc
A System.Drawing.Printing.PrintDocument that represents the document being printed.
ppea
A System.Drawing.Printing.PrintPageEventArgs that contains data about how to print a page in the document.
Remarks
See the System.Drawing.Printing namespace for additional information.
See Also

Reference

ActiveReportPrintControllerWithStatusDialog Class
ActiveReportPrintControllerWithStatusDialog Members


OnStartPrint Method

OnStartPrint Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ActiveReportPrintControllerWithStatusDialog Class : OnStartPrint Method
A System.Drawing.Printing.PrintDocument that represents the document being printed.
A System.Drawing.Printing.PrintPageEventArgs that contains data about how to print a page in the document.
Begins the control sequence that determines when and how to print a document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Sub OnStartPrint( _
   ByVal prnDoc As System.Drawing.Printing.PrintDocument, _
   ByVal ppea As System.Drawing.Printing.PrintEventArgs _
)
public override void OnStartPrint(
   System.Drawing.Printing.PrintDocument prnDoc,
   System.Drawing.Printing.PrintEventArgs ppea
)

Parameters

prnDoc
A System.Drawing.Printing.PrintDocument that represents the document being printed.
ppea
A System.Drawing.Printing.PrintPageEventArgs that contains data about how to print a page in the document.
Remarks
See the System.Drawing.Printing namespace for additional information.
See Also

Reference

ActiveReportPrintControllerWithStatusDialog Class
ActiveReportPrintControllerWithStatusDialog Members


ActiveReportPrintControllerWithStatusDialog Class Events

ActiveReportPrintControllerWithStatusDialog Class Events

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ActiveReportPrintControllerWithStatusDialog Class

For a list of all members of this type, see ActiveReportPrintControllerWithStatusDialog members.

Public Events
 | Name | Description
Public Event | PrintAborted | Occurs if the user clicks the Abort button on the status dialog.
Public Event | PrintingProgress | Raised for each page printed in the print controller.
Top
See Also

Reference

ActiveReportPrintControllerWithStatusDialog Class
GrapeCity.ActiveReports.Document.Section Namespace


PrintAborted Event (ActiveReportPrintControllerWithStatusDialog)

PrintAborted Event (ActiveReportPrintControllerWithStatusDialog)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ActiveReportPrintControllerWithStatusDialog Class : PrintAborted Event
Occurs if the user clicks the Abort button on the status dialog.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PrintAborted As PrintAbortedEventHandler
public event PrintAbortedEventHandler PrintAborted
See Also

Reference

ActiveReportPrintControllerWithStatusDialog Class
ActiveReportPrintControllerWithStatusDialog Members


PrintingProgress Event

PrintingProgress Event

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ActiveReportPrintControllerWithStatusDialog Class : PrintingProgress Event
Raised for each page printed in the print controller.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PrintingProgress As PrintProgressEventHandler
public event PrintProgressEventHandler PrintingProgress
Event Data

The event handler receives an argument of type PrintProgressEventArgs containing data related to this event. The following PrintProgressEventArgs properties provide information specific to this event.

Property | Description
CurrentPage | Gets the currently printing page.
Remarks
Use this event to display a progress UI to the user.
See Also

Reference

ActiveReportPrintControllerWithStatusDialog Class
ActiveReportPrintControllerWithStatusDialog Members


Bookmark Class

Bookmark Class
Members Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Bookmark Class
Specifies a named location in the report document or page that can be reached by name using hyperlinks or using the table of contents outline tree.
Object Model
Bookmark Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Bookmark
public sealed class Bookmark
Remarks

Bookmarks are added to the report in a section's BeforePrint event using the Section.AddBookmark method. In addition, bookmarks can be added to any page in the document after the report has completed processing using the Page.AddBookmark method.

Bookmarks are stored within each page; when pages are added to a document the bookmarks are merged with the document's Bookmarks collection.

Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    int i;
    for (i = 1; i <= arv.Document.Bookmarks.Count; i++)
    {
        arv.Document.Bookmarks[i - 1].Label = "Bookmark number " + i;
    }
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    Dim i As Integer
    For i = 1 To arv.Document.Bookmarks.Count
        arv.Document.Bookmarks(i - 1).Label = "Bookmark number " & i
    Next i
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.Bookmark

See Also

Reference

Bookmark Members
GrapeCity.ActiveReports.Document.Section Namespace
Bookmarks collection


Bookmark Class Members

Bookmark Class Members
Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Bookmark Class

The following tables list the members exposed by Bookmark.

Public Constructors
 | Name | Description
Public Constructor | Bookmark Constructor | Creates a new instance of the Bookmark class.
Top
Public Properties
 | Name | Description
Public Property | Label | Gets or sets the caption of the bookmark.
Public Property | Offset | Gets or sets the location of the bookmark relative to the top of the page.
Public Property | PageNumber | Gets or sets the page number to which the bookmark was added.
Top
See Also

Reference

Bookmark Class
GrapeCity.ActiveReports.Document.Section Namespace
Bookmarks collection


Bookmark Constructor

Bookmark Constructor

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Bookmark Class : Bookmark Constructor
Creates a new instance of the Bookmark class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Bookmark()
See Also

Reference

Bookmark Class
Bookmark Members


Bookmark Class Properties

Bookmark Class Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Bookmark Class

For a list of all members of this type, see Bookmark members.

Public Properties
 | Name | Description
Public Property | Label | Gets or sets the caption of the bookmark.
Public Property | Offset | Gets or sets the location of the bookmark relative to the top of the page.
Public Property | PageNumber | Gets or sets the page number to which the bookmark was added.
Top
See Also

Reference

Bookmark Class
GrapeCity.ActiveReports.Document.Section Namespace
Bookmarks collection


Label Property (Bookmark)

Label Property (Bookmark)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Bookmark Class : Label Property
Gets or sets the caption of the bookmark.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Label As System.String
public System.string Label {get; set;}

Property Value

String.
Remarks

The name can be a simple string or a path to create a hierarchy. For example, "Entry 1" is a node with no parent, "Entry 1\Child 1.1" is a bookmark node with a caption "Child 1.1" whose parent is "Entry 1".

Example
  • C#
Private void viewer1_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = New rptDocument();
    rpt.Run();
    viewer1.Document=rpt.Document;
    int i;
    For (i = 1; i <= viewer1.Document.Bookmarks.Count; i++)
    {
        viewer1.Document.Bookmarks[i - 1].Label = "Bookmark number " + i;
    }
}
  • Visual Basic
Private Sub viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    viewer1.Document = rpt.Document
    Dim i As Integer
    For i = 1 To viewer1.Document.Bookmarks.Count
        viewer1.Document.Bookmarks(i - 1).Label = "Bookmark number " & i
    Next i
End Sub
See Also

Reference

Bookmark Class
Bookmark Members


Offset Property

Offset Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Bookmark Class : Offset Property
Gets or sets the location of the bookmark relative to the top of the page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Offset As System.Single
public System.float Offset {get; set;}

Property Value

A float value that represents the location of the bookmark in inches.
Example
  • C#
private void viewer1_TableOfContentsClick(object sender, System.EventArgs e)
{
    int toc;
    toc = viewer1.Document.Bookmarks.CurrentBookmark;
    MessageBox.Show ("You are leaving the bookmark at page " + viewer1.Document.Bookmarks[toc].PageNumber.ToString() + ", " + viewer1.Document.Bookmarks[toc].Offset.ToString() + " inches from the top of the page.");
}
  • Visual Basic
Private Sub viewer1_TableOfContentsClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles arv.TableOfContentsClick
    Dim toc As Integer
    toc = viewer1.Document.Bookmarks.CurrentBookmark
    MessageBox.Show("You are leaving the bookmark at page " & viewer1.Document.Bookmarks(toc).PageNumber.ToString & ", " & viewer1.Document.Bookmarks(toc).Offset.ToString & " inches from the top of the page.")
End Sub
See Also

Reference

Bookmark Class
Bookmark Members


PageNumber Property (Bookmark)

PageNumber Property (Bookmark)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Bookmark Class : PageNumber Property
Gets or sets the page number to which the bookmark was added.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageNumber As System.Integer
public System.int PageNumber {get; set;}

Property Value

Integer.
Example
  • C#
private void viewer1_TableOfContentsClick(object sender, System.EventArgs e)
{
    int toc;
    toc = viewer1.Document.Bookmarks.CurrentBookmark;
    MessageBox.Show ("You are leaving the bookmark at page " + viewer1.Document.Bookmarks[toc].PageNumber.ToString() + ", " + viewer1.Document.Bookmarks[toc].Offset.ToString() + " inches from the top of the page.");
}
  • Visual Basic
Private Sub viewer1_TableOfContentsClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles arv.TableOfContentsClick
    Dim toc As Integer
    toc = viewer1.Document.Bookmarks.CurrentBookmark
    MessageBox.Show("You are leaving the bookmark at page " & viewer1.Document.Bookmarks(toc).PageNumber.ToString & ", " & viewer1.Document.Bookmarks(toc).Offset.ToString & " inches from the top of the page.")
End Sub
See Also

Reference

Bookmark Class
Bookmark Members


BookmarksCollection Class

BookmarksCollection Class
Members

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BookmarksCollection Class
Specifies a collection of Bookmark objects.
Object Model
BookmarksCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class BookmarksCollection
   Inherits System.Collections.CollectionBase
public sealed class BookmarksCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.BookmarksCollection

See Also

Reference

BookmarksCollection Members
GrapeCity.ActiveReports.Document.Section Namespace


BookmarksCollection Class Members

BookmarksCollection Class Members
Properties Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BookmarksCollection Class

The following tables list the members exposed by BookmarksCollection.

Public Constructors
 | Name | Description
Public Constructor | BookmarksCollection Constructor | Creates a new instance of the BookmarkCollection class.
Top
Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of Bookmark objects in the collection. (Inherited from System.Collections.CollectionBase)
Public Property | CurrentBookmark | Returns the index of the currently selected bookmark.
Public Property | Item | Returns a reference to the bookmark object at the specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds the specified Bookmark object to the collection.
Public Method | Clear | Removes all bookmarks from the collection.
Public Method | Contains | Determines whether the specified bookmark object exists in the collection.
Public Method | CopyTo | Copies the Bookmarks collection from the specified report to a Bookmarks collection at the specified index.
Public Method | Dispose | Releases the BookmarksCollection instance from memory.
Public Method | FillTree | Loads the Bookmark objects into the Windows Forms TreeView control.
Public Method | IndexOf | Returns the index of the specified Bookmark object in the collection.
Public Method | Insert | Inserts the specified Bookmark object at the specified index in the collection.
Public Method | Remove | Removes the specified Bookmark object from the collection.
Public Method | RemoveAt | Removes the Bookmark object at the specified index from the collection. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

BookmarksCollection Class
GrapeCity.ActiveReports.Document.Section Namespace


BookmarksCollection Constructor

BookmarksCollection Constructor

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : BookmarksCollection Constructor
Creates a new instance of the BookmarkCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public BookmarksCollection()
See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


BookmarksCollection Class Methods

BookmarksCollection Class Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BookmarksCollection Class

For a list of all members of this type, see BookmarksCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds the specified Bookmark object to the collection.
Public Method | Clear | Removes all bookmarks from the collection.
Public Method | Contains | Determines whether the specified bookmark object exists in the collection.
Public Method | CopyTo | Copies the Bookmarks collection from the specified report to a Bookmarks collection at the specified index.
Public Method | Dispose | Releases the BookmarksCollection instance from memory.
Public Method | FillTree | Loads the Bookmark objects into the Windows Forms TreeView control.
Public Method | IndexOf | Returns the index of the specified Bookmark object in the collection.
Public Method | Insert | Inserts the specified Bookmark object at the specified index in the collection.
Public Method | Remove | Removes the specified Bookmark object from the collection.
Public Method | RemoveAt | Removes the Bookmark object at the specified index from the collection. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

BookmarksCollection Class
GrapeCity.ActiveReports.Document.Section Namespace


Add Method (BookmarksCollection)

Add Method (BookmarksCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Add Method
Specifies the Bookmark object to be added to the collection.
Adds the specified Bookmark object to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As Bookmark _
) As System.Integer
public System.int Add(
   Bookmark value
)

Parameters

value
Specifies the Bookmark object to be added to the collection.

Return Value

An integer index of the added bookmark in the collection.
See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Clear Method (BookmarksCollection)

Clear Method (BookmarksCollection)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Clear Method
Removes all bookmarks from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Sub Clear()
public new void Clear()
Example
  • C#
private void btnClearTOC_Click(object sender, System.EventArgs e)
{
    MessageBox.Show ("Clearing " + arv.Document.Bookmarks.Count.ToString() + " bookmarks.");
    arv.Document.Bookmarks.Clear();
    arv.TableOfContents.Clear();
}
  • Visual Basic
Private Sub btnClearTOC_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnClearTOC.Click
    MsgBox("Clearing " & arv.Document.Bookmarks.Count.ToString & " bookmarks.")
    arv.Document.Bookmarks.Clear()
    arv.TableOfContents.Clear()
End Sub
See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Contains Method (BookmarksCollection)

Contains Method (BookmarksCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Contains Method
Specifies the Bookmark object to be searched for in the collection.

Determines whether the specified bookmark object exists in the collection.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal value As Bookmark _
) As System.Boolean
public System.bool Contains(
   Bookmark value
)

Parameters

value
Specifies the Bookmark object to be searched for in the collection.

Return Value

Boolean. True, if the bookmark is a member of the collection; otherwise, False.

See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


CopyTo Method (BookmarksCollection)

CopyTo Method (BookmarksCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : CopyTo Method
The array containing the copied Bookmarks.
The insertion index in the collection.
Copies the Bookmarks collection from the specified report to a Bookmarks collection at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal values() As Bookmark, _
   ByVal index As System.Integer _
)
public void CopyTo(
   Bookmark[] values,
   System.int index
)

Parameters

values
The array containing the copied Bookmarks.
index
The insertion index in the collection.
See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Dispose Method (BookmarksCollection)

Dispose Method (BookmarksCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Dispose Method
Releases the BookmarksCollection instance from memory.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


FillTree Method

FillTree Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : FillTree Method
Specifies the TreeView control to be filled with the bookmark objects.
Loads the Bookmark objects into the Windows Forms TreeView control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub FillTree( _
   ByVal treeView As System.Windows.Forms.TreeView _
)
public void FillTree(
   System.Windows.Forms.TreeView treeView
)

Parameters

treeView
Specifies the TreeView control to be filled with the bookmark objects.
Remarks
You can use this method to fill any TreeView with the bookmarks collection and customize the look and feel of the Table of Contents.
Example
  • C#
private void frmViewer_Load(object sender, System.EventArgs e)
{
   arv.Document.Bookmarks.FillTree(treeView1);
}
  • Visual Basic
Private Sub frmViewer_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Load
    arv.Document.Bookmarks.FillTree(TreeView1)
End Sub
See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


IndexOf Method (BookmarksCollection)

IndexOf Method (BookmarksCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : IndexOf Method
Specifies the Bookmark object for which to search.
Returns the index of the specified Bookmark object in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As Bookmark _
) As System.Integer
public System.int IndexOf(
   Bookmark value
)

Parameters

value
Specifies the Bookmark object for which to search.

Return Value

An integer specifying the index of the specified Bookmark.
See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Insert Method (BookmarksCollection)

Insert Method (BookmarksCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Insert Method
Insertion index in the collection.
New Bookmark object to be inserted at the specified index.
Inserts the specified Bookmark object at the specified index in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As Bookmark _
)
public void Insert(
   System.int index,
   Bookmark value
)

Parameters

index
Insertion index in the collection.
value
New Bookmark object to be inserted at the specified index.
See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Remove Method (BookmarksCollection)

Remove Method (BookmarksCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Remove Method
Specifies the Bookmark object to be removed.
Removes the specified Bookmark object from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As Bookmark _
)
public void Remove(
   Bookmark value
)

Parameters

value
Specifies the Bookmark object to be removed.
See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


BookmarksCollection Class Properties

BookmarksCollection Class Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BookmarksCollection Class

For a list of all members of this type, see BookmarksCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of Bookmark objects in the collection. (Inherited from System.Collections.CollectionBase)
Public Property | CurrentBookmark | Returns the index of the currently selected bookmark.
Public Property | Item | Returns a reference to the bookmark object at the specified index.
Top
See Also

Reference

BookmarksCollection Class
GrapeCity.ActiveReports.Document.Section Namespace


CurrentBookmark Property

CurrentBookmark Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : CurrentBookmark Property
Returns the index of the currently selected bookmark.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CurrentBookmark As System.Integer
public System.int CurrentBookmark {get; set;}

Property Value

An integer value that represents the number of bookmark objects in the collection.
Example
  • C#
private void arv_TableOfContentsClick(object sender, System.EventArgs e)
{
    int toc;
    toc = arv.Document.Bookmarks.CurrentBookmark;
    MessageBox.Show ("You are leaving the bookmark at page " + arv.Document.Bookmarks[toc].PageNumber.ToString() + ", " + arv.Document.Bookmarks[toc].Offset.ToString() + " inches from the top of the page.");
}
  • Visual Basic
Private Sub arv_TableOfContentsClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles arv.TableOfContentsClick
    Dim toc As Integer
    toc = arv.Document.Bookmarks.CurrentBookmark
    MsgBox("You are leaving the bookmark at page " & arv.Document.Bookmarks(toc).PageNumber.ToString & ", " & arv.Document.Bookmarks(toc).Offset.ToString & " inches from the top of the page.")
End Sub
See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Item Property (BookmarksCollection)

Item Property (BookmarksCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Item Property
Index of the requested item.
Returns a reference to the bookmark object at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As Bookmark
public Bookmark this[
   System.int index
]; {get;}

Parameters

index
Index of the requested item.

Property Value

A Bookmark object at the specified index in the collection.
See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Margins Class

Margins Class
Members

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Margins Class
Used to specify the printed page margins.
Object Model
Margins Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Margins
public class Margins
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.Margins

See Also

Reference

Margins Members
GrapeCity.ActiveReports.Document.Section Namespace


Margins Class Members

Margins Class Members
Properties Methods Events

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Margins Class

The following tables list the members exposed by Margins.

Public Constructors
 | Name | Description
Public Constructor | Margins Constructor | Overloaded. Creates a new instance of the Margins class.
Top
Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the bottom margin of the page, in inches.
Public Property | Left | Gets or sets the left margin of the page, in inches.
Public Property | Right | Gets or sets the right margin of the page, in inches.
Public Property | Top | Gets or sets the top margin of the page, in inches.
Top
Public Methods
 | Name | Description
Public Method | Clone | Creates a clone of the Margins object.
Public Method | Equals | Determines whether the specified object is equal to the current object.
Top
Public Events
 | Name | Description
Public Event | Changed | Fires when the margins are changed.
Top
See Also

Reference

Margins Class
GrapeCity.ActiveReports.Document.Section Namespace


Margins Constructor

Margins Constructor

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : Margins Constructor
Creates a new instance of the Margins class.
Overload List
Overload | Description
Margins Constructor() | Creates a new instance of the Margins class.
Margins Constructor(Single,Single,Single,Single) | Initializes a new instance of the Margins class with the specified margins.
See Also

Reference

Margins Class
Margins Members


Margins Constructor()

Margins Constructor()

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class > Margins Constructor : Margins Constructor()
Creates a new instance of the Margins class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Margins()
See Also

Reference

Margins Class
Margins Members
Overload List


Margins Constructor(Single,Single,Single,Single)

Margins Constructor(Single,Single,Single,Single)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class > Margins Constructor : Margins Constructor(Single,Single,Single,Single)
Specifies the left margin, in inches.
Specifies the top margin, in inches.
Specifies the right margin, in inches.
Specifies the bottom margin, in inches.

Initializes a new instance of the Margins class with the specified margins.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal left As System.Single, _
   ByVal top As System.Single, _
   ByVal right As System.Single, _
   ByVal bottom As System.Single _
)
public Margins(
   System.float left,
   System.float top,
   System.float right,
   System.float bottom
)

Parameters

left
Specifies the left margin, in inches.
top
Specifies the top margin, in inches.
right
Specifies the right margin, in inches.
bottom
Specifies the bottom margin, in inches.
Exceptions
Exception | Description
System.ArgumentException | Left margin value must be greater than 0 or Top margin value must be greater than 0 or Right margin value must be greater than 0 or Bottom margin value must be greater than 0
See Also

Reference

Margins Class
Margins Members
Overload List


Margins Class Methods

Margins Class Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Margins Class

For a list of all members of this type, see Margins members.

Public Methods
 | Name | Description
Public Method | Clone | Creates a clone of the Margins object.
Public Method | Equals | Determines whether the specified object is equal to the current object.
Top
See Also

Reference

Margins Class
GrapeCity.ActiveReports.Document.Section Namespace


Clone Method (Margins)

Clone Method (Margins)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : Clone Method
Creates a clone of the Margins object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Clone() As System.Object
public System.object Clone()

Return Value

A new object that is a copy of this instance.
See Also

Reference

Margins Class
Margins Members


Equals Method (Margins)

Equals Method (Margins)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : Equals Method
The object to compare with the current object.
Determines whether the specified object is equal to the current object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The object to compare with the current object.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.
See Also

Reference

Margins Class
Margins Members


Margins Class Properties

Margins Class Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Margins Class

For a list of all members of this type, see Margins members.

Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the bottom margin of the page, in inches.
Public Property | Left | Gets or sets the left margin of the page, in inches.
Public Property | Right | Gets or sets the right margin of the page, in inches.
Public Property | Top | Gets or sets the top margin of the page, in inches.
Top
See Also

Reference

Margins Class
GrapeCity.ActiveReports.Document.Section Namespace


Bottom Property (Margins)

Bottom Property (Margins)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : Bottom Property
Gets or sets the bottom margin of the page, in inches.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Bottom As System.Single
public System.float Bottom {get; set;}

Property Value

float value that represents the bottom margin in inches.
See Also

Reference

Margins Class
Margins Members


Left Property (Margins)

Left Property (Margins)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : Left Property
Gets or sets the left margin of the page, in inches.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Left As System.Single
public System.float Left {get; set;}

Property Value

float value that represents the left margin in inches.
See Also

Reference

Margins Class
Margins Members


Right Property (Margins)

Right Property (Margins)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : Right Property
Gets or sets the right margin of the page, in inches.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Right As System.Single
public System.float Right {get; set;}

Property Value

float value that represents the right margin in inches.
See Also

Reference

Margins Class
Margins Members


Top Property (Margins)

Top Property (Margins)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : Top Property
Gets or sets the top margin of the page, in inches.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Top As System.Single
public System.float Top {get; set;}

Property Value

float value that represents the top margin in inches.
See Also

Reference

Margins Class
Margins Members


Margins Class Events

Margins Class Events

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Margins Class

For a list of all members of this type, see Margins members.

Public Events
 | Name | Description
Public Event | Changed | Fires when the margins are changed.
Top
See Also

Reference

Margins Class
GrapeCity.ActiveReports.Document.Section Namespace


Changed Event (Margins)

Changed Event (Margins)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Margins Class : Changed Event
Fires when the margins are changed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Changed As System.EventHandler
public event System.EventHandler Changed
See Also

Reference

Margins Class
Margins Members


Page Class

Page Class
Members

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Page Class
Represents a printed page in the report document.
Object Model
Page Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Page
public class Page
Remarks

The Page class provides primitive drawing methods that you can use to create content on the page in the PageStart or PageEnd events or after the report has completed execution.

Drawing to the page in the PageStart event renders behind the report's page content, while drawing in the PageEnd event renders in the foreground on top of the report content.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.Page

See Also

Reference

Page Members
GrapeCity.ActiveReports.Document.Section Namespace


Page Class Members

Page Class Members
Properties Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Page Class

The following tables list the members exposed by Page.

Public Constructors
 | Name | Description
Public Constructor | Page Constructor | Initializes a new instance of the Page class.
Top
Public Properties
 | Name | Description
Public Property | Annotations | Gets or sets the annotations associated with the page.
Public Property | BackColor | Specifies the background color used to render shapes and text to the page.
Public Property | Bookmarks | Returns a list of the page's bookmarks.
Public Property | CanvasItems | Returns a list of the page's canvas items.
Public Property | CharacterSpacing | Gets or sets the CharacterSpacing value in inches for the page.
Public Property | Compress | Sets or returns a value indicating whether the page is compressed.
Public Property | Font | Gets or sets the current font used to draw text on the page.
Public Property | Fonts | Returns the collection of fonts for the page.
Public Property | ForeColor | Gets or sets the current foreground color used to draw text and shapes on the page.
Public Property | Height | Gets or sets the height of the page in inches.
Public Property | Identifier | Gets unique page identifier (used in PagesCollection to track swapped out pages)
Public Property | LineSpacing | Gets or sets the LineSpacing value in inches for the page.
Public Property | Margins | Gets a reference to the page margins settings.
Public Property | Orientation | Gets or sets the orientation of the page.
Public Property | Padding | Gets or sets the amount of padding to use around the text inside a control.
Public Property | PenStyle | Gets or sets the line style used to draw lines and shapes.
Public Property | PenWidth | Gets or sets the width of the pen used to draw lines and shapes. (1/2 point).
Public Property | RightToLeft | Determines whether DrawText should render text RightToLeft.
Public Property | Size | Returns a SizeF structure with the height and width of the page, in inches.
Public Property | TextAlignment | Determines the text alignment when using the DrawText method.
Public Property | TextAngle | Gets or sets the angle of text used to draw text.
Public Property | TextJustify | Gets or sets the type of justification to use when the TextAlignment property is set to Justify.
Public Property | TextRenderHint | Specifies the quality of rendering.
Public Property | Units | Gets or sets the units used with the page primitive drawing methods.
Public Property | VerticalText | Sets or returns a value indicating whether to draw text vertically when using the DrawText method.
Public Property | VerticalTextAlignment | Determines the vertical text alignment when using the DrawText method.
Public Property | Width | Gets or sets the width of the page (in inches).
Public Property | WordWrap | Gets or sets a value determining whether word wrapping occurs.
Public Property | WrapMode | Gets or sets the wrap mode for rendering text.
Top
Public Methods
 | Name | Description
Public Method | AddBookmark | Summary description for AddBookmark.
Public Method | Clear | Clears all items from all pages.
Public Method | ClearCanvasItems | Clears all CanvasItems from the page.
Public Method | Clone | Creates a clone of the Page object.
Public Method | Dispose | Releases the Page instance from memory.
Public Method | Draw | Renders the page's content to the specified Graphics object at the specified coordinates.
Public Method | DrawBorder | Overloaded. Paints the specified border at the specified coordinates.
Public Method | DrawEllipse | Draws an ellipse on the page.
Public Method | DrawImage | Overloaded. Draws an image on the page.
Public Method | DrawLine | Draws a line on the page at the specified coordinates.
Public Method | DrawRect | Overloaded. Draws a rectangular shape on the page at the specified coordinates.
Public Method | DrawRoundRect | Overloaded. Draws a rounded rectangle on the page at the specified coordinates.
Public Method | DrawText | Overloaded. Draws text on the page.
Public Method | FillRect | Overloaded. Fills the specified area with the current page BackColor.
Public Method | Load | Overloaded. Loads page content from a reader or a file.
Public Method | MeasureParagraphHeight | Overloaded. Measures the height of the specified text if rendered using the current page settings with the specified width.
Public Method | MeasureText | Overloaded. Determines the width and height of text string.
Public Method | Overlay | Overlays the specified page object on top of the Page.
Public Method | Save | Overloaded. Saves page content.
Public Method | ToString | Renders the page's settings and content to a string.
Top
See Also

Reference

Page Class
GrapeCity.ActiveReports.Document.Section Namespace


Page Constructor

Page Constructor

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Page Constructor
Initializes a new instance of the Page class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Page()
See Also

Reference

Page Class
Page Members


Page Class Methods

Page Class Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Page Class

For a list of all members of this type, see Page members.

Public Methods
 | Name | Description
Public Method | AddBookmark | Summary description for AddBookmark.
Public Method | Clear | Clears all items from all pages.
Public Method | ClearCanvasItems | Clears all CanvasItems from the page.
Public Method | Clone | Creates a clone of the Page object.
Public Method | Dispose | Releases the Page instance from memory.
Public Method | Draw | Renders the page's content to the specified Graphics object at the specified coordinates.
Public Method | DrawBorder | Overloaded. Paints the specified border at the specified coordinates.
Public Method | DrawEllipse | Draws an ellipse on the page.
Public Method | DrawImage | Overloaded. Draws an image on the page.
Public Method | DrawLine | Draws a line on the page at the specified coordinates.
Public Method | DrawRect | Overloaded. Draws a rectangular shape on the page at the specified coordinates.
Public Method | DrawRoundRect | Overloaded. Draws a rounded rectangle on the page at the specified coordinates.
Public Method | DrawText | Overloaded. Draws text on the page.
Public Method | FillRect | Overloaded. Fills the specified area with the current page BackColor.
Public Method | Load | Overloaded. Loads page content from a reader or a file.
Public Method | MeasureParagraphHeight | Overloaded. Measures the height of the specified text if rendered using the current page settings with the specified width.
Public Method | MeasureText | Overloaded. Determines the width and height of text string.
Public Method | Overlay | Overlays the specified page object on top of the Page.
Public Method | Save | Overloaded. Saves page content.
Public Method | ToString | Renders the page's settings and content to a string.
Top
See Also

Reference

Page Class
GrapeCity.ActiveReports.Document.Section Namespace


AddBookmark(String,Single) Method

AddBookmark(String,Single) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : AddBookmark(String,Single) Method
Specifies the name of the bookmark. You can use backslash "\" as a path separator to create a hierarchy of bookmarks.
Specifies the location of the bookmark on the page.
Summary description for AddBookmark.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function AddBookmark( _
   ByVal strBookmark As System.String, _
   ByVal offset As System.Single _
) As System.Integer
public System.int AddBookmark(
   System.string strBookmark,
   System.float offset
)

Parameters

strBookmark
Specifies the name of the bookmark. You can use backslash "\" as a path separator to create a hierarchy of bookmarks.
offset
Specifies the location of the bookmark on the page.
Example
  • C#
private void SectionReport1_ReportEnd(object sender, System.EventArgs eArgs)
{
    for(int i = 0; i<Document.Pages.Count;i++)
    {
        this.Document.Pages[i].AddBookmark("New Bookmark", 25);
    }
}
  • Visual Basic
Private Sub SectionReport1_ReportEnd(ByVal sender As Object, ByVal e As System.EventArgs) Handles SectionReport1.ReportEnd
    Dim i As Integer
    Try
        For i = 0 To Me.Document.Pages.Count - 1
            Me.Document.Pages(i).AddBookmark("New Bookmark", 8)
        Next
    Catch ex As Exception
    End Try
End Sub
See Also

Reference

Page Class
Page Members


Clear Method (Page)

Clear Method (Page)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Clear Method
Clears all items from all pages.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;
    arv.Document.Pages[0].DrawLine(1, 1, 4, 4);
    arv.Document.Pages[0].Clear();
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .DrawLine(1, 1, 4, 4)
    End With
    arv.Document.Pages(0).Clear();
End Sub
See Also

Reference

Page Class
Page Members


ClearCanvasItems Method

ClearCanvasItems Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : ClearCanvasItems Method
Clears all CanvasItems from the page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ClearCanvasItems()
public void ClearCanvasItems()
Remarks
This property works correctly only if the Document's CacheToDisk property is set to False.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;
    arv.Document.Pages[0].DrawLine(1, 1, 4, 4);
    arv.Document.Pages[0].ClearCanvasItems();
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .DrawLine(1, 1, 4, 4)
    End With
    arv.Document.Pages(0).ClearCanvasItems()
End Sub
See Also

Reference

Page Class
Page Members
CacheToDisk Property


Clone Method (Page)

Clone Method (Page)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Clone Method
Creates a clone of the Page object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Clone() As System.Object
public System.object Clone()

Return Value

A new object that is a copy of this instance.
See Also

Reference

Page Class
Page Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Dispose() Method
Releases the Page instance from memory.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Page Class
Page Members


Draw(Graphics,RectangleF) Method

Draw(Graphics,RectangleF) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > Draw Method : Draw(Graphics,RectangleF) Method
Graphics object to render on the page.
System.Drawing.RectangleF coordinates to which to draw the page.
Renders the page's content to the specified Graphics object at the specified coordinates.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Draw( _
   ByVal graphics As Graphics, _
   ByVal bounds As RectangleF _
)
public void Draw(
   Graphics graphics,
   RectangleF bounds
)

Parameters

graphics
Graphics object to render on the page.
bounds
System.Drawing.RectangleF coordinates to which to draw the page.
Example
  • C#
private void arScale()
{
    aPage = new GrapeCity.ActiveReports.Document.Page();
    GrapeCity.ActiveReports.Interop.SystemPrinter m_myARPrinter = new GrapeCity.
        ActiveReports.Interop.SystemPrinter();
    m_myARPrinter.StartJob("Test Printer");
    System.Drawing.RectangleF rec;
    float xOffSet = m_myARPrinter.PhysicalOffsetX/m_myARPrinter.Graphics.DpiX;
    float yOffSet = m_myARPrinter.PhysicalOffsetY/m_myARPrinter.Graphics.DpiY;
    float adjustedWidth = (aPage.Width/3)-(xOffSet*2);
    float xPos = 0;
    int nCount = rpt.Document.Pages.Count;
    m_myARPrinter.StartPage();
    For(int i=0; i < nCount; i++)
    {
        aPage = rpt.Document.Pages[i];
        m_myARPrinter.Graphics.PageUnit = System.Drawing.GraphicsUnit.Pixel;
        rec = System.Drawing.RectangleF.FromLTRB(xOffSet+xPos, yOffSet,(xOffSet+xPos)+
            adjustedWidth,yOffSet+adjustedWidth);
        xPos = adjustedWidth + xPos;
        aPage.Draw(m_myARPrinter.Graphics,rec);
    }
    m_myARPrinter.EndPage();
    m_myARPrinter.EndJob();
}
  • Visual Basic
Private Sub arScale()
    m_myARPrinter.StartJob("Test Printer")
    Dim aPage As New GrapeCity.ActiveReports.Document.Page()
    Dim rec As New System.Drawing.RectangleF()
    Dim xOffSet As Single
    Dim yOffSet As Single
    Dim adjustedWidth As Single
    Dim xPos As Single
    xOffSet = m_myARPrinter.PhysicalOffsetX / m_myARPrinter.Graphics.DpiX
    yOffSet = m_myARPrinter.PhysicalOffsetY / m_myARPrinter.Graphics.DpiY
    adjustedWidth = (aPage.Width / 3) - (xOffSet / 2)
    xPos = 0
    Dim nCount As Integer
    nCount = rpt.Document.Pages.Count
    m_myARPrinter.StartPage()
    For i = 0 To nCount - 1
        aPage = rpt.Document.Pages(i)
        m_myARPrinter.Graphics.PageUnit = GraphicsUnit.Pixel
        rec = System.Drawing.RectangleF.FromLTRB(xOffSet + xPos, yOffSet, (xOffSet + xPos) + _
            adjustedWidth, yOffSet + adjustedWidth)
        xPos = adjustedWidth + xPos
        aPage.Draw(m_myARPrinter.Graphics, rec)
    Next
    m_myARPrinter.EndPage()
    m_myARPrinter.EndJob()
End Sub
See Also

Reference

Page Class
Page Members
Overload List


DrawBorder Method

DrawBorder Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawBorder Method
Paints the specified border at the specified coordinates.
Overload List
Overload | Description
DrawBorder(Border,Single,Single,Single,Single) | Paints the specified border at the specified coordinates.
DrawBorder(Border,RectangleF) | Paints the specified border with the specified boundaries.
Remarks
Units are determined by the Page.Units property.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    GrapeCity.ActiveReports.Border b = new GrapeCity.ActiveReports.Border();
    b.BottomColor = System.Drawing.Color.Red;
    b.BottomStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid;
    b.LeftColor = System.Drawing.Color.Red;
    b.LeftStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid;
    b.RightColor = System.Drawing.Color.Red;
    b.RightStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid;
    b.TopColor = System.Drawing.Color.Red;
    b.TopStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid;

    arv.Document.Pages[0].DrawBorder(b, 1, 1, 4, 4);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim b As New GrapeCity.ActiveReports.Border
    b.BottomColor = System.Drawing.Color.Red
    b.BottomStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid
    b.LeftColor = System.Drawing.Color.Red
    b.LeftStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid
    b.RightColor = System.Drawing.Color.Red
    b.RightStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid
    b.TopColor = System.Drawing.Color.Red
    b.TopStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid

    arv.Document.Pages(0).DrawBorder(b, 1, 1, 4, 4)
End Sub
See Also

Reference

Page Class
Page Members


DrawBorder(Border,Single,Single,Single,Single) Method

DrawBorder(Border,Single,Single,Single,Single) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawBorder Method : DrawBorder(Border,Single,Single,Single,Single) Method
Border object to render on the page.
Left position of the border (in inches).
Top position of the border (in inches).
Width of the border (in inches).
Height of the border (in inches).
Paints the specified border at the specified coordinates.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DrawBorder( _
   ByVal border As Border, _
   ByVal left As System.Single, _
   ByVal top As System.Single, _
   ByVal width As System.Single, _
   ByVal height As System.Single _
)
public void DrawBorder(
   Border border,
   System.float left,
   System.float top,
   System.float width,
   System.float height
)

Parameters

border
Border object to render on the page.
left
Left position of the border (in inches).
top
Top position of the border (in inches).
width
Width of the border (in inches).
height
Height of the border (in inches).
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    GrapeCity.ActiveReports.Border b = new GrapeCity.ActiveReports.Border();
    b.BottomColor = System.Drawing.Color.Red;
    b.BottomStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid;
    b.LeftColor = System.Drawing.Color.Red;
    b.LeftStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid;
    b.RightColor = System.Drawing.Color.Red;
    b.RightStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid;
    b.TopColor = System.Drawing.Color.Red;
    b.TopStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid;

    arv.Document.Pages[0].DrawBorder(b, 1, 1, 4, 4);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim b As New GrapeCity.ActiveReports.Border
    b.BottomColor = System.Drawing.Color.Red
    b.BottomStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid
    b.LeftColor = System.Drawing.Color.Red
    b.LeftStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid
    b.RightColor = System.Drawing.Color.Red
    b.RightStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid
    b.TopColor = System.Drawing.Color.Red
    b.TopStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid

    arv.Document.Pages(0).DrawBorder(b, 1, 1, 4, 4)
End Sub
See Also

Reference

Page Class
Page Members
Overload List


DrawBorder(Border,RectangleF) Method

DrawBorder(Border,RectangleF) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawBorder Method : DrawBorder(Border,RectangleF) Method
Border object to render on the page.
System.Drawing.RectangleF coordinates to which to draw the border.
Paints the specified border with the specified boundaries.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DrawBorder( _
   ByVal border As Border, _
   ByVal bounds As RectangleF _
)
public void DrawBorder(
   Border border,
   RectangleF bounds
)

Parameters

border
Border object to render on the page.
bounds
System.Drawing.RectangleF coordinates to which to draw the border.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    GrapeCity.ActiveReports.Border b = new GrapeCity.ActiveReports.Border();
    b.BottomColor = System.Drawing.Color.Red;
    b.BottomStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid;
    b.LeftColor = System.Drawing.Color.Red;
    b.LeftStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid;
    b.RightColor = System.Drawing.Color.Red;
    b.RightStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid;
    b.TopColor = System.Drawing.Color.Red;
    b.TopStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 2.0F;
    Single height = 2.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawBorder(b, drawRect);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim b As New GrapeCity.ActiveReports.Border
    b.BottomColor = System.Drawing.Color.Red
    b.BottomStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid
    b.LeftColor = System.Drawing.Color.Red
    b.LeftStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid
    b.RightColor = System.Drawing.Color.Red
    b.RightStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid
    b.TopColor = System.Drawing.Color.Red
    b.TopStyle = GrapeCity.ActiveReports.BorderLineStyle.ExtraThickSolid

    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 2.0F
    Dim height As Single = 2.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    arv.Document.Pages(0).DrawBorder(b, drawRect)
End Sub
See Also

Reference

Page Class
Page Members
Overload List


DrawEllipse Method (Page)

DrawEllipse Method (Page)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawEllipse Method
Left position of the ellipse (in inches).
Top position of the ellipse (in inches).
Width of the ellipse (in inches)
Height of the ellipse (in inches).
Draws an ellipse on the page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub DrawEllipse( _
   ByVal left As System.Single, _
   ByVal top As System.Single, _
   ByVal width As System.Single, _
   ByVal height As System.Single _
)
public void DrawEllipse(
   System.float left,
   System.float top,
   System.float width,
   System.float height
)

Parameters

left
Left position of the ellipse (in inches).
top
Top position of the ellipse (in inches).
width
Width of the ellipse (in inches)
height
Height of the ellipse (in inches).
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;
    arv.Document.Pages[0].DrawEllipse(2, 2, 4, 8);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .DrawEllipse(2, 2, 4, 8)
    End With
End Sub
See Also

Reference

Page Class
Page Members


DrawImage Method (Page)

DrawImage Method (Page)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawImage Method
Draws an image on the page.
Overload List
Overload | Description
DrawImage(Image,Single,Single,Single,Single) | Draws the specified image within the specified coordinates.
DrawImage(Image,Single,Single,Single,Single,String,String) | Draws the specified image within the specified coordinates.
DrawImage(Image,RectangleF) | Draws the specified image within the specified rectangle bounds.
DrawImage(Image,Single,Single,Single,Single,String) | Draws the specified image on the page at the specified coordinates and assigns a hyperlink to the image area.
DrawImage(Image,Single,Single,Single,Single,String,String,String) | Draws the specified image on the page at the specified coordinates and assigns a hyperlink to the image area.
DrawImage(Image,RectangleF,String) | Draws the specified image within the specified rectangle bounds and assigns a hyperlink to the area on the page.
DrawImage(Image,Boolean,RectangleF,String) | Draws the specified image within the specified rectangle bounds and assigns a hyperlink to the area on the page.
Remarks
Units are determined by the Page.Units property.
See Also

Reference

Page Class
Page Members


DrawImage(Image,Single,Single,Single,Single) Method

DrawImage(Image,Single,Single,Single,Single) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawImage Method : DrawImage(Image,Single,Single,Single,Single) Method
The System.Drawing.Image to draw on the page.
Left position of the image (in inches).

Top position of the image (in inches).

Width of the image (in inches).
Height of the image (in inches).
Draws the specified image within the specified coordinates.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal left As System.Single, _
   ByVal top As System.Single, _
   ByVal width As System.Single, _
   ByVal height As System.Single _
)
public void DrawImage(
   Image image,
   System.float left,
   System.float top,
   System.float width,
   System.float height
)

Parameters

image
The System.Drawing.Image to draw on the page.
left
Left position of the image (in inches).
top

Top position of the image (in inches).

width
Width of the image (in inches).
height
Height of the image (in inches).
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].DrawImage(System.Drawing.Image.FromFile("c:\\logo.gif"), 1, 1, 1, 1);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    arv.Document.Pages(0).DrawImage(System.Drawing.Image.FromFile("c:\logo.gif"), 1, 1, 1, 1)
End Sub
See Also

Reference

Page Class
Page Members
Overload List


DrawImage(Image,Single,Single,Single,Single,String,String) Method

DrawImage(Image,Single,Single,Single,Single,String,String) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawImage Method : DrawImage(Image,Single,Single,Single,Single,String,String) Method
The System.Drawing.Image to draw on the page.
Left position of the image (in inches).

Top position of the image (in inches).

Width of the image (in inches).
Height of the image (in inches).
Title of the image.
Description of the image.
Draws the specified image within the specified coordinates.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal left As System.Single, _
   ByVal top As System.Single, _
   ByVal width As System.Single, _
   ByVal height As System.Single, _
   ByVal title As System.String, _
   ByVal description As System.String _
)
public void DrawImage(
   Image image,
   System.float left,
   System.float top,
   System.float width,
   System.float height,
   System.string title,
   System.string description
)

Parameters

image
The System.Drawing.Image to draw on the page.
left
Left position of the image (in inches).
top

Top position of the image (in inches).

width
Width of the image (in inches).
height
Height of the image (in inches).
title
Title of the image.
description
Description of the image.
See Also

Reference

Page Class
Page Members
Overload List


DrawImage(Image,RectangleF) Method

DrawImage(Image,RectangleF) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawImage Method : DrawImage(Image,RectangleF) Method
The System.Drawing.Image to draw on the page.
RectangleF structure that specifies the location and size of the drawn image.
Draws the specified image within the specified rectangle bounds.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal bounds As RectangleF _
)
public void DrawImage(
   Image image,
   RectangleF bounds
)

Parameters

image
The System.Drawing.Image to draw on the page.
bounds
RectangleF structure that specifies the location and size of the drawn image.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 2.0F;
    Single height = 2.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);
    arv.Document.Pages[0].DrawImage(System.Drawing.Image.FromFile("c:\\logo.gif"), drawRect);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 2.0F
    Dim height As Single = 2.0F
    Dim drawRect As New RectangleF(x, y, width, height)
    arv.Document.Pages(0).DrawImage(System.Drawing.Image.FromFile("c:\logo.gif"), drawRect)
End Sub
See Also

Reference

Page Class
Page Members
Overload List


DrawImage(Image,Single,Single,Single,Single,String) Method

DrawImage(Image,Single,Single,Single,Single,String) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawImage Method : DrawImage(Image,Single,Single,Single,Single,String) Method
The System.Drawing.Image to draw on the page.
Left position of the image (in inches).

Top position of the image (in inches).

Width of the image (in inches).
Height of the image (in inches).
Hyperlink URL.
Draws the specified image on the page at the specified coordinates and assigns a hyperlink to the image area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal left As System.Single, _
   ByVal top As System.Single, _
   ByVal width As System.Single, _
   ByVal height As System.Single, _
   ByVal strLink As System.String _
)
public void DrawImage(
   Image image,
   System.float left,
   System.float top,
   System.float width,
   System.float height,
   System.string strLink
)

Parameters

image
The System.Drawing.Image to draw on the page.
left
Left position of the image (in inches).
top

Top position of the image (in inches).

width
Width of the image (in inches).
height
Height of the image (in inches).
strLink
Hyperlink URL.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].DrawImage(System.Drawing.Image.FromFile("c:\\logo.gif"), 1, 1, 1, 1, "www.grapecity.com");
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    arv.Document.Pages(0).DrawImage(System.Drawing.Image.FromFile("c:\logo.gif"), 1, 1, 1, 1, "www.grapecity.com")
End Sub
See Also

Reference

Page Class
Page Members
Overload List


DrawImage(Image,Single,Single,Single,Single,String,String,String) Method

DrawImage(Image,Single,Single,Single,Single,String,String,String) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawImage Method : DrawImage(Image,Single,Single,Single,Single,String,String,String) Method
The System.Drawing.Image to draw on the page.
Left position of the image (in inches).

Top position of the image (in inches).

Width of the image (in inches).
Height of the image (in inches).
Hyperlink URL.
Title of the image.
Description of the image.
Draws the specified image on the page at the specified coordinates and assigns a hyperlink to the image area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal left As System.Single, _
   ByVal top As System.Single, _
   ByVal width As System.Single, _
   ByVal height As System.Single, _
   ByVal strLink As System.String, _
   ByVal title As System.String, _
   ByVal description As System.String _
)
public void DrawImage(
   Image image,
   System.float left,
   System.float top,
   System.float width,
   System.float height,
   System.string strLink,
   System.string title,
   System.string description
)

Parameters

image
The System.Drawing.Image to draw on the page.
left
Left position of the image (in inches).
top

Top position of the image (in inches).

width
Width of the image (in inches).
height
Height of the image (in inches).
strLink
Hyperlink URL.
title
Title of the image.
description
Description of the image.
See Also

Reference

Page Class
Page Members
Overload List


DrawImage(Image,RectangleF,String) Method

DrawImage(Image,RectangleF,String) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawImage Method : DrawImage(Image,RectangleF,String) Method
The System.Drawing.Image to draw on the page.
RectangleF structure that specifies the location and size of the drawn image.
Hyperlink URL.
Draws the specified image within the specified rectangle bounds and assigns a hyperlink to the area on the page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal bounds As RectangleF, _
   ByVal strLink As System.String _
)
public void DrawImage(
   Image image,
   RectangleF bounds,
   System.string strLink
)

Parameters

image
The System.Drawing.Image to draw on the page.
bounds
RectangleF structure that specifies the location and size of the drawn image.
strLink
Hyperlink URL.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 2.0F;
    Single height = 2.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);
    arv.Document.Pages[0].DrawImage(System.Drawing.Image.FromFile("c:\\logo.gif"), drawRect, "www.grapecity.com");
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 2.0F
    Dim height As Single = 2.0F
    Dim drawRect As New RectangleF(x, y, width, height)
    arv.Document.Pages(0).DrawImage(System.Drawing.Image.FromFile("c:\logo.gif"), drawRect, "www.grapecity.com")
End Sub
See Also

Reference

Page Class
Page Members
Overload List


DrawImage(Image,Boolean,RectangleF,String) Method

DrawImage(Image,Boolean,RectangleF,String) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawImage Method : DrawImage(Image,Boolean,RectangleF,String) Method
The System.Drawing.Image to draw on the page.
Boolean value determining whether the image has changed.
Bounds of the image.
Hyperlink URL.
Draws the specified image within the specified rectangle bounds and assigns a hyperlink to the area on the page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DrawImage( _
   ByVal image As Image, _
   ByVal imageChanged As System.Boolean, _
   ByVal text As RectangleF, _
   ByVal strLink As System.String _
)
public void DrawImage(
   Image image,
   System.bool imageChanged,
   RectangleF text,
   System.string strLink
)

Parameters

image
The System.Drawing.Image to draw on the page.
imageChanged
Boolean value determining whether the image has changed.
text
Bounds of the image.
strLink
Hyperlink URL.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 2.0F;
    Single height = 2.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);
    arv.Document.Pages[0].DrawImage(System.Drawing.Image.FromFile("c:\\logo.gif"), true, drawRect, "www.grapecity.com");
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 2.0F
    Dim height As Single = 2.0F
    Dim drawRect As New RectangleF(x, y, width, height)
    arv.Document.Pages(0).DrawImage(System.Drawing.Image.FromFile("c:\logo.gif"), True, drawRect, "www.grapecity.com")
End Sub
See Also

Reference

Page Class
Page Members
Overload List


DrawLine Method (Page)

DrawLine Method (Page)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawLine Method

Starting horizontal position of the line (in inches).

Starting vertical position of the line (in inches).

Ending horizontal position of the line (in inches).

Starting vertical position of the line (in inches).
Draws a line on the page at the specified coordinates.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub DrawLine( _
   ByVal x1 As System.Single, _
   ByVal y1 As System.Single, _
   ByVal x2 As System.Single, _
   ByVal y2 As System.Single _
)
public void DrawLine(
   System.float x1,
   System.float y1,
   System.float x2,
   System.float y2
)

Parameters

x1

Starting horizontal position of the line (in inches).

y1
Starting vertical position of the line (in inches).
x2

Ending horizontal position of the line (in inches).

y2
Starting vertical position of the line (in inches).
Remarks

Uses PenStyle and PenWidth to draw the line.

Units are determined by the Page.Units property.

Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;
    arv.Document.Pages[0].DrawLine(1, 1, 4, 4);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .DrawLine(1, 1, 4, 4)
    End With
End Sub
See Also

Reference

Page Class
Page Members
PenStyle Property
PenWidth Property


DrawRect Method

DrawRect Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawRect Method
Draws a rectangular shape on the page at the specified coordinates.
Overload List
Overload | Description
DrawRect(Single,Single,Single,Single) | Draws a rectangular shape on the page at the specified coordinates.
DrawRect(RectangleF) | Draws a rectangular shape on the page at the specified rectangle bounds.
Remarks

Uses PenStyle, PenWidth and BackColor to draw the rectangle.

Units are determined by the Page.Units property.

Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;
    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 2.0F;
    Single height = 2.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);
    arv.Document.Pages[0].DrawRect(drawRect);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 2.0F
    Dim height As Single = 2.0F
    Dim drawRect As New RectangleF(x, y, width, height)
    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .DrawRect(drawRect)
    End With
End Sub
See Also

Reference

Page Class
Page Members


DrawRect(Single,Single,Single,Single) Method

DrawRect(Single,Single,Single,Single) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawRect Method : DrawRect(Single,Single,Single,Single) Method
Left position of the rectangle (in inches).

Top position of the rectangle (in inches).

Width of the rectangle (in inches).
Height of the rectangle (in inches).
Draws a rectangular shape on the page at the specified coordinates.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DrawRect( _
   ByVal left As System.Single, _
   ByVal top As System.Single, _
   ByVal width As System.Single, _
   ByVal height As System.Single _
)
public void DrawRect(
   System.float left,
   System.float top,
   System.float width,
   System.float height
)

Parameters

left
Left position of the rectangle (in inches).
top

Top position of the rectangle (in inches).

width
Width of the rectangle (in inches).
height
Height of the rectangle (in inches).
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;
    arv.Document.Pages[0].DrawRect(1,1,3,5);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .DrawRect(1, 1, 3, 5)
    End With
End Sub
See Also

Reference

Page Class
Page Members
Overload List


DrawRect(RectangleF) Method

DrawRect(RectangleF) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawRect Method : DrawRect(RectangleF) Method
Bounds of the rectangle.
Draws a rectangular shape on the page at the specified rectangle bounds.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DrawRect( _
   ByVal rc As RectangleF _
)
public void DrawRect(
   RectangleF rc
)

Parameters

rc
Bounds of the rectangle.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;
    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 2.0F;
    Single height = 2.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);
    arv.Document.Pages[0].DrawRect(drawRect);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 2.0F
    Dim height As Single = 2.0F
    Dim drawRect As New RectangleF(x, y, width, height)
    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .DrawRect(drawRect)
    End With
End Sub
See Also

Reference

Page Class
Page Members
Overload List


DrawRoundRect Method

DrawRoundRect Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawRoundRect Method
Draws a rounded rectangle on the page at the specified coordinates.
Overload List
Overload | Description
DrawRoundRect(Single,Single,Single,Single,Single,Single) | Draws the round rect.
DrawRoundRect(Single,Single,Single,Single,Single,Single,Single,Single,Single) | Renders rounded rect with different corner radiuses.
Remarks

Uses PenStyle, PenWidth and BackColor to draw the rectangle.

Units are determined by the Page.Units property.

Example
  • C#
Private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = New rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;
    arv.Document.Pages[0].DrawRoundRect(1, 1, 3, 2, 1, 1);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .DrawRoundRect(1, 1, 3, 2, 1, 1)
    End With
End Sub
See Also

Reference

Page Class
Page Members


DrawRoundRect(Single,Single,Single,Single,Single,Single) Method

DrawRoundRect(Single,Single,Single,Single,Single,Single) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawRoundRect Method : DrawRoundRect(Single,Single,Single,Single,Single,Single) Method
The left.
The top.
The width.
The height.
Width of the edge.
Height of the edge.
Draws the round rect.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DrawRoundRect( _
   ByVal left As System.Single, _
   ByVal top As System.Single, _
   ByVal width As System.Single, _
   ByVal height As System.Single, _
   ByVal edgeWidth As System.Single, _
   ByVal edgeHeight As System.Single _
)
public void DrawRoundRect(
   System.float left,
   System.float top,
   System.float width,
   System.float height,
   System.float edgeWidth,
   System.float edgeHeight
)

Parameters

left
The left.
top
The top.
width
The width.
height
The height.
edgeWidth
Width of the edge.
edgeHeight
Height of the edge.
See Also

Reference

Page Class
Page Members
Overload List


DrawRoundRect(Single,Single,Single,Single,Single,Single,Single,Single,Single) Method

DrawRoundRect(Single,Single,Single,Single,Single,Single,Single,Single,Single) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawRoundRect Method : DrawRoundRect(Single,Single,Single,Single,Single,Single,Single,Single,Single) Method
Parameter to specify when we should fail back to old round rect with equals corners
Renders rounded rect with different corner radiuses.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DrawRoundRect( _
   ByVal left As System.Single, _
   ByVal top As System.Single, _
   ByVal width As System.Single, _
   ByVal height As System.Single, _
   ByVal topLeftEdge As System.Single, _
   ByVal topRightEdge As System.Single, _
   ByVal bottomLeftEdge As System.Single, _
   ByVal bottomRightEdge As System.Single, _
   ByVal precision As System.Single _
)
public void DrawRoundRect(
   System.float left,
   System.float top,
   System.float width,
   System.float height,
   System.float topLeftEdge,
   System.float topRightEdge,
   System.float bottomLeftEdge,
   System.float bottomRightEdge,
   System.float precision
)

Parameters

left
top
width
height
topLeftEdge
topRightEdge
bottomLeftEdge
bottomRightEdge
precision
Parameter to specify when we should fail back to old round rect with equals corners
See Also

Reference

Page Class
Page Members
Overload List


DrawText Method

DrawText Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : DrawText Method

Draws text on the page.

Overload List
Overload | Description
DrawText(String,Single,Single,Single,Single) | Draws the specified string within the specified coordinates.
DrawText(String,RectangleF) | Draws the specified string within the specified bounds.
DrawText(String[],Single,Single,Single,Single) | Draws the specified array of strings within the specified coordinates.
DrawText(String[],RectangleF) | Draws the specified array of strings within the specified bounds.
DrawText(String,Single,Single,Single,Single,String) | Draws the specified string within the specified coordinates and creates a hyperlink for the text area.
DrawText(String,RectangleF,String) | Draws the specified string within the specified bounds and creates a hyperlink at the specified area.
DrawText(String[],Single,Single,Single,Single,String) | Draws the specified array of strings within the specified coordinates and creates a hyperlink for the text area.
DrawText(String[],RectangleF,String) | Draws the specified array of strings within the specified bounds and creates a hyperlink at the specified area.
Remarks

Units are determined by the Page.Units property.

Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText("Confidential", drawRect);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", drawRect)
    End With
End Sub
See Also

Reference

Page Class
Page Members


DrawText(String,Single,Single,Single,Single) Method

DrawText(String,Single,Single,Single,Single) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawText Method : DrawText(String,Single,Single,Single,Single) Method
Text string to be drawn on the page.
Left position of the text.
Top position of the text.
Width of the text area (in inches).
Height of the text area (in inches).
Draws the specified string within the specified coordinates.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DrawText( _
   ByVal strText As System.String, _
   ByVal left As System.Single, _
   ByVal top As System.Single, _
   ByVal width As System.Single, _
   ByVal height As System.Single _
)
public void DrawText(
   System.string strText,
   System.float left,
   System.float top,
   System.float width,
   System.float height
)

Parameters

strText
Text string to be drawn on the page.
left
Left position of the text.
top
Top position of the text.
width
Width of the text area (in inches).
height
Height of the text area (in inches).
Remarks
Uses the page's Font, ForeColor, BackColor, TextAlignment, TextAngle and VerticalTextAlignment properties to draw the string.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    arv.Document.Pages[0].DrawText("Confidential", 1, 1, 6.5f, 9);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", 1, 1, 6.5, 9)
    End With
End Sub
See Also

Reference

Page Class
Page Members
Overload List


DrawText(String,RectangleF) Method

DrawText(String,RectangleF) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawText Method : DrawText(String,RectangleF) Method
Text string to be drawn on the page.
Bounds of the text.
Draws the specified string within the specified bounds.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DrawText( _
   ByVal strText As System.String, _
   ByVal text As RectangleF _
)
public void DrawText(
   System.string strText,
   RectangleF text
)

Parameters

strText
Text string to be drawn on the page.
text
Bounds of the text.
Remarks
Uses the page's Font, ForeColor, BackColor, TextAlignment, TextAngle and VerticalTextAlignment properties to draw the string.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText("Confidential", drawRect);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", drawRect)
    End With
End Sub
See Also

Reference

Page Class
Page Members
Overload List


DrawText(String[],Single,Single,Single,Single) Method

DrawText(String[],Single,Single,Single,Single) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawText Method : DrawText(String[],Single,Single,Single,Single) Method
Array of text strings to be drawn on the page.
Left position of the text.
Top position of the text.
Width of the text area (in inches).
Height of the text area (in inches).
Draws the specified array of strings within the specified coordinates.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DrawText( _
   ByVal astrText() As System.String, _
   ByVal left As System.Single, _
   ByVal top As System.Single, _
   ByVal width As System.Single, _
   ByVal height As System.Single _
)
public void DrawText(
   System.string[] astrText,
   System.float left,
   System.float top,
   System.float width,
   System.float height
)

Parameters

astrText
Array of text strings to be drawn on the page.
left
Left position of the text.
top
Top position of the text.
width
Width of the text area (in inches).
height
Height of the text area (in inches).
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    string[] strArray = new string[5] {"A", "B", "C", "Sofware", "Company"};

    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    arv.Document.Pages[0].DrawText(strArray, 1, 1, 6.5f, 9);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim strArray() As String = New String(4) {"A", "B", "C", "Software", "Company"}

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText(strArray, 1, 1, 6.5, 9)
    End With
End Sub
See Also

Reference

Page Class
Page Members
Overload List


DrawText(String[],RectangleF) Method

DrawText(String[],RectangleF) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawText Method : DrawText(String[],RectangleF) Method
Array of text strings to be drawn on the page.
Bounds of the text.
Draws the specified array of strings within the specified bounds.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DrawText( _
   ByVal astrText() As System.String, _
   ByVal text As RectangleF _
)
public void DrawText(
   System.string[] astrText,
   RectangleF text
)

Parameters

astrText
Array of text strings to be drawn on the page.
text
Bounds of the text.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    string[] strArray = new string[5] {"A", "B", "C", "Sofware", "Company"};
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText(strArray, drawRect);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim strArray() As String = New String(4) {"A", "B", "C", "Software", "Company"}
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText(strArray, drawRect)
    End With
End Sub
See Also

Reference

Page Class
Page Members
Overload List


DrawText(String,Single,Single,Single,Single,String) Method

DrawText(String,Single,Single,Single,Single,String) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawText Method : DrawText(String,Single,Single,Single,Single,String) Method
Text string to be drawn on the page.
Left position of the text.
Top position of the text.
Width of the text area (in inches).
Height of the text area (in inches).
Hyperlink URL.
Draws the specified string within the specified coordinates and creates a hyperlink for the text area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DrawText( _
   ByVal strText As System.String, _
   ByVal left As System.Single, _
   ByVal top As System.Single, _
   ByVal width As System.Single, _
   ByVal height As System.Single, _
   ByVal strLink As System.String _
)
public void DrawText(
   System.string strText,
   System.float left,
   System.float top,
   System.float width,
   System.float height,
   System.string strLink
)

Parameters

strText
Text string to be drawn on the page.
left
Left position of the text.
top
Top position of the text.
width
Width of the text area (in inches).
height
Height of the text area (in inches).
strLink
Hyperlink URL.
Remarks
Uses the page's Font, ForeColor, BackColor, TextAlignment, TextAngle and VerticalTextAlignment properties to draw the string.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    arv.Document.Pages[0].DrawText("Confidential", 1, 1, 6.5f, 9, "www.grapecity.com");
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", 1, 1, 6.5, 9, "www.grapecity.com")
    End With
End Sub
See Also

Reference

Page Class
Page Members
Overload List


DrawText(String,RectangleF,String) Method

DrawText(String,RectangleF,String) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawText Method : DrawText(String,RectangleF,String) Method
Text string to be drawn on the page.
Bounds of the text.
Hyperlink URL.
Draws the specified string within the specified bounds and creates a hyperlink at the specified area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DrawText( _
   ByVal strText As System.String, _
   ByVal text As RectangleF, _
   ByVal strLink As System.String _
)
public void DrawText(
   System.string strText,
   RectangleF text,
   System.string strLink
)

Parameters

strText
Text string to be drawn on the page.
text
Bounds of the text.
strLink
Hyperlink URL.
Remarks
Uses the page's Font, ForeColor, BackColor, TextAlignment, TextAngle and VerticalTextAlignment properties to draw the string.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText("Confidential", drawRect, "www.grapecity.com");
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", drawRect, "www.grapecity.com")
    End With
End Sub
See Also

Reference

Page Class
Page Members
Overload List


DrawText(String[],Single,Single,Single,Single,String) Method

DrawText(String[],Single,Single,Single,Single,String) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawText Method : DrawText(String[],Single,Single,Single,Single,String) Method
Array of text strings to be drawn on the page.
Left position of the text.
Top position of the text.
Width of the text area (in inches).
Height of the text area (in inches).
Hyperlink URL.
Draws the specified array of strings within the specified coordinates and creates a hyperlink for the text area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DrawText( _
   ByVal astrText() As System.String, _
   ByVal left As System.Single, _
   ByVal top As System.Single, _
   ByVal width As System.Single, _
   ByVal height As System.Single, _
   ByVal strLink As System.String _
)
public void DrawText(
   System.string[] astrText,
   System.float left,
   System.float top,
   System.float width,
   System.float height,
   System.string strLink
)

Parameters

astrText
Array of text strings to be drawn on the page.
left
Left position of the text.
top
Top position of the text.
width
Width of the text area (in inches).
height
Height of the text area (in inches).
strLink
Hyperlink URL.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    string[] strArray = new string[5] {"A", "B", "C", "Sofware", "Company"};

    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    arv.Document.Pages[0].DrawText(strArray, 1, 1, 6.5f, 9, "www.grapecity.com");
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim strArray() As String = New String(4) {"A", "B", "C", "Software", "Company"}

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText(strArray, 1, 1, 6.5, 9, "www.grapecity.com")
    End With
End Sub
See Also

Reference

Page Class
Page Members
Overload List


DrawText(String[],RectangleF,String) Method

DrawText(String[],RectangleF,String) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > DrawText Method : DrawText(String[],RectangleF,String) Method
Array of text strings to be drawn on the page.
Bounds of the text.
Hyperlink URL.
Draws the specified array of strings within the specified bounds and creates a hyperlink at the specified area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub DrawText( _
   ByVal astrText() As System.String, _
   ByVal text As RectangleF, _
   ByVal strLink As System.String _
)
public void DrawText(
   System.string[] astrText,
   RectangleF text,
   System.string strLink
)

Parameters

astrText
Array of text strings to be drawn on the page.
text
Bounds of the text.
strLink
Hyperlink URL.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    string[] strArray = new string[5] {"A", "B", "C", "Sofware", "Company"};
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText(strArray, drawRect, "www.grapecity.com");
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim strArray() As String = New String(4) {"A", "B", "C", "Software", "Company"}
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText(strArray, drawRect, "www.grapecity.com")
    End With
End Sub
See Also

Reference

Page Class
Page Members
Overload List


FillRect Method

FillRect Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : FillRect Method

Fills the specified area with the current page BackColor.

Overload List
Overload | Description
FillRect(Single,Single,Single,Single) | Fills the specified coordinates with the current page BackColor.
FillRect(RectangleF) | Fills the specified bounds with the current page BackColor.
Remarks

Units are determined by the Page.Units property.

Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;

    arv.Document.Pages[0].FillRect(1, 1, 2, 2);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .FillRect(1, 1, 2, 2)
    End With
End Sub
See Also

Reference

Page Class
Page Members


FillRect(Single,Single,Single,Single) Method

FillRect(Single,Single,Single,Single) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > FillRect Method : FillRect(Single,Single,Single,Single) Method
Left position of the rectangle (in inches).

Top position of the rectangle (in inches).

Width of the rectangle (in inches).
Height of the rectangle (in inches).

Fills the specified coordinates with the current page BackColor.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub FillRect( _
   ByVal left As System.Single, _
   ByVal top As System.Single, _
   ByVal width As System.Single, _
   ByVal height As System.Single _
)
public void FillRect(
   System.float left,
   System.float top,
   System.float width,
   System.float height
)

Parameters

left
Left position of the rectangle (in inches).
top

Top position of the rectangle (in inches).

width
Width of the rectangle (in inches).
height
Height of the rectangle (in inches).
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;

    arv.Document.Pages[0].FillRect(1, 1, 2, 2);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .FillRect(1, 1, 2, 2)
    End With
End Sub
See Also

Reference

Page Class
Page Members
Overload List


FillRect(RectangleF) Method

FillRect(RectangleF) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > FillRect Method : FillRect(RectangleF) Method
Bounds of the rectangle.

Fills the specified bounds with the current page BackColor.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub FillRect( _
   ByVal rc As RectangleF _
)
public void FillRect(
   RectangleF rc
)

Parameters

rc
Bounds of the rectangle.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 2.0F;
    Single height = 2.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].FillRect(drawRect);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 2.0F
    Dim height As Single = 2.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .FillRect(drawRect)
    End With
End Sub
See Also

Reference

Page Class
Page Members
Overload List


Load Method (Page)

Load Method (Page)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Load Method
Loads page content from a reader or a file.
Overload List
Overload | Description
Load(String) | Loads page content from the specified file name.
Load(Stream) | Loads page content from the specified stream.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText("Confidential", drawRect);

    arv.Document.Pages[0].Save(Application.StartupPath + "\\page.cnv");
    arv.Document.Pages[2].Load(Application.StartupPath + "\\page.cnv");
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", drawRect)
    End With
    arv.Document.Pages(0).Save(Application.StartupPath + "\page.cnv")
    arv.Document.Pages(2).Load(Application.StartupPath + "\page.cnv")
End Sub
See Also

Reference

Page Class
Page Members


Load(String) Method

Load(String) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > Load Method : Load(String) Method
Specifies the name of the file that contains the previously saved page content.
Loads page content from the specified file name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Load( _
   ByVal strFileName As System.String _
) As System.Boolean
public System.bool Load(
   System.string strFileName
)

Parameters

strFileName
Specifies the name of the file that contains the previously saved page content.
Remarks
Page content can be saved using the Page.Save method.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText("Confidential", drawRect);

    arv.Document.Pages[0].Save(Application.StartupPath + "\\page.cnv");
    arv.Document.Pages[2].Load(Application.StartupPath + "\\page.cnv");
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", drawRect)
    End With
    arv.Document.Pages(0).Save(Application.StartupPath + "\page.cnv")
    arv.Document.Pages(2).Load(Application.StartupPath + "\page.cnv")
End Sub
See Also

Reference

Page Class
Page Members
Overload List


Load(Stream) Method

Load(Stream) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > Load Method : Load(Stream) Method
Specifies the Stream that contains the previously saved page content.
Loads page content from the specified stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Load( _
   ByVal stm As System.IO.Stream _
) As System.Boolean
public System.bool Load(
   System.IO.Stream stm
)

Parameters

stm
Specifies the Stream that contains the previously saved page content.
See Also

Reference

Page Class
Page Members
Overload List


MeasureParagraphHeight Method

MeasureParagraphHeight Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : MeasureParagraphHeight Method
Measures the height of the specified text if rendered using the current page settings with the specified width.
Overload List
Overload | Description
MeasureParagraphHeight(String,Single) | Measures the height of the specified text in a specified width at run time.
MeasureParagraphHeight(String,Single,Font,StringFormat) | Measures the height of the specified text in a specified width, font, and format at run time.
Remarks
Units are determined by the Page.Units property.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDD rpt = new rptDD();
    rpt.Run();
    arv.Document = rpt.Document;

    System.Drawing.SizeF x;

    rpt.CurrentPage.Font = this.TextBox1.Font;
    Console.WriteLine("TextBox1 Size = " + this.TextBox1.Size.ToString());
    string y;
    y = "This is a really long textbox with text that should wrap multiple lines so I can then measure the height of the text using the MeasureParagrahHeight method off of the page object.";
    x = arv.Document.Pages[0].MeasureParagraphHeight(y,this.TextBox1.Width);
    Console.WriteLine("MPH = " + x.ToString());
    this.TextBox1.Size = x.ToSize();
    this.TextBox1.Text = y;
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDD
    rpt.Run()
    arv.Document = rpt.Document

    Dim x As System.Drawing.SizeF

    rpt.CurrentPage.Font = Me.TextBox1.Font
    Console.WriteLine("TextBox1 Size = " + Me.TextBox1.Size.ToString())
    Dim y As String
    y = "This is a really long textbox with text that should wrap multiple lines so I can then measure the height of the text using the MeasureParagrahHeight method off of the page object."
    x = arv.Document.Pages(0).MeasureParagraphHeight(y, Me.TextBox1.Width)
    Console.WriteLine("MPH = " + x.ToString())
    Me.TextBox1.Size = x.ToSize()
    Me.TextBox1.Text = y
End Sub
See Also

Reference

Page Class
Page Members


MeasureParagraphHeight(String,Single) Method

MeasureParagraphHeight(String,Single) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > MeasureParagraphHeight Method : MeasureParagraphHeight(String,Single) Method

Text string to be measured.

Width of the text (in inches).
Measures the height of the specified text in a specified width at run time.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function MeasureParagraphHeight( _
   ByVal strText As System.String, _
   ByVal width As System.Single _
) As SizeF
public SizeF MeasureParagraphHeight(
   System.string strText,
   System.float width
)

Parameters

strText

Text string to be measured.

width
Width of the text (in inches).
See Also

Reference

Page Class
Page Members
Overload List


MeasureParagraphHeight(String,Single,Font,StringFormat) Method

MeasureParagraphHeight(String,Single,Font,StringFormat) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > MeasureParagraphHeight Method : MeasureParagraphHeight(String,Single,Font,StringFormat) Method

Text string to be measured.

Width of the text (in inches).
The font of the text string to be measured.
The format of the text string to be measured.
Measures the height of the specified text in a specified width, font, and format at run time.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function MeasureParagraphHeight( _
   ByVal strText As System.String, _
   ByVal width As System.Single, _
   ByVal textFont As Font, _
   ByVal strFormat As StringFormat _
) As SizeF
public SizeF MeasureParagraphHeight(
   System.string strText,
   System.float width,
   Font textFont,
   StringFormat strFormat
)

Parameters

strText

Text string to be measured.

width
Width of the text (in inches).
textFont
The font of the text string to be measured.
strFormat
The format of the text string to be measured.
See Also

Reference

Page Class
Page Members
Overload List


MeasureText Method

MeasureText Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : MeasureText Method
Determines the width and height of text string.
Overload List
Overload | Description
MeasureText(String) | Measures the text string with the currently selected font.
MeasureText(String,Font) | Measures the text string.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDD rpt = new rptDD();
    rpt.Run();
    arv.Document = rpt.Document;

    SizeF sz = arv.Document.Pages[0].MeasureText("This is my string. How long is it?");
    arv.Document.Pages[0].DrawText("This is my string. How long is it? " + sz.ToString(),0,0,6f,9f);
    arv.Document.Pages[0].DrawLine(0,sz.Height,sz.Width,sz.Height);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDD
    rpt.Run()
    arv.Document = rpt.Document

    Dim sz As SizeF = arv.Document.Pages(0).MeasureText("This is my string. How long is it?")
    arv.Document.Pages(0).DrawText("This is my string. How long is it? " + sz.ToString(), 0, 0, 6.0F, 9.0F)
    arv.Document.Pages(0).DrawLine(0, sz.Height, sz.Width, sz.Height)
End Sub
See Also

Reference

Page Class
Page Members


MeasureText(String) Method

MeasureText(String) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > MeasureText Method : MeasureText(String) Method
The text string to measure.
Measures the text string with the currently selected font.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function MeasureText( _
   ByVal strText As System.String _
) As SizeF
public SizeF MeasureText(
   System.string strText
)

Parameters

strText
The text string to measure.
See Also

Reference

Page Class
Page Members
Overload List


MeasureText(String,Font) Method

MeasureText(String,Font) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > MeasureText Method : MeasureText(String,Font) Method
The text string to measure.
The font of the text.
Measures the text string.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function MeasureText( _
   ByVal strText As System.String, _
   ByVal font As Font _
) As SizeF
public SizeF MeasureText(
   System.string strText,
   Font font
)

Parameters

strText
The text string to measure.
font
The font of the text.
See Also

Reference

Page Class
Page Members
Overload List


Overlay Method

Overlay Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Overlay Method
Page to be laid on top of the current page.
Overlays the specified page object on top of the Page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Overlay( _
   ByVal page As Page _
)
public void Overlay(
   Page page
)

Parameters

page
Page to be laid on top of the current page.
Example
  • C#
private void Form1_Load(object sender, System.EventArgs e)
{
    rptReport rpt = new rptReport();
    rpt.Run();
    rptTemplate rpt2 = new rptTemplate();
    rpt2.Run();
    viewer1.Document = rpt.Document;
    for(int i = 0; i < rpt.Document.Pages.Count; i++)
    {
        rpt.Document.Pages[i].Overlay(rpt2.Document.Pages[0]);
    }
}
  • Visual Basic
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New rptReport()
    rpt.Run()
    Dim rpt2 As New rptTemplate()
    rpt2.Run()
    Viewer1.Document = rpt.Document
    For i = 0 To rpt.Document.Pages.Count - 1
        rpt.Document.Pages(i).Overlay(rpt2.Document.Pages(0))
    Next
End Sub
See Also

Reference

Page Class
Page Members

Walkthroughs

Overlaying Reports (Letterhead)


Save Method (Page)

Save Method (Page)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Save Method
Saves page content.
Overload List
Overload | Description
Save(String) | Saves page content to the specified file name.
Save(Stream) | Saves page content to the specified Stream.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText("Confidential", drawRect);

    arv.Document.Pages[0].Save(Application.StartupPath + "\\page.cnv");
    arv.Document.Pages[2].Load(Application.StartupPath + "\\page.cnv");
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", drawRect)
    End With
    arv.Document.Pages(0).Save(Application.StartupPath + "\page.cnv")
    arv.Document.Pages(2).Load(Application.StartupPath + "\page.cnv")
End Sub
See Also

Reference

Page Class
Page Members


Save(String) Method

Save(String) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > Save Method : Save(String) Method
Specifies the name of the file in which to store the page content.
Saves page content to the specified file name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Save( _
   ByVal strFileName As System.String _
) As System.Boolean
public System.bool Save(
   System.string strFileName
)

Parameters

strFileName
Specifies the name of the file in which to store the page content.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText("Confidential", drawRect);

    arv.Document.Pages[0].Save(Application.StartupPath + "\\page.cnv");
    arv.Document.Pages[2].Load(Application.StartupPath + "\\page.cnv");
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", drawRect)
    End With
    arv.Document.Pages(0).Save(Application.StartupPath + "\page.cnv")
    arv.Document.Pages(2).Load(Application.StartupPath + "\page.cnv")
End Sub
See Also

Reference

Page Class
Page Members
Overload List


Save(Stream) Method

Save(Stream) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class > Save Method : Save(Stream) Method
Specifies the stream to which to store the page content.
Saves page content to the specified Stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Save( _
   ByVal stm As System.IO.Stream _
) As System.Boolean
public System.bool Save(
   System.IO.Stream stm
)

Parameters

stm
Specifies the stream to which to store the page content.
See Also

Reference

Page Class
Page Members
Overload List


ToString Method (Page)

ToString Method (Page)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : ToString Method
Renders the page's settings and content to a string.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDD rpt = new rptDD();
    rpt.Run();
    arv.Document = rpt.Document;

    Console.WriteLine(arv.Document.Pages[0].ToString());
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDD
    rpt.Run()
    arv.Document = rpt.Document

    Console.WriteLine(arv.Document.Pages(0).ToString())
End Sub
See Also

Reference

Page Class
Page Members


Page Class Properties

Page Class Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Page Class

For a list of all members of this type, see Page members.

Public Properties
 | Name | Description
Public Property | Annotations | Gets or sets the annotations associated with the page.
Public Property | BackColor | Specifies the background color used to render shapes and text to the page.
Public Property | Bookmarks | Returns a list of the page's bookmarks.
Public Property | CanvasItems | Returns a list of the page's canvas items.
Public Property | CharacterSpacing | Gets or sets the CharacterSpacing value in inches for the page.
Public Property | Compress | Sets or returns a value indicating whether the page is compressed.
Public Property | Font | Gets or sets the current font used to draw text on the page.
Public Property | Fonts | Returns the collection of fonts for the page.
Public Property | ForeColor | Gets or sets the current foreground color used to draw text and shapes on the page.
Public Property | Height | Gets or sets the height of the page in inches.
Public Property | Identifier | Gets unique page identifier (used in PagesCollection to track swapped out pages)
Public Property | LineSpacing | Gets or sets the LineSpacing value in inches for the page.
Public Property | Margins | Gets a reference to the page margins settings.
Public Property | Orientation | Gets or sets the orientation of the page.
Public Property | Padding | Gets or sets the amount of padding to use around the text inside a control.
Public Property | PenStyle | Gets or sets the line style used to draw lines and shapes.
Public Property | PenWidth | Gets or sets the width of the pen used to draw lines and shapes. (1/2 point).
Public Property | RightToLeft | Determines whether DrawText should render text RightToLeft.
Public Property | Size | Returns a SizeF structure with the height and width of the page, in inches.
Public Property | TextAlignment | Determines the text alignment when using the DrawText method.
Public Property | TextAngle | Gets or sets the angle of text used to draw text.
Public Property | TextJustify | Gets or sets the type of justification to use when the TextAlignment property is set to Justify.
Public Property | TextRenderHint | Specifies the quality of rendering.
Public Property | Units | Gets or sets the units used with the page primitive drawing methods.
Public Property | VerticalText | Sets or returns a value indicating whether to draw text vertically when using the DrawText method.
Public Property | VerticalTextAlignment | Determines the vertical text alignment when using the DrawText method.
Public Property | Width | Gets or sets the width of the page (in inches).
Public Property | WordWrap | Gets or sets a value determining whether word wrapping occurs.
Public Property | WrapMode | Gets or sets the wrap mode for rendering text.
Top
See Also

Reference

Page Class
GrapeCity.ActiveReports.Document.Section Namespace


Annotations Property (Page)

Annotations Property (Page)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Annotations Property
Gets or sets the annotations associated with the page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Annotations As AnnotationCollection
public AnnotationCollection Annotations {get; set;}
See Also

Reference

Page Class
Page Members


BackColor Property (Page)

BackColor Property (Page)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : BackColor Property

Specifies the background color used to render shapes and text to the page.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackColor As Color
public Color BackColor {get; set;}

Property Value

System.Drawing.Color value.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;
    arv.Document.Pages[0].DrawLine(1, 1, 4, 4);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .DrawLine(1, 1, 4, 4)
    End With
End Sub
See Also

Reference

Page Class
Page Members


Bookmarks Property (Page)

Bookmarks Property (Page)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Bookmarks Property
Returns a list of the page's bookmarks.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Bookmarks As System.Collections.IList
public System.Collections.IList Bookmarks {get;}
See Also

Reference

Page Class
Page Members


CanvasItems Property

CanvasItems Property

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : CanvasItems Property
Returns a list of the page's canvas items.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CanvasItems As System.Collections.IList
public System.Collections.IList CanvasItems {get;}
Remarks
Use the Clear method to remove all CanvasItems from the Page object.
See Also

Reference

Page Class
Page Members


CharacterSpacing Property (Page)

CharacterSpacing Property (Page)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : CharacterSpacing Property
Gets or sets the CharacterSpacing value in inches for the page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CharacterSpacing As System.Single
public System.float CharacterSpacing {get; set;}

Property Value

The character spacing.
See Also

Reference

Page Class
Page Members


Compress Property

Compress Property

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Compress Property
Sets or returns a value indicating whether the page is compressed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Compress As System.Boolean
public System.bool Compress {get; set;}

Property Value

Boolean. The default value is False.
See Also

Reference

Page Class
Page Members


Font Property (Page)

Font Property (Page)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Font Property

Gets or sets the current font used to draw text on the page.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Font As Font
public Font Font {get; set;}

Property Value

System.Drawing.Font value.

Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText("Confidential", drawRect);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", drawRect)
    End With
End Sub
See Also

Reference

Page Class
Page Members


Fonts Property (Page)

Fonts Property (Page)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Fonts Property
Returns the collection of fonts for the page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Fonts As FontsCollection
public FontsCollection Fonts {get; set;}

Property Value

The fonts.
See Also

Reference

Page Class
Page Members


ForeColor Property (Page)

ForeColor Property (Page)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : ForeColor Property
Gets or sets the current foreground color used to draw text and shapes on the page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ForeColor As Color
public Color ForeColor {get; set;}

Property Value

System.Drawing.Color value.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;
    arv.Document.Pages[0].DrawLine(1, 1, 4, 4);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .DrawLine(1, 1, 4, 4)
    End With
End Sub
See Also

Reference

Page Class
Page Members


Height Property (Page)

Height Property (Page)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Height Property
Gets or sets the height of the page in inches.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As System.Single
public System.float Height {get; set;}
See Also

Reference

Page Class
Page Members


Identifier Property

Identifier Property

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Identifier Property
Gets unique page identifier (used in PagesCollection to track swapped out pages)
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Identifier As System.Guid
public System.Guid Identifier {get;}
See Also

Reference

Page Class
Page Members


LineSpacing Property (Page)

LineSpacing Property (Page)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : LineSpacing Property
Gets or sets the LineSpacing value in inches for the page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineSpacing As System.Single
public System.float LineSpacing {get; set;}

Property Value

The line spacing.
See Also

Reference

Page Class
Page Members


Margins Property (Page)

Margins Property (Page)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Margins Property
Gets a reference to the page margins settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Margins As Margins
public Margins Margins {get;}

Property Value

A Margins object used to set the margins of the page.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDD rpt = new rptDD();
    rpt.Run();
    arv.Document = rpt.Document;

    Console.WriteLine(arv.Document.Pages[0].Margins.Bottom);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDD
    rpt.Run()
    arv.Document = rpt.Document

    Console.WriteLine(arv.Document.Pages(0).Margins.Bottom)
End Sub
See Also

Reference

Page Class
Page Members


Orientation Property (Page)

Orientation Property (Page)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Orientation Property
Gets or sets the orientation of the page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Orientation As PageOrientation
public PageOrientation Orientation {get; set;}

Property Value

PageOrientation enumeration value that specifies the orientation of the page.
Remarks
The Printer.PaperHeight measurement is for the portrait orientation of the paper. In Landscape, the height is equal to Printer.PaperWidth.
Example
  • C#
private void rptPrint_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.Orientation = GrapeCity.ActiveReports.Document.Section.PageOrientation.Landscape;
}
  • Visual Basic
Private Sub rptPrint_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.PageSettings.Orientation = GrapeCity.ActiveReports.Document.Section.PageOrientation.Landscape
End Sub
See Also

Reference

Page Class
Page Members
PageOrientation Enumeration
Printer Class


Padding Property (Page)

Padding Property (Page)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Padding Property
Gets or sets the amount of padding to use around the text inside a control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Padding As PaddingEx
public PaddingEx Padding {get; set;}

Property Value

The padding.
See Also

Reference

Page Class
Page Members


PenStyle Property

PenStyle Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : PenStyle Property
Gets or sets the line style used to draw lines and shapes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PenStyle As PenStyles
public PenStyles PenStyle {get; set;}

Property Value

PenStyles enumeration value that determines the line style used to draw lines and shapes.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;
    arv.Document.Pages[0].DrawLine(1, 1, 4, 4);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .DrawLine(1, 1, 4, 4)
    End With
End Sub
See Also

Reference

Page Class
Page Members
PenStyles Enumeration


PenWidth Property

PenWidth Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : PenWidth Property
Gets or sets the width of the pen used to draw lines and shapes. (1/2 point).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PenWidth As System.Short
public System.short PenWidth {get; set;}

Property Value

Integer value (in 1/2 point) that specifies the width of the line.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;
    arv.Document.Pages[0].BackColor = System.Drawing.Color.Purple;
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot;
    arv.Document.Pages[0].PenWidth = 4;
    arv.Document.Pages[0].DrawLine(1, 1, 4, 4);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document
    With arv.Document.Pages(0)
        .BackColor = System.Drawing.Color.Purple
        .ForeColor = System.Drawing.Color.YellowGreen
        .PenStyle = GrapeCity.ActiveReports.Document.Section.PenStyles.Dot
        .PenWidth = 4
        .DrawLine(1, 1, 4, 4)
    End With
End Sub
Requirements

See Also

Reference

Page Class
Page Members


RightToLeft Property (Page)

RightToLeft Property (Page)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : RightToLeft Property

Determines whether DrawText should render text RightToLeft.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RightToLeft As System.Boolean
public System.bool RightToLeft {get; set;}

Property Value

A Boolean value. True if the text is rendered right to left; otherwise, false. Default is false.
See Also

Reference

Page Class
Page Members


Size Property (Page)

Size Property (Page)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Size Property
Returns a SizeF structure with the height and width of the page, in inches.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Size As SizeF
public SizeF Size {get;}

Property Value

A SizeF value specifying the height and width in inches.
See Also

Reference

Page Class
Page Members


TextAlignment Property (Page)

TextAlignment Property (Page)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : TextAlignment Property

Determines the text alignment when using the DrawText method.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TextAlignment As TextAlignment
public TextAlignment TextAlignment {get; set;}

Property Value

TextAlignment enumeration.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText("Confidential", drawRect);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", drawRect)
    End With
End Sub
See Also

Reference

Page Class
Page Members


TextAngle Property (Page)

TextAngle Property (Page)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : TextAngle Property
Gets or sets the angle of text used to draw text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TextAngle As System.Integer
public System.int TextAngle {get; set;}

Property Value

Integer value of the text angle (1/10 degree).
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText("Confidential", drawRect);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", drawRect)
    End With
End Sub
See Also

Reference

Page Class
Page Members


TextJustify Property (Page)

TextJustify Property (Page)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : TextJustify Property
Gets or sets the type of justification to use when the TextAlignment property is set to Justify.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TextJustify As TextJustify
public TextJustify TextJustify {get; set;}

Property Value

The text justify.
See Also

Reference

Page Class
Page Members


TextRenderHint Property

TextRenderHint Property

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : TextRenderHint Property
Specifies the quality of rendering.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TextRenderHint As TextRenderHint
public TextRenderHint TextRenderHint {get; set;}

Property Value

The text render hint.
See Also

Reference

Page Class
Page Members


Units Property

Units Property

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Units Property
Gets or sets the units used with the page primitive drawing methods.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Units As Units
public Units Units {get; set;}

Property Value

Units enumeration.
See Also

Reference

Page Class
Page Members
Units Enumeration


VerticalText Property (Page)

VerticalText Property (Page)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : VerticalText Property
Sets or returns a value indicating whether to draw text vertically when using the DrawText method.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property VerticalText As System.Boolean
public System.bool VerticalText {get; set;}

Property Value

true if [vertical text]; otherwise, false.
See Also

Reference

Page Class
Page Members


VerticalTextAlignment Property

VerticalTextAlignment Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : VerticalTextAlignment Property

Determines the vertical text alignment when using the DrawText method.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property VerticalTextAlignment As VerticalTextAlignment
public VerticalTextAlignment VerticalTextAlignment {get; set;}

Property Value

VerticalTextAlignment enumeration.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDocument rpt = new rptDocument();
    rpt.Run();
    arv.Document=rpt.Document;

    System.Drawing.Font f = new System.Drawing.Font("Times New Roman", 36);
    arv.Document.Pages[0].ForeColor = System.Drawing.Color.YellowGreen;
    arv.Document.Pages[0].Font = f;
    arv.Document.Pages[0].TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center;
    arv.Document.Pages[0].TextAngle = 900;
    arv.Document.Pages[0].VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle;

    Single x = 1.0F;
    Single y = 1.0F;
    Single width = 6.5F;
    Single height = 9.0F;
    RectangleF drawRect = new RectangleF(x,y,width,height);

    arv.Document.Pages[0].DrawText("Confidential", drawRect);
}
  • Visual Basic
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDocument
    rpt.Run()
    arv.Document = rpt.Document

    Dim f As New System.Drawing.Font("Times New Roman", 36)
    Dim x As Single = 1.0F
    Dim y As Single = 1.0F
    Dim width As Single = 6.0F
    Dim height As Single = 9.0F
    Dim drawRect As New RectangleF(x, y, width, height)

    With arv.Document.Pages(0)
        .Font = f
        .ForeColor = System.Drawing.Color.YellowGreen
        .TextAlignment = GrapeCity.ActiveReports.Document.Section.TextAlignment.Center
        .TextAngle = 900
        .VerticalTextAlignment = GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment.Middle
        .DrawText("Confidential", drawRect)
    End With
End Sub
See Also

Reference

Page Class
Page Members


Width Property (Page)

Width Property (Page)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Width Property
Gets or sets the width of the page (in inches).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As System.Single
public System.float Width {get; set;}
See Also

Reference

Page Class
Page Members


WordWrap Property

WordWrap Property

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : WordWrap Property
Gets or sets a value determining whether word wrapping occurs.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WordWrap As System.Boolean
public System.bool WordWrap {get; set;}
See Also

Reference

Page Class
Page Members


WrapMode Property (Page)

WrapMode Property (Page)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : WrapMode Property
Gets or sets the wrap mode for rendering text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WrapMode As WrapMode
public WrapMode WrapMode {get; set;}
See Also

Reference

Page Class
Page Members


PagesCollection Class

PagesCollection Class
Members

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PagesCollection Class
Manages a set of pages in the Document object.
Object Model
PagesCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class PagesCollection
public class PagesCollection
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.PagesCollection

See Also

Reference

PagesCollection Members
GrapeCity.ActiveReports.Document.Section Namespace


PagesCollection Class Members

PagesCollection Class Members
Properties Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PagesCollection Class

The following tables list the members exposed by PagesCollection.

Public Constructors
 | Name | Description
Public Constructor | PagesCollection Constructor | Overloaded. Initializes a new instance of the PagesCollection class.
Top
Public Properties
 | Name | Description
Public Property | Count | Returns the number of Page members in the collection.
Public Property | Fonts | Returns the FontsCollection that is used in the PagesCollection.
Public Property | IsFixedSize | Gets a value indicating whether the PagesCollection has a fixed size.
Public Property | IsReadOnly | Gets a value indicating whether the PagesCollection is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the PagesCollection is synchronized (thread safe). (Inherited from ICollection.)
Public Property | Item | Returns the member at the specified index in the collection.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the PagesCollection.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds the specified Page object to the collection.
Public Method | AddRange | Overloaded. Adds an array or collection of pages.
Public Method | Clear | Clears all pages from the collection.
Public Method | Clone | Creates a clone of the PagesCollection.
Public Method | Contains | Overloaded. Determines whether the specified object is a member of the collection.
Public Method | CopyTo | Overloaded. Copies pages from the collection to an array, starting at a particular array index.
Public Method | Dispose | Releases the PagesCollection instance from memory.
Public Method | GetRange | Returns a new collection of the specified number of pages starting with the specified index
Public Method | IndexOf | Overloaded. Returns the index of a page in the collection.
Public Method | Insert | Overloaded. Inserts the specified page into the collection at the specified index.
Public Method | InsertNew | Creates a new Page object and inserts it into the collection at the specified index.
Public Method | InsertRange | Overloaded. Inserts a range of pages into the collection at a specified position.
Public Method | Remove | Overloaded. Removes the specified page object from the collection.
Public Method | RemoveAt | Removes the page at the specified index from the collection.
Top
See Also

Reference

PagesCollection Class
GrapeCity.ActiveReports.Document.Section Namespace


PagesCollection Constructor

PagesCollection Constructor

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : PagesCollection Constructor
Initializes a new instance of the PagesCollection class.
Overload List
Overload | Description
PagesCollection Constructor() | Initializes a new instance of the PagesCollection class.
PagesCollection Constructor(SectionDocument) | Initializes a new instance of the PagesCollection class.
See Also

Reference

PagesCollection Class
PagesCollection Members


PagesCollection Constructor()

PagesCollection Constructor()

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > PagesCollection Constructor : PagesCollection Constructor()
Initializes a new instance of the PagesCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public PagesCollection()
See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


PagesCollection Constructor(SectionDocument)

PagesCollection Constructor(SectionDocument)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > PagesCollection Constructor : PagesCollection Constructor(SectionDocument)
Section document.
Initializes a new instance of the PagesCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal document As SectionDocument _
)
public PagesCollection(
   SectionDocument document
)

Parameters

document
Section document.
See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


PagesCollection Class Methods

PagesCollection Class Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PagesCollection Class

For a list of all members of this type, see PagesCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds the specified Page object to the collection.
Public Method | AddRange | Overloaded. Adds an array or collection of pages.
Public Method | Clear | Clears all pages from the collection.
Public Method | Clone | Creates a clone of the PagesCollection.
Public Method | Contains | Overloaded. Determines whether the specified object is a member of the collection.
Public Method | CopyTo | Overloaded. Copies pages from the collection to an array, starting at a particular array index.
Public Method | Dispose | Releases the PagesCollection instance from memory.
Public Method | GetRange | Returns a new collection of the specified number of pages starting with the specified index
Public Method | IndexOf | Overloaded. Returns the index of a page in the collection.
Public Method | Insert | Overloaded. Inserts the specified page into the collection at the specified index.
Public Method | InsertNew | Creates a new Page object and inserts it into the collection at the specified index.
Public Method | InsertRange | Overloaded. Inserts a range of pages into the collection at a specified position.
Public Method | Remove | Overloaded. Removes the specified page object from the collection.
Public Method | RemoveAt | Removes the page at the specified index from the collection.
Top
See Also

Reference

PagesCollection Class
GrapeCity.ActiveReports.Document.Section Namespace


Add Method (PagesCollection)

Add Method (PagesCollection)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : Add Method
Adds the specified Page object to the collection.
Overload List
Overload | Description
Add(Object) | Adds a Page object to the end of the PagesCollection.
Add(Page) | Adds a Page object to the end of the PagesCollection.
Example
  • C#
int i;
private void Form1_Load(object sender, System.EventArgs e)
{
    rptOne rpt1 = new rptOne();
    rpt1.Run();
    rptTwo rpt2 = new rptTwo();
    rpt2.Run();
    for(i = 0; i < rpt2.Document.Pages.Count; i++)
    {
        rpt1.Document.Pages.Add(rpt2.Document.Pages[i]);
    }
    viewer1.Document = rpt1.Document;
}
  • Visual Basic
Dim i As Integer
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New rptOne()
    rpt.Run()
    Dim rpt2 As New rptTwo()
    rpt2.Run()
    For i = 0 To rpt2.Document.Pages.Count - 1
        rpt.Document.Pages.Add(rpt2.Document.Pages(i))
    Next
    Viewer1.Document = rpt.Document
End Sub
See Also

Reference

PagesCollection Class
PagesCollection Members

How To

Insert or Add Pages


Add(Object) Method

Add(Object) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > Add Method : Add(Object) Method
The page object to add.
Adds a Page object to the end of the PagesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal value As System.Object _
) As System.Integer
public System.int Add(
   System.object value
)

Parameters

value
The page object to add.

Return Value

The position into which the new element was inserted.
See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


Add(Page) Method

Add(Page) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > Add Method : Add(Page) Method
The page object to add.
Adds a Page object to the end of the PagesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal value As Page _
) As System.Integer
public System.int Add(
   Page value
)

Parameters

value
The page object to add.
See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


AddRange Method (PagesCollection)

AddRange Method (PagesCollection)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : AddRange Method
Adds an array or collection of pages.
Overload List
Overload | Description
AddRange(Page[]) | Adds the specified array of Page objects to the collection.
AddRange(PagesCollection) | Adds the pages from the specified collection into the collection.
Example
  • C#
private void Form1_Load(object sender, System.EventArgs e)
{
    rptOne rpt1 = new rptOne();
    rpt1.Run();
    rptTwo rpt2 = new rptTwo();
    rpt2.Run();
    rpt1.Document.Pages.AddRange(rpt2.Document.Pages);
    viewer1.Document = rpt1.Document;
}
  • Visual Basic
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim rpt As New rptOne()
        rpt.Run()
        Dim rpt2 As New rptTwo()
        rpt2.Run()
        rpt.Document.Pages.AddRange(rpt2.Document.Pages)
        Viewer1.Document = rpt.Document
End Sub
See Also

Reference

PagesCollection Class
PagesCollection Members

How To

Insert or Add Pages


AddRange(Page[]) Method

AddRange(Page[]) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > AddRange Method : AddRange(Page[]) Method
Array of pages to be added to the collection.
Adds the specified array of Page objects to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddRange( _
   ByVal pages() As Page _
)
public void AddRange(
   Page[] pages
)

Parameters

pages
Array of pages to be added to the collection.
See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


AddRange(PagesCollection) Method

AddRange(PagesCollection) Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > AddRange Method : AddRange(PagesCollection) Method

Collection of pages to be added to the collection.

Adds the pages from the specified collection into the collection.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddRange( _
   ByVal pages As PagesCollection _
)
public void AddRange(
   PagesCollection pages
)

Parameters

pages

Collection of pages to be added to the collection.

Example
  • C#
private void Form1_Load(object sender, System.EventArgs e)
{
    rptOne rpt1 = new rptOne();
    rpt1.Run();
    rptTwo rpt2 = new rptTwo();
    rpt2.Run();
    rpt1.Document.Pages.AddRange(rpt2.Document.Pages);
    viewer1.Document = rpt1.Document;
}
  • Visual Basic
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim rpt As New rptOne()
        rpt.Run()
        Dim rpt2 As New rptTwo()
        rpt2.Run()
        rpt.Document.Pages.AddRange(rpt2.Document.Pages)
        Viewer1.Document = rpt.Document
End Sub
See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


Clear Method (PagesCollection)

Clear Method (PagesCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : Clear Method
Clears all pages from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

PagesCollection Class
PagesCollection Members


Clone Method (PagesCollection)

Clone Method (PagesCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : Clone Method
Creates a clone of the PagesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Clone() As System.Object
public System.object Clone()
See Also

Reference

PagesCollection Class
PagesCollection Members


Contains Method (PagesCollection)

Contains Method (PagesCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : Contains Method
Determines whether the specified object is a member of the collection.
Overload List
Overload | Description
Contains(Object) | Determines whether the specified object is a member of the collection.
Contains(Page) | Determines whether a Page element is in the PagesCollection.
See Also

Reference

PagesCollection Class
PagesCollection Members


Contains(Object) Method

Contains(Object) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > Contains Method : Contains(Object) Method
The page to locate in the collection.
Determines whether the specified object is a member of the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Contains( _
   ByVal value As System.Object _
) As System.Boolean
public System.bool Contains(
   System.object value
)

Parameters

value
The page to locate in the collection.

Return Value

true if the System.Object is found in the System.Collections.IList; otherwise, false.
See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


Contains(Page) Method

Contains(Page) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > Contains Method : Contains(Page) Method
The page to locate in the collection.
Determines whether a Page element is in the PagesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Contains( _
   ByVal value As Page _
) As System.Boolean
public System.bool Contains(
   Page value
)

Parameters

value
The page to locate in the collection.
See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


CopyTo Method (PagesCollection)

CopyTo Method (PagesCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : CopyTo Method

Copies pages from the collection to an array, starting at a particular array index.

Overload List
Overload | Description
CopyTo(Array,Int32) | Copies pages from the collection to an array, starting at a particular array index.
CopyTo(Page[],Int32) | Copies an array of Page objects to PagesCollection from the specified index.
See Also

Reference

PagesCollection Class
PagesCollection Members


CopyTo(Array,Int32) Method

CopyTo(Array,Int32) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > CopyTo Method : CopyTo(Array,Int32) Method

The array that is the destination of the elements copied from the current pages collection.

A 32-bit integer that represents the index in pages collection at which copying begins.

Copies pages from the collection to an array, starting at a particular array index.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub CopyTo( _
   ByVal array As System.Array, _
   ByVal index As System.Integer _
)
public void CopyTo(
   System.Array array,
   System.int index
)

Parameters

array

The array that is the destination of the elements copied from the current pages collection.

index

A 32-bit integer that represents the index in pages collection at which copying begins.

See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


CopyTo(Page[],Int32) Method

CopyTo(Page[],Int32) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > CopyTo Method : CopyTo(Page[],Int32) Method
The pages array that is the destination of the elements copied from the current pages collection.

A 32-bit integer that represents the index in pages collection at which copying begins.

Copies an array of Page objects to PagesCollection from the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub CopyTo( _
   ByVal values() As Page, _
   ByVal index As System.Integer _
)
public void CopyTo(
   Page[] values,
   System.int index
)

Parameters

values
The pages array that is the destination of the elements copied from the current pages collection.
index

A 32-bit integer that represents the index in pages collection at which copying begins.

See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : Dispose() Method
Releases the PagesCollection instance from memory.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

PagesCollection Class
PagesCollection Members


GetRange Method (PagesCollection)

GetRange Method (PagesCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : GetRange Method
Specifies the starting page index of the range.
The number of pages to be returned.
Returns a new collection of the specified number of pages starting with the specified index
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetRange( _
   ByVal index As System.Integer, _
   ByVal count As System.Integer _
) As PagesCollection
public PagesCollection GetRange(
   System.int index,
   System.int count
)

Parameters

index
Specifies the starting page index of the range.
count
The number of pages to be returned.

Return Value

A collection of pages from the collection starting at the specified index.
See Also

Reference

PagesCollection Class
PagesCollection Members


IndexOf Method (PagesCollection)

IndexOf Method (PagesCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : IndexOf Method
Returns the index of a page in the collection.
Overload List
Overload | Description
IndexOf(Object) | Returns the index of a page object in the collection.
IndexOf(Page) | Returns the zero-based index of the first occurrence of the Page object in the PagesCollection.
See Also

Reference

PagesCollection Class
PagesCollection Members


IndexOf(Object) Method

IndexOf(Object) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > IndexOf Method : IndexOf(Object) Method
The page to locate in the collection.
Returns the index of a page object in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function IndexOf( _
   ByVal value As System.Object _
) As System.Integer
public System.int IndexOf(
   System.object value
)

Parameters

value
The page to locate in the collection.

Return Value

The index of value if found in the list; otherwise, -1.
See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


IndexOf(Page) Method

IndexOf(Page) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > IndexOf Method : IndexOf(Page) Method
The page to locate in the collection.
Returns the zero-based index of the first occurrence of the Page object in the PagesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function IndexOf( _
   ByVal value As Page _
) As System.Integer
public System.int IndexOf(
   Page value
)

Parameters

value
The page to locate in the collection.
See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


Insert Method (PagesCollection)

Insert Method (PagesCollection)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : Insert Method
Inserts the specified page into the collection at the specified index.
Overload List
Overload | Description
Insert(Int32,Object) | Inserts a Page object element into the PagesCollection at the specified index.
Insert(Int32,Page) | Inserts a Page element into the PagesCollection at the specified index.
Example
  • C#
private void Form1_Load(object sender, System.EventArgs e)
{
    rptInsertPage rpt = new rptInsertPage();
    rptCoverPage rpt2 = new rptCoverPage();
    viewer1.Document = rpt.Document;
    rpt.Run();
    rpt2.Run();
    rpt.Document.Pages.Insert(0, rpt2.Document.Pages[0]);
}
  • Visual Basic
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New rptInsertPage()
    Viewer1.Document = rpt.Document    rpt.Run()
    Dim rpt2 As New rptCoverPage()
    rpt2.Run()
    rpt.Document.Pages.Insert(0, rpt2.Document.Pages(0))
End Sub
See Also

Reference

PagesCollection Class
PagesCollection Members

How To

Insert or Add Pages


Insert(Int32,Object) Method

Insert(Int32,Object) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > Insert Method : Insert(Int32,Object) Method
The zero based index at which value should be inserted.
The page to insert.
Inserts a Page object element into the PagesCollection at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As System.Object _
)
public void Insert(
   System.int index,
   System.object value
)

Parameters

index
The zero based index at which value should be inserted.
value
The page to insert.
See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


Insert(Int32,Page) Method

Insert(Int32,Page) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > Insert Method : Insert(Int32,Page) Method
The zero based index at which value should be inserted.
The page to insert.
Inserts a Page element into the PagesCollection at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As Page _
)
public void Insert(
   System.int index,
   Page value
)

Parameters

index
The zero based index at which value should be inserted.
value
The page to insert.
See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


InsertNew Method

InsertNew Method
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : InsertNew Method
Index of the new page.
Creates a new Page object and inserts it into the collection at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InsertNew( _
   ByVal index As System.Integer _
) As Page
public Page InsertNew(
   System.int index
)

Parameters

index
Index of the new page.
Example
  • C#
Private void Form1_Load(object sender, System.EventArgs e)
{
    rptInsertPage rpt = New rptInsertPage();
    viewer1.Document = rpt.Document;
    rpt.Run();
    rpt.Document.Pages.InsertNew(3);
}
  • Visual Basic
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New rptInsertPage()
    Viewer1.Document = rpt.Document    rpt.Run()
    rpt.Document.Pages.InsertNew(3)
End Sub
See Also

Reference

PagesCollection Class
PagesCollection Members

How To

Insert or Add Pages


InsertRange Method (PagesCollection)

InsertRange Method (PagesCollection)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : InsertRange Method
Inserts a range of pages into the collection at a specified position.
Overload List
Overload | Description
InsertRange(Int32,PagesCollection) | Inserts the members of the specified PagesCollection into the collection at the specified index.
InsertRange(Int32,Page[]) | Inserts an array of Page objects into the collection at the specified index.
Example
  • C#
private void button1_Click(object sender, System.EventArgs e)
{
    GrapeCity.ActiveReports.ActiveReport merge = new GrapeCity.ActiveReports.SectionReport();
    GrapeCity.ActiveReports.Document.Document fRdf = new GrapeCity.ActiveReports.Document.SectionDocument();
    fRdf.Load(@"C:\a.rdf");
    merge.Document.Pages.InsertRange(merge.Document.Pages.Count, fRdf.Pages);
    fRdf.Load(@"C:\b.rdf");
    merge.Document.Pages.InsertRange(merge.Document.Pages.Count, fRdf.Pages);
    arv.Document = merge.Document;
}
  • Visual Basic
Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim merge As New GrapeCity.ActiveReports.SectionReport
    Dim fRdf As New GrapeCity.ActiveReports.Document.SectionDocument
    fRdf.Load("C:\a.rdf")
    merge.Document.Pages.InsertRange(merge.Document.Pages.Count, fRdf.Pages)
    fRdf.Load("C:\b.rdf")
    merge.Document.Pages.InsertRange(merge.Document.Pages.Count, fRdf.Pages)
    Me.arv.Document = merge.Document
End Sub
See Also

Reference

PagesCollection Class
PagesCollection Members


InsertRange(Int32,PagesCollection) Method

InsertRange(Int32,PagesCollection) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > InsertRange Method : InsertRange(Int32,PagesCollection) Method
A zero-based index in the collection where the pages collection will be inserted.
The pages array whose elements should be inserted into the current pages collection.
Inserts the members of the specified PagesCollection into the collection at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub InsertRange( _
   ByVal index As System.Integer, _
   ByVal pages As PagesCollection _
)
public void InsertRange(
   System.int index,
   PagesCollection pages
)

Parameters

index
A zero-based index in the collection where the pages collection will be inserted.
pages
The pages array whose elements should be inserted into the current pages collection.
See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


InsertRange(Int32,Page[]) Method

InsertRange(Int32,Page[]) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > InsertRange Method : InsertRange(Int32,Page[]) Method
A zero-based index in the collection where the pages array will be inserted.
The pages array whose elements should be inserted into the current pages collection.
Inserts an array of Page objects into the collection at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub InsertRange( _
   ByVal index As System.Integer, _
   ByVal pages() As Page _
)
public void InsertRange(
   System.int index,
   Page[] pages
)

Parameters

index
A zero-based index in the collection where the pages array will be inserted.
pages
The pages array whose elements should be inserted into the current pages collection.
See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


Remove Method (PagesCollection)

Remove Method (PagesCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : Remove Method
Removes the specified page object from the collection.
Overload List
Overload | Description
Remove(Object) | Removes the specified page object from the collection.
Remove(Page) | Removes the first occurrence of Page object from the PagesCollection.
See Also

Reference

PagesCollection Class
PagesCollection Members


Remove(Object) Method

Remove(Object) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > Remove Method : Remove(Object) Method
The page to remove from the collection.
Removes the specified page object from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Remove( _
   ByVal value As System.Object _
)
public void Remove(
   System.object value
)

Parameters

value
The page to remove from the collection.
See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


Remove(Page) Method

Remove(Page) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class > Remove Method : Remove(Page) Method
The page to remove from the current pages collection.
Removes the first occurrence of Page object from the PagesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Remove( _
   ByVal page As Page _
)
public void Remove(
   Page page
)

Parameters

page
The page to remove from the current pages collection.
See Also

Reference

PagesCollection Class
PagesCollection Members
Overload List


RemoveAt Method (PagesCollection)

RemoveAt Method (PagesCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : RemoveAt Method

A zero-based index of the page to be removed.

Removes the page at the specified index from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index

A zero-based index of the page to be removed.

See Also

Reference

PagesCollection Class
PagesCollection Members


PagesCollection Class Properties

PagesCollection Class Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PagesCollection Class

For a list of all members of this type, see PagesCollection members.

Public Properties
 | Name | Description
Public Property | Count | Returns the number of Page members in the collection.
Public Property | Fonts | Returns the FontsCollection that is used in the PagesCollection.
Public Property | IsFixedSize | Gets a value indicating whether the PagesCollection has a fixed size.
Public Property | IsReadOnly | Gets a value indicating whether the PagesCollection is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the PagesCollection is synchronized (thread safe). (Inherited from ICollection.)
Public Property | Item | Returns the member at the specified index in the collection.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the PagesCollection.
Top
See Also

Reference

PagesCollection Class
GrapeCity.ActiveReports.Document.Section Namespace


Count Property (PagesCollection)

Count Property (PagesCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : Count Property
Returns the number of Page members in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}

Property Value

Integer value that represents the number of pages in the collection.

See Also

Reference

PagesCollection Class
PagesCollection Members


Fonts Property (PagesCollection)

Fonts Property (PagesCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : Fonts Property
Returns the FontsCollection that is used in the PagesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Fonts As FontsCollection
public FontsCollection Fonts {get;}
See Also

Reference

PagesCollection Class
PagesCollection Members


IsFixedSize Property (PagesCollection)

IsFixedSize Property (PagesCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : IsFixedSize Property
Gets a value indicating whether the PagesCollection has a fixed size.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsFixedSize As System.Boolean
public System.bool IsFixedSize {get;}

Property Value

true if this instance is fixed size; otherwise, false.
See Also

Reference

PagesCollection Class
PagesCollection Members


IsReadOnly Property (PagesCollection)

IsReadOnly Property (PagesCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : IsReadOnly Property
Gets a value indicating whether the PagesCollection is read-only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsReadOnly As System.Boolean
public System.bool IsReadOnly {get;}

Property Value

true if this instance is read only; otherwise, false.
See Also

Reference

PagesCollection Class
PagesCollection Members


IsSynchronized Property (PagesCollection)

IsSynchronized Property (PagesCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : IsSynchronized Property
Gets a value indicating whether access to the PagesCollection is synchronized (thread safe). (Inherited from ICollection.)
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsSynchronized As System.Boolean
public System.bool IsSynchronized {get;}

Property Value

true if this instance is synchronized; otherwise, false.
See Also

Reference

PagesCollection Class
PagesCollection Members


Item Property (PagesCollection)

Item Property (PagesCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : Item Property
Index of the member to be returned.
Returns the member at the specified index in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As Page
public Page this[
   System.int index
]; {get;}

Parameters

index
Index of the member to be returned.

Property Value

Page object at the specified index.
See Also

Reference

PagesCollection Class
PagesCollection Members


SyncRoot Property (PagesCollection)

SyncRoot Property (PagesCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : SyncRoot Property
Gets an object that can be used to synchronize access to the PagesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property SyncRoot As System.Object
public System.object SyncRoot {get;}

Property Value

The synchronize root.
See Also

Reference

PagesCollection Class
PagesCollection Members


RText.TabStop Class

RText.TabStop Class
Members

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : RText.TabStop Class
Represents the custom tab stop.
Object Model
RText.TabStop Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class RText.TabStop
public sealed class RText.TabStop
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.RText.TabStop

See Also

Reference

RText.TabStop Members
GrapeCity.ActiveReports.Document.Section Namespace


RText.TabStop Class Members

RText.TabStop Class Members
Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : RText.TabStop Class

The following tables list the members exposed by RText.TabStop.

Public Properties
 | Name | Description
Public Property | LeadingChar | Specifies the character which shall be used to fill in the space created by a tab which ends at this tab stop.
Public Property | Position | Specifies the position (in inches) of the current tab stop.
Public Property | Type | Specifies the type of tab stop.
Top
See Also

Reference

RText.TabStop Class
GrapeCity.ActiveReports.Document.Section Namespace


RText.TabStop Class Properties

RText.TabStop Class Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : RText.TabStop Class

For a list of all members of this type, see RText.TabStop members.

Public Properties
 | Name | Description
Public Property | LeadingChar | Specifies the character which shall be used to fill in the space created by a tab which ends at this tab stop.
Public Property | Position | Specifies the position (in inches) of the current tab stop.
Public Property | Type | Specifies the type of tab stop.
Top
See Also

Reference

RText.TabStop Class
GrapeCity.ActiveReports.Document.Section Namespace


LeadingChar Property (RText.TabStop)

LeadingChar Property (RText.TabStop)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RText.TabStop Class : LeadingChar Property
Specifies the character which shall be used to fill in the space created by a tab which ends at this tab stop.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property LeadingChar As System.String
public System.string LeadingChar {get;}
See Also

Reference

RText.TabStop Class
RText.TabStop Members


Position Property (RText.TabStop)

Position Property (RText.TabStop)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RText.TabStop Class : Position Property
Specifies the position (in inches) of the current tab stop.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Position As System.Single
public System.float Position {get;}
See Also

Reference

RText.TabStop Class
RText.TabStop Members


Type Property (RText.TabStop)

Type Property (RText.TabStop)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > RText.TabStop Class : Type Property
Specifies the type of tab stop.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Type As RText.TabType
public RText.TabType Type {get;}
See Also

Reference

RText.TabStop Class
RText.TabStop Members


StringFormatProvider Class

StringFormatProvider Class
Members

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : StringFormatProvider Class
Provide local factory which create own instances of StringFormat.GenericDefault and StringFormat.GenericTypographic, independent of changes in GDI+ StringFormat getter factories.
Object Model
StringFormatProvider Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class StringFormatProvider
public sealed class StringFormatProvider
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.StringFormatProvider

See Also

Reference

StringFormatProvider Members
GrapeCity.ActiveReports.Document.Section Namespace


StringFormatProvider Class Members

StringFormatProvider Class Members
Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : StringFormatProvider Class

The following tables list the members exposed by StringFormatProvider.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | GetGenericDefault | Creates new instance of StringFormat with parameters, identical to GDI+ StringFormat.GenericDefault.
static (Shared in Visual Basic) | GetGenericTypographic | Creates new instance of StringFormat with parameters, identical to GDI+ StringFormat.GenericTypographic.
Top
See Also

Reference

StringFormatProvider Class
GrapeCity.ActiveReports.Document.Section Namespace


StringFormatProvider Class Methods

StringFormatProvider Class Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : StringFormatProvider Class

For a list of all members of this type, see StringFormatProvider members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | GetGenericDefault | Creates new instance of StringFormat with parameters, identical to GDI+ StringFormat.GenericDefault.
static (Shared in Visual Basic) | GetGenericTypographic | Creates new instance of StringFormat with parameters, identical to GDI+ StringFormat.GenericTypographic.
Top
See Also

Reference

StringFormatProvider Class
GrapeCity.ActiveReports.Document.Section Namespace


GetGenericDefault Method

GetGenericDefault Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > StringFormatProvider Class : GetGenericDefault Method
Creates new instance of StringFormat with parameters, identical to GDI+ StringFormat.GenericDefault.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function GetGenericDefault() As StringFormat
public static StringFormat GetGenericDefault()

Return Value

GenericDefault string format
See Also

Reference

StringFormatProvider Class
StringFormatProvider Members


GetGenericTypographic Method

GetGenericTypographic Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > StringFormatProvider Class : GetGenericTypographic Method
Creates new instance of StringFormat with parameters, identical to GDI+ StringFormat.GenericTypographic.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function GetGenericTypographic() As StringFormat
public static StringFormat GetGenericTypographic()

Return Value

GenericTypographic string format
See Also

Reference

StringFormatProvider Class
StringFormatProvider Members


UrlErrorEventArgs Class

UrlErrorEventArgs Class
Members

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : UrlErrorEventArgs Class
Specifies the arguments of a downloadError event.
Object Model
UrlErrorEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class UrlErrorEventArgs
   Inherits System.EventArgs
public class UrlErrorEventArgs : System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Document.Section.UrlErrorEventArgs

See Also

Reference

UrlErrorEventArgs Members
GrapeCity.ActiveReports.Document.Section Namespace


UrlErrorEventArgs Class Members

UrlErrorEventArgs Class Members
Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : UrlErrorEventArgs Class

The following tables list the members exposed by UrlErrorEventArgs.

Public Constructors
 | Name | Description
Public Constructor | UrlErrorEventArgs Constructor | Overloaded. Creates a new instance of the UrlErrorEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Exception | Gets or sets a value that specifies the exception that caused the download error.
Top
See Also

Reference

UrlErrorEventArgs Class
GrapeCity.ActiveReports.Document.Section Namespace


UrlErrorEventArgs Constructor

UrlErrorEventArgs Constructor

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UrlErrorEventArgs Class : UrlErrorEventArgs Constructor
Creates a new instance of the UrlErrorEventArgs class.
Overload List
Overload | Description
UrlErrorEventArgs Constructor() | Creates a new instance of the UrlErrorEventArgs class.
UrlErrorEventArgs Constructor(Exception) | Initializes a new instance of the UrlErrorEventArgs class with the exception thrown.
See Also

Reference

UrlErrorEventArgs Class
UrlErrorEventArgs Members


UrlErrorEventArgs Constructor()

UrlErrorEventArgs Constructor()

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UrlErrorEventArgs Class > UrlErrorEventArgs Constructor : UrlErrorEventArgs Constructor()
Creates a new instance of the UrlErrorEventArgs class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public UrlErrorEventArgs()
See Also

Reference

UrlErrorEventArgs Class
UrlErrorEventArgs Members
Overload List


UrlErrorEventArgs Constructor(Exception)

UrlErrorEventArgs Constructor(Exception)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UrlErrorEventArgs Class > UrlErrorEventArgs Constructor : UrlErrorEventArgs Constructor(Exception)
A value that represents the exception.
Initializes a new instance of the UrlErrorEventArgs class with the exception thrown.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal e As System.Exception _
)
public UrlErrorEventArgs(
   System.Exception e
)

Parameters

e
A value that represents the exception.
See Also

Reference

UrlErrorEventArgs Class
UrlErrorEventArgs Members
Overload List


UrlErrorEventArgs Class Properties

UrlErrorEventArgs Class Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : UrlErrorEventArgs Class

For a list of all members of this type, see UrlErrorEventArgs members.

Public Properties
 | Name | Description
Public Property | Exception | Gets or sets a value that specifies the exception that caused the download error.
Top
See Also

Reference

UrlErrorEventArgs Class
GrapeCity.ActiveReports.Document.Section Namespace


Exception Property (UrlErrorEventArgs)

Exception Property (UrlErrorEventArgs)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UrlErrorEventArgs Class : Exception Property

Gets or sets a value that specifies the exception that caused the download error.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Exception As System.Exception
public System.Exception Exception {get;}

Property Value

The exception.
See Also

Reference

UrlErrorEventArgs Class
UrlErrorEventArgs Members


UserPreferences Class

UserPreferences Class
Members Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : UserPreferences Class
Specifies the look of hyperlinks and the controls that host them in the Viewer control.
Object Model
UserPreferences Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class UserPreferences
public class UserPreferences
Example
  • C#
private void myForm_Load(object sender, System.EventArgs e)
{
    rptKewl rpt = new rptKewl();
    rpt.Run();
    this.arViewer.Document = rpt.Document;

    this.arViewer.ReportViewer.HyperLinkBackColor = Color.Transparent;
    this.arViewer.ReportViewer.HyperLinkForeColor = Color.Aquamarine;
    this.arViewer.ReportViewer.HyperLinkUnderline = false;
    this.arViewer.ReportViewer.SearchResultsBackColor = Color.AliceBlue;
    this.arViewer.ReportViewer.SearchResultsForeColor = Color.Coral;
}
  • Visual Basic
Private Sub myForm_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New rptKewl
    rpt.Run
    Me.arViewer.Document = rpt.Document

    Me.arViewer.ReportViewer.HyperLinkBackColor = Color.Transparent;
    Me.arViewer.ReportViewer.HyperLinkForeColor = Color.Aquamarine;
    Me.arViewer.ReportViewer.HyperLinkUnderline = False;
    Me.arViewer.ReportViewer.SearchResultsBackColor = Color.AliceBlue;
    Me.arViewer.ReportViewer.SearchResultsForeColor = Color.Coral;
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.UserPreferences

See Also

Reference

UserPreferences Members
GrapeCity.ActiveReports.Document.Section Namespace


UserPreferences Class Members

UserPreferences Class Members
Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : UserPreferences Class

The following tables list the members exposed by UserPreferences.

Public Constructors
 | Name | Description
Public Constructor | UserPreferences Constructor | Initializes a new instance of the UserPreference class.
Top
Public Properties
 | Name | Description
Public Property | HyperLinkBackColor | Gets or sets the background color of the controls that hosts a hyperlink. The default is transparent.
Public Property | HyperLinkForeColor | Gets or sets the color of the text within a control that hosts a hyperlink. The default is Blue.
Public Property | HyperLinkUnderline | Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true.
Public Property | SearchResultsBackColor | Gets or sets the background color of the highlighted text when using the Viewer control's Find dialog.
Public Property | SearchResultsForeColor | Gets or sets the color of the highlighted text when using the Viewer control's Find dialog.
Public Property | UseHyperLinkSettings | If True, these settings will be applied to links. Otherwise, each link will be displayed according to their own settings.
Top
See Also

Reference

UserPreferences Class
GrapeCity.ActiveReports.Document.Section Namespace


UserPreferences Constructor

UserPreferences Constructor

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UserPreferences Class : UserPreferences Constructor
Initializes a new instance of the UserPreference class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public UserPreferences()
See Also

Reference

UserPreferences Class
UserPreferences Members


UserPreferences Class Properties

UserPreferences Class Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : UserPreferences Class

For a list of all members of this type, see UserPreferences members.

Public Properties
 | Name | Description
Public Property | HyperLinkBackColor | Gets or sets the background color of the controls that hosts a hyperlink. The default is transparent.
Public Property | HyperLinkForeColor | Gets or sets the color of the text within a control that hosts a hyperlink. The default is Blue.
Public Property | HyperLinkUnderline | Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true.
Public Property | SearchResultsBackColor | Gets or sets the background color of the highlighted text when using the Viewer control's Find dialog.
Public Property | SearchResultsForeColor | Gets or sets the color of the highlighted text when using the Viewer control's Find dialog.
Public Property | UseHyperLinkSettings | If True, these settings will be applied to links. Otherwise, each link will be displayed according to their own settings.
Top
See Also

Reference

UserPreferences Class
GrapeCity.ActiveReports.Document.Section Namespace


HyperLinkBackColor Property (UserPreferences)

HyperLinkBackColor Property (UserPreferences)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UserPreferences Class : HyperLinkBackColor Property
Gets or sets the background color of the controls that hosts a hyperlink. The default is transparent.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HyperLinkBackColor As Color
public Color HyperLinkBackColor {get; set;}

Property Value

The color of the hyper link back.
See Also

Reference

UserPreferences Class
UserPreferences Members


HyperLinkForeColor Property (UserPreferences)

HyperLinkForeColor Property (UserPreferences)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UserPreferences Class : HyperLinkForeColor Property
Gets or sets the color of the text within a control that hosts a hyperlink. The default is Blue.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HyperLinkForeColor As Color
public Color HyperLinkForeColor {get; set;}

Property Value

The color of the hyper link fore.
See Also

Reference

UserPreferences Class
UserPreferences Members


HyperLinkUnderline Property (UserPreferences)

HyperLinkUnderline Property (UserPreferences)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UserPreferences Class : HyperLinkUnderline Property
Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HyperLinkUnderline As System.Boolean
public System.bool HyperLinkUnderline {get; set;}

Property Value

true if [hyper link underline]; otherwise, false.
See Also

Reference

UserPreferences Class
UserPreferences Members


SearchResultsBackColor Property (UserPreferences)

SearchResultsBackColor Property (UserPreferences)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UserPreferences Class : SearchResultsBackColor Property
Gets or sets the background color of the highlighted text when using the Viewer control's Find dialog.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SearchResultsBackColor As Color
public Color SearchResultsBackColor {get; set;}

Property Value

The color of the search results back.
See Also

Reference

UserPreferences Class
UserPreferences Members


SearchResultsForeColor Property (UserPreferences)

SearchResultsForeColor Property (UserPreferences)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UserPreferences Class : SearchResultsForeColor Property
Gets or sets the color of the highlighted text when using the Viewer control's Find dialog.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SearchResultsForeColor As Color
public Color SearchResultsForeColor {get; set;}

Property Value

The color of the search results fore.
See Also

Reference

UserPreferences Class
UserPreferences Members


UseHyperLinkSettings Property (UserPreferences)

UseHyperLinkSettings Property (UserPreferences)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > UserPreferences Class : UseHyperLinkSettings Property
If True, these settings will be applied to links. Otherwise, each link will be displayed according to their own settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseHyperLinkSettings As System.Boolean
public System.bool UseHyperLinkSettings {get; set;}
See Also

Reference

UserPreferences Class
UserPreferences Members


BackgroundStyle Enumeration

BackgroundStyle Enumeration

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : BackgroundStyle Enumeration
Specifies the background style when using the low level page drawing APIs.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum BackgroundStyle
   Inherits System.Enum
public enum BackgroundStyle : System.Enum
Members
Member | Description
Opaque | Filled background, objects in the background will not show through.
Transparent | Background is transparent, objects in the background will show through.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.BackgroundStyle

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


PageOrientation Enumeration

PageOrientation Enumeration

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PageOrientation Enumeration
Specifies the orientation of a page when rendered to the printer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PageOrientation
   Inherits System.Enum
public enum PageOrientation : System.Enum
Members
Member | Description
Default | Follow printer default setting.
Landscape | Print pages in landscape.
Portrait | Print pages in portrait.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.PageOrientation

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace
Page.Orientation Property


PenStyles Enumeration

PenStyles Enumeration

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : PenStyles Enumeration
Specifies the pen style used to draw lines on a page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PenStyles
   Inherits System.Enum
public enum PenStyles : System.Enum
Members
Member | Description
Dash | Dashed line.
DashDot | Dash dot line.
DashDotDot | Dash dot dot line.
Dot | Dotted line.
Solid | Solid line.
Transparent | No line.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.PenStyles

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


RdfFormat Enumeration

RdfFormat Enumeration

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : RdfFormat Enumeration
Specifies the file format used to save the report document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum RdfFormat
   Inherits System.Enum
public enum RdfFormat : System.Enum
Members
Member | Description
AR20 | ActiveReports 2.0 file format.
ARNet | ActiveReports for .NET 2.0 file format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.RdfFormat

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace
Document.Save Method


RText.TabType Enumeration

RText.TabType Enumeration

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : RText.TabType Enumeration
Specifies tab stop types.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum RText.TabType
   Inherits System.Enum
public enum RText.TabType : System.Enum
Members
Member | Description
Center | The center
Left | The left
Right | The right
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.RText.TabType

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


SaveOptions Enumeration

SaveOptions Enumeration

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : SaveOptions Enumeration
Specifies the compression type used to save the report document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum SaveOptions
   Inherits System.Enum
public enum SaveOptions : System.Enum
Members
Member | Description
Compressed | Saves the RDF as a compressed file.
Normal | Saves the RDF as an uncompressed file.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.SaveOptions

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace
Document.Save Method


TextAlignment Enumeration

TextAlignment Enumeration

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TextAlignment Enumeration
Specifies the horizontal alignment of text within the control area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TextAlignment
   Inherits System.Enum
public enum TextAlignment : System.Enum
Members
Member | Description
Center | Text is centered within the control area.
Justify | Text is fully justified on left and right edges of the control.
Left | Text is aligned to the left edge of the control.
Right | Text is aligned to the right edge of the control.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.TextAlignment

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


TextJustify Enumeration

TextJustify Enumeration

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : TextJustify Enumeration
Specifies how to justify text when the TextAlignment property is set to Justify.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TextJustify
   Inherits System.Enum
public enum TextJustify : System.Enum
Members
Member | Description
Auto | Allows ActiveReports to determine which type to use.
Distribute | Increases or decreases spacing between letters and words, and is optimized for Asian language characters.
DistributeAllLines | Same as Distribute, but also increases spacing between letters and words in the last line of a paragraph.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.TextJustify

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


Units Enumeration

Units Enumeration

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : Units Enumeration
Specifies the document measurement units when using low level drawing API on a document page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Units
   Inherits System.Enum
public enum Units : System.Enum
Members
Member | Description
Centimeters | Page drawing method parameters are specified in centimeters.
Document | Page drawing method parameters are specified in document units.
Inches | Page drawing method parameters are specified in inches.
Pixels | Page drawing method parameters are specified in pixels.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.Units

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace
Units Property


VerticalTextAlignment Enumeration

VerticalTextAlignment Enumeration

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : VerticalTextAlignment Enumeration
Specifies the vertical alignment of text within the control area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum VerticalTextAlignment
   Inherits System.Enum
public enum VerticalTextAlignment : System.Enum
Members
Member | Description
Bottom | Text is aligned to the bottom of the control area.
Middle | Text is aligned in the middle of the control area.
Top | Text is aligned to the top of the control area.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.VerticalTextAlignment

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


WrapMode Enumeration

WrapMode Enumeration

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : WrapMode Enumeration
Specifies whether the text is written from left to right or right to left.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum WrapMode
   Inherits System.Enum
public enum WrapMode : System.Enum
Members
Member | Description
CharWrap | Per-character wrapping mode.
NoWrap | No text wrap.
WordWrap | Wrap by word boundaries
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.WrapMode

See Also

Reference

GrapeCity.ActiveReports.Document.Section Namespace


UrlErrorEventHandler Delegate

UrlErrorEventHandler Delegate

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : UrlErrorEventHandler Delegate

Source of the event.

UrlErrorEventArgs value that contains the event data.
Represents the method that will handle the downloadError event of a Document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub UrlErrorEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As UrlErrorEventArgs _
)
public delegate void UrlErrorEventHandler(
   System.object sender,
   UrlErrorEventArgs e
)

Parameters

sender

Source of the event.

e
UrlErrorEventArgs value that contains the event data.
See Also

Reference

UrlErrorEventHandler Members
GrapeCity.ActiveReports.Document.Section Namespace


GrapeCity.ActiveReports.Document.Section.Annotations Namespace

GrapeCity.ActiveReports.Document.Section.Annotations Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Document.v10 Assembly : GrapeCity.ActiveReports.Document.Section.Annotations Namespace
The GrapeCity.ActiveReports.Document.Section.Annotations namespace contains the Annotations classes and its settings.
Classes
 | Class | Description
Class | Annotation | Annotation is the base class for Annotation objects.
Class | AnnotationArrow | Represents the AnnotationArrow object.
Class | AnnotationBalloon | Represents the AnnotationBalloon object.
Class | AnnotationBaseText | Represents the base class for all of the Annotation objects.
Class | AnnotationCircle | Represents a circular Annotation object.
Class | AnnotationCollection | Represents a collection of Annotation objects.
Class | AnnotationImage | Represents the AnnotationImage object.
Class | AnnotationLine | Represents the AnnotationLine object.
Class | AnnotationRectangle | Represents the rectangular Annotation object.
Class | AnnotationText | Represents the characteristics of the text of the Annotation object.
Class | BorderCircle | Draws a border around an AnnotationCircle.
Class | BorderRectangle | Draws a border around an AnnotationRectangle.
Enumerations
 | Enumeration | Description
Enumeration | AnnotationBalloon.BallonQuadrant | Specifies the location of the balloon tail relative to the AnnotationBalloon object.
Enumeration | AnnotationLine.LinePlacement | Specifies the location relative to the Annotation object in which the line will be drawn.
Enumeration | AnnotationLine.ShowArrowCap | Specifies the location of the arrow cap on the AnnotationLine.
Enumeration | ArrowDirection | Specifies the direction in which the arrow points.
Enumeration | ImageLayout | Specifies the positioning for Annotation Images.
See Also

Reference

GrapeCity.ActiveReports.Document.v10 Assembly


Annotation Class

Annotation Class
Members Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : Annotation Class
Annotation is the base class for Annotation objects.
Object Model
Annotation Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Annotation
   Inherits System.ComponentModel.Component
public class Annotation : System.ComponentModel.Component
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations;

rptAnnotations rpt = new rptAnnotations();
private void AddAnnotations()
{
   //Run the report first
   rpt.Run();

   //Assign the viewer
   this.viewer1.Document = rpt.Document;

   //Create an annotation and assign property values
   AnnotationCircle circle = new AnnotationCircle();
   circle.Color = System.Drawing.Color.GreenYellow;
   circle.Border.Color = System.Drawing.Color.Chartreuse;

   //Add the annotation
   circle.Attach(1,1); //screen location
   this.viewer1.Document.Pages[0].Annotations.Add(circle);

   //Set the size properties. The annotation must be added to the page first.
   circle.Height = 0.25f;
   circle.Width = 0.50f;

   //Save annotations to an RDF file
   rpt.Document.Save("C:\\MyAnnotations.rdf");
}
  • Visual Basic
Dim rpt As New rptAnnotations
Private Sub AddAnnotations()
   'Run the report first
   rpt.Run()

   'Assign the viewer
   Me.Viewer1.Document = rpt.Document

   'Create an annotation and assign property values
   Dim circle As New AnnotationCircle
   circle.Color = System.Drawing.Color.GreenYellow
   circle.Border.Color = System.Drawing.Color.Chartreuse

   'Add the annotation
   circle.Attach(1,1) 'screen location
   Me.Viewer1.Document.Pages(0).Annotations.Add(circle)

   'Set the size properties. The annotation must be added to the page first.
   circle.Height = 0.25
   circle.Width = 0.50

   'Save annotations to an RDF file
   rpt.Document.Save("C:\\MyAnnotations.rdf")
End Sub
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationCircle
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationLine
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationRectangle

See Also

Reference

Annotation Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Annotation Class Members

Annotation Class Members
Properties Methods Events

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : Annotation Class

The following tables list the members exposed by Annotation.

Public Properties
 | Name | Description
Public Property | Alpha | Gets or sets the opacity of the Annotation object.
Public Property | Border | Gets the border for the annotation object.
Public Property | Color | Gets or sets the color that is used to fill the annotation object.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Height | Gets or sets the height of the annotation object, in inches.
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Width | Gets or sets the width of the annotation object, in inches.
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation.
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation.
Top
Public Methods
 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Annotation Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Annotation Class Methods

Annotation Class Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : Annotation Class

For a list of all members of this type, see Annotation members.

Public Methods
 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Annotation Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Attach Method

Attach Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Attach Method
The x coordinate for the annotation object.
The y coordinate for the annotation object.
Sets the top left most coordinates for the annotation object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Attach( _
   ByVal x As System.Single, _
   ByVal y As System.Single _
)
public void Attach(
   System.float x,
   System.float y
)

Parameters

x
The x coordinate for the annotation object.
y
The y coordinate for the annotation object.
See Also

Reference

Annotation Class
Annotation Members


Refresh Method (Annotation)

Refresh Method (Annotation)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Refresh Method
Refreshes the display of the annotation object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub Refresh()
public virtual void Refresh()
See Also

Reference

Annotation Class
Annotation Members


Annotation Class Properties

Annotation Class Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : Annotation Class

For a list of all members of this type, see Annotation members.

Public Properties
 | Name | Description
Public Property | Alpha | Gets or sets the opacity of the Annotation object.
Public Property | Border | Gets the border for the annotation object.
Public Property | Color | Gets or sets the color that is used to fill the annotation object.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Height | Gets or sets the height of the annotation object, in inches.
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Width | Gets or sets the width of the annotation object, in inches.
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation.
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation.
Top
See Also

Reference

Annotation Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Alpha Property (Annotation)

Alpha Property (Annotation)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Alpha Property
Gets or sets the opacity of the Annotation object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Alpha As System.Integer
public virtual System.int Alpha {get; set;}
Remarks
Acceptable values are 0 to 255.
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations;

rptAnnotations rpt = new rptAnnotations();
private void AddAnnotations()
{
   //Run the report first
   rpt.Run();

   //Assign the viewer
   this.viewer1.Document = rpt.Document;

   //Create an annotation and assign property values
   AnnotationCircle circle = new AnnotationCircle();
   circle.Color = System.Drawing.Color.GreenYellow;
   circle.Border.Color = System.Drawing.Color.Chartreuse;
   circle.Alpha = 150;

   //Add the annotation
   circle.Attach(1,1); //screen location
   this.viewer1.Document.Pages[0].Annotations.Add(circle);

   //Set the size properties. The annotation must be added to the page first.
   circle.Height = 0.25f;
   circle.Width = 0.50f;

   //Save annotations to an RDF file
   rpt.Document.Save("C:\\MyAnnotations.rdf");
}
  • Visual Basic
Private rpt As New rptAnnotations()
Private Sub AddAnnotations()
'Run the report first
rpt.Run()

'Assign the viewer
Me.viewer1.Document = rpt.Document

'Create an annotation and assign property values
Dim circle As New AnnotationCircle()
circle.Color = System.Drawing.Color.GreenYellow
circle.Border.Color = System.Drawing.Color.Chartreuse
circle.Alpha = 150

'Add the annotation
circle.Attach(1, 1)
'screen location
Me.viewer1.Document.Pages(0).Annotations.Add(circle)

'Set the size properties. The annotation must be added to the page first.
circle.Height = 0.25F
circle.Width = 0.5F

'Save annotations to an RDF file
rpt.Document.Save("C:\MyAnnotations.rdf")

End Sub
See Also

Reference

Annotation Class
Annotation Members


Border Property (Annotation)

Border Property (Annotation)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Border Property
Gets the border for the annotation object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Border As Border
public virtual Border Border {get;}

Property Value

The Border property allows you to access the border object for the annotation object.
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations;

rptAnnotations rpt = new rptAnnotations();
private void AddAnnotations()
{
   //Run the report first
   rpt.Run();

   //Assign the viewer
   this.viewer1.Document = rpt.Document;

   //Create an annotation and assign property values
   AnnotationCircle circle = new AnnotationCircle();
   circle.Color = System.Drawing.Color.GreenYellow;
   circle.Border.Color = System.Drawing.Color.Chartreuse;

   //Add the annotation
   circle.Attach(1,1); //screen location
   this.viewer1.Document.Pages[0].Annotations.Add(circle);

   //Set the size properties. The annotation must be added to the page first.
   circle.Height = 0.25f;
   circle.Width = 0.50f;

   //Save annotations to an RDF file
   rpt.Document.Save("C:\\MyAnnotations.rdf");
}
  • Visual Basic
Private rpt As New rptAnnotations()
Private Sub AddAnnotations()
    'Run the report first
    rpt.Run()

    'Assign the viewer
    Me.viewer1.Document = rpt.Document

    'Create an annotation and assign property values
    Dim circle As New AnnotationCircle()
    circle.Color = System.Drawing.Color.GreenYellow
    circle.Border.Color = System.Drawing.Color.Chartreuse

    'Add the annotation
    circle.Attach(1, 1)
    'screen location
    Me.viewer1.Document.Pages(0).Annotations.Add(circle)

    'Set the size properties. The annotation must be added to the page first.
    circle.Height = 0.25F
    circle.Width = 0.5F

    'Save annotations to an RDF file
    rpt.Document.Save("C:\MyAnnotations.rdf")
End Sub
See Also

Reference

Annotation Class
Annotation Members


Color Property (Annotation)

Color Property (Annotation)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Color Property
Gets or sets the color that is used to fill the annotation object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Color As Color
public virtual Color Color {get; set;}

Property Value

The color used to fill the annotation object.
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations;

rptAnnotations rpt = new rptAnnotations();
private void AddAnnotations()
{
   //Run the report first
   rpt.Run();

   //Assign the viewer
   this.viewer1.Document = rpt.Document;

   //Create an annotation and assign property values
   AnnotationCircle circle = new AnnotationCircle();
   circle.Color = System.Drawing.Color.GreenYellow;
   circle.Border.Color = System.Drawing.Color.Chartreuse;

   //Add the annotation
   circle.Attach(1,1); //screen location
   this.viewer1.Document.Pages[0].Annotations.Add(circle);

   //Set the size properties. The annotation must be added to the page first.
   circle.Height = 0.25f;
   circle.Width = 0.50f;

   //Save annotations to an RDF file
   rpt.Document.Save("C:\\MyAnnotations.rdf");
}
  • Visual Basic
Private rpt As New rptAnnotations()
Private Sub AddAnnotations()
    'Run the report first
    rpt.Run()

    'Assign the viewer
    Me.viewer1.Document = rpt.Document

    'Create an annotation and assign property values
    Dim circle As New AnnotationCircle()
    circle.Color = System.Drawing.Color.GreenYellow
    circle.Border.Color = System.Drawing.Color.Chartreuse

    'Add the annotation
    circle.Attach(1, 1)
    'screen location
    Me.viewer1.Document.Pages(0).Annotations.Add(circle)

    'Set the size properties. The annotation must be added to the page first.
    circle.Height = 0.25F
    circle.Width = 0.5F

    'Save annotations to an RDF file
    rpt.Document.Save("C:\MyAnnotations.rdf")
End Sub
See Also

Reference

Annotation Class
Annotation Members


Height Property (Annotation)

Height Property (Annotation)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Height Property
Gets or sets the height of the annotation object, in inches.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As System.Single
public System.float Height {get; set;}

Property Value

A float or single value in inches.
Remarks
You must add the annotation to the page before you can set the height of the annotation.
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations;

rptAnnotations rpt = new rptAnnotations();
private void AddAnnotations()
{
   //Run the report first
   rpt.Run();

   //Assign the viewer
   this.viewer1.Document = rpt.Document;

   //Create an annotation and assign property values
   AnnotationCircle circle = new AnnotationCircle();
   circle.Color = System.Drawing.Color.GreenYellow;
   circle.Border.Color = System.Drawing.Color.Chartreuse;

   //Add the annotation
   circle.Attach(1,1); //screen location
   this.viewer1.Document.Pages[0].Annotations.Add(circle);

   //Set the size properties. The annotation must be added to the page first.
   circle.Height = 0.25f;
   circle.Width = 0.50f;

   //Save annotations to an RDF file
   rpt.Document.Save("C:\\MyAnnotations.rdf");
}
  • Visual Basic
Private rpt As New rptAnnotations()
Private Sub AddAnnotations()
    'Run the report first
    rpt.Run()

    'Assign the viewer
    Me.viewer1.Document = rpt.Document

    'Create an annotation and assign property values
    Dim circle As New AnnotationCircle()
    circle.Color = System.Drawing.Color.GreenYellow
    circle.Border.Color = System.Drawing.Color.Chartreuse

    'Add the annotation
    circle.Attach(1, 1)
    'screen location
    Me.viewer1.Document.Pages(0).Annotations.Add(circle)

    'Set the size properties. The annotation must be added to the page first.
    circle.Height = 0.25F
    circle.Width = 0.5F

    'Save annotations to an RDF file
    rpt.Document.Save("C:\MyAnnotations.rdf")
End Sub
See Also

Reference

Annotation Class
Annotation Members


PageRectangle Property

PageRectangle Property

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : PageRectangle Property
Gets or sets the rectangular area of the page on which the annotation is drawn.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageRectangle As RectangleF
public RectangleF PageRectangle {get; set;}

Property Value

A RectangleF.
See Also

Reference

Annotation Class
Annotation Members


Width Property (Annotation)

Width Property (Annotation)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Width Property
Gets or sets the width of the annotation object, in inches.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Width As System.Single
public virtual System.float Width {get; set;}

Property Value

A float or single value in inches.
Remarks
You must add the annotation to the page before you can set the width of the annotation.
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations;

rptAnnotations rpt = new rptAnnotations();
private void AddAnnotations()
{
   //Run the report first
   rpt.Run();

   //Assign the viewer
   this.viewer1.Document = rpt.Document;

   //Create an annotation and assign property values
   AnnotationCircle circle = new AnnotationCircle();
   circle.Color = System.Drawing.Color.GreenYellow;
   circle.Border.Color = System.Drawing.Color.Chartreuse;

   //Add the annotation
   circle.Attach(1,1); //screen location
   this.viewer1.Document.Pages[0].Annotations.Add(circle);

   //Set the size properties. The annotation must be added to the page first.
   circle.Height = 0.25f;
   circle.Width = 0.50f;

   //Save annotations to an RDF file
   rpt.Document.Save("C:\\MyAnnotations.rdf");
}
  • Visual Basic
Private rpt As New rptAnnotations()
Private Sub AddAnnotations()
    'Run the report first
    rpt.Run()

    'Assign the viewer
    Me.viewer1.Document = rpt.Document

    'Create an annotation and assign property values
    Dim circle As New AnnotationCircle()
    circle.Color = System.Drawing.Color.GreenYellow
    circle.Border.Color = System.Drawing.Color.Chartreuse

    'Add the annotation
    circle.Attach(1, 1)
    'screen location
    Me.viewer1.Document.Pages(0).Annotations.Add(circle)

    'Set the size properties. The annotation must be added to the page first.
    circle.Height = 0.25F
    circle.Width = 0.5F

    'Save annotations to an RDF file
    rpt.Document.Save("C:\MyAnnotations.rdf")
End Sub
See Also

Reference

Annotation Class
Annotation Members


X Property (Annotation)

X Property (Annotation)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : X Property
Gets or sets the value in inches of the horizontal location of the annotation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property X As System.Single
public System.float X {get; set;}

Property Value

A single or float value in inches.
See Also

Reference

Annotation Class
Annotation Members


Y Property (Annotation)

Y Property (Annotation)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Y Property
Gets or sets the value in inches of the vertical location of the annotation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Y As System.Single
public System.float Y {get; set;}

Property Value

A single or float value in inches.
See Also

Reference

Annotation Class
Annotation Members


AnnotationArrow Class

AnnotationArrow Class
Members Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationArrow Class
Represents the AnnotationArrow object.
Object Model
AnnotationArrow Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class AnnotationArrow
   Inherits AnnotationText
public sealed class AnnotationArrow : AnnotationText
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations

private void AddAnnotations()
{
   rptAnno rpt = new rptAnno();
   rpt.Run();
   this.viewer1.Document = rpt.Document;

   AnnotationArrow arrow = new AnnotationArrow();
   arrow.ArrowDirection = ArrowDirection.Right;
   arrow.Text = "Look";
   arrow.TextColor = Color.Blue;
   arrow.Alpha = 255;
   arrow.Color = Color.Gray;

   arrow.Attach(2, 2);
   this.viewer1.Document.Pages[0].Annotations.Add(arrow);

   arrow.Height = 0.25f;
   arrow.Width = 1.50f;
}
  • Visual Basic
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
   Dim rptAnno As New rptAnno()
   rpt.Run()
   Me.Viewer1.Document = rpt.Document

   Dim arrow As New AnnotationArrow
   arrow.ArrowDirection = ArrowDirection.Right
   arrow.Text = "Look"
   arrow.TextColor = Color.Blue
   arrow.Alpha = 255
   arrow.Color = Color.Gray

   arrow.Attach(2, 2)
   this.Viewer1.Document.Pages(0).Annotations.Add(arrow)

   arrow.Height = 0.25
   arrow.Width = 1.50
End Sub
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationArrow

See Also

Reference

AnnotationArrow Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationArrow Class Members

AnnotationArrow Class Members
Properties Methods Events

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationArrow Class

The following tables list the members exposed by AnnotationArrow.

Public Constructors
 | Name | Description
Public Constructor | AnnotationArrow Constructor | Initializes a new instance of the AnnotationArrow class.
Top
Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the text alignment for the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | ArrowDirection | Gets or sets the direction of the AnnotationArrow object.
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Font | Gets or sets the font for the annotation text. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | LineAligment | Gets or sets the alignment of annotation lines. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the text to use in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | TextColor | Gets or sets the color of text used in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top
Public Methods
 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

AnnotationArrow Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationArrow Constructor

AnnotationArrow Constructor

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : AnnotationArrow Constructor
Initializes a new instance of the AnnotationArrow class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public AnnotationArrow()
See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


AnnotationArrow Class Properties

AnnotationArrow Class Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationArrow Class

For a list of all members of this type, see AnnotationArrow members.

Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the text alignment for the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | ArrowDirection | Gets or sets the direction of the AnnotationArrow object.
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Font | Gets or sets the font for the annotation text. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | LineAligment | Gets or sets the alignment of annotation lines. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the text to use in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | TextColor | Gets or sets the color of text used in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top
See Also

Reference

AnnotationArrow Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


ArrowDirection Property

ArrowDirection Property

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : ArrowDirection Property
Gets or sets the direction of the AnnotationArrow object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ArrowDirection As ArrowDirection
public ArrowDirection ArrowDirection {get; set;}

Property Value

The arrow direction.
See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


AnnotationBalloon Class

AnnotationBalloon Class
Members Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBalloon Class
Represents the AnnotationBalloon object.
Object Model
AnnotationBalloon Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class AnnotationBalloon
   Inherits AnnotationText
public sealed class AnnotationBalloon : AnnotationText
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationBalloon ball = new AnnotationBalloon();
    ball.Color = Color.LightSalmon;
    ball.Alpha = 75;
    ball.Border.Color = Color.Red;
    ball.Text = "Needs Review";
    ball.TextColor = Color.Black;
    ball.LineAligment = System.Drawing.StringAlignment.Center;
    ball.Alignment = System.Drawing.StringAlignment.Center;
    ball.Quadrant = AnnotationBalloon.BallonQuadrant.BottomLeft;

    ball.Attach(3, 3);
    this.viewer1.Document.Pages[0].Annotations.Add(ball);

    ball.Height = 1;
    ball.Width = 1.5f;
}
  • Visual Basic
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Dim rpt As New rptAnnotations
Private Sub AddAnnotations()
   rpt.Run()
   Me.Viewer1.Document = rpt.Document

   Dim ball As New AnnotationBalloon()
   ball.Color = Color.LightSalmon;
   ball.Alpha = 75;
   ball.Border.Color = Color.Red;
   ball.Text = "Needs Review";
   ball.TextColor = Color.Black;
   ball.LineAligment = System.Drawing.StringAlignment.Center;
   ball.Alignment = System.Drawing.StringAlignment.Center;
   ball.Quadrant = AnnotationBalloon.BallonQuadrant.BottomLeft;

   ball.Attach(4, 4)
   Me.Viewer1.Document.Pages(0).Annotations.Add(ball)

   ball.Height = 1
   ball.Width = 1.5
End Sub
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBalloon

See Also

Reference

AnnotationBalloon Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationBalloon Class Members

AnnotationBalloon Class Members
Properties Methods Events

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBalloon Class

The following tables list the members exposed by AnnotationBalloon.

Public Constructors
 | Name | Description
Public Constructor | AnnotationBalloon Constructor | Initializes a new instance of the AnnotationBalloon class.
Top
Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the text alignment for the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Font | Gets or sets the font for the annotation text. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | LineAligment | Gets or sets the alignment of annotation lines. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Quadrant | Gets or sets the quadrant for the tail of the AnnotationBalloon object.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the text to use in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | TextColor | Gets or sets the color of text used in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top
Public Methods
 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

AnnotationBalloon Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationBalloon Constructor

AnnotationBalloon Constructor

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : AnnotationBalloon Constructor
Initializes a new instance of the AnnotationBalloon class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public AnnotationBalloon()
See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


AnnotationBalloon Class Properties

AnnotationBalloon Class Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBalloon Class

For a list of all members of this type, see AnnotationBalloon members.

Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the text alignment for the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Font | Gets or sets the font for the annotation text. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | LineAligment | Gets or sets the alignment of annotation lines. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Quadrant | Gets or sets the quadrant for the tail of the AnnotationBalloon object.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the text to use in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | TextColor | Gets or sets the color of text used in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top
See Also

Reference

AnnotationBalloon Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Quadrant Property

Quadrant Property

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : Quadrant Property
Gets or sets the quadrant for the tail of the AnnotationBalloon object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Quadrant As AnnotationBalloon.BallonQuadrant
public AnnotationBalloon.BallonQuadrant Quadrant {get; set;}
See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


AnnotationBaseText Class

AnnotationBaseText Class
Members

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBaseText Class
Represents the base class for all of the Annotation objects.
Object Model
AnnotationBaseText Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class AnnotationBaseText
   Inherits Annotation
public abstract class AnnotationBaseText : Annotation
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationText

See Also

Reference

AnnotationBaseText Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationBaseText Class Members

AnnotationBaseText Class Members
Properties Methods Events

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBaseText Class

The following tables list the members exposed by AnnotationBaseText.

Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the text alignment for the annotation.
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Font | Gets or sets the font for the annotation text.
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | LineAligment | Gets or sets the alignment of annotation lines.
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the text to use in the annotation.
Public Property | TextColor | Gets or sets the color of text used in the annotation.
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top
Public Methods
 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

AnnotationBaseText Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationBaseText Class Properties

AnnotationBaseText Class Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBaseText Class

For a list of all members of this type, see AnnotationBaseText members.

Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the text alignment for the annotation.
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Font | Gets or sets the font for the annotation text.
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | LineAligment | Gets or sets the alignment of annotation lines.
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the text to use in the annotation.
Public Property | TextColor | Gets or sets the color of text used in the annotation.
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top
See Also

Reference

AnnotationBaseText Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Alignment Property (AnnotationBaseText)

Alignment Property (AnnotationBaseText)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : Alignment Property
Gets or sets the text alignment for the annotation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Alignment As StringAlignment
public StringAlignment Alignment {get; set;}
See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


Font Property (AnnotationBaseText)

Font Property (AnnotationBaseText)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : Font Property
Gets or sets the font for the annotation text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Font As Font
public Font Font {get; set;}
See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


LineAligment Property

LineAligment Property

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : LineAligment Property
Gets or sets the alignment of annotation lines.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineAligment As StringAlignment
public StringAlignment LineAligment {get; set;}
See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


Text Property (AnnotationBaseText)

Text Property (AnnotationBaseText)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : Text Property
Gets or sets the text to use in the annotation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Text As System.String
public System.string Text {get; set;}
See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


TextColor Property (AnnotationBaseText)

TextColor Property (AnnotationBaseText)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : TextColor Property
Gets or sets the color of text used in the annotation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TextColor As Color
public Color TextColor {get; set;}
See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


AnnotationCircle Class

AnnotationCircle Class
Members Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCircle Class
Represents a circular Annotation object.
Object Model
AnnotationCircle Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class AnnotationCircle
   Inherits Annotation
public sealed class AnnotationCircle : Annotation
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations;

rptAnnotations rpt = new rptAnnotations();
private void AddAnnotations()
{
   //Run the report first
   rpt.Run();

   //Assign the viewer
   this.viewer1.Document = rpt.Document;

   //Create an annotation and assign property values
   AnnotationCircle circle = new AnnotationCircle();
   circle.Color = System.Drawing.Color.GreenYellow;
   circle.Border.Color = System.Drawing.Color.Chartreuse;

   //Add the annotation
   circle.Attach(1,1); //screen location
   this.viewer1.Document.Pages[0].Annotations.Add(circle);

   //Set the size properties. The annotation must be added to the page first.
   circle.Height = 0.25f;
   circle.Width = 0.50f;

   //Save annotations to an RDF file
   rpt.Document.Save("C:\\MyAnnotations.rdf");
}
  • Visual Basic
Dim rpt As New rptAnnotations
Private Sub AddAnnotations()
   'Run the report first
   rpt.Run()

   'Assign the viewer
   Me.Viewer1.Document = rpt.Document

   'Create an annotation and assign property values
   Dim circle As New AnnotationCircle
   circle.Color = System.Drawing.Color.GreenYellow
   circle.Border.Color = System.Drawing.Color.Chartreuse

   'Add the annotation
   circle.Attach(1,1) 'screen location
   Me.Viewer1.Document.Pages(0).Annotations.Add(circle)

   'Set the size properties. The annotation must be added to the page first.
   circle.Height = 0.25
   circle.Width = 0.50

   'Save annotations to an RDF file
   rpt.Document.Save("C:\\MyAnnotations.rdf")
End Sub
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationCircle

See Also

Reference

AnnotationCircle Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationCircle Class Members

AnnotationCircle Class Members
Properties Methods Events

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCircle Class

The following tables list the members exposed by AnnotationCircle.

Public Constructors
 | Name | Description
Public Constructor | AnnotationCircle Constructor | Initializes a new instance of the AnnotationCircle class.
Top
Public Properties
 | Name | Description
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top
Public Methods
 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

AnnotationCircle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationCircle Constructor

AnnotationCircle Constructor

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : AnnotationCircle Constructor
Initializes a new instance of the AnnotationCircle class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public AnnotationCircle()
See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


AnnotationCollection Class

AnnotationCollection Class
Members

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCollection Class
Represents a collection of Annotation objects.
Object Model
AnnotationCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class AnnotationCollection
   Inherits System.Collections.CollectionBase
public class AnnotationCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationCollection

See Also

Reference

AnnotationCollection Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationCollection Class Members

AnnotationCollection Class Members
Properties Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCollection Class

The following tables list the members exposed by AnnotationCollection.

Public Constructors
 | Name | Description
Public Constructor | AnnotationCollection Constructor | Initializes a new instance of the AnnotationCollection class.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the fill color.
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets the annotation item in the collection.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an annotation to the end of the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Refresh | Forces an annotation to refresh its display.
Public Method | Remove | Removes an annotation from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

AnnotationCollection Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationCollection Constructor

AnnotationCollection Constructor

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : AnnotationCollection Constructor
Initializes a new instance of the AnnotationCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public AnnotationCollection()
See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


AnnotationCollection Class Methods

AnnotationCollection Class Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCollection Class

For a list of all members of this type, see AnnotationCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an annotation to the end of the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Refresh | Forces an annotation to refresh its display.
Public Method | Remove | Removes an annotation from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

AnnotationCollection Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Add Method (AnnotationCollection)

Add Method (AnnotationCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : Add Method
The annotation object to be added.
Adds an annotation to the end of the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Add( _
   ByVal annotation As Annotation _
)
public void Add(
   Annotation annotation
)

Parameters

annotation
The annotation object to be added.
See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


Refresh Method (AnnotationCollection)

Refresh Method (AnnotationCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : Refresh Method
The annotation object to be refreshed.
Forces an annotation to refresh its display.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Refresh( _
   ByVal annotation As Annotation _
)
public void Refresh(
   Annotation annotation
)

Parameters

annotation
The annotation object to be refreshed.
See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


Remove Method (AnnotationCollection)

Remove Method (AnnotationCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : Remove Method
The annotation object to be removed.
Removes an annotation from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal annotation As Annotation _
)
public void Remove(
   Annotation annotation
)

Parameters

annotation
The annotation object to be removed.
See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


AnnotationCollection Class Properties

AnnotationCollection Class Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCollection Class

For a list of all members of this type, see AnnotationCollection members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the fill color.
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets the annotation item in the collection.
Top
See Also

Reference

AnnotationCollection Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


BackColor Property (AnnotationCollection)

BackColor Property (AnnotationCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : BackColor Property
Gets or sets the fill color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackColor As Color
public Color BackColor {get; set;}

Property Value

The color of the back.
See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


Item Property (AnnotationCollection)

Item Property (AnnotationCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : Item Property
The location of the item.
Gets the annotation item in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As Annotation
public Annotation this[
   System.int index
]; {get;}

Parameters

index
The location of the item.

Property Value

Returns the element at the specified index.
See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


AnnotationImage Class

AnnotationImage Class
Members

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationImage Class
Represents the AnnotationImage object.
Object Model
AnnotationImage Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class AnnotationImage
   Inherits AnnotationText
public sealed class AnnotationImage : AnnotationText
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationImage

See Also

Reference

AnnotationImage Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationImage Class Members

AnnotationImage Class Members
Properties Methods Events

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationImage Class

The following tables list the members exposed by AnnotationImage.

Public Constructors
 | Name | Description
Public Constructor | AnnotationImage Constructor | Initializes a new instance of the AnnotationImage class.
Top
Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the text alignment for the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | BackgroundImage | Gets or sets the System.Drawing.Image to use as the annotation image.
Public Property | BackgroundLayout | Gets or sets the enumerated value that determines the positioning of the image within the annotation box.
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Font | Gets or sets the font for the annotation text. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | LineAligment | Gets or sets the alignment of annotation lines. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | ShowBorder | Gets or sets a value indicating whether to draw a border around the edge of the annotation box.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the text to use in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | TextColor | Gets or sets the color of text used in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top
Public Methods
 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

AnnotationImage Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationImage Constructor

AnnotationImage Constructor

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : AnnotationImage Constructor
Initializes a new instance of the AnnotationImage class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public AnnotationImage()
See Also

Reference

AnnotationImage Class
AnnotationImage Members


AnnotationImage Class Properties

AnnotationImage Class Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationImage Class

For a list of all members of this type, see AnnotationImage members.

Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the text alignment for the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | BackgroundImage | Gets or sets the System.Drawing.Image to use as the annotation image.
Public Property | BackgroundLayout | Gets or sets the enumerated value that determines the positioning of the image within the annotation box.
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Font | Gets or sets the font for the annotation text. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | LineAligment | Gets or sets the alignment of annotation lines. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | ShowBorder | Gets or sets a value indicating whether to draw a border around the edge of the annotation box.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the text to use in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | TextColor | Gets or sets the color of text used in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top
See Also

Reference

AnnotationImage Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


BackgroundImage Property (AnnotationImage)

BackgroundImage Property (AnnotationImage)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : BackgroundImage Property
Gets or sets the System.Drawing.Image to use as the annotation image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackgroundImage As Image
public Image BackgroundImage {get; set;}

Property Value

A System.Drawing.Image.
See Also

Reference

AnnotationImage Class
AnnotationImage Members


BackgroundLayout Property

BackgroundLayout Property

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : BackgroundLayout Property
Gets or sets the enumerated value that determines the positioning of the image within the annotation box.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackgroundLayout As ImageLayout
public ImageLayout BackgroundLayout {get; set;}

Property Value

The background layout.
See Also

Reference

AnnotationImage Class
AnnotationImage Members


ShowBorder Property

ShowBorder Property

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : ShowBorder Property
Gets or sets a value indicating whether to draw a border around the edge of the annotation box.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShowBorder As System.Boolean
public System.bool ShowBorder {get; set;}

Property Value

true if [show border]; otherwise, false.
See Also

Reference

AnnotationImage Class
AnnotationImage Members


AnnotationLine Class

AnnotationLine Class
Members Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationLine Class
Represents the AnnotationLine object.
Object Model
AnnotationLine Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class AnnotationLine
   Inherits Annotation
public sealed class AnnotationLine : Annotation
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
  • Visual Basic
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Dim rpt As New rptAnnotations
Private Sub AddAnnotations()
   rpt.Run()
   Me.Viewer1.Document = rpt.Document

   Dim line As New AnnotationLine()
   line.ArrowCapWidth = 4.5
   line.ArrowCapHeight = 4.5
   line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
   line.DashCap = System.Drawing.Drawing2D.DashCap.Round
   line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
   line.FillArrowCaps = True
   line.LineColor = Color.Red
   line.LineWidth = 1
   line.LineLocation = AnnotationLine.LinePlacement.Bottom
   line.Text = "Please review."
   line.TextColor = Color.Blue
   line.TextAlignment = System.Drawing.StringAlignment.Center

   line.Attach(4, 4)
   Me.Viewer1.Document.Pages(0).Annotations.Add(line)

   line.Height = 0.50
   line.Width = 1.5
End Sub
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationLine

See Also

Reference

AnnotationLine Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationLine Class Members

AnnotationLine Class Members
Properties Methods Events

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationLine Class

The following tables list the members exposed by AnnotationLine.

Public Constructors
 | Name | Description
Public Constructor | AnnotationLine Constructor | Initializes a new instance of the AnnotationLine class.
Top
Public Properties
 | Name | Description
Public Property | ArrowCapHeight | Gets or sets the height of the arrow cap of the AnnotationLine, in pixels.
Public Property | ArrowCapWidth | Gets or sets the arrow cap width of the AnnotationLine, in pixels.
Public Property | Color | Overridden. Gets the color of the AnnotationLine.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | DashCap | Gets or sets the graphic shape to be used on both ends of each dash of the AnnotationLine.
Public Property | DashStyle | Gets or sets the dash style of the AnnotationLine.
Public Property | FillArrowCaps | Determines whether the arrows caps of the AnnotationLine object will be filled.
Public Property | Font | Gets or sets the font for the text of the AnnotationLine object.
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | LineColor | Gets or sets the color of the AnnotationLine object.
Public Property | LineLocation | Gets or sets the location of the AnnotationLine within the Annotation object. The three possible values are Top, Middle, and Bottom.
Public Property | LineWidth | Gets or sets the width of the AnnotationLine line object, in pixels.
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | ShowArrowCaps | Gets or sets the location on the AnnotationLine that displays arrow caps.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the text to be rendered in the annotation.
Public Property | TextAlignment | Gets or sets the horizontal alignment of the text string relative to the bounds of the AnnotationLine object.
Public Property | TextColor | Gets or sets the color of the text that is rendered with the annotation.
Public Property | TextWidth | Gets or sets the amount of width, in inches, allocated to the text within the AnnotationLine object.
Public Property | Width | Overridden. Gets or sets the width of the AnnotationLine object, in inches.
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top
Public Methods
 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

AnnotationLine Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationLine Constructor

AnnotationLine Constructor

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : AnnotationLine Constructor
Initializes a new instance of the AnnotationLine class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public AnnotationLine()
See Also

Reference

AnnotationLine Class
AnnotationLine Members


AnnotationLine Class Properties

AnnotationLine Class Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationLine Class

For a list of all members of this type, see AnnotationLine members.

Public Properties
 | Name | Description
Public Property | ArrowCapHeight | Gets or sets the height of the arrow cap of the AnnotationLine, in pixels.
Public Property | ArrowCapWidth | Gets or sets the arrow cap width of the AnnotationLine, in pixels.
Public Property | Color | Overridden. Gets the color of the AnnotationLine.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | DashCap | Gets or sets the graphic shape to be used on both ends of each dash of the AnnotationLine.
Public Property | DashStyle | Gets or sets the dash style of the AnnotationLine.
Public Property | FillArrowCaps | Determines whether the arrows caps of the AnnotationLine object will be filled.
Public Property | Font | Gets or sets the font for the text of the AnnotationLine object.
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | LineColor | Gets or sets the color of the AnnotationLine object.
Public Property | LineLocation | Gets or sets the location of the AnnotationLine within the Annotation object. The three possible values are Top, Middle, and Bottom.
Public Property | LineWidth | Gets or sets the width of the AnnotationLine line object, in pixels.
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | ShowArrowCaps | Gets or sets the location on the AnnotationLine that displays arrow caps.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the text to be rendered in the annotation.
Public Property | TextAlignment | Gets or sets the horizontal alignment of the text string relative to the bounds of the AnnotationLine object.
Public Property | TextColor | Gets or sets the color of the text that is rendered with the annotation.
Public Property | TextWidth | Gets or sets the amount of width, in inches, allocated to the text within the AnnotationLine object.
Public Property | Width | Overridden. Gets or sets the width of the AnnotationLine object, in inches.
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top
See Also

Reference

AnnotationLine Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


ArrowCapHeight Property

ArrowCapHeight Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : ArrowCapHeight Property
Gets or sets the height of the arrow cap of the AnnotationLine, in pixels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ArrowCapHeight As System.Single
public System.float ArrowCapHeight {get; set;}

Property Value

The height of the arrow cap.
Remarks
The height is measured from the base of the arrow to the tip.
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
  • Visual Basic
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub
See Also

Reference

AnnotationLine Class
AnnotationLine Members


ArrowCapWidth Property

ArrowCapWidth Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : ArrowCapWidth Property
Gets or sets the arrow cap width of the AnnotationLine, in pixels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ArrowCapWidth As System.Single
public System.float ArrowCapWidth {get; set;}

Property Value

The width of the arrow cap.
Remarks
The width of the arrow cap is measured from each end of the base of the arrow cap.
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
  • Visual Basic
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub
See Also

Reference

AnnotationLine Class
AnnotationLine Members


Color Property (AnnotationLine)

Color Property (AnnotationLine)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Color Property
Gets the color of the AnnotationLine.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable ReadOnly Property Color As Color
public override Color Color {get;}

Property Value

The color is used to fill the annotation object.
See Also

Reference

AnnotationLine Class
AnnotationLine Members


DashCap Property (AnnotationLine)

DashCap Property (AnnotationLine)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : DashCap Property
Gets or sets the graphic shape to be used on both ends of each dash of the AnnotationLine.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DashCap As DashCap
public DashCap DashCap {get; set;}

Property Value

The dash cap.
Remarks
If the DashStyle property is set to Solid, the DashCap property has no effect.
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
  • Visual Basic
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub
See Also

Reference

AnnotationLine Class
AnnotationLine Members


DashStyle Property (AnnotationLine)

DashStyle Property (AnnotationLine)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : DashStyle Property
Gets or sets the dash style of the AnnotationLine.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DashStyle As DashStyle
public DashStyle DashStyle {get; set;}

Property Value

The dash style.
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
  • Visual Basic
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub
See Also

Reference

AnnotationLine Class
AnnotationLine Members


FillArrowCaps Property

FillArrowCaps Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : FillArrowCaps Property
Determines whether the arrows caps of the AnnotationLine object will be filled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FillArrowCaps As System.Boolean
public System.bool FillArrowCaps {get; set;}

Property Value

true if [fill arrow caps]; otherwise, false.
Remarks
If the ShowArrowCaps property is set to None, the FillArrowCaps property has no effect on the AnnotationLine object.
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
  • Visual Basic
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub
See Also

Reference

AnnotationLine Class
AnnotationLine Members


Font Property (AnnotationLine)

Font Property (AnnotationLine)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Font Property
Gets or sets the font for the text of the AnnotationLine object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Font As Font
public Font Font {get; set;}

Property Value

The font.
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.Font = new Font("Arial", 12f, FontStyle.Bold);
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
  • Visual Basic
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub
See Also

Reference

AnnotationLine Class
AnnotationLine Members


LineColor Property (AnnotationLine)

LineColor Property (AnnotationLine)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : LineColor Property
Gets or sets the color of the AnnotationLine object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineColor As Color
public Color LineColor {get; set;}

Property Value

The color of the line.
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
  • Visual Basic
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub
See Also

Reference

AnnotationLine Class
AnnotationLine Members


LineLocation Property

LineLocation Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : LineLocation Property
Gets or sets the location of the AnnotationLine within the Annotation object. The three possible values are Top, Middle, and Bottom.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineLocation As AnnotationLine.LinePlacement
public AnnotationLine.LinePlacement LineLocation {get; set;}

Property Value

The line location.
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
  • Visual Basic
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub
See Also

Reference

AnnotationLine Class
AnnotationLine Members


LineWidth Property

LineWidth Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : LineWidth Property
Gets or sets the width of the AnnotationLine line object, in pixels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineWidth As System.Single
public System.float LineWidth {get; set;}

Property Value

A float or single value in pixels.
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
  • Visual Basic
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub
See Also

Reference

AnnotationLine Class
AnnotationLine Members


ShowArrowCaps Property

ShowArrowCaps Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : ShowArrowCaps Property
Gets or sets the location on the AnnotationLine that displays arrow caps.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShowArrowCaps As AnnotationLine.ShowArrowCap
public AnnotationLine.ShowArrowCap ShowArrowCaps {get; set;}

Property Value

The show arrow caps.
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
  • Visual Basic
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub
See Also

Reference

AnnotationLine Class
AnnotationLine Members


Text Property (AnnotationLine)

Text Property (AnnotationLine)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Text Property
Gets or sets the text to be rendered in the annotation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Text As System.String
public System.string Text {get; set;}

Property Value

The text of the AnnotationLine object.
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
  • Visual Basic
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub
See Also

Reference

AnnotationLine Class
AnnotationLine Members


TextAlignment Property (AnnotationLine)

TextAlignment Property (AnnotationLine)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : TextAlignment Property
Gets or sets the horizontal alignment of the text string relative to the bounds of the AnnotationLine object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TextAlignment As StringAlignment
public StringAlignment TextAlignment {get; set;}
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
  • Visual Basic
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub
See Also

Reference

AnnotationLine Class
AnnotationLine Members


TextColor Property (AnnotationLine)

TextColor Property (AnnotationLine)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : TextColor Property
Gets or sets the color of the text that is rendered with the annotation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TextColor As Color
public Color TextColor {get; set;}

Property Value

The color of the text.
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
  • Visual Basic
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub
See Also

Reference

AnnotationLine Class
AnnotationLine Members


TextWidth Property

TextWidth Property
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : TextWidth Property
Gets or sets the amount of width, in inches, allocated to the text within the AnnotationLine object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TextWidth As System.Single
public System.float TextWidth {get; set;}

Property Value

A float or single value in inches.
Remarks
If the TextWidth property is set on the viewer to a value larger than the width of the AnnotationLine object, the AnnotationLine object is redrawn to accommodate the text.
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;
    line.TextWidth = 1.2f;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
  • Visual Basic
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub
See Also

Reference

AnnotationLine Class
AnnotationLine Members


Width Property (AnnotationLine)

Width Property (AnnotationLine)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Width Property
Gets or sets the width of the AnnotationLine object, in inches.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Property Width As System.Single
public override System.float Width {get; set;}

Property Value

A float or single value in inches.
Example
  • C#
using GrapeCity.ActiveReports.Document.Section.Annotations;

private void AddAnnotations()
{
    rptAnno rpt = new rptAnno();
    rpt.Run();
    this.viewer1.Document = rpt.Document;

    AnnotationLine line = new AnnotationLine();
    line.ArrowCapWidth = 4.5f;
    line.ArrowCapHeight = 4.5f;
    line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot;
    line.DashCap = System.Drawing.Drawing2D.DashCap.Round;
    line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly;
    line.FillArrowCaps = true;
    line.LineColor = Color.Red;
    line.LineWidth = 1;
    line.LineLocation = AnnotationLine.LinePlacement.Bottom;
    line.Text = "Please review.";
    line.TextColor = Color.Blue;
    line.TextAlignment = System.Drawing.StringAlignment.Center;
    line.TextWidth = 1.2f;

    line.Attach(4, 4);
    this.viewer1.Document.Pages[0].Annotations.Add(line);

    line.Height = 0.50f;
    line.Width = 1.5f;
}
  • Visual Basic
Imports GrapeCity.ActiveReports.Document.Section.Annotations

Private Sub AddAnnotations()
 Dim rpt As rptAnno = New rptAnno
 rpt.Run
 Me.viewer1.Document = rpt.Document

 Dim line As AnnotationLine = New AnnotationLine
 line.ArrowCapWidth = 4.5F
 line.ArrowCapHeight = 4.5F
 line.DashStyle = System.Drawing.Drawing2D.DashStyle.DashDotDot
 line.DashCap = System.Drawing.Drawing2D.DashCap.Round
 line.ShowArrowCaps = AnnotationLine.ShowArrowCap.RightOnly
 line.FillArrowCaps = True
 line.LineColor = Color.Red
 line.LineWidth = 1
 line.LineLocation = AnnotationLine.LinePlacement.Bottom
 line.Text = "Please review."
 line.Font = New Font("Arial", 12F, FontStyle.Bold)
 line.TextColor = Color.Blue
 line.TextAlignment = System.Drawing.StringAlignment.Center

 line.Attach(4, 4)
 Me.viewer1.Document.Pages(0).Annotations.Add(line)

 line.Height = 0.5F
 line.Width = 1.5F
End Sub
See Also

Reference

AnnotationLine Class
AnnotationLine Members


AnnotationRectangle Class

AnnotationRectangle Class
Members

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationRectangle Class
Represents the rectangular Annotation object.
Object Model
AnnotationRectangle Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class AnnotationRectangle
   Inherits Annotation
public sealed class AnnotationRectangle : Annotation
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationRectangle

See Also

Reference

AnnotationRectangle Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationRectangle Class Members

AnnotationRectangle Class Members
Properties Methods Events

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationRectangle Class

The following tables list the members exposed by AnnotationRectangle.

Public Constructors
 | Name | Description
Public Constructor | AnnotationRectangle Constructor | Initializes a new instance of the AnnotationRectangle object.
Top
Public Properties
 | Name | Description
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top
Public Methods
 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

AnnotationRectangle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationRectangle Constructor

AnnotationRectangle Constructor

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : AnnotationRectangle Constructor
Initializes a new instance of the AnnotationRectangle object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public AnnotationRectangle()
See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


AnnotationText Class

AnnotationText Class
Members

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationText Class
Represents the characteristics of the text of the Annotation object.
Object Model
AnnotationText Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class AnnotationText
   Inherits AnnotationBaseText
public class AnnotationText : AnnotationBaseText
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationArrow
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBalloon
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationImage

See Also

Reference

AnnotationText Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationText Class Members

AnnotationText Class Members
Properties Methods Events

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationText Class

The following tables list the members exposed by AnnotationText.

Public Constructors
 | Name | Description
Public Constructor | AnnotationText Constructor | Initializes a new instance of the AnnotationText object.
Top
Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the horizontal alignment of the text within the bounds of an annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Font | Gets or sets the text font associated with the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | LineAligment | Gets or sets the vertical alignment of the text within the bounds of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the text to be rendered in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | TextColor | Gets or sets the color of the text that is rendered with the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top
Public Methods
 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

AnnotationText Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationText Constructor

AnnotationText Constructor

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : AnnotationText Constructor
Initializes a new instance of the AnnotationText object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public AnnotationText()
See Also

Reference

AnnotationText Class
AnnotationText Members


BorderCircle Class

BorderCircle Class
Members

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : BorderCircle Class
Draws a border around an AnnotationCircle.
Object Model
BorderCircle Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class BorderCircle
   Inherits Border
public class BorderCircle : Border
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.Annotations.BorderCircle

See Also

Reference

BorderCircle Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


BorderCircle Class Members

BorderCircle Class Members

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : BorderCircle Class

The following tables list the members exposed by BorderCircle.

Public Constructors
 | Name | Description
Public Constructor | BorderCircle Constructor | Initializes a new instance of the BorderCircle class.
Top
See Also

Reference

BorderCircle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


BorderCircle Constructor

BorderCircle Constructor

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > BorderCircle Class : BorderCircle Constructor
Initializes a new instance of the BorderCircle class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public BorderCircle()
See Also

Reference

BorderCircle Class
BorderCircle Members


BorderRectangle Class

BorderRectangle Class
Members

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : BorderRectangle Class
Draws a border around an AnnotationRectangle.
Object Model
BorderRectangle Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class BorderRectangle
   Inherits Border
public class BorderRectangle : Border
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.Section.Annotations.BorderRectangle

See Also

Reference

BorderRectangle Members
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


BorderRectangle Class Members

BorderRectangle Class Members

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : BorderRectangle Class

The following tables list the members exposed by BorderRectangle.

Public Constructors
 | Name | Description
Public Constructor | BorderRectangle Constructor | Initializes a new instance of the BorderRectangle class.
Top
See Also

Reference

BorderRectangle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


BorderRectangle Constructor

BorderRectangle Constructor

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > BorderRectangle Class : BorderRectangle Constructor
Initializes a new instance of the BorderRectangle class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public BorderRectangle()
See Also

Reference

BorderRectangle Class
BorderRectangle Members


AnnotationBalloon.BallonQuadrant Enumeration

AnnotationBalloon.BallonQuadrant Enumeration

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBalloon.BallonQuadrant Enumeration
Specifies the location of the balloon tail relative to the AnnotationBalloon object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum AnnotationBalloon.BallonQuadrant
   Inherits System.Enum
public enum AnnotationBalloon.BallonQuadrant : System.Enum
Members
Member | Description
BottomLeft | The balloon tail is drawn to the bottom left of the balloon.
BottomRight | The balloon tail is drawn to the bottom right of the balloon.
LeftBottom | The balloon tail is drawn to the left bottom of the balloon.
LeftTop | The balloon tail is drawn to the left top of the balloon.
None | The balloon is drawn without a tail.
RightBottom | The balloon tail is drawn to the right bottom of the balloon.
RightTop | The balloon tail is drawn to the right top of the balloon.
TopLeft | The balloon tail is drawn to the top left of the balloon.
TopRight | The balloon tail is drawn to the top right of the balloon.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBalloon.BallonQuadrant

See Also

Reference

GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationLine.LinePlacement Enumeration

AnnotationLine.LinePlacement Enumeration

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationLine.LinePlacement Enumeration
Specifies the location relative to the Annotation object in which the line will be drawn.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum AnnotationLine.LinePlacement
   Inherits System.Enum
public enum AnnotationLine.LinePlacement : System.Enum
Members
Member | Description
Bottom | The line is drawn at the bottom of the Annotation object.
Middle | The line is drawn in the middle of the Annotation object.
Top | The line is drawn at the top of the Annotation object.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationLine.LinePlacement

See Also

Reference

GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationLine.ShowArrowCap Enumeration

AnnotationLine.ShowArrowCap Enumeration

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationLine.ShowArrowCap Enumeration
Specifies the location of the arrow cap on the AnnotationLine.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum AnnotationLine.ShowArrowCap
   Inherits System.Enum
public enum AnnotationLine.ShowArrowCap : System.Enum
Members
Member | Description
LeftOnly | The arrow cap displays on the left end of the line.
LeftRight | The arrow cap displays on both end of the line.
None | The arrow cap does not display.
RightOnly | The arrow cap displays on the right end of the line.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationLine.ShowArrowCap

See Also

Reference

GrapeCity.ActiveReports.Document.Section.Annotations Namespace


ArrowDirection Enumeration

ArrowDirection Enumeration

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : ArrowDirection Enumeration
Specifies the direction in which the arrow points.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ArrowDirection
   Inherits System.Enum
public enum ArrowDirection : System.Enum
Members
Member | Description
Bottom | The arrow points to the bottom.
Left | The arrow points to the left.
Right | The arrow points to the right.
Top | The arrow points to the top.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.Annotations.ArrowDirection

See Also

Reference

GrapeCity.ActiveReports.Document.Section.Annotations Namespace


ImageLayout Enumeration

ImageLayout Enumeration

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : ImageLayout Enumeration
Specifies the positioning for Annotation Images.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ImageLayout
   Inherits System.Enum
public enum ImageLayout : System.Enum
Members
Member | Description
Bottom | The bottom edge of the image is aligned with the bottom edge of the annotation rectangle.
Center | The image is centered within the annotation rectangle.
Left | The left edge of the image is aligned with the left edge of the annotation rectangle.
LeftBottom | The left and bottom edges of the image are aligned with the left and bottom edges of the annotation rectangle.
LeftTop | The left and top edges of the image are aligned with the left and top edges of the annotation rectangle.
Right | The right edge of the image is aligned with the right edge of the annotation rectangle.
RightBottom | The right and bottom edges of the image are aligned with the right and bottom edges of the annotation rectangle.
RightTop | The right and top edges of the image are aligned with the right and top edges of the annotation rectangle.
Stretch | The image is stretched (or shrunk) to fit the annotation rectangle exactly without regard to aspect ratio.
Tile | The image, at its actual size, is tiled within the annotation rectangle.
Top | The top edge of the image is aligned with the top edge of the annotation rectangle.
Zoom | The image is resized to fit within the control.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Document.Section.Annotations.ImageLayout

See Also

Reference

GrapeCity.ActiveReports.Document.Section.Annotations Namespace


GrapeCity.ActiveReports.Export Namespace (GrapeCity.ActiveReports.Document.v10)

GrapeCity.ActiveReports.Export Namespace (GrapeCity.ActiveReports.Document.v10)
Inheritance Hierarchy
GrapeCity.ActiveReports.Document.v10 Assembly : GrapeCity.ActiveReports.Export Namespace
The GrapeCity.ActiveReports.Export namespace contains the common interface for all the export filters.
Interfaces
 | Interface | Description
Interface | IDocumentExport | Provides a common interface for all the export filters.
See Also

Reference

GrapeCity.ActiveReports.Document.v10 Assembly


IDocumentExport Interface

IDocumentExport Interface
Members

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Export Namespace : IDocumentExport Interface
Provides a common interface for all the export filters.
Object Model
IDocumentExport Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDocumentExport
public interface IDocumentExport
See Also

Reference

IDocumentExport Members
GrapeCity.ActiveReports.Export Namespace


IDocumentExport Interface Members

IDocumentExport Interface Members
Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Export Namespace : IDocumentExport Interface

The following tables list the members exposed by IDocumentExport.

Public Methods
 | Name | Description
Method | Export | Overloaded. Exports the specified range of pages to an HTML file.
Top
See Also

Reference

IDocumentExport Interface
GrapeCity.ActiveReports.Export Namespace


IDocumentExport Interface Methods

IDocumentExport Interface Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Export Namespace : IDocumentExport Interface

For a list of all members of this type, see IDocumentExport members.

Public Methods
 | Name | Description
Method | Export | Overloaded. Exports the specified range of pages to an HTML file.
Top
See Also

Reference

IDocumentExport Interface
GrapeCity.ActiveReports.Export Namespace


Export Method (IDocumentExport)

Export Method (IDocumentExport)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExport Interface : Export Method
Exports the specified range of pages to an HTML file.
Exports the specified document to HTML.
Overload List
Overload | Description
Export(SectionDocument,String,String) | Exports the specified range of pages to an HTML file.
Export(SectionDocument,String) | Exports the entire ActiveReports document to the specified HTML file.
Export(SectionDocument,Stream) | Exports the entire ActiveReports document to HTML in a MIME MHT format (such as can be saved using Internet Explorer with the Save As Web Archive option) which combines the HTML and all images into a single file.
Export(SectionDocument,Stream,String) | Exports the specified range of pages to a System.IO.Stream in a MIME MHT format (such as can be saved using Internet Explorer with the Save As Web Archive option) which combines the HTML and all images into a single file.
Export(SectionDocument,IOutputHtml,String) | Exports the specified range of pages of the document to the chosen outputHandler.
See Also

Reference

IDocumentExport Interface
IDocumentExport Members


Export(SectionDocument,String,String) Method

Export(SectionDocument,String,String) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExport Interface > Export Method : Export(SectionDocument,String,String) Method
The ActiveReports Document object to export.
The file name and path to save the main html file to. If multiple filenames are generated (such as images, or table of contents pages) this argument's value will be used as a prefix for the other file names.
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.
Exports the specified range of pages to an HTML file.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As System.String, _
   ByVal pageRange As System.String _
)
void Export(
   SectionDocument document,
   System.string filePath,
   System.string pageRange
)

Parameters

document
The ActiveReports Document object to export.
filePath
The file name and path to save the main html file to. If multiple filenames are generated (such as images, or table of contents pages) this argument's value will be used as a prefix for the other file names.
pageRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.
See Also

Reference

IDocumentExport Interface
IDocumentExport Members
Overload List


Export(SectionDocument,String) Method

Export(SectionDocument,String) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExport Interface > Export Method : Export(SectionDocument,String) Method
The ActiveReports Document object to export.
The file name and path to which to save the main HTML file. If multiple filenames are generated (such as images, or table of contents pages) this argument's value will be used as a prefix for the other file names.
Exports the entire ActiveReports document to the specified HTML file.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As System.String _
)
void Export(
   SectionDocument document,
   System.string filePath
)

Parameters

document
The ActiveReports Document object to export.
filePath
The file name and path to which to save the main HTML file. If multiple filenames are generated (such as images, or table of contents pages) this argument's value will be used as a prefix for the other file names.
See Also

Reference

IDocumentExport Interface
IDocumentExport Members
Overload List


Export(SectionDocument,Stream) Method

Export(SectionDocument,Stream) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExport Interface > Export Method : Export(SectionDocument,Stream) Method
The ActiveReports document to be exported.
The destination System.IO.Stream to which to save the MHT file.
Exports the entire ActiveReports document to HTML in a MIME MHT format (such as can be saved using Internet Explorer with the Save As Web Archive option) which combines the HTML and all images into a single file.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As System.IO.Stream _
)
void Export(
   SectionDocument document,
   System.IO.Stream outputStream
)

Parameters

document
The ActiveReports document to be exported.
outputStream
The destination System.IO.Stream to which to save the MHT file.
See Also

Reference

IDocumentExport Interface
IDocumentExport Members
Overload List


Export(SectionDocument,Stream,String) Method

Export(SectionDocument,Stream,String) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExport Interface > Export Method : Export(SectionDocument,Stream,String) Method
The ActiveReports document to be exported.
The destination System.IO.Stream to which to save the MHT file.
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.
Exports the specified range of pages to a System.IO.Stream in a MIME MHT format (such as can be saved using Internet Explorer with the Save As Web Archive option) which combines the HTML and all images into a single file.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As System.IO.Stream, _
   ByVal pageRange As System.String _
)
void Export(
   SectionDocument document,
   System.IO.Stream outputStream,
   System.string pageRange
)

Parameters

document
The ActiveReports document to be exported.
outputStream
The destination System.IO.Stream to which to save the MHT file.
pageRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.
See Also

Reference

IDocumentExport Interface
IDocumentExport Members
Overload List


Export(SectionDocument,IOutputHtml,String) Method

Export(SectionDocument,IOutputHtml,String) Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExport Interface > Export Method : Export(SectionDocument,IOutputHtml,String) Method
The ActiveReports document to be exported.
The destination System.IO.Stream to which to save the MHT file.
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.
Exports the specified range of pages of the document to the chosen outputHandler.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputHandler As IOutputHtml, _
   ByVal pageRange As System.String _
)
void Export(
   SectionDocument document,
   IOutputHtml outputHandler,
   System.string pageRange
)

Parameters

document
The ActiveReports document to be exported.
outputHandler
The destination System.IO.Stream to which to save the MHT file.
pageRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.
See Also

Reference

IDocumentExport Interface
IDocumentExport Members
Overload List


GrapeCity.ActiveReports.Export.Html Namespace

GrapeCity.ActiveReports.Export.Html Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Document.v10 Assembly : GrapeCity.ActiveReports.Export.Html Namespace
The GrapeCity.ActiveReports.Export.Html namespace contains the class which gives control over the HTML output of the report.
Classes
 | Class | Description
Class | HtmlOutputInfoArgs | Used as an argument to the IOutputHtml interface's OutputHtmlData function.
Interfaces
 | Interface | Description
Interface | IOutputHtml | Provides an interface that can be passed for Export.
Enumerations
 | Enumeration | Description
Enumeration | HtmlOutputKind | Specifies the HTML output.
See Also

Reference

GrapeCity.ActiveReports.Document.v10 Assembly


HtmlOutputInfoArgs Class

HtmlOutputInfoArgs Class
Members

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Export.Html Namespace : HtmlOutputInfoArgs Class
Used as an argument to the IOutputHtml interface's OutputHtmlData function.
Object Model
HtmlOutputInfoArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class HtmlOutputInfoArgs
public class HtmlOutputInfoArgs
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Html.HtmlOutputInfoArgs

See Also

Reference

HtmlOutputInfoArgs Members
GrapeCity.ActiveReports.Export.Html Namespace


HtmlOutputInfoArgs Class Members

HtmlOutputInfoArgs Class Members
Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Export.Html Namespace : HtmlOutputInfoArgs Class

The following tables list the members exposed by HtmlOutputInfoArgs.

Public Constructors
 | Name | Description
Public Constructor | HtmlOutputInfoArgs Constructor | Initializes a new instance of the HtmlOutputInfoArgs class.
Top
Public Properties
 | Name | Description
Public Property | OutputKind | The type that is being outputted. Can be of type ImagePng, ImageJpg, HtmlPage, BookmarksHtml, or FramesetHtml.
Public Property | OutputStream | The System.IO.Stream that is being outputted.
Top
See Also

Reference

HtmlOutputInfoArgs Class
GrapeCity.ActiveReports.Export.Html Namespace


HtmlOutputInfoArgs Constructor

HtmlOutputInfoArgs Constructor

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Export.Html Namespace > HtmlOutputInfoArgs Class : HtmlOutputInfoArgs Constructor
The type that is being outputted.
The System.IO.Stream that is being outputted.
Initializes a new instance of the HtmlOutputInfoArgs class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal outputKind As HtmlOutputKind, _
   ByVal outputStream As System.IO.Stream _
)
public HtmlOutputInfoArgs(
   HtmlOutputKind outputKind,
   System.IO.Stream outputStream
)

Parameters

outputKind
The type that is being outputted.
outputStream
The System.IO.Stream that is being outputted.
See Also

Reference

HtmlOutputInfoArgs Class
HtmlOutputInfoArgs Members


HtmlOutputInfoArgs Class Properties

HtmlOutputInfoArgs Class Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Export.Html Namespace : HtmlOutputInfoArgs Class

For a list of all members of this type, see HtmlOutputInfoArgs members.

Public Properties
 | Name | Description
Public Property | OutputKind | The type that is being outputted. Can be of type ImagePng, ImageJpg, HtmlPage, BookmarksHtml, or FramesetHtml.
Public Property | OutputStream | The System.IO.Stream that is being outputted.
Top
See Also

Reference

HtmlOutputInfoArgs Class
GrapeCity.ActiveReports.Export.Html Namespace


OutputKind Property

OutputKind Property

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Export.Html Namespace > HtmlOutputInfoArgs Class : OutputKind Property
The type that is being outputted. Can be of type ImagePng, ImageJpg, HtmlPage, BookmarksHtml, or FramesetHtml.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property OutputKind As HtmlOutputKind
public HtmlOutputKind OutputKind {get;}
See Also

Reference

HtmlOutputInfoArgs Class
HtmlOutputInfoArgs Members


OutputStream Property

OutputStream Property

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Export.Html Namespace > HtmlOutputInfoArgs Class : OutputStream Property
The System.IO.Stream that is being outputted.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property OutputStream As System.IO.Stream
public System.IO.Stream OutputStream {get;}
See Also

Reference

HtmlOutputInfoArgs Class
HtmlOutputInfoArgs Members


HtmlOutputKind Enumeration

HtmlOutputKind Enumeration

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Export.Html Namespace : HtmlOutputKind Enumeration
Specifies the HTML output.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum HtmlOutputKind
   Inherits System.Enum
public enum HtmlOutputKind : System.Enum
Members
Member | Description
BookmarksHtml | The output is an HTML page containing a list of bookmarks for the main HTML page.
FramesetHtml | The output is an html page containing a Frameset declaration for a TOC page or navigation page if TOC not available, and the "target" document pages on the right.
HtmlPage | The output is the HTML page.
ImageJpg | The HTML output is an image of type JPEG.
ImagePng | The HTML output is an image of type PNG.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Html.HtmlOutputKind

See Also

Reference

GrapeCity.ActiveReports.Export.Html Namespace


IOutputHtml Interface

IOutputHtml Interface
Members

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Export.Html Namespace : IOutputHtml Interface
Provides an interface that can be passed for Export.
Object Model
IOutputHtml Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IOutputHtml
public interface IOutputHtml
See Also

Reference

IOutputHtml Members
GrapeCity.ActiveReports.Export.Html Namespace


IOutputHtml Interface Members

IOutputHtml Interface Members
Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Export.Html Namespace : IOutputHtml Interface

The following tables list the members exposed by IOutputHtml.

Public Methods
 | Name | Description
Method | Finish | Called by the HtmlExport to indicate that the export of the current document is complete. This can be used by an implementer to flush any remaining output, or to write out a frame set page for the previously exported document.
Method | OutputHtmlData | Called by the HtmlExport class to output data. The implementation of OutputHtmlData should use the data passed in the info argument and store it as the implementer requires.
Top
See Also

Reference

IOutputHtml Interface
GrapeCity.ActiveReports.Export.Html Namespace


IOutputHtml Interface Methods

IOutputHtml Interface Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Export.Html Namespace : IOutputHtml Interface

For a list of all members of this type, see IOutputHtml members.

Public Methods
 | Name | Description
Method | Finish | Called by the HtmlExport to indicate that the export of the current document is complete. This can be used by an implementer to flush any remaining output, or to write out a frame set page for the previously exported document.
Method | OutputHtmlData | Called by the HtmlExport class to output data. The implementation of OutputHtmlData should use the data passed in the info argument and store it as the implementer requires.
Top
See Also

Reference

IOutputHtml Interface
GrapeCity.ActiveReports.Export.Html Namespace


Finish Method

Finish Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Export.Html Namespace > IOutputHtml Interface : Finish Method
Called by the HtmlExport to indicate that the export of the current document is complete. This can be used by an implementer to flush any remaining output, or to write out a frame set page for the previously exported document.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Finish()
void Finish()
See Also

Reference

IOutputHtml Interface
IOutputHtml Members


OutputHtmlData Method

OutputHtmlData Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Export.Html Namespace > IOutputHtml Interface : OutputHtmlData Method
Information about the output
Called by the HtmlExport class to output data. The implementation of OutputHtmlData should use the data passed in the info argument and store it as the implementer requires.
Syntax
  • Visual Basic
  • C#
'Declaration

Function OutputHtmlData( _
   ByVal info As HtmlOutputInfoArgs _
) As System.String
System.string OutputHtmlData(
   HtmlOutputInfoArgs info
)

Parameters

info
Information about the output

Return Value

The implementation of OutputHtmlData should use the data passed in the info argument and store it as the implentator requires. The return value should be a "file name" that the calling HtmlExport class can use to place links in the main HTML page to the data. For example, as an HTML page is being created and an image is encountered that will be outputed as an HTML img the HtmlExport object will call this method to provide the data to the implentor, and the return value from OutputHtmlData (i.e. the filename) will be used as the src attribute's value. When the HTML page is ready, OutputHtmlData will be called again to pass the actual HTML page's data, in this case the filename returned by the OutputHtmlData implementation will not be used.
Remarks

The implementation of OutputHtmlData should use the data passed in the info argument and store it as the implementor requires. The return value should be a "file name" that the calling HtmlExport class can use to place links in the main HTML page to the data. For example, as an HTML page is being created and an image is encountered that will be output as an HTML img. the HtmlExport object will call this method to provide the data to the implementor and the return value from OutputHtmlData (i.e. the filename) will be used as the src attribute's value.

When the HTML page is ready, OutputHtmlData will be called again to pass the actual HTML page's data. In this case the filename returned by the OutputHtmlData implementation will not be used."

See Also

Reference

IOutputHtml Interface
IOutputHtml Members


GrapeCity.ActiveReports.Export.Excel Namespace

GrapeCity.ActiveReports.Export.Excel Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Excel.v10 Assembly : GrapeCity.ActiveReports.Export.Excel Namespace
See Also

Reference

GrapeCity.ActiveReports.Export.Excel.v10 Assembly


GrapeCity.ActiveReports.Export.Excel.Page Namespace

GrapeCity.ActiveReports.Export.Excel.Page Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Excel.v10 Assembly : GrapeCity.ActiveReports.Export.Excel.Page Namespace
Classes
 | Class | Description
Class | ExcelRenderingExtension | Renders report layout to excel file.
Class | ExcelRenderingExtensionPageSettings | Encapsulates the information necessary to provide Xls document print settings.
Class | ExcelRenderingExtensionSecurity | Encapsulates the information necessary to provide excel document security and encryption.
Class | ExcelRenderingExtensionSettings | Settings class for ExcelRenderingExtension.
Class | ExcelTransformationDevice | Allows for the creation of an excel spreadsheet containing rendered data from a report. Render Page report through RDF.
Class | Settings | Contains the settings used for rendering reports to Excel.
Enumerations
 | Enumeration | Description
Enumeration | ExcelRenderingExtensionPageSettings.PageOrientation | Valid paper orientation values.
Enumeration | ExcelRenderingExtensionPageSettings.PaperSizes | Valid paper size values.
Enumeration | FileFormat | Specifies the output format of Excel document.
Enumeration | OpenXmlStandard | Specifies the level of Open XML document conformance on exporting with Xlsx file format.
Remarks

See Also

Reference

GrapeCity.ActiveReports.Export.Excel.v10 Assembly


ExcelRenderingExtension Class

ExcelRenderingExtension Class
Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtension Class
Renders report layout to excel file.
Object Model
ExcelRenderingExtension Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ExcelRenderingExtension
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension
public sealed class ExcelRenderingExtension : GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension
Remarks
In comparison to ExcelTransformationDevice it doesn't use templates and try to obtain layout, not plain data. In comparison to GrapeCity.ActiveReports.Export.Excel.Section.XlsExport it doesn't use any intermediate formats, so output can be more WYSIWYG.
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtension

See Also

Reference

ExcelRenderingExtension Members
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ExcelRenderingExtension Class Members

ExcelRenderingExtension Class Members
Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtension Class

The following tables list the members exposed by ExcelRenderingExtension.

Public Constructors
 | Name | Description
Public Constructor | ExcelRenderingExtension Constructor |
Top
Public Methods
 | Name | Description
Public Method | Dispose | Implements the dispose logic of HtmlRenderingExtension class.
Public Method | GetSupportedSettings | Overloaded. Returns settings of current ExcelRenderingExtension instance.
Public Method | Render | Overloaded. Provides the output of the report to the specified rendering extension
Top
See Also

Reference

ExcelRenderingExtension Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ExcelRenderingExtension Constructor

ExcelRenderingExtension Constructor

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtension Class : ExcelRenderingExtension Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ExcelRenderingExtension()
See Also

Reference

ExcelRenderingExtension Class
ExcelRenderingExtension Members


ExcelRenderingExtension Class Methods

ExcelRenderingExtension Class Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtension Class

For a list of all members of this type, see ExcelRenderingExtension members.

Public Methods
 | Name | Description
Public Method | Dispose | Implements the dispose logic of HtmlRenderingExtension class.
Public Method | GetSupportedSettings | Overloaded. Returns settings of current ExcelRenderingExtension instance.
Public Method | Render | Overloaded. Provides the output of the report to the specified rendering extension
Top
See Also

Reference

ExcelRenderingExtension Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtension Class : Dispose() Method
Implements the dispose logic of HtmlRenderingExtension class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

ExcelRenderingExtension Class
ExcelRenderingExtension Members


GetSupportedSettings Method (ExcelRenderingExtension)

GetSupportedSettings Method (ExcelRenderingExtension)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtension Class : GetSupportedSettings Method
Returns settings of current ExcelRenderingExtension instance.
Overload List
Overload | Description
GetSupportedSettings() | Gets the supported settings.
GetSupportedSettings(Boolean) | Gets the supported settings.
See Also

Reference

ExcelRenderingExtension Class
ExcelRenderingExtension Members


GetSupportedSettings() Method

GetSupportedSettings() Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtension Class > GetSupportedSettings Method : GetSupportedSettings() Method
Gets the supported settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetSupportedSettings() As ISettings
public ISettings GetSupportedSettings()
See Also

Reference

ExcelRenderingExtension Class
ExcelRenderingExtension Members
Overload List


GetSupportedSettings(Boolean) Method

GetSupportedSettings(Boolean) Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtension Class > GetSupportedSettings Method : GetSupportedSettings(Boolean) Method
Is fixed page layout
Gets the supported settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetSupportedSettings( _
   ByVal fpl As System.Boolean _
) As ISettings
public ISettings GetSupportedSettings(
   System.bool fpl
)

Parameters

fpl
Is fixed page layout
See Also

Reference

ExcelRenderingExtension Class
ExcelRenderingExtension Members
Overload List


Render Method (ExcelRenderingExtension)

Render Method (ExcelRenderingExtension)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtension Class : Render Method
Provides the output of the report to the specified rendering extension
Overload List
Overload | Description
Render(IReport,StreamProvider) | Renders the specified report.
Render(IReport,StreamProvider,NameValueCollection) | Renders the specified report.
See Also

Reference

ExcelRenderingExtension Class
ExcelRenderingExtension Members


Render(IReport,StreamProvider) Method

Render(IReport,StreamProvider) Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtension Class > Render Method : Render(IReport,StreamProvider) Method
The report.
The streams.
Renders the specified report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Render( _
   ByVal report As IReport, _
   ByVal streams As StreamProvider _
)
public void Render(
   IReport report,
   StreamProvider streams
)

Parameters

report
The report.
streams
The streams.
See Also

Reference

ExcelRenderingExtension Class
ExcelRenderingExtension Members
Overload List


Render(IReport,StreamProvider,NameValueCollection) Method

Render(IReport,StreamProvider,NameValueCollection) Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtension Class > Render Method : Render(IReport,StreamProvider,NameValueCollection) Method
The report.
The stream provider.
The settings.
Renders the specified report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Render( _
   ByVal report As IReport, _
   ByVal streamProvider As StreamProvider, _
   ByVal settings As System.Collections.Specialized.NameValueCollection _
)
public void Render(
   IReport report,
   StreamProvider streamProvider,
   System.Collections.Specialized.NameValueCollection settings
)

Parameters

report
The report.
streamProvider
The stream provider.
settings
The settings.
See Also

Reference

ExcelRenderingExtension Class
ExcelRenderingExtension Members
Overload List


ExcelRenderingExtensionPageSettings Class

ExcelRenderingExtensionPageSettings Class
Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionPageSettings Class
Encapsulates the information necessary to provide Xls document print settings.
Object Model
ExcelRenderingExtensionPageSettings Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ExcelRenderingExtensionPageSettings
public class ExcelRenderingExtensionPageSettings
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionPageSettings

See Also

Reference

ExcelRenderingExtensionPageSettings Members
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ExcelRenderingExtensionPageSettings Class Members

ExcelRenderingExtensionPageSettings Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionPageSettings Class

The following tables list the members exposed by ExcelRenderingExtensionPageSettings.

Public Properties
 | Name | Description
Public Property | Orientation | Gets or sets the print orientation of Excel sheet.
Public Property | PaperSize | Gets or sets the print paper size of Excel sheet.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the value of the current instance to its string representation.
Top
See Also

Reference

ExcelRenderingExtensionPageSettings Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ExcelRenderingExtensionPageSettings Class Methods

ExcelRenderingExtensionPageSettings Class Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionPageSettings Class

For a list of all members of this type, see ExcelRenderingExtensionPageSettings members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the value of the current instance to its string representation.
Top
See Also

Reference

ExcelRenderingExtensionPageSettings Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ToString Method (ExcelRenderingExtensionPageSettings)

ToString Method (ExcelRenderingExtensionPageSettings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionPageSettings Class : ToString Method
Converts the value of the current instance to its string representation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()
See Also

Reference

ExcelRenderingExtensionPageSettings Class
ExcelRenderingExtensionPageSettings Members


ExcelRenderingExtensionPageSettings Class Properties

ExcelRenderingExtensionPageSettings Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionPageSettings Class

For a list of all members of this type, see ExcelRenderingExtensionPageSettings members.

Public Properties
 | Name | Description
Public Property | Orientation | Gets or sets the print orientation of Excel sheet.
Public Property | PaperSize | Gets or sets the print paper size of Excel sheet.
Top
See Also

Reference

ExcelRenderingExtensionPageSettings Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


Orientation Property (ExcelRenderingExtensionPageSettings)

Orientation Property (ExcelRenderingExtensionPageSettings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionPageSettings Class : Orientation Property
Gets or sets the print orientation of Excel sheet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Orientation As ExcelRenderingExtensionPageSettings.PageOrientation
public ExcelRenderingExtensionPageSettings.PageOrientation Orientation {get; set;}
See Also

Reference

ExcelRenderingExtensionPageSettings Class
ExcelRenderingExtensionPageSettings Members


PaperSize Property (ExcelRenderingExtensionPageSettings)

PaperSize Property (ExcelRenderingExtensionPageSettings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionPageSettings Class : PaperSize Property
Gets or sets the print paper size of Excel sheet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaperSize As ExcelRenderingExtensionPageSettings.PaperSizes
public ExcelRenderingExtensionPageSettings.PaperSizes PaperSize {get; set;}
Remarks
Reset this property to use default AR document print paper size.
See Also

Reference

ExcelRenderingExtensionPageSettings Class
ExcelRenderingExtensionPageSettings Members


ExcelRenderingExtensionSecurity Class

ExcelRenderingExtensionSecurity Class
Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionSecurity Class
Encapsulates the information necessary to provide excel document security and encryption.
Object Model
ExcelRenderingExtensionSecurity Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ExcelRenderingExtensionSecurity
public class ExcelRenderingExtensionSecurity
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionSecurity

See Also

Reference

ExcelRenderingExtensionSecurity Members
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ExcelRenderingExtensionSecurity Class Members

ExcelRenderingExtensionSecurity Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionSecurity Class

The following tables list the members exposed by ExcelRenderingExtensionSecurity.

Public Properties
 | Name | Description
Public Property | Password | Gets or sets the password which can be entered to permit to open Excel document.
Public Property | ProtectedBy | Gets or sets the User Name responsible to password protect the excel spreadsheet.
Public Property | ReadOnlyRecommended | Gets or sets the value to indicate if the Excel file was saved as read only recommended.
Public Property | WritePassword | Gets or sets the write password of the Excel file.
Top
Public Methods
 | Name | Description
Public Method | ToString | Converts the value of the current instance to its string representation.
Top
See Also

Reference

ExcelRenderingExtensionSecurity Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ExcelRenderingExtensionSecurity Class Methods

ExcelRenderingExtensionSecurity Class Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionSecurity Class

For a list of all members of this type, see ExcelRenderingExtensionSecurity members.

Public Methods
 | Name | Description
Public Method | ToString | Converts the value of the current instance to its string representation.
Top
See Also

Reference

ExcelRenderingExtensionSecurity Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ToString Method (ExcelRenderingExtensionSecurity)

ToString Method (ExcelRenderingExtensionSecurity)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSecurity Class : ToString Method
Converts the value of the current instance to its string representation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()
See Also

Reference

ExcelRenderingExtensionSecurity Class
ExcelRenderingExtensionSecurity Members


ExcelRenderingExtensionSecurity Class Properties

ExcelRenderingExtensionSecurity Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionSecurity Class

For a list of all members of this type, see ExcelRenderingExtensionSecurity members.

Public Properties
 | Name | Description
Public Property | Password | Gets or sets the password which can be entered to permit to open Excel document.
Public Property | ProtectedBy | Gets or sets the User Name responsible to password protect the excel spreadsheet.
Public Property | ReadOnlyRecommended | Gets or sets the value to indicate if the Excel file was saved as read only recommended.
Public Property | WritePassword | Gets or sets the write password of the Excel file.
Top
See Also

Reference

ExcelRenderingExtensionSecurity Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


Password Property (ExcelRenderingExtensionSecurity)

Password Property (ExcelRenderingExtensionSecurity)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSecurity Class : Password Property
Gets or sets the password which can be entered to permit to open Excel document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Password As System.String
public System.string Password {get; set;}
See Also

Reference

ExcelRenderingExtensionSecurity Class
ExcelRenderingExtensionSecurity Members


ProtectedBy Property (ExcelRenderingExtensionSecurity)

ProtectedBy Property (ExcelRenderingExtensionSecurity)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSecurity Class : ProtectedBy Property
Gets or sets the User Name responsible to password protect the excel spreadsheet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ProtectedBy As System.String
public System.string ProtectedBy {get; set;}
See Also

Reference

ExcelRenderingExtensionSecurity Class
ExcelRenderingExtensionSecurity Members


ReadOnlyRecommended Property (ExcelRenderingExtensionSecurity)

ReadOnlyRecommended Property (ExcelRenderingExtensionSecurity)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSecurity Class : ReadOnlyRecommended Property
Gets or sets the value to indicate if the Excel file was saved as read only recommended.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReadOnlyRecommended As System.Boolean
public System.bool ReadOnlyRecommended {get; set;}
See Also

Reference

ExcelRenderingExtensionSecurity Class
ExcelRenderingExtensionSecurity Members


WritePassword Property (ExcelRenderingExtensionSecurity)

WritePassword Property (ExcelRenderingExtensionSecurity)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSecurity Class : WritePassword Property
Gets or sets the write password of the Excel file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WritePassword As System.String
public System.string WritePassword {get; set;}
See Also

Reference

ExcelRenderingExtensionSecurity Class
ExcelRenderingExtensionSecurity Members


ExcelRenderingExtensionSettings Class

ExcelRenderingExtensionSettings Class
Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionSettings Class
Settings class for ExcelRenderingExtension.
Object Model
ExcelRenderingExtensionSettings Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ExcelRenderingExtensionSettings
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
public sealed class ExcelRenderingExtensionSettings : GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionSettings

See Also

Reference

ExcelRenderingExtensionSettings Members
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ExcelRenderingExtensionSettings Class Members

ExcelRenderingExtensionSettings Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionSettings Class

The following tables list the members exposed by ExcelRenderingExtensionSettings.

Public Constructors
 | Name | Description
Public Constructor | ExcelRenderingExtensionSettings Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | FileFormat | Indicates whether to use Biff or OpenXml format for the output file. OpenXml is default.
Public Property | MultiSheet | Indicates whether to generate single-sheet or multisheet document. true is default.
Public Property | OpenXmlStandard | Open XML conformance level. Strict by default.
Public Property | PageSettings | Returns a ExcelRenderingExtensionPageSettings object for initializing Excel file print setting.
Public Property | Pagination | Force paginated or galley report layout mode. true is default.
Public Property | Security | Returns a ExcelRenderingExtensionSecurity object for initializing document security.
Public Property | UseCompression | Gets or sets the value indicating should compression be used on exporting with Xlsx file format. True by default.
Public Property | UseDefaultPalette | Sets or returns whether export document with Excel default palette.
Top
Public Methods
 | Name | Description
Public Method | ApplySettings | Applies any settings passed in the NameValueCollection settings parameters.
Public Method | GetSettings | Gets the settings for rendering a report to Excel.
Top
See Also

Reference

ExcelRenderingExtensionSettings Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ExcelRenderingExtensionSettings Constructor

ExcelRenderingExtensionSettings Constructor

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : ExcelRenderingExtensionSettings Constructor
Overload List
Overload | Description
ExcelRenderingExtensionSettings Constructor() | Initializes a new instance of the ExcelRenderingExtensionSettings class.
ExcelRenderingExtensionSettings Constructor(NameValueCollection) | Initializes a new instance of the ExcelRenderingExtensionSettings class.
See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


ExcelRenderingExtensionSettings Constructor()

ExcelRenderingExtensionSettings Constructor()

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class > ExcelRenderingExtensionSettings Constructor : ExcelRenderingExtensionSettings Constructor()
Initializes a new instance of the ExcelRenderingExtensionSettings class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ExcelRenderingExtensionSettings()
See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members
Overload List


ExcelRenderingExtensionSettings Constructor(NameValueCollection)

ExcelRenderingExtensionSettings Constructor(NameValueCollection)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class > ExcelRenderingExtensionSettings Constructor : ExcelRenderingExtensionSettings Constructor(NameValueCollection)
Settings for the rendering extension.
Initializes a new instance of the ExcelRenderingExtensionSettings class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal settings As System.Collections.Specialized.NameValueCollection _
)
public ExcelRenderingExtensionSettings(
   System.Collections.Specialized.NameValueCollection settings
)

Parameters

settings
Settings for the rendering extension.
See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members
Overload List


ExcelRenderingExtensionSettings Class Methods

ExcelRenderingExtensionSettings Class Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionSettings Class

For a list of all members of this type, see ExcelRenderingExtensionSettings members.

Public Methods
 | Name | Description
Public Method | ApplySettings | Applies any settings passed in the NameValueCollection settings parameters.
Public Method | GetSettings | Gets the settings for rendering a report to Excel.
Top
See Also

Reference

ExcelRenderingExtensionSettings Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ApplySettings Method (ExcelRenderingExtensionSettings)

ApplySettings Method (ExcelRenderingExtensionSettings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : ApplySettings Method
Settings for the rendering extension.

Applies any settings passed in the NameValueCollection settings parameters.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ApplySettings( _
   ByVal settings As System.Collections.Specialized.NameValueCollection _
)
public void ApplySettings(
   System.Collections.Specialized.NameValueCollection settings
)

Parameters

settings
Settings for the rendering extension.
See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


GetSettings Method (ExcelRenderingExtensionSettings)

GetSettings Method (ExcelRenderingExtensionSettings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : GetSettings Method
Gets the settings for rendering a report to Excel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetSettings() As System.Collections.Specialized.NameValueCollection
public System.Collections.Specialized.NameValueCollection GetSettings()
See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


ExcelRenderingExtensionSettings Class Properties

ExcelRenderingExtensionSettings Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionSettings Class

For a list of all members of this type, see ExcelRenderingExtensionSettings members.

Public Properties
 | Name | Description
Public Property | FileFormat | Indicates whether to use Biff or OpenXml format for the output file. OpenXml is default.
Public Property | MultiSheet | Indicates whether to generate single-sheet or multisheet document. true is default.
Public Property | OpenXmlStandard | Open XML conformance level. Strict by default.
Public Property | PageSettings | Returns a ExcelRenderingExtensionPageSettings object for initializing Excel file print setting.
Public Property | Pagination | Force paginated or galley report layout mode. true is default.
Public Property | Security | Returns a ExcelRenderingExtensionSecurity object for initializing document security.
Public Property | UseCompression | Gets or sets the value indicating should compression be used on exporting with Xlsx file format. True by default.
Public Property | UseDefaultPalette | Sets or returns whether export document with Excel default palette.
Top
See Also

Reference

ExcelRenderingExtensionSettings Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


FileFormat Property (ExcelRenderingExtensionSettings)

FileFormat Property (ExcelRenderingExtensionSettings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : FileFormat Property
Indicates whether to use Biff or OpenXml format for the output file. OpenXml is default.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FileFormat As FileFormat
public FileFormat FileFormat {get; set;}
See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


MultiSheet Property (ExcelRenderingExtensionSettings)

MultiSheet Property (ExcelRenderingExtensionSettings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : MultiSheet Property
Indicates whether to generate single-sheet or multisheet document. true is default.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MultiSheet As System.Boolean
public System.bool MultiSheet {get; set;}
See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


OpenXmlStandard Property (ExcelRenderingExtensionSettings)

OpenXmlStandard Property (ExcelRenderingExtensionSettings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : OpenXmlStandard Property
Open XML conformance level. Strict by default.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OpenXmlStandard As OpenXmlStandard
public OpenXmlStandard OpenXmlStandard {get; set;}
See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


PageSettings Property (ExcelRenderingExtensionSettings)

PageSettings Property (ExcelRenderingExtensionSettings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : PageSettings Property
Returns a ExcelRenderingExtensionPageSettings object for initializing Excel file print setting.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PageSettings As ExcelRenderingExtensionPageSettings
public ExcelRenderingExtensionPageSettings PageSettings {get;}
See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


Pagination Property (ExcelRenderingExtensionSettings)

Pagination Property (ExcelRenderingExtensionSettings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : Pagination Property
Force paginated or galley report layout mode. true is default.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Pagination As System.Boolean
public System.bool Pagination {get; set;}
See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


Security Property (ExcelRenderingExtensionSettings)

Security Property (ExcelRenderingExtensionSettings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : Security Property
Returns a ExcelRenderingExtensionSecurity object for initializing document security.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Security As ExcelRenderingExtensionSecurity
public ExcelRenderingExtensionSecurity Security {get;}
See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


UseCompression Property (ExcelRenderingExtensionSettings)

UseCompression Property (ExcelRenderingExtensionSettings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : UseCompression Property
Gets or sets the value indicating should compression be used on exporting with Xlsx file format. True by default.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseCompression As System.Boolean
public System.bool UseCompression {get; set;}
See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


UseDefaultPalette Property (ExcelRenderingExtensionSettings)

UseDefaultPalette Property (ExcelRenderingExtensionSettings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtensionSettings Class : UseDefaultPalette Property
Sets or returns whether export document with Excel default palette.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseDefaultPalette As System.Boolean
public System.bool UseDefaultPalette {get; set;}
Remarks
Setting this value to true, application will use the color which is in default palette and is closest to pre-defined custom color of control's forecolor and backcolor.
See Also

Reference

ExcelRenderingExtensionSettings Class
ExcelRenderingExtensionSettings Members


ExcelTransformationDevice Class

ExcelTransformationDevice Class
Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelTransformationDevice Class
Allows for the creation of an excel spreadsheet containing rendered data from a report. Render Page report through RDF.
Object Model
ExcelTransformationDevice Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ExcelTransformationDevice
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension
public class ExcelTransformationDevice : GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension
Remarks
Works good with RDL reports, but not good with Page reports. Use ExcelRenderingExtension or GrapeCity.ActiveReports.Export.Excel.Section.XlsExport to export Excel data.
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Excel.Page.ExcelTransformationDevice

See Also

Reference

ExcelTransformationDevice Members
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ExcelTransformationDevice Class Members

ExcelTransformationDevice Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelTransformationDevice Class

The following tables list the members exposed by ExcelTransformationDevice.

Public Constructors
 | Name | Description
Public Constructor | ExcelTransformationDevice Constructor | Initializes a new instance of ExcelTransformationDevice class.
Top
Public Properties
 | Name | Description
Public Property | TemplateStream | Gets or sets the template as a System.IO.Stream to use for rendering.
Top
Public Methods
 | Name | Description
Public Method | GetSupportedSettings | Gets the settings that are supported for rendering a report to Excel.
Top
See Also

Reference

ExcelTransformationDevice Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ExcelTransformationDevice Constructor

ExcelTransformationDevice Constructor

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelTransformationDevice Class : ExcelTransformationDevice Constructor
Initializes a new instance of ExcelTransformationDevice class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ExcelTransformationDevice()
See Also

Reference

ExcelTransformationDevice Class
ExcelTransformationDevice Members


ExcelTransformationDevice Class Methods

ExcelTransformationDevice Class Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelTransformationDevice Class

For a list of all members of this type, see ExcelTransformationDevice members.

Public Methods
 | Name | Description
Public Method | GetSupportedSettings | Gets the settings that are supported for rendering a report to Excel.
Top
See Also

Reference

ExcelTransformationDevice Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


GetSupportedSettings() Method

GetSupportedSettings() Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelTransformationDevice Class > GetSupportedSettings Method : GetSupportedSettings() Method
Gets the settings that are supported for rendering a report to Excel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetSupportedSettings() As ISettings
public ISettings GetSupportedSettings()
See Also

Reference

ExcelTransformationDevice Class
ExcelTransformationDevice Members
Overload List


ExcelTransformationDevice Class Properties

ExcelTransformationDevice Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelTransformationDevice Class

For a list of all members of this type, see ExcelTransformationDevice members.

Public Properties
 | Name | Description
Public Property | TemplateStream | Gets or sets the template as a System.IO.Stream to use for rendering.
Top
See Also

Reference

ExcelTransformationDevice Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


TemplateStream Property

TemplateStream Property

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelTransformationDevice Class : TemplateStream Property
Gets or sets the template as a System.IO.Stream to use for rendering.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TemplateStream As System.IO.Stream
public System.IO.Stream TemplateStream {get; set;}
Remarks
The value of this property will override the Template setting if not null.
See Also

Reference

ExcelTransformationDevice Class
ExcelTransformationDevice Members


Settings Class

Settings Class
Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : Settings Class
Contains the settings used for rendering reports to Excel.
Object Model
Settings Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Settings
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
public sealed class Settings : GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Excel.Page.Settings

See Also

Reference

Settings Members
GrapeCity.ActiveReports.Export.Excel.Page Namespace


Settings Class Members

Settings Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : Settings Class

The following tables list the members exposed by Settings.

Public Constructors
 | Name | Description
Public Constructor | Settings Constructor | Allows internal callers to create instances of this class.
Top
Public Properties
 | Name | Description
Public Property | PaperHeight | Gets or sets the height of the paper size that will be set for the output document.
Public Property | PaperWidth | Gets or sets the width of the paper size that will be set for the output document.
Public Property | ProtectWorkbookPassword | Gets or sets the path of the ProtectWorkbookPassword used during the rendering process.
static (Shared in Visual Basic) | ProtectWorkbookPasswordPropertyName | Specifies the value of write-protection passwordfor the saved Excel file.
Public Property | ReadOnlyRecommended | Gets or sets the value ReadOnlyRecommended file sharing flag for the saved Excel file.
static (Shared in Visual Basic) | ReadOnlyRecommendedPropertyName | Specifies the value of ReadOnlyRecommended file sharing flag for the saved Excel file.
Public Property | Template | Gets or sets the path of the Template used during the rendering process. Doesn't work with Page reports, only with RDL reports.
static (Shared in Visual Basic) | TemplatePropertyName | Specifies the full path and filename of a Template to use during the rendering process.
Public Property | UseDefaultPalette | Sets or returns whether export document with Excel default palette.
static (Shared in Visual Basic) | UseDefaultPalettePropertyName | Specifies the value of UseDefaultPalette
Top
Public Methods
 | Name | Description
Public Method | ApplySettings | Applies any settings passed in the NameValueCollection settings parameters.
Public Method | GetSettings | Gets the settings for rendering a report to Excel.
Public Method | ToString | Returns a System.String that represents this instance.
Top
Public Operators
public Operator Implicit Type Conversion Performs an implicit conversion from Settings to System.Collections.Specialized.NameValueCollection.
Top
See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


Settings Constructor

Settings Constructor

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : Settings Constructor
Allows internal callers to create instances of this class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Settings()
See Also

Reference

Settings Class
Settings Members


Settings Class Methods

Settings Class Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : Settings Class

For a list of all members of this type, see Settings members.

Public Methods
 | Name | Description
Public Method | ApplySettings | Applies any settings passed in the NameValueCollection settings parameters.
Public Method | GetSettings | Gets the settings for rendering a report to Excel.
Public Method | ToString | Returns a System.String that represents this instance.
Top
See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


ApplySettings Method (Settings)

ApplySettings Method (Settings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : ApplySettings Method
A System.Collections.Specialized.NameValueCollection containing new settings.
Applies any settings passed in the NameValueCollection settings parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ApplySettings( _
   ByVal settings As System.Collections.Specialized.NameValueCollection _
)
public void ApplySettings(
   System.Collections.Specialized.NameValueCollection settings
)

Parameters

settings
A System.Collections.Specialized.NameValueCollection containing new settings.
See Also

Reference

Settings Class
Settings Members


GetSettings Method (Settings)

GetSettings Method (Settings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : GetSettings Method
Gets the settings for rendering a report to Excel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetSettings() As System.Collections.Specialized.NameValueCollection
public System.Collections.Specialized.NameValueCollection GetSettings()
See Also

Reference

Settings Class
Settings Members


ToString Method (Settings)

ToString Method (Settings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : ToString Method
Returns a System.String that represents this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()
See Also

Reference

Settings Class
Settings Members


Settings Class Properties

Settings Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : Settings Class

For a list of all members of this type, see Settings members.

Public Properties
 | Name | Description
Public Property | PaperHeight | Gets or sets the height of the paper size that will be set for the output document.
Public Property | PaperWidth | Gets or sets the width of the paper size that will be set for the output document.
Public Property | ProtectWorkbookPassword | Gets or sets the path of the ProtectWorkbookPassword used during the rendering process.
static (Shared in Visual Basic) | ProtectWorkbookPasswordPropertyName | Specifies the value of write-protection passwordfor the saved Excel file.
Public Property | ReadOnlyRecommended | Gets or sets the value ReadOnlyRecommended file sharing flag for the saved Excel file.
static (Shared in Visual Basic) | ReadOnlyRecommendedPropertyName | Specifies the value of ReadOnlyRecommended file sharing flag for the saved Excel file.
Public Property | Template | Gets or sets the path of the Template used during the rendering process. Doesn't work with Page reports, only with RDL reports.
static (Shared in Visual Basic) | TemplatePropertyName | Specifies the full path and filename of a Template to use during the rendering process.
Public Property | UseDefaultPalette | Sets or returns whether export document with Excel default palette.
static (Shared in Visual Basic) | UseDefaultPalettePropertyName | Specifies the value of UseDefaultPalette
Top
See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Excel.Page Namespace


PaperHeight Property (Settings)

PaperHeight Property (Settings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : PaperHeight Property
Gets or sets the height of the paper size that will be set for the output document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaperHeight As System.String
public System.string PaperHeight {get; set;}
Requirements

See Also

Reference

Settings Class
Settings Members


PaperWidth Property (Settings)

PaperWidth Property (Settings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : PaperWidth Property
Gets or sets the width of the paper size that will be set for the output document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaperWidth As System.String
public System.string PaperWidth {get; set;}
Requirements

See Also

Reference

Settings Class
Settings Members


ProtectWorkbookPassword Property (Settings)

ProtectWorkbookPassword Property (Settings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : ProtectWorkbookPassword Property
Gets or sets the path of the ProtectWorkbookPassword used during the rendering process.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ProtectWorkbookPassword As System.String
public System.string ProtectWorkbookPassword {get; set;}
Requirements

See Also

Reference

Settings Class
Settings Members


ProtectWorkbookPasswordPropertyName Property

ProtectWorkbookPasswordPropertyName Property

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : ProtectWorkbookPasswordPropertyName Property
Specifies the value of write-protection passwordfor the saved Excel file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property ProtectWorkbookPasswordPropertyName As System.String
public static System.string ProtectWorkbookPasswordPropertyName {get;}
Requirements

See Also

Reference

Settings Class
Settings Members


ReadOnlyRecommended Property (Settings)

ReadOnlyRecommended Property (Settings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : ReadOnlyRecommended Property
Gets or sets the value ReadOnlyRecommended file sharing flag for the saved Excel file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReadOnlyRecommended As System.Boolean
public System.bool ReadOnlyRecommended {get; set;}
Requirements

See Also

Reference

Settings Class
Settings Members


ReadOnlyRecommendedPropertyName Property

ReadOnlyRecommendedPropertyName Property

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : ReadOnlyRecommendedPropertyName Property
Specifies the value of ReadOnlyRecommended file sharing flag for the saved Excel file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property ReadOnlyRecommendedPropertyName As System.String
public static System.string ReadOnlyRecommendedPropertyName {get;}
Requirements

See Also

Reference

Settings Class
Settings Members


Template Property (Settings)

Template Property (Settings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : Template Property
Gets or sets the path of the Template used during the rendering process. Doesn't work with Page reports, only with RDL reports.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Template As System.String
public System.string Template {get; set;}
Requirements

See Also

Reference

Settings Class
Settings Members


TemplatePropertyName Property

TemplatePropertyName Property

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : TemplatePropertyName Property
Specifies the full path and filename of a Template to use during the rendering process.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property TemplatePropertyName As System.String
public static System.string TemplatePropertyName {get;}
Requirements

See Also

Reference

Settings Class
Settings Members


UseDefaultPalette Property (Settings)

UseDefaultPalette Property (Settings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : UseDefaultPalette Property
Sets or returns whether export document with Excel default palette.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseDefaultPalette As System.Boolean
public System.bool UseDefaultPalette {get; set;}
Remarks
Setting this value to true, application will use the color which is in default palette and is closest to pre-defined custom color of control's forecolor and backcolor.
Requirements

See Also

Reference

Settings Class
Settings Members


UseDefaultPalettePropertyName Property

UseDefaultPalettePropertyName Property

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : UseDefaultPalettePropertyName Property
Specifies the value of UseDefaultPalette
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property UseDefaultPalettePropertyName As System.String
public static System.string UseDefaultPalettePropertyName {get;}
Requirements

See Also

Reference

Settings Class
Settings Members


Implicit Type Conversion Operator (Settings)

Implicit Type Conversion Operator (Settings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > Settings Class : Implicit Type Conversion Operator
The rendering extention settings.
Performs an implicit conversion from Settings to System.Collections.Specialized.NameValueCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator Widening CType( _
   ByVal settings As Settings _
) As System.Collections.Specialized.NameValueCollection
public System.Collections.Specialized.NameValueCollection operator implicit(
   Settings settings
)

Parameters

settings
The rendering extention settings.

Return Value

The result of the conversion.
See Also

Reference

Settings Class
Settings Members


ExcelRenderingExtensionPageSettings.PageOrientation Enumeration

ExcelRenderingExtensionPageSettings.PageOrientation Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionPageSettings.PageOrientation Enumeration
Valid paper orientation values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ExcelRenderingExtensionPageSettings.PageOrientation
   Inherits System.Enum
public enum ExcelRenderingExtensionPageSettings.PageOrientation : System.Enum
Members
Member | Description
Default | Default printer orientation.
Landscape | Landscape orientation.
Portrait | Portrait orientation.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionPageSettings.PageOrientation

See Also

Reference

GrapeCity.ActiveReports.Export.Excel.Page Namespace


ExcelRenderingExtensionPageSettings.PaperSizes Enumeration

ExcelRenderingExtensionPageSettings.PaperSizes Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : ExcelRenderingExtensionPageSettings.PaperSizes Enumeration
Valid paper size values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ExcelRenderingExtensionPageSettings.PaperSizes
   Inherits System.Enum
public enum ExcelRenderingExtensionPageSettings.PaperSizes : System.Enum
Members
Member | Description
A2 | A2 paper (420 mm by 594 mm).
A3 | A3 paper (297 mm by 420 mm).
A3Extra | A3 extra paper (322 mm by 445 mm).
A3ExtraTransverse | A3 extra transverse paper (322 mm by 445 mm).
A3Rotated | A3 rotated paper (420 mm by 297 mm).
A3Transverse | A3 transverse paper (297 mm by 420 mm).
A4 | A4 paper (210 mm by 297 mm).
A4Extra | A4 extra paper (236 mm by 322 mm). This value is specific to the PostScript driver and is used only by Linotronic printers to help save paper.
A4Plus | A4 plus paper (210 mm by 330 mm).
A4Rotated | A4 rotated paper (297 mm by 210 mm).
A4Small | A4 small paper (210 mm by 297 mm).
A4Transverse | A4 transverse paper (210 mm by 297 mm).
A5 | A5 paper (148 mm by 210 mm).
A5Extra | A5 extra paper (174 mm by 235 mm).
A5Rotated | A5 rotated paper (210 mm by 148 mm).
A5Transverse | A5 transverse paper (148 mm by 210 mm).
A6 | A6 paper (105 mm by 148 mm).
A6Rotated | A6 rotated paper (148 mm by 105 mm).
APlus | SuperA/SuperA/A4 paper (227 mm by 356 mm).
B4 | B4 paper (250 mm by 353 mm).
B4Envelope | B4 envelope (250 mm by 353 mm).
B4JisRotated | JIS B4 rotated paper (364 mm by 257 mm).
B5 | B5 paper (176 mm by 250 mm).
B5Envelope | B5 envelope (176 mm by 250 mm).
B5Extra | ISO B5 extra paper (201 mm by 276 mm).
B5JisRotated | JIS B5 rotated paper (257 mm by 182 mm).
B5Transverse | JIS B5 transverse paper (182 mm by 257 mm).
B6Envelope | B6 envelope (176 mm by 125 mm).
B6Jis | JIS B6 paper (128 mm by 182 mm).
B6JisRotated | JIS B6 rotated paper (182 mm by 128 mm).
BPlus | SuperB/SuperB/A3 paper (305 mm by 487 mm).
C3Envelope | C3 envelope (324 mm by 458 mm).
C4Envelope | C4 envelope (229 mm by 324 mm).
C5Envelope | C5 envelope (162 mm by 229 mm).
C65Envelope | C65 envelope (114 mm by 229 mm).
C6Envelope | C6 envelope (114 mm by 162 mm).
CSheet | C paper (17 in. by 22 in.).
Default | The paper size is defined by the user.
DLEnvelope | DL envelope (110 mm by 220 mm).
DSheet | D paper (22 in. by 34 in.).
ESheet | E paper (34 in. by 44 in.).
Executive | Executive paper (7.25 in. by 10.5 in.).
Folio | Folio paper (8.5 in. by 13 in.).
GermanLegalFanfold | German legal fanfold (8.5 in. by 13 in.).
GermanStandardFanfold | German standard fanfold (8.5 in. by 12 in.).
InviteEnvelope | Invitation envelope (220 mm by 220 mm).
IsoB4 | ISO B4 (250 mm by 353 mm).
ItalyEnvelope | Italy envelope (110 mm by 230 mm).
JapaneseDoublePostcard | Japanese double postcard (200 mm by 148 mm).
JapaneseDoublePostcardRotated | Japanese rotated double postcard (148 mm by 200 mm).
JapaneseEnvelopeChouNumber3 | Japanese Chou #3 envelope.
JapaneseEnvelopeChouNumber3Rotated | Japanese rotated Chou #3 envelope.
JapaneseEnvelopeChouNumber4 | Japanese Chou #4 envelope.
JapaneseEnvelopeChouNumber4Rotated | Japanese rotated Chou #4 envelope.
JapaneseEnvelopeKakuNumber2 | Japanese Kaku #2 envelope.
JapaneseEnvelopeKakuNumber2Rotated | Japanese rotated Kaku #2 envelope.
JapaneseEnvelopeKakuNumber3 | Japanese Kaku #3 envelope.
JapaneseEnvelopeKakuNumber3Rotated | Japanese rotated Kaku #3 envelope.
JapaneseEnvelopeYouNumber4 | Japanese You #4 envelope.
JapaneseEnvelopeYouNumber4Rotated | Japanese You #4 rotated envelope.
JapanesePostcard | Japanese postcard (100 mm by 148 mm).
JapanesePostcardRotated | Japanese rotated postcard (148 mm by 100 mm).
Ledger | Ledger paper (17 in. by 11 in.).
Legal | Legal paper (8.5 in. by 14 in.).
LegalExtra | Legal extra paper (9.275 in. by 15 in.). This value is specific to the PostScript driver and is used only by Linotronic printers in order to conserve paper.
Letter | Letter paper (8.5 in. by 11 in.).
LetterExtra | Letter extra paper (9.275 in. by 12 in.). This value is specific to the PostScript driver and is used only by Linotronic printers in order to conserve paper.
LetterExtraTransverse | Letter extra transverse paper (9.275 in. by 12 in.).
LetterPlus | Letter plus paper (8.5 in. by 12.69 in.).
LetterRotated | Letter rotated paper (11 in. by 8.5 in.).
LetterSmall | Letter small paper (8.5 in. by 11 in.).
LetterTransverse | Letter transverse paper (8.275 in. by 11 in.).
MonarchEnvelope | Monarch envelope (3.875 in. by 7.5 in.).
Note | Note paper (8.5 in. by 11 in.).
Number10Envelope | #10 envelope (4.125 in. by 9.5 in.)
Number11Envelope | #11 envelope (4.5 in. by 10.375 in.).
Number12Envelope | #12 envelope (4.75 in. by 11 in.).
Number14Envelope | #14 envelope (5 in. by 11.5 in.).
Number9Envelope | #9 envelope (3.875 in. by 8.875 in.).
PersonalEnvelope | 6 3/4 envelope (3.625 in. by 6.5 in.).
Prc16K | People's Republic of China 16K paper (146 mm by 215 mm).
Prc16KRotated | People's Republic of China 16K rotated paper (146 mm by 215 mm).
Prc32K | People's Republic of China 32K paper (97 mm by 151 mm).
Prc32KBig | People's Republic of China 32K big paper (97 mm by 151 mm).
Prc32KBigRotated | People's Republic of China 32K big rotated paper (97 mm by 151 mm).
Prc32KRotated | People's Republic of China 32K rotated paper (97 mm by 151 mm).
PrcEnvelopeNumber1 | People's Republic of China #1 envelope (102 mm by 165 mm).
PrcEnvelopeNumber10 | People's Republic of China #10 envelope (324 mm by 458 mm).
PrcEnvelopeNumber10Rotated | People's Republic of China #10 rotated envelope (458 mm by 324 mm).
PrcEnvelopeNumber1Rotated | People's Republic of China #1 rotated envelope (165 mm by 102 mm).
PrcEnvelopeNumber2 | People's Republic of China #2 envelope (102 mm by 176 mm).
PrcEnvelopeNumber2Rotated | People's Republic of China #2 rotated envelope (176 mm by 102 mm).
PrcEnvelopeNumber3 | People's Republic of China #3 envelope (125 mm by 176 mm).
PrcEnvelopeNumber3Rotated | People's Republic of China #3 rotated envelope (176 mm by 125 mm).
PrcEnvelopeNumber4 | People's Republic of China #4 envelope (110 mm by 208 mm).
PrcEnvelopeNumber4Rotated | People's Republic of China #4 rotated envelope (208 mm by 110 mm).
PrcEnvelopeNumber5 | People's Republic of China #5 envelope (110 mm by 220 mm).
PrcEnvelopeNumber5Rotated | People's Republic of China Envelope #5 rotated envelope (220 mm by 110 mm).
PrcEnvelopeNumber6 | People's Republic of China #6 envelope (120 mm by 230 mm).
PrcEnvelopeNumber6Rotated | People's Republic of China #6 rotated envelope (230 mm by 120 mm).
PrcEnvelopeNumber7 | People's Republic of China #7 envelope (160 mm by 230 mm).
PrcEnvelopeNumber7Rotated | People's Republic of China #7 rotated envelope (230 mm by 160 mm).
PrcEnvelopeNumber8 | People's Republic of China #8 envelope (120 mm by 309 mm).
PrcEnvelopeNumber8Rotated | People's Republic of China #8 rotated envelope (309 mm by 120 mm).
PrcEnvelopeNumber9 | People's Republic of China #9 envelope (229 mm by 324 mm).
PrcEnvelopeNumber9Rotated | People's Republic of China #9 rotated envelope (324 mm by 229 mm).
Quarto | Quarto paper (215 mm by 275 mm).
Standard10x11 | Standard paper (10 in. by 11 in.).
Standard10x14 | Standard paper (10 in. by 14 in.).
Standard11x17 | Standard paper (11 in. by 17 in.).
Standard12x11 | Standard paper (12 in. by 11 in.).
Standard15x11 | Standard paper (15 in. by 11 in.).
Standard9x11 | Standard paper (9 in. by 11 in.).
Statement | Statement paper (5.5 in. by 8.5 in.).
Tabloid | Tabloid paper (11 in. by 17 in.).
TabloidExtra | Tabloid extra paper (11.69 in. by 18 in.). This value is specific to the PostScript driver and is used only by Linotronic printers in order to conserve paper.
USStandardFanfold | US standard fanfold (14.875 in. by 11 in.).
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionPageSettings.PaperSizes

See Also

Reference

GrapeCity.ActiveReports.Export.Excel.Page Namespace


FileFormat Enumeration

FileFormat Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : FileFormat Enumeration
Specifies the output format of Excel document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum FileFormat
   Inherits System.Enum
public enum FileFormat : System.Enum
Members
Member | Description
Xls | Excel BIFF format.
Xlsx | Excel Open XML format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Excel.Page.FileFormat

See Also

Reference

GrapeCity.ActiveReports.Export.Excel.Page Namespace


OpenXmlStandard Enumeration

OpenXmlStandard Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace : OpenXmlStandard Enumeration
Specifies the level of Open XML document conformance on exporting with Xlsx file format.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum OpenXmlStandard
   Inherits System.Enum
public enum OpenXmlStandard : System.Enum
Members
Member | Description
Strict | ISO/IEC 29500 Strict.
Transitional | ISO/IEC 29500 Transitional.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Excel.Page.OpenXmlStandard

See Also

Reference

GrapeCity.ActiveReports.Export.Excel.Page Namespace


GrapeCity.ActiveReports.Export.Excel.Section Namespace

GrapeCity.ActiveReports.Export.Excel.Section Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Excel.v10 Assembly : GrapeCity.ActiveReports.Export.Excel.Section Namespace

The GrapeCity.ActiveReports.Export.Excel.Section namespace provides Excel Export functionality for ActiveReports for .NET.

Classes
 | Class | Description
Class | XlsExport | Allows ActiveReports documents to be exported to Excel format.
Class | XlsExportException | The exception that is thrown for general exceptions that occur in the ActiveReports.XlsExport assembly.
Class | XlsPageSettings | Encapsulates the information necessary to provide Xls document print settings.
Class | XlsSecurity | Encapsulates the information necessary to provide excel document security and encryption.
Enumerations
 | Enumeration | Description
Enumeration | FileFormat | An enumeration of values which specify the file format that the exported file should support.
Enumeration | OpenXmlStandard | Specifies the level of Open XML document conformance on exporting with Xlsx file format.
Enumeration | PaperSizes | Specifies the standard paper sizes.
Remarks

Any public static members of this type (Shared in Visual Basic) are safe for multi-threaded operations. However, instance members are not guaranteed to be thread safe. For example, changing a property value in one thread while an Export method is running in a separate thread could yield unexpected results.

Optimizing your report for exporting to Excel:
Since Excel is basically a table of rows and columns and ActiveReports is a free form type output, it may be necessary to “optimize” your ActiveReport for Excel exporting. When you want two controls to be in the same column when exported to Excel, it is imperative that the two controls have exactly the same Left property value. It may also help to ensure that the font of the two controls is the same. Attempting to make the height of the two controls similar will often times lead to a cleaner looking output in Excel. Similarly if you want two controls to be in the same row when exported to Excel, you should make sure that the two controls have exactly the same Top value, that their font is the same, and that their width is similar if not the same. Using RichText controls in your ActiveReports often results in poorly formatted output in Excel. Using the Page object's drawing methods to draw anything in the margin areas of the export will cause pagination problems. To keep the pagination accurate when printing Excel-exported output with items drawn on the page, do not draw them in the margin area.

See Also

Reference

GrapeCity.ActiveReports.Export.Excel.v10 Assembly


XlsExport Class

XlsExport Class
Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsExport Class
Allows ActiveReports documents to be exported to Excel format.
Object Model
XlsExport Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class XlsExport
   Inherits System.ComponentModel.Component
   Implements GrapeCity.ActiveReports.Export.IDocumentExport, GrapeCity.ActiveReports.Export.IDocumentExportEx
public sealed class XlsExport : System.ComponentModel.Component, GrapeCity.ActiveReports.Export.IDocumentExport, GrapeCity.ActiveReports.Export.IDocumentExportEx
Remarks
Any public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Any instance members are not guaranteed to be thread safe. For example changing a property value in one thread while an Export method is running in a separate thread could yield unexpected results.

Optimizing your report for exporting to Excel:
Since Excel is basically a table of rows and columns, and ActiveReports is a free form type output it may be necessary to “optimize?your ActiveReport for Excel exporting. When you want two controls to be in the same column when outputted to excel it is imperative that the two controls have *exactly* the same left value. And it may also help to ensure that the font of the two controls is the same. Attempting to make the height of the two controls similar will often times lead to a cleaner looking output in excel. Similarly if you want two controls to be in the same row when outputted to Excel, you should make sure the two controls have exactly the same Top value, that their font is the same, and that their width is similar if not the same. Using RichText controls on your ActiveReports will often will not have good output in Excel. Using the Page object's drawing methods to draw anything in the margin areas of the export will cause pagination problems. If you draw items on the page, do not draw them in the margin area to keep the pagination accurate when printing excel exported output.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport

See Also

Reference

XlsExport Members
GrapeCity.ActiveReports.Export.Excel.Section Namespace


XlsExport Class Members

XlsExport Class Members
Properties Methods Events

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsExport Class

The following tables list the members exposed by XlsExport.

Public Constructors
 | Name | Description
Public Constructor | XlsExport Constructor | Initializes a new instance of the XlsExport class.
Top
Public Properties
 | Name | Description
Public Property | AutoRowHeight | Sets or returns a value indicating whether Excel should set the height of the row based on the contents of that row.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | DisplayGridLines | Sets or returns a value indicating whether grid lines in a workbook are displayed.
Public Property | FileFormat | Sets or returns a value indicating which file format version the exported file should support.
Public Property | MinColumnWidth | Sets or returns a value in inches indicating how small columns can be in the Excel document. Larger values reduce number of columns in a sheet.
Public Property | MinRowHeight | Sets or returns a value in inches indicating the minimum height rows can be in the Excel document. Larger values force the export to place more controls on a single line by reducing the number of rows added to match blank space.
Public Property | MultiSheet | Sets or returns a value indicating whether each page is to be exported to its own sheet. True indicates that each page in the ActiveReports document will be exported to a separate sheet.
Public Property | OpenXmlStandard | Gets or sets the level of Open XML document conformance on exporting with Xlsx file format.
Public Property | PageSettings | Returns a XlsPageSettings object for initializing Excel file print setting.
Public Property | Pagination | Gets or sets the value indicates should pagination be used for resulted xls document or not
Public Property | RemoveVerticalSpace | Sets or returns a value that indicates whether completely empty vertical spacing will be removed from the output.
Public Property | Security | Returns a XlsSecurity object for initializing document security.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | UseCellMerging | Sets or returns a value indicating whether cells should be merged together where applicable.
Public Property | UseCompression | Gets or sets the value indicating should compression be used on exporting with Xlsx file format.
Public Property | UseDefaultPalette | Sets or returns whether export document with Excel default palette.
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | Export | Overloaded. Exports the specified document to Excel format.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

XlsExport Class
GrapeCity.ActiveReports.Export.Excel.Section Namespace


XlsExport Constructor

XlsExport Constructor

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : XlsExport Constructor
Initializes a new instance of the XlsExport class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public XlsExport()
See Also

Reference

XlsExport Class
XlsExport Members


XlsExport Class Methods

XlsExport Class Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsExport Class

For a list of all members of this type, see XlsExport members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | Export | Overloaded. Exports the specified document to Excel format.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

XlsExport Class
GrapeCity.ActiveReports.Export.Excel.Section Namespace


Export Method (XlsExport)

Export Method (XlsExport)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : Export Method
Exports the specified document to Excel format.
Overload List
Overload | Description
Export(PageDocument,String) | Exports the specified document to a .xls file.
Export(PageDocument,String,String) | Exports the specified page document to Excel.
Export(PageDocument,Stream) | Exports the specified page document to Excel.
Export(PageDocument,Stream,String) | Exports the specified document to Excel.
Export(IReport,String,String) | Exports the specified IReport to file
Export(IReport,String) | Exports the specified IReport to file
Export(IReport,Stream) | Exports the specified IReport to stream
Export(IReport,Stream,String) | Exports the specified IReport to stream
Export(SectionDocument,String) | Exports the specified document to an Excel file.
Export(SectionDocument,String,String) | Exports the specified range of pages in a document to an Excel file.
Export(SectionDocument,Stream) | Exports the specified document to a stream in Excel format.
Export(SectionDocument,Stream,String) | Exports the specified range of pages in a document to a stream in Excel format.
Remarks
Only when the output on the report is valid for the following conditions, the format settings of the cells exported to Excel are set automatically.
Example
  • C#
private void Form1_Load(object sender, System.EventArgs e)
{
    rptExports rpt = new rptExports();
    this.viewer1.Document = rpt.Document;
    rpt.Run(false);

    xlsExport1.Export(this.viewer1.Document, Application.StartupPath + "\\x.xls");
}
  • VB.NET
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New rptExports()
    Viewer1.Document = rpt.Document
    rpt.Run(False)

    XlsExport1.Export(rpt.Document, Application.StartupPath + "\x.xls")
End Sub
See Also

Reference

XlsExport Class
XlsExport Members


Export(PageDocument,String) Method

Export(PageDocument,String) Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class > Export Method : Export(PageDocument,String) Method
The ActiveReports Document object to export.
The file name and path to save the main .xls file to.
Exports the specified document to a .xls file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As System.String _
)
public void Export(
   PageDocument document,
   System.string filePath
)

Parameters

document
The ActiveReports Document object to export.
filePath
The file name and path to save the main .xls file to.
See Also

Reference

XlsExport Class
XlsExport Members
Overload List


Export(PageDocument,String,String) Method

Export(PageDocument,String,String) Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class > Export Method : Export(PageDocument,String,String) Method
The ActiveReports Document object to export.
The file name and path to save the main .xls file to.
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified page document to Excel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As System.String, _
   ByVal pageRange As System.String _
)
public void Export(
   PageDocument document,
   System.string filePath,
   System.string pageRange
)

Parameters

document
The ActiveReports Document object to export.
filePath
The file name and path to save the main .xls file to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

XlsExport Class
XlsExport Members
Overload List


Export(PageDocument,Stream) Method

Export(PageDocument,Stream) Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class > Export Method : Export(PageDocument,Stream) Method
The ActiveReports Document object to export.
The Stream to write the Excel workbook to.
Exports the specified page document to Excel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal stream As System.IO.Stream _
)
public void Export(
   PageDocument document,
   System.IO.Stream stream
)

Parameters

document
The ActiveReports Document object to export.
stream
The Stream to write the Excel workbook to.
See Also

Reference

XlsExport Class
XlsExport Members
Overload List


Export(PageDocument,Stream,String) Method

Export(PageDocument,Stream,String) Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class > Export Method : Export(PageDocument,Stream,String) Method
The ActiveReports Document object to export.
The Stream to write the Excel workbook to.
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified document to Excel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal stream As System.IO.Stream, _
   ByVal pageRange As System.String _
)
public void Export(
   PageDocument document,
   System.IO.Stream stream,
   System.string pageRange
)

Parameters

document
The ActiveReports Document object to export.
stream
The Stream to write the Excel workbook to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

XlsExport Class
XlsExport Members
Overload List


Export(IReport,String,String) Method

Export(IReport,String,String) Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class > Export Method : Export(IReport,String,String) Method
IReport instance to Export
Path to export
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified IReport to file
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal filePath As System.String, _
   ByVal pageRange As System.String _
)
public void Export(
   IReport report,
   System.string filePath,
   System.string pageRange
)

Parameters

report
IReport instance to Export
filePath
Path to export
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

XlsExport Class
XlsExport Members
Overload List


Export(IReport,String) Method

Export(IReport,String) Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class > Export Method : Export(IReport,String) Method
IReport instance to Export
Path to export
Exports the specified IReport to file
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal filePath As System.String _
)
public void Export(
   IReport report,
   System.string filePath
)

Parameters

report
IReport instance to Export
filePath
Path to export
See Also

Reference

XlsExport Class
XlsExport Members
Overload List


Export(IReport,Stream) Method

Export(IReport,Stream) Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class > Export Method : Export(IReport,Stream) Method
IReport instance to Export
The output stream.
Exports the specified IReport to stream
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal outputStream As System.IO.Stream _
)
public void Export(
   IReport report,
   System.IO.Stream outputStream
)

Parameters

report
IReport instance to Export
outputStream
The output stream.
See Also

Reference

XlsExport Class
XlsExport Members
Overload List


Export(IReport,Stream,String) Method

Export(IReport,Stream,String) Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class > Export Method : Export(IReport,Stream,String) Method
IReport instance to Export
The output stream.
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified IReport to stream
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal outputStream As System.IO.Stream, _
   ByVal pageRange As System.String _
)
public void Export(
   IReport report,
   System.IO.Stream outputStream,
   System.string pageRange
)

Parameters

report
IReport instance to Export
outputStream
The output stream.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

XlsExport Class
XlsExport Members
Overload List


Export(SectionDocument,String) Method

Export(SectionDocument,String) Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class > Export Method : Export(SectionDocument,String) Method
The ActiveReports object to export.
The file name and path to which to save the spreadsheet.
Exports the specified document to an Excel file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As System.String _
)
public void Export(
   SectionDocument document,
   System.string filePath
)

Parameters

document
The ActiveReports object to export.
filePath
The file name and path to which to save the spreadsheet.
See Also

Reference

XlsExport Class
XlsExport Members
Overload List


Export(SectionDocument,String,String) Method

Export(SectionDocument,String,String) Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class > Export Method : Export(SectionDocument,String,String) Method
The ActiveReports object to export.
The file name and path to which to save the spreadsheet.
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.
Exports the specified range of pages in a document to an Excel file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As System.String, _
   ByVal pageRange As System.String _
)
public void Export(
   SectionDocument document,
   System.string filePath,
   System.string pageRange
)

Parameters

document
The ActiveReports object to export.
filePath
The file name and path to which to save the spreadsheet.
pageRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.
See Also

Reference

XlsExport Class
XlsExport Members
Overload List


Export(SectionDocument,Stream) Method

Export(SectionDocument,Stream) Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class > Export Method : Export(SectionDocument,Stream) Method
The ActiveReports object to export.
The System.IO.Stream to which to save the text.
Exports the specified document to a stream in Excel format.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As System.IO.Stream _
)
public void Export(
   SectionDocument document,
   System.IO.Stream outputStream
)

Parameters

document
The ActiveReports object to export.
outputStream
The System.IO.Stream to which to save the text.
See Also

Reference

XlsExport Class
XlsExport Members
Overload List


Export(SectionDocument,Stream,String) Method

Export(SectionDocument,Stream,String) Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class > Export Method : Export(SectionDocument,Stream,String) Method
The ActiveReports object to export.
The System.IO.Stream to which to save the text.

A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Exports the specified range of pages in a document to a stream in Excel format.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As System.IO.Stream, _
   ByVal pageRange As System.String _
)
public void Export(
   SectionDocument document,
   System.IO.Stream outputStream,
   System.string pageRange
)

Parameters

document
The ActiveReports object to export.
outputStream
The System.IO.Stream to which to save the text.
pageRange

A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

See Also

Reference

XlsExport Class
XlsExport Members
Overload List


XlsExport Class Properties

XlsExport Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsExport Class

For a list of all members of this type, see XlsExport members.

Public Properties
 | Name | Description
Public Property | AutoRowHeight | Sets or returns a value indicating whether Excel should set the height of the row based on the contents of that row.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | DisplayGridLines | Sets or returns a value indicating whether grid lines in a workbook are displayed.
Public Property | FileFormat | Sets or returns a value indicating which file format version the exported file should support.
Public Property | MinColumnWidth | Sets or returns a value in inches indicating how small columns can be in the Excel document. Larger values reduce number of columns in a sheet.
Public Property | MinRowHeight | Sets or returns a value in inches indicating the minimum height rows can be in the Excel document. Larger values force the export to place more controls on a single line by reducing the number of rows added to match blank space.
Public Property | MultiSheet | Sets or returns a value indicating whether each page is to be exported to its own sheet. True indicates that each page in the ActiveReports document will be exported to a separate sheet.
Public Property | OpenXmlStandard | Gets or sets the level of Open XML document conformance on exporting with Xlsx file format.
Public Property | PageSettings | Returns a XlsPageSettings object for initializing Excel file print setting.
Public Property | Pagination | Gets or sets the value indicates should pagination be used for resulted xls document or not
Public Property | RemoveVerticalSpace | Sets or returns a value that indicates whether completely empty vertical spacing will be removed from the output.
Public Property | Security | Returns a XlsSecurity object for initializing document security.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | UseCellMerging | Sets or returns a value indicating whether cells should be merged together where applicable.
Public Property | UseCompression | Gets or sets the value indicating should compression be used on exporting with Xlsx file format.
Public Property | UseDefaultPalette | Sets or returns whether export document with Excel default palette.
Top
See Also

Reference

XlsExport Class
GrapeCity.ActiveReports.Export.Excel.Section Namespace


AutoRowHeight Property

AutoRowHeight Property
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : AutoRowHeight Property
Sets or returns a value indicating whether Excel should set the height of the row based on the contents of that row.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoRowHeight As System.Boolean
public System.bool AutoRowHeight {get; set;}

Property Value

Boolean. Set to True if Excel should set the height of the row based on the contents of that row. Otherwise the XlsExport will calculate the height of the rows. In some cases this may make the output look better inside Excel. However, a value of True may adversely affect pagination when printing from Excel, as it will often cause Excel to stretch the height of the page. The default value is False.
Remarks
This property should usually not be set to True when the UseCellMerging property is True.
Example
  • C#
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport docexp = new GrapeCity.ActiveReports.Export.Excel.Section.XlsExport();
docexp.AutoRowHeight = true;
docexp.DisplayGridLines = true;
docexp.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95; //or Xls97Plus or Xlsx
docexp.MinColumnWidth = 3;
docexp.MinRowHeight = 1;
docexp.MultiSheet = true;
docexp.RemoveVerticalSpace = true;
docexp.UseCellMerging = false;
docexp.Export(this.viewer1.Document, Application.StartupPath + "\\x.xls");
  • Visual Basic
Dim docexp As New GrapeCity.ActiveReports.Export.Excel.Section.XlsExport()
docexp.AutoRowHeight=True
docexp.DisplayGridLines=True
docexp.FileFormat=GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95 'Or Xls97Plus
docexp.MinColumnWidth=3
docexp.MinRowHeight=1
docexp.MultiSheet=True
docexp.RemoveVerticalSpace=True
docexp.UseCellMerging=False
docexp.Export(Me.viewer1.Document, Application.StartupPath + "\x.xls")
See Also

Reference

XlsExport Class
XlsExport Members


DisplayGridLines Property (XlsExport)

DisplayGridLines Property (XlsExport)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : DisplayGridLines Property
Sets or returns a value indicating whether grid lines in a workbook are displayed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DisplayGridLines As System.Boolean
public System.bool DisplayGridLines {get; set;}

Property Value

Boolean. The default value is True.
Example
  • C#
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport docexp = new GrapeCity.ActiveReports.Export.Excel.Section.XlsExport();
docexp.AutoRowHeight = true;
docexp.DisplayGridLines = true;
docexp.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95; //or Xls97Plus or Xlsx
docexp.MinColumnWidth = 3;
docexp.MinRowHeight = 1;
docexp.MultiSheet = true;
docexp.RemoveVerticalSpace = true;
docexp.UseCellMerging = false;
docexp.Export(this.viewer1.Document, Application.StartupPath + "\\x.xls");
  • Visual Basic
Dim docexp As New GrapeCity.ActiveReports.Export.Excel.Section.XlsExport()
docexp.AutoRowHeight=True
docexp.DisplayGridLines=True
docexp.FileFormat=GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95 'Or Xls97Plus
docexp.MinColumnWidth=3
docexp.MinRowHeight=1
docexp.MultiSheet=True
docexp.RemoveVerticalSpace=True
docexp.UseCellMerging=False
docexp.Export(Me.viewer1.Document, Application.StartupPath + "\x.xls")
See Also

Reference

XlsExport Class
XlsExport Members


FileFormat Property (XlsExport)

FileFormat Property (XlsExport)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : FileFormat Property
Sets or returns a value indicating which file format version the exported file should support.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FileFormat As FileFormat
public FileFormat FileFormat {get; set;}

Property Value

FileFormat enumeration. The default value is Xls97Plus.
Example
  • Visual Basic
Dim docexp As New GrapeCity.ActiveReports.Export.Excel.Section.XlsExport()
docexp.AutoRowHeight=True
docexp.DisplayGridLines=True
docexp.FileFormat=GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95 'Or Xls97Plus
docexp.MinColumnWidth=3
docexp.MinRowHeight=1
docexp.MultiSheet=True
docexp.RemoveVerticalSpace=True
docexp.UseCellMerging=False
docexp.Export(Me.viewer1.Document, Application.StartupPath + "\x.xls")
  • C#
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport docexp = new GrapeCity.ActiveReports.Export.Excel.Section.XlsExport();
docexp.AutoRowHeight = true;
docexp.DisplayGridLines = true;
docexp.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95; //or Xls97Plus or Xlsx
docexp.MinColumnWidth = 3;
docexp.MinRowHeight = 1;
docexp.MultiSheet = true;
docexp.RemoveVerticalSpace = true;
docexp.UseCellMerging = false;
docexp.Export(this.viewer1.Document, Application.StartupPath + "\\x.xls");
See Also

Reference

XlsExport Class
XlsExport Members
FileFormat Enumeration


MinColumnWidth Property

MinColumnWidth Property
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : MinColumnWidth Property

Sets or returns a value in inches indicating how small columns can be in the Excel document. Larger values reduce number of columns in a sheet.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinColumnWidth As System.Single
public System.float MinColumnWidth {get; set;}

Property Value

Single. The default value is 0.1.
Remarks
This is typically the single most important variable to tweak when exporting to Excel.
Example
  • C#
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport docexp = new GrapeCity.ActiveReports.Export.Excel.Section.XlsExport();
docexp.AutoRowHeight = true;
docexp.DisplayGridLines = true;
docexp.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95; //or Xls97Plus or Xlsx
docexp.MinColumnWidth = 3;
docexp.MinRowHeight = 1;
docexp.MultiSheet = true;
docexp.RemoveVerticalSpace = true;
docexp.UseCellMerging = false;
docexp.Export(this.viewer1.Document, Application.StartupPath + "\\x.xls");
  • Visual Basic
Dim docexp As New GrapeCity.ActiveReports.Export.Excel.Section.XlsExport()
docexp.AutoRowHeight=True
docexp.DisplayGridLines=True
docexp.FileFormat=GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95 'Or Xls97Plus
docexp.MinColumnWidth=3
docexp.MinRowHeight=1
docexp.MultiSheet=True
docexp.RemoveVerticalSpace=True
docexp.UseCellMerging=False
docexp.Export(Me.viewer1.Document, Application.StartupPath + "\x.xls")
See Also

Reference

XlsExport Class
XlsExport Members


MinRowHeight Property

MinRowHeight Property
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : MinRowHeight Property

Sets or returns a value in inches indicating the minimum height rows can be in the Excel document. Larger values force the export to place more controls on a single line by reducing the number of rows added to match blank space.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinRowHeight As System.Single
public System.float MinRowHeight {get; set;}

Property Value

Single. The default value is 0.1.
Remarks
The MinRowHeight property takes effect only if the UseCellMerging property is set to True.
Example
  • Visual Basic
Dim docexp As New GrapeCity.ActiveReports.Export.Excel.Section.XlsExport()
docexp.AutoRowHeight=True
docexp.DisplayGridLines=True
docexp.FileFormat=GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95 'Or Xls97Plus
docexp.MinColumnWidth=3
docexp.MinRowHeight=1
docexp.MultiSheet=True
docexp.RemoveVerticalSpace=True
docexp.UseCellMerging=False
docexp.Export(Me.viewer1.Document, Application.StartupPath + "\x.xls")
  • C#
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport docexp = new GrapeCity.ActiveReports.Export.Excel.Section.XlsExport();
docexp.AutoRowHeight = true;
docexp.DisplayGridLines = true;
docexp.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95; //or Xls97Plus or Xlsx
docexp.MinColumnWidth = 3;
docexp.MinRowHeight = 1;
docexp.MultiSheet = true;
docexp.RemoveVerticalSpace = true;
docexp.UseCellMerging = false;
docexp.Export(this.viewer1.Document, Application.StartupPath + "\\x.xls");
See Also

Reference

XlsExport Class
XlsExport Members


MultiSheet Property (XlsExport)

MultiSheet Property (XlsExport)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : MultiSheet Property
Sets or returns a value indicating whether each page is to be exported to its own sheet. True indicates that each page in the ActiveReports document will be exported to a separate sheet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MultiSheet As System.Boolean
public System.bool MultiSheet {get; set;}

Property Value

Boolean. The default value is False.
Remarks
Setting this value to True can often increase performance and output quality at the cost of memory consumption up to a certain number of pages. The more complex the pages and the more deviation between page layouts in a single document, the lower the number of pages that should be exported to a single sheet. The complicity and deviation of layout between the pages drastically effects this number, but in general, a report with more than 30 pages would be a good candidate for setting this property to False.
Example
  • C#
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport docexp = new GrapeCity.ActiveReports.Export.Excel.Section.XlsExport();
docexp.AutoRowHeight = true;
docexp.DisplayGridLines = true;
docexp.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95; //or Xls97Plus or Xlsx
docexp.MinColumnWidth = 3;
docexp.MinRowHeight = 1;
docexp.MultiSheet = true;
docexp.RemoveVerticalSpace = true;
docexp.UseCellMerging = false;
docexp.Export(this.viewer1.Document, Application.StartupPath + "\\x.xls");
  • Visual Basic
Dim docexp As New GrapeCity.ActiveReports.Export.Excel.Section.XlsExport()
docexp.AutoRowHeight=True
docexp.DisplayGridLines=True
docexp.FileFormat=GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95 'Or Xls97Plus
docexp.MinColumnWidth=3
docexp.MinRowHeight=1
docexp.MultiSheet=True
docexp.RemoveVerticalSpace=True
docexp.UseCellMerging=False
docexp.Export(Me.viewer1.Document, Application.StartupPath + "\x.xls")
See Also

Reference

XlsExport Class
XlsExport Members


OpenXmlStandard Property (XlsExport)

OpenXmlStandard Property (XlsExport)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : OpenXmlStandard Property
Gets or sets the level of Open XML document conformance on exporting with Xlsx file format.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OpenXmlStandard As OpenXmlStandard
public OpenXmlStandard OpenXmlStandard {get; set;}
Remarks
The Open XML SDK saves the xlsx document in Strict standard. Use this property to convert the xlsx file to the Transitional standard for applications that cannot read the xlsx file.
Example
  • C#
SectionReport1 rpt = new SectionReport1();
GrapeCity.ActiveReports.Document.SectionDocument doc = new GrapeCity.ActiveReports.Document.SectionDocument();
doc.Pages.Add(new GrapeCity.ActiveReports.Document.Section.Page());
XlsExport export = new XlsExport();
export.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xlsx;
export.OpenXmlStandard = GrapeCity.ActiveReports.Export.Excel.Section.OpenXmlStandard.Transitional;
Stream stream = new MemoryStream();
export.Export(rpt.Document, stream);
  • VB.NET
Dim rpt As New SectionReport1()
Dim doc As New GrapeCity.ActiveReports.Document.SectionDocument()
doc.Pages.Add(New GrapeCity.ActiveReports.Document.Section.Page())
Dim export As New XlsExport()
export.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xlsx
export.OpenXmlStandard = GrapeCity.ActiveReports.Export.Excel.Section.OpenXmlStandard.Transitional
Dim stream As Stream = New MemoryStream()
export.Export(rpt.Document, stream)
See Also

Reference

XlsExport Class
XlsExport Members


PageSettings Property (XlsExport)

PageSettings Property (XlsExport)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : PageSettings Property
Returns a XlsPageSettings object for initializing Excel file print setting.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PageSettings As XlsPageSettings
public XlsPageSettings PageSettings {get;}
See Also

Reference

XlsExport Class
XlsExport Members


Pagination Property (XlsExport)

Pagination Property (XlsExport)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : Pagination Property
Gets or sets the value indicates should pagination be used for resulted xls document or not
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Pagination As System.Boolean
public System.bool Pagination {get; set;}
See Also

Reference

XlsExport Class
XlsExport Members


RemoveVerticalSpace Property (XlsExport)

RemoveVerticalSpace Property (XlsExport)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : RemoveVerticalSpace Property
Sets or returns a value that indicates whether completely empty vertical spacing will be removed from the output.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RemoveVerticalSpace As System.Boolean
public System.bool RemoveVerticalSpace {get; set;}

Property Value

Boolean. The default value is False.
Remarks
This may improve pagination if you wish to print the output from Excel.
Example
  • C#
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport docexp = new GrapeCity.ActiveReports.Export.Excel.Section.XlsExport();
docexp.AutoRowHeight = true;
docexp.DisplayGridLines = true;
docexp.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95; //or Xls97Plus or Xlsx
docexp.MinColumnWidth = 3;
docexp.MinRowHeight = 1;
docexp.MultiSheet = true;
docexp.RemoveVerticalSpace = true;
docexp.UseCellMerging = false;
docexp.Export(this.viewer1.Document, Application.StartupPath + "\\x.xls");
  • Visual Basic
Dim docexp As New GrapeCity.ActiveReports.Export.Excel.Section.XlsExport()
docexp.AutoRowHeight=True
docexp.DisplayGridLines=True
docexp.FileFormat=GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95 'Or Xls97Plus
docexp.MinColumnWidth=3
docexp.MinRowHeight=1
docexp.MultiSheet=True
docexp.RemoveVerticalSpace=True
docexp.UseCellMerging=False
docexp.Export(Me.viewer1.Document, Application.StartupPath + "\x.xls")
See Also

Reference

XlsExport Class
XlsExport Members


Security Property (XlsExport)

Security Property (XlsExport)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : Security Property
Returns a XlsSecurity object for initializing document security.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Security As XlsSecurity
public XlsSecurity Security {get;}
See Also

Reference

XlsExport Class
XlsExport Members


UseCellMerging Property

UseCellMerging Property
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : UseCellMerging Property
Sets or returns a value indicating whether cells should be merged together where applicable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseCellMerging As System.Boolean
public System.bool UseCellMerging {get; set;}

Property Value

Boolean. The default value is False.
Remarks
Since Excel95 does not support cell merging this property is not applicable when Version is set to Excel 95.
Example
  • Visual Basic
Dim docexp As New GrapeCity.ActiveReports.Export.Excel.Section.XlsExport()
docexp.AutoRowHeight=True
docexp.DisplayGridLines=True
docexp.FileFormat=GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95 'Or Xls97Plus
docexp.MinColumnWidth=3
docexp.MinRowHeight=1
docexp.MultiSheet=True
docexp.RemoveVerticalSpace=True
docexp.UseCellMerging=False
docexp.Export(Me.viewer1.Document, Application.StartupPath + "\x.xls")
  • C#
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport docexp = new GrapeCity.ActiveReports.Export.Excel.Section.XlsExport();
docexp.AutoRowHeight = true;
docexp.DisplayGridLines = true;
docexp.FileFormat = GrapeCity.ActiveReports.Export.Excel.Section.FileFormat.Xls95; //or Xls97Plus or Xlsx
docexp.MinColumnWidth = 3;
docexp.MinRowHeight = 1;
docexp.MultiSheet = true;
docexp.RemoveVerticalSpace = true;
docexp.UseCellMerging = false;
docexp.Export(this.viewer1.Document, Application.StartupPath + "\\x.xls");
See Also

Reference

XlsExport Class
XlsExport Members


UseCompression Property (XlsExport)

UseCompression Property (XlsExport)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : UseCompression Property
Gets or sets the value indicating should compression be used on exporting with Xlsx file format.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseCompression As System.Boolean
public System.bool UseCompression {get; set;}
See Also

Reference

XlsExport Class
XlsExport Members


UseDefaultPalette Property (XlsExport)

UseDefaultPalette Property (XlsExport)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : UseDefaultPalette Property
Sets or returns whether export document with Excel default palette.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseDefaultPalette As System.Boolean
public System.bool UseDefaultPalette {get; set;}
Remarks
Setting this value to true, application will use the color which is in default palette and is closest to pre-defined custom color of control's forecolor and backcolor.
See Also

Reference

XlsExport Class
XlsExport Members


XlsExportException Class

XlsExportException Class
Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsExportException Class
The exception that is thrown for general exceptions that occur in the ActiveReports.XlsExport assembly.
Object Model
XlsExportException Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class XlsExportException
   Inherits System.ApplicationException
public class XlsExportException : System.ApplicationException
Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Export.Excel.Section.XlsExportException

See Also

Reference

XlsExportException Members
GrapeCity.ActiveReports.Export.Excel.Section Namespace


XlsExportException Class Members

XlsExportException Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsExportException Class

The following tables list the members exposed by XlsExportException.

Public Constructors
 | Name | Description
Public Constructor | XlsExportException Constructor | Overloaded. Initializes a new instance of the ExcelExportException class.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

XlsExportException Class
GrapeCity.ActiveReports.Export.Excel.Section Namespace


XlsExportException Constructor

XlsExportException Constructor

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : XlsExportException Constructor
Initializes a new instance of the ExcelExportException class.
Overload List
Overload | Description
XlsExportException Constructor(String) | Initializes a new instance of the ExcelExportException class with a specified error message.
XlsExportException Constructor(String,Exception) | Initializes a new instance of the XlsExportException class with the specified error message and a reference to the inner exception that is the cause of this exception.
XlsExportException Constructor(SerializationInfo,StreamingContext) | Initializes a new instance of the ExcelExportException class with serialized data.
See Also

Reference

XlsExportException Class
XlsExportException Members


XlsExportException Constructor(String)

XlsExportException Constructor(String)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class > XlsExportException Constructor : XlsExportException Constructor(String)
A message that describes the error.
Initializes a new instance of the ExcelExportException class with a specified error message.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String _
)
public XlsExportException(
   System.string message
)

Parameters

message
A message that describes the error.
See Also

Reference

XlsExportException Class
XlsExportException Members
Overload List


XlsExportException Constructor(String,Exception)

XlsExportException Constructor(String,Exception)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class > XlsExportException Constructor : XlsExportException Constructor(String,Exception)
A message that describes the error.
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
Initializes a new instance of the XlsExportException class with the specified error message and a reference to the inner exception that is the cause of this exception.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String, _
   ByVal innerException As System.Exception _
)
public XlsExportException(
   System.string message,
   System.Exception innerException
)

Parameters

message
A message that describes the error.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
See Also

Reference

XlsExportException Class
XlsExportException Members
Overload List


XlsExportException Constructor(SerializationInfo,StreamingContext)

XlsExportException Constructor(SerializationInfo,StreamingContext)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class > XlsExportException Constructor : XlsExportException Constructor(SerializationInfo,StreamingContext)

Holds all the data needed to serialize or deserialize the object.

Describes the source and destination of a given serialized stream, as well as a means for serialization to retain that context and an additional caller-defined context.
Initializes a new instance of the ExcelExportException class with serialized data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public XlsExportException(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info

Holds all the data needed to serialize or deserialize the object.

context
Describes the source and destination of a given serialized stream, as well as a means for serialization to retain that context and an additional caller-defined context.
Remarks
This constructor is called during deserialization to reconstitute the exception object transmitted over a stream.
See Also

Reference

XlsExportException Class
XlsExportException Members
Overload List


XlsPageSettings Class

XlsPageSettings Class
Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsPageSettings Class
Encapsulates the information necessary to provide Xls document print settings.
Object Model
XlsPageSettings Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class XlsPageSettings
public class XlsPageSettings
Remarks
If you want to use default AR document print settings, you should Reset the properties on ProperGrid or invoke Reset() method.
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Excel.Section.XlsPageSettings

See Also

Reference

XlsPageSettings Members
GrapeCity.ActiveReports.Export.Excel.Section Namespace


XlsPageSettings Class Members

XlsPageSettings Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsPageSettings Class

The following tables list the members exposed by XlsPageSettings.

Public Properties
 | Name | Description
Public Property | Orientation | Gets or sets the print orientation of Excel sheet.
Public Property | PaperSize | Gets or sets the print paper size of Excel sheet.
Top
Public Methods
 | Name | Description
Public Method | Reset | Reset the properties of XlsPageSettings class.
Top
See Also

Reference

XlsPageSettings Class
GrapeCity.ActiveReports.Export.Excel.Section Namespace


XlsPageSettings Class Methods

XlsPageSettings Class Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsPageSettings Class

For a list of all members of this type, see XlsPageSettings members.

Public Methods
 | Name | Description
Public Method | Reset | Reset the properties of XlsPageSettings class.
Top
See Also

Reference

XlsPageSettings Class
GrapeCity.ActiveReports.Export.Excel.Section Namespace


Reset Method (XlsPageSettings)

Reset Method (XlsPageSettings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsPageSettings Class : Reset Method
Reset the properties of XlsPageSettings class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Reset()
public void Reset()
See Also

Reference

XlsPageSettings Class
XlsPageSettings Members


XlsPageSettings Class Properties

XlsPageSettings Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsPageSettings Class

For a list of all members of this type, see XlsPageSettings members.

Public Properties
 | Name | Description
Public Property | Orientation | Gets or sets the print orientation of Excel sheet.
Public Property | PaperSize | Gets or sets the print paper size of Excel sheet.
Top
See Also

Reference

XlsPageSettings Class
GrapeCity.ActiveReports.Export.Excel.Section Namespace


Orientation Property (XlsPageSettings)

Orientation Property (XlsPageSettings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsPageSettings Class : Orientation Property
Gets or sets the print orientation of Excel sheet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Orientation As PageOrientation
public PageOrientation Orientation {get; set;}
See Also

Reference

XlsPageSettings Class
XlsPageSettings Members


PaperSize Property (XlsPageSettings)

PaperSize Property (XlsPageSettings)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsPageSettings Class : PaperSize Property
Gets or sets the print paper size of Excel sheet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaperSize As PaperSizes
public PaperSizes PaperSize {get; set;}
Remarks
Reset this property to use default AR document print paper size.
See Also

Reference

XlsPageSettings Class
XlsPageSettings Members


XlsSecurity Class

XlsSecurity Class
Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsSecurity Class
Encapsulates the information necessary to provide excel document security and encryption.
Object Model
XlsSecurity Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class XlsSecurity
public class XlsSecurity
Remarks
If a WritePassword or a Password is supplied the Excel application will prompt for a write or open access password. If a WritePassword or a Password is not supplied no password will be requested to open the document. By correctly supplying the Password, the user will be able to open the document. By correctly supplying the WritePassword, the user will be able to write the document. If the read only recommended is set to true, the Excel application will prompt user whether to open document as read-only.
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Excel.Section.XlsSecurity

See Also

Reference

XlsSecurity Members
GrapeCity.ActiveReports.Export.Excel.Section Namespace


XlsSecurity Class Members

XlsSecurity Class Members
Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsSecurity Class

The following tables list the members exposed by XlsSecurity.

Public Properties
 | Name | Description
Public Property | Password | Gets or sets the password which can be entered to permit to open Excel document.
Public Property | ProtectedBy | Gets or sets the User Name responsible to password protect the excel spreadsheet.
Public Property | ReadOnlyRecommended | Gets or sets the value to indicate if the Excel file was saved as read only recommended.
Public Property | WritePassword | Gets or sets the write password of the Excel file.
Top
See Also

Reference

XlsSecurity Class
GrapeCity.ActiveReports.Export.Excel.Section Namespace


XlsSecurity Class Properties

XlsSecurity Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsSecurity Class

For a list of all members of this type, see XlsSecurity members.

Public Properties
 | Name | Description
Public Property | Password | Gets or sets the password which can be entered to permit to open Excel document.
Public Property | ProtectedBy | Gets or sets the User Name responsible to password protect the excel spreadsheet.
Public Property | ReadOnlyRecommended | Gets or sets the value to indicate if the Excel file was saved as read only recommended.
Public Property | WritePassword | Gets or sets the write password of the Excel file.
Top
See Also

Reference

XlsSecurity Class
GrapeCity.ActiveReports.Export.Excel.Section Namespace


Password Property (XlsSecurity)

Password Property (XlsSecurity)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsSecurity Class : Password Property
Gets or sets the password which can be entered to permit to open Excel document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Password As System.String
public System.string Password {get; set;}
See Also

Reference

XlsSecurity Class
XlsSecurity Members


ProtectedBy Property (XlsSecurity)

ProtectedBy Property (XlsSecurity)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsSecurity Class : ProtectedBy Property
Gets or sets the User Name responsible to password protect the excel spreadsheet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ProtectedBy As System.String
public System.string ProtectedBy {get; set;}
See Also

Reference

XlsSecurity Class
XlsSecurity Members


ReadOnlyRecommended Property (XlsSecurity)

ReadOnlyRecommended Property (XlsSecurity)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsSecurity Class : ReadOnlyRecommended Property
Gets or sets the value to indicate if the Excel file was saved as read only recommended.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReadOnlyRecommended As System.Boolean
public System.bool ReadOnlyRecommended {get; set;}
See Also

Reference

XlsSecurity Class
XlsSecurity Members


WritePassword Property (XlsSecurity)

WritePassword Property (XlsSecurity)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsSecurity Class : WritePassword Property
Gets or sets the write password of the Excel file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WritePassword As System.String
public System.string WritePassword {get; set;}
See Also

Reference

XlsSecurity Class
XlsSecurity Members


FileFormat Enumeration

FileFormat Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : FileFormat Enumeration
An enumeration of values which specify the file format that the exported file should support.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum FileFormat
   Inherits System.Enum
public enum FileFormat : System.Enum
Members
Member | Description
Xls95 | Microsoft Excel 95 format.
Xls97Plus | Optimized for Microsoft Excel 97 and newer versions.
Xlsx | Microsoft Excel OpenXml format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Excel.Section.FileFormat

See Also

Reference

GrapeCity.ActiveReports.Export.Excel.Section Namespace


OpenXmlStandard Enumeration

OpenXmlStandard Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : OpenXmlStandard Enumeration
Specifies the level of Open XML document conformance on exporting with Xlsx file format.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum OpenXmlStandard
   Inherits System.Enum
public enum OpenXmlStandard : System.Enum
Members
Member | Description
Strict | ISO/IEC 29500 Strict.
Transitional | ISO/IEC 29500 Transitional.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Excel.Section.OpenXmlStandard

See Also

Reference

GrapeCity.ActiveReports.Export.Excel.Section Namespace


PaperSizes Enumeration

PaperSizes Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : PaperSizes Enumeration
Specifies the standard paper sizes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PaperSizes
   Inherits System.Enum
public enum PaperSizes : System.Enum
Members
Member | Description
A2 | A2 paper (420 mm by 594 mm).
A3 | A3 paper (297 mm by 420 mm).
A3Extra | A3 extra paper (322 mm by 445 mm).
A3ExtraTransverse | A3 extra transverse paper (322 mm by 445 mm).
A3Rotated | A3 rotated paper (420 mm by 297 mm).
A3Transverse | A3 transverse paper (297 mm by 420 mm).
A4 | A4 paper (210 mm by 297 mm).
A4Extra | A4 extra paper (236 mm by 322 mm). This value is specific to the PostScript driver and is used only by Linotronic printers to help save paper.
A4Plus | A4 plus paper (210 mm by 330 mm).
A4Rotated | A4 rotated paper (297 mm by 210 mm).
A4Small | A4 small paper (210 mm by 297 mm).
A4Transverse | A4 transverse paper (210 mm by 297 mm).
A5 | A5 paper (148 mm by 210 mm).
A5Extra | A5 extra paper (174 mm by 235 mm).
A5Rotated | A5 rotated paper (210 mm by 148 mm).
A5Transverse | A5 transverse paper (148 mm by 210 mm).
A6 | A6 paper (105 mm by 148 mm).
A6Rotated | A6 rotated paper (148 mm by 105 mm).
APlus | SuperA/SuperA/A4 paper (227 mm by 356 mm).
B4 | B4 paper (250 mm by 353 mm).
B4Envelope | B4 envelope (250 mm by 353 mm).
B4JisRotated | JIS B4 rotated paper (364 mm by 257 mm).
B5 | B5 paper (176 mm by 250 mm).
B5Envelope | B5 envelope (176 mm by 250 mm).
B5Extra | ISO B5 extra paper (201 mm by 276 mm).
B5JisRotated | JIS B5 rotated paper (257 mm by 182 mm).
B5Transverse | JIS B5 transverse paper (182 mm by 257 mm).
B6Envelope | B6 envelope (176 mm by 125 mm).
B6Jis | JIS B6 paper (128 mm by 182 mm).
B6JisRotated | JIS B6 rotated paper (182 mm by 128 mm).
BPlus | SuperB/SuperB/A3 paper (305 mm by 487 mm).
C3Envelope | C3 envelope (324 mm by 458 mm).
C4Envelope | C4 envelope (229 mm by 324 mm).
C5Envelope | C5 envelope (162 mm by 229 mm).
C65Envelope | C65 envelope (114 mm by 229 mm).
C6Envelope | C6 envelope (114 mm by 162 mm).
CSheet | C paper (17 in. by 22 in.).
Default | No specific paper.
DLEnvelope | DL envelope (110 mm by 220 mm).
DSheet | D paper (22 in. by 34 in.).
ESheet | E paper (34 in. by 44 in.).
Executive | Executive paper (7.25 in. by 10.5 in.).
Folio | Folio paper (8.5 in. by 13 in.).
GermanLegalFanfold | German legal fanfold (8.5 in. by 13 in.).
GermanStandardFanfold | German standard fanfold (8.5 in. by 12 in.).
InviteEnvelope | Invitation envelope (220 mm by 220 mm).
IsoB4 | ISO B4 (250 mm by 353 mm).
ItalyEnvelope | Italy envelope (110 mm by 230 mm).
JapaneseDoublePostcard | Japanese double postcard (200 mm by 148 mm).
JapaneseDoublePostcardRotated | Japanese rotated double postcard (148 mm by 200 mm).
JapaneseEnvelopeChouNumber3 | Japanese Chou #3 envelope.
JapaneseEnvelopeChouNumber3Rotated | Japanese rotated Chou #3 envelope.
JapaneseEnvelopeChouNumber4 | Japanese Chou #4 envelope.
JapaneseEnvelopeChouNumber4Rotated | Japanese rotated Chou #4 envelope.
JapaneseEnvelopeKakuNumber2 | Japanese Kaku #2 envelope.
JapaneseEnvelopeKakuNumber2Rotated | Japanese rotated Kaku #2 envelope.
JapaneseEnvelopeKakuNumber3 | Japanese Kaku #3 envelope.
JapaneseEnvelopeKakuNumber3Rotated | Japanese rotated Kaku #3 envelope.
JapaneseEnvelopeYouNumber4 | Japanese You #4 envelope.
JapaneseEnvelopeYouNumber4Rotated | Japanese You #4 rotated envelope.
JapanesePostcard | Japanese postcard (100 mm by 148 mm).
JapanesePostcardRotated | Japanese rotated postcard (148 mm by 100 mm).
Ledger | Ledger paper (17 in. by 11 in.).
Legal | Legal paper (8.5 in. by 14 in.).
LegalExtra | Legal extra paper (9.275 in. by 15 in.). This value is specific to the PostScript driver and is used only by Linotronic printers in order to conserve paper.
Letter | Letter paper (8.5 in. by 11 in.).
LetterExtra | Letter extra paper (9.275 in. by 12 in.). This value is specific to the PostScript driver and is used only by Linotronic printers in order to conserve paper.
LetterExtraTransverse | Letter extra transverse paper (9.275 in. by 12 in.).
LetterPlus | Letter plus paper (8.5 in. by 12.69 in.).
LetterRotated | Letter rotated paper (11 in. by 8.5 in.).
LetterSmall | Letter small paper (8.5 in. by 11 in.).
LetterTransverse | Letter transverse paper (8.275 in. by 11 in.).
MonarchEnvelope | Monarch envelope (3.875 in. by 7.5 in.).
Note | Note paper (8.5 in. by 11 in.).
Number10Envelope | #10 envelope (4.125 in. by 9.5 in.).
Number11Envelope | #11 envelope (4.5 in. by 10.375 in.).
Number12Envelope | #12 envelope (4.75 in. by 11 in.).
Number14Envelope | #14 envelope (5 in. by 11.5 in.).
Number9Envelope | #9 envelope (3.875 in. by 8.875 in.).
PersonalEnvelope | 6 3/4 envelope (3.625 in. by 6.5 in.).
Prc16K | People's Republic of China 16K paper (146 mm by 215 mm).
Prc16KRotated | People's Republic of China 16K rotated paper (146 mm by 215 mm).
Prc32K | People's Republic of China 32K paper (97 mm by 151 mm).
Prc32KBig | People's Republic of China 32K big paper (97 mm by 151 mm).
Prc32KBigRotated | People's Republic of China 32K big rotated paper (97 mm by 151 mm).
Prc32KRotated | People's Republic of China 32K rotated paper (97 mm by 151 mm).
PrcEnvelopeNumber1 | People's Republic of China #1 envelope (102 mm by 165 mm).
PrcEnvelopeNumber10 | People's Republic of China #10 envelope (324 mm by 458 mm).
PrcEnvelopeNumber10Rotated | People's Republic of China #10 rotated envelope (458 mm by 324 mm).
PrcEnvelopeNumber1Rotated | People's Republic of China #1 rotated envelope (165 mm by 102 mm).
PrcEnvelopeNumber2 | People's Republic of China #2 envelope (102 mm by 176 mm).
PrcEnvelopeNumber2Rotated | People's Republic of China #2 rotated envelope (176 mm by 102 mm).
PrcEnvelopeNumber3 | People's Republic of China #3 envelope (125 mm by 176 mm).
PrcEnvelopeNumber3Rotated | People's Republic of China #3 rotated envelope (176 mm by 125 mm).
PrcEnvelopeNumber4 | People's Republic of China #4 envelope (110 mm by 208 mm).
PrcEnvelopeNumber4Rotated | People's Republic of China #4 rotated envelope (208 mm by 110 mm).
PrcEnvelopeNumber5 | People's Republic of China #5 envelope (110 mm by 220 mm).
PrcEnvelopeNumber5Rotated | People's Republic of China Envelope #5 rotated envelope (220 mm by 110 mm).
PrcEnvelopeNumber6 | People's Republic of China #6 envelope (120 mm by 230 mm).
PrcEnvelopeNumber6Rotated | People's Republic of China #6 rotated envelope (230 mm by 120 mm).
PrcEnvelopeNumber7 | People's Republic of China #7 envelope (160 mm by 230 mm).
PrcEnvelopeNumber7Rotated | People's Republic of China #7 rotated envelope (230 mm by 160 mm).
PrcEnvelopeNumber8 | People's Republic of China #8 envelope (120 mm by 309 mm).
PrcEnvelopeNumber8Rotated | People's Republic of China #8 rotated envelope (309 mm by 120 mm).
PrcEnvelopeNumber9 | People's Republic of China #9 envelope (229 mm by 324 mm).
PrcEnvelopeNumber9Rotated | People's Republic of China #9 rotated envelope (324 mm by 229 mm).
Quarto | Quarto paper (215 mm by 275 mm).
Standard10x11 | Standard paper (10 in. by 11 in.).
Standard10x14 | Standard paper (10 in. by 14 in.).
Standard11x17 | Standard paper (11 in. by 17 in.).
Standard12x11 | Standard paper (12 in. by 11 in.).
Standard15x11 | Standard paper (15 in. by 11 in.).
Standard9x11 | Standard paper (9 in. by 11 in.).
Statement | Statement paper (5.5 in. by 8.5 in.).
Tabloid | Tabloid paper (11 in. by 17 in.).
TabloidExtra | Tabloid extra paper (11.69 in. by 18 in.). This value is specific to the PostScript driver and is used only by Linotronic printers in order to conserve paper.
USStandardFanfold | US standard fanfold (14.875 in. by 11 in.).
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Excel.Section.PaperSizes

See Also

Reference

GrapeCity.ActiveReports.Export.Excel.Section Namespace


GrapeCity.SpreadBuilder Namespace

GrapeCity.SpreadBuilder Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Excel.v10 Assembly : GrapeCity.SpreadBuilder Namespace
The GrapeCity.SpreadBuilder namespace contains the Column, Row, Sheet and Workbook classes used for building Excel spreadsheets.
Classes
 | Class | Description
Class | ColumnCountOutOfRangeException | Thrown when the columns' count is out of range in a specific excel format.
Class | CompressionException | Indicates that an error (most likely related to images) occurred in the compression library.
Class | DDColumn | Represents a column in a spreadsheet.
Class | DDRow | Represents a single row in a sheet.
Class | DDSecurity | Encapsulates the information necessary to provide spreadsheet document security and encryption.
Class | DDSheet | Represents an Excel worksheet.
Class | DDSheetNameAlreadyExistsException | Thrown when you try to set a Name property to a value already in use.
Class | DDSheets | A collection of DDSheet objects.
Class | InvalidDDSheetNameException | Thrown when change a sheet's name to an invalid value. The name cannot be empty, cannot exceed 31 characters and cannot contain any of following characters: : \ / ? * [ or ]
Class | InvalidPasswordException | Thrown when the password is invalid in a specific excel format.(For example: the length of password is out of range.)
Class | NoDDSheetsException | Thrown when an operation is requested that requires at least one sheet in the Sheets collection (for example Saving the workbook) and no sheets exist.
Class | RowCountOutOfRangeException | Thrown when the rows' count is out of range in a specific excel format.
Class | SpreadBuilderException | A general exception thrown for application errors in the GrapeCity.SpreadBuilder assembly.
Class | VersionNotImplementedException | Indicates that a feature or features were not implemented for a particular version of the Excel/BIFF file format.
Class | Workbook | Represents a workbook that contains spreadsheets. This object presents information that is relevant to all spreadsheets in the workbook (e.g. Author, BIFF/file version, etc.).
Enumerations
 | Enumeration | Description
Enumeration | FileFormat | Specifies the file format that the outputted file should support.
See Also

Reference

GrapeCity.ActiveReports.Export.Excel.v10 Assembly


ColumnCountOutOfRangeException Class

ColumnCountOutOfRangeException Class
Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : ColumnCountOutOfRangeException Class
Thrown when the columns' count is out of range in a specific excel format.
Object Model
ColumnCountOutOfRangeException Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ColumnCountOutOfRangeException
   Inherits SpreadBuilderException
public class ColumnCountOutOfRangeException : SpreadBuilderException
Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.SpreadBuilder.SpreadBuilderException
GrapeCity.SpreadBuilder.ColumnCountOutOfRangeException

See Also

Reference

ColumnCountOutOfRangeException Members
GrapeCity.SpreadBuilder Namespace


ColumnCountOutOfRangeException Class Members

ColumnCountOutOfRangeException Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : ColumnCountOutOfRangeException Class

The following tables list the members exposed by ColumnCountOutOfRangeException.

Public Constructors
 | Name | Description
Public Constructor | ColumnCountOutOfRangeException Constructor | Overloaded. Initializes a new instance of the ColumnCountOutOfRangeException class.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

ColumnCountOutOfRangeException Class
GrapeCity.SpreadBuilder Namespace


ColumnCountOutOfRangeException Constructor

ColumnCountOutOfRangeException Constructor

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : ColumnCountOutOfRangeException Constructor
Initializes a new instance of the ColumnCountOutOfRangeException class.
Overload List
Overload | Description
ColumnCountOutOfRangeException Constructor(String) | Initializes a new instance of the ColumnCountOutOfRangeException class with specific error message.
ColumnCountOutOfRangeException Constructor() | Initializes a new instance of the ColumnCountOutOfRangeException class with default error message.
See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


ColumnCountOutOfRangeException Constructor(String)

ColumnCountOutOfRangeException Constructor(String)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class > ColumnCountOutOfRangeException Constructor : ColumnCountOutOfRangeException Constructor(String)
A message that describes the error.
Initializes a new instance of the ColumnCountOutOfRangeException class with specific error message.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String _
)
public ColumnCountOutOfRangeException(
   System.string message
)

Parameters

message
A message that describes the error.
See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members
Overload List


ColumnCountOutOfRangeException Constructor()

ColumnCountOutOfRangeException Constructor()

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class > ColumnCountOutOfRangeException Constructor : ColumnCountOutOfRangeException Constructor()
Initializes a new instance of the ColumnCountOutOfRangeException class with default error message.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ColumnCountOutOfRangeException()
See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members
Overload List


CompressionException Class

CompressionException Class
Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : CompressionException Class
Indicates that an error (most likely related to images) occurred in the compression library.
Object Model
CompressionException Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class CompressionException
   Inherits SpreadBuilderException
public class CompressionException : SpreadBuilderException
Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.SpreadBuilder.SpreadBuilderException
GrapeCity.SpreadBuilder.CompressionException

See Also

Reference

CompressionException Members
GrapeCity.SpreadBuilder Namespace


CompressionException Class Members

CompressionException Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : CompressionException Class

The following tables list the members exposed by CompressionException.

Public Constructors
 | Name | Description
Public Constructor | CompressionException Constructor | Overloaded. Initializes a new instance of the CompressionException class.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

CompressionException Class
GrapeCity.SpreadBuilder Namespace


CompressionException Constructor

CompressionException Constructor

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : CompressionException Constructor
Initializes a new instance of the CompressionException class.
Overload List
Overload | Description
CompressionException Constructor() | Initializes a new instance of the CompressionException class.
CompressionException Constructor(String) | Initializes a new instance of the CompressionException class with the specified error message.
CompressionException Constructor(String,Exception) | Initializes a new instance of the CompressionException class with the specified error message and a reference to the inner exception that is the cause of this exception.
See Also

Reference

CompressionException Class
CompressionException Members


CompressionException Constructor()

CompressionException Constructor()

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class > CompressionException Constructor : CompressionException Constructor()
Initializes a new instance of the CompressionException class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public CompressionException()
See Also

Reference

CompressionException Class
CompressionException Members
Overload List


CompressionException Constructor(String)

CompressionException Constructor(String)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class > CompressionException Constructor : CompressionException Constructor(String)
A message that describes the error.
Initializes a new instance of the CompressionException class with the specified error message.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal sMessage As System.String _
)
public CompressionException(
   System.string sMessage
)

Parameters

sMessage
A message that describes the error.
See Also

Reference

CompressionException Class
CompressionException Members
Overload List


CompressionException Constructor(String,Exception)

CompressionException Constructor(String,Exception)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class > CompressionException Constructor : CompressionException Constructor(String,Exception)
A message that describes the error.
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
Initializes a new instance of the CompressionException class with the specified error message and a reference to the inner exception that is the cause of this exception.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal sMessage As System.String, _
   ByVal oInnerException As System.Exception _
)
public CompressionException(
   System.string sMessage,
   System.Exception oInnerException
)

Parameters

sMessage
A message that describes the error.
oInnerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
See Also

Reference

CompressionException Class
CompressionException Members
Overload List


DDColumn Class

DDColumn Class
Members Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : DDColumn Class
Represents a column in a spreadsheet.
Object Model
DDColumn Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DDColumn
public class DDColumn
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.DDColumn

See Also

Reference

DDColumn Members
GrapeCity.SpreadBuilder Namespace


DDColumn Class Members

DDColumn Class Members
Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : DDColumn Class

The following tables list the members exposed by DDColumn.

Public Properties
 | Name | Description
Public Property | Column | Returns the zero-based column number that this object represents.
Public Property | OwnerSheet | Returns the sheet on which this column is located.
Public Property | Width | Sets or returns the width of the column in Twips.
Top
See Also

Reference

DDColumn Class
GrapeCity.SpreadBuilder Namespace


DDColumn Class Properties

DDColumn Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : DDColumn Class

For a list of all members of this type, see DDColumn members.

Public Properties
 | Name | Description
Public Property | Column | Returns the zero-based column number that this object represents.
Public Property | OwnerSheet | Returns the sheet on which this column is located.
Public Property | Width | Sets or returns the width of the column in Twips.
Top
See Also

Reference

DDColumn Class
GrapeCity.SpreadBuilder Namespace


Column Property (DDColumn)

Column Property (DDColumn)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDColumn Class : Column Property
Returns the zero-based column number that this object represents.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Column As System.Short
public System.short Column {get;}

Property Value

Short.
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub
See Also

Reference

DDColumn Class
DDColumn Members


OwnerSheet Property

OwnerSheet Property
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDColumn Class : OwnerSheet Property
Returns the sheet on which this column is located.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property OwnerSheet As DDSheet
public DDSheet OwnerSheet {get;}

Property Value

GrapeCity.SpreadBuilder.DDSheet.
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub
See Also

Reference

DDColumn Class
DDColumn Members
DDSheet Class


Width Property (DDColumn)

Width Property (DDColumn)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDColumn Class : Width Property
Sets or returns the width of the column in Twips.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As System.Integer
public System.int Width {get; set;}

Property Value

Integer.
Remarks
The value will be converted to Excel's "1/256 character width" unit system.
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub
See Also

Reference

DDColumn Class
DDColumn Members


DDRow Class

DDRow Class
Members Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : DDRow Class
Represents a single row in a sheet.
Object Model
DDRow Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DDRow
public class DDRow
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.DDRow

See Also

Reference

DDRow Members
GrapeCity.SpreadBuilder Namespace


DDRow Class Members

DDRow Class Members
Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : DDRow Class

The following tables list the members exposed by DDRow.

Public Constructors
 | Name | Description
Public Constructor | DDRow Constructor | Initializes a new instance of a DDRow with the specified sheet as a parent, and the specified row number as the row this instance represents.
Top
Public Properties
 | Name | Description
Public Property | AutoSize | Sets or returns a value indicating whether Excel will automatically determine the row's height based on its contents.
Public Property | Height | Sets or returns a value indicating the height for the row in 1/20ths of a point.
Top
See Also

Reference

DDRow Class
GrapeCity.SpreadBuilder Namespace


DDRow Constructor

DDRow Constructor

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDRow Class : DDRow Constructor
The sheet on which this row is located.
Returns the zero-based row number this instance represents.
Initializes a new instance of a DDRow with the specified sheet as a parent, and the specified row number as the row this instance represents.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal parentSheet As DDSheet, _
   ByVal row As System.Integer _
)
public DDRow(
   DDSheet parentSheet,
   System.int row
)

Parameters

parentSheet
The sheet on which this row is located.
row
Returns the zero-based row number this instance represents.
See Also

Reference

DDRow Class
DDRow Members


DDRow Class Properties

DDRow Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : DDRow Class

For a list of all members of this type, see DDRow members.

Public Properties
 | Name | Description
Public Property | AutoSize | Sets or returns a value indicating whether Excel will automatically determine the row's height based on its contents.
Public Property | Height | Sets or returns a value indicating the height for the row in 1/20ths of a point.
Top
See Also

Reference

DDRow Class
GrapeCity.SpreadBuilder Namespace


AutoSize Property (DDRow)

AutoSize Property (DDRow)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDRow Class : AutoSize Property
Sets or returns a value indicating whether Excel will automatically determine the row's height based on its contents.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoSize As System.Boolean
public System.bool AutoSize {get; set;}

Property Value

Boolean. The default value is True.
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    sb.Sheets[0].Rows(0).AutoSize = false;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        .Rows(0).AutoSize = False
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub
See Also

Reference

DDRow Class
DDRow Members


Height Property (DDRow)

Height Property (DDRow)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDRow Class : Height Property
Sets or returns a value indicating the height for the row in 1/20ths of a point.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As System.Integer
public System.int Height {get; set;}

Property Value

Integer. The default value is 12.75 points (or 255 in twips).
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub
See Also

Reference

DDRow Class
DDRow Members


DDSecurity Class

DDSecurity Class
Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : DDSecurity Class
Encapsulates the information necessary to provide spreadsheet document security and encryption.
Object Model
DDSecurity Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DDSecurity
public class DDSecurity
Remarks
If a WritePassword or a Password is supplied the spreadsheet application will prompt for a write or open access password. If a WritePassword or a Password is not supplied no password will be requested to open the document. By correctly supplying the Password, the user will be able to open the document. By correctly supplying the WritePassword, the user will be able to write the document. If the read only recommended is set to true, the Excel application will prompt user whether to open document as read-only.
Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.DDSecurity

See Also

Reference

DDSecurity Members
GrapeCity.SpreadBuilder Namespace


DDSecurity Class Members

DDSecurity Class Members
Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : DDSecurity Class

The following tables list the members exposed by DDSecurity.

Public Properties
 | Name | Description
Public Property | Password | Gets or sets the password which can be entered to permit to open spreadsheet document.
Public Property | ProtectedBy | Gets or sets the User Name responsible to password protect the spreadsheet document.
Public Property | ReadOnlyRecommended | Gets or sets the value to indicate if the spreadsheet document was saved as read only recommended.
Public Property | WritePassword | Gets or sets the write password of the spreadsheet document.
Top
See Also

Reference

DDSecurity Class
GrapeCity.SpreadBuilder Namespace


DDSecurity Class Properties

DDSecurity Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : DDSecurity Class

For a list of all members of this type, see DDSecurity members.

Public Properties
 | Name | Description
Public Property | Password | Gets or sets the password which can be entered to permit to open spreadsheet document.
Public Property | ProtectedBy | Gets or sets the User Name responsible to password protect the spreadsheet document.
Public Property | ReadOnlyRecommended | Gets or sets the value to indicate if the spreadsheet document was saved as read only recommended.
Public Property | WritePassword | Gets or sets the write password of the spreadsheet document.
Top
See Also

Reference

DDSecurity Class
GrapeCity.SpreadBuilder Namespace


Password Property (DDSecurity)

Password Property (DDSecurity)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSecurity Class : Password Property
Gets or sets the password which can be entered to permit to open spreadsheet document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Password As System.String
public System.string Password {get; set;}
Remarks
Checks if the password is valid when Workbook.Save method is invoked.
See Also

Reference

DDSecurity Class
DDSecurity Members


ProtectedBy Property (DDSecurity)

ProtectedBy Property (DDSecurity)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSecurity Class : ProtectedBy Property
Gets or sets the User Name responsible to password protect the spreadsheet document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ProtectedBy As System.String
public System.string ProtectedBy {get; set;}
Remarks
Cannot exceed 52 characters.
See Also

Reference

DDSecurity Class
DDSecurity Members


ReadOnlyRecommended Property (DDSecurity)

ReadOnlyRecommended Property (DDSecurity)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSecurity Class : ReadOnlyRecommended Property
Gets or sets the value to indicate if the spreadsheet document was saved as read only recommended.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReadOnlyRecommended As System.Boolean
public System.bool ReadOnlyRecommended {get; set;}
See Also

Reference

DDSecurity Class
DDSecurity Members


WritePassword Property (DDSecurity)

WritePassword Property (DDSecurity)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSecurity Class : WritePassword Property
Gets or sets the write password of the spreadsheet document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WritePassword As System.String
public System.string WritePassword {get; set;}

Property Value

Cannot exceed 15 characters.
See Also

Reference

DDSecurity Class
DDSecurity Members


DDSheet Class

DDSheet Class
Members Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : DDSheet Class
Represents an Excel worksheet.
Object Model
DDSheet Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DDSheet
public class DDSheet
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.DDSheet

See Also

Reference

DDSheet Members
GrapeCity.SpreadBuilder Namespace


DDSheet Class Members

DDSheet Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : DDSheet Class

The following tables list the members exposed by DDSheet.

Public Properties
 | Name | Description
Public Property | DisplayGridLines | Sets or returns the flag indicating whether grid lines are displayed in the sheet.
Public Property | Name | Sets or returns the name of the DDSheet.
Public Property | PageSetup | Returns the current information about this sheet when printed. This information is displayed in Excel in the page setup dialog.
Public Property | ParentSheets | Returns the DDSheets collection of which this DDSheet is a member.
Top
Public Methods
 | Name | Description
Public Method | AddHorizontalPageBreak | Adds a horizontal (row) page break.
Public Method | AddImage | Adds the specified image (currently stored as PNG format) to this sheet with the specified location, and settings.
Public Method | AddLine | Adds one line with the specified coordinates and properties.
Public Method | AddVerticalPageBreak | Adds a vertical (column) page break.
Public Method | Cell | Returns the DDCell object for the specified row and column.
Public Method | Cells | Returns a DDCell instance for the specified cell number.
Public Method | Clear | Deletes all properties and content, creating a blank sheet.
Public Method | Columns | Returns the DDColumn object representing the specified column.
Public Method | IsMerged | Sets or returns a value indicating whether the specified cell's XFRecord has its fMergeCell member set to True.
Public Method | Rows | Returns a DDRow instance for the specified row number.
Public Method | UnMergeCells | Removes the MergeArea from the MergedAreas record for this sheet.
Top
See Also

Reference

DDSheet Class
GrapeCity.SpreadBuilder Namespace


DDSheet Class Methods

DDSheet Class Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : DDSheet Class

For a list of all members of this type, see DDSheet members.

Public Methods
 | Name | Description
Public Method | AddHorizontalPageBreak | Adds a horizontal (row) page break.
Public Method | AddImage | Adds the specified image (currently stored as PNG format) to this sheet with the specified location, and settings.
Public Method | AddLine | Adds one line with the specified coordinates and properties.
Public Method | AddVerticalPageBreak | Adds a vertical (column) page break.
Public Method | Cell | Returns the DDCell object for the specified row and column.
Public Method | Cells | Returns a DDCell instance for the specified cell number.
Public Method | Clear | Deletes all properties and content, creating a blank sheet.
Public Method | Columns | Returns the DDColumn object representing the specified column.
Public Method | IsMerged | Sets or returns a value indicating whether the specified cell's XFRecord has its fMergeCell member set to True.
Public Method | Rows | Returns a DDRow instance for the specified row number.
Public Method | UnMergeCells | Removes the MergeArea from the MergedAreas record for this sheet.
Top
See Also

Reference

DDSheet Class
GrapeCity.SpreadBuilder Namespace


AddHorizontalPageBreak Method

AddHorizontalPageBreak Method
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : AddHorizontalPageBreak Method
The one-based row value of the break.
The one-based starting column for the break.
The one-based ending column for the break.
Adds a horizontal (row) page break.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddHorizontalPageBreak( _
   ByVal row As System.UShort, _
   ByVal columnstart As System.UShort, _
   ByVal columnend As System.UShort _
)
public void AddHorizontalPageBreak(
   System.ushort row,
   System.ushort columnstart,
   System.ushort columnend
)

Parameters

row
The one-based row value of the break.
columnstart
The one-based starting column for the break.
columnend
The one-based ending column for the break.
Remarks
PageBreaks may not overlap. The break occurs after the specified row or column.
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    sb.Sheets[0].AddHorizontalPageBreak(2, 0, 2);

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

     sb.Sheets(0).AddHorizontalPageBreak(2, 0, 2)

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub
See Also

Reference

DDSheet Class
DDSheet Members


AddImage(Image,ImageInfo,Color,Color,Int32,Int16,Int32,Int16,Int32,Int16,Int32,Int16,String) Method

AddImage(Image,ImageInfo,Color,Color,Int32,Int16,Int32,Int16,Int32,Int16,Int32,Int16,String) Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class > AddImage Method : AddImage(Image,ImageInfo,Color,Color,Int32,Int16,Int32,Int16,Int32,Int16,Int32,Int16,String) Method
This is an image object that represents the image to be placed on the sheet.
SpreadBuilder.Imaging.ImageInfo.
A System.Drawing.Color for the border lines on the image.
A System.Drawing.Color for the background of the image.
The column containing the upper-left corner of the object's bounding rectangle.
The X (horizontal) position of the upper-left corner of the object's bounding rectangle, relative to the left side of the underlying cell (specified in colL), expressed as 1/1024th of the cell's width.
The row containing the upper-left corner of the object's bounding rectangle.
The Y (vertical) position of the upper-left corner of the object's bounding rectangle, relative to the top of the underlying cell, expressed as 1/1024th of the cell's height.
The column containing the lower-right corner of the object's bounding rectangle.
The X (horizontal) position of the lower-right corner of the object's bounding rectangle, relative to the left side of the underlying cell, expressed as 1/1024th of the cell's width.

The row containing the lower-right corner of the object's bounding rectangle.
The Y (vertical) position of the lower-right corner of the object's bounding rectangle, relative to the top of the underlying cell, expressed as 1/1024th of the cell's height.
To add a clickable hyperlink to the image, specify the URL here. Otherwise use an empty string.
Adds the specified image (currently stored as PNG format) to this sheet with the specified location, and settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddImage( _
   ByVal img As Image, _
   ByVal imageOptions As ImageInfo, _
   ByVal lineColor As Color, _
   ByVal backColor As Color, _
   ByVal columnLeft As System.Integer, _
   ByVal dxL As System.Short, _
   ByVal rowTop As System.Integer, _
   ByVal dyT As System.Short, _
   ByVal columnRight As System.Integer, _
   ByVal dxR As System.Short, _
   ByVal rowBottom As System.Integer, _
   ByVal dyB As System.Short, _
   ByVal hyperlink As System.String _
)
public void AddImage(
   Image img,
   ImageInfo imageOptions,
   Color lineColor,
   Color backColor,
   System.int columnLeft,
   System.short dxL,
   System.int rowTop,
   System.short dyT,
   System.int columnRight,
   System.short dxR,
   System.int rowBottom,
   System.short dyB,
   System.string hyperlink
)

Parameters

img
This is an image object that represents the image to be placed on the sheet.
imageOptions
SpreadBuilder.Imaging.ImageInfo.
lineColor
A System.Drawing.Color for the border lines on the image.
backColor
A System.Drawing.Color for the background of the image.
columnLeft
The column containing the upper-left corner of the object's bounding rectangle.
dxL
The X (horizontal) position of the upper-left corner of the object's bounding rectangle, relative to the left side of the underlying cell (specified in colL), expressed as 1/1024th of the cell's width.
rowTop
The row containing the upper-left corner of the object's bounding rectangle.
dyT
The Y (vertical) position of the upper-left corner of the object's bounding rectangle, relative to the top of the underlying cell, expressed as 1/1024th of the cell's height.
columnRight
The column containing the lower-right corner of the object's bounding rectangle.
dxR
The X (horizontal) position of the lower-right corner of the object's bounding rectangle, relative to the left side of the underlying cell, expressed as 1/1024th of the cell's width.
rowBottom

The row containing the lower-right corner of the object's bounding rectangle.
dyB
The Y (vertical) position of the lower-right corner of the object's bounding rectangle, relative to the top of the underlying cell, expressed as 1/1024th of the cell's height.
hyperlink
To add a clickable hyperlink to the image, specify the URL here. Otherwise use an empty string.
See Also

Reference

DDSheet Class
DDSheet Members
Overload List


AddLine Method (DDSheet)

AddLine Method (DDSheet)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : AddLine Method
A LineInfo object with its members set to the proper line configuration values. See the LineInfo class for more information.
Adds one line with the specified coordinates and properties.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddLine( _
   ByVal li As LineInfo _
)
public void AddLine(
   LineInfo li
)

Parameters

li
A LineInfo object with its members set to the proper line configuration values. See the LineInfo class for more information.
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
//Dimension a Workbook and add a sheet to its Sheets collection
GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
sb.Sheets.AddNew();

//Set up properties and values for columns, rows and cells as desired
sb.Sheets[0].Name = "Customer Call List";
sb.Sheets[0].Columns(0).Width = 2 * 1440;
sb.Sheets[0].Columns(1).Width = 1440;
sb.Sheets[0].Columns(2).Width = 1440;
sb.Sheets[0].Rows(0).Height = 1440 / 4;
//Header row
sb.Sheets[0].Cell(0, 0).SetValue("Company Name");
sb.Sheets[0].Cell(0, 0).FontBold = true;
sb.Sheets[0].Cell(0, 1).SetValue("Contact Name");
sb.Sheets[0].Cell(0, 1).FontBold = true;
sb.Sheets[0].Cell(0, 2).SetValue("Phone");
sb.Sheets[0].Cell(0, 2).FontBold = true;
//First row of data
sb.Sheets[0].Cell(1, 0).SetValue("GrapeCity");
sb.Sheets[0].Cell(1, 1).SetValue("Mortimer");
sb.Sheets[0].Cell(1, 2).SetValue("(614) 895-3142");

GrapeCity.SpreadBuilder.Imaging.LineInfo l = new GrapeCity.SpreadBuilder.Imaging.LineInfo();
l.ColumnLeft = 3; //starting column for the line
l.Color = System.Drawing.Color.Salmon; //color for the line
l.ColumnRight = 8; //ending column for the line
l.dxL = 50;
l.dxR = 60;
l.dyB = 80;
l.dyT = 10;
l.EndAHLength = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadLengths.Long; //length of the ending arrowhead
l.EndAHStyle = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadStyles.DoubleEndedOpen; //style of the ending arrowhead
l.EndAHWidth = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadWidths.Wide; //width of the ending arrowhead
l.fAuto = true;
l.iQu = GrapeCity.SpreadBuilder.Imaging.ObjectDirection.UpperLeftToLowerRight; //direction of the line
l.MoveType = GrapeCity.SpreadBuilder.Imaging.SBFloatingMoveType.MoveSize; //sets whether user will be able to move and/or resize the line
l.RowBottom = 8; //bottom row for the line
l.RowTop = 1; //top row for the line
l.StartAHLength = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadLengths.Long; //length of the starting arrowhead
l.StartAHStyle = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadStyles.DoubleEndedOpen; //style of the starting arrowhead
l.StartAHWidth = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadWidths.Wide;
l.Style = GrapeCity.SpreadBuilder.Imaging.LineStyles.Dash; //style of the line
l.Weight = 5; //thickness of the line

sb.Sheets[0].AddLine(l);

//Save the Workbook to an Excel file
sb.Save(Application.StartupPath + @"\x.xls");

MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        .Rows(0).AutoSize = False
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
    End With
    Dim l As New GrapeCity.SpreadBuilder.Imaging.LineInfo
    With l
        .ColumnLeft = 3 'starting column for the line
        .Color = System.Drawing.Color.Salmon 'color for the line
        .ColumnRight = 8 'ending column for the line
        .dxL = 50
        .dxR = 60
        .dyB = 80
        .dyT = 10
        .EndAHLength = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadLengths.Long 'length of the ending arrowhead
        .EndAHStyle = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadStyles.DoubleEndedOpen 'style of the ending arrowhead
        .EndAHWidth = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadWidths.Wide 'width of the ending arrowhead
        .fAuto = True
        .iQu = GrapeCity.SpreadBuilder.Imaging.ObjectDirection.UpperLeftToLowerRight 'direction of the line
        .MoveType = GrapeCity.SpreadBuilder.Imaging.SBFloatingMoveType.MoveSize 'sets whether user will be able to move and/or resize the line
        .RowBottom = 8 'bottom row for the line
        .RowTop = 1 'top row for the line
        .StartAHLength = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadLengths.Long 'length of the starting arrowhead
        .StartAHStyle = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadStyles.DoubleEndedOpen 'style of the starting arrowhead
        .StartAHWidth = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadWidths.Wide
        .Style = GrapeCity.SpreadBuilder.Imaging.LineStyles.Dash 'style of the line
        .Weight = 5 'thickness of the line
    End With
    sb.Sheets(0).AddLine(l)

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub
See Also

Reference

DDSheet Class
DDSheet Members
LineInfo Class


AddVerticalPageBreak Method

AddVerticalPageBreak Method
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : AddVerticalPageBreak Method
The one-based column of the break.
The one-based starting row for the break.
The one-based ending row for the break.
Adds a vertical (column) page break.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddVerticalPageBreak( _
   ByVal col As System.UShort, _
   ByVal rowstart As System.UShort, _
   ByVal rowend As System.UShort _
)
public void AddVerticalPageBreak(
   System.ushort col,
   System.ushort rowstart,
   System.ushort rowend
)

Parameters

col
The one-based column of the break.
rowstart
The one-based starting row for the break.
rowend
The one-based ending row for the break.
Remarks
Pagebreaks may not overlap. The break occurs after the row or column.
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    sb.Sheets[0].AddVerticalPageBreak(2, 0, 2);

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

     sb.Sheets(0).AddVerticalPageBreak(2, 0, 2)

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub
See Also

Reference

DDSheet Class
DDSheet Members


Cell Method

Cell Method
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : Cell Method
The zero-based row number of the cell.

The zero-based column number of the cell.

Returns the DDCell object for the specified row and column.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Cell( _
   ByVal iRow As System.Integer, _
   ByVal iColumn As System.Integer _
) As DDCell
public DDCell Cell(
   System.int iRow,
   System.int iColumn
)

Parameters

iRow
The zero-based row number of the cell.
iColumn

The zero-based column number of the cell.

Return Value

The DDCell object for the specified row and column.
Remarks
This function will throw an ArgumentOutOfRangeException if the specified iRow or iColumn is not in the valid range. The maximum iRow value is 65535. The maximum iColumn value is 255. The minimum value for both the iRow and iColumn argument is 0.
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub
See Also

Reference

DDSheet Class
DDSheet Members


Cells Method

Cells Method
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : Cells Method
The DDCell showing the cell position of starting point.
The DDCell showing the cell position of ending point.
Returns a DDCell instance for the specified cell number.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Cells( _
   ByVal start As DDCell, _
   ByVal end As DDCell _
) As DDCells
public DDCells Cells(
   DDCell start,
   DDCell end
)

Parameters

start
The DDCell showing the cell position of starting point.
end
The DDCell showing the cell position of ending point.
Example
  • C#
private void Form1_Load(object sender, System.EventArgs e)
{
    // Add a sheet to the Sheets collection of the Workbook.
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    // Set the properties, values, for columns, rows, and cells.
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    // Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,1).SetValue("Department Name");
    sb.Sheets[0].Cell(0,2).SetValue("Phone Number");

    // Data for the first row
    sb.Sheets[0].Cell(1,0).SetValue("Grapecity");
    sb.Sheets[0].Cell(1,1).SetValue("Sales Department");
    sb.Sheets[0].Cell(1,2).SetValue("(022) 777-8210");

    //Specify the cell range and set the format
    sb.Sheets[0].Cells(sb.Sheets[0].Cell(0, 0), sb.Sheets[0].Cell(0, 2)).FontBold = true;
    sb.Sheets[0].Cells(sb.Sheets[0].Cell(0, 0), sb.Sheets[0].Cell(1, 2)).FontName = "MS UI Gothic";

    // Save the Workbook to an Excel file.
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show(Application.StartupPath + @"Saved to" + "\x.xls.");
}
  • Visual Basic
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    ' Add a sheet to the Sheets collection of the Workbook.
    Dim sb As New GrapeCity.SpreadBuilder.Workbook()
    sb.Sheets.AddNew()
    ' Set the properties, values, for columns, rows, and cells.
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        ' Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 1).SetValue("Department Name")
        .Cell(0, 2).SetValue("Phone Number")

        ' Data for the first row
        .Cell(1, 0).SetValue("Grapecity")
        .Cell(1, 1).SetValue("Sales Department")
        .Cell(1, 2).SetValue("(022) 777-8210")
    End With

    ' Specify the cell range and set the format
    sb.Sheets(0).Cells(sb.Sheets(0).Cell(0, 0), sb.Sheets(0).Cell(0, 2)).FontBold = True
    sb.Sheets(0).Cells(sb.Sheets(0).Cell(0, 0), sb.Sheets(0).Cell(1, 2)).FontName = "MS UI Gothic"

    ' Save the Workbook to an Excel file.
    sb.Save(Application.StartupPath & "\x.xls")
    MsgBox(Application.StartupPath & "Saved to" & "\x.xls")
End Sub
See Also

Reference

DDSheet Class
DDSheet Members


Clear Method (DDSheet)

Clear Method (DDSheet)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : Clear Method
Deletes all properties and content, creating a blank sheet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
    sb.Sheets[0].Clear();
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")
    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
    sb.Sheets(0).Clear()
End Sub
See Also

Reference

DDSheet Class
DDSheet Members


Columns Method

Columns Method
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : Columns Method

The zero-based non-negative column index.

Returns the DDColumn object representing the specified column.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Columns( _
   ByVal column As System.Short _
) As DDColumn
public DDColumn Columns(
   System.short column
)

Parameters

column

The zero-based non-negative column index.

Return Value

The DDColumn object representing the specified column.
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
    sb.Sheets[0].Clear();
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")
    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
    sb.Sheets(0).Clear()
End Sub
See Also

Reference

DDSheet Class
DDSheet Members


IsMerged Method

IsMerged Method
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : IsMerged Method
The zero-based row where the cell to check for merged status resides.
The zero-based column where the cell to check for merged status resides.
Sets or returns a value indicating whether the specified cell's XFRecord has its fMergeCell member set to True.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IsMerged( _
   ByVal row As System.Integer, _
   ByVal column As System.Integer _
) As System.Boolean
public System.bool IsMerged(
   System.int row,
   System.int column
)

Parameters

row
The zero-based row where the cell to check for merged status resides.
column
The zero-based column where the cell to check for merged status resides.

Return Value

Boolean. The default value is False.
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0, 0).Merge(0, 1);
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");
    if (sb.Sheets[0].IsMerged(0, 0))
    {
        sb.Sheets[0].Cell(0, 0).UnMerge();
    }
    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
    sb.Sheets[0].Clear();
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 0).Merge(0, 1)
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With
    If sb.Sheets(0).IsMerged(0, 0) Then
        sb.Sheets(0).Cell(0, 0).UnMerge()
    End If
    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")
    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
    sb.Sheets(0).Clear()
End Sub
See Also

Reference

DDSheet Class
DDSheet Members


Rows Method

Rows Method
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : Rows Method
The zero-based row number the returned DDRow will represent.
Returns a DDRow instance for the specified row number.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Rows( _
   ByVal iRow As System.Integer _
) As DDRow
public DDRow Rows(
   System.int iRow
)

Parameters

iRow
The zero-based row number the returned DDRow will represent.

Return Value

A DDRow instance that represents the specified row number.
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub
See Also

Reference

DDSheet Class
DDSheet Members
DDRow Class


UnMergeCells Method

UnMergeCells Method
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : UnMergeCells Method
The zero-based row where the cell to unmerge resides.
The zero-based column where the cell to unmerge resides.
Removes the MergeArea from the MergedAreas record for this sheet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub UnMergeCells( _
   ByVal row As System.Integer, _
   ByVal column As System.Integer _
)
public void UnMergeCells(
   System.int row,
   System.int column
)

Parameters

row
The zero-based row where the cell to unmerge resides.
column
The zero-based column where the cell to unmerge resides.
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0, 0).Merge(0, 1);
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");
    if (sb.Sheets[0].IsMerged(0, 0))
    {
        sb.Sheets[0].UnMergeCells(0, 0);
    }
    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
    sb.Sheets[0].Clear();
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 0).Merge(0, 1)
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With
    If sb.Sheets(0).IsMerged(0, 0) Then
        sb.Sheets(0).UnMergeCells(0, 0)
    End If
    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")
    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
    sb.Sheets(0).Clear()
End Sub
See Also

Reference

DDSheet Class
DDSheet Members


DDSheet Class Properties

DDSheet Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : DDSheet Class

For a list of all members of this type, see DDSheet members.

Public Properties
 | Name | Description
Public Property | DisplayGridLines | Sets or returns the flag indicating whether grid lines are displayed in the sheet.
Public Property | Name | Sets or returns the name of the DDSheet.
Public Property | PageSetup | Returns the current information about this sheet when printed. This information is displayed in Excel in the page setup dialog.
Public Property | ParentSheets | Returns the DDSheets collection of which this DDSheet is a member.
Top
See Also

Reference

DDSheet Class
GrapeCity.SpreadBuilder Namespace


DisplayGridLines Property (DDSheet)

DisplayGridLines Property (DDSheet)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : DisplayGridLines Property
Sets or returns the flag indicating whether grid lines are displayed in the sheet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DisplayGridLines As System.Boolean
public System.bool DisplayGridLines {get; set;}

Property Value

Boolean. The default value is True.
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].DisplayGridLines = false;
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
    sb.Sheets[0].Clear();
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .DisplayGridLines = False
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")
    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
    sb.Sheets(0).Clear()
End Sub
See Also

Reference

DDSheet Class
DDSheet Members


Name Property (DDSheet)

Name Property (DDSheet)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : Name Property
Sets or returns the name of the DDSheet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}

Property Value

String.
Remarks
This property will throw an ArgumentException if the specified name is already in use, or is invalid (e.g. empty).
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub
See Also

Reference

DDSheet Class
DDSheet Members


PageSetup Property

PageSetup Property
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : PageSetup Property
Returns the current information about this sheet when printed. This information is displayed in Excel in the page setup dialog.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PageSetup As PageSetup
public PageSetup PageSetup {get;}

Property Value

PageSetup class.
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].PageSetup.Zoom = 200;
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .PageSetup.Zoom = 200
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub
See Also

Reference

DDSheet Class
DDSheet Members


ParentSheets Property

ParentSheets Property

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : ParentSheets Property
Returns the DDSheets collection of which this DDSheet is a member.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ParentSheets As DDSheets
public DDSheets ParentSheets {get;}

Property Value

DDSheets collection.
Remarks
This property is read-only.
See Also

Reference

DDSheet Class
DDSheet Members


DDSheetNameAlreadyExistsException Class

DDSheetNameAlreadyExistsException Class
Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : DDSheetNameAlreadyExistsException Class
Thrown when you try to set a Name property to a value already in use.
Object Model
DDSheetNameAlreadyExistsException Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DDSheetNameAlreadyExistsException
   Inherits System.ArgumentException
public class DDSheetNameAlreadyExistsException : System.ArgumentException
Inheritance Hierarchy

System.Object
System.Exception
System.SystemException
System.ArgumentException
GrapeCity.SpreadBuilder.DDSheetNameAlreadyExistsException

See Also

Reference

DDSheetNameAlreadyExistsException Members
GrapeCity.SpreadBuilder Namespace


DDSheetNameAlreadyExistsException Class Members

DDSheetNameAlreadyExistsException Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : DDSheetNameAlreadyExistsException Class

The following tables list the members exposed by DDSheetNameAlreadyExistsException.

Public Constructors
 | Name | Description
Public Constructor | DDSheetNameAlreadyExistsException Constructor | Initializes an instance of the DDSheetNameAlreadyExistsException.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.ArgumentException)
Public Property | ParamName | (Inherited from System.ArgumentException)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.ArgumentException)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

DDSheetNameAlreadyExistsException Class
GrapeCity.SpreadBuilder Namespace


DDSheetNameAlreadyExistsException Constructor

DDSheetNameAlreadyExistsException Constructor

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : DDSheetNameAlreadyExistsException Constructor
Initializes an instance of the DDSheetNameAlreadyExistsException.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DDSheetNameAlreadyExistsException()
See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


DDSheets Class

DDSheets Class
Members Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : DDSheets Class
A collection of DDSheet objects.
Object Model
DDSheets Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DDSheets
public class DDSheets
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.DDSheets

See Also

Reference

DDSheets Members
GrapeCity.SpreadBuilder Namespace


DDSheets Class Members

DDSheets Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : DDSheets Class

The following tables list the members exposed by DDSheets.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the DDSheets collection.
Public Property | Item | Overloaded. Gets the specified DDSheet object.
Top
Public Methods
 | Name | Description
Public Method | AddNew | Adds a new blank DDSheet object to the collection and returns a reference to it.
Public Method | Clear | Removes all of the DDSheet objects contained in the collection.
Public Method | Move | Overloaded. Moves a sheet to the specified position.
Public Method | RemoveAt | Removes the DDSheet at the specified index from the collection.
Public Method | Select | Overloaded. Selects a DDSheet object, while deselecting all other DDSheet objects.
Top
See Also

Reference

DDSheets Class
GrapeCity.SpreadBuilder Namespace


DDSheets Class Methods

DDSheets Class Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : DDSheets Class

For a list of all members of this type, see DDSheets members.

Public Methods
 | Name | Description
Public Method | AddNew | Adds a new blank DDSheet object to the collection and returns a reference to it.
Public Method | Clear | Removes all of the DDSheet objects contained in the collection.
Public Method | Move | Overloaded. Moves a sheet to the specified position.
Public Method | RemoveAt | Removes the DDSheet at the specified index from the collection.
Public Method | Select | Overloaded. Selects a DDSheet object, while deselecting all other DDSheet objects.
Top
See Also

Reference

DDSheets Class
GrapeCity.SpreadBuilder Namespace


AddNew Method

AddNew Method
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class : AddNew Method
Adds a new blank DDSheet object to the collection and returns a reference to it.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function AddNew() As DDSheet
public DDSheet AddNew()

Return Value

The newly added DDSheet object.
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub
See Also

Reference

DDSheets Class
DDSheets Members


Clear Method (DDSheets)

Clear Method (DDSheets)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class : Clear Method
Removes all of the DDSheet objects contained in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
    sb.Clear();
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
    sb.Clear()
End Sub
See Also

Reference

DDSheets Class
DDSheets Members


Move Method

Move Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class : Move Method
Moves a sheet to the specified position.
Overload List
Overload | Description
Move(String,Int16) | Moves the sheet with the specified name to the specified position.
Move(Int16,Int16) | Moves the sheet at the specified position to the specified new position.
See Also

Reference

DDSheets Class
DDSheets Members


Move(String,Int16) Method

Move(String,Int16) Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class > Move Method : Move(String,Int16) Method
The Name value of the DDSheet that you want to move.
The new position to which you want to move the sheet. If the new position is less than zero, the sheet will be moved to the beginning of the collection (0). If the new position is greater than the upper bound of this collection, the sheet will be moved to the end of the collection.
Moves the sheet with the specified name to the specified position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Move( _
   ByVal sName As System.String, _
   ByVal newPosition As System.Short _
)
public void Move(
   System.string sName,
   System.short newPosition
)

Parameters

sName
The Name value of the DDSheet that you want to move.
newPosition
The new position to which you want to move the sheet. If the new position is less than zero, the sheet will be moved to the beginning of the collection (0). If the new position is greater than the upper bound of this collection, the sheet will be moved to the end of the collection.
See Also

Reference

DDSheets Class
DDSheets Members
Overload List


Move(Int16,Int16) Method

Move(Int16,Int16) Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class > Move Method : Move(Int16,Int16) Method
The current position (index) of the sheet you want to move.
The new position to which you want to move the sheet. If the new position is less than zero, the sheet will be moved to the beginning of the collection (0). If the new position is greater than the upper bound of this collection, the sheet will be moved to the end of the collection.
Moves the sheet at the specified position to the specified new position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Move( _
   ByVal oldPosition As System.Short, _
   ByVal newPosition As System.Short _
)
public void Move(
   System.short oldPosition,
   System.short newPosition
)

Parameters

oldPosition
The current position (index) of the sheet you want to move.
newPosition
The new position to which you want to move the sheet. If the new position is less than zero, the sheet will be moved to the beginning of the collection (0). If the new position is greater than the upper bound of this collection, the sheet will be moved to the end of the collection.
See Also

Reference

DDSheets Class
DDSheets Members
Overload List


RemoveAt Method (DDSheets)

RemoveAt Method (DDSheets)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class : RemoveAt Method

The zero-based index of the DDSheet object to be removed.

Removes the DDSheet at the specified index from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal iIndex As System.Integer _
)
public void RemoveAt(
   System.int iIndex
)

Parameters

iIndex

The zero-based index of the DDSheet object to be removed.

See Also

Reference

DDSheets Class
DDSheets Members


Select Method (DDSheets)

Select Method (DDSheets)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class : Select Method
Selects a DDSheet object, while deselecting all other DDSheet objects.
Overload List
Overload | Description
Select(String) | Selects the sheet with the specified name, and deselects all other sheets.
Select(Int32) | Selects the sheet at the specified index, and deselects all other sheets.
See Also

Reference

DDSheets Class
DDSheets Members


Select(String) Method

Select(String) Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class > Select Method : Select(String) Method
The value of the Name property of the DDSheet object to be selected.
Selects the sheet with the specified name, and deselects all other sheets.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Select( _
   ByVal sheetName As System.String _
)
public void Select(
   System.string sheetName
)

Parameters

sheetName
The value of the Name property of the DDSheet object to be selected.
See Also

Reference

DDSheets Class
DDSheets Members
Overload List


Select(Int32) Method

Select(Int32) Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class > Select Method : Select(Int32) Method
The zero-based index of the sheet whose tab is to be selected.
Selects the sheet at the specified index, and deselects all other sheets.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Select( _
   ByVal sheetIndex As System.Integer _
)
public void Select(
   System.int sheetIndex
)

Parameters

sheetIndex
The zero-based index of the sheet whose tab is to be selected.
See Also

Reference

DDSheets Class
DDSheets Members
Overload List


DDSheets Class Properties

DDSheets Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : DDSheets Class

For a list of all members of this type, see DDSheets members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the DDSheets collection.
Public Property | Item | Overloaded. Gets the specified DDSheet object.
Top
See Also

Reference

DDSheets Class
GrapeCity.SpreadBuilder Namespace


Count Property (DDSheets)

Count Property (DDSheets)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class : Count Property
Gets the number of elements contained in the DDSheets collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}

Property Value

Integer.
Remarks
This property is read-only.
Example
  • C#
if (MessageBox.Show ("Your spreadsheet is " + sb.Sheets.Count.ToString() + " sheet(s) long. Okay to save?", "Save", MessageBoxButtons.YesNo) == DialogResult.Yes)
{
    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
sb.Clear();
  • Visual Basic
If MessageBox.Show("Your spreadsheet is " + sb.Sheets.Count.ToString() + " sheet(s) long. Okay to save?", "Save", MessageBoxButtons.YesNo) = DialogResult.Yes Then
    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath + "\x.xls")
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets(0).Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\x.xls")
End If
sb.Clear()
See Also

Reference

DDSheets Class
DDSheets Members


Item Property (DDSheets)

Item Property (DDSheets)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class : Item Property
Gets the specified DDSheet object.
Overload List
Overload | Description
Item(Int32) | Gets the DDSheet at the specified index. In C#, this property is an indexer for the DDSheets class.
Item(String) | Gets the DDSheet with the specified name. In C#, this property is an indexer for the DDSheets class. If a DDSheet with the specified name does not exist in the collection, null will be returned.
Remarks
This property is read-only.
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub
See Also

Reference

DDSheets Class
DDSheets Members
DDSheet Class


Item(Int32) Property

Item(Int32) Property
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class > Item Property : Item(Int32) Property
The zero-based index of the DDSheet in the collection.
Gets the DDSheet at the specified index. In C#, this property is an indexer for the DDSheets class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal iIndex As System.Integer _
) As DDSheet
public DDSheet Item(
   System.int iIndex
) {get;}

Parameters

iIndex
The zero-based index of the DDSheet in the collection.
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub
See Also

Reference

DDSheets Class
DDSheets Members
Overload List


Item(String) Property

Item(String) Property
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheets Class > Item Property : Item(String) Property
The Name value of the DDSheet object.
Gets the DDSheet with the specified name. In C#, this property is an indexer for the DDSheets class. If a DDSheet with the specified name does not exist in the collection, null will be returned.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal sheetName As System.String _
) As DDSheet
public DDSheet Item(
   System.string sheetName
) {get;}

Parameters

sheetName
The Name value of the DDSheet object.
Remarks
The sheetName argument is not case sensitive.
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets["Customer Call List"].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets("Customer Call List").Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub
See Also

Reference

DDSheets Class
DDSheets Members
Overload List


InvalidDDSheetNameException Class

InvalidDDSheetNameException Class
Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : InvalidDDSheetNameException Class
Thrown when change a sheet's name to an invalid value. The name cannot be empty, cannot exceed 31 characters and cannot contain any of following characters: : \ / ? * [ or ]
Object Model
InvalidDDSheetNameException Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class InvalidDDSheetNameException
   Inherits System.ArgumentException
public class InvalidDDSheetNameException : System.ArgumentException
Inheritance Hierarchy

System.Object
System.Exception
System.SystemException
System.ArgumentException
GrapeCity.SpreadBuilder.InvalidDDSheetNameException

See Also

Reference

InvalidDDSheetNameException Members
GrapeCity.SpreadBuilder Namespace


InvalidDDSheetNameException Class Members

InvalidDDSheetNameException Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : InvalidDDSheetNameException Class

The following tables list the members exposed by InvalidDDSheetNameException.

Public Constructors
 | Name | Description
Public Constructor | InvalidDDSheetNameException Constructor | Overloaded. Initializes a new instance of InvalidDDSheetNameException Class.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.ArgumentException)
Public Property | ParamName | (Inherited from System.ArgumentException)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.ArgumentException)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

InvalidDDSheetNameException Class
GrapeCity.SpreadBuilder Namespace


InvalidDDSheetNameException Constructor

InvalidDDSheetNameException Constructor

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : InvalidDDSheetNameException Constructor
Initializes a new instance of InvalidDDSheetNameException Class.
Overload List
Overload | Description
InvalidDDSheetNameException Constructor(String) | Create a InvalidDDSheetNameException instance with parameter name.
InvalidDDSheetNameException Constructor() | Create a InvalidDDSheetNameException instance.
See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


InvalidDDSheetNameException Constructor(String)

InvalidDDSheetNameException Constructor(String)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class > InvalidDDSheetNameException Constructor : InvalidDDSheetNameException Constructor(String)
Gets the name of the parameter that causes the exception.
Create a InvalidDDSheetNameException instance with parameter name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal paramName As System.String _
)
public InvalidDDSheetNameException(
   System.string paramName
)

Parameters

paramName
Gets the name of the parameter that causes the exception.
See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members
Overload List


InvalidDDSheetNameException Constructor()

InvalidDDSheetNameException Constructor()

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class > InvalidDDSheetNameException Constructor : InvalidDDSheetNameException Constructor()
Create a InvalidDDSheetNameException instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public InvalidDDSheetNameException()
See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members
Overload List


InvalidPasswordException Class

InvalidPasswordException Class
Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : InvalidPasswordException Class
Thrown when the password is invalid in a specific excel format.(For example: the length of password is out of range.)
Object Model
InvalidPasswordException Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class InvalidPasswordException
   Inherits SpreadBuilderException
public class InvalidPasswordException : SpreadBuilderException
Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.SpreadBuilder.SpreadBuilderException
GrapeCity.SpreadBuilder.InvalidPasswordException

See Also

Reference

InvalidPasswordException Members
GrapeCity.SpreadBuilder Namespace


InvalidPasswordException Class Members

InvalidPasswordException Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : InvalidPasswordException Class

The following tables list the members exposed by InvalidPasswordException.

Public Constructors
 | Name | Description
Public Constructor | InvalidPasswordException Constructor | Overloaded. Initializes a new instance of InvalidPasswordException Class.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

InvalidPasswordException Class
GrapeCity.SpreadBuilder Namespace


InvalidPasswordException Constructor

InvalidPasswordException Constructor

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : InvalidPasswordException Constructor
Initializes a new instance of InvalidPasswordException Class.
Overload List
Overload | Description
InvalidPasswordException Constructor(String) | Initializes a new instance of the InvalidPasswordException class with specific error message.
InvalidPasswordException Constructor() | Initializes a new instance of the InvalidPasswordException class with default error message.
See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


InvalidPasswordException Constructor(String)

InvalidPasswordException Constructor(String)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class > InvalidPasswordException Constructor : InvalidPasswordException Constructor(String)
A message that describes the error.
Initializes a new instance of the InvalidPasswordException class with specific error message.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String _
)
public InvalidPasswordException(
   System.string message
)

Parameters

message
A message that describes the error.
See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members
Overload List


InvalidPasswordException Constructor()

InvalidPasswordException Constructor()

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class > InvalidPasswordException Constructor : InvalidPasswordException Constructor()
Initializes a new instance of the InvalidPasswordException class with default error message.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public InvalidPasswordException()
See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members
Overload List


NoDDSheetsException Class

NoDDSheetsException Class
Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : NoDDSheetsException Class
Thrown when an operation is requested that requires at least one sheet in the Sheets collection (for example Saving the workbook) and no sheets exist.
Object Model
NoDDSheetsException Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class NoDDSheetsException
   Inherits SpreadBuilderException
public class NoDDSheetsException : SpreadBuilderException
Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.SpreadBuilder.SpreadBuilderException
GrapeCity.SpreadBuilder.NoDDSheetsException

See Also

Reference

NoDDSheetsException Members
GrapeCity.SpreadBuilder Namespace


NoDDSheetsException Class Members

NoDDSheetsException Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : NoDDSheetsException Class

The following tables list the members exposed by NoDDSheetsException.

Public Constructors
 | Name | Description
Public Constructor | NoDDSheetsException Constructor | Initializes an instance of the NoDDSheetsException class.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Overridden. Returns a message that describes the error.
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

NoDDSheetsException Class
GrapeCity.SpreadBuilder Namespace


NoDDSheetsException Constructor

NoDDSheetsException Constructor

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : NoDDSheetsException Constructor
Initializes an instance of the NoDDSheetsException class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public NoDDSheetsException()
See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


NoDDSheetsException Class Properties

NoDDSheetsException Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : NoDDSheetsException Class

For a list of all members of this type, see NoDDSheetsException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Overridden. Returns a message that describes the error.
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

NoDDSheetsException Class
GrapeCity.SpreadBuilder Namespace


Message Property (NoDDSheetsException)

Message Property (NoDDSheetsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : Message Property
Returns a message that describes the error.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property Message As System.String
public override System.string Message {get;}
See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


RowCountOutOfRangeException Class

RowCountOutOfRangeException Class
Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : RowCountOutOfRangeException Class
Thrown when the rows' count is out of range in a specific excel format.
Object Model
RowCountOutOfRangeException Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class RowCountOutOfRangeException
   Inherits SpreadBuilderException
public class RowCountOutOfRangeException : SpreadBuilderException
Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.SpreadBuilder.SpreadBuilderException
GrapeCity.SpreadBuilder.RowCountOutOfRangeException

See Also

Reference

RowCountOutOfRangeException Members
GrapeCity.SpreadBuilder Namespace


RowCountOutOfRangeException Class Members

RowCountOutOfRangeException Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : RowCountOutOfRangeException Class

The following tables list the members exposed by RowCountOutOfRangeException.

Public Constructors
 | Name | Description
Public Constructor | RowCountOutOfRangeException Constructor | Overloaded. Initializes a new instance of RowCountOutOfRangeException Class.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

RowCountOutOfRangeException Class
GrapeCity.SpreadBuilder Namespace


RowCountOutOfRangeException Constructor

RowCountOutOfRangeException Constructor

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : RowCountOutOfRangeException Constructor
Initializes a new instance of RowCountOutOfRangeException Class.
Overload List
Overload | Description
RowCountOutOfRangeException Constructor(String) | Initializes a new instance of the RowCountOutOfRangeException class with specific error message.
RowCountOutOfRangeException Constructor() | Initializes a new instance of the RowCountOutOfRangeException class with default error message.
See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


RowCountOutOfRangeException Constructor(String)

RowCountOutOfRangeException Constructor(String)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class > RowCountOutOfRangeException Constructor : RowCountOutOfRangeException Constructor(String)
A message that describes the error.
Initializes a new instance of the RowCountOutOfRangeException class with specific error message.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String _
)
public RowCountOutOfRangeException(
   System.string message
)

Parameters

message
A message that describes the error.
See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members
Overload List


RowCountOutOfRangeException Constructor()

RowCountOutOfRangeException Constructor()

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class > RowCountOutOfRangeException Constructor : RowCountOutOfRangeException Constructor()
Initializes a new instance of the RowCountOutOfRangeException class with default error message.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public RowCountOutOfRangeException()
See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members
Overload List


SpreadBuilderException Class

SpreadBuilderException Class
Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : SpreadBuilderException Class
A general exception thrown for application errors in the GrapeCity.SpreadBuilder assembly.
Object Model
SpreadBuilderException Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class SpreadBuilderException
   Inherits System.ApplicationException
public class SpreadBuilderException : System.ApplicationException
Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.SpreadBuilder.SpreadBuilderException
GrapeCity.SpreadBuilder.ColumnCountOutOfRangeException
GrapeCity.SpreadBuilder.CompressionException
GrapeCity.SpreadBuilder.InvalidPasswordException
GrapeCity.SpreadBuilder.NoDDSheetsException
GrapeCity.SpreadBuilder.RowCountOutOfRangeException
GrapeCity.SpreadBuilder.VersionNotImplementedException

See Also

Reference

SpreadBuilderException Members
GrapeCity.SpreadBuilder Namespace


SpreadBuilderException Class Members

SpreadBuilderException Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : SpreadBuilderException Class

The following tables list the members exposed by SpreadBuilderException.

Public Constructors
 | Name | Description
Public Constructor | SpreadBuilderException Constructor | Overloaded. Initializes a new instance of the SpreadBuilderException class.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

SpreadBuilderException Class
GrapeCity.SpreadBuilder Namespace


SpreadBuilderException Constructor

SpreadBuilderException Constructor

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : SpreadBuilderException Constructor
Initializes a new instance of the SpreadBuilderException class.
Overload List
Overload | Description
SpreadBuilderException Constructor(String,Exception) | Initializes a new instance of the SpreadBuilderException class with the specified error message and a reference to the inner exception that is the cause of this exception.
SpreadBuilderException Constructor(String) | Initializes a new instance of the SpreadBuilderException class with the specified error message.
SpreadBuilderException Constructor() | Initializes a new instance of the SpreadBuilderException class.
See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


SpreadBuilderException Constructor(String,Exception)

SpreadBuilderException Constructor(String,Exception)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class > SpreadBuilderException Constructor : SpreadBuilderException Constructor(String,Exception)
A message that describes the error.
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
Initializes a new instance of the SpreadBuilderException class with the specified error message and a reference to the inner exception that is the cause of this exception.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String, _
   ByVal innerException As System.Exception _
)
public SpreadBuilderException(
   System.string message,
   System.Exception innerException
)

Parameters

message
A message that describes the error.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members
Overload List


SpreadBuilderException Constructor(String)

SpreadBuilderException Constructor(String)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class > SpreadBuilderException Constructor : SpreadBuilderException Constructor(String)
A message that describes the error.
Initializes a new instance of the SpreadBuilderException class with the specified error message.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String _
)
public SpreadBuilderException(
   System.string message
)

Parameters

message
A message that describes the error.
See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members
Overload List


SpreadBuilderException Constructor()

SpreadBuilderException Constructor()

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class > SpreadBuilderException Constructor : SpreadBuilderException Constructor()
Initializes a new instance of the SpreadBuilderException class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public SpreadBuilderException()
See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members
Overload List


VersionNotImplementedException Class

VersionNotImplementedException Class
Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : VersionNotImplementedException Class
Indicates that a feature or features were not implemented for a particular version of the Excel/BIFF file format.
Object Model
VersionNotImplementedException Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class VersionNotImplementedException
   Inherits SpreadBuilderException
public class VersionNotImplementedException : SpreadBuilderException
Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.SpreadBuilder.SpreadBuilderException
GrapeCity.SpreadBuilder.VersionNotImplementedException

See Also

Reference

VersionNotImplementedException Members
GrapeCity.SpreadBuilder Namespace


VersionNotImplementedException Class Members

VersionNotImplementedException Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : VersionNotImplementedException Class

The following tables list the members exposed by VersionNotImplementedException.

Public Constructors
 | Name | Description
Public Constructor | VersionNotImplementedException Constructor | Overloaded. Initializes a new instance of the VersionNotImplementedException class.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Overridden. Returns a message that describes the error.
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

VersionNotImplementedException Class
GrapeCity.SpreadBuilder Namespace


VersionNotImplementedException Constructor

VersionNotImplementedException Constructor

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : VersionNotImplementedException Constructor
Initializes a new instance of the VersionNotImplementedException class.
Overload List
Overload | Description
VersionNotImplementedException Constructor(String) | Initializes a new instance of the VersionNotImplementedException class with the specified message.
VersionNotImplementedException Constructor(String,Exception) | Initializes a new instance of the VersionNotImplementedException with the specified message and inner exception.
See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


VersionNotImplementedException Constructor(String)

VersionNotImplementedException Constructor(String)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class > VersionNotImplementedException Constructor : VersionNotImplementedException Constructor(String)
A message that describes the error.
Initializes a new instance of the VersionNotImplementedException class with the specified message.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String _
)
public VersionNotImplementedException(
   System.string message
)

Parameters

message
A message that describes the error.
See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members
Overload List


VersionNotImplementedException Constructor(String,Exception)

VersionNotImplementedException Constructor(String,Exception)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class > VersionNotImplementedException Constructor : VersionNotImplementedException Constructor(String,Exception)
A message that describes the error.
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
Initializes a new instance of the VersionNotImplementedException with the specified message and inner exception.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String, _
   ByVal innerException As System.Exception _
)
public VersionNotImplementedException(
   System.string message,
   System.Exception innerException
)

Parameters

message
A message that describes the error.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members
Overload List


VersionNotImplementedException Class Properties

VersionNotImplementedException Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : VersionNotImplementedException Class

For a list of all members of this type, see VersionNotImplementedException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Overridden. Returns a message that describes the error.
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

VersionNotImplementedException Class
GrapeCity.SpreadBuilder Namespace


Message Property (VersionNotImplementedException)

Message Property (VersionNotImplementedException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : Message Property
Returns a message that describes the error.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property Message As System.String
public override System.string Message {get;}
See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


Workbook Class

Workbook Class
Members Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : Workbook Class
Represents a workbook that contains spreadsheets. This object presents information that is relevant to all spreadsheets in the workbook (e.g. Author, BIFF/file version, etc.).
Object Model
Workbook Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Workbook
public class Workbook
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
   GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.Workbook

See Also

Reference

Workbook Members
GrapeCity.SpreadBuilder Namespace


Workbook Class Members

Workbook Class Members
Fields Properties Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : Workbook Class

The following tables list the members exposed by Workbook.

Public Constructors
 | Name | Description
Public Constructor | Workbook Constructor | Initializes a new instance of the Workbook class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | DefaultFontName | Returns the default font name for the workbook.
static (Shared in Visual Basic) | DefaultFontSizeInPoints | Returns the default font size in points for the workbook.
Top
Public Properties
 | Name | Description
Public Property | FileFormat | Sets/gets the file format that the spreadsheet will be saved in.
Public Property | OpenXmlStandard | Gets or sets the level of Open XML document conformance on exporting with Xlsx file format.
Public Property | ProtectWorkbookPassword | Sets/gets the password for protecting the elements in workbook.
Public Property | ProtectWorkBookStructure | Sets or returns a value indicating whether Excel will let the user add, delete, reorder, or rename sheets in the workbook.
Public Property | ProtectWorkbookWindows | Sets or returns a value indicating whether the workbook or sheet is protected.
Public Property | Security | Returns a DDSecurity object for initializing document security.
Public Property | Sheets | Returns a DDSheets object, which is a collection of DDSheet objects, which make up the workbook.
Public Property | UseCompression | Gets or sets the value indicating should compression be used on exporting with Xlsx file format.
Public Property | UseDefaultPalette | Sets or returns whether export document with Excel default palette.
Top
Public Methods
 | Name | Description
Public Method | Clear | Removes all sheets, creates a fresh instance of all member class variables and initializes all member data variables to their default value.
Public Method | Save | Overloaded. Saves the current workbook.
Top
See Also

Reference

Workbook Class
GrapeCity.SpreadBuilder Namespace


Workbook Constructor

Workbook Constructor

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : Workbook Constructor
Initializes a new instance of the Workbook class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Workbook()
See Also

Reference

Workbook Class
Workbook Members


Workbook Class Methods

Workbook Class Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : Workbook Class

For a list of all members of this type, see Workbook members.

Public Methods
 | Name | Description
Public Method | Clear | Removes all sheets, creates a fresh instance of all member class variables and initializes all member data variables to their default value.
Public Method | Save | Overloaded. Saves the current workbook.
Top
See Also

Reference

Workbook Class
GrapeCity.SpreadBuilder Namespace


Clear Method (Workbook)

Clear Method (Workbook)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : Clear Method
Removes all sheets, creates a fresh instance of all member class variables and initializes all member data variables to their default value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

Workbook Class
Workbook Members


Save Method (Workbook)

Save Method (Workbook)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : Save Method
Saves the current workbook.
Overload List
Overload | Description
Save(Stream) | Saves the current workbook to the specified stream.
Save(String) | Saves the current workbook to the specified file.
See Also

Reference

Workbook Class
Workbook Members


Save(Stream) Method

Save(Stream) Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class > Save Method : Save(Stream) Method

The output stream to which to save the workbook. The stream can be of various types, for example, a MemoryStream, or an HttpResponse.OutputStream.

Saves the current workbook to the specified stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Save( _
   ByVal outputStream As System.IO.Stream _
)
public void Save(
   System.IO.Stream outputStream
)

Parameters

outputStream

The output stream to which to save the workbook. The stream can be of various types, for example, a MemoryStream, or an HttpResponse.OutputStream.

See Also

Reference

Workbook Class
Workbook Members
Overload List


Save(String) Method

Save(String) Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class > Save Method : Save(String) Method
The file name and path to which to save the workbook.
Saves the current workbook to the specified file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Save( _
   ByVal filePath As System.String _
)
public void Save(
   System.string filePath
)

Parameters

filePath
The file name and path to which to save the workbook.
Remarks
Permissions to write to the specified file are Demanded.
See Also

Reference

Workbook Class
Workbook Members
Overload List


Workbook Class Properties

Workbook Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : Workbook Class

For a list of all members of this type, see Workbook members.

Public Properties
 | Name | Description
Public Property | FileFormat | Sets/gets the file format that the spreadsheet will be saved in.
Public Property | OpenXmlStandard | Gets or sets the level of Open XML document conformance on exporting with Xlsx file format.
Public Property | ProtectWorkbookPassword | Sets/gets the password for protecting the elements in workbook.
Public Property | ProtectWorkBookStructure | Sets or returns a value indicating whether Excel will let the user add, delete, reorder, or rename sheets in the workbook.
Public Property | ProtectWorkbookWindows | Sets or returns a value indicating whether the workbook or sheet is protected.
Public Property | Security | Returns a DDSecurity object for initializing document security.
Public Property | Sheets | Returns a DDSheets object, which is a collection of DDSheet objects, which make up the workbook.
Public Property | UseCompression | Gets or sets the value indicating should compression be used on exporting with Xlsx file format.
Public Property | UseDefaultPalette | Sets or returns whether export document with Excel default palette.
Top
See Also

Reference

Workbook Class
GrapeCity.SpreadBuilder Namespace


FileFormat Property (Workbook)

FileFormat Property (Workbook)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : FileFormat Property
Sets/gets the file format that the spreadsheet will be saved in.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FileFormat As FileFormat
public FileFormat FileFormat {get; set;}
See Also

Reference

Workbook Class
Workbook Members


OpenXmlStandard Property (Workbook)

OpenXmlStandard Property (Workbook)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : OpenXmlStandard Property
Gets or sets the level of Open XML document conformance on exporting with Xlsx file format.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OpenXmlStandard As OpenXmlStandard
public OpenXmlStandard OpenXmlStandard {get; set;}
See Also

Reference

Workbook Class
Workbook Members


ProtectWorkbookPassword Property (Workbook)

ProtectWorkbookPassword Property (Workbook)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : ProtectWorkbookPassword Property
Sets/gets the password for protecting the elements in workbook.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ProtectWorkbookPassword As System.String
public System.string ProtectWorkbookPassword {get; set;}
Remarks
The password will take effect when one of ProtectWorkbookWindows and ProtectWorkBookStructure property is true. If one or both ProtectWorkbookWindows and ProtectWorkBookStructure property are set to true, Workbook.Save method will be invoked.At this time, ProtectWorkbookPassword validity will be checked.
If file format is Xls95/Xls97Plus, InvalidPasswordExpection will be thrown out if ProtectWorkbookPassword contains more than 15 characters.If file format is Xlsx, InvalidPasswordExpection will be thrown out if ProtectWorkbookPassword contains more than 255 characters.
See Also

Reference

Workbook Class
Workbook Members


ProtectWorkBookStructure Property

ProtectWorkBookStructure Property
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : ProtectWorkBookStructure Property
Sets or returns a value indicating whether Excel will let the user add, delete, reorder, or rename sheets in the workbook.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ProtectWorkBookStructure As System.Boolean
public System.bool ProtectWorkBookStructure {get; set;}

Property Value

Boolean. The default value is False.
Example
  • C#
GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
sb.ProtectWorkBookStructure = true;
  • Visual Basic
Dim sb As New GrapeCity.SpreadBuilder.Workbook
sb.ProtectWorkBookStructure = True
See Also

Reference

Workbook Class
Workbook Members


ProtectWorkbookWindows Property

ProtectWorkbookWindows Property
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : ProtectWorkbookWindows Property
Sets or returns a value indicating whether the workbook or sheet is protected.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ProtectWorkbookWindows As System.Boolean
public System.bool ProtectWorkbookWindows {get; set;}

Property Value

Boolean. The default value is False.
Example
  • C#
GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
sb.ProtectWorkbookWindows = true;
  • Visual Basic
Dim sb As New GrapeCity.SpreadBuilder.Workbook
sb.ProtectWorkbookWindows = True
See Also

Reference

Workbook Class
Workbook Members


Security Property (Workbook)

Security Property (Workbook)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : Security Property
Returns a DDSecurity object for initializing document security.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Security As DDSecurity
public DDSecurity Security {get;}
See Also

Reference

Workbook Class
Workbook Members


Sheets Property

Sheets Property
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : Sheets Property
Returns a DDSheets object, which is a collection of DDSheet objects, which make up the workbook.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Sheets As DDSheets
public DDSheets Sheets {get;}
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub
See Also

Reference

Workbook Class
Workbook Members


UseCompression Property (Workbook)

UseCompression Property (Workbook)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : UseCompression Property
Gets or sets the value indicating should compression be used on exporting with Xlsx file format.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseCompression As System.Boolean
public System.bool UseCompression {get; set;}
See Also

Reference

Workbook Class
Workbook Members


UseDefaultPalette Property (Workbook)

UseDefaultPalette Property (Workbook)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : UseDefaultPalette Property
Sets or returns whether export document with Excel default palette.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseDefaultPalette As System.Boolean
public System.bool UseDefaultPalette {get; set;}
Remarks
Setting this value to true, application will use the color which is in default palette and is closest to pre-defined custom color of control's forecolor and backcolor.
See Also

Reference

Workbook Class
Workbook Members


Workbook Class Fields

Workbook Class Fields

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : Workbook Class

For a list of all members of this type, see Workbook members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | DefaultFontName | Returns the default font name for the workbook.
static (Shared in Visual Basic) | DefaultFontSizeInPoints | Returns the default font size in points for the workbook.
Top
See Also

Reference

Workbook Class
GrapeCity.SpreadBuilder Namespace


DefaultFontName Field

DefaultFontName Field

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : DefaultFontName Field
Returns the default font name for the workbook.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly DefaultFontName As System.String
public static readonly System.string DefaultFontName
See Also

Reference

Workbook Class
Workbook Members


DefaultFontSizeInPoints Field

DefaultFontSizeInPoints Field

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > Workbook Class : DefaultFontSizeInPoints Field
Returns the default font size in points for the workbook.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly DefaultFontSizeInPoints As System.Integer
public static readonly System.int DefaultFontSizeInPoints
Example

See Also

Reference

Workbook Class
Workbook Members


FileFormat Enumeration

FileFormat Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : FileFormat Enumeration
Specifies the file format that the outputted file should support.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum FileFormat
   Inherits System.Enum
public enum FileFormat : System.Enum
Members
Member | Description
Xls95 | Microsoft Excel 95 format.
Xls97Plus | Optimized for Microsoft Excel 97 and newer versions.
Xlsx | Microsoft Excel OpenXml format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.FileFormat

See Also

Reference

GrapeCity.SpreadBuilder Namespace


GrapeCity.SpreadBuilder.Cells Namespace

GrapeCity.SpreadBuilder.Cells Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Excel.v10 Assembly : GrapeCity.SpreadBuilder.Cells Namespace
The GrapeCity.SpreadBuilder.Cells namespace contains the DDCell class.
Classes
 | Class | Description
Class | DDCell | Represents a single cell in a spreadsheet.
Class | DDCells | Returns a DDCell instance for the specified cell number.
Structures
 | Structure | Description
Structure | MergeArea | A structure that represents a merged rectangular region of cells in the spreadsheet.
Enumerations
 | Enumeration | Description
Enumeration | BiffCellBoolErrValues | The values available for the BiffCellBoolErr.ValueBoolErr property.
Enumeration | CellTypes | The available types of spreadsheet cells that SpreadBuilder supports. This value is used with the DDCell class's Type property to get a specific cell's type.
See Also

Reference

GrapeCity.ActiveReports.Export.Excel.v10 Assembly


DDCell Class

DDCell Class
Members Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace : DDCell Class
Represents a single cell in a spreadsheet.
Object Model
DDCell Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DDCell
public class DDCell
Example
  • Visual Basic
'specify a font for a range of cells
Dim sb As New Workbook()
sb.Sheets.AddNew()
Dim start As DDCell = sb.Sheets(0).Cell(0, 0)
Dim end As DDCell = sb.Sheets(0).Cell(1, 2)
sb.Sheets(0).Cells(start, [end]).FontName = "Comic sans ms"
  • C#
Workbook sb = new Workbook();
sb.Sheets.AddNew();
DDCell start = sb.Sheets[0].Cell(0, 0);
DDCell end = sb.Sheets[0].Cell(1, 2);
sb.Sheets[0].Cells(start, end).FontName = "Comic sans ms";
Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.Cells.DDCell

See Also

Reference

DDCell Members
GrapeCity.SpreadBuilder.Cells Namespace


DDCell Class Members

DDCell Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace : DDCell Class

The following tables list the members exposed by DDCell.

Public Properties
 | Name | Description
Public Property | Alignment | Sets or returns the horizontal alignment value for the cell.
Public Property | BorderBottomColor | Sets or returns the color of the bottom border.
Public Property | BorderBottomStyle | Sets or returns the line style for the bottom portion of the cell's border.
Public Property | BorderDiagonalColor | Sets or returns the color of the diagonal border.
Public Property | BorderDiagonalEnum | Sets or returns a value indicating whether a diagonal border goes up or down, or both (which forms an "X" across the cell).
Public Property | BorderDiagonalStyle | Sets or returns the line style for the diagonal portion of the cell's border.
Public Property | BorderLeftColor | Sets or returns the color of the left border.
Public Property | BorderLeftStyle | Sets or returns the line style for the left portion of the cell's border.
Public Property | BorderRightColor | Sets or returns the color of the right border.
Public Property | BorderRightStyle | Sets or returns the line style for the right portion of the cell's border.
Public Property | BorderTopColor | Sets or returns the color of the top border.
Public Property | BorderTopStyle | Sets or returns the line style for the top portion of the cell's border.
Public Property | FillColor | Sets or returns the background color for the cell.
Public Property | FontBold | Sets or returns a value indicating whether the bold property of the cell's font is used.
Public Property | FontItalic | Sets or returns a value indicating whether the cell's font's Italic property is used.
Public Property | FontName | Sets or returns the name of the font.
Public Property | FontSize | Sets or returns a value indicating the point size to use in the cell's font size property.
Public Property | FontStrikeOut | Sets or returns a value indicating whether the text in the cell is rendered with a horizontal line striking through the text.
Public Property | FontUnderlineStyle | Sets or returns the underline style for the cell.
Public Property | ForeColor | Sets or returns the foreground color or text color of the cell.
Public Property | Hyperlink | Sets or returns a hyperlink for the cell that will automatically be launched by Excel when it is clicked.
Public Property | IsMerged | Sets or returns a value indicating whether the cell is in a merged group of cells.
Public Property | MergeArea | Returns a MergeArea object that represents the merged range containing this cell. If this cell is not in a merged area, this property returns MergeArea.Empty.
Public Property | NumberFormat | Sets or returns an Excel-style number format string.
Public Property | TextAngle | Sets or returns the text rotation for the cell in degrees.
Public Property | Type | The type of cell this DDCell object represents.
Public Property | VertAlignment | Sets or returns the vertical alignment value for the cell.
Public Property | WrapText | Sets or returns a value indicating whether the cell's text can be wrapped.
Top
Public Methods
 | Name | Description
Public Method | GetValue | Returns the cell's current value.
Public Method | Merge | Merges the cell with adjacent cells.
Public Method | SetValue | Overloaded. Sets the cell's type and stores its current value.
Public Method | SetValueBlank | Sets the cell's type to DDCellType.Blank and clears any other current value.
Public Method | UnMerge | Causes the cell and all cells that are currently merged with it to separate and behave as independent cells with their own values and styles.
Top
See Also

Reference

DDCell Class
GrapeCity.SpreadBuilder.Cells Namespace


DDCell Class Methods

DDCell Class Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace : DDCell Class

For a list of all members of this type, see DDCell members.

Public Methods
 | Name | Description
Public Method | GetValue | Returns the cell's current value.
Public Method | Merge | Merges the cell with adjacent cells.
Public Method | SetValue | Overloaded. Sets the cell's type and stores its current value.
Public Method | SetValueBlank | Sets the cell's type to DDCellType.Blank and clears any other current value.
Public Method | UnMerge | Causes the cell and all cells that are currently merged with it to separate and behave as independent cells with their own values and styles.
Top
See Also

Reference

DDCell Class
GrapeCity.SpreadBuilder.Cells Namespace


GetValue Method (DDCell)

GetValue Method (DDCell)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : GetValue Method
Returns the cell's current value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetValue() As System.Object
public System.object GetValue()

Return Value

The return type is one of the following:

  • Null reference (for CellTypes.Blank)
  • System.String (for CellTypes.Label)
  • System.Double (for CellTypes.Number)
  • A value in the BiffCellBoolErrValues enumeration (for CellTypes.BoolErr)

Use DDCell's Type property to determine the type of the cell before returning the value, or check the type of the returned value.

See Also

Reference

DDCell Class
DDCell Members
BiffCellBoolErrValues Enumeration
Type Property


Merge Method (DDCell)

Merge Method (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : Merge Method
The number of vertical rows from the cell to be merged. A value of 1 indicates that only the next cell in the specified direction will be merged.
The number of horizontal columns from the cell to be merged. A value of 1 indicates that only the next cell in the specified direction will be merged.
Merges the cell with adjacent cells.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Merge( _
   ByVal numberOfRowsToMerge As System.UShort, _
   ByVal numberOfColumnsToMerge As System.UShort _
)
public void Merge(
   System.ushort numberOfRowsToMerge,
   System.ushort numberOfColumnsToMerge
)

Parameters

numberOfRowsToMerge
The number of vertical rows from the cell to be merged. A value of 1 indicates that only the next cell in the specified direction will be merged.
numberOfColumnsToMerge
The number of horizontal columns from the cell to be merged. A value of 1 indicates that only the next cell in the specified direction will be merged.
Remarks
Do not merge a cell more than once.
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //To the dimensions of the workbook,add a sheet to sheet collection.
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0, 0).Merge(0, 1);
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");
    if (sb.Sheets[0].IsMerged(0, 0))
    {
        sb.Sheets[0].Cell(0, 0).UnMerge();
    }
    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
    sb.Sheets[0].Clear();
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'To the dimensions of the workbook,add a sheet to sheet collection.
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 0).Merge(0, 1)
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With
    If sb.Sheets(0).IsMerged(0, 0) Then
        sb.Sheets(0).Cell(0, 0).UnMerge()
    End If
    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")
    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
    sb.Sheets(0).Clear()
End Sub
See Also

Reference

DDCell Class
DDCell Members


SetValue Method (DDCell)

SetValue Method (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : SetValue Method
Sets the cell's type and stores its current value.
Overload List
Overload | Description
SetValue(Double) | Sets the cell's type to DDCellType.Number, and sets its value to the specified numeric value.
SetValue(String) | Sets the cell's type to DDCellType.Label, and sets its value to the specified string value.
SetValue(BiffCellBoolErrValues) | Sets the cell's type to DDCellType.Boolean, and sets its value to the specified BiffCellBoolErrValues enumeration.
Example
  • C#
Private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook And add a sheet To its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties And values For columns, rows And cells As desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of Data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");
    //Save the Workbook To an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
    sb.Sheets[0].Clear();
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With
    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")
    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
    sb.Sheets(0).Clear()
End Sub
See Also

Reference

DDCell Class
DDCell Members


SetValue(Double) Method

SetValue(Double) Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class > SetValue Method : SetValue(Double) Method
The numeric value to store as the cell's current value.
Sets the cell's type to DDCellType.Number, and sets its value to the specified numeric value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetValue( _
   ByVal dblValue As System.Double _
)
public void SetValue(
   System.double dblValue
)

Parameters

dblValue
The numeric value to store as the cell's current value.
See Also

Reference

DDCell Class
DDCell Members
Overload List


SetValue(String) Method

SetValue(String) Method
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class > SetValue Method : SetValue(String) Method
The string value to store as the cell's current value.
Sets the cell's type to DDCellType.Label, and sets its value to the specified string value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetValue( _
   ByVal sValue As System.String _
)
public void SetValue(
   System.string sValue
)

Parameters

sValue
The string value to store as the cell's current value.
Example
  • C#
Private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook And add a sheet To its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties And values For columns, rows And cells As desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of Data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");
    //Save the Workbook To an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
    sb.Sheets[0].Clear();
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With
    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")
    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
    sb.Sheets(0).Clear()
End Sub
See Also

Reference

DDCell Class
DDCell Members
Overload List


SetValue(BiffCellBoolErrValues) Method

SetValue(BiffCellBoolErrValues) Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class > SetValue Method : SetValue(BiffCellBoolErrValues) Method
A BiffCellBoolErrValues enumeration value.
Sets the cell's type to DDCellType.Boolean, and sets its value to the specified BiffCellBoolErrValues enumeration.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetValue( _
   ByVal boolerrValue As BiffCellBoolErrValues _
)
public void SetValue(
   BiffCellBoolErrValues boolerrValue
)

Parameters

boolerrValue
A BiffCellBoolErrValues enumeration value.
See Also

Reference

DDCell Class
DDCell Members
Overload List
BiffCellBoolErrValues Enumeration


SetValueBlank Method

SetValueBlank Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : SetValueBlank Method
Sets the cell's type to DDCellType.Blank and clears any other current value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetValueBlank()
public void SetValueBlank()
See Also

Reference

DDCell Class
DDCell Members


UnMerge Method

UnMerge Method
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : UnMerge Method
Causes the cell and all cells that are currently merged with it to separate and behave as independent cells with their own values and styles.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub UnMerge()
public void UnMerge()
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0, 0).Merge(0, 1);
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");
    if (sb.Sheets[0].IsMerged(0, 0))
    {
        sb.Sheets[0].Cell(0, 0).UnMerge();
    }
    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
    sb.Sheets[0].Clear();
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 0).Merge(0, 1)
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With
    If sb.Sheets(0).IsMerged(0, 0) Then
        sb.Sheets(0).Cell(0, 0).UnMerge()
    End If
    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")
    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
    sb.Sheets(0).Clear()
End Sub
See Also

Reference

DDCell Class
DDCell Members


DDCell Class Properties

DDCell Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace : DDCell Class

For a list of all members of this type, see DDCell members.

Public Properties
 | Name | Description
Public Property | Alignment | Sets or returns the horizontal alignment value for the cell.
Public Property | BorderBottomColor | Sets or returns the color of the bottom border.
Public Property | BorderBottomStyle | Sets or returns the line style for the bottom portion of the cell's border.
Public Property | BorderDiagonalColor | Sets or returns the color of the diagonal border.
Public Property | BorderDiagonalEnum | Sets or returns a value indicating whether a diagonal border goes up or down, or both (which forms an "X" across the cell).
Public Property | BorderDiagonalStyle | Sets or returns the line style for the diagonal portion of the cell's border.
Public Property | BorderLeftColor | Sets or returns the color of the left border.
Public Property | BorderLeftStyle | Sets or returns the line style for the left portion of the cell's border.
Public Property | BorderRightColor | Sets or returns the color of the right border.
Public Property | BorderRightStyle | Sets or returns the line style for the right portion of the cell's border.
Public Property | BorderTopColor | Sets or returns the color of the top border.
Public Property | BorderTopStyle | Sets or returns the line style for the top portion of the cell's border.
Public Property | FillColor | Sets or returns the background color for the cell.
Public Property | FontBold | Sets or returns a value indicating whether the bold property of the cell's font is used.
Public Property | FontItalic | Sets or returns a value indicating whether the cell's font's Italic property is used.
Public Property | FontName | Sets or returns the name of the font.
Public Property | FontSize | Sets or returns a value indicating the point size to use in the cell's font size property.
Public Property | FontStrikeOut | Sets or returns a value indicating whether the text in the cell is rendered with a horizontal line striking through the text.
Public Property | FontUnderlineStyle | Sets or returns the underline style for the cell.
Public Property | ForeColor | Sets or returns the foreground color or text color of the cell.
Public Property | Hyperlink | Sets or returns a hyperlink for the cell that will automatically be launched by Excel when it is clicked.
Public Property | IsMerged | Sets or returns a value indicating whether the cell is in a merged group of cells.
Public Property | MergeArea | Returns a MergeArea object that represents the merged range containing this cell. If this cell is not in a merged area, this property returns MergeArea.Empty.
Public Property | NumberFormat | Sets or returns an Excel-style number format string.
Public Property | TextAngle | Sets or returns the text rotation for the cell in degrees.
Public Property | Type | The type of cell this DDCell object represents.
Public Property | VertAlignment | Sets or returns the vertical alignment value for the cell.
Public Property | WrapText | Sets or returns a value indicating whether the cell's text can be wrapped.
Top
See Also

Reference

DDCell Class
GrapeCity.SpreadBuilder.Cells Namespace


Alignment Property (DDCell)

Alignment Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : Alignment Property
Sets or returns the horizontal alignment value for the cell.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Alignment As HorzAlignments
public HorzAlignments Alignment {get; set;}

Property Value

HorzAlignments Enumeration. The default value is General.
Example
  • C#
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
  • Visual Basic
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With
See Also

Reference

DDCell Class
DDCell Members
HorzAlignments Enumeration


BorderBottomColor Property (DDCell)

BorderBottomColor Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : BorderBottomColor Property
Sets or returns the color of the bottom border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BorderBottomColor As Color
public Color BorderBottomColor {get; set;}

Property Value

System.Drawing.Color.
Remarks
This property has no effect if the BorderBottomStyle property is not set.
Example
  • C#
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
  • Visual Basic
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With
See Also

Reference

DDCell Class
DDCell Members


BorderBottomStyle Property (DDCell)

BorderBottomStyle Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : BorderBottomStyle Property
Sets or returns the line style for the bottom portion of the cell's border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BorderBottomStyle As BorderLineStyle
public BorderLineStyle BorderBottomStyle {get; set;}

Property Value

BorderLineStyle enumeration.
Remarks
This property must be set for the BorderBottomColor property to have an effect.
Example
  • C#
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
  • Visual Basic
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With
See Also

Reference

DDCell Class
DDCell Members


BorderDiagonalColor Property (DDCell)

BorderDiagonalColor Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : BorderDiagonalColor Property
Sets or returns the color of the diagonal border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BorderDiagonalColor As Color
public Color BorderDiagonalColor {get; set;}

Property Value

System.Drawing.Color.
Remarks
This property has no effect if the BorderDiagonalStyle and BorderDiagonalEnum properties are not set.
Example
  • C#
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
  • Visual Basic
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With
See Also

Reference

DDCell Class
DDCell Members


BorderDiagonalEnum Property (DDCell)

BorderDiagonalEnum Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : BorderDiagonalEnum Property
Sets or returns a value indicating whether a diagonal border goes up or down, or both (which forms an "X" across the cell).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BorderDiagonalEnum As BorderDiagonalStyles
public BorderDiagonalStyles BorderDiagonalEnum {get; set;}

Property Value

BorderDiagonalStyles enumeration.
Remarks
The default value of this property is DiagonalEnum=0, so if it is not set, no BorderDiagonal lines will be visible.
Example
  • C#
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
  • Visual Basic
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With
See Also

Reference

DDCell Class
DDCell Members


BorderDiagonalStyle Property (DDCell)

BorderDiagonalStyle Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : BorderDiagonalStyle Property
Sets or returns the line style for the diagonal portion of the cell's border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BorderDiagonalStyle As BorderLineStyle
public BorderLineStyle BorderDiagonalStyle {get; set;}

Property Value

BorderLineStyle enumeration.
Remarks
This property, as well as the BorderDiagonalEnum property, must be set for the BorderDiagonalColor property to have an effect.
Example
  • C#
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
  • Visual Basic
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With
See Also

Reference

DDCell Class
DDCell Members


BorderLeftColor Property (DDCell)

BorderLeftColor Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : BorderLeftColor Property
Sets or returns the color of the left border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BorderLeftColor As Color
public Color BorderLeftColor {get; set;}

Property Value

System.Drawing.Color.
Remarks
This property has no effect if the BorderLeftStyle property is not set.
Example
  • C#
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
  • Visual Basic
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With
See Also

Reference

DDCell Class
DDCell Members


BorderLeftStyle Property (DDCell)

BorderLeftStyle Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : BorderLeftStyle Property
Sets or returns the line style for the left portion of the cell's border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BorderLeftStyle As BorderLineStyle
public BorderLineStyle BorderLeftStyle {get; set;}

Property Value

BorderLineStyle enumeration.
Remarks
This property must be set for the BorderLeftColor property to have an effect.
Example
  • C#
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
  • Visual Basic
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With
See Also

Reference

DDCell Class
DDCell Members


BorderRightColor Property (DDCell)

BorderRightColor Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : BorderRightColor Property
Sets or returns the color of the right border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BorderRightColor As Color
public Color BorderRightColor {get; set;}

Property Value

System.Drawing.Color.
Remarks
This property has no effect if the BorderRightStyle property is not set.
Example
  • C#
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
  • Visual Basic
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With
See Also

Reference

DDCell Class
DDCell Members


BorderRightStyle Property (DDCell)

BorderRightStyle Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : BorderRightStyle Property
Sets or returns the line style for the right portion of the cell's border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BorderRightStyle As BorderLineStyle
public BorderLineStyle BorderRightStyle {get; set;}

Property Value

BorderLineStyle enumeration.
Remarks
This property must be set for the BorderRightColor property to have an effect.
Example
  • Visual Basic
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = True;
sb.Sheets[0].Cell(0,0).FontItalic = True;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = True;
  • C#
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With
See Also

Reference

DDCell Class
DDCell Members


BorderTopColor Property (DDCell)

BorderTopColor Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : BorderTopColor Property
Sets or returns the color of the top border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BorderTopColor As Color
public Color BorderTopColor {get; set;}

Property Value

System.Drawing.Color.
Remarks
This property has no effect if the BorderTopStyle property is not set.
Example
  • C#
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
  • Visual Basic
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With
See Also

Reference

DDCell Class
DDCell Members


BorderTopStyle Property (DDCell)

BorderTopStyle Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : BorderTopStyle Property
Sets or returns the line style for the top portion of the cell's border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BorderTopStyle As BorderLineStyle
public BorderLineStyle BorderTopStyle {get; set;}

Property Value

BorderLineStyle enumeration.
Remarks
This property must be set for the BorderTopColor property to have an effect.
Example
  • C#
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
  • Visual Basic
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With
See Also

Reference

DDCell Class
DDCell Members


FillColor Property (DDCell)

FillColor Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : FillColor Property
Sets or returns the background color for the cell.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FillColor As Color
public Color FillColor {get; set;}

Property Value

System.Drawing.Color. The default value is Color.Empty
Example
  • C#
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
  • Visual Basic
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With
See Also

Reference

DDCell Class
DDCell Members


FontBold Property (DDCell)

FontBold Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : FontBold Property
Sets or returns a value indicating whether the bold property of the cell's font is used.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontBold As System.Boolean
public System.bool FontBold {get; set;}

Property Value

Boolean. The default value is False.
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook And add a sheet To its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties And values For columns, rows And cells As desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of Data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");
    //Save the Workbook To an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
    sb.Sheets[0].Clear();
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With
    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")
    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
    sb.Sheets(0).Clear()
End Sub
See Also

Reference

DDCell Class
DDCell Members


FontItalic Property (DDCell)

FontItalic Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : FontItalic Property
Sets or returns a value indicating whether the cell's font's Italic property is used.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontItalic As System.Boolean
public System.bool FontItalic {get; set;}

Property Value

Boolean. The default value is False.
Example
  • C#
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
  • Visual Basic
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With
See Also

Reference

DDCell Class
DDCell Members


FontName Property (DDCell)

FontName Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : FontName Property
Sets or returns the name of the font.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontName As System.String
public System.string FontName {get; set;}

Property Value

String.
Example
  • C#
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
  • Visual Basic
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With
See Also

Reference

DDCell Class
DDCell Members


FontSize Property (DDCell)

FontSize Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : FontSize Property
Sets or returns a value indicating the point size to use in the cell's font size property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontSize As System.Double
public System.double FontSize {get; set;}

Property Value

Double. The number size specified is rounded to the nearest half of a point.
Example
  • C#
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
  • Visual Basic
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With
See Also

Reference

DDCell Class
DDCell Members


FontStrikeOut Property (DDCell)

FontStrikeOut Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : FontStrikeOut Property
Sets or returns a value indicating whether the text in the cell is rendered with a horizontal line striking through the text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontStrikeOut As System.Boolean
public System.bool FontStrikeOut {get; set;}

Property Value

Boolean. The default value is False.
Example
  • C#
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontStrikeOut = true;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
  • Visual Basic
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontStrikeOut = True
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With
See Also

Reference

DDCell Class
DDCell Members


FontUnderlineStyle Property (DDCell)

FontUnderlineStyle Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : FontUnderlineStyle Property
Sets or returns the underline style for the cell.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontUnderlineStyle As FontUnderlineStyles
public FontUnderlineStyles FontUnderlineStyle {get; set;}

Property Value

FontUnderlineStyles enumeration.
Example
  • C#
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
  • Visual Basic
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With
See Also

Reference

DDCell Class
DDCell Members


ForeColor Property (DDCell)

ForeColor Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : ForeColor Property
Sets or returns the foreground color or text color of the cell.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ForeColor As Color
public Color ForeColor {get; set;}

Property Value

System.Drawing.Color. The default value is Color.Black.
Example
  • C#
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
  • Visual Basic
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With
See Also

Reference

DDCell Class
DDCell Members


Hyperlink Property (DDCell)

Hyperlink Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : Hyperlink Property
Sets or returns a hyperlink for the cell that will automatically be launched by Excel when it is clicked.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Hyperlink As System.String
public System.string Hyperlink {get; set;}

Property Value

String.
Example
  • C#
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
  • Visual Basic
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With
See Also

Reference

DDCell Class
DDCell Members


IsMerged Property

IsMerged Property
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : IsMerged Property
Sets or returns a value indicating whether the cell is in a merged group of cells.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsMerged As System.Boolean
public System.bool IsMerged {get;}

Property Value

Boolean. The default value is False.
Example
  • C#
private void btnSpread_Click(object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();
    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0, 0).Merge(0, 1);
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");
    if (sb.Sheets[0].IsMerged(0, 0))
    {
        sb.Sheets[0].Cell(0, 0).UnMerge();
    }
    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");
    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
    sb.Sheets[0].Clear();
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 0).Merge(0, 1)
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
     End With
    If sb.Sheets(0).IsMerged(0, 0) Then
        sb.Sheets(0).Cell(0, 0).UnMerge()
    End If
    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")
    MsgBox("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
    sb.Sheets(0).Clear()
End Sub
See Also

Reference

DDCell Class
DDCell Members


MergeArea Property

MergeArea Property

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : MergeArea Property
Returns a MergeArea object that represents the merged range containing this cell. If this cell is not in a merged area, this property returns MergeArea.Empty.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MergeArea As MergeArea
public MergeArea MergeArea {get;}

Property Value

MergeArea object.
See Also

Reference

DDCell Class
DDCell Members


NumberFormat Property (DDCell)

NumberFormat Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : NumberFormat Property
Sets or returns an Excel-style number format string.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NumberFormat As System.String
public System.string NumberFormat {get; set;}

Property Value

String.
Remarks
For foreign currency symbols such as the Japanese Yen you can use a format such as: "[$¥-0]#,##0.00". Replace the Yen sign (¥) with whatever currency symbol you want to use.
Example
  • C#
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
  • Visual Basic
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With
See Also

Reference

DDCell Class
DDCell Members


TextAngle Property (DDCell)

TextAngle Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : TextAngle Property
Sets or returns the text rotation for the cell in degrees.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TextAngle As System.Short
public System.short TextAngle {get; set;}

Property Value

Short.

  • Values 0-90 angle the text upward 0-90 degrees.
  • Values 91-180 angle the text downward 1-90 degrees.
  • The value 255 is vertical.
Example
  • C#
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
  • Visual Basic
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With
See Also

Reference

DDCell Class
DDCell Members


Type Property (DDCell)

Type Property (DDCell)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : Type Property
The type of cell this DDCell object represents.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Type As CellTypes
public CellTypes Type {get;}

Property Value

CellTypes enumeration.
See Also

Reference

DDCell Class
DDCell Members


VertAlignment Property (DDCell)

VertAlignment Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : VertAlignment Property
Sets or returns the vertical alignment value for the cell.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property VertAlignment As VertAlignments
public VertAlignments VertAlignment {get; set;}

Property Value

VertAlignments enumeration.
Example
  • C#
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
  • Visual Basic
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With
See Also

Reference

DDCell Class
DDCell Members


WrapText Property (DDCell)

WrapText Property (DDCell)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCell Class : WrapText Property
Sets or returns a value indicating whether the cell's text can be wrapped.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WrapText As System.Boolean
public System.bool WrapText {get; set;}

Property Value

Boolean. The default value is False.
Example
  • C#
sb.Sheets[0].Cell(0,0).Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right;
sb.Sheets[0].Cell(0,0).BorderBottomColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderDiagonalColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both;
sb.Sheets[0].Cell(0,0).BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair;
sb.Sheets[0].Cell(0,0).BorderLeftColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderRightColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).BorderTopColor = System.Drawing.Color.Red;
sb.Sheets[0].Cell(0,0).BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double;
sb.Sheets[0].Cell(0,0).FillColor = System.Drawing.Color.Gray;
sb.Sheets[0].Cell(0,0).FontBold = true;
sb.Sheets[0].Cell(0,0).FontItalic = true;
sb.Sheets[0].Cell(0,0).FontName = "Times New Roman";
sb.Sheets[0].Cell(0,0).FontSize = 14;
sb.Sheets[0].Cell(0,0).FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single;
sb.Sheets[0].Cell(0,0).ForeColor = System.Drawing.Color.Blue;
sb.Sheets[0].Cell(0,0).Hyperlink = "www.GrapeCity.com";
sb.Sheets[0].Cell(0,0).NumberFormat = "[$¥-0]#,##0.00";
sb.Sheets[0].Cell(0,0).TextAngle = 255;
sb.Sheets[0].Cell(0,0).VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top;
sb.Sheets[0].Cell(0,0).WrapText = true;
  • Visual Basic
With sb.Sheets(0).Cell(0, 0)
    .Alignment = GrapeCity.SpreadBuilder.Style.HorzAlignments.Right
    .BorderBottomColor = System.Drawing.Color.Red
    .BorderBottomStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderDiagonalColor = System.Drawing.Color.Red
    .BorderDiagonalEnum = GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles.Both
    .BorderDiagonalStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Hair
    .BorderLeftColor = System.Drawing.Color.Red
    .BorderLeftStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderRightColor = System.Drawing.Color.Red
    .BorderRightStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .BorderTopColor = System.Drawing.Color.Red
    .BorderTopStyle = GrapeCity.SpreadBuilder.Style.BorderLineStyle.Double
    .FillColor = System.Drawing.Color.Gray
    .FontBold = True
    .FontItalic = True
    .FontName = "Times New Roman"
    .FontSize = 14
    .FontUnderlineStyle = GrapeCity.SpreadBuilder.Style.FontUnderlineStyles.Single
    .ForeColor = System.Drawing.Color.Blue
    .Hyperlink = "www.GrapeCity.com"
    .NumberFormat = "[$¥-0]#,##0.00"
    .TextAngle = 255
    .VertAlignment = GrapeCity.SpreadBuilder.Style.VertAlignments.Top
    .WrapText = True
End With
See Also

Reference

DDCell Class
DDCell Members


DDCells Class

DDCells Class
Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace : DDCells Class
Returns a DDCell instance for the specified cell number.
Object Model
DDCells Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DDCells
public class DDCells
Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.Cells.DDCells

See Also

Reference

DDCells Members
GrapeCity.SpreadBuilder.Cells Namespace


DDCells Class Members

DDCells Class Members
Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace : DDCells Class

The following tables list the members exposed by DDCells.

Public Properties
 | Name | Description
Public Property | Alignment | Sets the horizontal alignment value for all cells.
Public Property | BorderBottomColor | Sets the color of the bottom border.
Public Property | BorderBottomStyle | Sets the line style for the bottom portion of each cell's border.
Public Property | BorderDiagonalColor | Sets the color of the diagonal border.
Public Property | BorderDiagonalEnum | Sets whether a diagonal border goes up or down, or both (which forms an "X" accross the cell).
Public Property | BorderDiagonalStyle | Sets/gets the line style for the diagonal portion of each cell's border.
Public Property | BorderLeftColor | Sets the color of the left border.
Public Property | BorderLeftStyle | Sets the line style for the left portion of each cell's border.
Public Property | BorderRightColor | Sets the color of the right border.
Public Property | BorderRightStyle | Sets the line style for the right portion of each cell's border.
Public Property | BorderTopColor | Sets the color of the top border.
Public Property | BorderTopStyle | Sets the line style for the top portion of each cell's border.
Public Property | Count | Gets the number of cells contained in this collection
Public Property | FillColor | Sets the "fill color" ("background color") for each cell.
Public Property | FontBold | Sets the bold property of the cell's font.
Public Property | FontItalic | Sets the italic property of the cell's font.
Public Property | FontName | Sets the name of the font.
Public Property | FontSize | Sets the size of the font in points. It will round the number size specified to the nearest half of a point.
Public Property | FontStrikeOut | Sets/gets the bold property of the cell's font.
Public Property | FontUnderlineStyle | Sets the underline style for the cell.
Public Property | ForeColor | Sets the "fore color" ("text color") for each cell.
Public Property | NumberFormat | Sets an Excel style number format string.
Public Property | TextAngle | Sets the text rotation for each cell, in degrees: Values 0-90 is up 0-90 degrees, values 91-180 is down 1-90 degrees, and the value 255 is vertical.
Public Property | VertAlignment | Sets vertical alignment value for all cells.
Public Property | WrapText | Gets/sets whether the cell's text can be wrapped or not.
Top
See Also

Reference

DDCells Class
GrapeCity.SpreadBuilder.Cells Namespace


DDCells Class Properties

DDCells Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace : DDCells Class

For a list of all members of this type, see DDCells members.

Public Properties
 | Name | Description
Public Property | Alignment | Sets the horizontal alignment value for all cells.
Public Property | BorderBottomColor | Sets the color of the bottom border.
Public Property | BorderBottomStyle | Sets the line style for the bottom portion of each cell's border.
Public Property | BorderDiagonalColor | Sets the color of the diagonal border.
Public Property | BorderDiagonalEnum | Sets whether a diagonal border goes up or down, or both (which forms an "X" accross the cell).
Public Property | BorderDiagonalStyle | Sets/gets the line style for the diagonal portion of each cell's border.
Public Property | BorderLeftColor | Sets the color of the left border.
Public Property | BorderLeftStyle | Sets the line style for the left portion of each cell's border.
Public Property | BorderRightColor | Sets the color of the right border.
Public Property | BorderRightStyle | Sets the line style for the right portion of each cell's border.
Public Property | BorderTopColor | Sets the color of the top border.
Public Property | BorderTopStyle | Sets the line style for the top portion of each cell's border.
Public Property | Count | Gets the number of cells contained in this collection
Public Property | FillColor | Sets the "fill color" ("background color") for each cell.
Public Property | FontBold | Sets the bold property of the cell's font.
Public Property | FontItalic | Sets the italic property of the cell's font.
Public Property | FontName | Sets the name of the font.
Public Property | FontSize | Sets the size of the font in points. It will round the number size specified to the nearest half of a point.
Public Property | FontStrikeOut | Sets/gets the bold property of the cell's font.
Public Property | FontUnderlineStyle | Sets the underline style for the cell.
Public Property | ForeColor | Sets the "fore color" ("text color") for each cell.
Public Property | NumberFormat | Sets an Excel style number format string.
Public Property | TextAngle | Sets the text rotation for each cell, in degrees: Values 0-90 is up 0-90 degrees, values 91-180 is down 1-90 degrees, and the value 255 is vertical.
Public Property | VertAlignment | Sets vertical alignment value for all cells.
Public Property | WrapText | Gets/sets whether the cell's text can be wrapped or not.
Top
See Also

Reference

DDCells Class
GrapeCity.SpreadBuilder.Cells Namespace


Alignment Property (DDCells)

Alignment Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : Alignment Property
Sets the horizontal alignment value for all cells.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property Alignment As HorzAlignments
public HorzAlignments Alignment {set;}
See Also

Reference

DDCells Class
DDCells Members


BorderBottomColor Property (DDCells)

BorderBottomColor Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : BorderBottomColor Property
Sets the color of the bottom border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property BorderBottomColor As Color
public Color BorderBottomColor {set;}
Remarks
See BorderTopColor property for more comments in the implementation of these BorderColor props.
See Also

Reference

DDCells Class
DDCells Members


BorderBottomStyle Property (DDCells)

BorderBottomStyle Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : BorderBottomStyle Property
Sets the line style for the bottom portion of each cell's border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property BorderBottomStyle As BorderLineStyle
public BorderLineStyle BorderBottomStyle {set;}
See Also

Reference

DDCells Class
DDCells Members


BorderDiagonalColor Property (DDCells)

BorderDiagonalColor Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : BorderDiagonalColor Property
Sets the color of the diagonal border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property BorderDiagonalColor As Color
public Color BorderDiagonalColor {set;}
Remarks
See BorderTopColor property for more comments in the implementation of these BorderColor props.
See Also

Reference

DDCells Class
DDCells Members


BorderDiagonalEnum Property (DDCells)

BorderDiagonalEnum Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : BorderDiagonalEnum Property
Sets whether a diagonal border goes up or down, or both (which forms an "X" accross the cell).
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property BorderDiagonalEnum As BorderDiagonalStyles
public BorderDiagonalStyles BorderDiagonalEnum {set;}
See Also

Reference

DDCells Class
DDCells Members


BorderDiagonalStyle Property (DDCells)

BorderDiagonalStyle Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : BorderDiagonalStyle Property
Sets/gets the line style for the diagonal portion of each cell's border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property BorderDiagonalStyle As BorderLineStyle
public BorderLineStyle BorderDiagonalStyle {set;}
See Also

Reference

DDCells Class
DDCells Members


BorderLeftColor Property (DDCells)

BorderLeftColor Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : BorderLeftColor Property
Sets the color of the left border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property BorderLeftColor As Color
public Color BorderLeftColor {set;}
Remarks
See BorderTopColor property for more comments in the implementation of these BorderColor props.
See Also

Reference

DDCells Class
DDCells Members


BorderLeftStyle Property (DDCells)

BorderLeftStyle Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : BorderLeftStyle Property
Sets the line style for the left portion of each cell's border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property BorderLeftStyle As BorderLineStyle
public BorderLineStyle BorderLeftStyle {set;}
See Also

Reference

DDCells Class
DDCells Members


BorderRightColor Property (DDCells)

BorderRightColor Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : BorderRightColor Property
Sets the color of the right border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property BorderRightColor As Color
public Color BorderRightColor {set;}
Remarks
See BorderTopColor property for more comments in the implementation of these BorderColor props.
See Also

Reference

DDCells Class
DDCells Members


BorderRightStyle Property (DDCells)

BorderRightStyle Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : BorderRightStyle Property
Sets the line style for the right portion of each cell's border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property BorderRightStyle As BorderLineStyle
public BorderLineStyle BorderRightStyle {set;}
See Also

Reference

DDCells Class
DDCells Members


BorderTopColor Property (DDCells)

BorderTopColor Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : BorderTopColor Property
Sets the color of the top border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property BorderTopColor As Color
public Color BorderTopColor {set;}
See Also

Reference

DDCells Class
DDCells Members


BorderTopStyle Property (DDCells)

BorderTopStyle Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : BorderTopStyle Property
Sets the line style for the top portion of each cell's border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property BorderTopStyle As BorderLineStyle
public BorderLineStyle BorderTopStyle {set;}
See Also

Reference

DDCells Class
DDCells Members


Count Property (DDCells)

Count Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : Count Property
Gets the number of cells contained in this collection
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

DDCells Class
DDCells Members


FillColor Property (DDCells)

FillColor Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : FillColor Property
Sets the "fill color" ("background color") for each cell.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property FillColor As Color
public Color FillColor {set;}
See Also

Reference

DDCells Class
DDCells Members


FontBold Property (DDCells)

FontBold Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : FontBold Property
Sets the bold property of the cell's font.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property FontBold As System.Boolean
public System.bool FontBold {set;}
See Also

Reference

DDCells Class
DDCells Members


FontItalic Property (DDCells)

FontItalic Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : FontItalic Property
Sets the italic property of the cell's font.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property FontItalic As System.Boolean
public System.bool FontItalic {set;}
See Also

Reference

DDCells Class
DDCells Members


FontName Property (DDCells)

FontName Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : FontName Property
Sets the name of the font.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property FontName As System.String
public System.string FontName {set;}
See Also

Reference

DDCells Class
DDCells Members


FontSize Property (DDCells)

FontSize Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : FontSize Property
Sets the size of the font in points. It will round the number size specified to the nearest half of a point.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property FontSize As System.Double
public System.double FontSize {set;}
See Also

Reference

DDCells Class
DDCells Members


FontStrikeOut Property (DDCells)

FontStrikeOut Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : FontStrikeOut Property
Sets/gets the bold property of the cell's font.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property FontStrikeOut As System.Boolean
public System.bool FontStrikeOut {set;}
See Also

Reference

DDCells Class
DDCells Members


FontUnderlineStyle Property (DDCells)

FontUnderlineStyle Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : FontUnderlineStyle Property
Sets the underline style for the cell.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property FontUnderlineStyle As FontUnderlineStyles
public FontUnderlineStyles FontUnderlineStyle {set;}
See Also

Reference

DDCells Class
DDCells Members


ForeColor Property (DDCells)

ForeColor Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : ForeColor Property
Sets the "fore color" ("text color") for each cell.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property ForeColor As Color
public Color ForeColor {set;}
See Also

Reference

DDCells Class
DDCells Members


NumberFormat Property (DDCells)

NumberFormat Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : NumberFormat Property
Sets an Excel style number format string.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property NumberFormat As System.String
public System.string NumberFormat {set;}
See Also

Reference

DDCells Class
DDCells Members


TextAngle Property (DDCells)

TextAngle Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : TextAngle Property
Sets the text rotation for each cell, in degrees: Values 0-90 is up 0-90 degrees, values 91-180 is down 1-90 degrees, and the value 255 is vertical.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property TextAngle As System.Short
public System.short TextAngle {set;}
See Also

Reference

DDCells Class
DDCells Members


VertAlignment Property (DDCells)

VertAlignment Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : VertAlignment Property
Sets vertical alignment value for all cells.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property VertAlignment As VertAlignments
public VertAlignments VertAlignment {set;}
See Also

Reference

DDCells Class
DDCells Members


WrapText Property (DDCells)

WrapText Property (DDCells)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > DDCells Class : WrapText Property
Gets/sets whether the cell's text can be wrapped or not.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property WrapText As System.Boolean
public System.bool WrapText {set;}
See Also

Reference

DDCells Class
DDCells Members


BiffCellBoolErrValues Enumeration

BiffCellBoolErrValues Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace : BiffCellBoolErrValues Enumeration
The values available for the BiffCellBoolErr.ValueBoolErr property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum BiffCellBoolErrValues
   Inherits System.Enum
public enum BiffCellBoolErrValues : System.Enum
Members
Member | Description
Div0 | Excel shows "#DIV/0!" as the error value when IsError is True.
False | Excel shows "False" as the error value when IsError is False.
NA | Excel shows "#N/A" as the error value when IsError is True.
Name | Excel shows "#NAME!" as the error value when IsError is True.
Null | Excel shows "#NULL!" as the error value when IsError is True.
Num | Excel shows "#NUM!" as the error value when IsError is True.
Ref | Excel shows "#REF!" as the error value when IsError is True.
True | Excel shows "True" as the error value when IsError is True.
Value | Excel shows "#VALUE!" as the error value when IsError is True.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Cells.BiffCellBoolErrValues

See Also

Reference

GrapeCity.SpreadBuilder.Cells Namespace


CellTypes Enumeration

CellTypes Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace : CellTypes Enumeration
The available types of spreadsheet cells that SpreadBuilder supports. This value is used with the DDCell class's Type property to get a specific cell's type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum CellTypes
   Inherits System.Enum
public enum CellTypes : System.Enum
Members
Member | Description
Blank | The cell is empty.
BoolErr | The cell is a boolean error.
Label | The cell is a label.
Number | The cell is a number.
Remarks
At this time DDCell does not support all of Excel's cell types.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Cells.CellTypes

See Also

Reference

GrapeCity.SpreadBuilder.Cells Namespace


MergeArea Structure

MergeArea Structure
Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace : MergeArea Structure

A structure that represents a merged rectangular region of cells in the spreadsheet.

Object Model
MergeArea Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure MergeArea
   Inherits System.ValueType
public struct MergeArea : System.ValueType
Remarks

This structure is immutable; you cannot change the values once an instance has been initialized. To extend or truncate an existing MergeArea, remove the existing one and add a new one representing the extended or truncated region.

Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.SpreadBuilder.Cells.MergeArea

See Also

Reference

MergeArea Members
GrapeCity.SpreadBuilder.Cells Namespace


MergeArea Structure Members

MergeArea Structure Members
Fields Properties Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace : MergeArea Structure

The following tables list the members exposed by MergeArea.

Public Constructors
 | Name | Description
Public Constructor | MergeArea Constructor | Initializes a new instance of the MergeArea structure from the specified row and column to the specified row and column.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | Represents an empty merge area.
static (Shared in Visual Basic) | SizeOf | Returns the size of the merged area when written to BIFF.
Top
Public Properties
 | Name | Description
Public Property | ColumnFrom | The leftmost row of the merged area.
Public Property | ColumnTo | The rightmost row of the merged area.
Public Property | RowFrom | The topmost row of the merged area.
Public Property | RowTo | The bottommost row of the merged area.
Top
Public Methods
 | Name | Description
Public Method | ContainsCell | Returns a Boolean value indicating whether the specified cell is contained within the MergeArea.
Top
See Also

Reference

MergeArea Structure
GrapeCity.SpreadBuilder.Cells Namespace


MergeArea Constructor

MergeArea Constructor

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > MergeArea Structure : MergeArea Constructor
The top most row of the merged rectangular region.
The bottom most row of the merged rectangular region.
The leftmost column of the merged rectangular region.
The rightmost column of the merged rectangular region.

Initializes a new instance of the MergeArea structure from the specified row and column to the specified row and column.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal rowFrom As System.UShort, _
   ByVal rowTo As System.UShort, _
   ByVal columnFrom As System.UShort, _
   ByVal columnTo As System.UShort _
)
public MergeArea(
   System.ushort rowFrom,
   System.ushort rowTo,
   System.ushort columnFrom,
   System.ushort columnTo
)

Parameters

rowFrom
The top most row of the merged rectangular region.
rowTo
The bottom most row of the merged rectangular region.
columnFrom
The leftmost column of the merged rectangular region.
columnTo
The rightmost column of the merged rectangular region.
See Also

Reference

MergeArea Structure
MergeArea Members


MergeArea Structure Methods

MergeArea Structure Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace : MergeArea Structure

For a list of all members of this type, see MergeArea members.

Public Methods
 | Name | Description
Public Method | ContainsCell | Returns a Boolean value indicating whether the specified cell is contained within the MergeArea.
Top
See Also

Reference

MergeArea Structure
GrapeCity.SpreadBuilder.Cells Namespace


ContainsCell Method

ContainsCell Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > MergeArea Structure : ContainsCell Method
The row of the cell.
The column of the cell.
Returns a Boolean value indicating whether the specified cell is contained within the MergeArea.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ContainsCell( _
   ByVal row As System.Integer, _
   ByVal column As System.Integer _
) As System.Boolean
public System.bool ContainsCell(
   System.int row,
   System.int column
)

Parameters

row
The row of the cell.
column
The column of the cell.
See Also

Reference

MergeArea Structure
MergeArea Members


MergeArea Structure Properties

MergeArea Structure Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace : MergeArea Structure

For a list of all members of this type, see MergeArea members.

Public Properties
 | Name | Description
Public Property | ColumnFrom | The leftmost row of the merged area.
Public Property | ColumnTo | The rightmost row of the merged area.
Public Property | RowFrom | The topmost row of the merged area.
Public Property | RowTo | The bottommost row of the merged area.
Top
See Also

Reference

MergeArea Structure
GrapeCity.SpreadBuilder.Cells Namespace


ColumnFrom Property

ColumnFrom Property

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > MergeArea Structure : ColumnFrom Property
The leftmost row of the merged area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ColumnFrom As System.UShort
public System.ushort ColumnFrom {get;}
See Also

Reference

MergeArea Structure
MergeArea Members


ColumnTo Property

ColumnTo Property

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > MergeArea Structure : ColumnTo Property
The rightmost row of the merged area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ColumnTo As System.UShort
public System.ushort ColumnTo {get;}
See Also

Reference

MergeArea Structure
MergeArea Members


RowFrom Property

RowFrom Property

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > MergeArea Structure : RowFrom Property
The topmost row of the merged area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property RowFrom As System.UShort
public System.ushort RowFrom {get;}
See Also

Reference

MergeArea Structure
MergeArea Members


RowTo Property

RowTo Property

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > MergeArea Structure : RowTo Property
The bottommost row of the merged area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property RowTo As System.UShort
public System.ushort RowTo {get;}
See Also

Reference

MergeArea Structure
MergeArea Members


MergeArea Structure Fields

MergeArea Structure Fields

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace : MergeArea Structure

For a list of all members of this type, see MergeArea members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | Represents an empty merge area.
static (Shared in Visual Basic) | SizeOf | Returns the size of the merged area when written to BIFF.
Top
See Also

Reference

MergeArea Structure
GrapeCity.SpreadBuilder.Cells Namespace


Empty Field (MergeArea)

Empty Field (MergeArea)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > MergeArea Structure : Empty Field
Represents an empty merge area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Empty As MergeArea
public static readonly MergeArea Empty
See Also

Reference

MergeArea Structure
MergeArea Members


SizeOf Field

SizeOf Field

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Cells Namespace > MergeArea Structure : SizeOf Field
Returns the size of the merged area when written to BIFF.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly SizeOf As System.Short
public static readonly System.short SizeOf
See Also

Reference

MergeArea Structure
MergeArea Members


GrapeCity.SpreadBuilder.Imaging Namespace

GrapeCity.SpreadBuilder.Imaging Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Excel.v10 Assembly : GrapeCity.SpreadBuilder.Imaging Namespace
The GrapeCity.SpreadBuilder.Imaging namespace contains the LineInfo class.
Classes
 | Class | Description
Class | Biff7PictureRecord | This class represents the binary representation of an OBJ record for BIFF7 Pictures. The picture data will be saved as WMF or BMP depending on what is programmatically determined to be more appropriate. Essentially it will be stored as an OBJ record with some additional "subrecord" fields specific to pictures in BIFF7.
Class | LineInfo | The LineInfo class represents a line on a spreadsheet, and all of its settings.
Structures
 | Structure | Description
Structure | ImageInfo | The ImageInfo structure is used by DDSheet.AddImage to specify various options about the image.Initializes a new instance of the ImageInfo structure.
Enumerations
 | Enumeration | Description
Enumeration | ImageLineStyle | Used with ImageInfo.LineStyle to specify the style of the line bounding an image.
Enumeration | ImageLineWeight | Used with ImageInfo.LineWeight to specify the weight of a line bounding an image.
Enumeration | LineArrowHeadLengths | Enumerated type for the Excel arrowhead length.
Enumeration | LineArrowHeadStyles | Excel enumerated type for arrowhead styles.
Enumeration | LineArrowHeadWidths | Enumerated type for Excel arrowhead widths.
Enumeration | LineStyles | Contains the various line styles for several versions of BIFF. Note that some values are not valid in some versions of the Excel BIFF file format.
Enumeration | ObjectDirection | Defines the direction in which a line should render.
Enumeration | SBFloatingMoveType | Defines whether users will be allowed to move or resize the line with cells in the spreadsheet.
See Also

Reference

GrapeCity.ActiveReports.Export.Excel.v10 Assembly


Biff7PictureRecord Class

Biff7PictureRecord Class
Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : Biff7PictureRecord Class
This class represents the binary representation of an OBJ record for BIFF7 Pictures. The picture data will be saved as WMF or BMP depending on what is programmatically determined to be more appropriate. Essentially it will be stored as an OBJ record with some additional "subrecord" fields specific to pictures in BIFF7.
Object Model
Biff7PictureRecord Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Biff7PictureRecord
public class Biff7PictureRecord
Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.Imaging.Biff7PictureRecord

See Also

Reference

Biff7PictureRecord Members
GrapeCity.SpreadBuilder.Imaging Namespace


Biff7PictureRecord Class Members

Biff7PictureRecord Class Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : Biff7PictureRecord Class

The following tables list the members exposed by Biff7PictureRecord.

Public Constructors
 | Name | Description
Public Constructor | Biff7PictureRecord Constructor | Initializes a new instance of Biff7PictureRecord class.
Top
See Also

Reference

Biff7PictureRecord Class
GrapeCity.SpreadBuilder.Imaging Namespace


Biff7PictureRecord Constructor

Biff7PictureRecord Constructor

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > Biff7PictureRecord Class : Biff7PictureRecord Constructor
Initializes a new instance of Biff7PictureRecord class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Biff7PictureRecord()
See Also

Reference

Biff7PictureRecord Class
Biff7PictureRecord Members


LineInfo Class

LineInfo Class
Members Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : LineInfo Class
The LineInfo class represents a line on a spreadsheet, and all of its settings.
Object Model
LineInfo Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class LineInfo
public class LineInfo
Example
  • C#
Private void btnSpread_Click(Object sender, System.EventArgs e)
{
    //Dimension a Workbook and add a sheet to its Sheets collection
    GrapeCity.SpreadBuilder.Workbook sb = new GrapeCity.SpreadBuilder.Workbook();
    sb.Sheets.AddNew();

    //Set up properties and values for columns, rows and cells as desired
    sb.Sheets[0].Name = "Customer Call List";
    sb.Sheets[0].Columns(0).Width = 2 * 1440;
    sb.Sheets[0].Columns(1).Width = 1440;
    sb.Sheets[0].Columns(2).Width = 1440;
    sb.Sheets[0].Rows(0).Height = 1440/4;
    //Header row
    sb.Sheets[0].Cell(0,0).SetValue("Company Name");
    sb.Sheets[0].Cell(0,0).FontBold = true;
    sb.Sheets[0].Cell(0,1).SetValue("Contact Name");
    sb.Sheets[0].Cell(0,1).FontBold = true;
    sb.Sheets[0].Cell(0,2).SetValue("Phone");
    sb.Sheets[0].Cell(0,2).FontBold = true;
    //First row of Data
    sb.Sheets[0].Cell(1,0).SetValue("GrapeCity");
    sb.Sheets[0].Cell(1,1).SetValue("Mortimer");
    sb.Sheets[0].Cell(1,2).SetValue("(614) 895-3142");

    GrapeCity.SpreadBuilder.Imaging.LineInfo l = new GrapeCity.SpreadBuilder.Imaging.LineInfo();
    l.ColumnLeft = 3; //starting column for the line
    l.Color = System.Drawing.Color.Salmon; //color for the line
    l.ColumnRight = 8; //ending column for the line
    l.dxL = 50;
    l.dxR = 60;
    l.dyB = 80;
    l.dyT = 10;
    l.EndAHLength = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadLengths.Long; //length of the ending arrowhead
    l.EndAHStyle = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadStyles.DoubleEndedOpen; //style of the ending arrowhead
    l.EndAHWidth = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadWidths.Wide; //width of the ending arrowhead
    l.fAuto = true;
    l.iQu = GrapeCity.SpreadBuilder.Imaging.ObjectDirection.UpperLeftToLowerRight; //direction of the line
    l.MoveType = GrapeCity.SpreadBuilder.Imaging.SBFloatingMoveType.MoveSize; //sets whether user will be able to move and/or resize the line
    l.RowBottom = 8; //bottom row for the line
    l.RowTop = 1; //top row for the line
    l.StartAHLength = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadLengths.Long; //length of the starting arrowhead
    l.StartAHStyle = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadStyles.DoubleEndedOpen; //style of the starting arrowhead
    l.StartAHWidth = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadWidths.Wide;
    l.Style = GrapeCity.SpreadBuilder.Imaging.LineStyles.Dash; //style of the line
    l.Weight = 5; //thickness of the line

    sb.Sheets[0].AddLine(l);

    //Save the Workbook to an Excel file
    sb.Save (Application.StartupPath + @"\x.xls");

    MessageBox.Show("Your Spreadsheet, " + sb.Sheets[0].Columns(0).OwnerSheet.Name + ", has been saved to " + Application.StartupPath + "\\x.xls");
}
  • Visual Basic
Private Sub btnSpread_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSpread.Click
    'Dimension a Workbook and add a sheet to its Sheets collection
    Dim sb As New GrapeCity.SpreadBuilder.Workbook
    sb.Sheets.AddNew()

    'Set up properties and values for columns, rows and cells as desired
    With sb.Sheets(0)
        .Name = "Customer Call List"
        .Columns(0).Width = 2 * 1440
        .Columns(1).Width = 1440
        .Columns(2).Width = 1440
        .Rows(0).Height = 1440 / 4
        .Rows(0).AutoSize = False
        'Header row
        .Cell(0, 0).SetValue("Company Name")
        .Cell(0, 0).FontBold = True
        .Cell(0, 1).SetValue("Contact Name")
        .Cell(0, 1).FontBold = True
        .Cell(0, 2).SetValue("Phone")
        .Cell(0, 2).FontBold = True
        'First row of data
        .Cell(1, 0).SetValue("GrapeCity")
        .Cell(1, 1).SetValue("Mortimer")
        .Cell(1, 2).SetValue("(614) 895-3142")
    End With
    Dim l As New GrapeCity.SpreadBuilder.Imaging.LineInfo
    With l
        .ColumnLeft = 3 'starting column for the line
        .Color = System.Drawing.Color.Salmon 'color for the line
        .ColumnRight = 8 'ending column for the line
        .dxL = 50
        .dxR = 60
        .dyB = 80
        .dyT = 10
        .EndAHLength = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadLengths.Long 'length of the ending arrowhead
        .EndAHStyle = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadStyles.DoubleEndedOpen 'style of the ending arrowhead
        .EndAHWidth = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadWidths.Wide 'width of the ending arrowhead
        .fAuto = True
        .iQu = GrapeCity.SpreadBuilder.Imaging.ObjectDirection.UpperLeftToLowerRight 'direction of the line
        .MoveType = GrapeCity.SpreadBuilder.Imaging.SBFloatingMoveType.MoveSize 'sets whether user will be able to move and/or resize the line
        .RowBottom = 8 'bottom row for the line
        .RowTop = 1 'top row for the line
        .StartAHLength = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadLengths.Long 'length of the starting arrowhead
        .StartAHStyle = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadStyles.DoubleEndedOpen 'style of the starting arrowhead
        .StartAHWidth = GrapeCity.SpreadBuilder.Imaging.LineArrowHeadWidths.Wide
        .Style = GrapeCity.SpreadBuilder.Imaging.LineStyles.Dash 'style of the line
        .Weight = 5 'thickness of the line
    End With
    sb.Sheets(0).AddLine(l)

    'Save the Workbook to an Excel file
    sb.Save(Application.StartupPath & "\x.xls")

    MessageBox.Show("Your Spreadsheet, " & sb.Sheets(0).Columns(0).OwnerSheet.Name & ", has been saved to " & Application.StartupPath & "\x.xls")
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.Imaging.LineInfo

See Also

Reference

LineInfo Members
GrapeCity.SpreadBuilder.Imaging Namespace


LineInfo Class Members

LineInfo Class Members
Fields Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : LineInfo Class

The following tables list the members exposed by LineInfo.

Public Constructors
 | Name | Description
Public Constructor | LineInfo Constructor | Initializes a new instance of the LineInfo class.
Top
Public Fields
 | Name | Description
Public Field | Color | The System.Drawing.Color for the line.
Public Field | dxL | The X (horizontal) position of the upper-left corner of the object's bounding rectangle, relative to the left side of the underlying cell (specified in colL), expressed as 1/1024th of the cell's width.
Public Field | dxR | The X (horizontal) position of the lower-right corner of the object's bounding rectangle, relative to the left side of the underlying cell, expressed as 1/1024th of the cell's width.
Public Field | dyB | The Y (vertical) position of the lower-right corner of the object's bounding rectangle, relative to the top of the underlying cell, expressed as 1/1024th of the cell's height.
Public Field | dyT | The Y (vertical) position of the upper-left corner of the object's bounding rectangle, relative to the top of the underlying cell, expressed as 1/1024th of the cell's height.
Public Field | EndAHLength | The length of the ending arrowhead.
Public Field | EndAHStyle | The style of the ending arrowhead.
Public Field | EndAHWidth | The width of the ending arrowhead.
Public Field | fAuto | Excel automatic border option.
Public Field | iQu | The direction of the line. Use GrapeCity.SpreadBuilder.Escher.LineDirections constants to define the "quadrant index."
Public Field | MoveType | The options users will have for moving or resizing the line with cells in spreadsheet.
Public Field | StartAHLength | The length of the starting arrowhead.
Public Field | StartAHStyle | The style of the starting arrowhead.
Public Field | StartAHWidth | The width of the starting arrowhead.
Public Field | Style | The style of the line.
Public Field | Weight | The thickness of the line.
Top
Public Properties
 | Name | Description
Public Property | ColumnLeft | Column containing the upper-left corner of the object's bounding rectangle.
Public Property | ColumnRight | Column containing the lower-right corner of the object's bounding rectangle.
Public Property | RowBottom | Row containing the lower-right corner of the object's bounding rectangle.
Public Property | RowTop | Row containing the upper-left corner of the object's bounding rectangle.
Top
See Also

Reference

LineInfo Class
GrapeCity.SpreadBuilder.Imaging Namespace


LineInfo Constructor()

LineInfo Constructor()

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class > LineInfo Constructor : LineInfo Constructor()
Initializes a new instance of the LineInfo class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public LineInfo()
See Also

Reference

LineInfo Class
LineInfo Members
Overload List


LineInfo Class Properties

LineInfo Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : LineInfo Class

For a list of all members of this type, see LineInfo members.

Public Properties
 | Name | Description
Public Property | ColumnLeft | Column containing the upper-left corner of the object's bounding rectangle.
Public Property | ColumnRight | Column containing the lower-right corner of the object's bounding rectangle.
Public Property | RowBottom | Row containing the lower-right corner of the object's bounding rectangle.
Public Property | RowTop | Row containing the upper-left corner of the object's bounding rectangle.
Top
See Also

Reference

LineInfo Class
GrapeCity.SpreadBuilder.Imaging Namespace


ColumnLeft Property

ColumnLeft Property

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : ColumnLeft Property
Column containing the upper-left corner of the object's bounding rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ColumnLeft As System.Integer
public System.int ColumnLeft {get; set;}
Remarks
Cannot be negative.
See Also

Reference

LineInfo Class
LineInfo Members


ColumnRight Property

ColumnRight Property

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : ColumnRight Property
Column containing the lower-right corner of the object's bounding rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ColumnRight As System.Integer
public System.int ColumnRight {get; set;}
Remarks
Cannot be negative.
See Also

Reference

LineInfo Class
LineInfo Members


RowBottom Property

RowBottom Property

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : RowBottom Property
Row containing the lower-right corner of the object's bounding rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RowBottom As System.Integer
public System.int RowBottom {get; set;}
Remarks
Cannot be negative.
See Also

Reference

LineInfo Class
LineInfo Members


RowTop Property

RowTop Property

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : RowTop Property
Row containing the upper-left corner of the object's bounding rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RowTop As System.Integer
public System.int RowTop {get; set;}
Remarks
Cannot be negative.
See Also

Reference

LineInfo Class
LineInfo Members


LineInfo Class Fields

LineInfo Class Fields

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : LineInfo Class

For a list of all members of this type, see LineInfo members.

Public Fields
 | Name | Description
Public Field | Color | The System.Drawing.Color for the line.
Public Field | dxL | The X (horizontal) position of the upper-left corner of the object's bounding rectangle, relative to the left side of the underlying cell (specified in colL), expressed as 1/1024th of the cell's width.
Public Field | dxR | The X (horizontal) position of the lower-right corner of the object's bounding rectangle, relative to the left side of the underlying cell, expressed as 1/1024th of the cell's width.
Public Field | dyB | The Y (vertical) position of the lower-right corner of the object's bounding rectangle, relative to the top of the underlying cell, expressed as 1/1024th of the cell's height.
Public Field | dyT | The Y (vertical) position of the upper-left corner of the object's bounding rectangle, relative to the top of the underlying cell, expressed as 1/1024th of the cell's height.
Public Field | EndAHLength | The length of the ending arrowhead.
Public Field | EndAHStyle | The style of the ending arrowhead.
Public Field | EndAHWidth | The width of the ending arrowhead.
Public Field | fAuto | Excel automatic border option.
Public Field | iQu | The direction of the line. Use GrapeCity.SpreadBuilder.Escher.LineDirections constants to define the "quadrant index."
Public Field | MoveType | The options users will have for moving or resizing the line with cells in spreadsheet.
Public Field | StartAHLength | The length of the starting arrowhead.
Public Field | StartAHStyle | The style of the starting arrowhead.
Public Field | StartAHWidth | The width of the starting arrowhead.
Public Field | Style | The style of the line.
Public Field | Weight | The thickness of the line.
Top
See Also

Reference

LineInfo Class
GrapeCity.SpreadBuilder.Imaging Namespace


Color Field (LineInfo)

Color Field (LineInfo)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : Color Field
The System.Drawing.Color for the line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Color As Color
public Color Color

Field Value

System.Drawing.Color.
See Also

Reference

LineInfo Class
LineInfo Members


dxL Field

dxL Field

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : dxL Field
The X (horizontal) position of the upper-left corner of the object's bounding rectangle, relative to the left side of the underlying cell (specified in colL), expressed as 1/1024th of the cell's width.
Syntax
  • Visual Basic
  • C#
'Declaration

Public dxL As System.Short
public System.short dxL

Field Value

Short.
Remarks
This value cannot be negative.
See Also

Reference

LineInfo Class
LineInfo Members


dxR Field

dxR Field

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : dxR Field
The X (horizontal) position of the lower-right corner of the object's bounding rectangle, relative to the left side of the underlying cell, expressed as 1/1024th of the cell's width.
Syntax
  • Visual Basic
  • C#
'Declaration

Public dxR As System.Short
public System.short dxR

Field Value

Short.
Remarks
This value cannot be negative.
See Also

Reference

LineInfo Class
LineInfo Members


dyB Field

dyB Field

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : dyB Field
The Y (vertical) position of the lower-right corner of the object's bounding rectangle, relative to the top of the underlying cell, expressed as 1/1024th of the cell's height.
Syntax
  • Visual Basic
  • C#
'Declaration

Public dyB As System.Short
public System.short dyB

Field Value

Short.
Remarks
This value cannot be negative.
See Also

Reference

LineInfo Class
LineInfo Members


dyT Field

dyT Field

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : dyT Field
The Y (vertical) position of the upper-left corner of the object's bounding rectangle, relative to the top of the underlying cell, expressed as 1/1024th of the cell's height.
Syntax
  • Visual Basic
  • C#
'Declaration

Public dyT As System.Short
public System.short dyT

Field Value

Short.
Remarks
This value cannot be negative.
See Also

Reference

LineInfo Class
LineInfo Members


EndAHLength Field

EndAHLength Field

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : EndAHLength Field
The length of the ending arrowhead.
Syntax
  • Visual Basic
  • C#
'Declaration

Public EndAHLength As LineArrowHeadLengths
public LineArrowHeadLengths EndAHLength

Field Value

A LineArrowHeadLengths enumeration value.
See Also

Reference

LineInfo Class
LineInfo Members


EndAHStyle Field

EndAHStyle Field

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : EndAHStyle Field
The style of the ending arrowhead.
Syntax
  • Visual Basic
  • C#
'Declaration

Public EndAHStyle As LineArrowHeadStyles
public LineArrowHeadStyles EndAHStyle

Field Value

A LineArrowHeadStyles enumeration value.
See Also

Reference

LineInfo Class
LineInfo Members


EndAHWidth Field

EndAHWidth Field

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : EndAHWidth Field
The width of the ending arrowhead.
Syntax
  • Visual Basic
  • C#
'Declaration

Public EndAHWidth As LineArrowHeadWidths
public LineArrowHeadWidths EndAHWidth

Field Value

A LineArrowHeadWidths enumeration value.
See Also

Reference

LineInfo Class
LineInfo Members


fAuto Field

fAuto Field

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : fAuto Field
Excel automatic border option.
Syntax
  • Visual Basic
  • C#
'Declaration

Public fAuto As System.Boolean
public System.bool fAuto

Field Value

Boolean.
Remarks
Set fAuto to 1 if you want the Excel automatic border option turned on.
See Also

Reference

LineInfo Class
LineInfo Members


iQu Field

iQu Field

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : iQu Field
The direction of the line. Use GrapeCity.SpreadBuilder.Escher.LineDirections constants to define the "quadrant index."
Syntax
  • Visual Basic
  • C#
'Declaration

Public iQu As ObjectDirection
public ObjectDirection iQu

Field Value

An ObjectDirection enumeration value.
See Also

Reference

LineInfo Class
LineInfo Members


MoveType Field

MoveType Field

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : MoveType Field
The options users will have for moving or resizing the line with cells in spreadsheet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MoveType As SBFloatingMoveType
public SBFloatingMoveType MoveType
See Also

Reference

LineInfo Class
LineInfo Members


StartAHLength Field

StartAHLength Field

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : StartAHLength Field
The length of the starting arrowhead.
Syntax
  • Visual Basic
  • C#
'Declaration

Public StartAHLength As LineArrowHeadLengths
public LineArrowHeadLengths StartAHLength

Field Value

A LineArrowHeadLengths enumeration value.
See Also

Reference

LineInfo Class
LineInfo Members


StartAHStyle Field

StartAHStyle Field

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : StartAHStyle Field
The style of the starting arrowhead.
Syntax
  • Visual Basic
  • C#
'Declaration

Public StartAHStyle As LineArrowHeadStyles
public LineArrowHeadStyles StartAHStyle

Field Value

A LineArrowHeadStyles enumeration value.
See Also

Reference

LineInfo Class
LineInfo Members


StartAHWidth Field

StartAHWidth Field

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : StartAHWidth Field
The width of the starting arrowhead.
Syntax
  • Visual Basic
  • C#
'Declaration

Public StartAHWidth As LineArrowHeadWidths
public LineArrowHeadWidths StartAHWidth

Field Value

A LineArrowHeadWidths enumeration value.
See Also

Reference

LineInfo Class
LineInfo Members


Style Field

Style Field

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : Style Field
The style of the line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Style As LineStyles
public LineStyles Style

Field Value

A LineStyles enumeration value.
Remarks

Effect for Microsoft Excel 97 file format (BIFF8):

0-Solid
1-Small Dash (No Equivalent Menu for Excel 2000)
2-Square Dot
3-Small Dash, Square Dot (No Equivalent Menu for Excel 2000)
4-Small Dash, Square Dot, Square Dot (No Equivalent Menu for Excel 2000)
5-Loosely spaced Square Dot (No Equivalent Menu for Excel 2000)
6-Dash
7-Long Dash
8-Dash Dot
9-Long Dash Dot
10-Long Dash Dot Dot
11-Round Dot

Effect for versions 3, 4, 5, and 7.

0-Solid
1-Long Dash
2-Dash
3-Long Dash Dot
4-Long Dash Dot Dot
5-Pattern 50% Solid (No Equivalent Menu for Excel 2000)
6-Pattern 75% Solid (No Equivalent Menu for Excel 2000)
7-Pattern 25% Solid (No Equivalent Menu for Excel 2000)
15-Transparent (No Line)

Version 2 does not support lines

See Also

Reference

LineInfo Class
LineInfo Members


Weight Field

Weight Field

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : Weight Field
The thickness of the line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Weight As System.Integer
public System.int Weight

Field Value

An Excel enumerated line weight value.
Remarks

Effect for Microsoft Excel 97 file format (BIFF8):

Parameter will generate line with weight parameter as points.

Effect for versions 3, 4, 5, and 7.

0-Hairline: 0 points
1-Single: .75 points
2-Double: 1.35 points
3-Thick: 1.95 points

Version 2 does not support lines

See Also

Reference

LineInfo Class
LineInfo Members


ImageLineStyle Enumeration

ImageLineStyle Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : ImageLineStyle Enumeration
Used with ImageInfo.LineStyle to specify the style of the line bounding an image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ImageLineStyle
   Inherits System.Enum
public enum ImageLineStyle : System.Enum
Members
Member | Description
DarkGray | Renders a dark gray line.
Dash | Renders a dashed line.
DashDot | Renders a line of alternating dashes and dots.
DashDotDot | Renders a line of alternating dashes and pairs of dots.
Dot | Renders a dotted line.
LightGray | Renders a light gray line.
MediumGray | Renders a medium gray line.
Null | Renders no line.
Solid | Renders a solid line.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Imaging.ImageLineStyle

See Also

Reference

GrapeCity.SpreadBuilder.Imaging Namespace


ImageLineWeight Enumeration

ImageLineWeight Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : ImageLineWeight Enumeration
Used with ImageInfo.LineWeight to specify the weight of a line bounding an image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ImageLineWeight
   Inherits System.Enum
public enum ImageLineWeight : System.Enum
Members
Member | Description
Double | Renders a double line around the image.
Hairline | Renders a thin line around the image.
Single | Renders a single line around the image.
Thick | Renders a thick line around the image.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Imaging.ImageLineWeight

See Also

Reference

GrapeCity.SpreadBuilder.Imaging Namespace


LineArrowHeadLengths Enumeration

LineArrowHeadLengths Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : LineArrowHeadLengths Enumeration
Enumerated type for the Excel arrowhead length.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LineArrowHeadLengths
   Inherits System.Enum
public enum LineArrowHeadLengths : System.Enum
Members
Member | Description
Long | Renders a long arrowhead on the line.
Medium | Renders a medium-length arrowhead on the line.
Short | Renders a short arrowhead on the line.
Remarks
Used with DDSheet.AddLine(..).
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Imaging.LineArrowHeadLengths

See Also

Reference

GrapeCity.SpreadBuilder.Imaging Namespace


LineArrowHeadStyles Enumeration

LineArrowHeadStyles Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : LineArrowHeadStyles Enumeration
Excel enumerated type for arrowhead styles.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LineArrowHeadStyles
   Inherits System.Enum
public enum LineArrowHeadStyles : System.Enum
Members
Member | Description
DoubleEndedFilled | Renders a line with a circular arrowhead.
DoubleEndedOpen | Renders a line with a diamond-shaped arrowhead.
Filled | Renders a line with a stylized, arrow-shaped arrowhead.
None | Renders a line with no arrowhead.
Open | Renders a line with a triangular arrowhead.
Remarks
Used with DDSheet.AddLine(..).
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Imaging.LineArrowHeadStyles

See Also

Reference

GrapeCity.SpreadBuilder.Imaging Namespace


LineArrowHeadWidths Enumeration

LineArrowHeadWidths Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : LineArrowHeadWidths Enumeration
Enumerated type for Excel arrowhead widths.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LineArrowHeadWidths
   Inherits System.Enum
public enum LineArrowHeadWidths : System.Enum
Members
Member | Description
Medium | Renders a line with a medium-width arrowhead.
Narrow | Renders a line with a narrow arrowhead.
Wide | Renders a line with a wide arrowhead.
Remarks
Used with DDSheet.AddLine(..).
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Imaging.LineArrowHeadWidths

See Also

Reference

GrapeCity.SpreadBuilder.Imaging Namespace


LineStyles Enumeration

LineStyles Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : LineStyles Enumeration
Contains the various line styles for several versions of BIFF. Note that some values are not valid in some versions of the Excel BIFF file format.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LineStyles
   Inherits System.Enum
public enum LineStyles : System.Enum
Members
Member | Description
Dash | Renders a dashed line.
DashDot | Renders a line of alternating dashes and dots.
LongDash | Renders a line of long dashes.
LongDashDot | Renders a line of alternating long dashes and dots.
LongDashDotDot | Renders a line of alternating long dashes and pairs of dots.
LooselySpacedSquareDot | Renders a line of loosely spaced square dots.
OldTransparent | Renders no line, i.e. Transparent. Only effective in BIFF versions 3, 4, 5, and 7.
RoundDot | Renders a line of round dots.
SmallDash | Renders a line of small dashes. (No equivalent in Excel 2000.)
SmallDashSquareDot | Renders a line of alternating small dashes and square dots.
SmallDashSquareDotSquareDot | Renders a line of alternating small dashes and pairs of square dots.
Solid | Renders a solid line.
SquareDot | Renders a line of square dots.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Imaging.LineStyles

See Also

Reference

GrapeCity.SpreadBuilder.Imaging Namespace


ObjectDirection Enumeration

ObjectDirection Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : ObjectDirection Enumeration
Defines the direction in which a line should render.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ObjectDirection
   Inherits System.Enum
public enum ObjectDirection : System.Enum
Members
Member | Description
LowerLeftToUpperRight | Renders the starting arrowhead at the lower left end of the line, and the ending arrowhead at the upper right end of the line.
LowerRightToUpperLeft | Renders the starting arrowhead at the lower right end of the line, and the ending arrowhead at the upper left end of the line.
UpperLeftToLowerRight | Renders the starting arrowhead at the upper left end of the line, and the ending arrowhead at the lower right end of the line.
UpperRightToLowerLeft | Renders the starting arrowhead at the upper left end of the line, and the ending arrowhead at the lower right end of the line.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Imaging.ObjectDirection

See Also

Reference

GrapeCity.SpreadBuilder.Imaging Namespace


SBFloatingMoveType Enumeration

SBFloatingMoveType Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : SBFloatingMoveType Enumeration
Defines whether users will be allowed to move or resize the line with cells in the spreadsheet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum SBFloatingMoveType
   Inherits System.Enum
public enum SBFloatingMoveType : System.Enum
Members
Member | Description
MoveNoSize | The user may move the line with cells, but the size is fixed.
MoveSize | The user may move and resize the line with cells.
NoMoveNoSize | The line is fixed. The user can neither move it nor resize it with cells.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Imaging.SBFloatingMoveType

See Also

Reference

GrapeCity.SpreadBuilder.Imaging Namespace


ImageInfo Structure

ImageInfo Structure
Members

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : ImageInfo Structure
The ImageInfo structure is used by DDSheet.AddImage to specify various options about the image.Initializes a new instance of the ImageInfo structure.
Object Model
ImageInfo Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure ImageInfo
   Inherits System.ValueType
public struct ImageInfo : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.SpreadBuilder.Imaging.ImageInfo

See Also

Reference

ImageInfo Members
GrapeCity.SpreadBuilder.Imaging Namespace


ImageInfo Structure Members

ImageInfo Structure Members
Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : ImageInfo Structure

The following tables list the members exposed by ImageInfo.

Public Properties
 | Name | Description
Public Property | AutoFill | Sets or returns a value indicating whether the image should automatically fill the specified range of cells.
Public Property | AutoSize | Sets or returns a value indicating whether the image automatically moves and sizes with the cells.
Public Property | FillPattern | Sets or returns a value indicating whether the background of the image is filled.
Public Property | LineStyle | Specifies the style of the line bounding the image.
Public Property | LineWeight | Specifies the weight of the line bounding the image.
Public Property | MoveWithCells | Sets or returns a value indicating whether the image moves with the cells.
Public Property | QuadrantIndex | Sets or returns the direction in which the image begins and ends.
Top
See Also

Reference

ImageInfo Structure
GrapeCity.SpreadBuilder.Imaging Namespace


ImageInfo Structure Properties

ImageInfo Structure Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace : ImageInfo Structure

For a list of all members of this type, see ImageInfo members.

Public Properties
 | Name | Description
Public Property | AutoFill | Sets or returns a value indicating whether the image should automatically fill the specified range of cells.
Public Property | AutoSize | Sets or returns a value indicating whether the image automatically moves and sizes with the cells.
Public Property | FillPattern | Sets or returns a value indicating whether the background of the image is filled.
Public Property | LineStyle | Specifies the style of the line bounding the image.
Public Property | LineWeight | Specifies the weight of the line bounding the image.
Public Property | MoveWithCells | Sets or returns a value indicating whether the image moves with the cells.
Public Property | QuadrantIndex | Sets or returns the direction in which the image begins and ends.
Top
See Also

Reference

ImageInfo Structure
GrapeCity.SpreadBuilder.Imaging Namespace


AutoFill Property

AutoFill Property

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > ImageInfo Structure : AutoFill Property

Sets or returns a value indicating whether the image should automatically fill the specified range of cells.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoFill As System.Boolean
public System.bool AutoFill {get; set;}

Property Value

Boolean. Returns True if the Automatic Fill option is turned on in the Format Object dialog box, Patterns tab.
See Also

Reference

ImageInfo Structure
ImageInfo Members


AutoSize Property (ImageInfo)

AutoSize Property (ImageInfo)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > ImageInfo Structure : AutoSize Property
Sets or returns a value indicating whether the image automatically moves and sizes with the cells.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoSize As System.Boolean
public System.bool AutoSize {get; set;}

Property Value

Boolean. If left False, the picture is clipped if it exceeds the area of the added image.
See Also

Reference

ImageInfo Structure
ImageInfo Members


FillPattern Property

FillPattern Property

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > ImageInfo Structure : FillPattern Property

Sets or returns a value indicating whether the background of the image is filled.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FillPattern As System.Boolean
public System.bool FillPattern {get; set;}
See Also

Reference

ImageInfo Structure
ImageInfo Members


LineStyle Property (ImageInfo)

LineStyle Property (ImageInfo)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > ImageInfo Structure : LineStyle Property
Specifies the style of the line bounding the image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineStyle As ImageLineStyle
public ImageLineStyle LineStyle {get; set;}

Property Value

GrapeCity.SpreadBuilder.Imaging.ImageLineStyle enumeration.
See Also

Reference

ImageInfo Structure
ImageInfo Members


LineWeight Property (ImageInfo)

LineWeight Property (ImageInfo)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > ImageInfo Structure : LineWeight Property
Specifies the weight of the line bounding the image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineWeight As ImageLineWeight
public ImageLineWeight LineWeight {get; set;}

Property Value

GrapeCity.SpreadBuilder.Imaging.ImageLineWeight enumeration.
See Also

Reference

ImageInfo Structure
ImageInfo Members


MoveWithCells Property

MoveWithCells Property

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > ImageInfo Structure : MoveWithCells Property
Sets or returns a value indicating whether the image moves with the cells.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MoveWithCells As System.Boolean
public System.bool MoveWithCells {get; set;}

Property Value

Boolean. Returns True if the object moves with the cells (Format Object dialog box, Properties tab).

See Also

Reference

ImageInfo Structure
ImageInfo Members


QuadrantIndex Property

QuadrantIndex Property

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > ImageInfo Structure : QuadrantIndex Property
Sets or returns the direction in which the image begins and ends.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property QuadrantIndex As ObjectDirection
public ObjectDirection QuadrantIndex {get; set;}

Property Value

GrapeCity.SpreadBuilder.Imaging.ObjectDirection enumeration.
See Also

Reference

ImageInfo Structure
ImageInfo Members


GrapeCity.SpreadBuilder.Printing Namespace

GrapeCity.SpreadBuilder.Printing Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Excel.v10 Assembly : GrapeCity.SpreadBuilder.Printing Namespace
The GrapeCity.SpreadBuilder.Printing namespace contains the PageSetup class.
Classes
 | Class | Description
Class | PageSetup | Represents page setup information for a worksheet such as margins, paper size, etc.
Enumerations
 | Enumeration | Description
Enumeration | PagePrintOrder | Used with the PageSetup.Order property to set the order in which pages are numbered when printing a large worksheet.
Enumeration | PagePrintOrientation | Used with PageSetup.Orientation to set pages to be printed in landscape or portrait.
See Also

Reference

GrapeCity.ActiveReports.Export.Excel.v10 Assembly


PageSetup Class

PageSetup Class
Members Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Printing Namespace : PageSetup Class
Represents page setup information for a worksheet such as margins, paper size, etc.
Object Model
PageSetup Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class PageSetup
public class PageSetup
Example
  • C#
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
  • Visual Basic
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With
Inheritance Hierarchy

System.Object
GrapeCity.SpreadBuilder.Printing.PageSetup

See Also

Reference

PageSetup Members
GrapeCity.SpreadBuilder.Printing Namespace


PageSetup Class Members

PageSetup Class Members
Fields Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Printing Namespace : PageSetup Class

The following tables list the members exposed by PageSetup.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | FirstPageNumberAuto | Use this value with PageSetup.FirstPageNumber to specify that the first page number used should be determined automatically.
Top
Public Properties
 | Name | Description
Public Property | BlackAndWhite | Sets or returns a value indicating whether elements of the document are printed in black and white.
Public Property | BottomMargin | Sets or returns the bottom margin value in points.
Public Property | Draft | Sets or returns a value indicating whether the sheet will be printed without graphics.
Public Property | FirstPageNumber | Returns or sets the first page number that will be used when this sheet is printed.
Public Property | FitToPage | Returns a value indicating whether the FitToPage option is selected in the page setup dialog.
Public Property | FitToPagesTall | Returns or sets the number of pages tall to which the worksheet will be scaled when it's printed.
Public Property | FitToPagesWide | Returns or sets the number of pages wide to which the worksheet will be scaled when it's printed.
Public Property | FooterMargin | Returns or sets the distance in points from the bottom of the page to the footer.
Public Property | HeaderMargin | Returns or sets the distance in points from the top of the page to the header.
Public Property | LeftMargin | Sets or returns the left margin value in points.
Public Property | Order | Returns or sets the order in which pages are numbered when printing a large worksheet.
Public Property | Orientation | Sets or returns a value indicating whether pages are printed in landscape or portrait.
Public Property | PaperSize | Sets or returns the size of the paper to use.
Public Property | PrintNotes | Sets or returns a value indicating whether cell notes are printed as end notes with the sheet.
Public Property | RightMargin | Sets or returns the right margin value in points.
Public Property | TopMargin | Sets or returns the top margin value in points.
Public Property | Zoom | Sets or returns the zoom value at which to print the spreadsheet.
Top
See Also

Reference

PageSetup Class
GrapeCity.SpreadBuilder.Printing Namespace


PageSetup Class Properties

PageSetup Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Printing Namespace : PageSetup Class

For a list of all members of this type, see PageSetup members.

Public Properties
 | Name | Description
Public Property | BlackAndWhite | Sets or returns a value indicating whether elements of the document are printed in black and white.
Public Property | BottomMargin | Sets or returns the bottom margin value in points.
Public Property | Draft | Sets or returns a value indicating whether the sheet will be printed without graphics.
Public Property | FirstPageNumber | Returns or sets the first page number that will be used when this sheet is printed.
Public Property | FitToPage | Returns a value indicating whether the FitToPage option is selected in the page setup dialog.
Public Property | FitToPagesTall | Returns or sets the number of pages tall to which the worksheet will be scaled when it's printed.
Public Property | FitToPagesWide | Returns or sets the number of pages wide to which the worksheet will be scaled when it's printed.
Public Property | FooterMargin | Returns or sets the distance in points from the bottom of the page to the footer.
Public Property | HeaderMargin | Returns or sets the distance in points from the top of the page to the header.
Public Property | LeftMargin | Sets or returns the left margin value in points.
Public Property | Order | Returns or sets the order in which pages are numbered when printing a large worksheet.
Public Property | Orientation | Sets or returns a value indicating whether pages are printed in landscape or portrait.
Public Property | PaperSize | Sets or returns the size of the paper to use.
Public Property | PrintNotes | Sets or returns a value indicating whether cell notes are printed as end notes with the sheet.
Public Property | RightMargin | Sets or returns the right margin value in points.
Public Property | TopMargin | Sets or returns the top margin value in points.
Public Property | Zoom | Sets or returns the zoom value at which to print the spreadsheet.
Top
See Also

Reference

PageSetup Class
GrapeCity.SpreadBuilder.Printing Namespace


BlackAndWhite Property

BlackAndWhite Property
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : BlackAndWhite Property
Sets or returns a value indicating whether elements of the document are printed in black and white.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BlackAndWhite As System.Boolean
public System.bool BlackAndWhite {get; set;}

Property Value

Boolean. The default value is False.
Example
  • C#
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
  • Visual Basic
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With
See Also

Reference

PageSetup Class
PageSetup Members


BottomMargin Property (PageSetup)

BottomMargin Property (PageSetup)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : BottomMargin Property
Sets or returns the bottom margin value in points.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BottomMargin As System.Double
public System.double BottomMargin {get; set;}

Property Value

Double. The default value is 72.
Remarks
The value MUST be greater than or equal to 0 and less than 3528.
Example
  • C#
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
  • Visual Basic
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With
See Also

Reference

PageSetup Class
PageSetup Members


Draft Property

Draft Property
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : Draft Property
Sets or returns a value indicating whether the sheet will be printed without graphics.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Draft As System.Boolean
public System.bool Draft {get; set;}

Property Value

Boolean. The default value is False.
Example
  • C#
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
  • Visual Basic
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With
See Also

Reference

PageSetup Class
PageSetup Members


FirstPageNumber Property

FirstPageNumber Property
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : FirstPageNumber Property
Returns or sets the first page number that will be used when this sheet is printed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FirstPageNumber As System.Short
public System.short FirstPageNumber {get; set;}

Property Value

Short. The default value is PageSetup.FirstPageNumberAuto. With this value, the first page number will be chosen automatically.
Example
  • C#
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
  • Visual Basic
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With
See Also

Reference

PageSetup Class
PageSetup Members


FitToPage Property

FitToPage Property
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : FitToPage Property
Returns a value indicating whether the FitToPage option is selected in the page setup dialog.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property FitToPage As System.Boolean
public System.bool FitToPage {get;}

Property Value

Boolean. The default value is False.
Remarks
If FitToPagesWide or FitToPagesTall was set since the last Zoom, this property will return True to indicate that the FitToPage option in the Page Setup dialog is selected. If Zoom was set since FitToPagesWide or FitToPagesTall (or none of these properties were set at all) this property returns False, indicating that the zoom/percentage scaling option is selected.
Example
  • C#
sb.Sheets[0].PageSetup.FitToPagesTall = 2;
sb.Sheets[0].PageSetup.FitToPagesWide = 2;

if (sb.Sheets[0].PageSetup.FitToPage == true)
{
    MessageBox.Show("FitToPage");
}
  • Visual Basic
sb.Sheets(0).PageSetup.FitToPagesTall = 2
sb.Sheets(0).PageSetup.FitToPagesWide = 2

If sb.Sheets(0).PageSetup.FitToPage = True Then
    MsgBox("FitToPage")
End If
See Also

Reference

PageSetup Class
PageSetup Members


FitToPagesTall Property

FitToPagesTall Property
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : FitToPagesTall Property
Returns or sets the number of pages tall to which the worksheet will be scaled when it's printed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FitToPagesTall As System.Short
public System.short FitToPagesTall {get; set;}

Property Value

Short.
Remarks
If the Zoom property is set to True, this property is ignored.
Example
  • C#
sb.Sheets[0].PageSetup.FitToPagesTall = 2;
sb.Sheets[0].PageSetup.FitToPagesWide = 2;

if (sb.Sheets[0].PageSetup.FitToPage == true)
{
    MessageBox.Show("FitToPage");
}
  • Visual Basic
sb.Sheets(0).PageSetup.FitToPagesTall = 2
sb.Sheets(0).PageSetup.FitToPagesWide = 2

If sb.Sheets(0).PageSetup.FitToPage = True Then
    MsgBox("FitToPage")
End If
See Also

Reference

PageSetup Class
PageSetup Members


FitToPagesWide Property

FitToPagesWide Property
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : FitToPagesWide Property
Returns or sets the number of pages wide to which the worksheet will be scaled when it's printed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FitToPagesWide As System.Short
public System.short FitToPagesWide {get; set;}

Property Value

Short.
Remarks
If the Zoom property is set to True, this property is ignored.
Example
  • C#
sb.Sheets[0].PageSetup.FitToPagesTall = 2;
sb.Sheets[0].PageSetup.FitToPagesWide = 2;

if (sb.Sheets[0].PageSetup.FitToPage == true)
{
    MessageBox.Show("FitToPage");
}
  • Visual Basic
sb.Sheets(0).PageSetup.FitToPagesTall = 2
sb.Sheets(0).PageSetup.FitToPagesWide = 2

If sb.Sheets(0).PageSetup.FitToPage = True Then
    MsgBox("FitToPage")
End If
See Also

Reference

PageSetup Class
PageSetup Members


FooterMargin Property

FooterMargin Property
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : FooterMargin Property
Returns or sets the distance in points from the bottom of the page to the footer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FooterMargin As System.Double
public System.double FooterMargin {get; set;}

Property Value

Short. The default value is 36.
Remarks
The value MUST be greater than or equal to 0 and less than 3528.
Example
  • C#
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
  • Visual Basic
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With
See Also

Reference

PageSetup Class
PageSetup Members


HeaderMargin Property

HeaderMargin Property
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : HeaderMargin Property
Returns or sets the distance in points from the top of the page to the header.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HeaderMargin As System.Double
public System.double HeaderMargin {get; set;}

Property Value

Short. The default value is 36.
Remarks
The value MUST be greater than or equal to 0 and less than 3528.
Example
  • C#
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
  • Visual Basic
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With
See Also

Reference

PageSetup Class
PageSetup Members


LeftMargin Property (PageSetup)

LeftMargin Property (PageSetup)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : LeftMargin Property
Sets or returns the left margin value in points.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LeftMargin As System.Double
public System.double LeftMargin {get; set;}

Property Value

Double. The default value is 54.
Remarks
The value MUST be greater than or equal to 0 and less than 3528.
Example
  • C#
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
  • Visual Basic
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With
See Also

Reference

PageSetup Class
PageSetup Members


Order Property

Order Property
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : Order Property
Returns or sets the order in which pages are numbered when printing a large worksheet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Order As PagePrintOrder
public PagePrintOrder Order {get; set;}

Property Value

PagePrintOrder enumeration.

The default value is GrapeCity.SpreadBuilder.Printing.PagePrintOrder.DownThenOver

Example
  • C#
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
  • Visual Basic
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With
See Also

Reference

PageSetup Class
PageSetup Members


Orientation Property (PageSetup)

Orientation Property (PageSetup)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : Orientation Property
Sets or returns a value indicating whether pages are printed in landscape or portrait.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Orientation As PagePrintOrientation
public PagePrintOrientation Orientation {get; set;}

Property Value

PagePrintOrientation enumeration.
Example
  • C#
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
  • Visual Basic
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With
See Also

Reference

PageSetup Class
PageSetup Members


PaperSize Property (PageSetup)

PaperSize Property (PageSetup)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : PaperSize Property
Sets or returns the size of the paper to use.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaperSize As System.Drawing.Printing.PaperKind
public System.Drawing.Printing.PaperKind PaperSize {get; set;}

Property Value

Printing.PaperKind enumeration. The default value is Letter.
Remarks
Custom paper size is not fully implemented at this time.
Example
  • C#
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
  • Visual Basic
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With
See Also

Reference

PageSetup Class
PageSetup Members


PrintNotes Property

PrintNotes Property
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : PrintNotes Property
Sets or returns a value indicating whether cell notes are printed as end notes with the sheet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrintNotes As System.Boolean
public System.bool PrintNotes {get; set;}

Property Value

Boolean. The default value is False.
Example
  • C#
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
  • Visual Basic
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With
See Also

Reference

PageSetup Class
PageSetup Members


RightMargin Property (PageSetup)

RightMargin Property (PageSetup)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : RightMargin Property
Sets or returns the right margin value in points.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RightMargin As System.Double
public System.double RightMargin {get; set;}

Property Value

Double. The default value is 54.
Remarks
The value MUST be greater than or equal to 0 and less than 3528.
Example
  • C#
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
  • Visual Basic
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With
See Also

Reference

PageSetup Class
PageSetup Members


TopMargin Property (PageSetup)

TopMargin Property (PageSetup)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : TopMargin Property
Sets or returns the top margin value in points.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TopMargin As System.Double
public System.double TopMargin {get; set;}

Property Value

Double. The default value is 72.
Remarks
The value MUST be greater than or equal to 0 and less than 3528.
Example
  • C#
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
  • Visual Basic
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With
See Also

Reference

PageSetup Class
PageSetup Members


Zoom Property (PageSetup)

Zoom Property (PageSetup)
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : Zoom Property
Sets or returns the zoom value at which to print the spreadsheet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Zoom As System.Short
public System.short Zoom {get; set;}

Property Value

Short. The default value is 100%.
Example
  • C#
sb.Sheets[0].PageSetup.BlackAndWhite = true;
sb.Sheets[0].PageSetup.BottomMargin = 144;
sb.Sheets[0].PageSetup.Draft = true;
sb.Sheets[0].PageSetup.FirstPageNumber = 100;
sb.Sheets[0].PageSetup.FooterMargin = 72;
sb.Sheets[0].PageSetup.HeaderMargin = 72;
sb.Sheets[0].PageSetup.LeftMargin = 108;
sb.Sheets[0].PageSetup.Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown;
sb.Sheets[0].PageSetup.Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape;
sb.Sheets[0].PageSetup.PaperSize = Printing.PaperKind.A4;
sb.Sheets[0].PageSetup.PrintNotes = true;
sb.Sheets[0].PageSetup.RightMargin = 108;
sb.Sheets[0].PageSetup.TopMargin = 144;
sb.Sheets[0].PageSetup.Zoom = 200;
  • Visual Basic
With sb.Sheets(0).PageSetup
    .BlackAndWhite = True
    .BottomMargin = 144
    .Draft = True
    .FirstPageNumber = 100
    .FooterMargin = 72
    .HeaderMargin = 72
    .LeftMargin = 108
    .Order = GrapeCity.SpreadBuilder.Printing.PagePrintOrder.OverThenDown
    .Orientation = GrapeCity.SpreadBuilder.Printing.PagePrintOrientation.Landscape
    .PaperSize = Printing.PaperKind.A4
    .PrintNotes = True
    .RightMargin = 108
    .TopMargin = 144
    .Zoom = 200
End With
See Also

Reference

PageSetup Class
PageSetup Members


PageSetup Class Fields

PageSetup Class Fields

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Printing Namespace : PageSetup Class

For a list of all members of this type, see PageSetup members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | FirstPageNumberAuto | Use this value with PageSetup.FirstPageNumber to specify that the first page number used should be determined automatically.
Top
See Also

Reference

PageSetup Class
GrapeCity.SpreadBuilder.Printing Namespace


FirstPageNumberAuto Field

FirstPageNumberAuto Field

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Printing Namespace > PageSetup Class : FirstPageNumberAuto Field
Use this value with PageSetup.FirstPageNumber to specify that the first page number used should be determined automatically.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly FirstPageNumberAuto As System.Short
public static readonly System.short FirstPageNumberAuto
See Also

Reference

PageSetup Class
PageSetup Members


PagePrintOrder Enumeration

PagePrintOrder Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Printing Namespace : PagePrintOrder Enumeration
Used with the PageSetup.Order property to set the order in which pages are numbered when printing a large worksheet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PagePrintOrder
   Inherits System.Enum
public enum PagePrintOrder : System.Enum
Members
Member | Description
DownThenOver | For spreadsheets that are wider and longer than a single page, Excel will print the left side of the spreadsheet from top to bottom, and then go over to the right and print the right side of the spreadsheet from top to bottom.
OverThenDown | For spreadsheets that are wider and longer than a single page, Excel will print the top page of the spreadsheet from left to right, and then go down to the next page and print that part of the spreadsheet from left to right.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Printing.PagePrintOrder

See Also

Reference

GrapeCity.SpreadBuilder.Printing Namespace


PagePrintOrientation Enumeration

PagePrintOrientation Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Printing Namespace : PagePrintOrientation Enumeration
Used with PageSetup.Orientation to set pages to be printed in landscape or portrait.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PagePrintOrientation
   Inherits System.Enum
public enum PagePrintOrientation : System.Enum
Members
Member | Description
Landscape | Prints in landscape orientation.
Portrait | Prints in portrait orientation.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Printing.PagePrintOrientation

See Also

Reference

GrapeCity.SpreadBuilder.Printing Namespace


GrapeCity.SpreadBuilder.Style Namespace

GrapeCity.SpreadBuilder.Style Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Excel.v10 Assembly : GrapeCity.SpreadBuilder.Style Namespace
The GrapeCity.SpreadBuilder.Style namespace contains various style enumerations.
Enumerations
 | Enumeration | Description
Enumeration | BorderDiagonalStyles | Used with DDCell's BorderDiagonalEnum property to determine whether a diagonal border goes up or down, or both (which forms an "X" across the cell).
Enumeration | BorderLineStyle | Used to set the border line styles for DDCell's borders (i.e. BorderTopStyle, BorderBottomStyle, etc.).
Enumeration | FontUnderlineStyles | Used with the DDCell.FontUnderlineStyle property to set the underline style for the cell.
Enumeration | HorzAlignments | Used with the DDCell.Alignment property to set the the horizontal alignment value for the cell.
Enumeration | VertAlignments | Used with the DDCell.VertAlignment property to set the vertical alignment value for the cell.
See Also

Reference

GrapeCity.ActiveReports.Export.Excel.v10 Assembly


BorderDiagonalStyles Enumeration

BorderDiagonalStyles Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Style Namespace : BorderDiagonalStyles Enumeration
Used with DDCell's BorderDiagonalEnum property to determine whether a diagonal border goes up or down, or both (which forms an "X" across the cell).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum BorderDiagonalStyles
   Inherits System.Enum
public enum BorderDiagonalStyles : System.Enum
Members
Member | Description
Both | One diagonal border starts in the bottom left corner and goes to the upper right corner, and a second one starts in the upper left corner and goes to the bottom right corner, forming an X.
Down | The diagonal border starts in the upper left corner, and goes down to the lower right corner.
None | No diagonal border will be drawn.
Up | The diagonal border starts in the bottom left corner, and goes up to the upper right corner.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Style.BorderDiagonalStyles

See Also

Reference

GrapeCity.SpreadBuilder.Style Namespace


BorderLineStyle Enumeration

BorderLineStyle Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Style Namespace : BorderLineStyle Enumeration
Used to set the border line styles for DDCell's borders (i.e. BorderTopStyle, BorderBottomStyle, etc.).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum BorderLineStyle
   Inherits System.Enum
public enum BorderLineStyle : System.Enum
Members
Member | Description
DashDot | Renders a line of alternating dashes and dots.
DashDotDot | Renders a line of alternating dashes and pairs of dots.
Dashed | Renders a dashed line.
Dotted | Renders a dotted line.
Double | Renders two parallel lines.
Hair | Renders a very thin line.
Medium | Renders a medium-weight line.
MediumDashDot | Renders a medium-weight line of alternating dashes and dots.
MediumDashDotDot | Renders a medium-weight line of alternating dashes and pairs of dots.
MediumDashed | Renders a medium-weight dashed line.
None | Renders no line.
SlantedDashDot | Renders a line of slanted alternating dashes and dots.
Thick | Renders a thick line.
Thin | Renders a thin line.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Style.BorderLineStyle

See Also

Reference

GrapeCity.SpreadBuilder.Style Namespace


FontUnderlineStyles Enumeration

FontUnderlineStyles Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Style Namespace : FontUnderlineStyles Enumeration
Used with the DDCell.FontUnderlineStyle property to set the underline style for the cell.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum FontUnderlineStyles
   Inherits System.Enum
public enum FontUnderlineStyles : System.Enum
Members
Member | Description
Double | Double underline.
DoubleAcc | Double accounting underline.
None | No underline.
Single | Single underline.
SingleAcc | Single accounting underline.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Style.FontUnderlineStyles

See Also

Reference

GrapeCity.SpreadBuilder.Style Namespace


HorzAlignments Enumeration

HorzAlignments Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Style Namespace : HorzAlignments Enumeration
Used with the DDCell.Alignment property to set the the horizontal alignment value for the cell.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum HorzAlignments
   Inherits System.Enum
public enum HorzAlignments : System.Enum
Members
Member | Description
Center | Centers the text horizontally across the cell.
CenterAcrossSelection | Centers the text horizontally across the selected cells.
Fill | Repeats the text to fill the width of the cell.
General | This is the default value. Numbers are aligned to the right of the cell; letters are aligned to the left.
Justify | Horizontally justifies text that is distributed in a cell (indented from both sides).
Left | Aligns text to the left of the cell.
Right | Aligns text to the right of the cell.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Style.HorzAlignments

See Also

Reference

GrapeCity.SpreadBuilder.Style Namespace


VertAlignments Enumeration

VertAlignments Enumeration

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Style Namespace : VertAlignments Enumeration
Used with the DDCell.VertAlignment property to set the vertical alignment value for the cell.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum VertAlignments
   Inherits System.Enum
public enum VertAlignments : System.Enum
Members
Member | Description
Bottom | Aligns text to the bottom of the cell.
Center | Centers text vertically in the cell.
Justify | Justifies text vertically in the cell.
Top | Aligns text to the top of the cell.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.SpreadBuilder.Style.VertAlignments

See Also

Reference

GrapeCity.SpreadBuilder.Style Namespace


GrapeCity.ActiveReports.Export.Html.Page Namespace

GrapeCity.ActiveReports.Export.Html.Page Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Html.v10 Assembly : GrapeCity.ActiveReports.Export.Html.Page Namespace
The GrapeCity.ActiveReports.Export.Html.Page namespace contains the information related to HTML rendering extensions and settings.
Classes
 | Class | Description
Class | EmailRenderingExtension | Rendering extension responsible for rendering report to HTML format suitable for email.
Class | HtmlRenderingExtension | Rendering extension responsible for rendering report to HTML format.
Class | Settings | Settings for the Html rendering extension.
Interfaces
 | Interface | Description
Interface | IHtmlRenderingExtensionContext | Specifies a context for the HtmlRenderingExtension class to share data among the control renderers.
Interface | ILinkProvider | Interface for creating a custom link provider for the html rendering extension.
Enumerations
 | Enumeration | Description
Enumeration | RenderMode | Specifies the HTML rendering mode.
See Also

Reference

GrapeCity.ActiveReports.Export.Html.v10 Assembly


EmailRenderingExtension Class

EmailRenderingExtension Class
Members

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace : EmailRenderingExtension Class
Rendering extension responsible for rendering report to HTML format suitable for email.
Object Model
EmailRenderingExtension Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class EmailRenderingExtension
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension
public sealed class EmailRenderingExtension : GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Html.Page.EmailRenderingExtension

See Also

Reference

EmailRenderingExtension Members
GrapeCity.ActiveReports.Export.Html.Page Namespace


EmailRenderingExtension Class Members

EmailRenderingExtension Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace : EmailRenderingExtension Class

The following tables list the members exposed by EmailRenderingExtension.

Public Constructors
 | Name | Description
Public Constructor | EmailRenderingExtension Constructor | Initializes a new instance of the EmailRenderingExtension class.
Top
Public Properties
 | Name | Description
Public Property | MailMessage | Gets the MailMessage object.
Top
Public Methods
 | Name | Description
Public Method | Dispose | Implements the Dispose logic of the EmailRenderingExtension Class.
Public Method | GetSupportedSettings | Overloaded. Returns the settings for the EmailRenderingExtension Class.
Top
See Also

Reference

EmailRenderingExtension Class
GrapeCity.ActiveReports.Export.Html.Page Namespace


EmailRenderingExtension Constructor

EmailRenderingExtension Constructor

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > EmailRenderingExtension Class : EmailRenderingExtension Constructor
Initializes a new instance of the EmailRenderingExtension class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public EmailRenderingExtension()
See Also

Reference

EmailRenderingExtension Class
EmailRenderingExtension Members


EmailRenderingExtension Class Methods

EmailRenderingExtension Class Methods

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace : EmailRenderingExtension Class

For a list of all members of this type, see EmailRenderingExtension members.

Public Methods
 | Name | Description
Public Method | Dispose | Implements the Dispose logic of the EmailRenderingExtension Class.
Public Method | GetSupportedSettings | Overloaded. Returns the settings for the EmailRenderingExtension Class.
Top
See Also

Reference

EmailRenderingExtension Class
GrapeCity.ActiveReports.Export.Html.Page Namespace


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > EmailRenderingExtension Class : Dispose() Method
Implements the Dispose logic of the EmailRenderingExtension Class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

EmailRenderingExtension Class
EmailRenderingExtension Members


GetSupportedSettings Method (EmailRenderingExtension)

GetSupportedSettings Method (EmailRenderingExtension)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > EmailRenderingExtension Class : GetSupportedSettings Method
Returns the settings for the EmailRenderingExtension Class.
Overload List
Overload | Description
GetSupportedSettings() | Returns settings of current EmailRenderingExtension instance.
GetSupportedSettings(Boolean) | Returns settings of current EmailRenderingExtension instance.
See Also

Reference

EmailRenderingExtension Class
EmailRenderingExtension Members


GetSupportedSettings() Method

GetSupportedSettings() Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > EmailRenderingExtension Class > GetSupportedSettings Method : GetSupportedSettings() Method
Returns settings of current EmailRenderingExtension instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetSupportedSettings() As ISettings
public ISettings GetSupportedSettings()
See Also

Reference

EmailRenderingExtension Class
EmailRenderingExtension Members
Overload List


GetSupportedSettings(Boolean) Method

GetSupportedSettings(Boolean) Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > EmailRenderingExtension Class > GetSupportedSettings Method : GetSupportedSettings(Boolean) Method
Returns the Email rendering settings.
Returns settings of current EmailRenderingExtension instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetSupportedSettings( _
   ByVal fpl As System.Boolean _
) As ISettings
public ISettings GetSupportedSettings(
   System.bool fpl
)

Parameters

fpl
Returns the Email rendering settings.
See Also

Reference

EmailRenderingExtension Class
EmailRenderingExtension Members
Overload List


EmailRenderingExtension Class Properties

EmailRenderingExtension Class Properties

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace : EmailRenderingExtension Class

For a list of all members of this type, see EmailRenderingExtension members.

Public Properties
 | Name | Description
Public Property | MailMessage | Gets the MailMessage object.
Top
See Also

Reference

EmailRenderingExtension Class
GrapeCity.ActiveReports.Export.Html.Page Namespace


MailMessage Property

MailMessage Property

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > EmailRenderingExtension Class : MailMessage Property
Gets the MailMessage object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MailMessage As System.Net.Mail.MailMessage
public System.Net.Mail.MailMessage MailMessage {get;}
See Also

Reference

EmailRenderingExtension Class
EmailRenderingExtension Members


HtmlRenderingExtension Class

HtmlRenderingExtension Class
Members

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace : HtmlRenderingExtension Class
Rendering extension responsible for rendering report to HTML format.
Object Model
HtmlRenderingExtension Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class HtmlRenderingExtension
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtensionInternal
public sealed class HtmlRenderingExtension : GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtensionInternal
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Html.Page.HtmlRenderingExtension

See Also

Reference

HtmlRenderingExtension Members
GrapeCity.ActiveReports.Export.Html.Page Namespace


HtmlRenderingExtension Class Members

HtmlRenderingExtension Class Members
Methods

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace : HtmlRenderingExtension Class

The following tables list the members exposed by HtmlRenderingExtension.

Public Constructors
 | Name | Description
Public Constructor | HtmlRenderingExtension Constructor | Initializes a new instance of the HtmlRenderingExtension class.
Top
Public Methods
 | Name | Description
Public Method | Dispose | Implements the dispose logic of HtmlRenderingExtension class.
Public Method | GetSupportedSettings | Overloaded. Returns the settings for the HtmlRenderingExtension class.
Top
See Also

Reference

HtmlRenderingExtension Class
GrapeCity.ActiveReports.Export.Html.Page Namespace


HtmlRenderingExtension Constructor

HtmlRenderingExtension Constructor

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > HtmlRenderingExtension Class : HtmlRenderingExtension Constructor
Initializes a new instance of the HtmlRenderingExtension class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public HtmlRenderingExtension()
See Also

Reference

HtmlRenderingExtension Class
HtmlRenderingExtension Members


HtmlRenderingExtension Class Methods

HtmlRenderingExtension Class Methods

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace : HtmlRenderingExtension Class

For a list of all members of this type, see HtmlRenderingExtension members.

Public Methods
 | Name | Description
Public Method | Dispose | Implements the dispose logic of HtmlRenderingExtension class.
Public Method | GetSupportedSettings | Overloaded. Returns the settings for the HtmlRenderingExtension class.
Top
See Also

Reference

HtmlRenderingExtension Class
GrapeCity.ActiveReports.Export.Html.Page Namespace


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > HtmlRenderingExtension Class : Dispose() Method
Implements the dispose logic of HtmlRenderingExtension class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

HtmlRenderingExtension Class
HtmlRenderingExtension Members


GetSupportedSettings Method (HtmlRenderingExtension)

GetSupportedSettings Method (HtmlRenderingExtension)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > HtmlRenderingExtension Class : GetSupportedSettings Method
Returns the settings for the HtmlRenderingExtension class.
Overload List
Overload | Description
GetSupportedSettings() | Returns settings of current HtmlRenderingExtension instance.
GetSupportedSettings(Boolean) | Returns settings of current HtmlRenderingExtension instance.
See Also

Reference

HtmlRenderingExtension Class
HtmlRenderingExtension Members


GetSupportedSettings() Method

GetSupportedSettings() Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > HtmlRenderingExtension Class > GetSupportedSettings Method : GetSupportedSettings() Method
Returns settings of current HtmlRenderingExtension instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetSupportedSettings() As ISettings
public ISettings GetSupportedSettings()
See Also

Reference

HtmlRenderingExtension Class
HtmlRenderingExtension Members
Overload List


GetSupportedSettings(Boolean) Method

GetSupportedSettings(Boolean) Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > HtmlRenderingExtension Class > GetSupportedSettings Method : GetSupportedSettings(Boolean) Method
Returns the HTML rendering settings.
Returns settings of current HtmlRenderingExtension instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetSupportedSettings( _
   ByVal fpl As System.Boolean _
) As ISettings
public ISettings GetSupportedSettings(
   System.bool fpl
)

Parameters

fpl
Returns the HTML rendering settings.
See Also

Reference

HtmlRenderingExtension Class
HtmlRenderingExtension Members
Overload List


Settings Class

Settings Class
Members

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace : Settings Class
Settings for the Html rendering extension.
Object Model
Settings Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Settings
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
public sealed class Settings : GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Html.Page.Settings

See Also

Reference

Settings Members
GrapeCity.ActiveReports.Export.Html.Page Namespace


Settings Class Members

Settings Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace : Settings Class

The following tables list the members exposed by Settings.

Public Constructors
 | Name | Description
Public Constructor | Settings Constructor | Initializes a new instance of the Settings class.
Top
Public Properties
 | Name | Description
Public Property | Fragment | Determine whether or not the full html text will be returned or just the contents contained inside the body tag will be returned. True indicates only the content inside the body tag will be return; otherwise false. The default is false.
Public Property | JavaScript | Gets or sets whether or not JavaScript will be included in the html. True indicates JaveScript will be used; otherwise false. The default is true.
Public Property | LinkTarget | Gets or set the target for hyperlinks contained inside the report. By default this value is not set.
Public Property | MhtOutput | Gets or sets whether or not the output should be in Mht format. True indicates the output should be in Mht format; otherwise false. The default is false.
Public Property | Mode | Gets or sets the mode to use when rendering to html.
Public Property | OutputTOC | Indicates whether the report's existing TOC should be added in the output.
Public Property | StyleStream | Gets or sets whether or not the CSS style information will be contained inside the html file, or inside a different stream. True indicates the CSS style information will be contained in its own stream; otherwise false. The default is true.
Top
Public Methods
 | Name | Description
Public Method | ApplySettings | Applies the settings from the NameValueCollection
Top
See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Html.Page Namespace


Settings Constructor

Settings Constructor

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > Settings Class : Settings Constructor
Initializes a new instance of the Settings class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Settings()
See Also

Reference

Settings Class
Settings Members


Settings Class Methods

Settings Class Methods

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace : Settings Class

For a list of all members of this type, see Settings members.

Public Methods
 | Name | Description
Public Method | ApplySettings | Applies the settings from the NameValueCollection
Top
See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Html.Page Namespace


ApplySettings Method (Settings)

ApplySettings Method (Settings)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > Settings Class : ApplySettings Method
a System.Collections.Specialized.NameValueCollection containing the settings for the renderer.
Applies the settings from the NameValueCollection
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ApplySettings( _
   ByVal settings As System.Collections.Specialized.NameValueCollection _
)
public void ApplySettings(
   System.Collections.Specialized.NameValueCollection settings
)

Parameters

settings
a System.Collections.Specialized.NameValueCollection containing the settings for the renderer.
See Also

Reference

Settings Class
Settings Members


Settings Class Properties

Settings Class Properties

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace : Settings Class

For a list of all members of this type, see Settings members.

Public Properties
 | Name | Description
Public Property | Fragment | Determine whether or not the full html text will be returned or just the contents contained inside the body tag will be returned. True indicates only the content inside the body tag will be return; otherwise false. The default is false.
Public Property | JavaScript | Gets or sets whether or not JavaScript will be included in the html. True indicates JaveScript will be used; otherwise false. The default is true.
Public Property | LinkTarget | Gets or set the target for hyperlinks contained inside the report. By default this value is not set.
Public Property | MhtOutput | Gets or sets whether or not the output should be in Mht format. True indicates the output should be in Mht format; otherwise false. The default is false.
Public Property | Mode | Gets or sets the mode to use when rendering to html.
Public Property | OutputTOC | Indicates whether the report's existing TOC should be added in the output.
Public Property | StyleStream | Gets or sets whether or not the CSS style information will be contained inside the html file, or inside a different stream. True indicates the CSS style information will be contained in its own stream; otherwise false. The default is true.
Top
See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Html.Page Namespace


Fragment Property

Fragment Property

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > Settings Class : Fragment Property
Determine whether or not the full html text will be returned or just the contents contained inside the body tag will be returned. True indicates only the content inside the body tag will be return; otherwise false. The default is false.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Fragment As System.Boolean
public System.bool Fragment {get; set;}

Property Value

A boolean value indicating whether or not to return the full html contents, or just the contents inside the body tag.
See Also

Reference

Settings Class
Settings Members


JavaScript Property

JavaScript Property

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > Settings Class : JavaScript Property
Gets or sets whether or not JavaScript will be included in the html. True indicates JaveScript will be used; otherwise false. The default is true.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property JavaScript As System.Boolean
public System.bool JavaScript {get; set;}

Property Value

A boolean value indicating whether or not JavaScript will be used in the html
Remarks
Disabling JavaScript will prevent some features for working correctly.
See Also

Reference

Settings Class
Settings Members


LinkTarget Property

LinkTarget Property

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > Settings Class : LinkTarget Property
Gets or set the target for hyperlinks contained inside the report. By default this value is not set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LinkTarget As System.String
public System.string LinkTarget {get; set;}

Property Value

A string value representing the LinkTarget.
Remarks
You can target a window by specifying the window name, or specify to open the target in a new window by setting the value to _blank. Acceptable values are WindowName, _blank, _self, _parent, and _top.
See Also

Reference

Settings Class
Settings Members


MhtOutput Property

MhtOutput Property

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > Settings Class : MhtOutput Property
Gets or sets whether or not the output should be in Mht format. True indicates the output should be in Mht format; otherwise false. The default is false.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MhtOutput As System.Boolean
public System.bool MhtOutput {get; set;}

Property Value

A boolean value indicating whether or not the output should be in Mht format.
See Also

Reference

Settings Class
Settings Members


Mode Property (Settings)

Mode Property (Settings)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > Settings Class : Mode Property
Gets or sets the mode to use when rendering to html.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Mode As RenderMode
public RenderMode Mode {get; set;}

Property Value

RenderMode indicating the rendering mode to use.
See Also

Reference

Settings Class
Settings Members


OutputTOC Property

OutputTOC Property

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > Settings Class : OutputTOC Property
Indicates whether the report's existing TOC should be added in the output.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OutputTOC As System.Boolean
public System.bool OutputTOC {get; set;}
See Also

Reference

Settings Class
Settings Members


StyleStream Property

StyleStream Property

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > Settings Class : StyleStream Property
Gets or sets whether or not the CSS style information will be contained inside the html file, or inside a different stream. True indicates the CSS style information will be contained in its own stream; otherwise false. The default is true.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StyleStream As System.Boolean
public System.bool StyleStream {get; set;}

Property Value

A boolean value indicating whether or not to write the CSS style information to a different stream, or embed it in the html file.
Remarks
When this value is set to False the full report will be rendered before being returned.
See Also

Reference

Settings Class
Settings Members


RenderMode Enumeration

RenderMode Enumeration

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace : RenderMode Enumeration
Specifies the HTML rendering mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum RenderMode
   Inherits System.Enum
public enum RenderMode : System.Enum
Members
Member | Description
Galley | Indicates that the report will be rendered in HTML with one page header, one page footer (if they exist) and the report body will be rendered in one large section.
Paginated | Indicates that the report will be rendered in HTML with a page header and page footer for each page (if they exist) and the positions will be determined by the report's page height.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Html.Page.RenderMode

See Also

Reference

GrapeCity.ActiveReports.Export.Html.Page Namespace


IHtmlRenderingExtensionContext Interface

IHtmlRenderingExtensionContext Interface
Members

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace : IHtmlRenderingExtensionContext Interface
Specifies a context for the HtmlRenderingExtension class to share data among the control renderers.
Object Model
IHtmlRenderingExtensionContext Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IHtmlRenderingExtensionContext
public interface IHtmlRenderingExtensionContext
See Also

Reference

IHtmlRenderingExtensionContext Members
GrapeCity.ActiveReports.Export.Html.Page Namespace


IHtmlRenderingExtensionContext Interface Members

IHtmlRenderingExtensionContext Interface Members
Properties Methods

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace : IHtmlRenderingExtensionContext Interface

The following tables list the members exposed by IHtmlRenderingExtensionContext.

Public Properties
 | Name | Description
Property | BodyWriter | Gets a XHTMLWriter to use for the HTML body section.
Property | BookmarkDictionary | Returns a GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataDictionary containing the bookmarks for the report.
Property | Settings | Gets the GrapeCity.ActiveReports.Extensibility.Rendering.ISettings to use while rendering a report. This points back to the settings on the HtmlRenderingExtension class.
Top
Public Methods
 | Name | Description
Method | GetLPath | Gets a string representation of the provided GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea.
Top
See Also

Reference

IHtmlRenderingExtensionContext Interface
GrapeCity.ActiveReports.Export.Html.Page Namespace


IHtmlRenderingExtensionContext Interface Methods

IHtmlRenderingExtensionContext Interface Methods

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace : IHtmlRenderingExtensionContext Interface

For a list of all members of this type, see IHtmlRenderingExtensionContext members.

Public Methods
 | Name | Description
Method | GetLPath | Gets a string representation of the provided GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea.
Top
See Also

Reference

IHtmlRenderingExtensionContext Interface
GrapeCity.ActiveReports.Export.Html.Page Namespace


GetLPath Method

GetLPath Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > IHtmlRenderingExtensionContext Interface : GetLPath Method
The GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea to create the LPath for.
Gets a string representation of the provided GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetLPath( _
   ByVal layoutArea As ILayoutArea _
) As System.String
System.string GetLPath(
   ILayoutArea layoutArea
)

Parameters

layoutArea
The GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea to create the LPath for.

Return Value

A string value representing the path to the provided GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea.
See Also

Reference

IHtmlRenderingExtensionContext Interface
IHtmlRenderingExtensionContext Members


IHtmlRenderingExtensionContext Interface Properties

IHtmlRenderingExtensionContext Interface Properties

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace : IHtmlRenderingExtensionContext Interface

For a list of all members of this type, see IHtmlRenderingExtensionContext members.

Public Properties
 | Name | Description
Property | BodyWriter | Gets a XHTMLWriter to use for the HTML body section.
Property | BookmarkDictionary | Returns a GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataDictionary containing the bookmarks for the report.
Property | Settings | Gets the GrapeCity.ActiveReports.Extensibility.Rendering.ISettings to use while rendering a report. This points back to the settings on the HtmlRenderingExtension class.
Top
See Also

Reference

IHtmlRenderingExtensionContext Interface
GrapeCity.ActiveReports.Export.Html.Page Namespace


BodyWriter Property

BodyWriter Property

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > IHtmlRenderingExtensionContext Interface : BodyWriter Property
Gets a XHTMLWriter to use for the HTML body section.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property BodyWriter As XhtmlTextWriter
XhtmlTextWriter BodyWriter {get;}
Remarks
If the CSS style information should be embedded in the page this will return a XHTMLWriter created with a stand-alone stream. And if the CSS style information is in its own stream it will return a XHTMLWriter created from the primary stream of the stream provider.
See Also

Reference

IHtmlRenderingExtensionContext Interface
IHtmlRenderingExtensionContext Members


BookmarkDictionary Property

BookmarkDictionary Property

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > IHtmlRenderingExtensionContext Interface : BookmarkDictionary Property
Returns a GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataDictionary containing the bookmarks for the report.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property BookmarkDictionary As IMetadataDictionary
IMetadataDictionary BookmarkDictionary {get;}
See Also

Reference

IHtmlRenderingExtensionContext Interface
IHtmlRenderingExtensionContext Members


Settings Property (IHtmlRenderingExtensionContext)

Settings Property (IHtmlRenderingExtensionContext)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > IHtmlRenderingExtensionContext Interface : Settings Property
Gets the GrapeCity.ActiveReports.Extensibility.Rendering.ISettings to use while rendering a report. This points back to the settings on the HtmlRenderingExtension class.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Settings As ISettings
ISettings Settings {get;}
See Also

Reference

IHtmlRenderingExtensionContext Interface
IHtmlRenderingExtensionContext Members


ILinkProvider Interface

ILinkProvider Interface
Members

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace : ILinkProvider Interface
Interface for creating a custom link provider for the html rendering extension.
Object Model
ILinkProvider Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ILinkProvider
public interface ILinkProvider
See Also

Reference

ILinkProvider Members
GrapeCity.ActiveReports.Export.Html.Page Namespace


ILinkProvider Interface Members

ILinkProvider Interface Members
Methods

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace : ILinkProvider Interface

The following tables list the members exposed by ILinkProvider.

Public Methods
 | Name | Description
Method | BookmarkLink | Returns a string value to use as a Document Map link.
Method | BookmarkLinkTarget | Returns as string value to use as a bookmark link target.
Method | DocumentMapLink | Returns a string value to use as a Document map link.
Method | DocumentMapTarget | Returns as string value to use as a Document map target.
Method | DrillthroughLink | Returns a string value to use as a Drillthrough link.
Method | FindLink | Returns a string value to use as a link for a match target
Method | Hyperlink | Returns a string value to use as a hyperlink.
Method | SortingToggleImageLink | Returns a string value to use as a link for sorting toggle image.
Method | SortingToggleLink | Returns a string value to use as a link for sorting toggle.
Method | VisibilityToggleImageLink | Returns a string value to use as a link for visibility toggle image.
Method | VisibilityToggleLink | Returns a string value to use as a link for visibility toggle.
Top
See Also

Reference

ILinkProvider Interface
GrapeCity.ActiveReports.Export.Html.Page Namespace


ILinkProvider Interface Methods

ILinkProvider Interface Methods

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace : ILinkProvider Interface

For a list of all members of this type, see ILinkProvider members.

Public Methods
 | Name | Description
Method | BookmarkLink | Returns a string value to use as a Document Map link.
Method | BookmarkLinkTarget | Returns as string value to use as a bookmark link target.
Method | DocumentMapLink | Returns a string value to use as a Document map link.
Method | DocumentMapTarget | Returns as string value to use as a Document map target.
Method | DrillthroughLink | Returns a string value to use as a Drillthrough link.
Method | FindLink | Returns a string value to use as a link for a match target
Method | Hyperlink | Returns a string value to use as a hyperlink.
Method | SortingToggleImageLink | Returns a string value to use as a link for sorting toggle image.
Method | SortingToggleLink | Returns a string value to use as a link for sorting toggle.
Method | VisibilityToggleImageLink | Returns a string value to use as a link for visibility toggle image.
Method | VisibilityToggleLink | Returns a string value to use as a link for visibility toggle.
Top
See Also

Reference

ILinkProvider Interface
GrapeCity.ActiveReports.Export.Html.Page Namespace


BookmarkLink Method

BookmarkLink Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > ILinkProvider Interface : BookmarkLink Method
The GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataDictionaryEntry for the bookmark link entry to create a link for.
The GrapeCity.ActiveReports.Export.Html.Page.IHtmlRenderingExtensionContext containing the shared information for rendering.
Returns a string value to use as a Document Map link.
Syntax
  • Visual Basic
  • C#
'Declaration

Function BookmarkLink( _
   ByVal dictionaryEntry As IMetadataDictionaryEntry, _
   ByVal context As IHtmlRenderingExtensionContext _
) As System.String
System.string BookmarkLink(
   IMetadataDictionaryEntry dictionaryEntry,
   IHtmlRenderingExtensionContext context
)

Parameters

dictionaryEntry
The GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataDictionaryEntry for the bookmark link entry to create a link for.
context
The GrapeCity.ActiveReports.Export.Html.Page.IHtmlRenderingExtensionContext containing the shared information for rendering.

Return Value

String value to use as the href value.
See Also

Reference

ILinkProvider Interface
ILinkProvider Members


BookmarkLinkTarget Method

BookmarkLinkTarget Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > ILinkProvider Interface : BookmarkLinkTarget Method
A string value representing the base name for the bookmark link target.
The GrapeCity.ActiveReports.Export.Html.Page.IHtmlRenderingExtensionContext containing the shared information for rendering
Returns as string value to use as a bookmark link target.
Syntax
  • Visual Basic
  • C#
'Declaration

Function BookmarkLinkTarget( _
   ByVal targetName As System.String, _
   ByVal context As IHtmlRenderingExtensionContext _
) As System.String
System.string BookmarkLinkTarget(
   System.string targetName,
   IHtmlRenderingExtensionContext context
)

Parameters

targetName
A string value representing the base name for the bookmark link target.
context
The GrapeCity.ActiveReports.Export.Html.Page.IHtmlRenderingExtensionContext containing the shared information for rendering

Return Value

string value to use as the href value's target
See Also

Reference

ILinkProvider Interface
ILinkProvider Members


DocumentMapLink Method

DocumentMapLink Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > ILinkProvider Interface : DocumentMapLink Method
The GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataDictionaryEntry for the document map node to create a link for.
The GrapeCity.ActiveReports.Export.Html.Page.IHtmlRenderingExtensionContext containing the shared information for rendering.
Returns a string value to use as a Document map link.
Syntax
  • Visual Basic
  • C#
'Declaration

Function DocumentMapLink( _
   ByVal dictionaryEntry As IMetadataDictionaryEntry, _
   ByVal context As IHtmlRenderingExtensionContext _
) As System.String
System.string DocumentMapLink(
   IMetadataDictionaryEntry dictionaryEntry,
   IHtmlRenderingExtensionContext context
)

Parameters

dictionaryEntry
The GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataDictionaryEntry for the document map node to create a link for.
context
The GrapeCity.ActiveReports.Export.Html.Page.IHtmlRenderingExtensionContext containing the shared information for rendering.

Return Value

String value to use as the href value.
See Also

Reference

ILinkProvider Interface
ILinkProvider Members


DocumentMapTarget Method

DocumentMapTarget Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > ILinkProvider Interface : DocumentMapTarget Method
A string value representing the base name for the document map target.
The GrapeCity.ActiveReports.Export.Html.Page.IHtmlRenderingExtensionContext containing the shared information for rendering.
Returns as string value to use as a Document map target.
Syntax
  • Visual Basic
  • C#
'Declaration

Function DocumentMapTarget( _
   ByVal targetName As System.String, _
   ByVal context As IHtmlRenderingExtensionContext _
) As System.String
System.string DocumentMapTarget(
   System.string targetName,
   IHtmlRenderingExtensionContext context
)

Parameters

targetName
A string value representing the base name for the document map target.
context
The GrapeCity.ActiveReports.Export.Html.Page.IHtmlRenderingExtensionContext containing the shared information for rendering.

Return Value

String value to use as the href value's target.
See Also

Reference

ILinkProvider Interface
ILinkProvider Members


DrillthroughLink Method

DrillthroughLink Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > ILinkProvider Interface : DrillthroughLink Method
The GrapeCity.ActiveReports.Extensibility.Rendering.Components.IAction to get the Drillthrough link value from.
The GrapeCity.ActiveReports.Export.Html.Page.IHtmlRenderingExtensionContext containing the shared information for rendering.
Returns a string value to use as a Drillthrough link.
Syntax
  • Visual Basic
  • C#
'Declaration

Function DrillthroughLink( _
   ByVal action As IAction, _
   ByVal context As IHtmlRenderingExtensionContext _
) As System.String
System.string DrillthroughLink(
   IAction action,
   IHtmlRenderingExtensionContext context
)

Parameters

action
The GrapeCity.ActiveReports.Extensibility.Rendering.Components.IAction to get the Drillthrough link value from.
context
The GrapeCity.ActiveReports.Export.Html.Page.IHtmlRenderingExtensionContext containing the shared information for rendering.

Return Value

String value to use as the href value
See Also

Reference

ILinkProvider Interface
ILinkProvider Members


FindLink Method

FindLink Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > ILinkProvider Interface : FindLink Method
The GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea for the item the found string.
The GrapeCity.ActiveReports.Export.Html.Page.IHtmlRenderingExtensionContext used to pass information.
The string searched for.
Returns a string value to use as a link for a match target
Syntax
  • Visual Basic
  • C#
'Declaration

Function FindLink( _
   ByVal layoutArea As ILayoutArea, _
   ByVal context As IHtmlRenderingExtensionContext, _
   ByVal searchString As System.String _
) As System.String
System.string FindLink(
   ILayoutArea layoutArea,
   IHtmlRenderingExtensionContext context,
   System.string searchString
)

Parameters

layoutArea
The GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea for the item the found string.
context
The GrapeCity.ActiveReports.Export.Html.Page.IHtmlRenderingExtensionContext used to pass information.
searchString
The string searched for.

Return Value

A string value use to navigate to a found search item.
See Also

Reference

ILinkProvider Interface
ILinkProvider Members


Hyperlink Method

Hyperlink Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > ILinkProvider Interface : Hyperlink Method
The GrapeCity.ActiveReports.Extensibility.Rendering.Components.IAction to get the hyperlink value from.
The GrapeCity.ActiveReports.Export.Html.Page.IHtmlRenderingExtensionContext containing the shared information for rendering.
Returns a string value to use as a hyperlink.
Syntax
  • Visual Basic
  • C#
'Declaration

Function Hyperlink( _
   ByVal action As IAction, _
   ByVal context As IHtmlRenderingExtensionContext _
) As System.String
System.string Hyperlink(
   IAction action,
   IHtmlRenderingExtensionContext context
)

Parameters

action
The GrapeCity.ActiveReports.Extensibility.Rendering.Components.IAction to get the hyperlink value from.
context
The GrapeCity.ActiveReports.Export.Html.Page.IHtmlRenderingExtensionContext containing the shared information for rendering.

Return Value

String value to use as the href value
See Also

Reference

ILinkProvider Interface
ILinkProvider Members


SortingToggleImageLink Method

SortingToggleImageLink Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > ILinkProvider Interface : SortingToggleImageLink Method
The GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea for the item that can be toggled.
the GrapeCity.ActiveReports.Export.Html.Page.IHtmlRenderingExtensionContext used to pass information.
Returns a string value to use as a link for sorting toggle image.
Syntax
  • Visual Basic
  • C#
'Declaration

Function SortingToggleImageLink( _
   ByVal layoutArea As ILayoutArea, _
   ByVal context As IHtmlRenderingExtensionContext _
) As System.String
System.string SortingToggleImageLink(
   ILayoutArea layoutArea,
   IHtmlRenderingExtensionContext context
)

Parameters

layoutArea
The GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea for the item that can be toggled.
context
the GrapeCity.ActiveReports.Export.Html.Page.IHtmlRenderingExtensionContext used to pass information.

Return Value

String value to use as the src value
See Also

Reference

ILinkProvider Interface
ILinkProvider Members


SortingToggleLink Method

SortingToggleLink Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > ILinkProvider Interface : SortingToggleLink Method
The GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea for the item that can be toggled.
The GrapeCity.ActiveReports.Export.Html.Page.IHtmlRenderingExtensionContext used to pass information.
Returns a string value to use as a link for sorting toggle.
Syntax
  • Visual Basic
  • C#
'Declaration

Function SortingToggleLink( _
   ByVal layoutArea As ILayoutArea, _
   ByVal context As IHtmlRenderingExtensionContext _
) As System.String
System.string SortingToggleLink(
   ILayoutArea layoutArea,
   IHtmlRenderingExtensionContext context
)

Parameters

layoutArea
The GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea for the item that can be toggled.
context
The GrapeCity.ActiveReports.Export.Html.Page.IHtmlRenderingExtensionContext used to pass information.

Return Value

String value to use as the href value
See Also

Reference

ILinkProvider Interface
ILinkProvider Members


VisibilityToggleImageLink Method

VisibilityToggleImageLink Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > ILinkProvider Interface : VisibilityToggleImageLink Method
The GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea for the item that can be toggled.
the GrapeCity.ActiveReports.Export.Html.Page.IHtmlRenderingExtensionContext used to pass information.
Returns a string value to use as a link for visibility toggle image.
Syntax
  • Visual Basic
  • C#
'Declaration

Function VisibilityToggleImageLink( _
   ByVal layoutArea As ILayoutArea, _
   ByVal context As IHtmlRenderingExtensionContext _
) As System.String
System.string VisibilityToggleImageLink(
   ILayoutArea layoutArea,
   IHtmlRenderingExtensionContext context
)

Parameters

layoutArea
The GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea for the item that can be toggled.
context
the GrapeCity.ActiveReports.Export.Html.Page.IHtmlRenderingExtensionContext used to pass information.

Return Value

String value to use as the src value
See Also

Reference

ILinkProvider Interface
ILinkProvider Members


VisibilityToggleLink Method

VisibilityToggleLink Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > ILinkProvider Interface : VisibilityToggleLink Method
The GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea for the item that can be toggled.
The GrapeCity.ActiveReports.Export.Html.Page.IHtmlRenderingExtensionContext used to pass information.
Returns a string value to use as a link for visibility toggle.
Syntax
  • Visual Basic
  • C#
'Declaration

Function VisibilityToggleLink( _
   ByVal layoutArea As ILayoutArea, _
   ByVal context As IHtmlRenderingExtensionContext _
) As System.String
System.string VisibilityToggleLink(
   ILayoutArea layoutArea,
   IHtmlRenderingExtensionContext context
)

Parameters

layoutArea
The GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea for the item that can be toggled.
context
The GrapeCity.ActiveReports.Export.Html.Page.IHtmlRenderingExtensionContext used to pass information.

Return Value

String value to use as the href value.
See Also

Reference

ILinkProvider Interface
ILinkProvider Members


GrapeCity.ActiveReports.Export.Html.Section Namespace

GrapeCity.ActiveReports.Export.Html.Section Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Html.v10 Assembly : GrapeCity.ActiveReports.Export.Html.Section Namespace
The GrapeCity.ActiveReports.Export.Html.Section namespace contains the Html export component.
Classes
 | Class | Description
Class | HtmlExport | Provides HTML creation functionality for ActiveReports documents.
Class | HtmlExportException | The exception that is thrown when an error occurs in the ActiveReports HTML export assembly.
Class | OutputHtmlFiles | OutputHtmlFiles is an implementation of the IHandleHtmlOutput interface that directs the HtmlExport object's output to files.
Enumerations
 | Enumeration | Description
Enumeration | BookmarkStyle | An enumeration of values for the HtmlExport.BookmarkStyle property.
Enumeration | HtmlCharacterSet | An enumeration of values for the HtmlExport.CharacterSet property.
Enumeration | HtmlOutputType | An enumeration of values for the HtmlExport.OutputType property.
See Also

Reference

GrapeCity.ActiveReports.Export.Html.v10 Assembly


HtmlExport Class

HtmlExport Class
Members

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace : HtmlExport Class
Provides HTML creation functionality for ActiveReports documents.
Object Model
HtmlExport Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class HtmlExport
   Inherits System.ComponentModel.Component
   Implements GrapeCity.ActiveReports.Export.IDocumentExport, GrapeCity.ActiveReports.Export.IDocumentExportEx
public sealed class HtmlExport : System.ComponentModel.Component, GrapeCity.ActiveReports.Export.IDocumentExport, GrapeCity.ActiveReports.Export.IDocumentExportEx
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Export.Html.Section.HtmlExport

See Also

Reference

HtmlExport Members
GrapeCity.ActiveReports.Export.Html.Section Namespace

Walkthroughs

Custom HTML Outputter


HtmlExport Class Members

HtmlExport Class Members
Properties Methods Events

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace : HtmlExport Class

The following tables list the members exposed by HtmlExport.

Public Constructors
 | Name | Description
Public Constructor | HtmlExport Constructor | Initializes a new instance of the Export.Html class.
Top
Public Properties
 | Name | Description
Public Property | BookmarkStyle | Sets or returns a value indicating whether a page of bookmarks will be created if the ActiveReports document contains bookmarks.
Public Property | CharacterSet | Sets or returns the character set encoding that will be used in the exported HTML pages.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | CreateFramesetPage | Sets or returns a value indicating whether the HTML pages appear in a frame set. If set to True, any bookmark entries appear on the left, and the report document contents appear on the right. The resulting file will use the specified filename with the extension ".frame.html".
Public Property | IncludeHtmlHeader | Sets or returns a value indicating whether the exported HTML files will include normal HTML page headers such as the HTML, HEAD, and BODY elements.
Public Property | IncludePageMargins | Sets or returns a value indicating whether the page's margins are included in the output.
Public Property | MultiPage | Sets or returns a value indicating whether multiple HTML pages are generated for the document.
Public Property | OutputType | Gets or sets a value indicating whether the document will be exported as DHTML or HTML.
Public Property | Pagination | Gets or sets the value, that indicates whether pagination should be used for the resultant html document or not.
Public Property | RemoveVerticalSpace | Sets or returns a value indicating whether completely empty vertical spacing will be removed from the output.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Title | Sets or returns the Title used in the header of HTML pages.
Top
Public Methods
 | Name | Description
Public Method | AddMetadata | Adds specified metadata property to be written as HTML meta.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | Export | Overloaded. Exports the specified document to HTML.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

HtmlExport Class
GrapeCity.ActiveReports.Export.Html.Section Namespace

Walkthroughs

Custom HTML Outputter


HtmlExport Constructor

HtmlExport Constructor

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : HtmlExport Constructor
Initializes a new instance of the Export.Html class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public HtmlExport()
See Also

Reference

HtmlExport Class
HtmlExport Members


HtmlExport Class Methods

HtmlExport Class Methods

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace : HtmlExport Class

For a list of all members of this type, see HtmlExport members.

Public Methods
 | Name | Description
Public Method | AddMetadata | Adds specified metadata property to be written as HTML meta.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | Export | Overloaded. Exports the specified document to HTML.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

HtmlExport Class
GrapeCity.ActiveReports.Export.Html.Section Namespace

Walkthroughs

Custom HTML Outputter


AddMetadata Method

AddMetadata Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : AddMetadata Method
The property name.
The property value.
Adds specified metadata property to be written as HTML meta.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddMetadata( _
   ByVal name As System.String, _
   ByVal value As System.String _
)
public void AddMetadata(
   System.string name,
   System.string value
)

Parameters

name
The property name.
value
The property value.
See Also

Reference

HtmlExport Class
HtmlExport Members


Export Method (HtmlExport)

Export Method (HtmlExport)
Example

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : Export Method
Exports the specified document to HTML.
Overload List
Overload | Description
Export(PageDocument,String) | Exports the specified document to html.
Export(PageDocument,String,String) | Exports the specified page document to HTML.
Export(PageDocument,Stream) | Exports the specified page document to HTML in a MIME MHT format (as can be saved from Internet Explorer) which includes the HTML and all images in a single file.
Export(PageDocument,Stream,String) | Exports the specified GrapeCity.ActiveReports.Document.SectionDocumentto HTML in a MIME MHT format (as can be saved from Internet Explorer) which includes the HTML and all images in a single file.
Export(PageDocument,IOutputHtml,String) | Provides advanced control over how the HtmlExport stores all output, including all html pages, images, bookmark pages, etc...
Export(IReport,String,String) | Exports the specified IReport to file
Export(IReport,String) | Exports the specified IReport to file
Export(IReport,Stream) | Exports the specified IReport to stream
Export(IReport,Stream,String) | Exports the specified IReport to stream
Export(SectionDocument,String) | Exports the entire ActiveReports document to the specified HTML file.
Export(SectionDocument,String,String) | Exports the specified range of pages to an HTML file.
Export(SectionDocument,Stream,String) | Exports the specified range of pages to a System.IO.Stream in a MIME MHT format (such as can be saved using Internet Explorer with the Save As Web Archive option) which combines the HTML and all images into a single file.
Export(SectionDocument,IOutputHtml,String) | Exports the specified range of pages of the document to the chosen outputHandler.
Export(SectionDocument,Stream) | Exports the entire ActiveReports document to HTML in a MIME MHT format (such as can be saved using Internet Explorer with the Save As Web Archive option) which combines the HTML and all images into a single file.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
rptGrapeCity rpt = new rptGrapeCity();
GrapeCity.ActiveReports.Export.Html.Section.HtmlExport h = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
rpt.Run();
this.arv.Document = rpt.Document;
h.Export(rpt.Document, Application.StartupPath + "\\h.html");
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim h As New GrapeCity.ActiveReports.Export.Html.Section.HtmlExport
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    h.Export(rpt.Document, Application.StartupPath & "\h.html")
End Sub
See Also

Reference

HtmlExport Class
HtmlExport Members


Export(PageDocument,String) Method

Export(PageDocument,String) Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(PageDocument,String) Method
The ActiveReports PageDocument object to export.
The file name and path to save the main html file to. If multiple filenames are generated (such as images, or table of contents pages) this argument's value will be used as a prefix for the other file names.
Exports the specified document to html.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As System.String _
)
public void Export(
   PageDocument document,
   System.string filePath
)

Parameters

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main html file to. If multiple filenames are generated (such as images, or table of contents pages) this argument's value will be used as a prefix for the other file names.
See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


Export(PageDocument,String,String) Method

Export(PageDocument,String,String) Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(PageDocument,String,String) Method
The GrapeCity.ActiveReports.Document.SectionDocument to export.
The file name and path to save the main html file to. If multiple filenames are generated (such as images, or table of contents pages) this argument's value will be used as a prefix for the other file names.
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified page document to HTML.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As System.String, _
   ByVal pageRange As System.String _
)
public void Export(
   PageDocument document,
   System.string filePath,
   System.string pageRange
)

Parameters

document
The GrapeCity.ActiveReports.Document.SectionDocument to export.
filePath
The file name and path to save the main html file to. If multiple filenames are generated (such as images, or table of contents pages) this argument's value will be used as a prefix for the other file names.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


Export(PageDocument,Stream) Method

Export(PageDocument,Stream) Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(PageDocument,Stream) Method
The PageDocument to export.
The destination System.IO.Stream to save the MHT file to.
Exports the specified page document to HTML in a MIME MHT format (as can be saved from Internet Explorer) which includes the HTML and all images in a single file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal stream As System.IO.Stream _
)
public void Export(
   PageDocument document,
   System.IO.Stream stream
)

Parameters

document
The PageDocument to export.
stream
The destination System.IO.Stream to save the MHT file to.
See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


Export(PageDocument,Stream,String) Method

Export(PageDocument,Stream,String) Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(PageDocument,Stream,String) Method
The GrapeCity.ActiveReports.Document.SectionDocument to export.
The destination System.IO.Stream to save the MHT file to.
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified GrapeCity.ActiveReports.Document.SectionDocumentto HTML in a MIME MHT format (as can be saved from Internet Explorer) which includes the HTML and all images in a single file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal stream As System.IO.Stream, _
   ByVal pageRange As System.String _
)
public void Export(
   PageDocument document,
   System.IO.Stream stream,
   System.string pageRange
)

Parameters

document
The GrapeCity.ActiveReports.Document.SectionDocument to export.
stream
The destination System.IO.Stream to save the MHT file to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


Export(PageDocument,IOutputHtml,String) Method

Export(PageDocument,IOutputHtml,String) Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(PageDocument,IOutputHtml,String) Method
The ActiveReports PageDocument to export to HTML.
An implementation of GrapeCity.ActiveReports.Export.Html.IOutputHtml that will receive all HTML output.
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Provides advanced control over how the HtmlExport stores all output, including all html pages, images, bookmark pages, etc...
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal outputHandler As IOutputHtml, _
   ByVal pageRange As System.String _
)
public void Export(
   PageDocument document,
   IOutputHtml outputHandler,
   System.string pageRange
)

Parameters

document
The ActiveReports PageDocument to export to HTML.
outputHandler
An implementation of GrapeCity.ActiveReports.Export.Html.IOutputHtml that will receive all HTML output.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


Export(IReport,String,String) Method

Export(IReport,String,String) Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(IReport,String,String) Method
IReport instance to Export
Path to export
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified IReport to file
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal filePath As System.String, _
   ByVal pageRange As System.String _
)
public void Export(
   IReport report,
   System.string filePath,
   System.string pageRange
)

Parameters

report
IReport instance to Export
filePath
Path to export
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


Export(IReport,String) Method

Export(IReport,String) Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(IReport,String) Method
IReport instance to Export
Path to export
Exports the specified IReport to file
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal filePath As System.String _
)
public void Export(
   IReport report,
   System.string filePath
)

Parameters

report
IReport instance to Export
filePath
Path to export
See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


Export(IReport,Stream) Method

Export(IReport,Stream) Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(IReport,Stream) Method
IReport instance to Export
The output stream.
Exports the specified IReport to stream
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal outputStream As System.IO.Stream _
)
public void Export(
   IReport report,
   System.IO.Stream outputStream
)

Parameters

report
IReport instance to Export
outputStream
The output stream.
See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


Export(IReport,Stream,String) Method

Export(IReport,Stream,String) Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(IReport,Stream,String) Method
IReport instance to Export
The output stream.
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified IReport to stream
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal outputStream As System.IO.Stream, _
   ByVal pageRange As System.String _
)
public void Export(
   IReport report,
   System.IO.Stream outputStream,
   System.string pageRange
)

Parameters

report
IReport instance to Export
outputStream
The output stream.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


Export(SectionDocument,String) Method

Export(SectionDocument,String) Method
Example

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(SectionDocument,String) Method
The ActiveReports document to be exported to HTML.
The file name and path to which to save the main HTML file. If multiple filenames are generated (such as images, or table of contents pages) this argument's value will be used as a prefix for the other file names.
Exports the entire ActiveReports document to the specified HTML file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As System.String _
)
public void Export(
   SectionDocument document,
   System.string filePath
)

Parameters

document
The ActiveReports document to be exported to HTML.
filePath
The file name and path to which to save the main HTML file. If multiple filenames are generated (such as images, or table of contents pages) this argument's value will be used as a prefix for the other file names.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    rptGrapeCity rpt = new rptGrapeCity();
    GrapeCity.ActiveReports.Export.Html.Section.HtmlExport h = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
    rpt.Run();
    this.arv.Document = rpt.Document;
    h.Export(rpt.Document, Application.StartupPath + "\\h.html");
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim h As New GrapeCity.ActiveReports.Export.Html.Section.HtmlExport
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    h.Export(rpt.Document, Application.StartupPath & "\h.html")
End Sub
See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


Export(SectionDocument,String,String) Method

Export(SectionDocument,String,String) Method
Example

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(SectionDocument,String,String) Method
The ActiveReports document to be exported to HTML.
The file name and path to which to save the main HTML file. If multiple filenames are generated (such as images, or table of contents pages) this argument's value will be used as a prefix for the other file names.
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.
Exports the specified range of pages to an HTML file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As System.String, _
   ByVal pagesRange As System.String _
)
public void Export(
   SectionDocument document,
   System.string filePath,
   System.string pagesRange
)

Parameters

document
The ActiveReports document to be exported to HTML.
filePath
The file name and path to which to save the main HTML file. If multiple filenames are generated (such as images, or table of contents pages) this argument's value will be used as a prefix for the other file names.
pagesRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    rptGrapeCity rpt = new rptGrapeCity();
    GrapeCity.ActiveReports.Export.Html.Section.HtmlExport h = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
    rpt.Run();
    this.arv.Document = rpt.Document;
    h.Export(rpt.Document, Application.StartupPath + "\\h.html", "1-3");
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim h As New GrapeCity.ActiveReports.Export.Html.HtmlExport
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    h.Export(rpt.Document, Application.StartupPath & "\h.html", "1-3")
End Sub
See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


Export(SectionDocument,Stream,String) Method

Export(SectionDocument,Stream,String) Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(SectionDocument,Stream,String) Method
The ActiveReports document to be exported to HTML.
The destination System.IO.Stream to which to save the MHT file.
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.
Exports the specified range of pages to a System.IO.Stream in a MIME MHT format (such as can be saved using Internet Explorer with the Save As Web Archive option) which combines the HTML and all images into a single file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As System.IO.Stream, _
   ByVal pagesRange As System.String _
)
public void Export(
   SectionDocument document,
   System.IO.Stream outputStream,
   System.string pagesRange
)

Parameters

document
The ActiveReports document to be exported to HTML.
outputStream
The destination System.IO.Stream to which to save the MHT file.
pagesRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.
See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


Export(SectionDocument,IOutputHtml,String) Method

Export(SectionDocument,IOutputHtml,String) Method
Example

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(SectionDocument,IOutputHtml,String) Method
The ActiveReports document to be exported to HTML.
An implementation of IOutputHandler that will receive the HTML output.
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.
Exports the specified range of pages of the document to the chosen outputHandler.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputHandler As IOutputHtml, _
   ByVal pageRange As System.String _
)
public void Export(
   SectionDocument document,
   IOutputHtml outputHandler,
   System.string pageRange
)

Parameters

document
The ActiveReports document to be exported to HTML.
outputHandler
An implementation of IOutputHandler that will receive the HTML output.
pageRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.
Remarks
Provides advanced control over how the HtmlExport stores all output, including html pages, images, bookmark pages, etc.
Example
  • C#
private void Page_Load(object sender, System.EventArgs e)
{
    rptCustExHTML rpt = new rptCustExHTML();
    try
    {
        rpt.Run(false);
    }
    catch (Exception eRunReport)
    {
        // Failure running report, just report the error to the user:
        Response.Clear();
        Response.Write("<h1>Error running report:</h1>");
        Response.Write(eRunReport.ToString());
        return;
    }
    // Buffer this page's output until the report output is ready.
    Response.Buffer = true;
    // Clear any part of this page that might have already been buffered for output.
    Response.ClearContent();
    // Clear any headers that might have already been buffered (such as the content type for an HTML page)
    Response.ClearHeaders();
    // Tell the browser and the "network" that this resulting data of this page should be be cached since this
     // could be a dynamic report that changes upon each request.
    Response.Cache.SetCacheability(HttpCacheability.NoCache);
    // Tell the browser this is an Html document so it will use an appropriate viewer.
    Response.ContentType = "text/html";
    // Create the HTML export object
    GrapeCity.ActiveReports.Export.Html.Section.HtmlExport html = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
    // Export the report to HTML in this session's webcache:
    //this.htmlExport1.Export(rpt.Document, GrapeCity.ActiveReports.Web
    MyCustomHtmlOutputter outputter = new MyCustomHtmlOutputter(this.Context);
    this.htmlExport1.Export(rpt.Document, outputter, "");
    Response.Redirect("ReportOutput" + "/" + System.IO.Path.GetFileName(outputter.mainPage));
}
  • Visual Basic
Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim rpt As New ActiveReport1()
        Try
            rpt.Run(False)
        Catch eRunReport As Exception
            ' Failure running report, just report the error to the user:
            Response.Clear()
            Response.Write("<h1>Error running report:</h1>")
            Response.Write(eRunReport.ToString())
            Return
        End Try
        ' Buffer this page's output until the report output is ready.
        Response.Buffer = True
        ' Clear any part of this page that might have already been buffered for output.
        Response.ClearContent()
        ' Clear any headers that might have already been buffered (such as the content type for an HTML page)
        Response.ClearHeaders()
        ' Tell the browser and the "network" that this resulting data of this page should be be cached since
        ' this could be a dynamic report that changes upon each request.
        Response.Cache.SetCacheability(HttpCacheability.NoCache)
        ' Tell the browser this is an Html document so it will use an appropriate viewer.
        Response.ContentType = "text/HTML"
        ' Create the Html export object
        Dim HtmlExport1 As New HtmlExport()
        Dim outputter As New MyCustomHtmlOutputter(Me.Context)
        Me.HtmlExport1.Export(rpt.Document, outputter, "")
        Response.Redirect("ReportOutput" + "/" + System.IO.Path.GetFileName(outputter.mainPage))
End Sub
See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List
OutputType Property


Export(SectionDocument,Stream) Method

Export(SectionDocument,Stream) Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class > Export Method : Export(SectionDocument,Stream) Method
The ActiveReports document to be exported to HTML.
The destination System.IO.Stream to which to save the MHT file.
Exports the entire ActiveReports document to HTML in a MIME MHT format (such as can be saved using Internet Explorer with the Save As Web Archive option) which combines the HTML and all images into a single file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As System.IO.Stream _
)
public void Export(
   SectionDocument document,
   System.IO.Stream outputStream
)

Parameters

document
The ActiveReports document to be exported to HTML.
outputStream
The destination System.IO.Stream to which to save the MHT file.
See Also

Reference

HtmlExport Class
HtmlExport Members
Overload List


HtmlExport Class Properties

HtmlExport Class Properties

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace : HtmlExport Class

For a list of all members of this type, see HtmlExport members.

Public Properties
 | Name | Description
Public Property | BookmarkStyle | Sets or returns a value indicating whether a page of bookmarks will be created if the ActiveReports document contains bookmarks.
Public Property | CharacterSet | Sets or returns the character set encoding that will be used in the exported HTML pages.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | CreateFramesetPage | Sets or returns a value indicating whether the HTML pages appear in a frame set. If set to True, any bookmark entries appear on the left, and the report document contents appear on the right. The resulting file will use the specified filename with the extension ".frame.html".
Public Property | IncludeHtmlHeader | Sets or returns a value indicating whether the exported HTML files will include normal HTML page headers such as the HTML, HEAD, and BODY elements.
Public Property | IncludePageMargins | Sets or returns a value indicating whether the page's margins are included in the output.
Public Property | MultiPage | Sets or returns a value indicating whether multiple HTML pages are generated for the document.
Public Property | OutputType | Gets or sets a value indicating whether the document will be exported as DHTML or HTML.
Public Property | Pagination | Gets or sets the value, that indicates whether pagination should be used for the resultant html document or not.
Public Property | RemoveVerticalSpace | Sets or returns a value indicating whether completely empty vertical spacing will be removed from the output.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Title | Sets or returns the Title used in the header of HTML pages.
Top
See Also

Reference

HtmlExport Class
GrapeCity.ActiveReports.Export.Html.Section Namespace

Walkthroughs

Custom HTML Outputter


BookmarkStyle Property (HtmlExport)

BookmarkStyle Property (HtmlExport)
Example

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : BookmarkStyle Property
Sets or returns a value indicating whether a page of bookmarks will be created if the ActiveReports document contains bookmarks.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BookmarkStyle As BookmarkStyle
public BookmarkStyle BookmarkStyle {get; set;}

Property Value

BookmarkStyle enumeration.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    rptGrapeCity rpt = new rptGrapeCity();
    GrapeCity.ActiveReports.Export.Html.Section.HtmlExport h = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
    h.BookmarkStyle = GrapeCity.ActiveReports.Export.Html.Section.BookmarkStyle.Html;
    h.CreateFramesetPage = true;
    rpt.Run();
    this.arv.Document = rpt.Document;
    h.Export(rpt.Document, Application.StartupPath + "\\h.html");
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim h As New  GrapeCity.ActiveReports.Export.Html.Section.HtmlExport
    h.BookmarkStyle =  GrapeCity.ActiveReports.Export.Html.Section.BookmarkStyle.Html
    h.CreateFramesetPage = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    h.Export(rpt.Document, Application.StartupPath & "\h.html")
End Sub
See Also

Reference

HtmlExport Class
HtmlExport Members
BookmarkStyle Enumeration


CharacterSet Property (HtmlExport)

CharacterSet Property (HtmlExport)
Example

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : CharacterSet Property
Sets or returns the character set encoding that will be used in the exported HTML pages.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CharacterSet As HtmlCharacterSet
public HtmlCharacterSet CharacterSet {get; set;}

Property Value

HtmlCharacterSet enumeration.
Remarks

The default character set is UTF8. Setting this property will change the meta tag in the header of the resulting HTML pages to the appropriate IANA character set value.

For example: <META content="text/html;charset=ISO-8859-1" http-equiv=Content-Type>.

Additionally, the inner text portion of the pages will be encoded according to the specific character set's encoding rules and font names. If you are exporting a Document without headers (IncludeHtmlHeader=false), then you must insert the appropriate meta tag to ensure that the browser knows how the text is encoded.

Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport();
    GrapeCity.ActiveReports.Export.Html.Section.HtmlExport h = new  GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
    h.CharacterSet =  GrapeCity.ActiveReports.Export.Html.Section.HtmlCharacterSet.Big5;
    rpt.Run();
    this.arv.Document = rpt.Document;
    h.Export(rpt.Document, Application.StartupPath + "\\h.html");
}
  • Visual Basic
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    Dim h As New  GrapeCity.ActiveReports.Export.Html.Section.HtmlExport
    h.CharacterSet =  GrapeCity.ActiveReports.Export.Html.Section.HtmlCharacterSet.Big5
    h.Export(rpt.Document, Application.StartupPath + "/export.html")
End Sub
See Also

Reference

HtmlExport Class
HtmlExport Members
HtmlCharacterSet Enumeration


CreateFramesetPage Property (HtmlExport)

CreateFramesetPage Property (HtmlExport)
Example

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : CreateFramesetPage Property
Sets or returns a value indicating whether the HTML pages appear in a frame set. If set to True, any bookmark entries appear on the left, and the report document contents appear on the right. The resulting file will use the specified filename with the extension ".frame.html".
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CreateFramesetPage As System.Boolean
public System.bool CreateFramesetPage {get; set;}

Property Value

Boolean.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Html.Section.HtmlExport h = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
    h.BookmarkStyle = GrapeCity.ActiveReports.Export.Html.Section.BookmarkStyle.Html;
    h.CreateFramesetPage = true;
    rpt.Run();
    this.arv.Document = rpt.Document;
    h.Export(rpt.Document, Application.StartupPath + "\\h.html");
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim h As New GrapeCity.ActiveReports.Export.Html.Section.HtmlExport
    h.BookmarkStyle = GrapeCity.ActiveReports.Export.Html.Section.BookmarkStyle.Html
    h.CreateFramesetPage = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    h.Export(rpt.Document, Application.StartupPath & "\h.html")
End Sub
See Also

Reference

HtmlExport Class
HtmlExport Members


IncludeHtmlHeader Property (HtmlExport)

IncludeHtmlHeader Property (HtmlExport)
Example

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : IncludeHtmlHeader Property
Sets or returns a value indicating whether the exported HTML files will include normal HTML page headers such as the HTML, HEAD, and BODY elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IncludeHtmlHeader As System.Boolean
public System.bool IncludeHtmlHeader {get; set;}

Property Value

Boolean. The default value is True.
Remarks
Set this value to False if you want to use the resulting HTML output in the middle of another HTML page.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Html.Section.HtmlExport h = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
    h.IncludeHtmlHeader = false;
    rpt.Run();
    this.arv.Document = rpt.Document;
    h.Export(rpt.Document, Application.StartupPath + "\\h.html");
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim h As New GrapeCity.ActiveReports.Export.Html.Section.HtmlExport
    h.IncludeHtmlHeader = False
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    h.Export(rpt.Document, Application.StartupPath & "\h.html")
End Sub
See Also

Reference

HtmlExport Class
HtmlExport Members


IncludePageMargins Property (HtmlExport)

IncludePageMargins Property (HtmlExport)
Example

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : IncludePageMargins Property
Sets or returns a value indicating whether the page's margins are included in the output.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IncludePageMargins As System.Boolean
public System.bool IncludePageMargins {get; set;}

Property Value

Boolean. The default value is False.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Html.Section.HtmlExport h = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
    h.IncludePageMargins = true;
    rpt.Run();
    this.arv.Document = rpt.Document;
    h.Export(rpt.Document, Application.StartupPath + "\\h.html");
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim h As New GrapeCity.ActiveReports.Export.Html.Section.HtmlExport
    h.IncludePageMargins = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    h.Export(rpt.Document, Application.StartupPath & "\h.html")
End Sub
See Also

Reference

HtmlExport Class
HtmlExport Members


MultiPage Property (HtmlExport)

MultiPage Property (HtmlExport)
Example

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : MultiPage Property

Sets or returns a value indicating whether multiple HTML pages are generated for the document.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MultiPage As System.Boolean
public System.bool MultiPage {get; set;}

Property Value

Boolean. If True, an HTML page will be generated for each page in the ActiveReports document. If False, (the default value) a single HTML page is generated which includes all of the pages in the ActiveReports document.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Html.Section.HtmlExport h = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
    h.MultiPage = true;
    rpt.Run();
    this.arv.Document = rpt.Document;
    h.Export(rpt.Document, Application.StartupPath + "\\h.html");
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim h As New GrapeCity.ActiveReports.Export.Html.Section.HtmlExport
    h.MultiPage = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    h.Export(rpt.Document, Application.StartupPath & "\h.html")
End Sub
See Also

Reference

HtmlExport Class
HtmlExport Members


OutputType Property (HtmlExport)

OutputType Property (HtmlExport)
Example

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : OutputType Property
Gets or sets a value indicating whether the document will be exported as DHTML or HTML.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OutputType As HtmlOutputType
public HtmlOutputType OutputType {get; set;}

Property Value

HtmlOutputType enumeration. The default value is DynamicHtml.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Html.Section.HtmlExport h = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
    h.OutputType = GrapeCity.ActiveReports.Export.Html.Section.HtmlOutputType.LegacyHtml;
    rpt.Run();
    this.arv.Document = rpt.Document;
    h.Export(rpt.Document, Application.StartupPath + "\\h.html");
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim h As New GrapeCity.ActiveReports.Export.Html.HtmlExport
    h.OutputType = GrapeCity.ActiveReports.Export.Html.HtmlOutputType.LegacyHtml
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    h.Export(rpt.Document, Application.StartupPath & "\h.html")
End Sub
See Also

Reference

HtmlExport Class
HtmlExport Members
HtmlOutputType Enumeration


Pagination Property (HtmlExport)

Pagination Property (HtmlExport)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : Pagination Property
Gets or sets the value, that indicates whether pagination should be used for the resultant html document or not.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Pagination As System.Boolean
public System.bool Pagination {get; set;}
See Also

Reference

HtmlExport Class
HtmlExport Members


RemoveVerticalSpace Property (HtmlExport)

RemoveVerticalSpace Property (HtmlExport)
Example

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : RemoveVerticalSpace Property
Sets or returns a value indicating whether completely empty vertical spacing will be removed from the output.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RemoveVerticalSpace As System.Boolean
public System.bool RemoveVerticalSpace {get; set;}

Property Value

Boolean. The default value is False.
Remarks
This property has no effect if you are using the default OutputType option (DynamicHtml). This may improve pagination if you wish to print the HTML output from a browser with the LegacyHtml OutputType option.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Html.Section.HtmlExport h = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
    h.OutputType = GrapeCity.ActiveReports.Export.Html.Section.HtmlOutputType.LegacyHtml;
    h.RemoveVerticalSpace = true;
    rpt.Run();
    this.arv.Document = rpt.Document;
    h.Export(rpt.Document, Application.StartupPath + "\\h.html");
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim h As New GrapeCity.ActiveReports.Export.Html.HtmlExport
    h.OutputType = GrapeCity.ActiveReports.Export.Html.HtmlOutputType.LegacyHtml
    h.RemoveVerticalSpace = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    h.Export(rpt.Document, Application.StartupPath & "\h.html")
End Sub
See Also

Reference

HtmlExport Class
HtmlExport Members


Title Property (HtmlExport)

Title Property (HtmlExport)
Example

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : Title Property
Sets or returns the Title used in the header of HTML pages.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Title As System.String
public System.string Title {get; set;}

Property Value

String.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    rptGrapeCity rpt = new rptGrapeCity();
    GrapeCity.ActiveReports.Export.Html.Section.HtmlExport h = new GrapeCity.ActiveReports.Export.Html.Section.HtmlExport();
    h.Title = "ActiveReports HTML Export";
    rpt.Run();
    this.arv.Document = rpt.Document;
    h.Export(rpt.Document, Application.StartupPath + "\\h.html");
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim h As New GrapeCity.ActiveReports.Export.Html.Section.HtmlExport
    h.Title = "ActiveReports HTML Export"
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    h.Export(rpt.Document, Application.StartupPath & "\h.html")
End Sub
See Also

Reference

HtmlExport Class
HtmlExport Members


HtmlExportException Class

HtmlExportException Class
Members

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace : HtmlExportException Class
The exception that is thrown when an error occurs in the ActiveReports HTML export assembly.
Object Model
HtmlExportException Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class HtmlExportException
   Inherits System.ApplicationException
public class HtmlExportException : System.ApplicationException
Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Export.Html.Section.HtmlExportException

See Also

Reference

HtmlExportException Members
GrapeCity.ActiveReports.Export.Html.Section Namespace


HtmlExportException Class Members

HtmlExportException Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace : HtmlExportException Class

The following tables list the members exposed by HtmlExportException.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

HtmlExportException Class
GrapeCity.ActiveReports.Export.Html.Section Namespace


OutputHtmlFiles Class

OutputHtmlFiles Class
Members

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace : OutputHtmlFiles Class
OutputHtmlFiles is an implementation of the IHandleHtmlOutput interface that directs the HtmlExport object's output to files.
Object Model
OutputHtmlFiles Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class OutputHtmlFiles
   Implements GrapeCity.ActiveReports.Export.Html.IOutputHtml
public class OutputHtmlFiles : GrapeCity.ActiveReports.Export.Html.IOutputHtml
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Html.Section.OutputHtmlFiles

See Also

Reference

OutputHtmlFiles Members
GrapeCity.ActiveReports.Export.Html.Section Namespace


OutputHtmlFiles Class Members

OutputHtmlFiles Class Members

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace : OutputHtmlFiles Class

The following tables list the members exposed by OutputHtmlFiles.

Public Constructors
 | Name | Description
Public Constructor | OutputHtmlFiles Constructor | Initializes an instance of the OutputHtmlFiles class using the specified filePath as the base html page.
Top
See Also

Reference

OutputHtmlFiles Class
GrapeCity.ActiveReports.Export.Html.Section Namespace


OutputHtmlFiles Constructor

OutputHtmlFiles Constructor

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > OutputHtmlFiles Class : OutputHtmlFiles Constructor
The file path to the main or starting HTML page. Other created files (such as linked images and table of contents pages) will use this file path as a prefix.
The parent HtmlExport object with which this object is working.
Initializes an instance of the OutputHtmlFiles class using the specified filePath as the base html page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal filePath As System.String, _
   ByVal htmlExport As HtmlExport _
)
public OutputHtmlFiles(
   System.string filePath,
   HtmlExport htmlExport
)

Parameters

filePath
The file path to the main or starting HTML page. Other created files (such as linked images and table of contents pages) will use this file path as a prefix.
htmlExport
The parent HtmlExport object with which this object is working.
Remarks
When this class is created, it demands permission to write files in the parent folder of the specified file. If permission is not granted, a SecurityException is thrown.
See Also

Reference

OutputHtmlFiles Class
OutputHtmlFiles Members


BookmarkStyle Enumeration

BookmarkStyle Enumeration

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace : BookmarkStyle Enumeration
An enumeration of values for the HtmlExport.BookmarkStyle property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum BookmarkStyle
   Inherits System.Enum
public enum BookmarkStyle : System.Enum
Members
Member | Description
Html | If the ActiveReports document contains bookmarks, an HTML page containing bookmark links to the document's pages is created.
None | No bookmark page is created.
Remarks
More styles may be added in future.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Html.Section.BookmarkStyle

See Also

Reference

GrapeCity.ActiveReports.Export.Html.Section Namespace
BookmarkStyle Property


HtmlCharacterSet Enumeration

HtmlCharacterSet Enumeration

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace : HtmlCharacterSet Enumeration
An enumeration of values for the HtmlExport.CharacterSet property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum HtmlCharacterSet
   Inherits System.Enum
public enum HtmlCharacterSet : System.Enum
Members
Member | Description
Big5 | Known as "Chinese for Taiwan Multi-byte set." The charset name is "Big5."
EucJp | Known as "Extended UNIX Code Packed Format for Japanese." The charset name is "EUC-JP."
HzGb2312 | Known as "ASCII Printable Characters-Based Chinese Character Encoding" per RFC1842 and RFC1843. The charset name is "HZ-GB-2312."
Ibm850 | Known only as "IBM850." The charset name is "IBM850."
Iso2022Jp | Known as "Japanese Character Encoding for Internet Messages" per RFC1468. The charset name is "ISO-2022-JP."
Iso2022Kr | Known as "Korean Character Encoding for Internet Messages" per RFC1557. The charset name is "ISO-2022-KR."
Iso8859_1 | Known as "Latin alphabet No. 1." The charset name is "ISO-8859-1."
Iso8859_2 | Known as "Latin alphabet No. 2." The charset name is "ISO-8859-2."
Iso8859_5 | Known as "Latin/Cyrillic alphabet." The charset name is "ISO-8859-5."
Iso8859_6 | Known as "Latin/Arabic alphabet." The charset name is "ISO-8859-6."
Koi8r | Known as "Russian Net Character Set." The charset name is "KOI8-R."
Ksc5601 | Known as "Unified Hangeul" (Korean). The charset name is "KSC5601."
ShiftJis | Known as "Shift-JIS" (Japanese). The charset name is "shift-jis."
UnicodeUtf16 | Per RFC 2781. An encoding for the Unicode character set in little-endian byte order using UTF-16 encoding.
UnicodeUtf8 | Per RFC 3629. An encoding for the Unicode character set using UTF-8 encoding.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Html.Section.HtmlCharacterSet

See Also

Reference

GrapeCity.ActiveReports.Export.Html.Section Namespace
CharacterSet Property


HtmlOutputType Enumeration

HtmlOutputType Enumeration

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace : HtmlOutputType Enumeration
An enumeration of values for the HtmlExport.OutputType property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum HtmlOutputType
   Inherits System.Enum
public enum HtmlOutputType : System.Enum
Members
Member | Description
DynamicHtml | Default. Exports the document to DHTML format.
LegacyHtml | Exports the document to static HTML format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Html.Section.HtmlOutputType

See Also

Reference

GrapeCity.ActiveReports.Export.Html.Section Namespace
OutputType Property


GrapeCity.ActiveReports.Export.Image.Page Namespace

GrapeCity.ActiveReports.Export.Image.Page Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Image.v10 Assembly : GrapeCity.ActiveReports.Export.Image.Page Namespace
The GrapeCity.ActiveReports.Export.Image.Page contains Image export classes for page layout.
Classes
 | Class | Description
Class | ImageRenderingExtension | Represents implementation of GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension. Allows to render GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport in image.
Class | Settings | Represents settings for ImageRenderingExtension.
See Also

Reference

GrapeCity.ActiveReports.Export.Image.v10 Assembly


ImageRenderingExtension Class

ImageRenderingExtension Class
Members

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace : ImageRenderingExtension Class
Represents implementation of GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension. Allows to render GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport in image.
Object Model
ImageRenderingExtension Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ImageRenderingExtension
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IImageRenderingExtension, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtensionInternal
public sealed class ImageRenderingExtension : GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IImageRenderingExtension, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtensionInternal
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension

See Also

Reference

ImageRenderingExtension Members
GrapeCity.ActiveReports.Export.Image.Page Namespace


ImageRenderingExtension Class Members

ImageRenderingExtension Class Members
Methods

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace : ImageRenderingExtension Class

The following tables list the members exposed by ImageRenderingExtension.

Public Constructors
 | Name | Description
Public Constructor | ImageRenderingExtension Constructor | Initializes a new instance of the ImageRenderingExtension class.
Top
Public Methods
 | Name | Description
Public Method | GetSupportedSettings | Overloaded. Returns the settings for the ImageRenderingExtension class.
Top
See Also

Reference

ImageRenderingExtension Class
GrapeCity.ActiveReports.Export.Image.Page Namespace


ImageRenderingExtension Constructor

ImageRenderingExtension Constructor

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > ImageRenderingExtension Class : ImageRenderingExtension Constructor
Initializes a new instance of the ImageRenderingExtension class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ImageRenderingExtension()
See Also

Reference

ImageRenderingExtension Class
ImageRenderingExtension Members


ImageRenderingExtension Class Methods

ImageRenderingExtension Class Methods

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace : ImageRenderingExtension Class

For a list of all members of this type, see ImageRenderingExtension members.

Public Methods
 | Name | Description
Public Method | GetSupportedSettings | Overloaded. Returns the settings for the ImageRenderingExtension class.
Top
See Also

Reference

ImageRenderingExtension Class
GrapeCity.ActiveReports.Export.Image.Page Namespace


GetSupportedSettings Method (ImageRenderingExtension)

GetSupportedSettings Method (ImageRenderingExtension)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > ImageRenderingExtension Class : GetSupportedSettings Method
Returns the settings for the ImageRenderingExtension class.
Overload List
Overload | Description
GetSupportedSettings() | Returns settings of current GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension instance.
GetSupportedSettings(Boolean) | Returns settings of current GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension instance.
See Also

Reference

ImageRenderingExtension Class
ImageRenderingExtension Members


GetSupportedSettings() Method

GetSupportedSettings() Method

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > ImageRenderingExtension Class > GetSupportedSettings Method : GetSupportedSettings() Method
Returns settings of current GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetSupportedSettings() As ISettings
public ISettings GetSupportedSettings()

Return Value

settings of current ImageRenderingExtension instance.
See Also

Reference

ImageRenderingExtension Class
ImageRenderingExtension Members
Overload List


GetSupportedSettings(Boolean) Method

GetSupportedSettings(Boolean) Method

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > ImageRenderingExtension Class > GetSupportedSettings Method : GetSupportedSettings(Boolean) Method
Returns the image rendering settings.
Returns settings of current GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetSupportedSettings( _
   ByVal fpl As System.Boolean _
) As ISettings
public ISettings GetSupportedSettings(
   System.bool fpl
)

Parameters

fpl
Returns the image rendering settings.

Return Value

settings of current ImageRenderingExtension instance.
See Also

Reference

ImageRenderingExtension Class
ImageRenderingExtension Members
Overload List


Settings Class

Settings Class
Members

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace : Settings Class
Represents settings for ImageRenderingExtension.
Object Model
Settings Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Settings
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
public class Settings : GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Image.Page.Settings

See Also

Reference

Settings Members
GrapeCity.ActiveReports.Export.Image.Page Namespace


Settings Class Members

Settings Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace : Settings Class

The following tables list the members exposed by Settings.

Public Constructors
 | Name | Description
Public Constructor | Settings Constructor | Overloaded. Initializes a new instance of the Settings class.
Top
Public Properties
Name | Description
Public Property | Compression | Sets or returns a value which specifies the compression to be used when exporting.
Public Property | Dither | Specifies whether the image should be dithered when saving to a black and white output format, like CCITT3 or Rle. This property has no effect if the CompressionScheme property is set to Lzw or None(represents color output).
Public Property DpiX

Adjust the horizontal resolution of rendered images. The default value is 96.

Public Property | DpiY | Adjust the vertical resolution of rendered images.
Public Property | EndPage | The default value of 0 in this property renders all of the report pages. Otherwise, set this value to the number of the last page to render. Please note that if the StartPage property is set to 0, all of the pages of the report render. In order to use the EndPage property, you must set the StartPage property to a valid non-zero number.
Public Property | ImageType | Select the type of image to which you want to render the report. Supported types are BMP, EMF, GIF, JPEG, TIFF, and PNG.
Public Property | MarginBottom | Set the value in inches to use for the bottom margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
Public Property | MarginLeft | Set the value in inches to use for the left margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
Public Property | MarginRight | Set the value in inches to use for the right margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
Public Property | MarginTop | Set the value in inches to use for the top margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
Public Property | PageHeight | Set the value in inches to use for the height of the image. The format is an integer or decimal with "in" as the suffix, for example "11in" for 11 inches. The value set in this property overrides the report's settings.
Public Property | PageWidth | Set the value in inches to use for the width of the image. The format is an integer or decimal with "in" as the suffix, for example "8in" for 8 inches. The value set in this property overrides the report's settings.
Public Property | Pagination | By default, each page of a report is rendered as a separate image. Set this value to False to render the entire report as a single image.
Public Property PrintLayoutMode Select how to lay out the pages of the report in the image.
  • OneLogicalPageOnSinglePhysicalPage
  • TwoLogicalPagesOnSinglePhysicalPage
  • FourLogicalPagesOnSinglePhysicalPage
  • EightLogicalPagesOnSinglePhysicalPage
  • BookletMode (lays the pages out for booklet printing)
Public Property | Quality | Gets or sets the quality of the report to be rendered as an image.
Public Property | SizeToFit | By default, rendered report pages are not resized to fit within the selected image size. Set this value to True to resize the report pages.
Public Property | StartPage | The default value of zero in this and the EndPage properties render all of the report pages to images. Otherwise, set this value to the number of the first page to render.
Public Property | WatermarkAngle | Specify the degree of angle for the watermark text on the image. Valid values range from 0 to 359, where 0 is horizontal, left to right.
Public Property | WatermarkColor | Select a color for the watermark text on the image. The default value for the watermark color is gray, but you can select any Web, System, or Custom color.
Public Property | WatermarkFont | Set the font to use for the watermark to any valid System.Drawing.Font.
Public Property | WatermarkTitle | Sets text (i.e. CONFIDENTIAL) to use as the watermark on the image.
Top
Public Methods
 | Name | Description
Public Method | ApplySettings | Applies any settings passed in the NameValueCollection settings parameters.
Public Method | GetSettings | Returns settings of ImageRenderingExtension.
Top
See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Image.Page Namespace


Settings Constructor

Settings Constructor

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : Settings Constructor
Initializes a new instance of the Settings class.
Overload List
Overload | Description
Settings Constructor() | Initializes a new instance of the Settings class.
Settings Constructor(NameValueCollection,Boolean) | Initializes new instance of GrapeCity.ActiveReports.Export.Image.Page.Settings class with specified settings.
See Also

Reference

Settings Class
Settings Members


Settings Constructor()

Settings Constructor()

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class > Settings Constructor : Settings Constructor()
Initializes a new instance of the Settings class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Settings()
See Also

Reference

Settings Class
Settings Members
Overload List


Settings Constructor(NameValueCollection,Boolean)

Settings Constructor(NameValueCollection,Boolean)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class > Settings Constructor : Settings Constructor(NameValueCollection,Boolean)
System.Collections.Specialized.NameValueCollection of specified settings.
FPL flag
Initializes new instance of GrapeCity.ActiveReports.Export.Image.Page.Settings class with specified settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal settings As System.Collections.Specialized.NameValueCollection, _
   ByVal fpl As System.Boolean _
)
public Settings(
   System.Collections.Specialized.NameValueCollection settings,
   System.bool fpl
)

Parameters

settings
System.Collections.Specialized.NameValueCollection of specified settings.
fpl
FPL flag
See Also

Reference

Settings Class
Settings Members
Overload List


Settings Class Methods

Settings Class Methods

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace : Settings Class

For a list of all members of this type, see Settings members.

Public Methods
 | Name | Description
Public Method | ApplySettings | Applies any settings passed in the NameValueCollection settings parameters.
Public Method | GetSettings | Returns settings of ImageRenderingExtension.
Top
See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Image.Page Namespace


ApplySettings Method (Settings)

ApplySettings Method (Settings)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : ApplySettings Method
a System.Collections.Specialized.NameValueCollection containing the settings for the renderer.
Applies any settings passed in the NameValueCollection settings parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ApplySettings( _
   ByVal settings As System.Collections.Specialized.NameValueCollection _
)
public void ApplySettings(
   System.Collections.Specialized.NameValueCollection settings
)

Parameters

settings
a System.Collections.Specialized.NameValueCollection containing the settings for the renderer.
See Also

Reference

Settings Class
Settings Members


GetSettings Method (Settings)

GetSettings Method (Settings)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : GetSettings Method
Returns settings of ImageRenderingExtension.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetSettings() As System.Collections.Specialized.NameValueCollection
public System.Collections.Specialized.NameValueCollection GetSettings()

Return Value

System.Collections.Specialized.NameValueCollection of ImageRenderingExtension settings.
See Also

Reference

Settings Class
Settings Members


Settings Class Properties

Settings Class Properties

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace : Settings Class

For a list of all members of this type, see Settings members.

Public Properties
Name | Description
Public Property | Compression | Sets or returns a value which specifies the compression to be used when exporting.
Public Property | Dither | Specifies whether the image should be dithered when saving to a black and white output format, like CCITT3 or Rle. This property has no effect if the CompressionScheme property is set to Lzw or None(represents color output).
Public Property DpiX

Adjust the horizontal resolution of rendered images. The default value is 96.

Public Property | DpiY | Adjust the vertical resolution of rendered images.
Public Property | EndPage | The default value of 0 in this property renders all of the report pages. Otherwise, set this value to the number of the last page to render. Please note that if the StartPage property is set to 0, all of the pages of the report render. In order to use the EndPage property, you must set the StartPage property to a valid non-zero number.
Public Property | ImageType | Select the type of image to which you want to render the report. Supported types are BMP, EMF, GIF, JPEG, TIFF, and PNG.
Public Property | MarginBottom | Set the value in inches to use for the bottom margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
Public Property | MarginLeft | Set the value in inches to use for the left margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
Public Property | MarginRight | Set the value in inches to use for the right margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
Public Property | MarginTop | Set the value in inches to use for the top margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
Public Property | PageHeight | Set the value in inches to use for the height of the image. The format is an integer or decimal with "in" as the suffix, for example "11in" for 11 inches. The value set in this property overrides the report's settings.
Public Property | PageWidth | Set the value in inches to use for the width of the image. The format is an integer or decimal with "in" as the suffix, for example "8in" for 8 inches. The value set in this property overrides the report's settings.
Public Property | Pagination | By default, each page of a report is rendered as a separate image. Set this value to False to render the entire report as a single image.
Public Property PrintLayoutMode Select how to lay out the pages of the report in the image.
  • OneLogicalPageOnSinglePhysicalPage
  • TwoLogicalPagesOnSinglePhysicalPage
  • FourLogicalPagesOnSinglePhysicalPage
  • EightLogicalPagesOnSinglePhysicalPage
  • BookletMode (lays the pages out for booklet printing)
Public Property | Quality | Gets or sets the quality of the report to be rendered as an image.
Public Property | SizeToFit | By default, rendered report pages are not resized to fit within the selected image size. Set this value to True to resize the report pages.
Public Property | StartPage | The default value of zero in this and the EndPage properties render all of the report pages to images. Otherwise, set this value to the number of the first page to render.
Public Property | WatermarkAngle | Specify the degree of angle for the watermark text on the image. Valid values range from 0 to 359, where 0 is horizontal, left to right.
Public Property | WatermarkColor | Select a color for the watermark text on the image. The default value for the watermark color is gray, but you can select any Web, System, or Custom color.
Public Property | WatermarkFont | Set the font to use for the watermark to any valid System.Drawing.Font.
Public Property | WatermarkTitle | Sets text (i.e. CONFIDENTIAL) to use as the watermark on the image.
Top
See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Image.Page Namespace


Compression Property

Compression Property

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : Compression Property
Sets or returns a value which specifies the compression to be used when exporting.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Compression As Compression
public Compression Compression {get; set;}
See Also

Reference

Settings Class
Settings Members


Dither Property (Settings)

Dither Property (Settings)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : Dither Property
Specifies whether the image should be dithered when saving to a black and white output format, like CCITT3 or Rle. This property has no effect if the CompressionScheme property is set to Lzw or None(represents color output).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Dither As System.Boolean
public System.bool Dither {get; set;}
See Also

Reference

Settings Class
Settings Members


DpiX Property (Settings)

DpiX Property (Settings)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : DpiX Property

Adjust the horizontal resolution of rendered images. The default value is 96.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DpiX As System.Single
public System.float DpiX {get; set;}
See Also

Reference

Settings Class
Settings Members


DpiY Property (Settings)

DpiY Property (Settings)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : DpiY Property
Adjust the vertical resolution of rendered images.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DpiY As System.Single
public System.float DpiY {get; set;}
See Also

Reference

Settings Class
Settings Members


EndPage Property (Settings)

EndPage Property (Settings)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : EndPage Property
The default value of 0 in this property renders all of the report pages. Otherwise, set this value to the number of the last page to render. Please note that if the StartPage property is set to 0, all of the pages of the report render. In order to use the EndPage property, you must set the StartPage property to a valid non-zero number.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EndPage As System.Integer
public System.int EndPage {get; set;}
See Also

Reference

Settings Class
Settings Members


ImageType Property (Settings)

ImageType Property (Settings)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : ImageType Property
Select the type of image to which you want to render the report. Supported types are BMP, EMF, GIF, JPEG, TIFF, and PNG.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ImageType As ImageType
public ImageType ImageType {get; set;}
See Also

Reference

Settings Class
Settings Members


MarginBottom Property (Settings)

MarginBottom Property (Settings)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : MarginBottom Property
Set the value in inches to use for the bottom margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MarginBottom As System.String
public System.string MarginBottom {get; set;}
See Also

Reference

Settings Class
Settings Members


MarginLeft Property (Settings)

MarginLeft Property (Settings)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : MarginLeft Property
Set the value in inches to use for the left margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MarginLeft As System.String
public System.string MarginLeft {get; set;}
See Also

Reference

Settings Class
Settings Members


MarginRight Property (Settings)

MarginRight Property (Settings)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : MarginRight Property
Set the value in inches to use for the right margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MarginRight As System.String
public System.string MarginRight {get; set;}
See Also

Reference

Settings Class
Settings Members


MarginTop Property (Settings)

MarginTop Property (Settings)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : MarginTop Property
Set the value in inches to use for the top margin of the image. The format is an integer or decimal with "in" as the suffix, for example "1in" for 1 inch. By default, no margins are used. The value set in this property overrides the report's settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MarginTop As System.String
public System.string MarginTop {get; set;}
See Also

Reference

Settings Class
Settings Members


PageHeight Property (Settings)

PageHeight Property (Settings)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : PageHeight Property
Set the value in inches to use for the height of the image. The format is an integer or decimal with "in" as the suffix, for example "11in" for 11 inches. The value set in this property overrides the report's settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageHeight As System.String
public System.string PageHeight {get; set;}
See Also

Reference

Settings Class
Settings Members


PageWidth Property (Settings)

PageWidth Property (Settings)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : PageWidth Property
Set the value in inches to use for the width of the image. The format is an integer or decimal with "in" as the suffix, for example "8in" for 8 inches. The value set in this property overrides the report's settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageWidth As System.String
public System.string PageWidth {get; set;}
See Also

Reference

Settings Class
Settings Members


Pagination Property (Settings)

Pagination Property (Settings)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : Pagination Property
By default, each page of a report is rendered as a separate image. Set this value to False to render the entire report as a single image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Pagination As System.Boolean
public System.bool Pagination {get; set;}
See Also

Reference

Settings Class
Settings Members


PrintLayoutMode Property (Settings)

PrintLayoutMode Property (Settings)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : PrintLayoutMode Property
Select how to lay out the pages of the report in the image.
  • OneLogicalPageOnSinglePhysicalPage
  • TwoLogicalPagesOnSinglePhysicalPage
  • FourLogicalPagesOnSinglePhysicalPage
  • EightLogicalPagesOnSinglePhysicalPage
  • BookletMode (lays the pages out for booklet printing)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrintLayoutMode As PrintLayoutMode
public PrintLayoutMode PrintLayoutMode {get; set;}
See Also

Reference

Settings Class
Settings Members


Quality Property

Quality Property

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : Quality Property
Gets or sets the quality of the report to be rendered as an image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Quality As System.Integer
public System.int Quality {get; set;}
See Also

Reference

Settings Class
Settings Members


SizeToFit Property (Settings)

SizeToFit Property (Settings)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : SizeToFit Property
By default, rendered report pages are not resized to fit within the selected image size. Set this value to True to resize the report pages.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SizeToFit As System.Boolean
public System.bool SizeToFit {get; set;}
See Also

Reference

Settings Class
Settings Members


StartPage Property (Settings)

StartPage Property (Settings)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : StartPage Property
The default value of zero in this and the EndPage properties render all of the report pages to images. Otherwise, set this value to the number of the first page to render.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartPage As System.Integer
public System.int StartPage {get; set;}
See Also

Reference

Settings Class
Settings Members


WatermarkAngle Property (Settings)

WatermarkAngle Property (Settings)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : WatermarkAngle Property
Specify the degree of angle for the watermark text on the image. Valid values range from 0 to 359, where 0 is horizontal, left to right.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WatermarkAngle As System.Single
public System.float WatermarkAngle {get; set;}
See Also

Reference

Settings Class
Settings Members


WatermarkColor Property (Settings)

WatermarkColor Property (Settings)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : WatermarkColor Property
Select a color for the watermark text on the image. The default value for the watermark color is gray, but you can select any Web, System, or Custom color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WatermarkColor As Color
public Color WatermarkColor {get; set;}
See Also

Reference

Settings Class
Settings Members


WatermarkFont Property (Settings)

WatermarkFont Property (Settings)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : WatermarkFont Property
Set the font to use for the watermark to any valid System.Drawing.Font.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WatermarkFont As Font
public Font WatermarkFont {get; set;}
See Also

Reference

Settings Class
Settings Members


WatermarkTitle Property (Settings)

WatermarkTitle Property (Settings)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page Namespace > Settings Class : WatermarkTitle Property
Sets text (i.e. CONFIDENTIAL) to use as the watermark on the image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WatermarkTitle As System.String
public System.string WatermarkTitle {get; set;}
See Also

Reference

Settings Class
Settings Members


GrapeCity.ActiveReports.Export.Image.Page.Renderers Namespace

GrapeCity.ActiveReports.Export.Image.Page.Renderers Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Image.v10 Assembly : GrapeCity.ActiveReports.Export.Image.Page.Renderers Namespace
The GrapeCity.ActiveReports.Export.Page.Renderers namespace contains the information on images to be rendered.
Enumerations
 | Enumeration | Description
Enumeration | Compression | Compression of rendered Tiff image.
Enumeration | ImageType | Represents Image types supported by GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension.
See Also

Reference

GrapeCity.ActiveReports.Export.Image.v10 Assembly


Compression Enumeration

Compression Enumeration

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page.Renderers Namespace : Compression Enumeration
Compression of rendered Tiff image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Compression
   Inherits System.Enum
public enum Compression : System.Enum
Members
Member | Description
Ccitt3 | This uses the CCITT Group 3 compression. This compression format is used mainly in faxes and delivers a Black and White output. The standards of CCITT Group 3 are 1728 x 2376 pixels, and the resolution is 200 x 196 DPI. If the aspect ratio of the report does not meet these standards, a margin gets inserted at the bottom.
Lzw | This uses LZW compression which is a lossless compression and delivers color output.
None | Specifies no compression and delivers color output.
Rle | PackBits compression format that uses the Run-Length Encoding (RLE) compression method and delivers Black and White output.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Image.Page.Renderers.Compression

See Also

Reference

GrapeCity.ActiveReports.Export.Image.Page.Renderers Namespace


ImageType Enumeration

ImageType Enumeration

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Page.Renderers Namespace : ImageType Enumeration
Represents Image types supported by GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ImageType
   Inherits System.Enum
public enum ImageType : System.Enum
Members
Member | Description
BMP | Represents a BMP image type
EMF | Represents a EMF image type
GIF | Represents a GIF image type
JPEG | Represents a JPEG image type
PNG | Represents a PNG image type
TIFF | Represents a TIFF image type
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Image.Page.Renderers.ImageType

See Also

Reference

GrapeCity.ActiveReports.Export.Image.Page.Renderers Namespace


GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace

GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Image.v10 Assembly : GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace
The GrapeCity.ActiveReports.Export.Tiff.Section namespace contains the TIFF export classes.
Classes
 | Class | Description
Class | TiffExport | The ActiveReports Tag Image File Format (TIFF) Export Component.
Class | TiffExportException | The exception thrown when a TiffExport-specific error occurs.
Enumerations
 | Enumeration | Description
Enumeration | CompressionScheme | An enumeration of values which specify the compression scheme used in the resulting TIFF image of the TiffExport component.
See Also

Reference

GrapeCity.ActiveReports.Export.Image.v10 Assembly


TiffExport Class

TiffExport Class
Members Example

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace : TiffExport Class
The ActiveReports Tag Image File Format (TIFF) Export Component.
Object Model
TiffExport Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class TiffExport
   Inherits System.ComponentModel.Component
   Implements GrapeCity.ActiveReports.Export.IDocumentExport, GrapeCity.ActiveReports.Export.IDocumentExportEx
public class TiffExport : System.ComponentModel.Component, GrapeCity.ActiveReports.Export.IDocumentExport, GrapeCity.ActiveReports.Export.IDocumentExportEx
Example
  • Visual Basic
Dim rpt As New SectionReport1()
rpt.Run()
Me.tiffExport1.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.None
'SettingAtheACompressionSchemeAtoANoneAallowsAcolorsAtoAbeAexported
Me.tiffExport1.Export(rpt.Document,Application.StartupPath & "\t.tiff")
  • C#
SectionReport1 rpt = new SectionReport1();
rpt.Run();
this.tiffExport1.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.None;
//SettingAtheACompressionSchemeAToANoneAallowsAcolorsAToAbeAexported
this.tiffExport1.Export(rpt.Document, Application.StartupPath + "\\t.tiff");
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport

See Also

Reference

TiffExport Members
GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace


TiffExport Class Members

TiffExport Class Members
Properties Methods Events

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace : TiffExport Class

The following tables list the members exposed by TiffExport.

Public Constructors
 | Name | Description
Public Constructor | TiffExport Constructor | Initializes a new instance of the TiffExport class.
Top
Public Properties
 | Name | Description
Public Property | CompressionScheme | Sets or returns a value which specifies the compression scheme to be used when exporting a TIFF file.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Dither | Specifies whether the image should be dithered when saving to a black and white output format such as Ccitt4, Ccitt3 or Rle. If the CompressionScheme is set to Lzw or None (indicating color output) this property has no effect.
Public Property | DpiX | Get or set the horizonal resolution value when exporting a TIFF.
Public Property | DpiY | Get or set the vertical resolution value when exporting a TIFF.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | Export | Overloaded. Exports the specified document to TIFF format.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

TiffExport Class
GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace


TiffExport Constructor

TiffExport Constructor

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : TiffExport Constructor
Initializes a new instance of the TiffExport class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public TiffExport()
See Also

Reference

TiffExport Class
TiffExport Members


TiffExport Class Methods

TiffExport Class Methods

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace : TiffExport Class

For a list of all members of this type, see TiffExport members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | Export | Overloaded. Exports the specified document to TIFF format.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

TiffExport Class
GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace


Export Method (TiffExport)

Export Method (TiffExport)
Example

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : Export Method
Exports the specified document to TIFF format.
Overload List
Overload | Description
Export(PageDocument,String) | Exports the specified document to a TIFF file.
Export(PageDocument,String,String) | Exports the specified document to a TIFF file.
Export(PageDocument,Stream) | Exports the specified document to the specified stream in TIFF.
Export(PageDocument,Stream,String) | Exports the specified document to the specified stream in TIFF.
Export(IReport,String,String) | Exports the specified IReport to file
Export(IReport,String) | Exports the specified IReport to file
Export(IReport,Stream) | Exports the specified IReport to stream
Export(IReport,Stream,String) | Exports the specified IReport to stream
Export(SectionDocument,String,String) | Exports the specified range of pages from the document to a TIFF file.
Export(SectionDocument,String) | Exports the specified document to a TIFF file.
Export(SectionDocument,Stream) | Exports the document to the specified stream.
Export(SectionDocument,Stream,String) | Exports the specified range of pages from the document to the specified stream.
Example
  • Visual Basic
Dim rpt As New SectionReport1()
rpt.Run()
Me.tiffExport1.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.None
'SettingAtheACompressionSchemeAtoANoneAallowsAcolorsAtoAbeAexported
Me.tiffExport1.Export(rpt.Document,Application.StartupPath & "\t.tiff")
  • C#
SectionReport1 rpt = new SectionReport1();
rpt.Run();
this.tiffExport1.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.None;
//SettingAtheACompressionSchemeAToANoneAallowsAcolorsAToAbeAexported
this.tiffExport1.Export(rpt.Document, Application.StartupPath + "\\t.tiff");
See Also

Reference

TiffExport Class
TiffExport Members


Export(PageDocument,String) Method

Export(PageDocument,String) Method

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class > Export Method : Export(PageDocument,String) Method
The ActiveReports PageDocument object to export.
The file name and path to save the main html file to.
Exports the specified document to a TIFF file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As System.String _
)
public void Export(
   PageDocument document,
   System.string filePath
)

Parameters

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main html file to.
See Also

Reference

TiffExport Class
TiffExport Members
Overload List


Export(PageDocument,String,String) Method

Export(PageDocument,String,String) Method

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class > Export Method : Export(PageDocument,String,String) Method
The ActiveReports PageDocument object to export.
The file name and path to save the main html file to.
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified document to a TIFF file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As System.String, _
   ByVal pageRange As System.String _
)
public void Export(
   PageDocument document,
   System.string filePath,
   System.string pageRange
)

Parameters

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main html file to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

TiffExport Class
TiffExport Members
Overload List


Export(PageDocument,Stream) Method

Export(PageDocument,Stream) Method

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class > Export Method : Export(PageDocument,Stream) Method
The ActiveReports PageDocument object to export.
The Stream to write the RTF to.
Exports the specified document to the specified stream in TIFF.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal stream As System.IO.Stream _
)
public void Export(
   PageDocument document,
   System.IO.Stream stream
)

Parameters

document
The ActiveReports PageDocument object to export.
stream
The Stream to write the RTF to.
See Also

Reference

TiffExport Class
TiffExport Members
Overload List


Export(PageDocument,Stream,String) Method

Export(PageDocument,Stream,String) Method

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class > Export Method : Export(PageDocument,Stream,String) Method
The ActiveReports PageDocument object to export.
The System.IO.Stream to write the TIFF data to.
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified document to the specified stream in TIFF.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal stream As System.IO.Stream, _
   ByVal pageRange As System.String _
)
public void Export(
   PageDocument document,
   System.IO.Stream stream,
   System.string pageRange
)

Parameters

document
The ActiveReports PageDocument object to export.
stream
The System.IO.Stream to write the TIFF data to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

TiffExport Class
TiffExport Members
Overload List


Export(IReport,String,String) Method

Export(IReport,String,String) Method

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class > Export Method : Export(IReport,String,String) Method
IReport instance to Export
Path to export
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified IReport to file
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal filePath As System.String, _
   ByVal pageRange As System.String _
)
public void Export(
   IReport report,
   System.string filePath,
   System.string pageRange
)

Parameters

report
IReport instance to Export
filePath
Path to export
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

TiffExport Class
TiffExport Members
Overload List


Export(IReport,String) Method

Export(IReport,String) Method

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class > Export Method : Export(IReport,String) Method
IReport instance to Export
Path to export
Exports the specified IReport to file
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal filePath As System.String _
)
public void Export(
   IReport report,
   System.string filePath
)

Parameters

report
IReport instance to Export
filePath
Path to export
See Also

Reference

TiffExport Class
TiffExport Members
Overload List


Export(IReport,Stream) Method

Export(IReport,Stream) Method

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class > Export Method : Export(IReport,Stream) Method
IReport instance to Export
The output stream.
Exports the specified IReport to stream
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal outputStream As System.IO.Stream _
)
public void Export(
   IReport report,
   System.IO.Stream outputStream
)

Parameters

report
IReport instance to Export
outputStream
The output stream.
See Also

Reference

TiffExport Class
TiffExport Members
Overload List


Export(IReport,Stream,String) Method

Export(IReport,Stream,String) Method

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class > Export Method : Export(IReport,Stream,String) Method
IReport instance to Export
The output stream.
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified IReport to stream
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal outputStream As System.IO.Stream, _
   ByVal pageRange As System.String _
)
public void Export(
   IReport report,
   System.IO.Stream outputStream,
   System.string pageRange
)

Parameters

report
IReport instance to Export
outputStream
The output stream.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

TiffExport Class
TiffExport Members
Overload List


Export(SectionDocument,String,String) Method

Export(SectionDocument,String,String) Method
Example

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class > Export Method : Export(SectionDocument,String,String) Method
The ActiveReports object to export.
The file name and path to which to save the TIFF.
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.
Exports the specified range of pages from the document to a TIFF file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As System.String, _
   ByVal pageRange As System.String _
)
public void Export(
   SectionDocument document,
   System.string filePath,
   System.string pageRange
)

Parameters

document
The ActiveReports object to export.
filePath
The file name and path to which to save the TIFF.
pageRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.
Example
  • Visual Basic
Dim rpt As New SectionReport1()
rpt.Run()
Me.tiffExport1.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.None
'SettingAtheACompressionSchemeAtoANoneAallowsAcolorsAtoAbeAexported
Me.tiffExport1.Export(rpt.Document,Application.StartupPath & "\t.tiff", "1-2")
  • C#
SectionReport1 rpt = new SectionReport1();
rpt.Run();
this.tiffExport1.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.None;
//SettingAtheACompressionSchemeAToANoneAallowsAcolorsAToAbeAexported
this.tiffExport1.Export(rpt.Document, Application.StartupPath + "\\t.tiff", "1-2");
See Also

Reference

TiffExport Class
TiffExport Members
Overload List


Export(SectionDocument,String) Method

Export(SectionDocument,String) Method
Example

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class > Export Method : Export(SectionDocument,String) Method
The ActiveReports object to export.
The file name and path to which to save the TIFF.
Exports the specified document to a TIFF file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As System.String _
)
public void Export(
   SectionDocument document,
   System.string filePath
)

Parameters

document
The ActiveReports object to export.
filePath
The file name and path to which to save the TIFF.
Example
  • Visual Basic
Dim rpt As New SectionReport1()
rpt.Run()
Me.tiffExport1.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.None
'SettingAtheACompressionSchemeAtoANoneAallowsAcolorsAtoAbeAexported
Me.tiffExport1.Export(rpt.Document,Application.StartupPath & "\t.tiff")
  • C#
SectionReport1 rpt = new SectionReport1();
rpt.Run();
this.tiffExport1.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.None;
//SettingAtheACompressionSchemeAToANoneAallowsAcolorsAToAbeAexported
this.tiffExport1.Export(rpt.Document, Application.StartupPath + "\\t.tiff");
See Also

Reference

TiffExport Class
TiffExport Members
Overload List


Export(SectionDocument,Stream) Method

Export(SectionDocument,Stream) Method
Example

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class > Export Method : Export(SectionDocument,Stream) Method
The ActiveReports object to export.
The System.IO.Stream to which to save the TIFF.
Exports the document to the specified stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As System.IO.Stream _
)
public void Export(
   SectionDocument document,
   System.IO.Stream outputStream
)

Parameters

document
The ActiveReports object to export.
outputStream
The System.IO.Stream to which to save the TIFF.
Example
  • Visual Basic
Dim rpt As New SectionReport1()
rpt.Run(False)
Response.ContentType="image/tiff"
Dim Astream = New System.IO.MemoryStream()
Response.AddHeader("content-disposition","attachment;filename=temp.tiff")
Me.TiffExport1.Export(rpt.Document,Astream)
Response.AddHeader("Content-Length",Astream.Length.ToString())
Response.BinaryWrite(stream.ToArray())
Response.End()
  • C#
SectionReport1 rpt = new SectionReport1();

try
{
rpt.Run(false);
}
catch(Exception eRunReport)
{
Response.Clear();
Response.Write("<h1>ErrorArunningAreport:</h1>");
Response.Write(eRunReport.ToString());
return;
}
Response.ContentType="image/tiff";
Response.AddHeader("content-disposition","attachment;Afilename=temp.tiff");
GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport T = new GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport();
System.IO.MemoryStream memStream= new System.IO.MemoryStream();
T.Export(rpt.Document,memStream);
Response.AddHeader("Content-Length",memStream.Length.ToString());
Response.BinaryWrite(memStream.ToArray());
Response.End();
See Also

Reference

TiffExport Class
TiffExport Members
Overload List


Export(SectionDocument,Stream,String) Method

Export(SectionDocument,Stream,String) Method
Example

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class > Export Method : Export(SectionDocument,Stream,String) Method
The ActiveReports object to export.
The System.IO.Stream to which to save the TIFF.
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.
Exports the specified range of pages from the document to the specified stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As System.IO.Stream, _
   ByVal pageRange As System.String _
)
public void Export(
   SectionDocument document,
   System.IO.Stream outputStream,
   System.string pageRange
)

Parameters

document
The ActiveReports object to export.
outputStream
The System.IO.Stream to which to save the TIFF.
pageRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.
Example
  • Visual Basic
Dim rpt As New SectionReport1()
rpt.Run(False)
Response.ContentType="image/tiff"
Dim Astream = New System.IO.MemoryStream()
Response.AddHeader("content-disposition","attachment;filename=temp.tiff")
Me.TiffExport1.Export(rpt.Document,Astream,"1-2")
Response.AddHeader("Content-Length",Astream.Length.ToString())
Response.BinaryWrite(Astream.ToArray())
Response.End()
  • C#
SectionReport1 rpt = new SectionReport1();
try
{
rpt.Run(false);
}
catch(Exception eRunReport)
{
Response.Clear();
Response.Write("<h1>Errorrunningreport:</h1>");
Response.Write(eRunReport.ToString());
return;
}
Response.ContentType="image/tiff";
Response.AddHeader("content-disposition","attachment;filename=temp.tiff");
GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport T= new GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport();
System.IO.MemoryStream AmemStream = new System.IO.MemoryStream();
T.Export(rpt.Document,AmemStream, "1-2");
Response.AddHeader("Content-Length",AmemStream.Length.ToString());
Response.BinaryWrite(AmemStream.ToArray());
Response.End();
See Also

Reference

TiffExport Class
TiffExport Members
Overload List


TiffExport Class Properties

TiffExport Class Properties

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace : TiffExport Class

For a list of all members of this type, see TiffExport members.

Public Properties
 | Name | Description
Public Property | CompressionScheme | Sets or returns a value which specifies the compression scheme to be used when exporting a TIFF file.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Dither | Specifies whether the image should be dithered when saving to a black and white output format such as Ccitt4, Ccitt3 or Rle. If the CompressionScheme is set to Lzw or None (indicating color output) this property has no effect.
Public Property | DpiX | Get or set the horizonal resolution value when exporting a TIFF.
Public Property | DpiY | Get or set the vertical resolution value when exporting a TIFF.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

TiffExport Class
GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace


CompressionScheme Property

CompressionScheme Property
Example

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : CompressionScheme Property
Sets or returns a value which specifies the compression scheme to be used when exporting a TIFF file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CompressionScheme As CompressionScheme
public CompressionScheme CompressionScheme {get; set;}

Property Value

CompressionScheme enumeration.
Remarks

The default value for CompressionScheme is Ccitt3, which can be used for 1 color depth, the old standard for faxes. Another enumeration of this property which will produce black and white TIFF files are Ccitt4 and RLE, or run-length encoding.

To export color TIFF files, set the CompressionScheme to None. There is also a new Lzw compression scheme. The new scheme provides a lossless color export for 1, 4 and 8 bit color depths with a smaller footprint, and is based on the Unisys patent on Lzw compression.

Example
  • Visual Basic
Dim rpt As New SectionReport1()
rpt.Run()
Me.tiffExport1.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.None
'Setting the CompressionScheme to None allows colors to be exported
Me.tiffExport1.Export(rpt.Document, Application.StartupPath & "\t.tiff")
  • C#
SectionReport1 rpt = new SectionReport1();
rpt.Run();
this.tiffExport1.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.None;
//Setting the CompressionScheme to None allows colors to be exported
this.tiffExport1.Export(rpt.Document, Application.StartupPath + "\\t.tiff");
See Also

Reference

TiffExport Class
TiffExport Members
CompressionScheme Enumeration


Dither Property (TiffExport)

Dither Property (TiffExport)
Example

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : Dither Property
Specifies whether the image should be dithered when saving to a black and white output format such as Ccitt4, Ccitt3 or Rle. If the CompressionScheme is set to Lzw or None (indicating color output) this property has no effect.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Dither As System.Boolean
public System.bool Dither {get; set;}

Property Value

Boolean. The default value is False.
Example
  • C#
private void btnExport_Click(Object sender, System.EventArgs e)
{
    rptGrapeCity rpt = new rptGrapeCity();
    GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport t = new GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport();
    rpt.Run();
    this.arv.Document = rpt.Document;
    t.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.Ccitt3;
    t.Dither = True;
    t.Export(rpt.Document, Application.StartupPath + "\\t.tiff","1-2");
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnExport.Click
    Dim rpt As New SectionReport
    Dim t As New GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    t.CompressionScheme = GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme.Ccitt3
    t.Dither = True
    t.Export(rpt.Document, Application.StartupPath & "\t.tiff")
End Sub
See Also

Reference

TiffExport Class
TiffExport Members


DpiX Property (TiffExport)

DpiX Property (TiffExport)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : DpiX Property
Get or set the horizonal resolution value when exporting a TIFF.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DpiX As System.Integer
public System.int DpiX {get; set;}
See Also

Reference

TiffExport Class
TiffExport Members


DpiY Property (TiffExport)

DpiY Property (TiffExport)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : DpiY Property
Get or set the vertical resolution value when exporting a TIFF.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DpiY As System.Integer
public System.int DpiY {get; set;}
See Also

Reference

TiffExport Class
TiffExport Members


TiffExportException Class

TiffExportException Class
Members

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace : TiffExportException Class
The exception thrown when a TiffExport-specific error occurs.
Object Model
TiffExportException Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class TiffExportException
   Inherits System.ApplicationException
public class TiffExportException : System.ApplicationException
Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExportException

See Also

Reference

TiffExportException Members
GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace


TiffExportException Class Members

TiffExportException Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace : TiffExportException Class

The following tables list the members exposed by TiffExportException.

Public Constructors
 | Name | Description
Public Constructor | TiffExportException Constructor | Overloaded. Initializes a new instance of the TiffExportException class.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

TiffExportException Class
GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace


TiffExportException Constructor

TiffExportException Constructor

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : TiffExportException Constructor
Initializes a new instance of the TiffExportException class.
Overload List
Overload | Description
TiffExportException Constructor(String) | Initializes a new instance of the TiffExportException class with the specified error message.
TiffExportException Constructor(String,Exception) | Initializes a new instance of the TiffExportException class with the specified error message and a reference to the inner exception that is the cause of this exception.
TiffExportException Constructor(SerializationInfo,StreamingContext) | Initializes a new instance of the TiffExportException class with serialized data.
See Also

Reference

TiffExportException Class
TiffExportException Members


TiffExportException Constructor(String)

TiffExportException Constructor(String)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class > TiffExportException Constructor : TiffExportException Constructor(String)
A message that describes the error.
Initializes a new instance of the TiffExportException class with the specified error message.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String _
)
public TiffExportException(
   System.string message
)

Parameters

message
A message that describes the error.
See Also

Reference

TiffExportException Class
TiffExportException Members
Overload List


TiffExportException Constructor(String,Exception)

TiffExportException Constructor(String,Exception)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class > TiffExportException Constructor : TiffExportException Constructor(String,Exception)
A message that describes the error.
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
Initializes a new instance of the TiffExportException class with the specified error message and a reference to the inner exception that is the cause of this exception.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String, _
   ByVal innerException As System.Exception _
)
public TiffExportException(
   System.string message,
   System.Exception innerException
)

Parameters

message
A message that describes the error.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
See Also

Reference

TiffExportException Class
TiffExportException Members
Overload List


TiffExportException Constructor(SerializationInfo,StreamingContext)

TiffExportException Constructor(SerializationInfo,StreamingContext)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class > TiffExportException Constructor : TiffExportException Constructor(SerializationInfo,StreamingContext)

Holds all the data needed to serialize or deserialize the object.

Describes the source and destination of a given serialized stream, as well as a means for serialization to retain that context and an additional caller-defined context.
Initializes a new instance of the TiffExportException class with serialized data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public TiffExportException(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info

Holds all the data needed to serialize or deserialize the object.

context
Describes the source and destination of a given serialized stream, as well as a means for serialization to retain that context and an additional caller-defined context.
See Also

Reference

TiffExportException Class
TiffExportException Members
Overload List


CompressionScheme Enumeration

CompressionScheme Enumeration

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace : CompressionScheme Enumeration
An enumeration of values which specify the compression scheme used in the resulting TIFF image of the TiffExport component.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum CompressionScheme
   Inherits System.Enum
public enum CompressionScheme : System.Enum
Members
Member | Description
Ccitt3 | This compression method can be used only for 1 color depth, and is used in old standard faxes.
Ccitt4 | This compression method is a successor to Ccitt3.
Lzw | Specifies the LZW compression scheme. This lossless compression can be used for for 1, 4, and 8 bit color depths with a smaller footprint, and is based on the Unisys patent on Lzw compression.
None | Specifies no compression and delivers color output.
Rle | Run-length encoding. This compression method can be used for 1, 4, and 8 bit color depths.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Image.Tiff.Section.CompressionScheme

See Also

Reference

GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace
CompressionScheme Property


GrapeCity.ActiveReports.Export.Pdf Namespace

GrapeCity.ActiveReports.Export.Pdf Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Pdf.v10 Assembly : GrapeCity.ActiveReports.Export.Pdf Namespace
The GrapeCity.ActiveReports.Export.Pdf namespace includes the Enums.ImageInterpolation enumeration.
Enumerations
 | Enumeration | Description
Enumeration | Enums.ImageInterpolation | Interpolation value of images. Allows to enable/disable image interpolation, at the time of exporting the file to PDF.
Remarks

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly


Enums.ImageInterpolation Enumeration

Enums.ImageInterpolation Enumeration

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf Namespace : Enums.ImageInterpolation Enumeration
Interpolation value of images. Allows to enable/disable image interpolation, at the time of exporting the file to PDF.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Enums.ImageInterpolation
   Inherits System.Enum
public enum Enums.ImageInterpolation : System.Enum
Members
Member | Description
Auto | Interpolation is enabled.
None | Interpolation is disabled.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Enums.ImageInterpolation

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf Namespace


GrapeCity.ActiveReports.Export.Pdf.Page Namespace

GrapeCity.ActiveReports.Export.Pdf.Page Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Pdf.v10 Assembly : GrapeCity.ActiveReports.Export.Pdf.Page Namespace
The GrapeCity.ActiveReports.Export.Pdf.Page namspace includes the PDF export controls.
Classes
 | Class | Description
Class | PdfRenderingExtension | GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension implementation used to create a PDF report.
Class | Settings | Settings for PDF Rendering Extension.
Enumerations
 | Enumeration | Description
Enumeration | DisplayMode | Used to specify PdfSettings.DisplayMode.
Enumeration | PdfPermissions | Specifies the permissions available for a PDF document. These values can be combined using a bitwise OR combination.
Enumeration | PdfVersion | Output pdf conformance level. Allows to export to PDF/A.
See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly


PdfRenderingExtension Class

PdfRenderingExtension Class
Members

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace : PdfRenderingExtension Class
GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension implementation used to create a PDF report.
Object Model
PdfRenderingExtension Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class PdfRenderingExtension
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension
public sealed class PdfRenderingExtension : GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension

See Also

Reference

PdfRenderingExtension Members
GrapeCity.ActiveReports.Export.Pdf.Page Namespace


PdfRenderingExtension Class Members

PdfRenderingExtension Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace : PdfRenderingExtension Class

The following tables list the members exposed by PdfRenderingExtension.

Public Constructors
 | Name | Description
Public Constructor | PdfRenderingExtension Constructor | Initializes new instance of PdfRenderingExtension.
Top
Public Properties
 | Name | Description
Public Property | CertificateRawData | Gets or Sets the X.509 certificate byte array to use in the PDF document signature.
Top
Public Methods
 | Name | Description
Public Method | GetSupportedSettings | Overloaded. Returns settings of current PdfRenderingExtension class.
Top
See Also

Reference

PdfRenderingExtension Class
GrapeCity.ActiveReports.Export.Pdf.Page Namespace


PdfRenderingExtension Constructor

PdfRenderingExtension Constructor

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > PdfRenderingExtension Class : PdfRenderingExtension Constructor
Initializes new instance of PdfRenderingExtension.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public PdfRenderingExtension()
See Also

Reference

PdfRenderingExtension Class
PdfRenderingExtension Members


PdfRenderingExtension Class Methods

PdfRenderingExtension Class Methods

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace : PdfRenderingExtension Class

For a list of all members of this type, see PdfRenderingExtension members.

Public Methods
 | Name | Description
Public Method | GetSupportedSettings | Overloaded. Returns settings of current PdfRenderingExtension class.
Top
See Also

Reference

PdfRenderingExtension Class
GrapeCity.ActiveReports.Export.Pdf.Page Namespace


GetSupportedSettings Method (PdfRenderingExtension)

GetSupportedSettings Method (PdfRenderingExtension)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > PdfRenderingExtension Class : GetSupportedSettings Method
Returns settings of current PdfRenderingExtension class.
Overload List
Overload | Description
GetSupportedSettings() | Returns settings of current PdfRenderingExtension instance.
GetSupportedSettings(Boolean) | Returns settings of current PdfRenderingExtension instance.
See Also

Reference

PdfRenderingExtension Class
PdfRenderingExtension Members


GetSupportedSettings() Method

GetSupportedSettings() Method

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > PdfRenderingExtension Class > GetSupportedSettings Method : GetSupportedSettings() Method
Returns settings of current PdfRenderingExtension instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetSupportedSettings() As ISettings
public ISettings GetSupportedSettings()

Return Value

System.Collections.Specialized.NameValueCollection of PdfRenderingExtension settings.
See Also

Reference

PdfRenderingExtension Class
PdfRenderingExtension Members
Overload List


GetSupportedSettings(Boolean) Method

GetSupportedSettings(Boolean) Method

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > PdfRenderingExtension Class > GetSupportedSettings Method : GetSupportedSettings(Boolean) Method
Returns the PDF rendering settings.
Returns settings of current PdfRenderingExtension instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetSupportedSettings( _
   ByVal fpl As System.Boolean _
) As ISettings
public ISettings GetSupportedSettings(
   System.bool fpl
)

Parameters

fpl
Returns the PDF rendering settings.

Return Value

System.Collections.Specialized.NameValueCollection of PdfRenderingExtension settings.
See Also

Reference

PdfRenderingExtension Class
PdfRenderingExtension Members
Overload List


PdfRenderingExtension Class Properties

PdfRenderingExtension Class Properties

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace : PdfRenderingExtension Class

For a list of all members of this type, see PdfRenderingExtension members.

Public Properties
 | Name | Description
Public Property | CertificateRawData | Gets or Sets the X.509 certificate byte array to use in the PDF document signature.
Top
See Also

Reference

PdfRenderingExtension Class
GrapeCity.ActiveReports.Export.Pdf.Page Namespace


CertificateRawData Property

CertificateRawData Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > PdfRenderingExtension Class : CertificateRawData Property
Gets or Sets the X.509 certificate byte array to use in the PDF document signature.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CertificateRawData As System.Byte()
public System.byte[] CertificateRawData {get; set;}
See Also

Reference

PdfRenderingExtension Class
PdfRenderingExtension Members


Settings Class

Settings Class
Members

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace : Settings Class
Settings for PDF Rendering Extension.
Object Model
Settings Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Settings
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
public sealed class Settings : GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Pdf.Page.Settings

See Also

Reference

Settings Members
GrapeCity.ActiveReports.Export.Pdf.Page Namespace


Settings Class Members

Settings Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace : Settings Class

The following tables list the members exposed by Settings.

Public Constructors
 | Name | Description
Public Constructor | Settings Constructor | Initializes a new instance of the Settings class.
Top
Public Properties
 | Name | Description
Public Property | Application | The value that appears for “Application” inside the Document Properties dialog of the PDF viewer application.
Public Property | Author | The name of the person who created the document.
Public Property | CenterWindow | True to position the document’s window in the center of the screen. Default value: false.
Public Property | Columns | The number of columns to set for the report. This value overrides the report's original settings.
Public Property | ColumnSpacing | The column spacing to set for the report. This value overrides the report's original settings.
Public Property | DisplayMode | Specifies how the document should be displayed when opened.
Public Property | DisplayTitle | True if the window’s title bar should display the document title taken from the Title entry in the document information/metadata. If this value is false, the title bar should instead display the name of the PDF file containing the document. Default value: false.
Public Property | DocumentToAddAfterReport | Gets or sets the path to the PDF document that should be inserted to the end of the rendering output.
Public Property | DocumentToAddBeforeReport | Gets or sets the path to the PDF document that should be inserted to the beginning of the rendering output.
Public Property | DpiX | The resolution of the output device in x-direction. The default value is 300.
Public Property | DpiY | The resolution of the output device in y-direction. The default value is 300.
Public Property | Encrypt | Determines whether the document is encrypted or not.
Public Property | EndPage | The last page of the report to render. The default value is the value for StartPage.
Public Property | FallbackFonts | Gets or sets a comma-delimited string of font families to locate missing glyphs from the original font.
Public Property | FitWindow | True to resize the document’s window to fit the size of the first displayed page. Default value: false.
Public Property | HideMenubar | True to hide the viewer application’s menu bar when the document is active. Default value: false.
Public Property | HideToolbar | True to hide the viewer application’s toolbars when the document is active. Default value: false.
Public Property | HideWindowUI | True to hide user interface elements in the document’s window (such as scroll bars and navigation controls), leaving only the document’s contents displayed. Default value: false.
Public Property | ImageInterpolation | Interpolation value of images. Allows to enable/disable image interpolation, when exporting the file to PDF.
Public Property | Keywords | Keywords associated with the document.
Public Property | MarginBottom | The bottom margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Public Property | MarginLeft | The left margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Public Property | MarginRight | The right margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Public Property | MarginTop | The top margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Public Property | OwnerPassword | The owner password that can be entered in the reader that permits full access to the document regardless of the specified user permissions.
Public Property | PageHeight | The page height value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Public Property | PageWidth | The page width value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Public Property | Permissions | Specifies the user permissions for the document. The PdfPermissions values can be combined using a bitwise OR combination.
Public Property | PrintLayoutMode | Specifies layout mode to be used for PDF document.
Public Property | PrintOnOpen | Gets or sets the value indicating whether the document should be printed after open.
Public Property | SignatureCertificateFileName | Gets/sets the signing certificate file name location
Public Property | SignatureCertificatePassword | Gets/sets the signing certificate password
Public Property | SignatureCertificationLevel | Gets/sets type of the signature certification
Public Property | SignatureContact | Gets/sets the signing contact.
Public Property | SignatureDistinguishedNameVisible | Gets/sets value visibility for the Distinguished Name of the certificate. If true, then the value will be written
Public Property | SignatureDistinguishedShowLabel | Gets/sets value, indicating that label for the Distinguished Name of the certificate should be shown
Public Property | SignatureLocation | Gets/sets the signing location.
Public Property | SignatureNameShowLabel | Gets/sets value, indicating that label for the name of the certificate should be shown
Public Property | SignatureNameVisible | Gets/sets value visibility for the name of the certificate. If true, then the value will be written
Public Property | SignatureReason | Gets/sets the signing reason.
Public Property | SignatureSignDate | Gets/sets the sign date. Default value is DateTime.Now
Public Property | SignatureStampBounds | Gets/sets the bounds of the signature
Public Property | SignatureStampCustomText | Gets/sets the custom text that drawn on signature
Public Property | SignatureStampFont | Gets/sets stamp text font
Public Property | SignatureStampImageAlignment | Gets/sets stamp image alignment inside signature
Public Property | SignatureStampImageFileName | Gets/sets the file location for image shown on signature
Public Property | SignatureStampImageRectangle | Gets/sets area where image should be placed. By default entire signature rectangle will be used.
Public Property | SignatureStampPageIndex | Gets/sets index of the page, where signature should be placed
Public Property | SignatureStampTextAlignment | Gets/sets stamp text alignment
Public Property | SignatureStampTextColor | Gets/sets stamp text color
Public Property | SignatureStampTextRectangle | Gets/sets area where text should be placed. By default entire signature area will be used.
Public Property | SignatureTimeStamp | Gets the settings for TSA server
Public Property | SignatureVisibilityType | Gets/sets visible type for the signature
Public Property | SizeToFit | Determines whether PDF pages are fit to the selected paper size or not.
Public Property | StartPage | The first page of the report to render. A value of 0 indicates that all pages are rendered. The default value is 1.
Public Property | Subject | The subject of the document.
Public Property | Title | The document’s title.
Public Property | Use128Bit | True to use 128 bit encryption with full permissions capability. False to use 40 bit encryption with limited permissions. The PdfPermissions.AllowFillIn, PdfPermissions.AllowAccessibleReaders, and PdfPermissions.AllowAssembly permissions require this value to be true.
Public Property | UserPassword | The user password that can be entered in the reader. If this value is left empty, the user will not be prompted for a password, however the user will be restricted by the specified permissions.
Public Property | Version | Sets output PDF version.
Public Property | WatermarkAngle | Specifies watermark angle for PDF document.
Public Property | WatermarkColor | Specifies watermark color for PDF document.
Public Property | WatermarkFont | Specifies watermark font for PDF document.
Public Property | WatermarkTitle | Specifies watermark title for PDF document.
Top
Public Methods
 | Name | Description
Public Method | ApplySettings | Applies any settings passed in the NameValueCollection settings parameters.
Top
See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Pdf.Page Namespace


Settings Constructor

Settings Constructor

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : Settings Constructor
Initializes a new instance of the Settings class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Settings()
See Also

Reference

Settings Class
Settings Members


Settings Class Methods

Settings Class Methods

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace : Settings Class

For a list of all members of this type, see Settings members.

Public Methods
 | Name | Description
Public Method | ApplySettings | Applies any settings passed in the NameValueCollection settings parameters.
Top
See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Pdf.Page Namespace


ApplySettings Method (Settings)

ApplySettings Method (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : ApplySettings Method
a System.Collections.Specialized.NameValueCollection containing the settings for the renderer.
Applies any settings passed in the NameValueCollection settings parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ApplySettings( _
   ByVal settings As System.Collections.Specialized.NameValueCollection _
)
public void ApplySettings(
   System.Collections.Specialized.NameValueCollection settings
)

Parameters

settings
a System.Collections.Specialized.NameValueCollection containing the settings for the renderer.
See Also

Reference

Settings Class
Settings Members


Settings Class Properties

Settings Class Properties

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace : Settings Class

For a list of all members of this type, see Settings members.

Public Properties
 | Name | Description
Public Property | Application | The value that appears for “Application” inside the Document Properties dialog of the PDF viewer application.
Public Property | Author | The name of the person who created the document.
Public Property | CenterWindow | True to position the document’s window in the center of the screen. Default value: false.
Public Property | Columns | The number of columns to set for the report. This value overrides the report's original settings.
Public Property | ColumnSpacing | The column spacing to set for the report. This value overrides the report's original settings.
Public Property | DisplayMode | Specifies how the document should be displayed when opened.
Public Property | DisplayTitle | True if the window’s title bar should display the document title taken from the Title entry in the document information/metadata. If this value is false, the title bar should instead display the name of the PDF file containing the document. Default value: false.
Public Property | DocumentToAddAfterReport | Gets or sets the path to the PDF document that should be inserted to the end of the rendering output.
Public Property | DocumentToAddBeforeReport | Gets or sets the path to the PDF document that should be inserted to the beginning of the rendering output.
Public Property | DpiX | The resolution of the output device in x-direction. The default value is 300.
Public Property | DpiY | The resolution of the output device in y-direction. The default value is 300.
Public Property | Encrypt | Determines whether the document is encrypted or not.
Public Property | EndPage | The last page of the report to render. The default value is the value for StartPage.
Public Property | FallbackFonts | Gets or sets a comma-delimited string of font families to locate missing glyphs from the original font.
Public Property | FitWindow | True to resize the document’s window to fit the size of the first displayed page. Default value: false.
Public Property | HideMenubar | True to hide the viewer application’s menu bar when the document is active. Default value: false.
Public Property | HideToolbar | True to hide the viewer application’s toolbars when the document is active. Default value: false.
Public Property | HideWindowUI | True to hide user interface elements in the document’s window (such as scroll bars and navigation controls), leaving only the document’s contents displayed. Default value: false.
Public Property | ImageInterpolation | Interpolation value of images. Allows to enable/disable image interpolation, when exporting the file to PDF.
Public Property | Keywords | Keywords associated with the document.
Public Property | MarginBottom | The bottom margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Public Property | MarginLeft | The left margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Public Property | MarginRight | The right margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Public Property | MarginTop | The top margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Public Property | OwnerPassword | The owner password that can be entered in the reader that permits full access to the document regardless of the specified user permissions.
Public Property | PageHeight | The page height value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Public Property | PageWidth | The page width value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Public Property | Permissions | Specifies the user permissions for the document. The PdfPermissions values can be combined using a bitwise OR combination.
Public Property | PrintLayoutMode | Specifies layout mode to be used for PDF document.
Public Property | PrintOnOpen | Gets or sets the value indicating whether the document should be printed after open.
Public Property | SignatureCertificateFileName | Gets/sets the signing certificate file name location
Public Property | SignatureCertificatePassword | Gets/sets the signing certificate password
Public Property | SignatureCertificationLevel | Gets/sets type of the signature certification
Public Property | SignatureContact | Gets/sets the signing contact.
Public Property | SignatureDistinguishedNameVisible | Gets/sets value visibility for the Distinguished Name of the certificate. If true, then the value will be written
Public Property | SignatureDistinguishedShowLabel | Gets/sets value, indicating that label for the Distinguished Name of the certificate should be shown
Public Property | SignatureLocation | Gets/sets the signing location.
Public Property | SignatureNameShowLabel | Gets/sets value, indicating that label for the name of the certificate should be shown
Public Property | SignatureNameVisible | Gets/sets value visibility for the name of the certificate. If true, then the value will be written
Public Property | SignatureReason | Gets/sets the signing reason.
Public Property | SignatureSignDate | Gets/sets the sign date. Default value is DateTime.Now
Public Property | SignatureStampBounds | Gets/sets the bounds of the signature
Public Property | SignatureStampCustomText | Gets/sets the custom text that drawn on signature
Public Property | SignatureStampFont | Gets/sets stamp text font
Public Property | SignatureStampImageAlignment | Gets/sets stamp image alignment inside signature
Public Property | SignatureStampImageFileName | Gets/sets the file location for image shown on signature
Public Property | SignatureStampImageRectangle | Gets/sets area where image should be placed. By default entire signature rectangle will be used.
Public Property | SignatureStampPageIndex | Gets/sets index of the page, where signature should be placed
Public Property | SignatureStampTextAlignment | Gets/sets stamp text alignment
Public Property | SignatureStampTextColor | Gets/sets stamp text color
Public Property | SignatureStampTextRectangle | Gets/sets area where text should be placed. By default entire signature area will be used.
Public Property | SignatureTimeStamp | Gets the settings for TSA server
Public Property | SignatureVisibilityType | Gets/sets visible type for the signature
Public Property | SizeToFit | Determines whether PDF pages are fit to the selected paper size or not.
Public Property | StartPage | The first page of the report to render. A value of 0 indicates that all pages are rendered. The default value is 1.
Public Property | Subject | The subject of the document.
Public Property | Title | The document’s title.
Public Property | Use128Bit | True to use 128 bit encryption with full permissions capability. False to use 40 bit encryption with limited permissions. The PdfPermissions.AllowFillIn, PdfPermissions.AllowAccessibleReaders, and PdfPermissions.AllowAssembly permissions require this value to be true.
Public Property | UserPassword | The user password that can be entered in the reader. If this value is left empty, the user will not be prompted for a password, however the user will be restricted by the specified permissions.
Public Property | Version | Sets output PDF version.
Public Property | WatermarkAngle | Specifies watermark angle for PDF document.
Public Property | WatermarkColor | Specifies watermark color for PDF document.
Public Property | WatermarkFont | Specifies watermark font for PDF document.
Public Property | WatermarkTitle | Specifies watermark title for PDF document.
Top
See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Pdf.Page Namespace


Application Property (Settings)

Application Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : Application Property
The value that appears for “Application” inside the Document Properties dialog of the PDF viewer application.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Application As System.String
public System.string Application {get; set;}
See Also

Reference

Settings Class
Settings Members


Author Property (Settings)

Author Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : Author Property
The name of the person who created the document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Author As System.String
public System.string Author {get; set;}
See Also

Reference

Settings Class
Settings Members


CenterWindow Property (Settings)

CenterWindow Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : CenterWindow Property
True to position the document’s window in the center of the screen. Default value: false.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CenterWindow As System.Boolean
public System.bool CenterWindow {get; set;}
See Also

Reference

Settings Class
Settings Members


Columns Property (Settings)

Columns Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : Columns Property
The number of columns to set for the report. This value overrides the report's original settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Columns As System.Integer
public System.int Columns {get; set;}
See Also

Reference

Settings Class
Settings Members


ColumnSpacing Property (Settings)

ColumnSpacing Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : ColumnSpacing Property
The column spacing to set for the report. This value overrides the report's original settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ColumnSpacing As System.String
public System.string ColumnSpacing {get; set;}
See Also

Reference

Settings Class
Settings Members


DisplayMode Property (Settings)

DisplayMode Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : DisplayMode Property
Specifies how the document should be displayed when opened.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DisplayMode As DisplayMode
public DisplayMode DisplayMode {get; set;}
See Also

Reference

Settings Class
Settings Members


DisplayTitle Property (Settings)

DisplayTitle Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : DisplayTitle Property
True if the window’s title bar should display the document title taken from the Title entry in the document information/metadata. If this value is false, the title bar should instead display the name of the PDF file containing the document. Default value: false.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DisplayTitle As System.Boolean
public System.bool DisplayTitle {get; set;}
See Also

Reference

Settings Class
Settings Members


DocumentToAddAfterReport Property

DocumentToAddAfterReport Property
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : DocumentToAddAfterReport Property
Gets or sets the path to the PDF document that should be inserted to the end of the rendering output.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DocumentToAddAfterReport As System.String
public System.string DocumentToAddAfterReport {get; set;}
Example
  • Visual Basic
' Create a new page report
Dim _reportDef As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(Server.MapPath("") + "\PageReport1.rdlx"))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(_reportDef)

' Set the information for the PDF file output.
Dim exportFile1 As String = Server.MapPath("") + "\PDF\" + System.IO.Path.GetRandomFileName + ".pdf"
Dim myFile1 As New System.IO.FileInfo(exportFile1)
Dim settings As New GrapeCity.ActiveReports.Export.Pdf.Page.Settings()
settings = New GrapeCity.ActiveReports.Export.Pdf.Page.Settings()
settings.DocumentToAddAfterReport = exportFile1 'Document to add after report property.

' Set the rendering extension and render the report.
Dim pdfRenderingExtension As New GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension()
Dim _outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(myFile1.Directory, System.IO.Path.GetFileNameWithoutExtension(myFile1.Name))
reportDocument.Render(pdfRenderingExtension, _outputProvider, settings)
  • C#
// Create a new page report
GrapeCity.ActiveReports.PageReport _reportDef = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(Server.MapPath("") + "\\PageReport1.rdlx"));
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(_reportDef);

// Set the information for the PDF file output.
string exportFile1 = Server.MapPath("") + "\\PDF\\" + System.IO.Path.GetRandomFileName + ".pdf";
System.IO.FileInfo myFile1 = new System.IO.FileInfo(exportFile1);
GrapeCity.ActiveReports.Export.Pdf.Page.Settings settings = new GrapeCity.ActiveReports.Export.Pdf.Page.Settings();
settings = new GrapeCity.ActiveReports.Export.Pdf.Page.Settings();
settings.DocumentToAddAfterReport = exportFile1; //Document to add after report property.

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension pdfRenderingExtension = new GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider _outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(myFile1.Directory, System.IO.Path.GetFileNameWithoutExtension(myFile1.Name));
reportDocument.Render(pdfRenderingExtension, _outputProvider, settings);
See Also

Reference

Settings Class
Settings Members


DocumentToAddBeforeReport Property

DocumentToAddBeforeReport Property
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : DocumentToAddBeforeReport Property
Gets or sets the path to the PDF document that should be inserted to the beginning of the rendering output.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DocumentToAddBeforeReport As System.String
public System.string DocumentToAddBeforeReport {get; set;}
Example
  • Visual Basic
' Create a new page report
Dim _reportDef As New GrapeCity.ActiveReports.PageReport(New System.IO.FileInfo(Server.MapPath("") + "\PageReport1.rdlx"))
Dim reportDocument As New GrapeCity.ActiveReports.Document.PageDocument(_reportDef)

' Set the information for the PDF file output.
Dim exportFile1 As String = Server.MapPath("") + "\PDF\" + System.IO.Path.GetRandomFileName + ".pdf"
Dim myFile1 As New System.IO.FileInfo(exportFile1)
Dim settings As New GrapeCity.ActiveReports.Export.Pdf.Page.Settings()
settings = New GrapeCity.ActiveReports.Export.Pdf.Page.Settings()
settings.DocumentToAddBeforeReport = exportFile1 'Document to add before report property.

' Set the rendering extension and render the report.
Dim pdfRenderingExtension As New GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension()
Dim _outputProvider As New GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(myFile1.Directory, System.IO.Path.GetFileNameWithoutExtension(myFile1.Name))
reportDocument.Render(pdfRenderingExtension, _outputProvider, settings)
  • C#
// Create a new page report
GrapeCity.ActiveReports.PageReport _reportDef = new GrapeCity.ActiveReports.PageReport(new System.IO.FileInfo(Server.MapPath("") + "\\PageReport1.rdlx"));
GrapeCity.ActiveReports.Document.PageDocument reportDocument = new GrapeCity.ActiveReports.Document.PageDocument(_reportDef);

// Set the information for the PDF file output.
string exportFile1 = Server.MapPath("") + "\\PDF\\" + System.IO.Path.GetRandomFileName + ".pdf";
System.IO.FileInfo myFile1 = new System.IO.FileInfo(exportFile1);
GrapeCity.ActiveReports.Export.Pdf.Page.Settings settings = new GrapeCity.ActiveReports.Export.Pdf.Page.Settings();
settings = new GrapeCity.ActiveReports.Export.Pdf.Page.Settings();
settings.DocumentToAddBeforeReport = exportFile1; //Document to add before report property.

// Set the rendering extension and render the report.
GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension pdfRenderingExtension = new GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension();
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider _outputProvider = new GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider(myFile1.Directory, System.IO.Path.GetFileNameWithoutExtension(myFile1.Name));
reportDocument.Render(pdfRenderingExtension, _outputProvider, settings);
See Also

Reference

Settings Class
Settings Members


DpiX Property (Settings)

DpiX Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : DpiX Property
The resolution of the output device in x-direction. The default value is 300.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DpiX As System.Single
public System.float DpiX {get; set;}
Remarks
PDF hasn't its own DPI options. So this setting can be obtained throght GrapeCity.ActiveReports.Extensibility.Layout.Features.FeatureResoluton and used for customers rendering (overriding of GrapeCity.ActiveReports.Extensibility.Rendering.Drawing.IGraphicsRenderer.
See Also

Reference

Settings Class
Settings Members


DpiY Property (Settings)

DpiY Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : DpiY Property
The resolution of the output device in y-direction. The default value is 300.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DpiY As System.Single
public System.float DpiY {get; set;}
Remarks
PDF hasn't its own DPI options. So this setting can be obtained throght GrapeCity.ActiveReports.Extensibility.Layout.Features.FeatureResoluton and used for customers rendering (overriding of GrapeCity.ActiveReports.Extensibility.Rendering.Drawing.IGraphicsRenderer.
See Also

Reference

Settings Class
Settings Members


Encrypt Property (Settings)

Encrypt Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : Encrypt Property
Determines whether the document is encrypted or not.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Encrypt As System.Boolean
public System.bool Encrypt {get; set;}
Remarks
You must set this property to true for the document to be encrypted and the permissions enforced.
See Also

Reference

Settings Class
Settings Members


EndPage Property (Settings)

EndPage Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : EndPage Property
The last page of the report to render. The default value is the value for StartPage.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EndPage As System.Integer
public System.int EndPage {get; set;}
See Also

Reference

Settings Class
Settings Members


FallbackFonts Property

FallbackFonts Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : FallbackFonts Property
Gets or sets a comma-delimited string of font families to locate missing glyphs from the original font.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FallbackFonts As System.String
public System.string FallbackFonts {get; set;}
See Also

Reference

Settings Class
Settings Members


FitWindow Property (Settings)

FitWindow Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : FitWindow Property
True to resize the document’s window to fit the size of the first displayed page. Default value: false.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FitWindow As System.Boolean
public System.bool FitWindow {get; set;}
See Also

Reference

Settings Class
Settings Members


HideMenubar Property (Settings)

HideMenubar Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : HideMenubar Property
True to hide the viewer application’s menu bar when the document is active. Default value: false.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HideMenubar As System.Boolean
public System.bool HideMenubar {get; set;}
See Also

Reference

Settings Class
Settings Members


HideToolbar Property (Settings)

HideToolbar Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : HideToolbar Property
True to hide the viewer application’s toolbars when the document is active. Default value: false.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HideToolbar As System.Boolean
public System.bool HideToolbar {get; set;}
See Also

Reference

Settings Class
Settings Members


HideWindowUI Property (Settings)

HideWindowUI Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : HideWindowUI Property
True to hide user interface elements in the document’s window (such as scroll bars and navigation controls), leaving only the document’s contents displayed. Default value: false.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HideWindowUI As System.Boolean
public System.bool HideWindowUI {get; set;}
See Also

Reference

Settings Class
Settings Members


ImageInterpolation Property (Settings)

ImageInterpolation Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : ImageInterpolation Property
Interpolation value of images. Allows to enable/disable image interpolation, when exporting the file to PDF.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ImageInterpolation As Enums.ImageInterpolation
public Enums.ImageInterpolation ImageInterpolation {get; set;}
See Also

Reference

Settings Class
Settings Members


Keywords Property (Settings)

Keywords Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : Keywords Property
Keywords associated with the document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Keywords As System.String
public System.string Keywords {get; set;}
See Also

Reference

Settings Class
Settings Members


MarginBottom Property (Settings)

MarginBottom Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : MarginBottom Property
The bottom margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MarginBottom As System.String
public System.string MarginBottom {get; set;}
See Also

Reference

Settings Class
Settings Members


MarginLeft Property (Settings)

MarginLeft Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : MarginLeft Property
The left margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MarginLeft As System.String
public System.string MarginLeft {get; set;}
See Also

Reference

Settings Class
Settings Members


MarginRight Property (Settings)

MarginRight Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : MarginRight Property
The right margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MarginRight As System.String
public System.string MarginRight {get; set;}
See Also

Reference

Settings Class
Settings Members


MarginTop Property (Settings)

MarginTop Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : MarginTop Property
The top margin value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MarginTop As System.String
public System.string MarginTop {get; set;}
See Also

Reference

Settings Class
Settings Members


OwnerPassword Property (Settings)

OwnerPassword Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : OwnerPassword Property
The owner password that can be entered in the reader that permits full access to the document regardless of the specified user permissions.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OwnerPassword As System.String
public System.string OwnerPassword {get; set;}
See Also

Reference

Settings Class
Settings Members


PageHeight Property (Settings)

PageHeight Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : PageHeight Property
The page height value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageHeight As System.String
public System.string PageHeight {get; set;}
See Also

Reference

Settings Class
Settings Members


PageWidth Property (Settings)

PageWidth Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : PageWidth Property
The page width value, in inches, to set for the report. You must include an integer or decimal value followed by "in" (for example, 1in). This value overrides the report's original settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageWidth As System.String
public System.string PageWidth {get; set;}
See Also

Reference

Settings Class
Settings Members


Permissions Property (Settings)

Permissions Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : Permissions Property
Specifies the user permissions for the document. The PdfPermissions values can be combined using a bitwise OR combination.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Permissions As PdfPermissions
public PdfPermissions Permissions {get; set;}
Remarks
By default all permissions are set/allowed.
See Also

Reference

Settings Class
Settings Members


PrintLayoutMode Property (Settings)

PrintLayoutMode Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : PrintLayoutMode Property
Specifies layout mode to be used for PDF document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrintLayoutMode As PrintLayoutMode
public PrintLayoutMode PrintLayoutMode {get; set;}
See Also

Reference

Settings Class
Settings Members


PrintOnOpen Property

PrintOnOpen Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : PrintOnOpen Property
Gets or sets the value indicating whether the document should be printed after open.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrintOnOpen As System.Boolean
public System.bool PrintOnOpen {get; set;}
See Also

Reference

Settings Class
Settings Members


SignatureCertificateFileName Property

SignatureCertificateFileName Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureCertificateFileName Property
Gets/sets the signing certificate file name location
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SignatureCertificateFileName As System.String
public System.string SignatureCertificateFileName {get; set;}
See Also

Reference

Settings Class
Settings Members


SignatureCertificatePassword Property

SignatureCertificatePassword Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureCertificatePassword Property
Gets/sets the signing certificate password
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SignatureCertificatePassword As System.String
public System.string SignatureCertificatePassword {get; set;}
See Also

Reference

Settings Class
Settings Members


SignatureCertificationLevel Property

SignatureCertificationLevel Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureCertificationLevel Property
Gets/sets type of the signature certification
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SignatureCertificationLevel As System.Nullable(Of CertificationLevel)
public System.Nullable<CertificationLevel> SignatureCertificationLevel {get; set;}
Remarks
This value parsed from string. Possible values: NotCertified, NoChangesAllowed, FormFilling or FormFillingAnnotations
See Also

Reference

Settings Class
Settings Members


SignatureContact Property

SignatureContact Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureContact Property
Gets/sets the signing contact.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SignatureContact As SignatureField(Of String)
public SignatureField<string> SignatureContact {get; set;}
Remarks
This value parsed from strings. Required 'contact' parameter passed via the 'SignatureContact' field. Optional parameters (visible and showLabel) passed via the 'SignatureContactVisible' and the 'SignatureContactShowLabel' fields
See Also

Reference

Settings Class
Settings Members


SignatureDistinguishedNameVisible Property

SignatureDistinguishedNameVisible Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureDistinguishedNameVisible Property
Gets/sets value visibility for the Distinguished Name of the certificate. If true, then the value will be written
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SignatureDistinguishedNameVisible As System.Nullable(Of Boolean)
public System.Nullable<bool> SignatureDistinguishedNameVisible {get; set;}
Remarks
This value parsed from strings.
See Also

Reference

Settings Class
Settings Members


SignatureDistinguishedShowLabel Property

SignatureDistinguishedShowLabel Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureDistinguishedShowLabel Property
Gets/sets value, indicating that label for the Distinguished Name of the certificate should be shown
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SignatureDistinguishedShowLabel As System.Nullable(Of Boolean)
public System.Nullable<bool> SignatureDistinguishedShowLabel {get; set;}
Remarks
This value parsed from strings.
See Also

Reference

Settings Class
Settings Members


SignatureLocation Property

SignatureLocation Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureLocation Property
Gets/sets the signing location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SignatureLocation As System.String
public System.string SignatureLocation {get; set;}
See Also

Reference

Settings Class
Settings Members


SignatureNameShowLabel Property

SignatureNameShowLabel Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureNameShowLabel Property
Gets/sets value, indicating that label for the name of the certificate should be shown
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SignatureNameShowLabel As System.Nullable(Of Boolean)
public System.Nullable<bool> SignatureNameShowLabel {get; set;}
Remarks
This value parsed from strings.
See Also

Reference

Settings Class
Settings Members


SignatureNameVisible Property

SignatureNameVisible Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureNameVisible Property
Gets/sets value visibility for the name of the certificate. If true, then the value will be written
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SignatureNameVisible As System.Nullable(Of Boolean)
public System.Nullable<bool> SignatureNameVisible {get; set;}
Remarks
This value parsed from strings.
See Also

Reference

Settings Class
Settings Members


SignatureReason Property

SignatureReason Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureReason Property
Gets/sets the signing reason.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SignatureReason As System.String
public System.string SignatureReason {get; set;}
See Also

Reference

Settings Class
Settings Members


SignatureSignDate Property

SignatureSignDate Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureSignDate Property
Gets/sets the sign date. Default value is DateTime.Now
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SignatureSignDate As System.String
public System.string SignatureSignDate {get; set;}
Remarks
Value must be a serialized DateTime value
See Also

Reference

Settings Class
Settings Members


SignatureStampBounds Property

SignatureStampBounds Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureStampBounds Property
Gets/sets the bounds of the signature
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SignatureStampBounds As System.Nullable(Of RectangleF)
public System.Nullable<RectangleF> SignatureStampBounds {get; set;}
Remarks
This value parsed from strings. Should be passed as serialized RectangleF struct.
See Also

Reference

Settings Class
Settings Members


SignatureStampCustomText Property

SignatureStampCustomText Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureStampCustomText Property
Gets/sets the custom text that drawn on signature
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SignatureStampCustomText As System.String
public System.string SignatureStampCustomText {get; set;}
See Also

Reference

Settings Class
Settings Members


SignatureStampFont Property

SignatureStampFont Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureStampFont Property
Gets/sets stamp text font
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SignatureStampFont As Font
public Font SignatureStampFont {get; set;}
Remarks
This value parsed from strings. Required 'familyName' parameter passed via the 'SignatureStampFont' field. Optional parameters passed via 'SignatureStampFontStyle', 'SignatureStampFontName', 'SignatureStampFontSize', 'SignatureStampFontCharset', 'SignatureStampFontVerticalText' fields
See Also

Reference

Settings Class
Settings Members


SignatureStampImageAlignment Property

SignatureStampImageAlignment Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureStampImageAlignment Property
Gets/sets stamp image alignment inside signature
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SignatureStampImageAlignment As System.Nullable(Of Alignment)
public System.Nullable<Alignment> SignatureStampImageAlignment {get; set;}
Remarks
This value parsed from strings. Should be passed as serialized Alignment struct.
See Also

Reference

Settings Class
Settings Members


SignatureStampImageFileName Property

SignatureStampImageFileName Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureStampImageFileName Property
Gets/sets the file location for image shown on signature
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SignatureStampImageFileName As System.String
public System.string SignatureStampImageFileName {get; set;}
See Also

Reference

Settings Class
Settings Members


SignatureStampImageRectangle Property

SignatureStampImageRectangle Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureStampImageRectangle Property
Gets/sets area where image should be placed. By default entire signature rectangle will be used.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SignatureStampImageRectangle As System.Nullable(Of RectangleF)
public System.Nullable<RectangleF> SignatureStampImageRectangle {get; set;}
Remarks
This value parsed from strings. Should be passed as serialized RectangleF struct.
See Also

Reference

Settings Class
Settings Members


SignatureStampPageIndex Property

SignatureStampPageIndex Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureStampPageIndex Property
Gets/sets index of the page, where signature should be placed
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SignatureStampPageIndex As System.Nullable(Of Integer)
public System.Nullable<int> SignatureStampPageIndex {get; set;}
Remarks
This value parsed from strings. First page have index 1
See Also

Reference

Settings Class
Settings Members


SignatureStampTextAlignment Property

SignatureStampTextAlignment Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureStampTextAlignment Property
Gets/sets stamp text alignment
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SignatureStampTextAlignment As System.Nullable(Of Alignment)
public System.Nullable<Alignment> SignatureStampTextAlignment {get; set;}
Remarks
This value parsed from strings. Should be passed as serialized Alignment struct.
See Also

Reference

Settings Class
Settings Members


SignatureStampTextColor Property

SignatureStampTextColor Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureStampTextColor Property
Gets/sets stamp text color
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SignatureStampTextColor As System.Nullable(Of Color)
public System.Nullable<Color> SignatureStampTextColor {get; set;}
Remarks
This value parsed from strings. Should be passed as serialized Color struct.
See Also

Reference

Settings Class
Settings Members


SignatureStampTextRectangle Property

SignatureStampTextRectangle Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureStampTextRectangle Property
Gets/sets area where text should be placed. By default entire signature area will be used.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SignatureStampTextRectangle As System.Nullable(Of RectangleF)
public System.Nullable<RectangleF> SignatureStampTextRectangle {get; set;}
Remarks
This value parsed from strings. Should be passed as serialized RectangleF struct.
See Also

Reference

Settings Class
Settings Members


SignatureTimeStamp Property

SignatureTimeStamp Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureTimeStamp Property
Gets the settings for TSA server
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SignatureTimeStamp As TimeStamp
public TimeStamp SignatureTimeStamp {get; set;}
Remarks
This value parsed from strings. Required 'serverUrl' parameter passed via the 'SignatureTimeStamp' field. Optional parameters (user and password) passed via the 'SignatureTimeStampUser' and the 'SignatureTimeStampPassword' fields
See Also

Reference

Settings Class
Settings Members


SignatureVisibilityType Property

SignatureVisibilityType Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SignatureVisibilityType Property
Gets/sets visible type for the signature
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SignatureVisibilityType As VisibilityType
public VisibilityType SignatureVisibilityType {get; set;}
Remarks
This value parsed from string. Default value: Invisible. Possible values: Invisible, Text, Image, ImageText
See Also

Reference

Settings Class
Settings Members


SizeToFit Property (Settings)

SizeToFit Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : SizeToFit Property
Determines whether PDF pages are fit to the selected paper size or not.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SizeToFit As System.Boolean
public System.bool SizeToFit {get; set;}
See Also

Reference

Settings Class
Settings Members


StartPage Property (Settings)

StartPage Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : StartPage Property
The first page of the report to render. A value of 0 indicates that all pages are rendered. The default value is 1.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartPage As System.Integer
public System.int StartPage {get; set;}
See Also

Reference

Settings Class
Settings Members


Subject Property (Settings)

Subject Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : Subject Property
The subject of the document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Subject As System.String
public System.string Subject {get; set;}
See Also

Reference

Settings Class
Settings Members


Title Property (Settings)

Title Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : Title Property
The document’s title.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Title As System.String
public System.string Title {get; set;}
See Also

Reference

Settings Class
Settings Members


Use128Bit Property (Settings)

Use128Bit Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : Use128Bit Property
True to use 128 bit encryption with full permissions capability. False to use 40 bit encryption with limited permissions. The PdfPermissions.AllowFillIn, PdfPermissions.AllowAccessibleReaders, and PdfPermissions.AllowAssembly permissions require this value to be true.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Use128Bit As System.Boolean
public System.bool Use128Bit {get; set;}
Remarks
The default value is true.
See Also

Reference

Settings Class
Settings Members


UserPassword Property (Settings)

UserPassword Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : UserPassword Property
The user password that can be entered in the reader. If this value is left empty, the user will not be prompted for a password, however the user will be restricted by the specified permissions.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UserPassword As System.String
public System.string UserPassword {get; set;}
See Also

Reference

Settings Class
Settings Members


Version Property (Settings)

Version Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : Version Property
Sets output PDF version.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Version As PdfVersion
public PdfVersion Version {get; set;}
See Also

Reference

Settings Class
Settings Members


WatermarkAngle Property (Settings)

WatermarkAngle Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : WatermarkAngle Property
Specifies watermark angle for PDF document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WatermarkAngle As System.Single
public System.float WatermarkAngle {get; set;}
See Also

Reference

Settings Class
Settings Members


WatermarkColor Property (Settings)

WatermarkColor Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : WatermarkColor Property
Specifies watermark color for PDF document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WatermarkColor As Color
public Color WatermarkColor {get; set;}
See Also

Reference

Settings Class
Settings Members


WatermarkFont Property (Settings)

WatermarkFont Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : WatermarkFont Property
Specifies watermark font for PDF document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WatermarkFont As Font
public Font WatermarkFont {get; set;}
See Also

Reference

Settings Class
Settings Members


WatermarkTitle Property (Settings)

WatermarkTitle Property (Settings)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace > Settings Class : WatermarkTitle Property
Specifies watermark title for PDF document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WatermarkTitle As System.String
public System.string WatermarkTitle {get; set;}
See Also

Reference

Settings Class
Settings Members


DisplayMode Enumeration

DisplayMode Enumeration

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace : DisplayMode Enumeration
Used to specify PdfSettings.DisplayMode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DisplayMode
   Inherits System.Enum
public enum DisplayMode : System.Enum
Members
Member | Description
FullScreen | Full-screen mode with no menu bar, window controls, or any other window visible.
None | Neither document outline nor thumbnail images are visible.
Outlines | The document outline is visible.
Thumbs | Thumbnail images are visible. If thumbnails and outline flags are set, thumbnails will be shown.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Page.DisplayMode

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.Page Namespace


PdfPermissions Enumeration

PdfPermissions Enumeration

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace : PdfPermissions Enumeration
Specifies the permissions available for a PDF document. These values can be combined using a bitwise OR combination.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PdfPermissions
   Inherits System.Enum
public enum PdfPermissions : System.Enum
Members
Member | Description
AllowAccessibleReaders | Set to permit extracting the text and graphics of the document for accessibility purposes or otherwise (it is most likely for accessibility reasons, but possibly for other “screen reading” purposes) when it is opened with user access permission. This is revision 3 only permission.
AllowAssembly | Set to permit the following operations when the document is opened with user access permission:Insert, rotate, or delete pages, and create bookmarks or thumbnail images even if AllowModifyContents is false. This is revision 3 only permission.
AllowCopy | Set to permit copying text or graphics from the document when it is opened with user access permission. This is a revision 2 permission.
AllowFillIn | Set to permit filling in form fields in the document when it is opened with user access permission. This is revision 3 only permission.
AllowModifyAnnotations | Set to permit adding or modifying annotations in the document when it is opened with user access permission. This permission is a revision 2 or revision 3 permission. Under revision three, the ability to copy/paste document contents is restricted other than what is specified by bit 10 (AllowAccessibleReaders).
AllowModifyContents | Set to permit modifying the document’s contents when it is opened with user access permission. Text annotations can still be added or modified. This is a revision 2 permission.
AllowPrint | Set to permit printing the document when it is opened with user access permission. This is a revision 2 permission.
Default | The default permissions.
None | You can use this setting alone to specify that none of the other permissions are set. It has no effect if you bitwise or this flag together with the other flags.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Page.PdfPermissions

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.Page Namespace


PdfVersion Enumeration

PdfVersion Enumeration

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Page Namespace : PdfVersion Enumeration
Output pdf conformance level. Allows to export to PDF/A.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PdfVersion
   Inherits System.Enum
public enum PdfVersion : System.Enum
Members
Member | Description
Pdf12 | PDF version 1.2. This is the native file format of Acrobat 3.0.
Pdf13 | PDF version 1.3. This is the native file format of Acrobat 4.0.
Pdf14 | PDF version 1.4. This is the native file format of Acrobat 5.0.
Pdf15 | PDF version 1.5.
Pdf16 | PDF version 1.6.
Pdf17 | PDF version 1.7.
PDFA1a | PDF/A-1a level, see http://en.wikipedia.org/wiki/PDF/A
PDFA1b | PDF/A-1b level, see http://en.wikipedia.org/wiki/PDF/A
PDFA2a | PDF/A-2a level, see http://en.wikipedia.org/wiki/PDF/A
PDFA2b | PDF/A-2b level, see http://en.wikipedia.org/wiki/PDF/A
PDFA2u | PDF/A-2u level, see http://en.wikipedia.org/wiki/PDF/A
PDFA3a | PDF/A-3a level, see http://en.wikipedia.org/wiki/PDF/A
PDFA3b | PDF/A-3b level, see http://en.wikipedia.org/wiki/PDF/A
PDFA3u | PDF/A-3u level, see http://en.wikipedia.org/wiki/PDF/A
PDFUA1 | PDF/UA-1 level, see http://en.wikipedia.org/wiki/PDF/UA
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Page.PdfVersion

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.Page Namespace


GrapeCity.ActiveReports.Export.Pdf.Section Namespace

GrapeCity.ActiveReports.Export.Pdf.Section Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Pdf.v10 Assembly : GrapeCity.ActiveReports.Export.Pdf.Section Namespace
The GrapeCity.ActiveReports.Export.Pdf Section namespace includes PDF export filters.
Classes
 | Class | Description
Class | PdfDocumentOptions | Encapsulates viewer preferences and document information/metadata for an output PDF document.
Class | PdfExport | Provides PDF document creation functionality for ActiveReports documents.
Class | PdfExportException | The exception that is thrown when a nonfatal PdfExport specific application error occurs.
Class | PdfSecurity | Encapsulates the information necessary to provide PDF document security and encryption.
Class | PdfSigningException | Thrown while signing .pdf
Enumerations
 | Enumeration | Description
Enumeration | DisplayMode | Used to specify PdfDocumentOptions.DisplayMode.
Enumeration | ImageQuality | Specifies the quality used for any images that are converted by ActiveReports.
Enumeration | PdfPermissions | Specifies the permissions available for a PDF document. These values can be combined using a bitwise OR combination
Enumeration | PdfVersion | Specifies the file format version of a PDF document.
See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly


PdfDocumentOptions Class

PdfDocumentOptions Class
Members Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfDocumentOptions Class
Encapsulates viewer preferences and document information/metadata for an output PDF document.
Object Model
PdfDocumentOptions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class PdfDocumentOptions
public sealed class PdfDocumentOptions
Example
  • C#
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Options.Application = "Mortimer&#39;s Reporting Software";
p.Options.Author = "Mortimer";
p.Options.CenterWindow = true;
p.Options.DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs;
p.Options.DisplayTitle = true;
p.Options.FitWindow = true;
p.Options.HideMenubar = true;
p.Options.HideToolbar = true;
p.Options.HideWindowUI = true;
p.Options.Keywords = "annual";
  • VB.NET
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
With p.Options
    .Application = "Mortimer&#39;s Reporting Software"
    .Author = "Mortimer"
    .CenterWindow = True
    .DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs
    .DisplayTitle = True
    .FitWindow = True
    .HideMenubar = True
    .HideToolbar = True
    .HideWindowUI = True
    .Keywords = "annual"
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Pdf.Section.PdfDocumentOptions

See Also

Reference

PdfDocumentOptions Members
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfDocumentOptions Class Members

PdfDocumentOptions Class Members
Properties

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfDocumentOptions Class

The following tables list the members exposed by PdfDocumentOptions.

Public Properties
 | Name | Description
Public Property | Application | The value that appears for “Application” inside the Document Properties dialog of the PDF viewer application.
Public Property | Author | The name of the person who created the document.
Public Property | CenterWindow | True to position the document’s window in the center of the screen. Default value: false.
Public Property | DisplayMode | Specifies how the document should be displayed when opened. Default value: DisplayMode.None.
Public Property | DisplayTitle | True if the window’s title bar should display the document title taken from the Title entry in the document information/metadata. If this value is false, the title bar should instead display the name of the PDF file containing the document. Default value: false.
Public Property | FitWindow | True to resize the document’s window to fit the size of the first displayed page. Default value: false.
Public Property | HideMenubar | True to hide the viewer application’s menu bar when the document is active. Default value: false.
Public Property | HideToolbar | True to hide the viewer application’s toolbars when the document is active. Default value: false.
Public Property | HideWindowUI | True to hide user interface elements in the document’s window (such as scroll bars and navigation controls), leaving only the document’s contents displayed. Default value: false.
Public Property | Keywords | Keywords associated with the document.
Public Property | OnlyForPrint | Indicate whether the PDF is only for print.
Public Property | Subject | The subject of the document.
Public Property | Title | The document’s title.
Top
See Also

Reference

PdfDocumentOptions Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfDocumentOptions Class Properties

PdfDocumentOptions Class Properties

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfDocumentOptions Class

For a list of all members of this type, see PdfDocumentOptions members.

Public Properties
 | Name | Description
Public Property | Application | The value that appears for “Application” inside the Document Properties dialog of the PDF viewer application.
Public Property | Author | The name of the person who created the document.
Public Property | CenterWindow | True to position the document’s window in the center of the screen. Default value: false.
Public Property | DisplayMode | Specifies how the document should be displayed when opened. Default value: DisplayMode.None.
Public Property | DisplayTitle | True if the window’s title bar should display the document title taken from the Title entry in the document information/metadata. If this value is false, the title bar should instead display the name of the PDF file containing the document. Default value: false.
Public Property | FitWindow | True to resize the document’s window to fit the size of the first displayed page. Default value: false.
Public Property | HideMenubar | True to hide the viewer application’s menu bar when the document is active. Default value: false.
Public Property | HideToolbar | True to hide the viewer application’s toolbars when the document is active. Default value: false.
Public Property | HideWindowUI | True to hide user interface elements in the document’s window (such as scroll bars and navigation controls), leaving only the document’s contents displayed. Default value: false.
Public Property | Keywords | Keywords associated with the document.
Public Property | OnlyForPrint | Indicate whether the PDF is only for print.
Public Property | Subject | The subject of the document.
Public Property | Title | The document’s title.
Top
See Also

Reference

PdfDocumentOptions Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


Application Property (PdfDocumentOptions)

Application Property (PdfDocumentOptions)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : Application Property
The value that appears for “Application” inside the Document Properties dialog of the PDF viewer application.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Application As System.String
public System.string Application {get; set;}
Example
  • C#
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Options.Application = "Mortimer&#39;s Reporting Software";
p.Options.Author = "Mortimer";
p.Options.CenterWindow = true;
p.Options.DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs;
p.Options.DisplayTitle = true;
p.Options.FitWindow = true;
p.Options.HideMenubar = true;
p.Options.HideToolbar = true;
p.Options.HideWindowUI = true;
p.Options.Keywords = "annual";
  • VB.NET
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
With p.Options
    .Application = "Mortimer&#39;s Reporting Software"
    .Author = "Mortimer"
    .CenterWindow = True
    .DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs
    .DisplayTitle = True
    .FitWindow = True
    .HideMenubar = True
    .HideToolbar = True
    .HideWindowUI = True
    .Keywords = "annual"
See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


Author Property (PdfDocumentOptions)

Author Property (PdfDocumentOptions)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : Author Property
The name of the person who created the document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Author As System.String
public System.string Author {get; set;}
Example
  • C#
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Options.Application = "Mortimer&#39;s Reporting Software";
p.Options.Author = "Mortimer";
p.Options.CenterWindow = true;
p.Options.DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs;
p.Options.DisplayTitle = true;
p.Options.FitWindow = true;
p.Options.HideMenubar = true;
p.Options.HideToolbar = true;
p.Options.HideWindowUI = true;
p.Options.Keywords = "annual";
  • VB.NET
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
With p.Options
    .Application = "Mortimer&#39;s Reporting Software"
    .Author = "Mortimer"
    .CenterWindow = True
    .DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs
    .DisplayTitle = True
    .FitWindow = True
    .HideMenubar = True
    .HideToolbar = True
    .HideWindowUI = True
    .Keywords = "annual"
See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


CenterWindow Property (PdfDocumentOptions)

CenterWindow Property (PdfDocumentOptions)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : CenterWindow Property
True to position the document’s window in the center of the screen. Default value: false.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CenterWindow As System.Boolean
public System.bool CenterWindow {get; set;}
Example
  • C#
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Options.Application = "Mortimer&#39;s Reporting Software";
p.Options.Author = "Mortimer";
p.Options.CenterWindow = true;
p.Options.DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs;
p.Options.DisplayTitle = true;
p.Options.FitWindow = true;
p.Options.HideMenubar = true;
p.Options.HideToolbar = true;
p.Options.HideWindowUI = true;
p.Options.Keywords = "annual";
  • VB.NET
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
With p.Options
    .Application = "Mortimer&#39;s Reporting Software"
    .Author = "Mortimer"
    .CenterWindow = True
    .DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs
    .DisplayTitle = True
    .FitWindow = True
    .HideMenubar = True
    .HideToolbar = True
    .HideWindowUI = True
    .Keywords = "annual"
See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


DisplayMode Property (PdfDocumentOptions)

DisplayMode Property (PdfDocumentOptions)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : DisplayMode Property
Specifies how the document should be displayed when opened. Default value: DisplayMode.None.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DisplayMode As DisplayMode
public DisplayMode DisplayMode {get; set;}
Example
  • C#
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Options.Application = "Mortimer&#39;s Reporting Software";
p.Options.Author = "Mortimer";
p.Options.CenterWindow = true;
p.Options.DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs;
p.Options.DisplayTitle = true;
p.Options.FitWindow = true;
p.Options.HideMenubar = true;
p.Options.HideToolbar = true;
p.Options.HideWindowUI = true;
p.Options.Keywords = "annual";
  • VB.NET
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
With p.Options
    .Application = "Mortimer&#39;s Reporting Software"
    .Author = "Mortimer"
    .CenterWindow = True
    .DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs
    .DisplayTitle = True
    .FitWindow = True
    .HideMenubar = True
    .HideToolbar = True
    .HideWindowUI = True
    .Keywords = "annual"
See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


DisplayTitle Property (PdfDocumentOptions)

DisplayTitle Property (PdfDocumentOptions)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : DisplayTitle Property
True if the window’s title bar should display the document title taken from the Title entry in the document information/metadata. If this value is false, the title bar should instead display the name of the PDF file containing the document. Default value: false.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DisplayTitle As System.Boolean
public System.bool DisplayTitle {get; set;}
Example
  • C#
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Options.Application = "Mortimer&#39;s Reporting Software";
p.Options.Author = "Mortimer";
p.Options.CenterWindow = true;
p.Options.DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs;
p.Options.DisplayTitle = true;
p.Options.FitWindow = true;
p.Options.HideMenubar = true;
p.Options.HideToolbar = true;
p.Options.HideWindowUI = true;
p.Options.Keywords = "annual";
  • VB.NET
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
With p.Options
    .Application = "Mortimer&#39;s Reporting Software"
    .Author = "Mortimer"
    .CenterWindow = True
    .DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs
    .DisplayTitle = True
    .FitWindow = True
    .HideMenubar = True
    .HideToolbar = True
    .HideWindowUI = True
    .Keywords = "annual"
See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


FitWindow Property (PdfDocumentOptions)

FitWindow Property (PdfDocumentOptions)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : FitWindow Property
True to resize the document’s window to fit the size of the first displayed page. Default value: false.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FitWindow As System.Boolean
public System.bool FitWindow {get; set;}
Example
  • C#
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Options.Application = "Mortimer&#39;s Reporting Software";
p.Options.Author = "Mortimer";
p.Options.CenterWindow = true;
p.Options.DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs;
p.Options.DisplayTitle = true;
p.Options.FitWindow = true;
p.Options.HideMenubar = true;
p.Options.HideToolbar = true;
p.Options.HideWindowUI = true;
p.Options.Keywords = "annual";
  • VB.NET
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
With p.Options
    .Application = "Mortimer&#39;s Reporting Software"
    .Author = "Mortimer"
    .CenterWindow = True
    .DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs
    .DisplayTitle = True
    .FitWindow = True
    .HideMenubar = True
    .HideToolbar = True
    .HideWindowUI = True
    .Keywords = "annual"
See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


HideMenubar Property (PdfDocumentOptions)

HideMenubar Property (PdfDocumentOptions)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : HideMenubar Property
True to hide the viewer application’s menu bar when the document is active. Default value: false.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HideMenubar As System.Boolean
public System.bool HideMenubar {get; set;}
Example
  • C#
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Options.Application = "Mortimer&#39;s Reporting Software";
p.Options.Author = "Mortimer";
p.Options.CenterWindow = true;
p.Options.DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs;
p.Options.DisplayTitle = true;
p.Options.FitWindow = true;
p.Options.HideMenubar = true;
p.Options.HideToolbar = true;
p.Options.HideWindowUI = true;
p.Options.Keywords = "annual";
  • VB.NET
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
With p.Options
    .Application = "Mortimer&#39;s Reporting Software"
    .Author = "Mortimer"
    .CenterWindow = True
    .DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs
    .DisplayTitle = True
    .FitWindow = True
    .HideMenubar = True
    .HideToolbar = True
    .HideWindowUI = True
    .Keywords = "annual"
See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


HideToolbar Property (PdfDocumentOptions)

HideToolbar Property (PdfDocumentOptions)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : HideToolbar Property
True to hide the viewer application’s toolbars when the document is active. Default value: false.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HideToolbar As System.Boolean
public System.bool HideToolbar {get; set;}
Example
  • C#
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Options.Application = "Mortimer&#39;s Reporting Software";
p.Options.Author = "Mortimer";
p.Options.CenterWindow = true;
p.Options.DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs;
p.Options.DisplayTitle = true;
p.Options.FitWindow = true;
p.Options.HideMenubar = true;
p.Options.HideToolbar = true;
p.Options.HideWindowUI = true;
p.Options.Keywords = "annual";
  • VB.NET
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
With p.Options
    .Application = "Mortimer&#39;s Reporting Software"
    .Author = "Mortimer"
    .CenterWindow = True
    .DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs
    .DisplayTitle = True
    .FitWindow = True
    .HideMenubar = True
    .HideToolbar = True
    .HideWindowUI = True
    .Keywords = "annual"
See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


HideWindowUI Property (PdfDocumentOptions)

HideWindowUI Property (PdfDocumentOptions)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : HideWindowUI Property
True to hide user interface elements in the document’s window (such as scroll bars and navigation controls), leaving only the document’s contents displayed. Default value: false.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HideWindowUI As System.Boolean
public System.bool HideWindowUI {get; set;}
Example
  • C#
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Options.Application = "Mortimer&#39;s Reporting Software";
p.Options.Author = "Mortimer";
p.Options.CenterWindow = true;
p.Options.DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs;
p.Options.DisplayTitle = true;
p.Options.FitWindow = true;
p.Options.HideMenubar = true;
p.Options.HideToolbar = true;
p.Options.HideWindowUI = true;
p.Options.Keywords = "annual";
  • VB.NET
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
With p.Options
    .Application = "Mortimer&#39;s Reporting Software"
    .Author = "Mortimer"
    .CenterWindow = True
    .DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs
    .DisplayTitle = True
    .FitWindow = True
    .HideMenubar = True
    .HideToolbar = True
    .HideWindowUI = True
    .Keywords = "annual"
See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


Keywords Property (PdfDocumentOptions)

Keywords Property (PdfDocumentOptions)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : Keywords Property
Keywords associated with the document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Keywords As System.String
public System.string Keywords {get; set;}
Example
  • C#
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Options.Application = "Mortimer&#39;s Reporting Software";
p.Options.Author = "Mortimer";
p.Options.CenterWindow = true;
p.Options.DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs;
p.Options.DisplayTitle = true;
p.Options.FitWindow = true;
p.Options.HideMenubar = true;
p.Options.HideToolbar = true;
p.Options.HideWindowUI = true;
p.Options.Keywords = "annual";
  • VB.NET
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
With p.Options
    .Application = "Mortimer&#39;s Reporting Software"
    .Author = "Mortimer"
    .CenterWindow = True
    .DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs
    .DisplayTitle = True
    .FitWindow = True
    .HideMenubar = True
    .HideToolbar = True
    .HideWindowUI = True
    .Keywords = "annual"
See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


OnlyForPrint Property (PdfDocumentOptions)

OnlyForPrint Property (PdfDocumentOptions)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : OnlyForPrint Property
Indicate whether the PDF is only for print.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OnlyForPrint As System.Boolean
public System.bool OnlyForPrint {get; set;}
See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


Subject Property (PdfDocumentOptions)

Subject Property (PdfDocumentOptions)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : Subject Property
The subject of the document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Subject As System.String
public System.string Subject {get; set;}

Property Value

String type.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    rptGrapeCity rpt = new rptGrapeCity();
    GrapeCity.ActiveReports.Export.Pdf.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.PdfExport();
    p.Options.Application = "Mortimer&#39;s Reporting Software";
    p.Options.Author = "Mortimer";
    p.Options.Keywords = "annual";
}
  • Visual Basic
private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
   Dim rpt As New rptDD
   Dim p As New GrapeCity.ActiveReports.Export.Pdf.PdfExport
   With p.Options
       .Application = "Mortimer&#39;s Reporting Software"
       .Author = "Mortimer"
       .Keywords = "annual"
End sub
See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


Title Property (PdfDocumentOptions)

Title Property (PdfDocumentOptions)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfDocumentOptions Class : Title Property
The document’s title.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Title As System.String
public System.string Title {get; set;}
Remarks
String Type.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    rptGrapeCity rpt = New rptGrapeCity();
    GrapeCity.ActiveReports.Export.Pdf.PdfExport p = New GrapeCity.ActiveReports.Export.Pdf.PdfExport();
    p.Options.Application = "Mortimer&#39;s Reporting Software";
    p.Options.Author = "Mortimer";
    p.Options.Keywords = "annual";
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New rptDD
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.PdfExport
    With p.Options
        .Application = "Mortimer&#39;s Reporting Software"
        .Author = "Mortimer"
        .Keywords = "annual"
End sub
See Also

Reference

PdfDocumentOptions Class
PdfDocumentOptions Members


PdfExport Class

PdfExport Class
Members

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfExport Class
Provides PDF document creation functionality for ActiveReports documents.
Object Model
PdfExport Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class PdfExport
   Inherits System.ComponentModel.Component
   Implements GrapeCity.ActiveReports.Export.IDocumentExport, GrapeCity.ActiveReports.Export.IDocumentExportEx
public sealed class PdfExport : System.ComponentModel.Component, GrapeCity.ActiveReports.Export.IDocumentExport, GrapeCity.ActiveReports.Export.IDocumentExportEx
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport

See Also

Reference

PdfExport Members
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfExport Class Members

PdfExport Class Members
Properties Methods Events

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfExport Class

The following tables list the members exposed by PdfExport.

Public Constructors
 | Name | Description
Public Constructor | PdfExport Constructor | Initializes a new instance of the PdfExport class.
Top
Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ConvertMetaToPng | Sets or returns a value indicating whether Windows metafiles are converted to PNG files in the exported PDF document.
Public Property | ExportBookmarks | Sets or returns a value indicating whether bookmarks are exported to the PDF document.
Public Property | FontFallback | Gets or sets a comma-delimited string of font families that will be used to lookup glyphs missing in original font
Public Property | ImageInterpolation | Specifies the images interpolation value.
Public Property | ImageQuality | Specifies the quality used for any images that are converted by ActiveReports. Note that if a JPG image is used in the report, it is written directly to PDF without any conversion. Other image formats may incur a conversion, which this value will effect.
Public Property | ImageResolution | Sets or returns the resolution of images converted from metafiles.
Public Property | NeverEmbedFonts | Sets or returns a comma-delimited string of values indicating fonts that should not be embedded in a PDF document.
Public Property | Options | Returns an object allowing you to specify viewer preferences and document information options for the exported PDF document.
Public Property | Pagination | Gets or sets the value, that indicates whether pagination should be used for resultant PDF document or not.
Public Property | Security | Returns a PdfSecurity object for initializing document encryption and security.
Public Property | Signature | Specifies the signature settings for pdf export
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Version | Sets or returns the version of the PDF format the exported document is saved in.
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | Export | Overloaded. Exports the specified page document to a PDF file.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

PdfExport Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfExport Constructor

PdfExport Constructor

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : PdfExport Constructor
Initializes a new instance of the PdfExport class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public PdfExport()
See Also

Reference

PdfExport Class
PdfExport Members


PdfExport Class Methods

PdfExport Class Methods

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfExport Class

For a list of all members of this type, see PdfExport members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | Export | Overloaded. Exports the specified page document to a PDF file.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

PdfExport Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


Export Method (PdfExport)

Export Method (PdfExport)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : Export Method
Exports the specified page document to a PDF file.
Overload List
Overload | Description
Export(PageDocument,String) | Exports the specified page document to a PDF file.
Export(PageDocument,String,String) | Exports the specified page document to a PDF file.
Export(PageDocument,Stream) | Exports the specified page document to a PDF stream.
Export(PageDocument,Stream,String) | Exports the specified page document to a PDF stream.
Export(IReport,String,String) | Exports the specified IReport to file
Export(IReport,String) | Exports the specified IReport to file
Export(IReport,Stream) | Exports the specified IReport to stream
Export(IReport,Stream,String) | Exports the specified IReport to stream
Export(SectionDocument,String) | Exports the specified document to a PDF file.
Export(SectionDocument,String,String) | Exports the specified document to a PDF file.
Export(SectionDocument,Stream) | Exports the specified document to a PDF stream.
Export(SectionDocument,Stream,String) | Exports the specified document to a PDF stream.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
  • VB.NET
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub
See Also

Reference

PdfExport Class
PdfExport Members


Export(PageDocument,String) Method

Export(PageDocument,String) Method

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class > Export Method : Export(PageDocument,String) Method
The ActiveReports PageDocument object to export.
The file name and path to save the main PDF file to.
Exports the specified page document to a PDF file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As System.String _
)
public void Export(
   PageDocument document,
   System.string filePath
)

Parameters

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main PDF file to.
See Also

Reference

PdfExport Class
PdfExport Members
Overload List


Export(PageDocument,String,String) Method

Export(PageDocument,String,String) Method

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class > Export Method : Export(PageDocument,String,String) Method
The ActiveReports PageDocument object to export.
The file name and path to save the main PDF file to.

A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Exports the specified page document to a PDF file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As System.String, _
   ByVal pageRange As System.String _
)
public void Export(
   PageDocument document,
   System.string filePath,
   System.string pageRange
)

Parameters

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main PDF file to.
pageRange

A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

See Also

Reference

PdfExport Class
PdfExport Members
Overload List


Export(PageDocument,Stream) Method

Export(PageDocument,Stream) Method

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class > Export Method : Export(PageDocument,Stream) Method
The ActiveReports PageDocument object to export.
The stream to save the PDF document to.
Exports the specified page document to a PDF stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal stream As System.IO.Stream _
)
public void Export(
   PageDocument document,
   System.IO.Stream stream
)

Parameters

document
The ActiveReports PageDocument object to export.
stream
The stream to save the PDF document to.
See Also

Reference

PdfExport Class
PdfExport Members
Overload List


Export(PageDocument,Stream,String) Method

Export(PageDocument,Stream,String) Method

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class > Export Method : Export(PageDocument,Stream,String) Method
ActiveReports PageDocument to be exported.
Stream that saves the PDF document.

A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Exports the specified page document to a PDF stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal stream As System.IO.Stream, _
   ByVal pageRange As System.String _
)
public void Export(
   PageDocument document,
   System.IO.Stream stream,
   System.string pageRange
)

Parameters

document
ActiveReports PageDocument to be exported.
stream
Stream that saves the PDF document.
pageRange

A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

See Also

Reference

PdfExport Class
PdfExport Members
Overload List


Export(IReport,String,String) Method

Export(IReport,String,String) Method

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class > Export Method : Export(IReport,String,String) Method
IReport instance to Export
Path to export
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified IReport to file
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal filePath As System.String, _
   ByVal pageRange As System.String _
)
public void Export(
   IReport report,
   System.string filePath,
   System.string pageRange
)

Parameters

report
IReport instance to Export
filePath
Path to export
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

PdfExport Class
PdfExport Members
Overload List


Export(IReport,String) Method

Export(IReport,String) Method

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class > Export Method : Export(IReport,String) Method
IReport instance to Export
Path to export
Exports the specified IReport to file
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal filePath As System.String _
)
public void Export(
   IReport report,
   System.string filePath
)

Parameters

report
IReport instance to Export
filePath
Path to export
See Also

Reference

PdfExport Class
PdfExport Members
Overload List


Export(IReport,Stream) Method

Export(IReport,Stream) Method

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class > Export Method : Export(IReport,Stream) Method
IReport instance to Export
The output stream.
Exports the specified IReport to stream
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal outputStream As System.IO.Stream _
)
public void Export(
   IReport report,
   System.IO.Stream outputStream
)

Parameters

report
IReport instance to Export
outputStream
The output stream.
See Also

Reference

PdfExport Class
PdfExport Members
Overload List


Export(IReport,Stream,String) Method

Export(IReport,Stream,String) Method

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class > Export Method : Export(IReport,Stream,String) Method
IReport instance to Export
The output stream.
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified IReport to stream
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal outputStream As System.IO.Stream, _
   ByVal pageRange As System.String _
)
public void Export(
   IReport report,
   System.IO.Stream outputStream,
   System.string pageRange
)

Parameters

report
IReport instance to Export
outputStream
The output stream.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

PdfExport Class
PdfExport Members
Overload List


Export(SectionDocument,String) Method

Export(SectionDocument,String) Method
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class > Export Method : Export(SectionDocument,String) Method
The ActiveReports GrapeCity.ActiveReports.Document.SectionDocumentDocument object to export.
The file name and path to save the main PDF file to.
Exports the specified document to a PDF file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As System.String _
)
public void Export(
   SectionDocument document,
   System.string filePath
)

Parameters

document
The ActiveReports GrapeCity.ActiveReports.Document.SectionDocumentDocument object to export.
filePath
The file name and path to save the main PDF file to.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
  • VB.NET
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub
See Also

Reference

PdfExport Class
PdfExport Members
Overload List


Export(SectionDocument,String,String) Method

Export(SectionDocument,String,String) Method
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class > Export Method : Export(SectionDocument,String,String) Method
The ActiveReports GrapeCity.ActiveReports.Document.SectionDocumentDocument object to export.
The file name and path to save the main PDF file to.

A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Exports the specified document to a PDF file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As System.String, _
   ByVal pageRange As System.String _
)
public void Export(
   SectionDocument document,
   System.string filePath,
   System.string pageRange
)

Parameters

document
The ActiveReports GrapeCity.ActiveReports.Document.SectionDocumentDocument object to export.
filePath
The file name and path to save the main PDF file to.
pageRange

A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf", "1-3");
}
  • VB.NET
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf", "1-3")
End Sub
See Also

Reference

PdfExport Class
PdfExport Members
Overload List


Export(SectionDocument,Stream) Method

Export(SectionDocument,Stream) Method

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class > Export Method : Export(SectionDocument,Stream) Method
The ActiveReports Document object to export.
System.IO.Stream to save the PDF document.
Exports the specified document to a PDF stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal stream As System.IO.Stream _
)
public void Export(
   SectionDocument document,
   System.IO.Stream stream
)

Parameters

document
The ActiveReports Document object to export.
stream
System.IO.Stream to save the PDF document.
See Also

Reference

PdfExport Class
PdfExport Members
Overload List


Export(SectionDocument,Stream,String) Method

Export(SectionDocument,Stream,String) Method

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class > Export Method : Export(SectionDocument,Stream,String) Method
The ActiveReports Document object to export.
System.IO.Stream to save the PDF document.

A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

Exports the specified document to a PDF stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal stream As System.IO.Stream, _
   ByVal pageRange As System.String _
)
public void Export(
   SectionDocument document,
   System.IO.Stream stream,
   System.string pageRange
)

Parameters

document
The ActiveReports Document object to export.
stream
System.IO.Stream to save the PDF document.
pageRange

A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.

See Also

Reference

PdfExport Class
PdfExport Members
Overload List


PdfExport Class Properties

PdfExport Class Properties

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfExport Class

For a list of all members of this type, see PdfExport members.

Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ConvertMetaToPng | Sets or returns a value indicating whether Windows metafiles are converted to PNG files in the exported PDF document.
Public Property | ExportBookmarks | Sets or returns a value indicating whether bookmarks are exported to the PDF document.
Public Property | FontFallback | Gets or sets a comma-delimited string of font families that will be used to lookup glyphs missing in original font
Public Property | ImageInterpolation | Specifies the images interpolation value.
Public Property | ImageQuality | Specifies the quality used for any images that are converted by ActiveReports. Note that if a JPG image is used in the report, it is written directly to PDF without any conversion. Other image formats may incur a conversion, which this value will effect.
Public Property | ImageResolution | Sets or returns the resolution of images converted from metafiles.
Public Property | NeverEmbedFonts | Sets or returns a comma-delimited string of values indicating fonts that should not be embedded in a PDF document.
Public Property | Options | Returns an object allowing you to specify viewer preferences and document information options for the exported PDF document.
Public Property | Pagination | Gets or sets the value, that indicates whether pagination should be used for resultant PDF document or not.
Public Property | Security | Returns a PdfSecurity object for initializing document encryption and security.
Public Property | Signature | Specifies the signature settings for pdf export
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Version | Sets or returns the version of the PDF format the exported document is saved in.
Top
See Also

Reference

PdfExport Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


ConvertMetaToPng Property (PdfExport)

ConvertMetaToPng Property (PdfExport)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : ConvertMetaToPng Property
Sets or returns a value indicating whether Windows metafiles are converted to PNG files in the exported PDF document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ConvertMetaToPng As System.Boolean
public System.bool ConvertMetaToPng {get; set;}
See Also

Reference

PdfExport Class
PdfExport Members


ExportBookmarks Property (PdfExport)

ExportBookmarks Property (PdfExport)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : ExportBookmarks Property
Sets or returns a value indicating whether bookmarks are exported to the PDF document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ExportBookmarks As System.Boolean
public System.bool ExportBookmarks {get; set;}
Remarks
To control the display method of the bookmarks that have been exported, Options.DisplayMode is used.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    p.ExportBookmarks = false;
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf", "1-3");
}
  • VB.NET
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    p.ExportBookmarks = False
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf", "1-3")
End Sub
See Also

Reference

PdfExport Class
PdfExport Members


FontFallback Property (PdfExport)

FontFallback Property (PdfExport)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : FontFallback Property
Gets or sets a comma-delimited string of font families that will be used to lookup glyphs missing in original font
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontFallback As System.String
public System.string FontFallback {get; set;}
Remarks
This function can only be used with the Professional version.
Note: If you use the Standard version, this setting gets disabled.
If there is a probelm in the output when it is exported to PDF, or if any problems occur with a particular font, then it is a limitation of the product.
See Also

Reference

PdfExport Class
PdfExport Members


ImageInterpolation Property (PdfExport)

ImageInterpolation Property (PdfExport)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : ImageInterpolation Property
Specifies the images interpolation value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ImageInterpolation As Enums.ImageInterpolation
public Enums.ImageInterpolation ImageInterpolation {get; set;}
See Also

Reference

PdfExport Class
PdfExport Members


ImageQuality Property (PdfExport)

ImageQuality Property (PdfExport)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : ImageQuality Property
Specifies the quality used for any images that are converted by ActiveReports. Note that if a JPG image is used in the report, it is written directly to PDF without any conversion. Other image formats may incur a conversion, which this value will effect.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ImageQuality As ImageQuality
public ImageQuality ImageQuality {get; set;}
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    p.ExportBookmarks = false;
    p.ImageResolution = 300;
    p.ImageQuality = GrapeCity.ActiveReports.Export.Pdf.Section.ImageQuality.Highest;
    p.NeverEmbedFonts = "Arial;Times New Roman;Verdana";
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
  • VB.NET
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    p.ExportBookmarks = False
    p.ImageResolution = 300
    p.ImageQuality = GrapeCity.ActiveReports.Export.Pdf.Section.ImageQuality.Highest
    p.NeverEmbedFonts = "Arial;Times New Roman;Verdana"
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub
See Also

Reference

PdfExport Class
PdfExport Members


ImageResolution Property (PdfExport)

ImageResolution Property (PdfExport)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : ImageResolution Property
Sets or returns the resolution of images converted from metafiles.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ImageResolution As System.Integer
public System.int ImageResolution {get; set;}
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    p.ExportBookmarks = false;
    p.ImageResolution = 300;
    p.ImageQuality = GrapeCity.ActiveReports.Export.Pdf.Section.ImageQuality.Highest;
    p.NeverEmbedFonts = "Arial;Times New Roman;Verdana";
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
  • VB.NET
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    p.ExportBookmarks = False
    p.ImageResolution = 300
    p.ImageQuality = GrapeCity.ActiveReports.Export.Pdf.Section.ImageQuality.Highest
    p.NeverEmbedFonts = "Arial;Times New Roman;Verdana"
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub
See Also

Reference

PdfExport Class
PdfExport Members


NeverEmbedFonts Property (PdfExport)

NeverEmbedFonts Property (PdfExport)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : NeverEmbedFonts Property
Sets or returns a comma-delimited string of values indicating fonts that should not be embedded in a PDF document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NeverEmbedFonts As System.String
public System.string NeverEmbedFonts {get; set;}
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    p.ExportBookmarks = false;
    p.ImageResolution = 300;
    p.ImageQuality = GrapeCity.ActiveReports.Export.Pdf.Section.ImageQuality.Highest;
    p.NeverEmbedFonts = "Arial;Times New Roman;Verdana";
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
  • VB.NET
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    p.ExportBookmarks = False
    p.ImageResolution = 300
    p.ImageQuality = GrapeCity.ActiveReports.Export.Pdf.Section.ImageQuality.Highest
    p.NeverEmbedFonts = "Arial;Times New Roman;Verdana"
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub
See Also

Reference

PdfExport Class
PdfExport Members


Options Property

Options Property
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : Options Property
Returns an object allowing you to specify viewer preferences and document information options for the exported PDF document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Options As PdfDocumentOptions
public PdfDocumentOptions Options {get;}
Example
  • C#
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
p.Options.Application = "Mortimer&#39;s Reporting Software";
p.Options.Author = "Mortimer";
p.Options.CenterWindow = true;
p.Options.DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs;
p.Options.DisplayTitle = true;
p.Options.FitWindow = true;
p.Options.HideMenubar = true;
p.Options.HideToolbar = true;
p.Options.HideWindowUI = true;
p.Options.Keywords = "annual";
  • VB.NET
Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
With p.Options
    .Application = "Mortimer&#39;s Reporting Software"
    .Author = "Mortimer"
    .CenterWindow = True
    .DisplayMode = GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode.Thumbs
    .DisplayTitle = True
    .FitWindow = True
    .HideMenubar = True
    .HideToolbar = True
    .HideWindowUI = True
    .Keywords = "annual"
See Also

Reference

PdfExport Class
PdfExport Members


Pagination Property (PdfExport)

Pagination Property (PdfExport)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : Pagination Property
Gets or sets the value, that indicates whether pagination should be used for resultant PDF document or not.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Pagination As System.Boolean
public System.bool Pagination {get; set;}
See Also

Reference

PdfExport Class
PdfExport Members


Security Property (PdfExport)

Security Property (PdfExport)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : Security Property
Returns a PdfSecurity object for initializing document encryption and security.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Security As PdfSecurity
public PdfSecurity Security {get;}
Remarks
You must set the PdfSecurity.Encrypt property to true in order for the document to be encrypted and the permissions enforced.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    p.ExportBookmarks = false;
    p.ImageResolution = 300;
    p.ImageQuality = GrapeCity.ActiveReports.Export.Pdf.Section.ImageQuality.Highest;
    p.NeverEmbedFonts = "Arial;Times New Roman;Verdana";
    p.Security.Encrypt = true;
    p.Security.OwnerPassword = "Mortimer";
    p.Security.UserPassword = "monkey";
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint;
    p.Security.Use128Bit = true;
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
  • VB.NET
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    p.ExportBookmarks = False
    p.ImageResolution = 300
    p.ImageQuality = GrapeCity.ActiveReports.Export.Pdf.Section.ImageQuality.Highest
    p.NeverEmbedFonts = "Arial;Times New Roman;Verdana"
    p.Security.Encrypt = True
    p.Security.OwnerPassword = "Mortimer"
    p.Security.UserPassword = "monkey"
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint
    p.Security.Use128Bit = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub
See Also

Reference

PdfExport Class
PdfExport Members


Signature Property

Signature Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : Signature Property
Specifies the signature settings for pdf export
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Signature As PdfSignature
public PdfSignature Signature {get;}
See Also

Reference

PdfExport Class
PdfExport Members


Version Property (PdfExport)

Version Property (PdfExport)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : Version Property
Sets or returns the version of the PDF format the exported document is saved in.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Version As PdfVersion
public PdfVersion Version {get; set;}
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    p.ExportBookmarks = false;
    p.ImageResolution = 300;
    p.ImageQuality = GrapeCity.ActiveReports.Export.Pdf.Section.ImageQuality.Highest;
    p.NeverEmbedFonts = "Arial;Times New Roman;Verdana";
    p.Version = GrapeCity.ActiveReports.Export.Pdf.Section.PdfVersion.Pdf11;
    p.Security.Encrypt = true;
    p.Security.OwnerPassword = "Mortimer";
    p.Security.UserPassword = "monkey";
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint;
    p.Security.Use128Bit = true;
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
  • VB.NET
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    p.ExportBookmarks = False
    p.ImageResolution = 300
    p.ImageQuality = GrapeCity.ActiveReports.Export.Pdf.Section.ImageQuality.Highest
    p.NeverEmbedFonts = "Arial;Times New Roman;Verdana"
    p.Version = GrapeCity.ActiveReports.Export.Pdf.Section.PdfVersion.Pdf11
    p.Security.Encrypt = True
    p.Security.OwnerPassword = "Mortimer"
    p.Security.UserPassword = "monkey"
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint
    p.Security.Use128Bit = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub
See Also

Reference

PdfExport Class
PdfExport Members


PdfExportException Class

PdfExportException Class
Members

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfExportException Class
The exception that is thrown when a nonfatal PdfExport specific application error occurs.
Object Model
PdfExportException Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class PdfExportException
   Inherits System.ApplicationException
public class PdfExportException : System.ApplicationException
Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExportException

See Also

Reference

PdfExportException Members
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfExportException Class Members

PdfExportException Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfExportException Class

The following tables list the members exposed by PdfExportException.

Public Constructors
 | Name | Description
Public Constructor | PdfExportException Constructor | Overloaded. Initializes a new instance of PdfExportException class.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

PdfExportException Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfExportException Constructor

PdfExportException Constructor

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : PdfExportException Constructor
Initializes a new instance of PdfExportException class.
Overload List
Overload | Description
PdfExportException Constructor() | Initializes a new instance of the PdfExportException class.
PdfExportException Constructor(String) | Initializes a new instance of the PdfExportException class.
PdfExportException Constructor(String,Exception) | Initializes a new instance of the PdfExportException class.
See Also

Reference

PdfExportException Class
PdfExportException Members


PdfExportException Constructor()

PdfExportException Constructor()

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class > PdfExportException Constructor : PdfExportException Constructor()
Initializes a new instance of the PdfExportException class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public PdfExportException()
See Also

Reference

PdfExportException Class
PdfExportException Members
Overload List


PdfExportException Constructor(String)

PdfExportException Constructor(String)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class > PdfExportException Constructor : PdfExportException Constructor(String)
The message to display when the exception is thrown.
Initializes a new instance of the PdfExportException class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String _
)
public PdfExportException(
   System.string message
)

Parameters

message
The message to display when the exception is thrown.
See Also

Reference

PdfExportException Class
PdfExportException Members
Overload List


PdfExportException Constructor(String,Exception)

PdfExportException Constructor(String,Exception)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class > PdfExportException Constructor : PdfExportException Constructor(String,Exception)
The message to display when the exception is thrown.
The exception that is the cause of the current exception. If the inner exception parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
Initializes a new instance of the PdfExportException class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String, _
   ByVal innerException As System.Exception _
)
public PdfExportException(
   System.string message,
   System.Exception innerException
)

Parameters

message
The message to display when the exception is thrown.
innerException
The exception that is the cause of the current exception. If the inner exception parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
See Also

Reference

PdfExportException Class
PdfExportException Members
Overload List


PdfSecurity Class

PdfSecurity Class
Members Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfSecurity Class
Encapsulates the information necessary to provide PDF document security and encryption.
Object Model
PdfSecurity Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class PdfSecurity
public class PdfSecurity
Remarks
If a user password is supplied the viewer application should prompt for a password. If a user password is not supplied no password will be requested to open the document. By correctly supplying either the user password, or the owner password, the user will be able to open the document, decrypt it and display it on the screen. Whether additional operations are allowed on a decrypted document depends on which password (if any) was supplied when the document was opened and on any access restrictions specified using this class's Permissions property.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    p.Security.Encrypt = true;
    p.Security.OwnerPassword = "Mortimer";
    p.Security.UserPassword = "monkey";
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint;
    p.Security.Use128Bit = true;
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
  • VB.NET
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    p.Security.Encrypt = True
    p.Security.OwnerPassword = "Mortimer"
    p.Security.UserPassword = "monkey"
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint
    p.Security.Use128Bit = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Pdf.Section.PdfSecurity

See Also

Reference

PdfSecurity Members
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfSecurity Class Members

PdfSecurity Class Members
Properties

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfSecurity Class

The following tables list the members exposed by PdfSecurity.

Public Properties
 | Name | Description
Public Property | Encrypt | Determines whether the document is encrypted or not.
Public Property | OwnerPassword | The owner password that can be entered in the reader that permits full access to the document regardless of the specified user permissions.
Public Property | Permissions | Specifies the user permissions for the document. The PdfPermissions values can be combined using a bitwise OR combination.
Public Property | Use128Bit | True to use 128 bit encryption with full permissions capability. False to use 40 bit encryption with limited permissions. The PdfPermissions.AllowFillIn, PdfPermissions.AllowAccessibleReaders, and PdfPermissions.AllowAssembly permissions require this value to be true.
Public Property | UserPassword | The user password that can be entered in the reader. If this value is left empty the user will not be prompted for a password, however the user will be restricted by the specified permissions.
Top
See Also

Reference

PdfSecurity Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfSecurity Class Properties

PdfSecurity Class Properties

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfSecurity Class

For a list of all members of this type, see PdfSecurity members.

Public Properties
 | Name | Description
Public Property | Encrypt | Determines whether the document is encrypted or not.
Public Property | OwnerPassword | The owner password that can be entered in the reader that permits full access to the document regardless of the specified user permissions.
Public Property | Permissions | Specifies the user permissions for the document. The PdfPermissions values can be combined using a bitwise OR combination.
Public Property | Use128Bit | True to use 128 bit encryption with full permissions capability. False to use 40 bit encryption with limited permissions. The PdfPermissions.AllowFillIn, PdfPermissions.AllowAccessibleReaders, and PdfPermissions.AllowAssembly permissions require this value to be true.
Public Property | UserPassword | The user password that can be entered in the reader. If this value is left empty the user will not be prompted for a password, however the user will be restricted by the specified permissions.
Top
See Also

Reference

PdfSecurity Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


Encrypt Property (PdfSecurity)

Encrypt Property (PdfSecurity)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSecurity Class : Encrypt Property
Determines whether the document is encrypted or not.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Encrypt As System.Boolean
public System.bool Encrypt {get; set;}
Remarks
You must set this property to true for the document to be encrypted and the permissions enforced.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    p.Security.Encrypt = true;
    p.Security.OwnerPassword = "Mortimer";
    p.Security.UserPassword = "monkey";
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint;
    p.Security.Use128Bit = true;
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
  • VB.NET
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    p.Security.Encrypt = True
    p.Security.OwnerPassword = "Mortimer"
    p.Security.UserPassword = "monkey"
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint
    p.Security.Use128Bit = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub
See Also

Reference

PdfSecurity Class
PdfSecurity Members


OwnerPassword Property (PdfSecurity)

OwnerPassword Property (PdfSecurity)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSecurity Class : OwnerPassword Property
The owner password that can be entered in the reader that permits full access to the document regardless of the specified user permissions.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OwnerPassword As System.String
public System.string OwnerPassword {get; set;}
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    p.Security.Encrypt = true;
    p.Security.OwnerPassword = "Mortimer";
    p.Security.UserPassword = "monkey";
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint;
    p.Security.Use128Bit = true;
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
  • VB.NET
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    p.Security.Encrypt = True
    p.Security.OwnerPassword = "Mortimer"
    p.Security.UserPassword = "monkey"
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint
    p.Security.Use128Bit = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub
See Also

Reference

PdfSecurity Class
PdfSecurity Members


Permissions Property (PdfSecurity)

Permissions Property (PdfSecurity)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSecurity Class : Permissions Property
Specifies the user permissions for the document. The PdfPermissions values can be combined using a bitwise OR combination.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Permissions As PdfPermissions
public PdfPermissions Permissions {get; set;}
Remarks
By default all permissions are set/allowed.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    p.Security.Encrypt = true;
    p.Security.OwnerPassword = "Mortimer";
    p.Security.UserPassword = "monkey";
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint;
    p.Security.Use128Bit = true;
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
  • VB.NET
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    p.Security.Encrypt = True
    p.Security.OwnerPassword = "Mortimer"
    p.Security.UserPassword = "monkey"
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint
    p.Security.Use128Bit = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub
See Also

Reference

PdfSecurity Class
PdfSecurity Members


Use128Bit Property (PdfSecurity)

Use128Bit Property (PdfSecurity)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSecurity Class : Use128Bit Property
True to use 128 bit encryption with full permissions capability. False to use 40 bit encryption with limited permissions. The PdfPermissions.AllowFillIn, PdfPermissions.AllowAccessibleReaders, and PdfPermissions.AllowAssembly permissions require this value to be true.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Use128Bit As System.Boolean
public System.bool Use128Bit {get; set;}
Remarks
The default value is true.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    p.Security.Encrypt = true;
    p.Security.OwnerPassword = "Mortimer";
    p.Security.UserPassword = "monkey";
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint;
    p.Security.Use128Bit = true;
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
  • VB.NET
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    p.Security.Encrypt = True
    p.Security.OwnerPassword = "Mortimer"
    p.Security.UserPassword = "monkey"
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint
    p.Security.Use128Bit = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub
See Also

Reference

PdfSecurity Class
PdfSecurity Members


UserPassword Property (PdfSecurity)

UserPassword Property (PdfSecurity)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSecurity Class : UserPassword Property
The user password that can be entered in the reader. If this value is left empty the user will not be prompted for a password, however the user will be restricted by the specified permissions.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UserPassword As System.String
public System.string UserPassword {get; set;}
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport p = new GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport();
    p.Security.Encrypt = true;
    p.Security.OwnerPassword = "Mortimer";
    p.Security.UserPassword = "monkey";
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint;
    p.Security.Use128Bit = true;
    rpt.Run();
    this.viewer1.Document = rpt.Document;
    p.Export(rpt.Document, Application.StartupPath + "\\p.pdf");
}
  • VB.NET
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim p As New GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
    p.Security.Encrypt = True
    p.Security.OwnerPassword = "Mortimer"
    p.Security.UserPassword = "monkey"
    p.Security.Permissions = GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions.AllowPrint
    p.Security.Use128Bit = True
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    p.Export(rpt.Document, Application.StartupPath & "\p.pdf")
End Sub
See Also

Reference

PdfSecurity Class
PdfSecurity Members


PdfSigningException Class

PdfSigningException Class
Members

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfSigningException Class
Thrown while signing .pdf
Object Model
PdfSigningException Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class PdfSigningException
   Inherits System.ApplicationException
public class PdfSigningException : System.ApplicationException
Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Export.Pdf.Section.PdfSigningException

See Also

Reference

PdfSigningException Members
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfSigningException Class Members

PdfSigningException Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfSigningException Class

The following tables list the members exposed by PdfSigningException.

Public Constructors
 | Name | Description
Public Constructor | PdfSigningException Constructor | Overloaded. Initializes a new instance of PdfSigningException class.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

PdfSigningException Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfSigningException Constructor

PdfSigningException Constructor

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : PdfSigningException Constructor
Initializes a new instance of PdfSigningException class.
Overload List
Overload | Description
PdfSigningException Constructor() | Initializes a new instance of the PdfExportException class.
PdfSigningException Constructor(String) | Initializes a new instance of the PdfExportException class.
PdfSigningException Constructor(String,Exception) | Initializes a new instance of the PdfExportException class.
See Also

Reference

PdfSigningException Class
PdfSigningException Members


PdfSigningException Constructor()

PdfSigningException Constructor()

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class > PdfSigningException Constructor : PdfSigningException Constructor()
Initializes a new instance of the PdfExportException class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public PdfSigningException()
See Also

Reference

PdfSigningException Class
PdfSigningException Members
Overload List


PdfSigningException Constructor(String)

PdfSigningException Constructor(String)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class > PdfSigningException Constructor : PdfSigningException Constructor(String)

The message to display when the exception is thrown.

Initializes a new instance of the PdfExportException class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String _
)
public PdfSigningException(
   System.string message
)

Parameters

message

The message to display when the exception is thrown.

See Also

Reference

PdfSigningException Class
PdfSigningException Members
Overload List


PdfSigningException Constructor(String,Exception)

PdfSigningException Constructor(String,Exception)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class > PdfSigningException Constructor : PdfSigningException Constructor(String,Exception)

The message to display when the exception is thrown.

The exception that is the cause of the current exception. If the inner exception parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Initializes a new instance of the PdfExportException class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String, _
   ByVal innerException As System.Exception _
)
public PdfSigningException(
   System.string message,
   System.Exception innerException
)

Parameters

message

The message to display when the exception is thrown.

innerException

The exception that is the cause of the current exception. If the inner exception parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

PdfSigningException Class
PdfSigningException Members
Overload List


DisplayMode Enumeration

DisplayMode Enumeration

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : DisplayMode Enumeration
Used to specify PdfDocumentOptions.DisplayMode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DisplayMode
   Inherits System.Enum
public enum DisplayMode : System.Enum
Members
Member | Description
FullScreen | Displays the exported PDF using the Full Screen. Bookmarks are not displayed until opened by the user.
None | Default value for DisplayMode. Bookmarks are not displayed until opened by the user.
Outlines | Shows bookmarks in Outline format.
Thumbs | Shows Bookmarks as thumbnail views of the pages of the exported PDF.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Section.DisplayMode

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.Section Namespace


ImageQuality Enumeration

ImageQuality Enumeration

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : ImageQuality Enumeration
Specifies the quality used for any images that are converted by ActiveReports.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ImageQuality
   Inherits System.Enum
public enum ImageQuality : System.Enum
Members
Member | Description
Highest | Exports Windows metafiles at the highest quality level. (Best for printing.)
Lowest | Exports Windows metafiles at the lowest quality level. (Used to save space.)
Medium | Exports Windows metafiles at a medium quality level. (For normal screen viewing.)
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Section.ImageQuality

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfPermissions Enumeration

PdfPermissions Enumeration

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfPermissions Enumeration
Specifies the permissions available for a PDF document. These values can be combined using a bitwise OR combination
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PdfPermissions
   Inherits System.Enum
public enum PdfPermissions : System.Enum
Members
Member | Description
AllowAccessibleReaders | Allows the user to open the PDF in a variety of devices, including hand-held computers and screen readers. Value is 512. The PdfSecurity.Use128Bit property must be set to True for this setting to function.
AllowAssembly | Allows insertion, deletion, or rotation of pages and creation of bookmarks and thumbnails even if AllowModifyContents hasn't been specified. Value is 1024. The PdfSecurity.Use128Bit property must be set to True for this setting to function.
AllowCopy | Allows the user to copy from the PDF file. Value is 16.
AllowFillIn | Allows the user to fill in a PDF form. Value is 256. The PdfSecurity.Use128Bit property must be set to True for this setting to function.
AllowModifyAnnotations | Allows the user to modify annotations in the PDF. Value is 32.
AllowModifyContents | Allows the user to modify the contents of the PDF. Value is 8.
AllowPrint | Allows the user to print the PDF. Value is 4.
None | Allows the user to read the PDF file, but not to modify it in any way. Value is 0.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Section.PdfPermissions

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfVersion Enumeration

PdfVersion Enumeration

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfVersion Enumeration
Specifies the file format version of a PDF document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PdfVersion
   Inherits System.Enum
public enum PdfVersion : System.Enum
Members
Member | Description
Pdf11 | PDF version 1.1. Suitable for legacy viewers.
Pdf12 | PDF version 1.2. This is the native file format of Acrobat 3.0.
Pdf13 | PDF version 1.3. This is the native file format of Acrobat 4.0.
Pdf14 | PDF version 1.4.
Pdf15 | PDF version 1.5.
Pdf16 | PDF version 1.6.
Pdf17 | PDF version 1.7.
PDFA1a | PDF/A-1a level, see http://en.wikipedia.org/wiki/PDF/A
PDFA1b | PDF/A-1b level, see http://en.wikipedia.org/wiki/PDF/A
PDFA2a | PDF/A-2a level, see http://en.wikipedia.org/wiki/PDF/A
PDFA2b | PDF/A-2b level, see http://en.wikipedia.org/wiki/PDF/A
PDFA2u | PDF/A-2u level, see http://en.wikipedia.org/wiki/PDF/A
PDFA3a | PDF/A-3a level, see http://en.wikipedia.org/wiki/PDF/A
PDFA3b | PDF/A-3b level, see http://en.wikipedia.org/wiki/PDF/A
PDFA3u | PDF/A-3u level, see http://en.wikipedia.org/wiki/PDF/A
PDFUA1 | PDF/UA-1 level, see http://en.wikipedia.org/wiki/PDF/UA
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Section.PdfVersion

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.Section Namespace


GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace

GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Pdf.v10 Assembly : GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace
This function is only supported in the Professional version.
In the Standard version, a banner indicating that a Professional license is required to output the PDF, is displayed.
Classes
 | Class | Description
Class | PdfSignature | Encapsulates the information necessary to provide PDF document digital signatures and certification.
Class | PdfStamp | Encapsulates the information necessary to draw PDF document digital signatures and certification on documents.
Class | SignatureField<T> | Class wrapper, provides additional fields to values which should be placed on signature
Class | TimeStamp | Encapsulates the information necessary to include timestamps from a Time Stamping Authority in digital signatures on PDF documents.
Enumerations
 | Enumeration | Description
Enumeration | Alignment | Sets the type of alignment to use for text or images.
Enumeration | CertificationLevel | Enumerates possible certification types
Enumeration | VisibilityType | Sets a value indicating whether and how to display certification on the document.
Remarks
Note: In case of exporting to a PDF document that is encrypted, an electronic signature cannot be added.
See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly


PdfSignature Class

PdfSignature Class
Members

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : PdfSignature Class
Encapsulates the information necessary to provide PDF document digital signatures and certification.
Object Model
PdfSignature Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class PdfSignature
public sealed class PdfSignature
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Pdf.Section.Signing.PdfSignature

See Also

Reference

PdfSignature Members
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


PdfSignature Class Members

PdfSignature Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : PdfSignature Class

The following tables list the members exposed by PdfSignature.

Public Properties
 | Name | Description
Public Property | Certificate | Gets or sets the X.509 certificate to use in the signature.
Public Property | CertificationLevel | Sets an enumerated Allowed Actions value as in the Save as Certified Document wizard in Adobe Acrobat.
Public Property | Contact | Gets or sets signer's contact information. For example, phone number.
Public Property | DistinguishedName | Gets the distinguished name to display in the signature.
Public Property | Location | Gets or sets the location. For example, city name.
Public Property | Name | The name to display in the signed by field.
Public Property | Reason | Allows you to add a reason for digitally signing the document.
Public Property | SignDate | Gets or sets the date on with the document is signed.
Public Property | Stamp | Gets the PdfStamp object used in the signature.
Public Property | TimeStamp | Gets or sets the TimeStamp object to use in the signature.
Public Property | VisibilityType | Gets or sets an enumerated value indicating whether and how to display certification on the document.
Top
Public Methods
 | Name | Description
Public Method | Clone | Clones current signatures
Top
See Also

Reference

PdfSignature Class
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


PdfSignature Class Methods

PdfSignature Class Methods

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : PdfSignature Class

For a list of all members of this type, see PdfSignature members.

Public Methods
 | Name | Description
Public Method | Clone | Clones current signatures
Top
See Also

Reference

PdfSignature Class
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


Clone Method (PdfSignature)

Clone Method (PdfSignature)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfSignature Class : Clone Method
Clones current signatures
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Clone() As System.Object
public System.object Clone()

Return Value

Copy of the current signature
See Also

Reference

PdfSignature Class
PdfSignature Members


PdfSignature Class Properties

PdfSignature Class Properties

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : PdfSignature Class

For a list of all members of this type, see PdfSignature members.

Public Properties
 | Name | Description
Public Property | Certificate | Gets or sets the X.509 certificate to use in the signature.
Public Property | CertificationLevel | Sets an enumerated Allowed Actions value as in the Save as Certified Document wizard in Adobe Acrobat.
Public Property | Contact | Gets or sets signer's contact information. For example, phone number.
Public Property | DistinguishedName | Gets the distinguished name to display in the signature.
Public Property | Location | Gets or sets the location. For example, city name.
Public Property | Name | The name to display in the signed by field.
Public Property | Reason | Allows you to add a reason for digitally signing the document.
Public Property | SignDate | Gets or sets the date on with the document is signed.
Public Property | Stamp | Gets the PdfStamp object used in the signature.
Public Property | TimeStamp | Gets or sets the TimeStamp object to use in the signature.
Public Property | VisibilityType | Gets or sets an enumerated value indicating whether and how to display certification on the document.
Top
See Also

Reference

PdfSignature Class
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


Certificate Property

Certificate Property
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfSignature Class : Certificate Property
Gets or sets the X.509 certificate to use in the signature.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Certificate As System.Security.Cryptography.X509Certificates.X509Certificate2
public System.Security.Cryptography.X509Certificates.X509Certificate2 Certificate {get; set;}
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

In the code example above, replace the path and filename and password of the Certificate with your certificate information, and replace the time stamping authority (TSA) URL with that of your TSA.

Note: You must purchase a volume-based registration at an actual TSA for your applications

Example
  • Visual Basic
' Text signature.
Me.PdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text
Me.PdfExport1.Signature.Stamp.Bounds = New RectangleF(1, 1, 4, 2)
Me.PdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left

' Set certificate & password.
Me.PdfExport1.Signature.Certificate = New Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath & "\..\..\certificate.pfx", "password")

' Signature items.
Me.PdfExport1.Signature.SignDate = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of Date)(System.DateTime.Now, True)
Me.PdfExport1.Signature.Contact = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("ar10@grapecity.com", True)
Me.PdfExport1.Signature.Reason = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("I agree.", True)
Me.PdfExport1.Signature.Location = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("Japan", True)

' Time stamp.
Me.PdfExport1.Signature.TimeStamp = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null")
Me.PdfExport1.Export(rpt.Document, Application.StartupPath & "\..\..\TimeStamped.pdf")
  • C#
this.pdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text;
this.pdfExport1.Signature.Stamp.Bounds = new RectangleF(1, 1, 4, 2);
this.pdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left;

// Set certificate & password.
this.pdfExport1.Signature.Certificate = new System.Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath + "\\..\\..\\certificate.pfx", "password");

// Signature items.
this.pdfExport1.Signature.SignDate = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<System.DateTime>(System.DateTime.Now, true);
this.pdfExport1.Signature.Contact = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("ar10@grapecity.com", true);
this.pdfExport1.Signature.Reason = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("I agree.", true);
this.pdfExport1.Signature.Location = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("Japan", true);

// Time stamp.
this.pdfExport1.Signature.TimeStamp = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null");
this.pdfExport1.Export(rpt.Document, Application.StartupPath + "\\..\\..\\TimeStamped.pdf");
See Also

Reference

PdfSignature Class
PdfSignature Members


CertificationLevel Property

CertificationLevel Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfSignature Class : CertificationLevel Property
Sets an enumerated Allowed Actions value as in the Save as Certified Document wizard in Adobe Acrobat.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CertificationLevel As CertificationLevel
public CertificationLevel CertificationLevel {get; set;}
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

See Also

Reference

PdfSignature Class
PdfSignature Members


Contact Property

Contact Property
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfSignature Class : Contact Property
Gets or sets signer's contact information. For example, phone number.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Contact As SignatureField(Of String)
public SignatureField<string> Contact {get; set;}
Remarks

In Adobe Acrobat, this is an optional field. This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

In the code example above, replace the path and filename and password of the Certificate with your certificate information, and replace the time stamping authority (TSA) URL with that of your TSA.

Note: You must purchase a volume-based registration at an actual TSA for your applications.

Example
  • Visual Basic
' Text signature.
Me.PdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text
Me.PdfExport1.Signature.Stamp.Bounds = New RectangleF(1, 1, 4, 2)
Me.PdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left

' Set certificate & password.
Me.PdfExport1.Signature.Certificate = New Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath & "\..\..\certificate.pfx", "password")

' Signature items.
Me.PdfExport1.Signature.SignDate = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of Date)(System.DateTime.Now, True)
Me.PdfExport1.Signature.Contact = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("ar10@grapecity.com", True)
Me.PdfExport1.Signature.Reason = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("I agree.", True)
Me.PdfExport1.Signature.Location = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("Japan", True)

' Time stamp.
Me.PdfExport1.Signature.TimeStamp = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null")
Me.PdfExport1.Export(rpt.Document, Application.StartupPath & "\..\..\TimeStamped.pdf")
  • C#
this.pdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text;
this.pdfExport1.Signature.Stamp.Bounds = new RectangleF(1, 1, 4, 2);
this.pdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left;

// Set certificate & password.
this.pdfExport1.Signature.Certificate = new System.Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath + "\\..\\..\\certificate.pfx", "password");

// Signature items.
this.pdfExport1.Signature.SignDate = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<System.DateTime>(System.DateTime.Now, true);
this.pdfExport1.Signature.Contact = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("ar10@grapecity.com", true);
this.pdfExport1.Signature.Reason = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("I agree.", true);
this.pdfExport1.Signature.Location = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("Japan", true);

// Time stamp.
this.pdfExport1.Signature.TimeStamp = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null");
this.pdfExport1.Export(rpt.Document, Application.StartupPath + "\\..\\..\\TimeStamped.pdf");
See Also

Reference

PdfSignature Class
PdfSignature Members


DistinguishedName Property

DistinguishedName Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfSignature Class : DistinguishedName Property
Gets the distinguished name to display in the signature.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DistinguishedName As SignatureField(Of String)
public SignatureField<string> DistinguishedName {get;}
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

See Also

Reference

PdfSignature Class
PdfSignature Members


Location Property (PdfSignature)

Location Property (PdfSignature)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfSignature Class : Location Property
Gets or sets the location. For example, city name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Location As SignatureField(Of String)
public SignatureField<string> Location {get; set;}
Remarks

In Adobe Acrobat, this is an optional field. This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

In the code example above, replace the path and filename and password of the Certificate with your certificate information, and replace the time stamping authority (TSA) URL with that of your TSA.

Note: You must purchase a volume-based registration at an actual TSA for your applications.

Example
  • Visual Basic
' Text signature.
Me.PdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text
Me.PdfExport1.Signature.Stamp.Bounds = New RectangleF(1, 1, 4, 2)
Me.PdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left

' Set certificate & password.
Me.PdfExport1.Signature.Certificate = New Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath & "\..\..\certificate.pfx", "password")

' Signature items.
Me.PdfExport1.Signature.SignDate = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of Date)(System.DateTime.Now, True)
Me.PdfExport1.Signature.Contact = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("ar10@grapecity.com", True)
Me.PdfExport1.Signature.Reason = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("I agree.", True)
Me.PdfExport1.Signature.Location = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("Japan", True)

' Time stamp.
Me.PdfExport1.Signature.TimeStamp = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null")
Me.PdfExport1.Export(rpt.Document, Application.StartupPath & "\..\..\TimeStamped.pdf")
  • C#
this.pdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text;
this.pdfExport1.Signature.Stamp.Bounds = new RectangleF(1, 1, 4, 2);
this.pdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left;

// Set certificate & password.
this.pdfExport1.Signature.Certificate = new System.Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath + "\\..\\..\\certificate.pfx", "password");

// Signature items.
this.pdfExport1.Signature.SignDate = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<System.DateTime>(System.DateTime.Now, true);
this.pdfExport1.Signature.Contact = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("ar10@grapecity.com", true);
this.pdfExport1.Signature.Reason = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("I agree.", true);
this.pdfExport1.Signature.Location = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("Japan", true);

// Time stamp.
this.pdfExport1.Signature.TimeStamp = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null");
this.pdfExport1.Export(rpt.Document, Application.StartupPath + "\\..\\..\\TimeStamped.pdf");
See Also

Reference

PdfSignature Class
PdfSignature Members


Name Property (PdfSignature)

Name Property (PdfSignature)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfSignature Class : Name Property
The name to display in the signed by field.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Name As SignatureField(Of String)
public SignatureField<string> Name {get;}
Remarks

The Name is displayed with the text "Signed by." This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

See Also

Reference

PdfSignature Class
PdfSignature Members


Reason Property

Reason Property
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfSignature Class : Reason Property
Allows you to add a reason for digitally signing the document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Reason As SignatureField(Of String)
public SignatureField<string> Reason {get; set;}
Remarks

In the Adobe Acrobat Save as Certified Document wizard, the following reasons can be selected:

  • I am the author of this document
  • I have reviewed this document
  • I am approving this document
  • I attest to the accuracy and integrity of this document
  • I agree to the terms defined by the placement of my signature on this document
  • I agree to 'specified' portions of this document

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

In the code example above, replace the path and filename and password of the Certificate with your certificate information, and replace the time stamping authority (TSA) URL with that of your TSA.

Note: You must purchase a volume-based registration at an actual TSA for your applications.

Example
  • Visual Basic
' Text signature.
Me.PdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text
Me.PdfExport1.Signature.Stamp.Bounds = New RectangleF(1, 1, 4, 2)
Me.PdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left

' Set certificate & password.
Me.PdfExport1.Signature.Certificate = New Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath & "\..\..\certificate.pfx", "password")

' Signature items.
Me.PdfExport1.Signature.SignDate = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of Date)(System.DateTime.Now, True)
Me.PdfExport1.Signature.Contact = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("ar10@grapecity.com", True)
Me.PdfExport1.Signature.Reason = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("I agree.", True)
Me.PdfExport1.Signature.Location = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("Japan", True)

' Time stamp.
Me.PdfExport1.Signature.TimeStamp = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null")
Me.PdfExport1.Export(rpt.Document, Application.StartupPath & "\..\..\TimeStamped.pdf")
  • C#
this.pdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text;
this.pdfExport1.Signature.Stamp.Bounds = new RectangleF(1, 1, 4, 2);
this.pdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left;

// Set certificate & password.
this.pdfExport1.Signature.Certificate = new System.Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath + "\\..\\..\\certificate.pfx", "password");

// Signature items.
this.pdfExport1.Signature.SignDate = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<System.DateTime>(System.DateTime.Now, true);
this.pdfExport1.Signature.Contact = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("ar10@grapecity.com", true);
this.pdfExport1.Signature.Reason = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("I agree.", true);
this.pdfExport1.Signature.Location = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("Japan", true);

// Time stamp.
this.pdfExport1.Signature.TimeStamp = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null");
this.pdfExport1.Export(rpt.Document, Application.StartupPath + "\\..\\..\\TimeStamped.pdf");
See Also

Reference

PdfSignature Class
PdfSignature Members


SignDate Property

SignDate Property
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfSignature Class : SignDate Property
Gets or sets the date on with the document is signed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SignDate As SignatureField(Of Date)
public SignatureField<DateTime> SignDate {get; set;}
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

In the code example above, replace the path and filename and password of the Certificate with your certificate information, and replace the time stamping authority (TSA) URL with that of your TSA.

Note: You must purchase a volume-based registration at an actual TSA for your applications.

Example
  • Visual Basic
' Text signature.
Me.PdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text
Me.PdfExport1.Signature.Stamp.Bounds = New RectangleF(1, 1, 4, 2)
Me.PdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left

' Set certificate & password.
Me.PdfExport1.Signature.Certificate = New Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath & "\..\..\certificate.pfx", "password")

' Signature items.
Me.PdfExport1.Signature.SignDate = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of Date)(System.DateTime.Now, True)
Me.PdfExport1.Signature.Contact = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("ar10@grapecity.com", True)
Me.PdfExport1.Signature.Reason = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("I agree.", True)
Me.PdfExport1.Signature.Location = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("Japan", True)

' Time stamp.
Me.PdfExport1.Signature.TimeStamp = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null")
Me.PdfExport1.Export(rpt.Document, Application.StartupPath & "\..\..\TimeStamped.pdf")
  • C#
this.pdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text;
this.pdfExport1.Signature.Stamp.Bounds = new RectangleF(1, 1, 4, 2);
this.pdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left;

// Set certificate & password.
this.pdfExport1.Signature.Certificate = new System.Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath + "\\..\\..\\certificate.pfx", "password");

// Signature items.
this.pdfExport1.Signature.SignDate = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<System.DateTime>(System.DateTime.Now, true);
this.pdfExport1.Signature.Contact = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("ar10@grapecity.com", true);
this.pdfExport1.Signature.Reason = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("I agree.", true);
this.pdfExport1.Signature.Location = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("Japan", true);

// Time stamp.
this.pdfExport1.Signature.TimeStamp = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null");
this.pdfExport1.Export(rpt.Document, Application.StartupPath + "\\..\\..\\TimeStamped.pdf");
See Also

Reference

PdfSignature Class
PdfSignature Members


Stamp Property

Stamp Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfSignature Class : Stamp Property
Gets the PdfStamp object used in the signature.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Stamp As PdfStamp
public PdfStamp Stamp {get;}
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

See Also

Reference

PdfSignature Class
PdfSignature Members


TimeStamp Property

TimeStamp Property
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfSignature Class : TimeStamp Property
Gets or sets the TimeStamp object to use in the signature.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TimeStamp As TimeStamp
public TimeStamp TimeStamp {get; set;}
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

In the code example above, replace the path and filename and password of the Certificate with your certificate information, and replace the time stamping authority (TSA) URL with that of your TSA.

Note: You must purchase a volume-based registration at an actual TSA for your applications.

Example
  • Visual Basic
' Text signature.
Me.PdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text
Me.PdfExport1.Signature.Stamp.Bounds = New RectangleF(1, 1, 4, 2)
Me.PdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left

' Set certificate & password.
Me.PdfExport1.Signature.Certificate = New Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath & "\..\..\certificate.pfx", "password")

' Signature items.
Me.PdfExport1.Signature.SignDate = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of Date)(System.DateTime.Now, True)
Me.PdfExport1.Signature.Contact = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("ar10@grapecity.com", True)
Me.PdfExport1.Signature.Reason = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("I agree.", True)
Me.PdfExport1.Signature.Location = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("Japan", True)

' Time stamp.
Me.PdfExport1.Signature.TimeStamp = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null")
Me.PdfExport1.Export(rpt.Document, Application.StartupPath & "\..\..\TimeStamped.pdf")
  • C#
this.pdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text;
this.pdfExport1.Signature.Stamp.Bounds = new RectangleF(1, 1, 4, 2);
this.pdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left;

// Set certificate & password.
this.pdfExport1.Signature.Certificate = new System.Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath + "\\..\\..\\certificate.pfx", "password");

// Signature items.
this.pdfExport1.Signature.SignDate = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<System.DateTime>(System.DateTime.Now, true);
this.pdfExport1.Signature.Contact = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("ar10@grapecity.com", true);
this.pdfExport1.Signature.Reason = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("I agree.", true);
this.pdfExport1.Signature.Location = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("Japan", true);

// Time stamp.
this.pdfExport1.Signature.TimeStamp = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null");
this.pdfExport1.Export(rpt.Document, Application.StartupPath + "\\..\\..\\TimeStamped.pdf");
See Also

Reference

PdfSignature Class
PdfSignature Members


VisibilityType Property

VisibilityType Property
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfSignature Class : VisibilityType Property
Gets or sets an enumerated value indicating whether and how to display certification on the document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property VisibilityType As VisibilityType
public VisibilityType VisibilityType {get; set;}
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

In the code example above, replace the path and filename and password of the Certificate with your certificate information, and replace the time stamping authority (TSA) URL with that of your TSA.

Note: You must purchase a volume-based registration at an actual TSA for your applications.

Example
  • Visual Basic
' Text signature.
Me.PdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text
Me.PdfExport1.Signature.Stamp.Bounds = New RectangleF(1, 1, 4, 2)
Me.PdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left

' Set certificate & password.
Me.PdfExport1.Signature.Certificate = New Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath & "\..\..\certificate.pfx", "password")

' Signature items.
Me.PdfExport1.Signature.SignDate = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of Date)(System.DateTime.Now, True)
Me.PdfExport1.Signature.Contact = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("ar10@grapecity.com", True)
Me.PdfExport1.Signature.Reason = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("I agree.", True)
Me.PdfExport1.Signature.Location = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("Japan", True)

' Time stamp.
Me.PdfExport1.Signature.TimeStamp = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null")
Me.PdfExport1.Export(rpt.Document, Application.StartupPath & "\..\..\TimeStamped.pdf")
  • C#
this.pdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text;
this.pdfExport1.Signature.Stamp.Bounds = new RectangleF(1, 1, 4, 2);
this.pdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left;

// Set certificate & password.
this.pdfExport1.Signature.Certificate = new System.Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath + "\\..\\..\\certificate.pfx", "password");

// Signature items.
this.pdfExport1.Signature.SignDate = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<System.DateTime>(System.DateTime.Now, true);
this.pdfExport1.Signature.Contact = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("ar10@grapecity.com", true);
this.pdfExport1.Signature.Reason = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("I agree.", true);
this.pdfExport1.Signature.Location = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("Japan", true);

// Time stamp.
this.pdfExport1.Signature.TimeStamp = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null");
this.pdfExport1.Export(rpt.Document, Application.StartupPath + "\\..\\..\\TimeStamped.pdf");
See Also

Reference

PdfSignature Class
PdfSignature Members


PdfStamp Class

PdfStamp Class
Members Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : PdfStamp Class
Encapsulates the information necessary to draw PDF document digital signatures and certification on documents.
Object Model
PdfStamp Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class PdfStamp
public sealed class PdfStamp
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

In the code example above, replace the path and filename and password of the Certificate with your certificate information, and replace the time stamping authority (TSA) URL with that of your TSA.

Note: You must purchase a volume-based registration at an actual TSA for your applications.

Example
  • Visual Basic
' Text signature.
Me.PdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text
Me.PdfExport1.Signature.Stamp.Bounds = New RectangleF(1, 1, 4, 2)
Me.PdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left

' Set certificate & password.
Me.PdfExport1.Signature.Certificate = New Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath & "\..\..\certificate.pfx", "password")

' Signature items.
Me.PdfExport1.Signature.SignDate = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of Date)(System.DateTime.Now, True)
Me.PdfExport1.Signature.Contact = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("ar10@grapecity.com", True)
Me.PdfExport1.Signature.Reason = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("I agree.", True)
Me.PdfExport1.Signature.Location = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("Japan", True)

' Time stamp.
Me.PdfExport1.Signature.TimeStamp = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null")
Me.PdfExport1.Export(rpt.Document, Application.StartupPath & "\..\..\TimeStamped.pdf")
  • C#
// Text signature.
this.pdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text;
this.pdfExport1.Signature.Stamp.Bounds = new RectangleF(1, 1, 4, 2);
this.pdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left;

// Set certificate & password.
this.pdfExport1.Signature.Certificate = new System.Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath + "\\..\\..\\certificate.pfx", "password");

// Signature items.
this.pdfExport1.Signature.SignDate = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<System.DateTime>(System.DateTime.Now, true);
this.pdfExport1.Signature.Contact = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("ar10@grapecity.com", true);
this.pdfExport1.Signature.Reason = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("I agree.", true);
this.pdfExport1.Signature.Location = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("Japan", true);

// Time stamp.
this.pdfExport1.Signature.TimeStamp = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null");
this.pdfExport1.Export(rpt.Document, Application.StartupPath + "\\..\\..\\TimeStamped.pdf");
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Pdf.Section.Signing.PdfStamp

See Also

Reference

PdfStamp Members
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


PdfStamp Class Members

PdfStamp Class Members
Properties

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : PdfStamp Class

The following tables list the members exposed by PdfStamp.

Public Properties
 | Name | Description
Public Property | Bounds | Gets or sets the rectangular bounding area in which to print the signature.
Public Property | CustomText | Gets or sets a string to the signature.
Public Property | Font | Gets or sets the font to use on the signature text.
Public Property | Image | Gets or sets the System.Drawing.Image file to use in the signature.
Public Property | ImageAlignment | Gets or sets an enumerated Alignment value to determine the placement of the image in the signature.
Public Property | ImageRectangle | Gets or sets a RectangleF value to determine the location of the image in the signature bounds.
Public Property | PageIndex | Gets or sets the index of the page on which to display the signature.
Public Property | TextAlignment | Gets or sets an enumerated Alignment value to determine the placement of the text in the signature.
Public Property | TextColor | Gets or sets the color of the text used in the signature.
Public Property | TextRectangle | Gets or sets a RectangleF value to determine the location of the text in the signature bounds.
Top
See Also

Reference

PdfStamp Class
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


PdfStamp Class Properties

PdfStamp Class Properties

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : PdfStamp Class

For a list of all members of this type, see PdfStamp members.

Public Properties
 | Name | Description
Public Property | Bounds | Gets or sets the rectangular bounding area in which to print the signature.
Public Property | CustomText | Gets or sets a string to the signature.
Public Property | Font | Gets or sets the font to use on the signature text.
Public Property | Image | Gets or sets the System.Drawing.Image file to use in the signature.
Public Property | ImageAlignment | Gets or sets an enumerated Alignment value to determine the placement of the image in the signature.
Public Property | ImageRectangle | Gets or sets a RectangleF value to determine the location of the image in the signature bounds.
Public Property | PageIndex | Gets or sets the index of the page on which to display the signature.
Public Property | TextAlignment | Gets or sets an enumerated Alignment value to determine the placement of the text in the signature.
Public Property | TextColor | Gets or sets the color of the text used in the signature.
Public Property | TextRectangle | Gets or sets a RectangleF value to determine the location of the text in the signature bounds.
Top
See Also

Reference

PdfStamp Class
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


Bounds Property (PdfStamp)

Bounds Property (PdfStamp)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfStamp Class : Bounds Property
Gets or sets the rectangular bounding area in which to print the signature.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Bounds As RectangleF
public RectangleF Bounds {get; set;}

Property Value

A RectangleF object.
Remarks

In Adobe Acrobat, the user does this by clicking and dragging a rectangle in the document. This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

In the code example above, replace the path and filename and password of the Certificate with your certificate information, and replace the time stamping authority (TSA) URL with that of your TSA.

Note: You must purchase a volume-based registration at an actual TSA for your applications.

See Also

Reference

PdfStamp Class
PdfStamp Members


CustomText Property

CustomText Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfStamp Class : CustomText Property
Gets or sets a string to the signature.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CustomText As System.String
public System.string CustomText {get; set;}

Property Value

String.
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document

See Also

Reference

PdfStamp Class
PdfStamp Members


Font Property (PdfStamp)

Font Property (PdfStamp)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfStamp Class : Font Property
Gets or sets the font to use on the signature text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Font As Font
public Font Font {get; set;}

Property Value

A System.Drawing.Font.
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

See Also

Reference

PdfStamp Class
PdfStamp Members


Image Property (PdfStamp)

Image Property (PdfStamp)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfStamp Class : Image Property
Gets or sets the System.Drawing.Image file to use in the signature.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Image As Image
public Image Image {get; set;}

Property Value

A System.Drawing.Image.
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

See Also

Reference

PdfStamp Class
PdfStamp Members


ImageAlignment Property

ImageAlignment Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfStamp Class : ImageAlignment Property
Gets or sets an enumerated Alignment value to determine the placement of the image in the signature.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ImageAlignment As Alignment
public Alignment ImageAlignment {get; set;}
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

See Also

Reference

PdfStamp Class
PdfStamp Members


ImageRectangle Property

ImageRectangle Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfStamp Class : ImageRectangle Property
Gets or sets a RectangleF value to determine the location of the image in the signature bounds.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ImageRectangle As RectangleF
public RectangleF ImageRectangle {get; set;}
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

See Also

Reference

PdfStamp Class
PdfStamp Members


PageIndex Property (PdfStamp)

PageIndex Property (PdfStamp)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfStamp Class : PageIndex Property
Gets or sets the index of the page on which to display the signature.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageIndex As System.Integer
public System.int PageIndex {get; set;}

Property Value

An integer.
Remarks

First page have index 1.

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

See Also

Reference

PdfStamp Class
PdfStamp Members


TextAlignment Property (PdfStamp)

TextAlignment Property (PdfStamp)
Example

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfStamp Class : TextAlignment Property
Gets or sets an enumerated Alignment value to determine the placement of the text in the signature.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TextAlignment As Alignment
public Alignment TextAlignment {get; set;}
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

In the code example above, replace the path and filename and password of the Certificate with your certificate information, and replace the time stamping authority (TSA) URL with that of your TSA.

Note: You must purchase a volume-based registration at an actual TSA for your applications.

Example
  • Visual Basic
' Text signature.
Me.PdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text
Me.PdfExport1.Signature.Stamp.Bounds = New RectangleF(1, 1, 4, 2)
Me.PdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left

' Set certificate & password.
Me.PdfExport1.Signature.Certificate = New Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath & "\..\..\certificate.pfx", "password")

' Signature items.
Me.PdfExport1.Signature.SignDate = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of Date)(System.DateTime.Now, True)
Me.PdfExport1.Signature.Contact = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("ar10@grapecity.com", True)
Me.PdfExport1.Signature.Reason = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("I agree.", True)
Me.PdfExport1.Signature.Location = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField(Of String)("Japan", True)

' Time stamp.
Me.PdfExport1.Signature.TimeStamp = New GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null")
Me.PdfExport1.Export(rpt.Document, Application.StartupPath & "\..\..\TimeStamped.pdf")
  • C#
this.pdfExport1.Signature.VisibilityType = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType.Text;
this.pdfExport1.Signature.Stamp.Bounds = new RectangleF(1, 1, 4, 2);
this.pdfExport1.Signature.Stamp.TextAlignment = GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment.Left;

// Set certificate & password.
this.pdfExport1.Signature.Certificate = new System.Security.Cryptography.X509Certificates.X509Certificate2(Application.StartupPath + "\\..\\..\\certificate.pfx", "password");

// Signature items.
this.pdfExport1.Signature.SignDate = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<System.DateTime>(System.DateTime.Now, true);
this.pdfExport1.Signature.Contact = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("ar10@grapecity.com", true);
this.pdfExport1.Signature.Reason = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("I agree.", true);
this.pdfExport1.Signature.Location = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<string>("Japan", true);

// Time stamp.
this.pdfExport1.Signature.TimeStamp = new GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp("http://TSAServer", "null", "null");
this.pdfExport1.Export(rpt.Document, Application.StartupPath + "\\..\\..\\TimeStamped.pdf");
See Also

Reference

PdfStamp Class
PdfStamp Members


TextColor Property (PdfStamp)

TextColor Property (PdfStamp)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfStamp Class : TextColor Property
Gets or sets the color of the text used in the signature.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TextColor As Color
public Color TextColor {get; set;}

Property Value

A System.Drawing.Color.
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

See Also

Reference

PdfStamp Class
PdfStamp Members


TextRectangle Property

TextRectangle Property

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > PdfStamp Class : TextRectangle Property
Gets or sets a RectangleF value to determine the location of the text in the signature bounds.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TextRectangle As RectangleF
public RectangleF TextRectangle {get; set;}

Property Value

A RectangleF.
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

See Also

Reference

PdfStamp Class
PdfStamp Members


SignatureField<T> Class

SignatureField<T> Class
Members

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : SignatureField<T> Class
A generic type.
Class wrapper, provides additional fields to values which should be placed on signature
Object Model
SignatureField<T> Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class SignatureField(Of T)
public sealed class SignatureField<T>
Type Parameters
T
A generic type.
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<T>

See Also

Reference

SignatureField<T> Members
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


SignatureField<T> Class Members

SignatureField<T> Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : SignatureField<T> Class

The following tables list the members exposed by SignatureField<T>.

Public Constructors
 | Name | Description
Public Constructor | SignatureField<T> Constructor | Overloaded. Initializes a new instance of the Generic SignatureField class.
Top
Public Properties
 | Name | Description
Public Property | ShowLabel | Gets or sets a value indicating whether to label the fields in the signature.
Public Property | Value | Gets the generic type from the constructor.
Public Property | Visible | Gets or sets a value indicating whether to display the signature.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateEmpty | Creates an empty generic signature field.
Public Method | ToString | Converts the value of the current instance to its string representation.
Top
Public Operators
public Operator Implicit Type Conversion Converts value to SignatureField<T> object
Top
See Also

Reference

SignatureField<T> Class
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


SignatureField<T> Constructor

SignatureField<T> Constructor

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > SignatureField<T> Class : SignatureField<T> Constructor
Initializes a new instance of the Generic SignatureField class.
Overload List
Overload | Description
SignatureField<T> Constructor(T) | Initializes a new instance of the Generic SignatureField class.
SignatureField<T> Constructor(T,Boolean) | Initializes a new instance of the Generic SignatureField class.
SignatureField<T> Constructor(T,Boolean,Boolean) | Initializes a new instance of the Generic SignatureField class.
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

See Also

Reference

SignatureField<T> Class
SignatureField<T> Members


SignatureField<T> Constructor(T)

SignatureField<T> Constructor(T)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > SignatureField<T> Class > SignatureField<T> Constructor : SignatureField<T> Constructor(T)
Value to write on signature
Initializes a new instance of the Generic SignatureField class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal value As T _
)
public SignatureField<T>(
   T value
)

Parameters

value
Value to write on signature
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document

See Also

Reference

SignatureField<T> Class
SignatureField<T> Members
Overload List


SignatureField<T> Constructor(T,Boolean)

SignatureField<T> Constructor(T,Boolean)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > SignatureField<T> Class > SignatureField<T> Constructor : SignatureField<T> Constructor(T,Boolean)
Value to write on signature
true, if value should be written
Initializes a new instance of the Generic SignatureField class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal value As T, _
   ByVal visible As System.Boolean _
)
public SignatureField<T>(
   T value,
   System.bool visible
)

Parameters

value
Value to write on signature
visible
true, if value should be written
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document

See Also

Reference

SignatureField<T> Class
SignatureField<T> Members
Overload List


SignatureField<T> Constructor(T,Boolean,Boolean)

SignatureField<T> Constructor(T,Boolean,Boolean)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > SignatureField<T> Class > SignatureField<T> Constructor : SignatureField<T> Constructor(T,Boolean,Boolean)
Value to write on signature
true, if value should be written
true, if label for value should be shown
Initializes a new instance of the Generic SignatureField class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal value As T, _
   ByVal visible As System.Boolean, _
   ByVal showLabel As System.Boolean _
)
public SignatureField<T>(
   T value,
   System.bool visible,
   System.bool showLabel
)

Parameters

value
Value to write on signature
visible
true, if value should be written
showLabel
true, if label for value should be shown
See Also

Reference

SignatureField<T> Class
SignatureField<T> Members
Overload List


SignatureField<T> Class Methods

SignatureField<T> Class Methods

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : SignatureField<T> Class

For a list of all members of this type, see SignatureField<T> members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateEmpty | Creates an empty generic signature field.
Public Method | ToString | Converts the value of the current instance to its string representation.
Top
See Also

Reference

SignatureField<T> Class
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


CreateEmpty Method

CreateEmpty Method

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > SignatureField<T> Class : CreateEmpty Method
Creates an empty generic signature field.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function CreateEmpty() As SignatureField(Of T)
public static SignatureField<T> CreateEmpty()

Return Value

Created empty field
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

See Also

Reference

SignatureField<T> Class
SignatureField<T> Members


ToString Method (SignatureField<T>)

ToString Method (SignatureField<T>)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > SignatureField<T> Class : ToString Method
Converts the value of the current instance to its string representation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()

Return Value

Returns Value.ToString()
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

See Also

Reference

SignatureField<T> Class
SignatureField<T> Members


SignatureField<T> Class Properties

SignatureField<T> Class Properties

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : SignatureField<T> Class

For a list of all members of this type, see SignatureField<T> members.

Public Properties
 | Name | Description
Public Property | ShowLabel | Gets or sets a value indicating whether to label the fields in the signature.
Public Property | Value | Gets the generic type from the constructor.
Public Property | Visible | Gets or sets a value indicating whether to display the signature.
Top
See Also

Reference

SignatureField<T> Class
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


ShowLabel Property (SignatureField<T>)

ShowLabel Property (SignatureField<T>)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > SignatureField<T> Class : ShowLabel Property
Gets or sets a value indicating whether to label the fields in the signature.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShowLabel As System.Boolean
public System.bool ShowLabel {get; set;}
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

See Also

Reference

SignatureField<T> Class
SignatureField<T> Members


Value Property (SignatureField<T>)

Value Property (SignatureField<T>)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > SignatureField<T> Class : Value Property
Gets the generic type from the constructor.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Value As T
public T Value {get;}
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

See Also

Reference

SignatureField<T> Class
SignatureField<T> Members


Visible Property (SignatureField<T>)

Visible Property (SignatureField<T>)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > SignatureField<T> Class : Visible Property
Gets or sets a value indicating whether to display the signature.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

See Also

Reference

SignatureField<T> Class
SignatureField<T> Members


Implicit Type Conversion Operator (SignatureField<T>)

Implicit Type Conversion Operator (SignatureField<T>)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > SignatureField<T> Class : Implicit Type Conversion Operator
Value to convert
Converts value to SignatureField<T> object
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator Widening CType( _
   ByVal value As T _
) As SignatureField(Of T)
public SignatureField<T> operator implicit(
   T value
)

Parameters

value
Value to convert

Return Value

Converted value
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document

See Also

Reference

SignatureField<T> Class
SignatureField<T> Members


TimeStamp Class

TimeStamp Class
Members

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : TimeStamp Class

Encapsulates the information necessary to include timestamps from a Time Stamping Authority in digital signatures on PDF documents.

Object Model
TimeStamp Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class TimeStamp
public class TimeStamp
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp

See Also

Reference

TimeStamp Members
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


TimeStamp Class Members

TimeStamp Class Members
Properties

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : TimeStamp Class

The following tables list the members exposed by TimeStamp.

Public Constructors
 | Name | Description
Public Constructor | TimeStamp Constructor | Overloaded. Initializes a new instance of the TimeStamp class.
Top
Public Properties
 | Name | Description
Public Property | Password | The user ID to send to the Time Stamping Authority (TSA) server.
Public Property | ServerUrl | Gets or sets the uniform resource identifier for the Time Stamping Authority (TSA) server providing the timestamp.
Public Property | UserName | The user ID to send to the Time Stamping Authority (TSA) server.
Top
See Also

Reference

TimeStamp Class
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


TimeStamp Constructor

TimeStamp Constructor

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > TimeStamp Class : TimeStamp Constructor
Initializes a new instance of the TimeStamp class.
Overload List
Overload | Description
TimeStamp Constructor(String,String,String) | Initializes a new instance of the TimeStamp class using the specified server string, user name, and password.
TimeStamp Constructor(Uri,String,String) | Initializes a new instance of the TimeStamp class using the specified server URI, user name, and password.
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

See Also

Reference

TimeStamp Class
TimeStamp Members


TimeStamp Constructor(String,String,String)

TimeStamp Constructor(String,String,String)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > TimeStamp Class > TimeStamp Constructor : TimeStamp Constructor(String,String,String)
TSA server address
User ID for TSA server
Password for TSA server
Initializes a new instance of the TimeStamp class using the specified server string, user name, and password.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal server As System.String, _
   ByVal user As System.String, _
   ByVal password As System.String _
)
public TimeStamp(
   System.string server,
   System.string user,
   System.string password
)

Parameters

server
TSA server address
user
User ID for TSA server
password
Password for TSA server
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document

See Also

Reference

TimeStamp Class
TimeStamp Members
Overload List


TimeStamp Constructor(Uri,String,String)

TimeStamp Constructor(Uri,String,String)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > TimeStamp Class > TimeStamp Constructor : TimeStamp Constructor(Uri,String,String)
TSA server URL
User ID for TSA server
Password for TSA server
Initializes a new instance of the TimeStamp class using the specified server URI, user name, and password.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal serverUrl As System.Uri, _
   ByVal user As System.String, _
   ByVal password As System.String _
)
public TimeStamp(
   System.Uri serverUrl,
   System.string user,
   System.string password
)

Parameters

serverUrl
TSA server URL
user
User ID for TSA server
password
Password for TSA server
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document

See Also

Reference

TimeStamp Class
TimeStamp Members
Overload List


TimeStamp Class Properties

TimeStamp Class Properties

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : TimeStamp Class

For a list of all members of this type, see TimeStamp members.

Public Properties
 | Name | Description
Public Property | Password | The user ID to send to the Time Stamping Authority (TSA) server.
Public Property | ServerUrl | Gets or sets the uniform resource identifier for the Time Stamping Authority (TSA) server providing the timestamp.
Public Property | UserName | The user ID to send to the Time Stamping Authority (TSA) server.
Top
See Also

Reference

TimeStamp Class
GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


Password Property (TimeStamp)

Password Property (TimeStamp)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > TimeStamp Class : Password Property
The user ID to send to the Time Stamping Authority (TSA) server.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Password As System.String
public System.string Password {get; set;}
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

See Also

Reference

TimeStamp Class
TimeStamp Members


ServerUrl Property (TimeStamp)

ServerUrl Property (TimeStamp)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > TimeStamp Class : ServerUrl Property
Gets or sets the uniform resource identifier for the Time Stamping Authority (TSA) server providing the timestamp.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ServerUrl As System.Uri
public System.Uri ServerUrl {get; set;}
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

See Also

Reference

TimeStamp Class
TimeStamp Members


UserName Property (TimeStamp)

UserName Property (TimeStamp)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace > TimeStamp Class : UserName Property
The user ID to send to the Time Stamping Authority (TSA) server.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UserName As System.String
public System.string UserName {get; set;}
Remarks

This feature is for use with the Professional Edition license only. An evaluation message is rendered when used with the Standard Edition license.

Note: This feature can not be used if a report is exported into a password-protected PDF document.

See Also

Reference

TimeStamp Class
TimeStamp Members


Alignment Enumeration

Alignment Enumeration

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : Alignment Enumeration
Sets the type of alignment to use for text or images.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Alignment
   Inherits System.Enum
public enum Alignment : System.Enum
Members
Member | Description
Center | Align in the center of the stamp bounds.
Left | Align to the left edge of the stamp bounds.
Right | Align to the right edge of the stamp bounds.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Section.Signing.Alignment

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


CertificationLevel Enumeration

CertificationLevel Enumeration

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : CertificationLevel Enumeration
Enumerates possible certification types
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum CertificationLevel
   Inherits System.Enum
public enum CertificationLevel : System.Enum
Members
Member | Description
FormFilling | Certified, permit changes to form field and signing
FormFillingAnnotations | Certified, permit changes to form field, annotation and signing
NoChangesAllowed | Certified, but no changes permitted
NotCertified | Document is not certified
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Section.Signing.CertificationLevel

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


VisibilityType Enumeration

VisibilityType Enumeration

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace : VisibilityType Enumeration
Sets a value indicating whether and how to display certification on the document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum VisibilityType
   Inherits System.Enum
public enum VisibilityType : System.Enum
Members
Member | Description
Image | Show only image on signature
ImageText | Show both, image and text
Invisible | Invisible signature, it means no data will be shown on page, but it will be accessible via "Signatures" tab in reader
Text | Show only text on signature
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Pdf.Section.Signing.VisibilityType

See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace


GrapeCity.ActiveReports.Export.Word.Page Namespace

GrapeCity.ActiveReports.Export.Word.Page Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Word.v10 Assembly : GrapeCity.ActiveReports.Export.Word.Page Namespace
The GrapeCity.ActiveReports.Export.Word.Page namespace includes information related to Settings and Word Rendering Extension.
Classes
 | Class | Description
Class | Settings | GrapeCity.ActiveReports.Extensibility.Rendering.ISettings implementation for Word Rendering Extension.
Class | WordRenderingExtension | Implementes GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension. Allows to render GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport to Word Html document.
Enumerations
 | Enumeration | Description
Enumeration | DocumentCompatibilityVersion | Specifies whe word document compatibility version
Enumeration | FileFormat | Specifies the output format of Word document.
See Also

Reference

GrapeCity.ActiveReports.Export.Word.v10 Assembly


Settings Class

Settings Class
Members

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace : Settings Class
GrapeCity.ActiveReports.Extensibility.Rendering.ISettings implementation for Word Rendering Extension.
Object Model
Settings Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Settings
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
public sealed class Settings : GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Word.Page.Settings

See Also

Reference

Settings Members
GrapeCity.ActiveReports.Export.Word.Page Namespace


Settings Class Members

Settings Class Members
Properties

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace : Settings Class

The following tables list the members exposed by Settings.

Public Properties
 | Name | Description
Public Property | Author | Gets or sets the name of the author of document.
Public Property | BaseUrl | Gets or sets the base Url used for hyperlinks on the document.
Public Property | CompanyName | Gets or sets the company name used for exported file document properties.
Public Property | DocumentCompatibilityVersion | Gets or sets the word version which should open the exported document.
Public Property | DpiX | Adjust the horizontal resolution of custom report items. The default value is 96.
Public Property | DpiY | Adjust the vertical resolution of custom report items. The default value is 96.
Public Property | FileFormat | Indicates whether to use WordHtml or OpenXml format for the output file. WordHtml is default.
Public Property | Generator | Gets or sets identity of the generator of the document.
Public Property | PageHeight | Gets or sets the height of the page of rendered document. Value corresponds to values passed in GrapeCity.ActiveReports.Extensibility.Definition.Components.Length class("8.5in", "11cm", etc.).
Public Property | PageSettings | Gets or sets the settings of page size and orientation.
Public Property | PageWidth | Gets or sets the width of the page of rendered document. Value corresponds to values passed in GrapeCity.ActiveReports.Extensibility.Definition.Components.Length class("8.5in", "11cm", etc.).
Public Property | SecuritySettings | Gets or sets the settings of document encryption and security.
Public Property | Title | Gets or sets the title of the document.
Public Property | TOCAutoUpdate | If true in the document will be inserted macros that automatically updates ToC control on opening.
Public Property | UseMhtOutput | Gets or sets the value indicates should Mht output be used for resulted word document or not.
Top
See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Word.Page Namespace


Settings Class Properties

Settings Class Properties

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace : Settings Class

For a list of all members of this type, see Settings members.

Public Properties
 | Name | Description
Public Property | Author | Gets or sets the name of the author of document.
Public Property | BaseUrl | Gets or sets the base Url used for hyperlinks on the document.
Public Property | CompanyName | Gets or sets the company name used for exported file document properties.
Public Property | DocumentCompatibilityVersion | Gets or sets the word version which should open the exported document.
Public Property | DpiX | Adjust the horizontal resolution of custom report items. The default value is 96.
Public Property | DpiY | Adjust the vertical resolution of custom report items. The default value is 96.
Public Property | FileFormat | Indicates whether to use WordHtml or OpenXml format for the output file. WordHtml is default.
Public Property | Generator | Gets or sets identity of the generator of the document.
Public Property | PageHeight | Gets or sets the height of the page of rendered document. Value corresponds to values passed in GrapeCity.ActiveReports.Extensibility.Definition.Components.Length class("8.5in", "11cm", etc.).
Public Property | PageSettings | Gets or sets the settings of page size and orientation.
Public Property | PageWidth | Gets or sets the width of the page of rendered document. Value corresponds to values passed in GrapeCity.ActiveReports.Extensibility.Definition.Components.Length class("8.5in", "11cm", etc.).
Public Property | SecuritySettings | Gets or sets the settings of document encryption and security.
Public Property | Title | Gets or sets the title of the document.
Public Property | TOCAutoUpdate | If true in the document will be inserted macros that automatically updates ToC control on opening.
Public Property | UseMhtOutput | Gets or sets the value indicates should Mht output be used for resulted word document or not.
Top
See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Word.Page Namespace


Author Property (Settings)

Author Property (Settings)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : Author Property
Gets or sets the name of the author of document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Author As System.String
public System.string Author {get; set;}
See Also

Reference

Settings Class
Settings Members


BaseUrl Property

BaseUrl Property

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : BaseUrl Property
Gets or sets the base Url used for hyperlinks on the document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BaseUrl As System.String
public System.string BaseUrl {get; set;}
See Also

Reference

Settings Class
Settings Members


CompanyName Property (Settings)

CompanyName Property (Settings)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : CompanyName Property
Gets or sets the company name used for exported file document properties.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CompanyName As System.String
public System.string CompanyName {get; set;}
See Also

Reference

Settings Class
Settings Members


DocumentCompatibilityVersion Property

DocumentCompatibilityVersion Property

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : DocumentCompatibilityVersion Property
Gets or sets the word version which should open the exported document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DocumentCompatibilityVersion As DocumentCompatibilityVersion
public DocumentCompatibilityVersion DocumentCompatibilityVersion {get; set;}
See Also

Reference

Settings Class
Settings Members


DpiX Property (Settings)

DpiX Property (Settings)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : DpiX Property
Adjust the horizontal resolution of custom report items. The default value is 96.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DpiX As System.Single
public System.float DpiX {get; set;}
See Also

Reference

Settings Class
Settings Members


DpiY Property (Settings)

DpiY Property (Settings)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : DpiY Property
Adjust the vertical resolution of custom report items. The default value is 96.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DpiY As System.Single
public System.float DpiY {get; set;}
See Also

Reference

Settings Class
Settings Members


FileFormat Property (Settings)

FileFormat Property (Settings)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : FileFormat Property
Indicates whether to use WordHtml or OpenXml format for the output file. WordHtml is default.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FileFormat As FileFormat
public FileFormat FileFormat {get; set;}
See Also

Reference

Settings Class
Settings Members


Generator Property

Generator Property

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : Generator Property
Gets or sets identity of the generator of the document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Generator As System.String
public System.string Generator {get; set;}
See Also

Reference

Settings Class
Settings Members


PageHeight Property (Settings)

PageHeight Property (Settings)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : PageHeight Property
Gets or sets the height of the page of rendered document. Value corresponds to values passed in GrapeCity.ActiveReports.Extensibility.Definition.Components.Length class("8.5in", "11cm", etc.).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageHeight As System.String
public System.string PageHeight {get; set;}
See Also

Reference

Settings Class
Settings Members


PageSettings Property (Settings)

PageSettings Property (Settings)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : PageSettings Property
Gets or sets the settings of page size and orientation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageSettings As WordPageSettings
public WordPageSettings PageSettings {get; set;}
See Also

Reference

Settings Class
Settings Members


PageWidth Property (Settings)

PageWidth Property (Settings)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : PageWidth Property
Gets or sets the width of the page of rendered document. Value corresponds to values passed in GrapeCity.ActiveReports.Extensibility.Definition.Components.Length class("8.5in", "11cm", etc.).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageWidth As System.String
public System.string PageWidth {get; set;}
See Also

Reference

Settings Class
Settings Members


SecuritySettings Property

SecuritySettings Property

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : SecuritySettings Property
Gets or sets the settings of document encryption and security.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SecuritySettings As WordSecurity
public WordSecurity SecuritySettings {get; set;}
See Also

Reference

Settings Class
Settings Members


Title Property (Settings)

Title Property (Settings)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : Title Property
Gets or sets the title of the document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Title As System.String
public System.string Title {get; set;}
See Also

Reference

Settings Class
Settings Members


TOCAutoUpdate Property

TOCAutoUpdate Property

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : TOCAutoUpdate Property
If true in the document will be inserted macros that automatically updates ToC control on opening.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TOCAutoUpdate As System.Boolean
public System.bool TOCAutoUpdate {get; set;}
See Also

Reference

Settings Class
Settings Members


UseMhtOutput Property

UseMhtOutput Property

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > Settings Class : UseMhtOutput Property
Gets or sets the value indicates should Mht output be used for resulted word document or not.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseMhtOutput As System.Boolean
public System.bool UseMhtOutput {get; set;}
See Also

Reference

Settings Class
Settings Members


WordRenderingExtension Class

WordRenderingExtension Class
Members

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace : WordRenderingExtension Class
Implementes GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension. Allows to render GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport to Word Html document.
Object Model
WordRenderingExtension Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class WordRenderingExtension
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension
public sealed class WordRenderingExtension : GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Word.Page.WordRenderingExtension

See Also

Reference

WordRenderingExtension Members
GrapeCity.ActiveReports.Export.Word.Page Namespace


WordRenderingExtension Class Members

WordRenderingExtension Class Members

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace : WordRenderingExtension Class

The following tables list the members exposed by WordRenderingExtension.

Public Constructors
 | Name | Description
Public Constructor | WordRenderingExtension Constructor | Initializes a new instance of the WordRenderingExtension class.
Top
See Also

Reference

WordRenderingExtension Class
GrapeCity.ActiveReports.Export.Word.Page Namespace


WordRenderingExtension Constructor

WordRenderingExtension Constructor

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace > WordRenderingExtension Class : WordRenderingExtension Constructor
Initializes a new instance of the WordRenderingExtension class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public WordRenderingExtension()
See Also

Reference

WordRenderingExtension Class
WordRenderingExtension Members


DocumentCompatibilityVersion Enumeration

DocumentCompatibilityVersion Enumeration

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace : DocumentCompatibilityVersion Enumeration
Specifies whe word document compatibility version
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DocumentCompatibilityVersion
   Inherits System.Enum
public enum DocumentCompatibilityVersion : System.Enum
Members
Member | Description
Word2007 | Word 2007
Word2010 | Word 2010
Word2013 | Word 2013
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Word.Page.DocumentCompatibilityVersion

See Also

Reference

GrapeCity.ActiveReports.Export.Word.Page Namespace


FileFormat Enumeration

FileFormat Enumeration

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Page Namespace : FileFormat Enumeration
Specifies the output format of Word document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum FileFormat
   Inherits System.Enum
public enum FileFormat : System.Enum
Members
Member | Description
HTML | Word html format.
OOXML | Word Open XML format.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Export.Word.Page.FileFormat

See Also

Reference

GrapeCity.ActiveReports.Export.Word.Page Namespace


GrapeCity.ActiveReports.Export.Word.Section Namespace

GrapeCity.ActiveReports.Export.Word.Section Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Word.v10 Assembly : GrapeCity.ActiveReports.Export.Word.Section Namespace
The GrapeCity.ActiveReports.Export.Word.Section namespace contains the RTF (Rich Text Format) export classes.
Classes
 | Class | Description
Class | RtfExport | The Rich Text Format (RTF) export component for ActiveReports.
Class | RtfExportException | The error thrown when an RtfExport-specific error occurs.
See Also

Reference

GrapeCity.ActiveReports.Export.Word.v10 Assembly


RtfExport Class

RtfExport Class
Members

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace : RtfExport Class
The Rich Text Format (RTF) export component for ActiveReports.
Object Model
RtfExport Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class RtfExport
   Inherits System.ComponentModel.Component
   Implements GrapeCity.ActiveReports.Export.IDocumentExport, GrapeCity.ActiveReports.Export.IDocumentExportEx
public sealed class RtfExport : System.ComponentModel.Component, GrapeCity.ActiveReports.Export.IDocumentExport, GrapeCity.ActiveReports.Export.IDocumentExportEx
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Export.Word.Section.RtfExport

See Also

Reference

RtfExport Members
GrapeCity.ActiveReports.Export.Word.Section Namespace


RtfExport Class Members

RtfExport Class Members
Properties Methods Events

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace : RtfExport Class

The following tables list the members exposed by RtfExport.

Public Constructors
 | Name | Description
Public Constructor | RtfExport Constructor | Initializes a new instance of the RtfExport class.
Top
Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | EnableShapes | Setting this value to true will export the Shapes and Lines to RTF Format. You will require Microsoft Word to view it correctly.
Public Property | Pagination | Gets or sets the value, that indicates whether pagination should be used for resultant RTF document or not.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | Export | Overloaded. Exports the specified document to RTF format.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

RtfExport Class
GrapeCity.ActiveReports.Export.Word.Section Namespace


RtfExport Constructor

RtfExport Constructor

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class : RtfExport Constructor
Initializes a new instance of the RtfExport class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public RtfExport()
See Also

Reference

RtfExport Class
RtfExport Members


RtfExport Class Methods

RtfExport Class Methods

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace : RtfExport Class

For a list of all members of this type, see RtfExport members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | Export | Overloaded. Exports the specified document to RTF format.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

RtfExport Class
GrapeCity.ActiveReports.Export.Word.Section Namespace


Export Method (RtfExport)

Export Method (RtfExport)
Example

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class : Export Method
Exports the specified document to RTF format.
Overload List
Overload | Description
Export(PageDocument,String) | Exports the specified document to a Rich Text Format (RTF) file.
Export(PageDocument,String,String) | Exports the specified document to a Rich Text Format (RTF) file.
Export(PageDocument,Stream) | Exports the specified document to the specified stream in Rich Text Format (RTF).
Export(PageDocument,Stream,String) | Exports the specified document to the specified stream in Rich Text Format (RTF).
Export(IReport,String,String) | Exports the specified IReport to file
Export(IReport,String) | Exports the specified IReport to file
Export(IReport,Stream) | Exports the specified IReport to stream
Export(IReport,Stream,String) | Exports the specified IReport to stream
Export(SectionDocument,String,String) | Exports the specified range of pages of the document to a Rich Text Format (RTF) file.
Export(SectionDocument,String) | Exports the specified document to a Rich Text Format (RTF) file.
Export(SectionDocument,Stream) | Exports the specified document to the specified stream in Rich Text Format (RTF).
Export(SectionDocument,Stream,String) | Exports the specified range of pages of the document to the specified stream in Rich Text Format (RTF).
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    rptGrapeCity rpt = new rptGrapeCity();
    GrapeCity.ActiveReports.Export.Word.Section.RtfExport r = new GrapeCity.ActiveReports.Export.Word.Section.RtfExport();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    r.Export(rpt.Document, Application.StartupPath + "\\r.rtf");
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport
    Dim r As New GrapeCity.ActiveReports.Export.Word.Section.RtfExport
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    r.Export(rpt.Document, Application.StartupPath & "\r.rtf")
End Sub
See Also

Reference

RtfExport Class
RtfExport Members


Export(PageDocument,String) Method

Export(PageDocument,String) Method

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class > Export Method : Export(PageDocument,String) Method
The ActiveReports PageDocument object to export.
The file name and path to save the main html file to.
Exports the specified document to a Rich Text Format (RTF) file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As System.String _
)
public void Export(
   PageDocument document,
   System.string filePath
)

Parameters

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main html file to.
See Also

Reference

RtfExport Class
RtfExport Members
Overload List


Export(PageDocument,String,String) Method

Export(PageDocument,String,String) Method

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class > Export Method : Export(PageDocument,String,String) Method
The ActiveReports PageDocument object to export.
The file name and path to save the main html file to.
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified document to a Rich Text Format (RTF) file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As System.String, _
   ByVal pageRange As System.String _
)
public void Export(
   PageDocument document,
   System.string filePath,
   System.string pageRange
)

Parameters

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main html file to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

RtfExport Class
RtfExport Members
Overload List


Export(PageDocument,Stream) Method

Export(PageDocument,Stream) Method

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class > Export Method : Export(PageDocument,Stream) Method
The ActiveReports PageDocument object to export.
The Stream to write the RTF to.
Exports the specified document to the specified stream in Rich Text Format (RTF).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal stream As System.IO.Stream _
)
public void Export(
   PageDocument document,
   System.IO.Stream stream
)

Parameters

document
The ActiveReports PageDocument object to export.
stream
The Stream to write the RTF to.
See Also

Reference

RtfExport Class
RtfExport Members
Overload List


Export(PageDocument,Stream,String) Method

Export(PageDocument,Stream,String) Method

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class > Export Method : Export(PageDocument,Stream,String) Method
The ActiveReports PageDocument object to export.
The Stream to write the RTF to.
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified document to the specified stream in Rich Text Format (RTF).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal stream As System.IO.Stream, _
   ByVal pageRange As System.String _
)
public void Export(
   PageDocument document,
   System.IO.Stream stream,
   System.string pageRange
)

Parameters

document
The ActiveReports PageDocument object to export.
stream
The Stream to write the RTF to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

RtfExport Class
RtfExport Members
Overload List


Export(IReport,String,String) Method

Export(IReport,String,String) Method

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class > Export Method : Export(IReport,String,String) Method
IReport instance to Export
Path to export
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified IReport to file
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal filePath As System.String, _
   ByVal pageRange As System.String _
)
public void Export(
   IReport report,
   System.string filePath,
   System.string pageRange
)

Parameters

report
IReport instance to Export
filePath
Path to export
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

RtfExport Class
RtfExport Members
Overload List


Export(IReport,String) Method

Export(IReport,String) Method

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class > Export Method : Export(IReport,String) Method
IReport instance to Export
Path to export
Exports the specified IReport to file
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal filePath As System.String _
)
public void Export(
   IReport report,
   System.string filePath
)

Parameters

report
IReport instance to Export
filePath
Path to export
See Also

Reference

RtfExport Class
RtfExport Members
Overload List


Export(IReport,Stream) Method

Export(IReport,Stream) Method

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class > Export Method : Export(IReport,Stream) Method
IReport instance to Export
The output stream.
Exports the specified IReport to stream
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal outputStream As System.IO.Stream _
)
public void Export(
   IReport report,
   System.IO.Stream outputStream
)

Parameters

report
IReport instance to Export
outputStream
The output stream.
See Also

Reference

RtfExport Class
RtfExport Members
Overload List


Export(IReport,Stream,String) Method

Export(IReport,Stream,String) Method

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class > Export Method : Export(IReport,Stream,String) Method
IReport instance to Export
The output stream.
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified IReport to stream
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal outputStream As System.IO.Stream, _
   ByVal pageRange As System.String _
)
public void Export(
   IReport report,
   System.IO.Stream outputStream,
   System.string pageRange
)

Parameters

report
IReport instance to Export
outputStream
The output stream.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

RtfExport Class
RtfExport Members
Overload List


Export(SectionDocument,String,String) Method

Export(SectionDocument,String,String) Method
Example

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class > Export Method : Export(SectionDocument,String,String) Method
The ActiveReports Document object to export.
The file name and path to save the main html file to.
A range of page numbers to export separated by a comma. A single page number can be between each comma, or a range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified range of pages of the document to a Rich Text Format (RTF) file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As System.String, _
   ByVal pageRange As System.String _
)
public void Export(
   SectionDocument document,
   System.string filePath,
   System.string pageRange
)

Parameters

document
The ActiveReports Document object to export.
filePath
The file name and path to save the main html file to.
pageRange
A range of page numbers to export separated by a comma. A single page number can be between each comma, or a range of pages with a hyphen between the starting and ending page numbers in the range.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    rptGrapeCity rpt = new rptGrapeCity();
    GrapeCity.ActiveReports.Export.Word.Section.RtfExport r = new GrapeCity.ActiveReports.Export.Word.Section.RtfExport();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    r.Export(rpt.Document, Application.StartupPath + "\\r.rtf", "1-3");
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim r As New GrapeCity.ActiveReports.Export.Word.Section.RtfExport
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    r.Export(rpt.Document, Application.StartupPath & "\r.rtf", "1-3")
End Sub
See Also

Reference

RtfExport Class
RtfExport Members
Overload List


Export(SectionDocument,String) Method

Export(SectionDocument,String) Method
Example

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class > Export Method : Export(SectionDocument,String) Method
The ActiveReports Document object to export.
The file name and path to which to save the RTF file.
Exports the specified document to a Rich Text Format (RTF) file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As System.String _
)
public void Export(
   SectionDocument document,
   System.string filePath
)

Parameters

document
The ActiveReports Document object to export.
filePath
The file name and path to which to save the RTF file.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    rptGrapeCity rpt = new rptGrapeCity();
    GrapeCity.ActiveReports.Export.Word.Section.RtfExport r = new GrapeCity.ActiveReports.Export.Word.Section.RtfExport();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    r.Export(rpt.Document, Application.StartupPath + "\\r.rtf");
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim r As New GrapeCity.ActiveReports.Export.Word.Section.RtfExport
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    r.Export(rpt.Document, Application.StartupPath & "\r.rtf")
End Sub
See Also

Reference

RtfExport Class
RtfExport Members
Overload List


Export(SectionDocument,Stream) Method

Export(SectionDocument,Stream) Method
Example

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class > Export Method : Export(SectionDocument,Stream) Method
The ActiveReports Document object to export.
The System.IO.Stream to which to write the RTF.
Exports the specified document to the specified stream in Rich Text Format (RTF).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As System.IO.Stream _
)
public void Export(
   SectionDocument document,
   System.IO.Stream outputStream
)

Parameters

document
The ActiveReports Document object to export.
outputStream
The System.IO.Stream to which to write the RTF.
Example
This code snippet assumes that you have a Windows RichTextBox control on your viewer's form.
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    rptGrapeCity rpt = new rptGrapeCity();
    GrapeCity.ActiveReports.Export.Word.Section.RtfExport r = new GrapeCity.ActiveReports.Export.Word.Section.RtfExport();
    System.IO.MemoryStream s = new System.IO.MemoryStream();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    r.Export(rpt.Document, s);
    s.Position = 0;
    this.rtbWinForm.LoadFile(s, RichTextBoxStreamType.RichText);
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New Sectionreport1
    Dim r As New GrapeCity.ActiveReports.Export.Word.Section.RtfExport
    Dim s As New System.IO.MemoryStream
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    r.Export(rpt.Document, s)
    s.position = 0
    Me.rtbWinForm.LoadFile(s, RichTextBoxStreamType.RichText)
End Sub
See Also

Reference

RtfExport Class
RtfExport Members
Overload List


Export(SectionDocument,Stream,String) Method

Export(SectionDocument,Stream,String) Method
Example

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class > Export Method : Export(SectionDocument,Stream,String) Method
The ActiveReports Document object to export.
The System.IO.Stream to which to write the RTF.
A range of page numbers to export separated by a comma. A single page number can be between each comma, or a range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified range of pages of the document to the specified stream in Rich Text Format (RTF).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As System.IO.Stream, _
   ByVal pageRange As System.String _
)
public void Export(
   SectionDocument document,
   System.IO.Stream outputStream,
   System.string pageRange
)

Parameters

document
The ActiveReports Document object to export.
outputStream
The System.IO.Stream to which to write the RTF.
pageRange
A range of page numbers to export separated by a comma. A single page number can be between each comma, or a range of pages with a hyphen between the starting and ending page numbers in the range.
Example
This code snippet assumes that you have a Windows RichTextBox control on your viewer's form.
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    rptGrapeCity rpt = new rptGrapeCity();
    GrapeCity.ActiveReports.Export.Word.Section.RtfExport r = new GrapeCity.ActiveReports.Export.Word.Section.RtfExport();
    System.IO.MemoryStream s = new System.IO.MemoryStream();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    r.Export(rpt.Document, s,"1");
    s.Position = 0;
    this.rtbWinForm.LoadFile(s, RichTextBoxStreamType.RichText);
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
    Dim rpt As New SectionReport1
    Dim r As New GrapeCity.ActiveReports.Export.Word.Section.RtfExport
    Dim s As New System.IO.MemoryStream
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    r.Export(rpt.Document, s, "1")
    s.position = 0
    Me.rtbWinForm.LoadFile(s, RichTextBoxStreamType.RichText)
End Sub
See Also

Reference

RtfExport Class
RtfExport Members
Overload List


RtfExport Class Properties

RtfExport Class Properties

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace : RtfExport Class

For a list of all members of this type, see RtfExport members.

Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | EnableShapes | Setting this value to true will export the Shapes and Lines to RTF Format. You will require Microsoft Word to view it correctly.
Public Property | Pagination | Gets or sets the value, that indicates whether pagination should be used for resultant RTF document or not.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

RtfExport Class
GrapeCity.ActiveReports.Export.Word.Section Namespace


EnableShapes Property

EnableShapes Property

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class : EnableShapes Property
Setting this value to true will export the Shapes and Lines to RTF Format. You will require Microsoft Word to view it correctly.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EnableShapes As System.Boolean
public System.bool EnableShapes {get; set;}
See Also

Reference

RtfExport Class
RtfExport Members


Pagination Property (RtfExport)

Pagination Property (RtfExport)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class : Pagination Property
Gets or sets the value, that indicates whether pagination should be used for resultant RTF document or not.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Pagination As System.Boolean
public System.bool Pagination {get; set;}
Requirements

See Also

Reference

RtfExport Class
RtfExport Members


RtfExportException Class

RtfExportException Class
Members

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace : RtfExportException Class
The error thrown when an RtfExport-specific error occurs.
Object Model
RtfExportException Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class RtfExportException
   Inherits System.ApplicationException
public class RtfExportException : System.ApplicationException
Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Export.Word.Section.RtfExportException

See Also

Reference

RtfExportException Members
GrapeCity.ActiveReports.Export.Word.Section Namespace


RtfExportException Class Members

RtfExportException Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace : RtfExportException Class

The following tables list the members exposed by RtfExportException.

Public Constructors
 | Name | Description
Public Constructor | RtfExportException Constructor | Overloaded. Initializes a new instance of the RtfExportException class.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

RtfExportException Class
GrapeCity.ActiveReports.Export.Word.Section Namespace


RtfExportException Constructor

RtfExportException Constructor

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : RtfExportException Constructor
Initializes a new instance of the RtfExportException class.
Overload List
Overload | Description
RtfExportException Constructor(String) | Initializes a new instance of the RtfExportException class with the specified error message.
RtfExportException Constructor(String,Exception) | Initializes a new instance of the RtfExportException class with the specified error message and a reference to the inner exception that is the cause of this exception.
RtfExportException Constructor(SerializationInfo,StreamingContext) | Initializes a new instance of the RtfExportException class with serialized data.
See Also

Reference

RtfExportException Class
RtfExportException Members


RtfExportException Constructor(String)

RtfExportException Constructor(String)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class > RtfExportException Constructor : RtfExportException Constructor(String)
A message that describes the error.
Initializes a new instance of the RtfExportException class with the specified error message.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String _
)
public RtfExportException(
   System.string message
)

Parameters

message
A message that describes the error.
See Also

Reference

RtfExportException Class
RtfExportException Members
Overload List


RtfExportException Constructor(String,Exception)

RtfExportException Constructor(String,Exception)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class > RtfExportException Constructor : RtfExportException Constructor(String,Exception)
A message that describes the error.
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
Initializes a new instance of the RtfExportException class with the specified error message and a reference to the inner exception that is the cause of this exception.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String, _
   ByVal innerException As System.Exception _
)
public RtfExportException(
   System.string message,
   System.Exception innerException
)

Parameters

message
A message that describes the error.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
See Also

Reference

RtfExportException Class
RtfExportException Members
Overload List


RtfExportException Constructor(SerializationInfo,StreamingContext)

RtfExportException Constructor(SerializationInfo,StreamingContext)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class > RtfExportException Constructor : RtfExportException Constructor(SerializationInfo,StreamingContext)

Holds all the data needed to serialize or deserialize the object.

Describes the source and destination of a given serialized stream, as well as a means for serialization to retain that context and an additional caller-defined context.
Initializes a new instance of the RtfExportException class with serialized data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public RtfExportException(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info

Holds all the data needed to serialize or deserialize the object.

context
Describes the source and destination of a given serialized stream, as well as a means for serialization to retain that context and an additional caller-defined context.
See Also

Reference

RtfExportException Class
RtfExportException Members
Overload List


GrapeCity.ActiveReports.Export.Xml.Page Namespace

GrapeCity.ActiveReports.Export.Xml.Page Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Xml.v10 Assembly : GrapeCity.ActiveReports.Export.Xml.Page Namespace
The GrapeCity.ActiveReports.Export.Xml.Page namespace includes information related to Settings and XML Rendering Extension.
Classes
 | Class | Description
Class | Settings | Specifies the available setting names used with the XmlRenderingExtension.
Class | XmlRenderingExtension | Implementation of GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension. Allows to render GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport to XML file.
See Also

Reference

GrapeCity.ActiveReports.Export.Xml.v10 Assembly


Settings Class

Settings Class
Members

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace : Settings Class
Specifies the available setting names used with the XmlRenderingExtension.
Object Model
Settings Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Settings
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
public sealed class Settings : GrapeCity.ActiveReports.Extensibility.Rendering.ISettings
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Xml.Page.Settings

See Also

Reference

Settings Members
GrapeCity.ActiveReports.Export.Xml.Page Namespace


Settings Class Members

Settings Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace : Settings Class

The following tables list the members exposed by Settings.

Public Constructors
 | Name | Description
Public Constructor | Settings Constructor | Initializes a new instance of Settings class.
Top
Public Properties
 | Name | Description
Public Property | Encoding | Returns the value of the current Encoding setting.
Public Property | XslStylesheet | Gets or sets the path of the Xsl Stylesheet used during the rendering process.
Top
Public Methods
 | Name | Description
Public Method | ApplySettings | Applies any settings passed in the NameValueCollection settings parameters.
Public Method | GetSettings | Returns settings of XmlRenderingExtension.
Top
See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Xml.Page Namespace


Settings Constructor

Settings Constructor

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace > Settings Class : Settings Constructor
Initializes a new instance of Settings class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Settings()
See Also

Reference

Settings Class
Settings Members


Settings Class Methods

Settings Class Methods

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace : Settings Class

For a list of all members of this type, see Settings members.

Public Methods
 | Name | Description
Public Method | ApplySettings | Applies any settings passed in the NameValueCollection settings parameters.
Public Method | GetSettings | Returns settings of XmlRenderingExtension.
Top
See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Xml.Page Namespace


ApplySettings Method (Settings)

ApplySettings Method (Settings)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace > Settings Class : ApplySettings Method
A System.Collections.Specialized.NameValueCollection containing new settings.
Applies any settings passed in the NameValueCollection settings parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ApplySettings( _
   ByVal settings As System.Collections.Specialized.NameValueCollection _
)
public void ApplySettings(
   System.Collections.Specialized.NameValueCollection settings
)

Parameters

settings
A System.Collections.Specialized.NameValueCollection containing new settings.
See Also

Reference

Settings Class
Settings Members


GetSettings Method (Settings)

GetSettings Method (Settings)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace > Settings Class : GetSettings Method
Returns settings of XmlRenderingExtension.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetSettings() As System.Collections.Specialized.NameValueCollection
public System.Collections.Specialized.NameValueCollection GetSettings()
See Also

Reference

Settings Class
Settings Members


Settings Class Properties

Settings Class Properties

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace : Settings Class

For a list of all members of this type, see Settings members.

Public Properties
 | Name | Description
Public Property | Encoding | Returns the value of the current Encoding setting.
Public Property | XslStylesheet | Gets or sets the path of the Xsl Stylesheet used during the rendering process.
Top
See Also

Reference

Settings Class
GrapeCity.ActiveReports.Export.Xml.Page Namespace


Encoding Property (Settings)

Encoding Property (Settings)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace > Settings Class : Encoding Property
Returns the value of the current Encoding setting.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Encoding As System.String
public System.string Encoding {get; set;}
See Also

Reference

Settings Class
Settings Members


XslStylesheet Property

XslStylesheet Property

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace > Settings Class : XslStylesheet Property
Gets or sets the path of the Xsl Stylesheet used during the rendering process.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property XslStylesheet As System.String
public System.string XslStylesheet {get; set;}
See Also

Reference

Settings Class
Settings Members


XmlRenderingExtension Class

XmlRenderingExtension Class
Members

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace : XmlRenderingExtension Class
Implementation of GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension. Allows to render GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReport to XML file.
Object Model
XmlRenderingExtension Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class XmlRenderingExtension
   Implements GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension
public sealed class XmlRenderingExtension : GrapeCity.ActiveReports.Extensibility.Rendering.IConfigurable, GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Export.Xml.Page.XmlRenderingExtension

See Also

Reference

XmlRenderingExtension Members
GrapeCity.ActiveReports.Export.Xml.Page Namespace


XmlRenderingExtension Class Members

XmlRenderingExtension Class Members
Methods

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace : XmlRenderingExtension Class

The following tables list the members exposed by XmlRenderingExtension.

Public Constructors
 | Name | Description
Public Constructor | XmlRenderingExtension Constructor | Initializes a new instance of XmlRenderingExtension class.
Top
Public Methods
 | Name | Description
Public Method | GetSupportedSettings | Gets supported settings of XmlRenderingExtension.
Top
See Also

Reference

XmlRenderingExtension Class
GrapeCity.ActiveReports.Export.Xml.Page Namespace


XmlRenderingExtension Constructor

XmlRenderingExtension Constructor

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace > XmlRenderingExtension Class : XmlRenderingExtension Constructor
Initializes a new instance of XmlRenderingExtension class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public XmlRenderingExtension()
See Also

Reference

XmlRenderingExtension Class
XmlRenderingExtension Members


XmlRenderingExtension Class Methods

XmlRenderingExtension Class Methods

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace : XmlRenderingExtension Class

For a list of all members of this type, see XmlRenderingExtension members.

Public Methods
 | Name | Description
Public Method | GetSupportedSettings | Gets supported settings of XmlRenderingExtension.
Top
See Also

Reference

XmlRenderingExtension Class
GrapeCity.ActiveReports.Export.Xml.Page Namespace


GetSupportedSettings() Method

GetSupportedSettings() Method

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace > XmlRenderingExtension Class > GetSupportedSettings Method : GetSupportedSettings() Method
Gets supported settings of XmlRenderingExtension.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetSupportedSettings() As ISettings
public ISettings GetSupportedSettings()
See Also

Reference

XmlRenderingExtension Class
XmlRenderingExtension Members
Overload List


GrapeCity.ActiveReports.Export.Xml.Section Namespace

GrapeCity.ActiveReports.Export.Xml.Section Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Xml.v10 Assembly : GrapeCity.ActiveReports.Export.Xml.Section Namespace
The GrapeCity.ActiveReports.Export.Xml.Section namespace contains the Text export classes.
Classes
 | Class | Description
Class | TextExport | Allows ActiveReports documents to be exported to plain text.
Class | TextExportException | The exception thrown when a TextExport-specific error occurs.
See Also

Reference

GrapeCity.ActiveReports.Export.Xml.v10 Assembly


TextExport Class

TextExport Class
Members Example

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace : TextExport Class
Allows ActiveReports documents to be exported to plain text.
Object Model
TextExport Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class TextExport
   Inherits System.ComponentModel.Component
   Implements GrapeCity.ActiveReports.Export.IDocumentExport, GrapeCity.ActiveReports.Export.IDocumentExportEx
public sealed class TextExport : System.ComponentModel.Component, GrapeCity.ActiveReports.Export.IDocumentExport, GrapeCity.ActiveReports.Export.IDocumentExportEx
Remarks
The default character encoding used for the TextExport is ASCII. If your reports may contain internationalized characters then consider using the Encoding property to specify the System.Text.UTF8Encoding or System.Text.UnicodeEncoding instead. The current Encoding’s preamble is written out according to the rules of System.IO.StreamWriter.
Example
This code sample assumes that you have a RichTextBox on the viewer's form.
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    GrapeCity.ActiveReports.Export.Xml.Section.TextExport t = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport();
    System.IO.MemoryStream s = new System.IO.MemoryStream();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    t.Encoding = System.Text.Encoding.Default;
    t.PageDelimiter = "\n" + "End of Page" + "\n" + "\n";
    t.SuppressEmptyLines = false;
    t.TextDelimiter = "        ";
    t.Export(rpt.Document, s,"1-2");
    s.Position = 0;
    this.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText);
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnExport.Click
    Dim rpt As New SectionReport1
    Dim t As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport
    Dim s = New System.IO.MemoryStream
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    t.Encoding = System.Text.Encoding.Default
    t.PageDelimiter = vbCrLf & "End of Page" & vbCrLf & vbCrLf
    t.SuppressEmptyLines = False
    t.TextDelimiter = "     "
    t.Export(rpt.Document, s, "1-2")
    s.position = 0
    Me.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText)
End Sub
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Export.Xml.Section.TextExport

See Also

Reference

TextExport Members
GrapeCity.ActiveReports.Export.Xml.Section Namespace


TextExport Class Members

TextExport Class Members
Properties Methods Events

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace : TextExport Class

The following tables list the members exposed by TextExport.

Public Constructors
 | Name | Description
Public Constructor | TextExport Constructor | Initializes a new instance of the TextExport class.
Top
Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Encoding | Gets or sets the character encoding used for the exported text.
Public Property | PageDelimiter | Gets or sets the character or sequence of characters that marks the beginning or end of a page.
Public Property | Pagination | Gets or sets the value, that indicates whether pagination should be used for resultant text document or not.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | SuppressEmptyLines | Gets or sets a value which determines whether empty lines will be inserted for layout purposes.
Public Property | TextDelimiter | Gets or sets the character or sequence of characters that marks the beginning or end of a text field.
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | Export | Overloaded. Exports the specified document to text format.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

TextExport Class
GrapeCity.ActiveReports.Export.Xml.Section Namespace


TextExport Constructor

TextExport Constructor

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : TextExport Constructor
Initializes a new instance of the TextExport class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public TextExport()
See Also

Reference

TextExport Class
TextExport Members


TextExport Class Methods

TextExport Class Methods

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace : TextExport Class

For a list of all members of this type, see TextExport members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | Export | Overloaded. Exports the specified document to text format.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

TextExport Class
GrapeCity.ActiveReports.Export.Xml.Section Namespace


Export Method (TextExport)

Export Method (TextExport)
Example

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : Export Method
Exports the specified document to text format.
Overload List
Overload | Description
Export(PageDocument,String) | Exports the specified document to a text format file.
Export(PageDocument,String,String) | Exports the specified document to a text format file.
Export(PageDocument,Stream) | Exports the specified document to the specified stream in Rich Text Format.
Export(PageDocument,Stream,String) | Exports the specified document to the specified stream in text format.
Export(IReport,String,String) | Exports the specified IReport to file
Export(IReport,String) | Exports the specified IReport to file
Export(IReport,Stream) | Exports the specified IReport to stream
Export(IReport,Stream,String) | Exports the specified IReport to stream
Export(SectionDocument,String,String) | Exports the specified range of pages in the document to a text file.
Export(SectionDocument,String) | Exports the specified document to a text file.
Export(SectionDocument,Stream) | Exports the specified document to a text stream.
Export(SectionDocument,Stream,String) | Exports the specified range of pages in the document to a text stream.
Example
This code sample assumes that you have a RichTextBox on the viewer's form.
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = New SectionReport();
    GrapeCity.ActiveReports.Export.Xml.Section.TextExport t = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport();
    System.IO.MemoryStream s = New System.IO.MemoryStream();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    t.Encoding = System.Text.Encoding.Default;
    t.PageDelimiter = "\n" + "End of Page" + "\n" + "\n";
    t.SuppressEmptyLines = false;
    t.TextDelimiter = "        ";
    t.Export(rpt.Document, s,"1-2");
    s.Position = 0;
    this.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText);
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnExport.Click
    Dim rpt As New SectionReport1
    Dim t As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport
    Dim s = New System.IO.MemoryStream
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    t.Encoding = System.Text.Encoding.Default
    t.PageDelimiter = vbCrLf & "End of Page" & vbCrLf & vbCrLf
    t.SuppressEmptyLines = False
    t.TextDelimiter = "     "
    t.Export(rpt.Document, s, "1-2")
    s.position = 0
    Me.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText)
End Sub
See Also

Reference

TextExport Class
TextExport Members


Export(PageDocument,String) Method

Export(PageDocument,String) Method

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class > Export Method : Export(PageDocument,String) Method
The ActiveReports PageDocument object to export.
The file name and path to save the main html file to.
Exports the specified document to a text format file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As System.String _
)
public void Export(
   PageDocument document,
   System.string filePath
)

Parameters

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main html file to.
See Also

Reference

TextExport Class
TextExport Members
Overload List


Export(PageDocument,String,String) Method

Export(PageDocument,String,String) Method

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class > Export Method : Export(PageDocument,String,String) Method
The ActiveReports PageDocument object to export.
The file name and path to save the main html file to.
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified document to a text format file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As System.String, _
   ByVal pageRange As System.String _
)
public void Export(
   PageDocument document,
   System.string filePath,
   System.string pageRange
)

Parameters

document
The ActiveReports PageDocument object to export.
filePath
The file name and path to save the main html file to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

TextExport Class
TextExport Members
Overload List


Export(PageDocument,Stream) Method

Export(PageDocument,Stream) Method

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class > Export Method : Export(PageDocument,Stream) Method
The ActiveReports PageDocument object to export.
The Stream to write the text to.
Exports the specified document to the specified stream in Rich Text Format.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal stream As System.IO.Stream _
)
public void Export(
   PageDocument document,
   System.IO.Stream stream
)

Parameters

document
The ActiveReports PageDocument object to export.
stream
The Stream to write the text to.
See Also

Reference

TextExport Class
TextExport Members
Overload List


Export(PageDocument,Stream,String) Method

Export(PageDocument,Stream,String) Method

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class > Export Method : Export(PageDocument,Stream,String) Method
The ActiveReports PageDocument object to export.
The Stream to write the text to.
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified document to the specified stream in text format.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal stream As System.IO.Stream, _
   ByVal pageRange As System.String _
)
public void Export(
   PageDocument document,
   System.IO.Stream stream,
   System.string pageRange
)

Parameters

document
The ActiveReports PageDocument object to export.
stream
The Stream to write the text to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

TextExport Class
TextExport Members
Overload List


Export(IReport,String,String) Method

Export(IReport,String,String) Method

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class > Export Method : Export(IReport,String,String) Method
IReport instance to Export
Path to export
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified IReport to file
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal filePath As System.String, _
   ByVal pageRange As System.String _
)
public void Export(
   IReport report,
   System.string filePath,
   System.string pageRange
)

Parameters

report
IReport instance to Export
filePath
Path to export
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

TextExport Class
TextExport Members
Overload List


Export(IReport,String) Method

Export(IReport,String) Method

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class > Export Method : Export(IReport,String) Method
IReport instance to Export
Path to export
Exports the specified IReport to file
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal filePath As System.String _
)
public void Export(
   IReport report,
   System.string filePath
)

Parameters

report
IReport instance to Export
filePath
Path to export
See Also

Reference

TextExport Class
TextExport Members
Overload List


Export(IReport,Stream) Method

Export(IReport,Stream) Method

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class > Export Method : Export(IReport,Stream) Method
IReport instance to Export
The output stream.
Exports the specified IReport to stream
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal outputStream As System.IO.Stream _
)
public void Export(
   IReport report,
   System.IO.Stream outputStream
)

Parameters

report
IReport instance to Export
outputStream
The output stream.
See Also

Reference

TextExport Class
TextExport Members
Overload List


Export(IReport,Stream,String) Method

Export(IReport,Stream,String) Method

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class > Export Method : Export(IReport,Stream,String) Method
IReport instance to Export
The output stream.
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified IReport to stream
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal outputStream As System.IO.Stream, _
   ByVal pageRange As System.String _
)
public void Export(
   IReport report,
   System.IO.Stream outputStream,
   System.string pageRange
)

Parameters

report
IReport instance to Export
outputStream
The output stream.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

TextExport Class
TextExport Members
Overload List


Export(SectionDocument,String,String) Method

Export(SectionDocument,String,String) Method
Example

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class > Export Method : Export(SectionDocument,String,String) Method
The ActiveReports object to export.
The file name and path to which to save the text.
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.
Exports the specified range of pages in the document to a text file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As System.String, _
   ByVal pageRange As System.String _
)
public void Export(
   SectionDocument document,
   System.string filePath,
   System.string pageRange
)

Parameters

document
The ActiveReports object to export.
filePath
The file name and path to which to save the text.
pageRange
A range of page numbers. Ranges are indicated by the use of a hyphen between the starting and ending page numbers in the range. Single pages may also be included. Each range or single page is separated by a comma.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = New  SectionReport1();
    GrapeCity.ActiveReports.Export.Xml.Section.TextExport t = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    t.Encoding = System.Text.Encoding.Default;
    t.PageDelimiter = "\n" + "End of Page" + "\n" + "\n";
    t.SuppressEmptyLines = false;
    t.TextDelimiter = "        ";
    t.Export(rpt.Document, Application.StartupPath & "\\t.txt", "1-3");
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnExport.Click
    Dim rpt As New SectionReport1
    Dim t As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    t.Encoding = System.Text.Encoding.Default
    t.PageDelimiter = vbCrLf & "End of Page" & vbCrLf & vbCrLf
    t.SuppressEmptyLines = False
    t.TextDelimiter = "     "
    t.Export(rpt.Document, Application.StartupPath & "\t.txt", "1-3")
End Sub
See Also

Reference

TextExport Class
TextExport Members
Overload List


Export(SectionDocument,String) Method

Export(SectionDocument,String) Method
Example

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class > Export Method : Export(SectionDocument,String) Method
The ActiveReports object to export.
The file name and path to which to save the text.
Exports the specified document to a text file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal filePath As System.String _
)
public void Export(
   SectionDocument document,
   System.string filePath
)

Parameters

document
The ActiveReports object to export.
filePath
The file name and path to which to save the text.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
     SectionReport1 rpt = New  SectionReport1();
    GrapeCity.ActiveReports.Export.Xml.Section.TextExport t = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    t.Encoding = System.Text.Encoding.Default;
    t.PageDelimiter = "\n" + "End of Page" + "\n" + "\n";
    t.SuppressEmptyLines = false;
    t.TextDelimiter = "        ";
    t.Export(rpt.Document, Application.StartupPath & "\\t.txt");
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnExport.Click
    Dim rpt As New SectionReport1
    Dim t As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    t.Encoding = System.Text.Encoding.Default
    t.PageDelimiter = vbCrLf & "End of Page" & vbCrLf & vbCrLf
    t.SuppressEmptyLines = False
    t.TextDelimiter = "     "
    t.Export(rpt.Document, Application.StartupPath & "\t.txt")
End Sub
See Also

Reference

TextExport Class
TextExport Members
Overload List


Export(SectionDocument,Stream) Method

Export(SectionDocument,Stream) Method
Example

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class > Export Method : Export(SectionDocument,Stream) Method
The ActiveReports object to export.
The System.IO.Stream to which to save the text.
Exports the specified document to a text stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As System.IO.Stream _
)
public void Export(
   SectionDocument document,
   System.IO.Stream outputStream
)

Parameters

document
The ActiveReports object to export.
outputStream
The System.IO.Stream to which to save the text.
Example
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = New  SectionReport1();
    GrapeCity.ActiveReports.Export.Xml.Section.TextExport t = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport();
    System.IO.MemoryStream s = New System.IO.MemoryStream();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    t.Encoding = System.Text.Encoding.Default;
    t.PageDelimiter = "\n" + "End of Page" + "\n" + "\n";
    t.SuppressEmptyLines = false;
    t.TextDelimiter = "        ";
    t.Export(rpt.Document, s);
    s.Position = 0;
    this.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText);
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnExport.Click
    Dim rpt As New SectionReport1
    Dim t As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport
    Dim s = New System.IO.MemoryStream
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    t.Encoding = System.Text.Encoding.Default
    t.PageDelimiter = vbCrLf & "End of Page" & vbCrLf & vbCrLf
    t.SuppressEmptyLines = False
    t.TextDelimiter = "     "
    t.Export(rpt.Document, s)
    s.position = 0
    Me.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText)
End Sub
See Also

Reference

TextExport Class
TextExport Members
Overload List


Export(SectionDocument,Stream,String) Method

Export(SectionDocument,Stream,String) Method
Example

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class > Export Method : Export(SectionDocument,Stream,String) Method
The ActiveReports Document object to export.
The Stream to write the text to.
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified range of pages in the document to a text stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal document As SectionDocument, _
   ByVal outputStream As System.IO.Stream, _
   ByVal pageRange As System.String _
)
public void Export(
   SectionDocument document,
   System.IO.Stream outputStream,
   System.string pageRange
)

Parameters

document
The ActiveReports Document object to export.
outputStream
The Stream to write the text to.
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Example
This code sample assumes that you have a RichTextBox on the viewer's form.
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = New SectionReport1();
    GrapeCity.ActiveReports.Export.Xml.Section.TextExport t = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport();
    System.IO.MemoryStream s = New System.IO.MemoryStream();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    t.Encoding = System.Text.Encoding.Default;
    t.PageDelimiter = "\n" + "End of Page" + "\n" + "\n";
    t.SuppressEmptyLines = false;
    t.TextDelimiter = "        ";
    t.Export(rpt.Document, s,"1-2");
    s.Position = 0;
    this.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText);
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnExport.Click
    Dim rpt As New SectionReport1
    Dim t As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport
    Dim s = New System.IO.MemoryStream
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    t.Encoding = System.Text.Encoding.Default
    t.PageDelimiter = vbCrLf & "End of Page" & vbCrLf & vbCrLf
    t.SuppressEmptyLines = False
    t.TextDelimiter = "     "
    t.Export(rpt.Document, s, "1-2")
    s.position = 0
    Me.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText)
End Sub
See Also

Reference

TextExport Class
TextExport Members
Overload List


TextExport Class Properties

TextExport Class Properties

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace : TextExport Class

For a list of all members of this type, see TextExport members.

Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Encoding | Gets or sets the character encoding used for the exported text.
Public Property | PageDelimiter | Gets or sets the character or sequence of characters that marks the beginning or end of a page.
Public Property | Pagination | Gets or sets the value, that indicates whether pagination should be used for resultant text document or not.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | SuppressEmptyLines | Gets or sets a value which determines whether empty lines will be inserted for layout purposes.
Public Property | TextDelimiter | Gets or sets the character or sequence of characters that marks the beginning or end of a text field.
Top
See Also

Reference

TextExport Class
GrapeCity.ActiveReports.Export.Xml.Section Namespace


Encoding Property (TextExport)

Encoding Property (TextExport)
Example

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : Encoding Property
Gets or sets the character encoding used for the exported text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Encoding As System.Text.Encoding
public System.Text.Encoding Encoding {get; set;}

Property Value

System.Text.Encoding enumeration. The default value is System.Text.Encoding.ASCII
Example
This code sample assumes that you have a RichTextBox on the viewer's form.
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = New SectionReport1();
    GrapeCity.ActiveReports.Export.Xml.Section.TextExport t = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport();
    System.IO.MemoryStream s = New System.IO.MemoryStream();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    t.Encoding = System.Text.Encoding.Default;
    t.PageDelimiter = "\n" + "End of Page" + "\n" + "\n";
    t.SuppressEmptyLines = false;
    t.TextDelimiter = "        ";
    t.Export(rpt.Document, s,"1-2");
    s.Position = 0;
    this.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText);
}
  • VB.NET
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnExport.Click
    Dim rpt As New SectionReport1
    Dim t As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport
    Dim s = New System.IO.MemoryStream
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    t.Encoding = System.Text.Encoding.Default
    t.PageDelimiter = vbCrLf & "End of Page" & vbCrLf & vbCrLf
    t.SuppressEmptyLines = False
    t.TextDelimiter = "     "
    t.Export(rpt.Document, s, "1-2")
    s.position = 0
    Me.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText)
End Sub
See Also

Reference

TextExport Class
TextExport Members


PageDelimiter Property

PageDelimiter Property
Example

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : PageDelimiter Property
Gets or sets the character or sequence of characters that marks the beginning or end of a page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageDelimiter As System.String
public System.string PageDelimiter {get; set;}

Property Value

String. The default value is an empty string.
Example
This code sample assumes that you have a RichTextBox on the viewer's form.
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = New SectionReport1();
    GrapeCity.ActiveReports.Export.Xml.Section.TextExport t = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport();
    System.IO.MemoryStream s = New System.IO.MemoryStream();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    t.Encoding = System.Text.Encoding.Default;
    t.PageDelimiter = "\n" + "End of Page" + "\n" + "\n";
    t.SuppressEmptyLines = false;
    t.TextDelimiter = "        ";
    t.Export(rpt.Document, s,"1-2");
    s.Position = 0;
    this.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText);
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnExport.Click
    Dim rpt As New SectionReport1
    Dim t As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport
    Dim s = New System.IO.MemoryStream
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    t.Encoding = System.Text.Encoding.Default
    t.PageDelimiter = vbCrLf & "End of Page" & vbCrLf & vbCrLf
    t.SuppressEmptyLines = False
    t.TextDelimiter = "     "
    t.Export(rpt.Document, s, "1-2")
    s.position = 0
    Me.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText)
End Sub
See Also

Reference

TextExport Class
TextExport Members


Pagination Property (TextExport)

Pagination Property (TextExport)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : Pagination Property
Gets or sets the value, that indicates whether pagination should be used for resultant text document or not.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Pagination As System.Boolean
public System.bool Pagination {get; set;}
Requirements

See Also

Reference

TextExport Class
TextExport Members


SuppressEmptyLines Property

SuppressEmptyLines Property
Example

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : SuppressEmptyLines Property
Gets or sets a value which determines whether empty lines will be inserted for layout purposes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SuppressEmptyLines As System.Boolean
public System.bool SuppressEmptyLines {get; set;}

Property Value

Boolean. The default value is True.
Example
This code sample assumes that you have a RichTextBox on the viewer's form.
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = New SectionReport1();
    GrapeCity.ActiveReports.Export.Xml.Section.TextExport t = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport();
    System.IO.MemoryStream s = New System.IO.MemoryStream();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    t.Encoding = System.Text.Encoding.Default;
    t.PageDelimiter = "\n" + "End of Page" + "\n" + "\n";
    t.SuppressEmptyLines = false;
    t.TextDelimiter = "        ";
    t.Export(rpt.Document, s,"1-2");
    s.Position = 0;
    this.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText);
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnExport.Click
    Dim rpt As New SectionReport1
    Dim t As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport
    Dim s = New System.IO.MemoryStream
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    t.Encoding = System.Text.Encoding.Default
    t.PageDelimiter = vbCrLf & "End of Page" & vbCrLf & vbCrLf
    t.SuppressEmptyLines = False
    t.TextDelimiter = "     "
    t.Export(rpt.Document, s, "1-2")
    s.position = 0
    Me.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText)
End Sub
See Also

Reference

TextExport Class
TextExport Members


TextDelimiter Property

TextDelimiter Property
Example

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : TextDelimiter Property
Gets or sets the character or sequence of characters that marks the beginning or end of a text field.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TextDelimiter As System.String
public System.string TextDelimiter {get; set;}

Property Value

String. The default value is a comma (,).
Example
This code sample assumes that you have a RichTextBox on the viewer's form.
  • C#
private void btnExport_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = New SectionReport1();
    GrapeCity.ActiveReports.Export.Xml.Section.TextExport t = new GrapeCity.ActiveReports.Export.Xml.Section.TextExport();
    System.IO.MemoryStream s = New System.IO.MemoryStream();
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
    t.Encoding = System.Text.Encoding.Default;
    t.PageDelimiter = "\n" + "End of Page" + "\n" + "\n";
    t.SuppressEmptyLines = false;
    t.TextDelimiter = "        ";
    t.Export(rpt.Document, s,"1-2");
    s.Position = 0;
    this.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText);
}
  • Visual Basic
Private Sub btnExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnExport.Click
    Dim rpt As New SectionReport1
    Dim t As New GrapeCity.ActiveReports.Export.Xml.Section.TextExport
    Dim s = New System.IO.MemoryStream
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    t.Encoding = System.Text.Encoding.Default
    t.PageDelimiter = vbCrLf & "End of Page" & vbCrLf & vbCrLf
    t.SuppressEmptyLines = False
    t.TextDelimiter = "     "
    t.Export(rpt.Document, s, "1-2")
    s.position = 0
    Me.rtbWinForm.LoadFile(s, RichTextBoxStreamType.PlainText)
End Sub
See Also

Reference

TextExport Class
TextExport Members


TextExportException Class

TextExportException Class
Members

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace : TextExportException Class

The exception thrown when a TextExport-specific error occurs.

Object Model
TextExportException Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class TextExportException
   Inherits System.ApplicationException
public class TextExportException : System.ApplicationException
Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Export.Xml.Section.TextExportException

See Also

Reference

TextExportException Members
GrapeCity.ActiveReports.Export.Xml.Section Namespace


TextExportException Class Members

TextExportException Class Members
Properties Methods

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace : TextExportException Class

The following tables list the members exposed by TextExportException.

Public Constructors
 | Name | Description
Public Constructor | TextExportException Constructor | Overloaded. Initializes a new instance of the TextExportException class.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

TextExportException Class
GrapeCity.ActiveReports.Export.Xml.Section Namespace


TextExportException Constructor

TextExportException Constructor

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : TextExportException Constructor
Initializes a new instance of the TextExportException class.
Overload List
Overload | Description
TextExportException Constructor(String) | Initializes a new instance of the TextExportException class with the specified error message.
TextExportException Constructor(String,Exception) | Initializes a new instance of the TextExportException class with the specified error message and a reference to the inner exception that is the cause of this exception.
TextExportException Constructor(SerializationInfo,StreamingContext) | Initializes a new instance of the TextExportException class with serialized data.
See Also

Reference

TextExportException Class
TextExportException Members


TextExportException Constructor(String)

TextExportException Constructor(String)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class > TextExportException Constructor : TextExportException Constructor(String)
A message that describes the error.
Initializes a new instance of the TextExportException class with the specified error message.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String _
)
public TextExportException(
   System.string message
)

Parameters

message
A message that describes the error.
See Also

Reference

TextExportException Class
TextExportException Members
Overload List


TextExportException Constructor(String,Exception)

TextExportException Constructor(String,Exception)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class > TextExportException Constructor : TextExportException Constructor(String,Exception)
A message that describes the error.
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
Initializes a new instance of the TextExportException class with the specified error message and a reference to the inner exception that is the cause of this exception.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String, _
   ByVal innerException As System.Exception _
)
public TextExportException(
   System.string message,
   System.Exception innerException
)

Parameters

message
A message that describes the error.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
See Also

Reference

TextExportException Class
TextExportException Members
Overload List


TextExportException Constructor(SerializationInfo,StreamingContext)

TextExportException Constructor(SerializationInfo,StreamingContext)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class > TextExportException Constructor : TextExportException Constructor(SerializationInfo,StreamingContext)

Holds all the data needed to serialize or deserialize the object.

Describes the source and destination of a given serialized stream, as well as a means for serialization to retain that context and an additional caller-defined context.
Initializes a new instance of the TextExportException class with serialized data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public TextExportException(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info

Holds all the data needed to serialize or deserialize the object.

context
Describes the source and destination of a given serialized stream, as well as a means for serialization to retain that context and an additional caller-defined context.
See Also

Reference

TextExportException Class
TextExportException Members
Overload List


GrapeCity.ActiveReports.Extensibility Namespace

GrapeCity.ActiveReports.Extensibility Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility Namespace
The GrapeCity.ActiveReports.Extensibility namespace includes IExtension interface.
Classes
 | Class | Description
Class | ResourceLocator | Abstract base class for resource Locator.
Interfaces
 | Interface | Description
Interface | IExtension | Defines an Extension.
Structures
 | Structure | Description
Structure | Resource | Represents report resource returned by ResourceLocator.GetResource.
Structure | ResourceInfo | Provides information about resource to be located by ResourceLocator.
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


ResourceLocator Class

ResourceLocator Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace : ResourceLocator Class
Abstract base class for resource Locator.
Object Model
ResourceLocator Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class ResourceLocator
public abstract class ResourceLocator
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.ResourceLocator

See Also

Reference

ResourceLocator Members
GrapeCity.ActiveReports.Extensibility Namespace


ResourceLocator Class Members

ResourceLocator Class Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace : ResourceLocator Class

The following tables list the members exposed by ResourceLocator.

Public Properties
 | Name | Description
Public Property | BaseUri | Base System.Uri that all the resources are located relatively to.
Public Property | ServiceProvider | Gets or sets System.IServiceProvider instance used to obtain Report services.
Top
Public Methods
 | Name | Description
Public Method | GetResource | Overloaded. Gets Resource by its ResourceInfo.
Top
See Also

Reference

ResourceLocator Class
GrapeCity.ActiveReports.Extensibility Namespace


ResourceLocator Class Methods

ResourceLocator Class Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace : ResourceLocator Class

For a list of all members of this type, see ResourceLocator members.

Public Methods
 | Name | Description
Public Method | GetResource | Overloaded. Gets Resource by its ResourceInfo.
Top
See Also

Reference

ResourceLocator Class
GrapeCity.ActiveReports.Extensibility Namespace


GetResource Method

GetResource Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace > ResourceLocator Class : GetResource Method
Gets Resource by its ResourceInfo.
Overload List
Overload | Description
GetResource(ResourceInfo) | Gets Resource by it's ResourceInfo.
GetResource(ResourceInfo,IServiceProvider) |
See Also

Reference

ResourceLocator Class
ResourceLocator Members


GetResource(ResourceInfo) Method

GetResource(ResourceInfo) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace > ResourceLocator Class > GetResource Method : GetResource(ResourceInfo) Method
ResourceInfo instance contains information about resource to be located.
Gets Resource by it's ResourceInfo.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads MustOverride Function GetResource( _
   ByVal resourceInfo As ResourceInfo _
) As Resource
public abstract Resource GetResource(
   ResourceInfo resourceInfo
)

Parameters

resourceInfo
ResourceInfo instance contains information about resource to be located.

Return Value

Resource contains resource that was located.
See Also

Reference

ResourceLocator Class
ResourceLocator Members
Overload List


GetResource(ResourceInfo,IServiceProvider) Method

GetResource(ResourceInfo,IServiceProvider) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace > ResourceLocator Class > GetResource Method : GetResource(ResourceInfo,IServiceProvider) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overridable Function GetResource( _
   ByVal resourceInfo As ResourceInfo, _
   ByVal serviceProvider As System.IServiceProvider _
) As Resource
public virtual Resource GetResource(
   ResourceInfo resourceInfo,
   System.IServiceProvider serviceProvider
)

Parameters

resourceInfo
serviceProvider
See Also

Reference

ResourceLocator Class
ResourceLocator Members
Overload List


ResourceLocator Class Properties

ResourceLocator Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace : ResourceLocator Class

For a list of all members of this type, see ResourceLocator members.

Public Properties
 | Name | Description
Public Property | BaseUri | Base System.Uri that all the resources are located relatively to.
Public Property | ServiceProvider | Gets or sets System.IServiceProvider instance used to obtain Report services.
Top
See Also

Reference

ResourceLocator Class
GrapeCity.ActiveReports.Extensibility Namespace


BaseUri Property

BaseUri Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace > ResourceLocator Class : BaseUri Property
Base System.Uri that all the resources are located relatively to.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BaseUri As System.Uri
public System.Uri BaseUri {get; set;}
See Also

Reference

ResourceLocator Class
ResourceLocator Members


ServiceProvider Property

ServiceProvider Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace > ResourceLocator Class : ServiceProvider Property
Gets or sets System.IServiceProvider instance used to obtain Report services.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ServiceProvider As System.IServiceProvider
public System.IServiceProvider ServiceProvider {get; set;}
See Also

Reference

ResourceLocator Class
ResourceLocator Members


Resource Structure

Resource Structure
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace : Resource Structure
Represents report resource returned by ResourceLocator.GetResource.
Object Model
Resource Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure Resource
   Inherits System.ValueType
public struct Resource : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Resource

See Also

Reference

Resource Members
GrapeCity.ActiveReports.Extensibility Namespace


Resource Structure Members

Resource Structure Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace : Resource Structure

The following tables list the members exposed by Resource.

Public Constructors
 | Name | Description
Public Constructor | Resource Constructor | Initiazlies new instance of Resource.
Top
Public Properties
 | Name | Description
Public Property | ParentUri | Gets or sets parent Uri of located resource.
Public Property | Value | Gets System.IO.Stream contains resource content.
Top
See Also

Reference

Resource Structure
GrapeCity.ActiveReports.Extensibility Namespace


Resource Constructor

Resource Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace > Resource Structure : Resource Constructor
System.IO.Stream contains resource content.
Parent Uri of located resource.
Initiazlies new instance of Resource.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal stream As System.IO.Stream, _
   ByVal parentUri As System.Uri _
)
public Resource(
   System.IO.Stream stream,
   System.Uri parentUri
)

Parameters

stream
System.IO.Stream contains resource content.
parentUri
Parent Uri of located resource.
See Also

Reference

Resource Structure
Resource Members


Resource Structure Properties

Resource Structure Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace : Resource Structure

For a list of all members of this type, see Resource members.

Public Properties
 | Name | Description
Public Property | ParentUri | Gets or sets parent Uri of located resource.
Public Property | Value | Gets System.IO.Stream contains resource content.
Top
See Also

Reference

Resource Structure
GrapeCity.ActiveReports.Extensibility Namespace


ParentUri Property

ParentUri Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace > Resource Structure : ParentUri Property
Gets or sets parent Uri of located resource.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ParentUri As System.Uri
public System.Uri ParentUri {get;}
See Also

Reference

Resource Structure
Resource Members


Value Property (Resource)

Value Property (Resource)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace > Resource Structure : Value Property
Gets System.IO.Stream contains resource content.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Value As System.IO.Stream
public System.IO.Stream Value {get;}
See Also

Reference

Resource Structure
Resource Members


ResourceInfo Structure

ResourceInfo Structure
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace : ResourceInfo Structure
Provides information about resource to be located by ResourceLocator.
Object Model
ResourceInfo Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure ResourceInfo
   Inherits System.ValueType
public struct ResourceInfo : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.ResourceInfo

See Also

Reference

ResourceInfo Members
GrapeCity.ActiveReports.Extensibility Namespace


ResourceInfo Structure Members

ResourceInfo Structure Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace : ResourceInfo Structure

The following tables list the members exposed by ResourceInfo.

Public Constructors
 | Name | Description
Public Constructor | ResourceInfo Constructor | Initializes new instance of ResourceInfo.
Top
Public Properties
 | Name | Description
Public Property | Name | Gets the name of the resource to be located.
Top
See Also

Reference

ResourceInfo Structure
GrapeCity.ActiveReports.Extensibility Namespace


ResourceInfo Constructor

ResourceInfo Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace > ResourceInfo Structure : ResourceInfo Constructor
Name of the resource to be located.
Initializes new instance of ResourceInfo.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As System.String _
)
public ResourceInfo(
   System.string name
)

Parameters

name
Name of the resource to be located.
See Also

Reference

ResourceInfo Structure
ResourceInfo Members


ResourceInfo Structure Properties

ResourceInfo Structure Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace : ResourceInfo Structure

For a list of all members of this type, see ResourceInfo members.

Public Properties
 | Name | Description
Public Property | Name | Gets the name of the resource to be located.
Top
See Also

Reference

ResourceInfo Structure
GrapeCity.ActiveReports.Extensibility Namespace


Name Property (ResourceInfo)

Name Property (ResourceInfo)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace > ResourceInfo Structure : Name Property
Gets the name of the resource to be located.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Name As System.String
public System.string Name {get;}
See Also

Reference

ResourceInfo Structure
ResourceInfo Members


IExtension Interface

IExtension Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace : IExtension Interface
Defines an Extension.
Object Model
IExtension Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IExtension
public interface IExtension
See Also

Reference

IExtension Members
GrapeCity.ActiveReports.Extensibility Namespace


IExtension Interface Members

IExtension Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace : IExtension Interface

The following tables list the members exposed by IExtension.

Public Properties
 | Name | Description
Property | LocalizedName | The localized name for this extension.
Top
Public Methods
 | Name | Description
Method | SetConfiguration | Specifies any configuration information for this extension.
Top
See Also

Reference

IExtension Interface
GrapeCity.ActiveReports.Extensibility Namespace


IExtension Interface Methods

IExtension Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace : IExtension Interface

For a list of all members of this type, see IExtension members.

Public Methods
 | Name | Description
Method | SetConfiguration | Specifies any configuration information for this extension.
Top
See Also

Reference

IExtension Interface
GrapeCity.ActiveReports.Extensibility Namespace


SetConfiguration Method

SetConfiguration Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace > IExtension Interface : SetConfiguration Method
Configuration information.
Specifies any configuration information for this extension.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub SetConfiguration( _
   ByVal configurationSettings As System.Collections.Specialized.NameValueCollection _
)
void SetConfiguration(
   System.Collections.Specialized.NameValueCollection configurationSettings
)

Parameters

configurationSettings
Configuration information.
See Also

Reference

IExtension Interface
IExtension Members


IExtension Interface Properties

IExtension Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace : IExtension Interface

For a list of all members of this type, see IExtension members.

Public Properties
 | Name | Description
Property | LocalizedName | The localized name for this extension.
Top
See Also

Reference

IExtension Interface
GrapeCity.ActiveReports.Extensibility Namespace


LocalizedName Property

LocalizedName Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility Namespace > IExtension Interface : LocalizedName Property
The localized name for this extension.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LocalizedName As System.String
System.string LocalizedName {get;}
See Also

Reference

IExtension Interface
IExtension Members


GrapeCity.ActiveReports.Extensibility.Data Namespace

GrapeCity.ActiveReports.Extensibility.Data Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Data Namespace
The GrapeCity.ActiveReports.Extensibility.Data namespace contains the types for describing the report runtime components.
Classes
 | Class | Description
Class | DataProviderFactory | Represents an abstract factory for data provider implementations.
Class | DataRow | Data row.
Class | DataTable | Represents result set of query execution.
Interfaces
 | Interface | Description
Interface | ICredentialsLocator | Allows to override login/password retrieval behavior.
Interface | IDataParameter | Represents a parameter used with an IDbCommand Interface.
Interface | IDataParameterCollection | Represents a collection of IDataParameter objects.
Interface | IDataProviderFactoryExtended | Extends the data provider factory by the additional functionality.
Interface | IDataProviderService | Exposes the services that can be used by data providers.
Interface | IDataReader | Provides a means of reading a forward-only result set.
Interface | IDataRecord | Provides access to the fields of a single record.
Interface | IDataSourceLocator | Allows to override data retrieval behavior.
Interface | IDbCommand | Represents a statement executed while connected to a data source.
Interface | IDbCommandExtension | This is an optional interface implemented by classes that implement IDbCommand Interface. Use it to provide additional information about a command.
Interface | IDbConnection | Represents a connection to a data source.
Interface | IDbConnectionExtension | Defines additional credential settings that can be supported by an IDbConnection-derived type.
Interface | IDbSchemaProvider | Specifies the schema provider.
Interface | IDbTransaction | Represents a transaction to be performed on a data source.
Interface | IDbTransactionExtension | Defines additional settings that can be supported by an IDbTransaction-derived type.
Structures
 | Structure | Description
Structure | DataColumn | Data column.
Structure | LoginPasswordCredentials | Defines login/password credentials
Enumerations
 | Enumeration | Description
Enumeration | CommandBehavior | Specifies the kind of results an IDbCommand Interface returns.
Enumeration | CommandType | Specifies how a command's CommandText Property is interpreted.
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


DataProviderFactory Class

DataProviderFactory Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataProviderFactory Class
Represents an abstract factory for data provider implementations.
Object Model
DataProviderFactory Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class DataProviderFactory
public abstract class DataProviderFactory
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Data.DataProviderFactory

See Also

Reference

DataProviderFactory Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


DataProviderFactory Class Members

DataProviderFactory Class Members
Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataProviderFactory Class

The following tables list the members exposed by DataProviderFactory.

Public Methods
 | Name | Description
Public Method | CreateCommand | Returns a new instance of the provider's class that implements IDbCommand.
Public Method | CreateConnection | Returns a new instance of the provider's class that implements IDbConnection.
Top
See Also

Reference

DataProviderFactory Class
GrapeCity.ActiveReports.Extensibility.Data Namespace


DataProviderFactory Class Methods

DataProviderFactory Class Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataProviderFactory Class

For a list of all members of this type, see DataProviderFactory members.

Public Methods
 | Name | Description
Public Method | CreateCommand | Returns a new instance of the provider's class that implements IDbCommand.
Public Method | CreateConnection | Returns a new instance of the provider's class that implements IDbConnection.
Top
See Also

Reference

DataProviderFactory Class
GrapeCity.ActiveReports.Extensibility.Data Namespace


CreateCommand Method (DataProviderFactory)

CreateCommand Method (DataProviderFactory)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataProviderFactory Class : CreateCommand Method
Returns a new instance of the provider's class that implements IDbCommand.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Function CreateCommand() As IDbCommand
public abstract IDbCommand CreateCommand()

Return Value

A new instance of IDbCommand.
See Also

Reference

DataProviderFactory Class
DataProviderFactory Members


CreateConnection Method

CreateConnection Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataProviderFactory Class : CreateConnection Method
Returns a new instance of the provider's class that implements IDbConnection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Function CreateConnection() As IDbConnection
public abstract IDbConnection CreateConnection()

Return Value

A new instance of IDbConnection.
See Also

Reference

DataProviderFactory Class
DataProviderFactory Members


DataRow Class

DataRow Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataRow Class
Data row.
Object Model
DataRow Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DataRow
public sealed class DataRow
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Data.DataRow

See Also

Reference

DataRow Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


DataRow Class Members

DataRow Class Members
Fields

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataRow Class

The following tables list the members exposed by DataRow.

Public Constructors
 | Name | Description
Public Constructor | DataRow Constructor | Creates new instance of DataRow.
Top
Public Fields
 | Name | Description
Public Field | Values | The row data.
Top
See Also

Reference

DataRow Class
GrapeCity.ActiveReports.Extensibility.Data Namespace


DataRow Constructor

DataRow Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataRow Class : DataRow Constructor
The row data.
Creates new instance of DataRow.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal values() As System.Object _
)
public DataRow(
   System.object[] values
)

Parameters

values
The row data.
See Also

Reference

DataRow Class
DataRow Members


DataRow Class Fields

DataRow Class Fields

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataRow Class

For a list of all members of this type, see DataRow members.

Public Fields
 | Name | Description
Public Field | Values | The row data.
Top
See Also

Reference

DataRow Class
GrapeCity.ActiveReports.Extensibility.Data Namespace


Values Field

Values Field

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataRow Class : Values Field
The row data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Values As System.Object()
public readonly System.object[] Values
See Also

Reference

DataRow Class
DataRow Members


DataTable Class

DataTable Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataTable Class
Represents result set of query execution.
Object Model
DataTable Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DataTable
public sealed class DataTable
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Data.DataTable

See Also

Reference

DataTable Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


DataTable Class Members

DataTable Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataTable Class

The following tables list the members exposed by DataTable.

Public Constructors
 | Name | Description
Public Constructor | DataTable Constructor | Creates new instance of DataTable.
Top
Public Properties
 | Name | Description
Public Property | Columns | Gets table columns.
Public Property | Rows | Gets table rows.
Top
See Also

Reference

DataTable Class
GrapeCity.ActiveReports.Extensibility.Data Namespace


DataTable Constructor

DataTable Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataTable Class : DataTable Constructor
The table columns.
The table rows.
Creates new instance of DataTable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal columns As System.Collections.Generic.IEnumerable(Of DataColumn), _
   ByVal rows As System.Collections.Generic.IEnumerable(Of DataRow) _
)
public DataTable(
   System.Collections.Generic.IEnumerable<DataColumn> columns,
   System.Collections.Generic.IEnumerable<DataRow> rows
)

Parameters

columns
The table columns.
rows
The table rows.
See Also

Reference

DataTable Class
DataTable Members


DataTable Class Properties

DataTable Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataTable Class

For a list of all members of this type, see DataTable members.

Public Properties
 | Name | Description
Public Property | Columns | Gets table columns.
Public Property | Rows | Gets table rows.
Top
See Also

Reference

DataTable Class
GrapeCity.ActiveReports.Extensibility.Data Namespace


Columns Property (DataTable)

Columns Property (DataTable)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataTable Class : Columns Property
Gets table columns.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Columns As IItemCollection(Of DataColumn)
public IItemCollection<DataColumn> Columns {get;}
See Also

Reference

DataTable Class
DataTable Members


Rows Property (DataTable)

Rows Property (DataTable)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataTable Class : Rows Property
Gets table rows.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Rows As IItemCollection(Of DataRow)
public IItemCollection<DataRow> Rows {get;}
See Also

Reference

DataTable Class
DataTable Members


CommandBehavior Enumeration

CommandBehavior Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : CommandBehavior Enumeration
Specifies the kind of results an IDbCommand Interface returns.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum CommandBehavior
   Inherits System.Enum
public enum CommandBehavior : System.Enum
Members
Member | Description
SchemaOnly | A single record is returned.
SingleResult | Only column information or the command's results are returned.
SingleRow | Indicates that the command result is expected to return a single row. Execution of the query may effect the database state. Data providers may or may not optimize the command based on this setting.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Data.CommandBehavior

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Data Namespace


CommandType Enumeration

CommandType Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : CommandType Enumeration
Specifies how a command's CommandText Property is interpreted.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum CommandType
   Inherits System.Enum
public enum CommandType : System.Enum
Members
Member | Description
StoredProcedure | The name of the stored procedure.
TableDirect | The name of a table.
Text | A plain text command (usually SQL).
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Data.CommandType

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Data Namespace


DataColumn Structure

DataColumn Structure
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataColumn Structure
Data column.
Object Model
DataColumn Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure DataColumn
   Inherits System.ValueType
public struct DataColumn : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Data.DataColumn

See Also

Reference

DataColumn Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


DataColumn Structure Members

DataColumn Structure Members
Fields

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataColumn Structure

The following tables list the members exposed by DataColumn.

Public Constructors
 | Name | Description
Public Constructor | DataColumn Constructor | Creates new instance of DataColumn.
Top
Public Fields
 | Name | Description
Public Field | DataType | Specifies data type of the column.
Public Field | Name | Specifies column name.
Top
See Also

Reference

DataColumn Structure
GrapeCity.ActiveReports.Extensibility.Data Namespace


DataColumn Constructor

DataColumn Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataColumn Structure : DataColumn Constructor
The column name.
The column type.
Creates new instance of DataColumn.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As System.String, _
   ByVal dataType As System.String _
)
public DataColumn(
   System.string name,
   System.string dataType
)

Parameters

name
The column name.
dataType
The column type.
See Also

Reference

DataColumn Structure
DataColumn Members


DataColumn Structure Fields

DataColumn Structure Fields

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : DataColumn Structure

For a list of all members of this type, see DataColumn members.

Public Fields
 | Name | Description
Public Field | DataType | Specifies data type of the column.
Public Field | Name | Specifies column name.
Top
See Also

Reference

DataColumn Structure
GrapeCity.ActiveReports.Extensibility.Data Namespace


DataType Field

DataType Field

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataColumn Structure : DataType Field
Specifies data type of the column.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly DataType As System.String
public readonly System.string DataType
See Also

Reference

DataColumn Structure
DataColumn Members


Name Field

Name Field

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > DataColumn Structure : Name Field
Specifies column name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Name As System.String
public readonly System.string Name
See Also

Reference

DataColumn Structure
DataColumn Members


LoginPasswordCredentials Structure

LoginPasswordCredentials Structure
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : LoginPasswordCredentials Structure
Defines login/password credentials
Object Model
LoginPasswordCredentials Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure LoginPasswordCredentials
   Inherits System.ValueType
public struct LoginPasswordCredentials : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Data.LoginPasswordCredentials

See Also

Reference

LoginPasswordCredentials Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


LoginPasswordCredentials Structure Members

LoginPasswordCredentials Structure Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : LoginPasswordCredentials Structure

The following tables list the members exposed by LoginPasswordCredentials.

Public Constructors
 | Name | Description
Public Constructor | LoginPasswordCredentials Constructor | Initializes a new instance of the LoginPasswordCredentials struct.
Top
Public Properties
 | Name | Description
Public Property | Login | Gets the user login.
Public Property | Password | Gets the password.
Top
See Also

Reference

LoginPasswordCredentials Structure
GrapeCity.ActiveReports.Extensibility.Data Namespace


LoginPasswordCredentials Constructor

LoginPasswordCredentials Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > LoginPasswordCredentials Structure : LoginPasswordCredentials Constructor
User login
User password
Initializes a new instance of the LoginPasswordCredentials struct.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal login As System.String, _
   ByVal password As System.String _
)
public LoginPasswordCredentials(
   System.string login,
   System.string password
)

Parameters

login
User login
password
User password
See Also

Reference

LoginPasswordCredentials Structure
LoginPasswordCredentials Members


LoginPasswordCredentials Structure Properties

LoginPasswordCredentials Structure Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : LoginPasswordCredentials Structure

For a list of all members of this type, see LoginPasswordCredentials members.

Public Properties
 | Name | Description
Public Property | Login | Gets the user login.
Public Property | Password | Gets the password.
Top
See Also

Reference

LoginPasswordCredentials Structure
GrapeCity.ActiveReports.Extensibility.Data Namespace


Login Property

Login Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > LoginPasswordCredentials Structure : Login Property
Gets the user login.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Login As System.String
public System.string Login {get;}
See Also

Reference

LoginPasswordCredentials Structure
LoginPasswordCredentials Members


Password Property (LoginPasswordCredentials)

Password Property (LoginPasswordCredentials)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > LoginPasswordCredentials Structure : Password Property
Gets the password.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Password As System.String
public System.string Password {get;}
See Also

Reference

LoginPasswordCredentials Structure
LoginPasswordCredentials Members


ICredentialsLocator Interface

ICredentialsLocator Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : ICredentialsLocator Interface
Allows to override login/password retrieval behavior.
Object Model
ICredentialsLocator Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ICredentialsLocator
public interface ICredentialsLocator
See Also

Reference

ICredentialsLocator Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


ICredentialsLocator Interface Members

ICredentialsLocator Interface Members
Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : ICredentialsLocator Interface

The following tables list the members exposed by ICredentialsLocator.

Public Methods
 | Name | Description
Method | ResolveCredentials | Gets the credentials for specified data source.
Top
See Also

Reference

ICredentialsLocator Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


ICredentialsLocator Interface Methods

ICredentialsLocator Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : ICredentialsLocator Interface

For a list of all members of this type, see ICredentialsLocator members.

Public Methods
 | Name | Description
Method | ResolveCredentials | Gets the credentials for specified data source.
Top
See Also

Reference

ICredentialsLocator Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


ResolveCredentials Method

ResolveCredentials Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > ICredentialsLocator Interface : ResolveCredentials Method
Tthe name of the data source.
The name of the report to resolve credentials for.
The text of prompt of the resolve credentials request.
Gets the credentials for specified data source.
Syntax
  • Visual Basic
  • C#
'Declaration

Function ResolveCredentials( _
   ByVal dataSourceName As System.String, _
   ByVal reportPath As System.String, _
   ByVal promptText As System.String _
) As LoginPasswordCredentials
LoginPasswordCredentials ResolveCredentials(
   System.string dataSourceName,
   System.string reportPath,
   System.string promptText
)

Parameters

dataSourceName
Tthe name of the data source.
reportPath
The name of the report to resolve credentials for.
promptText
The text of prompt of the resolve credentials request.
See Also

Reference

ICredentialsLocator Interface
ICredentialsLocator Members


IDataParameter Interface

IDataParameter Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataParameter Interface
Represents a parameter used with an IDbCommand Interface.
Object Model
IDataParameter Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDataParameter
public interface IDataParameter
See Also

Reference

IDataParameter Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDataParameter Interface Members

IDataParameter Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataParameter Interface

The following tables list the members exposed by IDataParameter.

Public Properties
 | Name | Description
Property | ParameterName | Sets or returns the name of the parameter.
Property | Value | Sets or returns the value of the parameter.
Top
See Also

Reference

IDataParameter Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDataParameter Interface Properties

IDataParameter Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataParameter Interface

For a list of all members of this type, see IDataParameter members.

Public Properties
 | Name | Description
Property | ParameterName | Sets or returns the name of the parameter.
Property | Value | Sets or returns the value of the parameter.
Top
See Also

Reference

IDataParameter Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


ParameterName Property

ParameterName Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDataParameter Interface : ParameterName Property
Sets or returns the name of the parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Property ParameterName As System.String
System.string ParameterName {get; set;}
See Also

Reference

IDataParameter Interface
IDataParameter Members


Value Property (IDataParameter)

Value Property (IDataParameter)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDataParameter Interface : Value Property
Sets or returns the value of the parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Property Value As System.Object
System.object Value {get; set;}
See Also

Reference

IDataParameter Interface
IDataParameter Members


IDataParameterCollection Interface

IDataParameterCollection Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataParameterCollection Interface
Represents a collection of IDataParameter objects.
Object Model
IDataParameterCollection Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDataParameterCollection
public interface IDataParameterCollection
See Also

Reference

IDataParameterCollection Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDataParameterCollection Interface Members

IDataParameterCollection Interface Members
Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataParameterCollection Interface

The following tables list the members exposed by IDataParameterCollection.

Public Methods
 | Name | Description
Method | Add | Adds the specified IDataParameter object to the collection.
Top
See Also

Reference

IDataParameterCollection Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDataParameterCollection Interface Methods

IDataParameterCollection Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataParameterCollection Interface

For a list of all members of this type, see IDataParameterCollection members.

Public Methods
 | Name | Description
Method | Add | Adds the specified IDataParameter object to the collection.
Top
See Also

Reference

IDataParameterCollection Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


Add Method (IDataParameterCollection)

Add Method (IDataParameterCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDataParameterCollection Interface : Add Method
The parameter to add in the collection.
Adds the specified IDataParameter object to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Function Add( _
   ByVal parameter As IDataParameter _
) As System.Integer
System.int Add(
   IDataParameter parameter
)

Parameters

parameter
The parameter to add in the collection.
See Also

Reference

IDataParameterCollection Interface
IDataParameterCollection Members


IDataProviderFactoryExtended Interface

IDataProviderFactoryExtended Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataProviderFactoryExtended Interface
Extends the data provider factory by the additional functionality.
Object Model
IDataProviderFactoryExtended Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDataProviderFactoryExtended
public interface IDataProviderFactoryExtended
See Also

Reference

IDataProviderFactoryExtended Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDataProviderFactoryExtended Interface Members

IDataProviderFactoryExtended Interface Members
Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataProviderFactoryExtended Interface

The following tables list the members exposed by IDataProviderFactoryExtended.

Public Methods
 | Name | Description
Method | CreateSchemaProvider | Returns a new instance of the provider's class that implements IDbSchemaProvider.
Top
See Also

Reference

IDataProviderFactoryExtended Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDataProviderFactoryExtended Interface Methods

IDataProviderFactoryExtended Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataProviderFactoryExtended Interface

For a list of all members of this type, see IDataProviderFactoryExtended members.

Public Methods
 | Name | Description
Method | CreateSchemaProvider | Returns a new instance of the provider's class that implements IDbSchemaProvider.
Top
See Also

Reference

IDataProviderFactoryExtended Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


CreateSchemaProvider Method

CreateSchemaProvider Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDataProviderFactoryExtended Interface : CreateSchemaProvider Method
Returns a new instance of the provider's class that implements IDbSchemaProvider.
Syntax
  • Visual Basic
  • C#
'Declaration

Function CreateSchemaProvider() As IDbSchemaProvider
IDbSchemaProvider CreateSchemaProvider()

Return Value

A new instance of IDbSchemaProvider.
See Also

Reference

IDataProviderFactoryExtended Interface
IDataProviderFactoryExtended Members


IDataProviderService Interface

IDataProviderService Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataProviderService Interface
Exposes the services that can be used by data providers.
Object Model
IDataProviderService Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDataProviderService
public interface IDataProviderService
See Also

Reference

IDataProviderService Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDataProviderService Interface Members

IDataProviderService Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataProviderService Interface

The following tables list the members exposed by IDataProviderService.

Public Properties
 | Name | Description
Property | DataSetName | Gets ot sets the name of the data set that the data are located for when LocateDataSource method is invoked.
Property | DataSourceName | Gets ot sets the name of the data source when LocateDataSource method is invoked.
Top
Public Methods
 | Name | Description
Method | LocateDataSource | Locates the data that passed at runtime.
Top
See Also

Reference

IDataProviderService Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDataProviderService Interface Methods

IDataProviderService Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataProviderService Interface

For a list of all members of this type, see IDataProviderService members.

Public Methods
 | Name | Description
Method | LocateDataSource | Locates the data that passed at runtime.
Top
See Also

Reference

IDataProviderService Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


LocateDataSource Method (IDataProviderService)

LocateDataSource Method (IDataProviderService)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDataProviderService Interface : LocateDataSource Method
Locates the data that passed at runtime.
Syntax
  • Visual Basic
  • C#
'Declaration

Function LocateDataSource() As System.Object
System.object LocateDataSource()
See Also

Reference

IDataProviderService Interface
IDataProviderService Members


IDataProviderService Interface Properties

IDataProviderService Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataProviderService Interface

For a list of all members of this type, see IDataProviderService members.

Public Properties
 | Name | Description
Property | DataSetName | Gets ot sets the name of the data set that the data are located for when LocateDataSource method is invoked.
Property | DataSourceName | Gets ot sets the name of the data source when LocateDataSource method is invoked.
Top
See Also

Reference

IDataProviderService Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


DataSetName Property (IDataProviderService)

DataSetName Property (IDataProviderService)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDataProviderService Interface : DataSetName Property
Gets ot sets the name of the data set that the data are located for when LocateDataSource method is invoked.
Syntax
  • Visual Basic
  • C#
'Declaration

Property DataSetName As System.String
System.string DataSetName {get; set;}
See Also

Reference

IDataProviderService Interface
IDataProviderService Members


DataSourceName Property (IDataProviderService)

DataSourceName Property (IDataProviderService)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDataProviderService Interface : DataSourceName Property
Gets ot sets the name of the data source when LocateDataSource method is invoked.
Syntax
  • Visual Basic
  • C#
'Declaration

Property DataSourceName As System.String
System.string DataSourceName {get; set;}
See Also

Reference

IDataProviderService Interface
IDataProviderService Members


IDataReader Interface

IDataReader Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataReader Interface
Provides a means of reading a forward-only result set.
Object Model
IDataReader Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDataReader
   Inherits IDataRecord
public interface IDataReader : IDataRecord
See Also

Reference

IDataReader Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDataReader Interface Members

IDataReader Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataReader Interface

The following tables list the members exposed by IDataReader.

Public Properties
 | Name | Description
Property | FieldCount | Returns the number of fields in the current row. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDataRecord)
Top
Public Methods
 | Name | Description
Method | Dispose | (Inherited from System.IDisposable)
Method | GetData | Returns an IDataRecord providing access to a related set of child records. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDataRecord)
Method | GetFieldType | Gets the data type of the field at the specified index. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDataRecord)
Method | GetName | Gets the name of the field at the specified field index. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDataRecord)
Method | GetOrdinal | Gets the ordinal field index of the field with the specified name. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDataRecord)
Method | GetValue | Gets the value of the field at the specified index. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDataRecord)
Method | Read | Advances to the next record.
Top
See Also

Reference

IDataReader Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDataReader Interface Methods

IDataReader Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataReader Interface

For a list of all members of this type, see IDataReader members.

Public Methods
 | Name | Description
Method | Dispose | (Inherited from System.IDisposable)
Method | GetData | Returns an IDataRecord providing access to a related set of child records. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDataRecord)
Method | GetFieldType | Gets the data type of the field at the specified index. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDataRecord)
Method | GetName | Gets the name of the field at the specified field index. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDataRecord)
Method | GetOrdinal | Gets the ordinal field index of the field with the specified name. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDataRecord)
Method | GetValue | Gets the value of the field at the specified index. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDataRecord)
Method | Read | Advances to the next record.
Top
See Also

Reference

IDataReader Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


Read Method

Read Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDataReader Interface : Read Method
Advances to the next record.
Syntax
  • Visual Basic
  • C#
'Declaration

Function Read() As System.Boolean
System.bool Read()
See Also

Reference

IDataReader Interface
IDataReader Members


IDataRecord Interface

IDataRecord Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataRecord Interface
Provides access to the fields of a single record.
Object Model
IDataRecord Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDataRecord
public interface IDataRecord
See Also

Reference

IDataRecord Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDataRecord Interface Members

IDataRecord Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataRecord Interface

The following tables list the members exposed by IDataRecord.

Public Properties
 | Name | Description
Property | FieldCount | Returns the number of fields in the current row.
Top
Public Methods
 | Name | Description
Method | GetData | Returns an IDataRecord providing access to a related set of child records.
Method | GetFieldType | Gets the data type of the field at the specified index.
Method | GetName | Gets the name of the field at the specified field index.
Method | GetOrdinal | Gets the ordinal field index of the field with the specified name.
Method | GetValue | Gets the value of the field at the specified index.
Top
See Also

Reference

IDataRecord Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDataRecord Interface Methods

IDataRecord Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataRecord Interface

For a list of all members of this type, see IDataRecord members.

Public Methods
 | Name | Description
Method | GetData | Returns an IDataRecord providing access to a related set of child records.
Method | GetFieldType | Gets the data type of the field at the specified index.
Method | GetName | Gets the name of the field at the specified field index.
Method | GetOrdinal | Gets the ordinal field index of the field with the specified name.
Method | GetValue | Gets the value of the field at the specified index.
Top
See Also

Reference

IDataRecord Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


GetData Method

GetData Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDataRecord Interface : GetData Method
An Int32 representing the ordinal value of the field being examined.
Returns an IDataRecord providing access to a related set of child records.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetData( _
   ByVal fieldIndex As System.Integer _
) As IDataReader
IDataReader GetData(
   System.int fieldIndex
)

Parameters

fieldIndex
An Int32 representing the ordinal value of the field being examined.
See Also

Reference

IDataRecord Interface
IDataRecord Members


GetFieldType Method

GetFieldType Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDataRecord Interface : GetFieldType Method
An Int32 representing the ordinal value of the field being examined.
Gets the data type of the field at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetFieldType( _
   ByVal fieldIndex As System.Integer _
) As System.Type
System.Type GetFieldType(
   System.int fieldIndex
)

Parameters

fieldIndex
An Int32 representing the ordinal value of the field being examined.
See Also

Reference

IDataRecord Interface
IDataRecord Members


GetName Method (IDataRecord)

GetName Method (IDataRecord)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDataRecord Interface : GetName Method
An Int32 representing the ordinal value of the field being examined.
Gets the name of the field at the specified field index.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetName( _
   ByVal fieldIndex As System.Integer _
) As System.String
System.string GetName(
   System.int fieldIndex
)

Parameters

fieldIndex
An Int32 representing the ordinal value of the field being examined.
See Also

Reference

IDataRecord Interface
IDataRecord Members


GetOrdinal Method

GetOrdinal Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDataRecord Interface : GetOrdinal Method
A String value of the field name for which to get the ordinal.
Gets the ordinal field index of the field with the specified name.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetOrdinal( _
   ByVal fieldName As System.String _
) As System.Integer
System.int GetOrdinal(
   System.string fieldName
)

Parameters

fieldName
A String value of the field name for which to get the ordinal.
See Also

Reference

IDataRecord Interface
IDataRecord Members


GetValue Method (IDataRecord)

GetValue Method (IDataRecord)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDataRecord Interface : GetValue Method
An Int32 representing the ordinal value of the field being examined.
Gets the value of the field at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetValue( _
   ByVal fieldIndex As System.Integer _
) As System.Object
System.object GetValue(
   System.int fieldIndex
)

Parameters

fieldIndex
An Int32 representing the ordinal value of the field being examined.
See Also

Reference

IDataRecord Interface
IDataRecord Members


IDataRecord Interface Properties

IDataRecord Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataRecord Interface

For a list of all members of this type, see IDataRecord members.

Public Properties
 | Name | Description
Property | FieldCount | Returns the number of fields in the current row.
Top
See Also

Reference

IDataRecord Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


FieldCount Property

FieldCount Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDataRecord Interface : FieldCount Property
Returns the number of fields in the current row.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property FieldCount As System.Integer
System.int FieldCount {get;}
See Also

Reference

IDataRecord Interface
IDataRecord Members


IDataSourceLocator Interface

IDataSourceLocator Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataSourceLocator Interface
Allows to override data retrieval behavior.
Object Model
IDataSourceLocator Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDataSourceLocator
public interface IDataSourceLocator
See Also

Reference

IDataSourceLocator Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDataSourceLocator Interface Members

IDataSourceLocator Interface Members
Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataSourceLocator Interface

The following tables list the members exposed by IDataSourceLocator.

Public Methods
 | Name | Description
Method | LocateDataSource | Gets data for specified parameters.
Top
See Also

Reference

IDataSourceLocator Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDataSourceLocator Interface Methods

IDataSourceLocator Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataSourceLocator Interface

For a list of all members of this type, see IDataSourceLocator members.

Public Methods
 | Name | Description
Method | LocateDataSource | Gets data for specified parameters.
Top
See Also

Reference

IDataSourceLocator Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


LocateDataSource Method (IDataSourceLocator)

LocateDataSource Method (IDataSourceLocator)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDataSourceLocator Interface : LocateDataSource Method
Data source name
Data set name
Report instance
Gets data for specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Function LocateDataSource( _
   ByVal dataSourceName As System.String, _
   ByVal dataSetName As System.String, _
   ByVal instance As System.Object _
) As System.Object
System.object LocateDataSource(
   System.string dataSourceName,
   System.string dataSetName,
   System.object instance
)

Parameters

dataSourceName
Data source name
dataSetName
Data set name
instance
Report instance

Return Value

Data
See Also

Reference

IDataSourceLocator Interface
IDataSourceLocator Members


IDbCommand Interface

IDbCommand Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbCommand Interface
Represents a statement executed while connected to a data source.
Object Model
IDbCommand Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDbCommand
public interface IDbCommand
See Also

Reference

IDbCommand Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDbCommand Interface Members

IDbCommand Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbCommand Interface

The following tables list the members exposed by IDbCommand.

Public Properties
 | Name | Description
Property | CommandText | Sets or returns the text statement to execute against the data source.
Property | CommandTimeout | Sets or returns the length of time in seconds to wait before terminating the attempt to execute the command and generating an error.
Property | CommandType | Specifies how to interpret the statement in CommandText.
Property | Parameters | Returns the collection of parameters.
Property | Transaction | Sets or returns the transaction in which this command executes.
Top
Public Methods
 | Name | Description
Method | Cancel | Attempts to cancel the current execution of this command.
Method | CreateParameter | Creates a new parameter object for use with this command.
Method | Dispose | (Inherited from System.IDisposable)
Method | ExecuteReader | Overloaded. Overloaded.
Method | GenerateRewrittenCommandText | Returns the command text with the parameters expanded into constants.
Top
See Also

Reference

IDbCommand Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDbCommand Interface Methods

IDbCommand Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbCommand Interface

For a list of all members of this type, see IDbCommand members.

Public Methods
 | Name | Description
Method | Cancel | Attempts to cancel the current execution of this command.
Method | CreateParameter | Creates a new parameter object for use with this command.
Method | Dispose | (Inherited from System.IDisposable)
Method | ExecuteReader | Overloaded. Overloaded.
Method | GenerateRewrittenCommandText | Returns the command text with the parameters expanded into constants.
Top
See Also

Reference

IDbCommand Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


Cancel Method (IDbCommand)

Cancel Method (IDbCommand)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbCommand Interface : Cancel Method
Attempts to cancel the current execution of this command.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Cancel()
void Cancel()
See Also

Reference

IDbCommand Interface
IDbCommand Members


CreateParameter Method

CreateParameter Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbCommand Interface : CreateParameter Method
Creates a new parameter object for use with this command.
Syntax
  • Visual Basic
  • C#
'Declaration

Function CreateParameter() As IDataParameter
IDataParameter CreateParameter()
See Also

Reference

IDbCommand Interface
IDbCommand Members


ExecuteReader Method

ExecuteReader Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbCommand Interface : ExecuteReader Method
Overloaded.
Overload List
Overload | Description
ExecuteReader() | Executes this command's statement and returns the results accessible with an IDataReader object.
ExecuteReader(CommandBehavior) | Executes this command's statement and returns the specified type of results accessible with an IDataReader object.
See Also

Reference

IDbCommand Interface
IDbCommand Members


ExecuteReader() Method

ExecuteReader() Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbCommand Interface > ExecuteReader Method : ExecuteReader() Method
Executes this command's statement and returns the results accessible with an IDataReader object.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function ExecuteReader() As IDataReader
IDataReader ExecuteReader()
See Also

Reference

IDbCommand Interface
IDbCommand Members
Overload List


ExecuteReader(CommandBehavior) Method

ExecuteReader(CommandBehavior) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbCommand Interface > ExecuteReader Method : ExecuteReader(CommandBehavior) Method
One of the CommandBehavior values.
Executes this command's statement and returns the specified type of results accessible with an IDataReader object.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function ExecuteReader( _
   ByVal behavior As CommandBehavior _
) As IDataReader
IDataReader ExecuteReader(
   CommandBehavior behavior
)

Parameters

behavior
One of the CommandBehavior values.
See Also

Reference

IDbCommand Interface
IDbCommand Members
Overload List


GenerateRewrittenCommandText Method

GenerateRewrittenCommandText Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbCommand Interface : GenerateRewrittenCommandText Method
Returns the command text with the parameters expanded into constants.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GenerateRewrittenCommandText() As System.String
System.string GenerateRewrittenCommandText()
See Also

Reference

IDbCommand Interface
IDbCommand Members


IDbCommand Interface Properties

IDbCommand Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbCommand Interface

For a list of all members of this type, see IDbCommand members.

Public Properties
 | Name | Description
Property | CommandText | Sets or returns the text statement to execute against the data source.
Property | CommandTimeout | Sets or returns the length of time in seconds to wait before terminating the attempt to execute the command and generating an error.
Property | CommandType | Specifies how to interpret the statement in CommandText.
Property | Parameters | Returns the collection of parameters.
Property | Transaction | Sets or returns the transaction in which this command executes.
Top
See Also

Reference

IDbCommand Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


CommandText Property (IDbCommand)

CommandText Property (IDbCommand)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbCommand Interface : CommandText Property
Sets or returns the text statement to execute against the data source.
Syntax
  • Visual Basic
  • C#
'Declaration

Property CommandText As System.String
System.string CommandText {get; set;}
See Also

Reference

IDbCommand Interface
IDbCommand Members


CommandTimeout Property (IDbCommand)

CommandTimeout Property (IDbCommand)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbCommand Interface : CommandTimeout Property
Sets or returns the length of time in seconds to wait before terminating the attempt to execute the command and generating an error.
Syntax
  • Visual Basic
  • C#
'Declaration

Property CommandTimeout As System.Integer
System.int CommandTimeout {get; set;}
See Also

Reference

IDbCommand Interface
IDbCommand Members


CommandType Property (IDbCommand)

CommandType Property (IDbCommand)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbCommand Interface : CommandType Property
Specifies how to interpret the statement in CommandText.
Syntax
  • Visual Basic
  • C#
'Declaration

Property CommandType As CommandType
CommandType CommandType {get; set;}
See Also

Reference

IDbCommand Interface
IDbCommand Members


Parameters Property (IDbCommand)

Parameters Property (IDbCommand)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbCommand Interface : Parameters Property
Returns the collection of parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Parameters As IDataParameterCollection
IDataParameterCollection Parameters {get;}
See Also

Reference

IDbCommand Interface
IDbCommand Members


Transaction Property (IDbCommand)

Transaction Property (IDbCommand)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbCommand Interface : Transaction Property
Sets or returns the transaction in which this command executes.
Syntax
  • Visual Basic
  • C#
'Declaration

Property Transaction As IDbTransaction
IDbTransaction Transaction {get; set;}
See Also

Reference

IDbCommand Interface
IDbCommand Members


IDbCommandExtension Interface

IDbCommandExtension Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbCommandExtension Interface
This is an optional interface implemented by classes that implement IDbCommand Interface. Use it to provide additional information about a command.
Object Model
IDbCommandExtension Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDbCommandExtension
public interface IDbCommandExtension
See Also

Reference

IDbCommandExtension Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDbCommandExtension Interface Members

IDbCommandExtension Interface Members
Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbCommandExtension Interface

The following tables list the members exposed by IDbCommandExtension.

Public Methods
 | Name | Description
Method | DeriveParameters | Returns the parameters found in the command's current CommandText Property.
Top
See Also

Reference

IDbCommandExtension Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDbCommandExtension Interface Methods

IDbCommandExtension Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbCommandExtension Interface

For a list of all members of this type, see IDbCommandExtension members.

Public Methods
 | Name | Description
Method | DeriveParameters | Returns the parameters found in the command's current CommandText Property.
Top
See Also

Reference

IDbCommandExtension Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


DeriveParameters Method

DeriveParameters Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbCommandExtension Interface : DeriveParameters Method
Returns the parameters found in the command's current CommandText Property.
Syntax
  • Visual Basic
  • C#
'Declaration

Function DeriveParameters() As IDataParameterCollection
IDataParameterCollection DeriveParameters()

Return Value

An IDataParameterCollection Interface containing the parameters from the command text.
See Also

Reference

IDbCommandExtension Interface
IDbCommandExtension Members


IDbConnection Interface

IDbConnection Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbConnection Interface
Represents a connection to a data source.
Object Model
IDbConnection Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDbConnection
   Inherits GrapeCity.ActiveReports.Extensibility.IExtension
public interface IDbConnection : GrapeCity.ActiveReports.Extensibility.IExtension
See Also

Reference

IDbConnection Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDbConnection Interface Members

IDbConnection Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbConnection Interface

The following tables list the members exposed by IDbConnection.

Public Properties
 | Name | Description
Property | ConnectionString | Sets or returns data source-dependent connection information.
Property | ConnectionTimeout | Sets or returns the amount of time in seconds to wait before terminating the attempt to open the connection and generating an error.
Property | DataProviderService | Sets or returns T:IDataProviderService implementation that provides the services which can be used by data provider.
Property | LocalizedName | The localized name for this extension. (Inherited from GrapeCity.ActiveReports.Extensibility.IExtension)
Top
Public Methods
 | Name | Description
Method | BeginTransaction | Begins a transaction at the data source.
Method | Close | Closes the connection.
Method | CreateCommand | Returns an initialized command object associated with this connection.
Method | Dispose | (Inherited from System.IDisposable)
Method | Open | Opens the connection.
Method | SetConfiguration | Specifies any configuration information for this extension. (Inherited from GrapeCity.ActiveReports.Extensibility.IExtension)
Top
See Also

Reference

IDbConnection Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDbConnection Interface Methods

IDbConnection Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbConnection Interface

For a list of all members of this type, see IDbConnection members.

Public Methods
 | Name | Description
Method | BeginTransaction | Begins a transaction at the data source.
Method | Close | Closes the connection.
Method | CreateCommand | Returns an initialized command object associated with this connection.
Method | Dispose | (Inherited from System.IDisposable)
Method | Open | Opens the connection.
Method | SetConfiguration | Specifies any configuration information for this extension. (Inherited from GrapeCity.ActiveReports.Extensibility.IExtension)
Top
See Also

Reference

IDbConnection Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


BeginTransaction Method

BeginTransaction Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbConnection Interface : BeginTransaction Method
Begins a transaction at the data source.
Syntax
  • Visual Basic
  • C#
'Declaration

Function BeginTransaction() As IDbTransaction
IDbTransaction BeginTransaction()
See Also

Reference

IDbConnection Interface
IDbConnection Members


Close Method

Close Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbConnection Interface : Close Method
Closes the connection.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Close()
void Close()
See Also

Reference

IDbConnection Interface
IDbConnection Members


CreateCommand Method (IDbConnection)

CreateCommand Method (IDbConnection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbConnection Interface : CreateCommand Method
Returns an initialized command object associated with this connection.
Syntax
  • Visual Basic
  • C#
'Declaration

Function CreateCommand() As IDbCommand
IDbCommand CreateCommand()
See Also

Reference

IDbConnection Interface
IDbConnection Members


Open Method

Open Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbConnection Interface : Open Method
Opens the connection.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Open()
void Open()
See Also

Reference

IDbConnection Interface
IDbConnection Members


IDbConnection Interface Properties

IDbConnection Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbConnection Interface

For a list of all members of this type, see IDbConnection members.

Public Properties
 | Name | Description
Property | ConnectionString | Sets or returns data source-dependent connection information.
Property | ConnectionTimeout | Sets or returns the amount of time in seconds to wait before terminating the attempt to open the connection and generating an error.
Property | DataProviderService | Sets or returns T:IDataProviderService implementation that provides the services which can be used by data provider.
Property | LocalizedName | The localized name for this extension. (Inherited from GrapeCity.ActiveReports.Extensibility.IExtension)
Top
See Also

Reference

IDbConnection Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


ConnectionString Property (IDbConnection)

ConnectionString Property (IDbConnection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbConnection Interface : ConnectionString Property
Sets or returns data source-dependent connection information.
Syntax
  • Visual Basic
  • C#
'Declaration

Property ConnectionString As System.String
System.string ConnectionString {get; set;}
See Also

Reference

IDbConnection Interface
IDbConnection Members


ConnectionTimeout Property

ConnectionTimeout Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbConnection Interface : ConnectionTimeout Property
Sets or returns the amount of time in seconds to wait before terminating the attempt to open the connection and generating an error.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ConnectionTimeout As System.Integer
System.int ConnectionTimeout {get;}
See Also

Reference

IDbConnection Interface
IDbConnection Members


DataProviderService Property (IDbConnection)

DataProviderService Property (IDbConnection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbConnection Interface : DataProviderService Property
Sets or returns T:IDataProviderService implementation that provides the services which can be used by data provider.
Syntax
  • Visual Basic
  • C#
'Declaration

Property DataProviderService As IDataProviderService
IDataProviderService DataProviderService {get; set;}
See Also

Reference

IDbConnection Interface
IDbConnection Members


IDbConnectionExtension Interface

IDbConnectionExtension Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbConnectionExtension Interface
Defines additional credential settings that can be supported by an IDbConnection-derived type.
Object Model
IDbConnectionExtension Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDbConnectionExtension
   Inherits IDbConnection, GrapeCity.ActiveReports.Extensibility.IExtension
public interface IDbConnectionExtension : IDbConnection, GrapeCity.ActiveReports.Extensibility.IExtension
Remarks
Implementing this interface is optional. If the additional functionality offered by IDbConnectionExtension is not desired, then it is only necessary to implement IDbConnection.
See Also

Reference

IDbConnectionExtension Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDbConnectionExtension Interface Members

IDbConnectionExtension Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbConnectionExtension Interface

The following tables list the members exposed by IDbConnectionExtension.

Public Properties
 | Name | Description
Property | ConnectionString | Sets or returns data source-dependent connection information. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDbConnection)
Property | ConnectionTimeout | Sets or returns the amount of time in seconds to wait before terminating the attempt to open the connection and generating an error. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDbConnection)
Property | DataProviderService | Sets or returns T:IDataProviderService implementation that provides the services which can be used by data provider. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDbConnection)
Property | Impersonate | The name of the user is impersonated while executing commands.
Property | IntegratedSecurity | Determines whether the connection uses integrated security or the values supplied in the UserName and Password properties.
Property | LocalizedName | The localized name for this extension. (Inherited from GrapeCity.ActiveReports.Extensibility.IExtension)
Property | Password | Specifies the password used when connecting to the data source. If a password was specified in the ConnectionString, this value overrides it.
Property | UserName | Specifies the username used when connecting to the data source. If a user name was specified in the ConnectionString, this value overrides it.
Top
Public Methods
 | Name | Description
Method | BeginTransaction | Begins a transaction at the data source. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDbConnection)
Method | Close | Closes the connection. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDbConnection)
Method | CreateCommand | Returns an initialized command object associated with this connection. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDbConnection)
Method | Dispose | (Inherited from System.IDisposable)
Method | Open | Opens the connection. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDbConnection)
Method | SetConfiguration | Specifies any configuration information for this extension. (Inherited from GrapeCity.ActiveReports.Extensibility.IExtension)
Top
See Also

Reference

IDbConnectionExtension Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDbConnectionExtension Interface Properties

IDbConnectionExtension Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbConnectionExtension Interface

For a list of all members of this type, see IDbConnectionExtension members.

Public Properties
 | Name | Description
Property | ConnectionString | Sets or returns data source-dependent connection information. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDbConnection)
Property | ConnectionTimeout | Sets or returns the amount of time in seconds to wait before terminating the attempt to open the connection and generating an error. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDbConnection)
Property | DataProviderService | Sets or returns T:IDataProviderService implementation that provides the services which can be used by data provider. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDbConnection)
Property | Impersonate | The name of the user is impersonated while executing commands.
Property | IntegratedSecurity | Determines whether the connection uses integrated security or the values supplied in the UserName and Password properties.
Property | LocalizedName | The localized name for this extension. (Inherited from GrapeCity.ActiveReports.Extensibility.IExtension)
Property | Password | Specifies the password used when connecting to the data source. If a password was specified in the ConnectionString, this value overrides it.
Property | UserName | Specifies the username used when connecting to the data source. If a user name was specified in the ConnectionString, this value overrides it.
Top
See Also

Reference

IDbConnectionExtension Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


Impersonate Property

Impersonate Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbConnectionExtension Interface : Impersonate Property
The name of the user is impersonated while executing commands.
Syntax
  • Visual Basic
  • C#
'Declaration

WriteOnly Property Impersonate As System.String
System.string Impersonate {set;}
See Also

Reference

IDbConnectionExtension Interface
IDbConnectionExtension Members


IntegratedSecurity Property (IDbConnectionExtension)

IntegratedSecurity Property (IDbConnectionExtension)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbConnectionExtension Interface : IntegratedSecurity Property
Determines whether the connection uses integrated security or the values supplied in the UserName and Password properties.
Syntax
  • Visual Basic
  • C#
'Declaration

Property IntegratedSecurity As System.Boolean
System.bool IntegratedSecurity {get; set;}
See Also

Reference

IDbConnectionExtension Interface
IDbConnectionExtension Members


Password Property (IDbConnectionExtension)

Password Property (IDbConnectionExtension)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbConnectionExtension Interface : Password Property
Specifies the password used when connecting to the data source. If a password was specified in the ConnectionString, this value overrides it.
Syntax
  • Visual Basic
  • C#
'Declaration

WriteOnly Property Password As System.String
System.string Password {set;}
See Also

Reference

IDbConnectionExtension Interface
IDbConnectionExtension Members


UserName Property (IDbConnectionExtension)

UserName Property (IDbConnectionExtension)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbConnectionExtension Interface : UserName Property
Specifies the username used when connecting to the data source. If a user name was specified in the ConnectionString, this value overrides it.
Syntax
  • Visual Basic
  • C#
'Declaration

WriteOnly Property UserName As System.String
System.string UserName {set;}
See Also

Reference

IDbConnectionExtension Interface
IDbConnectionExtension Members


IDbSchemaProvider Interface

IDbSchemaProvider Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbSchemaProvider Interface
Specifies the schema provider.
Object Model
IDbSchemaProvider Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDbSchemaProvider
public interface IDbSchemaProvider
See Also

Reference

IDbSchemaProvider Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDbSchemaProvider Interface Members

IDbSchemaProvider Interface Members
Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbSchemaProvider Interface

The following tables list the members exposed by IDbSchemaProvider.

Public Methods
 | Name | Description
Method | GetSchema | Gets the schema of the specified db connection if it's of the same data provider.
Top
See Also

Reference

IDbSchemaProvider Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDbSchemaProvider Interface Methods

IDbSchemaProvider Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbSchemaProvider Interface

For a list of all members of this type, see IDbSchemaProvider members.

Public Methods
 | Name | Description
Method | GetSchema | Gets the schema of the specified db connection if it's of the same data provider.
Top
See Also

Reference

IDbSchemaProvider Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


GetSchema Method

GetSchema Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbSchemaProvider Interface : GetSchema Method
A connection to get schema for.
Gets the schema of the specified db connection if it's of the same data provider.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetSchema( _
   ByVal connection As IDbConnection _
) As DataSchema
DataSchema GetSchema(
   IDbConnection connection
)

Parameters

connection
A connection to get schema for.
See Also

Reference

IDbSchemaProvider Interface
IDbSchemaProvider Members


IDbTransaction Interface

IDbTransaction Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbTransaction Interface
Represents a transaction to be performed on a data source.
Object Model
IDbTransaction Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDbTransaction
public interface IDbTransaction
See Also

Reference

IDbTransaction Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDbTransaction Interface Members

IDbTransaction Interface Members
Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbTransaction Interface

The following tables list the members exposed by IDbTransaction.

Public Methods
 | Name | Description
Method | Commit | Commits this transaction.
Method | Dispose | (Inherited from System.IDisposable)
Method | Rollback | Rolls back this transaction.
Top
See Also

Reference

IDbTransaction Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDbTransaction Interface Methods

IDbTransaction Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbTransaction Interface

For a list of all members of this type, see IDbTransaction members.

Public Methods
 | Name | Description
Method | Commit | Commits this transaction.
Method | Dispose | (Inherited from System.IDisposable)
Method | Rollback | Rolls back this transaction.
Top
See Also

Reference

IDbTransaction Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


Commit Method

Commit Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbTransaction Interface : Commit Method
Commits this transaction.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Commit()
void Commit()
See Also

Reference

IDbTransaction Interface
IDbTransaction Members


Rollback Method

Rollback Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbTransaction Interface : Rollback Method
Rolls back this transaction.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Rollback()
void Rollback()
See Also

Reference

IDbTransaction Interface
IDbTransaction Members


IDbTransactionExtension Interface

IDbTransactionExtension Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbTransactionExtension Interface
Defines additional settings that can be supported by an IDbTransaction-derived type.
Object Model
IDbTransactionExtension Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDbTransactionExtension
   Inherits IDbTransaction
public interface IDbTransactionExtension : IDbTransaction
Remarks
Implementing this interface is optional. If the additional functionality offered by IDbConnectionExtension is not desired, then it is only necessary to implement IDbTransaction.
See Also

Reference

IDbTransactionExtension Members
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDbTransactionExtension Interface Members

IDbTransactionExtension Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbTransactionExtension Interface

The following tables list the members exposed by IDbTransactionExtension.

Public Properties
 | Name | Description
Property | AllowMultiConnection | Defines whether a single transaction can be used across multiple connections.
Top
Public Methods
 | Name | Description
Method | Commit | Commits this transaction. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDbTransaction)
Method | Dispose | (Inherited from System.IDisposable)
Method | Rollback | Rolls back this transaction. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDbTransaction)
Top
See Also

Reference

IDbTransactionExtension Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


IDbTransactionExtension Interface Properties

IDbTransactionExtension Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbTransactionExtension Interface

For a list of all members of this type, see IDbTransactionExtension members.

Public Properties
 | Name | Description
Property | AllowMultiConnection | Defines whether a single transaction can be used across multiple connections.
Top
See Also

Reference

IDbTransactionExtension Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


AllowMultiConnection Property

AllowMultiConnection Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbTransactionExtension Interface : AllowMultiConnection Property
Defines whether a single transaction can be used across multiple connections.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property AllowMultiConnection As System.Boolean
System.bool AllowMultiConnection {get;}
See Also

Reference

IDbTransactionExtension Interface
IDbTransactionExtension Members


GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace

GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace
The GrapeCity.ActiveReports.Extensibility.Definition.Components namespace contains the types for describing the report runtime components.
Structures
 | Structure | Description
Structure | Length | Represents the length.
Enumerations
 | Enumeration | Description
Enumeration | ImageSizing | Determines how a picture should be sized within the image report control area.
Enumeration | LayoutDirection | Represents the direction of the layout.
Enumeration | Length.Unit | Represents the length units.
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


ImageSizing Enumeration

ImageSizing Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace : ImageSizing Enumeration
Determines how a picture should be sized within the image report control area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ImageSizing
   Inherits System.Enum
public enum ImageSizing : System.Enum
Members
Member | Description
AutoSize | Indicates that the image report control should be expanded to fit the picture.
Clip | Indicates that the picture should be clipped to fit.
Fit | Indicates that the picture should be clipped to fit the image report control.
FitProportional | Indicates that the picture should be clipped to fit the image report control and the proportions should be saved.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Definition.Components.ImageSizing

Requirements

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace


LayoutDirection Enumeration

LayoutDirection Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace : LayoutDirection Enumeration

Represents the direction of the layout.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LayoutDirection
   Inherits System.Enum
public enum LayoutDirection : System.Enum
Members
Member | Description
Ltr | From left to right
Rtl | From right to left.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Definition.Components.LayoutDirection

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace


Length.Unit Enumeration

Length.Unit Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace : Length.Unit Enumeration
Represents the length units.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Length.Unit
   Inherits System.Enum
public enum Length.Unit : System.Enum
Members
Member | Description
Centimeters | centimeters
Inches | inches
Millimeters | millimeters
Picas | picas
Points | points
Unknown | unknown unit
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Definition.Components.Length.Unit

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace


Length Structure

Length Structure
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace : Length Structure
Represents the length.
Object Model
Length Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure Length
   Inherits System.ValueType
public struct Length : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Definition.Components.Length

See Also

Reference

Length Members
GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace


Length Structure Members

Length Structure Members
Fields Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace : Length Structure

The following tables list the members exposed by Length.

Public Constructors
 | Name | Description
Public Constructor | Length Constructor | Overloaded.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | An empty Length object.
static (Shared in Visual Basic) | Zero | A zero inch Length object.
Top
Public Properties
 | Name | Description
Public Property | IsUndefined | T:GrapeCity.ActiveReports.Extensibility.Definition.Components.Length% has been set to a particular value.
Public Property | IsValid | Indicates if the Length string contains the correct units and value.
Public Property | OriginalUnit | Contains the original unit type that was passed in so that it can be used in conversions later.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | Add | Adds two specified Length values and return the unit of the first GrapeCity.ActiveReports.Extensibility.Definition.Components.Length.
Public Method | CompareTo | Overloaded. Compares this instance to a specified object and returns an indication of their relative values.
Public Method | Equals | Overloaded. Tests for equivalence between two Length objects.
static (Shared in Visual Basic) | FromTwips | Create a new Length from twips.
Public Method | GetHashCode | Serves as a hash function for the Length
static (Shared in Visual Basic) | Multiply | Multiply the length to the specified value.
static (Shared in Visual Basic) | Subtract | Subtracts one Length from another and return the unit of the first GrapeCity.ActiveReports.Extensibility.Definition.Components.Length.
Public Method | ToCentimeters | Converts the existing Length twips to centimeters (1cm = 567twips)
Public Method | ToInches | Converts the existing Length twips to inches (1in = 1440twips)
Public Method | ToMillimeters | Converts the existing Length twips to millimeters (1mm = 56.7twips)
Public Method | ToPica | Converts the existing Length twips to pica (1pc = 240twips)
Public Method | ToPoints | Converts the existing Length twips to points (1pt = 20twips)
Public Method | ToString | Overloaded. Converts the value of this instance to its equivalent string representation.
Public Method | ToTwips | Converts the existing Length to twips
static (Shared in Visual Basic) | TryParse | Tries to parse specified string as length.
static (Shared in Visual Basic) | TwipsToString | Converts a passed in value to string based on the passed in unit type.
Top
Public Operators
public Operator Addition | Adds two specified Length values and returns the unit of the first GrapeCity.ActiveReports.Extensibility.Definition.Components.Length.
public Operator Equality | For predefined value types, the equality operator (==) returns true if the values of its operands are equal, false otherwise. For reference types other than string, == returns true if its two operands refer to the same object. For the string type, == compares the values of the strings.
public Operator Explicit Type Conversion | Converts current Length instance to a string
public Operator Greater Than | All numeric and enumeration types define a "greater than" relational operator (>) that returns true if the first operand is greater than the second, false otherwise.
public Operator Greater Than or Equal | All numeric and enumeration types define a "greater than or equal" relational operator (>=) that returns true if the first operand is greater than or equal to the second, false otherwise.
public Operator Implicit Type Conversion | Converts string value to a new Length instance.
public Operator Inequality | The inequality operator (!=) returns false if its operands are equal, true otherwise. Inequality operators are predefined for all types, including string and object. User-defined types can overload the != operator.
public Operator Less Than | All numeric and enumeration types define a "less than" relational operator (<) that returns true if the first operand is less than the second, false otherwise.
public Operator Less Than or Equal | All numeric and enumeration types define a "less than or equal" relational operator (<=) that returns true if the first operand is less than or equal to the second, false otherwise.
public Operator Subtraction | Subtracts one Length from another and return the unit of the first GrapeCity.ActiveReports.Extensibility.Definition.Components.Length.
Top
See Also

Reference

Length Structure
GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace


Length Constructor

Length Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : Length Constructor
Overload List
Overload | Description
Length Constructor(String) | Constructor for the Length class
Length Constructor(Double,Unit) | Constructor for the Length class
See Also

Reference

Length Structure
Length Members


Length Constructor(String)

Length Constructor(String)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure > Length Constructor : Length Constructor(String)
string value indicate the size, e.g. 1 cm, 10 pt
Constructor for the Length class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal length As System.String _
)
public Length(
   System.string length
)

Parameters

length
string value indicate the size, e.g. 1 cm, 10 pt
See Also

Reference

Length Structure
Length Members
Overload List


Length Constructor(Double,Unit)

Length Constructor(Double,Unit)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure > Length Constructor : Length Constructor(Double,Unit)
length value in original units
original unit
Constructor for the Length class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal originalLength As System.Double, _
   ByVal originalUnit As Length.Unit _
)
public Length(
   System.double originalLength,
   Length.Unit originalUnit
)

Parameters

originalLength
length value in original units
originalUnit
original unit
See Also

Reference

Length Structure
Length Members
Overload List


Length Structure Methods

Length Structure Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace : Length Structure

For a list of all members of this type, see Length members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Add | Adds two specified Length values and return the unit of the first GrapeCity.ActiveReports.Extensibility.Definition.Components.Length.
Public Method | CompareTo | Overloaded. Compares this instance to a specified object and returns an indication of their relative values.
Public Method | Equals | Overloaded. Tests for equivalence between two Length objects.
static (Shared in Visual Basic) | FromTwips | Create a new Length from twips.
Public Method | GetHashCode | Serves as a hash function for the Length
static (Shared in Visual Basic) | Multiply | Multiply the length to the specified value.
static (Shared in Visual Basic) | Subtract | Subtracts one Length from another and return the unit of the first GrapeCity.ActiveReports.Extensibility.Definition.Components.Length.
Public Method | ToCentimeters | Converts the existing Length twips to centimeters (1cm = 567twips)
Public Method | ToInches | Converts the existing Length twips to inches (1in = 1440twips)
Public Method | ToMillimeters | Converts the existing Length twips to millimeters (1mm = 56.7twips)
Public Method | ToPica | Converts the existing Length twips to pica (1pc = 240twips)
Public Method | ToPoints | Converts the existing Length twips to points (1pt = 20twips)
Public Method | ToString | Overloaded. Converts the value of this instance to its equivalent string representation.
Public Method | ToTwips | Converts the existing Length to twips
static (Shared in Visual Basic) | TryParse | Tries to parse specified string as length.
static (Shared in Visual Basic) | TwipsToString | Converts a passed in value to string based on the passed in unit type.
Top
See Also

Reference

Length Structure
GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace


Add Method (Length)

Add Method (Length)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : Add Method
the Length
the Length
Adds two specified Length values and return the unit of the first GrapeCity.ActiveReports.Extensibility.Definition.Components.Length.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function Add( _
   ByVal unit1 As Length, _
   ByVal unit2 As Length _
) As Length
public static Length Add(
   Length unit1,
   Length unit2
)

Parameters

unit1
the Length
unit2
the Length

Return Value

the Length that is the results of adding unit1 to unit2
See Also

Reference

Length Structure
Length Members


CompareTo Method (Length)

CompareTo Method (Length)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : CompareTo Method
Compares this instance to a specified object and returns an indication of their relative values.
Overload List
Overload | Description
CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
CompareTo(Length)
Value | Meaning
Less than zero | This instance is less than obj.
Zero | This instance is equal to obj.
Greater than zero | This instance is greater than obj.
See Also

Reference

Length Structure
Length Members


CompareTo(Object) Method

CompareTo(Object) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure > CompareTo Method : CompareTo(Object) Method
Length to compare
Compares this instance to a specified object and returns an indication of their relative values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function CompareTo( _
   ByVal obj As System.Object _
) As System.Integer
public System.int CompareTo(
   System.object obj
)

Parameters

obj
Length to compare
See Also

Reference

Length Structure
Length Members
Overload List


CompareTo(Length) Method

CompareTo(Length) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure > CompareTo Method : CompareTo(Length) Method
Length to compare.
Value | Meaning
Less than zero | This instance is less than obj.
Zero | This instance is equal to obj.
Greater than zero | This instance is greater than obj.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function CompareTo( _
   ByVal other As Length _
) As System.Integer
public System.int CompareTo(
   Length other
)

Parameters

other
Length to compare.
See Also

Reference

Length Structure
Length Members
Overload List


Equals Method (Length)

Equals Method (Length)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : Equals Method
Tests for equivalence between two Length objects.
Overload List
Overload | Description
Equals(Object) | Tests for equivalence between two Length objects.
Equals(Length) | Determines whether the specified Object is equal to the current Object.
See Also

Reference

Length Structure
Length Members


Equals(Object) Method

Equals(Object) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure > Equals Method : Equals(Object) Method
Length to compare.
Tests for equivalence between two Length objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
Length to compare.

Return Value

True if the objects are equal; otherwise false.
See Also

Reference

Length Structure
Length Members
Overload List


Equals(Length) Method

Equals(Length) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure > Equals Method : Equals(Length) Method
Length to compare.
Determines whether the specified Object is equal to the current Object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Equals( _
   ByVal other As Length _
) As System.Boolean
public System.bool Equals(
   Length other
)

Parameters

other
Length to compare.
See Also

Reference

Length Structure
Length Members
Overload List


FromTwips Method

FromTwips Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : FromTwips Method
GrapeCity.ActiveReports.Extensibility.Definition.Components.Length in twips
Target unit for conversion for output or arithmetic
Create a new Length from twips.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function FromTwips( _
   ByVal twips As System.Single, _
   ByVal target As Length.Unit _
) As Length
public static Length FromTwips(
   System.float twips,
   Length.Unit target
)

Parameters

twips
GrapeCity.ActiveReports.Extensibility.Definition.Components.Length in twips
target
Target unit for conversion for output or arithmetic
See Also

Reference

Length Structure
Length Members


GetHashCode Method (Length)

GetHashCode Method (Length)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : GetHashCode Method
Serves as a hash function for the Length
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()

Return Value

A hash code for the Length
See Also

Reference

Length Structure
Length Members


Multiply Method (Length)

Multiply Method (Length)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : Multiply Method
The length value to multiply.
The float value to multiply the length value to.
Multiply the length to the specified value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function Multiply( _
   ByVal unit As Length, _
   ByVal scale As System.Single _
) As Length
public static Length Multiply(
   Length unit,
   System.float scale
)

Parameters

unit
The length value to multiply.
scale
The float value to multiply the length value to.
See Also

Reference

Length Structure
Length Members


Subtract Method

Subtract Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : Subtract Method
the Length minuend
the Length subtrahend
Subtracts one Length from another and return the unit of the first GrapeCity.ActiveReports.Extensibility.Definition.Components.Length.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function Subtract( _
   ByVal unit1 As Length, _
   ByVal unit2 As Length _
) As Length
public static Length Subtract(
   Length unit1,
   Length unit2
)

Parameters

unit1
the Length minuend
unit2
the Length subtrahend

Return Value

the Length that is the results of subtracting unit1 by unit2
See Also

Reference

Length Structure
Length Members


ToCentimeters Method

ToCentimeters Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : ToCentimeters Method
Converts the existing Length twips to centimeters (1cm = 567twips)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToCentimeters() As System.Single
public System.float ToCentimeters()

Return Value

Float value in centimeters
See Also

Reference

Length Structure
Length Members


ToInches Method

ToInches Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : ToInches Method
Converts the existing Length twips to inches (1in = 1440twips)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToInches() As System.Single
public System.float ToInches()

Return Value

Float value in inches
See Also

Reference

Length Structure
Length Members


ToMillimeters Method

ToMillimeters Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : ToMillimeters Method
Converts the existing Length twips to millimeters (1mm = 56.7twips)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToMillimeters() As System.Single
public System.float ToMillimeters()

Return Value

Float value in millimeters
See Also

Reference

Length Structure
Length Members


ToPica Method

ToPica Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : ToPica Method
Converts the existing Length twips to pica (1pc = 240twips)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToPica() As System.Single
public System.float ToPica()

Return Value

Float value in pica
See Also

Reference

Length Structure
Length Members


ToPoints Method

ToPoints Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : ToPoints Method
Converts the existing Length twips to points (1pt = 20twips)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToPoints() As System.Single
public System.float ToPoints()

Return Value

Float value in points
See Also

Reference

Length Structure
Length Members


ToString Method (Length)

ToString Method (Length)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : ToString Method
Converts the value of this instance to its equivalent string representation.
Overload List
Overload | Description
ToString() | Converts the value of this instance to its equivalent string representation.
ToString(IFormatProvider) | Converts the value of this instance to its equivalent string representation.
See Also

Reference

Length Structure
Length Members


ToString() Method

ToString() Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure > ToString Method : ToString() Method
Converts the value of this instance to its equivalent string representation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overrides Function ToString() As System.String
public override System.string ToString()

Return Value

String representation of current Length instance
See Also

Reference

Length Structure
Length Members
Overload List


ToString(IFormatProvider) Method

ToString(IFormatProvider) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure > ToString Method : ToString(IFormatProvider) Method
IFormatprovider to use to format the string.
Converts the value of this instance to its equivalent string representation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function ToString( _
   ByVal provider As System.IFormatProvider _
) As System.String
public System.string ToString(
   System.IFormatProvider provider
)

Parameters

provider
IFormatprovider to use to format the string.

Return Value

String representation of current Length instance
See Also

Reference

Length Structure
Length Members
Overload List


ToTwips Method

ToTwips Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : ToTwips Method
Converts the existing Length to twips
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToTwips() As System.Single
public System.float ToTwips()

Return Value

Float value in twips
See Also

Reference

Length Structure
Length Members


TryParse Method

TryParse Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : TryParse Method
Input string to parse.
The result to store parsed length.
Tries to parse specified string as length.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function TryParse( _
   ByVal value As System.String, _
   ByRef result As Length _
) As System.Boolean
public static System.bool TryParse(
   System.string value,
   out Length result
)

Parameters

value
Input string to parse.
result
The result to store parsed length.

Return Value

true if the input string is valid length; otherwise - false.
See Also

Reference

Length Structure
Length Members


TwipsToString Method

TwipsToString Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : TwipsToString Method
Value in twips
Target unit for conversion for output
Converts a passed in value to string based on the passed in unit type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function TwipsToString( _
   ByVal twips As System.Single, _
   ByVal target As Length.Unit _
) As System.String
public static System.string TwipsToString(
   System.float twips,
   Length.Unit target
)

Parameters

twips
Value in twips
target
Target unit for conversion for output
See Also

Reference

Length Structure
Length Members


Length Structure Properties

Length Structure Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace : Length Structure

For a list of all members of this type, see Length members.

Public Properties
 | Name | Description
Public Property | IsUndefined | T:GrapeCity.ActiveReports.Extensibility.Definition.Components.Length% has been set to a particular value.
Public Property | IsValid | Indicates if the Length string contains the correct units and value.
Public Property | OriginalUnit | Contains the original unit type that was passed in so that it can be used in conversions later.
Top
See Also

Reference

Length Structure
GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace


IsUndefined Property

IsUndefined Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : IsUndefined Property
T:GrapeCity.ActiveReports.Extensibility.Definition.Components.Length% has been set to a particular value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsUndefined As System.Boolean
public System.bool IsUndefined {get;}

Property Value

Returns true if the Length is empty, else false
See Also

Reference

Length Structure
Length Members


IsValid Property (Length)

IsValid Property (Length)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : IsValid Property
Indicates if the Length string contains the correct units and value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsValid As System.Boolean
public System.bool IsValid {get;}

Property Value

Return true if the Length string is valid, else false.
See Also

Reference

Length Structure
Length Members


OriginalUnit Property

OriginalUnit Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : OriginalUnit Property
Contains the original unit type that was passed in so that it can be used in conversions later.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property OriginalUnit As Length.Unit
public Length.Unit OriginalUnit {get;}

Property Value

Length.Unit
See Also

Reference

Length Structure
Length Members


Length Structure Fields

Length Structure Fields

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace : Length Structure

For a list of all members of this type, see Length members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | An empty Length object.
static (Shared in Visual Basic) | Zero | A zero inch Length object.
Top
See Also

Reference

Length Structure
GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace


Empty Field (Length)

Empty Field (Length)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : Empty Field
An empty Length object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Empty As Length
public static readonly Length Empty
See Also

Reference

Length Structure
Length Members


Zero Field

Zero Field

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : Zero Field
A zero inch Length object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Zero As Length
public static readonly Length Zero
See Also

Reference

Length Structure
Length Members


Addition Operator (Length)

Addition Operator (Length)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : Addition Operator
the Length
the Length
Adds two specified Length values and returns the unit of the first GrapeCity.ActiveReports.Extensibility.Definition.Components.Length.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator +( _
   ByVal unit1 As Length, _
   ByVal unit2 As Length _
) As Length
public Length operator +(
   Length unit1,
   Length unit2
)

Parameters

unit1
the Length
unit2
the Length

Return Value

the Length that is the results of adding unit1 to unit2
See Also

Reference

Length Structure
Length Members


Equality Operator (Length)

Equality Operator (Length)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : Equality Operator
the Length
the Length
For predefined value types, the equality operator (==) returns true if the values of its operands are equal, false otherwise. For reference types other than string, == returns true if its two operands refer to the same object. For the string type, == compares the values of the strings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator =( _
   ByVal unit1 As Length, _
   ByVal unit2 As Length _
) As System.Boolean
public System.bool operator ==(
   Length unit1,
   Length unit2
)

Parameters

unit1
the Length
unit2
the Length
See Also

Reference

Length Structure
Length Members


Explicit Type Conversion Operator

Explicit Type Conversion Operator

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : Explicit Type Conversion Operator
GrapeCity.ActiveReports.Extensibility.Definition.Components.Length to convert to a string
Converts current Length instance to a string
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator Narrowing CType( _
   ByVal unit As Length _
) As System.String
public System.string operator explicit(
   Length unit
)

Parameters

unit
GrapeCity.ActiveReports.Extensibility.Definition.Components.Length to convert to a string

Return Value

String representation of current Length instance
See Also

Reference

Length Structure
Length Members


Greater Than Operator

Greater Than Operator

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : Greater Than Operator
the Length
the Length
All numeric and enumeration types define a "greater than" relational operator (>) that returns true if the first operand is greater than the second, false otherwise.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator >( _
   ByVal unit1 As Length, _
   ByVal unit2 As Length _
) As System.Boolean
public System.bool operator >(
   Length unit1,
   Length unit2
)

Parameters

unit1
the Length
unit2
the Length
See Also

Reference

Length Structure
Length Members


Greater Than or Equal Operator

Greater Than or Equal Operator

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : Greater Than or Equal Operator
the Length
the Length
All numeric and enumeration types define a "greater than or equal" relational operator (>=) that returns true if the first operand is greater than or equal to the second, false otherwise.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator >=( _
   ByVal unit1 As Length, _
   ByVal unit2 As Length _
) As System.Boolean
public System.bool operator >=(
   Length unit1,
   Length unit2
)

Parameters

unit1
the Length
unit2
the Length
See Also

Reference

Length Structure
Length Members


Implicit Type Conversion Operator (Length)

Implicit Type Conversion Operator (Length)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : Implicit Type Conversion Operator
The length to convert.
Converts string value to a new Length instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator Widening CType( _
   ByVal length As System.String _
) As Length
public Length operator implicit(
   System.string length
)

Parameters

length
The length to convert.

Return Value

new Lengthinstance
See Also

Reference

Length Structure
Length Members


Inequality Operator (Length)

Inequality Operator (Length)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : Inequality Operator
the Length
the Length
The inequality operator (!=) returns false if its operands are equal, true otherwise. Inequality operators are predefined for all types, including string and object. User-defined types can overload the != operator.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator <>( _
   ByVal unit1 As Length, _
   ByVal unit2 As Length _
) As System.Boolean
public System.bool operator !=(
   Length unit1,
   Length unit2
)

Parameters

unit1
the Length
unit2
the Length
See Also

Reference

Length Structure
Length Members


Less Than Operator

Less Than Operator

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : Less Than Operator
the Length
the Length
All numeric and enumeration types define a "less than" relational operator (<) that returns true if the first operand is less than the second, false otherwise.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator <( _
   ByVal unit1 As Length, _
   ByVal unit2 As Length _
) As System.Boolean
public System.bool operator <(
   Length unit1,
   Length unit2
)

Parameters

unit1
the Length
unit2
the Length
See Also

Reference

Length Structure
Length Members


Less Than or Equal Operator

Less Than or Equal Operator

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : Less Than or Equal Operator
the Length
the Length
All numeric and enumeration types define a "less than or equal" relational operator (<=) that returns true if the first operand is less than or equal to the second, false otherwise.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator <=( _
   ByVal unit1 As Length, _
   ByVal unit2 As Length _
) As System.Boolean
public System.bool operator <=(
   Length unit1,
   Length unit2
)

Parameters

unit1
the Length
unit2
the Length
See Also

Reference

Length Structure
Length Members


Subtraction Operator

Subtraction Operator

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace > Length Structure : Subtraction Operator
the Length minuend
the Length subtrahend
Subtracts one Length from another and return the unit of the first GrapeCity.ActiveReports.Extensibility.Definition.Components.Length.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator -( _
   ByVal unit1 As Length, _
   ByVal unit2 As Length _
) As Length
public Length operator -(
   Length unit1,
   Length unit2
)

Parameters

unit1
the Length minuend
unit2
the Length subtrahend

Return Value

the Length that is the results of subtracting unit1 by unit2
See Also

Reference

Length Structure
Length Members


GrapeCity.ActiveReports.Extensibility.Drawing Namespace

GrapeCity.ActiveReports.Extensibility.Drawing Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Drawing Namespace
The GrapeCity.ActiveReports.Extensibility.Drawing namespace includes classes that extend rendering.
Classes
 | Class | Description
Class | BlendEx | Defines a blend pattern for a LinearGradientBrush object. This class cannot be inherited.
Class | ColorBlendEx | Defines arrays of colors and positions used for interpolating color blending in a multicolor gradient. This class cannot be inherited.
Class | MatrixEx | Indicates a 3-by-3 affine matrix representing a geometric transform
Class | RectangleEx | Stores a set of four integers that represent the location and size of a rectangle
Structures
 | Structure | Description
Structure | ColorEx | Represents an ARGB color.
Structure | PointFEx | Represents an ordered pair of floating-point x- and y-coordinates that defines a point in a two-dimensional plane.
Structure | RectangleFEx | Stores a set of four floating-pofloat numbers that represent the location and size of a rectangle
Structure | SizeFEx | Stores an ordered pair of floating-point numbers, typically the width and height of a rectangle.
Enumerations
 | Enumeration | Description
Enumeration | GraphicsUnitEx | Specifies the unit of measure the provided data is in.
Enumeration | MatrixOrderEx | Specifies matrix transform operation order.
Enumeration | SmoothingModeEx | Specifies if, and how, smoothing is applied to lines, curves and filled area edges.
Enumeration | TextRenderingHintEx | Specifies the text rendering quality.
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


BlendEx Class

BlendEx Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : BlendEx Class
Defines a blend pattern for a LinearGradientBrush object. This class cannot be inherited.
Object Model
BlendEx Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class BlendEx
public sealed class BlendEx
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Drawing.BlendEx

See Also

Reference

BlendEx Members
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


BlendEx Class Members

BlendEx Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : BlendEx Class

The following tables list the members exposed by BlendEx.

Public Constructors
 | Name | Description
Public Constructor | BlendEx Constructor | Overloaded. Initialises a new instance of the BlendEx class.
Top
Public Properties
 | Name | Description
Public Property | Factors | Gets or sets an array of blend factors for the gradient.
Public Property | Positions | Gets or sets an array of blend positions for the gradient.
Top
See Also

Reference

BlendEx Class
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


BlendEx Constructor

BlendEx Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > BlendEx Class : BlendEx Constructor
Initialises a new instance of the BlendEx class.
Overload List
Overload | Description
BlendEx Constructor() | Initializes a new instance of the BlendEx class.
BlendEx Constructor(Int32) | Initializes a new instance of the BlendEx class with the specified number of factors and positions.
See Also

Reference

BlendEx Class
BlendEx Members


BlendEx Constructor()

BlendEx Constructor()

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > BlendEx Class > BlendEx Constructor : BlendEx Constructor()
Initializes a new instance of the BlendEx class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public BlendEx()
See Also

Reference

BlendEx Class
BlendEx Members
Overload List


BlendEx Constructor(Int32)

BlendEx Constructor(Int32)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > BlendEx Class > BlendEx Constructor : BlendEx Constructor(Int32)
The number of elements in the Factors and Positions arrays.
Initializes a new instance of the BlendEx class with the specified number of factors and positions.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal count As System.Integer _
)
public BlendEx(
   System.int count
)

Parameters

count
The number of elements in the Factors and Positions arrays.
See Also

Reference

BlendEx Class
BlendEx Members
Overload List


BlendEx Class Properties

BlendEx Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : BlendEx Class

For a list of all members of this type, see BlendEx members.

Public Properties
 | Name | Description
Public Property | Factors | Gets or sets an array of blend factors for the gradient.
Public Property | Positions | Gets or sets an array of blend positions for the gradient.
Top
See Also

Reference

BlendEx Class
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


Factors Property

Factors Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > BlendEx Class : Factors Property
Gets or sets an array of blend factors for the gradient.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Factors As System.Single()
public System.float[] Factors {get; set;}
See Also

Reference

BlendEx Class
BlendEx Members


Positions Property (BlendEx)

Positions Property (BlendEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > BlendEx Class : Positions Property
Gets or sets an array of blend positions for the gradient.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Positions As System.Single()
public System.float[] Positions {get; set;}
See Also

Reference

BlendEx Class
BlendEx Members


ColorBlendEx Class

ColorBlendEx Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : ColorBlendEx Class
Defines arrays of colors and positions used for interpolating color blending in a multicolor gradient. This class cannot be inherited.
Object Model
ColorBlendEx Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ColorBlendEx
public sealed class ColorBlendEx
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Drawing.ColorBlendEx

See Also

Reference

ColorBlendEx Members
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


ColorBlendEx Class Members

ColorBlendEx Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : ColorBlendEx Class

The following tables list the members exposed by ColorBlendEx.

Public Constructors
 | Name | Description
Public Constructor | ColorBlendEx Constructor | Overloaded. Initialises a new instance of ColorBlendEx class.
Top
Public Properties
 | Name | Description
Public Property | Colors | Gets or sets an array of colors that represents the colors to use at corresponding positions along a gradient.
Public Property | Positions | Gets or sets the positions along a gradient line.
Top
See Also

Reference

ColorBlendEx Class
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


ColorBlendEx Constructor

ColorBlendEx Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > ColorBlendEx Class : ColorBlendEx Constructor
Initialises a new instance of ColorBlendEx class.
Overload List
Overload | Description
ColorBlendEx Constructor(Int32) | Initializes a new instance of the ColorBlend class with the specified number of colors and positions.
ColorBlendEx Constructor() | Initializes a new instance of the ColorBlend class.
See Also

Reference

ColorBlendEx Class
ColorBlendEx Members


ColorBlendEx Constructor(Int32)

ColorBlendEx Constructor(Int32)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > ColorBlendEx Class > ColorBlendEx Constructor : ColorBlendEx Constructor(Int32)
The number of colors and positions in this ColorBlendEx.
Initializes a new instance of the ColorBlend class with the specified number of colors and positions.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal count As System.Integer _
)
public ColorBlendEx(
   System.int count
)

Parameters

count
The number of colors and positions in this ColorBlendEx.
See Also

Reference

ColorBlendEx Class
ColorBlendEx Members
Overload List


ColorBlendEx Constructor()

ColorBlendEx Constructor()

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > ColorBlendEx Class > ColorBlendEx Constructor : ColorBlendEx Constructor()
Initializes a new instance of the ColorBlend class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ColorBlendEx()
See Also

Reference

ColorBlendEx Class
ColorBlendEx Members
Overload List


ColorBlendEx Class Properties

ColorBlendEx Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : ColorBlendEx Class

For a list of all members of this type, see ColorBlendEx members.

Public Properties
 | Name | Description
Public Property | Colors | Gets or sets an array of colors that represents the colors to use at corresponding positions along a gradient.
Public Property | Positions | Gets or sets the positions along a gradient line.
Top
See Also

Reference

ColorBlendEx Class
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


Colors Property

Colors Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > ColorBlendEx Class : Colors Property
Gets or sets an array of colors that represents the colors to use at corresponding positions along a gradient.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Colors As ColorEx()
public ColorEx[] Colors {get; set;}
See Also

Reference

ColorBlendEx Class
ColorBlendEx Members


Positions Property (ColorBlendEx)

Positions Property (ColorBlendEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > ColorBlendEx Class : Positions Property
Gets or sets the positions along a gradient line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Positions As System.Single()
public System.float[] Positions {get; set;}
See Also

Reference

ColorBlendEx Class
ColorBlendEx Members


MatrixEx Class

MatrixEx Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : MatrixEx Class
Indicates a 3-by-3 affine matrix representing a geometric transform
Object Model
MatrixEx Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MatrixEx
public sealed class MatrixEx
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Drawing.MatrixEx

See Also

Reference

MatrixEx Members
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


MatrixEx Class Members

MatrixEx Class Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : MatrixEx Class

The following tables list the members exposed by MatrixEx.

Public Constructors
 | Name | Description
Public Constructor | MatrixEx Constructor | Overloaded. Initialises a new instance of the MatrixEx class.
Top
Public Properties
 | Name | Description
Public Property | Elements | Gets an array of floating point value representing the MatrixEx
Public Property | IsIdentity | Geta an indication of whether or not the MatrixEx is an identity matrix.
Public Property | OffsetX | Gets the x translation value which is the value from the third row, first column.
Public Property | OffsetY | Gets the y translation value which is the value from the third row, second column.
Top
Public Methods
 | Name | Description
Public Method | Clone | Creates an exect duplicate of the MatrixEx
Public Method | Dispose | Disposes allocated resources.
Public Method | Invert | Inverts the MatrixEx if it can be inverted.
Public Method | Multiply | Prepends the specified MatrixEx to multiply this MatrixEx instance.
Public Method | Reset | Resets the MatrixEx
Public Method | Rotate | Prepends a clockwise rotation, around the origin and by the indicated angle, to the MatrixEx.
Public Method | RotateAt | Overloaded. Prepends a clockwise rotation, around the point specified and by the indicated angle, to the MatrixEx.
Public Method | Scale | Prepends a scale vector to the MatrixEx
Public Method | TransformPoints | Applies a geometric transform represented by the MatrixEx to the provided points.
Public Method | Translate | Prepends the specified translation vector to the MatrixEx
Top
See Also

Reference

MatrixEx Class
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


MatrixEx Constructor

MatrixEx Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > MatrixEx Class : MatrixEx Constructor
Initialises a new instance of the MatrixEx class.
Overload List
Overload | Description
MatrixEx Constructor() | Initializes a new instance of the MatrixEx class.
MatrixEx Constructor(Matrix) | Initializes a new instance of the MatrixEx class from System.Drawing.Drawing2D.Matrix.
MatrixEx Constructor(Single,Single,Single,Single,Single,Single) | Initializes a new instance of the MatrixEx class.
See Also

Reference

MatrixEx Class
MatrixEx Members


MatrixEx Constructor()

MatrixEx Constructor()

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > MatrixEx Class > MatrixEx Constructor : MatrixEx Constructor()
Initializes a new instance of the MatrixEx class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MatrixEx()
See Also

Reference

MatrixEx Class
MatrixEx Members
Overload List


MatrixEx Constructor(Matrix)

MatrixEx Constructor(Matrix)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > MatrixEx Class > MatrixEx Constructor : MatrixEx Constructor(Matrix)
The object to create the transformation matrix from.
Initializes a new instance of the MatrixEx class from System.Drawing.Drawing2D.Matrix.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal matrix As System.Drawing.Drawing2D.Matrix _
)
public MatrixEx(
   System.Drawing.Drawing2D.Matrix matrix
)

Parameters

matrix
The object to create the transformation matrix from.
See Also

Reference

MatrixEx Class
MatrixEx Members
Overload List


MatrixEx Constructor(Single,Single,Single,Single,Single,Single)

MatrixEx Constructor(Single,Single,Single,Single,Single,Single)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > MatrixEx Class > MatrixEx Constructor : MatrixEx Constructor(Single,Single,Single,Single,Single,Single)
The value to use fo the first row and column in the new matrix.
The value to use fo the first row and second column in the new matrix.
The value to use fo the second row and first column in the new matrix.
The value to use fo the second row and column in the new matrix.
The value to use fo the third row and second column in the new matrix.
The value to use fo the thrid row and second column in the new matrix.
Initializes a new instance of the MatrixEx class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal firstRowFirstColumm As System.Single, _
   ByVal firstRowSecondColumn As System.Single, _
   ByVal secondRowFirstColumn As System.Single, _
   ByVal secondRowSecondColumn As System.Single, _
   ByVal thirdRowFirstColumn As System.Single, _
   ByVal thirdRowSecondColumn As System.Single _
)
public MatrixEx(
   System.float firstRowFirstColumm,
   System.float firstRowSecondColumn,
   System.float secondRowFirstColumn,
   System.float secondRowSecondColumn,
   System.float thirdRowFirstColumn,
   System.float thirdRowSecondColumn
)

Parameters

firstRowFirstColumm
The value to use fo the first row and column in the new matrix.
firstRowSecondColumn
The value to use fo the first row and second column in the new matrix.
secondRowFirstColumn
The value to use fo the second row and first column in the new matrix.
secondRowSecondColumn
The value to use fo the second row and column in the new matrix.
thirdRowFirstColumn
The value to use fo the third row and second column in the new matrix.
thirdRowSecondColumn
The value to use fo the thrid row and second column in the new matrix.
See Also

Reference

MatrixEx Class
MatrixEx Members
Overload List


MatrixEx Class Methods

MatrixEx Class Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : MatrixEx Class

For a list of all members of this type, see MatrixEx members.

Public Methods
 | Name | Description
Public Method | Clone | Creates an exect duplicate of the MatrixEx
Public Method | Dispose | Disposes allocated resources.
Public Method | Invert | Inverts the MatrixEx if it can be inverted.
Public Method | Multiply | Prepends the specified MatrixEx to multiply this MatrixEx instance.
Public Method | Reset | Resets the MatrixEx
Public Method | Rotate | Prepends a clockwise rotation, around the origin and by the indicated angle, to the MatrixEx.
Public Method | RotateAt | Overloaded. Prepends a clockwise rotation, around the point specified and by the indicated angle, to the MatrixEx.
Public Method | Scale | Prepends a scale vector to the MatrixEx
Public Method | TransformPoints | Applies a geometric transform represented by the MatrixEx to the provided points.
Public Method | Translate | Prepends the specified translation vector to the MatrixEx
Top
See Also

Reference

MatrixEx Class
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


Clone Method (MatrixEx)

Clone Method (MatrixEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > MatrixEx Class : Clone Method
Creates an exect duplicate of the MatrixEx
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Clone() As MatrixEx
public MatrixEx Clone()

Return Value

The MatrixEx created.
See Also

Reference

MatrixEx Class
MatrixEx Members


Dispose Method (MatrixEx)

Dispose Method (MatrixEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > MatrixEx Class : Dispose Method
Disposes allocated resources.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

MatrixEx Class
MatrixEx Members


Invert Method

Invert Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > MatrixEx Class : Invert Method
Inverts the MatrixEx if it can be inverted.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Invert()
public void Invert()
See Also

Reference

MatrixEx Class
MatrixEx Members


Multiply Method (MatrixEx)

Multiply Method (MatrixEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > MatrixEx Class : Multiply Method
The MatrixEx to multiply this MatrixEx instance with.
Prepends the specified MatrixEx to multiply this MatrixEx instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Multiply( _
   ByVal matrix As MatrixEx _
)
public void Multiply(
   MatrixEx matrix
)

Parameters

matrix
The MatrixEx to multiply this MatrixEx instance with.
See Also

Reference

MatrixEx Class
MatrixEx Members


Reset Method (MatrixEx)

Reset Method (MatrixEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > MatrixEx Class : Reset Method
Resets the MatrixEx
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Reset()
public void Reset()
See Also

Reference

MatrixEx Class
MatrixEx Members


Rotate Method

Rotate Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > MatrixEx Class : Rotate Method
The angle for the rotation.
Prepends a clockwise rotation, around the origin and by the indicated angle, to the MatrixEx.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Rotate( _
   ByVal angle As System.Single _
)
public void Rotate(
   System.float angle
)

Parameters

angle
The angle for the rotation.
See Also

Reference

MatrixEx Class
MatrixEx Members


RotateAt Method

RotateAt Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > MatrixEx Class : RotateAt Method
Prepends a clockwise rotation, around the point specified and by the indicated angle, to the MatrixEx.
Overload List
Overload | Description
RotateAt(Single,PointFEx) | Prepends a clockwise rotation, around the point specified and by the indicated angle, to the MatrixEx.
RotateAt(Single,PointFEx,MatrixOrderEx) | Applies a clockwise rotation to the MatrixEx, around the point specified and by the indicated angle, in the order specified.
See Also

Reference

MatrixEx Class
MatrixEx Members


RotateAt(Single,PointFEx) Method

RotateAt(Single,PointFEx) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > MatrixEx Class > RotateAt Method : RotateAt(Single,PointFEx) Method
The angle for the rotation.
The point to rotate around.
Prepends a clockwise rotation, around the point specified and by the indicated angle, to the MatrixEx.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub RotateAt( _
   ByVal angle As System.Single, _
   ByVal point As PointFEx _
)
public void RotateAt(
   System.float angle,
   PointFEx point
)

Parameters

angle
The angle for the rotation.
point
The point to rotate around.
See Also

Reference

MatrixEx Class
MatrixEx Members
Overload List


RotateAt(Single,PointFEx,MatrixOrderEx) Method

RotateAt(Single,PointFEx,MatrixOrderEx) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > MatrixEx Class > RotateAt Method : RotateAt(Single,PointFEx,MatrixOrderEx) Method
The angle for the rotation.
The point to rotate around.
A MatrixOrderEx indicating the order in which the rotation should be applied
Applies a clockwise rotation to the MatrixEx, around the point specified and by the indicated angle, in the order specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub RotateAt( _
   ByVal angle As System.Single, _
   ByVal point As PointFEx, _
   ByVal order As MatrixOrderEx _
)
public void RotateAt(
   System.float angle,
   PointFEx point,
   MatrixOrderEx order
)

Parameters

angle
The angle for the rotation.
point
The point to rotate around.
order
A MatrixOrderEx indicating the order in which the rotation should be applied
See Also

Reference

MatrixEx Class
MatrixEx Members
Overload List


Scale Method (MatrixEx)

Scale Method (MatrixEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > MatrixEx Class : Scale Method
The scaled amount on the x-axis.
The scaled mount on the y-axis.
Prepends a scale vector to the MatrixEx
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Scale( _
   ByVal scaleX As System.Single, _
   ByVal scaleY As System.Single _
)
public void Scale(
   System.float scaleX,
   System.float scaleY
)

Parameters

scaleX
The scaled amount on the x-axis.
scaleY
The scaled mount on the y-axis.
See Also

Reference

MatrixEx Class
MatrixEx Members


TransformPoints Method

TransformPoints Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > MatrixEx Class : TransformPoints Method
An array of points to transform.
Applies a geometric transform represented by the MatrixEx to the provided points.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub TransformPoints( _
   ByVal points() As PointFEx _
)
public void TransformPoints(
   PointFEx[] points
)

Parameters

points
An array of points to transform.
See Also

Reference

MatrixEx Class
MatrixEx Members


Translate Method (MatrixEx)

Translate Method (MatrixEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > MatrixEx Class : Translate Method
the translation X value to use
the translation Y value to use
Prepends the specified translation vector to the MatrixEx
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Translate( _
   ByVal offsetX As System.Single, _
   ByVal offsetY As System.Single _
)
public void Translate(
   System.float offsetX,
   System.float offsetY
)

Parameters

offsetX
the translation X value to use
offsetY
the translation Y value to use
See Also

Reference

MatrixEx Class
MatrixEx Members


MatrixEx Class Properties

MatrixEx Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : MatrixEx Class

For a list of all members of this type, see MatrixEx members.

Public Properties
 | Name | Description
Public Property | Elements | Gets an array of floating point value representing the MatrixEx
Public Property | IsIdentity | Geta an indication of whether or not the MatrixEx is an identity matrix.
Public Property | OffsetX | Gets the x translation value which is the value from the third row, first column.
Public Property | OffsetY | Gets the y translation value which is the value from the third row, second column.
Top
See Also

Reference

MatrixEx Class
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


Elements Property (MatrixEx)

Elements Property (MatrixEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > MatrixEx Class : Elements Property
Gets an array of floating point value representing the MatrixEx
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Elements As System.Single()
public System.float[] Elements {get;}
See Also

Reference

MatrixEx Class
MatrixEx Members


IsIdentity Property

IsIdentity Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > MatrixEx Class : IsIdentity Property
Geta an indication of whether or not the MatrixEx is an identity matrix.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsIdentity As System.Boolean
public System.bool IsIdentity {get;}
See Also

Reference

MatrixEx Class
MatrixEx Members


OffsetX Property (MatrixEx)

OffsetX Property (MatrixEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > MatrixEx Class : OffsetX Property
Gets the x translation value which is the value from the third row, first column.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property OffsetX As System.Single
public System.float OffsetX {get;}
See Also

Reference

MatrixEx Class
MatrixEx Members


OffsetY Property (MatrixEx)

OffsetY Property (MatrixEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > MatrixEx Class : OffsetY Property
Gets the y translation value which is the value from the third row, second column.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property OffsetY As System.Single
public System.float OffsetY {get;}
See Also

Reference

MatrixEx Class
MatrixEx Members


RectangleEx Class

RectangleEx Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : RectangleEx Class
Stores a set of four integers that represent the location and size of a rectangle
Object Model
RectangleEx Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class RectangleEx
public sealed class RectangleEx
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Drawing.RectangleEx

See Also

Reference

RectangleEx Members
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


RectangleEx Class Members

RectangleEx Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : RectangleEx Class

The following tables list the members exposed by RectangleEx.

Public Constructors
 | Name | Description
Public Constructor | RectangleEx Constructor | Initializes a new instance of the RectangleEx class with the specified location and size.
Top
Public Properties
 | Name | Description
Public Property | Height | Gets or sets the height of this Rectangle structure.
Public Property | Width | Gets or sets the width of this Rectangle structure.
Public Property | X | Gets or sets the x-coordinate of the upper-left corner of this Rectangle structure.
Public Property | Y | Gets or sets the y-coordinate of the upper-left corner of this Rectangle structure.
Top
See Also

Reference

RectangleEx Class
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


RectangleEx Constructor

RectangleEx Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > RectangleEx Class : RectangleEx Constructor
The x-coordinate of the upper-left corner of the rectangle.
The y-coordinate of the upper-left corner of the rectangle.
The width of the rectangle.
The height of the rectangle.
Initializes a new instance of the RectangleEx class with the specified location and size.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer _
)
public RectangleEx(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

x
The x-coordinate of the upper-left corner of the rectangle.
y
The y-coordinate of the upper-left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.
See Also

Reference

RectangleEx Class
RectangleEx Members


RectangleEx Class Properties

RectangleEx Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : RectangleEx Class

For a list of all members of this type, see RectangleEx members.

Public Properties
 | Name | Description
Public Property | Height | Gets or sets the height of this Rectangle structure.
Public Property | Width | Gets or sets the width of this Rectangle structure.
Public Property | X | Gets or sets the x-coordinate of the upper-left corner of this Rectangle structure.
Public Property | Y | Gets or sets the y-coordinate of the upper-left corner of this Rectangle structure.
Top
See Also

Reference

RectangleEx Class
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


Height Property (RectangleEx)

Height Property (RectangleEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > RectangleEx Class : Height Property
Gets or sets the height of this Rectangle structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As System.Integer
public System.int Height {get; set;}
See Also

Reference

RectangleEx Class
RectangleEx Members


Width Property (RectangleEx)

Width Property (RectangleEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > RectangleEx Class : Width Property
Gets or sets the width of this Rectangle structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As System.Integer
public System.int Width {get; set;}
See Also

Reference

RectangleEx Class
RectangleEx Members


X Property (RectangleEx)

X Property (RectangleEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > RectangleEx Class : X Property
Gets or sets the x-coordinate of the upper-left corner of this Rectangle structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property X As System.Integer
public System.int X {get; set;}
See Also

Reference

RectangleEx Class
RectangleEx Members


Y Property (RectangleEx)

Y Property (RectangleEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > RectangleEx Class : Y Property
Gets or sets the y-coordinate of the upper-left corner of this Rectangle structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Y As System.Integer
public System.int Y {get; set;}
See Also

Reference

RectangleEx Class
RectangleEx Members


GraphicsUnitEx Enumeration

GraphicsUnitEx Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : GraphicsUnitEx Enumeration
Specifies the unit of measure the provided data is in.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum GraphicsUnitEx
   Inherits System.Enum
public enum GraphicsUnitEx : System.Enum
Members
Member | Description
Display | Specifies the unit of measure is 1/75 inch
Document | Specifies the unit of measure is the document unit (1/300 inch)
Inch | Specifies the unit of measure is an inch.
Millimeter | Specifies the unit of measure is a millimeter
Pixel | Specifies the unit of measure is the device pixel.
Point | Specifies the unit of measure is a printer's point (1/72 inch)
World | Specifies the unit of measure is the world unit.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Drawing.GraphicsUnitEx

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Drawing Namespace


MatrixOrderEx Enumeration

MatrixOrderEx Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : MatrixOrderEx Enumeration
Specifies matrix transform operation order.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MatrixOrderEx
   Inherits System.Enum
public enum MatrixOrderEx : System.Enum
Members
Member | Description
Append | Specifies the new operation will occur after the old operation.
Prepend | Specifies the new operation will occur before the old operation.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Drawing.MatrixOrderEx

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Drawing Namespace


SmoothingModeEx Enumeration

SmoothingModeEx Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : SmoothingModeEx Enumeration
Specifies if, and how, smoothing is applied to lines, curves and filled area edges.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum SmoothingModeEx
   Inherits System.Enum
public enum SmoothingModeEx : System.Enum
Members
Member | Description
AntiAlias | Specifies using antialiasing.
Default | Specifies default mode.
HighQuality | Specifies high qulaity rendering which has a lower rendering speed.
HighSpeed | Specifies a higher speed rendering which has a lower rendering quality.
Invalid | Specifies an invalid mode.
None | Specifies not to use antialiasing.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Drawing.SmoothingModeEx

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Drawing Namespace


TextRenderingHintEx Enumeration

TextRenderingHintEx Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : TextRenderingHintEx Enumeration
Specifies the text rendering quality.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TextRenderingHintEx
   Inherits System.Enum
public enum TextRenderingHintEx : System.Enum
Members
Member | Description
AntiAlias | Specifies characters are drawn using antialiased glyph bitmaps without hinting. Improves quality but with performance cost.
AntiAliasGridFit | Specifies characters are drawn using antialiased glyph bitmaps with hinting. Improves quality but with performance cost.
ClearTypeGridFit | Specifies characters are drawn using glyph CT bitmap with hinting. Highest quality rendering but with performance costs. Takes advantage of ClearType font features.
SingleBitPerPixel | Specifies characters are drawn using its glyph bitmp with no hinting used.
SingleBitPerPixelGridFit | Specifies characters are drawn using its glyph bitmap with hinting used to improve stms and curvature appearance.
SystemDefault | Specifies characters are drawn using its glyph bitmap using the user's system font smoothing settings.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Drawing.TextRenderingHintEx

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Drawing Namespace


ColorEx Structure

ColorEx Structure
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : ColorEx Structure
Represents an ARGB color.
Object Model
ColorEx Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure ColorEx
   Inherits System.ValueType
public struct ColorEx : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Drawing.ColorEx

See Also

Reference

ColorEx Members
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


ColorEx Structure Members

ColorEx Structure Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : ColorEx Structure

The following tables list the members exposed by ColorEx.

Public Properties
 | Name | Description
Public Property | A | Gets the alpha component value of this ColorEx structure.
Public Property | B | Gets the blue component value of this ColorEx structure.
Public Property | G | Gets the green component value of this ColorEx structure.
Public Property | IsTransparent | Determines whether color is transparent.
Public Property | R | Gets the red component value of this ColorEx structure.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | ApplyTransparency | Adjust the color with provided transparency.
static (Shared in Visual Basic) | FromArgb | Creates a ColorEx structure from the four 8-bit ARGB components (alpha, red, green, and blue) values.
static (Shared in Visual Basic) | FromColorEx | Creates a ColorEx structure from the existing ColorEx structure.
Public Method | ToString | Returns a System.String that represents this instance.
Top
Public Operators
public Operator Equality | Implements the operator ==.
public Operator Inequality | Implements the operator !=.
Top
See Also

Reference

ColorEx Structure
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


ColorEx Structure Methods

ColorEx Structure Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : ColorEx Structure

For a list of all members of this type, see ColorEx members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | ApplyTransparency | Adjust the color with provided transparency.
static (Shared in Visual Basic) | FromArgb | Creates a ColorEx structure from the four 8-bit ARGB components (alpha, red, green, and blue) values.
static (Shared in Visual Basic) | FromColorEx | Creates a ColorEx structure from the existing ColorEx structure.
Public Method | ToString | Returns a System.String that represents this instance.
Top
See Also

Reference

ColorEx Structure
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


ApplyTransparency Method

ApplyTransparency Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > ColorEx Structure : ApplyTransparency Method
Adjust the color with provided transparency.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function ApplyTransparency( _
   ByVal color As ColorEx, _
   ByVal transparency As System.Double _
) As ColorEx
public static ColorEx ApplyTransparency(
   ColorEx color,
   System.double transparency
)

Parameters

color
transparency
See Also

Reference

ColorEx Structure
ColorEx Members


FromArgb Method (ColorEx)

FromArgb Method (ColorEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > ColorEx Structure : FromArgb Method
The alpha component. Valid values are 0 through 255.
The red component. Valid values are 0 through 255.
The green component. Valid values are 0 through 255.
The blue component. Valid values are 0 through 255.
Creates a ColorEx structure from the four 8-bit ARGB components (alpha, red, green, and blue) values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function FromArgb( _
   ByVal a As System.Byte, _
   ByVal r As System.Byte, _
   ByVal g As System.Byte, _
   ByVal b As System.Byte _
) As ColorEx
public static ColorEx FromArgb(
   System.byte a,
   System.byte r,
   System.byte g,
   System.byte b
)

Parameters

a
The alpha component. Valid values are 0 through 255.
r
The red component. Valid values are 0 through 255.
g
The green component. Valid values are 0 through 255.
b
The blue component. Valid values are 0 through 255.

Return Value

The ColorEx that this method creates.
See Also

Reference

ColorEx Structure
ColorEx Members


FromColorEx Method

FromColorEx Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > ColorEx Structure : FromColorEx Method
The ColorEx structure to create the new ColorEx structure from.
Creates a ColorEx structure from the existing ColorEx structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function FromColorEx( _
   ByVal colorEx As ColorEx _
) As ColorEx
public static ColorEx FromColorEx(
   ColorEx colorEx
)

Parameters

colorEx
The ColorEx structure to create the new ColorEx structure from.

Return Value

The ColorEx that this method creates.
See Also

Reference

ColorEx Structure
ColorEx Members


ToString Method (ColorEx)

ToString Method (ColorEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > ColorEx Structure : ToString Method
Returns a System.String that represents this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()
See Also

Reference

ColorEx Structure
ColorEx Members


ColorEx Structure Properties

ColorEx Structure Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : ColorEx Structure

For a list of all members of this type, see ColorEx members.

Public Properties
 | Name | Description
Public Property | A | Gets the alpha component value of this ColorEx structure.
Public Property | B | Gets the blue component value of this ColorEx structure.
Public Property | G | Gets the green component value of this ColorEx structure.
Public Property | IsTransparent | Determines whether color is transparent.
Public Property | R | Gets the red component value of this ColorEx structure.
Top
See Also

Reference

ColorEx Structure
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


A Property (ColorEx)

A Property (ColorEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > ColorEx Structure : A Property
Gets the alpha component value of this ColorEx structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property A As System.Byte
public System.byte A {get;}
See Also

Reference

ColorEx Structure
ColorEx Members


B Property (ColorEx)

B Property (ColorEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > ColorEx Structure : B Property
Gets the blue component value of this ColorEx structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property B As System.Byte
public System.byte B {get;}
See Also

Reference

ColorEx Structure
ColorEx Members


G Property (ColorEx)

G Property (ColorEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > ColorEx Structure : G Property
Gets the green component value of this ColorEx structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property G As System.Byte
public System.byte G {get;}
See Also

Reference

ColorEx Structure
ColorEx Members


IsTransparent Property

IsTransparent Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > ColorEx Structure : IsTransparent Property
Determines whether color is transparent.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsTransparent As System.Boolean
public System.bool IsTransparent {get;}

Property Value

True if color is transparent, otherwise false.
See Also

Reference

ColorEx Structure
ColorEx Members


R Property (ColorEx)

R Property (ColorEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > ColorEx Structure : R Property
Gets the red component value of this ColorEx structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property R As System.Byte
public System.byte R {get;}
See Also

Reference

ColorEx Structure
ColorEx Members


Equality Operator (ColorEx)

Equality Operator (ColorEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > ColorEx Structure : Equality Operator
Left operand
Right operand
Implements the operator ==.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator =( _
   ByVal x As ColorEx, _
   ByVal y As ColorEx _
) As System.Boolean
public System.bool operator ==(
   ColorEx x,
   ColorEx y
)

Parameters

x
Left operand
y
Right operand
See Also

Reference

ColorEx Structure
ColorEx Members


Inequality Operator (ColorEx)

Inequality Operator (ColorEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > ColorEx Structure : Inequality Operator
Left operand
Right operand
Implements the operator !=.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator <>( _
   ByVal x As ColorEx, _
   ByVal y As ColorEx _
) As System.Boolean
public System.bool operator !=(
   ColorEx x,
   ColorEx y
)

Parameters

x
Left operand
y
Right operand
See Also

Reference

ColorEx Structure
ColorEx Members


PointFEx Structure

PointFEx Structure
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : PointFEx Structure
Represents an ordered pair of floating-point x- and y-coordinates that defines a point in a two-dimensional plane.
Object Model
PointFEx Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure PointFEx
   Inherits System.ValueType
public struct PointFEx : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Drawing.PointFEx

See Also

Reference

PointFEx Members
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


PointFEx Structure Members

PointFEx Structure Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : PointFEx Structure

The following tables list the members exposed by PointFEx.

Public Constructors
 | Name | Description
Public Constructor | PointFEx Constructor | Initializes a new instance of the PointFEx class with the specified coordinates.
Top
Public Properties
 | Name | Description
Public Property | X | Gets or sets the x-coordinate of this PointFEx.
Public Property | Y | Gets the y-coordinate of this PointFEx.
Top
See Also

Reference

PointFEx Structure
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


PointFEx Constructor

PointFEx Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > PointFEx Structure : PointFEx Constructor
The horizontal position of the point.
The vertical position of the point.
Initializes a new instance of the PointFEx class with the specified coordinates.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal x As System.Single, _
   ByVal y As System.Single _
)
public PointFEx(
   System.float x,
   System.float y
)

Parameters

x
The horizontal position of the point.
y
The vertical position of the point.
See Also

Reference

PointFEx Structure
PointFEx Members


PointFEx Structure Properties

PointFEx Structure Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : PointFEx Structure

For a list of all members of this type, see PointFEx members.

Public Properties
 | Name | Description
Public Property | X | Gets or sets the x-coordinate of this PointFEx.
Public Property | Y | Gets the y-coordinate of this PointFEx.
Top
See Also

Reference

PointFEx Structure
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


X Property (PointFEx)

X Property (PointFEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > PointFEx Structure : X Property
Gets or sets the x-coordinate of this PointFEx.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property X As System.Single
public System.float X {get; set;}
See Also

Reference

PointFEx Structure
PointFEx Members


Y Property (PointFEx)

Y Property (PointFEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > PointFEx Structure : Y Property
Gets the y-coordinate of this PointFEx.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Y As System.Single
public System.float Y {get; set;}
See Also

Reference

PointFEx Structure
PointFEx Members


RectangleFEx Structure

RectangleFEx Structure
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : RectangleFEx Structure
Stores a set of four floating-pofloat numbers that represent the location and size of a rectangle
Object Model
RectangleFEx Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure RectangleFEx
   Inherits System.ValueType
public struct RectangleFEx : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Drawing.RectangleFEx

See Also

Reference

RectangleFEx Members
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


RectangleFEx Structure Members

RectangleFEx Structure Members
Fields Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : RectangleFEx Structure

The following tables list the members exposed by RectangleFEx.

Public Constructors
 | Name | Description
Public Constructor | RectangleFEx Constructor | Initializes a new instance of the RectangleEx class with the specified location and size.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | the empty rectangle.
Top
Public Properties
 | Name | Description
Public Property | Bottom | Gets the y-coordinate of the lower-right corner of the rectangular region defined by this RectangleFEx.
Public Property | Height | Gets or sets the height of this Rectangle structure.
Public Property | IsEmpty | Returns true if the current rectangle is empty.
Public Property | Left | Gets or sets the x-coordinate of the upper-left corner of this Rectangle structure.
Public Property | Right | Gets the x-coordinate of the lower-right corner of the rectangular region defined by this RectangleFEx.
Public Property | Top | Gets or sets the y-coordinate of the upper-left corner of this Rectangle structure.
Public Property | Width | Gets or sets the width of this Rectangle structure.
Public Property | X | Gets or sets the x-coordinate of the upper-left corner of this Rectangle structure.
Public Property | Y | Gets or sets the y-coordinate of the upper-left corner of this Rectangle structure.
Top
Public Methods
 | Name | Description
Public Method | Inflate | Inflates this rectangle by specified amount.
static (Shared in Visual Basic) | Intersect | Gets the intersection rectangle.
Public Method | Offset | Overloaded. Adjusts the location of this rectangle by the specified amount.
Top
See Also

Reference

RectangleFEx Structure
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


RectangleFEx Constructor

RectangleFEx Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > RectangleFEx Structure : RectangleFEx Constructor
The x-coordinate of the upper-left corner of the rectangle.
The y-coordinate of the upper-left corner of the rectangle.
The width of the rectangle.
The height of the rectangle.
Initializes a new instance of the RectangleEx class with the specified location and size.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal x As System.Single, _
   ByVal y As System.Single, _
   ByVal width As System.Single, _
   ByVal height As System.Single _
)
public RectangleFEx(
   System.float x,
   System.float y,
   System.float width,
   System.float height
)

Parameters

x
The x-coordinate of the upper-left corner of the rectangle.
y
The y-coordinate of the upper-left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.
See Also

Reference

RectangleFEx Structure
RectangleFEx Members


RectangleFEx Structure Methods

RectangleFEx Structure Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : RectangleFEx Structure

For a list of all members of this type, see RectangleFEx members.

Public Methods
 | Name | Description
Public Method | Inflate | Inflates this rectangle by specified amount.
static (Shared in Visual Basic) | Intersect | Gets the intersection rectangle.
Public Method | Offset | Overloaded. Adjusts the location of this rectangle by the specified amount.
Top
See Also

Reference

RectangleFEx Structure
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


Inflate Method (RectangleFEx)

Inflate Method (RectangleFEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > RectangleFEx Structure : Inflate Method
The width.
The height.
Inflates this rectangle by specified amount.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Inflate( _
   ByVal width As System.Single, _
   ByVal height As System.Single _
)
public void Inflate(
   System.float width,
   System.float height
)

Parameters

width
The width.
height
The height.
See Also

Reference

RectangleFEx Structure
RectangleFEx Members


Intersect Method (RectangleFEx)

Intersect Method (RectangleFEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > RectangleFEx Structure : Intersect Method
The first rectangle.
The second rectangle.
Gets the intersection rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function Intersect( _
   ByVal rect1 As RectangleFEx, _
   ByVal rect2 As RectangleFEx _
) As RectangleFEx
public static RectangleFEx Intersect(
   RectangleFEx rect1,
   RectangleFEx rect2
)

Parameters

rect1
The first rectangle.
rect2
The second rectangle.

Return Value

The rectangle which represents intersection of provided rectangles.
See Also

Reference

RectangleFEx Structure
RectangleFEx Members


Offset Method (RectangleFEx)

Offset Method (RectangleFEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > RectangleFEx Structure : Offset Method
Adjusts the location of this rectangle by the specified amount.
Overload List
Overload | Description
Offset(Single,Single) | Adjusts the location of this rectangle by the specified amount.
Offset(RectangleFEx,Single,Single) | Gets the rectangle with adjusted location.
See Also

Reference

RectangleFEx Structure
RectangleFEx Members


Offset(Single,Single) Method

Offset(Single,Single) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > RectangleFEx Structure > Offset Method : Offset(Single,Single) Method
The amount to offset the location horizontally.
The amount to offset the location vertically.
Adjusts the location of this rectangle by the specified amount.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Offset( _
   ByVal dx As System.Single, _
   ByVal dy As System.Single _
)
public void Offset(
   System.float dx,
   System.float dy
)

Parameters

dx
The amount to offset the location horizontally.
dy
The amount to offset the location vertically.
See Also

Reference

RectangleFEx Structure
RectangleFEx Members
Overload List


Offset(RectangleFEx,Single,Single) Method

Offset(RectangleFEx,Single,Single) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > RectangleFEx Structure > Offset Method : Offset(RectangleFEx,Single,Single) Method
The rectangle.
The amount to offset the location horizontally.
The amount to offset the location vertically.
Gets the rectangle with adjusted location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Offset( _
   ByVal rect As RectangleFEx, _
   ByVal dx As System.Single, _
   ByVal dy As System.Single _
) As RectangleFEx
public static RectangleFEx Offset(
   RectangleFEx rect,
   System.float dx,
   System.float dy
)

Parameters

rect
The rectangle.
dx
The amount to offset the location horizontally.
dy
The amount to offset the location vertically.
See Also

Reference

RectangleFEx Structure
RectangleFEx Members
Overload List


RectangleFEx Structure Properties

RectangleFEx Structure Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : RectangleFEx Structure

For a list of all members of this type, see RectangleFEx members.

Public Properties
 | Name | Description
Public Property | Bottom | Gets the y-coordinate of the lower-right corner of the rectangular region defined by this RectangleFEx.
Public Property | Height | Gets or sets the height of this Rectangle structure.
Public Property | IsEmpty | Returns true if the current rectangle is empty.
Public Property | Left | Gets or sets the x-coordinate of the upper-left corner of this Rectangle structure.
Public Property | Right | Gets the x-coordinate of the lower-right corner of the rectangular region defined by this RectangleFEx.
Public Property | Top | Gets or sets the y-coordinate of the upper-left corner of this Rectangle structure.
Public Property | Width | Gets or sets the width of this Rectangle structure.
Public Property | X | Gets or sets the x-coordinate of the upper-left corner of this Rectangle structure.
Public Property | Y | Gets or sets the y-coordinate of the upper-left corner of this Rectangle structure.
Top
See Also

Reference

RectangleFEx Structure
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


Bottom Property (RectangleFEx)

Bottom Property (RectangleFEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > RectangleFEx Structure : Bottom Property
Gets the y-coordinate of the lower-right corner of the rectangular region defined by this RectangleFEx.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Bottom As System.Single
public System.float Bottom {get;}
See Also

Reference

RectangleFEx Structure
RectangleFEx Members


Height Property (RectangleFEx)

Height Property (RectangleFEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > RectangleFEx Structure : Height Property
Gets or sets the height of this Rectangle structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As System.Single
public System.float Height {get; set;}
See Also

Reference

RectangleFEx Structure
RectangleFEx Members


IsEmpty Property (RectangleFEx)

IsEmpty Property (RectangleFEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > RectangleFEx Structure : IsEmpty Property
Returns true if the current rectangle is empty.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsEmpty As System.Boolean
public System.bool IsEmpty {get;}
See Also

Reference

RectangleFEx Structure
RectangleFEx Members


Left Property (RectangleFEx)

Left Property (RectangleFEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > RectangleFEx Structure : Left Property
Gets or sets the x-coordinate of the upper-left corner of this Rectangle structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Left As System.Single
public System.float Left {get;}
See Also

Reference

RectangleFEx Structure
RectangleFEx Members


Right Property (RectangleFEx)

Right Property (RectangleFEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > RectangleFEx Structure : Right Property
Gets the x-coordinate of the lower-right corner of the rectangular region defined by this RectangleFEx.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Right As System.Single
public System.float Right {get;}
See Also

Reference

RectangleFEx Structure
RectangleFEx Members


Top Property (RectangleFEx)

Top Property (RectangleFEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > RectangleFEx Structure : Top Property
Gets or sets the y-coordinate of the upper-left corner of this Rectangle structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Top As System.Single
public System.float Top {get;}
See Also

Reference

RectangleFEx Structure
RectangleFEx Members


Width Property (RectangleFEx)

Width Property (RectangleFEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > RectangleFEx Structure : Width Property
Gets or sets the width of this Rectangle structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As System.Single
public System.float Width {get; set;}
See Also

Reference

RectangleFEx Structure
RectangleFEx Members


X Property (RectangleFEx)

X Property (RectangleFEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > RectangleFEx Structure : X Property
Gets or sets the x-coordinate of the upper-left corner of this Rectangle structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property X As System.Single
public System.float X {get; set;}
See Also

Reference

RectangleFEx Structure
RectangleFEx Members


Y Property (RectangleFEx)

Y Property (RectangleFEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > RectangleFEx Structure : Y Property
Gets or sets the y-coordinate of the upper-left corner of this Rectangle structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Y As System.Single
public System.float Y {get; set;}
See Also

Reference

RectangleFEx Structure
RectangleFEx Members


RectangleFEx Structure Fields

RectangleFEx Structure Fields

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : RectangleFEx Structure

For a list of all members of this type, see RectangleFEx members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | the empty rectangle.
Top
See Also

Reference

RectangleFEx Structure
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


Empty Field (RectangleFEx)

Empty Field (RectangleFEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > RectangleFEx Structure : Empty Field
the empty rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Empty As RectangleFEx
public static readonly RectangleFEx Empty
See Also

Reference

RectangleFEx Structure
RectangleFEx Members


SizeFEx Structure

SizeFEx Structure
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : SizeFEx Structure
Stores an ordered pair of floating-point numbers, typically the width and height of a rectangle.
Object Model
SizeFEx Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure SizeFEx
   Inherits System.ValueType
public struct SizeFEx : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Drawing.SizeFEx

See Also

Reference

SizeFEx Members
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


SizeFEx Structure Members

SizeFEx Structure Members
Fields Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : SizeFEx Structure

The following tables list the members exposed by SizeFEx.

Public Constructors
 | Name | Description
Public Constructor | SizeFEx Constructor | Initializes a new instance of the SizeF class from the specified dimensions.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | Gets the size that has a width and a height value of 0.
Top
Public Properties
 | Name | Description
Public Property | Height | Gets or sets the vertical component of this SizeF.
Public Property | IsEmpty | Gets a value indicating whether this SizeF has zero width and height.
Public Property | Width | Gets or sets the horizontal component of this SizeF.
Top
See Also

Reference

SizeFEx Structure
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


SizeFEx Constructor

SizeFEx Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > SizeFEx Structure : SizeFEx Constructor
The width component of the new SizeF.
The height component of the new SizeF.
Initializes a new instance of the SizeF class from the specified dimensions.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal width As System.Single, _
   ByVal height As System.Single _
)
public SizeFEx(
   System.float width,
   System.float height
)

Parameters

width
The width component of the new SizeF.
height
The height component of the new SizeF.
See Also

Reference

SizeFEx Structure
SizeFEx Members


SizeFEx Structure Properties

SizeFEx Structure Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : SizeFEx Structure

For a list of all members of this type, see SizeFEx members.

Public Properties
 | Name | Description
Public Property | Height | Gets or sets the vertical component of this SizeF.
Public Property | IsEmpty | Gets a value indicating whether this SizeF has zero width and height.
Public Property | Width | Gets or sets the horizontal component of this SizeF.
Top
See Also

Reference

SizeFEx Structure
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


Height Property (SizeFEx)

Height Property (SizeFEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > SizeFEx Structure : Height Property
Gets or sets the vertical component of this SizeF.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As System.Single
public System.float Height {get; set;}
See Also

Reference

SizeFEx Structure
SizeFEx Members


IsEmpty Property (SizeFEx)

IsEmpty Property (SizeFEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > SizeFEx Structure : IsEmpty Property
Gets a value indicating whether this SizeF has zero width and height.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsEmpty As System.Boolean
public System.bool IsEmpty {get;}
See Also

Reference

SizeFEx Structure
SizeFEx Members


Width Property (SizeFEx)

Width Property (SizeFEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > SizeFEx Structure : Width Property
Gets or sets the horizontal component of this SizeF.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As System.Single
public System.float Width {get; set;}
See Also

Reference

SizeFEx Structure
SizeFEx Members


SizeFEx Structure Fields

SizeFEx Structure Fields

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace : SizeFEx Structure

For a list of all members of this type, see SizeFEx members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | Gets the size that has a width and a height value of 0.
Top
See Also

Reference

SizeFEx Structure
GrapeCity.ActiveReports.Extensibility.Drawing Namespace


Empty Field (SizeFEx)

Empty Field (SizeFEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Drawing Namespace > SizeFEx Structure : Empty Field
Gets the size that has a width and a height value of 0.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Empty As SizeFEx
public static readonly SizeFEx Empty
See Also

Reference

SizeFEx Structure
SizeFEx Members


GrapeCity.ActiveReports.Extensibility.Layout Namespace

GrapeCity.ActiveReports.Extensibility.Layout Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Layout Namespace
The GrapeCity.ActiveReports.Extensibility.Layout namespace includes the classes that are used at the time of creating layouts for reports.
Classes
 | Class | Description
Class | ColumnInfo | The ColumnInfo class holds information about a multi-column layout. Creates a new instance of the ColumnInfo class.
Class | ContentRange | This is an abstract class that the ReportItem's layout manager creates, interprets and uses to denote a range with a logical beginning and end in its underlying content.
Class | LayoutManagerAttribute | Specifies the class used to implement layout services for a component.
Class | SupportedPageInfo | Supported page information.
Interfaces
 | Interface | Description
Interface | IBorders | Represents visual styles for all borders.
Interface | IContentRange | Represents a basic content range interface.
Interface | IGrid | Represents a virtual grid composed from the IGridCell
Interface | IGridCell | Represents a single cell in the virtual grid.
Interface | ILayoutArea | Specifies an area that contains a layout.
Interface | ILayoutAreaCollapsible | Specifies an area that contains a layout and provides collapsing support for hidden items inside layout area.
Interface | ILayoutEngine | Defines the layout engine public interface.
Interface | ILayoutEngineFactory | Summary description for ILayoutEngineFactory.
Interface | ILayoutManager | Implement this interface on ReportItem to provide custom layout logic or to support advanced layout features such as pagination.
Interface | ILayoutPage | Interface for layout page.
Interface | ILayoutRenderingService | Special service to support valid page numbers calculation during rendering.
Interface | ILayoutSection | Interface for layout sections.
Interface | ILayoutTree | The interface for the layout tree.
Interface | ISpanCellMethodResolver | Represents a resolve method for spanned cells of the grid
Interface | ITableArea | Public interface to a table. Basically just an ordered collection of TableRows.
Interface | ITableCell | Public interface to an individual cell in a table.
Interface | ITableRow | Public interface to a row in a table. Basically just an ordered collection of TableCells.
Interface | ITargetDevice | Interface to encapsulate target device properties and features, including, but not limited: - avail. fonts; - font/color mapping; - conversion of logical units to physical (dpi); - etc.
Structures
 | Structure | Description
Structure | CellSpan | Encapsulates information about cell column/row spans.
Structure | DeviceCapabilities | Describes the target rendering device capabilities for a specific set of features.
Structure | HitTestInfo | Contains information about the part of the layout area in which a mouse click occurs.
Structure | LayoutContext | Encapsulates information about layout operations for the report item to provide input for the DataDynamics.Reports.Extensibility.Layout.ILayoutManager interface.
Structure | LayoutInfo | Defines target device and other layout operation properties.
Structure | LayoutResult | Encapsulates the output of layout manager operations.
Structure | LayoutState | Encapsulates intermediate result (current state) of layout operation.
Delegates
 | Delegate | Description
Delegate | LayoutNotificationCallback | Specifies notification callback for layout operation.
Enumerations
 | Enumeration | Description
Enumeration | Features | All of the features recognized by the layout engine. This enumeration is used with the DataDynamics.Reports.Extensibility.Layout.ITargetDevice.Item property to locate rendering device capabilities.
Enumeration | HitTestResult | Specifes which area is hit. This enumeration is used with the DataDynamics.Reports.Extensibility.Layout.HitTestInfo.HitTestResult property to determine where a mouse click occurs.
Enumeration | LayoutCapabilities | Specifies what layout options are available for the report item. This enumeration is used with the DataDynamics.Reports.Extensibility.Layout.ILayoutManager.Capabilities property.
Enumeration | LayoutDirection | Specifies the direction in which the layout runs on the current page. This enumeration is used with the DataDynamics.Reports.Extensibility.Layout.LayoutContext.LayoutDirection property.
Enumeration | LayoutStatus | Indicates the progress of the layout operation. This enumeration is used with the DataDynamics.Reports.Extensibility.Layout.LayoutResult.LayoutStatus property.
Enumeration | SpanCellResolveMethod | Enum with kinds of method to indicate spanned cells
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


ColumnInfo Class

ColumnInfo Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ColumnInfo Class
The ColumnInfo class holds information about a multi-column layout. Creates a new instance of the ColumnInfo class.
Object Model
ColumnInfo Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ColumnInfo
public sealed class ColumnInfo
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Layout.ColumnInfo

See Also

Reference

ColumnInfo Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ColumnInfo Class Members

ColumnInfo Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ColumnInfo Class

The following tables list the members exposed by ColumnInfo.

Public Constructors
 | Name | Description
Public Constructor | ColumnInfo Constructor | Creates a new instance of the ColumnInfo class.
Top
Public Properties
 | Name | Description
Public Property | Columns | Gets the number of columns.
Public Property | ColumnSpacing | Gets the amount of space between columns.
Top
See Also

Reference

ColumnInfo Class
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ColumnInfo Constructor

ColumnInfo Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ColumnInfo Class : ColumnInfo Constructor
Number of columns.Number of columns.
Amount of space between columns.Amount of space between columns.
Creates a new instance of the ColumnInfo class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal columns As System.Integer, _
   ByVal columnSpacing As Length _
)
public ColumnInfo(
   System.int columns,
   Length columnSpacing
)

Parameters

columns
Number of columns.Number of columns.
columnSpacing
Amount of space between columns.Amount of space between columns.
See Also

Reference

ColumnInfo Class
ColumnInfo Members


ColumnInfo Class Properties

ColumnInfo Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ColumnInfo Class

For a list of all members of this type, see ColumnInfo members.

Public Properties
 | Name | Description
Public Property | Columns | Gets the number of columns.
Public Property | ColumnSpacing | Gets the amount of space between columns.
Top
See Also

Reference

ColumnInfo Class
GrapeCity.ActiveReports.Extensibility.Layout Namespace


Columns Property (ColumnInfo)

Columns Property (ColumnInfo)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ColumnInfo Class : Columns Property
Gets the number of columns.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Columns As System.Integer
public System.int Columns {get;}
See Also

Reference

ColumnInfo Class
ColumnInfo Members


ColumnSpacing Property (ColumnInfo)

ColumnSpacing Property (ColumnInfo)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ColumnInfo Class : ColumnSpacing Property
Gets the amount of space between columns.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ColumnSpacing As Length
public Length ColumnSpacing {get;}
See Also

Reference

ColumnInfo Class
ColumnInfo Members


ContentRange Class

ContentRange Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ContentRange Class
This is an abstract class that the ReportItem's layout manager creates, interprets and uses to denote a range with a logical beginning and end in its underlying content.
Object Model
ContentRange Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class ContentRange
   Implements IContentRange
public abstract class ContentRange : IContentRange
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Layout.ContentRange

See Also

Reference

ContentRange Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ContentRange Class Members

ContentRange Class Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ContentRange Class

The following tables list the members exposed by ContentRange.

Public Properties
 | Name | Description
Public Property | Owner | Specifies the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem represented by the current range.
Top
Public Methods
 | Name | Description
Public Method | CompareTo | Allows derived classes to provide an implementation for System.IComparable.
Top
See Also

Reference

ContentRange Class
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ContentRange Class Methods

ContentRange Class Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ContentRange Class

For a list of all members of this type, see ContentRange members.

Public Methods
 | Name | Description
Public Method | CompareTo | Allows derived classes to provide an implementation for System.IComparable.
Top
See Also

Reference

ContentRange Class
GrapeCity.ActiveReports.Extensibility.Layout Namespace


CompareTo Method (ContentRange)

CompareTo Method (ContentRange)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ContentRange Class : CompareTo Method
The System.Object to compare with the current instance.
Allows derived classes to provide an implementation for System.IComparable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Function CompareTo( _
   ByVal peer As System.Object _
) As System.Integer
public abstract System.int CompareTo(
   System.object peer
)

Parameters

peer
The System.Object to compare with the current instance.
See Also

Reference

ContentRange Class
ContentRange Members


ContentRange Class Properties

ContentRange Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ContentRange Class

For a list of all members of this type, see ContentRange members.

Public Properties
 | Name | Description
Public Property | Owner | Specifies the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem represented by the current range.
Top
See Also

Reference

ContentRange Class
GrapeCity.ActiveReports.Extensibility.Layout Namespace


Owner Property (ContentRange)

Owner Property (ContentRange)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ContentRange Class : Owner Property
Specifies the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem represented by the current range.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property Owner As IReportItem
public abstract IReportItem Owner {get;}
See Also

Reference

ContentRange Class
ContentRange Members


LayoutManagerAttribute Class

LayoutManagerAttribute Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutManagerAttribute Class
Specifies the class used to implement layout services for a component.
Object Model
LayoutManagerAttribute Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class LayoutManagerAttribute
   Inherits System.Attribute
public sealed class LayoutManagerAttribute : System.Attribute
Inheritance Hierarchy

System.Object
System.Attribute
GrapeCity.ActiveReports.Extensibility.Layout.LayoutManagerAttribute

See Also

Reference

LayoutManagerAttribute Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutManagerAttribute Class Members

LayoutManagerAttribute Class Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutManagerAttribute Class

The following tables list the members exposed by LayoutManagerAttribute.

Public Constructors
 | Name | Description
Public Constructor | LayoutManagerAttribute Constructor | Initializes a new instance of the LayoutManagerAttribute class.
Top
Public Properties
 | Name | Description
Public Property | LayoutManagerType | Returns the System.Type that provides rendering services for the component to which the attribute is bound.
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

LayoutManagerAttribute Class
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutManagerAttribute Constructor

LayoutManagerAttribute Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutManagerAttribute Class : LayoutManagerAttribute Constructor
The System.Type that provides rendering services for the component to which the attribute is bound.
Initializes a new instance of the LayoutManagerAttribute class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal layoutManagerType As System.Type _
)
public LayoutManagerAttribute(
   System.Type layoutManagerType
)

Parameters

layoutManagerType
The System.Type that provides rendering services for the component to which the attribute is bound.
See Also

Reference

LayoutManagerAttribute Class
LayoutManagerAttribute Members


LayoutManagerAttribute Class Properties

LayoutManagerAttribute Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutManagerAttribute Class

For a list of all members of this type, see LayoutManagerAttribute members.

Public Properties
 | Name | Description
Public Property | LayoutManagerType | Returns the System.Type that provides rendering services for the component to which the attribute is bound.
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

LayoutManagerAttribute Class
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutManagerType Property

LayoutManagerType Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutManagerAttribute Class : LayoutManagerType Property
Returns the System.Type that provides rendering services for the component to which the attribute is bound.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property LayoutManagerType As System.Type
public System.Type LayoutManagerType {get;}
See Also

Reference

LayoutManagerAttribute Class
LayoutManagerAttribute Members


SupportedPageInfo Class

SupportedPageInfo Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : SupportedPageInfo Class
Supported page information.
Object Model
SupportedPageInfo Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class SupportedPageInfo
public sealed class SupportedPageInfo
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Layout.SupportedPageInfo

See Also

Reference

SupportedPageInfo Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


SupportedPageInfo Class Members

SupportedPageInfo Class Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : SupportedPageInfo Class

The following tables list the members exposed by SupportedPageInfo.

Public Constructors
 | Name | Description
Public Constructor | SupportedPageInfo Constructor | Overloaded. Initializes a new instance of the SupportedPageInfo class.
Top
Public Properties
 | Name | Description
Public Property | BottomMargin | Specifies the bottom margin in twips.
Public Property | Height | Specifies the page height in twips.
Public Property | LeftMargin | Specifies the left margin in twips.
Public Property | RightMargin | Specifies the right margin in twips.
Public Property | TopMargin | Specifies the top margin in twips.
Public Property | Width | Specifies the page width in twips.
Top
Public Methods
 | Name | Description
Public Method | SetWidth | Sets the width of the page in twips.
Top
See Also

Reference

SupportedPageInfo Class
GrapeCity.ActiveReports.Extensibility.Layout Namespace


SupportedPageInfo Constructor

SupportedPageInfo Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > SupportedPageInfo Class : SupportedPageInfo Constructor
Initializes a new instance of the SupportedPageInfo class.
Overload List
Overload | Description
SupportedPageInfo Constructor(Int32,Int32) | Instantiates a new instance of the SupportedPageInfo class with the specified width and height.
SupportedPageInfo Constructor(Int32,Int32,Int32,Int32,Int32,Int32) | Instantiates a new instance of the SupportedPageInfo class with the specified width, height and margins.
See Also

Reference

SupportedPageInfo Class
SupportedPageInfo Members


SupportedPageInfo Constructor(Int32,Int32)

SupportedPageInfo Constructor(Int32,Int32)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > SupportedPageInfo Class > SupportedPageInfo Constructor : SupportedPageInfo Constructor(Int32,Int32)
The page width in twips.
The page height in twips.
Instantiates a new instance of the SupportedPageInfo class with the specified width and height.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal width As System.Integer, _
   ByVal height As System.Integer _
)
public SupportedPageInfo(
   System.int width,
   System.int height
)

Parameters

width
The page width in twips.
height
The page height in twips.
See Also

Reference

SupportedPageInfo Class
SupportedPageInfo Members
Overload List


SupportedPageInfo Constructor(Int32,Int32,Int32,Int32,Int32,Int32)

SupportedPageInfo Constructor(Int32,Int32,Int32,Int32,Int32,Int32)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > SupportedPageInfo Class > SupportedPageInfo Constructor : SupportedPageInfo Constructor(Int32,Int32,Int32,Int32,Int32,Int32)
The page width in twips.
The page height in twips.
The left margin in twips.
The top margin in twips.
The right margin in twips.
The bottom margin in twips.
Instantiates a new instance of the SupportedPageInfo class with the specified width, height and margins.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal width As System.Integer, _
   ByVal height As System.Integer, _
   ByVal leftMargin As System.Integer, _
   ByVal topMargin As System.Integer, _
   ByVal rightMargin As System.Integer, _
   ByVal bottomMargin As System.Integer _
)
public SupportedPageInfo(
   System.int width,
   System.int height,
   System.int leftMargin,
   System.int topMargin,
   System.int rightMargin,
   System.int bottomMargin
)

Parameters

width
The page width in twips.
height
The page height in twips.
leftMargin
The left margin in twips.
topMargin
The top margin in twips.
rightMargin
The right margin in twips.
bottomMargin
The bottom margin in twips.
See Also

Reference

SupportedPageInfo Class
SupportedPageInfo Members
Overload List


SupportedPageInfo Class Methods

SupportedPageInfo Class Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : SupportedPageInfo Class

For a list of all members of this type, see SupportedPageInfo members.

Public Methods
 | Name | Description
Public Method | SetWidth | Sets the width of the page in twips.
Top
See Also

Reference

SupportedPageInfo Class
GrapeCity.ActiveReports.Extensibility.Layout Namespace


SetWidth Method

SetWidth Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > SupportedPageInfo Class : SetWidth Method
An System.Int32 indicating the number of twips to which to set the page width.
Sets the width of the page in twips.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetWidth( _
   ByVal value As System.Integer _
)
public void SetWidth(
   System.int value
)

Parameters

value
An System.Int32 indicating the number of twips to which to set the page width.
See Also

Reference

SupportedPageInfo Class
SupportedPageInfo Members


SupportedPageInfo Class Properties

SupportedPageInfo Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : SupportedPageInfo Class

For a list of all members of this type, see SupportedPageInfo members.

Public Properties
 | Name | Description
Public Property | BottomMargin | Specifies the bottom margin in twips.
Public Property | Height | Specifies the page height in twips.
Public Property | LeftMargin | Specifies the left margin in twips.
Public Property | RightMargin | Specifies the right margin in twips.
Public Property | TopMargin | Specifies the top margin in twips.
Public Property | Width | Specifies the page width in twips.
Top
See Also

Reference

SupportedPageInfo Class
GrapeCity.ActiveReports.Extensibility.Layout Namespace


BottomMargin Property (SupportedPageInfo)

BottomMargin Property (SupportedPageInfo)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > SupportedPageInfo Class : BottomMargin Property
Specifies the bottom margin in twips.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property BottomMargin As System.Integer
public System.int BottomMargin {get;}
See Also

Reference

SupportedPageInfo Class
SupportedPageInfo Members


Height Property (SupportedPageInfo)

Height Property (SupportedPageInfo)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > SupportedPageInfo Class : Height Property
Specifies the page height in twips.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Height As System.Integer
public System.int Height {get;}
See Also

Reference

SupportedPageInfo Class
SupportedPageInfo Members


LeftMargin Property (SupportedPageInfo)

LeftMargin Property (SupportedPageInfo)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > SupportedPageInfo Class : LeftMargin Property
Specifies the left margin in twips.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property LeftMargin As System.Integer
public System.int LeftMargin {get;}
See Also

Reference

SupportedPageInfo Class
SupportedPageInfo Members


RightMargin Property (SupportedPageInfo)

RightMargin Property (SupportedPageInfo)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > SupportedPageInfo Class : RightMargin Property
Specifies the right margin in twips.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property RightMargin As System.Integer
public System.int RightMargin {get;}
See Also

Reference

SupportedPageInfo Class
SupportedPageInfo Members


TopMargin Property (SupportedPageInfo)

TopMargin Property (SupportedPageInfo)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > SupportedPageInfo Class : TopMargin Property
Specifies the top margin in twips.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TopMargin As System.Integer
public System.int TopMargin {get;}
See Also

Reference

SupportedPageInfo Class
SupportedPageInfo Members


Width Property (SupportedPageInfo)

Width Property (SupportedPageInfo)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > SupportedPageInfo Class : Width Property
Specifies the page width in twips.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Width As System.Integer
public System.int Width {get;}
See Also

Reference

SupportedPageInfo Class
SupportedPageInfo Members


Features Enumeration

Features Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : Features Enumeration
All of the features recognized by the layout engine. This enumeration is used with the DataDynamics.Reports.Extensibility.Layout.ITargetDevice.Item property to locate rendering device capabilities.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Features
   Inherits System.Enum
public enum Features : System.Enum
Members
Member | Description
FeatureColumns | Specifies whether the target device supports multi-column features.
FeatureFooter | Specifies whether the footer is generated.
FeatureHeader | Specifies whether the header is generated.
FeatureInteractiveSorting | Specifies whether the target device supports interactive sorting feature.
FeatureInteractivity | Specifies whether the target device supports interactivity features.
FeaturePagination | Specifies that a structure describing page size is supplied if the feature is supported.
FeatureResoluton | Specifies what resolution (dpi) is available for the target device. (The descriptor contains a single SizeF value corresponding to the horizontal and vertical resolutions respectively.)
TargetDevice | Defines output kinds which is used now by ITargetDevice
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Layout.Features

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Layout Namespace


HitTestResult Enumeration

HitTestResult Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : HitTestResult Enumeration
Specifes which area is hit. This enumeration is used with the DataDynamics.Reports.Extensibility.Layout.HitTestInfo.HitTestResult property to determine where a mouse click occurs.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum HitTestResult
   Inherits System.Enum
public enum HitTestResult : System.Enum
Members
Member | Description
InteractiveArea | Indicates that the mouse click region can accept events.
NonIteractiveArea | Indicates that mouse click region can not accept events.
NoWhere | Indicates that the mouse click is in a region beyond the area of the report.
TooltipArea | Indicates that mouse click tooltip area region.
TooltipInteractiveArea | Indicates that mouse click tooltip interactive area region.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Layout.HitTestResult

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutCapabilities Enumeration

LayoutCapabilities Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutCapabilities Enumeration
Specifies what layout options are available for the report item. This enumeration is used with the DataDynamics.Reports.Extensibility.Layout.ILayoutManager.Capabilities property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LayoutCapabilities
   Inherits System.Enum
public enum LayoutCapabilities : System.Enum
Members
Member | Description
CanGrowHorizontally | The report item can grow horizontally to fit the contents.
CanGrowVertically | The report item can grow vertically to fit the contents.
CanShrinkHorizontally | The report item can shrink horizontally to fit the contents.
CanShrinkVertically | The report item can shrink vertically to fit the contents.
CanSplitHorizontally | When the contents do not fit, the left portion of the report item can be rendered on the current page and the right portion on the following page. The default behavior is for the entire report item to move to the following page.
CanSplitVertically | When the contents do not fit, the top portion of the report item can be rendered on the current page and the bottom portion on the following page. The default behavior is for the entire report item to move to the following page.
None | The report item size remains fixed regardless of the contents.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Layout.LayoutCapabilities

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutDirection Enumeration

LayoutDirection Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutDirection Enumeration
Specifies the direction in which the layout runs on the current page. This enumeration is used with the DataDynamics.Reports.Extensibility.Layout.LayoutContext.LayoutDirection property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LayoutDirection
   Inherits System.Enum
public enum LayoutDirection : System.Enum
Members
Member | Description
Both | The layout runs from top to bottom and left to right.
Horizontal | The layout runs from left to right.
None | No direction is specified.
Vertical | The layout runs from top to bottom.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Layout.LayoutDirection

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutStatus Enumeration

LayoutStatus Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutStatus Enumeration
Indicates the progress of the layout operation. This enumeration is used with the DataDynamics.Reports.Extensibility.Layout.LayoutResult.LayoutStatus property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LayoutStatus
   Inherits System.Enum
public enum LayoutStatus : System.Enum
Members
Member | Description
Complete | Indicates that the item is laid out in its entirety.
ContinueHorizontally | Indicates that item continues layout in the next horizontal page.
ContinueVertically | Indicates that item continues layout in the next vertical page.
ForcedVerticalPageBreak | Indicates that a page break is produced after this layout operation.
NoContent | Indicates that no content is laid out.
None | Specifies an unknown status, with no layout operations performed. Please note that this is different from the NoContent status.
SomeContent | Indicates that some content is laid out, but that the layout is not complete and more layout runs are required for the item.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Layout.LayoutStatus

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Layout Namespace


SpanCellResolveMethod Enumeration

SpanCellResolveMethod Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : SpanCellResolveMethod Enumeration
Enum with kinds of method to indicate spanned cells
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum SpanCellResolveMethod
   Inherits System.Enum
public enum SpanCellResolveMethod : System.Enum
Members
Member | Description
DuplicateCell | Duplicate cell.
NullCell | Null cell.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Layout.SpanCellResolveMethod

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Layout Namespace


CellSpan Structure

CellSpan Structure
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : CellSpan Structure
Encapsulates information about cell column/row spans.
Object Model
CellSpan Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure CellSpan
   Inherits System.ValueType
public struct CellSpan : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Layout.CellSpan

See Also

Reference

CellSpan Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


CellSpan Structure Members

CellSpan Structure Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : CellSpan Structure

The following tables list the members exposed by CellSpan.

Public Constructors
 | Name | Description
Public Constructor | CellSpan Constructor | Allows initializaiton using specified start position and a span in corresponding dimension.
Top
Public Properties
 | Name | Description
Public Property | End | Specifies the last element in the span.
Public Property | Span | Specifies the span
Public Property | Start | Specifies the first element in the span.
Top
See Also

Reference

CellSpan Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


CellSpan Constructor

CellSpan Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > CellSpan Structure : CellSpan Constructor
The start of the span.
The length of the span.
Allows initializaiton using specified start position and a span in corresponding dimension.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal start As System.Integer, _
   ByVal span As System.Integer _
)
public CellSpan(
   System.int start,
   System.int span
)

Parameters

start
The start of the span.
span
The length of the span.
See Also

Reference

CellSpan Structure
CellSpan Members


CellSpan Structure Properties

CellSpan Structure Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : CellSpan Structure

For a list of all members of this type, see CellSpan members.

Public Properties
 | Name | Description
Public Property | End | Specifies the last element in the span.
Public Property | Span | Specifies the span
Public Property | Start | Specifies the first element in the span.
Top
See Also

Reference

CellSpan Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


End Property (CellSpan)

End Property (CellSpan)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > CellSpan Structure : End Property
Specifies the last element in the span.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property End As System.Integer
public System.int End {get;}
See Also

Reference

CellSpan Structure
CellSpan Members


Span Property

Span Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > CellSpan Structure : Span Property
Specifies the span
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Span As System.Integer
public System.int Span {get;}
See Also

Reference

CellSpan Structure
CellSpan Members


Start Property (CellSpan)

Start Property (CellSpan)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > CellSpan Structure : Start Property
Specifies the first element in the span.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Start As System.Integer
public System.int Start {get;}
See Also

Reference

CellSpan Structure
CellSpan Members


DeviceCapabilities Structure

DeviceCapabilities Structure
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : DeviceCapabilities Structure
Describes the target rendering device capabilities for a specific set of features.
Object Model
DeviceCapabilities Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure DeviceCapabilities
   Inherits System.ValueType
public struct DeviceCapabilities : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Layout.DeviceCapabilities

See Also

Reference

DeviceCapabilities Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


DeviceCapabilities Structure Members

DeviceCapabilities Structure Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : DeviceCapabilities Structure

The following tables list the members exposed by DeviceCapabilities.

Public Constructors
 | Name | Description
Public Constructor | DeviceCapabilities Constructor | Initializes a new instance of the DeviceCapabilities structure.
Top
Public Properties
 | Name | Description
Public Property | Descriptor | The value of this property depends on the type of features in the set. It can include an array of supported fonts, mapper objects, etc.
Public Property | Supported | This Boolean property returns true if the features set is supported by the target device.
Top
See Also

Reference

DeviceCapabilities Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


DeviceCapabilities Constructor

DeviceCapabilities Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > DeviceCapabilities Structure : DeviceCapabilities Constructor
True if the specified feature map is supported.
An object containing a feature or an array of features.
Initializes a new instance of the DeviceCapabilities structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal supported As System.Boolean, _
   ByVal supportedFeatureMap As System.Object _
)
public DeviceCapabilities(
   System.bool supported,
   System.object supportedFeatureMap
)

Parameters

supported
True if the specified feature map is supported.
supportedFeatureMap
An object containing a feature or an array of features.
See Also

Reference

DeviceCapabilities Structure
DeviceCapabilities Members


DeviceCapabilities Structure Properties

DeviceCapabilities Structure Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : DeviceCapabilities Structure

For a list of all members of this type, see DeviceCapabilities members.

Public Properties
 | Name | Description
Public Property | Descriptor | The value of this property depends on the type of features in the set. It can include an array of supported fonts, mapper objects, etc.
Public Property | Supported | This Boolean property returns true if the features set is supported by the target device.
Top
See Also

Reference

DeviceCapabilities Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


Descriptor Property

Descriptor Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > DeviceCapabilities Structure : Descriptor Property
The value of this property depends on the type of features in the set. It can include an array of supported fonts, mapper objects, etc.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Descriptor As System.Object
public System.object Descriptor {get;}
See Also

Reference

DeviceCapabilities Structure
DeviceCapabilities Members


Supported Property

Supported Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > DeviceCapabilities Structure : Supported Property
This Boolean property returns true if the features set is supported by the target device.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Supported As System.Boolean
public System.bool Supported {get;}
See Also

Reference

DeviceCapabilities Structure
DeviceCapabilities Members


HitTestInfo Structure

HitTestInfo Structure
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : HitTestInfo Structure
Contains information about the part of the layout area in which a mouse click occurs.
Object Model
HitTestInfo Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure HitTestInfo
   Inherits System.ValueType
public struct HitTestInfo : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Layout.HitTestInfo

See Also

Reference

HitTestInfo Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


HitTestInfo Structure Members

HitTestInfo Structure Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : HitTestInfo Structure

The following tables list the members exposed by HitTestInfo.

Public Constructors
 | Name | Description
Public Constructor | HitTestInfo Constructor | Initializes a new instance of the HitTestInfo structure at the area underlying a mouse click.
Top
Public Properties
 | Name | Description
Public Property | AcceptsEvents | Specifies whether the area in which the mouse click occurs can accept user events.
Public Property | Data | Hit test info data.
Public Property | HitTestResult | Specifies an enumerated DataDynamics.Reports.Extensibility.Layout.HitTestResult value indicating whether the mouse click is in an interactive area.
Public Property | InteractiveAreaId | Specifies the System.String value containing an ID assigned to the area in which the mouse click occurs, if any.
Public Property | IsInArea | Specifies whether the area in which the mouse click occurs is within the area defined by the DataDynamics.Reports.Extensibility.Layout.ILayoutArea interface.
Public Property | ReportItem | Specifies the DataDynamics.Reports.Extensibility.Rendering.Components.IReportItem, if any, associated with the area in which the mouse click occurs.
Top
See Also

Reference

HitTestInfo Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


HitTestInfo Constructor

HitTestInfo Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > HitTestInfo Structure : HitTestInfo Constructor
An enumerated DataDynamics.Reports.Extensibility.Layout.HitTestResult value indicating whether the mouse click is in an interactive area.
An DataDynamics.Reports.Extensibility.Layout.ILayoutArea interface defining the area on which the hit test is performed.
A System.String value indicating the ID assigned to the area.
Initializes a new instance of the HitTestInfo structure at the area underlying a mouse click.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal result As HitTestResult, _
   ByVal underlyingArea As ILayoutArea, _
   ByVal interactiveAreaID As System.String, _
   ByVal data As System.String _
)
public HitTestInfo(
   HitTestResult result,
   ILayoutArea underlyingArea,
   System.string interactiveAreaID,
   System.string data
)

Parameters

result
An enumerated DataDynamics.Reports.Extensibility.Layout.HitTestResult value indicating whether the mouse click is in an interactive area.
underlyingArea
An DataDynamics.Reports.Extensibility.Layout.ILayoutArea interface defining the area on which the hit test is performed.
interactiveAreaID
A System.String value indicating the ID assigned to the area.
data
See Also

Reference

HitTestInfo Structure
HitTestInfo Members


HitTestInfo Structure Properties

HitTestInfo Structure Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : HitTestInfo Structure

For a list of all members of this type, see HitTestInfo members.

Public Properties
 | Name | Description
Public Property | AcceptsEvents | Specifies whether the area in which the mouse click occurs can accept user events.
Public Property | Data | Hit test info data.
Public Property | HitTestResult | Specifies an enumerated DataDynamics.Reports.Extensibility.Layout.HitTestResult value indicating whether the mouse click is in an interactive area.
Public Property | InteractiveAreaId | Specifies the System.String value containing an ID assigned to the area in which the mouse click occurs, if any.
Public Property | IsInArea | Specifies whether the area in which the mouse click occurs is within the area defined by the DataDynamics.Reports.Extensibility.Layout.ILayoutArea interface.
Public Property | ReportItem | Specifies the DataDynamics.Reports.Extensibility.Rendering.Components.IReportItem, if any, associated with the area in which the mouse click occurs.
Top
See Also

Reference

HitTestInfo Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


AcceptsEvents Property

AcceptsEvents Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > HitTestInfo Structure : AcceptsEvents Property
Specifies whether the area in which the mouse click occurs can accept user events.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property AcceptsEvents As System.Boolean
public System.bool AcceptsEvents {get;}
See Also

Reference

HitTestInfo Structure
HitTestInfo Members


Data Property (HitTestInfo)

Data Property (HitTestInfo)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > HitTestInfo Structure : Data Property
Hit test info data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Data As System.String
public System.string Data {get;}
See Also

Reference

HitTestInfo Structure
HitTestInfo Members


HitTestResult Property

HitTestResult Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > HitTestInfo Structure : HitTestResult Property
Specifies an enumerated DataDynamics.Reports.Extensibility.Layout.HitTestResult value indicating whether the mouse click is in an interactive area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HitTestResult As HitTestResult
public HitTestResult HitTestResult {get;}
See Also

Reference

HitTestInfo Structure
HitTestInfo Members


InteractiveAreaId Property

InteractiveAreaId Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > HitTestInfo Structure : InteractiveAreaId Property
Specifies the System.String value containing an ID assigned to the area in which the mouse click occurs, if any.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InteractiveAreaId As System.String
public System.string InteractiveAreaId {get;}
See Also

Reference

HitTestInfo Structure
HitTestInfo Members


IsInArea Property

IsInArea Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > HitTestInfo Structure : IsInArea Property
Specifies whether the area in which the mouse click occurs is within the area defined by the DataDynamics.Reports.Extensibility.Layout.ILayoutArea interface.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsInArea As System.Boolean
public System.bool IsInArea {get;}
See Also

Reference

HitTestInfo Structure
HitTestInfo Members


ReportItem Property (HitTestInfo)

ReportItem Property (HitTestInfo)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > HitTestInfo Structure : ReportItem Property
Specifies the DataDynamics.Reports.Extensibility.Rendering.Components.IReportItem, if any, associated with the area in which the mouse click occurs.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ReportItem As IReportItem
public IReportItem ReportItem {get;}
See Also

Reference

HitTestInfo Structure
HitTestInfo Members


LayoutContext Structure

LayoutContext Structure
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutContext Structure
Encapsulates information about layout operations for the report item to provide input for the DataDynamics.Reports.Extensibility.Layout.ILayoutManager interface.
Object Model
LayoutContext Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure LayoutContext
   Inherits System.ValueType
public struct LayoutContext : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Layout.LayoutContext

See Also

Reference

LayoutContext Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutContext Structure Members

LayoutContext Structure Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutContext Structure

The following tables list the members exposed by LayoutContext.

Public Constructors
 | Name | Description
Public Constructor | LayoutContext Constructor | Initializes a new instance of the LayoutContext structure with the specified values.
Top
Public Properties
 | Name | Description
Public Property | AvailableSize | Indicates the maximum size that the report item can occupy in the current operation.
Public Property | ContentRange | Specifies the logical end of the DataDynamics.Reports.Extensibility.Layout.ContentRange object to pick up where a prior layout operation left off.
Public Property | HorizontalLayout | Specifies whether the context is for a horizontal layout run.
Public Property | LayoutDirection | Indicates whether the current page layout runs horizontally, vertically, neither, or both.
Public Property | VerticalLayout | Specifies whether the context is for a vertical layout run.
Top
Public Methods
 | Name | Description
Public Method | AdjustFromResult | Returns a new LayoutContext corresponding to the specified LayoutResult.
Public Method | SetAvailableSize | Creates a copy of the LayoutContext with the specified available size.
Top
See Also

Reference

LayoutContext Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutContext Constructor

LayoutContext Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutContext Structure : LayoutContext Constructor
A DataDynamics.Reports.Extensibility.Layout.ContentRange object containing information about the range of the underlying content to include in the current layout operation.
An enumerated DataDynamics.Reports.Extensibility.Layout.LayoutDirection value indicating the direction in which the layout for the report item runs.
A System.Drawing.SizeF structure containing the width and height of the rectangle within which the report item is laid out.
Initializes a new instance of the LayoutContext structure with the specified values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal contentRange As IContentRange, _
   ByVal direction As LayoutDirection, _
   ByVal availableSize As SizeFEx _
)
public LayoutContext(
   IContentRange contentRange,
   LayoutDirection direction,
   SizeFEx availableSize
)

Parameters

contentRange
A DataDynamics.Reports.Extensibility.Layout.ContentRange object containing information about the range of the underlying content to include in the current layout operation.
direction
An enumerated DataDynamics.Reports.Extensibility.Layout.LayoutDirection value indicating the direction in which the layout for the report item runs.
availableSize
A System.Drawing.SizeF structure containing the width and height of the rectangle within which the report item is laid out.
See Also

Reference

LayoutContext Structure
LayoutContext Members


LayoutContext Structure Methods

LayoutContext Structure Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutContext Structure

For a list of all members of this type, see LayoutContext members.

Public Methods
 | Name | Description
Public Method | AdjustFromResult | Returns a new LayoutContext corresponding to the specified LayoutResult.
Public Method | SetAvailableSize | Creates a copy of the LayoutContext with the specified available size.
Top
See Also

Reference

LayoutContext Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


AdjustFromResult Method

AdjustFromResult Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutContext Structure : AdjustFromResult Method
A LayoutResult object containing the output of the ILayoutManager interface.
Returns a new LayoutContext corresponding to the specified LayoutResult.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function AdjustFromResult( _
   ByVal result As LayoutResult _
) As LayoutContext
public LayoutContext AdjustFromResult(
   LayoutResult result
)

Parameters

result
A LayoutResult object containing the output of the ILayoutManager interface.
See Also

Reference

LayoutContext Structure
LayoutContext Members


SetAvailableSize Method

SetAvailableSize Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutContext Structure : SetAvailableSize Method
A System.Drawing.SizeF structure containing the width and height of the rectangle within which the report item is laid out.
Creates a copy of the LayoutContext with the specified available size.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function SetAvailableSize( _
   ByVal availableSize As SizeFEx _
) As LayoutContext
public LayoutContext SetAvailableSize(
   SizeFEx availableSize
)

Parameters

availableSize
A System.Drawing.SizeF structure containing the width and height of the rectangle within which the report item is laid out.
See Also

Reference

LayoutContext Structure
LayoutContext Members


LayoutContext Structure Properties

LayoutContext Structure Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutContext Structure

For a list of all members of this type, see LayoutContext members.

Public Properties
 | Name | Description
Public Property | AvailableSize | Indicates the maximum size that the report item can occupy in the current operation.
Public Property | ContentRange | Specifies the logical end of the DataDynamics.Reports.Extensibility.Layout.ContentRange object to pick up where a prior layout operation left off.
Public Property | HorizontalLayout | Specifies whether the context is for a horizontal layout run.
Public Property | LayoutDirection | Indicates whether the current page layout runs horizontally, vertically, neither, or both.
Public Property | VerticalLayout | Specifies whether the context is for a vertical layout run.
Top
See Also

Reference

LayoutContext Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


AvailableSize Property

AvailableSize Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutContext Structure : AvailableSize Property
Indicates the maximum size that the report item can occupy in the current operation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property AvailableSize As SizeFEx
public SizeFEx AvailableSize {get;}

Property Value

A System.Drawing.SizeF structure containing the width and height of the rectangle within which the report item is laid out.
Remarks
The width and height are in twips.
See Also

Reference

LayoutContext Structure
LayoutContext Members


ContentRange Property (LayoutContext)

ContentRange Property (LayoutContext)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutContext Structure : ContentRange Property
Specifies the logical end of the DataDynamics.Reports.Extensibility.Layout.ContentRange object to pick up where a prior layout operation left off.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ContentRange As IContentRange
public IContentRange ContentRange {get;}
See Also

Reference

LayoutContext Structure
LayoutContext Members


HorizontalLayout Property

HorizontalLayout Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutContext Structure : HorizontalLayout Property
Specifies whether the context is for a horizontal layout run.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HorizontalLayout As System.Boolean
public System.bool HorizontalLayout {get;}
See Also

Reference

LayoutContext Structure
LayoutContext Members


LayoutDirection Property (LayoutContext)

LayoutDirection Property (LayoutContext)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutContext Structure : LayoutDirection Property
Indicates whether the current page layout runs horizontally, vertically, neither, or both.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property LayoutDirection As LayoutDirection
public LayoutDirection LayoutDirection {get;}

Property Value

An enumerated DataDynamics.Reports.Extensibility.Layout.LayoutDirection value.
See Also

Reference

LayoutContext Structure
LayoutContext Members


VerticalLayout Property

VerticalLayout Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutContext Structure : VerticalLayout Property
Specifies whether the context is for a vertical layout run.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property VerticalLayout As System.Boolean
public System.bool VerticalLayout {get;}
See Also

Reference

LayoutContext Structure
LayoutContext Members


LayoutInfo Structure

LayoutInfo Structure
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutInfo Structure
Defines target device and other layout operation properties.
Object Model
LayoutInfo Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure LayoutInfo
   Inherits System.ValueType
public struct LayoutInfo : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Layout.LayoutInfo

See Also

Reference

LayoutInfo Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutInfo Structure Members

LayoutInfo Structure Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutInfo Structure

The following tables list the members exposed by LayoutInfo.

Public Constructors
 | Name | Description
Public Constructor | LayoutInfo Constructor | Initializes the new instance of LayoutInfo class.
Top
Public Properties
 | Name | Description
Public Property | NotificationCallback | Specifies optional LayoutNotificationCallback that layout engine will call after completing laying out each page.
Public Property | Report | Specifes Report instance for which layout tree will be generated.
Public Property | TargetDevice | Specifes target device for this LayoutContext.
Top
See Also

Reference

LayoutInfo Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutInfo Constructor(IReport,ITargetDevice)

LayoutInfo Constructor(IReport,ITargetDevice)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutInfo Structure > LayoutInfo Constructor : LayoutInfo Constructor(IReport,ITargetDevice)
Specifes Report instance for which layout tree will be generated.
Specifes target device for the layout.
Initializes the new instance of LayoutInfo class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal report As IReport, _
   ByVal targetDevice As ITargetDevice _
)
public LayoutInfo(
   IReport report,
   ITargetDevice targetDevice
)

Parameters

report
Specifes Report instance for which layout tree will be generated.
targetDevice
Specifes target device for the layout.
See Also

Reference

LayoutInfo Structure
LayoutInfo Members
Overload List


LayoutInfo Structure Properties

LayoutInfo Structure Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutInfo Structure

For a list of all members of this type, see LayoutInfo members.

Public Properties
 | Name | Description
Public Property | NotificationCallback | Specifies optional LayoutNotificationCallback that layout engine will call after completing laying out each page.
Public Property | Report | Specifes Report instance for which layout tree will be generated.
Public Property | TargetDevice | Specifes target device for this LayoutContext.
Top
See Also

Reference

LayoutInfo Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


NotificationCallback Property

NotificationCallback Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutInfo Structure : NotificationCallback Property
Specifies optional LayoutNotificationCallback that layout engine will call after completing laying out each page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NotificationCallback As LayoutNotificationCallback
public LayoutNotificationCallback NotificationCallback {get; set;}
See Also

Reference

LayoutInfo Structure
LayoutInfo Members


Report Property (LayoutInfo)

Report Property (LayoutInfo)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutInfo Structure : Report Property
Specifes Report instance for which layout tree will be generated.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Report As IReport
public IReport Report {get; set;}
See Also

Reference

LayoutInfo Structure
LayoutInfo Members


TargetDevice Property (LayoutInfo)

TargetDevice Property (LayoutInfo)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutInfo Structure : TargetDevice Property
Specifes target device for this LayoutContext.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TargetDevice As ITargetDevice
public ITargetDevice TargetDevice {get; set;}
See Also

Reference

LayoutInfo Structure
LayoutInfo Members


LayoutResult Structure

LayoutResult Structure
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutResult Structure
Encapsulates the output of layout manager operations.
Object Model
LayoutResult Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure LayoutResult
   Inherits System.ValueType
public struct LayoutResult : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Layout.LayoutResult

See Also

Reference

LayoutResult Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutResult Structure Members

LayoutResult Structure Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutResult Structure

The following tables list the members exposed by LayoutResult.

Public Constructors
 | Name | Description
Public Constructor | LayoutResult Constructor | Overloaded. Initializes LayoutResult with specified values
Top
Public Properties
 | Name | Description
Public Property | ActualSize | Indicates the actual size that layout area, produced by layout manager, will occupy.
Public Property | Complete | Specifies that this layout was complete.
Public Property | ContentRange | Specifies the content that will need to be laid out.
Public Property | ContinueHorizontally | Specifies that layout operation indicated that next run should be in horizontal direction.
Public Property | ContinueVertically | Specifies that layout operation indicated that next run should be in vertical direction.
Public Property | ForcedVerticalBreak | Specifies that layout encountered a hard page break.
Public Property | HasContent | Specifies that layout operation generated some content.
Public Property | ImpliedVerticalBreak | Specifies that content flow should continue on next vertical page to keep content together.
Public Property | IsEmpty | Specifies that layout operation didn't produce any content at all and no other status was supplied.
Public Property | LayoutArea | Returns the T:ILayoutArea.
Public Property | LayoutStatus | Specifies the outcome of layout operation.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | CompleteResult | Indicates a complete layout operation
static (Shared in Visual Basic) | EmptyResult | Overloaded. Overloaded.
Public Method | SetLayoutStatus | Sets the layout status.
Public Method | SetRange | Returns a new result with the specified range.
Top
See Also

Reference

LayoutResult Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutResult Constructor

LayoutResult Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : LayoutResult Constructor
Initializes LayoutResult with specified values
Overload List
Overload | Description
LayoutResult Constructor(IContentRange,LayoutStatus,SizeFEx) |
LayoutResult Constructor(ILayoutArea,IContentRange,LayoutStatus,SizeFEx) |
See Also

Reference

LayoutResult Structure
LayoutResult Members


LayoutResult Constructor(IContentRange,LayoutStatus,SizeFEx)

LayoutResult Constructor(IContentRange,LayoutStatus,SizeFEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure > LayoutResult Constructor : LayoutResult Constructor(IContentRange,LayoutStatus,SizeFEx)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal contentRange As IContentRange, _
   ByVal layoutStatus As LayoutStatus, _
   ByVal actualSize As SizeFEx _
)
public LayoutResult(
   IContentRange contentRange,
   LayoutStatus layoutStatus,
   SizeFEx actualSize
)

Parameters

contentRange
layoutStatus
actualSize
See Also

Reference

LayoutResult Structure
LayoutResult Members
Overload List


LayoutResult Constructor(ILayoutArea,IContentRange,LayoutStatus,SizeFEx)

LayoutResult Constructor(ILayoutArea,IContentRange,LayoutStatus,SizeFEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure > LayoutResult Constructor : LayoutResult Constructor(ILayoutArea,IContentRange,LayoutStatus,SizeFEx)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal area As ILayoutArea, _
   ByVal contentRange As IContentRange, _
   ByVal layoutStatus As LayoutStatus, _
   ByVal actualSize As SizeFEx _
)
public LayoutResult(
   ILayoutArea area,
   IContentRange contentRange,
   LayoutStatus layoutStatus,
   SizeFEx actualSize
)

Parameters

area
contentRange
layoutStatus
actualSize
See Also

Reference

LayoutResult Structure
LayoutResult Members
Overload List


LayoutResult Structure Methods

LayoutResult Structure Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutResult Structure

For a list of all members of this type, see LayoutResult members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CompleteResult | Indicates a complete layout operation
static (Shared in Visual Basic) | EmptyResult | Overloaded. Overloaded.
Public Method | SetLayoutStatus | Sets the layout status.
Public Method | SetRange | Returns a new result with the specified range.
Top
See Also

Reference

LayoutResult Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


CompleteResult Method

CompleteResult Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : CompleteResult Method
Indicates a complete layout operation
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function CompleteResult() As LayoutResult
public static LayoutResult CompleteResult()
See Also

Reference

LayoutResult Structure
LayoutResult Members


EmptyResult Method

EmptyResult Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : EmptyResult Method
Overloaded.
Overload List
Overload | Description
EmptyResult() | Indicates layout operation without any content laid out.
EmptyResult(SizeFEx) | Indicates layout operation without any content laid out and specifies the minimum SizeF required to accommodate the content.
See Also

Reference

LayoutResult Structure
LayoutResult Members


EmptyResult() Method

EmptyResult() Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure > EmptyResult Method : EmptyResult() Method
Indicates layout operation without any content laid out.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function EmptyResult() As LayoutResult
public static LayoutResult EmptyResult()
See Also

Reference

LayoutResult Structure
LayoutResult Members
Overload List


EmptyResult(SizeFEx) Method

EmptyResult(SizeFEx) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure > EmptyResult Method : EmptyResult(SizeFEx) Method
Indicates the actual size that layout area, produced by layout manager, will occupy.
Indicates layout operation without any content laid out and specifies the minimum SizeF required to accommodate the content.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function EmptyResult( _
   ByVal actualSize As SizeFEx _
) As LayoutResult
public static LayoutResult EmptyResult(
   SizeFEx actualSize
)

Parameters

actualSize
Indicates the actual size that layout area, produced by layout manager, will occupy.
See Also

Reference

LayoutResult Structure
LayoutResult Members
Overload List


SetLayoutStatus Method

SetLayoutStatus Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : SetLayoutStatus Method
The layoutstatus to set.
Sets the layout status.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetLayoutStatus( _
   ByVal value As LayoutStatus _
)
public void SetLayoutStatus(
   LayoutStatus value
)

Parameters

value
The layoutstatus to set.
See Also

Reference

LayoutResult Structure
LayoutResult Members


SetRange Method

SetRange Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : SetRange Method
The content range of the layout result.
Returns a new result with the specified range.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function SetRange( _
   ByVal range As ContentRange _
) As LayoutResult
public LayoutResult SetRange(
   ContentRange range
)

Parameters

range
The content range of the layout result.
See Also

Reference

LayoutResult Structure
LayoutResult Members


LayoutResult Structure Properties

LayoutResult Structure Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutResult Structure

For a list of all members of this type, see LayoutResult members.

Public Properties
 | Name | Description
Public Property | ActualSize | Indicates the actual size that layout area, produced by layout manager, will occupy.
Public Property | Complete | Specifies that this layout was complete.
Public Property | ContentRange | Specifies the content that will need to be laid out.
Public Property | ContinueHorizontally | Specifies that layout operation indicated that next run should be in horizontal direction.
Public Property | ContinueVertically | Specifies that layout operation indicated that next run should be in vertical direction.
Public Property | ForcedVerticalBreak | Specifies that layout encountered a hard page break.
Public Property | HasContent | Specifies that layout operation generated some content.
Public Property | ImpliedVerticalBreak | Specifies that content flow should continue on next vertical page to keep content together.
Public Property | IsEmpty | Specifies that layout operation didn't produce any content at all and no other status was supplied.
Public Property | LayoutArea | Returns the T:ILayoutArea.
Public Property | LayoutStatus | Specifies the outcome of layout operation.
Top
See Also

Reference

LayoutResult Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ActualSize Property

ActualSize Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : ActualSize Property
Indicates the actual size that layout area, produced by layout manager, will occupy.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ActualSize As SizeFEx
public SizeFEx ActualSize {get;}
Remarks
Width and height are in twips.
See Also

Reference

LayoutResult Structure
LayoutResult Members


Complete Property

Complete Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : Complete Property
Specifies that this layout was complete.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Complete As System.Boolean
public System.bool Complete {get;}
See Also

Reference

LayoutResult Structure
LayoutResult Members


ContentRange Property (LayoutResult)

ContentRange Property (LayoutResult)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : ContentRange Property
Specifies the content that will need to be laid out.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ContentRange As IContentRange
public IContentRange ContentRange {get;}
See Also

Reference

LayoutResult Structure
LayoutResult Members


ContinueHorizontally Property

ContinueHorizontally Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : ContinueHorizontally Property
Specifies that layout operation indicated that next run should be in horizontal direction.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ContinueHorizontally As System.Boolean
public System.bool ContinueHorizontally {get; set;}
See Also

Reference

LayoutResult Structure
LayoutResult Members


ContinueVertically Property

ContinueVertically Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : ContinueVertically Property
Specifies that layout operation indicated that next run should be in vertical direction.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ContinueVertically As System.Boolean
public System.bool ContinueVertically {get; set;}
See Also

Reference

LayoutResult Structure
LayoutResult Members


ForcedVerticalBreak Property

ForcedVerticalBreak Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : ForcedVerticalBreak Property
Specifies that layout encountered a hard page break.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ForcedVerticalBreak As System.Boolean
public System.bool ForcedVerticalBreak {get;}
See Also

Reference

LayoutResult Structure
LayoutResult Members


HasContent Property

HasContent Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : HasContent Property
Specifies that layout operation generated some content.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HasContent As System.Boolean
public System.bool HasContent {get;}
See Also

Reference

LayoutResult Structure
LayoutResult Members


ImpliedVerticalBreak Property

ImpliedVerticalBreak Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : ImpliedVerticalBreak Property
Specifies that content flow should continue on next vertical page to keep content together.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ImpliedVerticalBreak As System.Boolean
public System.bool ImpliedVerticalBreak {get;}
See Also

Reference

LayoutResult Structure
LayoutResult Members


IsEmpty Property (LayoutResult)

IsEmpty Property (LayoutResult)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : IsEmpty Property
Specifies that layout operation didn't produce any content at all and no other status was supplied.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsEmpty As System.Boolean
public System.bool IsEmpty {get;}
See Also

Reference

LayoutResult Structure
LayoutResult Members


LayoutArea Property (LayoutResult)

LayoutArea Property (LayoutResult)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : LayoutArea Property
Returns the T:ILayoutArea.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property LayoutArea As ILayoutArea
public ILayoutArea LayoutArea {get;}
See Also

Reference

LayoutResult Structure
LayoutResult Members


LayoutStatus Property

LayoutStatus Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutResult Structure : LayoutStatus Property
Specifies the outcome of layout operation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property LayoutStatus As LayoutStatus
public LayoutStatus LayoutStatus {get;}
See Also

Reference

LayoutResult Structure
LayoutResult Members


LayoutState Structure

LayoutState Structure
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutState Structure
Encapsulates intermediate result (current state) of layout operation.
Object Model
LayoutState Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure LayoutState
   Inherits System.ValueType
public struct LayoutState : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Layout.LayoutState

See Also

Reference

LayoutState Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutState Structure Members

LayoutState Structure Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutState Structure

The following tables list the members exposed by LayoutState.

Public Constructors
 | Name | Description
Public Constructor | LayoutState Constructor | Creates a new instance of LayoutState and initializes it with specified value.
Top
Public Properties
 | Name | Description
Public Property | LastPage | Specifies last page laid out by the engine for this LayoutTree.
Public Property | LayoutTree | Specifies LayoutTree being built by the layout engine.
Public Property | TargetDevice | Specifes target device for current layout operation.
Top
See Also

Reference

LayoutState Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LayoutState Constructor

LayoutState Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutState Structure : LayoutState Constructor
Specifies the LayoutTree being built by the layout engine.
Specifes target device for current layout operation.
Specifies last page laid out by the engine for this LayoutTree.
Creates a new instance of LayoutState and initializes it with specified value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal layoutTree As ILayoutTree, _
   ByVal targetDevice As ITargetDevice, _
   ByVal lastPageLaidOut As System.Integer _
)
public LayoutState(
   ILayoutTree layoutTree,
   ITargetDevice targetDevice,
   System.int lastPageLaidOut
)

Parameters

layoutTree
Specifies the LayoutTree being built by the layout engine.
targetDevice
Specifes target device for current layout operation.
lastPageLaidOut
Specifies last page laid out by the engine for this LayoutTree.
See Also

Reference

LayoutState Structure
LayoutState Members


LayoutState Structure Properties

LayoutState Structure Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutState Structure

For a list of all members of this type, see LayoutState members.

Public Properties
 | Name | Description
Public Property | LastPage | Specifies last page laid out by the engine for this LayoutTree.
Public Property | LayoutTree | Specifies LayoutTree being built by the layout engine.
Public Property | TargetDevice | Specifes target device for current layout operation.
Top
See Also

Reference

LayoutState Structure
GrapeCity.ActiveReports.Extensibility.Layout Namespace


LastPage Property

LastPage Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutState Structure : LastPage Property
Specifies last page laid out by the engine for this LayoutTree.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property LastPage As System.Integer
public System.int LastPage {get;}
See Also

Reference

LayoutState Structure
LayoutState Members


LayoutTree Property

LayoutTree Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutState Structure : LayoutTree Property
Specifies LayoutTree being built by the layout engine.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property LayoutTree As ILayoutTree
public ILayoutTree LayoutTree {get;}
See Also

Reference

LayoutState Structure
LayoutState Members


TargetDevice Property (LayoutState)

TargetDevice Property (LayoutState)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutState Structure : TargetDevice Property
Specifes target device for current layout operation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetDevice As ITargetDevice
public ITargetDevice TargetDevice {get;}
See Also

Reference

LayoutState Structure
LayoutState Members


IBorders Interface

IBorders Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IBorders Interface
Represents visual styles for all borders.
Object Model
IBorders Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IBorders
public interface IBorders
See Also

Reference

IBorders Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IBorders Interface Members

IBorders Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IBorders Interface

The following tables list the members exposed by IBorders.

Public Properties
 | Name | Description
Property | BottomBorderColor | The color of the bottom border.
Property | BottomBorderStyle | The style of the bottom border.
Property | BottomBorderWidth | The width of the bottom border.
Property | LeftBorderColor | The color of the left border.
Property | LeftBorderStyle | The style of the left border.
Property | LeftBorderWidth | The width of the left border.
Property | RightBorderColor | The color of the right border.
Property | RightBorderStyle | The style of the right border.
Property | RightBorderWidth | The width of the right border.
Property | TopBorderColor | The color of the top border.
Property | TopBorderStyle | The style of the top border.
Property | TopBorderWidth | The width of the top border.
Top
See Also

Reference

IBorders Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IBorders Interface Properties

IBorders Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IBorders Interface

For a list of all members of this type, see IBorders members.

Public Properties
 | Name | Description
Property | BottomBorderColor | The color of the bottom border.
Property | BottomBorderStyle | The style of the bottom border.
Property | BottomBorderWidth | The width of the bottom border.
Property | LeftBorderColor | The color of the left border.
Property | LeftBorderStyle | The style of the left border.
Property | LeftBorderWidth | The width of the left border.
Property | RightBorderColor | The color of the right border.
Property | RightBorderStyle | The style of the right border.
Property | RightBorderWidth | The width of the right border.
Property | TopBorderColor | The color of the top border.
Property | TopBorderStyle | The style of the top border.
Property | TopBorderWidth | The width of the top border.
Top
See Also

Reference

IBorders Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


BottomBorderColor Property (IBorders)

BottomBorderColor Property (IBorders)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IBorders Interface : BottomBorderColor Property
The color of the bottom border.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property BottomBorderColor As System.String
System.string BottomBorderColor {get;}

Property Value

The color of the bottom border.
See Also

Reference

IBorders Interface
IBorders Members


BottomBorderStyle Property (IBorders)

BottomBorderStyle Property (IBorders)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IBorders Interface : BottomBorderStyle Property
The style of the bottom border.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property BottomBorderStyle As System.String
System.string BottomBorderStyle {get;}

Property Value

The style of the bottom border.
See Also

Reference

IBorders Interface
IBorders Members


BottomBorderWidth Property (IBorders)

BottomBorderWidth Property (IBorders)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IBorders Interface : BottomBorderWidth Property
The width of the bottom border.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property BottomBorderWidth As Length
Length BottomBorderWidth {get;}

Property Value

The width of the bottom border.
See Also

Reference

IBorders Interface
IBorders Members


LeftBorderColor Property (IBorders)

LeftBorderColor Property (IBorders)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IBorders Interface : LeftBorderColor Property
The color of the left border.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LeftBorderColor As System.String
System.string LeftBorderColor {get;}

Property Value

The color of the left border.
See Also

Reference

IBorders Interface
IBorders Members


LeftBorderStyle Property (IBorders)

LeftBorderStyle Property (IBorders)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IBorders Interface : LeftBorderStyle Property
The style of the left border.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LeftBorderStyle As System.String
System.string LeftBorderStyle {get;}

Property Value

The style of the left border.
See Also

Reference

IBorders Interface
IBorders Members


LeftBorderWidth Property (IBorders)

LeftBorderWidth Property (IBorders)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IBorders Interface : LeftBorderWidth Property
The width of the left border.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LeftBorderWidth As Length
Length LeftBorderWidth {get;}

Property Value

The width of the left border.
See Also

Reference

IBorders Interface
IBorders Members


RightBorderColor Property (IBorders)

RightBorderColor Property (IBorders)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IBorders Interface : RightBorderColor Property
The color of the right border.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RightBorderColor As System.String
System.string RightBorderColor {get;}

Property Value

The color of the right border.
See Also

Reference

IBorders Interface
IBorders Members


RightBorderStyle Property (IBorders)

RightBorderStyle Property (IBorders)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IBorders Interface : RightBorderStyle Property
The style of the right border.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RightBorderStyle As System.String
System.string RightBorderStyle {get;}

Property Value

The style of the right border.
See Also

Reference

IBorders Interface
IBorders Members


RightBorderWidth Property (IBorders)

RightBorderWidth Property (IBorders)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IBorders Interface : RightBorderWidth Property
The width of the right border.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RightBorderWidth As Length
Length RightBorderWidth {get;}

Property Value

The width of the right border.
See Also

Reference

IBorders Interface
IBorders Members


TopBorderColor Property (IBorders)

TopBorderColor Property (IBorders)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IBorders Interface : TopBorderColor Property
The color of the top border.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TopBorderColor As System.String
System.string TopBorderColor {get;}

Property Value

The color of the top border.
See Also

Reference

IBorders Interface
IBorders Members


TopBorderStyle Property (IBorders)

TopBorderStyle Property (IBorders)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IBorders Interface : TopBorderStyle Property
The style of the top border.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TopBorderStyle As System.String
System.string TopBorderStyle {get;}

Property Value

The style of the top border.
See Also

Reference

IBorders Interface
IBorders Members


TopBorderWidth Property (IBorders)

TopBorderWidth Property (IBorders)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IBorders Interface : TopBorderWidth Property
The width of the top border.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TopBorderWidth As Length
Length TopBorderWidth {get;}

Property Value

The width of the top border.
See Also

Reference

IBorders Interface
IBorders Members


IContentRange Interface

IContentRange Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IContentRange Interface
Represents a basic content range interface.
Object Model
IContentRange Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IContentRange
public interface IContentRange
See Also

Reference

IContentRange Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IContentRange Interface Members

IContentRange Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IContentRange Interface

The following tables list the members exposed by IContentRange.

Public Properties
 | Name | Description
Property | Owner | Specifies the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem represented by the current range.
Top
See Also

Reference

IContentRange Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IContentRange Interface Properties

IContentRange Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IContentRange Interface

For a list of all members of this type, see IContentRange members.

Public Properties
 | Name | Description
Property | Owner | Specifies the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem represented by the current range.
Top
See Also

Reference

IContentRange Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


Owner Property (IContentRange)

Owner Property (IContentRange)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IContentRange Interface : Owner Property
Specifies the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem represented by the current range.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Owner As IReportItem
IReportItem Owner {get;}
See Also

Reference

IContentRange Interface
IContentRange Members


IGrid Interface

IGrid Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IGrid Interface
Represents a virtual grid composed from the IGridCell
Object Model
IGrid Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IGrid
public interface IGrid
See Also

Reference

IGrid Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IGrid Interface Members

IGrid Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IGrid Interface

The following tables list the members exposed by IGrid.

Public Properties
 | Name | Description
Property | Columns | Number of columns in the grid.
Property | Rows | Number of rows in the grid.
Top
Public Methods
 | Name | Description
Method | GetCellAt | Obtains IGridCell given row and column numbers.
Top
See Also

Reference

IGrid Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IGrid Interface Methods

IGrid Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IGrid Interface

For a list of all members of this type, see IGrid members.

Public Methods
 | Name | Description
Method | GetCellAt | Obtains IGridCell given row and column numbers.
Top
See Also

Reference

IGrid Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


GetCellAt Method

GetCellAt Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IGrid Interface : GetCellAt Method
The row number of the cell.
The column number of the cell.
Obtains IGridCell given row and column numbers.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetCellAt( _
   ByVal row As System.Integer, _
   ByVal column As System.Integer _
) As IGridCell
IGridCell GetCellAt(
   System.int row,
   System.int column
)

Parameters

row
The row number of the cell.
column
The column number of the cell.
See Also

Reference

IGrid Interface
IGrid Members


IGrid Interface Properties

IGrid Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IGrid Interface

For a list of all members of this type, see IGrid members.

Public Properties
 | Name | Description
Property | Columns | Number of columns in the grid.
Property | Rows | Number of rows in the grid.
Top
See Also

Reference

IGrid Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


Columns Property (IGrid)

Columns Property (IGrid)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IGrid Interface : Columns Property
Number of columns in the grid.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Columns As System.Integer
System.int Columns {get;}
See Also

Reference

IGrid Interface
IGrid Members


Rows Property (IGrid)

Rows Property (IGrid)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IGrid Interface : Rows Property
Number of rows in the grid.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Rows As System.Integer
System.int Rows {get;}
See Also

Reference

IGrid Interface
IGrid Members


IGridCell Interface

IGridCell Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IGridCell Interface
Represents a single cell in the virtual grid.
Object Model
IGridCell Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IGridCell
public interface IGridCell
See Also

Reference

IGridCell Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IGridCell Interface Members

IGridCell Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IGridCell Interface

The following tables list the members exposed by IGridCell.

Public Properties
 | Name | Description
Property | ColumnSpan | The column span for this cell.
Property | Content | The actual content to be rendered in this cell.
Property | EffectiveBorders | Retreives effective border styles for this cell.
Property | RowSpan | The row span for this cell.
Top
See Also

Reference

IGridCell Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


IGridCell Interface Properties

IGridCell Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : IGridCell Interface

For a list of all members of this type, see IGridCell members.

Public Properties
 | Name | Description
Property | ColumnSpan | The column span for this cell.
Property | Content | The actual content to be rendered in this cell.
Property | EffectiveBorders | Retreives effective border styles for this cell.
Property | RowSpan | The row span for this cell.
Top
See Also

Reference

IGridCell Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ColumnSpan Property (IGridCell)

ColumnSpan Property (IGridCell)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IGridCell Interface : ColumnSpan Property
The column span for this cell.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ColumnSpan As CellSpan
CellSpan ColumnSpan {get;}
See Also

Reference

IGridCell Interface
IGridCell Members


Content Property (IGridCell)

Content Property (IGridCell)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IGridCell Interface : Content Property
The actual content to be rendered in this cell.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Content As ILayoutArea
ILayoutArea Content {get;}
See Also

Reference

IGridCell Interface
IGridCell Members


EffectiveBorders Property

EffectiveBorders Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IGridCell Interface : EffectiveBorders Property
Retreives effective border styles for this cell.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property EffectiveBorders As IBorders
IBorders EffectiveBorders {get;}
See Also

Reference

IGridCell Interface
IGridCell Members


RowSpan Property (IGridCell)

RowSpan Property (IGridCell)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > IGridCell Interface : RowSpan Property
The row span for this cell.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RowSpan As CellSpan
CellSpan RowSpan {get;}
See Also

Reference

IGridCell Interface
IGridCell Members


ILayoutArea Interface

ILayoutArea Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutArea Interface
Specifies an area that contains a layout.
Object Model
ILayoutArea Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ILayoutArea
public interface ILayoutArea
See Also

Reference

ILayoutArea Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutArea Interface Members

ILayoutArea Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutArea Interface

The following tables list the members exposed by ILayoutArea.

Public Properties
 | Name | Description
Property | Children | Returns the LayoutArea objects that are children of this object (if any).
Property | ContentRange | Specifies the range of content in this area.
Property | Height | Gets the area's height.
Property | IsFirstHorizontally | True if this is the first area horizontally.
Property | IsFirstVertically | True if this is the first area vertically. This functionality is available via IMeasurements
Property | IsLastHorizontally | True if this is the last area horizontally.
Property | IsLastVertically | True if this is the last area vertically.
Property | Left | Gets the area's left position.
Property | MetadataDictionary | Specifies optional master (root) metadata dictionary associated with this layout area.
Property | Name | Specifies area component item name (for debugging purposes).
Property | Page | Specifies LayoutTree page that hosts this LayoutArea.
Property | Parent | Parent LayoutArea, if any.
Property | ReportItem | Returns the ReportItem.
Property | Top | Gets the area's top position.
Property | Width | Gets the area's width.
Top
Public Methods
 | Name | Description
Method | HitTest | Tries to find area corresponding to the specifed point.
Top
See Also

Reference

ILayoutArea Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutArea Interface Methods

ILayoutArea Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutArea Interface

For a list of all members of this type, see ILayoutArea members.

Public Methods
 | Name | Description
Method | HitTest | Tries to find area corresponding to the specifed point.
Top
See Also

Reference

ILayoutArea Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


HitTest Method (ILayoutArea)

HitTest Method (ILayoutArea)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : HitTest Method
The point to test.
Tries to find area corresponding to the specifed point.
Syntax
  • Visual Basic
  • C#
'Declaration

Function HitTest( _
   ByVal point As PointFEx _
) As HitTestInfo
HitTestInfo HitTest(
   PointFEx point
)

Parameters

point
The point to test.
See Also

Reference

ILayoutArea Interface
ILayoutArea Members


ILayoutArea Interface Properties

ILayoutArea Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutArea Interface

For a list of all members of this type, see ILayoutArea members.

Public Properties
 | Name | Description
Property | Children | Returns the LayoutArea objects that are children of this object (if any).
Property | ContentRange | Specifies the range of content in this area.
Property | Height | Gets the area's height.
Property | IsFirstHorizontally | True if this is the first area horizontally.
Property | IsFirstVertically | True if this is the first area vertically. This functionality is available via IMeasurements
Property | IsLastHorizontally | True if this is the last area horizontally.
Property | IsLastVertically | True if this is the last area vertically.
Property | Left | Gets the area's left position.
Property | MetadataDictionary | Specifies optional master (root) metadata dictionary associated with this layout area.
Property | Name | Specifies area component item name (for debugging purposes).
Property | Page | Specifies LayoutTree page that hosts this LayoutArea.
Property | Parent | Parent LayoutArea, if any.
Property | ReportItem | Returns the ReportItem.
Property | Top | Gets the area's top position.
Property | Width | Gets the area's width.
Top
See Also

Reference

ILayoutArea Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


Children Property (ILayoutArea)

Children Property (ILayoutArea)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : Children Property
Returns the LayoutArea objects that are children of this object (if any).
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Children As IItemCollection(Of ILayoutArea)
IItemCollection<ILayoutArea> Children {get;}
See Also

Reference

ILayoutArea Interface
ILayoutArea Members


ContentRange Property (ILayoutArea)

ContentRange Property (ILayoutArea)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : ContentRange Property
Specifies the range of content in this area.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ContentRange As IContentRange
IContentRange ContentRange {get;}
See Also

Reference

ILayoutArea Interface
ILayoutArea Members


Height Property (ILayoutArea)

Height Property (ILayoutArea)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : Height Property
Gets the area's height.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Height As System.Single
System.float Height {get;}
See Also

Reference

ILayoutArea Interface
ILayoutArea Members


IsFirstHorizontally Property

IsFirstHorizontally Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : IsFirstHorizontally Property
True if this is the first area horizontally.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property IsFirstHorizontally As System.Boolean
System.bool IsFirstHorizontally {get;}
Remarks
This functionality is available via IMeasurements
See Also

Reference

ILayoutArea Interface
ILayoutArea Members


IsFirstVertically Property

IsFirstVertically Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : IsFirstVertically Property
True if this is the first area vertically. This functionality is available via IMeasurements
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property IsFirstVertically As System.Boolean
System.bool IsFirstVertically {get;}
Remarks
This functionality is available via IMeasurements
See Also

Reference

ILayoutArea Interface
ILayoutArea Members


IsLastHorizontally Property

IsLastHorizontally Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : IsLastHorizontally Property
True if this is the last area horizontally.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property IsLastHorizontally As System.Boolean
System.bool IsLastHorizontally {get;}
See Also

Reference

ILayoutArea Interface
ILayoutArea Members


IsLastVertically Property

IsLastVertically Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : IsLastVertically Property
True if this is the last area vertically.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property IsLastVertically As System.Boolean
System.bool IsLastVertically {get;}
See Also

Reference

ILayoutArea Interface
ILayoutArea Members


Left Property (ILayoutArea)

Left Property (ILayoutArea)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : Left Property
Gets the area's left position.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Left As System.Single
System.float Left {get;}
See Also

Reference

ILayoutArea Interface
ILayoutArea Members


MetadataDictionary Property (ILayoutArea)

MetadataDictionary Property (ILayoutArea)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : MetadataDictionary Property
Specifies optional master (root) metadata dictionary associated with this layout area.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MetadataDictionary As IMetadataDictionary
IMetadataDictionary MetadataDictionary {get;}
See Also

Reference

ILayoutArea Interface
ILayoutArea Members


Name Property (ILayoutArea)

Name Property (ILayoutArea)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : Name Property
Specifies area component item name (for debugging purposes).
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Name As System.String
System.string Name {get;}
See Also

Reference

ILayoutArea Interface
ILayoutArea Members


Page Property (ILayoutArea)

Page Property (ILayoutArea)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : Page Property
Specifies LayoutTree page that hosts this LayoutArea.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Page As ILayoutPage
ILayoutPage Page {get;}
See Also

Reference

ILayoutArea Interface
ILayoutArea Members


Parent Property (ILayoutArea)

Parent Property (ILayoutArea)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : Parent Property
Parent LayoutArea, if any.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Parent As ILayoutArea
ILayoutArea Parent {get;}
See Also

Reference

ILayoutArea Interface
ILayoutArea Members


ReportItem Property (ILayoutArea)

ReportItem Property (ILayoutArea)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : ReportItem Property
Returns the ReportItem.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ReportItem As IReportItem
IReportItem ReportItem {get;}
See Also

Reference

ILayoutArea Interface
ILayoutArea Members


Top Property (ILayoutArea)

Top Property (ILayoutArea)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : Top Property
Gets the area's top position.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Top As System.Single
System.float Top {get;}
See Also

Reference

ILayoutArea Interface
ILayoutArea Members


Width Property (ILayoutArea)

Width Property (ILayoutArea)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutArea Interface : Width Property
Gets the area's width.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Width As System.Single
System.float Width {get;}
See Also

Reference

ILayoutArea Interface
ILayoutArea Members


ILayoutAreaCollapsible Interface

ILayoutAreaCollapsible Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutAreaCollapsible Interface
Specifies an area that contains a layout and provides collapsing support for hidden items inside layout area.
Object Model
ILayoutAreaCollapsible Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ILayoutAreaCollapsible
   Inherits ILayoutArea
public interface ILayoutAreaCollapsible : ILayoutArea
See Also

Reference

ILayoutAreaCollapsible Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutAreaCollapsible Interface Members

ILayoutAreaCollapsible Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutAreaCollapsible Interface

The following tables list the members exposed by ILayoutAreaCollapsible.

Public Properties
 | Name | Description
Property | Children | Returns the LayoutArea objects that are children of this object (if any). (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | ContentRange | Specifies the range of content in this area. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Height | Gets the area's height. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | IsFirstHorizontally | True if this is the first area horizontally. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | IsFirstVertically | True if this is the first area vertically. This functionality is available via IMeasurements (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | IsLastHorizontally | True if this is the last area horizontally. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | IsLastVertically | True if this is the last area vertically. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Left | Gets the area's left position. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | MetadataDictionary | Specifies optional master (root) metadata dictionary associated with this layout area. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Name | Specifies area component item name (for debugging purposes). (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Page | Specifies LayoutTree page that hosts this LayoutArea. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Parent | Parent LayoutArea, if any. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | ReportItem | Returns the ReportItem. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Top | Gets the area's top position. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Visible | Indicates that layout area is visble
Property | Width | Gets the area's width. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Top
Public Methods
 | Name | Description
Method | HitTest | Tries to find area corresponding to the specifed point. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Method | ProcessDescendants | Collapses the child area elements in the hidden layout area along with dynamic visibility.
Top
See Also

Reference

ILayoutAreaCollapsible Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutAreaCollapsible Interface Methods

ILayoutAreaCollapsible Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutAreaCollapsible Interface

For a list of all members of this type, see ILayoutAreaCollapsible members.

Public Methods
 | Name | Description
Method | HitTest | Tries to find area corresponding to the specifed point. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Method | ProcessDescendants | Collapses the child area elements in the hidden layout area along with dynamic visibility.
Top
See Also

Reference

ILayoutAreaCollapsible Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ProcessDescendants Method

ProcessDescendants Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutAreaCollapsible Interface : ProcessDescendants Method
Collapses the child area elements in the hidden layout area along with dynamic visibility.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub ProcessDescendants()
void ProcessDescendants()
See Also

Reference

ILayoutAreaCollapsible Interface
ILayoutAreaCollapsible Members


ILayoutAreaCollapsible Interface Properties

ILayoutAreaCollapsible Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutAreaCollapsible Interface

For a list of all members of this type, see ILayoutAreaCollapsible members.

Public Properties
 | Name | Description
Property | Children | Returns the LayoutArea objects that are children of this object (if any). (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | ContentRange | Specifies the range of content in this area. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Height | Gets the area's height. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | IsFirstHorizontally | True if this is the first area horizontally. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | IsFirstVertically | True if this is the first area vertically. This functionality is available via IMeasurements (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | IsLastHorizontally | True if this is the last area horizontally. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | IsLastVertically | True if this is the last area vertically. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Left | Gets the area's left position. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | MetadataDictionary | Specifies optional master (root) metadata dictionary associated with this layout area. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Name | Specifies area component item name (for debugging purposes). (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Page | Specifies LayoutTree page that hosts this LayoutArea. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Parent | Parent LayoutArea, if any. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | ReportItem | Returns the ReportItem. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Top | Gets the area's top position. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Visible | Indicates that layout area is visble
Property | Width | Gets the area's width. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Top
See Also

Reference

ILayoutAreaCollapsible Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


Visible Property (ILayoutAreaCollapsible)

Visible Property (ILayoutAreaCollapsible)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutAreaCollapsible Interface : Visible Property
Indicates that layout area is visble
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Visible As System.Boolean
System.bool Visible {get;}
Remarks
This functionality is available via IMeasurements
See Also

Reference

ILayoutAreaCollapsible Interface
ILayoutAreaCollapsible Members


ILayoutEngine Interface

ILayoutEngine Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutEngine Interface
Defines the layout engine public interface.
Object Model
ILayoutEngine Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ILayoutEngine
public interface ILayoutEngine
See Also

Reference

ILayoutEngine Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutEngine Interface Members

ILayoutEngine Interface Members
Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutEngine Interface

The following tables list the members exposed by ILayoutEngine.

Public Methods
 | Name | Description
Method | BuildLayout | Overloaded. Builds a complete layout tree using the supplied report instance.
Method | Dispose | (Inherited from System.IDisposable)
Top
See Also

Reference

ILayoutEngine Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutEngine Interface Methods

ILayoutEngine Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutEngine Interface

For a list of all members of this type, see ILayoutEngine members.

Public Methods
 | Name | Description
Method | BuildLayout | Overloaded. Builds a complete layout tree using the supplied report instance.
Method | Dispose | (Inherited from System.IDisposable)
Top
See Also

Reference

ILayoutEngine Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


BuildLayout Method

BuildLayout Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutEngine Interface : BuildLayout Method
Builds a complete layout tree using the supplied report instance.
Overload List
Overload | Description
BuildLayout(IReport,ITargetDevice) | Builds a complete layout tree using the supplied report instance.
BuildLayout(LayoutInfo) | Builds a complete layout tree using the supplied LayoutInfo instance.
See Also

Reference

ILayoutEngine Interface
ILayoutEngine Members


BuildLayout(IReport,ITargetDevice) Method

BuildLayout(IReport,ITargetDevice) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutEngine Interface > BuildLayout Method : BuildLayout(IReport,ITargetDevice) Method
The report to lay out.
ITargetDevice to use for layout.
Builds a complete layout tree using the supplied report instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function BuildLayout( _
   ByVal report As IReport, _
   ByVal targetDevice As ITargetDevice _
) As ILayoutTree
ILayoutTree BuildLayout(
   IReport report,
   ITargetDevice targetDevice
)

Parameters

report
The report to lay out.
targetDevice
ITargetDevice to use for layout.
See Also

Reference

ILayoutEngine Interface
ILayoutEngine Members
Overload List


BuildLayout(LayoutInfo) Method

BuildLayout(LayoutInfo) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutEngine Interface > BuildLayout Method : BuildLayout(LayoutInfo) Method
LayoutInfo use to build the layout.
Builds a complete layout tree using the supplied LayoutInfo instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function BuildLayout( _
   ByVal layoutInfo As LayoutInfo _
) As ILayoutTree
ILayoutTree BuildLayout(
   LayoutInfo layoutInfo
)

Parameters

layoutInfo
LayoutInfo use to build the layout.

Return Value

LayoutTree instance representing the report layout.
See Also

Reference

ILayoutEngine Interface
ILayoutEngine Members
Overload List


ILayoutEngineFactory Interface

ILayoutEngineFactory Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutEngineFactory Interface
Summary description for ILayoutEngineFactory.
Object Model
ILayoutEngineFactory Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ILayoutEngineFactory
public interface ILayoutEngineFactory
See Also

Reference

ILayoutEngineFactory Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutEngineFactory Interface Members

ILayoutEngineFactory Interface Members
Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutEngineFactory Interface

The following tables list the members exposed by ILayoutEngineFactory.

Public Methods
 | Name | Description
Method | GetLayoutEngine | Retrieves the LayoutEngine.
Top
See Also

Reference

ILayoutEngineFactory Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutEngineFactory Interface Methods

ILayoutEngineFactory Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutEngineFactory Interface

For a list of all members of this type, see ILayoutEngineFactory members.

Public Methods
 | Name | Description
Method | GetLayoutEngine | Retrieves the LayoutEngine.
Top
See Also

Reference

ILayoutEngineFactory Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


GetLayoutEngine Method

GetLayoutEngine Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutEngineFactory Interface : GetLayoutEngine Method
Retrieves the LayoutEngine.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetLayoutEngine() As ILayoutEngine
ILayoutEngine GetLayoutEngine()

Return Value

The LayoutEngine.
See Also

Reference

ILayoutEngineFactory Interface
ILayoutEngineFactory Members


ILayoutManager Interface

ILayoutManager Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutManager Interface
Implement this interface on ReportItem to provide custom layout logic or to support advanced layout features such as pagination.
Object Model
ILayoutManager Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ILayoutManager
public interface ILayoutManager
See Also

Reference

ILayoutManager Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutManager Interface Members

ILayoutManager Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutManager Interface

The following tables list the members exposed by ILayoutManager.

Public Properties
 | Name | Description
Property | Capabilities | Specifies layout capabilities of the item being laid out.
Top
Public Methods
 | Name | Description
Method | Initialize | Allows initialization of layout manager with specifies ITargetDevice.
Method | Layout | Lays out the content that the specified ContentRange represents.
Method | Measure | A query by the layout system of what the results of a call to Layout would be with the specified settings.
Top
See Also

Reference

ILayoutManager Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutManager Interface Methods

ILayoutManager Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutManager Interface

For a list of all members of this type, see ILayoutManager members.

Public Methods
 | Name | Description
Method | Initialize | Allows initialization of layout manager with specifies ITargetDevice.
Method | Layout | Lays out the content that the specified ContentRange represents.
Method | Measure | A query by the layout system of what the results of a call to Layout would be with the specified settings.
Top
See Also

Reference

ILayoutManager Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


Initialize Method (ILayoutManager)

Initialize Method (ILayoutManager)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutManager Interface : Initialize Method
ReportItem that will be laid out
TargetDevice for which layout operation should be performed
Allows initialization of layout manager with specifies ITargetDevice.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Initialize( _
   ByVal forReportItem As IReportItem, _
   ByVal targetDevice As ITargetDevice _
)
void Initialize(
   IReportItem forReportItem,
   ITargetDevice targetDevice
)

Parameters

forReportItem
ReportItem that will be laid out
targetDevice
TargetDevice for which layout operation should be performed
Remarks
Layout subsystem will call this method before fist call to Measure/Layout.
See Also

Reference

ILayoutManager Interface
ILayoutManager Members


Layout Method

Layout Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutManager Interface : Layout Method
LayoutContext specifying information about layout operations
Lays out the content that the specified ContentRange represents.
Syntax
  • Visual Basic
  • C#
'Declaration

Function Layout( _
   ByVal context As LayoutContext _
) As LayoutResult
LayoutResult Layout(
   LayoutContext context
)

Parameters

context
LayoutContext specifying information about layout operations

Return Value

LayoutResult indicating outcome of this operation
Remarks
This method should return the exact size of the content laid out encapsulated into LayoutResult.
See Also

Reference

ILayoutManager Interface
ILayoutManager Members


Measure Method (ILayoutManager)

Measure Method (ILayoutManager)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutManager Interface : Measure Method
LayoutContext specifying information about layout operations
A query by the layout system of what the results of a call to Layout would be with the specified settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Function Measure( _
   ByVal context As LayoutContext _
) As LayoutResult
LayoutResult Measure(
   LayoutContext context
)

Parameters

context
LayoutContext specifying information about layout operations

Return Value

LayoutResult indicating outcome of this operation
Remarks
Current implementation of layout subsystem assumes that this method will return actual extents encapsulated into LayoutResult. Nevertheless, it may be sufficient to return only approximate partial size (low end approximation) as long as the layout manager knows that the item (content being measured) will exceed current page dimensions (ITargetDevice for more details) for the current target device and a complete accurate measurement of the item is expensive.
See Also

Reference

ILayoutManager Interface
ILayoutManager Members


ILayoutManager Interface Properties

ILayoutManager Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutManager Interface

For a list of all members of this type, see ILayoutManager members.

Public Properties
 | Name | Description
Property | Capabilities | Specifies layout capabilities of the item being laid out.
Top
See Also

Reference

ILayoutManager Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


Capabilities Property

Capabilities Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutManager Interface : Capabilities Property
Specifies layout capabilities of the item being laid out.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Capabilities As LayoutCapabilities
LayoutCapabilities Capabilities {get;}
Remarks
The layout system can use this information as a hint to avoid an unnecessary Measure.
See Also

Reference

ILayoutManager Interface
ILayoutManager Members


ILayoutPage Interface

ILayoutPage Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutPage Interface
Interface for layout page.
Object Model
ILayoutPage Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ILayoutPage
public interface ILayoutPage
See Also

Reference

ILayoutPage Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutPage Interface Members

ILayoutPage Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutPage Interface

The following tables list the members exposed by ILayoutPage.

Public Properties
 | Name | Description
Property | BodyArea | Returns a page body area (where page content should be laid out).
Property | Footer | Page footer section for this instance.
Property | Header | Page header section for this instance.
Property | Height | Specifies page height.
Property | IsDirty | Allows to track changes for this page instance since last rendering.
Property | IsHorizontal | Specifies that a horizontal layout is being used.
Property | PageNumber | Returns the page number.
Property | Width | Specifies page width.
Top
Public Methods
 | Name | Description
Method | HitTest | Helper function that performs hit-testing for a complete page by checking header, body and footer when applicable.
Top
See Also

Reference

ILayoutPage Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutPage Interface Methods

ILayoutPage Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutPage Interface

For a list of all members of this type, see ILayoutPage members.

Public Methods
 | Name | Description
Method | HitTest | Helper function that performs hit-testing for a complete page by checking header, body and footer when applicable.
Top
See Also

Reference

ILayoutPage Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


HitTest Method (ILayoutPage)

HitTest Method (ILayoutPage)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutPage Interface : HitTest Method
The point to test.
Helper function that performs hit-testing for a complete page by checking header, body and footer when applicable.
Syntax
  • Visual Basic
  • C#
'Declaration

Function HitTest( _
   ByVal point As PointFEx _
) As HitTestInfo
HitTestInfo HitTest(
   PointFEx point
)

Parameters

point
The point to test.
See Also

Reference

ILayoutPage Interface
ILayoutPage Members


ILayoutPage Interface Properties

ILayoutPage Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutPage Interface

For a list of all members of this type, see ILayoutPage members.

Public Properties
 | Name | Description
Property | BodyArea | Returns a page body area (where page content should be laid out).
Property | Footer | Page footer section for this instance.
Property | Header | Page header section for this instance.
Property | Height | Specifies page height.
Property | IsDirty | Allows to track changes for this page instance since last rendering.
Property | IsHorizontal | Specifies that a horizontal layout is being used.
Property | PageNumber | Returns the page number.
Property | Width | Specifies page width.
Top
See Also

Reference

ILayoutPage Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


BodyArea Property

BodyArea Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutPage Interface : BodyArea Property
Returns a page body area (where page content should be laid out).
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property BodyArea As ILayoutArea
ILayoutArea BodyArea {get;}
See Also

Reference

ILayoutPage Interface
ILayoutPage Members


Footer Property (ILayoutPage)

Footer Property (ILayoutPage)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutPage Interface : Footer Property
Page footer section for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Footer As ILayoutArea
ILayoutArea Footer {get;}
See Also

Reference

ILayoutPage Interface
ILayoutPage Members


Header Property (ILayoutPage)

Header Property (ILayoutPage)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutPage Interface : Header Property
Page header section for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Header As ILayoutArea
ILayoutArea Header {get;}
See Also

Reference

ILayoutPage Interface
ILayoutPage Members


Height Property (ILayoutPage)

Height Property (ILayoutPage)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutPage Interface : Height Property
Specifies page height.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Height As System.Single
System.float Height {get;}
See Also

Reference

ILayoutPage Interface
ILayoutPage Members


IsDirty Property (ILayoutPage)

IsDirty Property (ILayoutPage)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutPage Interface : IsDirty Property
Allows to track changes for this page instance since last rendering.
Syntax
  • Visual Basic
  • C#
'Declaration

Property IsDirty As System.Boolean
System.bool IsDirty {get; set;}
See Also

Reference

ILayoutPage Interface
ILayoutPage Members


IsHorizontal Property

IsHorizontal Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutPage Interface : IsHorizontal Property
Specifies that a horizontal layout is being used.
Syntax
  • Visual Basic
  • C#
'Declaration

Property IsHorizontal As System.Boolean
System.bool IsHorizontal {get; set;}
See Also

Reference

ILayoutPage Interface
ILayoutPage Members


PageNumber Property (ILayoutPage)

PageNumber Property (ILayoutPage)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutPage Interface : PageNumber Property
Returns the page number.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PageNumber As System.Integer
System.int PageNumber {get;}
See Also

Reference

ILayoutPage Interface
ILayoutPage Members


Width Property (ILayoutPage)

Width Property (ILayoutPage)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutPage Interface : Width Property
Specifies page width.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Width As System.Single
System.float Width {get;}
See Also

Reference

ILayoutPage Interface
ILayoutPage Members


ILayoutRenderingService Interface

ILayoutRenderingService Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutRenderingService Interface
Special service to support valid page numbers calculation during rendering.
Object Model
ILayoutRenderingService Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ILayoutRenderingService
public interface ILayoutRenderingService
See Also

Reference

ILayoutRenderingService Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutRenderingService Interface Members

ILayoutRenderingService Interface Members
Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutRenderingService Interface

The following tables list the members exposed by ILayoutRenderingService.

Public Methods
 | Name | Description
Method | EnterPage | Start page rendering
Top
See Also

Reference

ILayoutRenderingService Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutRenderingService Interface Methods

ILayoutRenderingService Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutRenderingService Interface

For a list of all members of this type, see ILayoutRenderingService members.

Public Methods
 | Name | Description
Method | EnterPage | Start page rendering
Top
See Also

Reference

ILayoutRenderingService Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


EnterPage Method

EnterPage Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutRenderingService Interface : EnterPage Method
Start page rendering
Syntax
  • Visual Basic
  • C#
'Declaration

Function EnterPage( _
   ByVal page As ILayoutPage _
) As System.IDisposable
System.IDisposable EnterPage(
   ILayoutPage page
)

Parameters

page
See Also

Reference

ILayoutRenderingService Interface
ILayoutRenderingService Members


ILayoutSection Interface

ILayoutSection Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutSection Interface
Interface for layout sections.
Object Model
ILayoutSection Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ILayoutSection
   Inherits ILayoutArea
public interface ILayoutSection : ILayoutArea
See Also

Reference

ILayoutSection Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutSection Interface Members

ILayoutSection Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutSection Interface

The following tables list the members exposed by ILayoutSection.

Public Properties
 | Name | Description
Property | Children | Returns the LayoutArea objects that are children of this object (if any). (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | ContentRange | Specifies the range of content in this area. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Height | Gets the area's height. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | IsFirstHorizontally | True if this is the first area horizontally. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | IsFirstVertically | True if this is the first area vertically. This functionality is available via IMeasurements (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | IsLastHorizontally | True if this is the last area horizontally. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | IsLastVertically | True if this is the last area vertically. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Left | Gets the area's left position. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | MetadataDictionary | Specifies optional master (root) metadata dictionary associated with this layout area. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Name | Specifies area component item name (for debugging purposes). (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Page | Specifies LayoutTree page that hosts this LayoutArea. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Parent | Parent LayoutArea, if any. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Report | Master Report associated with this page section.
Property | ReportItem | Returns the ReportItem. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | SectionType | Section type to which this instance corresponds.
Property | Top | Gets the area's top position. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Width | Gets the area's width. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Top
Public Methods
 | Name | Description
Method | HitTest | Tries to find area corresponding to the specifed point. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Top
See Also

Reference

ILayoutSection Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutSection Interface Properties

ILayoutSection Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutSection Interface

For a list of all members of this type, see ILayoutSection members.

Public Properties
 | Name | Description
Property | Children | Returns the LayoutArea objects that are children of this object (if any). (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | ContentRange | Specifies the range of content in this area. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Height | Gets the area's height. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | IsFirstHorizontally | True if this is the first area horizontally. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | IsFirstVertically | True if this is the first area vertically. This functionality is available via IMeasurements (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | IsLastHorizontally | True if this is the last area horizontally. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | IsLastVertically | True if this is the last area vertically. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Left | Gets the area's left position. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | MetadataDictionary | Specifies optional master (root) metadata dictionary associated with this layout area. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Name | Specifies area component item name (for debugging purposes). (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Page | Specifies LayoutTree page that hosts this LayoutArea. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Parent | Parent LayoutArea, if any. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Report | Master Report associated with this page section.
Property | ReportItem | Returns the ReportItem. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | SectionType | Section type to which this instance corresponds.
Property | Top | Gets the area's top position. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Property | Width | Gets the area's width. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Top
See Also

Reference

ILayoutSection Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


Report Property (ILayoutSection)

Report Property (ILayoutSection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutSection Interface : Report Property
Master Report associated with this page section.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Report As IReport
IReport Report {get;}
See Also

Reference

ILayoutSection Interface
ILayoutSection Members


SectionType Property

SectionType Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutSection Interface : SectionType Property
Section type to which this instance corresponds.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property SectionType As LayoutPageSectionType
LayoutPageSectionType SectionType {get;}
See Also

Reference

ILayoutSection Interface
ILayoutSection Members


ILayoutTree Interface

ILayoutTree Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutTree Interface
The interface for the layout tree.
Object Model
ILayoutTree Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ILayoutTree
public interface ILayoutTree
See Also

Reference

ILayoutTree Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutTree Interface Members

ILayoutTree Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutTree Interface

The following tables list the members exposed by ILayoutTree.

Public Properties
 | Name | Description
Property | Item | Page indexer.
Property | MasterReport | Returns DataDynamics.Reports.Extensibility.Rendering.Components.IReport instance, associated with this layout.
Property | MetadataDictionary | Specifies Master metadata dictionary associated with this layout tree.
Property | PageCount | Returns a total number of laid out pages.
Property | Pages | Retreives pages enumerator.
Property | SyncRoot | Gets an object that can be used to synchronize access to this instance.
Top
Public Methods
 | Name | Description
Method | Dispose | (Inherited from System.IDisposable)
Top
See Also

Reference

ILayoutTree Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutTree Interface Properties

ILayoutTree Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutTree Interface

For a list of all members of this type, see ILayoutTree members.

Public Properties
 | Name | Description
Property | Item | Page indexer.
Property | MasterReport | Returns DataDynamics.Reports.Extensibility.Rendering.Components.IReport instance, associated with this layout.
Property | MetadataDictionary | Specifies Master metadata dictionary associated with this layout tree.
Property | PageCount | Returns a total number of laid out pages.
Property | Pages | Retreives pages enumerator.
Property | SyncRoot | Gets an object that can be used to synchronize access to this instance.
Top
See Also

Reference

ILayoutTree Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


Item Property (ILayoutTree)

Item Property (ILayoutTree)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutTree Interface : Item Property
Page indexer.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As ILayoutPage
ILayoutPage this[
   System.int index
]; {get;}

Parameters

index
See Also

Reference

ILayoutTree Interface
ILayoutTree Members


MasterReport Property (ILayoutTree)

MasterReport Property (ILayoutTree)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutTree Interface : MasterReport Property
Returns DataDynamics.Reports.Extensibility.Rendering.Components.IReport instance, associated with this layout.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MasterReport As IReport
IReport MasterReport {get;}
See Also

Reference

ILayoutTree Interface
ILayoutTree Members


MetadataDictionary Property (ILayoutTree)

MetadataDictionary Property (ILayoutTree)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutTree Interface : MetadataDictionary Property
Specifies Master metadata dictionary associated with this layout tree.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MetadataDictionary As IMetadataDictionary
IMetadataDictionary MetadataDictionary {get;}
See Also

Reference

ILayoutTree Interface
ILayoutTree Members


PageCount Property (ILayoutTree)

PageCount Property (ILayoutTree)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutTree Interface : PageCount Property
Returns a total number of laid out pages.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PageCount As System.Integer
System.int PageCount {get;}
See Also

Reference

ILayoutTree Interface
ILayoutTree Members


Pages Property (ILayoutTree)

Pages Property (ILayoutTree)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutTree Interface : Pages Property
Retreives pages enumerator.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Pages As System.Collections.Generic.IEnumerable(Of ILayoutPage)
System.Collections.Generic.IEnumerable<ILayoutPage> Pages {get;}
See Also

Reference

ILayoutTree Interface
ILayoutTree Members


SyncRoot Property (ILayoutTree)

SyncRoot Property (ILayoutTree)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutTree Interface : SyncRoot Property
Gets an object that can be used to synchronize access to this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property SyncRoot As System.Object
System.object SyncRoot {get;}
See Also

Reference

ILayoutTree Interface
ILayoutTree Members


ISpanCellMethodResolver Interface

ISpanCellMethodResolver Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ISpanCellMethodResolver Interface
Represents a resolve method for spanned cells of the grid
Object Model
ISpanCellMethodResolver Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ISpanCellMethodResolver
public interface ISpanCellMethodResolver
See Also

Reference

ISpanCellMethodResolver Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ISpanCellMethodResolver Interface Members

ISpanCellMethodResolver Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ISpanCellMethodResolver Interface

The following tables list the members exposed by ISpanCellMethodResolver.

Public Properties
 | Name | Description
Property | SpanResolveMethod | Represents a kind of method to indicate spanned cells.
Top
See Also

Reference

ISpanCellMethodResolver Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ISpanCellMethodResolver Interface Properties

ISpanCellMethodResolver Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ISpanCellMethodResolver Interface

For a list of all members of this type, see ISpanCellMethodResolver members.

Public Properties
 | Name | Description
Property | SpanResolveMethod | Represents a kind of method to indicate spanned cells.
Top
See Also

Reference

ISpanCellMethodResolver Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


SpanResolveMethod Property

SpanResolveMethod Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ISpanCellMethodResolver Interface : SpanResolveMethod Property
Represents a kind of method to indicate spanned cells.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property SpanResolveMethod As SpanCellResolveMethod
SpanCellResolveMethod SpanResolveMethod {get;}
See Also

Reference

ISpanCellMethodResolver Interface
ISpanCellMethodResolver Members


ITableArea Interface

ITableArea Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ITableArea Interface
Public interface to a table. Basically just an ordered collection of TableRows.
Object Model
ITableArea Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITableArea
public interface ITableArea
See Also

Reference

ITableArea Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ITableArea Interface Members

ITableArea Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ITableArea Interface

The following tables list the members exposed by ITableArea.

Public Properties
 | Name | Description
Property | RowsCount | Count of the number of rows in the table
Property | TableRows | A list of ITableRows representing each row of the table
Top
See Also

Reference

ITableArea Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ITableArea Interface Properties

ITableArea Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ITableArea Interface

For a list of all members of this type, see ITableArea members.

Public Properties
 | Name | Description
Property | RowsCount | Count of the number of rows in the table
Property | TableRows | A list of ITableRows representing each row of the table
Top
See Also

Reference

ITableArea Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


RowsCount Property (ITableArea)

RowsCount Property (ITableArea)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ITableArea Interface : RowsCount Property
Count of the number of rows in the table
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RowsCount As System.Integer
System.int RowsCount {get;}
See Also

Reference

ITableArea Interface
ITableArea Members


TableRows Property (ITableArea)

TableRows Property (ITableArea)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ITableArea Interface : TableRows Property
A list of ITableRows representing each row of the table
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TableRows As System.Collections.IEnumerable
System.Collections.IEnumerable TableRows {get;}
See Also

Reference

ITableArea Interface
ITableArea Members


ITableCell Interface

ITableCell Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ITableCell Interface
Public interface to an individual cell in a table.
Object Model
ITableCell Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITableCell
public interface ITableCell
See Also

Reference

ITableCell Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ITableCell Interface Members

ITableCell Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ITableCell Interface

The following tables list the members exposed by ITableCell.

Public Properties
 | Name | Description
Property | CellType | Type of cell such as header, footer or detail.
Property | ColumnSpan | The column span for this cell, always at least 1.
Property | Content | The actual content to be rendered in this cell.
Property | RowSpan | The row span for this cell, always at least 1.
Top
See Also

Reference

ITableCell Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ITableCell Interface Properties

ITableCell Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ITableCell Interface

For a list of all members of this type, see ITableCell members.

Public Properties
 | Name | Description
Property | CellType | Type of cell such as header, footer or detail.
Property | ColumnSpan | The column span for this cell, always at least 1.
Property | Content | The actual content to be rendered in this cell.
Property | RowSpan | The row span for this cell, always at least 1.
Top
See Also

Reference

ITableCell Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


CellType Property

CellType Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ITableCell Interface : CellType Property
Type of cell such as header, footer or detail.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CellType As TableElementType
TableElementType CellType {get;}
See Also

Reference

ITableCell Interface
ITableCell Members


ColumnSpan Property (ITableCell)

ColumnSpan Property (ITableCell)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ITableCell Interface : ColumnSpan Property
The column span for this cell, always at least 1.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ColumnSpan As System.Integer
System.int ColumnSpan {get;}
See Also

Reference

ITableCell Interface
ITableCell Members


Content Property (ITableCell)

Content Property (ITableCell)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ITableCell Interface : Content Property
The actual content to be rendered in this cell.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Content As ILayoutArea
ILayoutArea Content {get;}
See Also

Reference

ITableCell Interface
ITableCell Members


RowSpan Property (ITableCell)

RowSpan Property (ITableCell)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ITableCell Interface : RowSpan Property
The row span for this cell, always at least 1.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RowSpan As System.Integer
System.int RowSpan {get;}
See Also

Reference

ITableCell Interface
ITableCell Members


ITableRow Interface

ITableRow Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ITableRow Interface
Public interface to a row in a table. Basically just an ordered collection of TableCells.
Object Model
ITableRow Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITableRow
public interface ITableRow
See Also

Reference

ITableRow Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ITableRow Interface Members

ITableRow Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ITableRow Interface

The following tables list the members exposed by ITableRow.

Public Properties
 | Name | Description
Property | TableCells | A list of ITableCells representing a column in the table. Null entries may occur because of row spans to above or column spans to the left.
Top
See Also

Reference

ITableRow Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ITableRow Interface Properties

ITableRow Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ITableRow Interface

For a list of all members of this type, see ITableRow members.

Public Properties
 | Name | Description
Property | TableCells | A list of ITableCells representing a column in the table. Null entries may occur because of row spans to above or column spans to the left.
Top
See Also

Reference

ITableRow Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


TableCells Property (ITableRow)

TableCells Property (ITableRow)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ITableRow Interface : TableCells Property
A list of ITableCells representing a column in the table. Null entries may occur because of row spans to above or column spans to the left.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TableCells As System.Collections.IEnumerable
System.Collections.IEnumerable TableCells {get;}
See Also

Reference

ITableRow Interface
ITableRow Members


ITargetDevice Interface

ITargetDevice Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ITargetDevice Interface
Interface to encapsulate target device properties and features, including, but not limited: - avail. fonts; - font/color mapping; - conversion of logical units to physical (dpi); - etc.
Object Model
ITargetDevice Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITargetDevice
public interface ITargetDevice
Remarks
This interface is relevant to the layout engine as well as to the renderers.
See Also

Reference

ITargetDevice Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ITargetDevice Interface Members

ITargetDevice Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ITargetDevice Interface

The following tables list the members exposed by ITargetDevice.

Public Properties
 | Name | Description
Property | Item | Indexer that returns DeviceCapabilities for the specified feature set.
Top
See Also

Reference

ITargetDevice Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ITargetDevice Interface Properties

ITargetDevice Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ITargetDevice Interface

For a list of all members of this type, see ITargetDevice members.

Public Properties
 | Name | Description
Property | Item | Indexer that returns DeviceCapabilities for the specified feature set.
Top
See Also

Reference

ITargetDevice Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


Item Property (ITargetDevice)

Item Property (ITargetDevice)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ITargetDevice Interface : Item Property
Feature to fetch device capabilities for.
Indexer that returns DeviceCapabilities for the specified feature set.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Default Property Item( _
   ByVal feature As Features _
) As DeviceCapabilities
DeviceCapabilities this[
   Features feature
]; {get;}

Parameters

feature
Feature to fetch device capabilities for.

Property Value

DeviceCapabilities for this feature
See Also

Reference

ITargetDevice Interface
ITargetDevice Members


LayoutNotificationCallback Delegate

LayoutNotificationCallback Delegate

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutNotificationCallback Delegate
The current state of the layout.
Specifies notification callback for layout operation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Function LayoutNotificationCallback( _
   ByVal state As LayoutState _
) As System.Boolean
public delegate System.bool LayoutNotificationCallback(
   LayoutState state
)

Parameters

state
The current state of the layout.

Return Value

true to continue layout or false to cancel layout
Remarks
Layout subsystem will call supplied callback method upon completion of each layout page (after adding the page to resulting layout tree).
See Also

Reference

LayoutNotificationCallback Members
GrapeCity.ActiveReports.Extensibility.Layout Namespace


GrapeCity.ActiveReports.Extensibility.Layout.Areas Namespace

GrapeCity.ActiveReports.Extensibility.Layout.Areas Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Layout.Areas Namespace
The GrapeCity.ActiveReports.Extensibility.Layout.Areas namespace includes members that are used when the section reports layout is used.
Enumerations
 | Enumeration | Description
Enumeration | LayoutPageSectionType | Page sections.
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


LayoutPageSectionType Enumeration

LayoutPageSectionType Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout.Areas Namespace : LayoutPageSectionType Enumeration
Page sections.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LayoutPageSectionType
   Inherits System.Enum
public enum LayoutPageSectionType : System.Enum
Members
Member | Description
SectionBody | Designates page body.
SectionFooter | Designates page footer.
SectionHeader | Designates page header.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Layout.Areas.LayoutPageSectionType

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Layout.Areas Namespace


GrapeCity.ActiveReports.Extensibility.Printing Namespace

GrapeCity.ActiveReports.Extensibility.Printing Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Printing Namespace
The GrapeCity.ActiveReports.Extensibility.Printing namespace includes classes that are used when printing reports.
Classes
 | Class | Description
Class | Margin | Page margins.
Class | Printer | Summary description for Printer.
Class | PrintingThreadErrorEventArgs | Specifies argument of PrintingThreadErrorEventArgs.
Class | PrintOptions | Represents the advanced printing options.
Class | PrintProgressEventArgs | Specifies the arguments of the PrintProgress event.
Class | WatermarkOptions | Represents the watermark settings.
Delegates
 | Delegate | Description
Delegate | PrintingThreadErrorEventHandler | Specifies the arguments of the PrintThreadError event.
Delegate | PrintProgressEventHandler | Specifies the arguments of the PrintProgress event.
Enumerations
 | Enumeration | Description
Enumeration | PageOrder | Specifies page printing order
Enumeration | PageScaling | Specifies page scaling.
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


Margin Class

Margin Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : Margin Class
Page margins.
Object Model
Margin Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Margin
public sealed class Margin
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Printing.Margin

See Also

Reference

Margin Members
GrapeCity.ActiveReports.Extensibility.Printing Namespace


Margin Class Members

Margin Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : Margin Class

The following tables list the members exposed by Margin.

Public Constructors
 | Name | Description
Public Constructor | Margin Constructor | Initializes the new instance of Margin class.
Top
Public Properties
 | Name | Description
Public Property | Bottom | The bottom margin value.
Public Property | Left | The left margin value.
Public Property | Right | The right margin value.
Public Property | Top | The top margin value.
Top
See Also

Reference

Margin Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


Margin Constructor

Margin Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Margin Class : Margin Constructor
The left margin value.
The right margin value.
The top margin value.
The bottom margin value.
Initializes the new instance of Margin class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal left As System.Single, _
   ByVal right As System.Single, _
   ByVal top As System.Single, _
   ByVal bottom As System.Single _
)
public Margin(
   System.float left,
   System.float right,
   System.float top,
   System.float bottom
)

Parameters

left
The left margin value.
right
The right margin value.
top
The top margin value.
bottom
The bottom margin value.
See Also

Reference

Margin Class
Margin Members


Margin Class Properties

Margin Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : Margin Class

For a list of all members of this type, see Margin members.

Public Properties
 | Name | Description
Public Property | Bottom | The bottom margin value.
Public Property | Left | The left margin value.
Public Property | Right | The right margin value.
Public Property | Top | The top margin value.
Top
See Also

Reference

Margin Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


Bottom Property (Margin)

Bottom Property (Margin)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Margin Class : Bottom Property
The bottom margin value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Bottom As System.Single
public System.float Bottom {get;}
See Also

Reference

Margin Class
Margin Members


Left Property (Margin)

Left Property (Margin)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Margin Class : Left Property
The left margin value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Left As System.Single
public System.float Left {get;}
See Also

Reference

Margin Class
Margin Members


Right Property (Margin)

Right Property (Margin)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Margin Class : Right Property
The right margin value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Right As System.Single
public System.float Right {get;}
See Also

Reference

Margin Class
Margin Members


Top Property (Margin)

Top Property (Margin)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Margin Class : Top Property
The top margin value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Top As System.Single
public System.float Top {get;}
See Also

Reference

Margin Class
Margin Members


Printer Class

Printer Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : Printer Class
Summary description for Printer.
Object Model
Printer Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Printer
   Inherits System.Drawing.Printing.PrintDocument
public class Printer : System.Drawing.Printing.PrintDocument
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Drawing.Printing.PrintDocument
GrapeCity.ActiveReports.Extensibility.Printing.Printer

See Also

Reference

Printer Members
GrapeCity.ActiveReports.Extensibility.Printing Namespace


Printer Class Members

Printer Class Members
Properties Methods Events

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : Printer Class

The following tables list the members exposed by Printer.

Public Constructors
 | Name | Description
Public Constructor | Printer Constructor | Initializes a new instance of the Printer class.
Top
Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | DefaultPageSettings | (Inherited from System.Drawing.Printing.PrintDocument)
Public Property | DocumentName | (Inherited from System.Drawing.Printing.PrintDocument)
Public Property | Landscape | Specifies whether to print the page in landscape mode or portrait mode.
Public Property | OriginAtMargins | (Inherited from System.Drawing.Printing.PrintDocument)
Public Property | PaperHeight | Gets the height of the paper, in inches.
Public Property | PaperKind | Gets or sets the kind of paper to be used to print the report.
Public Property | PaperSize | Sets or returns the custom paper size object to be used to print the report.
Public Property | PaperSizes | Gets the paper sizes that are supported by this printer.
Public Property | PaperWidth | Gets the width of the paper, in inches.
Public Property | PrintController | Gets or sets the print controller that guides the printing process.
Public Property | PrinterName | Gets or sets the name of the printer to use.
Public Property | PrinterSettings | (Inherited from System.Drawing.Printing.PrintDocument)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | VisibleBounds | Gets the printable area of the page for the printer.
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Print | Starts the document's printing process. (Inherited from System.Drawing.Printing.PrintDocument)
Public Method | Reinitialize | Reinitializes an instance of the Printer class.
Public Method | ToString | (Inherited from System.Drawing.Printing.PrintDocument)
Top
Public Events
 | Name | Description
Public Event | BeginPrint | (Inherited from System.Drawing.Printing.PrintDocument)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | EndPrint | (Inherited from System.Drawing.Printing.PrintDocument)
Public Event | PrintPage | (Inherited from System.Drawing.Printing.PrintDocument)
Public Event | QueryPageSettings | (Inherited from System.Drawing.Printing.PrintDocument)
Top
See Also

Reference

Printer Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


Printer Constructor()

Printer Constructor()

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class > Printer Constructor : Printer Constructor()
Initializes a new instance of the Printer class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Printer()
See Also

Reference

Printer Class
Printer Members
Overload List


Printer Class Methods

Printer Class Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : Printer Class

For a list of all members of this type, see Printer members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Print | Starts the document's printing process. (Inherited from System.Drawing.Printing.PrintDocument)
Public Method | Reinitialize | Reinitializes an instance of the Printer class.
Public Method | ToString | (Inherited from System.Drawing.Printing.PrintDocument)
Top
See Also

Reference

Printer Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


Reinitialize Method

Reinitialize Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : Reinitialize Method
Reinitializes an instance of the Printer class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Reinitialize()
public void Reinitialize()
See Also

Reference

Printer Class
Printer Members


Printer Class Properties

Printer Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : Printer Class

For a list of all members of this type, see Printer members.

Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | DefaultPageSettings | (Inherited from System.Drawing.Printing.PrintDocument)
Public Property | DocumentName | (Inherited from System.Drawing.Printing.PrintDocument)
Public Property | Landscape | Specifies whether to print the page in landscape mode or portrait mode.
Public Property | OriginAtMargins | (Inherited from System.Drawing.Printing.PrintDocument)
Public Property | PaperHeight | Gets the height of the paper, in inches.
Public Property | PaperKind | Gets or sets the kind of paper to be used to print the report.
Public Property | PaperSize | Sets or returns the custom paper size object to be used to print the report.
Public Property | PaperSizes | Gets the paper sizes that are supported by this printer.
Public Property | PaperWidth | Gets the width of the paper, in inches.
Public Property | PrintController | Gets or sets the print controller that guides the printing process.
Public Property | PrinterName | Gets or sets the name of the printer to use.
Public Property | PrinterSettings | (Inherited from System.Drawing.Printing.PrintDocument)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | VisibleBounds | Gets the printable area of the page for the printer.
Top
See Also

Reference

Printer Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


Landscape Property (Printer)

Landscape Property (Printer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : Landscape Property
Specifies whether to print the page in landscape mode or portrait mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Landscape As System.Boolean
public System.bool Landscape {get; set;}
See Also

Reference

Printer Class
Printer Members


PaperHeight Property (Printer)

PaperHeight Property (Printer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : PaperHeight Property
Gets the height of the paper, in inches.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PaperHeight As System.Single
public System.float PaperHeight {get;}
See Also

Reference

Printer Class
Printer Members


PaperKind Property (Printer)

PaperKind Property (Printer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : PaperKind Property
Gets or sets the kind of paper to be used to print the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaperKind As System.Drawing.Printing.PaperKind
public System.Drawing.Printing.PaperKind PaperKind {get; set;}
See Also

Reference

Printer Class
Printer Members


PaperSize Property (Printer)

PaperSize Property (Printer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : PaperSize Property
Sets or returns the custom paper size object to be used to print the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaperSize As System.Drawing.Printing.PaperSize
public System.Drawing.Printing.PaperSize PaperSize {get; set;}
See Also

Reference

Printer Class
Printer Members


PaperSizes Property (Printer)

PaperSizes Property (Printer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : PaperSizes Property
Gets the paper sizes that are supported by this printer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PaperSizes As System.Drawing.Printing.PrinterSettings.PaperSizeCollection
public System.Drawing.Printing.PrinterSettings.PaperSizeCollection PaperSizes {get;}
See Also

Reference

Printer Class
Printer Members


PaperWidth Property (Printer)

PaperWidth Property (Printer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : PaperWidth Property
Gets the width of the paper, in inches.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PaperWidth As System.Single
public System.float PaperWidth {get;}
See Also

Reference

Printer Class
Printer Members


PrintController Property

PrintController Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : PrintController Property
Gets or sets the print controller that guides the printing process.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Property PrintController As System.Drawing.Printing.PrintController
public new System.Drawing.Printing.PrintController PrintController {get; set;}
See Also

Reference

Printer Class
Printer Members


PrinterName Property (Printer)

PrinterName Property (Printer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : PrinterName Property
Gets or sets the name of the printer to use.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrinterName As System.String
public System.string PrinterName {get; set;}
See Also

Reference

Printer Class
Printer Members


VisibleBounds Property

VisibleBounds Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : VisibleBounds Property
Gets the printable area of the page for the printer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property VisibleBounds As RectangleF
public RectangleF VisibleBounds {get;}
See Also

Reference

Printer Class
Printer Members


PrintingThreadErrorEventArgs Class

PrintingThreadErrorEventArgs Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintingThreadErrorEventArgs Class
Specifies argument of PrintingThreadErrorEventArgs.
Object Model
PrintingThreadErrorEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class PrintingThreadErrorEventArgs
   Inherits System.EventArgs
public class PrintingThreadErrorEventArgs : System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Extensibility.Printing.PrintingThreadErrorEventArgs

See Also

Reference

PrintingThreadErrorEventArgs Members
GrapeCity.ActiveReports.Extensibility.Printing Namespace


PrintingThreadErrorEventArgs Class Members

PrintingThreadErrorEventArgs Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintingThreadErrorEventArgs Class

The following tables list the members exposed by PrintingThreadErrorEventArgs.

Public Constructors
 | Name | Description
Public Constructor | PrintingThreadErrorEventArgs Constructor | Initializes the new instance of PrintingThreadErrorEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Exception | Gets or sets a value that specifies the exception that caused the printing thread error.
Top
See Also

Reference

PrintingThreadErrorEventArgs Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


PrintingThreadErrorEventArgs Constructor

PrintingThreadErrorEventArgs Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > PrintingThreadErrorEventArgs Class : PrintingThreadErrorEventArgs Constructor
Specifies the exception caused the printing thread error.
Initializes the new instance of PrintingThreadErrorEventArgs class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal exception As System.Exception _
)
public PrintingThreadErrorEventArgs(
   System.Exception exception
)

Parameters

exception
Specifies the exception caused the printing thread error.
See Also

Reference

PrintingThreadErrorEventArgs Class
PrintingThreadErrorEventArgs Members


PrintingThreadErrorEventArgs Class Properties

PrintingThreadErrorEventArgs Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintingThreadErrorEventArgs Class

For a list of all members of this type, see PrintingThreadErrorEventArgs members.

Public Properties
 | Name | Description
Public Property | Exception | Gets or sets a value that specifies the exception that caused the printing thread error.
Top
See Also

Reference

PrintingThreadErrorEventArgs Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


Exception Property (PrintingThreadErrorEventArgs)

Exception Property (PrintingThreadErrorEventArgs)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > PrintingThreadErrorEventArgs Class : Exception Property
Gets or sets a value that specifies the exception that caused the printing thread error.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Exception As System.Exception
public System.Exception Exception {get;}
See Also

Reference

PrintingThreadErrorEventArgs Class
PrintingThreadErrorEventArgs Members


PrintOptions Class

PrintOptions Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintOptions Class
Represents the advanced printing options.
Object Model
PrintOptions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class PrintOptions
public sealed class PrintOptions
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Printing.PrintOptions

See Also

Reference

PrintOptions Members
GrapeCity.ActiveReports.Extensibility.Printing Namespace


PrintOptions Class Members

PrintOptions Class Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintOptions Class

The following tables list the members exposed by PrintOptions.

Public Properties
 | Name | Description
Public Property | AutoRotate | Gets or sets the value that indicates whether the page content should be rotated according to the paper orientation.
Public Property | Margin | Gets or sets page margins.
Public Property | PageOrder | Gets or sets the value that indicates the order in which the pages will be laid out in multiple pages per sheet mode.
Public Property | PageScaling | Gets or sets the value that indicates the page scaling mode.
Public Property | PagesPerSheet | Gets or sets the value that indicates how many pages will be printed on a sinngle paper sheet.
Public Property | PrintPageBorder | Gets or sets the value indicates whether the page border should be printed.
Public Property | Watermark | Gets or sets the watermark options.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateDefault | Initializes the new instance of PrintOptions class with the default values.
Top
See Also

Reference

PrintOptions Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


PrintOptions Class Methods

PrintOptions Class Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintOptions Class

For a list of all members of this type, see PrintOptions members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateDefault | Initializes the new instance of PrintOptions class with the default values.
Top
See Also

Reference

PrintOptions Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


CreateDefault Method (PrintOptions)

CreateDefault Method (PrintOptions)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > PrintOptions Class : CreateDefault Method
Initializes the new instance of PrintOptions class with the default values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function CreateDefault() As PrintOptions
public static PrintOptions CreateDefault()
See Also

Reference

PrintOptions Class
PrintOptions Members


PrintOptions Class Properties

PrintOptions Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintOptions Class

For a list of all members of this type, see PrintOptions members.

Public Properties
 | Name | Description
Public Property | AutoRotate | Gets or sets the value that indicates whether the page content should be rotated according to the paper orientation.
Public Property | Margin | Gets or sets page margins.
Public Property | PageOrder | Gets or sets the value that indicates the order in which the pages will be laid out in multiple pages per sheet mode.
Public Property | PageScaling | Gets or sets the value that indicates the page scaling mode.
Public Property | PagesPerSheet | Gets or sets the value that indicates how many pages will be printed on a sinngle paper sheet.
Public Property | PrintPageBorder | Gets or sets the value indicates whether the page border should be printed.
Public Property | Watermark | Gets or sets the watermark options.
Top
See Also

Reference

PrintOptions Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


AutoRotate Property

AutoRotate Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > PrintOptions Class : AutoRotate Property
Gets or sets the value that indicates whether the page content should be rotated according to the paper orientation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoRotate As System.Boolean
public System.bool AutoRotate {get; set;}
See Also

Reference

PrintOptions Class
PrintOptions Members


Margin Property (PrintOptions)

Margin Property (PrintOptions)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > PrintOptions Class : Margin Property
Gets or sets page margins.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Margin As Margin
public Margin Margin {get; set;}
See Also

Reference

PrintOptions Class
PrintOptions Members


PageOrder Property

PageOrder Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > PrintOptions Class : PageOrder Property
Gets or sets the value that indicates the order in which the pages will be laid out in multiple pages per sheet mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageOrder As PageOrder
public PageOrder PageOrder {get; set;}
See Also

Reference

PrintOptions Class
PrintOptions Members


PageScaling Property

PageScaling Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > PrintOptions Class : PageScaling Property
Gets or sets the value that indicates the page scaling mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageScaling As PageScaling
public PageScaling PageScaling {get; set;}
See Also

Reference

PrintOptions Class
PrintOptions Members


PagesPerSheet Property

PagesPerSheet Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > PrintOptions Class : PagesPerSheet Property
Gets or sets the value that indicates how many pages will be printed on a sinngle paper sheet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PagesPerSheet As System.Integer
public System.int PagesPerSheet {get; set;}
See Also

Reference

PrintOptions Class
PrintOptions Members


PrintPageBorder Property

PrintPageBorder Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > PrintOptions Class : PrintPageBorder Property
Gets or sets the value indicates whether the page border should be printed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrintPageBorder As System.Boolean
public System.bool PrintPageBorder {get; set;}
See Also

Reference

PrintOptions Class
PrintOptions Members


Watermark Property (PrintOptions)

Watermark Property (PrintOptions)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > PrintOptions Class : Watermark Property
Gets or sets the watermark options.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Watermark As WatermarkOptions
public WatermarkOptions Watermark {get; set;}
See Also

Reference

PrintOptions Class
PrintOptions Members


PrintProgressEventArgs Class

PrintProgressEventArgs Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintProgressEventArgs Class
Specifies the arguments of the PrintProgress event.
Object Model
PrintProgressEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class PrintProgressEventArgs
   Inherits System.EventArgs
public sealed class PrintProgressEventArgs : System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Extensibility.Printing.PrintProgressEventArgs

See Also

Reference

PrintProgressEventArgs Members
GrapeCity.ActiveReports.Extensibility.Printing Namespace


PrintProgressEventArgs Class Members

PrintProgressEventArgs Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintProgressEventArgs Class

The following tables list the members exposed by PrintProgressEventArgs.

Public Constructors
 | Name | Description
Public Constructor | PrintProgressEventArgs Constructor | Creates a new instance of the PrintProgressEventArgs with progress set at the specified page.
Top
Public Properties
 | Name | Description
Public Property | CurrentPage | Gets the currently printing page.
Top
See Also

Reference

PrintProgressEventArgs Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


PrintProgressEventArgs Constructor

PrintProgressEventArgs Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > PrintProgressEventArgs Class : PrintProgressEventArgs Constructor
Current printing page.
Creates a new instance of the PrintProgressEventArgs with progress set at the specified page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal currentPage As System.Integer _
)
public PrintProgressEventArgs(
   System.int currentPage
)

Parameters

currentPage
Current printing page.
See Also

Reference

PrintProgressEventArgs Class
PrintProgressEventArgs Members


PrintProgressEventArgs Class Properties

PrintProgressEventArgs Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintProgressEventArgs Class

For a list of all members of this type, see PrintProgressEventArgs members.

Public Properties
 | Name | Description
Public Property | CurrentPage | Gets the currently printing page.
Top
See Also

Reference

PrintProgressEventArgs Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


CurrentPage Property (PrintProgressEventArgs)

CurrentPage Property (PrintProgressEventArgs)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > PrintProgressEventArgs Class : CurrentPage Property
Gets the currently printing page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CurrentPage As System.Integer
public System.int CurrentPage {get;}
See Also

Reference

PrintProgressEventArgs Class
PrintProgressEventArgs Members


WatermarkOptions Class

WatermarkOptions Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : WatermarkOptions Class
Represents the watermark settings.
Object Model
WatermarkOptions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class WatermarkOptions
public sealed class WatermarkOptions
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Printing.WatermarkOptions

See Also

Reference

WatermarkOptions Members
GrapeCity.ActiveReports.Extensibility.Printing Namespace


WatermarkOptions Class Members

WatermarkOptions Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : WatermarkOptions Class

The following tables list the members exposed by WatermarkOptions.

Public Constructors
 | Name | Description
Public Constructor | WatermarkOptions Constructor | Initializes the new instance of WatermarkOptions class.
Top
Public Properties
 | Name | Description
Public Property | Angle | Test rotation angle, degrees, counter-clockwise
Public Property | Color | Gets or sets the watermark color
Public Property | DrawOver | If property is true watermark sign will be painted on the pages over report content, else watermark will be painted on the pages before all other report content
Public Property | Font | Gets or sets the watermark font
Public Property | Title | Watermark text
Top
See Also

Reference

WatermarkOptions Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


WatermarkOptions Constructor

WatermarkOptions Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > WatermarkOptions Class : WatermarkOptions Constructor
Initializes the new instance of WatermarkOptions class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public WatermarkOptions()
See Also

Reference

WatermarkOptions Class
WatermarkOptions Members


WatermarkOptions Class Properties

WatermarkOptions Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : WatermarkOptions Class

For a list of all members of this type, see WatermarkOptions members.

Public Properties
 | Name | Description
Public Property | Angle | Test rotation angle, degrees, counter-clockwise
Public Property | Color | Gets or sets the watermark color
Public Property | DrawOver | If property is true watermark sign will be painted on the pages over report content, else watermark will be painted on the pages before all other report content
Public Property | Font | Gets or sets the watermark font
Public Property | Title | Watermark text
Top
See Also

Reference

WatermarkOptions Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


Angle Property (WatermarkOptions)

Angle Property (WatermarkOptions)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > WatermarkOptions Class : Angle Property
Test rotation angle, degrees, counter-clockwise
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Angle As System.Single
public System.float Angle {get; set;}
See Also

Reference

WatermarkOptions Class
WatermarkOptions Members


Color Property (WatermarkOptions)

Color Property (WatermarkOptions)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > WatermarkOptions Class : Color Property
Gets or sets the watermark color
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Color As Color
public Color Color {get; set;}
See Also

Reference

WatermarkOptions Class
WatermarkOptions Members


DrawOver Property

DrawOver Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > WatermarkOptions Class : DrawOver Property
If property is true watermark sign will be painted on the pages over report content, else watermark will be painted on the pages before all other report content
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DrawOver As System.Boolean
public System.bool DrawOver {get; set;}
See Also

Reference

WatermarkOptions Class
WatermarkOptions Members


Font Property (WatermarkOptions)

Font Property (WatermarkOptions)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > WatermarkOptions Class : Font Property
Gets or sets the watermark font
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Font As Font
public Font Font {get; set;}
See Also

Reference

WatermarkOptions Class
WatermarkOptions Members


Title Property (WatermarkOptions)

Title Property (WatermarkOptions)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > WatermarkOptions Class : Title Property
Watermark text
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Title As System.String
public System.string Title {get; set;}
See Also

Reference

WatermarkOptions Class
WatermarkOptions Members


PageOrder Enumeration

PageOrder Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PageOrder Enumeration
Specifies page printing order
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PageOrder
   Inherits System.Enum
public enum PageOrder : System.Enum
Members
Member | Description
Horizontal | Horizontal order.
HorizontalReversed | Reversed horizontal order.
Vertical | Vertical order.
VerticalReversed | Vertical reversed order.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Printing.PageOrder

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Printing Namespace


PageScaling Enumeration

PageScaling Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PageScaling Enumeration
Specifies page scaling.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PageScaling
   Inherits System.Enum
public enum PageScaling : System.Enum
Members
Member | Description
Booklet | Booklet mode.
FitToPrintableArea | Mode that scales small pages up and large pages down to fit the paper.
MultiplePages | Multiple pages per sheet mode.
None | No scaling mode.
ShrinkToPrintableArea | Mode that resizes only large pages to fit the paper and prints small pages as they are.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Printing.PageScaling

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Printing Namespace


PrintingThreadErrorEventHandler Delegate

PrintingThreadErrorEventHandler Delegate

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintingThreadErrorEventHandler Delegate
The source of the event.
The object that contains the event data.
Specifies the arguments of the PrintThreadError event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub PrintingThreadErrorEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As PrintingThreadErrorEventArgs _
)
public delegate void PrintingThreadErrorEventHandler(
   System.object sender,
   PrintingThreadErrorEventArgs e
)

Parameters

sender
The source of the event.
e
The object that contains the event data.
See Also

Reference

PrintingThreadErrorEventHandler Members
GrapeCity.ActiveReports.Extensibility.Printing Namespace


PrintProgressEventHandler Delegate

PrintProgressEventHandler Delegate

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : PrintProgressEventHandler Delegate
The source of the event.
The object that contains the event data.
Specifies the arguments of the PrintProgress event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub PrintProgressEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As PrintProgressEventArgs _
)
public delegate void PrintProgressEventHandler(
   System.object sender,
   PrintProgressEventArgs e
)

Parameters

sender
The source of the event.
e
The object that contains the event data.
See Also

Reference

PrintProgressEventHandler Members
GrapeCity.ActiveReports.Extensibility.Printing Namespace


GrapeCity.ActiveReports.Extensibility.Rendering Namespace

GrapeCity.ActiveReports.Extensibility.Rendering Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Rendering Namespace
The GrapeCity.ActiveReports.Extensibility.Rendering namespace includes classes that are used when rendering reports.
Classes
 | Class | Description
Class | CustomData | Specifies the data for a custom data region.
Class | CustomProperty | Interface for custom properties.
Class | DataMember | Represents a heading member on the row or column axis of the CustomData structure.
Class | ImageMapAreaCollection | Defines a collection of GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity.IImageMapArea objects
Class | RenderingPageEventArgs | Encapsulates rendering page event data
Interfaces
 | Interface | Description
Interface | IConfigurable | Interface for configurable components.
Interface | IEmbeddedImageStorage | Represents service to resolve embedded images stored in document.
Interface | IGroup | Interface for groups.
Interface | IPropertyBag | Represents a way to retrieve property values.
Interface | IReadOnlyReportItemCollection | Interface for a collection of read-only DataDynamics.Reports.Extensibility.Rendering.Components.IReportItem objects.
Interface | IRenderingExtension | Interface for rendering extention objects.
Interface | IReportInformationService | Service that returns Global variables and user specific information.
Interface | ISettings | Interface for settings.
Structures
 | Structure | Description
Structure | ImageInfo | Contains information about an image.
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


CustomData Class

CustomData Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : CustomData Class
Specifies the data for a custom data region.
Object Model
CustomData Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class CustomData
public abstract class CustomData
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.CustomData

See Also

Reference

CustomData Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


CustomData Class Members

CustomData Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : CustomData Class

The following tables list the members exposed by CustomData.

Public Properties
 | Name | Description
Public Property | DataCells | Contains the cells contained in the detail-data area of the CustomData structure.
Public Property | DataColumnGroupings | Returns the groupings on the column axis for the CustomData structure.
Public Property | DataRowGroupings | Returns the groupings on the row axis for the CustomData structure.
Public Property | NoRows | Indicates no data is available for this data region.
Top
See Also

Reference

CustomData Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


CustomData Class Properties

CustomData Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : CustomData Class

For a list of all members of this type, see CustomData members.

Public Properties
 | Name | Description
Public Property | DataCells | Contains the cells contained in the detail-data area of the CustomData structure.
Public Property | DataColumnGroupings | Returns the groupings on the column axis for the CustomData structure.
Public Property | DataRowGroupings | Returns the groupings on the row axis for the CustomData structure.
Public Property | NoRows | Indicates no data is available for this data region.
Top
See Also

Reference

CustomData Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


DataCells Property (CustomData)

DataCells Property (CustomData)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > CustomData Class : DataCells Property
Contains the cells contained in the detail-data area of the CustomData structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property DataCells As DataCellCollection
public abstract DataCellCollection DataCells {get;}
See Also

Reference

CustomData Class
CustomData Members


DataColumnGroupings Property (CustomData)

DataColumnGroupings Property (CustomData)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > CustomData Class : DataColumnGroupings Property
Returns the groupings on the column axis for the CustomData structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property DataColumnGroupings As DataGroupingCollection
public abstract DataGroupingCollection DataColumnGroupings {get;}
See Also

Reference

CustomData Class
CustomData Members


DataRowGroupings Property (CustomData)

DataRowGroupings Property (CustomData)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > CustomData Class : DataRowGroupings Property
Returns the groupings on the row axis for the CustomData structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property DataRowGroupings As DataGroupingCollection
public abstract DataGroupingCollection DataRowGroupings {get;}
See Also

Reference

CustomData Class
CustomData Members


NoRows Property (CustomData)

NoRows Property (CustomData)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > CustomData Class : NoRows Property
Indicates no data is available for this data region.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property NoRows As System.Boolean
public abstract System.bool NoRows {get;}
See Also

Reference

CustomData Class
CustomData Members


CustomProperty Class

CustomProperty Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : CustomProperty Class
Interface for custom properties.
Object Model
CustomProperty Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class CustomProperty
public sealed class CustomProperty
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.CustomProperty

See Also

Reference

CustomProperty Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


CustomProperty Class Members

CustomProperty Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : CustomProperty Class

The following tables list the members exposed by CustomProperty.

Public Properties
 | Name | Description
Public Property | Name | Returns the name of this property.
Public Property | Value | Returns the value of this property.
Top
See Also

Reference

CustomProperty Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


CustomProperty Class Properties

CustomProperty Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : CustomProperty Class

For a list of all members of this type, see CustomProperty members.

Public Properties
 | Name | Description
Public Property | Name | Returns the name of this property.
Public Property | Value | Returns the value of this property.
Top
See Also

Reference

CustomProperty Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


Name Property (CustomProperty)

Name Property (CustomProperty)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > CustomProperty Class : Name Property
Returns the name of this property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Name As System.String
public System.string Name {get;}
See Also

Reference

CustomProperty Class
CustomProperty Members


Value Property (CustomProperty)

Value Property (CustomProperty)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > CustomProperty Class : Value Property
Returns the value of this property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Value As System.Object
public System.object Value {get;}
See Also

Reference

CustomProperty Class
CustomProperty Members


DataMember Class

DataMember Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : DataMember Class
Represents a heading member on the row or column axis of the CustomData structure.
Object Model
DataMember Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class DataMember
public abstract class DataMember
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.DataMember

See Also

Reference

DataMember Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


DataMember Class Members

DataMember Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : DataMember Class

The following tables list the members exposed by DataMember.

Public Properties
 | Name | Description
Public Property | Children | Returns the members contained within this member.
Public Property | CustomProperties | Returns the custom properties for this member.
Public Property | DataElementName | The name to use for the data element or attribute for this data member when rendered via a data oriented rendering extension (e.g. XML).
Public Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device.
Public Property | Hidden | Indicates the current hidden state of this member. The value can change via toggling.
Public Property | IsStatic | Indicates this member is part of a static grouping. It will repeat for every instance of its parent member.
Public Property | IsTotal | Indicates whether this member shows subtotal values or a value for a particular member.
Public Property | MemberCellIndex | Indicates the cell (within CustomData.DataCells) that this member starts at.
Public Property | MemberHeadingSpan | The number of leaf groups this member spans (will always be at least one).
Public Property | Parent | Gets the parent of this member.
Top
See Also

Reference

DataMember Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


DataMember Class Properties

DataMember Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : DataMember Class

For a list of all members of this type, see DataMember members.

Public Properties
 | Name | Description
Public Property | Children | Returns the members contained within this member.
Public Property | CustomProperties | Returns the custom properties for this member.
Public Property | DataElementName | The name to use for the data element or attribute for this data member when rendered via a data oriented rendering extension (e.g. XML).
Public Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device.
Public Property | Hidden | Indicates the current hidden state of this member. The value can change via toggling.
Public Property | IsStatic | Indicates this member is part of a static grouping. It will repeat for every instance of its parent member.
Public Property | IsTotal | Indicates whether this member shows subtotal values or a value for a particular member.
Public Property | MemberCellIndex | Indicates the cell (within CustomData.DataCells) that this member starts at.
Public Property | MemberHeadingSpan | The number of leaf groups this member spans (will always be at least one).
Public Property | Parent | Gets the parent of this member.
Top
See Also

Reference

DataMember Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


Children Property (DataMember)

Children Property (DataMember)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataMember Class : Children Property
Returns the members contained within this member.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property Children As DataGroupingCollection
public abstract DataGroupingCollection Children {get;}
See Also

Reference

DataMember Class
DataMember Members


CustomProperties Property (DataMember)

CustomProperties Property (DataMember)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataMember Class : CustomProperties Property
Returns the custom properties for this member.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property CustomProperties As CustomPropertyCollection
public abstract CustomPropertyCollection CustomProperties {get;}
See Also

Reference

DataMember Class
DataMember Members


DataElementName Property (DataMember)

DataElementName Property (DataMember)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataMember Class : DataElementName Property
The name to use for the data element or attribute for this data member when rendered via a data oriented rendering extension (e.g. XML).
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property DataElementName As System.String
public abstract System.string DataElementName {get;}
See Also

Reference

DataMember Class
DataMember Members


DataElementOutput Property (DataMember)

DataElementOutput Property (DataMember)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataMember Class : DataElementOutput Property
Indicates how this item should appear when rendered with a data oriented rendering device.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property DataElementOutput As DataElementOutput
public abstract DataElementOutput DataElementOutput {get;}
See Also

Reference

DataMember Class
DataMember Members


Hidden Property (DataMember)

Hidden Property (DataMember)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataMember Class : Hidden Property
Indicates the current hidden state of this member. The value can change via toggling.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property Hidden As System.Boolean
public abstract System.bool Hidden {get;}
See Also

Reference

DataMember Class
DataMember Members


IsStatic Property (DataMember)

IsStatic Property (DataMember)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataMember Class : IsStatic Property
Indicates this member is part of a static grouping. It will repeat for every instance of its parent member.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property IsStatic As System.Boolean
public abstract System.bool IsStatic {get;}
See Also

Reference

DataMember Class
DataMember Members


IsTotal Property (DataMember)

IsTotal Property (DataMember)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataMember Class : IsTotal Property
Indicates whether this member shows subtotal values or a value for a particular member.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property IsTotal As System.Boolean
public abstract System.bool IsTotal {get;}
See Also

Reference

DataMember Class
DataMember Members


MemberCellIndex Property (DataMember)

MemberCellIndex Property (DataMember)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataMember Class : MemberCellIndex Property
Indicates the cell (within CustomData.DataCells) that this member starts at.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property MemberCellIndex As System.Integer
public abstract System.int MemberCellIndex {get;}
See Also

Reference

DataMember Class
DataMember Members
MemberHeadingSpan Property


MemberHeadingSpan Property (DataMember)

MemberHeadingSpan Property (DataMember)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataMember Class : MemberHeadingSpan Property
The number of leaf groups this member spans (will always be at least one).
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property MemberHeadingSpan As System.Integer
public abstract System.int MemberHeadingSpan {get;}
See Also

Reference

DataMember Class
DataMember Members


Parent Property (DataMember)

Parent Property (DataMember)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > DataMember Class : Parent Property
Gets the parent of this member.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property Parent As DataMember
public abstract DataMember Parent {get;}
See Also

Reference

DataMember Class
DataMember Members


ImageMapAreaCollection Class

ImageMapAreaCollection Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ImageMapAreaCollection Class
Defines a collection of GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity.IImageMapArea objects
Object Model
ImageMapAreaCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class ImageMapAreaCollection
   Inherits System.Collections.CollectionBase
public abstract class ImageMapAreaCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.ImageMapAreaCollection

See Also

Reference

ImageMapAreaCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


ImageMapAreaCollection Class Members

ImageMapAreaCollection Class Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ImageMapAreaCollection Class

The following tables list the members exposed by ImageMapAreaCollection.

Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets the GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity.IImageMapArea at the specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds the specified GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity.IImageMapArea to the ImageMapAreaCollection
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ImageMapAreaCollection Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


ImageMapAreaCollection Class Methods

ImageMapAreaCollection Class Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ImageMapAreaCollection Class

For a list of all members of this type, see ImageMapAreaCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds the specified GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity.IImageMapArea to the ImageMapAreaCollection
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ImageMapAreaCollection Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


Add Method (ImageMapAreaCollection)

Add Method (ImageMapAreaCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ImageMapAreaCollection Class : Add Method
The GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity.IImageMapArea to add.
Adds the specified GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity.IImageMapArea to the ImageMapAreaCollection
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Function Add( _
   ByVal imageMapArea As IImageMapArea _
) As System.Integer
public abstract System.int Add(
   IImageMapArea imageMapArea
)

Parameters

imageMapArea
The GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity.IImageMapArea to add.

Return Value

The index of the newly added GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity.IImageMapArea.
See Also

Reference

ImageMapAreaCollection Class
ImageMapAreaCollection Members


ImageMapAreaCollection Class Properties

ImageMapAreaCollection Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ImageMapAreaCollection Class

For a list of all members of this type, see ImageMapAreaCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets the GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity.IImageMapArea at the specified index.
Top
See Also

Reference

ImageMapAreaCollection Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


Item Property (ImageMapAreaCollection)

Item Property (ImageMapAreaCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ImageMapAreaCollection Class : Item Property
The index of the element to get.
Gets the GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity.IImageMapArea at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Default Property Item( _
   ByVal index As System.Integer _
) As IImageMapArea
public abstract IImageMapArea this[
   System.int index
]; {get; set;}

Parameters

index
The index of the element to get.

Property Value

The GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity.IImageMapArea at the specified index.
See Also

Reference

ImageMapAreaCollection Class
ImageMapAreaCollection Members


RenderingPageEventArgs Class

RenderingPageEventArgs Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : RenderingPageEventArgs Class
Encapsulates rendering page event data
Object Model
RenderingPageEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class RenderingPageEventArgs
   Inherits System.EventArgs
public sealed class RenderingPageEventArgs : System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Extensibility.Rendering.RenderingPageEventArgs

See Also

Reference

RenderingPageEventArgs Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


RenderingPageEventArgs Class Members

RenderingPageEventArgs Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : RenderingPageEventArgs Class

The following tables list the members exposed by RenderingPageEventArgs.

Public Constructors
 | Name | Description
Public Constructor | RenderingPageEventArgs Constructor | Initalizes rendering event data with specified page
Top
Public Properties
 | Name | Description
Public Property | Cancel | Specifies that further processing should be canceled
Public Property | CurrentPage | Specifies a page number for which event was raised
Top
See Also

Reference

RenderingPageEventArgs Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


RenderingPageEventArgs Constructor

RenderingPageEventArgs Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > RenderingPageEventArgs Class : RenderingPageEventArgs Constructor
Specifies the page number for which event was raised.
Initalizes rendering event data with specified page
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal currentPage As System.Integer _
)
public RenderingPageEventArgs(
   System.int currentPage
)

Parameters

currentPage
Specifies the page number for which event was raised.
See Also

Reference

RenderingPageEventArgs Class
RenderingPageEventArgs Members


RenderingPageEventArgs Class Properties

RenderingPageEventArgs Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : RenderingPageEventArgs Class

For a list of all members of this type, see RenderingPageEventArgs members.

Public Properties
 | Name | Description
Public Property | Cancel | Specifies that further processing should be canceled
Public Property | CurrentPage | Specifies a page number for which event was raised
Top
See Also

Reference

RenderingPageEventArgs Class
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


Cancel Property (RenderingPageEventArgs)

Cancel Property (RenderingPageEventArgs)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > RenderingPageEventArgs Class : Cancel Property
Specifies that further processing should be canceled
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Cancel As System.Boolean
public System.bool Cancel {get; set;}
See Also

Reference

RenderingPageEventArgs Class
RenderingPageEventArgs Members


CurrentPage Property (RenderingPageEventArgs)

CurrentPage Property (RenderingPageEventArgs)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > RenderingPageEventArgs Class : CurrentPage Property
Specifies a page number for which event was raised
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CurrentPage As System.Integer
public System.int CurrentPage {get;}
See Also

Reference

RenderingPageEventArgs Class
RenderingPageEventArgs Members


ImageInfo Structure

ImageInfo Structure
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ImageInfo Structure
Contains information about an image.
Object Model
ImageInfo Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure ImageInfo
   Inherits System.ValueType
public struct ImageInfo : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Rendering.ImageInfo

See Also

Reference

ImageInfo Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


ImageInfo Structure Members

ImageInfo Structure Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ImageInfo Structure

The following tables list the members exposed by ImageInfo.

Public Constructors
 | Name | Description
Public Constructor | ImageInfo Constructor | Gets the mime type of the image.
Top
Public Properties
 | Name | Description
Public Property | MimeType | Gets the mime type of the image.
Public Property | Stream | Gets the stream that contains the image data.
Top
See Also

Reference

ImageInfo Structure
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


ImageInfo Constructor

ImageInfo Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ImageInfo Structure : ImageInfo Constructor
The System.IO.Stream that contains the image data.
The mime type of the image.
Gets the mime type of the image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal stream As System.IO.Stream, _
   ByVal mimeType As System.String _
)
public ImageInfo(
   System.IO.Stream stream,
   System.string mimeType
)

Parameters

stream
The System.IO.Stream that contains the image data.
mimeType
The mime type of the image.
See Also

Reference

ImageInfo Structure
ImageInfo Members


ImageInfo Structure Properties

ImageInfo Structure Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ImageInfo Structure

For a list of all members of this type, see ImageInfo members.

Public Properties
 | Name | Description
Public Property | MimeType | Gets the mime type of the image.
Public Property | Stream | Gets the stream that contains the image data.
Top
See Also

Reference

ImageInfo Structure
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


MimeType Property (ImageInfo)

MimeType Property (ImageInfo)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ImageInfo Structure : MimeType Property
Gets the mime type of the image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MimeType As System.String
public System.string MimeType {get;}
See Also

Reference

ImageInfo Structure
ImageInfo Members


Stream Property

Stream Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ImageInfo Structure : Stream Property
Gets the stream that contains the image data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Stream As System.IO.Stream
public System.IO.Stream Stream {get;}
See Also

Reference

ImageInfo Structure
ImageInfo Members


IConfigurable Interface

IConfigurable Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IConfigurable Interface
Interface for configurable components.
Object Model
IConfigurable Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IConfigurable
public interface IConfigurable
See Also

Reference

IConfigurable Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IConfigurable Interface Members

IConfigurable Interface Members
Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IConfigurable Interface

The following tables list the members exposed by IConfigurable.

Public Methods
 | Name | Description
Method | GetSupportedSettings | Returns the settings supported by a rendering extension.
Top
See Also

Reference

IConfigurable Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IConfigurable Interface Methods

IConfigurable Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IConfigurable Interface

For a list of all members of this type, see IConfigurable members.

Public Methods
 | Name | Description
Method | GetSupportedSettings | Returns the settings supported by a rendering extension.
Top
See Also

Reference

IConfigurable Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


GetSupportedSettings() Method

GetSupportedSettings() Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IConfigurable Interface > GetSupportedSettings Method : GetSupportedSettings() Method
Returns the settings supported by a rendering extension.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function GetSupportedSettings() As ISettings
ISettings GetSupportedSettings()

Return Value

a DataDynamics.Reports.Extensibility.Rendering.ISettings to provide access to the rendering extension settings.
See Also

Reference

IConfigurable Interface
IConfigurable Members
Overload List


IEmbeddedImageStorage Interface

IEmbeddedImageStorage Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IEmbeddedImageStorage Interface
Represents service to resolve embedded images stored in document.
Object Model
IEmbeddedImageStorage Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IEmbeddedImageStorage
public interface IEmbeddedImageStorage
See Also

Reference

IEmbeddedImageStorage Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IEmbeddedImageStorage Interface Members

IEmbeddedImageStorage Interface Members
Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IEmbeddedImageStorage Interface

The following tables list the members exposed by IEmbeddedImageStorage.

Public Methods
 | Name | Description
Method | GetImageData | Gets image bytes by specified key.
Top
See Also

Reference

IEmbeddedImageStorage Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IEmbeddedImageStorage Interface Methods

IEmbeddedImageStorage Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IEmbeddedImageStorage Interface

For a list of all members of this type, see IEmbeddedImageStorage members.

Public Methods
 | Name | Description
Method | GetImageData | Gets image bytes by specified key.
Top
See Also

Reference

IEmbeddedImageStorage Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


GetImageData Method

GetImageData Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IEmbeddedImageStorage Interface : GetImageData Method
The key to resolve image bytes.
Gets image bytes by specified key.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetImageData( _
   ByVal key As System.String _
) As System.Byte()
System.byte[] GetImageData(
   System.string key
)

Parameters

key
The key to resolve image bytes.

Return Value

null or resolved image bytes.
See Also

Reference

IEmbeddedImageStorage Interface
IEmbeddedImageStorage Members


IGroup Interface

IGroup Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IGroup Interface
Interface for groups.
Object Model
IGroup Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IGroup
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem
public interface IGroup : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem
See Also

Reference

IGroup Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IGroup Interface Members

IGroup Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IGroup Interface

The following tables list the members exposed by IGroup.

Public Properties
 | Name | Description
Property | Custom | String of custom data.
Property | CustomProperties | Collection of custom properties.
Property | DataCollectionName | Returns the name of the data collection associated with this group.
Property | DataElementName | Returns the name of the data element associated with this group.
Property | DataElementOutput | Returns the name used for this group.
Property | Hidden | Indicates that the group should be hidden.
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | LabelValue | Gets the value representing the label for this member.
Property | Name | Returns the name used for this group.
Property | PageBreakAtEnd | Indicates the report should page break at end of the group.
Property | PageBreakAtStart | Indicates the report should page break at start of the group.
Top
See Also

Reference

IGroup Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IGroup Interface Properties

IGroup Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IGroup Interface

For a list of all members of this type, see IGroup members.

Public Properties
 | Name | Description
Property | Custom | String of custom data.
Property | CustomProperties | Collection of custom properties.
Property | DataCollectionName | Returns the name of the data collection associated with this group.
Property | DataElementName | Returns the name of the data element associated with this group.
Property | DataElementOutput | Returns the name used for this group.
Property | Hidden | Indicates that the group should be hidden.
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | LabelValue | Gets the value representing the label for this member.
Property | Name | Returns the name used for this group.
Property | PageBreakAtEnd | Indicates the report should page break at end of the group.
Property | PageBreakAtStart | Indicates the report should page break at start of the group.
Top
See Also

Reference

IGroup Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


Custom Property (IGroup)

Custom Property (IGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IGroup Interface : Custom Property
String of custom data.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Custom As System.String
System.string Custom {get;}
See Also

Reference

IGroup Interface
IGroup Members


CustomProperties Property (IGroup)

CustomProperties Property (IGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IGroup Interface : CustomProperties Property
Collection of custom properties.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CustomProperties As CustomPropertyCollection
CustomPropertyCollection CustomProperties {get;}
See Also

Reference

IGroup Interface
IGroup Members


DataCollectionName Property (IGroup)

DataCollectionName Property (IGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IGroup Interface : DataCollectionName Property
Returns the name of the data collection associated with this group.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataCollectionName As System.String
System.string DataCollectionName {get;}
See Also

Reference

IGroup Interface
IGroup Members


DataElementName Property (IGroup)

DataElementName Property (IGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IGroup Interface : DataElementName Property
Returns the name of the data element associated with this group.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataElementName As System.String
System.string DataElementName {get;}
See Also

Reference

IGroup Interface
IGroup Members


DataElementOutput Property (IGroup)

DataElementOutput Property (IGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IGroup Interface : DataElementOutput Property
Returns the name used for this group.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataElementOutput As DataElementOutput
DataElementOutput DataElementOutput {get;}
See Also

Reference

IGroup Interface
IGroup Members


Hidden Property (IGroup)

Hidden Property (IGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IGroup Interface : Hidden Property
Indicates that the group should be hidden.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Hidden As System.Boolean
System.bool Hidden {get;}
See Also

Reference

IGroup Interface
IGroup Members


LabelValue Property

LabelValue Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IGroup Interface : LabelValue Property
Gets the value representing the label for this member.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LabelValue As System.Object
System.object LabelValue {get;}
See Also

Reference

IGroup Interface
IGroup Members


Name Property (IGroup)

Name Property (IGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IGroup Interface : Name Property
Returns the name used for this group.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Name As System.String
System.string Name {get;}
See Also

Reference

IGroup Interface
IGroup Members


PageBreakAtEnd Property (IGroup)

PageBreakAtEnd Property (IGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IGroup Interface : PageBreakAtEnd Property
Indicates the report should page break at end of the group.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PageBreakAtEnd As System.Boolean
System.bool PageBreakAtEnd {get;}
See Also

Reference

IGroup Interface
IGroup Members


PageBreakAtStart Property (IGroup)

PageBreakAtStart Property (IGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IGroup Interface : PageBreakAtStart Property
Indicates the report should page break at start of the group.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PageBreakAtStart As System.Boolean
System.bool PageBreakAtStart {get;}
See Also

Reference

IGroup Interface
IGroup Members


IPropertyBag Interface

IPropertyBag Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IPropertyBag Interface
Represents a way to retrieve property values.
Object Model
IPropertyBag Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IPropertyBag
public interface IPropertyBag
See Also

Reference

IPropertyBag Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IPropertyBag Interface Members

IPropertyBag Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IPropertyBag Interface

The following tables list the members exposed by IPropertyBag.

Public Properties
 | Name | Description
Property | PropertyNames | Gets names of the properties contained in the bag.
Top
Public Methods
 | Name | Description
Method | GetPropertyContent | Get the content for the named property without evaluation.
Method | GetValue | Get the value for the named property.
Top
See Also

Reference

IPropertyBag Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IPropertyBag Interface Methods

IPropertyBag Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IPropertyBag Interface

For a list of all members of this type, see IPropertyBag members.

Public Methods
 | Name | Description
Method | GetPropertyContent | Get the content for the named property without evaluation.
Method | GetValue | Get the value for the named property.
Top
See Also

Reference

IPropertyBag Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


GetPropertyContent Method

GetPropertyContent Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IPropertyBag Interface : GetPropertyContent Method
Name of the property to retrieve.
Get the content for the named property without evaluation.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetPropertyContent( _
   ByVal name As System.String _
) As System.Object
System.object GetPropertyContent(
   System.string name
)

Parameters

name
Name of the property to retrieve.

Return Value

The property's value.
See Also

Reference

IPropertyBag Interface
IPropertyBag Members


GetValue Method (IPropertyBag)

GetValue Method (IPropertyBag)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IPropertyBag Interface : GetValue Method
Name of the property to retrieve.
Get the value for the named property.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetValue( _
   ByVal name As System.String _
) As System.Object
System.object GetValue(
   System.string name
)

Parameters

name
Name of the property to retrieve.

Return Value

The property's value.
See Also

Reference

IPropertyBag Interface
IPropertyBag Members


IPropertyBag Interface Properties

IPropertyBag Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IPropertyBag Interface

For a list of all members of this type, see IPropertyBag members.

Public Properties
 | Name | Description
Property | PropertyNames | Gets names of the properties contained in the bag.
Top
See Also

Reference

IPropertyBag Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


PropertyNames Property

PropertyNames Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IPropertyBag Interface : PropertyNames Property
Gets names of the properties contained in the bag.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PropertyNames As System.Collections.Generic.IEnumerable(Of String)
System.Collections.Generic.IEnumerable<string> PropertyNames {get;}
See Also

Reference

IPropertyBag Interface
IPropertyBag Members


IReadOnlyReportItemCollection Interface

IReadOnlyReportItemCollection Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IReadOnlyReportItemCollection Interface
Interface for a collection of read-only DataDynamics.Reports.Extensibility.Rendering.Components.IReportItem objects.
Object Model
IReadOnlyReportItemCollection Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IReadOnlyReportItemCollection
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection(Of IReportItem)
public interface IReadOnlyReportItemCollection : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<IReportItem>
See Also

Reference

IReadOnlyReportItemCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IReadOnlyReportItemCollection Interface Members

IReadOnlyReportItemCollection Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IReadOnlyReportItemCollection Interface

The following tables list the members exposed by IReadOnlyReportItemCollection.

Public Properties
 | Name | Description
Property | Count | Gets number of items in the collection. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<IReportItem>)
Property | Item | Gets the T at the specified index. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<IReportItem>)
Top
See Also

Reference

IReadOnlyReportItemCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IRenderingExtension Interface

IRenderingExtension Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IRenderingExtension Interface
Interface for rendering extention objects.
Object Model
IRenderingExtension Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IRenderingExtension
public interface IRenderingExtension
See Also

Reference

IRenderingExtension Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IRenderingExtension Interface Members

IRenderingExtension Interface Members
Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IRenderingExtension Interface

The following tables list the members exposed by IRenderingExtension.

Public Methods
 | Name | Description
Method | Render | Overloaded. Renders the report
Top
See Also

Reference

IRenderingExtension Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IRenderingExtension Interface Methods

IRenderingExtension Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IRenderingExtension Interface

For a list of all members of this type, see IRenderingExtension members.

Public Methods
 | Name | Description
Method | Render | Overloaded. Renders the report
Top
See Also

Reference

IRenderingExtension Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


Render Method (IRenderingExtension)

Render Method (IRenderingExtension)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IRenderingExtension Interface : Render Method
Renders the report
Overload List
Overload | Description
Render(IReport,StreamProvider) | Renders the report.
Render(IReport,StreamProvider,NameValueCollection) | Renders the report.
See Also

Reference

IRenderingExtension Interface
IRenderingExtension Members


Render(IReport,StreamProvider) Method

Render(IReport,StreamProvider) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IRenderingExtension Interface > Render Method : Render(IReport,StreamProvider) Method
The report to render.
Stream for the output.
Renders the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub Render( _
   ByVal report As IReport, _
   ByVal streams As StreamProvider _
)
void Render(
   IReport report,
   StreamProvider streams
)

Parameters

report
The report to render.
streams
Stream for the output.
See Also

Reference

IRenderingExtension Interface
IRenderingExtension Members
Overload List


Render(IReport,StreamProvider,NameValueCollection) Method

Render(IReport,StreamProvider,NameValueCollection) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IRenderingExtension Interface > Render Method : Render(IReport,StreamProvider,NameValueCollection) Method
The report to render.
Stream for the output.
The rendering settings.
Renders the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub Render( _
   ByVal report As IReport, _
   ByVal streams As StreamProvider, _
   ByVal settings As System.Collections.Specialized.NameValueCollection _
)
void Render(
   IReport report,
   StreamProvider streams,
   System.Collections.Specialized.NameValueCollection settings
)

Parameters

report
The report to render.
streams
Stream for the output.
settings
The rendering settings.
See Also

Reference

IRenderingExtension Interface
IRenderingExtension Members
Overload List


IReportInformationService Interface

IReportInformationService Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IReportInformationService Interface
Service that returns Global variables and user specific information.
Object Model
IReportInformationService Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IReportInformationService
public interface IReportInformationService
See Also

Reference

IReportInformationService Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IReportInformationService Interface Members

IReportInformationService Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IReportInformationService Interface

The following tables list the members exposed by IReportInformationService.

Public Properties
 | Name | Description
Property | ExecutionTime | Gets the Date/Time the report began executing.
Property | Language | Gets the language code of the client executing the report.
Property | ReportFolder | Gets the path of the folder containing the report.
Property | ReportName | Gets the name of the report.
Property | UserID | Gets the ID of the user executing the report.
Top
See Also

Reference

IReportInformationService Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


IReportInformationService Interface Properties

IReportInformationService Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IReportInformationService Interface

For a list of all members of this type, see IReportInformationService members.

Public Properties
 | Name | Description
Property | ExecutionTime | Gets the Date/Time the report began executing.
Property | Language | Gets the language code of the client executing the report.
Property | ReportFolder | Gets the path of the folder containing the report.
Property | ReportName | Gets the name of the report.
Property | UserID | Gets the ID of the user executing the report.
Top
See Also

Reference

IReportInformationService Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


ExecutionTime Property

ExecutionTime Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IReportInformationService Interface : ExecutionTime Property
Gets the Date/Time the report began executing.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ExecutionTime As System.Date
System.DateTime ExecutionTime {get;}
See Also

Reference

IReportInformationService Interface
IReportInformationService Members


Language Property (IReportInformationService)

Language Property (IReportInformationService)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IReportInformationService Interface : Language Property
Gets the language code of the client executing the report.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Language As System.String
System.string Language {get;}
See Also

Reference

IReportInformationService Interface
IReportInformationService Members


ReportFolder Property

ReportFolder Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IReportInformationService Interface : ReportFolder Property
Gets the path of the folder containing the report.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ReportFolder As System.String
System.string ReportFolder {get;}
See Also

Reference

IReportInformationService Interface
IReportInformationService Members


ReportName Property (IReportInformationService)

ReportName Property (IReportInformationService)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IReportInformationService Interface : ReportName Property
Gets the name of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ReportName As System.String
System.string ReportName {get;}
See Also

Reference

IReportInformationService Interface
IReportInformationService Members


UserID Property

UserID Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IReportInformationService Interface : UserID Property
Gets the ID of the user executing the report.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property UserID As System.String
System.string UserID {get;}
See Also

Reference

IReportInformationService Interface
IReportInformationService Members


ISettings Interface

ISettings Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ISettings Interface
Interface for settings.
Object Model
ISettings Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ISettings
public interface ISettings
See Also

Reference

ISettings Members
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


ISettings Interface Members

ISettings Interface Members
Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ISettings Interface

The following tables list the members exposed by ISettings.

Public Methods
 | Name | Description
Method | ApplySettings | Apply settings for the rendering extension.
Method | GetSettings | Returns a System.Collections.Specialized.NameValueCollection containing the settings for the rendering extension.
Top
See Also

Reference

ISettings Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


ISettings Interface Methods

ISettings Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : ISettings Interface

For a list of all members of this type, see ISettings members.

Public Methods
 | Name | Description
Method | ApplySettings | Apply settings for the rendering extension.
Method | GetSettings | Returns a System.Collections.Specialized.NameValueCollection containing the settings for the rendering extension.
Top
See Also

Reference

ISettings Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


ApplySettings Method (ISettings)

ApplySettings Method (ISettings)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ISettings Interface : ApplySettings Method
Settings for the rendering extension.
Apply settings for the rendering extension.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub ApplySettings( _
   ByVal settings As System.Collections.Specialized.NameValueCollection _
)
void ApplySettings(
   System.Collections.Specialized.NameValueCollection settings
)

Parameters

settings
Settings for the rendering extension.
See Also

Reference

ISettings Interface
ISettings Members


GetSettings Method (ISettings)

GetSettings Method (ISettings)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ISettings Interface : GetSettings Method
Returns a System.Collections.Specialized.NameValueCollection containing the settings for the rendering extension.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetSettings() As System.Collections.Specialized.NameValueCollection
System.Collections.Specialized.NameValueCollection GetSettings()
See Also

Reference

ISettings Interface
ISettings Members


GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace
The GrapeCity.ActiveReports.Extensibility.Rendering.Components namespace includes the description of the components that are required for rendering reports.
Classes
 | Class | Description
Class | ItemCollectionExtensions | Utility methods on IItemCollection.
Interfaces
 | Interface | Description
Interface | IAction | Interface for action items.
Interface | IBand | Interface for the Band of a BandedList
Interface | IBandedList | Interface for a banded list report item.
Interface | IBandedListGroupCollection | Interface for a collection of banded list group objects.
Interface | IBody | Interface for the Body object of a report.
Interface | ICheckBox | Represents the CheckBox.
Interface | IContentItem | Defines iterfact for item with content.
Interface | ICustomReportItem | Interface for CRIs.
Interface | ICustomReportItemWithImages | Special extension class for CRI with internal images.
Interface | IDataRegion | Interface for data regions.
Interface | IDataRegionOverflow | This interface is needed to work with objects that are fully implemented DataRegion. It is used for OverflowPlaceHolderLayoutManager ustnovki properties OverflowName (!). It smells, But it's the best thing I can do now.
Interface | IDataScope | Represents a data scope in a report at rendering time.
Interface | IDetailBandCollection | Interface for the detail band object.
Interface | IDocumentMapItem | Interface to unify document map nodes.
Interface | IDrillthrough | Interface for drill through object.
Interface | IFixedPage | Defines container of IFixedPageContent objects.
Interface | IFixedPageContent | Defines content of a single FixedPage instance.
Interface | IFooterBand | Interface for the footer band of the banded list.
Interface | IFormattedText | Defines the formatted text rendering component.
Interface | IHeaderBand | Interface for the header band of the banded list.
Interface | IImage | Interface for images.
Interface | IImageLocator | Represents the service to get images.
Interface | IItemCollection<T> | Represents the collection of T objects.
Interface | IList | Interface for the List ReportItem.
Interface | IListContentCollection | Interface for a collection of List report items.
Interface | IMetadataDictionary | Interface for a dictionary of meta data objects.
Interface | IMetadataDictionaryEntry | Interface for members of the IMetadataDictionary
Interface | IMetadataEntry | Interface for meta data entry objects.
Interface | IOverflowItem | Interface for overflow item.
Interface | IPageRegion | Represents the page region
Interface | IPageSection | Interface for page selection.
Interface | IRectangle | Indicates that all whitespace in rectangle should be consumed when contents grow rather than preserving the minimum whitespace between the contents and the bounds of the rectangle.
Interface | IRenderComponent | Interface for render component objects.
Interface | IReport | Interface for the Report object.
Interface | IReportItem | Interface for report item objects.
Interface | IReportItemContainer | Defines container of IReportItem objects.
Interface | IRoundingRadius | Defines radii of rounded rectangle.
Interface | ISectionRegion | Umbrella to unify IDataRegion and IBandedList data regions.
Interface | IShape | Interface for Rectangle report item.
Interface | IStaticItem | All static report items with static content
Interface | IStyle | Interface for the Style object.
Interface | ISubreport | Interface for the subreport report item.
Interface | ITextBox | Interface for the textbox report item.
Interface | ITextItem | ITextItem
Interface | ITocItem | Represents ToC item.
Interface | ITocLevel | Represents table of contents level.
Interface | ITocList | Represents table of contents list.
Interface | IToggleReceiver | Specifies report entities whose visibility state can be toggled by Toggle report control.
Interface | IValueCollection | Interface for a collection of values.
Interface | IVisualAppearance | Interface for the visual appearance.
Interface | IVisualShape | Interface for a visual shape.
Structures
 | Structure | Description
Structure | ChangeResult | Encapsulates the resulting change for interactivity action processed by IReportItem
Structure | DrillthroughParameter | Definition of a parameter for drillthrough action
Structure | TabStop | Specifies the tab stop.
Enumerations
 | Enumeration | Description
Enumeration | ActionType | Specifies possible action type
Enumeration | AntiAliasing | Specifies the quality of the anti-aliasing .
Enumeration | ChangeType | Defines the type of change resulting from Process() or an event handler for a custom report item.
Enumeration | DataElementOutput | Defines how an item should appear in data output.
Enumeration | DataElementStyle | Indicates whether an item should render as an element or attribute.
Enumeration | ImageSource | Enumeration of image sources.
Enumeration | InteractivityStates | Specifies interactivity state to control area appearance.
Enumeration | KeepWithGroup | Specifies whether to keep a static member on the same page as the previous or next visible dynamic member.
Enumeration | MetadataType | Specifies metadata content type
Enumeration | MouseButton | Indicates which mouse button was clicked
Enumeration | PageBreakLocation | Specifies where a page break should occur for a Group, DataRegion or Rectangle.
Enumeration | PaperOrientation | Specifies the paper orientation of the report.
Enumeration | Position | Defines the position enumeration.
Enumeration | ShapeStyle | Defines the shape style.
Enumeration | TabType | Specifies tab stop types.
Enumeration | TargetDeviceKind | Defines enumeration of possible target devices for layer.
Enumeration | TextAntiAliasingQuality | Specifies the quality of the anti-aliasing to be used with the TextAntiAliasingQuality property.
Enumeration | TooltipType | Specifies how tooltip should be displayed for this area
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


ItemCollectionExtensions Class

ItemCollectionExtensions Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ItemCollectionExtensions Class
Utility methods on IItemCollection.
Object Model
ItemCollectionExtensions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit NotInheritable Class ItemCollectionExtensions
public static class ItemCollectionExtensions
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ItemCollectionExtensions

See Also

Reference

ItemCollectionExtensions Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ItemCollectionExtensions Class Members

ItemCollectionExtensions Class Members
Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ItemCollectionExtensions Class

The following tables list the members exposed by ItemCollectionExtensions.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Downcast<TI,TO> | Downcasts the items type within collection.
static (Shared in Visual Basic) | Empty<T> | Gets empty item collection.
static (Shared in Visual Basic) | ToItemCollection | Overloaded. Wraps the list to item collection.
static (Shared in Visual Basic) | ToLazyItemCollection | Overloaded. Returns lazy memoizable item collection for specified sequence.
Top
See Also

Reference

ItemCollectionExtensions Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ItemCollectionExtensions Class Methods

ItemCollectionExtensions Class Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ItemCollectionExtensions Class

For a list of all members of this type, see ItemCollectionExtensions members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Downcast<TI,TO> | Downcasts the items type within collection.
static (Shared in Visual Basic) | Empty<T> | Gets empty item collection.
static (Shared in Visual Basic) | ToItemCollection | Overloaded. Wraps the list to item collection.
static (Shared in Visual Basic) | ToLazyItemCollection | Overloaded. Returns lazy memoizable item collection for specified sequence.
Top
See Also

Reference

ItemCollectionExtensions Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Downcast<TI,TO> Method

Downcast<TI,TO> Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ItemCollectionExtensions Class : Downcast<TI,TO> Method
The type of the I.
The type of the O.
The input.
Downcasts the items type within collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function Downcast
    (Of TI As TO,
     TO)( _
   ByVal input As IItemCollection(Of TI) _
) As IItemCollection(Of TO)
public static IItemCollection<TO> Downcast<TI,TO>(
   IItemCollection<TI> input
)
where TI: TO

Parameters

input
The input.

Type Parameters

TI
The type of the I.
TO
The type of the O.
See Also

Reference

ItemCollectionExtensions Class
ItemCollectionExtensions Members


Empty<T> Method

Empty<T> Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ItemCollectionExtensions Class : Empty<T> Method
The items type.
Gets empty item collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function Empty(Of T)() As IItemCollection(Of T)
public static IItemCollection<T> Empty<T>()

Type Parameters

T
The items type.
See Also

Reference

ItemCollectionExtensions Class
ItemCollectionExtensions Members


ToItemCollection Method

ToItemCollection Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ItemCollectionExtensions Class : ToItemCollection Method
Wraps the list to item collection.
Overload List
Overload | Description
ToItemCollection<T>(IList<T>) | Wraps the list to item collection.
ToItemCollection<T>(IEnumerable<T>) | Wraps the list to item collection.
See Also

Reference

ItemCollectionExtensions Class
ItemCollectionExtensions Members


ToItemCollection<T>(IList<T>) Method

ToItemCollection<T>(IList<T>) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ItemCollectionExtensions Class > ToItemCollection Method : ToItemCollection<T>(IList<T>) Method
The items type.
The list.
Wraps the list to item collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ToItemCollection(Of T)( _
   ByVal list As System.Collections.Generic.IList(Of T) _
) As IItemCollection(Of T)
public static IItemCollection<T> ToItemCollection<T>(
   System.Collections.Generic.IList<T> list
)

Parameters

list
The list.

Type Parameters

T
The items type.
See Also

Reference

ItemCollectionExtensions Class
ItemCollectionExtensions Members
Overload List


ToItemCollection<T>(IEnumerable<T>) Method

ToItemCollection<T>(IEnumerable<T>) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ItemCollectionExtensions Class > ToItemCollection Method : ToItemCollection<T>(IEnumerable<T>) Method
The items type.
The seq.
Wraps the list to item collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ToItemCollection(Of T)( _
   ByVal seq As System.Collections.Generic.IEnumerable(Of T) _
) As IItemCollection(Of T)
public static IItemCollection<T> ToItemCollection<T>(
   System.Collections.Generic.IEnumerable<T> seq
)

Parameters

seq
The seq.

Type Parameters

T
The items type.
See Also

Reference

ItemCollectionExtensions Class
ItemCollectionExtensions Members
Overload List


ToLazyItemCollection Method

ToLazyItemCollection Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ItemCollectionExtensions Class : ToLazyItemCollection Method
Returns lazy memoizable item collection for specified sequence.
Overload List
Overload | Description
ToLazyItemCollection<T>(IList<T>) | Returns lazy memoizable item collection for specified sequence.
ToLazyItemCollection<T>(IEnumerable<T>) | Returns lazy memoizable item collection for specified sequence.
See Also

Reference

ItemCollectionExtensions Class
ItemCollectionExtensions Members


ToLazyItemCollection<T>(IList<T>) Method

ToLazyItemCollection<T>(IList<T>) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ItemCollectionExtensions Class > ToLazyItemCollection Method : ToLazyItemCollection<T>(IList<T>) Method
The items type.
The sequence to memoize.
Returns lazy memoizable item collection for specified sequence.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ToLazyItemCollection(Of T)( _
   ByVal source As System.Collections.Generic.IList(Of T) _
) As IItemCollection(Of T)
public static IItemCollection<T> ToLazyItemCollection<T>(
   System.Collections.Generic.IList<T> source
)

Parameters

source
The sequence to memoize.

Type Parameters

T
The items type.
See Also

Reference

ItemCollectionExtensions Class
ItemCollectionExtensions Members
Overload List


ToLazyItemCollection<T>(IEnumerable<T>) Method

ToLazyItemCollection<T>(IEnumerable<T>) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ItemCollectionExtensions Class > ToLazyItemCollection Method : ToLazyItemCollection<T>(IEnumerable<T>) Method
The items type.
The sequence to memoize.
Returns lazy memoizable item collection for specified sequence.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ToLazyItemCollection(Of T)( _
   ByVal source As System.Collections.Generic.IEnumerable(Of T) _
) As IItemCollection(Of T)
public static IItemCollection<T> ToLazyItemCollection<T>(
   System.Collections.Generic.IEnumerable<T> source
)

Parameters

source
The sequence to memoize.

Type Parameters

T
The items type.
See Also

Reference

ItemCollectionExtensions Class
ItemCollectionExtensions Members
Overload List


ActionType Enumeration

ActionType Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ActionType Enumeration
Specifies possible action type
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ActionType
   Inherits System.Enum
public enum ActionType : System.Enum
Members
Member | Description
BookmarkLink | Bookmark link.
DrillThrough | Drill through.
HyperLink | Hyperlink.
None | No action.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ActionType

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


AntiAliasing Enumeration

AntiAliasing Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : AntiAliasing Enumeration
Specifies the quality of the anti-aliasing .
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum AntiAliasing
   Inherits System.Enum
public enum AntiAliasing : System.Enum
Members
Member | Description
All | Anti-aliasing is applied to both text and graphics.
Graphics | Anti-aliasing is applied to graphics.
None | Anti-aliasing is not applied.
Text | Anti-aliasing is applied to text.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.AntiAliasing

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ChangeType Enumeration

ChangeType Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ChangeType Enumeration
Defines the type of change resulting from Process() or an event handler for a custom report item.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ChangeType
   Inherits System.Enum
public enum ChangeType : System.Enum
Members
Member | Description
Action | The user event should result in an action (such as redirecting to a URL) specified in ReportItem.Action
None | Neither the RenderItem nor the underlying data source changed.
Relayout | Properties of the CustomReportItem changed, requiring the report to be re-layout again.
Repaint | The RenderItem changed, requiring the report to be rendered again
Reprocess | Data Map must be re-created (for example, re-sort)
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ChangeType

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


DataElementOutput Enumeration

DataElementOutput Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : DataElementOutput Enumeration
Defines how an item should appear in data output.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DataElementOutput
   Inherits System.Enum
public enum DataElementOutput : System.Enum
Members
Member | Description
ContentsOnly | Indicates the item should not appear in the (e.g. XML), but its contents should be rendered as if they were in this item’s container. Only applies to Lists.
NoOutput | Indicates the item should not appear in the output.
Output | Indicates the item should appear in the output
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


DataElementStyle Enumeration

DataElementStyle Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : DataElementStyle Enumeration
Indicates whether an item should render as an element or attribute.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DataElementStyle
   Inherits System.Enum
public enum DataElementStyle : System.Enum
Members
Member | Description
AttributeNormal | Render as an attribute.
ElementNormal | Render as an element.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementStyle

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ImageSource Enumeration

ImageSource Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ImageSource Enumeration
Enumeration of image sources.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ImageSource
   Inherits System.Enum
public enum ImageSource : System.Enum
Members
Member | Description
Database | Database image source.
Embedded | Embedded image source.
External | External image source.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ImageSource

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


InteractivityStates Enumeration

InteractivityStates Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : InteractivityStates Enumeration
Specifies interactivity state to control area appearance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum InteractivityStates
   Inherits System.Enum
public enum InteractivityStates : System.Enum
Members
Member | Description
StateDown | Mouse button pressed/held inside the area
StateNormal | Default state
StateRollover | User moved cursor into area without pressing mouse button.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.InteractivityStates

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


KeepWithGroup Enumeration

KeepWithGroup Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : KeepWithGroup Enumeration
Specifies whether to keep a static member on the same page as the previous or next visible dynamic member.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum KeepWithGroup
   Inherits System.Enum
public enum KeepWithGroup : System.Enum
Members
Member | Description
After | Keep the static member on the same page as the next visible dynamic member.
Before | Keep the static member on the same page as the previous visible dynamic member.
None | Do not attempt to keep the static member on the same page as the previous or next visible dynamic member.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.KeepWithGroup

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


MetadataType Enumeration

MetadataType Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : MetadataType Enumeration
Specifies metadata content type
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MetadataType
   Inherits System.Enum
public enum MetadataType : System.Enum
Members
Member | Description
MetaBlob | Specifies that content is opaque binary data.
MetaText | Specifies that content is a string
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.MetadataType

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


MouseButton Enumeration

MouseButton Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : MouseButton Enumeration
Indicates which mouse button was clicked
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MouseButton
   Inherits System.Enum
public enum MouseButton : System.Enum
Members
Member | Description
Center | The center mouse button was clicked
Left | The left mouse button was clicked
Right | The right mouse button was clicked
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.MouseButton

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


PageBreakLocation Enumeration

PageBreakLocation Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : PageBreakLocation Enumeration
Specifies where a page break should occur for a Group, DataRegion or Rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PageBreakLocation
   Inherits System.Enum
public enum PageBreakLocation : System.Enum
Members
Member | Description
Between | Specifies that there must be a page break in between each Group.
End | Specifies that there must be a page break after a ReportItem or each Group.
None | Specifies that there is no page break.
Start | Specifies that there must be a page break before a ReportItem or each Group.
StartAndEnd | Specifies that there must be a page break both before and after a ReportItem or each Group.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.PageBreakLocation

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


PaperOrientation Enumeration

PaperOrientation Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : PaperOrientation Enumeration
Specifies the paper orientation of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PaperOrientation
   Inherits System.Enum
public enum PaperOrientation : System.Enum
Members
Member | Description
Landscape | Orientation will be landscape.
Portrait | Orientation will be portrait.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.PaperOrientation

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Position Enumeration

Position Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : Position Enumeration
Defines the position enumeration.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Position
   Inherits System.Enum
public enum Position : System.Enum
Members
Member | Description
Auto | The automatic position.
Bottom | The bottom position.
BottomLeft | The bottom left position.
BottomRight | The bottom right position.
Center | The center position.
Left | The left position.
Right | The right position.
Top | The top position.
TopLeft | The top left position.
TopRight | The top right position.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Position

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ShapeStyle Enumeration

ShapeStyle Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ShapeStyle Enumeration
Defines the shape style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ShapeStyle
   Inherits System.Enum
public enum ShapeStyle : System.Enum
Members
Member | Description
Ellipse | Elliptical shape.
Rectangle | Rectangular shape.
RoundRect | RoundRectangle shape.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ShapeStyle

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


TabType Enumeration

TabType Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : TabType Enumeration
Specifies tab stop types.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TabType
   Inherits System.Enum
public enum TabType : System.Enum
Members
Member | Description
Center | The center tab stop.
Left | The left tab stop.
Right | The right tab stop.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.TabType

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


TargetDeviceKind Enumeration

TargetDeviceKind Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : TargetDeviceKind Enumeration
Defines enumeration of possible target devices for layer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TargetDeviceKind
   Inherits System.Enum
public enum TargetDeviceKind : System.Enum
Members
Member | Description
All | Allows to output to Screen, Paper and Export target devices
Export | Allows to output to Export target device
None | Forbids to output to any target device
Paper | Allows to output to Paper target device
Screen | Allows to output to Screen target device
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.TargetDeviceKind

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


TextAntiAliasingQuality Enumeration

TextAntiAliasingQuality Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : TextAntiAliasingQuality Enumeration
Specifies the quality of the anti-aliasing to be used with the TextAntiAliasingQuality property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TextAntiAliasingQuality
   Inherits System.Enum
public enum TextAntiAliasingQuality : System.Enum
Members
Member | Description
High | The high quality anti-aliasing.
Normal | The normal quality anti-aliasing.
SystemDefault | The quality according to system default anti-aliasing.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.TextAntiAliasingQuality

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


TooltipType Enumeration

TooltipType Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : TooltipType Enumeration
Specifies how tooltip should be displayed for this area
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TooltipType
   Inherits System.Enum
public enum TooltipType : System.Enum
Members
Member | Description
Balloon | Dispaly TooltipText as balloon
None | Don't dispaly a tooltip
Tooltip | Display TooltipText as a tooltip
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.TooltipType

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ChangeResult Structure

ChangeResult Structure
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ChangeResult Structure
Encapsulates the resulting change for interactivity action processed by IReportItem
Object Model
ChangeResult Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure ChangeResult
   Inherits System.ValueType
public struct ChangeResult : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ChangeResult

See Also

Reference

ChangeResult Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ChangeResult Structure Members

ChangeResult Structure Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ChangeResult Structure

The following tables list the members exposed by ChangeResult.

Public Properties
 | Name | Description
Public Property | Action | Specifies the Action definition, if any, that should be performed. May be null.
Public Property | ChangeType | Defines the type of change resulting from Process() or an event handler for a custom report item.
static (Shared in Visual Basic) | None | Creates ChangeResult corresponding to no action.
Top
See Also

Reference

ChangeResult Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ChangeResult Structure Properties

ChangeResult Structure Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ChangeResult Structure

For a list of all members of this type, see ChangeResult members.

Public Properties
 | Name | Description
Public Property | Action | Specifies the Action definition, if any, that should be performed. May be null.
Public Property | ChangeType | Defines the type of change resulting from Process() or an event handler for a custom report item.
static (Shared in Visual Basic) | None | Creates ChangeResult corresponding to no action.
Top
See Also

Reference

ChangeResult Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Action Property (ChangeResult)

Action Property (ChangeResult)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ChangeResult Structure : Action Property
Specifies the Action definition, if any, that should be performed. May be null.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Action As IAction
public IAction Action {get;}
See Also

Reference

ChangeResult Structure
ChangeResult Members


ChangeType Property

ChangeType Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ChangeResult Structure : ChangeType Property
Defines the type of change resulting from Process() or an event handler for a custom report item.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ChangeType As ChangeType
public ChangeType ChangeType {get;}
See Also

Reference

ChangeResult Structure
ChangeResult Members


None Property

None Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ChangeResult Structure : None Property
Creates ChangeResult corresponding to no action.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property None As ChangeResult
public static ChangeResult None {get;}
See Also

Reference

ChangeResult Structure
ChangeResult Members


DrillthroughParameter Structure

DrillthroughParameter Structure
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : DrillthroughParameter Structure
Definition of a parameter for drillthrough action
Object Model
DrillthroughParameter Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure DrillthroughParameter
   Inherits System.ValueType
public struct DrillthroughParameter : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Rendering.Components.DrillthroughParameter

See Also

Reference

DrillthroughParameter Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


DrillthroughParameter Structure Members

DrillthroughParameter Structure Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : DrillthroughParameter Structure

The following tables list the members exposed by DrillthroughParameter.

Public Constructors
 | Name | Description
Public Constructor | DrillthroughParameter Constructor | Creates new parameter.
Top
Public Properties
 | Name | Description
Public Property | Name | Specifies parameter name
Public Property | Omit | Indicates whether the parameter should be skipped.
Public Property | Value | Specifies parameter value
Top
See Also

Reference

DrillthroughParameter Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


DrillthroughParameter Constructor

DrillthroughParameter Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > DrillthroughParameter Structure : DrillthroughParameter Constructor
parameter name
parameter value
value that indicates whether the paramater should be skipped
Creates new parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As System.String, _
   ByVal value As System.Object, _
   ByVal omit As System.Boolean _
)
public DrillthroughParameter(
   System.string name,
   System.object value,
   System.bool omit
)

Parameters

name
parameter name
value
parameter value
omit
value that indicates whether the paramater should be skipped
See Also

Reference

DrillthroughParameter Structure
DrillthroughParameter Members


DrillthroughParameter Structure Properties

DrillthroughParameter Structure Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : DrillthroughParameter Structure

For a list of all members of this type, see DrillthroughParameter members.

Public Properties
 | Name | Description
Public Property | Name | Specifies parameter name
Public Property | Omit | Indicates whether the parameter should be skipped.
Public Property | Value | Specifies parameter value
Top
See Also

Reference

DrillthroughParameter Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Name Property (DrillthroughParameter)

Name Property (DrillthroughParameter)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > DrillthroughParameter Structure : Name Property
Specifies parameter name
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Name As System.String
public System.string Name {get;}
See Also

Reference

DrillthroughParameter Structure
DrillthroughParameter Members


Omit Property (DrillthroughParameter)

Omit Property (DrillthroughParameter)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > DrillthroughParameter Structure : Omit Property
Indicates whether the parameter should be skipped.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Omit As System.Boolean
public System.bool Omit {get;}
See Also

Reference

DrillthroughParameter Structure
DrillthroughParameter Members


Value Property (DrillthroughParameter)

Value Property (DrillthroughParameter)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > DrillthroughParameter Structure : Value Property
Specifies parameter value
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Value As System.Object
public System.object Value {get;}
See Also

Reference

DrillthroughParameter Structure
DrillthroughParameter Members


TabStop Structure

TabStop Structure
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : TabStop Structure
Specifies the tab stop.
Object Model
TabStop Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure TabStop
   Inherits System.ValueType
public struct TabStop : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Rendering.Components.TabStop

See Also

Reference

TabStop Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


TabStop Structure Members

TabStop Structure Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : TabStop Structure

The following tables list the members exposed by TabStop.

Public Constructors
 | Name | Description
Public Constructor | TabStop Constructor | Initializes a new instanse of this class.
Top
Public Properties
 | Name | Description
Public Property | LeadingChar | Specifies the character which shall be used to fill in the space created by a tab which ends at this tab stop.
Public Property | Position | Specifies the position of the current tab stop.
Public Property | Type | Specifies the type of tab stop.
Top
See Also

Reference

TabStop Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


TabStop Constructor

TabStop Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > TabStop Structure : TabStop Constructor
The position of tab stop.
The leading char.
The type of tab stop.
Initializes a new instanse of this class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal position As Length, _
   ByVal leadingChar As System.String, _
   ByVal type As TabType _
)
public TabStop(
   Length position,
   System.string leadingChar,
   TabType type
)

Parameters

position
The position of tab stop.
leadingChar
The leading char.
type
The type of tab stop.
See Also

Reference

TabStop Structure
TabStop Members


TabStop Structure Properties

TabStop Structure Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : TabStop Structure

For a list of all members of this type, see TabStop members.

Public Properties
 | Name | Description
Public Property | LeadingChar | Specifies the character which shall be used to fill in the space created by a tab which ends at this tab stop.
Public Property | Position | Specifies the position of the current tab stop.
Public Property | Type | Specifies the type of tab stop.
Top
See Also

Reference

TabStop Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


LeadingChar Property (TabStop)

LeadingChar Property (TabStop)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > TabStop Structure : LeadingChar Property
Specifies the character which shall be used to fill in the space created by a tab which ends at this tab stop.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property LeadingChar As System.String
public System.string LeadingChar {get;}
See Also

Reference

TabStop Structure
TabStop Members


Position Property (TabStop)

Position Property (TabStop)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > TabStop Structure : Position Property
Specifies the position of the current tab stop.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Position As Length
public Length Position {get;}
See Also

Reference

TabStop Structure
TabStop Members


Type Property (TabStop)

Type Property (TabStop)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > TabStop Structure : Type Property
Specifies the type of tab stop.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Type As TabType
public TabType Type {get;}
See Also

Reference

TabStop Structure
TabStop Members


IAction Interface

IAction Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IAction Interface
Interface for action items.
Object Model
IAction Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IAction
public interface IAction
See Also

Reference

IAction Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IAction Interface Members

IAction Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IAction Interface

The following tables list the members exposed by IAction.

Public Properties
 | Name | Description
Property | ActionType | Specifies Action type.
Property | BookmarkLink | Specifies bookmark within the report to go to when report item is clicked on.
Property | Drillthrough | Provides a definition of how drillthrough report should be executed.
Property | HyperLink | Specifies the URL of this Action HyperLink
Top
See Also

Reference

IAction Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IAction Interface Properties

IAction Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IAction Interface

For a list of all members of this type, see IAction members.

Public Properties
 | Name | Description
Property | ActionType | Specifies Action type.
Property | BookmarkLink | Specifies bookmark within the report to go to when report item is clicked on.
Property | Drillthrough | Provides a definition of how drillthrough report should be executed.
Property | HyperLink | Specifies the URL of this Action HyperLink
Top
See Also

Reference

IAction Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ActionType Property

ActionType Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IAction Interface : ActionType Property
Specifies Action type.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ActionType As ActionType
ActionType ActionType {get;}
See Also

Reference

IAction Interface
IAction Members


BookmarkLink Property (IAction)

BookmarkLink Property (IAction)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IAction Interface : BookmarkLink Property
Specifies bookmark within the report to go to when report item is clicked on.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property BookmarkLink As System.String
System.string BookmarkLink {get;}
See Also

Reference

IAction Interface
IAction Members


Drillthrough Property (IAction)

Drillthrough Property (IAction)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IAction Interface : Drillthrough Property
Provides a definition of how drillthrough report should be executed.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Drillthrough As IDrillthrough
IDrillthrough Drillthrough {get;}
See Also

Reference

IAction Interface
IAction Members


HyperLink Property (IAction)

HyperLink Property (IAction)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IAction Interface : HyperLink Property
Specifies the URL of this Action HyperLink
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property HyperLink As System.String
System.string HyperLink {get;}
See Also

Reference

IAction Interface
IAction Members


IBand Interface

IBand Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IBand Interface
Interface for the Band of a BandedList
Object Model
IBand Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IBand
   Inherits IDocumentMapItem, IRenderComponent, IReportItem, IReportItemContainer
public interface IBand : IDocumentMapItem, IRenderComponent, IReportItem, IReportItemContainer
See Also

Reference

IBand Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IBand Interface Members

IBand Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IBand Interface

The following tables list the members exposed by IBand.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | CanGrow | Indicates that this band can grow in vertical direction.
Property | CanShrink | Indicates that this Band can shrink in vertical direction.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Specifies, if the Band should try to keep the content together.
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Returns PageBreakAtEnd property for this Band.
Property | PageBreakAtStart | Returns PageBreakAtStart property for this Band.
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | ReportItems | Returns the IReportItem objects in this container. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemContainer)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IBand Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IBand Interface Properties

IBand Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IBand Interface

For a list of all members of this type, see IBand members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | CanGrow | Indicates that this band can grow in vertical direction.
Property | CanShrink | Indicates that this Band can shrink in vertical direction.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Specifies, if the Band should try to keep the content together.
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Returns PageBreakAtEnd property for this Band.
Property | PageBreakAtStart | Returns PageBreakAtStart property for this Band.
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | ReportItems | Returns the IReportItem objects in this container. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemContainer)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IBand Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


CanGrow Property (IBand)

CanGrow Property (IBand)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBand Interface : CanGrow Property
Indicates that this band can grow in vertical direction.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CanGrow As System.Boolean
System.bool CanGrow {get;}
See Also

Reference

IBand Interface
IBand Members


CanShrink Property (IBand)

CanShrink Property (IBand)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBand Interface : CanShrink Property
Indicates that this Band can shrink in vertical direction.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CanShrink As System.Boolean
System.bool CanShrink {get;}
See Also

Reference

IBand Interface
IBand Members


KeepTogether Property (IBand)

KeepTogether Property (IBand)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBand Interface : KeepTogether Property
Specifies, if the Band should try to keep the content together.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property KeepTogether As System.Boolean
System.bool KeepTogether {get;}
See Also

Reference

IBand Interface
IBand Members


PageBreakAtEnd Property (IBand)

PageBreakAtEnd Property (IBand)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBand Interface : PageBreakAtEnd Property
Returns PageBreakAtEnd property for this Band.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PageBreakAtEnd As System.Boolean
System.bool PageBreakAtEnd {get;}
See Also

Reference

IBand Interface
IBand Members


PageBreakAtStart Property (IBand)

PageBreakAtStart Property (IBand)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBand Interface : PageBreakAtStart Property
Returns PageBreakAtStart property for this Band.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PageBreakAtStart As System.Boolean
System.bool PageBreakAtStart {get;}
See Also

Reference

IBand Interface
IBand Members


IBandedList Interface

IBandedList Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IBandedList Interface
Interface for a banded list report item.
Object Model
IBandedList Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IBandedList
   Inherits IDocumentMapItem, IOverflowItem, IPageRegion, IRenderComponent, IReportItem, ISectionRegion
public interface IBandedList : IDocumentMapItem, IOverflowItem, IPageRegion, IRenderComponent, IReportItem, ISectionRegion
See Also

Reference

IBandedList Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IBandedList Interface Members

IBandedList Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IBandedList Interface

The following tables list the members exposed by IBandedList.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ConsumeWhiteSpace | Indicates that all whitespace in band should be consumed when contents grow rather than preserving the minimum whitespace between the contents and the bounds.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Details | Specifies details of band collection (if any) for this BandedList.
Property | Footer | Specifies report footer for this banded list.
Property | Groups | Returns a collection of groups for this instance of BandedList.
Property | Header | Specifies report header for this banded list.
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | OverflowName | Overflow name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Gets a value indicating whether the page should break at the end of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | PageBreakAtStart | Gets a value indicating whether the page should break at the start of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | PreventOrphanedFooter | Indicates whether the orphaned footer is displayed on next page.
Property | PreventOrphanedHeader | Indicates whether the orphaned header is displayed on the page.
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IBandedList Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IBandedList Interface Properties

IBandedList Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IBandedList Interface

For a list of all members of this type, see IBandedList members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ConsumeWhiteSpace | Indicates that all whitespace in band should be consumed when contents grow rather than preserving the minimum whitespace between the contents and the bounds.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Details | Specifies details of band collection (if any) for this BandedList.
Property | Footer | Specifies report footer for this banded list.
Property | Groups | Returns a collection of groups for this instance of BandedList.
Property | Header | Specifies report header for this banded list.
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | OverflowName | Overflow name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Gets a value indicating whether the page should break at the end of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | PageBreakAtStart | Gets a value indicating whether the page should break at the start of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | PreventOrphanedFooter | Indicates whether the orphaned footer is displayed on next page.
Property | PreventOrphanedHeader | Indicates whether the orphaned header is displayed on the page.
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IBandedList Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ConsumeWhiteSpace Property (IBandedList)

ConsumeWhiteSpace Property (IBandedList)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBandedList Interface : ConsumeWhiteSpace Property
Indicates that all whitespace in band should be consumed when contents grow rather than preserving the minimum whitespace between the contents and the bounds.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ConsumeWhiteSpace As System.Boolean
System.bool ConsumeWhiteSpace {get;}
See Also

Reference

IBandedList Interface
IBandedList Members


Details Property (IBandedList)

Details Property (IBandedList)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBandedList Interface : Details Property
Specifies details of band collection (if any) for this BandedList.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Details As IDetailBandCollection
IDetailBandCollection Details {get;}
Remarks
Details collection will be empty if there are Groups.
See Also

Reference

IBandedList Interface
IBandedList Members


Footer Property (IBandedList)

Footer Property (IBandedList)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBandedList Interface : Footer Property
Specifies report footer for this banded list.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Footer As IFooterBand
IFooterBand Footer {get;}
See Also

Reference

IBandedList Interface
IBandedList Members


Groups Property (IBandedList)

Groups Property (IBandedList)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBandedList Interface : Groups Property
Returns a collection of groups for this instance of BandedList.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Groups As IBandedListGroupCollection
IBandedListGroupCollection Groups {get;}
See Also

Reference

IBandedList Interface
IBandedList Members


Header Property (IBandedList)

Header Property (IBandedList)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBandedList Interface : Header Property
Specifies report header for this banded list.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Header As IHeaderBand
IHeaderBand Header {get;}
See Also

Reference

IBandedList Interface
IBandedList Members


PreventOrphanedFooter Property (IBandedList)

PreventOrphanedFooter Property (IBandedList)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBandedList Interface : PreventOrphanedFooter Property
Indicates whether the orphaned footer is displayed on next page.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PreventOrphanedFooter As System.Boolean
System.bool PreventOrphanedFooter {get;}
See Also

Reference

IBandedList Interface
IBandedList Members


PreventOrphanedHeader Property (IBandedList)

PreventOrphanedHeader Property (IBandedList)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBandedList Interface : PreventOrphanedHeader Property
Indicates whether the orphaned header is displayed on the page.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PreventOrphanedHeader As System.Boolean
System.bool PreventOrphanedHeader {get;}
See Also

Reference

IBandedList Interface
IBandedList Members


IBandedListGroupCollection Interface

IBandedListGroupCollection Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IBandedListGroupCollection Interface
Interface for a collection of banded list group objects.
Object Model
IBandedListGroupCollection Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IBandedListGroupCollection
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection(Of IBandedListGroup)
public interface IBandedListGroupCollection : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<IBandedListGroup>
See Also

Reference

IBandedListGroupCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IBandedListGroupCollection Interface Members

IBandedListGroupCollection Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IBandedListGroupCollection Interface

The following tables list the members exposed by IBandedListGroupCollection.

Public Properties
 | Name | Description
Property | Count | Gets number of items in the collection. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<IBandedListGroup>)
Property | Item | Returns the BandedListGroup with the specified name.
Top
See Also

Reference

IBandedListGroupCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IBandedListGroupCollection Interface Properties

IBandedListGroupCollection Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IBandedListGroupCollection Interface

For a list of all members of this type, see IBandedListGroupCollection members.

Public Properties
 | Name | Description
Property | Count | Gets number of items in the collection. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<IBandedListGroup>)
Property | Item | Returns the BandedListGroup with the specified name.
Top
See Also

Reference

IBandedListGroupCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Item Property (IBandedListGroupCollection)

Item Property (IBandedListGroupCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBandedListGroupCollection Interface : Item Property
Returns the BandedListGroup with the specified name.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Default Property Item( _
   ByVal name As System.String _
) As IBandedListGroup
IBandedListGroup this[
   System.string name
]; {get;}

Parameters

name
See Also

Reference

IBandedListGroupCollection Interface
IBandedListGroupCollection Members


IBody Interface

IBody Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IBody Interface
Interface for the Body object of a report.
Object Model
IBody Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IBody
   Inherits IReportItemContainer
public interface IBody : IReportItemContainer
See Also

Reference

IBody Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IBody Interface Members

IBody Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IBody Interface

The following tables list the members exposed by IBody.

Public Properties
 | Name | Description
Property | Columns | Defines number of columns in the body of the report
Property | ColumnSpacing | Defines the spacing between columns
Property | Height | Indicates the height of report body
Property | ParentReport | Returns the report this body is within.
Property | ReportItems | Returns the IReportItem objects in this container. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemContainer)
Property | Style | Returns style of this IBody instance
Top
See Also

Reference

IBody Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IBody Interface Properties

IBody Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IBody Interface

For a list of all members of this type, see IBody members.

Public Properties
 | Name | Description
Property | Columns | Defines number of columns in the body of the report
Property | ColumnSpacing | Defines the spacing between columns
Property | Height | Indicates the height of report body
Property | ParentReport | Returns the report this body is within.
Property | ReportItems | Returns the IReportItem objects in this container. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemContainer)
Property | Style | Returns style of this IBody instance
Top
See Also

Reference

IBody Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Columns Property (IBody)

Columns Property (IBody)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBody Interface : Columns Property
Defines number of columns in the body of the report
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Columns As System.Integer
System.int Columns {get;}
See Also

Reference

IBody Interface
IBody Members


ColumnSpacing Property (IBody)

ColumnSpacing Property (IBody)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBody Interface : ColumnSpacing Property
Defines the spacing between columns
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ColumnSpacing As Length
Length ColumnSpacing {get;}
See Also

Reference

IBody Interface
IBody Members


Height Property (IBody)

Height Property (IBody)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBody Interface : Height Property
Indicates the height of report body
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Height As Length
Length Height {get;}
See Also

Reference

IBody Interface
IBody Members


ParentReport Property (IBody)

ParentReport Property (IBody)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBody Interface : ParentReport Property
Returns the report this body is within.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ParentReport As IReport
IReport ParentReport {get;}
See Also

Reference

IBody Interface
IBody Members


Style Property (IBody)

Style Property (IBody)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBody Interface : Style Property
Returns style of this IBody instance
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Style As IStyle
IStyle Style {get;}
See Also

Reference

IBody Interface
IBody Members


ICheckBox Interface

ICheckBox Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ICheckBox Interface
Represents the CheckBox.
Object Model
ICheckBox Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ICheckBox
   Inherits IDocumentMapItem, IRenderComponent, IReportItem, ITextItem
public interface ICheckBox : IDocumentMapItem, IRenderComponent, IReportItem, ITextItem
See Also

Reference

ICheckBox Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ICheckBox Interface Members

ICheckBox Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ICheckBox Interface

The following tables list the members exposed by ICheckBox.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | CheckAlignment | Gets the alignment of the checkbox text within the drawing area.
Property | Checked | Gets or sets a value indicating the state of the checkbox.
Property | ContentValue | Returns a string representation of this instance Value. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ITextItem)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementStyle | Indicates whether to render this textbox as an element or as an attribute. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ITextItem)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Value | Returns the value of this textbox. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ITextItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

ICheckBox Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ICheckBox Interface Properties

ICheckBox Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ICheckBox Interface

For a list of all members of this type, see ICheckBox members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | CheckAlignment | Gets the alignment of the checkbox text within the drawing area.
Property | Checked | Gets or sets a value indicating the state of the checkbox.
Property | ContentValue | Returns a string representation of this instance Value. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ITextItem)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementStyle | Indicates whether to render this textbox as an element or as an attribute. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ITextItem)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Value | Returns the value of this textbox. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ITextItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

ICheckBox Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


CheckAlignment Property (ICheckBox)

CheckAlignment Property (ICheckBox)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ICheckBox Interface : CheckAlignment Property
Gets the alignment of the checkbox text within the drawing area.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CheckAlignment As System.Drawing.ContentAlignment
System.Drawing.ContentAlignment CheckAlignment {get;}
See Also

Reference

ICheckBox Interface
ICheckBox Members


Checked Property (ICheckBox)

Checked Property (ICheckBox)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ICheckBox Interface : Checked Property
Gets or sets a value indicating the state of the checkbox.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Checked As System.Boolean
System.bool Checked {get;}
See Also

Reference

ICheckBox Interface
ICheckBox Members


IContentItem Interface

IContentItem Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IContentItem Interface
Defines iterfact for item with content.
Object Model
IContentItem Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IContentItem
public interface IContentItem
See Also

Reference

IContentItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IContentItem Interface Members

IContentItem Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IContentItem Interface

The following tables list the members exposed by IContentItem.

Public Properties
 | Name | Description
Property | ContentHeight | The content height.
Property | ContentWidth | The content width.
Top
See Also

Reference

IContentItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IContentItem Interface Properties

IContentItem Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IContentItem Interface

For a list of all members of this type, see IContentItem members.

Public Properties
 | Name | Description
Property | ContentHeight | The content height.
Property | ContentWidth | The content width.
Top
See Also

Reference

IContentItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ContentHeight Property

ContentHeight Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IContentItem Interface : ContentHeight Property
The content height.
Syntax
  • Visual Basic
  • C#
'Declaration

Property ContentHeight As System.Nullable(Of Single)
System.Nullable<float> ContentHeight {get; set;}
See Also

Reference

IContentItem Interface
IContentItem Members


ContentWidth Property

ContentWidth Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IContentItem Interface : ContentWidth Property
The content width.
Syntax
  • Visual Basic
  • C#
'Declaration

Property ContentWidth As System.Nullable(Of Single)
System.Nullable<float> ContentWidth {get; set;}
See Also

Reference

IContentItem Interface
IContentItem Members


ICustomReportItem Interface

ICustomReportItem Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ICustomReportItem Interface
Interface for CRIs.
Object Model
ICustomReportItem Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ICustomReportItem
   Inherits IDocumentMapItem, IRenderComponent, IReportItem
public interface ICustomReportItem : IDocumentMapItem, IRenderComponent, IReportItem
See Also

Reference

ICustomReportItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ICustomReportItem Interface Members

ICustomReportItem Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ICustomReportItem Interface

The following tables list the members exposed by ICustomReportItem.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | CustomData | Returns custom data of this CRI
Property | CustomProperties | Gets custom properties of the report item. Exists primary for FlashViewer. Returned value can be null.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementValue | Returns data element value.
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | ReferencedImages | Gets the images required for rendering of the report item. Exists primary for FlashViewer. Returned value can be null.
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderItem | Returns presentation of the CRI with system DPI via simple report items supported by ActiveReports (in general - IImage implementation). Returned value must not be null.
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Type | Specifies type of custom report item to find it after deserialization. Exists primary for FlashViewer (GrapeCity.ActiveReports.Rendering.ICustomReportItemFactory). Returned value can be null.
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetRenderItem | Returns presentation of the CRI with the given DPI via simple report items supported by ActiveReports (in general - IImage implementation). Returned value must not be null.
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

ICustomReportItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ICustomReportItem Interface Methods

ICustomReportItem Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ICustomReportItem Interface

For a list of all members of this type, see ICustomReportItem members.

Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetRenderItem | Returns presentation of the CRI with the given DPI via simple report items supported by ActiveReports (in general - IImage implementation). Returned value must not be null.
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

ICustomReportItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetRenderItem Method

GetRenderItem Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ICustomReportItem Interface : GetRenderItem Method
Horizontal dpi.
Vertical dpi.
Returns presentation of the CRI with the given DPI via simple report items supported by ActiveReports (in general - IImage implementation). Returned value must not be null.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetRenderItem( _
   ByVal dpiX As System.Single, _
   ByVal dpiY As System.Single _
) As IReportItem
IReportItem GetRenderItem(
   System.float dpiX,
   System.float dpiY
)

Parameters

dpiX
Horizontal dpi.
dpiY
Vertical dpi.
See Also

Reference

ICustomReportItem Interface
ICustomReportItem Members


ICustomReportItem Interface Properties

ICustomReportItem Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ICustomReportItem Interface

For a list of all members of this type, see ICustomReportItem members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | CustomData | Returns custom data of this CRI
Property | CustomProperties | Gets custom properties of the report item. Exists primary for FlashViewer. Returned value can be null.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementValue | Returns data element value.
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | ReferencedImages | Gets the images required for rendering of the report item. Exists primary for FlashViewer. Returned value can be null.
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderItem | Returns presentation of the CRI with system DPI via simple report items supported by ActiveReports (in general - IImage implementation). Returned value must not be null.
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Type | Specifies type of custom report item to find it after deserialization. Exists primary for FlashViewer (GrapeCity.ActiveReports.Rendering.ICustomReportItemFactory). Returned value can be null.
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

ICustomReportItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


CustomData Property (ICustomReportItem)

CustomData Property (ICustomReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ICustomReportItem Interface : CustomData Property
Returns custom data of this CRI
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CustomData As CustomData
CustomData CustomData {get;}
See Also

Reference

ICustomReportItem Interface
ICustomReportItem Members


CustomProperties Property (ICustomReportItem)

CustomProperties Property (ICustomReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ICustomReportItem Interface : CustomProperties Property
Gets custom properties of the report item. Exists primary for FlashViewer. Returned value can be null.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CustomProperties As System.Collections.Generic.IEnumerable(Of KeyValuePair(Of String,Object))
System.Collections.Generic.IEnumerable<KeyValuePair<string,object>> CustomProperties {get;}
See Also

Reference

ICustomReportItem Interface
ICustomReportItem Members


DataElementValue Property

DataElementValue Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ICustomReportItem Interface : DataElementValue Property
Returns data element value.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataElementValue As System.String
System.string DataElementValue {get;}
See Also

Reference

ICustomReportItem Interface
ICustomReportItem Members


ReferencedImages Property (ICustomReportItem)

ReferencedImages Property (ICustomReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ICustomReportItem Interface : ReferencedImages Property
Gets the images required for rendering of the report item. Exists primary for FlashViewer. Returned value can be null.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ReferencedImages As System.Collections.Generic.IEnumerable(Of KeyValuePair(Of String,Byte()))
System.Collections.Generic.IEnumerable<KeyValuePair<string,byte[]>> ReferencedImages {get;}
See Also

Reference

ICustomReportItem Interface
ICustomReportItem Members


RenderItem Property

RenderItem Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ICustomReportItem Interface : RenderItem Property
Returns presentation of the CRI with system DPI via simple report items supported by ActiveReports (in general - IImage implementation). Returned value must not be null.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RenderItem As IReportItem
IReportItem RenderItem {get;}
See Also

Reference

ICustomReportItem Interface
ICustomReportItem Members


Type Property (ICustomReportItem)

Type Property (ICustomReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ICustomReportItem Interface : Type Property
Specifies type of custom report item to find it after deserialization. Exists primary for FlashViewer (GrapeCity.ActiveReports.Rendering.ICustomReportItemFactory). Returned value can be null.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Type As System.String
System.string Type {get;}
See Also

Reference

ICustomReportItem Interface
ICustomReportItem Members


ICustomReportItemWithImages Interface

ICustomReportItemWithImages Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ICustomReportItemWithImages Interface
Special extension class for CRI with internal images.
Object Model
ICustomReportItemWithImages Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ICustomReportItemWithImages
public interface ICustomReportItemWithImages
See Also

Reference

ICustomReportItemWithImages Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ICustomReportItemWithImages Interface Members

ICustomReportItemWithImages Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ICustomReportItemWithImages Interface

The following tables list the members exposed by ICustomReportItemWithImages.

Public Properties
 | Name | Description
Property | ReferencedImages | Gets the images required for rendering of the report item. Exists primary for FlashViewer. Returned value can be null.
Top
Public Methods
 | Name | Description
Method | SetReferencedImages | Initialize images collection during deserialization. Exists primary for FlashViewer.
Top
See Also

Reference

ICustomReportItemWithImages Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ICustomReportItemWithImages Interface Methods

ICustomReportItemWithImages Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ICustomReportItemWithImages Interface

For a list of all members of this type, see ICustomReportItemWithImages members.

Public Methods
 | Name | Description
Method | SetReferencedImages | Initialize images collection during deserialization. Exists primary for FlashViewer.
Top
See Also

Reference

ICustomReportItemWithImages Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


SetReferencedImages Method

SetReferencedImages Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ICustomReportItemWithImages Interface : SetReferencedImages Method
Initialize images collection during deserialization. Exists primary for FlashViewer.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub SetReferencedImages( _
   ByVal referencedImages As System.Collections.Generic.IEnumerable(Of KeyValuePair(Of String,Byte())) _
)
void SetReferencedImages(
   System.Collections.Generic.IEnumerable<KeyValuePair<string,byte[]>> referencedImages
)

Parameters

referencedImages
See Also

Reference

ICustomReportItemWithImages Interface
ICustomReportItemWithImages Members


ICustomReportItemWithImages Interface Properties

ICustomReportItemWithImages Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ICustomReportItemWithImages Interface

For a list of all members of this type, see ICustomReportItemWithImages members.

Public Properties
 | Name | Description
Property | ReferencedImages | Gets the images required for rendering of the report item. Exists primary for FlashViewer. Returned value can be null.
Top
See Also

Reference

ICustomReportItemWithImages Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ReferencedImages Property (ICustomReportItemWithImages)

ReferencedImages Property (ICustomReportItemWithImages)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ICustomReportItemWithImages Interface : ReferencedImages Property
Gets the images required for rendering of the report item. Exists primary for FlashViewer. Returned value can be null.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ReferencedImages As System.Collections.Generic.IEnumerable(Of KeyValuePair(Of String,Byte()))
System.Collections.Generic.IEnumerable<KeyValuePair<string,byte[]>> ReferencedImages {get;}
See Also

Reference

ICustomReportItemWithImages Interface
ICustomReportItemWithImages Members


IDataRegion Interface

IDataRegion Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDataRegion Interface
Interface for data regions.
Object Model
IDataRegion Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDataRegion
   Inherits IDocumentMapItem, IOverflowItem, IPageRegion, IRenderComponent, IReportItem, ISectionRegion
public interface IDataRegion : IDocumentMapItem, IOverflowItem, IPageRegion, IRenderComponent, IReportItem, ISectionRegion
See Also

Reference

IDataRegion Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IDataRegion Interface Members

IDataRegion Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDataRegion Interface

The following tables list the members exposed by IDataRegion.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataSetName | Specifies which data set to use for this data region.
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | NoRows | Indicates if the DataRegion has no rows available.
Property | NoRowsMessage | Message to display in the DataRegion when no rows of data are available.
Property | NoRowsTextBox | Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.
Property | OverflowName | Overflow name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Gets a value indicating whether the page should break at the end of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | PageBreakAtStart | Gets a value indicating whether the page should break at the start of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IDataRegion Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IDataRegion Interface Properties

IDataRegion Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDataRegion Interface

For a list of all members of this type, see IDataRegion members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataSetName | Specifies which data set to use for this data region.
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | NoRows | Indicates if the DataRegion has no rows available.
Property | NoRowsMessage | Message to display in the DataRegion when no rows of data are available.
Property | NoRowsTextBox | Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.
Property | OverflowName | Overflow name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Gets a value indicating whether the page should break at the end of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | PageBreakAtStart | Gets a value indicating whether the page should break at the start of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IDataRegion Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


DataSetName Property (IDataRegion)

DataSetName Property (IDataRegion)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDataRegion Interface : DataSetName Property
Specifies which data set to use for this data region.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataSetName As System.String
System.string DataSetName {get;}
See Also

Reference

IDataRegion Interface
IDataRegion Members


NoRows Property (IDataRegion)

NoRows Property (IDataRegion)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDataRegion Interface : NoRows Property
Indicates if the DataRegion has no rows available.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property NoRows As System.Boolean
System.bool NoRows {get;}
See Also

Reference

IDataRegion Interface
IDataRegion Members


NoRowsMessage Property (IDataRegion)

NoRowsMessage Property (IDataRegion)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDataRegion Interface : NoRowsMessage Property
Message to display in the DataRegion when no rows of data are available.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property NoRowsMessage As System.String
System.string NoRowsMessage {get;}
See Also

Reference

IDataRegion Interface
IDataRegion Members


NoRowsTextBox Property (IDataRegion)

NoRowsTextBox Property (IDataRegion)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDataRegion Interface : NoRowsTextBox Property
Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property NoRowsTextBox As ITextBox
ITextBox NoRowsTextBox {get;}
See Also

Reference

IDataRegion Interface
IDataRegion Members


IDataRegionOverflow Interface

IDataRegionOverflow Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDataRegionOverflow Interface
This interface is needed to work with objects that are fully implemented DataRegion. It is used for OverflowPlaceHolderLayoutManager ustnovki properties OverflowName (!). It smells, But it's the best thing I can do now.
Object Model
IDataRegionOverflow Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDataRegionOverflow
   Inherits IDataRegion, IDocumentMapItem, IOverflowItem, IPageRegion, IRenderComponent, IReportItem, ISectionRegion
public interface IDataRegionOverflow : IDataRegion, IDocumentMapItem, IOverflowItem, IPageRegion, IRenderComponent, IReportItem, ISectionRegion
See Also

Reference

IDataRegionOverflow Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IDataRegionOverflow Interface Members

IDataRegionOverflow Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDataRegionOverflow Interface

The following tables list the members exposed by IDataRegionOverflow.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataSetName | Specifies which data set to use for this data region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | NoRows | Indicates if the DataRegion has no rows available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsMessage | Message to display in the DataRegion when no rows of data are available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsTextBox | Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.Returns a renderable textbox suitable for displaying NoRowsMessage for this instance. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | OverflowName | Overflow name
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Gets a value indicating whether the page should break at the end of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | PageBreakAtStart | Gets a value indicating whether the page should break at the start of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IDataRegionOverflow Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IDataRegionOverflow Interface Properties

IDataRegionOverflow Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDataRegionOverflow Interface

For a list of all members of this type, see IDataRegionOverflow members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataSetName | Specifies which data set to use for this data region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | NoRows | Indicates if the DataRegion has no rows available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsMessage | Message to display in the DataRegion when no rows of data are available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsTextBox | Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.Returns a renderable textbox suitable for displaying NoRowsMessage for this instance. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | OverflowName | Overflow name
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Gets a value indicating whether the page should break at the end of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | PageBreakAtStart | Gets a value indicating whether the page should break at the start of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IDataRegionOverflow Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


OverflowName Property (IDataRegionOverflow)

OverflowName Property (IDataRegionOverflow)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDataRegionOverflow Interface : OverflowName Property
Overflow name
Syntax
  • Visual Basic
  • C#
'Declaration

Property OverflowName As System.String
System.string OverflowName {get; set;}
See Also

Reference

IDataRegionOverflow Interface
IDataRegionOverflow Members


IDataScope Interface

IDataScope Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDataScope Interface
Represents a data scope in a report at rendering time.
Object Model
IDataScope Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDataScope
public interface IDataScope
See Also

Reference

IDataScope Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IDataScope Interface Members

IDataScope Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDataScope Interface

The following tables list the members exposed by IDataScope.

Public Properties
 | Name | Description
Property | Label | Returns the document map label for the current grouping or an empty string if the grouping does not have a document map label.
Property | Name | Specifies the name of the current scope.
Property | Parents | The data scopes that are considered direct parents of the current scope.
Property | ToggleReceiver | Specifies the component that can be toggled for the current scope if there is one.
Top
Public Methods
 | Name | Description
Method | GetReportItem | Returns the instance of the specified IReportItem.
Method | GetService | (Inherited from System.IServiceProvider)
Top
See Also

Reference

IDataScope Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IDataScope Interface Methods

IDataScope Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDataScope Interface

For a list of all members of this type, see IDataScope members.

Public Methods
 | Name | Description
Method | GetReportItem | Returns the instance of the specified IReportItem.
Method | GetService | (Inherited from System.IServiceProvider)
Top
See Also

Reference

IDataScope Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetReportItem Method

GetReportItem Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDataScope Interface : GetReportItem Method
The name of the report item to get.
Returns the instance of the specified IReportItem.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetReportItem( _
   ByVal reportItemName As System.String _
) As IReportItem
IReportItem GetReportItem(
   System.string reportItemName
)

Parameters

reportItemName
The name of the report item to get.

Return Value

The specified report item or null if it does not exist in the current scope.
Remarks
The report item must exist in the current scope.
See Also

Reference

IDataScope Interface
IDataScope Members


IDataScope Interface Properties

IDataScope Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDataScope Interface

For a list of all members of this type, see IDataScope members.

Public Properties
 | Name | Description
Property | Label | Returns the document map label for the current grouping or an empty string if the grouping does not have a document map label.
Property | Name | Specifies the name of the current scope.
Property | Parents | The data scopes that are considered direct parents of the current scope.
Property | ToggleReceiver | Specifies the component that can be toggled for the current scope if there is one.
Top
See Also

Reference

IDataScope Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Label Property (IDataScope)

Label Property (IDataScope)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDataScope Interface : Label Property
Returns the document map label for the current grouping or an empty string if the grouping does not have a document map label.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Label As System.String
System.string Label {get;}
See Also

Reference

IDataScope Interface
IDataScope Members


Name Property (IDataScope)

Name Property (IDataScope)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDataScope Interface : Name Property
Specifies the name of the current scope.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Name As System.String
System.string Name {get;}
Remarks
Some scopes may be unnamed and return an empty string.
See Also

Reference

IDataScope Interface
IDataScope Members


Parents Property

Parents Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDataScope Interface : Parents Property
The data scopes that are considered direct parents of the current scope.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Parents As IDataScope()
IDataScope[] Parents {get;}
Remarks
A scope can have zero or more parents. For example, if the current scope represents a matrix cell, it will have a parent from each of the leaf members on the row and column axis. However, a grouping or data region will have only one parent.
See Also

Reference

IDataScope Interface
IDataScope Members


ToggleReceiver Property

ToggleReceiver Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDataScope Interface : ToggleReceiver Property
Specifies the component that can be toggled for the current scope if there is one.
Syntax
  • Visual Basic
  • C#
'Declaration

Property ToggleReceiver As IToggleReceiver
IToggleReceiver ToggleReceiver {get; set;}
See Also

Reference

IDataScope Interface
IDataScope Members


IDetailBandCollection Interface

IDetailBandCollection Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDetailBandCollection Interface
Interface for the detail band object.
Object Model
IDetailBandCollection Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDetailBandCollection
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection(Of IBand)
public interface IDetailBandCollection : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<IBand>
See Also

Reference

IDetailBandCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IDetailBandCollection Interface Members

IDetailBandCollection Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDetailBandCollection Interface

The following tables list the members exposed by IDetailBandCollection.

Public Properties
 | Name | Description
Property | Count | Gets number of items in the collection. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<IBand>)
Property | Item | Returns the IDetailBand with the specified name.
Top
See Also

Reference

IDetailBandCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IDetailBandCollection Interface Properties

IDetailBandCollection Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDetailBandCollection Interface

For a list of all members of this type, see IDetailBandCollection members.

Public Properties
 | Name | Description
Property | Count | Gets number of items in the collection. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<IBand>)
Property | Item | Returns the IDetailBand with the specified name.
Top
See Also

Reference

IDetailBandCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Item Property (IDetailBandCollection)

Item Property (IDetailBandCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDetailBandCollection Interface : Item Property
Returns the IDetailBand with the specified name.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Default Property Item( _
   ByVal name As System.String _
) As IBand
IBand this[
   System.string name
]; {get;}

Parameters

name
See Also

Reference

IDetailBandCollection Interface
IDetailBandCollection Members


IDocumentMapItem Interface

IDocumentMapItem Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDocumentMapItem Interface
Interface to unify document map nodes.
Object Model
IDocumentMapItem Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDocumentMapItem
public interface IDocumentMapItem
See Also

Reference

IDocumentMapItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IDocumentMapItem Interface Members

IDocumentMapItem Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDocumentMapItem Interface

The following tables list the members exposed by IDocumentMapItem.

Public Properties
 | Name | Description
Property | Label | Gets document map label.
Top
See Also

Reference

IDocumentMapItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IDocumentMapItem Interface Properties

IDocumentMapItem Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDocumentMapItem Interface

For a list of all members of this type, see IDocumentMapItem members.

Public Properties
 | Name | Description
Property | Label | Gets document map label.
Top
See Also

Reference

IDocumentMapItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Label Property (IDocumentMapItem)

Label Property (IDocumentMapItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDocumentMapItem Interface : Label Property
Gets document map label.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Label As System.String
System.string Label {get;}
See Also

Reference

IDocumentMapItem Interface
IDocumentMapItem Members


IDrillthrough Interface

IDrillthrough Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDrillthrough Interface
Interface for drill through object.
Object Model
IDrillthrough Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDrillthrough
public interface IDrillthrough
See Also

Reference

IDrillthrough Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IDrillthrough Interface Members

IDrillthrough Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDrillthrough Interface

The following tables list the members exposed by IDrillthrough.

Public Properties
 | Name | Description
Property | NumberOfParameters | Specifies drillthrough parameters count.
Property | Parameters | Specifies drillthrough parameters.
Property | ReportName | The path of the drillthrough report. Paths may be absolute or relative.
Top
See Also

Reference

IDrillthrough Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IDrillthrough Interface Properties

IDrillthrough Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDrillthrough Interface

For a list of all members of this type, see IDrillthrough members.

Public Properties
 | Name | Description
Property | NumberOfParameters | Specifies drillthrough parameters count.
Property | Parameters | Specifies drillthrough parameters.
Property | ReportName | The path of the drillthrough report. Paths may be absolute or relative.
Top
See Also

Reference

IDrillthrough Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


NumberOfParameters Property

NumberOfParameters Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDrillthrough Interface : NumberOfParameters Property
Specifies drillthrough parameters count.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property NumberOfParameters As System.Integer
System.int NumberOfParameters {get;}
See Also

Reference

IDrillthrough Interface
IDrillthrough Members


Parameters Property (IDrillthrough)

Parameters Property (IDrillthrough)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDrillthrough Interface : Parameters Property
Specifies drillthrough parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Parameters As DrillthroughParameter()
DrillthroughParameter[] Parameters {get;}
See Also

Reference

IDrillthrough Interface
IDrillthrough Members


ReportName Property (IDrillthrough)

ReportName Property (IDrillthrough)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDrillthrough Interface : ReportName Property
The path of the drillthrough report. Paths may be absolute or relative.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ReportName As System.String
System.string ReportName {get;}
See Also

Reference

IDrillthrough Interface
IDrillthrough Members


IFixedPage Interface

IFixedPage Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFixedPage Interface
Defines container of IFixedPageContent objects.
Object Model
IFixedPage Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IFixedPage
   Inherits IDataRegion, IDocumentMapItem, IOverflowItem, IPageRegion, IRenderComponent, IReportItem, ISectionRegion
public interface IFixedPage : IDataRegion, IDocumentMapItem, IOverflowItem, IPageRegion, IRenderComponent, IReportItem, ISectionRegion
See Also

Reference

IFixedPage Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IFixedPage Interface Members

IFixedPage Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFixedPage Interface

The following tables list the members exposed by IFixedPage.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Contents | Returns the IFixedPageContents objects in this container.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataSetName | Specifies which data set to use for this data region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | NoRows | Indicates if the DataRegion has no rows available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsMessage | Message to display in the DataRegion when no rows of data are available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsTextBox | Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.Returns a renderable textbox suitable for displaying NoRowsMessage for this instance. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | OverflowName | Overflow name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Gets a value indicating whether the page should break at the end of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | PageBreakAtStart | Gets a value indicating whether the page should break at the start of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | GetStyle | Gets the style object of the specified page.
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IFixedPage Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IFixedPage Interface Methods

IFixedPage Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFixedPage Interface

For a list of all members of this type, see IFixedPage members.

Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | GetStyle | Gets the style object of the specified page.
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IFixedPage Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetStyle Method

GetStyle Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IFixedPage Interface : GetStyle Method
The index of the page.
Gets the style object of the specified page.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetStyle( _
   ByVal pageIndex As System.Integer _
) As IStyle
IStyle GetStyle(
   System.int pageIndex
)

Parameters

pageIndex
The index of the page.
See Also

Reference

IFixedPage Interface
IFixedPage Members


IFixedPage Interface Properties

IFixedPage Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFixedPage Interface

For a list of all members of this type, see IFixedPage members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Contents | Returns the IFixedPageContents objects in this container.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataSetName | Specifies which data set to use for this data region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | NoRows | Indicates if the DataRegion has no rows available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsMessage | Message to display in the DataRegion when no rows of data are available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsTextBox | Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.Returns a renderable textbox suitable for displaying NoRowsMessage for this instance. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | OverflowName | Overflow name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Gets a value indicating whether the page should break at the end of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | PageBreakAtStart | Gets a value indicating whether the page should break at the start of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IFixedPage Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Contents Property (IFixedPage)

Contents Property (IFixedPage)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IFixedPage Interface : Contents Property
Returns the IFixedPageContents objects in this container.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Contents As System.Collections.Generic.IList(Of IFixedPageContent)
System.Collections.Generic.IList<IFixedPageContent> Contents {get;}
See Also

Reference

IFixedPage Interface
IFixedPage Members


IFixedPageContent Interface

IFixedPageContent Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFixedPageContent Interface
Defines content of a single FixedPage instance.
Object Model
IFixedPageContent Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IFixedPageContent
   Inherits IDocumentMapItem, ISectionRegion
public interface IFixedPageContent : IDocumentMapItem, ISectionRegion
See Also

Reference

IFixedPageContent Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IFixedPageContent Interface Members

IFixedPageContent Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFixedPageContent Interface

The following tables list the members exposed by IFixedPageContent.

Public Properties
 | Name | Description
Property | Label | Returns the label of the current content. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | Pages | Returns the pages in this container.
Top
See Also

Reference

IFixedPageContent Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IFixedPageContent Interface Properties

IFixedPageContent Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFixedPageContent Interface

For a list of all members of this type, see IFixedPageContent members.

Public Properties
 | Name | Description
Property | Label | Returns the label of the current content. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | Pages | Returns the pages in this container.
Top
See Also

Reference

IFixedPageContent Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Pages Property (IFixedPageContent)

Pages Property (IFixedPageContent)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IFixedPageContent Interface : Pages Property
Returns the pages in this container.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Pages As IItemCollection(Of IPage)
IItemCollection<IPage> Pages {get;}
See Also

Reference

IFixedPageContent Interface
IFixedPageContent Members


IFooterBand Interface

IFooterBand Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFooterBand Interface
Interface for the footer band of the banded list.
Object Model
IFooterBand Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IFooterBand
   Inherits IBand, IDocumentMapItem, IRenderComponent, IReportItem, IReportItemContainer
public interface IFooterBand : IBand, IDocumentMapItem, IRenderComponent, IReportItem, IReportItemContainer
See Also

Reference

IFooterBand Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IFooterBand Interface Members

IFooterBand Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFooterBand Interface

The following tables list the members exposed by IFooterBand.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | CanGrow | Indicates that this band can grow in vertical direction. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IBand)
Property | CanShrink | Indicates that this Band can shrink in vertical direction. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IBand)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Specifies, if the Band should try to keep the content together. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IBand)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Returns PageBreakAtEnd property for this Band. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IBand)
Property | PageBreakAtStart | Returns PageBreakAtStart property for this Band. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IBand)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | PrintAtBottom | Indicates that this footer band will print at the bottom of the page.
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RepeatOnNewPage | Indicates that this footer band will repeat on each new page.
Property | ReportItems | Returns the IReportItem objects in this container. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemContainer)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IFooterBand Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IFooterBand Interface Properties

IFooterBand Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFooterBand Interface

For a list of all members of this type, see IFooterBand members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | CanGrow | Indicates that this band can grow in vertical direction. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IBand)
Property | CanShrink | Indicates that this Band can shrink in vertical direction. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IBand)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Specifies, if the Band should try to keep the content together. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IBand)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Returns PageBreakAtEnd property for this Band. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IBand)
Property | PageBreakAtStart | Returns PageBreakAtStart property for this Band. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IBand)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | PrintAtBottom | Indicates that this footer band will print at the bottom of the page.
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RepeatOnNewPage | Indicates that this footer band will repeat on each new page.
Property | ReportItems | Returns the IReportItem objects in this container. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemContainer)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IFooterBand Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


PrintAtBottom Property (IFooterBand)

PrintAtBottom Property (IFooterBand)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IFooterBand Interface : PrintAtBottom Property
Indicates that this footer band will print at the bottom of the page.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PrintAtBottom As System.Boolean
System.bool PrintAtBottom {get;}
See Also

Reference

IFooterBand Interface
IFooterBand Members


RepeatOnNewPage Property (IFooterBand)

RepeatOnNewPage Property (IFooterBand)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IFooterBand Interface : RepeatOnNewPage Property
Indicates that this footer band will repeat on each new page.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RepeatOnNewPage As System.Boolean
System.bool RepeatOnNewPage {get;}
See Also

Reference

IFooterBand Interface
IFooterBand Members


IFormattedText Interface

IFormattedText Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFormattedText Interface
Defines the formatted text rendering component.
Object Model
IFormattedText Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IFormattedText
public interface IFormattedText
See Also

Reference

IFormattedText Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IFormattedText Interface Members

IFormattedText Interface Members
Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFormattedText Interface

The following tables list the members exposed by IFormattedText.

Public Methods
 | Name | Description
Method | GenerateHtml | Returns the html of the specified layout area of the formatted text rendering component.
Method | GenerateInnerXhtml | Returns the html content of the current formatted text rendering component.
Top
See Also

Reference

IFormattedText Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IFormattedText Interface Methods

IFormattedText Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFormattedText Interface

For a list of all members of this type, see IFormattedText members.

Public Methods
 | Name | Description
Method | GenerateHtml | Returns the html of the specified layout area of the formatted text rendering component.
Method | GenerateInnerXhtml | Returns the html content of the current formatted text rendering component.
Top
See Also

Reference

IFormattedText Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GenerateHtml Method

GenerateHtml Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IFormattedText Interface : GenerateHtml Method
The layout area to return the html for.
Returns the html of the specified layout area of the formatted text rendering component.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GenerateHtml( _
   ByVal formattedTextArea As ILayoutArea _
) As System.String
System.string GenerateHtml(
   ILayoutArea formattedTextArea
)

Parameters

formattedTextArea
The layout area to return the html for.
See Also

Reference

IFormattedText Interface
IFormattedText Members


GenerateInnerXhtml Method

GenerateInnerXhtml Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IFormattedText Interface : GenerateInnerXhtml Method
The layout area to return the Xhtml for.
Returns the html content of the current formatted text rendering component.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GenerateInnerXhtml( _
   ByVal formattedTextArea As ILayoutArea _
) As System.String
System.string GenerateInnerXhtml(
   ILayoutArea formattedTextArea
)

Parameters

formattedTextArea
The layout area to return the Xhtml for.
See Also

Reference

IFormattedText Interface
IFormattedText Members


IHeaderBand Interface

IHeaderBand Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IHeaderBand Interface
Interface for the header band of the banded list.
Object Model
IHeaderBand Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IHeaderBand
   Inherits IBand, IDocumentMapItem, IRenderComponent, IReportItem, IReportItemContainer
public interface IHeaderBand : IBand, IDocumentMapItem, IRenderComponent, IReportItem, IReportItemContainer
See Also

Reference

IHeaderBand Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IHeaderBand Interface Members

IHeaderBand Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IHeaderBand Interface

The following tables list the members exposed by IHeaderBand.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | CanGrow | Indicates that this band can grow in vertical direction. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IBand)
Property | CanShrink | Indicates that this Band can shrink in vertical direction. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IBand)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Specifies, if the Band should try to keep the content together. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IBand)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Returns PageBreakAtEnd property for this Band. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IBand)
Property | PageBreakAtStart | Returns PageBreakAtStart property for this Band. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IBand)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RepeatOnNewPage | Indicates that this header band will repeat on each new page.
Property | ReportItems | Returns the IReportItem objects in this container. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemContainer)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IHeaderBand Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IHeaderBand Interface Properties

IHeaderBand Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IHeaderBand Interface

For a list of all members of this type, see IHeaderBand members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | CanGrow | Indicates that this band can grow in vertical direction. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IBand)
Property | CanShrink | Indicates that this Band can shrink in vertical direction. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IBand)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Specifies, if the Band should try to keep the content together. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IBand)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Returns PageBreakAtEnd property for this Band. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IBand)
Property | PageBreakAtStart | Returns PageBreakAtStart property for this Band. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IBand)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RepeatOnNewPage | Indicates that this header band will repeat on each new page.
Property | ReportItems | Returns the IReportItem objects in this container. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemContainer)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IHeaderBand Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


RepeatOnNewPage Property (IHeaderBand)

RepeatOnNewPage Property (IHeaderBand)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IHeaderBand Interface : RepeatOnNewPage Property
Indicates that this header band will repeat on each new page.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RepeatOnNewPage As System.Boolean
System.bool RepeatOnNewPage {get;}
See Also

Reference

IHeaderBand Interface
IHeaderBand Members


IImage Interface

IImage Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IImage Interface
Interface for images.
Object Model
IImage Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IImage
   Inherits IDocumentMapItem, IRenderComponent, IReportItem, IStaticItem
public interface IImage : IDocumentMapItem, IRenderComponent, IReportItem, IStaticItem
See Also

Reference

IImage Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IImage Interface Members

IImage Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IImage Interface

The following tables list the members exposed by IImage.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | CanGrow | Specifies whether the image can grow.
Property | CanShrink | Specifies whether the image can shrink.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | HorizontalAlignment | Gets the horizontal alignment of the picture that is shown by the Image Report Item.
Property | HorizontalResolution | Horizontal resolution (DPI) of the image.
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | MimeType | Identifies the Multipurpose Internet Mail Extensions (MIME) type of the image.
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Sizing | Determines the behavior if the image doesn't fit within the specified size.
Property | Source | Indicates the source of the image specified in the Value property.
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Value | Identifies the source of the image.
Property | VerticalAlignment | Gets the vertical alignment of the picture that is shown by the Image Report Item.
Property | VerticalResolution | Vertical resolution (DPI) of the image.
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetDrawImageCopy | Returns a copy of image data as System.Drawing.Image
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IImage Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IImage Interface Methods

IImage Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IImage Interface

For a list of all members of this type, see IImage members.

Public Methods
 | Name | Description
Method | GetDrawImageCopy | Returns a copy of image data as System.Drawing.Image
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IImage Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetDrawImageCopy Method

GetDrawImageCopy Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IImage Interface : GetDrawImageCopy Method
Returns a copy of image data as System.Drawing.Image
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetDrawImageCopy() As Image
Image GetDrawImageCopy()
See Also

Reference

IImage Interface
IImage Members


IImage Interface Properties

IImage Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IImage Interface

For a list of all members of this type, see IImage members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | CanGrow | Specifies whether the image can grow.
Property | CanShrink | Specifies whether the image can shrink.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | HorizontalAlignment | Gets the horizontal alignment of the picture that is shown by the Image Report Item.
Property | HorizontalResolution | Horizontal resolution (DPI) of the image.
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | MimeType | Identifies the Multipurpose Internet Mail Extensions (MIME) type of the image.
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Sizing | Determines the behavior if the image doesn't fit within the specified size.
Property | Source | Indicates the source of the image specified in the Value property.
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Value | Identifies the source of the image.
Property | VerticalAlignment | Gets the vertical alignment of the picture that is shown by the Image Report Item.
Property | VerticalResolution | Vertical resolution (DPI) of the image.
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IImage Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


CanGrow Property (IImage)

CanGrow Property (IImage)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IImage Interface : CanGrow Property
Specifies whether the image can grow.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CanGrow As System.Boolean
System.bool CanGrow {get;}
See Also

Reference

IImage Interface
IImage Members


CanShrink Property (IImage)

CanShrink Property (IImage)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IImage Interface : CanShrink Property
Specifies whether the image can shrink.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CanShrink As System.Boolean
System.bool CanShrink {get;}
See Also

Reference

IImage Interface
IImage Members


HorizontalAlignment Property (IImage)

HorizontalAlignment Property (IImage)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IImage Interface : HorizontalAlignment Property
Gets the horizontal alignment of the picture that is shown by the Image Report Item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property HorizontalAlignment As System.String
System.string HorizontalAlignment {get;}
See Also

Reference

IImage Interface
IImage Members


HorizontalResolution Property (IImage)

HorizontalResolution Property (IImage)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IImage Interface : HorizontalResolution Property
Horizontal resolution (DPI) of the image.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property HorizontalResolution As System.Single
System.float HorizontalResolution {get;}
See Also

Reference

IImage Interface
IImage Members


MimeType Property (IImage)

MimeType Property (IImage)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IImage Interface : MimeType Property
Identifies the Multipurpose Internet Mail Extensions (MIME) type of the image.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MimeType As System.String
System.string MimeType {get;}
See Also

Reference

IImage Interface
IImage Members


Sizing Property (IImage)

Sizing Property (IImage)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IImage Interface : Sizing Property
Determines the behavior if the image doesn't fit within the specified size.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Sizing As ImageSizing
ImageSizing Sizing {get;}
See Also

Reference

IImage Interface
IImage Members


Source Property (IImage)

Source Property (IImage)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IImage Interface : Source Property
Indicates the source of the image specified in the Value property.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Source As ImageSource
ImageSource Source {get;}
See Also

Reference

IImage Interface
IImage Members


Value Property (IImage)

Value Property (IImage)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IImage Interface : Value Property
Identifies the source of the image.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Value As System.Object
System.object Value {get;}
See Also

Reference

IImage Interface
IImage Members


VerticalAlignment Property (IImage)

VerticalAlignment Property (IImage)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IImage Interface : VerticalAlignment Property
Gets the vertical alignment of the picture that is shown by the Image Report Item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property VerticalAlignment As System.String
System.string VerticalAlignment {get;}
See Also

Reference

IImage Interface
IImage Members


VerticalResolution Property (IImage)

VerticalResolution Property (IImage)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IImage Interface : VerticalResolution Property
Vertical resolution (DPI) of the image.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property VerticalResolution As System.Single
System.float VerticalResolution {get;}
See Also

Reference

IImage Interface
IImage Members


IImageLocator Interface

IImageLocator Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IImageLocator Interface
Represents the service to get images.
Object Model
IImageLocator Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IImageLocator
public interface IImageLocator
See Also

Reference

IImageLocator Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IImageLocator Interface Members

IImageLocator Interface Members
Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IImageLocator Interface

The following tables list the members exposed by IImageLocator.

Public Methods
 | Name | Description
Method | GetImage | Retrieves image from specified source.
Top
See Also

Reference

IImageLocator Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IImageLocator Interface Methods

IImageLocator Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IImageLocator Interface

For a list of all members of this type, see IImageLocator members.

Public Methods
 | Name | Description
Method | GetImage | Retrieves image from specified source.
Top
See Also

Reference

IImageLocator Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetImage Method (IImageLocator)

GetImage Method (IImageLocator)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IImageLocator Interface : GetImage Method
The image source.
The image mime type.
The value.
Retrieves image from specified source.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetImage( _
   ByVal imageSource As ImageSource, _
   ByVal mimeType As System.String, _
   ByVal value As System.Object _
) As Image
Image GetImage(
   ImageSource imageSource,
   System.string mimeType,
   System.object value
)

Parameters

imageSource
The image source.
mimeType
The image mime type.
value
The value.
See Also

Reference

IImageLocator Interface
IImageLocator Members


IItemCollection<T> Interface

IItemCollection<T> Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IItemCollection<T> Interface
Represents the collection of T objects.
Object Model
IItemCollection<T> Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IItemCollection(Of T)
public interface IItemCollection<T>
Type Parameters
T
See Also

Reference

IItemCollection<T> Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IItemCollection<T> Interface Members

IItemCollection<T> Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IItemCollection<T> Interface

The following tables list the members exposed by IItemCollection<T>.

Public Properties
 | Name | Description
Property | Count | Gets number of items in the collection.
Property | Item | Gets the T at the specified index.
Top
See Also

Reference

IItemCollection<T> Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IItemCollection<T> Interface Properties

IItemCollection<T> Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IItemCollection<T> Interface

For a list of all members of this type, see IItemCollection<T> members.

Public Properties
 | Name | Description
Property | Count | Gets number of items in the collection.
Property | Item | Gets the T at the specified index.
Top
See Also

Reference

IItemCollection<T> Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Count Property (IItemCollection<T>)

Count Property (IItemCollection<T>)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IItemCollection<T> Interface : Count Property
Gets number of items in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Count As System.Integer
System.int Count {get;}
See Also

Reference

IItemCollection<T> Interface
IItemCollection<T> Members


Item Property (IItemCollection<T>)

Item Property (IItemCollection<T>)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IItemCollection<T> Interface : Item Property
Gets the T at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As T
T this[
   System.int index
]; {get;}

Parameters

index
See Also

Reference

IItemCollection<T> Interface
IItemCollection<T> Members


IList Interface

IList Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IList Interface
Interface for the List ReportItem.
Object Model
IList Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IList
   Inherits IDataRegion, IDocumentMapItem, IOverflowItem, IPageRegion, IRenderComponent, IReportItem, ISectionRegion
public interface IList : IDataRegion, IDocumentMapItem, IOverflowItem, IPageRegion, IRenderComponent, IReportItem, ISectionRegion
See Also

Reference

IList Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IList Interface Members

IList Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IList Interface

The following tables list the members exposed by IList.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | CanGrowHorizontally | Specifies if the List can grow horizontally.
Property | Contents | Provides the instances of this list control based on the data.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataSetName | Specifies which data set to use for this data region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | NoRows | Indicates if the DataRegion has no rows available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsMessage | Message to display in the DataRegion when no rows of data are available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsTextBox | Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.Returns a renderable textbox suitable for displaying NoRowsMessage for this instance. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | OverflowName | Overflow name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Gets a value indicating whether the page should break at the end of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | PageBreakAtStart | Gets a value indicating whether the page should break at the start of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IList Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IList Interface Properties

IList Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IList Interface

For a list of all members of this type, see IList members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | CanGrowHorizontally | Specifies if the List can grow horizontally.
Property | Contents | Provides the instances of this list control based on the data.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataSetName | Specifies which data set to use for this data region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | NoRows | Indicates if the DataRegion has no rows available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsMessage | Message to display in the DataRegion when no rows of data are available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsTextBox | Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.Returns a renderable textbox suitable for displaying NoRowsMessage for this instance. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | OverflowName | Overflow name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Gets a value indicating whether the page should break at the end of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | PageBreakAtStart | Gets a value indicating whether the page should break at the start of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IList Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


CanGrowHorizontally Property (IList)

CanGrowHorizontally Property (IList)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IList Interface : CanGrowHorizontally Property
Specifies if the List can grow horizontally.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CanGrowHorizontally As System.Boolean
System.bool CanGrowHorizontally {get;}
See Also

Reference

IList Interface
IList Members


Contents Property (IList)

Contents Property (IList)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IList Interface : Contents Property
Provides the instances of this list control based on the data.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Contents As IItemCollection(Of IListContent)
IItemCollection<IListContent> Contents {get;}
See Also

Reference

IList Interface
IList Members


IListContentCollection Interface

IListContentCollection Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IListContentCollection Interface
Interface for a collection of List report items.
Object Model
IListContentCollection Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IListContentCollection
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection(Of IListContent)
public interface IListContentCollection : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<IListContent>
See Also

Reference

IListContentCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IListContentCollection Interface Members

IListContentCollection Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IListContentCollection Interface

The following tables list the members exposed by IListContentCollection.

Public Properties
 | Name | Description
Property | Count | Gets number of items in the collection. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<IListContent>)
Property | Item | Gets the T at the specified index. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<IListContent>)
Top
See Also

Reference

IListContentCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IMetadataDictionary Interface

IMetadataDictionary Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IMetadataDictionary Interface
Interface for a dictionary of meta data objects.
Object Model
IMetadataDictionary Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMetadataDictionary
   Inherits IMetadataDictionaryEntry, IMetadataEntry
public interface IMetadataDictionary : IMetadataDictionaryEntry, IMetadataEntry
See Also

Reference

IMetadataDictionary Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IMetadataDictionary Interface Members

IMetadataDictionary Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IMetadataDictionary Interface

The following tables list the members exposed by IMetadataDictionary.

Public Properties
 | Name | Description
Property | Contents | Gets the contents of this object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataDictionaryEntry)
Property | ContentType | Specifies content type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataEntry)
Property | ID | Gets the identifier of this object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataDictionaryEntry)
Property | Item | Returns IMetadataDictionaryEntry with specified id.
Property | LayoutArea | Specifies the LayoutArea instance referenced directly or indirectly via Contents. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataDictionaryEntry)
Property | Name | Gets the name of this object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataDictionaryEntry)
Property | ReportItem | Specifies the IMetadataDictionaryEntry.ReportItem referenced directly (for Document Map) or indirectly via Contents. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataDictionaryEntry)
Property | VisualRectangle | Gets the visual rectangle of this object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataDictionaryEntry)
Property | VisualShape | Specifies the metadata visual representation. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataEntry)
Top
Public Methods
 | Name | Description
Method | Add | Overloaded.
Method | AreaFromPoint | Returns area from the map, containing specified point (if any).
Top
See Also

Reference

IMetadataDictionary Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IMetadataDictionary Interface Methods

IMetadataDictionary Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IMetadataDictionary Interface

For a list of all members of this type, see IMetadataDictionary members.

Public Methods
 | Name | Description
Method | Add | Overloaded.
Method | AreaFromPoint | Returns area from the map, containing specified point (if any).
Top
See Also

Reference

IMetadataDictionary Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Add Method (IMetadataDictionary)

Add Method (IMetadataDictionary)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataDictionary Interface : Add Method
Overloaded.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Add( _
   ByVal entry As IMetadataDictionaryEntry _
)
void Add(
   IMetadataDictionaryEntry entry
)

Parameters

entry
See Also

Reference

IMetadataDictionary Interface
IMetadataDictionary Members


AreaFromPoint Method

AreaFromPoint Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataDictionary Interface : AreaFromPoint Method
The point to return the area for.
Returns area from the map, containing specified point (if any).
Syntax
  • Visual Basic
  • C#
'Declaration

Function AreaFromPoint( _
   ByVal fromPoint As PointFEx _
) As IMetadataDictionaryEntry
IMetadataDictionaryEntry AreaFromPoint(
   PointFEx fromPoint
)

Parameters

fromPoint
The point to return the area for.
See Also

Reference

IMetadataDictionary Interface
IMetadataDictionary Members


IMetadataDictionary Interface Properties

IMetadataDictionary Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IMetadataDictionary Interface

For a list of all members of this type, see IMetadataDictionary members.

Public Properties
 | Name | Description
Property | Contents | Gets the contents of this object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataDictionaryEntry)
Property | ContentType | Specifies content type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataEntry)
Property | ID | Gets the identifier of this object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataDictionaryEntry)
Property | Item | Returns IMetadataDictionaryEntry with specified id.
Property | LayoutArea | Specifies the LayoutArea instance referenced directly or indirectly via Contents. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataDictionaryEntry)
Property | Name | Gets the name of this object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataDictionaryEntry)
Property | ReportItem | Specifies the IMetadataDictionaryEntry.ReportItem referenced directly (for Document Map) or indirectly via Contents. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataDictionaryEntry)
Property | VisualRectangle | Gets the visual rectangle of this object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataDictionaryEntry)
Property | VisualShape | Specifies the metadata visual representation. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataEntry)
Top
See Also

Reference

IMetadataDictionary Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Item Property (IMetadataDictionary)

Item Property (IMetadataDictionary)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataDictionary Interface : Item Property
Returns IMetadataDictionaryEntry with specified id.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Default Property Item( _
   ByVal id As System.String _
) As IMetadataDictionaryEntry
IMetadataDictionaryEntry this[
   System.string id
]; {get;}

Parameters

id
See Also

Reference

IMetadataDictionary Interface
IMetadataDictionary Members


IMetadataDictionaryEntry Interface

IMetadataDictionaryEntry Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IMetadataDictionaryEntry Interface
Interface for members of the IMetadataDictionary
Object Model
IMetadataDictionaryEntry Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMetadataDictionaryEntry
   Inherits IMetadataEntry
public interface IMetadataDictionaryEntry : IMetadataEntry
See Also

Reference

IMetadataDictionaryEntry Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IMetadataDictionaryEntry Interface Members

IMetadataDictionaryEntry Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IMetadataDictionaryEntry Interface

The following tables list the members exposed by IMetadataDictionaryEntry.

Public Properties
 | Name | Description
Property | Contents | Gets the contents of this object.
Property | ContentType | Specifies content type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataEntry)
Property | ID | Gets the identifier of this object.
Property | LayoutArea | Specifies the LayoutArea instance referenced directly or indirectly via Contents.
Property | Name | Gets the name of this object.
Property | ReportItem | Specifies the ReportItem referenced directly (for Document Map) or indirectly via Contents.
Property | VisualRectangle | Gets the visual rectangle of this object.
Property | VisualShape | Specifies the metadata visual representation. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataEntry)
Top
See Also

Reference

IMetadataDictionaryEntry Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IMetadataDictionaryEntry Interface Properties

IMetadataDictionaryEntry Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IMetadataDictionaryEntry Interface

For a list of all members of this type, see IMetadataDictionaryEntry members.

Public Properties
 | Name | Description
Property | Contents | Gets the contents of this object.
Property | ContentType | Specifies content type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataEntry)
Property | ID | Gets the identifier of this object.
Property | LayoutArea | Specifies the LayoutArea instance referenced directly or indirectly via Contents.
Property | Name | Gets the name of this object.
Property | ReportItem | Specifies the ReportItem referenced directly (for Document Map) or indirectly via Contents.
Property | VisualRectangle | Gets the visual rectangle of this object.
Property | VisualShape | Specifies the metadata visual representation. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IMetadataEntry)
Top
See Also

Reference

IMetadataDictionaryEntry Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Contents Property (IMetadataDictionaryEntry)

Contents Property (IMetadataDictionaryEntry)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataDictionaryEntry Interface : Contents Property
Gets the contents of this object.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Contents As System.Object
System.object Contents {get;}
See Also

Reference

IMetadataDictionaryEntry Interface
IMetadataDictionaryEntry Members


ID Property (IMetadataDictionaryEntry)

ID Property (IMetadataDictionaryEntry)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataDictionaryEntry Interface : ID Property
Gets the identifier of this object.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ID As System.String
System.string ID {get;}
See Also

Reference

IMetadataDictionaryEntry Interface
IMetadataDictionaryEntry Members


LayoutArea Property (IMetadataDictionaryEntry)

LayoutArea Property (IMetadataDictionaryEntry)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataDictionaryEntry Interface : LayoutArea Property
Specifies the LayoutArea instance referenced directly or indirectly via Contents.
Syntax
  • Visual Basic
  • C#
'Declaration

Property LayoutArea As ILayoutArea
ILayoutArea LayoutArea {get; set;}
See Also

Reference

IMetadataDictionaryEntry Interface
IMetadataDictionaryEntry Members


Name Property (IMetadataDictionaryEntry)

Name Property (IMetadataDictionaryEntry)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataDictionaryEntry Interface : Name Property
Gets the name of this object.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Name As System.String
System.string Name {get;}
See Also

Reference

IMetadataDictionaryEntry Interface
IMetadataDictionaryEntry Members


ReportItem Property (IMetadataDictionaryEntry)

ReportItem Property (IMetadataDictionaryEntry)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataDictionaryEntry Interface : ReportItem Property
Specifies the ReportItem referenced directly (for Document Map) or indirectly via Contents.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ReportItem As IReportItem
IReportItem ReportItem {get;}
See Also

Reference

IMetadataDictionaryEntry Interface
IMetadataDictionaryEntry Members


VisualRectangle Property (IMetadataDictionaryEntry)

VisualRectangle Property (IMetadataDictionaryEntry)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataDictionaryEntry Interface : VisualRectangle Property
Gets the visual rectangle of this object.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property VisualRectangle As RectangleFEx
RectangleFEx VisualRectangle {get;}
See Also

Reference

IMetadataDictionaryEntry Interface
IMetadataDictionaryEntry Members


IMetadataEntry Interface

IMetadataEntry Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IMetadataEntry Interface
Interface for meta data entry objects.
Object Model
IMetadataEntry Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMetadataEntry
public interface IMetadataEntry
See Also

Reference

IMetadataEntry Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IMetadataEntry Interface Members

IMetadataEntry Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IMetadataEntry Interface

The following tables list the members exposed by IMetadataEntry.

Public Properties
 | Name | Description
Property | Contents | The contents of this object.
Property | ContentType | Specifies content type.
Property | ID | Specifies metadata entry ID.
Property | Name | Specifies metadata entry name.
Property | VisualRectangle | Specifies the location of the metadata visual representation boundary.
Property | VisualShape | Specifies the metadata visual representation.
Top
See Also

Reference

IMetadataEntry Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IMetadataEntry Interface Properties

IMetadataEntry Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IMetadataEntry Interface

For a list of all members of this type, see IMetadataEntry members.

Public Properties
 | Name | Description
Property | Contents | The contents of this object.
Property | ContentType | Specifies content type.
Property | ID | Specifies metadata entry ID.
Property | Name | Specifies metadata entry name.
Property | VisualRectangle | Specifies the location of the metadata visual representation boundary.
Property | VisualShape | Specifies the metadata visual representation.
Top
See Also

Reference

IMetadataEntry Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Contents Property (IMetadataEntry)

Contents Property (IMetadataEntry)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataEntry Interface : Contents Property
The contents of this object.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Contents As System.Object
System.object Contents {get;}
See Also

Reference

IMetadataEntry Interface
IMetadataEntry Members


ContentType Property

ContentType Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataEntry Interface : ContentType Property
Specifies content type.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ContentType As MetadataType
MetadataType ContentType {get;}
See Also

Reference

IMetadataEntry Interface
IMetadataEntry Members


ID Property (IMetadataEntry)

ID Property (IMetadataEntry)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataEntry Interface : ID Property
Specifies metadata entry ID.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ID As System.String
System.string ID {get;}
Remarks
ID should be unique accross all metadata entries in the dictionary.
See Also

Reference

IMetadataEntry Interface
IMetadataEntry Members


Name Property (IMetadataEntry)

Name Property (IMetadataEntry)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataEntry Interface : Name Property
Specifies metadata entry name.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Name As System.String
System.string Name {get;}
See Also

Reference

IMetadataEntry Interface
IMetadataEntry Members


VisualRectangle Property (IMetadataEntry)

VisualRectangle Property (IMetadataEntry)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataEntry Interface : VisualRectangle Property
Specifies the location of the metadata visual representation boundary.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property VisualRectangle As RectangleFEx
RectangleFEx VisualRectangle {get;}
Remarks
This property will return bounding rectangle in case if visual shape is specified by the graphics path,
See Also

Reference

IMetadataEntry Interface
IMetadataEntry Members
VisualShape


VisualShape Property

VisualShape Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IMetadataEntry Interface : VisualShape Property
Specifies the metadata visual representation.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property VisualShape As IVisualShape
IVisualShape VisualShape {get;}
See Also

Reference

IMetadataEntry Interface
IMetadataEntry Members


IOverflowItem Interface

IOverflowItem Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IOverflowItem Interface
Interface for overflow item.
Object Model
IOverflowItem Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IOverflowItem
   Inherits IDocumentMapItem, IRenderComponent, IReportItem
public interface IOverflowItem : IDocumentMapItem, IRenderComponent, IReportItem
See Also

Reference

IOverflowItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IOverflowItem Interface Members

IOverflowItem Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IOverflowItem Interface

The following tables list the members exposed by IOverflowItem.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OverflowName | Overflow name.
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IOverflowItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IOverflowItem Interface Properties

IOverflowItem Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IOverflowItem Interface

For a list of all members of this type, see IOverflowItem members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OverflowName | Overflow name.
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IOverflowItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


OverflowName Property (IOverflowItem)

OverflowName Property (IOverflowItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IOverflowItem Interface : OverflowName Property
Overflow name.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property OverflowName As System.String
System.string OverflowName {get;}
See Also

Reference

IOverflowItem Interface
IOverflowItem Members


IPageRegion Interface

IPageRegion Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IPageRegion Interface
Represents the page region
Object Model
IPageRegion Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IPageRegion
   Inherits IDocumentMapItem, IRenderComponent, IReportItem
public interface IPageRegion : IDocumentMapItem, IRenderComponent, IReportItem
See Also

Reference

IPageRegion Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IPageRegion Interface Members

IPageRegion Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IPageRegion Interface

The following tables list the members exposed by IPageRegion.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Gets a value indicating whether the page should break at the end of the region.
Property | PageBreakAtStart | Gets a value indicating whether the page should break at the start of the region.
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IPageRegion Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IPageRegion Interface Properties

IPageRegion Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IPageRegion Interface

For a list of all members of this type, see IPageRegion members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Gets a value indicating whether the page should break at the end of the region.
Property | PageBreakAtStart | Gets a value indicating whether the page should break at the start of the region.
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IPageRegion Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


PageBreakAtEnd Property (IPageRegion)

PageBreakAtEnd Property (IPageRegion)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IPageRegion Interface : PageBreakAtEnd Property
Gets a value indicating whether the page should break at the end of the region.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PageBreakAtEnd As System.Boolean
System.bool PageBreakAtEnd {get;}
See Also

Reference

IPageRegion Interface
IPageRegion Members


PageBreakAtStart Property (IPageRegion)

PageBreakAtStart Property (IPageRegion)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IPageRegion Interface : PageBreakAtStart Property
Gets a value indicating whether the page should break at the start of the region.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PageBreakAtStart As System.Boolean
System.bool PageBreakAtStart {get;}
See Also

Reference

IPageRegion Interface
IPageRegion Members


IPageSection Interface

IPageSection Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IPageSection Interface
Interface for page selection.
Object Model
IPageSection Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IPageSection
   Inherits IReportItemContainer
public interface IPageSection : IReportItemContainer
See Also

Reference

IPageSection Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IPageSection Interface Members

IPageSection Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IPageSection Interface

The following tables list the members exposed by IPageSection.

Public Properties
 | Name | Description
Property | Height | Indicates the height of page header/footer section.
Property | Parent | Returns parent report.
Property | PrintOnFirstPage | Specifies that the page header/footer should be printed on the first page.
Property | PrintOnLastPage | Specifies that the page header/footer should be printed on the last page.
Property | ReportItems | Returns the IReportItem objects in this container. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemContainer)
Property | Style | Returns style of this IPageSection.
Top
See Also

Reference

IPageSection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IPageSection Interface Properties

IPageSection Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IPageSection Interface

For a list of all members of this type, see IPageSection members.

Public Properties
 | Name | Description
Property | Height | Indicates the height of page header/footer section.
Property | Parent | Returns parent report.
Property | PrintOnFirstPage | Specifies that the page header/footer should be printed on the first page.
Property | PrintOnLastPage | Specifies that the page header/footer should be printed on the last page.
Property | ReportItems | Returns the IReportItem objects in this container. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemContainer)
Property | Style | Returns style of this IPageSection.
Top
See Also

Reference

IPageSection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Height Property (IPageSection)

Height Property (IPageSection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IPageSection Interface : Height Property
Indicates the height of page header/footer section.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Height As Length
Length Height {get;}
See Also

Reference

IPageSection Interface
IPageSection Members


Parent Property (IPageSection)

Parent Property (IPageSection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IPageSection Interface : Parent Property
Returns parent report.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Parent As IReport
IReport Parent {get;}
See Also

Reference

IPageSection Interface
IPageSection Members


PrintOnFirstPage Property (IPageSection)

PrintOnFirstPage Property (IPageSection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IPageSection Interface : PrintOnFirstPage Property
Specifies that the page header/footer should be printed on the first page.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PrintOnFirstPage As System.Boolean
System.bool PrintOnFirstPage {get;}
See Also

Reference

IPageSection Interface
IPageSection Members


PrintOnLastPage Property (IPageSection)

PrintOnLastPage Property (IPageSection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IPageSection Interface : PrintOnLastPage Property
Specifies that the page header/footer should be printed on the last page.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PrintOnLastPage As System.Boolean
System.bool PrintOnLastPage {get;}
See Also

Reference

IPageSection Interface
IPageSection Members


Style Property (IPageSection)

Style Property (IPageSection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IPageSection Interface : Style Property
Returns style of this IPageSection.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Style As IStyle
IStyle Style {get;}
See Also

Reference

IPageSection Interface
IPageSection Members


IRectangle Interface

IRectangle Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IRectangle Interface
Indicates that all whitespace in rectangle should be consumed when contents grow rather than preserving the minimum whitespace between the contents and the bounds of the rectangle.
Object Model
IRectangle Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IRectangle
   Inherits IDocumentMapItem, IPageRegion, IRenderComponent, IReportItem, IReportItemContainer, IShape
public interface IRectangle : IDocumentMapItem, IPageRegion, IRenderComponent, IReportItem, IReportItemContainer, IShape
See Also

Reference

IRectangle Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IRectangle Interface Members

IRectangle Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IRectangle Interface

The following tables list the members exposed by IRectangle.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ConsumeWhiteSpace | Indicates that all whitespace in rectangle should be consumed when contents grow rather than preserving the minimum whitespace between the contents and the bounds of the rectangle.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Returns Rectangle item PageBreakAtEnd property. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | PageBreakAtStart | Returns Rectangle item PageBreakAtStart property. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | ReportItems | Returns the IReportItem objects in this container. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemContainer)
Property | RoundingRadius | Specifies radius of rounded rectangle. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IShape)
Property | ShapeStyle | Specifies the style of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IShape)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IRectangle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IRectangle Interface Properties

IRectangle Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IRectangle Interface

For a list of all members of this type, see IRectangle members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ConsumeWhiteSpace | Indicates that all whitespace in rectangle should be consumed when contents grow rather than preserving the minimum whitespace between the contents and the bounds of the rectangle.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Returns Rectangle item PageBreakAtEnd property. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | PageBreakAtStart | Returns Rectangle item PageBreakAtStart property. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | ReportItems | Returns the IReportItem objects in this container. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemContainer)
Property | RoundingRadius | Specifies radius of rounded rectangle. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IShape)
Property | ShapeStyle | Specifies the style of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IShape)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IRectangle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ConsumeWhiteSpace Property (IRectangle)

ConsumeWhiteSpace Property (IRectangle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IRectangle Interface : ConsumeWhiteSpace Property
Indicates that all whitespace in rectangle should be consumed when contents grow rather than preserving the minimum whitespace between the contents and the bounds of the rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ConsumeWhiteSpace As System.Boolean
System.bool ConsumeWhiteSpace {get;}
See Also

Reference

IRectangle Interface
IRectangle Members


IRenderComponent Interface

IRenderComponent Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IRenderComponent Interface
Interface for render component objects.
Object Model
IRenderComponent Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IRenderComponent
public interface IRenderComponent
See Also

Reference

IRenderComponent Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IRenderComponent Interface Members

IRenderComponent Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IRenderComponent Interface

The following tables list the members exposed by IRenderComponent.

Public Properties
 | Name | Description
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned.
Property | RenderComponents | Returns a collection of render components.
Top
Public Methods
 | Name | Description
Method | GetService | (Inherited from System.IServiceProvider)
Top
See Also

Reference

IRenderComponent Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IRenderComponent Interface Properties

IRenderComponent Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IRenderComponent Interface

For a list of all members of this type, see IRenderComponent members.

Public Properties
 | Name | Description
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned.
Property | RenderComponents | Returns a collection of render components.
Top
See Also

Reference

IRenderComponent Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Parent Property (IRenderComponent)

Parent Property (IRenderComponent)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IRenderComponent Interface : Parent Property
Sets or returns a reference to this object's parent. If the parent is unavailable null is returned.
Syntax
  • Visual Basic
  • C#
'Declaration

Property Parent As IRenderComponent
IRenderComponent Parent {get; set;}
See Also

Reference

IRenderComponent Interface
IRenderComponent Members


RenderComponents Property

RenderComponents Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IRenderComponent Interface : RenderComponents Property
Returns a collection of render components.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RenderComponents As System.Collections.Generic.IEnumerable(Of IRenderComponent)
System.Collections.Generic.IEnumerable<IRenderComponent> RenderComponents {get;}
See Also

Reference

IRenderComponent Interface
IRenderComponent Members


IReport Interface

IReport Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReport Interface
Interface for the Report object.
Object Model
IReport Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IReport
public interface IReport
See Also

Reference

IReport Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IReport Interface Members

IReport Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReport Interface

The following tables list the members exposed by IReport.

Public Properties
 | Name | Description
Property | Body | Returns a reference to the body of the report.
Property | BottomMargin | Specifies the height of the bottom margin of the report.
Property | ConsumeContainerWhitespace | Indicates that all whitespace in container (only for RDL reports) should be consumed when contents grow rather than preserving the minimum whitespace between the contents and the bounds.
Property | ContainsCumulativeExpressions | Returns true if layout contains CumulativeTotal expressions.
Property | Culture | Indicates the primary language of the report.
Property | DataElementName | The name of the top-level element for a report rendered using a data oriented rendering extension (e.g. XML).
Property | DataElementStyle | Indicates whether to render textboxes as an element or as an attribute.
Property | DataSchema | The namespace to use in a report rendered using a data oriented rendering extension (e.g. XML).
Property | DataTransform | The location and file name of a transformation to use with a data oriented rendering extension (e.g. XML).
Property | LeftMargin | Specifies the width of the left margin of the report.
Property | Name | Sets or returns the name of the report.
Property | PageFooter | Returns a reference to the page footer section of the report.
Property | PageHeader | Returns a reference to the page header section of the report.
Property | PageHeight | Specifies report page height.
Property | PageWidth | Specifies report page width.
Property | PaperOrientation | Returns paper orientation of the report.
Property | RightMargin | Specifies the width of the right margin of the report.
Property | StartPageNumber | Returns the page number to start the numeration with.
Property | TopMargin | Specifies the height of the top margin of the report.
Property | Version | A unique version number to identify the instance of the report.
Property | Width | Indicates the width of the report.
Top
Public Methods
 | Name | Description
Method | GetSectionRenderer | Gets a renderer of the specified type that can render the body and page sections (IPageSection) of this report.
Method | GetService | (Inherited from System.IServiceProvider)
Top
See Also

Reference

IReport Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IReport Interface Methods

IReport Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReport Interface

For a list of all members of this type, see IReport members.

Public Methods
 | Name | Description
Method | GetSectionRenderer | Gets a renderer of the specified type that can render the body and page sections (IPageSection) of this report.
Method | GetService | (Inherited from System.IServiceProvider)
Top
See Also

Reference

IReport Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetSectionRenderer Method

GetSectionRenderer Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : GetSectionRenderer Method
The System.Type of the base class or interface that the returned renderer must implement.
Gets a renderer of the specified type that can render the body and page sections (IPageSection) of this report.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetSectionRenderer( _
   ByVal rendererType As System.Type _
) As System.Object
System.object GetSectionRenderer(
   System.Type rendererType
)

Parameters

rendererType
The System.Type of the base class or interface that the returned renderer must implement.

Return Value

The instance of the renderer that that provides rendering services for the page sections.
See Also

Reference

IReport Interface
IReport Members


IReport Interface Properties

IReport Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReport Interface

For a list of all members of this type, see IReport members.

Public Properties
 | Name | Description
Property | Body | Returns a reference to the body of the report.
Property | BottomMargin | Specifies the height of the bottom margin of the report.
Property | ConsumeContainerWhitespace | Indicates that all whitespace in container (only for RDL reports) should be consumed when contents grow rather than preserving the minimum whitespace between the contents and the bounds.
Property | ContainsCumulativeExpressions | Returns true if layout contains CumulativeTotal expressions.
Property | Culture | Indicates the primary language of the report.
Property | DataElementName | The name of the top-level element for a report rendered using a data oriented rendering extension (e.g. XML).
Property | DataElementStyle | Indicates whether to render textboxes as an element or as an attribute.
Property | DataSchema | The namespace to use in a report rendered using a data oriented rendering extension (e.g. XML).
Property | DataTransform | The location and file name of a transformation to use with a data oriented rendering extension (e.g. XML).
Property | LeftMargin | Specifies the width of the left margin of the report.
Property | Name | Sets or returns the name of the report.
Property | PageFooter | Returns a reference to the page footer section of the report.
Property | PageHeader | Returns a reference to the page header section of the report.
Property | PageHeight | Specifies report page height.
Property | PageWidth | Specifies report page width.
Property | PaperOrientation | Returns paper orientation of the report.
Property | RightMargin | Specifies the width of the right margin of the report.
Property | StartPageNumber | Returns the page number to start the numeration with.
Property | TopMargin | Specifies the height of the top margin of the report.
Property | Version | A unique version number to identify the instance of the report.
Property | Width | Indicates the width of the report.
Top
See Also

Reference

IReport Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Body Property (IReport)

Body Property (IReport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : Body Property
Returns a reference to the body of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Body As IBody
IBody Body {get;}
See Also

Reference

IReport Interface
IReport Members


BottomMargin Property (IReport)

BottomMargin Property (IReport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : BottomMargin Property
Specifies the height of the bottom margin of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property BottomMargin As Length
Length BottomMargin {get;}
See Also

Reference

IReport Interface
IReport Members


ConsumeContainerWhitespace Property (IReport)

ConsumeContainerWhitespace Property (IReport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : ConsumeContainerWhitespace Property
Indicates that all whitespace in container (only for RDL reports) should be consumed when contents grow rather than preserving the minimum whitespace between the contents and the bounds.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ConsumeContainerWhitespace As System.Boolean
System.bool ConsumeContainerWhitespace {get;}
See Also

Reference

IReport Interface
IReport Members


ContainsCumulativeExpressions Property

ContainsCumulativeExpressions Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : ContainsCumulativeExpressions Property
Returns true if layout contains CumulativeTotal expressions.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ContainsCumulativeExpressions As System.Boolean
System.bool ContainsCumulativeExpressions {get;}
See Also

Reference

IReport Interface
IReport Members


Culture Property (IReport)

Culture Property (IReport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : Culture Property
Indicates the primary language of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Culture As System.Globalization.CultureInfo
System.Globalization.CultureInfo Culture {get;}
See Also

Reference

IReport Interface
IReport Members


DataElementName Property (IReport)

DataElementName Property (IReport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : DataElementName Property
The name of the top-level element for a report rendered using a data oriented rendering extension (e.g. XML).
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataElementName As System.String
System.string DataElementName {get;}
See Also

Reference

IReport Interface
IReport Members


DataElementStyle Property (IReport)

DataElementStyle Property (IReport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : DataElementStyle Property
Indicates whether to render textboxes as an element or as an attribute.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataElementStyle As DataElementStyle
DataElementStyle DataElementStyle {get;}
See Also

Reference

IReport Interface
IReport Members


DataSchema Property (IReport)

DataSchema Property (IReport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : DataSchema Property
The namespace to use in a report rendered using a data oriented rendering extension (e.g. XML).
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataSchema As System.String
System.string DataSchema {get;}
See Also

Reference

IReport Interface
IReport Members


DataTransform Property (IReport)

DataTransform Property (IReport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : DataTransform Property
The location and file name of a transformation to use with a data oriented rendering extension (e.g. XML).
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataTransform As System.String
System.string DataTransform {get;}
See Also

Reference

IReport Interface
IReport Members


LeftMargin Property (IReport)

LeftMargin Property (IReport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : LeftMargin Property
Specifies the width of the left margin of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LeftMargin As Length
Length LeftMargin {get;}
See Also

Reference

IReport Interface
IReport Members


Name Property (IReport)

Name Property (IReport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : Name Property
Sets or returns the name of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Name As System.String
System.string Name {get;}
See Also

Reference

IReport Interface
IReport Members


PageFooter Property (IReport)

PageFooter Property (IReport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : PageFooter Property
Returns a reference to the page footer section of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PageFooter As IPageSection
IPageSection PageFooter {get;}
See Also

Reference

IReport Interface
IReport Members


PageHeader Property (IReport)

PageHeader Property (IReport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : PageHeader Property
Returns a reference to the page header section of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PageHeader As IPageSection
IPageSection PageHeader {get;}
See Also

Reference

IReport Interface
IReport Members


PageHeight Property (IReport)

PageHeight Property (IReport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : PageHeight Property
Specifies report page height.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PageHeight As Length
Length PageHeight {get;}
See Also

Reference

IReport Interface
IReport Members


PageWidth Property (IReport)

PageWidth Property (IReport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : PageWidth Property
Specifies report page width.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PageWidth As Length
Length PageWidth {get;}
See Also

Reference

IReport Interface
IReport Members


PaperOrientation Property (IReport)

PaperOrientation Property (IReport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : PaperOrientation Property
Returns paper orientation of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PaperOrientation As PaperOrientation
PaperOrientation PaperOrientation {get;}
See Also

Reference

IReport Interface
IReport Members


RightMargin Property (IReport)

RightMargin Property (IReport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : RightMargin Property
Specifies the width of the right margin of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RightMargin As Length
Length RightMargin {get;}
See Also

Reference

IReport Interface
IReport Members


StartPageNumber Property (IReport)

StartPageNumber Property (IReport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : StartPageNumber Property
Returns the page number to start the numeration with.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property StartPageNumber As System.Integer
System.int StartPageNumber {get;}
See Also

Reference

IReport Interface
IReport Members


TopMargin Property (IReport)

TopMargin Property (IReport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : TopMargin Property
Specifies the height of the top margin of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TopMargin As Length
Length TopMargin {get;}
See Also

Reference

IReport Interface
IReport Members


Version Property (IReport)

Version Property (IReport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : Version Property
A unique version number to identify the instance of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Version As System.String
System.string Version {get;}
See Also

Reference

IReport Interface
IReport Members


Width Property (IReport)

Width Property (IReport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : Width Property
Indicates the width of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Width As Length
Length Width {get;}
See Also

Reference

IReport Interface
IReport Members


IReportItem Interface

IReportItem Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReportItem Interface
Interface for report item objects.
Object Model
IReportItem Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IReportItem
   Inherits IDocumentMapItem, IRenderComponent
public interface IReportItem : IDocumentMapItem, IRenderComponent
See Also

Reference

IReportItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IReportItem Interface Members

IReportItem Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReportItem Interface

The following tables list the members exposed by IReportItem.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item.
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML).
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device.
Property | Height | Height of the item.
Property | Hidden | Indicates if this report item should be hidden.
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden.
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible.
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object.
Property | Name | The name of this report item.
Property | OwnHidden | Indicates this report item own hidden state.
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item.
Property | StyleName | Specifies style name.
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item.
Property | ToolTip | Contains a textual label for the item.
Property | Top | The distance of the item from the top of the containing object.
Property | Width | Width of the item.
Property | ZIndex | Specifies drawing order of the report item within the containing object.
Top
Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component.
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item.
Method | OnClick | The wrapper for the OnClick event.
Method | OnDoubleClick | The wrapper for the OnDoubleClick event.
Method | OnMove | The wrapper for the OnMove event.
Method | OnValueChange | The wrapper for the ValueChange event.
Top
See Also

Reference

IReportItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IReportItem Interface Methods

IReportItem Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReportItem Interface

For a list of all members of this type, see IReportItem members.

Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component.
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item.
Method | OnClick | The wrapper for the OnClick event.
Method | OnDoubleClick | The wrapper for the OnDoubleClick event.
Method | OnMove | The wrapper for the OnMove event.
Method | OnValueChange | The wrapper for the ValueChange event.
Top
See Also

Reference

IReportItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetRenderer Method

GetRenderer Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : GetRenderer Method
The System.Type of the base class or interface that the returned renderer must implement.
Gets a renderer of the specified type that can render this component.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetRenderer( _
   ByVal rendererType As System.Type _
) As System.Object
System.object GetRenderer(
   System.Type rendererType
)

Parameters

rendererType
The System.Type of the base class or interface that the returned renderer must implement.

Return Value

The instance of the renderer that that provides rendering services for this component.
See Also

Reference

IReportItem Interface
IReportItem Members


Initialize Method (IReportItem)

Initialize Method (IReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : Initialize Method
The data context associated with this report item.
The property bag associated with this report item.
Initializes the report item.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Initialize( _
   ByVal dataContext As IDataScope, _
   ByVal properties As IPropertyBag _
)
void Initialize(
   IDataScope dataContext,
   IPropertyBag properties
)

Parameters

dataContext
The data context associated with this report item.
properties
The property bag associated with this report item.
See Also

Reference

IReportItem Interface
IReportItem Members


OnClick Method

OnClick Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : OnClick Method
The report item clicked.
The x position of the click.
The y position of the click.
The image map ID.
The button that was clicked.
The wrapper for the OnClick event.
Syntax
  • Visual Basic
  • C#
'Declaration

Function OnClick( _
   ByVal reportItem As IReportItem, _
   ByVal xPosition As System.Integer, _
   ByVal yPosition As System.Integer, _
   ByVal imageMapId As System.String, _
   ByVal button As MouseButton _
) As ChangeResult
ChangeResult OnClick(
   IReportItem reportItem,
   System.int xPosition,
   System.int yPosition,
   System.string imageMapId,
   MouseButton button
)

Parameters

reportItem
The report item clicked.
xPosition
The x position of the click.
yPosition
The y position of the click.
imageMapId
The image map ID.
button
The button that was clicked.

Return Value

The change result of the button click.
See Also

Reference

IReportItem Interface
IReportItem Members


OnDoubleClick Method

OnDoubleClick Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : OnDoubleClick Method
The report item double-clicked.
The x position of the double-click.
The y position of the double-click.
The image map ID.
The button that was double-clicked.
The wrapper for the OnDoubleClick event.
Syntax
  • Visual Basic
  • C#
'Declaration

Function OnDoubleClick( _
   ByVal reportItem As IReportItem, _
   ByVal xPosition As System.Integer, _
   ByVal yPosition As System.Integer, _
   ByVal imageMapId As System.String, _
   ByVal button As MouseButton _
) As ChangeResult
ChangeResult OnDoubleClick(
   IReportItem reportItem,
   System.int xPosition,
   System.int yPosition,
   System.string imageMapId,
   MouseButton button
)

Parameters

reportItem
The report item double-clicked.
xPosition
The x position of the double-click.
yPosition
The y position of the double-click.
imageMapId
The image map ID.
button
The button that was double-clicked.

Return Value

The change result of the double-click.
See Also

Reference

IReportItem Interface
IReportItem Members


OnMove Method

OnMove Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : OnMove Method
The report item that was moved.
The report item that this report item was moved into.
The x position of the move.
The y position of the move.
The wrapper for the OnMove event.
Syntax
  • Visual Basic
  • C#
'Declaration

Function OnMove( _
   ByVal reportItem As IReportItem, _
   ByVal target As IReportItem, _
   ByVal xPosition As System.Integer, _
   ByVal yPosition As System.Integer _
) As ChangeResult
ChangeResult OnMove(
   IReportItem reportItem,
   IReportItem target,
   System.int xPosition,
   System.int yPosition
)

Parameters

reportItem
The report item that was moved.
target
The report item that this report item was moved into.
xPosition
The x position of the move.
yPosition
The y position of the move.

Return Value

The change result of the move.
See Also

Reference

IReportItem Interface
IReportItem Members


OnValueChange Method

OnValueChange Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : OnValueChange Method
The report item that was changed.
The new values for this report item.
The wrapper for the ValueChange event.
Syntax
  • Visual Basic
  • C#
'Declaration

Function OnValueChange( _
   ByVal reportItem As IReportItem, _
   ByVal newValues As IValueCollection _
) As ChangeResult
ChangeResult OnValueChange(
   IReportItem reportItem,
   IValueCollection newValues
)

Parameters

reportItem
The report item that was changed.
newValues
The new values for this report item.

Return Value

The change result of the new value assignment.
See Also

Reference

IReportItem Interface
IReportItem Members


IReportItem Interface Properties

IReportItem Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReportItem Interface

For a list of all members of this type, see IReportItem members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item.
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML).
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device.
Property | Height | Height of the item.
Property | Hidden | Indicates if this report item should be hidden.
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden.
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible.
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object.
Property | Name | The name of this report item.
Property | OwnHidden | Indicates this report item own hidden state.
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item.
Property | StyleName | Specifies style name.
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item.
Property | ToolTip | Contains a textual label for the item.
Property | Top | The distance of the item from the top of the containing object.
Property | Width | Width of the item.
Property | ZIndex | Specifies drawing order of the report item within the containing object.
Top
See Also

Reference

IReportItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Action Property (IReportItem)

Action Property (IReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : Action Property
The Action object of this report item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Action As IAction
IAction Action {get;}
See Also

Reference

IReportItem Interface
IReportItem Members


Bookmark Property (IReportItem)

Bookmark Property (IReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : Bookmark Property
Specifies a bookmark that can be linked to via a Bookmark action.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Bookmark As System.String
System.string Bookmark {get;}
See Also

Reference

IReportItem Interface
IReportItem Members


DataElementName Property (IReportItem)

DataElementName Property (IReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : DataElementName Property
The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML).
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataElementName As System.String
System.string DataElementName {get;}
Remarks
By default this is the name of this report item.
See Also

Reference

IReportItem Interface
IReportItem Members


DataElementOutput Property (IReportItem)

DataElementOutput Property (IReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : DataElementOutput Property
Indicates how this item should appear when rendered with a data oriented rendering device.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataElementOutput As DataElementOutput
DataElementOutput DataElementOutput {get;}
See Also

Reference

IReportItem Interface
IReportItem Members


Height Property (IReportItem)

Height Property (IReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : Height Property
Height of the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Height As Length
Length Height {get;}
See Also

Reference

IReportItem Interface
IReportItem Members


Hidden Property (IReportItem)

Hidden Property (IReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : Hidden Property
Indicates if this report item should be hidden.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Hidden As System.Boolean
System.bool Hidden {get;}
See Also

Reference

IReportItem Interface
IReportItem Members


IsDynamicallyHidden Property

IsDynamicallyHidden Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : IsDynamicallyHidden Property
Determines if this item has dynamic visiblity and is hidden.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property IsDynamicallyHidden As System.Boolean
System.bool IsDynamicallyHidden {get;}
See Also

Reference

IReportItem Interface
IReportItem Members


KeepTogether Property (IReportItem)

KeepTogether Property (IReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : KeepTogether Property
Gets a value indicating whether the report item is kept together on one page if possible.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property KeepTogether As System.Boolean
System.bool KeepTogether {get;}
See Also

Reference

IReportItem Interface
IReportItem Members


Left Property (IReportItem)

Left Property (IReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : Left Property
The distance of the item from the left of the containing object.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Left As Length
Length Left {get;}
See Also

Reference

IReportItem Interface
IReportItem Members


Name Property (IReportItem)

Name Property (IReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : Name Property
The name of this report item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Name As System.String
System.string Name {get;}
See Also

Reference

IReportItem Interface
IReportItem Members


OwnHidden Property (IReportItem)

OwnHidden Property (IReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : OwnHidden Property
Indicates this report item own hidden state.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property OwnHidden As System.Boolean
System.bool OwnHidden {get;}
See Also

Reference

IReportItem Interface
IReportItem Members


Style Property (IReportItem)

Style Property (IReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : Style Property
Returns style of the report item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Style As IStyle
IStyle Style {get;}
See Also

Reference

IReportItem Interface
IReportItem Members


StyleName Property (IReportItem)

StyleName Property (IReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : StyleName Property
Specifies style name.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property StyleName As System.String
System.string StyleName {get;}
See Also

Reference

IReportItem Interface
IReportItem Members


TargetDevice Property (IReportItem)

TargetDevice Property (IReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : TargetDevice Property
Defines output kinds in which report item is present (Screen, Export tec.)
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TargetDevice As TargetDeviceKind
TargetDeviceKind TargetDevice {get;}
See Also

Reference

IReportItem Interface
IReportItem Members


ToggleItem Property (IReportItem)

ToggleItem Property (IReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : ToggleItem Property
Specifies a report item that users can click toggle the visibility of this item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ToggleItem As System.String
System.string ToggleItem {get;}
See Also

Reference

IReportItem Interface
IReportItem Members


ToolTip Property (IReportItem)

ToolTip Property (IReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : ToolTip Property
Contains a textual label for the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ToolTip As System.String
System.string ToolTip {get;}
See Also

Reference

IReportItem Interface
IReportItem Members


Top Property (IReportItem)

Top Property (IReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : Top Property
The distance of the item from the top of the containing object.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Top As Length
Length Top {get;}
See Also

Reference

IReportItem Interface
IReportItem Members


Width Property (IReportItem)

Width Property (IReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : Width Property
Width of the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Width As Length
Length Width {get;}
See Also

Reference

IReportItem Interface
IReportItem Members


ZIndex Property (IReportItem)

ZIndex Property (IReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : ZIndex Property
Specifies drawing order of the report item within the containing object.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ZIndex As System.Integer
System.int ZIndex {get;}
See Also

Reference

IReportItem Interface
IReportItem Members


IReportItemContainer Interface

IReportItemContainer Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReportItemContainer Interface
Defines container of IReportItem objects.
Object Model
IReportItemContainer Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IReportItemContainer
public interface IReportItemContainer
See Also

Reference

IReportItemContainer Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IReportItemContainer Interface Members

IReportItemContainer Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReportItemContainer Interface

The following tables list the members exposed by IReportItemContainer.

Public Properties
 | Name | Description
Property | ReportItems | Returns the IReportItem objects in this container.
Top
See Also

Reference

IReportItemContainer Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IReportItemContainer Interface Properties

IReportItemContainer Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IReportItemContainer Interface

For a list of all members of this type, see IReportItemContainer members.

Public Properties
 | Name | Description
Property | ReportItems | Returns the IReportItem objects in this container.
Top
See Also

Reference

IReportItemContainer Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ReportItems Property (IReportItemContainer)

ReportItems Property (IReportItemContainer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItemContainer Interface : ReportItems Property
Returns the IReportItem objects in this container.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ReportItems As IReadOnlyReportItemCollection
IReadOnlyReportItemCollection ReportItems {get;}
See Also

Reference

IReportItemContainer Interface
IReportItemContainer Members


IRoundingRadius Interface

IRoundingRadius Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IRoundingRadius Interface
Defines radii of rounded rectangle.
Object Model
IRoundingRadius Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IRoundingRadius
public interface IRoundingRadius
See Also

Reference

IRoundingRadius Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IRoundingRadius Interface Members

IRoundingRadius Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IRoundingRadius Interface

The following tables list the members exposed by IRoundingRadius.

Public Properties
 | Name | Description
Property | BottomLeft | Specifies the bottom left radius of the rounded rectangle.
Property | BottomRight | Specifies the bottom right radius of the rounded rectangle.
Property | Default | Specifies the default radius of the rounded rectangle.
Property | TopLeft | Specifies the top left radius of the rounded rectangle.
Property | TopRight | Specifies the top right radius of the rounded rectangle.
Top
See Also

Reference

IRoundingRadius Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IRoundingRadius Interface Properties

IRoundingRadius Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IRoundingRadius Interface

For a list of all members of this type, see IRoundingRadius members.

Public Properties
 | Name | Description
Property | BottomLeft | Specifies the bottom left radius of the rounded rectangle.
Property | BottomRight | Specifies the bottom right radius of the rounded rectangle.
Property | Default | Specifies the default radius of the rounded rectangle.
Property | TopLeft | Specifies the top left radius of the rounded rectangle.
Property | TopRight | Specifies the top right radius of the rounded rectangle.
Top
See Also

Reference

IRoundingRadius Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


BottomLeft Property (IRoundingRadius)

BottomLeft Property (IRoundingRadius)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IRoundingRadius Interface : BottomLeft Property
Specifies the bottom left radius of the rounded rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property BottomLeft As Length
Length BottomLeft {get;}
See Also

Reference

IRoundingRadius Interface
IRoundingRadius Members


BottomRight Property (IRoundingRadius)

BottomRight Property (IRoundingRadius)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IRoundingRadius Interface : BottomRight Property
Specifies the bottom right radius of the rounded rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property BottomRight As Length
Length BottomRight {get;}
See Also

Reference

IRoundingRadius Interface
IRoundingRadius Members


Default Property (IRoundingRadius)

Default Property (IRoundingRadius)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IRoundingRadius Interface : Default Property
Specifies the default radius of the rounded rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Default As Length
Length Default {get;}
See Also

Reference

IRoundingRadius Interface
IRoundingRadius Members


TopLeft Property (IRoundingRadius)

TopLeft Property (IRoundingRadius)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IRoundingRadius Interface : TopLeft Property
Specifies the top left radius of the rounded rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TopLeft As Length
Length TopLeft {get;}
See Also

Reference

IRoundingRadius Interface
IRoundingRadius Members


TopRight Property (IRoundingRadius)

TopRight Property (IRoundingRadius)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IRoundingRadius Interface : TopRight Property
Specifies the top right radius of the rounded rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TopRight As Length
Length TopRight {get;}
See Also

Reference

IRoundingRadius Interface
IRoundingRadius Members


ISectionRegion Interface

ISectionRegion Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ISectionRegion Interface
Umbrella to unify IDataRegion and IBandedList data regions.
Object Model
ISectionRegion Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ISectionRegion
public interface ISectionRegion
See Also

Reference

ISectionRegion Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ISectionRegion Interface Members

ISectionRegion Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ISectionRegion Interface

The following tables list the members exposed by ISectionRegion.

Public Properties
 | Name | Description
Property | NewSection | Indicating whether a region is in it's own section.
Top
See Also

Reference

ISectionRegion Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ISectionRegion Interface Properties

ISectionRegion Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ISectionRegion Interface

For a list of all members of this type, see ISectionRegion members.

Public Properties
 | Name | Description
Property | NewSection | Indicating whether a region is in it's own section.
Top
See Also

Reference

ISectionRegion Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


NewSection Property (ISectionRegion)

NewSection Property (ISectionRegion)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ISectionRegion Interface : NewSection Property
Indicating whether a region is in it's own section.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property NewSection As System.Boolean
System.bool NewSection {get;}
See Also

Reference

ISectionRegion Interface
ISectionRegion Members


IShape Interface

IShape Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IShape Interface
Interface for Rectangle report item.
Object Model
IShape Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IShape
   Inherits IDocumentMapItem, IRenderComponent, IReportItem
public interface IShape : IDocumentMapItem, IRenderComponent, IReportItem
See Also

Reference

IShape Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IShape Interface Members

IShape Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IShape Interface

The following tables list the members exposed by IShape.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RoundingRadius | Specifies radius of rounded rectangle.
Property | ShapeStyle | Specifies the style of the shape.
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IShape Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IShape Interface Properties

IShape Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IShape Interface

For a list of all members of this type, see IShape members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RoundingRadius | Specifies radius of rounded rectangle.
Property | ShapeStyle | Specifies the style of the shape.
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IShape Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


RoundingRadius Property (IShape)

RoundingRadius Property (IShape)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IShape Interface : RoundingRadius Property
Specifies radius of rounded rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RoundingRadius As IRoundingRadius
IRoundingRadius RoundingRadius {get;}
See Also

Reference

IShape Interface
IShape Members


ShapeStyle Property

ShapeStyle Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IShape Interface : ShapeStyle Property
Specifies the style of the shape.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ShapeStyle As ShapeStyle
ShapeStyle ShapeStyle {get;}
See Also

Reference

IShape Interface
IShape Members


IStaticItem Interface

IStaticItem Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IStaticItem Interface
All static report items with static content
Object Model
IStaticItem Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IStaticItem
   Inherits IDocumentMapItem, IRenderComponent, IReportItem
public interface IStaticItem : IDocumentMapItem, IRenderComponent, IReportItem
See Also

Reference

IStaticItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IStaticItem Interface Members

IStaticItem Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IStaticItem Interface

The following tables list the members exposed by IStaticItem.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IStaticItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IStyle Interface

IStyle Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IStyle Interface
Interface for the Style object.
Object Model
IStyle Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IStyle
public interface IStyle
See Also

Reference

IStyle Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IStyle Interface Members

IStyle Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IStyle Interface

The following tables list the members exposed by IStyle.

Public Properties
 | Name | Description
Property | Angle | Gets the text output angle.
Property | BackgroundColor | Specifies color of the background
Property | BackgroundGradientEndColor | Specifies the secondary color for gradient fill.
Property | BackgroundGradientType | Specifies the gradient type of the background.
Property | BackgroundImage | Returns a stream with background image for this report item
Property | BackgroundImageMimeType | Identifies the Multipurpose Internet Mail Extensions (MIME) type of the background image.
Property | BackgroundImageSource | Specifies the default width of the border of the item.
Property | BackgroundImageValue | Specifies a background image value for this report item
Property | BackgroundRepeat | Specifies the repeat style of the background.
Property | BottomBorderColor | Describes the color of the bottom border of the item.
Property | BottomBorderStyle | Specifies the style of the bottom border of the item.
Property | BottomBorderWidth | Specifies the width of the bottom border of the item.
Property | Calendar | Specifies calendar to use to format dates.
Property | CharacterSpacing | Char spacing
Property | Color | Specifies the foreground color of the item.
Property | DefaultBorderColor | Specifies a default color of the border.
Property | DefaultBorderStyle | Specifies the default style of the border of the item.
Property | DefaultBorderWidth | Specifies the default width of the border of the item.
Property | Direction | Specifies the direction of text.
Property | DisplayPageNumber | Gets a value indicating whether to display page number.
Property | FontFamily | Contains the name of the font for the item
Property | FontSize | Indicates the size of the font for the item.
Property | FontStyle | Indicates the style of the font for the item.
Property | FontWeight | Indicates the thickness of the font for the item.
Property | Format | Contains the Microsoft® .NET Framework formatting string for the item.
Property | HeadingLevel | Gets the heading level.
Property | LabelExpression | Gets the label expression.
Property | Language | Indicates the primary language of the text.
Property | LeadingChar | Gets the leading character.
Property | LeftBorderColor | Specifies the default width of the border of the item.
Property | LeftBorderStyle | Describes the style of the left border of the item.
Property | LeftBorderWidth | Describes the width of the left border of the item.
Property | LineHeight | Describes the height of a line of text.
Property | LineSpacing | Line spacing
Property | MaxLevel | Specifies max level depth for ToC.
Property | NumeralLanguage | Specifies digit format as described by its primary language.
Property | NumeralVariant | Specifies the variant of the digit format to use.
Property | PaddingBottom | Specifies the amount of padding below the item.
Property | PaddingLeft | Specifies the amount of padding to the left of the item.
Property | PaddingRight | Specifies the amount of padding to the right of the item.
Property | PaddingTop | Specifies the amount of padding above the item.
Property | RightBorderColor | Describes the color of the right border of the item.
Property | RightBorderStyle | Describes the style of the right border of the item.
Property | RightBorderWidth | Describes the width of the right border of the report.
Property | ShadowOffset | Gets the shadow offset.
Property | ShrinkToFit | Shrink to Fit
Property | TextAlign | Describes the horizontal alignment of the text of the item.
Property | TextDecoration | Describes special text formatting for the item.
Property | TextIndent | Gets the text indent.
Property | TextJustify | TextJustify
Property | TopBorderColor | Describes the color of the top border of the item.
Property | TopBorderStyle | Describes the style of the top border of the item.
Property | TopBorderWidth | Describes the height of the top border of the item.
Property | VerticalAlign | Describes the vertical alignment of the text of the item.
Property | WrapMode | Wrap mode
Property | WritingMode | Indicates whether the text is written horizontally or vertically.
Top
See Also

Reference

IStyle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IStyle Interface Properties

IStyle Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IStyle Interface

For a list of all members of this type, see IStyle members.

Public Properties
 | Name | Description
Property | Angle | Gets the text output angle.
Property | BackgroundColor | Specifies color of the background
Property | BackgroundGradientEndColor | Specifies the secondary color for gradient fill.
Property | BackgroundGradientType | Specifies the gradient type of the background.
Property | BackgroundImage | Returns a stream with background image for this report item
Property | BackgroundImageMimeType | Identifies the Multipurpose Internet Mail Extensions (MIME) type of the background image.
Property | BackgroundImageSource | Specifies the default width of the border of the item.
Property | BackgroundImageValue | Specifies a background image value for this report item
Property | BackgroundRepeat | Specifies the repeat style of the background.
Property | BottomBorderColor | Describes the color of the bottom border of the item.
Property | BottomBorderStyle | Specifies the style of the bottom border of the item.
Property | BottomBorderWidth | Specifies the width of the bottom border of the item.
Property | Calendar | Specifies calendar to use to format dates.
Property | CharacterSpacing | Char spacing
Property | Color | Specifies the foreground color of the item.
Property | DefaultBorderColor | Specifies a default color of the border.
Property | DefaultBorderStyle | Specifies the default style of the border of the item.
Property | DefaultBorderWidth | Specifies the default width of the border of the item.
Property | Direction | Specifies the direction of text.
Property | DisplayPageNumber | Gets a value indicating whether to display page number.
Property | FontFamily | Contains the name of the font for the item
Property | FontSize | Indicates the size of the font for the item.
Property | FontStyle | Indicates the style of the font for the item.
Property | FontWeight | Indicates the thickness of the font for the item.
Property | Format | Contains the Microsoft® .NET Framework formatting string for the item.
Property | HeadingLevel | Gets the heading level.
Property | LabelExpression | Gets the label expression.
Property | Language | Indicates the primary language of the text.
Property | LeadingChar | Gets the leading character.
Property | LeftBorderColor | Specifies the default width of the border of the item.
Property | LeftBorderStyle | Describes the style of the left border of the item.
Property | LeftBorderWidth | Describes the width of the left border of the item.
Property | LineHeight | Describes the height of a line of text.
Property | LineSpacing | Line spacing
Property | MaxLevel | Specifies max level depth for ToC.
Property | NumeralLanguage | Specifies digit format as described by its primary language.
Property | NumeralVariant | Specifies the variant of the digit format to use.
Property | PaddingBottom | Specifies the amount of padding below the item.
Property | PaddingLeft | Specifies the amount of padding to the left of the item.
Property | PaddingRight | Specifies the amount of padding to the right of the item.
Property | PaddingTop | Specifies the amount of padding above the item.
Property | RightBorderColor | Describes the color of the right border of the item.
Property | RightBorderStyle | Describes the style of the right border of the item.
Property | RightBorderWidth | Describes the width of the right border of the report.
Property | ShadowOffset | Gets the shadow offset.
Property | ShrinkToFit | Shrink to Fit
Property | TextAlign | Describes the horizontal alignment of the text of the item.
Property | TextDecoration | Describes special text formatting for the item.
Property | TextIndent | Gets the text indent.
Property | TextJustify | TextJustify
Property | TopBorderColor | Describes the color of the top border of the item.
Property | TopBorderStyle | Describes the style of the top border of the item.
Property | TopBorderWidth | Describes the height of the top border of the item.
Property | VerticalAlign | Describes the vertical alignment of the text of the item.
Property | WrapMode | Wrap mode
Property | WritingMode | Indicates whether the text is written horizontally or vertically.
Top
See Also

Reference

IStyle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Angle Property (IStyle)

Angle Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : Angle Property
Gets the text output angle.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Angle As System.Single
System.float Angle {get;}
See Also

Reference

IStyle Interface
IStyle Members


BackgroundColor Property (IStyle)

BackgroundColor Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : BackgroundColor Property
Specifies color of the background
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property BackgroundColor As System.String
System.string BackgroundColor {get;}
See Also

Reference

IStyle Interface
IStyle Members


BackgroundGradientEndColor Property (IStyle)

BackgroundGradientEndColor Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : BackgroundGradientEndColor Property
Specifies the secondary color for gradient fill.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property BackgroundGradientEndColor As System.String
System.string BackgroundGradientEndColor {get;}
See Also

Reference

IStyle Interface
IStyle Members


BackgroundGradientType Property (IStyle)

BackgroundGradientType Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : BackgroundGradientType Property
Specifies the gradient type of the background.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property BackgroundGradientType As System.String
System.string BackgroundGradientType {get;}
See Also

Reference

IStyle Interface
IStyle Members


BackgroundImage Property (IStyle)

BackgroundImage Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : BackgroundImage Property
Returns a stream with background image for this report item
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property BackgroundImage As System.IO.Stream
System.IO.Stream BackgroundImage {get;}
See Also

Reference

IStyle Interface
IStyle Members


BackgroundImageMimeType Property

BackgroundImageMimeType Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : BackgroundImageMimeType Property
Identifies the Multipurpose Internet Mail Extensions (MIME) type of the background image.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property BackgroundImageMimeType As System.String
System.string BackgroundImageMimeType {get;}
See Also

Reference

IStyle Interface
IStyle Members


BackgroundImageSource Property

BackgroundImageSource Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : BackgroundImageSource Property
Specifies the default width of the border of the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property BackgroundImageSource As ImageSource
ImageSource BackgroundImageSource {get;}
See Also

Reference

IStyle Interface
IStyle Members


BackgroundImageValue Property

BackgroundImageValue Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : BackgroundImageValue Property
Specifies a background image value for this report item
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property BackgroundImageValue As System.Object
System.object BackgroundImageValue {get;}
See Also

Reference

IStyle Interface
IStyle Members


BackgroundRepeat Property (IStyle)

BackgroundRepeat Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : BackgroundRepeat Property
Specifies the repeat style of the background.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property BackgroundRepeat As System.String
System.string BackgroundRepeat {get;}
See Also

Reference

IStyle Interface
IStyle Members


BottomBorderColor Property (IStyle)

BottomBorderColor Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : BottomBorderColor Property
Describes the color of the bottom border of the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property BottomBorderColor As System.String
System.string BottomBorderColor {get;}
See Also

Reference

IStyle Interface
IStyle Members


BottomBorderStyle Property (IStyle)

BottomBorderStyle Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : BottomBorderStyle Property
Specifies the style of the bottom border of the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property BottomBorderStyle As System.String
System.string BottomBorderStyle {get;}
See Also

Reference

IStyle Interface
IStyle Members


BottomBorderWidth Property (IStyle)

BottomBorderWidth Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : BottomBorderWidth Property
Specifies the width of the bottom border of the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property BottomBorderWidth As Length
Length BottomBorderWidth {get;}
See Also

Reference

IStyle Interface
IStyle Members


Calendar Property (IStyle)

Calendar Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : Calendar Property
Specifies calendar to use to format dates.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Calendar As System.String
System.string Calendar {get;}
See Also

Reference

IStyle Interface
IStyle Members


CharacterSpacing Property (IStyle)

CharacterSpacing Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : CharacterSpacing Property
Char spacing
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CharacterSpacing As Length
Length CharacterSpacing {get;}
See Also

Reference

IStyle Interface
IStyle Members


Color Property (IStyle)

Color Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : Color Property
Specifies the foreground color of the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Color As System.String
System.string Color {get;}
See Also

Reference

IStyle Interface
IStyle Members


DefaultBorderColor Property

DefaultBorderColor Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : DefaultBorderColor Property
Specifies a default color of the border.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DefaultBorderColor As System.String
System.string DefaultBorderColor {get;}
See Also

Reference

IStyle Interface
IStyle Members


DefaultBorderStyle Property

DefaultBorderStyle Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : DefaultBorderStyle Property
Specifies the default style of the border of the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DefaultBorderStyle As System.String
System.string DefaultBorderStyle {get;}
See Also

Reference

IStyle Interface
IStyle Members


DefaultBorderWidth Property

DefaultBorderWidth Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : DefaultBorderWidth Property
Specifies the default width of the border of the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DefaultBorderWidth As Length
Length DefaultBorderWidth {get;}
See Also

Reference

IStyle Interface
IStyle Members


Direction Property (IStyle)

Direction Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : Direction Property
Specifies the direction of text.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Direction As System.String
System.string Direction {get;}
See Also

Reference

IStyle Interface
IStyle Members


DisplayPageNumber Property (IStyle)

DisplayPageNumber Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : DisplayPageNumber Property
Gets a value indicating whether to display page number.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DisplayPageNumber As System.Boolean
System.bool DisplayPageNumber {get;}
See Also

Reference

IStyle Interface
IStyle Members


FontFamily Property (IStyle)

FontFamily Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : FontFamily Property
Contains the name of the font for the item
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property FontFamily As System.String
System.string FontFamily {get;}
See Also

Reference

IStyle Interface
IStyle Members


FontSize Property (IStyle)

FontSize Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : FontSize Property
Indicates the size of the font for the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property FontSize As System.String
System.string FontSize {get;}
See Also

Reference

IStyle Interface
IStyle Members


FontStyle Property (IStyle)

FontStyle Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : FontStyle Property
Indicates the style of the font for the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property FontStyle As System.String
System.string FontStyle {get;}
See Also

Reference

IStyle Interface
IStyle Members


FontWeight Property (IStyle)

FontWeight Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : FontWeight Property
Indicates the thickness of the font for the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property FontWeight As System.String
System.string FontWeight {get;}
See Also

Reference

IStyle Interface
IStyle Members


Format Property (IStyle)

Format Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : Format Property
Contains the Microsoft® .NET Framework formatting string for the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Format As System.String
System.string Format {get;}
See Also

Reference

IStyle Interface
IStyle Members


HeadingLevel Property (IStyle)

HeadingLevel Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : HeadingLevel Property
Gets the heading level.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property HeadingLevel As System.Integer
System.int HeadingLevel {get;}
See Also

Reference

IStyle Interface
IStyle Members


LabelExpression Property (IStyle)

LabelExpression Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : LabelExpression Property
Gets the label expression.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LabelExpression As System.String
System.string LabelExpression {get;}
See Also

Reference

IStyle Interface
IStyle Members


Language Property (IStyle)

Language Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : Language Property
Indicates the primary language of the text.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Language As System.String
System.string Language {get;}
See Also

Reference

IStyle Interface
IStyle Members


LeadingChar Property (IStyle)

LeadingChar Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : LeadingChar Property
Gets the leading character.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LeadingChar As System.String
System.string LeadingChar {get;}
See Also

Reference

IStyle Interface
IStyle Members


LeftBorderColor Property (IStyle)

LeftBorderColor Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : LeftBorderColor Property
Specifies the default width of the border of the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LeftBorderColor As System.String
System.string LeftBorderColor {get;}
See Also

Reference

IStyle Interface
IStyle Members


LeftBorderStyle Property (IStyle)

LeftBorderStyle Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : LeftBorderStyle Property
Describes the style of the left border of the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LeftBorderStyle As System.String
System.string LeftBorderStyle {get;}
See Also

Reference

IStyle Interface
IStyle Members


LeftBorderWidth Property (IStyle)

LeftBorderWidth Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : LeftBorderWidth Property
Describes the width of the left border of the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LeftBorderWidth As Length
Length LeftBorderWidth {get;}
See Also

Reference

IStyle Interface
IStyle Members


LineHeight Property (IStyle)

LineHeight Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : LineHeight Property
Describes the height of a line of text.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LineHeight As Length
Length LineHeight {get;}
See Also

Reference

IStyle Interface
IStyle Members


LineSpacing Property (IStyle)

LineSpacing Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : LineSpacing Property
Line spacing
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LineSpacing As Length
Length LineSpacing {get;}
See Also

Reference

IStyle Interface
IStyle Members


MaxLevel Property (IStyle)

MaxLevel Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : MaxLevel Property
Specifies max level depth for ToC.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MaxLevel As System.Integer
System.int MaxLevel {get;}
See Also

Reference

IStyle Interface
IStyle Members


NumeralLanguage Property (IStyle)

NumeralLanguage Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : NumeralLanguage Property
Specifies digit format as described by its primary language.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property NumeralLanguage As System.String
System.string NumeralLanguage {get;}
See Also

Reference

IStyle Interface
IStyle Members


NumeralVariant Property (IStyle)

NumeralVariant Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : NumeralVariant Property
Specifies the variant of the digit format to use.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property NumeralVariant As System.Integer
System.int NumeralVariant {get;}
See Also

Reference

IStyle Interface
IStyle Members


PaddingBottom Property (IStyle)

PaddingBottom Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : PaddingBottom Property
Specifies the amount of padding below the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PaddingBottom As Length
Length PaddingBottom {get;}
See Also

Reference

IStyle Interface
IStyle Members


PaddingLeft Property (IStyle)

PaddingLeft Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : PaddingLeft Property
Specifies the amount of padding to the left of the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PaddingLeft As Length
Length PaddingLeft {get;}
See Also

Reference

IStyle Interface
IStyle Members


PaddingRight Property (IStyle)

PaddingRight Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : PaddingRight Property
Specifies the amount of padding to the right of the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PaddingRight As Length
Length PaddingRight {get;}
See Also

Reference

IStyle Interface
IStyle Members


PaddingTop Property (IStyle)

PaddingTop Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : PaddingTop Property
Specifies the amount of padding above the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PaddingTop As Length
Length PaddingTop {get;}
See Also

Reference

IStyle Interface
IStyle Members


RightBorderColor Property (IStyle)

RightBorderColor Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : RightBorderColor Property
Describes the color of the right border of the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RightBorderColor As System.String
System.string RightBorderColor {get;}
See Also

Reference

IStyle Interface
IStyle Members


RightBorderStyle Property (IStyle)

RightBorderStyle Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : RightBorderStyle Property
Describes the style of the right border of the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RightBorderStyle As System.String
System.string RightBorderStyle {get;}
See Also

Reference

IStyle Interface
IStyle Members


RightBorderWidth Property (IStyle)

RightBorderWidth Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : RightBorderWidth Property
Describes the width of the right border of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RightBorderWidth As Length
Length RightBorderWidth {get;}
See Also

Reference

IStyle Interface
IStyle Members


ShadowOffset Property (IStyle)

ShadowOffset Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : ShadowOffset Property
Gets the shadow offset.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ShadowOffset As Length
Length ShadowOffset {get;}
See Also

Reference

IStyle Interface
IStyle Members


ShrinkToFit Property (IStyle)

ShrinkToFit Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : ShrinkToFit Property
Shrink to Fit
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ShrinkToFit As System.Boolean
System.bool ShrinkToFit {get;}
See Also

Reference

IStyle Interface
IStyle Members


TextAlign Property (IStyle)

TextAlign Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : TextAlign Property
Describes the horizontal alignment of the text of the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TextAlign As System.String
System.string TextAlign {get;}
See Also

Reference

IStyle Interface
IStyle Members


TextDecoration Property (IStyle)

TextDecoration Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : TextDecoration Property
Describes special text formatting for the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TextDecoration As System.String
System.string TextDecoration {get;}
See Also

Reference

IStyle Interface
IStyle Members


TextIndent Property (IStyle)

TextIndent Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : TextIndent Property
Gets the text indent.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TextIndent As Length
Length TextIndent {get;}
See Also

Reference

IStyle Interface
IStyle Members


TextJustify Property (IStyle)

TextJustify Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : TextJustify Property
TextJustify
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TextJustify As System.String
System.string TextJustify {get;}
See Also

Reference

IStyle Interface
IStyle Members


TopBorderColor Property (IStyle)

TopBorderColor Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : TopBorderColor Property
Describes the color of the top border of the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TopBorderColor As System.String
System.string TopBorderColor {get;}
See Also

Reference

IStyle Interface
IStyle Members


TopBorderStyle Property (IStyle)

TopBorderStyle Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : TopBorderStyle Property
Describes the style of the top border of the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TopBorderStyle As System.String
System.string TopBorderStyle {get;}
See Also

Reference

IStyle Interface
IStyle Members


TopBorderWidth Property (IStyle)

TopBorderWidth Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : TopBorderWidth Property
Describes the height of the top border of the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TopBorderWidth As Length
Length TopBorderWidth {get;}
See Also

Reference

IStyle Interface
IStyle Members


VerticalAlign Property (IStyle)

VerticalAlign Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : VerticalAlign Property
Describes the vertical alignment of the text of the item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property VerticalAlign As System.String
System.string VerticalAlign {get;}
See Also

Reference

IStyle Interface
IStyle Members


WrapMode Property (IStyle)

WrapMode Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : WrapMode Property
Wrap mode
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property WrapMode As System.String
System.string WrapMode {get;}
See Also

Reference

IStyle Interface
IStyle Members


WritingMode Property (IStyle)

WritingMode Property (IStyle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStyle Interface : WritingMode Property
Indicates whether the text is written horizontally or vertically.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property WritingMode As System.String
System.string WritingMode {get;}
See Also

Reference

IStyle Interface
IStyle Members


ISubreport Interface

ISubreport Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ISubreport Interface
Interface for the subreport report item.
Object Model
ISubreport Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ISubreport
   Inherits IDocumentMapItem, IRenderComponent, IReportItem
public interface ISubreport : IDocumentMapItem, IRenderComponent, IReportItem
See Also

Reference

ISubreport Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ISubreport Interface Members

ISubreport Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ISubreport Interface

The following tables list the members exposed by ISubreport.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ErrorTextBox | Returns a renderable textbox suitable for displaying error message when subreport processed with error
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | NoRows | Returns true if no rows of data were loaded by the subreport.
Property | NoRowsMessage | Message to display in the subreport when no rows of data are available in any data set in the subreport.
Property | NoRowsTextBox | Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | ProcessedWithError | Returns a value indicating if an error occured why attempting to process the report.
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Report | Returns the renderable report that this subreport ReportItem represents.
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

ISubreport Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ISubreport Interface Properties

ISubreport Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ISubreport Interface

For a list of all members of this type, see ISubreport members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ErrorTextBox | Returns a renderable textbox suitable for displaying error message when subreport processed with error
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | NoRows | Returns true if no rows of data were loaded by the subreport.
Property | NoRowsMessage | Message to display in the subreport when no rows of data are available in any data set in the subreport.
Property | NoRowsTextBox | Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | ProcessedWithError | Returns a value indicating if an error occured why attempting to process the report.
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Report | Returns the renderable report that this subreport ReportItem represents.
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

ISubreport Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ErrorTextBox Property

ErrorTextBox Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ISubreport Interface : ErrorTextBox Property
Returns a renderable textbox suitable for displaying error message when subreport processed with error
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ErrorTextBox As ITextBox
ITextBox ErrorTextBox {get;}
See Also

Reference

ISubreport Interface
ISubreport Members


NoRows Property (ISubreport)

NoRows Property (ISubreport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ISubreport Interface : NoRows Property
Returns true if no rows of data were loaded by the subreport.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property NoRows As System.Boolean
System.bool NoRows {get;}
See Also

Reference

ISubreport Interface
ISubreport Members


NoRowsMessage Property (ISubreport)

NoRowsMessage Property (ISubreport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ISubreport Interface : NoRowsMessage Property
Message to display in the subreport when no rows of data are available in any data set in the subreport.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property NoRowsMessage As System.String
System.string NoRowsMessage {get;}
See Also

Reference

ISubreport Interface
ISubreport Members


NoRowsTextBox Property (ISubreport)

NoRowsTextBox Property (ISubreport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ISubreport Interface : NoRowsTextBox Property
Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property NoRowsTextBox As ITextBox
ITextBox NoRowsTextBox {get;}
See Also

Reference

ISubreport Interface
ISubreport Members


ProcessedWithError Property

ProcessedWithError Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ISubreport Interface : ProcessedWithError Property
Returns a value indicating if an error occured why attempting to process the report.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ProcessedWithError As System.Boolean
System.bool ProcessedWithError {get;}
See Also

Reference

ISubreport Interface
ISubreport Members


Report Property (ISubreport)

Report Property (ISubreport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ISubreport Interface : Report Property
Returns the renderable report that this subreport ReportItem represents.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Report As IReport
IReport Report {get;}
See Also

Reference

ISubreport Interface
ISubreport Members


ITextBox Interface

ITextBox Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITextBox Interface
Interface for the textbox report item.
Object Model
ITextBox Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITextBox
   Inherits IDocumentMapItem, IRenderComponent, IReportItem, ITextItem
public interface ITextBox : IDocumentMapItem, IRenderComponent, IReportItem, ITextItem
See Also

Reference

ITextBox Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ITextBox Interface Members

ITextBox Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITextBox Interface

The following tables list the members exposed by ITextBox.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Angle | Returns the number of degrees the text is rotated counter-clockwise. Negative values indicate a clockwise rotation.
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | CanGrow | Returns the value of ITextBox CanGrow property.
Property | CanShrink | Returns the value of ITextBox CanShrink property.
Property | Characteristics | Returns the Characteristics held by this textbox instance.
Property | ContentValue | Returns a string representation of this instance Value. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ITextItem)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementStyle | Indicates whether to render this textbox as an element or as an attribute. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ITextItem)
Property | HeadingLevel | The heading level of this textbox.
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | ShrinkToFit | Shrink to Fit
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TabStops | Gets the tab stops.
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Value | Returns the value of this textbox. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ITextItem)
Property | ValueExpression | Gets expression which is used to evaluate textbox value.
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

ITextBox Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ITextBox Interface Properties

ITextBox Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITextBox Interface

For a list of all members of this type, see ITextBox members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Angle | Returns the number of degrees the text is rotated counter-clockwise. Negative values indicate a clockwise rotation.
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | CanGrow | Returns the value of ITextBox CanGrow property.
Property | CanShrink | Returns the value of ITextBox CanShrink property.
Property | Characteristics | Returns the Characteristics held by this textbox instance.
Property | ContentValue | Returns a string representation of this instance Value. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ITextItem)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementStyle | Indicates whether to render this textbox as an element or as an attribute. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ITextItem)
Property | HeadingLevel | The heading level of this textbox.
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | ShrinkToFit | Shrink to Fit
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TabStops | Gets the tab stops.
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Value | Returns the value of this textbox. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ITextItem)
Property | ValueExpression | Gets expression which is used to evaluate textbox value.
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

ITextBox Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Angle Property (ITextBox)

Angle Property (ITextBox)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITextBox Interface : Angle Property
Returns the number of degrees the text is rotated counter-clockwise. Negative values indicate a clockwise rotation.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Angle As System.Single
System.float Angle {get;}
See Also

Reference

ITextBox Interface
ITextBox Members


CanGrow Property (ITextBox)

CanGrow Property (ITextBox)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITextBox Interface : CanGrow Property
Returns the value of ITextBox CanGrow property.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CanGrow As System.Boolean
System.bool CanGrow {get;}
See Also

Reference

ITextBox Interface
ITextBox Members


CanShrink Property (ITextBox)

CanShrink Property (ITextBox)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITextBox Interface : CanShrink Property
Returns the value of ITextBox CanShrink property.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CanShrink As System.Boolean
System.bool CanShrink {get;}
See Also

Reference

ITextBox Interface
ITextBox Members


Characteristics Property

Characteristics Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITextBox Interface : Characteristics Property
Returns the Characteristics held by this textbox instance.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Characteristics As Characteristics
Characteristics Characteristics {get;}
See Also

Reference

ITextBox Interface
ITextBox Members


HeadingLevel Property (ITextBox)

HeadingLevel Property (ITextBox)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITextBox Interface : HeadingLevel Property
The heading level of this textbox.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property HeadingLevel As System.Integer
System.int HeadingLevel {get;}
See Also

Reference

ITextBox Interface
ITextBox Members


ShrinkToFit Property (ITextBox)

ShrinkToFit Property (ITextBox)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITextBox Interface : ShrinkToFit Property
Shrink to Fit
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ShrinkToFit As System.Boolean
System.bool ShrinkToFit {get;}
See Also

Reference

ITextBox Interface
ITextBox Members


TabStops Property

TabStops Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITextBox Interface : TabStops Property
Gets the tab stops.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TabStops As IItemCollection(Of TabStop)
IItemCollection<TabStop> TabStops {get;}
See Also

Reference

ITextBox Interface
ITextBox Members


ValueExpression Property

ValueExpression Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITextBox Interface : ValueExpression Property
Gets expression which is used to evaluate textbox value.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ValueExpression As System.String
System.string ValueExpression {get;}
Remarks
This expression is not null if the expression depends on pagination context.
See Also

Reference

ITextBox Interface
ITextBox Members


ITextItem Interface

ITextItem Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITextItem Interface
ITextItem
Object Model
ITextItem Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITextItem
   Inherits IDocumentMapItem, IRenderComponent, IReportItem
public interface ITextItem : IDocumentMapItem, IRenderComponent, IReportItem
See Also

Reference

ITextItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ITextItem Interface Members

ITextItem Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITextItem Interface

The following tables list the members exposed by ITextItem.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ContentValue | Returns a string representation of this instance Value.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementStyle | Indicates whether to render this textbox as an element or as an attribute.
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Value | Returns the value of this textbox.
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

ITextItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ITextItem Interface Properties

ITextItem Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITextItem Interface

For a list of all members of this type, see ITextItem members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ContentValue | Returns a string representation of this instance Value.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementStyle | Indicates whether to render this textbox as an element or as an attribute.
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Value | Returns the value of this textbox.
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

ITextItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ContentValue Property

ContentValue Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITextItem Interface : ContentValue Property
Returns a string representation of this instance Value.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ContentValue As System.String
System.string ContentValue {get;}
See Also

Reference

ITextItem Interface
ITextItem Members


DataElementStyle Property (ITextItem)

DataElementStyle Property (ITextItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITextItem Interface : DataElementStyle Property
Indicates whether to render this textbox as an element or as an attribute.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataElementStyle As DataElementStyle
DataElementStyle DataElementStyle {get;}
Remarks
DataElementStyle.Auto uses the setting on the Report element.
See Also

Reference

ITextItem Interface
ITextItem Members


Value Property (ITextItem)

Value Property (ITextItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITextItem Interface : Value Property
Returns the value of this textbox.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Value As System.Object
System.object Value {get;}
See Also

Reference

ITextItem Interface
ITextItem Members


ITocItem Interface

ITocItem Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITocItem Interface
Represents ToC item.
Object Model
ITocItem Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITocItem
   Inherits IDocumentMapItem, IRenderComponent, IReportItem, ITextItem
public interface ITocItem : IDocumentMapItem, IRenderComponent, IReportItem, ITextItem
See Also

Reference

ITocItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ITocItem Interface Members

ITocItem Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITocItem Interface

The following tables list the members exposed by ITocItem.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ContentValue | Returns a string representation of this instance Value. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ITextItem)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementStyle | Indicates whether to render this textbox as an element or as an attribute. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ITextItem)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | LeadingChar | Leading char.
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Level | Gets the level (starts from 1).
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageNumber | Gets page number.
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Text | Levels + Label
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Value | Returns the value of this textbox. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ITextItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

ITocItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ITocItem Interface Properties

ITocItem Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITocItem Interface

For a list of all members of this type, see ITocItem members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ContentValue | Returns a string representation of this instance Value. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ITextItem)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementStyle | Indicates whether to render this textbox as an element or as an attribute. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ITextItem)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | LeadingChar | Leading char.
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Level | Gets the level (starts from 1).
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageNumber | Gets page number.
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Text | Levels + Label
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Value | Returns the value of this textbox. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ITextItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

ITocItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


LeadingChar Property (ITocItem)

LeadingChar Property (ITocItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocItem Interface : LeadingChar Property
Leading char.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LeadingChar As System.String
System.string LeadingChar {get;}
See Also

Reference

ITocItem Interface
ITocItem Members


Level Property

Level Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocItem Interface : Level Property
Gets the level (starts from 1).
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Level As System.Integer
System.int Level {get;}
See Also

Reference

ITocItem Interface
ITocItem Members


PageNumber Property (ITocItem)

PageNumber Property (ITocItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocItem Interface : PageNumber Property
Gets page number.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PageNumber As System.String
System.string PageNumber {get;}
See Also

Reference

ITocItem Interface
ITocItem Members


Text Property (ITocItem)

Text Property (ITocItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocItem Interface : Text Property
Levels + Label
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Text As System.String
System.string Text {get;}
See Also

Reference

ITocItem Interface
ITocItem Members


ITocLevel Interface

ITocLevel Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITocLevel Interface
Represents table of contents level.
Object Model
ITocLevel Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITocLevel
public interface ITocLevel
See Also

Reference

ITocLevel Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ITocLevel Interface Members

ITocLevel Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITocLevel Interface

The following tables list the members exposed by ITocLevel.

Public Properties
 | Name | Description
Property | DataElementName | The data element name of level.
Property | DisplayPageNumber | Specifies whether items of this level should display page number.
Property | LabelExpression | The expression which will be used as level label.
Property | LeadingChar | The leading char used to fill space on this level.
Property | Name | The name of level.
Property | Style | The style of level.
Property | TextIndent | The indent of text on this level.
Top
See Also

Reference

ITocLevel Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ITocLevel Interface Properties

ITocLevel Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITocLevel Interface

For a list of all members of this type, see ITocLevel members.

Public Properties
 | Name | Description
Property | DataElementName | The data element name of level.
Property | DisplayPageNumber | Specifies whether items of this level should display page number.
Property | LabelExpression | The expression which will be used as level label.
Property | LeadingChar | The leading char used to fill space on this level.
Property | Name | The name of level.
Property | Style | The style of level.
Property | TextIndent | The indent of text on this level.
Top
See Also

Reference

ITocLevel Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


DataElementName Property (ITocLevel)

DataElementName Property (ITocLevel)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocLevel Interface : DataElementName Property
The data element name of level.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataElementName As System.String
System.string DataElementName {get;}
See Also

Reference

ITocLevel Interface
ITocLevel Members


DisplayPageNumber Property (ITocLevel)

DisplayPageNumber Property (ITocLevel)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocLevel Interface : DisplayPageNumber Property
Specifies whether items of this level should display page number.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DisplayPageNumber As System.Boolean
System.bool DisplayPageNumber {get;}
See Also

Reference

ITocLevel Interface
ITocLevel Members


LabelExpression Property (ITocLevel)

LabelExpression Property (ITocLevel)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocLevel Interface : LabelExpression Property
The expression which will be used as level label.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LabelExpression As System.String
System.string LabelExpression {get;}
See Also

Reference

ITocLevel Interface
ITocLevel Members


LeadingChar Property (ITocLevel)

LeadingChar Property (ITocLevel)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocLevel Interface : LeadingChar Property
The leading char used to fill space on this level.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LeadingChar As System.String
System.string LeadingChar {get;}
See Also

Reference

ITocLevel Interface
ITocLevel Members


Name Property (ITocLevel)

Name Property (ITocLevel)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocLevel Interface : Name Property
The name of level.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Name As System.String
System.string Name {get;}
See Also

Reference

ITocLevel Interface
ITocLevel Members


Style Property (ITocLevel)

Style Property (ITocLevel)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocLevel Interface : Style Property
The style of level.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Style As IStyle
IStyle Style {get;}
See Also

Reference

ITocLevel Interface
ITocLevel Members


TextIndent Property (ITocLevel)

TextIndent Property (ITocLevel)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocLevel Interface : TextIndent Property
The indent of text on this level.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TextIndent As Length
Length TextIndent {get;}
See Also

Reference

ITocLevel Interface
ITocLevel Members


ITocList Interface

ITocList Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITocList Interface
Represents table of contents list.
Object Model
ITocList Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITocList
   Inherits IDataRegion, IDocumentMapItem, IList, IOverflowItem, IPageRegion, IRenderComponent, IReportItem, ISectionRegion
public interface ITocList : IDataRegion, IDocumentMapItem, IList, IOverflowItem, IPageRegion, IRenderComponent, IReportItem, ISectionRegion
See Also

Reference

ITocList Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ITocList Interface Members

ITocList Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITocList Interface

The following tables list the members exposed by ITocList.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | CanGrowHorizontally | Specifies if the List can grow horizontally. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IList)
Property | Contents | Provides the instances of this list control based on the data. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IList)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataSetName | Specifies which data set to use for this data region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Levels | Returns the collection of table of contents levels.
Property | MaxLevel | Specifies max level depth.
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | NoRows | Indicates if the DataRegion has no rows available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsMessage | Message to display in the DataRegion when no rows of data are available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsTextBox | Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.Returns a renderable textbox suitable for displaying NoRowsMessage for this instance. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | OverflowName | Overflow name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Gets a value indicating whether the page should break at the end of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | PageBreakAtStart | Gets a value indicating whether the page should break at the start of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

ITocList Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ITocList Interface Properties

ITocList Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITocList Interface

For a list of all members of this type, see ITocList members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | CanGrowHorizontally | Specifies if the List can grow horizontally. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IList)
Property | Contents | Provides the instances of this list control based on the data. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IList)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataSetName | Specifies which data set to use for this data region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Levels | Returns the collection of table of contents levels.
Property | MaxLevel | Specifies max level depth.
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | NoRows | Indicates if the DataRegion has no rows available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsMessage | Message to display in the DataRegion when no rows of data are available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsTextBox | Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.Returns a renderable textbox suitable for displaying NoRowsMessage for this instance. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | OverflowName | Overflow name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Gets a value indicating whether the page should break at the end of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | PageBreakAtStart | Gets a value indicating whether the page should break at the start of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

ITocList Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Levels Property (ITocList)

Levels Property (ITocList)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocList Interface : Levels Property
Returns the collection of table of contents levels.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Levels As IItemCollection(Of ITocLevel)
IItemCollection<ITocLevel> Levels {get;}
See Also

Reference

ITocList Interface
ITocList Members


MaxLevel Property (ITocList)

MaxLevel Property (ITocList)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocList Interface : MaxLevel Property
Specifies max level depth.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MaxLevel As System.Integer
System.int MaxLevel {get;}
See Also

Reference

ITocList Interface
ITocList Members


IToggleReceiver Interface

IToggleReceiver Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IToggleReceiver Interface
Specifies report entities whose visibility state can be toggled by Toggle report control.
Object Model
IToggleReceiver Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IToggleReceiver
public interface IToggleReceiver
See Also

Reference

IToggleReceiver Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IToggleReceiver Interface Members

IToggleReceiver Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IToggleReceiver Interface

The following tables list the members exposed by IToggleReceiver.

Public Properties
 | Name | Description
Property | Hidden | Indicates whether the item should be visible.
Property | OwnHidden | Indicates that own hidden state of control.
Property | ToggleInstance | Specifies toggle item instance for this entity.
Property | ToggleItem | Specifies toggle item name.
Top
Public Methods
 | Name | Description
Method | ChangeVisibility | Toggles visibility state.
Method | Subscribe | Looks for the toggle controller and registers this instance with it (if there is any).
Top
See Also

Reference

IToggleReceiver Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IToggleReceiver Interface Methods

IToggleReceiver Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IToggleReceiver Interface

For a list of all members of this type, see IToggleReceiver members.

Public Methods
 | Name | Description
Method | ChangeVisibility | Toggles visibility state.
Method | Subscribe | Looks for the toggle controller and registers this instance with it (if there is any).
Top
See Also

Reference

IToggleReceiver Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


ChangeVisibility Method

ChangeVisibility Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IToggleReceiver Interface : ChangeVisibility Method
Toggles visibility state.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub ChangeVisibility()
void ChangeVisibility()
See Also

Reference

IToggleReceiver Interface
IToggleReceiver Members


Subscribe Method

Subscribe Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IToggleReceiver Interface : Subscribe Method
Looks for the toggle controller and registers this instance with it (if there is any).
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Subscribe()
void Subscribe()
See Also

Reference

IToggleReceiver Interface
IToggleReceiver Members


IToggleReceiver Interface Properties

IToggleReceiver Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IToggleReceiver Interface

For a list of all members of this type, see IToggleReceiver members.

Public Properties
 | Name | Description
Property | Hidden | Indicates whether the item should be visible.
Property | OwnHidden | Indicates that own hidden state of control.
Property | ToggleInstance | Specifies toggle item instance for this entity.
Property | ToggleItem | Specifies toggle item name.
Top
See Also

Reference

IToggleReceiver Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Hidden Property (IToggleReceiver)

Hidden Property (IToggleReceiver)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IToggleReceiver Interface : Hidden Property
Indicates whether the item should be visible.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Hidden As System.Boolean
System.bool Hidden {get;}
See Also

Reference

IToggleReceiver Interface
IToggleReceiver Members


OwnHidden Property (IToggleReceiver)

OwnHidden Property (IToggleReceiver)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IToggleReceiver Interface : OwnHidden Property
Indicates that own hidden state of control.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property OwnHidden As System.Boolean
System.bool OwnHidden {get;}
See Also

Reference

IToggleReceiver Interface
IToggleReceiver Members


ToggleInstance Property

ToggleInstance Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IToggleReceiver Interface : ToggleInstance Property
Specifies toggle item instance for this entity.
Syntax
  • Visual Basic
  • C#
'Declaration

Property ToggleInstance As IToggleController
IToggleController ToggleInstance {get; set;}
See Also

Reference

IToggleReceiver Interface
IToggleReceiver Members


ToggleItem Property (IToggleReceiver)

ToggleItem Property (IToggleReceiver)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IToggleReceiver Interface : ToggleItem Property
Specifies toggle item name.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ToggleItem As System.String
System.string ToggleItem {get;}
See Also

Reference

IToggleReceiver Interface
IToggleReceiver Members


IValueCollection Interface

IValueCollection Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IValueCollection Interface
Interface for a collection of values.
Object Model
IValueCollection Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IValueCollection
public interface IValueCollection
See Also

Reference

IValueCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IValueCollection Interface Members

IValueCollection Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IValueCollection Interface

The following tables list the members exposed by IValueCollection.

Public Properties
 | Name | Description
Property | Count | The number of values currently in this collection.
Property | Item | A member of the collection as referenced by the integer index.
Top
See Also

Reference

IValueCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IValueCollection Interface Properties

IValueCollection Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IValueCollection Interface

For a list of all members of this type, see IValueCollection members.

Public Properties
 | Name | Description
Property | Count | The number of values currently in this collection.
Property | Item | A member of the collection as referenced by the integer index.
Top
See Also

Reference

IValueCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


Count Property (IValueCollection)

Count Property (IValueCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IValueCollection Interface : Count Property
The number of values currently in this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Count As System.Integer
System.int Count {get;}
See Also

Reference

IValueCollection Interface
IValueCollection Members


Item Property (IValueCollection)

Item Property (IValueCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IValueCollection Interface : Item Property
The index of the item.
A member of the collection as referenced by the integer index.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As System.Object
System.object this[
   System.int index
]; {get;}

Parameters

index
The index of the item.
See Also

Reference

IValueCollection Interface
IValueCollection Members


IVisualAppearance Interface

IVisualAppearance Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IVisualAppearance Interface
Interface for the visual appearance.
Object Model
IVisualAppearance Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IVisualAppearance
public interface IVisualAppearance
See Also

Reference

IVisualAppearance Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IVisualAppearance Interface Members

IVisualAppearance Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IVisualAppearance Interface

The following tables list the members exposed by IVisualAppearance.

Public Properties
 | Name | Description
Property | BackgroundColor | The color of the background.
Property | Image | Specifies the image that should be displayed, if any.
Property | ImageSource | Specifies image source for image.
Property | InteractivityStates | Specifies interactivity states to which this appearance is applicable.
Property | Tooltip | Specifies how tooltip should be displayed for this area.
Property | TooltipText | Specifies balloon or tooltip text that should be displayed for this area.
Property | Transparency | Specifies how image should be alpha-blended with the underlying area.
Property | Visible | Specifies that there should be visual effects for the area.
Top
See Also

Reference

IVisualAppearance Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IVisualAppearance Interface Properties

IVisualAppearance Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IVisualAppearance Interface

For a list of all members of this type, see IVisualAppearance members.

Public Properties
 | Name | Description
Property | BackgroundColor | The color of the background.
Property | Image | Specifies the image that should be displayed, if any.
Property | ImageSource | Specifies image source for image.
Property | InteractivityStates | Specifies interactivity states to which this appearance is applicable.
Property | Tooltip | Specifies how tooltip should be displayed for this area.
Property | TooltipText | Specifies balloon or tooltip text that should be displayed for this area.
Property | Transparency | Specifies how image should be alpha-blended with the underlying area.
Property | Visible | Specifies that there should be visual effects for the area.
Top
See Also

Reference

IVisualAppearance Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


BackgroundColor Property (IVisualAppearance)

BackgroundColor Property (IVisualAppearance)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IVisualAppearance Interface : BackgroundColor Property
The color of the background.
Syntax
  • Visual Basic
  • C#
'Declaration

Property BackgroundColor As ColorEx
ColorEx BackgroundColor {get; set;}
Remarks
Does not seem as used somewhere, probably should be removed.
See Also

Reference

IVisualAppearance Interface
IVisualAppearance Members


Image Property (IVisualAppearance)

Image Property (IVisualAppearance)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IVisualAppearance Interface : Image Property
Specifies the image that should be displayed, if any.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Image As System.String
System.string Image {get;}
See Also

Reference

IVisualAppearance Interface
IVisualAppearance Members


ImageSource Property

ImageSource Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IVisualAppearance Interface : ImageSource Property
Specifies image source for image.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ImageSource As ImageSource
ImageSource ImageSource {get;}
See Also

Reference

IVisualAppearance Interface
IVisualAppearance Members


InteractivityStates Property

InteractivityStates Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IVisualAppearance Interface : InteractivityStates Property
Specifies interactivity states to which this appearance is applicable.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property InteractivityStates As InteractivityStates
InteractivityStates InteractivityStates {get;}
See Also

Reference

IVisualAppearance Interface
IVisualAppearance Members


Tooltip Property (IVisualAppearance)

Tooltip Property (IVisualAppearance)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IVisualAppearance Interface : Tooltip Property
Specifies how tooltip should be displayed for this area.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Tooltip As TooltipType
TooltipType Tooltip {get;}
See Also

Reference

IVisualAppearance Interface
IVisualAppearance Members


TooltipText Property

TooltipText Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IVisualAppearance Interface : TooltipText Property
Specifies balloon or tooltip text that should be displayed for this area.
Syntax
  • Visual Basic
  • C#
'Declaration

Property TooltipText As System.String
System.string TooltipText {get; set;}
See Also

Reference

IVisualAppearance Interface
IVisualAppearance Members


Transparency Property (IVisualAppearance)

Transparency Property (IVisualAppearance)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IVisualAppearance Interface : Transparency Property
Specifies how image should be alpha-blended with the underlying area.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Transparency As System.Single
System.float Transparency {get;}
See Also

Reference

IVisualAppearance Interface
IVisualAppearance Members


Visible Property (IVisualAppearance)

Visible Property (IVisualAppearance)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IVisualAppearance Interface : Visible Property
Specifies that there should be visual effects for the area.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Visible As System.Boolean
System.bool Visible {get;}
See Also

Reference

IVisualAppearance Interface
IVisualAppearance Members


IVisualShape Interface

IVisualShape Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IVisualShape Interface
Interface for a visual shape.
Object Model
IVisualShape Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IVisualShape
public interface IVisualShape
See Also

Reference

IVisualShape Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IVisualShape Interface Members

IVisualShape Interface Members
Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IVisualShape Interface

The following tables list the members exposed by IVisualShape.

Public Methods
 | Name | Description
Method | GetBounds | Returns a System.Drawing.RectangleF that bounds this shape.
Top
See Also

Reference

IVisualShape Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IVisualShape Interface Methods

IVisualShape Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IVisualShape Interface

For a list of all members of this type, see IVisualShape members.

Public Methods
 | Name | Description
Method | GetBounds | Returns a System.Drawing.RectangleF that bounds this shape.
Top
See Also

Reference

IVisualShape Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetBounds Method (IVisualShape)

GetBounds Method (IVisualShape)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IVisualShape Interface : GetBounds Method
Returns a System.Drawing.RectangleF that bounds this shape.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetBounds() As RectangleFEx
RectangleFEx GetBounds()
See Also

Reference

IVisualShape Interface
IVisualShape Members


GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace

GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace
The GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList namespace includes the IBandedList interface.
Interfaces
 | Interface | Description
Interface | IBandedListGroup | Interface for the banded list group object.
Enumerations
 | Enumeration | Description
Enumeration | GroupKeepTogether | Specifies how BandedListGroup content should be kept together
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


GroupKeepTogether Enumeration

GroupKeepTogether Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace : GroupKeepTogether Enumeration
Specifies how BandedListGroup content should be kept together
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum GroupKeepTogether
   Inherits System.Enum
public enum GroupKeepTogether : System.Enum
Members
Member | Description
All | Specifies that BandedListGroup content should be kept together when possible
FirstDetail | Specifies that BandedListGroup header band should be kept together with first details band when possible
LastDetail | Specifies that BandedListGroup footer band should be kept together with last details band when possible
None | Specifies that BandedListGroup content could be broken across pages
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList.GroupKeepTogether

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace


IBandedListGroup Interface

IBandedListGroup Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace : IBandedListGroup Interface
Interface for the banded list group object.
Object Model
IBandedListGroup Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IBandedListGroup
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion
public interface IBandedListGroup : GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion
See Also

Reference

IBandedListGroup Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace


IBandedListGroup Interface Members

IBandedListGroup Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace : IBandedListGroup Interface

The following tables list the members exposed by IBandedListGroup.

Public Properties
 | Name | Description
Property | DataCollectionName | The name of the banded list group element.
Property | DataElementName | The name of this group instance element.
Property | DataElementOutput | Indicates whether the group should appear in a data rendering. Valid values are DataElementOutput.NoOutput and DataElementOutput.Output.
Property | Details | Returns the Details Band for this Group.
Property | GroupFooter | Specifies footer for this group instance.
Property | GroupHeader | Specifies header for this group instance.
Property | Hidden | Specifies initial visibility for this instance.
Property | KeepTogether | Returns KeepTogether property for this Group.
Property | Name | Specifies a name of this BandedListGroup.
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | PageBreakAtEnd | Returns PageBreakAtEnd property for this Group.
Property | PageBreakAtStart | Returns PageBreakAtStart property for this Group.
Property | PreventOrphanedFooter | Indicates whether the orphaned footer is displayed on next page.
Property | PreventOrphanedHeader | Indicates whether the orphaned header is displayed on the page.
Property | SubGroups | Returns SubGroups for this Group.
Top
See Also

Reference

IBandedListGroup Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace


IBandedListGroup Interface Properties

IBandedListGroup Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace : IBandedListGroup Interface

For a list of all members of this type, see IBandedListGroup members.

Public Properties
 | Name | Description
Property | DataCollectionName | The name of the banded list group element.
Property | DataElementName | The name of this group instance element.
Property | DataElementOutput | Indicates whether the group should appear in a data rendering. Valid values are DataElementOutput.NoOutput and DataElementOutput.Output.
Property | Details | Returns the Details Band for this Group.
Property | GroupFooter | Specifies footer for this group instance.
Property | GroupHeader | Specifies header for this group instance.
Property | Hidden | Specifies initial visibility for this instance.
Property | KeepTogether | Returns KeepTogether property for this Group.
Property | Name | Specifies a name of this BandedListGroup.
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | PageBreakAtEnd | Returns PageBreakAtEnd property for this Group.
Property | PageBreakAtStart | Returns PageBreakAtStart property for this Group.
Property | PreventOrphanedFooter | Indicates whether the orphaned footer is displayed on next page.
Property | PreventOrphanedHeader | Indicates whether the orphaned header is displayed on the page.
Property | SubGroups | Returns SubGroups for this Group.
Top
See Also

Reference

IBandedListGroup Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace


DataCollectionName Property (IBandedListGroup)

DataCollectionName Property (IBandedListGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : DataCollectionName Property
The name of the banded list group element.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataCollectionName As System.String
System.string DataCollectionName {get;}
See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


DataElementName Property (IBandedListGroup)

DataElementName Property (IBandedListGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : DataElementName Property
The name of this group instance element.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataElementName As System.String
System.string DataElementName {get;}
See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


DataElementOutput Property (IBandedListGroup)

DataElementOutput Property (IBandedListGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : DataElementOutput Property
Indicates whether the group should appear in a data rendering. Valid values are DataElementOutput.NoOutput and DataElementOutput.Output.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataElementOutput As DataElementOutput
DataElementOutput DataElementOutput {get;}
See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


Details Property (IBandedListGroup)

Details Property (IBandedListGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : Details Property
Returns the Details Band for this Group.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Details As IDetailBandCollection
IDetailBandCollection Details {get;}
See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


GroupFooter Property

GroupFooter Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : GroupFooter Property
Specifies footer for this group instance.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property GroupFooter As IFooterBand
IFooterBand GroupFooter {get;}
See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


GroupHeader Property

GroupHeader Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : GroupHeader Property
Specifies header for this group instance.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property GroupHeader As IHeaderBand
IHeaderBand GroupHeader {get;}
See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


Hidden Property (IBandedListGroup)

Hidden Property (IBandedListGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : Hidden Property
Specifies initial visibility for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Hidden As System.Boolean
System.bool Hidden {get;}
See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


KeepTogether Property (IBandedListGroup)

KeepTogether Property (IBandedListGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : KeepTogether Property
Returns KeepTogether property for this Group.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property KeepTogether As System.Boolean
System.bool KeepTogether {get;}
See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


Name Property (IBandedListGroup)

Name Property (IBandedListGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : Name Property
Specifies a name of this BandedListGroup.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Name As System.String
System.string Name {get;}
See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


PageBreakAtEnd Property (IBandedListGroup)

PageBreakAtEnd Property (IBandedListGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : PageBreakAtEnd Property
Returns PageBreakAtEnd property for this Group.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PageBreakAtEnd As System.Boolean
System.bool PageBreakAtEnd {get;}
See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


PageBreakAtStart Property (IBandedListGroup)

PageBreakAtStart Property (IBandedListGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : PageBreakAtStart Property
Returns PageBreakAtStart property for this Group.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PageBreakAtStart As System.Boolean
System.bool PageBreakAtStart {get;}
See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


PreventOrphanedFooter Property (IBandedListGroup)

PreventOrphanedFooter Property (IBandedListGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : PreventOrphanedFooter Property
Indicates whether the orphaned footer is displayed on next page.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PreventOrphanedFooter As System.Boolean
System.bool PreventOrphanedFooter {get;}
See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


PreventOrphanedHeader Property (IBandedListGroup)

PreventOrphanedHeader Property (IBandedListGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : PreventOrphanedHeader Property
Indicates whether the orphaned header is displayed on the page.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PreventOrphanedHeader As System.Boolean
System.bool PreventOrphanedHeader {get;}
See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


SubGroups Property (IBandedListGroup)

SubGroups Property (IBandedListGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace > IBandedListGroup Interface : SubGroups Property
Returns SubGroups for this Group.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property SubGroups As IBandedListGroupCollection
IBandedListGroupCollection SubGroups {get;}
See Also

Reference

IBandedListGroup Interface
IBandedListGroup Members


GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace
The GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart namespace includes the interfaces that are used when creating graphs.
Interfaces
 | Interface | Description
Interface | IAxis | Provides axis information required for chart rendering.
Interface | IChart | Interface for the chart report item.
Interface | IChartDataPoint | Interface for chart data points.
Interface | IChartDataPointCollection | Interface for a collection of chart data point objects.
Interface | IChartMember | Interface of chart members.
Interface | IChartMemberCollection | Interface for a collection of chart member objects.
Interface | IDataLabel | Interface for styling labels of the chart data point values.
Interface | ILegend | Interface for chart legend.
Interface | IMarker | Defines a marker properties for displayed chart values.
Interface | IPalette | Represents chart palette.
Interface | IPlotArea | Interface for chart plot area.
Interface | IReferenceLine | Interface for chart reference line.
Interface | IThreeDProperties | Provides 3D properties.
Interface | ITitle | Interface for chart title.
Structures
 | Structure | Description
Structure | PaletteEntry | Defines chart palette entry.
Enumerations
 | Enumeration | Description
Enumeration | ChartSeriesPlotType | Defines chart series plot types.
Enumeration | ChartSubtype | Defines chart subtypes.
Enumeration | ChartType | Defines the enumeration of chart types.
Enumeration | ImageType | An enumeration of chart image types.
Enumeration | LegendLayout | Defines the legend layout.
Enumeration | LegendPosition | Defines the legend position enumeration.
Enumeration | MarkerType | Defines the marker types of chart.
Enumeration | SortOrder | An enumeration of chart sort orders.
Enumeration | ThreeDPropertiesDrawingStyle | Defines the 3D properties drawing styles enumeration.
Enumeration | ThreeDPropertiesProjectionMode | Defines the 3D properties projection mode enumeration.
Enumeration | ThreeDPropertiesShading | Defines the 3D properties shading enumeration.
Enumeration | TickMark | Defines the tick mark enumeration.
Enumeration | TitlePosition | Defines the title position enumeration.
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


ChartSeriesPlotType Enumeration

ChartSeriesPlotType Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ChartSeriesPlotType Enumeration
Defines chart series plot types.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ChartSeriesPlotType
   Inherits System.Enum
public enum ChartSeriesPlotType : System.Enum
Members
Member | Description
Auto | The automatic plot type.
Line | The line plot type.
Point | The point plot type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.ChartSeriesPlotType

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


ChartSubtype Enumeration

ChartSubtype Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ChartSubtype Enumeration
Defines chart subtypes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ChartSubtype
   Inherits System.Enum
public enum ChartSubtype : System.Enum
Members
Member | Description
Candlestick | The candle stick chart subtype.
Exploded | The exploded chart subtype.
HighLowClose | The high low close chart subtype.
Line | The line chart subtype.
OpenHighLowClose | The open high low close chart subtype.
PercentStacked | The percent stacked chart subtype.
Plain | The plain chart subtype.
Smooth | The smooth chart subtype.
SmoothLine | The smooth line chart subtype.
Stacked | The stacked chart subtype.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.ChartSubtype

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


ChartType Enumeration

ChartType Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ChartType Enumeration
Defines the enumeration of chart types.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ChartType
   Inherits System.Enum
public enum ChartType : System.Enum
Members
Member | Description
Area | The area chart type.
Bar | The bar chart type.
Bubble | The bubble chart type.
Column | The column chart type.
DotPlot | The dot plot chart type.
Doughnut | The doughnut chart type.
Funnel | The funnel chart type.
Gantt | The gantt chart type.
Kagi | The kagi chart type.
Line | The line chart type.
Pie | The pie chart type.
PointAndFigure | The point and figure chart type.
Pyramid | The pyramid chart type.
Renko | The renko chart type.
Scatter | The scatter chart type.
Stock | The stock chart type.
ThreeLineBreak | The three line break chart type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.ChartType

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


ImageType Enumeration

ImageType Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ImageType Enumeration
An enumeration of chart image types.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ImageType
   Inherits System.Enum
public enum ImageType : System.Enum
Members
Member | Description
Emf | Metafile image.
Png | PNG image.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.ImageType

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


LegendLayout Enumeration

LegendLayout Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : LegendLayout Enumeration
Defines the legend layout.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LegendLayout
   Inherits System.Enum
public enum LegendLayout : System.Enum
Members
Member | Description
Column | The column legend.
Row | The row legend.
Table | The table layout.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.LegendLayout

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


LegendPosition Enumeration

LegendPosition Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : LegendPosition Enumeration
Defines the legend position enumeration.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LegendPosition
   Inherits System.Enum
public enum LegendPosition : System.Enum
Members
Member | Description
BottomCenter | The bottom center legend position.
BottomLeft | The bottom left legend position.
BottomRight | The bottom right legend position.
LeftBottom | The left bottom legend position.
LeftCenter | The left center legend position.
LeftTop | The left top legend position.
RightBottom | The right bottom legend position.
RightCenter | The right center legend position.
RightTop | The right top legend position.
TopCenter | The top center legend position.
TopLeft | The top left legend position.
TopRight | The top right legend position.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.LegendPosition

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


MarkerType Enumeration

MarkerType Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : MarkerType Enumeration
Defines the marker types of chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MarkerType
   Inherits System.Enum
public enum MarkerType : System.Enum
Members
Member | Description
Auto | The automaticly determined marker type.
Circle | The circle markers.
Cross | The cross markers.
Diamond | The diamond markers.
None | No markerts should be displayed.
Square | The square markers.
Triangle | The triangle markers.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.MarkerType

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


SortOrder Enumeration

SortOrder Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : SortOrder Enumeration
An enumeration of chart sort orders.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum SortOrder
   Inherits System.Enum
public enum SortOrder : System.Enum
Members
Member | Description
Ascending | Sort from low values to high values.
Descending | Sort from high values to low values.
None | Do not sort.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.SortOrder

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


ThreeDPropertiesDrawingStyle Enumeration

ThreeDPropertiesDrawingStyle Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ThreeDPropertiesDrawingStyle Enumeration
Defines the 3D properties drawing styles enumeration.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ThreeDPropertiesDrawingStyle
   Inherits System.Enum
public enum ThreeDPropertiesDrawingStyle : System.Enum
Members
Member | Description
Cube | The cube drawing style.
Cylinder | The cylinder drawing style.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.ThreeDPropertiesDrawingStyle

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


ThreeDPropertiesProjectionMode Enumeration

ThreeDPropertiesProjectionMode Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ThreeDPropertiesProjectionMode Enumeration
Defines the 3D properties projection mode enumeration.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ThreeDPropertiesProjectionMode
   Inherits System.Enum
public enum ThreeDPropertiesProjectionMode : System.Enum
Members
Member | Description
Orthographic | The orthographic projection.
Perspective | The perspective projection.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.ThreeDPropertiesProjectionMode

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


ThreeDPropertiesShading Enumeration

ThreeDPropertiesShading Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ThreeDPropertiesShading Enumeration
Defines the 3D properties shading enumeration.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ThreeDPropertiesShading
   Inherits System.Enum
public enum ThreeDPropertiesShading : System.Enum
Members
Member | Description
None | No shading.
Real | The real shading.
Simple | The simple shading.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.ThreeDPropertiesShading

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


TickMark Enumeration

TickMark Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : TickMark Enumeration
Defines the tick mark enumeration.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TickMark
   Inherits System.Enum
public enum TickMark : System.Enum
Members
Member | Description
Cross | The cross tick mark.
Inside | The inside tick mark.
None | No tick mark.
Outside | The outside tick mark.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.TickMark

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


TitlePosition Enumeration

TitlePosition Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : TitlePosition Enumeration
Defines the title position enumeration.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TitlePosition
   Inherits System.Enum
public enum TitlePosition : System.Enum
Members
Member | Description
Center | The center title position.
Far | The far title position.
Near | The near title position.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.TitlePosition

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


PaletteEntry Structure

PaletteEntry Structure
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : PaletteEntry Structure
Defines chart palette entry.
Object Model
PaletteEntry Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure PaletteEntry
   Inherits System.ValueType
public struct PaletteEntry : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.PaletteEntry

See Also

Reference

PaletteEntry Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


PaletteEntry Structure Members

PaletteEntry Structure Members
Fields Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : PaletteEntry Structure

The following tables list the members exposed by PaletteEntry.

Public Constructors
 | Name | Description
Public Constructor | PaletteEntry Constructor | Overloaded.
Top
Public Fields
 | Name | Description
Public Field | Color | Specifies color of the palette entry.
static (Shared in Visual Basic) | Empty | The empty palette entry.
Public Field | HatchStyle | Specifies hatch style of the palette entry.
Top
Public Properties
 | Name | Description
Public Property | IsHatch | Indicates whether the entry defines hatch style.
Top
Public Methods
 | Name | Description
Public Method | IsEmpty | Specifies whether properties of the entry are unspecified.
Top
See Also

Reference

PaletteEntry Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


PaletteEntry Constructor

PaletteEntry Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > PaletteEntry Structure : PaletteEntry Constructor
Overload List
Overload | Description
PaletteEntry Constructor(ColorEx) | Initializes palette entry with specified color.
PaletteEntry Constructor(Byte) | Initializes palette entry with specified hatch style.
See Also

Reference

PaletteEntry Structure
PaletteEntry Members


PaletteEntry Constructor(ColorEx)

PaletteEntry Constructor(ColorEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > PaletteEntry Structure > PaletteEntry Constructor : PaletteEntry Constructor(ColorEx)
The color of palette entry.
Initializes palette entry with specified color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal color As ColorEx _
)
public PaletteEntry(
   ColorEx color
)

Parameters

color
The color of palette entry.
See Also

Reference

PaletteEntry Structure
PaletteEntry Members
Overload List


PaletteEntry Constructor(Byte)

PaletteEntry Constructor(Byte)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > PaletteEntry Structure > PaletteEntry Constructor : PaletteEntry Constructor(Byte)
The hatch style of palette entry.
Initializes palette entry with specified hatch style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal style As System.Byte _
)
public PaletteEntry(
   System.byte style
)

Parameters

style
The hatch style of palette entry.
See Also

Reference

PaletteEntry Structure
PaletteEntry Members
Overload List


PaletteEntry Structure Methods

PaletteEntry Structure Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : PaletteEntry Structure

For a list of all members of this type, see PaletteEntry members.

Public Methods
 | Name | Description
Public Method | IsEmpty | Specifies whether properties of the entry are unspecified.
Top
See Also

Reference

PaletteEntry Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IsEmpty Method

IsEmpty Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > PaletteEntry Structure : IsEmpty Method
Specifies whether properties of the entry are unspecified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IsEmpty() As System.Boolean
public System.bool IsEmpty()
See Also

Reference

PaletteEntry Structure
PaletteEntry Members


PaletteEntry Structure Properties

PaletteEntry Structure Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : PaletteEntry Structure

For a list of all members of this type, see PaletteEntry members.

Public Properties
 | Name | Description
Public Property | IsHatch | Indicates whether the entry defines hatch style.
Top
See Also

Reference

PaletteEntry Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IsHatch Property

IsHatch Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > PaletteEntry Structure : IsHatch Property
Indicates whether the entry defines hatch style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsHatch As System.Boolean
public System.bool IsHatch {get;}
See Also

Reference

PaletteEntry Structure
PaletteEntry Members


PaletteEntry Structure Fields

PaletteEntry Structure Fields

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : PaletteEntry Structure

For a list of all members of this type, see PaletteEntry members.

Public Fields
 | Name | Description
Public Field | Color | Specifies color of the palette entry.
static (Shared in Visual Basic) | Empty | The empty palette entry.
Public Field | HatchStyle | Specifies hatch style of the palette entry.
Top
See Also

Reference

PaletteEntry Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


Color Field (PaletteEntry)

Color Field (PaletteEntry)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > PaletteEntry Structure : Color Field
Specifies color of the palette entry.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Color As ColorEx
public readonly ColorEx Color
See Also

Reference

PaletteEntry Structure
PaletteEntry Members


Empty Field (PaletteEntry)

Empty Field (PaletteEntry)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > PaletteEntry Structure : Empty Field
The empty palette entry.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Empty As PaletteEntry
public static readonly PaletteEntry Empty
See Also

Reference

PaletteEntry Structure
PaletteEntry Members


HatchStyle Field

HatchStyle Field

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > PaletteEntry Structure : HatchStyle Field
Specifies hatch style of the palette entry.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly HatchStyle As System.Byte
public readonly System.byte HatchStyle
See Also

Reference

PaletteEntry Structure
PaletteEntry Members


IAxis Interface

IAxis Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IAxis Interface
Provides axis information required for chart rendering.
Object Model
IAxis Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IAxis
public interface IAxis
See Also

Reference

IAxis Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IAxis Interface Members

IAxis Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IAxis Interface

The following tables list the members exposed by IAxis.

Public Properties
 | Name | Description
Property | AngledLabels | Gets a value indicating whether the axis labels should be angled.
Property | CrossAt | Gets the value at which to cross the other axis.
Property | EndCap | Specifies the end cap style to use for the axis.
Property | Interlaced | Gets a value indicating whether strip lines are drawn for every second grid line interval for the axis. If grid lines are not used for the axis then the axis' tick marks or labels are used to determine the interlaced strip lines interval.
Property | LogScale | Gets a value indicating whether the axis is logarithmic.
Property | MajorGridStyle | Gets style of axis major grid lines.
Property | MajorInterval | Gets the unit of measurement for major gridlines and tickmarks.
Property | MajorTickMarks | Gets the style of the major tick marks.
Property | Margin | Gets a value indicating whether an axis margin is created. The size of the margin is automatically generated based on the scale and the number of data points.
Property | Max | Gets the maximum value for the axis.
Property | Min | Gets the minimum value for the axis.
Property | MinorGridStyle | Gets style of axis minor grid lines.
Property | MinorInterval | Gets the unit of measurement for minor gridlines and tickmarks.
Property | MinorTickMarks | Gets the style of minor tick marks.
Property | Reverse | Gets a value indicating whether the axis is plotted in reverse or normally. If set to true, the axis direction is reversed.
Property | Scalar | Gets a value indicating whether the values along the axis are scalar values (i.e. numeric or date) which are displayed on the chart in a continuous flow with missing numbers or dates filled in.
Property | ShowMajorGridLines | Specifies visibility of major grid lines.
Property | ShowMinorGridLines | Specifies visibility of minor grid lines.
Property | Style | Gets axis style.
Property | Title | Gets style of axis title.
Property | Visible | Gets a value indicating whether the axis labels are displayed.
Top
See Also

Reference

IAxis Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IAxis Interface Properties

IAxis Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IAxis Interface

For a list of all members of this type, see IAxis members.

Public Properties
 | Name | Description
Property | AngledLabels | Gets a value indicating whether the axis labels should be angled.
Property | CrossAt | Gets the value at which to cross the other axis.
Property | EndCap | Specifies the end cap style to use for the axis.
Property | Interlaced | Gets a value indicating whether strip lines are drawn for every second grid line interval for the axis. If grid lines are not used for the axis then the axis' tick marks or labels are used to determine the interlaced strip lines interval.
Property | LogScale | Gets a value indicating whether the axis is logarithmic.
Property | MajorGridStyle | Gets style of axis major grid lines.
Property | MajorInterval | Gets the unit of measurement for major gridlines and tickmarks.
Property | MajorTickMarks | Gets the style of the major tick marks.
Property | Margin | Gets a value indicating whether an axis margin is created. The size of the margin is automatically generated based on the scale and the number of data points.
Property | Max | Gets the maximum value for the axis.
Property | Min | Gets the minimum value for the axis.
Property | MinorGridStyle | Gets style of axis minor grid lines.
Property | MinorInterval | Gets the unit of measurement for minor gridlines and tickmarks.
Property | MinorTickMarks | Gets the style of minor tick marks.
Property | Reverse | Gets a value indicating whether the axis is plotted in reverse or normally. If set to true, the axis direction is reversed.
Property | Scalar | Gets a value indicating whether the values along the axis are scalar values (i.e. numeric or date) which are displayed on the chart in a continuous flow with missing numbers or dates filled in.
Property | ShowMajorGridLines | Specifies visibility of major grid lines.
Property | ShowMinorGridLines | Specifies visibility of minor grid lines.
Property | Style | Gets axis style.
Property | Title | Gets style of axis title.
Property | Visible | Gets a value indicating whether the axis labels are displayed.
Top
See Also

Reference

IAxis Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


AngledLabels Property (IAxis)

AngledLabels Property (IAxis)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : AngledLabels Property
Gets a value indicating whether the axis labels should be angled.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property AngledLabels As System.Boolean
System.bool AngledLabels {get;}
See Also

Reference

IAxis Interface
IAxis Members


CrossAt Property (IAxis)

CrossAt Property (IAxis)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : CrossAt Property
Gets the value at which to cross the other axis.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CrossAt As System.Nullable(Of Double)
System.Nullable<double> CrossAt {get;}
Remarks
If this value is omitted, it uses the default value for the chart type.
See Also

Reference

IAxis Interface
IAxis Members


EndCap Property (IAxis)

EndCap Property (IAxis)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : EndCap Property
Specifies the end cap style to use for the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property EndCap As System.String
System.string EndCap {get;}
See Also

Reference

IAxis Interface
IAxis Members


Interlaced Property (IAxis)

Interlaced Property (IAxis)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : Interlaced Property
Gets a value indicating whether strip lines are drawn for every second grid line interval for the axis. If grid lines are not used for the axis then the axis' tick marks or labels are used to determine the interlaced strip lines interval.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Interlaced As System.Boolean
System.bool Interlaced {get;}
See Also

Reference

IAxis Interface
IAxis Members


LogScale Property (IAxis)

LogScale Property (IAxis)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : LogScale Property
Gets a value indicating whether the axis is logarithmic.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LogScale As System.Boolean
System.bool LogScale {get;}
See Also

Reference

IAxis Interface
IAxis Members


MajorGridStyle Property

MajorGridStyle Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : MajorGridStyle Property
Gets style of axis major grid lines.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MajorGridStyle As IStyle
IStyle MajorGridStyle {get;}
See Also

Reference

IAxis Interface
IAxis Members


MajorInterval Property (IAxis)

MajorInterval Property (IAxis)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : MajorInterval Property
Gets the unit of measurement for major gridlines and tickmarks.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MajorInterval As System.Nullable(Of Double)
System.Nullable<double> MajorInterval {get;}
Remarks
If omitted, the axis is automatically divided.
See Also

Reference

IAxis Interface
IAxis Members


MajorTickMarks Property (IAxis)

MajorTickMarks Property (IAxis)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : MajorTickMarks Property
Gets the style of the major tick marks.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MajorTickMarks As TickMark
TickMark MajorTickMarks {get;}
See Also

Reference

IAxis Interface
IAxis Members


Margin Property (IAxis)

Margin Property (IAxis)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : Margin Property
Gets a value indicating whether an axis margin is created. The size of the margin is automatically generated based on the scale and the number of data points.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Margin As System.Boolean
System.bool Margin {get;}
See Also

Reference

IAxis Interface
IAxis Members


Max Property (IAxis)

Max Property (IAxis)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : Max Property
Gets the maximum value for the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Max As System.Nullable(Of Double)
System.Nullable<double> Max {get;}
Remarks
If omitted, the axis automatically scales.
See Also

Reference

IAxis Interface
IAxis Members


Min Property (IAxis)

Min Property (IAxis)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : Min Property
Gets the minimum value for the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Min As System.Nullable(Of Double)
System.Nullable<double> Min {get;}
Remarks
If omitted, the axis automatically scales.
See Also

Reference

IAxis Interface
IAxis Members


MinorGridStyle Property

MinorGridStyle Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : MinorGridStyle Property
Gets style of axis minor grid lines.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MinorGridStyle As IStyle
IStyle MinorGridStyle {get;}
See Also

Reference

IAxis Interface
IAxis Members


MinorInterval Property (IAxis)

MinorInterval Property (IAxis)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : MinorInterval Property
Gets the unit of measurement for minor gridlines and tickmarks.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MinorInterval As System.Nullable(Of Double)
System.Nullable<double> MinorInterval {get;}
Remarks
If omitted, the axis is automatically divided.
See Also

Reference

IAxis Interface
IAxis Members


MinorTickMarks Property (IAxis)

MinorTickMarks Property (IAxis)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : MinorTickMarks Property
Gets the style of minor tick marks.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MinorTickMarks As TickMark
TickMark MinorTickMarks {get;}
See Also

Reference

IAxis Interface
IAxis Members


Reverse Property (IAxis)

Reverse Property (IAxis)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : Reverse Property
Gets a value indicating whether the axis is plotted in reverse or normally. If set to true, the axis direction is reversed.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Reverse As System.Boolean
System.bool Reverse {get;}
See Also

Reference

IAxis Interface
IAxis Members


Scalar Property (IAxis)

Scalar Property (IAxis)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : Scalar Property
Gets a value indicating whether the values along the axis are scalar values (i.e. numeric or date) which are displayed on the chart in a continuous flow with missing numbers or dates filled in.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Scalar As System.Boolean
System.bool Scalar {get;}
See Also

Reference

IAxis Interface
IAxis Members


ShowMajorGridLines Property

ShowMajorGridLines Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : ShowMajorGridLines Property
Specifies visibility of major grid lines.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ShowMajorGridLines As System.Boolean
System.bool ShowMajorGridLines {get;}
See Also

Reference

IAxis Interface
IAxis Members


ShowMinorGridLines Property

ShowMinorGridLines Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : ShowMinorGridLines Property
Specifies visibility of minor grid lines.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ShowMinorGridLines As System.Boolean
System.bool ShowMinorGridLines {get;}
See Also

Reference

IAxis Interface
IAxis Members


Style Property (IAxis)

Style Property (IAxis)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : Style Property
Gets axis style.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Style As IStyle
IStyle Style {get;}
See Also

Reference

IAxis Interface
IAxis Members


Title Property (IAxis)

Title Property (IAxis)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : Title Property
Gets style of axis title.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Title As ITitle
ITitle Title {get;}
See Also

Reference

IAxis Interface
IAxis Members


Visible Property (IAxis)

Visible Property (IAxis)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IAxis Interface : Visible Property
Gets a value indicating whether the axis labels are displayed.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Visible As System.Boolean
System.bool Visible {get;}
See Also

Reference

IAxis Interface
IAxis Members


IChart Interface

IChart Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChart Interface
Interface for the chart report item.
Object Model
IChart Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IChart
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStaticItem
public interface IChart : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStaticItem
See Also

Reference

IChart Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IChart Interface Members

IChart Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChart Interface

The following tables list the members exposed by IChart.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | CategoriesCount | Returns the count of the number of categories in this chart.
Property | CategoryAxis | Gets chart category axis.
Property | CategoryGroupingsCount | Gets number of category groupings defined in chart definition.
Property | CategoryMemberCollection | Returns top-level category grouping members.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataPointCategoryCount | Returns the category count.
Property | DataPointCollection | Returns the data point collection.
Property | DataPointSeriesCount | Returns the series count.
Property | DataSetName | Specifies which data set to use for this data region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | DefinitionSeriesCount | Gets count of series defined in ChartData of the chart definition.
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | HorizontalResolution | Horizontal resolution (DPI) of the image.
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Legend | Gets chart legend.
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | NoRows | Indicates if the DataRegion has no rows available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsMessage | Message to display in the DataRegion when no rows of data are available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsTextBox | Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.Returns a renderable textbox suitable for displaying NoRowsMessage for this instance. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | OverflowName | Overflow name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Gets a value indicating whether the page should break at the end of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | PageBreakAtStart | Gets a value indicating whether the page should break at the start of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | Palette | Gets chart palette.
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | PlainCategoryMembers | Returns the category members as an array of chart members.
Property | PlainSeriesMembers | Returns the series members as an array of chart members.
Property | PlotArea | Gets chart plot area.
Property | PointWidth | Specifies point width.
Property | ReferenceLine | Returns the reference line.
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | SeriesCount | Returns the count of the number of series in this chart.
Property | SeriesMemberCollection | Returns the series member collection.
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Subtype | Gets chart subtype.
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ThreeDProperties | Gets properties to setup 3D-chart.
Property | Title | Gets chart title properties.
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Type | Gets chart type.
Property | ValueAxis | Gets chart value axis.
Property | VerticalResolution | Vertical resolution (DPI) of the image.
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetImage | Overloaded. Returns an image of the chart in the PNG format. The image will be at the appropriate size to render at 96dpi.
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetSeriesPlotType | Gets plot type of chart series defined in ChartData at specified index.
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | SetDpi | Sets the dpi on the chart.
Top
See Also

Reference

IChart Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IChart Interface Methods

IChart Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChart Interface

For a list of all members of this type, see IChart members.

Public Methods
 | Name | Description
Method | GetImage | Overloaded. Returns an image of the chart in the PNG format. The image will be at the appropriate size to render at 96dpi.
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetSeriesPlotType | Gets plot type of chart series defined in ChartData at specified index.
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | SetDpi | Sets the dpi on the chart.
Top
See Also

Reference

IChart Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


GetImage Method (IChart)

GetImage Method (IChart)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : GetImage Method
Returns an image of the chart in the PNG format. The image will be at the appropriate size to render at 96dpi.
Overload List
Overload | Description
GetImage() | Returns an image of the chart in the PNG format. The image will be at the appropriate size to render at 96dpi.
GetImage(Boolean) | Returns an image of the chart in the PNG format. The image will be at the appropriate size to render at 96dpi.
GetImage(ImageType) | Returns an image of the chart.
GetImage(ImageType,Boolean) | Returns the image of the chart.
See Also

Reference

IChart Interface
IChart Members


GetImage() Method

GetImage() Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface > GetImage Method : GetImage() Method
Returns an image of the chart in the PNG format. The image will be at the appropriate size to render at 96dpi.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function GetImage() As System.IO.Stream
System.IO.Stream GetImage()

Return Value

The image of the chart in the PNG format.
See Also

Reference

IChart Interface
IChart Members
Overload List


GetImage(Boolean) Method

GetImage(Boolean) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface > GetImage Method : GetImage(Boolean) Method
A returned variable indicating if this image contains an image map.
Returns an image of the chart in the PNG format. The image will be at the appropriate size to render at 96dpi.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function GetImage( _
   ByRef hasImageMap As System.Boolean _
) As System.IO.Stream
System.IO.Stream GetImage(
   out System.bool hasImageMap
)

Parameters

hasImageMap
A returned variable indicating if this image contains an image map.

Return Value

The image of the chart in the PNG format.
See Also

Reference

IChart Interface
IChart Members
Overload List


GetImage(ImageType) Method

GetImage(ImageType) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface > GetImage Method : GetImage(ImageType) Method
The format of the image.
Returns an image of the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function GetImage( _
   ByVal type As ImageType _
) As System.IO.Stream
System.IO.Stream GetImage(
   ImageType type
)

Parameters

type
The format of the image.

Return Value

The image of the chart in the PNG format.
See Also

Reference

IChart Interface
IChart Members
Overload List


GetImage(ImageType,Boolean) Method

GetImage(ImageType,Boolean) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface > GetImage Method : GetImage(ImageType,Boolean) Method
The format of the image.
A returned variable indicating if this image contains an image map.
Returns the image of the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function GetImage( _
   ByVal type As ImageType, _
   ByRef hasImageMap As System.Boolean _
) As System.IO.Stream
System.IO.Stream GetImage(
   ImageType type,
   out System.bool hasImageMap
)

Parameters

type
The format of the image.
hasImageMap
A returned variable indicating if this image contains an image map.

Return Value

The image of the chart in the PNG format.
See Also

Reference

IChart Interface
IChart Members
Overload List


GetSeriesPlotType Method

GetSeriesPlotType Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : GetSeriesPlotType Method
Zero-based index of the chart series definition.
Gets plot type of chart series defined in ChartData at specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetSeriesPlotType( _
   ByVal seriesIndex As System.Integer _
) As ChartSeriesPlotType
ChartSeriesPlotType GetSeriesPlotType(
   System.int seriesIndex
)

Parameters

seriesIndex
Zero-based index of the chart series definition.
See Also

Reference

IChart Interface
IChart Members


SetDpi Method

SetDpi Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : SetDpi Method
The horizontal dots per inch.
The vertical dots per inch.
Sets the dpi on the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub SetDpi( _
   ByVal xDpi As System.Integer, _
   ByVal yDpi As System.Integer _
)
void SetDpi(
   System.int xDpi,
   System.int yDpi
)

Parameters

xDpi
The horizontal dots per inch.
yDpi
The vertical dots per inch.
See Also

Reference

IChart Interface
IChart Members


IChart Interface Properties

IChart Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChart Interface

For a list of all members of this type, see IChart members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | CategoriesCount | Returns the count of the number of categories in this chart.
Property | CategoryAxis | Gets chart category axis.
Property | CategoryGroupingsCount | Gets number of category groupings defined in chart definition.
Property | CategoryMemberCollection | Returns top-level category grouping members.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataPointCategoryCount | Returns the category count.
Property | DataPointCollection | Returns the data point collection.
Property | DataPointSeriesCount | Returns the series count.
Property | DataSetName | Specifies which data set to use for this data region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | DefinitionSeriesCount | Gets count of series defined in ChartData of the chart definition.
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | HorizontalResolution | Horizontal resolution (DPI) of the image.
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Legend | Gets chart legend.
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | NoRows | Indicates if the DataRegion has no rows available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsMessage | Message to display in the DataRegion when no rows of data are available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsTextBox | Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.Returns a renderable textbox suitable for displaying NoRowsMessage for this instance. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | OverflowName | Overflow name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Gets a value indicating whether the page should break at the end of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | PageBreakAtStart | Gets a value indicating whether the page should break at the start of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | Palette | Gets chart palette.
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | PlainCategoryMembers | Returns the category members as an array of chart members.
Property | PlainSeriesMembers | Returns the series members as an array of chart members.
Property | PlotArea | Gets chart plot area.
Property | PointWidth | Specifies point width.
Property | ReferenceLine | Returns the reference line.
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | SeriesCount | Returns the count of the number of series in this chart.
Property | SeriesMemberCollection | Returns the series member collection.
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Subtype | Gets chart subtype.
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ThreeDProperties | Gets properties to setup 3D-chart.
Property | Title | Gets chart title properties.
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Type | Gets chart type.
Property | ValueAxis | Gets chart value axis.
Property | VerticalResolution | Vertical resolution (DPI) of the image.
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IChart Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


CategoriesCount Property

CategoriesCount Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : CategoriesCount Property
Returns the count of the number of categories in this chart.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CategoriesCount As System.Integer
System.int CategoriesCount {get;}
See Also

Reference

IChart Interface
IChart Members


CategoryAxis Property (IChart)

CategoryAxis Property (IChart)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : CategoryAxis Property
Gets chart category axis.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CategoryAxis As IAxis
IAxis CategoryAxis {get;}
See Also

Reference

IChart Interface
IChart Members


CategoryGroupingsCount Property

CategoryGroupingsCount Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : CategoryGroupingsCount Property
Gets number of category groupings defined in chart definition.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CategoryGroupingsCount As System.Integer
System.int CategoryGroupingsCount {get;}
See Also

Reference

IChart Interface
IChart Members


CategoryMemberCollection Property

CategoryMemberCollection Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : CategoryMemberCollection Property
Returns top-level category grouping members.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CategoryMemberCollection As IChartMemberCollection
IChartMemberCollection CategoryMemberCollection {get;}
See Also

Reference

IChart Interface
IChart Members


DataPointCategoryCount Property

DataPointCategoryCount Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : DataPointCategoryCount Property
Returns the category count.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataPointCategoryCount As System.Integer
System.int DataPointCategoryCount {get;}
See Also

Reference

IChart Interface
IChart Members


DataPointCollection Property

DataPointCollection Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : DataPointCollection Property
Returns the data point collection.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataPointCollection As IChartDataPointCollection
IChartDataPointCollection DataPointCollection {get;}
See Also

Reference

IChart Interface
IChart Members


DataPointSeriesCount Property

DataPointSeriesCount Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : DataPointSeriesCount Property
Returns the series count.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataPointSeriesCount As System.Integer
System.int DataPointSeriesCount {get;}
See Also

Reference

IChart Interface
IChart Members


DefinitionSeriesCount Property

DefinitionSeriesCount Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : DefinitionSeriesCount Property
Gets count of series defined in ChartData of the chart definition.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DefinitionSeriesCount As System.Integer
System.int DefinitionSeriesCount {get;}
See Also

Reference

IChart Interface
IChart Members


HorizontalResolution Property (IChart)

HorizontalResolution Property (IChart)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : HorizontalResolution Property
Horizontal resolution (DPI) of the image.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property HorizontalResolution As System.Single
System.float HorizontalResolution {get;}
See Also

Reference

IChart Interface
IChart Members


Legend Property (IChart)

Legend Property (IChart)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : Legend Property
Gets chart legend.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Legend As ILegend
ILegend Legend {get;}
See Also

Reference

IChart Interface
IChart Members


Palette Property (IChart)

Palette Property (IChart)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : Palette Property
Gets chart palette.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Palette As IPalette
IPalette Palette {get;}
See Also

Reference

IChart Interface
IChart Members


PlainCategoryMembers Property

PlainCategoryMembers Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : PlainCategoryMembers Property
Returns the category members as an array of chart members.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PlainCategoryMembers As IChartMember()
IChartMember[] PlainCategoryMembers {get;}
See Also

Reference

IChart Interface
IChart Members


PlainSeriesMembers Property

PlainSeriesMembers Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : PlainSeriesMembers Property
Returns the series members as an array of chart members.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PlainSeriesMembers As IChartMember()
IChartMember[] PlainSeriesMembers {get;}
See Also

Reference

IChart Interface
IChart Members


PlotArea Property (IChart)

PlotArea Property (IChart)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : PlotArea Property
Gets chart plot area.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PlotArea As IPlotArea
IPlotArea PlotArea {get;}
See Also

Reference

IChart Interface
IChart Members


PointWidth Property (IChart)

PointWidth Property (IChart)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : PointWidth Property
Specifies point width.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PointWidth As System.Nullable(Of Integer)
System.Nullable<int> PointWidth {get;}
See Also

Reference

IChart Interface
IChart Members


ReferenceLine Property (IChart)

ReferenceLine Property (IChart)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : ReferenceLine Property
Returns the reference line.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ReferenceLine As IReferenceLine
IReferenceLine ReferenceLine {get;}
See Also

Reference

IChart Interface
IChart Members


SeriesCount Property (IChart)

SeriesCount Property (IChart)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : SeriesCount Property
Returns the count of the number of series in this chart.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property SeriesCount As System.Integer
System.int SeriesCount {get;}
See Also

Reference

IChart Interface
IChart Members


SeriesMemberCollection Property

SeriesMemberCollection Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : SeriesMemberCollection Property
Returns the series member collection.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property SeriesMemberCollection As IChartMemberCollection
IChartMemberCollection SeriesMemberCollection {get;}
See Also

Reference

IChart Interface
IChart Members


Subtype Property (IChart)

Subtype Property (IChart)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : Subtype Property
Gets chart subtype.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Subtype As ChartSubtype
ChartSubtype Subtype {get;}
See Also

Reference

IChart Interface
IChart Members


ThreeDProperties Property (IChart)

ThreeDProperties Property (IChart)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : ThreeDProperties Property
Gets properties to setup 3D-chart.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ThreeDProperties As IThreeDProperties
IThreeDProperties ThreeDProperties {get;}
See Also

Reference

IChart Interface
IChart Members


Title Property (IChart)

Title Property (IChart)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : Title Property
Gets chart title properties.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Title As ITitle
ITitle Title {get;}
See Also

Reference

IChart Interface
IChart Members


Type Property (IChart)

Type Property (IChart)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : Type Property
Gets chart type.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Type As ChartType
ChartType Type {get;}
See Also

Reference

IChart Interface
IChart Members


ValueAxis Property (IChart)

ValueAxis Property (IChart)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : ValueAxis Property
Gets chart value axis.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ValueAxis As IAxis
IAxis ValueAxis {get;}
See Also

Reference

IChart Interface
IChart Members


VerticalResolution Property (IChart)

VerticalResolution Property (IChart)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : VerticalResolution Property
Vertical resolution (DPI) of the image.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property VerticalResolution As System.Single
System.float VerticalResolution {get;}
See Also

Reference

IChart Interface
IChart Members


IChartDataPoint Interface

IChartDataPoint Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartDataPoint Interface
Interface for chart data points.
Object Model
IChartDataPoint Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IChartDataPoint
public interface IChartDataPoint
See Also

Reference

IChartDataPoint Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IChartDataPoint Interface Members

IChartDataPoint Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartDataPoint Interface

The following tables list the members exposed by IChartDataPoint.

Public Properties
 | Name | Description
Property | Action | A (default) Action to perform for this instance.
Property | CustomProperties | Gets the custom properties for this data point.
Property | DataElementName | The name used for this chart data point in data renderings.
Property | DataElementOutput | Indicates how to render the item in data renderings.
Property | DataLabel | Gets data label style.
Property | DataValues | Gets the values for the data point.
Property | MapAreas | Gets the IImageMapAreas contained within the IChartDataPoint
Property | Marker | Gets data point marker style.
Property | ShowBeginEndMarkersOnly | Indicates if only the first and last markers are shown for the data point; otherwise all markers are shown.
Property | Style | Gets data point style.
Property | StyleProperties | Gets properties to customize rendering for specific chart types.
Top
See Also

Reference

IChartDataPoint Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IChartDataPoint Interface Properties

IChartDataPoint Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartDataPoint Interface

For a list of all members of this type, see IChartDataPoint members.

Public Properties
 | Name | Description
Property | Action | A (default) Action to perform for this instance.
Property | CustomProperties | Gets the custom properties for this data point.
Property | DataElementName | The name used for this chart data point in data renderings.
Property | DataElementOutput | Indicates how to render the item in data renderings.
Property | DataLabel | Gets data label style.
Property | DataValues | Gets the values for the data point.
Property | MapAreas | Gets the IImageMapAreas contained within the IChartDataPoint
Property | Marker | Gets data point marker style.
Property | ShowBeginEndMarkersOnly | Indicates if only the first and last markers are shown for the data point; otherwise all markers are shown.
Property | Style | Gets data point style.
Property | StyleProperties | Gets properties to customize rendering for specific chart types.
Top
See Also

Reference

IChartDataPoint Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


Action Property (IChartDataPoint)

Action Property (IChartDataPoint)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPoint Interface : Action Property
A (default) Action to perform for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Action As IAction
IAction Action {get;}
See Also

Reference

IChartDataPoint Interface
IChartDataPoint Members


CustomProperties Property (IChartDataPoint)

CustomProperties Property (IChartDataPoint)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPoint Interface : CustomProperties Property
Gets the custom properties for this data point.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CustomProperties As CustomPropertyCollection
CustomPropertyCollection CustomProperties {get;}
See Also

Reference

IChartDataPoint Interface
IChartDataPoint Members


DataElementName Property (IChartDataPoint)

DataElementName Property (IChartDataPoint)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPoint Interface : DataElementName Property
The name used for this chart data point in data renderings.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataElementName As System.String
System.string DataElementName {get;}
See Also

Reference

IChartDataPoint Interface
IChartDataPoint Members


DataElementOutput Property (IChartDataPoint)

DataElementOutput Property (IChartDataPoint)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPoint Interface : DataElementOutput Property
Indicates how to render the item in data renderings.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataElementOutput As DataElementOutput
DataElementOutput DataElementOutput {get;}
See Also

Reference

IChartDataPoint Interface
IChartDataPoint Members


DataLabel Property (IChartDataPoint)

DataLabel Property (IChartDataPoint)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPoint Interface : DataLabel Property
Gets data label style.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataLabel As IDataLabel
IDataLabel DataLabel {get;}
See Also

Reference

IChartDataPoint Interface
IChartDataPoint Members


DataValues Property (IChartDataPoint)

DataValues Property (IChartDataPoint)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPoint Interface : DataValues Property
Gets the values for the data point.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataValues As System.Object()
System.object[] DataValues {get;}
See Also

Reference

IChartDataPoint Interface
IChartDataPoint Members


MapAreas Property

MapAreas Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPoint Interface : MapAreas Property
Gets the IImageMapAreas contained within the IChartDataPoint
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MapAreas As ImageMapAreaCollection
ImageMapAreaCollection MapAreas {get;}
See Also

Reference

IChartDataPoint Interface
IChartDataPoint Members


Marker Property (IChartDataPoint)

Marker Property (IChartDataPoint)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPoint Interface : Marker Property
Gets data point marker style.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Marker As IMarker
IMarker Marker {get;}
See Also

Reference

IChartDataPoint Interface
IChartDataPoint Members


ShowBeginEndMarkersOnly Property (IChartDataPoint)

ShowBeginEndMarkersOnly Property (IChartDataPoint)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPoint Interface : ShowBeginEndMarkersOnly Property
Indicates if only the first and last markers are shown for the data point; otherwise all markers are shown.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ShowBeginEndMarkersOnly As System.Boolean
System.bool ShowBeginEndMarkersOnly {get;}
See Also

Reference

IChartDataPoint Interface
IChartDataPoint Members


Style Property (IChartDataPoint)

Style Property (IChartDataPoint)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPoint Interface : Style Property
Gets data point style.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Style As IStyle
IStyle Style {get;}
See Also

Reference

IChartDataPoint Interface
IChartDataPoint Members


StyleProperties Property

StyleProperties Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPoint Interface : StyleProperties Property
Gets properties to customize rendering for specific chart types.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property StyleProperties As System.Collections.Generic.IEnumerable(Of KeyValuePair(Of String,String))
System.Collections.Generic.IEnumerable<KeyValuePair<string,string>> StyleProperties {get;}
See Also

Reference

IChartDataPoint Interface
IChartDataPoint Members


IChartDataPointCollection Interface

IChartDataPointCollection Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartDataPointCollection Interface
Interface for a collection of chart data point objects.
Object Model
IChartDataPointCollection Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IChartDataPointCollection
public interface IChartDataPointCollection
See Also

Reference

IChartDataPointCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IChartDataPointCollection Interface Members

IChartDataPointCollection Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartDataPointCollection Interface

The following tables list the members exposed by IChartDataPointCollection.

Public Properties
 | Name | Description
Property | CategoryCount | Gets the number of categories in the data point collection.
Property | Count | Gets the number of category*series cells.
Property | Item | Gets the two dimensional array of data points in the chart.
Property | SeriesCount | Gets the number of series in the data point collection.
Top
See Also

Reference

IChartDataPointCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IChartDataPointCollection Interface Properties

IChartDataPointCollection Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartDataPointCollection Interface

For a list of all members of this type, see IChartDataPointCollection members.

Public Properties
 | Name | Description
Property | CategoryCount | Gets the number of categories in the data point collection.
Property | Count | Gets the number of category*series cells.
Property | Item | Gets the two dimensional array of data points in the chart.
Property | SeriesCount | Gets the number of series in the data point collection.
Top
See Also

Reference

IChartDataPointCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


CategoryCount Property

CategoryCount Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPointCollection Interface : CategoryCount Property
Gets the number of categories in the data point collection.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CategoryCount As System.Integer
System.int CategoryCount {get;}
See Also

Reference

IChartDataPointCollection Interface
IChartDataPointCollection Members


Count Property (IChartDataPointCollection)

Count Property (IChartDataPointCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPointCollection Interface : Count Property
Gets the number of category*series cells.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Count As System.Integer
System.int Count {get;}
See Also

Reference

IChartDataPointCollection Interface
IChartDataPointCollection Members


Item Property (IChartDataPointCollection)

Item Property (IChartDataPointCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPointCollection Interface : Item Property
The series index of the item.
The category index of the item.
Gets the two dimensional array of data points in the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Default Property Item( _
   ByVal series As System.Integer, _
   ByVal category As System.Integer _
) As IChartDataPoint
IChartDataPoint this[
   System.int series,
   System.int category
]; {get;}

Parameters

series
The series index of the item.
category
The category index of the item.
See Also

Reference

IChartDataPointCollection Interface
IChartDataPointCollection Members


SeriesCount Property (IChartDataPointCollection)

SeriesCount Property (IChartDataPointCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartDataPointCollection Interface : SeriesCount Property
Gets the number of series in the data point collection.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property SeriesCount As System.Integer
System.int SeriesCount {get;}
See Also

Reference

IChartDataPointCollection Interface
IChartDataPointCollection Members


IChartMember Interface

IChartMember Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartMember Interface
Interface of chart members.
Object Model
IChartMember Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IChartMember
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.IGroup
public interface IChartMember : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.IGroup
See Also

Reference

IChartMember Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IChartMember Interface Members

IChartMember Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartMember Interface

The following tables list the members exposed by IChartMember.

Public Properties
 | Name | Description
Property | Children | Gets the members collection of a chart series or category.
Property | Custom | String of custom data. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | CustomProperties | Collection of custom properties. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | DataCollectionName | Returns the name of the data collection associated with this group. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | DataElementName | Returns the name of the data element associated with this group. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | DataElementOutput | Returns the name used for this group. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | Hidden | Indicates that the group should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | IsInnerMostMember | Indicates that the current chart member has no child items.
Property | IsStatic | Indicates whether the chart member corresponds to a database field or a regular member corresponding to a value for a field.
Property | IsToggleChild | Indicates that this member is a child of a toggle item.
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | LabelValue | Gets the value representing the label for this member. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | MemberDataPointIndex | Gets the index location of the current member in the grid of data points.
Property | MemberHeadingSpan | Gets the number of innermost group instances that the current chart member spans.
Property | Name | Returns the name used for this group. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | PageBreakAtEnd | Indicates the report should page break at end of the group. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | PageBreakAtStart | Indicates the report should page break at start of the group. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | Parent | Gets the parent member of the current chart member.
Property | SortOrder | Indicates the order in which the data is sorted. Possible values are Ascending, Descending, or None.
Property | ToggleParent | Indicates that this member is a parent of a toggle item.
Top
Public Methods
 | Name | Description
Method | DataElementOutputForStatic | Returns whether a static heading should be included in data renderings.
Top
See Also

Reference

IChartMember Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IChartMember Interface Methods

IChartMember Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartMember Interface

For a list of all members of this type, see IChartMember members.

Public Methods
 | Name | Description
Method | DataElementOutputForStatic | Returns whether a static heading should be included in data renderings.
Top
See Also

Reference

IChartMember Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


DataElementOutputForStatic Method

DataElementOutputForStatic Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartMember Interface : DataElementOutputForStatic Method
A chart member represtenting the heading.
Returns whether a static heading should be included in data renderings.
Syntax
  • Visual Basic
  • C#
'Declaration

Function DataElementOutputForStatic( _
   ByVal staticHeading As IChartMember _
) As DataElementOutput
DataElementOutput DataElementOutputForStatic(
   IChartMember staticHeading
)

Parameters

staticHeading
A chart member represtenting the heading.

Return Value

The data element output for this data rendering.
See Also

Reference

IChartMember Interface
IChartMember Members


IChartMember Interface Properties

IChartMember Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartMember Interface

For a list of all members of this type, see IChartMember members.

Public Properties
 | Name | Description
Property | Children | Gets the members collection of a chart series or category.
Property | Custom | String of custom data. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | CustomProperties | Collection of custom properties. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | DataCollectionName | Returns the name of the data collection associated with this group. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | DataElementName | Returns the name of the data element associated with this group. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | DataElementOutput | Returns the name used for this group. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | Hidden | Indicates that the group should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | IsInnerMostMember | Indicates that the current chart member has no child items.
Property | IsStatic | Indicates whether the chart member corresponds to a database field or a regular member corresponding to a value for a field.
Property | IsToggleChild | Indicates that this member is a child of a toggle item.
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | LabelValue | Gets the value representing the label for this member. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | MemberDataPointIndex | Gets the index location of the current member in the grid of data points.
Property | MemberHeadingSpan | Gets the number of innermost group instances that the current chart member spans.
Property | Name | Returns the name used for this group. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | PageBreakAtEnd | Indicates the report should page break at end of the group. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | PageBreakAtStart | Indicates the report should page break at start of the group. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | Parent | Gets the parent member of the current chart member.
Property | SortOrder | Indicates the order in which the data is sorted. Possible values are Ascending, Descending, or None.
Property | ToggleParent | Indicates that this member is a parent of a toggle item.
Top
See Also

Reference

IChartMember Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


Children Property (IChartMember)

Children Property (IChartMember)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartMember Interface : Children Property
Gets the members collection of a chart series or category.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Children As IChartMemberCollection
IChartMemberCollection Children {get;}
See Also

Reference

IChartMember Interface
IChartMember Members


IsInnerMostMember Property

IsInnerMostMember Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartMember Interface : IsInnerMostMember Property
Indicates that the current chart member has no child items.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property IsInnerMostMember As System.Boolean
System.bool IsInnerMostMember {get;}
See Also

Reference

IChartMember Interface
IChartMember Members


IsStatic Property (IChartMember)

IsStatic Property (IChartMember)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartMember Interface : IsStatic Property
Indicates whether the chart member corresponds to a database field or a regular member corresponding to a value for a field.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property IsStatic As System.Boolean
System.bool IsStatic {get;}
See Also

Reference

IChartMember Interface
IChartMember Members


IsToggleChild Property

IsToggleChild Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartMember Interface : IsToggleChild Property
Indicates that this member is a child of a toggle item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property IsToggleChild As System.Boolean
System.bool IsToggleChild {get;}
See Also

Reference

IChartMember Interface
IChartMember Members


MemberDataPointIndex Property

MemberDataPointIndex Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartMember Interface : MemberDataPointIndex Property
Gets the index location of the current member in the grid of data points.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MemberDataPointIndex As System.Integer
System.int MemberDataPointIndex {get;}
See Also

Reference

IChartMember Interface
IChartMember Members


MemberHeadingSpan Property (IChartMember)

MemberHeadingSpan Property (IChartMember)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartMember Interface : MemberHeadingSpan Property
Gets the number of innermost group instances that the current chart member spans.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MemberHeadingSpan As System.Integer
System.int MemberHeadingSpan {get;}
See Also

Reference

IChartMember Interface
IChartMember Members


Parent Property (IChartMember)

Parent Property (IChartMember)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartMember Interface : Parent Property
Gets the parent member of the current chart member.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Parent As IChartMember
IChartMember Parent {get;}
See Also

Reference

IChartMember Interface
IChartMember Members


SortOrder Property

SortOrder Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartMember Interface : SortOrder Property
Indicates the order in which the data is sorted. Possible values are Ascending, Descending, or None.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property SortOrder As SortOrder
SortOrder SortOrder {get;}
See Also

Reference

IChartMember Interface
IChartMember Members


ToggleParent Property

ToggleParent Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartMember Interface : ToggleParent Property
Indicates that this member is a parent of a toggle item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ToggleParent As ITextBox
ITextBox ToggleParent {get;}
See Also

Reference

IChartMember Interface
IChartMember Members


IChartMemberCollection Interface

IChartMemberCollection Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartMemberCollection Interface
Interface for a collection of chart member objects.
Object Model
IChartMemberCollection Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IChartMemberCollection
public interface IChartMemberCollection
See Also

Reference

IChartMemberCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IChartMemberCollection Interface Members

IChartMemberCollection Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartMemberCollection Interface

The following tables list the members exposed by IChartMemberCollection.

Public Properties
 | Name | Description
Property | Count | Gets the number of elements in this collection.
Property | Item | Gets the IChartMember at the specified index.
Top
See Also

Reference

IChartMemberCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IChartMemberCollection Interface Properties

IChartMemberCollection Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IChartMemberCollection Interface

For a list of all members of this type, see IChartMemberCollection members.

Public Properties
 | Name | Description
Property | Count | Gets the number of elements in this collection.
Property | Item | Gets the IChartMember at the specified index.
Top
See Also

Reference

IChartMemberCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


Count Property (IChartMemberCollection)

Count Property (IChartMemberCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartMemberCollection Interface : Count Property
Gets the number of elements in this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Count As System.Integer
System.int Count {get;}
See Also

Reference

IChartMemberCollection Interface
IChartMemberCollection Members


Item Property (IChartMemberCollection)

Item Property (IChartMemberCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChartMemberCollection Interface : Item Property
The index of the element to get.
Gets the IChartMember at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As IChartMember
IChartMember this[
   System.int index
]; {get;}

Parameters

index
The index of the element to get.

Property Value

The IChartMember at the specified index.
See Also

Reference

IChartMemberCollection Interface
IChartMemberCollection Members


IDataLabel Interface

IDataLabel Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IDataLabel Interface
Interface for styling labels of the chart data point values.
Object Model
IDataLabel Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDataLabel
public interface IDataLabel
See Also

Reference

IDataLabel Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IDataLabel Interface Members

IDataLabel Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IDataLabel Interface

The following tables list the members exposed by IDataLabel.

Public Properties
 | Name | Description
Property | Position | Gets the position of the label.
Property | Rotation | Gets the angle of rotation of the label text.
Property | Style | Gets the text, border and background style properties for the labels.
Property | Value | Gets the label text to use for the value labels.
Property | Visible | Gets a value indicating whether the data label is displayed on the chart.
Top
See Also

Reference

IDataLabel Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IDataLabel Interface Properties

IDataLabel Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IDataLabel Interface

For a list of all members of this type, see IDataLabel members.

Public Properties
 | Name | Description
Property | Position | Gets the position of the label.
Property | Rotation | Gets the angle of rotation of the label text.
Property | Style | Gets the text, border and background style properties for the labels.
Property | Value | Gets the label text to use for the value labels.
Property | Visible | Gets a value indicating whether the data label is displayed on the chart.
Top
See Also

Reference

IDataLabel Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


Position Property (IDataLabel)

Position Property (IDataLabel)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IDataLabel Interface : Position Property
Gets the position of the label.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Position As Position
Position Position {get;}
See Also

Reference

IDataLabel Interface
IDataLabel Members


Rotation Property (IDataLabel)

Rotation Property (IDataLabel)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IDataLabel Interface : Rotation Property
Gets the angle of rotation of the label text.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Rotation As System.Nullable(Of Integer)
System.Nullable<int> Rotation {get;}
See Also

Reference

IDataLabel Interface
IDataLabel Members


Style Property (IDataLabel)

Style Property (IDataLabel)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IDataLabel Interface : Style Property
Gets the text, border and background style properties for the labels.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Style As IStyle
IStyle Style {get;}
See Also

Reference

IDataLabel Interface
IDataLabel Members


Value Property (IDataLabel)

Value Property (IDataLabel)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IDataLabel Interface : Value Property
Gets the label text to use for the value labels.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Value As System.String
System.string Value {get;}
See Also

Reference

IDataLabel Interface
IDataLabel Members


Visible Property (IDataLabel)

Visible Property (IDataLabel)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IDataLabel Interface : Visible Property
Gets a value indicating whether the data label is displayed on the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Visible As System.Boolean
System.bool Visible {get;}
See Also

Reference

IDataLabel Interface
IDataLabel Members


ILegend Interface

ILegend Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ILegend Interface
Interface for chart legend.
Object Model
ILegend Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ILegend
public interface ILegend
See Also

Reference

ILegend Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


ILegend Interface Members

ILegend Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ILegend Interface

The following tables list the members exposed by ILegend.

Public Properties
 | Name | Description
Property | InsidePlotArea | Specifies whether the legend is inside plot area.
Property | Layout | Specifies the legend layout.
Property | Position | Specifies the legend position.
Property | Style | Returns the style for the legend.
Property | UseSmartSettings | Specifies whether to use smart settings for legend.
Property | Visible | Specifies whether the legend is visible.
Top
See Also

Reference

ILegend Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


ILegend Interface Properties

ILegend Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ILegend Interface

For a list of all members of this type, see ILegend members.

Public Properties
 | Name | Description
Property | InsidePlotArea | Specifies whether the legend is inside plot area.
Property | Layout | Specifies the legend layout.
Property | Position | Specifies the legend position.
Property | Style | Returns the style for the legend.
Property | UseSmartSettings | Specifies whether to use smart settings for legend.
Property | Visible | Specifies whether the legend is visible.
Top
See Also

Reference

ILegend Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


InsidePlotArea Property (ILegend)

InsidePlotArea Property (ILegend)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > ILegend Interface : InsidePlotArea Property
Specifies whether the legend is inside plot area.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property InsidePlotArea As System.Boolean
System.bool InsidePlotArea {get;}
See Also

Reference

ILegend Interface
ILegend Members


Layout Property (ILegend)

Layout Property (ILegend)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > ILegend Interface : Layout Property
Specifies the legend layout.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Layout As LegendLayout
LegendLayout Layout {get;}
See Also

Reference

ILegend Interface
ILegend Members


Position Property (ILegend)

Position Property (ILegend)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > ILegend Interface : Position Property
Specifies the legend position.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Position As LegendPosition
LegendPosition Position {get;}
See Also

Reference

ILegend Interface
ILegend Members


Style Property (ILegend)

Style Property (ILegend)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > ILegend Interface : Style Property
Returns the style for the legend.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Style As IStyle
IStyle Style {get;}
See Also

Reference

ILegend Interface
ILegend Members


UseSmartSettings Property (ILegend)

UseSmartSettings Property (ILegend)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > ILegend Interface : UseSmartSettings Property
Specifies whether to use smart settings for legend.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property UseSmartSettings As System.Boolean
System.bool UseSmartSettings {get;}
See Also

Reference

ILegend Interface
ILegend Members


Visible Property (ILegend)

Visible Property (ILegend)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > ILegend Interface : Visible Property
Specifies whether the legend is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Visible As System.Boolean
System.bool Visible {get;}
See Also

Reference

ILegend Interface
ILegend Members


IMarker Interface

IMarker Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IMarker Interface
Defines a marker properties for displayed chart values.
Object Model
IMarker Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMarker
public interface IMarker
See Also

Reference

IMarker Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IMarker Interface Members

IMarker Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IMarker Interface

The following tables list the members exposed by IMarker.

Public Properties
 | Name | Description
Property | Size | Gets the height and width of the plotting area of the markers.
Property | Style | Gets the border and background style properties for the markers.
Property | Type | Gets the marker type for values.
Top
See Also

Reference

IMarker Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IMarker Interface Properties

IMarker Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IMarker Interface

For a list of all members of this type, see IMarker members.

Public Properties
 | Name | Description
Property | Size | Gets the height and width of the plotting area of the markers.
Property | Style | Gets the border and background style properties for the markers.
Property | Type | Gets the marker type for values.
Top
See Also

Reference

IMarker Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


Size Property (IMarker)

Size Property (IMarker)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IMarker Interface : Size Property
Gets the height and width of the plotting area of the markers.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Size As Length
Length Size {get;}
See Also

Reference

IMarker Interface
IMarker Members


Style Property (IMarker)

Style Property (IMarker)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IMarker Interface : Style Property
Gets the border and background style properties for the markers.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Style As IStyle
IStyle Style {get;}
See Also

Reference

IMarker Interface
IMarker Members


Type Property (IMarker)

Type Property (IMarker)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IMarker Interface : Type Property
Gets the marker type for values.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Type As MarkerType
MarkerType Type {get;}
See Also

Reference

IMarker Interface
IMarker Members


IPalette Interface

IPalette Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IPalette Interface
Represents chart palette.
Object Model
IPalette Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IPalette
public interface IPalette
See Also

Reference

IPalette Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IPalette Interface Members

IPalette Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IPalette Interface

The following tables list the members exposed by IPalette.

Public Properties
 | Name | Description
Property | Count | Gets number of entries in the palette.
Property | Item | Get next palette entry (color or hatch style) at the index specified
Top
See Also

Reference

IPalette Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IPalette Interface Properties

IPalette Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IPalette Interface

For a list of all members of this type, see IPalette members.

Public Properties
 | Name | Description
Property | Count | Gets number of entries in the palette.
Property | Item | Get next palette entry (color or hatch style) at the index specified
Top
See Also

Reference

IPalette Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


Count Property (IPalette)

Count Property (IPalette)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IPalette Interface : Count Property
Gets number of entries in the palette.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Count As System.Integer
System.int Count {get;}
See Also

Reference

IPalette Interface
IPalette Members


Item Property (IPalette)

Item Property (IPalette)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IPalette Interface : Item Property
The index of palette entry.
Get next palette entry (color or hatch style) at the index specified
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As PaletteEntry
PaletteEntry this[
   System.int index
]; {get;}

Parameters

index
The index of palette entry.
See Also

Reference

IPalette Interface
IPalette Members


IPlotArea Interface

IPlotArea Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IPlotArea Interface
Interface for chart plot area.
Object Model
IPlotArea Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IPlotArea
public interface IPlotArea
See Also

Reference

IPlotArea Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IPlotArea Interface Members

IPlotArea Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IPlotArea Interface

The following tables list the members exposed by IPlotArea.

Public Properties
 | Name | Description
Property | Style | The style of the plot area.
Top
See Also

Reference

IPlotArea Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IPlotArea Interface Properties

IPlotArea Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IPlotArea Interface

For a list of all members of this type, see IPlotArea members.

Public Properties
 | Name | Description
Property | Style | The style of the plot area.
Top
See Also

Reference

IPlotArea Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


Style Property (IPlotArea)

Style Property (IPlotArea)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IPlotArea Interface : Style Property
The style of the plot area.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Style As IStyle
IStyle Style {get;}
See Also

Reference

IPlotArea Interface
IPlotArea Members


IReferenceLine Interface

IReferenceLine Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IReferenceLine Interface
Interface for chart reference line.
Object Model
IReferenceLine Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IReferenceLine
public interface IReferenceLine
See Also

Reference

IReferenceLine Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IReferenceLine Interface Members

IReferenceLine Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IReferenceLine Interface

The following tables list the members exposed by IReferenceLine.

Public Properties
 | Name | Description
Property | LegendLabel | Specifies the legend label.
Property | Style | Returns the style of the reference line.
Property | Value | Specifies the value of reference line.
Property | Visible | Specifies whether the reference line is visible.
Top
See Also

Reference

IReferenceLine Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IReferenceLine Interface Properties

IReferenceLine Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IReferenceLine Interface

For a list of all members of this type, see IReferenceLine members.

Public Properties
 | Name | Description
Property | LegendLabel | Specifies the legend label.
Property | Style | Returns the style of the reference line.
Property | Value | Specifies the value of reference line.
Property | Visible | Specifies whether the reference line is visible.
Top
See Also

Reference

IReferenceLine Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


LegendLabel Property (IReferenceLine)

LegendLabel Property (IReferenceLine)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IReferenceLine Interface : LegendLabel Property
Specifies the legend label.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LegendLabel As System.String
System.string LegendLabel {get;}
See Also

Reference

IReferenceLine Interface
IReferenceLine Members


Style Property (IReferenceLine)

Style Property (IReferenceLine)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IReferenceLine Interface : Style Property
Returns the style of the reference line.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Style As IStyle
IStyle Style {get;}
See Also

Reference

IReferenceLine Interface
IReferenceLine Members


Value Property (IReferenceLine)

Value Property (IReferenceLine)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IReferenceLine Interface : Value Property
Specifies the value of reference line.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Value As System.Double
System.double Value {get;}
See Also

Reference

IReferenceLine Interface
IReferenceLine Members


Visible Property (IReferenceLine)

Visible Property (IReferenceLine)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IReferenceLine Interface : Visible Property
Specifies whether the reference line is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Visible As System.Boolean
System.bool Visible {get;}
See Also

Reference

IReferenceLine Interface
IReferenceLine Members


IThreeDProperties Interface

IThreeDProperties Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IThreeDProperties Interface
Provides 3D properties.
Object Model
IThreeDProperties Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IThreeDProperties
public interface IThreeDProperties
See Also

Reference

IThreeDProperties Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IThreeDProperties Interface Members

IThreeDProperties Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IThreeDProperties Interface

The following tables list the members exposed by IThreeDProperties.

Public Properties
 | Name | Description
Property | Clustered | Returns clustered property.
Property | DrawingStyle | Specifies the drawing style.
Property | Enabled | Specifies if 3D enabled.
Property | Inclination | Specifies the inclination.
Property | Perspective | Specifies the perspective.
Property | ProjectionMode | Specifies the projection mode.
Property | Rotation | Specifies the rotation.
Property | Shading | Specifies the shading.
Property | WallThickness | Specifies the wall thinkness.
Top
See Also

Reference

IThreeDProperties Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


IThreeDProperties Interface Properties

IThreeDProperties Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : IThreeDProperties Interface

For a list of all members of this type, see IThreeDProperties members.

Public Properties
 | Name | Description
Property | Clustered | Returns clustered property.
Property | DrawingStyle | Specifies the drawing style.
Property | Enabled | Specifies if 3D enabled.
Property | Inclination | Specifies the inclination.
Property | Perspective | Specifies the perspective.
Property | ProjectionMode | Specifies the projection mode.
Property | Rotation | Specifies the rotation.
Property | Shading | Specifies the shading.
Property | WallThickness | Specifies the wall thinkness.
Top
See Also

Reference

IThreeDProperties Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


Clustered Property (IThreeDProperties)

Clustered Property (IThreeDProperties)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IThreeDProperties Interface : Clustered Property
Returns clustered property.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Clustered As System.Boolean
System.bool Clustered {get;}
See Also

Reference

IThreeDProperties Interface
IThreeDProperties Members


DrawingStyle Property (IThreeDProperties)

DrawingStyle Property (IThreeDProperties)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IThreeDProperties Interface : DrawingStyle Property
Specifies the drawing style.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DrawingStyle As ThreeDPropertiesDrawingStyle
ThreeDPropertiesDrawingStyle DrawingStyle {get;}
See Also

Reference

IThreeDProperties Interface
IThreeDProperties Members


Enabled Property (IThreeDProperties)

Enabled Property (IThreeDProperties)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IThreeDProperties Interface : Enabled Property
Specifies if 3D enabled.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Enabled As System.Boolean
System.bool Enabled {get;}
See Also

Reference

IThreeDProperties Interface
IThreeDProperties Members


Inclination Property (IThreeDProperties)

Inclination Property (IThreeDProperties)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IThreeDProperties Interface : Inclination Property
Specifies the inclination.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Inclination As System.Nullable(Of Integer)
System.Nullable<int> Inclination {get;}
See Also

Reference

IThreeDProperties Interface
IThreeDProperties Members


Perspective Property (IThreeDProperties)

Perspective Property (IThreeDProperties)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IThreeDProperties Interface : Perspective Property
Specifies the perspective.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Perspective As System.Nullable(Of Integer)
System.Nullable<int> Perspective {get;}
See Also

Reference

IThreeDProperties Interface
IThreeDProperties Members


ProjectionMode Property (IThreeDProperties)

ProjectionMode Property (IThreeDProperties)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IThreeDProperties Interface : ProjectionMode Property
Specifies the projection mode.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ProjectionMode As ThreeDPropertiesProjectionMode
ThreeDPropertiesProjectionMode ProjectionMode {get;}
See Also

Reference

IThreeDProperties Interface
IThreeDProperties Members


Rotation Property (IThreeDProperties)

Rotation Property (IThreeDProperties)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IThreeDProperties Interface : Rotation Property
Specifies the rotation.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Rotation As System.Nullable(Of Integer)
System.Nullable<int> Rotation {get;}
See Also

Reference

IThreeDProperties Interface
IThreeDProperties Members


Shading Property (IThreeDProperties)

Shading Property (IThreeDProperties)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IThreeDProperties Interface : Shading Property
Specifies the shading.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Shading As ThreeDPropertiesShading
ThreeDPropertiesShading Shading {get;}
See Also

Reference

IThreeDProperties Interface
IThreeDProperties Members


WallThickness Property (IThreeDProperties)

WallThickness Property (IThreeDProperties)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IThreeDProperties Interface : WallThickness Property
Specifies the wall thinkness.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property WallThickness As System.Nullable(Of Integer)
System.Nullable<int> WallThickness {get;}
See Also

Reference

IThreeDProperties Interface
IThreeDProperties Members


ITitle Interface

ITitle Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ITitle Interface
Interface for chart title.
Object Model
ITitle Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITitle
public interface ITitle
See Also

Reference

ITitle Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


ITitle Interface Members

ITitle Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ITitle Interface

The following tables list the members exposed by ITitle.

Public Properties
 | Name | Description
Property | Caption | Specifies the chart title caption.
Property | Position | Specifies the chart title position.
Property | Style | Returns the chart title style.
Property | Vertical | Specifies whether the chart title is vertical.
Top
See Also

Reference

ITitle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


ITitle Interface Properties

ITitle Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace : ITitle Interface

For a list of all members of this type, see ITitle members.

Public Properties
 | Name | Description
Property | Caption | Specifies the chart title caption.
Property | Position | Specifies the chart title position.
Property | Style | Returns the chart title style.
Property | Vertical | Specifies whether the chart title is vertical.
Top
See Also

Reference

ITitle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace


Caption Property (ITitle)

Caption Property (ITitle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > ITitle Interface : Caption Property
Specifies the chart title caption.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Caption As System.String
System.string Caption {get;}
See Also

Reference

ITitle Interface
ITitle Members


Position Property (ITitle)

Position Property (ITitle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > ITitle Interface : Position Property
Specifies the chart title position.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Position As TitlePosition
TitlePosition Position {get;}
See Also

Reference

ITitle Interface
ITitle Members


Style Property (ITitle)

Style Property (ITitle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > ITitle Interface : Style Property
Returns the chart title style.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Style As IStyle
IStyle Style {get;}
See Also

Reference

ITitle Interface
ITitle Members


Vertical Property (ITitle)

Vertical Property (ITitle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > ITitle Interface : Vertical Property
Specifies whether the chart title is vertical.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Vertical As System.Boolean
System.bool Vertical {get;}
See Also

Reference

ITitle Interface
ITitle Members


GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace
Classes
 | Class | Description
Class | MapLocation | Defines the properties for map sub items location.
Class | MapSize | Defines the properties for map sub items size.
Interfaces
 | Interface | Description
Interface | IEmbeddedMapTile | Interface fot the embedded map tile.
Interface | IMap | Map rendering component
Interface | IMapColorScale | Map color scale rendering settings.
Interface | IMapColorScaleElement | MapColorScale rendering 'ticks'.
Interface | IMapColorScaleTitle | Rendering settings for MapColorScale title rendering.
Interface | IMapDistanceScale | Map distance scale rendering settings.
Interface | IMapDockableSubItem | Represents the dockable subitem of a map.
Interface | IMapGridLines | Base interface for map meridians/parallels rendering.
Interface | IMapLayer | Map layer rendering item.
Interface | IMapLegend | Map legend rendering settings.
Interface | IMapLegendItem | Map legend rendering subitem.
Interface | IMapLimits | Specifies the limits of a MapViewport element.
Interface | IMapLineElement | Represents the map spatial line.
Interface | IMapMarker | Represents the marker for map spatial elements.
Interface | IMapMarkerImage | Rendering settings for MapMarker with Image style.
Interface | IMapPointElement | Represents the map spatial point.
Interface | IMapPolygonElement | Represents the map spatial polygon.
Interface | IMapSpatialElement | Represents the map spatial element.
Interface | IMapSubItem | Base interface for all map rendering parts: viewport, titles, legends, distance scale, color scale.
Interface | IMapTile | Tile of map tile layer
Interface | IMapTileLayer | Map layer with image tiles as data.
Interface | IMapTileProvider | Provider of tiles of particular tile layer
Interface | IMapTileProviderInternal | Temprorary solution for sync tiles loading
Interface | IMapTitle | Represents the map title.
Interface | IMapVectorLayer | Map layer with spatial data rendering item.
Interface | IMapView | MapViewport main view rendering settings.
Interface | IMapViewport | Map viewport rendering item.
Structures
 | Structure | Description
Structure | MapTileKey | Tile identifier
Enumerations
 | Enumeration | Description
Enumeration | MapCoordinateSystem | The map coordinate system.
Enumeration | MapImageResizeMode | Indicates whether the content will resize to fit in the available space.
Enumeration | MapLabelBehavior | Indicates the positioning of the color scale labels.
Enumeration | MapLabelPlacement | Indicates the labels placement along the color bar.
Enumeration | MapLabelPositionType | Possible label positions for map meridians/parallels.
Enumeration | MapLegendLayout | The arrangement of labels within the legend.
Enumeration | MapLegendMarkerStyle | Specifies the style for legend rendering.
Enumeration | MapLegendTitleSeparator | Indicates what type of separator to use for the legend title.
Enumeration | MapLineLabelPlacement | Defines the label placement for the line.
Enumeration | MapMarkerLabelPlacement | Defines the label placement for the marker.
Enumeration | MapMarkerStyle | Defines the point marker.
Enumeration | MapPolygonLabelPlacement | Indicates the label placement of the polygon
Enumeration | MapPolygonLabelVisibility | Indicates the visibility mode of map polygon label.
Enumeration | MapPosition | The position of the docakable subitem.
Enumeration | MapProjection | The map projection.
Enumeration | MapTileStyle | Indicates the tiles style.
Enumeration | MapUnit | Defines the unit for both width and height.
Enumeration | MapViewCenterUnits | Specify the type of the MapViewport.MapView.
Enumeration | MapVisibilityMode | Indicates the layer visibility mode.
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


MapLocation Class

MapLocation Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapLocation Class
Defines the properties for map sub items location.
Object Model
MapLocation Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapLocation
public sealed class MapLocation
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapLocation

See Also

Reference

MapLocation Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapLocation Class Members

MapLocation Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapLocation Class

The following tables list the members exposed by MapLocation.

Public Constructors
 | Name | Description
Public Constructor | MapLocation Constructor |
Top
Public Properties
 | Name | Description
Public Property | Left | The distance of the item from the left of the containing object. The default value is 0.
Public Property | Top | The distance of the item from the top of the containing object. The default value is 0.
Public Property | Unit | Gets or sets the unit for both left and top. The default value is MapUnit.Percentage.
Top
See Also

Reference

MapLocation Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapLocation Constructor

MapLocation Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapLocation Class : MapLocation Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapLocation()
See Also

Reference

MapLocation Class
MapLocation Members


MapLocation Class Properties

MapLocation Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapLocation Class

For a list of all members of this type, see MapLocation members.

Public Properties
 | Name | Description
Public Property | Left | The distance of the item from the left of the containing object. The default value is 0.
Public Property | Top | The distance of the item from the top of the containing object. The default value is 0.
Public Property | Unit | Gets or sets the unit for both left and top. The default value is MapUnit.Percentage.
Top
See Also

Reference

MapLocation Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Left Property (MapLocation)

Left Property (MapLocation)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapLocation Class : Left Property
The distance of the item from the left of the containing object. The default value is 0.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Left As System.Double
public System.double Left {get; set;}
See Also

Reference

MapLocation Class
MapLocation Members


Top Property (MapLocation)

Top Property (MapLocation)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapLocation Class : Top Property
The distance of the item from the top of the containing object. The default value is 0.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Top As System.Double
public System.double Top {get; set;}
See Also

Reference

MapLocation Class
MapLocation Members


Unit Property (MapLocation)

Unit Property (MapLocation)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapLocation Class : Unit Property
Gets or sets the unit for both left and top. The default value is MapUnit.Percentage.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Unit As MapUnit
public MapUnit Unit {get; set;}
See Also

Reference

MapLocation Class
MapLocation Members


MapSize Class

MapSize Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapSize Class
Defines the properties for map sub items size.
Object Model
MapSize Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapSize
public sealed class MapSize
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapSize

See Also

Reference

MapSize Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapSize Class Members

MapSize Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapSize Class

The following tables list the members exposed by MapSize.

Public Constructors
 | Name | Description
Public Constructor | MapSize Constructor |
Top
Public Properties
 | Name | Description
Public Property | Height | Height of the item.
Public Property | Unit | Gets or sets the unit for both width and height. The default value is MapUnit.Percentage.
Public Property | Width | Width of the item.
Top
See Also

Reference

MapSize Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapSize Constructor

MapSize Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapSize Class : MapSize Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapSize()
See Also

Reference

MapSize Class
MapSize Members


MapSize Class Properties

MapSize Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapSize Class

For a list of all members of this type, see MapSize members.

Public Properties
 | Name | Description
Public Property | Height | Height of the item.
Public Property | Unit | Gets or sets the unit for both width and height. The default value is MapUnit.Percentage.
Public Property | Width | Width of the item.
Top
See Also

Reference

MapSize Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Height Property (MapSize)

Height Property (MapSize)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapSize Class : Height Property
Height of the item.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As System.Double
public System.double Height {get; set;}
See Also

Reference

MapSize Class
MapSize Members


Unit Property (MapSize)

Unit Property (MapSize)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapSize Class : Unit Property
Gets or sets the unit for both width and height. The default value is MapUnit.Percentage.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Unit As MapUnit
public MapUnit Unit {get; set;}
See Also

Reference

MapSize Class
MapSize Members


Width Property (MapSize)

Width Property (MapSize)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapSize Class : Width Property
Width of the item.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As System.Double
public System.double Width {get; set;}
See Also

Reference

MapSize Class
MapSize Members


MapCoordinateSystem Enumeration

MapCoordinateSystem Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapCoordinateSystem Enumeration
The map coordinate system.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapCoordinateSystem
   Inherits System.Enum
public enum MapCoordinateSystem : System.Enum
Members
Member | Description
Geographic | Geographic coordinate system (longitude and latitude).
Planar | Planar coordinate system.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapCoordinateSystem

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapImageResizeMode Enumeration

MapImageResizeMode Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapImageResizeMode Enumeration
Indicates whether the content will resize to fit in the available space.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapImageResizeMode
   Inherits System.Enum
public enum MapImageResizeMode : System.Enum
Members
Member | Description
AutoFit | Fits the available size.
None | No fitting.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapImageResizeMode

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapLabelBehavior Enumeration

MapLabelBehavior Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapLabelBehavior Enumeration
Indicates the positioning of the color scale labels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapLabelBehavior
   Inherits System.Enum
public enum MapLabelBehavior : System.Enum
Members
Member | Description
Auto | Automatically determined
ShowBorderValue | Labels are displayed at the borders between color divisions.
ShowMiddleValue | Labels are displayed in the middle of each color division.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapLabelBehavior

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapLabelPlacement Enumeration

MapLabelPlacement Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapLabelPlacement Enumeration
Indicates the labels placement along the color bar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapLabelPlacement
   Inherits System.Enum
public enum MapLabelPlacement : System.Enum
Members
Member | Description
Alternate | Odd labels are below the color bar and even ones are above.
Bottom | Labels are positioned below the color bar.
Top | Labels are positioned above the color bar.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapLabelPlacement

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapLabelPositionType Enumeration

MapLabelPositionType Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapLabelPositionType Enumeration
Possible label positions for map meridians/parallels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapLabelPositionType
   Inherits System.Enum
public enum MapLabelPositionType : System.Enum
Members
Member | Description
Center | Labels are centered.
Far | Labels are on the right for parallels and on bottom for meridians.
Near | Labels are on the left for parallels and on top for meridians.
OneQuarter | Labels are between the left and center for parallels and between top and center for meridians.
ThreeQuarters | Labels are between the center and right for parallels and between center and bottom for meridians.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapLabelPositionType

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapLegendLayout Enumeration

MapLegendLayout Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapLegendLayout Enumeration
The arrangement of labels within the legend.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapLegendLayout
   Inherits System.Enum
public enum MapLegendLayout : System.Enum
Members
Member | Description
AutoTable | Autoarrange labels to fit
Column | Arrange labels in a column
Row | Arrange labels in a row
TallTable | Arrange labels in a tall table
WideTable | Arrange labels in a wide table
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapLegendLayout

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapLegendMarkerStyle Enumeration

MapLegendMarkerStyle Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapLegendMarkerStyle Enumeration
Specifies the style for legend rendering.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapLegendMarkerStyle
   Inherits System.Enum
public enum MapLegendMarkerStyle : System.Enum
Members
Member | Description
Circle | A circle-shaped marker is used.
Diamond | A diamond-shaped marker is used.
Image | An image marker is used.
Line | A line-shaped marker is used.
None | No marker is used.
Pentagon | A pentagon-shaped marker is used.
PushPin | A pushpin-shaped marker is used.
Rectangle | A rectangle-shaped marker is used.
Square | A square-shaped marker is used.
Star | A star-shaped marker is used.
Trapezoid | A trapezoid-shaped marker is used.
Triangle | A triangle-shaped marker is used.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapLegendMarkerStyle

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapLegendTitleSeparator Enumeration

MapLegendTitleSeparator Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapLegendTitleSeparator Enumeration
Indicates what type of separator to use for the legend title.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapLegendTitleSeparator
   Inherits System.Enum
public enum MapLegendTitleSeparator : System.Enum
Members
Member | Description
DashLine | Separate with dash line.
DotLine | Separate with dot line.
DoubleLine | Separate with double line.
GradientLine | Separate with gradient line.
Line | Separate with a line.
None | No separator .
ThickGradientLine | Separate with thick gradient line.
ThickLine | Separate with a thick line.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapLegendTitleSeparator

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapLineLabelPlacement Enumeration

MapLineLabelPlacement Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapLineLabelPlacement Enumeration
Defines the label placement for the line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapLineLabelPlacement
   Inherits System.Enum
public enum MapLineLabelPlacement : System.Enum
Members
Member | Description
Above | Label placed above.
Below | Label placed below.
Center | Label placed to the center.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapLineLabelPlacement

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapMarkerLabelPlacement Enumeration

MapMarkerLabelPlacement Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapMarkerLabelPlacement Enumeration
Defines the label placement for the marker.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapMarkerLabelPlacement
   Inherits System.Enum
public enum MapMarkerLabelPlacement : System.Enum
Members
Member | Description
Bottom | Label placed to the bottom.
Center | Label placed to the center.
Left | Label placed to the left.
Right | Label placed to the right.
Top | Label placed to the top.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapMarkerLabelPlacement

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapMarkerStyle Enumeration

MapMarkerStyle Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapMarkerStyle Enumeration
Defines the point marker.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapMarkerStyle
   Inherits System.Enum
public enum MapMarkerStyle : System.Enum
Members
Member | Description
Circle | Circle marker
Diamond | Diamond marker
Image | Image marker
None | Default
Pentagon | Pentagon marker
PushPin | Push Pin marker
Rectangle | Rectangle marker
Star | Star marker
Trapezoid | Trapezoid marker
Triangle | Triangle marker
Wedge | Wedge marker
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapMarkerStyle

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapPolygonLabelPlacement Enumeration

MapPolygonLabelPlacement Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapPolygonLabelPlacement Enumeration
Indicates the label placement of the polygon
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapPolygonLabelPlacement
   Inherits System.Enum
public enum MapPolygonLabelPlacement : System.Enum
Members
Member | Description
BottomCenter | Label placed to the bottom center.
BottomLeft | Label placed to the bottom left.
BottomRight | Label placed to the bottom right.
MiddleCenter | Label placed to the middle center.
MiddleLeft | Label placed to the middle left.
MiddleRight | Label placed to the middle right.
TopCenter | Label placed to the top center.
TopLeft | Label placed to the top left.
TopRight | Label placed to the top right.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapPolygonLabelPlacement

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapPolygonLabelVisibility Enumeration

MapPolygonLabelVisibility Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapPolygonLabelVisibility Enumeration
Indicates the visibility mode of map polygon label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapPolygonLabelVisibility
   Inherits System.Enum
public enum MapPolygonLabelVisibility : System.Enum
Members
Member | Description
Auto | Defines mode when labels are conditionally visible.
Hidden | Defines mode when polygon label is unconditionally hidden.
Visible | Defines mode when polygon label is unconditionally visible.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapPolygonLabelVisibility

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapPosition Enumeration

MapPosition Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapPosition Enumeration
The position of the docakable subitem.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapPosition
   Inherits System.Enum
public enum MapPosition : System.Enum
Members
Member | Description
BottomCenter | Position title at BottomCenter
BottomLeft | Position title at BottomLeft
BottomRight | Position title at BottomRight
LeftBottom | Position title at LeftBottom
LeftCenter | Position title at LeftCenter
LeftTop | Position title at LeftTop
RightBottom | Position title at RightBottom
RightCenter | Position title at RightCenter
RightTop | Position title at RightTop
TopCenter | Position title at TopCenter
TopLeft | Position title at TopLeft
TopRight | Position title at TopRight
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapPosition

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapProjection Enumeration

MapProjection Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapProjection Enumeration
The map projection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapProjection
   Inherits System.Enum
public enum MapProjection : System.Enum
Members
Member | Description
Bonne | Bonne projection
Eckert1 | Eckert1 projection
Eckert3 | Eckert3 projection
Equirectangular | Equirectangular projection
Fahey | Fahey projection
HammerAitoff | HammerAitoff projection
Mercator | Mercator projection
Robinson | Robinson projection
Wagner3 | Wagner3 projection
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapProjection

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapTileStyle Enumeration

MapTileStyle Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapTileStyle Enumeration
Indicates the tiles style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapTileStyle
   Inherits System.Enum
public enum MapTileStyle : System.Enum
Members
Member | Description
Aerial | Tiles containing aerial imagery of the earth.
Hybrid | Tiles containing aerial imagery of borders and roads.
Road | Tiles containing roads and streets.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapTileStyle

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapUnit Enumeration

MapUnit Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapUnit Enumeration
Defines the unit for both width and height.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapUnit
   Inherits System.Enum
public enum MapUnit : System.Enum
Members
Member | Description
Centimeter | Unit is Centimeter
Inch | Unit is Inch
Millimeter | Unit is Millimeter
Percentage | Unit is percentage of the containing object’s width/height.
Pica | Unit is Pica (12 Points)
Point | Unit is Point
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapUnit

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapViewCenterUnits Enumeration

MapViewCenterUnits Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapViewCenterUnits Enumeration
Specify the type of the MapViewport.MapView.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapViewCenterUnits
   Inherits System.Enum
public enum MapViewCenterUnits : System.Enum
Members
Member | Description
Coordinates | MapViewport uses MapDataBoundView or MapElementView (coordinates are calculated based on data).
Percents | MapViewport uses MapCustomView.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapViewCenterUnits

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapVisibilityMode Enumeration

MapVisibilityMode Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapVisibilityMode Enumeration
Indicates the layer visibility mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapVisibilityMode
   Inherits System.Enum
public enum MapVisibilityMode : System.Enum
Members
Member | Description
Hidden | Layer is hidden
Visible | Layer is Shown
ZoomBased | Layer is shown within a zoom level range defined by MinimumZoomMaximumZoom of a map layer.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapVisibilityMode

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapTileKey Structure

MapTileKey Structure
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapTileKey Structure
Tile identifier
Object Model
MapTileKey Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure MapTileKey
   Inherits System.ValueType
public struct MapTileKey : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapTileKey

See Also

Reference

MapTileKey Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapTileKey Structure Members

MapTileKey Structure Members
Fields Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapTileKey Structure

The following tables list the members exposed by MapTileKey.

Public Constructors
 | Name | Description
Public Constructor | MapTileKey Constructor | Tile identifier contstructor.
Top
Public Fields
 | Name | Description
Public Field | Col | X coordinate (column in layer grid)
Public Field | LevelOfDetail | Level of detalization
Public Field | Row | Y coordinate (row in layer grid)
Top
Public Methods
 | Name | Description
Public Method | ToQuadKey | Calculates the quad key (unique identifier) for provided x, y and level of detail values.
Public Method | ToWorldPos | Gets tile's center latitude and longitude.
Top
Public Operators
public Operator Equality | Equality operator implementation.
public Operator Inequality | Inequality operator implementation.
Top
See Also

Reference

MapTileKey Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MapTileKey Constructor

MapTileKey Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapTileKey Structure : MapTileKey Constructor
X coordinate (column in layer grid)
Y coordinate (row in layer grid)
Level of detalization
Tile identifier contstructor.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal col As System.Integer, _
   ByVal row As System.Integer, _
   ByVal levelOfDetail As System.Integer _
)
public MapTileKey(
   System.int col,
   System.int row,
   System.int levelOfDetail
)

Parameters

col
X coordinate (column in layer grid)
row
Y coordinate (row in layer grid)
levelOfDetail
Level of detalization
See Also

Reference

MapTileKey Structure
MapTileKey Members


MapTileKey Structure Methods

MapTileKey Structure Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapTileKey Structure

For a list of all members of this type, see MapTileKey members.

Public Methods
 | Name | Description
Public Method | ToQuadKey | Calculates the quad key (unique identifier) for provided x, y and level of detail values.
Public Method | ToWorldPos | Gets tile's center latitude and longitude.
Top
See Also

Reference

MapTileKey Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


ToQuadKey Method

ToQuadKey Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapTileKey Structure : ToQuadKey Method
Calculates the quad key (unique identifier) for provided x, y and level of detail values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToQuadKey() As System.String
public System.string ToQuadKey()

Return Value

Quad key.
See Also

Reference

MapTileKey Structure
MapTileKey Members


ToWorldPos Method

ToWorldPos Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapTileKey Structure : ToWorldPos Method
Gets tile's center latitude and longitude.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToWorldPos() As PointF
public PointF ToWorldPos()
See Also

Reference

MapTileKey Structure
MapTileKey Members


MapTileKey Structure Fields

MapTileKey Structure Fields

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : MapTileKey Structure

For a list of all members of this type, see MapTileKey members.

Public Fields
 | Name | Description
Public Field | Col | X coordinate (column in layer grid)
Public Field | LevelOfDetail | Level of detalization
Public Field | Row | Y coordinate (row in layer grid)
Top
See Also

Reference

MapTileKey Structure
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Col Field

Col Field

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapTileKey Structure : Col Field
X coordinate (column in layer grid)
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Col As System.Integer
public readonly System.int Col
See Also

Reference

MapTileKey Structure
MapTileKey Members


LevelOfDetail Field

LevelOfDetail Field

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapTileKey Structure : LevelOfDetail Field
Level of detalization
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly LevelOfDetail As System.Integer
public readonly System.int LevelOfDetail
See Also

Reference

MapTileKey Structure
MapTileKey Members


Row Field

Row Field

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapTileKey Structure : Row Field
Y coordinate (row in layer grid)
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Row As System.Integer
public readonly System.int Row
See Also

Reference

MapTileKey Structure
MapTileKey Members


Equality Operator (MapTileKey)

Equality Operator (MapTileKey)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapTileKey Structure : Equality Operator
Left operand.
Right operand.
Equality operator implementation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator =( _
   ByVal x As MapTileKey, _
   ByVal y As MapTileKey _
) As System.Boolean
public System.bool operator ==(
   MapTileKey x,
   MapTileKey y
)

Parameters

x
Left operand.
y
Right operand.
See Also

Reference

MapTileKey Structure
MapTileKey Members


Inequality Operator (MapTileKey)

Inequality Operator (MapTileKey)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > MapTileKey Structure : Inequality Operator
Left operand.
Right operand.
Inequality operator implementation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator <>( _
   ByVal x As MapTileKey, _
   ByVal y As MapTileKey _
) As System.Boolean
public System.bool operator !=(
   MapTileKey x,
   MapTileKey y
)

Parameters

x
Left operand.
y
Right operand.
See Also

Reference

MapTileKey Structure
MapTileKey Members


IEmbeddedMapTile Interface

IEmbeddedMapTile Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IEmbeddedMapTile Interface
Interface fot the embedded map tile.
Object Model
IEmbeddedMapTile Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IEmbeddedMapTile
public interface IEmbeddedMapTile
See Also

Reference

IEmbeddedMapTile Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IEmbeddedMapTile Interface Members

IEmbeddedMapTile Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IEmbeddedMapTile Interface

The following tables list the members exposed by IEmbeddedMapTile.

Public Properties
 | Name | Description
Property | Image | Tile image.
Property | Name | Tile name.
Top
See Also

Reference

IEmbeddedMapTile Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IEmbeddedMapTile Interface Properties

IEmbeddedMapTile Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IEmbeddedMapTile Interface

For a list of all members of this type, see IEmbeddedMapTile members.

Public Properties
 | Name | Description
Property | Image | Tile image.
Property | Name | Tile name.
Top
See Also

Reference

IEmbeddedMapTile Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Image Property (IEmbeddedMapTile)

Image Property (IEmbeddedMapTile)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IEmbeddedMapTile Interface : Image Property
Tile image.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Image As System.IO.Stream
System.IO.Stream Image {get;}
See Also

Reference

IEmbeddedMapTile Interface
IEmbeddedMapTile Members


Name Property (IEmbeddedMapTile)

Name Property (IEmbeddedMapTile)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IEmbeddedMapTile Interface : Name Property
Tile name.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Name As System.String
System.string Name {get;}
See Also

Reference

IEmbeddedMapTile Interface
IEmbeddedMapTile Members


IMap Interface

IMap Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMap Interface
Map rendering component
Object Model
IMap Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMap
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStaticItem
public interface IMap : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IStaticItem
See Also

Reference

IMap Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMap Interface Members

IMap Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMap Interface

The following tables list the members exposed by IMap.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | AntiAliasing | Smoothing mode for map rendering.
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ColorScale | Color scale rendering settings.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DistanceScale | Distance scale rendering settings.
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Layers | Collection of map rendering layers.
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Legends | Collection of map rendering legends.
Property | MaximumSpatialElementCount | The maximum number of spatial elements in the map.
Property | MaximumTotalPointCount | The maximum number of points in the map.
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | ShadowIntensity | Shadow opacity in percents.
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TextAntiAliasingQuality | Text rendering hints for map rendering.
Property | TileLanguage | Bing server setting for tile layer rendering.
Property | Titles | Collection of map rendering titles.
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Viewport | Viewport rendering settings.
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IMap Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMap Interface Properties

IMap Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMap Interface

For a list of all members of this type, see IMap members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | AntiAliasing | Smoothing mode for map rendering.
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ColorScale | Color scale rendering settings.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DistanceScale | Distance scale rendering settings.
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Layers | Collection of map rendering layers.
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Legends | Collection of map rendering legends.
Property | MaximumSpatialElementCount | The maximum number of spatial elements in the map.
Property | MaximumTotalPointCount | The maximum number of points in the map.
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | ShadowIntensity | Shadow opacity in percents.
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TextAntiAliasingQuality | Text rendering hints for map rendering.
Property | TileLanguage | Bing server setting for tile layer rendering.
Property | Titles | Collection of map rendering titles.
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Viewport | Viewport rendering settings.
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IMap Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


AntiAliasing Property (IMap)

AntiAliasing Property (IMap)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : AntiAliasing Property
Smoothing mode for map rendering.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property AntiAliasing As AntiAliasing
AntiAliasing AntiAliasing {get;}
See Also

Reference

IMap Interface
IMap Members


ColorScale Property

ColorScale Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : ColorScale Property
Color scale rendering settings.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ColorScale As IMapColorScale
IMapColorScale ColorScale {get;}
See Also

Reference

IMap Interface
IMap Members


DistanceScale Property

DistanceScale Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : DistanceScale Property
Distance scale rendering settings.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DistanceScale As IMapDistanceScale
IMapDistanceScale DistanceScale {get;}
See Also

Reference

IMap Interface
IMap Members


Layers Property (IMap)

Layers Property (IMap)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : Layers Property
Collection of map rendering layers.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Layers As System.Collections.Generic.IEnumerable(Of IMapLayer)
System.Collections.Generic.IEnumerable<IMapLayer> Layers {get;}
See Also

Reference

IMap Interface
IMap Members


Legends Property (IMap)

Legends Property (IMap)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : Legends Property
Collection of map rendering legends.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Legends As System.Collections.Generic.IEnumerable(Of IMapLegend)
System.Collections.Generic.IEnumerable<IMapLegend> Legends {get;}
See Also

Reference

IMap Interface
IMap Members


MaximumSpatialElementCount Property (IMap)

MaximumSpatialElementCount Property (IMap)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : MaximumSpatialElementCount Property
The maximum number of spatial elements in the map.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MaximumSpatialElementCount As System.Nullable(Of Integer)
System.Nullable<int> MaximumSpatialElementCount {get;}
See Also

Reference

IMap Interface
IMap Members


MaximumTotalPointCount Property (IMap)

MaximumTotalPointCount Property (IMap)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : MaximumTotalPointCount Property
The maximum number of points in the map.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MaximumTotalPointCount As System.Nullable(Of Integer)
System.Nullable<int> MaximumTotalPointCount {get;}
See Also

Reference

IMap Interface
IMap Members


ShadowIntensity Property (IMap)

ShadowIntensity Property (IMap)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : ShadowIntensity Property
Shadow opacity in percents.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ShadowIntensity As System.Double
System.double ShadowIntensity {get;}
See Also

Reference

IMap Interface
IMap Members


TextAntiAliasingQuality Property (IMap)

TextAntiAliasingQuality Property (IMap)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : TextAntiAliasingQuality Property
Text rendering hints for map rendering.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TextAntiAliasingQuality As TextAntiAliasingQuality
TextAntiAliasingQuality TextAntiAliasingQuality {get;}
See Also

Reference

IMap Interface
IMap Members


TileLanguage Property (IMap)

TileLanguage Property (IMap)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : TileLanguage Property
Bing server setting for tile layer rendering.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TileLanguage As System.String
System.string TileLanguage {get;}
See Also

Reference

IMap Interface
IMap Members


Titles Property (IMap)

Titles Property (IMap)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : Titles Property
Collection of map rendering titles.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Titles As System.Collections.Generic.IEnumerable(Of IMapTitle)
System.Collections.Generic.IEnumerable<IMapTitle> Titles {get;}
See Also

Reference

IMap Interface
IMap Members


Viewport Property

Viewport Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : Viewport Property
Viewport rendering settings.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Viewport As IMapViewport
IMapViewport Viewport {get;}
See Also

Reference

IMap Interface
IMap Members


IMapColorScale Interface

IMapColorScale Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapColorScale Interface
Map color scale rendering settings.
Object Model
IMapColorScale Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapColorScale
   Inherits IMapDockableSubItem, IMapSubItem
public interface IMapColorScale : IMapDockableSubItem, IMapSubItem
See Also

Reference

IMapColorScale Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapColorScale Interface Members

IMapColorScale Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapColorScale Interface

The following tables list the members exposed by IMapColorScale.

Public Properties
 | Name | Description
Property | Action | Returns the action associated to the element if any, otherwise null. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | BottomMargin | Width of the bottom margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ColorBarBorderColor | Specifies the border color of the color bar.
Property | DockOutsideViewport | Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | Elements | Collection of internal rendering elements.
Property | Hidden | Returns the value indicating whether the item is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | HideEndLabels | Specifies whether the end labels for a MapColorScale will be hidden.
Property | LabelBehavior | Specifies how the labels display the values.
Property | LabelFormat | Specifies the label format.
Property | LabelInterval | Specifies the interval between labels.
Property | LabelPlacement | Specifies the placement of labels.
Property | LeftMargin | Width of the left margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MapLocation | Gets or sets the sub item location within the map. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MapSize | Gets or sets the sub item size within the map. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | NoDataText | Specifies the label for the MapColorScale that is to be used with colors that have no data associated with them.
Property | Position | The position of the sub item. Ignored if MapLocation is defined. The default value is MapPosition.TopCenter. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | RangeGapColor | Specifies the color to be used in a MapColorScale to fill the undefined color divisions.
Property | RightMargin | Width of the right margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ShadowIntensity | Gets the shadow intensity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | Style | Gets or sets style properties for map sub item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | TickMarkLength | Specifies the length of the tick mark.
Property | Title | Color scale title rendering settings.
Property | ToolTip | Gets the tooltip. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | TopMargin | Width of the top margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ZIndex | Drawing order of the item within the map. The default value is 0. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Top
See Also

Reference

IMapColorScale Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapColorScale Interface Properties

IMapColorScale Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapColorScale Interface

For a list of all members of this type, see IMapColorScale members.

Public Properties
 | Name | Description
Property | Action | Returns the action associated to the element if any, otherwise null. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | BottomMargin | Width of the bottom margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ColorBarBorderColor | Specifies the border color of the color bar.
Property | DockOutsideViewport | Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | Elements | Collection of internal rendering elements.
Property | Hidden | Returns the value indicating whether the item is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | HideEndLabels | Specifies whether the end labels for a MapColorScale will be hidden.
Property | LabelBehavior | Specifies how the labels display the values.
Property | LabelFormat | Specifies the label format.
Property | LabelInterval | Specifies the interval between labels.
Property | LabelPlacement | Specifies the placement of labels.
Property | LeftMargin | Width of the left margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MapLocation | Gets or sets the sub item location within the map. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MapSize | Gets or sets the sub item size within the map. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | NoDataText | Specifies the label for the MapColorScale that is to be used with colors that have no data associated with them.
Property | Position | The position of the sub item. Ignored if MapLocation is defined. The default value is MapPosition.TopCenter. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | RangeGapColor | Specifies the color to be used in a MapColorScale to fill the undefined color divisions.
Property | RightMargin | Width of the right margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ShadowIntensity | Gets the shadow intensity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | Style | Gets or sets style properties for map sub item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | TickMarkLength | Specifies the length of the tick mark.
Property | Title | Color scale title rendering settings.
Property | ToolTip | Gets the tooltip. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | TopMargin | Width of the top margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ZIndex | Drawing order of the item within the map. The default value is 0. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Top
See Also

Reference

IMapColorScale Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


ColorBarBorderColor Property (IMapColorScale)

ColorBarBorderColor Property (IMapColorScale)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScale Interface : ColorBarBorderColor Property
Specifies the border color of the color bar.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ColorBarBorderColor As ColorEx
ColorEx ColorBarBorderColor {get;}
See Also

Reference

IMapColorScale Interface
IMapColorScale Members


Elements Property (IMapColorScale)

Elements Property (IMapColorScale)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScale Interface : Elements Property
Collection of internal rendering elements.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Elements As System.Collections.Generic.IEnumerable(Of IMapColorScaleElement)
System.Collections.Generic.IEnumerable<IMapColorScaleElement> Elements {get;}
See Also

Reference

IMapColorScale Interface
IMapColorScale Members


HideEndLabels Property (IMapColorScale)

HideEndLabels Property (IMapColorScale)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScale Interface : HideEndLabels Property
Specifies whether the end labels for a MapColorScale will be hidden.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property HideEndLabels As System.Boolean
System.bool HideEndLabels {get;}
See Also

Reference

IMapColorScale Interface
IMapColorScale Members


LabelBehavior Property (IMapColorScale)

LabelBehavior Property (IMapColorScale)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScale Interface : LabelBehavior Property
Specifies how the labels display the values.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LabelBehavior As MapLabelBehavior
MapLabelBehavior LabelBehavior {get;}
See Also

Reference

IMapColorScale Interface
IMapColorScale Members


LabelFormat Property (IMapColorScale)

LabelFormat Property (IMapColorScale)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScale Interface : LabelFormat Property
Specifies the label format.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LabelFormat As System.String
System.string LabelFormat {get;}
See Also

Reference

IMapColorScale Interface
IMapColorScale Members


LabelInterval Property (IMapColorScale)

LabelInterval Property (IMapColorScale)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScale Interface : LabelInterval Property
Specifies the interval between labels.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LabelInterval As System.Integer
System.int LabelInterval {get;}
See Also

Reference

IMapColorScale Interface
IMapColorScale Members


LabelPlacement Property (IMapColorScale)

LabelPlacement Property (IMapColorScale)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScale Interface : LabelPlacement Property
Specifies the placement of labels.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LabelPlacement As MapLabelPlacement
MapLabelPlacement LabelPlacement {get;}
See Also

Reference

IMapColorScale Interface
IMapColorScale Members


NoDataText Property (IMapColorScale)

NoDataText Property (IMapColorScale)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScale Interface : NoDataText Property
Specifies the label for the MapColorScale that is to be used with colors that have no data associated with them.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property NoDataText As System.String
System.string NoDataText {get;}
See Also

Reference

IMapColorScale Interface
IMapColorScale Members


RangeGapColor Property (IMapColorScale)

RangeGapColor Property (IMapColorScale)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScale Interface : RangeGapColor Property
Specifies the color to be used in a MapColorScale to fill the undefined color divisions.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RangeGapColor As System.String
System.string RangeGapColor {get;}
See Also

Reference

IMapColorScale Interface
IMapColorScale Members


TickMarkLength Property (IMapColorScale)

TickMarkLength Property (IMapColorScale)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScale Interface : TickMarkLength Property
Specifies the length of the tick mark.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TickMarkLength As Length
Length TickMarkLength {get;}
See Also

Reference

IMapColorScale Interface
IMapColorScale Members


Title Property (IMapColorScale)

Title Property (IMapColorScale)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScale Interface : Title Property
Color scale title rendering settings.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Title As IMapColorScaleTitle
IMapColorScaleTitle Title {get;}
See Also

Reference

IMapColorScale Interface
IMapColorScale Members


IMapColorScaleElement Interface

IMapColorScaleElement Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapColorScaleElement Interface
MapColorScale rendering 'ticks'.
Object Model
IMapColorScaleElement Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapColorScaleElement
public interface IMapColorScaleElement
See Also

Reference

IMapColorScaleElement Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapColorScaleElement Interface Members

IMapColorScaleElement Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapColorScaleElement Interface

The following tables list the members exposed by IMapColorScaleElement.

Public Properties
 | Name | Description
Property | End | End value of the color range.
Property | IsScalar | Is the value descrite/contiuous.
Property | Middle | Middle value of the color range if necessary.
Property | Start | Start value of the color range.
Property | Style | Bar rendering style.
Top
See Also

Reference

IMapColorScaleElement Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapColorScaleElement Interface Properties

IMapColorScaleElement Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapColorScaleElement Interface

For a list of all members of this type, see IMapColorScaleElement members.

Public Properties
 | Name | Description
Property | End | End value of the color range.
Property | IsScalar | Is the value descrite/contiuous.
Property | Middle | Middle value of the color range if necessary.
Property | Start | Start value of the color range.
Property | Style | Bar rendering style.
Top
See Also

Reference

IMapColorScaleElement Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


End Property (IMapColorScaleElement)

End Property (IMapColorScaleElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScaleElement Interface : End Property
End value of the color range.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property End As System.Object
System.object End {get;}
See Also

Reference

IMapColorScaleElement Interface
IMapColorScaleElement Members


IsScalar Property

IsScalar Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScaleElement Interface : IsScalar Property
Is the value descrite/contiuous.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property IsScalar As System.Boolean
System.bool IsScalar {get;}
See Also

Reference

IMapColorScaleElement Interface
IMapColorScaleElement Members


Middle Property

Middle Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScaleElement Interface : Middle Property
Middle value of the color range if necessary.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Middle As System.Object
System.object Middle {get;}
See Also

Reference

IMapColorScaleElement Interface
IMapColorScaleElement Members


Start Property (IMapColorScaleElement)

Start Property (IMapColorScaleElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScaleElement Interface : Start Property
Start value of the color range.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Start As System.Object
System.object Start {get;}
See Also

Reference

IMapColorScaleElement Interface
IMapColorScaleElement Members


Style Property (IMapColorScaleElement)

Style Property (IMapColorScaleElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScaleElement Interface : Style Property
Bar rendering style.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Style As IStyle
IStyle Style {get;}
See Also

Reference

IMapColorScaleElement Interface
IMapColorScaleElement Members


IMapColorScaleTitle Interface

IMapColorScaleTitle Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapColorScaleTitle Interface
Rendering settings for MapColorScale title rendering.
Object Model
IMapColorScaleTitle Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapColorScaleTitle
public interface IMapColorScaleTitle
See Also

Reference

IMapColorScaleTitle Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapColorScaleTitle Interface Members

IMapColorScaleTitle Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapColorScaleTitle Interface

The following tables list the members exposed by IMapColorScaleTitle.

Public Properties
 | Name | Description
Property | Caption | Title text.
Property | Style | Title rendeting style.
Top
See Also

Reference

IMapColorScaleTitle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapColorScaleTitle Interface Properties

IMapColorScaleTitle Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapColorScaleTitle Interface

For a list of all members of this type, see IMapColorScaleTitle members.

Public Properties
 | Name | Description
Property | Caption | Title text.
Property | Style | Title rendeting style.
Top
See Also

Reference

IMapColorScaleTitle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Caption Property (IMapColorScaleTitle)

Caption Property (IMapColorScaleTitle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScaleTitle Interface : Caption Property
Title text.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Caption As System.String
System.string Caption {get;}
See Also

Reference

IMapColorScaleTitle Interface
IMapColorScaleTitle Members


Style Property (IMapColorScaleTitle)

Style Property (IMapColorScaleTitle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapColorScaleTitle Interface : Style Property
Title rendeting style.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Style As IStyle
IStyle Style {get;}
See Also

Reference

IMapColorScaleTitle Interface
IMapColorScaleTitle Members


IMapDistanceScale Interface

IMapDistanceScale Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapDistanceScale Interface
Map distance scale rendering settings.
Object Model
IMapDistanceScale Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapDistanceScale
   Inherits IMapDockableSubItem, IMapSubItem
public interface IMapDistanceScale : IMapDockableSubItem, IMapSubItem
See Also

Reference

IMapDistanceScale Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapDistanceScale Interface Members

IMapDistanceScale Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapDistanceScale Interface

The following tables list the members exposed by IMapDistanceScale.

Public Properties
 | Name | Description
Property | Action | Returns the action associated to the element if any, otherwise null. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | BottomMargin | Width of the bottom margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | DockOutsideViewport | Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | Hidden | Returns the value indicating whether the item is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | LeftMargin | Width of the left margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MapLocation | Gets or sets the sub item location within the map. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MapSize | Gets or sets the sub item size within the map. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | Position | The position of the sub item. Ignored if MapLocation is defined. The default value is MapPosition.TopCenter. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | RightMargin | Width of the right margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ScaleBorderColor | Gets the border color for the scale.
Property | ScaleColor | Gets the color for the scale.
Property | ScaleFactor | Twips to kilometers scale factor.
Property | ShadowIntensity | Gets the shadow intensity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | Style | Gets or sets style properties for map sub item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ToolTip | Gets the tooltip. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | TopMargin | Width of the top margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ZIndex | Drawing order of the item within the map. The default value is 0. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Top
See Also

Reference

IMapDistanceScale Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapDistanceScale Interface Properties

IMapDistanceScale Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapDistanceScale Interface

For a list of all members of this type, see IMapDistanceScale members.

Public Properties
 | Name | Description
Property | Action | Returns the action associated to the element if any, otherwise null. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | BottomMargin | Width of the bottom margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | DockOutsideViewport | Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | Hidden | Returns the value indicating whether the item is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | LeftMargin | Width of the left margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MapLocation | Gets or sets the sub item location within the map. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MapSize | Gets or sets the sub item size within the map. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | Position | The position of the sub item. Ignored if MapLocation is defined. The default value is MapPosition.TopCenter. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | RightMargin | Width of the right margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ScaleBorderColor | Gets the border color for the scale.
Property | ScaleColor | Gets the color for the scale.
Property | ScaleFactor | Twips to kilometers scale factor.
Property | ShadowIntensity | Gets the shadow intensity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | Style | Gets or sets style properties for map sub item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ToolTip | Gets the tooltip. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | TopMargin | Width of the top margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ZIndex | Drawing order of the item within the map. The default value is 0. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Top
See Also

Reference

IMapDistanceScale Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


ScaleBorderColor Property (IMapDistanceScale)

ScaleBorderColor Property (IMapDistanceScale)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapDistanceScale Interface : ScaleBorderColor Property
Gets the border color for the scale.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ScaleBorderColor As ColorEx
ColorEx ScaleBorderColor {get;}
See Also

Reference

IMapDistanceScale Interface
IMapDistanceScale Members


ScaleColor Property (IMapDistanceScale)

ScaleColor Property (IMapDistanceScale)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapDistanceScale Interface : ScaleColor Property
Gets the color for the scale.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ScaleColor As ColorEx
ColorEx ScaleColor {get;}
See Also

Reference

IMapDistanceScale Interface
IMapDistanceScale Members


ScaleFactor Property (IMapDistanceScale)

ScaleFactor Property (IMapDistanceScale)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapDistanceScale Interface : ScaleFactor Property
Twips to kilometers scale factor.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ScaleFactor As System.Double
System.double ScaleFactor {get;}
See Also

Reference

IMapDistanceScale Interface
IMapDistanceScale Members


IMapDockableSubItem Interface

IMapDockableSubItem Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapDockableSubItem Interface
Represents the dockable subitem of a map.
Object Model
IMapDockableSubItem Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapDockableSubItem
   Inherits IMapSubItem
public interface IMapDockableSubItem : IMapSubItem
See Also

Reference

IMapDockableSubItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapDockableSubItem Interface Members

IMapDockableSubItem Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapDockableSubItem Interface

The following tables list the members exposed by IMapDockableSubItem.

Public Properties
 | Name | Description
Property | Action | Returns the action associated to the element if any, otherwise null.
Property | BottomMargin | Width of the bottom margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | DockOutsideViewport | Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined.
Property | Hidden | Returns the value indicating whether the item is hidden.
Property | LeftMargin | Width of the left margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MapLocation | Gets or sets the sub item location within the map. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MapSize | Gets or sets the sub item size within the map. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | Position | The position of the sub item. Ignored if MapLocation is defined. The default value is MapPosition.TopCenter.
Property | RightMargin | Width of the right margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ShadowIntensity | Gets the shadow intensity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | Style | Gets or sets style properties for map sub item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ToolTip | Gets the tooltip.
Property | TopMargin | Width of the top margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ZIndex | Drawing order of the item within the map. The default value is 0. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Top
See Also

Reference

IMapDockableSubItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapDockableSubItem Interface Properties

IMapDockableSubItem Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapDockableSubItem Interface

For a list of all members of this type, see IMapDockableSubItem members.

Public Properties
 | Name | Description
Property | Action | Returns the action associated to the element if any, otherwise null.
Property | BottomMargin | Width of the bottom margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | DockOutsideViewport | Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined.
Property | Hidden | Returns the value indicating whether the item is hidden.
Property | LeftMargin | Width of the left margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MapLocation | Gets or sets the sub item location within the map. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MapSize | Gets or sets the sub item size within the map. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | Position | The position of the sub item. Ignored if MapLocation is defined. The default value is MapPosition.TopCenter.
Property | RightMargin | Width of the right margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ShadowIntensity | Gets the shadow intensity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | Style | Gets or sets style properties for map sub item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ToolTip | Gets the tooltip.
Property | TopMargin | Width of the top margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ZIndex | Drawing order of the item within the map. The default value is 0. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Top
See Also

Reference

IMapDockableSubItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Action Property (IMapDockableSubItem)

Action Property (IMapDockableSubItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapDockableSubItem Interface : Action Property
Returns the action associated to the element if any, otherwise null.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Action As IAction
IAction Action {get;}
See Also

Reference

IMapDockableSubItem Interface
IMapDockableSubItem Members


DockOutsideViewport Property (IMapDockableSubItem)

DockOutsideViewport Property (IMapDockableSubItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapDockableSubItem Interface : DockOutsideViewport Property
Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DockOutsideViewport As System.Boolean
System.bool DockOutsideViewport {get;}
See Also

Reference

IMapDockableSubItem Interface
IMapDockableSubItem Members


Hidden Property (IMapDockableSubItem)

Hidden Property (IMapDockableSubItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapDockableSubItem Interface : Hidden Property
Returns the value indicating whether the item is hidden.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Hidden As System.Boolean
System.bool Hidden {get;}
See Also

Reference

IMapDockableSubItem Interface
IMapDockableSubItem Members


Position Property (IMapDockableSubItem)

Position Property (IMapDockableSubItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapDockableSubItem Interface : Position Property
The position of the sub item. Ignored if MapLocation is defined. The default value is MapPosition.TopCenter.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Position As MapPosition
MapPosition Position {get;}
See Also

Reference

IMapDockableSubItem Interface
IMapDockableSubItem Members


ToolTip Property (IMapDockableSubItem)

ToolTip Property (IMapDockableSubItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapDockableSubItem Interface : ToolTip Property
Gets the tooltip.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ToolTip As System.String
System.string ToolTip {get;}
See Also

Reference

IMapDockableSubItem Interface
IMapDockableSubItem Members


IMapGridLines Interface

IMapGridLines Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapGridLines Interface
Base interface for map meridians/parallels rendering.
Object Model
IMapGridLines Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapGridLines
public interface IMapGridLines
See Also

Reference

IMapGridLines Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapGridLines Interface Members

IMapGridLines Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapGridLines Interface

The following tables list the members exposed by IMapGridLines.

Public Properties
 | Name | Description
Property | Hidden | Should we render this meridian/parallel.
Property | Interval | Intervals between meridian/parallel.
Property | LabelPosition | Specify grid labels positions.
Property | ShowLabels | Specify grid labels visibility.
Property | Style | Map grid labels style.
Top
See Also

Reference

IMapGridLines Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapGridLines Interface Properties

IMapGridLines Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapGridLines Interface

For a list of all members of this type, see IMapGridLines members.

Public Properties
 | Name | Description
Property | Hidden | Should we render this meridian/parallel.
Property | Interval | Intervals between meridian/parallel.
Property | LabelPosition | Specify grid labels positions.
Property | ShowLabels | Specify grid labels visibility.
Property | Style | Map grid labels style.
Top
See Also

Reference

IMapGridLines Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Hidden Property (IMapGridLines)

Hidden Property (IMapGridLines)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapGridLines Interface : Hidden Property
Should we render this meridian/parallel.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Hidden As System.Boolean
System.bool Hidden {get;}
See Also

Reference

IMapGridLines Interface
IMapGridLines Members


Interval Property (IMapGridLines)

Interval Property (IMapGridLines)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapGridLines Interface : Interval Property
Intervals between meridian/parallel.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Interval As System.Double
System.double Interval {get;}
See Also

Reference

IMapGridLines Interface
IMapGridLines Members


LabelPosition Property (IMapGridLines)

LabelPosition Property (IMapGridLines)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapGridLines Interface : LabelPosition Property
Specify grid labels positions.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LabelPosition As MapLabelPositionType
MapLabelPositionType LabelPosition {get;}
See Also

Reference

IMapGridLines Interface
IMapGridLines Members


ShowLabels Property (IMapGridLines)

ShowLabels Property (IMapGridLines)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapGridLines Interface : ShowLabels Property
Specify grid labels visibility.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ShowLabels As System.Boolean
System.bool ShowLabels {get;}
See Also

Reference

IMapGridLines Interface
IMapGridLines Members


Style Property (IMapGridLines)

Style Property (IMapGridLines)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapGridLines Interface : Style Property
Map grid labels style.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Style As IStyle
IStyle Style {get;}
See Also

Reference

IMapGridLines Interface
IMapGridLines Members


IMapLayer Interface

IMapLayer Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLayer Interface
Map layer rendering item.
Object Model
IMapLayer Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapLayer
public interface IMapLayer
See Also

Reference

IMapLayer Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapLayer Interface Members

IMapLayer Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLayer Interface

The following tables list the members exposed by IMapLayer.

Public Properties
 | Name | Description
Property | MaxZoom | The maximum zoom level at which the layer is visible.
Property | MinZoom | The minimum zoom level at which the layer is visible.
Property | Name | The layer name.
Property | Transparency | Map layer transparency.
Property | VisibilityMode | Map layer visibility.
Top
See Also

Reference

IMapLayer Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapLayer Interface Properties

IMapLayer Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLayer Interface

For a list of all members of this type, see IMapLayer members.

Public Properties
 | Name | Description
Property | MaxZoom | The maximum zoom level at which the layer is visible.
Property | MinZoom | The minimum zoom level at which the layer is visible.
Property | Name | The layer name.
Property | Transparency | Map layer transparency.
Property | VisibilityMode | Map layer visibility.
Top
See Also

Reference

IMapLayer Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MaxZoom Property

MaxZoom Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLayer Interface : MaxZoom Property
The maximum zoom level at which the layer is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MaxZoom As System.Double
System.double MaxZoom {get;}
See Also

Reference

IMapLayer Interface
IMapLayer Members


MinZoom Property

MinZoom Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLayer Interface : MinZoom Property
The minimum zoom level at which the layer is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MinZoom As System.Double
System.double MinZoom {get;}
See Also

Reference

IMapLayer Interface
IMapLayer Members


Name Property (IMapLayer)

Name Property (IMapLayer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLayer Interface : Name Property
The layer name.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Name As System.String
System.string Name {get;}
See Also

Reference

IMapLayer Interface
IMapLayer Members


Transparency Property (IMapLayer)

Transparency Property (IMapLayer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLayer Interface : Transparency Property
Map layer transparency.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Transparency As System.Double
System.double Transparency {get;}
See Also

Reference

IMapLayer Interface
IMapLayer Members


VisibilityMode Property (IMapLayer)

VisibilityMode Property (IMapLayer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLayer Interface : VisibilityMode Property
Map layer visibility.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property VisibilityMode As MapVisibilityMode
MapVisibilityMode VisibilityMode {get;}
See Also

Reference

IMapLayer Interface
IMapLayer Members


IMapLegend Interface

IMapLegend Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLegend Interface
Map legend rendering settings.
Object Model
IMapLegend Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapLegend
   Inherits IMapDockableSubItem, IMapSubItem
public interface IMapLegend : IMapDockableSubItem, IMapSubItem
See Also

Reference

IMapLegend Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapLegend Interface Members

IMapLegend Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLegend Interface

The following tables list the members exposed by IMapLegend.

Public Properties
 | Name | Description
Property | Action | Returns the action associated to the element if any, otherwise null. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | AutoFitText | Specifies whether text will be autosized to fit in the MapLegend area.
Property | BottomMargin | Width of the bottom margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | Caption | Specifies the caption for the title of a map legend.
Property | DockOutsideViewport | Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | EquallySpacedItems | Specifies whether legend items are equally spaced in a MapLegend.
Property | Hidden | Returns the value indicating whether the item is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | InterlacedRows | Specifies whether the legend rows in a MapLegend will use interlaced colors.
Property | InterlacedRowsColor | Specifies the color of the interlaced rows in a MapLegend.
Property | LeftMargin | Width of the left margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | LegendItems | Legend subitems collection.
Property | LegendLayout | Specifies the arrangement of labels in a MapLegend.
Property | MapLocation | Gets or sets the sub item location within the map. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MapSize | Gets or sets the sub item size within the map. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MinFontSize | Specifies the minimum font size for the auto-sizing algorithm of MapLegend text.
Property | Name | RDL name of the legend item.
Property | Position | The position of the sub item. Ignored if MapLocation is defined. The default value is MapPosition.TopCenter. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | RightMargin | Width of the right margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ShadowIntensity | Gets the shadow intensity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | Style | Gets or sets style properties for map sub item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | TextWrapThreshold | Specifies the number of characters after which to wrap the legend text in a MapLegend.
Property | TitleSeparator | Style of separator between legent title and legend body.
Property | TitleSeparatorColor | Color of separator between legent title and legend body.
Property | TitleStyle | Map caption rendering style.
Property | ToolTip | Gets the tooltip. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | TopMargin | Width of the top margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ZIndex | Drawing order of the item within the map. The default value is 0. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Top
See Also

Reference

IMapLegend Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapLegend Interface Properties

IMapLegend Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLegend Interface

For a list of all members of this type, see IMapLegend members.

Public Properties
 | Name | Description
Property | Action | Returns the action associated to the element if any, otherwise null. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | AutoFitText | Specifies whether text will be autosized to fit in the MapLegend area.
Property | BottomMargin | Width of the bottom margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | Caption | Specifies the caption for the title of a map legend.
Property | DockOutsideViewport | Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | EquallySpacedItems | Specifies whether legend items are equally spaced in a MapLegend.
Property | Hidden | Returns the value indicating whether the item is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | InterlacedRows | Specifies whether the legend rows in a MapLegend will use interlaced colors.
Property | InterlacedRowsColor | Specifies the color of the interlaced rows in a MapLegend.
Property | LeftMargin | Width of the left margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | LegendItems | Legend subitems collection.
Property | LegendLayout | Specifies the arrangement of labels in a MapLegend.
Property | MapLocation | Gets or sets the sub item location within the map. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MapSize | Gets or sets the sub item size within the map. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MinFontSize | Specifies the minimum font size for the auto-sizing algorithm of MapLegend text.
Property | Name | RDL name of the legend item.
Property | Position | The position of the sub item. Ignored if MapLocation is defined. The default value is MapPosition.TopCenter. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | RightMargin | Width of the right margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ShadowIntensity | Gets the shadow intensity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | Style | Gets or sets style properties for map sub item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | TextWrapThreshold | Specifies the number of characters after which to wrap the legend text in a MapLegend.
Property | TitleSeparator | Style of separator between legent title and legend body.
Property | TitleSeparatorColor | Color of separator between legent title and legend body.
Property | TitleStyle | Map caption rendering style.
Property | ToolTip | Gets the tooltip. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | TopMargin | Width of the top margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ZIndex | Drawing order of the item within the map. The default value is 0. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Top
See Also

Reference

IMapLegend Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


AutoFitText Property

AutoFitText Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : AutoFitText Property
Specifies whether text will be autosized to fit in the MapLegend area.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property AutoFitText As System.Boolean
System.bool AutoFitText {get;}
See Also

Reference

IMapLegend Interface
IMapLegend Members


Caption Property (IMapLegend)

Caption Property (IMapLegend)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : Caption Property
Specifies the caption for the title of a map legend.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Caption As System.String
System.string Caption {get;}
See Also

Reference

IMapLegend Interface
IMapLegend Members


EquallySpacedItems Property (IMapLegend)

EquallySpacedItems Property (IMapLegend)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : EquallySpacedItems Property
Specifies whether legend items are equally spaced in a MapLegend.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property EquallySpacedItems As System.Boolean
System.bool EquallySpacedItems {get;}
See Also

Reference

IMapLegend Interface
IMapLegend Members


InterlacedRows Property (IMapLegend)

InterlacedRows Property (IMapLegend)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : InterlacedRows Property
Specifies whether the legend rows in a MapLegend will use interlaced colors.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property InterlacedRows As System.Boolean
System.bool InterlacedRows {get;}
See Also

Reference

IMapLegend Interface
IMapLegend Members


InterlacedRowsColor Property (IMapLegend)

InterlacedRowsColor Property (IMapLegend)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : InterlacedRowsColor Property
Specifies the color of the interlaced rows in a MapLegend.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property InterlacedRowsColor As System.String
System.string InterlacedRowsColor {get;}
See Also

Reference

IMapLegend Interface
IMapLegend Members


LegendItems Property (IMapLegend)

LegendItems Property (IMapLegend)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : LegendItems Property
Legend subitems collection.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LegendItems As System.Collections.Generic.IEnumerable(Of IMapLegendItem)
System.Collections.Generic.IEnumerable<IMapLegendItem> LegendItems {get;}
See Also

Reference

IMapLegend Interface
IMapLegend Members


LegendLayout Property

LegendLayout Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : LegendLayout Property
Specifies the arrangement of labels in a MapLegend.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LegendLayout As MapLegendLayout
MapLegendLayout LegendLayout {get;}
See Also

Reference

IMapLegend Interface
IMapLegend Members


MinFontSize Property (IMapLegend)

MinFontSize Property (IMapLegend)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : MinFontSize Property
Specifies the minimum font size for the auto-sizing algorithm of MapLegend text.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MinFontSize As Length
Length MinFontSize {get;}
See Also

Reference

IMapLegend Interface
IMapLegend Members


Name Property (IMapLegend)

Name Property (IMapLegend)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : Name Property
RDL name of the legend item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Name As System.String
System.string Name {get;}
See Also

Reference

IMapLegend Interface
IMapLegend Members


TextWrapThreshold Property (IMapLegend)

TextWrapThreshold Property (IMapLegend)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : TextWrapThreshold Property
Specifies the number of characters after which to wrap the legend text in a MapLegend.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TextWrapThreshold As System.Integer
System.int TextWrapThreshold {get;}
See Also

Reference

IMapLegend Interface
IMapLegend Members


TitleSeparator Property (IMapLegend)

TitleSeparator Property (IMapLegend)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : TitleSeparator Property
Style of separator between legent title and legend body.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TitleSeparator As MapLegendTitleSeparator
MapLegendTitleSeparator TitleSeparator {get;}
See Also

Reference

IMapLegend Interface
IMapLegend Members


TitleSeparatorColor Property (IMapLegend)

TitleSeparatorColor Property (IMapLegend)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : TitleSeparatorColor Property
Color of separator between legent title and legend body.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TitleSeparatorColor As System.String
System.string TitleSeparatorColor {get;}
See Also

Reference

IMapLegend Interface
IMapLegend Members


TitleStyle Property

TitleStyle Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegend Interface : TitleStyle Property
Map caption rendering style.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TitleStyle As IStyle
IStyle TitleStyle {get;}
See Also

Reference

IMapLegend Interface
IMapLegend Members


IMapLegendItem Interface

IMapLegendItem Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLegendItem Interface
Map legend rendering subitem.
Object Model
IMapLegendItem Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapLegendItem
public interface IMapLegendItem
See Also

Reference

IMapLegendItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapLegendItem Interface Members

IMapLegendItem Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLegendItem Interface

The following tables list the members exposed by IMapLegendItem.

Public Properties
 | Name | Description
Property | Label | Map legend item text.
Property | MarkerImage | Image settings for Image MarkerStyle.
Property | MarkerStyle | Map legend rendering style.
Property | Size | Height and width of the plotting area of the point marker.
Property | Style | Map legend item text rendering style.
Top
See Also

Reference

IMapLegendItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapLegendItem Interface Properties

IMapLegendItem Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLegendItem Interface

For a list of all members of this type, see IMapLegendItem members.

Public Properties
 | Name | Description
Property | Label | Map legend item text.
Property | MarkerImage | Image settings for Image MarkerStyle.
Property | MarkerStyle | Map legend rendering style.
Property | Size | Height and width of the plotting area of the point marker.
Property | Style | Map legend item text rendering style.
Top
See Also

Reference

IMapLegendItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Label Property (IMapLegendItem)

Label Property (IMapLegendItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegendItem Interface : Label Property
Map legend item text.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Label As System.String
System.string Label {get;}
See Also

Reference

IMapLegendItem Interface
IMapLegendItem Members


MarkerImage Property (IMapLegendItem)

MarkerImage Property (IMapLegendItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegendItem Interface : MarkerImage Property
Image settings for Image MarkerStyle.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MarkerImage As IMapMarkerImage
IMapMarkerImage MarkerImage {get;}
See Also

Reference

IMapLegendItem Interface
IMapLegendItem Members


MarkerStyle Property (IMapLegendItem)

MarkerStyle Property (IMapLegendItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegendItem Interface : MarkerStyle Property
Map legend rendering style.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MarkerStyle As MapLegendMarkerStyle
MapLegendMarkerStyle MarkerStyle {get;}
See Also

Reference

IMapLegendItem Interface
IMapLegendItem Members


Size Property (IMapLegendItem)

Size Property (IMapLegendItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegendItem Interface : Size Property
Height and width of the plotting area of the point marker.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Size As Length
Length Size {get;}
See Also

Reference

IMapLegendItem Interface
IMapLegendItem Members


Style Property (IMapLegendItem)

Style Property (IMapLegendItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLegendItem Interface : Style Property
Map legend item text rendering style.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Style As IStyle
IStyle Style {get;}
See Also

Reference

IMapLegendItem Interface
IMapLegendItem Members


IMapLimits Interface

IMapLimits Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLimits Interface
Specifies the limits of a MapViewport element.
Object Model
IMapLimits Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapLimits
public interface IMapLimits
See Also

Reference

IMapLimits Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapLimits Interface Members

IMapLimits Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLimits Interface

The following tables list the members exposed by IMapLimits.

Public Properties
 | Name | Description
Property | MaximumX | Specifies the maximum X value in map coordinates for a MapViewport element.
Property | MaximumY | Specifies the maximum Y value in map coordinates for a MapViewport element.
Property | MinimumX | Specifies the minimum X value in map coordinates for a MapViewport element.
Property | MinimumY | Specifies the minimum Y value in map coordinates for a MapViewport element.
Top
See Also

Reference

IMapLimits Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapLimits Interface Properties

IMapLimits Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLimits Interface

For a list of all members of this type, see IMapLimits members.

Public Properties
 | Name | Description
Property | MaximumX | Specifies the maximum X value in map coordinates for a MapViewport element.
Property | MaximumY | Specifies the maximum Y value in map coordinates for a MapViewport element.
Property | MinimumX | Specifies the minimum X value in map coordinates for a MapViewport element.
Property | MinimumY | Specifies the minimum Y value in map coordinates for a MapViewport element.
Top
See Also

Reference

IMapLimits Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


MaximumX Property (IMapLimits)

MaximumX Property (IMapLimits)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLimits Interface : MaximumX Property
Specifies the maximum X value in map coordinates for a MapViewport element.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MaximumX As System.Double
System.double MaximumX {get;}
See Also

Reference

IMapLimits Interface
IMapLimits Members


MaximumY Property (IMapLimits)

MaximumY Property (IMapLimits)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLimits Interface : MaximumY Property
Specifies the maximum Y value in map coordinates for a MapViewport element.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MaximumY As System.Double
System.double MaximumY {get;}
See Also

Reference

IMapLimits Interface
IMapLimits Members


MinimumX Property (IMapLimits)

MinimumX Property (IMapLimits)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLimits Interface : MinimumX Property
Specifies the minimum X value in map coordinates for a MapViewport element.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MinimumX As System.Double
System.double MinimumX {get;}
See Also

Reference

IMapLimits Interface
IMapLimits Members


MinimumY Property (IMapLimits)

MinimumY Property (IMapLimits)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLimits Interface : MinimumY Property
Specifies the minimum Y value in map coordinates for a MapViewport element.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MinimumY As System.Double
System.double MinimumY {get;}
See Also

Reference

IMapLimits Interface
IMapLimits Members


IMapLineElement Interface

IMapLineElement Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLineElement Interface
Represents the map spatial line.
Object Model
IMapLineElement Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapLineElement
   Inherits IMapSpatialElement
public interface IMapLineElement : IMapSpatialElement
See Also

Reference

IMapLineElement Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapLineElement Interface Members

IMapLineElement Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLineElement Interface

The following tables list the members exposed by IMapLineElement.

Public Properties
 | Name | Description
Property | Action | Returns the action associated to the element if any, otherwise null. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | DataElementLabel | Gets the data element label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | DataElementName | Gets the name of the data element. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | DataElementOutput | Gets the data element output. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Hidden | Returns the value indicating whether the element is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Label | Specifies the label text for map line.
Property | LabelPlacement | Specifies label placement.
Property | Name | Gets the name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | OffsetX | Gets the offset of x-coordinate specifying in degrees. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | OffsetY | Gets the offset of y-coordinate specifying in degrees. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | ShadowIntensity | Gets the shadow intensity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Shape | Gets the spatial shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Style | Text rendering style.
Property | Tooltip | Line tooltip.
Property | Transparency | Gets the transparency. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Values | Gets the spatial element values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Width | Specifies line width.
Top
See Also

Reference

IMapLineElement Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapLineElement Interface Properties

IMapLineElement Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapLineElement Interface

For a list of all members of this type, see IMapLineElement members.

Public Properties
 | Name | Description
Property | Action | Returns the action associated to the element if any, otherwise null. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | DataElementLabel | Gets the data element label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | DataElementName | Gets the name of the data element. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | DataElementOutput | Gets the data element output. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Hidden | Returns the value indicating whether the element is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Label | Specifies the label text for map line.
Property | LabelPlacement | Specifies label placement.
Property | Name | Gets the name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | OffsetX | Gets the offset of x-coordinate specifying in degrees. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | OffsetY | Gets the offset of y-coordinate specifying in degrees. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | ShadowIntensity | Gets the shadow intensity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Shape | Gets the spatial shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Style | Text rendering style.
Property | Tooltip | Line tooltip.
Property | Transparency | Gets the transparency. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Values | Gets the spatial element values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Width | Specifies line width.
Top
See Also

Reference

IMapLineElement Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Label Property (IMapLineElement)

Label Property (IMapLineElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLineElement Interface : Label Property
Specifies the label text for map line.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Label As System.String
System.string Label {get;}
See Also

Reference

IMapLineElement Interface
IMapLineElement Members


LabelPlacement Property (IMapLineElement)

LabelPlacement Property (IMapLineElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLineElement Interface : LabelPlacement Property
Specifies label placement.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LabelPlacement As MapLineLabelPlacement
MapLineLabelPlacement LabelPlacement {get;}
See Also

Reference

IMapLineElement Interface
IMapLineElement Members


Style Property (IMapLineElement)

Style Property (IMapLineElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLineElement Interface : Style Property
Text rendering style.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Style As IStyle
IStyle Style {get;}
See Also

Reference

IMapLineElement Interface
IMapLineElement Members


Tooltip Property (IMapLineElement)

Tooltip Property (IMapLineElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLineElement Interface : Tooltip Property
Line tooltip.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Tooltip As System.String
System.string Tooltip {get;}
See Also

Reference

IMapLineElement Interface
IMapLineElement Members


Width Property (IMapLineElement)

Width Property (IMapLineElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapLineElement Interface : Width Property
Specifies line width.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Width As Length
Length Width {get;}
See Also

Reference

IMapLineElement Interface
IMapLineElement Members


IMapMarker Interface

IMapMarker Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapMarker Interface
Represents the marker for map spatial elements.
Object Model
IMapMarker Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapMarker
public interface IMapMarker
See Also

Reference

IMapMarker Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapMarker Interface Members

IMapMarker Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapMarker Interface

The following tables list the members exposed by IMapMarker.

Public Properties
 | Name | Description
Property | Action | Returns the action associated to the marker if any, otherwise null.
Property | Hidden | Returns the value indicating whether the marker is hidden.
Property | Label | Gets the marker label.
Property | LabelPlacement | Gets the label placement.
Property | MarkerImage | Gets the marker image.
Property | MarkerStyle | Gets the marker style.
Property | Name | Gets the marker name.
Property | OffsetX | Gets the offset of x-coordinate specifying in pixels.
Property | OffsetY | Gets the offset of y-coordinate specifying in pixels.
Property | Size | Gets the marker size.
Property | Style | Gets the style.
Property | Tooltip | Gets the tooltip.
Top
See Also

Reference

IMapMarker Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapMarker Interface Properties

IMapMarker Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapMarker Interface

For a list of all members of this type, see IMapMarker members.

Public Properties
 | Name | Description
Property | Action | Returns the action associated to the marker if any, otherwise null.
Property | Hidden | Returns the value indicating whether the marker is hidden.
Property | Label | Gets the marker label.
Property | LabelPlacement | Gets the label placement.
Property | MarkerImage | Gets the marker image.
Property | MarkerStyle | Gets the marker style.
Property | Name | Gets the marker name.
Property | OffsetX | Gets the offset of x-coordinate specifying in pixels.
Property | OffsetY | Gets the offset of y-coordinate specifying in pixels.
Property | Size | Gets the marker size.
Property | Style | Gets the style.
Property | Tooltip | Gets the tooltip.
Top
See Also

Reference

IMapMarker Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Action Property (IMapMarker)

Action Property (IMapMarker)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarker Interface : Action Property
Returns the action associated to the marker if any, otherwise null.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Action As IAction
IAction Action {get;}
See Also

Reference

IMapMarker Interface
IMapMarker Members


Hidden Property (IMapMarker)

Hidden Property (IMapMarker)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarker Interface : Hidden Property
Returns the value indicating whether the marker is hidden.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Hidden As System.Boolean
System.bool Hidden {get;}
See Also

Reference

IMapMarker Interface
IMapMarker Members


Label Property (IMapMarker)

Label Property (IMapMarker)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarker Interface : Label Property
Gets the marker label.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Label As System.String
System.string Label {get;}
See Also

Reference

IMapMarker Interface
IMapMarker Members


LabelPlacement Property (IMapMarker)

LabelPlacement Property (IMapMarker)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarker Interface : LabelPlacement Property
Gets the label placement.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LabelPlacement As MapMarkerLabelPlacement
MapMarkerLabelPlacement LabelPlacement {get;}
See Also

Reference

IMapMarker Interface
IMapMarker Members


MarkerImage Property (IMapMarker)

MarkerImage Property (IMapMarker)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarker Interface : MarkerImage Property
Gets the marker image.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MarkerImage As IMapMarkerImage
IMapMarkerImage MarkerImage {get;}
See Also

Reference

IMapMarker Interface
IMapMarker Members


MarkerStyle Property (IMapMarker)

MarkerStyle Property (IMapMarker)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarker Interface : MarkerStyle Property
Gets the marker style.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MarkerStyle As MapMarkerStyle
MapMarkerStyle MarkerStyle {get;}
See Also

Reference

IMapMarker Interface
IMapMarker Members


Name Property (IMapMarker)

Name Property (IMapMarker)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarker Interface : Name Property
Gets the marker name.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Name As System.String
System.string Name {get;}
See Also

Reference

IMapMarker Interface
IMapMarker Members


OffsetX Property (IMapMarker)

OffsetX Property (IMapMarker)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarker Interface : OffsetX Property
Gets the offset of x-coordinate specifying in pixels.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property OffsetX As System.Double
System.double OffsetX {get;}
See Also

Reference

IMapMarker Interface
IMapMarker Members


OffsetY Property (IMapMarker)

OffsetY Property (IMapMarker)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarker Interface : OffsetY Property
Gets the offset of y-coordinate specifying in pixels.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property OffsetY As System.Double
System.double OffsetY {get;}
See Also

Reference

IMapMarker Interface
IMapMarker Members


Size Property (IMapMarker)

Size Property (IMapMarker)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarker Interface : Size Property
Gets the marker size.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Size As Length
Length Size {get;}
See Also

Reference

IMapMarker Interface
IMapMarker Members


Style Property (IMapMarker)

Style Property (IMapMarker)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarker Interface : Style Property
Gets the style.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Style As IStyle
IStyle Style {get;}
See Also

Reference

IMapMarker Interface
IMapMarker Members


Tooltip Property (IMapMarker)

Tooltip Property (IMapMarker)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarker Interface : Tooltip Property
Gets the tooltip.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Tooltip As System.String
System.string Tooltip {get;}
See Also

Reference

IMapMarker Interface
IMapMarker Members


IMapMarkerImage Interface

IMapMarkerImage Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapMarkerImage Interface
Rendering settings for MapMarker with Image style.
Object Model
IMapMarkerImage Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapMarkerImage
public interface IMapMarkerImage
See Also

Reference

IMapMarkerImage Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapMarkerImage Interface Members

IMapMarkerImage Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapMarkerImage Interface

The following tables list the members exposed by IMapMarkerImage.

Public Properties
 | Name | Description
Property | Image | Gets image object to render.
Property | ResizeMode | Rendering resize mode for the image.
Top
See Also

Reference

IMapMarkerImage Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapMarkerImage Interface Properties

IMapMarkerImage Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapMarkerImage Interface

For a list of all members of this type, see IMapMarkerImage members.

Public Properties
 | Name | Description
Property | Image | Gets image object to render.
Property | ResizeMode | Rendering resize mode for the image.
Top
See Also

Reference

IMapMarkerImage Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Image Property (IMapMarkerImage)

Image Property (IMapMarkerImage)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarkerImage Interface : Image Property
Gets image object to render.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Image As Image
Image Image {get;}
See Also

Reference

IMapMarkerImage Interface
IMapMarkerImage Members


ResizeMode Property (IMapMarkerImage)

ResizeMode Property (IMapMarkerImage)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapMarkerImage Interface : ResizeMode Property
Rendering resize mode for the image.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ResizeMode As MapImageResizeMode
MapImageResizeMode ResizeMode {get;}
See Also

Reference

IMapMarkerImage Interface
IMapMarkerImage Members


IMapPointElement Interface

IMapPointElement Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapPointElement Interface
Represents the map spatial point.
Object Model
IMapPointElement Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapPointElement
   Inherits IMapSpatialElement
public interface IMapPointElement : IMapSpatialElement
See Also

Reference

IMapPointElement Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapPointElement Interface Members

IMapPointElement Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapPointElement Interface

The following tables list the members exposed by IMapPointElement.

Public Properties
 | Name | Description
Property | Action | Returns the action associated to the element if any, otherwise null. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | DataElementLabel | Gets the data element label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | DataElementName | Gets the name of the data element. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | DataElementOutput | Gets the data element output. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Hidden | Returns the value indicating whether the element is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Marker | Specifies point rendering marker.
Property | Name | Gets the name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | OffsetX | Gets the offset of x-coordinate specifying in degrees. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | OffsetY | Gets the offset of y-coordinate specifying in degrees. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | ShadowIntensity | Gets the shadow intensity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Shape | Gets the spatial shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Transparency | Gets the transparency. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Values | Gets the spatial element values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Top
See Also

Reference

IMapPointElement Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapPointElement Interface Properties

IMapPointElement Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapPointElement Interface

For a list of all members of this type, see IMapPointElement members.

Public Properties
 | Name | Description
Property | Action | Returns the action associated to the element if any, otherwise null. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | DataElementLabel | Gets the data element label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | DataElementName | Gets the name of the data element. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | DataElementOutput | Gets the data element output. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Hidden | Returns the value indicating whether the element is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Marker | Specifies point rendering marker.
Property | Name | Gets the name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | OffsetX | Gets the offset of x-coordinate specifying in degrees. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | OffsetY | Gets the offset of y-coordinate specifying in degrees. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | ShadowIntensity | Gets the shadow intensity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Shape | Gets the spatial shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Transparency | Gets the transparency. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Values | Gets the spatial element values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Top
See Also

Reference

IMapPointElement Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Marker Property (IMapPointElement)

Marker Property (IMapPointElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapPointElement Interface : Marker Property
Specifies point rendering marker.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Marker As IMapMarker
IMapMarker Marker {get;}
See Also

Reference

IMapPointElement Interface
IMapPointElement Members


IMapPolygonElement Interface

IMapPolygonElement Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapPolygonElement Interface
Represents the map spatial polygon.
Object Model
IMapPolygonElement Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapPolygonElement
   Inherits IMapSpatialElement
public interface IMapPolygonElement : IMapSpatialElement
See Also

Reference

IMapPolygonElement Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapPolygonElement Interface Members

IMapPolygonElement Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapPolygonElement Interface

The following tables list the members exposed by IMapPolygonElement.

Public Properties
 | Name | Description
Property | Action | Returns the action associated to the element if any, otherwise null. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | CenterPointOffsetX | Specifies the X offset for the center point of a polygon.
Property | CenterPointOffsetY | Specifies the Y offset for the center point of a polygon.
Property | DataElementLabel | Gets the data element label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | DataElementName | Gets the name of the data element. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | DataElementOutput | Gets the data element output. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Hidden | Returns the value indicating whether the element is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Label | Specifies the label text for map polygons.
Property | LabelPlacement | Specifies label placement.
Property | LabelVisibility | Specifies label visibility.
Property | Marker | Specifies polygon rendering marker.
Property | Name | Gets the name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | OffsetX | Gets the offset of x-coordinate specifying in degrees. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | OffsetY | Gets the offset of y-coordinate specifying in degrees. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | ScaleFactor | Twips to kilometers scale factor.
Property | ShadowIntensity | Gets the shadow intensity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Shape | Gets the spatial shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Style | Text rendering style.
Property | Tooltip | Polygon tooltip.
Property | Transparency | Gets the transparency. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Values | Gets the spatial element values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Top
See Also

Reference

IMapPolygonElement Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapPolygonElement Interface Properties

IMapPolygonElement Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapPolygonElement Interface

For a list of all members of this type, see IMapPolygonElement members.

Public Properties
 | Name | Description
Property | Action | Returns the action associated to the element if any, otherwise null. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | CenterPointOffsetX | Specifies the X offset for the center point of a polygon.
Property | CenterPointOffsetY | Specifies the Y offset for the center point of a polygon.
Property | DataElementLabel | Gets the data element label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | DataElementName | Gets the name of the data element. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | DataElementOutput | Gets the data element output. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Hidden | Returns the value indicating whether the element is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Label | Specifies the label text for map polygons.
Property | LabelPlacement | Specifies label placement.
Property | LabelVisibility | Specifies label visibility.
Property | Marker | Specifies polygon rendering marker.
Property | Name | Gets the name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | OffsetX | Gets the offset of x-coordinate specifying in degrees. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | OffsetY | Gets the offset of y-coordinate specifying in degrees. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | ScaleFactor | Twips to kilometers scale factor.
Property | ShadowIntensity | Gets the shadow intensity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Shape | Gets the spatial shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Style | Text rendering style.
Property | Tooltip | Polygon tooltip.
Property | Transparency | Gets the transparency. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Property | Values | Gets the spatial element values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSpatialElement)
Top
See Also

Reference

IMapPolygonElement Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


CenterPointOffsetX Property (IMapPolygonElement)

CenterPointOffsetX Property (IMapPolygonElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapPolygonElement Interface : CenterPointOffsetX Property
Specifies the X offset for the center point of a polygon.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CenterPointOffsetX As System.Double
System.double CenterPointOffsetX {get;}
See Also

Reference

IMapPolygonElement Interface
IMapPolygonElement Members


CenterPointOffsetY Property (IMapPolygonElement)

CenterPointOffsetY Property (IMapPolygonElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapPolygonElement Interface : CenterPointOffsetY Property
Specifies the Y offset for the center point of a polygon.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CenterPointOffsetY As System.Double
System.double CenterPointOffsetY {get;}
See Also

Reference

IMapPolygonElement Interface
IMapPolygonElement Members


Label Property (IMapPolygonElement)

Label Property (IMapPolygonElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapPolygonElement Interface : Label Property
Specifies the label text for map polygons.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Label As System.String
System.string Label {get;}
See Also

Reference

IMapPolygonElement Interface
IMapPolygonElement Members


LabelPlacement Property (IMapPolygonElement)

LabelPlacement Property (IMapPolygonElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapPolygonElement Interface : LabelPlacement Property
Specifies label placement.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LabelPlacement As MapPolygonLabelPlacement
MapPolygonLabelPlacement LabelPlacement {get;}
See Also

Reference

IMapPolygonElement Interface
IMapPolygonElement Members


LabelVisibility Property

LabelVisibility Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapPolygonElement Interface : LabelVisibility Property
Specifies label visibility.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LabelVisibility As MapPolygonLabelVisibility
MapPolygonLabelVisibility LabelVisibility {get;}
See Also

Reference

IMapPolygonElement Interface
IMapPolygonElement Members


Marker Property (IMapPolygonElement)

Marker Property (IMapPolygonElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapPolygonElement Interface : Marker Property
Specifies polygon rendering marker.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Marker As IMapMarker
IMapMarker Marker {get;}
See Also

Reference

IMapPolygonElement Interface
IMapPolygonElement Members


ScaleFactor Property (IMapPolygonElement)

ScaleFactor Property (IMapPolygonElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapPolygonElement Interface : ScaleFactor Property
Twips to kilometers scale factor.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ScaleFactor As System.Double
System.double ScaleFactor {get;}
See Also

Reference

IMapPolygonElement Interface
IMapPolygonElement Members


Style Property (IMapPolygonElement)

Style Property (IMapPolygonElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapPolygonElement Interface : Style Property
Text rendering style.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Style As IStyle
IStyle Style {get;}
See Also

Reference

IMapPolygonElement Interface
IMapPolygonElement Members


Tooltip Property (IMapPolygonElement)

Tooltip Property (IMapPolygonElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapPolygonElement Interface : Tooltip Property
Polygon tooltip.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Tooltip As System.String
System.string Tooltip {get;}
See Also

Reference

IMapPolygonElement Interface
IMapPolygonElement Members


IMapSpatialElement Interface

IMapSpatialElement Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapSpatialElement Interface
Represents the map spatial element.
Object Model
IMapSpatialElement Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapSpatialElement
public interface IMapSpatialElement
See Also

Reference

IMapSpatialElement Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapSpatialElement Interface Members

IMapSpatialElement Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapSpatialElement Interface

The following tables list the members exposed by IMapSpatialElement.

Public Properties
 | Name | Description
Property | Action | Returns the action associated to the element if any, otherwise null.
Property | DataElementLabel | Gets the data element label.
Property | DataElementName | Gets the name of the data element.
Property | DataElementOutput | Gets the data element output.
Property | Hidden | Returns the value indicating whether the element is hidden.
Property | Name | Gets the name.
Property | OffsetX | Gets the offset of x-coordinate specifying in degrees.
Property | OffsetY | Gets the offset of y-coordinate specifying in degrees.
Property | ShadowIntensity | Gets the shadow intensity.
Property | Shape | Gets the spatial shape.
Property | Transparency | Gets the transparency.
Property | Values | Gets the spatial element values.
Top
See Also

Reference

IMapSpatialElement Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapSpatialElement Interface Properties

IMapSpatialElement Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapSpatialElement Interface

For a list of all members of this type, see IMapSpatialElement members.

Public Properties
 | Name | Description
Property | Action | Returns the action associated to the element if any, otherwise null.
Property | DataElementLabel | Gets the data element label.
Property | DataElementName | Gets the name of the data element.
Property | DataElementOutput | Gets the data element output.
Property | Hidden | Returns the value indicating whether the element is hidden.
Property | Name | Gets the name.
Property | OffsetX | Gets the offset of x-coordinate specifying in degrees.
Property | OffsetY | Gets the offset of y-coordinate specifying in degrees.
Property | ShadowIntensity | Gets the shadow intensity.
Property | Shape | Gets the spatial shape.
Property | Transparency | Gets the transparency.
Property | Values | Gets the spatial element values.
Top
See Also

Reference

IMapSpatialElement Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Action Property (IMapSpatialElement)

Action Property (IMapSpatialElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSpatialElement Interface : Action Property
Returns the action associated to the element if any, otherwise null.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Action As IAction
IAction Action {get;}
See Also

Reference

IMapSpatialElement Interface
IMapSpatialElement Members


DataElementLabel Property (IMapSpatialElement)

DataElementLabel Property (IMapSpatialElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSpatialElement Interface : DataElementLabel Property
Gets the data element label.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataElementLabel As System.String
System.string DataElementLabel {get;}
See Also

Reference

IMapSpatialElement Interface
IMapSpatialElement Members


DataElementName Property (IMapSpatialElement)

DataElementName Property (IMapSpatialElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSpatialElement Interface : DataElementName Property
Gets the name of the data element.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataElementName As System.String
System.string DataElementName {get;}
See Also

Reference

IMapSpatialElement Interface
IMapSpatialElement Members


DataElementOutput Property (IMapSpatialElement)

DataElementOutput Property (IMapSpatialElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSpatialElement Interface : DataElementOutput Property
Gets the data element output.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataElementOutput As DataElementOutput
DataElementOutput DataElementOutput {get;}
See Also

Reference

IMapSpatialElement Interface
IMapSpatialElement Members


Hidden Property (IMapSpatialElement)

Hidden Property (IMapSpatialElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSpatialElement Interface : Hidden Property
Returns the value indicating whether the element is hidden.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Hidden As System.Boolean
System.bool Hidden {get;}
See Also

Reference

IMapSpatialElement Interface
IMapSpatialElement Members


Name Property (IMapSpatialElement)

Name Property (IMapSpatialElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSpatialElement Interface : Name Property
Gets the name.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Name As System.String
System.string Name {get;}
See Also

Reference

IMapSpatialElement Interface
IMapSpatialElement Members


OffsetX Property (IMapSpatialElement)

OffsetX Property (IMapSpatialElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSpatialElement Interface : OffsetX Property
Gets the offset of x-coordinate specifying in degrees.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property OffsetX As System.Double
System.double OffsetX {get;}
See Also

Reference

IMapSpatialElement Interface
IMapSpatialElement Members


OffsetY Property (IMapSpatialElement)

OffsetY Property (IMapSpatialElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSpatialElement Interface : OffsetY Property
Gets the offset of y-coordinate specifying in degrees.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property OffsetY As System.Double
System.double OffsetY {get;}
See Also

Reference

IMapSpatialElement Interface
IMapSpatialElement Members


ShadowIntensity Property (IMapSpatialElement)

ShadowIntensity Property (IMapSpatialElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSpatialElement Interface : ShadowIntensity Property
Gets the shadow intensity.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ShadowIntensity As System.Double
System.double ShadowIntensity {get;}
See Also

Reference

IMapSpatialElement Interface
IMapSpatialElement Members


Shape Property (IMapSpatialElement)

Shape Property (IMapSpatialElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSpatialElement Interface : Shape Property
Gets the spatial shape.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Shape As GeoShape
GeoShape Shape {get;}
See Also

Reference

IMapSpatialElement Interface
IMapSpatialElement Members


Transparency Property (IMapSpatialElement)

Transparency Property (IMapSpatialElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSpatialElement Interface : Transparency Property
Gets the transparency.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Transparency As System.Double
System.double Transparency {get;}
See Also

Reference

IMapSpatialElement Interface
IMapSpatialElement Members


Values Property (IMapSpatialElement)

Values Property (IMapSpatialElement)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSpatialElement Interface : Values Property
Gets the spatial element values.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Values As System.Collections.Generic.IEnumerable(Of KeyValuePair(Of String,Object))
System.Collections.Generic.IEnumerable<KeyValuePair<string,object>> Values {get;}
See Also

Reference

IMapSpatialElement Interface
IMapSpatialElement Members


IMapSubItem Interface

IMapSubItem Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapSubItem Interface
Base interface for all map rendering parts: viewport, titles, legends, distance scale, color scale.
Object Model
IMapSubItem Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapSubItem
public interface IMapSubItem
See Also

Reference

IMapSubItem Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapSubItem Interface Members

IMapSubItem Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapSubItem Interface

The following tables list the members exposed by IMapSubItem.

Public Properties
 | Name | Description
Property | BottomMargin | Width of the bottom margin. The default value is 0in.
Property | LeftMargin | Width of the left margin. The default value is 0in.
Property | MapLocation | Gets or sets the sub item location within the map.
Property | MapSize | Gets or sets the sub item size within the map.
Property | RightMargin | Width of the right margin. The default value is 0in.
Property | ShadowIntensity | Gets the shadow intensity.
Property | Style | Gets or sets style properties for map sub item.
Property | TopMargin | Width of the top margin. The default value is 0in.
Property | ZIndex | Drawing order of the item within the map. The default value is 0.
Top
See Also

Reference

IMapSubItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapSubItem Interface Properties

IMapSubItem Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapSubItem Interface

For a list of all members of this type, see IMapSubItem members.

Public Properties
 | Name | Description
Property | BottomMargin | Width of the bottom margin. The default value is 0in.
Property | LeftMargin | Width of the left margin. The default value is 0in.
Property | MapLocation | Gets or sets the sub item location within the map.
Property | MapSize | Gets or sets the sub item size within the map.
Property | RightMargin | Width of the right margin. The default value is 0in.
Property | ShadowIntensity | Gets the shadow intensity.
Property | Style | Gets or sets style properties for map sub item.
Property | TopMargin | Width of the top margin. The default value is 0in.
Property | ZIndex | Drawing order of the item within the map. The default value is 0.
Top
See Also

Reference

IMapSubItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


BottomMargin Property (IMapSubItem)

BottomMargin Property (IMapSubItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSubItem Interface : BottomMargin Property
Width of the bottom margin. The default value is 0in.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property BottomMargin As Length
Length BottomMargin {get;}
See Also

Reference

IMapSubItem Interface
IMapSubItem Members


LeftMargin Property (IMapSubItem)

LeftMargin Property (IMapSubItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSubItem Interface : LeftMargin Property
Width of the left margin. The default value is 0in.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LeftMargin As Length
Length LeftMargin {get;}
See Also

Reference

IMapSubItem Interface
IMapSubItem Members


MapLocation Property (IMapSubItem)

MapLocation Property (IMapSubItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSubItem Interface : MapLocation Property
Gets or sets the sub item location within the map.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MapLocation As MapLocation
MapLocation MapLocation {get;}
See Also

Reference

IMapSubItem Interface
IMapSubItem Members


MapSize Property (IMapSubItem)

MapSize Property (IMapSubItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSubItem Interface : MapSize Property
Gets or sets the sub item size within the map.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MapSize As MapSize
MapSize MapSize {get;}
See Also

Reference

IMapSubItem Interface
IMapSubItem Members


RightMargin Property (IMapSubItem)

RightMargin Property (IMapSubItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSubItem Interface : RightMargin Property
Width of the right margin. The default value is 0in.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RightMargin As Length
Length RightMargin {get;}
See Also

Reference

IMapSubItem Interface
IMapSubItem Members


ShadowIntensity Property (IMapSubItem)

ShadowIntensity Property (IMapSubItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSubItem Interface : ShadowIntensity Property
Gets the shadow intensity.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ShadowIntensity As System.Double
System.double ShadowIntensity {get;}
See Also

Reference

IMapSubItem Interface
IMapSubItem Members


Style Property (IMapSubItem)

Style Property (IMapSubItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSubItem Interface : Style Property
Gets or sets style properties for map sub item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Style As IStyle
IStyle Style {get;}
See Also

Reference

IMapSubItem Interface
IMapSubItem Members


TopMargin Property (IMapSubItem)

TopMargin Property (IMapSubItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSubItem Interface : TopMargin Property
Width of the top margin. The default value is 0in.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TopMargin As Length
Length TopMargin {get;}
See Also

Reference

IMapSubItem Interface
IMapSubItem Members


ZIndex Property (IMapSubItem)

ZIndex Property (IMapSubItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapSubItem Interface : ZIndex Property
Drawing order of the item within the map. The default value is 0.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ZIndex As System.Integer
System.int ZIndex {get;}
See Also

Reference

IMapSubItem Interface
IMapSubItem Members


IMapTile Interface

IMapTile Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTile Interface
Tile of map tile layer
Object Model
IMapTile Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapTile
public interface IMapTile
See Also

Reference

IMapTile Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapTile Interface Members

IMapTile Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTile Interface

The following tables list the members exposed by IMapTile.

Public Properties
 | Name | Description
Property | Id | Unique tile identifier within the layer
Property | Image | Tile image
Top
See Also

Reference

IMapTile Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapTile Interface Properties

IMapTile Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTile Interface

For a list of all members of this type, see IMapTile members.

Public Properties
 | Name | Description
Property | Id | Unique tile identifier within the layer
Property | Image | Tile image
Top
See Also

Reference

IMapTile Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Id Property (IMapTile)

Id Property (IMapTile)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTile Interface : Id Property
Unique tile identifier within the layer
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Id As MapTileKey
MapTileKey Id {get;}
See Also

Reference

IMapTile Interface
IMapTile Members


Image Property (IMapTile)

Image Property (IMapTile)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTile Interface : Image Property
Tile image
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Image As System.IO.Stream
System.IO.Stream Image {get;}
See Also

Reference

IMapTile Interface
IMapTile Members


IMapTileLayer Interface

IMapTileLayer Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTileLayer Interface
Map layer with image tiles as data.
Object Model
IMapTileLayer Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapTileLayer
   Inherits IMapLayer
public interface IMapTileLayer : IMapLayer
See Also

Reference

IMapTileLayer Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapTileLayer Interface Members

IMapTileLayer Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTileLayer Interface

The following tables list the members exposed by IMapTileLayer.

Public Properties
 | Name | Description
Property | EmbeddedTiles | Collection of embedded tiles.
Property | MaxZoom | The maximum zoom level at which the layer is visible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapLayer)
Property | MinZoom | The minimum zoom level at which the layer is visible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapLayer)
Property | Name | The layer name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapLayer)
Property | Provider | The name of tile provider. 'Bing' by default.
Property | TileLanguage | The language of the tile.
Property | TileStyle | The tiles style That evaluates to one of MapTileStyle.
Property | Transparency | Map layer transparency. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapLayer)
Property | UseSecureConnection | Value indicating whether secure connection should be used for tiles retrieveing.
Property | VisibilityMode | Map layer visibility. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapLayer)
Top
See Also

Reference

IMapTileLayer Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapTileLayer Interface Properties

IMapTileLayer Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTileLayer Interface

For a list of all members of this type, see IMapTileLayer members.

Public Properties
 | Name | Description
Property | EmbeddedTiles | Collection of embedded tiles.
Property | MaxZoom | The maximum zoom level at which the layer is visible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapLayer)
Property | MinZoom | The minimum zoom level at which the layer is visible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapLayer)
Property | Name | The layer name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapLayer)
Property | Provider | The name of tile provider. 'Bing' by default.
Property | TileLanguage | The language of the tile.
Property | TileStyle | The tiles style That evaluates to one of MapTileStyle.
Property | Transparency | Map layer transparency. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapLayer)
Property | UseSecureConnection | Value indicating whether secure connection should be used for tiles retrieveing.
Property | VisibilityMode | Map layer visibility. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapLayer)
Top
See Also

Reference

IMapTileLayer Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


EmbeddedTiles Property

EmbeddedTiles Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTileLayer Interface : EmbeddedTiles Property
Collection of embedded tiles.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property EmbeddedTiles As System.Collections.Generic.IEnumerable(Of IEmbeddedMapTile)
System.Collections.Generic.IEnumerable<IEmbeddedMapTile> EmbeddedTiles {get;}
See Also

Reference

IMapTileLayer Interface
IMapTileLayer Members


Provider Property (IMapTileLayer)

Provider Property (IMapTileLayer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTileLayer Interface : Provider Property
The name of tile provider. 'Bing' by default.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Provider As System.String
System.string Provider {get;}
See Also

Reference

IMapTileLayer Interface
IMapTileLayer Members


TileLanguage Property (IMapTileLayer)

TileLanguage Property (IMapTileLayer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTileLayer Interface : TileLanguage Property
The language of the tile.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TileLanguage As System.String
System.string TileLanguage {get;}
See Also

Reference

IMapTileLayer Interface
IMapTileLayer Members


TileStyle Property (IMapTileLayer)

TileStyle Property (IMapTileLayer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTileLayer Interface : TileStyle Property
The tiles style That evaluates to one of MapTileStyle.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TileStyle As MapTileStyle
MapTileStyle TileStyle {get;}
See Also

Reference

IMapTileLayer Interface
IMapTileLayer Members


UseSecureConnection Property (IMapTileLayer)

UseSecureConnection Property (IMapTileLayer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTileLayer Interface : UseSecureConnection Property
Value indicating whether secure connection should be used for tiles retrieveing.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property UseSecureConnection As System.Boolean
System.bool UseSecureConnection {get;}
See Also

Reference

IMapTileLayer Interface
IMapTileLayer Members


IMapTileProvider Interface

IMapTileProvider Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTileProvider Interface
Provider of tiles of particular tile layer
Object Model
IMapTileProvider Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapTileProvider
public interface IMapTileProvider
See Also

Reference

IMapTileProvider Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapTileProvider Interface Members

IMapTileProvider Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTileProvider Interface

The following tables list the members exposed by IMapTileProvider.

Public Properties
 | Name | Description
Property | Copyright | Copyright displayed for tile provider
Property | Settings | Tile provider settings, like ApiKey, Language, Style and etc.
Top
Public Methods
 | Name | Description
Method | GetTile | Get instance of tile by specified coordinates and level of detalization
Top
See Also

Reference

IMapTileProvider Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapTileProvider Interface Methods

IMapTileProvider Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTileProvider Interface

For a list of all members of this type, see IMapTileProvider members.

Public Methods
 | Name | Description
Method | GetTile | Get instance of tile by specified coordinates and level of detalization
Top
See Also

Reference

IMapTileProvider Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


GetTile Method (IMapTileProvider)

GetTile Method (IMapTileProvider)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTileProvider Interface : GetTile Method
Tile identifier
Success result handler.
Error handler.
Get instance of tile by specified coordinates and level of detalization
Syntax
  • Visual Basic
  • C#
'Declaration

Sub GetTile( _
   ByVal key As MapTileKey, _
   ByVal success As System.Action(Of IMapTile), _
   ByVal error As System.Action(Of Exception) _
)
void GetTile(
   MapTileKey key,
   System.Action<IMapTile> success,
   System.Action<Exception> error
)

Parameters

key
Tile identifier
success
Success result handler.
error
Error handler.
See Also

Reference

IMapTileProvider Interface
IMapTileProvider Members


IMapTileProvider Interface Properties

IMapTileProvider Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTileProvider Interface

For a list of all members of this type, see IMapTileProvider members.

Public Properties
 | Name | Description
Property | Copyright | Copyright displayed for tile provider
Property | Settings | Tile provider settings, like ApiKey, Language, Style and etc.
Top
See Also

Reference

IMapTileProvider Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Copyright Property

Copyright Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTileProvider Interface : Copyright Property
Copyright displayed for tile provider
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Copyright As System.String
System.string Copyright {get;}
See Also

Reference

IMapTileProvider Interface
IMapTileProvider Members


Settings Property (IMapTileProvider)

Settings Property (IMapTileProvider)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTileProvider Interface : Settings Property
Tile provider settings, like ApiKey, Language, Style and etc.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Settings As System.Collections.Specialized.NameValueCollection
System.Collections.Specialized.NameValueCollection Settings {get;}
See Also

Reference

IMapTileProvider Interface
IMapTileProvider Members


IMapTileProviderInternal Interface

IMapTileProviderInternal Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTileProviderInternal Interface
Temprorary solution for sync tiles loading
Object Model
IMapTileProviderInternal Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapTileProviderInternal
public interface IMapTileProviderInternal
See Also

Reference

IMapTileProviderInternal Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapTileProviderInternal Interface Members

IMapTileProviderInternal Interface Members
Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTileProviderInternal Interface

The following tables list the members exposed by IMapTileProviderInternal.

Public Methods
 | Name | Description
Method | GetTile | Get instance of tile by specified coordinates and level of detalization
Top
See Also

Reference

IMapTileProviderInternal Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapTileProviderInternal Interface Methods

IMapTileProviderInternal Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTileProviderInternal Interface

For a list of all members of this type, see IMapTileProviderInternal members.

Public Methods
 | Name | Description
Method | GetTile | Get instance of tile by specified coordinates and level of detalization
Top
See Also

Reference

IMapTileProviderInternal Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


GetTile Method (IMapTileProviderInternal)

GetTile Method (IMapTileProviderInternal)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTileProviderInternal Interface : GetTile Method
Get instance of tile by specified coordinates and level of detalization
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetTile( _
   ByVal key As MapTileKey _
) As IMapTile
IMapTile GetTile(
   MapTileKey key
)

Parameters

key
See Also

Reference

IMapTileProviderInternal Interface
IMapTileProviderInternal Members


IMapTitle Interface

IMapTitle Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTitle Interface
Represents the map title.
Object Model
IMapTitle Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapTitle
   Inherits IMapDockableSubItem, IMapSubItem
public interface IMapTitle : IMapDockableSubItem, IMapSubItem
See Also

Reference

IMapTitle Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapTitle Interface Members

IMapTitle Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTitle Interface

The following tables list the members exposed by IMapTitle.

Public Properties
 | Name | Description
Property | Action | Returns the action associated to the element if any, otherwise null. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | Angle | Angle of rotation for the title.
Property | BottomMargin | Width of the bottom margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | DockOutsideViewport | Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | Hidden | Returns the value indicating whether the item is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | LeftMargin | Width of the left margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MapLocation | Gets or sets the sub item location within the map. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MapSize | Gets or sets the sub item size within the map. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | Name | Gets the title name.
Property | Position | The position of the sub item. Ignored if MapLocation is defined. The default value is MapPosition.TopCenter. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | RightMargin | Width of the right margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ShadowIntensity | Gets the shadow intensity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | Style | Gets or sets style properties for map sub item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | Text | Text of the title.
Property | TextShadowOffset | Size of the text shadow. The default value is 0.
Property | ToolTip | Gets the tooltip. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | TopMargin | Width of the top margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ZIndex | Drawing order of the item within the map. The default value is 0. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Top
See Also

Reference

IMapTitle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapTitle Interface Properties

IMapTitle Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapTitle Interface

For a list of all members of this type, see IMapTitle members.

Public Properties
 | Name | Description
Property | Action | Returns the action associated to the element if any, otherwise null. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | Angle | Angle of rotation for the title.
Property | BottomMargin | Width of the bottom margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | DockOutsideViewport | Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | Hidden | Returns the value indicating whether the item is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | LeftMargin | Width of the left margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MapLocation | Gets or sets the sub item location within the map. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MapSize | Gets or sets the sub item size within the map. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | Name | Gets the title name.
Property | Position | The position of the sub item. Ignored if MapLocation is defined. The default value is MapPosition.TopCenter. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | RightMargin | Width of the right margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ShadowIntensity | Gets the shadow intensity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | Style | Gets or sets style properties for map sub item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | Text | Text of the title.
Property | TextShadowOffset | Size of the text shadow. The default value is 0.
Property | ToolTip | Gets the tooltip. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapDockableSubItem)
Property | TopMargin | Width of the top margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ZIndex | Drawing order of the item within the map. The default value is 0. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Top
See Also

Reference

IMapTitle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


Angle Property (IMapTitle)

Angle Property (IMapTitle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTitle Interface : Angle Property
Angle of rotation for the title.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Angle As System.Double
System.double Angle {get;}
See Also

Reference

IMapTitle Interface
IMapTitle Members


Name Property (IMapTitle)

Name Property (IMapTitle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTitle Interface : Name Property
Gets the title name.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Name As System.String
System.string Name {get;}
See Also

Reference

IMapTitle Interface
IMapTitle Members


Text Property (IMapTitle)

Text Property (IMapTitle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTitle Interface : Text Property
Text of the title.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Text As System.String
System.string Text {get;}
See Also

Reference

IMapTitle Interface
IMapTitle Members


TextShadowOffset Property (IMapTitle)

TextShadowOffset Property (IMapTitle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapTitle Interface : TextShadowOffset Property
Size of the text shadow. The default value is 0.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TextShadowOffset As Length
Length TextShadowOffset {get;}
See Also

Reference

IMapTitle Interface
IMapTitle Members


IMapVectorLayer Interface

IMapVectorLayer Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapVectorLayer Interface
Map layer with spatial data rendering item.
Object Model
IMapVectorLayer Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapVectorLayer
   Inherits IMapLayer
public interface IMapVectorLayer : IMapLayer
See Also

Reference

IMapVectorLayer Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapVectorLayer Interface Members

IMapVectorLayer Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapVectorLayer Interface

The following tables list the members exposed by IMapVectorLayer.

Public Properties
 | Name | Description
Property | ColorScaleElements | Color sclaes settings.
Property | DataElementName | XML export custom element name.
Property | DataElementOutput | XML export custom element output type.
Property | Elements | Spatial elements to render in the layer.
Property | MaxZoom | The maximum zoom level at which the layer is visible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapLayer)
Property | MinZoom | The minimum zoom level at which the layer is visible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapLayer)
Property | Name | The layer name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapLayer)
Property | Transparency | Map layer transparency. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapLayer)
Property | VisibilityMode | Map layer visibility. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapLayer)
Top
Public Methods
 | Name | Description
Method | ProcessLegend | Obtains rendering legend items.
Top
See Also

Reference

IMapVectorLayer Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapVectorLayer Interface Methods

IMapVectorLayer Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapVectorLayer Interface

For a list of all members of this type, see IMapVectorLayer members.

Public Methods
 | Name | Description
Method | ProcessLegend | Obtains rendering legend items.
Top
See Also

Reference

IMapVectorLayer Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


ProcessLegend Method

ProcessLegend Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapVectorLayer Interface : ProcessLegend Method
Obtains rendering legend items.
Syntax
  • Visual Basic
  • C#
'Declaration

Function ProcessLegend( _
   ByVal legend As IMapLegend _
) As System.Collections.Generic.IEnumerable(Of IMapLegendItem)
System.Collections.Generic.IEnumerable<IMapLegendItem> ProcessLegend(
   IMapLegend legend
)

Parameters

legend
See Also

Reference

IMapVectorLayer Interface
IMapVectorLayer Members


IMapVectorLayer Interface Properties

IMapVectorLayer Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapVectorLayer Interface

For a list of all members of this type, see IMapVectorLayer members.

Public Properties
 | Name | Description
Property | ColorScaleElements | Color sclaes settings.
Property | DataElementName | XML export custom element name.
Property | DataElementOutput | XML export custom element output type.
Property | Elements | Spatial elements to render in the layer.
Property | MaxZoom | The maximum zoom level at which the layer is visible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapLayer)
Property | MinZoom | The minimum zoom level at which the layer is visible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapLayer)
Property | Name | The layer name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapLayer)
Property | Transparency | Map layer transparency. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapLayer)
Property | VisibilityMode | Map layer visibility. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapLayer)
Top
See Also

Reference

IMapVectorLayer Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


ColorScaleElements Property

ColorScaleElements Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapVectorLayer Interface : ColorScaleElements Property
Color sclaes settings.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ColorScaleElements As System.Collections.Generic.IEnumerable(Of IMapColorScaleElement)
System.Collections.Generic.IEnumerable<IMapColorScaleElement> ColorScaleElements {get;}
See Also

Reference

IMapVectorLayer Interface
IMapVectorLayer Members


DataElementName Property (IMapVectorLayer)

DataElementName Property (IMapVectorLayer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapVectorLayer Interface : DataElementName Property
XML export custom element name.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataElementName As System.String
System.string DataElementName {get;}
See Also

Reference

IMapVectorLayer Interface
IMapVectorLayer Members


DataElementOutput Property (IMapVectorLayer)

DataElementOutput Property (IMapVectorLayer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapVectorLayer Interface : DataElementOutput Property
XML export custom element output type.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataElementOutput As DataElementOutput
DataElementOutput DataElementOutput {get;}
See Also

Reference

IMapVectorLayer Interface
IMapVectorLayer Members


Elements Property (IMapVectorLayer)

Elements Property (IMapVectorLayer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapVectorLayer Interface : Elements Property
Spatial elements to render in the layer.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Elements As System.Collections.Generic.IEnumerable(Of IMapSpatialElement)
System.Collections.Generic.IEnumerable<IMapSpatialElement> Elements {get;}
See Also

Reference

IMapVectorLayer Interface
IMapVectorLayer Members


IMapView Interface

IMapView Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapView Interface
MapViewport main view rendering settings.
Object Model
IMapView Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapView
public interface IMapView
See Also

Reference

IMapView Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapView Interface Members

IMapView Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapView Interface

The following tables list the members exposed by IMapView.

Public Properties
 | Name | Description
Property | CenterUnits | Specify the type of the MapViewport.MapView.
Property | CenterX | Specifies the x-coordinate of the MapViewport element center as a percentage of the map content.
Property | CenterY | Specifies the y-coordinate of the MapViewport element center as a percentage of the map content.
Property | Zoom | Specifies the zoom level of a MapViewport element.
Top
See Also

Reference

IMapView Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapView Interface Properties

IMapView Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapView Interface

For a list of all members of this type, see IMapView members.

Public Properties
 | Name | Description
Property | CenterUnits | Specify the type of the MapViewport.MapView.
Property | CenterX | Specifies the x-coordinate of the MapViewport element center as a percentage of the map content.
Property | CenterY | Specifies the y-coordinate of the MapViewport element center as a percentage of the map content.
Property | Zoom | Specifies the zoom level of a MapViewport element.
Top
See Also

Reference

IMapView Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


CenterUnits Property

CenterUnits Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapView Interface : CenterUnits Property
Specify the type of the MapViewport.MapView.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CenterUnits As MapViewCenterUnits
MapViewCenterUnits CenterUnits {get;}
See Also

Reference

IMapView Interface
IMapView Members


CenterX Property (IMapView)

CenterX Property (IMapView)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapView Interface : CenterX Property
Specifies the x-coordinate of the MapViewport element center as a percentage of the map content.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CenterX As System.Double
System.double CenterX {get;}
See Also

Reference

IMapView Interface
IMapView Members


CenterY Property (IMapView)

CenterY Property (IMapView)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapView Interface : CenterY Property
Specifies the y-coordinate of the MapViewport element center as a percentage of the map content.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CenterY As System.Double
System.double CenterY {get;}
See Also

Reference

IMapView Interface
IMapView Members


Zoom Property (IMapView)

Zoom Property (IMapView)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapView Interface : Zoom Property
Specifies the zoom level of a MapViewport element.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Zoom As System.Double
System.double Zoom {get;}
See Also

Reference

IMapView Interface
IMapView Members


IMapViewport Interface

IMapViewport Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapViewport Interface
Map viewport rendering item.
Object Model
IMapViewport Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMapViewport
   Inherits IMapSubItem
public interface IMapViewport : IMapSubItem
See Also

Reference

IMapViewport Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapViewport Interface Members

IMapViewport Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapViewport Interface

The following tables list the members exposed by IMapViewport.

Public Properties
 | Name | Description
Property | BottomMargin | Width of the bottom margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ContentMargin | Specifies the margin between a MapViewport element and its content.
Property | GridUnderContent | Specifies whether the map meridians and map parallels will be drawn under the map content.
Property | LeftMargin | Width of the left margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MapCoordinateSystem | Coordinate sytem rendering settings.
Property | MapLimits | Map viewport rendering limits.
Property | MapLocation | Gets or sets the sub item location within the map. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MapMeridians | Meridians rendering settings.
Property | MapParallels | Parallels rendering settings.
Property | MapProjection | Used map projection.
Property | MapSize | Gets or sets the sub item size within the map. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MapView | Map viewport main view settings.
Property | MaximumZoom | Specifies the maximum zoom level that is allowed in a Map element.
Property | MinimumZoom | Specifies the minimum zoom level that is allowed in a Map element.
Property | ProjectionCenterX | Specifies the X projection center of a MapViewport element in map coordinates.
Property | ProjectionCenterY | Specifies the Y projection center of a MapViewport element in map coordinates.
Property | RightMargin | Width of the right margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ScaleFactor | Twips to kilometers scale factor.
Property | ShadowIntensity | Gets the shadow intensity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | SimplificationResolution | Specifies the resolution that is used to simplify map polygons and map lines. The resolution is specified in map coordinates.
Property | Style | Gets or sets style properties for map sub item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | TopMargin | Width of the top margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ZIndex | Drawing order of the item within the map. The default value is 0. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Top
See Also

Reference

IMapViewport Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


IMapViewport Interface Properties

IMapViewport Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMapViewport Interface

For a list of all members of this type, see IMapViewport members.

Public Properties
 | Name | Description
Property | BottomMargin | Width of the bottom margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ContentMargin | Specifies the margin between a MapViewport element and its content.
Property | GridUnderContent | Specifies whether the map meridians and map parallels will be drawn under the map content.
Property | LeftMargin | Width of the left margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MapCoordinateSystem | Coordinate sytem rendering settings.
Property | MapLimits | Map viewport rendering limits.
Property | MapLocation | Gets or sets the sub item location within the map. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MapMeridians | Meridians rendering settings.
Property | MapParallels | Parallels rendering settings.
Property | MapProjection | Used map projection.
Property | MapSize | Gets or sets the sub item size within the map. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | MapView | Map viewport main view settings.
Property | MaximumZoom | Specifies the maximum zoom level that is allowed in a Map element.
Property | MinimumZoom | Specifies the minimum zoom level that is allowed in a Map element.
Property | ProjectionCenterX | Specifies the X projection center of a MapViewport element in map coordinates.
Property | ProjectionCenterY | Specifies the Y projection center of a MapViewport element in map coordinates.
Property | RightMargin | Width of the right margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ScaleFactor | Twips to kilometers scale factor.
Property | ShadowIntensity | Gets the shadow intensity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | SimplificationResolution | Specifies the resolution that is used to simplify map polygons and map lines. The resolution is specified in map coordinates.
Property | Style | Gets or sets style properties for map sub item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | TopMargin | Width of the top margin. The default value is 0in. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Property | ZIndex | Drawing order of the item within the map. The default value is 0. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.IMapSubItem)
Top
See Also

Reference

IMapViewport Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


ContentMargin Property (IMapViewport)

ContentMargin Property (IMapViewport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : ContentMargin Property
Specifies the margin between a MapViewport element and its content.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ContentMargin As Length
Length ContentMargin {get;}
See Also

Reference

IMapViewport Interface
IMapViewport Members


GridUnderContent Property (IMapViewport)

GridUnderContent Property (IMapViewport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : GridUnderContent Property
Specifies whether the map meridians and map parallels will be drawn under the map content.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property GridUnderContent As System.Boolean
System.bool GridUnderContent {get;}
See Also

Reference

IMapViewport Interface
IMapViewport Members


MapCoordinateSystem Property (IMapViewport)

MapCoordinateSystem Property (IMapViewport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : MapCoordinateSystem Property
Coordinate sytem rendering settings.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MapCoordinateSystem As MapCoordinateSystem
MapCoordinateSystem MapCoordinateSystem {get;}
See Also

Reference

IMapViewport Interface
IMapViewport Members


MapLimits Property (IMapViewport)

MapLimits Property (IMapViewport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : MapLimits Property
Map viewport rendering limits.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MapLimits As IMapLimits
IMapLimits MapLimits {get;}
See Also

Reference

IMapViewport Interface
IMapViewport Members


MapMeridians Property (IMapViewport)

MapMeridians Property (IMapViewport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : MapMeridians Property
Meridians rendering settings.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MapMeridians As IMapGridLines
IMapGridLines MapMeridians {get;}
See Also

Reference

IMapViewport Interface
IMapViewport Members


MapParallels Property (IMapViewport)

MapParallels Property (IMapViewport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : MapParallels Property
Parallels rendering settings.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MapParallels As IMapGridLines
IMapGridLines MapParallels {get;}
See Also

Reference

IMapViewport Interface
IMapViewport Members


MapProjection Property (IMapViewport)

MapProjection Property (IMapViewport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : MapProjection Property
Used map projection.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MapProjection As MapProjection
MapProjection MapProjection {get;}
See Also

Reference

IMapViewport Interface
IMapViewport Members


MapView Property (IMapViewport)

MapView Property (IMapViewport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : MapView Property
Map viewport main view settings.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MapView As IMapView
IMapView MapView {get;}
See Also

Reference

IMapViewport Interface
IMapViewport Members


MaximumZoom Property (IMapViewport)

MaximumZoom Property (IMapViewport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : MaximumZoom Property
Specifies the maximum zoom level that is allowed in a Map element.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MaximumZoom As System.Double
System.double MaximumZoom {get;}
See Also

Reference

IMapViewport Interface
IMapViewport Members


MinimumZoom Property (IMapViewport)

MinimumZoom Property (IMapViewport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : MinimumZoom Property
Specifies the minimum zoom level that is allowed in a Map element.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MinimumZoom As System.Double
System.double MinimumZoom {get;}
See Also

Reference

IMapViewport Interface
IMapViewport Members


ProjectionCenterX Property (IMapViewport)

ProjectionCenterX Property (IMapViewport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : ProjectionCenterX Property
Specifies the X projection center of a MapViewport element in map coordinates.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ProjectionCenterX As System.Double
System.double ProjectionCenterX {get;}
See Also

Reference

IMapViewport Interface
IMapViewport Members


ProjectionCenterY Property (IMapViewport)

ProjectionCenterY Property (IMapViewport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : ProjectionCenterY Property
Specifies the Y projection center of a MapViewport element in map coordinates.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ProjectionCenterY As System.Double
System.double ProjectionCenterY {get;}
See Also

Reference

IMapViewport Interface
IMapViewport Members


ScaleFactor Property (IMapViewport)

ScaleFactor Property (IMapViewport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : ScaleFactor Property
Twips to kilometers scale factor.
Syntax
  • Visual Basic
  • C#
'Declaration

Property ScaleFactor As System.Double
System.double ScaleFactor {get; set;}
See Also

Reference

IMapViewport Interface
IMapViewport Members


SimplificationResolution Property (IMapViewport)

SimplificationResolution Property (IMapViewport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMapViewport Interface : SimplificationResolution Property
Specifies the resolution that is used to simplify map polygons and map lines. The resolution is specified in map coordinates.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property SimplificationResolution As System.Double
System.double SimplificationResolution {get;}
See Also

Reference

IMapViewport Interface
IMapViewport Members


GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace
Classes
 | Class | Description
Class | GeoCurve | Represents the base type for geospatial curve.
Class | GeoGeometryCollection | Represents the collection of geospatial shapes.
Class | GeoLine | Represents the geospatial line
Class | GeoLinearRing | Represents the geospatial ring for the polygons.
Class | GeoLineString | Represents the geospatial line shape.
Class | GeoMultiLineString | Represents the geospatial multi line shape.
Class | GeoMultiPoint | Represents the geospatial multi point shape.
Class | GeoMultiPolygon | Represents the multi polygon shape.
Class | GeoPoint | Represents the geospatial point shape.
Class | GeoPolygon | Represents the geospatial polygon shape.
Class | GeoPolyhedralSurface | Represents the geospatial polyhedral surface.
Class | GeoShape | Represents geospatial shape base class.
Class | GeoSurface | Represents the base class for geospatial surface.
Class | GeoTin | Represents the geospatial triangulated irregular network.
Class | GeoTriangle | Represents the geospatial triangle shape.
Class | ShapePoint | Represents the 2D point.
Class | ShapePointM | Represents 2D point with M value.
Class | ShapePointZ | Represents the 3D point.
Class | ShapePointZM | Represents the 3D point with M value.
Enumerations
 | Enumeration | Description
Enumeration | GeometryType | Defines the geometry types according to OGC Simple Access specification.
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


GeoCurve Class

GeoCurve Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoCurve Class
Represents the base type for geospatial curve.
Object Model
GeoCurve Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class GeoCurve
   Inherits GeoShape
public abstract class GeoCurve : GeoShape
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoCurve
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString

See Also

Reference

GeoCurve Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoCurve Class Members

GeoCurve Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoCurve Class

The following tables list the members exposed by GeoCurve.

Public Properties
 | Name | Description
Public Property | Bounds | Returns the bounds of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Center | Gets the centroid of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Is3D | Returns true if the shape has z-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | IsEmpty | Returns the value indicating whether the shape is empty geometry. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | IsMeasured | Returns true if the shape has m-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | PointsCount | Returns the number of points used in a shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoCurve Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoGeometryCollection Class

GeoGeometryCollection Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoGeometryCollection Class
Represents the collection of geospatial shapes.
Object Model
GeoGeometryCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class GeoGeometryCollection
   Inherits GeoShape
public class GeoGeometryCollection : GeoShape
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoMultiLineString
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoMultiPoint
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoMultiPolygon

See Also

Reference

GeoGeometryCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoGeometryCollection Class Members

GeoGeometryCollection Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoGeometryCollection Class

The following tables list the members exposed by GeoGeometryCollection.

Public Constructors
 | Name | Description
Public Constructor | GeoGeometryCollection Constructor | Initializes a new instance of the GeoGeometryCollection class.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Returns the bounds of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Center | Gets the centroid of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Is3D | Overridden. Returns true if any shape in collection has z-coordinate values.
Public Property | IsEmpty | Overridden. Returns the value indicating whether the collection is empty or all shapes in collection is empty geometry.
Public Property | IsMeasured | Overridden. Returns true if any shape in collection has m-coordinate values.
Public Property | PointsCount | Overridden. Returns the sum of points used in shapes.
Public Property | Shapes | Gets the inner shapes.
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoGeometryCollection Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoGeometryCollection Constructor

GeoGeometryCollection Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoGeometryCollection Class : GeoGeometryCollection Constructor
Collection of geospatial shapes
Initializes a new instance of the GeoGeometryCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal shapes As System.Collections.Generic.IEnumerable(Of GeoShape) _
)
public GeoGeometryCollection(
   System.Collections.Generic.IEnumerable<GeoShape> shapes
)

Parameters

shapes
Collection of geospatial shapes
See Also

Reference

GeoGeometryCollection Class
GeoGeometryCollection Members


GeoGeometryCollection Class Properties

GeoGeometryCollection Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoGeometryCollection Class

For a list of all members of this type, see GeoGeometryCollection members.

Public Properties
 | Name | Description
Public Property | Bounds | Returns the bounds of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Center | Gets the centroid of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Is3D | Overridden. Returns true if any shape in collection has z-coordinate values.
Public Property | IsEmpty | Overridden. Returns the value indicating whether the collection is empty or all shapes in collection is empty geometry.
Public Property | IsMeasured | Overridden. Returns true if any shape in collection has m-coordinate values.
Public Property | PointsCount | Overridden. Returns the sum of points used in shapes.
Public Property | Shapes | Gets the inner shapes.
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoGeometryCollection Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


Is3D Property (GeoGeometryCollection)

Is3D Property (GeoGeometryCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoGeometryCollection Class : Is3D Property
Returns true if any shape in collection has z-coordinate values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property Is3D As System.Boolean
public override System.bool Is3D {get;}
See Also

Reference

GeoGeometryCollection Class
GeoGeometryCollection Members


IsEmpty Property (GeoGeometryCollection)

IsEmpty Property (GeoGeometryCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoGeometryCollection Class : IsEmpty Property
Returns the value indicating whether the collection is empty or all shapes in collection is empty geometry.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property IsEmpty As System.Boolean
public override System.bool IsEmpty {get;}
See Also

Reference

GeoGeometryCollection Class
GeoGeometryCollection Members


IsMeasured Property (GeoGeometryCollection)

IsMeasured Property (GeoGeometryCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoGeometryCollection Class : IsMeasured Property
Returns true if any shape in collection has m-coordinate values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property IsMeasured As System.Boolean
public override System.bool IsMeasured {get;}
See Also

Reference

GeoGeometryCollection Class
GeoGeometryCollection Members


PointsCount Property (GeoGeometryCollection)

PointsCount Property (GeoGeometryCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoGeometryCollection Class : PointsCount Property
Returns the sum of points used in shapes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property PointsCount As System.Integer
public override System.int PointsCount {get;}
See Also

Reference

GeoGeometryCollection Class
GeoGeometryCollection Members


Shapes Property

Shapes Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoGeometryCollection Class : Shapes Property
Gets the inner shapes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Shapes As System.Collections.Generic.IEnumerable(Of GeoShape)
public System.Collections.Generic.IEnumerable<GeoShape> Shapes {get;}
See Also

Reference

GeoGeometryCollection Class
GeoGeometryCollection Members


GeoLine Class

GeoLine Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoLine Class
Represents the geospatial line
Object Model
GeoLine Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class GeoLine
   Inherits GeoLineString
public sealed class GeoLine : GeoLineString
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoCurve
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLine

See Also

Reference

GeoLine Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoLine Class Members

GeoLine Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoLine Class

The following tables list the members exposed by GeoLine.

Public Constructors
 | Name | Description
Public Constructor | GeoLine Constructor | Initializes a new instance of the GeoLine class.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Returns the bounds of the line shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString)
Public Property | Center | Gets the centroid of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Is3D | Returns true if any point in collection has z-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString)
Public Property | IsEmpty | Returns the value indicating whether the collection of line points is empty. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString)
Public Property | IsMeasured | Returns true if any point in collection has m-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString)
Public Property | Points | Gets the line points. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString)
Public Property | PointsCount | Returns the points count. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString)
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoLine Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoLine Constructor

GeoLine Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoLine Class : GeoLine Constructor
The points.
Initializes a new instance of the GeoLine class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal points As System.Collections.Generic.IEnumerable(Of GeoPoint) _
)
public GeoLine(
   System.Collections.Generic.IEnumerable<GeoPoint> points
)

Parameters

points
The points.
See Also

Reference

GeoLine Class
GeoLine Members


GeoLinearRing Class

GeoLinearRing Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoLinearRing Class
Represents the geospatial ring for the polygons.
Object Model
GeoLinearRing Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class GeoLinearRing
   Inherits GeoLineString
public sealed class GeoLinearRing : GeoLineString
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoCurve
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLinearRing

See Also

Reference

GeoLinearRing Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoLinearRing Class Members

GeoLinearRing Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoLinearRing Class

The following tables list the members exposed by GeoLinearRing.

Public Constructors
 | Name | Description
Public Constructor | GeoLinearRing Constructor | Initializes a new instance of the GeoLinearRing class.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Returns the bounds of the line shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString)
Public Property | Center | Overridden. Gets the centroid of the polygon.
Public Property | Is3D | Returns true if any point in collection has z-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString)
Public Property | IsEmpty | Returns the value indicating whether the collection of line points is empty. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString)
Public Property | IsMeasured | Returns true if any point in collection has m-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString)
Public Property | Points | Gets the line points. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString)
Public Property | PointsCount | Returns the points count. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString)
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoLinearRing Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoLinearRing Constructor

GeoLinearRing Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoLinearRing Class : GeoLinearRing Constructor
The points.
Initializes a new instance of the GeoLinearRing class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal points As System.Collections.Generic.IEnumerable(Of GeoPoint) _
)
public GeoLinearRing(
   System.Collections.Generic.IEnumerable<GeoPoint> points
)

Parameters

points
The points.
See Also

Reference

GeoLinearRing Class
GeoLinearRing Members


GeoLinearRing Class Properties

GeoLinearRing Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoLinearRing Class

For a list of all members of this type, see GeoLinearRing members.

Public Properties
 | Name | Description
Public Property | Bounds | Returns the bounds of the line shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString)
Public Property | Center | Overridden. Gets the centroid of the polygon.
Public Property | Is3D | Returns true if any point in collection has z-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString)
Public Property | IsEmpty | Returns the value indicating whether the collection of line points is empty. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString)
Public Property | IsMeasured | Returns true if any point in collection has m-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString)
Public Property | Points | Gets the line points. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString)
Public Property | PointsCount | Returns the points count. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString)
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoLinearRing Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


Center Property (GeoLinearRing)

Center Property (GeoLinearRing)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoLinearRing Class : Center Property
Gets the centroid of the polygon.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable ReadOnly Property Center As PointFEx
public override PointFEx Center {get;}
See Also

Reference

GeoLinearRing Class
GeoLinearRing Members


GeoLineString Class

GeoLineString Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoLineString Class
Represents the geospatial line shape.
Object Model
GeoLineString Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class GeoLineString
   Inherits GeoCurve
public class GeoLineString : GeoCurve
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoCurve
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLine
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLinearRing

See Also

Reference

GeoLineString Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoLineString Class Members

GeoLineString Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoLineString Class

The following tables list the members exposed by GeoLineString.

Public Constructors
 | Name | Description
Public Constructor | GeoLineString Constructor | Initializes new instance of GeoLineString.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Returns the bounds of the line shape.
Public Property | Center | Gets the centroid of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Is3D | Overridden. Returns true if any point in collection has z-coordinate values.
Public Property | IsEmpty | Overridden. Returns the value indicating whether the collection of line points is empty.
Public Property | IsMeasured | Overridden. Returns true if any point in collection has m-coordinate values.
Public Property | Points | Gets the line points.
Public Property | PointsCount | Overridden. Returns the points count.
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoLineString Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoLineString Constructor

GeoLineString Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoLineString Class : GeoLineString Constructor
The line points.
Initializes new instance of GeoLineString.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal points As System.Collections.Generic.IEnumerable(Of GeoPoint) _
)
public GeoLineString(
   System.Collections.Generic.IEnumerable<GeoPoint> points
)

Parameters

points
The line points.
See Also

Reference

GeoLineString Class
GeoLineString Members


GeoLineString Class Properties

GeoLineString Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoLineString Class

For a list of all members of this type, see GeoLineString members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Returns the bounds of the line shape.
Public Property | Center | Gets the centroid of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Is3D | Overridden. Returns true if any point in collection has z-coordinate values.
Public Property | IsEmpty | Overridden. Returns the value indicating whether the collection of line points is empty.
Public Property | IsMeasured | Overridden. Returns true if any point in collection has m-coordinate values.
Public Property | Points | Gets the line points.
Public Property | PointsCount | Overridden. Returns the points count.
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoLineString Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


Bounds Property (GeoLineString)

Bounds Property (GeoLineString)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoLineString Class : Bounds Property
Returns the bounds of the line shape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property Bounds As RectangleFEx
public override RectangleFEx Bounds {get;}
See Also

Reference

GeoLineString Class
GeoLineString Members


Is3D Property (GeoLineString)

Is3D Property (GeoLineString)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoLineString Class : Is3D Property
Returns true if any point in collection has z-coordinate values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property Is3D As System.Boolean
public override System.bool Is3D {get;}
See Also

Reference

GeoLineString Class
GeoLineString Members


IsEmpty Property (GeoLineString)

IsEmpty Property (GeoLineString)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoLineString Class : IsEmpty Property
Returns the value indicating whether the collection of line points is empty.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property IsEmpty As System.Boolean
public override System.bool IsEmpty {get;}
See Also

Reference

GeoLineString Class
GeoLineString Members


IsMeasured Property (GeoLineString)

IsMeasured Property (GeoLineString)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoLineString Class : IsMeasured Property
Returns true if any point in collection has m-coordinate values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property IsMeasured As System.Boolean
public override System.bool IsMeasured {get;}
See Also

Reference

GeoLineString Class
GeoLineString Members


Points Property (GeoLineString)

Points Property (GeoLineString)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoLineString Class : Points Property
Gets the line points.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Points As System.Collections.Generic.IEnumerable(Of GeoPoint)
public System.Collections.Generic.IEnumerable<GeoPoint> Points {get;}
See Also

Reference

GeoLineString Class
GeoLineString Members


PointsCount Property (GeoLineString)

PointsCount Property (GeoLineString)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoLineString Class : PointsCount Property
Returns the points count.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property PointsCount As System.Integer
public override System.int PointsCount {get;}
See Also

Reference

GeoLineString Class
GeoLineString Members


GeoMultiLineString Class

GeoMultiLineString Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoMultiLineString Class
Represents the geospatial multi line shape.
Object Model
GeoMultiLineString Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class GeoMultiLineString
   Inherits GeoGeometryCollection
public sealed class GeoMultiLineString : GeoGeometryCollection
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoMultiLineString

See Also

Reference

GeoMultiLineString Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoMultiLineString Class Members

GeoMultiLineString Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoMultiLineString Class

The following tables list the members exposed by GeoMultiLineString.

Public Constructors
 | Name | Description
Public Constructor | GeoMultiLineString Constructor | Initializes a new instance of the GeoMultiLineString class.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Returns the bounds of the multi line shape.
Public Property | Center | Gets the centroid of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Is3D | Returns true if any shape in collection has z-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | IsEmpty | Returns the value indicating whether the collection is empty or all shapes in collection is empty geometry. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | IsMeasured | Returns true if any shape in collection has m-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | Lines | Gets the line shapes.
Public Property | PointsCount | Returns the sum of points used in shapes. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | Shapes | Gets the inner shapes. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoMultiLineString Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoMultiLineString Constructor

GeoMultiLineString Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoMultiLineString Class : GeoMultiLineString Constructor
The line string.
Initializes a new instance of the GeoMultiLineString class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal lines As System.Collections.Generic.IEnumerable(Of GeoLineString) _
)
public GeoMultiLineString(
   System.Collections.Generic.IEnumerable<GeoLineString> lines
)

Parameters

lines
The line string.
See Also

Reference

GeoMultiLineString Class
GeoMultiLineString Members


GeoMultiLineString Class Properties

GeoMultiLineString Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoMultiLineString Class

For a list of all members of this type, see GeoMultiLineString members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Returns the bounds of the multi line shape.
Public Property | Center | Gets the centroid of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Is3D | Returns true if any shape in collection has z-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | IsEmpty | Returns the value indicating whether the collection is empty or all shapes in collection is empty geometry. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | IsMeasured | Returns true if any shape in collection has m-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | Lines | Gets the line shapes.
Public Property | PointsCount | Returns the sum of points used in shapes. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | Shapes | Gets the inner shapes. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoMultiLineString Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


Bounds Property (GeoMultiLineString)

Bounds Property (GeoMultiLineString)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoMultiLineString Class : Bounds Property
Returns the bounds of the multi line shape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable ReadOnly Property Bounds As RectangleFEx
public override RectangleFEx Bounds {get;}
See Also

Reference

GeoMultiLineString Class
GeoMultiLineString Members


Lines Property

Lines Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoMultiLineString Class : Lines Property
Gets the line shapes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Lines As System.Collections.Generic.IEnumerable(Of GeoLineString)
public System.Collections.Generic.IEnumerable<GeoLineString> Lines {get;}
See Also

Reference

GeoMultiLineString Class
GeoMultiLineString Members


GeoMultiPoint Class

GeoMultiPoint Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoMultiPoint Class
Represents the geospatial multi point shape.
Object Model
GeoMultiPoint Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class GeoMultiPoint
   Inherits GeoGeometryCollection
public sealed class GeoMultiPoint : GeoGeometryCollection
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoMultiPoint

See Also

Reference

GeoMultiPoint Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoMultiPoint Class Members

GeoMultiPoint Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoMultiPoint Class

The following tables list the members exposed by GeoMultiPoint.

Public Constructors
 | Name | Description
Public Constructor | GeoMultiPoint Constructor | Initializes new instance of GeoMultiPoint.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Returns the bounds of the multi point shape.
Public Property | Center | Gets the centroid of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Is3D | Returns true if any shape in collection has z-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | IsEmpty | Overridden. Returns the value indicating whether the collection is empty.
Public Property | IsMeasured | Returns true if any shape in collection has m-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | Points | Gets the inner points shapes.
Public Property | PointsCount | Returns the sum of points used in shapes. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | Shapes | Gets the inner shapes. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoMultiPoint Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoMultiPoint Constructor

GeoMultiPoint Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoMultiPoint Class : GeoMultiPoint Constructor
The inner points.
Initializes new instance of GeoMultiPoint.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal points As System.Collections.Generic.IEnumerable(Of GeoPoint) _
)
public GeoMultiPoint(
   System.Collections.Generic.IEnumerable<GeoPoint> points
)

Parameters

points
The inner points.
See Also

Reference

GeoMultiPoint Class
GeoMultiPoint Members


GeoMultiPoint Class Properties

GeoMultiPoint Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoMultiPoint Class

For a list of all members of this type, see GeoMultiPoint members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Returns the bounds of the multi point shape.
Public Property | Center | Gets the centroid of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Is3D | Returns true if any shape in collection has z-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | IsEmpty | Overridden. Returns the value indicating whether the collection is empty.
Public Property | IsMeasured | Returns true if any shape in collection has m-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | Points | Gets the inner points shapes.
Public Property | PointsCount | Returns the sum of points used in shapes. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | Shapes | Gets the inner shapes. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoMultiPoint Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


Bounds Property (GeoMultiPoint)

Bounds Property (GeoMultiPoint)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoMultiPoint Class : Bounds Property
Returns the bounds of the multi point shape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable ReadOnly Property Bounds As RectangleFEx
public override RectangleFEx Bounds {get;}
See Also

Reference

GeoMultiPoint Class
GeoMultiPoint Members


IsEmpty Property (GeoMultiPoint)

IsEmpty Property (GeoMultiPoint)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoMultiPoint Class : IsEmpty Property
Returns the value indicating whether the collection is empty.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable ReadOnly Property IsEmpty As System.Boolean
public override System.bool IsEmpty {get;}
See Also

Reference

GeoMultiPoint Class
GeoMultiPoint Members


Points Property (GeoMultiPoint)

Points Property (GeoMultiPoint)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoMultiPoint Class : Points Property
Gets the inner points shapes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Points As System.Collections.Generic.IEnumerable(Of GeoPoint)
public System.Collections.Generic.IEnumerable<GeoPoint> Points {get;}
See Also

Reference

GeoMultiPoint Class
GeoMultiPoint Members


GeoMultiPolygon Class

GeoMultiPolygon Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoMultiPolygon Class
Represents the multi polygon shape.
Object Model
GeoMultiPolygon Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class GeoMultiPolygon
   Inherits GeoGeometryCollection
public sealed class GeoMultiPolygon : GeoGeometryCollection
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoMultiPolygon

See Also

Reference

GeoMultiPolygon Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoMultiPolygon Class Members

GeoMultiPolygon Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoMultiPolygon Class

The following tables list the members exposed by GeoMultiPolygon.

Public Constructors
 | Name | Description
Public Constructor | GeoMultiPolygon Constructor | Initializes new instance of GeoMultiPolygon.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Returns the bounds of the multi polygon shape.
Public Property | Center | Overridden. Gets the centroid of the multi polygon shape.
Public Property | Is3D | Returns true if any shape in collection has z-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | IsEmpty | Returns the value indicating whether the collection is empty or all shapes in collection is empty geometry. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | IsMeasured | Returns true if any shape in collection has m-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | PointsCount | Returns the sum of points used in shapes. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | Polygons | Gets the inner polygon shapes.
Public Property | Shapes | Gets the inner shapes. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoMultiPolygon Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoMultiPolygon Constructor

GeoMultiPolygon Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoMultiPolygon Class : GeoMultiPolygon Constructor
The inner polygon shapes.
Initializes new instance of GeoMultiPolygon.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal polygons As System.Collections.Generic.IEnumerable(Of GeoPolygon) _
)
public GeoMultiPolygon(
   System.Collections.Generic.IEnumerable<GeoPolygon> polygons
)

Parameters

polygons
The inner polygon shapes.
See Also

Reference

GeoMultiPolygon Class
GeoMultiPolygon Members


GeoMultiPolygon Class Properties

GeoMultiPolygon Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoMultiPolygon Class

For a list of all members of this type, see GeoMultiPolygon members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Returns the bounds of the multi polygon shape.
Public Property | Center | Overridden. Gets the centroid of the multi polygon shape.
Public Property | Is3D | Returns true if any shape in collection has z-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | IsEmpty | Returns the value indicating whether the collection is empty or all shapes in collection is empty geometry. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | IsMeasured | Returns true if any shape in collection has m-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | PointsCount | Returns the sum of points used in shapes. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | Polygons | Gets the inner polygon shapes.
Public Property | Shapes | Gets the inner shapes. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection)
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoMultiPolygon Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


Bounds Property (GeoMultiPolygon)

Bounds Property (GeoMultiPolygon)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoMultiPolygon Class : Bounds Property
Returns the bounds of the multi polygon shape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable ReadOnly Property Bounds As RectangleFEx
public override RectangleFEx Bounds {get;}
See Also

Reference

GeoMultiPolygon Class
GeoMultiPolygon Members


Center Property (GeoMultiPolygon)

Center Property (GeoMultiPolygon)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoMultiPolygon Class : Center Property
Gets the centroid of the multi polygon shape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable ReadOnly Property Center As PointFEx
public override PointFEx Center {get;}
See Also

Reference

GeoMultiPolygon Class
GeoMultiPolygon Members


Polygons Property (GeoMultiPolygon)

Polygons Property (GeoMultiPolygon)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoMultiPolygon Class : Polygons Property
Gets the inner polygon shapes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Polygons As System.Collections.Generic.IEnumerable(Of GeoPolygon)
public System.Collections.Generic.IEnumerable<GeoPolygon> Polygons {get;}
See Also

Reference

GeoMultiPolygon Class
GeoMultiPolygon Members


GeoPoint Class

GeoPoint Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoPoint Class
Represents the geospatial point shape.
Object Model
GeoPoint Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class GeoPoint
   Inherits GeoShape
public sealed class GeoPoint : GeoShape
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPoint

See Also

Reference

GeoPoint Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoPoint Class Members

GeoPoint Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoPoint Class

The following tables list the members exposed by GeoPoint.

Public Constructors
 | Name | Description
Public Constructor | GeoPoint Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. The bounds of the point shape.
Public Property | Center | Gets the centroid of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Is3D | Overridden. Returns true if the point shape has z-coordinate values.
Public Property | IsEmpty | Overridden. Returns the value indicating whether the point shape is empty geometry.
Public Property | IsMeasured | Overridden. Returns true if the point shape has m-coordinate values.
Public Property | M | Gets or sets the m-coordinate.
Public Property | PointsCount | Overridden. The count of the points.
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | X | Gets or sets the x-coordinate.
Public Property | Y | Gets or sets the y-coordinate.
Public Property | Z | Gets or sets the z-coordinate.
Top
See Also

Reference

GeoPoint Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoPoint Constructor

GeoPoint Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPoint Class : GeoPoint Constructor
Overload List
Overload | Description
GeoPoint Constructor(Double,Double) | Initializes a new instance of the GeoPoint class.
GeoPoint Constructor(Double,Double,Nullable<Double>,Nullable<Double>) | Initializes a new instance of the GeoPoint class.
See Also

Reference

GeoPoint Class
GeoPoint Members


GeoPoint Constructor(Double,Double)

GeoPoint Constructor(Double,Double)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPoint Class > GeoPoint Constructor : GeoPoint Constructor(Double,Double)
The x-coordinate.
The y-coordinate.
Initializes a new instance of the GeoPoint class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal x As System.Double, _
   ByVal y As System.Double _
)
public GeoPoint(
   System.double x,
   System.double y
)

Parameters

x
The x-coordinate.
y
The y-coordinate.
See Also

Reference

GeoPoint Class
GeoPoint Members
Overload List


GeoPoint Constructor(Double,Double,Nullable<Double>,Nullable<Double>)

GeoPoint Constructor(Double,Double,Nullable<Double>,Nullable<Double>)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPoint Class > GeoPoint Constructor : GeoPoint Constructor(Double,Double,Nullable<Double>,Nullable<Double>)
The x-coordinate.
The y-coordinate.
The z-coordinate.
The m-coordinate.
Initializes a new instance of the GeoPoint class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal x As System.Double, _
   ByVal y As System.Double, _
   ByVal z As System.Nullable(Of Double), _
   ByVal m As System.Nullable(Of Double) _
)
public GeoPoint(
   System.double x,
   System.double y,
   System.Nullable<double> z,
   System.Nullable<double> m
)

Parameters

x
The x-coordinate.
y
The y-coordinate.
z
The z-coordinate.
m
The m-coordinate.
See Also

Reference

GeoPoint Class
GeoPoint Members
Overload List


GeoPoint Class Properties

GeoPoint Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoPoint Class

For a list of all members of this type, see GeoPoint members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. The bounds of the point shape.
Public Property | Center | Gets the centroid of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Is3D | Overridden. Returns true if the point shape has z-coordinate values.
Public Property | IsEmpty | Overridden. Returns the value indicating whether the point shape is empty geometry.
Public Property | IsMeasured | Overridden. Returns true if the point shape has m-coordinate values.
Public Property | M | Gets or sets the m-coordinate.
Public Property | PointsCount | Overridden. The count of the points.
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | X | Gets or sets the x-coordinate.
Public Property | Y | Gets or sets the y-coordinate.
Public Property | Z | Gets or sets the z-coordinate.
Top
See Also

Reference

GeoPoint Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


Bounds Property (GeoPoint)

Bounds Property (GeoPoint)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPoint Class : Bounds Property
The bounds of the point shape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable ReadOnly Property Bounds As RectangleFEx
public override RectangleFEx Bounds {get;}
See Also

Reference

GeoPoint Class
GeoPoint Members


Is3D Property (GeoPoint)

Is3D Property (GeoPoint)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPoint Class : Is3D Property
Returns true if the point shape has z-coordinate values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable ReadOnly Property Is3D As System.Boolean
public override System.bool Is3D {get;}
See Also

Reference

GeoPoint Class
GeoPoint Members


IsEmpty Property (GeoPoint)

IsEmpty Property (GeoPoint)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPoint Class : IsEmpty Property
Returns the value indicating whether the point shape is empty geometry.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable ReadOnly Property IsEmpty As System.Boolean
public override System.bool IsEmpty {get;}
See Also

Reference

GeoPoint Class
GeoPoint Members


IsMeasured Property (GeoPoint)

IsMeasured Property (GeoPoint)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPoint Class : IsMeasured Property
Returns true if the point shape has m-coordinate values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable ReadOnly Property IsMeasured As System.Boolean
public override System.bool IsMeasured {get;}
See Also

Reference

GeoPoint Class
GeoPoint Members


M Property (GeoPoint)

M Property (GeoPoint)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPoint Class : M Property
Gets or sets the m-coordinate.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property M As System.Nullable(Of Double)
public System.Nullable<double> M {get;}
See Also

Reference

GeoPoint Class
GeoPoint Members


PointsCount Property (GeoPoint)

PointsCount Property (GeoPoint)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPoint Class : PointsCount Property
The count of the points.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable ReadOnly Property PointsCount As System.Integer
public override System.int PointsCount {get;}
See Also

Reference

GeoPoint Class
GeoPoint Members


X Property (GeoPoint)

X Property (GeoPoint)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPoint Class : X Property
Gets or sets the x-coordinate.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property X As System.Double
public System.double X {get;}
See Also

Reference

GeoPoint Class
GeoPoint Members


Y Property (GeoPoint)

Y Property (GeoPoint)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPoint Class : Y Property
Gets or sets the y-coordinate.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Y As System.Double
public System.double Y {get;}
See Also

Reference

GeoPoint Class
GeoPoint Members


Z Property (GeoPoint)

Z Property (GeoPoint)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPoint Class : Z Property
Gets or sets the z-coordinate.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Z As System.Nullable(Of Double)
public System.Nullable<double> Z {get;}
See Also

Reference

GeoPoint Class
GeoPoint Members


GeoPolygon Class

GeoPolygon Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoPolygon Class
Represents the geospatial polygon shape.
Object Model
GeoPolygon Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class GeoPolygon
   Inherits GeoSurface
public class GeoPolygon : GeoSurface
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoSurface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoTriangle

See Also

Reference

GeoPolygon Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoPolygon Class Members

GeoPolygon Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoPolygon Class

The following tables list the members exposed by GeoPolygon.

Public Constructors
 | Name | Description
Public Constructor | GeoPolygon Constructor | Initializes new instance of GeoPolygon.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Returns the bounds of the polygon shape.
Public Property | Center | Overridden. Gets the centroid of the polygon shape.
Public Property | ExteriorRing | Exterior ring of the polygon shape.
Public Property | InteriorRings | Interior rings of the polygon shape.
Public Property | Is3D | Overridden. Returns true if any ring in collection has z-coordinate values.
Public Property | IsEmpty | Overridden. Returns value indicating whether the ExterorRing null or empty.
Public Property | IsMeasured | Overridden. Returns true if any ring in collection has m-coordinate values.
Public Property | PointsCount | Overridden. Returns sum of rings points count.
Public Property | Rings | Gets the polygon rings.
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoPolygon Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoPolygon Constructor

GeoPolygon Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolygon Class : GeoPolygon Constructor
The polygon rings.
Initializes new instance of GeoPolygon.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal rings As System.Collections.Generic.IEnumerable(Of GeoLinearRing) _
)
public GeoPolygon(
   System.Collections.Generic.IEnumerable<GeoLinearRing> rings
)

Parameters

rings
The polygon rings.
See Also

Reference

GeoPolygon Class
GeoPolygon Members


GeoPolygon Class Properties

GeoPolygon Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoPolygon Class

For a list of all members of this type, see GeoPolygon members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Returns the bounds of the polygon shape.
Public Property | Center | Overridden. Gets the centroid of the polygon shape.
Public Property | ExteriorRing | Exterior ring of the polygon shape.
Public Property | InteriorRings | Interior rings of the polygon shape.
Public Property | Is3D | Overridden. Returns true if any ring in collection has z-coordinate values.
Public Property | IsEmpty | Overridden. Returns value indicating whether the ExterorRing null or empty.
Public Property | IsMeasured | Overridden. Returns true if any ring in collection has m-coordinate values.
Public Property | PointsCount | Overridden. Returns sum of rings points count.
Public Property | Rings | Gets the polygon rings.
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoPolygon Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


Bounds Property (GeoPolygon)

Bounds Property (GeoPolygon)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolygon Class : Bounds Property
Returns the bounds of the polygon shape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property Bounds As RectangleFEx
public override RectangleFEx Bounds {get;}
See Also

Reference

GeoPolygon Class
GeoPolygon Members


Center Property (GeoPolygon)

Center Property (GeoPolygon)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolygon Class : Center Property
Gets the centroid of the polygon shape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property Center As PointFEx
public override PointFEx Center {get;}
See Also

Reference

GeoPolygon Class
GeoPolygon Members


ExteriorRing Property

ExteriorRing Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolygon Class : ExteriorRing Property
Exterior ring of the polygon shape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ExteriorRing As GeoLinearRing
public GeoLinearRing ExteriorRing {get;}
See Also

Reference

GeoPolygon Class
GeoPolygon Members


InteriorRings Property

InteriorRings Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolygon Class : InteriorRings Property
Interior rings of the polygon shape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InteriorRings As System.Collections.Generic.IEnumerable(Of GeoLinearRing)
public System.Collections.Generic.IEnumerable<GeoLinearRing> InteriorRings {get;}
See Also

Reference

GeoPolygon Class
GeoPolygon Members


Is3D Property (GeoPolygon)

Is3D Property (GeoPolygon)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolygon Class : Is3D Property
Returns true if any ring in collection has z-coordinate values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property Is3D As System.Boolean
public override System.bool Is3D {get;}
See Also

Reference

GeoPolygon Class
GeoPolygon Members


IsEmpty Property (GeoPolygon)

IsEmpty Property (GeoPolygon)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolygon Class : IsEmpty Property
Returns value indicating whether the ExterorRing null or empty.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property IsEmpty As System.Boolean
public override System.bool IsEmpty {get;}
See Also

Reference

GeoPolygon Class
GeoPolygon Members


IsMeasured Property (GeoPolygon)

IsMeasured Property (GeoPolygon)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolygon Class : IsMeasured Property
Returns true if any ring in collection has m-coordinate values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property IsMeasured As System.Boolean
public override System.bool IsMeasured {get;}
See Also

Reference

GeoPolygon Class
GeoPolygon Members


PointsCount Property (GeoPolygon)

PointsCount Property (GeoPolygon)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolygon Class : PointsCount Property
Returns sum of rings points count.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property PointsCount As System.Integer
public override System.int PointsCount {get;}
See Also

Reference

GeoPolygon Class
GeoPolygon Members


Rings Property

Rings Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolygon Class : Rings Property
Gets the polygon rings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Rings As System.Collections.Generic.IEnumerable(Of GeoLinearRing)
public System.Collections.Generic.IEnumerable<GeoLinearRing> Rings {get;}
See Also

Reference

GeoPolygon Class
GeoPolygon Members


GeoPolyhedralSurface Class

GeoPolyhedralSurface Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoPolyhedralSurface Class
Represents the geospatial polyhedral surface.
Object Model
GeoPolyhedralSurface Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class GeoPolyhedralSurface
   Inherits GeoSurface
public class GeoPolyhedralSurface : GeoSurface
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoSurface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolyhedralSurface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoTin

See Also

Reference

GeoPolyhedralSurface Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoPolyhedralSurface Class Members

GeoPolyhedralSurface Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoPolyhedralSurface Class

The following tables list the members exposed by GeoPolyhedralSurface.

Public Constructors
 | Name | Description
Public Constructor | GeoPolyhedralSurface Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Returns the bound of the polyhedral surface.
Public Property | Center | Gets the centroid of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Is3D | Overridden. Returns true if any polygon in collection has z-coordinate values.
Public Property | IsEmpty | Overridden. Returns the value indicating whether the collection is empty or all polygons in collection is empty geometry.
Public Property | IsMeasured | Overridden. Returns true if any polygon in collection has m-coordinate values.
Public Property | PointsCount | Overridden. Returns the sum of the polygon points count.
Public Property | Polygons | Gets the surface polygons.
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoPolyhedralSurface Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoPolyhedralSurface Constructor

GeoPolyhedralSurface Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolyhedralSurface Class : GeoPolyhedralSurface Constructor
Overload List
Overload | Description
GeoPolyhedralSurface Constructor(GeometryType,IEnumerable<GeoPolygon>) | Initializes a new instance of the GeoPolyhedralSurface class.
GeoPolyhedralSurface Constructor(IEnumerable<GeoPolygon>) | Initializes a new instance of the GeoPolyhedralSurface class.
See Also

Reference

GeoPolyhedralSurface Class
GeoPolyhedralSurface Members


GeoPolyhedralSurface Constructor(GeometryType,IEnumerable<GeoPolygon>)

GeoPolyhedralSurface Constructor(GeometryType,IEnumerable<GeoPolygon>)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolyhedralSurface Class > GeoPolyhedralSurface Constructor : GeoPolyhedralSurface Constructor(GeometryType,IEnumerable<GeoPolygon>)
The type.
The polygons.
Initializes a new instance of the GeoPolyhedralSurface class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal type As GeometryType, _
   ByVal polygons As System.Collections.Generic.IEnumerable(Of GeoPolygon) _
)
public GeoPolyhedralSurface(
   GeometryType type,
   System.Collections.Generic.IEnumerable<GeoPolygon> polygons
)

Parameters

type
The type.
polygons
The polygons.
See Also

Reference

GeoPolyhedralSurface Class
GeoPolyhedralSurface Members
Overload List


GeoPolyhedralSurface Constructor(IEnumerable<GeoPolygon>)

GeoPolyhedralSurface Constructor(IEnumerable<GeoPolygon>)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolyhedralSurface Class > GeoPolyhedralSurface Constructor : GeoPolyhedralSurface Constructor(IEnumerable<GeoPolygon>)
The polygons.
Initializes a new instance of the GeoPolyhedralSurface class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal polygons As System.Collections.Generic.IEnumerable(Of GeoPolygon) _
)
public GeoPolyhedralSurface(
   System.Collections.Generic.IEnumerable<GeoPolygon> polygons
)

Parameters

polygons
The polygons.
See Also

Reference

GeoPolyhedralSurface Class
GeoPolyhedralSurface Members
Overload List


GeoPolyhedralSurface Class Properties

GeoPolyhedralSurface Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoPolyhedralSurface Class

For a list of all members of this type, see GeoPolyhedralSurface members.

Public Properties
 | Name | Description
Public Property | Bounds | Overridden. Returns the bound of the polyhedral surface.
Public Property | Center | Gets the centroid of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Is3D | Overridden. Returns true if any polygon in collection has z-coordinate values.
Public Property | IsEmpty | Overridden. Returns the value indicating whether the collection is empty or all polygons in collection is empty geometry.
Public Property | IsMeasured | Overridden. Returns true if any polygon in collection has m-coordinate values.
Public Property | PointsCount | Overridden. Returns the sum of the polygon points count.
Public Property | Polygons | Gets the surface polygons.
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoPolyhedralSurface Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


Bounds Property (GeoPolyhedralSurface)

Bounds Property (GeoPolyhedralSurface)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolyhedralSurface Class : Bounds Property
Returns the bound of the polyhedral surface.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property Bounds As RectangleFEx
public override RectangleFEx Bounds {get;}
See Also

Reference

GeoPolyhedralSurface Class
GeoPolyhedralSurface Members


Is3D Property (GeoPolyhedralSurface)

Is3D Property (GeoPolyhedralSurface)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolyhedralSurface Class : Is3D Property
Returns true if any polygon in collection has z-coordinate values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property Is3D As System.Boolean
public override System.bool Is3D {get;}
See Also

Reference

GeoPolyhedralSurface Class
GeoPolyhedralSurface Members


IsEmpty Property (GeoPolyhedralSurface)

IsEmpty Property (GeoPolyhedralSurface)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolyhedralSurface Class : IsEmpty Property
Returns the value indicating whether the collection is empty or all polygons in collection is empty geometry.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property IsEmpty As System.Boolean
public override System.bool IsEmpty {get;}
See Also

Reference

GeoPolyhedralSurface Class
GeoPolyhedralSurface Members


IsMeasured Property (GeoPolyhedralSurface)

IsMeasured Property (GeoPolyhedralSurface)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolyhedralSurface Class : IsMeasured Property
Returns true if any polygon in collection has m-coordinate values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property IsMeasured As System.Boolean
public override System.bool IsMeasured {get;}
See Also

Reference

GeoPolyhedralSurface Class
GeoPolyhedralSurface Members


PointsCount Property (GeoPolyhedralSurface)

PointsCount Property (GeoPolyhedralSurface)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolyhedralSurface Class : PointsCount Property
Returns the sum of the polygon points count.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property PointsCount As System.Integer
public override System.int PointsCount {get;}
See Also

Reference

GeoPolyhedralSurface Class
GeoPolyhedralSurface Members


Polygons Property (GeoPolyhedralSurface)

Polygons Property (GeoPolyhedralSurface)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolyhedralSurface Class : Polygons Property
Gets the surface polygons.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Polygons As System.Collections.Generic.IEnumerable(Of GeoPolygon)
public System.Collections.Generic.IEnumerable<GeoPolygon> Polygons {get;}
See Also

Reference

GeoPolyhedralSurface Class
GeoPolyhedralSurface Members


GeoShape Class

GeoShape Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoShape Class
Represents geospatial shape base class.
Object Model
GeoShape Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class GeoShape
public abstract class GeoShape
Remarks
Based on Open Geospatial Consortium Simple Feature Access v1.2.1 spec (http://www.opengeospatial.org/standards/sfa).
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoCurve
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPoint
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoSurface

See Also

Reference

GeoShape Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoShape Class Members

GeoShape Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoShape Class

The following tables list the members exposed by GeoShape.

Public Properties
 | Name | Description
Public Property | Bounds | Returns the bounds of the shape.
Public Property | Center | Gets the centroid of the shape.
Public Property | Is3D | Returns true if the shape has z-coordinate values.
Public Property | IsEmpty | Returns the value indicating whether the shape is empty geometry.
Public Property | IsMeasured | Returns true if the shape has m-coordinate values.
Public Property | PointsCount | Returns the number of points used in a shape.
Public Property | Type | Gets the geometry type.
Top
See Also

Reference

GeoShape Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoShape Class Properties

GeoShape Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoShape Class

For a list of all members of this type, see GeoShape members.

Public Properties
 | Name | Description
Public Property | Bounds | Returns the bounds of the shape.
Public Property | Center | Gets the centroid of the shape.
Public Property | Is3D | Returns true if the shape has z-coordinate values.
Public Property | IsEmpty | Returns the value indicating whether the shape is empty geometry.
Public Property | IsMeasured | Returns true if the shape has m-coordinate values.
Public Property | PointsCount | Returns the number of points used in a shape.
Public Property | Type | Gets the geometry type.
Top
See Also

Reference

GeoShape Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


Bounds Property (GeoShape)

Bounds Property (GeoShape)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoShape Class : Bounds Property
Returns the bounds of the shape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Bounds As RectangleFEx
public virtual RectangleFEx Bounds {get;}
See Also

Reference

GeoShape Class
GeoShape Members


Center Property (GeoShape)

Center Property (GeoShape)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoShape Class : Center Property
Gets the centroid of the shape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Center As PointFEx
public virtual PointFEx Center {get;}
See Also

Reference

GeoShape Class
GeoShape Members


Is3D Property (GeoShape)

Is3D Property (GeoShape)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoShape Class : Is3D Property
Returns true if the shape has z-coordinate values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property Is3D As System.Boolean
public abstract System.bool Is3D {get;}
See Also

Reference

GeoShape Class
GeoShape Members


IsEmpty Property (GeoShape)

IsEmpty Property (GeoShape)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoShape Class : IsEmpty Property
Returns the value indicating whether the shape is empty geometry.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property IsEmpty As System.Boolean
public abstract System.bool IsEmpty {get;}
See Also

Reference

GeoShape Class
GeoShape Members


IsMeasured Property (GeoShape)

IsMeasured Property (GeoShape)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoShape Class : IsMeasured Property
Returns true if the shape has m-coordinate values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property IsMeasured As System.Boolean
public abstract System.bool IsMeasured {get;}
See Also

Reference

GeoShape Class
GeoShape Members


PointsCount Property (GeoShape)

PointsCount Property (GeoShape)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoShape Class : PointsCount Property
Returns the number of points used in a shape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property PointsCount As System.Integer
public abstract System.int PointsCount {get;}
See Also

Reference

GeoShape Class
GeoShape Members


Type Property (GeoShape)

Type Property (GeoShape)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoShape Class : Type Property
Gets the geometry type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Type As GeometryType
public GeometryType Type {get;}
See Also

Reference

GeoShape Class
GeoShape Members


GeoSurface Class

GeoSurface Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoSurface Class
Represents the base class for geospatial surface.
Object Model
GeoSurface Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class GeoSurface
   Inherits GeoShape
public abstract class GeoSurface : GeoShape
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoSurface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolyhedralSurface

See Also

Reference

GeoSurface Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoSurface Class Members

GeoSurface Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoSurface Class

The following tables list the members exposed by GeoSurface.

Public Properties
 | Name | Description
Public Property | Bounds | Returns the bounds of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Center | Gets the centroid of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Is3D | Returns true if the shape has z-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | IsEmpty | Returns the value indicating whether the shape is empty geometry. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | IsMeasured | Returns true if the shape has m-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | PointsCount | Returns the number of points used in a shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoSurface Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoTin Class

GeoTin Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoTin Class
Represents the geospatial triangulated irregular network.
Object Model
GeoTin Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class GeoTin
   Inherits GeoPolyhedralSurface
public sealed class GeoTin : GeoPolyhedralSurface
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoSurface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolyhedralSurface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoTin

See Also

Reference

GeoTin Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoTin Class Members

GeoTin Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoTin Class

The following tables list the members exposed by GeoTin.

Public Constructors
 | Name | Description
Public Constructor | GeoTin Constructor | Initializes a new instance of the GeoTin class.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Returns the bound of the polyhedral surface. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolyhedralSurface)
Public Property | Center | Gets the centroid of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Is3D | Returns true if any polygon in collection has z-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolyhedralSurface)
Public Property | IsEmpty | Returns the value indicating whether the collection is empty or all polygons in collection is empty geometry. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolyhedralSurface)
Public Property | IsMeasured | Returns true if any polygon in collection has m-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolyhedralSurface)
Public Property | PointsCount | Returns the sum of the polygon points count. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolyhedralSurface)
Public Property | Polygons | Gets the surface polygons. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolyhedralSurface)
Public Property | Triangles | Gets the tin triangles.
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoTin Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoTin Constructor

GeoTin Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoTin Class : GeoTin Constructor
The triangles.
Initializes a new instance of the GeoTin class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal triangles As System.Collections.Generic.IEnumerable(Of GeoTriangle) _
)
public GeoTin(
   System.Collections.Generic.IEnumerable<GeoTriangle> triangles
)

Parameters

triangles
The triangles.
See Also

Reference

GeoTin Class
GeoTin Members


GeoTin Class Properties

GeoTin Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoTin Class

For a list of all members of this type, see GeoTin members.

Public Properties
 | Name | Description
Public Property | Bounds | Returns the bound of the polyhedral surface. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolyhedralSurface)
Public Property | Center | Gets the centroid of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Is3D | Returns true if any polygon in collection has z-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolyhedralSurface)
Public Property | IsEmpty | Returns the value indicating whether the collection is empty or all polygons in collection is empty geometry. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolyhedralSurface)
Public Property | IsMeasured | Returns true if any polygon in collection has m-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolyhedralSurface)
Public Property | PointsCount | Returns the sum of the polygon points count. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolyhedralSurface)
Public Property | Polygons | Gets the surface polygons. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolyhedralSurface)
Public Property | Triangles | Gets the tin triangles.
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoTin Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


Triangles Property

Triangles Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoTin Class : Triangles Property
Gets the tin triangles.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Triangles As System.Collections.Generic.IEnumerable(Of GeoTriangle)
public System.Collections.Generic.IEnumerable<GeoTriangle> Triangles {get;}
See Also

Reference

GeoTin Class
GeoTin Members


GeoTriangle Class

GeoTriangle Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoTriangle Class
Represents the geospatial triangle shape.
Object Model
GeoTriangle Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class GeoTriangle
   Inherits GeoPolygon
public sealed class GeoTriangle : GeoPolygon
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoSurface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoTriangle

See Also

Reference

GeoTriangle Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoTriangle Class Members

GeoTriangle Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoTriangle Class

The following tables list the members exposed by GeoTriangle.

Public Constructors
 | Name | Description
Public Constructor | GeoTriangle Constructor | Initializes new instance of GeoTriangle.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Returns the bounds of the polygon shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon)
Public Property | Center | Gets the centroid of the polygon shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon)
Public Property | ExteriorRing | Exterior ring of the polygon shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon)
Public Property | InteriorRings | Interior rings of the polygon shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon)
Public Property | Is3D | Returns true if any ring in collection has z-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon)
Public Property | IsEmpty | Returns value indicating whether the ExterorRing null or empty. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon)
Public Property | IsMeasured | Returns true if any ring in collection has m-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon)
Public Property | PointsCount | Returns sum of rings points count. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon)
Public Property | Rings | Gets the polygon rings. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon)
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoTriangle Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoTriangle Constructor

GeoTriangle Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoTriangle Class : GeoTriangle Constructor
The triangle rings.
Initializes new instance of GeoTriangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal rings As System.Collections.Generic.IEnumerable(Of GeoLinearRing) _
)
public GeoTriangle(
   System.Collections.Generic.IEnumerable<GeoLinearRing> rings
)

Parameters

rings
The triangle rings.
See Also

Reference

GeoTriangle Class
GeoTriangle Members


ShapePoint Class

ShapePoint Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : ShapePoint Class
Represents the 2D point.
Object Model
ShapePoint Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ShapePoint
public class ShapePoint
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePoint
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePointM
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePointZ
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePointZM

See Also

Reference

ShapePoint Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


ShapePoint Class Members

ShapePoint Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : ShapePoint Class

The following tables list the members exposed by ShapePoint.

Public Constructors
 | Name | Description
Public Constructor | ShapePoint Constructor | Initializes new instance of ShapePoint.
Top
Public Properties
 | Name | Description
Public Property | X | Gets the X coordinate.
Public Property | Y | Gets the Y coordinate.
Top
See Also

Reference

ShapePoint Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


ShapePoint Constructor

ShapePoint Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > ShapePoint Class : ShapePoint Constructor
The x coordinate value.
The y coordinate value.
Initializes new instance of ShapePoint.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal x As System.Double, _
   ByVal y As System.Double _
)
public ShapePoint(
   System.double x,
   System.double y
)

Parameters

x
The x coordinate value.
y
The y coordinate value.
See Also

Reference

ShapePoint Class
ShapePoint Members


ShapePoint Class Properties

ShapePoint Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : ShapePoint Class

For a list of all members of this type, see ShapePoint members.

Public Properties
 | Name | Description
Public Property | X | Gets the X coordinate.
Public Property | Y | Gets the Y coordinate.
Top
See Also

Reference

ShapePoint Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


X Property (ShapePoint)

X Property (ShapePoint)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > ShapePoint Class : X Property
Gets the X coordinate.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property X As System.Double
public System.double X {get;}
See Also

Reference

ShapePoint Class
ShapePoint Members


Y Property (ShapePoint)

Y Property (ShapePoint)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > ShapePoint Class : Y Property
Gets the Y coordinate.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Y As System.Double
public System.double Y {get;}
See Also

Reference

ShapePoint Class
ShapePoint Members


ShapePointM Class

ShapePointM Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : ShapePointM Class
Represents 2D point with M value.
Object Model
ShapePointM Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ShapePointM
   Inherits ShapePoint
public sealed class ShapePointM : ShapePoint
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePoint
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePointM

See Also

Reference

ShapePointM Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


ShapePointM Class Members

ShapePointM Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : ShapePointM Class

The following tables list the members exposed by ShapePointM.

Public Constructors
 | Name | Description
Public Constructor | ShapePointM Constructor | Initializes new instance of ShapePointM.
Top
Public Properties
 | Name | Description
Public Property | M | Gets the M value.
Public Property | X | Gets the X coordinate. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePoint)
Public Property | Y | Gets the Y coordinate. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePoint)
Top
See Also

Reference

ShapePointM Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


ShapePointM Constructor

ShapePointM Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > ShapePointM Class : ShapePointM Constructor
The x coordinate value.
The y coordinate value.
The m value.
Initializes new instance of ShapePointM.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal x As System.Double, _
   ByVal y As System.Double, _
   ByVal m As System.Double _
)
public ShapePointM(
   System.double x,
   System.double y,
   System.double m
)

Parameters

x
The x coordinate value.
y
The y coordinate value.
m
The m value.
See Also

Reference

ShapePointM Class
ShapePointM Members


ShapePointM Class Properties

ShapePointM Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : ShapePointM Class

For a list of all members of this type, see ShapePointM members.

Public Properties
 | Name | Description
Public Property | M | Gets the M value.
Public Property | X | Gets the X coordinate. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePoint)
Public Property | Y | Gets the Y coordinate. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePoint)
Top
See Also

Reference

ShapePointM Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


M Property (ShapePointM)

M Property (ShapePointM)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > ShapePointM Class : M Property
Gets the M value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property M As System.Double
public System.double M {get;}
See Also

Reference

ShapePointM Class
ShapePointM Members


ShapePointZ Class

ShapePointZ Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : ShapePointZ Class
Represents the 3D point.
Object Model
ShapePointZ Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ShapePointZ
   Inherits ShapePoint
public sealed class ShapePointZ : ShapePoint
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePoint
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePointZ

See Also

Reference

ShapePointZ Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


ShapePointZ Class Members

ShapePointZ Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : ShapePointZ Class

The following tables list the members exposed by ShapePointZ.

Public Constructors
 | Name | Description
Public Constructor | ShapePointZ Constructor | Initializes new instance of ShapePointZ
Top
Public Properties
 | Name | Description
Public Property | X | Gets the X coordinate. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePoint)
Public Property | Y | Gets the Y coordinate. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePoint)
Public Property | Z | Gets the Z coordinate value.
Top
See Also

Reference

ShapePointZ Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


ShapePointZ Constructor

ShapePointZ Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > ShapePointZ Class : ShapePointZ Constructor
The x coordinate value.
The y coordinate value.
The z coordinate value.
Initializes new instance of ShapePointZ
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal x As System.Double, _
   ByVal y As System.Double, _
   ByVal z As System.Double _
)
public ShapePointZ(
   System.double x,
   System.double y,
   System.double z
)

Parameters

x
The x coordinate value.
y
The y coordinate value.
z
The z coordinate value.
See Also

Reference

ShapePointZ Class
ShapePointZ Members


ShapePointZ Class Properties

ShapePointZ Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : ShapePointZ Class

For a list of all members of this type, see ShapePointZ members.

Public Properties
 | Name | Description
Public Property | X | Gets the X coordinate. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePoint)
Public Property | Y | Gets the Y coordinate. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePoint)
Public Property | Z | Gets the Z coordinate value.
Top
See Also

Reference

ShapePointZ Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


Z Property (ShapePointZ)

Z Property (ShapePointZ)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > ShapePointZ Class : Z Property
Gets the Z coordinate value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Z As System.Double
public System.double Z {get;}
See Also

Reference

ShapePointZ Class
ShapePointZ Members


ShapePointZM Class

ShapePointZM Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : ShapePointZM Class
Represents the 3D point with M value.
Object Model
ShapePointZM Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ShapePointZM
   Inherits ShapePoint
public sealed class ShapePointZM : ShapePoint
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePoint
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePointZM

See Also

Reference

ShapePointZM Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


ShapePointZM Class Members

ShapePointZM Class Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : ShapePointZM Class

The following tables list the members exposed by ShapePointZM.

Public Constructors
 | Name | Description
Public Constructor | ShapePointZM Constructor | Initializes new instance of ShapePointZM.
Top
Public Properties
 | Name | Description
Public Property | M | Gets the M value.
Public Property | X | Gets the X coordinate. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePoint)
Public Property | Y | Gets the Y coordinate. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePoint)
Public Property | Z | Gets the Z coordinate value.
Top
See Also

Reference

ShapePointZM Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


ShapePointZM Constructor

ShapePointZM Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > ShapePointZM Class : ShapePointZM Constructor
The x coordinate value.
The y coordinate value.
The z coordinate value.
The m value.
Initializes new instance of ShapePointZM.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal x As System.Double, _
   ByVal y As System.Double, _
   ByVal z As System.Double, _
   ByVal m As System.Double _
)
public ShapePointZM(
   System.double x,
   System.double y,
   System.double z,
   System.double m
)

Parameters

x
The x coordinate value.
y
The y coordinate value.
z
The z coordinate value.
m
The m value.
See Also

Reference

ShapePointZM Class
ShapePointZM Members


ShapePointZM Class Properties

ShapePointZM Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : ShapePointZM Class

For a list of all members of this type, see ShapePointZM members.

Public Properties
 | Name | Description
Public Property | M | Gets the M value.
Public Property | X | Gets the X coordinate. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePoint)
Public Property | Y | Gets the Y coordinate. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePoint)
Public Property | Z | Gets the Z coordinate value.
Top
See Also

Reference

ShapePointZM Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


M Property (ShapePointZM)

M Property (ShapePointZM)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > ShapePointZM Class : M Property
Gets the M value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property M As System.Double
public System.double M {get;}
See Also

Reference

ShapePointZM Class
ShapePointZM Members


Z Property (ShapePointZM)

Z Property (ShapePointZM)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > ShapePointZM Class : Z Property
Gets the Z coordinate value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Z As System.Double
public System.double Z {get;}
See Also

Reference

ShapePointZM Class
ShapePointZM Members


GeometryType Enumeration

GeometryType Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeometryType Enumeration
Defines the geometry types according to OGC Simple Access specification.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum GeometryType
   Inherits System.Enum
public enum GeometryType : System.Enum
Members
Member | Description
CircularString | The CircularString is the basic curve type, similar to a LINESTRING in the linear world. A single segment required three points, the start and end points (first and third) and any other point on the arc.
CompoundCurve | A compound curve is a single, continuous curve that has both curved (circular) segments and linear segments.
Curve | 1-dimensional geometric object usually stored as a sequence of Points.
CurvePolygon | A CurvePolygon is just like a polygon, with an outer ring and zero or more inner rings. The difference is that a ring can take the form of a circular string, linear string or compound string.
GeometryCollection | Geometric object that is a collection of some number of geometric objects.
LineString | Curve with linear interpolation between Points.
MultiCurve | 1-dimensional GeometryCollection whose elements are Curves.
MultiLineString | MultiCurve whose elements are LineStrings.
MultiPoint | 0-dimensional GeometryCollection.
MultiPolygon | MultiSurface whose elements are Polygons.
MultiSurface | 2-dimensional GeometryCollection whose elements are Surfaces.
Point | 0-dimensional geometric object and represents a single location in coordinate space.
Polygon | Planar Surface defined by 1 exterior boundary and 0 or more interior boundaries.
PolyhedralSurface | Contiguous collection of Polygons, which share common boundary segments.
Surface | 2-dimensional geometric object.
Tin | Contiguous collection of Triangles, which share common boundary segments.
Triangle | Special tringle Polygon.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeometryType

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace
The GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix namespace includes the interfaces that are used when creating Matrix.
Classes
 | Class | Description
Class | MatrixGroupingDefinition | Used to define a matrix data grouping.
Interfaces
 | Interface | Description
Interface | IMatrix | Interface for the Matrix object.
Interface | IMatrixCell | Interface for the cell of a matrix
Interface | IMatrixCellCollection | Interface for a collection of matrix cell objects.
Interface | IMatrixMember | Interface for the matrix member.
Interface | IMatrixMemberCollection | Interface for a collection of matrix member objects.
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


MatrixGroupingDefinition Class

MatrixGroupingDefinition Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : MatrixGroupingDefinition Class
Used to define a matrix data grouping.
Object Model
MatrixGroupingDefinition Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class MatrixGroupingDefinition
public class MatrixGroupingDefinition
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix.MatrixGroupingDefinition

See Also

Reference

MatrixGroupingDefinition Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


MatrixGroupingDefinition Class Members

MatrixGroupingDefinition Class Members
Fields

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : MatrixGroupingDefinition Class

The following tables list the members exposed by MatrixGroupingDefinition.

Public Constructors
 | Name | Description
Public Constructor | MatrixGroupingDefinition Constructor | Initializes a new MatrixGroupingDefinition instance
Top
Public Fields
 | Name | Description
Public Field | HasTotal | Indicates whether grouping has total.
Public Field | IsStatic | Indicates if this is a static grouping.
Public Field | Length | The length of the grouping.
Public Field | ToggleItem | Grouping toggle item name.
Top
See Also

Reference

MatrixGroupingDefinition Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


MatrixGroupingDefinition Constructor

MatrixGroupingDefinition Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > MatrixGroupingDefinition Class : MatrixGroupingDefinition Constructor
The length of the grouping.
Indicates if this is a static grouping.
Indicates whether grouping has total.
Grouping toggle item name.
Initializes a new MatrixGroupingDefinition instance
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal length As Length, _
   ByVal isStatic As System.Boolean, _
   ByVal hasTotal As System.Boolean, _
   ByVal toggleItem As System.String _
)
public MatrixGroupingDefinition(
   Length length,
   System.bool isStatic,
   System.bool hasTotal,
   System.string toggleItem
)

Parameters

length
The length of the grouping.
isStatic
Indicates if this is a static grouping.
hasTotal
Indicates whether grouping has total.
toggleItem
Grouping toggle item name.
See Also

Reference

MatrixGroupingDefinition Class
MatrixGroupingDefinition Members


MatrixGroupingDefinition Class Fields

MatrixGroupingDefinition Class Fields

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : MatrixGroupingDefinition Class

For a list of all members of this type, see MatrixGroupingDefinition members.

Public Fields
 | Name | Description
Public Field | HasTotal | Indicates whether grouping has total.
Public Field | IsStatic | Indicates if this is a static grouping.
Public Field | Length | The length of the grouping.
Public Field | ToggleItem | Grouping toggle item name.
Top
See Also

Reference

MatrixGroupingDefinition Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


HasTotal Field

HasTotal Field

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > MatrixGroupingDefinition Class : HasTotal Field
Indicates whether grouping has total.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly HasTotal As System.Boolean
public readonly System.bool HasTotal
See Also

Reference

MatrixGroupingDefinition Class
MatrixGroupingDefinition Members


IsStatic Field

IsStatic Field

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > MatrixGroupingDefinition Class : IsStatic Field
Indicates if this is a static grouping.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly IsStatic As System.Boolean
public readonly System.bool IsStatic
See Also

Reference

MatrixGroupingDefinition Class
MatrixGroupingDefinition Members


Length Field (MatrixGroupingDefinition)

Length Field (MatrixGroupingDefinition)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > MatrixGroupingDefinition Class : Length Field
The length of the grouping.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Length As Length
public readonly Length Length
See Also

Reference

MatrixGroupingDefinition Class
MatrixGroupingDefinition Members


ToggleItem Field

ToggleItem Field

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > MatrixGroupingDefinition Class : ToggleItem Field
Grouping toggle item name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly ToggleItem As System.String
public readonly System.string ToggleItem
See Also

Reference

MatrixGroupingDefinition Class
MatrixGroupingDefinition Members


IMatrix Interface

IMatrix Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrix Interface
Interface for the Matrix object.
Object Model
IMatrix Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMatrix
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion
public interface IMatrix : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion
See Also

Reference

IMatrix Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


IMatrix Interface Members

IMatrix Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrix Interface

The following tables list the members exposed by IMatrix.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | CellCollection | Provides access to the cells in the matrix.
Property | CellColumns | Returns the number of columns in the CellCollection.
Property | CellHeights | Specifies the height of each renderable row in the matrix.
Property | CellRows | Returns the number of rows in the CellCollection.
Property | CellsBeforeRowHeaders | The number of instances of the outermost column group that should appear to the left of the row headers (right of the row headers for RTL matrixes).
Property | CellWidths | Specifies the width of each renderable column in the matrix.
Property | ColumnGroupings | The set of groupings on the column axis for the matrix.
Property | ColumnMemberCollection | Returns a collection of MatrixMember objects or null if there is no column grouping defined.
Property | Columns | Defines the number of columns in this matrix.
Property | Corner | Specifies the ReportItem to be displayed in the upper left corner area for this Matrix instance.
Property | DataCells | Collection of matrix data cells.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataSetName | Specifies which data set to use for this data region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | GroupsBeforeRowHeaders | The number of instances of the outermost column group that should appear to the left of the row headers (right of the row headers for RTL matrixes).
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | LayoutDirection | Indicates whether the matrix columns grow left-to-right (with headers on the left) or right-to-left (with headers on the right).
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | NoRows | Indicates if the DataRegion has no rows available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsMessage | Message to display in the DataRegion when no rows of data are available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsTextBox | Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.Returns a renderable textbox suitable for displaying NoRowsMessage for this instance. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | OverflowName | Overflow name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Gets a value indicating whether the page should break at the end of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | PageBreakAtStart | Gets a value indicating whether the page should break at the start of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RowGroupings | The set of groupings on the row axis for the matrix.
Property | RowMemberCollection | Returns a collection of MatrixMember objects or null if there is no row grouping defined.
Property | Rows | The number of rows in this matrix's definition.
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IMatrix Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


IMatrix Interface Properties

IMatrix Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrix Interface

For a list of all members of this type, see IMatrix members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | CellCollection | Provides access to the cells in the matrix.
Property | CellColumns | Returns the number of columns in the CellCollection.
Property | CellHeights | Specifies the height of each renderable row in the matrix.
Property | CellRows | Returns the number of rows in the CellCollection.
Property | CellsBeforeRowHeaders | The number of instances of the outermost column group that should appear to the left of the row headers (right of the row headers for RTL matrixes).
Property | CellWidths | Specifies the width of each renderable column in the matrix.
Property | ColumnGroupings | The set of groupings on the column axis for the matrix.
Property | ColumnMemberCollection | Returns a collection of MatrixMember objects or null if there is no column grouping defined.
Property | Columns | Defines the number of columns in this matrix.
Property | Corner | Specifies the ReportItem to be displayed in the upper left corner area for this Matrix instance.
Property | DataCells | Collection of matrix data cells.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataSetName | Specifies which data set to use for this data region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | GroupsBeforeRowHeaders | The number of instances of the outermost column group that should appear to the left of the row headers (right of the row headers for RTL matrixes).
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | LayoutDirection | Indicates whether the matrix columns grow left-to-right (with headers on the left) or right-to-left (with headers on the right).
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | NoRows | Indicates if the DataRegion has no rows available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsMessage | Message to display in the DataRegion when no rows of data are available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsTextBox | Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.Returns a renderable textbox suitable for displaying NoRowsMessage for this instance. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | OverflowName | Overflow name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Gets a value indicating whether the page should break at the end of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | PageBreakAtStart | Gets a value indicating whether the page should break at the start of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RowGroupings | The set of groupings on the row axis for the matrix.
Property | RowMemberCollection | Returns a collection of MatrixMember objects or null if there is no row grouping defined.
Property | Rows | The number of rows in this matrix's definition.
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IMatrix Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


CellCollection Property

CellCollection Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : CellCollection Property
Provides access to the cells in the matrix.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CellCollection As IMatrixCellCollection
IMatrixCellCollection CellCollection {get;}
See Also

Reference

IMatrix Interface
IMatrix Members


CellColumns Property

CellColumns Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : CellColumns Property
Returns the number of columns in the CellCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CellColumns As System.Integer
System.int CellColumns {get;}
See Also

Reference

IMatrix Interface
IMatrix Members


CellHeights Property

CellHeights Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : CellHeights Property
Specifies the height of each renderable row in the matrix.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CellHeights As System.Collections.Generic.IList(Of Length)
System.Collections.Generic.IList<Length> CellHeights {get;}
See Also

Reference

IMatrix Interface
IMatrix Members


CellRows Property

CellRows Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : CellRows Property
Returns the number of rows in the CellCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CellRows As System.Integer
System.int CellRows {get;}
See Also

Reference

IMatrix Interface
IMatrix Members


CellsBeforeRowHeaders Property

CellsBeforeRowHeaders Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : CellsBeforeRowHeaders Property
The number of instances of the outermost column group that should appear to the left of the row headers (right of the row headers for RTL matrixes).
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CellsBeforeRowHeaders As System.Integer
System.int CellsBeforeRowHeaders {get;}
See Also

Reference

IMatrix Interface
IMatrix Members


CellWidths Property

CellWidths Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : CellWidths Property
Specifies the width of each renderable column in the matrix.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CellWidths As System.Collections.Generic.IList(Of Length)
System.Collections.Generic.IList<Length> CellWidths {get;}
See Also

Reference

IMatrix Interface
IMatrix Members


ColumnGroupings Property (IMatrix)

ColumnGroupings Property (IMatrix)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : ColumnGroupings Property
The set of groupings on the column axis for the matrix.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ColumnGroupings As System.Collections.Generic.IList(Of MatrixGroupingDefinition)
System.Collections.Generic.IList<MatrixGroupingDefinition> ColumnGroupings {get;}
See Also

Reference

IMatrix Interface
IMatrix Members


ColumnMemberCollection Property

ColumnMemberCollection Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : ColumnMemberCollection Property
Returns a collection of MatrixMember objects or null if there is no column grouping defined.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ColumnMemberCollection As IMatrixMemberCollection
IMatrixMemberCollection ColumnMemberCollection {get;}
See Also

Reference

IMatrix Interface
IMatrix Members


Columns Property (IMatrix)

Columns Property (IMatrix)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : Columns Property
Defines the number of columns in this matrix.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Columns As System.Integer
System.int Columns {get;}
See Also

Reference

IMatrix Interface
IMatrix Members


Corner Property (IMatrix)

Corner Property (IMatrix)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : Corner Property
Specifies the ReportItem to be displayed in the upper left corner area for this Matrix instance.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Corner As IReportItem
IReportItem Corner {get;}
See Also

Reference

IMatrix Interface
IMatrix Members


DataCells Property (IMatrix)

DataCells Property (IMatrix)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : DataCells Property
Collection of matrix data cells.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataCells As IMatrixCellCollection
IMatrixCellCollection DataCells {get;}
See Also

Reference

IMatrix Interface
IMatrix Members


GroupsBeforeRowHeaders Property (IMatrix)

GroupsBeforeRowHeaders Property (IMatrix)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : GroupsBeforeRowHeaders Property
The number of instances of the outermost column group that should appear to the left of the row headers (right of the row headers for RTL matrixes).
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property GroupsBeforeRowHeaders As System.Integer
System.int GroupsBeforeRowHeaders {get;}
See Also

Reference

IMatrix Interface
IMatrix Members


LayoutDirection Property (IMatrix)

LayoutDirection Property (IMatrix)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : LayoutDirection Property
Indicates whether the matrix columns grow left-to-right (with headers on the left) or right-to-left (with headers on the right).
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property LayoutDirection As LayoutDirection
LayoutDirection LayoutDirection {get;}
See Also

Reference

IMatrix Interface
IMatrix Members


RowGroupings Property (IMatrix)

RowGroupings Property (IMatrix)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : RowGroupings Property
The set of groupings on the row axis for the matrix.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RowGroupings As System.Collections.Generic.IList(Of MatrixGroupingDefinition)
System.Collections.Generic.IList<MatrixGroupingDefinition> RowGroupings {get;}
See Also

Reference

IMatrix Interface
IMatrix Members


RowMemberCollection Property

RowMemberCollection Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : RowMemberCollection Property
Returns a collection of MatrixMember objects or null if there is no row grouping defined.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RowMemberCollection As IMatrixMemberCollection
IMatrixMemberCollection RowMemberCollection {get;}
See Also

Reference

IMatrix Interface
IMatrix Members


Rows Property (IMatrix)

Rows Property (IMatrix)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : Rows Property
The number of rows in this matrix's definition.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Rows As System.Integer
System.int Rows {get;}
See Also

Reference

IMatrix Interface
IMatrix Members


IMatrixCell Interface

IMatrixCell Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrixCell Interface
Interface for the cell of a matrix
Object Model
IMatrixCell Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMatrixCell
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemContainer
public interface IMatrixCell : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemContainer
See Also

Reference

IMatrixCell Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


IMatrixCell Interface Members

IMatrixCell Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrixCell Interface

The following tables list the members exposed by IMatrixCell.

Public Properties
 | Name | Description
Property | CellLabel | Gets the cell's label.
Property | DataElementName | Gets the name of the data element.
Property | DataElementOutput | Gets the output of the data element.
Property | Height | Gets the cell height.
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | ReportItem | Gets the report item.
Property | ReportItems | Returns the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem objects in this container. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemContainer)
Property | Width | Gets the cell width.
Top
Public Methods
 | Name | Description
Method | GetService | (Inherited from System.IServiceProvider)
Top
See Also

Reference

IMatrixCell Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


IMatrixCell Interface Properties

IMatrixCell Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrixCell Interface

For a list of all members of this type, see IMatrixCell members.

Public Properties
 | Name | Description
Property | CellLabel | Gets the cell's label.
Property | DataElementName | Gets the name of the data element.
Property | DataElementOutput | Gets the output of the data element.
Property | Height | Gets the cell height.
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | ReportItem | Gets the report item.
Property | ReportItems | Returns the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem objects in this container. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemContainer)
Property | Width | Gets the cell width.
Top
See Also

Reference

IMatrixCell Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


CellLabel Property

CellLabel Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixCell Interface : CellLabel Property
Gets the cell's label.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CellLabel As System.String
System.string CellLabel {get;}
See Also

Reference

IMatrixCell Interface
IMatrixCell Members


DataElementName Property (IMatrixCell)

DataElementName Property (IMatrixCell)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixCell Interface : DataElementName Property
Gets the name of the data element.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataElementName As System.String
System.string DataElementName {get;}
See Also

Reference

IMatrixCell Interface
IMatrixCell Members


DataElementOutput Property (IMatrixCell)

DataElementOutput Property (IMatrixCell)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixCell Interface : DataElementOutput Property
Gets the output of the data element.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataElementOutput As DataElementOutput
DataElementOutput DataElementOutput {get;}
See Also

Reference

IMatrixCell Interface
IMatrixCell Members


Height Property (IMatrixCell)

Height Property (IMatrixCell)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixCell Interface : Height Property
Gets the cell height.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Height As Length
Length Height {get;}
See Also

Reference

IMatrixCell Interface
IMatrixCell Members


ReportItem Property (IMatrixCell)

ReportItem Property (IMatrixCell)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixCell Interface : ReportItem Property
Gets the report item.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ReportItem As IReportItem
IReportItem ReportItem {get;}
See Also

Reference

IMatrixCell Interface
IMatrixCell Members


Width Property (IMatrixCell)

Width Property (IMatrixCell)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixCell Interface : Width Property
Gets the cell width.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Width As Length
Length Width {get;}
See Also

Reference

IMatrixCell Interface
IMatrixCell Members


IMatrixCellCollection Interface

IMatrixCellCollection Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrixCellCollection Interface
Interface for a collection of matrix cell objects.
Object Model
IMatrixCellCollection Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMatrixCellCollection
public interface IMatrixCellCollection
See Also

Reference

IMatrixCellCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


IMatrixCellCollection Interface Members

IMatrixCellCollection Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrixCellCollection Interface

The following tables list the members exposed by IMatrixCellCollection.

Public Properties
 | Name | Description
Property | ColumnCount | Gets a count of the number of columns rendered.
Property | Count | Gets a count of the number of cells rendered.
Property | Item | Gets a matrix cell by the specified row and column index.
Property | RowCount | Gets a count of the number of rows rendered.
Top
See Also

Reference

IMatrixCellCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


IMatrixCellCollection Interface Properties

IMatrixCellCollection Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrixCellCollection Interface

For a list of all members of this type, see IMatrixCellCollection members.

Public Properties
 | Name | Description
Property | ColumnCount | Gets a count of the number of columns rendered.
Property | Count | Gets a count of the number of cells rendered.
Property | Item | Gets a matrix cell by the specified row and column index.
Property | RowCount | Gets a count of the number of rows rendered.
Top
See Also

Reference

IMatrixCellCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


ColumnCount Property (IMatrixCellCollection)

ColumnCount Property (IMatrixCellCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixCellCollection Interface : ColumnCount Property
Gets a count of the number of columns rendered.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ColumnCount As System.Integer
System.int ColumnCount {get;}
See Also

Reference

IMatrixCellCollection Interface
IMatrixCellCollection Members


Count Property (IMatrixCellCollection)

Count Property (IMatrixCellCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixCellCollection Interface : Count Property
Gets a count of the number of cells rendered.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Count As System.Integer
System.int Count {get;}
See Also

Reference

IMatrixCellCollection Interface
IMatrixCellCollection Members


Item Property (IMatrixCellCollection)

Item Property (IMatrixCellCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixCellCollection Interface : Item Property

The number of the row in the matrix from which to retrieve the matrix cell.

The number of the column in the matrix from which to retrieve the matrix cell.

Gets a matrix cell by the specified row and column index.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Default Property Item( _
   ByVal row As System.Integer, _
   ByVal column As System.Integer _
) As IMatrixCell
IMatrixCell this[
   System.int row,
   System.int column
]; {get;}

Parameters

row

The number of the row in the matrix from which to retrieve the matrix cell.

column

The number of the column in the matrix from which to retrieve the matrix cell.

See Also

Reference

IMatrixCellCollection Interface
IMatrixCellCollection Members


RowCount Property (IMatrixCellCollection)

RowCount Property (IMatrixCellCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixCellCollection Interface : RowCount Property
Gets a count of the number of rows rendered.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RowCount As System.Integer
System.int RowCount {get;}
See Also

Reference

IMatrixCellCollection Interface
IMatrixCellCollection Members


IMatrixMember Interface

IMatrixMember Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrixMember Interface
Interface for the matrix member.
Object Model
IMatrixMember Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMatrixMember
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion, GrapeCity.ActiveReports.Extensibility.Rendering.IGroup
public interface IMatrixMember : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion, GrapeCity.ActiveReports.Extensibility.Rendering.IGroup
See Also

Reference

IMatrixMember Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


IMatrixMember Interface Members

IMatrixMember Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrixMember Interface

The following tables list the members exposed by IMatrixMember.

Public Properties
 | Name | Description
Property | AllChildren | Returns all child data members including all subtotals and hidden members. The contents of this collection will not change based on toggle/hidden state.
Property | Children | Returns the collection of child group members for the inner hierarchy or null if this member is the inner-most leaf grouping.
Property | ColumnSpan | Returns the number of columns this member's heading spans.
Property | Custom | String of custom data. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | CustomProperties | Collection of custom properties. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | DataCollectionName | Returns the name of the data collection associated with this group. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | DataElementName | Returns the name of the data element associated with this group. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | DataElementOutput | Returns the name used for this group. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | DataMemberId | Returns the id of the data member.
Property | GroupingIndex | Returns a grouping index.
Property | Height | Specifies the height of this member from the report definition.
Property | Hidden | Indicates that the group should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | IsStatic | Determines if this is a member of a static grouping.
Property | IsTotal | Determines if this is a subtotal member.
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | LabelValue | Gets the value representing the label for this member. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | MemberCellIndex | Determines the index into the Matrix.CellCollection for this member's axis.
Property | Name | Returns the name used for this group. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | PageBreakAtEnd | Indicates the report should page break at end of the group. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | PageBreakAtStart | Indicates the report should page break at start of the group. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | Parent | Returns the parent group of this group member or null if this is the outer most group.
Property | ReportItem | The ReportItem displayed in the header area.
Property | RowSpan | Returns the number of rows this member's heading spans.
Property | StaticIndex | Returns the index of this member within its static grouping. If this member is not a member of a static grouping, then it's parents will be checked. If any parent is a StaticMember, it's StaticIndex value will be returned. If there are no static ancestors, then zero is returned.
Property | Width | Specifies the width of this member from the report definition.
Top
See Also

Reference

IMatrixMember Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


IMatrixMember Interface Properties

IMatrixMember Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrixMember Interface

For a list of all members of this type, see IMatrixMember members.

Public Properties
 | Name | Description
Property | AllChildren | Returns all child data members including all subtotals and hidden members. The contents of this collection will not change based on toggle/hidden state.
Property | Children | Returns the collection of child group members for the inner hierarchy or null if this member is the inner-most leaf grouping.
Property | ColumnSpan | Returns the number of columns this member's heading spans.
Property | Custom | String of custom data. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | CustomProperties | Collection of custom properties. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | DataCollectionName | Returns the name of the data collection associated with this group. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | DataElementName | Returns the name of the data element associated with this group. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | DataElementOutput | Returns the name used for this group. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | DataMemberId | Returns the id of the data member.
Property | GroupingIndex | Returns a grouping index.
Property | Height | Specifies the height of this member from the report definition.
Property | Hidden | Indicates that the group should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | IsStatic | Determines if this is a member of a static grouping.
Property | IsTotal | Determines if this is a subtotal member.
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | LabelValue | Gets the value representing the label for this member. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | MemberCellIndex | Determines the index into the Matrix.CellCollection for this member's axis.
Property | Name | Returns the name used for this group. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | PageBreakAtEnd | Indicates the report should page break at end of the group. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | PageBreakAtStart | Indicates the report should page break at start of the group. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IGroup)
Property | Parent | Returns the parent group of this group member or null if this is the outer most group.
Property | ReportItem | The ReportItem displayed in the header area.
Property | RowSpan | Returns the number of rows this member's heading spans.
Property | StaticIndex | Returns the index of this member within its static grouping. If this member is not a member of a static grouping, then it's parents will be checked. If any parent is a StaticMember, it's StaticIndex value will be returned. If there are no static ancestors, then zero is returned.
Property | Width | Specifies the width of this member from the report definition.
Top
See Also

Reference

IMatrixMember Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


AllChildren Property

AllChildren Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : AllChildren Property
Returns all child data members including all subtotals and hidden members. The contents of this collection will not change based on toggle/hidden state.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property AllChildren As IMatrixMemberCollection
IMatrixMemberCollection AllChildren {get;}
See Also

Reference

IMatrixMember Interface
IMatrixMember Members


Children Property (IMatrixMember)

Children Property (IMatrixMember)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : Children Property
Returns the collection of child group members for the inner hierarchy or null if this member is the inner-most leaf grouping.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Children As IMatrixMemberCollection
IMatrixMemberCollection Children {get;}
See Also

Reference

IMatrixMember Interface
IMatrixMember Members


ColumnSpan Property (IMatrixMember)

ColumnSpan Property (IMatrixMember)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : ColumnSpan Property
Returns the number of columns this member's heading spans.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ColumnSpan As System.Integer
System.int ColumnSpan {get;}
Remarks
Only valid if this is a member of a grouping on the row axis.
See Also

Reference

IMatrixMember Interface
IMatrixMember Members


DataMemberId Property

DataMemberId Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : DataMemberId Property
Returns the id of the data member.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataMemberId As System.Integer
System.int DataMemberId {get;}
See Also

Reference

IMatrixMember Interface
IMatrixMember Members


GroupingIndex Property

GroupingIndex Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : GroupingIndex Property
Returns a grouping index.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property GroupingIndex As System.Integer
System.int GroupingIndex {get;}
See Also

Reference

IMatrixMember Interface
IMatrixMember Members


Height Property (IMatrixMember)

Height Property (IMatrixMember)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : Height Property
Specifies the height of this member from the report definition.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Height As Length
Length Height {get;}
Remarks
Only valid for members of a grouping on the column axis.
See Also

Reference

IMatrixMember Interface
IMatrixMember Members


IsStatic Property (IMatrixMember)

IsStatic Property (IMatrixMember)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : IsStatic Property
Determines if this is a member of a static grouping.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property IsStatic As System.Boolean
System.bool IsStatic {get;}
See Also

Reference

IMatrixMember Interface
IMatrixMember Members


IsTotal Property (IMatrixMember)

IsTotal Property (IMatrixMember)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : IsTotal Property
Determines if this is a subtotal member.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property IsTotal As System.Boolean
System.bool IsTotal {get;}
See Also

Reference

IMatrixMember Interface
IMatrixMember Members


MemberCellIndex Property (IMatrixMember)

MemberCellIndex Property (IMatrixMember)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : MemberCellIndex Property
Determines the index into the Matrix.CellCollection for this member's axis.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MemberCellIndex As System.Integer
System.int MemberCellIndex {get;}
Remarks
If this member is on the column axis, MemberCellIndex is a cell column index. If this member is on the row axis, MemberCellIndex is a cell row index.
See Also

Reference

IMatrixMember Interface
IMatrixMember Members


Parent Property (IMatrixMember)

Parent Property (IMatrixMember)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : Parent Property
Returns the parent group of this group member or null if this is the outer most group.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Parent As IMatrixMember
IMatrixMember Parent {get;}
See Also

Reference

IMatrixMember Interface
IMatrixMember Members


ReportItem Property (IMatrixMember)

ReportItem Property (IMatrixMember)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : ReportItem Property
The ReportItem displayed in the header area.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ReportItem As IReportItem
IReportItem ReportItem {get;}
See Also

Reference

IMatrixMember Interface
IMatrixMember Members


RowSpan Property (IMatrixMember)

RowSpan Property (IMatrixMember)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : RowSpan Property
Returns the number of rows this member's heading spans.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RowSpan As System.Integer
System.int RowSpan {get;}
Remarks
Only valid if this is a member of a grouping on the column axis.
See Also

Reference

IMatrixMember Interface
IMatrixMember Members


StaticIndex Property

StaticIndex Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : StaticIndex Property
Returns the index of this member within its static grouping. If this member is not a member of a static grouping, then it's parents will be checked. If any parent is a StaticMember, it's StaticIndex value will be returned. If there are no static ancestors, then zero is returned.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property StaticIndex As System.Integer
System.int StaticIndex {get;}
See Also

Reference

IMatrixMember Interface
IMatrixMember Members


Width Property (IMatrixMember)

Width Property (IMatrixMember)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMember Interface : Width Property
Specifies the width of this member from the report definition.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Width As Length
Length Width {get;}
Remarks
Only valid for members of a grouping on the row axis.
See Also

Reference

IMatrixMember Interface
IMatrixMember Members


IMatrixMemberCollection Interface

IMatrixMemberCollection Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrixMemberCollection Interface
Interface for a collection of matrix member objects.
Object Model
IMatrixMemberCollection Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMatrixMemberCollection
public interface IMatrixMemberCollection
See Also

Reference

IMatrixMemberCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


IMatrixMemberCollection Interface Members

IMatrixMemberCollection Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrixMemberCollection Interface

The following tables list the members exposed by IMatrixMemberCollection.

Public Properties
 | Name | Description
Property | Count | Gets the number of elements in this collection.
Property | Item |
Top
Public Methods
 | Name | Description
Method | GetIndexOf | Returns the index of specified matrix member in collection.
Top
See Also

Reference

IMatrixMemberCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


IMatrixMemberCollection Interface Methods

IMatrixMemberCollection Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrixMemberCollection Interface

For a list of all members of this type, see IMatrixMemberCollection members.

Public Methods
 | Name | Description
Method | GetIndexOf | Returns the index of specified matrix member in collection.
Top
See Also

Reference

IMatrixMemberCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


GetIndexOf Method

GetIndexOf Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMemberCollection Interface : GetIndexOf Method
Matrix member to get index of
Returns the index of specified matrix member in collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetIndexOf( _
   ByVal member As IMatrixMember _
) As System.Integer
System.int GetIndexOf(
   IMatrixMember member
)

Parameters

member
Matrix member to get index of

Return Value

The index of the specified matrix member.
See Also

Reference

IMatrixMemberCollection Interface
IMatrixMemberCollection Members


IMatrixMemberCollection Interface Properties

IMatrixMemberCollection Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrixMemberCollection Interface

For a list of all members of this type, see IMatrixMemberCollection members.

Public Properties
 | Name | Description
Property | Count | Gets the number of elements in this collection.
Property | Item |
Top
See Also

Reference

IMatrixMemberCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


Count Property (IMatrixMemberCollection)

Count Property (IMatrixMemberCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMemberCollection Interface : Count Property
Gets the number of elements in this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Count As System.Integer
System.int Count {get;}
See Also

Reference

IMatrixMemberCollection Interface
IMatrixMemberCollection Members


Item Property (IMatrixMemberCollection)

Item Property (IMatrixMemberCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixMemberCollection Interface : Item Property
The index of the element to get.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As IMatrixMember
IMatrixMember this[
   System.int index
]; {get;}

Parameters

index
The index of the element to get.

Property Value

The MatrixMember at the specified index.
See Also

Reference

IMatrixMemberCollection Interface
IMatrixMemberCollection Members


GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace
The GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table namespace includes the interfaces that are used when creating Table.
Interfaces
 | Interface | Description
Interface | ITable | Interface for Table rendering component.
Interface | ITableCell | Interface for table cells.
Interface | ITableCellCollection | Interface for a collection of table cell objects.
Interface | ITableColumn | Interface for a table column.
Interface | ITableColumnCollection | Interface for a collection of table column objects.
Interface | ITableDetail | Interface for a table detail object.
Interface | ITableDetailCollection | Interface for a collection of table detail objects.
Interface | ITableGroup | Interface for table group objects.
Interface | ITableGroupCollection | Represents a collection of ITableGroup objects.
Interface | ITableHeaderFooterRows | Interface for table header or footer row objects.
Interface | ITableRow | Interface for a table row object.
Interface | ITableRowCollection | Interface for a collection of table row objects.
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


ITable Interface

ITable Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITable Interface
Interface for Table rendering component.
Object Model
ITable Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITable
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion
public interface ITable : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion
See Also

Reference

ITable Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITable Interface Members

ITable Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITable Interface

The following tables list the members exposed by ITable.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | CanGrowHorizontally | Determines if table content can grow horizontally
Property | Columns | Returns ITableColumn collection for this table instance.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataSetName | Specifies which data set to use for this data region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | DetailDataCollectionName | The name that data oriented rendering extensions should use for the collection of all instances of the table's details.
Property | DetailDataElementName | The name that data oriented rendering extensions should use for each detail instance of the table.
Property | DetailDataElementOutput | Indicates whether the details should appear in a data rendering. Valid values are GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.NoOutput and GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.Output.
Property | Details | Defines details rows for this table.
Property | Footer | Gets the table's footer.
Property | Header | Gets the table's header.
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | NewGroupingSection | A Boolean value indicating whether the grouping is in it's own section.
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | NoRows | Indicates if the DataRegion has no rows available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsMessage | Message to display in the DataRegion when no rows of data are available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsTextBox | Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.Returns a renderable textbox suitable for displaying NoRowsMessage for this instance. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | OverflowName | Overflow name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Gets a value indicating whether the page should break at the end of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | PageBreakAtStart | Gets a value indicating whether the page should break at the start of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | PreventOrphanedFooter | Indicates whether the last detailed row will be printed along with the footer in order to prevent orphaned footer on the next page.
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RepeatToFill | Value indicating whether a Table should fill the space with empty rows to reach its FixedHeight. Applicable to FPL reports only.
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TableGroups | The instances of each of the subsequent groupings defined by the table are accessible via each group instance's TableGroup.SubGroups property.
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

ITable Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITable Interface Properties

ITable Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITable Interface

For a list of all members of this type, see ITable members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | CanGrowHorizontally | Determines if table content can grow horizontally
Property | Columns | Returns ITableColumn collection for this table instance.
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataSetName | Specifies which data set to use for this data region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | DetailDataCollectionName | The name that data oriented rendering extensions should use for the collection of all instances of the table's details.
Property | DetailDataElementName | The name that data oriented rendering extensions should use for each detail instance of the table.
Property | DetailDataElementOutput | Indicates whether the details should appear in a data rendering. Valid values are GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.NoOutput and GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.Output.
Property | Details | Defines details rows for this table.
Property | Footer | Gets the table's footer.
Property | Header | Gets the table's header.
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | NewGroupingSection | A Boolean value indicating whether the grouping is in it's own section.
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | NoRows | Indicates if the DataRegion has no rows available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsMessage | Message to display in the DataRegion when no rows of data are available. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | NoRowsTextBox | Returns a renderable textbox suitable for displaying NoRowsMessage for this instance.Returns a renderable textbox suitable for displaying NoRowsMessage for this instance. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDataRegion)
Property | OverflowName | Overflow name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IOverflowItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | PageBreakAtEnd | Gets a value indicating whether the page should break at the end of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | PageBreakAtStart | Gets a value indicating whether the page should break at the start of the region. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IPageRegion)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | PreventOrphanedFooter | Indicates whether the last detailed row will be printed along with the footer in order to prevent orphaned footer on the next page.
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RepeatToFill | Value indicating whether a Table should fill the space with empty rows to reach its FixedHeight. Applicable to FPL reports only.
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TableGroups | The instances of each of the subsequent groupings defined by the table are accessible via each group instance's TableGroup.SubGroups property.
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

ITable Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


CanGrowHorizontally Property (ITable)

CanGrowHorizontally Property (ITable)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : CanGrowHorizontally Property
Determines if table content can grow horizontally
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CanGrowHorizontally As System.Boolean
System.bool CanGrowHorizontally {get;}
See Also

Reference

ITable Interface
ITable Members


Columns Property (ITable)

Columns Property (ITable)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : Columns Property
Returns ITableColumn collection for this table instance.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Columns As ITableColumnCollection
ITableColumnCollection Columns {get;}
See Also

Reference

ITable Interface
ITable Members


DetailDataCollectionName Property (ITable)

DetailDataCollectionName Property (ITable)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : DetailDataCollectionName Property
The name that data oriented rendering extensions should use for the collection of all instances of the table's details.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DetailDataCollectionName As System.String
System.string DetailDataCollectionName {get;}
See Also

Reference

ITable Interface
ITable Members


DetailDataElementName Property (ITable)

DetailDataElementName Property (ITable)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : DetailDataElementName Property
The name that data oriented rendering extensions should use for each detail instance of the table.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DetailDataElementName As System.String
System.string DetailDataElementName {get;}
See Also

Reference

ITable Interface
ITable Members


DetailDataElementOutput Property (ITable)

DetailDataElementOutput Property (ITable)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : DetailDataElementOutput Property
Indicates whether the details should appear in a data rendering. Valid values are GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.NoOutput and GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.Output.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DetailDataElementOutput As DataElementOutput
DataElementOutput DetailDataElementOutput {get;}
See Also

Reference

ITable Interface
ITable Members


Details Property (ITable)

Details Property (ITable)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : Details Property
Defines details rows for this table.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Details As ITableDetailCollection
ITableDetailCollection Details {get;}
See Also

Reference

ITable Interface
ITable Members


Footer Property (ITable)

Footer Property (ITable)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : Footer Property
Gets the table's footer.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Footer As ITableHeaderFooterRows
ITableHeaderFooterRows Footer {get;}
See Also

Reference

ITable Interface
ITable Members


Header Property (ITable)

Header Property (ITable)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : Header Property
Gets the table's header.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Header As ITableHeaderFooterRows
ITableHeaderFooterRows Header {get;}
See Also

Reference

ITable Interface
ITable Members


NewGroupingSection Property

NewGroupingSection Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : NewGroupingSection Property
A Boolean value indicating whether the grouping is in it's own section.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property NewGroupingSection As System.Boolean
System.bool NewGroupingSection {get;}
See Also

Reference

ITable Interface
ITable Members


PreventOrphanedFooter Property (ITable)

PreventOrphanedFooter Property (ITable)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : PreventOrphanedFooter Property
Indicates whether the last detailed row will be printed along with the footer in order to prevent orphaned footer on the next page.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PreventOrphanedFooter As System.Boolean
System.bool PreventOrphanedFooter {get;}
See Also

Reference

ITable Interface
ITable Members


RepeatToFill Property (ITable)

RepeatToFill Property (ITable)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : RepeatToFill Property
Value indicating whether a Table should fill the space with empty rows to reach its FixedHeight. Applicable to FPL reports only.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RepeatToFill As System.Boolean
System.bool RepeatToFill {get;}
See Also

Reference

ITable Interface
ITable Members


TableGroups Property (ITable)

TableGroups Property (ITable)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : TableGroups Property
The instances of each of the subsequent groupings defined by the table are accessible via each group instance's TableGroup.SubGroups property.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TableGroups As ITableGroupCollection
ITableGroupCollection TableGroups {get;}
Remarks
The instances of each of the subsequent groupings defined by the table are accessible via each group instance's TableGroup.SubGroups property.
See Also

Reference

ITable Interface
ITable Members


ITableCell Interface

ITableCell Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableCell Interface
Interface for table cells.
Object Model
ITableCell Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITableCell
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemContainer
public interface ITableCell : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemContainer
See Also

Reference

ITableCell Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableCell Interface Members

ITableCell Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableCell Interface

The following tables list the members exposed by ITableCell.

Public Properties
 | Name | Description
Property | ColSpan | Specifies the number of columns that table cell spans.
Property | Height | Specifies the table cell height.
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | ParentRow | Specifies the row containing this cell.
Property | ParentTable | Specifies the table containing this cell.
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | ReportItems | Returns the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem objects in this container. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemContainer)
Property | SpanWidth | Specifies the table cell span width.
Property | StartColumn | Specifies the first column in the span.
Top
Public Methods
 | Name | Description
Method | GetService | (Inherited from System.IServiceProvider)
Top
See Also

Reference

ITableCell Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableCell Interface Properties

ITableCell Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableCell Interface

For a list of all members of this type, see ITableCell members.

Public Properties
 | Name | Description
Property | ColSpan | Specifies the number of columns that table cell spans.
Property | Height | Specifies the table cell height.
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | ParentRow | Specifies the row containing this cell.
Property | ParentTable | Specifies the table containing this cell.
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | ReportItems | Returns the GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem objects in this container. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItemContainer)
Property | SpanWidth | Specifies the table cell span width.
Property | StartColumn | Specifies the first column in the span.
Top
See Also

Reference

ITableCell Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ColSpan Property (ITableCell)

ColSpan Property (ITableCell)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableCell Interface : ColSpan Property
Specifies the number of columns that table cell spans.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ColSpan As System.Integer
System.int ColSpan {get;}
See Also

Reference

ITableCell Interface
ITableCell Members


Height Property (ITableCell)

Height Property (ITableCell)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableCell Interface : Height Property
Specifies the table cell height.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Height As Length
Length Height {get;}
See Also

Reference

ITableCell Interface
ITableCell Members


ParentRow Property

ParentRow Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableCell Interface : ParentRow Property
Specifies the row containing this cell.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ParentRow As ITableRow
ITableRow ParentRow {get;}
See Also

Reference

ITableCell Interface
ITableCell Members


ParentTable Property

ParentTable Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableCell Interface : ParentTable Property
Specifies the table containing this cell.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ParentTable As ITable
ITable ParentTable {get;}
See Also

Reference

ITableCell Interface
ITableCell Members


SpanWidth Property

SpanWidth Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableCell Interface : SpanWidth Property
Specifies the table cell span width.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property SpanWidth As System.Single
System.float SpanWidth {get;}
See Also

Reference

ITableCell Interface
ITableCell Members


StartColumn Property

StartColumn Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableCell Interface : StartColumn Property
Specifies the first column in the span.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property StartColumn As System.Integer
System.int StartColumn {get;}
See Also

Reference

ITableCell Interface
ITableCell Members


ITableCellCollection Interface

ITableCellCollection Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableCellCollection Interface
Interface for a collection of table cell objects.
Object Model
ITableCellCollection Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITableCellCollection
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection(Of ITableCell)
public interface ITableCellCollection : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableCell>
See Also

Reference

ITableCellCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableCellCollection Interface Members

ITableCellCollection Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableCellCollection Interface

The following tables list the members exposed by ITableCellCollection.

Public Properties
 | Name | Description
Property | Count | Gets number of items in the collection. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableCell>)
Property | Item | Gets the T at the specified index. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableCell>)
Top
See Also

Reference

ITableCellCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableColumn Interface

ITableColumn Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableColumn Interface
Interface for a table column.
Object Model
ITableColumn Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITableColumn
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver
public interface ITableColumn : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver
See Also

Reference

ITableColumn Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableColumn Interface Members

ITableColumn Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableColumn Interface

The following tables list the members exposed by ITableColumn.

Public Properties
 | Name | Description
Property | Hidden | Indicates whether the item should be visible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | OwnHidden | Indicates that own hidden state of control. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | ToggleInstance | Specifies toggle item instance for this entity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | ToggleItem | Specifies toggle item name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | Width | Specifies this instance width.
Top
Public Methods
 | Name | Description
Method | ChangeVisibility | Toggles visibility state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Method | Subscribe | Looks for the toggle controller and registers this instance with it (if there is any). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Top
See Also

Reference

ITableColumn Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableColumn Interface Properties

ITableColumn Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableColumn Interface

For a list of all members of this type, see ITableColumn members.

Public Properties
 | Name | Description
Property | Hidden | Indicates whether the item should be visible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | OwnHidden | Indicates that own hidden state of control. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | ToggleInstance | Specifies toggle item instance for this entity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | ToggleItem | Specifies toggle item name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | Width | Specifies this instance width.
Top
See Also

Reference

ITableColumn Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


Width Property (ITableColumn)

Width Property (ITableColumn)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableColumn Interface : Width Property
Specifies this instance width.
Syntax
  • Visual Basic
  • C#
'Declaration

Property Width As Length
Length Width {get; set;}
See Also

Reference

ITableColumn Interface
ITableColumn Members


ITableColumnCollection Interface

ITableColumnCollection Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableColumnCollection Interface
Interface for a collection of table column objects.
Object Model
ITableColumnCollection Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITableColumnCollection
public interface ITableColumnCollection
See Also

Reference

ITableColumnCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableColumnCollection Interface Members

ITableColumnCollection Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableColumnCollection Interface

The following tables list the members exposed by ITableColumnCollection.

Public Properties
 | Name | Description
Property | Count | (Inherited from System.Collections.ICollection)
Property | IsSynchronized | (Inherited from System.Collections.ICollection)
Property | Item | Returns the TableColumn at the specified index.
Property | SyncRoot | (Inherited from System.Collections.ICollection)
Top
Public Methods
 | Name | Description
Method | CopyTo | (Inherited from System.Collections.ICollection)
Top
See Also

Reference

ITableColumnCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableColumnCollection Interface Properties

ITableColumnCollection Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableColumnCollection Interface

For a list of all members of this type, see ITableColumnCollection members.

Public Properties
 | Name | Description
Property | Count | (Inherited from System.Collections.ICollection)
Property | IsSynchronized | (Inherited from System.Collections.ICollection)
Property | Item | Returns the TableColumn at the specified index.
Property | SyncRoot | (Inherited from System.Collections.ICollection)
Top
See Also

Reference

ITableColumnCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


Item Property (ITableColumnCollection)

Item Property (ITableColumnCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableColumnCollection Interface : Item Property
The index of the item.
Returns the TableColumn at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As ITableColumn
ITableColumn this[
   System.int index
]; {get;}

Parameters

index
The index of the item.
Exceptions
Exception | Description
ArgumentOutOfRangeException | index is not a valid index in the collection.
See Also

Reference

ITableColumnCollection Interface
ITableColumnCollection Members


ITableDetail Interface

ITableDetail Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableDetail Interface
Interface for a table detail object.
Object Model
ITableDetail Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITableDetail
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver
public interface ITableDetail : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver
See Also

Reference

ITableDetail Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableDetail Interface Members

ITableDetail Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableDetail Interface

The following tables list the members exposed by ITableDetail.

Public Properties
 | Name | Description
Property | Hidden | Indicates whether the item should be visible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | OwnHidden | Indicates that own hidden state of control. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | PageBreakAtEnd | Gets a value indicating whether the page should break at the end of the table detail.
Property | PageBreakAtStart | Gets a value indicating whether the page should break at the start of the table detail.
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Rows | Gets a collection of table rows associated with this detail instance.
Property | ToggleInstance | Specifies toggle item instance for this entity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | ToggleItem | Specifies toggle item name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Top
Public Methods
 | Name | Description
Method | ChangeVisibility | Toggles visibility state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Subscribe | Looks for the toggle controller and registers this instance with it (if there is any). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Top
See Also

Reference

ITableDetail Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableDetail Interface Properties

ITableDetail Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableDetail Interface

For a list of all members of this type, see ITableDetail members.

Public Properties
 | Name | Description
Property | Hidden | Indicates whether the item should be visible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | OwnHidden | Indicates that own hidden state of control. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | PageBreakAtEnd | Gets a value indicating whether the page should break at the end of the table detail.
Property | PageBreakAtStart | Gets a value indicating whether the page should break at the start of the table detail.
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Rows | Gets a collection of table rows associated with this detail instance.
Property | ToggleInstance | Specifies toggle item instance for this entity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | ToggleItem | Specifies toggle item name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Top
See Also

Reference

ITableDetail Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


PageBreakAtEnd Property (ITableDetail)

PageBreakAtEnd Property (ITableDetail)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableDetail Interface : PageBreakAtEnd Property
Gets a value indicating whether the page should break at the end of the table detail.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PageBreakAtEnd As System.Boolean
System.bool PageBreakAtEnd {get;}
See Also

Reference

ITableDetail Interface
ITableDetail Members


PageBreakAtStart Property (ITableDetail)

PageBreakAtStart Property (ITableDetail)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableDetail Interface : PageBreakAtStart Property
Gets a value indicating whether the page should break at the start of the table detail.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PageBreakAtStart As System.Boolean
System.bool PageBreakAtStart {get;}
See Also

Reference

ITableDetail Interface
ITableDetail Members


Rows Property (ITableDetail)

Rows Property (ITableDetail)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableDetail Interface : Rows Property
Gets a collection of table rows associated with this detail instance.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Rows As ITableRowCollection
ITableRowCollection Rows {get;}
See Also

Reference

ITableDetail Interface
ITableDetail Members


ITableDetailCollection Interface

ITableDetailCollection Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableDetailCollection Interface
Interface for a collection of table detail objects.
Object Model
ITableDetailCollection Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITableDetailCollection
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection(Of ITableDetail)
public interface ITableDetailCollection : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableDetail>
See Also

Reference

ITableDetailCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableDetailCollection Interface Members

ITableDetailCollection Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableDetailCollection Interface

The following tables list the members exposed by ITableDetailCollection.

Public Properties
 | Name | Description
Property | Count | Gets number of items in the collection. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableDetail>)
Property | Item | Gets the T at the specified index. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableDetail>)
Top
See Also

Reference

ITableDetailCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableGroup Interface

ITableGroup Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableGroup Interface
Interface for table group objects.
Object Model
ITableGroup Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITableGroup
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver
public interface ITableGroup : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver
See Also

Reference

ITableGroup Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableGroup Interface Members

ITableGroup Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableGroup Interface

The following tables list the members exposed by ITableGroup.

Public Properties
 | Name | Description
Property | DataCollectionName | The name of the table group element.
Property | DataElementName | The name of this group instance element.
Property | DetailDataCollectionName | The name that data oriented rendering extensions should use for the collection of all instances of the table's details
Property | DetailDataElementName | The name that data oriented rendering extensions should use for each detail instance of the table.
Property | DetailDataElementOutput | Indicates whether the details should appear in a data rendering. Valid values are GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.NoOutput and GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.Output.
Property | Details | Defines details rows for this group.
Property | Footer | Defines the header section of this group.
Property | HasDynamicVisibility | Determines if this table group has dynamic visiblity.
Property | Header | Defines the header section of this group.
Property | Hidden | Indicates whether the item should be visible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | KeepTogether | Gets or sets a value indicating whether a table group is kept together on a single page where possible.
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | OwnHidden | Indicates that own hidden state of control. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | PageBreakAtEnd | Specifies a page break at the end of each instance of this group.
Property | PageBreakAtStart | Specifies a page break in the begining of each instance of this group.
Property | PreventOrphanedFooter | Indicates whether the last detailed row will be printed along with the footer in order to prevent orphaned footer on the next page.
Property | SubGroups | The inner groups of the table that are nested within this one.
Property | Table | The ITable that this group is a member of.
Property | ToggleInstance | Specifies toggle item instance for this entity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | ToggleItem | Specifies toggle item name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Top
Public Methods
 | Name | Description
Method | ChangeVisibility | Toggles visibility state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Method | Subscribe | Looks for the toggle controller and registers this instance with it (if there is any). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Top
See Also

Reference

ITableGroup Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableGroup Interface Properties

ITableGroup Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableGroup Interface

For a list of all members of this type, see ITableGroup members.

Public Properties
 | Name | Description
Property | DataCollectionName | The name of the table group element.
Property | DataElementName | The name of this group instance element.
Property | DetailDataCollectionName | The name that data oriented rendering extensions should use for the collection of all instances of the table's details
Property | DetailDataElementName | The name that data oriented rendering extensions should use for each detail instance of the table.
Property | DetailDataElementOutput | Indicates whether the details should appear in a data rendering. Valid values are GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.NoOutput and GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.Output.
Property | Details | Defines details rows for this group.
Property | Footer | Defines the header section of this group.
Property | HasDynamicVisibility | Determines if this table group has dynamic visiblity.
Property | Header | Defines the header section of this group.
Property | Hidden | Indicates whether the item should be visible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | KeepTogether | Gets or sets a value indicating whether a table group is kept together on a single page where possible.
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | NewSection | Indicating whether a region is in it's own section. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.ISectionRegion)
Property | OwnHidden | Indicates that own hidden state of control. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | PageBreakAtEnd | Specifies a page break at the end of each instance of this group.
Property | PageBreakAtStart | Specifies a page break in the begining of each instance of this group.
Property | PreventOrphanedFooter | Indicates whether the last detailed row will be printed along with the footer in order to prevent orphaned footer on the next page.
Property | SubGroups | The inner groups of the table that are nested within this one.
Property | Table | The ITable that this group is a member of.
Property | ToggleInstance | Specifies toggle item instance for this entity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | ToggleItem | Specifies toggle item name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Top
See Also

Reference

ITableGroup Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


DataCollectionName Property (ITableGroup)

DataCollectionName Property (ITableGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : DataCollectionName Property
The name of the table group element.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataCollectionName As System.String
System.string DataCollectionName {get;}
See Also

Reference

ITableGroup Interface
ITableGroup Members


DataElementName Property (ITableGroup)

DataElementName Property (ITableGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : DataElementName Property
The name of this group instance element.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataElementName As System.String
System.string DataElementName {get;}
Remarks
Group instance elements are subelements of the table group element (i.e. DataCollectionName).
See Also

Reference

ITableGroup Interface
ITableGroup Members


DetailDataCollectionName Property (ITableGroup)

DetailDataCollectionName Property (ITableGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : DetailDataCollectionName Property
The name that data oriented rendering extensions should use for the collection of all instances of the table's details
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DetailDataCollectionName As System.String
System.string DetailDataCollectionName {get;}
See Also

Reference

ITableGroup Interface
ITableGroup Members


DetailDataElementName Property (ITableGroup)

DetailDataElementName Property (ITableGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : DetailDataElementName Property
The name that data oriented rendering extensions should use for each detail instance of the table.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DetailDataElementName As System.String
System.string DetailDataElementName {get;}
See Also

Reference

ITableGroup Interface
ITableGroup Members


DetailDataElementOutput Property (ITableGroup)

DetailDataElementOutput Property (ITableGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : DetailDataElementOutput Property
Indicates whether the details should appear in a data rendering. Valid values are GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.NoOutput and GrapeCity.ActiveReports.Extensibility.Rendering.Components.DataElementOutput.Output.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DetailDataElementOutput As DataElementOutput
DataElementOutput DetailDataElementOutput {get;}
See Also

Reference

ITableGroup Interface
ITableGroup Members


Details Property (ITableGroup)

Details Property (ITableGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : Details Property
Defines details rows for this group.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Details As ITableDetailCollection
ITableDetailCollection Details {get;}
See Also

Reference

ITableGroup Interface
ITableGroup Members


Footer Property (ITableGroup)

Footer Property (ITableGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : Footer Property
Defines the header section of this group.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Footer As ITableHeaderFooterRows
ITableHeaderFooterRows Footer {get;}
See Also

Reference

ITableGroup Interface
ITableGroup Members


HasDynamicVisibility Property (ITableGroup)

HasDynamicVisibility Property (ITableGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : HasDynamicVisibility Property
Determines if this table group has dynamic visiblity.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property HasDynamicVisibility As System.Boolean
System.bool HasDynamicVisibility {get;}
See Also

Reference

ITableGroup Interface
ITableGroup Members


Header Property (ITableGroup)

Header Property (ITableGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : Header Property
Defines the header section of this group.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Header As ITableHeaderFooterRows
ITableHeaderFooterRows Header {get;}
See Also

Reference

ITableGroup Interface
ITableGroup Members


KeepTogether Property (ITableGroup)

KeepTogether Property (ITableGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : KeepTogether Property
Gets or sets a value indicating whether a table group is kept together on a single page where possible.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property KeepTogether As System.Boolean
System.bool KeepTogether {get;}
See Also

Reference

ITableGroup Interface
ITableGroup Members


PageBreakAtEnd Property (ITableGroup)

PageBreakAtEnd Property (ITableGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : PageBreakAtEnd Property
Specifies a page break at the end of each instance of this group.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PageBreakAtEnd As System.Boolean
System.bool PageBreakAtEnd {get;}
See Also

Reference

ITableGroup Interface
ITableGroup Members


PageBreakAtStart Property (ITableGroup)

PageBreakAtStart Property (ITableGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : PageBreakAtStart Property
Specifies a page break in the begining of each instance of this group.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PageBreakAtStart As System.Boolean
System.bool PageBreakAtStart {get;}
See Also

Reference

ITableGroup Interface
ITableGroup Members


PreventOrphanedFooter Property (ITableGroup)

PreventOrphanedFooter Property (ITableGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : PreventOrphanedFooter Property
Indicates whether the last detailed row will be printed along with the footer in order to prevent orphaned footer on the next page.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PreventOrphanedFooter As System.Boolean
System.bool PreventOrphanedFooter {get;}
See Also

Reference

ITableGroup Interface
ITableGroup Members


SubGroups Property (ITableGroup)

SubGroups Property (ITableGroup)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : SubGroups Property
The inner groups of the table that are nested within this one.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property SubGroups As ITableGroupCollection
ITableGroupCollection SubGroups {get;}
See Also

Reference

ITableGroup Interface
ITableGroup Members


Table Property

Table Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableGroup Interface : Table Property
The ITable that this group is a member of.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Table As ITable
ITable Table {get;}
See Also

Reference

ITableGroup Interface
ITableGroup Members


ITableGroupCollection Interface

ITableGroupCollection Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableGroupCollection Interface
Represents a collection of ITableGroup objects.
Object Model
ITableGroupCollection Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITableGroupCollection
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection(Of ITableGroup)
public interface ITableGroupCollection : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableGroup>
See Also

Reference

ITableGroupCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableGroupCollection Interface Members

ITableGroupCollection Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableGroupCollection Interface

The following tables list the members exposed by ITableGroupCollection.

Public Properties
 | Name | Description
Property | Count | Gets number of items in the collection. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableGroup>)
Property | Item | Gets the T at the specified index. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableGroup>)
Top
See Also

Reference

ITableGroupCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableHeaderFooterRows Interface

ITableHeaderFooterRows Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableHeaderFooterRows Interface
Interface for table header or footer row objects.
Object Model
ITableHeaderFooterRows Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITableHeaderFooterRows
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection(Of ITableRow), ITableRowCollection
public interface ITableHeaderFooterRows : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableRow>, ITableRowCollection
See Also

Reference

ITableHeaderFooterRows Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableHeaderFooterRows Interface Members

ITableHeaderFooterRows Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableHeaderFooterRows Interface

The following tables list the members exposed by ITableHeaderFooterRows.

Public Properties
 | Name | Description
Property | Count | Gets number of items in the collection. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableRow>)
Property | Item | Gets the T at the specified index. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableRow>)
Property | PrintAtBottom | Indicates that these rows should be printed at bottom of the page.
Property | RepeatOnNewPage | Indicates if these rows should be repeated on each page that the table or group is displayed on.
Top
See Also

Reference

ITableHeaderFooterRows Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableHeaderFooterRows Interface Properties

ITableHeaderFooterRows Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableHeaderFooterRows Interface

For a list of all members of this type, see ITableHeaderFooterRows members.

Public Properties
 | Name | Description
Property | Count | Gets number of items in the collection. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableRow>)
Property | Item | Gets the T at the specified index. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableRow>)
Property | PrintAtBottom | Indicates that these rows should be printed at bottom of the page.
Property | RepeatOnNewPage | Indicates if these rows should be repeated on each page that the table or group is displayed on.
Top
See Also

Reference

ITableHeaderFooterRows Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


PrintAtBottom Property (ITableHeaderFooterRows)

PrintAtBottom Property (ITableHeaderFooterRows)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableHeaderFooterRows Interface : PrintAtBottom Property
Indicates that these rows should be printed at bottom of the page.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PrintAtBottom As System.Boolean
System.bool PrintAtBottom {get;}
See Also

Reference

ITableHeaderFooterRows Interface
ITableHeaderFooterRows Members


RepeatOnNewPage Property (ITableHeaderFooterRows)

RepeatOnNewPage Property (ITableHeaderFooterRows)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableHeaderFooterRows Interface : RepeatOnNewPage Property
Indicates if these rows should be repeated on each page that the table or group is displayed on.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RepeatOnNewPage As System.Boolean
System.bool RepeatOnNewPage {get;}
See Also

Reference

ITableHeaderFooterRows Interface
ITableHeaderFooterRows Members


ITableRow Interface

ITableRow Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableRow Interface
Interface for a table row object.
Object Model
ITableRow Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITableRow
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver
public interface ITableRow : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem, GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver
See Also

Reference

ITableRow Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableRow Interface Members

ITableRow Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableRow Interface

The following tables list the members exposed by ITableRow.

Public Properties
 | Name | Description
Property | Cells | Gets a collection of table cells.
Property | HasDynamicVisibility | Determines if this table row has dynamic visiblity.
Property | Height | Specifies table row height.
Property | Hidden | Indicates whether the item should be visible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | OwnHidden | Indicates that own hidden state of control. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | ToggleInstance | Specifies toggle item instance for this entity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | ToggleItem | Specifies toggle item name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Top
Public Methods
 | Name | Description
Method | ChangeVisibility | Toggles visibility state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Method | Subscribe | Looks for the toggle controller and registers this instance with it (if there is any). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Top
See Also

Reference

ITableRow Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableRow Interface Properties

ITableRow Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableRow Interface

For a list of all members of this type, see ITableRow members.

Public Properties
 | Name | Description
Property | Cells | Gets a collection of table cells.
Property | HasDynamicVisibility | Determines if this table row has dynamic visiblity.
Property | Height | Specifies table row height.
Property | Hidden | Indicates whether the item should be visible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | OwnHidden | Indicates that own hidden state of control. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | ToggleInstance | Specifies toggle item instance for this entity. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Property | ToggleItem | Specifies toggle item name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Top
See Also

Reference

ITableRow Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


Cells Property

Cells Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableRow Interface : Cells Property
Gets a collection of table cells.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Cells As ITableCellCollection
ITableCellCollection Cells {get;}
See Also

Reference

ITableRow Interface
ITableRow Members


HasDynamicVisibility Property (ITableRow)

HasDynamicVisibility Property (ITableRow)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableRow Interface : HasDynamicVisibility Property
Determines if this table row has dynamic visiblity.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property HasDynamicVisibility As System.Boolean
System.bool HasDynamicVisibility {get;}
See Also

Reference

ITableRow Interface
ITableRow Members


Height Property (ITableRow)

Height Property (ITableRow)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableRow Interface : Height Property
Specifies table row height.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Height As Length
Length Height {get;}
See Also

Reference

ITableRow Interface
ITableRow Members


ITableRowCollection Interface

ITableRowCollection Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableRowCollection Interface
Interface for a collection of table row objects.
Object Model
ITableRowCollection Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITableRowCollection
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection(Of ITableRow)
public interface ITableRowCollection : GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableRow>
See Also

Reference

ITableRowCollection Members
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableRowCollection Interface Members

ITableRowCollection Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableRowCollection Interface

The following tables list the members exposed by ITableRowCollection.

Public Properties
 | Name | Description
Property | Count | Gets number of items in the collection. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableRow>)
Property | Item | Gets the T at the specified index. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableRow>)
Top
See Also

Reference

ITableRowCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace

GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace
The GrapeCity.ActiveReports.Extensibility.Rendering.Drawing namespace includes functions that are required when rendering reports.
Classes
 | Class | Description
Class | BrushEx | Classes derived from this abstract base class define objects used to fill the interiors of graphical shapes such as rectangles, ellipses, pies, polygons, and paths.
Class | FontEx | Defines a particular format for text, including font face, size, and style attributes. This class is abstract.
Class | ImageEx | Classes derived from this abstract base class define objects used to hold images.
Class | PenEx | Defines an object used to draw lines and curves. This class is abstract.
Interfaces
 | Interface | Description
Interface | IDrawingCanvas | Defines a set of properties and methods used to render a canvas.
Interface | IFontInfo | Specifies the information about the font.
Interface | IGlyphRun | Defines a run of glyphs
Interface | IPathEx | Represents an abstract series of connected lines and curves.
Enumerations
 | Enumeration | Description
Enumeration | DashCap | Specifies the type of graphic shape to use on both ends of each dash in a dashed line.
Enumeration | FillModeEx | Specifies how the interior of a closed path is filled.
Enumeration | FontDecoration | Represents the font decoration.
Enumeration | FontStyle | Represents the font style.
Enumeration | FontWeight | Specifies font thickness.
Enumeration | LineCap | Specifies the available cap styles with which a PenEx object can end a line.
Enumeration | LineJoin | Specifies how to join consecutive line or curve segments in a figure (subpath) contained in a GraphicsPath object.
Enumeration | PenAlignment | Gets or sets the alignment for PenEx object.
Enumeration | PenStyleEx | Specifies the style of dashed lines drawn with a System.Drawing.Pen object.
Enumeration | TextJustify | Represents the text justification.
Enumeration | WrapMode | Represents the text wrap mode.
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


BrushEx Class

BrushEx Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : BrushEx Class
Classes derived from this abstract base class define objects used to fill the interiors of graphical shapes such as rectangles, ellipses, pies, polygons, and paths.
Object Model
BrushEx Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class BrushEx
   Inherits System.MarshalByRefObject
public abstract class BrushEx : System.MarshalByRefObject
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing.BrushEx

See Also

Reference

BrushEx Members
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


BrushEx Class Members

BrushEx Class Members
Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : BrushEx Class

The following tables list the members exposed by BrushEx.

Public Methods
 | Name | Description
Public Method | Clone | When overridden in a derived class, creates an exact copy of this BrushEx object.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases all resources used by this BrushEx object.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Top
See Also

Reference

BrushEx Class
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


BrushEx Class Methods

BrushEx Class Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : BrushEx Class

For a list of all members of this type, see BrushEx members.

Public Methods
 | Name | Description
Public Method | Clone | When overridden in a derived class, creates an exact copy of this BrushEx object.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases all resources used by this BrushEx object.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Top
See Also

Reference

BrushEx Class
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


Clone Method (BrushEx)

Clone Method (BrushEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > BrushEx Class : Clone Method
When overridden in a derived class, creates an exact copy of this BrushEx object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Function Clone() As System.Object
public abstract System.object Clone()

Return Value

The new BrushEx object that this method creates.
See Also

Reference

BrushEx Class
BrushEx Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > BrushEx Class : Dispose() Method
Releases all resources used by this BrushEx object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()

Return Value

This method does not return a value.
See Also

Reference

BrushEx Class
BrushEx Members


FontEx Class

FontEx Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : FontEx Class
Defines a particular format for text, including font face, size, and style attributes. This class is abstract.
Object Model
FontEx Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class FontEx
   Inherits System.MarshalByRefObject
public abstract class FontEx : System.MarshalByRefObject
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing.FontEx

See Also

Reference

FontEx Members
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


FontEx Class Members

FontEx Class Members
Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : FontEx Class

The following tables list the members exposed by FontEx.

Public Methods
 | Name | Description
Public Method | Clone | When overridden in a derived class, creates an exact copy of this FontEx object.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases all resources used by this FontEx object.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Top
See Also

Reference

FontEx Class
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


FontEx Class Methods

FontEx Class Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : FontEx Class

For a list of all members of this type, see FontEx members.

Public Methods
 | Name | Description
Public Method | Clone | When overridden in a derived class, creates an exact copy of this FontEx object.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases all resources used by this FontEx object.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Top
See Also

Reference

FontEx Class
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


Clone Method (FontEx)

Clone Method (FontEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > FontEx Class : Clone Method
When overridden in a derived class, creates an exact copy of this FontEx object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Function Clone() As System.Object
public abstract System.object Clone()

Return Value

The new FontEx object that this method creates.
See Also

Reference

FontEx Class
FontEx Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > FontEx Class : Dispose() Method
Releases all resources used by this FontEx object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()

Return Value

This method does not return a value.
See Also

Reference

FontEx Class
FontEx Members


ImageEx Class

ImageEx Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : ImageEx Class
Classes derived from this abstract base class define objects used to hold images.
Object Model
ImageEx Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class ImageEx
   Inherits System.MarshalByRefObject
public abstract class ImageEx : System.MarshalByRefObject
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing.ImageEx

See Also

Reference

ImageEx Members
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


ImageEx Class Members

ImageEx Class Members
Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : ImageEx Class

The following tables list the members exposed by ImageEx.

Public Methods
 | Name | Description
Public Method | Clone | When overridden in a derived class, creates an exact copy of this ImageEx object.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases all resources used by this ImageEx object.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Top
See Also

Reference

ImageEx Class
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


ImageEx Class Methods

ImageEx Class Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : ImageEx Class

For a list of all members of this type, see ImageEx members.

Public Methods
 | Name | Description
Public Method | Clone | When overridden in a derived class, creates an exact copy of this ImageEx object.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases all resources used by this ImageEx object.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Top
See Also

Reference

ImageEx Class
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


Clone Method (ImageEx)

Clone Method (ImageEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > ImageEx Class : Clone Method
When overridden in a derived class, creates an exact copy of this ImageEx object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Function Clone() As System.Object
public abstract System.object Clone()

Return Value

The new ImageEx object that this method creates.
See Also

Reference

ImageEx Class
ImageEx Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > ImageEx Class : Dispose() Method
Releases all resources used by this ImageEx object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()

Return Value

This method does not return a value.
See Also

Reference

ImageEx Class
ImageEx Members


PenEx Class

PenEx Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : PenEx Class
Defines an object used to draw lines and curves. This class is abstract.
Object Model
PenEx Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class PenEx
   Inherits System.MarshalByRefObject
public abstract class PenEx : System.MarshalByRefObject
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing.PenEx

See Also

Reference

PenEx Members
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


PenEx Class Members

PenEx Class Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : PenEx Class

The following tables list the members exposed by PenEx.

Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the alignment for this PenEx object.
Public Property | Brush | Gets or sets the BrushEx object that determines attributes of this PenEx object
Public Property | Color | Gets or sets the color of this PenEx object.
Public Property | DashCap | Gets or sets the cap style used at the beginning and the end of the dashes that make up dashed lines drawn with this PenEx object.
Public Property | DashStyle | Gets or sets the style used for dashed lines drawn with this PenEx object.
Public Property | EndCap | Gets or sets the cap style used at the end of lines drawn with this PenEx object.
Public Property | LineJoin | Gets or sets the join style for the ends of two consecutive lines drawn with this Pen.
Public Property | StartCap | Gets or sets the cap style used at the beginning of lines drawn with this PenEx object.
Public Property | Width | Gets or sets the width of this PenEx object.
Top
Public Methods
 | Name | Description
Public Method | Clone | Creates an exact copy of this PenEx object.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases all resources used by this PenEx object.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Top
See Also

Reference

PenEx Class
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


PenEx Class Methods

PenEx Class Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : PenEx Class

For a list of all members of this type, see PenEx members.

Public Methods
 | Name | Description
Public Method | Clone | Creates an exact copy of this PenEx object.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases all resources used by this PenEx object.
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Top
See Also

Reference

PenEx Class
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


Clone Method (PenEx)

Clone Method (PenEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > PenEx Class : Clone Method
Creates an exact copy of this PenEx object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Function Clone() As System.Object
public abstract System.object Clone()
See Also

Reference

PenEx Class
PenEx Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > PenEx Class : Dispose() Method
Releases all resources used by this PenEx object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()

Return Value

This method does not return a value.
See Also

Reference

PenEx Class
PenEx Members


PenEx Class Properties

PenEx Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : PenEx Class

For a list of all members of this type, see PenEx members.

Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the alignment for this PenEx object.
Public Property | Brush | Gets or sets the BrushEx object that determines attributes of this PenEx object
Public Property | Color | Gets or sets the color of this PenEx object.
Public Property | DashCap | Gets or sets the cap style used at the beginning and the end of the dashes that make up dashed lines drawn with this PenEx object.
Public Property | DashStyle | Gets or sets the style used for dashed lines drawn with this PenEx object.
Public Property | EndCap | Gets or sets the cap style used at the end of lines drawn with this PenEx object.
Public Property | LineJoin | Gets or sets the join style for the ends of two consecutive lines drawn with this Pen.
Public Property | StartCap | Gets or sets the cap style used at the beginning of lines drawn with this PenEx object.
Public Property | Width | Gets or sets the width of this PenEx object.
Top
See Also

Reference

PenEx Class
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


Alignment Property (PenEx)

Alignment Property (PenEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > PenEx Class : Alignment Property
Gets or sets the alignment for this PenEx object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Property Alignment As PenAlignment
public abstract PenAlignment Alignment {get; set;}
See Also

Reference

PenEx Class
PenEx Members


Brush Property

Brush Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > PenEx Class : Brush Property
Gets or sets the BrushEx object that determines attributes of this PenEx object
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Property Brush As BrushEx
public abstract BrushEx Brush {get; set;}
See Also

Reference

PenEx Class
PenEx Members


Color Property (PenEx)

Color Property (PenEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > PenEx Class : Color Property
Gets or sets the color of this PenEx object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Property Color As ColorEx
public abstract ColorEx Color {get; set;}
See Also

Reference

PenEx Class
PenEx Members


DashCap Property (PenEx)

DashCap Property (PenEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > PenEx Class : DashCap Property
Gets or sets the cap style used at the beginning and the end of the dashes that make up dashed lines drawn with this PenEx object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Property DashCap As DashCap
public abstract DashCap DashCap {get; set;}
See Also

Reference

PenEx Class
PenEx Members


DashStyle Property (PenEx)

DashStyle Property (PenEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > PenEx Class : DashStyle Property
Gets or sets the style used for dashed lines drawn with this PenEx object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Property DashStyle As PenStyleEx
public abstract PenStyleEx DashStyle {get; set;}
See Also

Reference

PenEx Class
PenEx Members


EndCap Property (PenEx)

EndCap Property (PenEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > PenEx Class : EndCap Property
Gets or sets the cap style used at the end of lines drawn with this PenEx object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Property EndCap As LineCap
public abstract LineCap EndCap {get; set;}
See Also

Reference

PenEx Class
PenEx Members


LineJoin Property

LineJoin Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > PenEx Class : LineJoin Property
Gets or sets the join style for the ends of two consecutive lines drawn with this Pen.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Property LineJoin As LineJoin
public abstract LineJoin LineJoin {get; set;}
See Also

Reference

PenEx Class
PenEx Members


StartCap Property

StartCap Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > PenEx Class : StartCap Property
Gets or sets the cap style used at the beginning of lines drawn with this PenEx object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Property StartCap As LineCap
public abstract LineCap StartCap {get; set;}
See Also

Reference

PenEx Class
PenEx Members


Width Property (PenEx)

Width Property (PenEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > PenEx Class : Width Property
Gets or sets the width of this PenEx object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Property Width As System.Single
public abstract System.float Width {get; set;}
See Also

Reference

PenEx Class
PenEx Members


DashCap Enumeration

DashCap Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : DashCap Enumeration
Specifies the type of graphic shape to use on both ends of each dash in a dashed line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DashCap
   Inherits System.Enum
public enum DashCap : System.Enum
Members
Member | Description
Flat | Specifies a square cap that squares off both ends of each dash.
Round | Specifies a circular cap that rounds off both ends of each dash.
Triangle | Specifies a triangular cap that points both ends of each dash.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing.DashCap

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


FillModeEx Enumeration

FillModeEx Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : FillModeEx Enumeration
Specifies how the interior of a closed path is filled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum FillModeEx
   Inherits System.Enum
public enum FillModeEx : System.Enum
Members
Member | Description
Alternate | Specifies the alternate fill mode.
Winding | Specifies the winding fill mode.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing.FillModeEx

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


FontDecoration Enumeration

FontDecoration Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : FontDecoration Enumeration
Represents the font decoration.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum FontDecoration
   Inherits System.Enum
public enum FontDecoration : System.Enum
Members
Member | Description
Linethrough | Defines a line through the text.
None | Defines a normal text.
Overline | Defines a line above the text.
Underline | Defines a line below the text.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing.FontDecoration

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


FontStyle Enumeration

FontStyle Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : FontStyle Enumeration
Represents the font style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum FontStyle
   Inherits System.Enum
public enum FontStyle : System.Enum
Members
Member | Description
Italic | Defines an italic text.
Normal | Defines a normal text.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing.FontStyle

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


FontWeight Enumeration

FontWeight Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : FontWeight Enumeration
Specifies font thickness.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum FontWeight
   Inherits System.Enum
public enum FontWeight : System.Enum
Members
Member | Description
Bold | Indicates a bold font weight.
Bolder | Indicates a bolder font weight.
ExtraBold | Indicates an extra bold font weight.
ExtraLight | Indicates an extra light font weight
Heavy | Indicates a heavy font weight.
Light | Indicates a light font weight
Lighter | Indicates a lighter font weight
Medium | Indicates a medium font weight.
Normal | Indicates a normal font weight.
SemiBold | Indicates a semi-bold font weight.
Thin | Indicates a thin font weight
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing.FontWeight

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


LineCap Enumeration

LineCap Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : LineCap Enumeration
Specifies the available cap styles with which a PenEx object can end a line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LineCap
   Inherits System.Enum
public enum LineCap : System.Enum
Members
Member | Description
AnchorMask | Specifies a mask used to check whether a line cap is an anchor cap.
ArrowAnchor | Specifies an arrow-shaped anchor cap.
Custom | Specifies a custom line cap.
DiamondAnchor | Specifies a diamond anchor cap.
Flat | Specifies a flat line cap.
NoAnchor | Specifies no anchor.
Round | Specifies a round line cap.
RoundAnchor | Specifies a round anchor cap.
Square | Specifies a square line cap.
SquareAnchor | Specifies a square anchor line cap.
Triangle | Specifies a triangular line cap.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing.LineCap

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


LineJoin Enumeration

LineJoin Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : LineJoin Enumeration
Specifies how to join consecutive line or curve segments in a figure (subpath) contained in a GraphicsPath object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LineJoin
   Inherits System.Enum
public enum LineJoin : System.Enum
Members
Member | Description
Bevel | Specifies a beveled join. This produces a diagonal corner.
Miter | Specifies a mitered join. This produces a sharp corner or a clipped corner, depending on whether the length of the miter exceeds the miter limit.
MiterClipped | Specifies a mitered join. This produces a sharp corner or a beveled corner, depending on whether the length of the miter exceeds the miter limit.
Round | Specifies a circular join. This produces a smooth, circular arc between the lines.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing.LineJoin

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


PenAlignment Enumeration

PenAlignment Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : PenAlignment Enumeration
Gets or sets the alignment for PenEx object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PenAlignment
   Inherits System.Enum
public enum PenAlignment : System.Enum
Members
Member | Description
Center | Specifies that the Pen object is centered over the theoretical line.
Inset | Specifies that the Pen is positioned on the inside of the theoretical line.
Left | Specifies that the Pen is positioned on the left of the theoretical line.
Outset | Specifies that the Pen is positioned on the outside of the theoretical line.
Right | Specifies that the Pen is positioned on the right of the theoretical line.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing.PenAlignment

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


PenStyleEx Enumeration

PenStyleEx Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : PenStyleEx Enumeration
Specifies the style of dashed lines drawn with a System.Drawing.Pen object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PenStyleEx
   Inherits System.Enum
public enum PenStyleEx : System.Enum
Members
Member | Description
Custom | Specifies a user-defined custom dash style.
Dash | Specifies a line consisting of dashes.
DashDot | Specifies a line consisting of a repeating pattern of dash-dot.
DashDotDot | Specifies a line consisting of a repeating pattern of dash-dot-dot.
Dot | Specifies a line consisting of dots.
Solid | Specifies a solid line.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing.PenStyleEx

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


TextJustify Enumeration

TextJustify Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : TextJustify Enumeration
Represents the text justification.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TextJustify
   Inherits System.Enum
public enum TextJustify : System.Enum
Members
Member | Description
Auto | Defines the justification algorithm that is determined automatically.
Distribute | Defines the newspaper-like distribution except the last line of text which is not modified
DistributeAllLines | Defines the newspaper-like distribution including the last line.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing.TextJustify

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


WrapMode Enumeration

WrapMode Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : WrapMode Enumeration
Represents the text wrap mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum WrapMode
   Inherits System.Enum
public enum WrapMode : System.Enum
Members
Member | Description
CharWrap | Defines the char wrap.
NoWrap | Defines no wrap .
WordWrap | Defines the word wrap.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing.WrapMode

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


IDrawingCanvas Interface

IDrawingCanvas Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : IDrawingCanvas Interface
Defines a set of properties and methods used to render a canvas.
Object Model
IDrawingCanvas Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDrawingCanvas
public interface IDrawingCanvas
See Also

Reference

IDrawingCanvas Members
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


IDrawingCanvas Interface Members

IDrawingCanvas Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : IDrawingCanvas Interface

The following tables list the members exposed by IDrawingCanvas.

Public Properties
 | Name | Description
Property | ClipBounds | Gets a RectangleF structure that bounds the clipping region of this Graphics object.
Property | IsDrawStringWithDelayedContentSupported | Returns whether the IDrawingCanvas supports drawing delayed content.
Property | RenderCallback | Returns method for performing some action with canvas during rendering
Property | SmoothingMode | Specifies the rendering quality for lines, curves, and the edges of filled areas.
Property | TextRenderingHint | Specifies the quality of text rendering.
Property | Transform | Gets or sets the world transformation for this object
Top
Public Methods
 | Name | Description
Method | CreateFont | Overloaded. Initializes a new instance of FontEx.
Method | CreateHatchBrush | Initializes a new BrushEx using specified hatch pattern and colors.
Method | CreateLinearGradientBrush | Overloaded. Initializes a new BrushEx linear gradient brush object.
Method | CreatePath | Initializes a new instance of IPathEx.
Method | CreatePathGradientBrush | Overloaded. Initializes a new BrushEx path gradient brush object.
Method | CreatePen | Overloaded. Initializes a new instance of PenEx with the specified color and width
Method | CreateSolidBrush | Initializes a new BrushEx solid brush object of specified color.
Method | CreateStringFormat | Initializes a new instance of StringFormatEx based on a System.Drawing.StringFormat.
Method | CreateTextureBrush | Initializes a new BrushEx brush using the specified image data.
Method | DrawAndFillPath | Fills the path supplied with brush, and strokes it with pen. If brush or pen is null, corresponding operation is omitted.
Method | DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
Method | DrawGlyphRun | Draws a run of glyphs.
Method | DrawImage | Overloaded. Draws the specified Image at the specified location and with the specified size.
Method | DrawLine | Draws a line connecting two PointF structures.
Method | DrawLines | Draws a series of line segments that connect an array of System.Drawing.PointF structures.
Method | DrawPolygon | Draws a polygon defined by an array of System.Drawing.PointF structures
Method | DrawRectangle | Draws a rectangle rectangle specified by a RectangleF structure.
Method | DrawString | Overloaded. Draws the specified text string at the specified location with the specified Brush and Font objects. using the formatting attributes of the specified StringFormat object.
Method | FillEllipse | Overloaded. Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
Method | FillPolygon | Fills the interior of a polygon defined by an array of points specified by System.Drawing.PointF structures
Method | FillRectangle | Overloaded. Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
Method | IntersectClip | Overloaded. Sets the clipping region of this Graphics object to the rectangle specified by a RectangleF structure.
Method | PopState | Restores the state of this IDrawingCanvas object to the previous saved state.
Method | PushState | Saves the current state on a stack.
Method | TranslateTransform | Prepends the specified translation to the transformation matrix of this Graphics object.
Top
See Also

Reference

IDrawingCanvas Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


IDrawingCanvas Interface Methods

IDrawingCanvas Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : IDrawingCanvas Interface

For a list of all members of this type, see IDrawingCanvas members.

Public Methods
 | Name | Description
Method | CreateFont | Overloaded. Initializes a new instance of FontEx.
Method | CreateHatchBrush | Initializes a new BrushEx using specified hatch pattern and colors.
Method | CreateLinearGradientBrush | Overloaded. Initializes a new BrushEx linear gradient brush object.
Method | CreatePath | Initializes a new instance of IPathEx.
Method | CreatePathGradientBrush | Overloaded. Initializes a new BrushEx path gradient brush object.
Method | CreatePen | Overloaded. Initializes a new instance of PenEx with the specified color and width
Method | CreateSolidBrush | Initializes a new BrushEx solid brush object of specified color.
Method | CreateStringFormat | Initializes a new instance of StringFormatEx based on a System.Drawing.StringFormat.
Method | CreateTextureBrush | Initializes a new BrushEx brush using the specified image data.
Method | DrawAndFillPath | Fills the path supplied with brush, and strokes it with pen. If brush or pen is null, corresponding operation is omitted.
Method | DrawEllipse | Overloaded. Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
Method | DrawGlyphRun | Draws a run of glyphs.
Method | DrawImage | Overloaded. Draws the specified Image at the specified location and with the specified size.
Method | DrawLine | Draws a line connecting two PointF structures.
Method | DrawLines | Draws a series of line segments that connect an array of System.Drawing.PointF structures.
Method | DrawPolygon | Draws a polygon defined by an array of System.Drawing.PointF structures
Method | DrawRectangle | Draws a rectangle rectangle specified by a RectangleF structure.
Method | DrawString | Overloaded. Draws the specified text string at the specified location with the specified Brush and Font objects. using the formatting attributes of the specified StringFormat object.
Method | FillEllipse | Overloaded. Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
Method | FillPolygon | Fills the interior of a polygon defined by an array of points specified by System.Drawing.PointF structures
Method | FillRectangle | Overloaded. Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
Method | IntersectClip | Overloaded. Sets the clipping region of this Graphics object to the rectangle specified by a RectangleF structure.
Method | PopState | Restores the state of this IDrawingCanvas object to the previous saved state.
Method | PushState | Saves the current state on a stack.
Method | TranslateTransform | Prepends the specified translation to the transformation matrix of this Graphics object.
Top
See Also

Reference

IDrawingCanvas Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


CreateFont Method

CreateFont Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : CreateFont Method
Initializes a new instance of FontEx.
Overload List
Overload | Description
CreateFont(String,Single) | Initializes a new instance of FontEx.
CreateFont(IFontInfo) | Initializes a new instance of FontEx.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


CreateFont(String,Single) Method

CreateFont(String,Single) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > CreateFont Method : CreateFont(String,Single) Method
The name of the font family.
The size of the font.
Initializes a new instance of FontEx.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function CreateFont( _
   ByVal familyName As System.String, _
   ByVal emSize As System.Single _
) As FontEx
FontEx CreateFont(
   System.string familyName,
   System.float emSize
)

Parameters

familyName
The name of the font family.
emSize
The size of the font.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


CreateFont(IFontInfo) Method

CreateFont(IFontInfo) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > CreateFont Method : CreateFont(IFontInfo) Method
The font information to create the new font from.
Initializes a new instance of FontEx.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function CreateFont( _
   ByVal fontInfo As IFontInfo _
) As FontEx
FontEx CreateFont(
   IFontInfo fontInfo
)

Parameters

fontInfo
The font information to create the new font from.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


CreateHatchBrush Method

CreateHatchBrush Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : CreateHatchBrush Method
The foreground color.
The background color.
Initializes a new BrushEx using specified hatch pattern and colors.
Syntax
  • Visual Basic
  • C#
'Declaration

Function CreateHatchBrush( _
   ByVal foreColor As ColorEx, _
   ByVal backColor As ColorEx _
) As BrushEx
BrushEx CreateHatchBrush(
   ColorEx foreColor,
   ColorEx backColor
)

Parameters

foreColor
The foreground color.
backColor
The background color.

Return Value

The hatch brush.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


CreateLinearGradientBrush Method

CreateLinearGradientBrush Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : CreateLinearGradientBrush Method
Initializes a new BrushEx linear gradient brush object.
Overload List
Overload | Description
CreateLinearGradientBrush(PointFEx,PointFEx,ColorEx,ColorEx) | Initializes a new BrushEx linear gradient brush object.
CreateLinearGradientBrush(PointFEx,PointFEx,ColorEx,ColorEx,BlendEx) | Initializes a new BrushEx linear gradient brush object.
CreateLinearGradientBrush(PointFEx,PointFEx,ColorEx,ColorEx,ColorBlendEx) | Initializes a new BrushEx linear gradient brush object.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


CreateLinearGradientBrush(PointFEx,PointFEx,ColorEx,ColorEx) Method

CreateLinearGradientBrush(PointFEx,PointFEx,ColorEx,ColorEx) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > CreateLinearGradientBrush Method : CreateLinearGradientBrush(PointFEx,PointFEx,ColorEx,ColorEx) Method
Start gradient point.
End gradient point.
Start gradient color.
End gradient color.
Initializes a new BrushEx linear gradient brush object.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function CreateLinearGradientBrush( _
   ByVal point1 As PointFEx, _
   ByVal point2 As PointFEx, _
   ByVal color1 As ColorEx, _
   ByVal color2 As ColorEx _
) As BrushEx
BrushEx CreateLinearGradientBrush(
   PointFEx point1,
   PointFEx point2,
   ColorEx color1,
   ColorEx color2
)

Parameters

point1
Start gradient point.
point2
End gradient point.
color1
Start gradient color.
color2
End gradient color.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


CreateLinearGradientBrush(PointFEx,PointFEx,ColorEx,ColorEx,BlendEx) Method

CreateLinearGradientBrush(PointFEx,PointFEx,ColorEx,ColorEx,BlendEx) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > CreateLinearGradientBrush Method : CreateLinearGradientBrush(PointFEx,PointFEx,ColorEx,ColorEx,BlendEx) Method
Start gradient point.
End gradient point.
Start gradient color.
End gradient color.
A blend pattern for the gradient.
Initializes a new BrushEx linear gradient brush object.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function CreateLinearGradientBrush( _
   ByVal point1 As PointFEx, _
   ByVal point2 As PointFEx, _
   ByVal color1 As ColorEx, _
   ByVal color2 As ColorEx, _
   ByVal blend As BlendEx _
) As BrushEx
BrushEx CreateLinearGradientBrush(
   PointFEx point1,
   PointFEx point2,
   ColorEx color1,
   ColorEx color2,
   BlendEx blend
)

Parameters

point1
Start gradient point.
point2
End gradient point.
color1
Start gradient color.
color2
End gradient color.
blend
A blend pattern for the gradient.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


CreateLinearGradientBrush(PointFEx,PointFEx,ColorEx,ColorEx,ColorBlendEx) Method

CreateLinearGradientBrush(PointFEx,PointFEx,ColorEx,ColorEx,ColorBlendEx) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > CreateLinearGradientBrush Method : CreateLinearGradientBrush(PointFEx,PointFEx,ColorEx,ColorEx,ColorBlendEx) Method
Start gradient point.
End gradient point.
Start gradient color.
End gradient color.
A color blend pattern for the gradient.
Initializes a new BrushEx linear gradient brush object.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function CreateLinearGradientBrush( _
   ByVal point1 As PointFEx, _
   ByVal point2 As PointFEx, _
   ByVal color1 As ColorEx, _
   ByVal color2 As ColorEx, _
   ByVal colorBlend As ColorBlendEx _
) As BrushEx
BrushEx CreateLinearGradientBrush(
   PointFEx point1,
   PointFEx point2,
   ColorEx color1,
   ColorEx color2,
   ColorBlendEx colorBlend
)

Parameters

point1
Start gradient point.
point2
End gradient point.
color1
Start gradient color.
color2
End gradient color.
colorBlend
A color blend pattern for the gradient.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


CreatePath Method

CreatePath Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : CreatePath Method
Initializes a new instance of IPathEx.
Syntax
  • Visual Basic
  • C#
'Declaration

Function CreatePath() As IPathEx
IPathEx CreatePath()
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


CreatePathGradientBrush Method

CreatePathGradientBrush Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : CreatePathGradientBrush Method
Initializes a new BrushEx path gradient brush object.
Overload List
Overload | Description
CreatePathGradientBrush(IPathEx,PointFEx,ColorEx,ColorEx[]) | Initializes a new BrushEx path gradient brush object.
CreatePathGradientBrush(IPathEx,PointFEx,ColorEx,ColorEx[],BlendEx) | Initializes a new BrushEx path gradient brush object.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


CreatePathGradientBrush(IPathEx,PointFEx,ColorEx,ColorEx[]) Method

CreatePathGradientBrush(IPathEx,PointFEx,ColorEx,ColorEx[]) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > CreatePathGradientBrush Method : CreatePathGradientBrush(IPathEx,PointFEx,ColorEx,ColorEx[]) Method
The path of the gradient.
The center point of the gradient.
The center color of the gradient.
The array of the surrounding colors of the gradient.
Initializes a new BrushEx path gradient brush object.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function CreatePathGradientBrush( _
   ByVal path As IPathEx, _
   ByVal centerPoint As PointFEx, _
   ByVal centerColor As ColorEx, _
   ByVal surroundColors() As ColorEx _
) As BrushEx
BrushEx CreatePathGradientBrush(
   IPathEx path,
   PointFEx centerPoint,
   ColorEx centerColor,
   ColorEx[] surroundColors
)

Parameters

path
The path of the gradient.
centerPoint
The center point of the gradient.
centerColor
The center color of the gradient.
surroundColors
The array of the surrounding colors of the gradient.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


CreatePathGradientBrush(IPathEx,PointFEx,ColorEx,ColorEx[],BlendEx) Method

CreatePathGradientBrush(IPathEx,PointFEx,ColorEx,ColorEx[],BlendEx) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > CreatePathGradientBrush Method : CreatePathGradientBrush(IPathEx,PointFEx,ColorEx,ColorEx[],BlendEx) Method
The path of the gradient.
The center point of the gradient.
The center color of the gradient.
The array of the surrounding colors of the gradient.
A blend pattern for the gradient.
Initializes a new BrushEx path gradient brush object.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function CreatePathGradientBrush( _
   ByVal path As IPathEx, _
   ByVal centerPoint As PointFEx, _
   ByVal centerColor As ColorEx, _
   ByVal surroundColors() As ColorEx, _
   ByVal blend As BlendEx _
) As BrushEx
BrushEx CreatePathGradientBrush(
   IPathEx path,
   PointFEx centerPoint,
   ColorEx centerColor,
   ColorEx[] surroundColors,
   BlendEx blend
)

Parameters

path
The path of the gradient.
centerPoint
The center point of the gradient.
centerColor
The center color of the gradient.
surroundColors
The array of the surrounding colors of the gradient.
blend
A blend pattern for the gradient.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


CreatePen Method

CreatePen Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : CreatePen Method
Initializes a new instance of PenEx with the specified color and width
Overload List
Overload | Description
CreatePen(ColorEx,Single) | Initializes a new instance of PenEx with the specified color and width
CreatePen(ColorEx) | Initializes a new instance of PenEx with the specified color and default width
CreatePen(BrushEx,Single) | Initializes a new instance of PenEx using specified BrushEx and width
CreatePen(BrushEx) | Initializes a new instance of PenEx using specified BrushEx and default width
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


CreatePen(ColorEx,Single) Method

CreatePen(ColorEx,Single) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > CreatePen Method : CreatePen(ColorEx,Single) Method
The pen color.
The pen width.
Initializes a new instance of PenEx with the specified color and width
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function CreatePen( _
   ByVal color As ColorEx, _
   ByVal width As System.Single _
) As PenEx
PenEx CreatePen(
   ColorEx color,
   System.float width
)

Parameters

color
The pen color.
width
The pen width.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


CreatePen(ColorEx) Method

CreatePen(ColorEx) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > CreatePen Method : CreatePen(ColorEx) Method
The pen color.
Initializes a new instance of PenEx with the specified color and default width
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function CreatePen( _
   ByVal color As ColorEx _
) As PenEx
PenEx CreatePen(
   ColorEx color
)

Parameters

color
The pen color.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


CreatePen(BrushEx,Single) Method

CreatePen(BrushEx,Single) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > CreatePen Method : CreatePen(BrushEx,Single) Method
The pen brush.
The brush width.
Initializes a new instance of PenEx using specified BrushEx and width
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function CreatePen( _
   ByVal brush As BrushEx, _
   ByVal width As System.Single _
) As PenEx
PenEx CreatePen(
   BrushEx brush,
   System.float width
)

Parameters

brush
The pen brush.
width
The brush width.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


CreatePen(BrushEx) Method

CreatePen(BrushEx) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > CreatePen Method : CreatePen(BrushEx) Method
The pen brush.
Initializes a new instance of PenEx using specified BrushEx and default width
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function CreatePen( _
   ByVal brush As BrushEx _
) As PenEx
PenEx CreatePen(
   BrushEx brush
)

Parameters

brush
The pen brush.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


CreateSolidBrush Method

CreateSolidBrush Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : CreateSolidBrush Method
The brush color.
Initializes a new BrushEx solid brush object of specified color.
Syntax
  • Visual Basic
  • C#
'Declaration

Function CreateSolidBrush( _
   ByVal color As ColorEx _
) As BrushEx
BrushEx CreateSolidBrush(
   ColorEx color
)

Parameters

color
The brush color.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


CreateStringFormat Method

CreateStringFormat Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : CreateStringFormat Method
The string format.
Initializes a new instance of StringFormatEx based on a System.Drawing.StringFormat.
Syntax
  • Visual Basic
  • C#
'Declaration

Function CreateStringFormat( _
   ByVal format As StringFormat _
) As StringFormatEx
StringFormatEx CreateStringFormat(
   StringFormat format
)

Parameters

format
The string format.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


CreateTextureBrush(Stream) Method

CreateTextureBrush(Stream) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > CreateTextureBrush Method : CreateTextureBrush(Stream) Method
The System.IO.Stream contains image data.
Initializes a new BrushEx brush using the specified image data.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function CreateTextureBrush( _
   ByVal bitmap As System.IO.Stream _
) As BrushEx
BrushEx CreateTextureBrush(
   System.IO.Stream bitmap
)

Parameters

bitmap
The System.IO.Stream contains image data.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


DrawAndFillPath Method

DrawAndFillPath Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : DrawAndFillPath Method
The pen to draw the path with.
The brush to fill the path with.
The path to draw and fill.
Fills the path supplied with brush, and strokes it with pen. If brush or pen is null, corresponding operation is omitted.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub DrawAndFillPath( _
   ByVal pen As PenEx, _
   ByVal brush As BrushEx, _
   ByVal path As IPathEx _
)
void DrawAndFillPath(
   PenEx pen,
   BrushEx brush,
   IPathEx path
)

Parameters

pen
The pen to draw the path with.
brush
The brush to fill the path with.
path
The path to draw and fill.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


DrawEllipse Method (IDrawingCanvas)

DrawEllipse Method (IDrawingCanvas)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : DrawEllipse Method
Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
Overload List
Overload | Description
DrawEllipse(PenEx,Int32,Int32,Int32,Int32) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawEllipse(PenEx,RectangleEx) | Draws an ellipse specified by a bounding System.Drawing.Rectangle structure.
DrawEllipse(PenEx,Single,Single,Single,Single) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawEllipse(PenEx,RectangleFEx) | Draws an ellipse defined by a bounding System.Drawing.RectangleF.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


DrawEllipse(PenEx,Int32,Int32,Int32,Int32) Method

DrawEllipse(PenEx,Int32,Int32,Int32,Int32) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > DrawEllipse Method : DrawEllipse(PenEx,Int32,Int32,Int32,Int32) Method
The pen to draw the ellipse with.
X coordinate of the ellipse center.
Y coordinate of the ellipse center.
The width of the ellipse.
The height of the ellipse.
Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub DrawEllipse( _
   ByVal pen As PenEx, _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer _
)
void DrawEllipse(
   PenEx pen,
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

pen
The pen to draw the ellipse with.
x
X coordinate of the ellipse center.
y
Y coordinate of the ellipse center.
width
The width of the ellipse.
height
The height of the ellipse.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


DrawEllipse(PenEx,RectangleEx) Method

DrawEllipse(PenEx,RectangleEx) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > DrawEllipse Method : DrawEllipse(PenEx,RectangleEx) Method
The pen to draw the ellipse with.
The bounding rectangle of the ellipse to draw.
Draws an ellipse specified by a bounding System.Drawing.Rectangle structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub DrawEllipse( _
   ByVal pen As PenEx, _
   ByVal rect As RectangleEx _
)
void DrawEllipse(
   PenEx pen,
   RectangleEx rect
)

Parameters

pen
The pen to draw the ellipse with.
rect
The bounding rectangle of the ellipse to draw.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


DrawEllipse(PenEx,Single,Single,Single,Single) Method

DrawEllipse(PenEx,Single,Single,Single,Single) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > DrawEllipse Method : DrawEllipse(PenEx,Single,Single,Single,Single) Method
The pen to draw the ellipse with.
X coordinate of the ellipse center.
Y coordinate of the ellipse center.
The width of the ellipse.
The height of the ellipse.
Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub DrawEllipse( _
   ByVal pen As PenEx, _
   ByVal x As System.Single, _
   ByVal y As System.Single, _
   ByVal width As System.Single, _
   ByVal height As System.Single _
)
void DrawEllipse(
   PenEx pen,
   System.float x,
   System.float y,
   System.float width,
   System.float height
)

Parameters

pen
The pen to draw the ellipse with.
x
X coordinate of the ellipse center.
y
Y coordinate of the ellipse center.
width
The width of the ellipse.
height
The height of the ellipse.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


DrawEllipse(PenEx,RectangleFEx) Method

DrawEllipse(PenEx,RectangleFEx) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > DrawEllipse Method : DrawEllipse(PenEx,RectangleFEx) Method
The pen to draw the ellipse with.
The bounding rectangle of the ellipse to draw.
Draws an ellipse defined by a bounding System.Drawing.RectangleF.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub DrawEllipse( _
   ByVal pen As PenEx, _
   ByVal rect As RectangleFEx _
)
void DrawEllipse(
   PenEx pen,
   RectangleFEx rect
)

Parameters

pen
The pen to draw the ellipse with.
rect
The bounding rectangle of the ellipse to draw.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


DrawGlyphRun Method

DrawGlyphRun Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : DrawGlyphRun Method
The glyph run to draw.
The color to draw the glyph run with.
The location to draw the glyph run at.
Draws a run of glyphs.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub DrawGlyphRun( _
   ByVal glyphRun As IGlyphRun, _
   ByVal color As ColorEx, _
   ByVal point As PointFEx _
)
void DrawGlyphRun(
   IGlyphRun glyphRun,
   ColorEx color,
   PointFEx point
)

Parameters

glyphRun
The glyph run to draw.
color
The color to draw the glyph run with.
point
The location to draw the glyph run at.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


DrawImage Method (IDrawingCanvas)

DrawImage Method (IDrawingCanvas)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : DrawImage Method
Draws the specified Image at the specified location and with the specified size.
Overload List
Overload | Description
DrawImage(ImageEx,Single,Single,Single,Single) | Draws the specified Image at the specified location and with the specified size.
DrawImage(ImageEx,Single,Single,RectangleFEx,GraphicsUnitEx) | Draws a portion of an image at a specified location.
DrawImage(ImageEx,Single,Single) | Draws the specified Image object, using its original physical size, at the specified location.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


DrawImage(ImageEx,Single,Single,Single,Single) Method

DrawImage(ImageEx,Single,Single,Single,Single) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > DrawImage Method : DrawImage(ImageEx,Single,Single,Single,Single) Method
Image to draw.
The x-coordinate of the upper-left corner of the drawn image.
The y-coordinate of the upper-left corner of the drawn image.
Width of the drawn image.
Height of the drawn image.
Draws the specified Image at the specified location and with the specified size.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub DrawImage( _
   ByVal image As ImageEx, _
   ByVal x As System.Single, _
   ByVal y As System.Single, _
   ByVal width As System.Single, _
   ByVal height As System.Single _
)
void DrawImage(
   ImageEx image,
   System.float x,
   System.float y,
   System.float width,
   System.float height
)

Parameters

image
Image to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
width
Width of the drawn image.
height
Height of the drawn image.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


DrawImage(ImageEx,Single,Single,RectangleFEx,GraphicsUnitEx) Method

DrawImage(ImageEx,Single,Single,RectangleFEx,GraphicsUnitEx) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > DrawImage Method : DrawImage(ImageEx,Single,Single,RectangleFEx,GraphicsUnitEx) Method
Image to draw.
The x-coordinate of the upper-left corner of the drawn image.
The y-coordinate of the upper-left corner of the drawn image.
RectangleFEx structure that specifies the portion of the Image to draw.
Member of the GraphicsUnitEx enumeration that specifies the units of measure used by the srcRectangle parameter.
Draws a portion of an image at a specified location.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub DrawImage( _
   ByVal image As ImageEx, _
   ByVal x As System.Single, _
   ByVal y As System.Single, _
   ByVal srcRectangle As RectangleFEx, _
   ByVal srcUnit As GraphicsUnitEx _
)
void DrawImage(
   ImageEx image,
   System.float x,
   System.float y,
   RectangleFEx srcRectangle,
   GraphicsUnitEx srcUnit
)

Parameters

image
Image to draw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
srcRectangle
RectangleFEx structure that specifies the portion of the Image to draw.
srcUnit
Member of the GraphicsUnitEx enumeration that specifies the units of measure used by the srcRectangle parameter.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


DrawImage(ImageEx,Single,Single) Method

DrawImage(ImageEx,Single,Single) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > DrawImage Method : DrawImage(ImageEx,Single,Single) Method
Image todraw.
The x-coordinate of the upper-left corner of the drawn image.
The y-coordinate of the upper-left corner of the drawn image.
Draws the specified Image object, using its original physical size, at the specified location.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub DrawImage( _
   ByVal image As ImageEx, _
   ByVal x As System.Single, _
   ByVal y As System.Single _
)
void DrawImage(
   ImageEx image,
   System.float x,
   System.float y
)

Parameters

image
Image todraw.
x
The x-coordinate of the upper-left corner of the drawn image.
y
The y-coordinate of the upper-left corner of the drawn image.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


DrawLine Method (IDrawingCanvas)

DrawLine Method (IDrawingCanvas)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : DrawLine Method
PenEx that determines the color, width, and style of the line.
PointFEx structure that represents the first point to connect.
PointFEx structure that represents the second point to connect.
Draws a line connecting two PointF structures.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub DrawLine( _
   ByVal pen As PenEx, _
   ByVal from As PointFEx, _
   ByVal to As PointFEx _
)
void DrawLine(
   PenEx pen,
   PointFEx from,
   PointFEx to
)

Parameters

pen
PenEx that determines the color, width, and style of the line.
from
PointFEx structure that represents the first point to connect.
to
PointFEx structure that represents the second point to connect.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


DrawLines Method

DrawLines Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : DrawLines Method
PenEx that determines the color, width, and style of the line.
The array of the PointFEx structures that define the lines starts and ends.
Draws a series of line segments that connect an array of System.Drawing.PointF structures.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub DrawLines( _
   ByVal pen As PenEx, _
   ByVal polyLine() As PointFEx _
)
void DrawLines(
   PenEx pen,
   PointFEx[] polyLine
)

Parameters

pen
PenEx that determines the color, width, and style of the line.
polyLine
The array of the PointFEx structures that define the lines starts and ends.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


DrawPolygon Method

DrawPolygon Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : DrawPolygon Method

PenEx that determines the color, width, and style of the polygon.

The array of PointFEx stcutures that define a polygon to draw.
Draws a polygon defined by an array of System.Drawing.PointF structures
Syntax
  • Visual Basic
  • C#
'Declaration

Sub DrawPolygon( _
   ByVal pen As PenEx, _
   ByVal point() As PointFEx _
)
void DrawPolygon(
   PenEx pen,
   PointFEx[] point
)

Parameters

pen

PenEx that determines the color, width, and style of the polygon.

point
The array of PointFEx stcutures that define a polygon to draw.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


DrawRectangle Method

DrawRectangle Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : DrawRectangle Method
Draws a rectangle rectangle specified by a RectangleF structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub DrawRectangle( _
   ByVal pen As PenEx, _
   ByVal rect As RectangleFEx _
)
void DrawRectangle(
   PenEx pen,
   RectangleFEx rect
)

Parameters

pen
rect
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


DrawString Method

DrawString Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : DrawString Method
Draws the specified text string at the specified location with the specified Brush and Font objects. using the formatting attributes of the specified StringFormat object.
Overload List
Overload | Description
DrawString(String,FontEx,BrushEx,PointFEx,StringFormatEx) | Draws the specified text string at the specified location with the specified Brush and Font objects. using the formatting attributes of the specified StringFormat object.
DrawString(String,FontEx,BrushEx,RectangleFEx,StringFormatEx) | Draws the specified text string in the specified rectangle with the specified Brush and Font objects using the formatting attributes of the specified StringFormat.
DrawString(String,FontEx,BrushEx,PointFEx) | Draws the specified text string at the specified location with the specified Brush and Font objects.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


DrawString(String,FontEx,BrushEx,PointFEx,StringFormatEx) Method

DrawString(String,FontEx,BrushEx,PointFEx,StringFormatEx) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > DrawString Method : DrawString(String,FontEx,BrushEx,PointFEx,StringFormatEx) Method
String to draw.
Font that defines the text format of the string.
Brush that determines the color and texture of the drawn text.
PointFEx structure that specifies the upper-left corner of the drawn text.
StringFormat that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.
Draws the specified text string at the specified location with the specified Brush and Font objects. using the formatting attributes of the specified StringFormat object.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub DrawString( _
   ByVal value As System.String, _
   ByVal font As FontEx, _
   ByVal brush As BrushEx, _
   ByVal point As PointFEx, _
   ByVal format As StringFormatEx _
)
void DrawString(
   System.string value,
   FontEx font,
   BrushEx brush,
   PointFEx point,
   StringFormatEx format
)

Parameters

value
String to draw.
font
Font that defines the text format of the string.
brush
Brush that determines the color and texture of the drawn text.
point
PointFEx structure that specifies the upper-left corner of the drawn text.
format
StringFormat that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


DrawString(String,FontEx,BrushEx,RectangleFEx,StringFormatEx) Method

DrawString(String,FontEx,BrushEx,RectangleFEx,StringFormatEx) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > DrawString Method : DrawString(String,FontEx,BrushEx,RectangleFEx,StringFormatEx) Method
String to draw.
Font that defines the text format of the string.
Brush that determines the color and texture of the drawn text.
RectangleFEx structure that specifies the location of the drawn text.
StringFormat that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.
Draws the specified text string in the specified rectangle with the specified Brush and Font objects using the formatting attributes of the specified StringFormat.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub DrawString( _
   ByVal value As System.String, _
   ByVal font As FontEx, _
   ByVal brush As BrushEx, _
   ByVal layoutRectange As RectangleFEx, _
   ByVal format As StringFormatEx _
)
void DrawString(
   System.string value,
   FontEx font,
   BrushEx brush,
   RectangleFEx layoutRectange,
   StringFormatEx format
)

Parameters

value
String to draw.
font
Font that defines the text format of the string.
brush
Brush that determines the color and texture of the drawn text.
layoutRectange
RectangleFEx structure that specifies the location of the drawn text.
format
StringFormat that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


DrawString(String,FontEx,BrushEx,PointFEx) Method

DrawString(String,FontEx,BrushEx,PointFEx) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > DrawString Method : DrawString(String,FontEx,BrushEx,PointFEx) Method
String to draw.
Font that defines the text format of the string.
Brush that determines the color and texture of the drawn text.
PointFEx structure that specifies the upper-left corner of the drawn text.
Draws the specified text string at the specified location with the specified Brush and Font objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub DrawString( _
   ByVal s As System.String, _
   ByVal font As FontEx, _
   ByVal brush As BrushEx, _
   ByVal point As PointFEx _
)
void DrawString(
   System.string s,
   FontEx font,
   BrushEx brush,
   PointFEx point
)

Parameters

s
String to draw.
font
Font that defines the text format of the string.
brush
Brush that determines the color and texture of the drawn text.
point
PointFEx structure that specifies the upper-left corner of the drawn text.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


FillEllipse Method

FillEllipse Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : FillEllipse Method
Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
Overload List
Overload | Description
FillEllipse(BrushEx,Int32,Int32,Int32,Int32) | Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
FillEllipse(BrushEx,RectangleEx) | Fills the interior of an ellipse defined by a bounding rectangle specified by a System.Drawing.Rectangle structure.
FillEllipse(BrushEx,Single,Single,Single,Single) | Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
FillEllipse(BrushEx,RectangleFEx) | Fills the interior of an ellipse defined by a bounding rectangle specified by a System.Drawing.RectangleF structure.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


FillEllipse(BrushEx,Int32,Int32,Int32,Int32) Method

FillEllipse(BrushEx,Int32,Int32,Int32,Int32) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > FillEllipse Method : FillEllipse(BrushEx,Int32,Int32,Int32,Int32) Method
BrushEx that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
Width of the bounding rectangle that defines the ellipse.
Height of the bounding rectangle that defines the ellipse.
Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub FillEllipse( _
   ByVal brush As BrushEx, _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer _
)
void FillEllipse(
   BrushEx brush,
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

brush
BrushEx that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
Width of the bounding rectangle that defines the ellipse.
height
Height of the bounding rectangle that defines the ellipse.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


FillEllipse(BrushEx,RectangleEx) Method

FillEllipse(BrushEx,RectangleEx) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > FillEllipse Method : FillEllipse(BrushEx,RectangleEx) Method
BrushEx that determines the characteristics of the fill.
RectangleEx structure that represents the bounding rectangle that defines the ellipse.
Fills the interior of an ellipse defined by a bounding rectangle specified by a System.Drawing.Rectangle structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub FillEllipse( _
   ByVal brush As BrushEx, _
   ByVal rect As RectangleEx _
)
void FillEllipse(
   BrushEx brush,
   RectangleEx rect
)

Parameters

brush
BrushEx that determines the characteristics of the fill.
rect
RectangleEx structure that represents the bounding rectangle that defines the ellipse.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


FillEllipse(BrushEx,Single,Single,Single,Single) Method

FillEllipse(BrushEx,Single,Single,Single,Single) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > FillEllipse Method : FillEllipse(BrushEx,Single,Single,Single,Single) Method
BrushEx that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
Width of the bounding rectangle that defines the ellipse.
Height of the bounding rectangle that defines the ellipse.
Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub FillEllipse( _
   ByVal brush As BrushEx, _
   ByVal x As System.Single, _
   ByVal y As System.Single, _
   ByVal width As System.Single, _
   ByVal height As System.Single _
)
void FillEllipse(
   BrushEx brush,
   System.float x,
   System.float y,
   System.float width,
   System.float height
)

Parameters

brush
BrushEx that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
Width of the bounding rectangle that defines the ellipse.
height
Height of the bounding rectangle that defines the ellipse.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


FillEllipse(BrushEx,RectangleFEx) Method

FillEllipse(BrushEx,RectangleFEx) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > FillEllipse Method : FillEllipse(BrushEx,RectangleFEx) Method
BrushEx that determines the characteristics of the fill.
RectangleFEx structure that represents the bounding rectangle that defines the ellipse.
Fills the interior of an ellipse defined by a bounding rectangle specified by a System.Drawing.RectangleF structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub FillEllipse( _
   ByVal brush As BrushEx, _
   ByVal rect As RectangleFEx _
)
void FillEllipse(
   BrushEx brush,
   RectangleFEx rect
)

Parameters

brush
BrushEx that determines the characteristics of the fill.
rect
RectangleFEx structure that represents the bounding rectangle that defines the ellipse.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


FillPolygon Method

FillPolygon Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : FillPolygon Method
BrushEx that determines the characteristics of the fill.
Array of PointFEx structures that represent the vertices of the polygon to fill.
Fills the interior of a polygon defined by an array of points specified by System.Drawing.PointF structures
Syntax
  • Visual Basic
  • C#
'Declaration

Sub FillPolygon( _
   ByVal brush As BrushEx, _
   ByVal polygon() As PointFEx _
)
void FillPolygon(
   BrushEx brush,
   PointFEx[] polygon
)

Parameters

brush
BrushEx that determines the characteristics of the fill.
polygon
Array of PointFEx structures that represent the vertices of the polygon to fill.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


FillRectangle Method

FillRectangle Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : FillRectangle Method
Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
Overload List
Overload | Description
FillRectangle(BrushEx,Single,Single,Single,Single) | Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
FillRectangle(BrushEx,RectangleFEx) | Fills the interior of a rectangle specified by a RectangleF structure.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


FillRectangle(BrushEx,Single,Single,Single,Single) Method

FillRectangle(BrushEx,Single,Single,Single,Single) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > FillRectangle Method : FillRectangle(BrushEx,Single,Single,Single,Single) Method
BrushEx that determines the characteristics of the fill.
The x-coordinate of the upper-left corner of the bounding rectangle that defines the rectangle.
The y-coordinate of the upper-left corner of the bounding rectangle that defines the rectangle.
Width of the bounding rectangle that defines the rectangle.
Height of the bounding rectangle that defines the rectangle.
Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub FillRectangle( _
   ByVal brush As BrushEx, _
   ByVal x As System.Single, _
   ByVal y As System.Single, _
   ByVal width As System.Single, _
   ByVal height As System.Single _
)
void FillRectangle(
   BrushEx brush,
   System.float x,
   System.float y,
   System.float width,
   System.float height
)

Parameters

brush
BrushEx that determines the characteristics of the fill.
x
The x-coordinate of the upper-left corner of the bounding rectangle that defines the rectangle.
y
The y-coordinate of the upper-left corner of the bounding rectangle that defines the rectangle.
width
Width of the bounding rectangle that defines the rectangle.
height
Height of the bounding rectangle that defines the rectangle.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


FillRectangle(BrushEx,RectangleFEx) Method

FillRectangle(BrushEx,RectangleFEx) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > FillRectangle Method : FillRectangle(BrushEx,RectangleFEx) Method
BrushEx that determines the characteristics of the fill.
RectangleFEx structure that represents the bounding rectangle that defines the rectangle.
Fills the interior of a rectangle specified by a RectangleF structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub FillRectangle( _
   ByVal brush As BrushEx, _
   ByVal rect As RectangleFEx _
)
void FillRectangle(
   BrushEx brush,
   RectangleFEx rect
)

Parameters

brush
BrushEx that determines the characteristics of the fill.
rect
RectangleFEx structure that represents the bounding rectangle that defines the rectangle.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


IntersectClip Method

IntersectClip Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : IntersectClip Method
Sets the clipping region of this Graphics object to the rectangle specified by a RectangleF structure.
Overload List
Overload | Description
IntersectClip(RectangleFEx) | Sets the clipping region of this Graphics object to the rectangle specified by a RectangleF structure.
IntersectClip(IPathEx) | Sets the clipping region of this Graphics object to the shape specified by a IDDPath structure.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


IntersectClip(RectangleFEx) Method

IntersectClip(RectangleFEx) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > IntersectClip Method : IntersectClip(RectangleFEx) Method
RectangleFEx structure to intersect with the current clip region.
Sets the clipping region of this Graphics object to the rectangle specified by a RectangleF structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub IntersectClip( _
   ByVal rect As RectangleFEx _
)
void IntersectClip(
   RectangleFEx rect
)

Parameters

rect
RectangleFEx structure to intersect with the current clip region.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


IntersectClip(IPathEx) Method

IntersectClip(IPathEx) Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface > IntersectClip Method : IntersectClip(IPathEx) Method
IPathEx structure to intersect with the current clip region.
Sets the clipping region of this Graphics object to the shape specified by a IDDPath structure.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub IntersectClip( _
   ByVal path As IPathEx _
)
void IntersectClip(
   IPathEx path
)

Parameters

path
IPathEx structure to intersect with the current clip region.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members
Overload List


PopState Method

PopState Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : PopState Method
Restores the state of this IDrawingCanvas object to the previous saved state.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub PopState()
void PopState()
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


PushState Method

PushState Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : PushState Method
Saves the current state on a stack.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub PushState()
void PushState()
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


TranslateTransform Method

TranslateTransform Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : TranslateTransform Method
The x-coordinate of the translation.
The y-coordinate of the translation.
Prepends the specified translation to the transformation matrix of this Graphics object.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub TranslateTransform( _
   ByVal dx As System.Single, _
   ByVal dy As System.Single _
)
void TranslateTransform(
   System.float dx,
   System.float dy
)

Parameters

dx
The x-coordinate of the translation.
dy
The y-coordinate of the translation.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


IDrawingCanvas Interface Properties

IDrawingCanvas Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : IDrawingCanvas Interface

For a list of all members of this type, see IDrawingCanvas members.

Public Properties
 | Name | Description
Property | ClipBounds | Gets a RectangleF structure that bounds the clipping region of this Graphics object.
Property | IsDrawStringWithDelayedContentSupported | Returns whether the IDrawingCanvas supports drawing delayed content.
Property | RenderCallback | Returns method for performing some action with canvas during rendering
Property | SmoothingMode | Specifies the rendering quality for lines, curves, and the edges of filled areas.
Property | TextRenderingHint | Specifies the quality of text rendering.
Property | Transform | Gets or sets the world transformation for this object
Top
See Also

Reference

IDrawingCanvas Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


ClipBounds Property

ClipBounds Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : ClipBounds Property
Gets a RectangleF structure that bounds the clipping region of this Graphics object.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ClipBounds As RectangleFEx
RectangleFEx ClipBounds {get;}
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


IsDrawStringWithDelayedContentSupported Property

IsDrawStringWithDelayedContentSupported Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : IsDrawStringWithDelayedContentSupported Property
Returns whether the IDrawingCanvas supports drawing delayed content.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property IsDrawStringWithDelayedContentSupported As System.Boolean
System.bool IsDrawStringWithDelayedContentSupported {get;}
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


RenderCallback Property

RenderCallback Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : RenderCallback Property
Returns method for performing some action with canvas during rendering
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RenderCallback As System.Action(Of ILayoutArea)
System.Action<ILayoutArea> RenderCallback {get;}
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


SmoothingMode Property

SmoothingMode Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : SmoothingMode Property
Specifies the rendering quality for lines, curves, and the edges of filled areas.
Syntax
  • Visual Basic
  • C#
'Declaration

Property SmoothingMode As SmoothingModeEx
SmoothingModeEx SmoothingMode {get; set;}
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


TextRenderingHint Property

TextRenderingHint Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : TextRenderingHint Property
Specifies the quality of text rendering.
Syntax
  • Visual Basic
  • C#
'Declaration

Property TextRenderingHint As TextRenderingHintEx
TextRenderingHintEx TextRenderingHint {get; set;}
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


Transform Property

Transform Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : Transform Property
Gets or sets the world transformation for this object
Syntax
  • Visual Basic
  • C#
'Declaration

Property Transform As MatrixEx
MatrixEx Transform {get; set;}
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


IFontInfo Interface

IFontInfo Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : IFontInfo Interface
Specifies the information about the font.
Object Model
IFontInfo Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IFontInfo
public interface IFontInfo
See Also

Reference

IFontInfo Members
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


IFontInfo Interface Members

IFontInfo Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : IFontInfo Interface

The following tables list the members exposed by IFontInfo.

Public Properties
 | Name | Description
Property | Decoration | Font FontDecoration attribute.
Property | Family | Returns font family.
Property | Name | Returns font name.
Property | Size | Returns em-size in points.
Property | Style | Font FontStyle attribute.
Property | Weight | Font FontWeight attribute
Top
Public Methods
 | Name | Description
Method | Dispose | (Inherited from System.IDisposable)
Method | Map | Returns a mapped font
Method | Unmap | Try to release the font from cache or destroy.
Top
See Also

Reference

IFontInfo Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


IFontInfo Interface Methods

IFontInfo Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : IFontInfo Interface

For a list of all members of this type, see IFontInfo members.

Public Methods
 | Name | Description
Method | Dispose | (Inherited from System.IDisposable)
Method | Map | Returns a mapped font
Method | Unmap | Try to release the font from cache or destroy.
Top
See Also

Reference

IFontInfo Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


Map Method

Map Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IFontInfo Interface : Map Method
Returns a mapped font
Syntax
  • Visual Basic
  • C#
'Declaration

Function Map() As Font
Font Map()
Remarks
this implementation will try to use a cached font first (using the existing caching facility, associated with the context).
See Also

Reference

IFontInfo Interface
IFontInfo Members


Unmap Method

Unmap Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IFontInfo Interface : Unmap Method
Try to release the font from cache or destroy.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Unmap( _
   ByVal font As Font _
)
void Unmap(
   Font font
)

Parameters

font
See Also

Reference

IFontInfo Interface
IFontInfo Members


IFontInfo Interface Properties

IFontInfo Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : IFontInfo Interface

For a list of all members of this type, see IFontInfo members.

Public Properties
 | Name | Description
Property | Decoration | Font FontDecoration attribute.
Property | Family | Returns font family.
Property | Name | Returns font name.
Property | Size | Returns em-size in points.
Property | Style | Font FontStyle attribute.
Property | Weight | Font FontWeight attribute
Top
See Also

Reference

IFontInfo Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


Decoration Property

Decoration Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IFontInfo Interface : Decoration Property
Font FontDecoration attribute.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Decoration As FontDecoration
FontDecoration Decoration {get;}
See Also

Reference

IFontInfo Interface
IFontInfo Members


Family Property

Family Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IFontInfo Interface : Family Property
Returns font family.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Family As System.String
System.string Family {get;}
See Also

Reference

IFontInfo Interface
IFontInfo Members


Name Property (IFontInfo)

Name Property (IFontInfo)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IFontInfo Interface : Name Property
Returns font name.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Name As System.String
System.string Name {get;}
See Also

Reference

IFontInfo Interface
IFontInfo Members


Size Property (IFontInfo)

Size Property (IFontInfo)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IFontInfo Interface : Size Property
Returns em-size in points.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Size As System.Single
System.float Size {get;}
See Also

Reference

IFontInfo Interface
IFontInfo Members


Style Property (IFontInfo)

Style Property (IFontInfo)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IFontInfo Interface : Style Property
Font FontStyle attribute.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Style As FontStyle
FontStyle Style {get;}
See Also

Reference

IFontInfo Interface
IFontInfo Members


Weight Property (IFontInfo)

Weight Property (IFontInfo)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IFontInfo Interface : Weight Property
Font FontWeight attribute
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Weight As FontWeight
FontWeight Weight {get;}
See Also

Reference

IFontInfo Interface
IFontInfo Members


IGlyphRun Interface

IGlyphRun Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : IGlyphRun Interface
Defines a run of glyphs
Object Model
IGlyphRun Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IGlyphRun
public interface IGlyphRun
See Also

Reference

IGlyphRun Members
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


IGlyphRun Interface Members

IGlyphRun Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : IGlyphRun Interface

The following tables list the members exposed by IGlyphRun.

Public Properties
 | Name | Description
Property | AdvanceWidths | Array of widths corresponding with each glyph index.
Property | Characters | Array of chars that represents the original text.
Property | Font | Font associated with this glyph run.
Property | GlyphIndicies | Array of glyph indexes used to draw the text.
Top
See Also

Reference

IGlyphRun Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


IGlyphRun Interface Properties

IGlyphRun Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : IGlyphRun Interface

For a list of all members of this type, see IGlyphRun members.

Public Properties
 | Name | Description
Property | AdvanceWidths | Array of widths corresponding with each glyph index.
Property | Characters | Array of chars that represents the original text.
Property | Font | Font associated with this glyph run.
Property | GlyphIndicies | Array of glyph indexes used to draw the text.
Top
See Also

Reference

IGlyphRun Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


AdvanceWidths Property

AdvanceWidths Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IGlyphRun Interface : AdvanceWidths Property
Array of widths corresponding with each glyph index.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property AdvanceWidths As System.Single()
System.float[] AdvanceWidths {get;}
See Also

Reference

IGlyphRun Interface
IGlyphRun Members


Characters Property

Characters Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IGlyphRun Interface : Characters Property
Array of chars that represents the original text.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Characters As System.Char()
System.char[] Characters {get;}
See Also

Reference

IGlyphRun Interface
IGlyphRun Members


Font Property (IGlyphRun)

Font Property (IGlyphRun)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IGlyphRun Interface : Font Property
Font associated with this glyph run.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Font As FontEx
FontEx Font {get;}
See Also

Reference

IGlyphRun Interface
IGlyphRun Members


GlyphIndicies Property

GlyphIndicies Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IGlyphRun Interface : GlyphIndicies Property
Array of glyph indexes used to draw the text.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property GlyphIndicies As System.Short()
System.short[] GlyphIndicies {get;}
See Also

Reference

IGlyphRun Interface
IGlyphRun Members


IPathEx Interface

IPathEx Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : IPathEx Interface
Represents an abstract series of connected lines and curves.
Object Model
IPathEx Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IPathEx
public interface IPathEx
See Also

Reference

IPathEx Members
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


IPathEx Interface Members

IPathEx Interface Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : IPathEx Interface

The following tables list the members exposed by IPathEx.

Public Properties
 | Name | Description
Property | FillMode | Gets or sets a FillMode enumeration that determines how the interiors of shapes in this GraphicsPath are filled.
Top
Public Methods
 | Name | Description
Method | AddArc | Appends an elliptical arc to the current figure
Method | AddCurve | Adds a spline curve to the current figure
Method | AddEllipse | Adds an ellipse to the current path
Method | AddLine | Appends a line segment to this DDPath
Method | AddLines | Appends multiple line segments to this DDPath
Method | AddLineTo | Adds line from path's current end point to the specified point
Method | AddPath | Appends the specified DDPath object to this path
Method | AddRectangle | Appends rectangle to this path
Method | Clone | Creates an exact copy of this IPathEx
Method | CloseAllFigures | Closes all open figures in this path and starts a new figure. It closes each open figure by connecting a line from its endpoint to its starting point.
Method | Dispose | (Inherited from System.IDisposable)
Method | GetBounds | Returns a rectangle bounding this path.
Method | IsVisible | Indicated whether the specifies System.Drawing.PointF is contained withing this path.
Top
See Also

Reference

IPathEx Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


IPathEx Interface Methods

IPathEx Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : IPathEx Interface

For a list of all members of this type, see IPathEx members.

Public Methods
 | Name | Description
Method | AddArc | Appends an elliptical arc to the current figure
Method | AddCurve | Adds a spline curve to the current figure
Method | AddEllipse | Adds an ellipse to the current path
Method | AddLine | Appends a line segment to this DDPath
Method | AddLines | Appends multiple line segments to this DDPath
Method | AddLineTo | Adds line from path's current end point to the specified point
Method | AddPath | Appends the specified DDPath object to this path
Method | AddRectangle | Appends rectangle to this path
Method | Clone | Creates an exact copy of this IPathEx
Method | CloseAllFigures | Closes all open figures in this path and starts a new figure. It closes each open figure by connecting a line from its endpoint to its starting point.
Method | Dispose | (Inherited from System.IDisposable)
Method | GetBounds | Returns a rectangle bounding this path.
Method | IsVisible | Indicated whether the specifies System.Drawing.PointF is contained withing this path.
Top
See Also

Reference

IPathEx Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


AddArc Method

AddArc Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IPathEx Interface : AddArc Method
The x-coordinate of the upper-left corner of the rectangular region that defines the ellipse from which the arc is drawn.
The y-coordinate of the upper-left corner of the rectangular region that defines the ellipse from which the arc is drawn.
The width of the rectangular region that defines the ellipse from which the arc is drawn.
The height of the rectangular region that defines the ellipse from which the arc is drawn.
The starting angle of the arc.
The angle between startAngle and the end of the arc.
Appends an elliptical arc to the current figure
Syntax
  • Visual Basic
  • C#
'Declaration

Sub AddArc( _
   ByVal x As System.Single, _
   ByVal y As System.Single, _
   ByVal width As System.Single, _
   ByVal height As System.Single, _
   ByVal startAngle As System.Single, _
   ByVal sweepAngle As System.Single _
)
void AddArc(
   System.float x,
   System.float y,
   System.float width,
   System.float height,
   System.float startAngle,
   System.float sweepAngle
)

Parameters

x
The x-coordinate of the upper-left corner of the rectangular region that defines the ellipse from which the arc is drawn.
y
The y-coordinate of the upper-left corner of the rectangular region that defines the ellipse from which the arc is drawn.
width
The width of the rectangular region that defines the ellipse from which the arc is drawn.
height
The height of the rectangular region that defines the ellipse from which the arc is drawn.
startAngle
The starting angle of the arc.
sweepAngle
The angle between startAngle and the end of the arc.
See Also

Reference

IPathEx Interface
IPathEx Members


AddCurve Method

AddCurve Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IPathEx Interface : AddCurve Method
An array of PointFEx structures that represents the points that define the curve.
A value that specifies the amount that the curve bends between control points. Values greater than 1 produce unpredictable results.
Adds a spline curve to the current figure
Syntax
  • Visual Basic
  • C#
'Declaration

Sub AddCurve( _
   ByVal pointData() As PointFEx, _
   ByVal tension As System.Single _
)
void AddCurve(
   PointFEx[] pointData,
   System.float tension
)

Parameters

pointData
An array of PointFEx structures that represents the points that define the curve.
tension
A value that specifies the amount that the curve bends between control points. Values greater than 1 produce unpredictable results.
See Also

Reference

IPathEx Interface
IPathEx Members


AddEllipse Method

AddEllipse Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IPathEx Interface : AddEllipse Method

The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.

The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.

The width of the bounding rectangle that defines the ellipse.

The height of the bounding rectangle that defines the ellipse.

Adds an ellipse to the current path
Syntax
  • Visual Basic
  • C#
'Declaration

Sub AddEllipse( _
   ByVal x As System.Single, _
   ByVal y As System.Single, _
   ByVal width As System.Single, _
   ByVal height As System.Single _
)
void AddEllipse(
   System.float x,
   System.float y,
   System.float width,
   System.float height
)

Parameters

x

The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.

y

The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.

width

The width of the bounding rectangle that defines the ellipse.

height

The height of the bounding rectangle that defines the ellipse.

See Also

Reference

IPathEx Interface
IPathEx Members


AddLine Method (IPathEx)

AddLine Method (IPathEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IPathEx Interface : AddLine Method
A PointFEx that represents the starting point of the line.
A PointFEx that represents the endpoint of the line.
Appends a line segment to this DDPath
Syntax
  • Visual Basic
  • C#
'Declaration

Sub AddLine( _
   ByVal point1 As PointFEx, _
   ByVal point2 As PointFEx _
)
void AddLine(
   PointFEx point1,
   PointFEx point2
)

Parameters

point1
A PointFEx that represents the starting point of the line.
point2
A PointFEx that represents the endpoint of the line.
See Also

Reference

IPathEx Interface
IPathEx Members


AddLines Method

AddLines Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IPathEx Interface : AddLines Method
An array of PointFEx structures that represents the points that define the line segments to add.
Appends multiple line segments to this DDPath
Syntax
  • Visual Basic
  • C#
'Declaration

Sub AddLines( _
   ByVal linePoints() As PointFEx _
)
void AddLines(
   PointFEx[] linePoints
)

Parameters

linePoints
An array of PointFEx structures that represents the points that define the line segments to add.
See Also

Reference

IPathEx Interface
IPathEx Members


AddLineTo Method

AddLineTo Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IPathEx Interface : AddLineTo Method
A PointFEx that represents the end point of the line.
Adds line from path's current end point to the specified point
Syntax
  • Visual Basic
  • C#
'Declaration

Sub AddLineTo( _
   ByVal point As PointFEx _
)
void AddLineTo(
   PointFEx point
)

Parameters

point
A PointFEx that represents the end point of the line.
See Also

Reference

IPathEx Interface
IPathEx Members


AddPath Method

AddPath Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IPathEx Interface : AddPath Method
The IPathEx to add.
Appends the specified DDPath object to this path
Syntax
  • Visual Basic
  • C#
'Declaration

Sub AddPath( _
   ByVal graphicsPath As IPathEx _
)
void AddPath(
   IPathEx graphicsPath
)

Parameters

graphicsPath
The IPathEx to add.
See Also

Reference

IPathEx Interface
IPathEx Members


AddRectangle Method

AddRectangle Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IPathEx Interface : AddRectangle Method
Appends rectangle to this path
Syntax
  • Visual Basic
  • C#
'Declaration

Sub AddRectangle( _
   ByVal rectangle As RectangleFEx _
)
void AddRectangle(
   RectangleFEx rectangle
)

Parameters

rectangle
See Also

Reference

IPathEx Interface
IPathEx Members


Clone Method (IPathEx)

Clone Method (IPathEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IPathEx Interface : Clone Method
Creates an exact copy of this IPathEx
Syntax
  • Visual Basic
  • C#
'Declaration

Function Clone() As IPathEx
IPathEx Clone()
See Also

Reference

IPathEx Interface
IPathEx Members


CloseAllFigures Method

CloseAllFigures Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IPathEx Interface : CloseAllFigures Method
Closes all open figures in this path and starts a new figure. It closes each open figure by connecting a line from its endpoint to its starting point.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub CloseAllFigures()
void CloseAllFigures()
See Also

Reference

IPathEx Interface
IPathEx Members


GetBounds Method (IPathEx)

GetBounds Method (IPathEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IPathEx Interface : GetBounds Method
Returns a rectangle bounding this path.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetBounds() As RectangleFEx
RectangleFEx GetBounds()
See Also

Reference

IPathEx Interface
IPathEx Members


IsVisible Method

IsVisible Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IPathEx Interface : IsVisible Method
PointFEx that represents the end point of the point line.
Indicated whether the specifies System.Drawing.PointF is contained withing this path.
Syntax
  • Visual Basic
  • C#
'Declaration

Function IsVisible( _
   ByVal point As PointFEx _
) As System.Boolean
System.bool IsVisible(
   PointFEx point
)

Parameters

point
PointFEx that represents the end point of the point line.
See Also

Reference

IPathEx Interface
IPathEx Members


IPathEx Interface Properties

IPathEx Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace : IPathEx Interface

For a list of all members of this type, see IPathEx members.

Public Properties
 | Name | Description
Property | FillMode | Gets or sets a FillMode enumeration that determines how the interiors of shapes in this GraphicsPath are filled.
Top
See Also

Reference

IPathEx Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace


FillMode Property

FillMode Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IPathEx Interface : FillMode Property
Gets or sets a FillMode enumeration that determines how the interiors of shapes in this GraphicsPath are filled.
Syntax
  • Visual Basic
  • C#
'Declaration

Property FillMode As FillModeEx
FillModeEx FillMode {get; set;}
See Also

Reference

IPathEx Interface
IPathEx Members


GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace

GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace
The GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity namespace includes members to add interactive features in the report.
Interfaces
 | Interface | Description
Interface | IImageMapArea | Interface for defining image map area information for creating image maps for an image.
Enumerations
 | Enumeration | Description
Enumeration | ImageMapShape | Defines shapes used by IImageMapArea
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


ImageMapShape Enumeration

ImageMapShape Enumeration

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace : ImageMapShape Enumeration
Defines shapes used by IImageMapArea
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ImageMapShape
   Inherits System.Enum
public enum ImageMapShape : System.Enum
Members
Member | Description
Circle | Not implemented
Polygon | The shape is a Polygon
Rectangle | The shape is a Rectangle.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity.ImageMapShape

See Also

Reference

GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace


IImageMapArea Interface

IImageMapArea Interface
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace : IImageMapArea Interface
Interface for defining image map area information for creating image maps for an image.
Object Model
IImageMapArea Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IImageMapArea
public interface IImageMapArea
See Also

Reference

IImageMapArea Members
GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace


IImageMapArea Interface Members

IImageMapArea Interface Members
Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace : IImageMapArea Interface

The following tables list the members exposed by IImageMapArea.

Public Properties
 | Name | Description
Property | Coordinates | Gets the coordinates for this instance.
Property | Id | Gets the ID for this instance.
Property | shape | Gets the ImageMapShape this instance represents.
Top
See Also

Reference

IImageMapArea Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace


IImageMapArea Interface Properties

IImageMapArea Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace : IImageMapArea Interface

For a list of all members of this type, see IImageMapArea members.

Public Properties
 | Name | Description
Property | Coordinates | Gets the coordinates for this instance.
Property | Id | Gets the ID for this instance.
Property | shape | Gets the ImageMapShape this instance represents.
Top
See Also

Reference

IImageMapArea Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace


Coordinates Property

Coordinates Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace > IImageMapArea Interface : Coordinates Property
Gets the coordinates for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Coordinates As System.Single()
System.float[] Coordinates {get;}
See Also

Reference

IImageMapArea Interface
IImageMapArea Members


Id Property (IImageMapArea)

Id Property (IImageMapArea)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace > IImageMapArea Interface : Id Property
Gets the ID for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Id As System.String
System.string Id {get;}
See Also

Reference

IImageMapArea Interface
IImageMapArea Members


shape Property (IImageMapArea)

shape Property (IImageMapArea)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace > IImageMapArea Interface : shape Property
Gets the ImageMapShape this instance represents.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property shape As ImageMapShape
ImageMapShape shape {get;}
See Also

Reference

IImageMapArea Interface
IImageMapArea Members


GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace

GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace
The GrapeCity.ActiveReports.Extensibility.Rendering.IO namespace includes StreamInfo and StreamProvider class.
Classes
 | Class | Description
Class | StreamInfo | Wraps info about streams. Used with StreamProvider to access streams.
Class | StreamProvider | Base class for stream provider for rendering report extension outputs to a file.
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


StreamInfo Class

StreamInfo Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace : StreamInfo Class
Wraps info about streams. Used with StreamProvider to access streams.
Object Model
StreamInfo Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class StreamInfo
public abstract class StreamInfo
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamInfo

See Also

Reference

StreamInfo Members
GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace


StreamInfo Class Members

StreamInfo Class Members
Properties Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace : StreamInfo Class

The following tables list the members exposed by StreamInfo.

Public Properties
 | Name | Description
Public Property | MimeType | Returns MimeType of the underlying stream
Public Property | Uri | Returns System.Uri of the underlying stream
Top
Public Methods
 | Name | Description
Public Method | OpenStream | Returns instance to the underlying System.IO.Stream
Top
See Also

Reference

StreamInfo Class
GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace


StreamInfo Class Methods

StreamInfo Class Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace : StreamInfo Class

For a list of all members of this type, see StreamInfo members.

Public Methods
 | Name | Description
Public Method | OpenStream | Returns instance to the underlying System.IO.Stream
Top
See Also

Reference

StreamInfo Class
GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace


OpenStream Method

OpenStream Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace > StreamInfo Class : OpenStream Method
Returns instance to the underlying System.IO.Stream
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Function OpenStream() As System.IO.Stream
public abstract System.IO.Stream OpenStream()
See Also

Reference

StreamInfo Class
StreamInfo Members


StreamInfo Class Properties

StreamInfo Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace : StreamInfo Class

For a list of all members of this type, see StreamInfo members.

Public Properties
 | Name | Description
Public Property | MimeType | Returns MimeType of the underlying stream
Public Property | Uri | Returns System.Uri of the underlying stream
Top
See Also

Reference

StreamInfo Class
GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace


MimeType Property (StreamInfo)

MimeType Property (StreamInfo)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace > StreamInfo Class : MimeType Property
Returns MimeType of the underlying stream
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MimeType As System.String
public System.string MimeType {get;}
See Also

Reference

StreamInfo Class
StreamInfo Members


Uri Property

Uri Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace > StreamInfo Class : Uri Property
Returns System.Uri of the underlying stream
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Uri As System.Uri
public System.Uri Uri {get;}
See Also

Reference

StreamInfo Class
StreamInfo Members


StreamProvider Class

StreamProvider Class
Members

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace : StreamProvider Class
Base class for stream provider for rendering report extension outputs to a file.
Object Model
StreamProvider Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class StreamProvider
public abstract class StreamProvider
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider
GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider

See Also

Reference

StreamProvider Members
GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace


StreamProvider Class Members

StreamProvider Class Members
Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace : StreamProvider Class

The following tables list the members exposed by StreamProvider.

Public Methods
 | Name | Description
Public Method | CleanUpOnError | Performs the required clean up in case of a rendering error.
Public Method | CreatePrimaryStream | Returns DataDynamics.Reports.Extensibility.IO.StreamInfo of the primary stream.
Public Method | CreateSecondaryStream | Returns StreamInfo of the primary stream.
Public Method | GetPrimaryStream | Returns a DataDynamics.Reports.Extensibility.IO.StreamInfo providing access to the primary stream.
Public Method | GetSecondaryStreams | Returns an array of DataDynamics.Reports.Extensibility.IO.StreamInfo objects providing access to the secondary stream(s).
Top
See Also

Reference

StreamProvider Class
GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace


StreamProvider Class Methods

StreamProvider Class Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace : StreamProvider Class

For a list of all members of this type, see StreamProvider members.

Public Methods
 | Name | Description
Public Method | CleanUpOnError | Performs the required clean up in case of a rendering error.
Public Method | CreatePrimaryStream | Returns DataDynamics.Reports.Extensibility.IO.StreamInfo of the primary stream.
Public Method | CreateSecondaryStream | Returns StreamInfo of the primary stream.
Public Method | GetPrimaryStream | Returns a DataDynamics.Reports.Extensibility.IO.StreamInfo providing access to the primary stream.
Public Method | GetSecondaryStreams | Returns an array of DataDynamics.Reports.Extensibility.IO.StreamInfo objects providing access to the secondary stream(s).
Top
See Also

Reference

StreamProvider Class
GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace


CleanUpOnError Method (StreamProvider)

CleanUpOnError Method (StreamProvider)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace > StreamProvider Class : CleanUpOnError Method
Performs the required clean up in case of a rendering error.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub CleanUpOnError()
public virtual void CleanUpOnError()
See Also

Reference

StreamProvider Class
StreamProvider Members


CreatePrimaryStream Method (StreamProvider)

CreatePrimaryStream Method (StreamProvider)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace > StreamProvider Class : CreatePrimaryStream Method
mime type of the primary stram
suggested file extension
Returns DataDynamics.Reports.Extensibility.IO.StreamInfo of the primary stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Function CreatePrimaryStream( _
   ByVal mimeType As System.String, _
   ByVal suggestedFileExtension As System.String _
) As StreamInfo
public abstract StreamInfo CreatePrimaryStream(
   System.string mimeType,
   System.string suggestedFileExtension
)

Parameters

mimeType
mime type of the primary stram
suggestedFileExtension
suggested file extension
See Also

Reference

StreamProvider Class
StreamProvider Members


CreateSecondaryStream Method (StreamProvider)

CreateSecondaryStream Method (StreamProvider)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace > StreamProvider Class : CreateSecondaryStream Method
relative name
mime type of the primary stram
suggested file extension
Returns StreamInfo of the primary stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Function CreateSecondaryStream( _
   ByVal relativeName As System.String, _
   ByVal mimeType As System.String, _
   ByVal suggestedFileExtension As System.String _
) As StreamInfo
public abstract StreamInfo CreateSecondaryStream(
   System.string relativeName,
   System.string mimeType,
   System.string suggestedFileExtension
)

Parameters

relativeName
relative name
mimeType
mime type of the primary stram
suggestedFileExtension
suggested file extension
See Also

Reference

StreamProvider Class
StreamProvider Members


GetPrimaryStream Method (StreamProvider)

GetPrimaryStream Method (StreamProvider)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace > StreamProvider Class : GetPrimaryStream Method
Returns a DataDynamics.Reports.Extensibility.IO.StreamInfo providing access to the primary stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Function GetPrimaryStream() As StreamInfo
public abstract StreamInfo GetPrimaryStream()
See Also

Reference

StreamProvider Class
StreamProvider Members


GetSecondaryStreams Method (StreamProvider)

GetSecondaryStreams Method (StreamProvider)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace > StreamProvider Class : GetSecondaryStreams Method
Returns an array of DataDynamics.Reports.Extensibility.IO.StreamInfo objects providing access to the secondary stream(s).
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Function GetSecondaryStreams() As StreamInfo()
public abstract StreamInfo[] GetSecondaryStreams()
See Also

Reference

StreamProvider Class
StreamProvider Members


GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports.v10)

GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports.v10)
Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports Namespace
The GrapeCity.ActiveReports namespace contains the report, control, and section classes that are the basis of all reports.
Classes
 | Class | Description
Class | InvalidReportDefinitionException | Exception raised when a report definition is invalid.
Class | LocateCredentialsEventArgs | Provides data for LocateCredentials event.
Class | LocateDataSourceEventArgs | Provides data for the LocateDataSource event.
Class | PageReport | Loads, modifies, or saves a report definition.
Class | PageSettings | Specifies the page settings used to print the report document pages.
Class | ReportDataException | This exception is thrown when an error occurs while connecting to the report's data source.
Class | ReportException | This exception or one of its descendent classes is thrown when an error occurs while running the report.
Class | ReportScriptException | The ReportScriptException is thrown when an error occurs in the report scripting code or any of the report's calculated DataField expressions.
Class | SectionCollection | Represents a collection of all sections (Section objects) in the report layout.
Class | SectionReport | The SectionReport class is the base class for all section reports. It is used to execute and render the report.
Class | SectionReport.FetchEventArgs | FetchEventArgs class provides data required for the FetchData Event.
Class | SystemPrinter | Represents the settings of the SystemPrinter class.
Delegates
 | Delegate | Description
Delegate | LocateCredentialsEventHandler | Represents method that handles LocateCredentials event.
Delegate | LocateDataSourceEventHandler | Represents the method that will handle the LocateDataSource event
Delegate | SectionReport.FetchEventHandler | Represents the method that handles the FetchData event.
Delegate | SectionReport.ParameterUIClosedHandler | Represents a method that handles the ParameterUIClosed event.
Enumerations
 | Enumeration | Description
Enumeration | LayoutAction | Specifies the action to be performed after a section is formatted.
Enumeration | PageSettings.PrinterCollate | Determines the collation order when printing multiple copies of a report.
Enumeration | ReportProcessingError | Describe possible error codes for future detail processing of the error.
Enumeration | SectionReport.ReportState | Determines the current state of the report engine.
Enumeration | SectionReport.RpxFormat | Specifies the format in which the report is to be saved.
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


InvalidReportDefinitionException Class

InvalidReportDefinitionException Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : InvalidReportDefinitionException Class
Exception raised when a report definition is invalid.
Object Model
InvalidReportDefinitionException Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class InvalidReportDefinitionException
   Inherits ReportException
public class InvalidReportDefinitionException : ReportException
Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.ReportException
GrapeCity.ActiveReports.InvalidReportDefinitionException

See Also

Reference

InvalidReportDefinitionException Members
GrapeCity.ActiveReports Namespace


InvalidReportDefinitionException Class Members

InvalidReportDefinitionException Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : InvalidReportDefinitionException Class

The following tables list the members exposed by InvalidReportDefinitionException.

Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorCode | Error code for future detail processing. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | ErrorData | Error data, depends on error code. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

InvalidReportDefinitionException Class
GrapeCity.ActiveReports Namespace


LocateCredentialsEventArgs Class

LocateCredentialsEventArgs Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : LocateCredentialsEventArgs Class
Provides data for LocateCredentials event.
Object Model
LocateCredentialsEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class LocateCredentialsEventArgs
   Inherits System.EventArgs
public sealed class LocateCredentialsEventArgs : System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.LocateCredentialsEventArgs

See Also

Reference

LocateCredentialsEventArgs Members
GrapeCity.ActiveReports Namespace


LocateCredentialsEventArgs Class Members

LocateCredentialsEventArgs Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : LocateCredentialsEventArgs Class

The following tables list the members exposed by LocateCredentialsEventArgs.

Public Constructors
 | Name | Description
Public Constructor | LocateCredentialsEventArgs Constructor | Initializes new instance of LocateCredentialsEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | DataSourceName | Gets the name of the data source to locate credentials for.
Public Property | Password | Gets ot sets the password of the credentials to be located.
Public Property | PromptText | Gets the text of prompt of the locate credentials request.
Public Property | ReportPath | Gets the name of the report to locate credentials for.
Public Property | UserName | Gets ot sets the user name of the credentials to be located.
Top
See Also

Reference

LocateCredentialsEventArgs Class
GrapeCity.ActiveReports Namespace


LocateCredentialsEventArgs Constructor

LocateCredentialsEventArgs Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > LocateCredentialsEventArgs Class : LocateCredentialsEventArgs Constructor
The name of the data source to locate credentials for.
The name of the report to locate credentials for.
The text of prompt of the locate credentials request.
Initializes new instance of LocateCredentialsEventArgs class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal dataSourceName As System.String, _
   ByVal reportPath As System.String, _
   ByVal promptText As System.String _
)
public LocateCredentialsEventArgs(
   System.string dataSourceName,
   System.string reportPath,
   System.string promptText
)

Parameters

dataSourceName
The name of the data source to locate credentials for.
reportPath
The name of the report to locate credentials for.
promptText
The text of prompt of the locate credentials request.
See Also

Reference

LocateCredentialsEventArgs Class
LocateCredentialsEventArgs Members


LocateCredentialsEventArgs Class Properties

LocateCredentialsEventArgs Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : LocateCredentialsEventArgs Class

For a list of all members of this type, see LocateCredentialsEventArgs members.

Public Properties
 | Name | Description
Public Property | DataSourceName | Gets the name of the data source to locate credentials for.
Public Property | Password | Gets ot sets the password of the credentials to be located.
Public Property | PromptText | Gets the text of prompt of the locate credentials request.
Public Property | ReportPath | Gets the name of the report to locate credentials for.
Public Property | UserName | Gets ot sets the user name of the credentials to be located.
Top
See Also

Reference

LocateCredentialsEventArgs Class
GrapeCity.ActiveReports Namespace


DataSourceName Property (LocateCredentialsEventArgs)

DataSourceName Property (LocateCredentialsEventArgs)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > LocateCredentialsEventArgs Class : DataSourceName Property
Gets the name of the data source to locate credentials for.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DataSourceName As System.String
public System.string DataSourceName {get;}
See Also

Reference

LocateCredentialsEventArgs Class
LocateCredentialsEventArgs Members


Password Property (LocateCredentialsEventArgs)

Password Property (LocateCredentialsEventArgs)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > LocateCredentialsEventArgs Class : Password Property
Gets ot sets the password of the credentials to be located.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Password As System.String
public System.string Password {get; set;}
See Also

Reference

LocateCredentialsEventArgs Class
LocateCredentialsEventArgs Members


PromptText Property

PromptText Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > LocateCredentialsEventArgs Class : PromptText Property
Gets the text of prompt of the locate credentials request.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PromptText As System.String
public System.string PromptText {get;}
See Also

Reference

LocateCredentialsEventArgs Class
LocateCredentialsEventArgs Members


ReportPath Property

ReportPath Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > LocateCredentialsEventArgs Class : ReportPath Property
Gets the name of the report to locate credentials for.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ReportPath As System.String
public System.string ReportPath {get;}
See Also

Reference

LocateCredentialsEventArgs Class
LocateCredentialsEventArgs Members


UserName Property (LocateCredentialsEventArgs)

UserName Property (LocateCredentialsEventArgs)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > LocateCredentialsEventArgs Class : UserName Property
Gets ot sets the user name of the credentials to be located.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UserName As System.String
public System.string UserName {get; set;}
See Also

Reference

LocateCredentialsEventArgs Class
LocateCredentialsEventArgs Members


LocateDataSourceEventArgs Class

LocateDataSourceEventArgs Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : LocateDataSourceEventArgs Class
Provides data for the LocateDataSource event.
Object Model
LocateDataSourceEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class LocateDataSourceEventArgs
   Inherits System.EventArgs
public sealed class LocateDataSourceEventArgs : System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.LocateDataSourceEventArgs

See Also

Reference

LocateDataSourceEventArgs Members
GrapeCity.ActiveReports Namespace


LocateDataSourceEventArgs Class Members

LocateDataSourceEventArgs Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : LocateDataSourceEventArgs Class

The following tables list the members exposed by LocateDataSourceEventArgs.

Public Constructors
 | Name | Description
Public Constructor | LocateDataSourceEventArgs Constructor | Initializes a new instance of LocateCredentials class.
Top
Public Properties
 | Name | Description
Public Property | Data | The data returned by the event handler.
Public Property | DataSetName | Gets the name of data set to be located.
Public Property | DataSourceName | Gets the name of data source that contains the data set to be located.
Public Property | Report | Gets the Report that is trying to locate the data set.
Top
See Also

Reference

LocateDataSourceEventArgs Class
GrapeCity.ActiveReports Namespace


LocateDataSourceEventArgs Constructor

LocateDataSourceEventArgs Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > LocateDataSourceEventArgs Class : LocateDataSourceEventArgs Constructor
The name of data source that contains the data set to be located.
The name of data set to be located.
The Report that is trying to locate the data set.
Initializes a new instance of LocateCredentials class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal dataSourceName As System.String, _
   ByVal dataSetName As System.String, _
   ByVal report As PageDocument _
)
public LocateDataSourceEventArgs(
   System.string dataSourceName,
   System.string dataSetName,
   PageDocument report
)

Parameters

dataSourceName
The name of data source that contains the data set to be located.
dataSetName
The name of data set to be located.
report
The Report that is trying to locate the data set.
See Also

Reference

LocateDataSourceEventArgs Class
LocateDataSourceEventArgs Members


LocateDataSourceEventArgs Class Properties

LocateDataSourceEventArgs Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : LocateDataSourceEventArgs Class

For a list of all members of this type, see LocateDataSourceEventArgs members.

Public Properties
 | Name | Description
Public Property | Data | The data returned by the event handler.
Public Property | DataSetName | Gets the name of data set to be located.
Public Property | DataSourceName | Gets the name of data source that contains the data set to be located.
Public Property | Report | Gets the Report that is trying to locate the data set.
Top
See Also

Reference

LocateDataSourceEventArgs Class
GrapeCity.ActiveReports Namespace


Data Property (LocateDataSourceEventArgs)

Data Property (LocateDataSourceEventArgs)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > LocateDataSourceEventArgs Class : Data Property
The data returned by the event handler.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Data As System.Object
public System.object Data {get; set;}
See Also

Reference

LocateDataSourceEventArgs Class
LocateDataSourceEventArgs Members


DataSetName Property (LocateDataSourceEventArgs)

DataSetName Property (LocateDataSourceEventArgs)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > LocateDataSourceEventArgs Class : DataSetName Property
Gets the name of data set to be located.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DataSetName As System.String
public System.string DataSetName {get;}
See Also

Reference

LocateDataSourceEventArgs Class
LocateDataSourceEventArgs Members


DataSourceName Property (LocateDataSourceEventArgs)

DataSourceName Property (LocateDataSourceEventArgs)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > LocateDataSourceEventArgs Class : DataSourceName Property
Gets the name of data source that contains the data set to be located.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DataSourceName As System.String
public System.string DataSourceName {get;}
See Also

Reference

LocateDataSourceEventArgs Class
LocateDataSourceEventArgs Members


Report Property (LocateDataSourceEventArgs)

Report Property (LocateDataSourceEventArgs)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > LocateDataSourceEventArgs Class : Report Property
Gets the Report that is trying to locate the data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Report As PageDocument
public PageDocument Report {get;}
See Also

Reference

LocateDataSourceEventArgs Class
LocateDataSourceEventArgs Members


PageReport Class

PageReport Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : PageReport Class
Loads, modifies, or saves a report definition.
Object Model
PageReport Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class PageReport
   Inherits System.ComponentModel.Component
public sealed class PageReport : System.ComponentModel.Component
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReport

See Also

Reference

PageReport Members
GrapeCity.ActiveReports Namespace


PageReport Class Members

PageReport Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : PageReport Class

The following tables list the members exposed by PageReport.

Public Constructors
 | Name | Description
Public Constructor | PageReport Constructor | Overloaded. Initializes a new instance of PageReport class.
Top
Public Properties
 | Name | Description
Public Property | ConfigurationProvider | Gets or sets the IConfigurationProvider associated with this ReportDefinition.
Public Property | Container | Gets the IContainer that contains the Component. (Inherited from System.ComponentModel.Component)
Public Property | Document | Gets the document.
Public Property | Report | Returns the current report object.
Public Property | ResourceLocator | Gets the object responsible for resolving report resources.
Public Property | Site | Gets or sets the ISite of the Component. (Inherited from System.ComponentModel.Component)
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateFromMaster | Overloaded. Creates blank report with all of the content placeholders from specified master report.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the resources used by the Component. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Initialize | Allows post-initialization of the PageReport instance.
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Load | Overloaded. Loads the specified report definition file.
Public Method | Run | Runs the specified report definition file.
Public Method | Save | Overloaded. Saves the report definition to the specified file.
Public Method | ToRdlString | Returns the RDL of the report definition as a System.String.
Public Method | ToString | Returns a String containing the name of the Component, if any. (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

PageReport Class
GrapeCity.ActiveReports Namespace


PageReport Constructor

PageReport Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : PageReport Constructor
Initializes a new instance of PageReport class.
Overload List
Overload | Description
PageReport Constructor() | Initializes a new instance of PageReport class.
PageReport Constructor(FileInfo) | Initializes a new instance of PageReport class using the specified report definition file.
PageReport Constructor(TextReader) | Initializes a new instance of PageReport class using the specified report definition.
See Also

Reference

PageReport Class
PageReport Members


PageReport Constructor()

PageReport Constructor()

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > PageReport Constructor : PageReport Constructor()
Initializes a new instance of PageReport class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public PageReport()
See Also

Reference

PageReport Class
PageReport Members
Overload List


PageReport Constructor(FileInfo)

PageReport Constructor(FileInfo)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > PageReport Constructor : PageReport Constructor(FileInfo)
The report definition (*.rdlx) file to load.
Initializes a new instance of PageReport class using the specified report definition file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal reportDefinitionFile As System.IO.FileInfo _
)
public PageReport(
   System.IO.FileInfo reportDefinitionFile
)

Parameters

reportDefinitionFile
The report definition (*.rdlx) file to load.
See Also

Reference

PageReport Class
PageReport Members
Overload List


PageReport Constructor(TextReader)

PageReport Constructor(TextReader)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > PageReport Constructor : PageReport Constructor(TextReader)
The report definition (*.rdlx) file to load.
Initializes a new instance of PageReport class using the specified report definition.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal reportDefinitionReader As System.IO.TextReader _
)
public PageReport(
   System.IO.TextReader reportDefinitionReader
)

Parameters

reportDefinitionReader
The report definition (*.rdlx) file to load.
See Also

Reference

PageReport Class
PageReport Members
Overload List


PageReport Class Methods

PageReport Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : PageReport Class

For a list of all members of this type, see PageReport members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateFromMaster | Overloaded. Creates blank report with all of the content placeholders from specified master report.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the resources used by the Component. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Initialize | Allows post-initialization of the PageReport instance.
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Load | Overloaded. Loads the specified report definition file.
Public Method | Run | Runs the specified report definition file.
Public Method | Save | Overloaded. Saves the report definition to the specified file.
Public Method | ToRdlString | Returns the RDL of the report definition as a System.String.
Public Method | ToString | Returns a String containing the name of the Component, if any. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

PageReport Class
GrapeCity.ActiveReports Namespace


CreateFromMaster Method

CreateFromMaster Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : CreateFromMaster Method
Creates blank report with all of the content placeholders from specified master report.
Overload List
Overload | Description
CreateFromMaster(Uri) | Creates blank report with all of the content placeholders from specified master report.
CreateFromMaster(String,ResourceLocator) | Creates blank report with all of the content placeholders from specified master report.
See Also

Reference

PageReport Class
PageReport Members


CreateFromMaster(Uri) Method

CreateFromMaster(Uri) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > CreateFromMaster Method : CreateFromMaster(Uri) Method
The Uri to the master report
Creates blank report with all of the content placeholders from specified master report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CreateFromMaster( _
   ByVal masterUri As System.Uri _
) As PageReport
public static PageReport CreateFromMaster(
   System.Uri masterUri
)

Parameters

masterUri
The Uri to the master report
See Also

Reference

PageReport Class
PageReport Members
Overload List


CreateFromMaster(String,ResourceLocator) Method

CreateFromMaster(String,ResourceLocator) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > CreateFromMaster Method : CreateFromMaster(String,ResourceLocator) Method
The master report name
The resource locator
Creates blank report with all of the content placeholders from specified master report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CreateFromMaster( _
   ByVal masterName As System.String, _
   ByVal resourceLocator As ResourceLocator _
) As PageReport
public static PageReport CreateFromMaster(
   System.string masterName,
   ResourceLocator resourceLocator
)

Parameters

masterName
The master report name
resourceLocator
The resource locator
See Also

Reference

PageReport Class
PageReport Members
Overload List


Initialize Method (PageReport)

Initialize Method (PageReport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Initialize Method
Allows post-initialization of the PageReport instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Initialize()
public void Initialize()
See Also

Reference

PageReport Class
PageReport Members


Load Method (PageReport)

Load Method (PageReport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Load Method
Loads the specified report definition file.
Overload List
Overload | Description
Load(FileInfo) | Loads the specified report definition file.
Load(TextReader) | Loads the specified report definition file.
See Also

Reference

PageReport Class
PageReport Members


Load(FileInfo) Method

Load(FileInfo) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > Load Method : Load(FileInfo) Method
The report definition (*.rdlx) file to load.
Loads the specified report definition file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Load( _
   ByVal reportDefinitionFile As System.IO.FileInfo _
)
public void Load(
   System.IO.FileInfo reportDefinitionFile
)

Parameters

reportDefinitionFile
The report definition (*.rdlx) file to load.
See Also

Reference

PageReport Class
PageReport Members
Overload List


Load(TextReader) Method

Load(TextReader) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > Load Method : Load(TextReader) Method
The report definition (*.rdlx) file to load.
Loads the specified report definition file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Load( _
   ByVal reportDefinitionReader As System.IO.TextReader _
)
public void Load(
   System.IO.TextReader reportDefinitionReader
)

Parameters

reportDefinitionReader
The report definition (*.rdlx) file to load.
See Also

Reference

PageReport Class
PageReport Members
Overload List


Run Method (PageReport)

Run Method (PageReport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Run Method
Runs the specified report definition file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Run()
public void Run()
See Also

Reference

PageReport Class
PageReport Members


Save Method (PageReport)

Save Method (PageReport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Save Method
Saves the report definition to the specified file.
Overload List
Overload | Description
Save(FileInfo) | Saves the report definition to the specified file.
Save(XmlWriter) | Saves the report definition to the XmlWriter.
See Also

Reference

PageReport Class
PageReport Members


Save(FileInfo) Method

Save(FileInfo) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > Save Method : Save(FileInfo) Method
The file to which to save the report.
Saves the report definition to the specified file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Save( _
   ByVal file As System.IO.FileInfo _
)
public void Save(
   System.IO.FileInfo file
)

Parameters

file
The file to which to save the report.
See Also

Reference

PageReport Class
PageReport Members
Overload List


Save(XmlWriter) Method

Save(XmlWriter) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class > Save Method : Save(XmlWriter) Method
The System.Xml.XmlWriter to which to save the report.
Saves the report definition to the XmlWriter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Save( _
   ByVal xmlWriter As System.Xml.XmlWriter _
)
public void Save(
   System.Xml.XmlWriter xmlWriter
)

Parameters

xmlWriter
The System.Xml.XmlWriter to which to save the report.
See Also

Reference

PageReport Class
PageReport Members
Overload List


ToRdlString Method

ToRdlString Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : ToRdlString Method
Returns the RDL of the report definition as a System.String.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToRdlString() As System.String
public System.string ToRdlString()

Return Value

A string containing RDL.
See Also

Reference

PageReport Class
PageReport Members


PageReport Class Properties

PageReport Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : PageReport Class

For a list of all members of this type, see PageReport members.

Public Properties
 | Name | Description
Public Property | ConfigurationProvider | Gets or sets the IConfigurationProvider associated with this ReportDefinition.
Public Property | Container | Gets the IContainer that contains the Component. (Inherited from System.ComponentModel.Component)
Public Property | Document | Gets the document.
Public Property | Report | Returns the current report object.
Public Property | ResourceLocator | Gets the object responsible for resolving report resources.
Public Property | Site | Gets or sets the ISite of the Component. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

PageReport Class
GrapeCity.ActiveReports Namespace


ConfigurationProvider Property

ConfigurationProvider Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : ConfigurationProvider Property
Gets or sets the IConfigurationProvider associated with this ReportDefinition.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ConfigurationProvider As IConfigurationProvider
public IConfigurationProvider ConfigurationProvider {get; set;}
See Also

Reference

PageReport Class
PageReport Members


Document Property (PageReport)

Document Property (PageReport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Document Property
Gets the document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Document As PageDocument
public PageDocument Document {get;}

Property Value

The document.
See Also

Reference

PageReport Class
PageReport Members


Report Property (PageReport)

Report Property (PageReport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Report Property
Returns the current report object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Report As Report
public Report Report {get;}
See Also

Reference

PageReport Class
PageReport Members


ResourceLocator Property (PageReport)

ResourceLocator Property (PageReport)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : ResourceLocator Property
Gets the object responsible for resolving report resources.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ResourceLocator As ResourceLocator
public ResourceLocator ResourceLocator {get; set;}
Remarks
Resolve a ReportDefinition for a subreport referenced in an RDLX file by using the resolver returned by this property. In the case of a subreport, the RDLX Subreport element's ReportName value is used as the resource identifier. For example, the code below demonstrates how to use the ResourceResolver property to specify a ReportDefinition for a subreport with the value "vendorssub.rdlx" for its ReportName element.
Example
  • VB.NET
Private Sub ShowReport()
    Dim reportData As Stream = [GetType]().Assembly.GetManifestResourceStream("GrapeCity.ActiveReports.Samples.CustomResourceLocator.DemoReport.rdlx")
    reportData.Position = 0
    Dim reader As New StreamReader(reportData)
    Dim def As New PageReport(reader)
    def.ResourceLocator = New MyPicturesLocator()
    Dim runtime As New PageDocument(def)
    runtime.Parameters("PictureName").CurrentValue = listView.SelectedItems(0).Text
    runtime.Parameters("MimeType").CurrentValue = String.Format("image/{0}", listView.SelectedItems(0).Tag)
End Sub
  • C#
private void ShowReport()
{
    Stream reportData = GetType().Assembly.GetManifestResourceStream(
            "GrapeCity.ActiveReports.Samples.CustomResourceLocator.DemoReport.rdlx");
    reportData.Position = 0;
    StreamReader reader = new StreamReader(reportData);
    PageReport def = new PageReport(reader);
    def.ResourceLocator = new MyPicturesLocator();
    PageDocument runtime = new PageDocument(def);
    runtime.Parameters["PictureName"].CurrentValue = listView.SelectedItems[0].Text;
    runtime.Parameters["MimeType"].CurrentValue = string.Format("image/{0}", listView.SelectedItems[0].Tag);
}
See Also

Reference

PageReport Class
PageReport Members


PageSettings Class

PageSettings Class
Members Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : PageSettings Class
Specifies the page settings used to print the report document pages.
Object Model
PageSettings Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class PageSettings
public class PageSettings
Example
  • C#
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.Collate = GrapeCity.ActiveReports.PageSettings.PrinterCollate.Collate;
    this.PageSettings.DefaultPaperSize = true;
    this.PageSettings.DefaultPaperSource = true;
    this.PageSettings.Duplex = System.Drawing.Printing.Duplex.Default;
    this.PageSettings.Gutter = 1.0f;
    this.PageSettings.Margins.Bottom = 1.0f;
    this.PageSettings.Margins.Left = 1.0f;
    this.PageSettings.Margins.Right = 1.0f;
    this.PageSettings.Margins.Top = 1.0f;
    this.PageSettings.MirrorMargins = false;
    this.PageSettings.Orientation = PageOrientation.Default;
    this.PageSettings.PaperHeight = 11.0f;
    this.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom;
    this.PageSettings.PaperSource = System.Drawing.Printing.PaperSourceKind.Manual;
    this.PageSettings.PaperWidth = 8.5f;
}
  • Visual Basic
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.Collate = PageSettings.PrinterCollate.Collate
   Me.PageSettings.DefaultPaperSize = True
   Me.PageSettings.DefaultPaperSource = True
   Me.PageSettings.Duplex = Drawing.Printing.Duplex.Default
   Me.PageSettings.Gutter = 1.0F
   Me.PageSettings.Margins.Bottom = 1.0F
   Me.PageSettings.Margins.Left = 1.0F
   Me.PageSettings.Margins.Right = 1.0F
   Me.PageSettings.Margins.Top = 1.0F
   Me.PageSettings.MirrorMargins = False
   Me.PageSettings.Orientation = PageOrientation.Default
   Me.PageSettings.PaperHeight = 11.0F
   Me.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom
   Me.PageSettings.PaperSource = System.Drawing.Printing.PaperSourceKind.Manual
   Me.PageSettings.PaperWidth = 8.5F
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageSettings

See Also

Reference

PageSettings Members
GrapeCity.ActiveReports Namespace


PageSettings Class Members

PageSettings Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : PageSettings Class

The following tables list the members exposed by PageSettings.

Public Constructors
 | Name | Description
Public Constructor | PageSettings Constructor | Initializes a new instance of the PageSettings class.
Top
Public Properties
 | Name | Description
Public Property | Collate | Gets or sets a value indicating whether the report document is collated.
Public Property | DefaultPaperSize | Gets or sets a value that specifies whether the report document should print to the printer's default paper size.
Public Property | DefaultPaperSource | Gets or sets a value that specifies whether the report document should print to the printer's default paper source.
Public Property | Duplex | Gets or sets the report document setting for double-sided printing.
Public Property | Gutter | Gets or sets the amount of space between columns in inches.
Public Property | Margins | Gets or sets the default page margins of the report document.
Public Property | MirrorMargins | Gets or sets a value that specifies whether the margins will be mirrored for every other page of the document.
Public Property | Orientation | Gets or sets a value that specifies whether the document pages should be printed in portrait or landscape.
Public Property | PaperHeight | Gets or sets a value that specifies the height of a custom paper size.
Public Property | PaperKind | Gets or sets the kind of paper to be used to print the report.
Public Property | PaperName | Gets or sets the name of the type of paper.
Public Property | PaperSource | Gets or sets the paper source used to print the report document pages.
Public Property | PaperSourceName | Gets the name of the paper source.
Public Property | PaperWidth | Gets or sets a value that specifies the width, in inches, of a custom paper size.
Top
Public Methods
 | Name | Description
Public Method | Dispose | Releases the PageSettings object from memory.
Top
Public Events
 | Name | Description
Public Event | Changed | Occurs when any of the PageSettings properties are changed.
Top
See Also

Reference

PageSettings Class
GrapeCity.ActiveReports Namespace


PageSettings Constructor

PageSettings Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : PageSettings Constructor
Initializes a new instance of the PageSettings class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public PageSettings()
See Also

Reference

PageSettings Class
PageSettings Members


PageSettings Class Methods

PageSettings Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : PageSettings Class

For a list of all members of this type, see PageSettings members.

Public Methods
 | Name | Description
Public Method | Dispose | Releases the PageSettings object from memory.
Top
See Also

Reference

PageSettings Class
GrapeCity.ActiveReports Namespace


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : Dispose() Method
Releases the PageSettings object from memory.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

PageSettings Class
PageSettings Members


PageSettings Class Properties

PageSettings Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : PageSettings Class

For a list of all members of this type, see PageSettings members.

Public Properties
 | Name | Description
Public Property | Collate | Gets or sets a value indicating whether the report document is collated.
Public Property | DefaultPaperSize | Gets or sets a value that specifies whether the report document should print to the printer's default paper size.
Public Property | DefaultPaperSource | Gets or sets a value that specifies whether the report document should print to the printer's default paper source.
Public Property | Duplex | Gets or sets the report document setting for double-sided printing.
Public Property | Gutter | Gets or sets the amount of space between columns in inches.
Public Property | Margins | Gets or sets the default page margins of the report document.
Public Property | MirrorMargins | Gets or sets a value that specifies whether the margins will be mirrored for every other page of the document.
Public Property | Orientation | Gets or sets a value that specifies whether the document pages should be printed in portrait or landscape.
Public Property | PaperHeight | Gets or sets a value that specifies the height of a custom paper size.
Public Property | PaperKind | Gets or sets the kind of paper to be used to print the report.
Public Property | PaperName | Gets or sets the name of the type of paper.
Public Property | PaperSource | Gets or sets the paper source used to print the report document pages.
Public Property | PaperSourceName | Gets the name of the paper source.
Public Property | PaperWidth | Gets or sets a value that specifies the width, in inches, of a custom paper size.
Top
See Also

Reference

PageSettings Class
GrapeCity.ActiveReports Namespace


Collate Property (PageSettings)

Collate Property (PageSettings)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : Collate Property
Gets or sets a value indicating whether the report document is collated.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Collate As PageSettings.PrinterCollate
public PageSettings.PrinterCollate Collate {get; set;}

Property Value

A PrinterCollate enumeration value. Default is PrinterCollate.Default.
Remarks

Collating is performed only when the number of copies is greater than 1.

Setting the property to PrinterCollate.Collate will print a complete copy of the document before the first page of the next copy is printed. PrinterCollate.DontCollate will print each page by the number of copies specified before printing the next page. PrinterCollate.Default will use the printer's collate setting.

Example
  • C#
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.Collate = GrapeCity.ActiveReports.PageSettings.PrinterCollate.Collate;
}
  • Visual Basic
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.Collate = PageSettings.PrinterCollate.Collate
End Sub
See Also

Reference

PageSettings Class
PageSettings Members


DefaultPaperSize Property

DefaultPaperSize Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : DefaultPaperSize Property
Gets or sets a value that specifies whether the report document should print to the printer's default paper size.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultPaperSize As System.Boolean
public System.bool DefaultPaperSize {get; set;}

Property Value

Boolean. True if the document should use the printer's default paper size; otherwise, False. The default value is False.
Example
  • C#
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.DefaultPaperSize = true;
}
  • Visual Basic
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.DefaultPaperSize = True
End Sub
See Also

Reference

PageSettings Class
PageSettings Members
PaperKind Property


DefaultPaperSource Property

DefaultPaperSource Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : DefaultPaperSource Property
Gets or sets a value that specifies whether the report document should print to the printer's default paper source.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultPaperSource As System.Boolean
public System.bool DefaultPaperSource {get; set;}

Property Value

Boolean. True if the document should use the printer's default paper source; otherwise, False. The default value is False.
Example
  • C#
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.DefaultPaperSource = true;
}
  • Visual Basic
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.DefaultPaperSource = True
End Sub
See Also

Reference

PageSettings Class
PageSettings Members
PaperSource Property


Duplex Property (PageSettings)

Duplex Property (PageSettings)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : Duplex Property
Gets or sets the report document setting for double-sided printing.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Duplex As System.Drawing.Printing.Duplex
public System.Drawing.Printing.Duplex Duplex {get; set;}

Property Value

A System.Drawing.Duplex enumeration value. The default value is determined by the value of System.Drawing.Printing.Duplex.Default.
Example
  • C#
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.Duplex = System.Drawing.Printing.Duplex.Default;
}
  • Visual Basic
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.Duplex = Drawing.Printing.Duplex.Default
End Sub
See Also

Reference

PageSettings Class
PageSettings Members


Gutter Property

Gutter Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : Gutter Property
Gets or sets the amount of space between columns in inches.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Gutter As System.Single
public System.float Gutter {get; set;}

Property Value

A float or Single value in inches used to determine the gutter width.
Example
  • C#
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.Gutter = 1.0f;
}
  • Visual Basic
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.Gutter = 1.0F
End Sub
See Also

Reference

PageSettings Class
PageSettings Members


Margins Property (PageSettings)

Margins Property (PageSettings)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : Margins Property
Gets or sets the default page margins of the report document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Margins As Margins
public Margins Margins {get; set;}

Property Value

A Margins object that specifies the top, bottom, left and right margin settings in inches.
Example
  • C#
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.Margins.Bottom = 1.0f;
    this.PageSettings.Margins.Left = 1.0f;
    this.PageSettings.Margins.Right = 1.0f;
    this.PageSettings.Margins.Top = 1.0f;
}
  • Visual Basic
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.Margins.Bottom = 1.0F
   Me.PageSettings.Margins.Left = 1.0F
   Me.PageSettings.Margins.Right = 1.0F
   Me.PageSettings.Margins.Top = 1.0F
End Sub
See Also

Reference

PageSettings Class
PageSettings Members
Margins Class


MirrorMargins Property

MirrorMargins Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : MirrorMargins Property
Gets or sets a value that specifies whether the margins will be mirrored for every other page of the document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MirrorMargins As System.Boolean
public System.bool MirrorMargins {get; set;}

Property Value

Boolean. True if margins should be mirrored; otherwise, False. The default value is False.

Remarks

Use this property when printing in duplex and the left and right margins are not equal. This would alternate the margins between odd and even pages.

Example
  • Visual Basic
Private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.Duplex = System.Drawing.Printing.Duplex.Vertical;
    this.PageSettings.Margins.Bottom = 1.0f;
    this.PageSettings.Margins.Left = 1.5f;
    this.PageSettings.Margins.Right = 1.0f;
    this.PageSettings.Margins.Top = 1.0f;
    this.PageSettings.MirrorMargins = True;
}
  • Visual Basic
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.Duplex = System.Drawing.Printing.Duplex.Vertical
   Me.PageSettings.Margins.Bottom = 1.0F
   Me.PageSettings.Margins.Left = 1.5F
   Me.PageSettings.Margins.Right = 1.0F
   Me.PageSettings.Margins.Top = 1.0F
   Me.PageSettings.MirrorMargins = True
End Sub
See Also

Reference

PageSettings Class
PageSettings Members


Orientation Property (PageSettings)

Orientation Property (PageSettings)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : Orientation Property
Gets or sets a value that specifies whether the document pages should be printed in portrait or landscape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Orientation As PageOrientation
public PageOrientation Orientation {get; set;}

Property Value

A GrapeCity.ActiveReports.Document.Section.PageOrientation enumeration value that specifies the orientation of the document pages.
Example
  • C#
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.Orientation = PageOrientation.Default;
}
  • Visual Basic
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.Orientation = PageOrientation.Default
End Sub
See Also

Reference

PageSettings Class
PageSettings Members
PageOrientation Enumeration


PaperHeight Property (PageSettings)

PaperHeight Property (PageSettings)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : PaperHeight Property
Gets or sets a value that specifies the height of a custom paper size.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaperHeight As System.Single
public System.float PaperHeight {get; set;}

Property Value

A float value that specifies the custom paper height in inches.
Remarks
Set the PaperKind property to PaperKind.Custom to use this property. Custom paper sizes must be supported by the printer for this property to work.
Example
  • C#
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.PaperHeight = 11.0f;
    this.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom;
    this.PageSettings.PaperWidth = 8.5f;
}
  • Visual Basic
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.PaperHeight = 11.0F
   Me.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom
   Me.PageSettings.PaperWidth = 8.5F
End Sub
See Also

Reference

PageSettings Class
PageSettings Members
PaperKind Property
PaperWidth Property


PaperKind Property (PageSettings)

PaperKind Property (PageSettings)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : PaperKind Property
Gets or sets the kind of paper to be used to print the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaperKind As System.Drawing.Printing.PaperKind
public System.Drawing.Printing.PaperKind PaperKind {get; set;}

Property Value

A System.Drawing.Printing.PaperKind enumeration value that determines the paper size to use.
Remarks
To use custom paper sizes, you must set the PaperKind property to Custom and the PaperName property to a unique string.
Example
  • C#
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.PaperHeight = 11.0f;
    this.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom;
    this.PageSettings.PaperName = "My Paper";
    this.PageSettings.PaperWidth = 8.5f;
}
  • Visual Basic
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.PaperHeight = 11.0F
   Me.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom
   Me.PageSettings.PaperName = "My Paper"
   Me.PageSettings.PaperWidth = 8.5F
End Sub
See Also

Reference

PageSettings Class
PageSettings Members


PaperName Property

PaperName Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : PaperName Property
Gets or sets the name of the type of paper.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaperName As System.String
public System.string PaperName {get; set;}

Property Value

String. The name of the type of custom paper.
Remarks

You can set the paper name only if the PaperKind property is set to Custom. To use custom paper sizes, you must set the PaperKind property to Custom and set the PaperName property to a unique string.

Example
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom;
    this.PageSettings.PaperHeight = 3;
    this.PageSettings.PaperName = "Logo Labels";
    this.PageSettings.PaperWidth = 5;

}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.PageSettings.PaperKind = Printing.PaperKind.Custom
    Me.PageSettings.PaperHeight = 3
    Me.PageSettings.PaperName = "Logo Labels"
    Me.PageSettings.PaperWidth = 5
End Sub
See Also

Reference

PageSettings Class
PageSettings Members
PaperKind Property


PaperSource Property (PageSettings)

PaperSource Property (PageSettings)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : PaperSource Property
Gets or sets the paper source used to print the report document pages.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaperSource As System.Drawing.Printing.PaperSourceKind
public System.Drawing.Printing.PaperSourceKind PaperSource {get; set;}

Property Value

A System.Drawing.Printing.PaperSourceKind enumeration value that specifies the paper source.
Example
  • C#
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.PaperSource = System.Drawing.Printing.PaperSourceKind.Manual;
}
  • Visual Basic
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.PaperSource = System.Drawing.Printing.PaperSourceKind.Manual
End Sub
See Also

Reference

PageSettings Class
PageSettings Members


PaperSourceName Property

PaperSourceName Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : PaperSourceName Property
Gets the name of the paper source.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaperSourceName As System.String
public System.string PaperSourceName {get; set;}

Property Value

String. The name of the paper source.
Remarks
Call this property when the paper source needs to be displayed. The name of the paper source is generated based upon the PaperKind property.
See Also

Reference

PageSettings Class
PageSettings Members
PaperKind Property
PaperSource Property


PaperWidth Property (PageSettings)

PaperWidth Property (PageSettings)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : PaperWidth Property
Gets or sets a value that specifies the width, in inches, of a custom paper size.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaperWidth As System.Single
public System.float PaperWidth {get; set;}

Property Value

A float value that specifies the custom paper width in inches.
Remarks
Set the PaperKind property to PaperKind.Custom to use this property. Custom paper sizes must be supported by the printer for this property to work.
Example
  • C#
private void rptPageSettings_ReportStart(object sender, System.EventArgs eArgs)
{
    this.PageSettings.PaperHeight = 11.0f;
    this.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom;
    this.PageSettings.PaperWidth = 8.5f;
}
  • Visual Basic
Private Sub rptPageSettings_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.PageSettings.PaperHeight = 11.0F
   Me.PageSettings.PaperKind = System.Drawing.Printing.PaperKind.Custom
   Me.PageSettings.PaperWidth = 8.5F
End Sub
See Also

Reference

PageSettings Class
PageSettings Members
PaperKind Property
PaperHeight Property


PageSettings Class Events

PageSettings Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : PageSettings Class

For a list of all members of this type, see PageSettings members.

Public Events
 | Name | Description
Public Event | Changed | Occurs when any of the PageSettings properties are changed.
Top
See Also

Reference

PageSettings Class
GrapeCity.ActiveReports Namespace


Changed Event (PageSettings)

Changed Event (PageSettings)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : Changed Event
Occurs when any of the PageSettings properties are changed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Changed As System.EventHandler
public event System.EventHandler Changed
See Also

Reference

PageSettings Class
PageSettings Members


ReportDataException Class

ReportDataException Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : ReportDataException Class
This exception is thrown when an error occurs while connecting to the report's data source.
Object Model
ReportDataException Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ReportDataException
   Inherits ReportException
public class ReportDataException : ReportException
Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.ReportException
GrapeCity.ActiveReports.ReportDataException

See Also

Reference

ReportDataException Members
GrapeCity.ActiveReports Namespace


ReportDataException Class Members

ReportDataException Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : ReportDataException Class

The following tables list the members exposed by ReportDataException.

Public Constructors
 | Name | Description
Public Constructor | ReportDataException Constructor | Overloaded. Initializes a new instance of the ReportDataException class.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorCode | Error code for future detail processing. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | ErrorData | Error data, depends on error code. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the Info with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

ReportDataException Class
GrapeCity.ActiveReports Namespace


ReportDataException Constructor

ReportDataException Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : ReportDataException Constructor
Initializes a new instance of the ReportDataException class.
Overload List
Overload | Description
ReportDataException Constructor() | Initializes a new instance of the ReportDataException class.
ReportDataException Constructor(String) | Initializes a new instance of the ReportDataException with the specified message.
ReportDataException Constructor(String,Exception) | Initializes a new instance of the ReportDataException class with a specified error message and a reference to the inner exception that is the cause of this exception.
See Also

Reference

ReportDataException Class
ReportDataException Members


ReportDataException Constructor()

ReportDataException Constructor()

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class > ReportDataException Constructor : ReportDataException Constructor()
Initializes a new instance of the ReportDataException class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ReportDataException()
See Also

Reference

ReportDataException Class
ReportDataException Members
Overload List


ReportDataException Constructor(String)

ReportDataException Constructor(String)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class > ReportDataException Constructor : ReportDataException Constructor(String)

The message to display when the exception is thrown.

Initializes a new instance of the ReportDataException with the specified message.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String _
)
public ReportDataException(
   System.string message
)

Parameters

message

The message to display when the exception is thrown.

See Also

Reference

ReportDataException Class
ReportDataException Members
Overload List


ReportDataException Constructor(String,Exception)

ReportDataException Constructor(String,Exception)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class > ReportDataException Constructor : ReportDataException Constructor(String,Exception)

The message to display when the exception is thrown.

A reference to an inner exception. If the innerException parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.
Initializes a new instance of the ReportDataException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String, _
   ByVal innerException As System.Exception _
)
public ReportDataException(
   System.string message,
   System.Exception innerException
)

Parameters

message

The message to display when the exception is thrown.

innerException
A reference to an inner exception. If the innerException parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.
See Also

Reference

ReportDataException Class
ReportDataException Members
Overload List


ReportException Class

ReportException Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : ReportException Class

This exception or one of its descendent classes is thrown when an error occurs while running the report.

Object Model
ReportException Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ReportException
   Inherits System.ApplicationException
public class ReportException : System.ApplicationException
Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.ReportException
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel.ReportParameterException
GrapeCity.ActiveReports.InvalidReportDefinitionException
GrapeCity.ActiveReports.PageReportModel.MasterReportNotFoundException
GrapeCity.ActiveReports.ReportDataException
GrapeCity.ActiveReports.ReportScriptException

See Also

Reference

ReportException Members
GrapeCity.ActiveReports Namespace


ReportException Class Members

ReportException Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : ReportException Class

The following tables list the members exposed by ReportException.

Public Constructors
 | Name | Description
Public Constructor | ReportException Constructor | Overloaded. Initializes a new instance of the ReportException class.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorCode | Error code for future detail processing.
Public Property | ErrorData | Error data, depends on error code.
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the Info with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

ReportException Class
GrapeCity.ActiveReports Namespace


ReportException Constructor

ReportException Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : ReportException Constructor
Initializes a new instance of the ReportException class.
Overload List
Overload | Description
ReportException Constructor() | Initializes a new instance of the ReportException class.
ReportException Constructor(String) | Initializes a new instance of the ReportException with the specified message.
ReportException Constructor(String,Exception) | Initializes a new instance of the ReportException class with a specified error message and a reference to the inner exception that is the cause of this exception.
See Also

Reference

ReportException Class
ReportException Members


ReportException Constructor()

ReportException Constructor()

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportException Class > ReportException Constructor : ReportException Constructor()
Initializes a new instance of the ReportException class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ReportException()
See Also

Reference

ReportException Class
ReportException Members
Overload List


ReportException Constructor(String)

ReportException Constructor(String)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportException Class > ReportException Constructor : ReportException Constructor(String)

The message to display when the exception is thrown.

Initializes a new instance of the ReportException with the specified message.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String _
)
public ReportException(
   System.string message
)

Parameters

message

The message to display when the exception is thrown.

See Also

Reference

ReportException Class
ReportException Members
Overload List


ReportException Constructor(String,Exception)

ReportException Constructor(String,Exception)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportException Class > ReportException Constructor : ReportException Constructor(String,Exception)

The message to display when the exception is thrown.

A reference to an inner exception. If the innerException parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.
Initializes a new instance of the ReportException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String, _
   ByVal innerException As System.Exception _
)
public ReportException(
   System.string message,
   System.Exception innerException
)

Parameters

message

The message to display when the exception is thrown.

innerException
A reference to an inner exception. If the innerException parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.
See Also

Reference

ReportException Class
ReportException Members
Overload List


ReportException Class Properties

ReportException Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : ReportException Class

For a list of all members of this type, see ReportException members.

Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorCode | Error code for future detail processing.
Public Property | ErrorData | Error data, depends on error code.
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
See Also

Reference

ReportException Class
GrapeCity.ActiveReports Namespace


ErrorCode Property

ErrorCode Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : ErrorCode Property
Error code for future detail processing.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ErrorCode As ReportProcessingError
public ReportProcessingError ErrorCode {get; set;}
See Also

Reference

ReportException Class
ReportException Members


ErrorData Property

ErrorData Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : ErrorData Property
Error data, depends on error code.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ErrorData As System.String()
public System.string[] ErrorData {get; set;}
See Also

Reference

ReportException Class
ReportException Members


ReportScriptException Class

ReportScriptException Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : ReportScriptException Class
The ReportScriptException is thrown when an error occurs in the report scripting code or any of the report's calculated DataField expressions.
Object Model
ReportScriptException Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ReportScriptException
   Inherits ReportException
public class ReportScriptException : ReportException
Remarks
You should catch this exception and inspect the InnerException property to diagnose the location and type of the error that caused the exception.
Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.ReportException
GrapeCity.ActiveReports.ReportScriptException

See Also

Reference

ReportScriptException Members
GrapeCity.ActiveReports Namespace
GrapeCity.ActiveReports.v10~GrapeCity.ActiveReports.ActiveReport~Script


ReportScriptException Class Members

ReportScriptException Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : ReportScriptException Class

The following tables list the members exposed by ReportScriptException.

Public Constructors
 | Name | Description
Public Constructor | ReportScriptException Constructor | Overloaded. Initializes a new instance of the ReportScriptException class.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorCode | Error code for future detail processing. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | ErrorData | Error data, depends on error code. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the Info with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

ReportScriptException Class
GrapeCity.ActiveReports Namespace
GrapeCity.ActiveReports.v10~GrapeCity.ActiveReports.ActiveReport~Script


ReportScriptException Constructor

ReportScriptException Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : ReportScriptException Constructor
Initializes a new instance of the ReportScriptException class.
Overload List
Overload | Description
ReportScriptException Constructor() | Initializes a new instance of the ReportScriptException class.
ReportScriptException Constructor(String) | Initializes a new instance of the ReportScriptException with the specified message.
ReportScriptException Constructor(String,Exception) | Initializes a new instance of the ReportScriptException class with a specified error message and a reference to the inner exception that is the cause of this exception.
See Also

Reference

ReportScriptException Class
ReportScriptException Members


ReportScriptException Constructor()

ReportScriptException Constructor()

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class > ReportScriptException Constructor : ReportScriptException Constructor()
Initializes a new instance of the ReportScriptException class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ReportScriptException()
See Also

Reference

ReportScriptException Class
ReportScriptException Members
Overload List


ReportScriptException Constructor(String)

ReportScriptException Constructor(String)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class > ReportScriptException Constructor : ReportScriptException Constructor(String)

The message to display when the exception is thrown.

Initializes a new instance of the ReportScriptException with the specified message.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String _
)
public ReportScriptException(
   System.string message
)

Parameters

message

The message to display when the exception is thrown.

See Also

Reference

ReportScriptException Class
ReportScriptException Members
Overload List


ReportScriptException Constructor(String,Exception)

ReportScriptException Constructor(String,Exception)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class > ReportScriptException Constructor : ReportScriptException Constructor(String,Exception)

The message to display when the exception is thrown.

A reference to an inner exception. If the innerException parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.
Initializes a new instance of the ReportScriptException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String, _
   ByVal innerException As System.Exception _
)
public ReportScriptException(
   System.string message,
   System.Exception innerException
)

Parameters

message

The message to display when the exception is thrown.

innerException
A reference to an inner exception. If the innerException parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.
See Also

Reference

ReportScriptException Class
ReportScriptException Members
Overload List


SectionCollection Class

SectionCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : SectionCollection Class
Represents a collection of all sections (Section objects) in the report layout.
Object Model
SectionCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class SectionCollection
   Inherits System.Collections.CollectionBase
public class SectionCollection : System.Collections.CollectionBase
Remarks
The collection provides access to the removal or addition of sections, as well as access to the individual sections within the report. You can use the collection to create dynamic reports at run time.
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionCollection

See Also

Reference

SectionCollection Members
GrapeCity.ActiveReports Namespace
Section Class
Detail Class
GroupFooter Class
GroupHeader Class
PageFooter Class
PageHeader Class
ReportFooter Class
ReportHeader Class


SectionCollection Class Members

SectionCollection Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : SectionCollection Class

The following tables list the members exposed by SectionCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the SectionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the SectionCollection instance. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Returns a reference to a Section in the SectionCollection using its index or unique name.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds the specified SectionType to the SectionCollection.
Public Method | Clear | Remove all sections from the collection.
Public Method | Contains | Determines whether the specified section object exists in the collection.
Public Method | CopyTo | Copies the Sections collection from the specified report to a Sections collection at the specified index.
Public Method | Dispose | Releases the section collection from memory.
Public Method | IndexOf | Determines the specific index of the specified section in the collection.
Public Method | Insert | Overloaded. Inserts a section into the collection at the specified index.
Public Method | InsertGroupHF | Overloaded. Inserts a group header and a matching group footer into the SectionCollection with the default names GroupHeader1,GroupFooter1; where 1 is an order number.
Public Method | InsertPageHF | Inserts a page header and a page matching footer into the SectionCollection with the default names PageHeader1, PageFooter1; where 1 is an order number.
Public Method | InsertReportHF | Inserts a report header and a matching report footer into the SectionCollection.
Public Method | Remove | Overloaded. Removes the specified Section from the SectionCollection if it exists.
Public Method | RemoveAt | Inherited from System.Collections.CollectionBase. (Inherited from System.Collections.CollectionBase)
Top
Public Events
 | Name | Description
Public Event | Changed | Occurs when the members of the SectionCollection have changed.
Top
See Also

Reference

SectionCollection Class
GrapeCity.ActiveReports Namespace
Section Class
Detail Class
GroupFooter Class
GroupHeader Class
PageFooter Class
PageHeader Class
ReportFooter Class
ReportHeader Class


SectionCollection Class Methods

SectionCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : SectionCollection Class

For a list of all members of this type, see SectionCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds the specified SectionType to the SectionCollection.
Public Method | Clear | Remove all sections from the collection.
Public Method | Contains | Determines whether the specified section object exists in the collection.
Public Method | CopyTo | Copies the Sections collection from the specified report to a Sections collection at the specified index.
Public Method | Dispose | Releases the section collection from memory.
Public Method | IndexOf | Determines the specific index of the specified section in the collection.
Public Method | Insert | Overloaded. Inserts a section into the collection at the specified index.
Public Method | InsertGroupHF | Overloaded. Inserts a group header and a matching group footer into the SectionCollection with the default names GroupHeader1,GroupFooter1; where 1 is an order number.
Public Method | InsertPageHF | Inserts a page header and a page matching footer into the SectionCollection with the default names PageHeader1, PageFooter1; where 1 is an order number.
Public Method | InsertReportHF | Inserts a report header and a matching report footer into the SectionCollection.
Public Method | Remove | Overloaded. Removes the specified Section from the SectionCollection if it exists.
Public Method | RemoveAt | Inherited from System.Collections.CollectionBase. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

SectionCollection Class
GrapeCity.ActiveReports Namespace
Section Class
Detail Class
GroupFooter Class
GroupHeader Class
PageFooter Class
PageHeader Class
ReportFooter Class
ReportHeader Class


Add Method (SectionCollection)

Add Method (SectionCollection)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Add Method
Adds the specified SectionType to the SectionCollection.
Adds a section to the SectionCollection.
Overload List
Overload | Description
Add(SectionType,String) | Adds the specified SectionType to the SectionCollection.
Add(Section) | Adds the specified section to the SectionCollection.
Remarks
When modifying the layout of a report, the Insert methods are easier to use for header/footer section pairs.
Example
  • C#
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
    rpt.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail,"detail");
    rpt.Sections.InsertPageHF();
    rpt.Sections[0].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Sections[1].BackColor = System.Drawing.Color.Orchid;
    rpt.Sections[2].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Run();
    this.arv.Document = rpt.Document;
  • Visual Basic
Dim rpt As New GrapeCity.ActiveReports.SectionReport
    rpt.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail, "Detail1")
    rpt.Sections.InsertPageHF()
    rpt.Sections(0).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Sections(1).BackColor = System.Drawing.Color.Orchid
    rpt.Sections(2).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
See Also

Reference

SectionCollection Class
SectionCollection Members
SectionType Property


Add(SectionType,String) Method

Add(SectionType,String) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > Add Method : Add(SectionType,String) Method
SectionType of the new section.
Name of the new section, must be unique within the report.
Adds the specified SectionType to the SectionCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal type As SectionType, _
   ByVal name As System.String _
) As Section
public Section Add(
   SectionType type,
   System.string name
)

Parameters

type
SectionType of the new section.
name
Name of the new section, must be unique within the report.
See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


Add(Section) Method

Add(Section) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > Add Method : Add(Section) Method

Specifies the Section object to be added in the collection.

Adds the specified section to the SectionCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal section As Section _
) As System.Integer
public System.int Add(
   Section section
)

Parameters

section

Specifies the Section object to be added in the collection.

See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


Clear Method (SectionCollection)

Clear Method (SectionCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Clear Method
Remove all sections from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Sub Clear()
public new void Clear()
See Also

Reference

SectionCollection Class
SectionCollection Members


Contains Method (SectionCollection)

Contains Method (SectionCollection)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Contains Method

Specifies the Section object to be searched for in the collection.

Determines whether the specified section object exists in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal section As Section _
) As System.Boolean
public System.bool Contains(
   Section section
)

Parameters

section

Specifies the Section object to be searched for in the collection.

Return Value

Boolean. Returns True if the section exists in the collection; otherwise, False.
Example
  • C#
private void rpt_ReportEnd(object sender, System.EventArgs eArgs)
{
    System.Windows.Forms.MessageBox.Show(this.Sections.Contains(this.Sections["detail"]).ToString());
}
  • Visual Basic
Private Sub rpt_ReportEnd(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportEnd
    MsgBox(Me.Sections.Contains(Me.Sections("Detail1")).ToString)
End Sub
See Also

Reference

SectionCollection Class
SectionCollection Members


CopyTo Method (SectionCollection)

CopyTo Method (SectionCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : CopyTo Method
The array containing the copied Sections.

The insertion index in the collection.

Copies the Sections collection from the specified report to a Sections collection at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal sections() As Section, _
   ByVal index As System.Integer _
)
public void CopyTo(
   Section[] sections,
   System.int index
)

Parameters

sections
The array containing the copied Sections.
index

The insertion index in the collection.

See Also

Reference

SectionCollection Class
SectionCollection Members


Dispose Method (SectionCollection)

Dispose Method (SectionCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Dispose Method
Releases the section collection from memory.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

SectionCollection Class
SectionCollection Members


IndexOf(Section) Method

IndexOf(Section) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : IndexOf(Section) Method

Specifies the Section object.

Determines the specific index of the specified section in the collection.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal section As Section _
) As System.Integer
public System.int IndexOf(
   Section section
)

Parameters

section

Specifies the Section object.

See Also

Reference

SectionCollection Class
SectionCollection Members


Insert Method (SectionCollection)

Insert Method (SectionCollection)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Insert Method
Inserts a section into the collection at the specified index.
Overload List
Overload | Description
Insert(Int32,Section) | Inserts a section at the specified index in the collection.
Insert(Int32,SectionType,String) | Creates a new Section of the specified type and name and inserts it into the SectionCollection at the specified index.
Example
  • C#
GrapeCity.ActiveReports.ActiveReport rpt = New GrapeCity.ActiveReports.ActiveReport();
    rpt.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail,"Detail");
    rpt.Sections.InsertPageHF();
    rpt.Sections.Insert(0,GrapeCity.ActiveReports.Document.Section.SectionType.ReportHeader,"rh");
    rpt.Sections.Insert(4,GrapeCity.ActiveReports.Document.Section.SectionType.ReportFooter,"rf");
    rpt.Sections[0].BackColor = System.Drawing.Color.PowderBlue;
    rpt.Sections[1].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Sections[2].BackColor = System.Drawing.Color.Orchid;
    rpt.Sections[3].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Sections[4].BackColor = System.Drawing.Color.PowderBlue;
    rpt.Run();
    this.arv.Document = rpt.Document;
  • Visual Basic
Dim rpt As New GrapeCity.ActiveReports.ActiveReport
    rpt.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail, "Detail")
    rpt.Sections.InsertPageHF()
    rpt.Sections.Insert(0, GrapeCity.ActiveReports.Document.Section.SectionType.ReportHeader, "rh")
    rpt.Sections.Insert(4, GrapeCity.ActiveReports.Document.Section.SectionType.ReportFooter, "rf")
    rpt.Sections(0).BackColor = System.Drawing.Color.PowderBlue
    rpt.Sections(1).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Sections(2).BackColor = System.Drawing.Color.Orchid
    rpt.Sections(3).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Sections(4).BackColor = System.Drawing.Color.PowderBlue
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
See Also

Reference

SectionCollection Class
SectionCollection Members


Insert(Int32,Section) Method

Insert(Int32,Section) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > Insert Method : Insert(Int32,Section) Method
The zero-based index where the specified section should be inserted.
The Section to be inserted.
Inserts a section at the specified index in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Insert( _
   ByVal index As System.Integer, _
   ByVal section As Section _
)
public void Insert(
   System.int index,
   Section section
)

Parameters

index
The zero-based index where the specified section should be inserted.
section
The Section to be inserted.
See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


Insert(Int32,SectionType,String) Method

Insert(Int32,SectionType,String) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > Insert Method : Insert(Int32,SectionType,String) Method
The zero-based index where the new section should be inserted.
SectionType of the section to insert.
Unique name of the new section.
Creates a new Section of the specified type and name and inserts it into the SectionCollection at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Insert( _
   ByVal index As System.Integer, _
   ByVal type As SectionType, _
   ByVal name As System.String _
) As Section
public Section Insert(
   System.int index,
   SectionType type,
   System.string name
)

Parameters

index
The zero-based index where the new section should be inserted.
type
SectionType of the section to insert.
name
Unique name of the new section.

Return Value

A section that was created and added into the collection.
Remarks
Report, Page and Group sections must be added in a header/footer pair. The InsertReportHF, InsertPageHF and InsertGroupHF ensure proper pairing of the header/footer.
See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List
InsertReportHF Method
InsertPageHF Method
InsertGroupHF Method


InsertGroupHF Method

InsertGroupHF Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : InsertGroupHF Method
Inserts a group header and a matching group footer into the SectionCollection with the default names GroupHeader1,GroupFooter1; where 1 is an order number.
Inserts a group header and a matching group footer into the SectionCollection.
Overload List
Overload | Description
InsertGroupHF() | Inserts a group header and a matching group footer into the SectionCollection with the default names GroupHeader1,GroupFooter1; where 1 is an order number.
InsertGroupHF(String,String) | Inserts a group header and a matching group footer into the SectionCollection with the names, specified in the corresponding grHeaderName and grFooterName parameters.
Remarks
The new sections are added at the inner level of the groups, immediately before and after the Detail section in the report layout.
Example
  • C#
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
    rpt.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail,"Detail");
    rpt.Sections.InsertGroupHF();
    rpt.Sections[0].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Sections[1].BackColor = System.Drawing.Color.Orchid;
    rpt.Sections[2].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Run();
    this.Viewer.Document = rpt.Document;
  • Visual Basic
Dim rpt As New GrapeCity.ActiveReports.SectionReport
    rpt.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail, "Detail")
    rpt.Sections.InsertGroupHF()
    rpt.Sections(0).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Sections(1).BackColor = System.Drawing.Color.Orchid
    rpt.Sections(2).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
See Also

Reference

SectionCollection Class
SectionCollection Members
GroupHeader Class
GroupFooter Class
Section Class


InsertGroupHF() Method

InsertGroupHF() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > InsertGroupHF Method : InsertGroupHF() Method
Inserts a group header and a matching group footer into the SectionCollection with the default names GroupHeader1,GroupFooter1; where 1 is an order number.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub InsertGroupHF()
public void InsertGroupHF()
See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


InsertGroupHF(String,String) Method

InsertGroupHF(String,String) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > InsertGroupHF Method : InsertGroupHF(String,String) Method
Specifies the name of the Group Header section.
Specifies the name of the Page Footer section.
Inserts a group header and a matching group footer into the SectionCollection with the names, specified in the corresponding grHeaderName and grFooterName parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub InsertGroupHF( _
   ByVal grHeaderName As System.String, _
   ByVal grFooterName As System.String _
)
public void InsertGroupHF(
   System.string grHeaderName,
   System.string grFooterName
)

Parameters

grHeaderName
Specifies the name of the Group Header section.
grFooterName
Specifies the name of the Page Footer section.
See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


InsertPageHF() Method

InsertPageHF() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : InsertPageHF() Method
Inserts a page header and a page matching footer into the SectionCollection with the default names PageHeader1, PageFooter1; where 1 is an order number.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub InsertPageHF()
public void InsertPageHF()
See Also

Reference

SectionCollection Class
SectionCollection Members


InsertReportHF() Method

InsertReportHF() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : InsertReportHF() Method
Inserts a report header and a matching report footer into the SectionCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub InsertReportHF()
public void InsertReportHF()
See Also

Reference

SectionCollection Class
SectionCollection Members


Remove Method (SectionCollection)

Remove Method (SectionCollection)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Remove Method
Removes the specified Section from the SectionCollection if it exists.
Removes a section from the SectionCollection.
Overload List
Overload | Description
Remove(Section) | Removes the specified Section from the SectionCollection if it exists.
Remove(Int32) | Removes the Section at the specified index from the SectionCollection.
Remarks

You should always remove the matching header/footer section when removing either a header or a footer section. The Detail section cannot be removed from the collection.

Removing a section from the collection adjusts the index of the remaining sections.

Example
  • C#
GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
    rpt.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail,"detail");
    rpt.Sections.InsertPageHF();
    rpt.Sections.Insert(0,GrapeCity.ActiveReports.Document.Section.SectionType.ReportHeader,"rh");
    rpt.Sections.Insert(4,GrapeCity.ActiveReports.Document.Section.SectionType.ReportFooter,"rf");
    rpt.Sections[0].BackColor = System.Drawing.Color.PowderBlue;
    rpt.Sections[1].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Sections[2].BackColor = System.Drawing.Color.Orchid;
    rpt.Sections[3].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Sections[4].BackColor = System.Drawing.Color.PowderBlue;
    rpt.Sections.Remove(0);
    rpt.Sections.Remove(3);
    rpt.Run();
    this.arv.Document = rpt.Document;
  • Visual Basic
Dim rpt As New GrapeCity.ActiveReports.SectionReport
    rpt.Sections.Add(GrapeCity.ActiveReports.Document.Section.SectionType.Detail, "Detail1")
    rpt.Sections.InsertPageHF()
    rpt.Sections.Insert(0, GrapeCity.ActiveReports.Document.Section.SectionType.ReportHeader, "rh")
    rpt.Sections.Insert(4, GrapeCity.ActiveReports.Document.Section.SectionType.ReportFooter, "rf")
    rpt.Sections(0).BackColor = System.Drawing.Color.PowderBlue
    rpt.Sections(1).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Sections(2).BackColor = System.Drawing.Color.Orchid
    rpt.Sections(3).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Sections(4).BackColor = System.Drawing.Color.PowderBlue
    rpt.Sections.Remove(0)
    rpt.Sections.Remove(3)
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
See Also

Reference

SectionCollection Class
SectionCollection Members


Remove(Section) Method

Remove(Section) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > Remove Method : Remove(Section) Method
Section to be removed from the collection.
Removes the specified Section from the SectionCollection if it exists.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Remove( _
   ByVal section As Section _
)
public void Remove(
   Section section
)

Parameters

section
Section to be removed from the collection.
See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


Remove(Int32) Method

Remove(Int32) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > Remove Method : Remove(Int32) Method
Index of the Section to be removed.
Removes the Section at the specified index from the SectionCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Remove( _
   ByVal index As System.Integer _
)
public void Remove(
   System.int index
)

Parameters

index
Index of the Section to be removed.
See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


SectionCollection Class Properties

SectionCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : SectionCollection Class

For a list of all members of this type, see SectionCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the SectionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the SectionCollection instance. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Returns a reference to a Section in the SectionCollection using its index or unique name.
Top
See Also

Reference

SectionCollection Class
GrapeCity.ActiveReports Namespace
Section Class
Detail Class
GroupFooter Class
GroupHeader Class
PageFooter Class
PageHeader Class
ReportFooter Class
ReportHeader Class


Item Property (SectionCollection)

Item Property (SectionCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Item Property
Returns a reference to a Section in the SectionCollection using its index or unique name.
Overload List
Overload | Description
Item(Int32) | Gets the Section object at the specified indexed location in the SectionCollection.
Item(String) | Gets the Section object with the specified name in the SectionCollection.
See Also

Reference

SectionCollection Class
SectionCollection Members


Item(Int32) Property

Item(Int32) Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > Item Property : Item(Int32) Property
Index of the section to be returned.
Gets the Section object at the specified indexed location in the SectionCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal index As System.Integer _
) As Section
public Section Item(
   System.int index
) {get;}

Parameters

index
Index of the section to be returned.
See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


Item(String) Property

Item(String) Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class > Item Property : Item(String) Property
Unique name of the Section to be returned.
Gets the Section object with the specified name in the SectionCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal name As System.String _
) As Section
public Section Item(
   System.string name
) {get;}

Parameters

name
Unique name of the Section to be returned.
See Also

Reference

SectionCollection Class
SectionCollection Members
Overload List


SectionCollection Class Events

SectionCollection Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : SectionCollection Class

For a list of all members of this type, see SectionCollection members.

Public Events
 | Name | Description
Public Event | Changed | Occurs when the members of the SectionCollection have changed.
Top
See Also

Reference

SectionCollection Class
GrapeCity.ActiveReports Namespace
Section Class
Detail Class
GroupFooter Class
GroupHeader Class
PageFooter Class
PageHeader Class
ReportFooter Class
ReportHeader Class


Changed Event (SectionCollection)

Changed Event (SectionCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Changed Event
Occurs when the members of the SectionCollection have changed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Changed As System.EventHandler
public event System.EventHandler Changed
See Also

Reference

SectionCollection Class
SectionCollection Members


SectionReport Class

SectionReport Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : SectionReport Class
The SectionReport class is the base class for all section reports. It is used to execute and render the report.
Object Model
SectionReport Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class SectionReport
   Inherits System.MarshalByRefObject
public class SectionReport : System.MarshalByRefObject
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
GrapeCity.ActiveReports.SectionReport

See Also

Reference

SectionReport Members
GrapeCity.ActiveReports Namespace


SectionReport Class Members

SectionReport Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : SectionReport Class

The following tables list the members exposed by SectionReport.

Public Constructors
 | Name | Description
Public Constructor | SectionReport Constructor | Initializes a new instance of the SectionReport class.
Top
Public Properties
 | Name | Description
Public Property | CalculatedFields | Gets a FieldCollection object containing all of the calculated fields in the report.
Public Property | Culture | Provides information on a specific culture, including its names and the writing system.
Public Property | CurrentPage | Returns the current page instance.
Public Property | DataMember | Gets or sets the specified list in an DataSource to which the report will bind.
Public Property | DataSource | Gets or sets the data source from which the report will retrieve data.
Public Property | Document | Gets a reference to the report output Document object.
Public Property | EnableScriptDebugging | Allows to catch script exceptions in the debugger. The default value is False.
Public Property | ExpressionErrorMessage | Stops the reporting engine from throwing exceptions and instead displays the provided string.
Public Property | Fields | Returns the current data binding collection. This collection contains the available Field objects to which the report controls and sections can be bound.
Public Property | IsDirty | Sets or returns the current state of the report layout. This property is set to True when any changes are made to the report layout since it was last saved.
Public Property | LayoutAction | Sets or returns a custom action following the rendering of the current record.
Public Property | MaxPages | Sets or returns the maximum number of pages that the report will create.
Public Property | Name | Gets or sets the name of the report.
Public Property | PageNumber | Returns the number of the current page being processed when a report is running.
Public Property | PageSettings | Returns a reference to the current report's page settings.
Public Property | Parameters | Returns a reference to the data source query parameters collection.
Public Property | ParentReport | Gets a reference to the parent report.
Public Property | PrintWidth | Sets or returns the report's printable width in inches.
Public Property | ReportServerUri | Gets or sets the report server URI.
Public Property | Script | Sets or returns the script code for a report's events. Either this property or the script editor may be used to add script to a report.
Public Property | ScriptLanguage | Sets or returns the scripting language ActiveReports will use to write and interpret the script properties.
Public Property | Sections | Returns a reference to the report's sections collection.
Public Property | ShowParameterUI | Sets or returns whether or not the query parameters dialog box will appear when the report is run.
Public Property | State | Returns the current state of the report.
Public Property | StyleSheet | Returns a collection of formatting styles used to format controls in the report.
Public Property | UserData | Sets or returns a user-defined value.
Public Property | Version | Returns the product's version number.
Public Property | Watermark | Adds a specified image to the report's background. The watermark image can be positioned, sized, aligned and placed on specified pages by using the other watermark properties.
Public Property | WatermarkAlignment | Sets or returns the watermark's general vertical and horizontal position when it is added to the canvas.
Public Property | WatermarkPrintOnPages | Sets or returns a value indicating the specific pages to which the watermark should be added.
Public Property | WatermarkSizeMode | Sets or returns how the watermark will be sized when the image is rendered on the page.
Top
Public Methods
 | Name | Description
Public Method | AddCode | Adds additional valid script code to the report's scripting context. Using AddCode allows complete functions to be added to a report's script at run time. The added functions can be called from the report events in script.
Public Method | AddControlLicense | Adds a license key to the report so licensed controls can be added to sections at run time by using the Controls.Add method.
Public Method | AddNamedItem | Adds an object to the script's global namespace. This method allows scripts to become aware of custom classes contained within a project. Once an item has been added, the script can use the objectName string to reference the object and the functions contained within the class.
Public Method | AddScriptReference | Adds a reference to the specified assembly to be loaded into the scripting run-time context.
Public Method | Cancel | Cancels the report's processing. Any rendered pages will be cleared from the report's Document object.
static (Shared in Visual Basic) | CmToInch | Converts value from centimeters to inches.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the report instance from memory.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
static (Shared in Visual Basic) | InchToCm | Converts value from inches to centimeters.
Public Method | LoadLayout | Overloaded. Retrieves a report XML layout (RPX) from a file, stream or resource.
Public Method | LoadStyles | Overloaded. Loads an external stylesheet to use with the report.
Public Method | ResetScripts | Clears the script of any items added using the AddNamedItem method or code added using the AddCode method. This does not affect the pre-saved report layout (RPX) file and only clears code added using the above methods.
Public Method | ResetWatermark | Resets the watermark to its default value.
Public Method | Restart | Resets the report data source and clears the pages collection.
Public Method | Run | Overloaded. Starts the report processing.
Public Method | SaveLayout | Overloaded. Saves a report's XML layout to a stream or file.
Public Method | SaveStyles | Overloaded. Saves a reports styles to an external stylesheet.
Public Method | Stop | Stops processing the report.
Top
Public Events
 | Name | Description
Public Event | DataInitialize | Raised after the ReportStart event to allow the addition of custom fields to the report's fields collection.
Public Event | DataSourceChanged | Raised when the properties of the report's data source are modified.
Public Event | FetchData | Raised every time a new record is processed.
Public Event | NoData | Raised if the report's data source does not return any records and there is no data to be processed.
Public Event | PageEnd | Raised after the report finishes rendering each page.
Public Event | PageStart | Raised before the report renders any output to a new page.
Public Event | ParameterUIClosed | Raised after the user closes the query parameters dialog.
Public Event | PrintAborted | Raised when the user cancels a print job.
Public Event | PrintProgress | Raised for each page while printing the report document.
Public Event | ReportEnd | Raised after the report finishes processing all pages.
Public Event | ReportStart | Raised before a report starts processing.
Top
See Also

Reference

SectionReport Class
GrapeCity.ActiveReports Namespace


SectionReport Constructor

SectionReport Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : SectionReport Constructor
Initializes a new instance of the SectionReport class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public SectionReport()
See Also

Reference

SectionReport Class
SectionReport Members


SectionReport Class Methods

SectionReport Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : SectionReport Class

For a list of all members of this type, see SectionReport members.

Public Methods
 | Name | Description
Public Method | AddCode | Adds additional valid script code to the report's scripting context. Using AddCode allows complete functions to be added to a report's script at run time. The added functions can be called from the report events in script.
Public Method | AddControlLicense | Adds a license key to the report so licensed controls can be added to sections at run time by using the Controls.Add method.
Public Method | AddNamedItem | Adds an object to the script's global namespace. This method allows scripts to become aware of custom classes contained within a project. Once an item has been added, the script can use the objectName string to reference the object and the functions contained within the class.
Public Method | AddScriptReference | Adds a reference to the specified assembly to be loaded into the scripting run-time context.
Public Method | Cancel | Cancels the report's processing. Any rendered pages will be cleared from the report's Document object.
static (Shared in Visual Basic) | CmToInch | Converts value from centimeters to inches.
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the report instance from memory.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
static (Shared in Visual Basic) | InchToCm | Converts value from inches to centimeters.
Public Method | LoadLayout | Overloaded. Retrieves a report XML layout (RPX) from a file, stream or resource.
Public Method | LoadStyles | Overloaded. Loads an external stylesheet to use with the report.
Public Method | ResetScripts | Clears the script of any items added using the AddNamedItem method or code added using the AddCode method. This does not affect the pre-saved report layout (RPX) file and only clears code added using the above methods.
Public Method | ResetWatermark | Resets the watermark to its default value.
Public Method | Restart | Resets the report data source and clears the pages collection.
Public Method | Run | Overloaded. Starts the report processing.
Public Method | SaveLayout | Overloaded. Saves a report's XML layout to a stream or file.
Public Method | SaveStyles | Overloaded. Saves a reports styles to an external stylesheet.
Public Method | Stop | Stops processing the report.
Top
See Also

Reference

SectionReport Class
GrapeCity.ActiveReports Namespace


AddCode Method

AddCode Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : AddCode Method
Script code written in the specified report scripting language.
Adds additional valid script code to the report's scripting context. Using AddCode allows complete functions to be added to a report's script at run time. The added functions can be called from the report events in script.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddCode( _
   ByVal script As System.String _
)
public void AddCode(
   System.string script
)

Parameters

script
Script code written in the specified report scripting language.
Remarks
This method is typically used when executing stand-alone reports that are not compiled into the application. Injected code allows the report to access features such as custom calculation functions and data access modules in the calling application.
Example
  • C#
public string addThisCode()
{
    string sCode = "public string ShowACMessage()\"{return \"my Added Code\";}";
    return sCode;
}

private void rptAddCode_ReportStart(object sender, System.EventArgs eArgs)
{
    this.AddCode(addThisCode());
}
  • Visual Basic
Public Function addThisCode() As String
    Dim sCode As String = "public string ShowACMessage()""{return ""my Added Code"";}"
    Return sCode
End Function

Private Sub rptAddCode_ReportStart(sender As Object, eArgs As System.EventArgs)
    Me.AddCode(addThisCode())
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
AddNamedItem Method


AddControlLicense Method

AddControlLicense Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : AddControlLicense Method
Licensed control's class name.
String containing the licensed control's license.
Adds a license key to the report so licensed controls can be added to sections at run time by using the Controls.Add method.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddControlLicense( _
   ByVal className As System.String, _
   ByVal license As System.String _
)
public void AddControlLicense(
   System.string className,
   System.string license
)

Parameters

className
Licensed control's class name.
license
String containing the licensed control's license.
See Also

Reference

SectionReport Class
SectionReport Members


AddNamedItem Method

AddNamedItem Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : AddNamedItem Method
The name of the new object.
The value of the new object.
Adds an object to the script's global namespace. This method allows scripts to become aware of custom classes contained within a project. Once an item has been added, the script can use the objectName string to reference the object and the functions contained within the class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddNamedItem( _
   ByVal objectName As System.String, _
   ByVal objectReference As System.Object _
)
public void AddNamedItem(
   System.string objectName,
   System.object objectReference
)

Parameters

objectName
The name of the new object.
objectReference
The value of the new object.
Remarks

This method allows you to add objects such as data layer or business objects from the calling application into the report scripting context. For example, you might have an Order class that contains a method for computing sales tax. When you print the order you can pass an Order class instance to the report to allow you to call that method from the report script.

This method is typically used when running reports in stand-alone mode and not compiled into the application.

Example
  • C#
//Add this code to the Class File
public class clsMyItem
{
      public clsMyItem()
      {
      }
      public string getMyItem()
      {
            return "Hello";
      }
}

//Add this code to the report
private void rptAddNamedItem_ReportStart(object sender, System.EventArgs eArgs)
{
      this.AddNamedItem("myItem", new clsMyItem());
}
  • Visual Basic
'Add this code to the Class File
Public Class clsMyItem
      Public Function getMyItem() As String
            getMyItem = "Hello"
      End Function
End Class

'Add this code to the report
Private Sub rptAddNamedItem_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
      Me.AddNamedItem("myItem", New clsMyItem())
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
AddCode Method


AddScriptReference Method

AddScriptReference Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : AddScriptReference Method
Name of the assembly to be added to the scripting run-time context.
Adds a reference to the specified assembly to be loaded into the scripting run-time context.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddScriptReference( _
   ByVal scriptRef As System.String _
)
public void AddScriptReference(
   System.string scriptRef
)

Parameters

scriptRef
Name of the assembly to be added to the scripting run-time context.
Remarks
ActiveReports loads assemblies that are referenced in the application. You can use this method to add additional assemblies to be used in scripting that are not part of the application running the report.
Example
  • C#
private void runReport()
{
      SectionReport1 rpt = new SectionReport1();
      rpt.AddScriptReference("System.Data");
      rpt.Run();
      this.viewer1.Document = rpt.Document;
}
  • Visual Basic
Private Sub runReport()
      Dim rpt As New SectionReport1()
      rpt.AddScriptReference("System.Data")
      rpt.Run()
      Me.viewer1.Document = rpt.Document
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
AddNamedItem Method
AddCode Method


Cancel Method (SectionReport)

Cancel Method (SectionReport)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Cancel Method
Cancels the report's processing. Any rendered pages will be cleared from the report's Document object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Cancel()
public void Cancel()
Remarks
You can call this method based on a user's request or in a report event such as ReportStart to prevent printing a blank report if their data source did not return any records.
Example
  • C#
private void rpt_ReportStart(object sender, System.EventArgs eArgs)
{
    if (this.DataSource==null)
    {
        this.Cancel();
    }
}
  • Visual Basic
Private Sub rpt_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    If Me.DataSource Is Nothing Then
        Me.Cancel()
    End If
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
Stop Method


CmToInch Method

CmToInch Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : CmToInch Method
The measurement in centimeters to be converted to inches.
Converts value from centimeters to inches.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function CmToInch( _
   ByVal value As System.Single _
) As System.Single
public static System.float CmToInch(
   System.float value
)

Parameters

value
The measurement in centimeters to be converted to inches.

Return Value

Single value representing the specified centimeters value in inches.
Remarks

ActiveReports uses inches for all coordinate and dimension properties. This method helps convert centimeter values to inches.

Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.Left = SectionReport1.CmToInch(2);
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Label1.Left = SectionReport1.CmToInch(2)
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
InchToCm Method


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Dispose() Method
Releases the report instance from memory.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

SectionReport Class
SectionReport Members


InchToCm Method

InchToCm Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : InchToCm Method
Inches value to be converted to centimeters .
Converts value from inches to centimeters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function InchToCm( _
   ByVal value As System.Single _
) As System.Single
public static System.float InchToCm(
   System.float value
)

Parameters

value
Inches value to be converted to centimeters .

Return Value

Single value representing the inches value in centimeters.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.Label1.Left = SectionReport1.InchToCm(2);
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Label1.Left = SectionReport1.InchToCm(2)
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
CmToInch Method


LoadLayout Method

LoadLayout Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : LoadLayout Method
Retrieves a report XML layout (RPX) from a file, stream or resource.
Overload List
Overload | Description
LoadLayout(String) | This overload has been deprecated. Please use the new LoadLayout(XmlReader) overload.
LoadLayout(Stream) | This overload has been deprecated. Please use the new LoadLayout(XmlReader) overload.
LoadLayout(Stream,ArrayList) | This overload has been deprecated. Please use the new LoadLayout(XmlReader) overload.
LoadLayout(Type,String) | This overload has been deprecated. Please use the new LoadLayout(XmlReader) overload.
LoadLayout(XmlReader) | Retrieves a report XML layout from an XmlReader and loads it into a report object.
Remarks
This method can be executed for any existing report class (code type). However, in such cases, all the layout related information defined in existing report class is cleared and gets updated with the loaded RPX file content. Due to this reason, any code (example: Me.textBox1.Text = "ABC") that directly tries to access a control on a report and is defined in the existing report class is ignored. For event related code implementations, it is possible to embed the code in RPX file. In this case, please use Scripting.
Example
  • C#
GrapeCity.ActiveReports.SectionReport report = new GrapeCity.ActiveReports.SectionReport();
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader("\\report.rpx");
report.LoadLayout(xtr);
xtr.Close();

// reading from XML DOM (XmlNode)
using (System.Xml.XmlNodeReader reader = new System.Xml.XmlNodeReader(node))
{
    report.LoadLayout(reader);
}

// reading from stream
using (System.Xml.XmlReader reader = System.Xml.XmlReader.Create(inputStream))
{
    report.LoadLayout(reader);
}

// reading from string
string layoutContent = "<ActiveReports>...  ...</ActiveReports>";
using (System.Xml.XmlReader reader = System.Xml.XmlReader.Create(new System.IO.StringReader(layoutContent)))
{
    report.LoadLayout(reader);
}
  • Visual Basic
Dim report As New GrapeCity.ActiveReports.SectionReport()
Dim xtr As New System.Xml.XmlTextReader("\report.rpx")
report.LoadLayout(xtr)
xtr.Close()

' reading from XML DOM (XmlNode)
Using reader As New System.Xml.XmlNodeReader(node)
    report.LoadLayout(reader)
End Using

' reading from stream
Using reader As New System.Xml.XmlTextReader(inputStream)
    report.LoadLayout(reader)
End Using

' reading from string
Dim layoutContent As String = "<ActiveReports>...  ...</ActiveReports>"
Using reader As New System.Xml.XmlTextReader(New System.IO.StringReader(layoutContent))
    report.LoadLayout(reader)
End Using
See Also

Reference

SectionReport Class
SectionReport Members
SaveLayout Method

Concepts

Scripting


LoadLayout(String) Method

LoadLayout(String) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > LoadLayout Method : LoadLayout(String) Method
Report layout (RPX) file name.

This overload has been deprecated. Please use the new LoadLayout(XmlReader) overload.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadLayout( _
   ByVal fileName As System.String _
)
public void LoadLayout(
   System.string fileName
)

Parameters

fileName
Report layout (RPX) file name.
Remarks
This method can be executed for any existing report class (code type). However, in such cases, all the layout related information defined in existing report class is cleared and gets updated with the loaded RPX file content. Due to this reason, any code (example: Me.textBox1.Text = "ABC") that directly tries to access a control on a report and is defined in the existing report class is ignored. For event related code implementations, it is possible to embed the code in RPX file. In this case, please use Scripting.
See Also

Reference

SectionReport Class
SectionReport Members
Overload List


LoadLayout(Stream) Method

LoadLayout(Stream) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > LoadLayout Method : LoadLayout(Stream) Method

A stream that contains a valid report XML layout.

This overload has been deprecated. Please use the new LoadLayout(XmlReader) overload.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadLayout( _
   ByVal stream As System.IO.Stream _
)
public void LoadLayout(
   System.IO.Stream stream
)

Parameters

stream

A stream that contains a valid report XML layout.

Remarks
This method can be executed for any existing report class (code type). However, in such cases, all the layout related information defined in existing report class is cleared and gets updated with the loaded RPX file content. Due to this reason, any code (example: Me.textBox1.Text = "ABC") that directly tries to access a control on a report and is defined in the existing report class is ignored. For event related code implementations, it is possible to embed the code in RPX file. In this case, please use Scripting.
See Also

Reference

SectionReport Class
SectionReport Members
Overload List


LoadLayout(Stream,ArrayList) Method

LoadLayout(Stream,ArrayList) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > LoadLayout Method : LoadLayout(Stream,ArrayList) Method

A stream that contains a valid report XML layout.

An array containing any errors that occur during LoadLayout.

This overload has been deprecated. Please use the new LoadLayout(XmlReader) overload.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadLayout( _
   ByVal stream As System.IO.Stream, _
   ByRef errors As ArrayList _
)
public void LoadLayout(
   System.IO.Stream stream,
   out ArrayList errors
)

Parameters

stream

A stream that contains a valid report XML layout.

errors

An array containing any errors that occur during LoadLayout.

Remarks
This method can be executed for any existing report class (code type). However, in such cases, all the layout related information defined in existing report class is cleared and gets updated with the loaded RPX file content. Due to this reason, any code (example: Me.textBox1.Text = "ABC") that directly tries to access a control on a report and is defined in the existing report class is ignored. For event related code implementations, it is possible to embed the code in RPX file. In this case, please use Scripting.
See Also

Reference

SectionReport Class
SectionReport Members
Overload List


LoadLayout(Type,String) Method

LoadLayout(Type,String) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > LoadLayout Method : LoadLayout(Type,String) Method
Type of stored resource.
Name of the resource entry that contains the report XML layout.

This overload has been deprecated. Please use the new LoadLayout(XmlReader) overload.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadLayout( _
   ByVal type As System.Type, _
   ByVal resourceName As System.String _
)
public void LoadLayout(
   System.Type type,
   System.string resourceName
)

Parameters

type
Type of stored resource.
resourceName
Name of the resource entry that contains the report XML layout.
Remarks
Use LoadLayout(Stream) or LoadLayout(String) instead.
See Also

Reference

SectionReport Class
SectionReport Members
Overload List

Concepts

Scripting


LoadLayout(XmlReader) Method

LoadLayout(XmlReader) Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > LoadLayout Method : LoadLayout(XmlReader) Method
XmlReader object from which to retrieve the report's layout.
Retrieves a report XML layout from an XmlReader and loads it into a report object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadLayout( _
   ByVal reader As System.Xml.XmlReader _
)
public void LoadLayout(
   System.Xml.XmlReader reader
)

Parameters

reader
XmlReader object from which to retrieve the report's layout.
Remarks
This method can be executed for any existing report class (code type). However, in such cases, all the layout related information defined in existing report class is cleared and gets updated with the loaded RPX file content. Due to this reason, any code (example: Me.textBox1.Text = "ABC") that directly tries to access a control on a report and is defined in the existing report class is ignored. For event related code implementations, it is possible to embed the code in RPX file. In this case, please use Scripting.
Example
  • C#
GrapeCity.ActiveReports.ActiveReport report = new GrapeCity.ActiveReports.ActiveReport();
System.Xml.XmlTextReader xtr = new System.Xml.XmlTextReader("\\report.rpx");
report.LoadLayout(xtr);
xtr.Close();

// reading from XML DOM (XmlNode)
using (System.Xml.XmlNodeReader reader = new System.Xml.XmlNodeReader(node))
{
   report.LoadLayout(reader);
}

// reading from stream
using (System.Xml.XmlReader reader = System.Xml.XmlReader.Create(inputStream))
{
   report.LoadLayout(reader);
}

// reading from string
string layoutContent = "<ActiveReports>...  ...</ActiveReports>";
using (System.Xml.XmlReader reader = System.Xml.XmlReader.Create(new System.IO.StringReader(layoutContent)))
{
   report.LoadLayout(reader);
}
  • Visual Basic
Dim report As New GrapeCity.ActiveReports.ActiveReport()
Dim xtr As New System.Xml.XmlTextReader("\report.rpx")
report.LoadLayout(xtr)
xtr.Close()

' reading from XML DOM (XmlNode)
Using reader As New System.Xml.XmlNodeReader(node)
    report.LoadLayout(reader)
End Using

' reading from stream
Using reader As New System.Xml.XmlTextReader(inputStream)
    report.LoadLayout(reader)
End Using

' reading from string
Dim layoutContent As String = "<ActiveReports>... ...</ActiveReports>"
Using reader As New System.Xml.XmlTextReader(New System.IO.StringReader(layoutContent))
    report.LoadLayout(reader)
End Using
See Also

Reference

SectionReport Class
SectionReport Members
Overload List


LoadStyles Method

LoadStyles Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : LoadStyles Method
Loads an external stylesheet to use with the report.
Overload List
Overload | Description
LoadStyles(String) | Loads an external stylesheet to use with the report.
LoadStyles(Stream) | Loads an external stylesheet to use with the report.
See Also

Reference

SectionReport Class
SectionReport Members

How To

Use External Style Sheets


LoadStyles(String) Method

LoadStyles(String) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > LoadStyles Method : LoadStyles(String) Method
The name of the file that loads the style sheet.
Loads an external stylesheet to use with the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadStyles( _
   ByVal fileName As System.String _
)
public void LoadStyles(
   System.string fileName
)

Parameters

fileName
The name of the file that loads the style sheet.
See Also

Reference

SectionReport Class
SectionReport Members
Overload List


LoadStyles(Stream) Method

LoadStyles(Stream) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > LoadStyles Method : LoadStyles(Stream) Method
The stream from which the external stylesheet is loaded.
Loads an external stylesheet to use with the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadStyles( _
   ByVal inStream As System.IO.Stream _
)
public void LoadStyles(
   System.IO.Stream inStream
)

Parameters

inStream
The stream from which the external stylesheet is loaded.
See Also

Reference

SectionReport Class
SectionReport Members
Overload List


ResetScripts Method

ResetScripts Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ResetScripts Method
Clears the script of any items added using the AddNamedItem method or code added using the AddCode method. This does not affect the pre-saved report layout (RPX) file and only clears code added using the above methods.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ResetScripts()
public void ResetScripts()
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
    rpt.LoadLayout(Application.StartupPath + "\\rptAddNamedItem.rpx");
    clsAddNamedItem m = new clsAddNamedItem();
    rpt.AddNamedItem("x", m);
    rpt.Run();
    this.arv.Document=rpt.Document;
    rpt.ResetScripts();
}
  • Visual Basic
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New GrapeCity.ActiveReports.SectionReport
    rpt.LoadLayout(Application.StartupPath & "\rptAddNamedItem.rpx")
    Dim m As New clsAddNamedItem
    rpt.AddNamedItem("x", m)
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
    rpt.ResetScripts()
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
AddCode
AddNamedItem
AddScriptReference


ResetWatermark Method

ResetWatermark Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ResetWatermark Method
Resets the watermark to its default value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub ResetWatermark()
public virtual void ResetWatermark()
Example
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.ResetWatermark();
}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.ResetWatermark()
End Sub
See Also

Reference

SectionReport Class
SectionReport Members


Restart Method (SectionReport)

Restart Method (SectionReport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Restart Method
Resets the report data source and clears the pages collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Restart()
public void Restart()
Remarks

This method is used to reset an existing report instance after modifying its data source or page settings so that it can be run again. Note that in order to run the report with the new settings, you must call the Run method after calling Restart.

See Also

Reference

SectionReport Class
SectionReport Members
Run Method


Run Method (SectionReport)

Run Method (SectionReport)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Run Method
Starts the report processing.
Overload List
Overload | Description
Run(Boolean) | Starts report execution and optionally keeps any linked viewer control document in sync with the report's document.
Run() | Starts the report processing in blocked mode.
Remarks
Once the report is completed, the Document property is set to the report output Document. You can use the Document to Print, Preview or Export the output.
Example
  • C#
private void formReport_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Run();
    viewer1.Document = rpt.Document;
}
  • Visual Basic
Private Sub formReport_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New rptMain()
    rpt.Run()
    Viewer1.Document = rpt.Document
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
Document Property
Cancel Method
Stop Method


Run(Boolean) Method

Run(Boolean) Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > Run Method : Run(Boolean) Method
Set to True to synchronize a linked viewer control document with the report processing.
Starts report execution and optionally keeps any linked viewer control document in sync with the report's document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Run( _
   ByVal syncDocument As System.Boolean _
)
public void Run(
   System.bool syncDocument
)

Parameters

syncDocument
Set to True to synchronize a linked viewer control document with the report processing.
Remarks
If the report document is linked to a viewer control the report will synchronize the viewer display and load pages as soon as they have completed rendering.
Example
  • C#
private void Form1_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Run(True);
    viewer1.Document = rpt.Document;
}
  • Visual Basic
Private Sub Form1_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New rptMain()
    rpt.Run(True)
    Viewer1.Document = rpt.Document
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
Overload List


Run() Method

Run() Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > Run Method : Run() Method
Starts the report processing in blocked mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Run()
public void Run()
Remarks
This method does not synchronize a viewer control's linked document until the report has finished processing.
Example
  • C#
private void Form1_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Run();
    viewer1.Document = rpt.Document;
}
  • Visual Basic
Private Sub Form1_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New rptMain()
    rpt.Run()
    Viewer1.Document = rpt.Document
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
Overload List
Document Property


SaveLayout Method

SaveLayout Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : SaveLayout Method
Saves a report's XML layout to a stream or file.
Overload List
Overload | Description
SaveLayout(String) | This overload has been deprecated. Please use the new SaveLayout(XmlWriter) overload.
SaveLayout(Stream) | This overload has been deprecated. Please use the new SaveLayout(XmlWriter) overload.
SaveLayout(XmlWriter) | Saves a report's XML layout to the specified XmlWriter.
Remarks

The SaveLayout(String) method uses the UTF-8 encoding, and the SaveLayout(Stream) method uses the UTF-16 encoding for saving.

When using this method, any code behind the report is ignored. To embed code in the report, use Scripting.

Example
  • C#
SectionReport1 ar = new SectionReport1();
System.Xml.XmlTextWriter xtw = new System.Xml.XmlTextWriter("\\report.rpx", null);
ar.SaveLayout(xtw);
xtw.Close();

// saving to stream
System.IO.MemoryStream memory_stream = new System.IO.MemoryStream();
using (System.Xml.XmlWriter writer = System.Xml.XmlWriter.Create(memory_stream))
{
    ar.SaveLayout(writer);
}

// saving to string
System.Text.StringBuilder layoutContent = new System.Text.StringBuilder();
using (System.Xml.XmlWriter writer = System.Xml.XmlWriter.Create(layoutContent))
{
    ar.SaveLayout(writer);
}
  • Visual Basic
Dim ar As New SectionReport1()
Dim xtw As New System.Xml.XmlTextWriter("\report.rpx", Nothing)
ar.SaveLayout(xtw)
xtw.Close()

' saving to stream
Dim memory_stream As New System.IO.MemoryStream
Using writer As System.Xml.XmlWriter = System.Xml.XmlWriter.Create(memory_stream)
    ar.SaveLayout(writer)
End Using

' saving to string
Dim layoutContent As New System.Text.StringBuilder()
Using writer As System.Xml.XmlWriter = System.Xml.XmlWriter.Create(layoutContent)
    ar.SaveLayout(writer)
End Using
See Also

Reference

SectionReport Class
SectionReport Members
LoadLayout Method

Concepts

Scripting


SaveLayout(String) Method

SaveLayout(String) Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > SaveLayout Method : SaveLayout(String) Method
Name of the file where the report's layout will be saved.

This overload has been deprecated. Please use the new SaveLayout(XmlWriter) overload.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SaveLayout( _
   ByVal fileName As System.String _
)
public void SaveLayout(
   System.string fileName
)

Parameters

fileName
Name of the file where the report's layout will be saved.
Remarks

The SaveLayout(String) method uses the UTF-8 encoding when you save to a file.

When using this method, any code behind the report is ignored. To embed code in the report, use Scripting.

Example
  • C#
private void saveRPX()
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Run();
    rpt.SaveLayout(Application.StartupPath + "\\NewRPX.RPX");
}
  • VB.NET
Dim rpt As New SectionReport1()
Private Sub saveRPX()
    rpt.Run()
    rpt.SaveLayout(Application.StartupPath + "\\NewRPX.RPX")
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
Overload List

Concepts

Scripting


SaveLayout(Stream) Method

SaveLayout(Stream) Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > SaveLayout Method : SaveLayout(Stream) Method
Stream object where the report's layout will be saved.

This overload has been deprecated. Please use the new SaveLayout(XmlWriter) overload.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SaveLayout( _
   ByVal stream As System.IO.Stream _
)
public void SaveLayout(
   System.IO.Stream stream
)

Parameters

stream
Stream object where the report's layout will be saved.
Remarks

You can use this method to save the report's layout as a stream, then store it in a database or a resource file.

The SaveLayout(Stream) method uses the UTF-16 encoding when you save to a stream.

When using this method, any code behind the report is ignored. To embed code in the report, use Scripting.

Example
  • C#
private void mnuPrintPreview_Click(object sender, System.EventArgs e)
{
    GrapeCity.ActiveReports.SectionReport rpt = new GrapeCity.ActiveReports.SectionReport();
    System.IO.MemoryStream m_stream = new System.IO.MemoryStream();
    this.designer1.Report.SaveLayout(m_stream);
    m_stream.Position = 0;
    rpt.LoadLayout(m_stream);
    m_stream.Close();
    frmViewer frm = new frmViewer();
    frm.SetReport(rpt);
    frm.ShowDialog(this);
}
  • VB.NET
Private Sub mnuPrintPreview_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) _
    Handles mnuPrintPreview.Click
        Dim rpt As New GrapeCity.ActiveReports.SectionReport()
        Dim m_stream As New System.IO.MemoryStream()
        Me.Designer1.Report.SaveLayout(m_stream)
        m_stream.Position = 0
        rpt.LoadLayout(m_stream)
        m_stream.Close()
        Dim frm As New frmViewer()
        frm.SetReport(rpt)
        frm.ShowDialog(Me)
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
Overload List


SaveLayout(XmlWriter) Method

SaveLayout(XmlWriter) Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > SaveLayout Method : SaveLayout(XmlWriter) Method
XmlWriter object where the report's layout is saved.
Saves a report's XML layout to the specified XmlWriter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SaveLayout( _
   ByVal writer As System.Xml.XmlWriter _
)
public void SaveLayout(
   System.Xml.XmlWriter writer
)

Parameters

writer
XmlWriter object where the report's layout is saved.
Remarks

You can use this method to save the report's layout to an XmlWriter object, then store it in a database or a resource file.

When using this method, any code behind the report is ignored. To embed code in the report, use Scripting.

Example
  • C#
SectionReport1 ar = new SectionReport1();
System.Xml.XmlTextWriter xtw = new System.Xml.XmlTextWriter("\\report.rpx", null);
ar.SaveLayout(xtw);
xtw.Close();

// saving to stream
System.IO.MemoryStream memory_stream = new System.IO.MemoryStream();
using (System.Xml.XmlWriter writer = System.Xml.XmlWriter.Create(memory_stream))
{
  ar.SaveLayout(writer);
}

// saving to string
System.Text.StringBuilder layoutContent = new System.Text.StringBuilder();
using (System.Xml.XmlWriter writer = System.Xml.XmlWriter.Create(layoutContent))
{
  ar.SaveLayout(writer);
}
  • Visual Basic
Dim ar As New SectionReport1()
Dim xtw As New System.Xml.XmlTextWriter("\report.rpx", Nothing)
ar.SaveLayout(xtw)
xtw.Close()

' saving to stream
Dim memory_stream As New System.IO.MemoryStream
Using writer As System.Xml.XmlWriter = System.Xml.XmlWriter.Create(memory_stream)
    ar.SaveLayout(writer)
End Using

' saving to string
Dim layoutContent As New System.Text.StringBuilder()
Using writer As System.Xml.XmlWriter = System.Xml.XmlWriter.Create(layoutContent)
   ar.SaveLayout(writer)
End Using
See Also

Reference

SectionReport Class
SectionReport Members
Overload List


SaveStyles Method

SaveStyles Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : SaveStyles Method
Saves a reports styles to an external stylesheet.
Overload List
Overload | Description
SaveStyles(String) | Saves a reports styles to an external stylesheet.
SaveStyles(Stream) | Saves a reports styles to an external stylesheet.
See Also

Reference

SectionReport Class
SectionReport Members


SaveStyles(String) Method

SaveStyles(String) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > SaveStyles Method : SaveStyles(String) Method
The file name to save the report's Style Sheet to.
Saves a reports styles to an external stylesheet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SaveStyles( _
   ByVal fileName As System.String _
)
public void SaveStyles(
   System.string fileName
)

Parameters

fileName
The file name to save the report's Style Sheet to.
See Also

Reference

SectionReport Class
SectionReport Members
Overload List


SaveStyles(Stream) Method

SaveStyles(Stream) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class > SaveStyles Method : SaveStyles(Stream) Method
The stream to which the external stylesheet is saved.
Saves a reports styles to an external stylesheet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SaveStyles( _
   ByVal outStream As System.IO.Stream _
)
public void SaveStyles(
   System.IO.Stream outStream
)

Parameters

outStream
The stream to which the external stylesheet is saved.
See Also

Reference

SectionReport Class
SectionReport Members
Overload List


Stop Method

Stop Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Stop Method
Stops processing the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Stop()
public void Stop()
Remarks
All rendered pages are retained in the report's Document.
See Also

Reference

SectionReport Class
SectionReport Members
Cancel Method


SectionReport Class Properties

SectionReport Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : SectionReport Class

For a list of all members of this type, see SectionReport members.

Public Properties
 | Name | Description
Public Property | CalculatedFields | Gets a FieldCollection object containing all of the calculated fields in the report.
Public Property | Culture | Provides information on a specific culture, including its names and the writing system.
Public Property | CurrentPage | Returns the current page instance.
Public Property | DataMember | Gets or sets the specified list in an DataSource to which the report will bind.
Public Property | DataSource | Gets or sets the data source from which the report will retrieve data.
Public Property | Document | Gets a reference to the report output Document object.
Public Property | EnableScriptDebugging | Allows to catch script exceptions in the debugger. The default value is False.
Public Property | ExpressionErrorMessage | Stops the reporting engine from throwing exceptions and instead displays the provided string.
Public Property | Fields | Returns the current data binding collection. This collection contains the available Field objects to which the report controls and sections can be bound.
Public Property | IsDirty | Sets or returns the current state of the report layout. This property is set to True when any changes are made to the report layout since it was last saved.
Public Property | LayoutAction | Sets or returns a custom action following the rendering of the current record.
Public Property | MaxPages | Sets or returns the maximum number of pages that the report will create.
Public Property | Name | Gets or sets the name of the report.
Public Property | PageNumber | Returns the number of the current page being processed when a report is running.
Public Property | PageSettings | Returns a reference to the current report's page settings.
Public Property | Parameters | Returns a reference to the data source query parameters collection.
Public Property | ParentReport | Gets a reference to the parent report.
Public Property | PrintWidth | Sets or returns the report's printable width in inches.
Public Property | ReportServerUri | Gets or sets the report server URI.
Public Property | Script | Sets or returns the script code for a report's events. Either this property or the script editor may be used to add script to a report.
Public Property | ScriptLanguage | Sets or returns the scripting language ActiveReports will use to write and interpret the script properties.
Public Property | Sections | Returns a reference to the report's sections collection.
Public Property | ShowParameterUI | Sets or returns whether or not the query parameters dialog box will appear when the report is run.
Public Property | State | Returns the current state of the report.
Public Property | StyleSheet | Returns a collection of formatting styles used to format controls in the report.
Public Property | UserData | Sets or returns a user-defined value.
Public Property | Version | Returns the product's version number.
Public Property | Watermark | Adds a specified image to the report's background. The watermark image can be positioned, sized, aligned and placed on specified pages by using the other watermark properties.
Public Property | WatermarkAlignment | Sets or returns the watermark's general vertical and horizontal position when it is added to the canvas.
Public Property | WatermarkPrintOnPages | Sets or returns a value indicating the specific pages to which the watermark should be added.
Public Property | WatermarkSizeMode | Sets or returns how the watermark will be sized when the image is rendered on the page.
Top
See Also

Reference

SectionReport Class
GrapeCity.ActiveReports Namespace


CalculatedFields Property

CalculatedFields Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : CalculatedFields Property
Gets a FieldCollection object containing all of the calculated fields in the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CalculatedFields As FieldCollection
public FieldCollection CalculatedFields {get;}
See Also

Reference

SectionReport Class
SectionReport Members


Culture Property (SectionReport)

Culture Property (SectionReport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Culture Property
Provides information on a specific culture, including its names and the writing system.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Culture As System.Globalization.CultureInfo
public System.Globalization.CultureInfo Culture {get; set;}
See Also

Reference

SectionReport Class
SectionReport Members


CurrentPage Property (SectionReport)

CurrentPage Property (SectionReport)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : CurrentPage Property
Returns the current page instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CurrentPage As Page
public Page CurrentPage {get;}
Remarks
This property allows you to use primitive drawing methods or apply templates to report pages while the report is processing.
Example
  • C#
private void rptTest_PageEnd(object sender, System.EventArgs eArgs)
{
    this.CurrentPage.DrawText("Confidential", 4F,10F,2F,0.188F);
}
  • Visual Basic
Private Sub rptDocument_PageEnd(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.PageEnd
    Me.CurrentPage.DrawText("Confidential", 4.0F, 10.0F, 2.0F, 0.188F)
End Sub
See Also

Reference

SectionReport Class
SectionReport Members


DataMember Property

DataMember Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : DataMember Property

Gets or sets the specified list in an DataSource to which the report will bind.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataMember As System.String
public System.string DataMember {get; set;}
Remarks

Default is an empty string.

If a data source, such as a dataset, contains multiple lists, you must set the DataMember to a list contained in the data source. The ActiveReports built-in data sources always contain a single data source, hence do not require that this property be set.

Example
  • C#
private void rptProducts_ReportStart(object sender, System.EventArgs eArgs)
{
    rptProducts rpt = new rptProducts();
    localhost.DataSetWS ws = new localhost.DataSetWS();
    DataSet ds = ws.GetProduct();
    this.DataSource = ds;
    this.DataMember = "Products";
}
  • Visual Basic
Private Sub rptProducts_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Dim rpt As New rptProducts()
    Dim ws As New localhost.DataSetWS()
    Dim ds As New DataSet()
    ds = ws.GetProduct()
    Me.DataSource = ds
    Me.DataMember = "Products"
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
DataSource Property


DataSource Property (SectionReport)

DataSource Property (SectionReport)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : DataSource Property
Gets or sets the data source from which the report will retrieve data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataSource As System.Object
public System.object DataSource {get; set;}

Property Value

An object that functions as a data source.
Remarks

The data source can be set to any of the ActiveReports built-in data sources or to any of the following:

  • DataSet
  • DataTable
  • DataView
  • RowCollection

You cannot change the data source property settings after the report starts processing.

Example
  • C#
private void rptProducts_ReportStart(object sender, System.EventArgs eArgs)
{
    rptProducts rpt = new rptProducts();
    localhost.DataSetWS ws = new localhost.DataSetWS();
    DataSet ds = ws.GetProduct();
    this.DataSource = ds;
    this.DataMember = "Products";
}
  • Visual Basic
Private Sub rptProducts_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Dim rpt As New rptProducts()
    Dim ws As New localhost.DataSetWS()
    Dim ds As New DataSet()
    ds = ws.GetProduct()
    Me.DataSource = ds
    Me.DataMember = "Products"
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
DataMember Property


Document Property (SectionReport)

Document Property (SectionReport)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Document Property
Gets a reference to the report output Document object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Document As SectionDocument
public SectionDocument Document {get;}

Property Value

Generated Document object, null if the report has not been executed.
Remarks
The SectionDocument class is in the GrapeCity.ActiveReports.Document.v10 assembly in the GrapeCity.ActiveReports.Document namespace.
Example
  • C#
private void formReport_Load(object sender, System.EventArgs e)
{
    rptMain rpt = new rptMain();
    this.viewer1.Document = rpt.Document;
    rpt.Run();
}
  • Visual Basic
Private Sub formReport_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New rptMain()
    Viewer1.Document = rpt.Document
    rpt.Run()
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
SectionDocument Class


EnableScriptDebugging Property

EnableScriptDebugging Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : EnableScriptDebugging Property
Allows to catch script exceptions in the debugger. The default value is False.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EnableScriptDebugging As System.Boolean
public System.bool EnableScriptDebugging {get; set;}
Remarks

The EnableScriptDebugging property should be set to True before the script code compilation, which is similar to setting it before calling the Run method in ActiveReports.

If EnableScriptDebugging is set to True, then the compiled code is stored to a .dll file in the temporary folder.

Note: Visual Studio does not support script debugging at design time preview of a report.

Example
  • C#
public void SectionReport_ReportStart()
{
    // the following line of script code attaches the debugger to the script
    System.Diagnostics.Debugger.Launch();
}
  • Visual Basic
Public Sub SectionReport_ReportStart()
   'the following line of script code attaches the debugger to the script
   System.Diagnostics.Debugger.Launch()
End Sub
See Also

Reference

SectionReport Class
SectionReport Members


ExpressionErrorMessage Property

ExpressionErrorMessage Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ExpressionErrorMessage Property
Stops the reporting engine from throwing exceptions and instead displays the provided string.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ExpressionErrorMessage As System.String
public System.string ExpressionErrorMessage {get; set;}

Property Value

String. The default value is null.
Remarks

If this property is not set and an expression can't be parsed, or if you get a divide-by-zero type exception, ActiveReports will throw a ReportScriptException and stop the report from running.

When this property is set to a valid string, the engine stops throwing exceptions and instead displays the specified string (like Excel). Set it to ### and try Sales/0 to test.

Persistence: There is a new attribute called "ExprError" in .rpx files.

Example
  • C#
private void arViewer_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.ExpressionErrorMessage = "oops";
    rpt.Run();
    this.arViewer.Document = rpt.Document;
}
  • Visual Basic
Private Sub arViewer_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arViewer.Load
    Dim rpt As New SectionReport1()
    rpt.ExpressionErrorMessage = "oops"
    rpt.Run()
    Me.arViewer.Document = rpt.Document
End Sub
See Also

Reference

SectionReport Class
SectionReport Members


Fields Property (SectionReport)

Fields Property (SectionReport)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Fields Property
Returns the current data binding collection. This collection contains the available Field objects to which the report controls and sections can be bound.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Fields As FieldCollection
public FieldCollection Fields {get; set;}
Remarks

ActiveReports initializes the collection with all the fields in the DataSource if any. You can add custom unbound fields to the collection in the DataInitialize event. This allows you to create custom calculated fields and bind the report sections and controls to fields not available through the data source but provided at run time in the FetchData event. This allows the report to bind to collections, arrays or any other custom data structure that your application handles.

Note: Do not reference the Fields collection outside the DataInitialize and FetchData events.

Example
  • C#
private void rptUnbound_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
}
  • Visual Basic
Private Sub rptUnbound_DataInitialize(ByVal sender As Object, ByVal e As _
    System.EventArgs) Handles MyBase.DataInitialize
    Fields.Add("CategoryName")
    Fields.Add("ProductName")
    Fields.Add("UnitsInStock")
    Fields.Add("Description")
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
DataInitialize Event
FetchData Event


IsDirty Property (SectionReport)

IsDirty Property (SectionReport)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : IsDirty Property
Sets or returns the current state of the report layout. This property is set to True when any changes are made to the report layout since it was last saved.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsDirty As System.Boolean
public System.bool IsDirty {get; set;}
Remarks
This property is typically used by the End-User Report Designer control to determine whether the current report layout needs to be saved.
Example
NOTE: The following is incomplete code. You would need to add your own code to handle the user's answer via the MessageBox.
  • C#
private void mnuExit_Click(object sender, System.EventArgs e)
{
    if (((GrapeCity.ActiveReports.SectionReport)this.reportdesigner.Report).IsDirty == true)
    {
        MessageBox.Show("Do you want to save your report?");
    }
    else
    {
        this.Close();
    }
}
  • Visual Basic
Private Sub mnuExit_Click(sender As Object, e As System.EventArgs)
    If DirectCast(Me.reportdesigner.Report, GrapeCity.ActiveReports.SectionReport).IsDirty = True Then
        MessageBox.Show("Do you want to save your report?")
    Else
        Me.Close()
    End If
End Sub
See Also

Reference

SectionReport Class
SectionReport Members


LayoutAction Property

LayoutAction Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : LayoutAction Property

Sets or returns a custom action following the rendering of the current record.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LayoutAction As LayoutAction
public LayoutAction LayoutAction {get; set;}

Property Value

Current layout action. The default is LayoutAction.MoveLayout | LayoutAction.NextRecord | LayoutAction.PrintSection, which returns a value of 7.

  • PrintSection has a value of 1.
  • MoveLayout has a value of 2.
  • NextRecord has a value of 4.
Remarks

ActiveReports automatically performs the following actions for each record in the data source after each Detail section format:

  1. Prints the section.
  2. Moves the layout (sets the next print position for the rest of the report).
  3. Moves to the next record.

The LayoutAction property allows you to control which of these steps should be performed or omitted. Using a combination of layout actions when the report is executed can change a report's layout.

This property can be used only in the Detail section's Format event.

The following table shows the results of different combinations of LayoutActions

Value | Print | Layout | NextR | Description
7 | True | True | True | (Default) Move to next print location, get next record, and print data.
3 | True | True | False | Move to the next print location, don't advance to the next record, but print the data.
4 | False | False | True | Skip a record without leaving a blank space on the page.
6 | False | True | True | Skip a record and leave a blank space on the page.
2 | False | True | False | Leave a blank space without skipping a record.
5 | True | False | True | Print the next record on top of the current record (UnderlayNext).
Example
  • C#
int counter=0;
private void detail_Format(object sender, System.EventArgs eArgs)
{
    //repeat each row five times
    counter = counter + 1;
    if (counter <= 4)
    {
        this.LayoutAction =  GrapeCity.ActiveReports.LayoutAction.LayoutAction.MoveLayout|GrapeCity.ActiveReports.LayoutAction.LayoutAction.PrintSection;
    }
    else
    {
        this.LayoutAction = GrapeCity.ActiveReports.LayoutAction.LayoutAction.MoveLayout|GrapeCity.ActiveReports.LayoutAction.LayoutAction.NextRecord|GrapeCity.ActiveReports.LayoutAction.LayoutAction.PrintSection;
        counter = 0;
    }
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    'repeat each row five times
    Static counter As Integer
    counter = counter + 1
    If counter <= 4 Then
        Me.LayoutAction = 3
    Else
        Me.LayoutAction = 7
        counter = 0
    End If
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
Format Event
LayoutAction Enumeration


MaxPages Property

MaxPages Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : MaxPages Property
Sets or returns the maximum number of pages that the report will create.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaxPages As System.Long
public System.long MaxPages {get; set;}

Property Value

Maximum number of pages. The default value is 0, which specifies no page limit.
Remarks

ActiveReports will stop the report execution once the report Document reaches the set number of pages.

This property can be used to limit the number of output pages when running large reports and distributing the results over a slow connection. It can also be used to present a quick preview of a few pages in a long report.

Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.MaxPages = 2;
    rpt.Run();
    this.arv.Document = rpt.Document;
}
  • Visual Basic
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    rpt.MaxPages = 2
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
End Sub
See Also

Reference

SectionReport Class
SectionReport Members


Name Property (SectionReport)

Name Property (SectionReport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Name Property
Gets or sets the name of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}
See Also

Reference

SectionReport Class
SectionReport Members


PageNumber Property (SectionReport)

PageNumber Property (SectionReport)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : PageNumber Property
Returns the number of the current page being processed when a report is running.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PageNumber As System.Integer
public System.int PageNumber {get;}
Example
  • C#
private void detail1_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Text=this.PageNumber.ToString();
}
  • Visual Basic
Private Sub detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.textBox1.Text = Me.PageNumber
End Sub
See Also

Reference

SectionReport Class
SectionReport Members


PageSettings Property (SectionReport)

PageSettings Property (SectionReport)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : PageSettings Property
Returns a reference to the current report's page settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageSettings As PageSettings
public PageSettings PageSettings {get; set;}

Property Value

Default PageSettings object.
Remarks

Used to specify settings that modify the way the report's pages will be printed.

Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.PageSettings.Orientation = GrapeCity.ActiveReports.Document.Section.PageOrientation.Landscape;
    rpt.Run();
    this.arv.Document = rpt.Document;
}
  • Visual Basic
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1()
    rpt.PageSettings.Orientation = GrapeCity.ActiveReports.Document.Section.PageOrientation.Landscape
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
ActiveReports6~GrapeCity.ActiveReports.PageSettings


Parameters Property (SectionReport)

Parameters Property (SectionReport)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Parameters Property
Returns a reference to the data source query parameters collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Parameters As ParameterCollection
public ParameterCollection Parameters {get;}

Property Value

An initialized Parameters collection.
Remarks

The parameters collection is automatically populated when the report is started. If parameters are specified in the report's DataSource, they will be added to the collection.

For example, setting your RecordSource to the following SQL adds "Order Date" and "Order ID" to the parameters collection.

"SELECT * FROM orders WHERE OrderDate >= #<%OrderDate|Enter Order date|1/1/1995%># AND OrderID > <%OrderID|OrderID%>"

You can set the parameter values before the report starts or allow ActiveReports to collect the values from the user at run time.

Note: Depending on your data source, you may need to add pound signs around the parameter syntax for dates (as in the "Order Date" example above) or apostrophes around the parameter syntax for strings, i.e. "SELECT * FROM Customers CustomerID = '<%CustomerID%>'"

Example
Paste into the Viewer Hyperlink event.
  • C#
private void arv_HyperLink(object sender, GrapeCity.ActiveReports.Viewer.Win.HyperLinkEventArgs e)
    {
     SectionReport1 rpt = new SectionReport1();
     Form1 frm = new Form1();
     rpt.Parameters["customerID"].Value = e.HyperLink.ToString();
     rpt.Run();
     frm.arv.Document = rpt.Document;
     frm.ShowDialog(this);
 }
Paste into the Viewer Hyperlink event.
  • Visual Basic
Private Sub arv_HyperLink(sender As Object, e As GrapeCity.ActiveReports.Viewer.Win.HyperLinkEventArgs) Handles arv.HyperLink
Dim rpt As New SectionReport1()
Dim frm As New Form1()
rpt.Parameters("customerID").Value = e.HyperLink.ToString()
rpt.Run()
frm.arv.Document = rpt.Document
frm.ShowDialog(Me)
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
ShowParameterUI Property


ParentReport Property (SectionReport)

ParentReport Property (SectionReport)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ParentReport Property
Gets a reference to the parent report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ParentReport As SectionReport
public SectionReport ParentReport {get;}

Property Value

ActiveReport (Reference to the parent report object).
Remarks
This property is available when the report is running as a subreport of another report.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.AddBookmark(((TextBox)(this.ParentReport.Sections["detail"].Controls["txtCategoryName"])).
        Text + "\\" + this.txtProductName.Text);
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.AddBookmark(CType(Me.ParentReport.Sections("Detail1").Controls("txtCategoryName"),  _
        TextBox).Text + "\" + Me.txtProductName.Text)
End Sub
See Also

Reference

SectionReport Class
SectionReport Members


PrintWidth Property

PrintWidth Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : PrintWidth Property
Sets or returns the report's printable width in inches.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrintWidth As System.Single
public System.float PrintWidth {get; set;}

Property Value

The amount of physical space to which a report can print. The default value is 6.5 inches.
Remarks
If the margin widths are not taken into consideration when setting the print width, the report may become wider than the paper size. When this happens, a blank page will be printed out after each page in the report, or in the viewer, a vertical red dotted line will appear on the right-hand side of the page.
Example
  • C#
private void viewer1_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.PrintWidth = rpt.PageSettings.PaperWidth - rpt.PageSettings.Margins.Left - rpt.PageSettings.Margins.Right;
    rpt.Run();
    this.viewer1.Document = rpt.Document;
}
  • Visual Basic
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    rpt.PrintWidth = rpt.PageSettings.PaperWidth - rpt.PageSettings.Margins.Left - rpt.PageSettings.Margins.Right
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
PageSettings Property


ReportServerUri Property

ReportServerUri Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ReportServerUri Property
Gets or sets the report server URI.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportServerUri As System.String
public System.string ReportServerUri {get; set;}
See Also

Reference

SectionReport Class
SectionReport Members


Script Property

Script Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Script Property
Sets or returns the script code for a report's events. Either this property or the script editor may be used to add script to a report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Script As System.String
public System.string Script {get; set;}

Property Value

The current script code. The default value is an empty string.
Remarks

The Script property can be used to make modifications to the report outside the code written in the report's events. The script events run immediately after their matching ActiveReports code-behind events and take precedence over the code inside the project.

If reports with scripts are saved to XML, the scripts (unlike code-behind) are incorporated into the XML file. Changes can be made to the XML file scripts and then loaded back into a report project to show the changes. This allows reports to be modified without requiring the project to be recompiled.

When referencing the report in the script, use rpt instead of the report's name or "Me" or "this".

In order to reference a member of the report class using the "rpt" named object, the member has to be a public member. You can use a control's modifier property to change the generated code for a control from private to public.

If you plan to run the report from a stand-alone RPX file without the compiled code-behind class, your scripting code would have to reference the report class controls using the Controls collection instead of by name.

Scripts are compiled at run time using the language specified in the ScriptLanguage property.

Example
This snippet assumes that you have html in the RichTextBox, and that the Modifiers property of the RichTextBox is set to Public.
  • C#
private void button1_Click(object sender, System.EventArgs e)
{
    string sScript = string.Empty;
    SectionReport1 rpt = new SectionReport1();

    sScript += "public void ReportHeader_Format()";
    sScript += "{";
    sScript += "rpt.RichTextBox1.Html = rpt.RichTextBox1.Text;";
    sScript += "}";

    rpt.Script = sScript;
    rpt.Run();
    arv.Document = rpt.Document;
}
  • Visual Basic
Private Sub button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnScript.Click
    Dim sScript As String = String.Empty
    Dim rpt As New SectionReport1

    sScript += "public void ReportHeader_Format()"
    sScript += "{"
    sScript += "rpt.RichTextBox1.Html = rpt.RichTextBox1.Text;"
    sScript += "}"

    rpt.Script = sScript
    rpt.Run()
    Viewer1.Document = rpt.Document
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
ScriptLanguage Property


ScriptLanguage Property

ScriptLanguage Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ScriptLanguage Property
Sets or returns the scripting language ActiveReports will use to write and interpret the script properties.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ScriptLanguage As System.String
public System.string ScriptLanguage {get; set;}

Property Value

String value that is the current scripting language. The default value is C#.

Remarks
When the ScriptLanguage is set, the script editor will use the specified scripting language. ActiveReports supports C# and VB.NET for run-time scripting.
See Also

Reference

SectionReport Class
SectionReport Members
Script Property


Sections Property

Sections Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Sections Property
Returns a reference to the report's sections collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Sections As SectionCollection
public SectionCollection Sections {get;}

Property Value

Sections collection.
Remarks
This property can be used to add or remove report sections at run time.
Example
  • C#
float m_defaultHeight = .2f;
float m_defaultWidth = 4f;
float m_currentY = 0f;

private void constructReport()
{
    try
    {
        this.detail.CanGrow = true;
        this.detail.CanShrink = true;
        this.detail.KeepTogether = true;

        if(m_useGroups)
        {
            this.Sections.InsertGroupHF();
            ((GroupHeader)this.Sections["groupHeader1"]).DataField = "Country";
            this.Sections["groupHeader1"].BackColor = System.Drawing.Color.SlateBlue;
            this.Sections["groupHeader1"].CanGrow = true;
            this.Sections["groupHeader1"].CanShrink = true;
            ((GroupHeader)this.Sections["groupHeader1"]).RepeatStyle = RepeatStyle.OnPageIncludeNoDetail;
            this.Sections["groupFooter1"].Height = 0;

            TextBox txt = new TextBox();
            txt.DataField = "Country";
            txt.Location = new System.Drawing.PointF(0f,0);
            txt.Width =2f;
            txt.Height = .3f;
            txt.Style = "font-weight: bold; font-size: 16pt;";
            this.Sections["groupHeader1"].Controls.Add(txt);

        }

        for(int i=0;i<m_arrayFields.Count;i++)
        {
            if(!m_useGroups || (m_useGroups && m_arrayFields[i].ToString() != "Country"))
            {
                Label lbl = new Label();
                lbl.Text = m_arrayFields[i].ToString() + ":";
                lbl.Location = new System.Drawing.PointF(0f,m_currentY);
                lbl.Width =.9f;
                lbl.Height = m_defaultHeight;
                this.detail.Controls.Add(lbl);

                TextBox txt = new TextBox();
                txt.DataField = m_arrayFields[i].ToString();
                txt.Location = new System.Drawing.PointF(1f,m_currentY);
                txt.Width =m_defaultWidth;
                txt.Height = m_defaultHeight;
                this.detail.Controls.Add(txt);

                m_currentY = m_currentY + m_defaultHeight;
            }
        }
    }
    catch(Exception ex)
    {
        System.Windows.Forms.MessageBox.Show("Error in Report-constructReport: " + ex.Message,"Project Error",System.Windows.Forms.MessageBoxButtons.OK,System.Windows.Forms.MessageBoxIcon.Error);
    }
}
  • Visual Basic
Private Sub constructReport()
    Try
        Me.Detail1.CanGrow = True
        Me.Detail1.CanShrink = True
        Me.Detail1.KeepTogether = True
        If m_useGroups = True Then
            Me.Sections.InsertGroupHF()

            CType(Me.Sections("GroupHeader1"), GroupHeader).DataField = "CategoryID"
            Me.Sections("GroupHeader1").BackColor = System.Drawing.Color.SlateBlue
            Me.Sections("GroupHeader1").CanGrow = True
            Me.Sections("GroupHeader1").CanShrink = True
            CType(Me.Sections("GroupHeader1"), GroupHeader).RepeatStyle = RepeatStyle.OnPageIncludeNoDetail
            Me.Sections("GroupHeader1").Height = 0

            Dim txt As New TextBox()
            txt.DataField = "CatagoryID"
            txt.Location = New System.Drawing.PointF(0.0F, 0)
            txt.Width = 2.0F
            txt.Height = 0.3F
            txt.Style = "font-weight: bold; font-size: 16pt"
            Me.Sections("GroupHeader1").Controls.Add(txt)
        End If
        For i = 0 To m_arrayFields.Count - 1
           If (m_useGroups = False) Or (m_useGroups AndAlso m_arrayFields(i).ToString <> "CategoryID") Then

                Dim lbl As New Label()
                lbl.Text = m_arrayFields(i) + ":"
                lbl.Location() = New System.Drawing.PointF(0.0F, m_currentY)
                lbl.Width() = 0.9F
                lbl.Height = m_defaultHeight
                Me.Detail1.Controls.Add(lbl)

                Dim txt As New TextBox()
                txt.DataField = m_arrayFields(i)
                txt.Location = New System.Drawing.PointF(1.0F, m_currentY)
                txt.Width = m_defaultWidth
                txt.Height = m_defaultHeight
                Me.Detail1.Controls.Add(txt)
                If m_arrayFields(i) = "UnitPrice" Then
                    txt.OutputFormat = "$#.00"
                End If
                m_currentY = m_currentY + m_defaultHeight
            End If
        Next
    Catch ex As Exception
        System.Windows.Forms.MessageBox.Show("Error in Report-constructReport: " + ex.Message, "Project Error", System.Windows.Forms.MessageBoxButtons.OK, System.Windows.Forms.MessageBoxIcon.Error)
    End Try
End Sub
See Also

Reference

SectionReport Class
SectionReport Members

Walkthroughs

Run Time Layouts


ShowParameterUI Property

ShowParameterUI Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ShowParameterUI Property
Sets or returns whether or not the query parameters dialog box will appear when the report is run.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShowParameterUI As System.Boolean
public System.bool ShowParameterUI {get; set;}
Remarks
Set this property to False if the report is a subreport that will take its parameter values from the parent report.
Example
  • C#
private void rptChild_ReportStart(object sender, System.EventArgs eArgs)
{
    this.ShowParameterUI = false;
}
  • Visual Basic
Private Sub rptChild_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.ShowParameterUI = False
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
ParameterUIClosed Event


State Property (SectionReport)

State Property (SectionReport)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : State Property
Returns the current state of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property State As SectionReport.ReportState
public SectionReport.ReportState State {get;}

Property Value

Current ReportState.
Remarks
The possible values for this property are Running, Idle, or Completed.
Example
  • C#
private void viewer1_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    this.statusBar1.Text = "Report is " + rpt.State.ToString();
    rpt.Run();
    this.statusBar1.Text = "Report is " + rpt.State.ToString();
    this.viewer1.Document = rpt.Document;
}
  • Visual Basic
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    Me.StatusBar1.Text = "Report is " & rpt.State.ToString
    rpt.Run()
    Me.StatusBar1.Text = "Report is " & rpt.State.ToString
    Me.Viewer1.Document = rpt.Document
End Sub
See Also

Reference

SectionReport Class
SectionReport Members


StyleSheet Property (SectionReport)

StyleSheet Property (SectionReport)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : StyleSheet Property
Returns a collection of formatting styles used to format controls in the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StyleSheet As StyleSheet
public StyleSheet StyleSheet {get; set;}

Property Value

Predefined default styles collection.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub
See Also

Reference

SectionReport Class
SectionReport Members
ActiveReports6~GrapeCity.ActiveReports.StyleSheet
ActiveReports6~GrapeCity.ActiveReports.Style


UserData Property

UserData Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : UserData Property

Sets or returns a user-defined value.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UserData As System.Object
public System.object UserData {get; set;}
Remarks

Values specified in this property are saved and loaded as part of the report layout. You can use this property to store information beyond what the report properties offer, much like the Tag property in Visual Basic. This property is only persisted as a string if the RPX is saved or loaded to file.

See Also

Reference

SectionReport Class
SectionReport Members


Version Property (SectionReport)

Version Property (SectionReport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Version Property
Returns the product's version number.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Version As System.String
public System.string Version {get;}
See Also

Reference

SectionReport Class
SectionReport Members


Watermark Property (SectionReport)

Watermark Property (SectionReport)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Watermark Property
Adds a specified image to the report's background. The watermark image can be positioned, sized, aligned and placed on specified pages by using the other watermark properties.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Watermark As Image
public Image Watermark {get; set;}

Property Value

Watermark image object. Default is null.
Remarks
Watermark properties must be specified before the report starts executing, preferably in the ReportStart event. The watermark will be clipped and centered on the page unless the WatermarkSizeMode and WatermarkAlignment are specified.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Watermark=System.Drawing.Image.FromFile ("C:\\DSCF2183.JPG");
    rpt.Run();
    this.arv.Document = rpt.Document;
}
  • Visual Basic
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    rpt.Watermark = System.Drawing.Image.FromFile("c:\DSCF2183.JPG")
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
WatermarkAlignment Property
WatermarkPrintOnPages Property
WatermarkSizeMode Property


WatermarkAlignment Property

WatermarkAlignment Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : WatermarkAlignment Property
Sets or returns the watermark's general vertical and horizontal position when it is added to the canvas.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WatermarkAlignment As PictureAlignment
public PictureAlignment WatermarkAlignment {get; set;}

Property Value

PictureAlignment enumeration. The default value is PictureAlignment.Center.

Remarks
The watermark properties should be specified in or before the ReportStart event.
Example
Paste into the Viewer Load event.
  • C#
SectionReport1 rpt = new SectionReport1();
    rpt.Watermark=System.Drawing.Image.FromFile ("C:\\DSCF2183.JPG");
    rpt.WatermarkAlignment = GrapeCity.ActiveReports.SectionReportModel.PictureAlignment.BottomRight;
    rpt.Run();
    this.arv.Document = rpt.Document;
Paste into the Viewer Load event.
  • Visual Basic
Dim rpt As New SectionReport1
    rpt.Watermark = System.Drawing.Image.FromFile("c:\DSCF2183.JPG")
    rpt.WatermarkAlignment = GrapeCity.ActiveReports.SectionReportModel.PictureAlignment.BottomRight
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
See Also

Reference

SectionReport Class
SectionReport Members
Watermark Property


WatermarkPrintOnPages Property

WatermarkPrintOnPages Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : WatermarkPrintOnPages Property
Sets or returns a value indicating the specific pages to which the watermark should be added.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WatermarkPrintOnPages As System.String
public System.string WatermarkPrintOnPages {get; set;}

Property Value

String representing page or page range on which the watermark will be printed. Default is an empty string (all pages).
Remarks
The syntax can include a single page, page range or a combination of both. For example: 1, 5-8, 9, 10-12.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Watermark=System.Drawing.Image.FromFile ("C:\\DSCF2183.JPG");
    rpt.WatermarkPrintOnPages = "1,3-5,7";
    rpt.Run();
    this.arv.Document = rpt.Document;
}
  • Visual Basic
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    rpt.Watermark = System.Drawing.Image.FromFile("c:\DSCF2183.JPG")
    rpt.WatermarkPrintOnPages = "1,3-5,7"
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
Watermark Property


WatermarkSizeMode Property

WatermarkSizeMode Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : WatermarkSizeMode Property
Sets or returns how the watermark will be sized when the image is rendered on the page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WatermarkSizeMode As SizeModes
public SizeModes WatermarkSizeMode {get; set;}

Property Value

SizeModes enumeration. The default value is SizeModes.Clip.

Remarks
Watermark properties should be specified in the ReportStart event.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Watermark = System.Drawing.Image.FromFile ("C:\\DSCF2183.JPG");
    rpt.WatermarkSizeMode = GrapeCity.ActiveReports.SectionReportModel.SizeModes.Zoom;
    rpt.Run();
    this.arv.Document = rpt.Document;
}
  • Visual Basic
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    rpt.Watermark = System.Drawing.Image.FromFile("c:\DSCF2183.JPG")
    rpt.WatermarkSizeMode = GrapeCity.ActiveReports.SectionReportModel.SizeModes.Zoom
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
ActiveReports6~GrapeCity.ActiveReports.SizeModes


SectionReport Class Events

SectionReport Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : SectionReport Class

For a list of all members of this type, see SectionReport members.

Public Events
 | Name | Description
Public Event | DataInitialize | Raised after the ReportStart event to allow the addition of custom fields to the report's fields collection.
Public Event | DataSourceChanged | Raised when the properties of the report's data source are modified.
Public Event | FetchData | Raised every time a new record is processed.
Public Event | NoData | Raised if the report's data source does not return any records and there is no data to be processed.
Public Event | PageEnd | Raised after the report finishes rendering each page.
Public Event | PageStart | Raised before the report renders any output to a new page.
Public Event | ParameterUIClosed | Raised after the user closes the query parameters dialog.
Public Event | PrintAborted | Raised when the user cancels a print job.
Public Event | PrintProgress | Raised for each page while printing the report document.
Public Event | ReportEnd | Raised after the report finishes processing all pages.
Public Event | ReportStart | Raised before a report starts processing.
Top
See Also

Reference

SectionReport Class
GrapeCity.ActiveReports Namespace


DataInitialize Event

DataInitialize Event
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : DataInitialize Event
Raised after the ReportStart event to allow the addition of custom fields to the report's fields collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DataInitialize As System.EventHandler
public event System.EventHandler DataInitialize
Remarks

Custom fields can be added to a bound report (one that uses the built-in data source to retrieve records) or an unbound report (one that does not depend on the data source to get its records).

In a bound report, the report's data source is initialized, opened and its fields are added to the Fields collection before the DataInitialize event is raised.

The DataInitialize event is raised only once unless you call the Restart() method.

Note: Do not reference the Fields collection outside the DataInitialize and FetchData events.

Example
  • C#
private void rptUnbound_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
}
  • Visual Basic
Private Sub rptUnbound_DataInitialize(ByVal sender As Object, ByVal e As _
    System.EventArgs) Handles MyBase.DataInitialize
    Fields.Add("CategoryName")
    Fields.Add("ProductName")
    Fields.Add("UnitsInStock")
    Fields.Add("Description")
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
FetchData Event
Fields Property
DataSource Property
ReportStart Event

Concepts

Sequence of Events


DataSourceChanged Event (SectionReport)

DataSourceChanged Event (SectionReport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : DataSourceChanged Event
Raised when the properties of the report's data source are modified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DataSourceChanged As System.EventHandler
public event System.EventHandler DataSourceChanged
See Also

Reference

SectionReport Class
SectionReport Members
DataSource Property


FetchData Event

FetchData Event
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : FetchData Event
Raised every time a new record is processed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event FetchData As SectionReport.FetchEventHandler
public event SectionReport.FetchEventHandler FetchData
Event Data

The event handler receives an argument of type SectionReport.FetchEventArgs containing data related to this event. The following SectionReport.FetchEventArgs properties provide information specific to this event.

Property | Description
EOF | This parameter is passed by reference and its default Value is True. It has to be explicitly set to False for the report to continue processing more records when the report is unbound. For bound reports, the EOF property is set automatically.
Remarks

This event is used to set the values of custom unbound fields that were added in the DataInitialize event.

ActiveReports does not null unbound field values before firing this event. The unbound field value is carried over so you should always set the values of all unbound fields in this event.

Note: Do not reference the Fields collection outside the DataInitialize and FetchData events.

Example
  • C#
private void rptUnbound_FetchData(object sender, GrapeCity.ActiveReports.ActiveReport.
    FetchEventArgs eArgs)
{
    try
    {
        m_reader.Read();
        Fields["CategoryName"].Value = m_reader["CategoryName"].ToString();
        Fields["ProductName"].Value = m_reader["ProductName"].ToString();
        Fields["UnitsInStock"].Value = m_reader["UnitsInStock"].ToString();
        Fields["Description"].Value = m_reader["Description"].ToString();
        eArgs.EOF = false;
    }
    catch
    {
        eArgs.EOF = true;
    }
}
  • Visual Basic
Private Sub rptUnbound_FetchData(ByVal sender As Object, ByVal eArgs As DataDynamics._
      ActiveReports.ActiveReport.FetchEventArgs) Handles MyBase.FetchData
      Try
          m_reader.Read()
          Me.Fields("CategoryName").Value = m_reader("CategoryName")
          Me.Fields("ProductName").Value = m_reader("ProductName")
          Me.Fields("UnitsInStock").Value = m_reader("UnitsInStock")
          Me.Fields("Description").Value = m_reader("Description")
          eArgs.EOF = False
          Catch ex As Exception
          eArgs.EOF = True
      End Try
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
DataInitialize Event

Concepts

Sequence of Events


NoData Event

NoData Event
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : NoData Event
Raised if the report's data source does not return any records and there is no data to be processed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event NoData As System.EventHandler
public event System.EventHandler NoData
Remarks
This event is used either to cancel the report or to print a page with a message informing the user that the report did not return any records to print.
Example
  • C#
private void SectionReport1_NoData(object sender, System.EventArgs eArgs)
{
    this.Cancel();
}
  • Visual Basic
Private Sub SectionReport1_NoData(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.NoData
    Me.Cancel()
End Sub
See Also

Reference

SectionReport Class
SectionReport Members


PageEnd Event

PageEnd Event
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : PageEnd Event
Raised after the report finishes rendering each page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PageEnd As System.EventHandler
public event System.EventHandler PageEnd
Remarks
This event is used to update any page level variables when running an unbound report.
Example
  • C#
private void rptTest_PageEnd(object sender, System.EventArgs eArgs)
{
    this.CurrentPage.DrawText("Confidential", 4F,10F,2F,0.188F);
}
  • Visual Basic
Private Sub rptDocument_PageEnd(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.PageEnd
    Me.CurrentPage.DrawText("Confidential", 4.0F, 10.0F, 2.0F, 0.188F)
End Sub
See Also

Reference

SectionReport Class
SectionReport Members


PageStart Event

PageStart Event
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : PageStart Event
Raised before the report renders any output to a new page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PageStart As System.EventHandler
public event System.EventHandler PageStart
Remarks
This event is used to initialize any page-level variables when running an unbound report.
Example
  • C#
bool bSwitch;
private void SectionReport1_PageStart(object sender, System.EventArgs eArgs)
{
    if (bSwitch == true)
    {
        this.PrintWidth = 6.5F;
        this.Document.Printer.Landscape = false;
    }
}
  • Visual Basic
' boolean to keep track of which orientation to use
Dim bSwitch As Boolean

Private Sub rptMain_PageStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.PageStart
    If bSwitch = True Then
        Me.PrintWidth = 6.5
        Me.Document.Printer.Landscape = False
    End If
End Sub
See Also

Reference

SectionReport Class
SectionReport Members


ParameterUIClosed Event

ParameterUIClosed Event
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ParameterUIClosed Event
Raised after the user closes the query parameters dialog.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ParameterUIClosed As SectionReport.ParameterUIClosedHandler
public event SectionReport.ParameterUIClosedHandler ParameterUIClosed
Example
  • C#
private void SectionReport1_ParameterUIClosed(object sender, bool Cancelled)
{
    System.Windows.Forms.MessageBox.Show ("Parameters sent.");
}
  • Visual Basic
Private Sub SectionReport1_ParameterUIClosed(ByVal sender As Object, ByVal cancelled As Boolean) Handles MyBase.ParameterUIClosed
    MessageBox.Show("Parameters set.")
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
ShowParameterUI Property


PrintAborted Event (SectionReport)

PrintAborted Event (SectionReport)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : PrintAborted Event
Raised when the user cancels a print job.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PrintAborted As System.EventHandler
public event System.EventHandler PrintAborted
Example
  • C#
private void SectionReport1_PrintAborted(object sender, System.EventArgs eArgs)
{
    System.Windows.Forms.MessageBox.Show("Printing has been aborted.");
}
  • Visual Basic
Private Sub SectionReport1_PrintAborted(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.PrintAborted
    MessageBox.Show("Printing has been aborted.")
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
PrintProgress Event


PrintProgress Event (SectionReport)

PrintProgress Event (SectionReport)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : PrintProgress Event
Raised for each page while printing the report document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PrintProgress As System.EventHandler
public event System.EventHandler PrintProgress
Example
This sample assumes that you have created a public property in the report and passed in a reference to the calling form. You can also use this technique to set the title bar text on the form window.
  • C#
private int x = 0;
private void testLA_PrintProgress(object sender, System.EventArgs eArgs)
{
    //Print Progress is triggered once per page printed.
    myWinForm.Label1.Text = "Now Printing Page " + x;
    x++;
}
  • Visual Basic
Private x As Integer = 0
Private Sub SectionReport1_PrintProgress(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.PrintProgress
    myWinForm.Label1.Text = "Now Printing Page " + x
    x = x + 1
End Sub
See Also

Reference

SectionReport Class
SectionReport Members
PrintAborted Event


ReportEnd Event

ReportEnd Event
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ReportEnd Event
Raised after the report finishes processing all pages.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ReportEnd As System.EventHandler
public event System.EventHandler ReportEnd
Remarks
This event can be used to close or free any objects that you were using while running a report in unbound mode, or to display an information message to the end user.
Example
  • C#
private void rptMain_ReportEnd(object sender, System.EventArgs eArgs)
{
    rptBookmarks rpt = new rptBookmarks();
    rpt.pBM = this.Document.Bookmarks;
    rpt.Run();
    this.Document.Pages.InsertRange(this.Document.Pages.Count, rpt.Document.Pages);
}
  • Visual Basic
Private Sub rptMain_ReportEnd(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportEnd
        Dim rpt As New rptBookmarks()
        rpt.pBM = Me.Document.Bookmarks
        rpt.Run()
        Me.Document.Pages.InsertRange(Me.Document.Pages.Count, rpt.Document.Pages)
End Sub
See Also

Reference

SectionReport Class
SectionReport Members


ReportStart Event

ReportStart Event
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : ReportStart Event
Raised before a report starts processing.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ReportStart As System.EventHandler
public event System.EventHandler ReportStart
Remarks

This event can be used to initialize any objects or variables that are needed while running a report.

Note: Printer values are set after this event is raised. The values that will be applied to the Printer object are in the PageSettings object. ReportStart is the event in which you can modify these values in the PageSettings object before they are applied to the Printer object.

Example
  • C#
private void rptUnbound_ReportStart(object sender, System.EventArgs eArgs)
{
    string m_cnnString = @"Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Users\[UserName]\Documents\GrapeCity Samples\ActiveReports 9\Data\NWIND.MDB;Persist Security Info=False";
    string sqlString = "SELECT * FROM categories INNER JOIN products ON categories.categoryid = products.categoryid ORDER BY products.categoryid, products.productid";
    m_cnn = new OleDbConnection(m_cnnString);
    OleDbCommand m_Cmd = new OleDbCommand(sqlString,m_cnn);
    if(m_cnn.State == ConnectionState.Closed)
    {
        m_cnn.Open();
    }
        m_reader = m_Cmd.ExecuteReader();
}
  • Visual Basic
Dim m_cnnString As String
Dim sqlString As String
Dim m_reader As OleDbDataReader
Dim m_cnn As OleDbConnection
Private Sub rptUnbound_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) _
    Handles MyBase.ReportStart
    m_cnnString =  "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Users\[UserName]\Documents\GrapeCity Samples\ActiveReports 9\Data\NWIND.MDB;Persist Security Info=False"
    sqlString = "Select * FROM categories INNER JOIN products On categories.categoryid _
        = products.categoryid ORDER BY products.categoryid, products.productid"
    m_cnn = New OleDb.OleDbConnection(m_cnnString)
    Dim m_Cmd As New OleDb.OleDbCommand(sqlString, m_cnn)
    If m_cnn.State = ConnectionState.Closed Then
        m_cnn.Open()
    End If
    m_reader = m_Cmd.ExecuteReader()
End Sub
See Also

Reference

SectionReport Class
SectionReport Members


SectionReport.FetchEventArgs Class

SectionReport.FetchEventArgs Class
Members Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : SectionReport.FetchEventArgs Class
FetchEventArgs class provides data required for the FetchData Event.
Object Model
SectionReport.FetchEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class SectionReport.FetchEventArgs
   Inherits System.EventArgs
public class SectionReport.FetchEventArgs : System.EventArgs
Example
  • C#
private void rptUnbound_FetchData(object sender, GrapeCity.ActiveReports.ActiveReport.
    FetchEventArgs eArgs)
{
    try
    {
        m_reader.Read();
        Fields["CategoryName"].Value = m_reader["CategoryName"].ToString();
        Fields["ProductName"].Value = m_reader["ProductName"].ToString();
        Fields["UnitsInStock"].Value = m_reader["UnitsInStock"].ToString();
        Fields["Description"].Value = m_reader["Description"].ToString();
        eArgs.EOF = false;
    }
    catch
    {
        eArgs.EOF = true;
    }
}
  • Visual Basic
Private Sub rptUnbound_FetchData(ByVal sender As Object, ByVal eArgs As DataDynamics._
      ActiveReports.ActiveReport.FetchEventArgs) Handles MyBase.FetchData
      Try
          m_reader.Read()
          Me.Fields("CategoryName").Value = m_reader("CategoryName")
          Me.Fields("ProductName").Value = m_reader("ProductName")
          Me.Fields("UnitsInStock").Value = m_reader("UnitsInStock")
          Me.Fields("Description").Value = m_reader("Description")
          eArgs.EOF = False
          Catch ex As Exception
          eArgs.EOF = True
      End Try
End Sub
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.SectionReport.FetchEventArgs

See Also

Reference

SectionReport.FetchEventArgs Members
GrapeCity.ActiveReports Namespace
FetchData Event
SectionReport.FetchEventHandler Delegate


SectionReport.FetchEventArgs Class Members

SectionReport.FetchEventArgs Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : SectionReport.FetchEventArgs Class

The following tables list the members exposed by SectionReport.FetchEventArgs.

Public Constructors
 | Name | Description
Public Constructor | SectionReport.FetchEventArgs Constructor | Creates a new SectionReport.FetchEventArgs instance.
Top
Public Properties
 | Name | Description
Public Property | EOF | This parameter is passed by reference and its default Value is True. It has to be explicitly set to False for the report to continue processing more records when the report is unbound. For bound reports, the EOF property is set automatically.
Top
See Also

Reference

SectionReport.FetchEventArgs Class
GrapeCity.ActiveReports Namespace
FetchData Event
SectionReport.FetchEventHandler Delegate


SectionReport.FetchEventArgs Constructor

SectionReport.FetchEventArgs Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport.FetchEventArgs Class : SectionReport.FetchEventArgs Constructor
End Of Fields as a Boolean value.
Creates a new SectionReport.FetchEventArgs instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal eof As System.Boolean _
)
public SectionReport.FetchEventArgs(
   System.bool eof
)

Parameters

eof
End Of Fields as a Boolean value.
See Also

Reference

SectionReport.FetchEventArgs Class
SectionReport.FetchEventArgs Members


SectionReport.FetchEventArgs Class Properties

SectionReport.FetchEventArgs Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : SectionReport.FetchEventArgs Class

For a list of all members of this type, see SectionReport.FetchEventArgs members.

Public Properties
 | Name | Description
Public Property | EOF | This parameter is passed by reference and its default Value is True. It has to be explicitly set to False for the report to continue processing more records when the report is unbound. For bound reports, the EOF property is set automatically.
Top
See Also

Reference

SectionReport.FetchEventArgs Class
GrapeCity.ActiveReports Namespace
FetchData Event
SectionReport.FetchEventHandler Delegate


EOF Property (SectionReport.FetchEventArgs)

EOF Property (SectionReport.FetchEventArgs)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport.FetchEventArgs Class : EOF Property

This parameter is passed by reference and its default Value is True. It has to be explicitly set to False for the report to continue processing more records when the report is unbound. For bound reports, the EOF property is set automatically.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EOF As System.Boolean
public System.bool EOF {get; set;}
Example
  • C#
private void rptUnbound_FetchData(object sender, GrapeCity.ActiveReports.ActiveReport.
    FetchEventArgs eArgs)
{
    try
    {
        m_reader.Read();
        Fields["CategoryName"].Value = m_reader["CategoryName"].ToString();
        Fields["ProductName"].Value = m_reader["ProductName"].ToString();
        Fields["UnitsInStock"].Value = m_reader["UnitsInStock"].ToString();
        Fields["Description"].Value = m_reader["Description"].ToString();
        eArgs.EOF = false;
    }
    catch
    {
        eArgs.EOF = true;
    }
}
  • Visual Basic
Private Sub rptUnbound_FetchData(ByVal sender As Object, ByVal eArgs As DataDynamics._
      ActiveReports.ActiveReport.FetchEventArgs) Handles MyBase.FetchData
      Try
          m_reader.Read()
          Me.Fields("CategoryName").Value = m_reader("CategoryName")
          Me.Fields("ProductName").Value = m_reader("ProductName")
          Me.Fields("UnitsInStock").Value = m_reader("UnitsInStock")
          Me.Fields("Description").Value = m_reader("Description")
          eArgs.EOF = False
          Catch ex As Exception
          eArgs.EOF = True
      End Try
End Sub
See Also

Reference

SectionReport.FetchEventArgs Class
SectionReport.FetchEventArgs Members


SystemPrinter Class

SystemPrinter Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : SystemPrinter Class
Represents the settings of the SystemPrinter class.
Object Model
SystemPrinter Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class SystemPrinter
public sealed class SystemPrinter
Remarks
Allows the developer to manually control report printing.
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SystemPrinter

See Also

Reference

SystemPrinter Members
GrapeCity.ActiveReports Namespace


SystemPrinter Class Members

SystemPrinter Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : SystemPrinter Class

The following tables list the members exposed by SystemPrinter.

Public Constructors
 | Name | Description
Public Constructor | SystemPrinter Constructor | Initializes a new instance of the SystemPrinter class.
Top
Public Properties
 | Name | Description
Public Property | CanDuplex | Determines whether or not the report can be duplexed while printing.
Public Property | Collate | Determines whether all the pages of the report should be printed before another copy of the report.
Public Property | Color | Determines whether or not the report will print in color.
Public Property | Copies | Determines the number of copies to print.
Public Property | DpiX | Gets the horizontal resolution of the SystemPrinter object.
Public Property | DpiY | Gets the vertical resolution of the SystemPrinter object.
Public Property | Duplex | Gets or sets the report document setting for double-sided printing.
Public Property | FileName | Gets or sets the file name used to print to a file.
Public Property | FromPage | Sets the starting page in a print job.
Public Property | Graphics | Draws the page to the printer.
Public Property | Landscape | Determines whether or not the report will be landscaped for printing.
Public Property | MaxPage | Sets the total page count in the progress dialog when doing custom printing.
Public Property | PaperHeight | Gets or sets the paper height for printing.
Public Property | PaperSize | Gets or sets the paper size for the page.
Public Property | PaperSizes | Returns a reference to the collection of paper sizes the printer supports.
Public Property | PaperSource | Gets or sets the paper source for the page.
Public Property | PaperSources | Returns a reference to the collection of paper sources the printer supports.
Public Property | PaperWidth | Sets or returns the width of the paper used to print the report.
Public Property | PhysicalOffsetX | Returns the measurement in pixels of the non-printable section on the left side of the page.
Public Property | PhysicalOffsetY | Returns the measurement in pixels of the non-printable section at the top of the page.
Public Property | Port | Gets or sets the current printer port.
Public Property | Ports | Returns the collection of printer ports available.
Public Property | PrinterName | Gets or sets the name of the printer to use.
Public Property | PrinterNames | Returns the collection of printer names available.
Public Property | PrinterResolution | Gets or sets the printer resolution for the page.
Public Property | PrinterResolutions | Returns a collection of the available printer resolutions.
Public Property | PrinterSettings | Gets or sets the printer settings associated with the page.
Public Property | ToPage | Sets the number of the last page to be printed.
Top
Public Methods
 | Name | Description
Public Method | AbortJob | Aborts the SystemPrinter print job initialized by the StartJob method.
Public Method | EndJob | Ends the SystemPrinter print job initialized by the StartJob method.
Public Method | EndPage | Ends a specific page in a SystemPrinter print job initialized by the StartPage method.
Public Method | Escape | Allows escape codes to be entered.
Public Method | PrintDialog | Shows a SystemPrinter print dialog.
Public Method | SetupDialog | Shows a SystemPrinter setup dialog.
Public Method | StartJob | Starts a SystemPrinter print job.
Public Method | StartPage | Starts a specific page in a SystemPrinter print job.
Top
See Also

Reference

SystemPrinter Class
GrapeCity.ActiveReports Namespace


SystemPrinter Constructor

SystemPrinter Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : SystemPrinter Constructor
Initializes a new instance of the SystemPrinter class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public SystemPrinter()
See Also

Reference

SystemPrinter Class
SystemPrinter Members


SystemPrinter Class Methods

SystemPrinter Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : SystemPrinter Class

For a list of all members of this type, see SystemPrinter members.

Public Methods
 | Name | Description
Public Method | AbortJob | Aborts the SystemPrinter print job initialized by the StartJob method.
Public Method | EndJob | Ends the SystemPrinter print job initialized by the StartJob method.
Public Method | EndPage | Ends a specific page in a SystemPrinter print job initialized by the StartPage method.
Public Method | Escape | Allows escape codes to be entered.
Public Method | PrintDialog | Shows a SystemPrinter print dialog.
Public Method | SetupDialog | Shows a SystemPrinter setup dialog.
Public Method | StartJob | Starts a SystemPrinter print job.
Public Method | StartPage | Starts a specific page in a SystemPrinter print job.
Top
See Also

Reference

SystemPrinter Class
GrapeCity.ActiveReports Namespace


AbortJob Method

AbortJob Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : AbortJob Method
Aborts the SystemPrinter print job initialized by the StartJob method.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AbortJob()
public void AbortJob()
See Also

Reference

SystemPrinter Class
SystemPrinter Members


EndJob Method

EndJob Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : EndJob Method
Ends the SystemPrinter print job initialized by the StartJob method.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub EndJob()
public void EndJob()
See Also

Reference

SystemPrinter Class
SystemPrinter Members


EndPage Method

EndPage Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : EndPage Method
Ends a specific page in a SystemPrinter print job initialized by the StartPage method.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub EndPage()
public void EndPage()
See Also

Reference

SystemPrinter Class
SystemPrinter Members


Escape Method

Escape Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : Escape Method
The escape code being entered.
Allows escape codes to be entered.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Escape( _
   ByVal code As System.String _
)
public void Escape(
   System.string code
)

Parameters

code
The escape code being entered.
Remarks
Escape codes are specific to the printer being used. For a list of escape codes, see the documentation for the printer.
Example
  • C#
private void Form1_Load(object sender, System.EventArgs e)
{
    if((openFileDialog1.ShowDialog(this) == DialogResult.OK))
    {
        this.viewer1.Document.Password = "Test";
        viewer1.Document.Load(openFileDialog1.OpenFile());
        Escape("&1 OH"); //page eject code for certain printer (see manual for printer's sequences)
    }
}

public void Escape(string code)
{
    //code is the escape sequence from the printer's manual
    m_myARPrinter.StartJob("Test Printer");
    m_myARPrinter.Graphics.PageUnit = GraphicsUnit.Pixel;

    GrapeCity.ActiveReports.Document.Section.Page aPage;
    int nCount;
    nCount = this.viewer1.Document.Pages.Count;
    RectangleF rcPage;
    rcPage = RectangleF.Empty;
    for (int i = 0; i <= nCount - 1; i++)
    {
        m_myARPrinter.Escape(code);
        m_myARPrinter.StartPage();
        aPage = viewer1.Document.Pages[i];
        aPage.Units = GrapeCity.ActiveReports.Document.Section.Units.Pixels;
        rcPage.Width = aPage.Width;
        rcPage.Height = aPage.Height;
        aPage.Draw(m_myARPrinter.Graphics, rcPage);
        m_myARPrinter.EndPage();
    }
    m_myARPrinter.EndJob();
}
  • Visual Basic
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    If (OpenFileDialog.ShowDialog(Me) = DialogResult.OK) Then
        Viewer1.Document.Password = "Test"
        Viewer1.Document.Load(OpenFileDialog.OpenFile())
        Escape("&l  0H") 'page eject code for certain printer (see manual for printer's sequences)
    End If
End Sub

Public Sub Escape(ByVal code As String) 'code is the escape sequence from the printer's manual
    m_myARPrinter.StartJob("Test Printer")
    m_myARPrinter.Graphics.PageUnit = GraphicsUnit.Pixel

    Dim aPage As GrapeCity.ActiveReports.Document.Section.Page
    Dim nCount As Integer
    nCount = Viewer1.Document.Pages.Count
    Dim rcPage As RectangleF
    rcPage = RectangleF.Empty
    For int i = 0 To nCount - 1
        m_myARPrinter.Escape(code)
        m_myARPrinter.StartPage()
        aPage = Viewer1.Document.Pages(i)
        aPage.Units = GrapeCity.ActiveReports.Document.Section.Units.Pixels
        rcPage.Width = aPage.Width
        rcPage.Height = aPage.Height
        aPage.Draw(m_myARPrinter.Graphics, rcPage)
        m_myARPrinter.EndPage()
    Next
    m_myARPrinter.EndJob()
End Sub
See Also

Reference

SystemPrinter Class
SystemPrinter Members


PrintDialog Method

PrintDialog Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PrintDialog Method
Shows a SystemPrinter print dialog.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PrintDialog() As System.Windows.Forms.DialogResult
public System.Windows.Forms.DialogResult PrintDialog()
See Also

Reference

SystemPrinter Class
SystemPrinter Members


SetupDialog Method

SetupDialog Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : SetupDialog Method
Shows a SystemPrinter setup dialog.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetupDialog()
public void SetupDialog()
See Also

Reference

SystemPrinter Class
SystemPrinter Members


StartJob Method

StartJob Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : StartJob Method
The job being printed.
Starts a SystemPrinter print job.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub StartJob( _
   ByVal printJob As System.String _
)
public void StartJob(
   System.string printJob
)

Parameters

printJob
The job being printed.
See Also

Reference

SystemPrinter Class
SystemPrinter Members


StartPage Method

StartPage Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : StartPage Method
Starts a specific page in a SystemPrinter print job.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub StartPage()
public void StartPage()
See Also

Reference

SystemPrinter Class
SystemPrinter Members


SystemPrinter Class Properties

SystemPrinter Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : SystemPrinter Class

For a list of all members of this type, see SystemPrinter members.

Public Properties
 | Name | Description
Public Property | CanDuplex | Determines whether or not the report can be duplexed while printing.
Public Property | Collate | Determines whether all the pages of the report should be printed before another copy of the report.
Public Property | Color | Determines whether or not the report will print in color.
Public Property | Copies | Determines the number of copies to print.
Public Property | DpiX | Gets the horizontal resolution of the SystemPrinter object.
Public Property | DpiY | Gets the vertical resolution of the SystemPrinter object.
Public Property | Duplex | Gets or sets the report document setting for double-sided printing.
Public Property | FileName | Gets or sets the file name used to print to a file.
Public Property | FromPage | Sets the starting page in a print job.
Public Property | Graphics | Draws the page to the printer.
Public Property | Landscape | Determines whether or not the report will be landscaped for printing.
Public Property | MaxPage | Sets the total page count in the progress dialog when doing custom printing.
Public Property | PaperHeight | Gets or sets the paper height for printing.
Public Property | PaperSize | Gets or sets the paper size for the page.
Public Property | PaperSizes | Returns a reference to the collection of paper sizes the printer supports.
Public Property | PaperSource | Gets or sets the paper source for the page.
Public Property | PaperSources | Returns a reference to the collection of paper sources the printer supports.
Public Property | PaperWidth | Sets or returns the width of the paper used to print the report.
Public Property | PhysicalOffsetX | Returns the measurement in pixels of the non-printable section on the left side of the page.
Public Property | PhysicalOffsetY | Returns the measurement in pixels of the non-printable section at the top of the page.
Public Property | Port | Gets or sets the current printer port.
Public Property | Ports | Returns the collection of printer ports available.
Public Property | PrinterName | Gets or sets the name of the printer to use.
Public Property | PrinterNames | Returns the collection of printer names available.
Public Property | PrinterResolution | Gets or sets the printer resolution for the page.
Public Property | PrinterResolutions | Returns a collection of the available printer resolutions.
Public Property | PrinterSettings | Gets or sets the printer settings associated with the page.
Public Property | ToPage | Sets the number of the last page to be printed.
Top
See Also

Reference

SystemPrinter Class
GrapeCity.ActiveReports Namespace


CanDuplex Property

CanDuplex Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : CanDuplex Property
Determines whether or not the report can be duplexed while printing.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CanDuplex As System.Boolean
public System.bool CanDuplex {get;}

Property Value

Boolean value. True, if the report can be duplexed; otherwise, false.
See Also

Reference

SystemPrinter Class
SystemPrinter Members


Collate Property (SystemPrinter)

Collate Property (SystemPrinter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : Collate Property
Determines whether all the pages of the report should be printed before another copy of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Collate As System.Boolean
public System.bool Collate {get; set;}

Property Value

A Boolean value. True if a complete copy of the report should be printed before another copy begins printing; otherwise, false.
See Also

Reference

SystemPrinter Class
SystemPrinter Members


Color Property (SystemPrinter)

Color Property (SystemPrinter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : Color Property
Determines whether or not the report will print in color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Color As System.Boolean
public System.bool Color {get; set;}

Property Value

Boolean value. True, if the report will print in color; otherwise, false.
See Also

Reference

SystemPrinter Class
SystemPrinter Members


Copies Property

Copies Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : Copies Property
Determines the number of copies to print.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Copies As System.Short
public System.short Copies {get; set;}

Property Value

Short value.
See Also

Reference

SystemPrinter Class
SystemPrinter Members


DpiX Property (SystemPrinter)

DpiX Property (SystemPrinter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : DpiX Property
Gets the horizontal resolution of the SystemPrinter object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DpiX As System.Integer
public System.int DpiX {get;}

Property Value

An integer value in pixels.
Remarks
Read only.
See Also

Reference

SystemPrinter Class
SystemPrinter Members


DpiY Property (SystemPrinter)

DpiY Property (SystemPrinter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : DpiY Property
Gets the vertical resolution of the SystemPrinter object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DpiY As System.Integer
public System.int DpiY {get;}

Property Value

An integer value in pixels.
Remarks
Read only.
See Also

Reference

SystemPrinter Class
SystemPrinter Members


Duplex Property (SystemPrinter)

Duplex Property (SystemPrinter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : Duplex Property
Gets or sets the report document setting for double-sided printing.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Duplex As System.Drawing.Printing.Duplex
public System.Drawing.Printing.Duplex Duplex {get; set;}

Property Value

A System.Drawing.Duplex enumeration value. Default is determined by System.Drawing.Printing.Duplex.Default.
See Also

Reference

SystemPrinter Class
SystemPrinter Members


FileName Property (SystemPrinter)

FileName Property (SystemPrinter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : FileName Property
Gets or sets the file name used to print to a file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FileName As System.String
public System.string FileName {get; set;}
See Also

Reference

SystemPrinter Class
SystemPrinter Members


FromPage Property

FromPage Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : FromPage Property
Sets the starting page in a print job.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FromPage As System.Integer
public System.int FromPage {get; set;}

Property Value

Long value.
See Also

Reference

SystemPrinter Class
SystemPrinter Members


Graphics Property

Graphics Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : Graphics Property

Draws the page to the printer.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Graphics As Graphics
public Graphics Graphics {get;}
Remarks
This property is valid only after the StartJob event is called.
See Also

Reference

SystemPrinter Class
SystemPrinter Members


Landscape Property (SystemPrinter)

Landscape Property (SystemPrinter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : Landscape Property
Determines whether or not the report will be landscaped for printing.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Landscape As System.Boolean
public System.bool Landscape {get; set;}

Property Value

Boolean value. True, if the report will be landscaped; otherwise, false.
See Also

Reference

SystemPrinter Class
SystemPrinter Members


MaxPage Property

MaxPage Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : MaxPage Property
Sets the total page count in the progress dialog when doing custom printing.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaxPage As System.Integer
public System.int MaxPage {get; set;}
See Also

Reference

SystemPrinter Class
SystemPrinter Members


PaperHeight Property (SystemPrinter)

PaperHeight Property (SystemPrinter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PaperHeight Property
Gets or sets the paper height for printing.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaperHeight As System.Single
public System.float PaperHeight {get; set;}

Property Value

A float or Single value in inches.
Remarks
This property is used to set custom paper sizes that might not be available in the PaperSizes collection.
See Also

Reference

SystemPrinter Class
SystemPrinter Members


PaperSize Property (SystemPrinter)

PaperSize Property (SystemPrinter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PaperSize Property
Gets or sets the paper size for the page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaperSize As System.Drawing.Printing.PaperSize
public System.Drawing.Printing.PaperSize PaperSize {get; set;}

Property Value

System.Drawing.Printing.PaperSize
See Also

Reference

SystemPrinter Class
SystemPrinter Members


PaperSizes Property (SystemPrinter)

PaperSizes Property (SystemPrinter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PaperSizes Property
Returns a reference to the collection of paper sizes the printer supports.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PaperSizes As System.Drawing.Printing.PrinterSettings.PaperSizeCollection
public System.Drawing.Printing.PrinterSettings.PaperSizeCollection PaperSizes {get;}
Remarks
Read only.
See Also

Reference

SystemPrinter Class
SystemPrinter Members


PaperSource Property (SystemPrinter)

PaperSource Property (SystemPrinter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PaperSource Property
Gets or sets the paper source for the page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaperSource As System.Drawing.Printing.PaperSource
public System.Drawing.Printing.PaperSource PaperSource {get; set;}
See Also

Reference

SystemPrinter Class
SystemPrinter Members


PaperSources Property

PaperSources Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PaperSources Property
Returns a reference to the collection of paper sources the printer supports.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PaperSources As System.Drawing.Printing.PrinterSettings.PaperSourceCollection
public System.Drawing.Printing.PrinterSettings.PaperSourceCollection PaperSources {get;}
Remarks
Read only.
See Also

Reference

SystemPrinter Class
SystemPrinter Members


PaperWidth Property (SystemPrinter)

PaperWidth Property (SystemPrinter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PaperWidth Property
Sets or returns the width of the paper used to print the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaperWidth As System.Single
public System.float PaperWidth {get; set;}

Property Value

A float or Single value in inches.
Remarks
This property is used to set custom paper sizes that might not be available in the PaperSizes collection.
See Also

Reference

SystemPrinter Class
SystemPrinter Members


PhysicalOffsetX Property

PhysicalOffsetX Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PhysicalOffsetX Property
Returns the measurement in pixels of the non-printable section on the left side of the page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PhysicalOffsetX As System.Long
public System.long PhysicalOffsetX {get;}

Property Value

An integer value in pixels.
See Also

Reference

SystemPrinter Class
SystemPrinter Members


PhysicalOffsetY Property

PhysicalOffsetY Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PhysicalOffsetY Property
Returns the measurement in pixels of the non-printable section at the top of the page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PhysicalOffsetY As System.Long
public System.long PhysicalOffsetY {get;}

Property Value

An integer value in pixels.
See Also

Reference

SystemPrinter Class
SystemPrinter Members


Port Property

Port Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : Port Property
Gets or sets the current printer port.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Port As System.String
public System.string Port {get; set;}
See Also

Reference

SystemPrinter Class
SystemPrinter Members


Ports Property

Ports Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : Ports Property
Returns the collection of printer ports available.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Ports As System.Collections.Specialized.StringCollection
public System.Collections.Specialized.StringCollection Ports {get;}
Remarks
Read only.
See Also

Reference

SystemPrinter Class
SystemPrinter Members


PrinterName Property (SystemPrinter)

PrinterName Property (SystemPrinter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PrinterName Property
Gets or sets the name of the printer to use.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrinterName As System.String
public System.string PrinterName {get; set;}
See Also

Reference

SystemPrinter Class
SystemPrinter Members


PrinterNames Property

PrinterNames Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PrinterNames Property
Returns the collection of printer names available.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PrinterNames As System.Drawing.Printing.PrinterSettings.StringCollection
public System.Drawing.Printing.PrinterSettings.StringCollection PrinterNames {get;}
Remarks
Read only.
See Also

Reference

SystemPrinter Class
SystemPrinter Members


PrinterResolution Property

PrinterResolution Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PrinterResolution Property
Gets or sets the printer resolution for the page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrinterResolution As System.Drawing.Printing.PrinterResolution
public System.Drawing.Printing.PrinterResolution PrinterResolution {get; set;}

Property Value

System.Drawing.Printing.PrinterResolution
See Also

Reference

SystemPrinter Class
SystemPrinter Members


PrinterResolutions Property

PrinterResolutions Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PrinterResolutions Property
Returns a collection of the available printer resolutions.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PrinterResolutions As System.Drawing.Printing.PrinterSettings.PrinterResolutionCollection
public System.Drawing.Printing.PrinterSettings.PrinterResolutionCollection PrinterResolutions {get;}
Remarks
Read only.
See Also

Reference

SystemPrinter Class
SystemPrinter Members


PrinterSettings Property (SystemPrinter)

PrinterSettings Property (SystemPrinter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : PrinterSettings Property
Gets or sets the printer settings associated with the page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PrinterSettings As System.Drawing.Printing.PrinterSettings
public System.Drawing.Printing.PrinterSettings PrinterSettings {get;}
See Also

Reference

SystemPrinter Class
SystemPrinter Members


ToPage Property

ToPage Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SystemPrinter Class : ToPage Property
Sets the number of the last page to be printed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ToPage As System.Integer
public System.int ToPage {get; set;}
See Also

Reference

SystemPrinter Class
SystemPrinter Members


LayoutAction Enumeration

LayoutAction Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : LayoutAction Enumeration
Specifies the action to be performed after a section is formatted.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LayoutAction
   Inherits System.Enum
public enum LayoutAction : System.Enum
Members
Member | Description
MoveLayout | The layout position will move to the next printing location on the page.
NextRecord | The data navigation will advance to the next record.
PrintSection | The section will be printed.
Remarks

The following table shows the results for setting different LayoutAction combinations.

PrintSection | MoveLayout | NextRecord | (Default) Move to the next print location, get the next record, and print data.
PrintSection | MoveLayout | Move to the next print location, don't advance to the next record, but print the data (repeats the same record).
NextRecord | Skip a record without leaving a blank space on the page.
MoveLayout | NextRecord | Skip a record and leave a blank space on the page.
MoveLayout | Leave a blank space without skipping a record.
PrintSection | NextRecord | Print the next record on top of the current record (UnderlayNext).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.LayoutAction

See Also

Reference

GrapeCity.ActiveReports Namespace
GrapeCity.ActiveReports.v10~GrapeCity.ActiveReports~LayoutAction


PageSettings.PrinterCollate Enumeration

PageSettings.PrinterCollate Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : PageSettings.PrinterCollate Enumeration
Determines the collation order when printing multiple copies of a report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PageSettings.PrinterCollate
   Inherits System.Enum
public enum PageSettings.PrinterCollate : System.Enum
Members
Member | Description
Collate | Print a complete copy of the document before starting another copy.
Default | Use the current printer collate settings.
DontCollate | Prints each page by the number of the copies specified before printing the next page.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageSettings.PrinterCollate

See Also

Reference

GrapeCity.ActiveReports Namespace
Collate Property


ReportProcessingError Enumeration

ReportProcessingError Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : ReportProcessingError Enumeration
Describe possible error codes for future detail processing of the error.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ReportProcessingError
   Inherits System.Enum
public enum ReportProcessingError : System.Enum
Members
Member | Description
BlankValueAssignedToNonBlankParameter | Parameters validation error: ReportException.ErrorData provides name of the parameter.
CyclicParameter | Cyclic dependencies in parameters: ReportException.ErrorData provides name of the parameter.
InfinitePages | Internal loop in pages processing observed.
InternalError | Just internal error.
InvalidData | Invalid data or cannot access to date with current configuration.
InvalidDataTypeForParameter | Parameters validation error: ReportException.ErrorData provides name of the parameter.
InvalidQueryParameters | Cannot parse/process data set query parameters.
InvalidReport | Something wrong in report structure.
InvalidSharedDataSource | No assess to shared data source: ReportException.ErrorData provides name of the data source.
InvalidTheme | Invalid theme was specified.
NoMasterReport | No master report was found.
NoPermission | DB assess error.
NullValueAssignedToNonNullableParameter | Parameters validation error: ReportException.ErrorData provides name of the parameter.
ParameterValueIsNotValid | Parameters validation error: ReportException.ErrorData provides name of the parameter.
ScriptCompilationFailed | Describe script compilation problem: ReportException.ErrorData provides errors array.
ScriptError | Describe script execution problem.
SubreportNotFound | Subreport not found.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.ReportProcessingError

See Also

Reference

GrapeCity.ActiveReports Namespace


SectionReport.ReportState Enumeration

SectionReport.ReportState Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : SectionReport.ReportState Enumeration
Determines the current state of the report engine.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum SectionReport.ReportState
   Inherits System.Enum
public enum SectionReport.ReportState : System.Enum
Members
Member | Description
Completed | The report processing is complete.
Idle | The report processing is idle.
InProgress | The report is currently being processed to create a document.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReport.ReportState

See Also

Reference

GrapeCity.ActiveReports Namespace
GrapeCity.ActiveReports.v10~GrapeCity.ActiveReports.SectionReportModel~State


SectionReport.RpxFormat Enumeration

SectionReport.RpxFormat Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : SectionReport.RpxFormat Enumeration
Specifies the format in which the report is to be saved.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum SectionReport.RpxFormat
   Inherits System.Enum
public enum SectionReport.RpxFormat : System.Enum
Members
Member | Description
Arnet | Saves the layout as a standard RPX file. Items in the component tray are not saved.
Arnet3 | Allows for the components in the component tray to be saved in the RPX file.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReport.RpxFormat

See Also

Reference

GrapeCity.ActiveReports Namespace


LocateCredentialsEventHandler Delegate

LocateCredentialsEventHandler Delegate

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : LocateCredentialsEventHandler Delegate
The source of the event.
LocateCredentials object that contains event data.
Represents method that handles LocateCredentials event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub LocateCredentialsEventHandler( _
   ByVal sender As System.Object, _
   ByVal args As LocateCredentialsEventArgs _
)
public delegate void LocateCredentialsEventHandler(
   System.object sender,
   LocateCredentialsEventArgs args
)

Parameters

sender
The source of the event.
args
LocateCredentials object that contains event data.
See Also

Reference

LocateCredentialsEventHandler Members
GrapeCity.ActiveReports Namespace


LocateDataSourceEventHandler Delegate

LocateDataSourceEventHandler Delegate

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : LocateDataSourceEventHandler Delegate
The sender of the event.
The LocateDataSourceEventArgs that contains the LocateDataSource event class.
Represents the method that will handle the LocateDataSource event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub LocateDataSourceEventHandler( _
   ByVal sender As System.Object, _
   ByVal args As LocateDataSourceEventArgs _
)
public delegate void LocateDataSourceEventHandler(
   System.object sender,
   LocateDataSourceEventArgs args
)

Parameters

sender
The sender of the event.
args
The LocateDataSourceEventArgs that contains the LocateDataSource event class.
See Also

Reference

LocateDataSourceEventHandler Members
GrapeCity.ActiveReports Namespace


SectionReport.FetchEventHandler Delegate

SectionReport.FetchEventHandler Delegate

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : SectionReport.FetchEventHandler Delegate
The source of the event.
FetchEventArgs that contains the event data

Represents the method that handles the FetchData event.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub SectionReport.FetchEventHandler( _
   ByVal sender As System.Object, _
   ByVal eArgs As SectionReport.FetchEventArgs _
)
public delegate void SectionReport.FetchEventHandler(
   System.object sender,
   SectionReport.FetchEventArgs eArgs
)

Parameters

sender
The source of the event.
eArgs
FetchEventArgs that contains the event data
See Also

Reference

SectionReport.FetchEventHandler Members
GrapeCity.ActiveReports Namespace


SectionReport.ParameterUIClosedHandler Delegate

SectionReport.ParameterUIClosedHandler Delegate

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : SectionReport.ParameterUIClosedHandler Delegate
The source of the event.
Value indicates whether the parameters dialog was closed by using Cancel button.
Represents a method that handles the ParameterUIClosed event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub SectionReport.ParameterUIClosedHandler( _
   ByVal sender As System.Object, _
   ByVal cancelled As System.Boolean _
)
public delegate void SectionReport.ParameterUIClosedHandler(
   System.object sender,
   System.bool cancelled
)

Parameters

sender
The source of the event.
cancelled
Value indicates whether the parameters dialog was closed by using Cancel button.
See Also

Reference

SectionReport.ParameterUIClosedHandler Members
GrapeCity.ActiveReports Namespace


GrapeCity.ActiveReports.Configuration Namespace

GrapeCity.ActiveReports.Configuration Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports.Configuration Namespace
The GrapeCity.ActiveReports.Configuration namespace consists of classes that configure the report.
Classes
 | Class | Description
Class | CustomDesignerConfigurationDictionary | Represents a dictionary of custom designers configured for components.
Class | DefaultConfigurationProvider | Implements an IConfigurationProvider that gets configuration information from a file in the executable directory.
Class | PropertyElement | Represents a property configuration option for the associated export extension.
Class | RenderingExtensionInfo | Class containing rendering extension information.
Class | RenderingExtensionInfoCollection | Represents a collection of RenderingExtensionInfo.
Class | ReportItemsConfigurationDictionary | A dictionary of CustomReportItem type names and their corresponding System.Type.
Class | ToolboxItemConfig | Represents an entry for a toolbox configuration item.
Interfaces
 | Interface | Description
Interface | IConfigurationManager | Defines an interface to allow access to configuration information.
Interface | IConfigurationProvider | Defines interface for providing raw configuration information.
Delegates
 | Delegate | Description
Delegate | RenderingExtensionInfoCollection.ContentChangedEventHandler | Represents the method that processes the ContentChanged event.
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


CustomDesignerConfigurationDictionary Class

CustomDesignerConfigurationDictionary Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : CustomDesignerConfigurationDictionary Class
Represents a dictionary of custom designers configured for components.
Object Model
CustomDesignerConfigurationDictionary Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class CustomDesignerConfigurationDictionary
public sealed class CustomDesignerConfigurationDictionary
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Configuration.CustomDesignerConfigurationDictionary

See Also

Reference

CustomDesignerConfigurationDictionary Members
GrapeCity.ActiveReports.Configuration Namespace


CustomDesignerConfigurationDictionary Class Members

CustomDesignerConfigurationDictionary Class Members
Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : CustomDesignerConfigurationDictionary Class

The following tables list the members exposed by CustomDesignerConfigurationDictionary.

Public Constructors
 | Name | Description
Public Constructor | CustomDesignerConfigurationDictionary Constructor | Initializes a new instance of CustomDesignerConfigurationDictionary class.
Top
Public Methods
 | Name | Description
Public Method | GetCustomTypeNameForDesigner | Gets the CustomReportItem.Type value associated with the specified designer.
Public Method | GetDesignerForCustomTypeName | Returns the System.Type of the custom designer configured for the specified component type or null.
Top
See Also

Reference

CustomDesignerConfigurationDictionary Class
GrapeCity.ActiveReports.Configuration Namespace


CustomDesignerConfigurationDictionary Constructor

CustomDesignerConfigurationDictionary Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > CustomDesignerConfigurationDictionary Class : CustomDesignerConfigurationDictionary Constructor
Initializes a new instance of CustomDesignerConfigurationDictionary class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public CustomDesignerConfigurationDictionary()
See Also

Reference

CustomDesignerConfigurationDictionary Class
CustomDesignerConfigurationDictionary Members


CustomDesignerConfigurationDictionary Class Methods

CustomDesignerConfigurationDictionary Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : CustomDesignerConfigurationDictionary Class

For a list of all members of this type, see CustomDesignerConfigurationDictionary members.

Public Methods
 | Name | Description
Public Method | GetCustomTypeNameForDesigner | Gets the CustomReportItem.Type value associated with the specified designer.
Public Method | GetDesignerForCustomTypeName | Returns the System.Type of the custom designer configured for the specified component type or null.
Top
See Also

Reference

CustomDesignerConfigurationDictionary Class
GrapeCity.ActiveReports.Configuration Namespace


GetCustomTypeNameForDesigner Method

GetCustomTypeNameForDesigner Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > CustomDesignerConfigurationDictionary Class : GetCustomTypeNameForDesigner Method
The System.Type for the designer the caller wants a custom report item type name for.
Gets the CustomReportItem.Type value associated with the specified designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetCustomTypeNameForDesigner( _
   ByVal designerType As System.Type _
) As System.String
public System.string GetCustomTypeNameForDesigner(
   System.Type designerType
)

Parameters

designerType
The System.Type for the designer the caller wants a custom report item type name for.

Return Value

A value appropriate for the CustomReportItem RDL element's Type attribute value.
See Also

Reference

CustomDesignerConfigurationDictionary Class
CustomDesignerConfigurationDictionary Members


GetDesignerForCustomTypeName Method

GetDesignerForCustomTypeName Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > CustomDesignerConfigurationDictionary Class : GetDesignerForCustomTypeName Method
The value of CustomReportItem.Type for which a configured designer is sought for.
Returns the System.Type of the custom designer configured for the specified component type or null.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetDesignerForCustomTypeName( _
   ByVal customTypeName As System.String _
) As System.Type
public System.Type GetDesignerForCustomTypeName(
   System.string customTypeName
)

Parameters

customTypeName
The value of CustomReportItem.Type for which a configured designer is sought for.

Return Value

The System.Type of the custom designer configured for the specified component, or null if a custom designer is not configured for the specified component.
See Also

Reference

CustomDesignerConfigurationDictionary Class
CustomDesignerConfigurationDictionary Members


DefaultConfigurationProvider Class

DefaultConfigurationProvider Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : DefaultConfigurationProvider Class
Implements an IConfigurationProvider that gets configuration information from a file in the executable directory.
Object Model
DefaultConfigurationProvider Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DefaultConfigurationProvider
   Implements IConfigurationProvider
public class DefaultConfigurationProvider : IConfigurationProvider
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Configuration.DefaultConfigurationProvider

See Also

Reference

DefaultConfigurationProvider Members
GrapeCity.ActiveReports.Configuration Namespace


DefaultConfigurationProvider Class Members

DefaultConfigurationProvider Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : DefaultConfigurationProvider Class

The following tables list the members exposed by DefaultConfigurationProvider.

Public Constructors
 | Name | Description
Public Constructor | DefaultConfigurationProvider Constructor | Creates a new instance of DefaultConfigurationProvider.
Top
Public Properties
 | Name | Description
Public Property | Content | Returns the xml content of the configuration information.
Top
See Also

Reference

DefaultConfigurationProvider Class
GrapeCity.ActiveReports.Configuration Namespace


DefaultConfigurationProvider Constructor

DefaultConfigurationProvider Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > DefaultConfigurationProvider Class : DefaultConfigurationProvider Constructor
Creates a new instance of DefaultConfigurationProvider.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DefaultConfigurationProvider()
See Also

Reference

DefaultConfigurationProvider Class
DefaultConfigurationProvider Members


DefaultConfigurationProvider Class Properties

DefaultConfigurationProvider Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : DefaultConfigurationProvider Class

For a list of all members of this type, see DefaultConfigurationProvider members.

Public Properties
 | Name | Description
Public Property | Content | Returns the xml content of the configuration information.
Top
See Also

Reference

DefaultConfigurationProvider Class
GrapeCity.ActiveReports.Configuration Namespace


Content Property (DefaultConfigurationProvider)

Content Property (DefaultConfigurationProvider)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > DefaultConfigurationProvider Class : Content Property
Returns the xml content of the configuration information.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Content As System.String
public System.string Content {get;}
See Also

Reference

DefaultConfigurationProvider Class
DefaultConfigurationProvider Members


PropertyElement Class

PropertyElement Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : PropertyElement Class
Represents a property configuration option for the associated export extension.
Object Model
PropertyElement Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class PropertyElement
public class PropertyElement
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Configuration.PropertyElement

See Also

Reference

PropertyElement Members
GrapeCity.ActiveReports.Configuration Namespace


PropertyElement Class Members

PropertyElement Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : PropertyElement Class

The following tables list the members exposed by PropertyElement.

Public Constructors
 | Name | Description
Public Constructor | PropertyElement Constructor | Initializes a new instance of the System.Object class with the specified property, value and value type.
Top
Public Properties
 | Name | Description
Public Property | Property | Gets the property to assign value to.
Public Property | Type | Gets the type of the value to convert the value to.
Public Property | Value | Gets the string value.
Top
See Also

Reference

PropertyElement Class
GrapeCity.ActiveReports.Configuration Namespace


PropertyElement Constructor

PropertyElement Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > PropertyElement Class : PropertyElement Constructor
The property to assign value to.
The value for the property.
The type of the value to convert the string value to.
Initializes a new instance of the System.Object class with the specified property, value and value type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal property As System.String, _
   ByVal value As System.String, _
   ByVal type As System.String _
)
public PropertyElement(
   System.string property,
   System.string value,
   System.string type
)

Parameters

property
The property to assign value to.
value
The value for the property.
type
The type of the value to convert the string value to.
See Also

Reference

PropertyElement Class
PropertyElement Members


PropertyElement Class Properties

PropertyElement Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : PropertyElement Class

For a list of all members of this type, see PropertyElement members.

Public Properties
 | Name | Description
Public Property | Property | Gets the property to assign value to.
Public Property | Type | Gets the type of the value to convert the value to.
Public Property | Value | Gets the string value.
Top
See Also

Reference

PropertyElement Class
GrapeCity.ActiveReports.Configuration Namespace


Property Property

Property Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > PropertyElement Class : Property Property
Gets the property to assign value to.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Property As System.String
public System.string Property {get;}
See Also

Reference

PropertyElement Class
PropertyElement Members


Type Property (PropertyElement)

Type Property (PropertyElement)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > PropertyElement Class : Type Property
Gets the type of the value to convert the value to.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Type As System.String
public System.string Type {get;}
See Also

Reference

PropertyElement Class
PropertyElement Members


Value Property (PropertyElement)

Value Property (PropertyElement)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > PropertyElement Class : Value Property
Gets the string value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Value As System.String
public System.string Value {get;}
See Also

Reference

PropertyElement Class
PropertyElement Members


RenderingExtensionInfo Class

RenderingExtensionInfo Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfo Class
Class containing rendering extension information.
Object Model
RenderingExtensionInfo Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class RenderingExtensionInfo
public class RenderingExtensionInfo
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Configuration.RenderingExtensionInfo

See Also

Reference

RenderingExtensionInfo Members
GrapeCity.ActiveReports.Configuration Namespace


RenderingExtensionInfo Class Members

RenderingExtensionInfo Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfo Class

The following tables list the members exposed by RenderingExtensionInfo.

Public Properties
 | Name | Description
Public Property | AssemblyName | Fully qualified name of the assembly.
Public Property | MenuName | Export menu item name for this rendering extension name.
Public Property | Settings | Gets the configuration.
Public Property | TypeName | Rendering extension implementation class name.
Top
See Also

Reference

RenderingExtensionInfo Class
GrapeCity.ActiveReports.Configuration Namespace


RenderingExtensionInfo Class Properties

RenderingExtensionInfo Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfo Class

For a list of all members of this type, see RenderingExtensionInfo members.

Public Properties
 | Name | Description
Public Property | AssemblyName | Fully qualified name of the assembly.
Public Property | MenuName | Export menu item name for this rendering extension name.
Public Property | Settings | Gets the configuration.
Public Property | TypeName | Rendering extension implementation class name.
Top
See Also

Reference

RenderingExtensionInfo Class
GrapeCity.ActiveReports.Configuration Namespace


AssemblyName Property

AssemblyName Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfo Class : AssemblyName Property
Fully qualified name of the assembly.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property AssemblyName As System.String
public System.string AssemblyName {get;}
See Also

Reference

RenderingExtensionInfo Class
RenderingExtensionInfo Members


MenuName Property

MenuName Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfo Class : MenuName Property
Export menu item name for this rendering extension name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MenuName As System.String
public System.string MenuName {get;}
See Also

Reference

RenderingExtensionInfo Class
RenderingExtensionInfo Members


Settings Property (RenderingExtensionInfo)

Settings Property (RenderingExtensionInfo)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfo Class : Settings Property
Gets the configuration.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Settings As System.Collections.ObjectModel.ReadOnlyCollection(Of PropertyElement)
public System.Collections.ObjectModel.ReadOnlyCollection<PropertyElement> Settings {get;}
See Also

Reference

RenderingExtensionInfo Class
RenderingExtensionInfo Members


TypeName Property

TypeName Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfo Class : TypeName Property
Rendering extension implementation class name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TypeName As System.String
public System.string TypeName {get;}
See Also

Reference

RenderingExtensionInfo Class
RenderingExtensionInfo Members


RenderingExtensionInfoCollection Class

RenderingExtensionInfoCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfoCollection Class
Represents a collection of RenderingExtensionInfo.
Object Model
RenderingExtensionInfoCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class RenderingExtensionInfoCollection
   Inherits System.Collections.CollectionBase
public class RenderingExtensionInfoCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Configuration.RenderingExtensionInfoCollection

See Also

Reference

RenderingExtensionInfoCollection Members
GrapeCity.ActiveReports.Configuration Namespace


RenderingExtensionInfoCollection Class Members

RenderingExtensionInfoCollection Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfoCollection Class

The following tables list the members exposed by RenderingExtensionInfoCollection.

Public Constructors
 | Name | Description
Public Constructor | RenderingExtensionInfoCollection Constructor | Creates an instance of RenderingExtensionInfoCollection.
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the RenderingExtensionInfoCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the RenderingExtensionInfoCollection instance. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the RenderingExtensionInfo at the specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds RenderingExtensionInfo to the end of the RenderingExtensionsCollection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the RenderingExtensionsCollection contains a specific RenderingExtensionInfo.
Public Method | IndexOf | Searches for the specified RenderingExtensions and returns the zero-based index of the first occurrence within the entire RenderingExtensionsCollection.
Public Method | Remove | Removes the first occurrence of a specific RenderingExtensionInfo from the RenderingExtensionsCollection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
Public Events
 | Name | Description
Public Event | ContentChanged | Occurs when the content has changed.
Top
See Also

Reference

RenderingExtensionInfoCollection Class
GrapeCity.ActiveReports.Configuration Namespace


RenderingExtensionInfoCollection Constructor

RenderingExtensionInfoCollection Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : RenderingExtensionInfoCollection Constructor
Creates an instance of RenderingExtensionInfoCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public RenderingExtensionInfoCollection()
See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


RenderingExtensionInfoCollection Class Methods

RenderingExtensionInfoCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfoCollection Class

For a list of all members of this type, see RenderingExtensionInfoCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds RenderingExtensionInfo to the end of the RenderingExtensionsCollection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the RenderingExtensionsCollection contains a specific RenderingExtensionInfo.
Public Method | IndexOf | Searches for the specified RenderingExtensions and returns the zero-based index of the first occurrence within the entire RenderingExtensionsCollection.
Public Method | Remove | Removes the first occurrence of a specific RenderingExtensionInfo from the RenderingExtensionsCollection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

RenderingExtensionInfoCollection Class
GrapeCity.ActiveReports.Configuration Namespace


Add Method (RenderingExtensionInfoCollection)

Add Method (RenderingExtensionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : Add Method
Adds RenderingExtensionInfo to the end of the RenderingExtensionsCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As RenderingExtensionInfo _
) As System.Integer
public System.int Add(
   RenderingExtensionInfo value
)

Parameters

value
See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


Contains Method (RenderingExtensionInfoCollection)

Contains Method (RenderingExtensionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : Contains Method
Determines whether the RenderingExtensionsCollection contains a specific RenderingExtensionInfo.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal value As RenderingExtensionInfo _
) As System.Boolean
public System.bool Contains(
   RenderingExtensionInfo value
)

Parameters

value
See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


IndexOf Method (RenderingExtensionInfoCollection)

IndexOf Method (RenderingExtensionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : IndexOf Method
Searches for the specified RenderingExtensions and returns the zero-based index of the first occurrence within the entire RenderingExtensionsCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As RenderingExtensionInfo _
) As System.Integer
public System.int IndexOf(
   RenderingExtensionInfo value
)

Parameters

value
See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


Remove Method (RenderingExtensionInfoCollection)

Remove Method (RenderingExtensionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : Remove Method
Removes the first occurrence of a specific RenderingExtensionInfo from the RenderingExtensionsCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As RenderingExtensionInfo _
)
public void Remove(
   RenderingExtensionInfo value
)

Parameters

value
See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


RenderingExtensionInfoCollection Class Properties

RenderingExtensionInfoCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfoCollection Class

For a list of all members of this type, see RenderingExtensionInfoCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the RenderingExtensionInfoCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the RenderingExtensionInfoCollection instance. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the RenderingExtensionInfo at the specified index.
Top
See Also

Reference

RenderingExtensionInfoCollection Class
GrapeCity.ActiveReports.Configuration Namespace


Item Property (RenderingExtensionInfoCollection)

Item Property (RenderingExtensionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : Item Property
Gets or sets the RenderingExtensionInfo at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As RenderingExtensionInfo
public RenderingExtensionInfo this[
   System.int index
]; {get; set;}

Parameters

index
See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


RenderingExtensionInfoCollection Class Events

RenderingExtensionInfoCollection Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfoCollection Class

For a list of all members of this type, see RenderingExtensionInfoCollection members.

Public Events
 | Name | Description
Public Event | ContentChanged | Occurs when the content has changed.
Top
See Also

Reference

RenderingExtensionInfoCollection Class
GrapeCity.ActiveReports.Configuration Namespace


ContentChanged Event

ContentChanged Event

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : ContentChanged Event
Occurs when the content has changed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ContentChanged As RenderingExtensionInfoCollection.ContentChangedEventHandler
public event RenderingExtensionInfoCollection.ContentChangedEventHandler ContentChanged
See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


ReportItemsConfigurationDictionary Class

ReportItemsConfigurationDictionary Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : ReportItemsConfigurationDictionary Class
A dictionary of CustomReportItem type names and their corresponding System.Type.
Object Model
ReportItemsConfigurationDictionary Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ReportItemsConfigurationDictionary
public sealed class ReportItemsConfigurationDictionary
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Configuration.ReportItemsConfigurationDictionary

See Also

Reference

ReportItemsConfigurationDictionary Members
GrapeCity.ActiveReports.Configuration Namespace


ReportItemsConfigurationDictionary Class Members

ReportItemsConfigurationDictionary Class Members
Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : ReportItemsConfigurationDictionary Class

The following tables list the members exposed by ReportItemsConfigurationDictionary.

Public Methods
 | Name | Description
Public Method | GetCustomTypeNameForReportItem | Gets the Type value associated with the specified ReportItem.
Public Method | GetReportItemForCustomTypeName | Returns the System.Type of the custom report item configured for the specified component type or null.
Top
See Also

Reference

ReportItemsConfigurationDictionary Class
GrapeCity.ActiveReports.Configuration Namespace


ReportItemsConfigurationDictionary Class Methods

ReportItemsConfigurationDictionary Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : ReportItemsConfigurationDictionary Class

For a list of all members of this type, see ReportItemsConfigurationDictionary members.

Public Methods
 | Name | Description
Public Method | GetCustomTypeNameForReportItem | Gets the Type value associated with the specified ReportItem.
Public Method | GetReportItemForCustomTypeName | Returns the System.Type of the custom report item configured for the specified component type or null.
Top
See Also

Reference

ReportItemsConfigurationDictionary Class
GrapeCity.ActiveReports.Configuration Namespace


GetCustomTypeNameForReportItem Method

GetCustomTypeNameForReportItem Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > ReportItemsConfigurationDictionary Class : GetCustomTypeNameForReportItem Method
The System.Type for the designer the caller wants a custom report item type name for.
Gets the Type value associated with the specified ReportItem.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetCustomTypeNameForReportItem( _
   ByVal reportItemType As System.Type _
) As System.String
public System.string GetCustomTypeNameForReportItem(
   System.Type reportItemType
)

Parameters

reportItemType
The System.Type for the designer the caller wants a custom report item type name for.

Return Value

A value appropriate for the CustomReportItem RDL element's Type attribute value.
Remarks
The specified ReportItem Type should implement the interface IReportItem.
See Also

Reference

ReportItemsConfigurationDictionary Class
ReportItemsConfigurationDictionary Members


GetReportItemForCustomTypeName Method

GetReportItemForCustomTypeName Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > ReportItemsConfigurationDictionary Class : GetReportItemForCustomTypeName Method
The value of Type for which a configured designer is sought for.
Returns the System.Type of the custom report item configured for the specified component type or null.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetReportItemForCustomTypeName( _
   ByVal customReportItemTypeName As System.String _
) As System.Type
public System.Type GetReportItemForCustomTypeName(
   System.string customReportItemTypeName
)

Parameters

customReportItemTypeName
The value of Type for which a configured designer is sought for.

Return Value

The System.Type of the custom designer configured for the specified component, or null if a custom designer is not configured for the specified component.
Remarks
The returned type should implement the interface IReportItem.
See Also

Reference

ReportItemsConfigurationDictionary Class
ReportItemsConfigurationDictionary Members


ToolboxItemConfig Class

ToolboxItemConfig Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : ToolboxItemConfig Class
Represents an entry for a toolbox configuration item.
Object Model
ToolboxItemConfig Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ToolboxItemConfig
public sealed class ToolboxItemConfig
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Configuration.ToolboxItemConfig

See Also

Reference

ToolboxItemConfig Members
GrapeCity.ActiveReports.Configuration Namespace


ToolboxItemConfig Class Members

ToolboxItemConfig Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : ToolboxItemConfig Class

The following tables list the members exposed by ToolboxItemConfig.

Public Properties
 | Name | Description
Public Property | BitmapResource | Gets an assembly qualified resource name of the bitmap that should be displayed for this toolbox item.
Public Property | ClearItems | Gets a value that indicates if all existing items should be cleared.
Public Property | ReportItemDesignerType | Gets an assembly qualified type name of the report item designer type that this toolbox item represents (technically it represents the component associated with this designer).
Top
See Also

Reference

ToolboxItemConfig Class
GrapeCity.ActiveReports.Configuration Namespace


ToolboxItemConfig Class Properties

ToolboxItemConfig Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : ToolboxItemConfig Class

For a list of all members of this type, see ToolboxItemConfig members.

Public Properties
 | Name | Description
Public Property | BitmapResource | Gets an assembly qualified resource name of the bitmap that should be displayed for this toolbox item.
Public Property | ClearItems | Gets a value that indicates if all existing items should be cleared.
Public Property | ReportItemDesignerType | Gets an assembly qualified type name of the report item designer type that this toolbox item represents (technically it represents the component associated with this designer).
Top
See Also

Reference

ToolboxItemConfig Class
GrapeCity.ActiveReports.Configuration Namespace


BitmapResource Property

BitmapResource Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > ToolboxItemConfig Class : BitmapResource Property
Gets an assembly qualified resource name of the bitmap that should be displayed for this toolbox item.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property BitmapResource As System.String
public System.string BitmapResource {get;}
See Also

Reference

ToolboxItemConfig Class
ToolboxItemConfig Members


ClearItems Property

ClearItems Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > ToolboxItemConfig Class : ClearItems Property
Gets a value that indicates if all existing items should be cleared.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ClearItems As System.Boolean
public System.bool ClearItems {get;}
See Also

Reference

ToolboxItemConfig Class
ToolboxItemConfig Members


ReportItemDesignerType Property

ReportItemDesignerType Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > ToolboxItemConfig Class : ReportItemDesignerType Property
Gets an assembly qualified type name of the report item designer type that this toolbox item represents (technically it represents the component associated with this designer).
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ReportItemDesignerType As System.String
public System.string ReportItemDesignerType {get;}
See Also

Reference

ToolboxItemConfig Class
ToolboxItemConfig Members


IConfigurationManager Interface

IConfigurationManager Interface
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : IConfigurationManager Interface
Defines an interface to allow access to configuration information.
Object Model
IConfigurationManager Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IConfigurationManager
public interface IConfigurationManager
See Also

Reference

IConfigurationManager Members
GrapeCity.ActiveReports.Configuration Namespace


IConfigurationManager Interface Members

IConfigurationManager Interface Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : IConfigurationManager Interface

The following tables list the members exposed by IConfigurationManager.

Public Properties
 | Name | Description
Property | CustomItemDesigners | Returns a map for the custom report items with the custom designers.
Property | DataProviders | Returns a collection of custom data providers.
Property | MapTileServerConfiguration | Returns a configuration for communication with map tile server.
Property | RenderingExtensions |
Property | ReportItems |
Property | Settings | Returns a collection of configuration settings.
Property | TileProviders | Returns map tile providers.
Property | ToolboxItems | Returns the toolbox item configuration entries.
Top
See Also

Reference

IConfigurationManager Interface
GrapeCity.ActiveReports.Configuration Namespace


IConfigurationManager Interface Properties

IConfigurationManager Interface Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : IConfigurationManager Interface

For a list of all members of this type, see IConfigurationManager members.

Public Properties
 | Name | Description
Property | CustomItemDesigners | Returns a map for the custom report items with the custom designers.
Property | DataProviders | Returns a collection of custom data providers.
Property | MapTileServerConfiguration | Returns a configuration for communication with map tile server.
Property | RenderingExtensions |
Property | ReportItems |
Property | Settings | Returns a collection of configuration settings.
Property | TileProviders | Returns map tile providers.
Property | ToolboxItems | Returns the toolbox item configuration entries.
Top
See Also

Reference

IConfigurationManager Interface
GrapeCity.ActiveReports.Configuration Namespace


CustomItemDesigners Property

CustomItemDesigners Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : CustomItemDesigners Property
Returns a map for the custom report items with the custom designers.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CustomItemDesigners As CustomDesignerConfigurationDictionary
CustomDesignerConfigurationDictionary CustomItemDesigners {get;}
See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


DataProviders Property

DataProviders Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : DataProviders Property
Returns a collection of custom data providers.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DataProviders As DataProviderInfoCollection
DataProviderInfoCollection DataProviders {get;}
See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


MapTileServerConfiguration Property

MapTileServerConfiguration Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : MapTileServerConfiguration Property
Returns a configuration for communication with map tile server.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MapTileServerConfiguration As MapTileServerConfiguration
MapTileServerConfiguration MapTileServerConfiguration {get;}
See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


RenderingExtensions Property

RenderingExtensions Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : RenderingExtensions Property
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property RenderingExtensions As RenderingExtensionInfoCollection
RenderingExtensionInfoCollection RenderingExtensions {get;}
See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


ReportItems Property (IConfigurationManager)

ReportItems Property (IConfigurationManager)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : ReportItems Property
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ReportItems As ReportItemsConfigurationDictionary
ReportItemsConfigurationDictionary ReportItems {get;}
See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


Settings Property (IConfigurationManager)

Settings Property (IConfigurationManager)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : Settings Property
Returns a collection of configuration settings.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Settings As System.Collections.Specialized.NameValueCollection
System.Collections.Specialized.NameValueCollection Settings {get;}
See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


TileProviders Property

TileProviders Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : TileProviders Property
Returns map tile providers.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property TileProviders As System.Collections.Generic.IEnumerable(Of TileProviderInfo)
System.Collections.Generic.IEnumerable<TileProviderInfo> TileProviders {get;}
See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


ToolboxItems Property

ToolboxItems Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationManager Interface : ToolboxItems Property
Returns the toolbox item configuration entries.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ToolboxItems As System.Collections.ICollection
System.Collections.ICollection ToolboxItems {get;}
See Also

Reference

IConfigurationManager Interface
IConfigurationManager Members


IConfigurationProvider Interface

IConfigurationProvider Interface
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : IConfigurationProvider Interface
Defines interface for providing raw configuration information.
Object Model
IConfigurationProvider Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IConfigurationProvider
public interface IConfigurationProvider
See Also

Reference

IConfigurationProvider Members
GrapeCity.ActiveReports.Configuration Namespace


IConfigurationProvider Interface Members

IConfigurationProvider Interface Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : IConfigurationProvider Interface

The following tables list the members exposed by IConfigurationProvider.

Public Properties
 | Name | Description
Property | Content | Gets the xml representing the configuration.
Top
See Also

Reference

IConfigurationProvider Interface
GrapeCity.ActiveReports.Configuration Namespace


IConfigurationProvider Interface Properties

IConfigurationProvider Interface Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : IConfigurationProvider Interface

For a list of all members of this type, see IConfigurationProvider members.

Public Properties
 | Name | Description
Property | Content | Gets the xml representing the configuration.
Top
See Also

Reference

IConfigurationProvider Interface
GrapeCity.ActiveReports.Configuration Namespace


Content Property (IConfigurationProvider)

Content Property (IConfigurationProvider)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > IConfigurationProvider Interface : Content Property
Gets the xml representing the configuration.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Content As System.String
System.string Content {get;}
See Also

Reference

IConfigurationProvider Interface
IConfigurationProvider Members


RenderingExtensionInfoCollection.ContentChangedEventHandler Delegate

RenderingExtensionInfoCollection.ContentChangedEventHandler Delegate

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace : RenderingExtensionInfoCollection.ContentChangedEventHandler Delegate
The source of the event.
The RenderingExtensionInfoCollection.ContentChangedEventargs value that contains the event data.
Represents the method that processes the ContentChanged event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub RenderingExtensionInfoCollection.ContentChangedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)
public delegate void RenderingExtensionInfoCollection.ContentChangedEventHandler(
   System.object sender,
   System.EventArgs e
)

Parameters

sender
The source of the event.
e
The RenderingExtensionInfoCollection.ContentChangedEventargs value that contains the event data.
See Also

Reference

RenderingExtensionInfoCollection.ContentChangedEventHandler Members
GrapeCity.ActiveReports.Configuration Namespace


GrapeCity.ActiveReports.Data Namespace

GrapeCity.ActiveReports.Data Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports.Data Namespace
The GrapeCity.ActiveReports.Data namespace contains the classes used for section report data binding in section reports.
Classes
 | Class | Description
Class | Field | The Field class represents any data field available for data binding in section reports.
Class | FieldCollection | The FieldCollection class manages the data binding fields used in the section report.
Class | ListDataSource | Represents a section report data source based on the IDataRecord and IDataReader members of the .NET Framework.
Class | OdbcDataSource | ODBC data source - allows to connect through ODBC driver.
Class | OleDBDataSource | Represents a section report data source based on the OleDb ADO.NET data provider.
Class | SqlDBDataSource | Represents a section report data source based on the SqlDB ADO.NET data provider.
Class | XMLDataSource | Represents a section report data source based on an XML document and an XPath pattern to select the XML nodes used as records in the data source.
Enumerations
 | Enumeration | Description
Enumeration | FieldTypeEnum | Provides a set of values for use with the FieldType property of the Field class.
Remarks
If you want to use run-time data binding in page reports, please see Bind a Page Report to a Data Source at Run Time.
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


Field Class

Field Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : Field Class
The Field class represents any data field available for data binding in section reports.
Object Model
Field Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Field
public class Field
Remarks
Field objects are created automatically for all fields in the bound data source. This class allows you to inspect the value of each field. You can create additional custom fields and add them to the Fields collection in the DataIntialize event. Custom field values should be set in the FetchData event.
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.Field

See Also

Reference

Field Members
GrapeCity.ActiveReports.Data Namespace
Fields Property
FetchData Event
DataInitialize Event


Field Class Members

Field Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : Field Class

The following tables list the members exposed by Field.

Public Constructors
 | Name | Description
Public Constructor | Field Constructor | Initializes a new instance of the Field class.
Top
Public Properties
 | Name | Description
Public Property | DefaultValue | Gets or sets the user-defined default value of the field, which is used if the formula or value is null.
Public Property | FieldType | Gets or sets the type associated with the field.
Public Property | Formula | Gets or sets a formula used to derive the run-time value. If the formula is not null, it overrides all preceding values. The formula can be any combination of calculated and/or bound fields and literals.
Public Property | Name | Gets or sets the name of the field.
Public Property | Tag | Gets or sets a user-defined value associated with the field object.
Public Property | Value | Gets or sets the current value of the field object.
Top
Public Methods
 | Name | Description
Public Method | Dispose | Release the instance of the Field object from memory.
Public Method | ToString | Returns a string that represents the current Field object.
Top
Public Events
 | Name | Description
Public Event | Disposed | Raised when the Field object is released from memory.
Top
See Also

Reference

Field Class
GrapeCity.ActiveReports.Data Namespace
Fields Property
FetchData Event
DataInitialize Event


Field Constructor

Field Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : Field Constructor
Initializes a new instance of the Field class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Field()
See Also

Reference

Field Class
Field Members


Field Class Methods

Field Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : Field Class

For a list of all members of this type, see Field members.

Public Methods
 | Name | Description
Public Method | Dispose | Release the instance of the Field object from memory.
Public Method | ToString | Returns a string that represents the current Field object.
Top
See Also

Reference

Field Class
GrapeCity.ActiveReports.Data Namespace
Fields Property
FetchData Event
DataInitialize Event


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : Dispose() Method
Release the instance of the Field object from memory.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Field Class
Field Members


ToString Method (Field)

ToString Method (Field)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : ToString Method
Returns a string that represents the current Field object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()
See Also

Reference

Field Class
Field Members


Field Class Properties

Field Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : Field Class

For a list of all members of this type, see Field members.

Public Properties
 | Name | Description
Public Property | DefaultValue | Gets or sets the user-defined default value of the field, which is used if the formula or value is null.
Public Property | FieldType | Gets or sets the type associated with the field.
Public Property | Formula | Gets or sets a formula used to derive the run-time value. If the formula is not null, it overrides all preceding values. The formula can be any combination of calculated and/or bound fields and literals.
Public Property | Name | Gets or sets the name of the field.
Public Property | Tag | Gets or sets a user-defined value associated with the field object.
Public Property | Value | Gets or sets the current value of the field object.
Top
See Also

Reference

Field Class
GrapeCity.ActiveReports.Data Namespace
Fields Property
FetchData Event
DataInitialize Event


DefaultValue Property (Field)

DefaultValue Property (Field)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : DefaultValue Property
Gets or sets the user-defined default value of the field, which is used if the formula or value is null.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultValue As System.String
public System.string DefaultValue {get; set;}
Example
  • C#
private void rptCalFields_ReportStart(object sender, System.EventArgs e)
{
    this.field1.DefaultValue = "\"Does not compute\"";
    this.field1.FieldType = GrapeCity.ActiveReports.Data.FieldTypeEnum.None;
    this.field1.Formula = "ProductName + UnitPrice";
    this.field1.Name = "field1";
    this.field1.Tag = null;
}
  • Visual Basic
Private Sub rptCalFields_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs)
   Me.field1.DefaultValue = """Does not compute"""
   Me.field1.FieldType = GrapeCity.ActiveReports.Data.FieldTypeEnum.None
   Me.field1.Formula = "ProductName + UnitPrice"
   Me.field1.Name = "field1"
   Me.field1.Tag = Nothing
End Sub
See Also

Reference

Field Class
Field Members


FieldType Property

FieldType Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : FieldType Property
Gets or sets the type associated with the field.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FieldType As FieldTypeEnum
public FieldTypeEnum FieldType {get; set;}
Remarks
If the output of a field does not match the setting of the FieldType property, Field.DefaultValue takes precedence.
Example
  • C#
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    Fields[1].FieldType = FieldTypeEnum.String;
}
  • Visual Basic
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
  Fields(1).FieldType = FieldTypeEnum.String
End Sub
See Also

Reference

Field Class
Field Members


Formula Property

Formula Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : Formula Property
Gets or sets a formula used to derive the run-time value. If the formula is not null, it overrides all preceding values. The formula can be any combination of calculated and/or bound fields and literals.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Formula As System.String
public System.string Formula {get; set;}
Example
  • C#
private void rptCalFields_ReportStart(object sender, System.EventArgs e)
{
    this.field1.DefaultValue = "\"Does not compute\"";
    this.field1.FieldType = GrapeCity.ActiveReports.Data.FieldTypeEnum.None;
    this.field1.Formula = "ProductName + UnitPrice";
    this.field1.Name = "field1";
    this.field1.Tag = null;
}
  • Visual Basic
Private Sub rptCalFields_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs)
   Me.field1.DefaultValue = """Does not compute"""
   Me.field1.FieldType = GrapeCity.ActiveReports.Data.FieldTypeEnum.None
   Me.field1.Formula = "ProductName + UnitPrice"
   Me.field1.Name = "field1"
   Me.field1.Tag = Nothing
End Sub
See Also

Reference

Field Class
Field Members


Name Property (Field)

Name Property (Field)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : Name Property
Gets or sets the name of the field.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}

Property Value

String value representing the name of the field.
Remarks
The name must be unique within the collection and is used as a key of the field in the collection.
Example
  • C#
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    Fields[0].Name = "FirstField";
}
  • Visual Basic
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
  Fields(0).Name = "FirstField"
End Sub
See Also

Reference

Field Class
Field Members


Tag Property (Field)

Tag Property (Field)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : Tag Property
Gets or sets a user-defined value associated with the field object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Tag As System.Object
public System.object Tag {get; set;}

Property Value

An object user-defined value.
Example
  • C#
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    Fields[0].Tag = "Some extra data";
}
  • Visual Basic
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
  Fields(0).Tag = "Some extra data"
End Sub
See Also

Reference

Field Class
Field Members


Value Property (Field)

Value Property (Field)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : Value Property
Gets or sets the current value of the field object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As System.Object
public System.object Value {get; set;}
Example
  • C#
private void rptUnbound_FetchData(object sender, GrapeCity.ActiveReports.ActiveReport.
    FetchEventArgs eArgs)
{
    try
    {
        m_reader.Read();
        Fields["CategoryName"].Value = m_reader["CategoryName"].ToString();
        Fields["ProductName"].Value = m_reader["ProductName"].ToString();
        Fields["UnitsInStock"].Value = m_reader["UnitsInStock"].ToString();
        Fields["Description"].Value = m_reader["Description"].ToString();
        eArgs.EOF = false;
    }
    catch
    {
        eArgs.EOF = true;
    }
}
  • Visual Basic
Private Sub rptUnbound_FetchData(ByVal sender As Object, ByVal eArgs As GrapeCity.ActiveReports.ActiveReport.FetchEventArgs) Handles MyBase.FetchData
      Try
          m_reader.Read()
          Me.Fields("CategoryName").Value = m_reader("CategoryName")
          Me.Fields("ProductName").Value = m_reader("ProductName")
          Me.Fields("UnitsInStock").Value = m_reader("UnitsInStock")
          Me.Fields("Description").Value = m_reader("Description")
          eArgs.EOF = False
          Catch ex As Exception
          eArgs.EOF = True
      End Try
End Sub
See Also

Reference

Field Class
Field Members


Field Class Events

Field Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : Field Class

For a list of all members of this type, see Field members.

Public Events
 | Name | Description
Public Event | Disposed | Raised when the Field object is released from memory.
Top
See Also

Reference

Field Class
GrapeCity.ActiveReports.Data Namespace
Fields Property
FetchData Event
DataInitialize Event


Disposed Event (Field)

Disposed Event (Field)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : Disposed Event
Raised when the Field object is released from memory.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Field Class
Field Members


FieldCollection Class

FieldCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : FieldCollection Class
The FieldCollection class manages the data binding fields used in the section report.
Object Model
FieldCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class FieldCollection
   Inherits System.Collections.CollectionBase
public class FieldCollection : System.Collections.CollectionBase
Remarks
ActiveReports populates this collection with fields from the data source and updates the values with each record in the data source. In addition, you can add your own custom fields in the DataInitialize event to create unbound calculated fields. Custom field values can be set in the FetchData event.
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.FieldCollection

See Also

Reference

FieldCollection Members
GrapeCity.ActiveReports.Data Namespace
DataInitialize Event
FetchData Event


FieldCollection Class Members

FieldCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : FieldCollection Class

The following tables list the members exposed by FieldCollection.

Public Constructors
 | Name | Description
Public Constructor | FieldCollection Constructor | Initializes a new instance of the FieldCollection class.
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the FieldCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the FieldCollection instance. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Gets or sets the element at the specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a new field to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Overloaded. Returns a value indicating whether the field collection contains a field with the specified name.
Public Method | CopyTo | Copies fields from the collection to an array, starting at a particular array index.
Public Method | Dispose | Releases the fields collection from memory.
Public Method | IndexOf | Finds the index number of the specified field in the collection.
Public Method | Insert | Inserts an existing field in the fields collection at the specified location.
Public Method | Remove | Overloaded. Removes the specified field from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

FieldCollection Class
GrapeCity.ActiveReports.Data Namespace
DataInitialize Event
FetchData Event


FieldCollection Constructor

FieldCollection Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : FieldCollection Constructor
The parent object of the field collection.
Initializes a new instance of the FieldCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal parent As System.ComponentModel.IComponent _
)
public FieldCollection(
   System.ComponentModel.IComponent parent
)

Parameters

parent
The parent object of the field collection.
See Also

Reference

FieldCollection Class
FieldCollection Members


FieldCollection Class Methods

FieldCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : FieldCollection Class

For a list of all members of this type, see FieldCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a new field to the collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Overloaded. Returns a value indicating whether the field collection contains a field with the specified name.
Public Method | CopyTo | Copies fields from the collection to an array, starting at a particular array index.
Public Method | Dispose | Releases the fields collection from memory.
Public Method | IndexOf | Finds the index number of the specified field in the collection.
Public Method | Insert | Inserts an existing field in the fields collection at the specified location.
Public Method | Remove | Overloaded. Removes the specified field from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

FieldCollection Class
GrapeCity.ActiveReports.Data Namespace
DataInitialize Event
FetchData Event


Add Method (FieldCollection)

Add Method (FieldCollection)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : Add Method
Adds a new field to the collection.
Adds a new field to the collection.
Overload List
Overload | Description
Add(String) | Adds a new field to the collection.
Add(Field) | Adds a new field to the collection.
Remarks
The Add method should be used in the DataInitialize event.
Example
  • C#
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
}
  • Visual Basic
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
End Sub
See Also

Reference

FieldCollection Class
FieldCollection Members


Add(String) Method

Add(String) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Add Method : Add(String) Method

Name of the field to be added to the collection.

Adds a new field to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal fieldName As System.String _
) As System.Integer
public System.int Add(
   System.string fieldName
)

Parameters

fieldName

Name of the field to be added to the collection.

See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


Add(Field) Method

Add(Field) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Add Method : Add(Field) Method
The field to be added to the collection.
Adds a new field to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal field As Field _
) As System.Integer
public System.int Add(
   Field field
)

Parameters

field
The field to be added to the collection.
See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


Contains Method (FieldCollection)

Contains Method (FieldCollection)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : Contains Method

Returns a value indicating whether the field collection contains a field with the specified name.

Overload List
Overload | Description
Contains(String) | Returns whether the field collection contains a field with the specified name.
Contains(Field) | Returns whether the field collection contains the specified field.
Example
  • C#
private void UnboundGrp_ReportEnd(object sender, System.EventArgs eArgs)
{
    if (this.Fields.Contains("DiscountTotal"))
    {
        System.Windows.Forms.MessageBox.Show ("Contains Discount Total");
    }
}
  • Visual Basic
Private Sub UnboundGrp_ReportEnd(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportEnd
    If Me.Fields.Contains("DiscountTotal") Then
        MsgBox("contains discount total")
    End If
End Sub
See Also

Reference

FieldCollection Class
FieldCollection Members


Contains(String) Method

Contains(String) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Contains Method : Contains(String) Method
Specifies the field name to look for in the collection.

Returns whether the field collection contains a field with the specified name.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Contains( _
   ByVal fieldName As System.String _
) As System.Boolean
public System.bool Contains(
   System.string fieldName
)

Parameters

fieldName
Specifies the field name to look for in the collection.

Return Value

A Boolean value that indicates whether the specified fieldname was found.
See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


Contains(Field) Method

Contains(Field) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Contains Method : Contains(Field) Method
Specifies the field to look for in the collection.

Returns whether the field collection contains the specified field.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Contains( _
   ByVal field As Field _
) As System.Boolean
public System.bool Contains(
   Field field
)

Parameters

field
Specifies the field to look for in the collection.

Return Value

A Boolean value indicating whether the specified field was found.
See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


CopyTo Method (FieldCollection)

CopyTo Method (FieldCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : CopyTo Method
The array containing the copied fields.
The insertion index in the collection.
Copies fields from the collection to an array, starting at a particular array index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal fields() As Field, _
   ByVal index As System.Integer _
)
public void CopyTo(
   Field[] fields,
   System.int index
)

Parameters

fields
The array containing the copied fields.
index
The insertion index in the collection.
See Also

Reference

FieldCollection Class
FieldCollection Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : Dispose() Method
Releases the fields collection from memory.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

FieldCollection Class
FieldCollection Members


IndexOf(Field) Method

IndexOf(Field) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : IndexOf(Field) Method
The field to find the index of in the collection.
Finds the index number of the specified field in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal field As Field _
) As System.Integer
public System.int IndexOf(
   Field field
)

Parameters

field
The field to find the index of in the collection.

Return Value

An integer indicating the position of the field within the collection.
See Also

Reference

FieldCollection Class
FieldCollection Members


Insert Method (FieldCollection)

Insert Method (FieldCollection)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : Insert Method
The indexed location within the fields collection in which to insert the new field.
The field to insert.
Inserts an existing field in the fields collection at the specified location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal field As Field _
)
public void Insert(
   System.int index,
   Field field
)

Parameters

index
The indexed location within the fields collection in which to insert the new field.
field
The field to insert.
Example
  • C#
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    Fields.Insert(0,Fields[1]);
}
See Also

Reference

FieldCollection Class
FieldCollection Members


Remove Method (FieldCollection)

Remove Method (FieldCollection)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : Remove Method
Removes the specified field from the collection.
Overload List
Overload | Description
Remove(Field) | Removes the specified field from the collection.
Remove(String) | Removes the field with specified name from the collection.
Remove(Int32) | Removes the field at the specified index from the collection.
Example
  • C#
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    Fields.Remove("Description");
}
  • Visual Basic
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
  Fields.Remove("Description")
End Sub
See Also

Reference

FieldCollection Class
FieldCollection Members


Remove(Field) Method

Remove(Field) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Remove Method : Remove(Field) Method
The field to remove.
Removes the specified field from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Remove( _
   ByVal value As Field _
)
public void Remove(
   Field value
)

Parameters

value
The field to remove.
See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


Remove(String) Method

Remove(String) Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Remove Method : Remove(String) Method
Specifies the field name to remove from the collection.
Removes the field with specified name from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Remove( _
   ByVal fieldName As System.String _
)
public void Remove(
   System.string fieldName
)

Parameters

fieldName
Specifies the field name to remove from the collection.
Example
  • C#
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    Fields.Remove("Description");
}
  • Visual Basic
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
  Fields.Remove("Description")
End Sub
See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


Remove(Int32) Method

Remove(Int32) Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Remove Method : Remove(Int32) Method

Specifies the index of the field to be removed.

Removes the field at the specified index from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Remove( _
   ByVal index As System.Integer _
)
public void Remove(
   System.int index
)

Parameters

index

Specifies the index of the field to be removed.

Example
  • C#
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    Fields.Remove(4);
}
  • Visual Basic
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
  Fields.Remove(4)
End Sub
See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


FieldCollection Class Properties

FieldCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : FieldCollection Class

For a list of all members of this type, see FieldCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the FieldCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the FieldCollection instance. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Gets or sets the element at the specified index.
Top
See Also

Reference

FieldCollection Class
GrapeCity.ActiveReports.Data Namespace
DataInitialize Event
FetchData Event


Item Property (FieldCollection)

Item Property (FieldCollection)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : Item Property
Gets or sets the element at the specified index.
Gets the specified field object from the collection.
Overload List
Overload | Description
Item(Int32) | Gets the Field object at the specified indexed location in the FieldCollection.
Item(String) | Gets the Field object with the specified name in the FieldCollection.
Remarks
This is the default property for the FieldCollection.
Example
  • C#
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    System.Windows.Forms.MessageBox.Show (this.Fields[1].Name.ToString());
}
  • Visual Basic
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
  MessageBox.Show(Me.Fields.Item(1).Name.ToString)
End Sub
See Also

Reference

FieldCollection Class
FieldCollection Members


Item(Int32) Property

Item(Int32) Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Item Property : Item(Int32) Property
The indexed location of the Field in the collection.
Gets the Field object at the specified indexed location in the FieldCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal index As System.Integer _
) As Field
public Field Item(
   System.int index
) {get;}

Parameters

index
The indexed location of the Field in the collection.
Example
  • C#
private void UnboundGrp_DataInitialize(object sender, System.EventArgs eArgs)
{
    Fields.Add("CategoryID");
    Fields.Add("CategoryName");
    Fields.Add("ProductName");
    Fields.Add("UnitsInStock");
    Fields.Add("Description");
    Fields.Add("TotalLabel");
    System.Windows.Forms.MessageBox.Show (this.Fields[1].Name.ToString());
}
  • Visual Basic
Private Sub rptUnboundGrp_DataInitialize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.DataInitialize
  Fields.Add("CategoryID")
  Fields.Add("CategoryName")
  Fields.Add("ProductName")
  Fields.Add("UnitsInStock")
  Fields.Add("Description")
  Fields.Add("TotalLabel")
  MsgBox(Me.Fields.Item(1).Name.ToString)
End Sub
See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


Item(String) Property

Item(String) Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class > Item Property : Item(String) Property
The name of the Field in the collection.
Gets the Field object with the specified name in the FieldCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal fieldName As System.String _
) As Field
public Field Item(
   System.string fieldName
) {get;}

Parameters

fieldName
The name of the Field in the collection.
Example
  • C#
private void UnboundGrp_FetchData(object sender, GrapeCity.ActiveReports.ActiveReport.FetchEventArgs eArgs)
{
    try
    {
        m_reader.Read();
        Fields["CategoryID"].Value = m_reader["categories.CategoryID"].ToString();
        Fields["CategoryName"].Value = m_reader["CategoryName"].ToString();
        Fields["ProductName"].Value = m_reader["ProductName"].ToString();
        Fields["UnitsInStock"].Value = m_reader["UnitsInStock"].ToString();
        Fields["Description"].Value = m_reader["Description"].ToString();
        Fields["TotalLabel"].Value = "Total Number of " + m_reader["CategoryName"].ToString() + ":";
        eArgs.EOF = false;
    }
    catch
    {
        eArgs.EOF = true;
    }
    //Item is the default property for Fields
    System.Windows.Forms.MessageBox.Show (this.Fields["Description"].Value.ToString());
}
  • Visual Basic
Private Sub rptUnboundGrp_FetchData(ByVal sender As Object, ByVal eArgs As GrapeCity.ActiveReports.ActiveReport. _
    FetchEventArgs) Handles MyBase.FetchData
  Try    m_reader.Read()
    Me.Fields("CategoryID").Value = m_reader("categories.CategoryID")
    Me.Fields("CategoryName").Value = m_reader("CategoryName")
    Me.Fields("ProductName").Value = m_reader("ProductName")
    Me.Fields("UnitsInStock").Value = m_reader("UnitsInStock")
    Me.Fields("Description").Value = m_reader("Description")
    Me.Fields("TotalLabel").Value = "Total Number of " + m_reader("CategoryName") + ":"
    eArgs.EOF = False
  Catch ex As Exception
    System.Windows.Forms.MessageBox.Show(ex.ToString())
    eArgs.EOF = True
  End Try
  MsgBox(Me.Fields.Item("Description").Value.ToString)
End Sub
See Also

Reference

FieldCollection Class
FieldCollection Members
Overload List


ListDataSource Class

ListDataSource Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : ListDataSource Class
Represents a section report data source based on the IDataRecord and IDataReader members of the .NET Framework.
Object Model
ListDataSource Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ListDataSource
public class ListDataSource
Remarks
This class uses the IList interface to bind data from a custom object or a RowCollection to the report. The interface determines the structure of the data, so that the user needs no additional code to structure it.
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.ListDataSource

See Also

Reference

ListDataSource Members
GrapeCity.ActiveReports.Data Namespace


ListDataSource Class Members

ListDataSource Class Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : ListDataSource Class

The following tables list the members exposed by ListDataSource.

Public Constructors
 | Name | Description
Public Constructor | ListDataSource Constructor | Initializes a new instance of the ListDataSource class.
Top
See Also

Reference

ListDataSource Class
GrapeCity.ActiveReports.Data Namespace


ListDataSource Constructor

ListDataSource Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > ListDataSource Class : ListDataSource Constructor
System.Collections.IList
Initializes a new instance of the ListDataSource class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal list As System.Collections.IList _
)
public ListDataSource(
   System.Collections.IList list
)

Parameters

list
System.Collections.IList
See Also

Reference

ListDataSource Class
ListDataSource Members


OdbcDataSource Class

OdbcDataSource Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : OdbcDataSource Class
ODBC data source - allows to connect through ODBC driver.
Object Model
OdbcDataSource Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class OdbcDataSource
public sealed class OdbcDataSource
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.OdbcDataSource

See Also

Reference

OdbcDataSource Members
GrapeCity.ActiveReports.Data Namespace


OdbcDataSource Class Members

OdbcDataSource Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : OdbcDataSource Class

The following tables list the members exposed by OdbcDataSource.

Public Constructors
 | Name | Description
Public Constructor | OdbcDataSource Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | CommandTimeout | Gets or sets current commant timeout.
Public Property | ConnectionString | Gets or sets connection string.
Public Property | SQL | Gets or sets current command text
Top
See Also

Reference

OdbcDataSource Class
GrapeCity.ActiveReports.Data Namespace


OdbcDataSource Constructor

OdbcDataSource Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > OdbcDataSource Class : OdbcDataSource Constructor
Overload List
Overload | Description
OdbcDataSource Constructor() | Default ctor. By default, connection string and command text are empty strings, and command timeout is DefaultTimeout
OdbcDataSource Constructor(String,String,Int32) | Initializes a new instance of the OdbcDataSource class.
See Also

Reference

OdbcDataSource Class
OdbcDataSource Members


OdbcDataSource Constructor()

OdbcDataSource Constructor()

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > OdbcDataSource Class > OdbcDataSource Constructor : OdbcDataSource Constructor()
Default ctor. By default, connection string and command text are empty strings, and command timeout is DefaultTimeout
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public OdbcDataSource()
See Also

Reference

OdbcDataSource Class
OdbcDataSource Members
Overload List


OdbcDataSource Constructor(String,String,Int32)

OdbcDataSource Constructor(String,String,Int32)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > OdbcDataSource Class > OdbcDataSource Constructor : OdbcDataSource Constructor(String,String,Int32)
Initializes a new instance of the OdbcDataSource class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal connectionString As System.String, _
   ByVal sql As System.String, _
   ByVal timeout As System.Integer _
)
public OdbcDataSource(
   System.string connectionString,
   System.string sql,
   System.int timeout
)

Parameters

connectionString
sql
timeout
See Also

Reference

OdbcDataSource Class
OdbcDataSource Members
Overload List


OdbcDataSource Class Properties

OdbcDataSource Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : OdbcDataSource Class

For a list of all members of this type, see OdbcDataSource members.

Public Properties
 | Name | Description
Public Property | CommandTimeout | Gets or sets current commant timeout.
Public Property | ConnectionString | Gets or sets connection string.
Public Property | SQL | Gets or sets current command text
Top
See Also

Reference

OdbcDataSource Class
GrapeCity.ActiveReports.Data Namespace


CommandTimeout Property (OdbcDataSource)

CommandTimeout Property (OdbcDataSource)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > OdbcDataSource Class : CommandTimeout Property
Gets or sets current commant timeout.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CommandTimeout As System.Integer
public System.int CommandTimeout {get; set;}
See Also

Reference

OdbcDataSource Class
OdbcDataSource Members


ConnectionString Property (OdbcDataSource)

ConnectionString Property (OdbcDataSource)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > OdbcDataSource Class : ConnectionString Property
Gets or sets connection string.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ConnectionString As System.String
public System.string ConnectionString {get; set;}
See Also

Reference

OdbcDataSource Class
OdbcDataSource Members


SQL Property (OdbcDataSource)

SQL Property (OdbcDataSource)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > OdbcDataSource Class : SQL Property
Gets or sets current command text
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SQL As System.String
public System.string SQL {get; set;}
See Also

Reference

OdbcDataSource Class
OdbcDataSource Members


OleDBDataSource Class

OleDBDataSource Class
Members Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : OleDBDataSource Class
Represents a section report data source based on the OleDb ADO.NET data provider.
Object Model
OleDBDataSource Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class OleDBDataSource
public sealed class OleDBDataSource
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    rptSub rpt = New rptSubBM();
    GrapeCity.ActiveReports.Data.OleDBDataSource subDS = new GrapeCity.ActiveReports.Data.OleDBDataSource();
    subDS.ConnectionString = ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).ConnectionString;
    subDS.SQL = "Select * from products where categoryID = " + m_categoryID;
    rpt.DataSource = subDS;
    ctlSubReport.Report = rpt;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Dim rpt As New rptSubBM()
    Dim subDS As New GrapeCity.ActiveReports.Data.OleDBDataSource()
    subDS.ConnectionString = CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString
    subDS.SQL = "Select * from products where categoryID = " + m_categoryID    rpt.DataSource = subDS
    Me.ctlSubreport.Report = rpt
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.OleDBDataSource

See Also

Reference

OleDBDataSource Members
GrapeCity.ActiveReports.Data Namespace


OleDBDataSource Class Members

OleDBDataSource Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : OleDBDataSource Class

The following tables list the members exposed by OleDBDataSource.

Public Constructors
 | Name | Description
Public Constructor | OleDBDataSource Constructor | Overloaded. Initializes a new instance of the OleDBDataSource class.
Top
Public Properties
 | Name | Description
Public Property | CommandTimeout | Sets or returns the amount of time to wait while executing a command before terminating the attempt and generating an error.
Public Property | ConnectionString | Specifies the string used to open a connection to the data source using the OleDb data provider.
Public Property | SQL | Specifies a valid SQL statement used to retrieve records from the data source.
Top
See Also

Reference

OleDBDataSource Class
GrapeCity.ActiveReports.Data Namespace


OleDBDataSource Constructor

OleDBDataSource Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > OleDBDataSource Class : OleDBDataSource Constructor
Initializes a new instance of the OleDBDataSource class.
Initializes a new instance of the OleDbDataSource class.
Overload List
Overload | Description
OleDBDataSource Constructor() | Initializes a new instance of the OleDbDataSource class. By default, the connection string and command text are empty strings; the command timeout is DefaultTimeout.
OleDBDataSource Constructor(String,String,Int32) | Initializes a new instance of the OleDbDataSource class.
See Also

Reference

OleDBDataSource Class
OleDBDataSource Members


OleDBDataSource Constructor()

OleDBDataSource Constructor()

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > OleDBDataSource Class > OleDBDataSource Constructor : OleDBDataSource Constructor()
Initializes a new instance of the OleDbDataSource class. By default, the connection string and command text are empty strings; the command timeout is DefaultTimeout.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public OleDBDataSource()
See Also

Reference

OleDBDataSource Class
OleDBDataSource Members
Overload List


OleDBDataSource Constructor(String,String,Int32)

OleDBDataSource Constructor(String,String,Int32)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > OleDBDataSource Class > OleDBDataSource Constructor : OleDBDataSource Constructor(String,String,Int32)
The connection used to open the database.
The text of the query.
The wait time before terminating an attempt to execute a command.
Initializes a new instance of the OleDbDataSource class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal connectionString As System.String, _
   ByVal sql As System.String, _
   ByVal timeout As System.Integer _
)
public OleDBDataSource(
   System.string connectionString,
   System.string sql,
   System.int timeout
)

Parameters

connectionString
The connection used to open the database.
sql
The text of the query.
timeout
The wait time before terminating an attempt to execute a command.
See Also

Reference

OleDBDataSource Class
OleDBDataSource Members
Overload List


OleDBDataSource Class Properties

OleDBDataSource Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : OleDBDataSource Class

For a list of all members of this type, see OleDBDataSource members.

Public Properties
 | Name | Description
Public Property | CommandTimeout | Sets or returns the amount of time to wait while executing a command before terminating the attempt and generating an error.
Public Property | ConnectionString | Specifies the string used to open a connection to the data source using the OleDb data provider.
Public Property | SQL | Specifies a valid SQL statement used to retrieve records from the data source.
Top
See Also

Reference

OleDBDataSource Class
GrapeCity.ActiveReports.Data Namespace


CommandTimeout Property (OleDBDataSource)

CommandTimeout Property (OleDBDataSource)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > OleDBDataSource Class : CommandTimeout Property
Sets or returns the amount of time to wait while executing a command before terminating the attempt and generating an error.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CommandTimeout As System.Integer
public System.int CommandTimeout {get; set;}
Remarks
When using this property with the OleDBDataSource, you need to verify with the provider that it supports the command timeout settings. Some of them do not. This is provider-specific, so we are unable to provide a list of working providers.
Example
  • C#
private void detail1_Format(object sender, System.EventArgs eArgs)
{
    rptSubBM rpt = new rptSubBM();
    GrapeCity.ActiveReports.Data.OleDBDataSource subDS = new GrapeCity.ActiveReports.Data.OleDBDataSource();
    subDS.CommandTimeout = 30;
    subDS.ConnectionString = ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).ConnectionString;
    subDS.SQL = "Select * from products where categoryID = " + m_categoryID;
    rpt.DataSource = subDS;
    ctlSubReport.Report = rpt;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Dim rpt As New rptSubBM()
    Dim subDS As New GrapeCity.ActiveReports.Data.OleDBDataSource()
    subDS.CommandTimeout = 30
    subDS.ConnectionString = CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString
    subDS.SQL = "Select * from products where categoryID = " + m_categoryID
    rpt.DataSource = subDS
    Me.ctlSubreport.Report = rpt
End Sub
See Also

Reference

OleDBDataSource Class
OleDBDataSource Members


ConnectionString Property (OleDBDataSource)

ConnectionString Property (OleDBDataSource)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > OleDBDataSource Class : ConnectionString Property
Specifies the string used to open a connection to the data source using the OleDb data provider.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ConnectionString As System.String
public System.string ConnectionString {get; set;}
Example
  • C#
private void detail1_Format(object sender, System.EventArgs eArgs)
{
    rptSubBM rpt = new rptSubBM();
    GrapeCity.ActiveReports.Data.OleDBDataSource subDS = new GrapeCity.ActiveReports.Data.OleDBDataSource();
    subDS.ConnectionString = ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).ConnectionString;
    subDS.SQL = "Select * from products where categoryID = " + m_categoryID;
    rpt.DataSource = subDS;
    ctlSubReport.Report = rpt;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Dim rpt As New rptSubBM()
    Dim subDS As New GrapeCity.ActiveReports.Data.OleDBDataSource()
    subDS.ConnectionString = CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString
    subDS.SQL = "Select * from products where categoryID = " + m_categoryID    rpt.DataSource = subDS
    Me.ctlSubreport.Report = rpt
End Sub
See Also

Reference

OleDBDataSource Class
OleDBDataSource Members


SQL Property (OleDBDataSource)

SQL Property (OleDBDataSource)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > OleDBDataSource Class : SQL Property
Specifies a valid SQL statement used to retrieve records from the data source.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SQL As System.String
public System.string SQL {get; set;}
Remarks

ActiveReports creates a DataReader and uses it to load the data into the report.

The SQL string may contain parameter placeholder syntax to fill the report's parameters collection and prompt the user to enter their values before executing the report.

Example
  • C#
private void detail1_Format(object sender, System.EventArgs eArgs)
{
    rptSubBM rpt = new rptSubBM();
    GrapeCity.ActiveReports.Data.OleDBDataSource subDS = new GrapeCity.ActiveReports.Data.OleDBDataSource();
    subDS.ConnectionString = ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).ConnectionString;
    subDS.SQL = "Select * from products where categoryID = " + m_categoryID;
    rpt.DataSource = subDS;
    ctlSubReport.Report = rpt;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Dim rpt As New rptSubBM()
    Dim subDS As New GrapeCity.ActiveReports.Data.OleDBDataSource()
    subDS.ConnectionString = CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString
    subDS.SQL = "Select * from products where categoryID = " + m_categoryID    rpt.DataSource = subDS
    Me.ctlSubreport.Report = rpt
End Sub
See Also

Reference

OleDBDataSource Class
OleDBDataSource Members
Parameters Property


SqlDBDataSource Class

SqlDBDataSource Class
Members Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : SqlDBDataSource Class
Represents a section report data source based on the SqlDB ADO.NET data provider.
Object Model
SqlDBDataSource Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class SqlDBDataSource
public sealed class SqlDBDataSource
Example
  • C#
private void rpt_ReportStart(object sender, System.EventArgs eArgs)
{
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).ConnectionString = @"Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks2000;Data Source=TESTING";
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).CommandTimeout = 30;
    System.IO.StringReader sr = new System.IO.StringReader(new System.IO.StreamReader("..\\..\\sqlString.txt").ReadToEnd());
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).SQL = sr.ReadToEnd();
    sr.Close();
}
  • Visual Basic
Private Sub rpt_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).CommandTimeout = 30
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString = "Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks2000;Data Source=TESTING"
    Dim sr As New System.IO.StringReader(New System.IO.StreamReader("..\\..\\sqlString.txt").ReadToEnd())
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).SQL = sr.ReadToEnd
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.SqlDBDataSource

See Also

Reference

SqlDBDataSource Members
GrapeCity.ActiveReports.Data Namespace


SqlDBDataSource Class Members

SqlDBDataSource Class Members
Fields Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : SqlDBDataSource Class

The following tables list the members exposed by SqlDBDataSource.

Public Constructors
 | Name | Description
Public Constructor | SqlDBDataSource Constructor | Overloaded.
Top
Public Fields
 | Name | Description
Public Field | DefaultTimeout | Sets or returns the number of seconds to wait for a connection to open, before canceling the attempt and generate an error.
Top
Public Properties
 | Name | Description
Public Property | CommandTimeout | Sets or returns the amount of time to wait while executing a command before terminating the attempt and generating an error.
Public Property | ConnectionString | Specifies the string used to open a connection to the data source using the SqlDb data provider.
Public Property | SQL | Specifies a valid SQL statement used to retrieve records from the data source.
Top
See Also

Reference

SqlDBDataSource Class
GrapeCity.ActiveReports.Data Namespace


SqlDBDataSource Constructor

SqlDBDataSource Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > SqlDBDataSource Class : SqlDBDataSource Constructor
Initializes a new instance of the SqlDBDataSource class.
Overload List
Overload | Description
SqlDBDataSource Constructor() | Initializes a new instance of the SqlDBDataSource class.
SqlDBDataSource Constructor(String,String,Int32) | Initializes a new instance of the SqlDBDataSource class with the specified parameters.
See Also

Reference

SqlDBDataSource Class
SqlDBDataSource Members


SqlDBDataSource Constructor()

SqlDBDataSource Constructor()

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > SqlDBDataSource Class > SqlDBDataSource Constructor : SqlDBDataSource Constructor()
Initializes a new instance of the SqlDBDataSource class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public SqlDBDataSource()
See Also

Reference

SqlDBDataSource Class
SqlDBDataSource Members
Overload List


SqlDBDataSource Constructor(String,String,Int32)

SqlDBDataSource Constructor(String,String,Int32)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > SqlDBDataSource Class > SqlDBDataSource Constructor : SqlDBDataSource Constructor(String,String,Int32)
The connection used to open the database.
The text of the query.
The wait time before terminating an attempt to execute a command.
Initializes a new instance of the SqlDBDataSource class with the specified parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal connectionString As System.String, _
   ByVal sql As System.String, _
   ByVal timeout As System.Integer _
)
public SqlDBDataSource(
   System.string connectionString,
   System.string sql,
   System.int timeout
)

Parameters

connectionString
The connection used to open the database.
sql
The text of the query.
timeout
The wait time before terminating an attempt to execute a command.
See Also

Reference

SqlDBDataSource Class
SqlDBDataSource Members
Overload List


SqlDBDataSource Class Properties

SqlDBDataSource Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : SqlDBDataSource Class

For a list of all members of this type, see SqlDBDataSource members.

Public Properties
 | Name | Description
Public Property | CommandTimeout | Sets or returns the amount of time to wait while executing a command before terminating the attempt and generating an error.
Public Property | ConnectionString | Specifies the string used to open a connection to the data source using the SqlDb data provider.
Public Property | SQL | Specifies a valid SQL statement used to retrieve records from the data source.
Top
See Also

Reference

SqlDBDataSource Class
GrapeCity.ActiveReports.Data Namespace


CommandTimeout Property (SqlDBDataSource)

CommandTimeout Property (SqlDBDataSource)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > SqlDBDataSource Class : CommandTimeout Property
Sets or returns the amount of time to wait while executing a command before terminating the attempt and generating an error.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CommandTimeout As System.Integer
public System.int CommandTimeout {get; set;}
Example
  • C#
Private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).ConnectionString = @"Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks2000;Data Source=TESTING";
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).CommandTimeout = 30;
    System.IO.StringReader sr = new System.IO.StringReader(new System.IO.StreamReader("..\\..\\sqlString.txt").ReadToEnd());
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).SQL = sr.ReadToEnd();
    sr.Close();
}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).CommandTimeout = 30
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString = "Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks2000;Data Source=TESTING"
    Dim sr As New System.IO.StringReader(New System.IO.StreamReader("..\\..\\sqlString.txt").ReadToEnd())
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).SQL = sr.ReadToEnd
End Sub
See Also

Reference

SqlDBDataSource Class
SqlDBDataSource Members


ConnectionString Property (SqlDBDataSource)

ConnectionString Property (SqlDBDataSource)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > SqlDBDataSource Class : ConnectionString Property
Specifies the string used to open a connection to the data source using the SqlDb data provider.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ConnectionString As System.String
public System.string ConnectionString {get; set;}
Example
  • C#
Private void rpt_ReportStart(object sender, System.EventArgs eArgs)
{
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).ConnectionString = @"Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks2000;Data Source=TESTING";
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).CommandTimeout = 30;
    System.IO.StringReader sr = new System.IO.StringReader(new System.IO.StreamReader("..\\..\\sqlString.txt").ReadToEnd());
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).SQL = sr.ReadToEnd();
    sr.Close();
}
  • Visual Basic
Private Sub rpt_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).CommandTimeout = 30
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString = "Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks2000;Data Source=TESTING"
    Dim sr As New System.IO.StringReader(New System.IO.StreamReader("..\\..\\sqlString.txt").ReadToEnd())
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).SQL = sr.ReadToEnd
End Sub
See Also

Reference

SqlDBDataSource Class
SqlDBDataSource Members


SQL Property (SqlDBDataSource)

SQL Property (SqlDBDataSource)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > SqlDBDataSource Class : SQL Property
Specifies a valid SQL statement used to retrieve records from the data source.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SQL As System.String
public System.string SQL {get; set;}
Remarks

ActiveReports creates a DataReader and uses it to load the data into the report.

The SQL string may contain parameter placeholder syntax to fill the report's parameters collection and prompt the user to enter their values before executing the report.

Example
  • C#
Private void rpt_ReportStart(object sender, System.EventArgs eArgs)
{
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).ConnectionString = @"Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks2000;Data Source=TESTING";
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).CommandTimeout = 30;
    System.IO.StringReader sr = new System.IO.StringReader(new System.IO.StreamReader("..\\..\\sqlString.txt").ReadToEnd());
    ((GrapeCity.ActiveReports.Data.OleDBDataSource)(this.DataSource)).SQL = sr.ReadToEnd();
    sr.Close();
}
  • Visual Basic
Private Sub rpt_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).CommandTimeout = 30
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).ConnectionString = "Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=AdventureWorks2000;Data Source=TESTING"
    Dim sr As New System.IO.StringReader(New System.IO.StreamReader("..\\..\\sqlString.txt").ReadToEnd())
    CType(Me.DataSource, GrapeCity.ActiveReports.Data.OleDBDataSource).SQL = sr.ReadToEnd
End Sub
See Also

Reference

SqlDBDataSource Class
SqlDBDataSource Members
Parameters Property


SqlDBDataSource Class Fields

SqlDBDataSource Class Fields

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : SqlDBDataSource Class

For a list of all members of this type, see SqlDBDataSource members.

Public Fields
 | Name | Description
Public Field | DefaultTimeout | Sets or returns the number of seconds to wait for a connection to open, before canceling the attempt and generate an error.
Top
See Also

Reference

SqlDBDataSource Class
GrapeCity.ActiveReports.Data Namespace


DefaultTimeout Field

DefaultTimeout Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > SqlDBDataSource Class : DefaultTimeout Field
Sets or returns the number of seconds to wait for a connection to open, before canceling the attempt and generate an error.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const DefaultTimeout As System.Integer
public const System.int DefaultTimeout
See Also

Reference

SqlDBDataSource Class
SqlDBDataSource Members


XMLDataSource Class

XMLDataSource Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : XMLDataSource Class
Represents a section report data source based on an XML document and an XPath pattern to select the XML nodes used as records in the data source.
Object Model
XMLDataSource Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class XMLDataSource
public sealed class XMLDataSource
Remarks

ActiveReports supports a DataType attribute for nodes in the XML file. This attribute helps ActiveReports determine the data type of bound fields. Valid values include: double, datetime and string.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Data.XMLDataSource

See Also

Reference

XMLDataSource Members
GrapeCity.ActiveReports.Data Namespace


XMLDataSource Class Members

XMLDataSource Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : XMLDataSource Class

The following tables list the members exposed by XMLDataSource.

Public Constructors
 | Name | Description
Public Constructor | XMLDataSource Constructor | Overloaded. Initializes a new instance of the XMLDataSource class.
Top
Public Properties
 | Name | Description
Public Property | BOF | Determines whether the CurrentPosition is at the first node in the NodeList.
Public Property | Count | Gets the number of nodes (records) in the node list.
Public Property | CurrentPosition | Gets the index of the current node in the NodeList.
Public Property | Document | Returns a reference to the loaded XmlDocument that is used as the data source.
Public Property | EOF | Determines whether the CurrentPosition is at the end of the NodeList.
Public Property | FileURL | Gets or sets the file name or url used to retrieve the XML document to be used as a data source.
Public Property | NodeList | Gets or sets a reference to the XmlNodeList object that is the result of applying the XPath pattern provided in the RecordsetPattern property.
Public Property | RecordsetPattern | Gets or sets a valid XPath pattern used to select the data source nodes to be printed in the report.
Public Property | ValidateOnParse | Gets or sets a value that determines whether the retrieved XmlDocument should be validated while parsing.
Top
Public Methods
 | Name | Description
Public Method | Field | Overloaded. Returns the XML node or nodelist using the specified XPath pattern relative to the current node (record).
Public Method | LoadXML | Loads an XML fragment from a string.
Public Method | MoveFirst | Moves the current position to the first node in the NodeList.
Public Method | MoveNext | Moves the CurrentPosition to the next node in the NodeList.
Top
See Also

Reference

XMLDataSource Class
GrapeCity.ActiveReports.Data Namespace


XMLDataSource Constructor

XMLDataSource Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : XMLDataSource Constructor
Initializes a new instance of the XMLDataSource class.
Overload List
Overload | Description
XMLDataSource Constructor() | Initializes a new instance of the XMLDataSource class.
XMLDataSource Constructor(String,String) | Initializes a new instance of the XMLDataSource class.
See Also

Reference

XMLDataSource Class
XMLDataSource Members


XMLDataSource Constructor()

XMLDataSource Constructor()

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class > XMLDataSource Constructor : XMLDataSource Constructor()
Initializes a new instance of the XMLDataSource class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public XMLDataSource()
See Also

Reference

XMLDataSource Class
XMLDataSource Members
Overload List


XMLDataSource Constructor(String,String)

XMLDataSource Constructor(String,String)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class > XMLDataSource Constructor : XMLDataSource Constructor(String,String)
The path to the XML file.
The Xpath expression that specifies the record pattern.
Initializes a new instance of the XMLDataSource class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal fileUrl As System.String, _
   ByVal recordsetPattern As System.String _
)
public XMLDataSource(
   System.string fileUrl,
   System.string recordsetPattern
)

Parameters

fileUrl
The path to the XML file.
recordsetPattern
The Xpath expression that specifies the record pattern.
See Also

Reference

XMLDataSource Class
XMLDataSource Members
Overload List


XMLDataSource Class Methods

XMLDataSource Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : XMLDataSource Class

For a list of all members of this type, see XMLDataSource members.

Public Methods
 | Name | Description
Public Method | Field | Overloaded. Returns the XML node or nodelist using the specified XPath pattern relative to the current node (record).
Public Method | LoadXML | Loads an XML fragment from a string.
Public Method | MoveFirst | Moves the current position to the first node in the NodeList.
Public Method | MoveNext | Moves the CurrentPosition to the next node in the NodeList.
Top
See Also

Reference

XMLDataSource Class
GrapeCity.ActiveReports.Data Namespace


Field Method

Field Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : Field Method
Returns the XML node or nodelist using the specified XPath pattern relative to the current node (record).
Overload List
Overload | Description
Field(String,Boolean) | Returns the XML node or nodelist using the specified XPath pattern relative to the current node.
Field(String,Boolean,Boolean) | Returns the XML node or nodelist using the specified XPath pattern relative to the current node. The isOutputformatNull flag specifies whether to use the text of the current node.
Example
Paste into the Detail Format event.
  • C#
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();
SectionReport1 rpt = new SectionReport1();

    xDS.ValidateOnParse = true;
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml";
    xDS.RecordsetPattern = "//ITEM";
    xDS.NodeList = (System.Xml.XmlNodeList)xDS.Field("ITEM",true);
    this.Label1.Text = xDS.CurrentPosition;
    Console.WriteLine(xDS.Count.ToString());

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
  • Visual Basic
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()
Dim rpt As New SectionReport1()

    xDS.ValidateOnParse = True
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml"
    xDS.RecordsetPattern = "//ITEM"
    xDS.NodeList = xDS.Field("ITEM", True)
    Me.Label1.Text = xDS.CurrentPosition
    Console.WriteLine(xDS.Count.ToString())

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If
See Also

Reference

XMLDataSource Class
XMLDataSource Members


Field(String,Boolean) Method

Field(String,Boolean) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class > Field Method : Field(String,Boolean) Method
The Xpath expression relative to the current node.
Specifies whether the returned value should be the list of the nodes.
Returns the XML node or nodelist using the specified XPath pattern relative to the current node.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Field( _
   ByVal name As System.String, _
   ByVal asNodeList As System.Boolean _
) As System.Object
public System.object Field(
   System.string name,
   System.bool asNodeList
)

Parameters

name
The Xpath expression relative to the current node.
asNodeList
Specifies whether the returned value should be the list of the nodes.
See Also

Reference

XMLDataSource Class
XMLDataSource Members
Overload List


Field(String,Boolean,Boolean) Method

Field(String,Boolean,Boolean) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class > Field Method : Field(String,Boolean,Boolean) Method
The Xpath expression relative to the current node.
Specifies whether the returned value should be the list of the nodes.
Specifies whether to use the text of the current node.
Returns the XML node or nodelist using the specified XPath pattern relative to the current node. The isOutputformatNull flag specifies whether to use the text of the current node.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Field( _
   ByVal name As System.String, _
   ByVal asNodeList As System.Boolean, _
   ByVal isOutputformatNull As System.Boolean _
) As System.Object
public System.object Field(
   System.string name,
   System.bool asNodeList,
   System.bool isOutputformatNull
)

Parameters

name
The Xpath expression relative to the current node.
asNodeList
Specifies whether the returned value should be the list of the nodes.
isOutputformatNull
Specifies whether to use the text of the current node.
See Also

Reference

XMLDataSource Class
XMLDataSource Members
Overload List


LoadXML Method

LoadXML Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : LoadXML Method
Specifies a valid XML fragment string to be loaded into the XML document.
Loads an XML fragment from a string.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub LoadXML( _
   ByVal xmlFragment As System.String _
)
public void LoadXML(
   System.string xmlFragment
)

Parameters

xmlFragment
Specifies a valid XML fragment string to be loaded into the XML document.
Remarks

The XML is parsed and used as the XML document source.

Example
Paste into the ReportStart event.
  • C#
GrapeCity.ActiveReports.Data.XMLDataSource ds = new GrapeCity.ActiveReports.Data.XMLDataSource();
    ds.ValidateOnParse = true;
    ds.FileURL = null;
    ds.RecordsetPattern = "//Customer";
    ds.LoadXML("<Order><Customer><Name>John Doe</Name><Cardnum>131 131 131 131</Cardnum><Manifest><Item><ID>204</ID><Title>Advanced VB</Title><Quantity>1</Quantity><UnitPrice>$10.75</UnitPrice></Item></Manifest><Receipt><Subtotal>$23.75</Subtotal><Tax>$2.43</Tax></Receipt></Customer></Order>");
Paste into the ReportStart event.
  • Visual Basic
Dim ds As New GrapeCity.ActiveReports.Data.XMLDataSource
    ds.FileURL = Nothing
    ds.ValidateOnParse = True
    ds.RecordsetPattern = "//Customer"
    ds.LoadXML("<Order>" & _
        "<Customer>" & _
        "<Name>John Doe</Name>" & _
        "<Cardnum>131 131 131 131</Cardnum>" & _
        "<Manifest>" & _
        "<Item>" & _
        "<ID>204</ID>" & _
        "<Title>Advanced VB</Title>" & _
        "<Quantity>1</Quantity>" & _
        "<UnitPrice>$10.75</UnitPrice>" & _
        "</Item>" & _
        "</Manifest>" & _
        "<Receipt>" & _
        "<Subtotal>$23.75</Subtotal>" & _
        "<Tax>$2.43</Tax>" & _
        "</Receipt>" & _
        "</Customer>" & _
        "</Order>")
See Also

Reference

XMLDataSource Class
XMLDataSource Members


MoveFirst Method

MoveFirst Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : MoveFirst Method
Moves the current position to the first node in the NodeList.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub MoveFirst()
public void MoveFirst()
See Also

Reference

XMLDataSource Class
XMLDataSource Members


MoveNext Method (XMLDataSource)

MoveNext Method (XMLDataSource)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : MoveNext Method
Moves the CurrentPosition to the next node in the NodeList.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub MoveNext()
public void MoveNext()
See Also

Reference

XMLDataSource Class
XMLDataSource Members


XMLDataSource Class Properties

XMLDataSource Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : XMLDataSource Class

For a list of all members of this type, see XMLDataSource members.

Public Properties
 | Name | Description
Public Property | BOF | Determines whether the CurrentPosition is at the first node in the NodeList.
Public Property | Count | Gets the number of nodes (records) in the node list.
Public Property | CurrentPosition | Gets the index of the current node in the NodeList.
Public Property | Document | Returns a reference to the loaded XmlDocument that is used as the data source.
Public Property | EOF | Determines whether the CurrentPosition is at the end of the NodeList.
Public Property | FileURL | Gets or sets the file name or url used to retrieve the XML document to be used as a data source.
Public Property | NodeList | Gets or sets a reference to the XmlNodeList object that is the result of applying the XPath pattern provided in the RecordsetPattern property.
Public Property | RecordsetPattern | Gets or sets a valid XPath pattern used to select the data source nodes to be printed in the report.
Public Property | ValidateOnParse | Gets or sets a value that determines whether the retrieved XmlDocument should be validated while parsing.
Top
See Also

Reference

XMLDataSource Class
GrapeCity.ActiveReports.Data Namespace


BOF Property

BOF Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : BOF Property
Determines whether the CurrentPosition is at the first node in the NodeList.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property BOF As System.Boolean
public System.bool BOF {get;}

Property Value

Boolean. True if the CurrentPostion is at the first node in the NodeList; otherwise, False.

Example
Paste into the Detail Format event.
  • C#
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
  • Visual Basic
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If
See Also

Reference

XMLDataSource Class
XMLDataSource Members


Count Property (XMLDataSource)

Count Property (XMLDataSource)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : Count Property
Gets the number of nodes (records) in the node list.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}

Property Value

Integer.
Example
Paste into the Detail Format event.
  • C#
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();
SectionReport1 rpt = new SectionReport1();

    xDS.ValidateOnParse = true;
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml";
    xDS.RecordsetPattern = "//ITEM";
    xDS.NodeList = (System.Xml.XmlNodeList)ds.Field("ITEM",true);
    this.Label1.Text = xDS.CurrentPosition;
    Console.WriteLine(xDS.Count.ToString());

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
  • Visual Basic
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()
Dim rpt As New SectionReport1()

    xDS.ValidateOnParse = True
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml"
    xDS.RecordsetPattern = "//ITEM"
    xDS.NodeList = xDS.Field("ITEM", True)
    Me.Label1.Text = xDS.CurrentPosition
    Console.WriteLine(xDS.Count.ToString())

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If
See Also

Reference

XMLDataSource Class
XMLDataSource Members


CurrentPosition Property

CurrentPosition Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : CurrentPosition Property
Gets the index of the current node in the NodeList.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CurrentPosition As System.Integer
public System.int CurrentPosition {get;}

Property Value

A long value that represents the current node in the NodeList.

Example
Paste into the Detail Format event.
  • C#
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();
SectionReport1 rpt = new SectionReport1();

    xDS.ValidateOnParse = true;
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml";
    xDS.RecordsetPattern = "//ITEM";
    xDS.NodeList = (System.Xml.XmlNodeList)ds.Field("ITEM",true);
    this.Label1.Text = xDS.CurrentPosition;
    Console.WriteLine(xDS.Count.ToString());

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
  • Visual Basic
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()
Dim rpt As New SectionReport1()

    xDS.ValidateOnParse = True
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml"
    xDS.RecordsetPattern = "//ITEM"
    xDS.NodeList = xDS.Field("ITEM", True)
    Me.Label1.Text = xDS.CurrentPosition
    Console.WriteLine(xDS.Count.ToString())

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If
See Also

Reference

XMLDataSource Class
XMLDataSource Members


Document Property (XMLDataSource)

Document Property (XMLDataSource)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : Document Property
Returns a reference to the loaded XmlDocument that is used as the data source.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Document As System.Xml.XmlDocument
public System.Xml.XmlDocument Document {get;}
Example
  • C#
Private void rpt_ReportStart(object sender, System.EventArgs eArgs)
{
    System.Windows.Forms.MessageBox.Show (this.ds.Document.BaseURI.ToString());
}
  • Visual Basic
Private Sub rpt_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    MsgBox(Me.ds.Document.BaseURI.ToString)
End Sub
See Also

Reference

XMLDataSource Class
XMLDataSource Members


EOF Property (XMLDataSource)

EOF Property (XMLDataSource)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : EOF Property

Determines whether the CurrentPosition is at the end of the NodeList.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property EOF As System.Boolean
public System.bool EOF {get;}
Example
Paste into the Detail Format event.
  • C#
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
  • Visual Basic
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()
Dim rpt As New SectionReport1()

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If
See Also

Reference

XMLDataSource Class
XMLDataSource Members


FileURL Property

FileURL Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : FileURL Property
Gets or sets the file name or url used to retrieve the XML document to be used as a data source.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FileURL As System.String
public System.string FileURL {get; set;}
Example
Paste into the Detail Format event.
  • C#
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();
SectionReport1 rpt = new SectionReport1();

    xDS.ValidateOnParse = true;
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml";
    xDS.RecordsetPattern = "//ITEM";
    xDS.NodeList = (System.Xml.XmlNodeList)ds.Field("ITEM",true);
    this.Label1.Text = xDS.CurrentPosition;
    Console.WriteLine(xDS.Count.ToString());

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
  • Visual Basic
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()
Dim rpt As New SectionReport1()

    xDS.ValidateOnParse = True
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml"
    xDS.RecordsetPattern = "//ITEM"
    xDS.NodeList = xDS.Field("ITEM", True)
    Me.Label1.Text = xDS.CurrentPosition
    Console.WriteLine(xDS.Count.ToString())

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If
See Also

Reference

XMLDataSource Class
XMLDataSource Members


NodeList Property

NodeList Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : NodeList Property
Gets or sets a reference to the XmlNodeList object that is the result of applying the XPath pattern provided in the RecordsetPattern property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NodeList As System.Xml.XmlNodeList
public System.Xml.XmlNodeList NodeList {get; set;}

Property Value

An XmlNodeList object.
Remarks
You can set the NodeList property to your own XmlNodeList object without setting the FileURL or RecordsetPattern. This can be useful in subreports where the parent report sets the NodeList of the subreport data source from one of its fields (returned from the Field method as an XmlNodeList).
Example
Paste into the Detail Format event.
  • C#
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();
SectionReport1 rpt = new SectionReport1();

    xDS.ValidateOnParse = true;
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml";
    xDS.RecordsetPattern = "//ITEM";
    xDS.NodeList = (System.Xml.XmlNodeList)ds.Field("ITEM",true);
    this.Label1.Text = xDS.CurrentPosition;
    Console.WriteLine(xDS.Count.ToString());

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
  • Visual Basic
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()
Dim rpt As New SectionReport1()

    xDS.ValidateOnParse = True
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml"
    xDS.RecordsetPattern = "//ITEM"
    xDS.NodeList = xDS.Field("ITEM", True)
    Me.Label1.Text = xDS.CurrentPosition
    Console.WriteLine(xDS.Count.ToString())

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If
See Also

Reference

XMLDataSource Class
XMLDataSource Members


RecordsetPattern Property

RecordsetPattern Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : RecordsetPattern Property

Gets or sets a valid XPath pattern used to select the data source nodes to be printed in the report.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RecordsetPattern As System.String
public System.string RecordsetPattern {get; set;}
Remarks

The report uses each node selected in the RecordSetPattern to create a detail section.

Note: XSL patterns are case sensitive and must use valid XSL syntax. XSL and XPath documentation can be found on MSDN at http://msdn.microsoft.com/en-us/library/ms256172%28v=vs.110%29.aspx and http://msdn.microsoft.com/en-us/library/ms256471%28v=vs.110%29.aspx

Typical XSL patterns:

Pattern Description

//* All Nodes
//ITEM All ITEM Nodes
/ Root item
/LAYOUT/ITEM/* All child nodes of /LAYOUT/ITEM
//ITEM[@type] All item nodes that contain the type attribute
//ITEM[@id="1"] All item nodes that have an id attribute value of "1"

Example
Paste into the Detail Format event.
  • C#
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();
SectionReport1 rpt = new SectionReport1();

    xDS.ValidateOnParse = true;
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml";
    xDS.RecordsetPattern = "//ITEM";
    xDS.NodeList = (System.Xml.XmlNodeList)ds.Field("ITEM",true);
    this.Label1.Text = xDS.CurrentPosition;
    Console.WriteLine(xDS.Count.ToString());

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
  • Visual Basic
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()
Dim rpt As New SectionReport1()

    xDS.ValidateOnParse = True
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml"
    xDS.RecordsetPattern = "//ITEM"
    xDS.NodeList = xDS.Field("ITEM", True)
    Me.Label1.Text = xDS.CurrentPosition
    Console.WriteLine(xDS.Count.ToString())

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If
See Also

Reference

XMLDataSource Class
XMLDataSource Members


ValidateOnParse Property

ValidateOnParse Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > XMLDataSource Class : ValidateOnParse Property
Gets or sets a value that determines whether the retrieved XmlDocument should be validated while parsing.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ValidateOnParse As System.Boolean
public System.bool ValidateOnParse {get; set;}

Property Value

Boolean.
Example
Paste into the Detail Format event.
  • C#
GrapeCity.ActiveReports.Data.XMLDataSource xDS = new GrapeCity.ActiveReports.Data.XMLDataSource();
SectionReport1 rpt = new SectionReport1();

    xDS.ValidateOnParse = true;
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml";
    xDS.RecordsetPattern = "//ITEM";
    xDS.NodeList = (System.Xml.XmlNodeList)ds.Field("ITEM",true);
    this.Label1.Text = xDS.CurrentPosition;
    Console.WriteLine(xDS.Count.ToString());

    if (xDS.BOF && xDS.EOF)
    {
        return;
    }
Paste into the Detail Format event.
  • Visual Basic
Dim xDS As New GrapeCity.ActiveReports.Data.XMLDataSource()
Dim rpt As New SectionReport1()

    xDS.ValidateOnParse = True
    xDS.FileURL = System.Windows.Forms.Application.StartupPath + " \\customer.xml"
    xDS.RecordsetPattern = "//ITEM"
    xDS.NodeList = xDS.Field("ITEM", True)
    Me.Label1.Text = xDS.CurrentPosition
    Console.WriteLine(xDS.Count.ToString())

    If xDS.BOF & xDS.EOF Then
        Exit Sub
    End If
See Also

Reference

XMLDataSource Class
XMLDataSource Members


FieldTypeEnum Enumeration

FieldTypeEnum Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace : FieldTypeEnum Enumeration
Provides a set of values for use with the FieldType property of the Field class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum FieldTypeEnum
   Inherits System.Enum
public enum FieldTypeEnum : System.Enum
Members
Member | Description
Boolean | Specifies that the field contains a Boolean value.
Date | Specifies that the field contains a date value.
Double | Specifies that the field contains a double value.
Float | Specifies that the field contains a float value.
Int32 | Specifies that the field contains an integer value.
None | No type is specified for the data value.
String | Specifies that the field contains a string value.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Data.FieldTypeEnum

See Also

Reference

GrapeCity.ActiveReports.Data Namespace


GrapeCity.ActiveReports.Document Namespace (GrapeCity.ActiveReports.v10)

GrapeCity.ActiveReports.Document Namespace (GrapeCity.ActiveReports.v10)
Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports.Document Namespace
The Grape.ActiveReports.Document namespace contains many classes which give control over various aspects of the final output of the report.
Classes
 | Class | Description
Class | PageDocument | Provides the capabilities necessary for processing a report.
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


PageDocument Class

PageDocument Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace : PageDocument Class
Provides the capabilities necessary for processing a report.
Object Model
PageDocument Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class PageDocument
public sealed class PageDocument
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Document.PageDocument

See Also

Reference

PageDocument Members
GrapeCity.ActiveReports.Document Namespace


PageDocument Class Members

PageDocument Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace : PageDocument Class

The following tables list the members exposed by PageDocument.

Public Constructors
 | Name | Description
Public Constructor | PageDocument Constructor | Initializes a new instance of PageDocument Class.
Top
Public Properties
 | Name | Description
Public Property | CredentialsLocator | Gets the credentials locator service.
Public Property | DataProviderService | Gets the data provider service
Public Property | DataSourceLocator | Gets the data source locator
Public Property | PageReport | Gets the ReportDefinition for the report.
Public Property | Parameters | Gets the parameters for the report.
Public Property | Printer | Gets a reference to the document's printer settings.
Public Property | PrintOptions | Gets a reference to the document's print options.
Top
Public Methods
 | Name | Description
Public Method | Dispose | Performs tasks associated with freeing and releasing resources.
Public Method | Render | Overloaded. Provides the output of the report to the specified rendering extension.
Public Method | ResetPrinter | Resets the printer properties.
Top
Public Events
 | Name | Description
Public Event | LocateCredentials | Occurs when the report needs to obtain data source credentials from the calling application.
Public Event | LocateDataSource | Occurs when the report needs to locate a data source with from the calling application.
Public Event | PrintAborted | Occurs if the user clicks the Abort button on the status dialog.
Public Event | PrintingThreadErrorEvent | Occurs when an exception is thrown by the printing thread.
Public Event | PrintProgress | Occurs when the document pages are printing.
Top
See Also

Reference

PageDocument Class
GrapeCity.ActiveReports.Document Namespace


PageDocument Constructor

PageDocument Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : PageDocument Constructor
The page report object to create the page document from.
Initializes a new instance of PageDocument Class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal pageReport As PageReport _
)
public PageDocument(
   PageReport pageReport
)

Parameters

pageReport
The page report object to create the page document from.
See Also

Reference

PageDocument Class
PageDocument Members


PageDocument Class Methods

PageDocument Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace : PageDocument Class

For a list of all members of this type, see PageDocument members.

Public Methods
 | Name | Description
Public Method | Dispose | Performs tasks associated with freeing and releasing resources.
Public Method | Render | Overloaded. Provides the output of the report to the specified rendering extension.
Public Method | ResetPrinter | Resets the printer properties.
Top
See Also

Reference

PageDocument Class
GrapeCity.ActiveReports.Document Namespace


Dispose Method (PageDocument)

Dispose Method (PageDocument)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : Dispose Method
Performs tasks associated with freeing and releasing resources.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

PageDocument Class
PageDocument Members


Render Method (PageDocument)

Render Method (PageDocument)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : Render Method
Provides the output of the report to the specified rendering extension.
Overload List
Overload | Description
Render(IRenderingExtension,StreamProvider) | Provides the output of the report to the specified rendering extension.
Render(IRenderingExtension,StreamProvider,NameValueCollection) | Provides the output of the report to the specified rendering extension with the specified values.
Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean) | Provides the output of this report to the specified rendering extension with the specified values and refreshed data.
Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean,Boolean) | Provides the output of this report to the specified rendering extension with the specified values and refreshed data.
See Also

Reference

PageDocument Class
PageDocument Members


Render(IRenderingExtension,StreamProvider) Method

Render(IRenderingExtension,StreamProvider) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class > Render Method : Render(IRenderingExtension,StreamProvider) Method
Rendering extension to use to render a report.
The DataDynamics.Reports.Extensibility.Rendering.IO.StreamProvider that is to store the rendered report output.
Provides the output of the report to the specified rendering extension.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Render( _
   ByVal renderingExtension As IRenderingExtension, _
   ByVal streams As StreamProvider _
)
public void Render(
   IRenderingExtension renderingExtension,
   StreamProvider streams
)

Parameters

renderingExtension
Rendering extension to use to render a report.
streams
The DataDynamics.Reports.Extensibility.Rendering.IO.StreamProvider that is to store the rendered report output.
Exceptions
Exception | Description
System.ArgumentNullException | renderingExtension or streams is null.
ReportsException | A report specific error occured.
See Also

Reference

PageDocument Class
PageDocument Members
Overload List


Render(IRenderingExtension,StreamProvider,NameValueCollection) Method

Render(IRenderingExtension,StreamProvider,NameValueCollection) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class > Render Method : Render(IRenderingExtension,StreamProvider,NameValueCollection) Method
Rendering extension to use to render a report.
The DataDynamics.Reports.Extensibility.Rendering.IO.StreamProvider that is to store the rendered report output.
The System.Collections.Specialized.NameValueCollection that contains the settings for the GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension.
Provides the output of the report to the specified rendering extension with the specified values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Render( _
   ByVal renderingExtension As IRenderingExtension, _
   ByVal streams As StreamProvider, _
   ByVal settings As System.Collections.Specialized.NameValueCollection _
)
public void Render(
   IRenderingExtension renderingExtension,
   StreamProvider streams,
   System.Collections.Specialized.NameValueCollection settings
)

Parameters

renderingExtension
Rendering extension to use to render a report.
streams
The DataDynamics.Reports.Extensibility.Rendering.IO.StreamProvider that is to store the rendered report output.
settings
The System.Collections.Specialized.NameValueCollection that contains the settings for the GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension.
Exceptions
Exception | Description
System.ArgumentNullException | renderingExtension or streams is null.
ReportsException | A report specific error occured.
See Also

Reference

PageDocument Class
PageDocument Members
Overload List


Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean) Method

Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class > Render Method : Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean) Method
Rendering extension to use to render a report.
The DataDynamics.Reports.Extensibility.Rendering.IO.StreamProvider that is to store the rendered report output.
The System.Collections.Specialized.NameValueCollection that contains the settings for the GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension.
Set to True to force a refresh or requery of the data even if the DataMap has already retrieved the necessary data.
Provides the output of this report to the specified rendering extension with the specified values and refreshed data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Render( _
   ByVal renderingExtension As IRenderingExtension, _
   ByVal streams As StreamProvider, _
   ByVal settings As System.Collections.Specialized.NameValueCollection, _
   ByVal forceDataRefresh As System.Boolean _
)
public void Render(
   IRenderingExtension renderingExtension,
   StreamProvider streams,
   System.Collections.Specialized.NameValueCollection settings,
   System.bool forceDataRefresh
)

Parameters

renderingExtension
Rendering extension to use to render a report.
streams
The DataDynamics.Reports.Extensibility.Rendering.IO.StreamProvider that is to store the rendered report output.
settings
The System.Collections.Specialized.NameValueCollection that contains the settings for the GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension.
forceDataRefresh
Set to True to force a refresh or requery of the data even if the DataMap has already retrieved the necessary data.
Exceptions
Exception | Description
System.ArgumentNullException | renderingExtension or streams is null.
ReportsException | A report specific error occured.
See Also

Reference

PageDocument Class
PageDocument Members
Overload List


Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean,Boolean) Method

Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean,Boolean) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class > Render Method : Render(IRenderingExtension,StreamProvider,NameValueCollection,Boolean,Boolean) Method
The DataDynamics.Reports.Extensibility.Rendering.IO.StreamProvider that is to store the rendered report output.
The System.Collections.Specialized.NameValueCollection that contains the settings for the GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension.
Set to True to force a refresh or requery of the data even if the DataMap has already retrieved the necessary data.
Set to True to force a refresh or requery of the parameter data.
Provides the output of this report to the specified rendering extension with the specified values and refreshed data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Render( _
   ByVal renderingExtension As IRenderingExtension, _
   ByVal streams As StreamProvider, _
   ByVal settings As System.Collections.Specialized.NameValueCollection, _
   ByVal forceDataRefresh As System.Boolean, _
   ByVal forceParameterDataRefresh As System.Boolean _
)
public void Render(
   IRenderingExtension renderingExtension,
   StreamProvider streams,
   System.Collections.Specialized.NameValueCollection settings,
   System.bool forceDataRefresh,
   System.bool forceParameterDataRefresh
)

Parameters

renderingExtension
streams
The DataDynamics.Reports.Extensibility.Rendering.IO.StreamProvider that is to store the rendered report output.
settings
The System.Collections.Specialized.NameValueCollection that contains the settings for the GrapeCity.ActiveReports.Extensibility.Rendering.IRenderingExtension.
forceDataRefresh
Set to True to force a refresh or requery of the data even if the DataMap has already retrieved the necessary data.
forceParameterDataRefresh
Set to True to force a refresh or requery of the parameter data.
Exceptions
Exception | Description
System.ArgumentNullException | renderingExtension or streams is null.
ReportsException | A report specific error occured.
See Also

Reference

PageDocument Class
PageDocument Members
Overload List


ResetPrinter Method (PageDocument)

ResetPrinter Method (PageDocument)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : ResetPrinter Method
Resets the printer properties.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ResetPrinter()
public void ResetPrinter()
See Also

Reference

PageDocument Class
PageDocument Members


PageDocument Class Properties

PageDocument Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace : PageDocument Class

For a list of all members of this type, see PageDocument members.

Public Properties
 | Name | Description
Public Property | CredentialsLocator | Gets the credentials locator service.
Public Property | DataProviderService | Gets the data provider service
Public Property | DataSourceLocator | Gets the data source locator
Public Property | PageReport | Gets the ReportDefinition for the report.
Public Property | Parameters | Gets the parameters for the report.
Public Property | Printer | Gets a reference to the document's printer settings.
Public Property | PrintOptions | Gets a reference to the document's print options.
Top
See Also

Reference

PageDocument Class
GrapeCity.ActiveReports.Document Namespace


CredentialsLocator Property

CredentialsLocator Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : CredentialsLocator Property
Gets the credentials locator service.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CredentialsLocator As ICredentialsLocator
public ICredentialsLocator CredentialsLocator {get;}
See Also

Reference

PageDocument Class
PageDocument Members


DataProviderService Property (PageDocument)

DataProviderService Property (PageDocument)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : DataProviderService Property
Gets the data provider service
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DataProviderService As IDataProviderService
public IDataProviderService DataProviderService {get;}
See Also

Reference

PageDocument Class
PageDocument Members


DataSourceLocator Property

DataSourceLocator Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : DataSourceLocator Property
Gets the data source locator
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DataSourceLocator As IDataSourceLocator
public IDataSourceLocator DataSourceLocator {get;}
See Also

Reference

PageDocument Class
PageDocument Members


PageReport Property

PageReport Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : PageReport Property
Gets the ReportDefinition for the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PageReport As PageReport
public PageReport PageReport {get;}
See Also

Reference

PageDocument Class
PageDocument Members


Parameters Property (PageDocument)

Parameters Property (PageDocument)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : Parameters Property
Gets the parameters for the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Parameters As ParameterCollection
public ParameterCollection Parameters {get;}
See Also

Reference

PageDocument Class
PageDocument Members


Printer Property (PageDocument)

Printer Property (PageDocument)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : Printer Property
Gets a reference to the document's printer settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Printer As Printer
public Printer Printer {get;}
Remarks
Use this property to set the printer options before displaying a print dialog or directly printing the document to the printer with the specified options.
See Also

Reference

PageDocument Class
PageDocument Members


PrintOptions Property (PageDocument)

PrintOptions Property (PageDocument)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : PrintOptions Property
Gets a reference to the document's print options.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PrintOptions As PrintOptions
public PrintOptions PrintOptions {get;}
See Also

Reference

PageDocument Class
PageDocument Members


PageDocument Class Events

PageDocument Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace : PageDocument Class

For a list of all members of this type, see PageDocument members.

Public Events
 | Name | Description
Public Event | LocateCredentials | Occurs when the report needs to obtain data source credentials from the calling application.
Public Event | LocateDataSource | Occurs when the report needs to locate a data source with from the calling application.
Public Event | PrintAborted | Occurs if the user clicks the Abort button on the status dialog.
Public Event | PrintingThreadErrorEvent | Occurs when an exception is thrown by the printing thread.
Public Event | PrintProgress | Occurs when the document pages are printing.
Top
See Also

Reference

PageDocument Class
GrapeCity.ActiveReports.Document Namespace


LocateCredentials Event (PageDocument)

LocateCredentials Event (PageDocument)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : LocateCredentials Event
Occurs when the report needs to obtain data source credentials from the calling application.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LocateCredentials As LocateCredentialsEventHandler
public event LocateCredentialsEventHandler LocateCredentials
Event Data

The event handler receives an argument of type LocateCredentialsEventArgs containing data related to this event. The following LocateCredentialsEventArgs properties provide information specific to this event.

Property | Description
DataSourceName | Gets the name of the data source to locate credentials for.
Password | Gets ot sets the password of the credentials to be located.
PromptText | Gets the text of prompt of the locate credentials request.
ReportPath | Gets the name of the report to locate credentials for.
UserName | Gets ot sets the user name of the credentials to be located.
See Also

Reference

PageDocument Class
PageDocument Members


LocateDataSource Event (PageDocument)

LocateDataSource Event (PageDocument)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : LocateDataSource Event
Occurs when the report needs to locate a data source with from the calling application.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LocateDataSource As LocateDataSourceEventHandler
public event LocateDataSourceEventHandler LocateDataSource
Event Data

The event handler receives an argument of type LocateDataSourceEventArgs containing data related to this event. The following LocateDataSourceEventArgs properties provide information specific to this event.

Property | Description
Data | The data returned by the event handler.
DataSetName | Gets the name of data set to be located.
DataSourceName | Gets the name of data source that contains the data set to be located.
Report | Gets the Report that is trying to locate the data set.
See Also

Reference

PageDocument Class
PageDocument Members


PrintAborted Event (PageDocument)

PrintAborted Event (PageDocument)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : PrintAborted Event
Occurs if the user clicks the Abort button on the status dialog.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PrintAborted As PrintAbortedEventHandler
public event PrintAbortedEventHandler PrintAborted
See Also

Reference

PageDocument Class
PageDocument Members


PrintingThreadErrorEvent Event (PageDocument)

PrintingThreadErrorEvent Event (PageDocument)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : PrintingThreadErrorEvent Event
Occurs when an exception is thrown by the printing thread.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PrintingThreadErrorEvent As PrintingThreadErrorEventHandler
public event PrintingThreadErrorEventHandler PrintingThreadErrorEvent
Event Data

The event handler receives an argument of type PrintingThreadErrorEventArgs containing data related to this event. The following PrintingThreadErrorEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets or sets a value that specifies the exception that caused the printing thread error.
See Also

Reference

PageDocument Class
PageDocument Members


PrintProgress Event (PageDocument)

PrintProgress Event (PageDocument)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : PrintProgress Event
Occurs when the document pages are printing.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PrintProgress As PrintProgressEventHandler
public event PrintProgressEventHandler PrintProgress
Event Data

The event handler receives an argument of type PrintProgressEventArgs containing data related to this event. The following PrintProgressEventArgs properties provide information specific to this event.

Property | Description
CurrentPage | Gets the currently printing page.
See Also

Reference

PageDocument Class
PageDocument Members


GrapeCity.ActiveReports.Export Namespace (GrapeCity.ActiveReports.v10)

GrapeCity.ActiveReports.Export Namespace (GrapeCity.ActiveReports.v10)
Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports.Export Namespace
The GrapeCity.ActiveReports.Export namespace contains the common interface for all the export filters.
Interfaces
 | Interface | Description
Interface | IDocumentExportEx | Provides a common interface for all the export filters.
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


IDocumentExportEx Interface

IDocumentExportEx Interface
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Export Namespace : IDocumentExportEx Interface
Provides a common interface for all the export filters.
Object Model
IDocumentExportEx Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDocumentExportEx
   Inherits IDocumentExport
public interface IDocumentExportEx : IDocumentExport
See Also

Reference

IDocumentExportEx Members
GrapeCity.ActiveReports.Export Namespace


IDocumentExportEx Interface Members

IDocumentExportEx Interface Members
Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Export Namespace : IDocumentExportEx Interface

The following tables list the members exposed by IDocumentExportEx.

Public Methods
 | Name | Description
Method | Export | Overloaded. Exports the specified document to HTML.
Top
See Also

Reference

IDocumentExportEx Interface
GrapeCity.ActiveReports.Export Namespace


IDocumentExportEx Interface Methods

IDocumentExportEx Interface Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Export Namespace : IDocumentExportEx Interface

For a list of all members of this type, see IDocumentExportEx members.

Public Methods
 | Name | Description
Method | Export | Overloaded. Exports the specified document to HTML.
Top
See Also

Reference

IDocumentExportEx Interface
GrapeCity.ActiveReports.Export Namespace


Export Method (IDocumentExportEx)

Export Method (IDocumentExportEx)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExportEx Interface : Export Method
Exports the specified document to HTML.
Overload List
Overload | Description
Export(PageDocument,String,String) | Exports the specified range of pages to an HTML file.
Export(PageDocument,String) | Exports the entire ActiveReports document to the specified HTML file.
Export(PageDocument,Stream) | Exports the entire ActiveReports document to HTML in a MIME MHT format (such as can be saved using Internet Explorer with the Save As Web Archive option) which combines the HTML and all images into a single file.
Export(PageDocument,Stream,String) | Exports the specified range of pages to a System.IO.Stream in a MIME MHT format (such as can be saved using Internet Explorer with the Save As Web Archive option) which combines the HTML and all images into a single file.
Export(IReport,String,String) | Exports the specified IReport to file
Export(IReport,String) | Exports the specified IReport to file
Export(IReport,Stream) | Exports the specified IReport to stream
Export(IReport,Stream,String) | Exports the specified IReport to stream
See Also

Reference

IDocumentExportEx Interface
IDocumentExportEx Members


Export(PageDocument,String,String) Method

Export(PageDocument,String,String) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExportEx Interface > Export Method : Export(PageDocument,String,String) Method
Page document to export.
The path to the file to save exported result to.
The page range to export.
Exports the specified range of pages to an HTML file.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As System.String, _
   ByVal pageRange As System.String _
)
void Export(
   PageDocument document,
   System.string filePath,
   System.string pageRange
)

Parameters

document
Page document to export.
filePath
The path to the file to save exported result to.
pageRange
The page range to export.
See Also

Reference

IDocumentExportEx Interface
IDocumentExportEx Members
Overload List


Export(PageDocument,String) Method

Export(PageDocument,String) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExportEx Interface > Export Method : Export(PageDocument,String) Method
Page document to export.
The path to the file to save exported result to.
Exports the entire ActiveReports document to the specified HTML file.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal filePath As System.String _
)
void Export(
   PageDocument document,
   System.string filePath
)

Parameters

document
Page document to export.
filePath
The path to the file to save exported result to.
See Also

Reference

IDocumentExportEx Interface
IDocumentExportEx Members
Overload List


Export(PageDocument,Stream) Method

Export(PageDocument,Stream) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExportEx Interface > Export Method : Export(PageDocument,Stream) Method
Page document to export.
The stream to write the output to.
Exports the entire ActiveReports document to HTML in a MIME MHT format (such as can be saved using Internet Explorer with the Save As Web Archive option) which combines the HTML and all images into a single file.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal outputStream As System.IO.Stream _
)
void Export(
   PageDocument document,
   System.IO.Stream outputStream
)

Parameters

document
Page document to export.
outputStream
The stream to write the output to.
See Also

Reference

IDocumentExportEx Interface
IDocumentExportEx Members
Overload List


Export(PageDocument,Stream,String) Method

Export(PageDocument,Stream,String) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExportEx Interface > Export Method : Export(PageDocument,Stream,String) Method
Page document to export.
The stream to write the output to.
The page range to export.
Exports the specified range of pages to a System.IO.Stream in a MIME MHT format (such as can be saved using Internet Explorer with the Save As Web Archive option) which combines the HTML and all images into a single file.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub Export( _
   ByVal document As PageDocument, _
   ByVal outputStream As System.IO.Stream, _
   ByVal pageRange As System.String _
)
void Export(
   PageDocument document,
   System.IO.Stream outputStream,
   System.string pageRange
)

Parameters

document
Page document to export.
outputStream
The stream to write the output to.
pageRange
The page range to export.
See Also

Reference

IDocumentExportEx Interface
IDocumentExportEx Members
Overload List


Export(IReport,String,String) Method

Export(IReport,String,String) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExportEx Interface > Export Method : Export(IReport,String,String) Method
IReport instance to Export
Path to export
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified IReport to file
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal filePath As System.String, _
   ByVal pageRange As System.String _
)
void Export(
   IReport report,
   System.string filePath,
   System.string pageRange
)

Parameters

report
IReport instance to Export
filePath
Path to export
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

IDocumentExportEx Interface
IDocumentExportEx Members
Overload List


Export(IReport,String) Method

Export(IReport,String) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExportEx Interface > Export Method : Export(IReport,String) Method
IReport instance to Export
Path to export
Exports the specified IReport to file
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal filePath As System.String _
)
void Export(
   IReport report,
   System.string filePath
)

Parameters

report
IReport instance to Export
filePath
Path to export
See Also

Reference

IDocumentExportEx Interface
IDocumentExportEx Members
Overload List


Export(IReport,Stream) Method

Export(IReport,Stream) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExportEx Interface > Export Method : Export(IReport,Stream) Method
IReport instance to Export
Stream to export
Exports the specified IReport to stream
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal outputStream As System.IO.Stream _
)
void Export(
   IReport report,
   System.IO.Stream outputStream
)

Parameters

report
IReport instance to Export
outputStream
Stream to export
See Also

Reference

IDocumentExportEx Interface
IDocumentExportEx Members
Overload List


Export(IReport,Stream,String) Method

Export(IReport,Stream,String) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Export Namespace > IDocumentExportEx Interface > Export Method : Export(IReport,Stream,String) Method
IReport instance to Export
Stream to export
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified IReport to stream
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub Export( _
   ByVal report As IReport, _
   ByVal outputStream As System.IO.Stream, _
   ByVal pageRange As System.String _
)
void Export(
   IReport report,
   System.IO.Stream outputStream,
   System.string pageRange
)

Parameters

report
IReport instance to Export
outputStream
Stream to export
pageRange
A range of page numbers to export seperated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

IDocumentExportEx Interface
IDocumentExportEx Members
Overload List


GrapeCity.ActiveReports.Expressions Namespace

GrapeCity.ActiveReports.Expressions Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports.Expressions Namespace
The GrapeCity.ActiveReports.Expressions namespace includes classes having information of expressions etc.
Classes
 | Class | Description
Class | ExpressionInfo | The ExpressionInfo class stores, evaluates, and provides information about an expression. ExpressionInfo provides aggregates, global collections, et cetera, as well as information about the expected data type of the expression's result.
Class | ExpressionInfoCollection | Implements a strongly typed collection for ExpressionInfo.
Class | ExpressionInfoCollectionEventArgs | Provides data for the ItemAdded or ItemRemoved event of the ExpressionInfoCollection.
Interfaces
 | Interface | Description
Interface | IExpressionEvaluatorService | Allows an ExpressionInfo object to be evaluated.
Interface | ITheme | Defines an interface to set and get theme information.
Delegates
 | Delegate | Description
Delegate | ExpressionInfoCollectionEventHandler | Represents the method that handles the ItemAdded or ItemRemoved event.
Enumerations
 | Enumeration | Description
Enumeration | ExpressionResultType | Specifies the data type of an expression result.
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


ExpressionInfo Class

ExpressionInfo Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace : ExpressionInfo Class
The ExpressionInfo class stores, evaluates, and provides information about an expression. ExpressionInfo provides aggregates, global collections, et cetera, as well as information about the expected data type of the expression's result.
Object Model
ExpressionInfo Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class ExpressionInfo
public abstract class ExpressionInfo
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Expressions.ExpressionInfo

See Also

Reference

ExpressionInfo Members
GrapeCity.ActiveReports.Expressions Namespace


ExpressionInfo Class Members

ExpressionInfo Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace : ExpressionInfo Class

The following tables list the members exposed by ExpressionInfo.

Public Properties
 | Name | Description
Public Property | Expression | The original expression.
Public Property | IsConstant | Gets a Boolean value indicating whether the ExpressionInfo object contains only constant values.
Public Property | ResultType | The expected data type of the expression result.
Top
Public Methods
 | Name | Description
Public Method | CompareTo | Compares the current ExpressionInfo with another ExpressionInfo and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public Method | Equals | Overloaded. Determines whether the specified ExpressionInfo object represents the same expression as this one.
Public Method | GetHashCode | Generates a unique HashCode for this expression.
static (Shared in Visual Basic) | Parse | Parses the specified expression string and returns an ExpressionInfo object that represents the specified expression.
Public Method | ToString | Returns the string representation of this object suitable for RDL output.
Top
Public Operators
public Operator Equality | Determines whether the two ExpressionInfo objects represent the same expression.
public Operator Implicit Type Conversion | Overloaded. Defines an operator that allows implicit conversion from an ExpressionInfo to a string.
public Operator Inequality | Determines whether the specified ExpressionInfo objects represent different expressions.
Top
See Also

Reference

ExpressionInfo Class
GrapeCity.ActiveReports.Expressions Namespace


ExpressionInfo Class Methods

ExpressionInfo Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace : ExpressionInfo Class

For a list of all members of this type, see ExpressionInfo members.

Public Methods
 | Name | Description
Public Method | CompareTo | Compares the current ExpressionInfo with another ExpressionInfo and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public Method | Equals | Overloaded. Determines whether the specified ExpressionInfo object represents the same expression as this one.
Public Method | GetHashCode | Generates a unique HashCode for this expression.
static (Shared in Visual Basic) | Parse | Parses the specified expression string and returns an ExpressionInfo object that represents the specified expression.
Public Method | ToString | Returns the string representation of this object suitable for RDL output.
Top
See Also

Reference

ExpressionInfo Class
GrapeCity.ActiveReports.Expressions Namespace


CompareTo Method (ExpressionInfo)

CompareTo Method (ExpressionInfo)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfo Class : CompareTo Method
The expression to compare the current expression with.
Compares the current ExpressionInfo with another ExpressionInfo and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CompareTo( _
   ByVal obj As System.Object _
) As System.Integer
public System.int CompareTo(
   System.object obj
)

Parameters

obj
The expression to compare the current expression with.

Return Value

A signed integer that indicates the relative values of this instance and obj.
See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


Equals Method (ExpressionInfo)

Equals Method (ExpressionInfo)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfo Class : Equals Method
Determines whether the specified ExpressionInfo object represents the same expression as this one.
Overload List
Overload | Description
Equals(Object) | Determines whether the specified ExpressionInfo object represents the same expression as this one.
Equals(ExpressionInfo) | Determines whether the current ExpressionInfo object is the same as the specified object.
See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


Equals(Object) Method

Equals(Object) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfo Class > Equals Method : Equals(Object) Method
The expression to be evaluated.
Determines whether the specified ExpressionInfo object represents the same expression as this one.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overrides Function Equals( _
   ByVal expression As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object expression
)

Parameters

expression
The expression to be evaluated.
See Also

Reference

ExpressionInfo Class
ExpressionInfo Members
Overload List


Equals(ExpressionInfo) Method

Equals(ExpressionInfo) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfo Class > Equals Method : Equals(ExpressionInfo) Method
The expression to be evaluated.

Determines whether the current ExpressionInfo object is the same as the specified object.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Equals( _
   ByVal expression As ExpressionInfo _
) As System.Boolean
public System.bool Equals(
   ExpressionInfo expression
)

Parameters

expression
The expression to be evaluated.
See Also

Reference

ExpressionInfo Class
ExpressionInfo Members
Overload List


GetHashCode Method (ExpressionInfo)

GetHashCode Method (ExpressionInfo)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfo Class : GetHashCode Method
Generates a unique HashCode for this expression.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()
See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


Parse(String,ExpressionResultType) Method

Parse(String,ExpressionResultType) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfo Class : Parse(String,ExpressionResultType) Method
The string to parse.
If the expressionString parameter does not start with an equals sign (=), then the expression is treated as a constant with an enumerated ExpressionResultType.
Parses the specified expression string and returns an ExpressionInfo object that represents the specified expression.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function Parse( _
   ByVal expressionString As System.String, _
   ByVal subType As ExpressionResultType _
) As ExpressionInfo
public static ExpressionInfo Parse(
   System.string expressionString,
   ExpressionResultType subType
)

Parameters

expressionString
The string to parse.
subType
If the expressionString parameter does not start with an equals sign (=), then the expression is treated as a constant with an enumerated ExpressionResultType.
See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


ToString Method (ExpressionInfo)

ToString Method (ExpressionInfo)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfo Class : ToString Method
Returns the string representation of this object suitable for RDL output.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()
Remarks
Returns the expression this object represents. The return value is the value of Expression prefixed with an equal sign if this is an expression to be evaluated. Otherwise it is just the value of Expression.
See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


ExpressionInfo Class Properties

ExpressionInfo Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace : ExpressionInfo Class

For a list of all members of this type, see ExpressionInfo members.

Public Properties
 | Name | Description
Public Property | Expression | The original expression.
Public Property | IsConstant | Gets a Boolean value indicating whether the ExpressionInfo object contains only constant values.
Public Property | ResultType | The expected data type of the expression result.
Top
See Also

Reference

ExpressionInfo Class
GrapeCity.ActiveReports.Expressions Namespace


Expression Property

Expression Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfo Class : Expression Property
The original expression.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Expression As System.String
public System.string Expression {get;}
See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


IsConstant Property

IsConstant Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfo Class : IsConstant Property
Gets a Boolean value indicating whether the ExpressionInfo object contains only constant values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property IsConstant As System.Boolean
public virtual System.bool IsConstant {get;}
See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


ResultType Property

ResultType Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfo Class : ResultType Property
The expected data type of the expression result.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ResultType As ExpressionResultType
public ExpressionResultType ResultType {get;}
See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


Equality Operator (ExpressionInfo)

Equality Operator (ExpressionInfo)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfo Class : Equality Operator
The first expression to be evaluated.
The second expression to be evaluated.
Determines whether the two ExpressionInfo objects represent the same expression.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator =( _
   ByVal expression1 As ExpressionInfo, _
   ByVal expression2 As ExpressionInfo _
) As System.Boolean
public System.bool operator ==(
   ExpressionInfo expression1,
   ExpressionInfo expression2
)

Parameters

expression1
The first expression to be evaluated.
expression2
The second expression to be evaluated.
See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


Implicit Type Conversion Operator (ExpressionInfo)

Implicit Type Conversion Operator (ExpressionInfo)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfo Class : Implicit Type Conversion Operator
Defines an operator that allows implicit conversion from an ExpressionInfo to a string.
Overload List
Overload | Description
Implicit Type Conversion(String,ExpressionInfo) | Defines an operator that allows implicit conversion from an ExpressionInfo to a string.
Implicit Type Conversion(ExpressionInfo,String) | Defines an operator that allows implicit conversion from a string to an ExpressionInfo.
See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


Implicit Type Conversion(String,ExpressionInfo) Operator

Implicit Type Conversion(String,ExpressionInfo) Operator

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfo Class > Implicit Type Conversion Operator : Implicit Type Conversion(String,ExpressionInfo) Operator
The expression to be evaluated.
Defines an operator that allows implicit conversion from an ExpressionInfo to a string.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator Widening CType( _
   ByVal expression As ExpressionInfo _
) As System.String
public System.string operator implicit(
   ExpressionInfo expression
)

Parameters

expression
The expression to be evaluated.
See Also

Reference

ExpressionInfo Class
ExpressionInfo Members
Overload List


Implicit Type Conversion(ExpressionInfo,String) Operator

Implicit Type Conversion(ExpressionInfo,String) Operator

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfo Class > Implicit Type Conversion Operator : Implicit Type Conversion(ExpressionInfo,String) Operator
The string to be converted to an expression.
Defines an operator that allows implicit conversion from a string to an ExpressionInfo.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator Widening CType( _
   ByVal expressionString As System.String _
) As ExpressionInfo
public ExpressionInfo operator implicit(
   System.string expressionString
)

Parameters

expressionString
The string to be converted to an expression.
See Also

Reference

ExpressionInfo Class
ExpressionInfo Members
Overload List


Inequality Operator (ExpressionInfo)

Inequality Operator (ExpressionInfo)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfo Class : Inequality Operator
The first expression to be evaluated.
The second expression to be evaluated.
Determines whether the specified ExpressionInfo objects represent different expressions.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator <>( _
   ByVal expression1 As ExpressionInfo, _
   ByVal expression2 As ExpressionInfo _
) As System.Boolean
public System.bool operator !=(
   ExpressionInfo expression1,
   ExpressionInfo expression2
)

Parameters

expression1
The first expression to be evaluated.
expression2
The second expression to be evaluated.
See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


ExpressionInfoCollection Class

ExpressionInfoCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace : ExpressionInfoCollection Class
Implements a strongly typed collection for ExpressionInfo.
Object Model
ExpressionInfoCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ExpressionInfoCollection
   Inherits System.Collections.CollectionBase
public sealed class ExpressionInfoCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Expressions.ExpressionInfoCollection

See Also

Reference

ExpressionInfoCollection Members
GrapeCity.ActiveReports.Expressions Namespace


ExpressionInfoCollection Class Members

ExpressionInfoCollection Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace : ExpressionInfoCollection Class

The following tables list the members exposed by ExpressionInfoCollection.

Public Constructors
 | Name | Description
Public Constructor | ExpressionInfoCollection Constructor | Initializes a new instance of ExpressionInfoCollection class.
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the ExpressionInfoCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the ExpressionInfoCollection instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Gets a value indicating whether the ExpressionInfoCollection is read-only.
Public Property | Item | Gets the ExpressionInfo object by specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a new ExpressionInfo into the ExpressionInfoCollection.
Public Method | AddRange | Adds a range of ExpressionInfo into the ExpressionInfoCollection.
Public Method | Clear | Removes all objects from the ExpressionInfoCollection instance. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the ExpressionInfoCollection contains a specific value.
Public Method | CopyTo | Copies the elements of the ExpressionInfoCollection to an System.Array, starting at a particular System.Array index.
Public Method | IndexOf | Determines the index of a specific item in the ExpressionInfoCollection.
Public Method | Insert | Inserts a new a ExpressionInfo into the ExpressionInfoCollection at the specified location.
Public Method | Remove | Remove item from collection
Public Method | RemoveAt | Removes the ExpressionInfo at the specified index of the ExpressionInfoCollection instance. (Inherited from System.Collections.CollectionBase)
Public Method | ToArray | Copies the elements of the ExpressionInfoCollection to a new array.
Top
Public Events
 | Name | Description
Public Event | ItemAdded | Occurs immediately after adding an item to the collection.
Public Event | ItemRemoved | Occurs immediately after removing an item from the collection.
Top
See Also

Reference

ExpressionInfoCollection Class
GrapeCity.ActiveReports.Expressions Namespace


ExpressionInfoCollection Constructor

ExpressionInfoCollection Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfoCollection Class : ExpressionInfoCollection Constructor
Initializes a new instance of ExpressionInfoCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ExpressionInfoCollection()
See Also

Reference

ExpressionInfoCollection Class
ExpressionInfoCollection Members


ExpressionInfoCollection Class Methods

ExpressionInfoCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace : ExpressionInfoCollection Class

For a list of all members of this type, see ExpressionInfoCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a new ExpressionInfo into the ExpressionInfoCollection.
Public Method | AddRange | Adds a range of ExpressionInfo into the ExpressionInfoCollection.
Public Method | Clear | Removes all objects from the ExpressionInfoCollection instance. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the ExpressionInfoCollection contains a specific value.
Public Method | CopyTo | Copies the elements of the ExpressionInfoCollection to an System.Array, starting at a particular System.Array index.
Public Method | IndexOf | Determines the index of a specific item in the ExpressionInfoCollection.
Public Method | Insert | Inserts a new a ExpressionInfo into the ExpressionInfoCollection at the specified location.
Public Method | Remove | Remove item from collection
Public Method | RemoveAt | Removes the ExpressionInfo at the specified index of the ExpressionInfoCollection instance. (Inherited from System.Collections.CollectionBase)
Public Method | ToArray | Copies the elements of the ExpressionInfoCollection to a new array.
Top
See Also

Reference

ExpressionInfoCollection Class
GrapeCity.ActiveReports.Expressions Namespace


Add Method (ExpressionInfoCollection)

Add Method (ExpressionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfoCollection Class : Add Method
The ExpressionInfo object to add.
Adds a new ExpressionInfo into the ExpressionInfoCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As ExpressionInfo _
) As System.Integer
public System.int Add(
   ExpressionInfo value
)

Parameters

value
The ExpressionInfo object to add.
See Also

Reference

ExpressionInfoCollection Class
ExpressionInfoCollection Members


AddRange Method (ExpressionInfoCollection)

AddRange Method (ExpressionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfoCollection Class : AddRange Method
The array of the expressions to add the ExpressionInfoCollection.
Adds a range of ExpressionInfo into the ExpressionInfoCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddRange( _
   ByVal expressions As ExpressionInfoCollection _
)
public void AddRange(
   ExpressionInfoCollection expressions
)

Parameters

expressions
The array of the expressions to add the ExpressionInfoCollection.
See Also

Reference

ExpressionInfoCollection Class
ExpressionInfoCollection Members


Contains Method (ExpressionInfoCollection)

Contains Method (ExpressionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfoCollection Class : Contains Method
The object to locate in the ExpressionInfoCollection.
Determines whether the ExpressionInfoCollection contains a specific value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal item As ExpressionInfo _
) As System.Boolean
public System.bool Contains(
   ExpressionInfo item
)

Parameters

item
The object to locate in the ExpressionInfoCollection.

Return Value

true if item is found in the ExpressionInfoCollection; otherwise, false.
See Also

Reference

ExpressionInfoCollection Class
ExpressionInfoCollection Members


CopyTo Method (ExpressionInfoCollection)

CopyTo Method (ExpressionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfoCollection Class : CopyTo Method
The one-dimensional System.Array that is the destination of the elements copied from ExpressionInfoCollection. The System.Array must have zero-based indexing.
The zero-based index in array at which copying begins.
Copies the elements of the ExpressionInfoCollection to an System.Array, starting at a particular System.Array index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal array() As ExpressionInfo, _
   ByVal arrayIndex As System.Integer _
)
public void CopyTo(
   ExpressionInfo[] array,
   System.int arrayIndex
)

Parameters

array
The one-dimensional System.Array that is the destination of the elements copied from ExpressionInfoCollection. The System.Array must have zero-based indexing.
arrayIndex
The zero-based index in array at which copying begins.
See Also

Reference

ExpressionInfoCollection Class
ExpressionInfoCollection Members


IndexOf Method (ExpressionInfoCollection)

IndexOf Method (ExpressionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfoCollection Class : IndexOf Method
Determines the index of a specific item in the ExpressionInfoCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal item As ExpressionInfo _
) As System.Integer
public System.int IndexOf(
   ExpressionInfo item
)

Parameters

item

Return Value

The index of value if found in the list; otherwise, -1.
See Also

Reference

ExpressionInfoCollection Class
ExpressionInfoCollection Members


Insert Method (ExpressionInfoCollection)

Insert Method (ExpressionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfoCollection Class : Insert Method
A zero-based Int32 index indicating the position at which to insert the ExpressionInfo.
The ExpressionInfo object to add.
Inserts a new a ExpressionInfo into the ExpressionInfoCollection at the specified location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As ExpressionInfo _
)
public void Insert(
   System.int index,
   ExpressionInfo value
)

Parameters

index
A zero-based Int32 index indicating the position at which to insert the ExpressionInfo.
value
The ExpressionInfo object to add.
See Also

Reference

ExpressionInfoCollection Class
ExpressionInfoCollection Members


Remove Method (ExpressionInfoCollection)

Remove Method (ExpressionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfoCollection Class : Remove Method
Item for remove
Remove item from collection
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Remove( _
   ByVal item As ExpressionInfo _
) As System.Boolean
public System.bool Remove(
   ExpressionInfo item
)

Parameters

item
Item for remove
See Also

Reference

ExpressionInfoCollection Class
ExpressionInfoCollection Members


ToArray Method (ExpressionInfoCollection)

ToArray Method (ExpressionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfoCollection Class : ToArray Method
Copies the elements of the ExpressionInfoCollection to a new array.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToArray() As ExpressionInfo()
public ExpressionInfo[] ToArray()

Return Value

GrapeCity.ActiveReports.Expressions.ExpressionInfo[].
See Also

Reference

ExpressionInfoCollection Class
ExpressionInfoCollection Members


ExpressionInfoCollection Class Properties

ExpressionInfoCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace : ExpressionInfoCollection Class

For a list of all members of this type, see ExpressionInfoCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the ExpressionInfoCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the ExpressionInfoCollection instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Gets a value indicating whether the ExpressionInfoCollection is read-only.
Public Property | Item | Gets the ExpressionInfo object by specified index.
Top
See Also

Reference

ExpressionInfoCollection Class
GrapeCity.ActiveReports.Expressions Namespace


IsReadOnly Property (ExpressionInfoCollection)

IsReadOnly Property (ExpressionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfoCollection Class : IsReadOnly Property
Gets a value indicating whether the ExpressionInfoCollection is read-only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsReadOnly As System.Boolean
public System.bool IsReadOnly {get;}

Property Value

true if the ExpressionInfoCollection is read-only; otherwise, false.
See Also

Reference

ExpressionInfoCollection Class
ExpressionInfoCollection Members


Item Property (ExpressionInfoCollection)

Item Property (ExpressionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfoCollection Class : Item Property
The zero-based index of the item to locate.
Gets the ExpressionInfo object by specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As ExpressionInfo
public ExpressionInfo this[
   System.int index
]; {get; set;}

Parameters

index
The zero-based index of the item to locate.

Property Value

GrapeCity.ActiveReports.Expressions.ExpressionInfo.
See Also

Reference

ExpressionInfoCollection Class
ExpressionInfoCollection Members


ExpressionInfoCollection Class Events

ExpressionInfoCollection Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace : ExpressionInfoCollection Class

For a list of all members of this type, see ExpressionInfoCollection members.

Public Events
 | Name | Description
Public Event | ItemAdded | Occurs immediately after adding an item to the collection.
Public Event | ItemRemoved | Occurs immediately after removing an item from the collection.
Top
See Also

Reference

ExpressionInfoCollection Class
GrapeCity.ActiveReports.Expressions Namespace


ItemAdded Event (ExpressionInfoCollection)

ItemAdded Event (ExpressionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfoCollection Class : ItemAdded Event
Occurs immediately after adding an item to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ItemAdded As ExpressionInfoCollectionEventHandler
public event ExpressionInfoCollectionEventHandler ItemAdded
Event Data

The event handler receives an argument of type ExpressionInfoCollectionEventArgs containing data related to this event. The following ExpressionInfoCollectionEventArgs properties provide information specific to this event.

Property | Description
Index | Returns the Integer for the ExpressionInfo object that was added or removed.
Value | Returns the ExpressionInfo object that was added or removed.
See Also

Reference

ExpressionInfoCollection Class
ExpressionInfoCollection Members


ItemRemoved Event (ExpressionInfoCollection)

ItemRemoved Event (ExpressionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfoCollection Class : ItemRemoved Event
Occurs immediately after removing an item from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ItemRemoved As ExpressionInfoCollectionEventHandler
public event ExpressionInfoCollectionEventHandler ItemRemoved
Event Data

The event handler receives an argument of type ExpressionInfoCollectionEventArgs containing data related to this event. The following ExpressionInfoCollectionEventArgs properties provide information specific to this event.

Property | Description
Index | Returns the Integer for the ExpressionInfo object that was added or removed.
Value | Returns the ExpressionInfo object that was added or removed.
See Also

Reference

ExpressionInfoCollection Class
ExpressionInfoCollection Members


ExpressionInfoCollectionEventArgs Class

ExpressionInfoCollectionEventArgs Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace : ExpressionInfoCollectionEventArgs Class
Provides data for the ItemAdded or ItemRemoved event of the ExpressionInfoCollection.
Object Model
ExpressionInfoCollectionEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ExpressionInfoCollectionEventArgs
   Inherits System.EventArgs
public sealed class ExpressionInfoCollectionEventArgs : System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Expressions.ExpressionInfoCollectionEventArgs

See Also

Reference

ExpressionInfoCollectionEventArgs Members
GrapeCity.ActiveReports.Expressions Namespace


ExpressionInfoCollectionEventArgs Class Members

ExpressionInfoCollectionEventArgs Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace : ExpressionInfoCollectionEventArgs Class

The following tables list the members exposed by ExpressionInfoCollectionEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ExpressionInfoCollectionEventArgs Constructor | Initializes a new instance of ExpressionInfoCollectionEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Index | Returns the Integer for the ExpressionInfo object that was added or removed.
Public Property | Value | Returns the ExpressionInfo object that was added or removed.
Top
See Also

Reference

ExpressionInfoCollectionEventArgs Class
GrapeCity.ActiveReports.Expressions Namespace


ExpressionInfoCollectionEventArgs Constructor

ExpressionInfoCollectionEventArgs Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfoCollectionEventArgs Class : ExpressionInfoCollectionEventArgs Constructor
An Int32 indicating the index of the ExpressionInfo object that was added or removed.
The ExpressionInfo object that was added or removed.
Initializes a new instance of ExpressionInfoCollectionEventArgs class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal index As System.Integer, _
   ByVal value As ExpressionInfo _
)
public ExpressionInfoCollectionEventArgs(
   System.int index,
   ExpressionInfo value
)

Parameters

index
An Int32 indicating the index of the ExpressionInfo object that was added or removed.
value
The ExpressionInfo object that was added or removed.
See Also

Reference

ExpressionInfoCollectionEventArgs Class
ExpressionInfoCollectionEventArgs Members


ExpressionInfoCollectionEventArgs Class Properties

ExpressionInfoCollectionEventArgs Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace : ExpressionInfoCollectionEventArgs Class

For a list of all members of this type, see ExpressionInfoCollectionEventArgs members.

Public Properties
 | Name | Description
Public Property | Index | Returns the Integer for the ExpressionInfo object that was added or removed.
Public Property | Value | Returns the ExpressionInfo object that was added or removed.
Top
See Also

Reference

ExpressionInfoCollectionEventArgs Class
GrapeCity.ActiveReports.Expressions Namespace


Index Property (ExpressionInfoCollectionEventArgs)

Index Property (ExpressionInfoCollectionEventArgs)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfoCollectionEventArgs Class : Index Property
Returns the Integer for the ExpressionInfo object that was added or removed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Index As System.Integer
public System.int Index {get;}

Property Value

An Integer indicating the index of the ExpressionInfo object that was added or removed.
See Also

Reference

ExpressionInfoCollectionEventArgs Class
ExpressionInfoCollectionEventArgs Members


Value Property (ExpressionInfoCollectionEventArgs)

Value Property (ExpressionInfoCollectionEventArgs)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfoCollectionEventArgs Class : Value Property
Returns the ExpressionInfo object that was added or removed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Value As ExpressionInfo
public ExpressionInfo Value {get;}

Property Value

An ExpressionInfo object representing the item that was added or removed.
See Also

Reference

ExpressionInfoCollectionEventArgs Class
ExpressionInfoCollectionEventArgs Members


ExpressionResultType Enumeration

ExpressionResultType Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace : ExpressionResultType Enumeration
Specifies the data type of an expression result.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ExpressionResultType
   Inherits System.Enum
public enum ExpressionResultType : System.Enum
Members
Member | Description
Binary | Expression results in a Binary type.
Boolean | Expression results in a Boolean type.
DateTime | Expression results in a DateTime type.
Error | Expression results in an Error.
Float | Expression results in a Float type.
Integer | Expression results in a Integer type.
String | Expression results in a String type.
Variant | Expression results in a Variant type.
VariantArray | Expression results in a Variant Array type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Expressions.ExpressionResultType

See Also

Reference

GrapeCity.ActiveReports.Expressions Namespace


IExpressionEvaluatorService Interface

IExpressionEvaluatorService Interface
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace : IExpressionEvaluatorService Interface
Allows an ExpressionInfo object to be evaluated.
Object Model
IExpressionEvaluatorService Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IExpressionEvaluatorService
public interface IExpressionEvaluatorService
See Also

Reference

IExpressionEvaluatorService Members
GrapeCity.ActiveReports.Expressions Namespace


IExpressionEvaluatorService Interface Members

IExpressionEvaluatorService Interface Members
Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace : IExpressionEvaluatorService Interface

The following tables list the members exposed by IExpressionEvaluatorService.

Public Methods
 | Name | Description
Method | Evaluate | Evaluates the ExpressionInfo object and returns the evaluated result or null if it cannot be evaluated.
Method | Fork | Creates new evaluator within context of given services.
Method | IsValid | Determines whether the ExpressionInfo object is an expression that can potentially be evaluated. Expressions with invalid syntax return false.
Top
See Also

Reference

IExpressionEvaluatorService Interface
GrapeCity.ActiveReports.Expressions Namespace


IExpressionEvaluatorService Interface Methods

IExpressionEvaluatorService Interface Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace : IExpressionEvaluatorService Interface

For a list of all members of this type, see IExpressionEvaluatorService members.

Public Methods
 | Name | Description
Method | Evaluate | Evaluates the ExpressionInfo object and returns the evaluated result or null if it cannot be evaluated.
Method | Fork | Creates new evaluator within context of given services.
Method | IsValid | Determines whether the ExpressionInfo object is an expression that can potentially be evaluated. Expressions with invalid syntax return false.
Top
See Also

Reference

IExpressionEvaluatorService Interface
GrapeCity.ActiveReports.Expressions Namespace


Evaluate Method

Evaluate Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > IExpressionEvaluatorService Interface : Evaluate Method
The ExpressionInfo object to evaluate.
Evaluates the ExpressionInfo object and returns the evaluated result or null if it cannot be evaluated.
Syntax
  • Visual Basic
  • C#
'Declaration

Function Evaluate( _
   ByVal expression As ExpressionInfo _
) As System.Object
System.object Evaluate(
   ExpressionInfo expression
)

Parameters

expression
The ExpressionInfo object to evaluate.

Return Value

Resulting value of the ExpressionInfo object or null.
See Also

Reference

IExpressionEvaluatorService Interface
IExpressionEvaluatorService Members


Fork Method

Fork Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > IExpressionEvaluatorService Interface : Fork Method
Specifies new context.
Creates new evaluator within context of given services.
Syntax
  • Visual Basic
  • C#
'Declaration

Function Fork( _
   ByVal serviceProvider As System.IServiceProvider _
) As IExpressionEvaluatorService
IExpressionEvaluatorService Fork(
   System.IServiceProvider serviceProvider
)

Parameters

serviceProvider
Specifies new context.
See Also

Reference

IExpressionEvaluatorService Interface
IExpressionEvaluatorService Members


IsValid Method

IsValid Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > IExpressionEvaluatorService Interface : IsValid Method
The ExpressionInfo object to evaluate.
Determines whether the ExpressionInfo object is an expression that can potentially be evaluated. Expressions with invalid syntax return false.
Syntax
  • Visual Basic
  • C#
'Declaration

Function IsValid( _
   ByVal expression As ExpressionInfo _
) As System.Boolean
System.bool IsValid(
   ExpressionInfo expression
)

Parameters

expression
The ExpressionInfo object to evaluate.

Return Value

True if the syntax is valid, otherwise False.
See Also

Reference

IExpressionEvaluatorService Interface
IExpressionEvaluatorService Members


ITheme Interface

ITheme Interface
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace : ITheme Interface
Defines an interface to set and get theme information.
Object Model
ITheme Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITheme
public interface ITheme
See Also

Reference

ITheme Members
GrapeCity.ActiveReports.Expressions Namespace


ITheme Interface Members

ITheme Interface Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace : ITheme Interface

The following tables list the members exposed by ITheme.

Public Properties
 | Name | Description
Property | Theme | Returns the currently attached theme.
Property | ThemeAttached | Gets if a theme file is currently attached.
Property | ThemeUri | Returns the name of the currently attached theme.
Top
Public Methods
 | Name | Description
Method | CreateTheme | Creates a new theme based on the supplied URI.
Method | GetColors | Returns all the theme colors associated with the currently attached theme.
Top
See Also

Reference

ITheme Interface
GrapeCity.ActiveReports.Expressions Namespace


ITheme Interface Methods

ITheme Interface Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace : ITheme Interface

For a list of all members of this type, see ITheme members.

Public Methods
 | Name | Description
Method | CreateTheme | Creates a new theme based on the supplied URI.
Method | GetColors | Returns all the theme colors associated with the currently attached theme.
Top
See Also

Reference

ITheme Interface
GrapeCity.ActiveReports.Expressions Namespace


CreateTheme Method

CreateTheme Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ITheme Interface : CreateTheme Method
The URI of the existing theme to create the new theme from.
Creates a new theme based on the supplied URI.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub CreateTheme( _
   ByVal uri As System.String _
)
void CreateTheme(
   System.string uri
)

Parameters

uri
The URI of the existing theme to create the new theme from.
See Also

Reference

ITheme Interface
ITheme Members


GetColors Method

GetColors Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ITheme Interface : GetColors Method
Returns all the theme colors associated with the currently attached theme.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetColors() As System.String()
System.string[] GetColors()
See Also

Reference

ITheme Interface
ITheme Members


ITheme Interface Properties

ITheme Interface Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace : ITheme Interface

For a list of all members of this type, see ITheme members.

Public Properties
 | Name | Description
Property | Theme | Returns the currently attached theme.
Property | ThemeAttached | Gets if a theme file is currently attached.
Property | ThemeUri | Returns the name of the currently attached theme.
Top
See Also

Reference

ITheme Interface
GrapeCity.ActiveReports.Expressions Namespace


Theme Property

Theme Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ITheme Interface : Theme Property
Returns the currently attached theme.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Theme As Theme
Theme Theme {get;}
See Also

Reference

ITheme Interface
ITheme Members


ThemeAttached Property

ThemeAttached Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ITheme Interface : ThemeAttached Property
Gets if a theme file is currently attached.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ThemeAttached As System.Boolean
System.bool ThemeAttached {get;}
See Also

Reference

ITheme Interface
ITheme Members


ThemeUri Property (ITheme)

ThemeUri Property (ITheme)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ITheme Interface : ThemeUri Property
Returns the name of the currently attached theme.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ThemeUri As System.String
System.string ThemeUri {get;}
See Also

Reference

ITheme Interface
ITheme Members


ExpressionInfoCollectionEventHandler Delegate

ExpressionInfoCollectionEventHandler Delegate

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace : ExpressionInfoCollectionEventHandler Delegate
The source of the event.
The ExpressionInfoCollectionEventArgs object that contains the event data.
Represents the method that handles the ItemAdded or ItemRemoved event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub ExpressionInfoCollectionEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As ExpressionInfoCollectionEventArgs _
)
public delegate void ExpressionInfoCollectionEventHandler(
   System.object sender,
   ExpressionInfoCollectionEventArgs e
)

Parameters

sender
The source of the event.
e
The ExpressionInfoCollectionEventArgs object that contains the event data.
See Also

Reference

ExpressionInfoCollectionEventHandler Members
GrapeCity.ActiveReports.Expressions Namespace


GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace

GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace
The GrapeCity.ActiveReports.Expression.ExpressionObjectModel namespace includes parameter related classes.
Classes
 | Class | Description
Class | Parameter | Specifies information about a parameter for the report.
Class | ParameterCollection | A Collection of Parameter objects.
Class | ParameterValue | Describes a parameter value.
Class | ParameterValueCollection | A Collection of ParameterValue objects.
Class | ReportParameterException | An exception thrown when an error related to a report's parameter occurs.
Enumerations
 | Enumeration | Description
Enumeration | ParameterState | Specifies the state of a parameter.
Enumeration | ParameterType | Specifies the available data types for a parameter.
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


Parameter Class

Parameter Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace : Parameter Class
Specifies information about a parameter for the report.
Object Model
Parameter Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Parameter
public sealed class Parameter
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel.Parameter

See Also

Reference

Parameter Members
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace


Parameter Class Members

Parameter Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace : Parameter Class

The following tables list the members exposed by Parameter.

Public Properties
 | Name | Description
Public Property | AllowBlank | Indicates whether an empty string is a valid value for this parameter.
Public Property | CurrentValue | Gets or sets the current value of the Parameter.
Public Property | DataType | The data type of the parameter.
Public Property | DateOnly | Indicates whether the user should be prompted for both date and time or only the date. Applicable to DateTime parameters.
Public Property | DefaultValues | The default value or values (if this parameter is a MultiValue parameter) to use for the parameter.
Public Property | DefinesValidValues | Gets whether this parameter has valid values defined in the report definition.
Public Property | DependentParameters | Returns Parameter objects that cannot be evaluated until this Parameter is evaluated.
Public Property | ErrorMessage | Gets the error message associated with this parameter.
Public Property | Hidden | Indicates the parameter should not be displayed to the user.
Public Property | Label | Gets or sets the label of the current value of the Parameter.
Public Property | LabelsArray | Returns an object array of all the Values.Label for this parameter. Mainly for use with Multivalue parameters.
Public Property | Multiline | Indicates whether the parameter value supposes to be multiline.
Public Property | MultiValue | Indicates if this parameter accepts multiple values.
Public Property | Name | Name of the parameter (This name can be used by expressions to refer to this parameter).
Public Property | Nullable | Indicates the value for this parameter is allowed to be Null.
Public Property | Prompt | The text to display to a user when prompting the a for the parameter's value.
Public Property | PromptUser | Indicates if the user should be prompted for this parameter's value.
Public Property | QueryParameter | Indicates whether the parameter is used in a query.
Public Property | State | Specifies the current state of this parameter.
Public Property | ValidValues | The ordered list of possible values for this parameter.
Public Property | Values | Gets the Values collection for this parameter. Used for Multivalue parameters.
Public Property | ValuesArray | Returns an object array of all the Values.Value for this parameter. Mainly for use with Multivalue parameters.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | Create | Creates new instance of Parameter with specified properties.
Top
See Also

Reference

Parameter Class
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace


Parameter Class Methods

Parameter Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace : Parameter Class

For a list of all members of this type, see Parameter members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Create | Creates new instance of Parameter with specified properties.
Top
See Also

Reference

Parameter Class
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace


Create Method (Parameter)

Create Method (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > Parameter Class : Create Method
The parameter name.
The text to display to a user when prompting the a for the parameter's value.
The data type of the new parameter.
Specifies the state of the new parameter.
Specifies whether the new parameter is allowed to be Null.
Specifies whether an empty string is a valid value for the new parameter.
Specifies whether parameter should not be displayed to the user.
Specifies whether the new parameter accepts multiple values.
Specifies whether the new parameter is used in a query.
Specifies whether the parameter value supposes to be multiline.
Indicates whether the user should be prompted for both date and time or only the date. Applicable to DateTime parameters.
Creates new instance of Parameter with specified properties.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function Create( _
   ByVal name As System.String, _
   ByVal prompt As System.String, _
   ByVal dataType As ParameterType, _
   ByVal state As ParameterState, _
   ByVal nullable As System.Boolean, _
   ByVal allowBlank As System.Boolean, _
   ByVal hidden As System.Boolean, _
   ByVal multiValue As System.Boolean, _
   ByVal usedInQuery As System.Boolean, _
   ByVal multiline As System.Boolean, _
   ByVal dateOnly As System.Boolean _
) As Parameter
public static Parameter Create(
   System.string name,
   System.string prompt,
   ParameterType dataType,
   ParameterState state,
   System.bool nullable,
   System.bool allowBlank,
   System.bool hidden,
   System.bool multiValue,
   System.bool usedInQuery,
   System.bool multiline,
   System.bool dateOnly
)

Parameters

name
The parameter name.
prompt
The text to display to a user when prompting the a for the parameter's value.
dataType
The data type of the new parameter.
state
Specifies the state of the new parameter.
nullable
Specifies whether the new parameter is allowed to be Null.
allowBlank
Specifies whether an empty string is a valid value for the new parameter.
hidden
Specifies whether parameter should not be displayed to the user.
multiValue
Specifies whether the new parameter accepts multiple values.
usedInQuery
Specifies whether the new parameter is used in a query.
multiline
Specifies whether the parameter value supposes to be multiline.
dateOnly
Indicates whether the user should be prompted for both date and time or only the date. Applicable to DateTime parameters.

Return Value

New Parameter instance.
See Also

Reference

Parameter Class
Parameter Members


Parameter Class Properties

Parameter Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace : Parameter Class

For a list of all members of this type, see Parameter members.

Public Properties
 | Name | Description
Public Property | AllowBlank | Indicates whether an empty string is a valid value for this parameter.
Public Property | CurrentValue | Gets or sets the current value of the Parameter.
Public Property | DataType | The data type of the parameter.
Public Property | DateOnly | Indicates whether the user should be prompted for both date and time or only the date. Applicable to DateTime parameters.
Public Property | DefaultValues | The default value or values (if this parameter is a MultiValue parameter) to use for the parameter.
Public Property | DefinesValidValues | Gets whether this parameter has valid values defined in the report definition.
Public Property | DependentParameters | Returns Parameter objects that cannot be evaluated until this Parameter is evaluated.
Public Property | ErrorMessage | Gets the error message associated with this parameter.
Public Property | Hidden | Indicates the parameter should not be displayed to the user.
Public Property | Label | Gets or sets the label of the current value of the Parameter.
Public Property | LabelsArray | Returns an object array of all the Values.Label for this parameter. Mainly for use with Multivalue parameters.
Public Property | Multiline | Indicates whether the parameter value supposes to be multiline.
Public Property | MultiValue | Indicates if this parameter accepts multiple values.
Public Property | Name | Name of the parameter (This name can be used by expressions to refer to this parameter).
Public Property | Nullable | Indicates the value for this parameter is allowed to be Null.
Public Property | Prompt | The text to display to a user when prompting the a for the parameter's value.
Public Property | PromptUser | Indicates if the user should be prompted for this parameter's value.
Public Property | QueryParameter | Indicates whether the parameter is used in a query.
Public Property | State | Specifies the current state of this parameter.
Public Property | ValidValues | The ordered list of possible values for this parameter.
Public Property | Values | Gets the Values collection for this parameter. Used for Multivalue parameters.
Public Property | ValuesArray | Returns an object array of all the Values.Value for this parameter. Mainly for use with Multivalue parameters.
Top
See Also

Reference

Parameter Class
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace


AllowBlank Property (Parameter)

AllowBlank Property (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > Parameter Class : AllowBlank Property
Indicates whether an empty string is a valid value for this parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property AllowBlank As System.Boolean
public System.bool AllowBlank {get;}
See Also

Reference

Parameter Class
Parameter Members


CurrentValue Property

CurrentValue Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > Parameter Class : CurrentValue Property
Gets or sets the current value of the Parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CurrentValue As System.Object
public System.object CurrentValue {get; set;}
See Also

Reference

Parameter Class
Parameter Members


DataType Property (Parameter)

DataType Property (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > Parameter Class : DataType Property
The data type of the parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DataType As ParameterType
public ParameterType DataType {get;}
See Also

Reference

Parameter Class
Parameter Members


DateOnly Property (Parameter)

DateOnly Property (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > Parameter Class : DateOnly Property
Indicates whether the user should be prompted for both date and time or only the date. Applicable to DateTime parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DateOnly As System.Boolean
public System.bool DateOnly {get;}
See Also

Reference

Parameter Class
Parameter Members


DefaultValues Property

DefaultValues Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > Parameter Class : DefaultValues Property
The default value or values (if this parameter is a MultiValue parameter) to use for the parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DefaultValues As ParameterValueCollection
public ParameterValueCollection DefaultValues {get;}
See Also

Reference

Parameter Class
Parameter Members


DefinesValidValues Property

DefinesValidValues Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > Parameter Class : DefinesValidValues Property
Gets whether this parameter has valid values defined in the report definition.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DefinesValidValues As System.Boolean
public System.bool DefinesValidValues {get;}
Remarks
Can be used to determine if a selection list is needed when populating UI.
See Also

Reference

Parameter Class
Parameter Members


DependentParameters Property

DependentParameters Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > Parameter Class : DependentParameters Property
Returns Parameter objects that cannot be evaluated until this Parameter is evaluated.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DependentParameters As ParameterCollection
public ParameterCollection DependentParameters {get;}
See Also

Reference

Parameter Class
Parameter Members


ErrorMessage Property

ErrorMessage Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > Parameter Class : ErrorMessage Property
Gets the error message associated with this parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ErrorMessage As System.String
public System.string ErrorMessage {get;}
See Also

Reference

Parameter Class
Parameter Members


Hidden Property (Parameter)

Hidden Property (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > Parameter Class : Hidden Property
Indicates the parameter should not be displayed to the user.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Hidden As System.Boolean
public System.bool Hidden {get;}
See Also

Reference

Parameter Class
Parameter Members


Label Property (Parameter)

Label Property (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > Parameter Class : Label Property
Gets or sets the label of the current value of the Parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Label As System.String
public System.string Label {get; set;}
See Also

Reference

Parameter Class
Parameter Members


LabelsArray Property

LabelsArray Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > Parameter Class : LabelsArray Property
Returns an object array of all the Values.Label for this parameter. Mainly for use with Multivalue parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property LabelsArray As System.String()
public System.string[] LabelsArray {get;}

Property Value

Returns a string array of all the Values.Label.
See Also

Reference

Parameter Class
Parameter Members


Multiline Property (Parameter)

Multiline Property (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > Parameter Class : Multiline Property
Indicates whether the parameter value supposes to be multiline.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Multiline As System.Boolean
public System.bool Multiline {get;}
See Also

Reference

Parameter Class
Parameter Members


MultiValue Property (Parameter)

MultiValue Property (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > Parameter Class : MultiValue Property
Indicates if this parameter accepts multiple values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MultiValue As System.Boolean
public System.bool MultiValue {get;}
See Also

Reference

Parameter Class
Parameter Members


Name Property (Parameter)

Name Property (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > Parameter Class : Name Property
Name of the parameter (This name can be used by expressions to refer to this parameter).
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Name As System.String
public System.string Name {get;}
See Also

Reference

Parameter Class
Parameter Members


Nullable Property (Parameter)

Nullable Property (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > Parameter Class : Nullable Property
Indicates the value for this parameter is allowed to be Null.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Nullable As System.Boolean
public System.bool Nullable {get;}
See Also

Reference

Parameter Class
Parameter Members


Prompt Property (Parameter)

Prompt Property (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > Parameter Class : Prompt Property
The text to display to a user when prompting the a for the parameter's value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Prompt As System.String
public System.string Prompt {get;}
See Also

Reference

Parameter Class
Parameter Members


PromptUser Property (Parameter)

PromptUser Property (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > Parameter Class : PromptUser Property
Indicates if the user should be prompted for this parameter's value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PromptUser As System.Boolean
public System.bool PromptUser {get;}
See Also

Reference

Parameter Class
Parameter Members


QueryParameter Property

QueryParameter Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > Parameter Class : QueryParameter Property
Indicates whether the parameter is used in a query.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property QueryParameter As System.Boolean
public System.bool QueryParameter {get;}
See Also

Reference

Parameter Class
Parameter Members


State Property (Parameter)

State Property (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > Parameter Class : State Property
Specifies the current state of this parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property State As ParameterState
public ParameterState State {get;}
See Also

Reference

Parameter Class
Parameter Members


ValidValues Property (Parameter)

ValidValues Property (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > Parameter Class : ValidValues Property
The ordered list of possible values for this parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ValidValues As ParameterValueCollection
public ParameterValueCollection ValidValues {get;}
Remarks
Can be used for populating UI selection lists for users to select a parameter value.
See Also

Reference

Parameter Class
Parameter Members


Values Property (Parameter)

Values Property (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > Parameter Class : Values Property
Gets the Values collection for this parameter. Used for Multivalue parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Values As ParameterValueCollection
public ParameterValueCollection Values {get;}
See Also

Reference

Parameter Class
Parameter Members


ValuesArray Property

ValuesArray Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > Parameter Class : ValuesArray Property
Returns an object array of all the Values.Value for this parameter. Mainly for use with Multivalue parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ValuesArray As System.Object()
public System.object[] ValuesArray {get;}

Property Value

Returns an object array of all the Values.Value.
See Also

Reference

Parameter Class
Parameter Members


ParameterCollection Class

ParameterCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace : ParameterCollection Class
A Collection of Parameter objects.
Object Model
ParameterCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ParameterCollection
   Inherits System.Collections.CollectionBase
public class ParameterCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel.ParameterCollection

See Also

Reference

ParameterCollection Members
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace


ParameterCollection Class Members

ParameterCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace : ParameterCollection Class

The following tables list the members exposed by ParameterCollection.

Public Constructors
 | Name | Description
Public Constructor | ParameterCollection Constructor | Creates a new instance of ParameterCollection class.
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the ParameterCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the ParameterCollection instance. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Gets the Parameter from the ParameterCollection.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds Parameter item to this collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Overloaded. Determines if a Parameter is in this collection.
Public Method | CopyTo | Copies this collection of Parameter items to the array.
Public Method | Remove | Removes the Parameter from this collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ParameterCollection Class
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace


ParameterCollection Constructor

ParameterCollection Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterCollection Class : ParameterCollection Constructor
Creates a new instance of ParameterCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ParameterCollection()
See Also

Reference

ParameterCollection Class
ParameterCollection Members


ParameterCollection Class Methods

ParameterCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace : ParameterCollection Class

For a list of all members of this type, see ParameterCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds Parameter item to this collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Overloaded. Determines if a Parameter is in this collection.
Public Method | CopyTo | Copies this collection of Parameter items to the array.
Public Method | Remove | Removes the Parameter from this collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ParameterCollection Class
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace


Add Method (ParameterCollection)

Add Method (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterCollection Class : Add Method
Parameter to add.
Adds Parameter item to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Add( _
   ByVal item As Parameter _
)
public void Add(
   Parameter item
)

Parameters

item
Parameter to add.
See Also

Reference

ParameterCollection Class
ParameterCollection Members


Contains Method (ParameterCollection)

Contains Method (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterCollection Class : Contains Method
Determines if a Parameter is in this collection.
Overload List
Overload | Description
Contains(Parameter) | Determines if a Parameter is in this collection.
Contains(String) | Returns true if a parameter is in the collection with the specified name.
See Also

Reference

ParameterCollection Class
ParameterCollection Members


Contains(Parameter) Method

Contains(Parameter) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterCollection Class > Contains Method : Contains(Parameter) Method
Parameter to find.
Determines if a Parameter is in this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Contains( _
   ByVal item As Parameter _
) As System.Boolean
public System.bool Contains(
   Parameter item
)

Parameters

item
Parameter to find.

Return Value

true if item is in this collection, otherwise false.
See Also

Reference

ParameterCollection Class
ParameterCollection Members
Overload List


Contains(String) Method

Contains(String) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterCollection Class > Contains Method : Contains(String) Method
The name of the parameter to check.
Returns true if a parameter is in the collection with the specified name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Contains( _
   ByVal name As System.String _
) As System.Boolean
public System.bool Contains(
   System.string name
)

Parameters

name
The name of the parameter to check.
See Also

Reference

ParameterCollection Class
ParameterCollection Members
Overload List


CopyTo Method (ParameterCollection)

CopyTo Method (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterCollection Class : CopyTo Method
destination
starting point.
Copies this collection of Parameter items to the array.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal array() As Parameter, _
   ByVal arrayIndex As System.Integer _
)
public void CopyTo(
   Parameter[] array,
   System.int arrayIndex
)

Parameters

array
destination
arrayIndex
starting point.
See Also

Reference

ParameterCollection Class
ParameterCollection Members


Remove Method (ParameterCollection)

Remove Method (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterCollection Class : Remove Method
the parameter to remove
Removes the Parameter from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal item As Parameter _
)
public void Remove(
   Parameter item
)

Parameters

item
the parameter to remove

Return Value

true if successful, otherwise false.
See Also

Reference

ParameterCollection Class
ParameterCollection Members


ParameterCollection Class Properties

ParameterCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace : ParameterCollection Class

For a list of all members of this type, see ParameterCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the ParameterCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the ParameterCollection instance. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Gets the Parameter from the ParameterCollection.
Top
See Also

Reference

ParameterCollection Class
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace


Item Property (ParameterCollection)

Item Property (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterCollection Class : Item Property
Gets the Parameter from the ParameterCollection.
Overload List
Overload | Description
Item(String) | Gets the Parameter with the given name.
Item(Int32) | Gets the Parameter by specified index
See Also

Reference

ParameterCollection Class
ParameterCollection Members


Item(String) Property

Item(String) Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterCollection Class > Item Property : Item(String) Property
Name of the parameter to return.
Gets the Parameter with the given name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal name As System.String _
) As Parameter
public Parameter Item(
   System.string name
) {get;}

Parameters

name
Name of the parameter to return.

Property Value

The Parameter, otherwise null.
See Also

Reference

ParameterCollection Class
ParameterCollection Members
Overload List


Item(Int32) Property

Item(Int32) Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterCollection Class > Item Property : Item(Int32) Property
Index of the parameter to return.
Gets the Parameter by specified index
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal index As System.Integer _
) As Parameter
public Parameter Item(
   System.int index
) {get;}

Parameters

index
Index of the parameter to return.

Property Value

The Parameter, otherwise throws exception.
See Also

Reference

ParameterCollection Class
ParameterCollection Members
Overload List


ParameterValue Class

ParameterValue Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace : ParameterValue Class
Describes a parameter value.
Object Model
ParameterValue Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ParameterValue
public sealed class ParameterValue
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel.ParameterValue

See Also

Reference

ParameterValue Members
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace


ParameterValue Class Members

ParameterValue Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace : ParameterValue Class

The following tables list the members exposed by ParameterValue.

Public Constructors
 | Name | Description
Public Constructor | ParameterValue Constructor | Overloaded. Creates a new instance of ParameterValue class.
Top
Public Properties
 | Name | Description
Public Property | Label | Label for the value to display in a UI
Public Property | Value | Specifies a value for a parameter.
Top
Public Methods
 | Name | Description
Public Method | Equals | Tests for equivalence between two ParameterValue objects.
Public Method | GetHashCode | Returns the hash code for ParameterValue.
Top
See Also

Reference

ParameterValue Class
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace


ParameterValue Constructor

ParameterValue Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterValue Class : ParameterValue Constructor
Creates a new instance of ParameterValue class.
Overload List
Overload | Description
ParameterValue Constructor() | Creates a new instance of ParameterValue class.
ParameterValue Constructor(ParameterValue) | Creates a copy of the ParameterValue parameter.
ParameterValue Constructor(Parameter) | Creates a ParameterValue object.
See Also

Reference

ParameterValue Class
ParameterValue Members


ParameterValue Constructor()

ParameterValue Constructor()

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterValue Class > ParameterValue Constructor : ParameterValue Constructor()
Creates a new instance of ParameterValue class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ParameterValue()
See Also

Reference

ParameterValue Class
ParameterValue Members
Overload List


ParameterValue Constructor(ParameterValue)

ParameterValue Constructor(ParameterValue)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterValue Class > ParameterValue Constructor : ParameterValue Constructor(ParameterValue)
Parameter object to initialize with.
Creates a copy of the ParameterValue parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal p As ParameterValue _
)
public ParameterValue(
   ParameterValue p
)

Parameters

p
Parameter object to initialize with.
See Also

Reference

ParameterValue Class
ParameterValue Members
Overload List


ParameterValue Constructor(Parameter)

ParameterValue Constructor(Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterValue Class > ParameterValue Constructor : ParameterValue Constructor(Parameter)
Parameter object to initialize with.
Creates a ParameterValue object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal p As Parameter _
)
public ParameterValue(
   Parameter p
)

Parameters

p
Parameter object to initialize with.
See Also

Reference

ParameterValue Class
ParameterValue Members
Overload List


ParameterValue Class Methods

ParameterValue Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace : ParameterValue Class

For a list of all members of this type, see ParameterValue members.

Public Methods
 | Name | Description
Public Method | Equals | Tests for equivalence between two ParameterValue objects.
Public Method | GetHashCode | Returns the hash code for ParameterValue.
Top
See Also

Reference

ParameterValue Class
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace


Equals Method (ParameterValue)

Equals Method (ParameterValue)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterValue Class : Equals Method
The parameter value to compare the current value with.
Tests for equivalence between two ParameterValue objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The parameter value to compare the current value with.

Return Value

True if the objects are equal; otherwise false.
See Also

Reference

ParameterValue Class
ParameterValue Members


GetHashCode Method (ParameterValue)

GetHashCode Method (ParameterValue)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterValue Class : GetHashCode Method
Returns the hash code for ParameterValue.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()
See Also

Reference

ParameterValue Class
ParameterValue Members


ParameterValue Class Properties

ParameterValue Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace : ParameterValue Class

For a list of all members of this type, see ParameterValue members.

Public Properties
 | Name | Description
Public Property | Label | Label for the value to display in a UI
Public Property | Value | Specifies a value for a parameter.
Top
See Also

Reference

ParameterValue Class
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace


Label Property (ParameterValue)

Label Property (ParameterValue)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterValue Class : Label Property
Label for the value to display in a UI
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Label As System.String
public System.string Label {get; set;}
Remarks
If not supplied, the Value is used as the label. If Value is not supplied, Label is the empty string.
See Also

Reference

ParameterValue Class
ParameterValue Members


Value Property (ParameterValue)

Value Property (ParameterValue)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterValue Class : Value Property
Specifies a value for a parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As System.Object
public System.object Value {get; set;}
Remarks
For Boolean parameters, use "true" and "false". For DateTime parameters, use ISO 8601. For Float parameters, use “.” As the optional decimal separator.
See Also

Reference

ParameterValue Class
ParameterValue Members


ParameterValueCollection Class

ParameterValueCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace : ParameterValueCollection Class
A Collection of ParameterValue objects.
Object Model
ParameterValueCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ParameterValueCollection
   Inherits System.Collections.CollectionBase
public class ParameterValueCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel.ParameterValueCollection

See Also

Reference

ParameterValueCollection Members
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace


ParameterValueCollection Class Members

ParameterValueCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace : ParameterValueCollection Class

The following tables list the members exposed by ParameterValueCollection.

Public Constructors
 | Name | Description
Public Constructor | ParameterValueCollection Constructor | Overloaded. Creates a new instance of ParameterValueCollection class.
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the ParameterValueCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the ParameterValueCollection instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Gets if the collection is readonly.
Public Property | Item | Gets the ParameterValue by specified index
Top
Public Methods
 | Name | Description
Public Method | Add | Adds ParameterValue item to this collection.
Public Method | AddRange | Adds an array of ParameterValue items to this collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines if a ParameterValue is in this collection.
Public Method | CopyTo | Copies this collection of ParameterValue items to the array.
Public Method | Remove | Removes the ParameterValue from this collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ParameterValueCollection Class
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace


ParameterValueCollection Constructor

ParameterValueCollection Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterValueCollection Class : ParameterValueCollection Constructor
Creates a new instance of ParameterValueCollection class.
Overload List
Overload | Description
ParameterValueCollection Constructor() | Creates a new instance of ParameterValueCollection class.
ParameterValueCollection Constructor(Boolean) | Creates a new instance of ParameterValueCollection class.
See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


ParameterValueCollection Constructor()

ParameterValueCollection Constructor()

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterValueCollection Class > ParameterValueCollection Constructor : ParameterValueCollection Constructor()
Creates a new instance of ParameterValueCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ParameterValueCollection()
See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members
Overload List


ParameterValueCollection Constructor(Boolean)

ParameterValueCollection Constructor(Boolean)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterValueCollection Class > ParameterValueCollection Constructor : ParameterValueCollection Constructor(Boolean)
Indicates whether the parameter value may include more than one value.
Creates a new instance of ParameterValueCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal multiValue As System.Boolean _
)
public ParameterValueCollection(
   System.bool multiValue
)

Parameters

multiValue
Indicates whether the parameter value may include more than one value.
See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members
Overload List


ParameterValueCollection Class Methods

ParameterValueCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace : ParameterValueCollection Class

For a list of all members of this type, see ParameterValueCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds ParameterValue item to this collection.
Public Method | AddRange | Adds an array of ParameterValue items to this collection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines if a ParameterValue is in this collection.
Public Method | CopyTo | Copies this collection of ParameterValue items to the array.
Public Method | Remove | Removes the ParameterValue from this collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ParameterValueCollection Class
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace


Add Method (ParameterValueCollection)

Add Method (ParameterValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterValueCollection Class : Add Method
ParameterValue to add.
Adds ParameterValue item to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Add( _
   ByVal item As ParameterValue _
)
public void Add(
   ParameterValue item
)

Parameters

item
ParameterValue to add.
See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


AddRange Method (ParameterValueCollection)

AddRange Method (ParameterValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterValueCollection Class : AddRange Method
Array of ParameterValue items to be added.
Adds an array of ParameterValue items to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddRange( _
   ByVal items() As ParameterValue _
)
public void AddRange(
   ParameterValue[] items
)

Parameters

items
Array of ParameterValue items to be added.
See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


Contains Method (ParameterValueCollection)

Contains Method (ParameterValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterValueCollection Class : Contains Method
ParameterValue to find.
Determines if a ParameterValue is in this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal item As ParameterValue _
) As System.Boolean
public System.bool Contains(
   ParameterValue item
)

Parameters

item
ParameterValue to find.

Return Value

true if item is in this collection, otherwise false.
See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


CopyTo Method (ParameterValueCollection)

CopyTo Method (ParameterValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterValueCollection Class : CopyTo Method
destination
starting point.
Copies this collection of ParameterValue items to the array.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal array() As ParameterValue, _
   ByVal arrayIndex As System.Integer _
)
public void CopyTo(
   ParameterValue[] array,
   System.int arrayIndex
)

Parameters

array
destination
arrayIndex
starting point.
See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


Remove Method (ParameterValueCollection)

Remove Method (ParameterValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterValueCollection Class : Remove Method
the ParameterValue to remove
Removes the ParameterValue from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal item As ParameterValue _
)
public void Remove(
   ParameterValue item
)

Parameters

item
the ParameterValue to remove

Return Value

true if successful, otherwise false.
See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


ParameterValueCollection Class Properties

ParameterValueCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace : ParameterValueCollection Class

For a list of all members of this type, see ParameterValueCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the ParameterValueCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the ParameterValueCollection instance. (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Gets if the collection is readonly.
Public Property | Item | Gets the ParameterValue by specified index
Top
See Also

Reference

ParameterValueCollection Class
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace


IsReadOnly Property (ParameterValueCollection)

IsReadOnly Property (ParameterValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterValueCollection Class : IsReadOnly Property
Gets if the collection is readonly.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsReadOnly As System.Boolean
public System.bool IsReadOnly {get;}

Property Value

true
See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


Item Property (ParameterValueCollection)

Item Property (ParameterValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterValueCollection Class : Item Property
Index of the ParameterValue to return.
Gets the ParameterValue by specified index
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Default Property Item( _
   ByVal index As System.Integer _
) As ParameterValue
public ParameterValue this[
   System.int index
]; {get;}

Parameters

index
Index of the ParameterValue to return.

Property Value

The ParameterValue, otherwise throws exception.
See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


ReportParameterException Class

ReportParameterException Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace : ReportParameterException Class
An exception thrown when an error related to a report's parameter occurs.
Object Model
ReportParameterException Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ReportParameterException
   Inherits GrapeCity.ActiveReports.ReportException
public class ReportParameterException : GrapeCity.ActiveReports.ReportException
Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.ReportException
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel.ReportParameterException

See Also

Reference

ReportParameterException Members
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace


ReportParameterException Class Members

ReportParameterException Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace : ReportParameterException Class

The following tables list the members exposed by ReportParameterException.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Error code for future detail processing. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | ErrorData | Error data, depends on error code. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

ReportParameterException Class
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace


ParameterState Enumeration

ParameterState Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace : ParameterState Enumeration
Specifies the state of a parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ParameterState
   Inherits System.Enum
public enum ParameterState : System.Enum
Members
Member | Description
DynamicValuesUnavailable | Indicates that no valid, query-based values were returned as a result of the query used to populate the valid values for the parameter.
HasOutstandingDependencies | Indicates that the valid values for the parameter are dependent upon another parameter's value and the other parameter does not yet have a valid value. Once the other parameter has a valid value, the state of the dependent parameter will change.
HasValidValue | The current value for the parameter is valid.
MissingValidValue | The current value for the parameter is not valid.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel.ParameterState

See Also

Reference

GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace


ParameterType Enumeration

ParameterType Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace : ParameterType Enumeration
Specifies the available data types for a parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ParameterType
   Inherits System.Enum
public enum ParameterType : System.Enum
Members
Member | Description
Boolean | Specifies a true or false value.
DateTime | Specifies an ISO 8601 date/time value.
Float | Specifies a floating point number.
Integer | Specifies an integral number.
String | Specifies a textual value.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel.ParameterType

See Also

Reference

GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace


GrapeCity.ActiveReports.Options Namespace

GrapeCity.ActiveReports.Options Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports.Options Namespace
The GrapeCity.ActiveReports.Options namespace contains the barcode options classes for Code49, PDF417, and QRCode barcodes.
Classes
 | Class | Description
Class | BarCodeException | The exception thrown when an error is caused by an inapplicable value of the barcode control.
Class | Code128Options | Represents the Code128 barcode's particular information.
Class | Code49Options | Represents the Code49 barcode's particular information.
Class | DataMatrixOptions | Represents the options of the Data Matrix barcode.
Class | GS1CompositeOptions | Represents the GS1 composite brcode's particular information.
Class | MicroPDF417Options | Represents the MicroPDF417 barcode's particular information.
Class | PDF417Options | Represents the PDF417 barcode's particular information.
Class | QRCodeOptions | Represents the QRCode barcode's particular information.
Class | RssExpandedStackedOptions | Represents the RssExpandedStacked barcode's particular information.
Enumerations
 | Enumeration | Description
Enumeration | DataMatrixEcc000_140SymbolSize | The symbol size enumeration for ECC000-140 mode.
Enumeration | DataMatrixEcc200EncodingMode | The enumeration of encoding char set under ECC200 mode.
Enumeration | DataMatrixEcc200SymbolSize | The symbol size enumeration for ECC200 mode.
Enumeration | DataMatrixEccMode | The ECC mode enumeration.
Enumeration | GS1CompositeType | Composite symbol type.
Enumeration | MicroPDF417SymbolCompactionMode | MicroPDF417 encoding compaction mode.
Enumeration | MicroPDF417SymbolVersion | MicroPDF417 encoding compaction mode.
Enumeration | PDF417Type | Specifies PDF417's barcode type.
Enumeration | QRCodeErrorLevel | Specifies the QRCode's error correction level.
Enumeration | QRCodeMask | Sets the QRCode's mask pattern reference.
Enumeration | QRCodeModel | Sets the QRCode's model.
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


BarCodeException Class

BarCodeException Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : BarCodeException Class
The exception thrown when an error is caused by an inapplicable value of the barcode control.
Object Model
BarCodeException Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class BarCodeException
   Inherits System.ApplicationException
public class BarCodeException : System.ApplicationException
Remarks

The BarCodeDataException is thrown by the Barcode control.

Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.Options.BarCodeException

See Also

Reference

BarCodeException Members
GrapeCity.ActiveReports.Options Namespace


BarCodeException Class Members

BarCodeException Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : BarCodeException Class

The following tables list the members exposed by BarCodeException.

Public Constructors
 | Name | Description
Public Constructor | BarCodeException Constructor | Overloaded. Initializes a new instance of BarCodeException class.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | Gets the BarCodeException instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Overridden. Gets a message that describes the current exception.
Public Property | Source | Gets or sets the name of the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the BarCodeException that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, it sets the information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

BarCodeException Class
GrapeCity.ActiveReports.Options Namespace


BarCodeException Constructor

BarCodeException Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > BarCodeException Class : BarCodeException Constructor
Initializes a new instance of BarCodeException class.
Overload List
Overload | Description
BarCodeException Constructor() | Initializes a new instance of the System.ApplicationException class.
BarCodeException Constructor(String) | Initializes a new instance of the System.ApplicationException class with a specified error message.
BarCodeException Constructor(String,Exception) | Initializes a new instance of the System.ApplicationException class with a specified error message and a reference to the inner exception that is the cause of this exception.
See Also

Reference

BarCodeException Class
BarCodeException Members


BarCodeException Constructor()

BarCodeException Constructor()

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > BarCodeException Class > BarCodeException Constructor : BarCodeException Constructor()
Initializes a new instance of the System.ApplicationException class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public BarCodeException()
See Also

Reference

BarCodeException Class
BarCodeException Members
Overload List


BarCodeException Constructor(String)

BarCodeException Constructor(String)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > BarCodeException Class > BarCodeException Constructor : BarCodeException Constructor(String)
A message that describes the error.

Initializes a new instance of the System.ApplicationException class with a specified error message.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String _
)
public BarCodeException(
   System.string message
)

Parameters

message
A message that describes the error.
See Also

Reference

BarCodeException Class
BarCodeException Members
Overload List


BarCodeException Constructor(String,Exception)

BarCodeException Constructor(String,Exception)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > BarCodeException Class > BarCodeException Constructor : BarCodeException Constructor(String,Exception)
The error message that explains the reason for the exception.
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.

Initializes a new instance of the System.ApplicationException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal message As System.String, _
   ByVal innerException As System.Exception _
)
public BarCodeException(
   System.string message,
   System.Exception innerException
)

Parameters

message
The error message that explains the reason for the exception.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.
See Also

Reference

BarCodeException Class
BarCodeException Members
Overload List


BarCodeException Class Properties

BarCodeException Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : BarCodeException Class

For a list of all members of this type, see BarCodeException members.

Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | Gets the BarCodeException instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Overridden. Gets a message that describes the current exception.
Public Property | Source | Gets or sets the name of the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
See Also

Reference

BarCodeException Class
GrapeCity.ActiveReports.Options Namespace


Message Property (BarCodeException)

Message Property (BarCodeException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > BarCodeException Class : Message Property

Gets a message that describes the current exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property Message As System.String
public override System.string Message {get;}
See Also

Reference

BarCodeException Class
BarCodeException Members


Code128Options Class

Code128Options Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : Code128Options Class

Represents the Code128 barcode's particular information.

Object Model
Code128Options Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Code128Options
   Inherits BarCodeOptionsBase
public class Code128Options : BarCodeOptionsBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Options.Code128Options

See Also

Reference

Code128Options Members
GrapeCity.ActiveReports.Options Namespace


Code128Options Class Members

Code128Options Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : Code128Options Class

The following tables list the members exposed by Code128Options.

Public Constructors
 | Name | Description
Public Constructor | Code128Options Constructor | Initializes a new instance of the Code128Options class.
Top
Public Properties
 | Name | Description
Public Property | BarAdjust | Specifies the correction of the bar in units of dot.
Public Property | Dpi | Specifies the resolution of the printer.
Public Property | ModuleSize | Sets the width of the barcode module.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Public Method | Equals | Returns true of this instance is equal to provided object.
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

Code128Options Class
GrapeCity.ActiveReports.Options Namespace


Code128Options Constructor()

Code128Options Constructor()

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > Code128Options Class > Code128Options Constructor : Code128Options Constructor()
Initializes a new instance of the Code128Options class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Code128Options()
See Also

Reference

Code128Options Class
Code128Options Members
Overload List


Code128Options Class Methods

Code128Options Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : Code128Options Class

For a list of all members of this type, see Code128Options members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Public Method | Equals | Returns true of this instance is equal to provided object.
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

Code128Options Class
GrapeCity.ActiveReports.Options Namespace


Clone Method (Code128Options)

Clone Method (Code128Options)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > Code128Options Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Clone() As System.Object
public override System.object Clone()

Return Value

A new object that is a copy of this instance.
See Also

Reference

Code128Options Class
Code128Options Members


Equals Method (Code128Options)

Equals Method (Code128Options)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > Code128Options Class : Equals Method
The object to compare with.
Returns true of this instance is equal to provided object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The object to compare with.
See Also

Reference

Code128Options Class
Code128Options Members


ToString Method (Code128Options)

ToString Method (Code128Options)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > Code128Options Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()

Return Value

String that represents the current object.
See Also

Reference

Code128Options Class
Code128Options Members


Code128Options Class Properties

Code128Options Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : Code128Options Class

For a list of all members of this type, see Code128Options members.

Public Properties
 | Name | Description
Public Property | BarAdjust | Specifies the correction of the bar in units of dot.
Public Property | Dpi | Specifies the resolution of the printer.
Public Property | ModuleSize | Sets the width of the barcode module.
Top
See Also

Reference

Code128Options Class
GrapeCity.ActiveReports.Options Namespace


BarAdjust Property

BarAdjust Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > Code128Options Class : BarAdjust Property
Specifies the correction of the bar in units of dot.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BarAdjust As System.Integer
public System.int BarAdjust {get; set;}
See Also

Reference

Code128Options Class
Code128Options Members


Dpi Property

Dpi Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > Code128Options Class : Dpi Property
Specifies the resolution of the printer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Dpi As System.Integer
public System.int Dpi {get; set;}
See Also

Reference

Code128Options Class
Code128Options Members


ModuleSize Property

ModuleSize Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > Code128Options Class : ModuleSize Property
Sets the width of the barcode module.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ModuleSize As System.Integer
public System.int ModuleSize {get; set;}
See Also

Reference

Code128Options Class
Code128Options Members


Code49Options Class

Code49Options Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : Code49Options Class

Represents the Code49 barcode's particular information.

Object Model
Code49Options Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Code49Options
   Inherits BarCodeOptionsBase
public class Code49Options : BarCodeOptionsBase
Remarks
Code49 is a 2D high-density stacked barcode which encodes the complete ASCII character set.
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Options.Code49Options

See Also

Reference

Code49Options Members
GrapeCity.ActiveReports.Options Namespace


Code49Options Class Members

Code49Options Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : Code49Options Class

The following tables list the members exposed by Code49Options.

Public Constructors
 | Name | Description
Public Constructor | Code49Options Constructor | Initializes a new instance of the Code49Options class.
Top
Public Properties
 | Name | Description
Public Property | Group | Gets or sets group numbers.
Public Property | Grouping | Gets or sets a value indicating whether grouping is set for the barcode.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Public Method | Equals | Compares the Code490 object to a specified object to see if they are equal.
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

Code49Options Class
GrapeCity.ActiveReports.Options Namespace


Code49Options Constructor()

Code49Options Constructor()

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > Code49Options Class > Code49Options Constructor : Code49Options Constructor()
Initializes a new instance of the Code49Options class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Code49Options()
See Also

Reference

Code49Options Class
Code49Options Members
Overload List


Code49Options Class Methods

Code49Options Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : Code49Options Class

For a list of all members of this type, see Code49Options members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Public Method | Equals | Compares the Code490 object to a specified object to see if they are equal.
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

Code49Options Class
GrapeCity.ActiveReports.Options Namespace


Clone Method (Code49Options)

Clone Method (Code49Options)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > Code49Options Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Clone() As System.Object
public override System.object Clone()

Return Value

A new object that is a copy of this instance.
See Also

Reference

Code49Options Class
Code49Options Members


Equals Method (Code49Options)

Equals Method (Code49Options)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > Code49Options Class : Equals Method
The System.Object to which the Code49Options object is being compared.
Compares the Code490 object to a specified object to see if they are equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The System.Object to which the Code49Options object is being compared.

Return Value

Boolean.
See Also

Reference

Code49Options Class
Code49Options Members


ToString Method (Code49Options)

ToString Method (Code49Options)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > Code49Options Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()

Return Value

String that represents the current object.
See Also

Reference

Code49Options Class
Code49Options Members


Code49Options Class Properties

Code49Options Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : Code49Options Class

For a list of all members of this type, see Code49Options members.

Public Properties
 | Name | Description
Public Property | Group | Gets or sets group numbers.
Public Property | Grouping | Gets or sets a value indicating whether grouping is set for the barcode.
Top
See Also

Reference

Code49Options Class
GrapeCity.ActiveReports.Options Namespace


Group Property (Code49Options)

Group Property (Code49Options)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > Code49Options Class : Group Property
Gets or sets group numbers.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Group As System.Integer
public System.int Group {get; set;}
Remarks
This property can be used to specify how many portions of the barcode to create when it is split. This property is active only when the Grouping property is set to True. 0 through 8 are valid values which can be set. When invalid group numbers are set, the BarCodeDataException is thrown.
See Also

Reference

Code49Options Class
Code49Options Members


Grouping Property (Code49Options)

Grouping Property (Code49Options)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > Code49Options Class : Grouping Property
Gets or sets a value indicating whether grouping is set for the barcode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Grouping As System.Boolean
public System.bool Grouping {get; set;}

Property Value

A Boolean value. If true, a grouped single barcode is created.
Remarks
With grouping, any value not expressed by a single barcode is expressed by splitting it into several barcodes. This property is used in conjunction with the Group property. When the Group property is set to 2, the grouped barcode's second symbol is created.
See Also

Reference

Code49Options Class
Code49Options Members


DataMatrixOptions Class

DataMatrixOptions Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : DataMatrixOptions Class
Represents the options of the Data Matrix barcode.
Object Model
DataMatrixOptions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DataMatrixOptions
   Inherits BarCodeOptionsBase
public class DataMatrixOptions : BarCodeOptionsBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Options.DataMatrixOptions

See Also

Reference

DataMatrixOptions Members
GrapeCity.ActiveReports.Options Namespace


DataMatrixOptions Class Members

DataMatrixOptions Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : DataMatrixOptions Class

The following tables list the members exposed by DataMatrixOptions.

Public Constructors
 | Name | Description
Public Constructor | DataMatrixOptions Constructor | Overloaded. Initializes a new instance of DataMatrixOptions class.
Top
Public Properties
 | Name | Description
Public Property | Ecc000_140SymbolSize | Gets or sets the size of the ECC000-140 symbol.
Public Property | Ecc200EncodingMode | Gets or sets the ECC200 encoding mode.
Public Property | Ecc200SymbolSize | Gets or sets the size of the ECC200 symbol.
Public Property | EccMode | Gets or sets the ECC mode.
Public Property | EncodingCodePage | Design-time property to specify encoding in designer.
Public Property | FileIdentifier | Gets or sets the file identifier of a related group of structured append symbols.
Public Property | StructuredAppend | Gets or sets a value indicating whether the current symbol is part of structured append symbols.
Public Property | StructureNumber | Gets or sets the structure number of current symbol within the structuerd append symbols.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Public Method | Equals | Determines whether the specified System.Object is equal to the current System.Object.
Public Method | ToString | Returns a System.String that represents the current System.Object.
Top
See Also

Reference

DataMatrixOptions Class
GrapeCity.ActiveReports.Options Namespace


DataMatrixOptions Constructor

DataMatrixOptions Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > DataMatrixOptions Class : DataMatrixOptions Constructor
Initializes a new instance of DataMatrixOptions class.
Overload List
Overload | Description
DataMatrixOptions Constructor() | Initializes a new instance of the GrapeCity.ActiveReports.BarCodes.DataMatrix class.
DataMatrixOptions Constructor(String) | Initializes a new instance of the GrapeCity.ActiveReports.BarCodes.DataMatrix class.
See Also

Reference

DataMatrixOptions Class
DataMatrixOptions Members


DataMatrixOptions Constructor()

DataMatrixOptions Constructor()

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > DataMatrixOptions Class > DataMatrixOptions Constructor : DataMatrixOptions Constructor()
Initializes a new instance of the GrapeCity.ActiveReports.BarCodes.DataMatrix class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DataMatrixOptions()
See Also

Reference

DataMatrixOptions Class
DataMatrixOptions Members
Overload List


DataMatrixOptions Constructor(String)

DataMatrixOptions Constructor(String)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > DataMatrixOptions Class > DataMatrixOptions Constructor : DataMatrixOptions Constructor(String)
The serialized data string.
Initializes a new instance of the GrapeCity.ActiveReports.BarCodes.DataMatrix class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal str As System.String _
)
public DataMatrixOptions(
   System.string str
)

Parameters

str
The serialized data string.
See Also

Reference

DataMatrixOptions Class
DataMatrixOptions Members
Overload List


DataMatrixOptions Class Methods

DataMatrixOptions Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : DataMatrixOptions Class

For a list of all members of this type, see DataMatrixOptions members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Public Method | Equals | Determines whether the specified System.Object is equal to the current System.Object.
Public Method | ToString | Returns a System.String that represents the current System.Object.
Top
See Also

Reference

DataMatrixOptions Class
GrapeCity.ActiveReports.Options Namespace


Clone Method (DataMatrixOptions)

Clone Method (DataMatrixOptions)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > DataMatrixOptions Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Clone() As System.Object
public override System.object Clone()

Return Value

A new object that is a copy of this instance.
See Also

Reference

DataMatrixOptions Class
DataMatrixOptions Members


Equals Method (DataMatrixOptions)

Equals Method (DataMatrixOptions)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > DataMatrixOptions Class : Equals Method
The System.Object to compare with the current System.Object.
Determines whether the specified System.Object is equal to the current System.Object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The System.Object to compare with the current System.Object.

Return Value

true if the specified System.Object is equal to the current System.Object; otherwise, false.
See Also

Reference

DataMatrixOptions Class
DataMatrixOptions Members


ToString Method (DataMatrixOptions)

ToString Method (DataMatrixOptions)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > DataMatrixOptions Class : ToString Method
Returns a System.String that represents the current System.Object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()

Return Value

A System.String that represents the current System.Object.
See Also

Reference

DataMatrixOptions Class
DataMatrixOptions Members


DataMatrixOptions Class Properties

DataMatrixOptions Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : DataMatrixOptions Class

For a list of all members of this type, see DataMatrixOptions members.

Public Properties
 | Name | Description
Public Property | Ecc000_140SymbolSize | Gets or sets the size of the ECC000-140 symbol.
Public Property | Ecc200EncodingMode | Gets or sets the ECC200 encoding mode.
Public Property | Ecc200SymbolSize | Gets or sets the size of the ECC200 symbol.
Public Property | EccMode | Gets or sets the ECC mode.
Public Property | EncodingCodePage | Design-time property to specify encoding in designer.
Public Property | FileIdentifier | Gets or sets the file identifier of a related group of structured append symbols.
Public Property | StructuredAppend | Gets or sets a value indicating whether the current symbol is part of structured append symbols.
Public Property | StructureNumber | Gets or sets the structure number of current symbol within the structuerd append symbols.
Top
See Also

Reference

DataMatrixOptions Class
GrapeCity.ActiveReports.Options Namespace


Ecc000_140SymbolSize Property

Ecc000_140SymbolSize Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > DataMatrixOptions Class : Ecc000_140SymbolSize Property
Gets or sets the size of the ECC000-140 symbol.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Ecc000_140SymbolSize As DataMatrixEcc000_140SymbolSize
public DataMatrixEcc000_140SymbolSize Ecc000_140SymbolSize {get; set;}

Property Value

The size of the ECC000-140 symbol.
See Also

Reference

DataMatrixOptions Class
DataMatrixOptions Members


Ecc200EncodingMode Property

Ecc200EncodingMode Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > DataMatrixOptions Class : Ecc200EncodingMode Property
Gets or sets the ECC200 encoding mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Ecc200EncodingMode As DataMatrixEcc200EncodingMode
public DataMatrixEcc200EncodingMode Ecc200EncodingMode {get; set;}

Property Value

The ECC200 encoding mode.
See Also

Reference

DataMatrixOptions Class
DataMatrixOptions Members


Ecc200SymbolSize Property

Ecc200SymbolSize Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > DataMatrixOptions Class : Ecc200SymbolSize Property
Gets or sets the size of the ECC200 symbol.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Ecc200SymbolSize As DataMatrixEcc200SymbolSize
public DataMatrixEcc200SymbolSize Ecc200SymbolSize {get; set;}

Property Value

The size of the ECC200 symbol.
See Also

Reference

DataMatrixOptions Class
DataMatrixOptions Members


EccMode Property

EccMode Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > DataMatrixOptions Class : EccMode Property
Gets or sets the ECC mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EccMode As DataMatrixEccMode
public DataMatrixEccMode EccMode {get; set;}

Property Value

The ECC mode.
See Also

Reference

DataMatrixOptions Class
DataMatrixOptions Members


EncodingCodePage Property

EncodingCodePage Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > DataMatrixOptions Class : EncodingCodePage Property
Design-time property to specify encoding in designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EncodingCodePage As System.Integer
public System.int EncodingCodePage {get; set;}
See Also

Reference

DataMatrixOptions Class
DataMatrixOptions Members


FileIdentifier Property

FileIdentifier Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > DataMatrixOptions Class : FileIdentifier Property
Gets or sets the file identifier of a related group of structured append symbols.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FileIdentifier As System.Byte
public System.byte FileIdentifier {get; set;}

Property Value

The file identifier.
Remarks
The valid file indentifier value should be within [1,254], set file identifier to 0 lets the file identifier of the symbols calculated automatically.
See Also

Reference

DataMatrixOptions Class
DataMatrixOptions Members


StructuredAppend Property

StructuredAppend Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > DataMatrixOptions Class : StructuredAppend Property
Gets or sets a value indicating whether the current symbol is part of structured append symbols.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StructuredAppend As System.Boolean
public System.bool StructuredAppend {get; set;}

Property Value

true if the current symbol is part of structured append symbols; otherwise, false.
Remarks
Structured append is only supported by ECC200.
See Also

Reference

DataMatrixOptions Class
DataMatrixOptions Members


StructureNumber Property

StructureNumber Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > DataMatrixOptions Class : StructureNumber Property
Gets or sets the structure number of current symbol within the structuerd append symbols.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StructureNumber As System.Integer
public System.int StructureNumber {get; set;}

Property Value

The structure number of current symbol within the structured append symbols. The structure number starts from 0, and should be less than both the symbol amount and the max symbol count(16).
Remarks
The structure number will only be used when ECC mode is DataMatrixEccMode.ECC200.
See Also

Reference

DataMatrixOptions Class
DataMatrixOptions Members


GS1CompositeOptions Class

GS1CompositeOptions Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : GS1CompositeOptions Class
Represents the GS1 composite brcode's particular information.
Object Model
GS1CompositeOptions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class GS1CompositeOptions
   Inherits BarCodeOptionsBase
public class GS1CompositeOptions : BarCodeOptionsBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Options.GS1CompositeOptions

See Also

Reference

GS1CompositeOptions Members
GrapeCity.ActiveReports.Options Namespace


GS1CompositeOptions Class Members

GS1CompositeOptions Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : GS1CompositeOptions Class

The following tables list the members exposed by GS1CompositeOptions.

Public Constructors
 | Name | Description
Public Constructor | GS1CompositeOptions Constructor | Initializes a new instance of the GS1CompositeOptions class.
Top
Public Properties
 | Name | Description
Public Property | Type | Gets or sets the composite symbol type. Default value is None.
Public Property | Value | Gets or sets the CCA character data.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Public Method | Equals | Compares the GS1CompositeOptions object to another System.Object to see if they are equal.
Public Method | ToString | Returns a System.String that represents the current System.Object.
Top
See Also

Reference

GS1CompositeOptions Class
GrapeCity.ActiveReports.Options Namespace


GS1CompositeOptions Constructor

GS1CompositeOptions Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > GS1CompositeOptions Class : GS1CompositeOptions Constructor
Initializes a new instance of the GS1CompositeOptions class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public GS1CompositeOptions()
See Also

Reference

GS1CompositeOptions Class
GS1CompositeOptions Members


GS1CompositeOptions Class Methods

GS1CompositeOptions Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : GS1CompositeOptions Class

For a list of all members of this type, see GS1CompositeOptions members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Public Method | Equals | Compares the GS1CompositeOptions object to another System.Object to see if they are equal.
Public Method | ToString | Returns a System.String that represents the current System.Object.
Top
See Also

Reference

GS1CompositeOptions Class
GrapeCity.ActiveReports.Options Namespace


Clone Method (GS1CompositeOptions)

Clone Method (GS1CompositeOptions)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > GS1CompositeOptions Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Clone() As System.Object
public override System.object Clone()

Return Value

A new object that is a copy of this instance.
See Also

Reference

GS1CompositeOptions Class
GS1CompositeOptions Members


Equals Method (GS1CompositeOptions)

Equals Method (GS1CompositeOptions)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > GS1CompositeOptions Class : Equals Method
The System.Object to which the GS1CompositeOptions object is being compared.
Compares the GS1CompositeOptions object to another System.Object to see if they are equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The System.Object to which the GS1CompositeOptions object is being compared.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.
See Also

Reference

GS1CompositeOptions Class
GS1CompositeOptions Members


ToString Method (GS1CompositeOptions)

ToString Method (GS1CompositeOptions)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > GS1CompositeOptions Class : ToString Method
Returns a System.String that represents the current System.Object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()

Return Value

A System.String that represents the current System.Object.
See Also

Reference

GS1CompositeOptions Class
GS1CompositeOptions Members


GS1CompositeOptions Class Properties

GS1CompositeOptions Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : GS1CompositeOptions Class

For a list of all members of this type, see GS1CompositeOptions members.

Public Properties
 | Name | Description
Public Property | Type | Gets or sets the composite symbol type. Default value is None.
Public Property | Value | Gets or sets the CCA character data.
Top
See Also

Reference

GS1CompositeOptions Class
GrapeCity.ActiveReports.Options Namespace


Type Property (GS1CompositeOptions)

Type Property (GS1CompositeOptions)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > GS1CompositeOptions Class : Type Property
Gets or sets the composite symbol type. Default value is None.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Type As GS1CompositeType
public GS1CompositeType Type {get; set;}
See Also

Reference

GS1CompositeOptions Class
GS1CompositeOptions Members


Value Property (GS1CompositeOptions)

Value Property (GS1CompositeOptions)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > GS1CompositeOptions Class : Value Property
Gets or sets the CCA character data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As System.String
public System.string Value {get; set;}
See Also

Reference

GS1CompositeOptions Class
GS1CompositeOptions Members


MicroPDF417Options Class

MicroPDF417Options Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : MicroPDF417Options Class
Represents the MicroPDF417 barcode's particular information.
Object Model
MicroPDF417Options Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class MicroPDF417Options
   Inherits BarCodeOptionsBase
public class MicroPDF417Options : BarCodeOptionsBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Options.MicroPDF417Options

See Also

Reference

MicroPDF417Options Members
GrapeCity.ActiveReports.Options Namespace


MicroPDF417Options Class Members

MicroPDF417Options Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : MicroPDF417Options Class

The following tables list the members exposed by MicroPDF417Options.

Public Constructors
 | Name | Description
Public Constructor | MicroPDF417Options Constructor | Overloaded. Initializes a new instance of the MicroPDF417Options class.
Top
Public Properties
 | Name | Description
Public Property | CompactionMode | Gets or sets the CompactionMode.
Public Property | FileID | Gets or sets the file id of the structured append symbol.
Public Property | SegmentCount | Gets or sets the segment count of the structured append symbol.
Public Property | SegmentIndex | Gets or sets the segment index of structured append symbol.
Public Property | Version | Gets or sets the symbol size.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Public Method | Equals | Compares the MicroPDF417Options object to another System.Object to see if they are equal.
Public Method | ToString | Returns a System.String that represents the current System.Object.
Top
See Also

Reference

MicroPDF417Options Class
GrapeCity.ActiveReports.Options Namespace


MicroPDF417Options Constructor

MicroPDF417Options Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > MicroPDF417Options Class : MicroPDF417Options Constructor
Initializes a new instance of the MicroPDF417Options class.
Overload List
Overload | Description
MicroPDF417Options Constructor() | Initializes a new instance of the MicroPDF417Options class.
MicroPDF417Options Constructor(String) | Initializes a new instance of the MicroPDF417Options class.
See Also

Reference

MicroPDF417Options Class
MicroPDF417Options Members


MicroPDF417Options Constructor()

MicroPDF417Options Constructor()

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > MicroPDF417Options Class > MicroPDF417Options Constructor : MicroPDF417Options Constructor()
Initializes a new instance of the MicroPDF417Options class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MicroPDF417Options()
See Also

Reference

MicroPDF417Options Class
MicroPDF417Options Members
Overload List


MicroPDF417Options Constructor(String)

MicroPDF417Options Constructor(String)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > MicroPDF417Options Class > MicroPDF417Options Constructor : MicroPDF417Options Constructor(String)
The serialized data string.
Initializes a new instance of the MicroPDF417Options class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal str As System.String _
)
public MicroPDF417Options(
   System.string str
)

Parameters

str
The serialized data string.
See Also

Reference

MicroPDF417Options Class
MicroPDF417Options Members
Overload List


MicroPDF417Options Class Methods

MicroPDF417Options Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : MicroPDF417Options Class

For a list of all members of this type, see MicroPDF417Options members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Public Method | Equals | Compares the MicroPDF417Options object to another System.Object to see if they are equal.
Public Method | ToString | Returns a System.String that represents the current System.Object.
Top
See Also

Reference

MicroPDF417Options Class
GrapeCity.ActiveReports.Options Namespace


Clone Method (MicroPDF417Options)

Clone Method (MicroPDF417Options)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > MicroPDF417Options Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Clone() As System.Object
public override System.object Clone()

Return Value

A new object that is a copy of this instance.
See Also

Reference

MicroPDF417Options Class
MicroPDF417Options Members


Equals Method (MicroPDF417Options)

Equals Method (MicroPDF417Options)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > MicroPDF417Options Class : Equals Method
The System.Object to which the MicroPDF417Options object is being compared.
Compares the MicroPDF417Options object to another System.Object to see if they are equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The System.Object to which the MicroPDF417Options object is being compared.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.
See Also

Reference

MicroPDF417Options Class
MicroPDF417Options Members


ToString Method (MicroPDF417Options)

ToString Method (MicroPDF417Options)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > MicroPDF417Options Class : ToString Method
Returns a System.String that represents the current System.Object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()

Return Value

A System.String that represents the current System.Object.
See Also

Reference

MicroPDF417Options Class
MicroPDF417Options Members


MicroPDF417Options Class Properties

MicroPDF417Options Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : MicroPDF417Options Class

For a list of all members of this type, see MicroPDF417Options members.

Public Properties
 | Name | Description
Public Property | CompactionMode | Gets or sets the CompactionMode.
Public Property | FileID | Gets or sets the file id of the structured append symbol.
Public Property | SegmentCount | Gets or sets the segment count of the structured append symbol.
Public Property | SegmentIndex | Gets or sets the segment index of structured append symbol.
Public Property | Version | Gets or sets the symbol size.
Top
See Also

Reference

MicroPDF417Options Class
GrapeCity.ActiveReports.Options Namespace


CompactionMode Property

CompactionMode Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > MicroPDF417Options Class : CompactionMode Property
Gets or sets the CompactionMode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CompactionMode As MicroPDF417SymbolCompactionMode
public MicroPDF417SymbolCompactionMode CompactionMode {get; set;}
See Also

Reference

MicroPDF417Options Class
MicroPDF417Options Members


FileID Property

FileID Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > MicroPDF417Options Class : FileID Property
Gets or sets the file id of the structured append symbol.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FileID As System.Integer
public System.int FileID {get; set;}
Remarks
Valid value is from 0 to 899.
See Also

Reference

MicroPDF417Options Class
MicroPDF417Options Members


SegmentCount Property

SegmentCount Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > MicroPDF417Options Class : SegmentCount Property
Gets or sets the segment count of the structured append symbol.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SegmentCount As System.Integer
public System.int SegmentCount {get; set;}
Remarks
Valid value is from 0 to 99999.
See Also

Reference

MicroPDF417Options Class
MicroPDF417Options Members


SegmentIndex Property

SegmentIndex Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > MicroPDF417Options Class : SegmentIndex Property
Gets or sets the segment index of structured append symbol.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SegmentIndex As System.Integer
public System.int SegmentIndex {get; set;}
Remarks
Valid value is from 0 to 99998, and less than SegmentCount.
See Also

Reference

MicroPDF417Options Class
MicroPDF417Options Members


Version Property (MicroPDF417Options)

Version Property (MicroPDF417Options)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > MicroPDF417Options Class : Version Property
Gets or sets the symbol size.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Version As MicroPDF417SymbolVersion
public MicroPDF417SymbolVersion Version {get; set;}
See Also

Reference

MicroPDF417Options Class
MicroPDF417Options Members


PDF417Options Class

PDF417Options Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : PDF417Options Class

Represents the PDF417 barcode's particular information.

Object Model
PDF417Options Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class PDF417Options
   Inherits BarCodeOptionsBase
public class PDF417Options : BarCodeOptionsBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Options.PDF417Options

See Also

Reference

PDF417Options Members
GrapeCity.ActiveReports.Options Namespace


PDF417Options Class Members

PDF417Options Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : PDF417Options Class

The following tables list the members exposed by PDF417Options.

Public Constructors
 | Name | Description
Public Constructor | PDF417Options Constructor | Initializes a new instance of PDF417Options class.
Top
Public Properties
 | Name | Description
Public Property | Column | Gets or sets column numbers for the barcode.
Public Property | ErrorLevel | Gets or sets the error correction level for the barcode.
Public Property | Row | Gets or sets row numbers for the barcode.
Public Property | Type | Gets or set the PDF417 barcode's type.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Public Method | Equals | Compares the PDF417 object to another System.Object to see if they are equal.
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PDF417Options Class
GrapeCity.ActiveReports.Options Namespace


PDF417Options Constructor()

PDF417Options Constructor()

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > PDF417Options Class > PDF417Options Constructor : PDF417Options Constructor()
Initializes a new instance of PDF417Options class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public PDF417Options()
See Also

Reference

PDF417Options Class
PDF417Options Members
Overload List


PDF417Options Class Methods

PDF417Options Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : PDF417Options Class

For a list of all members of this type, see PDF417Options members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Public Method | Equals | Compares the PDF417 object to another System.Object to see if they are equal.
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

PDF417Options Class
GrapeCity.ActiveReports.Options Namespace


Clone Method (PDF417Options)

Clone Method (PDF417Options)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > PDF417Options Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Clone() As System.Object
public override System.object Clone()

Return Value

A new object that is a copy of this instance.
See Also

Reference

PDF417Options Class
PDF417Options Members


Equals Method (PDF417Options)

Equals Method (PDF417Options)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > PDF417Options Class : Equals Method
The System.Object to which the PDF417 object is being compared.
Compares the PDF417 object to another System.Object to see if they are equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The System.Object to which the PDF417 object is being compared.

Return Value

Boolean. True if the Border object is equal to the System.Object; otherwise False.
See Also

Reference

PDF417Options Class
PDF417Options Members


ToString Method (PDF417Options)

ToString Method (PDF417Options)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > PDF417Options Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()

Return Value

A System.String that represents this instance.
See Also

Reference

PDF417Options Class
PDF417Options Members


PDF417Options Class Properties

PDF417Options Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : PDF417Options Class

For a list of all members of this type, see PDF417Options members.

Public Properties
 | Name | Description
Public Property | Column | Gets or sets column numbers for the barcode.
Public Property | ErrorLevel | Gets or sets the error correction level for the barcode.
Public Property | Row | Gets or sets row numbers for the barcode.
Public Property | Type | Gets or set the PDF417 barcode's type.
Top
See Also

Reference

PDF417Options Class
GrapeCity.ActiveReports.Options Namespace


Column Property (PDF417Options)

Column Property (PDF417Options)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > PDF417Options Class : Column Property
Gets or sets column numbers for the barcode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Column As System.Integer
public System.int Column {get; set;}
Remarks
Values for this property normally range from 1 to 30. The default value is -1 which specifies row numbers to be automatically determined.
See Also

Reference

PDF417Options Class
PDF417Options Members


ErrorLevel Property (PDF417Options)

ErrorLevel Property (PDF417Options)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > PDF417Options Class : ErrorLevel Property
Gets or sets the error correction level for the barcode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ErrorLevel As System.Integer
public System.int ErrorLevel {get; set;}
Remarks
Values between 1 and 8 can be specified for this property. Level 0 is the lowest error correction level. The error correction capability increases as the value for this property increases. With each increase in the ErrorLevel value, the size of the barcode increases. The default value is -1 which indicates auto configuration.
See Also

Reference

PDF417Options Class
PDF417Options Members


Row Property

Row Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > PDF417Options Class : Row Property
Gets or sets row numbers for the barcode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Row As System.Integer
public System.int Row {get; set;}
Remarks
Values between 3 and 90 can be set for this property. The default value is -1 which specifies that row numbers are to be determined automatically.
See Also

Reference

PDF417Options Class
PDF417Options Members


Type Property (PDF417Options)

Type Property (PDF417Options)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > PDF417Options Class : Type Property
Gets or set the PDF417 barcode's type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Type As PDF417Type
public PDF417Type Type {get; set;}
Remarks
Uses the PDF417Type enumeration.
See Also

Reference

PDF417Options Class
PDF417Options Members


QRCodeOptions Class

QRCodeOptions Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : QRCodeOptions Class

Represents the QRCode barcode's particular information.

Object Model
QRCodeOptions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class QRCodeOptions
   Inherits BarCodeOptionsBase
public class QRCodeOptions : BarCodeOptionsBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Options.QRCodeOptions

See Also

Reference

QRCodeOptions Members
GrapeCity.ActiveReports.Options Namespace


QRCodeOptions Class Members

QRCodeOptions Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : QRCodeOptions Class

The following tables list the members exposed by QRCodeOptions.

Public Constructors
 | Name | Description
Public Constructor | QRCodeOptions Constructor | Initializes a new instance of QRCodeOptions class.
Top
Public Properties
 | Name | Description
Public Property | Connection | Gets or sets whether connection is used for the barcode.
Public Property | ConnectionNumber | Gets or sets the connection number for the barcode.
Public Property | ErrorLevel | Gets or sets the error correction level for the barcode.
Public Property | Mask | Gets or sets the pattern used for the barcode's masking.
Public Property | Model | Gets or sets the QRCode's model.
Public Property | Version | Gets or sets the QRCode's version.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Public Method | Equals | Compares the QRCodeOptions object to another System.Object to see if they are equal.
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

QRCodeOptions Class
GrapeCity.ActiveReports.Options Namespace


QRCodeOptions Constructor()

QRCodeOptions Constructor()

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > QRCodeOptions Class > QRCodeOptions Constructor : QRCodeOptions Constructor()
Initializes a new instance of QRCodeOptions class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public QRCodeOptions()
See Also

Reference

QRCodeOptions Class
QRCodeOptions Members
Overload List


QRCodeOptions Class Methods

QRCodeOptions Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : QRCodeOptions Class

For a list of all members of this type, see QRCodeOptions members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Public Method | Equals | Compares the QRCodeOptions object to another System.Object to see if they are equal.
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

QRCodeOptions Class
GrapeCity.ActiveReports.Options Namespace


Clone Method (QRCodeOptions)

Clone Method (QRCodeOptions)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > QRCodeOptions Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Clone() As System.Object
public override System.object Clone()

Return Value

A new object that is a copy of this instance.
See Also

Reference

QRCodeOptions Class
QRCodeOptions Members


Equals Method (QRCodeOptions)

Equals Method (QRCodeOptions)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > QRCodeOptions Class : Equals Method
The System.Object to which the QRCodeOptions object is being compared.
Compares the QRCodeOptions object to another System.Object to see if they are equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
The System.Object to which the QRCodeOptions object is being compared.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.
See Also

Reference

QRCodeOptions Class
QRCodeOptions Members


ToString Method (QRCodeOptions)

ToString Method (QRCodeOptions)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > QRCodeOptions Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()

Return Value

A System.String that represents this instance.
See Also

Reference

QRCodeOptions Class
QRCodeOptions Members


QRCodeOptions Class Properties

QRCodeOptions Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : QRCodeOptions Class

For a list of all members of this type, see QRCodeOptions members.

Public Properties
 | Name | Description
Public Property | Connection | Gets or sets whether connection is used for the barcode.
Public Property | ConnectionNumber | Gets or sets the connection number for the barcode.
Public Property | ErrorLevel | Gets or sets the error correction level for the barcode.
Public Property | Mask | Gets or sets the pattern used for the barcode's masking.
Public Property | Model | Gets or sets the QRCode's model.
Public Property | Version | Gets or sets the QRCode's version.
Top
See Also

Reference

QRCodeOptions Class
GrapeCity.ActiveReports.Options Namespace


Connection Property

Connection Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > QRCodeOptions Class : Connection Property
Gets or sets whether connection is used for the barcode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Connection As System.Boolean
public System.bool Connection {get; set;}

Property Value

A Boolean value. If true, a connected single barcode is created.
Remarks
Connection means that any value which cannot be expressed by a single barcode is split into several barcodes. This property is used in conjunction with the ConnectionNumber property. When 2 is specified for the ConnectionNumber property, the connected barcode's second symbol is created.
See Also

Reference

QRCodeOptions Class
QRCodeOptions Members


ConnectionNumber Property

ConnectionNumber Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > QRCodeOptions Class : ConnectionNumber Property
Gets or sets the connection number for the barcode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ConnectionNumber As System.Integer
public System.int ConnectionNumber {get; set;}
Remarks
Use this property with the Connection property. Values between 0 and 15 are valid and can be set. When the ConnectionNumber property's value is invalid, the BarCodeData Exception is thrown.
See Also

Reference

QRCodeOptions Class
QRCodeOptions Members


ErrorLevel Property (QRCodeOptions)

ErrorLevel Property (QRCodeOptions)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > QRCodeOptions Class : ErrorLevel Property
Gets or sets the error correction level for the barcode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ErrorLevel As QRCodeErrorLevel
public QRCodeErrorLevel ErrorLevel {get; set;}
Remarks
This property uses the QRCodeErrorLevel enumeration. Low is the lowest error correction value and High is the highest possible error correction level value. As the level increases, the size of the barcode increases.
See Also

Reference

QRCodeOptions Class
QRCodeOptions Members


Mask Property

Mask Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > QRCodeOptions Class : Mask Property
Gets or sets the pattern used for the barcode's masking.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Mask As QRCodeMask
public QRCodeMask Mask {get; set;}
Remarks
Masking is the process used to balance brightness to confirm QRCode's read, which is selected from 8 different patterns. This property uses the QRCodeMask enumeration. The default value is -1, which indicates that the masking pattern is set automatically. The default value is recommended for most uses.
See Also

Reference

QRCodeOptions Class
QRCodeOptions Members


Model Property

Model Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > QRCodeOptions Class : Model Property
Gets or sets the QRCode's model.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Model As QRCodeModel
public QRCodeModel Model {get; set;}
Remarks
This property uses the QRCodeModel enumeration.
See Also

Reference

QRCodeOptions Class
QRCodeOptions Members


Version Property (QRCodeOptions)

Version Property (QRCodeOptions)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > QRCodeOptions Class : Version Property
Gets or sets the QRCode's version.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Version As System.Integer
public System.int Version {get; set;}
Remarks

Version indicates the size of the barcode. As the value increases, the barcode's size increases, enabling more information to be stored.

Specify any value between 1 and 14 when the Model property is set to Model1 and 1 to 40 for Model2. When -1 is specified, the version most suited to the value is automatically determined.

See Also

Reference

QRCodeOptions Class
QRCodeOptions Members


RssExpandedStackedOptions Class

RssExpandedStackedOptions Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : RssExpandedStackedOptions Class
Represents the RssExpandedStacked barcode's particular information.
Object Model
RssExpandedStackedOptions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class RssExpandedStackedOptions
   Inherits BarCodeOptionsBase
public class RssExpandedStackedOptions : BarCodeOptionsBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Options.RssExpandedStackedOptions

See Also

Reference

RssExpandedStackedOptions Members
GrapeCity.ActiveReports.Options Namespace


RssExpandedStackedOptions Class Members

RssExpandedStackedOptions Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : RssExpandedStackedOptions Class

The following tables list the members exposed by RssExpandedStackedOptions.

Public Constructors
 | Name | Description
Public Constructor | RssExpandedStackedOptions Constructor | Initializes a new instance of the RssExpandedStackedOptions class.
Top
Public Properties
 | Name | Description
Public Property | RowCount | Gets or sets the number of stacked rows for the RSS Expanded Stacked barcode type.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Public Method | Equals | Compares the RssExpandedStackedOptions object to another System.Object to see if they are equal.
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

RssExpandedStackedOptions Class
GrapeCity.ActiveReports.Options Namespace


RssExpandedStackedOptions Constructor()

RssExpandedStackedOptions Constructor()

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > RssExpandedStackedOptions Class > RssExpandedStackedOptions Constructor : RssExpandedStackedOptions Constructor()
Initializes a new instance of the RssExpandedStackedOptions class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public RssExpandedStackedOptions()
See Also

Reference

RssExpandedStackedOptions Class
RssExpandedStackedOptions Members
Overload List


RssExpandedStackedOptions Class Methods

RssExpandedStackedOptions Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : RssExpandedStackedOptions Class

For a list of all members of this type, see RssExpandedStackedOptions members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Public Method | Equals | Compares the RssExpandedStackedOptions object to another System.Object to see if they are equal.
Public Method | ToString | Returns a string that represents the current object.
Top
See Also

Reference

RssExpandedStackedOptions Class
GrapeCity.ActiveReports.Options Namespace


Clone Method (RssExpandedStackedOptions)

Clone Method (RssExpandedStackedOptions)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > RssExpandedStackedOptions Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Clone() As System.Object
public override System.object Clone()

Return Value

A new object that is a copy of this instance.
See Also

Reference

RssExpandedStackedOptions Class
RssExpandedStackedOptions Members


Equals Method (RssExpandedStackedOptions)

Equals Method (RssExpandedStackedOptions)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > RssExpandedStackedOptions Class : Equals Method
The value to check the equality with.
Compares the RssExpandedStackedOptions object to another System.Object to see if they are equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal val As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object val
)

Parameters

val
The value to check the equality with.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.
See Also

Reference

RssExpandedStackedOptions Class
RssExpandedStackedOptions Members


ToString Method (RssExpandedStackedOptions)

ToString Method (RssExpandedStackedOptions)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > RssExpandedStackedOptions Class : ToString Method
Returns a string that represents the current object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()

Return Value

A System.String that represents this instance.
See Also

Reference

RssExpandedStackedOptions Class
RssExpandedStackedOptions Members


RssExpandedStackedOptions Class Properties

RssExpandedStackedOptions Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : RssExpandedStackedOptions Class

For a list of all members of this type, see RssExpandedStackedOptions members.

Public Properties
 | Name | Description
Public Property | RowCount | Gets or sets the number of stacked rows for the RSS Expanded Stacked barcode type.
Top
See Also

Reference

RssExpandedStackedOptions Class
GrapeCity.ActiveReports.Options Namespace


RowCount Property (RssExpandedStackedOptions)

RowCount Property (RssExpandedStackedOptions)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > RssExpandedStackedOptions Class : RowCount Property
Gets or sets the number of stacked rows for the RSS Expanded Stacked barcode type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RowCount As System.Integer
public System.int RowCount {get; set;}
See Also

Reference

RssExpandedStackedOptions Class
RssExpandedStackedOptions Members


DataMatrixEcc000_140SymbolSize Enumeration

DataMatrixEcc000_140SymbolSize Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : DataMatrixEcc000_140SymbolSize Enumeration
The symbol size enumeration for ECC000-140 mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DataMatrixEcc000_140SymbolSize
   Inherits System.Enum
public enum DataMatrixEcc000_140SymbolSize : System.Enum
Members
Member | Description
Auto | Auto. The smallest symbol size which fits the data will be selected automatically.
Square11 | Square11. Represents 11 by 11 square symbol.
Square13 | Square13. Represents 13 by 13 square symbol.
Square15 | Square15. Represents 15 by 15 square symbol.
Square17 | Square17. Represents 17 by 17 square symbol.
Square19 | Square19. Represents 19 by 19 square symbol.
Square21 | Square21. Represents 21 by 21 square symbol.
Square23 | Square23. Represents 23 by 23 square symbol.
Square25 | Square25. Represents 25 by 25 square symbol.
Square27 | Square27. Represents 27 by 27 square symbol.
Square29 | Square29. Represents 29 by 29 square symbol.
Square31 | Square31. Represents 31 by 31 square symbol.
Square33 | Square33. Represents 33 by 33 square symbol.
Square35 | Square35. Represents 35 by 35 square symbol.
Square37 | Square37 Represents 37 by 37 square symbol.
Square39 | Square39. Represents 39 by 39 square symbol.
Square41 | Square41. Represents 41 by 41 square symbol.
Square43 | Square43. Represents 43 by 43 square symbol.
Square45 | Square45. Represents 45 by 45 square symbol.
Square47 | Square47. Represents 47 by 47 square symbol.
Square49 | Square49. Represents 49 by 49 square symbol.
Square9 | Square9. Represents 9 by 9 square symbol.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Options.DataMatrixEcc000_140SymbolSize

See Also

Reference

GrapeCity.ActiveReports.Options Namespace


DataMatrixEcc200EncodingMode Enumeration

DataMatrixEcc200EncodingMode Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : DataMatrixEcc200EncodingMode Enumeration
The enumeration of encoding char set under ECC200 mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DataMatrixEcc200EncodingMode
   Inherits System.Enum
public enum DataMatrixEcc200EncodingMode : System.Enum
Members
Member | Description
ASCII | ASCII.
Auto | Auto. The encoding char set will be selected automatically to achieve a better compression efficiency.
Base256 | Base256.
C40 | C40.
EDIFACT | EDIFACT. Only 63 EDIFACT characters are supported by this char set.
Text | Text.
X12 | X12. Only 40 X12 characters are supported by this char set.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Options.DataMatrixEcc200EncodingMode

See Also

Reference

GrapeCity.ActiveReports.Options Namespace


DataMatrixEcc200SymbolSize Enumeration

DataMatrixEcc200SymbolSize Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : DataMatrixEcc200SymbolSize Enumeration
The symbol size enumeration for ECC200 mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DataMatrixEcc200SymbolSize
   Inherits System.Enum
public enum DataMatrixEcc200SymbolSize : System.Enum
Members
Member | Description
Rectangular12x26 | Rectangular12x26. Represents 12 by 26 rectangular symbol.
Rectangular12x36 | Rectangular12x36. Represents 12 by 36 rectangular symbol.
Rectangular16x36 | Rectangular16x36. Represents 16 by 36 rectangular symbol.
Rectangular16x48 | Rectangular16x48. Represents 16 by 48 rectangular symbol.
Rectangular8x18 | Rectangular8x18. Represents 8 by 18 rectangular symbol.
Rectangular8x32 | Rectangular8x32. Represents 8 by 32 rectangular symbol.
RectangularAuto | RectangularAuto. The minimum rectangular symbol size that fits the data will be selected automatically.
Square10 | Square10. Represents 10 by 10 square symbol.
Square104 | Square104. Represents 104 by 104 square symbol.
Square12 | Square12. Represents 12 by 12 square symbol.
Square120 | Square120. Represents 120 by 120 square symbol.
Square132 | Square132. Represents 132 by 132 square symbol.
Square14 | Square14. Represents 14 by 14 square symbol.
Square144 | Square144. Represents 144 by 144 square symbol.
Square16 | Square16. Represents 16 by 16 square symbol.
Square18 | Square18. Represents 18 by 18 square symbol.
Square20 | Square20. Represents 20 by 20 square symbol.
Square22 | Square22. Represents 22 by 22 square symbol.
Square24 | Square24. Represents 24 by 24 square symbol.
Square26 | Square26. Represents 26 by 26 square symbol.
Square32 | Square32. Represents 32 by 32 square symbol.
Square36 | Square36. Represents 36 by 36 square symbol.
Square40 | Square40. Represents 40 by 40 square symbol.
Square44 | Square44. Represents 44 by 44 square symbol.
Square48 | Square48. Represents 48 by 48 square symbol.
Square52 | Square52. Represents 52 by 52 square symbol.
Square64 | Square64. Represents 64 by 64 square symbol.
Square72 | Square72. Represents 72 by 72 square symbol.
Square80 | Square80. Represents 80 by 80 square symbol.
Square88 | Square88. Represents 88 by 88 square symbol.
Square96 | Square96. Represents 96 by 96 square symbol.
SquareAuto | SquareAuto. The minimum square symbol size that fits the data will be selected automatically.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Options.DataMatrixEcc200SymbolSize

See Also

Reference

GrapeCity.ActiveReports.Options Namespace


DataMatrixEccMode Enumeration

DataMatrixEccMode Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : DataMatrixEccMode Enumeration
The ECC mode enumeration.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DataMatrixEccMode
   Inherits System.Enum
public enum DataMatrixEccMode : System.Enum
Members
Member | Description
ECC000 | ECC000. This mode encodes data with only CRC checksum, no additional error checking bits. Data encoded with this ECC mode usually requiers the smallest symbol size.
ECC050 | ECC050.
ECC080 | ECC080.
ECC100 | ECC100.
ECC140 | ECC140.
ECC200 | ECC200. This is the suggested ECC mode. Data encoded with this ECC mode will be protedted Reed-Solomon error checking and correcting algorithm.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Options.DataMatrixEccMode

See Also

Reference

GrapeCity.ActiveReports.Options Namespace


GS1CompositeType Enumeration

GS1CompositeType Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : GS1CompositeType Enumeration
Composite symbol type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum GS1CompositeType
   Inherits System.Enum
public enum GS1CompositeType : System.Enum
Members
Member | Description
CCA | Composite the GS1 barcode with a dependent CC-A barcode.
None | Does not composite the GS1 barcode with a depenent barcode.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Options.GS1CompositeType

See Also

Reference

GrapeCity.ActiveReports.Options Namespace


MicroPDF417SymbolCompactionMode Enumeration

MicroPDF417SymbolCompactionMode Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : MicroPDF417SymbolCompactionMode Enumeration
MicroPDF417 encoding compaction mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MicroPDF417SymbolCompactionMode
   Inherits System.Enum
public enum MicroPDF417SymbolCompactionMode : System.Enum
Members
Member | Description
Auto | The compaction mode will be selected automatically to achieve a better compression efficiency.
ByteCompactionMode | Byte Compaction Mode.
NumericCompactionMode | Numeric Compaction Mode.
TextCompactionMode | Text Compaction Mode.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Options.MicroPDF417SymbolCompactionMode

See Also

Reference

GrapeCity.ActiveReports.Options Namespace


MicroPDF417SymbolVersion Enumeration

MicroPDF417SymbolVersion Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : MicroPDF417SymbolVersion Enumeration
MicroPDF417 encoding compaction mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MicroPDF417SymbolVersion
   Inherits System.Enum
public enum MicroPDF417SymbolVersion : System.Enum
Members
Member | Description
ColumnPriorAuto | The minimum symbol size that fits the data first for the column, will be selected automatically.
RowPriorAuto | The minimum symbol size that fits the data first for the row, will be selected automatically.
Version1X11 | Represents 1 column and 11 row.
Version1X14 | Represents 1 column and 14 row.
Version1X17 | Represents 1 column and 17 row.
Version1X20 | Represents 1 column and 20 row.
Version1X24 | Represents 1 column and 24 row.
Version1X28 | Represents 1 column and 28 row.
Version2X11 | Represents 2 column and 11 row.
Version2X14 | Represents 2 column and 14 row.
Version2X17 | Represents 2 column and 17 row.
Version2X20 | Represents 2 column and 20 row.
Version2X23 | Represents 2 column and 23 row.
Version2X26 | Represents 2 column and 26 row.
Version2X8 | Represents 2 column and 8 row.
Version3X10 | Represents 3 column and 10 row.
Version3X12 | Represents 3 column and 12 row.
Version3X15 | Represents 3 column and 15 row.
Version3X20 | Represents 3 column and 20 row.
Version3X26 | Represents 3 column and 26 row.
Version3X32 | Represents 3 column and 32 row.
Version3X38 | Represents 3 column and 38 row.
Version3X44 | Represents 3 column and 44 row.
Version3X6 | Represents 3 column and 6 row.
Version3X8 | Represents 3 column and 8 row.
Version4X10 | Represents 4 column and 10 row.
Version4X12 | Represents 4 column and 12 row.
Version4X15 | Represents 4 column and 15 row.
Version4X20 | Represents 4 column and 20 row.
Version4X26 | Represents 4 column and 26 row.
Version4X32 | Represents 4 column and 32 row.
Version4X38 | Represents 4 column and 38 row.
Version4X4 | Represents 4 column and 4 row.
Version4X44 | Represents 4 column and 44 row.
Version4X6 | Represents 4 column and 6 row.
Version4X8 | Represents 4 column and 8 row.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Options.MicroPDF417SymbolVersion

See Also

Reference

GrapeCity.ActiveReports.Options Namespace


PDF417Type Enumeration

PDF417Type Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : PDF417Type Enumeration
Specifies PDF417's barcode type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PDF417Type
   Inherits System.Enum
public enum PDF417Type : System.Enum
Members
Member | Description
Normal | Standard type.
Simple | Compact type (right indicator is neither displayed nor printed).
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Options.PDF417Type

See Also

Reference

GrapeCity.ActiveReports.Options Namespace


QRCodeErrorLevel Enumeration

QRCodeErrorLevel Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : QRCodeErrorLevel Enumeration
Specifies the QRCode's error correction level.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum QRCodeErrorLevel
   Inherits System.Enum
public enum QRCodeErrorLevel : System.Enum
Members
Member | Description
H | High
L | Low
M | Medium
Q | Quality
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Options.QRCodeErrorLevel

See Also

Reference

GrapeCity.ActiveReports.Options Namespace


QRCodeMask Enumeration

QRCodeMask Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : QRCodeMask Enumeration
Sets the QRCode's mask pattern reference.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum QRCodeMask
   Inherits System.Enum
public enum QRCodeMask : System.Enum
Members
Member | Description
Auto | Auto configuration.
Mask000 | Pattern 000.
Mask001 | Pattern 001.
Mask010 | Pattern 010.
Mask011 | Pattern 011.
Mask100 | Pattern 100.
Mask101 | Pattern 101.
Mask110 | Pattern 110.
Mask111 | Pattern 111.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Options.QRCodeMask

See Also

Reference

GrapeCity.ActiveReports.Options Namespace


QRCodeModel Enumeration

QRCodeModel Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : QRCodeModel Enumeration
Sets the QRCode's model.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum QRCodeModel
   Inherits System.Enum
public enum QRCodeModel : System.Enum
Members
Member | Description
Model1 | Model1.
Model2 | Model2.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Options.QRCodeModel

See Also

Reference

GrapeCity.ActiveReports.Options Namespace


GrapeCity.ActiveReports.PageReportModel Namespace

GrapeCity.ActiveReports.PageReportModel Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports.PageReportModel Namespace
The GrapeCity.ActiveReports.PageReportModel namespace includes classes that can be used in page reports.
Classes
 | Class | Description
Class | Action | The Action element defines a hyperlink, bookmark link, or drillthrough action associated with a ReportItem
Class | ActionInfo | Represents the action information.
Class | Axis | The Axis element defines properties for labels, titles and gridlines along an axis.
Class | BackgroundImage | Defines a background image for the report.
Class | Body | Represents the body element for a report. This is the parent container for all report items in the report.
Class | Border | Represents the border properties.
Class | BorderColor | Defines the color for the border.
Class | BorderStyle | Defines the style for the border.
Class | BorderWidth | Defines the width of the border.
Class | CategoryGrouping | The CategoryGrouping element defines the category level for a Chart. The labels for the categories are displayed along the category axis.
Class | CategoryGroupingCollection | Provides a strongly typed collection for CategoryGrouping objects.
Class | Chart | The Chart element defines a chart data region. The Chart is defined much like a Matrix, but instead of Columns, Rows, and Cells, the Chart has Categories, Series, and DataPoints.
Class | ChartSeries | The ChartSeries element defines the set of data points for one series.
Class | ChartSeriesCollection | Provides a strongly typed collection for ChartSeries objects.
Class | CheckBox | The CheckBox element defines a CheckBox control.
Class | CodeClass | Represents information about a class instantiated during the report's initialization. The instantiated class can be used in expressions.
Class | CodeClassCollection | Provides a strongly typed collection for CodeClassCollection objects.
Class | ColumnGrouping | The ColumnGrouping element defines a column header region for a matrix.
Class | ColumnGroupingCollection | Provides a strongly typed collection for ColumnGroupingCollection objects.
Class | ConnectionProperties | Specifies the information used to connect to a data source.
Class | Container | Specifies a rectangle ReportItem contained in the report definition.
Class | Corner | The Corner element defines the layout and structure of the upper left-hand corner region of a matrix.
Class | Custom | The Custom element allows report design tools to pass information to report output components. This element may contain any valid XML. The engine passes the contents of the Custom object unchanged. Client applications using the Custom element place custom properties under their own single subelement of Custom, defining a namespace for that node.
Class | CustomData | Defines the data to be handed to an ICustomReportItem interface.
Class | CustomPropertyDefinition | Represents a CustomProperty element from RDL. When processing the ReportObjectModel, if the ExpressionInfo object contains any aggregate functions that do not specify the scope, the scope is updated with the current scope.
Class | CustomPropertyDefinitionCollection | Provides a strongly typed collection for CustomPropertyDefinition objects.
Class | CustomReportItem | Represents an IReportItem not defined within the RDL specification. The custom report item's information is stored inside the CustomReportItem element under a namespace for the tool or server supporting the type. If the custom report item is not recognized it is treated as an IRectangle.
Class | DataCellCollection | Provides a strongly typed collection for DataCell objects.
Class | DataGrouping | Describes how to group and sort data.
Class | DataGroupingCollection | Provides a strongly typed collection for DataGrouping objects.
Class | DataLabel | The DataLabel element defines the data labels to display on the data values in the chart.
Class | DataPoint | The DataPoint element defines a set of data for a single point in the chart. There must be a corresponding DataPoint for each static category in a static series. A DataPoint may consist of a single value expression (for example in a bar or line chart) or multiple value expressions (for example in a stock or bubble chart).
Class | DataPointCollection | Provides a strongly typed collection for DataPoint objects.
Class | DataRegion | Specifies a region where a dataset is laid out for a report. A data region bound to a dataset's results may repeat its contents to account for the dataset's size. The List, Matrix, Table and Chart report items are all data regions.
Class | DataRowCollection | Provides a strongly typed collection for DataRow objects.
Class | DataSet | Represents a DataSet element for a report which contains information about a set of data retrieved as part of the report.
Class | DataSetCollection | Provides a strongly typed collection for IDataSet interfaces.
Class | DataSetReference | The query to execute to obtain a list of values or default values for a parameter.
Class | DataSource | Specifies information about a report data source.
Class | DataSourceCollection | Provides a strongly typed collection for DataSource objects.
Class | DataSourcePrompt | Represents request for credentials to connect to a datasource.
Class | DataValue | The DataValue element defines a collection of data values for a single data point in the chart, or custom report control.
Class | DataValueCollection | Provides a strongly typed collection for DataValue objects.
Class | DefaultValue | The default value for the parameter.
Class | Details | Defines the detail rows for a table.
Class | DocumentMap | Specifies document map settings.
Class | DocumentMapLevel | Represents document map level properties.
Class | Drillthrough | Specifies an element that defines a drillthrough action.
Class | DynamicCategoriesSeries | Defines a Series level that repeats with each Series group in the rowset of the chart.
Class | DynamicColumnsRows | Defines a column or row header region that repeats with each column or row group in the rowset of a Matrix.
Class | EmbeddedImage | Specifies information about an image embedded in the report definition.
Class | EmbeddedImageCollection | Provides a strongly typed collection for EmbeddedImage objects.
Class | EmbeddedStyleSheet | Specifies information about an stylesheet embedded to the report definition.
Class | Field | Defines a field element containing information about a field within the data model of the report.
Class | FieldCollection | Provides a strongly typed collection for Field objects.
Class | Filter | Defines a Filter element which describes a filter to apply to rows of data in a dataset or data region, or to apply to the group instances.
Class | Footer | Defines the footer rows for a table or group.
Class | GridLines | Defines the style properties for the major and minor gridlines along an axis in a chart.
Class | Grouping | Specifies an element that defines the expressions by which to group the data.
Class | Header | Defines the header rows for a table or group.
Class | HeaderFooter | Defines the header or footer rows for a table or group.
Class | Image | Specifies an image ReportItem contained in the report definition.
Class | Layer | Defines a report layer.
Class | LayerCollection | Defines the collection of report layers.
Class | Legend | The Legend element defines the properties that are used to display instances of the series groupings in a chart legend.
Class | Line | Specifies a Line ReportItem contained in the report definition.
Class | List | Specifies a region that repeats with each group in the rowset or each row in the rowset (if no group expression is defined).
Class | LocalizationResource | Specifies a localization resource for the Report.
Class | Map | Defines map-based data visualization.
Class | MapAppearanceRule | Defines the appearance rule for spatial elements based on a data field
Class | MapBindingFieldPair | Defines a field/expression pairs to be used to bind the map elements within a vector based layer to the data region associated with it
Class | MapBorderSkin | Defines the appearance of the border skin around the map report item
Class | MapBucket | Defines a bucket for custom data distribution
Class | MapColorPaletteRule | Defines the color palette for spatial elements based on a data field
Class | MapColorRangeRule | Defines the color ranges for spatial elements based on a data field
Class | MapColorRule | Defines the color rule for spatial elements based on a data field.
Class | MapColorScale | Defines the map color scale
Class | MapColorScaleTitle | Defines the settings for the title to be displayed within the color scale
Class | MapCustomColorRule | Defines a set of custom colors for spatial elements based on a data field
Class | MapCustomView | Defines the center of the view port based on an arbitrary center point
Class | MapDataBoundView | Defines the center/zoom of the view port based on the spatial map elements bound to data
Class | MapDataRegion | Defines a data region for the map
Class | MapDistanceScale | Defines the map distance scale
Class | MapDockableSubItem | Defines the common properties for map dockable sub items
Class | MapElementView | Defines the center/zoom of the view port based on map spatial element
Class | MapField | Defines a field for map elements within a static layer
Class | MapFieldDefinition | Defines a field definition for map elements within a static layer
Class | MapGridLines | Defines the properties for map grid (meridians/parallels)
Class | MapLayer | Defines a layer to be drawn within a map
Class | MapLegend | Defines a legend to be drawn within a map
Class | MapLegendTitle | Defines a title for a map legend
Class | MapLimits | Defines the map limits
Class | MapLine | Defines an element to be embedded within a MapLineLayer
Class | MapLineLayer | Defines a vector-based layer of lines to be drawn within a map
Class | MapLineRules | Defines a set of rules to be applied on lines
Class | MapLineTemplate | Defines a template to be applied to lines within a line layer
Class | MapLocation | Defines the properties for map sub items location
Class | MapMarker | Defines a marker to be applied to points within a point or polygon layer.
Class | MapMarkerImage | Image marker.
Class | MapMarkerRule | Defines the points marker based on a data field
Class | MapMarkerTemplate | Defines a marker template to be applied to points within a point or polygon layer
Class | MapMember | Defines group and filter behavior for the data.
Class | MapPoint | Defines an element to be embedded within a MapPointLayer
Class | MapPointLayer | Defines a vector-based layer of points to be drawn within a map
Class | MapPointRules | Defines a set of rules to be applied on points on a point or polygon layer
Class | MapPointTemplate | Defines a template to be applied to points within a point or polygon layer
Class | MapPolygon | Defines an element to be embedded within a MapPolygonLayer
Class | MapPolygonLayer | Defines a vector-based layer of polygons to be drawn within a map.
Class | MapPolygonRules | Defines a set of rules to be applied on polygons
Class | MapPolygonTemplate | Defines a template to be applied to polygons within a polygon layer.
Class | MapShapefile | Defines a file-based source for spatial data and possibly non-spatial data
Class | MapSize | Defines the properties for map sub items size
Class | MapSizeRule | Defines the size rule for point or line based on a data field
Class | MapSpatialData | Defines the source of spatial data for a vector layer
Class | MapSpatialDataRegion | Defines a data region-based source for spatial data
Class | MapSpatialDataSet | Defines a dataset-based source for spatial and possibly non-spatial data.
Class | MapSpatialElement | Defines a spatial element to be embedded within a static layer
Class | MapSpatialElementTemplate | Defines the template to be applied on map spatial elements within a vector layer
Class | MapSubItem | Defines the common properties for map sub items
Class | MapTile | Defines a tile to be embedded in a MapTileLayer
Class | MapTileLayer | Defines a raster-based layer to be drawn within a map
Class | MapTitle | Defines a title to be drawn within a map
Class | MapVectorLayer | Defines a vector-based layer of map elements to be drawn within a map
Class | MapView | Defines the viewport center and zoom level
Class | MapViewport | Defines the map viewport
Class | Marker | The Marker element defines a marker for displayed chart values.
Class | MasterReportNotFoundException | Raised when a master report cannot be found.
Class | Matrix | The Matrix element defines a grid of regions that repeats with each column group and row group in the dataset.
Class | MatrixCell | The MatrixCell element defines the contents of each detail cell in the matrix.
Class | MatrixCellCollection | Provides a strongly typed collection for MatrixCell objects.
Class | MatrixColumn | Defines a column in the detail section of a Matrix.
Class | MatrixColumnCollection | Provides a strongly typed collection for MatrixColumn objects.
Class | MatrixRow | Defines the set of cells in a row of the detail section of a Matrix.
Class | MatrixRowCollection | Provides a strongly typed collection for MatrixRow objects.
Class | NameValidator | Defines a NameValidator to check names contained in a report.
Class | OverflowPlaceHolder | Represents the page report overflow place holder.
Class | Page | Represents the Page report page.
Class | PageBreak | Defines page breaking options.
Class | PageCollection | Provides a strongly typed collection for Page object.
Class | PageCollectionEventArgs | Provides data for the ItemAdded or ItemRemoved event of the PageCollection.
Class | PageHeaderFooter | Specifies the layout definition for each ReportItem at the top of each page (PageHeader) or the bottom of each page (PageFooter).
Class | Parameter | The Parameter element contains information about a subreport parameter.
Class | ParameterCollection | Provides a strongly typed collection for Parameter objects.
Class | ParameterValue | A possible value for the parameter.
Class | ParameterValueCollection | Provides a strongly typed collection for ParameterValue objects
Class | PlotArea | The PlotArea element defines properties for the plot area (for chart types with X and Y axes).
Class | Property | Summary description for Property.
Class | PropertyCollection | Provides a strongly typed collection for Property objects.
Class | Query | Represents the Query element of a dataset which contains the description of the query to execute to retrieve the data for the report.
Class | QueryParameter | Defines a QueryParameter element which contains information about a parameter that is passed to the data source as part of the query.
Class | QueryParameterCollection | Provides a strongly typed collection for QueryParameter objects.
Class | ReferenceLine | Defines the properties for the reference line in a chart.
Class | Report | The Report element contains property, data, and layout information about the report which is the top-level element.
Class | ReportComponent | Defines a new ReportComponent.
Class | ReportComponentCollection | Defines a collection of IReportComponent objects.
Class | ReportComponentContainer | Defines a GrapeCity.ActiveReports.ReportObjectModel.ReportComponentContainer that containes other GrapeCity.ActiveReports.ReportObjectModel.ReportComponent objects.
Class | ReportItem | A report item is one of the following types of objects: Line, Rectangle, TextBox, Image, Subreport, CustomReportItem, or DataRegion. DataRegions include List, Table, Matrix, and Chart. The ReportItem element itself is not used. Instead, the specific report item element is used whenever ReportItem is allowed.
Class | ReportItemCollection | Provides a strongly typed collection for ReportItem objects.
Class | ReportItemCollectionEventArgs | Provides data for the ItemAdded or ItemRemoved event of the ReportItemCollection.
Class | ReportParameter | The ReportParameter element contains information about a parameter for the report.
Class | ReportParameterCollection | Provides a strongly typed collection for ReportParameter objects.
Class | RoundingRadius | Defines the color for the border.
Class | RowGrouping | Defines a row grouping for a matrix.
Class | RowGroupingCollection | Provides a strongly typed collection for RowGrouping objects.
Class | SeriesGrouping | The SeriesGrouping element defines a Series level for a chart SeriesGrouping. The labels for the series are displayed in the legend.
Class | SeriesGroupingCollection | Provides a strongly typed collection for SeriesGrouping objects.
Class | Shape | Represents the shape on the report.
Class | SharedDataSet | Represents a shared dataset.
Class | SortBy | Specifies an element that defines an expression by which to sort the groups.
Class | SortByCollection | Provides a strongly typed collection for SortBy objects.
Class | StaticMember | Defines the data label to display for a static series or static category member.
Class | StaticMemberCollection | Provides a strongly typed collection for StaticMember objects.
Class | StaticRowColumn | Defines a column or row header region with a fixed set of columns or rows.
Class | StaticRowColumnCollection | Provides a strongly typed collection for StaticRowColumn objects.
Class | Style | The Style element contains information about the style of a report control. Where possible, the style property names and values match standard HTML/CSS properties. All expression-based Style elements evaluate to either the type listed or to Nothing (an error in evaluation is treated as Nothing). Nothing is equivalent to not specifying the style, thereby indicating that it uses the default value. The expression must evaluate to a Boolean value for Boolean properties, an enumerated value for enum properties, an integer for integer properties and a (formatted) string for all other properties.
Class | StyleExpressionExtensions | Provides extension methods for expressions of style
Class | StyleSheet | Specifies information about an a report's stylesheet.
Class | Subreport | Specifies a Subreport ReportItem, which is a separate report contained in the report definition.
Class | Subtotal | The Subtotals element defines a subtotal column or row to include in the Matrix.
Class | Table | The Table element defines a tabular grouped layout of the data region.
Class | TableCell | Defines the contents of a cell in a table data region.
Class | TableCellCollection | Provides a strongly typed collection for TableCell objects.
Class | TableColumn | Defines a column in the table.
Class | TableColumnCollection | Provides a strongly typed collection for TableColumn objects.
Class | TableGroup | Defines a group in a table data region.
Class | TableGroupCollection | Provides a strongly typed collection for TableGroup objects.
Class | TableOfContents | Defines the table of contents to presents the document map.
Class | TableOfContentsLevel | Defines the level for TableOfContents.
Class | TableRow | Defines a row of cells in a table data region.
Class | TableRowCollection | Provides a strongly typed collection for TableRow objects.
Class | TextBox | Specifies a textbox ReportItem contained in the report definition.
Class | TextItem | Abstract base class for TextBox and CheckBox
Class | ThreeDProperties | The ThreeDProperties element defines properties for a 3D chart layout.
Class | Title | The Title element defines a title for the chart or for an axis.
Class | ToggleImage | Indicates the initial state of a toggle image if such an image is displayed as part of the Textbox.
Class | UserSort | Defines an object for sort information to the end-user as part of the TextBox UI.
Class | ValidationContext | Defines the type of context information that is available during validation.
Class | ValidationEntry | Represents a single entry of information related to validation.
Class | Validator | Defines an object for performing validation on a report definition.
Class | ValidValues | The possible values for the parameter. This is used to populate UI selection lists from which users can select a parameter value.
Class | ValueCategoryAxis | Used as a Category axis in a chart, the element defines the category (X) axis. There must be a corresponding DataPoint for each StaticCategories member. Used as a Value axis, the element defines the data (Y) axis.
Class | Variable | Defines a variable.
Class | Visibility | The Visibility element controls whether the ReportItem is initially shown in the output report.
Interfaces
 | Interface | Description
Interface | IBaseDataSet | Represents the members common to all types of datasets.
Interface | IDataSet | Represents a data set element for a report which contains information about a set of data retrieved as a part of the report.
Interface | IMasterContentService | Defines an auxiliary interface for determining report and report item ownership
Interface | IRdlContainer | Specifies an area containing report items.
Interface | IReportComponent | Specifies a component for the report.
Interface | IReportComponentContainer | Represents a report object that can contain other GrapeCity.ActiveReports.ReportObjectModel.IReportComponent objects.
Interface | IScopeDefinition | Represents an object that defines a data scope in the RDL report object model (data region or grouping).
Structures
 | Structure | Description
Structure | MasterContentCode | Defines a struct for containing the master and child report code separately.
Delegates
 | Delegate | Description
Delegate | PageCollectionEventHandler | Represents the method that handles the ItemAdded or ItemRemoved event.
Delegate | ReportItemCollectionEventHandler | Represents the method that handles the ItemAdded or ItemRemoved event.
Enumerations
 | Enumeration | Description
Enumeration | AccentSensitivity | Specifies whether the data is accent sensitive.
Enumeration | AntiAliasing | The possible values for the GaugePanel.AntiAliasing and Map.AntiAliasing properties.
Enumeration | BackgroundHatchTypes | The enum for Style.BackgroundHatchType element.
Enumeration | BorderDrawingStyle | Specifies the style of the border on a report item.
Enumeration | BorderDrawingStyle2008 | Specifies the style of the border on a report item.
Enumeration | BreakLocation | Specifies break location.
Enumeration | CaseSensitivity | Specifies whether the data is case sensitive.
Enumeration | ChartPalette | Specifies the color palette for chart items.
Enumeration | ChartSeriesPlotType | Specifies whether the series is plotted as a line on a column chart.
Enumeration | ChartSubtype | Specifies the subtype of the chart. Different subtypes are available for each chart type.
Enumeration | ChartType | Specifies the type of the chart.
Enumeration | CollateBy | Controls the combination of reports during output when using a theme.
Enumeration | DataElementOutput | Defines how an item should appear in data output.
Enumeration | DataElementStyle | Indicates whether an item should render as an element or attribute.
Enumeration | DocumentMapSource | Defines an enumeration of document map sources.
Enumeration | FilterOperator | Specifies the operator to use to compare the values returned by the FilterExpression with those in the FilterValues object.
Enumeration | ItemOwners | Specifies the report component owner when master report is defined for child report
Enumeration | KanatypeSensitivity | Specifies whether the data is Kanatype sensitive. (Used with the Japanese language to distinguish between hiragana and katakana.)
Enumeration | KeepWithGroup | Defines KeepWithGroup property values.
Enumeration | LegendLayout | Specifies the arrangement of labels within the legend.
Enumeration | LegendPosition | Specifies the position of the legend.
Enumeration | MapBorderSkin.BorderSkinType | Border skin type for the map
Enumeration | MapColorPalette | Indicates the palette to be used for coloring the spatial elements.
Enumeration | MapColorScale.MapLabelBehavior | Indicates the positioning of the color scale labels.
Enumeration | MapColorScale.MapLabelPlacement | Indicates the labels placement along the color bar.
Enumeration | MapCoordinateSystem | The map coordinate system.
Enumeration | MapDataType | The data type of the field.
Enumeration | MapDockableSubItem.MapPosition | The position of the sub item.
Enumeration | MapGridLines.LabelPositionType | Defines the position for grid labels.
Enumeration | MapLegendTitle.LegendTitleSeparator | Indicates what type of separator to use for the legend title.
Enumeration | MapLineTemplate.LineLabelPlacement | Defines the label placement for the line.
Enumeration | MapMarker.MarkerStyle | Defines the point marker.
Enumeration | MapMarkerImage.ImageResizeMode | Indicates whether the content will resize to fit in the available space.
Enumeration | MapPointTemplate.MapPointLabelPlacement | Defines the label placement for the point.
Enumeration | MapPolygonTemplate.PolygonLabelPlacement | Indicates the label placement of the polygon
Enumeration | MapPolygonTemplate.PolygonShowLabel | Indicates if the label should be shown.
Enumeration | MapProjection | The map projection.
Enumeration | MapRuleDistributionType | Indicates the distribution type.
Enumeration | MapTileLayer.MapTileStyle | Indicates the tiles style.
Enumeration | MapUnit | Defines the unit for both width and height.
Enumeration | MapVisibilityMode | Indicates the layer visibility mode.
Enumeration | MarkerType | Specifies the type of marker to use with chart data.
Enumeration | NameType | Specifies the type of object the name belongs to.
Enumeration | NumberingStyle | Defines the numbering style enumeration.
Enumeration | PaperOrientation | Represents the list of paper orientation options.
Enumeration | Position | Specifies the position of a data label.
Enumeration | QueryCommandType | Specifies the type of query contained in the CommandText.
Enumeration | ReportParameterDataType | Specifies the data type for the parameter.
Enumeration | ReportParameterUsedInQuery | Specifies whether the parameter is used in a query in the report. This evaluates to True if the parameter is referenced in any query value expression.
Enumeration | Severity | Specifies the severity level of a ValidationEntry object.
Enumeration | SortByDirection | Specifies whether items are sorted in ascending or descending order.
Enumeration | StyleSheetSource | Enumeration of stylesheet sources.
Enumeration | StyleType | Enumeration of style types.
Enumeration | SubtotalPosition | Specifies whether the subtotal rows or columns appear before or after the detail rows or columns.
Enumeration | TargetDevices | Defines enumeration of possible target devices for layer.
Enumeration | TextAlign | Specifies the horizontal alignment of the text
Enumeration | TextAntiAliasingQuality | Defines the enumeration of text anti-aliasing quality.
Enumeration | ThreeDPropertiesDrawingStyle | Specifies the shape of the columns or bars in a three-dimensional chart. ThreeDPropertiesDrawingStyle only applies to bar and column charts.
Enumeration | ThreeDPropertiesProjectionMode | Specifies the projection mode for the three-dimensional chart.
Enumeration | ThreeDPropertiesShading | Specifies the shading style of the three-dimensional chart.
Enumeration | TickMark | Specifies the position of the tick marks on the axis.
Enumeration | TitlePosition | Specifies the position of the title. TitlePosition is not used for the chart title.
Enumeration | ValidationMode | Indicates the current mode of the validation system. Different severities and validation entries may be used for different modes.
Enumeration | WidthSensitivity | Specifies whether the data is width sensitive.
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


Action Class

Action Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Action Class
The Action element defines a hyperlink, bookmark link, or drillthrough action associated with a ReportItem
Object Model
Action Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Action
public sealed class Action
Remarks

An Action must have one and only one of the following properties: Hyperlink, BookmarkLink or Drillthrough.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Action

See Also

Reference

Action Members
GrapeCity.ActiveReports.PageReportModel Namespace


Action Class Members

Action Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Action Class

The following tables list the members exposed by Action.

Public Constructors
 | Name | Description
Public Constructor | Action Constructor | Initializes a new instance of Action class.
Top
Public Properties
 | Name | Description
Public Property | BookmarkLink | Gets or sets an expression that evaluates to the ID of a bookmark within the report to which to navigate when the report item is clicked.
Public Property | Drillthrough | Gets or sets the drillthrough report that is executed by clicking the hyperlink.
Public Property | Hyperlink | Gets or sets an expression that evaluates to the URL of the hyperlink.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the Action class.
Top
See Also

Reference

Action Class
GrapeCity.ActiveReports.PageReportModel Namespace


Action Constructor

Action Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Action Class : Action Constructor
Initializes a new instance of Action class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Action()
See Also

Reference

Action Class
Action Members


Action Class Methods

Action Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Action Class

For a list of all members of this type, see Action members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the Action class.
Top
See Also

Reference

Action Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (Action)

Validate Method (Action)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Action Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the Action class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all of the validation entries found, or empty if none are found.
See Also

Reference

Action Class
Action Members


Action Class Properties

Action Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Action Class

For a list of all members of this type, see Action members.

Public Properties
 | Name | Description
Public Property | BookmarkLink | Gets or sets an expression that evaluates to the ID of a bookmark within the report to which to navigate when the report item is clicked.
Public Property | Drillthrough | Gets or sets the drillthrough report that is executed by clicking the hyperlink.
Public Property | Hyperlink | Gets or sets an expression that evaluates to the URL of the hyperlink.
Top
See Also

Reference

Action Class
GrapeCity.ActiveReports.PageReportModel Namespace


BookmarkLink Property (Action)

BookmarkLink Property (Action)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Action Class : BookmarkLink Property

Gets or sets an expression that evaluates to the ID of a bookmark within the report to which to navigate when the report item is clicked.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BookmarkLink As ExpressionInfo
public ExpressionInfo BookmarkLink {get; set;}

Property Value

An ExpressionInfo object that evaluates to the ID of a bookmark within the report to which to navigate when the report control is clicked.
Remarks

If no bookmark with this ID is found, the link is not included in the report. If the bookmark is hidden, the link goes to the start of the page of the bookmark. If multiple bookmarks with the ID are found, the link goes to the first one.

See Also

Reference

Action Class
Action Members


Drillthrough Property (Action)

Drillthrough Property (Action)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Action Class : Drillthrough Property

Gets or sets the drillthrough report that is executed by clicking the hyperlink.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Drillthrough As Drillthrough
public Drillthrough Drillthrough {get;}

Property Value

A Drillthrough object representing the drillthrough report that is executed by clicking the hyperlink.
See Also

Reference

Action Class
Action Members


Hyperlink Property (Action)

Hyperlink Property (Action)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Action Class : Hyperlink Property

Gets or sets an expression that evaluates to the URL of the hyperlink.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Hyperlink As ExpressionInfo
public ExpressionInfo Hyperlink {get; set;}

Property Value

An ExpressionInfo object that evaluates to the URL of the hyperlink.
See Also

Reference

Action Class
Action Members


ActionInfo Class

ActionInfo Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ActionInfo Class
Represents the action information.
Object Model
ActionInfo Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ActionInfo
public sealed class ActionInfo
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ActionInfo

See Also

Reference

ActionInfo Members
GrapeCity.ActiveReports.PageReportModel Namespace


ActionInfo Class Members

ActionInfo Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ActionInfo Class

The following tables list the members exposed by ActionInfo.

Public Constructors
 | Name | Description
Public Constructor | ActionInfo Constructor |
Top
Public Properties
 | Name | Description
Public Property | Actions | The list of actions.
Top
See Also

Reference

ActionInfo Class
GrapeCity.ActiveReports.PageReportModel Namespace


ActionInfo Constructor

ActionInfo Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ActionInfo Class : ActionInfo Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ActionInfo()
See Also

Reference

ActionInfo Class
ActionInfo Members


ActionInfo Class Properties

ActionInfo Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ActionInfo Class

For a list of all members of this type, see ActionInfo members.

Public Properties
 | Name | Description
Public Property | Actions | The list of actions.
Top
See Also

Reference

ActionInfo Class
GrapeCity.ActiveReports.PageReportModel Namespace


Actions Property

Actions Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ActionInfo Class : Actions Property
The list of actions.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Actions As System.Collections.Generic.IList(Of Action)
public System.Collections.Generic.IList<Action> Actions {get;}
See Also

Reference

ActionInfo Class
ActionInfo Members


Axis Class

Axis Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Axis Class
The Axis element defines properties for labels, titles and gridlines along an axis.
Object Model
Axis Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Axis
public sealed class Axis
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Axis

See Also

Reference

Axis Members
GrapeCity.ActiveReports.PageReportModel Namespace


Axis Class Members

Axis Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Axis Class

The following tables list the members exposed by Axis.

Public Constructors
 | Name | Description
Public Constructor | Axis Constructor | Initializes a new instance of the Axis class.
Top
Public Properties
 | Name | Description
Public Property | AngledLabels | True if angled labels should be used.
Public Property | CrossAt | Gets or sets the value at which to cross the other axis.
Public Property | EndCap | The end cap style to use for the axis.
Public Property | Interlaced | Gets or sets a value indicating whether strip lines are drawn for every second grid line interval for the axis. If grid lines are not used for the axis then the axis' tick marks or labels are used to determine the interlaced strip lines interval.
Public Property | LogScale | Gets or sets a value indicating whether the axis is logarithmic.
Public Property | MajorGridLines | Gets or sets a value indicating how the major gridlines are displayed.
Public Property | MajorInterval | Gets or sets the unit of measurement for major gridlines and tickmarks.
Public Property | MajorTickMarks | Gets or sets the style of the major tick marks.
Public Property | Margin | Gets or sets a value indicating whether an axis margin is created. The size of the margin is automatically generated based on the scale and the number of data points.
Public Property | Max | Gets or sets the maximum value for the axis.
Public Property | Min | Gets or sets the minimum value for the axis.
Public Property | MinorGridLines | Gets or sets a value indicating how the minor gridlines are displayed.
Public Property | MinorInterval | Gets or sets the unit of measurement for minor gridlines and tickmarks.
Public Property | MinorTickMarks | Gets or sets the style of minor tick marks.
Public Property | Reverse | Gets or sets a Boolean value indicating whether the axis is plotted in reverse or normally. If set to true, the axis direction is reversed.
Public Property | Scalar | Gets or sets a value indicating whether the values along the axis are scalar values (i.e. numeric or date) which are displayed on the chart in a continuous flow with missing numbers or dates filled in.
Public Property | Style | Gets or sets text style properties for the axis labels and line style properties for the axis line.
Public Property | Title | Gets or sets the title for the axis.
Public Property | Visible | Gets or sets a value indicating whether the axis labels are displayed.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the Axis class.
Top
See Also

Reference

Axis Class
GrapeCity.ActiveReports.PageReportModel Namespace


Axis Constructor

Axis Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Axis Constructor
Initializes a new instance of the Axis class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Axis()
See Also

Reference

Axis Class
Axis Members


Axis Class Methods

Axis Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Axis Class

For a list of all members of this type, see Axis members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the Axis class.
Top
See Also

Reference

Axis Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (Axis)

Validate Method (Axis)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the Axis class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all of the validation entries found, or empty if none are found.
See Also

Reference

Axis Class
Axis Members


Axis Class Properties

Axis Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Axis Class

For a list of all members of this type, see Axis members.

Public Properties
 | Name | Description
Public Property | AngledLabels | True if angled labels should be used.
Public Property | CrossAt | Gets or sets the value at which to cross the other axis.
Public Property | EndCap | The end cap style to use for the axis.
Public Property | Interlaced | Gets or sets a value indicating whether strip lines are drawn for every second grid line interval for the axis. If grid lines are not used for the axis then the axis' tick marks or labels are used to determine the interlaced strip lines interval.
Public Property | LogScale | Gets or sets a value indicating whether the axis is logarithmic.
Public Property | MajorGridLines | Gets or sets a value indicating how the major gridlines are displayed.
Public Property | MajorInterval | Gets or sets the unit of measurement for major gridlines and tickmarks.
Public Property | MajorTickMarks | Gets or sets the style of the major tick marks.
Public Property | Margin | Gets or sets a value indicating whether an axis margin is created. The size of the margin is automatically generated based on the scale and the number of data points.
Public Property | Max | Gets or sets the maximum value for the axis.
Public Property | Min | Gets or sets the minimum value for the axis.
Public Property | MinorGridLines | Gets or sets a value indicating how the minor gridlines are displayed.
Public Property | MinorInterval | Gets or sets the unit of measurement for minor gridlines and tickmarks.
Public Property | MinorTickMarks | Gets or sets the style of minor tick marks.
Public Property | Reverse | Gets or sets a Boolean value indicating whether the axis is plotted in reverse or normally. If set to true, the axis direction is reversed.
Public Property | Scalar | Gets or sets a value indicating whether the values along the axis are scalar values (i.e. numeric or date) which are displayed on the chart in a continuous flow with missing numbers or dates filled in.
Public Property | Style | Gets or sets text style properties for the axis labels and line style properties for the axis line.
Public Property | Title | Gets or sets the title for the axis.
Public Property | Visible | Gets or sets a value indicating whether the axis labels are displayed.
Top
See Also

Reference

Axis Class
GrapeCity.ActiveReports.PageReportModel Namespace


AngledLabels Property (Axis)

AngledLabels Property (Axis)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : AngledLabels Property
True if angled labels should be used.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AngledLabels As System.Boolean
public System.bool AngledLabels {get; set;}
See Also

Reference

Axis Class
Axis Members


CrossAt Property (Axis)

CrossAt Property (Axis)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : CrossAt Property

Gets or sets the value at which to cross the other axis.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CrossAt As ExpressionInfo
public ExpressionInfo CrossAt {get; set;}

Property Value

A ExpressionInfo value indicating the value at which to cross the other axis.
Remarks
If this value is omitted, it uses the default value for the chart type.
See Also

Reference

Axis Class
Axis Members


EndCap Property (Axis)

EndCap Property (Axis)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : EndCap Property
The end cap style to use for the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EndCap As ExpressionInfo
public ExpressionInfo EndCap {get; set;}
See Also

Reference

Axis Class
Axis Members


Interlaced Property (Axis)

Interlaced Property (Axis)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Interlaced Property

Gets or sets a value indicating whether strip lines are drawn for every second grid line interval for the axis. If grid lines are not used for the axis then the axis' tick marks or labels are used to determine the interlaced strip lines interval.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Interlaced As System.Boolean
public System.bool Interlaced {get; set;}

Property Value

A Boolean value where true indicates that strip lines are drawn for every second grid line interval for the axis; otherwise false. The default value is false.

See Also

Reference

Axis Class
Axis Members


LogScale Property (Axis)

LogScale Property (Axis)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : LogScale Property

Gets or sets a value indicating whether the axis is logarithmic.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LogScale As System.Boolean
public System.bool LogScale {get; set;}

Property Value

A Boolean value where true indicates that the axis is logarithmic; otherwise false. The default value is false.

See Also

Reference

Axis Class
Axis Members


MajorGridLines Property

MajorGridLines Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : MajorGridLines Property

Gets or sets a value indicating how the major gridlines are displayed.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MajorGridLines As GridLines
public GridLines MajorGridLines {get; set;}

Property Value

A GridLines object indicating how the major gridlines are displayed.
See Also

Reference

Axis Class
Axis Members


MajorInterval Property (Axis)

MajorInterval Property (Axis)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : MajorInterval Property

Gets or sets the unit of measurement for major gridlines and tickmarks.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MajorInterval As ExpressionInfo
public ExpressionInfo MajorInterval {get; set;}

Property Value

A ExpressionInfo value indicating the unit of measurement for major gridlines and tickmarks.
Remarks
If omitted, the axis is automatically divided.
See Also

Reference

Axis Class
Axis Members


MajorTickMarks Property (Axis)

MajorTickMarks Property (Axis)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : MajorTickMarks Property

Gets or sets the style of the major tick marks.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MajorTickMarks As TickMark
public TickMark MajorTickMarks {get; set;}

Property Value

A TickMark enumeration indicating whether the major tick marks are inside, outside, or cross the axis, or are nonexistent.
See Also

Reference

Axis Class
Axis Members


Margin Property (Axis)

Margin Property (Axis)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Margin Property

Gets or sets a value indicating whether an axis margin is created. The size of the margin is automatically generated based on the scale and the number of data points.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Margin As System.Boolean
public System.bool Margin {get; set;}

Property Value

A Boolean value where true indicates that the axis margin is created; otherwise false. The default value is false.

See Also

Reference

Axis Class
Axis Members


Max Property (Axis)

Max Property (Axis)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Max Property

Gets or sets the maximum value for the axis.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Max As ExpressionInfo
public ExpressionInfo Max {get; set;}

Property Value

A ExpressionInfo value indicating the maximum value for the axis.
Remarks
If omitted, the axis automatically scales.
See Also

Reference

Axis Class
Axis Members


Min Property (Axis)

Min Property (Axis)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Min Property

Gets or sets the minimum value for the axis.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Min As ExpressionInfo
public ExpressionInfo Min {get; set;}

Property Value

A ExpressionInfo value indicating the maximum value for the axis.
Remarks
If omitted, the axis automatically scales.
See Also

Reference

Axis Class
Axis Members


MinorGridLines Property

MinorGridLines Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : MinorGridLines Property

Gets or sets a value indicating how the minor gridlines are displayed.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinorGridLines As GridLines
public GridLines MinorGridLines {get; set;}

Property Value

A GridLines object indicating how the minor gridlines are displayed.
See Also

Reference

Axis Class
Axis Members


MinorInterval Property (Axis)

MinorInterval Property (Axis)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : MinorInterval Property

Gets or sets the unit of measurement for minor gridlines and tickmarks.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinorInterval As ExpressionInfo
public ExpressionInfo MinorInterval {get; set;}

Property Value

A ExpressionInfo value indicating the unit of measurement for minor gridlines and tickmarks.
Remarks
If omitted, the axis is automatically divided.
See Also

Reference

Axis Class
Axis Members


MinorTickMarks Property (Axis)

MinorTickMarks Property (Axis)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : MinorTickMarks Property

Gets or sets the style of minor tick marks.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinorTickMarks As TickMark
public TickMark MinorTickMarks {get; set;}

Property Value

A TickMark enumeration indicating whether the minor tick marks are inside, outside, or cross the axis, or are nonexistent.
See Also

Reference

Axis Class
Axis Members


Reverse Property (Axis)

Reverse Property (Axis)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Reverse Property

Gets or sets a Boolean value indicating whether the axis is plotted in reverse or normally. If set to true, the axis direction is reversed.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Reverse As System.Boolean
public System.bool Reverse {get; set;}

Property Value

A Boolean value where true indicates that the axis direction is plotted in reverse; otherwise false. The default value is false.

See Also

Reference

Axis Class
Axis Members


Scalar Property (Axis)

Scalar Property (Axis)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Scalar Property

Gets or sets a value indicating whether the values along the axis are scalar values (i.e. numeric or date) which are displayed on the chart in a continuous flow with missing numbers or dates filled in.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Scalar As System.Boolean
public System.bool Scalar {get; set;}

Property Value

A Boolean value where true indicates that the values along the axis are scalar (i.e numeric or date) values; otherwise false. The default value is false.

Remarks
Scalar cannot be true if the axis has more than one grouping, if the grouping is static or has more than one group expression, or if the axis values have labels.
See Also

Reference

Axis Class
Axis Members


Style Property (Axis)

Style Property (Axis)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Style Property

Gets or sets text style properties for the axis labels and line style properties for the axis line.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As Style
public Style Style {get; set;}

Property Value

A Style object indicating the text style properties for the axis labels and line style properties for the axis line.
See Also

Reference

Axis Class
Axis Members


Title Property (Axis)

Title Property (Axis)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Title Property

Gets or sets the title for the axis.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Title As Title
public Title Title {get; set;}

Property Value

A Title object indicating the title to display for the axis.
See Also

Reference

Axis Class
Axis Members


Visible Property (Axis)

Visible Property (Axis)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Axis Class : Visible Property

Gets or sets a value indicating whether the axis labels are displayed.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}

Property Value

A Boolean value where true indicates that the axis labels are displayed; otherwise false. The default value is false.

See Also

Reference

Axis Class
Axis Members


BackgroundImage Class

BackgroundImage Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BackgroundImage Class
Defines a background image for the report.
Object Model
BackgroundImage Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class BackgroundImage
public sealed class BackgroundImage
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.BackgroundImage

See Also

Reference

BackgroundImage Members
GrapeCity.ActiveReports.PageReportModel Namespace


BackgroundImage Class Members

BackgroundImage Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BackgroundImage Class

The following tables list the members exposed by BackgroundImage.

Public Constructors
 | Name | Description
Public Constructor | BackgroundImage Constructor | Initializes a new instance of the BackgroundImage class.
Top
Public Properties
 | Name | Description
Public Property | BackgroundRepeat | Gets or sets a value indicating how the background image repeats to fill the available space: vertically (RepeatY), horizontally (RepeatX), both (Repeat), or neither (NoRepeat).
Public Property | MIMEType | Gets or sets the MIMEType for the image.
Public Property | Source | Gets or sets the source of the image.
Public Property | Value | Gets or sets the value of the background image.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the BackgroundImage object.
Top
See Also

Reference

BackgroundImage Class
GrapeCity.ActiveReports.PageReportModel Namespace


BackgroundImage Constructor

BackgroundImage Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BackgroundImage Class : BackgroundImage Constructor
Initializes a new instance of the BackgroundImage class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public BackgroundImage()
See Also

Reference

BackgroundImage Class
BackgroundImage Members


BackgroundImage Class Methods

BackgroundImage Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BackgroundImage Class

For a list of all members of this type, see BackgroundImage members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the BackgroundImage object.
Top
See Also

Reference

BackgroundImage Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (BackgroundImage)

Validate Method (BackgroundImage)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BackgroundImage Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the BackgroundImage object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

BackgroundImage Class
BackgroundImage Members


BackgroundImage Class Properties

BackgroundImage Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BackgroundImage Class

For a list of all members of this type, see BackgroundImage members.

Public Properties
 | Name | Description
Public Property | BackgroundRepeat | Gets or sets a value indicating how the background image repeats to fill the available space: vertically (RepeatY), horizontally (RepeatX), both (Repeat), or neither (NoRepeat).
Public Property | MIMEType | Gets or sets the MIMEType for the image.
Public Property | Source | Gets or sets the source of the image.
Public Property | Value | Gets or sets the value of the background image.
Top
See Also

Reference

BackgroundImage Class
GrapeCity.ActiveReports.PageReportModel Namespace


BackgroundRepeat Property (BackgroundImage)

BackgroundRepeat Property (BackgroundImage)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BackgroundImage Class : BackgroundRepeat Property

Gets or sets a value indicating how the background image repeats to fill the available space: vertically (RepeatY), horizontally (RepeatX), both (Repeat), or neither (NoRepeat).

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackgroundRepeat As ExpressionInfo
public ExpressionInfo BackgroundRepeat {get; set;}

Property Value

An ExpressionInfo object that evaluates to a BackgroundRepeat enumeration. Valid values are listed in the table below.
Enumerated Value | Description
Repeat | The image repeats horizontally and vertically in the background.
NoRepeat | The image is rendered once and does not repeat.
RepeatX | The image repeats horizontally in the background.
RepeatY | The image repeats vertically in the background.
See Also

Reference

BackgroundImage Class
BackgroundImage Members


MIMEType Property (BackgroundImage)

MIMEType Property (BackgroundImage)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BackgroundImage Class : MIMEType Property

Gets or sets the MIMEType for the image.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MIMEType As ExpressionInfo
public ExpressionInfo MIMEType {get; set;}

Property Value

A string ExpressionInfo that evaluates to a MIMEType for the image.
Remarks

Valid values are: image/bmp, image/jpeg, image/gif, image/png, and image/x-png.

MIMEType is required if the Source is set to Database; otherwise it is ignored.

See Also

Reference

BackgroundImage Class
BackgroundImage Members


Source Property (BackgroundImage)

Source Property (BackgroundImage)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BackgroundImage Class : Source Property

Gets or sets the source of the image.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Source As ImageSource
public ImageSource Source {get; set;}

Property Value

An ImageSource enumeration representing the source of the image. Valid values are listed in the table below.
Remarks
Enumerated Value | Description
External | The Value contains a constant or expression that evaluates to the location of the image.
Embedded | The Value contains a constant or expression that evaluates to the name of an EmbeddedImage within the report.
Database | The Value contains an expression (a field in the database) that evaluates to the binary data for the image.
See Also

Reference

BackgroundImage Class
BackgroundImage Members


Value Property (BackgroundImage)

Value Property (BackgroundImage)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BackgroundImage Class : Value Property
Gets or sets the value of the background image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As ExpressionInfo
public ExpressionInfo Value {get; set;}

Property Value

A ExpressionInfo that evaluates to the value of the background image.
See Also

Reference

BackgroundImage Class
BackgroundImage Members


Body Class

Body Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Body Class
Represents the body element for a report. This is the parent container for all report items in the report.
Object Model
Body Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Body
   Inherits ReportComponentContainer
   Implements IRdlContainer, IReportComponent, IReportComponentContainer
public sealed class Body : ReportComponentContainer, IRdlContainer, IReportComponent, IReportComponentContainer
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer
GrapeCity.ActiveReports.PageReportModel.Body

See Also

Reference

Body Members
GrapeCity.ActiveReports.PageReportModel Namespace


Body Class Members

Body Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Body Class

The following tables list the members exposed by Body.

Public Constructors
 | Name | Description
Public Constructor | Body Constructor | Initializes a new instance of the Body class.
Top
Public Properties
 | Name | Description
Public Property | Columns | Gets or sets the number of columns the report contains.
Public Property | ColumnSpacing | Gets or sets the amount of white space between each of the report's columns.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Container | Gets the IContainer that contains the Body. (Inherited from System.ComponentModel.Component)
Public Property | Height | Gets or sets the height of the report's IBody
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportItems | Gets a ReportItemCollection containing all the ReportItem in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Site | Gets or sets the ISite of the Body. (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report's body.
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the resources used by the Body. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String containing the name of the Body, if any. This method should not be overridden. (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the Body class.
Top
Public Events
 | Name | Description
Public Event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Body Class
GrapeCity.ActiveReports.PageReportModel Namespace


Body Constructor

Body Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Body Class : Body Constructor
Initializes a new instance of the Body class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Body()
See Also

Reference

Body Class
Body Members


Body Class Methods

Body Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Body Class

For a list of all members of this type, see Body members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the resources used by the Body. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String containing the name of the Body, if any. This method should not be overridden. (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the Body class.
Top
See Also

Reference

Body Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (Body)

Validate Method (Body)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Body Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the Body class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

Body Class
Body Members


Body Class Properties

Body Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Body Class

For a list of all members of this type, see Body members.

Public Properties
 | Name | Description
Public Property | Columns | Gets or sets the number of columns the report contains.
Public Property | ColumnSpacing | Gets or sets the amount of white space between each of the report's columns.
Public Property | Components | Gets a ReportComponentCollection containing all the ReportComponent in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Container | Gets the IContainer that contains the Body. (Inherited from System.ComponentModel.Component)
Public Property | Height | Gets or sets the height of the report's IBody
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportItems | Gets a ReportItemCollection containing all the ReportItem in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Site | Gets or sets the ISite of the Body. (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report's body.
Top
See Also

Reference

Body Class
GrapeCity.ActiveReports.PageReportModel Namespace


Columns Property (Body)

Columns Property (Body)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Body Class : Columns Property

Gets or sets the number of columns the report contains.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Columns As System.Integer
public System.int Columns {get; set;}

Property Value

An Int indicating the column count. The default value is 1. The minimum value is 1 and the maximum value is 100.

See Also

Reference

Body Class
Body Members


ColumnSpacing Property (Body)

ColumnSpacing Property (Body)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Body Class : ColumnSpacing Property

Gets or sets the amount of white space between each of the report's columns.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ColumnSpacing As Length
public Length ColumnSpacing {get; set;}

Property Value

A Length structure indicating the value of the columns' spacing. The default value is 0.5 inches.

See Also

Reference

Body Class
Body Members


Height Property (Body)

Height Property (Body)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Body Class : Height Property
Gets or sets the height of the report's IBody
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As Length
public Length Height {get; set;}

Property Value

A Length structure indicating the value of the body's height.

See Also

Reference

Body Class
Body Members


Style Property (Body)

Style Property (Body)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Body Class : Style Property

Gets or sets the the style settings for the report's body.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As Style
public Style Style {get; set;}

Property Value

A Style object representing the report body's style elements.
Remarks
The body is treated like a rectangular ReportItem when determining which style elements apply, with the exception of the Language property.
See Also

Reference

Body Class
Body Members


Border Class

Border Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Border Class
Represents the border properties.
Object Model
Border Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Border
public class Border
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Border

See Also

Reference

Border Members
GrapeCity.ActiveReports.PageReportModel Namespace


Border Class Members

Border Class Members
Fields Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Border Class

The following tables list the members exposed by Border.

Public Constructors
 | Name | Description
Public Constructor | Border Constructor | Overloaded.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | ColorDefaultValue | The default value for color.
static (Shared in Visual Basic) | WidthDefaultValue | The default value for width.
Top
Public Properties
 | Name | Description
Public Property | Color | The border color.
Public Property | Style | The border style.
Public Property | Width | The border width.
Top
See Also

Reference

Border Class
GrapeCity.ActiveReports.PageReportModel Namespace


Border Constructor

Border Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Border Class : Border Constructor
Overload List
Overload | Description
Border Constructor() | Initializes a new instance of this class.
Border Constructor(ExpressionInfo,ExpressionInfo,ExpressionInfo) | Initializes a new instance of this class.
See Also

Reference

Border Class
Border Members


Border Constructor()

Border Constructor()

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Border Class > Border Constructor : Border Constructor()
Initializes a new instance of this class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Border()
See Also

Reference

Border Class
Border Members
Overload List


Border Constructor(ExpressionInfo,ExpressionInfo,ExpressionInfo)

Border Constructor(ExpressionInfo,ExpressionInfo,ExpressionInfo)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Border Class > Border Constructor : Border Constructor(ExpressionInfo,ExpressionInfo,ExpressionInfo)
The border style.
The border width.
The border color.
Initializes a new instance of this class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal style As ExpressionInfo, _
   ByVal width As ExpressionInfo, _
   ByVal color As ExpressionInfo _
)
public Border(
   ExpressionInfo style,
   ExpressionInfo width,
   ExpressionInfo color
)

Parameters

style
The border style.
width
The border width.
color
The border color.
See Also

Reference

Border Class
Border Members
Overload List


Border Class Properties

Border Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Border Class

For a list of all members of this type, see Border members.

Public Properties
 | Name | Description
Public Property | Color | The border color.
Public Property | Style | The border style.
Public Property | Width | The border width.
Top
See Also

Reference

Border Class
GrapeCity.ActiveReports.PageReportModel Namespace


Color Property (Border)

Color Property (Border)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Border Class : Color Property
The border color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Color As ExpressionInfo
public ExpressionInfo Color {get; set;}
See Also

Reference

Border Class
Border Members


Style Property (Border)

Style Property (Border)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Border Class : Style Property
The border style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As ExpressionInfo
public ExpressionInfo Style {get; set;}
See Also

Reference

Border Class
Border Members


Width Property (Border)

Width Property (Border)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Border Class : Width Property
The border width.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As ExpressionInfo
public ExpressionInfo Width {get; set;}
See Also

Reference

Border Class
Border Members


Border Class Fields

Border Class Fields

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Border Class

For a list of all members of this type, see Border members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | ColorDefaultValue | The default value for color.
static (Shared in Visual Basic) | WidthDefaultValue | The default value for width.
Top
See Also

Reference

Border Class
GrapeCity.ActiveReports.PageReportModel Namespace


ColorDefaultValue Field

ColorDefaultValue Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Border Class : ColorDefaultValue Field
The default value for color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly ColorDefaultValue As ExpressionInfo
public static readonly ExpressionInfo ColorDefaultValue
See Also

Reference

Border Class
Border Members


WidthDefaultValue Field

WidthDefaultValue Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Border Class : WidthDefaultValue Field
The default value for width.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly WidthDefaultValue As Length
public static readonly Length WidthDefaultValue
See Also

Reference

Border Class
Border Members


BorderColor Class

BorderColor Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderColor Class
Defines the color for the border.
Object Model
BorderColor Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class BorderColor
public sealed class BorderColor
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.BorderColor

See Also

Reference

BorderColor Members
GrapeCity.ActiveReports.PageReportModel Namespace


BorderColor Class Members

BorderColor Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderColor Class

The following tables list the members exposed by BorderColor.

Public Constructors
 | Name | Description
Public Constructor | BorderColor Constructor | Initializes a new instance of the BorderColor class.
Top
Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the color of the bottom border.
Public Property | Default | Gets or sets the color of the border (unless overridden for a specific side).
Public Property | Left | Gets or sets the color of the left border.
Public Property | Right | Gets or sets the color of the right border.
Public Property | Top | Gets or sets the color of the top border.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the BorderColor object.
Top
See Also

Reference

BorderColor Class
GrapeCity.ActiveReports.PageReportModel Namespace


BorderColor Constructor

BorderColor Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderColor Class : BorderColor Constructor
Initializes a new instance of the BorderColor class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public BorderColor()
See Also

Reference

BorderColor Class
BorderColor Members


BorderColor Class Methods

BorderColor Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderColor Class

For a list of all members of this type, see BorderColor members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the BorderColor object.
Top
See Also

Reference

BorderColor Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (BorderColor)

Validate Method (BorderColor)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderColor Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the BorderColor object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

BorderColor Class
BorderColor Members


BorderColor Class Properties

BorderColor Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderColor Class

For a list of all members of this type, see BorderColor members.

Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the color of the bottom border.
Public Property | Default | Gets or sets the color of the border (unless overridden for a specific side).
Public Property | Left | Gets or sets the color of the left border.
Public Property | Right | Gets or sets the color of the right border.
Public Property | Top | Gets or sets the color of the top border.
Top
See Also

Reference

BorderColor Class
GrapeCity.ActiveReports.PageReportModel Namespace


Bottom Property (BorderColor)

Bottom Property (BorderColor)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderColor Class : Bottom Property

Gets or sets the color of the bottom border.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Bottom As ExpressionInfo
public ExpressionInfo Bottom {get; set;}

Property Value

An ExpressionInfo object that evaluates to the color of the bottom border.
See Also

Reference

BorderColor Class
BorderColor Members


Default Property (BorderColor)

Default Property (BorderColor)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderColor Class : Default Property

Gets or sets the color of the border (unless overridden for a specific side).

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Default As ExpressionInfo
public ExpressionInfo Default {get; set;}

Property Value

An ExpressionInfo object that evaluates to the color of the border.
Remarks

The default value is Black.

See Also

Reference

BorderColor Class
BorderColor Members


Left Property (BorderColor)

Left Property (BorderColor)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderColor Class : Left Property

Gets or sets the color of the left border.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Left As ExpressionInfo
public ExpressionInfo Left {get; set;}

Property Value

An ExpressionInfo object that evaluates to the color of the left border.
See Also

Reference

BorderColor Class
BorderColor Members


Right Property (BorderColor)

Right Property (BorderColor)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderColor Class : Right Property

Gets or sets the color of the right border.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Right As ExpressionInfo
public ExpressionInfo Right {get; set;}

Property Value

An ExpressionInfo object that evaluates to the color of the right border.
See Also

Reference

BorderColor Class
BorderColor Members


Top Property (BorderColor)

Top Property (BorderColor)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderColor Class : Top Property

Gets or sets the color of the top border.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Top As ExpressionInfo
public ExpressionInfo Top {get; set;}

Property Value

An ExpressionInfo object that evaluates to the color of the top border.
See Also

Reference

BorderColor Class
BorderColor Members


BorderStyle Class

BorderStyle Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderStyle Class
Defines the style for the border.
Object Model
BorderStyle Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class BorderStyle
public sealed class BorderStyle
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.BorderStyle

See Also

Reference

BorderStyle Members
GrapeCity.ActiveReports.PageReportModel Namespace


BorderStyle Class Members

BorderStyle Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderStyle Class

The following tables list the members exposed by BorderStyle.

Public Constructors
 | Name | Description
Public Constructor | BorderStyle Constructor | Initializes a new instance of the BorderStyle class.
Top
Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the style of the bottom border.
Public Property | Default | Gets or sets the style of the border (unless overridden for a specific side).
Public Property | Left | Gets or sets the style of the left border.
Public Property | Right | Gets or sets the style of the right border.
Public Property | Top | Gets or sets the style of the top border.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the BorderStyle object.
Top
See Also

Reference

BorderStyle Class
GrapeCity.ActiveReports.PageReportModel Namespace


BorderStyle Constructor

BorderStyle Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderStyle Class : BorderStyle Constructor
Initializes a new instance of the BorderStyle class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public BorderStyle()
See Also

Reference

BorderStyle Class
BorderStyle Members


BorderStyle Class Methods

BorderStyle Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderStyle Class

For a list of all members of this type, see BorderStyle members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the BorderStyle object.
Top
See Also

Reference

BorderStyle Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (BorderStyle)

Validate Method (BorderStyle)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderStyle Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the BorderStyle object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

BorderStyle Class
BorderStyle Members


BorderStyle Class Properties

BorderStyle Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderStyle Class

For a list of all members of this type, see BorderStyle members.

Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the style of the bottom border.
Public Property | Default | Gets or sets the style of the border (unless overridden for a specific side).
Public Property | Left | Gets or sets the style of the left border.
Public Property | Right | Gets or sets the style of the right border.
Public Property | Top | Gets or sets the style of the top border.
Top
See Also

Reference

BorderStyle Class
GrapeCity.ActiveReports.PageReportModel Namespace


Bottom Property (BorderStyle)

Bottom Property (BorderStyle)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderStyle Class : Bottom Property

Gets or sets the style of the bottom border.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Bottom As ExpressionInfo
public ExpressionInfo Bottom {get; set;}

Property Value

An ExpressionInfo object that evaluates to a BorderStyle enumeration. Valid values are listed in the table below.
BorderStyle | Description
None | No border line is drawn around the report control.
Dotted | A dotted line is drawn around the report control.
Dashed | A dashed line is drawn around the report control.
Solid | A solid line is drawn around the report control.
Double | A double line is drawn around the report control.
Groove | A grooved line is drawn around the report control.
Ridge | A ridged line is drawn around the report control.
Inset | An inset line is drawn around the report control.
WindowInset | A Windows-style inset line is drawn around the report control.
Outset | An outset line is drawn around the report control.
See Also

Reference

BorderStyle Class
BorderStyle Members


Default Property (BorderStyle)

Default Property (BorderStyle)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderStyle Class : Default Property

Gets or sets the style of the border (unless overridden for a specific side).

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Default As ExpressionInfo
public ExpressionInfo Default {get; set;}

Property Value

An ExpressionInfo object that evaluates to a BorderStyle enumeration. Valid values are listed in the table below.
BorderStyle | Description
None | No border line is drawn around the report control.
Dotted | A dotted line is drawn around the report control.
Dashed | A dashed line is drawn around the report control.
Solid | A solid line is drawn around the report control.
Double | A double line is drawn around the report control.
Groove | A grooved line is drawn around the report control.
Ridge | A ridged line is drawn around the report control.
Inset | An inset line is drawn around the report control.
WindowInset | A Windows-style inset line is drawn around the report control.
Outset | An outset line is drawn around the report control.
See Also

Reference

BorderStyle Class
BorderStyle Members


Left Property (BorderStyle)

Left Property (BorderStyle)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderStyle Class : Left Property

Gets or sets the style of the left border.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Left As ExpressionInfo
public ExpressionInfo Left {get; set;}

Property Value

An ExpressionInfo object that evaluates to a BorderStyle enumeration. Valid values are listed in the table below.
BorderStyle | Description
None | No border line is drawn around the report control.
Dotted | A dotted line is drawn around the report control.
Dashed | A dashed line is drawn around the report control.
Solid | A solid line is drawn around the report control.
Double | A double line is drawn around the report control.
Groove | A grooved line is drawn around the report control.
Ridge | A ridged line is drawn around the report control.
Inset | An inset line is drawn around the report control.
WindowInset | A Windows-style inset line is drawn around the report control.
Outset | An outset line is drawn around the report control.
See Also

Reference

BorderStyle Class
BorderStyle Members


Right Property (BorderStyle)

Right Property (BorderStyle)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderStyle Class : Right Property

Gets or sets the style of the right border.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Right As ExpressionInfo
public ExpressionInfo Right {get; set;}

Property Value

An ExpressionInfo object that evaluates to a BorderStyle enumeration. Valid values are listed in the table below.
BorderStyle | Description
None | No border line is drawn around the report control.
Dotted | A dotted line is drawn around the report control.
Dashed | A dashed line is drawn around the report control.
Solid | A solid line is drawn around the report control.
Double | A double line is drawn around the report control.
Groove | A grooved line is drawn around the report control.
Ridge | A ridged line is drawn around the report control.
Inset | An inset line is drawn around the report control.
WindowInset | A Windows-style inset line is drawn around the report control.
Outset | An outset line is drawn around the report control.
See Also

Reference

BorderStyle Class
BorderStyle Members


Top Property (BorderStyle)

Top Property (BorderStyle)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderStyle Class : Top Property

Gets or sets the style of the top border.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Top As ExpressionInfo
public ExpressionInfo Top {get; set;}

Property Value

An ExpressionInfo object that evaluates to a BorderStyle enumeration. Valid values are listed in the table below.
BorderStyle | Description
None | No border line is drawn around the report control.
Dotted | A dotted line is drawn around the report control.
Dashed | A dashed line is drawn around the report control.
Solid | A solid line is drawn around the report control.
Double | A double line is drawn around the report control.
Groove | A grooved line is drawn around the report control.
Ridge | A ridged line is drawn around the report control.
Inset | An inset line is drawn around the report control.
WindowInset | A Windows-style inset line is drawn around the report control.
Outset | An outset line is drawn around the report control.
See Also

Reference

BorderStyle Class
BorderStyle Members


BorderWidth Class

BorderWidth Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderWidth Class
Defines the width of the border.
Object Model
BorderWidth Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class BorderWidth
public sealed class BorderWidth
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.BorderWidth

See Also

Reference

BorderWidth Members
GrapeCity.ActiveReports.PageReportModel Namespace


BorderWidth Class Members

BorderWidth Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderWidth Class

The following tables list the members exposed by BorderWidth.

Public Constructors
 | Name | Description
Public Constructor | BorderWidth Constructor | Initializes a new instance of the BorderWidth class.
Top
Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the width of the bottom border.
Public Property | Default | Gets or sets the width of the border (unless overridden for a specific side).
Public Property | Left | Gets or sets the width of the left border.
Public Property | Right | Gets or sets the width of the right border.
Public Property | Top | Gets or sets the width of the top border.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the BorderWidth object.
Top
See Also

Reference

BorderWidth Class
GrapeCity.ActiveReports.PageReportModel Namespace


BorderWidth Constructor

BorderWidth Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderWidth Class : BorderWidth Constructor
Initializes a new instance of the BorderWidth class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public BorderWidth()
See Also

Reference

BorderWidth Class
BorderWidth Members


BorderWidth Class Methods

BorderWidth Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderWidth Class

For a list of all members of this type, see BorderWidth members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the BorderWidth object.
Top
See Also

Reference

BorderWidth Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (BorderWidth)

Validate Method (BorderWidth)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderWidth Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the BorderWidth object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

BorderWidth Class
BorderWidth Members


BorderWidth Class Properties

BorderWidth Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderWidth Class

For a list of all members of this type, see BorderWidth members.

Public Properties
 | Name | Description
Public Property | Bottom | Gets or sets the width of the bottom border.
Public Property | Default | Gets or sets the width of the border (unless overridden for a specific side).
Public Property | Left | Gets or sets the width of the left border.
Public Property | Right | Gets or sets the width of the right border.
Public Property | Top | Gets or sets the width of the top border.
Top
See Also

Reference

BorderWidth Class
GrapeCity.ActiveReports.PageReportModel Namespace


Bottom Property (BorderWidth)

Bottom Property (BorderWidth)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderWidth Class : Bottom Property

Gets or sets the width of the bottom border.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Bottom As ExpressionInfo
public ExpressionInfo Bottom {get; set;}

Property Value

An ExpressionInfo object that evaluates to a Length structure indicating the width of the bottom border.
See Also

Reference

BorderWidth Class
BorderWidth Members


Default Property (BorderWidth)

Default Property (BorderWidth)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderWidth Class : Default Property

Gets or sets the width of the border (unless overridden for a specific side).

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Default As ExpressionInfo
public ExpressionInfo Default {get; set;}

Property Value

An ExpressionInfo object that evaluates to a Length structure indicating the width of the border.
Remarks

The default value is 1pt; the maximum is 20pt; the minimum is .25pt.

See Also

Reference

BorderWidth Class
BorderWidth Members


Left Property (BorderWidth)

Left Property (BorderWidth)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderWidth Class : Left Property

Gets or sets the width of the left border.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Left As ExpressionInfo
public ExpressionInfo Left {get; set;}

Property Value

An ExpressionInfo object that evaluates to a Length structure indicating the width of the left border.
See Also

Reference

BorderWidth Class
BorderWidth Members


Right Property (BorderWidth)

Right Property (BorderWidth)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderWidth Class : Right Property

Gets or sets the width of the right border.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Right As ExpressionInfo
public ExpressionInfo Right {get; set;}

Property Value

An ExpressionInfo object that evaluates to a Length structure indicating the width of the right border.
See Also

Reference

BorderWidth Class
BorderWidth Members


Top Property (BorderWidth)

Top Property (BorderWidth)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > BorderWidth Class : Top Property

Gets or sets the width of the top border.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Top As ExpressionInfo
public ExpressionInfo Top {get; set;}

Property Value

An ExpressionInfo object that evaluates to a Length structure indicating the width of the top border.
See Also

Reference

BorderWidth Class
BorderWidth Members


CategoryGrouping Class

CategoryGrouping Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CategoryGrouping Class
The CategoryGrouping element defines the category level for a Chart. The labels for the categories are displayed along the category axis.
Object Model
CategoryGrouping Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class CategoryGrouping
   Inherits ReportComponent
   Implements IReportComponent
public sealed class CategoryGrouping : ReportComponent, IReportComponent
Remarks
A CategoryGrouping object must have either a defined DynamicCategories or a defined StaticCategories property, but not both.
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.CategoryGrouping

See Also

Reference

CategoryGrouping Members
GrapeCity.ActiveReports.PageReportModel Namespace


CategoryGrouping Class Members

CategoryGrouping Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CategoryGrouping Class

The following tables list the members exposed by CategoryGrouping.

Public Constructors
 | Name | Description
Public Constructor | CategoryGrouping Constructor | Initializes a new instance of the CategoryGrouping class.
Top
Public Properties
 | Name | Description
Public Property | Container | Gets the IContainer that contains the CategoryGrouping. (Inherited from System.ComponentModel.Component)
Public Property | DynamicCategories | Gets or sets the dynamic category headings for the grouping.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | Gets or sets the ISite of the CategoryGrouping. (Inherited from System.ComponentModel.Component)
Public Property | StaticCategories | Gets the static category headings for the grouping.
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String containing the name of the CategoryGrouping, if any. This method should not be overridden. (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the CategoryGrouping object.
Top
Public Events
 | Name | Description
Public Event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

CategoryGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


CategoryGrouping Constructor

CategoryGrouping Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGrouping Class : CategoryGrouping Constructor
Initializes a new instance of the CategoryGrouping class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public CategoryGrouping()
See Also

Reference

CategoryGrouping Class
CategoryGrouping Members


CategoryGrouping Class Methods

CategoryGrouping Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CategoryGrouping Class

For a list of all members of this type, see CategoryGrouping members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String containing the name of the CategoryGrouping, if any. This method should not be overridden. (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the CategoryGrouping object.
Top
See Also

Reference

CategoryGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (CategoryGrouping)

Validate Method (CategoryGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGrouping Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the CategoryGrouping object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

CategoryGrouping Class
CategoryGrouping Members


CategoryGrouping Class Properties

CategoryGrouping Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CategoryGrouping Class

For a list of all members of this type, see CategoryGrouping members.

Public Properties
 | Name | Description
Public Property | Container | Gets the IContainer that contains the CategoryGrouping. (Inherited from System.ComponentModel.Component)
Public Property | DynamicCategories | Gets or sets the dynamic category headings for the grouping.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | Gets or sets the ISite of the CategoryGrouping. (Inherited from System.ComponentModel.Component)
Public Property | StaticCategories | Gets the static category headings for the grouping.
Top
See Also

Reference

CategoryGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


DynamicCategories Property

DynamicCategories Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGrouping Class : DynamicCategories Property

Gets or sets the dynamic category headings for the grouping.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DynamicCategories As DynamicCategoriesSeries
public DynamicCategoriesSeries DynamicCategories {get; set;}

Property Value

A DynamicCategoriesSeries object indicating the dynamic category headings for the grouping.
See Also

Reference

CategoryGrouping Class
CategoryGrouping Members


StaticCategories Property

StaticCategories Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGrouping Class : StaticCategories Property

Gets the static category headings for the grouping.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property StaticCategories As StaticMemberCollection
public StaticMemberCollection StaticCategories {get;}

Property Value

A StaticMemberCollection object indicating static category headings for the grouping.
See Also

Reference

CategoryGrouping Class
CategoryGrouping Members


CategoryGroupingCollection Class

CategoryGroupingCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CategoryGroupingCollection Class
Provides a strongly typed collection for CategoryGrouping objects.
Object Model
CategoryGroupingCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class CategoryGroupingCollection
   Inherits System.Collections.CollectionBase
public sealed class CategoryGroupingCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.CategoryGroupingCollection

See Also

Reference

CategoryGroupingCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


CategoryGroupingCollection Class Members

CategoryGroupingCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CategoryGroupingCollection Class

The following tables list the members exposed by CategoryGroupingCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CategoryGroupingCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CategoryGroupingCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific CategoryGrouping object in the CategoryGroupingCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a CategoryGrouping object to the CategoryGroupingCollection.
Public Method | Clear | Clears all CategoryGrouping objects from the CategoryGroupingCollection. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a CategoryGrouping object in the CategoryGroupingCollection
Public Method | Insert | Inserts a new CategoryGrouping object into the CategoryGroupingCollection at the specified location.
Public Method | Remove | Removes the specified CategoryGrouping object from the CategoryGroupingCollection.
Public Method | RemoveAt | Removes the specified CategoryGrouping object from the CategoryGroupingCollection. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

CategoryGroupingCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


CategoryGroupingCollection Class Methods

CategoryGroupingCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CategoryGroupingCollection Class

For a list of all members of this type, see CategoryGroupingCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a CategoryGrouping object to the CategoryGroupingCollection.
Public Method | Clear | Clears all CategoryGrouping objects from the CategoryGroupingCollection. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a CategoryGrouping object in the CategoryGroupingCollection
Public Method | Insert | Inserts a new CategoryGrouping object into the CategoryGroupingCollection at the specified location.
Public Method | Remove | Removes the specified CategoryGrouping object from the CategoryGroupingCollection.
Public Method | RemoveAt | Removes the specified CategoryGrouping object from the CategoryGroupingCollection. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

CategoryGroupingCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (CategoryGroupingCollection)

Add Method (CategoryGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGroupingCollection Class : Add Method
The CategoryGrouping object to add to the collection.
Adds a CategoryGrouping object to the CategoryGroupingCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As CategoryGrouping _
) As System.Integer
public System.int Add(
   CategoryGrouping value
)

Parameters

value
The CategoryGrouping object to add to the collection.

Return Value

A new CategoryGrouping object.
See Also

Reference

CategoryGroupingCollection Class
CategoryGroupingCollection Members


IndexOf Method (CategoryGroupingCollection)

IndexOf Method (CategoryGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGroupingCollection Class : IndexOf Method
The CategoryGrouping object to locate in the CategoryGroupingCollection.
Determines the index of a CategoryGrouping object in the CategoryGroupingCollection
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As CategoryGrouping _
) As System.Integer
public System.int IndexOf(
   CategoryGrouping value
)

Parameters

value
The CategoryGrouping object to locate in the CategoryGroupingCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

CategoryGroupingCollection Class
CategoryGroupingCollection Members


Insert Method (CategoryGroupingCollection)

Insert Method (CategoryGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGroupingCollection Class : Insert Method
A zero-based Integer indicating the position at which to insert the CategoryGrouping object.
The CategoryGrouping object to insert.
Inserts a new CategoryGrouping object into the CategoryGroupingCollection at the specified location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As CategoryGrouping _
)
public void Insert(
   System.int index,
   CategoryGrouping value
)

Parameters

index
A zero-based Integer indicating the position at which to insert the CategoryGrouping object.
value
The CategoryGrouping object to insert.
See Also

Reference

CategoryGroupingCollection Class
CategoryGroupingCollection Members


Remove Method (CategoryGroupingCollection)

Remove Method (CategoryGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGroupingCollection Class : Remove Method
The CategoryGrouping object to remove.
Removes the specified CategoryGrouping object from the CategoryGroupingCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As CategoryGrouping _
)
public void Remove(
   CategoryGrouping value
)

Parameters

value
The CategoryGrouping object to remove.
See Also

Reference

CategoryGroupingCollection Class
CategoryGroupingCollection Members


CategoryGroupingCollection Class Properties

CategoryGroupingCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CategoryGroupingCollection Class

For a list of all members of this type, see CategoryGroupingCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CategoryGroupingCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CategoryGroupingCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific CategoryGrouping object in the CategoryGroupingCollection by position.
Top
See Also

Reference

CategoryGroupingCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (CategoryGroupingCollection)

Item Property (CategoryGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGroupingCollection Class : Item Property
A zero-based Integer indicating the index of the CategoryGrouping to return or set.
Gets or sets a specific CategoryGrouping object in the CategoryGroupingCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As CategoryGrouping
public CategoryGrouping this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the CategoryGrouping to return or set.

Property Value

The CategoryGrouping object at the specified position.
See Also

Reference

CategoryGroupingCollection Class
CategoryGroupingCollection Members


Chart Class

Chart Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Chart Class
The Chart element defines a chart data region. The Chart is defined much like a Matrix, but instead of Columns, Rows, and Cells, the Chart has Categories, Series, and DataPoints.
Object Model
Chart Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Chart
   Inherits DataRegion
   Implements IReportComponent, IScopeDefinition
public sealed class Chart : DataRegion, IReportComponent, IScopeDefinition
Remarks
A Chart must have either a defined SeriesGroupings or a defined CategoryGroupings property, or both.
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.DataRegion
GrapeCity.ActiveReports.PageReportModel.Chart

See Also

Reference

Chart Members
GrapeCity.ActiveReports.PageReportModel Namespace


Chart Class Members

Chart Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Chart Class

The following tables list the members exposed by Chart.

Public Constructors
 | Name | Description
Public Constructor | Chart Constructor | Initializes a new instance of the Chart class.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | CategoryAxis | Gets or sets the category axis.
Public Property | CategoryGroupings | Gets the set of category groupings for the chart.
Public Property | ChartCustomPaletteColors | Represents ChartCustomPaletteColors element (DD RDL extension).
Public Property | ChartData | Gets the data values for the chart.
Public Property | ChartElementOutput | Gets or sets a value indicating whether a DataPoint element containing the chart data points appears in a data rendering.
Public Property | ChildScopes | Overridden. Gets the child scopes.
Public Property | Container | Gets the IContainer that contains the Chart. (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataSetName | Gets or sets the name of the dataset that the data region uses. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | Filters | Gets the collection of filters applied to each row of data within the data region. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | FixedHeight | Represents the data region's maximum height per page. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | FixedWidth | Represents the data region's maximum width per page. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Legend | Gets or sets the chart legend.
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | NewSection | Gets or sets a value indicating whether a data region is in it's own section (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | NoRows | Gets or sets the message to display inside the data region when the region contains no rows. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | OverflowName | Represents the data region's overflow name. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether a page break occurs immediately after the data region ends. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | PageBreakAtStart | Gets or sets a value indicating whether a page break occurs immediately before the data region begins. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | Palette | Gets or sets the color palette for the chart items.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | PlotArea | Gets or sets the properties for the plot area.
Public Property | PointWidth | Gets or sets the percent width for bars and columns. A value of 100 represents 100% of the distance between points. A value greater than 100 causes columns to overlap.
Public Property | Properties | Gets the properties for extended chart types.
Public Property | ReferenceLine | Gets or sets the properties for reference line.
Public Property | SeriesGroupings | Gets the set of series groupings for the chart.
Public Property | Site | Gets or sets the ISite of the Chart. (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Subtype | Gets or sets the subtype of the chart. Available subtypes, and their default values, depend on the chart's Type.
Public Property | ThreeDProperties | Gets or sets the properties for a 3D chart layout.
Public Property | Title | Gets or sets the title for the chart.
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Type | Gets or sets the type of the chart.
Public Property | ValueAxis | Gets or sets the value axis.
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the resources used by the Chart. (Inherited from System.ComponentModel.Component)
Public Method | GetExpressions | Overridden. Gets the expressions required for chart to be rendered.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String containing the name of the Chart, if any. This method should not be overridden. (Inherited from System.ComponentModel.Component)
Public Method | Validate | Overridden. Validates the information in each property of the Chart object.
Top
Public Events
 | Name | Description
Public Event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Chart Class
GrapeCity.ActiveReports.PageReportModel Namespace


Chart Constructor

Chart Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : Chart Constructor
Initializes a new instance of the Chart class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Chart()
See Also

Reference

Chart Class
Chart Members


Chart Class Methods

Chart Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Chart Class

For a list of all members of this type, see Chart members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the resources used by the Chart. (Inherited from System.ComponentModel.Component)
Public Method | GetExpressions | Overridden. Gets the expressions required for chart to be rendered.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String containing the name of the Chart, if any. This method should not be overridden. (Inherited from System.ComponentModel.Component)
Public Method | Validate | Overridden. Validates the information in each property of the Chart object.
Top
See Also

Reference

Chart Class
GrapeCity.ActiveReports.PageReportModel Namespace


GetExpressions Method (Chart)

GetExpressions Method (Chart)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : GetExpressions Method
Gets the expressions required for chart to be rendered.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function GetExpressions() As ExpressionInfo()
public override ExpressionInfo[] GetExpressions()
See Also

Reference

Chart Class
Chart Members


Validate Method (Chart)

Validate Method (Chart)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the Chart object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

Chart Class
Chart Members


Chart Class Properties

Chart Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Chart Class

For a list of all members of this type, see Chart members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | CategoryAxis | Gets or sets the category axis.
Public Property | CategoryGroupings | Gets the set of category groupings for the chart.
Public Property | ChartCustomPaletteColors | Represents ChartCustomPaletteColors element (DD RDL extension).
Public Property | ChartData | Gets the data values for the chart.
Public Property | ChartElementOutput | Gets or sets a value indicating whether a DataPoint element containing the chart data points appears in a data rendering.
Public Property | ChildScopes | Overridden. Gets the child scopes.
Public Property | Container | Gets the IContainer that contains the Chart. (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataSetName | Gets or sets the name of the dataset that the data region uses. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | Filters | Gets the collection of filters applied to each row of data within the data region. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | FixedHeight | Represents the data region's maximum height per page. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | FixedWidth | Represents the data region's maximum width per page. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Legend | Gets or sets the chart legend.
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | NewSection | Gets or sets a value indicating whether a data region is in it's own section (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | NoRows | Gets or sets the message to display inside the data region when the region contains no rows. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | OverflowName | Represents the data region's overflow name. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether a page break occurs immediately after the data region ends. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | PageBreakAtStart | Gets or sets a value indicating whether a page break occurs immediately before the data region begins. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | Palette | Gets or sets the color palette for the chart items.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | PlotArea | Gets or sets the properties for the plot area.
Public Property | PointWidth | Gets or sets the percent width for bars and columns. A value of 100 represents 100% of the distance between points. A value greater than 100 causes columns to overlap.
Public Property | Properties | Gets the properties for extended chart types.
Public Property | ReferenceLine | Gets or sets the properties for reference line.
Public Property | SeriesGroupings | Gets the set of series groupings for the chart.
Public Property | Site | Gets or sets the ISite of the Chart. (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Subtype | Gets or sets the subtype of the chart. Available subtypes, and their default values, depend on the chart's Type.
Public Property | ThreeDProperties | Gets or sets the properties for a 3D chart layout.
Public Property | Title | Gets or sets the title for the chart.
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Type | Gets or sets the type of the chart.
Public Property | ValueAxis | Gets or sets the value axis.
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
See Also

Reference

Chart Class
GrapeCity.ActiveReports.PageReportModel Namespace


CategoryAxis Property (Chart)

CategoryAxis Property (Chart)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : CategoryAxis Property

Gets or sets the category axis.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CategoryAxis As ValueCategoryAxis
public ValueCategoryAxis CategoryAxis {get; set;}

Property Value

A ValueCategoryAxis representing the chart's category axis.
See Also

Reference

Chart Class
Chart Members


CategoryGroupings Property

CategoryGroupings Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : CategoryGroupings Property

Gets the set of category groupings for the chart.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CategoryGroupings As CategoryGroupingCollection
public CategoryGroupingCollection CategoryGroupings {get;}

Property Value

A CategoryGroupingCollection indicating the set of category groupings for the chart.
See Also

Reference

Chart Class
Chart Members


ChartCustomPaletteColors Property

ChartCustomPaletteColors Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : ChartCustomPaletteColors Property
Represents ChartCustomPaletteColors element (DD RDL extension).
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ChartCustomPaletteColors As CustomPaletteColorsCollection
public CustomPaletteColorsCollection ChartCustomPaletteColors {get;}
See Also

Reference

Chart Class
Chart Members


ChartData Property

ChartData Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : ChartData Property

Gets the data values for the chart.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ChartData As ChartSeriesCollection
public ChartSeriesCollection ChartData {get;}

Property Value

A ChartSeriesCollection indicating the data values for the chart.
See Also

Reference

Chart Class
Chart Members


ChartElementOutput Property

ChartElementOutput Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : ChartElementOutput Property

Gets or sets a value indicating whether a DataPoint element containing the chart data points appears in a data rendering.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ChartElementOutput As DataElementOutput
public DataElementOutput ChartElementOutput {get; set;}

Property Value

A DataElementOutput enumeration indicating whether a DataPoint element containing the chart data points appears in a data rendering. Valid values are listed in the table below.
DataElementOutput | Description
Auto | The chart appears in an XML rendering of the report.
Output (Default) | The chart appears in an XML rendering of the report.
NoOutput | The chart does not appear in an XML rendering of the report.
ContentsOnly | This value does not apply to the chart data region.
See Also

Reference

Chart Class
Chart Members


ChildScopes Property (Chart)

ChildScopes Property (Chart)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : ChildScopes Property
Gets the child scopes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable ReadOnly Property ChildScopes As System.Collections.IEnumerable
public override System.Collections.IEnumerable ChildScopes {get;}

Property Value

The child scopes.
See Also

Reference

Chart Class
Chart Members


Legend Property (Chart)

Legend Property (Chart)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : Legend Property

Gets or sets the chart legend.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Legend As Legend
public Legend Legend {get; set;}

Property Value

A Legend object representing the chart's legend.
See Also

Reference

Chart Class
Chart Members


Palette Property (Chart)

Palette Property (Chart)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : Palette Property

Gets or sets the color palette for the chart items.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Palette As ChartPalette
public ChartPalette Palette {get; set;}

Property Value

A ChartPalette enumeration indicating the color palette for the chart items.

See Also

Reference

Chart Class
Chart Members


PlotArea Property (Chart)

PlotArea Property (Chart)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : PlotArea Property

Gets or sets the properties for the plot area.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PlotArea As PlotArea
public PlotArea PlotArea {get; set;}

Property Value

A PlotArea object representing the properties for a plot area.
See Also

Reference

Chart Class
Chart Members


PointWidth Property (Chart)

PointWidth Property (Chart)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : PointWidth Property

Gets or sets the percent width for bars and columns. A value of 100 represents 100% of the distance between points. A value greater than 100 causes columns to overlap.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PointWidth As System.Nullable(Of Integer)
public System.Nullable<int> PointWidth {get; set;}

Property Value

A NullableInt32 representing the percent width for bars and columns.

See Also

Reference

Chart Class
Chart Members


Properties Property (Chart)

Properties Property (Chart)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : Properties Property
Gets the properties for extended chart types.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Properties As PropertyCollection
public PropertyCollection Properties {get;}
See Also

Reference

Chart Class
Chart Members


ReferenceLine Property (Chart)

ReferenceLine Property (Chart)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : ReferenceLine Property
Gets or sets the properties for reference line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReferenceLine As ReferenceLine
public ReferenceLine ReferenceLine {get; set;}
See Also

Reference

Chart Class
Chart Members


SeriesGroupings Property

SeriesGroupings Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : SeriesGroupings Property

Gets the set of series groupings for the chart.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property SeriesGroupings As SeriesGroupingCollection
public SeriesGroupingCollection SeriesGroupings {get;}

Property Value

A SeriesGroupingCollection indicating the set of series groupings for the chart.
See Also

Reference

Chart Class
Chart Members


Subtype Property (Chart)

Subtype Property (Chart)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : Subtype Property

Gets or sets the subtype of the chart.

Available subtypes, and their default values, depend on the chart's Type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Subtype As ChartSubtype
public ChartSubtype Subtype {get; set;}

Property Value

A ChartSubtype enumeration indicating the subtype of the chart.
Remarks
Available subtypes, and their default values, depend on the chart's Type.
ChartType | Available ChartSubtypes
Column | Plain (Default), Stacked, and PercentStacked
Bar | Plain (Default), Stacked, and PercentStacked
Line | Plain (Default) and Smooth
Pie | Plain (Default) and Exploded
Scatter | Plain (Default), Line, and SmoothLine
Bubble | Plain (Default)
Area | Plain (Default), PercentStacked, and Stacked
Doughnut | Plain (Default) and Exploded
Stock | HighLowClose (Default), OpenHighLowClose, and Candlestick
See Also

Reference

Chart Class
Chart Members


ThreeDProperties Property (Chart)

ThreeDProperties Property (Chart)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : ThreeDProperties Property

Gets or sets the properties for a 3D chart layout.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ThreeDProperties As ThreeDProperties
public ThreeDProperties ThreeDProperties {get; set;}

Property Value

A ThreeDProperties object representing the properties for a 3D layout.
See Also

Reference

Chart Class
Chart Members


Title Property (Chart)

Title Property (Chart)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : Title Property

Gets or sets the title for the chart.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Title As Title
public Title Title {get; set;}

Property Value

A Title object representing the chart's title.
See Also

Reference

Chart Class
Chart Members


Type Property (Chart)

Type Property (Chart)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : Type Property

Gets or sets the type of the chart.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Type As ChartType
public ChartType Type {get; set;}

Property Value

A ChartType enumeration indicating the type of chart.
See Also

Reference

Chart Class
Chart Members


ValueAxis Property (Chart)

ValueAxis Property (Chart)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : ValueAxis Property

Gets or sets the value axis.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ValueAxis As ValueCategoryAxis
public ValueCategoryAxis ValueAxis {get; set;}

Property Value

A ValueCategoryAxis representing the chart's value axis.
See Also

Reference

Chart Class
Chart Members


ChartSeries Class

ChartSeries Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartSeries Class
The ChartSeries element defines the set of data points for one series.
Object Model
ChartSeries Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ChartSeries
public sealed class ChartSeries
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ChartSeries

See Also

Reference

ChartSeries Members
GrapeCity.ActiveReports.PageReportModel Namespace


ChartSeries Class Members

ChartSeries Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartSeries Class

The following tables list the members exposed by ChartSeries.

Public Constructors
 | Name | Description
Public Constructor | ChartSeries Constructor | Initializes a new instance of the ChartSeries class.
Top
Public Properties
 | Name | Description
Public Property | DataPoints | Gets the data points within the series.
Public Property | PlotType | Gets or sets a value indicating whether the series is plotted as a line in a column chart. If set to Auto, it is plotted per the primary chart type. If set to Line, it is plotted as a line.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the ChartSeries object.
Top
See Also

Reference

ChartSeries Class
GrapeCity.ActiveReports.PageReportModel Namespace


ChartSeries Constructor

ChartSeries Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartSeries Class : ChartSeries Constructor
Initializes a new instance of the ChartSeries class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ChartSeries()
See Also

Reference

ChartSeries Class
ChartSeries Members


ChartSeries Class Methods

ChartSeries Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartSeries Class

For a list of all members of this type, see ChartSeries members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the ChartSeries object.
Top
See Also

Reference

ChartSeries Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (ChartSeries)

Validate Method (ChartSeries)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartSeries Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the ChartSeries object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

ChartSeries Class
ChartSeries Members


ChartSeries Class Properties

ChartSeries Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartSeries Class

For a list of all members of this type, see ChartSeries members.

Public Properties
 | Name | Description
Public Property | DataPoints | Gets the data points within the series.
Public Property | PlotType | Gets or sets a value indicating whether the series is plotted as a line in a column chart. If set to Auto, it is plotted per the primary chart type. If set to Line, it is plotted as a line.
Top
See Also

Reference

ChartSeries Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataPoints Property

DataPoints Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartSeries Class : DataPoints Property

Gets the data points within the series.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DataPoints As DataPointCollection
public DataPointCollection DataPoints {get;}

Property Value

A DataPointCollection object containing all of the data points in the series.
See Also

Reference

ChartSeries Class
ChartSeries Members


PlotType Property

PlotType Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartSeries Class : PlotType Property

Gets or sets a value indicating whether the series is plotted as a line in a column chart. If set to Auto, it is plotted per the primary chart type. If set to Line, it is plotted as a line.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PlotType As ChartSeriesPlotType
public ChartSeriesPlotType PlotType {get; set;}

Property Value

A ChartSeriesPlotType enumeration indicating whether the series is plotted as a line in a Column chart. The default value is Auto.
See Also

Reference

ChartSeries Class
ChartSeries Members


ChartSeriesCollection Class

ChartSeriesCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartSeriesCollection Class
Provides a strongly typed collection for ChartSeries objects.
Object Model
ChartSeriesCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ChartSeriesCollection
   Inherits System.Collections.CollectionBase
public sealed class ChartSeriesCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ChartSeriesCollection

See Also

Reference

ChartSeriesCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


ChartSeriesCollection Class Members

ChartSeriesCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartSeriesCollection Class

The following tables list the members exposed by ChartSeriesCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the ChartSeriesCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the ChartSeriesCollection instance. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific ChartSeries object in the ChartSeriesCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a ChartSeries object to the ChartSeriesCollection.
Public Method | Clear | Clears all ChartSeries objects from the ChartSeriesCollection. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific ChartSeries object in the ChartSeriesCollection.
Public Method | Insert | Inserts a new ChartSeries object into the ChartSeriesCollection at the specified location.
Public Method | Remove | Removes the specified ChartSeries object from the ChartSeriesCollection.
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ChartSeriesCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ChartSeriesCollection Class Methods

ChartSeriesCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartSeriesCollection Class

For a list of all members of this type, see ChartSeriesCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a ChartSeries object to the ChartSeriesCollection.
Public Method | Clear | Clears all ChartSeries objects from the ChartSeriesCollection. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific ChartSeries object in the ChartSeriesCollection.
Public Method | Insert | Inserts a new ChartSeries object into the ChartSeriesCollection at the specified location.
Public Method | Remove | Removes the specified ChartSeries object from the ChartSeriesCollection.
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ChartSeriesCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (ChartSeriesCollection)

Add Method (ChartSeriesCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartSeriesCollection Class : Add Method
The ChartSeries object to add to the collection.
Adds a ChartSeries object to the ChartSeriesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As ChartSeries _
) As System.Integer
public System.int Add(
   ChartSeries value
)

Parameters

value
The ChartSeries object to add to the collection.

Return Value

A new ChartSeries object.
See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


IndexOf Method (ChartSeriesCollection)

IndexOf Method (ChartSeriesCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartSeriesCollection Class : IndexOf Method
The ChartSeries object to locate in the ChartSeriesCollection.
Determines the index of a specific ChartSeries object in the ChartSeriesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As ChartSeries _
) As System.Integer
public System.int IndexOf(
   ChartSeries value
)

Parameters

value
The ChartSeries object to locate in the ChartSeriesCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


Insert Method (ChartSeriesCollection)

Insert Method (ChartSeriesCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartSeriesCollection Class : Insert Method
A zero-based Integer indicating the position at which to insert the ChartSeries object.
The ChartSeries object to insert.
Inserts a new ChartSeries object into the ChartSeriesCollection at the specified location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As ChartSeries _
)
public void Insert(
   System.int index,
   ChartSeries value
)

Parameters

index
A zero-based Integer indicating the position at which to insert the ChartSeries object.
value
The ChartSeries object to insert.
See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


Remove Method (ChartSeriesCollection)

Remove Method (ChartSeriesCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartSeriesCollection Class : Remove Method
The ChartSeries object to remove.
Removes the specified ChartSeries object from the ChartSeriesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As ChartSeries _
)
public void Remove(
   ChartSeries value
)

Parameters

value
The ChartSeries object to remove.
See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


ChartSeriesCollection Class Properties

ChartSeriesCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartSeriesCollection Class

For a list of all members of this type, see ChartSeriesCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the ChartSeriesCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the ChartSeriesCollection instance. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific ChartSeries object in the ChartSeriesCollection by position.
Top
See Also

Reference

ChartSeriesCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (ChartSeriesCollection)

Item Property (ChartSeriesCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartSeriesCollection Class : Item Property
A zero-based Integer indicating the index of the ChartSeries to return or set.
Gets or sets a specific ChartSeries object in the ChartSeriesCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As ChartSeries
public ChartSeries this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the ChartSeries to return or set.

Property Value

The ChartSeries object at the specified position.
See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


CheckBox Class

CheckBox Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CheckBox Class
The CheckBox element defines a CheckBox control.
Object Model
CheckBox Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class CheckBox
   Inherits TextItem
   Implements IReportComponent
public sealed class CheckBox : TextItem, IReportComponent
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.TextItem
GrapeCity.ActiveReports.PageReportModel.CheckBox

See Also

Reference

CheckBox Members
GrapeCity.ActiveReports.PageReportModel Namespace


CheckBox Class Members

CheckBox Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CheckBox Class

The following tables list the members exposed by CheckBox.

Public Constructors
 | Name | Description
Public Constructor | CheckBox Constructor | Initializes a new instance of CheckBox object.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | CheckAlignment | Gets or sets the alignment of check inside a CheckBox object.
Public Property | Checked | Sets the state of the CheckBox object to checked.
Public Property | Container | Gets the IContainer that contains the CheckBox. (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementStyle | Gets or sets a value indicating whether the textbox value is rendered as an element or attribute. (Inherited from GrapeCity.ActiveReports.PageReportModel.TextItem)
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | Gets or sets the ISite of the CheckBox. (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Text | Sets or gets the field, constant or expression whose value is displayed in the checkbox.
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the resources used by the CheckBox. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String containing the name of the CheckBox, if any. This method should not be overridden. (Inherited from System.ComponentModel.Component)
Public Method | Validate | Overridden. Validates the information in each property of the CheckBox class.
Top
Public Events
 | Name | Description
Public Event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

CheckBox Class
GrapeCity.ActiveReports.PageReportModel Namespace


CheckBox Constructor

CheckBox Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CheckBox Class : CheckBox Constructor
Initializes a new instance of CheckBox object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public CheckBox()
See Also

Reference

CheckBox Class
CheckBox Members


CheckBox Class Methods

CheckBox Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CheckBox Class

For a list of all members of this type, see CheckBox members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the resources used by the CheckBox. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String containing the name of the CheckBox, if any. This method should not be overridden. (Inherited from System.ComponentModel.Component)
Public Method | Validate | Overridden. Validates the information in each property of the CheckBox class.
Top
See Also

Reference

CheckBox Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (CheckBox)

Validate Method (CheckBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CheckBox Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the CheckBox class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all of the validation entries found, or empty if none are found.
See Also

Reference

CheckBox Class
CheckBox Members


CheckBox Class Properties

CheckBox Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CheckBox Class

For a list of all members of this type, see CheckBox members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | CheckAlignment | Gets or sets the alignment of check inside a CheckBox object.
Public Property | Checked | Sets the state of the CheckBox object to checked.
Public Property | Container | Gets the IContainer that contains the CheckBox. (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementStyle | Gets or sets a value indicating whether the textbox value is rendered as an element or attribute. (Inherited from GrapeCity.ActiveReports.PageReportModel.TextItem)
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | Gets or sets the ISite of the CheckBox. (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Text | Sets or gets the field, constant or expression whose value is displayed in the checkbox.
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
See Also

Reference

CheckBox Class
GrapeCity.ActiveReports.PageReportModel Namespace


CheckAlignment Property (CheckBox)

CheckAlignment Property (CheckBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CheckBox Class : CheckAlignment Property
Gets or sets the alignment of check inside a CheckBox object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CheckAlignment As System.Drawing.ContentAlignment
public System.Drawing.ContentAlignment CheckAlignment {get; set;}
See Also

Reference

CheckBox Class
CheckBox Members


Checked Property (CheckBox)

Checked Property (CheckBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CheckBox Class : Checked Property
Sets the state of the CheckBox object to checked.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Checked As ExpressionInfo
public ExpressionInfo Checked {get; set;}
See Also

Reference

CheckBox Class
CheckBox Members


Text Property (CheckBox)

Text Property (CheckBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CheckBox Class : Text Property
Sets or gets the field, constant or expression whose value is displayed in the checkbox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Text As ExpressionInfo
public ExpressionInfo Text {get; set;}
See Also

Reference

CheckBox Class
CheckBox Members


CodeClass Class

CodeClass Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CodeClass Class
Represents information about a class instantiated during the report's initialization. The instantiated class can be used in expressions.
Object Model
CodeClass Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class CodeClass
public sealed class CodeClass
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.CodeClass

See Also

Reference

CodeClass Members
GrapeCity.ActiveReports.PageReportModel Namespace


CodeClass Class Members

CodeClass Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CodeClass Class

The following tables list the members exposed by CodeClass.

Public Constructors
 | Name | Description
Public Constructor | CodeClass Constructor | Initializes a new instance of the CodeClass class.
Top
Public Properties
 | Name | Description
Public Property | ClassName | Gets or sets the name used for the class.
Public Property | InstanceName | Gets or sets the variable to which the class is assigned. The InstanceName can be used in expressions.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the CodeClass object.
Top
See Also

Reference

CodeClass Class
GrapeCity.ActiveReports.PageReportModel Namespace


CodeClass Constructor

CodeClass Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CodeClass Class : CodeClass Constructor
Initializes a new instance of the CodeClass class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public CodeClass()
See Also

Reference

CodeClass Class
CodeClass Members


CodeClass Class Methods

CodeClass Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CodeClass Class

For a list of all members of this type, see CodeClass members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the CodeClass object.
Top
See Also

Reference

CodeClass Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (CodeClass)

Validate Method (CodeClass)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CodeClass Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the CodeClass object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

CodeClass Class
CodeClass Members


CodeClass Class Properties

CodeClass Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CodeClass Class

For a list of all members of this type, see CodeClass members.

Public Properties
 | Name | Description
Public Property | ClassName | Gets or sets the name used for the class.
Public Property | InstanceName | Gets or sets the variable to which the class is assigned. The InstanceName can be used in expressions.
Top
See Also

Reference

CodeClass Class
GrapeCity.ActiveReports.PageReportModel Namespace


ClassName Property (CodeClass)

ClassName Property (CodeClass)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CodeClass Class : ClassName Property

Gets or sets the name used for the class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ClassName As System.String
public System.string ClassName {get; set;}

Property Value

A String indicating the name of the class.

See Also

Reference

CodeClass Class
CodeClass Members


InstanceName Property

InstanceName Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CodeClass Class : InstanceName Property

Gets or sets the variable to which the class is assigned. The InstanceName can be used in expressions.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property InstanceName As System.String
public System.string InstanceName {get; set;}

Property Value

A String indicating the variable name assigned to the class.

See Also

Reference

CodeClass Class
CodeClass Members


CodeClassCollection Class

CodeClassCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CodeClassCollection Class
Provides a strongly typed collection for CodeClassCollection objects.
Object Model
CodeClassCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class CodeClassCollection
   Inherits System.Collections.CollectionBase
public sealed class CodeClassCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.CodeClassCollection

See Also

Reference

CodeClassCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


CodeClassCollection Class Members

CodeClassCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CodeClassCollection Class

The following tables list the members exposed by CodeClassCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CodeClassCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CodeClassCollection instance. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific CodeClass object in the CodeClassCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a CodeClass object to the CodeClassCollection.
Public Method | Clear | Clears all CodeClass objects from the CodeClassCollection. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific CodeClass object in the CodeClassCollection.
Public Method | RemoveAt | Removes the specified CodeClass object from the CodeClassCollection. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

CodeClassCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


CodeClassCollection Class Methods

CodeClassCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CodeClassCollection Class

For a list of all members of this type, see CodeClassCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a CodeClass object to the CodeClassCollection.
Public Method | Clear | Clears all CodeClass objects from the CodeClassCollection. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific CodeClass object in the CodeClassCollection.
Public Method | RemoveAt | Removes the specified CodeClass object from the CodeClassCollection. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

CodeClassCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (CodeClassCollection)

Add Method (CodeClassCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CodeClassCollection Class : Add Method
The CodeClass object to add to the collection.
Adds a CodeClass object to the CodeClassCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As CodeClass _
) As System.Integer
public System.int Add(
   CodeClass value
)

Parameters

value
The CodeClass object to add to the collection.

Return Value

A new CodeClass object.
See Also

Reference

CodeClassCollection Class
CodeClassCollection Members


IndexOf Method (CodeClassCollection)

IndexOf Method (CodeClassCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CodeClassCollection Class : IndexOf Method
The CodeClass object to locate in the CodeClassCollection.
Determines the index of a specific CodeClass object in the CodeClassCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As CodeClass _
) As System.Integer
public System.int IndexOf(
   CodeClass value
)

Parameters

value
The CodeClass object to locate in the CodeClassCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

CodeClassCollection Class
CodeClassCollection Members


CodeClassCollection Class Properties

CodeClassCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CodeClassCollection Class

For a list of all members of this type, see CodeClassCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CodeClassCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CodeClassCollection instance. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific CodeClass object in the CodeClassCollection by position.
Top
See Also

Reference

CodeClassCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (CodeClassCollection)

Item Property (CodeClassCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CodeClassCollection Class : Item Property
A zero-based Integer indicating the index of the CodeClass object to return or set.
Gets or sets a specific CodeClass object in the CodeClassCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As CodeClass
public CodeClass this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the CodeClass object to return or set.

Property Value

The CodeClass object at the specified position.
See Also

Reference

CodeClassCollection Class
CodeClassCollection Members


ColumnGrouping Class

ColumnGrouping Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ColumnGrouping Class
The ColumnGrouping element defines a column header region for a matrix.
Object Model
ColumnGrouping Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ColumnGrouping
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer, IScopeDefinition
public sealed class ColumnGrouping : ReportComponent, IReportComponent, IReportComponentContainer, IScopeDefinition
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ColumnGrouping

See Also

Reference

ColumnGrouping Members
GrapeCity.ActiveReports.PageReportModel Namespace


ColumnGrouping Class Members

ColumnGrouping Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ColumnGrouping Class

The following tables list the members exposed by ColumnGrouping.

Public Constructors
 | Name | Description
Public Constructor | ColumnGrouping Constructor | Initializes a new instance of the ColumnGrouping class.
Top
Public Properties
 | Name | Description
Public Property | Components | Gets the ReportComponentCollection object containing all the components hosted in the control.
Public Property | Container | Gets the IContainer that contains the ColumnGrouping. (Inherited from System.ComponentModel.Component)
Public Property | DynamicColumns | Gets or sets the dynamic column headings for this grouping.
Public Property | FixedHeader | Gets or sets a value indicating whether the header for this grouping should be displayed on the page even when the user scrolls part of the matrix off the page.
Public Property | Height | Gets or sets the height of the column header.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | Gets or sets the ISite of the ColumnGrouping. (Inherited from System.ComponentModel.Component)
Public Property | StaticColumns | Gets the static column headings for this grouping.
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the resources used by the ColumnGrouping. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String containing the name of the ColumnGrouping, if any. This method should not be overridden. (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the ColumnGrouping object.
Top
Public Events
 | Name | Description
Public Event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

ColumnGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


ColumnGrouping Constructor

ColumnGrouping Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGrouping Class : ColumnGrouping Constructor
Initializes a new instance of the ColumnGrouping class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ColumnGrouping()
See Also

Reference

ColumnGrouping Class
ColumnGrouping Members


ColumnGrouping Class Methods

ColumnGrouping Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ColumnGrouping Class

For a list of all members of this type, see ColumnGrouping members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the resources used by the ColumnGrouping. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String containing the name of the ColumnGrouping, if any. This method should not be overridden. (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the ColumnGrouping object.
Top
See Also

Reference

ColumnGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (ColumnGrouping)

Validate Method (ColumnGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGrouping Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the ColumnGrouping object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

ColumnGrouping Class
ColumnGrouping Members


ColumnGrouping Class Properties

ColumnGrouping Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ColumnGrouping Class

For a list of all members of this type, see ColumnGrouping members.

Public Properties
 | Name | Description
Public Property | Components | Gets the ReportComponentCollection object containing all the components hosted in the control.
Public Property | Container | Gets the IContainer that contains the ColumnGrouping. (Inherited from System.ComponentModel.Component)
Public Property | DynamicColumns | Gets or sets the dynamic column headings for this grouping.
Public Property | FixedHeader | Gets or sets a value indicating whether the header for this grouping should be displayed on the page even when the user scrolls part of the matrix off the page.
Public Property | Height | Gets or sets the height of the column header.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | Gets or sets the ISite of the ColumnGrouping. (Inherited from System.ComponentModel.Component)
Public Property | StaticColumns | Gets the static column headings for this grouping.
Top
See Also

Reference

ColumnGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property (ColumnGrouping)

Components Property (ColumnGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGrouping Class : Components Property
Gets the ReportComponentCollection object containing all the components hosted in the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Components As ReportComponentCollection
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection containing all the components hosted in the control.A read-only DataDynamics.Reports.ReportObjectModel.Rdl.ReportComponentCollection containing all the components hosted in the control.
See Also

Reference

ColumnGrouping Class
ColumnGrouping Members


DynamicColumns Property

DynamicColumns Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGrouping Class : DynamicColumns Property

Gets or sets the dynamic column headings for this grouping.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DynamicColumns As DynamicColumnsRows
public DynamicColumnsRows DynamicColumns {get; set;}

Property Value

A DynamicColumnsRows object containing the dynamic column headings for this grouping.
See Also

Reference

ColumnGrouping Class
ColumnGrouping Members


FixedHeader Property (ColumnGrouping)

FixedHeader Property (ColumnGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGrouping Class : FixedHeader Property

Gets or sets a value indicating whether the header for this grouping should be displayed on the page even when the user scrolls part of the matrix off the page.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FixedHeader As System.Boolean
public System.bool FixedHeader {get; set;}

Property Value

A Boolean value where true indicates the grouping should be displayed on the page even when the user scrolls part of the matrix off the page; otherwise false. The default value is false.

Remarks
Fixed headers must be touching each other and must also include the outermost grouping.
See Also

Reference

ColumnGrouping Class
ColumnGrouping Members


Height Property (ColumnGrouping)

Height Property (ColumnGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGrouping Class : Height Property

Gets or sets the height of the column header.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As Length
public Length Height {get; set;}

Property Value

A Length structure indicating the height of the column header.
See Also

Reference

ColumnGrouping Class
ColumnGrouping Members


StaticColumns Property

StaticColumns Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGrouping Class : StaticColumns Property
Gets the static column headings for this grouping.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property StaticColumns As StaticRowColumnCollection
public StaticRowColumnCollection StaticColumns {get;}

Property Value

A StaticRowColumnCollection object containing the static column headings for this grouping.
See Also

Reference

ColumnGrouping Class
ColumnGrouping Members


ColumnGroupingCollection Class

ColumnGroupingCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ColumnGroupingCollection Class
Provides a strongly typed collection for ColumnGroupingCollection objects.
Object Model
ColumnGroupingCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ColumnGroupingCollection
   Inherits System.Collections.CollectionBase
public sealed class ColumnGroupingCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ColumnGroupingCollection

See Also

Reference

ColumnGroupingCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


ColumnGroupingCollection Class Members

ColumnGroupingCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ColumnGroupingCollection Class

The following tables list the members exposed by ColumnGroupingCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the ColumnGroupingCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the ColumnGroupingCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific ColumnGrouping object in the ColumnGroupingCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a ColumnGrouping object to the ColumnGroupingCollection.
Public Method | Clear | Removes all objects from the ColumnGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific ColumnGrouping object in the ColumnGroupingCollection.
Public Method | Insert | Inserts a new CategoryGrouping object into the CategoryGroupingCollection at the specified location.
Public Method | RemoveAt | Removes the element at the specified index of the ColumnGroupingCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ColumnGroupingCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ColumnGroupingCollection Class Methods

ColumnGroupingCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ColumnGroupingCollection Class

For a list of all members of this type, see ColumnGroupingCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a ColumnGrouping object to the ColumnGroupingCollection.
Public Method | Clear | Removes all objects from the ColumnGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific ColumnGrouping object in the ColumnGroupingCollection.
Public Method | Insert | Inserts a new CategoryGrouping object into the CategoryGroupingCollection at the specified location.
Public Method | RemoveAt | Removes the element at the specified index of the ColumnGroupingCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ColumnGroupingCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (ColumnGroupingCollection)

Add Method (ColumnGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGroupingCollection Class : Add Method
The ColumnGrouping object to add to the collection.
Adds a ColumnGrouping object to the ColumnGroupingCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As ColumnGrouping _
) As System.Integer
public System.int Add(
   ColumnGrouping value
)

Parameters

value
The ColumnGrouping object to add to the collection.

Return Value

A new ColumnGrouping object.
See Also

Reference

ColumnGroupingCollection Class
ColumnGroupingCollection Members


IndexOf Method (ColumnGroupingCollection)

IndexOf Method (ColumnGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGroupingCollection Class : IndexOf Method
The ColumnGrouping object to locate in the ColumnGroupingCollection.
Determines the index of a specific ColumnGrouping object in the ColumnGroupingCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As ColumnGrouping _
) As System.Integer
public System.int IndexOf(
   ColumnGrouping value
)

Parameters

value
The ColumnGrouping object to locate in the ColumnGroupingCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

ColumnGroupingCollection Class
ColumnGroupingCollection Members


Insert Method (ColumnGroupingCollection)

Insert Method (ColumnGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGroupingCollection Class : Insert Method
A zero-based Integer indicating the position at which to insert the CategoryGrouping object.
The CategoryGrouping object to insert.
Inserts a new CategoryGrouping object into the CategoryGroupingCollection at the specified location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As ColumnGrouping _
)
public void Insert(
   System.int index,
   ColumnGrouping value
)

Parameters

index
A zero-based Integer indicating the position at which to insert the CategoryGrouping object.
value
The CategoryGrouping object to insert.
See Also

Reference

ColumnGroupingCollection Class
ColumnGroupingCollection Members


ColumnGroupingCollection Class Properties

ColumnGroupingCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ColumnGroupingCollection Class

For a list of all members of this type, see ColumnGroupingCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the ColumnGroupingCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the ColumnGroupingCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific ColumnGrouping object in the ColumnGroupingCollection by position.
Top
See Also

Reference

ColumnGroupingCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (ColumnGroupingCollection)

Item Property (ColumnGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGroupingCollection Class : Item Property
A zero-based Integer indicating the index of the ColumnGrouping to return or set.
Gets or sets a specific ColumnGrouping object in the ColumnGroupingCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As ColumnGrouping
public ColumnGrouping this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the ColumnGrouping to return or set.

Property Value

The ColumnGrouping object at the specified position.
See Also

Reference

ColumnGroupingCollection Class
ColumnGroupingCollection Members


ConnectionProperties Class

ConnectionProperties Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ConnectionProperties Class
Specifies the information used to connect to a data source.
Object Model
ConnectionProperties Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ConnectionProperties
public class ConnectionProperties
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ConnectionProperties

See Also

Reference

ConnectionProperties Members
GrapeCity.ActiveReports.PageReportModel Namespace


ConnectionProperties Class Members

ConnectionProperties Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ConnectionProperties Class

The following tables list the members exposed by ConnectionProperties.

Public Constructors
 | Name | Description
Public Constructor | ConnectionProperties Constructor | Initializes a new instance of the ConnectionProperties class.
Top
Public Properties
 | Name | Description
Public Property | ConnectString | Gets or sets a connection string to use with the data source.
Public Property | DataProvider | Gets or sets the data source type.
Public Property | IntegratedSecurity | Gets or sets a value indicating whether the data source uses integrated security when connecting.
Public Property | Prompt | Gets or sets a value indicating the prompt that is displayed to the user when requesting credentials for connecting to the database with the specified data source.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the ConnectionProperties object.
Top
See Also

Reference

ConnectionProperties Class
GrapeCity.ActiveReports.PageReportModel Namespace


ConnectionProperties Constructor

ConnectionProperties Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ConnectionProperties Class : ConnectionProperties Constructor
Initializes a new instance of the ConnectionProperties class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ConnectionProperties()
See Also

Reference

ConnectionProperties Class
ConnectionProperties Members


ConnectionProperties Class Methods

ConnectionProperties Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ConnectionProperties Class

For a list of all members of this type, see ConnectionProperties members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the ConnectionProperties object.
Top
See Also

Reference

ConnectionProperties Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (ConnectionProperties)

Validate Method (ConnectionProperties)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ConnectionProperties Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the ConnectionProperties object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

The ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

ConnectionProperties Class
ConnectionProperties Members


ConnectionProperties Class Properties

ConnectionProperties Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ConnectionProperties Class

For a list of all members of this type, see ConnectionProperties members.

Public Properties
 | Name | Description
Public Property | ConnectString | Gets or sets a connection string to use with the data source.
Public Property | DataProvider | Gets or sets the data source type.
Public Property | IntegratedSecurity | Gets or sets a value indicating whether the data source uses integrated security when connecting.
Public Property | Prompt | Gets or sets a value indicating the prompt that is displayed to the user when requesting credentials for connecting to the database with the specified data source.
Top
See Also

Reference

ConnectionProperties Class
GrapeCity.ActiveReports.PageReportModel Namespace


ConnectString Property

ConnectString Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ConnectionProperties Class : ConnectString Property

Gets or sets a connection string to use with the data source.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ConnectString As ExpressionInfo
public ExpressionInfo ConnectString {get; set;}

Property Value

A String indicating the connection string for the data source.

See Also

Reference

ConnectionProperties Class
ConnectionProperties Members


DataProvider Property

DataProvider Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ConnectionProperties Class : DataProvider Property

Gets or sets the data source type.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataProvider As System.String
public System.string DataProvider {get; set;}

Property Value

A String indicating the data source type.

Remarks

The DataProvider value determines the syntax used for the ConnectString and CommandText properties.

The table below contains the set of data source extensions available by default. Custom extensions can be created but RDL consumers take caution when loading reports containing unknown or unsupported extensions.

Extension | Description
SQL | Microsoft SQL Server
OLEDB | Microsoft OLE DB Provider
ODBC | Microsoft Open Database Connectivity Driver
Oracle | Oracle
See Also

Reference

ConnectionProperties Class
ConnectionProperties Members


IntegratedSecurity Property (ConnectionProperties)

IntegratedSecurity Property (ConnectionProperties)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ConnectionProperties Class : IntegratedSecurity Property

Gets or sets a value indicating whether the data source uses integrated security when connecting.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IntegratedSecurity As System.Boolean
public System.bool IntegratedSecurity {get; set;}

Property Value

A Boolean value where true indicates that the data source uses integrated security when connecting; otherwise false. The default value is false.

See Also

Reference

ConnectionProperties Class
ConnectionProperties Members


Prompt Property (ConnectionProperties)

Prompt Property (ConnectionProperties)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ConnectionProperties Class : Prompt Property

Gets or sets a value indicating the prompt that is displayed to the user when requesting credentials for connecting to the database with the specified data source.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Prompt As System.String
public System.string Prompt {get; set;}

Property Value

A String indicating the prompt to show the user when database credentials are needed for the data source.

See Also

Reference

ConnectionProperties Class
ConnectionProperties Members


Container Class

Container Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Container Class
Specifies a rectangle ReportItem contained in the report definition.
Object Model
Container Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Container
   Inherits ShapeBase
   Implements IRdlContainer, IReportComponent, IReportComponentContainer
public sealed class Container : ShapeBase, IRdlContainer, IReportComponent, IReportComponentContainer
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.Container

See Also

Reference

Container Members
GrapeCity.ActiveReports.PageReportModel Namespace


Container Class Members

Container Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Container Class

The following tables list the members exposed by Container.

Public Constructors
 | Name | Description
Public Constructor | Container Constructor | Initializes a new instance of the Container class.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Components | Gets the ReportComponentCollection containing all the components hosted in the control.
Public Property | ConsumeWhiteSpace | Indicates that all white space in container is consumed during report rendering when the container’s contents grow rather than preserving the minimum white space between the contents and the bounds of the container.
Public Property | Container | Gets the IContainer that contains the Container. (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether a page break occurs immediately after the rectangle ends.
Public Property | PageBreakAtStart | Gets or sets a value indicating whether a page break occurs immediately before the rectangle begins.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportItems | Gets a collection of the ReportItem objects hosted in the Rectangle.
Public Property | Site | Gets or sets the ISite of the Container. (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the resources used by the Container. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String containing the name of the Container, if any. This method should not be overridden. (Inherited from System.ComponentModel.Component)
Public Method | Validate | Overridden. Validates the information in each property of the Container object.
Top
Public Events
 | Name | Description
Public Event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Container Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Constructor

Container Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : Container Constructor
Initializes a new instance of the Container class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Container()
See Also

Reference

Container Class
Container Members


Container Class Methods

Container Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Container Class

For a list of all members of this type, see Container members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the resources used by the Container. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String containing the name of the Container, if any. This method should not be overridden. (Inherited from System.ComponentModel.Component)
Public Method | Validate | Overridden. Validates the information in each property of the Container object.
Top
See Also

Reference

Container Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (Container)

Validate Method (Container)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the Container object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

Container Class
Container Members


Container Class Properties

Container Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Container Class

For a list of all members of this type, see Container members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Components | Gets the ReportComponentCollection containing all the components hosted in the control.
Public Property | ConsumeWhiteSpace | Indicates that all white space in container is consumed during report rendering when the container’s contents grow rather than preserving the minimum white space between the contents and the bounds of the container.
Public Property | Container | Gets the IContainer that contains the Container. (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether a page break occurs immediately after the rectangle ends.
Public Property | PageBreakAtStart | Gets or sets a value indicating whether a page break occurs immediately before the rectangle begins.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportItems | Gets a collection of the ReportItem objects hosted in the Rectangle.
Public Property | Site | Gets or sets the ISite of the Container. (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
See Also

Reference

Container Class
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property (Container)

Components Property (Container)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : Components Property
Gets the ReportComponentCollection containing all the components hosted in the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Components As ReportComponentCollection
public ReportComponentCollection Components {get;}

Property Value

A read-only DataDynamics.Reports.ReportObjectModel.Rdl.ReportComponentCollection containing all the components hosted in the control.
See Also

Reference

Container Class
Container Members


ConsumeWhiteSpace Property (Container)

ConsumeWhiteSpace Property (Container)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : ConsumeWhiteSpace Property
Indicates that all white space in container is consumed during report rendering when the container’s contents grow rather than preserving the minimum white space between the contents and the bounds of the container.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ConsumeWhiteSpace As System.Boolean
public System.bool ConsumeWhiteSpace {get; set;}
See Also

Reference

Container Class
Container Members


PageBreakAtEnd Property (Container)

PageBreakAtEnd Property (Container)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : PageBreakAtEnd Property

Gets or sets a value indicating whether a page break occurs immediately after the rectangle ends.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageBreakAtEnd As System.Boolean
public System.bool PageBreakAtEnd {get; set;}

Property Value

A Boolean value where true indicates that a page break occurs immediately after the rectangle ends; otherwise false. The default value is false.

Remarks
Page breaks are ignored if the rectangle contains no report items.
See Also

Reference

Container Class
Container Members


PageBreakAtStart Property (Container)

PageBreakAtStart Property (Container)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : PageBreakAtStart Property

Gets or sets a value indicating whether a page break occurs immediately before the rectangle begins.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageBreakAtStart As System.Boolean
public System.bool PageBreakAtStart {get; set;}

Property Value

A Boolean value where true indicates that a page break occurs immediately before the rectangle begins; otherwise false. The default value is false.

Remarks
Page breaks are ignored if the rectangle contains no report items.
See Also

Reference

Container Class
Container Members


ReportItems Property (Container)

ReportItems Property (Container)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : ReportItems Property
Gets a collection of the ReportItem objects hosted in the Rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ReportItems As ReportItemCollection
public ReportItemCollection ReportItems {get;}

Property Value

A ReportItemCollection containing the ReportItem objects hosted in the Rectangle.

See Also

Reference

Container Class
Container Members


Corner Class

Corner Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Corner Class
The Corner element defines the layout and structure of the upper left-hand corner region of a matrix.
Object Model
Corner Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Corner
   Inherits ReportComponentContainer
   Implements IRdlContainer, IReportComponent, IReportComponentContainer
public sealed class Corner : ReportComponentContainer, IRdlContainer, IReportComponent, IReportComponentContainer
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer
GrapeCity.ActiveReports.PageReportModel.Corner

See Also

Reference

Corner Members
GrapeCity.ActiveReports.PageReportModel Namespace


Corner Class Members

Corner Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Corner Class

The following tables list the members exposed by Corner.

Public Constructors
 | Name | Description
Public Constructor | Corner Constructor | Initializes a new instance of the Corner class.
Top
Public Properties
 | Name | Description
Public Property | Components | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportComponentCollection containing all the ReportComponents in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Container | Gets the IContainer that contains the Corner. (Inherited from System.ComponentModel.Component)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportItems | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportItemCollection containing all the ReportItems in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Site | Gets or sets the ISite of the Corner. (Inherited from System.ComponentModel.Component)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the resources used by the Corner. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String containing the name of the Corner, if any. This method should not be overridden. (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the Corner object.
Top
Public Events
 | Name | Description
Public Event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Corner Class
GrapeCity.ActiveReports.PageReportModel Namespace


Corner Constructor

Corner Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Corner Class : Corner Constructor
Initializes a new instance of the Corner class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Corner()
See Also

Reference

Corner Class
Corner Members


Corner Class Methods

Corner Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Corner Class

For a list of all members of this type, see Corner members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the resources used by the Corner. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String containing the name of the Corner, if any. This method should not be overridden. (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the Corner object.
Top
See Also

Reference

Corner Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (Corner)

Validate Method (Corner)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Corner Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the Corner object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

Corner Class
Corner Members


Custom Class

Custom Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Custom Class
The Custom element allows report design tools to pass information to report output components. This element may contain any valid XML. The engine passes the contents of the Custom object unchanged. Client applications using the Custom element place custom properties under their own single subelement of Custom, defining a namespace for that node.
Object Model
Custom Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Custom
public sealed class Custom
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Custom

See Also

Reference

Custom Members
GrapeCity.ActiveReports.PageReportModel Namespace


Custom Class Members

Custom Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Custom Class

The following tables list the members exposed by Custom.

Public Constructors
 | Name | Description
Public Constructor | Custom Constructor | Initializes a new instance of Custom class.
Top
Public Properties
 | Name | Description
Public Property | InnerXML | Gets or sets a String value representing the Custom XML.
Top
See Also

Reference

Custom Class
GrapeCity.ActiveReports.PageReportModel Namespace


Custom Constructor

Custom Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Custom Class : Custom Constructor
Initializes a new instance of Custom class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Custom()
See Also

Reference

Custom Class
Custom Members


Custom Class Properties

Custom Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Custom Class

For a list of all members of this type, see Custom members.

Public Properties
 | Name | Description
Public Property | InnerXML | Gets or sets a String value representing the Custom XML.
Top
See Also

Reference

Custom Class
GrapeCity.ActiveReports.PageReportModel Namespace


InnerXML Property (Custom)

InnerXML Property (Custom)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Custom Class : InnerXML Property

Gets or sets a String value representing the Custom XML.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property InnerXML As System.String
public System.string InnerXML {get; set;}

Property Value

A String value representing the Custom xml.

See Also

Reference

Custom Class
Custom Members


CustomData Class

CustomData Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomData Class
Defines the data to be handed to an ICustomReportItem interface.
Object Model
CustomData Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class CustomData
public class CustomData
Remarks
This class represents the RDL CustomData element. A custom report item that defines a CustomData element is treated as a data region. This imposes the same restrictions on the custom report item as are imposed on other data regions (i.e. not allowed in detail rows, not allowed in page header/footer sections).
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.CustomData

See Also

Reference

CustomData Members
GrapeCity.ActiveReports.PageReportModel Namespace


CustomData Class Members

CustomData Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomData Class

The following tables list the members exposed by CustomData.

Public Constructors
 | Name | Description
Public Constructor | CustomData Constructor | Initializes a new instance of the CustomData class.
Top
Public Properties
 | Name | Description
Public Property | DataColumnGroupings | A DataGroupingCollection containing the column groupings for the data.
Public Property | DataRowGroupings | A DataGroupingCollection containing the row groupings for the data.
Public Property | DataRows | A DataRowCollection containing the data values to calculate for each detail cell of the data.
Public Property | DataSetName | Indicates which data set to use as the source of data for the custom report item.
Public Property | Filters | A FilterCollection containing the filters to apply to each row of data.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.CustomData object.
Top
See Also

Reference

CustomData Class
GrapeCity.ActiveReports.PageReportModel Namespace


CustomData Constructor

CustomData Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomData Class : CustomData Constructor
Initializes a new instance of the CustomData class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public CustomData()
See Also

Reference

CustomData Class
CustomData Members


CustomData Class Methods

CustomData Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomData Class

For a list of all members of this type, see CustomData members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.CustomData object.
Top
See Also

Reference

CustomData Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (CustomData)

Validate Method (CustomData)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomData Class : Validate Method
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.CustomData object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A DataDynamics.Reports.ReportObjectModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

CustomData Class
CustomData Members


CustomData Class Properties

CustomData Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomData Class

For a list of all members of this type, see CustomData members.

Public Properties
 | Name | Description
Public Property | DataColumnGroupings | A DataGroupingCollection containing the column groupings for the data.
Public Property | DataRowGroupings | A DataGroupingCollection containing the row groupings for the data.
Public Property | DataRows | A DataRowCollection containing the data values to calculate for each detail cell of the data.
Public Property | DataSetName | Indicates which data set to use as the source of data for the custom report item.
Public Property | Filters | A FilterCollection containing the filters to apply to each row of data.
Top
See Also

Reference

CustomData Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataColumnGroupings Property (CustomData)

DataColumnGroupings Property (CustomData)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomData Class : DataColumnGroupings Property
A DataGroupingCollection containing the column groupings for the data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DataColumnGroupings As DataGroupingCollection
public DataGroupingCollection DataColumnGroupings {get;}
See Also

Reference

CustomData Class
CustomData Members


DataRowGroupings Property (CustomData)

DataRowGroupings Property (CustomData)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomData Class : DataRowGroupings Property
A DataGroupingCollection containing the row groupings for the data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DataRowGroupings As DataGroupingCollection
public DataGroupingCollection DataRowGroupings {get;}
See Also

Reference

CustomData Class
CustomData Members


DataRows Property

DataRows Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomData Class : DataRows Property
A DataRowCollection containing the data values to calculate for each detail cell of the data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DataRows As DataRowCollection
public DataRowCollection DataRows {get;}
See Also

Reference

CustomData Class
CustomData Members


DataSetName Property (CustomData)

DataSetName Property (CustomData)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomData Class : DataSetName Property
Indicates which data set to use as the source of data for the custom report item.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataSetName As System.String
public System.string DataSetName {get; set;}
See Also

Reference

CustomData Class
CustomData Members


Filters Property (CustomData)

Filters Property (CustomData)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomData Class : Filters Property
A FilterCollection containing the filters to apply to each row of data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Filters As System.Collections.Generic.IList(Of Filter)
public System.Collections.Generic.IList<Filter> Filters {get;}
See Also

Reference

CustomData Class
CustomData Members


CustomPropertyDefinition Class

CustomPropertyDefinition Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomPropertyDefinition Class
Represents a CustomProperty element from RDL. When processing the ReportObjectModel, if the ExpressionInfo object contains any aggregate functions that do not specify the scope, the scope is updated with the current scope.
Object Model
CustomPropertyDefinition Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class CustomPropertyDefinition
public class CustomPropertyDefinition
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.CustomPropertyDefinition

Requirements

See Also

Reference

CustomPropertyDefinition Members
GrapeCity.ActiveReports.PageReportModel Namespace


CustomPropertyDefinition Class Members

CustomPropertyDefinition Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomPropertyDefinition Class

The following tables list the members exposed by CustomPropertyDefinition.

Public Constructors
 | Name | Description
Public Constructor | CustomPropertyDefinition Constructor | Initializes a new instance of the CustomPropertyDefinition class.
Top
Public Properties
 | Name | Description
Public Property | Name | The name of the custom property.
Public Property | Value | The value of the custom property.
Top
See Also

Reference

CustomPropertyDefinition Class
GrapeCity.ActiveReports.PageReportModel Namespace


CustomPropertyDefinition Constructor

CustomPropertyDefinition Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPropertyDefinition Class : CustomPropertyDefinition Constructor
A string containing the name of the custom property.
An GrapeCity.ActiveReports.Expressions.ExpressionInfo object containing the value or the expression and data type to assign to the custom property.
Initializes a new instance of the CustomPropertyDefinition class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As System.String, _
   ByVal value As ExpressionInfo _
)
public CustomPropertyDefinition(
   System.string name,
   ExpressionInfo value
)

Parameters

name
A string containing the name of the custom property.
value
An GrapeCity.ActiveReports.Expressions.ExpressionInfo object containing the value or the expression and data type to assign to the custom property.
See Also

Reference

CustomPropertyDefinition Class
CustomPropertyDefinition Members


CustomPropertyDefinition Class Properties

CustomPropertyDefinition Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomPropertyDefinition Class

For a list of all members of this type, see CustomPropertyDefinition members.

Public Properties
 | Name | Description
Public Property | Name | The name of the custom property.
Public Property | Value | The value of the custom property.
Top
See Also

Reference

CustomPropertyDefinition Class
GrapeCity.ActiveReports.PageReportModel Namespace


Name Property (CustomPropertyDefinition)

Name Property (CustomPropertyDefinition)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPropertyDefinition Class : Name Property
The name of the custom property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}
See Also

Reference

CustomPropertyDefinition Class
CustomPropertyDefinition Members


Value Property (CustomPropertyDefinition)

Value Property (CustomPropertyDefinition)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPropertyDefinition Class : Value Property
The value of the custom property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As ExpressionInfo
public ExpressionInfo Value {get; set;}
Remarks
The Value can be in the form of an expression.
See Also

Reference

CustomPropertyDefinition Class
CustomPropertyDefinition Members


CustomPropertyDefinitionCollection Class

CustomPropertyDefinitionCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomPropertyDefinitionCollection Class
Provides a strongly typed collection for CustomPropertyDefinition objects.
Object Model
CustomPropertyDefinitionCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class CustomPropertyDefinitionCollection
   Inherits System.Collections.CollectionBase
public class CustomPropertyDefinitionCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.CustomPropertyDefinitionCollection

See Also

Reference

CustomPropertyDefinitionCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


CustomPropertyDefinitionCollection Class Members

CustomPropertyDefinitionCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomPropertyDefinitionCollection Class

The following tables list the members exposed by CustomPropertyDefinitionCollection.

Public Constructors
 | Name | Description
Public Constructor | CustomPropertyDefinitionCollection Constructor | Initializes a new instance of the CustomPropertyDefinitionCollection class.
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Gets or sets the element at the specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an object to the collection.
Public Method | AddRange | Adds the range of object to the collection.
Public Method | Clear | Removes all objects from the CustomPropertyDefinitionCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Searches for the specified value and returns the zero-based index of the first occurrence within the collection.
Public Method | Remove | Removes the first occurrence of a specific object from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the CustomPropertyDefinitionCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

CustomPropertyDefinitionCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


CustomPropertyDefinitionCollection Constructor

CustomPropertyDefinitionCollection Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPropertyDefinitionCollection Class : CustomPropertyDefinitionCollection Constructor
Initializes a new instance of the CustomPropertyDefinitionCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public CustomPropertyDefinitionCollection()
See Also

Reference

CustomPropertyDefinitionCollection Class
CustomPropertyDefinitionCollection Members


CustomPropertyDefinitionCollection Class Methods

CustomPropertyDefinitionCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomPropertyDefinitionCollection Class

For a list of all members of this type, see CustomPropertyDefinitionCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an object to the collection.
Public Method | AddRange | Adds the range of object to the collection.
Public Method | Clear | Removes all objects from the CustomPropertyDefinitionCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Searches for the specified value and returns the zero-based index of the first occurrence within the collection.
Public Method | Remove | Removes the first occurrence of a specific object from the collection.
Public Method | RemoveAt | Removes the element at the specified index of the CustomPropertyDefinitionCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

CustomPropertyDefinitionCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (CustomPropertyDefinitionCollection)

Add Method (CustomPropertyDefinitionCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPropertyDefinitionCollection Class : Add Method
The CustomPropertyDefinition object to add.
Adds an object to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As CustomPropertyDefinition _
) As System.Integer
public System.int Add(
   CustomPropertyDefinition value
)

Parameters

value
The CustomPropertyDefinition object to add.
See Also

Reference

CustomPropertyDefinitionCollection Class
CustomPropertyDefinitionCollection Members


AddRange Method (CustomPropertyDefinitionCollection)

AddRange Method (CustomPropertyDefinitionCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPropertyDefinitionCollection Class : AddRange Method
The collection to add in the current collection.
Adds the range of object to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddRange( _
   ByVal collection As CustomPropertyDefinitionCollection _
)
public void AddRange(
   CustomPropertyDefinitionCollection collection
)

Parameters

collection
The collection to add in the current collection.
See Also

Reference

CustomPropertyDefinitionCollection Class
CustomPropertyDefinitionCollection Members


IndexOf Method (CustomPropertyDefinitionCollection)

IndexOf Method (CustomPropertyDefinitionCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPropertyDefinitionCollection Class : IndexOf Method
The CustomPropertyDefinition value to look up in the collection.
Searches for the specified value and returns the zero-based index of the first occurrence within the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As CustomPropertyDefinition _
) As System.Integer
public System.int IndexOf(
   CustomPropertyDefinition value
)

Parameters

value
The CustomPropertyDefinition value to look up in the collection.

Return Value

The zero-based index of the first occurrence of the value within the collection, if found; otherwise, -1.
See Also

Reference

CustomPropertyDefinitionCollection Class
CustomPropertyDefinitionCollection Members


Remove Method (CustomPropertyDefinitionCollection)

Remove Method (CustomPropertyDefinitionCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPropertyDefinitionCollection Class : Remove Method
The CustomPropertyDefinition to remove.
Removes the first occurrence of a specific object from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As CustomPropertyDefinition _
)
public void Remove(
   CustomPropertyDefinition value
)

Parameters

value
The CustomPropertyDefinition to remove.
See Also

Reference

CustomPropertyDefinitionCollection Class
CustomPropertyDefinitionCollection Members


CustomPropertyDefinitionCollection Class Properties

CustomPropertyDefinitionCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomPropertyDefinitionCollection Class

For a list of all members of this type, see CustomPropertyDefinitionCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Gets or sets the element at the specified index.
Top
See Also

Reference

CustomPropertyDefinitionCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (CustomPropertyDefinitionCollection)

Item Property (CustomPropertyDefinitionCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPropertyDefinitionCollection Class : Item Property
Gets or sets the element at the specified index.
Overload List
Overload | Description
Item(Int32) | Gets or sets the element at the specified index.
Item(String) | Gets the element with the specified name or null if no element has the specified name value.
See Also

Reference

CustomPropertyDefinitionCollection Class
CustomPropertyDefinitionCollection Members


Item(Int32) Property

Item(Int32) Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPropertyDefinitionCollection Class > Item Property : Item(Int32) Property
The index of the CustomPropertyDefinition to get or set.
Gets or sets the element at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Property Item( _
   ByVal index As System.Integer _
) As CustomPropertyDefinition
public CustomPropertyDefinition Item(
   System.int index
) {get; set;}

Parameters

index
The index of the CustomPropertyDefinition to get or set.
See Also

Reference

CustomPropertyDefinitionCollection Class
CustomPropertyDefinitionCollection Members
Overload List


Item(String) Property

Item(String) Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPropertyDefinitionCollection Class > Item Property : Item(String) Property
The name of the CustomPropertyDefinition to get or set.
Gets the element with the specified name or null if no element has the specified name value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal name As System.String _
) As CustomPropertyDefinition
public CustomPropertyDefinition Item(
   System.string name
) {get;}

Parameters

name
The name of the CustomPropertyDefinition to get or set.
See Also

Reference

CustomPropertyDefinitionCollection Class
CustomPropertyDefinitionCollection Members
Overload List


CustomReportItem Class

CustomReportItem Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomReportItem Class
Represents an IReportItem not defined within the RDL specification. The custom report item's information is stored inside the CustomReportItem element under a namespace for the tool or server supporting the type. If the custom report item is not recognized it is treated as an IRectangle.
Object Model
CustomReportItem Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class CustomReportItem
   Inherits ReportItem
   Implements IRdlContainer, IReportComponent, IReportComponentContainer, IScopeDefinition
public sealed class CustomReportItem : ReportItem, IRdlContainer, IReportComponent, IReportComponentContainer, IScopeDefinition
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.CustomReportItem

See Also

Reference

CustomReportItem Members
GrapeCity.ActiveReports.PageReportModel Namespace


CustomReportItem Class Members

CustomReportItem Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomReportItem Class

The following tables list the members exposed by CustomReportItem.

Public Constructors
 | Name | Description
Public Constructor | CustomReportItem Constructor | Initializes a new instance of the CustomReportItem class.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | AltReportItem | Gets or sets the alternative report item to use in the event that the custom report item cannot be used.
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Container | Gets the IContainer that contains the CustomReportItem. (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | CustomData | Gets or sets the custom data settings used by the custom report item
Public Property | CustomProperties | Gets a collection of custom property elements for the custom report item.
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | InnerXml | Gets or sets the XML representation of the custom report item. This contains all of the XML content inside the CustomReportItem element.
Public Property | IsDataRegion | Gets a value indicating whether the custom report item is a data region.
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportItems | Implements IRdlContainer.ReportItems.
Public Property | Site | Gets or sets the ISite of the CustomReportItem. (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Type | Gets or sets a custom report item's type which is interpreted by the report server or designer tool.
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the resources used by the CustomReportItem. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String containing the name of the CustomReportItem, if any. This method should not be overridden. (Inherited from System.ComponentModel.Component)
Public Method | Validate | Overridden. Validates the information in each property of the CustomReportItem.
Top
Public Events
 | Name | Description
Public Event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

CustomReportItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


CustomReportItem Constructor

CustomReportItem Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : CustomReportItem Constructor
Initializes a new instance of the CustomReportItem class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public CustomReportItem()
See Also

Reference

CustomReportItem Class
CustomReportItem Members


CustomReportItem Class Methods

CustomReportItem Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomReportItem Class

For a list of all members of this type, see CustomReportItem members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the resources used by the CustomReportItem. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | Returns a String containing the name of the CustomReportItem, if any. This method should not be overridden. (Inherited from System.ComponentModel.Component)
Public Method | Validate | Overridden. Validates the information in each property of the CustomReportItem.
Top
See Also

Reference

CustomReportItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (CustomReportItem)

Validate Method (CustomReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the CustomReportItem.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

CustomReportItem Class
CustomReportItem Members


CustomReportItem Class Properties

CustomReportItem Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomReportItem Class

For a list of all members of this type, see CustomReportItem members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | AltReportItem | Gets or sets the alternative report item to use in the event that the custom report item cannot be used.
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Container | Gets the IContainer that contains the CustomReportItem. (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | CustomData | Gets or sets the custom data settings used by the custom report item
Public Property | CustomProperties | Gets a collection of custom property elements for the custom report item.
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | InnerXml | Gets or sets the XML representation of the custom report item. This contains all of the XML content inside the CustomReportItem element.
Public Property | IsDataRegion | Gets a value indicating whether the custom report item is a data region.
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportItems | Implements IRdlContainer.ReportItems.
Public Property | Site | Gets or sets the ISite of the CustomReportItem. (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Type | Gets or sets a custom report item's type which is interpreted by the report server or designer tool.
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
See Also

Reference

CustomReportItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


AltReportItem Property

AltReportItem Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : AltReportItem Property

Gets or sets the alternative report item to use in the event that the custom report item cannot be used.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AltReportItem As ReportItem
public ReportItem AltReportItem {get; set;}

Property Value

A ReportItem object indicating the alternative report control to use in the event that the custom report control cannot be used.
See Also

Reference

CustomReportItem Class
CustomReportItem Members


CustomData Property (CustomReportItem)

CustomData Property (CustomReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : CustomData Property

Gets or sets the custom data settings used by the custom report item

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CustomData As CustomData
public CustomData CustomData {get; set;}

Property Value

A CustomData object containing the custom report item's custom data settings, or null if no custom data has been defined.
See Also

Reference

CustomReportItem Class
CustomReportItem Members


CustomProperties Property (CustomReportItem)

CustomProperties Property (CustomReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : CustomProperties Property

Gets a collection of custom property elements for the custom report item.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CustomProperties As CustomPropertyDefinitionCollection
public CustomPropertyDefinitionCollection CustomProperties {get;}

Property Value

A CustomPropertyDefinitionCollection containing the custom report item's custom properties.
See Also

Reference

CustomReportItem Class
CustomReportItem Members


InnerXml Property (CustomReportItem)

InnerXml Property (CustomReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : InnerXml Property

Gets or sets the XML representation of the custom report item. This contains all of the XML content inside the CustomReportItem element.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property InnerXml As System.String
public System.string InnerXml {get; set;}

Property Value

A String containing XML information representing the custom report item.

See Also

Reference

CustomReportItem Class
CustomReportItem Members


IsDataRegion Property

IsDataRegion Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : IsDataRegion Property

Gets a value indicating whether the custom report item is a data region.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsDataRegion As System.Boolean
public System.bool IsDataRegion {get;}

Property Value

A Boolean value where true indicates that the custom report control is a DataRegion; false. The default value is false.
See Also

Reference

CustomReportItem Class
CustomReportItem Members


ReportItems Property (CustomReportItem)

ReportItems Property (CustomReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : ReportItems Property
Implements IRdlContainer.ReportItems.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ReportItems As ReportItemCollection
public ReportItemCollection ReportItems {get;}
Remarks
Allows a CustomReportItem to implement a composite ReportItem. The serialization to the ReportDefinition of any contained ReportItems must be implemented using custom syntax specific to the derived ReportItem implementation. A Custom Designer for the derived implementation may be useful in that case.
See Also

Reference

CustomReportItem Class
CustomReportItem Members


Type Property (CustomReportItem)

Type Property (CustomReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : Type Property

Gets or sets a custom report item's type which is interpreted by the report server or designer tool.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Type As System.String
public System.string Type {get; set;}

Property Value

A String indicating the custom report item's type.

See Also

Reference

CustomReportItem Class
CustomReportItem Members


DataCellCollection Class

DataCellCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataCellCollection Class
Provides a strongly typed collection for DataCell objects.
Object Model
DataCellCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DataCellCollection
   Inherits System.Collections.CollectionBase
public class DataCellCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DataCellCollection

See Also

Reference

DataCellCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataCellCollection Class Members

DataCellCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataCellCollection Class

The following tables list the members exposed by DataCellCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the DataCellCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the DataCellCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific DataCell object in the DataCellCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a DataCell object to the DataCellCollection.
Public Method | Clear | Removes all objects from the DataCellCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific DataCell object in the DataCellCollection.
Public Method | Remove | Removes the specified DataCell object from the DataCellCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

DataCellCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataCellCollection Class Methods

DataCellCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataCellCollection Class

For a list of all members of this type, see DataCellCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a DataCell object to the DataCellCollection.
Public Method | Clear | Removes all objects from the DataCellCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific DataCell object in the DataCellCollection.
Public Method | Remove | Removes the specified DataCell object from the DataCellCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

DataCellCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (DataCellCollection)

Add Method (DataCellCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataCellCollection Class : Add Method
The DataCell object to add to the collection.
Adds a DataCell object to the DataCellCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As DataCell _
) As System.Integer
public System.int Add(
   DataCell value
)

Parameters

value
The DataCell object to add to the collection.

Return Value

A new DataCell object.
See Also

Reference

DataCellCollection Class
DataCellCollection Members


IndexOf Method (DataCellCollection)

IndexOf Method (DataCellCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataCellCollection Class : IndexOf Method
The DataCell object to locate in the DataCellCollection.
Determines the index of a specific DataCell object in the DataCellCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As DataCell _
) As System.Integer
public System.int IndexOf(
   DataCell value
)

Parameters

value
The DataCell object to locate in the DataCellCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

DataCellCollection Class
DataCellCollection Members


Remove Method (DataCellCollection)

Remove Method (DataCellCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataCellCollection Class : Remove Method
The DataCell object to remove.
Removes the specified DataCell object from the DataCellCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As DataCell _
)
public void Remove(
   DataCell value
)

Parameters

value
The DataCell object to remove.
See Also

Reference

DataCellCollection Class
DataCellCollection Members


DataCellCollection Class Properties

DataCellCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataCellCollection Class

For a list of all members of this type, see DataCellCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the DataCellCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the DataCellCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific DataCell object in the DataCellCollection by position.
Top
See Also

Reference

DataCellCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (DataCellCollection)

Item Property (DataCellCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataCellCollection Class : Item Property
A zero-based Integer indicating the index of the DataCell object to return or set.
Gets or sets a specific DataCell object in the DataCellCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As DataCell
public DataCell this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the DataCell object to return or set.

Property Value

The DataCell object at the specified position.
See Also

Reference

DataCellCollection Class
DataCellCollection Members


DataGrouping Class

DataGrouping Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataGrouping Class
Describes how to group and sort data.
Object Model
DataGrouping Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DataGrouping
   Implements IScopeDefinition
public class DataGrouping : IScopeDefinition
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DataGrouping

See Also

Reference

DataGrouping Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataGrouping Class Members

DataGrouping Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataGrouping Class

The following tables list the members exposed by DataGrouping.

Public Constructors
 | Name | Description
Public Constructor | DataGrouping Constructor | Initializes a new instance of the DataGrouping class.
Top
Public Properties
 | Name | Description
Public Property | CustomProperties | Specifies custom properties for a report item.
Public Property | DataGroupings | Specifies the subgroupings contained within the current group.
Public Property | Grouping | The expressions by which to group the data.
Public Property | ReportItems | Gets the collection of the report items in this grouping.
Public Property | Sorting | Specifies how to sort the group instances.
Public Property | Static | Gets or sets a value indicating if this is a static grouping.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataGrouping object.
Top
See Also

Reference

DataGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataGrouping Constructor

DataGrouping Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGrouping Class : DataGrouping Constructor
Initializes a new instance of the DataGrouping class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DataGrouping()
See Also

Reference

DataGrouping Class
DataGrouping Members


DataGrouping Class Methods

DataGrouping Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataGrouping Class

For a list of all members of this type, see DataGrouping members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataGrouping object.
Top
See Also

Reference

DataGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (DataGrouping)

Validate Method (DataGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGrouping Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataGrouping object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

DataGrouping Class
DataGrouping Members


DataGrouping Class Properties

DataGrouping Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataGrouping Class

For a list of all members of this type, see DataGrouping members.

Public Properties
 | Name | Description
Public Property | CustomProperties | Specifies custom properties for a report item.
Public Property | DataGroupings | Specifies the subgroupings contained within the current group.
Public Property | Grouping | The expressions by which to group the data.
Public Property | ReportItems | Gets the collection of the report items in this grouping.
Public Property | Sorting | Specifies how to sort the group instances.
Public Property | Static | Gets or sets a value indicating if this is a static grouping.
Top
See Also

Reference

DataGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


CustomProperties Property (DataGrouping)

CustomProperties Property (DataGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGrouping Class : CustomProperties Property
Specifies custom properties for a report item.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CustomProperties As CustomPropertyDefinitionCollection
public CustomPropertyDefinitionCollection CustomProperties {get;}
Remarks
Custom properties from RDL or intrinsic RI properties. This is useful for external custom report item implementations.
See Also

Reference

DataGrouping Class
DataGrouping Members


DataGroupings Property

DataGroupings Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGrouping Class : DataGroupings Property
Specifies the subgroupings contained within the current group.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DataGroupings As DataGroupingCollection
public DataGroupingCollection DataGroupings {get;}
Remarks
If there are no subgroupings in the current collection, the current grouping is the inner-most grouping.
See Also

Reference

DataGrouping Class
DataGrouping Members


Grouping Property (DataGrouping)

Grouping Property (DataGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGrouping Class : Grouping Property
The expressions by which to group the data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Grouping As Grouping
public Grouping Grouping {get; set;}
Remarks
If Grouping is null or the GroupExpressions property is empty and there are no SubGroupings, it indicates that this is a detail grouping which is repeated for every detail record.

However, if Grouping is null or the GroupExpressions property is empty and there are SubGroupings, it indicates that this grouping has a single instance which contains all records and all SubGrouping instances and is not repeated for each record).

See Also

Reference

DataGrouping Class
DataGrouping Members


ReportItems Property (DataGrouping)

ReportItems Property (DataGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGrouping Class : ReportItems Property
Gets the collection of the report items in this grouping.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ReportItems As ReportItemCollection
public ReportItemCollection ReportItems {get;}
See Also

Reference

DataGrouping Class
DataGrouping Members


Sorting Property (DataGrouping)

Sorting Property (DataGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGrouping Class : Sorting Property
Specifies how to sort the group instances.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Sorting As SortByCollection
public SortByCollection Sorting {get;}
See Also

Reference

DataGrouping Class
DataGrouping Members


Static Property

Static Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGrouping Class : Static Property
Gets or sets a value indicating if this is a static grouping.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Static As System.Boolean
public System.bool Static {get; set;}
Remarks

Must be true if any ancestor grouping is a detail grouping.

See Also

Reference

DataGrouping Class
DataGrouping Members


DataGroupingCollection Class

DataGroupingCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataGroupingCollection Class
Provides a strongly typed collection for DataGrouping objects.
Object Model
DataGroupingCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DataGroupingCollection
   Inherits System.Collections.CollectionBase
public sealed class DataGroupingCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DataGroupingCollection

See Also

Reference

DataGroupingCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataGroupingCollection Class Members

DataGroupingCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataGroupingCollection Class

The following tables list the members exposed by DataGroupingCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the DataGroupingCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the DataGroupingCollection instance. This property cannot be overridden.` (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the element at the specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a DataGrouping object to the DataGroupingCollection collection.
Public Method | AddRange | Adds the elements of the specified DataGroupingCollection to the current DataGroupingCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Remove | Removes the first occurrence of a specific DataGrouping object from the DataGroupingCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataGroupingCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

DataGroupingCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataGroupingCollection Class Methods

DataGroupingCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataGroupingCollection Class

For a list of all members of this type, see DataGroupingCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a DataGrouping object to the DataGroupingCollection collection.
Public Method | AddRange | Adds the elements of the specified DataGroupingCollection to the current DataGroupingCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Remove | Removes the first occurrence of a specific DataGrouping object from the DataGroupingCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataGroupingCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

DataGroupingCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (DataGroupingCollection)

Add Method (DataGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGroupingCollection Class : Add Method
The DataGrouping object to add.
Adds a DataGrouping object to the DataGroupingCollection collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As DataGrouping _
) As System.Integer
public System.int Add(
   DataGrouping value
)

Parameters

value
The DataGrouping object to add.
See Also

Reference

DataGroupingCollection Class
DataGroupingCollection Members


AddRange Method (DataGroupingCollection)

AddRange Method (DataGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGroupingCollection Class : AddRange Method
The DataGroupingCollection from which to add elements.
Adds the elements of the specified DataGroupingCollection to the current DataGroupingCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddRange( _
   ByVal collection As DataGroupingCollection _
)
public void AddRange(
   DataGroupingCollection collection
)

Parameters

collection
The DataGroupingCollection from which to add elements.
See Also

Reference

DataGroupingCollection Class
DataGroupingCollection Members


Remove Method (DataGroupingCollection)

Remove Method (DataGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGroupingCollection Class : Remove Method
The DataGrouping object to remove.
Removes the first occurrence of a specific DataGrouping object from the DataGroupingCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As DataGrouping _
)
public void Remove(
   DataGrouping value
)

Parameters

value
The DataGrouping object to remove.
See Also

Reference

DataGroupingCollection Class
DataGroupingCollection Members


DataGroupingCollection Class Properties

DataGroupingCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataGroupingCollection Class

For a list of all members of this type, see DataGroupingCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the DataGroupingCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the DataGroupingCollection instance. This property cannot be overridden.` (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the element at the specified index.
Top
See Also

Reference

DataGroupingCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (DataGroupingCollection)

Item Property (DataGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGroupingCollection Class : Item Property
The index of the DataGrouping to get or set.
Gets or sets the element at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As DataGrouping
public DataGrouping this[
   System.int index
]; {get; set;}

Parameters

index
The index of the DataGrouping to get or set.
See Also

Reference

DataGroupingCollection Class
DataGroupingCollection Members


DataLabel Class

DataLabel Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataLabel Class
The DataLabel element defines the data labels to display on the data values in the chart.
Object Model
DataLabel Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DataLabel
public sealed class DataLabel
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DataLabel

See Also

Reference

DataLabel Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataLabel Class Members

DataLabel Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataLabel Class

The following tables list the members exposed by DataLabel.

Public Constructors
 | Name | Description
Public Constructor | DataLabel Constructor | Initializes a new instance of the DataLabel class.
Top
Public Properties
 | Name | Description
Public Property | Position | Gets or sets the position of the label.
Public Property | Rotation | Gets or sets the angle of rotation of the label text.
Public Property | Style | Gets or sets the text, border and background style properties for the labels.
Public Property | Value | Gets or sets the expression to use for the value labels.
Public Property | Visible | Gets or sets a value indicating whether the data label is displayed on the chart.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataLabel object.
Top
See Also

Reference

DataLabel Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataLabel Constructor

DataLabel Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataLabel Class : DataLabel Constructor
Initializes a new instance of the DataLabel class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DataLabel()
See Also

Reference

DataLabel Class
DataLabel Members


DataLabel Class Methods

DataLabel Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataLabel Class

For a list of all members of this type, see DataLabel members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataLabel object.
Top
See Also

Reference

DataLabel Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (DataLabel)

Validate Method (DataLabel)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataLabel Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataLabel object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

DataLabel Class
DataLabel Members


DataLabel Class Properties

DataLabel Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataLabel Class

For a list of all members of this type, see DataLabel members.

Public Properties
 | Name | Description
Public Property | Position | Gets or sets the position of the label.
Public Property | Rotation | Gets or sets the angle of rotation of the label text.
Public Property | Style | Gets or sets the text, border and background style properties for the labels.
Public Property | Value | Gets or sets the expression to use for the value labels.
Public Property | Visible | Gets or sets a value indicating whether the data label is displayed on the chart.
Top
See Also

Reference

DataLabel Class
GrapeCity.ActiveReports.PageReportModel Namespace


Position Property (DataLabel)

Position Property (DataLabel)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataLabel Class : Position Property

Gets or sets the position of the label.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Position As Position
public Position Position {get; set;}

Property Value

A Position enumeration indicating the position of the label.
See Also

Reference

DataLabel Class
DataLabel Members


Rotation Property (DataLabel)

Rotation Property (DataLabel)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataLabel Class : Rotation Property

Gets or sets the angle of rotation of the label text.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Rotation As System.Nullable(Of Integer)
public System.Nullable<int> Rotation {get; set;}

Property Value

A NullableInt32 value indicating the angle of rotation of the label text.

See Also

Reference

DataLabel Class
DataLabel Members


Style Property (DataLabel)

Style Property (DataLabel)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataLabel Class : Style Property

Gets or sets the text, border and background style properties for the labels.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As Style
public Style Style {get; set;}

Property Value

A Style object indicating the text, border and background style properties for the labels.
See Also

Reference

DataLabel Class
DataLabel Members


Value Property (DataLabel)

Value Property (DataLabel)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataLabel Class : Value Property
Gets or sets the expression to use for the value labels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As ExpressionInfo
public ExpressionInfo Value {get; set;}

Property Value

An ExpressionInfo object containing the expression for the value labels.
Remarks

If omitted, values in the ValueCategoryAxis object are used instead.

See Also

Reference

DataLabel Class
DataLabel Members


Visible Property (DataLabel)

Visible Property (DataLabel)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataLabel Class : Visible Property

Gets or sets a value indicating whether the data label is displayed on the chart.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}

Property Value

A Boolean value where true indicates that the data label is displayed on the chart; otherwise false. The default value is false.

See Also

Reference

DataLabel Class
DataLabel Members


DataPoint Class

DataPoint Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataPoint Class
The DataPoint element defines a set of data for a single point in the chart. There must be a corresponding DataPoint for each static category in a static series. A DataPoint may consist of a single value expression (for example in a bar or line chart) or multiple value expressions (for example in a stock or bubble chart).
Object Model
DataPoint Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DataPoint
public sealed class DataPoint
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DataPoint

See Also

Reference

DataPoint Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataPoint Class Members

DataPoint Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataPoint Class

The following tables list the members exposed by DataPoint.

Public Constructors
 | Name | Description
Public Constructor | DataPoint Constructor | Initializes a new instance of the DataPoint class.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets the action to execute.
Public Property | DataElementName | Gets or sets the name to use for the data element for the data point.
Public Property | DataElementOutput | Gets or sets a value defining how or whether a data point appears in a data rendering.
Public Property | DataLabel | Gets or sets the data label with which to mark the value.
Public Property | DataValues | Gets the data value set for the Y axis.
Public Property | Marker | Gets or sets the marker properties.
Public Property | ShowBeginEndMarkersOnly | Indicates if only the first and last markers are shown for the data point; otherwise all markers are shown.
Public Property | Style | Gets or sets the border and background style properties for the data point.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataPoint object.
Top
See Also

Reference

DataPoint Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataPoint Constructor

DataPoint Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPoint Class : DataPoint Constructor
Initializes a new instance of the DataPoint class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DataPoint()
See Also

Reference

DataPoint Class
DataPoint Members


DataPoint Class Methods

DataPoint Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataPoint Class

For a list of all members of this type, see DataPoint members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataPoint object.
Top
See Also

Reference

DataPoint Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (DataPoint)

Validate Method (DataPoint)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPoint Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataPoint object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

DataPoint Class
DataPoint Members


DataPoint Class Properties

DataPoint Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataPoint Class

For a list of all members of this type, see DataPoint members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets the action to execute.
Public Property | DataElementName | Gets or sets the name to use for the data element for the data point.
Public Property | DataElementOutput | Gets or sets a value defining how or whether a data point appears in a data rendering.
Public Property | DataLabel | Gets or sets the data label with which to mark the value.
Public Property | DataValues | Gets the data value set for the Y axis.
Public Property | Marker | Gets or sets the marker properties.
Public Property | ShowBeginEndMarkersOnly | Indicates if only the first and last markers are shown for the data point; otherwise all markers are shown.
Public Property | Style | Gets or sets the border and background style properties for the data point.
Top
See Also

Reference

DataPoint Class
GrapeCity.ActiveReports.PageReportModel Namespace


Action Property (DataPoint)

Action Property (DataPoint)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPoint Class : Action Property

Gets or sets the action to execute.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Action As Action
public Action Action {get; set;}

Property Value

An Action indicating the action to execute.
See Also

Reference

DataPoint Class
DataPoint Members


DataElementName Property (DataPoint)

DataElementName Property (DataPoint)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPoint Class : DataElementName Property

Gets or sets the name to use for the data element for the data point.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataElementName As System.String
public System.string DataElementName {get; set;}

Property Value

A String indicating the name to use for the data element for the data point.

Remarks
The default value is the name of the corresponding static series or category. If there is no static series or category, "Value."
See Also

Reference

DataPoint Class
DataPoint Members


DataElementOutput Property (DataPoint)

DataElementOutput Property (DataPoint)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPoint Class : DataElementOutput Property

Gets or sets a value defining how or whether a data point appears in a data rendering.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataElementOutput As DataElementOutput
public DataElementOutput DataElementOutput {get; set;}

Property Value

A DataElementOutput enumeration defining how or whether a data point appears in a data rendering.
Remarks

Output(Default) indicates that the DataPoints appear in the output.

NoOutput indicates that the DataPoints do not appear in the output.

See DataElementOutput for other enumerated values.

See Also

Reference

DataPoint Class
DataPoint Members


DataLabel Property (DataPoint)

DataLabel Property (DataPoint)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPoint Class : DataLabel Property

Gets or sets the data label with which to mark the value.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataLabel As DataLabel
public DataLabel DataLabel {get; set;}

Property Value

A DataLabel object indicating that the values are marked with data labels.
See Also

Reference

DataPoint Class
DataPoint Members


DataValues Property (DataPoint)

DataValues Property (DataPoint)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPoint Class : DataValues Property

Gets the data value set for the Y axis.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DataValues As DataValueCollection
public DataValueCollection DataValues {get;}

Property Value

A DataValueCollection object containing the data value set for the Y axis.
See Also

Reference

DataPoint Class
DataPoint Members


Marker Property (DataPoint)

Marker Property (DataPoint)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPoint Class : Marker Property

Gets or sets the marker properties.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Marker As Marker
public Marker Marker {get; set;}

Property Value

A Marker object containing the marker properties.
Remarks
Markers do not apply to data points of pie, doughnut, or stacked chart types.
See Also

Reference

DataPoint Class
DataPoint Members


ShowBeginEndMarkersOnly Property (DataPoint)

ShowBeginEndMarkersOnly Property (DataPoint)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPoint Class : ShowBeginEndMarkersOnly Property
Indicates if only the first and last markers are shown for the data point; otherwise all markers are shown.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShowBeginEndMarkersOnly As System.Boolean
public System.bool ShowBeginEndMarkersOnly {get; set;}
See Also

Reference

DataPoint Class
DataPoint Members


Style Property (DataPoint)

Style Property (DataPoint)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPoint Class : Style Property

Gets or sets the border and background style properties for the data point.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As Style
public Style Style {get; set;}

Property Value

A Style object containing the border and background style properties for the data point.
See Also

Reference

DataPoint Class
DataPoint Members


DataPointCollection Class

DataPointCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataPointCollection Class
Provides a strongly typed collection for DataPoint objects.
Object Model
DataPointCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DataPointCollection
   Inherits System.Collections.CollectionBase
public sealed class DataPointCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DataPointCollection

See Also

Reference

DataPointCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataPointCollection Class Members

DataPointCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataPointCollection Class

The following tables list the members exposed by DataPointCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the DataPointCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the DataPointCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific DataPoint object in the DataPointCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a DataPoint object to the DataPointCollection.
Public Method | Clear | Removes all objects from the DataPointCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific DataPoint object in the DataPointCollection.
Public Method | Insert | Inserts a new DataPoint object into the DataPointCollection at the specified location.
Public Method | Remove | Removes the specified DataPoint object from the DataPointCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataPointCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

DataPointCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataPointCollection Class Methods

DataPointCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataPointCollection Class

For a list of all members of this type, see DataPointCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a DataPoint object to the DataPointCollection.
Public Method | Clear | Removes all objects from the DataPointCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific DataPoint object in the DataPointCollection.
Public Method | Insert | Inserts a new DataPoint object into the DataPointCollection at the specified location.
Public Method | Remove | Removes the specified DataPoint object from the DataPointCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataPointCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

DataPointCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (DataPointCollection)

Add Method (DataPointCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPointCollection Class : Add Method
The DataPoint object to add to the collection.
Adds a DataPoint object to the DataPointCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As DataPoint _
) As System.Integer
public System.int Add(
   DataPoint value
)

Parameters

value
The DataPoint object to add to the collection.

Return Value

A new DataPoint object.
See Also

Reference

DataPointCollection Class
DataPointCollection Members


IndexOf Method (DataPointCollection)

IndexOf Method (DataPointCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPointCollection Class : IndexOf Method
The DataPoint object to locate in the DataPointCollection.
Determines the index of a specific DataPoint object in the DataPointCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As DataPoint _
) As System.Integer
public System.int IndexOf(
   DataPoint value
)

Parameters

value
The DataPoint object to locate in the DataPointCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

DataPointCollection Class
DataPointCollection Members


Insert Method (DataPointCollection)

Insert Method (DataPointCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPointCollection Class : Insert Method
A zero-based Integer indicating the position at which to insert the DataPoint object.
The DataPoint object to insert.
Inserts a new DataPoint object into the DataPointCollection at the specified location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As DataPoint _
)
public void Insert(
   System.int index,
   DataPoint value
)

Parameters

index
A zero-based Integer indicating the position at which to insert the DataPoint object.
value
The DataPoint object to insert.
See Also

Reference

DataPointCollection Class
DataPointCollection Members


Remove Method (DataPointCollection)

Remove Method (DataPointCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPointCollection Class : Remove Method
The DataPoint object to remove.
Removes the specified DataPoint object from the DataPointCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As DataPoint _
)
public void Remove(
   DataPoint value
)

Parameters

value
The DataPoint object to remove.
See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataPointCollection Class Properties

DataPointCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataPointCollection Class

For a list of all members of this type, see DataPointCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the DataPointCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the DataPointCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific DataPoint object in the DataPointCollection by position.
Top
See Also

Reference

DataPointCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (DataPointCollection)

Item Property (DataPointCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPointCollection Class : Item Property
A zero-based Integer indicating the index of the DataPoint to return or set.
Gets or sets a specific DataPoint object in the DataPointCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As DataPoint
public DataPoint this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the DataPoint to return or set.

Property Value

The DataPoint object at the specified position.
See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataRegion Class

DataRegion Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataRegion Class
Specifies a region where a dataset is laid out for a report. A data region bound to a dataset's results may repeat its contents to account for the dataset's size. The List, Matrix, Table and Chart report items are all data regions.
Object Model
DataRegion Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class DataRegion
   Inherits ReportItem
   Implements IReportComponent, IScopeDefinition
public abstract class DataRegion : ReportItem, IReportComponent, IScopeDefinition
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.DataRegion
GrapeCity.ActiveReports.PageReportModel.Chart
GrapeCity.ActiveReports.PageReportModel.List
GrapeCity.ActiveReports.PageReportModel.Matrix
GrapeCity.ActiveReports.PageReportModel.Table

See Also

Reference

DataRegion Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataRegion Class Members

DataRegion Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataRegion Class

The following tables list the members exposed by DataRegion.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ChildScopes | Implements IScopeDefinition.ChildScopes.
Public Property | Container | Gets the IContainer that contains the DataRegion. (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataSetName | Gets or sets the name of the dataset that the data region uses.
Public Property | Filters | Gets the collection of filters applied to each row of data within the data region.
Public Property | FixedHeight | Represents the data region's maximum height per page.
Public Property | FixedWidth | Represents the data region's maximum width per page.
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | NewSection | Gets or sets a value indicating whether a data region is in it's own section
Public Property | NoRows | Gets or sets the message to display inside the data region when the region contains no rows.
Public Property | OverflowName | Represents the data region's overflow name.
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether a page break occurs immediately after the data region ends.
Public Property | PageBreakAtStart | Gets or sets a value indicating whether a page break occurs immediately before the data region begins.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportItemsInScope | Overridden.Implements IScopeDefinition.ReportItemsInScope.
Public Property | Site | Gets or sets the ISite of the DataRegion. (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the resources used by the DataRegion. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Overridden. Validates the information in each property of the DataRegion object.
Top
Public Events
 | Name | Description
Public Event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

DataRegion Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataRegion Class Methods

DataRegion Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataRegion Class

For a list of all members of this type, see DataRegion members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the resources used by the DataRegion. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Overridden. Validates the information in each property of the DataRegion object.
Top
See Also

Reference

DataRegion Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (DataRegion)

Validate Method (DataRegion)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataRegion object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationContext array containing all the validation entries found, or empty if none are found.
See Also

Reference

DataRegion Class
DataRegion Members


DataRegion Class Properties

DataRegion Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataRegion Class

For a list of all members of this type, see DataRegion members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ChildScopes | Implements IScopeDefinition.ChildScopes.
Public Property | Container | Gets the IContainer that contains the DataRegion. (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataSetName | Gets or sets the name of the dataset that the data region uses.
Public Property | Filters | Gets the collection of filters applied to each row of data within the data region.
Public Property | FixedHeight | Represents the data region's maximum height per page.
Public Property | FixedWidth | Represents the data region's maximum width per page.
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | NewSection | Gets or sets a value indicating whether a data region is in it's own section
Public Property | NoRows | Gets or sets the message to display inside the data region when the region contains no rows.
Public Property | OverflowName | Represents the data region's overflow name.
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether a page break occurs immediately after the data region ends.
Public Property | PageBreakAtStart | Gets or sets a value indicating whether a page break occurs immediately before the data region begins.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportItemsInScope | Overridden.Implements IScopeDefinition.ReportItemsInScope.
Public Property | Site | Gets or sets the ISite of the DataRegion. (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
See Also

Reference

DataRegion Class
GrapeCity.ActiveReports.PageReportModel Namespace


ChildScopes Property (DataRegion)

ChildScopes Property (DataRegion)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : ChildScopes Property
Implements IScopeDefinition.ChildScopes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property ChildScopes As System.Collections.IEnumerable
public abstract System.Collections.IEnumerable ChildScopes {get;}
See Also

Reference

DataRegion Class
DataRegion Members


DataSetName Property (DataRegion)

DataSetName Property (DataRegion)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : DataSetName Property

Gets or sets the name of the dataset that the data region uses.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataSetName As System.String
public System.string DataSetName {get; set;}

Property Value

A String containing the name of the dataset that the data region uses to lay out its content.

Remarks

If there are multiple datasets in the report, the DataSetName is required for all DataRegions not contained inside a parent data region. If there is only one dataset in the report, this dataset will be assumed if the DataSetName is not specified. If there are no datasets in the report, the DataSetName cannot be set.

This property is ignored in child data regions.

See Also

Reference

DataRegion Class
DataRegion Members


Filters Property (DataRegion)

Filters Property (DataRegion)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : Filters Property

Gets the collection of filters applied to each row of data within the data region.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Filters As System.Collections.Generic.IList(Of Filter)
public System.Collections.Generic.IList<Filter> Filters {get;}

Property Value

A FilterCollection object containing the filters applied to each row of data within the data region.

See Also

Reference

DataRegion Class
DataRegion Members


FixedHeight Property (DataRegion)

FixedHeight Property (DataRegion)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : FixedHeight Property

Represents the data region's maximum height per page.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FixedHeight As Length
public Length FixedHeight {get; set;}

Property Value

Represents the data region's maximum height per page. If undefined use ReportItem.Height.

See Also

Reference

DataRegion Class
DataRegion Members


FixedWidth Property

FixedWidth Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : FixedWidth Property

Represents the data region's maximum width per page.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FixedWidth As Length
public Length FixedWidth {get; set;}

Property Value

Represents the data region's maximum width per page. If undefined use ReportItem.Width.

See Also

Reference

DataRegion Class
DataRegion Members


NewSection Property (DataRegion)

NewSection Property (DataRegion)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : NewSection Property

Gets or sets a value indicating whether a data region is in it's own section

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NewSection As System.Boolean
public System.bool NewSection {get; set;}

Property Value

A Boolean value indicating whether a data region is in it's own section. Default value is false.

See Also

Reference

DataRegion Class
DataRegion Members


NoRows Property (DataRegion)

NoRows Property (DataRegion)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : NoRows Property

Gets or sets the message to display inside the data region when the region contains no rows.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NoRows As ExpressionInfo
public ExpressionInfo NoRows {get; set;}

Property Value

A String value containing the message to display inside the data region instead of the layout content when the region contains no rows.

Remarks

If the NoRows message is displayed, the style information for the region is applied to the text.

Data regions inside a Table or Matrix cell that do not have a NoRows property value set display no content when there is no data, but the region's border and background properties are still applied to the cell.

See Also

Reference

DataRegion Class
DataRegion Members


OverflowName Property (DataRegion)

OverflowName Property (DataRegion)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : OverflowName Property

Represents the data region's overflow name.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OverflowName As System.String
public System.string OverflowName {get; set;}

Property Value

Represents the data region's overflow name.

See Also

Reference

DataRegion Class
DataRegion Members


PageBreakAtEnd Property (DataRegion)

PageBreakAtEnd Property (DataRegion)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : PageBreakAtEnd Property

Gets or sets a value indicating whether a page break occurs immediately after the data region ends.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageBreakAtEnd As System.Boolean
public System.bool PageBreakAtEnd {get; set;}

Property Value

A Boolean value where true indicates that a page break occurs immediately after the data region ends; otherwise false. The default value is false.

Remarks
If a data region has PageBreakAtEnd set to true, any controls laid out horizontally before the data region ends that extend past the end of the data region are moved to the next page.
See Also

Reference

DataRegion Class
DataRegion Members


PageBreakAtStart Property (DataRegion)

PageBreakAtStart Property (DataRegion)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : PageBreakAtStart Property

Gets or sets a value indicating whether a page break occurs immediately before the data region begins.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageBreakAtStart As System.Boolean
public System.bool PageBreakAtStart {get; set;}

Property Value

A Boolean value where true indicates that a page break occurs immediately before the data region begins; otherwise false. The default value is false.

Remarks
If a data region has PageBreakAtStart set to true, any controls laid out above the data region that extend past the beginning of the data region horizontally are not moved to the next page.
See Also

Reference

DataRegion Class
DataRegion Members


ReportItemsInScope Property (DataRegion)

ReportItemsInScope Property (DataRegion)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : ReportItemsInScope Property
Overridden.Implements IScopeDefinition.ReportItemsInScope.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property ReportItemsInScope As System.Collections.IEnumerable
public abstract System.Collections.IEnumerable ReportItemsInScope {get;}
See Also

Reference

DataRegion Class
DataRegion Members


DataRowCollection Class

DataRowCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataRowCollection Class
Provides a strongly typed collection for DataRow objects.
Object Model
DataRowCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DataRowCollection
   Inherits System.Collections.CollectionBase
public class DataRowCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DataRowCollection

See Also

Reference

DataRowCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataRowCollection Class Members

DataRowCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataRowCollection Class

The following tables list the members exposed by DataRowCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the DataRowCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the DataRowCollection instance. This property cannot be overridden.` (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific DataRow object in the DataRowCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a DataRow object to the DataRowCollection.
Public Method | Clear | Removes all objects from the DataRowCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific DataRow object in the DataRowCollection.
Public Method | Remove | Removes the specified DataRow object from the DataRowCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataRowCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

DataRowCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataRowCollection Class Methods

DataRowCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataRowCollection Class

For a list of all members of this type, see DataRowCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a DataRow object to the DataRowCollection.
Public Method | Clear | Removes all objects from the DataRowCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific DataRow object in the DataRowCollection.
Public Method | Remove | Removes the specified DataRow object from the DataRowCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataRowCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

DataRowCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (DataRowCollection)

Add Method (DataRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRowCollection Class : Add Method
The DataRow object to add to the collection.
Adds a DataRow object to the DataRowCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As DataRow _
) As System.Integer
public System.int Add(
   DataRow value
)

Parameters

value
The DataRow object to add to the collection.

Return Value

A new DataRow object.
See Also

Reference

DataRowCollection Class
DataRowCollection Members


IndexOf Method (DataRowCollection)

IndexOf Method (DataRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRowCollection Class : IndexOf Method
The DataRow object to locate in the DataRowCollection.
Determines the index of a specific DataRow object in the DataRowCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As DataRow _
) As System.Integer
public System.int IndexOf(
   DataRow value
)

Parameters

value
The DataRow object to locate in the DataRowCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

DataRowCollection Class
DataRowCollection Members


Remove Method (DataRowCollection)

Remove Method (DataRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRowCollection Class : Remove Method
The DataRow object to remove.
Removes the specified DataRow object from the DataRowCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As DataRow _
)
public void Remove(
   DataRow value
)

Parameters

value
The DataRow object to remove.
See Also

Reference

DataRowCollection Class
DataRowCollection Members


DataRowCollection Class Properties

DataRowCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataRowCollection Class

For a list of all members of this type, see DataRowCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the DataRowCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the DataRowCollection instance. This property cannot be overridden.` (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific DataRow object in the DataRowCollection by position.
Top
See Also

Reference

DataRowCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (DataRowCollection)

Item Property (DataRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRowCollection Class : Item Property
A zero-based Integer indicating the index of the DataRow object to return or set.
Gets or sets a specific DataRow object in the DataRowCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As DataRow
public DataRow this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the DataRow object to return or set.

Property Value

The DataRow object at the specified position.
See Also

Reference

DataRowCollection Class
DataRowCollection Members


DataSet Class

DataSet Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSet Class
Represents a DataSet element for a report which contains information about a set of data retrieved as part of the report.
Object Model
DataSet Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DataSet
   Implements IBaseDataSet, IDataSet, IReportComponent
public sealed class DataSet : IBaseDataSet, IDataSet, IReportComponent
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DataSet

See Also

Reference

DataSet Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataSet Class Members

DataSet Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSet Class

The following tables list the members exposed by DataSet.

Public Constructors
 | Name | Description
Public Constructor | DataSet Constructor | Initializes a new instance of the DataSet class.
Top
Public Properties
 | Name | Description
Public Property | AccentSensitivity | Gets or sets a value indicating whether the data is accent sensitive.
Public Property | CaseSensitivity | Gets or sets a value indicating whether the data is case sensitive.
Public Property | Collation | Gets or sets the locale to use for the collation sequence when sorting data.
Public Property | Fields | Gets the fields in the data set.
Public Property | Filters | Gets the filters to apply to each row of data in the data set.
Public Property | KanatypeSensitivity | Gets or sets a value indicating whether the data is kanatype sensitive.
Public Property | Name | Gets or sets the name of the dataset.
Public Property | Query | Gets or sets the information about the data source, including connection information, query, etc.
Public Property | SharedDataSet | Gets or sets the shared dataset.
Public Property | WidthSensitivity | Gets or sets a value indicating whether the data is width sensitive.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataSet object.
Top
See Also

Reference

DataSet Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataSet Constructor

DataSet Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSet Class : DataSet Constructor
Initializes a new instance of the DataSet class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DataSet()
See Also

Reference

DataSet Class
DataSet Members


DataSet Class Methods

DataSet Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSet Class

For a list of all members of this type, see DataSet members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataSet object.
Top
See Also

Reference

DataSet Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (DataSet)

Validate Method (DataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSet Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataSet object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

DataSet Class
DataSet Members


DataSet Class Properties

DataSet Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSet Class

For a list of all members of this type, see DataSet members.

Public Properties
 | Name | Description
Public Property | AccentSensitivity | Gets or sets a value indicating whether the data is accent sensitive.
Public Property | CaseSensitivity | Gets or sets a value indicating whether the data is case sensitive.
Public Property | Collation | Gets or sets the locale to use for the collation sequence when sorting data.
Public Property | Fields | Gets the fields in the data set.
Public Property | Filters | Gets the filters to apply to each row of data in the data set.
Public Property | KanatypeSensitivity | Gets or sets a value indicating whether the data is kanatype sensitive.
Public Property | Name | Gets or sets the name of the dataset.
Public Property | Query | Gets or sets the information about the data source, including connection information, query, etc.
Public Property | SharedDataSet | Gets or sets the shared dataset.
Public Property | WidthSensitivity | Gets or sets a value indicating whether the data is width sensitive.
Top
See Also

Reference

DataSet Class
GrapeCity.ActiveReports.PageReportModel Namespace


AccentSensitivity Property (DataSet)

AccentSensitivity Property (DataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSet Class : AccentSensitivity Property

Gets or sets a value indicating whether the data is accent sensitive.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AccentSensitivity As AccentSensitivity
public AccentSensitivity AccentSensitivity {get; set;}

Property Value

An AccentSensitivity enumeration indicating whether the data is accent sensitive.
Remarks

If Auto is specified, the application attempts to derive the accent sensitivity setting by querying the data provider.

Defaults to false if the data provider does not support that method.

See Also

Reference

DataSet Class
DataSet Members


CaseSensitivity Property (DataSet)

CaseSensitivity Property (DataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSet Class : CaseSensitivity Property

Gets or sets a value indicating whether the data is case sensitive.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CaseSensitivity As CaseSensitivity
public CaseSensitivity CaseSensitivity {get; set;}

Property Value

A CaseSensitivity enumeration indicating whether the fields in a data set are case sensitive.
Remarks

If Auto is specified, the application attempts to derive the case sensitivity setting by querying the data provider.

Defaults to false if the data provider does not support that method.

See Also

Reference

DataSet Class
DataSet Members


Collation Property (DataSet)

Collation Property (DataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSet Class : Collation Property

Gets or sets the locale to use for the collation sequence when sorting data.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Collation As System.String
public System.string Collation {get; set;}

Property Value

A String indicating the locale to use for the collation sequence for sorting data.

Remarks

If no Collation is specified, the application attempts to derive the collation setting by querying the data provider.

The default value is the application's locale settings if the data provider does not support that method or if it returns an unsupported or invalid value.

See Also

Reference

DataSet Class
DataSet Members


Fields Property (DataSet)

Fields Property (DataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSet Class : Fields Property

Gets the fields in the data set.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Fields As FieldCollection
public FieldCollection Fields {get;}

Property Value

A FieldCollection object containing the fields in a data set.
See Also

Reference

DataSet Class
DataSet Members


Filters Property (DataSet)

Filters Property (DataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSet Class : Filters Property

Gets the filters to apply to each row of data in the data set.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Filters As System.Collections.Generic.IList(Of Filter)
public System.Collections.Generic.IList<Filter> Filters {get;}

Property Value

A FilterCollection object containing the filters to apply to each row of data in the data set.

See Also

Reference

DataSet Class
DataSet Members


KanatypeSensitivity Property (DataSet)

KanatypeSensitivity Property (DataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSet Class : KanatypeSensitivity Property

Gets or sets a value indicating whether the data is kanatype sensitive.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property KanatypeSensitivity As KanatypeSensitivity
public KanatypeSensitivity KanatypeSensitivity {get; set;}

Property Value

A KanatypeSensitivity enumeration indicating whether the data is kanatype sensitive.
Remarks

If Auto is specified, the application attempts to derive the kanatype sensitivity setting by querying the data provider.

Defaults to false if the data provider does not support that method.

See Also

Reference

DataSet Class
DataSet Members


Name Property (DataSet)

Name Property (DataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSet Class : Name Property

Gets or sets the name of the dataset.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}

Property Value

A String indicating the name of the dataset.

Remarks

Cannot be the same name as any data region or grouping.

See Also

Reference

DataSet Class
DataSet Members


Query Property (DataSet)

Query Property (DataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSet Class : Query Property

Gets or sets the information about the data source, including connection information, query, etc.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Query As Query
public Query Query {get; set;}

Property Value

A Query object containing information about the data source, including connection information, query, etc..
Remarks

Setting a value for this property is required to get the data from the data source.

See Also

Reference

DataSet Class
DataSet Members


SharedDataSet Property (DataSet)

SharedDataSet Property (DataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSet Class : SharedDataSet Property
Gets or sets the shared dataset.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SharedDataSet As SharedDataSet
public SharedDataSet SharedDataSet {get; set;}
See Also

Reference

DataSet Class
DataSet Members


WidthSensitivity Property (DataSet)

WidthSensitivity Property (DataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSet Class : WidthSensitivity Property

Gets or sets a value indicating whether the data is width sensitive.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WidthSensitivity As WidthSensitivity
public WidthSensitivity WidthSensitivity {get; set;}

Property Value

A WidthSensitivity enumeration indicating whether the data is width sensitive.
Remarks

If Auto is specified, the application attempts to derive the width sensitivity setting by querying the data provider.

Defaults to false if the data provider does not support that method.

See Also

Reference

DataSet Class
DataSet Members


DataSetCollection Class

DataSetCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSetCollection Class
Provides a strongly typed collection for IDataSet interfaces.
Object Model
DataSetCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DataSetCollection
   Inherits System.Collections.CollectionBase
public sealed class DataSetCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DataSetCollection

See Also

Reference

DataSetCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataSetCollection Class Members

DataSetCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSetCollection Class

The following tables list the members exposed by DataSetCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the DataSetCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the DataSetCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific IDataSet interface in the DataSetCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an IDataSet interface to the DataSetCollection.
Public Method | Clear | Removes all objects from the DataSetCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific IDataSet interface in the DataSetCollection.
Public Method | Remove | Removes the specified IDataSet interface from the DataSetCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataSetCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

DataSetCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataSetCollection Class Methods

DataSetCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSetCollection Class

For a list of all members of this type, see DataSetCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an IDataSet interface to the DataSetCollection.
Public Method | Clear | Removes all objects from the DataSetCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific IDataSet interface in the DataSetCollection.
Public Method | Remove | Removes the specified IDataSet interface from the DataSetCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataSetCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

DataSetCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (DataSetCollection)

Add Method (DataSetCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSetCollection Class : Add Method
The IDataSet interface to add to the collection.
Adds an IDataSet interface to the DataSetCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As IDataSet _
) As System.Integer
public System.int Add(
   IDataSet value
)

Parameters

value
The IDataSet interface to add to the collection.

Return Value

A new IDataSet interface.
See Also

Reference

DataSetCollection Class
DataSetCollection Members


IndexOf Method (DataSetCollection)

IndexOf Method (DataSetCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSetCollection Class : IndexOf Method
The IDataSet interface to locate in the DataSetCollection.
Determines the index of a specific IDataSet interface in the DataSetCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As IDataSet _
) As System.Integer
public System.int IndexOf(
   IDataSet value
)

Parameters

value
The IDataSet interface to locate in the DataSetCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

DataSetCollection Class
DataSetCollection Members


Remove Method (DataSetCollection)

Remove Method (DataSetCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSetCollection Class : Remove Method
The IDataSet interface to remove.
Removes the specified IDataSet interface from the DataSetCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As IDataSet _
)
public void Remove(
   IDataSet value
)

Parameters

value
The IDataSet interface to remove.
See Also

Reference

DataSetCollection Class
DataSetCollection Members


DataSetCollection Class Properties

DataSetCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSetCollection Class

For a list of all members of this type, see DataSetCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the DataSetCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the DataSetCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific IDataSet interface in the DataSetCollection by position.
Top
See Also

Reference

DataSetCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (DataSetCollection)

Item Property (DataSetCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSetCollection Class : Item Property
A zero-based Integer indicating the index of the IDataSet interface to return or set.
Gets or sets a specific IDataSet interface in the DataSetCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As IDataSet
public IDataSet this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the IDataSet interface to return or set.

Property Value

The IDataSet interface at the specified position.
See Also

Reference

DataSetCollection Class
DataSetCollection Members


DataSetReference Class

DataSetReference Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSetReference Class
The query to execute to obtain a list of values or default values for a parameter.
Object Model
DataSetReference Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DataSetReference
public sealed class DataSetReference
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DataSetReference

See Also

Reference

DataSetReference Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataSetReference Class Members

DataSetReference Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSetReference Class

The following tables list the members exposed by DataSetReference.

Public Constructors
 | Name | Description
Public Constructor | DataSetReference Constructor | Initializes a new instance of the DataSetReference class.
Top
Public Properties
 | Name | Description
Public Property | DataSetName | Gets or sets the name of the dataset to use in the parameter.
Public Property | LabelField | Gets or sets name of the field to use for the value displayed to the user for the selection.
Public Property | ValueField | Gets or sets the name of the field to use for the values and defaults for the parameter.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataSetReference object.
Top
See Also

Reference

DataSetReference Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataSetReference Constructor

DataSetReference Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSetReference Class : DataSetReference Constructor
Initializes a new instance of the DataSetReference class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DataSetReference()
See Also

Reference

DataSetReference Class
DataSetReference Members


DataSetReference Class Methods

DataSetReference Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSetReference Class

For a list of all members of this type, see DataSetReference members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataSetReference object.
Top
See Also

Reference

DataSetReference Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (DataSetReference)

Validate Method (DataSetReference)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSetReference Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataSetReference object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

DataSetReference Class
DataSetReference Members


DataSetReference Class Properties

DataSetReference Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSetReference Class

For a list of all members of this type, see DataSetReference members.

Public Properties
 | Name | Description
Public Property | DataSetName | Gets or sets the name of the dataset to use in the parameter.
Public Property | LabelField | Gets or sets name of the field to use for the value displayed to the user for the selection.
Public Property | ValueField | Gets or sets the name of the field to use for the values and defaults for the parameter.
Top
See Also

Reference

DataSetReference Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataSetName Property (DataSetReference)

DataSetName Property (DataSetReference)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSetReference Class : DataSetName Property

Gets or sets the name of the dataset to use in the parameter.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataSetName As System.String
public System.string DataSetName {get; set;}

Property Value

A String representing the name of the dataset to use.

See Also

Reference

DataSetReference Class
DataSetReference Members


LabelField Property

LabelField Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSetReference Class : LabelField Property

Gets or sets name of the field to use for the value displayed to the user for the selection.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LabelField As System.String
public System.string LabelField {get; set;}

Property Value

A String representing the name of the field to use for the value displayed to the user for the selection.

See Also

Reference

DataSetReference Class
DataSetReference Members


ValueField Property

ValueField Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSetReference Class : ValueField Property

Gets or sets the name of the field to use for the values and defaults for the parameter.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ValueField As System.String
public System.string ValueField {get; set;}

Property Value

A String representing the name of the field to use for the values and defaults for the parameter.

See Also

Reference

DataSetReference Class
DataSetReference Members


DataSource Class

DataSource Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSource Class
Specifies information about a report data source.
Object Model
DataSource Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DataSource
public class DataSource
Remarks
A DataSource must have only one DataSourceReference or one ConnectionProperties object defined.
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DataSource

See Also

Reference

DataSource Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataSource Class Members

DataSource Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSource Class

The following tables list the members exposed by DataSource.

Public Constructors
 | Name | Description
Public Constructor | DataSource Constructor | Initializes a new instance of the DataSource class.
Top
Public Properties
 | Name | Description
Public Property | ConnectionProperties | Gets or sets information used to connect to the data source.
Public Property | DataSourceReference | Gets or sets the full or relative path to the data source reference.
Public Property | Name | Gets or sets a value indicating the name of the data source.
Public Property | Transaction | Gets or sets a value indicating whether the data source executes a single transaction for its datasets.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataSource object.=
Top
See Also

Reference

DataSource Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataSource Constructor

DataSource Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSource Class : DataSource Constructor
Initializes a new instance of the DataSource class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DataSource()
See Also

Reference

DataSource Class
DataSource Members


DataSource Class Methods

DataSource Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSource Class

For a list of all members of this type, see DataSource members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataSource object.=
Top
See Also

Reference

DataSource Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (DataSource)

Validate Method (DataSource)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSource Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataSource object.=
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

DataSource Class
DataSource Members


DataSource Class Properties

DataSource Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSource Class

For a list of all members of this type, see DataSource members.

Public Properties
 | Name | Description
Public Property | ConnectionProperties | Gets or sets information used to connect to the data source.
Public Property | DataSourceReference | Gets or sets the full or relative path to the data source reference.
Public Property | Name | Gets or sets a value indicating the name of the data source.
Public Property | Transaction | Gets or sets a value indicating whether the data source executes a single transaction for its datasets.
Top
See Also

Reference

DataSource Class
GrapeCity.ActiveReports.PageReportModel Namespace


ConnectionProperties Property

ConnectionProperties Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSource Class : ConnectionProperties Property

Gets or sets information used to connect to the data source.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ConnectionProperties As ConnectionProperties
public ConnectionProperties ConnectionProperties {get; set;}

Property Value

A ConnectionProperties object indicating the information used to connect to the data source.
See Also

Reference

DataSource Class
DataSource Members


DataSourceReference Property

DataSourceReference Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSource Class : DataSourceReference Property

Gets or sets the full or relative path to the data source reference.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataSourceReference As System.String
public System.string DataSourceReference {get; set;}

Property Value

A String indicating the full or relative path to the data source reference.

Remarks
Relative paths are based on the location of the report.
See Also

Reference

DataSource Class
DataSource Members


Name Property (DataSource)

Name Property (DataSource)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSource Class : Name Property

Gets or sets a value indicating the name of the data source.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}

Property Value

A String indicating the name of the data source.

Remarks
Each data source must have a unique name.
See Also

Reference

DataSource Class
DataSource Members


Transaction Property (DataSource)

Transaction Property (DataSource)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSource Class : Transaction Property

Gets or sets a value indicating whether the data source executes a single transaction for its datasets.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Transaction As System.Boolean
public System.bool Transaction {get; set;}

Property Value

A Boolean value where true indicates that the data source uses a single transaction when executing its datasets; otherwise false. The default value is false.

See Also

Reference

DataSource Class
DataSource Members


DataSourceCollection Class

DataSourceCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSourceCollection Class
Provides a strongly typed collection for DataSource objects.
Object Model
DataSourceCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DataSourceCollection
   Inherits System.Collections.CollectionBase
public sealed class DataSourceCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DataSourceCollection

See Also

Reference

DataSourceCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataSourceCollection Class Members

DataSourceCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSourceCollection Class

The following tables list the members exposed by DataSourceCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the DataSourceCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the DataSourceCollection instance. This property cannot be overridden.` (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific DataSource object in the DataSourceCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a DataSource object to the DataSourceCollection.
Public Method | Clear | Removes all objects from the DataSourceCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific DataSource object in the DataSourceCollection.
Public Method | Remove | Removes the specified DataSource object from the DataSourceCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataSourceCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

DataSourceCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataSourceCollection Class Methods

DataSourceCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSourceCollection Class

For a list of all members of this type, see DataSourceCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a DataSource object to the DataSourceCollection.
Public Method | Clear | Removes all objects from the DataSourceCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific DataSource object in the DataSourceCollection.
Public Method | Remove | Removes the specified DataSource object from the DataSourceCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataSourceCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

DataSourceCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (DataSourceCollection)

Add Method (DataSourceCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSourceCollection Class : Add Method
The DataSource object to add to the collection.
Adds a DataSource object to the DataSourceCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As DataSource _
) As System.Integer
public System.int Add(
   DataSource value
)

Parameters

value
The DataSource object to add to the collection.

Return Value

A new DataSource object.
See Also

Reference

DataSourceCollection Class
DataSourceCollection Members


IndexOf Method (DataSourceCollection)

IndexOf Method (DataSourceCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSourceCollection Class : IndexOf Method
The DataSource object to locate in the DataSourceCollection.
Determines the index of a specific DataSource object in the DataSourceCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As DataSource _
) As System.Integer
public System.int IndexOf(
   DataSource value
)

Parameters

value
The DataSource object to locate in the DataSourceCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

DataSourceCollection Class
DataSourceCollection Members


Remove Method (DataSourceCollection)

Remove Method (DataSourceCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSourceCollection Class : Remove Method
The DataSource object to remove.
Removes the specified DataSource object from the DataSourceCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As DataSource _
)
public void Remove(
   DataSource value
)

Parameters

value
The DataSource object to remove.
See Also

Reference

DataSourceCollection Class
DataSourceCollection Members


DataSourceCollection Class Properties

DataSourceCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSourceCollection Class

For a list of all members of this type, see DataSourceCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the DataSourceCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the DataSourceCollection instance. This property cannot be overridden.` (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific DataSource object in the DataSourceCollection by position.
Top
See Also

Reference

DataSourceCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (DataSourceCollection)

Item Property (DataSourceCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSourceCollection Class : Item Property
A zero-based Integer indicating the index of the DataSource to return or set.
Gets or sets a specific DataSource object in the DataSourceCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As DataSource
public DataSource this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the DataSource to return or set.

Property Value

The DataSource object at the specified position.
See Also

Reference

DataSourceCollection Class
DataSourceCollection Members


DataSourcePrompt Class

DataSourcePrompt Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSourcePrompt Class
Represents request for credentials to connect to a datasource.
Object Model
DataSourcePrompt Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DataSourcePrompt
public sealed class DataSourcePrompt
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DataSourcePrompt

See Also

Reference

DataSourcePrompt Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataSourcePrompt Class Members

DataSourcePrompt Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSourcePrompt Class

The following tables list the members exposed by DataSourcePrompt.

Public Properties
 | Name | Description
Public Property | Name | Gets name of data source that credentials are required for.
Public Property | Password | Gets or sets credentials password.
Public Property | Prompt | Gets prompt that shown when credentials should be entered.
Public Property | User | Gets or sets credentials user name.
Top
See Also

Reference

DataSourcePrompt Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataSourcePrompt Class Properties

DataSourcePrompt Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataSourcePrompt Class

For a list of all members of this type, see DataSourcePrompt members.

Public Properties
 | Name | Description
Public Property | Name | Gets name of data source that credentials are required for.
Public Property | Password | Gets or sets credentials password.
Public Property | Prompt | Gets prompt that shown when credentials should be entered.
Public Property | User | Gets or sets credentials user name.
Top
See Also

Reference

DataSourcePrompt Class
GrapeCity.ActiveReports.PageReportModel Namespace


Name Property (DataSourcePrompt)

Name Property (DataSourcePrompt)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSourcePrompt Class : Name Property
Gets name of data source that credentials are required for.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Name As System.String
public System.string Name {get;}
See Also

Reference

DataSourcePrompt Class
DataSourcePrompt Members


Password Property (DataSourcePrompt)

Password Property (DataSourcePrompt)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSourcePrompt Class : Password Property
Gets or sets credentials password.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Password As System.String
public System.string Password {get; set;}
See Also

Reference

DataSourcePrompt Class
DataSourcePrompt Members


Prompt Property (DataSourcePrompt)

Prompt Property (DataSourcePrompt)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSourcePrompt Class : Prompt Property
Gets prompt that shown when credentials should be entered.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Prompt As System.String
public System.string Prompt {get;}
See Also

Reference

DataSourcePrompt Class
DataSourcePrompt Members


User Property

User Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSourcePrompt Class : User Property
Gets or sets credentials user name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property User As System.String
public System.string User {get; set;}
See Also

Reference

DataSourcePrompt Class
DataSourcePrompt Members


DataValue Class

DataValue Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataValue Class
The DataValue element defines a collection of data values for a single data point in the chart, or custom report control.
Object Model
DataValue Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DataValue
public sealed class DataValue
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DataValue

See Also

Reference

DataValue Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataValue Class Members

DataValue Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataValue Class

The following tables list the members exposed by DataValue.

Public Constructors
 | Name | Description
Public Constructor | DataValue Constructor | Initializes a new instance of the DataValue class.
Top
Public Properties
 | Name | Description
Public Property | Name | Gets or sets the name for the data value.
Public Property | Value | Gets or sets the value expression.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataValue object.
Top
See Also

Reference

DataValue Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataValue Constructor

DataValue Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataValue Class : DataValue Constructor
Initializes a new instance of the DataValue class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DataValue()
See Also

Reference

DataValue Class
DataValue Members


DataValue Class Methods

DataValue Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataValue Class

For a list of all members of this type, see DataValue members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataValue object.
Top
See Also

Reference

DataValue Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (DataValue)

Validate Method (DataValue)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataValue Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataValue object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

DataValue Class
DataValue Members


DataValue Class Properties

DataValue Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataValue Class

For a list of all members of this type, see DataValue members.

Public Properties
 | Name | Description
Public Property | Name | Gets or sets the name for the data value.
Public Property | Value | Gets or sets the value expression.
Top
See Also

Reference

DataValue Class
GrapeCity.ActiveReports.PageReportModel Namespace


Name Property (DataValue)

Name Property (DataValue)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataValue Class : Name Property

Gets or sets the name for the data value.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As ExpressionInfo
public ExpressionInfo Name {get; set;}

Property Value

An ExpressionInfo object containing the name expression.
See Also

Reference

DataValue Class
DataValue Members


Value Property (DataValue)

Value Property (DataValue)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataValue Class : Value Property

Gets or sets the value expression.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As ExpressionInfo
public ExpressionInfo Value {get; set;}

Property Value

An ExpressionInfo object containing the value expression.
See Also

Reference

DataValue Class
DataValue Members


DataValueCollection Class

DataValueCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataValueCollection Class
Provides a strongly typed collection for DataValue objects.
Object Model
DataValueCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DataValueCollection
   Inherits System.Collections.CollectionBase
public sealed class DataValueCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DataValueCollection

See Also

Reference

DataValueCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


DataValueCollection Class Members

DataValueCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataValueCollection Class

The following tables list the members exposed by DataValueCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the DataValueCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the DataValueCollection instance. This property cannot be overridden.` (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific DataValue object in the DataValueCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a DataValue object to the DataValueCollection.
Public Method | Clear | Removes all objects from the DataValueCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific DataValue object in the DataValueCollection.
Public Method | Insert | Inserts a new DataValue object into the DataValueCollection at the specified location.
Public Method | Remove | Removes the specified DataValue object from the DataValueCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataValueCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

DataValueCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataValueCollection Class Methods

DataValueCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataValueCollection Class

For a list of all members of this type, see DataValueCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a DataValue object to the DataValueCollection.
Public Method | Clear | Removes all objects from the DataValueCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific DataValue object in the DataValueCollection.
Public Method | Insert | Inserts a new DataValue object into the DataValueCollection at the specified location.
Public Method | Remove | Removes the specified DataValue object from the DataValueCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataValueCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

DataValueCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (DataValueCollection)

Add Method (DataValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataValueCollection Class : Add Method
The DataValue object to add to the collection.
Adds a DataValue object to the DataValueCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As DataValue _
) As System.Integer
public System.int Add(
   DataValue value
)

Parameters

value
The DataValue object to add to the collection.

Return Value

A new DataValue object.
See Also

Reference

DataValueCollection Class
DataValueCollection Members


IndexOf Method (DataValueCollection)

IndexOf Method (DataValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataValueCollection Class : IndexOf Method
The DataValue object to locate in the DataValueCollection.
Determines the index of a specific DataValue object in the DataValueCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As DataValue _
) As System.Integer
public System.int IndexOf(
   DataValue value
)

Parameters

value
The DataValue object to locate in the DataValueCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

DataValueCollection Class
DataValueCollection Members


Insert Method (DataValueCollection)

Insert Method (DataValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataValueCollection Class : Insert Method
A zero-based Integer indicating the position at which to insert the DataValue object.
The DataValue object to insert.
Inserts a new DataValue object into the DataValueCollection at the specified location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As DataValue _
)
public void Insert(
   System.int index,
   DataValue value
)

Parameters

index
A zero-based Integer indicating the position at which to insert the DataValue object.
value
The DataValue object to insert.
See Also

Reference

DataValueCollection Class
DataValueCollection Members


Remove Method (DataValueCollection)

Remove Method (DataValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataValueCollection Class : Remove Method
The DataValue object to remove.
Removes the specified DataValue object from the DataValueCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As DataValue _
)
public void Remove(
   DataValue value
)

Parameters

value
The DataValue object to remove.
See Also

Reference

DataValueCollection Class
DataValueCollection Members


DataValueCollection Class Properties

DataValueCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataValueCollection Class

For a list of all members of this type, see DataValueCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the DataValueCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the DataValueCollection instance. This property cannot be overridden.` (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific DataValue object in the DataValueCollection by position.
Top
See Also

Reference

DataValueCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (DataValueCollection)

Item Property (DataValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataValueCollection Class : Item Property
A zero-based Integer indicating the index of the DataValue object to return or set.
Gets or sets a specific DataValue object in the DataValueCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As DataValue
public DataValue this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the DataValue object to return or set.

Property Value

The DataValue object at the specified position.
See Also

Reference

DataValueCollection Class
DataValueCollection Members


DefaultValue Class

DefaultValue Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DefaultValue Class
The default value for the parameter.
Object Model
DefaultValue Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DefaultValue
public sealed class DefaultValue
Remarks

DefaultValue must have one and only one of the following properties set: Values or DataSetReference.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DefaultValue

See Also

Reference

DefaultValue Members
GrapeCity.ActiveReports.PageReportModel Namespace


DefaultValue Class Members

DefaultValue Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DefaultValue Class

The following tables list the members exposed by DefaultValue.

Public Constructors
 | Name | Description
Public Constructor | DefaultValue Constructor | Initializes a new instance of the DefaultValue class.
Top
Public Properties
 | Name | Description
Public Property | DataSetReference | Gets or sets the query to execute to obtain the default value(s) for the parameter.
Public Property | Values | Gets the default values for the parameter.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DefaultValue object.
Top
See Also

Reference

DefaultValue Class
GrapeCity.ActiveReports.PageReportModel Namespace


DefaultValue Constructor

DefaultValue Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DefaultValue Class : DefaultValue Constructor
Initializes a new instance of the DefaultValue class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DefaultValue()
See Also

Reference

DefaultValue Class
DefaultValue Members


DefaultValue Class Methods

DefaultValue Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DefaultValue Class

For a list of all members of this type, see DefaultValue members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DefaultValue object.
Top
See Also

Reference

DefaultValue Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (DefaultValue)

Validate Method (DefaultValue)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DefaultValue Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DefaultValue object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

DefaultValue Class
DefaultValue Members


DefaultValue Class Properties

DefaultValue Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DefaultValue Class

For a list of all members of this type, see DefaultValue members.

Public Properties
 | Name | Description
Public Property | DataSetReference | Gets or sets the query to execute to obtain the default value(s) for the parameter.
Public Property | Values | Gets the default values for the parameter.
Top
See Also

Reference

DefaultValue Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataSetReference Property (DefaultValue)

DataSetReference Property (DefaultValue)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DefaultValue Class : DataSetReference Property

Gets or sets the query to execute to obtain the default value(s) for the parameter.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataSetReference As DataSetReference
public DataSetReference DataSetReference {get; set;}

Property Value

A DataSetReference object representing the query to execute to obtain the default value(s) for the parameter.
Remarks

If this property is not set, the first value of the ValueField is used.

See Also

Reference

DefaultValue Class
DefaultValue Members


Values Property (DefaultValue)

Values Property (DefaultValue)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DefaultValue Class : Values Property

Gets the default values for the parameter.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Values As ExpressionInfoCollection
public ExpressionInfoCollection Values {get;}

Property Value

An ExpressionInfoCollection object containing the default values for the parameter.
See Also

Reference

DefaultValue Class
DefaultValue Members


Details Class

Details Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Details Class
Defines the detail rows for a table.
Object Model
Details Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Details
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer, IScopeDefinition
public sealed class Details : ReportComponent, IReportComponent, IReportComponentContainer, IScopeDefinition
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.Details

See Also

Reference

Details Members
GrapeCity.ActiveReports.PageReportModel Namespace


Details Class Members

Details Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Details Class

The following tables list the members exposed by Details.

Public Constructors
 | Name | Description
Public Constructor | Details Constructor | Initializes a new instance of the Details class.
Top
Public Properties
 | Name | Description
Public Property | Components | Gets a ReportComponentCollection object containing all the components hosted in the control.
Public Property | Container | Gets the IContainer that contains the Details. (Inherited from System.ComponentModel.Component)
Public Property | Grouping | Gets or sets the expressions by which to group the detail data.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | Gets or sets the ISite of the Details. (Inherited from System.ComponentModel.Component)
Public Property | Sorting | Gets or sets the expressions by which to sort the detail data.
Public Property | TableRows | Gets the detail rows for the table.
Public Property | Visibility | Gets or sets a value indicating whether the details are hidden.
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the resources used by the Details. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the Details object.
Top
Public Events
 | Name | Description
Public Event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Details Class
GrapeCity.ActiveReports.PageReportModel Namespace


Details Constructor

Details Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Details Class : Details Constructor
Initializes a new instance of the Details class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Details()
See Also

Reference

Details Class
Details Members


Details Class Methods

Details Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Details Class

For a list of all members of this type, see Details members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the resources used by the Details. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the Details object.
Top
See Also

Reference

Details Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (Details)

Validate Method (Details)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Details Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the Details object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

Details Class
Details Members


Details Class Properties

Details Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Details Class

For a list of all members of this type, see Details members.

Public Properties
 | Name | Description
Public Property | Components | Gets a ReportComponentCollection object containing all the components hosted in the control.
Public Property | Container | Gets the IContainer that contains the Details. (Inherited from System.ComponentModel.Component)
Public Property | Grouping | Gets or sets the expressions by which to group the detail data.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | Gets or sets the ISite of the Details. (Inherited from System.ComponentModel.Component)
Public Property | Sorting | Gets or sets the expressions by which to sort the detail data.
Public Property | TableRows | Gets the detail rows for the table.
Public Property | Visibility | Gets or sets a value indicating whether the details are hidden.
Top
See Also

Reference

Details Class
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property (Details)

Components Property (Details)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Details Class : Components Property
Gets a ReportComponentCollection object containing all the components hosted in the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Components As ReportComponentCollection
public ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection containing all the components hosted in the control.A read-only DataDynamics.Reports.ReportObjectModel.Rdl.ReportComponentCollection containing all the components hosted in the control.
See Also

Reference

Details Class
Details Members


Grouping Property (Details)

Grouping Property (Details)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Details Class : Grouping Property

Gets or sets the expressions by which to group the detail data.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Grouping As Grouping
public Grouping Grouping {get; set;}

Property Value

A Grouping object containing the expressions by which to group the detail data.
See Also

Reference

Details Class
Details Members


Sorting Property (Details)

Sorting Property (Details)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Details Class : Sorting Property

Gets or sets the expressions by which to sort the detail data.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Sorting As SortByCollection
public SortByCollection Sorting {get;}

Property Value

A SortByCollection indicating the expressions by which to sort the detail data.
See Also

Reference

Details Class
Details Members


TableRows Property (Details)

TableRows Property (Details)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Details Class : TableRows Property

Gets the detail rows for the table.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TableRows As TableRowCollection
public TableRowCollection TableRows {get;}

Property Value

A TableRowCollection containing the detail rows for the table.
Remarks

The detail rows cannot contain any DataRegions in any of their TableCells.

See Also

Reference

Details Class
Details Members


Visibility Property (Details)

Visibility Property (Details)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Details Class : Visibility Property

Gets or sets a value indicating whether the details are hidden.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visibility As Visibility
public Visibility Visibility {get; set;}

Property Value

A Visibility object containing properties indicating whether the details are hidden, and if so, the ToggleItem used to hide or reveal them.
See Also

Reference

Details Class
Details Members


DocumentMap Class

DocumentMap Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DocumentMap Class
Specifies document map settings.
Object Model
DocumentMap Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DocumentMap
public sealed class DocumentMap
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DocumentMap

See Also

Reference

DocumentMap Members
GrapeCity.ActiveReports.PageReportModel Namespace


DocumentMap Class Members

DocumentMap Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DocumentMap Class

The following tables list the members exposed by DocumentMap.

Public Constructors
 | Name | Description
Public Constructor | DocumentMap Constructor | Initializes a new instance of this class.
Top
Public Properties
 | Name | Description
Public Property | Levels | The list of document map levels.
Public Property | NumberingStyle | Specifies default numering style for headings.
Public Property | Source | The document map source.
Top
Public Methods
 | Name | Description
Public Method | IsDefault | Determines whether document map has default setup.
Top
See Also

Reference

DocumentMap Class
GrapeCity.ActiveReports.PageReportModel Namespace


DocumentMap Constructor

DocumentMap Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DocumentMap Class : DocumentMap Constructor
Initializes a new instance of this class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DocumentMap()
See Also

Reference

DocumentMap Class
DocumentMap Members


DocumentMap Class Methods

DocumentMap Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DocumentMap Class

For a list of all members of this type, see DocumentMap members.

Public Methods
 | Name | Description
Public Method | IsDefault | Determines whether document map has default setup.
Top
See Also

Reference

DocumentMap Class
GrapeCity.ActiveReports.PageReportModel Namespace


IsDefault Method

IsDefault Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DocumentMap Class : IsDefault Method
Determines whether document map has default setup.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IsDefault() As System.Boolean
public System.bool IsDefault()
See Also

Reference

DocumentMap Class
DocumentMap Members


DocumentMap Class Properties

DocumentMap Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DocumentMap Class

For a list of all members of this type, see DocumentMap members.

Public Properties
 | Name | Description
Public Property | Levels | The list of document map levels.
Public Property | NumberingStyle | Specifies default numering style for headings.
Public Property | Source | The document map source.
Top
See Also

Reference

DocumentMap Class
GrapeCity.ActiveReports.PageReportModel Namespace


Levels Property (DocumentMap)

Levels Property (DocumentMap)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DocumentMap Class : Levels Property
The list of document map levels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Levels As System.Collections.Generic.List(Of DocumentMapLevel)
public System.Collections.Generic.List<DocumentMapLevel> Levels {get;}
See Also

Reference

DocumentMap Class
DocumentMap Members


NumberingStyle Property (DocumentMap)

NumberingStyle Property (DocumentMap)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DocumentMap Class : NumberingStyle Property
Specifies default numering style for headings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NumberingStyle As NumberingStyle
public NumberingStyle NumberingStyle {get; set;}
See Also

Reference

DocumentMap Class
DocumentMap Members


Source Property (DocumentMap)

Source Property (DocumentMap)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DocumentMap Class : Source Property
The document map source.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Source As DocumentMapSource
public DocumentMapSource Source {get; set;}
See Also

Reference

DocumentMap Class
DocumentMap Members


DocumentMapLevel Class

DocumentMapLevel Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DocumentMapLevel Class
Represents document map level properties.
Object Model
DocumentMapLevel Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DocumentMapLevel
public sealed class DocumentMapLevel
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DocumentMapLevel

See Also

Reference

DocumentMapLevel Members
GrapeCity.ActiveReports.PageReportModel Namespace


DocumentMapLevel Class Members

DocumentMapLevel Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DocumentMapLevel Class

The following tables list the members exposed by DocumentMapLevel.

Public Constructors
 | Name | Description
Public Constructor | DocumentMapLevel Constructor | Initializes a new instance of this class.
Top
Public Properties
 | Name | Description
Public Property | NumberingStyle | Specifies numbering style for document map level.
Top
See Also

Reference

DocumentMapLevel Class
GrapeCity.ActiveReports.PageReportModel Namespace


DocumentMapLevel Constructor

DocumentMapLevel Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DocumentMapLevel Class : DocumentMapLevel Constructor
Initializes a new instance of this class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DocumentMapLevel()
See Also

Reference

DocumentMapLevel Class
DocumentMapLevel Members


DocumentMapLevel Class Properties

DocumentMapLevel Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DocumentMapLevel Class

For a list of all members of this type, see DocumentMapLevel members.

Public Properties
 | Name | Description
Public Property | NumberingStyle | Specifies numbering style for document map level.
Top
See Also

Reference

DocumentMapLevel Class
GrapeCity.ActiveReports.PageReportModel Namespace


NumberingStyle Property (DocumentMapLevel)

NumberingStyle Property (DocumentMapLevel)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DocumentMapLevel Class : NumberingStyle Property
Specifies numbering style for document map level.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NumberingStyle As NumberingStyle
public NumberingStyle NumberingStyle {get; set;}
See Also

Reference

DocumentMapLevel Class
DocumentMapLevel Members


Drillthrough Class

Drillthrough Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Drillthrough Class
Specifies an element that defines a drillthrough action.
Object Model
Drillthrough Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Drillthrough
public sealed class Drillthrough
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Drillthrough

See Also

Reference

Drillthrough Members
GrapeCity.ActiveReports.PageReportModel Namespace


Drillthrough Class Members

Drillthrough Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Drillthrough Class

The following tables list the members exposed by Drillthrough.

Public Constructors
 | Name | Description
Public Constructor | Drillthrough Constructor | Initializes a new instance of Drillthrough class.
Top
Public Properties
 | Name | Description
Public Property | Parameters | Gets the parameters to pass to the drillthrough report.
Public Property | ReportName | Gets or sets a String value representing the path of the drillthrough report. Paths may be absolute or relative.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the Drillthrough object.
Top
See Also

Reference

Drillthrough Class
GrapeCity.ActiveReports.PageReportModel Namespace


Drillthrough Constructor

Drillthrough Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Drillthrough Class : Drillthrough Constructor
Initializes a new instance of Drillthrough class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Drillthrough()
See Also

Reference

Drillthrough Class
Drillthrough Members


Drillthrough Class Methods

Drillthrough Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Drillthrough Class

For a list of all members of this type, see Drillthrough members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the Drillthrough object.
Top
See Also

Reference

Drillthrough Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (Drillthrough)

Validate Method (Drillthrough)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Drillthrough Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the Drillthrough object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

Drillthrough Class
Drillthrough Members


Drillthrough Class Properties

Drillthrough Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Drillthrough Class

For a list of all members of this type, see Drillthrough members.

Public Properties
 | Name | Description
Public Property | Parameters | Gets the parameters to pass to the drillthrough report.
Public Property | ReportName | Gets or sets a String value representing the path of the drillthrough report. Paths may be absolute or relative.
Top
See Also

Reference

Drillthrough Class
GrapeCity.ActiveReports.PageReportModel Namespace


Parameters Property (Drillthrough)

Parameters Property (Drillthrough)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Drillthrough Class : Parameters Property

Gets the parameters to pass to the drillthrough report.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Parameters As ParameterCollection
public ParameterCollection Parameters {get;}

Property Value

A ParameterCollection object containing the parameters to pass to the drillthrough report.

See Also

Reference

Drillthrough Class
Drillthrough Members


ReportName Property (Drillthrough)

ReportName Property (Drillthrough)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Drillthrough Class : ReportName Property

Gets or sets a String value representing the path of the drillthrough report. Paths may be absolute or relative.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportName As System.String
public System.string ReportName {get; set;}

Property Value

A String value representing the path to the drillthrough report. The path may be absolute (i.e. "/orderentry/processedorders"), or relative (i.e. "processedorders").

See Also

Reference

Drillthrough Class
Drillthrough Members


DynamicCategoriesSeries Class

DynamicCategoriesSeries Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DynamicCategoriesSeries Class
Defines a Series level that repeats with each Series group in the rowset of the chart.
Object Model
DynamicCategoriesSeries Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DynamicCategoriesSeries
public sealed class DynamicCategoriesSeries
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.DynamicCategoriesSeries

See Also

Reference

DynamicCategoriesSeries Members
GrapeCity.ActiveReports.PageReportModel Namespace


DynamicCategoriesSeries Class Members

DynamicCategoriesSeries Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DynamicCategoriesSeries Class

The following tables list the members exposed by DynamicCategoriesSeries.

Public Constructors
 | Name | Description
Public Constructor | DynamicCategoriesSeries Constructor | Initializes a new instance of the DynamicCategoriesSeries class.
Top
Public Properties
 | Name | Description
Public Property | Grouping | Gets or sets the expressions by which to group the data.
Public Property | Label | Gets or sets the label displayed on the legend.
Public Property | Sorting | Gets the expression by which to sort the columns or data.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DynamicCategoriesSeries object.
Top
See Also

Reference

DynamicCategoriesSeries Class
GrapeCity.ActiveReports.PageReportModel Namespace


DynamicCategoriesSeries Constructor

DynamicCategoriesSeries Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicCategoriesSeries Class : DynamicCategoriesSeries Constructor
Initializes a new instance of the DynamicCategoriesSeries class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DynamicCategoriesSeries()
See Also

Reference

DynamicCategoriesSeries Class
DynamicCategoriesSeries Members


DynamicCategoriesSeries Class Methods

DynamicCategoriesSeries Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DynamicCategoriesSeries Class

For a list of all members of this type, see DynamicCategoriesSeries members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DynamicCategoriesSeries object.
Top
See Also

Reference

DynamicCategoriesSeries Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (DynamicCategoriesSeries)

Validate Method (DynamicCategoriesSeries)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicCategoriesSeries Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DynamicCategoriesSeries object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

DynamicCategoriesSeries Class
DynamicCategoriesSeries Members


DynamicCategoriesSeries Class Properties

DynamicCategoriesSeries Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DynamicCategoriesSeries Class

For a list of all members of this type, see DynamicCategoriesSeries members.

Public Properties
 | Name | Description
Public Property | Grouping | Gets or sets the expressions by which to group the data.
Public Property | Label | Gets or sets the label displayed on the legend.
Public Property | Sorting | Gets the expression by which to sort the columns or data.
Top
See Also

Reference

DynamicCategoriesSeries Class
GrapeCity.ActiveReports.PageReportModel Namespace


Grouping Property (DynamicCategoriesSeries)

Grouping Property (DynamicCategoriesSeries)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicCategoriesSeries Class : Grouping Property

Gets or sets the expressions by which to group the data.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Grouping As Grouping
public Grouping Grouping {get; set;}

Property Value

A Grouping object containing the expressions by which to group the data.

Remarks
Page breaks in the grouping are not allowed.
See Also

Reference

DynamicCategoriesSeries Class
DynamicCategoriesSeries Members


Label Property (DynamicCategoriesSeries)

Label Property (DynamicCategoriesSeries)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicCategoriesSeries Class : Label Property

Gets or sets the label displayed on the legend.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Label As ExpressionInfo
public ExpressionInfo Label {get; set;}

Property Value

An ExpressionInfo object indicating the label displayed on the legend.
See Also

Reference

DynamicCategoriesSeries Class
DynamicCategoriesSeries Members


Sorting Property (DynamicCategoriesSeries)

Sorting Property (DynamicCategoriesSeries)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicCategoriesSeries Class : Sorting Property

Gets the expression by which to sort the columns or data.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Sorting As SortByCollection
public SortByCollection Sorting {get;}

Property Value

A SortByCollection object containing the expression by which to sort the columns or data.

See Also

Reference

DynamicCategoriesSeries Class
DynamicCategoriesSeries Members


DynamicColumnsRows Class

DynamicColumnsRows Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DynamicColumnsRows Class
Defines a column or row header region that repeats with each column or row group in the rowset of a Matrix.
Object Model
DynamicColumnsRows Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DynamicColumnsRows
   Inherits ReportComponentContainer
   Implements IRdlContainer, IReportComponent, IReportComponentContainer
public sealed class DynamicColumnsRows : ReportComponentContainer, IRdlContainer, IReportComponent, IReportComponentContainer
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer
GrapeCity.ActiveReports.PageReportModel.DynamicColumnsRows

See Also

Reference

DynamicColumnsRows Members
GrapeCity.ActiveReports.PageReportModel Namespace


DynamicColumnsRows Class Members

DynamicColumnsRows Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DynamicColumnsRows Class

The following tables list the members exposed by DynamicColumnsRows.

Public Constructors
 | Name | Description
Public Constructor | DynamicColumnsRows Constructor | Initializes a new instance of the DynamicColumnsRows class.
Top
Public Properties
 | Name | Description
Public Property | Components | Overridden. Gets the components.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Grouping | Gets or sets the expressions by which to group the data.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportItems | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportItemCollection containing all the ReportItems in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Sorting | Gets or sets the expressions by which to sort the columns or rows.
Public Property | Subtotal | Gets or sets an automatic subtotal for the column or row.
Public Property | Visibility | Gets or sets a value indicating whether all of the dynamic columns or rows for this grouping are hidden and replaced with a subtotal column for the grouping scope.
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the resources used by the DynamicColumnsRows. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the DynamicColumnsRows object.
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

DynamicColumnsRows Class
GrapeCity.ActiveReports.PageReportModel Namespace


DynamicColumnsRows Constructor

DynamicColumnsRows Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicColumnsRows Class : DynamicColumnsRows Constructor
Initializes a new instance of the DynamicColumnsRows class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DynamicColumnsRows()
See Also

Reference

DynamicColumnsRows Class
DynamicColumnsRows Members


DynamicColumnsRows Class Methods

DynamicColumnsRows Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DynamicColumnsRows Class

For a list of all members of this type, see DynamicColumnsRows members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Releases the resources used by the DynamicColumnsRows. (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the DynamicColumnsRows object.
Top
See Also

Reference

DynamicColumnsRows Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (DynamicColumnsRows)

Validate Method (DynamicColumnsRows)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicColumnsRows Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DynamicColumnsRows object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

DynamicColumnsRows Class
DynamicColumnsRows Members


DynamicColumnsRows Class Properties

DynamicColumnsRows Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DynamicColumnsRows Class

For a list of all members of this type, see DynamicColumnsRows members.

Public Properties
 | Name | Description
Public Property | Components | Overridden. Gets the components.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Grouping | Gets or sets the expressions by which to group the data.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportItems | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportItemCollection containing all the ReportItems in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Sorting | Gets or sets the expressions by which to sort the columns or rows.
Public Property | Subtotal | Gets or sets an automatic subtotal for the column or row.
Public Property | Visibility | Gets or sets a value indicating whether all of the dynamic columns or rows for this grouping are hidden and replaced with a subtotal column for the grouping scope.
Top
See Also

Reference

DynamicColumnsRows Class
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property (DynamicColumnsRows)

Components Property (DynamicColumnsRows)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicColumnsRows Class : Components Property
Gets the components.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable ReadOnly Property Components As ReportComponentCollection
public override ReportComponentCollection Components {get;}

Property Value

The components.
See Also

Reference

DynamicColumnsRows Class
DynamicColumnsRows Members


Grouping Property (DynamicColumnsRows)

Grouping Property (DynamicColumnsRows)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicColumnsRows Class : Grouping Property

Gets or sets the expressions by which to group the data.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Grouping As Grouping
public Grouping Grouping {get; set;}

Property Value

A Grouping object containing the expressions by which to group the data.

See Also

Reference

DynamicColumnsRows Class
DynamicColumnsRows Members


Sorting Property (DynamicColumnsRows)

Sorting Property (DynamicColumnsRows)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicColumnsRows Class : Sorting Property

Gets or sets the expressions by which to sort the columns or rows.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Sorting As SortByCollection
public SortByCollection Sorting {get;}

Property Value

A SortByCollection object containing the expression by which to sort the columns or rows.

See Also

Reference

DynamicColumnsRows Class
DynamicColumnsRows Members


Subtotal Property

Subtotal Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicColumnsRows Class : Subtotal Property

Gets or sets an automatic subtotal for the column or row.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Subtotal As Subtotal
public Subtotal Subtotal {get; set;}

Property Value

A Subtotal object containing an automatic subtotal for the column or row.

See Also

Reference

DynamicColumnsRows Class
DynamicColumnsRows Members


Visibility Property (DynamicColumnsRows)

Visibility Property (DynamicColumnsRows)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicColumnsRows Class : Visibility Property

Gets or sets a value indicating whether all of the dynamic columns or rows for this grouping are hidden and replaced with a subtotal column for the grouping scope.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visibility As Visibility
public Visibility Visibility {get; set;}

Property Value

A Boolean value where true indicates that all of the dynamic columns or rows for this grouping are hidden; otherwise false. The default value is false.

See Also

Reference

DynamicColumnsRows Class
DynamicColumnsRows Members


EmbeddedImage Class

EmbeddedImage Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : EmbeddedImage Class
Specifies information about an image embedded in the report definition.
Object Model
EmbeddedImage Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class EmbeddedImage
public sealed class EmbeddedImage
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.EmbeddedImage

See Also

Reference

EmbeddedImage Members
GrapeCity.ActiveReports.PageReportModel Namespace


EmbeddedImage Class Members

EmbeddedImage Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : EmbeddedImage Class

The following tables list the members exposed by EmbeddedImage.

Public Constructors
 | Name | Description
Public Constructor | EmbeddedImage Constructor | Initializes a new instance of the EmbeddedImage class.
Top
Public Properties
 | Name | Description
Public Property | ImageData | Gets or sets the Base-64 encoded image data.
Public Property | MIMEType | Gets or sets the MIME type of the image.
Public Property | Name | Gets or sets the name of the image.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the EmbeddedImage object.
Top
See Also

Reference

EmbeddedImage Class
GrapeCity.ActiveReports.PageReportModel Namespace


EmbeddedImage Constructor

EmbeddedImage Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedImage Class : EmbeddedImage Constructor

Initializes a new instance of the EmbeddedImage class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public EmbeddedImage()
See Also

Reference

EmbeddedImage Class
EmbeddedImage Members


EmbeddedImage Class Methods

EmbeddedImage Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : EmbeddedImage Class

For a list of all members of this type, see EmbeddedImage members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the EmbeddedImage object.
Top
See Also

Reference

EmbeddedImage Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (EmbeddedImage)

Validate Method (EmbeddedImage)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedImage Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the EmbeddedImage object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

EmbeddedImage Class
EmbeddedImage Members


EmbeddedImage Class Properties

EmbeddedImage Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : EmbeddedImage Class

For a list of all members of this type, see EmbeddedImage members.

Public Properties
 | Name | Description
Public Property | ImageData | Gets or sets the Base-64 encoded image data.
Public Property | MIMEType | Gets or sets the MIME type of the image.
Public Property | Name | Gets or sets the name of the image.
Top
See Also

Reference

EmbeddedImage Class
GrapeCity.ActiveReports.PageReportModel Namespace


ImageData Property

ImageData Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedImage Class : ImageData Property

Gets or sets the Base-64 encoded image data.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ImageData As System.String
public System.string ImageData {get; set;}

Property Value

A String indicating the Base-64 encoded image data.

A String indicating the Base-64 encoded image data.

See Also

Reference

EmbeddedImage Class
EmbeddedImage Members


MIMEType Property (EmbeddedImage)

MIMEType Property (EmbeddedImage)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedImage Class : MIMEType Property

Gets or sets the MIME type of the image.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MIMEType As System.String
public System.string MIMEType {get; set;}

Property Value

A String indicating the MIME type of the image.

Remarks
Valid values are image/bmp, image/jpeg, image/gif, image/png, and image/x-png.
See Also

Reference

EmbeddedImage Class
EmbeddedImage Members


Name Property (EmbeddedImage)

Name Property (EmbeddedImage)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedImage Class : Name Property

Gets or sets the name of the image.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}

Property Value

A String indicating the name of the image.

See Also

Reference

EmbeddedImage Class
EmbeddedImage Members


EmbeddedImageCollection Class

EmbeddedImageCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : EmbeddedImageCollection Class
Provides a strongly typed collection for EmbeddedImage objects.
Object Model
EmbeddedImageCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class EmbeddedImageCollection
   Inherits System.Collections.CollectionBase
public sealed class EmbeddedImageCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.EmbeddedImageCollection

Requirements

See Also

Reference

EmbeddedImageCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


EmbeddedImageCollection Class Members

EmbeddedImageCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : EmbeddedImageCollection Class

The following tables list the members exposed by EmbeddedImageCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.` (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific EmbeddedImage object in the EmbeddedImageCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds an EmbeddedImage object to the EmbeddedImageCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific EmbeddedImage object in the EmbeddedImageCollection.
Public Method | Remove | Removes the specified EmbeddedImage object from the EmbeddedImageCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

EmbeddedImageCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


EmbeddedImageCollection Class Methods

EmbeddedImageCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : EmbeddedImageCollection Class

For a list of all members of this type, see EmbeddedImageCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds an EmbeddedImage object to the EmbeddedImageCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific EmbeddedImage object in the EmbeddedImageCollection.
Public Method | Remove | Removes the specified EmbeddedImage object from the EmbeddedImageCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

EmbeddedImageCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (EmbeddedImageCollection)

Add Method (EmbeddedImageCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedImageCollection Class : Add Method
The EmbeddedImage object to add to the collection.
Adds an EmbeddedImage object to the EmbeddedImageCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As EmbeddedImage _
) As System.Integer
public System.int Add(
   EmbeddedImage value
)

Parameters

value
The EmbeddedImage object to add to the collection.

Return Value

A new EmbeddedImage object.
See Also

Reference

EmbeddedImageCollection Class
EmbeddedImageCollection Members


IndexOf Method (EmbeddedImageCollection)

IndexOf Method (EmbeddedImageCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedImageCollection Class : IndexOf Method

The EmbeddedImage object to locate in the EmbeddedImageCollection.

Determines the index of a specific EmbeddedImage object in the EmbeddedImageCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As EmbeddedImage _
) As System.Integer
public System.int IndexOf(
   EmbeddedImage value
)

Parameters

value

The EmbeddedImage object to locate in the EmbeddedImageCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

EmbeddedImageCollection Class
EmbeddedImageCollection Members


Remove Method (EmbeddedImageCollection)

Remove Method (EmbeddedImageCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedImageCollection Class : Remove Method

The EmbeddedImage object to remove.

Removes the specified EmbeddedImage object from the EmbeddedImageCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As EmbeddedImage _
)
public void Remove(
   EmbeddedImage value
)

Parameters

value

The EmbeddedImage object to remove.

See Also

Reference

EmbeddedImageCollection Class
EmbeddedImageCollection Members


EmbeddedImageCollection Class Properties

EmbeddedImageCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : EmbeddedImageCollection Class

For a list of all members of this type, see EmbeddedImageCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.` (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific EmbeddedImage object in the EmbeddedImageCollection by position.
Top
See Also

Reference

EmbeddedImageCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (EmbeddedImageCollection)

Item Property (EmbeddedImageCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedImageCollection Class : Item Property
A zero-based Integer indicating the index of the EmbeddedImage to return or set.
Gets or sets a specific EmbeddedImage object in the EmbeddedImageCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As EmbeddedImage
public EmbeddedImage this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the EmbeddedImage to return or set.

Property Value

The EmbeddedImage object at the specified position.
See Also

Reference

EmbeddedImageCollection Class
EmbeddedImageCollection Members


EmbeddedStyleSheet Class

EmbeddedStyleSheet Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : EmbeddedStyleSheet Class
Specifies information about an stylesheet embedded to the report definition.
Object Model
EmbeddedStyleSheet Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class EmbeddedStyleSheet
public sealed class EmbeddedStyleSheet
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.EmbeddedStyleSheet

See Also

Reference

EmbeddedStyleSheet Members
GrapeCity.ActiveReports.PageReportModel Namespace


EmbeddedStyleSheet Class Members

EmbeddedStyleSheet Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : EmbeddedStyleSheet Class

The following tables list the members exposed by EmbeddedStyleSheet.

Public Constructors
 | Name | Description
Public Constructor | EmbeddedStyleSheet Constructor | Initializes a new instance of the EmbeddedStyleSheet class.
Top
Public Properties
 | Name | Description
Public Property | Data | Gets or sets the EmbeddedStyleSheet data in XML format.
Public Property | Name | Gets or sets the name of the EmbeddedStyleSheet.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the EmbeddedStyleSheet object.
Top
See Also

Reference

EmbeddedStyleSheet Class
GrapeCity.ActiveReports.PageReportModel Namespace


EmbeddedStyleSheet Constructor

EmbeddedStyleSheet Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedStyleSheet Class : EmbeddedStyleSheet Constructor
The name of the EmbeddedStyleSheet.
The StyleSheet instance.
Initializes a new instance of the EmbeddedStyleSheet class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As System.String, _
   ByVal styleSheet As StyleSheet _
)
public EmbeddedStyleSheet(
   System.string name,
   StyleSheet styleSheet
)

Parameters

name
The name of the EmbeddedStyleSheet.
styleSheet
The StyleSheet instance.
See Also

Reference

EmbeddedStyleSheet Class
EmbeddedStyleSheet Members


EmbeddedStyleSheet Class Methods

EmbeddedStyleSheet Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : EmbeddedStyleSheet Class

For a list of all members of this type, see EmbeddedStyleSheet members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the EmbeddedStyleSheet object.
Top
See Also

Reference

EmbeddedStyleSheet Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (EmbeddedStyleSheet)

Validate Method (EmbeddedStyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedStyleSheet Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the EmbeddedStyleSheet object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

EmbeddedStyleSheet Class
EmbeddedStyleSheet Members


EmbeddedStyleSheet Class Properties

EmbeddedStyleSheet Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : EmbeddedStyleSheet Class

For a list of all members of this type, see EmbeddedStyleSheet members.

Public Properties
 | Name | Description
Public Property | Data | Gets or sets the EmbeddedStyleSheet data in XML format.
Public Property | Name | Gets or sets the name of the EmbeddedStyleSheet.
Top
See Also

Reference

EmbeddedStyleSheet Class
GrapeCity.ActiveReports.PageReportModel Namespace


Data Property (EmbeddedStyleSheet)

Data Property (EmbeddedStyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedStyleSheet Class : Data Property
Gets or sets the EmbeddedStyleSheet data in XML format.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Data As System.String
public System.string Data {get; set;}
See Also

Reference

EmbeddedStyleSheet Class
EmbeddedStyleSheet Members


Name Property (EmbeddedStyleSheet)

Name Property (EmbeddedStyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedStyleSheet Class : Name Property
Gets or sets the name of the EmbeddedStyleSheet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}
See Also

Reference

EmbeddedStyleSheet Class
EmbeddedStyleSheet Members


Field Class

Field Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Field Class
Defines a field element containing information about a field within the data model of the report.
Object Model
Field Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Field
public class Field
Remarks

A Field must have either a DataField or Value property set, but not both.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Field

See Also

Reference

Field Members
GrapeCity.ActiveReports.PageReportModel Namespace


Field Class Members

Field Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Field Class

The following tables list the members exposed by Field.

Public Constructors
 | Name | Description
Public Constructor | Field Constructor | Overloaded. Initializes a new instance of the Field class.
Top
Public Properties
 | Name | Description
Public Property | DataField | Gets or sets the name of the field in the query.
Public Property | Name | Gets or sets the name to use for the field within the report.
Public Property | Value | Gets or sets an expression that evaluates to the value of the field.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the Field object
Top
See Also

Reference

Field Class
GrapeCity.ActiveReports.PageReportModel Namespace


Field Constructor

Field Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Field Class : Field Constructor
Initializes a new instance of the Field class.
Overload List
Overload | Description
Field Constructor() | Initializes a new instance of the Field class with the specified Name, DataField, and Value.
Field Constructor(String,String,ExpressionInfo) | Initializes a new instance of the Field class with the specified Name, DataField, and Value.
See Also

Reference

Field Class
Field Members


Field Constructor()

Field Constructor()

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Field Class > Field Constructor : Field Constructor()

Initializes a new instance of the Field class with the specified Name, DataField, and Value.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Field()
See Also

Reference

Field Class
Field Members
Overload List


Field Constructor(String,String,ExpressionInfo)

Field Constructor(String,String,ExpressionInfo)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Field Class > Field Constructor : Field Constructor(String,String,ExpressionInfo)
The System.String indicating the name to use for the field.
The System.String indicating the data field to use.
The GrapeCity.ActiveReports.Expressions.ExpressionInfo object that evaluates to the value of the field.

Initializes a new instance of the Field class with the specified Name, DataField, and Value.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As System.String, _
   ByVal dataField As System.String, _
   ByVal value As ExpressionInfo _
)
public Field(
   System.string name,
   System.string dataField,
   ExpressionInfo value
)

Parameters

name
The System.String indicating the name to use for the field.
dataField
The System.String indicating the data field to use.
value
The GrapeCity.ActiveReports.Expressions.ExpressionInfo object that evaluates to the value of the field.
See Also

Reference

Field Class
Field Members
Overload List


Field Class Methods

Field Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Field Class

For a list of all members of this type, see Field members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the Field object
Top
See Also

Reference

Field Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (Field)

Validate Method (Field)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Field Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the Field object
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

Field Class
Field Members


Field Class Properties

Field Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Field Class

For a list of all members of this type, see Field members.

Public Properties
 | Name | Description
Public Property | DataField | Gets or sets the name of the field in the query.
Public Property | Name | Gets or sets the name to use for the field within the report.
Public Property | Value | Gets or sets an expression that evaluates to the value of the field.
Top
See Also

Reference

Field Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataField Property (Field)

DataField Property (Field)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Field Class : DataField Property

Gets or sets the name of the field in the query.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataField As System.String
public System.string DataField {get; set;}

Property Value

A String containing the name of the field in the query.

Remarks

Data field names do not need to be unique. Multiple fields can refer to the same data field.

See Also

Reference

Field Class
Field Members


Name Property (Field)

Name Property (Field)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Field Class : Name Property

Gets or sets the name to use for the field within the report.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}

Property Value

A String containing the name to use for the field within a report.

Remarks

Field names need only be unique within the containing Fields collection.

See Also

Reference

Field Class
Field Members


Value Property (Field)

Value Property (Field)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Field Class : Value Property

Gets or sets an expression that evaluates to the value of the field.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As ExpressionInfo
public ExpressionInfo Value {get; set;}

Property Value

An ExpressionInfo object containing the expression that evaluates to the value of the field.

Remarks

For example: =Fields!Quantity.Value+Fields!UnitPrice.Value

The expression cannot contain aggregates or references to report items.

Expressions are fully described in the Expressions namespace.

See Also

Reference

Field Class
Field Members


FieldCollection Class

FieldCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : FieldCollection Class
Provides a strongly typed collection for Field objects.
Object Model
FieldCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class FieldCollection
   Inherits System.Collections.CollectionBase
public sealed class FieldCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.FieldCollection

See Also

Reference

FieldCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


FieldCollection Class Members

FieldCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : FieldCollection Class

The following tables list the members exposed by FieldCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.` (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific Field object in the FieldCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a Field object to the FieldCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific Field object in the FieldCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

FieldCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


FieldCollection Class Methods

FieldCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : FieldCollection Class

For a list of all members of this type, see FieldCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a Field object to the FieldCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific Field object in the FieldCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

FieldCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (FieldCollection)

Add Method (FieldCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > FieldCollection Class : Add Method

The Field object to add to the collection.

Adds a Field object to the FieldCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As Field _
) As System.Integer
public System.int Add(
   Field value
)

Parameters

value

The Field object to add to the collection.

Return Value

A new Field object.
See Also

Reference

FieldCollection Class
FieldCollection Members


IndexOf Method (FieldCollection)

IndexOf Method (FieldCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > FieldCollection Class : IndexOf Method

The Field object to locate in the FieldCollection.

Determines the index of a specific Field object in the FieldCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As Field _
) As System.Integer
public System.int IndexOf(
   Field value
)

Parameters

value

The Field object to locate in the FieldCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

FieldCollection Class
FieldCollection Members


FieldCollection Class Properties

FieldCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : FieldCollection Class

For a list of all members of this type, see FieldCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.` (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific Field object in the FieldCollection by position.
Top
See Also

Reference

FieldCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (FieldCollection)

Item Property (FieldCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > FieldCollection Class : Item Property
A zero-based Integer indicating the index of the Field object to return or set.
Gets or sets a specific Field object in the FieldCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As Field
public Field this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the Field object to return or set.

Property Value

The Field object at the specified position.
See Also

Reference

FieldCollection Class
FieldCollection Members


Filter Class

Filter Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Filter Class
Defines a Filter element which describes a filter to apply to rows of data in a dataset or data region, or to apply to the group instances.
Object Model
Filter Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Filter
public sealed class Filter
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Filter

See Also

Reference

Filter Members
GrapeCity.ActiveReports.PageReportModel Namespace


Filter Class Members

Filter Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Filter Class

The following tables list the members exposed by Filter.

Public Constructors
 | Name | Description
Public Constructor | Filter Constructor | Initializes a new instance of the Filter class.
Top
Public Properties
 | Name | Description
Public Property | FilterExpression | Gets or sets an expression that is evaluated for each instance within the group or each row of the dataset or data region and compared (via the Operator) to the FilterValues.
Public Property | FilterValues | Gets the values to compare to the FilterExpression.
Public Property | Operator | Gets or sets the operator used when comparing the FilterExpression to the FilterValues.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the Filter object.
Top
See Also

Reference

Filter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Filter Constructor

Filter Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Filter Class : Filter Constructor
Initializes a new instance of the Filter class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Filter()
See Also

Reference

Filter Class
Filter Members


Filter Class Methods

Filter Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Filter Class

For a list of all members of this type, see Filter members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the Filter object.
Top
See Also

Reference

Filter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (Filter)

Validate Method (Filter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Filter Class : Validate Method

The ValidationContext object containing the contextual information used to drive the validation.

Validates the information in each property of the Filter object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context

The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

Filter Class
Filter Members


Filter Class Properties

Filter Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Filter Class

For a list of all members of this type, see Filter members.

Public Properties
 | Name | Description
Public Property | FilterExpression | Gets or sets an expression that is evaluated for each instance within the group or each row of the dataset or data region and compared (via the Operator) to the FilterValues.
Public Property | FilterValues | Gets the values to compare to the FilterExpression.
Public Property | Operator | Gets or sets the operator used when comparing the FilterExpression to the FilterValues.
Top
See Also

Reference

Filter Class
GrapeCity.ActiveReports.PageReportModel Namespace


FilterExpression Property

FilterExpression Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Filter Class : FilterExpression Property

Gets or sets an expression that is evaluated for each instance within the group or each row of the dataset or data region and compared (via the Operator) to the FilterValues.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FilterExpression As ExpressionInfo
public ExpressionInfo FilterExpression {get; set;}

Property Value

An ExpressionInfo object that is evaluated for each instance within the group or each row of the dataset or data region and compared (via the Operator) to the FilterValues.

Remarks

Failed comparisons result in the row or instance being filtered out of the dataset, data region or grouping.

See Also

Reference

Filter Class
Filter Members


FilterValues Property

FilterValues Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Filter Class : FilterValues Property

Gets the values to compare to the FilterExpression.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property FilterValues As ExpressionInfoCollection
public ExpressionInfoCollection FilterValues {get;}

Property Value

An ExpressionInfoCollection object containing the values to compare to the FilterExpression

Remarks

For Equal, Like, NotEqual, GreaterThan, GreaterThanOrEqual, LessThan, LessThanOrEqual, TopN, BottomN, TopPercent and BottomPercent, there must be exactly one FilterValue.

For TopN and BottomN, the FilterValue expression must evaluate to an integer.

For TopPercent and BottomPercent, the FilterValue expresson must evaluate to an integer or a float.

For TopN, BottomN, TopPercent and BottomPercent, the FilterValue expression is evaluated only once: for the first row (after all earlier filters have been applied) in the case of a dataset or data region; a filter for the first group instance (after all earlier filters have been applied) in the case of a group filter.

For Between, there must be exactly two FilterValues.

For In, the FilterValues are treated as a set (if the FilterExpression value appears anywhere in the set of FilterValues, the instance is not filtered out).

Like uses the same special characters as the Visual Basic LIKE operator (e.g. "?" to represent a single character and "*" to represent any series of characters).

See Also

Reference

Filter Class
Filter Members


Operator Property

Operator Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Filter Class : Operator Property

Gets or sets the operator used when comparing the FilterExpression to the FilterValues.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Operator As FilterOperator
public FilterOperator Operator {get; set;}

Property Value

A FilterOperator enumeration of the operator used when comparing the FilterExpression to the FilterValues.

Remarks

Top and Bottom operators include ties in the resulting data.

String comparisons are locale-dependent.

Null equals Null.

See Also

Reference

Filter Class
Filter Members


Footer Class

Footer Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Footer Class
Defines the footer rows for a table or group.
Object Model
Footer Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Footer
   Inherits HeaderFooter
   Implements IReportComponent, IReportComponentContainer
public sealed class Footer : HeaderFooter, IReportComponent, IReportComponentContainer
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.HeaderFooter
GrapeCity.ActiveReports.PageReportModel.Footer

See Also

Reference

Footer Members
GrapeCity.ActiveReports.PageReportModel Namespace


Footer Class Members

Footer Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Footer Class

The following tables list the members exposed by Footer.

Public Constructors
 | Name | Description
Public Constructor | Footer Constructor | Initializes a new instance of the Footer class.
Top
Public Properties
 | Name | Description
Public Property | Components | Gets a ReportComponentCollection object containing all the components hosted in the control. (Inherited from GrapeCity.ActiveReports.PageReportModel.HeaderFooter)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | PrintAtBottom | Gets or sets a value indicating if the rows corresponding to the footer is pushed to bottom by empty rows..
Public Property | RepeatOnNewPage | Gets or sets a value indicating whether the footer or header is displayed on each page on which the table or group is displayed. (Inherited from GrapeCity.ActiveReports.PageReportModel.HeaderFooter)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | TableRows | Gets the footer or header rows for the table or group. (Inherited from GrapeCity.ActiveReports.PageReportModel.HeaderFooter)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the HeaderFooter. (Inherited from GrapeCity.ActiveReports.PageReportModel.HeaderFooter)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Footer Class
GrapeCity.ActiveReports.PageReportModel Namespace


Footer Constructor

Footer Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Footer Class : Footer Constructor

Initializes a new instance of the Footer class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Footer()
See Also

Reference

Footer Class
Footer Members


Footer Class Properties

Footer Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Footer Class

For a list of all members of this type, see Footer members.

Public Properties
 | Name | Description
Public Property | Components | Gets a ReportComponentCollection object containing all the components hosted in the control. (Inherited from GrapeCity.ActiveReports.PageReportModel.HeaderFooter)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | PrintAtBottom | Gets or sets a value indicating if the rows corresponding to the footer is pushed to bottom by empty rows..
Public Property | RepeatOnNewPage | Gets or sets a value indicating whether the footer or header is displayed on each page on which the table or group is displayed. (Inherited from GrapeCity.ActiveReports.PageReportModel.HeaderFooter)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | TableRows | Gets the footer or header rows for the table or group. (Inherited from GrapeCity.ActiveReports.PageReportModel.HeaderFooter)
Top
See Also

Reference

Footer Class
GrapeCity.ActiveReports.PageReportModel Namespace


PrintAtBottom Property (Footer)

PrintAtBottom Property (Footer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Footer Class : PrintAtBottom Property

Gets or sets a value indicating if the rows corresponding to the footer is pushed to bottom by empty rows..

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrintAtBottom As System.Boolean
public System.bool PrintAtBottom {get; set;}

Property Value

A Boolean value where true indicates if the rows corresponding to the footer is pushed to bottom by empty rows. otherwise false. The default value is false.

Remarks
Allowed only with the TableGroup.Footer
See Also

Reference

Footer Class
Footer Members


GridLines Class

GridLines Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : GridLines Class
Defines the style properties for the major and minor gridlines along an axis in a chart.
Object Model
GridLines Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class GridLines
public sealed class GridLines
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.GridLines

See Also

Reference

GridLines Members
GrapeCity.ActiveReports.PageReportModel Namespace


GridLines Class Members

GridLines Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : GridLines Class

The following tables list the members exposed by GridLines.

Public Constructors
 | Name | Description
Public Constructor | GridLines Constructor | Initializes a new instance of the GridLines class.
Top
Public Properties
 | Name | Description
Public Property | ShowGridLines | Gets or sets a value indicating whether the gridlines are shown.
Public Property | Style | Gets or sets the line style properties for the gridlines and tickmarks.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the GridLines object.
Top
See Also

Reference

GridLines Class
GrapeCity.ActiveReports.PageReportModel Namespace


GridLines Constructor

GridLines Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > GridLines Class : GridLines Constructor

Initializes a new instance of the GridLines class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public GridLines()
See Also

Reference

GridLines Class
GridLines Members


GridLines Class Methods

GridLines Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : GridLines Class

For a list of all members of this type, see GridLines members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the GridLines object.
Top
See Also

Reference

GridLines Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (GridLines)

Validate Method (GridLines)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > GridLines Class : Validate Method

TheValidationContext object containing the contextual information used to drive the validation.

Validates the information in each property of the GridLines object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context

TheValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

GridLines Class
GridLines Members


GridLines Class Properties

GridLines Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : GridLines Class

For a list of all members of this type, see GridLines members.

Public Properties
 | Name | Description
Public Property | ShowGridLines | Gets or sets a value indicating whether the gridlines are shown.
Public Property | Style | Gets or sets the line style properties for the gridlines and tickmarks.
Top
See Also

Reference

GridLines Class
GrapeCity.ActiveReports.PageReportModel Namespace


ShowGridLines Property

ShowGridLines Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > GridLines Class : ShowGridLines Property

Gets or sets a value indicating whether the gridlines are shown.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShowGridLines As System.Boolean
public System.bool ShowGridLines {get; set;}

Property Value

A Boolean value where true indicates that the gridlines are shown; otherwise false. The default value is false.

See Also

Reference

GridLines Class
GridLines Members


Style Property (GridLines)

Style Property (GridLines)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > GridLines Class : Style Property

Gets or sets the line style properties for the gridlines and tickmarks.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As Style
public Style Style {get; set;}

Property Value

A Style object containing the line style properties for the gridlines and tickmarks.

See Also

Reference

GridLines Class
GridLines Members


Grouping Class

Grouping Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Grouping Class
Specifies an element that defines the expressions by which to group the data.
Object Model
Grouping Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Grouping
public sealed class Grouping
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Grouping

See Also

Reference

Grouping Members
GrapeCity.ActiveReports.PageReportModel Namespace


Grouping Class Members

Grouping Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Grouping Class

The following tables list the members exposed by Grouping.

Public Constructors
 | Name | Description
Public Constructor | Grouping Constructor | Initializes a new instance of the Grouping class.
Top
Public Properties
 | Name | Description
Public Property | Custom | Gets or sets information to be passed to the report output component.
Public Property | DataCollectionName | Gets or sets the name to use for the data element for the collection of all instances of this group.
Public Property | DataElementName | Gets or sets the name for the data element for instances of this group.
Public Property | DataElementOutput | Gets or sets a value indicating whether the group appears in a data rendering.
Public Property | DomainScope | Specifies the domain scope for grouping.
Public Property | Filters | Gets filters to apply to each instance of the group.
Public Property | GroupExpressions | Gets a set of expressions by which to group the data.
Public Property | Label | Gets or sets a label to identify an instance of the group within the client UI (to provide a user-friendly label for searching).
Public Property | Name | Gets or sets the name of the grouping.
Public Property | NewSection | Gets or sets a value indicating whether the grouping is in it's own section
Public Property | PageBreak | Specifies the page break options for grouping.
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether the report breaks to a new page at the end of the group.
Public Property | PageBreakAtStart | Gets or sets a value indicating whether the report breaks to a new page at the start of the group.
Public Property | PageName | Specifies the page name.
Public Property | Parent | Gets or sets an expression that identifies the parent group in a recursive hierarchy.
Public Property | Variables | Specifies the list of variables.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the Grouping object.
Top
See Also

Reference

Grouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


Grouping Constructor

Grouping Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : Grouping Constructor
Initializes a new instance of the Grouping class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Grouping()
See Also

Reference

Grouping Class
Grouping Members


Grouping Class Methods

Grouping Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Grouping Class

For a list of all members of this type, see Grouping members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the Grouping object.
Top
See Also

Reference

Grouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (Grouping)

Validate Method (Grouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : Validate Method

The ValidationContext object containing the contextual information used to drive the validation.

Validates the information in each property of the Grouping object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context

The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

Grouping Class
Grouping Members


Grouping Class Properties

Grouping Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Grouping Class

For a list of all members of this type, see Grouping members.

Public Properties
 | Name | Description
Public Property | Custom | Gets or sets information to be passed to the report output component.
Public Property | DataCollectionName | Gets or sets the name to use for the data element for the collection of all instances of this group.
Public Property | DataElementName | Gets or sets the name for the data element for instances of this group.
Public Property | DataElementOutput | Gets or sets a value indicating whether the group appears in a data rendering.
Public Property | DomainScope | Specifies the domain scope for grouping.
Public Property | Filters | Gets filters to apply to each instance of the group.
Public Property | GroupExpressions | Gets a set of expressions by which to group the data.
Public Property | Label | Gets or sets a label to identify an instance of the group within the client UI (to provide a user-friendly label for searching).
Public Property | Name | Gets or sets the name of the grouping.
Public Property | NewSection | Gets or sets a value indicating whether the grouping is in it's own section
Public Property | PageBreak | Specifies the page break options for grouping.
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether the report breaks to a new page at the end of the group.
Public Property | PageBreakAtStart | Gets or sets a value indicating whether the report breaks to a new page at the start of the group.
Public Property | PageName | Specifies the page name.
Public Property | Parent | Gets or sets an expression that identifies the parent group in a recursive hierarchy.
Public Property | Variables | Specifies the list of variables.
Top
See Also

Reference

Grouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


Custom Property (Grouping)

Custom Property (Grouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : Custom Property

Gets or sets information to be passed to the report output component.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Custom As Custom
public Custom Custom {get; set;}

Property Value

A Custom object containing information to be passed to the report output component.

See Also

Reference

Grouping Class
Grouping Members


DataCollectionName Property (Grouping)

DataCollectionName Property (Grouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : DataCollectionName Property

Gets or sets the name to use for the data element for the collection of all instances of this group.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataCollectionName As System.String
public System.string DataCollectionName {get; set;}

Property Value

A String indicating the name to use for the data element for the collection of all instances of this group.

Remarks

The default value is "DataElementName_Collection."

See Also

Reference

Grouping Class
Grouping Members


DataElementName Property (Grouping)

DataElementName Property (Grouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : DataElementName Property

Gets or sets the name for the data element for instances of this group.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataElementName As System.String
public System.string DataElementName {get; set;}

Property Value

A String indicating the name to use for the data element for instances of this group.

Remarks

The default value is the name of the group.

See Also

Reference

Grouping Class
Grouping Members


DataElementOutput Property (Grouping)

DataElementOutput Property (Grouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : DataElementOutput Property

Gets or sets a value indicating whether the group appears in a data rendering.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataElementOutput As DataElementOutput
public DataElementOutput DataElementOutput {get; set;}

Property Value

A DataElementOutput enumeration indicating whether the group appears in a data rendering.
Remarks

This property is ignored if there is a grouping for the list.

Output (Default) indicates that the group appears in the output.

NoOutput indicates that the group does not appear in the output.

See Also

Reference

Grouping Class
Grouping Members


DomainScope Property

DomainScope Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : DomainScope Property
Specifies the domain scope for grouping.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DomainScope As System.String
public System.string DomainScope {get; set;}
See Also

Reference

Grouping Class
Grouping Members


Filters Property (Grouping)

Filters Property (Grouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : Filters Property

Gets filters to apply to each instance of the group.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Filters As System.Collections.Generic.IList(Of Filter)
public System.Collections.Generic.IList<Filter> Filters {get;}

Property Value

A FilterCollection object containing filters to apply to each instance of the group.

See Also

Reference

Grouping Class
Grouping Members


GroupExpressions Property

GroupExpressions Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : GroupExpressions Property

Gets a set of expressions by which to group the data.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property GroupExpressions As ExpressionInfoCollection
public ExpressionInfoCollection GroupExpressions {get;}

Property Value

An ExpressionInfoCollection object by which to group the data.

See Also

Reference

Grouping Class
Grouping Members


Label Property (Grouping)

Label Property (Grouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : Label Property

Gets or sets a label to identify an instance of the group within the client UI (to provide a user-friendly label for searching).

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Label As ExpressionInfo
public ExpressionInfo Label {get; set;}

Property Value

An ExpressionInfo object for a label to identify an instance of the group within the client UI.
See Also

Reference

Grouping Class
Grouping Members


Name Property (Grouping)

Name Property (Grouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : Name Property

Gets or sets the name of the grouping.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}

Property Value

A String indicating the name of the grouping.

Remarks

This property is used for RunningValue and RowNumber aggregate functions.

No two grouping elements may have the same name and no grouping element may have the same name as a dataset or a data region.

See Also

Reference

Grouping Class
Grouping Members


NewSection Property (Grouping)

NewSection Property (Grouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : NewSection Property

Gets or sets a value indicating whether the grouping is in it's own section

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NewSection As System.Boolean
public System.bool NewSection {get; set;}

Property Value

A Boolean value indicating whether the grouping is in it's own section. Default value is false.

See Also

Reference

Grouping Class
Grouping Members


PageBreak Property (Grouping)

PageBreak Property (Grouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : PageBreak Property
Specifies the page break options for grouping.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageBreak As PageBreak
public PageBreak PageBreak {get; set;}
See Also

Reference

Grouping Class
Grouping Members


PageBreakAtEnd Property (Grouping)

PageBreakAtEnd Property (Grouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : PageBreakAtEnd Property

Gets or sets a value indicating whether the report breaks to a new page at the end of the group.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageBreakAtEnd As System.Boolean
public System.bool PageBreakAtEnd {get; set;}

Property Value

A Boolean value where true indicates that the report breaks to a new page at the end of the group; otherwise false. The default value is false.

Remarks

This property is not valid for column groupings in Matrix regions.

Grouping page breaks on table groups are ignored if the group has no header and no footer, no subgroups have a header or footer and there is no detail row in the table.

See Also

Reference

Grouping Class
Grouping Members


PageBreakAtStart Property (Grouping)

PageBreakAtStart Property (Grouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : PageBreakAtStart Property

Gets or sets a value indicating whether the report breaks to a new page at the start of the group.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageBreakAtStart As System.Boolean
public System.bool PageBreakAtStart {get; set;}

Property Value

A Boolean value where true indicates that the report breaks to a new page at the start of the group; otherwise false. The default value is false.

Remarks

This property is not valid for column groupings in the Matrix regions.

Grouping page breaks on table groups are ignored if the group has no header and no footer, no subgroups have a header or footer and there is no detail row in the table.

See Also

Reference

Grouping Class
Grouping Members


PageName Property (Grouping)

PageName Property (Grouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : PageName Property
Specifies the page name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageName As ExpressionInfo
public ExpressionInfo PageName {get; set;}
See Also

Reference

Grouping Class
Grouping Members


Parent Property (Grouping)

Parent Property (Grouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : Parent Property

Gets or sets an expression that identifies the parent group in a recursive hierarchy.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Parent As ExpressionInfo
public ExpressionInfo Parent {get; set;}

Property Value

An ExpressionInfo object indicating the parent group in a recursive hierarchy.
Remarks

This property only applies if the group has exactly one group expression

Indicates the following:

  1. Groups are sorted according to the recursive hierarchy (sort is still used to sort peer groups).
  2. Labels (in the document map) are indented according to the recursive hierarchy.
  3. Intra-group show/hide toggles items according to the recursive hierarchy (see ToggleItem).

If filters on the group eliminate the parent of a group instance, it is instead treated as a child of the parent's parent.

See Also

Reference

Grouping Class
Grouping Members


Variables Property

Variables Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Grouping Class : Variables Property
Specifies the list of variables.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Variables As System.Collections.Generic.List(Of Variable)
public System.Collections.Generic.List<Variable> Variables {get;}
See Also

Reference

Grouping Class
Grouping Members


Header Class

Header Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Header Class
Defines the header rows for a table or group.
Object Model
Header Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Header
   Inherits HeaderFooter
   Implements IReportComponent, IReportComponentContainer
public sealed class Header : HeaderFooter, IReportComponent, IReportComponentContainer
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.HeaderFooter
GrapeCity.ActiveReports.PageReportModel.Header

See Also

Reference

Header Members
GrapeCity.ActiveReports.PageReportModel Namespace


Header Class Members

Header Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Header Class

The following tables list the members exposed by Header.

Public Constructors
 | Name | Description
Public Constructor | Header Constructor | Initializes a new instance of the Header class.
Top
Public Properties
 | Name | Description
Public Property | Components | Gets a ReportComponentCollection object containing all the components hosted in the control. (Inherited from GrapeCity.ActiveReports.PageReportModel.HeaderFooter)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | FixedHeader | Gets or sets a value indicating whether the header should be displayed on the page even when the user scrolls part of the table off the page.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | RepeatOnNewPage | Gets or sets a value indicating whether the footer or header is displayed on each page on which the table or group is displayed. (Inherited from GrapeCity.ActiveReports.PageReportModel.HeaderFooter)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | TableRows | Gets the footer or header rows for the table or group. (Inherited from GrapeCity.ActiveReports.PageReportModel.HeaderFooter)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the HeaderFooter. (Inherited from GrapeCity.ActiveReports.PageReportModel.HeaderFooter)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Header Class
GrapeCity.ActiveReports.PageReportModel Namespace


Header Constructor

Header Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Header Class : Header Constructor
Initializes a new instance of the Header class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Header()
See Also

Reference

Header Class
Header Members


Header Class Properties

Header Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Header Class

For a list of all members of this type, see Header members.

Public Properties
 | Name | Description
Public Property | Components | Gets a ReportComponentCollection object containing all the components hosted in the control. (Inherited from GrapeCity.ActiveReports.PageReportModel.HeaderFooter)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | FixedHeader | Gets or sets a value indicating whether the header should be displayed on the page even when the user scrolls part of the table off the page.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | RepeatOnNewPage | Gets or sets a value indicating whether the footer or header is displayed on each page on which the table or group is displayed. (Inherited from GrapeCity.ActiveReports.PageReportModel.HeaderFooter)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | TableRows | Gets the footer or header rows for the table or group. (Inherited from GrapeCity.ActiveReports.PageReportModel.HeaderFooter)
Top
See Also

Reference

Header Class
GrapeCity.ActiveReports.PageReportModel Namespace


FixedHeader Property (Header)

FixedHeader Property (Header)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Header Class : FixedHeader Property

Gets or sets a value indicating whether the header should be displayed on the page even when the user scrolls part of the table off the page.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FixedHeader As System.Boolean
public System.bool FixedHeader {get; set;}

Property Value

A Boolean value where true indicates the header should be displayed on the page even when the user scrolls part of the table off the page; otherwise false. The default value is false.

Remarks
Allowed only with the Table.Header
See Also

Reference

Header Class
Header Members


HeaderFooter Class

HeaderFooter Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : HeaderFooter Class
Defines the header or footer rows for a table or group.
Object Model
HeaderFooter Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class HeaderFooter
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer
public class HeaderFooter : ReportComponent, IReportComponent, IReportComponentContainer
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.HeaderFooter
GrapeCity.ActiveReports.PageReportModel.Footer
GrapeCity.ActiveReports.PageReportModel.Header

See Also

Reference

HeaderFooter Members
GrapeCity.ActiveReports.PageReportModel Namespace


HeaderFooter Class Members

HeaderFooter Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : HeaderFooter Class

The following tables list the members exposed by HeaderFooter.

Public Properties
 | Name | Description
Public Property | Components | Gets a ReportComponentCollection object containing all the components hosted in the control.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | RepeatOnNewPage | Gets or sets a value indicating whether the footer or header is displayed on each page on which the table or group is displayed.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | TableRows | Gets the footer or header rows for the table or group.
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the HeaderFooter.
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

HeaderFooter Class
GrapeCity.ActiveReports.PageReportModel Namespace


HeaderFooter Class Methods

HeaderFooter Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : HeaderFooter Class

For a list of all members of this type, see HeaderFooter members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the HeaderFooter.
Top
See Also

Reference

HeaderFooter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (HeaderFooter)

Validate Method (HeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > HeaderFooter Class : Validate Method

The ValidationContext object containing the contextual information used to drive the validation.

Validates the information in each property of the HeaderFooter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context

The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

HeaderFooter Class
HeaderFooter Members


HeaderFooter Class Properties

HeaderFooter Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : HeaderFooter Class

For a list of all members of this type, see HeaderFooter members.

Public Properties
 | Name | Description
Public Property | Components | Gets a ReportComponentCollection object containing all the components hosted in the control.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | RepeatOnNewPage | Gets or sets a value indicating whether the footer or header is displayed on each page on which the table or group is displayed.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | TableRows | Gets the footer or header rows for the table or group.
Top
See Also

Reference

HeaderFooter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property (HeaderFooter)

Components Property (HeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > HeaderFooter Class : Components Property
Gets a ReportComponentCollection object containing all the components hosted in the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Components As ReportComponentCollection
public ReportComponentCollection Components {get;}

Property Value

A read-only DataDynamics.Reports.ReportObjectModel.Rdl.ReportComponentCollection object containing all the components hosted in the control.
See Also

Reference

HeaderFooter Class
HeaderFooter Members


RepeatOnNewPage Property (HeaderFooter)

RepeatOnNewPage Property (HeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > HeaderFooter Class : RepeatOnNewPage Property

Gets or sets a value indicating whether the footer or header is displayed on each page on which the table or group is displayed.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RepeatOnNewPage As System.Boolean
public System.bool RepeatOnNewPage {get; set;}

Property Value

A Boolean value where true indicates that the footer or header is displayed on each page on which the table or group is displayed; otherwise false. The default value is false.

See Also

Reference

HeaderFooter Class
HeaderFooter Members


TableRows Property (HeaderFooter)

TableRows Property (HeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > HeaderFooter Class : TableRows Property

Gets the footer or header rows for the table or group.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TableRows As TableRowCollection
public TableRowCollection TableRows {get;}

Property Value

A TableRowCollection object containing the footer or header rows for the table or group.
See Also

Reference

HeaderFooter Class
HeaderFooter Members


Image Class

Image Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Image Class
Specifies an image ReportItem contained in the report definition.
Object Model
Image Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Image
   Inherits ReportItem
   Implements IReportComponent
public sealed class Image : ReportItem, IReportComponent
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.Image

See Also

Reference

Image Members
GrapeCity.ActiveReports.PageReportModel Namespace


Image Class Members

Image Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Image Class

The following tables list the members exposed by Image.

Public Constructors
 | Name | Description
Public Constructor | Image Constructor | Initializes a new instance of the Image class.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment of the picture inside the image report item.
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | MIMEType | Gets or sets the MIME type of the image.
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Sizing | Gets or sets a value indicating the how the image is rendered if it does not fit within the defined size.
Public Property | Source | Gets or sets the source of the image.
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Value | Gets or sets the value of the image. See the Source property for more information.
Public Property | VerticalAlignment | Gets or sets the vertical alignment of the picture inside the image report item.
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Overridden. Validates the information in each property of the Image object.
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Image Class
GrapeCity.ActiveReports.PageReportModel Namespace


Image Constructor

Image Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : Image Constructor
Initializes a new instance of the Image class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Image()
See Also

Reference

Image Class
Image Members


Image Class Methods

Image Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Image Class

For a list of all members of this type, see Image members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Overridden. Validates the information in each property of the Image object.
Top
See Also

Reference

Image Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (Image)

Validate Method (Image)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the Image object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

Image Class
Image Members


Image Class Properties

Image Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Image Class

For a list of all members of this type, see Image members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | HorizontalAlignment | Gets or sets the horizontal alignment of the picture inside the image report item.
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | MIMEType | Gets or sets the MIME type of the image.
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Sizing | Gets or sets a value indicating the how the image is rendered if it does not fit within the defined size.
Public Property | Source | Gets or sets the source of the image.
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Value | Gets or sets the value of the image. See the Source property for more information.
Public Property | VerticalAlignment | Gets or sets the vertical alignment of the picture inside the image report item.
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
See Also

Reference

Image Class
GrapeCity.ActiveReports.PageReportModel Namespace


HorizontalAlignment Property (Image)

HorizontalAlignment Property (Image)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : HorizontalAlignment Property
Gets or sets the horizontal alignment of the picture inside the image report item.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HorizontalAlignment As ExpressionInfo
public ExpressionInfo HorizontalAlignment {get; set;}
See Also

Reference

Image Class
Image Members


MIMEType Property (Image)

MIMEType Property (Image)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : MIMEType Property

Gets or sets the MIME type of the image.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MIMEType As ExpressionInfo
public ExpressionInfo MIMEType {get; set;}

Property Value

An ExpressionInfo object containing the MIME type of the image.
Remarks
Valid values are image/bmp, image/jpeg, image/gif, image/png, and image/x-png. This property is required if the source is set to Database, but ignored otherwise.
See Also

Reference

Image Class
Image Members


Sizing Property (Image)

Sizing Property (Image)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : Sizing Property

Gets or sets a value indicating the how the image is rendered if it does not fit within the defined size.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Sizing As ImageSizing
public ImageSizing Sizing {get; set;}

Property Value

An ImageSizing enumeration indicating how the image is rendered if it does not fit within the defined size.
Remarks

If Sizing is set to AutoSize, the control's borders grow or shrink to match the size of the image.

If Sizing is set to Fit, the image is resized to match the height and width of the control.

If Sizing is set to FitProportional, the image is resized while preserving the aspect ratio to match either the height or width of the control or both.

If Sizing is set to Clip, the image is clipped to fit inside the borders of the control.

Report output formats which do not support FitProportional or Clip substitute Fit.

See Also

Reference

Image Class
Image Members


Source Property (Image)

Source Property (Image)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : Source Property

Gets or sets the source of the image.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Source As ImageSource
public ImageSource Source {get; set;}

Property Value

An ImageSource enumeration indicating the source of the image.
Remarks

If the source is set to External the Value property evaluates to the location of the image.

If the source is set to Embedded the Value property evaluates to the name of the EmbeddedImage in the report.

If the source is set to Database the Value property evaluates to the binary data of the image.

See Also

Reference

Image Class
Image Members


Value Property (Image)

Value Property (Image)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : Value Property

Gets or sets the value of the image. See the Source property for more information.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As ExpressionInfo
public ExpressionInfo Value {get; set;}

Property Value

An ExpressionInfo object containing the value of the image. See the Source property for more information
See Also

Reference

Image Class
Image Members


VerticalAlignment Property (Image)

VerticalAlignment Property (Image)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : VerticalAlignment Property
Gets or sets the vertical alignment of the picture inside the image report item.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property VerticalAlignment As ExpressionInfo
public ExpressionInfo VerticalAlignment {get; set;}
See Also

Reference

Image Class
Image Members


Layer Class

Layer Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Layer Class
Defines a report layer.
Object Model
Layer Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Layer
public class Layer
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Layer

See Also

Reference

Layer Members
GrapeCity.ActiveReports.PageReportModel Namespace


Layer Class Members

Layer Class Members
Fields Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Layer Class

The following tables list the members exposed by Layer.

Public Constructors
 | Name | Description
Public Constructor | Layer Constructor | Initializes a new layer.
Top
Public Fields
 | Name | Description
Public Field | DefaultLayerName | The name of default layer which is always present.
Top
Public Properties
 | Name | Description
Public Property | DesignerLock | Specifies whether elements on this layer are locked on designer surface.
Public Property | DesignerTransparency | Gets or sets the transparency of elements on this layer in designer.
Public Property | DesignerVisible | Specifies whether elements on this layer are visible in designer.
Public Property | Name | Gets or sets a name of layer.
Public Property | TargetDevice | Gets or sets a layer's target device.
Top
Public Methods
 | Name | Description
Public Method | Validate | Performs contextual validation of layer.
Top
See Also

Reference

Layer Class
GrapeCity.ActiveReports.PageReportModel Namespace


Layer Constructor

Layer Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer Class : Layer Constructor
Initializes a new layer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Layer()
See Also

Reference

Layer Class
Layer Members


Layer Class Methods

Layer Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Layer Class

For a list of all members of this type, see Layer members.

Public Methods
 | Name | Description
Public Method | Validate | Performs contextual validation of layer.
Top
See Also

Reference

Layer Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (Layer)

Validate Method (Layer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer Class : Validate Method
The context.
Performs contextual validation of layer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The context.

Return Value

The validation entries.
See Also

Reference

Layer Class
Layer Members


Layer Class Properties

Layer Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Layer Class

For a list of all members of this type, see Layer members.

Public Properties
 | Name | Description
Public Property | DesignerLock | Specifies whether elements on this layer are locked on designer surface.
Public Property | DesignerTransparency | Gets or sets the transparency of elements on this layer in designer.
Public Property | DesignerVisible | Specifies whether elements on this layer are visible in designer.
Public Property | Name | Gets or sets a name of layer.
Public Property | TargetDevice | Gets or sets a layer's target device.
Top
See Also

Reference

Layer Class
GrapeCity.ActiveReports.PageReportModel Namespace


DesignerLock Property

DesignerLock Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer Class : DesignerLock Property
Specifies whether elements on this layer are locked on designer surface.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DesignerLock As System.Boolean
public System.bool DesignerLock {get; set;}
See Also

Reference

Layer Class
Layer Members


DesignerTransparency Property

DesignerTransparency Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer Class : DesignerTransparency Property
Gets or sets the transparency of elements on this layer in designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DesignerTransparency As System.Single
public System.float DesignerTransparency {get; set;}
See Also

Reference

Layer Class
Layer Members


DesignerVisible Property

DesignerVisible Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer Class : DesignerVisible Property
Specifies whether elements on this layer are visible in designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DesignerVisible As System.Boolean
public System.bool DesignerVisible {get; set;}
See Also

Reference

Layer Class
Layer Members


Name Property (Layer)

Name Property (Layer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer Class : Name Property
Gets or sets a name of layer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}
See Also

Reference

Layer Class
Layer Members


TargetDevice Property (Layer)

TargetDevice Property (Layer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer Class : TargetDevice Property
Gets or sets a layer's target device.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TargetDevice As TargetDevices
public TargetDevices TargetDevice {get; set;}
See Also

Reference

Layer Class
Layer Members


Layer Class Fields

Layer Class Fields

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Layer Class

For a list of all members of this type, see Layer members.

Public Fields
 | Name | Description
Public Field | DefaultLayerName | The name of default layer which is always present.
Top
See Also

Reference

Layer Class
GrapeCity.ActiveReports.PageReportModel Namespace


DefaultLayerName Field (Layer)

DefaultLayerName Field (Layer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer Class : DefaultLayerName Field
The name of default layer which is always present.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const DefaultLayerName As System.String
public const System.string DefaultLayerName
See Also

Reference

Layer Class
Layer Members


LayerCollection Class

LayerCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LayerCollection Class
Defines the collection of report layers.
Object Model
LayerCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class LayerCollection
   Inherits System.Collections.CollectionBase
public class LayerCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.LayerCollection

See Also

Reference

LayerCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


LayerCollection Class Members

LayerCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LayerCollection Class

The following tables list the members exposed by LayerCollection.

Public Constructors
 | Name | Description
Public Constructor | LayerCollection Constructor | Initializes a new collection of Layers.
Top
Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | DefaultLayer | The default Layer.
Public Property | IsReadOnly | Gets a value indicating whether the LayerCollection is read-only.
Public Property | Item | Gets or sets the Layer at the specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a Layer to the LayerCollection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the LayerCollection contains a specific value.
Public Method | CopyTo | Copies the elements of the LayerCollection to an System.Array, starting at a particular System.Array index.
Public Method | IndexOf | Determines the index of a specific layer in the LayerCollection.
Public Method | Insert | Inserts a layer to the LayerCollection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific layer from the LayerCollection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Public Method | Validate | Performs contextual validation of report layers.
Top
See Also

Reference

LayerCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


LayerCollection Constructor

LayerCollection Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : LayerCollection Constructor
The Report to which collection belongs.
Initializes a new collection of Layers.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal report As Report _
)
public LayerCollection(
   Report report
)

Parameters

report
The Report to which collection belongs.
See Also

Reference

LayerCollection Class
LayerCollection Members


LayerCollection Class Methods

LayerCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LayerCollection Class

For a list of all members of this type, see LayerCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a Layer to the LayerCollection.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the LayerCollection contains a specific value.
Public Method | CopyTo | Copies the elements of the LayerCollection to an System.Array, starting at a particular System.Array index.
Public Method | IndexOf | Determines the index of a specific layer in the LayerCollection.
Public Method | Insert | Inserts a layer to the LayerCollection at the specified index.
Public Method | Remove | Removes the first occurrence of a specific layer from the LayerCollection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Public Method | Validate | Performs contextual validation of report layers.
Top
See Also

Reference

LayerCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (LayerCollection)

Add Method (LayerCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : Add Method
The Layer to add to the LayerCollection.
Adds a Layer to the LayerCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Add( _
   ByVal item As Layer _
)
public void Add(
   Layer item
)

Parameters

item
The Layer to add to the LayerCollection.
See Also

Reference

LayerCollection Class
LayerCollection Members


Contains Method (LayerCollection)

Contains Method (LayerCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : Contains Method
The Layer to locate in the LayerCollection.
Determines whether the LayerCollection contains a specific value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal item As Layer _
) As System.Boolean
public System.bool Contains(
   Layer item
)

Parameters

item
The Layer to locate in the LayerCollection.

Return Value

true if item is found in the LayerCollection; otherwise, false.
See Also

Reference

LayerCollection Class
LayerCollection Members


CopyTo Method (LayerCollection)

CopyTo Method (LayerCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : CopyTo Method
The array.
Index of the array.
Copies the elements of the LayerCollection to an System.Array, starting at a particular System.Array index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal array() As Layer, _
   ByVal arrayIndex As System.Integer _
)
public void CopyTo(
   Layer[] array,
   System.int arrayIndex
)

Parameters

array
The array.
arrayIndex
Index of the array.
See Also

Reference

LayerCollection Class
LayerCollection Members


IndexOf Method (LayerCollection)

IndexOf Method (LayerCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : IndexOf Method
The Layer to locate in the LayerCollection.
Determines the index of a specific layer in the LayerCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal item As Layer _
) As System.Integer
public System.int IndexOf(
   Layer item
)

Parameters

item
The Layer to locate in the LayerCollection.

Return Value

The index of item if found in the list; otherwise, -1.
See Also

Reference

LayerCollection Class
LayerCollection Members


Insert Method (LayerCollection)

Insert Method (LayerCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : Insert Method
The zero-based index at which item should be inserted.
The Layer to insert into the LayerCollection.
Inserts a layer to the LayerCollection at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As Layer _
)
public void Insert(
   System.int index,
   Layer item
)

Parameters

index
The zero-based index at which item should be inserted.
item
The Layer to insert into the LayerCollection.
See Also

Reference

LayerCollection Class
LayerCollection Members


Remove Method (LayerCollection)

Remove Method (LayerCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : Remove Method
The Layer to remove from the LayerCollection.
Removes the first occurrence of a specific layer from the LayerCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Remove( _
   ByVal item As Layer _
) As System.Boolean
public System.bool Remove(
   Layer item
)

Parameters

item
The Layer to remove from the LayerCollection.

Return Value

true if item was successfully removed from the LayerCollection; otherwise, false. This method also returns false if item is not found in the original LayerCollection.
See Also

Reference

LayerCollection Class
LayerCollection Members


Validate Method (LayerCollection)

Validate Method (LayerCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : Validate Method
The context.
Performs contextual validation of report layers.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The context.

Return Value

The validation entries.
See Also

Reference

LayerCollection Class
LayerCollection Members


LayerCollection Class Properties

LayerCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LayerCollection Class

For a list of all members of this type, see LayerCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | DefaultLayer | The default Layer.
Public Property | IsReadOnly | Gets a value indicating whether the LayerCollection is read-only.
Public Property | Item | Gets or sets the Layer at the specified index.
Top
See Also

Reference

LayerCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


DefaultLayer Property

DefaultLayer Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : DefaultLayer Property
The default Layer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DefaultLayer As Layer
public Layer DefaultLayer {get;}
See Also

Reference

LayerCollection Class
LayerCollection Members


IsReadOnly Property (LayerCollection)

IsReadOnly Property (LayerCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : IsReadOnly Property
Gets a value indicating whether the LayerCollection is read-only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsReadOnly As System.Boolean
public System.bool IsReadOnly {get;}
See Also

Reference

LayerCollection Class
LayerCollection Members


Item Property (LayerCollection)

Item Property (LayerCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : Item Property
The index.
Gets or sets the Layer at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As Layer
public Layer this[
   System.int index
]; {get; set;}

Parameters

index
The index.
See Also

Reference

LayerCollection Class
LayerCollection Members


Legend Class

Legend Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Legend Class
The Legend element defines the properties that are used to display instances of the series groupings in a chart legend.
Object Model
Legend Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Legend
public sealed class Legend
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Legend

See Also

Reference

Legend Members
GrapeCity.ActiveReports.PageReportModel Namespace


Legend Class Members

Legend Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Legend Class

The following tables list the members exposed by Legend.

Public Constructors
 | Name | Description
Public Constructor | Legend Constructor | Initializes a new instance of the Legend class.
Top
Public Properties
 | Name | Description
Public Property | InsidePlotArea | Gets or sets a value indicating whether to draw the legend inside or outside the plot area.
Public Property | Layout | Gets or sets the arrangement of labels within the legend.
Public Property | Position | Gets or sets the position of the legend.
Public Property | Style | Gets or sets the text, border and background style properties for the legend.
Public Property | UseSmartSettings | Gets or sets the value indicates whether to use automatic legend.
Public Property | Visible | Gets or sets a value indicating whether a legend is displayed.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the Legend object.
Top
See Also

Reference

Legend Class
GrapeCity.ActiveReports.PageReportModel Namespace


Legend Constructor

Legend Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Legend Class : Legend Constructor
Initializes a new instance of the Legend class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Legend()
See Also

Reference

Legend Class
Legend Members


Legend Class Methods

Legend Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Legend Class

For a list of all members of this type, see Legend members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the Legend object.
Top
See Also

Reference

Legend Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (Legend)

Validate Method (Legend)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Legend Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the Legend object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

Legend Class
Legend Members


Legend Class Properties

Legend Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Legend Class

For a list of all members of this type, see Legend members.

Public Properties
 | Name | Description
Public Property | InsidePlotArea | Gets or sets a value indicating whether to draw the legend inside or outside the plot area.
Public Property | Layout | Gets or sets the arrangement of labels within the legend.
Public Property | Position | Gets or sets the position of the legend.
Public Property | Style | Gets or sets the text, border and background style properties for the legend.
Public Property | UseSmartSettings | Gets or sets the value indicates whether to use automatic legend.
Public Property | Visible | Gets or sets a value indicating whether a legend is displayed.
Top
See Also

Reference

Legend Class
GrapeCity.ActiveReports.PageReportModel Namespace


InsidePlotArea Property (Legend)

InsidePlotArea Property (Legend)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Legend Class : InsidePlotArea Property

Gets or sets a value indicating whether to draw the legend inside or outside the plot area.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property InsidePlotArea As System.Boolean
public System.bool InsidePlotArea {get; set;}

Property Value

A Boolean value where true indicates that the legend is displayed inside the plot area; otherwise false. The default value is false.

See Also

Reference

Legend Class
Legend Members


Layout Property (Legend)

Layout Property (Legend)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Legend Class : Layout Property

Gets or sets the arrangement of labels within the legend.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Layout As LegendLayout
public LegendLayout Layout {get; set;}

Property Value

A LegendLayout enumeration indicating the arrangement of labels within the legend.
See Also

Reference

Legend Class
Legend Members


Position Property (Legend)

Position Property (Legend)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Legend Class : Position Property

Gets or sets the position of the legend.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Position As LegendPosition
public LegendPosition Position {get; set;}

Property Value

A LegendPosition enumeration indicating the position of the legend.
See Also

Reference

Legend Class
Legend Members


Style Property (Legend)

Style Property (Legend)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Legend Class : Style Property

Gets or sets the text, border and background style properties for the legend.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As Style
public Style Style {get; set;}

Property Value

A Style object containing the text, border and background style properties for the legend.
Remarks
All textbox properties apply.
See Also

Reference

Legend Class
Legend Members


UseSmartSettings Property (Legend)

UseSmartSettings Property (Legend)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Legend Class : UseSmartSettings Property
Gets or sets the value indicates whether to use automatic legend.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseSmartSettings As System.Boolean
public System.bool UseSmartSettings {get; set;}
See Also

Reference

Legend Class
Legend Members


Visible Property (Legend)

Visible Property (Legend)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Legend Class : Visible Property

Gets or sets a value indicating whether a legend is displayed.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}

Property Value

A Boolean value where true indicates that the legend is displayed; otherwise false. The default value is false.

See Also

Reference

Legend Class
Legend Members


Line Class

Line Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Line Class
Specifies a Line ReportItem contained in the report definition.
Object Model
Line Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Line
   Inherits ReportItem
   Implements IReportComponent
public sealed class Line : ReportItem, IReportComponent
Remarks
Lines drawn from the top or left (or both) are represented by negative heights or widths (or both). However, the Top plus Height and Left plus Width must be nonnegative, valid sizes.
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.Line

See Also

Reference

Line Members
GrapeCity.ActiveReports.PageReportModel Namespace


Line Class Members

Line Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Line Class

The following tables list the members exposed by Line.

Public Constructors
 | Name | Description
Public Constructor | Line Constructor | Initializes a new instance of the Line class.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Height | Overridden. Overrides the report item height to allow for negative values
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Overridden. Overrides the report item width to allow for negative values
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the ReportItem object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Line Class
GrapeCity.ActiveReports.PageReportModel Namespace


Line Constructor

Line Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Line Class : Line Constructor
Initializes a new instance of the Line class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Line()
See Also

Reference

Line Class
Line Members


Line Class Properties

Line Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Line Class

For a list of all members of this type, see Line members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Height | Overridden. Overrides the report item height to allow for negative values
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Overridden. Overrides the report item width to allow for negative values
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
See Also

Reference

Line Class
GrapeCity.ActiveReports.PageReportModel Namespace


Height Property (Line)

Height Property (Line)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Line Class : Height Property
Overrides the report item height to allow for negative values
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Property Height As Length
public override Length Height {get; set;}
See Also

Reference

Line Class
Line Members


Width Property (Line)

Width Property (Line)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Line Class : Width Property
Overrides the report item width to allow for negative values
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Property Width As Length
public override Length Width {get; set;}
See Also

Reference

Line Class
Line Members


List Class

List Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : List Class
Specifies a region that repeats with each group in the rowset or each row in the rowset (if no group expression is defined).
Object Model
List Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class List
   Inherits DataRegion
   Implements IRdlContainer, IReportComponent, IReportComponentContainer, IScopeDefinition
public sealed class List : DataRegion, IRdlContainer, IReportComponent, IReportComponentContainer, IScopeDefinition
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.DataRegion
GrapeCity.ActiveReports.PageReportModel.List

See Also

Reference

List Members
GrapeCity.ActiveReports.PageReportModel Namespace


List Class Members

List Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : List Class

The following tables list the members exposed by List.

Public Constructors
 | Name | Description
Public Constructor | List Constructor | Initializes a new instance of the List class.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ChildScopes | Overridden. Overridden.Implements IScopeDefinition.ChildScopes.
Public Property | Components | Gets the ReportComponentCollection containing all the components hosted in the control.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataInstanceElementOutput | Gets or sets a value indicating whether the list instance appears in a data rendering.
Public Property | DataInstanceName | Gets or sets the name to use for the data element for each instance of the list.
Public Property | DataSetName | Gets or sets the name of the dataset that the data region uses. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | Filters | Gets the collection of filters applied to each row of data within the data region. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | FixedHeight | Represents the data region's maximum height per page. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | FixedWidth | Represents the data region's maximum width per page. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | Grouping | Gets or sets an expression by which to group the data.
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | NewSection | Gets or sets a value indicating whether a data region is in it's own section (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | NoRows | Gets or sets the message to display inside the data region when the region contains no rows. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | OverflowName | Represents the data region's overflow name. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether a page break occurs immediately after the data region ends. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | PageBreakAtStart | Gets or sets a value indicating whether a page break occurs immediately before the data region begins. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportItems | Gets the report items contained in the List.
Public Property | ReportItemsInScope | Overridden. Overridden.Implements IScopeDefinition.ReportItemsInScopes.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Sorting | Gets an expression by which to sort the repeated list regions.
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Overridden. Validates the information in each property of the List object.
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

List Class
GrapeCity.ActiveReports.PageReportModel Namespace


List Constructor

List Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : List Constructor
Initializes a new instance of the List class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public List()
See Also

Reference

List Class
List Members


List Class Methods

List Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : List Class

For a list of all members of this type, see List members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Overridden. Validates the information in each property of the List object.
Top
See Also

Reference

List Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (List)

Validate Method (List)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the List object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

List Class
List Members


List Class Properties

List Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : List Class

For a list of all members of this type, see List members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ChildScopes | Overridden. Overridden.Implements IScopeDefinition.ChildScopes.
Public Property | Components | Gets the ReportComponentCollection containing all the components hosted in the control.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataInstanceElementOutput | Gets or sets a value indicating whether the list instance appears in a data rendering.
Public Property | DataInstanceName | Gets or sets the name to use for the data element for each instance of the list.
Public Property | DataSetName | Gets or sets the name of the dataset that the data region uses. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | Filters | Gets the collection of filters applied to each row of data within the data region. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | FixedHeight | Represents the data region's maximum height per page. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | FixedWidth | Represents the data region's maximum width per page. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | Grouping | Gets or sets an expression by which to group the data.
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | NewSection | Gets or sets a value indicating whether a data region is in it's own section (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | NoRows | Gets or sets the message to display inside the data region when the region contains no rows. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | OverflowName | Represents the data region's overflow name. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether a page break occurs immediately after the data region ends. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | PageBreakAtStart | Gets or sets a value indicating whether a page break occurs immediately before the data region begins. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportItems | Gets the report items contained in the List.
Public Property | ReportItemsInScope | Overridden. Overridden.Implements IScopeDefinition.ReportItemsInScopes.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Sorting | Gets an expression by which to sort the repeated list regions.
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
See Also

Reference

List Class
GrapeCity.ActiveReports.PageReportModel Namespace


ChildScopes Property (List)

ChildScopes Property (List)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : ChildScopes Property
Overridden.Implements IScopeDefinition.ChildScopes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable ReadOnly Property ChildScopes As System.Collections.IEnumerable
public override System.Collections.IEnumerable ChildScopes {get;}

Property Value

The child scopes.
See Also

Reference

List Class
List Members


Components Property (List)

Components Property (List)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : Components Property
Gets the ReportComponentCollection containing all the components hosted in the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Components As ReportComponentCollection
public ReportComponentCollection Components {get;}

Property Value

A read-only DataDynamics.Reports.ReportObjectModel.Rdl.ReportComponentCollection containing all the components hosted in the control.
See Also

Reference

List Class
List Members


DataInstanceElementOutput Property

DataInstanceElementOutput Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : DataInstanceElementOutput Property

Gets or sets a value indicating whether the list instance appears in a data rendering.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataInstanceElementOutput As DataElementOutput
public DataElementOutput DataInstanceElementOutput {get; set;}

Property Value

A DataElementOutput enumeration indicating whether the list instance appears in a data rendering.
Remarks

This property is ignored if there is a grouping for the list.

Output (Default) indicates that the list instances appear in the output.

NoOutput indicates that the list instance does not appear in the output.

See Also

Reference

List Class
List Members


DataInstanceName Property

DataInstanceName Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : DataInstanceName Property

Gets or sets the name to use for the data element for each instance of the list.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataInstanceName As System.String
public System.string DataInstanceName {get; set;}

Property Value

A String name to use for the data element for each instance of the list.

Remarks

This property is ignored if there is a grouping for the list.

The default value is "Item."

See Also

Reference

List Class
List Members


Grouping Property (List)

Grouping Property (List)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : Grouping Property

Gets or sets an expression by which to group the data.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Grouping As Grouping
public Grouping Grouping {get; set;}

Property Value

A Grouping expression by which to group the data.
Remarks

A Grouping is required if there are any DataRegions contained within the List.

See Also

Reference

List Class
List Members


ReportItems Property (List)

ReportItems Property (List)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : ReportItems Property
Gets the report items contained in the List.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ReportItems As ReportItemCollection
public ReportItemCollection ReportItems {get;}

Property Value

A ReportItemCollection representing the report items contained inside the control.
See Also

Reference

List Class
List Members


ReportItemsInScope Property (List)

ReportItemsInScope Property (List)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : ReportItemsInScope Property
Overridden.Implements IScopeDefinition.ReportItemsInScopes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable ReadOnly Property ReportItemsInScope As System.Collections.IEnumerable
public override System.Collections.IEnumerable ReportItemsInScope {get;}

Property Value

The report items in scope.
See Also

Reference

List Class
List Members


Sorting Property (List)

Sorting Property (List)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : Sorting Property

Gets an expression by which to sort the repeated list regions.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Sorting As SortByCollection
public SortByCollection Sorting {get;}

Property Value

A SortByCollection object containing a collection of expressions by which to sort the repeated list regions.
See Also

Reference

List Class
List Members


LocalizationResource Class

LocalizationResource Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LocalizationResource Class
Specifies a localization resource for the Report.
Object Model
LocalizationResource Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class LocalizationResource
public sealed class LocalizationResource
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.LocalizationResource

See Also

Reference

LocalizationResource Members
GrapeCity.ActiveReports.PageReportModel Namespace


LocalizationResource Class Members

LocalizationResource Class Members
Fields Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LocalizationResource Class

The following tables list the members exposed by LocalizationResource.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | KeyFormat | Defines a format of key for resource.
Top
Public Methods
 | Name | Description
Public Method | AddResourceValue | Adds a resource value for the given key.
Public Method | GetResourcesByItemName | Retrieves the resource by item name.
Public Method | GetResourceValue | Get the resource value for the given key.
Public Method | RemoveResourceValue | Remove the resource value for the given key.
Top
See Also

Reference

LocalizationResource Class
GrapeCity.ActiveReports.PageReportModel Namespace


LocalizationResource Class Methods

LocalizationResource Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LocalizationResource Class

For a list of all members of this type, see LocalizationResource members.

Public Methods
 | Name | Description
Public Method | AddResourceValue | Adds a resource value for the given key.
Public Method | GetResourcesByItemName | Retrieves the resource by item name.
Public Method | GetResourceValue | Get the resource value for the given key.
Public Method | RemoveResourceValue | Remove the resource value for the given key.
Top
See Also

Reference

LocalizationResource Class
GrapeCity.ActiveReports.PageReportModel Namespace


AddResourceValue Method

AddResourceValue Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LocalizationResource Class : AddResourceValue Method
The resource key, based on the template: [control name].[property name].
The resource value string.
Adds a resource value for the given key.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddResourceValue( _
   ByVal key As System.String, _
   ByVal value As System.String _
)
public void AddResourceValue(
   System.string key,
   System.string value
)

Parameters

key
The resource key, based on the template: [control name].[property name].
value
The resource value string.
See Also

Reference

LocalizationResource Class
LocalizationResource Members


GetResourcesByItemName Method

GetResourcesByItemName Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LocalizationResource Class : GetResourcesByItemName Method
The item name.
Retrieves the resource by item name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetResourcesByItemName( _
   ByVal itemName As System.String _
) As System.Collections.Generic.IEnumerable(Of KeyValuePair(Of String,String))
public System.Collections.Generic.IEnumerable<KeyValuePair<string,string>> GetResourcesByItemName(
   System.string itemName
)

Parameters

itemName
The item name.
See Also

Reference

LocalizationResource Class
LocalizationResource Members


GetResourceValue Method

GetResourceValue Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LocalizationResource Class : GetResourceValue Method
The resource key, based on the template: [control name].[property name].
Get the resource value for the given key.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetResourceValue( _
   ByVal key As System.String _
) As System.String
public System.string GetResourceValue(
   System.string key
)

Parameters

key
The resource key, based on the template: [control name].[property name].

Return Value

The resource value string.
See Also

Reference

LocalizationResource Class
LocalizationResource Members


RemoveResourceValue Method

RemoveResourceValue Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LocalizationResource Class : RemoveResourceValue Method
The resource key, based on the template: [control name].[property name].
Remove the resource value for the given key.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveResourceValue( _
   ByVal key As System.String _
)
public void RemoveResourceValue(
   System.string key
)

Parameters

key
The resource key, based on the template: [control name].[property name].
See Also

Reference

LocalizationResource Class
LocalizationResource Members


LocalizationResource Class Fields

LocalizationResource Class Fields

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LocalizationResource Class

For a list of all members of this type, see LocalizationResource members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | KeyFormat | Defines a format of key for resource.
Top
See Also

Reference

LocalizationResource Class
GrapeCity.ActiveReports.PageReportModel Namespace


KeyFormat Field

KeyFormat Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LocalizationResource Class : KeyFormat Field
Defines a format of key for resource.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly KeyFormat As System.String
public static readonly System.string KeyFormat
See Also

Reference

LocalizationResource Class
LocalizationResource Members


Map Class

Map Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Map Class
Defines map-based data visualization.
Object Model
Map Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Map
   Inherits ReportItem
   Implements IRdlContainer, IReportComponent, IReportComponentContainer
public sealed class Map : ReportItem, IRdlContainer, IReportComponent, IReportComponentContainer
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.Map

See Also

Reference

Map Members
GrapeCity.ActiveReports.PageReportModel Namespace


Map Class Members

Map Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Map Class

The following tables list the members exposed by Map.

Public Constructors
 | Name | Description
Public Constructor | Map Constructor | Initializes a new instance of the Map class.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ActionInfo | Gets or sets the map action info.
Public Property | AntiAliasing | Gets or sets the anti-aliasing type expresion for a Map that evaluates to one of AntiAliasing. If this element is not present, its value is interpreted as AntiAliasing.All.
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | CustomProperties | Gets or sets the custom properties.
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DocumentMapLabel | Specifies a label to identify a Map instance within the client UI in order to provide a user-friendly label for searching.
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | MapBorderSkin | Gets or sets the map border skin.
Public Property | MapColorScale | Gets or sets the map color scale.
Public Property | MapDataRegions | Gets the map data regions.
Public Property | MapDistanceScale | Gets or sets the map distance scale.
Public Property | MapLayers | Gets the map layers.
Public Property | MapLegends | Gets the map legends.
Public Property | MapTitles | Gets the map titles.
Public Property | MapViewport | Gets or sets the map viewport.
Public Property | MaximumSpatialElementCount | Specifies the maximum number of spatial elements that are allowed in a Map. If this element is not present, its value is interpreted as 20000.
Public Property | MaximumTotalPointCount | Specifies the maximum total number of map points in all spatial elements that are allowed in a Map. If this element is not present, its value is interpreted as 1000000.
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | PageBreak | Gets or sets the page break.
Public Property | PageName | Specifies value to use for the name of a paginated page.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ShadowIntensity | Specifies the intensity of the shadows throughout a Map. If this element is not present, its value is interpreted as 25.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | TextAntiAliasingQuality | Gets or sets the anti-aliasing quality of the text of a Map that evaluates to one of PageReportModel.TextAntiAliasingQualityType. If this element is not present, its value is interpreted as TextAntiAliasingQuality.High.
Public Property | TileLanguage | Specifies the primary language of map tiles, an expression should evaluate to a valid language code string.
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the ReportItem object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Map Class
GrapeCity.ActiveReports.PageReportModel Namespace


Map Constructor

Map Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : Map Constructor
Initializes a new instance of the Map class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Map()
See Also

Reference

Map Class
Map Members


Map Class Properties

Map Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Map Class

For a list of all members of this type, see Map members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ActionInfo | Gets or sets the map action info.
Public Property | AntiAliasing | Gets or sets the anti-aliasing type expresion for a Map that evaluates to one of AntiAliasing. If this element is not present, its value is interpreted as AntiAliasing.All.
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | CustomProperties | Gets or sets the custom properties.
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DocumentMapLabel | Specifies a label to identify a Map instance within the client UI in order to provide a user-friendly label for searching.
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | MapBorderSkin | Gets or sets the map border skin.
Public Property | MapColorScale | Gets or sets the map color scale.
Public Property | MapDataRegions | Gets the map data regions.
Public Property | MapDistanceScale | Gets or sets the map distance scale.
Public Property | MapLayers | Gets the map layers.
Public Property | MapLegends | Gets the map legends.
Public Property | MapTitles | Gets the map titles.
Public Property | MapViewport | Gets or sets the map viewport.
Public Property | MaximumSpatialElementCount | Specifies the maximum number of spatial elements that are allowed in a Map. If this element is not present, its value is interpreted as 20000.
Public Property | MaximumTotalPointCount | Specifies the maximum total number of map points in all spatial elements that are allowed in a Map. If this element is not present, its value is interpreted as 1000000.
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | PageBreak | Gets or sets the page break.
Public Property | PageName | Specifies value to use for the name of a paginated page.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ShadowIntensity | Specifies the intensity of the shadows throughout a Map. If this element is not present, its value is interpreted as 25.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | TextAntiAliasingQuality | Gets or sets the anti-aliasing quality of the text of a Map that evaluates to one of PageReportModel.TextAntiAliasingQualityType. If this element is not present, its value is interpreted as TextAntiAliasingQuality.High.
Public Property | TileLanguage | Specifies the primary language of map tiles, an expression should evaluate to a valid language code string.
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
See Also

Reference

Map Class
GrapeCity.ActiveReports.PageReportModel Namespace


ActionInfo Property (Map)

ActionInfo Property (Map)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : ActionInfo Property
Gets or sets the map action info.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ActionInfo As ActionInfo
public ActionInfo ActionInfo {get; set;}
See Also

Reference

Map Class
Map Members


AntiAliasing Property (Map)

AntiAliasing Property (Map)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : AntiAliasing Property
Gets or sets the anti-aliasing type expresion for a Map that evaluates to one of AntiAliasing. If this element is not present, its value is interpreted as AntiAliasing.All.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AntiAliasing As ExpressionInfo
public ExpressionInfo AntiAliasing {get; set;}
See Also

Reference

Map Class
Map Members


CustomProperties Property (Map)

CustomProperties Property (Map)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : CustomProperties Property
Gets or sets the custom properties.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CustomProperties As CustomPropertyDefinitionCollection
public CustomPropertyDefinitionCollection CustomProperties {get;}
See Also

Reference

Map Class
Map Members


DocumentMapLabel Property

DocumentMapLabel Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : DocumentMapLabel Property
Specifies a label to identify a Map instance within the client UI in order to provide a user-friendly label for searching.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DocumentMapLabel As ExpressionInfo
public ExpressionInfo DocumentMapLabel {get; set;}
See Also

Reference

Map Class
Map Members


MapBorderSkin Property

MapBorderSkin Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : MapBorderSkin Property
Gets or sets the map border skin.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapBorderSkin As MapBorderSkin
public MapBorderSkin MapBorderSkin {get; set;}
See Also

Reference

Map Class
Map Members


MapColorScale Property

MapColorScale Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : MapColorScale Property
Gets or sets the map color scale.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapColorScale As MapColorScale
public MapColorScale MapColorScale {get; set;}
See Also

Reference

Map Class
Map Members


MapDataRegions Property

MapDataRegions Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : MapDataRegions Property
Gets the map data regions.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MapDataRegions As System.Collections.Generic.IList(Of MapDataRegion)
public System.Collections.Generic.IList<MapDataRegion> MapDataRegions {get;}
See Also

Reference

Map Class
Map Members


MapDistanceScale Property

MapDistanceScale Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : MapDistanceScale Property
Gets or sets the map distance scale.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapDistanceScale As MapDistanceScale
public MapDistanceScale MapDistanceScale {get; set;}
See Also

Reference

Map Class
Map Members


MapLayers Property

MapLayers Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : MapLayers Property
Gets the map layers.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MapLayers As System.Collections.Generic.IList(Of MapLayer)
public System.Collections.Generic.IList<MapLayer> MapLayers {get;}
See Also

Reference

Map Class
Map Members


MapLegends Property

MapLegends Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : MapLegends Property
Gets the map legends.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MapLegends As System.Collections.Generic.IList(Of MapLegend)
public System.Collections.Generic.IList<MapLegend> MapLegends {get;}
See Also

Reference

Map Class
Map Members


MapTitles Property

MapTitles Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : MapTitles Property
Gets the map titles.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MapTitles As System.Collections.Generic.IList(Of MapTitle)
public System.Collections.Generic.IList<MapTitle> MapTitles {get;}
See Also

Reference

Map Class
Map Members


MapViewport Property

MapViewport Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : MapViewport Property
Gets or sets the map viewport.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapViewport As MapViewport
public MapViewport MapViewport {get; set;}
See Also

Reference

Map Class
Map Members


MaximumSpatialElementCount Property (Map)

MaximumSpatialElementCount Property (Map)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : MaximumSpatialElementCount Property
Specifies the maximum number of spatial elements that are allowed in a Map. If this element is not present, its value is interpreted as 20000.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaximumSpatialElementCount As System.Integer
public System.int MaximumSpatialElementCount {get; set;}
See Also

Reference

Map Class
Map Members


MaximumTotalPointCount Property (Map)

MaximumTotalPointCount Property (Map)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : MaximumTotalPointCount Property
Specifies the maximum total number of map points in all spatial elements that are allowed in a Map. If this element is not present, its value is interpreted as 1000000.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaximumTotalPointCount As System.Integer
public System.int MaximumTotalPointCount {get; set;}
See Also

Reference

Map Class
Map Members


PageBreak Property (Map)

PageBreak Property (Map)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : PageBreak Property
Gets or sets the page break.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageBreak As PageBreak
public PageBreak PageBreak {get; set;}
See Also

Reference

Map Class
Map Members


PageName Property (Map)

PageName Property (Map)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : PageName Property
Specifies value to use for the name of a paginated page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageName As ExpressionInfo
public ExpressionInfo PageName {get; set;}
See Also

Reference

Map Class
Map Members


ShadowIntensity Property (Map)

ShadowIntensity Property (Map)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : ShadowIntensity Property
Specifies the intensity of the shadows throughout a Map. If this element is not present, its value is interpreted as 25.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShadowIntensity As ExpressionInfo
public ExpressionInfo ShadowIntensity {get; set;}
See Also

Reference

Map Class
Map Members


TextAntiAliasingQuality Property (Map)

TextAntiAliasingQuality Property (Map)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : TextAntiAliasingQuality Property
Gets or sets the anti-aliasing quality of the text of a Map that evaluates to one of PageReportModel.TextAntiAliasingQualityType. If this element is not present, its value is interpreted as TextAntiAliasingQuality.High.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TextAntiAliasingQuality As ExpressionInfo
public ExpressionInfo TextAntiAliasingQuality {get; set;}
See Also

Reference

Map Class
Map Members


TileLanguage Property (Map)

TileLanguage Property (Map)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : TileLanguage Property
Specifies the primary language of map tiles, an expression should evaluate to a valid language code string.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TileLanguage As ExpressionInfo
public ExpressionInfo TileLanguage {get; set;}
See Also

Reference

Map Class
Map Members


MapAppearanceRule Class

MapAppearanceRule Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapAppearanceRule Class
Defines the appearance rule for spatial elements based on a data field
Object Model
MapAppearanceRule Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class MapAppearanceRule
public abstract class MapAppearanceRule
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule
GrapeCity.ActiveReports.PageReportModel.MapColorRule
GrapeCity.ActiveReports.PageReportModel.MapMarkerRule
GrapeCity.ActiveReports.PageReportModel.MapSizeRule

See Also

Reference

MapAppearanceRule Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapAppearanceRule Class Members

MapAppearanceRule Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapAppearanceRule Class

The following tables list the members exposed by MapAppearanceRule.

Public Properties
 | Name | Description
Public Property | BucketCount | Defines the number of buckets for the specified distribution. Ignored if DistributionType is RuleDistributionType.Custom or if DataValue is not Scalar. An expression should evaluate to a System.Integer. The default value is 5
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier.
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output.
Public Property | DataValue | An expression to be evaluated on the scope of the spatial element. The appearance rule will be applied on the element based on its value.
Public Property | DistributionType | Gets or sets the distribution type. That evaluates to one of RuleDistributionType. The default value is RuleDistributionType.Optimal.
Public Property | EndValue | Gets or sets the end value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom.
Public Property | LegendName | Name of the legend in which the data field will appear.
Public Property | LegendText | Label to use in the legend for the data field.
Public Property | MapBuckets | Gets the set of buckets used to distribute the data. Mandatory if DistributionType = RuleDistributionType.Custom, otherwise ignored.
Public Property | StartValue | Gets or sets the start value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom.
Top
See Also

Reference

MapAppearanceRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapAppearanceRule Class Properties

MapAppearanceRule Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapAppearanceRule Class

For a list of all members of this type, see MapAppearanceRule members.

Public Properties
 | Name | Description
Public Property | BucketCount | Defines the number of buckets for the specified distribution. Ignored if DistributionType is RuleDistributionType.Custom or if DataValue is not Scalar. An expression should evaluate to a System.Integer. The default value is 5
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier.
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output.
Public Property | DataValue | An expression to be evaluated on the scope of the spatial element. The appearance rule will be applied on the element based on its value.
Public Property | DistributionType | Gets or sets the distribution type. That evaluates to one of RuleDistributionType. The default value is RuleDistributionType.Optimal.
Public Property | EndValue | Gets or sets the end value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom.
Public Property | LegendName | Name of the legend in which the data field will appear.
Public Property | LegendText | Label to use in the legend for the data field.
Public Property | MapBuckets | Gets the set of buckets used to distribute the data. Mandatory if DistributionType = RuleDistributionType.Custom, otherwise ignored.
Public Property | StartValue | Gets or sets the start value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom.
Top
See Also

Reference

MapAppearanceRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


BucketCount Property

BucketCount Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule Class : BucketCount Property
Defines the number of buckets for the specified distribution. Ignored if DistributionType is RuleDistributionType.Custom or if DataValue is not Scalar. An expression should evaluate to a System.Integer. The default value is 5
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BucketCount As ExpressionInfo
public ExpressionInfo BucketCount {get; set;}
See Also

Reference

MapAppearanceRule Class
MapAppearanceRule Members


DataElementName Property (MapAppearanceRule)

DataElementName Property (MapAppearanceRule)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule Class : DataElementName Property
The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataElementName As System.String
public System.string DataElementName {get; set;}
See Also

Reference

MapAppearanceRule Class
MapAppearanceRule Members


DataElementOutput Property (MapAppearanceRule)

DataElementOutput Property (MapAppearanceRule)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule Class : DataElementOutput Property
Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataElementOutput As DataElementOutput
public DataElementOutput DataElementOutput {get; set;}
See Also

Reference

MapAppearanceRule Class
MapAppearanceRule Members


DataValue Property

DataValue Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule Class : DataValue Property
An expression to be evaluated on the scope of the spatial element. The appearance rule will be applied on the element based on its value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataValue As ExpressionInfo
public ExpressionInfo DataValue {get; set;}
See Also

Reference

MapAppearanceRule Class
MapAppearanceRule Members


DistributionType Property

DistributionType Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule Class : DistributionType Property
Gets or sets the distribution type. That evaluates to one of RuleDistributionType. The default value is RuleDistributionType.Optimal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DistributionType As ExpressionInfo
public ExpressionInfo DistributionType {get; set;}
See Also

Reference

MapAppearanceRule Class
MapAppearanceRule Members


EndValue Property (MapAppearanceRule)

EndValue Property (MapAppearanceRule)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule Class : EndValue Property
Gets or sets the end value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EndValue As ExpressionInfo
public ExpressionInfo EndValue {get; set;}
See Also

Reference

MapAppearanceRule Class
MapAppearanceRule Members


LegendName Property

LegendName Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule Class : LegendName Property
Name of the legend in which the data field will appear.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LegendName As System.String
public System.string LegendName {get; set;}
See Also

Reference

MapAppearanceRule Class
MapAppearanceRule Members


LegendText Property (MapAppearanceRule)

LegendText Property (MapAppearanceRule)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule Class : LegendText Property
Label to use in the legend for the data field.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LegendText As ExpressionInfo
public ExpressionInfo LegendText {get; set;}
See Also

Reference

MapAppearanceRule Class
MapAppearanceRule Members


MapBuckets Property

MapBuckets Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule Class : MapBuckets Property
Gets the set of buckets used to distribute the data. Mandatory if DistributionType = RuleDistributionType.Custom, otherwise ignored.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MapBuckets As System.Collections.Generic.IList(Of MapBucket)
public System.Collections.Generic.IList<MapBucket> MapBuckets {get;}
See Also

Reference

MapAppearanceRule Class
MapAppearanceRule Members


StartValue Property (MapAppearanceRule)

StartValue Property (MapAppearanceRule)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapAppearanceRule Class : StartValue Property
Gets or sets the start value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartValue As ExpressionInfo
public ExpressionInfo StartValue {get; set;}
See Also

Reference

MapAppearanceRule Class
MapAppearanceRule Members


MapBindingFieldPair Class

MapBindingFieldPair Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapBindingFieldPair Class
Defines a field/expression pairs to be used to bind the map elements within a vector based layer to the data region associated with it
Object Model
MapBindingFieldPair Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class MapBindingFieldPair
public class MapBindingFieldPair
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapBindingFieldPair

See Also

Reference

MapBindingFieldPair Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapBindingFieldPair Class Members

MapBindingFieldPair Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapBindingFieldPair Class

The following tables list the members exposed by MapBindingFieldPair.

Public Constructors
 | Name | Description
Public Constructor | MapBindingFieldPair Constructor | Initializes a new instance of the MapBindingFieldPair class.
Top
Public Properties
 | Name | Description
Public Property | BindingExpression | An expression that is evaluated for each inner most group instance and is compared to the field value.
Public Property | FieldName | Gets or sets which map element field to be used for binding.
Top
See Also

Reference

MapBindingFieldPair Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapBindingFieldPair Constructor

MapBindingFieldPair Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapBindingFieldPair Class : MapBindingFieldPair Constructor
Initializes a new instance of the MapBindingFieldPair class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapBindingFieldPair()
See Also

Reference

MapBindingFieldPair Class
MapBindingFieldPair Members


MapBindingFieldPair Class Properties

MapBindingFieldPair Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapBindingFieldPair Class

For a list of all members of this type, see MapBindingFieldPair members.

Public Properties
 | Name | Description
Public Property | BindingExpression | An expression that is evaluated for each inner most group instance and is compared to the field value.
Public Property | FieldName | Gets or sets which map element field to be used for binding.
Top
See Also

Reference

MapBindingFieldPair Class
GrapeCity.ActiveReports.PageReportModel Namespace


BindingExpression Property

BindingExpression Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapBindingFieldPair Class : BindingExpression Property
An expression that is evaluated for each inner most group instance and is compared to the field value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BindingExpression As ExpressionInfo
public ExpressionInfo BindingExpression {get; set;}
See Also

Reference

MapBindingFieldPair Class
MapBindingFieldPair Members


FieldName Property

FieldName Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapBindingFieldPair Class : FieldName Property
Gets or sets which map element field to be used for binding.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FieldName As ExpressionInfo
public ExpressionInfo FieldName {get; set;}
See Also

Reference

MapBindingFieldPair Class
MapBindingFieldPair Members


MapBorderSkin Class

MapBorderSkin Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapBorderSkin Class
Defines the appearance of the border skin around the map report item
Object Model
MapBorderSkin Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapBorderSkin
public sealed class MapBorderSkin
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapBorderSkin

See Also

Reference

MapBorderSkin Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapBorderSkin Class Members

MapBorderSkin Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapBorderSkin Class

The following tables list the members exposed by MapBorderSkin.

Public Constructors
 | Name | Description
Public Constructor | MapBorderSkin Constructor | Initializes a new instance of the MapBorderSkin class.
Top
Public Properties
 | Name | Description
Public Property | MapBorderSkinType | Border skin type for the map. That evaluates to one of MapBorderSkin.BorderSkinType. The default value is MapBorderSkin.BorderSkinType.None.
Public Property | Style | Style properties for the border skin. Each of the properties of type Color support transparency.
Top
See Also

Reference

MapBorderSkin Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapBorderSkin Constructor

MapBorderSkin Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapBorderSkin Class : MapBorderSkin Constructor
Initializes a new instance of the MapBorderSkin class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapBorderSkin()
See Also

Reference

MapBorderSkin Class
MapBorderSkin Members


MapBorderSkin Class Properties

MapBorderSkin Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapBorderSkin Class

For a list of all members of this type, see MapBorderSkin members.

Public Properties
 | Name | Description
Public Property | MapBorderSkinType | Border skin type for the map. That evaluates to one of MapBorderSkin.BorderSkinType. The default value is MapBorderSkin.BorderSkinType.None.
Public Property | Style | Style properties for the border skin. Each of the properties of type Color support transparency.
Top
See Also

Reference

MapBorderSkin Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapBorderSkinType Property

MapBorderSkinType Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapBorderSkin Class : MapBorderSkinType Property
Border skin type for the map. That evaluates to one of MapBorderSkin.BorderSkinType. The default value is MapBorderSkin.BorderSkinType.None.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapBorderSkinType As ExpressionInfo
public ExpressionInfo MapBorderSkinType {get; set;}
See Also

Reference

MapBorderSkin Class
MapBorderSkin Members


Style Property (MapBorderSkin)

Style Property (MapBorderSkin)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapBorderSkin Class : Style Property
Style properties for the border skin. Each of the properties of type Color support transparency.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As Style
public Style Style {get; set;}
See Also

Reference

MapBorderSkin Class
MapBorderSkin Members


MapBucket Class

MapBucket Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapBucket Class
Defines a bucket for custom data distribution
Object Model
MapBucket Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapBucket
public sealed class MapBucket
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapBucket

See Also

Reference

MapBucket Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapBucket Class Members

MapBucket Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapBucket Class

The following tables list the members exposed by MapBucket.

Public Constructors
 | Name | Description
Public Constructor | MapBucket Constructor | Initializes a new instance of the MapBucket class.
Top
Public Properties
 | Name | Description
Public Property | EndValue | Gets or sets the end value for the bucket.
Public Property | StartValue | Gets or sets the start value for the bucket
Top
See Also

Reference

MapBucket Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapBucket Constructor

MapBucket Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapBucket Class : MapBucket Constructor
Initializes a new instance of the MapBucket class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapBucket()
See Also

Reference

MapBucket Class
MapBucket Members


MapBucket Class Properties

MapBucket Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapBucket Class

For a list of all members of this type, see MapBucket members.

Public Properties
 | Name | Description
Public Property | EndValue | Gets or sets the end value for the bucket.
Public Property | StartValue | Gets or sets the start value for the bucket
Top
See Also

Reference

MapBucket Class
GrapeCity.ActiveReports.PageReportModel Namespace


EndValue Property (MapBucket)

EndValue Property (MapBucket)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapBucket Class : EndValue Property
Gets or sets the end value for the bucket.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EndValue As ExpressionInfo
public ExpressionInfo EndValue {get; set;}
See Also

Reference

MapBucket Class
MapBucket Members


StartValue Property (MapBucket)

StartValue Property (MapBucket)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapBucket Class : StartValue Property
Gets or sets the start value for the bucket
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartValue As ExpressionInfo
public ExpressionInfo StartValue {get; set;}
See Also

Reference

MapBucket Class
MapBucket Members


MapColorPaletteRule Class

MapColorPaletteRule Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorPaletteRule Class
Defines the color palette for spatial elements based on a data field
Object Model
MapColorPaletteRule Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapColorPaletteRule
   Inherits MapColorRule
public sealed class MapColorPaletteRule : MapColorRule
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule
GrapeCity.ActiveReports.PageReportModel.MapColorRule
GrapeCity.ActiveReports.PageReportModel.MapColorPaletteRule

See Also

Reference

MapColorPaletteRule Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorPaletteRule Class Members

MapColorPaletteRule Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorPaletteRule Class

The following tables list the members exposed by MapColorPaletteRule.

Public Constructors
 | Name | Description
Public Constructor | MapColorPaletteRule Constructor | Initializes a new instance of the MapColorPaletteRule class.
Top
Public Properties
 | Name | Description
Public Property | BucketCount | Defines the number of buckets for the specified distribution. Ignored if DistributionType is RuleDistributionType.Custom or if DataValue is not Scalar. An expression should evaluate to a System.Integer. The default value is 5 (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataValue | An expression to be evaluated on the scope of the spatial element. The appearance rule will be applied on the element based on its value. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DistributionType | Gets or sets the distribution type. That evaluates to one of RuleDistributionType. The default value is RuleDistributionType.Optimal. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | EndValue | Gets or sets the end value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | LegendName | Name of the legend in which the data field will appear. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | LegendText | Label to use in the legend for the data field. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | MapBuckets | Gets the set of buckets used to distribute the data. Mandatory if DistributionType = RuleDistributionType.Custom, otherwise ignored. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | Palette | Gets or sets the palette to be used for coloring the spatial elements. That evaluates to one of ColorPalette. The default value is MapColorPalette.Random.
Public Property | ShowInColorScale | Gets or sets if the data field should be shown in the color scale. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapColorRule)
Public Property | StartValue | Gets or sets the start value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Top
See Also

Reference

MapColorPaletteRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorPaletteRule Constructor

MapColorPaletteRule Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorPaletteRule Class : MapColorPaletteRule Constructor
Initializes a new instance of the MapColorPaletteRule class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapColorPaletteRule()
See Also

Reference

MapColorPaletteRule Class
MapColorPaletteRule Members


MapColorPaletteRule Class Properties

MapColorPaletteRule Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorPaletteRule Class

For a list of all members of this type, see MapColorPaletteRule members.

Public Properties
 | Name | Description
Public Property | BucketCount | Defines the number of buckets for the specified distribution. Ignored if DistributionType is RuleDistributionType.Custom or if DataValue is not Scalar. An expression should evaluate to a System.Integer. The default value is 5 (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataValue | An expression to be evaluated on the scope of the spatial element. The appearance rule will be applied on the element based on its value. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DistributionType | Gets or sets the distribution type. That evaluates to one of RuleDistributionType. The default value is RuleDistributionType.Optimal. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | EndValue | Gets or sets the end value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | LegendName | Name of the legend in which the data field will appear. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | LegendText | Label to use in the legend for the data field. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | MapBuckets | Gets the set of buckets used to distribute the data. Mandatory if DistributionType = RuleDistributionType.Custom, otherwise ignored. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | Palette | Gets or sets the palette to be used for coloring the spatial elements. That evaluates to one of ColorPalette. The default value is MapColorPalette.Random.
Public Property | ShowInColorScale | Gets or sets if the data field should be shown in the color scale. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapColorRule)
Public Property | StartValue | Gets or sets the start value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Top
See Also

Reference

MapColorPaletteRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


Palette Property (MapColorPaletteRule)

Palette Property (MapColorPaletteRule)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorPaletteRule Class : Palette Property
Gets or sets the palette to be used for coloring the spatial elements. That evaluates to one of ColorPalette. The default value is MapColorPalette.Random.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Palette As ExpressionInfo
public ExpressionInfo Palette {get; set;}
See Also

Reference

MapColorPaletteRule Class
MapColorPaletteRule Members


MapColorRangeRule Class

MapColorRangeRule Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorRangeRule Class
Defines the color ranges for spatial elements based on a data field
Object Model
MapColorRangeRule Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapColorRangeRule
   Inherits MapColorRule
public sealed class MapColorRangeRule : MapColorRule
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule
GrapeCity.ActiveReports.PageReportModel.MapColorRule
GrapeCity.ActiveReports.PageReportModel.MapColorRangeRule

See Also

Reference

MapColorRangeRule Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorRangeRule Class Members

MapColorRangeRule Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorRangeRule Class

The following tables list the members exposed by MapColorRangeRule.

Public Constructors
 | Name | Description
Public Constructor | MapColorRangeRule Constructor | Initializes a new instance of the MapColorRangeRule class.
Top
Public Properties
 | Name | Description
Public Property | BucketCount | Defines the number of buckets for the specified distribution. Ignored if DistributionType is RuleDistributionType.Custom or if DataValue is not Scalar. An expression should evaluate to a System.Integer. The default value is 5 (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataValue | An expression to be evaluated on the scope of the spatial element. The appearance rule will be applied on the element based on its value. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DistributionType | Gets or sets the distribution type. That evaluates to one of RuleDistributionType. The default value is RuleDistributionType.Optimal. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | EndColor | Defines the end color to be used for the spatial elements. Default value is Red
Public Property | EndValue | Gets or sets the end value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | LegendName | Name of the legend in which the data field will appear. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | LegendText | Label to use in the legend for the data field. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | MapBuckets | Gets the set of buckets used to distribute the data. Mandatory if DistributionType = RuleDistributionType.Custom, otherwise ignored. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | MiddleColor | Defines the middle color to be used for the spatial elements. Default value is Yellow
Public Property | ShowInColorScale | Gets or sets if the data field should be shown in the color scale. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapColorRule)
Public Property | StartColor | Defines the start color to be used for the spatial elements. Default value is Green
Public Property | StartValue | Gets or sets the start value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Top
See Also

Reference

MapColorRangeRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorRangeRule Constructor

MapColorRangeRule Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorRangeRule Class : MapColorRangeRule Constructor
Initializes a new instance of the MapColorRangeRule class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapColorRangeRule()
See Also

Reference

MapColorRangeRule Class
MapColorRangeRule Members


MapColorRangeRule Class Properties

MapColorRangeRule Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorRangeRule Class

For a list of all members of this type, see MapColorRangeRule members.

Public Properties
 | Name | Description
Public Property | BucketCount | Defines the number of buckets for the specified distribution. Ignored if DistributionType is RuleDistributionType.Custom or if DataValue is not Scalar. An expression should evaluate to a System.Integer. The default value is 5 (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataValue | An expression to be evaluated on the scope of the spatial element. The appearance rule will be applied on the element based on its value. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DistributionType | Gets or sets the distribution type. That evaluates to one of RuleDistributionType. The default value is RuleDistributionType.Optimal. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | EndColor | Defines the end color to be used for the spatial elements. Default value is Red
Public Property | EndValue | Gets or sets the end value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | LegendName | Name of the legend in which the data field will appear. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | LegendText | Label to use in the legend for the data field. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | MapBuckets | Gets the set of buckets used to distribute the data. Mandatory if DistributionType = RuleDistributionType.Custom, otherwise ignored. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | MiddleColor | Defines the middle color to be used for the spatial elements. Default value is Yellow
Public Property | ShowInColorScale | Gets or sets if the data field should be shown in the color scale. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapColorRule)
Public Property | StartColor | Defines the start color to be used for the spatial elements. Default value is Green
Public Property | StartValue | Gets or sets the start value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Top
See Also

Reference

MapColorRangeRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


EndColor Property

EndColor Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorRangeRule Class : EndColor Property
Defines the end color to be used for the spatial elements. Default value is Red
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EndColor As ExpressionInfo
public ExpressionInfo EndColor {get; set;}
See Also

Reference

MapColorRangeRule Class
MapColorRangeRule Members


MiddleColor Property

MiddleColor Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorRangeRule Class : MiddleColor Property
Defines the middle color to be used for the spatial elements. Default value is Yellow
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MiddleColor As ExpressionInfo
public ExpressionInfo MiddleColor {get; set;}
See Also

Reference

MapColorRangeRule Class
MapColorRangeRule Members


StartColor Property

StartColor Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorRangeRule Class : StartColor Property
Defines the start color to be used for the spatial elements. Default value is Green
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartColor As ExpressionInfo
public ExpressionInfo StartColor {get; set;}
See Also

Reference

MapColorRangeRule Class
MapColorRangeRule Members


MapColorRule Class

MapColorRule Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorRule Class
Defines the color rule for spatial elements based on a data field.
Object Model
MapColorRule Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class MapColorRule
   Inherits MapAppearanceRule
public abstract class MapColorRule : MapAppearanceRule
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule
GrapeCity.ActiveReports.PageReportModel.MapColorRule
GrapeCity.ActiveReports.PageReportModel.MapColorPaletteRule
GrapeCity.ActiveReports.PageReportModel.MapColorRangeRule
GrapeCity.ActiveReports.PageReportModel.MapCustomColorRule

See Also

Reference

MapColorRule Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorRule Class Members

MapColorRule Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorRule Class

The following tables list the members exposed by MapColorRule.

Public Properties
 | Name | Description
Public Property | BucketCount | Defines the number of buckets for the specified distribution. Ignored if DistributionType is RuleDistributionType.Custom or if DataValue is not Scalar. An expression should evaluate to a System.Integer. The default value is 5 (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataValue | An expression to be evaluated on the scope of the spatial element. The appearance rule will be applied on the element based on its value. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DistributionType | Gets or sets the distribution type. That evaluates to one of RuleDistributionType. The default value is RuleDistributionType.Optimal. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | EndValue | Gets or sets the end value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | LegendName | Name of the legend in which the data field will appear. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | LegendText | Label to use in the legend for the data field. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | MapBuckets | Gets the set of buckets used to distribute the data. Mandatory if DistributionType = RuleDistributionType.Custom, otherwise ignored. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | ShowInColorScale | Gets or sets if the data field should be shown in the color scale. An expression should evaluate to a System.Boolean.
Public Property | StartValue | Gets or sets the start value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Top
See Also

Reference

MapColorRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorRule Class Properties

MapColorRule Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorRule Class

For a list of all members of this type, see MapColorRule members.

Public Properties
 | Name | Description
Public Property | BucketCount | Defines the number of buckets for the specified distribution. Ignored if DistributionType is RuleDistributionType.Custom or if DataValue is not Scalar. An expression should evaluate to a System.Integer. The default value is 5 (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataValue | An expression to be evaluated on the scope of the spatial element. The appearance rule will be applied on the element based on its value. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DistributionType | Gets or sets the distribution type. That evaluates to one of RuleDistributionType. The default value is RuleDistributionType.Optimal. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | EndValue | Gets or sets the end value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | LegendName | Name of the legend in which the data field will appear. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | LegendText | Label to use in the legend for the data field. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | MapBuckets | Gets the set of buckets used to distribute the data. Mandatory if DistributionType = RuleDistributionType.Custom, otherwise ignored. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | ShowInColorScale | Gets or sets if the data field should be shown in the color scale. An expression should evaluate to a System.Boolean.
Public Property | StartValue | Gets or sets the start value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Top
See Also

Reference

MapColorRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


ShowInColorScale Property

ShowInColorScale Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorRule Class : ShowInColorScale Property
Gets or sets if the data field should be shown in the color scale. An expression should evaluate to a System.Boolean.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShowInColorScale As ExpressionInfo
public ExpressionInfo ShowInColorScale {get; set;}
See Also

Reference

MapColorRule Class
MapColorRule Members


MapColorScale Class

MapColorScale Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorScale Class
Defines the map color scale
Object Model
MapColorScale Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapColorScale
   Inherits MapDockableSubItem
public sealed class MapColorScale : MapDockableSubItem
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSubItem
GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem
GrapeCity.ActiveReports.PageReportModel.MapColorScale

See Also

Reference

MapColorScale Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorScale Class Members

MapColorScale Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorScale Class

The following tables list the members exposed by MapColorScale.

Public Constructors
 | Name | Description
Public Constructor | MapColorScale Constructor | Initializes a new instance of the MapColorScale class.
Top
Public Properties
 | Name | Description
Public Property | ActionInfo | Actions for the map sub item. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | BottomMargin | Width of the bottom margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | ColorBarBorderColor | Gets or sets the border color for the color bar. The default value is Black.
Public Property | DockOutsideViewport | Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | Hidden | Gets or sets the item is hidden. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | HideEndLabels | Gets or sets labels should be hidden at bar color ends An expression should evaluate to a System.Boolean.
Public Property | LabelBehavior | Gets or sets the positioning of the color scale labels. That evaluates to one of MapColorScale.MapLabelBehavior. The default value is MapColorScale.MapLabelBehavior.Auto.
Public Property | LabelFormat | Gets or sets the format string to be used for numeric labels. The default value is #,##0.##.
Public Property | LabelInterval | Gets or sets the frequency of the labels along the color bar. An expression should evaluate to a System.Integer. The default value is 1.
Public Property | LabelPlacement | Gets or sets the labels placement along the color bar. That evaluates to one of MapColorScale.MapLabelPlacement. The default value is MapColorScale.MapLabelPlacement.Alternate.
Public Property | LeftMargin | Width of the left margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapColorScaleTitle | Gets or sets the title to be displayed for the color scale.
Public Property | MapLocation | Gets or sets the sub item location within the map. Default for MapViewport (0,0), otherwise MapDockableSubItem.Position is used. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapSize | Gets or sets the sub item size within the map. If omitted for MapViewport the default is (100,100) in percents. Automatically calculated for MapDockableSubItem. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | NoDataText | Gets or sets the label to be used for colors with no data values. An expression should evaluate to a System.String.
Public Property | Position | The position of the sub item. Ignored if MapLocation is defined. That evaluates to one of MapDockableSubItem.MapPosition. The default value is MapDockableSubItem.MapPosition.TopCenter. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | RangeGapColor | Gets or sets the color used to fill color divisions for range values which are not defined. Ignored if LabelBehavior != MapColorScale.MapLabelBehavior.ShowBorderValue. The default value is White.
Public Property | RightMargin | Width of the right margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | Style | Gets or sets style properties for map sub item. Each of the properties of type Color support transparency. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | TickMarkLength | Gets or sets the tick mark length. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 2.25pt.
Public Property | ToolTip | Tool tip to display for the map sub item. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | TopMargin | Width of the top margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | ZIndex | Drawing order of the item within the map. An expression should evaluate to a System.Integer. The default value is 0. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Top
See Also

Reference

MapColorScale Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorScale Constructor

MapColorScale Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale Class : MapColorScale Constructor
Initializes a new instance of the MapColorScale class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapColorScale()
See Also

Reference

MapColorScale Class
MapColorScale Members


MapColorScale Class Properties

MapColorScale Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorScale Class

For a list of all members of this type, see MapColorScale members.

Public Properties
 | Name | Description
Public Property | ActionInfo | Actions for the map sub item. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | BottomMargin | Width of the bottom margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | ColorBarBorderColor | Gets or sets the border color for the color bar. The default value is Black.
Public Property | DockOutsideViewport | Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | Hidden | Gets or sets the item is hidden. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | HideEndLabels | Gets or sets labels should be hidden at bar color ends An expression should evaluate to a System.Boolean.
Public Property | LabelBehavior | Gets or sets the positioning of the color scale labels. That evaluates to one of MapColorScale.MapLabelBehavior. The default value is MapColorScale.MapLabelBehavior.Auto.
Public Property | LabelFormat | Gets or sets the format string to be used for numeric labels. The default value is #,##0.##.
Public Property | LabelInterval | Gets or sets the frequency of the labels along the color bar. An expression should evaluate to a System.Integer. The default value is 1.
Public Property | LabelPlacement | Gets or sets the labels placement along the color bar. That evaluates to one of MapColorScale.MapLabelPlacement. The default value is MapColorScale.MapLabelPlacement.Alternate.
Public Property | LeftMargin | Width of the left margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapColorScaleTitle | Gets or sets the title to be displayed for the color scale.
Public Property | MapLocation | Gets or sets the sub item location within the map. Default for MapViewport (0,0), otherwise MapDockableSubItem.Position is used. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapSize | Gets or sets the sub item size within the map. If omitted for MapViewport the default is (100,100) in percents. Automatically calculated for MapDockableSubItem. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | NoDataText | Gets or sets the label to be used for colors with no data values. An expression should evaluate to a System.String.
Public Property | Position | The position of the sub item. Ignored if MapLocation is defined. That evaluates to one of MapDockableSubItem.MapPosition. The default value is MapDockableSubItem.MapPosition.TopCenter. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | RangeGapColor | Gets or sets the color used to fill color divisions for range values which are not defined. Ignored if LabelBehavior != MapColorScale.MapLabelBehavior.ShowBorderValue. The default value is White.
Public Property | RightMargin | Width of the right margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | Style | Gets or sets style properties for map sub item. Each of the properties of type Color support transparency. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | TickMarkLength | Gets or sets the tick mark length. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 2.25pt.
Public Property | ToolTip | Tool tip to display for the map sub item. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | TopMargin | Width of the top margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | ZIndex | Drawing order of the item within the map. An expression should evaluate to a System.Integer. The default value is 0. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Top
See Also

Reference

MapColorScale Class
GrapeCity.ActiveReports.PageReportModel Namespace


ColorBarBorderColor Property (MapColorScale)

ColorBarBorderColor Property (MapColorScale)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale Class : ColorBarBorderColor Property
Gets or sets the border color for the color bar. The default value is Black.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ColorBarBorderColor As ExpressionInfo
public ExpressionInfo ColorBarBorderColor {get; set;}
See Also

Reference

MapColorScale Class
MapColorScale Members


HideEndLabels Property (MapColorScale)

HideEndLabels Property (MapColorScale)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale Class : HideEndLabels Property
Gets or sets labels should be hidden at bar color ends An expression should evaluate to a System.Boolean.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HideEndLabels As ExpressionInfo
public ExpressionInfo HideEndLabels {get; set;}
See Also

Reference

MapColorScale Class
MapColorScale Members


LabelBehavior Property (MapColorScale)

LabelBehavior Property (MapColorScale)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale Class : LabelBehavior Property
Gets or sets the positioning of the color scale labels. That evaluates to one of MapColorScale.MapLabelBehavior. The default value is MapColorScale.MapLabelBehavior.Auto.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LabelBehavior As ExpressionInfo
public ExpressionInfo LabelBehavior {get; set;}
See Also

Reference

MapColorScale Class
MapColorScale Members


LabelFormat Property (MapColorScale)

LabelFormat Property (MapColorScale)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale Class : LabelFormat Property
Gets or sets the format string to be used for numeric labels. The default value is #,##0.##.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LabelFormat As ExpressionInfo
public ExpressionInfo LabelFormat {get; set;}
See Also

Reference

MapColorScale Class
MapColorScale Members


LabelInterval Property (MapColorScale)

LabelInterval Property (MapColorScale)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale Class : LabelInterval Property
Gets or sets the frequency of the labels along the color bar. An expression should evaluate to a System.Integer. The default value is 1.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LabelInterval As ExpressionInfo
public ExpressionInfo LabelInterval {get; set;}
See Also

Reference

MapColorScale Class
MapColorScale Members


LabelPlacement Property (MapColorScale)

LabelPlacement Property (MapColorScale)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale Class : LabelPlacement Property
Gets or sets the labels placement along the color bar. That evaluates to one of MapColorScale.MapLabelPlacement. The default value is MapColorScale.MapLabelPlacement.Alternate.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LabelPlacement As ExpressionInfo
public ExpressionInfo LabelPlacement {get; set;}
See Also

Reference

MapColorScale Class
MapColorScale Members


MapColorScaleTitle Property

MapColorScaleTitle Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale Class : MapColorScaleTitle Property
Gets or sets the title to be displayed for the color scale.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapColorScaleTitle As MapColorScaleTitle
public MapColorScaleTitle MapColorScaleTitle {get; set;}
See Also

Reference

MapColorScale Class
MapColorScale Members


NoDataText Property (MapColorScale)

NoDataText Property (MapColorScale)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale Class : NoDataText Property
Gets or sets the label to be used for colors with no data values. An expression should evaluate to a System.String.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NoDataText As ExpressionInfo
public ExpressionInfo NoDataText {get; set;}
See Also

Reference

MapColorScale Class
MapColorScale Members


RangeGapColor Property (MapColorScale)

RangeGapColor Property (MapColorScale)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale Class : RangeGapColor Property
Gets or sets the color used to fill color divisions for range values which are not defined. Ignored if LabelBehavior != MapColorScale.MapLabelBehavior.ShowBorderValue. The default value is White.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RangeGapColor As ExpressionInfo
public ExpressionInfo RangeGapColor {get; set;}
See Also

Reference

MapColorScale Class
MapColorScale Members


TickMarkLength Property (MapColorScale)

TickMarkLength Property (MapColorScale)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScale Class : TickMarkLength Property
Gets or sets the tick mark length. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 2.25pt.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TickMarkLength As ExpressionInfo
public ExpressionInfo TickMarkLength {get; set;}
See Also

Reference

MapColorScale Class
MapColorScale Members


MapColorScaleTitle Class

MapColorScaleTitle Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorScaleTitle Class
Defines the settings for the title to be displayed within the color scale
Object Model
MapColorScaleTitle Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapColorScaleTitle
public sealed class MapColorScaleTitle
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapColorScaleTitle

See Also

Reference

MapColorScaleTitle Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorScaleTitle Class Members

MapColorScaleTitle Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorScaleTitle Class

The following tables list the members exposed by MapColorScaleTitle.

Public Constructors
 | Name | Description
Public Constructor | MapColorScaleTitle Constructor | Initializes a new instance of the MapColorScaleTitle class.
Top
Public Properties
 | Name | Description
Public Property | Caption | Caption of the title. An expression should evaluate to a System.String.
Public Property | Style | Gets or sets style properties to be applied to the title. Each of the properties of type Color support transparency.
Top
See Also

Reference

MapColorScaleTitle Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorScaleTitle Constructor

MapColorScaleTitle Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScaleTitle Class : MapColorScaleTitle Constructor
Initializes a new instance of the MapColorScaleTitle class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapColorScaleTitle()
See Also

Reference

MapColorScaleTitle Class
MapColorScaleTitle Members


MapColorScaleTitle Class Properties

MapColorScaleTitle Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorScaleTitle Class

For a list of all members of this type, see MapColorScaleTitle members.

Public Properties
 | Name | Description
Public Property | Caption | Caption of the title. An expression should evaluate to a System.String.
Public Property | Style | Gets or sets style properties to be applied to the title. Each of the properties of type Color support transparency.
Top
See Also

Reference

MapColorScaleTitle Class
GrapeCity.ActiveReports.PageReportModel Namespace


Caption Property (MapColorScaleTitle)

Caption Property (MapColorScaleTitle)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScaleTitle Class : Caption Property
Caption of the title. An expression should evaluate to a System.String.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Caption As ExpressionInfo
public ExpressionInfo Caption {get; set;}
See Also

Reference

MapColorScaleTitle Class
MapColorScaleTitle Members


Style Property (MapColorScaleTitle)

Style Property (MapColorScaleTitle)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapColorScaleTitle Class : Style Property
Gets or sets style properties to be applied to the title. Each of the properties of type Color support transparency.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As Style
public Style Style {get; set;}
See Also

Reference

MapColorScaleTitle Class
MapColorScaleTitle Members


MapCustomColorRule Class

MapCustomColorRule Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapCustomColorRule Class
Defines a set of custom colors for spatial elements based on a data field
Object Model
MapCustomColorRule Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapCustomColorRule
   Inherits MapColorRule
public sealed class MapCustomColorRule : MapColorRule
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule
GrapeCity.ActiveReports.PageReportModel.MapColorRule
GrapeCity.ActiveReports.PageReportModel.MapCustomColorRule

See Also

Reference

MapCustomColorRule Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapCustomColorRule Class Members

MapCustomColorRule Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapCustomColorRule Class

The following tables list the members exposed by MapCustomColorRule.

Public Constructors
 | Name | Description
Public Constructor | MapCustomColorRule Constructor | Initializes a new instance of the MapCustomColorRule class.
Top
Public Properties
 | Name | Description
Public Property | BucketCount | Defines the number of buckets for the specified distribution. Ignored if DistributionType is RuleDistributionType.Custom or if DataValue is not Scalar. An expression should evaluate to a System.Integer. The default value is 5 (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataValue | An expression to be evaluated on the scope of the spatial element. The appearance rule will be applied on the element based on its value. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DistributionType | Gets or sets the distribution type. That evaluates to one of RuleDistributionType. The default value is RuleDistributionType.Optimal. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | EndValue | Gets or sets the end value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | LegendName | Name of the legend in which the data field will appear. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | LegendText | Label to use in the legend for the data field. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | MapBuckets | Gets the set of buckets used to distribute the data. Mandatory if DistributionType = RuleDistributionType.Custom, otherwise ignored. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | MapCustomColors | Gets the custom colors to be used.
Public Property | ShowInColorScale | Gets or sets if the data field should be shown in the color scale. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapColorRule)
Public Property | StartValue | Gets or sets the start value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Top
See Also

Reference

MapCustomColorRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapCustomColorRule Constructor

MapCustomColorRule Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapCustomColorRule Class : MapCustomColorRule Constructor
Initializes a new instance of the MapCustomColorRule class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapCustomColorRule()
See Also

Reference

MapCustomColorRule Class
MapCustomColorRule Members


MapCustomColorRule Class Properties

MapCustomColorRule Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapCustomColorRule Class

For a list of all members of this type, see MapCustomColorRule members.

Public Properties
 | Name | Description
Public Property | BucketCount | Defines the number of buckets for the specified distribution. Ignored if DistributionType is RuleDistributionType.Custom or if DataValue is not Scalar. An expression should evaluate to a System.Integer. The default value is 5 (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataValue | An expression to be evaluated on the scope of the spatial element. The appearance rule will be applied on the element based on its value. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DistributionType | Gets or sets the distribution type. That evaluates to one of RuleDistributionType. The default value is RuleDistributionType.Optimal. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | EndValue | Gets or sets the end value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | LegendName | Name of the legend in which the data field will appear. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | LegendText | Label to use in the legend for the data field. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | MapBuckets | Gets the set of buckets used to distribute the data. Mandatory if DistributionType = RuleDistributionType.Custom, otherwise ignored. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | MapCustomColors | Gets the custom colors to be used.
Public Property | ShowInColorScale | Gets or sets if the data field should be shown in the color scale. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapColorRule)
Public Property | StartValue | Gets or sets the start value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Top
See Also

Reference

MapCustomColorRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapCustomColors Property

MapCustomColors Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapCustomColorRule Class : MapCustomColors Property
Gets the custom colors to be used.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MapCustomColors As System.Collections.Generic.IList(Of ExpressionInfo)
public System.Collections.Generic.IList<ExpressionInfo> MapCustomColors {get;}
See Also

Reference

MapCustomColorRule Class
MapCustomColorRule Members


MapCustomView Class

MapCustomView Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapCustomView Class
Defines the center of the view port based on an arbitrary center point
Object Model
MapCustomView Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapCustomView
   Inherits MapView
public sealed class MapCustomView : MapView
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapView
GrapeCity.ActiveReports.PageReportModel.MapCustomView

See Also

Reference

MapCustomView Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapCustomView Class Members

MapCustomView Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapCustomView Class

The following tables list the members exposed by MapCustomView.

Public Constructors
 | Name | Description
Public Constructor | MapCustomView Constructor | Initializes a new instance of the MapCustomView class.
Top
Public Properties
 | Name | Description
Public Property | CenterX | X Center of the view in percent of the map content. An expression should evaluate to a System.Double. The default value is 50.
Public Property | CenterY | Y Center of the view in percent of the map content. An expression should evaluate to a System.Double. The default value is 50.
Public Property | Zoom | Gets or sets the viewport zoom level. Automatically calculated if omitted based on the MapView type. An expression should evaluate to a System.Double. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapView)
Top
See Also

Reference

MapCustomView Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapCustomView Constructor

MapCustomView Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapCustomView Class : MapCustomView Constructor
Initializes a new instance of the MapCustomView class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapCustomView()
See Also

Reference

MapCustomView Class
MapCustomView Members


MapCustomView Class Properties

MapCustomView Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapCustomView Class

For a list of all members of this type, see MapCustomView members.

Public Properties
 | Name | Description
Public Property | CenterX | X Center of the view in percent of the map content. An expression should evaluate to a System.Double. The default value is 50.
Public Property | CenterY | Y Center of the view in percent of the map content. An expression should evaluate to a System.Double. The default value is 50.
Public Property | Zoom | Gets or sets the viewport zoom level. Automatically calculated if omitted based on the MapView type. An expression should evaluate to a System.Double. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapView)
Top
See Also

Reference

MapCustomView Class
GrapeCity.ActiveReports.PageReportModel Namespace


CenterX Property (MapCustomView)

CenterX Property (MapCustomView)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapCustomView Class : CenterX Property
X Center of the view in percent of the map content. An expression should evaluate to a System.Double. The default value is 50.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CenterX As ExpressionInfo
public ExpressionInfo CenterX {get; set;}
See Also

Reference

MapCustomView Class
MapCustomView Members


CenterY Property (MapCustomView)

CenterY Property (MapCustomView)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapCustomView Class : CenterY Property
Y Center of the view in percent of the map content. An expression should evaluate to a System.Double. The default value is 50.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CenterY As ExpressionInfo
public ExpressionInfo CenterY {get; set;}
See Also

Reference

MapCustomView Class
MapCustomView Members


MapDataBoundView Class

MapDataBoundView Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDataBoundView Class
Defines the center/zoom of the view port based on the spatial map elements bound to data
Object Model
MapDataBoundView Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapDataBoundView
   Inherits MapView
public sealed class MapDataBoundView : MapView
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapView
GrapeCity.ActiveReports.PageReportModel.MapDataBoundView

See Also

Reference

MapDataBoundView Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapDataBoundView Class Members

MapDataBoundView Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDataBoundView Class

The following tables list the members exposed by MapDataBoundView.

Public Constructors
 | Name | Description
Public Constructor | MapDataBoundView Constructor | Initializes a new instance of the MapDataBoundView class.
Top
Public Properties
 | Name | Description
Public Property | Zoom | Gets or sets the viewport zoom level. Automatically calculated if omitted based on the MapView type. An expression should evaluate to a System.Double. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapView)
Top
See Also

Reference

MapDataBoundView Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapDataBoundView Constructor

MapDataBoundView Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDataBoundView Class : MapDataBoundView Constructor
Initializes a new instance of the MapDataBoundView class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapDataBoundView()
See Also

Reference

MapDataBoundView Class
MapDataBoundView Members


MapDataRegion Class

MapDataRegion Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDataRegion Class
Defines a data region for the map
Object Model
MapDataRegion Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapDataRegion
public sealed class MapDataRegion
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapDataRegion

See Also

Reference

MapDataRegion Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapDataRegion Class Members

MapDataRegion Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDataRegion Class

The following tables list the members exposed by MapDataRegion.

Public Constructors
 | Name | Description
Public Constructor | MapDataRegion Constructor | Initializes a new instance of the MapDataRegion class.
Top
Public Properties
 | Name | Description
Public Property | DataSetName | Gets or sets which data set to use for this data region.
Public Property | Filters | Gets filters to apply to each row of data in the data region.
Public Property | MapMember | Gets or sets group, and filter behavior for the data.
Public Property | Name | Gets or sets the map's name
Top
See Also

Reference

MapDataRegion Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapDataRegion Constructor

MapDataRegion Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDataRegion Class : MapDataRegion Constructor
Initializes a new instance of the MapDataRegion class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapDataRegion()
See Also

Reference

MapDataRegion Class
MapDataRegion Members


MapDataRegion Class Properties

MapDataRegion Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDataRegion Class

For a list of all members of this type, see MapDataRegion members.

Public Properties
 | Name | Description
Public Property | DataSetName | Gets or sets which data set to use for this data region.
Public Property | Filters | Gets filters to apply to each row of data in the data region.
Public Property | MapMember | Gets or sets group, and filter behavior for the data.
Public Property | Name | Gets or sets the map's name
Top
See Also

Reference

MapDataRegion Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataSetName Property (MapDataRegion)

DataSetName Property (MapDataRegion)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDataRegion Class : DataSetName Property
Gets or sets which data set to use for this data region.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataSetName As System.String
public System.string DataSetName {get; set;}
See Also

Reference

MapDataRegion Class
MapDataRegion Members


Filters Property (MapDataRegion)

Filters Property (MapDataRegion)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDataRegion Class : Filters Property
Gets filters to apply to each row of data in the data region.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Filters As System.Collections.Generic.IList(Of Filter)
public System.Collections.Generic.IList<Filter> Filters {get;}
See Also

Reference

MapDataRegion Class
MapDataRegion Members


MapMember Property

MapMember Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDataRegion Class : MapMember Property
Gets or sets group, and filter behavior for the data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapMember As MapMember
public MapMember MapMember {get; set;}
See Also

Reference

MapDataRegion Class
MapDataRegion Members


Name Property (MapDataRegion)

Name Property (MapDataRegion)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDataRegion Class : Name Property
Gets or sets the map's name
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}
See Also

Reference

MapDataRegion Class
MapDataRegion Members


MapDistanceScale Class

MapDistanceScale Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDistanceScale Class
Defines the map distance scale
Object Model
MapDistanceScale Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapDistanceScale
   Inherits MapDockableSubItem
public sealed class MapDistanceScale : MapDockableSubItem
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSubItem
GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem
GrapeCity.ActiveReports.PageReportModel.MapDistanceScale

See Also

Reference

MapDistanceScale Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapDistanceScale Class Members

MapDistanceScale Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDistanceScale Class

The following tables list the members exposed by MapDistanceScale.

Public Constructors
 | Name | Description
Public Constructor | MapDistanceScale Constructor | Initializes a new instance of the MapDistanceScale class.
Top
Public Properties
 | Name | Description
Public Property | ActionInfo | Actions for the map sub item. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | BottomMargin | Width of the bottom margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | DockOutsideViewport | Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | Hidden | Gets or sets the item is hidden. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | LeftMargin | Width of the left margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapLocation | Gets or sets the sub item location within the map. Default for MapViewport (0,0), otherwise MapDockableSubItem.Position is used. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapSize | Gets or sets the sub item size within the map. If omitted for MapViewport the default is (100,100) in percents. Automatically calculated for MapDockableSubItem. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | Position | The position of the sub item. Ignored if MapLocation is defined. That evaluates to one of MapDockableSubItem.MapPosition. The default value is MapDockableSubItem.MapPosition.TopCenter. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | RightMargin | Width of the right margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | ScaleBorderColor | Defines the border color for the scale. Default value is DarkGray
Public Property | ScaleColor | Gets or sets the color for the scale. Default value is White
Public Property | Style | Gets or sets style properties for map sub item. Each of the properties of type Color support transparency. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | ToolTip | Tool tip to display for the map sub item. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | TopMargin | Width of the top margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | ZIndex | Drawing order of the item within the map. An expression should evaluate to a System.Integer. The default value is 0. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Top
See Also

Reference

MapDistanceScale Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapDistanceScale Constructor

MapDistanceScale Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDistanceScale Class : MapDistanceScale Constructor
Initializes a new instance of the MapDistanceScale class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapDistanceScale()
See Also

Reference

MapDistanceScale Class
MapDistanceScale Members


MapDistanceScale Class Properties

MapDistanceScale Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDistanceScale Class

For a list of all members of this type, see MapDistanceScale members.

Public Properties
 | Name | Description
Public Property | ActionInfo | Actions for the map sub item. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | BottomMargin | Width of the bottom margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | DockOutsideViewport | Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | Hidden | Gets or sets the item is hidden. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | LeftMargin | Width of the left margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapLocation | Gets or sets the sub item location within the map. Default for MapViewport (0,0), otherwise MapDockableSubItem.Position is used. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapSize | Gets or sets the sub item size within the map. If omitted for MapViewport the default is (100,100) in percents. Automatically calculated for MapDockableSubItem. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | Position | The position of the sub item. Ignored if MapLocation is defined. That evaluates to one of MapDockableSubItem.MapPosition. The default value is MapDockableSubItem.MapPosition.TopCenter. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | RightMargin | Width of the right margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | ScaleBorderColor | Defines the border color for the scale. Default value is DarkGray
Public Property | ScaleColor | Gets or sets the color for the scale. Default value is White
Public Property | Style | Gets or sets style properties for map sub item. Each of the properties of type Color support transparency. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | ToolTip | Tool tip to display for the map sub item. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | TopMargin | Width of the top margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | ZIndex | Drawing order of the item within the map. An expression should evaluate to a System.Integer. The default value is 0. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Top
See Also

Reference

MapDistanceScale Class
GrapeCity.ActiveReports.PageReportModel Namespace


ScaleBorderColor Property (MapDistanceScale)

ScaleBorderColor Property (MapDistanceScale)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDistanceScale Class : ScaleBorderColor Property
Defines the border color for the scale. Default value is DarkGray
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ScaleBorderColor As ExpressionInfo
public ExpressionInfo ScaleBorderColor {get; set;}
See Also

Reference

MapDistanceScale Class
MapDistanceScale Members


ScaleColor Property (MapDistanceScale)

ScaleColor Property (MapDistanceScale)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDistanceScale Class : ScaleColor Property
Gets or sets the color for the scale. Default value is White
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ScaleColor As ExpressionInfo
public ExpressionInfo ScaleColor {get; set;}
See Also

Reference

MapDistanceScale Class
MapDistanceScale Members


MapDockableSubItem Class

MapDockableSubItem Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDockableSubItem Class
Defines the common properties for map dockable sub items
Object Model
MapDockableSubItem Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class MapDockableSubItem
   Inherits MapSubItem
public abstract class MapDockableSubItem : MapSubItem
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSubItem
GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem
GrapeCity.ActiveReports.PageReportModel.MapColorScale
GrapeCity.ActiveReports.PageReportModel.MapDistanceScale
GrapeCity.ActiveReports.PageReportModel.MapLegend
GrapeCity.ActiveReports.PageReportModel.MapTitle

See Also

Reference

MapDockableSubItem Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapDockableSubItem Class Members

MapDockableSubItem Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDockableSubItem Class

The following tables list the members exposed by MapDockableSubItem.

Public Properties
 | Name | Description
Public Property | ActionInfo | Actions for the map sub item.
Public Property | BottomMargin | Width of the bottom margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | DockOutsideViewport | Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined. An expression should evaluate to a System.Boolean.
Public Property | Hidden | Gets or sets the item is hidden. An expression should evaluate to a System.Boolean.
Public Property | LeftMargin | Width of the left margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapLocation | Gets or sets the sub item location within the map. Default for MapViewport (0,0), otherwise Position is used. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapSize | Gets or sets the sub item size within the map. If omitted for MapViewport the default is (100,100) in percents. Automatically calculated for MapDockableSubItem. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | Position | The position of the sub item. Ignored if MapLocation is defined. That evaluates to one of MapDockableSubItem.MapPosition. The default value is MapDockableSubItem.MapPosition.TopCenter.
Public Property | RightMargin | Width of the right margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | Style | Gets or sets style properties for map sub item. Each of the properties of type Color support transparency. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | ToolTip | Tool tip to display for the map sub item. An expression should evaluate to a System.String.
Public Property | TopMargin | Width of the top margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | ZIndex | Drawing order of the item within the map. An expression should evaluate to a System.Integer. The default value is 0. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Top
See Also

Reference

MapDockableSubItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapDockableSubItem Class Properties

MapDockableSubItem Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDockableSubItem Class

For a list of all members of this type, see MapDockableSubItem members.

Public Properties
 | Name | Description
Public Property | ActionInfo | Actions for the map sub item.
Public Property | BottomMargin | Width of the bottom margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | DockOutsideViewport | Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined. An expression should evaluate to a System.Boolean.
Public Property | Hidden | Gets or sets the item is hidden. An expression should evaluate to a System.Boolean.
Public Property | LeftMargin | Width of the left margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapLocation | Gets or sets the sub item location within the map. Default for MapViewport (0,0), otherwise Position is used. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapSize | Gets or sets the sub item size within the map. If omitted for MapViewport the default is (100,100) in percents. Automatically calculated for MapDockableSubItem. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | Position | The position of the sub item. Ignored if MapLocation is defined. That evaluates to one of MapDockableSubItem.MapPosition. The default value is MapDockableSubItem.MapPosition.TopCenter.
Public Property | RightMargin | Width of the right margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | Style | Gets or sets style properties for map sub item. Each of the properties of type Color support transparency. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | ToolTip | Tool tip to display for the map sub item. An expression should evaluate to a System.String.
Public Property | TopMargin | Width of the top margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | ZIndex | Drawing order of the item within the map. An expression should evaluate to a System.Integer. The default value is 0. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Top
See Also

Reference

MapDockableSubItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


ActionInfo Property (MapDockableSubItem)

ActionInfo Property (MapDockableSubItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDockableSubItem Class : ActionInfo Property
Actions for the map sub item.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ActionInfo As ActionInfo
public ActionInfo ActionInfo {get; set;}
See Also

Reference

MapDockableSubItem Class
MapDockableSubItem Members


DockOutsideViewport Property (MapDockableSubItem)

DockOutsideViewport Property (MapDockableSubItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDockableSubItem Class : DockOutsideViewport Property
Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined. An expression should evaluate to a System.Boolean.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DockOutsideViewport As ExpressionInfo
public ExpressionInfo DockOutsideViewport {get; set;}
See Also

Reference

MapDockableSubItem Class
MapDockableSubItem Members


Hidden Property (MapDockableSubItem)

Hidden Property (MapDockableSubItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDockableSubItem Class : Hidden Property
Gets or sets the item is hidden. An expression should evaluate to a System.Boolean.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Hidden As ExpressionInfo
public ExpressionInfo Hidden {get; set;}
See Also

Reference

MapDockableSubItem Class
MapDockableSubItem Members


Position Property (MapDockableSubItem)

Position Property (MapDockableSubItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDockableSubItem Class : Position Property
The position of the sub item. Ignored if MapLocation is defined. That evaluates to one of MapDockableSubItem.MapPosition. The default value is MapDockableSubItem.MapPosition.TopCenter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Position As ExpressionInfo
public ExpressionInfo Position {get; set;}
See Also

Reference

MapDockableSubItem Class
MapDockableSubItem Members


ToolTip Property (MapDockableSubItem)

ToolTip Property (MapDockableSubItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapDockableSubItem Class : ToolTip Property
Tool tip to display for the map sub item. An expression should evaluate to a System.String.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ToolTip As ExpressionInfo
public ExpressionInfo ToolTip {get; set;}
See Also

Reference

MapDockableSubItem Class
MapDockableSubItem Members


MapElementView Class

MapElementView Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapElementView Class
Defines the center/zoom of the view port based on map spatial element
Object Model
MapElementView Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapElementView
   Inherits MapView
public sealed class MapElementView : MapView
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapView
GrapeCity.ActiveReports.PageReportModel.MapElementView

See Also

Reference

MapElementView Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapElementView Class Members

MapElementView Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapElementView Class

The following tables list the members exposed by MapElementView.

Public Constructors
 | Name | Description
Public Constructor | MapElementView Constructor | Initializes a new instance of the MapElementView class.
Top
Public Properties
 | Name | Description
Public Property | LayerName | Layer name containing the spatial element to be centered. An expression should evaluate to a System.String.
Public Property | MapBindingFieldPairs | Gets the set of fields used to identify the element to be centered. If omitted, the view center will be the center of the bounding rectangle of all the map elements of the specified layer.
Public Property | Zoom | Gets or sets the viewport zoom level. Automatically calculated if omitted based on the MapView type. An expression should evaluate to a System.Double. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapView)
Top
See Also

Reference

MapElementView Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapElementView Constructor

MapElementView Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapElementView Class : MapElementView Constructor
Initializes a new instance of the MapElementView class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapElementView()
See Also

Reference

MapElementView Class
MapElementView Members


MapElementView Class Properties

MapElementView Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapElementView Class

For a list of all members of this type, see MapElementView members.

Public Properties
 | Name | Description
Public Property | LayerName | Layer name containing the spatial element to be centered. An expression should evaluate to a System.String.
Public Property | MapBindingFieldPairs | Gets the set of fields used to identify the element to be centered. If omitted, the view center will be the center of the bounding rectangle of all the map elements of the specified layer.
Public Property | Zoom | Gets or sets the viewport zoom level. Automatically calculated if omitted based on the MapView type. An expression should evaluate to a System.Double. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapView)
Top
See Also

Reference

MapElementView Class
GrapeCity.ActiveReports.PageReportModel Namespace


LayerName Property (MapElementView)

LayerName Property (MapElementView)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapElementView Class : LayerName Property
Layer name containing the spatial element to be centered. An expression should evaluate to a System.String.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LayerName As ExpressionInfo
public ExpressionInfo LayerName {get; set;}
See Also

Reference

MapElementView Class
MapElementView Members


MapBindingFieldPairs Property (MapElementView)

MapBindingFieldPairs Property (MapElementView)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapElementView Class : MapBindingFieldPairs Property
Gets the set of fields used to identify the element to be centered. If omitted, the view center will be the center of the bounding rectangle of all the map elements of the specified layer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MapBindingFieldPairs As System.Collections.Generic.IList(Of MapBindingFieldPair)
public System.Collections.Generic.IList<MapBindingFieldPair> MapBindingFieldPairs {get;}
See Also

Reference

MapElementView Class
MapElementView Members


MapField Class

MapField Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapField Class
Defines a field for map elements within a static layer
Object Model
MapField Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapField
public sealed class MapField
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapField

See Also

Reference

MapField Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapField Class Members

MapField Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapField Class

The following tables list the members exposed by MapField.

Public Constructors
 | Name | Description
Public Constructor | MapField Constructor | Initializes a new instance of the MapField class.
Top
Public Properties
 | Name | Description
Public Property | Name | Gets or sets the field name.
Public Property | Value | Gets or sets the field value.
Top
See Also

Reference

MapField Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapField Constructor

MapField Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapField Class : MapField Constructor
Initializes a new instance of the MapField class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapField()
See Also

Reference

MapField Class
MapField Members


MapField Class Properties

MapField Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapField Class

For a list of all members of this type, see MapField members.

Public Properties
 | Name | Description
Public Property | Name | Gets or sets the field name.
Public Property | Value | Gets or sets the field value.
Top
See Also

Reference

MapField Class
GrapeCity.ActiveReports.PageReportModel Namespace


Name Property (MapField)

Name Property (MapField)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapField Class : Name Property
Gets or sets the field name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}
See Also

Reference

MapField Class
MapField Members


Value Property (MapField)

Value Property (MapField)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapField Class : Value Property
Gets or sets the field value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As System.String
public System.string Value {get; set;}
See Also

Reference

MapField Class
MapField Members


MapFieldDefinition Class

MapFieldDefinition Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapFieldDefinition Class
Defines a field definition for map elements within a static layer
Object Model
MapFieldDefinition Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapFieldDefinition
public sealed class MapFieldDefinition
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapFieldDefinition

See Also

Reference

MapFieldDefinition Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapFieldDefinition Class Members

MapFieldDefinition Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapFieldDefinition Class

The following tables list the members exposed by MapFieldDefinition.

Public Constructors
 | Name | Description
Public Constructor | MapFieldDefinition Constructor | Initializes a new instance of the MapFieldDefinition class.
Top
Public Properties
 | Name | Description
Public Property | DataType | The data type of the field. That evaluates to one of MapDataType.
Public Property | Name | Gets or sets the field name.
Top
See Also

Reference

MapFieldDefinition Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapFieldDefinition Constructor

MapFieldDefinition Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapFieldDefinition Class : MapFieldDefinition Constructor
Initializes a new instance of the MapFieldDefinition class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapFieldDefinition()
See Also

Reference

MapFieldDefinition Class
MapFieldDefinition Members


MapFieldDefinition Class Properties

MapFieldDefinition Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapFieldDefinition Class

For a list of all members of this type, see MapFieldDefinition members.

Public Properties
 | Name | Description
Public Property | DataType | The data type of the field. That evaluates to one of MapDataType.
Public Property | Name | Gets or sets the field name.
Top
See Also

Reference

MapFieldDefinition Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataType Property (MapFieldDefinition)

DataType Property (MapFieldDefinition)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapFieldDefinition Class : DataType Property
The data type of the field. That evaluates to one of MapDataType.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataType As MapDataType
public MapDataType DataType {get; set;}
See Also

Reference

MapFieldDefinition Class
MapFieldDefinition Members


Name Property (MapFieldDefinition)

Name Property (MapFieldDefinition)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapFieldDefinition Class : Name Property
Gets or sets the field name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}
See Also

Reference

MapFieldDefinition Class
MapFieldDefinition Members


MapGridLines Class

MapGridLines Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapGridLines Class
Defines the properties for map grid (meridians/parallels)
Object Model
MapGridLines Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapGridLines
public sealed class MapGridLines
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapGridLines

See Also

Reference

MapGridLines Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapGridLines Class Members

MapGridLines Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapGridLines Class

The following tables list the members exposed by MapGridLines.

Public Constructors
 | Name | Description
Public Constructor | MapGridLines Constructor | Initializes a new instance of the MapGridLines class.
Top
Public Properties
 | Name | Description
Public Property | Hidden | Gets or sets the gridlines are hidden. An expression should evaluate to a System.Boolean.
Public Property | Interval | Gets or sets the spacing between the grid lines in geographic units. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Public Property | LabelPosition | Gets or sets the position for grid labels. That evaluates to one of MapGridLines.LabelPositionType. The default value is MapGridLines.LabelPositionType.Near.
Public Property | ShowLabels | Gets or sets if the labels should be shown. An expression should evaluate to a System.Boolean.
Public Property | Style | Gets the style of the grid lines.
Top
See Also

Reference

MapGridLines Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapGridLines Constructor

MapGridLines Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapGridLines Class : MapGridLines Constructor
Initializes a new instance of the MapGridLines class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapGridLines()
See Also

Reference

MapGridLines Class
MapGridLines Members


MapGridLines Class Properties

MapGridLines Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapGridLines Class

For a list of all members of this type, see MapGridLines members.

Public Properties
 | Name | Description
Public Property | Hidden | Gets or sets the gridlines are hidden. An expression should evaluate to a System.Boolean.
Public Property | Interval | Gets or sets the spacing between the grid lines in geographic units. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Public Property | LabelPosition | Gets or sets the position for grid labels. That evaluates to one of MapGridLines.LabelPositionType. The default value is MapGridLines.LabelPositionType.Near.
Public Property | ShowLabels | Gets or sets if the labels should be shown. An expression should evaluate to a System.Boolean.
Public Property | Style | Gets the style of the grid lines.
Top
See Also

Reference

MapGridLines Class
GrapeCity.ActiveReports.PageReportModel Namespace


Hidden Property (MapGridLines)

Hidden Property (MapGridLines)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapGridLines Class : Hidden Property
Gets or sets the gridlines are hidden. An expression should evaluate to a System.Boolean.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Hidden As ExpressionInfo
public ExpressionInfo Hidden {get; set;}
See Also

Reference

MapGridLines Class
MapGridLines Members


Interval Property (MapGridLines)

Interval Property (MapGridLines)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapGridLines Class : Interval Property
Gets or sets the spacing between the grid lines in geographic units. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Interval As ExpressionInfo
public ExpressionInfo Interval {get; set;}
See Also

Reference

MapGridLines Class
MapGridLines Members


LabelPosition Property (MapGridLines)

LabelPosition Property (MapGridLines)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapGridLines Class : LabelPosition Property
Gets or sets the position for grid labels. That evaluates to one of MapGridLines.LabelPositionType. The default value is MapGridLines.LabelPositionType.Near.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LabelPosition As ExpressionInfo
public ExpressionInfo LabelPosition {get; set;}
See Also

Reference

MapGridLines Class
MapGridLines Members


ShowLabels Property (MapGridLines)

ShowLabels Property (MapGridLines)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapGridLines Class : ShowLabels Property
Gets or sets if the labels should be shown. An expression should evaluate to a System.Boolean.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShowLabels As ExpressionInfo
public ExpressionInfo ShowLabels {get; set;}
See Also

Reference

MapGridLines Class
MapGridLines Members


Style Property (MapGridLines)

Style Property (MapGridLines)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapGridLines Class : Style Property
Gets the style of the grid lines.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As Style
public Style Style {get; set;}

Property Value

The style.
See Also

Reference

MapGridLines Class
MapGridLines Members


MapLayer Class

MapLayer Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLayer Class
Defines a layer to be drawn within a map
Object Model
MapLayer Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class MapLayer
public abstract class MapLayer
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLayer
GrapeCity.ActiveReports.PageReportModel.MapTileLayer
GrapeCity.ActiveReports.PageReportModel.MapVectorLayer

See Also

Reference

MapLayer Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapLayer Class Members

MapLayer Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLayer Class

The following tables list the members exposed by MapLayer.

Public Properties
 | Name | Description
Public Property | MaximumZoom | Gets or sets the maximum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 200.
Public Property | MinimumZoom | Gets or sets the minimum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 50.
Public Property | Name | Name of the layer.
Public Property | Transparency | Gets or sets the transparency for all map elements contained in this layer. Measured in percents. An expression should evaluate to a System.Double. The default value is 0.
Public Property | VisibilityMode | Gets or sets the layer visibility mode. That evaluates to one of MapVisibilityMode. The default value is MapVisibilityMode.Visible.
Top
See Also

Reference

MapLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLayer Class Properties

MapLayer Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLayer Class

For a list of all members of this type, see MapLayer members.

Public Properties
 | Name | Description
Public Property | MaximumZoom | Gets or sets the maximum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 200.
Public Property | MinimumZoom | Gets or sets the minimum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 50.
Public Property | Name | Name of the layer.
Public Property | Transparency | Gets or sets the transparency for all map elements contained in this layer. Measured in percents. An expression should evaluate to a System.Double. The default value is 0.
Public Property | VisibilityMode | Gets or sets the layer visibility mode. That evaluates to one of MapVisibilityMode. The default value is MapVisibilityMode.Visible.
Top
See Also

Reference

MapLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


MaximumZoom Property (MapLayer)

MaximumZoom Property (MapLayer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLayer Class : MaximumZoom Property
Gets or sets the maximum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 200.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaximumZoom As ExpressionInfo
public ExpressionInfo MaximumZoom {get; set;}
See Also

Reference

MapLayer Class
MapLayer Members


MinimumZoom Property (MapLayer)

MinimumZoom Property (MapLayer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLayer Class : MinimumZoom Property
Gets or sets the minimum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 50.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinimumZoom As ExpressionInfo
public ExpressionInfo MinimumZoom {get; set;}
See Also

Reference

MapLayer Class
MapLayer Members


Name Property (MapLayer)

Name Property (MapLayer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLayer Class : Name Property
Name of the layer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}
See Also

Reference

MapLayer Class
MapLayer Members


Transparency Property (MapLayer)

Transparency Property (MapLayer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLayer Class : Transparency Property
Gets or sets the transparency for all map elements contained in this layer. Measured in percents. An expression should evaluate to a System.Double. The default value is 0.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Transparency As ExpressionInfo
public ExpressionInfo Transparency {get; set;}
See Also

Reference

MapLayer Class
MapLayer Members


VisibilityMode Property (MapLayer)

VisibilityMode Property (MapLayer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLayer Class : VisibilityMode Property
Gets or sets the layer visibility mode. That evaluates to one of MapVisibilityMode. The default value is MapVisibilityMode.Visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property VisibilityMode As ExpressionInfo
public ExpressionInfo VisibilityMode {get; set;}
See Also

Reference

MapLayer Class
MapLayer Members


MapLegend Class

MapLegend Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLegend Class
Defines a legend to be drawn within a map
Object Model
MapLegend Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapLegend
   Inherits MapDockableSubItem
public sealed class MapLegend : MapDockableSubItem
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSubItem
GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem
GrapeCity.ActiveReports.PageReportModel.MapLegend

See Also

Reference

MapLegend Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapLegend Class Members

MapLegend Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLegend Class

The following tables list the members exposed by MapLegend.

Public Constructors
 | Name | Description
Public Constructor | MapLegend Constructor | Initializes a new instance of the MapLegend class.
Top
Public Properties
 | Name | Description
Public Property | ActionInfo | Actions for the map sub item. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | AutoFitTextDisabled | Gets or sets text will not be autosized to fit in the legend area. An expression should evaluate to a System.Boolean.
Public Property | BottomMargin | Width of the bottom margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | DockOutsideViewport | Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | EquallySpacedItems | Gets or sets legend items should be equally spaced. An expression should evaluate to a System.Boolean.
Public Property | Hidden | Gets or sets the item is hidden. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | InterlacedRows | Gets or sets legend rows should use interlaced colors. An expression should evaluate to a System.Boolean.
Public Property | InterlacedRowsColor | The background color to use for interlaced legend rows. The default value is LightGray.
Public Property | Layout | The arrangement of labels within the legend. That evaluates to one of MapLegend.LegendLayout. The default value is MapLegend.LegendLayout.AutoTable.
Public Property | LeftMargin | Width of the left margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapLegendTitle | Title displays in the legend.
Public Property | MapLocation | Gets or sets the sub item location within the map. Default for MapViewport (0,0), otherwise Position is used. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapSize | Gets or sets the sub item size within the map. If omitted for MapViewport the default is (100,100) in percents. Automatically calculated for MapDockableSubItem. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MinFontSize | Minimum size for autosized legend text. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 7pt.
Public Property | Name | Name of the legend.
Public Property | Position | The position of the sub item. Ignored if MapLocation is defined. That evaluates to one of MapDockableSubItem.MapPosition. The default value is MapDockableSubItem.MapPosition.TopCenter. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | RightMargin | Width of the right margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | Style | Gets or sets style properties for map sub item. Each of the properties of type Color support transparency. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | TextWrapThreshold | Number of characters after which the legend text wraps. An expression should evaluate to a System.Integer. The default value is 25.
Public Property | ToolTip | Tool tip to display for the map sub item. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | TopMargin | Width of the top margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | ZIndex | Drawing order of the item within the map. An expression should evaluate to a System.Integer. The default value is 0. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Top
See Also

Reference

MapLegend Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLegend Constructor

MapLegend Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend Class : MapLegend Constructor
Initializes a new instance of the MapLegend class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapLegend()
See Also

Reference

MapLegend Class
MapLegend Members


MapLegend Class Properties

MapLegend Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLegend Class

For a list of all members of this type, see MapLegend members.

Public Properties
 | Name | Description
Public Property | ActionInfo | Actions for the map sub item. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | AutoFitTextDisabled | Gets or sets text will not be autosized to fit in the legend area. An expression should evaluate to a System.Boolean.
Public Property | BottomMargin | Width of the bottom margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | DockOutsideViewport | Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | EquallySpacedItems | Gets or sets legend items should be equally spaced. An expression should evaluate to a System.Boolean.
Public Property | Hidden | Gets or sets the item is hidden. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | InterlacedRows | Gets or sets legend rows should use interlaced colors. An expression should evaluate to a System.Boolean.
Public Property | InterlacedRowsColor | The background color to use for interlaced legend rows. The default value is LightGray.
Public Property | Layout | The arrangement of labels within the legend. That evaluates to one of MapLegend.LegendLayout. The default value is MapLegend.LegendLayout.AutoTable.
Public Property | LeftMargin | Width of the left margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapLegendTitle | Title displays in the legend.
Public Property | MapLocation | Gets or sets the sub item location within the map. Default for MapViewport (0,0), otherwise Position is used. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapSize | Gets or sets the sub item size within the map. If omitted for MapViewport the default is (100,100) in percents. Automatically calculated for MapDockableSubItem. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MinFontSize | Minimum size for autosized legend text. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 7pt.
Public Property | Name | Name of the legend.
Public Property | Position | The position of the sub item. Ignored if MapLocation is defined. That evaluates to one of MapDockableSubItem.MapPosition. The default value is MapDockableSubItem.MapPosition.TopCenter. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | RightMargin | Width of the right margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | Style | Gets or sets style properties for map sub item. Each of the properties of type Color support transparency. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | TextWrapThreshold | Number of characters after which the legend text wraps. An expression should evaluate to a System.Integer. The default value is 25.
Public Property | ToolTip | Tool tip to display for the map sub item. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | TopMargin | Width of the top margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | ZIndex | Drawing order of the item within the map. An expression should evaluate to a System.Integer. The default value is 0. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Top
See Also

Reference

MapLegend Class
GrapeCity.ActiveReports.PageReportModel Namespace


AutoFitTextDisabled Property

AutoFitTextDisabled Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend Class : AutoFitTextDisabled Property
Gets or sets text will not be autosized to fit in the legend area. An expression should evaluate to a System.Boolean.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoFitTextDisabled As ExpressionInfo
public ExpressionInfo AutoFitTextDisabled {get; set;}
See Also

Reference

MapLegend Class
MapLegend Members


EquallySpacedItems Property (MapLegend)

EquallySpacedItems Property (MapLegend)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend Class : EquallySpacedItems Property
Gets or sets legend items should be equally spaced. An expression should evaluate to a System.Boolean.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EquallySpacedItems As ExpressionInfo
public ExpressionInfo EquallySpacedItems {get; set;}
See Also

Reference

MapLegend Class
MapLegend Members


InterlacedRows Property (MapLegend)

InterlacedRows Property (MapLegend)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend Class : InterlacedRows Property
Gets or sets legend rows should use interlaced colors. An expression should evaluate to a System.Boolean.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property InterlacedRows As ExpressionInfo
public ExpressionInfo InterlacedRows {get; set;}
See Also

Reference

MapLegend Class
MapLegend Members


InterlacedRowsColor Property (MapLegend)

InterlacedRowsColor Property (MapLegend)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend Class : InterlacedRowsColor Property
The background color to use for interlaced legend rows. The default value is LightGray.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property InterlacedRowsColor As ExpressionInfo
public ExpressionInfo InterlacedRowsColor {get; set;}
See Also

Reference

MapLegend Class
MapLegend Members


Layout Property (MapLegend)

Layout Property (MapLegend)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend Class : Layout Property
The arrangement of labels within the legend. That evaluates to one of MapLegend.LegendLayout. The default value is MapLegend.LegendLayout.AutoTable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Layout As ExpressionInfo
public ExpressionInfo Layout {get; set;}
See Also

Reference

MapLegend Class
MapLegend Members


MapLegendTitle Property

MapLegendTitle Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend Class : MapLegendTitle Property
Title displays in the legend.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapLegendTitle As MapLegendTitle
public MapLegendTitle MapLegendTitle {get; set;}
See Also

Reference

MapLegend Class
MapLegend Members


MinFontSize Property (MapLegend)

MinFontSize Property (MapLegend)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend Class : MinFontSize Property
Minimum size for autosized legend text. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 7pt.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinFontSize As ExpressionInfo
public ExpressionInfo MinFontSize {get; set;}
See Also

Reference

MapLegend Class
MapLegend Members


Name Property (MapLegend)

Name Property (MapLegend)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend Class : Name Property
Name of the legend.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}
See Also

Reference

MapLegend Class
MapLegend Members


TextWrapThreshold Property (MapLegend)

TextWrapThreshold Property (MapLegend)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegend Class : TextWrapThreshold Property
Number of characters after which the legend text wraps. An expression should evaluate to a System.Integer. The default value is 25.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TextWrapThreshold As ExpressionInfo
public ExpressionInfo TextWrapThreshold {get; set;}
See Also

Reference

MapLegend Class
MapLegend Members


MapLegendTitle Class

MapLegendTitle Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLegendTitle Class
Defines a title for a map legend
Object Model
MapLegendTitle Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapLegendTitle
public sealed class MapLegendTitle
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLegendTitle

See Also

Reference

MapLegendTitle Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapLegendTitle Class Members

MapLegendTitle Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLegendTitle Class

The following tables list the members exposed by MapLegendTitle.

Public Constructors
 | Name | Description
Public Constructor | MapLegendTitle Constructor | Initializes a new instance of the MapLegendTitle class.
Top
Public Properties
 | Name | Description
Public Property | Caption | Caption of the title. An expression should evaluate to a System.String.
Public Property | Style | Gets or sets style properties for the title. Each of the properties of type Color support transparency.
Public Property | TitleSeparator | Gets or sets what type of separator to use for the legend title. That evaluates to one of MapLegendTitle.LegendTitleSeparator. The default value is MapLegendTitle.LegendTitleSeparator.None.
Public Property | TitleSeparatorColor | Gets or sets the color for the title separator. The default value is Gray
Top
See Also

Reference

MapLegendTitle Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLegendTitle Constructor

MapLegendTitle Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegendTitle Class : MapLegendTitle Constructor
Initializes a new instance of the MapLegendTitle class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapLegendTitle()
See Also

Reference

MapLegendTitle Class
MapLegendTitle Members


MapLegendTitle Class Properties

MapLegendTitle Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLegendTitle Class

For a list of all members of this type, see MapLegendTitle members.

Public Properties
 | Name | Description
Public Property | Caption | Caption of the title. An expression should evaluate to a System.String.
Public Property | Style | Gets or sets style properties for the title. Each of the properties of type Color support transparency.
Public Property | TitleSeparator | Gets or sets what type of separator to use for the legend title. That evaluates to one of MapLegendTitle.LegendTitleSeparator. The default value is MapLegendTitle.LegendTitleSeparator.None.
Public Property | TitleSeparatorColor | Gets or sets the color for the title separator. The default value is Gray
Top
See Also

Reference

MapLegendTitle Class
GrapeCity.ActiveReports.PageReportModel Namespace


Caption Property (MapLegendTitle)

Caption Property (MapLegendTitle)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegendTitle Class : Caption Property
Caption of the title. An expression should evaluate to a System.String.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Caption As ExpressionInfo
public ExpressionInfo Caption {get; set;}
See Also

Reference

MapLegendTitle Class
MapLegendTitle Members


Style Property (MapLegendTitle)

Style Property (MapLegendTitle)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegendTitle Class : Style Property
Gets or sets style properties for the title. Each of the properties of type Color support transparency.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As Style
public Style Style {get; set;}
See Also

Reference

MapLegendTitle Class
MapLegendTitle Members


TitleSeparator Property (MapLegendTitle)

TitleSeparator Property (MapLegendTitle)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegendTitle Class : TitleSeparator Property
Gets or sets what type of separator to use for the legend title. That evaluates to one of MapLegendTitle.LegendTitleSeparator. The default value is MapLegendTitle.LegendTitleSeparator.None.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TitleSeparator As ExpressionInfo
public ExpressionInfo TitleSeparator {get; set;}
See Also

Reference

MapLegendTitle Class
MapLegendTitle Members


TitleSeparatorColor Property (MapLegendTitle)

TitleSeparatorColor Property (MapLegendTitle)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLegendTitle Class : TitleSeparatorColor Property
Gets or sets the color for the title separator. The default value is Gray
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TitleSeparatorColor As ExpressionInfo
public ExpressionInfo TitleSeparatorColor {get; set;}
See Also

Reference

MapLegendTitle Class
MapLegendTitle Members


MapLimits Class

MapLimits Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLimits Class
Defines the map limits
Object Model
MapLimits Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapLimits
public sealed class MapLimits
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLimits

See Also

Reference

MapLimits Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapLimits Class Members

MapLimits Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLimits Class

The following tables list the members exposed by MapLimits.

Public Constructors
 | Name | Description
Public Constructor | MapLimits Constructor | Initializes a new instance of the MapLimits class.
Top
Public Properties
 | Name | Description
Public Property | MaximumX | Gets or sets the maximum X for map. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Public Property | MaximumY | Gets or sets the maximum Y for map. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Public Property | MinimumX | Gets or sets the minimum X for map. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Public Property | MinimumY | Gets or sets the minimum Y for map. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Top
See Also

Reference

MapLimits Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLimits Constructor

MapLimits Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLimits Class : MapLimits Constructor
Initializes a new instance of the MapLimits class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapLimits()
See Also

Reference

MapLimits Class
MapLimits Members


MapLimits Class Properties

MapLimits Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLimits Class

For a list of all members of this type, see MapLimits members.

Public Properties
 | Name | Description
Public Property | MaximumX | Gets or sets the maximum X for map. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Public Property | MaximumY | Gets or sets the maximum Y for map. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Public Property | MinimumX | Gets or sets the minimum X for map. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Public Property | MinimumY | Gets or sets the minimum Y for map. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Top
See Also

Reference

MapLimits Class
GrapeCity.ActiveReports.PageReportModel Namespace


MaximumX Property (MapLimits)

MaximumX Property (MapLimits)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLimits Class : MaximumX Property
Gets or sets the maximum X for map. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaximumX As ExpressionInfo
public ExpressionInfo MaximumX {get; set;}
See Also

Reference

MapLimits Class
MapLimits Members


MaximumY Property (MapLimits)

MaximumY Property (MapLimits)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLimits Class : MaximumY Property
Gets or sets the maximum Y for map. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaximumY As ExpressionInfo
public ExpressionInfo MaximumY {get; set;}
See Also

Reference

MapLimits Class
MapLimits Members


MinimumX Property (MapLimits)

MinimumX Property (MapLimits)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLimits Class : MinimumX Property
Gets or sets the minimum X for map. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinimumX As ExpressionInfo
public ExpressionInfo MinimumX {get; set;}
See Also

Reference

MapLimits Class
MapLimits Members


MinimumY Property (MapLimits)

MinimumY Property (MapLimits)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLimits Class : MinimumY Property
Gets or sets the minimum Y for map. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinimumY As ExpressionInfo
public ExpressionInfo MinimumY {get; set;}
See Also

Reference

MapLimits Class
MapLimits Members


MapLine Class

MapLine Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLine Class
Defines an element to be embedded within a MapLineLayer
Object Model
MapLine Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapLine
   Inherits MapSpatialElement
public sealed class MapLine : MapSpatialElement
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialElement
GrapeCity.ActiveReports.PageReportModel.MapLine

See Also

Reference

MapLine Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapLine Class Members

MapLine Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLine Class

The following tables list the members exposed by MapLine.

Public Constructors
 | Name | Description
Public Constructor | MapLine Constructor | Initializes a new instance of the MapLine class.
Top
Public Properties
 | Name | Description
Public Property | MapFields | Gets a set of fields for the element. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElement)
Public Property | MapLineTemplate | Gets or sets the custom template to be used for the line. Ignored if UsCustomTemplate is false.
Public Property | UseCustomLineTemplate | Gets or sets a custom template will be used for the line, otherwise the layer template will be used. An expression should evaluate to a System.Boolean.
Public Property | VectorData | Gets or sets the element vector data. (Based-64 encoded string) (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElement)
Top
See Also

Reference

MapLine Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLine Constructor

MapLine Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLine Class : MapLine Constructor
Initializes a new instance of the MapLine class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapLine()
See Also

Reference

MapLine Class
MapLine Members


MapLine Class Properties

MapLine Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLine Class

For a list of all members of this type, see MapLine members.

Public Properties
 | Name | Description
Public Property | MapFields | Gets a set of fields for the element. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElement)
Public Property | MapLineTemplate | Gets or sets the custom template to be used for the line. Ignored if UsCustomTemplate is false.
Public Property | UseCustomLineTemplate | Gets or sets a custom template will be used for the line, otherwise the layer template will be used. An expression should evaluate to a System.Boolean.
Public Property | VectorData | Gets or sets the element vector data. (Based-64 encoded string) (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElement)
Top
See Also

Reference

MapLine Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLineTemplate Property (MapLine)

MapLineTemplate Property (MapLine)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLine Class : MapLineTemplate Property
Gets or sets the custom template to be used for the line. Ignored if UsCustomTemplate is false.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapLineTemplate As MapLineTemplate
public MapLineTemplate MapLineTemplate {get; set;}
See Also

Reference

MapLine Class
MapLine Members


UseCustomLineTemplate Property

UseCustomLineTemplate Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLine Class : UseCustomLineTemplate Property
Gets or sets a custom template will be used for the line, otherwise the layer template will be used. An expression should evaluate to a System.Boolean.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseCustomLineTemplate As ExpressionInfo
public ExpressionInfo UseCustomLineTemplate {get; set;}
See Also

Reference

MapLine Class
MapLine Members


MapLineLayer Class

MapLineLayer Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineLayer Class
Defines a vector-based layer of lines to be drawn within a map
Object Model
MapLineLayer Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapLineLayer
   Inherits MapVectorLayer
public sealed class MapLineLayer : MapVectorLayer
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLayer
GrapeCity.ActiveReports.PageReportModel.MapVectorLayer
GrapeCity.ActiveReports.PageReportModel.MapLineLayer

See Also

Reference

MapLineLayer Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapLineLayer Class Members

MapLineLayer Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineLayer Class

The following tables list the members exposed by MapLineLayer.

Public Constructors
 | Name | Description
Public Constructor | MapLineLayer Constructor | Initializes a new instance of the MapLineLayer class.
Top
Public Properties
 | Name | Description
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | Elements | Overridden. Returns the collection of layer elements.
Public Property | MapBindingFieldPairs | Gets the set of field/expression pairs for binding the map elements within a layer to the data region. Mandatory if MapVectorLayer.MapDataRegionName is defined and MapVectorLayer.MapSpatialData is not MapSpatialDataRegion; ignored otherwise. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | MapDataRegionName | Gets or sets which data region to use as the source. Mandatory if MapVectorLayer.MapSpatialData is MapSpatialDataRegion. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | MapFieldDefinitions | Gets the set of field definitions for the embedded map elements (for example, MapPolygons, MapLines, MapPoints). Ignored if the embedded map elements are not defined. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | MapLineRules | Gets or sets the set of rules to be applied for lines within the layer.
Public Property | MapLines | Gets the set of embedded lines in the layer.
Public Property | MapLineTemplate | Gets or sets the template to be applied for lines within the layer.
Public Property | MapSpatialData | Gets or sets the spatial data source for the layer. Ignored if the embedded map elements are defined. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | MaximumZoom | Gets or sets the maximum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 200. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | MinimumZoom | Gets or sets the minimum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 50. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | Name | Name of the layer. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | Transparency | Gets or sets the transparency for all map elements contained in this layer. Measured in percents. An expression should evaluate to a System.Double. The default value is 0. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | VisibilityMode | Gets or sets the layer visibility mode. That evaluates to one of MapVisibilityMode. The default value is MapVisibilityMode.Visible. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Top
See Also

Reference

MapLineLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLineLayer Constructor

MapLineLayer Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineLayer Class : MapLineLayer Constructor
Initializes a new instance of the MapLineLayer class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapLineLayer()
See Also

Reference

MapLineLayer Class
MapLineLayer Members


MapLineLayer Class Properties

MapLineLayer Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineLayer Class

For a list of all members of this type, see MapLineLayer members.

Public Properties
 | Name | Description
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | Elements | Overridden. Returns the collection of layer elements.
Public Property | MapBindingFieldPairs | Gets the set of field/expression pairs for binding the map elements within a layer to the data region. Mandatory if MapVectorLayer.MapDataRegionName is defined and MapVectorLayer.MapSpatialData is not MapSpatialDataRegion; ignored otherwise. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | MapDataRegionName | Gets or sets which data region to use as the source. Mandatory if MapVectorLayer.MapSpatialData is MapSpatialDataRegion. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | MapFieldDefinitions | Gets the set of field definitions for the embedded map elements (for example, MapPolygons, MapLines, MapPoints). Ignored if the embedded map elements are not defined. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | MapLineRules | Gets or sets the set of rules to be applied for lines within the layer.
Public Property | MapLines | Gets the set of embedded lines in the layer.
Public Property | MapLineTemplate | Gets or sets the template to be applied for lines within the layer.
Public Property | MapSpatialData | Gets or sets the spatial data source for the layer. Ignored if the embedded map elements are defined. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | MaximumZoom | Gets or sets the maximum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 200. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | MinimumZoom | Gets or sets the minimum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 50. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | Name | Name of the layer. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | Transparency | Gets or sets the transparency for all map elements contained in this layer. Measured in percents. An expression should evaluate to a System.Double. The default value is 0. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | VisibilityMode | Gets or sets the layer visibility mode. That evaluates to one of MapVisibilityMode. The default value is MapVisibilityMode.Visible. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Top
See Also

Reference

MapLineLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


Elements Property (MapLineLayer)

Elements Property (MapLineLayer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineLayer Class : Elements Property
Returns the collection of layer elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable ReadOnly Property Elements As System.Collections.Generic.IEnumerable(Of MapSpatialElement)
public override System.Collections.Generic.IEnumerable<MapSpatialElement> Elements {get;}
See Also

Reference

MapLineLayer Class
MapLineLayer Members


MapLineRules Property

MapLineRules Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineLayer Class : MapLineRules Property
Gets or sets the set of rules to be applied for lines within the layer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapLineRules As MapLineRules
public MapLineRules MapLineRules {get; set;}
See Also

Reference

MapLineLayer Class
MapLineLayer Members


MapLines Property

MapLines Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineLayer Class : MapLines Property
Gets the set of embedded lines in the layer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MapLines As System.Collections.Generic.IList(Of MapLine)
public System.Collections.Generic.IList<MapLine> MapLines {get;}
See Also

Reference

MapLineLayer Class
MapLineLayer Members


MapLineTemplate Property (MapLineLayer)

MapLineTemplate Property (MapLineLayer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineLayer Class : MapLineTemplate Property
Gets or sets the template to be applied for lines within the layer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapLineTemplate As MapLineTemplate
public MapLineTemplate MapLineTemplate {get; set;}
See Also

Reference

MapLineLayer Class
MapLineLayer Members


MapLineRules Class

MapLineRules Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineRules Class
Defines a set of rules to be applied on lines
Object Model
MapLineRules Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class MapLineRules
public class MapLineRules
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLineRules

See Also

Reference

MapLineRules Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapLineRules Class Members

MapLineRules Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineRules Class

The following tables list the members exposed by MapLineRules.

Public Constructors
 | Name | Description
Public Constructor | MapLineRules Constructor | Initializes a new instance of the MapLineRules class.
Top
Public Properties
 | Name | Description
Public Property | MapColorRule | Defines the color of the line based on a data field. Overrides MapLineTemplate.Style.Color
Public Property | MapSizeRule | Gets or sets the width of the line based on a data field. Overrides MapLineTemplate.Width
Top
See Also

Reference

MapLineRules Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLineRules Constructor

MapLineRules Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineRules Class : MapLineRules Constructor
Initializes a new instance of the MapLineRules class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapLineRules()
See Also

Reference

MapLineRules Class
MapLineRules Members


MapLineRules Class Properties

MapLineRules Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineRules Class

For a list of all members of this type, see MapLineRules members.

Public Properties
 | Name | Description
Public Property | MapColorRule | Defines the color of the line based on a data field. Overrides MapLineTemplate.Style.Color
Public Property | MapSizeRule | Gets or sets the width of the line based on a data field. Overrides MapLineTemplate.Width
Top
See Also

Reference

MapLineRules Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorRule Property (MapLineRules)

MapColorRule Property (MapLineRules)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineRules Class : MapColorRule Property
Defines the color of the line based on a data field. Overrides MapLineTemplate.Style.Color
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapColorRule As MapColorRule
public MapColorRule MapColorRule {get; set;}
See Also

Reference

MapLineRules Class
MapLineRules Members


MapSizeRule Property (MapLineRules)

MapSizeRule Property (MapLineRules)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineRules Class : MapSizeRule Property
Gets or sets the width of the line based on a data field. Overrides MapLineTemplate.Width
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapSizeRule As MapSizeRule
public MapSizeRule MapSizeRule {get; set;}
See Also

Reference

MapLineRules Class
MapLineRules Members


MapLineTemplate Class

MapLineTemplate Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineTemplate Class
Defines a template to be applied to lines within a line layer
Object Model
MapLineTemplate Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapLineTemplate
   Inherits MapSpatialElementTemplate
public sealed class MapLineTemplate : MapSpatialElementTemplate
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate
GrapeCity.ActiveReports.PageReportModel.MapLineTemplate

See Also

Reference

MapLineTemplate Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapLineTemplate Class Members

MapLineTemplate Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineTemplate Class

The following tables list the members exposed by MapLineTemplate.

Public Constructors
 | Name | Description
Public Constructor | MapLineTemplate Constructor | Initializes a new instance of the MapLineTemplate class.
Top
Public Properties
 | Name | Description
Public Property | ActionInfo | Actions for the map elements. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | DataElementLabel | The label for the data element. Defaults to the value of MapSpatialElementTemplate.Label property. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | DataElementName | The name to use for the data element for this value. Must be a CLS-compliant identifier. If not defined, MapDataRow is used. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | Hidden | Gets or sets the map element is hidden. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | Label | The label to display on the map elements. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | LabelPlacement | Gets or sets the label placement for the line. That evaluates to one of MapLineTemplate.LineLabelPlacement. The default value is MapLineTemplate.LineLabelPlacement.Above.
Public Property | OffsetX | Gets or sets the X offset for the element in geographic units. An expression should evaluate to a System.Double. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | OffsetY | Gets or sets the Y offset for the element in geographic units. An expression should evaluate to a System.Double. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | Style | Gets or sets style properties to be applied to the map elements. Each of the properties of type Color support transparency. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | ToolTip | Tool tip to display for the map elements. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | Width | Defines the width of the line. Default: 3.75pt An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 3.75pt.
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Top
See Also

Reference

MapLineTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLineTemplate Constructor

MapLineTemplate Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineTemplate Class : MapLineTemplate Constructor
Initializes a new instance of the MapLineTemplate class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapLineTemplate()
See Also

Reference

MapLineTemplate Class
MapLineTemplate Members


MapLineTemplate Class Methods

MapLineTemplate Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineTemplate Class

For a list of all members of this type, see MapLineTemplate members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Top
See Also

Reference

MapLineTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


Clone Method (MapLineTemplate)

Clone Method (MapLineTemplate)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineTemplate Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()
See Also

Reference

MapLineTemplate Class
MapLineTemplate Members


MapLineTemplate Class Properties

MapLineTemplate Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineTemplate Class

For a list of all members of this type, see MapLineTemplate members.

Public Properties
 | Name | Description
Public Property | ActionInfo | Actions for the map elements. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | DataElementLabel | The label for the data element. Defaults to the value of MapSpatialElementTemplate.Label property. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | DataElementName | The name to use for the data element for this value. Must be a CLS-compliant identifier. If not defined, MapDataRow is used. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | Hidden | Gets or sets the map element is hidden. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | Label | The label to display on the map elements. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | LabelPlacement | Gets or sets the label placement for the line. That evaluates to one of MapLineTemplate.LineLabelPlacement. The default value is MapLineTemplate.LineLabelPlacement.Above.
Public Property | OffsetX | Gets or sets the X offset for the element in geographic units. An expression should evaluate to a System.Double. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | OffsetY | Gets or sets the Y offset for the element in geographic units. An expression should evaluate to a System.Double. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | Style | Gets or sets style properties to be applied to the map elements. Each of the properties of type Color support transparency. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | ToolTip | Tool tip to display for the map elements. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | Width | Defines the width of the line. Default: 3.75pt An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 3.75pt.
Top
See Also

Reference

MapLineTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


LabelPlacement Property (MapLineTemplate)

LabelPlacement Property (MapLineTemplate)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineTemplate Class : LabelPlacement Property
Gets or sets the label placement for the line. That evaluates to one of MapLineTemplate.LineLabelPlacement. The default value is MapLineTemplate.LineLabelPlacement.Above.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LabelPlacement As ExpressionInfo
public ExpressionInfo LabelPlacement {get; set;}
See Also

Reference

MapLineTemplate Class
MapLineTemplate Members


Width Property (MapLineTemplate)

Width Property (MapLineTemplate)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLineTemplate Class : Width Property
Defines the width of the line. Default: 3.75pt An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 3.75pt.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As ExpressionInfo
public ExpressionInfo Width {get; set;}
See Also

Reference

MapLineTemplate Class
MapLineTemplate Members


MapLocation Class

MapLocation Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLocation Class
Defines the properties for map sub items location
Object Model
MapLocation Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapLocation
public sealed class MapLocation
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLocation

See Also

Reference

MapLocation Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapLocation Class Members

MapLocation Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLocation Class

The following tables list the members exposed by MapLocation.

Public Constructors
 | Name | Description
Public Constructor | MapLocation Constructor | Initializes a new instance of the MapLocation class.
Top
Public Properties
 | Name | Description
Public Property | Left | The distance of the item from the left of the containing object. An expression should evaluate to a System.Double. The default value is 0.
Public Property | Top | The distance of the item from the top of the containing object. An expression should evaluate to a System.Double. The default value is 0.
Public Property | Unit | Gets or sets the unit of measurement for setting the location.
Top
See Also

Reference

MapLocation Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapLocation Constructor

MapLocation Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLocation Class : MapLocation Constructor
Initializes a new instance of the MapLocation class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapLocation()
See Also

Reference

MapLocation Class
MapLocation Members


MapLocation Class Properties

MapLocation Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLocation Class

For a list of all members of this type, see MapLocation members.

Public Properties
 | Name | Description
Public Property | Left | The distance of the item from the left of the containing object. An expression should evaluate to a System.Double. The default value is 0.
Public Property | Top | The distance of the item from the top of the containing object. An expression should evaluate to a System.Double. The default value is 0.
Public Property | Unit | Gets or sets the unit of measurement for setting the location.
Top
See Also

Reference

MapLocation Class
GrapeCity.ActiveReports.PageReportModel Namespace


Left Property (MapLocation)

Left Property (MapLocation)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLocation Class : Left Property
The distance of the item from the left of the containing object. An expression should evaluate to a System.Double. The default value is 0.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Left As ExpressionInfo
public ExpressionInfo Left {get; set;}
See Also

Reference

MapLocation Class
MapLocation Members


Top Property (MapLocation)

Top Property (MapLocation)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLocation Class : Top Property
The distance of the item from the top of the containing object. An expression should evaluate to a System.Double. The default value is 0.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Top As ExpressionInfo
public ExpressionInfo Top {get; set;}
See Also

Reference

MapLocation Class
MapLocation Members


Unit Property (MapLocation)

Unit Property (MapLocation)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapLocation Class : Unit Property
Gets or sets the unit of measurement for setting the location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Unit As ExpressionInfo
public ExpressionInfo Unit {get; set;}
See Also

Reference

MapLocation Class
MapLocation Members


MapMarker Class

MapMarker Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarker Class
Defines a marker to be applied to points within a point or polygon layer.
Object Model
MapMarker Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapMarker
public sealed class MapMarker
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapMarker

See Also

Reference

MapMarker Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapMarker Class Members

MapMarker Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarker Class

The following tables list the members exposed by MapMarker.

Public Constructors
 | Name | Description
Public Constructor | MapMarker Constructor | Initializes a new instance of the MapMarker class.
Top
Public Properties
 | Name | Description
Public Property | MapMarkerImage | Gets or sets an image to be used for point marker. Mandatory if MapMarkerStyle, otherwise ignored.
Public Property | MapMarkerStyle | Gets or sets the point marker. That evaluates to one of MapMarker.MarkerStyle. The default value is MapMarker.MarkerStyle.None.
Top
Public Methods
 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

MapMarker Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapMarker Constructor

MapMarker Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarker Class : MapMarker Constructor
Initializes a new instance of the MapMarker class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapMarker()
See Also

Reference

MapMarker Class
MapMarker Members


MapMarker Class Methods

MapMarker Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarker Class

For a list of all members of this type, see MapMarker members.

Public Methods
 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

MapMarker Class
GrapeCity.ActiveReports.PageReportModel Namespace


Clone Method (MapMarker)

Clone Method (MapMarker)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarker Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Clone() As System.Object
public System.object Clone()
See Also

Reference

MapMarker Class
MapMarker Members


MapMarker Class Properties

MapMarker Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarker Class

For a list of all members of this type, see MapMarker members.

Public Properties
 | Name | Description
Public Property | MapMarkerImage | Gets or sets an image to be used for point marker. Mandatory if MapMarkerStyle, otherwise ignored.
Public Property | MapMarkerStyle | Gets or sets the point marker. That evaluates to one of MapMarker.MarkerStyle. The default value is MapMarker.MarkerStyle.None.
Top
See Also

Reference

MapMarker Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapMarkerImage Property

MapMarkerImage Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarker Class : MapMarkerImage Property
Gets or sets an image to be used for point marker. Mandatory if MapMarkerStyle, otherwise ignored.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapMarkerImage As MapMarkerImage
public MapMarkerImage MapMarkerImage {get; set;}
See Also

Reference

MapMarker Class
MapMarker Members


MapMarkerStyle Property

MapMarkerStyle Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarker Class : MapMarkerStyle Property
Gets or sets the point marker. That evaluates to one of MapMarker.MarkerStyle. The default value is MapMarker.MarkerStyle.None.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapMarkerStyle As ExpressionInfo
public ExpressionInfo MapMarkerStyle {get; set;}
See Also

Reference

MapMarker Class
MapMarker Members


MapMarkerImage Class

MapMarkerImage Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerImage Class
Image marker.
Object Model
MapMarkerImage Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapMarkerImage
public sealed class MapMarkerImage
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapMarkerImage

See Also

Reference

MapMarkerImage Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapMarkerImage Class Members

MapMarkerImage Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerImage Class

The following tables list the members exposed by MapMarkerImage.

Public Constructors
 | Name | Description
Public Constructor | MapMarkerImage Constructor | Initializes a new instance of the MapMarkerImage class.
Top
Public Properties
 | Name | Description
Public Property | MIMEType | The MIMEType of the image. Valid values are: image/bmp, image/jpeg, image/gif, image/png, image/x-png Required if Source = Database. Ignored otherwise.
Public Property | ResizeMode | Gets or sets whether the content will resize to fit in the available space. That evaluates to one of MapMarkerImage.ImageResizeMode. The default value is MapMarkerImage.ImageResizeMode.AutoFit.
Public Property | Source | Identifies the source of the image. That evaluates to one of ImageSource />.
Public Property | TransparentColor | Color to treat as transparent in the image.
Public Property | Value | See Source. Expected datatype is string or binary,
Top
Public Methods
 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

MapMarkerImage Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapMarkerImage Constructor

MapMarkerImage Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerImage Class : MapMarkerImage Constructor
Initializes a new instance of the MapMarkerImage class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapMarkerImage()
See Also

Reference

MapMarkerImage Class
MapMarkerImage Members


MapMarkerImage Class Methods

MapMarkerImage Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerImage Class

For a list of all members of this type, see MapMarkerImage members.

Public Methods
 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

MapMarkerImage Class
GrapeCity.ActiveReports.PageReportModel Namespace


Clone Method (MapMarkerImage)

Clone Method (MapMarkerImage)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerImage Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Clone() As System.Object
public System.object Clone()

Return Value

A new object that is a copy of this instance.
See Also

Reference

MapMarkerImage Class
MapMarkerImage Members


MapMarkerImage Class Properties

MapMarkerImage Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerImage Class

For a list of all members of this type, see MapMarkerImage members.

Public Properties
 | Name | Description
Public Property | MIMEType | The MIMEType of the image. Valid values are: image/bmp, image/jpeg, image/gif, image/png, image/x-png Required if Source = Database. Ignored otherwise.
Public Property | ResizeMode | Gets or sets whether the content will resize to fit in the available space. That evaluates to one of MapMarkerImage.ImageResizeMode. The default value is MapMarkerImage.ImageResizeMode.AutoFit.
Public Property | Source | Identifies the source of the image. That evaluates to one of ImageSource />.
Public Property | TransparentColor | Color to treat as transparent in the image.
Public Property | Value | See Source. Expected datatype is string or binary,
Top
See Also

Reference

MapMarkerImage Class
GrapeCity.ActiveReports.PageReportModel Namespace


MIMEType Property (MapMarkerImage)

MIMEType Property (MapMarkerImage)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerImage Class : MIMEType Property
The MIMEType of the image. Valid values are: image/bmp, image/jpeg, image/gif, image/png, image/x-png Required if Source = Database. Ignored otherwise.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MIMEType As ExpressionInfo
public ExpressionInfo MIMEType {get; set;}
See Also

Reference

MapMarkerImage Class
MapMarkerImage Members


ResizeMode Property (MapMarkerImage)

ResizeMode Property (MapMarkerImage)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerImage Class : ResizeMode Property
Gets or sets whether the content will resize to fit in the available space. That evaluates to one of MapMarkerImage.ImageResizeMode. The default value is MapMarkerImage.ImageResizeMode.AutoFit.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ResizeMode As ExpressionInfo
public ExpressionInfo ResizeMode {get; set;}
See Also

Reference

MapMarkerImage Class
MapMarkerImage Members


Source Property (MapMarkerImage)

Source Property (MapMarkerImage)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerImage Class : Source Property
Identifies the source of the image. That evaluates to one of ImageSource />.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Source As ExpressionInfo
public ExpressionInfo Source {get; set;}
See Also

Reference

MapMarkerImage Class
MapMarkerImage Members


TransparentColor Property

TransparentColor Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerImage Class : TransparentColor Property
Color to treat as transparent in the image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TransparentColor As ExpressionInfo
public ExpressionInfo TransparentColor {get; set;}
See Also

Reference

MapMarkerImage Class
MapMarkerImage Members


Value Property (MapMarkerImage)

Value Property (MapMarkerImage)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerImage Class : Value Property
See Source. Expected datatype is string or binary,
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As ExpressionInfo
public ExpressionInfo Value {get; set;}
See Also

Reference

MapMarkerImage Class
MapMarkerImage Members


MapMarkerRule Class

MapMarkerRule Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerRule Class
Defines the points marker based on a data field
Object Model
MapMarkerRule Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapMarkerRule
   Inherits MapAppearanceRule
public sealed class MapMarkerRule : MapAppearanceRule
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule
GrapeCity.ActiveReports.PageReportModel.MapMarkerRule

See Also

Reference

MapMarkerRule Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapMarkerRule Class Members

MapMarkerRule Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerRule Class

The following tables list the members exposed by MapMarkerRule.

Public Constructors
 | Name | Description
Public Constructor | MapMarkerRule Constructor | Initializes a new instance of the MapMarkerRule class.
Top
Public Properties
 | Name | Description
Public Property | BucketCount | Defines the number of buckets for the specified distribution. Ignored if DistributionType is RuleDistributionType.Custom or if DataValue is not Scalar. An expression should evaluate to a System.Integer. The default value is 5 (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataValue | An expression to be evaluated on the scope of the spatial element. The appearance rule will be applied on the element based on its value. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DistributionType | Gets or sets the distribution type. That evaluates to one of RuleDistributionType. The default value is RuleDistributionType.Optimal. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | EndValue | Gets or sets the end value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | LegendName | Name of the legend in which the data field will appear. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | LegendText | Label to use in the legend for the data field. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | MapBuckets | Gets the set of buckets used to distribute the data. Mandatory if DistributionType = RuleDistributionType.Custom, otherwise ignored. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | MapMarkers | Gets a set of markers to be used for points.
Public Property | StartValue | Gets or sets the start value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Top
See Also

Reference

MapMarkerRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapMarkerRule Constructor

MapMarkerRule Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerRule Class : MapMarkerRule Constructor
Initializes a new instance of the MapMarkerRule class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapMarkerRule()
See Also

Reference

MapMarkerRule Class
MapMarkerRule Members


MapMarkerRule Class Properties

MapMarkerRule Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerRule Class

For a list of all members of this type, see MapMarkerRule members.

Public Properties
 | Name | Description
Public Property | BucketCount | Defines the number of buckets for the specified distribution. Ignored if DistributionType is RuleDistributionType.Custom or if DataValue is not Scalar. An expression should evaluate to a System.Integer. The default value is 5 (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataValue | An expression to be evaluated on the scope of the spatial element. The appearance rule will be applied on the element based on its value. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DistributionType | Gets or sets the distribution type. That evaluates to one of RuleDistributionType. The default value is RuleDistributionType.Optimal. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | EndValue | Gets or sets the end value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | LegendName | Name of the legend in which the data field will appear. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | LegendText | Label to use in the legend for the data field. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | MapBuckets | Gets the set of buckets used to distribute the data. Mandatory if DistributionType = RuleDistributionType.Custom, otherwise ignored. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | MapMarkers | Gets a set of markers to be used for points.
Public Property | StartValue | Gets or sets the start value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Top
See Also

Reference

MapMarkerRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapMarkers Property

MapMarkers Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerRule Class : MapMarkers Property
Gets a set of markers to be used for points.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MapMarkers As System.Collections.Generic.IList(Of MapMarker)
public System.Collections.Generic.IList<MapMarker> MapMarkers {get;}
See Also

Reference

MapMarkerRule Class
MapMarkerRule Members


MapMarkerTemplate Class

MapMarkerTemplate Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerTemplate Class
Defines a marker template to be applied to points within a point or polygon layer
Object Model
MapMarkerTemplate Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapMarkerTemplate
   Inherits MapPointTemplate
public sealed class MapMarkerTemplate : MapPointTemplate
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate
GrapeCity.ActiveReports.PageReportModel.MapPointTemplate
GrapeCity.ActiveReports.PageReportModel.MapMarkerTemplate

See Also

Reference

MapMarkerTemplate Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapMarkerTemplate Class Members

MapMarkerTemplate Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerTemplate Class

The following tables list the members exposed by MapMarkerTemplate.

Public Constructors
 | Name | Description
Public Constructor | MapMarkerTemplate Constructor | Initializes a new instance of the MapMarkerTemplate class.
Top
Public Properties
 | Name | Description
Public Property | ActionInfo | Actions for the map elements. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | DataElementLabel | The label for the data element. Defaults to the value of MapSpatialElementTemplate.Label property. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | DataElementName | The name to use for the data element for this value. Must be a CLS-compliant identifier. If not defined, MapDataRow is used. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | Hidden | Gets or sets the map element is hidden. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | Label | The label to display on the map elements. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | LabelPlacement | Gets or sets the label placement for the point. That evaluates to one of PointLabelPlacement. The default value is PointLabelPlacement.Bottom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapPointTemplate)
Public Property | MapMarker | Gets or sets the point marker.
Public Property | OffsetX | Gets or sets the X offset for the element in geographic units. An expression should evaluate to a System.Double. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | OffsetY | Gets or sets the Y offset for the element in geographic units. An expression should evaluate to a System.Double. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | Size | Gets or sets the height and width of the plotting area of the point marker. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 5.25pt. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapPointTemplate)
Public Property | Style | Gets or sets style properties to be applied to the map elements. Each of the properties of type Color support transparency. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | ToolTip | Tool tip to display for the map elements. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Top
See Also

Reference

MapMarkerTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapMarkerTemplate Constructor

MapMarkerTemplate Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerTemplate Class : MapMarkerTemplate Constructor
Initializes a new instance of the MapMarkerTemplate class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapMarkerTemplate()
See Also

Reference

MapMarkerTemplate Class
MapMarkerTemplate Members


MapMarkerTemplate Class Methods

MapMarkerTemplate Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerTemplate Class

For a list of all members of this type, see MapMarkerTemplate members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Top
See Also

Reference

MapMarkerTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


Clone Method (MapMarkerTemplate)

Clone Method (MapMarkerTemplate)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerTemplate Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()

Return Value

System.Object.
See Also

Reference

MapMarkerTemplate Class
MapMarkerTemplate Members


MapMarkerTemplate Class Properties

MapMarkerTemplate Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerTemplate Class

For a list of all members of this type, see MapMarkerTemplate members.

Public Properties
 | Name | Description
Public Property | ActionInfo | Actions for the map elements. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | DataElementLabel | The label for the data element. Defaults to the value of MapSpatialElementTemplate.Label property. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | DataElementName | The name to use for the data element for this value. Must be a CLS-compliant identifier. If not defined, MapDataRow is used. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | Hidden | Gets or sets the map element is hidden. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | Label | The label to display on the map elements. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | LabelPlacement | Gets or sets the label placement for the point. That evaluates to one of PointLabelPlacement. The default value is PointLabelPlacement.Bottom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapPointTemplate)
Public Property | MapMarker | Gets or sets the point marker.
Public Property | OffsetX | Gets or sets the X offset for the element in geographic units. An expression should evaluate to a System.Double. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | OffsetY | Gets or sets the Y offset for the element in geographic units. An expression should evaluate to a System.Double. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | Size | Gets or sets the height and width of the plotting area of the point marker. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 5.25pt. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapPointTemplate)
Public Property | Style | Gets or sets style properties to be applied to the map elements. Each of the properties of type Color support transparency. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | ToolTip | Tool tip to display for the map elements. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Top
See Also

Reference

MapMarkerTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapMarker Property

MapMarker Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMarkerTemplate Class : MapMarker Property
Gets or sets the point marker.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapMarker As MapMarker
public MapMarker MapMarker {get; set;}
See Also

Reference

MapMarkerTemplate Class
MapMarkerTemplate Members


MapMember Class

MapMember Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMember Class
Defines group and filter behavior for the data.
Object Model
MapMember Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapMember
public sealed class MapMember
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapMember

See Also

Reference

MapMember Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapMember Class Members

MapMember Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMember Class

The following tables list the members exposed by MapMember.

Public Constructors
 | Name | Description
Public Constructor | MapMember Constructor | Initializes a new instance of the MapMember class.
Top
Public Properties
 | Name | Description
Public Property | ChildMember | Nested grouping/ filtering.
Public Property | Group | Grouping to apply to the data.
Top
See Also

Reference

MapMember Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapMember Constructor

MapMember Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMember Class : MapMember Constructor
Initializes a new instance of the MapMember class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapMember()
See Also

Reference

MapMember Class
MapMember Members


MapMember Class Properties

MapMember Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMember Class

For a list of all members of this type, see MapMember members.

Public Properties
 | Name | Description
Public Property | ChildMember | Nested grouping/ filtering.
Public Property | Group | Grouping to apply to the data.
Top
See Also

Reference

MapMember Class
GrapeCity.ActiveReports.PageReportModel Namespace


ChildMember Property

ChildMember Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMember Class : ChildMember Property
Nested grouping/ filtering.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ChildMember As MapMember
public MapMember ChildMember {get; set;}
See Also

Reference

MapMember Class
MapMember Members


Group Property (MapMember)

Group Property (MapMember)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapMember Class : Group Property
Grouping to apply to the data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Group As Grouping
public Grouping Group {get; set;}
See Also

Reference

MapMember Class
MapMember Members


MapPoint Class

MapPoint Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPoint Class
Defines an element to be embedded within a MapPointLayer
Object Model
MapPoint Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapPoint
   Inherits MapSpatialElement
public sealed class MapPoint : MapSpatialElement
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialElement
GrapeCity.ActiveReports.PageReportModel.MapPoint

See Also

Reference

MapPoint Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapPoint Class Members

MapPoint Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPoint Class

The following tables list the members exposed by MapPoint.

Public Constructors
 | Name | Description
Public Constructor | MapPoint Constructor | Initializes a new instance of the MapPoint class.
Top
Public Properties
 | Name | Description
Public Property | MapFields | Gets a set of fields for the element. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElement)
Public Property | MapPointTemplate | Gets or sets the custom template to be used for the point. Ignored if UseCustomPointTemplate is False.
Public Property | UseCustomPointTemplate | Gets or sets a custom template will be used for the point, otherwise the layer template will be used. An expression should evaluate to a System.Boolean.
Public Property | VectorData | Gets or sets the element vector data. (Based-64 encoded string) (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElement)
Top
See Also

Reference

MapPoint Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapPoint Constructor

MapPoint Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPoint Class : MapPoint Constructor
Initializes a new instance of the MapPoint class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapPoint()
See Also

Reference

MapPoint Class
MapPoint Members


MapPoint Class Properties

MapPoint Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPoint Class

For a list of all members of this type, see MapPoint members.

Public Properties
 | Name | Description
Public Property | MapFields | Gets a set of fields for the element. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElement)
Public Property | MapPointTemplate | Gets or sets the custom template to be used for the point. Ignored if UseCustomPointTemplate is False.
Public Property | UseCustomPointTemplate | Gets or sets a custom template will be used for the point, otherwise the layer template will be used. An expression should evaluate to a System.Boolean.
Public Property | VectorData | Gets or sets the element vector data. (Based-64 encoded string) (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElement)
Top
See Also

Reference

MapPoint Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapPointTemplate Property (MapPoint)

MapPointTemplate Property (MapPoint)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPoint Class : MapPointTemplate Property
Gets or sets the custom template to be used for the point. Ignored if UseCustomPointTemplate is False.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapPointTemplate As MapMarkerTemplate
public MapMarkerTemplate MapPointTemplate {get; set;}
See Also

Reference

MapPoint Class
MapPoint Members


UseCustomPointTemplate Property

UseCustomPointTemplate Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPoint Class : UseCustomPointTemplate Property
Gets or sets a custom template will be used for the point, otherwise the layer template will be used. An expression should evaluate to a System.Boolean.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseCustomPointTemplate As ExpressionInfo
public ExpressionInfo UseCustomPointTemplate {get; set;}
See Also

Reference

MapPoint Class
MapPoint Members


MapPointLayer Class

MapPointLayer Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointLayer Class
Defines a vector-based layer of points to be drawn within a map
Object Model
MapPointLayer Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapPointLayer
   Inherits MapVectorLayer
public sealed class MapPointLayer : MapVectorLayer
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLayer
GrapeCity.ActiveReports.PageReportModel.MapVectorLayer
GrapeCity.ActiveReports.PageReportModel.MapPointLayer

See Also

Reference

MapPointLayer Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapPointLayer Class Members

MapPointLayer Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointLayer Class

The following tables list the members exposed by MapPointLayer.

Public Constructors
 | Name | Description
Public Constructor | MapPointLayer Constructor | Initializes a new instance of the MapPointLayer class.
Top
Public Properties
 | Name | Description
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | Elements | Overridden. Returns the collection of layer elements.
Public Property | MapBindingFieldPairs | Gets the set of field/expression pairs for binding the map elements within a layer to the data region. Mandatory if MapVectorLayer.MapDataRegionName is defined and MapVectorLayer.MapSpatialData is not MapSpatialDataRegion; ignored otherwise. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | MapDataRegionName | Gets or sets which data region to use as the source. Mandatory if MapVectorLayer.MapSpatialData is MapSpatialDataRegion. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | MapFieldDefinitions | Gets the set of field definitions for the embedded map elements (for example, MapPolygons, MapLines, MapPoints). Ignored if the embedded map elements are not defined. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | MapPointRules | Gets or sets the set of rules to be applied for points within the layer.
Public Property | MapPoints | Gets the set of embedded points in the layer.
Public Property | MapPointTemplate | Gets or sets the template to be applied for points within the layer.
Public Property | MapSpatialData | Gets or sets the spatial data source for the layer. Ignored if the embedded map elements are defined. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | MaximumZoom | Gets or sets the maximum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 200. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | MinimumZoom | Gets or sets the minimum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 50. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | Name | Name of the layer. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | Transparency | Gets or sets the transparency for all map elements contained in this layer. Measured in percents. An expression should evaluate to a System.Double. The default value is 0. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | VisibilityMode | Gets or sets the layer visibility mode. That evaluates to one of MapVisibilityMode. The default value is MapVisibilityMode.Visible. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Top
See Also

Reference

MapPointLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapPointLayer Constructor

MapPointLayer Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointLayer Class : MapPointLayer Constructor
Initializes a new instance of the MapPointLayer class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapPointLayer()
See Also

Reference

MapPointLayer Class
MapPointLayer Members


MapPointLayer Class Properties

MapPointLayer Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointLayer Class

For a list of all members of this type, see MapPointLayer members.

Public Properties
 | Name | Description
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | Elements | Overridden. Returns the collection of layer elements.
Public Property | MapBindingFieldPairs | Gets the set of field/expression pairs for binding the map elements within a layer to the data region. Mandatory if MapVectorLayer.MapDataRegionName is defined and MapVectorLayer.MapSpatialData is not MapSpatialDataRegion; ignored otherwise. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | MapDataRegionName | Gets or sets which data region to use as the source. Mandatory if MapVectorLayer.MapSpatialData is MapSpatialDataRegion. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | MapFieldDefinitions | Gets the set of field definitions for the embedded map elements (for example, MapPolygons, MapLines, MapPoints). Ignored if the embedded map elements are not defined. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | MapPointRules | Gets or sets the set of rules to be applied for points within the layer.
Public Property | MapPoints | Gets the set of embedded points in the layer.
Public Property | MapPointTemplate | Gets or sets the template to be applied for points within the layer.
Public Property | MapSpatialData | Gets or sets the spatial data source for the layer. Ignored if the embedded map elements are defined. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | MaximumZoom | Gets or sets the maximum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 200. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | MinimumZoom | Gets or sets the minimum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 50. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | Name | Name of the layer. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | Transparency | Gets or sets the transparency for all map elements contained in this layer. Measured in percents. An expression should evaluate to a System.Double. The default value is 0. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | VisibilityMode | Gets or sets the layer visibility mode. That evaluates to one of MapVisibilityMode. The default value is MapVisibilityMode.Visible. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Top
See Also

Reference

MapPointLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


Elements Property (MapPointLayer)

Elements Property (MapPointLayer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointLayer Class : Elements Property
Returns the collection of layer elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable ReadOnly Property Elements As System.Collections.Generic.IEnumerable(Of MapSpatialElement)
public override System.Collections.Generic.IEnumerable<MapSpatialElement> Elements {get;}

Property Value

The elements.
See Also

Reference

MapPointLayer Class
MapPointLayer Members


MapPointRules Property

MapPointRules Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointLayer Class : MapPointRules Property
Gets or sets the set of rules to be applied for points within the layer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapPointRules As MapPointRules
public MapPointRules MapPointRules {get; set;}
See Also

Reference

MapPointLayer Class
MapPointLayer Members


MapPoints Property

MapPoints Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointLayer Class : MapPoints Property
Gets the set of embedded points in the layer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MapPoints As System.Collections.Generic.IList(Of MapPoint)
public System.Collections.Generic.IList<MapPoint> MapPoints {get;}
See Also

Reference

MapPointLayer Class
MapPointLayer Members


MapPointTemplate Property (MapPointLayer)

MapPointTemplate Property (MapPointLayer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointLayer Class : MapPointTemplate Property
Gets or sets the template to be applied for points within the layer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapPointTemplate As MapMarkerTemplate
public MapMarkerTemplate MapPointTemplate {get; set;}
See Also

Reference

MapPointLayer Class
MapPointLayer Members


MapPointRules Class

MapPointRules Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointRules Class
Defines a set of rules to be applied on points on a point or polygon layer
Object Model
MapPointRules Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapPointRules
public sealed class MapPointRules
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapPointRules

See Also

Reference

MapPointRules Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapPointRules Class Members

MapPointRules Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointRules Class

The following tables list the members exposed by MapPointRules.

Public Constructors
 | Name | Description
Public Constructor | MapPointRules Constructor | Initializes a new instance of the MapPointRules class.
Top
Public Properties
 | Name | Description
Public Property | MapColorRule | Gets or sets the color of the point based on a data field. Overrides MapPointTemplate.Style.Color
Public Property | MapMarkerRule | Gets or sets the marker style of the point based on a data field. Overrides MapMarkerTemplate.MapMarker
Public Property | MapSizeRule | Gets or sets the size of the point based on a data field. Overrides MapPointTemplate.Size
Top
See Also

Reference

MapPointRules Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapPointRules Constructor

MapPointRules Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointRules Class : MapPointRules Constructor
Initializes a new instance of the MapPointRules class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapPointRules()
See Also

Reference

MapPointRules Class
MapPointRules Members


MapPointRules Class Properties

MapPointRules Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointRules Class

For a list of all members of this type, see MapPointRules members.

Public Properties
 | Name | Description
Public Property | MapColorRule | Gets or sets the color of the point based on a data field. Overrides MapPointTemplate.Style.Color
Public Property | MapMarkerRule | Gets or sets the marker style of the point based on a data field. Overrides MapMarkerTemplate.MapMarker
Public Property | MapSizeRule | Gets or sets the size of the point based on a data field. Overrides MapPointTemplate.Size
Top
See Also

Reference

MapPointRules Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorRule Property (MapPointRules)

MapColorRule Property (MapPointRules)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointRules Class : MapColorRule Property
Gets or sets the color of the point based on a data field. Overrides MapPointTemplate.Style.Color
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapColorRule As MapColorRule
public MapColorRule MapColorRule {get; set;}
See Also

Reference

MapPointRules Class
MapPointRules Members


MapMarkerRule Property

MapMarkerRule Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointRules Class : MapMarkerRule Property
Gets or sets the marker style of the point based on a data field. Overrides MapMarkerTemplate.MapMarker
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapMarkerRule As MapMarkerRule
public MapMarkerRule MapMarkerRule {get; set;}
See Also

Reference

MapPointRules Class
MapPointRules Members


MapSizeRule Property (MapPointRules)

MapSizeRule Property (MapPointRules)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointRules Class : MapSizeRule Property
Gets or sets the size of the point based on a data field. Overrides MapPointTemplate.Size
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapSizeRule As MapSizeRule
public MapSizeRule MapSizeRule {get; set;}
See Also

Reference

MapPointRules Class
MapPointRules Members


MapPointTemplate Class

MapPointTemplate Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointTemplate Class
Defines a template to be applied to points within a point or polygon layer
Object Model
MapPointTemplate Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class MapPointTemplate
   Inherits MapSpatialElementTemplate
public class MapPointTemplate : MapSpatialElementTemplate
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate
GrapeCity.ActiveReports.PageReportModel.MapPointTemplate
GrapeCity.ActiveReports.PageReportModel.MapMarkerTemplate

See Also

Reference

MapPointTemplate Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapPointTemplate Class Members

MapPointTemplate Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointTemplate Class

The following tables list the members exposed by MapPointTemplate.

Public Constructors
 | Name | Description
Public Constructor | MapPointTemplate Constructor | Initializes a new instance of the MapPointTemplate class.
Top
Public Properties
 | Name | Description
Public Property | ActionInfo | Actions for the map elements. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | DataElementLabel | The label for the data element. Defaults to the value of MapSpatialElementTemplate.Label property. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | DataElementName | The name to use for the data element for this value. Must be a CLS-compliant identifier. If not defined, MapDataRow is used. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | Hidden | Gets or sets the map element is hidden. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | Label | The label to display on the map elements. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | LabelPlacement | Gets or sets the label placement for the point. That evaluates to one of PointLabelPlacement. The default value is PointLabelPlacement.Bottom.
Public Property | OffsetX | Gets or sets the X offset for the element in geographic units. An expression should evaluate to a System.Double. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | OffsetY | Gets or sets the Y offset for the element in geographic units. An expression should evaluate to a System.Double. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | Size | Gets or sets the height and width of the plotting area of the point marker. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 5.25pt.
Public Property | Style | Gets or sets style properties to be applied to the map elements. Each of the properties of type Color support transparency. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | ToolTip | Tool tip to display for the map elements. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Top
See Also

Reference

MapPointTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapPointTemplate Constructor

MapPointTemplate Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointTemplate Class : MapPointTemplate Constructor
Initializes a new instance of the MapPointTemplate class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapPointTemplate()
See Also

Reference

MapPointTemplate Class
MapPointTemplate Members


MapPointTemplate Class Methods

MapPointTemplate Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointTemplate Class

For a list of all members of this type, see MapPointTemplate members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Top
See Also

Reference

MapPointTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


Clone Method (MapPointTemplate)

Clone Method (MapPointTemplate)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointTemplate Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Clone() As System.Object
public override System.object Clone()
See Also

Reference

MapPointTemplate Class
MapPointTemplate Members


MapPointTemplate Class Properties

MapPointTemplate Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointTemplate Class

For a list of all members of this type, see MapPointTemplate members.

Public Properties
 | Name | Description
Public Property | ActionInfo | Actions for the map elements. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | DataElementLabel | The label for the data element. Defaults to the value of MapSpatialElementTemplate.Label property. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | DataElementName | The name to use for the data element for this value. Must be a CLS-compliant identifier. If not defined, MapDataRow is used. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | Hidden | Gets or sets the map element is hidden. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | Label | The label to display on the map elements. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | LabelPlacement | Gets or sets the label placement for the point. That evaluates to one of PointLabelPlacement. The default value is PointLabelPlacement.Bottom.
Public Property | OffsetX | Gets or sets the X offset for the element in geographic units. An expression should evaluate to a System.Double. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | OffsetY | Gets or sets the Y offset for the element in geographic units. An expression should evaluate to a System.Double. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | Size | Gets or sets the height and width of the plotting area of the point marker. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 5.25pt.
Public Property | Style | Gets or sets style properties to be applied to the map elements. Each of the properties of type Color support transparency. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | ToolTip | Tool tip to display for the map elements. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Top
See Also

Reference

MapPointTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


LabelPlacement Property (MapPointTemplate)

LabelPlacement Property (MapPointTemplate)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointTemplate Class : LabelPlacement Property
Gets or sets the label placement for the point. That evaluates to one of PointLabelPlacement. The default value is PointLabelPlacement.Bottom.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LabelPlacement As ExpressionInfo
public ExpressionInfo LabelPlacement {get; set;}
See Also

Reference

MapPointTemplate Class
MapPointTemplate Members


Size Property (MapPointTemplate)

Size Property (MapPointTemplate)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPointTemplate Class : Size Property
Gets or sets the height and width of the plotting area of the point marker. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 5.25pt.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Size As ExpressionInfo
public ExpressionInfo Size {get; set;}
See Also

Reference

MapPointTemplate Class
MapPointTemplate Members


MapPolygon Class

MapPolygon Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygon Class
Defines an element to be embedded within a MapPolygonLayer
Object Model
MapPolygon Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapPolygon
   Inherits MapSpatialElement
public sealed class MapPolygon : MapSpatialElement
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialElement
GrapeCity.ActiveReports.PageReportModel.MapPolygon

See Also

Reference

MapPolygon Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapPolygon Class Members

MapPolygon Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygon Class

The following tables list the members exposed by MapPolygon.

Public Constructors
 | Name | Description
Public Constructor | MapPolygon Constructor | Initializes a new instance of the MapPloygon class.
Top
Public Properties
 | Name | Description
Public Property | MapCenterPointTemplate | Gets or sets the custom point template to be used for the polygon center point. Ignored if UseCustomCenterPointTemplate is false.
Public Property | MapFields | Gets a set of fields for the element. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElement)
Public Property | MapPolygonTemplate | Gets or sets the custom polygon template to be used for the polygon. Ignored if UseCustomPolygonTemplate is false.
Public Property | UseCustomCenterPointTemplate | Gets or sets a custom point template will be used for the polygon center point, otherwise the layer template will be used. An expression should evaluate to a System.Boolean.
Public Property | UseCustomPolygonTemplate | Gets or sets a custom polygon template will be used for the polygon, otherwise the layer template will be used. An expression should evaluate to a System.Boolean.
Public Property | VectorData | Gets or sets the element vector data. (Based-64 encoded string) (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElement)
Top
See Also

Reference

MapPolygon Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapPolygon Constructor

MapPolygon Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygon Class : MapPolygon Constructor
Initializes a new instance of the MapPloygon class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapPolygon()
See Also

Reference

MapPolygon Class
MapPolygon Members


MapPolygon Class Properties

MapPolygon Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygon Class

For a list of all members of this type, see MapPolygon members.

Public Properties
 | Name | Description
Public Property | MapCenterPointTemplate | Gets or sets the custom point template to be used for the polygon center point. Ignored if UseCustomCenterPointTemplate is false.
Public Property | MapFields | Gets a set of fields for the element. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElement)
Public Property | MapPolygonTemplate | Gets or sets the custom polygon template to be used for the polygon. Ignored if UseCustomPolygonTemplate is false.
Public Property | UseCustomCenterPointTemplate | Gets or sets a custom point template will be used for the polygon center point, otherwise the layer template will be used. An expression should evaluate to a System.Boolean.
Public Property | UseCustomPolygonTemplate | Gets or sets a custom polygon template will be used for the polygon, otherwise the layer template will be used. An expression should evaluate to a System.Boolean.
Public Property | VectorData | Gets or sets the element vector data. (Based-64 encoded string) (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElement)
Top
See Also

Reference

MapPolygon Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapCenterPointTemplate Property (MapPolygon)

MapCenterPointTemplate Property (MapPolygon)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygon Class : MapCenterPointTemplate Property
Gets or sets the custom point template to be used for the polygon center point. Ignored if UseCustomCenterPointTemplate is false.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapCenterPointTemplate As MapMarkerTemplate
public MapMarkerTemplate MapCenterPointTemplate {get; set;}
See Also

Reference

MapPolygon Class
MapPolygon Members


MapPolygonTemplate Property (MapPolygon)

MapPolygonTemplate Property (MapPolygon)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygon Class : MapPolygonTemplate Property
Gets or sets the custom polygon template to be used for the polygon. Ignored if UseCustomPolygonTemplate is false.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapPolygonTemplate As MapPolygonTemplate
public MapPolygonTemplate MapPolygonTemplate {get; set;}
See Also

Reference

MapPolygon Class
MapPolygon Members


UseCustomCenterPointTemplate Property

UseCustomCenterPointTemplate Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygon Class : UseCustomCenterPointTemplate Property
Gets or sets a custom point template will be used for the polygon center point, otherwise the layer template will be used. An expression should evaluate to a System.Boolean.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseCustomCenterPointTemplate As ExpressionInfo
public ExpressionInfo UseCustomCenterPointTemplate {get; set;}
See Also

Reference

MapPolygon Class
MapPolygon Members


UseCustomPolygonTemplate Property

UseCustomPolygonTemplate Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygon Class : UseCustomPolygonTemplate Property
Gets or sets a custom polygon template will be used for the polygon, otherwise the layer template will be used. An expression should evaluate to a System.Boolean.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseCustomPolygonTemplate As ExpressionInfo
public ExpressionInfo UseCustomPolygonTemplate {get; set;}
See Also

Reference

MapPolygon Class
MapPolygon Members


MapPolygonLayer Class

MapPolygonLayer Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonLayer Class
Defines a vector-based layer of polygons to be drawn within a map.
Object Model
MapPolygonLayer Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapPolygonLayer
   Inherits MapVectorLayer
public sealed class MapPolygonLayer : MapVectorLayer
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLayer
GrapeCity.ActiveReports.PageReportModel.MapVectorLayer
GrapeCity.ActiveReports.PageReportModel.MapPolygonLayer

See Also

Reference

MapPolygonLayer Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapPolygonLayer Class Members

MapPolygonLayer Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonLayer Class

The following tables list the members exposed by MapPolygonLayer.

Public Constructors
 | Name | Description
Public Constructor | MapPolygonLayer Constructor | Initializes a new instance of the MapPolygonLayer class.
Top
Public Properties
 | Name | Description
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | Elements | Overridden. Returns the collection of layer elements.
Public Property | MapBindingFieldPairs | Gets the set of field/expression pairs for binding the map elements within a layer to the data region. Mandatory if MapVectorLayer.MapDataRegionName is defined and MapVectorLayer.MapSpatialData is not MapSpatialDataRegion; ignored otherwise. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | MapCenterPointRules | Gets or sets the set of rules to be applied for polygon center point.
Public Property | MapCenterPointTemplate | Gets or sets the template to be applied for polygon center point.
Public Property | MapDataRegionName | Gets or sets which data region to use as the source. Mandatory if MapVectorLayer.MapSpatialData is MapSpatialDataRegion. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | MapFieldDefinitions | Gets the set of field definitions for the embedded map elements (for example, MapPolygons, MapLines, MapPoints). Ignored if the embedded map elements are not defined. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | MapPolygonRules | Gets or sets the set of rules to be applied for polygons within the layer.
Public Property | MapPolygons | Gets the set of embedded polygons in the layer.
Public Property | MapPolygonTemplate | Gets or sets the template to be applied for polygons within the layer.
Public Property | MapSpatialData | Gets or sets the spatial data source for the layer. Ignored if the embedded map elements are defined. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | MaximumZoom | Gets or sets the maximum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 200. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | MinimumZoom | Gets or sets the minimum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 50. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | Name | Name of the layer. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | Transparency | Gets or sets the transparency for all map elements contained in this layer. Measured in percents. An expression should evaluate to a System.Double. The default value is 0. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | VisibilityMode | Gets or sets the layer visibility mode. That evaluates to one of MapVisibilityMode. The default value is MapVisibilityMode.Visible. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Top
See Also

Reference

MapPolygonLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapPolygonLayer Constructor

MapPolygonLayer Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonLayer Class : MapPolygonLayer Constructor
Initializes a new instance of the MapPolygonLayer class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapPolygonLayer()
See Also

Reference

MapPolygonLayer Class
MapPolygonLayer Members


MapPolygonLayer Class Properties

MapPolygonLayer Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonLayer Class

For a list of all members of this type, see MapPolygonLayer members.

Public Properties
 | Name | Description
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | Elements | Overridden. Returns the collection of layer elements.
Public Property | MapBindingFieldPairs | Gets the set of field/expression pairs for binding the map elements within a layer to the data region. Mandatory if MapVectorLayer.MapDataRegionName is defined and MapVectorLayer.MapSpatialData is not MapSpatialDataRegion; ignored otherwise. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | MapCenterPointRules | Gets or sets the set of rules to be applied for polygon center point.
Public Property | MapCenterPointTemplate | Gets or sets the template to be applied for polygon center point.
Public Property | MapDataRegionName | Gets or sets which data region to use as the source. Mandatory if MapVectorLayer.MapSpatialData is MapSpatialDataRegion. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | MapFieldDefinitions | Gets the set of field definitions for the embedded map elements (for example, MapPolygons, MapLines, MapPoints). Ignored if the embedded map elements are not defined. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | MapPolygonRules | Gets or sets the set of rules to be applied for polygons within the layer.
Public Property | MapPolygons | Gets the set of embedded polygons in the layer.
Public Property | MapPolygonTemplate | Gets or sets the template to be applied for polygons within the layer.
Public Property | MapSpatialData | Gets or sets the spatial data source for the layer. Ignored if the embedded map elements are defined. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapVectorLayer)
Public Property | MaximumZoom | Gets or sets the maximum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 200. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | MinimumZoom | Gets or sets the minimum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 50. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | Name | Name of the layer. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | Transparency | Gets or sets the transparency for all map elements contained in this layer. Measured in percents. An expression should evaluate to a System.Double. The default value is 0. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | VisibilityMode | Gets or sets the layer visibility mode. That evaluates to one of MapVisibilityMode. The default value is MapVisibilityMode.Visible. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Top
See Also

Reference

MapPolygonLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


Elements Property (MapPolygonLayer)

Elements Property (MapPolygonLayer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonLayer Class : Elements Property
Returns the collection of layer elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable ReadOnly Property Elements As System.Collections.Generic.IEnumerable(Of MapSpatialElement)
public override System.Collections.Generic.IEnumerable<MapSpatialElement> Elements {get;}
See Also

Reference

MapPolygonLayer Class
MapPolygonLayer Members


MapCenterPointRules Property

MapCenterPointRules Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonLayer Class : MapCenterPointRules Property
Gets or sets the set of rules to be applied for polygon center point.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapCenterPointRules As MapPointRules
public MapPointRules MapCenterPointRules {get; set;}
See Also

Reference

MapPolygonLayer Class
MapPolygonLayer Members


MapCenterPointTemplate Property (MapPolygonLayer)

MapCenterPointTemplate Property (MapPolygonLayer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonLayer Class : MapCenterPointTemplate Property
Gets or sets the template to be applied for polygon center point.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapCenterPointTemplate As MapMarkerTemplate
public MapMarkerTemplate MapCenterPointTemplate {get; set;}
See Also

Reference

MapPolygonLayer Class
MapPolygonLayer Members


MapPolygonRules Property

MapPolygonRules Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonLayer Class : MapPolygonRules Property
Gets or sets the set of rules to be applied for polygons within the layer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapPolygonRules As MapPolygonRules
public MapPolygonRules MapPolygonRules {get; set;}
See Also

Reference

MapPolygonLayer Class
MapPolygonLayer Members


MapPolygons Property

MapPolygons Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonLayer Class : MapPolygons Property
Gets the set of embedded polygons in the layer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MapPolygons As System.Collections.Generic.IList(Of MapPolygon)
public System.Collections.Generic.IList<MapPolygon> MapPolygons {get;}
See Also

Reference

MapPolygonLayer Class
MapPolygonLayer Members


MapPolygonTemplate Property (MapPolygonLayer)

MapPolygonTemplate Property (MapPolygonLayer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonLayer Class : MapPolygonTemplate Property
Gets or sets the template to be applied for polygons within the layer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapPolygonTemplate As MapPolygonTemplate
public MapPolygonTemplate MapPolygonTemplate {get; set;}
See Also

Reference

MapPolygonLayer Class
MapPolygonLayer Members


MapPolygonRules Class

MapPolygonRules Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonRules Class
Defines a set of rules to be applied on polygons
Object Model
MapPolygonRules Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapPolygonRules
public sealed class MapPolygonRules
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapPolygonRules

See Also

Reference

MapPolygonRules Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapPolygonRules Class Members

MapPolygonRules Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonRules Class

The following tables list the members exposed by MapPolygonRules.

Public Constructors
 | Name | Description
Public Constructor | MapPolygonRules Constructor | Initializes a new instance of the MapPolygonRules class.
Top
Public Properties
 | Name | Description
Public Property | MapColorRule | Gets or sets the color of the polygon based on a data field. Overrides %MapPolygonTemplate.Style.Color %
Top
See Also

Reference

MapPolygonRules Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapPolygonRules Constructor

MapPolygonRules Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonRules Class : MapPolygonRules Constructor
Initializes a new instance of the MapPolygonRules class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapPolygonRules()
See Also

Reference

MapPolygonRules Class
MapPolygonRules Members


MapPolygonRules Class Properties

MapPolygonRules Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonRules Class

For a list of all members of this type, see MapPolygonRules members.

Public Properties
 | Name | Description
Public Property | MapColorRule | Gets or sets the color of the polygon based on a data field. Overrides %MapPolygonTemplate.Style.Color %
Top
See Also

Reference

MapPolygonRules Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapColorRule Property (MapPolygonRules)

MapColorRule Property (MapPolygonRules)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonRules Class : MapColorRule Property
Gets or sets the color of the polygon based on a data field. Overrides %MapPolygonTemplate.Style.Color %
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapColorRule As MapColorRule
public MapColorRule MapColorRule {get; set;}
See Also

Reference

MapPolygonRules Class
MapPolygonRules Members


MapPolygonTemplate Class

MapPolygonTemplate Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonTemplate Class
Defines a template to be applied to polygons within a polygon layer.
Object Model
MapPolygonTemplate Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapPolygonTemplate
   Inherits MapSpatialElementTemplate
public sealed class MapPolygonTemplate : MapSpatialElementTemplate
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate
GrapeCity.ActiveReports.PageReportModel.MapPolygonTemplate

See Also

Reference

MapPolygonTemplate Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapPolygonTemplate Class Members

MapPolygonTemplate Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonTemplate Class

The following tables list the members exposed by MapPolygonTemplate.

Public Constructors
 | Name | Description
Public Constructor | MapPolygonTemplate Constructor | Initializes a new instance of the MapPloygonTemplate class.
Top
Public Properties
 | Name | Description
Public Property | ActionInfo | Actions for the map elements. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | CenterPointOffsetX | Gets or sets the X offset for the polygon center point in geographic units. An expression should evaluate to a System.Double.
Public Property | CenterPointOffsetY | Gets or sets the Y offset for the polygon center point in geographic units. An expression should evaluate to a System.Double.
Public Property | DataElementLabel | The label for the data element. Defaults to the value of MapSpatialElementTemplate.Label property. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | DataElementName | The name to use for the data element for this value. Must be a CLS-compliant identifier. If not defined, MapDataRow is used. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | Hidden | Gets or sets the map element is hidden. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | Label | The label to display on the map elements. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | LabelPlacement | Gets or sets the label placement of the polygon. That evaluates to one of MapPolygonTemplate.PolygonLabelPlacement. The default value is MapPolygonTemplate.PolygonLabelPlacement.MiddleCenter.
Public Property | OffsetX | Gets or sets the X offset for the element in geographic units. An expression should evaluate to a System.Double. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | OffsetY | Gets or sets the Y offset for the element in geographic units. An expression should evaluate to a System.Double. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | ScaleFactor | Gets or sets the factor by which the polygon will be scaled. An expression should evaluate to a System.Double. The default value is 1.
Public Property | ShowLabel | Gets or sets if the label should be shown. That evaluates to one of Auto, True, False The default value is Auto.
Public Property | Style | Gets or sets style properties to be applied to the map elements. Each of the properties of type Color support transparency. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | ToolTip | Tool tip to display for the map elements. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Top
Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Top
See Also

Reference

MapPolygonTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapPolygonTemplate Constructor

MapPolygonTemplate Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonTemplate Class : MapPolygonTemplate Constructor
Initializes a new instance of the MapPloygonTemplate class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapPolygonTemplate()
See Also

Reference

MapPolygonTemplate Class
MapPolygonTemplate Members


MapPolygonTemplate Class Methods

MapPolygonTemplate Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonTemplate Class

For a list of all members of this type, see MapPolygonTemplate members.

Public Methods
 | Name | Description
Public Method | Clone | Overridden. Creates a new object that is a copy of the current instance.
Top
See Also

Reference

MapPolygonTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


Clone Method (MapPolygonTemplate)

Clone Method (MapPolygonTemplate)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonTemplate Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Clone() As System.Object
public override System.object Clone()
See Also

Reference

MapPolygonTemplate Class
MapPolygonTemplate Members


MapPolygonTemplate Class Properties

MapPolygonTemplate Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonTemplate Class

For a list of all members of this type, see MapPolygonTemplate members.

Public Properties
 | Name | Description
Public Property | ActionInfo | Actions for the map elements. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | CenterPointOffsetX | Gets or sets the X offset for the polygon center point in geographic units. An expression should evaluate to a System.Double.
Public Property | CenterPointOffsetY | Gets or sets the Y offset for the polygon center point in geographic units. An expression should evaluate to a System.Double.
Public Property | DataElementLabel | The label for the data element. Defaults to the value of MapSpatialElementTemplate.Label property. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | DataElementName | The name to use for the data element for this value. Must be a CLS-compliant identifier. If not defined, MapDataRow is used. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | Hidden | Gets or sets the map element is hidden. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | Label | The label to display on the map elements. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | LabelPlacement | Gets or sets the label placement of the polygon. That evaluates to one of MapPolygonTemplate.PolygonLabelPlacement. The default value is MapPolygonTemplate.PolygonLabelPlacement.MiddleCenter.
Public Property | OffsetX | Gets or sets the X offset for the element in geographic units. An expression should evaluate to a System.Double. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | OffsetY | Gets or sets the Y offset for the element in geographic units. An expression should evaluate to a System.Double. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | ScaleFactor | Gets or sets the factor by which the polygon will be scaled. An expression should evaluate to a System.Double. The default value is 1.
Public Property | ShowLabel | Gets or sets if the label should be shown. That evaluates to one of Auto, True, False The default value is Auto.
Public Property | Style | Gets or sets style properties to be applied to the map elements. Each of the properties of type Color support transparency. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Public Property | ToolTip | Tool tip to display for the map elements. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate)
Top
See Also

Reference

MapPolygonTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


CenterPointOffsetX Property (MapPolygonTemplate)

CenterPointOffsetX Property (MapPolygonTemplate)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonTemplate Class : CenterPointOffsetX Property
Gets or sets the X offset for the polygon center point in geographic units. An expression should evaluate to a System.Double.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CenterPointOffsetX As ExpressionInfo
public ExpressionInfo CenterPointOffsetX {get; set;}
See Also

Reference

MapPolygonTemplate Class
MapPolygonTemplate Members


CenterPointOffsetY Property (MapPolygonTemplate)

CenterPointOffsetY Property (MapPolygonTemplate)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonTemplate Class : CenterPointOffsetY Property
Gets or sets the Y offset for the polygon center point in geographic units. An expression should evaluate to a System.Double.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CenterPointOffsetY As ExpressionInfo
public ExpressionInfo CenterPointOffsetY {get; set;}
See Also

Reference

MapPolygonTemplate Class
MapPolygonTemplate Members


LabelPlacement Property (MapPolygonTemplate)

LabelPlacement Property (MapPolygonTemplate)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonTemplate Class : LabelPlacement Property
Gets or sets the label placement of the polygon. That evaluates to one of MapPolygonTemplate.PolygonLabelPlacement. The default value is MapPolygonTemplate.PolygonLabelPlacement.MiddleCenter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LabelPlacement As ExpressionInfo
public ExpressionInfo LabelPlacement {get; set;}
See Also

Reference

MapPolygonTemplate Class
MapPolygonTemplate Members


ScaleFactor Property (MapPolygonTemplate)

ScaleFactor Property (MapPolygonTemplate)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonTemplate Class : ScaleFactor Property
Gets or sets the factor by which the polygon will be scaled. An expression should evaluate to a System.Double. The default value is 1.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ScaleFactor As ExpressionInfo
public ExpressionInfo ScaleFactor {get; set;}
See Also

Reference

MapPolygonTemplate Class
MapPolygonTemplate Members


ShowLabel Property (MapPolygonTemplate)

ShowLabel Property (MapPolygonTemplate)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapPolygonTemplate Class : ShowLabel Property
Gets or sets if the label should be shown. That evaluates to one of Auto, True, False The default value is Auto.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShowLabel As ExpressionInfo
public ExpressionInfo ShowLabel {get; set;}
See Also

Reference

MapPolygonTemplate Class
MapPolygonTemplate Members


MapShapefile Class

MapShapefile Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapShapefile Class
Defines a file-based source for spatial data and possibly non-spatial data
Object Model
MapShapefile Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapShapefile
   Inherits MapSpatialData
public sealed class MapShapefile : MapSpatialData
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialData
GrapeCity.ActiveReports.PageReportModel.MapShapefile

See Also

Reference

MapShapefile Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapShapefile Class Members

MapShapefile Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapShapefile Class

The following tables list the members exposed by MapShapefile.

Public Constructors
 | Name | Description
Public Constructor | MapShapefile Constructor | Initializes a new instance of the MapShapefile class.
Top
Public Properties
 | Name | Description
Public Property | MapFieldNames | Gets the set of non-spatial data fields to be imported from the shape file.
Public Property | Source | Contains a constant or expression that evaluates to the location of the shapefile. This can be a full path, relative path, or URL. Relative paths start in the same folder as the report. An expression should evaluate to a System.String.
Top
See Also

Reference

MapShapefile Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapShapefile Constructor

MapShapefile Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapShapefile Class : MapShapefile Constructor
Initializes a new instance of the MapShapefile class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapShapefile()
See Also

Reference

MapShapefile Class
MapShapefile Members


MapShapefile Class Properties

MapShapefile Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapShapefile Class

For a list of all members of this type, see MapShapefile members.

Public Properties
 | Name | Description
Public Property | MapFieldNames | Gets the set of non-spatial data fields to be imported from the shape file.
Public Property | Source | Contains a constant or expression that evaluates to the location of the shapefile. This can be a full path, relative path, or URL. Relative paths start in the same folder as the report. An expression should evaluate to a System.String.
Top
See Also

Reference

MapShapefile Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapFieldNames Property (MapShapefile)

MapFieldNames Property (MapShapefile)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapShapefile Class : MapFieldNames Property
Gets the set of non-spatial data fields to be imported from the shape file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MapFieldNames As System.Collections.Generic.IList(Of ExpressionInfo)
public System.Collections.Generic.IList<ExpressionInfo> MapFieldNames {get;}
See Also

Reference

MapShapefile Class
MapShapefile Members


Source Property (MapShapefile)

Source Property (MapShapefile)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapShapefile Class : Source Property
Contains a constant or expression that evaluates to the location of the shapefile. This can be a full path, relative path, or URL. Relative paths start in the same folder as the report. An expression should evaluate to a System.String.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Source As ExpressionInfo
public ExpressionInfo Source {get; set;}
See Also

Reference

MapShapefile Class
MapShapefile Members


MapSize Class

MapSize Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSize Class
Defines the properties for map sub items size
Object Model
MapSize Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapSize
public sealed class MapSize
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSize

See Also

Reference

MapSize Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapSize Class Members

MapSize Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSize Class

The following tables list the members exposed by MapSize.

Public Constructors
 | Name | Description
Public Constructor | MapSize Constructor | Initializes a new instance of the MapSize class.
Top
Public Properties
 | Name | Description
Public Property | Height | Height of the item. An expression should evaluate to a System.Double.
Public Property | Unit | Gets or sets the unit of measurement in which the size is set.
Public Property | Width | Width of the item. An expression should evaluate to a System.Double.
Top
See Also

Reference

MapSize Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapSize Constructor

MapSize Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSize Class : MapSize Constructor
Initializes a new instance of the MapSize class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapSize()
See Also

Reference

MapSize Class
MapSize Members


MapSize Class Properties

MapSize Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSize Class

For a list of all members of this type, see MapSize members.

Public Properties
 | Name | Description
Public Property | Height | Height of the item. An expression should evaluate to a System.Double.
Public Property | Unit | Gets or sets the unit of measurement in which the size is set.
Public Property | Width | Width of the item. An expression should evaluate to a System.Double.
Top
See Also

Reference

MapSize Class
GrapeCity.ActiveReports.PageReportModel Namespace


Height Property (MapSize)

Height Property (MapSize)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSize Class : Height Property
Height of the item. An expression should evaluate to a System.Double.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As ExpressionInfo
public ExpressionInfo Height {get; set;}
See Also

Reference

MapSize Class
MapSize Members


Unit Property (MapSize)

Unit Property (MapSize)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSize Class : Unit Property
Gets or sets the unit of measurement in which the size is set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Unit As ExpressionInfo
public ExpressionInfo Unit {get; set;}
See Also

Reference

MapSize Class
MapSize Members


Width Property (MapSize)

Width Property (MapSize)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSize Class : Width Property
Width of the item. An expression should evaluate to a System.Double.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As ExpressionInfo
public ExpressionInfo Width {get; set;}
See Also

Reference

MapSize Class
MapSize Members


MapSizeRule Class

MapSizeRule Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSizeRule Class
Defines the size rule for point or line based on a data field
Object Model
MapSizeRule Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapSizeRule
   Inherits MapAppearanceRule
public sealed class MapSizeRule : MapAppearanceRule
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule
GrapeCity.ActiveReports.PageReportModel.MapSizeRule

See Also

Reference

MapSizeRule Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapSizeRule Class Members

MapSizeRule Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSizeRule Class

The following tables list the members exposed by MapSizeRule.

Public Constructors
 | Name | Description
Public Constructor | MapSizeRule Constructor | Initializes a new instance of the MapSizeRule class.
Top
Public Properties
 | Name | Description
Public Property | BucketCount | Defines the number of buckets for the specified distribution. Ignored if DistributionType is RuleDistributionType.Custom or if DataValue is not Scalar. An expression should evaluate to a System.Integer. The default value is 5 (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataValue | An expression to be evaluated on the scope of the spatial element. The appearance rule will be applied on the element based on its value. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DistributionType | Gets or sets the distribution type. That evaluates to one of RuleDistributionType. The default value is RuleDistributionType.Optimal. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | EndSize | Gets or sets the end size to be used for the map elements.
Public Property | EndValue | Gets or sets the end value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | LegendName | Name of the legend in which the data field will appear. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | LegendText | Label to use in the legend for the data field. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | MapBuckets | Gets the set of buckets used to distribute the data. Mandatory if DistributionType = RuleDistributionType.Custom, otherwise ignored. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | StartSize | Gets or sets the start size to be used for the map elements.
Public Property | StartValue | Gets or sets the start value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Top
See Also

Reference

MapSizeRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapSizeRule Constructor

MapSizeRule Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSizeRule Class : MapSizeRule Constructor
Initializes a new instance of the MapSizeRule class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapSizeRule()
See Also

Reference

MapSizeRule Class
MapSizeRule Members


MapSizeRule Class Properties

MapSizeRule Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSizeRule Class

For a list of all members of this type, see MapSizeRule members.

Public Properties
 | Name | Description
Public Property | BucketCount | Defines the number of buckets for the specified distribution. Ignored if DistributionType is RuleDistributionType.Custom or if DataValue is not Scalar. An expression should evaluate to a System.Integer. The default value is 5 (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DataValue | An expression to be evaluated on the scope of the spatial element. The appearance rule will be applied on the element based on its value. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | DistributionType | Gets or sets the distribution type. That evaluates to one of RuleDistributionType. The default value is RuleDistributionType.Optimal. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | EndSize | Gets or sets the end size to be used for the map elements.
Public Property | EndValue | Gets or sets the end value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | LegendName | Name of the legend in which the data field will appear. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | LegendText | Label to use in the legend for the data field. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | MapBuckets | Gets the set of buckets used to distribute the data. Mandatory if DistributionType = RuleDistributionType.Custom, otherwise ignored. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Public Property | StartSize | Gets or sets the start size to be used for the map elements.
Public Property | StartValue | Gets or sets the start value for the distribution. Automatically calculated if omitted. Ignored if DistributionType = RuleDistributionType.Custom. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule)
Top
See Also

Reference

MapSizeRule Class
GrapeCity.ActiveReports.PageReportModel Namespace


EndSize Property

EndSize Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSizeRule Class : EndSize Property
Gets or sets the end size to be used for the map elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EndSize As ExpressionInfo
public ExpressionInfo EndSize {get; set;}
See Also

Reference

MapSizeRule Class
MapSizeRule Members


StartSize Property

StartSize Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSizeRule Class : StartSize Property
Gets or sets the start size to be used for the map elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartSize As ExpressionInfo
public ExpressionInfo StartSize {get; set;}
See Also

Reference

MapSizeRule Class
MapSizeRule Members


MapSpatialData Class

MapSpatialData Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialData Class
Defines the source of spatial data for a vector layer
Object Model
MapSpatialData Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class MapSpatialData
public abstract class MapSpatialData
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialData
GrapeCity.ActiveReports.PageReportModel.MapShapefile
GrapeCity.ActiveReports.PageReportModel.MapSpatialDataRegion
GrapeCity.ActiveReports.PageReportModel.MapSpatialDataSet

See Also

Reference

MapSpatialData Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapSpatialData Class Members

MapSpatialData Class Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialData Class

The following tables list the members exposed by MapSpatialData.

See Also

Reference

MapSpatialData Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapSpatialDataRegion Class

MapSpatialDataRegion Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialDataRegion Class
Defines a data region-based source for spatial data
Object Model
MapSpatialDataRegion Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapSpatialDataRegion
   Inherits MapSpatialData
public sealed class MapSpatialDataRegion : MapSpatialData
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialData
GrapeCity.ActiveReports.PageReportModel.MapSpatialDataRegion

See Also

Reference

MapSpatialDataRegion Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapSpatialDataRegion Class Members

MapSpatialDataRegion Class Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialDataRegion Class

The following tables list the members exposed by MapSpatialDataRegion.

Public Constructors
 | Name | Description
Public Constructor | MapSpatialDataRegion Constructor | Initializes a new instance of the MapSpatialDataRegion class.
Top
See Also

Reference

MapSpatialDataRegion Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapSpatialDataRegion Constructor

MapSpatialDataRegion Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialDataRegion Class : MapSpatialDataRegion Constructor
Initializes a new instance of the MapSpatialDataRegion class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapSpatialDataRegion()
See Also

Reference

MapSpatialDataRegion Class
MapSpatialDataRegion Members


MapSpatialDataSet Class

MapSpatialDataSet Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialDataSet Class
Defines a dataset-based source for spatial and possibly non-spatial data.
Object Model
MapSpatialDataSet Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapSpatialDataSet
   Inherits MapSpatialData
public sealed class MapSpatialDataSet : MapSpatialData
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialData
GrapeCity.ActiveReports.PageReportModel.MapSpatialDataSet

See Also

Reference

MapSpatialDataSet Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapSpatialDataSet Class Members

MapSpatialDataSet Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialDataSet Class

The following tables list the members exposed by MapSpatialDataSet.

Public Constructors
 | Name | Description
Public Constructor | MapSpatialDataSet Constructor | Initializes a new instance of the MapSpatialDataSet class.
Top
Public Properties
 | Name | Description
Public Property | DataSetName | Gets or sets which data set to use as the source data. Note: The filters defined for the dataset will be ignored. An expression should evaluate to a System.String.
Public Property | MapFieldNames | Gets the set of non-spatial data fields to be imported from the data set.
Public Property | SpatialField | Gets or sets the name of the spatial field to be imported from the data source. It should be of type SqlGeometry or SqlGeography. An expression should evaluate to a System.String.
Top
See Also

Reference

MapSpatialDataSet Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapSpatialDataSet Constructor

MapSpatialDataSet Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialDataSet Class : MapSpatialDataSet Constructor
Initializes a new instance of the MapSpatialDataSet class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapSpatialDataSet()
See Also

Reference

MapSpatialDataSet Class
MapSpatialDataSet Members


MapSpatialDataSet Class Properties

MapSpatialDataSet Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialDataSet Class

For a list of all members of this type, see MapSpatialDataSet members.

Public Properties
 | Name | Description
Public Property | DataSetName | Gets or sets which data set to use as the source data. Note: The filters defined for the dataset will be ignored. An expression should evaluate to a System.String.
Public Property | MapFieldNames | Gets the set of non-spatial data fields to be imported from the data set.
Public Property | SpatialField | Gets or sets the name of the spatial field to be imported from the data source. It should be of type SqlGeometry or SqlGeography. An expression should evaluate to a System.String.
Top
See Also

Reference

MapSpatialDataSet Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataSetName Property (MapSpatialDataSet)

DataSetName Property (MapSpatialDataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialDataSet Class : DataSetName Property
Gets or sets which data set to use as the source data. Note: The filters defined for the dataset will be ignored. An expression should evaluate to a System.String.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataSetName As ExpressionInfo
public ExpressionInfo DataSetName {get; set;}
See Also

Reference

MapSpatialDataSet Class
MapSpatialDataSet Members


MapFieldNames Property (MapSpatialDataSet)

MapFieldNames Property (MapSpatialDataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialDataSet Class : MapFieldNames Property
Gets the set of non-spatial data fields to be imported from the data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MapFieldNames As System.Collections.Generic.IList(Of ExpressionInfo)
public System.Collections.Generic.IList<ExpressionInfo> MapFieldNames {get;}
See Also

Reference

MapSpatialDataSet Class
MapSpatialDataSet Members


SpatialField Property

SpatialField Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialDataSet Class : SpatialField Property
Gets or sets the name of the spatial field to be imported from the data source. It should be of type SqlGeometry or SqlGeography. An expression should evaluate to a System.String.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SpatialField As ExpressionInfo
public ExpressionInfo SpatialField {get; set;}
See Also

Reference

MapSpatialDataSet Class
MapSpatialDataSet Members


MapSpatialElement Class

MapSpatialElement Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialElement Class
Defines a spatial element to be embedded within a static layer
Object Model
MapSpatialElement Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class MapSpatialElement
public abstract class MapSpatialElement
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialElement
GrapeCity.ActiveReports.PageReportModel.MapLine
GrapeCity.ActiveReports.PageReportModel.MapPoint
GrapeCity.ActiveReports.PageReportModel.MapPolygon

See Also

Reference

MapSpatialElement Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapSpatialElement Class Members

MapSpatialElement Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialElement Class

The following tables list the members exposed by MapSpatialElement.

Public Properties
 | Name | Description
Public Property | MapFields | Gets a set of fields for the element.
Public Property | VectorData | Gets or sets the element vector data. (Based-64 encoded string)
Top
See Also

Reference

MapSpatialElement Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapSpatialElement Class Properties

MapSpatialElement Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialElement Class

For a list of all members of this type, see MapSpatialElement members.

Public Properties
 | Name | Description
Public Property | MapFields | Gets a set of fields for the element.
Public Property | VectorData | Gets or sets the element vector data. (Based-64 encoded string)
Top
See Also

Reference

MapSpatialElement Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapFields Property

MapFields Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElement Class : MapFields Property
Gets a set of fields for the element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MapFields As System.Collections.Generic.ICollection(Of MapField)
public System.Collections.Generic.ICollection<MapField> MapFields {get;}
See Also

Reference

MapSpatialElement Class
MapSpatialElement Members


VectorData Property

VectorData Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElement Class : VectorData Property
Gets or sets the element vector data. (Based-64 encoded string)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property VectorData As System.String
public System.string VectorData {get; set;}
See Also

Reference

MapSpatialElement Class
MapSpatialElement Members


MapSpatialElementTemplate Class

MapSpatialElementTemplate Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialElementTemplate Class
Defines the template to be applied on map spatial elements within a vector layer
Object Model
MapSpatialElementTemplate Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class MapSpatialElementTemplate
public abstract class MapSpatialElementTemplate
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate
GrapeCity.ActiveReports.PageReportModel.MapLineTemplate
GrapeCity.ActiveReports.PageReportModel.MapPointTemplate
GrapeCity.ActiveReports.PageReportModel.MapPolygonTemplate

See Also

Reference

MapSpatialElementTemplate Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapSpatialElementTemplate Class Members

MapSpatialElementTemplate Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialElementTemplate Class

The following tables list the members exposed by MapSpatialElementTemplate.

Public Properties
 | Name | Description
Public Property | ActionInfo | Actions for the map elements.
Public Property | DataElementLabel | The label for the data element. Defaults to the value of Label property. An expression should evaluate to a System.String.
Public Property | DataElementName | The name to use for the data element for this value. Must be a CLS-compliant identifier. If not defined, MapDataRow is used.
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output.
Public Property | Hidden | Gets or sets the map element is hidden. An expression should evaluate to a System.Boolean.
Public Property | Label | The label to display on the map elements. An expression should evaluate to a System.String.
Public Property | OffsetX | Gets or sets the X offset for the element in geographic units. An expression should evaluate to a System.Double.
Public Property | OffsetY | Gets or sets the Y offset for the element in geographic units. An expression should evaluate to a System.Double.
Public Property | Style | Gets or sets style properties to be applied to the map elements. Each of the properties of type Color support transparency.
Public Property | ToolTip | Tool tip to display for the map elements. An expression should evaluate to a System.String.
Top
Public Methods
 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

MapSpatialElementTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapSpatialElementTemplate Class Methods

MapSpatialElementTemplate Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialElementTemplate Class

For a list of all members of this type, see MapSpatialElementTemplate members.

Public Methods
 | Name | Description
Public Method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

MapSpatialElementTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


Clone Method (MapSpatialElementTemplate)

Clone Method (MapSpatialElementTemplate)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate Class : Clone Method
Creates a new object that is a copy of the current instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Function Clone() As System.Object
public abstract System.object Clone()

Return Value

A new object that is a copy of this instance.
See Also

Reference

MapSpatialElementTemplate Class
MapSpatialElementTemplate Members


MapSpatialElementTemplate Class Properties

MapSpatialElementTemplate Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSpatialElementTemplate Class

For a list of all members of this type, see MapSpatialElementTemplate members.

Public Properties
 | Name | Description
Public Property | ActionInfo | Actions for the map elements.
Public Property | DataElementLabel | The label for the data element. Defaults to the value of Label property. An expression should evaluate to a System.String.
Public Property | DataElementName | The name to use for the data element for this value. Must be a CLS-compliant identifier. If not defined, MapDataRow is used.
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output.
Public Property | Hidden | Gets or sets the map element is hidden. An expression should evaluate to a System.Boolean.
Public Property | Label | The label to display on the map elements. An expression should evaluate to a System.String.
Public Property | OffsetX | Gets or sets the X offset for the element in geographic units. An expression should evaluate to a System.Double.
Public Property | OffsetY | Gets or sets the Y offset for the element in geographic units. An expression should evaluate to a System.Double.
Public Property | Style | Gets or sets style properties to be applied to the map elements. Each of the properties of type Color support transparency.
Public Property | ToolTip | Tool tip to display for the map elements. An expression should evaluate to a System.String.
Top
See Also

Reference

MapSpatialElementTemplate Class
GrapeCity.ActiveReports.PageReportModel Namespace


ActionInfo Property (MapSpatialElementTemplate)

ActionInfo Property (MapSpatialElementTemplate)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate Class : ActionInfo Property
Actions for the map elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ActionInfo As ActionInfo
public ActionInfo ActionInfo {get; set;}
See Also

Reference

MapSpatialElementTemplate Class
MapSpatialElementTemplate Members


DataElementLabel Property (MapSpatialElementTemplate)

DataElementLabel Property (MapSpatialElementTemplate)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate Class : DataElementLabel Property
The label for the data element. Defaults to the value of Label property. An expression should evaluate to a System.String.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataElementLabel As ExpressionInfo
public ExpressionInfo DataElementLabel {get; set;}
See Also

Reference

MapSpatialElementTemplate Class
MapSpatialElementTemplate Members


DataElementName Property (MapSpatialElementTemplate)

DataElementName Property (MapSpatialElementTemplate)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate Class : DataElementName Property
The name to use for the data element for this value. Must be a CLS-compliant identifier. If not defined, MapDataRow is used.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataElementName As System.String
public System.string DataElementName {get; set;}
See Also

Reference

MapSpatialElementTemplate Class
MapSpatialElementTemplate Members


DataElementOutput Property (MapSpatialElementTemplate)

DataElementOutput Property (MapSpatialElementTemplate)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate Class : DataElementOutput Property
Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataElementOutput As DataElementOutput
public DataElementOutput DataElementOutput {get; set;}
See Also

Reference

MapSpatialElementTemplate Class
MapSpatialElementTemplate Members


Hidden Property (MapSpatialElementTemplate)

Hidden Property (MapSpatialElementTemplate)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate Class : Hidden Property
Gets or sets the map element is hidden. An expression should evaluate to a System.Boolean.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Hidden As ExpressionInfo
public ExpressionInfo Hidden {get; set;}
See Also

Reference

MapSpatialElementTemplate Class
MapSpatialElementTemplate Members


Label Property (MapSpatialElementTemplate)

Label Property (MapSpatialElementTemplate)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate Class : Label Property
The label to display on the map elements. An expression should evaluate to a System.String.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Label As ExpressionInfo
public ExpressionInfo Label {get; set;}
See Also

Reference

MapSpatialElementTemplate Class
MapSpatialElementTemplate Members


OffsetX Property (MapSpatialElementTemplate)

OffsetX Property (MapSpatialElementTemplate)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate Class : OffsetX Property
Gets or sets the X offset for the element in geographic units. An expression should evaluate to a System.Double.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OffsetX As ExpressionInfo
public ExpressionInfo OffsetX {get; set;}
See Also

Reference

MapSpatialElementTemplate Class
MapSpatialElementTemplate Members


OffsetY Property (MapSpatialElementTemplate)

OffsetY Property (MapSpatialElementTemplate)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate Class : OffsetY Property
Gets or sets the Y offset for the element in geographic units. An expression should evaluate to a System.Double.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OffsetY As ExpressionInfo
public ExpressionInfo OffsetY {get; set;}
See Also

Reference

MapSpatialElementTemplate Class
MapSpatialElementTemplate Members


Style Property (MapSpatialElementTemplate)

Style Property (MapSpatialElementTemplate)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate Class : Style Property
Gets or sets style properties to be applied to the map elements. Each of the properties of type Color support transparency.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As Style
public Style Style {get; set;}
See Also

Reference

MapSpatialElementTemplate Class
MapSpatialElementTemplate Members


ToolTip Property (MapSpatialElementTemplate)

ToolTip Property (MapSpatialElementTemplate)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSpatialElementTemplate Class : ToolTip Property
Tool tip to display for the map elements. An expression should evaluate to a System.String.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ToolTip As ExpressionInfo
public ExpressionInfo ToolTip {get; set;}
See Also

Reference

MapSpatialElementTemplate Class
MapSpatialElementTemplate Members


MapSubItem Class

MapSubItem Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSubItem Class
Defines the common properties for map sub items
Object Model
MapSubItem Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class MapSubItem
public abstract class MapSubItem
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSubItem
GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem
GrapeCity.ActiveReports.PageReportModel.MapViewport

See Also

Reference

MapSubItem Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapSubItem Class Members

MapSubItem Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSubItem Class

The following tables list the members exposed by MapSubItem.

Public Properties
 | Name | Description
Public Property | BottomMargin | Width of the bottom margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in.
Public Property | LeftMargin | Width of the left margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in.
Public Property | MapLocation | Gets or sets the sub item location within the map. Default for MapViewport (0,0), otherwise Position is used.
Public Property | MapSize | Gets or sets the sub item size within the map. If omitted for MapViewport the default is (100,100) in percents. Automatically calculated for MapDockableSubItem.
Public Property | RightMargin | Width of the right margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in.
Public Property | Style | Gets or sets style properties for map sub item. Each of the properties of type Color support transparency.
Public Property | TopMargin | Width of the top margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in.
Public Property | ZIndex | Drawing order of the item within the map. An expression should evaluate to a System.Integer. The default value is 0.
Top
See Also

Reference

MapSubItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapSubItem Class Properties

MapSubItem Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapSubItem Class

For a list of all members of this type, see MapSubItem members.

Public Properties
 | Name | Description
Public Property | BottomMargin | Width of the bottom margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in.
Public Property | LeftMargin | Width of the left margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in.
Public Property | MapLocation | Gets or sets the sub item location within the map. Default for MapViewport (0,0), otherwise Position is used.
Public Property | MapSize | Gets or sets the sub item size within the map. If omitted for MapViewport the default is (100,100) in percents. Automatically calculated for MapDockableSubItem.
Public Property | RightMargin | Width of the right margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in.
Public Property | Style | Gets or sets style properties for map sub item. Each of the properties of type Color support transparency.
Public Property | TopMargin | Width of the top margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in.
Public Property | ZIndex | Drawing order of the item within the map. An expression should evaluate to a System.Integer. The default value is 0.
Top
See Also

Reference

MapSubItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


BottomMargin Property (MapSubItem)

BottomMargin Property (MapSubItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSubItem Class : BottomMargin Property
Width of the bottom margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BottomMargin As ExpressionInfo
public ExpressionInfo BottomMargin {get; set;}
See Also

Reference

MapSubItem Class
MapSubItem Members


LeftMargin Property (MapSubItem)

LeftMargin Property (MapSubItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSubItem Class : LeftMargin Property
Width of the left margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LeftMargin As ExpressionInfo
public ExpressionInfo LeftMargin {get; set;}
See Also

Reference

MapSubItem Class
MapSubItem Members


MapLocation Property (MapSubItem)

MapLocation Property (MapSubItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSubItem Class : MapLocation Property
Gets or sets the sub item location within the map. Default for MapViewport (0,0), otherwise Position is used.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapLocation As MapLocation
public MapLocation MapLocation {get; set;}
See Also

Reference

MapSubItem Class
MapSubItem Members


MapSize Property (MapSubItem)

MapSize Property (MapSubItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSubItem Class : MapSize Property
Gets or sets the sub item size within the map. If omitted for MapViewport the default is (100,100) in percents. Automatically calculated for MapDockableSubItem.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapSize As MapSize
public MapSize MapSize {get; set;}
See Also

Reference

MapSubItem Class
MapSubItem Members


RightMargin Property (MapSubItem)

RightMargin Property (MapSubItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSubItem Class : RightMargin Property
Width of the right margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RightMargin As ExpressionInfo
public ExpressionInfo RightMargin {get; set;}
See Also

Reference

MapSubItem Class
MapSubItem Members


Style Property (MapSubItem)

Style Property (MapSubItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSubItem Class : Style Property
Gets or sets style properties for map sub item. Each of the properties of type Color support transparency.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As Style
public Style Style {get; set;}
See Also

Reference

MapSubItem Class
MapSubItem Members


TopMargin Property (MapSubItem)

TopMargin Property (MapSubItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSubItem Class : TopMargin Property
Width of the top margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TopMargin As ExpressionInfo
public ExpressionInfo TopMargin {get; set;}
See Also

Reference

MapSubItem Class
MapSubItem Members


ZIndex Property (MapSubItem)

ZIndex Property (MapSubItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapSubItem Class : ZIndex Property
Drawing order of the item within the map. An expression should evaluate to a System.Integer. The default value is 0.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ZIndex As ExpressionInfo
public ExpressionInfo ZIndex {get; set;}
See Also

Reference

MapSubItem Class
MapSubItem Members


MapTile Class

MapTile Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTile Class
Defines a tile to be embedded in a MapTileLayer
Object Model
MapTile Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapTile
public sealed class MapTile
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapTile

See Also

Reference

MapTile Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapTile Class Members

MapTile Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTile Class

The following tables list the members exposed by MapTile.

Public Constructors
 | Name | Description
Public Constructor | MapTile Constructor | Initializes a new instance of the MapTile class.
Top
Public Properties
 | Name | Description
Public Property | MIMEType | The MIMEType for the image. Valid values are: image/jpeg, image/png.
Public Property | Name | Gets or sets the name of the tile.
Public Property | TileData | Based-64 encoded tile data
Top
See Also

Reference

MapTile Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapTile Constructor

MapTile Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTile Class : MapTile Constructor
Initializes a new instance of the MapTile class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapTile()
See Also

Reference

MapTile Class
MapTile Members


MapTile Class Properties

MapTile Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTile Class

For a list of all members of this type, see MapTile members.

Public Properties
 | Name | Description
Public Property | MIMEType | The MIMEType for the image. Valid values are: image/jpeg, image/png.
Public Property | Name | Gets or sets the name of the tile.
Public Property | TileData | Based-64 encoded tile data
Top
See Also

Reference

MapTile Class
GrapeCity.ActiveReports.PageReportModel Namespace


MIMEType Property (MapTile)

MIMEType Property (MapTile)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTile Class : MIMEType Property
The MIMEType for the image. Valid values are: image/jpeg, image/png.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MIMEType As System.String
public System.string MIMEType {get; set;}
See Also

Reference

MapTile Class
MapTile Members


Name Property (MapTile)

Name Property (MapTile)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTile Class : Name Property
Gets or sets the name of the tile.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}
See Also

Reference

MapTile Class
MapTile Members


TileData Property

TileData Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTile Class : TileData Property
Based-64 encoded tile data
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TileData As System.String
public System.string TileData {get; set;}
See Also

Reference

MapTile Class
MapTile Members


MapTileLayer Class

MapTileLayer Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTileLayer Class
Defines a raster-based layer to be drawn within a map
Object Model
MapTileLayer Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapTileLayer
   Inherits MapLayer
public sealed class MapTileLayer : MapLayer
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLayer
GrapeCity.ActiveReports.PageReportModel.MapTileLayer

See Also

Reference

MapTileLayer Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapTileLayer Class Members

MapTileLayer Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTileLayer Class

The following tables list the members exposed by MapTileLayer.

Public Constructors
 | Name | Description
Public Constructor | MapTileLayer Constructor | Initializes a new instance of the MapTileLayer class.
Top
Public Properties
 | Name | Description
Public Property | MapTiles | Gets a set of cached tiles returned by the service for a specific zoom level. For other zoom levels the tiles will be requested from the service.
Public Property | MaximumZoom | Gets or sets the maximum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 200. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | MinimumZoom | Gets or sets the minimum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 50. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | Name | Name of the layer. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | Provider | Gets or sets the name of tile provider. 'Bing' by default.
Public Property | TileStyle | Gets or sets the tiles style That evaluates to one of MapTileLayer.MapTileStyle. The default value is MapTileLayer.MapTileStyle.Road.
Public Property | Transparency | Gets or sets the transparency for all map elements contained in this layer. Measured in percents. An expression should evaluate to a System.Double. The default value is 0. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | UseSecureConnection | Gets or sets value indicating whether secure connection should be used for tiles retrieveing.
Public Property | VisibilityMode | Gets or sets the layer visibility mode. That evaluates to one of MapVisibilityMode. The default value is MapVisibilityMode.Visible. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Top
See Also

Reference

MapTileLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapTileLayer Constructor

MapTileLayer Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTileLayer Class : MapTileLayer Constructor
Initializes a new instance of the MapTileLayer class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapTileLayer()
See Also

Reference

MapTileLayer Class
MapTileLayer Members


MapTileLayer Class Properties

MapTileLayer Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTileLayer Class

For a list of all members of this type, see MapTileLayer members.

Public Properties
 | Name | Description
Public Property | MapTiles | Gets a set of cached tiles returned by the service for a specific zoom level. For other zoom levels the tiles will be requested from the service.
Public Property | MaximumZoom | Gets or sets the maximum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 200. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | MinimumZoom | Gets or sets the minimum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 50. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | Name | Name of the layer. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | Provider | Gets or sets the name of tile provider. 'Bing' by default.
Public Property | TileStyle | Gets or sets the tiles style That evaluates to one of MapTileLayer.MapTileStyle. The default value is MapTileLayer.MapTileStyle.Road.
Public Property | Transparency | Gets or sets the transparency for all map elements contained in this layer. Measured in percents. An expression should evaluate to a System.Double. The default value is 0. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | UseSecureConnection | Gets or sets value indicating whether secure connection should be used for tiles retrieveing.
Public Property | VisibilityMode | Gets or sets the layer visibility mode. That evaluates to one of MapVisibilityMode. The default value is MapVisibilityMode.Visible. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Top
See Also

Reference

MapTileLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapTiles Property

MapTiles Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTileLayer Class : MapTiles Property
Gets a set of cached tiles returned by the service for a specific zoom level. For other zoom levels the tiles will be requested from the service.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MapTiles As System.Collections.Generic.IList(Of MapTile)
public System.Collections.Generic.IList<MapTile> MapTiles {get;}
See Also

Reference

MapTileLayer Class
MapTileLayer Members


Provider Property (MapTileLayer)

Provider Property (MapTileLayer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTileLayer Class : Provider Property
Gets or sets the name of tile provider. 'Bing' by default.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Provider As ExpressionInfo
public ExpressionInfo Provider {get; set;}
See Also

Reference

MapTileLayer Class
MapTileLayer Members


TileStyle Property (MapTileLayer)

TileStyle Property (MapTileLayer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTileLayer Class : TileStyle Property
Gets or sets the tiles style That evaluates to one of MapTileLayer.MapTileStyle. The default value is MapTileLayer.MapTileStyle.Road.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TileStyle As ExpressionInfo
public ExpressionInfo TileStyle {get; set;}
See Also

Reference

MapTileLayer Class
MapTileLayer Members


UseSecureConnection Property (MapTileLayer)

UseSecureConnection Property (MapTileLayer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTileLayer Class : UseSecureConnection Property
Gets or sets value indicating whether secure connection should be used for tiles retrieveing.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseSecureConnection As ExpressionInfo
public ExpressionInfo UseSecureConnection {get; set;}
See Also

Reference

MapTileLayer Class
MapTileLayer Members


MapTitle Class

MapTitle Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTitle Class
Defines a title to be drawn within a map
Object Model
MapTitle Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapTitle
   Inherits MapDockableSubItem
public sealed class MapTitle : MapDockableSubItem
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSubItem
GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem
GrapeCity.ActiveReports.PageReportModel.MapTitle

See Also

Reference

MapTitle Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapTitle Class Members

MapTitle Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTitle Class

The following tables list the members exposed by MapTitle.

Public Constructors
 | Name | Description
Public Constructor | MapTitle Constructor | Initializes a new instance of the MapTitle class.
Top
Public Properties
 | Name | Description
Public Property | ActionInfo | Actions for the map sub item. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | Angle | Angle of rotation for the title. An expression should evaluate to a System.Double. The default value is 0.
Public Property | BottomMargin | Width of the bottom margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | DockOutsideViewport | Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | Hidden | Gets or sets the item is hidden. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | LeftMargin | Width of the left margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapLocation | Gets or sets the sub item location within the map. Default for MapViewport (0,0), otherwise Position is used. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapSize | Gets or sets the sub item size within the map. If omitted for MapViewport the default is (100,100) in percents. Automatically calculated for MapDockableSubItem. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | Name | Name of the title.
Public Property | Position | The position of the sub item. Ignored if MapLocation is defined. That evaluates to one of MapDockableSubItem.MapPosition. The default value is MapDockableSubItem.MapPosition.TopCenter. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | RightMargin | Width of the right margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | Style | Gets or sets style properties for map sub item. Each of the properties of type Color support transparency. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | Text | Text of the title.
Public Property | TextShadowOffset | Size of the text shadow. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0.
Public Property | ToolTip | Tool tip to display for the map sub item. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | TopMargin | Width of the top margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | ZIndex | Drawing order of the item within the map. An expression should evaluate to a System.Integer. The default value is 0. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Top
See Also

Reference

MapTitle Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapTitle Constructor

MapTitle Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTitle Class : MapTitle Constructor
Initializes a new instance of the MapTitle class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapTitle()
See Also

Reference

MapTitle Class
MapTitle Members


MapTitle Class Properties

MapTitle Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTitle Class

For a list of all members of this type, see MapTitle members.

Public Properties
 | Name | Description
Public Property | ActionInfo | Actions for the map sub item. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | Angle | Angle of rotation for the title. An expression should evaluate to a System.Double. The default value is 0.
Public Property | BottomMargin | Width of the bottom margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | DockOutsideViewport | Gets or sets the sub item should be docked outside the viewport. Ignored if MapLocation is defined. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | Hidden | Gets or sets the item is hidden. An expression should evaluate to a System.Boolean. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | LeftMargin | Width of the left margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapLocation | Gets or sets the sub item location within the map. Default for MapViewport (0,0), otherwise Position is used. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapSize | Gets or sets the sub item size within the map. If omitted for MapViewport the default is (100,100) in percents. Automatically calculated for MapDockableSubItem. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | Name | Name of the title.
Public Property | Position | The position of the sub item. Ignored if MapLocation is defined. That evaluates to one of MapDockableSubItem.MapPosition. The default value is MapDockableSubItem.MapPosition.TopCenter. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | RightMargin | Width of the right margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | Style | Gets or sets style properties for map sub item. Each of the properties of type Color support transparency. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | Text | Text of the title.
Public Property | TextShadowOffset | Size of the text shadow. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0.
Public Property | ToolTip | Tool tip to display for the map sub item. An expression should evaluate to a System.String. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem)
Public Property | TopMargin | Width of the top margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | ZIndex | Drawing order of the item within the map. An expression should evaluate to a System.Integer. The default value is 0. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Top
See Also

Reference

MapTitle Class
GrapeCity.ActiveReports.PageReportModel Namespace


Angle Property (MapTitle)

Angle Property (MapTitle)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTitle Class : Angle Property
Angle of rotation for the title. An expression should evaluate to a System.Double. The default value is 0.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Angle As ExpressionInfo
public ExpressionInfo Angle {get; set;}
See Also

Reference

MapTitle Class
MapTitle Members


Name Property (MapTitle)

Name Property (MapTitle)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTitle Class : Name Property
Name of the title.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}
See Also

Reference

MapTitle Class
MapTitle Members


Text Property (MapTitle)

Text Property (MapTitle)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTitle Class : Text Property
Text of the title.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Text As ExpressionInfo
public ExpressionInfo Text {get; set;}
See Also

Reference

MapTitle Class
MapTitle Members


TextShadowOffset Property (MapTitle)

TextShadowOffset Property (MapTitle)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapTitle Class : TextShadowOffset Property
Size of the text shadow. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TextShadowOffset As ExpressionInfo
public ExpressionInfo TextShadowOffset {get; set;}
See Also

Reference

MapTitle Class
MapTitle Members


MapVectorLayer Class

MapVectorLayer Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapVectorLayer Class
Defines a vector-based layer of map elements to be drawn within a map
Object Model
MapVectorLayer Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class MapVectorLayer
   Inherits MapLayer
public abstract class MapVectorLayer : MapLayer
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapLayer
GrapeCity.ActiveReports.PageReportModel.MapVectorLayer
GrapeCity.ActiveReports.PageReportModel.MapLineLayer
GrapeCity.ActiveReports.PageReportModel.MapPointLayer
GrapeCity.ActiveReports.PageReportModel.MapPolygonLayer

See Also

Reference

MapVectorLayer Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapVectorLayer Class Members

MapVectorLayer Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapVectorLayer Class

The following tables list the members exposed by MapVectorLayer.

Public Properties
 | Name | Description
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier.
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output.
Public Property | Elements | Returns the collection of layer elements.
Public Property | MapBindingFieldPairs | Gets the set of field/expression pairs for binding the map elements within a layer to the data region. Mandatory if MapDataRegionName is defined and MapSpatialData is not MapSpatialDataRegion; ignored otherwise.
Public Property | MapDataRegionName | Gets or sets which data region to use as the source. Mandatory if MapSpatialData is MapSpatialDataRegion.
Public Property | MapFieldDefinitions | Gets the set of field definitions for the embedded map elements (for example, MapPolygons, MapLines, MapPoints). Ignored if the embedded map elements are not defined.
Public Property | MapSpatialData | Gets or sets the spatial data source for the layer. Ignored if the embedded map elements are defined.
Public Property | MaximumZoom | Gets or sets the maximum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 200. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | MinimumZoom | Gets or sets the minimum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 50. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | Name | Name of the layer. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | Transparency | Gets or sets the transparency for all map elements contained in this layer. Measured in percents. An expression should evaluate to a System.Double. The default value is 0. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | VisibilityMode | Gets or sets the layer visibility mode. That evaluates to one of MapVisibilityMode. The default value is MapVisibilityMode.Visible. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Top
See Also

Reference

MapVectorLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapVectorLayer Class Properties

MapVectorLayer Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapVectorLayer Class

For a list of all members of this type, see MapVectorLayer members.

Public Properties
 | Name | Description
Public Property | DataElementName | The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier.
Public Property | DataElementOutput | Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output.
Public Property | Elements | Returns the collection of layer elements.
Public Property | MapBindingFieldPairs | Gets the set of field/expression pairs for binding the map elements within a layer to the data region. Mandatory if MapDataRegionName is defined and MapSpatialData is not MapSpatialDataRegion; ignored otherwise.
Public Property | MapDataRegionName | Gets or sets which data region to use as the source. Mandatory if MapSpatialData is MapSpatialDataRegion.
Public Property | MapFieldDefinitions | Gets the set of field definitions for the embedded map elements (for example, MapPolygons, MapLines, MapPoints). Ignored if the embedded map elements are not defined.
Public Property | MapSpatialData | Gets or sets the spatial data source for the layer. Ignored if the embedded map elements are defined.
Public Property | MaximumZoom | Gets or sets the maximum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 200. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | MinimumZoom | Gets or sets the minimum zoom level at which the layer is visible. Ignored if VisibilityMode != MapVisibilityMode.ZoomBased. An expression should evaluate to a System.Double. The default value is 50. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | Name | Name of the layer. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | Transparency | Gets or sets the transparency for all map elements contained in this layer. Measured in percents. An expression should evaluate to a System.Double. The default value is 0. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Public Property | VisibilityMode | Gets or sets the layer visibility mode. That evaluates to one of MapVisibilityMode. The default value is MapVisibilityMode.Visible. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapLayer)
Top
See Also

Reference

MapVectorLayer Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataElementName Property (MapVectorLayer)

DataElementName Property (MapVectorLayer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapVectorLayer Class : DataElementName Property
The name to use for the data element/attribute for this value. Must be a CLS-compliant identifier.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataElementName As System.String
public System.string DataElementName {get; set;}
See Also

Reference

MapVectorLayer Class
MapVectorLayer Members


DataElementOutput Property (MapVectorLayer)

DataElementOutput Property (MapVectorLayer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapVectorLayer Class : DataElementOutput Property
Gets or sets whether the item should appear in a data rendering. That evaluates to one of DataElementOutput. The default value is DataElementOutput.Output.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataElementOutput As DataElementOutput
public DataElementOutput DataElementOutput {get; set;}
See Also

Reference

MapVectorLayer Class
MapVectorLayer Members


Elements Property (MapVectorLayer)

Elements Property (MapVectorLayer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapVectorLayer Class : Elements Property
Returns the collection of layer elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property Elements As System.Collections.Generic.IEnumerable(Of MapSpatialElement)
public abstract System.Collections.Generic.IEnumerable<MapSpatialElement> Elements {get;}

Property Value

The elements.
See Also

Reference

MapVectorLayer Class
MapVectorLayer Members


MapBindingFieldPairs Property (MapVectorLayer)

MapBindingFieldPairs Property (MapVectorLayer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapVectorLayer Class : MapBindingFieldPairs Property
Gets the set of field/expression pairs for binding the map elements within a layer to the data region. Mandatory if MapDataRegionName is defined and MapSpatialData is not MapSpatialDataRegion; ignored otherwise.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MapBindingFieldPairs As System.Collections.Generic.IList(Of MapBindingFieldPair)
public System.Collections.Generic.IList<MapBindingFieldPair> MapBindingFieldPairs {get;}
See Also

Reference

MapVectorLayer Class
MapVectorLayer Members


MapDataRegionName Property

MapDataRegionName Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapVectorLayer Class : MapDataRegionName Property
Gets or sets which data region to use as the source. Mandatory if MapSpatialData is MapSpatialDataRegion.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapDataRegionName As System.String
public System.string MapDataRegionName {get; set;}
See Also

Reference

MapVectorLayer Class
MapVectorLayer Members


MapFieldDefinitions Property

MapFieldDefinitions Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapVectorLayer Class : MapFieldDefinitions Property
Gets the set of field definitions for the embedded map elements (for example, MapPolygons, MapLines, MapPoints). Ignored if the embedded map elements are not defined.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MapFieldDefinitions As System.Collections.Generic.IList(Of MapFieldDefinition)
public System.Collections.Generic.IList<MapFieldDefinition> MapFieldDefinitions {get;}
See Also

Reference

MapVectorLayer Class
MapVectorLayer Members


MapSpatialData Property

MapSpatialData Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapVectorLayer Class : MapSpatialData Property
Gets or sets the spatial data source for the layer. Ignored if the embedded map elements are defined.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapSpatialData As MapSpatialData
public MapSpatialData MapSpatialData {get; set;}
See Also

Reference

MapVectorLayer Class
MapVectorLayer Members


MapView Class

MapView Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapView Class
Defines the viewport center and zoom level
Object Model
MapView Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class MapView
public abstract class MapView
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapView
GrapeCity.ActiveReports.PageReportModel.MapCustomView
GrapeCity.ActiveReports.PageReportModel.MapDataBoundView
GrapeCity.ActiveReports.PageReportModel.MapElementView

See Also

Reference

MapView Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapView Class Members

MapView Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapView Class

The following tables list the members exposed by MapView.

Public Properties
 | Name | Description
Public Property | Zoom | Gets or sets the viewport zoom level. Automatically calculated if omitted based on the MapView type. An expression should evaluate to a System.Double.
Top
See Also

Reference

MapView Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapView Class Properties

MapView Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapView Class

For a list of all members of this type, see MapView members.

Public Properties
 | Name | Description
Public Property | Zoom | Gets or sets the viewport zoom level. Automatically calculated if omitted based on the MapView type. An expression should evaluate to a System.Double.
Top
See Also

Reference

MapView Class
GrapeCity.ActiveReports.PageReportModel Namespace


Zoom Property (MapView)

Zoom Property (MapView)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapView Class : Zoom Property
Gets or sets the viewport zoom level. Automatically calculated if omitted based on the MapView type. An expression should evaluate to a System.Double.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Zoom As ExpressionInfo
public ExpressionInfo Zoom {get; set;}
See Also

Reference

MapView Class
MapView Members


MapViewport Class

MapViewport Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapViewport Class
Defines the map viewport
Object Model
MapViewport Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MapViewport
   Inherits MapSubItem
public sealed class MapViewport : MapSubItem
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MapSubItem
GrapeCity.ActiveReports.PageReportModel.MapViewport

See Also

Reference

MapViewport Members
GrapeCity.ActiveReports.PageReportModel Namespace


MapViewport Class Members

MapViewport Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapViewport Class

The following tables list the members exposed by MapViewport.

Public Constructors
 | Name | Description
Public Constructor | MapViewport Constructor | Initializes a new instance of the MapViewport class.
Top
Public Properties
 | Name | Description
Public Property | BottomMargin | Width of the bottom margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | ContentMargin | Gets or sets the content margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 10pt.
Public Property | GridUnderContent | Gets or sets the meridians and parallels will be drawn under the map content. An expression should evaluate to a System.Boolean.
Public Property | LeftMargin | Width of the left margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapCoordinateSystem | The map projection That evaluates to one of CoordinateSystem. The default value is CoordinateSystem.Planar.
Public Property | MapLimits | Gets or sets the map limits. Automatically calculated if omitted.
Public Property | MapLocation | Gets or sets the sub item location within the map. Default for MapViewport (0,0), otherwise Position is used. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapMeridians | Gets or sets the map meridians.
Public Property | MapParallels | Gets or sets the map parallels.
Public Property | MapProjection | The map projection. That evaluates to one of MapProjection. The default value is MapProjection.Equirectangular.
Public Property | MapSize | Gets or sets the sub item size within the map. If omitted for MapViewport the default is (100,100) in percents. Automatically calculated for MapDockableSubItem. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapView | Gets or sets the view center and zoom. An expression should evaluate to a MapView.
Public Property | MaximumZoom | Gets or sets the maximum zoom level allowed. An expression should evaluate to a System.Double. The default value is 20000.
Public Property | MinimumZoom | Gets or sets the minimum zoom level allowed. An expression should evaluate to a System.Double. The default value is 20.
Public Property | ProjectionCenterX | Gets or sets the X projection center in geographic units. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Public Property | ProjectionCenterY | Gets or sets the Y projection center in geographic units. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Public Property | RightMargin | Width of the right margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | SimplificationResolution | Simplification resolution in map units to be applied to polygon and line layers. An expression should evaluate to a System.Double. The default value is 0 (No simplification).
Public Property | Style | Gets or sets style properties for map sub item. Each of the properties of type Color support transparency. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | TopMargin | Width of the top margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | ZIndex | Drawing order of the item within the map. An expression should evaluate to a System.Integer. The default value is 0. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Top
See Also

Reference

MapViewport Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapViewport Constructor

MapViewport Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : MapViewport Constructor
Initializes a new instance of the MapViewport class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapViewport()
See Also

Reference

MapViewport Class
MapViewport Members


MapViewport Class Properties

MapViewport Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapViewport Class

For a list of all members of this type, see MapViewport members.

Public Properties
 | Name | Description
Public Property | BottomMargin | Width of the bottom margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | ContentMargin | Gets or sets the content margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 10pt.
Public Property | GridUnderContent | Gets or sets the meridians and parallels will be drawn under the map content. An expression should evaluate to a System.Boolean.
Public Property | LeftMargin | Width of the left margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapCoordinateSystem | The map projection That evaluates to one of CoordinateSystem. The default value is CoordinateSystem.Planar.
Public Property | MapLimits | Gets or sets the map limits. Automatically calculated if omitted.
Public Property | MapLocation | Gets or sets the sub item location within the map. Default for MapViewport (0,0), otherwise Position is used. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapMeridians | Gets or sets the map meridians.
Public Property | MapParallels | Gets or sets the map parallels.
Public Property | MapProjection | The map projection. That evaluates to one of MapProjection. The default value is MapProjection.Equirectangular.
Public Property | MapSize | Gets or sets the sub item size within the map. If omitted for MapViewport the default is (100,100) in percents. Automatically calculated for MapDockableSubItem. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | MapView | Gets or sets the view center and zoom. An expression should evaluate to a MapView.
Public Property | MaximumZoom | Gets or sets the maximum zoom level allowed. An expression should evaluate to a System.Double. The default value is 20000.
Public Property | MinimumZoom | Gets or sets the minimum zoom level allowed. An expression should evaluate to a System.Double. The default value is 20.
Public Property | ProjectionCenterX | Gets or sets the X projection center in geographic units. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Public Property | ProjectionCenterY | Gets or sets the Y projection center in geographic units. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Public Property | RightMargin | Width of the right margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | SimplificationResolution | Simplification resolution in map units to be applied to polygon and line layers. An expression should evaluate to a System.Double. The default value is 0 (No simplification).
Public Property | Style | Gets or sets style properties for map sub item. Each of the properties of type Color support transparency. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | TopMargin | Width of the top margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 0 in. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Public Property | ZIndex | Drawing order of the item within the map. An expression should evaluate to a System.Integer. The default value is 0. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapSubItem)
Top
See Also

Reference

MapViewport Class
GrapeCity.ActiveReports.PageReportModel Namespace


ContentMargin Property (MapViewport)

ContentMargin Property (MapViewport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : ContentMargin Property
Gets or sets the content margin. An expression should evaluate to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length. The default value is 10pt.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ContentMargin As ExpressionInfo
public ExpressionInfo ContentMargin {get; set;}
See Also

Reference

MapViewport Class
MapViewport Members


GridUnderContent Property (MapViewport)

GridUnderContent Property (MapViewport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : GridUnderContent Property
Gets or sets the meridians and parallels will be drawn under the map content. An expression should evaluate to a System.Boolean.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GridUnderContent As ExpressionInfo
public ExpressionInfo GridUnderContent {get; set;}
See Also

Reference

MapViewport Class
MapViewport Members


MapCoordinateSystem Property (MapViewport)

MapCoordinateSystem Property (MapViewport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : MapCoordinateSystem Property
The map projection That evaluates to one of CoordinateSystem. The default value is CoordinateSystem.Planar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapCoordinateSystem As ExpressionInfo
public ExpressionInfo MapCoordinateSystem {get; set;}
See Also

Reference

MapViewport Class
MapViewport Members


MapLimits Property (MapViewport)

MapLimits Property (MapViewport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : MapLimits Property
Gets or sets the map limits. Automatically calculated if omitted.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapLimits As MapLimits
public MapLimits MapLimits {get; set;}
See Also

Reference

MapViewport Class
MapViewport Members


MapMeridians Property (MapViewport)

MapMeridians Property (MapViewport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : MapMeridians Property
Gets or sets the map meridians.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapMeridians As MapGridLines
public MapGridLines MapMeridians {get; set;}
See Also

Reference

MapViewport Class
MapViewport Members


MapParallels Property (MapViewport)

MapParallels Property (MapViewport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : MapParallels Property
Gets or sets the map parallels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapParallels As MapGridLines
public MapGridLines MapParallels {get; set;}
See Also

Reference

MapViewport Class
MapViewport Members


MapProjection Property (MapViewport)

MapProjection Property (MapViewport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : MapProjection Property
The map projection. That evaluates to one of MapProjection. The default value is MapProjection.Equirectangular.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapProjection As ExpressionInfo
public ExpressionInfo MapProjection {get; set;}
See Also

Reference

MapViewport Class
MapViewport Members


MapView Property (MapViewport)

MapView Property (MapViewport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : MapView Property
Gets or sets the view center and zoom. An expression should evaluate to a MapView.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MapView As MapView
public MapView MapView {get; set;}
See Also

Reference

MapViewport Class
MapViewport Members


MaximumZoom Property (MapViewport)

MaximumZoom Property (MapViewport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : MaximumZoom Property
Gets or sets the maximum zoom level allowed. An expression should evaluate to a System.Double. The default value is 20000.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaximumZoom As ExpressionInfo
public ExpressionInfo MaximumZoom {get; set;}
See Also

Reference

MapViewport Class
MapViewport Members


MinimumZoom Property (MapViewport)

MinimumZoom Property (MapViewport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : MinimumZoom Property
Gets or sets the minimum zoom level allowed. An expression should evaluate to a System.Double. The default value is 20.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinimumZoom As ExpressionInfo
public ExpressionInfo MinimumZoom {get; set;}
See Also

Reference

MapViewport Class
MapViewport Members


ProjectionCenterX Property (MapViewport)

ProjectionCenterX Property (MapViewport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : ProjectionCenterX Property
Gets or sets the X projection center in geographic units. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ProjectionCenterX As ExpressionInfo
public ExpressionInfo ProjectionCenterX {get; set;}
See Also

Reference

MapViewport Class
MapViewport Members


ProjectionCenterY Property (MapViewport)

ProjectionCenterY Property (MapViewport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : ProjectionCenterY Property
Gets or sets the Y projection center in geographic units. Automatically calculated if omitted. An expression should evaluate to a System.Double.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ProjectionCenterY As ExpressionInfo
public ExpressionInfo ProjectionCenterY {get; set;}
See Also

Reference

MapViewport Class
MapViewport Members


SimplificationResolution Property (MapViewport)

SimplificationResolution Property (MapViewport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MapViewport Class : SimplificationResolution Property
Simplification resolution in map units to be applied to polygon and line layers. An expression should evaluate to a System.Double. The default value is 0 (No simplification).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SimplificationResolution As ExpressionInfo
public ExpressionInfo SimplificationResolution {get; set;}
See Also

Reference

MapViewport Class
MapViewport Members


Marker Class

Marker Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Marker Class
The Marker element defines a marker for displayed chart values.
Object Model
Marker Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Marker
public sealed class Marker
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Marker

See Also

Reference

Marker Members
GrapeCity.ActiveReports.PageReportModel Namespace


Marker Class Members

Marker Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Marker Class

The following tables list the members exposed by Marker.

Public Constructors
 | Name | Description
Public Constructor | Marker Constructor | Initializes a new instance of the Marker class.
Top
Public Properties
 | Name | Description
Public Property | Size | Gets or sets the height and width of the plotting area of the markers.
Public Property | Style | Gets or sets the border and background style properties for the markers.
Public Property | Type | Gets or sets the marker type for values.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the Marker object.
Top
See Also

Reference

Marker Class
GrapeCity.ActiveReports.PageReportModel Namespace


Marker Constructor

Marker Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Marker Class : Marker Constructor

Initializes a new instance of the Marker class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Marker()
See Also

Reference

Marker Class
Marker Members


Marker Class Methods

Marker Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Marker Class

For a list of all members of this type, see Marker members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the Marker object.
Top
See Also

Reference

Marker Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (Marker)

Validate Method (Marker)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Marker Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the Marker object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

Marker Class
Marker Members


Marker Class Properties

Marker Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Marker Class

For a list of all members of this type, see Marker members.

Public Properties
 | Name | Description
Public Property | Size | Gets or sets the height and width of the plotting area of the markers.
Public Property | Style | Gets or sets the border and background style properties for the markers.
Public Property | Type | Gets or sets the marker type for values.
Top
See Also

Reference

Marker Class
GrapeCity.ActiveReports.PageReportModel Namespace


Size Property (Marker)

Size Property (Marker)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Marker Class : Size Property

Gets or sets the height and width of the plotting area of the markers.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Size As Length
public Length Size {get; set;}

Property Value

A GrapeCity.ActiveReports.Extensibility.Definition.Components.Length structure containing the height and width of the plotting area of the markers.
See Also

Reference

Marker Class
Marker Members


Style Property (Marker)

Style Property (Marker)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Marker Class : Style Property

Gets or sets the border and background style properties for the markers.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As Style
public Style Style {get; set;}

Property Value

A Style object containing the border and background style properties for the markers.
See Also

Reference

Marker Class
Marker Members


Type Property (Marker)

Type Property (Marker)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Marker Class : Type Property

Gets or sets the marker type for values.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Type As MarkerType
public MarkerType Type {get; set;}

Property Value

A MarkerType enumeration indicating the marker type for values.

See Also

Reference

Marker Class
Marker Members


MasterReportNotFoundException Class

MasterReportNotFoundException Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MasterReportNotFoundException Class
Raised when a master report cannot be found.
Object Model
MasterReportNotFoundException Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class MasterReportNotFoundException
   Inherits GrapeCity.ActiveReports.ReportException
public class MasterReportNotFoundException : GrapeCity.ActiveReports.ReportException
Inheritance Hierarchy

System.Object
System.Exception
GrapeCity.ActiveReports.ReportException
GrapeCity.ActiveReports.PageReportModel.MasterReportNotFoundException

See Also

Reference

MasterReportNotFoundException Members
GrapeCity.ActiveReports.PageReportModel Namespace


MasterReportNotFoundException Class Members

MasterReportNotFoundException Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MasterReportNotFoundException Class

The following tables list the members exposed by MasterReportNotFoundException.

Public Constructors
 | Name | Description
Public Constructor | MasterReportNotFoundException Constructor | Initializes a new instance of the MasterReportNotFoundException class.
Top
Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Error code for future detail processing. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | ErrorData | Error data, depends on error code. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

MasterReportNotFoundException Class
GrapeCity.ActiveReports.PageReportModel Namespace


MasterReportNotFoundException Constructor

MasterReportNotFoundException Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterReportNotFoundException Class : MasterReportNotFoundException Constructor
Initializes a new instance of the MasterReportNotFoundException class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MasterReportNotFoundException()
See Also

Reference

MasterReportNotFoundException Class
MasterReportNotFoundException Members


Matrix Class

Matrix Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Matrix Class
The Matrix element defines a grid of regions that repeats with each column group and row group in the dataset.
Object Model
Matrix Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Matrix
   Inherits DataRegion
   Implements IReportComponent, IReportComponentContainer, IScopeDefinition
public sealed class Matrix : DataRegion, IReportComponent, IReportComponentContainer, IScopeDefinition
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.DataRegion
GrapeCity.ActiveReports.PageReportModel.Matrix

See Also

Reference

Matrix Members
GrapeCity.ActiveReports.PageReportModel Namespace


Matrix Class Members

Matrix Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Matrix Class

The following tables list the members exposed by Matrix.

Public Constructors
 | Name | Description
Public Constructor | Matrix Constructor | Initializes a new instance of the Matrix class.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | CellDataElementName | The name to use for the cell element.
Public Property | CellDataElementOutput | Gets or sets a value indicating whether the cell contents appear in a data rendering.
Public Property | ChildScopes | Overridden. Overridden.Implements IScopeDefinition.ChildScopes.
Public Property | ColumnGroupings | Gets the set of column groupings for the matrix.
Public Property | Components | Gets the ReportComponentCollection containing all of the components hosted in the control.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Corner | Gets or sets the region that contains the elements of the upper left corner area of the matrix.
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataSetName | Gets or sets the name of the dataset that the data region uses. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | Filters | Gets the collection of filters applied to each row of data within the data region. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | FixedHeight | Represents the data region's maximum height per page. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | FixedWidth | Represents the data region's maximum width per page. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | GroupsBeforeRowHeaders | Gets or sets the number of instances of the outermost column group that appear to the left of the row headers (right of the row headers for right-to-left matrices).
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayoutDirection | Gets or sets a value indicating whether the matrix columns grow left-to-right (with headers on the left) or right-to-left (with headers on the right).
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | MatrixColumns | Gets the columns contained in each detail cell of the matrix layout.
Public Property | MatrixRows | Gets the rows contained in each detail cell of the matrix layout.
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | NewSection | Gets or sets a value indicating whether a data region is in it's own section (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | NoRows | Gets or sets the message to display inside the data region when the region contains no rows. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | OverflowName | Represents the data region's overflow name. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether a page break occurs immediately after the data region ends. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | PageBreakAtStart | Gets or sets a value indicating whether a page break occurs immediately before the data region begins. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | RowGroupings | Gets the set of row groupings for the matrix.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Overridden. Validates the information in each property of the Matrix object.
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Matrix Class
GrapeCity.ActiveReports.PageReportModel Namespace


Matrix Constructor

Matrix Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : Matrix Constructor
Initializes a new instance of the Matrix class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Matrix()
See Also

Reference

Matrix Class
Matrix Members


Matrix Class Methods

Matrix Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Matrix Class

For a list of all members of this type, see Matrix members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Overridden. Validates the information in each property of the Matrix object.
Top
See Also

Reference

Matrix Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (Matrix)

Validate Method (Matrix)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the Matrix object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

Matrix Class
Matrix Members


Matrix Class Properties

Matrix Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Matrix Class

For a list of all members of this type, see Matrix members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | CellDataElementName | The name to use for the cell element.
Public Property | CellDataElementOutput | Gets or sets a value indicating whether the cell contents appear in a data rendering.
Public Property | ChildScopes | Overridden. Overridden.Implements IScopeDefinition.ChildScopes.
Public Property | ColumnGroupings | Gets the set of column groupings for the matrix.
Public Property | Components | Gets the ReportComponentCollection containing all of the components hosted in the control.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Corner | Gets or sets the region that contains the elements of the upper left corner area of the matrix.
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataSetName | Gets or sets the name of the dataset that the data region uses. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | Filters | Gets the collection of filters applied to each row of data within the data region. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | FixedHeight | Represents the data region's maximum height per page. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | FixedWidth | Represents the data region's maximum width per page. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | GroupsBeforeRowHeaders | Gets or sets the number of instances of the outermost column group that appear to the left of the row headers (right of the row headers for right-to-left matrices).
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayoutDirection | Gets or sets a value indicating whether the matrix columns grow left-to-right (with headers on the left) or right-to-left (with headers on the right).
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | MatrixColumns | Gets the columns contained in each detail cell of the matrix layout.
Public Property | MatrixRows | Gets the rows contained in each detail cell of the matrix layout.
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | NewSection | Gets or sets a value indicating whether a data region is in it's own section (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | NoRows | Gets or sets the message to display inside the data region when the region contains no rows. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | OverflowName | Represents the data region's overflow name. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether a page break occurs immediately after the data region ends. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | PageBreakAtStart | Gets or sets a value indicating whether a page break occurs immediately before the data region begins. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | RowGroupings | Gets the set of row groupings for the matrix.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
See Also

Reference

Matrix Class
GrapeCity.ActiveReports.PageReportModel Namespace


CellDataElementName Property

CellDataElementName Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : CellDataElementName Property

The name to use for the cell element.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CellDataElementName As System.String
public System.string CellDataElementName {get; set;}

Property Value

A String indicating the name to use for the cell element.

Remarks

The default value is "Cell."

See Also

Reference

Matrix Class
Matrix Members


CellDataElementOutput Property

CellDataElementOutput Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : CellDataElementOutput Property

Gets or sets a value indicating whether the cell contents appear in a data rendering.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CellDataElementOutput As DataElementOutput
public DataElementOutput CellDataElementOutput {get; set;}

Property Value

A DataElementOutput enumeration indicating whether the cell contents appear in a data rendering.
Remarks

Output(Default) indicates that the cell appears in the output.

NoOutput indicates that the cell does not appear in the output.

See Also

Reference

Matrix Class
Matrix Members


ChildScopes Property (Matrix)

ChildScopes Property (Matrix)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : ChildScopes Property
Overridden.Implements IScopeDefinition.ChildScopes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable ReadOnly Property ChildScopes As System.Collections.IEnumerable
public override System.Collections.IEnumerable ChildScopes {get;}

Property Value

The child scopes.
See Also

Reference

Matrix Class
Matrix Members


ColumnGroupings Property (Matrix)

ColumnGroupings Property (Matrix)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : ColumnGroupings Property

Gets the set of column groupings for the matrix.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ColumnGroupings As ColumnGroupingCollection
public ColumnGroupingCollection ColumnGroupings {get;}

Property Value

A ColumnGroupingCollection containing the set of column groupings for the matrix.

See Also

Reference

Matrix Class
Matrix Members


Components Property (Matrix)

Components Property (Matrix)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : Components Property
Gets the ReportComponentCollection containing all of the components hosted in the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Components As ReportComponentCollection
public ReportComponentCollection Components {get;}

Property Value

A read-only DataDynamics.Reports.ReportObjectModel.Rdl.ReportComponentCollection containing all of the components hosted in the control.
See Also

Reference

Matrix Class
Matrix Members


Corner Property (Matrix)

Corner Property (Matrix)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : Corner Property

Gets or sets the region that contains the elements of the upper left corner area of the matrix.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Corner As Corner
public Corner Corner {get; set;}

Property Value

A Corner object indicating the region that contains the elements of the upper left corner area of the matrix.
Remarks

If omitted, no report items are output in the corner.

See Also

Reference

Matrix Class
Matrix Members


GroupsBeforeRowHeaders Property (Matrix)

GroupsBeforeRowHeaders Property (Matrix)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : GroupsBeforeRowHeaders Property

Gets or sets the number of instances of the outermost column group that appear to the left of the row headers (right of the row headers for right-to-left matrices).

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GroupsBeforeRowHeaders As System.Integer
public System.int GroupsBeforeRowHeaders {get; set;}

Property Value

An Integer indicating the number of instances of the outermost column group that appear to the left of the row headers.

Remarks

For the purposes of GroupsBeforeRowHeaders, a subtotal column is considered a part of (and will move with) the rightmost or leftmost detail column, as appropriate.

See Also

Reference

Matrix Class
Matrix Members


LayoutDirection Property (Matrix)

LayoutDirection Property (Matrix)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : LayoutDirection Property

Gets or sets a value indicating whether the matrix columns grow left-to-right (with headers on the left) or right-to-left (with headers on the right).

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LayoutDirection As LayoutDirection
public LayoutDirection LayoutDirection {get; set;}

Property Value

A LayoutDirection enumeration indicating whether the matrix columns grow left-to-right or right-to-left.
See Also

Reference

Matrix Class
Matrix Members


MatrixColumns Property

MatrixColumns Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : MatrixColumns Property

Gets the columns contained in each detail cell of the matrix layout.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MatrixColumns As MatrixColumnCollection
public MatrixColumnCollection MatrixColumns {get;}

Property Value

A MatrixColumnCollection indicating the columns contained in each detail cell of the matrix layout.
See Also

Reference

Matrix Class
Matrix Members


MatrixRows Property

MatrixRows Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : MatrixRows Property

Gets the rows contained in each detail cell of the matrix layout.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MatrixRows As MatrixRowCollection
public MatrixRowCollection MatrixRows {get;}

Property Value

A MatrixRowCollection indicating the rows contained in each detail cell of the matrix layout.
See Also

Reference

Matrix Class
Matrix Members


RowGroupings Property (Matrix)

RowGroupings Property (Matrix)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : RowGroupings Property

Gets the set of row groupings for the matrix.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property RowGroupings As RowGroupingCollection
public RowGroupingCollection RowGroupings {get;}

Property Value

A RowGroupingCollection indicating the set of row groupings for the matrix.
See Also

Reference

Matrix Class
Matrix Members


MatrixCell Class

MatrixCell Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixCell Class
The MatrixCell element defines the contents of each detail cell in the matrix.
Object Model
MatrixCell Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MatrixCell
   Inherits ReportComponentContainer
   Implements IRdlContainer, IReportComponent, IReportComponentContainer
public sealed class MatrixCell : ReportComponentContainer, IRdlContainer, IReportComponent, IReportComponentContainer
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer
GrapeCity.ActiveReports.PageReportModel.MatrixCell

See Also

Reference

MatrixCell Members
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixCell Class Members

MatrixCell Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixCell Class

The following tables list the members exposed by MatrixCell.

Public Constructors
 | Name | Description
Public Constructor | MatrixCell Constructor | Initializes a new instance of the MatrixCell class.
Top
Public Properties
 | Name | Description
Public Property | Components | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportComponentCollection containing all the ReportComponents in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportItems | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportItemCollection containing all the ReportItems in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the MatrixCell object.
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

MatrixCell Class
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixCell Constructor

MatrixCell Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixCell Class : MatrixCell Constructor

Initializes a new instance of the MatrixCell class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MatrixCell()
See Also

Reference

MatrixCell Class
MatrixCell Members


MatrixCell Class Methods

MatrixCell Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixCell Class

For a list of all members of this type, see MatrixCell members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the MatrixCell object.
Top
See Also

Reference

MatrixCell Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (MatrixCell)

Validate Method (MatrixCell)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixCell Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the MatrixCell object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

MatrixCell Class
MatrixCell Members


MatrixCellCollection Class

MatrixCellCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixCellCollection Class
Provides a strongly typed collection for MatrixCell objects.
Object Model
MatrixCellCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MatrixCellCollection
   Inherits System.Collections.CollectionBase
public sealed class MatrixCellCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MatrixCellCollection

See Also

Reference

MatrixCellCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixCellCollection Class Members

MatrixCellCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixCellCollection Class

The following tables list the members exposed by MatrixCellCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.` (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific MatrixCell object in the MatrixCellCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a MatrixCell object to the MatrixCellCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific MatrixCell object in the MatrixCellCollection.
Public Method | Insert | Inserts a new MatrixCell object into the MatrixCellCollection at the specified location.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

MatrixCellCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixCellCollection Class Methods

MatrixCellCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixCellCollection Class

For a list of all members of this type, see MatrixCellCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a MatrixCell object to the MatrixCellCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific MatrixCell object in the MatrixCellCollection.
Public Method | Insert | Inserts a new MatrixCell object into the MatrixCellCollection at the specified location.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

MatrixCellCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (MatrixCellCollection)

Add Method (MatrixCellCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixCellCollection Class : Add Method
The MatrixCell object to add to the collection.
Adds a MatrixCell object to the MatrixCellCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As MatrixCell _
) As System.Integer
public System.int Add(
   MatrixCell value
)

Parameters

value
The MatrixCell object to add to the collection.

Return Value

A new MatrixCell object.
See Also

Reference

MatrixCellCollection Class
MatrixCellCollection Members


IndexOf Method (MatrixCellCollection)

IndexOf Method (MatrixCellCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixCellCollection Class : IndexOf Method
The MatrixCell object to locate in the MatrixCellCollection.
Determines the index of a specific MatrixCell object in the MatrixCellCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As MatrixCell _
) As System.Integer
public System.int IndexOf(
   MatrixCell value
)

Parameters

value
The MatrixCell object to locate in the MatrixCellCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

MatrixCellCollection Class
MatrixCellCollection Members


Insert Method (MatrixCellCollection)

Insert Method (MatrixCellCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixCellCollection Class : Insert Method
A zero-based Integer index indicating the position at which to insert the MatrixCell object.
The MatrixCell object to insert.
Inserts a new MatrixCell object into the MatrixCellCollection at the specified location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As MatrixCell _
)
public void Insert(
   System.int index,
   MatrixCell value
)

Parameters

index
A zero-based Integer index indicating the position at which to insert the MatrixCell object.
value
The MatrixCell object to insert.
See Also

Reference

MatrixCellCollection Class
MatrixCellCollection Members


MatrixCellCollection Class Properties

MatrixCellCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixCellCollection Class

For a list of all members of this type, see MatrixCellCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.` (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific MatrixCell object in the MatrixCellCollection by position.
Top
See Also

Reference

MatrixCellCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (MatrixCellCollection)

Item Property (MatrixCellCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixCellCollection Class : Item Property
A zero-based Integer indicating the index of the MatrixCell object to return or set.
Gets or sets a specific MatrixCell object in the MatrixCellCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As MatrixCell
public MatrixCell this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the MatrixCell object to return or set.

Property Value

The MatrixCell object at the specified position.
See Also

Reference

MatrixCellCollection Class
MatrixCellCollection Members


MatrixColumn Class

MatrixColumn Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixColumn Class
Defines a column in the detail section of a Matrix.
Object Model
MatrixColumn Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MatrixColumn
public sealed class MatrixColumn
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MatrixColumn

See Also

Reference

MatrixColumn Members
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixColumn Class Members

MatrixColumn Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixColumn Class

The following tables list the members exposed by MatrixColumn.

Public Constructors
 | Name | Description
Public Constructor | MatrixColumn Constructor | Initializes a new instance of the MatrixColumn class.
Top
Public Properties
 | Name | Description
Public Property | Width | Gets or sets the width of each detail cell in the column.
Top
See Also

Reference

MatrixColumn Class
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixColumn Constructor

MatrixColumn Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixColumn Class : MatrixColumn Constructor
Initializes a new instance of the MatrixColumn class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MatrixColumn()
See Also

Reference

MatrixColumn Class
MatrixColumn Members


MatrixColumn Class Properties

MatrixColumn Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixColumn Class

For a list of all members of this type, see MatrixColumn members.

Public Properties
 | Name | Description
Public Property | Width | Gets or sets the width of each detail cell in the column.
Top
See Also

Reference

MatrixColumn Class
GrapeCity.ActiveReports.PageReportModel Namespace


Width Property (MatrixColumn)

Width Property (MatrixColumn)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixColumn Class : Width Property

Gets or sets the width of each detail cell in the column.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As Length
public Length Width {get; set;}

Property Value

A Length structure indicating the width of each detail cell in the column.
See Also

Reference

MatrixColumn Class
MatrixColumn Members


MatrixColumnCollection Class

MatrixColumnCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixColumnCollection Class
Provides a strongly typed collection for MatrixColumn objects.
Object Model
MatrixColumnCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MatrixColumnCollection
   Inherits System.Collections.ObjectModel.Collection(Of MatrixColumn)
public sealed class MatrixColumnCollection : System.Collections.ObjectModel.Collection<MatrixColumn>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.MatrixColumnCollection

See Also

Reference

MatrixColumnCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixColumnCollection Class Members

MatrixColumnCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixColumnCollection Class

The following tables list the members exposed by MatrixColumnCollection.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.` (Inherited from System.Collections.ObjectModel.Collection<MatrixColumn>)
Public Property | Item | Gets or sets a specific MatrixColumn object in the MatrixColumnCollection by position. (Inherited from System.Collections.ObjectModel.Collection<MatrixColumn>)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a MatrixColumn object to the MatrixColumnCollection. (Inherited from System.Collections.ObjectModel.Collection<MatrixColumn>)
Public Method | AddRange | Adds a MatrixColumnCollection to the existing MatrixColumnCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.ObjectModel.Collection<MatrixColumn>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<MatrixColumn>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<MatrixColumn>)
Public Method | IndexOf | Determines the index of a specific MatrixColumn object in the MatrixColumnCollection. (Inherited from System.Collections.ObjectModel.Collection<MatrixColumn>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<MatrixColumn>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<MatrixColumn>)
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.ObjectModel.Collection<MatrixColumn>)
Top
See Also

Reference

MatrixColumnCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixColumnCollection Class Methods

MatrixColumnCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixColumnCollection Class

For a list of all members of this type, see MatrixColumnCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a MatrixColumn object to the MatrixColumnCollection. (Inherited from System.Collections.ObjectModel.Collection<MatrixColumn>)
Public Method | AddRange | Adds a MatrixColumnCollection to the existing MatrixColumnCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.ObjectModel.Collection<MatrixColumn>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<MatrixColumn>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<MatrixColumn>)
Public Method | IndexOf | Determines the index of a specific MatrixColumn object in the MatrixColumnCollection. (Inherited from System.Collections.ObjectModel.Collection<MatrixColumn>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<MatrixColumn>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<MatrixColumn>)
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.ObjectModel.Collection<MatrixColumn>)
Top
See Also

Reference

MatrixColumnCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


AddRange Method (MatrixColumnCollection)

AddRange Method (MatrixColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixColumnCollection Class : AddRange Method
The MatrixColumnCollection to add to the current collection.
Adds a MatrixColumnCollection to the existing MatrixColumnCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddRange( _
   ByVal collection As System.Collections.Generic.IEnumerable(Of MatrixColumn) _
)
public void AddRange(
   System.Collections.Generic.IEnumerable<MatrixColumn> collection
)

Parameters

collection
The MatrixColumnCollection to add to the current collection.
See Also

Reference

MatrixColumnCollection Class
MatrixColumnCollection Members


MatrixRow Class

MatrixRow Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixRow Class
Defines the set of cells in a row of the detail section of a Matrix.
Object Model
MatrixRow Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MatrixRow
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer
public sealed class MatrixRow : ReportComponent, IReportComponent, IReportComponentContainer
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.MatrixRow

See Also

Reference

MatrixRow Members
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixRow Class Members

MatrixRow Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixRow Class

The following tables list the members exposed by MatrixRow.

Public Constructors
 | Name | Description
Public Constructor | MatrixRow Constructor | Initializes a new instance of the MatrixRow class.
Top
Public Properties
 | Name | Description
Public Property | Components | Gets the ReportComponentCollection containing all the components hosted in the control.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Height | Gets or sets the height of each detail cell in the row.
Public Property | MatrixCells | Gets the set of cells in a row in the detail section of the Matrix.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the MatrixRow object.
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

MatrixRow Class
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixRow Constructor

MatrixRow Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRow Class : MatrixRow Constructor
Initializes a new instance of the MatrixRow class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MatrixRow()
See Also

Reference

MatrixRow Class
MatrixRow Members


MatrixRow Class Methods

MatrixRow Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixRow Class

For a list of all members of this type, see MatrixRow members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the MatrixRow object.
Top
See Also

Reference

MatrixRow Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (MatrixRow)

Validate Method (MatrixRow)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRow Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the MatrixRow object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

MatrixRow Class
MatrixRow Members


MatrixRow Class Properties

MatrixRow Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixRow Class

For a list of all members of this type, see MatrixRow members.

Public Properties
 | Name | Description
Public Property | Components | Gets the ReportComponentCollection containing all the components hosted in the control.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Height | Gets or sets the height of each detail cell in the row.
Public Property | MatrixCells | Gets the set of cells in a row in the detail section of the Matrix.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

MatrixRow Class
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property (MatrixRow)

Components Property (MatrixRow)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRow Class : Components Property
Gets the ReportComponentCollection containing all the components hosted in the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Components As ReportComponentCollection
public ReportComponentCollection Components {get;}

Property Value

A read-only DataDynamics.Reports.ReportObjectModel.Rdl.ReportComponentCollection containing all the components hosted in the control.
See Also

Reference

MatrixRow Class
MatrixRow Members


Height Property (MatrixRow)

Height Property (MatrixRow)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRow Class : Height Property

Gets or sets the height of each detail cell in the row.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As Length
public Length Height {get; set;}

Property Value

A Length structure indicating the width of each detail cell in the row.
See Also

Reference

MatrixRow Class
MatrixRow Members


MatrixCells Property

MatrixCells Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRow Class : MatrixCells Property

Gets the set of cells in a row in the detail section of the Matrix.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MatrixCells As MatrixCellCollection
public MatrixCellCollection MatrixCells {get;}

Property Value

A MatrixCellCollection containing the set of cells in a row in the detail section of the Matrix.
See Also

Reference

MatrixRow Class
MatrixRow Members


MatrixRowCollection Class

MatrixRowCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixRowCollection Class
Provides a strongly typed collection for MatrixRow objects.
Object Model
MatrixRowCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class MatrixRowCollection
   Inherits System.Collections.CollectionBase
public sealed class MatrixRowCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.MatrixRowCollection

See Also

Reference

MatrixRowCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixRowCollection Class Members

MatrixRowCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixRowCollection Class

The following tables list the members exposed by MatrixRowCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific MatrixRow object in the MatrixRowCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a MatrixRow object to the MatrixRowCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific MatrixRow object in the MatrixRowCollection.
Public Method | Insert | Inserts a new MatrixRow object into the MatrixRowCollection at the specified location.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

MatrixRowCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixRowCollection Class Methods

MatrixRowCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixRowCollection Class

For a list of all members of this type, see MatrixRowCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a MatrixRow object to the MatrixRowCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific MatrixRow object in the MatrixRowCollection.
Public Method | Insert | Inserts a new MatrixRow object into the MatrixRowCollection at the specified location.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

MatrixRowCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (MatrixRowCollection)

Add Method (MatrixRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRowCollection Class : Add Method

The MatrixRow object to add to the collection.

Adds a MatrixRow object to the MatrixRowCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As MatrixRow _
) As System.Integer
public System.int Add(
   MatrixRow value
)

Parameters

value

The MatrixRow object to add to the collection.

Return Value

A new MatrixRow object.
See Also

Reference

MatrixRowCollection Class
MatrixRowCollection Members


IndexOf Method (MatrixRowCollection)

IndexOf Method (MatrixRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRowCollection Class : IndexOf Method

The MatrixRow object to locate in the MatrixRowCollection.

Determines the index of a specific MatrixRow object in the MatrixRowCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As MatrixRow _
) As System.Integer
public System.int IndexOf(
   MatrixRow value
)

Parameters

value

The MatrixRow object to locate in the MatrixRowCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

MatrixRowCollection Class
MatrixRowCollection Members


Insert Method (MatrixRowCollection)

Insert Method (MatrixRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRowCollection Class : Insert Method
A zero-based Integer index indicating the position at which to insert the MatrixRow object.
The MatrixRow object to insert.
Inserts a new MatrixRow object into the MatrixRowCollection at the specified location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As MatrixRow _
)
public void Insert(
   System.int index,
   MatrixRow value
)

Parameters

index
A zero-based Integer index indicating the position at which to insert the MatrixRow object.
value
The MatrixRow object to insert.
See Also

Reference

MatrixRowCollection Class
MatrixRowCollection Members


MatrixRowCollection Class Properties

MatrixRowCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixRowCollection Class

For a list of all members of this type, see MatrixRowCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific MatrixRow object in the MatrixRowCollection by position.
Top
See Also

Reference

MatrixRowCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (MatrixRowCollection)

Item Property (MatrixRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRowCollection Class : Item Property
A zero-based Integer indicating the index of the MatrixRow to return or set.
Gets or sets a specific MatrixRow object in the MatrixRowCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As MatrixRow
public MatrixRow this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the MatrixRow to return or set.

Property Value

The MatrixRow object at the specified position.
See Also

Reference

MatrixRowCollection Class
MatrixRowCollection Members


NameValidator Class

NameValidator Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : NameValidator Class
Defines a NameValidator to check names contained in a report.
Object Model
NameValidator Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class NameValidator
public sealed class NameValidator
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.NameValidator

See Also

Reference

NameValidator Members
GrapeCity.ActiveReports.PageReportModel Namespace


NameValidator Class Members

NameValidator Class Members
Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : NameValidator Class

The following tables list the members exposed by NameValidator.

Public Methods
 | Name | Description
Public Method | ValidateName | Checks report item names to ensure that they are unique and that they are not empty or null and do not contain invalid characters.
Top
See Also

Reference

NameValidator Class
GrapeCity.ActiveReports.PageReportModel Namespace


NameValidator Class Methods

NameValidator Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : NameValidator Class

For a list of all members of this type, see NameValidator members.

Public Methods
 | Name | Description
Public Method | ValidateName | Checks report item names to ensure that they are unique and that they are not empty or null and do not contain invalid characters.
Top
See Also

Reference

NameValidator Class
GrapeCity.ActiveReports.PageReportModel Namespace


ValidateName Method

ValidateName Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > NameValidator Class : ValidateName Method
A string value representing the name to validate.
A NameType enumeration indicating whether the name is for a control, dataset, dataregion or grouping object.
Checks report item names to ensure that they are unique and that they are not empty or null and do not contain invalid characters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ValidateName( _
   ByVal name As System.String, _
   ByVal nameType As NameType _
) As System.Boolean
public System.bool ValidateName(
   System.string name,
   NameType nameType
)

Parameters

name
A string value representing the name to validate.
nameType
A NameType enumeration indicating whether the name is for a control, dataset, dataregion or grouping object.

Return Value

Returns true if the name is valid; otherwise false.
See Also

Reference

NameValidator Class
NameValidator Members


OverflowPlaceHolder Class

OverflowPlaceHolder Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : OverflowPlaceHolder Class
Represents the page report overflow place holder.
Object Model
OverflowPlaceHolder Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class OverflowPlaceHolder
   Inherits ReportItem
   Implements IReportComponent
public sealed class OverflowPlaceHolder : ReportItem, IReportComponent
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.OverflowPlaceHolder

See Also

Reference

OverflowPlaceHolder Members
GrapeCity.ActiveReports.PageReportModel Namespace


OverflowPlaceHolder Class Members

OverflowPlaceHolder Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : OverflowPlaceHolder Class

The following tables list the members exposed by OverflowPlaceHolder.

Public Constructors
 | Name | Description
Public Constructor | OverflowPlaceHolder Constructor | Initializes a new instance of the OverflowPlaceHolder class.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | OverflowName | Represents the overflow name.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Overridden. Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.DataRegion object.
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

OverflowPlaceHolder Class
GrapeCity.ActiveReports.PageReportModel Namespace


OverflowPlaceHolder Constructor

OverflowPlaceHolder Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > OverflowPlaceHolder Class : OverflowPlaceHolder Constructor
Initializes a new instance of the OverflowPlaceHolder class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public OverflowPlaceHolder()
See Also

Reference

OverflowPlaceHolder Class
OverflowPlaceHolder Members


OverflowPlaceHolder Class Methods

OverflowPlaceHolder Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : OverflowPlaceHolder Class

For a list of all members of this type, see OverflowPlaceHolder members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Overridden. Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.DataRegion object.
Top
See Also

Reference

OverflowPlaceHolder Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (OverflowPlaceHolder)

Validate Method (OverflowPlaceHolder)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > OverflowPlaceHolder Class : Validate Method
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.DataRegion object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A DataDynamics.Reports.ReportObjectModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

OverflowPlaceHolder Class
OverflowPlaceHolder Members


OverflowPlaceHolder Class Properties

OverflowPlaceHolder Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : OverflowPlaceHolder Class

For a list of all members of this type, see OverflowPlaceHolder members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | OverflowName | Represents the overflow name.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
See Also

Reference

OverflowPlaceHolder Class
GrapeCity.ActiveReports.PageReportModel Namespace


OverflowName Property (OverflowPlaceHolder)

OverflowName Property (OverflowPlaceHolder)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > OverflowPlaceHolder Class : OverflowName Property
Represents the overflow name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OverflowName As System.String
public System.string OverflowName {get; set;}
See Also

Reference

OverflowPlaceHolder Class
OverflowPlaceHolder Members


Page Class

Page Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Page Class
Represents the Page report page.
Object Model
Page Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Page
   Inherits ReportComponentContainer
   Implements IRdlContainer, IReportComponent, IReportComponentContainer
public sealed class Page : ReportComponentContainer, IRdlContainer, IReportComponent, IReportComponentContainer
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer
GrapeCity.ActiveReports.PageReportModel.Page

See Also

Reference

Page Members
GrapeCity.ActiveReports.PageReportModel Namespace


Page Class Members

Page Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Page Class

The following tables list the members exposed by Page.

Public Constructors
 | Name | Description
Public Constructor | Page Constructor | Initializes a new instance of the Page class.
Top
Public Properties
 | Name | Description
Public Property | Components | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportComponentCollection containing all the ReportComponents in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportItems | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportItemCollection containing all the ReportItems in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Site | Gets information about the container that hosts the current control when rendered on a design surface.
Public Property | Style | Gets or sets the style information for the page.
Public Property | ThrowIfPlaceHoldersEmpty |
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Page Class
GrapeCity.ActiveReports.PageReportModel Namespace


Page Constructor

Page Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : Page Constructor
Initializes a new instance of the Page class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Page()
See Also

Reference

Page Class
Page Members


Page Class Properties

Page Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Page Class

For a list of all members of this type, see Page members.

Public Properties
 | Name | Description
Public Property | Components | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportComponentCollection containing all the ReportComponents in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportItems | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportItemCollection containing all the ReportItems in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Site | Gets information about the container that hosts the current control when rendered on a design surface.
Public Property | Style | Gets or sets the style information for the page.
Public Property | ThrowIfPlaceHoldersEmpty |
Top
See Also

Reference

Page Class
GrapeCity.ActiveReports.PageReportModel Namespace


Site Property (Page)

Site Property (Page)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : Site Property
Gets information about the container that hosts the current control when rendered on a design surface.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Property Site As System.ComponentModel.ISite
public new System.ComponentModel.ISite Site {get; set;}

Property Value

The site.
See Also

Reference

Page Class
Page Members


Style Property (Page)

Style Property (Page)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : Style Property
Gets or sets the style information for the page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As Style
public Style Style {get; set;}
See Also

Reference

Page Class
Page Members


ThrowIfPlaceHoldersEmpty Property

ThrowIfPlaceHoldersEmpty Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : ThrowIfPlaceHoldersEmpty Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ThrowIfPlaceHoldersEmpty As System.Boolean
public System.bool ThrowIfPlaceHoldersEmpty {get; set;}
See Also

Reference

Page Class
Page Members


PageBreak Class

PageBreak Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageBreak Class
Defines page breaking options.
Object Model
PageBreak Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class PageBreak
public class PageBreak
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.PageBreak

See Also

Reference

PageBreak Members
GrapeCity.ActiveReports.PageReportModel Namespace


PageBreak Class Members

PageBreak Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageBreak Class

The following tables list the members exposed by PageBreak.

Public Constructors
 | Name | Description
Public Constructor | PageBreak Constructor |
Top
Public Properties
 | Name | Description
Public Property | BreakLocation | Specifies break location.
Public Property | Disabled | Specifies whether page break is disabled.
Public Property | ResetPageNumber | Specifies page number reset value.
Top
See Also

Reference

PageBreak Class
GrapeCity.ActiveReports.PageReportModel Namespace


PageBreak Constructor

PageBreak Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageBreak Class : PageBreak Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public PageBreak()
See Also

Reference

PageBreak Class
PageBreak Members


PageBreak Class Properties

PageBreak Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageBreak Class

For a list of all members of this type, see PageBreak members.

Public Properties
 | Name | Description
Public Property | BreakLocation | Specifies break location.
Public Property | Disabled | Specifies whether page break is disabled.
Public Property | ResetPageNumber | Specifies page number reset value.
Top
See Also

Reference

PageBreak Class
GrapeCity.ActiveReports.PageReportModel Namespace


BreakLocation Property

BreakLocation Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageBreak Class : BreakLocation Property
Specifies break location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BreakLocation As BreakLocation
public BreakLocation BreakLocation {get; set;}
See Also

Reference

PageBreak Class
PageBreak Members


Disabled Property

Disabled Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageBreak Class : Disabled Property
Specifies whether page break is disabled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Disabled As ExpressionInfo
public ExpressionInfo Disabled {get; set;}
See Also

Reference

PageBreak Class
PageBreak Members


ResetPageNumber Property

ResetPageNumber Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageBreak Class : ResetPageNumber Property
Specifies page number reset value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ResetPageNumber As ExpressionInfo
public ExpressionInfo ResetPageNumber {get; set;}
See Also

Reference

PageBreak Class
PageBreak Members


PageCollection Class

PageCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageCollection Class
Provides a strongly typed collection for Page object.
Object Model
PageCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class PageCollection
public sealed class PageCollection
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.PageCollection

See Also

Reference

PageCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


PageCollection Class Members

PageCollection Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageCollection Class

The following tables list the members exposed by PageCollection.

Public Constructors
 | Name | Description
Public Constructor | PageCollection Constructor | Initializes a new instance of the PageCollection class.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the number of Page object in the PageCollection.
Public Property | IsReadOnly | Gets a Boolean value indicating whether the PageCollection is read-only.
Public Property | Item | Gets or sets a specific Page object in the PageCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a Page object to PageCollection.
Public Method | Clear | Removes all items from the PageCollection.
Public Method | Contains | Determines whether the collection contains the specified page.
Public Method | CopyTo | Copies an array of Page objects to PagesCollection.
Public Method | IndexOf | Determines the index of a specific Page object in the PageCollection.
Public Method | Insert | Inserts a new Page into the PageCollection at the specified location.
Public Method | Remove | Removes the specified Page object from the PageCollection.
Public Method | RemoveAt | Removes the specified Page object from the PageCollection at the specified index.
Public Method | ToArray | Copies the elements of the PageCollection to a new array.
Top
Public Events
 | Name | Description
Public Event | ItemAdded | Occurs immediately after adding an item to the collection.
Top
See Also

Reference

PageCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


PageCollection Constructor

PageCollection Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : PageCollection Constructor
Initializes a new instance of the PageCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public PageCollection()
See Also

Reference

PageCollection Class
PageCollection Members


PageCollection Class Methods

PageCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageCollection Class

For a list of all members of this type, see PageCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a Page object to PageCollection.
Public Method | Clear | Removes all items from the PageCollection.
Public Method | Contains | Determines whether the collection contains the specified page.
Public Method | CopyTo | Copies an array of Page objects to PagesCollection.
Public Method | IndexOf | Determines the index of a specific Page object in the PageCollection.
Public Method | Insert | Inserts a new Page into the PageCollection at the specified location.
Public Method | Remove | Removes the specified Page object from the PageCollection.
Public Method | RemoveAt | Removes the specified Page object from the PageCollection at the specified index.
Public Method | ToArray | Copies the elements of the PageCollection to a new array.
Top
See Also

Reference

PageCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (PageCollection)

Add Method (PageCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : Add Method
The Page object to add.
Adds a Page object to PageCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Add( _
   ByVal value As Page _
)
public void Add(
   Page value
)

Parameters

value
The Page object to add.

Return Value

A new Page object.
See Also

Reference

PageCollection Class
PageCollection Members


Clear Method (PageCollection)

Clear Method (PageCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : Clear Method
Removes all items from the PageCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

PageCollection Class
PageCollection Members


Contains Method (PageCollection)

Contains Method (PageCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : Contains Method
The page to locate.
Determines whether the collection contains the specified page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal item As Page _
) As System.Boolean
public System.bool Contains(
   Page item
)

Parameters

item
The page to locate.

Return Value

true if item is found in the System.Collections.Generic.ICollection`1; otherwise, false.
See Also

Reference

PageCollection Class
PageCollection Members


CopyTo Method (PageCollection)

CopyTo Method (PageCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : CopyTo Method

The one-dimensional Array that is the destination of the elements copied from PageCollection. The Array must have zero-based indexing.

The zero-based index in array at which copying begins.
Copies an array of Page objects to PagesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal array() As Page, _
   ByVal arrayIndex As System.Integer _
)
public void CopyTo(
   Page[] array,
   System.int arrayIndex
)

Parameters

array

The one-dimensional Array that is the destination of the elements copied from PageCollection. The Array must have zero-based indexing.

arrayIndex
The zero-based index in array at which copying begins.
See Also

Reference

PageCollection Class
PageCollection Members


IndexOf Method (PageCollection)

IndexOf Method (PageCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : IndexOf Method
The page to locate in the page collection.
Determines the index of a specific Page object in the PageCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal item As Page _
) As System.Integer
public System.int IndexOf(
   Page item
)

Parameters

item
The page to locate in the page collection.

Return Value

The index of item if found in the list; otherwise, -1.
See Also

Reference

PageCollection Class
PageCollection Members


Insert Method (PageCollection)

Insert Method (PageCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : Insert Method
A zero-based Integer index indicating the position at which to insert the Page object.
The Page object to insert.
Inserts a new Page into the PageCollection at the specified location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As Page _
)
public void Insert(
   System.int index,
   Page value
)

Parameters

index
A zero-based Integer index indicating the position at which to insert the Page object.
value
The Page object to insert.
See Also

Reference

PageCollection Class
PageCollection Members


Remove Method (PageCollection)

Remove Method (PageCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : Remove Method
The Page object to remove.
Removes the specified Page object from the PageCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Remove( _
   ByVal value As Page _
) As System.Boolean
public System.bool Remove(
   Page value
)

Parameters

value
The Page object to remove.
See Also

Reference

PageCollection Class
PageCollection Members


RemoveAt Method (PageCollection)

RemoveAt Method (PageCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : RemoveAt Method
An Integer indicating the index at which to remove the Page object.
Removes the specified Page object from the PageCollection at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
An Integer indicating the index at which to remove the Page object.
See Also

Reference

PageCollection Class
PageCollection Members


ToArray Method (PageCollection)

ToArray Method (PageCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : ToArray Method
Copies the elements of the PageCollection to a new array.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToArray() As Page()
public Page[] ToArray()

Return Value

An array of Page objects containing copies of the elements in the PageCollection.
See Also

Reference

PageCollection Class
PageCollection Members


PageCollection Class Properties

PageCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageCollection Class

For a list of all members of this type, see PageCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of Page object in the PageCollection.
Public Property | IsReadOnly | Gets a Boolean value indicating whether the PageCollection is read-only.
Public Property | Item | Gets or sets a specific Page object in the PageCollection by position.
Top
See Also

Reference

PageCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Count Property (PageCollection)

Count Property (PageCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : Count Property
Gets the number of Page object in the PageCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}

Property Value

An Integer indicating the number of Page objects.
See Also

Reference

PageCollection Class
PageCollection Members


IsReadOnly Property (PageCollection)

IsReadOnly Property (PageCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : IsReadOnly Property
Gets a Boolean value indicating whether the PageCollection is read-only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsReadOnly As System.Boolean
public System.bool IsReadOnly {get;}

Property Value

Returns true if the PageCollection is read-only; otherwise, false.
See Also

Reference

PageCollection Class
PageCollection Members


Item Property (PageCollection)

Item Property (PageCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : Item Property
A zero-based Integer index of the Page to return or set.
Gets or sets a specific Page object in the PageCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As Page
public Page this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer index of the Page to return or set.

Property Value

The Page object at the specified position.
See Also

Reference

PageCollection Class
PageCollection Members


PageCollection Class Events

PageCollection Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageCollection Class

For a list of all members of this type, see PageCollection members.

Public Events
 | Name | Description
Public Event | ItemAdded | Occurs immediately after adding an item to the collection.
Top
See Also

Reference

PageCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ItemAdded Event (PageCollection)

ItemAdded Event (PageCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollection Class : ItemAdded Event
Occurs immediately after adding an item to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ItemAdded As PageCollectionEventHandler
public event PageCollectionEventHandler ItemAdded
Event Data

The event handler receives an argument of type PageCollectionEventArgs containing data related to this event. The following PageCollectionEventArgs properties provide information specific to this event.

Property | Description
Value | Returns the Page object that was added or removed.
See Also

Reference

PageCollection Class
PageCollection Members


PageCollectionEventArgs Class

PageCollectionEventArgs Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageCollectionEventArgs Class
Provides data for the ItemAdded or ItemRemoved event of the PageCollection.
Object Model
PageCollectionEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class PageCollectionEventArgs
   Inherits System.EventArgs
public sealed class PageCollectionEventArgs : System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.PageReportModel.PageCollectionEventArgs

See Also

Reference

PageCollectionEventArgs Members
GrapeCity.ActiveReports.PageReportModel Namespace


PageCollectionEventArgs Class Members

PageCollectionEventArgs Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageCollectionEventArgs Class

The following tables list the members exposed by PageCollectionEventArgs.

Public Constructors
 | Name | Description
Public Constructor | PageCollectionEventArgs Constructor | Initializes a new instance of the PageCollection class.
Top
Public Properties
 | Name | Description
Public Property | Value | Returns the Page object that was added or removed.
Top
See Also

Reference

PageCollectionEventArgs Class
GrapeCity.ActiveReports.PageReportModel Namespace


PageCollectionEventArgs Constructor

PageCollectionEventArgs Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollectionEventArgs Class : PageCollectionEventArgs Constructor
The Page object that was added or removed.
Initializes a new instance of the PageCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal value As Page _
)
public PageCollectionEventArgs(
   Page value
)

Parameters

value
The Page object that was added or removed.
See Also

Reference

PageCollectionEventArgs Class
PageCollectionEventArgs Members


PageCollectionEventArgs Class Properties

PageCollectionEventArgs Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageCollectionEventArgs Class

For a list of all members of this type, see PageCollectionEventArgs members.

Public Properties
 | Name | Description
Public Property | Value | Returns the Page object that was added or removed.
Top
See Also

Reference

PageCollectionEventArgs Class
GrapeCity.ActiveReports.PageReportModel Namespace


Value Property (PageCollectionEventArgs)

Value Property (PageCollectionEventArgs)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageCollectionEventArgs Class : Value Property
Returns the Page object that was added or removed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Value As Page
public Page Value {get;}

Property Value

A Page object representing the item that was added or removed.
See Also

Reference

PageCollectionEventArgs Class
PageCollectionEventArgs Members


PageHeaderFooter Class

PageHeaderFooter Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageHeaderFooter Class
Specifies the layout definition for each ReportItem at the top of each page (PageHeader) or the bottom of each page (PageFooter).
Object Model
PageHeaderFooter Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class PageHeaderFooter
   Inherits ReportComponentContainer
   Implements IRdlContainer, IReportComponent, IReportComponentContainer
public sealed class PageHeaderFooter : ReportComponentContainer, IRdlContainer, IReportComponent, IReportComponentContainer
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer
GrapeCity.ActiveReports.PageReportModel.PageHeaderFooter

See Also

Reference

PageHeaderFooter Members
GrapeCity.ActiveReports.PageReportModel Namespace


PageHeaderFooter Class Members

PageHeaderFooter Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageHeaderFooter Class

The following tables list the members exposed by PageHeaderFooter.

Public Constructors
 | Name | Description
Public Constructor | PageHeaderFooter Constructor | Initializes a new instance of the PageHeaderFooter class.
Top
Public Properties
 | Name | Description
Public Property | Components | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportComponentCollection containing all the ReportComponents in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Height | Gets or sets the height of the page header or footer.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | PrintOnFirstPage | Gets or sets a value indicating whether the page header or footer is rendered on the first page.
Public Property | PrintOnLastPage | Gets or sets a value indicating whether the page header or footer is rendered on the last page.
Public Property | ReportItems | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportItemCollection containing all the ReportItems in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the style information for the page header or footer.
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the PageHeaderFooter object.
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

PageHeaderFooter Class
GrapeCity.ActiveReports.PageReportModel Namespace


PageHeaderFooter Constructor

PageHeaderFooter Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageHeaderFooter Class : PageHeaderFooter Constructor

Initializes a new instance of the PageHeaderFooter class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public PageHeaderFooter()
See Also

Reference

PageHeaderFooter Class
PageHeaderFooter Members


PageHeaderFooter Class Methods

PageHeaderFooter Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageHeaderFooter Class

For a list of all members of this type, see PageHeaderFooter members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the PageHeaderFooter object.
Top
See Also

Reference

PageHeaderFooter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (PageHeaderFooter)

Validate Method (PageHeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageHeaderFooter Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the PageHeaderFooter object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

PageHeaderFooter Class
PageHeaderFooter Members


PageHeaderFooter Class Properties

PageHeaderFooter Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageHeaderFooter Class

For a list of all members of this type, see PageHeaderFooter members.

Public Properties
 | Name | Description
Public Property | Components | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportComponentCollection containing all the ReportComponents in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Height | Gets or sets the height of the page header or footer.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | PrintOnFirstPage | Gets or sets a value indicating whether the page header or footer is rendered on the first page.
Public Property | PrintOnLastPage | Gets or sets a value indicating whether the page header or footer is rendered on the last page.
Public Property | ReportItems | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportItemCollection containing all the ReportItems in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the style information for the page header or footer.
Top
See Also

Reference

PageHeaderFooter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Height Property (PageHeaderFooter)

Height Property (PageHeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageHeaderFooter Class : Height Property

Gets or sets the height of the page header or footer.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As Length
public Length Height {get; set;}

Property Value

A Length structure indicating the height of the page header or footer.

See Also

Reference

PageHeaderFooter Class
PageHeaderFooter Members


PrintOnFirstPage Property (PageHeaderFooter)

PrintOnFirstPage Property (PageHeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageHeaderFooter Class : PrintOnFirstPage Property

Gets or sets a value indicating whether the page header or footer is rendered on the first page.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrintOnFirstPage As System.Boolean
public System.bool PrintOnFirstPage {get; set;}

Property Value

A Boolean value where true indicates that the page header or footer is rendered on the first page; otherwise false. The default value is false.

Remarks

This property is ignored in single page reports.

See Also

Reference

PageHeaderFooter Class
PageHeaderFooter Members


PrintOnLastPage Property (PageHeaderFooter)

PrintOnLastPage Property (PageHeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageHeaderFooter Class : PrintOnLastPage Property

Gets or sets a value indicating whether the page header or footer is rendered on the last page.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrintOnLastPage As System.Boolean
public System.bool PrintOnLastPage {get; set;}

Property Value

A Boolean value where true indicates that the page header or footer is rendered on the last page; otherwise false. The default value is false.

Remarks

This property is ignored in single page reports.

See Also

Reference

PageHeaderFooter Class
PageHeaderFooter Members


Style Property (PageHeaderFooter)

Style Property (PageHeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageHeaderFooter Class : Style Property

Gets or sets the style information for the page header or footer.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As Style
public Style Style {get; set;}

Property Value

A Style object containing the style information for the page header or footer.

Remarks

When applying style information, the page header and footer are considered the same as a Rectangle.

See Also

Reference

PageHeaderFooter Class
PageHeaderFooter Members


Parameter Class

Parameter Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Parameter Class
The Parameter element contains information about a subreport parameter.
Object Model
Parameter Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Parameter
public sealed class Parameter
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Parameter

See Also

Reference

Parameter Members
GrapeCity.ActiveReports.PageReportModel Namespace


Parameter Class Members

Parameter Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Parameter Class

The following tables list the members exposed by Parameter.

Public Constructors
 | Name | Description
Public Constructor | Parameter Constructor | Initializes a new instance of the Parameter class.
Top
Public Properties
 | Name | Description
Public Property | Name | Gets or sets the name of the parameter.
Public Property | Omit | Gets or sets a Boolean expression that indicates whether the parameter is skipped.
Public Property | Value | Gets or sets an expression that evaluates to the value to pass for the parameter to the subreport.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the Parameter object.
Top
See Also

Reference

Parameter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Parameter Constructor

Parameter Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Parameter Class : Parameter Constructor

Initializes a new instance of the Parameter class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Parameter()
See Also

Reference

Parameter Class
Parameter Members


Parameter Class Methods

Parameter Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Parameter Class

For a list of all members of this type, see Parameter members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the Parameter object.
Top
See Also

Reference

Parameter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (Parameter)

Validate Method (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Parameter Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the Parameter object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

Parameter Class
Parameter Members


Parameter Class Properties

Parameter Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Parameter Class

For a list of all members of this type, see Parameter members.

Public Properties
 | Name | Description
Public Property | Name | Gets or sets the name of the parameter.
Public Property | Omit | Gets or sets a Boolean expression that indicates whether the parameter is skipped.
Public Property | Value | Gets or sets an expression that evaluates to the value to pass for the parameter to the subreport.
Top
See Also

Reference

Parameter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Name Property (Parameter)

Name Property (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Parameter Class : Name Property

Gets or sets the name of the parameter.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}

Property Value

A String representing the name of the parameter.

See Also

Reference

Parameter Class
Parameter Members


Omit Property (Parameter)

Omit Property (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Parameter Class : Omit Property

Gets or sets a Boolean expression that indicates whether the parameter is skipped.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Omit As ExpressionInfo
public ExpressionInfo Omit {get; set;}

Property Value

An ExpressionInfo object that evaluates to a Boolean value to indicate whether the parameter is skipped.

See Also

Reference

Parameter Class
Parameter Members


Value Property (Parameter)

Value Property (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Parameter Class : Value Property

Gets or sets an expression that evaluates to the value to pass for the parameter to the subreport.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As ExpressionInfo
public ExpressionInfo Value {get; set;}

Property Value

An ExpressionInfo object that evaluates to the value to pass for the parameter to the subreport.
See Also

Reference

Parameter Class
Parameter Members


ParameterCollection Class

ParameterCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ParameterCollection Class
Provides a strongly typed collection for Parameter objects.
Object Model
ParameterCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ParameterCollection
   Inherits System.Collections.CollectionBase
public sealed class ParameterCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ParameterCollection

See Also

Reference

ParameterCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


ParameterCollection Class Members

ParameterCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ParameterCollection Class

The following tables list the members exposed by ParameterCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.` (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | True if this collection can not be modified.
Public Property | Item | Gets or sets a specific Parameter object in the ParameterCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a Parameter object to the ParameterCollection.
Public Method | AddRange | Adds a ParameterCollection to the existing ParameterCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Checks whether parameter is contained withing this collection.
Public Method | CopyTo | Copies contents of this collection to given array starting from specified index.
Public Method | IndexOf | Determines the index of a specific Parameter object in the ParameterCollection.
Public Method | Insert | Inserts a Parameter object to the ParameterCollection.
Public Method | Remove | Removes the parameter from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ParameterCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ParameterCollection Class Methods

ParameterCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ParameterCollection Class

For a list of all members of this type, see ParameterCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a Parameter object to the ParameterCollection.
Public Method | AddRange | Adds a ParameterCollection to the existing ParameterCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Checks whether parameter is contained withing this collection.
Public Method | CopyTo | Copies contents of this collection to given array starting from specified index.
Public Method | IndexOf | Determines the index of a specific Parameter object in the ParameterCollection.
Public Method | Insert | Inserts a Parameter object to the ParameterCollection.
Public Method | Remove | Removes the parameter from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ParameterCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (ParameterCollection)

Add Method (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterCollection Class : Add Method
The Parameter object to add to the collection.
Adds a Parameter object to the ParameterCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As Parameter _
) As System.Integer
public System.int Add(
   Parameter value
)

Parameters

value
The Parameter object to add to the collection.

Return Value

A new Parameter object.
See Also

Reference

ParameterCollection Class
ParameterCollection Members


AddRange Method (ParameterCollection)

AddRange Method (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterCollection Class : AddRange Method
The ParameterCollection to add to the current collection.
Adds a ParameterCollection to the existing ParameterCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddRange( _
   ByVal collection As ParameterCollection _
)
public void AddRange(
   ParameterCollection collection
)

Parameters

collection
The ParameterCollection to add to the current collection.
See Also

Reference

ParameterCollection Class
ParameterCollection Members


Contains Method (ParameterCollection)

Contains Method (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterCollection Class : Contains Method
The Parameter to locate in the ParameterCollection.
Checks whether parameter is contained withing this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal item As Parameter _
) As System.Boolean
public System.bool Contains(
   Parameter item
)

Parameters

item
The Parameter to locate in the ParameterCollection.

Return Value

true if item is found in the ParameterCollection; otherwise, false.
See Also

Reference

ParameterCollection Class
ParameterCollection Members


CopyTo Method (ParameterCollection)

CopyTo Method (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterCollection Class : CopyTo Method
The array to copy to.
The starting index in destination array.
Copies contents of this collection to given array starting from specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal array() As Parameter, _
   ByVal arrayIndex As System.Integer _
)
public void CopyTo(
   Parameter[] array,
   System.int arrayIndex
)

Parameters

array
The array to copy to.
arrayIndex
The starting index in destination array.
See Also

Reference

ParameterCollection Class
ParameterCollection Members


IndexOf Method (ParameterCollection)

IndexOf Method (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterCollection Class : IndexOf Method
The Parameter object to locate in the ParameterCollection.
Determines the index of a specific Parameter object in the ParameterCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As Parameter _
) As System.Integer
public System.int IndexOf(
   Parameter value
)

Parameters

value
The Parameter object to locate in the ParameterCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

ParameterCollection Class
ParameterCollection Members


Insert Method (ParameterCollection)

Insert Method (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterCollection Class : Insert Method
Inserts a Parameter object to the ParameterCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As Parameter _
)
public void Insert(
   System.int index,
   Parameter value
)

Parameters

index
value
See Also

Reference

ParameterCollection Class
ParameterCollection Members


Remove Method (ParameterCollection)

Remove Method (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterCollection Class : Remove Method
The parameter to remove.
Removes the parameter from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Remove( _
   ByVal item As Parameter _
) As System.Boolean
public System.bool Remove(
   Parameter item
)

Parameters

item
The parameter to remove.

Return Value

True if parameter was actually removed.
See Also

Reference

ParameterCollection Class
ParameterCollection Members


ParameterCollection Class Properties

ParameterCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ParameterCollection Class

For a list of all members of this type, see ParameterCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.` (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | True if this collection can not be modified.
Public Property | Item | Gets or sets a specific Parameter object in the ParameterCollection by position.
Top
See Also

Reference

ParameterCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


IsReadOnly Property (ParameterCollection)

IsReadOnly Property (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterCollection Class : IsReadOnly Property
True if this collection can not be modified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsReadOnly As System.Boolean
public System.bool IsReadOnly {get;}
See Also

Reference

ParameterCollection Class
ParameterCollection Members


Item Property (ParameterCollection)

Item Property (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterCollection Class : Item Property
A zero-based Integer indicating the index of the Parameter to return or set.
Gets or sets a specific Parameter object in the ParameterCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As Parameter
public Parameter this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the Parameter to return or set.

Property Value

The Parameter object at the specified position.
See Also

Reference

ParameterCollection Class
ParameterCollection Members


ParameterValue Class

ParameterValue Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ParameterValue Class
A possible value for the parameter.
Object Model
ParameterValue Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ParameterValue
public sealed class ParameterValue
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ParameterValue

See Also

Reference

ParameterValue Members
GrapeCity.ActiveReports.PageReportModel Namespace


ParameterValue Class Members

ParameterValue Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ParameterValue Class

The following tables list the members exposed by ParameterValue.

Public Constructors
 | Name | Description
Public Constructor | ParameterValue Constructor | Initializes a new instance of the ParameterValue class.
Top
Public Properties
 | Name | Description
Public Property | Label | Gets or sets the user-friendly label to display for the value in the UI.
Public Property | Value | Gets or sets a possible value for the parameter.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the ParameterValue object.
Top
See Also

Reference

ParameterValue Class
GrapeCity.ActiveReports.PageReportModel Namespace


ParameterValue Constructor

ParameterValue Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterValue Class : ParameterValue Constructor
Initializes a new instance of the ParameterValue class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ParameterValue()
See Also

Reference

ParameterValue Class
ParameterValue Members


ParameterValue Class Methods

ParameterValue Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ParameterValue Class

For a list of all members of this type, see ParameterValue members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the ParameterValue object.
Top
See Also

Reference

ParameterValue Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (ParameterValue)

Validate Method (ParameterValue)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterValue Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the ParameterValue object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

ParameterValue Class
ParameterValue Members


ParameterValue Class Properties

ParameterValue Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ParameterValue Class

For a list of all members of this type, see ParameterValue members.

Public Properties
 | Name | Description
Public Property | Label | Gets or sets the user-friendly label to display for the value in the UI.
Public Property | Value | Gets or sets a possible value for the parameter.
Top
See Also

Reference

ParameterValue Class
GrapeCity.ActiveReports.PageReportModel Namespace


Label Property (ParameterValue)

Label Property (ParameterValue)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterValue Class : Label Property

Gets or sets the user-friendly label to display for the value in the UI.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Label As ExpressionInfo
public ExpressionInfo Label {get; set;}

Property Value

An ExpressionInfo object representing a label to display for the value in the UI.

Remarks

If not supplied, the Value is used as the label. If a Value is not supplied, the Label is an empty string.

See Also

Reference

ParameterValue Class
ParameterValue Members


Value Property (ParameterValue)

Value Property (ParameterValue)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterValue Class : Value Property

Gets or sets a possible value for the parameter.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As ExpressionInfo
public ExpressionInfo Value {get; set;}

Property Value

An ExpressionInfo object representing a possible value for the parameter.

Remarks

For Boolean parameters, use "true" or "false."

For DateTime parameters, use ISO 8601 date time format: yyyy-mm-ddThh:mm:ss[.mmm]

For Float parameters, use "." as the optional decimal separator.

See Also

Reference

ParameterValue Class
ParameterValue Members


ParameterValueCollection Class

ParameterValueCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ParameterValueCollection Class
Provides a strongly typed collection for ParameterValue objects
Object Model
ParameterValueCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ParameterValueCollection
   Inherits System.Collections.CollectionBase
public sealed class ParameterValueCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ParameterValueCollection

See Also

Reference

ParameterValueCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


ParameterValueCollection Class Members

ParameterValueCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ParameterValueCollection Class

The following tables list the members exposed by ParameterValueCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific ParameterValue object in the ParameterValueCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a ParameterValue object to the ParameterValueCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific ParameterValue object in the ParameterValueCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ParameterValueCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ParameterValueCollection Class Methods

ParameterValueCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ParameterValueCollection Class

For a list of all members of this type, see ParameterValueCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a ParameterValue object to the ParameterValueCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific ParameterValue object in the ParameterValueCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ParameterValueCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (ParameterValueCollection)

Add Method (ParameterValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterValueCollection Class : Add Method
The ParameterValue object to add to the collection.
Adds a ParameterValue object to the ParameterValueCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As ParameterValue _
) As System.Integer
public System.int Add(
   ParameterValue value
)

Parameters

value
The ParameterValue object to add to the collection.

Return Value

A new ParameterValue object.
See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


IndexOf Method (ParameterValueCollection)

IndexOf Method (ParameterValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterValueCollection Class : IndexOf Method
The ParameterValue object to locate in the ParameterValueCollection.
Determines the index of a specific ParameterValue object in the ParameterValueCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As ParameterValue _
) As System.Integer
public System.int IndexOf(
   ParameterValue value
)

Parameters

value
The ParameterValue object to locate in the ParameterValueCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


ParameterValueCollection Class Properties

ParameterValueCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ParameterValueCollection Class

For a list of all members of this type, see ParameterValueCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific ParameterValue object in the ParameterValueCollection by position.
Top
See Also

Reference

ParameterValueCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (ParameterValueCollection)

Item Property (ParameterValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterValueCollection Class : Item Property
A zero-based Integer indicating the index of the ParameterValue to return or set.
Gets or sets a specific ParameterValue object in the ParameterValueCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As ParameterValue
public ParameterValue this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the ParameterValue to return or set.

Property Value

The ParameterValue object at the specified position.
See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


PlotArea Class

PlotArea Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PlotArea Class
The PlotArea element defines properties for the plot area (for chart types with X and Y axes).
Object Model
PlotArea Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class PlotArea
public sealed class PlotArea
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.PlotArea

See Also

Reference

PlotArea Members
GrapeCity.ActiveReports.PageReportModel Namespace


PlotArea Class Members

PlotArea Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PlotArea Class

The following tables list the members exposed by PlotArea.

Public Constructors
 | Name | Description
Public Constructor | PlotArea Constructor | Initializes a new instance of the PlotArea class.
Top
Public Properties
 | Name | Description
Public Property | Style | Gets or sets the border and background style properties for the plot area.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the PlotArea object.
Top
See Also

Reference

PlotArea Class
GrapeCity.ActiveReports.PageReportModel Namespace


PlotArea Constructor

PlotArea Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PlotArea Class : PlotArea Constructor
Initializes a new instance of the PlotArea class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public PlotArea()
See Also

Reference

PlotArea Class
PlotArea Members


PlotArea Class Methods

PlotArea Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PlotArea Class

For a list of all members of this type, see PlotArea members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the PlotArea object.
Top
See Also

Reference

PlotArea Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (PlotArea)

Validate Method (PlotArea)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PlotArea Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the PlotArea object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

PlotArea Class
PlotArea Members


PlotArea Class Properties

PlotArea Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PlotArea Class

For a list of all members of this type, see PlotArea members.

Public Properties
 | Name | Description
Public Property | Style | Gets or sets the border and background style properties for the plot area.
Top
See Also

Reference

PlotArea Class
GrapeCity.ActiveReports.PageReportModel Namespace


Style Property (PlotArea)

Style Property (PlotArea)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PlotArea Class : Style Property

Gets or sets the border and background style properties for the plot area.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As Style
public Style Style {get; set;}

Property Value

A Style object containing the border and background style properties for the plot area.

See Also

Reference

PlotArea Class
PlotArea Members


Property Class

Property Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Property Class
Summary description for Property.
Object Model
Property Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Property
public sealed class Property
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Property

See Also

Reference

Property Members
GrapeCity.ActiveReports.PageReportModel Namespace


Property Class Members

Property Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Property Class

The following tables list the members exposed by Property.

Public Constructors
 | Name | Description
Public Constructor | Property Constructor | Initializes a new instance of the Property class.
Top
Public Properties
 | Name | Description
Public Property | Name | A System.String containing the name to use for the property.
Public Property | Value | An ExpressionInfo object that evaluates to the value of the property.
Top
See Also

Reference

Property Class
GrapeCity.ActiveReports.PageReportModel Namespace


Property Constructor

Property Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Property Class : Property Constructor
A System.String containing the name to use for the property.
An ExpressionInfo object that evaluates the value of the property.
Initializes a new instance of the Property class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As System.String, _
   ByVal value As ExpressionInfo _
)
public Property(
   System.string name,
   ExpressionInfo value
)

Parameters

name
A System.String containing the name to use for the property.
value
An ExpressionInfo object that evaluates the value of the property.
See Also

Reference

Property Class
Property Members


Property Class Properties

Property Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Property Class

For a list of all members of this type, see Property members.

Public Properties
 | Name | Description
Public Property | Name | A System.String containing the name to use for the property.
Public Property | Value | An ExpressionInfo object that evaluates to the value of the property.
Top
See Also

Reference

Property Class
GrapeCity.ActiveReports.PageReportModel Namespace


Name Property (Property)

Name Property (Property)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Property Class : Name Property
A System.String containing the name to use for the property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}
See Also

Reference

Property Class
Property Members


Value Property (Property)

Value Property (Property)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Property Class : Value Property
An ExpressionInfo object that evaluates to the value of the property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As ExpressionInfo
public ExpressionInfo Value {get; set;}
See Also

Reference

Property Class
Property Members


PropertyCollection Class

PropertyCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PropertyCollection Class
Provides a strongly typed collection for Property objects.
Object Model
PropertyCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class PropertyCollection
   Inherits System.Collections.CollectionBase
public sealed class PropertyCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.PropertyCollection

See Also

Reference

PropertyCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


PropertyCollection Class Members

PropertyCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PropertyCollection Class

The following tables list the members exposed by PropertyCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific Property object in the PropertyCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a Property object to the PropertyCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific Property object in the PropertyCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

PropertyCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


PropertyCollection Class Methods

PropertyCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PropertyCollection Class

For a list of all members of this type, see PropertyCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a Property object to the PropertyCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific Property object in the PropertyCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

PropertyCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (PropertyCollection)

Add Method (PropertyCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PropertyCollection Class : Add Method
The Property object to add to the collection.
Adds a Property object to the PropertyCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As Property _
) As System.Integer
public System.int Add(
   Property value
)

Parameters

value
The Property object to add to the collection.

Return Value

A new Property object.
See Also

Reference

PropertyCollection Class
PropertyCollection Members


IndexOf Method (PropertyCollection)

IndexOf Method (PropertyCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PropertyCollection Class : IndexOf Method
The Property object to locate in the PropertyCollection.
Determines the index of a specific Property object in the PropertyCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As Property _
) As System.Integer
public System.int IndexOf(
   Property value
)

Parameters

value
The Property object to locate in the PropertyCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

PropertyCollection Class
PropertyCollection Members


PropertyCollection Class Properties

PropertyCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PropertyCollection Class

For a list of all members of this type, see PropertyCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific Property object in the PropertyCollection by position.
Top
See Also

Reference

PropertyCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (PropertyCollection)

Item Property (PropertyCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PropertyCollection Class : Item Property
A zero-based Integer indicating the index of the Property object to return or set.
Gets or sets a specific Property object in the PropertyCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As Property
public Property this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the Property object to return or set.

Property Value

The Property object at the specified position.
See Also

Reference

PropertyCollection Class
PropertyCollection Members


Query Class

Query Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Query Class
Represents the Query element of a dataset which contains the description of the query to execute to retrieve the data for the report.
Object Model
Query Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Query
public class Query
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Query

See Also

Reference

Query Members
GrapeCity.ActiveReports.PageReportModel Namespace


Query Class Members

Query Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Query Class

The following tables list the members exposed by Query.

Public Constructors
 | Name | Description
Public Constructor | Query Constructor | Initializes a new instance of the Query class.
Top
Public Properties
 | Name | Description
Public Property | CommandText | Gets or sets the query to execute to obtain the data for the report.
Public Property | CommandType | Gets or sets the type of query contained in the CommandText property.
Public Property | DataSourceName | Gets or sets the name of the data source against which to execute the query.
Public Property | QueryParameters | Gets a list of parameters that are passed to the data source as part of the query.
Public Property | Timeout | Gets or sets the number of seconds to allow the query to run before timing out.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the Query object.
Top
See Also

Reference

Query Class
GrapeCity.ActiveReports.PageReportModel Namespace


Query Constructor

Query Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Query Class : Query Constructor
Initializes a new instance of the Query class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Query()
See Also

Reference

Query Class
Query Members


Query Class Methods

Query Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Query Class

For a list of all members of this type, see Query members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the Query object.
Top
See Also

Reference

Query Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (Query)

Validate Method (Query)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Query Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the Query object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

Query Class
Query Members


Query Class Properties

Query Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Query Class

For a list of all members of this type, see Query members.

Public Properties
 | Name | Description
Public Property | CommandText | Gets or sets the query to execute to obtain the data for the report.
Public Property | CommandType | Gets or sets the type of query contained in the CommandText property.
Public Property | DataSourceName | Gets or sets the name of the data source against which to execute the query.
Public Property | QueryParameters | Gets a list of parameters that are passed to the data source as part of the query.
Public Property | Timeout | Gets or sets the number of seconds to allow the query to run before timing out.
Top
See Also

Reference

Query Class
GrapeCity.ActiveReports.PageReportModel Namespace


CommandText Property (Query)

CommandText Property (Query)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Query Class : CommandText Property

Gets or sets the query to execute to obtain the data for the report.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CommandText As ExpressionInfo
public ExpressionInfo CommandText {get; set;}

Property Value

A String containing the query to execute to obtain the data for the report.

See Also

Reference

Query Class
Query Members


CommandType Property (Query)

CommandType Property (Query)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Query Class : CommandType Property

Gets or sets the type of query contained in the CommandText property.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CommandType As QueryCommandType
public QueryCommandType CommandType {get; set;}

Property Value

A QueryCommandType enumeration indicating the type of query contained in the CommandText property.

See Also

Reference

Query Class
Query Members


DataSourceName Property (Query)

DataSourceName Property (Query)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Query Class : DataSourceName Property

Gets or sets the name of the data source against which to execute the query.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataSourceName As System.String
public System.string DataSourceName {get; set;}

Property Value

A String containing the name of the data source against which to execute the query.

See Also

Reference

Query Class
Query Members


QueryParameters Property (Query)

QueryParameters Property (Query)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Query Class : QueryParameters Property

Gets a list of parameters that are passed to the data source as part of the query.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property QueryParameters As QueryParameterCollection
public QueryParameterCollection QueryParameters {get;}

Property Value

A QueryParameterCollection containing the list of parameters that are passed to the data source as part of the query.

See Also

Reference

Query Class
Query Members


Timeout Property (Query)

Timeout Property (Query)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Query Class : Timeout Property

Gets or sets the number of seconds to allow the query to run before timing out.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Timeout As System.Integer
public System.int Timeout {get; set;}

Property Value

An Int32 indicating the number of seconds to allow the query to run before timing out.

Remarks

The Timeout value must be nonnegative.

If the value for the Timeout property is omitted or is zero, the query does not time out.

The maximum value is 2147483647 seconds.

See Also

Reference

Query Class
Query Members


QueryParameter Class

QueryParameter Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : QueryParameter Class

Defines a QueryParameter element which contains information about a parameter that is passed to the data source as part of the query.

Object Model
QueryParameter Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class QueryParameter
public sealed class QueryParameter
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.QueryParameter

See Also

Reference

QueryParameter Members
GrapeCity.ActiveReports.PageReportModel Namespace


QueryParameter Class Members

QueryParameter Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : QueryParameter Class

The following tables list the members exposed by QueryParameter.

Public Constructors
 | Name | Description
Public Constructor | QueryParameter Constructor | Initializes a new instance of the QueryParameter class.
Top
Public Properties
 | Name | Description
Public Property | AllowBlank | Gets or sets a value that indicates whether to allow empty value in the parameter.
Public Property | Caption | Gets or sets the caption of the parameter.
Public Property | DbType | Gets or sets the data type of the parameter.
Public Property | DefaultValue | Gets or sets the default value of the parameter.
Public Property | IsHidden | Gets or sets whether parameter is hidden.
Public Property | IsMultiline | Gets or sets whether parameter is multiline.
Public Property | IsMultiValued | Gets or sets whether parameter data is multi-valued.
Public Property | IsNullable | Gets or sets whether parameter is nullable.
Public Property | Name | Gets or sets the name for the parameter.
Public Property | Value | Gets or sets an expression that evaluates to the parameter value to pass to the data source.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the QueryParameter object.
Top
See Also

Reference

QueryParameter Class
GrapeCity.ActiveReports.PageReportModel Namespace


QueryParameter Constructor

QueryParameter Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > QueryParameter Class : QueryParameter Constructor
Initializes a new instance of the QueryParameter class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public QueryParameter()
See Also

Reference

QueryParameter Class
QueryParameter Members


QueryParameter Class Methods

QueryParameter Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : QueryParameter Class

For a list of all members of this type, see QueryParameter members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the QueryParameter object.
Top
See Also

Reference

QueryParameter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (QueryParameter)

Validate Method (QueryParameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > QueryParameter Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the QueryParameter object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

QueryParameter Class
QueryParameter Members


QueryParameter Class Properties

QueryParameter Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : QueryParameter Class

For a list of all members of this type, see QueryParameter members.

Public Properties
 | Name | Description
Public Property | AllowBlank | Gets or sets a value that indicates whether to allow empty value in the parameter.
Public Property | Caption | Gets or sets the caption of the parameter.
Public Property | DbType | Gets or sets the data type of the parameter.
Public Property | DefaultValue | Gets or sets the default value of the parameter.
Public Property | IsHidden | Gets or sets whether parameter is hidden.
Public Property | IsMultiline | Gets or sets whether parameter is multiline.
Public Property | IsMultiValued | Gets or sets whether parameter data is multi-valued.
Public Property | IsNullable | Gets or sets whether parameter is nullable.
Public Property | Name | Gets or sets the name for the parameter.
Public Property | Value | Gets or sets an expression that evaluates to the parameter value to pass to the data source.
Top
See Also

Reference

QueryParameter Class
GrapeCity.ActiveReports.PageReportModel Namespace


AllowBlank Property (QueryParameter)

AllowBlank Property (QueryParameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > QueryParameter Class : AllowBlank Property
Gets or sets a value that indicates whether to allow empty value in the parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AllowBlank As System.Nullable(Of Boolean)
public System.Nullable<bool> AllowBlank {get; set;}
See Also

Reference

QueryParameter Class
QueryParameter Members


Caption Property (QueryParameter)

Caption Property (QueryParameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > QueryParameter Class : Caption Property
Gets or sets the caption of the parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Caption As System.String
public System.string Caption {get; set;}
See Also

Reference

QueryParameter Class
QueryParameter Members


DbType Property

DbType Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > QueryParameter Class : DbType Property
Gets or sets the data type of the parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DbType As System.Nullable(Of ReportParameterDataType)
public System.Nullable<ReportParameterDataType> DbType {get; set;}
See Also

Reference

QueryParameter Class
QueryParameter Members


DefaultValue Property (QueryParameter)

DefaultValue Property (QueryParameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > QueryParameter Class : DefaultValue Property
Gets or sets the default value of the parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultValue As DefaultValue
public DefaultValue DefaultValue {get; set;}
See Also

Reference

QueryParameter Class
QueryParameter Members


IsHidden Property

IsHidden Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > QueryParameter Class : IsHidden Property
Gets or sets whether parameter is hidden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsHidden As System.Nullable(Of Boolean)
public System.Nullable<bool> IsHidden {get; set;}
See Also

Reference

QueryParameter Class
QueryParameter Members


IsMultiline Property

IsMultiline Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > QueryParameter Class : IsMultiline Property
Gets or sets whether parameter is multiline.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsMultiline As System.Nullable(Of Boolean)
public System.Nullable<bool> IsMultiline {get; set;}
See Also

Reference

QueryParameter Class
QueryParameter Members


IsMultiValued Property

IsMultiValued Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > QueryParameter Class : IsMultiValued Property
Gets or sets whether parameter data is multi-valued.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsMultiValued As System.Nullable(Of Boolean)
public System.Nullable<bool> IsMultiValued {get; set;}
See Also

Reference

QueryParameter Class
QueryParameter Members


IsNullable Property

IsNullable Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > QueryParameter Class : IsNullable Property
Gets or sets whether parameter is nullable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsNullable As System.Nullable(Of Boolean)
public System.Nullable<bool> IsNullable {get; set;}
See Also

Reference

QueryParameter Class
QueryParameter Members


Name Property (QueryParameter)

Name Property (QueryParameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > QueryParameter Class : Name Property

Gets or sets the name for the parameter.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}

Property Value

A String containing the name for the parameter.

See Also

Reference

QueryParameter Class
QueryParameter Members


Value Property (QueryParameter)

Value Property (QueryParameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > QueryParameter Class : Value Property

Gets or sets an expression that evaluates to the parameter value to pass to the data source.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As ExpressionInfo
public ExpressionInfo Value {get; set;}

Property Value

An ExpressionInfo object that evaluates to the value to pass to the data source.
Remarks

The expression can refer to report parameters but cannot contain references to report elements, fields in the data model, or aggregate functions.

In the case of a parameter for a Values or DataValues query, the expression can only refer to report parameters that occur earlier in the parameters list. The value for this query parameter is then taken from the user selection for that earlier report parameter.

See Also

Reference

QueryParameter Class
QueryParameter Members


QueryParameterCollection Class

QueryParameterCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : QueryParameterCollection Class
Provides a strongly typed collection for QueryParameter objects.
Object Model
QueryParameterCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class QueryParameterCollection
   Inherits System.Collections.CollectionBase
public sealed class QueryParameterCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.QueryParameterCollection

See Also

Reference

QueryParameterCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


QueryParameterCollection Class Members

QueryParameterCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : QueryParameterCollection Class

The following tables list the members exposed by QueryParameterCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific QueryParameter object in the QueryParameterCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a QueryParameter object to the QueryParameterCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific QueryParameter object in the QueryParameterCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

QueryParameterCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


QueryParameterCollection Class Methods

QueryParameterCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : QueryParameterCollection Class

For a list of all members of this type, see QueryParameterCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a QueryParameter object to the QueryParameterCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific QueryParameter object in the QueryParameterCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

QueryParameterCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (QueryParameterCollection)

Add Method (QueryParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > QueryParameterCollection Class : Add Method
The QueryParameter object to add to the collection.
Adds a QueryParameter object to the QueryParameterCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As QueryParameter _
) As System.Integer
public System.int Add(
   QueryParameter value
)

Parameters

value
The QueryParameter object to add to the collection.

Return Value

A new QueryParameter object.
See Also

Reference

QueryParameterCollection Class
QueryParameterCollection Members


IndexOf Method (QueryParameterCollection)

IndexOf Method (QueryParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > QueryParameterCollection Class : IndexOf Method
The QueryParameter object to locate in the QueryParameterCollection.
Determines the index of a specific QueryParameter object in the QueryParameterCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As QueryParameter _
) As System.Integer
public System.int IndexOf(
   QueryParameter value
)

Parameters

value
The QueryParameter object to locate in the QueryParameterCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

QueryParameterCollection Class
QueryParameterCollection Members


QueryParameterCollection Class Properties

QueryParameterCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : QueryParameterCollection Class

For a list of all members of this type, see QueryParameterCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific QueryParameter object in the QueryParameterCollection by position.
Top
See Also

Reference

QueryParameterCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (QueryParameterCollection)

Item Property (QueryParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > QueryParameterCollection Class : Item Property
A zero-based Integer indicating the index of the QueryParameter object to return or set.
Gets or sets a specific QueryParameter object in the QueryParameterCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As QueryParameter
public QueryParameter this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the QueryParameter object to return or set.

Property Value

The QueryParameter object at the specified position.
See Also

Reference

QueryParameterCollection Class
QueryParameterCollection Members


ReferenceLine Class

ReferenceLine Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReferenceLine Class
Defines the properties for the reference line in a chart.
Object Model
ReferenceLine Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ReferenceLine
public sealed class ReferenceLine
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ReferenceLine

See Also

Reference

ReferenceLine Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReferenceLine Class Members

ReferenceLine Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReferenceLine Class

The following tables list the members exposed by ReferenceLine.

Public Constructors
 | Name | Description
Public Constructor | ReferenceLine Constructor | Initializes a new instance of the ReferenceLine class.
Top
Public Properties
 | Name | Description
Public Property | LegendLabel | Gets or sets the string to insert in to the legend for the reference line.
Public Property | Style | Gets or sets the line style properties for the reference line.
Public Property | Value | Gets or sets the ExpressionInfo to evaluate to determine the location of the reference line.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the ReferenceLine object.
Top
See Also

Reference

ReferenceLine Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReferenceLine Constructor

ReferenceLine Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReferenceLine Class : ReferenceLine Constructor
Initializes a new instance of the ReferenceLine class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ReferenceLine()
See Also

Reference

ReferenceLine Class
ReferenceLine Members


ReferenceLine Class Methods

ReferenceLine Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReferenceLine Class

For a list of all members of this type, see ReferenceLine members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the ReferenceLine object.
Top
See Also

Reference

ReferenceLine Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (ReferenceLine)

Validate Method (ReferenceLine)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReferenceLine Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the ReferenceLine object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

ReferenceLine Class
ReferenceLine Members


ReferenceLine Class Properties

ReferenceLine Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReferenceLine Class

For a list of all members of this type, see ReferenceLine members.

Public Properties
 | Name | Description
Public Property | LegendLabel | Gets or sets the string to insert in to the legend for the reference line.
Public Property | Style | Gets or sets the line style properties for the reference line.
Public Property | Value | Gets or sets the ExpressionInfo to evaluate to determine the location of the reference line.
Top
See Also

Reference

ReferenceLine Class
GrapeCity.ActiveReports.PageReportModel Namespace


LegendLabel Property (ReferenceLine)

LegendLabel Property (ReferenceLine)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReferenceLine Class : LegendLabel Property
Gets or sets the string to insert in to the legend for the reference line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LegendLabel As System.String
public System.string LegendLabel {get; set;}
See Also

Reference

ReferenceLine Class
ReferenceLine Members


Style Property (ReferenceLine)

Style Property (ReferenceLine)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReferenceLine Class : Style Property

Gets or sets the line style properties for the reference line.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As Style
public Style Style {get; set;}

Property Value

A Style object containing the line style properties for the reference line.
See Also

Reference

ReferenceLine Class
ReferenceLine Members


Value Property (ReferenceLine)

Value Property (ReferenceLine)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReferenceLine Class : Value Property
Gets or sets the ExpressionInfo to evaluate to determine the location of the reference line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As ExpressionInfo
public ExpressionInfo Value {get; set;}
See Also

Reference

ReferenceLine Class
ReferenceLine Members


Report Class

Report Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Report Class
The Report element contains property, data, and layout information about the report which is the top-level element.
Object Model
Report Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Report
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer
public sealed class Report : ReportComponent, IReportComponent, IReportComponentContainer
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.Report

See Also

Reference

Report Members
GrapeCity.ActiveReports.PageReportModel Namespace


Report Class Members

Report Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Report Class

The following tables list the members exposed by Report.

Public Constructors
 | Name | Description
Public Constructor | Report Constructor | Initializes a new instance of the Report class.
Top
Public Properties
 | Name | Description
Public Property | Author | Gets or sets a value indicating the author of the report.
Public Property | AutoRefresh |
Public Property | Body | Gets or sets the structure for the body of the report.
Public Property | BottomMargin | Gets or sets the height of the bottom margin.
Public Property | Classes | Gets the code classes to instantiate during report initialization.
Public Property | Code | Gets or sets a string of code available to the report for use as a custom function.
Public Property | CodeModules | Gets the code modules to make available to the report for use in expressions.
Public Property | CollateBy | Gets or sets the collation settings for Page report.
Public Property | Components | Returns the ReportComponentCollection containing all of the components hosted in the report.
Public Property | ConsumeContainerWhitespace | Indicates that all white space in containers (such as Body and Rectangle) is consumed during report rendering when the container’s contents grow rather than preserving the minimum white space between the contents and the bounds of the container. This property is available for RDL reports only.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to the report engine.
Public Property | CustomProperties | Gets the collection of the custom properties of the report.
Public Property | DataElementName | Gets or sets the name of a top level element that represents the report data.
Public Property | DataElementStyle | Gets or sets a value indicating whether textboxes render as elements or attributes.
Public Property | DataSchema | Gets or sets the schema or namespace to use for an exported report.
Public Property | DataSets | Gets the data that is displayed as part of the report.
Public Property | DataSources | Gets the collection of data sources from which data sets are taken for the report.
Public Property | DataTransform | Gets or sets the name and location of the transformation file to apply to an exported report. This can be a full folder path (e.g. "/xsl/xfrm.xsl"), or a relative path (e.g. "xfrm.xsl").
Public Property | Description | Gets or sets a description of the report.
Public Property | DocumentMap | The report document map options.
Public Property | EmbeddedImages | Gets a collection of the images embedded in the report.
Public Property | EmbeddedStyleSheets | Gets a collection of the images embedded in the report.
Public Property | InteractiveHeight | Gets or sets the default report height when rendering the report in interactive mode.
Public Property | InteractiveWidth | Gets or sets the default report width when rendering the report in interactive mode.
Public Property | Language | Gets or sets the primary language of the text.
Public Property | Layers | The report layers collection.
Public Property | LeftMargin | Gets or sets the width of the left margin.
Public Property | LocalizationResources | Gets the collection of the localization resources for the report.
Public Property | MasterReport | Specifies URI for the master report, if any
Public Property | Name | Gets or sets the name of the report.
Public Property | PageFooter | Gets or sets the footer object that is output at the bottom of each report page.
Public Property | PageHeader | Gets or sets the header object that is output at the top of each report page.
Public Property | PageHeight | Gets or sets the height of the pages in the report.
Public Property | PageWidth | Gets or sets the width of the pages in the report.
Public Property | PaperOrientation | Gets or sets the report's pages paper orientation that used for printing.
Public Property | Parent | Overridden. Gets or sets the parent IReportComponentContainer hosting this control.
Public Property | ReportParameters | Gets the parameters for the report.
Public Property | RightMargin | Gets or sets the width of the right margin.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | StartPageNumber | Gets or sets the page number to start the numeration with in the report.
Public Property | StyleSheet | Obsolete. Gets the report's stylesheet. If stylesheet was invalidated, it will be loaded by StyleSheetSource and StyleSheetValue properties.
Public Property | StyleSheetSource | Gets or sets the source of the report's slylesheet.
Public Property | StyleSheetValue | Gets or sets the value of the report's slylesheet.
Public Property | Themes | Gets all themes associated with this Report.
Public Property | ThemeUri | Gets or sets the URI for the current attached theme.
Public Property | TopMargin | Gets or sets the height of the top margin.
Public Property | Width | Gets or sets a value indicating the width of the report.
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the Report object.
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Report Class
GrapeCity.ActiveReports.PageReportModel Namespace


Report Constructor

Report Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Report Constructor
Initializes a new instance of the Report class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Report()
See Also

Reference

Report Class
Report Members


Report Class Methods

Report Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Report Class

For a list of all members of this type, see Report members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the Report object.
Top
See Also

Reference

Report Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (Report)

Validate Method (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the Report object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

Report Class
Report Members


Report Class Properties

Report Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Report Class

For a list of all members of this type, see Report members.

Public Properties
 | Name | Description
Public Property | Author | Gets or sets a value indicating the author of the report.
Public Property | AutoRefresh |
Public Property | Body | Gets or sets the structure for the body of the report.
Public Property | BottomMargin | Gets or sets the height of the bottom margin.
Public Property | Classes | Gets the code classes to instantiate during report initialization.
Public Property | Code | Gets or sets a string of code available to the report for use as a custom function.
Public Property | CodeModules | Gets the code modules to make available to the report for use in expressions.
Public Property | CollateBy | Gets or sets the collation settings for Page report.
Public Property | Components | Returns the ReportComponentCollection containing all of the components hosted in the report.
Public Property | ConsumeContainerWhitespace | Indicates that all white space in containers (such as Body and Rectangle) is consumed during report rendering when the container’s contents grow rather than preserving the minimum white space between the contents and the bounds of the container. This property is available for RDL reports only.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to the report engine.
Public Property | CustomProperties | Gets the collection of the custom properties of the report.
Public Property | DataElementName | Gets or sets the name of a top level element that represents the report data.
Public Property | DataElementStyle | Gets or sets a value indicating whether textboxes render as elements or attributes.
Public Property | DataSchema | Gets or sets the schema or namespace to use for an exported report.
Public Property | DataSets | Gets the data that is displayed as part of the report.
Public Property | DataSources | Gets the collection of data sources from which data sets are taken for the report.
Public Property | DataTransform | Gets or sets the name and location of the transformation file to apply to an exported report. This can be a full folder path (e.g. "/xsl/xfrm.xsl"), or a relative path (e.g. "xfrm.xsl").
Public Property | Description | Gets or sets a description of the report.
Public Property | DocumentMap | The report document map options.
Public Property | EmbeddedImages | Gets a collection of the images embedded in the report.
Public Property | EmbeddedStyleSheets | Gets a collection of the images embedded in the report.
Public Property | InteractiveHeight | Gets or sets the default report height when rendering the report in interactive mode.
Public Property | InteractiveWidth | Gets or sets the default report width when rendering the report in interactive mode.
Public Property | Language | Gets or sets the primary language of the text.
Public Property | Layers | The report layers collection.
Public Property | LeftMargin | Gets or sets the width of the left margin.
Public Property | LocalizationResources | Gets the collection of the localization resources for the report.
Public Property | MasterReport | Specifies URI for the master report, if any
Public Property | Name | Gets or sets the name of the report.
Public Property | PageFooter | Gets or sets the footer object that is output at the bottom of each report page.
Public Property | PageHeader | Gets or sets the header object that is output at the top of each report page.
Public Property | PageHeight | Gets or sets the height of the pages in the report.
Public Property | PageWidth | Gets or sets the width of the pages in the report.
Public Property | PaperOrientation | Gets or sets the report's pages paper orientation that used for printing.
Public Property | Parent | Overridden. Gets or sets the parent IReportComponentContainer hosting this control.
Public Property | ReportParameters | Gets the parameters for the report.
Public Property | RightMargin | Gets or sets the width of the right margin.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | StartPageNumber | Gets or sets the page number to start the numeration with in the report.
Public Property | StyleSheet | Obsolete. Gets the report's stylesheet. If stylesheet was invalidated, it will be loaded by StyleSheetSource and StyleSheetValue properties.
Public Property | StyleSheetSource | Gets or sets the source of the report's slylesheet.
Public Property | StyleSheetValue | Gets or sets the value of the report's slylesheet.
Public Property | Themes | Gets all themes associated with this Report.
Public Property | ThemeUri | Gets or sets the URI for the current attached theme.
Public Property | TopMargin | Gets or sets the height of the top margin.
Public Property | Width | Gets or sets a value indicating the width of the report.
Top
See Also

Reference

Report Class
GrapeCity.ActiveReports.PageReportModel Namespace


Author Property (Report)

Author Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Author Property
Gets or sets a value indicating the author of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Author As System.String
public System.string Author {get; set;}
See Also

Reference

Report Class
Report Members


AutoRefresh Property (Report)

AutoRefresh Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : AutoRefresh Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoRefresh As System.Integer
public System.int AutoRefresh {get; set;}
See Also

Reference

Report Class
Report Members


Body Property (Report)

Body Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Body Property
Gets or sets the structure for the body of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Body As Body
public Body Body {get; set;}

Property Value

A Body object describing the structure for the body of the report.

See Also

Reference

Report Class
Report Members


BottomMargin Property (Report)

BottomMargin Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : BottomMargin Property
Gets or sets the height of the bottom margin.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BottomMargin As Length
public Length BottomMargin {get; set;}

Property Value

A Length structure indicating the height of the bottom margin.

Remarks
The default value is 0in.
See Also

Reference

Report Class
Report Members


Classes Property

Classes Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Classes Property

Gets the code classes to instantiate during report initialization.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Classes As CodeClassCollection
public CodeClassCollection Classes {get;}

Property Value

A CodeClassCollection containing the code classes to instantiate during report initialization.

See Also

Reference

Report Class
Report Members


Code Property

Code Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Code Property
Gets or sets a string of code available to the report for use as a custom function.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Code As System.String
public System.string Code {get; set;}
Remarks
The custom functions contained in the string must be instance methods written in Visual Basic.NET syntax. See the "Custom Code" topic in the User Guide for more information.
See Also

Reference

Report Class
Report Members


CodeModules Property

CodeModules Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : CodeModules Property

Gets the code modules to make available to the report for use in expressions.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CodeModules As System.Collections.Specialized.StringCollection
public System.Collections.Specialized.StringCollection CodeModules {get;}

Property Value

A StringCollection containing the code modules to make available to the report for use in expressions.

See Also

Reference

Report Class
Report Members


CollateBy Property

CollateBy Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : CollateBy Property
Gets or sets the collation settings for Page report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CollateBy As CollateBy
public CollateBy CollateBy {get; set;}
See Also

Reference

Report Class
Report Members


Components Property (Report)

Components Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Components Property
Returns the ReportComponentCollection containing all of the components hosted in the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Components As ReportComponentCollection
public ReportComponentCollection Components {get;}

Property Value

A read-only DataDynamics.Reports.ReportObjectModel.Rdl.ReportComponentCollection containing all of the components hosted in the report.
See Also

Reference

Report Class
Report Members


ConsumeContainerWhitespace Property (Report)

ConsumeContainerWhitespace Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : ConsumeContainerWhitespace Property
Indicates that all white space in containers (such as Body and Rectangle) is consumed during report rendering when the container’s contents grow rather than preserving the minimum white space between the contents and the bounds of the container. This property is available for RDL reports only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ConsumeContainerWhitespace As System.Boolean
public System.bool ConsumeContainerWhitespace {get; set;}
See Also

Reference

Report Class
Report Members


Custom Property (Report)

Custom Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Custom Property

Gets or sets custom information to be passed to the report engine.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Custom As Custom
public Custom Custom {get; set;}

Property Value

A Custom object containing custom information to be passed to the report engine.

See Also

Reference

Report Class
Report Members


CustomProperties Property (Report)

CustomProperties Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : CustomProperties Property
Gets the collection of the custom properties of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CustomProperties As CustomPropertyDefinitionCollection
public CustomPropertyDefinitionCollection CustomProperties {get;}

Property Value

The custom properties.
See Also

Reference

Report Class
Report Members


DataElementName Property (Report)

DataElementName Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : DataElementName Property

Gets or sets the name of a top level element that represents the report data.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataElementName As System.String
public System.string DataElementName {get; set;}

Property Value

A String indicating the name of a top level element that represents the report data.

Remarks

The default value is "Report."

See Also

Reference

Report Class
Report Members


DataElementStyle Property (Report)

DataElementStyle Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : DataElementStyle Property

Gets or sets a value indicating whether textboxes render as elements or attributes.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataElementStyle As DataElementStyle
public DataElementStyle DataElementStyle {get; set;}

Property Value

A DataElementStyle enumeration indicating whether textboxes render as elements or attributes.

See Also

Reference

Report Class
Report Members


DataSchema Property (Report)

DataSchema Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : DataSchema Property

Gets or sets the schema or namespace to use for an exported report.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataSchema As System.String
public System.string DataSchema {get; set;}

Property Value

A String indicating the schema or namespace to use for an exported report.

See Also

Reference

Report Class
Report Members


DataSets Property

DataSets Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : DataSets Property
Gets the data that is displayed as part of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DataSets As DataSetCollection
public DataSetCollection DataSets {get;}

Property Value

A DataSetCollection describing the data that is displayed as part of the report.

See Also

Reference

Report Class
Report Members


DataSources Property

DataSources Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : DataSources Property
Gets the collection of data sources from which data sets are taken for the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DataSources As DataSourceCollection
public DataSourceCollection DataSources {get;}

Property Value

A DataSourceCollection describing the data sources from which data sets are taken for the report.

See Also

Reference

Report Class
Report Members


DataTransform Property (Report)

DataTransform Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : DataTransform Property

Gets or sets the name and location of the transformation file to apply to an exported report. This can be a full folder path (e.g. "/xsl/xfrm.xsl"), or a relative path (e.g. "xfrm.xsl").

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataTransform As System.String
public System.string DataTransform {get; set;}

Property Value

A String indicating the name and location of a transformation file to apply to an exported report.

See Also

Reference

Report Class
Report Members


Description Property (Report)

Description Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Description Property
Gets or sets a description of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Description As System.String
public System.string Description {get; set;}
See Also

Reference

Report Class
Report Members


DocumentMap Property

DocumentMap Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : DocumentMap Property
The report document map options.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DocumentMap As DocumentMap
public DocumentMap DocumentMap {get;}
See Also

Reference

Report Class
Report Members


EmbeddedImages Property

EmbeddedImages Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : EmbeddedImages Property

Gets a collection of the images embedded in the report.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property EmbeddedImages As EmbeddedImageCollection
public EmbeddedImageCollection EmbeddedImages {get;}

Property Value

An EmbeddedImageCollection containing images embedded in the report.

See Also

Reference

Report Class
Report Members


EmbeddedStyleSheets Property

EmbeddedStyleSheets Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : EmbeddedStyleSheets Property

Gets a collection of the images embedded in the report.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property EmbeddedStyleSheets As System.Collections.Generic.List(Of EmbeddedStyleSheet)
public System.Collections.Generic.List<EmbeddedStyleSheet> EmbeddedStyleSheets {get;}

Property Value

An EmbeddedImageCollection containing images embedded in the report.

See Also

Reference

Report Class
Report Members


InteractiveHeight Property

InteractiveHeight Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : InteractiveHeight Property

Gets or sets the default report height when rendering the report in interactive mode.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property InteractiveHeight As Length
public Length InteractiveHeight {get; set;}

Property Value

A Length structure indicating the default report height when rendering the report in interactive mode.

Remarks

Using a length of 0, with any unit, indicates the height should be treated as unlimited.

The default value PageHeight.

See Also

Reference

Report Class
Report Members


InteractiveWidth Property

InteractiveWidth Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : InteractiveWidth Property

Gets or sets the default report width when rendering the report in interactive mode.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property InteractiveWidth As Length
public Length InteractiveWidth {get; set;}

Property Value

A Length structure indicating the default report width when rendering the report in interactive mode.

Remarks

Using a length of 0, with any unit, indicates the width should be treated as unlimited.

The default value PageWidth.

See Also

Reference

Report Class
Report Members


Language Property (Report)

Language Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Language Property

Gets or sets the primary language of the text.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Language As ExpressionInfo
public ExpressionInfo Language {get; set;}

Property Value

An ExpressionInfo object that evaluates to a language value which complies with the Internet Engineering Task Force (IETF) RFC1766 specification.

Remarks

The default value is the server language.

See Also

Reference

Report Class
Report Members


Layers Property (Report)

Layers Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Layers Property
The report layers collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Layers As LayerCollection
public LayerCollection Layers {get;}
See Also

Reference

Report Class
Report Members


LeftMargin Property (Report)

LeftMargin Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : LeftMargin Property
Gets or sets the width of the left margin.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LeftMargin As Length
public Length LeftMargin {get; set;}

Property Value

A Length structure indicating the width of the left margin.

Remarks
The default value is 0in.
See Also

Reference

Report Class
Report Members


LocalizationResources Property

LocalizationResources Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : LocalizationResources Property

Gets the collection of the localization resources for the report.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property LocalizationResources As LocalizationResourceCollection
public LocalizationResourceCollection LocalizationResources {get;}

Property Value

The collection of the localization resources for the report.

See Also

Reference

Report Class
Report Members


MasterReport Property (Report)

MasterReport Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : MasterReport Property
Specifies URI for the master report, if any
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MasterReport As System.String
public System.string MasterReport {get; set;}
See Also

Reference

Report Class
Report Members


Name Property (Report)

Name Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Name Property

Gets or sets the name of the report.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}

Property Value

A String indicating the name of the report.

See Also

Reference

Report Class
Report Members


PageFooter Property (Report)

PageFooter Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : PageFooter Property
Gets or sets the footer object that is output at the bottom of each report page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageFooter As PageHeaderFooter
public PageHeaderFooter PageFooter {get; set;}

Property Value

A PageHeaderFooter object containing the footer that is output at the bottom of each report page
See Also

Reference

Report Class
Report Members


PageHeader Property (Report)

PageHeader Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : PageHeader Property
Gets or sets the header object that is output at the top of each report page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageHeader As PageHeaderFooter
public PageHeaderFooter PageHeader {get; set;}

Property Value

A PageHeaderFooter object containing the header that is output at the top of each report page.

See Also

Reference

Report Class
Report Members


PageHeight Property (Report)

PageHeight Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : PageHeight Property
Gets or sets the height of the pages in the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageHeight As Length
public Length PageHeight {get; set;}

Property Value

A Length structure indicating the height of the pages in the report.

Remarks
The default value is 11in.
See Also

Reference

Report Class
Report Members


PageWidth Property (Report)

PageWidth Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : PageWidth Property
Gets or sets the width of the pages in the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageWidth As Length
public Length PageWidth {get; set;}

Property Value

A Length structure indicating the width of the pages in the report.

Remarks
The default value is 8.5in.
See Also

Reference

Report Class
Report Members


PaperOrientation Property (Report)

PaperOrientation Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : PaperOrientation Property
Gets or sets the report's pages paper orientation that used for printing.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaperOrientation As PaperOrientation
public PaperOrientation PaperOrientation {get; set;}
See Also

Reference

Report Class
Report Members


Parent Property (Report)

Parent Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Parent Property
Gets or sets the parent IReportComponentContainer hosting this control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Property Parent As IReportComponentContainer
public override IReportComponentContainer Parent {get; set;}

Property Value

An IReportComponentContainer representing the parent control.
Remarks
The Report does not not use this property.
See Also

Reference

Report Class
Report Members


ReportParameters Property

ReportParameters Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : ReportParameters Property
Gets the parameters for the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ReportParameters As ReportParameterCollection
public ReportParameterCollection ReportParameters {get;}

Property Value

A ReportParameterCollection containing the parameters for the report.

See Also

Reference

Report Class
Report Members


RightMargin Property (Report)

RightMargin Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : RightMargin Property
Gets or sets the width of the right margin.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RightMargin As Length
public Length RightMargin {get; set;}

Property Value

A Length structure indicating the width of the right margin.

Remarks
The default value is 0in.
See Also

Reference

Report Class
Report Members


StartPageNumber Property (Report)

StartPageNumber Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : StartPageNumber Property
Gets or sets the page number to start the numeration with in the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartPageNumber As System.Integer
public System.int StartPageNumber {get; set;}
See Also

Reference

Report Class
Report Members


StyleSheet Property (Report)

StyleSheet Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : StyleSheet Property
Obsolete. Gets the report's stylesheet. If stylesheet was invalidated, it will be loaded by StyleSheetSource and StyleSheetValue properties.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property StyleSheet As StyleSheet
public StyleSheet StyleSheet {get;}
See Also

Reference

Report Class
Report Members


StyleSheetSource Property

StyleSheetSource Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : StyleSheetSource Property
Gets or sets the source of the report's slylesheet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StyleSheetSource As StyleSheetSource
public StyleSheetSource StyleSheetSource {get; set;}
See Also

Reference

Report Class
Report Members


StyleSheetValue Property

StyleSheetValue Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : StyleSheetValue Property
Gets or sets the value of the report's slylesheet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StyleSheetValue As ExpressionInfo
public ExpressionInfo StyleSheetValue {get; set;}
See Also

Reference

Report Class
Report Members


Themes Property

Themes Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Themes Property
Gets all themes associated with this Report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Themes As System.Collections.Specialized.StringCollection
public System.Collections.Specialized.StringCollection Themes {get;}
See Also

Reference

Report Class
Report Members


ThemeUri Property (Report)

ThemeUri Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : ThemeUri Property
Gets or sets the URI for the current attached theme.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ThemeUri As System.String
public System.string ThemeUri {get; set;}
See Also

Reference

Report Class
Report Members


TopMargin Property (Report)

TopMargin Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : TopMargin Property
Gets or sets the height of the top margin.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TopMargin As Length
public Length TopMargin {get; set;}

Property Value

A Length structure indicating the height of the right margin
Remarks
The default value is 0in.
See Also

Reference

Report Class
Report Members


Width Property (Report)

Width Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Width Property
Gets or sets a value indicating the width of the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As Length
public Length Width {get; set;}

Property Value

A Length structure indicating the width of the report.

See Also

Reference

Report Class
Report Members


ReportComponent Class

ReportComponent Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponent Class
Defines a new ReportComponent.
Object Model
ReportComponent Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class ReportComponent
   Inherits System.ComponentModel.Component
   Implements IReportComponent
public abstract class ReportComponent : System.ComponentModel.Component, IReportComponent
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.CategoryGrouping
GrapeCity.ActiveReports.PageReportModel.ColumnGrouping
GrapeCity.ActiveReports.PageReportModel.Details
GrapeCity.ActiveReports.PageReportModel.HeaderFooter
GrapeCity.ActiveReports.PageReportModel.MatrixRow
GrapeCity.ActiveReports.PageReportModel.Report
GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.RowGrouping
GrapeCity.ActiveReports.PageReportModel.SeriesGrouping
GrapeCity.ActiveReports.PageReportModel.TableGroup
GrapeCity.ActiveReports.PageReportModel.TableRow

See Also

Reference

ReportComponent Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportComponent Class Members

ReportComponent Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponent Class

The following tables list the members exposed by ReportComponent.

Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

ReportComponent Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportComponent Class Properties

ReportComponent Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponent Class

For a list of all members of this type, see ReportComponent members.

Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

ReportComponent Class
GrapeCity.ActiveReports.PageReportModel Namespace


Parent Property (ReportComponent)

Parent Property (ReportComponent)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponent Class : Parent Property
Gets or sets an IReportComponentContainer interface representing the parent hosting the component.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Parent As IReportComponentContainer
public virtual IReportComponentContainer Parent {get; set;}

Property Value

An IReportComponentContainer interface representing the parent hosting the component.
See Also

Reference

ReportComponent Class
ReportComponent Members


ReportComponentCollection Class

ReportComponentCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponentCollection Class
Defines a collection of IReportComponent objects.
Object Model
ReportComponentCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ReportComponentCollection
public sealed class ReportComponentCollection
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ReportComponentCollection

See Also

Reference

ReportComponentCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportComponentCollection Class Members

ReportComponentCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponentCollection Class

The following tables list the members exposed by ReportComponentCollection.

Public Constructors
 | Name | Description
Public Constructor | ReportComponentCollection Constructor | Initializes a new instance of the ReportComponentCollection class.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets a value indicating how many items there are in the collection.
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Top
Public Methods
 | Name | Description
Public Method | CopyTo | Copies the collection to an System.Array.
Top
See Also

Reference

ReportComponentCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportComponentCollection Constructor

ReportComponentCollection Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponentCollection Class : ReportComponentCollection Constructor
An IReportComponent array containing the components to add to the collection.
Initializes a new instance of the ReportComponentCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal components() As IReportComponent _
)
public ReportComponentCollection(
   IReportComponent[] components
)

Parameters

components
An IReportComponent array containing the components to add to the collection.
See Also

Reference

ReportComponentCollection Class
ReportComponentCollection Members


ReportComponentCollection Class Methods

ReportComponentCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponentCollection Class

For a list of all members of this type, see ReportComponentCollection members.

Public Methods
 | Name | Description
Public Method | CopyTo | Copies the collection to an System.Array.
Top
See Also

Reference

ReportComponentCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


CopyTo Method (ReportComponentCollection)

CopyTo Method (ReportComponentCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponentCollection Class : CopyTo Method
The array to which to copy the collection.
The position at which to start copying.
Copies the collection to an System.Array.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal array As System.Array, _
   ByVal index As System.Integer _
)
public void CopyTo(
   System.Array array,
   System.int index
)

Parameters

array
The array to which to copy the collection.
index
The position at which to start copying.
See Also

Reference

ReportComponentCollection Class
ReportComponentCollection Members


ReportComponentCollection Class Properties

ReportComponentCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponentCollection Class

For a list of all members of this type, see ReportComponentCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets a value indicating how many items there are in the collection.
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Top
See Also

Reference

ReportComponentCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Count Property (ReportComponentCollection)

Count Property (ReportComponentCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponentCollection Class : Count Property
Gets a value indicating how many items there are in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}

Property Value

An System.Int32 indicating the number of IReportComponents in the collection.
See Also

Reference

ReportComponentCollection Class
ReportComponentCollection Members


IsSynchronized Property (ReportComponentCollection)

IsSynchronized Property (ReportComponentCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponentCollection Class : IsSynchronized Property
Gets a value indicating whether access to the collection is synchronized.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsSynchronized As System.Boolean
public System.bool IsSynchronized {get;}

Property Value

A System.Boolean value where true indicates that access to the collection is synchronized; otherwise false.
See Also

Reference

ReportComponentCollection Class
ReportComponentCollection Members


SyncRoot Property (ReportComponentCollection)

SyncRoot Property (ReportComponentCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponentCollection Class : SyncRoot Property
Gets an object that can be used to synchronize access to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property SyncRoot As System.Object
public System.object SyncRoot {get;}

Property Value

An object that can be used to synchronize access to the collection.
See Also

Reference

ReportComponentCollection Class
ReportComponentCollection Members


ReportComponentContainer Class

ReportComponentContainer Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponentContainer Class
Defines a GrapeCity.ActiveReports.ReportObjectModel.ReportComponentContainer that containes other GrapeCity.ActiveReports.ReportObjectModel.ReportComponent objects.
Object Model
ReportComponentContainer Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class ReportComponentContainer
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer
public abstract class ReportComponentContainer : ReportComponent, IReportComponent, IReportComponentContainer
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer
GrapeCity.ActiveReports.PageReportModel.Body
GrapeCity.ActiveReports.PageReportModel.Corner
GrapeCity.ActiveReports.PageReportModel.DynamicColumnsRows
GrapeCity.ActiveReports.PageReportModel.MatrixCell
GrapeCity.ActiveReports.PageReportModel.Page
GrapeCity.ActiveReports.PageReportModel.PageHeaderFooter
GrapeCity.ActiveReports.PageReportModel.StaticRowColumn
GrapeCity.ActiveReports.PageReportModel.Subtotal
GrapeCity.ActiveReports.PageReportModel.TableCell

See Also

Reference

ReportComponentContainer Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportComponentContainer Class Members

ReportComponentContainer Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponentContainer Class

The following tables list the members exposed by ReportComponentContainer.

Public Properties
 | Name | Description
Public Property | Components | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportComponentCollection containing all the ReportComponents in the container.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportItems | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportItemCollection containing all the ReportItems in the container.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

ReportComponentContainer Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportComponentContainer Class Properties

ReportComponentContainer Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponentContainer Class

For a list of all members of this type, see ReportComponentContainer members.

Public Properties
 | Name | Description
Public Property | Components | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportComponentCollection containing all the ReportComponents in the container.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportItems | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportItemCollection containing all the ReportItems in the container.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

ReportComponentContainer Class
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property (ReportComponentContainer)

Components Property (ReportComponentContainer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponentContainer Class : Components Property
Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportComponentCollection containing all the ReportComponents in the container.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Components As ReportComponentCollection
public virtual ReportComponentCollection Components {get;}

Property Value

a GrapeCity.ActiveReports.ReportObjectModel.ReportComponentCollection containing all the ReportComponents in the container.
See Also

Reference

ReportComponentContainer Class
ReportComponentContainer Members


ReportItems Property (ReportComponentContainer)

ReportItems Property (ReportComponentContainer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponentContainer Class : ReportItems Property
Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportItemCollection containing all the ReportItems in the container.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ReportItems As ReportItemCollection
public ReportItemCollection ReportItems {get;}

Property Value

a GrapeCity.ActiveReports.ReportObjectModel.ReportItemCollection containing all the ReportItems in the container.
See Also

Reference

ReportComponentContainer Class
ReportComponentContainer Members


ReportItem Class

ReportItem Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItem Class
A report item is one of the following types of objects: Line, Rectangle, TextBox, Image, Subreport, CustomReportItem, or DataRegion. DataRegions include List, Table, Matrix, and Chart. The ReportItem element itself is not used. Instead, the specific report item element is used whenever ReportItem is allowed.
Object Model
ReportItem Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class ReportItem
   Inherits ReportComponent
   Implements IReportComponent
public abstract class ReportItem : ReportComponent, IReportComponent
Remarks

The properties in this base class are shared among all types of ReportItem elements. Note, however, that not all properties of the ReportItem are necessarily meaningful for all types of report items.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.CustomReportItem
GrapeCity.ActiveReports.PageReportModel.DataRegion
GrapeCity.ActiveReports.PageReportModel.Image
GrapeCity.ActiveReports.PageReportModel.Line
GrapeCity.ActiveReports.PageReportModel.Map
GrapeCity.ActiveReports.PageReportModel.OverflowPlaceHolder
GrapeCity.ActiveReports.PageReportModel.Subreport
GrapeCity.ActiveReports.PageReportModel.TableOfContents
GrapeCity.ActiveReports.PageReportModel.TextItem

See Also

Reference

ReportItem Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportItem Class Members

ReportItem Class Members
Fields Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItem Class

The following tables list the members exposed by ReportItem.

Public Fields
 | Name | Description
Public Field | DefaultKeepTogether |
Public Field | DefaultLayerName |
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked.
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component.
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item.
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering.
Public Property | Height | Gets or sets the height of the report item.
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible.
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map).
Public Property | LayerName | The name of layer to which this report item belongs.
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object.
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any).
Public Property | Name | Gets or sets the name of the report item.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item.
Public Property | ToolTip | Gets or sets a textual label for the report item.
Public Property | Top | Gets or sets the distance of the item from the top of the containing object.
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden.
Public Property | Width | Gets or sets the width of the report item.
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object.
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the ReportItem object.
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

ReportItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportItem Class Methods

ReportItem Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItem Class

For a list of all members of this type, see ReportItem members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the ReportItem object.
Top
See Also

Reference

ReportItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (ReportItem)

Validate Method (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the ReportItem object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public virtual ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

ReportItem Class
ReportItem Members


ReportItem Class Properties

ReportItem Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItem Class

For a list of all members of this type, see ReportItem members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked.
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component.
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item.
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering.
Public Property | Height | Gets or sets the height of the report item.
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible.
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map).
Public Property | LayerName | The name of layer to which this report item belongs.
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object.
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any).
Public Property | Name | Gets or sets the name of the report item.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item.
Public Property | ToolTip | Gets or sets a textual label for the report item.
Public Property | Top | Gets or sets the distance of the item from the top of the containing object.
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden.
Public Property | Width | Gets or sets the width of the report item.
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object.
Top
See Also

Reference

ReportItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


Action Property (ReportItem)

Action Property (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Action Property

Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Action As Action
public Action Action {get; set;}

Property Value

An Action object representing the action to perform when the report control is clicked.

See Also

Reference

ReportItem Class
ReportItem Members


Bookmark Property (ReportItem)

Bookmark Property (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Bookmark Property

Gets or sets a bookmark that can be linked via a Bookmark action.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Bookmark As ExpressionInfo
public ExpressionInfo Bookmark {get; set;}

Property Value

An ExpressionInfo object that evaluates to a bookmark that can be linked via a bookmark action.

See Also

Reference

ReportItem Class
ReportItem Members


Custom Property (ReportItem)

Custom Property (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Custom Property

Gets or sets custom information to be passed to a report output component.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Custom As Custom
public Custom Custom {get; set;}

Property Value

A Custom object containing custom information to be passed to a report output component.

See Also

Reference

ReportItem Class
ReportItem Members


DataElementName Property (ReportItem)

DataElementName Property (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : DataElementName Property

Gets or sets the name to use for the data element or attribute for the report item.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataElementName As System.String
public System.string DataElementName {get; set;}

Property Value

A String indicating the name to use for the data element or attribute for the report item.

Remarks

The default value is the Name of the report item

See Also

Reference

ReportItem Class
ReportItem Members


DataElementOutput Property (ReportItem)

DataElementOutput Property (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : DataElementOutput Property

Gets or sets a value indicating whether the item appears in a data rendering.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataElementOutput As DataElementOutput
public DataElementOutput DataElementOutput {get; set;}

Property Value

A DataElementOutput enumeration indicating whether the item appears in a data rendering.

Remarks

Output indicates that the group appears in the output.

NoOutput indicates that the group does not appear in the output.

ContentsOnly indicates that the item does not appear in the XML, but its contents are rendered as if they were in the item's container. This value only applies to Lists.

Auto behaves in the same manner as NoOutput for Textbox report items with constant values, ContentsOnly for Rectangle report items and Output for all other items.

See Also

Reference

ReportItem Class
ReportItem Members


Height Property (ReportItem)

Height Property (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Height Property

Gets or sets the height of the report item.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Height As Length
public virtual Length Height {get; set;}

Property Value

A Length structure indicating the report item's height.

Remarks

Negative sizes are allowed only for the Line report item.

The default value is the height of the containing object minus the Top, if no value is provided.

For Table and Matrix report items, the default values for Height and Width are instead derived from the sizes of the component parts (columns, rows, matrix cells).

See Also

Reference

ReportItem Class
ReportItem Members


KeepTogether Property (ReportItem)

KeepTogether Property (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : KeepTogether Property

Gets or sets a value indicating whether a data region is kept together on a single page where possible.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property KeepTogether As System.Boolean
public System.bool KeepTogether {get; set;}

Property Value

A Boolean value where true indicates that the data region's content is kept together on a single page if possible; otherwise false. The default value is false.

Remarks
If the data region is larger than the body of the page, the property is ignored.
See Also

Reference

ReportItem Class
ReportItem Members


Label Property (ReportItem)

Label Property (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Label Property

Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map).

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Label As ExpressionInfo
public ExpressionInfo Label {get; set;}

Property Value

An ExpressionInfo object containing a label to identify an instance of a report control within the client UI.

Remarks

Hierarchical listings of report items and group labels within the UI (the Document Map) reflect the object containment hierarchy in the report definition. Peer items are listed in left-to-right, top-to-bottom order.

If the expression returns null, no item is added to the Document Map.

Labels are not used for report items in the page header or footer.

See Also

Reference

ReportItem Class
ReportItem Members


LayerName Property (ReportItem)

LayerName Property (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : LayerName Property
The name of layer to which this report item belongs.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LayerName As System.String
public System.string LayerName {get; set;}
See Also

Reference

ReportItem Class
ReportItem Members


Left Property (ReportItem)

Left Property (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Left Property

Gets or sets the distance of the item from the left edge of the containing object.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Left As Length
public Length Left {get; set;}

Property Value

A Length structure indicating the distance of the item from the left edge of the containing object.

Remarks

The default value is 0 if no value is provided.

See Also

Reference

ReportItem Class
ReportItem Members


LinkToChild Property

LinkToChild Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : LinkToChild Property

Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any).

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LinkToChild As System.String
public System.string LinkToChild {get; set;}

Property Value

A String indicating the name of the report item contained directly within the report item that is the target location for the Document Map label.

Remarks

Used only for Rectangle report items.

This property is ignored if a Label is not present.

See Also

Reference

ReportItem Class
ReportItem Members


Name Property (ReportItem)

Name Property (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Name Property

Gets or sets the name of the report item.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}

Property Value

A String indicating the name of the report item.

See Also

Reference

ReportItem Class
ReportItem Members


Style Property (ReportItem)

Style Property (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Style Property

Gets or sets the the style settings for the report item.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As Style
public Style Style {get; set;}

Property Value

A Style object representing the style elements of the report control.

See Also

Reference

ReportItem Class
ReportItem Members


ToolTip Property (ReportItem)

ToolTip Property (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : ToolTip Property

Gets or sets a textual label for the report item.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ToolTip As ExpressionInfo
public ExpressionInfo ToolTip {get; set;}

Property Value

An ExpressionInfo object that evaluates to a textual label for the report control.

Remarks

The ToolTip is used for such things as including TITLE and ALT attributes in HTML reports.

See Also

Reference

ReportItem Class
ReportItem Members


Top Property (ReportItem)

Top Property (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Top Property

Gets or sets the distance of the item from the top of the containing object.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Top As Length
public Length Top {get; set;}

Property Value

A Length structure indicating the distance of the item from the top of the containing object.

Remarks

The default value is 0 if no value is provided.

See Also

Reference

ReportItem Class
ReportItem Members


Visibility Property (ReportItem)

Visibility Property (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Visibility Property

Gets or sets a value indicating whether the items are hidden.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visibility As Visibility
public Visibility Visibility {get; set;}

Property Value

A Visibility object indicating whether the report control is hidden.

See Also

Reference

ReportItem Class
ReportItem Members


Width Property (ReportItem)

Width Property (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Width Property

Gets or sets the width of the report item.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Width As Length
public virtual Length Width {get; set;}

Property Value

A Length structure indicating the width of the report control.

Remarks

Negative sizes are allowed only for Line report items.

The default value is the width of the containing object minus the Left, if no value is provided.

For Table and Matrix report items, the default values for Height and Width are instead derived from the sizes of the component parts (columns, rows, matrix cells).

See Also

Reference

ReportItem Class
ReportItem Members


ZIndex Property (ReportItem)

ZIndex Property (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : ZIndex Property

Gets or sets the drawing order of the report item within the containing object.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ZIndex As System.Integer
public System.int ZIndex {get; set;}

Property Value

An Integer indicating the drawing order of the report item within the containing object.

Remarks

Items with lower indices are drawn first (appearing behind items with higher indices).

Items with equal indices have an unspecified order.

The default value is 0. The minimum value is 0. The maximum value is 21474836478.

See Also

Reference

ReportItem Class
ReportItem Members


ReportItem Class Fields

ReportItem Class Fields

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItem Class

For a list of all members of this type, see ReportItem members.

Public Fields
 | Name | Description
Public Field | DefaultKeepTogether |
Public Field | DefaultLayerName |
Top
See Also

Reference

ReportItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


DefaultKeepTogether Field

DefaultKeepTogether Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : DefaultKeepTogether Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const DefaultKeepTogether As System.Boolean
public const System.bool DefaultKeepTogether
See Also

Reference

ReportItem Class
ReportItem Members


DefaultLayerName Field (ReportItem)

DefaultLayerName Field (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : DefaultLayerName Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const DefaultLayerName As System.String
public const System.string DefaultLayerName
See Also

Reference

ReportItem Class
ReportItem Members


ReportItemCollection Class

ReportItemCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItemCollection Class
Provides a strongly typed collection for ReportItem objects.
Object Model
ReportItemCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ReportItemCollection
public class ReportItemCollection
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ReportItemCollection

See Also

Reference

ReportItemCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportItemCollection Class Members

ReportItemCollection Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItemCollection Class

The following tables list the members exposed by ReportItemCollection.

Public Constructors
 | Name | Description
Public Constructor | ReportItemCollection Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the number of ReportItem objects in the ReportItemCollection.
Public Property | IsFixedSize | Gets a Boolean value indicating whether the ReportItemCollection has a fixed size.
Public Property | IsReadOnly | Gets a Boolean value indicating whether the ReportItemCollection is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the ReportItemCollection is synchronized (thread safe).
Public Property | Item | Overloaded. Gets or sets a specific ReportItem object in the ReportItemCollection by position.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the ReportItemCollection.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a ReportItem object to the ReportItemCollection.
Public Method | AddRange | Adds a ReportItemCollection to the existing ReportItemCollection.
Public Method | Clear | Removes all items from the ReportItemCollection.
Public Method | Contains | Gets a Boolean value indicating whether the ReportItemCollection contains the specified ReportItem.
Public Method | CopyTo | Overloaded. Copies the objects in the ReportItemCollection to an array, starting at the indicated Array index.
Public Method | IndexOf | Determines the index of a specific ReportItem object in the ReportItemCollection.
Public Method | Insert | Inserts a new ReportItem into the ReportItemCollection at the specified location.
Public Method | Remove | Removes the specified ReportItem object from the ReportItemCollection.
Public Method | RemoveAt | Removes a ReportItem object from the ReportItemCollection at the specified index.
Public Method | ToArray | Copies the elements of the ReportItemCollection to a new array.
Top
Public Events
 | Name | Description
Public Event | ItemAdded | Occurs immediately after adding an item to the collection.
Public Event | ItemRemoved | Occurs immediately after removing an item from the collection.
Top
See Also

Reference

ReportItemCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportItemCollection Constructor

ReportItemCollection Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : ReportItemCollection Constructor
Overload List
Overload | Description
ReportItemCollection Constructor() | Initializes a new instance of the ReportItemCollection class.
ReportItemCollection Constructor(IEnumerable<ReportItem>) | Initializes a new instance of the ReportItemCollection class and pre-populates the collection with a passed-in ReportItemCollection.
See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


ReportItemCollection Constructor()

ReportItemCollection Constructor()

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class > ReportItemCollection Constructor : ReportItemCollection Constructor()
Initializes a new instance of the ReportItemCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ReportItemCollection()
See Also

Reference

ReportItemCollection Class
ReportItemCollection Members
Overload List


ReportItemCollection Constructor(IEnumerable<ReportItem>)

ReportItemCollection Constructor(IEnumerable<ReportItem>)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class > ReportItemCollection Constructor : ReportItemCollection Constructor(IEnumerable<ReportItem>)
Initializes a new instance of the ReportItemCollection class and pre-populates the collection with a passed-in ReportItemCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal items As System.Collections.Generic.IEnumerable(Of ReportItem) _
)
public ReportItemCollection(
   System.Collections.Generic.IEnumerable<ReportItem> items
)

Parameters

items
See Also

Reference

ReportItemCollection Class
ReportItemCollection Members
Overload List


ReportItemCollection Class Methods

ReportItemCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItemCollection Class

For a list of all members of this type, see ReportItemCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a ReportItem object to the ReportItemCollection.
Public Method | AddRange | Adds a ReportItemCollection to the existing ReportItemCollection.
Public Method | Clear | Removes all items from the ReportItemCollection.
Public Method | Contains | Gets a Boolean value indicating whether the ReportItemCollection contains the specified ReportItem.
Public Method | CopyTo | Overloaded. Copies the objects in the ReportItemCollection to an array, starting at the indicated Array index.
Public Method | IndexOf | Determines the index of a specific ReportItem object in the ReportItemCollection.
Public Method | Insert | Inserts a new ReportItem into the ReportItemCollection at the specified location.
Public Method | Remove | Removes the specified ReportItem object from the ReportItemCollection.
Public Method | RemoveAt | Removes a ReportItem object from the ReportItemCollection at the specified index.
Public Method | ToArray | Copies the elements of the ReportItemCollection to a new array.
Top
See Also

Reference

ReportItemCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (ReportItemCollection)

Add Method (ReportItemCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : Add Method
The ReportItem object to add.
Adds a ReportItem object to the ReportItemCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Add( _
   ByVal value As ReportItem _
)
public void Add(
   ReportItem value
)

Parameters

value
The ReportItem object to add.

Return Value

A new ReportItem object.
See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


AddRange Method (ReportItemCollection)

AddRange Method (ReportItemCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : AddRange Method

The ReportItemCollection object to add.

Adds a ReportItemCollection to the existing ReportItemCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddRange( _
   ByVal collection As System.Collections.Generic.IEnumerable(Of ReportItem) _
)
public void AddRange(
   System.Collections.Generic.IEnumerable<ReportItem> collection
)

Parameters

collection

The ReportItemCollection object to add.

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


Clear Method (ReportItemCollection)

Clear Method (ReportItemCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : Clear Method
Removes all items from the ReportItemCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


Contains Method (ReportItemCollection)

Contains Method (ReportItemCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : Contains Method
The ReportItem object for which to check.
Gets a Boolean value indicating whether the ReportItemCollection contains the specified ReportItem.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function Contains( _
   ByVal value As ReportItem _
) As System.Boolean
public virtual System.bool Contains(
   ReportItem value
)

Parameters

value
The ReportItem object for which to check.

Return Value

Returns true if the ReportItemCollection contains the specified ReportItem; otherwise, false.
See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


CopyTo Method (ReportItemCollection)

CopyTo Method (ReportItemCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : CopyTo Method
Copies the objects in the ReportItemCollection to an array, starting at the indicated Array index.
Overload List
Overload | Description
CopyTo(Array,Int32) | Copies the objects in the ReportItemCollection to an array, starting at the indicated Array index.
CopyTo(ReportItem[],Int32) | Copies the objects in the ReportItemCollection to a ReportItem array, starting at the indicated Array index.
See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


CopyTo(Array,Int32) Method

CopyTo(Array,Int32) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class > CopyTo Method : CopyTo(Array,Int32) Method
The one-dimensional Array that is the destination of the objects copied from the ReportItemCollection. The Array must have zero-based indexing.
The zero-based Integer index in the array at which copying begins.
Copies the objects in the ReportItemCollection to an array, starting at the indicated Array index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overridable Sub CopyTo( _
   ByVal array As System.Array, _
   ByVal index As System.Integer _
)
public virtual void CopyTo(
   System.Array array,
   System.int index
)

Parameters

array
The one-dimensional Array that is the destination of the objects copied from the ReportItemCollection. The Array must have zero-based indexing.
index
The zero-based Integer index in the array at which copying begins.
See Also

Reference

ReportItemCollection Class
ReportItemCollection Members
Overload List


CopyTo(ReportItem[],Int32) Method

CopyTo(ReportItem[],Int32) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class > CopyTo Method : CopyTo(ReportItem[],Int32) Method
The one-dimensional ReportItem[] that is the destination of the elements copied from the ReportItemCollection. The Array must have zero-based indexing.
The zero-based Integer index in the array at which copying begins.
Copies the objects in the ReportItemCollection to a ReportItem array, starting at the indicated Array index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overridable Sub CopyTo( _
   ByVal array() As ReportItem, _
   ByVal index As System.Integer _
)
public virtual void CopyTo(
   ReportItem[] array,
   System.int index
)

Parameters

array
The one-dimensional ReportItem[] that is the destination of the elements copied from the ReportItemCollection. The Array must have zero-based indexing.
index
The zero-based Integer index in the array at which copying begins.
See Also

Reference

ReportItemCollection Class
ReportItemCollection Members
Overload List


IndexOf Method (ReportItemCollection)

IndexOf Method (ReportItemCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : IndexOf Method

The ReportItem object to locate in the ReportItemCollection.

Determines the index of a specific ReportItem object in the ReportItemCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function IndexOf( _
   ByVal value As ReportItem _
) As System.Integer
public virtual System.int IndexOf(
   ReportItem value
)

Parameters

value

The ReportItem object to locate in the ReportItemCollection.

Return Value

The index of the entry if it was found in the collection; otherwise, -1.
See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


Insert Method (ReportItemCollection)

Insert Method (ReportItemCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : Insert Method
A zero-based Integer index indicating the position at which to insert the ReportItem object.

The ReportItem object to insert.

Inserts a new ReportItem into the ReportItemCollection at the specified location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As ReportItem _
)
public void Insert(
   System.int index,
   ReportItem value
)

Parameters

index
A zero-based Integer index indicating the position at which to insert the ReportItem object.
value

The ReportItem object to insert.

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


Remove Method (ReportItemCollection)

Remove Method (ReportItemCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : Remove Method

The ReportItem object to remove.

Removes the specified ReportItem object from the ReportItemCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Remove( _
   ByVal value As ReportItem _
) As System.Boolean
public System.bool Remove(
   ReportItem value
)

Parameters

value

The ReportItem object to remove.

See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


RemoveAt Method (ReportItemCollection)

RemoveAt Method (ReportItemCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : RemoveAt Method
An Integer indicating the index at which to remove the ReportItem object.
Removes a ReportItem object from the ReportItemCollection at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
An Integer indicating the index at which to remove the ReportItem object.
See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


ToArray Method (ReportItemCollection)

ToArray Method (ReportItemCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : ToArray Method
Copies the elements of the ReportItemCollection to a new array.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToArray() As ReportItem()
public ReportItem[] ToArray()

Return Value

An array of ReportItem objects containing copies of the elements in the ReportItemCollection.
See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


ReportItemCollection Class Properties

ReportItemCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItemCollection Class

For a list of all members of this type, see ReportItemCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of ReportItem objects in the ReportItemCollection.
Public Property | IsFixedSize | Gets a Boolean value indicating whether the ReportItemCollection has a fixed size.
Public Property | IsReadOnly | Gets a Boolean value indicating whether the ReportItemCollection is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the ReportItemCollection is synchronized (thread safe).
Public Property | Item | Overloaded. Gets or sets a specific ReportItem object in the ReportItemCollection by position.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the ReportItemCollection.
Top
See Also

Reference

ReportItemCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Count Property (ReportItemCollection)

Count Property (ReportItemCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : Count Property
Gets the number of ReportItem objects in the ReportItemCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}

Property Value

An Integer indicating the number of ReportItem objects.
See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


IsFixedSize Property (ReportItemCollection)

IsFixedSize Property (ReportItemCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : IsFixedSize Property
Gets a Boolean value indicating whether the ReportItemCollection has a fixed size.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsFixedSize As System.Boolean
public System.bool IsFixedSize {get;}

Property Value

Returns true if the ReportItemCollection has a fixed size; otherwise, false.
See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


IsReadOnly Property (ReportItemCollection)

IsReadOnly Property (ReportItemCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : IsReadOnly Property
Gets a Boolean value indicating whether the ReportItemCollection is read-only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsReadOnly As System.Boolean
public System.bool IsReadOnly {get;}

Property Value

Returns true if the ReportItemCollection is read-only; otherwise, false.
See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


IsSynchronized Property (ReportItemCollection)

IsSynchronized Property (ReportItemCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : IsSynchronized Property
Gets a value indicating whether access to the ReportItemCollection is synchronized (thread safe).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property IsSynchronized As System.Boolean
public virtual System.bool IsSynchronized {get;}

Property Value

Returns true if access to the ReportItemCollection is synchronized (thread safe); otherwise, false.
See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


Item Property (ReportItemCollection)

Item Property (ReportItemCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : Item Property
Gets or sets a specific ReportItem object in the ReportItemCollection by position.
Overload List
Overload | Description
Item(Int32) | Gets or sets a specific ReportItem object in the ReportItemCollection by position.
Item(String) | Gets the specified report control from the collection located at the position specified by the index.
See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


Item(Int32) Property

Item(Int32) Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class > Item Property : Item(Int32) Property
A zero-based Integer index of the ReportItem to return or set.
Gets or sets a specific ReportItem object in the ReportItemCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Property Item( _
   ByVal index As System.Integer _
) As ReportItem
public ReportItem Item(
   System.int index
) {get; set;}

Parameters

index
A zero-based Integer index of the ReportItem to return or set.

Property Value

The ReportItem object at the specified position.
See Also

Reference

ReportItemCollection Class
ReportItemCollection Members
Overload List


Item(String) Property

Item(String) Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class > Item Property : Item(String) Property
The name of the report control to get.
Gets the specified report control from the collection located at the position specified by the index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal name As System.String _
) As ReportItem
public ReportItem Item(
   System.string name
) {get;}

Parameters

name
The name of the report control to get.
See Also

Reference

ReportItemCollection Class
ReportItemCollection Members
Overload List


SyncRoot Property (ReportItemCollection)

SyncRoot Property (ReportItemCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : SyncRoot Property
Gets an object that can be used to synchronize access to the ReportItemCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property SyncRoot As System.Object
public virtual System.object SyncRoot {get;}

Property Value

An object that can be used to synchronize access to the ReportItemCollection.
See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


ReportItemCollection Class Events

ReportItemCollection Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItemCollection Class

For a list of all members of this type, see ReportItemCollection members.

Public Events
 | Name | Description
Public Event | ItemAdded | Occurs immediately after adding an item to the collection.
Public Event | ItemRemoved | Occurs immediately after removing an item from the collection.
Top
See Also

Reference

ReportItemCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ItemAdded Event (ReportItemCollection)

ItemAdded Event (ReportItemCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : ItemAdded Event
Occurs immediately after adding an item to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ItemAdded As ReportItemCollectionEventHandler
public event ReportItemCollectionEventHandler ItemAdded
Event Data

The event handler receives an argument of type ReportItemCollectionEventArgs containing data related to this event. The following ReportItemCollectionEventArgs properties provide information specific to this event.

Property | Description
Index | Returns an Integer for the ReportItem that was added or removed.
Value | Returns the ReportItem object that was added or removed.
See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


ItemRemoved Event (ReportItemCollection)

ItemRemoved Event (ReportItemCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollection Class : ItemRemoved Event
Occurs immediately after removing an item from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ItemRemoved As ReportItemCollectionEventHandler
public event ReportItemCollectionEventHandler ItemRemoved
Event Data

The event handler receives an argument of type ReportItemCollectionEventArgs containing data related to this event. The following ReportItemCollectionEventArgs properties provide information specific to this event.

Property | Description
Index | Returns an Integer for the ReportItem that was added or removed.
Value | Returns the ReportItem object that was added or removed.
See Also

Reference

ReportItemCollection Class
ReportItemCollection Members


ReportItemCollectionEventArgs Class

ReportItemCollectionEventArgs Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItemCollectionEventArgs Class
Provides data for the ItemAdded or ItemRemoved event of the ReportItemCollection.
Object Model
ReportItemCollectionEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ReportItemCollectionEventArgs
   Inherits System.EventArgs
public class ReportItemCollectionEventArgs : System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.PageReportModel.ReportItemCollectionEventArgs

See Also

Reference

ReportItemCollectionEventArgs Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportItemCollectionEventArgs Class Members

ReportItemCollectionEventArgs Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItemCollectionEventArgs Class

The following tables list the members exposed by ReportItemCollectionEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ReportItemCollectionEventArgs Constructor | Initializes a new instance of the ReportItemCollectionEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Index | Returns an Integer for the ReportItem that was added or removed.
Public Property | Value | Returns the ReportItem object that was added or removed.
Top
See Also

Reference

ReportItemCollectionEventArgs Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportItemCollectionEventArgs Constructor

ReportItemCollectionEventArgs Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollectionEventArgs Class : ReportItemCollectionEventArgs Constructor
An Integer indicating the index of the ReportItem object added or removed.
The ReportItem object that was added or removed.
Initializes a new instance of the ReportItemCollectionEventArgs class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal index As System.Integer, _
   ByVal value As ReportItem _
)
public ReportItemCollectionEventArgs(
   System.int index,
   ReportItem value
)

Parameters

index
An Integer indicating the index of the ReportItem object added or removed.
value
The ReportItem object that was added or removed.
See Also

Reference

ReportItemCollectionEventArgs Class
ReportItemCollectionEventArgs Members


ReportItemCollectionEventArgs Class Properties

ReportItemCollectionEventArgs Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItemCollectionEventArgs Class

For a list of all members of this type, see ReportItemCollectionEventArgs members.

Public Properties
 | Name | Description
Public Property | Index | Returns an Integer for the ReportItem that was added or removed.
Public Property | Value | Returns the ReportItem object that was added or removed.
Top
See Also

Reference

ReportItemCollectionEventArgs Class
GrapeCity.ActiveReports.PageReportModel Namespace


Index Property (ReportItemCollectionEventArgs)

Index Property (ReportItemCollectionEventArgs)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollectionEventArgs Class : Index Property
Returns an Integer for the ReportItem that was added or removed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Index As System.Integer
public System.int Index {get;}

Property Value

An Integer indicating the index of the ReportItem that was added or removed.
See Also

Reference

ReportItemCollectionEventArgs Class
ReportItemCollectionEventArgs Members


Value Property (ReportItemCollectionEventArgs)

Value Property (ReportItemCollectionEventArgs)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItemCollectionEventArgs Class : Value Property
Returns the ReportItem object that was added or removed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Value As ReportItem
public ReportItem Value {get;}

Property Value

A ReportItem object representing the item that was added or removed.
See Also

Reference

ReportItemCollectionEventArgs Class
ReportItemCollectionEventArgs Members


ReportParameter Class

ReportParameter Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportParameter Class
The ReportParameter element contains information about a parameter for the report.
Object Model
ReportParameter Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ReportParameter
public sealed class ReportParameter
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ReportParameter

See Also

Reference

ReportParameter Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportParameter Class Members

ReportParameter Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportParameter Class

The following tables list the members exposed by ReportParameter.

Public Constructors
 | Name | Description
Public Constructor | ReportParameter Constructor | Initializes a new instance of the ReportParameter class.
Top
Public Properties
 | Name | Description
Public Property | AllowBlank | Gets or sets a value indicating whether the value for this parameter is allowed to be an empty string.
Public Property | DataType | Gets or sets the data type of the parameter.
Public Property | DateOnly | Specifies whether this parameter contains only date without time.
Public Property | DefaultValue | Gets or sets the default value to use for the parameter (if none is provided by the user).
Public Property | Hidden | Gets or sets a value indicating whether this parameter should be visible to the end user.
Public Property | Multiline | Gets or sets a value indicating whether the parameter supposes to get the multiline values.
Public Property | MultiValue | Gets or sets a value indicating whether mutltiple values for this parameter are allowed.
Public Property | Name | Gets or sets the name of the parameter (this is the name used when expressions refer to the parameter).
Public Property | Nullable | Gets or sets a value indicating whether the value for this parameter is allowed to be Null.
Public Property | Prompt | Gets or sets the user prompt to display when asking for parameter values.
Public Property | UsedInQuery | Gets or sets a value indicating whether the parameter is used in a query in the report.
Public Property | ValidValues | Gets or sets the possible values for the parameter (for an end-user prompting interface).
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.ReportParameter object.
Top
See Also

Reference

ReportParameter Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportParameter Constructor

ReportParameter Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : ReportParameter Constructor
Initializes a new instance of the ReportParameter class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ReportParameter()
See Also

Reference

ReportParameter Class
ReportParameter Members


ReportParameter Class Methods

ReportParameter Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportParameter Class

For a list of all members of this type, see ReportParameter members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.ReportParameter object.
Top
See Also

Reference

ReportParameter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (ReportParameter)

Validate Method (ReportParameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : Validate Method
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.ReportParameter object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A DataDynamics.Reports.ReportObjectModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

ReportParameter Class
ReportParameter Members


ReportParameter Class Properties

ReportParameter Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportParameter Class

For a list of all members of this type, see ReportParameter members.

Public Properties
 | Name | Description
Public Property | AllowBlank | Gets or sets a value indicating whether the value for this parameter is allowed to be an empty string.
Public Property | DataType | Gets or sets the data type of the parameter.
Public Property | DateOnly | Specifies whether this parameter contains only date without time.
Public Property | DefaultValue | Gets or sets the default value to use for the parameter (if none is provided by the user).
Public Property | Hidden | Gets or sets a value indicating whether this parameter should be visible to the end user.
Public Property | Multiline | Gets or sets a value indicating whether the parameter supposes to get the multiline values.
Public Property | MultiValue | Gets or sets a value indicating whether mutltiple values for this parameter are allowed.
Public Property | Name | Gets or sets the name of the parameter (this is the name used when expressions refer to the parameter).
Public Property | Nullable | Gets or sets a value indicating whether the value for this parameter is allowed to be Null.
Public Property | Prompt | Gets or sets the user prompt to display when asking for parameter values.
Public Property | UsedInQuery | Gets or sets a value indicating whether the parameter is used in a query in the report.
Public Property | ValidValues | Gets or sets the possible values for the parameter (for an end-user prompting interface).
Top
See Also

Reference

ReportParameter Class
GrapeCity.ActiveReports.PageReportModel Namespace


AllowBlank Property (ReportParameter)

AllowBlank Property (ReportParameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : AllowBlank Property
Gets or sets a value indicating whether the value for this parameter is allowed to be an empty string.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AllowBlank As System.Boolean
public System.bool AllowBlank {get; set;}

Property Value

A Boolean value where true indicates that the parameter is allowed to be an empty string; otherwise false. The default value is false.
Remarks
This property is ignored if the DataType is not string.
See Also

Reference

ReportParameter Class
ReportParameter Members


DataType Property (ReportParameter)

DataType Property (ReportParameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : DataType Property
Gets or sets the data type of the parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataType As ReportParameterDataType
public ReportParameterDataType DataType {get; set;}

Property Value

A ReportParameterDataType enumeration representing the data type of the parameter.
See Also

Reference

ReportParameter Class
ReportParameter Members


DateOnly Property (ReportParameter)

DateOnly Property (ReportParameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : DateOnly Property
Specifies whether this parameter contains only date without time.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DateOnly As System.Boolean
public System.bool DateOnly {get; set;}
See Also

Reference

ReportParameter Class
ReportParameter Members


DefaultValue Property (ReportParameter)

DefaultValue Property (ReportParameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : DefaultValue Property
Gets or sets the default value to use for the parameter (if none is provided by the user).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultValue As DefaultValue
public DefaultValue DefaultValue {get; set;}

Property Value

A DefaultValue object used to supply the parameter.
Remarks
If no value is provided as a part of the definition or by the user, the value is null. A DefaultValue is required if there is no Prompt and either Nullable is False or a ValidValues list is provided that does not contain Null (an omitted value).
See Also

Reference

ReportParameter Class
ReportParameter Members


Hidden Property (ReportParameter)

Hidden Property (ReportParameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : Hidden Property
Gets or sets a value indicating whether this parameter should be visible to the end user.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Hidden As System.Boolean
public System.bool Hidden {get; set;}

Property Value

A Boolean value where true indicates this parameter should not be visible to the end user.; otherwise false. The default value is false.
Remarks
The paramer will still be usable programatically, such as with subreports and drillthrough reports, when the property is set to true.
See Also

Reference

ReportParameter Class
ReportParameter Members


Multiline Property (ReportParameter)

Multiline Property (ReportParameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : Multiline Property
Gets or sets a value indicating whether the parameter supposes to get the multiline values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Multiline As System.Boolean
public System.bool Multiline {get; set;}

Property Value

A Boolean value where true indicates that the parameters supposes to get the multiline values otherwise false. The default value is false.
See Also

Reference

ReportParameter Class
ReportParameter Members


MultiValue Property (ReportParameter)

MultiValue Property (ReportParameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : MultiValue Property
Gets or sets a value indicating whether mutltiple values for this parameter are allowed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MultiValue As System.Boolean
public System.bool MultiValue {get; set;}

Property Value

A Boolean value where true indicates that mutliple parameter values are allowed; otherwise false. The default value is false.
See Also

Reference

ReportParameter Class
ReportParameter Members


Name Property (ReportParameter)

Name Property (ReportParameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : Name Property
Gets or sets the name of the parameter (this is the name used when expressions refer to the parameter).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}

Property Value

A String representing the name of the parameter.
Remarks
Parameter names need only be unique within the containing Parameters collection.
See Also

Reference

ReportParameter Class
ReportParameter Members


Nullable Property (ReportParameter)

Nullable Property (ReportParameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : Nullable Property
Gets or sets a value indicating whether the value for this parameter is allowed to be Null.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Nullable As System.Boolean
public System.bool Nullable {get; set;}

Property Value

A Boolean value where true indicates that the parameter is allowed to be null; otherwise false. The default value is false.
See Also

Reference

ReportParameter Class
ReportParameter Members


Prompt Property (ReportParameter)

Prompt Property (ReportParameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : Prompt Property
Gets or sets the user prompt to display when asking for parameter values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Prompt As System.String
public System.string Prompt {get; set;}

Property Value

A String representing the user prompt to display when asking for parameter values.
Remarks
If this value is omitted, the user is not prompted for a value for the parameter.
See Also

Reference

ReportParameter Class
ReportParameter Members


UsedInQuery Property

UsedInQuery Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : UsedInQuery Property
Gets or sets a value indicating whether the parameter is used in a query in the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UsedInQuery As ReportParameterUsedInQuery
public ReportParameterUsedInQuery UsedInQuery {get; set;}

Property Value

A ReportParameterUsedInQuery enumeration indicating whether the parameter is used in a query in the report.
Remarks

This property is used to determine whether queries need to be re-executed if the parameter changes.

Auto (Default) indicates that the UsedInQuery setting is automatically detected. Auto returns true if the parameter is referenced in any query value expression, otherwise false.

See Also

Reference

ReportParameter Class
ReportParameter Members


ValidValues Property (ReportParameter)

ValidValues Property (ReportParameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameter Class : ValidValues Property
Gets or sets the possible values for the parameter (for an end-user prompting interface).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ValidValues As ValidValues
public ValidValues ValidValues {get; set;}

Property Value

A ValidValues object containing the possible values for the parameter.
See Also

Reference

ReportParameter Class
ReportParameter Members


ReportParameterCollection Class

ReportParameterCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportParameterCollection Class
Provides a strongly typed collection for ReportParameter objects.
Object Model
ReportParameterCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ReportParameterCollection
   Inherits System.Collections.CollectionBase
public sealed class ReportParameterCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ReportParameterCollection

See Also

Reference

ReportParameterCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportParameterCollection Class Members

ReportParameterCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportParameterCollection Class

The following tables list the members exposed by ReportParameterCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific ReportParameter object in the ReportParameterCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a ReportParameter object to the ReportParameterCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific ReportParameter object in the ReportParameterCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ReportParameterCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportParameterCollection Class Methods

ReportParameterCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportParameterCollection Class

For a list of all members of this type, see ReportParameterCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a ReportParameter object to the ReportParameterCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific ReportParameter object in the ReportParameterCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ReportParameterCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (ReportParameterCollection)

Add Method (ReportParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameterCollection Class : Add Method
The ReportParameter object to add to the collection.
Adds a ReportParameter object to the ReportParameterCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As ReportParameter _
) As System.Integer
public System.int Add(
   ReportParameter value
)

Parameters

value
The ReportParameter object to add to the collection.

Return Value

A new ReportParameter object.
See Also

Reference

ReportParameterCollection Class
ReportParameterCollection Members


IndexOf Method (ReportParameterCollection)

IndexOf Method (ReportParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameterCollection Class : IndexOf Method
The ReportParameter object to locate in the ReportParameterCollection.
Determines the index of a specific ReportParameter object in the ReportParameterCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As ReportParameter _
) As System.Integer
public System.int IndexOf(
   ReportParameter value
)

Parameters

value
The ReportParameter object to locate in the ReportParameterCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

ReportParameterCollection Class
ReportParameterCollection Members


ReportParameterCollection Class Properties

ReportParameterCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportParameterCollection Class

For a list of all members of this type, see ReportParameterCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific ReportParameter object in the ReportParameterCollection by position.
Top
See Also

Reference

ReportParameterCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (ReportParameterCollection)

Item Property (ReportParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameterCollection Class : Item Property
A zero-based Integer indicating the index of the ReportParameter to return or set.
Gets or sets a specific ReportParameter object in the ReportParameterCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As ReportParameter
public ReportParameter this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the ReportParameter to return or set.

Property Value

The ReportParameter object at the specified position.
See Also

Reference

ReportParameterCollection Class
ReportParameterCollection Members


RoundingRadius Class

RoundingRadius Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RoundingRadius Class
Defines the color for the border.
Object Model
RoundingRadius Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class RoundingRadius
public sealed class RoundingRadius
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.RoundingRadius

See Also

Reference

RoundingRadius Members
GrapeCity.ActiveReports.PageReportModel Namespace


RoundingRadius Class Members

RoundingRadius Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RoundingRadius Class

The following tables list the members exposed by RoundingRadius.

Public Constructors
 | Name | Description
Public Constructor | RoundingRadius Constructor | Initializes a new instance of the RoundingRadius class.
Top
Public Properties
 | Name | Description
Public Property | BottomLeft | Gets or sets the radius of the bottom left corner.
Public Property | BottomRight | Gets or sets the radius of the bottom right corner.
Public Property | Default | Gets or sets the radius of the corner rounding (unless overridden for a specific corner).
Public Property | TopLeft | Gets or sets the radius of the top left corner.
Public Property | TopRight | Gets or sets the radius of the top right corner.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the RoundingRadius object.
Top
See Also

Reference

RoundingRadius Class
GrapeCity.ActiveReports.PageReportModel Namespace


RoundingRadius Constructor

RoundingRadius Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RoundingRadius Class : RoundingRadius Constructor
Initializes a new instance of the RoundingRadius class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public RoundingRadius()
See Also

Reference

RoundingRadius Class
RoundingRadius Members


RoundingRadius Class Methods

RoundingRadius Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RoundingRadius Class

For a list of all members of this type, see RoundingRadius members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the RoundingRadius object.
Top
See Also

Reference

RoundingRadius Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (RoundingRadius)

Validate Method (RoundingRadius)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RoundingRadius Class : Validate Method
The ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the RoundingRadius object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The ValidationContext object containing the contextual information used to drive the validation.

Return Value

A ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

RoundingRadius Class
RoundingRadius Members


RoundingRadius Class Properties

RoundingRadius Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RoundingRadius Class

For a list of all members of this type, see RoundingRadius members.

Public Properties
 | Name | Description
Public Property | BottomLeft | Gets or sets the radius of the bottom left corner.
Public Property | BottomRight | Gets or sets the radius of the bottom right corner.
Public Property | Default | Gets or sets the radius of the corner rounding (unless overridden for a specific corner).
Public Property | TopLeft | Gets or sets the radius of the top left corner.
Public Property | TopRight | Gets or sets the radius of the top right corner.
Top
See Also

Reference

RoundingRadius Class
GrapeCity.ActiveReports.PageReportModel Namespace


BottomLeft Property (RoundingRadius)

BottomLeft Property (RoundingRadius)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RoundingRadius Class : BottomLeft Property

Gets or sets the radius of the bottom left corner.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BottomLeft As ExpressionInfo
public ExpressionInfo BottomLeft {get; set;}

Property Value

An ExpressionInfo object that evaluates to the radius of the bottom left corner.

See Also

Reference

RoundingRadius Class
RoundingRadius Members


BottomRight Property (RoundingRadius)

BottomRight Property (RoundingRadius)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RoundingRadius Class : BottomRight Property

Gets or sets the radius of the bottom right corner.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BottomRight As ExpressionInfo
public ExpressionInfo BottomRight {get; set;}

Property Value

An ExpressionInfo object that evaluates to the radius of the bottom right corner.

See Also

Reference

RoundingRadius Class
RoundingRadius Members


Default Property (RoundingRadius)

Default Property (RoundingRadius)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RoundingRadius Class : Default Property

Gets or sets the radius of the corner rounding (unless overridden for a specific corner).

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Default As ExpressionInfo
public ExpressionInfo Default {get; set;}

Property Value

An ExpressionInfo object that evaluates to the rounding radius of the corner.

Remarks

The default value is Black.

See Also

Reference

RoundingRadius Class
RoundingRadius Members


TopLeft Property (RoundingRadius)

TopLeft Property (RoundingRadius)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RoundingRadius Class : TopLeft Property

Gets or sets the radius of the top left corner.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TopLeft As ExpressionInfo
public ExpressionInfo TopLeft {get; set;}

Property Value

An ExpressionInfo object that evaluates to the radius of the top left corner.

See Also

Reference

RoundingRadius Class
RoundingRadius Members


TopRight Property (RoundingRadius)

TopRight Property (RoundingRadius)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RoundingRadius Class : TopRight Property

Gets or sets the radius of the top right corner.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TopRight As ExpressionInfo
public ExpressionInfo TopRight {get; set;}

Property Value

An ExpressionInfo object that evaluates to the radius of the top right corner.

See Also

Reference

RoundingRadius Class
RoundingRadius Members


RowGrouping Class

RowGrouping Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RowGrouping Class
Defines a row grouping for a matrix.
Object Model
RowGrouping Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class RowGrouping
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer, IScopeDefinition
public sealed class RowGrouping : ReportComponent, IReportComponent, IReportComponentContainer, IScopeDefinition
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.RowGrouping

See Also

Reference

RowGrouping Members
GrapeCity.ActiveReports.PageReportModel Namespace


RowGrouping Class Members

RowGrouping Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RowGrouping Class

The following tables list the members exposed by RowGrouping.

Public Constructors
 | Name | Description
Public Constructor | RowGrouping Constructor | Initializes a new instance of the RowGrouping class.
Top
Public Properties
 | Name | Description
Public Property | Components | Returns the DataDynamics.Reports.ReportObjectModel.Rdl.ReportComponentCollection containing all of the components hosted in the control.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | DynamicRows | Gets or sets the dynamic row headings for the grouping.
Public Property | FixedHeader | Gets or sets a value indicating whether the header for this grouping should be displayed on the page even when the user scrolls part of the matrix off the page.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | StaticRows | Gets the static row headings for the grouping.
Public Property | Width | Gets or sets the width of the row header.
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.RowGrouping object.
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

RowGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


RowGrouping Constructor

RowGrouping Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGrouping Class : RowGrouping Constructor

Initializes a new instance of the RowGrouping class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public RowGrouping()
See Also

Reference

RowGrouping Class
RowGrouping Members


RowGrouping Class Methods

RowGrouping Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RowGrouping Class

For a list of all members of this type, see RowGrouping members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.RowGrouping object.
Top
See Also

Reference

RowGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (RowGrouping)

Validate Method (RowGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGrouping Class : Validate Method
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.RowGrouping object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A DataDynamics.Reports.ReportObjectModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

RowGrouping Class
RowGrouping Members


RowGrouping Class Properties

RowGrouping Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RowGrouping Class

For a list of all members of this type, see RowGrouping members.

Public Properties
 | Name | Description
Public Property | Components | Returns the DataDynamics.Reports.ReportObjectModel.Rdl.ReportComponentCollection containing all of the components hosted in the control.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | DynamicRows | Gets or sets the dynamic row headings for the grouping.
Public Property | FixedHeader | Gets or sets a value indicating whether the header for this grouping should be displayed on the page even when the user scrolls part of the matrix off the page.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | StaticRows | Gets the static row headings for the grouping.
Public Property | Width | Gets or sets the width of the row header.
Top
See Also

Reference

RowGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property (RowGrouping)

Components Property (RowGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGrouping Class : Components Property
Returns the DataDynamics.Reports.ReportObjectModel.Rdl.ReportComponentCollection containing all of the components hosted in the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Components As ReportComponentCollection
public ReportComponentCollection Components {get;}

Property Value

A read-only DataDynamics.Reports.ReportObjectModel.Rdl.ReportComponentCollection containing all of the components hosted in the control.
See Also

Reference

RowGrouping Class
RowGrouping Members


DynamicRows Property

DynamicRows Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGrouping Class : DynamicRows Property

Gets or sets the dynamic row headings for the grouping.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DynamicRows As DynamicColumnsRows
public DynamicColumnsRows DynamicRows {get; set;}

Property Value

A DynamicColumnsRows object containing the dynamic row headings for this grouping.

See Also

Reference

RowGrouping Class
RowGrouping Members


FixedHeader Property (RowGrouping)

FixedHeader Property (RowGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGrouping Class : FixedHeader Property

Gets or sets a value indicating whether the header for this grouping should be displayed on the page even when the user scrolls part of the matrix off the page.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FixedHeader As System.Boolean
public System.bool FixedHeader {get; set;}

Property Value

A Boolean value where true indicates the grouping should be displayed on the page even when the user scrolls part of the matrix off the page; otherwise false. The default value is false.

Remarks
Fixed headers must be touching each other and must also include the outermost grouping.
See Also

Reference

RowGrouping Class
RowGrouping Members


StaticRows Property

StaticRows Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGrouping Class : StaticRows Property

Gets the static row headings for the grouping.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property StaticRows As StaticRowColumnCollection
public StaticRowColumnCollection StaticRows {get;}

Property Value

A StaticRowColumnCollection containing the static row headings for the grouping.

See Also

Reference

RowGrouping Class
RowGrouping Members


Width Property (RowGrouping)

Width Property (RowGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGrouping Class : Width Property

Gets or sets the width of the row header.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As Length
public Length Width {get; set;}

Property Value

A Length structure containing the width of the row header.

See Also

Reference

RowGrouping Class
RowGrouping Members


RowGroupingCollection Class

RowGroupingCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RowGroupingCollection Class
Provides a strongly typed collection for RowGrouping objects.
Object Model
RowGroupingCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class RowGroupingCollection
   Inherits System.Collections.CollectionBase
public sealed class RowGroupingCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.RowGroupingCollection

See Also

Reference

RowGroupingCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


RowGroupingCollection Class Members

RowGroupingCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RowGroupingCollection Class

The following tables list the members exposed by RowGroupingCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific RowGrouping object in the RowGroupingCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a RowGrouping object to the RowGroupingCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
static (Shared in Visual Basic) | Create | Returns a new instance of the RowGroupingCollection class.
Public Method | IndexOf | Determines the index of a specific RowGrouping object in the RowGroupingCollection.
Public Method | Insert | Inserts a new RowGrouping object into the RowGroupingCollection at the specified location.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

RowGroupingCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


RowGroupingCollection Class Methods

RowGroupingCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RowGroupingCollection Class

For a list of all members of this type, see RowGroupingCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a RowGrouping object to the RowGroupingCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
static (Shared in Visual Basic) | Create | Returns a new instance of the RowGroupingCollection class.
Public Method | IndexOf | Determines the index of a specific RowGrouping object in the RowGroupingCollection.
Public Method | Insert | Inserts a new RowGrouping object into the RowGroupingCollection at the specified location.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

RowGroupingCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (RowGroupingCollection)

Add Method (RowGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGroupingCollection Class : Add Method
The RowGrouping object to add to the collection.
Adds a RowGrouping object to the RowGroupingCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As RowGrouping _
) As System.Integer
public System.int Add(
   RowGrouping value
)

Parameters

value
The RowGrouping object to add to the collection.

Return Value

A new RowGrouping object.
See Also

Reference

RowGroupingCollection Class
RowGroupingCollection Members


Create Method (RowGroupingCollection)

Create Method (RowGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGroupingCollection Class : Create Method
Returns a new instance of the RowGroupingCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function Create() As RowGroupingCollection
public static RowGroupingCollection Create()
See Also

Reference

RowGroupingCollection Class
RowGroupingCollection Members


IndexOf Method (RowGroupingCollection)

IndexOf Method (RowGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGroupingCollection Class : IndexOf Method
The RowGrouping object to locate in the RowGroupingCollection.
Determines the index of a specific RowGrouping object in the RowGroupingCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As RowGrouping _
) As System.Integer
public System.int IndexOf(
   RowGrouping value
)

Parameters

value
The RowGrouping object to locate in the RowGroupingCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

RowGroupingCollection Class
RowGroupingCollection Members


Insert Method (RowGroupingCollection)

Insert Method (RowGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGroupingCollection Class : Insert Method
A zero-based Integer index indicating the position at which to insert the RowGrouping object.
The RowGrouping object to insert.
Inserts a new RowGrouping object into the RowGroupingCollection at the specified location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As RowGrouping _
)
public void Insert(
   System.int index,
   RowGrouping value
)

Parameters

index
A zero-based Integer index indicating the position at which to insert the RowGrouping object.
value
The RowGrouping object to insert.
See Also

Reference

RowGroupingCollection Class
RowGroupingCollection Members


RowGroupingCollection Class Properties

RowGroupingCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RowGroupingCollection Class

For a list of all members of this type, see RowGroupingCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific RowGrouping object in the RowGroupingCollection by position.
Top
See Also

Reference

RowGroupingCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (RowGroupingCollection)

Item Property (RowGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGroupingCollection Class : Item Property
A zero-based Integer indicating the index of the RowGrouping to return or set.
Gets or sets a specific RowGrouping object in the RowGroupingCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As RowGrouping
public RowGrouping this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the RowGrouping to return or set.

Property Value

The RowGrouping object at the specified position.
See Also

Reference

RowGroupingCollection Class
RowGroupingCollection Members


SeriesGrouping Class

SeriesGrouping Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SeriesGrouping Class
The SeriesGrouping element defines a Series level for a chart SeriesGrouping. The labels for the series are displayed in the legend.
Object Model
SeriesGrouping Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class SeriesGrouping
   Inherits ReportComponent
   Implements IReportComponent
public sealed class SeriesGrouping : ReportComponent, IReportComponent
Remarks
A SeriesGrouping must have a defined DynamicSeries, a defined StaticSeries, or both.
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.SeriesGrouping

See Also

Reference

SeriesGrouping Members
GrapeCity.ActiveReports.PageReportModel Namespace


SeriesGrouping Class Members

SeriesGrouping Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SeriesGrouping Class

The following tables list the members exposed by SeriesGrouping.

Public Constructors
 | Name | Description
Public Constructor | SeriesGrouping Constructor | Initializes a new instance of the SeriesGrouping class.
Top
Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | DynamicSeries | Gets the dynamic series headings for the grouping.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | StaticSeries | Gets the static series headings for the grouping.
Public Property | Style | Gets or sets the border and background style properties for the series legend items(s) and data points in the series.
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.SeriesGrouping object.
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

SeriesGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


SeriesGrouping Constructor

SeriesGrouping Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGrouping Class : SeriesGrouping Constructor

Initializes a new instance of the SeriesGrouping class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public SeriesGrouping()
See Also

Reference

SeriesGrouping Class
SeriesGrouping Members


SeriesGrouping Class Methods

SeriesGrouping Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SeriesGrouping Class

For a list of all members of this type, see SeriesGrouping members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.SeriesGrouping object.
Top
See Also

Reference

SeriesGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (SeriesGrouping)

Validate Method (SeriesGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGrouping Class : Validate Method
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.SeriesGrouping object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A DataDynamics.Reports.ReportObjectModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

SeriesGrouping Class
SeriesGrouping Members


SeriesGrouping Class Properties

SeriesGrouping Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SeriesGrouping Class

For a list of all members of this type, see SeriesGrouping members.

Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | DynamicSeries | Gets the dynamic series headings for the grouping.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | StaticSeries | Gets the static series headings for the grouping.
Public Property | Style | Gets or sets the border and background style properties for the series legend items(s) and data points in the series.
Top
See Also

Reference

SeriesGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


DynamicSeries Property

DynamicSeries Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGrouping Class : DynamicSeries Property

Gets the dynamic series headings for the grouping.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DynamicSeries As DynamicCategoriesSeries
public DynamicCategoriesSeries DynamicSeries {get; set;}

Property Value

A DynamicCategoriesSeries containing dynamic series headings for the grouping.

See Also

Reference

SeriesGrouping Class
SeriesGrouping Members


StaticSeries Property

StaticSeries Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGrouping Class : StaticSeries Property

Gets the static series headings for the grouping.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property StaticSeries As StaticMemberCollection
public StaticMemberCollection StaticSeries {get;}

Property Value

A StaticMemberCollection containing static series headings for the grouping.

See Also

Reference

SeriesGrouping Class
SeriesGrouping Members


Style Property (SeriesGrouping)

Style Property (SeriesGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGrouping Class : Style Property

Gets or sets the border and background style properties for the series legend items(s) and data points in the series.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As Style
public Style Style {get; set;}

Property Value

A Style object containing the border and background style properties for the series legend items(s) and data points in the series.

Remarks
Style expressions are evaluated for each group instance when applied to DynamicsSeries.
See Also

Reference

SeriesGrouping Class
SeriesGrouping Members


SeriesGroupingCollection Class

SeriesGroupingCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SeriesGroupingCollection Class
Provides a strongly typed collection for SeriesGrouping objects.
Object Model
SeriesGroupingCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class SeriesGroupingCollection
   Inherits System.Collections.CollectionBase
public sealed class SeriesGroupingCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.SeriesGroupingCollection

See Also

Reference

SeriesGroupingCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


SeriesGroupingCollection Class Members

SeriesGroupingCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SeriesGroupingCollection Class

The following tables list the members exposed by SeriesGroupingCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific SeriesGrouping object in the SeriesGroupingCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a SeriesGrouping object to the SeriesGroupingCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific SeriesGrouping object in the SeriesGroupingCollection.
Public Method | Insert | Inserts a new SeriesGrouping object into the SeriesGroupingCollection at the specified location.
Public Method | Remove | Removes the specified SeriesGrouping object from the SeriesGroupingCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

SeriesGroupingCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


SeriesGroupingCollection Class Methods

SeriesGroupingCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SeriesGroupingCollection Class

For a list of all members of this type, see SeriesGroupingCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a SeriesGrouping object to the SeriesGroupingCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific SeriesGrouping object in the SeriesGroupingCollection.
Public Method | Insert | Inserts a new SeriesGrouping object into the SeriesGroupingCollection at the specified location.
Public Method | Remove | Removes the specified SeriesGrouping object from the SeriesGroupingCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

SeriesGroupingCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (SeriesGroupingCollection)

Add Method (SeriesGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGroupingCollection Class : Add Method
The SeriesGrouping object to add to the collection.
Adds a SeriesGrouping object to the SeriesGroupingCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As SeriesGrouping _
) As System.Integer
public System.int Add(
   SeriesGrouping value
)

Parameters

value
The SeriesGrouping object to add to the collection.

Return Value

A new SeriesGrouping object.
See Also

Reference

SeriesGroupingCollection Class
SeriesGroupingCollection Members


IndexOf Method (SeriesGroupingCollection)

IndexOf Method (SeriesGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGroupingCollection Class : IndexOf Method
The SeriesGrouping object to locate in the SeriesGroupingCollection.
Determines the index of a specific SeriesGrouping object in the SeriesGroupingCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As SeriesGrouping _
) As System.Integer
public System.int IndexOf(
   SeriesGrouping value
)

Parameters

value
The SeriesGrouping object to locate in the SeriesGroupingCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

SeriesGroupingCollection Class
SeriesGroupingCollection Members


Insert Method (SeriesGroupingCollection)

Insert Method (SeriesGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGroupingCollection Class : Insert Method
A zero-based Integer index indicating the position at which to insert the SeriesGrouping object.
The SeriesGrouping object to insert.
Inserts a new SeriesGrouping object into the SeriesGroupingCollection at the specified location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As SeriesGrouping _
)
public void Insert(
   System.int index,
   SeriesGrouping value
)

Parameters

index
A zero-based Integer index indicating the position at which to insert the SeriesGrouping object.
value
The SeriesGrouping object to insert.
See Also

Reference

SeriesGroupingCollection Class
SeriesGroupingCollection Members


Remove Method (SeriesGroupingCollection)

Remove Method (SeriesGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGroupingCollection Class : Remove Method
The SeriesGrouping object to remove.
Removes the specified SeriesGrouping object from the SeriesGroupingCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As SeriesGrouping _
)
public void Remove(
   SeriesGrouping value
)

Parameters

value
The SeriesGrouping object to remove.
See Also

Reference

SeriesGroupingCollection Class
SeriesGroupingCollection Members


SeriesGroupingCollection Class Properties

SeriesGroupingCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SeriesGroupingCollection Class

For a list of all members of this type, see SeriesGroupingCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific SeriesGrouping object in the SeriesGroupingCollection by position.
Top
See Also

Reference

SeriesGroupingCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (SeriesGroupingCollection)

Item Property (SeriesGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGroupingCollection Class : Item Property
A zero-based Integer indicating the index of the SeriesGrouping to return or set.
Gets or sets a specific SeriesGrouping object in the SeriesGroupingCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As SeriesGrouping
public SeriesGrouping this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the SeriesGrouping to return or set.

Property Value

The SeriesGrouping object at the specified position.
See Also

Reference

SeriesGroupingCollection Class
SeriesGroupingCollection Members


Shape Class

Shape Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Shape Class
Represents the shape on the report.
Object Model
Shape Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Shape
   Inherits ShapeBase
   Implements IReportComponent
public sealed class Shape : ShapeBase, IReportComponent
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.Shape

See Also

Reference

Shape Members
GrapeCity.ActiveReports.PageReportModel Namespace


Shape Class Members

Shape Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Shape Class

The following tables list the members exposed by Shape.

Public Constructors
 | Name | Description
Public Constructor | Shape Constructor | Initializes a new instance of the Shape class.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the ReportItem object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Shape Class
GrapeCity.ActiveReports.PageReportModel Namespace


Shape Constructor

Shape Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Shape Class : Shape Constructor
Initializes a new instance of the Shape class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Shape()
See Also

Reference

Shape Class
Shape Members


SharedDataSet Class

SharedDataSet Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SharedDataSet Class
Represents a shared dataset.
Object Model
SharedDataSet Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class SharedDataSet
public sealed class SharedDataSet
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.SharedDataSet

See Also

Reference

SharedDataSet Members
GrapeCity.ActiveReports.PageReportModel Namespace


SharedDataSet Class Members

SharedDataSet Class Members
Fields Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SharedDataSet Class

The following tables list the members exposed by SharedDataSet.

Public Constructors
 | Name | Description
Public Constructor | SharedDataSet Constructor |
Top
Public Fields
 | Name | Description
Public Field | ReferencePrefix |
Top
Public Properties
 | Name | Description
Public Property | QueryParameters | Gets or sets a collection of query parameters.
Public Property | SharedDataSetReference | Gets or sets a reference to a shared dataset.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates this instance within the specified context.
Top
See Also

Reference

SharedDataSet Class
GrapeCity.ActiveReports.PageReportModel Namespace


SharedDataSet Constructor

SharedDataSet Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SharedDataSet Class : SharedDataSet Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public SharedDataSet()
See Also

Reference

SharedDataSet Class
SharedDataSet Members


SharedDataSet Class Methods

SharedDataSet Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SharedDataSet Class

For a list of all members of this type, see SharedDataSet members.

Public Methods
 | Name | Description
Public Method | Validate | Validates this instance within the specified context.
Top
See Also

Reference

SharedDataSet Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (SharedDataSet)

Validate Method (SharedDataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SharedDataSet Class : Validate Method
The context.
Validates this instance within the specified context.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The context.

Return Value

ValidationEntry[].
Exceptions
Exception | Description
System.ArgumentNullException | context
See Also

Reference

SharedDataSet Class
SharedDataSet Members


SharedDataSet Class Properties

SharedDataSet Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SharedDataSet Class

For a list of all members of this type, see SharedDataSet members.

Public Properties
 | Name | Description
Public Property | QueryParameters | Gets or sets a collection of query parameters.
Public Property | SharedDataSetReference | Gets or sets a reference to a shared dataset.
Top
See Also

Reference

SharedDataSet Class
GrapeCity.ActiveReports.PageReportModel Namespace


QueryParameters Property (SharedDataSet)

QueryParameters Property (SharedDataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SharedDataSet Class : QueryParameters Property
Gets or sets a collection of query parameters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property QueryParameters As QueryParameterCollection
public QueryParameterCollection QueryParameters {get;}
See Also

Reference

SharedDataSet Class
SharedDataSet Members


SharedDataSetReference Property

SharedDataSetReference Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SharedDataSet Class : SharedDataSetReference Property
Gets or sets a reference to a shared dataset.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SharedDataSetReference As System.String
public System.string SharedDataSetReference {get; set;}
See Also

Reference

SharedDataSet Class
SharedDataSet Members


SharedDataSet Class Fields

SharedDataSet Class Fields

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SharedDataSet Class

For a list of all members of this type, see SharedDataSet members.

Public Fields
 | Name | Description
Public Field | ReferencePrefix |
Top
See Also

Reference

SharedDataSet Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReferencePrefix Field

ReferencePrefix Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SharedDataSet Class : ReferencePrefix Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const ReferencePrefix As System.String
public const System.string ReferencePrefix
See Also

Reference

SharedDataSet Class
SharedDataSet Members


SortBy Class

SortBy Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SortBy Class
Specifies an element that defines an expression by which to sort the groups.
Object Model
SortBy Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class SortBy
public sealed class SortBy
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.SortBy

See Also

Reference

SortBy Members
GrapeCity.ActiveReports.PageReportModel Namespace


SortBy Class Members

SortBy Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SortBy Class

The following tables list the members exposed by SortBy.

Public Constructors
 | Name | Description
Public Constructor | SortBy Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Direction | Gets or sets the direction of the sort.
Public Property | SortExpression | Gets or sets an expression by which to sort the groups.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.SortBy object.
Top
See Also

Reference

SortBy Class
GrapeCity.ActiveReports.PageReportModel Namespace


SortBy Constructor

SortBy Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortBy Class : SortBy Constructor
Overload List
Overload | Description
SortBy Constructor() | Initializes a new default instance of the SortBy class.
SortBy Constructor(ExpressionInfo,SortByDirection) | Initializes a new instance of the SortBy class with the specified sort expression and direction.
See Also

Reference

SortBy Class
SortBy Members


SortBy Constructor()

SortBy Constructor()

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortBy Class > SortBy Constructor : SortBy Constructor()

Initializes a new default instance of the SortBy class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public SortBy()
See Also

Reference

SortBy Class
SortBy Members
Overload List


SortBy Constructor(ExpressionInfo,SortByDirection)

SortBy Constructor(ExpressionInfo,SortByDirection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortBy Class > SortBy Constructor : SortBy Constructor(ExpressionInfo,SortByDirection)
The initial value for the SortExpression property.
The initial value for the Direction property.

Initializes a new instance of the SortBy class with the specified sort expression and direction.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal sortExpression As ExpressionInfo, _
   ByVal direction As SortByDirection _
)
public SortBy(
   ExpressionInfo sortExpression,
   SortByDirection direction
)

Parameters

sortExpression
The initial value for the SortExpression property.
direction
The initial value for the Direction property.
See Also

Reference

SortBy Class
SortBy Members
Overload List


SortBy Class Methods

SortBy Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SortBy Class

For a list of all members of this type, see SortBy members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.SortBy object.
Top
See Also

Reference

SortBy Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (SortBy)

Validate Method (SortBy)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortBy Class : Validate Method
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.SortBy object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A DataDynamics.Reports.ReportObjectModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

SortBy Class
SortBy Members


SortBy Class Properties

SortBy Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SortBy Class

For a list of all members of this type, see SortBy members.

Public Properties
 | Name | Description
Public Property | Direction | Gets or sets the direction of the sort.
Public Property | SortExpression | Gets or sets an expression by which to sort the groups.
Top
See Also

Reference

SortBy Class
GrapeCity.ActiveReports.PageReportModel Namespace


Direction Property (SortBy)

Direction Property (SortBy)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortBy Class : Direction Property

Gets or sets the direction of the sort.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Direction As SortByDirection
public SortByDirection Direction {get; set;}

Property Value

A SortByDirection enumeration indicating the direction of the sort.

Remarks

The default value is Ascending

See Also

Reference

SortBy Class
SortBy Members


SortExpression Property (SortBy)

SortExpression Property (SortBy)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortBy Class : SortExpression Property

Gets or sets an expression by which to sort the groups.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SortExpression As ExpressionInfo
public ExpressionInfo SortExpression {get; set;}

Property Value

An ExpressionInfo object by which to sort the groups.

Remarks

The aggregate functions RunningValue and RowNumber are not allowed in a SortExpression.

References to report items are not allowed.

See Also

Reference

SortBy Class
SortBy Members


SortByCollection Class

SortByCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SortByCollection Class
Provides a strongly typed collection for SortBy objects.
Object Model
SortByCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class SortByCollection
   Inherits System.Collections.ObjectModel.Collection(Of SortBy)
public sealed class SortByCollection : System.Collections.ObjectModel.Collection<SortBy>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.SortByCollection

See Also

Reference

SortByCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


SortByCollection Class Members

SortByCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SortByCollection Class

The following tables list the members exposed by SortByCollection.

Public Constructors
 | Name | Description
Public Constructor | SortByCollection Constructor | Initializes a new instance of the SortByCollection class.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.ObjectModel.Collection<SortBy>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<SortBy>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<SortBy>)
Public Method | AddRange | Adds a SortByCollection to the existing SortByCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.ObjectModel.Collection<SortBy>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<SortBy>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<SortBy>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<SortBy>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<SortBy>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<SortBy>)
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.ObjectModel.Collection<SortBy>)
Public Method | ToArray | Copies the elements of the SortByCollection to a new array.
Top
See Also

Reference

SortByCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


SortByCollection Constructor

SortByCollection Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortByCollection Class : SortByCollection Constructor
Initializes a new instance of the SortByCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public SortByCollection()
See Also

Reference

SortByCollection Class
SortByCollection Members


SortByCollection Class Methods

SortByCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SortByCollection Class

For a list of all members of this type, see SortByCollection members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<SortBy>)
Public Method | AddRange | Adds a SortByCollection to the existing SortByCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.ObjectModel.Collection<SortBy>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<SortBy>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<SortBy>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<SortBy>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<SortBy>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<SortBy>)
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.ObjectModel.Collection<SortBy>)
Public Method | ToArray | Copies the elements of the SortByCollection to a new array.
Top
See Also

Reference

SortByCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


AddRange Method (SortByCollection)

AddRange Method (SortByCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortByCollection Class : AddRange Method
The sort by items to be added.
Adds a SortByCollection to the existing SortByCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddRange( _
   ByVal items As System.Collections.Generic.IEnumerable(Of SortBy) _
)
public void AddRange(
   System.Collections.Generic.IEnumerable<SortBy> items
)

Parameters

items
The sort by items to be added.
See Also

Reference

SortByCollection Class
SortByCollection Members


ToArray Method (SortByCollection)

ToArray Method (SortByCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortByCollection Class : ToArray Method
Copies the elements of the SortByCollection to a new array.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToArray() As SortBy()
public SortBy[] ToArray()

Return Value

An array of SortBy objects containing copies of the objects in the SortByCollection.
See Also

Reference

SortByCollection Class
SortByCollection Members


StaticMember Class

StaticMember Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticMember Class
Defines the data label to display for a static series or static category member.
Object Model
StaticMember Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class StaticMember
public sealed class StaticMember
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.StaticMember

See Also

Reference

StaticMember Members
GrapeCity.ActiveReports.PageReportModel Namespace


StaticMember Class Members

StaticMember Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticMember Class

The following tables list the members exposed by StaticMember.

Public Constructors
 | Name | Description
Public Constructor | StaticMember Constructor | Initializes a new instance of the StaticMember class.
Top
Public Properties
 | Name | Description
Public Property | Label | Gets or sets the label for the static member (displayed either on the category axis or in the legend, as appropriate).
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.StaticMember object.
Top
See Also

Reference

StaticMember Class
GrapeCity.ActiveReports.PageReportModel Namespace


StaticMember Constructor

StaticMember Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticMember Class : StaticMember Constructor

Initializes a new instance of the StaticMember class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public StaticMember()
See Also

Reference

StaticMember Class
StaticMember Members


StaticMember Class Methods

StaticMember Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticMember Class

For a list of all members of this type, see StaticMember members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.StaticMember object.
Top
See Also

Reference

StaticMember Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (StaticMember)

Validate Method (StaticMember)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticMember Class : Validate Method
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.StaticMember object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A DataDynamics.Reports.ReportObjectModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

StaticMember Class
StaticMember Members


StaticMember Class Properties

StaticMember Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticMember Class

For a list of all members of this type, see StaticMember members.

Public Properties
 | Name | Description
Public Property | Label | Gets or sets the label for the static member (displayed either on the category axis or in the legend, as appropriate).
Top
See Also

Reference

StaticMember Class
GrapeCity.ActiveReports.PageReportModel Namespace


Label Property (StaticMember)

Label Property (StaticMember)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticMember Class : Label Property

Gets or sets the label for the static member (displayed either on the category axis or in the legend, as appropriate).

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Label As ExpressionInfo
public ExpressionInfo Label {get; set;}

Property Value

An ExpressionInfo object indicating the label for the static member (displayed either on the category axis or in the legend, as appropriate).

See Also

Reference

StaticMember Class
StaticMember Members


StaticMemberCollection Class

StaticMemberCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticMemberCollection Class
Provides a strongly typed collection for StaticMember objects.
Object Model
StaticMemberCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class StaticMemberCollection
   Inherits System.Collections.CollectionBase
public sealed class StaticMemberCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.StaticMemberCollection

See Also

Reference

StaticMemberCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


StaticMemberCollection Class Members

StaticMemberCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticMemberCollection Class

The following tables list the members exposed by StaticMemberCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific StaticMember object in the StaticMemberCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a StaticMember object to the StaticMemberCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific StaticMember object in the StaticMemberCollection.
Public Method | Insert | Inserts a new StaticMember object into the StaticMemberCollection at the specified location.
Public Method | Remove | Removes the specified StaticMember object from the StaticMemberCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

StaticMemberCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


StaticMemberCollection Class Methods

StaticMemberCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticMemberCollection Class

For a list of all members of this type, see StaticMemberCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a StaticMember object to the StaticMemberCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific StaticMember object in the StaticMemberCollection.
Public Method | Insert | Inserts a new StaticMember object into the StaticMemberCollection at the specified location.
Public Method | Remove | Removes the specified StaticMember object from the StaticMemberCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

StaticMemberCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (StaticMemberCollection)

Add Method (StaticMemberCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticMemberCollection Class : Add Method
The StaticMember object to add to the collection.
Adds a StaticMember object to the StaticMemberCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As StaticMember _
) As System.Integer
public System.int Add(
   StaticMember value
)

Parameters

value
The StaticMember object to add to the collection.

Return Value

A new StaticMember object.
See Also

Reference

StaticMemberCollection Class
StaticMemberCollection Members


IndexOf Method (StaticMemberCollection)

IndexOf Method (StaticMemberCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticMemberCollection Class : IndexOf Method
The StaticMember object to locate in the StaticMemberCollection.
Determines the index of a specific StaticMember object in the StaticMemberCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As StaticMember _
) As System.Integer
public System.int IndexOf(
   StaticMember value
)

Parameters

value
The StaticMember object to locate in the StaticMemberCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

StaticMemberCollection Class
StaticMemberCollection Members


Insert Method (StaticMemberCollection)

Insert Method (StaticMemberCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticMemberCollection Class : Insert Method
A zero-based Integer index indicating the position at which to insert the StaticMember object.
The StaticMember object to insert.
Inserts a new StaticMember object into the StaticMemberCollection at the specified location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As StaticMember _
)
public void Insert(
   System.int index,
   StaticMember value
)

Parameters

index
A zero-based Integer index indicating the position at which to insert the StaticMember object.
value
The StaticMember object to insert.
See Also

Reference

StaticMemberCollection Class
StaticMemberCollection Members


Remove Method (StaticMemberCollection)

Remove Method (StaticMemberCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticMemberCollection Class : Remove Method
The StaticMember object to remove.
Removes the specified StaticMember object from the StaticMemberCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As StaticMember _
)
public void Remove(
   StaticMember value
)

Parameters

value
The StaticMember object to remove.
See Also

Reference

StaticMemberCollection Class
StaticMemberCollection Members


StaticMemberCollection Class Properties

StaticMemberCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticMemberCollection Class

For a list of all members of this type, see StaticMemberCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific StaticMember object in the StaticMemberCollection by position.
Top
See Also

Reference

StaticMemberCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (StaticMemberCollection)

Item Property (StaticMemberCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticMemberCollection Class : Item Property
A zero-based Integer indicating the index of the StaticMember object to return or set.
Gets or sets a specific StaticMember object in the StaticMemberCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As StaticMember
public StaticMember this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the StaticMember object to return or set.

Property Value

The StaticMember object at the specified position.
See Also

Reference

StaticMemberCollection Class
StaticMemberCollection Members


StaticRowColumn Class

StaticRowColumn Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticRowColumn Class
Defines a column or row header region with a fixed set of columns or rows.
Object Model
StaticRowColumn Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class StaticRowColumn
   Inherits ReportComponentContainer
   Implements IRdlContainer, IReportComponent, IReportComponentContainer
public sealed class StaticRowColumn : ReportComponentContainer, IRdlContainer, IReportComponent, IReportComponentContainer
Remarks

Only one ColumnGrouping in each matrix may be static.

Only one RowGrouping in each matrix may be static.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer
GrapeCity.ActiveReports.PageReportModel.StaticRowColumn

See Also

Reference

StaticRowColumn Members
GrapeCity.ActiveReports.PageReportModel Namespace


StaticRowColumn Class Members

StaticRowColumn Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticRowColumn Class

The following tables list the members exposed by StaticRowColumn.

Public Constructors
 | Name | Description
Public Constructor | StaticRowColumn Constructor | Initializes a new instance of the StaticRowColumn class.
Top
Public Properties
 | Name | Description
Public Property | Components | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportComponentCollection containing all the ReportComponents in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportItems | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportItemCollection containing all the ReportItems in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.StaticRowColumn object.
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

StaticRowColumn Class
GrapeCity.ActiveReports.PageReportModel Namespace


StaticRowColumn Constructor

StaticRowColumn Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticRowColumn Class : StaticRowColumn Constructor

Initializes a new instance of the StaticRowColumn class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public StaticRowColumn()
See Also

Reference

StaticRowColumn Class
StaticRowColumn Members


StaticRowColumn Class Methods

StaticRowColumn Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticRowColumn Class

For a list of all members of this type, see StaticRowColumn members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.StaticRowColumn object.
Top
See Also

Reference

StaticRowColumn Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (StaticRowColumn)

Validate Method (StaticRowColumn)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticRowColumn Class : Validate Method
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.StaticRowColumn object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A DataDynamics.Reports.ReportObjectModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

StaticRowColumn Class
StaticRowColumn Members


StaticRowColumnCollection Class

StaticRowColumnCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticRowColumnCollection Class
Provides a strongly typed collection for StaticRowColumn objects.
Object Model
StaticRowColumnCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class StaticRowColumnCollection
   Inherits System.Collections.CollectionBase
public sealed class StaticRowColumnCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.StaticRowColumnCollection

See Also

Reference

StaticRowColumnCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


StaticRowColumnCollection Class Members

StaticRowColumnCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticRowColumnCollection Class

The following tables list the members exposed by StaticRowColumnCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific StaticRowColumn object in the StaticRowColumnCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a StaticRowColumn object to the StaticRowColumnCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific StaticRowColumn object in the StaticRowColumnCollection.
Public Method | Insert | Inserts a new StaticRowColumn into the StaticRowColumnCollection at the specified location.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

StaticRowColumnCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


StaticRowColumnCollection Class Methods

StaticRowColumnCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticRowColumnCollection Class

For a list of all members of this type, see StaticRowColumnCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a StaticRowColumn object to the StaticRowColumnCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific StaticRowColumn object in the StaticRowColumnCollection.
Public Method | Insert | Inserts a new StaticRowColumn into the StaticRowColumnCollection at the specified location.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

StaticRowColumnCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (StaticRowColumnCollection)

Add Method (StaticRowColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticRowColumnCollection Class : Add Method
The StaticRowColumn object to add to the collection.
Adds a StaticRowColumn object to the StaticRowColumnCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As StaticRowColumn _
) As System.Integer
public System.int Add(
   StaticRowColumn value
)

Parameters

value
The StaticRowColumn object to add to the collection.

Return Value

A new StaticRowColumn object.
See Also

Reference

StaticRowColumnCollection Class
StaticRowColumnCollection Members


IndexOf Method (StaticRowColumnCollection)

IndexOf Method (StaticRowColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticRowColumnCollection Class : IndexOf Method
The StaticRowColumn object to locate in the StaticRowColumnCollection.
Determines the index of a specific StaticRowColumn object in the StaticRowColumnCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As StaticRowColumn _
) As System.Integer
public System.int IndexOf(
   StaticRowColumn value
)

Parameters

value
The StaticRowColumn object to locate in the StaticRowColumnCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

StaticRowColumnCollection Class
StaticRowColumnCollection Members


Insert Method (StaticRowColumnCollection)

Insert Method (StaticRowColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticRowColumnCollection Class : Insert Method
A zero-based Integer index indicating the position at which to insert the StaticRowColumn object.
The StaticRowColumn object to insert.
Inserts a new StaticRowColumn into the StaticRowColumnCollection at the specified location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As StaticRowColumn _
)
public void Insert(
   System.int index,
   StaticRowColumn value
)

Parameters

index
A zero-based Integer index indicating the position at which to insert the StaticRowColumn object.
value
The StaticRowColumn object to insert.
See Also

Reference

StaticRowColumnCollection Class
StaticRowColumnCollection Members


StaticRowColumnCollection Class Properties

StaticRowColumnCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticRowColumnCollection Class

For a list of all members of this type, see StaticRowColumnCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific StaticRowColumn object in the StaticRowColumnCollection by position.
Top
See Also

Reference

StaticRowColumnCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (StaticRowColumnCollection)

Item Property (StaticRowColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticRowColumnCollection Class : Item Property
A zero-based Integer indicating the index of the StaticRowColumn object to return or set.
Gets or sets a specific StaticRowColumn object in the StaticRowColumnCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As StaticRowColumn
public StaticRowColumn this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the StaticRowColumn object to return or set.

Property Value

The StaticRowColumn object at the specified position.
See Also

Reference

StaticRowColumnCollection Class
StaticRowColumnCollection Members


Style Class

Style Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Style Class
The Style element contains information about the style of a report control. Where possible, the style property names and values match standard HTML/CSS properties. All expression-based Style elements evaluate to either the type listed or to Nothing (an error in evaluation is treated as Nothing). Nothing is equivalent to not specifying the style, thereby indicating that it uses the default value. The expression must evaluate to a Boolean value for Boolean properties, an enumerated value for enum properties, an integer for integer properties and a (formatted) string for all other properties.
Object Model
Style Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Style
public sealed class Style
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Style

See Also

Reference

Style Members
GrapeCity.ActiveReports.PageReportModel Namespace


Style Class Members

Style Class Members
Fields Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Style Class

The following tables list the members exposed by Style.

Public Constructors
 | Name | Description
Public Constructor | Style Constructor | Overloaded.
Top
Public Fields
 | Name | Description
Public Field | AngleDefault |
Public Field | BackgroundColorDefault |
Public Field | BackgroundGradientEndColorDefault |
Public Field | BackgroundGradientTypeDefault |
Public Field | BackgroundImageSourceDefault |
Public Field | BorderColorDefault |
Public Field | BorderStyleDefault |
Public Field | BorderWidthDefault |
Public Field | CharacterSpacingDefault |
Public Field | ColorDefault |
static (Shared in Visual Basic) | DefaultStyle | Global default Style object.
Public Field | DirectionDefault |
Public Field | FontFamilyDefault |
Public Field | FontSizeDefault |
Public Field | FontStyleDefault |
Public Field | FontWeightDefault |
Public Field | HeadingLevelDefault |
Public Field | InheritedValue |
Public Field | LabelExpressionDefault |
Public Field | LeadingCharDefault |
Public Field | MaxLevelDefault |
static (Shared in Visual Basic) | MinTextIndent |
Public Field | NumberingStyleDefault |
Public Field | ShadowOffsetDefault |
Public Field | ShrinkToFitDefault |
Public Field | TextAlignDefault |
Public Field | TextDecorationDefault |
Public Field | TextIndentDefault |
Public Field | VerticalAlignDefault |
Public Field | WrapModeDefault |
Public Field | WritingModeDefault |
Top
Public Properties
 | Name | Description
Public Property | Angle |
Public Property | BackgroundColor |
Public Property | BackgroundGradientEndColor | Gets or sets the end color for the background gradient.
Public Property | BackgroundGradientType | Gets or sets the gradient type of the background.
Public Property | BackgroundHatchType | Enum of BackgroundHatchTypes The Style.BackgroundHatchType element specifies the hatching pattern of a report item. This element is optional.
Public Property | BackgroundImage | Gets the background image for the report item.
Public Property | Border | Specifies the border properties.
Public Property | BorderColor | Gets the color of the border.
Public Property | BorderStyle | Gets the style of the border.
Public Property | BorderWidth | Gets the width of the border.
Public Property | BottomBorder | Specifies the bottom border properties.
Public Property | Calendar | Specifies the calendar.
Public Property | CharacterSpacing | Space between characters
Public Property | Color | Gets or sets the foreground or text color.
Public Property | Direction | Specifies the direction.
Public Property | FontFamily | Gets or sets the name of the font family.
Public Property | FontSize | Gets or sets the point size of the font.
Public Property | FontStyle | Gets or sets the font style.
Public Property | FontWeight | Gets or sets the thickness of the font.
Public Property | Format | Gets or sets a .NET Framework formatting string.
Public Property | HeadingLevel |
Public Property | LabelExpression |
Public Property | Language | Specifies the language.
Public Property | LeadingChar |
Public Property | LeftBorder | Specifies the left border properties.
Public Property | LineHeight | Specifies the line height.
Public Property | LineSpacing | Space between lines
Public Property | MaxLevel |
Public Property | Name | Gets or sets element name
Public Property | NumberingStyle |
Public Property | NumeralLanguage | Specifies the numeral language.
Public Property | NumeralVariant | Gets or sets the variant of the digit format to use.
Public Property | PaddingBottom | Specifies the bottom padding
Public Property | PaddingLeft | Gets or sets the amount of padding between the left edge of the report item and its contents.
Public Property | PaddingRight | Gets or sets the amount of padding between the right edge of the report item and its contents.
Public Property | PaddingTop | Gets or sets the amount of padding between the top edge of the report item and its contents.
Public Property | ParentStyle | Gets or sets element parent
Public Property | RightBorder | Specifies the right border properties.
Public Property | ShadowOffset | Specifies the shadow offset.
Public Property | ShrinkToFit |
Public Property | StyleName | Gets or set element style name.
Public Property | TextAlign | Gets or sets the horizontal alignment of the text.
Public Property | TextDecoration | Gets or sets special text formatting.
Public Property | TextIndent |
Public Property | TextJustify | Gets the text justification setting.
Public Property | TopBorder | Specifies the top border properties.
Public Property | Type |
Public Property | UnicodeBiDi | Specifies the unicode bi di.
Public Property | VerticalAlign | Gets or sets the vertical alignment of the text.
Public Property | WrapMode | Wrap mode
Public Property | WritingMode | Specifies the writing mode.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateDefaultStyle | Returns a new Style object with default values.
Public Method | Equals | Compares two style instances.
Public Method | GetExpressions | Returns list of inner expressions of style.
Public Method | GetHashCode |
static (Shared in Visual Basic) | Merge | Merges given report element style with extrenal style from stylesheet.
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.Style object.
Top
See Also

Reference

Style Class
GrapeCity.ActiveReports.PageReportModel Namespace


Style Constructor

Style Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Style Constructor
Overload List
Overload | Description
Style Constructor() | Initializes a new instance of the Style class.
Style Constructor(String,Style,StyleType) | Initializes a new instance of the Style class.
See Also

Reference

Style Class
Style Members


Style Constructor()

Style Constructor()

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class > Style Constructor : Style Constructor()
Initializes a new instance of the Style class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Style()
See Also

Reference

Style Class
Style Members
Overload List


Style Constructor(String,Style,StyleType)

Style Constructor(String,Style,StyleType)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class > Style Constructor : Style Constructor(String,Style,StyleType)
Initializes a new instance of the Style class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As System.String, _
   ByVal parent As Style, _
   ByVal type As StyleType _
)
public Style(
   System.string name,
   Style parent,
   StyleType type
)

Parameters

name
parent
type
See Also

Reference

Style Class
Style Members
Overload List


Style Class Methods

Style Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Style Class

For a list of all members of this type, see Style members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateDefaultStyle | Returns a new Style object with default values.
Public Method | Equals | Compares two style instances.
Public Method | GetExpressions | Returns list of inner expressions of style.
Public Method | GetHashCode |
static (Shared in Visual Basic) | Merge | Merges given report element style with extrenal style from stylesheet.
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.Style object.
Top
See Also

Reference

Style Class
GrapeCity.ActiveReports.PageReportModel Namespace


CreateDefaultStyle Method

CreateDefaultStyle Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : CreateDefaultStyle Method
Returns a new Style object with default values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function CreateDefaultStyle() As Style
public static Style CreateDefaultStyle()

Return Value

New Style object with default values.
See Also

Reference

Style Class
Style Members


Equals Method (Style)

Equals Method (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Equals Method
Compares two style instances.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
See Also

Reference

Style Class
Style Members


GetExpressions Method (Style)

GetExpressions Method (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : GetExpressions Method
Returns list of inner expressions of style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetExpressions() As ExpressionInfo()
public ExpressionInfo[] GetExpressions()
See Also

Reference

Style Class
Style Members


GetHashCode Method (Style)

GetHashCode Method (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()
See Also

Reference

Style Class
Style Members


Merge Method (Style)

Merge Method (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Merge Method
Style of report element.
External style obtained from stylesheet. Default style will be used if this parameter is null .
Merges given report element style with extrenal style from stylesheet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function Merge( _
   ByVal local As Style, _
   ByVal external As Style _
) As Style
public static Style Merge(
   Style local,
   Style external
)

Parameters

local
Style of report element.
external
External style obtained from stylesheet. Default style will be used if this parameter is null .
See Also

Reference

Style Class
Style Members


Validate Method (Style)

Validate Method (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Validate Method
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.Style object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A DataDynamics.Reports.ReportObjectModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

Style Class
Style Members


Style Class Properties

Style Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Style Class

For a list of all members of this type, see Style members.

Public Properties
 | Name | Description
Public Property | Angle |
Public Property | BackgroundColor |
Public Property | BackgroundGradientEndColor | Gets or sets the end color for the background gradient.
Public Property | BackgroundGradientType | Gets or sets the gradient type of the background.
Public Property | BackgroundHatchType | Enum of BackgroundHatchTypes The Style.BackgroundHatchType element specifies the hatching pattern of a report item. This element is optional.
Public Property | BackgroundImage | Gets the background image for the report item.
Public Property | Border | Specifies the border properties.
Public Property | BorderColor | Gets the color of the border.
Public Property | BorderStyle | Gets the style of the border.
Public Property | BorderWidth | Gets the width of the border.
Public Property | BottomBorder | Specifies the bottom border properties.
Public Property | Calendar | Specifies the calendar.
Public Property | CharacterSpacing | Space between characters
Public Property | Color | Gets or sets the foreground or text color.
Public Property | Direction | Specifies the direction.
Public Property | FontFamily | Gets or sets the name of the font family.
Public Property | FontSize | Gets or sets the point size of the font.
Public Property | FontStyle | Gets or sets the font style.
Public Property | FontWeight | Gets or sets the thickness of the font.
Public Property | Format | Gets or sets a .NET Framework formatting string.
Public Property | HeadingLevel |
Public Property | LabelExpression |
Public Property | Language | Specifies the language.
Public Property | LeadingChar |
Public Property | LeftBorder | Specifies the left border properties.
Public Property | LineHeight | Specifies the line height.
Public Property | LineSpacing | Space between lines
Public Property | MaxLevel |
Public Property | Name | Gets or sets element name
Public Property | NumberingStyle |
Public Property | NumeralLanguage | Specifies the numeral language.
Public Property | NumeralVariant | Gets or sets the variant of the digit format to use.
Public Property | PaddingBottom | Specifies the bottom padding
Public Property | PaddingLeft | Gets or sets the amount of padding between the left edge of the report item and its contents.
Public Property | PaddingRight | Gets or sets the amount of padding between the right edge of the report item and its contents.
Public Property | PaddingTop | Gets or sets the amount of padding between the top edge of the report item and its contents.
Public Property | ParentStyle | Gets or sets element parent
Public Property | RightBorder | Specifies the right border properties.
Public Property | ShadowOffset | Specifies the shadow offset.
Public Property | ShrinkToFit |
Public Property | StyleName | Gets or set element style name.
Public Property | TextAlign | Gets or sets the horizontal alignment of the text.
Public Property | TextDecoration | Gets or sets special text formatting.
Public Property | TextIndent |
Public Property | TextJustify | Gets the text justification setting.
Public Property | TopBorder | Specifies the top border properties.
Public Property | Type |
Public Property | UnicodeBiDi | Specifies the unicode bi di.
Public Property | VerticalAlign | Gets or sets the vertical alignment of the text.
Public Property | WrapMode | Wrap mode
Public Property | WritingMode | Specifies the writing mode.
Top
See Also

Reference

Style Class
GrapeCity.ActiveReports.PageReportModel Namespace


Angle Property (Style)

Angle Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Angle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Angle As ExpressionInfo
public ExpressionInfo Angle {get; set;}
See Also

Reference

Style Class
Style Members


BackgroundColor Property (Style)

BackgroundColor Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BackgroundColor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackgroundColor As ExpressionInfo
public ExpressionInfo BackgroundColor {get; set;}
See Also

Reference

Style Class
Style Members


BackgroundGradientEndColor Property (Style)

BackgroundGradientEndColor Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BackgroundGradientEndColor Property
Gets or sets the end color for the background gradient.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackgroundGradientEndColor As ExpressionInfo
public ExpressionInfo BackgroundGradientEndColor {get; set;}
Remarks
If this value is omitted, there is no gradient.
See Also

Reference

Style Class
Style Members


BackgroundGradientType Property (Style)

BackgroundGradientType Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BackgroundGradientType Property
Gets or sets the gradient type of the background.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackgroundGradientType As ExpressionInfo
public ExpressionInfo BackgroundGradientType {get; set;}
See Also

Reference

Style Class
Style Members


BackgroundHatchType Property

BackgroundHatchType Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BackgroundHatchType Property
Enum of BackgroundHatchTypes The Style.BackgroundHatchType element specifies the hatching pattern of a report item. This element is optional.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackgroundHatchType As ExpressionInfo
public ExpressionInfo BackgroundHatchType {get; set;}
See Also

Reference

Style Class
Style Members


BackgroundImage Property (Style)

BackgroundImage Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BackgroundImage Property
Gets the background image for the report item.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property BackgroundImage As BackgroundImage
public BackgroundImage BackgroundImage {get;}
Remarks
If omitted, there is no background image.
See Also

Reference

Style Class
Style Members


Border Property (Style)

Border Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Border Property
Specifies the border properties.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Border As Border
public Border Border {get; set;}
See Also

Reference

Style Class
Style Members


BorderColor Property (Style)

BorderColor Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BorderColor Property
Gets the color of the border.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property BorderColor As BorderColor
public BorderColor BorderColor {get;}
See Also

Reference

Style Class
Style Members


BorderStyle Property (Style)

BorderStyle Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BorderStyle Property

Gets the style of the border.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property BorderStyle As BorderStyle
public BorderStyle BorderStyle {get;}

Property Value

A BorderStyle object representing the border style.

See Also

Reference

Style Class
Style Members


BorderWidth Property (Style)

BorderWidth Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BorderWidth Property

Gets the width of the border.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property BorderWidth As BorderWidth
public BorderWidth BorderWidth {get;}

Property Value

A BorderWidth object representing the border width.

See Also

Reference

Style Class
Style Members


BottomBorder Property

BottomBorder Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BottomBorder Property
Specifies the bottom border properties.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BottomBorder As Border
public Border BottomBorder {get; set;}
See Also

Reference

Style Class
Style Members


Calendar Property (Style)

Calendar Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Calendar Property
Specifies the calendar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Calendar As ExpressionInfo
public ExpressionInfo Calendar {get; set;}
See Also

Reference

Style Class
Style Members


CharacterSpacing Property (Style)

CharacterSpacing Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : CharacterSpacing Property
Space between characters
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CharacterSpacing As ExpressionInfo
public ExpressionInfo CharacterSpacing {get; set;}
See Also

Reference

Style Class
Style Members


Color Property (Style)

Color Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Color Property

Gets or sets the foreground or text color.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Color As ExpressionInfo
public ExpressionInfo Color {get; set;}

Property Value

An ExpressionInfo that evaluates to the foreground color.

Remarks
The default value is Black.
See Also

Reference

Style Class
Style Members


Direction Property (Style)

Direction Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Direction Property
Specifies the direction.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Direction As ExpressionInfo
public ExpressionInfo Direction {get; set;}
See Also

Reference

Style Class
Style Members


FontFamily Property (Style)

FontFamily Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : FontFamily Property

Gets or sets the name of the font family.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontFamily As ExpressionInfo
public ExpressionInfo FontFamily {get; set;}

Property Value

An ExpressionInfo that evaluates to a string containing the name of the font family.

See Also

Reference

Style Class
Style Members


FontSize Property (Style)

FontSize Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : FontSize Property

Gets or sets the point size of the font.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontSize As ExpressionInfo
public ExpressionInfo FontSize {get; set;}

Property Value

An ExpressionInfo that evaluates to a GrapeCity.ActiveReports.Extensibility.Definition.Components.Length containing the point size of the font.

Remarks
The default value is 10pt. The minimum value is 1pt, and the maximum value is 200pt.
See Also

Reference

Style Class
Style Members


FontStyle Property (Style)

FontStyle Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : FontStyle Property
Gets or sets the font style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontStyle As ExpressionInfo
public ExpressionInfo FontStyle {get; set;}
See Also

Reference

Style Class
Style Members


FontWeight Property (Style)

FontWeight Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : FontWeight Property

Gets or sets the thickness of the font.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontWeight As ExpressionInfo
public ExpressionInfo FontWeight {get; set;}

Property Value

An ExpressionInfo object that evaluates to a FontWeight enumeration or a number between 100 and 900 indicating the thickness of the font. Valid values are listed in the table below.

FontWeight | Description
Light | A light font weight with a numeric value of 300.
Normal (Default) | A normal font weight with a numeric value of 400.
Medium | A medium font weight with a numeric value of 500.
Semibold | A semi-bold font weight with a numeric value of 600.
Bold | A bold font weight with a numeric value of 700.
Extrabold | An extra-bold font weight with a numeric value of 800.
Heavy | The heaviest possible font weight with a numeric value of 900.
Bolder | Selects the next value that is darker than the inherited value.
See Also

Reference

Style Class
Style Members


Format Property (Style)

Format Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Format Property

Gets or sets a .NET Framework formatting string.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Format As ExpressionInfo
public ExpressionInfo Format {get; set;}

Property Value

An ExpressionInfo that evaluates to a .NET Framework formatting string.

Remarks

Locale-dependent currency formatting (format code "C") is based on the language setting of the report item.

Locale-dependent date formatting is supported and is based on the language property of the ReportItem.

See Also

Reference

Style Class
Style Members


HeadingLevel Property (Style)

HeadingLevel Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : HeadingLevel Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HeadingLevel As ExpressionInfo
public ExpressionInfo HeadingLevel {get; set;}
See Also

Reference

Style Class
Style Members


LabelExpression Property (Style)

LabelExpression Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : LabelExpression Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LabelExpression As ExpressionInfo
public ExpressionInfo LabelExpression {get; set;}
See Also

Reference

Style Class
Style Members


Language Property (Style)

Language Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Language Property
Specifies the language.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Language As ExpressionInfo
public ExpressionInfo Language {get; set;}
See Also

Reference

Style Class
Style Members


LeadingChar Property (Style)

LeadingChar Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : LeadingChar Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LeadingChar As ExpressionInfo
public ExpressionInfo LeadingChar {get; set;}
See Also

Reference

Style Class
Style Members


LeftBorder Property

LeftBorder Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : LeftBorder Property
Specifies the left border properties.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LeftBorder As Border
public Border LeftBorder {get; set;}
See Also

Reference

Style Class
Style Members


LineHeight Property (Style)

LineHeight Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : LineHeight Property
Specifies the line height.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineHeight As ExpressionInfo
public ExpressionInfo LineHeight {get; set;}
See Also

Reference

Style Class
Style Members


LineSpacing Property (Style)

LineSpacing Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : LineSpacing Property
Space between lines
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineSpacing As ExpressionInfo
public ExpressionInfo LineSpacing {get; set;}
See Also

Reference

Style Class
Style Members


MaxLevel Property (Style)

MaxLevel Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : MaxLevel Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaxLevel As ExpressionInfo
public ExpressionInfo MaxLevel {get; set;}
See Also

Reference

Style Class
Style Members


Name Property (Style)

Name Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Name Property
Gets or sets element name
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}
See Also

Reference

Style Class
Style Members


NumberingStyle Property (Style)

NumberingStyle Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : NumberingStyle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NumberingStyle As ExpressionInfo
public ExpressionInfo NumberingStyle {get; set;}
See Also

Reference

Style Class
Style Members


NumeralLanguage Property (Style)

NumeralLanguage Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : NumeralLanguage Property
Specifies the numeral language.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NumeralLanguage As ExpressionInfo
public ExpressionInfo NumeralLanguage {get; set;}
See Also

Reference

Style Class
Style Members


NumeralVariant Property (Style)

NumeralVariant Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : NumeralVariant Property

Gets or sets the variant of the digit format to use.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NumeralVariant As ExpressionInfo
public ExpressionInfo NumeralVariant {get; set;}

Property Value

An integer ExpressionInfo object that evaluates to the variant of the digit format to use.

Remarks

Currently defined values are:

Value | Description
1 | Default, follow Unicode context rules
2 | 0123456789
3 | Traditional digits for the script as defined in GDI+. Currently supports: ar|bn|bo|fa|gu|hi|kn|kok|lo|mr|ms|or|pa|sa|ta|te|th|ur and variants.
4 | ko, ja, zh-CHS, zh-CHT only
5 | ko, ja, zh-CHS, zh-CHT only
6 | ko, ja, zh-CHS, zh-CHT only (Wide versions of regular digits)
7 | ko only
See Also

Reference

Style Class
Style Members


PaddingBottom Property (Style)

PaddingBottom Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : PaddingBottom Property
Specifies the bottom padding
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaddingBottom As ExpressionInfo
public ExpressionInfo PaddingBottom {get; set;}
See Also

Reference

Style Class
Style Members


PaddingLeft Property (Style)

PaddingLeft Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : PaddingLeft Property

Gets or sets the amount of padding between the left edge of the report item and its contents.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaddingLeft As ExpressionInfo
public ExpressionInfo PaddingLeft {get; set;}

Property Value

A Length ExpressionInfo that evaluates to the padding between the left edge of the report item and its contents.

Remarks

The default value is 0pt. The maximum value is 1000pt.

As both borders and padding are measured from the edge of the object, borders may overlap the contents of report items unless there is sufficient padding.

See Also

Reference

Style Class
Style Members


PaddingRight Property (Style)

PaddingRight Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : PaddingRight Property

Gets or sets the amount of padding between the right edge of the report item and its contents.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaddingRight As ExpressionInfo
public ExpressionInfo PaddingRight {get; set;}

Property Value

A Length ExpressionInfo object that evaluates to the padding between the right edge of the report item and its contents.

Remarks

The default value is 0pt. The maximum value is 1000pt.

As both borders and padding are measured from the edge of the object, borders may overlap the contents of report items unless there is sufficient padding.

See Also

Reference

Style Class
Style Members


PaddingTop Property (Style)

PaddingTop Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : PaddingTop Property

Gets or sets the amount of padding between the top edge of the report item and its contents.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaddingTop As ExpressionInfo
public ExpressionInfo PaddingTop {get; set;}

Property Value

A Length ExpressionInfo object that evaluates to the padding between the top edge of the report item and its contents.

Remarks

The default value is 0pt. The maximum value is 1000pt.

As both borders and padding are measured from the edge of the object, borders may overlap the contents of report items unless there is sufficient padding.

See Also

Reference

Style Class
Style Members


ParentStyle Property

ParentStyle Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : ParentStyle Property
Gets or sets element parent
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ParentStyle As Style
public Style ParentStyle {get; set;}
See Also

Reference

Style Class
Style Members


RightBorder Property

RightBorder Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : RightBorder Property
Specifies the right border properties.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RightBorder As Border
public Border RightBorder {get; set;}
See Also

Reference

Style Class
Style Members


ShadowOffset Property (Style)

ShadowOffset Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : ShadowOffset Property
Specifies the shadow offset.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShadowOffset As ExpressionInfo
public ExpressionInfo ShadowOffset {get; set;}
See Also

Reference

Style Class
Style Members


ShrinkToFit Property (Style)

ShrinkToFit Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : ShrinkToFit Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShrinkToFit As ExpressionInfo
public ExpressionInfo ShrinkToFit {get; set;}
See Also

Reference

Style Class
Style Members


StyleName Property (Style)

StyleName Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : StyleName Property
Gets or set element style name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StyleName As ExpressionInfo
public ExpressionInfo StyleName {get; set;}
See Also

Reference

Style Class
Style Members


TextAlign Property (Style)

TextAlign Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : TextAlign Property

Gets or sets the horizontal alignment of the text.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TextAlign As ExpressionInfo
public ExpressionInfo TextAlign {get; set;}

Property Value

An ExpressionInfo object that evaluates to a TextAlign enumeration indicating the horizontal alignment of the text. Valid values are listed in the table below.

TextAlign | Description
General | The alignment is based on the content type.
Left | Text is aligned to the left.
Center | Text is centered in the control.
Right | Text is aligned to the right.
See Also

Reference

Style Class
Style Members


TextDecoration Property (Style)

TextDecoration Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : TextDecoration Property

Gets or sets special text formatting.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TextDecoration As ExpressionInfo
public ExpressionInfo TextDecoration {get; set;}

Property Value

An ExpressionInfo object that evaluates to a TextDecoration enumeration indicating the special text formatting. Valid values are listed in the table below.

TextDecoration | Description
None | No special formatting is used.
Underline | Text is rendered with a line below it.
Overline | Text is rendered with a line above it.
LineThrough | Text is rendered with a line through it.
See Also

Reference

Style Class
Style Members


TextIndent Property (Style)

TextIndent Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : TextIndent Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TextIndent As ExpressionInfo
public ExpressionInfo TextIndent {get; set;}
See Also

Reference

Style Class
Style Members


TextJustify Property (Style)

TextJustify Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : TextJustify Property
Gets the text justification setting.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TextJustify As ExpressionInfo
public ExpressionInfo TextJustify {get; set;}
See Also

Reference

Style Class
Style Members


TopBorder Property

TopBorder Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : TopBorder Property
Specifies the top border properties.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TopBorder As Border
public Border TopBorder {get; set;}
See Also

Reference

Style Class
Style Members


Type Property (Style)

Type Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : Type Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Type As StyleType
public StyleType Type {get;}
See Also

Reference

Style Class
Style Members


UnicodeBiDi Property

UnicodeBiDi Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : UnicodeBiDi Property
Specifies the unicode bi di.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UnicodeBiDi As ExpressionInfo
public ExpressionInfo UnicodeBiDi {get; set;}
See Also

Reference

Style Class
Style Members


VerticalAlign Property (Style)

VerticalAlign Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : VerticalAlign Property

Gets or sets the vertical alignment of the text.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property VerticalAlign As ExpressionInfo
public ExpressionInfo VerticalAlign {get; set;}

Property Value

An ExpressionInfo object that evaluates to a VerticalAlign enumeration indicating the vertical alignment of the text. Valid values are listed in the table below.

VerticalAlign | Description
Top | Text is aligned to the top.
Middle | Text is centered in the control.
Bottom | Text is aligned to the bottom.
See Also

Reference

Style Class
Style Members


WrapMode Property (Style)

WrapMode Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : WrapMode Property
Wrap mode
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WrapMode As ExpressionInfo
public ExpressionInfo WrapMode {get; set;}
See Also

Reference

Style Class
Style Members


WritingMode Property (Style)

WritingMode Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : WritingMode Property
Specifies the writing mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WritingMode As ExpressionInfo
public ExpressionInfo WritingMode {get; set;}
See Also

Reference

Style Class
Style Members


Style Class Fields

Style Class Fields

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Style Class

For a list of all members of this type, see Style members.

Public Fields
 | Name | Description
Public Field | AngleDefault |
Public Field | BackgroundColorDefault |
Public Field | BackgroundGradientEndColorDefault |
Public Field | BackgroundGradientTypeDefault |
Public Field | BackgroundImageSourceDefault |
Public Field | BorderColorDefault |
Public Field | BorderStyleDefault |
Public Field | BorderWidthDefault |
Public Field | CharacterSpacingDefault |
Public Field | ColorDefault |
static (Shared in Visual Basic) | DefaultStyle | Global default Style object.
Public Field | DirectionDefault |
Public Field | FontFamilyDefault |
Public Field | FontSizeDefault |
Public Field | FontStyleDefault |
Public Field | FontWeightDefault |
Public Field | HeadingLevelDefault |
Public Field | InheritedValue |
Public Field | LabelExpressionDefault |
Public Field | LeadingCharDefault |
Public Field | MaxLevelDefault |
static (Shared in Visual Basic) | MinTextIndent |
Public Field | NumberingStyleDefault |
Public Field | ShadowOffsetDefault |
Public Field | ShrinkToFitDefault |
Public Field | TextAlignDefault |
Public Field | TextDecorationDefault |
Public Field | TextIndentDefault |
Public Field | VerticalAlignDefault |
Public Field | WrapModeDefault |
Public Field | WritingModeDefault |
Top
See Also

Reference

Style Class
GrapeCity.ActiveReports.PageReportModel Namespace


AngleDefault Field

AngleDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : AngleDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const AngleDefault As System.String
public const System.string AngleDefault
See Also

Reference

Style Class
Style Members


BackgroundColorDefault Field

BackgroundColorDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BackgroundColorDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const BackgroundColorDefault As System.String
public const System.string BackgroundColorDefault
See Also

Reference

Style Class
Style Members


BackgroundGradientEndColorDefault Field

BackgroundGradientEndColorDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BackgroundGradientEndColorDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const BackgroundGradientEndColorDefault As System.String
public const System.string BackgroundGradientEndColorDefault
See Also

Reference

Style Class
Style Members


BackgroundGradientTypeDefault Field

BackgroundGradientTypeDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BackgroundGradientTypeDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const BackgroundGradientTypeDefault As System.String
public const System.string BackgroundGradientTypeDefault
See Also

Reference

Style Class
Style Members


BackgroundImageSourceDefault Field

BackgroundImageSourceDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BackgroundImageSourceDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const BackgroundImageSourceDefault As System.String
public const System.string BackgroundImageSourceDefault
See Also

Reference

Style Class
Style Members


BorderColorDefault Field

BorderColorDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BorderColorDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const BorderColorDefault As System.String
public const System.string BorderColorDefault
See Also

Reference

Style Class
Style Members


BorderStyleDefault Field

BorderStyleDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BorderStyleDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const BorderStyleDefault As System.String
public const System.string BorderStyleDefault
See Also

Reference

Style Class
Style Members


BorderWidthDefault Field

BorderWidthDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : BorderWidthDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const BorderWidthDefault As System.String
public const System.string BorderWidthDefault
See Also

Reference

Style Class
Style Members


CharacterSpacingDefault Field

CharacterSpacingDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : CharacterSpacingDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const CharacterSpacingDefault As System.String
public const System.string CharacterSpacingDefault
See Also

Reference

Style Class
Style Members


ColorDefault Field

ColorDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : ColorDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const ColorDefault As System.String
public const System.string ColorDefault
See Also

Reference

Style Class
Style Members


DefaultStyle Field

DefaultStyle Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : DefaultStyle Field
Global default Style object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly DefaultStyle As Style
public static readonly Style DefaultStyle
See Also

Reference

Style Class
Style Members


DirectionDefault Field

DirectionDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : DirectionDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const DirectionDefault As System.String
public const System.string DirectionDefault
See Also

Reference

Style Class
Style Members


FontFamilyDefault Field

FontFamilyDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : FontFamilyDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const FontFamilyDefault As System.String
public const System.string FontFamilyDefault
See Also

Reference

Style Class
Style Members


FontSizeDefault Field

FontSizeDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : FontSizeDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const FontSizeDefault As System.String
public const System.string FontSizeDefault
See Also

Reference

Style Class
Style Members


FontStyleDefault Field

FontStyleDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : FontStyleDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const FontStyleDefault As System.String
public const System.string FontStyleDefault
See Also

Reference

Style Class
Style Members


FontWeightDefault Field

FontWeightDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : FontWeightDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const FontWeightDefault As System.String
public const System.string FontWeightDefault
See Also

Reference

Style Class
Style Members


HeadingLevelDefault Field

HeadingLevelDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : HeadingLevelDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const HeadingLevelDefault As System.String
public const System.string HeadingLevelDefault
See Also

Reference

Style Class
Style Members


InheritedValue Field

InheritedValue Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : InheritedValue Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const InheritedValue As System.String
public const System.string InheritedValue
See Also

Reference

Style Class
Style Members


LabelExpressionDefault Field

LabelExpressionDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : LabelExpressionDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const LabelExpressionDefault As System.String
public const System.string LabelExpressionDefault
See Also

Reference

Style Class
Style Members


LeadingCharDefault Field

LeadingCharDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : LeadingCharDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const LeadingCharDefault As System.String
public const System.string LeadingCharDefault
See Also

Reference

Style Class
Style Members


MaxLevelDefault Field

MaxLevelDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : MaxLevelDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const MaxLevelDefault As System.String
public const System.string MaxLevelDefault
See Also

Reference

Style Class
Style Members


MinTextIndent Field

MinTextIndent Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : MinTextIndent Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly MinTextIndent As Length
public static readonly Length MinTextIndent
See Also

Reference

Style Class
Style Members


NumberingStyleDefault Field

NumberingStyleDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : NumberingStyleDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const NumberingStyleDefault As System.String
public const System.string NumberingStyleDefault
See Also

Reference

Style Class
Style Members


ShadowOffsetDefault Field

ShadowOffsetDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : ShadowOffsetDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const ShadowOffsetDefault As System.String
public const System.string ShadowOffsetDefault
See Also

Reference

Style Class
Style Members


ShrinkToFitDefault Field

ShrinkToFitDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : ShrinkToFitDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const ShrinkToFitDefault As System.String
public const System.string ShrinkToFitDefault
See Also

Reference

Style Class
Style Members


TextAlignDefault Field

TextAlignDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : TextAlignDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const TextAlignDefault As System.String
public const System.string TextAlignDefault
See Also

Reference

Style Class
Style Members


TextDecorationDefault Field

TextDecorationDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : TextDecorationDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const TextDecorationDefault As System.String
public const System.string TextDecorationDefault
See Also

Reference

Style Class
Style Members


TextIndentDefault Field

TextIndentDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : TextIndentDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const TextIndentDefault As System.String
public const System.string TextIndentDefault
See Also

Reference

Style Class
Style Members


VerticalAlignDefault Field

VerticalAlignDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : VerticalAlignDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const VerticalAlignDefault As System.String
public const System.string VerticalAlignDefault
See Also

Reference

Style Class
Style Members


WrapModeDefault Field

WrapModeDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : WrapModeDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const WrapModeDefault As System.String
public const System.string WrapModeDefault
See Also

Reference

Style Class
Style Members


WritingModeDefault Field

WritingModeDefault Field

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Style Class : WritingModeDefault Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const WritingModeDefault As System.String
public const System.string WritingModeDefault
See Also

Reference

Style Class
Style Members


StyleExpressionExtensions Class

StyleExpressionExtensions Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StyleExpressionExtensions Class
Provides extension methods for expressions of style
Object Model
StyleExpressionExtensions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit NotInheritable Class StyleExpressionExtensions
public static class StyleExpressionExtensions
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.StyleExpressionExtensions

See Also

Reference

StyleExpressionExtensions Members
GrapeCity.ActiveReports.PageReportModel Namespace


StyleExpressionExtensions Class Members

StyleExpressionExtensions Class Members
Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StyleExpressionExtensions Class

The following tables list the members exposed by StyleExpressionExtensions.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | IsInheritedValue | Checks that the value is inherited value
Top
See Also

Reference

StyleExpressionExtensions Class
GrapeCity.ActiveReports.PageReportModel Namespace


StyleExpressionExtensions Class Methods

StyleExpressionExtensions Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StyleExpressionExtensions Class

For a list of all members of this type, see StyleExpressionExtensions members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | IsInheritedValue | Checks that the value is inherited value
Top
See Also

Reference

StyleExpressionExtensions Class
GrapeCity.ActiveReports.PageReportModel Namespace


IsInheritedValue Method

IsInheritedValue Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleExpressionExtensions Class : IsInheritedValue Method
GrapeCity.ActiveReports.Expressions.ExpressionInfo value
Checks that the value is inherited value
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function IsInheritedValue( _
   ByVal value As ExpressionInfo _
) As System.Boolean
public static System.bool IsInheritedValue(
   ExpressionInfo value
)

Parameters

value
GrapeCity.ActiveReports.Expressions.ExpressionInfo value

Return Value

True if value is inherited value, otherwise: False
See Also

Reference

StyleExpressionExtensions Class
StyleExpressionExtensions Members


StyleSheet Class

StyleSheet Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StyleSheet Class
Specifies information about an a report's stylesheet.
Object Model
StyleSheet Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class StyleSheet
   Inherits System.Collections.Generic.List(Of Style)
public sealed class StyleSheet : System.Collections.Generic.List<Style>
Inheritance Hierarchy

System.Object
System.Collections.Generic.List<T>
GrapeCity.ActiveReports.PageReportModel.StyleSheet

See Also

Reference

StyleSheet Members
GrapeCity.ActiveReports.PageReportModel Namespace


StyleSheet Class Members

StyleSheet Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StyleSheet Class

The following tables list the members exposed by StyleSheet.

Public Constructors
 | Name | Description
Public Constructor | StyleSheet Constructor |
Top
Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List<Style>)
Public Property | Count | (Inherited from System.Collections.Generic.List<Style>)
Public Property | Item | Gets a specific Style object in the StyleSheet by name.
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List<Style>)
Public Method | AddRange | (Inherited from System.Collections.Generic.List<Style>)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List<Style>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<Style>)
Public Method | Clear | (Inherited from System.Collections.Generic.List<Style>)
Public Method | Contains | (Inherited from System.Collections.Generic.List<Style>)
Public Method | ConvertAll<TOutput> | (Inherited from System.Collections.Generic.List<Style>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<Style>)
Public Method | Exists | (Inherited from System.Collections.Generic.List<Style>)
Public Method | Find | (Inherited from System.Collections.Generic.List<Style>)
Public Method | FindAll | (Inherited from System.Collections.Generic.List<Style>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<Style>)
Public Method | FindLast | (Inherited from System.Collections.Generic.List<Style>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<Style>)
Public Method | ForEach | (Inherited from System.Collections.Generic.List<Style>)
Public Method | GetRange | (Inherited from System.Collections.Generic.List<Style>)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Style>)
Public Method | Insert | (Inherited from System.Collections.Generic.List<Style>)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List<Style>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Style>)
static (Shared in Visual Basic) | Load | Loads StyleSheet object from the System.IO.Stream.
Public Method | Remove | (Inherited from System.Collections.Generic.List<Style>)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List<Style>)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List<Style>)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List<Style>)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List<Style>)
Public Method | Save | Writes StyleSheet object to the System.IO.Stream.
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List<Style>)
Public Method | ToArray | (Inherited from System.Collections.Generic.List<Style>)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List<Style>)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List<Style>)
Top
See Also

Reference

StyleSheet Class
GrapeCity.ActiveReports.PageReportModel Namespace


StyleSheet Constructor

StyleSheet Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : StyleSheet Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public StyleSheet()
See Also

Reference

StyleSheet Class
StyleSheet Members


StyleSheet Class Methods

StyleSheet Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StyleSheet Class

For a list of all members of this type, see StyleSheet members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List<Style>)
Public Method | AddRange | (Inherited from System.Collections.Generic.List<Style>)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List<Style>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<Style>)
Public Method | Clear | (Inherited from System.Collections.Generic.List<Style>)
Public Method | Contains | (Inherited from System.Collections.Generic.List<Style>)
Public Method | ConvertAll<TOutput> | (Inherited from System.Collections.Generic.List<Style>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<Style>)
Public Method | Exists | (Inherited from System.Collections.Generic.List<Style>)
Public Method | Find | (Inherited from System.Collections.Generic.List<Style>)
Public Method | FindAll | (Inherited from System.Collections.Generic.List<Style>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<Style>)
Public Method | FindLast | (Inherited from System.Collections.Generic.List<Style>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<Style>)
Public Method | ForEach | (Inherited from System.Collections.Generic.List<Style>)
Public Method | GetRange | (Inherited from System.Collections.Generic.List<Style>)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Style>)
Public Method | Insert | (Inherited from System.Collections.Generic.List<Style>)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List<Style>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<Style>)
static (Shared in Visual Basic) | Load | Loads StyleSheet object from the System.IO.Stream.
Public Method | Remove | (Inherited from System.Collections.Generic.List<Style>)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List<Style>)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List<Style>)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List<Style>)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List<Style>)
Public Method | Save | Writes StyleSheet object to the System.IO.Stream.
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List<Style>)
Public Method | ToArray | (Inherited from System.Collections.Generic.List<Style>)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List<Style>)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List<Style>)
Top
See Also

Reference

StyleSheet Class
GrapeCity.ActiveReports.PageReportModel Namespace


Load Method (StyleSheet)

Load Method (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : Load Method
The System.IO.Stream object for loading.
Loads StyleSheet object from the System.IO.Stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function Load( _
   ByVal stream As System.IO.Stream _
) As StyleSheet
public static StyleSheet Load(
   System.IO.Stream stream
)

Parameters

stream
The System.IO.Stream object for loading.

Return Value

Loaded StyleSheet object
See Also

Reference

StyleSheet Class
StyleSheet Members


Save Method (StyleSheet)

Save Method (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : Save Method
The System.IO.Stream object for writing.
Writes StyleSheet object to the System.IO.Stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Save( _
   ByVal stream As System.IO.Stream _
)
public void Save(
   System.IO.Stream stream
)

Parameters

stream
The System.IO.Stream object for writing.
See Also

Reference

StyleSheet Class
StyleSheet Members


StyleSheet Class Properties

StyleSheet Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StyleSheet Class

For a list of all members of this type, see StyleSheet members.

Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List<Style>)
Public Property | Count | (Inherited from System.Collections.Generic.List<Style>)
Public Property | Item | Gets a specific Style object in the StyleSheet by name.
Top
See Also

Reference

StyleSheet Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (StyleSheet)

Item Property (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : Item Property
A String indicating the name of the Style to return.
Gets a specific Style object in the StyleSheet by name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows ReadOnly Default Property Item( _
   ByVal styleName As System.String _
) As Style
public new Style this[
   System.string styleName
]; {get;}

Parameters

styleName
A String indicating the name of the Style to return.

Property Value

The Style object with the specified name.
See Also

Reference

StyleSheet Class
StyleSheet Members


Subreport Class

Subreport Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Subreport Class
Specifies a Subreport ReportItem, which is a separate report contained in the report definition.
Object Model
Subreport Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Subreport
   Inherits ReportItem
   Implements IReportComponent
public sealed class Subreport : ReportItem, IReportComponent
Remarks
If the report specified in the subreport does not execute properly, an error message is displayed in its place.
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.Subreport

See Also

Reference

Subreport Members
GrapeCity.ActiveReports.PageReportModel Namespace


Subreport Class Members

Subreport Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Subreport Class

The following tables list the members exposed by Subreport.

Public Constructors
 | Name | Description
Public Constructor | Subreport Constructor | Initializes a new instance of the Subreport class.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | InheritStyleSheet |
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | MergeTransactions | Gets or sets a value indicating whether the transactions in the subreport are merged with the transactions in the parent report if the data sources use the same connection.
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | NoRows | Gets or sets a message to display in the subreport instead of the region layout when no rows of data are available in any dataset for the subreport.
Public Property | Parameters | Gets the parameters for the subreport.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportName | Gets or sets a string value containing the full path (e.g. "/salesreports/orderdetails") or relative path (e.g. "orderdetails") to the subreport.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | SubstituteThemeOnSubreport | Gets or sets a value indicating whether the subreport uses the theme from the current report.
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Overridden. Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.SubReport object.
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Subreport Class
GrapeCity.ActiveReports.PageReportModel Namespace


Subreport Constructor

Subreport Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : Subreport Constructor

Initializes a new instance of the Subreport class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Subreport()
See Also

Reference

Subreport Class
Subreport Members


Subreport Class Methods

Subreport Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Subreport Class

For a list of all members of this type, see Subreport members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Overridden. Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.SubReport object.
Top
See Also

Reference

Subreport Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (Subreport)

Validate Method (Subreport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : Validate Method
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.SubReport object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A DataDynamics.Reports.ReportObjectModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

Subreport Class
Subreport Members


Subreport Class Properties

Subreport Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Subreport Class

For a list of all members of this type, see Subreport members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | InheritStyleSheet |
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | MergeTransactions | Gets or sets a value indicating whether the transactions in the subreport are merged with the transactions in the parent report if the data sources use the same connection.
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | NoRows | Gets or sets a message to display in the subreport instead of the region layout when no rows of data are available in any dataset for the subreport.
Public Property | Parameters | Gets the parameters for the subreport.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportName | Gets or sets a string value containing the full path (e.g. "/salesreports/orderdetails") or relative path (e.g. "orderdetails") to the subreport.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | SubstituteThemeOnSubreport | Gets or sets a value indicating whether the subreport uses the theme from the current report.
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
See Also

Reference

Subreport Class
GrapeCity.ActiveReports.PageReportModel Namespace


InheritStyleSheet Property

InheritStyleSheet Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : InheritStyleSheet Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property InheritStyleSheet As System.Boolean
public System.bool InheritStyleSheet {get; set;}
See Also

Reference

Subreport Class
Subreport Members


MergeTransactions Property

MergeTransactions Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : MergeTransactions Property

Gets or sets a value indicating whether the transactions in the subreport are merged with the transactions in the parent report if the data sources use the same connection.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MergeTransactions As System.Boolean
public System.bool MergeTransactions {get; set;}

Property Value

A Boolean value where true indicates that the subreport transactions merge with the parent report transactions if the data sources use the same connection; otherwise false. The default value is false.

See Also

Reference

Subreport Class
Subreport Members


NoRows Property (Subreport)

NoRows Property (Subreport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : NoRows Property

Gets or sets a message to display in the subreport instead of the region layout when no rows of data are available in any dataset for the subreport.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NoRows As ExpressionInfo
public ExpressionInfo NoRows {get; set;}

Property Value

A String message to display in the subreport when no rows of data are available.

Remarks

Style information for this text is taken from the subreport.

If the subreport is in a table or matrix cell and does not have a NoRows property, the contents of the subreport are omitted, but the subreport's border properties still apply to the cell.

See Also

Reference

Subreport Class
Subreport Members


Parameters Property (Subreport)

Parameters Property (Subreport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : Parameters Property

Gets the parameters for the subreport.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Parameters As ParameterCollection
public ParameterCollection Parameters {get;}

Property Value

A ParameterCollection containing the parameters for the subreport.

Remarks

If the subreport is executed without parameters and contains no Toggle elements, it is only executed once even if it appears inside of a list, table, or matrix..

See Also

Reference

Subreport Class
Subreport Members


ReportName Property (Subreport)

ReportName Property (Subreport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : ReportName Property

Gets or sets a string value containing the full path (e.g. "/salesreports/orderdetails") or relative path (e.g. "orderdetails") to the subreport.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportName As System.String
public System.string ReportName {get; set;}

Property Value

A String containing the full or relative path to the subreport.

Remarks
Relative paths are relative to the current application's folder. The value cannot be an empty string.
See Also

Reference

Subreport Class
Subreport Members


SubstituteThemeOnSubreport Property

SubstituteThemeOnSubreport Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : SubstituteThemeOnSubreport Property

Gets or sets a value indicating whether the subreport uses the theme from the current report.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SubstituteThemeOnSubreport As System.Boolean
public System.bool SubstituteThemeOnSubreport {get; set;}

Property Value

A Boolean value where true indicates that the subreport uses the theme from the current report; otherwise false. The default value is false.

See Also

Reference

Subreport Class
Subreport Members


Subtotal Class

Subtotal Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Subtotal Class
The Subtotals element defines a subtotal column or row to include in the Matrix.
Object Model
Subtotal Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Subtotal
   Inherits ReportComponentContainer
   Implements IRdlContainer, IReportComponent, IReportComponentContainer
public sealed class Subtotal : ReportComponentContainer, IRdlContainer, IReportComponent, IReportComponentContainer
Remarks

In the subtotal column or row, the full set of data for the entire group is aggregated in the matrix cell.

If a matrix cell contains an aggregate that uses an explicit grouping scope contained within the scope of the aggregate, that scope is automatically adjusted to equal the current scope. For example, if a textbox in a matrix cell contains the expression =Sum(Fields!Sales.Value/Sum(Fields!Sales.Value,"State") and this subtotal is applied to the Country grouping scope, the expression evaluates to =Sum(Fields!Sales.Value)/Sum(Fields!Sales.Value,"Country"), since the State grouping scope is contained within the country grouping scope.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer
GrapeCity.ActiveReports.PageReportModel.Subtotal

See Also

Reference

Subtotal Members
GrapeCity.ActiveReports.PageReportModel Namespace


Subtotal Class Members

Subtotal Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Subtotal Class

The following tables list the members exposed by Subtotal.

Public Constructors
 | Name | Description
Public Constructor | Subtotal Constructor | Initializes a new instance of the Subtotal class.
Top
Public Properties
 | Name | Description
Public Property | Components | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportComponentCollection containing all the ReportComponents in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | DataElementName | The name to use for the subtotal.
Public Property | DataElementOutput | Gets or sets a value indicating whether the subtotal appears in a data rendering.
Public Property | Name | Gets the subtotal's name.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Position | Gets or sets a value indicating whether the subtotal column or row appears before (left or above) or after (right or below) the detail columns or rows.
Public Property | ReportItems | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportItemCollection containing all the ReportItems in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the style properties that override the style properties for all top-level report items contained in the subtotal column or row.
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.Subtotal object.
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Subtotal Class
GrapeCity.ActiveReports.PageReportModel Namespace


Subtotal Constructor

Subtotal Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subtotal Class : Subtotal Constructor

Initializes a new instance of the Subtotal class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Subtotal()
See Also

Reference

Subtotal Class
Subtotal Members


Subtotal Class Methods

Subtotal Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Subtotal Class

For a list of all members of this type, see Subtotal members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.Subtotal object.
Top
See Also

Reference

Subtotal Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (Subtotal)

Validate Method (Subtotal)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subtotal Class : Validate Method
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.Subtotal object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A DataDynamics.Reports.ReportObjectModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

Subtotal Class
Subtotal Members


Subtotal Class Properties

Subtotal Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Subtotal Class

For a list of all members of this type, see Subtotal members.

Public Properties
 | Name | Description
Public Property | Components | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportComponentCollection containing all the ReportComponents in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | DataElementName | The name to use for the subtotal.
Public Property | DataElementOutput | Gets or sets a value indicating whether the subtotal appears in a data rendering.
Public Property | Name | Gets the subtotal's name.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Position | Gets or sets a value indicating whether the subtotal column or row appears before (left or above) or after (right or below) the detail columns or rows.
Public Property | ReportItems | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportItemCollection containing all the ReportItems in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the style properties that override the style properties for all top-level report items contained in the subtotal column or row.
Top
See Also

Reference

Subtotal Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataElementName Property (Subtotal)

DataElementName Property (Subtotal)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subtotal Class : DataElementName Property

The name to use for the subtotal.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataElementName As System.String
public System.string DataElementName {get; set;}

Property Value

A String indicating the name to use for the subtotal element.

Remarks

The default value is "Total."

See Also

Reference

Subtotal Class
Subtotal Members


DataElementOutput Property (Subtotal)

DataElementOutput Property (Subtotal)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subtotal Class : DataElementOutput Property

Gets or sets a value indicating whether the subtotal appears in a data rendering.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataElementOutput As DataElementOutput
public DataElementOutput DataElementOutput {get; set;}

Property Value

A DataElementOutput enumeration indicating how or whether the subtotal appears in a data rendering.

Remarks

Output indicates that the subtotal appears in the output.

NoOutput(Default) indicates that the subtotal does not appear in the output.

See Also

Reference

Subtotal Class
Subtotal Members


Name Property (Subtotal)

Name Property (Subtotal)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subtotal Class : Name Property
Gets the subtotal's name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Name As System.String
public System.string Name {get;}
Remarks
The returned value is always "subtotal."
See Also

Reference

Subtotal Class
Subtotal Members


Position Property (Subtotal)

Position Property (Subtotal)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subtotal Class : Position Property

Gets or sets a value indicating whether the subtotal column or row appears before (left or above) or after (right or below) the detail columns or rows.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Position As SubtotalPosition
public SubtotalPosition Position {get; set;}

Property Value

A SubtotalPosition enumeration indicating whether the subtotal column or row appears before or after the detail columns or rows.

See Also

Reference

Subtotal Class
Subtotal Members


Style Property (Subtotal)

Style Property (Subtotal)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subtotal Class : Style Property

Gets or sets the style properties that override the style properties for all top-level report items contained in the subtotal column or row.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As Style
public Style Style {get; set;}

Property Value

A Style object containing the style properties that override any style properties of report items contained in the subtotal column or row.

Remarks

At Subtotal Column and Row intersections, the Row style takes priority.

See Also

Reference

Subtotal Class
Subtotal Members


Table Class

Table Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Table Class
The Table element defines a tabular grouped layout of the data region.
Object Model
Table Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Table
   Inherits DataRegion
   Implements IReportComponent, IReportComponentContainer, IScopeDefinition
public sealed class Table : DataRegion, IReportComponent, IReportComponentContainer, IScopeDefinition
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.DataRegion
GrapeCity.ActiveReports.PageReportModel.Table

See Also

Reference

Table Members
GrapeCity.ActiveReports.PageReportModel Namespace


Table Class Members

Table Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Table Class

The following tables list the members exposed by Table.

Public Constructors
 | Name | Description
Public Constructor | Table Constructor | Initializes a new instance of the Table class.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ChildScopes | Overridden. Overridden.Implements IScopeDefinition.ChildScopes.
Public Property | Components | Returns the DataDynamics.Reports.ReportObjectModel.Rdl.ReportComponentCollection containing all the components hosted in the control.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataSetName | Gets or sets the name of the dataset that the data region uses. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | DetailDataCollectionName | The name to use for the data element for the collection of all instances of the group.
Public Property | DetailDataElementName | The name to use for the data element for instances of the group. This property is ignored if there is a grouping defined for the details.
Public Property | DetailDataElementOutput | Gets or sets a value indicating whether the details appear in a data rendering.
Public Property | Details | Gets or sets the detail rows for the table..
Public Property | Filters | Gets the collection of filters applied to each row of data within the data region. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | FixedHeight | Represents the data region's maximum height per page. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | FixedWidth | Represents the data region's maximum width per page. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | Footer | Gets or sets the table footer rows.
Public Property | Header | Gets or sets the table header rows.
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | NewSection | Gets or sets a value indicating whether a data region is in it's own section (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | NoRows | Gets or sets the message to display inside the data region when the region contains no rows. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | OverflowName | Represents the data region's overflow name. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether a page break occurs immediately after the data region ends. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | PageBreakAtStart | Gets or sets a value indicating whether a page break occurs immediately before the data region begins. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | PreventOrphanedFooter | Indicates whether the last detailed row will be printed along with the footer in order to prevent orphaned footer on the next page.
Public Property | RepeatToFill | Gets or sets a value indicating whether a Table should fill the space with empty rows to reach its FixedHeight. Applicable to Page reports only.
Public Property | ReportItemsInScope | Overridden. Overridden.Implements IScopeDefinition.ReportItemsInScope.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | TableColumns | Gets the columns in the table.
Public Property | TableGroups | Gets the groups to use in the table.
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Overridden. Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.Table object.
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Table Class
GrapeCity.ActiveReports.PageReportModel Namespace


Table Constructor

Table Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : Table Constructor

Initializes a new instance of the Table class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Table()
See Also

Reference

Table Class
Table Members


Table Class Methods

Table Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Table Class

For a list of all members of this type, see Table members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Overridden. Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.Table object.
Top
See Also

Reference

Table Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (Table)

Validate Method (Table)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : Validate Method
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.Table object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A DataDynamics.Reports.ReportObjectModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

Table Class
Table Members


Table Class Properties

Table Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Table Class

For a list of all members of this type, see Table members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ChildScopes | Overridden. Overridden.Implements IScopeDefinition.ChildScopes.
Public Property | Components | Returns the DataDynamics.Reports.ReportObjectModel.Rdl.ReportComponentCollection containing all the components hosted in the control.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataSetName | Gets or sets the name of the dataset that the data region uses. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | DetailDataCollectionName | The name to use for the data element for the collection of all instances of the group.
Public Property | DetailDataElementName | The name to use for the data element for instances of the group. This property is ignored if there is a grouping defined for the details.
Public Property | DetailDataElementOutput | Gets or sets a value indicating whether the details appear in a data rendering.
Public Property | Details | Gets or sets the detail rows for the table..
Public Property | Filters | Gets the collection of filters applied to each row of data within the data region. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | FixedHeight | Represents the data region's maximum height per page. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | FixedWidth | Represents the data region's maximum width per page. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | Footer | Gets or sets the table footer rows.
Public Property | Header | Gets or sets the table header rows.
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | NewSection | Gets or sets a value indicating whether a data region is in it's own section (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | NoRows | Gets or sets the message to display inside the data region when the region contains no rows. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | OverflowName | Represents the data region's overflow name. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | PageBreakAtEnd | Gets or sets a value indicating whether a page break occurs immediately after the data region ends. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | PageBreakAtStart | Gets or sets a value indicating whether a page break occurs immediately before the data region begins. (Inherited from GrapeCity.ActiveReports.PageReportModel.DataRegion)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | PreventOrphanedFooter | Indicates whether the last detailed row will be printed along with the footer in order to prevent orphaned footer on the next page.
Public Property | RepeatToFill | Gets or sets a value indicating whether a Table should fill the space with empty rows to reach its FixedHeight. Applicable to Page reports only.
Public Property | ReportItemsInScope | Overridden. Overridden.Implements IScopeDefinition.ReportItemsInScope.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | TableColumns | Gets the columns in the table.
Public Property | TableGroups | Gets the groups to use in the table.
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
See Also

Reference

Table Class
GrapeCity.ActiveReports.PageReportModel Namespace


ChildScopes Property (Table)

ChildScopes Property (Table)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : ChildScopes Property
Overridden.Implements IScopeDefinition.ChildScopes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable ReadOnly Property ChildScopes As System.Collections.IEnumerable
public override System.Collections.IEnumerable ChildScopes {get;}

Property Value

The child scopes.
See Also

Reference

Table Class
Table Members


Components Property (Table)

Components Property (Table)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : Components Property
Returns the DataDynamics.Reports.ReportObjectModel.Rdl.ReportComponentCollection containing all the components hosted in the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Components As ReportComponentCollection
public ReportComponentCollection Components {get;}

Property Value

A read-only DataDynamics.Reports.ReportObjectModel.Rdl.ReportComponentCollection containing all the components hosted in the control.
See Also

Reference

Table Class
Table Members


DetailDataCollectionName Property (Table)

DetailDataCollectionName Property (Table)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : DetailDataCollectionName Property

The name to use for the data element for the collection of all instances of the group.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DetailDataCollectionName As System.String
public System.string DetailDataCollectionName {get; set;}

Property Value

A String indicating the name to use for the data element for the collection of all instances of the group.

Remarks

The default value is "Details_Collection."

See Also

Reference

Table Class
Table Members


DetailDataElementName Property (Table)

DetailDataElementName Property (Table)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : DetailDataElementName Property

The name to use for the data element for instances of the group. This property is ignored if there is a grouping defined for the details.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DetailDataElementName As System.String
public System.string DetailDataElementName {get; set;}

Property Value

A String indicating the name to use for the data element for instances of the group.

Remarks

The default value is "Details."

See Also

Reference

Table Class
Table Members


DetailDataElementOutput Property (Table)

DetailDataElementOutput Property (Table)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : DetailDataElementOutput Property

Gets or sets a value indicating whether the details appear in a data rendering.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DetailDataElementOutput As DataElementOutput
public DataElementOutput DetailDataElementOutput {get; set;}

Property Value

A DataElementOutput enumeration indicating how or whether the details appear in a data rendering.

Remarks

DataElement.Output (Default) indicates that the details appear in the output.

DataElement.NoOutput indicates that the details do not appear in the output.

See Also

Reference

Table Class
Table Members


Details Property (Table)

Details Property (Table)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : Details Property

Gets or sets the detail rows for the table..

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Details As Details
public Details Details {get; set;}

Property Value

A Details object containing the set of detail rows for the table.

Remarks

The table must include at least one of the following: Details, Header, or Footer.

See Also

Reference

Table Class
Table Members


Footer Property (Table)

Footer Property (Table)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : Footer Property

Gets or sets the table footer rows.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Footer As Footer
public Footer Footer {get; set;}

Property Value

A HeaderFooter object containing the table footer rows.

See Also

Reference

Table Class
Table Members


Header Property (Table)

Header Property (Table)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : Header Property

Gets or sets the table header rows.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Header As Header
public Header Header {get; set;}

Property Value

A HeaderFooter object containing the table header rows.

See Also

Reference

Table Class
Table Members


PreventOrphanedFooter Property (Table)

PreventOrphanedFooter Property (Table)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : PreventOrphanedFooter Property
Indicates whether the last detailed row will be printed along with the footer in order to prevent orphaned footer on the next page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PreventOrphanedFooter As System.Boolean
public System.bool PreventOrphanedFooter {get; set;}
See Also

Reference

Table Class
Table Members


RepeatToFill Property (Table)

RepeatToFill Property (Table)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : RepeatToFill Property

Gets or sets a value indicating whether a Table should fill the space with empty rows to reach its FixedHeight. Applicable to Page reports only.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RepeatToFill As System.Boolean
public System.bool RepeatToFill {get; set;}

Property Value

A Boolean value indicating whether a Table should fill the space with empty rows to reach its FixedHeight.

See Also

Reference

Table Class
Table Members


ReportItemsInScope Property (Table)

ReportItemsInScope Property (Table)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : ReportItemsInScope Property
Overridden.Implements IScopeDefinition.ReportItemsInScope.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable ReadOnly Property ReportItemsInScope As System.Collections.IEnumerable
public override System.Collections.IEnumerable ReportItemsInScope {get;}

Property Value

The report items in scope.
See Also

Reference

Table Class
Table Members


TableColumns Property

TableColumns Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : TableColumns Property

Gets the columns in the table.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TableColumns As TableColumnCollection
public TableColumnCollection TableColumns {get;}

Property Value

A TableColumnCollection containing the columns in the table.

See Also

Reference

Table Class
Table Members


TableGroups Property (Table)

TableGroups Property (Table)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : TableGroups Property

Gets the groups to use in the table.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TableGroups As TableGroupCollection
public TableGroupCollection TableGroups {get;}

Property Value

A TableGroupCollection containing the set of row groupings for the table.

See Also

Reference

Table Class
Table Members


TableCell Class

TableCell Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableCell Class
Defines the contents of a cell in a table data region.
Object Model
TableCell Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class TableCell
   Inherits ReportComponentContainer
   Implements IRdlContainer, IReportComponent, IReportComponentContainer
public sealed class TableCell : ReportComponentContainer, IRdlContainer, IReportComponent, IReportComponentContainer
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer
GrapeCity.ActiveReports.PageReportModel.TableCell

See Also

Reference

TableCell Members
GrapeCity.ActiveReports.PageReportModel Namespace


TableCell Class Members

TableCell Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableCell Class

The following tables list the members exposed by TableCell.

Public Constructors
 | Name | Description
Public Constructor | TableCell Constructor | Initializes a new instance of the TableCell class.
Top
Public Properties
 | Name | Description
Public Property | ColSpan | Gets or sets the number of columns the cell spans.
Public Property | Components | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportComponentCollection containing all the ReportComponents in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportItems | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportItemCollection containing all the ReportItems in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.TableCell object.
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

TableCell Class
GrapeCity.ActiveReports.PageReportModel Namespace


TableCell Constructor

TableCell Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCell Class : TableCell Constructor
Initializes a new instance of the TableCell class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public TableCell()
See Also

Reference

TableCell Class
TableCell Members


TableCell Class Methods

TableCell Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableCell Class

For a list of all members of this type, see TableCell members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.TableCell object.
Top
See Also

Reference

TableCell Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (TableCell)

Validate Method (TableCell)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCell Class : Validate Method
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.TableCell object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A DataDynamics.Reports.ReportObjectModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

TableCell Class
TableCell Members


TableCell Class Properties

TableCell Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableCell Class

For a list of all members of this type, see TableCell members.

Public Properties
 | Name | Description
Public Property | ColSpan | Gets or sets the number of columns the cell spans.
Public Property | Components | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportComponentCollection containing all the ReportComponents in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportItems | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportItemCollection containing all the ReportItems in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

TableCell Class
GrapeCity.ActiveReports.PageReportModel Namespace


ColSpan Property (TableCell)

ColSpan Property (TableCell)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCell Class : ColSpan Property

Gets or sets the number of columns the cell spans.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ColSpan As System.Integer
public System.int ColSpan {get; set;}

Property Value

An Int structure indicating the number of columns the cell spans.

Remarks

A ColSpan of 1 is the same as not specifying a ColSpan.

For the purpose of hidden columns, the cell is considered to occupy the first visible column in which it appears. Hiding a spanned column reduces the effective number of columns spanned. The cell remains visible, spanning the nonhidden columns, unless all spanned columns are hidden.

See Also

Reference

TableCell Class
TableCell Members


TableCellCollection Class

TableCellCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableCellCollection Class
Provides a strongly typed collection for TableCell objects.
Object Model
TableCellCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class TableCellCollection
   Inherits System.Collections.CollectionBase
public sealed class TableCellCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.TableCellCollection

See Also

Reference

TableCellCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


TableCellCollection Class Members

TableCellCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableCellCollection Class

The following tables list the members exposed by TableCellCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific TableCell object in the TableCellCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a TableCell object to the TableCellCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific TableCell object in the TableCellCollection.
Public Method | Insert | Inserts a new TableCell object into the TableCellCollection at the specified location.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

TableCellCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


TableCellCollection Class Methods

TableCellCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableCellCollection Class

For a list of all members of this type, see TableCellCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a TableCell object to the TableCellCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific TableCell object in the TableCellCollection.
Public Method | Insert | Inserts a new TableCell object into the TableCellCollection at the specified location.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

TableCellCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (TableCellCollection)

Add Method (TableCellCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCellCollection Class : Add Method
The TableCell object to add to the collection.
Adds a TableCell object to the TableCellCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As TableCell _
) As System.Integer
public System.int Add(
   TableCell value
)

Parameters

value
The TableCell object to add to the collection.

Return Value

A new TableCell object.
See Also

Reference

TableCellCollection Class
TableCellCollection Members


IndexOf Method (TableCellCollection)

IndexOf Method (TableCellCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCellCollection Class : IndexOf Method
The TableCell object to locate in the TableCellCollection.
Determines the index of a specific TableCell object in the TableCellCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As TableCell _
) As System.Integer
public System.int IndexOf(
   TableCell value
)

Parameters

value
The TableCell object to locate in the TableCellCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

TableCellCollection Class
TableCellCollection Members


Insert Method (TableCellCollection)

Insert Method (TableCellCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCellCollection Class : Insert Method
A zero-based Integer index indicating the position at which to insert the TableCell object.
The TableCell object to insert.
Inserts a new TableCell object into the TableCellCollection at the specified location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As TableCell _
)
public void Insert(
   System.int index,
   TableCell value
)

Parameters

index
A zero-based Integer index indicating the position at which to insert the TableCell object.
value
The TableCell object to insert.
See Also

Reference

TableCellCollection Class
TableCellCollection Members


TableCellCollection Class Properties

TableCellCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableCellCollection Class

For a list of all members of this type, see TableCellCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific TableCell object in the TableCellCollection by position.
Top
See Also

Reference

TableCellCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (TableCellCollection)

Item Property (TableCellCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCellCollection Class : Item Property
A zero-based Integer indicating the index of the TableCell object to return or set.
Gets or sets a specific TableCell object in the TableCellCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As TableCell
public TableCell this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the TableCell object to return or set.

Property Value

The TableCell object at the specified position.
See Also

Reference

TableCellCollection Class
TableCellCollection Members


TableColumn Class

TableColumn Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableColumn Class
Defines a column in the table.
Object Model
TableColumn Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class TableColumn
public sealed class TableColumn
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.TableColumn

See Also

Reference

TableColumn Members
GrapeCity.ActiveReports.PageReportModel Namespace


TableColumn Class Members

TableColumn Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableColumn Class

The following tables list the members exposed by TableColumn.

Public Constructors
 | Name | Description
Public Constructor | TableColumn Constructor | Initializes a new instance of the TableColumn class.
Top
Public Properties
 | Name | Description
Public Property | FixedHeader | Gets or sets a value indicating whether the header for this grouping should be displayed on the page even when the user scrolls part of the table off the page.
Public Property | Visibility | Gets or sets a value indicating whether the column is hidden.
Public Property | Width | Gets or sets the width of the column.
Top
See Also

Reference

TableColumn Class
GrapeCity.ActiveReports.PageReportModel Namespace


TableColumn Constructor

TableColumn Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableColumn Class : TableColumn Constructor
Initializes a new instance of the TableColumn class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public TableColumn()
See Also

Reference

TableColumn Class
TableColumn Members


TableColumn Class Properties

TableColumn Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableColumn Class

For a list of all members of this type, see TableColumn members.

Public Properties
 | Name | Description
Public Property | FixedHeader | Gets or sets a value indicating whether the header for this grouping should be displayed on the page even when the user scrolls part of the table off the page.
Public Property | Visibility | Gets or sets a value indicating whether the column is hidden.
Public Property | Width | Gets or sets the width of the column.
Top
See Also

Reference

TableColumn Class
GrapeCity.ActiveReports.PageReportModel Namespace


FixedHeader Property (TableColumn)

FixedHeader Property (TableColumn)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableColumn Class : FixedHeader Property

Gets or sets a value indicating whether the header for this grouping should be displayed on the page even when the user scrolls part of the table off the page.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FixedHeader As System.Boolean
public System.bool FixedHeader {get; set;}

Property Value

A Boolean value where true indicates the grouping should be displayed on the page even when the user scrolls part of the table off the page; otherwise false. The default value is false.

Remarks
Fixed headers must be touching each other and must also include the first or last column in the table.
See Also

Reference

TableColumn Class
TableColumn Members


Visibility Property (TableColumn)

Visibility Property (TableColumn)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableColumn Class : Visibility Property

Gets or sets a value indicating whether the column is hidden.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visibility As Visibility
public Visibility Visibility {get; set;}

Property Value

A Visibility object indicating whether the column is hidden.

See Also

Reference

TableColumn Class
TableColumn Members


Width Property (TableColumn)

Width Property (TableColumn)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableColumn Class : Width Property

Gets or sets the width of the column.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As Length
public Length Width {get; set;}

Property Value

A Length structure indicating the width of the column.

See Also

Reference

TableColumn Class
TableColumn Members


TableColumnCollection Class

TableColumnCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableColumnCollection Class
Provides a strongly typed collection for TableColumn objects.
Object Model
TableColumnCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class TableColumnCollection
   Inherits System.Collections.CollectionBase
public sealed class TableColumnCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.TableColumnCollection

See Also

Reference

TableColumnCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


TableColumnCollection Class Members

TableColumnCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableColumnCollection Class

The following tables list the members exposed by TableColumnCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific TableColumn object in the TableColumnCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a TableColumn object to the TableColumnCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific TableColumn object in the TableColumnCollection.
Public Method | Insert | Inserts a new TableColumn object into the TableColumnCollection at the specified location.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

TableColumnCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


TableColumnCollection Class Methods

TableColumnCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableColumnCollection Class

For a list of all members of this type, see TableColumnCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a TableColumn object to the TableColumnCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific TableColumn object in the TableColumnCollection.
Public Method | Insert | Inserts a new TableColumn object into the TableColumnCollection at the specified location.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

TableColumnCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (TableColumnCollection)

Add Method (TableColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableColumnCollection Class : Add Method
The TableColumn object to add to the collection.
Adds a TableColumn object to the TableColumnCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As TableColumn _
) As System.Integer
public System.int Add(
   TableColumn value
)

Parameters

value
The TableColumn object to add to the collection.

Return Value

A new TableColumn object.
See Also

Reference

TableColumnCollection Class
TableColumnCollection Members


IndexOf Method (TableColumnCollection)

IndexOf Method (TableColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableColumnCollection Class : IndexOf Method
The TableColumn object to locate in the TableColumnCollection.
Determines the index of a specific TableColumn object in the TableColumnCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As TableColumn _
) As System.Integer
public System.int IndexOf(
   TableColumn value
)

Parameters

value
The TableColumn object to locate in the TableColumnCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

TableColumnCollection Class
TableColumnCollection Members


Insert Method (TableColumnCollection)

Insert Method (TableColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableColumnCollection Class : Insert Method
A zero-based Integer index indicating the position at which to insert the TableColumn object.
The TableColumn object to insert.
Inserts a new TableColumn object into the TableColumnCollection at the specified location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As TableColumn _
)
public void Insert(
   System.int index,
   TableColumn value
)

Parameters

index
A zero-based Integer index indicating the position at which to insert the TableColumn object.
value
The TableColumn object to insert.
See Also

Reference

TableColumnCollection Class
TableColumnCollection Members


TableColumnCollection Class Properties

TableColumnCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableColumnCollection Class

For a list of all members of this type, see TableColumnCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific TableColumn object in the TableColumnCollection by position.
Top
See Also

Reference

TableColumnCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (TableColumnCollection)

Item Property (TableColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableColumnCollection Class : Item Property
A zero-based Integer indicating the index of the TableColumn object to return or set.
Gets or sets a specific TableColumn object in the TableColumnCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As TableColumn
public TableColumn this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the TableColumn object to return or set.

Property Value

The TableColumn object at the specified position.
See Also

Reference

TableColumnCollection Class
TableColumnCollection Members


TableGroup Class

TableGroup Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableGroup Class
Defines a group in a table data region.
Object Model
TableGroup Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class TableGroup
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer, IScopeDefinition
public sealed class TableGroup : ReportComponent, IReportComponent, IReportComponentContainer, IScopeDefinition
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.TableGroup

See Also

Reference

TableGroup Members
GrapeCity.ActiveReports.PageReportModel Namespace


TableGroup Class Members

TableGroup Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableGroup Class

The following tables list the members exposed by TableGroup.

Public Constructors
 | Name | Description
Public Constructor | TableGroup Constructor | Initializes a new instance of the TableGroup class.
Top
Public Properties
 | Name | Description
Public Property | Components | Gets the DataDynamics.Reports.ReportObjectModel.Rdl.ReportComponentCollection containing all the components hosted in the control.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Footer | Gets or sets the group footer row for the table.
Public Property | Grouping | Gets or sets the expressions by which to group the data.
Public Property | Header | Gets or sets the group header row for the table.
Public Property | KeepTogether | Gets or sets a value indicating whether a table group is kept together on a single page where possible.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | PreventOrphanedFooter | Indicates whether the last detailed row will be printed along with the footer in order to prevent orphaned footer on the next page.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Sorting | Gets or sets the expressions by which to sort the data.
Public Property | Visibility | Gets or sets a value indicating whether the group (and any group embedded within it) is hidden.
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.TableGroup object.
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

TableGroup Class
GrapeCity.ActiveReports.PageReportModel Namespace


TableGroup Constructor

TableGroup Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : TableGroup Constructor
Initializes a new instance of the TableGroup class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public TableGroup()
See Also

Reference

TableGroup Class
TableGroup Members


TableGroup Class Methods

TableGroup Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableGroup Class

For a list of all members of this type, see TableGroup members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.TableGroup object.
Top
See Also

Reference

TableGroup Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (TableGroup)

Validate Method (TableGroup)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : Validate Method
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.TableGroup object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A DataDynamics.Reports.ReportObjectModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

TableGroup Class
TableGroup Members


TableGroup Class Properties

TableGroup Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableGroup Class

For a list of all members of this type, see TableGroup members.

Public Properties
 | Name | Description
Public Property | Components | Gets the DataDynamics.Reports.ReportObjectModel.Rdl.ReportComponentCollection containing all the components hosted in the control.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Footer | Gets or sets the group footer row for the table.
Public Property | Grouping | Gets or sets the expressions by which to group the data.
Public Property | Header | Gets or sets the group header row for the table.
Public Property | KeepTogether | Gets or sets a value indicating whether a table group is kept together on a single page where possible.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | PreventOrphanedFooter | Indicates whether the last detailed row will be printed along with the footer in order to prevent orphaned footer on the next page.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Sorting | Gets or sets the expressions by which to sort the data.
Public Property | Visibility | Gets or sets a value indicating whether the group (and any group embedded within it) is hidden.
Top
See Also

Reference

TableGroup Class
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property (TableGroup)

Components Property (TableGroup)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : Components Property
Gets the DataDynamics.Reports.ReportObjectModel.Rdl.ReportComponentCollection containing all the components hosted in the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Components As ReportComponentCollection
public ReportComponentCollection Components {get;}

Property Value

A read-only DataDynamics.Reports.ReportObjectModel.Rdl.ReportComponentCollection containing all the components hosted in the control.
See Also

Reference

TableGroup Class
TableGroup Members


Footer Property (TableGroup)

Footer Property (TableGroup)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : Footer Property

Gets or sets the group footer row for the table.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Footer As Footer
public Footer Footer {get; set;}

Property Value

A HeaderFooter object containing the group footer row.

See Also

Reference

TableGroup Class
TableGroup Members


Grouping Property (TableGroup)

Grouping Property (TableGroup)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : Grouping Property

Gets or sets the expressions by which to group the data.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Grouping As Grouping
public Grouping Grouping {get; set;}

Property Value

A Grouping object containing the expressions by which to group the data.

See Also

Reference

TableGroup Class
TableGroup Members


Header Property (TableGroup)

Header Property (TableGroup)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : Header Property

Gets or sets the group header row for the table.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Header As Header
public Header Header {get; set;}

Property Value

A HeaderFooter object containing the group header row.

See Also

Reference

TableGroup Class
TableGroup Members


KeepTogether Property (TableGroup)

KeepTogether Property (TableGroup)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : KeepTogether Property

Gets or sets a value indicating whether a table group is kept together on a single page where possible.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property KeepTogether As System.Boolean
public System.bool KeepTogether {get; set;}

Property Value

A Boolean value where true indicates that the table groups's content is kept together on a single page if possible; otherwise false. The default value is false.

See Also

Reference

TableGroup Class
TableGroup Members


PreventOrphanedFooter Property (TableGroup)

PreventOrphanedFooter Property (TableGroup)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : PreventOrphanedFooter Property
Indicates whether the last detailed row will be printed along with the footer in order to prevent orphaned footer on the next page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PreventOrphanedFooter As System.Boolean
public System.bool PreventOrphanedFooter {get; set;}
See Also

Reference

TableGroup Class
TableGroup Members


Sorting Property (TableGroup)

Sorting Property (TableGroup)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : Sorting Property

Gets or sets the expressions by which to sort the data.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Sorting As SortByCollection
public SortByCollection Sorting {get;}

Property Value

A SortByCollection object containing the expressions by which to sort the data.

See Also

Reference

TableGroup Class
TableGroup Members


Visibility Property (TableGroup)

Visibility Property (TableGroup)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : Visibility Property

Gets or sets a value indicating whether the group (and any group embedded within it) is hidden.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visibility As Visibility
public Visibility Visibility {get; set;}

Property Value

A Visibility object indicating whether the group is hidden.

See Also

Reference

TableGroup Class
TableGroup Members


TableGroupCollection Class

TableGroupCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableGroupCollection Class
Provides a strongly typed collection for TableGroup objects.
Object Model
TableGroupCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class TableGroupCollection
   Inherits System.Collections.CollectionBase
public sealed class TableGroupCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.TableGroupCollection

See Also

Reference

TableGroupCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


TableGroupCollection Class Members

TableGroupCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableGroupCollection Class

The following tables list the members exposed by TableGroupCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific TableGroup object in the TableGroupCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a TableGroup object to the TableGroupCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific TableGroup object in the TableGroupCollection.
Public Method | Insert | Inserts a new TableGroup object into the TableGroupCollection at the specified location.
Public Method | Remove | Removes the specified TableGroup object from the TableGroupCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

TableGroupCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


TableGroupCollection Class Methods

TableGroupCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableGroupCollection Class

For a list of all members of this type, see TableGroupCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a TableGroup object to the TableGroupCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific TableGroup object in the TableGroupCollection.
Public Method | Insert | Inserts a new TableGroup object into the TableGroupCollection at the specified location.
Public Method | Remove | Removes the specified TableGroup object from the TableGroupCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

TableGroupCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (TableGroupCollection)

Add Method (TableGroupCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroupCollection Class : Add Method
The TableGroup object to add to the collection.
Adds a TableGroup object to the TableGroupCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As TableGroup _
) As System.Integer
public System.int Add(
   TableGroup value
)

Parameters

value
The TableGroup object to add to the collection.

Return Value

A new TableGroup object.
See Also

Reference

TableGroupCollection Class
TableGroupCollection Members


IndexOf Method (TableGroupCollection)

IndexOf Method (TableGroupCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroupCollection Class : IndexOf Method
The TableGroup object to locate in the TableGroupCollection.
Determines the index of a specific TableGroup object in the TableGroupCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As TableGroup _
) As System.Integer
public System.int IndexOf(
   TableGroup value
)

Parameters

value
The TableGroup object to locate in the TableGroupCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

TableGroupCollection Class
TableGroupCollection Members


Insert Method (TableGroupCollection)

Insert Method (TableGroupCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroupCollection Class : Insert Method
A zero-based Integer index indicating the position at which to insert the TableGroup object.
The TableGroup object to insert.
Inserts a new TableGroup object into the TableGroupCollection at the specified location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As TableGroup _
)
public void Insert(
   System.int index,
   TableGroup value
)

Parameters

index
A zero-based Integer index indicating the position at which to insert the TableGroup object.
value
The TableGroup object to insert.
See Also

Reference

TableGroupCollection Class
TableGroupCollection Members


Remove Method (TableGroupCollection)

Remove Method (TableGroupCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroupCollection Class : Remove Method
The TableGroup object to remove.
Removes the specified TableGroup object from the TableGroupCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As TableGroup _
)
public void Remove(
   TableGroup value
)

Parameters

value
The TableGroup object to remove.
See Also

Reference

TableGroupCollection Class
TableGroupCollection Members


TableGroupCollection Class Properties

TableGroupCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableGroupCollection Class

For a list of all members of this type, see TableGroupCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific TableGroup object in the TableGroupCollection by position.
Top
See Also

Reference

TableGroupCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (TableGroupCollection)

Item Property (TableGroupCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroupCollection Class : Item Property
A zero-based Integer indicating the index of the TableGroup object to return or set.
Gets or sets a specific TableGroup object in the TableGroupCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As TableGroup
public TableGroup this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the TableGroup object to return or set.

Property Value

The TableGroup object at the specified position.
See Also

Reference

TableGroupCollection Class
TableGroupCollection Members


TableOfContents Class

TableOfContents Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableOfContents Class
Defines the table of contents to presents the document map.
Object Model
TableOfContents Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class TableOfContents
   Inherits ReportItem
   Implements IReportComponent
public sealed class TableOfContents : ReportItem, IReportComponent
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.TableOfContents

See Also

Reference

TableOfContents Members
GrapeCity.ActiveReports.PageReportModel Namespace


TableOfContents Class Members

TableOfContents Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableOfContents Class

The following tables list the members exposed by TableOfContents.

Public Constructors
 | Name | Description
Public Constructor | TableOfContents Constructor | Initializes a new instance of the TableOfContents class.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | FixedHeight | Specifies the fixed height of table of contents.
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Levels | Returns the list of levels of table of contents.
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | MaxLevel | Specifies max level for table of contents.
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | OverflowName | Specifies overflow name.
Public Property | PageBreakAtEnd | Specifies whether to insert page break at end.
Public Property | PageBreakAtStart | Specifies whether to insert page break at start.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the ReportItem object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

TableOfContents Class
GrapeCity.ActiveReports.PageReportModel Namespace


TableOfContents Constructor

TableOfContents Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents Class : TableOfContents Constructor
Initializes a new instance of the TableOfContents class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public TableOfContents()
See Also

Reference

TableOfContents Class
TableOfContents Members


TableOfContents Class Properties

TableOfContents Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableOfContents Class

For a list of all members of this type, see TableOfContents members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | FixedHeight | Specifies the fixed height of table of contents.
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Levels | Returns the list of levels of table of contents.
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | MaxLevel | Specifies max level for table of contents.
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | OverflowName | Specifies overflow name.
Public Property | PageBreakAtEnd | Specifies whether to insert page break at end.
Public Property | PageBreakAtStart | Specifies whether to insert page break at start.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
See Also

Reference

TableOfContents Class
GrapeCity.ActiveReports.PageReportModel Namespace


FixedHeight Property (TableOfContents)

FixedHeight Property (TableOfContents)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents Class : FixedHeight Property
Specifies the fixed height of table of contents.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FixedHeight As Length
public Length FixedHeight {get; set;}
See Also

Reference

TableOfContents Class
TableOfContents Members


Levels Property (TableOfContents)

Levels Property (TableOfContents)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents Class : Levels Property
Returns the list of levels of table of contents.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Levels As System.Collections.Generic.IList(Of TableOfContentsLevel)
public System.Collections.Generic.IList<TableOfContentsLevel> Levels {get;}
See Also

Reference

TableOfContents Class
TableOfContents Members


MaxLevel Property (TableOfContents)

MaxLevel Property (TableOfContents)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents Class : MaxLevel Property
Specifies max level for table of contents.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaxLevel As ExpressionInfo
public ExpressionInfo MaxLevel {get; set;}
See Also

Reference

TableOfContents Class
TableOfContents Members


OverflowName Property (TableOfContents)

OverflowName Property (TableOfContents)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents Class : OverflowName Property
Specifies overflow name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OverflowName As System.String
public System.string OverflowName {get; set;}
See Also

Reference

TableOfContents Class
TableOfContents Members


PageBreakAtEnd Property (TableOfContents)

PageBreakAtEnd Property (TableOfContents)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents Class : PageBreakAtEnd Property
Specifies whether to insert page break at end.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageBreakAtEnd As System.Boolean
public System.bool PageBreakAtEnd {get; set;}
See Also

Reference

TableOfContents Class
TableOfContents Members


PageBreakAtStart Property (TableOfContents)

PageBreakAtStart Property (TableOfContents)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents Class : PageBreakAtStart Property
Specifies whether to insert page break at start.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageBreakAtStart As System.Boolean
public System.bool PageBreakAtStart {get; set;}
See Also

Reference

TableOfContents Class
TableOfContents Members


TableOfContentsLevel Class

TableOfContentsLevel Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableOfContentsLevel Class
Defines the level for TableOfContents.
Object Model
TableOfContentsLevel Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class TableOfContentsLevel
public sealed class TableOfContentsLevel
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.TableOfContentsLevel

See Also

Reference

TableOfContentsLevel Members
GrapeCity.ActiveReports.PageReportModel Namespace


TableOfContentsLevel Class Members

TableOfContentsLevel Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableOfContentsLevel Class

The following tables list the members exposed by TableOfContentsLevel.

Public Constructors
 | Name | Description
Public Constructor | TableOfContentsLevel Constructor | Initializes a new instance of this class.
Top
Public Properties
 | Name | Description
Public Property | DataElementName | Specifies the data element name.
Public Property | Label | Specifies the label of level.
Public Property | LeadingChar | Specifies the leading char for level.
Public Property | Name | Specifies the name of level.
Public Property | Style | Specifies the style of level.
Public Property | TextIndent | Specifies the text indent.
Top
See Also

Reference

TableOfContentsLevel Class
GrapeCity.ActiveReports.PageReportModel Namespace


TableOfContentsLevel Constructor

TableOfContentsLevel Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContentsLevel Class : TableOfContentsLevel Constructor
Initializes a new instance of this class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public TableOfContentsLevel()
See Also

Reference

TableOfContentsLevel Class
TableOfContentsLevel Members


TableOfContentsLevel Class Properties

TableOfContentsLevel Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableOfContentsLevel Class

For a list of all members of this type, see TableOfContentsLevel members.

Public Properties
 | Name | Description
Public Property | DataElementName | Specifies the data element name.
Public Property | Label | Specifies the label of level.
Public Property | LeadingChar | Specifies the leading char for level.
Public Property | Name | Specifies the name of level.
Public Property | Style | Specifies the style of level.
Public Property | TextIndent | Specifies the text indent.
Top
See Also

Reference

TableOfContentsLevel Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataElementName Property (TableOfContentsLevel)

DataElementName Property (TableOfContentsLevel)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContentsLevel Class : DataElementName Property
Specifies the data element name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataElementName As System.String
public System.string DataElementName {get; set;}
See Also

Reference

TableOfContentsLevel Class
TableOfContentsLevel Members


Label Property (TableOfContentsLevel)

Label Property (TableOfContentsLevel)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContentsLevel Class : Label Property
Specifies the label of level.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Label As ExpressionInfo
public ExpressionInfo Label {get; set;}
See Also

Reference

TableOfContentsLevel Class
TableOfContentsLevel Members


LeadingChar Property (TableOfContentsLevel)

LeadingChar Property (TableOfContentsLevel)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContentsLevel Class : LeadingChar Property
Specifies the leading char for level.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LeadingChar As ExpressionInfo
public ExpressionInfo LeadingChar {get; set;}
See Also

Reference

TableOfContentsLevel Class
TableOfContentsLevel Members


Name Property (TableOfContentsLevel)

Name Property (TableOfContentsLevel)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContentsLevel Class : Name Property
Specifies the name of level.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}
See Also

Reference

TableOfContentsLevel Class
TableOfContentsLevel Members


Style Property (TableOfContentsLevel)

Style Property (TableOfContentsLevel)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContentsLevel Class : Style Property
Specifies the style of level.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As Style
public Style Style {get; set;}
See Also

Reference

TableOfContentsLevel Class
TableOfContentsLevel Members


TextIndent Property (TableOfContentsLevel)

TextIndent Property (TableOfContentsLevel)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContentsLevel Class : TextIndent Property
Specifies the text indent.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TextIndent As Length
public Length TextIndent {get; set;}
See Also

Reference

TableOfContentsLevel Class
TableOfContentsLevel Members


TableRow Class

TableRow Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableRow Class
Defines a row of cells in a table data region.
Object Model
TableRow Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class TableRow
   Inherits ReportComponent
   Implements IReportComponent, IReportComponentContainer
public sealed class TableRow : ReportComponent, IReportComponent, IReportComponentContainer
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.TableRow

See Also

Reference

TableRow Members
GrapeCity.ActiveReports.PageReportModel Namespace


TableRow Class Members

TableRow Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableRow Class

The following tables list the members exposed by TableRow.

Public Constructors
 | Name | Description
Public Constructor | TableRow Constructor | Initializes a new instance of the TableRow class.
Top
Public Properties
 | Name | Description
Public Property | Components | Gets the DataDynamics.Reports.ReportObjectModel.Rdl.ReportComponentCollection containing all the components hosted in the control.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Height | Gets or sets the height of the row.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | TableCells | Gets the contents of the row.
Public Property | Visibility | Gets or sets a value indicating whether the row is hidden.
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.TableRow object.
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

TableRow Class
GrapeCity.ActiveReports.PageReportModel Namespace


TableRow Constructor

TableRow Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRow Class : TableRow Constructor

Initializes a new instance of the TableRow class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public TableRow()
See Also

Reference

TableRow Class
TableRow Members


TableRow Class Methods

TableRow Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableRow Class

For a list of all members of this type, see TableRow members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.TableRow object.
Top
See Also

Reference

TableRow Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (TableRow)

Validate Method (TableRow)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRow Class : Validate Method
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.TableRow object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A DataDynamics.Reports.ReportObjectModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

TableRow Class
TableRow Members


TableRow Class Properties

TableRow Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableRow Class

For a list of all members of this type, see TableRow members.

Public Properties
 | Name | Description
Public Property | Components | Gets the DataDynamics.Reports.ReportObjectModel.Rdl.ReportComponentCollection containing all the components hosted in the control.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Height | Gets or sets the height of the row.
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | TableCells | Gets the contents of the row.
Public Property | Visibility | Gets or sets a value indicating whether the row is hidden.
Top
See Also

Reference

TableRow Class
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property (TableRow)

Components Property (TableRow)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRow Class : Components Property
Gets the DataDynamics.Reports.ReportObjectModel.Rdl.ReportComponentCollection containing all the components hosted in the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Components As ReportComponentCollection
public ReportComponentCollection Components {get;}

Property Value

A read-only DataDynamics.Reports.ReportObjectModel.Rdl.ReportComponentCollection containing all the components hosted in the control.
See Also

Reference

TableRow Class
TableRow Members


Height Property (TableRow)

Height Property (TableRow)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRow Class : Height Property

Gets or sets the height of the row.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As Length
public Length Height {get; set;}

Property Value

A Length structure indicating the height of the row.

See Also

Reference

TableRow Class
TableRow Members


TableCells Property (TableRow)

TableCells Property (TableRow)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRow Class : TableCells Property

Gets the contents of the row.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TableCells As TableCellCollection
public TableCellCollection TableCells {get;}

Property Value

A TableCellCollection containing the contents of the row.

Remarks

There is one cell per column in a table.

See Also

Reference

TableRow Class
TableRow Members


Visibility Property (TableRow)

Visibility Property (TableRow)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRow Class : Visibility Property

Gets or sets a value indicating whether the row is hidden.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visibility As Visibility
public Visibility Visibility {get; set;}

Property Value

A Visibility object indicating whether the row is hidden.

See Also

Reference

TableRow Class
TableRow Members


TableRowCollection Class

TableRowCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableRowCollection Class
Provides a strongly typed collection for TableRow objects.
Object Model
TableRowCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class TableRowCollection
   Inherits System.Collections.CollectionBase
public sealed class TableRowCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.TableRowCollection

See Also

Reference

TableRowCollection Members
GrapeCity.ActiveReports.PageReportModel Namespace


TableRowCollection Class Members

TableRowCollection Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableRowCollection Class

The following tables list the members exposed by TableRowCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific TableRow object in the TableRowCollection by position.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a TableRow object to the TableRowCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific TableRow object in the TableRowCollection.
Public Method | Insert | Inserts a new TableRow object into the TableRowCollection at the specified location.
Public Method | Remove | Removes the specified TableRow object from the TableRowCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

TableRowCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


TableRowCollection Class Methods

TableRowCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableRowCollection Class

For a list of all members of this type, see TableRowCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a TableRow object to the TableRowCollection.
Public Method | Clear | Removes all objects from the DataGroupingCollection instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specific TableRow object in the TableRowCollection.
Public Method | Insert | Inserts a new TableRow object into the TableRowCollection at the specified location.
Public Method | Remove | Removes the specified TableRow object from the TableRowCollection.
Public Method | RemoveAt | Removes the element at the specified index of the DataCellCollection instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

TableRowCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (TableRowCollection)

Add Method (TableRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRowCollection Class : Add Method
The TableRow object to add to the collection.
Adds a TableRow object to the TableRowCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal value As TableRow _
) As System.Integer
public System.int Add(
   TableRow value
)

Parameters

value
The TableRow object to add to the collection.

Return Value

A new TableRow object.
See Also

Reference

TableRowCollection Class
TableRowCollection Members


IndexOf Method (TableRowCollection)

IndexOf Method (TableRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRowCollection Class : IndexOf Method
The TableRow object to locate in the TableRowCollection.
Determines the index of a specific TableRow object in the TableRowCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As TableRow _
) As System.Integer
public System.int IndexOf(
   TableRow value
)

Parameters

value
The TableRow object to locate in the TableRowCollection.

Return Value

The index of the entry if it is found in the collection; otherwise, -1.
See Also

Reference

TableRowCollection Class
TableRowCollection Members


Insert Method (TableRowCollection)

Insert Method (TableRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRowCollection Class : Insert Method
A zero-based Integer index indicating the position at which to insert the TableRow object.
The TableRow object to insert.
Inserts a new TableRow object into the TableRowCollection at the specified location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As TableRow _
)
public void Insert(
   System.int index,
   TableRow value
)

Parameters

index
A zero-based Integer index indicating the position at which to insert the TableRow object.
value
The TableRow object to insert.
See Also

Reference

TableRowCollection Class
TableRowCollection Members


Remove Method (TableRowCollection)

Remove Method (TableRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRowCollection Class : Remove Method
The TableRow object to remove.
Removes the specified TableRow object from the TableRowCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal value As TableRow _
)
public void Remove(
   TableRow value
)

Parameters

value
The TableRow object to remove.
See Also

Reference

TableRowCollection Class
TableRowCollection Members


TableRowCollection Class Properties

TableRowCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableRowCollection Class

For a list of all members of this type, see TableRowCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets a specific TableRow object in the TableRowCollection by position.
Top
See Also

Reference

TableRowCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Item Property (TableRowCollection)

Item Property (TableRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRowCollection Class : Item Property
A zero-based Integer indicating the index of the TableRow object to return or set.
Gets or sets a specific TableRow object in the TableRowCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As TableRow
public TableRow this[
   System.int index
]; {get; set;}

Parameters

index
A zero-based Integer indicating the index of the TableRow object to return or set.

Property Value

The TableRow object at the specified position.
See Also

Reference

TableRowCollection Class
TableRowCollection Members


TextBox Class

TextBox Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextBox Class
Specifies a textbox ReportItem contained in the report definition.
Object Model
TextBox Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class TextBox
   Inherits TextItem
   Implements IReportComponent
public sealed class TextBox : TextItem, IReportComponent
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.TextItem
GrapeCity.ActiveReports.PageReportModel.TextBox

See Also

Reference

TextBox Members
GrapeCity.ActiveReports.PageReportModel Namespace


TextBox Class Members

TextBox Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextBox Class

The following tables list the members exposed by TextBox.

Public Constructors
 | Name | Description
Public Constructor | TextBox Constructor | Intializes the new instance of TextBox class.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Angle | Returns the number of degrees the text is rotated counter-clockwise. Negative values indicate a clockwise rotation.
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | CanGrow | Specifies the heading level of this textbox. Gets or sets a value indicating whether the textbox size can increase to accommodate the contents.
Public Property | CanShrink | Gets or sets a value indicating whether the textbox size can decrease to match the contents.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementStyle | Gets or sets a value indicating whether the textbox value is rendered as an element or attribute. (Inherited from GrapeCity.ActiveReports.PageReportModel.TextItem)
Public Property | HeadingLevel |
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ShrinkToFit | Select whether the Textbox shrinks text to fit fixed sized control.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ToggleImage | Gets or sets a value indicating the initial state of a toggling image, if one is displayed as part of the textbox. The toggle image displays as a plus sign (+) to indicate a collapsed state with hidden report items, and as a minus sign (-) to indicate an expanded state with all report items visible.
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | UserSort | Gets or sets a value indicating whether the end-user sort control should be displayed as part of the textbox UI.
Public Property | Value | Gets or sets an expression, the value of which is displayed in the textbox. (Inherited from GrapeCity.ActiveReports.PageReportModel.TextItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Overridden. Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.TextBox object.
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

TextBox Class
GrapeCity.ActiveReports.PageReportModel Namespace


TextBox Constructor

TextBox Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : TextBox Constructor
Intializes the new instance of TextBox class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public TextBox()
See Also

Reference

TextBox Class
TextBox Members


TextBox Class Methods

TextBox Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextBox Class

For a list of all members of this type, see TextBox members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Overridden. Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.TextBox object.
Top
See Also

Reference

TextBox Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (TextBox)

Validate Method (TextBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : Validate Method
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.TextBox object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public override ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A DataDynamics.Reports.ReportObjectModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

TextBox Class
TextBox Members


TextBox Class Properties

TextBox Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextBox Class

For a list of all members of this type, see TextBox members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Angle | Returns the number of degrees the text is rotated counter-clockwise. Negative values indicate a clockwise rotation.
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | CanGrow | Specifies the heading level of this textbox. Gets or sets a value indicating whether the textbox size can increase to accommodate the contents.
Public Property | CanShrink | Gets or sets a value indicating whether the textbox size can decrease to match the contents.
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementStyle | Gets or sets a value indicating whether the textbox value is rendered as an element or attribute. (Inherited from GrapeCity.ActiveReports.PageReportModel.TextItem)
Public Property | HeadingLevel |
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ShrinkToFit | Select whether the Textbox shrinks text to fit fixed sized control.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ToggleImage | Gets or sets a value indicating the initial state of a toggling image, if one is displayed as part of the textbox. The toggle image displays as a plus sign (+) to indicate a collapsed state with hidden report items, and as a minus sign (-) to indicate an expanded state with all report items visible.
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | UserSort | Gets or sets a value indicating whether the end-user sort control should be displayed as part of the textbox UI.
Public Property | Value | Gets or sets an expression, the value of which is displayed in the textbox. (Inherited from GrapeCity.ActiveReports.PageReportModel.TextItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
See Also

Reference

TextBox Class
GrapeCity.ActiveReports.PageReportModel Namespace


Angle Property (TextBox)

Angle Property (TextBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : Angle Property

Returns the number of degrees the text is rotated counter-clockwise. Negative values indicate a clockwise rotation.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Angle As System.Single
public System.float Angle {get; set;}

Property Value

A float value indicating the number of degrees the text is rotated counter-clockwise. Negative values indicate a clockwise rotation.

See Also

Reference

TextBox Class
TextBox Members


CanGrow Property (TextBox)

CanGrow Property (TextBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : CanGrow Property
Specifies the heading level of this textbox.

Gets or sets a value indicating whether the textbox size can increase to accommodate the contents.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CanGrow As System.Boolean
public System.bool CanGrow {get; set;}

Property Value

A Boolean value where true indicates that the size of the textbox can increase to accomodate the contents; otherwise false. The default value is false.

See Also

Reference

TextBox Class
TextBox Members


CanShrink Property (TextBox)

CanShrink Property (TextBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : CanShrink Property

Gets or sets a value indicating whether the textbox size can decrease to match the contents.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CanShrink As System.Boolean
public System.bool CanShrink {get; set;}

Property Value

A Boolean where true indicates that the size of the textbox can decrease to match the contents; otherwise false. The default value is false.

See Also

Reference

TextBox Class
TextBox Members


HeadingLevel Property (TextBox)

HeadingLevel Property (TextBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : HeadingLevel Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HeadingLevel As ExpressionInfo
public ExpressionInfo HeadingLevel {get; set;}
See Also

Reference

TextBox Class
TextBox Members


ShrinkToFit Property (TextBox)

ShrinkToFit Property (TextBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : ShrinkToFit Property
Select whether the Textbox shrinks text to fit fixed sized control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShrinkToFit As System.Boolean
public System.bool ShrinkToFit {get; set;}
See Also

Reference

TextBox Class
TextBox Members


ToggleImage Property

ToggleImage Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : ToggleImage Property

Gets or sets a value indicating the initial state of a toggling image, if one is displayed as part of the textbox. The toggle image displays as a plus sign (+) to indicate a collapsed state with hidden report items, and as a minus sign (-) to indicate an expanded state with all report items visible.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ToggleImage As ToggleImage
public ToggleImage ToggleImage {get; set;}

Property Value

A ToggleImage object indicating the initial state of a toggling image, if one is displayed as part of the textbox.

Remarks

The ToggleImage is used along with the Visibility class for report items toggled with a textbox.

See Also

Reference

TextBox Class
TextBox Members


UserSort Property

UserSort Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : UserSort Property

Gets or sets a value indicating whether the end-user sort control should be displayed as part of the textbox UI.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UserSort As UserSort
public UserSort UserSort {get; set;}

Property Value

A UserSort value indicating whether the end-user sort control should be displayed as part of the textbox UI.

See Also

Reference

TextBox Class
TextBox Members


TextItem Class

TextItem Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextItem Class
Abstract base class for TextBox and CheckBox
Object Model
TextItem Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class TextItem
   Inherits ReportItem
   Implements IReportComponent
public abstract class TextItem : ReportItem, IReportComponent
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.TextItem
GrapeCity.ActiveReports.PageReportModel.CheckBox
GrapeCity.ActiveReports.PageReportModel.TextBox

See Also

Reference

TextItem Members
GrapeCity.ActiveReports.PageReportModel Namespace


TextItem Class Members

TextItem Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextItem Class

The following tables list the members exposed by TextItem.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementStyle | Gets or sets a value indicating whether the textbox value is rendered as an element or attribute.
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Value | Gets or sets an expression, the value of which is displayed in the textbox.
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the ReportItem object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

TextItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


TextItem Class Properties

TextItem Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextItem Class

For a list of all members of this type, see TextItem members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementStyle | Gets or sets a value indicating whether the textbox value is rendered as an element or attribute.
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Value | Gets or sets an expression, the value of which is displayed in the textbox.
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
See Also

Reference

TextItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataElementStyle Property (TextItem)

DataElementStyle Property (TextItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextItem Class : DataElementStyle Property

Gets or sets a value indicating whether the textbox value is rendered as an element or attribute.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataElementStyle As DataElementStyle
public DataElementStyle DataElementStyle {get; set;}

Property Value

A DataElementStyle enumeration indicating whether the textbox value is rendered as an element or attribute.

See Also

Reference

TextItem Class
TextItem Members


Value Property (TextItem)

Value Property (TextItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextItem Class : Value Property

Gets or sets an expression, the value of which is displayed in the textbox.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As ExpressionInfo
public ExpressionInfo Value {get; set;}

Property Value

An ExpressionInfo that evaluates to text which is displayed in the textbox.

Remarks

The value can be a constant expression for constant labels.

See Also

Reference

TextItem Class
TextItem Members


ThreeDProperties Class

ThreeDProperties Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ThreeDProperties Class
The ThreeDProperties element defines properties for a 3D chart layout.
Object Model
ThreeDProperties Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ThreeDProperties
public sealed class ThreeDProperties
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ThreeDProperties

See Also

Reference

ThreeDProperties Members
GrapeCity.ActiveReports.PageReportModel Namespace


ThreeDProperties Class Members

ThreeDProperties Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ThreeDProperties Class

The following tables list the members exposed by ThreeDProperties.

Public Constructors
 | Name | Description
Public Constructor | ThreeDProperties Constructor | Initializes a new instance of the ThreeDProperties class.
Top
Public Properties
 | Name | Description
Public Property | Clustered | Gets or sets a value indicating whether the data series are clustered (displayed along distinct rows).
Public Property | DrawingStyle | Gets or sets the shape of bars or columns to display in the chart.
Public Property | Enabled | Gets or sets a value indicating whether a chart is displayed in 3D.
Public Property | Inclination | Gets or sets the angle of inclination.
Public Property | Perspective | Gets or sets the angle of perspective.
Public Property | ProjectionMode | Gets or sets the projection mode used for 3D rendering.
Public Property | Rotation | Gets or sets the angle of rotation.
Public Property | Shading | Gets or sets the 3D shading type to use.
Public Property | WallThickness | Gets or sets the thickness percent of the outer walls.
Top
See Also

Reference

ThreeDProperties Class
GrapeCity.ActiveReports.PageReportModel Namespace


ThreeDProperties Constructor

ThreeDProperties Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ThreeDProperties Class : ThreeDProperties Constructor

Initializes a new instance of the ThreeDProperties class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ThreeDProperties()
See Also

Reference

ThreeDProperties Class
ThreeDProperties Members


ThreeDProperties Class Properties

ThreeDProperties Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ThreeDProperties Class

For a list of all members of this type, see ThreeDProperties members.

Public Properties
 | Name | Description
Public Property | Clustered | Gets or sets a value indicating whether the data series are clustered (displayed along distinct rows).
Public Property | DrawingStyle | Gets or sets the shape of bars or columns to display in the chart.
Public Property | Enabled | Gets or sets a value indicating whether a chart is displayed in 3D.
Public Property | Inclination | Gets or sets the angle of inclination.
Public Property | Perspective | Gets or sets the angle of perspective.
Public Property | ProjectionMode | Gets or sets the projection mode used for 3D rendering.
Public Property | Rotation | Gets or sets the angle of rotation.
Public Property | Shading | Gets or sets the 3D shading type to use.
Public Property | WallThickness | Gets or sets the thickness percent of the outer walls.
Top
See Also

Reference

ThreeDProperties Class
GrapeCity.ActiveReports.PageReportModel Namespace


Clustered Property (ThreeDProperties)

Clustered Property (ThreeDProperties)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ThreeDProperties Class : Clustered Property

Gets or sets a value indicating whether the data series are clustered (displayed along distinct rows).

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Clustered As System.Boolean
public System.bool Clustered {get; set;}

Property Value

A Boolean value where true indicates that the data series is clustered; otherwise false. The default value is false.

Remarks

This property only applies to bar and column chart types.

See Also

Reference

ThreeDProperties Class
ThreeDProperties Members


DrawingStyle Property (ThreeDProperties)

DrawingStyle Property (ThreeDProperties)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ThreeDProperties Class : DrawingStyle Property

Gets or sets the shape of bars or columns to display in the chart.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DrawingStyle As ThreeDPropertiesDrawingStyle
public ThreeDPropertiesDrawingStyle DrawingStyle {get; set;}

Property Value

A ThreeDPropertiesDrawingStyle enumeration indicating the shape of bars or columns displayed.

Remarks

This property only applies to bar and column chart types.

See Also

Reference

ThreeDProperties Class
ThreeDProperties Members


Enabled Property (ThreeDProperties)

Enabled Property (ThreeDProperties)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ThreeDProperties Class : Enabled Property

Gets or sets a value indicating whether a chart is displayed in 3D.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Enabled As System.Boolean
public System.bool Enabled {get; set;}

Property Value

A Boolean value where true indicates that the chart is displayed in 3D; otherwise false. The default value is false.

See Also

Reference

ThreeDProperties Class
ThreeDProperties Members


Inclination Property (ThreeDProperties)

Inclination Property (ThreeDProperties)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ThreeDProperties Class : Inclination Property

Gets or sets the angle of inclination.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Inclination As System.Nullable(Of Integer)
public System.Nullable<int> Inclination {get; set;}

Property Value

A NullableInt32 structure indicating the angle of inclination.

Remarks

This property is ignored unless the ProjectionMode property is set to DataDynamics.Reports.ReportObjectModel.Rdl.ThreeDPropertiesProjectionMode.Perspective

See Also

Reference

ThreeDProperties Class
ThreeDProperties Members


Perspective Property (ThreeDProperties)

Perspective Property (ThreeDProperties)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ThreeDProperties Class : Perspective Property

Gets or sets the angle of perspective.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Perspective As System.Nullable(Of Integer)
public System.Nullable<int> Perspective {get; set;}

Property Value

A NullableInt32 indicating the angle of perspective.

Remarks

This property is ignored unless the ProjectionMode property is set to DataDynamics.Reports.ReportObjectModel.Rdl.ThreeDPropertiesProjectionMode.Perspective

See Also

Reference

ThreeDProperties Class
ThreeDProperties Members


ProjectionMode Property (ThreeDProperties)

ProjectionMode Property (ThreeDProperties)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ThreeDProperties Class : ProjectionMode Property

Gets or sets the projection mode used for 3D rendering.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ProjectionMode As ThreeDPropertiesProjectionMode
public ThreeDPropertiesProjectionMode ProjectionMode {get; set;}

Property Value

A ThreeDPropertiesProjectionMode enumeration indicating the projection mode used for 3D rendering.

See Also

Reference

ThreeDProperties Class
ThreeDProperties Members


Rotation Property (ThreeDProperties)

Rotation Property (ThreeDProperties)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ThreeDProperties Class : Rotation Property

Gets or sets the angle of rotation.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Rotation As System.Nullable(Of Integer)
public System.Nullable<int> Rotation {get; set;}

Property Value

A NullableInt32 structure indicating the angle of rotation.

See Also

Reference

ThreeDProperties Class
ThreeDProperties Members


Shading Property (ThreeDProperties)

Shading Property (ThreeDProperties)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ThreeDProperties Class : Shading Property

Gets or sets the 3D shading type to use.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Shading As ThreeDPropertiesShading
public ThreeDPropertiesShading Shading {get; set;}

Property Value

A ThreeDPropertiesShading enumeration indicating the 3D shading type to use.

See Also

Reference

ThreeDProperties Class
ThreeDProperties Members


WallThickness Property (ThreeDProperties)

WallThickness Property (ThreeDProperties)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ThreeDProperties Class : WallThickness Property

Gets or sets the thickness percent of the outer walls.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WallThickness As System.Nullable(Of Integer)
public System.Nullable<int> WallThickness {get; set;}

Property Value

A NullableInt32 indicating the thickness percent of the outer walls.

See Also

Reference

ThreeDProperties Class
ThreeDProperties Members


Title Class

Title Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Title Class
The Title element defines a title for the chart or for an axis.
Object Model
Title Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Title
public sealed class Title
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Title

See Also

Reference

Title Members
GrapeCity.ActiveReports.PageReportModel Namespace


Title Class Members

Title Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Title Class

The following tables list the members exposed by Title.

Public Constructors
 | Name | Description
Public Constructor | Title Constructor | Initializes a new instance of the Title class.
Top
Public Properties
 | Name | Description
Public Property | Caption | Gets or sets the caption of the title.
Public Property | Position | Gets or sets the position of the title.
Public Property | Style | Gets or sets the text, border and background style properties for the title.
Public Property | Vertical | Specifies whether the title should be vertical.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.Title object.
Top
See Also

Reference

Title Class
GrapeCity.ActiveReports.PageReportModel Namespace


Title Constructor

Title Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Title Class : Title Constructor

Initializes a new instance of the Title class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Title()
See Also

Reference

Title Class
Title Members


Title Class Methods

Title Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Title Class

For a list of all members of this type, see Title members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.Title object.
Top
See Also

Reference

Title Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (Title)

Validate Method (Title)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Title Class : Validate Method
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.Title object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A DataDynamics.Reports.ReportObjectModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

Title Class
Title Members


Title Class Properties

Title Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Title Class

For a list of all members of this type, see Title members.

Public Properties
 | Name | Description
Public Property | Caption | Gets or sets the caption of the title.
Public Property | Position | Gets or sets the position of the title.
Public Property | Style | Gets or sets the text, border and background style properties for the title.
Public Property | Vertical | Specifies whether the title should be vertical.
Top
See Also

Reference

Title Class
GrapeCity.ActiveReports.PageReportModel Namespace


Caption Property (Title)

Caption Property (Title)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Title Class : Caption Property

Gets or sets the caption of the title.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Caption As ExpressionInfo
public ExpressionInfo Caption {get; set;}

Property Value

An ExpressionInfo object containing the caption of the title.

See Also

Reference

Title Class
Title Members


Position Property (Title)

Position Property (Title)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Title Class : Position Property

Gets or sets the position of the title.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Position As TitlePosition
public TitlePosition Position {get; set;}

Property Value

A TitlePosition enumeration indicating the position of the title.

Remarks
This property is only used for chart axis titles.
See Also

Reference

Title Class
Title Members


Style Property (Title)

Style Property (Title)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Title Class : Style Property

Gets or sets the text, border and background style properties for the title.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As Style
public Style Style {get; set;}

Property Value

A Style object containing the text, border and background style properties for the title.

Remarks
All textbox properties apply.
See Also

Reference

Title Class
Title Members


Vertical Property (Title)

Vertical Property (Title)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Title Class : Vertical Property
Specifies whether the title should be vertical.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Vertical As System.Boolean
public System.bool Vertical {get; set;}
See Also

Reference

Title Class
Title Members


ToggleImage Class

ToggleImage Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ToggleImage Class
Indicates the initial state of a toggle image if such an image is displayed as part of the Textbox.
Object Model
ToggleImage Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ToggleImage
public sealed class ToggleImage
Remarks
The image is always displayed if the texbox is a toggle item for another report item. If no ToggleImage element is present, no image is displayed. The toggle image displays as a plus sign (+) to indicate a collapsed state with hidden report items, and as a minus sign (-) to indicate an expanded state with all report items visible. Whenever the textbox or image is clicked, the toggle image state flips and the image associated with the new state is displayed instead.
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ToggleImage

See Also

Reference

ToggleImage Members
GrapeCity.ActiveReports.PageReportModel Namespace


ToggleImage Class Members

ToggleImage Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ToggleImage Class

The following tables list the members exposed by ToggleImage.

Public Constructors
 | Name | Description
Public Constructor | ToggleImage Constructor | Initializes a new instance of the ToggleImage class.
Top
Public Properties
 | Name | Description
Public Property | InitialState | Gets or sets a Boolean expression, the value of which determines the initial state of the toggle image.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.ToggleImage object.
Top
See Also

Reference

ToggleImage Class
GrapeCity.ActiveReports.PageReportModel Namespace


ToggleImage Constructor

ToggleImage Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ToggleImage Class : ToggleImage Constructor

Initializes a new instance of the ToggleImage class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ToggleImage()
See Also

Reference

ToggleImage Class
ToggleImage Members


ToggleImage Class Methods

ToggleImage Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ToggleImage Class

For a list of all members of this type, see ToggleImage members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.ToggleImage object.
Top
See Also

Reference

ToggleImage Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (ToggleImage)

Validate Method (ToggleImage)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ToggleImage Class : Validate Method
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.ToggleImage object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A DataDynamics.Reports.ReportObjectModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

ToggleImage Class
ToggleImage Members


ToggleImage Class Properties

ToggleImage Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ToggleImage Class

For a list of all members of this type, see ToggleImage members.

Public Properties
 | Name | Description
Public Property | InitialState | Gets or sets a Boolean expression, the value of which determines the initial state of the toggle image.
Top
See Also

Reference

ToggleImage Class
GrapeCity.ActiveReports.PageReportModel Namespace


InitialState Property

InitialState Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ToggleImage Class : InitialState Property

Gets or sets a Boolean expression, the value of which determines the initial state of the toggle image.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property InitialState As ExpressionInfo
public ExpressionInfo InitialState {get; set;}

Property Value

An ExpressionInfo object that evaluates to a Boolean value which determines the initial state of the toggle image. The default value is false, or collapsed (+).

Remarks

A value of true displays an expanded toggle image (a minus sign).

A value of false displays a collapsed toggle image (a plus sign).

See Also

Reference

ToggleImage Class
ToggleImage Members


UserSort Class

UserSort Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : UserSort Class
Defines an object for sort information to the end-user as part of the TextBox UI.
Object Model
UserSort Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class UserSort
public sealed class UserSort
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.UserSort

See Also

Reference

UserSort Members
GrapeCity.ActiveReports.PageReportModel Namespace


UserSort Class Members

UserSort Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : UserSort Class

The following tables list the members exposed by UserSort.

Public Constructors
 | Name | Description
Public Constructor | UserSort Constructor | Returns an instance of a DataDynamics.Reports.ReportObjectModel.Runtime.UserSort.
Top
Public Properties
 | Name | Description
Public Property | SortExpression | Gets or sets the expression to sort on.
Public Property | SortExpressionScope | Gets or sets the name of the data region, or grouping, scope to evaluate the expression in.
Public Property | SortTarget | Gets or sets name of the data region, grouping, or data set to apply the sort to.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.UserSort object.
Top
See Also

Reference

UserSort Class
GrapeCity.ActiveReports.PageReportModel Namespace


UserSort Constructor

UserSort Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > UserSort Class : UserSort Constructor
Returns an instance of a DataDynamics.Reports.ReportObjectModel.Runtime.UserSort.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public UserSort()

Return Value

a DataDynamics.Reports.ReportObjectModel.Runtime.UserSort
See Also

Reference

UserSort Class
UserSort Members


UserSort Class Methods

UserSort Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : UserSort Class

For a list of all members of this type, see UserSort members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.UserSort object.
Top
See Also

Reference

UserSort Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (UserSort)

Validate Method (UserSort)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > UserSort Class : Validate Method
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.UserSort object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A DataDynamics.Reports.ReportObjectModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

UserSort Class
UserSort Members


UserSort Class Properties

UserSort Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : UserSort Class

For a list of all members of this type, see UserSort members.

Public Properties
 | Name | Description
Public Property | SortExpression | Gets or sets the expression to sort on.
Public Property | SortExpressionScope | Gets or sets the name of the data region, or grouping, scope to evaluate the expression in.
Public Property | SortTarget | Gets or sets name of the data region, grouping, or data set to apply the sort to.
Top
See Also

Reference

UserSort Class
GrapeCity.ActiveReports.PageReportModel Namespace


SortExpression Property (UserSort)

SortExpression Property (UserSort)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > UserSort Class : SortExpression Property
Gets or sets the expression to sort on.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SortExpression As ExpressionInfo
public ExpressionInfo SortExpression {get; set;}
Remarks
Has the same restrictions as a grouping filter expression. Aggregates used in the SortExpression should only use scopes equal, or contain, the SortExpressionScope. If no SortExpressionScope is specified aggregates must set the scope.
See Also

Reference

UserSort Class
UserSort Members


SortExpressionScope Property

SortExpressionScope Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > UserSort Class : SortExpressionScope Property
Gets or sets the name of the data region, or grouping, scope to evaluate the expression in.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SortExpressionScope As System.String
public System.string SortExpressionScope {get; set;}
Remarks

If omitted, the expression will be evaluated and the sort will be performed independently in each detail scope in the SortTarget.

The scope must be equal to, or contained, inside the current scope. If the TextBox has no current scope the value must be equal to or contained within the SortTarget.

The SortExpressionScope and the SortTarget must use the same data set.

Sorting takes place within the group containing the SortExpressionScope. For instance: In a table with a state group and a city group with UserSort on each header and SortExpressionScope on the corresponding group, the state sort will sort the state groups within the table and the city sort will sort the city groups within each state group without rearranging the country state groups.

See Also

Reference

UserSort Class
UserSort Members


SortTarget Property

SortTarget Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > UserSort Class : SortTarget Property
Gets or sets name of the data region, grouping, or data set to apply the sort to.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SortTarget As System.String
public System.string SortTarget {get; set;}
Remarks

If omitted, the sort will apply to the current scope.

Must be the current scope, and ancestor scope, or a peer scope which is a data region.

Matrix groupings are only valid SortTargets from within matrix grouping scopes along the same matrix axis.

See Also

Reference

UserSort Class
UserSort Members


ValidationContext Class

ValidationContext Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValidationContext Class
Defines the type of context information that is available during validation.
Object Model
ValidationContext Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ValidationContext
public sealed class ValidationContext
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ValidationContext

See Also

Reference

ValidationContext Members
GrapeCity.ActiveReports.PageReportModel Namespace


ValidationContext Class Members

ValidationContext Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValidationContext Class

The following tables list the members exposed by ValidationContext.

Public Constructors
 | Name | Description
Public Constructor | ValidationContext Constructor | Creates a new ValidationContext class.
Top
Public Properties
 | Name | Description
Public Property | ContextualInformation | Gets a System.Collections.Specialized.HybridDictionary object containing any information that needs to be passed through validation.
Public Property | Mode | Gets the mode for which the validation context is set.
Public Property | NameValidator | Gets a DataDynamics.Reports.ReportObjectMode.Validation.NameValidator object for the current validation context to use for name validation.
Top
See Also

Reference

ValidationContext Class
GrapeCity.ActiveReports.PageReportModel Namespace


ValidationContext Constructor

ValidationContext Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidationContext Class : ValidationContext Constructor
The mode to run the validation for.
Creates a new ValidationContext class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal mode As ValidationMode _
)
public ValidationContext(
   ValidationMode mode
)

Parameters

mode
The mode to run the validation for.
See Also

Reference

ValidationContext Class
ValidationContext Members


ValidationContext Class Properties

ValidationContext Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValidationContext Class

For a list of all members of this type, see ValidationContext members.

Public Properties
 | Name | Description
Public Property | ContextualInformation | Gets a System.Collections.Specialized.HybridDictionary object containing any information that needs to be passed through validation.
Public Property | Mode | Gets the mode for which the validation context is set.
Public Property | NameValidator | Gets a DataDynamics.Reports.ReportObjectMode.Validation.NameValidator object for the current validation context to use for name validation.
Top
See Also

Reference

ValidationContext Class
GrapeCity.ActiveReports.PageReportModel Namespace


ContextualInformation Property

ContextualInformation Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidationContext Class : ContextualInformation Property
Gets a System.Collections.Specialized.HybridDictionary object containing any information that needs to be passed through validation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ContextualInformation As System.Collections.Specialized.HybridDictionary
public System.Collections.Specialized.HybridDictionary ContextualInformation {get;}
See Also

Reference

ValidationContext Class
ValidationContext Members


Mode Property (ValidationContext)

Mode Property (ValidationContext)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidationContext Class : Mode Property
Gets the mode for which the validation context is set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Mode As ValidationMode
public ValidationMode Mode {get;}

Property Value

Returns a ValidationMode enumeration indicating the current mode.
See Also

Reference

ValidationContext Class
ValidationContext Members


NameValidator Property

NameValidator Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidationContext Class : NameValidator Property
Gets a DataDynamics.Reports.ReportObjectMode.Validation.NameValidator object for the current validation context to use for name validation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property NameValidator As NameValidator
public NameValidator NameValidator {get;}
See Also

Reference

ValidationContext Class
ValidationContext Members


ValidationEntry Class

ValidationEntry Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValidationEntry Class
Represents a single entry of information related to validation.
Object Model
ValidationEntry Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ValidationEntry
public sealed class ValidationEntry
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ValidationEntry

See Also

Reference

ValidationEntry Members
GrapeCity.ActiveReports.PageReportModel Namespace


ValidationEntry Class Members

ValidationEntry Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValidationEntry Class

The following tables list the members exposed by ValidationEntry.

Public Constructors
 | Name | Description
Public Constructor | ValidationEntry Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Exception | Gets an System.Exception object to throw when the severity level is Error.
Public Property | Message | Gets a user-friendly message to display.
Public Property | Owner | Gets the object associated with the current validation.
Public Property | Severity | Indicates the severity of the entry.
Top
See Also

Reference

ValidationEntry Class
GrapeCity.ActiveReports.PageReportModel Namespace


ValidationEntry Constructor

ValidationEntry Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidationEntry Class : ValidationEntry Constructor
Overload List
Overload | Description
ValidationEntry Constructor(Severity,String,Object) | Creates a new ValidationEntry
ValidationEntry Constructor(Severity,String,Exception,Object) | Creates a new ValidationEntry
See Also

Reference

ValidationEntry Class
ValidationEntry Members


ValidationEntry Constructor(Severity,String,Object)

ValidationEntry Constructor(Severity,String,Object)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidationEntry Class > ValidationEntry Constructor : ValidationEntry Constructor(Severity,String,Object)
The severity level for the entry
The user friendly message to use for the entry. This message will be displayed in the task list.
Creates a new ValidationEntry
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal severity As Severity, _
   ByVal message As System.String, _
   ByVal owner As System.Object _
)
public ValidationEntry(
   Severity severity,
   System.string message,
   System.object owner
)

Parameters

severity
The severity level for the entry
message
The user friendly message to use for the entry. This message will be displayed in the task list.
owner
See Also

Reference

ValidationEntry Class
ValidationEntry Members
Overload List


ValidationEntry Constructor(Severity,String,Exception,Object)

ValidationEntry Constructor(Severity,String,Exception,Object)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidationEntry Class > ValidationEntry Constructor : ValidationEntry Constructor(Severity,String,Exception,Object)
The severity level for the entry
The user friendly message to use for the entry. This message will be displayed in the task list.
The exception to be logged/fired by the entry.
Creates a new ValidationEntry
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal severity As Severity, _
   ByVal message As System.String, _
   ByVal exception As System.Exception, _
   ByVal owner As System.Object _
)
public ValidationEntry(
   Severity severity,
   System.string message,
   System.Exception exception,
   System.object owner
)

Parameters

severity
The severity level for the entry
message
The user friendly message to use for the entry. This message will be displayed in the task list.
exception
The exception to be logged/fired by the entry.
owner
See Also

Reference

ValidationEntry Class
ValidationEntry Members
Overload List


ValidationEntry Class Properties

ValidationEntry Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValidationEntry Class

For a list of all members of this type, see ValidationEntry members.

Public Properties
 | Name | Description
Public Property | Exception | Gets an System.Exception object to throw when the severity level is Error.
Public Property | Message | Gets a user-friendly message to display.
Public Property | Owner | Gets the object associated with the current validation.
Public Property | Severity | Indicates the severity of the entry.
Top
See Also

Reference

ValidationEntry Class
GrapeCity.ActiveReports.PageReportModel Namespace


Exception Property (ValidationEntry)

Exception Property (ValidationEntry)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidationEntry Class : Exception Property
Gets an System.Exception object to throw when the severity level is Error.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Exception As System.Exception
public System.Exception Exception {get;}
See Also

Reference

ValidationEntry Class
ValidationEntry Members


Message Property (ValidationEntry)

Message Property (ValidationEntry)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidationEntry Class : Message Property
Gets a user-friendly message to display.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Message As System.String
public System.string Message {get;}
See Also

Reference

ValidationEntry Class
ValidationEntry Members


Owner Property (ValidationEntry)

Owner Property (ValidationEntry)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidationEntry Class : Owner Property
Gets the object associated with the current validation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Owner As System.Object
public System.object Owner {get;}
See Also

Reference

ValidationEntry Class
ValidationEntry Members


Severity Property (ValidationEntry)

Severity Property (ValidationEntry)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidationEntry Class : Severity Property
Indicates the severity of the entry.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Severity As Severity
public Severity Severity {get;}

Property Value

Returns a DataDynamics.Reports.ReportObjectModel.Validation.Severity enumeration indicating the severity of the entry.
Remarks
If the severity level is Error, the DataDynamics.Reports.ReportObjectModel.Validation.Exception property is used.
See Also

Reference

ValidationEntry Class
ValidationEntry Members


Validator Class

Validator Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Validator Class
Defines an object for performing validation on a report definition.
Object Model
Validator Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Validator
public sealed class Validator
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Validator

See Also

Reference

Validator Members
GrapeCity.ActiveReports.PageReportModel Namespace


Validator Class Members

Validator Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Validator Class

The following tables list the members exposed by Validator.

Public Properties
 | Name | Description
Public Property | ValidationEntries | Gets the ValidationEntry results from a validated report definition. If there are no entries the returned array is empty.
Top
Public Methods
 | Name | Description
Public Method | Validate | Performs validation on the passed-in report definition.
Top
See Also

Reference

Validator Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validator Class Methods

Validator Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Validator Class

For a list of all members of this type, see Validator members.

Public Methods
 | Name | Description
Public Method | Validate | Performs validation on the passed-in report definition.
Top
See Also

Reference

Validator Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (Validator)

Validate Method (Validator)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Validator Class : Validate Method
The DataDynamics.Reports.ReportDefinition object to validate.
Performs validation on the passed-in report definition.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Validate( _
   ByVal report As PageReport _
)
public void Validate(
   PageReport report
)

Parameters

report
The DataDynamics.Reports.ReportDefinition object to validate.
See Also

Reference

Validator Class
Validator Members


Validator Class Properties

Validator Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Validator Class

For a list of all members of this type, see Validator members.

Public Properties
 | Name | Description
Public Property | ValidationEntries | Gets the ValidationEntry results from a validated report definition. If there are no entries the returned array is empty.
Top
See Also

Reference

Validator Class
GrapeCity.ActiveReports.PageReportModel Namespace


ValidationEntries Property

ValidationEntries Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Validator Class : ValidationEntries Property
Gets the ValidationEntry results from a validated report definition. If there are no entries the returned array is empty.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ValidationEntries As ValidationEntry()
public ValidationEntry[] ValidationEntries {get;}
See Also

Reference

Validator Class
Validator Members


ValidValues Class

ValidValues Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValidValues Class
The possible values for the parameter. This is used to populate UI selection lists from which users can select a parameter value.
Object Model
ValidValues Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ValidValues
public sealed class ValidValues
Remarks

A ValidValues object must have one and only one of the following properties set: DataSetReference or ParameterValues.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ValidValues

See Also

Reference

ValidValues Members
GrapeCity.ActiveReports.PageReportModel Namespace


ValidValues Class Members

ValidValues Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValidValues Class

The following tables list the members exposed by ValidValues.

Public Constructors
 | Name | Description
Public Constructor | ValidValues Constructor | Initializes a new instance of the ValidValues class.
Top
Public Properties
 | Name | Description
Public Property | DataSetReference | Gets or sets the query to execute to obtain the default value(s) for the parameter.
Public Property | ParameterValues | Gets a set of hardcoded values for the parameter.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.ValidValues object.
Top
See Also

Reference

ValidValues Class
GrapeCity.ActiveReports.PageReportModel Namespace


ValidValues Constructor

ValidValues Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidValues Class : ValidValues Constructor

Initializes a new instance of the ValidValues class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ValidValues()
See Also

Reference

ValidValues Class
ValidValues Members


ValidValues Class Methods

ValidValues Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValidValues Class

For a list of all members of this type, see ValidValues members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.ValidValues object.
Top
See Also

Reference

ValidValues Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (ValidValues)

Validate Method (ValidValues)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidValues Class : Validate Method
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.ValidValues object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A DataDynamics.Reports.ReportObjectModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

ValidValues Class
ValidValues Members


ValidValues Class Properties

ValidValues Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValidValues Class

For a list of all members of this type, see ValidValues members.

Public Properties
 | Name | Description
Public Property | DataSetReference | Gets or sets the query to execute to obtain the default value(s) for the parameter.
Public Property | ParameterValues | Gets a set of hardcoded values for the parameter.
Top
See Also

Reference

ValidValues Class
GrapeCity.ActiveReports.PageReportModel Namespace


DataSetReference Property (ValidValues)

DataSetReference Property (ValidValues)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidValues Class : DataSetReference Property

Gets or sets the query to execute to obtain the default value(s) for the parameter.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataSetReference As DataSetReference
public DataSetReference DataSetReference {get; set;}

Property Value

A DataSetReference object representing the query to execute to obtain the default value(s) for the parameter.

Remarks

By default, this is the first value from the ValueField property of the DataSetReference object.

See Also

Reference

ValidValues Class
ValidValues Members


ParameterValues Property

ParameterValues Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValidValues Class : ParameterValues Property

Gets a set of hardcoded values for the parameter.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ParameterValues As ParameterValueCollection
public ParameterValueCollection ParameterValues {get;}

Property Value

A ParameterValuesCollection containing hardcoded values for the parameter.

See Also

Reference

ValidValues Class
ValidValues Members


ValueCategoryAxis Class

ValueCategoryAxis Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValueCategoryAxis Class
Used as a Category axis in a chart, the element defines the category (X) axis. There must be a corresponding DataPoint for each StaticCategories member. Used as a Value axis, the element defines the data (Y) axis.
Object Model
ValueCategoryAxis Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ValueCategoryAxis
public sealed class ValueCategoryAxis
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.ValueCategoryAxis

See Also

Reference

ValueCategoryAxis Members
GrapeCity.ActiveReports.PageReportModel Namespace


ValueCategoryAxis Class Members

ValueCategoryAxis Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValueCategoryAxis Class

The following tables list the members exposed by ValueCategoryAxis.

Public Constructors
 | Name | Description
Public Constructor | ValueCategoryAxis Constructor | Initializes a new instance of the ValueCategoryAxis class.
Top
Public Properties
 | Name | Description
Public Property | Axis | Gets or sets the display properties for the category or value axis.
Top
Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.ValueCategoryAxis object.
Top
See Also

Reference

ValueCategoryAxis Class
GrapeCity.ActiveReports.PageReportModel Namespace


ValueCategoryAxis Constructor

ValueCategoryAxis Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValueCategoryAxis Class : ValueCategoryAxis Constructor

Initializes a new instance of the ValueCategoryAxis class.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ValueCategoryAxis()
See Also

Reference

ValueCategoryAxis Class
ValueCategoryAxis Members


ValueCategoryAxis Class Methods

ValueCategoryAxis Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValueCategoryAxis Class

For a list of all members of this type, see ValueCategoryAxis members.

Public Methods
 | Name | Description
Public Method | Validate | Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.ValueCategoryAxis object.
Top
See Also

Reference

ValueCategoryAxis Class
GrapeCity.ActiveReports.PageReportModel Namespace


Validate Method (ValueCategoryAxis)

Validate Method (ValueCategoryAxis)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValueCategoryAxis Class : Validate Method
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.
Validates the information in each property of the DataDynamics.Reports.ReportObjectModel.Runtime.ValueCategoryAxis object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Validate( _
   ByVal context As ValidationContext _
) As ValidationEntry()
public ValidationEntry[] Validate(
   ValidationContext context
)

Parameters

context
The DataDynamics.Reports.ReportObjectModel.Validation.ValidationContext object containing the contextual information used to drive the validation.

Return Value

A DataDynamics.Reports.ReportObjectModel.Validation.ValidationEntry array containing all the validation entries found, or empty if none are found.
See Also

Reference

ValueCategoryAxis Class
ValueCategoryAxis Members


ValueCategoryAxis Class Properties

ValueCategoryAxis Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValueCategoryAxis Class

For a list of all members of this type, see ValueCategoryAxis members.

Public Properties
 | Name | Description
Public Property | Axis | Gets or sets the display properties for the category or value axis.
Top
See Also

Reference

ValueCategoryAxis Class
GrapeCity.ActiveReports.PageReportModel Namespace


Axis Property

Axis Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ValueCategoryAxis Class : Axis Property

Gets or sets the display properties for the category or value axis.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Axis As Axis
public Axis Axis {get; set;}

Property Value

An Axis object containing the display properties for the category or value axis.

See Also

Reference

ValueCategoryAxis Class
ValueCategoryAxis Members


Variable Class

Variable Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Variable Class
Defines a variable.
Object Model
Variable Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Variable
public class Variable
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Variable

See Also

Reference

Variable Members
GrapeCity.ActiveReports.PageReportModel Namespace


Variable Class Members

Variable Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Variable Class

The following tables list the members exposed by Variable.

Public Constructors
 | Name | Description
Public Constructor | Variable Constructor |
Top
Public Properties
 | Name | Description
Public Property | Name | Specifies the name of variable.
Public Property | Value | Specifies the value of variable.
Public Property | Writable | Specifies whether the variable is writable.
Top
See Also

Reference

Variable Class
GrapeCity.ActiveReports.PageReportModel Namespace


Variable Constructor

Variable Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Variable Class : Variable Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Variable()
See Also

Reference

Variable Class
Variable Members


Variable Class Properties

Variable Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Variable Class

For a list of all members of this type, see Variable members.

Public Properties
 | Name | Description
Public Property | Name | Specifies the name of variable.
Public Property | Value | Specifies the value of variable.
Public Property | Writable | Specifies whether the variable is writable.
Top
See Also

Reference

Variable Class
GrapeCity.ActiveReports.PageReportModel Namespace


Name Property (Variable)

Name Property (Variable)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Variable Class : Name Property
Specifies the name of variable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}
See Also

Reference

Variable Class
Variable Members


Value Property (Variable)

Value Property (Variable)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Variable Class : Value Property
Specifies the value of variable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As ExpressionInfo
public ExpressionInfo Value {get; set;}
See Also

Reference

Variable Class
Variable Members


Writable Property

Writable Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Variable Class : Writable Property
Specifies whether the variable is writable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Writable As System.Boolean
public System.bool Writable {get; set;}
See Also

Reference

Variable Class
Variable Members


Visibility Class

Visibility Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Visibility Class
The Visibility element controls whether the ReportItem is initially shown in the output report.
Object Model
Visibility Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Visibility
public sealed class Visibility
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PageReportModel.Visibility

See Also

Reference

Visibility Members
GrapeCity.ActiveReports.PageReportModel Namespace


Visibility Class Members

Visibility Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Visibility Class

The following tables list the members exposed by Visibility.

Public Constructors
 | Name | Description
Public Constructor | Visibility Constructor |
Top
Public Properties
 | Name | Description
Public Property | Hidden | Gets or sets a Boolean expression that indicates whether the item is initially hidden.
Public Property | ToggleItem | Gets or sets the name of the textbox used to hide or reveal the report item.
Top
See Also

Reference

Visibility Class
GrapeCity.ActiveReports.PageReportModel Namespace


Visibility Constructor

Visibility Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Visibility Class : Visibility Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Visibility()
See Also

Reference

Visibility Class
Visibility Members


Visibility Class Properties

Visibility Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Visibility Class

For a list of all members of this type, see Visibility members.

Public Properties
 | Name | Description
Public Property | Hidden | Gets or sets a Boolean expression that indicates whether the item is initially hidden.
Public Property | ToggleItem | Gets or sets the name of the textbox used to hide or reveal the report item.
Top
See Also

Reference

Visibility Class
GrapeCity.ActiveReports.PageReportModel Namespace


Hidden Property (Visibility)

Hidden Property (Visibility)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Visibility Class : Hidden Property

Gets or sets a Boolean expression that indicates whether the item is initially hidden.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Hidden As ExpressionInfo
public ExpressionInfo Hidden {get; set;}

Property Value

An ExpressionInfo object that evaluates to a Boolean value indicating whether the item is initially hidden. The default value is false.

See Also

Reference

Visibility Class
Visibility Members


ToggleItem Property (Visibility)

ToggleItem Property (Visibility)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Visibility Class : ToggleItem Property

Gets or sets the name of the textbox used to hide or reveal the report item.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ToggleItem As System.String
public System.string ToggleItem {get; set;}

Property Value

A String representing the name of the textbox used to hide or reveal the report item.

See Also

Reference

Visibility Class
Visibility Members


AccentSensitivity Enumeration

AccentSensitivity Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : AccentSensitivity Enumeration
Specifies whether the data is accent sensitive.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum AccentSensitivity
   Inherits System.Enum
public enum AccentSensitivity : System.Enum
Members
Member | Description
Auto | The accent sensitivity setting is derived by querying the data provider.
False | The data is not accent sensitive.
True | The data is accent sensitive.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.AccentSensitivity

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


AntiAliasing Enumeration

AntiAliasing Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : AntiAliasing Enumeration
The possible values for the GaugePanel.AntiAliasing and Map.AntiAliasing properties.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum AntiAliasing
   Inherits System.Enum
public enum AntiAliasing : System.Enum
Members
Member | Description
All | Anti-aliasing is applied to both text and graphics.
Graphics | Anti-aliasing is applied to graphics.
None | Anti-aliasing is not applied.
Text | Anti-aliasing is applied to text.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.AntiAliasing

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


BackgroundHatchTypes Enumeration

BackgroundHatchTypes Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BackgroundHatchTypes Enumeration
The enum for Style.BackgroundHatchType element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum BackgroundHatchTypes
   Inherits System.Enum
public enum BackgroundHatchTypes : System.Enum
Members
Member | Description
BackwardDiagonal | The backward diagonal hatch type.
Cross | The cross hatch type.
DarkDownwardDiagonal | The dark downward diagonal hatch type.
DarkHorizontal | The dark horizontal hatch type.
DarkUpwardDiagonal | The dark upward diagonal hatch type.
DarkVertical | The dark vertical hatch type.
DashedDownwardDiagonal | The dashed downward diagonal hatch type.
DashedHorizontal | The dashed horizontal hatch type.
DashedUpwardDiagonal | The dashed upward diagonal hatch type.
DashedVertical | The dashed vertical hatch type.
Default | The default hatch type.
DiagonalBrick | The diagonal brick hatch type.
DiagonalCross | The diagonal cross hatch type.
Divot | The divot hatch type.
DottedDiamond | The dotted diamond hatch type.
DottedGrid | The dotted grid hatch type.
ForwardDiagonal | The forward diagonal hatch type.
Horizontal | The horizontal hatch type.
HorizontalBrick | The horizontal brick hatch type.
LargeCheckerBoard | The large checker board hatch type.
LargeConfetti | The large confetti hatch type.
LargeGrid | The large grid hatch type.
LightDownwardDiagonal | The light downward diagonal hatch type.
LightHorizontal | The light horizontal hatch type.
LightUpwardDiagonal | The light upward diagonal hatch type.
LightVertical | The light vertical hatch type.
NarrowHorizontal | The narrow horizontal hatch type.
NarrowVertical | The narrow vertical hatch type.
None | The none hatch type.
OutlinedDiamond | The outlined diamond hatch type.
Percent05 | The percent05 hatch type.
Percent10 | The percent10 hatch type.
Percent20 | The percent20 hatch type.
Percent25 | The percent25 hatch type.
Percent30 | The percent30 hatch type.
Percent40 | The percent40 hatch type.
Percent50 | The percent50 hatch type.
Percent60 | The percent60 hatch type.
Percent70 | The percent70 hatch type.
Percent75 | The percent75 hatch type.
Percent80 | The percent80 hatch type.
Percent90 | The percent90 hatch type.
Plaid | The plaid
Shingle | The shingle hatch type.
SmallCheckerBoard | The small checker board hatch type.
SmallConfetti | The small confetti hatch type.
SmallGrid | The small grid hatch type.
SolidDiamond | The solid diamond hatch type.
Sphere | The sphere hatch type.
Trellis | The trellis hatch type.
Vertical | The vertical hatch type.
Wave | The wave hatch type.
Weave | The weave hatch type.
WideDownwardDiagonal | The wide downward diagonal hatch type.
WideUpwardDiagonal | The wide upward diagonal hatch type.
ZigZag | The zig zag hatch type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.BackgroundHatchTypes

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


BorderDrawingStyle Enumeration

BorderDrawingStyle Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderDrawingStyle Enumeration
Specifies the style of the border on a report item.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum BorderDrawingStyle
   Inherits System.Enum
public enum BorderDrawingStyle : System.Enum
Members
Member | Description
DashDot | Indicates a DashDot border line.
DashDotDot | Indicates a DashDotDot border line.
Dashed | Indicates a dashed border line.
Dotted | Indicates a dotted border line.
Double | Indicates a double border line.
Groove | Indicates a grooved border line.
Inset | Indicates an inset border line.
None | Indicates no border line.
Outset | Indicates an outset border line.
Ridge | Indicates a ridged border line.
Solid | Indicates a solid border line.
WindowInset | Indicates a Windows-style inset border line.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.BorderDrawingStyle

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


BorderDrawingStyle2008 Enumeration

BorderDrawingStyle2008 Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BorderDrawingStyle2008 Enumeration
Specifies the style of the border on a report item.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum BorderDrawingStyle2008
   Inherits System.Enum
public enum BorderDrawingStyle2008 : System.Enum
Members
Member | Description
DashDot | Indicates a grooved border line.
DashDotDot | Indicates a DashDotDot border line.
Dashed | Indicates a dashed border line.
Dotted | Indicates a dotted border line.
Double | Indicates a double border line.
None | Indicates no border line.
Solid | Indicates a solid border line.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.BorderDrawingStyle2008

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


BreakLocation Enumeration

BreakLocation Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : BreakLocation Enumeration
Specifies break location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum BreakLocation
   Inherits System.Enum
public enum BreakLocation : System.Enum
Members
Member | Description
Between | Break between.
End | Break at end.
None | No break.
Start | Break at start.
StartAndEnd | Break at start and end.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.BreakLocation

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


CaseSensitivity Enumeration

CaseSensitivity Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CaseSensitivity Enumeration
Specifies whether the data is case sensitive.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum CaseSensitivity
   Inherits System.Enum
public enum CaseSensitivity : System.Enum
Members
Member | Description
Auto | The case sensitivity setting is derived by querying the data provider.
False | The data is not case sensitive.
True | The data is case sensitive.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.CaseSensitivity

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ChartPalette Enumeration

ChartPalette Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartPalette Enumeration
Specifies the color palette for chart items.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ChartPalette
   Inherits System.Enum
public enum ChartPalette : System.Enum
Members
Member | Description
Custom | Custom chart palette
Default | Indicates the default palette of rich jewel tones.
EarthTones | Indicates an earth tone palette of autumnal browns, oranges, and greens.
Excel | Indicates an Excel palette of muted plums, blues, and creams.
GrayScale | Indicates a gray scale palette of patterns suitable for printing to a black and white printer.
Light | Indicates a light colored palette of pale pinks and peaches.
Pastel | Indicates a pastel palette of blues, greens and purples.
SemiTransparent | Indicates a semi-transparent palette of primary and tertiary colors that allows the backdrop to show through.
Subdued | Indicates a palette of subdued colors ideal for charts where the data should not have special emphasis drawn to it.
Theme | Theme chart palette
Vivid | Indicates a vivid palette of colors idea for drawing emphasis to the data being displayed in the chart.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ChartPalette

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ChartSeriesPlotType Enumeration

ChartSeriesPlotType Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartSeriesPlotType Enumeration
Specifies whether the series is plotted as a line on a column chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ChartSeriesPlotType
   Inherits System.Enum
public enum ChartSeriesPlotType : System.Enum
Members
Member | Description
Auto | Indicates the series should be plotted based on the chart type. The series is plotted based on the primary chart type. For example, the plot type for a column chart is columns.
Line | Indicates the series should be plotted as a line. Indicates that the series is plotted as a line.
Point | Indicates the series should be plotted with points.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ChartSeriesPlotType

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ChartSubtype Enumeration

ChartSubtype Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartSubtype Enumeration
Specifies the subtype of the chart. Different subtypes are available for each chart type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ChartSubtype
   Inherits System.Enum
public enum ChartSubtype : System.Enum
Members
Member | Description
Candlestick | Used with Stock chart types.
Exploded | Used with Pie and Doughnut chart types.
HighLowClose | Used with Stock chart types.
Line | Used with Scatter chart types.
OpenHighLowClose | Used with Stock chart types.
PercentStacked | Used with Column, Bar, and Area chart types.
Plain | Used with Column, Bar, Line, Pie, Scatter, Bubble, Area, and Doughnut chart types.
Smooth | Used with Line chart types.
SmoothLine | Used with Scatter chart types.
Stacked | Used with Column, Bar, and Area chart types.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ChartSubtype

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ChartType Enumeration

ChartType Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ChartType Enumeration
Specifies the type of the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ChartType
   Inherits System.Enum
public enum ChartType : System.Enum
Members
Member | Description
Area | The chart fills an area below a line to display values.
Bar | The chart uses horizontal bars to display values.
Bubble | The chart uses bubbles to display values.
Column | The chart uses vertical bars to display values.
DotPlot | Dot plot chart type
Doughnut | The chart uses segments of a doughnut to display values to total 100%.
Funnel | The chart uses segments of a funnel to display values to total 100%.
Gantt | The chart uses bars to display beginning and ending values.
Kagi | The chart uses connected vertical lines of varying thicknesses to display values and reversals.
Line | The chart uses lines to display values.
Pie | The chart uses wedges in a pie to display values to total 100%.
PointAndFigure | The chart uses Xs and Os to display rising or falling values.
Pyramid | The chart uses segments of a pyramid to display values to total 100%.
Renko | The chart uses bricks to display trends in values.
Scatter | The chart uses markers or points to display values.
Stock | The chart uses sticks to display high, low, and closing (and opening) values.
ThreeLineBreak | The chart uses boxes to display rising or falling values which break the previous high or low value.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ChartType

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


CollateBy Enumeration

CollateBy Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CollateBy Enumeration
Controls the combination of reports during output when using a theme.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum CollateBy
   Inherits System.Enum
public enum CollateBy : System.Enum
Members
Member | Description
Simple | Defines the simple collation.
Value | Defines the collation when the pages are grouped by the page report grouping value.
ValueIndex | Defines the collation when the pages are grouped by the page report grouping, then by the page input.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.CollateBy

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


DataElementOutput Enumeration

DataElementOutput Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataElementOutput Enumeration
Defines how an item should appear in data output.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DataElementOutput
   Inherits System.Enum
public enum DataElementOutput : System.Enum
Members
Member | Description
Auto | If the item is a text box with a constant value, such as a label, the item does not appear (NoOutput). If the item is a rectangle, the output is the same as it is for ContentsOnly. For all other report items, the item appears in the output (Output).
ContentsOnly | Applies to XML only. Indicates the item does not appear in the XML, but the contents of the item are rendered as part of the containing report control. ContentsOnly can only be used with lists.
NoOutput | Indicates the item should not appear in the output.
Output | Indicates the item should appear in the output.
Remarks
Some ReportItems do not support all values (for example List and Table do not support Auto).
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.DataElementOutput

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


DataElementStyle Enumeration

DataElementStyle Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataElementStyle Enumeration
Indicates whether an item should render as an element or attribute.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DataElementStyle
   Inherits System.Enum
public enum DataElementStyle : System.Enum
Members
Member | Description
AttributeNormal | Render as an attribute.
Auto | Auto settings.
ElementNormal | Render as an element.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.DataElementStyle

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


DocumentMapSource Enumeration

DocumentMapSource Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DocumentMapSource Enumeration
Defines an enumeration of document map sources.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DocumentMapSource
   Inherits System.Enum
public enum DocumentMapSource : System.Enum
Members
Member | Description
All | The document map provided by both labels and headings.
Headings | The document map provided by headings.
Labels | The document map prodived by labels of controls.
None | No document map.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.DocumentMapSource

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


FilterOperator Enumeration

FilterOperator Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : FilterOperator Enumeration
Specifies the operator to use to compare the values returned by the FilterExpression with those in the FilterValues object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum FilterOperator
   Inherits System.Enum
public enum FilterOperator : System.Enum
Members
Member | Description
Between | Displays the record if the FilterExpression result falls between the two FilterValues.
BottomN | Displays the record if the FilterExpression result is in the bottom N of all records processed.
BottomPercent | Displays the record if the FilterExpression result is in the bottom N% of all records processed.
Equal | Displays the record if the two values are equal.
GreaterThan | Displays the record if the FilterExpression result is greater than the FilterValues.
GreaterThanOrEqual | Displays the record if the FilterExpression result is greater than or equal to the FilterValues.
In | Displays the record if the FilterExpression result is within the list of FilterValues.
LessThan | Displays the record if the FilterExpression result is less than the FilterValue.
LessThanOrEqual | Displays the record if the FilterExpression result is less than or equal to the FilterValue.
Like | Displays the record if the FilterExpression results satisfy the pattern set in the FilterValues.
NotEqual | Displays the record if the two values are not equal.
TopN | Displays the record if the FilterExpression result is in the top N of all records processed.
TopPercent | Displays the record if the FilterExpression result is in the top N% of all records processed.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.FilterOperator

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ItemOwners Enumeration

ItemOwners Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ItemOwners Enumeration
Specifies the report component owner when master report is defined for child report
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ItemOwners
   Inherits System.Enum
public enum ItemOwners : System.Enum
Members
Member | Description
Child | Item was contributed by the child report
Master | Item was inferred from the master report
None | unknow/not applicable
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ItemOwners

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


KanatypeSensitivity Enumeration

KanatypeSensitivity Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : KanatypeSensitivity Enumeration
Specifies whether the data is Kanatype sensitive. (Used with the Japanese language to distinguish between hiragana and katakana.)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum KanatypeSensitivity
   Inherits System.Enum
public enum KanatypeSensitivity : System.Enum
Members
Member | Description
Auto | The Kanatype sensitivity setting is derived by querying the data provider.
False | There is no distinction between hiragana and katakana.
True | There is a distinction between hiragana and katakana.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.KanatypeSensitivity

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


KeepWithGroup Enumeration

KeepWithGroup Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : KeepWithGroup Enumeration
Defines KeepWithGroup property values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum KeepWithGroup
   Inherits System.Enum
public enum KeepWithGroup : System.Enum
Members
Member | Description
After | Keep after group.
Before | Keep before group.
None | Do not keep with group.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.KeepWithGroup

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


LegendLayout Enumeration

LegendLayout Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LegendLayout Enumeration
Specifies the arrangement of labels within the legend.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LegendLayout
   Inherits System.Enum
public enum LegendLayout : System.Enum
Members
Member | Description
Column | Indicates that the labels are arranged in a single column.
Row | Indicates that the labels are arranged in a single row.
Table | Indicates that the labels are arranged in a table with as many rows and columns as required.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.LegendLayout

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


LegendPosition Enumeration

LegendPosition Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : LegendPosition Enumeration
Specifies the position of the legend.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LegendPosition
   Inherits System.Enum
public enum LegendPosition : System.Enum
Members
Member | Description
BottomCenter | Indicates that the legend is positioned below the chart at the center.
BottomLeft | Indicates that the legend is positioned below the chart on the left.
BottomRight | Indicates that the legend is positioned below the chart on the right.
LeftBottom | Indicates that the legend is positioned to the left of the chart at the bottom.
LeftCenter | Indicates that the legend is positioned to the left of the chart at the center.
LeftTop | Indicates that the legend is positioned to the left of the chart at the top.
RightBottom | Indicates that the legend is positioned to the right of the chart at the bottom.
RightCenter | Indicates that the legend is positioned to the right of the chart at the center.
RightTop | Indicates that the legend is positioned to the right of the chart at the top.
TopCenter | Indicates that the legend is positioned above the chart at the center.
TopLeft | Indicates that the legend is positioned above the chart on the left.
TopRight | Indicates that the legend is positioned above the chart on the right.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.LegendPosition

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapBorderSkin.BorderSkinType Enumeration

MapBorderSkin.BorderSkinType Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapBorderSkin.BorderSkinType Enumeration
Border skin type for the map
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapBorderSkin.BorderSkinType
   Inherits System.Enum
public enum MapBorderSkin.BorderSkinType : System.Enum
Members
Member | Description
Emboss | Use Emboss border skin
FrameThin1 | Use FrameThin1 border skin
FrameThin2 | Use FrameThin2 border skin
FrameThin3 | Use FrameThin3 border skin
FrameThin4 | Use FrameThin4 border skin
FrameThin5 | Use FrameThin5 border skin
FrameThin6 | Use FrameThin6 border skin
FrameTitle1 | Use FrameTitle1 border skin
FrameTitle2 | Use FrameTitle2 border skin
FrameTitle3 | Use FrameTitle3 border skin
FrameTitle4 | Use FrameTitle4 border skin
FrameTitle5 | Use FrameTitle5 border skin
FrameTitle6 | Use FrameTitle6 border skin
FrameTitle7 | Use FrameTitle7 border skin
FrameTitle8 | Use FrameTitle8 border skin
None | No border skin
Raised | Use Raised border skin
Sunken | Use Sunken border skin
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapBorderSkin.BorderSkinType

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapColorPalette Enumeration

MapColorPalette Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorPalette Enumeration
Indicates the palette to be used for coloring the spatial elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapColorPalette
   Inherits System.Enum
public enum MapColorPalette : System.Enum
Members
Member | Description
BrightPastel | Use BrightPastel palette
Light | Use Light palette
Random | Use Random palette
SemiTransparent | Use SemiTransparent palette
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapColorPalette

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapColorScale.MapLabelBehavior Enumeration

MapColorScale.MapLabelBehavior Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorScale.MapLabelBehavior Enumeration
Indicates the positioning of the color scale labels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapColorScale.MapLabelBehavior
   Inherits System.Enum
public enum MapColorScale.MapLabelBehavior : System.Enum
Members
Member | Description
Auto | Automatically determined
ShowBorderValue | Labels are displayed at the borders between color divisions.
ShowMiddleValue | Labels are displayed in the middle of each color division.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapColorScale.MapLabelBehavior

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapColorScale.MapLabelPlacement Enumeration

MapColorScale.MapLabelPlacement Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapColorScale.MapLabelPlacement Enumeration
Indicates the labels placement along the color bar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapColorScale.MapLabelPlacement
   Inherits System.Enum
public enum MapColorScale.MapLabelPlacement : System.Enum
Members
Member | Description
Alternate | Odd labels are below the color bar and even ones are above.
Bottom | Labels are positioned below the color bar.
Top | Labels are positioned above the color bar.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapColorScale.MapLabelPlacement

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapCoordinateSystem Enumeration

MapCoordinateSystem Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapCoordinateSystem Enumeration
The map coordinate system.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapCoordinateSystem
   Inherits System.Enum
public enum MapCoordinateSystem : System.Enum
Members
Member | Description
Geographic | Geographic coordinate system (longitude and latitude).
Planar | Planar coordinate system.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapCoordinateSystem

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapDataType Enumeration

MapDataType Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDataType Enumeration
The data type of the field.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapDataType
   Inherits System.Enum
public enum MapDataType : System.Enum
Members
Member | Description
Boolean | Field values are Boolean
DateTime | Fields values are DateTime
Decimal | Fields values are Decimal
Float | Fields values are Float
Integer | Fields values are Integer
String | Fields values are String
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapDataType

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapDockableSubItem.MapPosition Enumeration

MapDockableSubItem.MapPosition Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDockableSubItem.MapPosition Enumeration
The position of the sub item.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapDockableSubItem.MapPosition
   Inherits System.Enum
public enum MapDockableSubItem.MapPosition : System.Enum
Members
Member | Description
BottomCenter | Position title at BottomCenter
BottomLeft | Position title at BottomLeft
BottomRight | Position title at BottomRight
LeftBottom | Position title at LeftBottom
LeftCenter | Position title at LeftCenter
LeftTop | Position title at LeftTop
RightBottom | Position title at RightBottom
RightCenter | Position title at RightCenter
RightTop | Position title at RightTop
TopCenter | Position title at TopCenter
TopLeft | Position title at TopLeft
TopRight | Position title at TopRight
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem.MapPosition

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapGridLines.LabelPositionType Enumeration

MapGridLines.LabelPositionType Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapGridLines.LabelPositionType Enumeration
Defines the position for grid labels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapGridLines.LabelPositionType
   Inherits System.Enum
public enum MapGridLines.LabelPositionType : System.Enum
Members
Member | Description
Center | Labels are centered.
Far | Labels are on the right for parallels and on bottom for meridians.
Near | Labels are on the left for parallels and on top for meridians.
OneQuarter | Labels are between the left and center for parallels and between top and center for meridians.
ThreeQuarters | Labels are between the center and right for parallels and between center and bottom for meridians.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapGridLines.LabelPositionType

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapLegendTitle.LegendTitleSeparator Enumeration

MapLegendTitle.LegendTitleSeparator Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLegendTitle.LegendTitleSeparator Enumeration
Indicates what type of separator to use for the legend title.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapLegendTitle.LegendTitleSeparator
   Inherits System.Enum
public enum MapLegendTitle.LegendTitleSeparator : System.Enum
Members
Member | Description
DashLine | Separate with DashLine
DotLine | Separate with DotLine
DoubleLine | Separate with DoubleLine
GradientLine | Separate with GradientLine
Line | Separate with Line
None | No separator
ThickGradientLine | Separate with ThickGradientLine
ThickLine | Separate with ThickLine
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapLegendTitle.LegendTitleSeparator

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapLineTemplate.LineLabelPlacement Enumeration

MapLineTemplate.LineLabelPlacement Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapLineTemplate.LineLabelPlacement Enumeration
Defines the label placement for the line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapLineTemplate.LineLabelPlacement
   Inherits System.Enum
public enum MapLineTemplate.LineLabelPlacement : System.Enum
Members
Member | Description
Above | Label placed above.
Below | Label placed below.
Center | Label placed to the center.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapLineTemplate.LineLabelPlacement

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapMarker.MarkerStyle Enumeration

MapMarker.MarkerStyle Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarker.MarkerStyle Enumeration
Defines the point marker.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapMarker.MarkerStyle
   Inherits System.Enum
public enum MapMarker.MarkerStyle : System.Enum
Members
Member | Description
Circle | Circle marker
Diamond | Diamond marker
Image | Image marker
None | Default
Pentagon | Pentagon marker
PushPin | Push Pin marker
Rectangle | Rectangle marker
Star | Star marker
Trapezoid | Trapezoid marker
Triangle | Triangle marker
Wedge | Wedge marker
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapMarker.MarkerStyle

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapMarkerImage.ImageResizeMode Enumeration

MapMarkerImage.ImageResizeMode Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapMarkerImage.ImageResizeMode Enumeration
Indicates whether the content will resize to fit in the available space.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapMarkerImage.ImageResizeMode
   Inherits System.Enum
public enum MapMarkerImage.ImageResizeMode : System.Enum
Members
Member | Description
AutoFit | Fits the available size.
None | No fitting.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapMarkerImage.ImageResizeMode

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapPointTemplate.MapPointLabelPlacement Enumeration

MapPointTemplate.MapPointLabelPlacement Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPointTemplate.MapPointLabelPlacement Enumeration
Defines the label placement for the point.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapPointTemplate.MapPointLabelPlacement
   Inherits System.Enum
public enum MapPointTemplate.MapPointLabelPlacement : System.Enum
Members
Member | Description
Bottom | Label placed to the bottom.
Center | Label placed to the center.
Left | Label placed to the left.
Right | Label placed to the right.
Top | Label placed to the top.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapPointTemplate.MapPointLabelPlacement

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapPolygonTemplate.PolygonLabelPlacement Enumeration

MapPolygonTemplate.PolygonLabelPlacement Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonTemplate.PolygonLabelPlacement Enumeration
Indicates the label placement of the polygon
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapPolygonTemplate.PolygonLabelPlacement
   Inherits System.Enum
public enum MapPolygonTemplate.PolygonLabelPlacement : System.Enum
Members
Member | Description
BottomCenter | Label placed to the bottom center.
BottomLeft | Label placed to the bottom left.
BottomRight | Label placed to the bottom right.
MiddleCenter | Label placed to the middle center.
MiddleLeft | Label placed to the middle left.
MiddleRight | Label placed to the middle right.
TopCenter | Label placed to the top center.
TopLeft | Label placed to the top left.
TopRight | Label placed to the top right.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapPolygonTemplate.PolygonLabelPlacement

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapPolygonTemplate.PolygonShowLabel Enumeration

MapPolygonTemplate.PolygonShowLabel Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapPolygonTemplate.PolygonShowLabel Enumeration
Indicates if the label should be shown.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapPolygonTemplate.PolygonShowLabel
   Inherits System.Enum
public enum MapPolygonTemplate.PolygonShowLabel : System.Enum
Members
Member | Description
Auto | Default
False | Always Hide
True | Always Show
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapPolygonTemplate.PolygonShowLabel

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapProjection Enumeration

MapProjection Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapProjection Enumeration
The map projection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapProjection
   Inherits System.Enum
public enum MapProjection : System.Enum
Members
Member | Description
Bonne | Bonne projection
Eckert1 | Eckert1 projection
Eckert3 | Eckert3 projection
Equirectangular | Equirectangular projection
Fahey | Fahey projection
HammerAitoff | HammerAitoff projection
Mercator | Mercator projection
Robinson | Robinson projection
Wagner3 | Wagner3 projection
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapProjection

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapRuleDistributionType Enumeration

MapRuleDistributionType Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapRuleDistributionType Enumeration
Indicates the distribution type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapRuleDistributionType
   Inherits System.Enum
public enum MapRuleDistributionType : System.Enum
Members
Member | Description
Custom | Custom Distribution
EqualDistribution | Equal Distribution
EqualInterval | Equal Interval
Optimal | Optimal Distribution
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapRuleDistributionType

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapTileLayer.MapTileStyle Enumeration

MapTileLayer.MapTileStyle Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapTileLayer.MapTileStyle Enumeration
Indicates the tiles style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapTileLayer.MapTileStyle
   Inherits System.Enum
public enum MapTileLayer.MapTileStyle : System.Enum
Members
Member | Description
Aerial | Tiles containing aerial imagery of the earth.
Hybrid | Tiles containing aerial imagery of borders and roads.
Road | Tiles containing roads and streets.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapTileLayer.MapTileStyle

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapUnit Enumeration

MapUnit Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapUnit Enumeration
Defines the unit for both width and height.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapUnit
   Inherits System.Enum
public enum MapUnit : System.Enum
Members
Member | Description
Centimeter | Unit is Centimeter
Inch | Unit is Inch
Millimeter | Unit is Millimeter
Percentage | Unit is percentage of the containing object’s width/height.
Pica | Unit is Pica (12 Points)
Point | Unit is Point
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapUnit

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MapVisibilityMode Enumeration

MapVisibilityMode Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapVisibilityMode Enumeration
Indicates the layer visibility mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MapVisibilityMode
   Inherits System.Enum
public enum MapVisibilityMode : System.Enum
Members
Member | Description
Hidden | Layer is hidden
Visible | Layer is Shown
ZoomBased | Layer is shown within a zoom level range defined by MapLayer.MinimumZoom MapLayer.MaximumZoom
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MapVisibilityMode

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MarkerType Enumeration

MarkerType Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MarkerType Enumeration
Specifies the type of marker to use with chart data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MarkerType
   Inherits System.Enum
public enum MarkerType : System.Enum
Members
Member | Description
Auto | Indicates that a marker shape is chosen automatically.
Circle | Indicates a round marker.
Cross | Indicates a cross-shaped marker.
Diamond | Indicates a diamond-shaped marker.
None | Indicates no marker.
Square | Indicates a square marker.
Triangle | Indicates a triangular marker.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.MarkerType

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


NameType Enumeration

NameType Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : NameType Enumeration
Specifies the type of object the name belongs to.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum NameType
   Inherits System.Enum
public enum NameType : System.Enum
Members
Member | Description
Control | The name belongs to a control.
DataRegion | The name belongs to a DataRegion.
DataSet | The name belongs to a DataSet.
Grouping | The name belongs to a Grouping.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.NameType

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


NumberingStyle Enumeration

NumberingStyle Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : NumberingStyle Enumeration
Defines the numbering style enumeration.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum NumberingStyle
   Inherits System.Enum
public enum NumberingStyle : System.Enum
Members
Member | Description
Decimal | The decimal numbering style.
DecimalLeadingZero | The decimal numbering style with leading zero .
Georgian | The georgian numbering style.
LowerArmenian | The lower armenian numbering style.
LowerGreek | The lower greek numbering style.
LowerLatin | The lower latin numbering style.
LowerRoman | The lower roman numbering style.
None | No numbering.
UpperArmenian | The upper armenian numbering style.
UpperGreek | The upper greek numbering style.
UpperLatin | The upper latin numbering style.
UpperRoman | The upper roman numbering style.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.NumberingStyle

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


PaperOrientation Enumeration

PaperOrientation Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PaperOrientation Enumeration
Represents the list of paper orientation options.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PaperOrientation
   Inherits System.Enum
public enum PaperOrientation : System.Enum
Members
Member | Description
Landscape | Landscape orientation.
Portrait | Portrait orientation.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.PaperOrientation

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


Position Enumeration

Position Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Position Enumeration
Specifies the position of a data label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Position
   Inherits System.Enum
public enum Position : System.Enum
Members
Member | Description
Auto | Indicates that the data label position is automatically determined.
Bottom | Indicates that the data label is at the bottom.
BottomLeft | Indicates that the data label is at the bottom left.
BottomRight | Indicates that the data label is at the bottom right.
Center | Indicates that the data label is at the center.
Left | Indicates that the data label is at the left.
Right | Indicates that the data label is at the right.
Top | Indicates that the data label is at the top.
TopLeft | Indicates that the data label is at the top left.
TopRight | Indicates that the data label is at the top right.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.Position

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


QueryCommandType Enumeration

QueryCommandType Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : QueryCommandType Enumeration
Specifies the type of query contained in the CommandText.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum QueryCommandType
   Inherits System.Enum
public enum QueryCommandType : System.Enum
Members
Member | Description
StoredProcedure | Indicates that the value of the CommandText is the name of a stored procedure to execute. The stored procedure must return a single result set.
TableDirect | Indicates that the value of the CommandText is the name of a table from which to retrieve data. All data from the table is returned.
Text | Indicates that the value of the CommandText is a text string to pass to the data source, for example, a Transact-SQL query.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.QueryCommandType

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ReportParameterDataType Enumeration

ReportParameterDataType Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportParameterDataType Enumeration
Specifies the data type for the parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ReportParameterDataType
   Inherits System.Enum
public enum ReportParameterDataType : System.Enum
Members
Member | Description
Boolean | The data type is Boolean.
DateTime | The data type is date/time.
Float | The data type is float.
Integer | The data type is integer.
String | The data type is string.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ReportParameterDataType

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ReportParameterUsedInQuery Enumeration

ReportParameterUsedInQuery Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportParameterUsedInQuery Enumeration
Specifies whether the parameter is used in a query in the report. This evaluates to True if the parameter is referenced in any query value expression.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ReportParameterUsedInQuery
   Inherits System.Enum
public enum ReportParameterUsedInQuery : System.Enum
Members
Member | Description
Auto | Indicates that the setting is automatically detected.
False | The parameter is not used in a query.
True | The parameter is used in a query.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ReportParameterUsedInQuery

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


Severity Enumeration

Severity Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Severity Enumeration
Specifies the severity level of a ValidationEntry object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Severity
   Inherits System.Enum
public enum Severity : System.Enum
Members
Member | Description
Error | Indicates that the report cannot be processed until the error is corrected.
Information | Indicates that the entry is for informational purposes only.
Warning | Indicates that the report should be able to execute but may have unexpected results.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.Severity

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


SortByDirection Enumeration

SortByDirection Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SortByDirection Enumeration
Specifies whether items are sorted in ascending or descending order.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum SortByDirection
   Inherits System.Enum
public enum SortByDirection : System.Enum
Members
Member | Description
Ascending | Items are sorted in ascending order.
Descending | Items are sorted in descending order.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.SortByDirection

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


StyleSheetSource Enumeration

StyleSheetSource Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StyleSheetSource Enumeration
Enumeration of stylesheet sources.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum StyleSheetSource
   Inherits System.Enum
public enum StyleSheetSource : System.Enum
Members
Member | Description
Embedded | Embedded stylesheet source.
External | External stylesheet source.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.StyleSheetSource

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


StyleType Enumeration

StyleType Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StyleType Enumeration
Enumeration of style types.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum StyleType
   Inherits System.Enum
public enum StyleType : System.Enum
Members
Member | Description
Common | Common style type.
TableOfContent | TOC style type
TableOfContentLevel | TOC level style type
Text | Text style type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.StyleType

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


SubtotalPosition Enumeration

SubtotalPosition Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SubtotalPosition Enumeration
Specifies whether the subtotal rows or columns appear before or after the detail rows or columns.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum SubtotalPosition
   Inherits System.Enum
public enum SubtotalPosition : System.Enum
Members
Member | Description
After | Subtotal column or row appears after the detail columns or rows.
Before | Subtotal column or row appears before the detail columns or rows.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.SubtotalPosition

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


TargetDevices Enumeration

TargetDevices Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TargetDevices Enumeration
Defines enumeration of possible target devices for layer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TargetDevices
   Inherits System.Enum
public enum TargetDevices : System.Enum
Members
Member | Description
All | Allows to output to Screen, Paper and Export target devices
Export | Allows to output to Export target device
None | Forbids to output to any target device
Paper | Allows to output to Paper target device
Screen | Allows to output to Screen target device
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.TargetDevices

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


TextAlign Enumeration

TextAlign Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextAlign Enumeration
Specifies the horizontal alignment of the text
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TextAlign
   Inherits System.Enum
public enum TextAlign : System.Enum
Members
Member | Description
Center | Indicates align centered.
General | Indicates aligment will be based off of the content type.
Justify | Indicates justified align.
Left | Indicates align to the left.
Right | Indicates align to the right.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.TextAlign

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


TextAntiAliasingQuality Enumeration

TextAntiAliasingQuality Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextAntiAliasingQuality Enumeration
Defines the enumeration of text anti-aliasing quality.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TextAntiAliasingQuality
   Inherits System.Enum
public enum TextAntiAliasingQuality : System.Enum
Members
Member | Description
High | The high quality anti-aliasing.
Normal | The normal quality anti-aliasing.
SystemDefault | The system default anti-aliasing.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.TextAntiAliasingQuality

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ThreeDPropertiesDrawingStyle Enumeration

ThreeDPropertiesDrawingStyle Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ThreeDPropertiesDrawingStyle Enumeration
Specifies the shape of the columns or bars in a three-dimensional chart. ThreeDPropertiesDrawingStyle only applies to bar and column charts.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ThreeDPropertiesDrawingStyle
   Inherits System.Enum
public enum ThreeDPropertiesDrawingStyle : System.Enum
Members
Member | Description
Cube | Indicates that the column or bar is drawn as a cube.
Cylinder | Indicates that the column or bar is drawn as a cylinder.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ThreeDPropertiesDrawingStyle

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ThreeDPropertiesProjectionMode Enumeration

ThreeDPropertiesProjectionMode Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ThreeDPropertiesProjectionMode Enumeration
Specifies the projection mode for the three-dimensional chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ThreeDPropertiesProjectionMode
   Inherits System.Enum
public enum ThreeDPropertiesProjectionMode : System.Enum
Members
Member | Description
Orthographic | Indicates that the projection is set to Orthographic.
Perspective | Indicates that the projection is set to perspective.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ThreeDPropertiesProjectionMode

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ThreeDPropertiesShading Enumeration

ThreeDPropertiesShading Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ThreeDPropertiesShading Enumeration
Specifies the shading style of the three-dimensional chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ThreeDPropertiesShading
   Inherits System.Enum
public enum ThreeDPropertiesShading : System.Enum
Members
Member | Description
None | Indicates no shading.
Real | Indicates realistic shading.
Simple | Indicates simple shading.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ThreeDPropertiesShading

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


TickMark Enumeration

TickMark Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TickMark Enumeration
Specifies the position of the tick marks on the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TickMark
   Inherits System.Enum
public enum TickMark : System.Enum
Members
Member | Description
Cross | Indicates that the tick marks cross the axis.
Inside | Indicates that the tick marks are inside the axis.
None | Indicates no tick marks.
Outside | Indicates that the tick marks are outside the axis.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.TickMark

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


TitlePosition Enumeration

TitlePosition Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TitlePosition Enumeration
Specifies the position of the title. TitlePosition is not used for the chart title.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TitlePosition
   Inherits System.Enum
public enum TitlePosition : System.Enum
Members
Member | Description
Center | Indicates that the title is centered.
Far | Indicates that the title is aligned further from the chart.
Near | Indicates that the title is aligned near the chart.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.TitlePosition

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


ValidationMode Enumeration

ValidationMode Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ValidationMode Enumeration
Indicates the current mode of the validation system. Different severities and validation entries may be used for different modes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ValidationMode
   Inherits System.Enum
public enum ValidationMode : System.Enum
Members
Member | Description
BeforeProcessing | Indicates that the validation is being done in order to process a report. Any errors cause the report processing to halt.
DesignTime | Indicates that the validation is being done at design time and the user will have a chance to correct any detected validation entries.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.ValidationMode

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


WidthSensitivity Enumeration

WidthSensitivity Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : WidthSensitivity Enumeration
Specifies whether the data is width sensitive.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum WidthSensitivity
   Inherits System.Enum
public enum WidthSensitivity : System.Enum
Members
Member | Description
Auto | The width sensitivity setting is derived by querying the data provider.
False | Data is not width sensitive.
True | Data is width sensitive.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.PageReportModel.WidthSensitivity

See Also

Reference

GrapeCity.ActiveReports.PageReportModel Namespace


MasterContentCode Structure

MasterContentCode Structure
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MasterContentCode Structure
Defines a struct for containing the master and child report code separately.
Object Model
MasterContentCode Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure MasterContentCode
   Inherits System.ValueType
public struct MasterContentCode : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.ActiveReports.PageReportModel.MasterContentCode

See Also

Reference

MasterContentCode Members
GrapeCity.ActiveReports.PageReportModel Namespace


MasterContentCode Structure Members

MasterContentCode Structure Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MasterContentCode Structure

The following tables list the members exposed by MasterContentCode.

Public Constructors
 | Name | Description
Public Constructor | MasterContentCode Constructor | Initializes a new instance of the MasterContentCode.
Top
Public Properties
 | Name | Description
Public Property | ChildCode | Gets the code property value from the child report.
Public Property | MasterCode | Gets the code property value from the master report.
Top
See Also

Reference

MasterContentCode Structure
GrapeCity.ActiveReports.PageReportModel Namespace


MasterContentCode Constructor

MasterContentCode Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterContentCode Structure : MasterContentCode Constructor
The code property value coming from the master report.
The code property value coming fromt the child report.
Initializes a new instance of the MasterContentCode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal masterCode As System.String, _
   ByVal childCode As System.String _
)
public MasterContentCode(
   System.string masterCode,
   System.string childCode
)

Parameters

masterCode
The code property value coming from the master report.
childCode
The code property value coming fromt the child report.
See Also

Reference

MasterContentCode Structure
MasterContentCode Members


MasterContentCode Structure Properties

MasterContentCode Structure Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MasterContentCode Structure

For a list of all members of this type, see MasterContentCode members.

Public Properties
 | Name | Description
Public Property | ChildCode | Gets the code property value from the child report.
Public Property | MasterCode | Gets the code property value from the master report.
Top
See Also

Reference

MasterContentCode Structure
GrapeCity.ActiveReports.PageReportModel Namespace


ChildCode Property

ChildCode Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterContentCode Structure : ChildCode Property
Gets the code property value from the child report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ChildCode As System.String
public System.string ChildCode {get;}
See Also

Reference

MasterContentCode Structure
MasterContentCode Members


MasterCode Property

MasterCode Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterContentCode Structure : MasterCode Property
Gets the code property value from the master report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MasterCode As System.String
public System.string MasterCode {get;}
See Also

Reference

MasterContentCode Structure
MasterContentCode Members


IBaseDataSet Interface

IBaseDataSet Interface
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IBaseDataSet Interface
Represents the members common to all types of datasets.
Object Model
IBaseDataSet Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IBaseDataSet
public interface IBaseDataSet
See Also

Reference

IBaseDataSet Members
GrapeCity.ActiveReports.PageReportModel Namespace


IBaseDataSet Interface Members

IBaseDataSet Interface Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IBaseDataSet Interface

The following tables list the members exposed by IBaseDataSet.

Public Properties
 | Name | Description
Property | AccentSensitivity | Gets or sets a value indicating whether the data is accent sensitive.
Property | CaseSensitivity | Gets or sets a value indicating whether the data is case sensitive.
Property | Collation | Gets or sets the locale to use in the collation sequence for sorting data.
Property | Fields | Gets or sets the fields in the data set.
Property | KanatypeSensitivity | Gets or sets a value indicating whether the data is kanatype sensitive.
Property | Name | Gets or sets the name of the data set.
Property | WidthSensitivity | Gets or sets a value indicating whether the data is width sensitive.
Top
See Also

Reference

IBaseDataSet Interface
GrapeCity.ActiveReports.PageReportModel Namespace


IBaseDataSet Interface Properties

IBaseDataSet Interface Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IBaseDataSet Interface

For a list of all members of this type, see IBaseDataSet members.

Public Properties
 | Name | Description
Property | AccentSensitivity | Gets or sets a value indicating whether the data is accent sensitive.
Property | CaseSensitivity | Gets or sets a value indicating whether the data is case sensitive.
Property | Collation | Gets or sets the locale to use in the collation sequence for sorting data.
Property | Fields | Gets or sets the fields in the data set.
Property | KanatypeSensitivity | Gets or sets a value indicating whether the data is kanatype sensitive.
Property | Name | Gets or sets the name of the data set.
Property | WidthSensitivity | Gets or sets a value indicating whether the data is width sensitive.
Top
See Also

Reference

IBaseDataSet Interface
GrapeCity.ActiveReports.PageReportModel Namespace


AccentSensitivity Property (IBaseDataSet)

AccentSensitivity Property (IBaseDataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IBaseDataSet Interface : AccentSensitivity Property

Gets or sets a value indicating whether the data is accent sensitive.

Syntax
  • Visual Basic
  • C#
'Declaration

Property AccentSensitivity As AccentSensitivity
AccentSensitivity AccentSensitivity {get; set;}

Property Value

An AccentSensitivity enumeration indicating whether the data is accent sensitive.

Remarks

If Auto is specified, the application attempts to derive the accent sensitivity setting by querying the data provider.

Defaults to false if the data provider does not support that method.

See Also

Reference

IBaseDataSet Interface
IBaseDataSet Members


CaseSensitivity Property (IBaseDataSet)

CaseSensitivity Property (IBaseDataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IBaseDataSet Interface : CaseSensitivity Property

Gets or sets a value indicating whether the data is case sensitive.

Syntax
  • Visual Basic
  • C#
'Declaration

Property CaseSensitivity As CaseSensitivity
CaseSensitivity CaseSensitivity {get; set;}

Property Value

A CaseSensitivity enumeration indicating whether the fields in a data set are case sensitive.

Remarks

If Auto is specified, the application attempts to derive the case sensitivity setting by querying the data provider.

Defaults to false if the data provider does not support that method.

See Also

Reference

IBaseDataSet Interface
IBaseDataSet Members


Collation Property (IBaseDataSet)

Collation Property (IBaseDataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IBaseDataSet Interface : Collation Property

Gets or sets the locale to use in the collation sequence for sorting data.

Syntax
  • Visual Basic
  • C#
'Declaration

Property Collation As System.String
System.string Collation {get; set;}

Property Value

A String indicating the locale to use in the collation sequence for sorting data.

Remarks

If no Collation is specified, the application attempts to derive the collation setting by querying the data provider.

Defaults to the application's locale settings if the data provider does not support that method or returns an unsupported or invalid value.

See Also

Reference

IBaseDataSet Interface
IBaseDataSet Members


Fields Property (IBaseDataSet)

Fields Property (IBaseDataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IBaseDataSet Interface : Fields Property

Gets or sets the fields in the data set.

Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Fields As FieldCollection
FieldCollection Fields {get;}

Property Value

A FieldCollection containing the fields in the data set.

See Also

Reference

IBaseDataSet Interface
IBaseDataSet Members


KanatypeSensitivity Property (IBaseDataSet)

KanatypeSensitivity Property (IBaseDataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IBaseDataSet Interface : KanatypeSensitivity Property

Gets or sets a value indicating whether the data is kanatype sensitive.

Syntax
  • Visual Basic
  • C#
'Declaration

Property KanatypeSensitivity As KanatypeSensitivity
KanatypeSensitivity KanatypeSensitivity {get; set;}

Property Value

A KanatypeSensitivity value indicating whether the data is kanatype sensitive.
Remarks

If Auto is specified, the application attempts to derive the kanatype sensitivity setting by querying the data provider.

Defaults to false if the data provider does not support that method.

See Also

Reference

IBaseDataSet Interface
IBaseDataSet Members


Name Property (IBaseDataSet)

Name Property (IBaseDataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IBaseDataSet Interface : Name Property

Gets or sets the name of the data set.

Syntax
  • Visual Basic
  • C#
'Declaration

Property Name As System.String
System.string Name {get; set;}

Property Value

A String containing the name of the data set.

Remarks

The data set name cannot be the same as any data region or grouping name.

See Also

Reference

IBaseDataSet Interface
IBaseDataSet Members


WidthSensitivity Property (IBaseDataSet)

WidthSensitivity Property (IBaseDataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IBaseDataSet Interface : WidthSensitivity Property

Gets or sets a value indicating whether the data is width sensitive.

Syntax
  • Visual Basic
  • C#
'Declaration

Property WidthSensitivity As WidthSensitivity
WidthSensitivity WidthSensitivity {get; set;}

Property Value

A WidthSensitivity enumeration indicating whether the data is width sensitive.
Remarks

If Auto is specified, the application attempts to derive the width sensitivity setting by querying the data provider.

Defaults to false if the data provider does not support that method.

See Also

Reference

IBaseDataSet Interface
IBaseDataSet Members


IDataSet Interface

IDataSet Interface
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IDataSet Interface
Represents a data set element for a report which contains information about a set of data retrieved as a part of the report.
Object Model
IDataSet Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDataSet
   Inherits IBaseDataSet, IReportComponent
public interface IDataSet : IBaseDataSet, IReportComponent
See Also

Reference

IDataSet Members
GrapeCity.ActiveReports.PageReportModel Namespace


IDataSet Interface Members

IDataSet Interface Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IDataSet Interface

The following tables list the members exposed by IDataSet.

Public Properties
 | Name | Description
Property | AccentSensitivity | Gets or sets a value indicating whether the data is accent sensitive. (Inherited from GrapeCity.ActiveReports.PageReportModel.IBaseDataSet)
Property | CaseSensitivity | Gets or sets a value indicating whether the data is case sensitive. (Inherited from GrapeCity.ActiveReports.PageReportModel.IBaseDataSet)
Property | Collation | Gets or sets the locale to use in the collation sequence for sorting data. (Inherited from GrapeCity.ActiveReports.PageReportModel.IBaseDataSet)
Property | Fields | Gets or sets the fields in the data set. (Inherited from GrapeCity.ActiveReports.PageReportModel.IBaseDataSet)
Property | Filters | Gets or sets the filters to apply to each row of data in the data set.
Property | KanatypeSensitivity | Gets or sets a value indicating whether the data is kanatype sensitive. (Inherited from GrapeCity.ActiveReports.PageReportModel.IBaseDataSet)
Property | Name | Gets or sets the name of the data set. (Inherited from GrapeCity.ActiveReports.PageReportModel.IBaseDataSet)
Property | Parent | Gets or sets an IReportComponentContainer representing the parent container. (Inherited from GrapeCity.ActiveReports.PageReportModel.IReportComponent)
Property | Query | Information about the data source, including connection information, query, etc.
Property | SharedDataSet | Gets or sets the shared dataset.
Property | Site | (Inherited from System.ComponentModel.IComponent)
Property | WidthSensitivity | Gets or sets a value indicating whether the data is width sensitive. (Inherited from GrapeCity.ActiveReports.PageReportModel.IBaseDataSet)
Top
Public Methods
 | Name | Description
Method | Dispose | (Inherited from System.IDisposable)
Top
See Also

Reference

IDataSet Interface
GrapeCity.ActiveReports.PageReportModel Namespace


IDataSet Interface Properties

IDataSet Interface Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IDataSet Interface

For a list of all members of this type, see IDataSet members.

Public Properties
 | Name | Description
Property | AccentSensitivity | Gets or sets a value indicating whether the data is accent sensitive. (Inherited from GrapeCity.ActiveReports.PageReportModel.IBaseDataSet)
Property | CaseSensitivity | Gets or sets a value indicating whether the data is case sensitive. (Inherited from GrapeCity.ActiveReports.PageReportModel.IBaseDataSet)
Property | Collation | Gets or sets the locale to use in the collation sequence for sorting data. (Inherited from GrapeCity.ActiveReports.PageReportModel.IBaseDataSet)
Property | Fields | Gets or sets the fields in the data set. (Inherited from GrapeCity.ActiveReports.PageReportModel.IBaseDataSet)
Property | Filters | Gets or sets the filters to apply to each row of data in the data set.
Property | KanatypeSensitivity | Gets or sets a value indicating whether the data is kanatype sensitive. (Inherited from GrapeCity.ActiveReports.PageReportModel.IBaseDataSet)
Property | Name | Gets or sets the name of the data set. (Inherited from GrapeCity.ActiveReports.PageReportModel.IBaseDataSet)
Property | Parent | Gets or sets an IReportComponentContainer representing the parent container. (Inherited from GrapeCity.ActiveReports.PageReportModel.IReportComponent)
Property | Query | Information about the data source, including connection information, query, etc.
Property | SharedDataSet | Gets or sets the shared dataset.
Property | Site | (Inherited from System.ComponentModel.IComponent)
Property | WidthSensitivity | Gets or sets a value indicating whether the data is width sensitive. (Inherited from GrapeCity.ActiveReports.PageReportModel.IBaseDataSet)
Top
See Also

Reference

IDataSet Interface
GrapeCity.ActiveReports.PageReportModel Namespace


Filters Property (IDataSet)

Filters Property (IDataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IDataSet Interface : Filters Property

Gets or sets the filters to apply to each row of data in the data set.

Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Filters As System.Collections.Generic.IList(Of Filter)
System.Collections.Generic.IList<Filter> Filters {get;}

Property Value

A FilterCollection containing the filters to apply to each row of data in the data set.
See Also

Reference

IDataSet Interface
IDataSet Members


Query Property (IDataSet)

Query Property (IDataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IDataSet Interface : Query Property

Information about the data source, including connection information, query, etc.

Syntax
  • Visual Basic
  • C#
'Declaration

Property Query As Query
Query Query {get; set;}

Property Value

A Query object with information about the data source, including connection information, query, etc.
Remarks

A setting for this property is required to get the data from the data source.

See Also

Reference

IDataSet Interface
IDataSet Members


SharedDataSet Property (IDataSet)

SharedDataSet Property (IDataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IDataSet Interface : SharedDataSet Property
Gets or sets the shared dataset.
Syntax
  • Visual Basic
  • C#
'Declaration

Property SharedDataSet As SharedDataSet
SharedDataSet SharedDataSet {get; set;}
See Also

Reference

IDataSet Interface
IDataSet Members


IMasterContentService Interface

IMasterContentService Interface
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IMasterContentService Interface
Defines an auxiliary interface for determining report and report item ownership
Object Model
IMasterContentService Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IMasterContentService
public interface IMasterContentService
See Also

Reference

IMasterContentService Members
GrapeCity.ActiveReports.PageReportModel Namespace


IMasterContentService Interface Members

IMasterContentService Interface Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IMasterContentService Interface

The following tables list the members exposed by IMasterContentService.

Public Properties
 | Name | Description
Property | IsMaster | specifies if the current report is master report
Property | MasterReport | specifies master report name, if any
Top
Public Methods
 | Name | Description
Method | GetCode | Gets the child and master report code based off of the passed in combined code.
Method | IsUpdatedReportProperty | Returns whether or not the report property value has been changed from the master.
Top
See Also

Reference

IMasterContentService Interface
GrapeCity.ActiveReports.PageReportModel Namespace


IMasterContentService Interface Methods

IMasterContentService Interface Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IMasterContentService Interface

For a list of all members of this type, see IMasterContentService members.

Public Methods
 | Name | Description
Method | GetCode | Gets the child and master report code based off of the passed in combined code.
Method | IsUpdatedReportProperty | Returns whether or not the report property value has been changed from the master.
Top
See Also

Reference

IMasterContentService Interface
GrapeCity.ActiveReports.PageReportModel Namespace


GetCode Method

GetCode Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IMasterContentService Interface : GetCode Method
The results of the combined master and child reports code property.
Gets the child and master report code based off of the passed in combined code.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetCode( _
   ByVal combinedCode As System.String _
) As MasterContentCode
MasterContentCode GetCode(
   System.string combinedCode
)

Parameters

combinedCode
The results of the combined master and child reports code property.

Return Value

a string array containing the master report code at index 0 and the child report code at index 1.
See Also

Reference

IMasterContentService Interface
IMasterContentService Members


IsUpdatedReportProperty Method

IsUpdatedReportProperty Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IMasterContentService Interface : IsUpdatedReportProperty Method
the name of the property to check.
the value of the property to compare against the master.
Returns whether or not the report property value has been changed from the master.
Syntax
  • Visual Basic
  • C#
'Declaration

Function IsUpdatedReportProperty( _
   ByVal propertyName As System.String, _
   ByVal propertyValue As System.Object _
) As System.Boolean
System.bool IsUpdatedReportProperty(
   System.string propertyName,
   System.object propertyValue
)

Parameters

propertyName
the name of the property to check.
propertyValue
the value of the property to compare against the master.
See Also

Reference

IMasterContentService Interface
IMasterContentService Members


IMasterContentService Interface Properties

IMasterContentService Interface Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IMasterContentService Interface

For a list of all members of this type, see IMasterContentService members.

Public Properties
 | Name | Description
Property | IsMaster | specifies if the current report is master report
Property | MasterReport | specifies master report name, if any
Top
See Also

Reference

IMasterContentService Interface
GrapeCity.ActiveReports.PageReportModel Namespace


IsMaster Property

IsMaster Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IMasterContentService Interface : IsMaster Property
specifies if the current report is master report
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property IsMaster As System.Boolean
System.bool IsMaster {get;}
See Also

Reference

IMasterContentService Interface
IMasterContentService Members


MasterReport Property (IMasterContentService)

MasterReport Property (IMasterContentService)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IMasterContentService Interface : MasterReport Property
specifies master report name, if any
Syntax
  • Visual Basic
  • C#
'Declaration

Property MasterReport As System.String
System.string MasterReport {get; set;}
See Also

Reference

IMasterContentService Interface
IMasterContentService Members


IRdlContainer Interface

IRdlContainer Interface
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IRdlContainer Interface
Specifies an area containing report items.
Object Model
IRdlContainer Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IRdlContainer
   Inherits IReportComponent
public interface IRdlContainer : IReportComponent
See Also

Reference

IRdlContainer Members
GrapeCity.ActiveReports.PageReportModel Namespace


IRdlContainer Interface Members

IRdlContainer Interface Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IRdlContainer Interface

The following tables list the members exposed by IRdlContainer.

Public Properties
 | Name | Description
Property | Parent | Gets or sets an IReportComponentContainer representing the parent container. (Inherited from GrapeCity.ActiveReports.PageReportModel.IReportComponent)
Property | ReportItems | Gets a collection of report items.
Property | Site | (Inherited from System.ComponentModel.IComponent)
Top
Public Methods
 | Name | Description
Method | Dispose | (Inherited from System.IDisposable)
Top
See Also

Reference

IRdlContainer Interface
GrapeCity.ActiveReports.PageReportModel Namespace


IRdlContainer Interface Properties

IRdlContainer Interface Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IRdlContainer Interface

For a list of all members of this type, see IRdlContainer members.

Public Properties
 | Name | Description
Property | Parent | Gets or sets an IReportComponentContainer representing the parent container. (Inherited from GrapeCity.ActiveReports.PageReportModel.IReportComponent)
Property | ReportItems | Gets a collection of report items.
Property | Site | (Inherited from System.ComponentModel.IComponent)
Top
See Also

Reference

IRdlContainer Interface
GrapeCity.ActiveReports.PageReportModel Namespace


ReportItems Property (IRdlContainer)

ReportItems Property (IRdlContainer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IRdlContainer Interface : ReportItems Property

Gets a collection of report items.

Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ReportItems As ReportItemCollection
ReportItemCollection ReportItems {get;}

Property Value

A ReportItemCollection of ReportItem objects.
See Also

Reference

IRdlContainer Interface
IRdlContainer Members


IReportComponent Interface

IReportComponent Interface
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IReportComponent Interface
Specifies a component for the report.
Object Model
IReportComponent Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IReportComponent
public interface IReportComponent
Remarks
Provides a base interface for types like Report, Body, and ReportItem.
See Also

Reference

IReportComponent Members
GrapeCity.ActiveReports.PageReportModel Namespace


IReportComponent Interface Members

IReportComponent Interface Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IReportComponent Interface

The following tables list the members exposed by IReportComponent.

Public Properties
 | Name | Description
Property | Parent | Gets or sets an IReportComponentContainer representing the parent container.
Property | Site | (Inherited from System.ComponentModel.IComponent)
Top
Public Methods
 | Name | Description
Method | Dispose | (Inherited from System.IDisposable)
Top
See Also

Reference

IReportComponent Interface
GrapeCity.ActiveReports.PageReportModel Namespace


IReportComponent Interface Properties

IReportComponent Interface Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IReportComponent Interface

For a list of all members of this type, see IReportComponent members.

Public Properties
 | Name | Description
Property | Parent | Gets or sets an IReportComponentContainer representing the parent container.
Property | Site | (Inherited from System.ComponentModel.IComponent)
Top
See Also

Reference

IReportComponent Interface
GrapeCity.ActiveReports.PageReportModel Namespace


Parent Property (IReportComponent)

Parent Property (IReportComponent)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IReportComponent Interface : Parent Property
Gets or sets an IReportComponentContainer representing the parent container.
Syntax
  • Visual Basic
  • C#
'Declaration

Property Parent As IReportComponentContainer
IReportComponentContainer Parent {get; set;}

Property Value

An IReportComponentContainer representing the parent container.
See Also

Reference

IReportComponent Interface
IReportComponent Members


IReportComponentContainer Interface

IReportComponentContainer Interface
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IReportComponentContainer Interface
Represents a report object that can contain other GrapeCity.ActiveReports.ReportObjectModel.IReportComponent objects.
Object Model
IReportComponentContainer Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IReportComponentContainer
   Inherits IReportComponent
public interface IReportComponentContainer : IReportComponent
See Also

Reference

IReportComponentContainer Members
GrapeCity.ActiveReports.PageReportModel Namespace


IReportComponentContainer Interface Members

IReportComponentContainer Interface Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IReportComponentContainer Interface

The following tables list the members exposed by IReportComponentContainer.

Public Properties
 | Name | Description
Property | Components | Gets the child components contained inside the container.
Property | Parent | Gets or sets an IReportComponentContainer representing the parent container. (Inherited from GrapeCity.ActiveReports.PageReportModel.IReportComponent)
Property | Site | (Inherited from System.ComponentModel.IComponent)
Top
Public Methods
 | Name | Description
Method | Dispose | (Inherited from System.IDisposable)
Top
See Also

Reference

IReportComponentContainer Interface
GrapeCity.ActiveReports.PageReportModel Namespace


IReportComponentContainer Interface Properties

IReportComponentContainer Interface Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IReportComponentContainer Interface

For a list of all members of this type, see IReportComponentContainer members.

Public Properties
 | Name | Description
Property | Components | Gets the child components contained inside the container.
Property | Parent | Gets or sets an IReportComponentContainer representing the parent container. (Inherited from GrapeCity.ActiveReports.PageReportModel.IReportComponent)
Property | Site | (Inherited from System.ComponentModel.IComponent)
Top
See Also

Reference

IReportComponentContainer Interface
GrapeCity.ActiveReports.PageReportModel Namespace


Components Property (IReportComponentContainer)

Components Property (IReportComponentContainer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IReportComponentContainer Interface : Components Property
Gets the child components contained inside the container.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Components As ReportComponentCollection
ReportComponentCollection Components {get;}

Property Value

A read-only ReportComponentCollection containing the child components in the container.
See Also

Reference

IReportComponentContainer Interface
IReportComponentContainer Members


IScopeDefinition Interface

IScopeDefinition Interface
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IScopeDefinition Interface
Represents an object that defines a data scope in the RDL report object model (data region or grouping).
Object Model
IScopeDefinition Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IScopeDefinition
public interface IScopeDefinition
Remarks
Since some objects (at least CustomReportItem) may represent a scope only based on it's settings, some of these properties my return a default value.
See Also

Reference

IScopeDefinition Members
GrapeCity.ActiveReports.PageReportModel Namespace


IScopeDefinition Interface Members

IScopeDefinition Interface Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IScopeDefinition Interface

The following tables list the members exposed by IScopeDefinition.

Public Properties
 | Name | Description
Property | ChildScopes | The scope objects that are direct children of this scope.
Property | ParentScope | The parent of this scope.
Property | ReportItemsInScope | Returns the report items contained directly within this scope.
Property | ScopeName | The name of this scope.
Top
See Also

Reference

IScopeDefinition Interface
GrapeCity.ActiveReports.PageReportModel Namespace


IScopeDefinition Interface Properties

IScopeDefinition Interface Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IScopeDefinition Interface

For a list of all members of this type, see IScopeDefinition members.

Public Properties
 | Name | Description
Property | ChildScopes | The scope objects that are direct children of this scope.
Property | ParentScope | The parent of this scope.
Property | ReportItemsInScope | Returns the report items contained directly within this scope.
Property | ScopeName | The name of this scope.
Top
See Also

Reference

IScopeDefinition Interface
GrapeCity.ActiveReports.PageReportModel Namespace


ChildScopes Property (IScopeDefinition)

ChildScopes Property (IScopeDefinition)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IScopeDefinition Interface : ChildScopes Property
The scope objects that are direct children of this scope.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ChildScopes As System.Collections.IEnumerable
System.Collections.IEnumerable ChildScopes {get;}
Remarks
NOTE: This may not be the same set of objects as the child components. It is the children in terms of RDL scope rules. It may also be empty if there are no descendent scopes.
See Also

Reference

IScopeDefinition Interface
IScopeDefinition Members


ParentScope Property

ParentScope Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IScopeDefinition Interface : ParentScope Property
The parent of this scope.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ParentScope As IScopeDefinition
IScopeDefinition ParentScope {get;}
Remarks
NOTE: This may not be the same object as the parent component or report item container. It is the parent in terms of RDL scope rules.
See Also

Reference

IScopeDefinition Interface
IScopeDefinition Members


ReportItemsInScope Property (IScopeDefinition)

ReportItemsInScope Property (IScopeDefinition)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IScopeDefinition Interface : ReportItemsInScope Property
Returns the report items contained directly within this scope.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ReportItemsInScope As System.Collections.IEnumerable
System.Collections.IEnumerable ReportItemsInScope {get;}
Remarks
NOTE: These may not be direct descendents of the component/report item this object represents. Instead it is the items that are considered in this scope according to RDL rules.
See Also

Reference

IScopeDefinition Interface
IScopeDefinition Members


ScopeName Property

ScopeName Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IScopeDefinition Interface : ScopeName Property
The name of this scope.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ScopeName As System.String
System.string ScopeName {get;}
Remarks
This can return null if the object does not currently represent a scope.
See Also

Reference

IScopeDefinition Interface
IScopeDefinition Members


PageCollectionEventHandler Delegate

PageCollectionEventHandler Delegate

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageCollectionEventHandler Delegate
The source of the event.
A PageCollection object that contains event data.
Represents the method that handles the ItemAdded or ItemRemoved event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub PageCollectionEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As PageCollectionEventArgs _
)
public delegate void PageCollectionEventHandler(
   System.object sender,
   PageCollectionEventArgs e
)

Parameters

sender
The source of the event.
e
A PageCollection object that contains event data.
See Also

Reference

PageCollectionEventHandler Members
GrapeCity.ActiveReports.PageReportModel Namespace


ReportItemCollectionEventHandler Delegate

ReportItemCollectionEventHandler Delegate

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItemCollectionEventHandler Delegate
The source of the event.
A ReportItemCollectionEventArgs object that contains event data.
Represents the method that handles the ItemAdded or ItemRemoved event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub ReportItemCollectionEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As ReportItemCollectionEventArgs _
)
public delegate void ReportItemCollectionEventHandler(
   System.object sender,
   ReportItemCollectionEventArgs e
)

Parameters

sender
The source of the event.
e
A ReportItemCollectionEventArgs object that contains event data.
See Also

Reference

ReportItemCollectionEventHandler Members
GrapeCity.ActiveReports.PageReportModel Namespace


GrapeCity.ActiveReports.Rendering.IO Namespace

GrapeCity.ActiveReports.Rendering.IO Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports.Rendering.IO Namespace
The GrapeCity.ActiveReports.Rendering.IO Namespace includes FileStreamProvider class and MemoryStreamProvider class.
Classes
 | Class | Description
Class | FileStreamProvider | Stream provider for rendering report extension outputs to a file.
Class | MemoryStreamProvider | The provider for rendering report rendering extension outputs to a stream.
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


FileStreamProvider Class

FileStreamProvider Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace : FileStreamProvider Class
Stream provider for rendering report extension outputs to a file.
Object Model
FileStreamProvider Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class FileStreamProvider
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider
public class FileStreamProvider : GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider

See Also

Reference

FileStreamProvider Members
GrapeCity.ActiveReports.Rendering.IO Namespace


FileStreamProvider Class Members

FileStreamProvider Class Members
Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace : FileStreamProvider Class

The following tables list the members exposed by FileStreamProvider.

Public Constructors
 | Name | Description
Public Constructor | FileStreamProvider Constructor | Initializes a new instance of the FileStreamProvider class.
Top
Public Methods
 | Name | Description
Public Method | CleanUpOnError | Overridden. Performs the required clean up in case of a rendering error.
Public Method | CreatePrimaryStream | Overridden. Creates the primary working stream.
Public Method | CreateSecondaryStream | Overridden. Creates a secondary stream in the stream provider.
Public Method | GetPrimaryStream | Overridden. Gets the primary stream.
Public Method | GetSecondaryStreams | Overridden. Gets the array of secondary streams
Top
See Also

Reference

FileStreamProvider Class
GrapeCity.ActiveReports.Rendering.IO Namespace


FileStreamProvider Constructor

FileStreamProvider Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace > FileStreamProvider Class : FileStreamProvider Constructor
a System.IO.DirectoryInfo to save the file streams to.
a string value indicating the name to place at the beginning of the files created.
Initializes a new instance of the FileStreamProvider class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal baseOutputDirectory As System.IO.DirectoryInfo, _
   ByVal outputFileNamePrefix As System.String _
)
public FileStreamProvider(
   System.IO.DirectoryInfo baseOutputDirectory,
   System.string outputFileNamePrefix
)

Parameters

baseOutputDirectory
a System.IO.DirectoryInfo to save the file streams to.
outputFileNamePrefix
a string value indicating the name to place at the beginning of the files created.
Exceptions
Exception | Description
System.ArgumentNullException | Thrown if the base output directory argument is null.
See Also

Reference

FileStreamProvider Class
FileStreamProvider Members


FileStreamProvider Class Methods

FileStreamProvider Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace : FileStreamProvider Class

For a list of all members of this type, see FileStreamProvider members.

Public Methods
 | Name | Description
Public Method | CleanUpOnError | Overridden. Performs the required clean up in case of a rendering error.
Public Method | CreatePrimaryStream | Overridden. Creates the primary working stream.
Public Method | CreateSecondaryStream | Overridden. Creates a secondary stream in the stream provider.
Public Method | GetPrimaryStream | Overridden. Gets the primary stream.
Public Method | GetSecondaryStreams | Overridden. Gets the array of secondary streams
Top
See Also

Reference

FileStreamProvider Class
GrapeCity.ActiveReports.Rendering.IO Namespace


CleanUpOnError Method (FileStreamProvider)

CleanUpOnError Method (FileStreamProvider)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace > FileStreamProvider Class : CleanUpOnError Method
Performs the required clean up in case of a rendering error.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Sub CleanUpOnError()
public override void CleanUpOnError()
See Also

Reference

FileStreamProvider Class
FileStreamProvider Members


CreatePrimaryStream Method (FileStreamProvider)

CreatePrimaryStream Method (FileStreamProvider)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace > FileStreamProvider Class : CreatePrimaryStream Method
a string value indicating the mime type for the primary stream.
a string value indicating the file extension to use for the primary stream.
Creates the primary working stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function CreatePrimaryStream( _
   ByVal mimeType As System.String, _
   ByVal fileExtension As System.String _
) As StreamInfo
public override StreamInfo CreatePrimaryStream(
   System.string mimeType,
   System.string fileExtension
)

Parameters

mimeType
a string value indicating the mime type for the primary stream.
fileExtension
a string value indicating the file extension to use for the primary stream.

Return Value

a GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamInfo for the primary stream.
Exceptions
Exception | Description
System.InvalidOperationException | Thrown if the primary stream has already been created.
System.InvalidOperationException | Thrown if the file extension is not specified.
See Also

Reference

FileStreamProvider Class
FileStreamProvider Members


CreateSecondaryStream Method (FileStreamProvider)

CreateSecondaryStream Method (FileStreamProvider)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace > FileStreamProvider Class : CreateSecondaryStream Method
a string value in the name for the secondary stream. The relative name is appended to the file name prefix
a string value indicating the mime type for the primary stream.
a string value indicating the file extension to use for the primary stream.
Creates a secondary stream in the stream provider.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function CreateSecondaryStream( _
   ByVal relativeName As System.String, _
   ByVal mimeType As System.String, _
   ByVal fileExtension As System.String _
) As StreamInfo
public override StreamInfo CreateSecondaryStream(
   System.string relativeName,
   System.string mimeType,
   System.string fileExtension
)

Parameters

relativeName
a string value in the name for the secondary stream. The relative name is appended to the file name prefix
mimeType
a string value indicating the mime type for the primary stream.
fileExtension
a string value indicating the file extension to use for the primary stream.

Return Value

a GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamInfo for the secondary stream.
Exceptions
Exception | Description
System.InvalidOperationException | Thrown if the file extension is not specified.
See Also

Reference

FileStreamProvider Class
FileStreamProvider Members


GetPrimaryStream Method (FileStreamProvider)

GetPrimaryStream Method (FileStreamProvider)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace > FileStreamProvider Class : GetPrimaryStream Method
Gets the primary stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetPrimaryStream() As StreamInfo
public override StreamInfo GetPrimaryStream()

Return Value

a GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamInfo for the primary stream.
See Also

Reference

FileStreamProvider Class
FileStreamProvider Members


GetSecondaryStreams Method (FileStreamProvider)

GetSecondaryStreams Method (FileStreamProvider)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace > FileStreamProvider Class : GetSecondaryStreams Method
Gets the array of secondary streams
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetSecondaryStreams() As StreamInfo()
public override StreamInfo[] GetSecondaryStreams()

Return Value

an array of GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamInfo containing the secondary streams.
See Also

Reference

FileStreamProvider Class
FileStreamProvider Members


MemoryStreamProvider Class

MemoryStreamProvider Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace : MemoryStreamProvider Class
The provider for rendering report rendering extension outputs to a stream.
Object Model
MemoryStreamProvider Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class MemoryStreamProvider
   Inherits GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider
public class MemoryStreamProvider : GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider
GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider

See Also

Reference

MemoryStreamProvider Members
GrapeCity.ActiveReports.Rendering.IO Namespace


MemoryStreamProvider Class Members

MemoryStreamProvider Class Members
Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace : MemoryStreamProvider Class

The following tables list the members exposed by MemoryStreamProvider.

Public Constructors
 | Name | Description
Public Constructor | MemoryStreamProvider Constructor | Initializes a new instance of the MemoryStreamProvider class.
Top
Public Methods
 | Name | Description
Public Method | CleanUpOnError | Performs the required clean up in case of a rendering error. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider)
Public Method | CreatePrimaryStream | Overridden. Creates the primary working stream.
Public Method | CreateSecondaryStream | Overridden. Creates a secondary stream in the stream provider.
Public Method | GetPrimaryStream | Overridden. Gets the primary stream.
Public Method | GetSecondaryStreams | Overridden. Gets the array of secondary streams
Top
See Also

Reference

MemoryStreamProvider Class
GrapeCity.ActiveReports.Rendering.IO Namespace


MemoryStreamProvider Constructor

MemoryStreamProvider Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace > MemoryStreamProvider Class : MemoryStreamProvider Constructor
Initializes a new instance of the MemoryStreamProvider class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MemoryStreamProvider()
See Also

Reference

MemoryStreamProvider Class
MemoryStreamProvider Members


MemoryStreamProvider Class Methods

MemoryStreamProvider Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace : MemoryStreamProvider Class

For a list of all members of this type, see MemoryStreamProvider members.

Public Methods
 | Name | Description
Public Method | CleanUpOnError | Performs the required clean up in case of a rendering error. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider)
Public Method | CreatePrimaryStream | Overridden. Creates the primary working stream.
Public Method | CreateSecondaryStream | Overridden. Creates a secondary stream in the stream provider.
Public Method | GetPrimaryStream | Overridden. Gets the primary stream.
Public Method | GetSecondaryStreams | Overridden. Gets the array of secondary streams
Top
See Also

Reference

MemoryStreamProvider Class
GrapeCity.ActiveReports.Rendering.IO Namespace


CreatePrimaryStream Method (MemoryStreamProvider)

CreatePrimaryStream Method (MemoryStreamProvider)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace > MemoryStreamProvider Class : CreatePrimaryStream Method
a string value indicating the mime type for the primary stream.
a string value indicating the file extension to use for the primary stream.
Creates the primary working stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function CreatePrimaryStream( _
   ByVal mimeType As System.String, _
   ByVal suggestedFileExtension As System.String _
) As StreamInfo
public override StreamInfo CreatePrimaryStream(
   System.string mimeType,
   System.string suggestedFileExtension
)

Parameters

mimeType
a string value indicating the mime type for the primary stream.
suggestedFileExtension
a string value indicating the file extension to use for the primary stream.

Return Value

StreamInfo.
See Also

Reference

MemoryStreamProvider Class
MemoryStreamProvider Members


CreateSecondaryStream Method (MemoryStreamProvider)

CreateSecondaryStream Method (MemoryStreamProvider)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace > MemoryStreamProvider Class : CreateSecondaryStream Method
A string value in the name for the secondary stream. The relative name is appended to the MemoryStreamProvider name prefix
A string value indicating the mime type for the primary stream.
A string value indicating the file extension to use for the secondary stream.
Creates a secondary stream in the stream provider.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function CreateSecondaryStream( _
   ByVal relativeName As System.String, _
   ByVal mimeType As System.String, _
   ByVal suggestedFileExtension As System.String _
) As StreamInfo
public override StreamInfo CreateSecondaryStream(
   System.string relativeName,
   System.string mimeType,
   System.string suggestedFileExtension
)

Parameters

relativeName
A string value in the name for the secondary stream. The relative name is appended to the MemoryStreamProvider name prefix
mimeType
A string value indicating the mime type for the primary stream.
suggestedFileExtension
A string value indicating the file extension to use for the secondary stream.

Return Value

StreamInfo.
See Also

Reference

MemoryStreamProvider Class
MemoryStreamProvider Members


GetPrimaryStream Method (MemoryStreamProvider)

GetPrimaryStream Method (MemoryStreamProvider)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace > MemoryStreamProvider Class : GetPrimaryStream Method
Gets the primary stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetPrimaryStream() As StreamInfo
public override StreamInfo GetPrimaryStream()

Return Value

StreamInfo.
See Also

Reference

MemoryStreamProvider Class
MemoryStreamProvider Members


GetSecondaryStreams Method (MemoryStreamProvider)

GetSecondaryStreams Method (MemoryStreamProvider)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Rendering.IO Namespace > MemoryStreamProvider Class : GetSecondaryStreams Method
Gets the array of secondary streams
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetSecondaryStreams() As StreamInfo()
public override StreamInfo[] GetSecondaryStreams()

Return Value

StreamInfo[].
See Also

Reference

MemoryStreamProvider Class
MemoryStreamProvider Members


GrapeCity.ActiveReports.ReportsCore.Configuration Namespace

GrapeCity.ActiveReports.ReportsCore.Configuration Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports.ReportsCore.Configuration Namespace
Classes
 | Class | Description
Class | MapTileServerConfiguration | Represents configuration settings for communication with map tile server.
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


MapTileServerConfiguration Class

MapTileServerConfiguration Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace : MapTileServerConfiguration Class
Represents configuration settings for communication with map tile server.
Object Model
MapTileServerConfiguration Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class MapTileServerConfiguration
public class MapTileServerConfiguration
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ReportsCore.Configuration.MapTileServerConfiguration

See Also

Reference

MapTileServerConfiguration Members
GrapeCity.ActiveReports.ReportsCore.Configuration Namespace


MapTileServerConfiguration Class Members

MapTileServerConfiguration Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace : MapTileServerConfiguration Class

The following tables list the members exposed by MapTileServerConfiguration.

Public Constructors
 | Name | Description
Public Constructor | MapTileServerConfiguration Constructor |
Top
Public Properties
 | Name | Description
Public Property | AppID | Gets or sets bing application id.
Public Property | MaxConnections | Gets or sets the number of maximum connections.
Public Property | Timeout | Gets or sets the timeout in seconds.
Top
See Also

Reference

MapTileServerConfiguration Class
GrapeCity.ActiveReports.ReportsCore.Configuration Namespace


MapTileServerConfiguration Constructor

MapTileServerConfiguration Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace > MapTileServerConfiguration Class : MapTileServerConfiguration Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public MapTileServerConfiguration()
See Also

Reference

MapTileServerConfiguration Class
MapTileServerConfiguration Members


MapTileServerConfiguration Class Properties

MapTileServerConfiguration Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace : MapTileServerConfiguration Class

For a list of all members of this type, see MapTileServerConfiguration members.

Public Properties
 | Name | Description
Public Property | AppID | Gets or sets bing application id.
Public Property | MaxConnections | Gets or sets the number of maximum connections.
Public Property | Timeout | Gets or sets the timeout in seconds.
Top
See Also

Reference

MapTileServerConfiguration Class
GrapeCity.ActiveReports.ReportsCore.Configuration Namespace


AppID Property

AppID Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace > MapTileServerConfiguration Class : AppID Property
Gets or sets bing application id.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AppID As System.String
public System.string AppID {get; set;}
See Also

Reference

MapTileServerConfiguration Class
MapTileServerConfiguration Members


MaxConnections Property

MaxConnections Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace > MapTileServerConfiguration Class : MaxConnections Property
Gets or sets the number of maximum connections.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaxConnections As System.Integer
public System.int MaxConnections {get; set;}
See Also

Reference

MapTileServerConfiguration Class
MapTileServerConfiguration Members


Timeout Property (MapTileServerConfiguration)

Timeout Property (MapTileServerConfiguration)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.ReportsCore.Configuration Namespace > MapTileServerConfiguration Class : Timeout Property
Gets or sets the timeout in seconds.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Timeout As System.Integer
public System.int Timeout {get; set;}
See Also

Reference

MapTileServerConfiguration Class
MapTileServerConfiguration Members


GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace

GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace
Classes
 | Class | Description
Class | TileProviderInfo | Descriptor for map tile provider.
Interfaces
 | Interface | Description
Interface | ITileProvidersManager | Defines interface for managing map tile provider.
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


TileProviderInfo Class

TileProviderInfo Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace : TileProviderInfo Class
Descriptor for map tile provider.
Object Model
TileProviderInfo Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class TileProviderInfo
public class TileProviderInfo
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders.TileProviderInfo

See Also

Reference

TileProviderInfo Members
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace


TileProviderInfo Class Members

TileProviderInfo Class Members
Fields Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace : TileProviderInfo Class

The following tables list the members exposed by TileProviderInfo.

Public Constructors
 | Name | Description
Public Constructor | TileProviderInfo Constructor | Overloaded.
Top
Public Fields
 | Name | Description
Public Field | Settings | The settings of map tile provider.
Top
Public Properties
 | Name | Description
Public Property | AssemblyQualifiedName | Fully assembly-qualified name of the class that implements ITileProvider
Public Property | DisplayName | The display name of tile provider.
Public Property | Name | The name that can be used to refer to the tile provider in reports.
Top
See Also

Reference

TileProviderInfo Class
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace


TileProviderInfo Constructor

TileProviderInfo Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace > TileProviderInfo Class : TileProviderInfo Constructor
Overload List
Overload | Description
TileProviderInfo Constructor(String,String) |
TileProviderInfo Constructor(String,String,String) | Initializes a new instance of this class.
See Also

Reference

TileProviderInfo Class
TileProviderInfo Members


TileProviderInfo Constructor(String,String)

TileProviderInfo Constructor(String,String)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace > TileProviderInfo Class > TileProviderInfo Constructor : TileProviderInfo Constructor(String,String)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As System.String, _
   ByVal typeName As System.String _
)
public TileProviderInfo(
   System.string name,
   System.string typeName
)

Parameters

name
typeName
See Also

Reference

TileProviderInfo Class
TileProviderInfo Members
Overload List


TileProviderInfo Constructor(String,String,String)

TileProviderInfo Constructor(String,String,String)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace > TileProviderInfo Class > TileProviderInfo Constructor : TileProviderInfo Constructor(String,String,String)
The name that can be used to refer to the tile provider in reports.
The display name of map tile provider.
Fully assembly-qualified name of the class that implements ITileProvider.
Initializes a new instance of this class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As System.String, _
   ByVal displayName As System.String, _
   ByVal typeName As System.String _
)
public TileProviderInfo(
   System.string name,
   System.string displayName,
   System.string typeName
)

Parameters

name
The name that can be used to refer to the tile provider in reports.
displayName
The display name of map tile provider.
typeName
Fully assembly-qualified name of the class that implements ITileProvider.
See Also

Reference

TileProviderInfo Class
TileProviderInfo Members
Overload List


TileProviderInfo Class Properties

TileProviderInfo Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace : TileProviderInfo Class

For a list of all members of this type, see TileProviderInfo members.

Public Properties
 | Name | Description
Public Property | AssemblyQualifiedName | Fully assembly-qualified name of the class that implements ITileProvider
Public Property | DisplayName | The display name of tile provider.
Public Property | Name | The name that can be used to refer to the tile provider in reports.
Top
See Also

Reference

TileProviderInfo Class
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace


AssemblyQualifiedName Property (TileProviderInfo)

AssemblyQualifiedName Property (TileProviderInfo)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace > TileProviderInfo Class : AssemblyQualifiedName Property
Fully assembly-qualified name of the class that implements ITileProvider
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AssemblyQualifiedName As System.String
public System.string AssemblyQualifiedName {get; set;}
See Also

Reference

TileProviderInfo Class
TileProviderInfo Members


DisplayName Property (TileProviderInfo)

DisplayName Property (TileProviderInfo)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace > TileProviderInfo Class : DisplayName Property
The display name of tile provider.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DisplayName As System.String
public System.string DisplayName {get; set;}
See Also

Reference

TileProviderInfo Class
TileProviderInfo Members


Name Property (TileProviderInfo)

Name Property (TileProviderInfo)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace > TileProviderInfo Class : Name Property
The name that can be used to refer to the tile provider in reports.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Name As System.String
public System.string Name {get;}
See Also

Reference

TileProviderInfo Class
TileProviderInfo Members


TileProviderInfo Class Fields

TileProviderInfo Class Fields

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace : TileProviderInfo Class

For a list of all members of this type, see TileProviderInfo members.

Public Fields
 | Name | Description
Public Field | Settings | The settings of map tile provider.
Top
See Also

Reference

TileProviderInfo Class
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace


Settings Field (TileProviderInfo)

Settings Field (TileProviderInfo)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace > TileProviderInfo Class : Settings Field
The settings of map tile provider.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Settings As System.Collections.Specialized.NameValueCollection
public readonly System.Collections.Specialized.NameValueCollection Settings
See Also

Reference

TileProviderInfo Class
TileProviderInfo Members


ITileProvidersManager Interface

ITileProvidersManager Interface
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace : ITileProvidersManager Interface
Defines interface for managing map tile provider.
Object Model
ITileProvidersManager Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ITileProvidersManager
public interface ITileProvidersManager
See Also

Reference

ITileProvidersManager Members
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace


ITileProvidersManager Interface Members

ITileProvidersManager Interface Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace : ITileProvidersManager Interface

The following tables list the members exposed by ITileProvidersManager.

Public Properties
 | Name | Description
Property | Providers | Returns the map tile providers enumeration.
Top
Public Methods
 | Name | Description
Method | CreateTileProvider | Create and configure specified tile provider.
Top
See Also

Reference

ITileProvidersManager Interface
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace


ITileProvidersManager Interface Methods

ITileProvidersManager Interface Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace : ITileProvidersManager Interface

For a list of all members of this type, see ITileProvidersManager members.

Public Methods
 | Name | Description
Method | CreateTileProvider | Create and configure specified tile provider.
Top
See Also

Reference

ITileProvidersManager Interface
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace


CreateTileProvider Method

CreateTileProvider Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace > ITileProvidersManager Interface : CreateTileProvider Method
Invariant tile provider name.
True if secured connection to tile provider should be used.
The style of tiles to be returned by tile provider.
The language of tiles to be returned by tile provider.
Create and configure specified tile provider.
Syntax
  • Visual Basic
  • C#
'Declaration

Function CreateTileProvider( _
   ByVal provider As System.String, _
   ByVal useSecureConnection As System.Boolean, _
   ByVal tileStyle As MapTileStyle, _
   ByVal tileLanguage As System.String _
) As IMapTileProvider
IMapTileProvider CreateTileProvider(
   System.string provider,
   System.bool useSecureConnection,
   MapTileStyle tileStyle,
   System.string tileLanguage
)

Parameters

provider
Invariant tile provider name.
useSecureConnection
True if secured connection to tile provider should be used.
tileStyle
The style of tiles to be returned by tile provider.
tileLanguage
The language of tiles to be returned by tile provider.
See Also

Reference

ITileProvidersManager Interface
ITileProvidersManager Members


ITileProvidersManager Interface Properties

ITileProvidersManager Interface Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace : ITileProvidersManager Interface

For a list of all members of this type, see ITileProvidersManager members.

Public Properties
 | Name | Description
Property | Providers | Returns the map tile providers enumeration.
Top
See Also

Reference

ITileProvidersManager Interface
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace


Providers Property

Providers Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace > ITileProvidersManager Interface : Providers Property
Returns the map tile providers enumeration.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Providers As System.Collections.Generic.IEnumerable(Of TileProviderInfo)
System.Collections.Generic.IEnumerable<TileProviderInfo> Providers {get;}
See Also

Reference

ITileProvidersManager Interface
ITileProvidersManager Members


GrapeCity.ActiveReports.SectionReportModel Namespace

GrapeCity.ActiveReports.SectionReportModel Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports.SectionReportModel Namespace
The GrapeCity.ActiveReports.SectionReportModel namespace includes classes that can be used in section reports.
Classes
 | Class | Description
Class | ARControl | ARControl is the base class for ActiveReports controls. You should not need to use this class in your application.
Class | Barcode | The Barcode control is used to print barcode symbology in the report.
Class | ChartControl | Renders a chart on the report.
Class | CheckBox | Checkbox is used to print Boolean values as checked or unchecked.
Class | ControlCollection | Represents a collection of ARControl objects.
Class | CrossSectionBox | The CrossSectionBox control renders a rectangular outline with its corners where you place them in the header and footer sections, and its vertical lines growing with intervening sections.
Class | CrossSectionControl | ARControl is the base class for ActiveReports CrossSection controls. You should not need to use this class in your application.
Class | CrossSectionLine | The CrossSectionLine control renders a vertical line that begins where you place it in a header section, grows with any intervening sections, and ends where you place it in the related footer section.
Class | CustomControl | CustomControl is a wrapper class that allows you to print .NET controls that inherit from System.Windows.Forms.Control
Class | Detail | Detail section is the main section in a report. It is printed once for each record in the data source.
Class | GroupFooter | The GroupFooter section is directly related to the Detail section and its matching group header. It prints once each time a group of similar records (as defined in the GroupHeader.DataField property) ends. A GroupFooter section cannot exist without a matching GroupHeader section.
Class | GroupHeader | The GroupHeader section prints once for every data group defined using the field specified in DataField property. A GroupHeader section requires a matching GroupFooter section.
Class | Label | Prints static text on the report.
Class | Line | Prints a line on the report.
Class | OleObject | OleObject is a wrapper class for printing OLE objects.
Class | PageBreak | PageBreak ends the current page and starts a new page at the control's location on the page.
Class | PageFooter | The PageFooter section prints once at the bottom of every page in the report.
Class | PageHeader | The PageHeader section prints once at the top of every page in the report.
Class | Parameter | A Parameter is used to substitute values for parameter placeholders in the report's data source SQL query text.
Class | ParameterCollection | Represents the collection of parameters that ActiveReports parses from the parameter placeholders in the data source SQL query.
Class | Picture | Prints an image on the report.
Class | ReportFooter | The ReportFooter section prints once at the end of the report.
Class | ReportHeader | The ReportHeader section is printed once at the beginning of the report.
Class | ReportInfo | The ReportInfo control displays the information specified in the FormatString property.
Class | RichTextBox | Prints text formatted as Rich Text (RTF) on the report.
Class | Section | Section is the base class of all ActiveReports section types.
Class | Shape | Prints a rectangular or oval shape on the report.
Class | Style | Represents the formatting properties of a control.
Class | StyleSheet | Represents the collection of Style objects used to format controls.
Class | SubReport | Prints a linked report object as part of the current report. Subreports are linked using the Report property.
Class | TextBox | Prints a formatted text value, bound or unbound.
Enumerations
 | Enumeration | Description
Enumeration | BarCodeCaptionPosition | Specifies the barcode caption position relative to the barcode symbol.
Enumeration | BarCodeDirection | Specifies the print direction of the barcode symbol.
Enumeration | BarCodeStyle | Type of code, or symbology, the barcode control will use to generate the barcode.
Enumeration | ChartControl.UIAction | Specifies the action to perform on the chart control.
Enumeration | ColumnDirection | Specifies the direction of columns in a multi-column report.
Enumeration | GroupKeepTogether | Specifies whether a group header and footer pair with associated details will print as a single block on the same page.
Enumeration | ImageTypes | Specifies the type of image to be used for a chart.
Enumeration | LineStyle | Specifies the pen style used to draw a line.
Enumeration | NewColumn | Specifies whether a new column will be started before or after a section.
Enumeration | NewPage | Specifies whether a new page will be started before or after a section.
Enumeration | Parameter.DataType | Specifies the data type used to create the input control for collection of report parameter values.
Enumeration | ParameterCollection.ParseResultCode | Specifies the results of parsing the report's parameter values.
Enumeration | PictureAlignment | Determines the position of the picture within the control area.
Enumeration | RepeatStyle | Specifies whether a group header section will be repeated with subsequent detail pages.
Enumeration | RichTextBox.FindOptions | Specifies how a text search is carried out in a RichTextBox control. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Enumeration | RichTextBox.RichTextStreamType | Determines the RichText control's content type.
Enumeration | RichTextType | Determines the type of stream to load into the RichTextBox.
Enumeration | ShapeType | Specifies the type of shape that the shape control should print.
Enumeration | SizeModes | Determines how a picture should be sized within the control area.
Enumeration | SummaryFunc | Determines the summary calculation function performed on the field value.
Enumeration | SummaryRunning | Determines whether summary values will be accumulated or reset based on the specified level.
Enumeration | SummaryType | Determines the type of field summary.
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


ARControl Class

ARControl Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ARControl Class
ARControl is the base class for ActiveReports controls. You should not need to use this class in your application.
Object Model
ARControl Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ARControl
public class ARControl
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.Barcode
GrapeCity.ActiveReports.SectionReportModel.ChartControl
GrapeCity.ActiveReports.SectionReportModel.CheckBox
GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl
GrapeCity.ActiveReports.SectionReportModel.CustomControl
GrapeCity.ActiveReports.SectionReportModel.Label
GrapeCity.ActiveReports.SectionReportModel.Line
GrapeCity.ActiveReports.SectionReportModel.OleObject
GrapeCity.ActiveReports.SectionReportModel.PageBreak
GrapeCity.ActiveReports.SectionReportModel.Picture
GrapeCity.ActiveReports.SectionReportModel.ReportInfo
GrapeCity.ActiveReports.SectionReportModel.RichTextBox
GrapeCity.ActiveReports.SectionReportModel.Shape
GrapeCity.ActiveReports.SectionReportModel.SubReport
GrapeCity.ActiveReports.SectionReportModel.TextBox

Requirements

See Also

Reference

ARControl Members
GrapeCity.ActiveReports.SectionReportModel Namespace


ARControl Class Members

ARControl Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ARControl Class

The following tables list the members exposed by ARControl.

Public Properties
 | Name | Description
Public Property | Border | Gets a border object that defines the border style for each edge of the control.
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control.
Public Property | Height | Gets or sets the height of the control in inches.
Public Property | Left | Gets or sets the left position of the control in inches.
Public Property | Location | Gets or sets the location of the control in inches.
Public Property | Name | Gets or sets the name of the control.
Public Property | Parent | Gets a reference to the parent section of the control.
Public Property | Size | Gets or sets the size of the control in inches.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed.
Public Property | Width | Gets or sets the width of the control in inches.
Top
Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order.
Public Method | Dispose | Releases the control instance from memory.
Public Method | SendToBack | Sends the control to the back of the z-order.
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle.
Top
See Also

Reference

ARControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ARControl Class Methods

ARControl Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ARControl Class

For a list of all members of this type, see ARControl members.

Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order.
Public Method | Dispose | Releases the control instance from memory.
Public Method | SendToBack | Sends the control to the back of the z-order.
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle.
Top
See Also

Reference

ARControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


BringToFront Method (ARControl)

BringToFront Method (ARControl)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : BringToFront Method
Brings the control to the front of the z-order.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub BringToFront()
public void BringToFront()
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.BringToFront();
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.BringToFront()
End Sub
See Also

Reference

ARControl Class
ARControl Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Dispose() Method
Releases the control instance from memory.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

ARControl Class
ARControl Members


SendToBack Method (ARControl)

SendToBack Method (ARControl)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : SendToBack Method
Sends the control to the back of the z-order.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SendToBack()
public void SendToBack()
Example
  • C#
private void detail_BeforePrint(object sender, System.EventArgs eArgs)
{
    this.barcode1.SendToBack();
}
  • Visual Basic
Private Sub Detail1_BeforePrint(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.SendToBack()
End Sub
See Also

Reference

ARControl Class
ARControl Members


SetBounds Method (ARControl)

SetBounds Method (ARControl)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : SetBounds Method
Rectangle that defines the location and size of the control.
Sets the bounds of the control to the specified rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetBounds( _
   ByVal bounds As RectangleF _
)
public void SetBounds(
   RectangleF bounds
)

Parameters

bounds
Rectangle that defines the location and size of the control.

Return Value

The rectangle is defined using float or Single values in inches.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    System.Drawing.RectangleF b = new System.Drawing.RectangleF();
    b.X=2;
    b.Y=1;
    b.Width=2;
    b.Height=1;
    this.barcode2.SetBounds(b);
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Dim b As New System.Drawing.RectangleF
    With b
        .X = 2
        .Y = 1
        .Width = 2
        .Height = 0.5
    End With
    Me.Barcode2.SetBounds(b)
End Sub
See Also

Reference

ARControl Class
ARControl Members


ARControl Class Properties

ARControl Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ARControl Class

For a list of all members of this type, see ARControl members.

Public Properties
 | Name | Description
Public Property | Border | Gets a border object that defines the border style for each edge of the control.
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control.
Public Property | Height | Gets or sets the height of the control in inches.
Public Property | Left | Gets or sets the left position of the control in inches.
Public Property | Location | Gets or sets the location of the control in inches.
Public Property | Name | Gets or sets the name of the control.
Public Property | Parent | Gets a reference to the parent section of the control.
Public Property | Size | Gets or sets the size of the control in inches.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed.
Public Property | Width | Gets or sets the width of the control in inches.
Top
See Also

Reference

ARControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Border Property (ARControl)

Border Property (ARControl)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Border Property
Gets a border object that defines the border style for each edge of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Border As Border
public virtual Border Border {get;}

Property Value

Default border object.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    GrapeCity.ActiveReports.Border b = new GrapeCity.ActiveReports.Border();
    this.textBox1.Border.BottomStyle = BorderLineStyle.ThickDash;
    this.textBox1.Border.TopStyle = BorderLineStyle.ThickDash;
    b = this.textBox1.Border.Clone();
    this.textBox2.Border.BottomStyle = b.BottomStyle;
    this.textBox2.Border.TopStyle = b.TopStyle;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Dim b As New GrapeCity.ActiveReports.Border
    Me.TextBox1.Border.BottomStyle = BorderLineStyle.ThickDash
    Me.TextBox1.Border.TopStyle = BorderLineStyle.ThickDash
    b = Me.TextBox1.Border.Clone()
    Me.TextBox2.Border.BottomStyle = b.BottomStyle
    Me.TextBox2.Border.TopStyle = b.TopStyle
End Sub
See Also

Reference

ARControl Class
ARControl Members


Bounds Property (ARControl)

Bounds Property (ARControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Bounds Property
Sets or returns a rectangle that defines the location and size of the control in inches.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Bounds As RectangleF
public RectangleF Bounds {get; set;}

Property Value

A RectangleF object defined using Float or Single values in inches.
See Also

Reference

ARControl Class
ARControl Members


DataField Property (ARControl)

DataField Property (ARControl)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : DataField Property

Gets or sets the field name from the data source to bind to the control.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property DataField As System.String
public virtual System.string DataField {get; set;}

Property Value

Name of the data bound field. Default is an empty string; the control is not bound.
Remarks

When the DataField property is set to a field contained within the DataSource, ActiveReports binds the field's data from each record to the control. The recordset data is first saved into the Value property. It then converts to any output format and is set as the control's text.

The DataField property can also be used to perform calculations using a scripting expression beginning with an equals sign (=). This allows fields to be set up to display calculated results. For example, field control or data field's group field section can be set to an expression such as "=UnitPrice * Qty" or "=CompanyName.Trim()" where UnitPrice, Qty and CompanyName are members of the report's Fields collection.

Add an equals sign (=) at the beginning when using parameters in a DataField property.

When using XML, the DataField must be set to a valid XPath expression.

Example
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.textBox2.DataField = "CustomerID";
}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.TextBox2.DataField = "CustomerID"
End Sub
Requirements

See Also

Reference

ARControl Class
ARControl Members


Height Property (ARControl)

Height Property (ARControl)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Height Property
Gets or sets the height of the control in inches.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As System.Single
public System.float Height {get; set;}

Property Value

A float or Single value in inches.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Height = 1;
    this.textBox1.Width = 2;
    this.textBox1.Left = 2;
    this.textBox1.Top = 0;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    With Me.TextBox1
        .Height = 1
        .Width = 2
        .Left = 2
        .Top = 0
    End With
End Sub
See Also

Reference

ARControl Class
ARControl Members


Left Property (ARControl)

Left Property (ARControl)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Left Property

Gets or sets the left position of the control in inches.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Left As System.Single
public System.float Left {get; set;}

Property Value

A float or Single value in inches.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Height = 1;
    this.textBox1.Width = 2;
    this.textBox1.Left = 2;
    this.textBox1.Top = 0;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    With Me.TextBox1
        .Height = 1
        .Width = 2
        .Left = 2
        .Top = 0
    End With
End Sub
See Also

Reference

ARControl Class
ARControl Members


Location Property (ARControl)

Location Property (ARControl)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Location Property
Gets or sets the location of the control in inches.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Location As PointF
public virtual PointF Location {get; set;}

Property Value

System.Drawing.PointF defined by X and Y float or Single values in inches.
Remarks
Note: Be sure that the section containing the control is sized to accommodate the location; otherwise the control may render in a hidden area.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    System.Drawing.PointF p = new System.Drawing.PointF();
    p.X = 0.5f;
    p.Y = 0.5f;
    this.textBox1.Location = p;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Dim p As System.Drawing.PointF
    p.X = 0.5
    p.Y = 0.5
    Me.TextBox1.Location = p
End Sub
See Also

Reference

ARControl Class
ARControl Members


Name Property (ARControl)

Name Property (ARControl)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Name Property
Gets or sets the name of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}
Remarks
Requires a unique name within the report class.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Name = "txtCustID";
    this.Sections["detail"].Controls["txtCustID"].Width = 4;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.TextBox1.Name = "txtCustID"
    Me.Sections("Detail1").Controls("txtCustID").Width = 4
End Sub
See Also

Reference

ARControl Class
ARControl Members


Parent Property (ARControl)

Parent Property (ARControl)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Parent Property
Gets a reference to the parent section of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Parent As System.Object
public System.object Parent {get;}

Property Value

Object - Reference to the parent section.

Example
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    System.Windows.Forms.MessageBox.Show (this.textBox2.Parent.ToString());
}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    MessageBox.Show(Me.TextBox1.Parent.ToString())
End Sub
See Also

Reference

ARControl Class
ARControl Members
ActiveReports6~GrapeCity.ActiveReports.Section


Size Property (ARControl)

Size Property (ARControl)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Size Property
Gets or sets the size of the control in inches.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Size As SizeF
public virtual SizeF Size {get; set;}

Property Value

System.Drawing.SizeF.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    System.Drawing.SizeF s = new System.Drawing.SizeF();
    s.Width = 2;
    s.Height = 1;
    this.textBox1.Size = s;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Dim s As System.Drawing.SizeF
    s.Width = 2
    s.Height = 1
    Me.TextBox1.Size = s
End Sub
See Also

Reference

ARControl Class
ARControl Members


Tag Property (ARControl)

Tag Property (ARControl)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Tag Property
Gets or sets user-defined information to be persisted with the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Tag As System.Object
public System.object Tag {get; set;}
Example
  • C#
GrapeCity.ActiveReports.SectionReportModel.ARControl arcontrol = new GrapeCity.ActiveReports.SectionReportModel.ARControl();
arcontrol.Tag = new TextBox();
  • Visual Basic
Dim arcontrol As New GrapeCity.ActiveReports.SectionReportModel.ARControl()
arcontrol.Tag = New TextBox()
See Also

Reference

ARControl Class
ARControl Members


Top Property (ARControl)

Top Property (ARControl)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Top Property
Gets or sets, in inches, the top position of the control relative to the section that contains it.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Top As System.Single
public System.float Top {get; set;}

Property Value

A float or Single value in inches.
Remarks
Note: Be sure that the section containing the control is sized to accommodate the location. Otherwise the control may render in a hidden area.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Height = 1;
    this.textBox1.Width = 2;
    this.textBox1.Left = 2;
    this.textBox1.Top = 0;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    With Me.TextBox1
        .Height = 1
        .Width = 2
        .Left = 2
        .Top = 0
    End With
End Sub
See Also

Reference

ARControl Class
ARControl Members


Visible Property (ARControl)

Visible Property (ARControl)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Visible Property
Sets or returns a value indicating whether the control will be printed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}

Property Value

A Boolean value. Default is True.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.textBox2.Value.ToString() == "ALFKI")
    {
        this.textBox2.Visible = false;
    }
    else
    {
        this.textBox2.Visible = true;
    }
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    If Me.TextBox1.Value = "ALFKI" Then
        Me.TextBox1.Visible = False
    Else
        Me.TextBox1.Visible = True
    End If
End Sub
See Also

Reference

ARControl Class
ARControl Members


Width Property (ARControl)

Width Property (ARControl)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Width Property
Gets or sets the width of the control in inches.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As System.Single
public System.float Width {get; set;}

Property Value

A float or Single value in inches.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Height = 1;
    this.textBox1.Width = 2;
    this.textBox1.Left = 2;
    this.textBox1.Top = 0;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    With Me.TextBox1
        .Height = 1
        .Width = 2
        .Left = 2
        .Top = 0
    End With
End Sub
See Also

Reference

ARControl Class
ARControl Members


Barcode Class

Barcode Class
Members Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Barcode Class
The Barcode control is used to print barcode symbology in the report.
Object Model
Barcode Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Barcode
   Inherits ARControl
public sealed class Barcode : ARControl
Remarks
The Barcode control can be bound to data fields or unbound.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.Alignment = System.Drawing.StringAlignment.Center;
    this.barcode1.AutoSize = true;
    this.barcode1.BackColor = System.Drawing.Color.White;
    this.barcode1.BarHeight = 0.0f;
    this.barcode1.CaptionPosition = BarCodeCaptionPosition.Below;
    this.barcode1.CheckSumEnabled = true;
    this.barcode1.ForeColor = System.Drawing.Color.Green;
    this.barcode1.Style = BarCodeStyle.Code49;
    this.barcode1.Text = "Barcode";
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.Alignment = System.Drawing.StringAlignment.Center
    Me.Barcode1.AutoSize = True
    Me.Barcode1.BackColor = System.Drawing.Color.White
    Me.Barcode1.BarHeight = 0.0F
    Me.Barcode1.CaptionPosition = BarCodeCaptionPosition.Below
    Me.Barcode1.CheckSumEnabled = True
    Me.Barcode1.ForeColor = System.Drawing.Color.Green
    Me.Barcode1.Style = BarCodeStyle.Code49
    Me.Barcode1.Text = "Barcode"
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.Barcode

See Also

Reference

Barcode Members
GrapeCity.ActiveReports.SectionReportModel Namespace


Barcode Class Members

Barcode Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Barcode Class

The following tables list the members exposed by Barcode.

Public Constructors
 | Name | Description
Public Constructor | Barcode Constructor | Initializes a new instance of the Barcode class.
Top
Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the horizontal alignment of the caption in the control.
Public Property | AutoSize | Gets or sets whether the barcode automatically stretches to fit the control.
Public Property | BackColor | Gets or sets the barcode's background color or fill color.
Public Property | BarHeight | Gets or sets the height of the bars in inches.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | CaptionGrouping | Gets or sets a value indicating whether to add spaces between groups of characters in the caption to make long numbers easier to read.
Public Property | CaptionPosition | Gets or sets the caption's vertical position relative to the barcode symbol.
Public Property | CheckSumEnabled | Determines whether a checksum of the barcode will be computed and included in the barcode when applicable.
Public Property | Code128 | Gets or sets the Code128Options for the barcode control.
Public Property | Code49 | Gets or sets the Code49Options for the barcode control.
Public Property | DataField | Overridden. Gets or sets the name of the field used to bind the data source records.
Public Property | DataMatrix | DataMatrix options include EccMode, Ecc200SymbolSize, Ecc200EncodingMode, Ecc000_140SymbolSize, StructuredAppend, StructureNumber, FileIdentifier, and Encoding. Select from supplied values, or enter a number for the StructureNumber and FileIdentifier.
Public Property | Font | Gets or returns the font object used to print the control's caption.
Public Property | ForeColor | Gets or returns the foreground color of the control.
Public Property | GS1Composite | Gets or sets the GS1CompositeOptions for the barcode control.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | MicroPDF417 | Gets or sets the MicroPDF417Options for the barcode control.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | NarrowBarWidth | Also known as the X dimension, this is a value defining the width of the narrowest part of the barcode. Before using an extremely small value for this width, ensure that the scanner can read it. This value is in pixel for SectionReports and in point/inch/cm for PageReports.
Public Property | NWRatio | Also known as the N dimension, this is a value defining the multiple of the ratio between the narrow and wide bars in symbologies that contain bars in only two widths. For example, if it is a 3 to 1 ratio, this value is 3.
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | PDF417 | Gets or sets the PDF417Options for the barcode control.
Public Property | QRCode | Gets or sets the QRCodeOptions for the barcode control.
Public Property | QuietZoneBottom | Gets or sets the bottom quiet zone of the barcode.
Public Property | QuietZoneLeft | Gets or sets the left quiet zone of the barcode.
Public Property | QuietZoneRight | Gets or sets the right quiet zone of the barcode
Public Property | QuietZoneTop | Gets or sets the top quiet zone of the barcode
Public Property | Rotation | Gets or sets the angle the barcode should be rotated to.
Public Property | RssExpandedStacked | When you set the Barcode Style property to RssExpandedStacked, this property allows you to control, via the RowCount property, the number of stacks of segments in which to display the code. You can specify two to eleven rows. Displaying an RSS Expanded barcode in stacks may be more appropriate for certain packaging requirements, as it reduces the length of a barcode.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Style | Gets or sets the barcode symbology used to render the barcode text.
Public Property | SupplementBarHeight | The height of a bar in the supplement barcode.
Public Property | SupplementCaptionPosition | Defines how to display the barcode caption.
Public Property | SupplementDataField | The supplement for barcode data.
Public Property | SupplementSpacing | The spacing between main and supplement barcodes.
Public Property | SupplementText | The supplement for barcode data.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Text | Gets or sets the barcode text value to be printed as a barcode symbol and caption of the barcode in applicable symbologies.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | ValueBinary | Special property to pass binary data to barcode. Exists primary for QR Code barcode.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

Barcode Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Barcode Constructor

Barcode Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Barcode Constructor
Initializes a new instance of the Barcode class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Barcode()
See Also

Reference

Barcode Class
Barcode Members


Barcode Class Properties

Barcode Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Barcode Class

For a list of all members of this type, see Barcode members.

Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the horizontal alignment of the caption in the control.
Public Property | AutoSize | Gets or sets whether the barcode automatically stretches to fit the control.
Public Property | BackColor | Gets or sets the barcode's background color or fill color.
Public Property | BarHeight | Gets or sets the height of the bars in inches.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | CaptionGrouping | Gets or sets a value indicating whether to add spaces between groups of characters in the caption to make long numbers easier to read.
Public Property | CaptionPosition | Gets or sets the caption's vertical position relative to the barcode symbol.
Public Property | CheckSumEnabled | Determines whether a checksum of the barcode will be computed and included in the barcode when applicable.
Public Property | Code128 | Gets or sets the Code128Options for the barcode control.
Public Property | Code49 | Gets or sets the Code49Options for the barcode control.
Public Property | DataField | Overridden. Gets or sets the name of the field used to bind the data source records.
Public Property | DataMatrix | DataMatrix options include EccMode, Ecc200SymbolSize, Ecc200EncodingMode, Ecc000_140SymbolSize, StructuredAppend, StructureNumber, FileIdentifier, and Encoding. Select from supplied values, or enter a number for the StructureNumber and FileIdentifier.
Public Property | Font | Gets or returns the font object used to print the control's caption.
Public Property | ForeColor | Gets or returns the foreground color of the control.
Public Property | GS1Composite | Gets or sets the GS1CompositeOptions for the barcode control.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | MicroPDF417 | Gets or sets the MicroPDF417Options for the barcode control.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | NarrowBarWidth | Also known as the X dimension, this is a value defining the width of the narrowest part of the barcode. Before using an extremely small value for this width, ensure that the scanner can read it. This value is in pixel for SectionReports and in point/inch/cm for PageReports.
Public Property | NWRatio | Also known as the N dimension, this is a value defining the multiple of the ratio between the narrow and wide bars in symbologies that contain bars in only two widths. For example, if it is a 3 to 1 ratio, this value is 3.
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | PDF417 | Gets or sets the PDF417Options for the barcode control.
Public Property | QRCode | Gets or sets the QRCodeOptions for the barcode control.
Public Property | QuietZoneBottom | Gets or sets the bottom quiet zone of the barcode.
Public Property | QuietZoneLeft | Gets or sets the left quiet zone of the barcode.
Public Property | QuietZoneRight | Gets or sets the right quiet zone of the barcode
Public Property | QuietZoneTop | Gets or sets the top quiet zone of the barcode
Public Property | Rotation | Gets or sets the angle the barcode should be rotated to.
Public Property | RssExpandedStacked | When you set the Barcode Style property to RssExpandedStacked, this property allows you to control, via the RowCount property, the number of stacks of segments in which to display the code. You can specify two to eleven rows. Displaying an RSS Expanded barcode in stacks may be more appropriate for certain packaging requirements, as it reduces the length of a barcode.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Style | Gets or sets the barcode symbology used to render the barcode text.
Public Property | SupplementBarHeight | The height of a bar in the supplement barcode.
Public Property | SupplementCaptionPosition | Defines how to display the barcode caption.
Public Property | SupplementDataField | The supplement for barcode data.
Public Property | SupplementSpacing | The spacing between main and supplement barcodes.
Public Property | SupplementText | The supplement for barcode data.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Text | Gets or sets the barcode text value to be printed as a barcode symbol and caption of the barcode in applicable symbologies.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | ValueBinary | Special property to pass binary data to barcode. Exists primary for QR Code barcode.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

Barcode Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Alignment Property (Barcode)

Alignment Property (Barcode)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Alignment Property
Gets or sets the horizontal alignment of the caption in the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Alignment As StringAlignment
public StringAlignment Alignment {get; set;}

Property Value

StringAlignment enum. The default value is StringAlignment.Center.

The possible values are StringAlignment.Near, StringAlignment.Center and StringAlignment.Far.

Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.Alignment = System.Drawing.StringAlignment.Near;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.Alignment = System.Drawing.StringAlignment.Center
End Sub
See Also

Reference

Barcode Class
Barcode Members


AutoSize Property (Barcode)

AutoSize Property (Barcode)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : AutoSize Property
Gets or sets whether the barcode automatically stretches to fit the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoSize As System.Boolean
public System.bool AutoSize {get; set;}

Property Value

Boolean. The default value is True.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.AutoSize = true;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.AutoSize = True
End Sub
See Also

Reference

Barcode Class
Barcode Members


BackColor Property (Barcode)

BackColor Property (Barcode)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : BackColor Property
Gets or sets the barcode's background color or fill color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackColor As Color
public Color BackColor {get; set;}

Property Value

System.Drawing.Color
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.BackColor = System.Drawing.Color.White;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.BackColor = System.Drawing.Color.White
End Sub
See Also

Reference

Barcode Class
Barcode Members


BarHeight Property

BarHeight Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : BarHeight Property
Gets or sets the height of the bars in inches.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BarHeight As System.Single
public System.float BarHeight {get; set;}
Remarks
If the bar height exceeds the height of the control, this property is ignored.
See Also

Reference

Barcode Class
Barcode Members


CaptionGrouping Property

CaptionGrouping Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : CaptionGrouping Property
Gets or sets a value indicating whether to add spaces between groups of characters in the caption to make long numbers easier to read.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CaptionGrouping As System.Boolean
public System.bool CaptionGrouping {get; set;}
See Also

Reference

Barcode Class
Barcode Members


CaptionPosition Property

CaptionPosition Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : CaptionPosition Property
Gets or sets the caption's vertical position relative to the barcode symbol.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CaptionPosition As BarCodeCaptionPosition
public BarCodeCaptionPosition CaptionPosition {get; set;}

Property Value

Current position of the caption. Default is BarCodeCaptionPosition.None.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.CaptionPosition = BarCodeCaptionPosition.Below;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.CaptionPosition = BarCodeCaptionPosition.Below
End Sub
See Also

Reference

Barcode Class
Barcode Members
ActiveReports6~GrapeCity.ActiveReports.BarCodeCaptionPosition


CheckSumEnabled Property

CheckSumEnabled Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : CheckSumEnabled Property
Determines whether a checksum of the barcode will be computed and included in the barcode when applicable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CheckSumEnabled As System.Boolean
public System.bool CheckSumEnabled {get; set;}

Property Value

Boolean. Default is true.
Remarks
  • Property is valid for the following barcodes:

Ansi39
Ansi39x
Code39
Code39x
Code_128_A
Code_128_B
Code_128_C
Code_128auto
Code_93
Code93x
MSI
PostNet
EAN_8
UPC_A
RM4SCC
UCCEAN128

  • Property is not valid for the following barcodes:

Codabar(NW-7)
EAN_13(JAN13)
Code_2_of_5
Code25intlv
Matrix_2_of_5
UPC_E0
UPC_E1
QRCode
Code49
DataMatrix
Pdf417
microPdf417
IntelligentMail
JapanesePostal (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)
EAN128FNC1 (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)
RSS14 (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)
RSS14Truncated (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)
RSS14Stacked (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)
RSS14StackedOmnidirectional (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)
RSSExpanded (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)
RSSExpandedStacked (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)
RSSLimited (Checksum is added automatically irrespective of the value set in the CheckSumEnabled property.)

CheckSumEnabled has no effect if the style is EAN-13 and the result is based on the length of the string as follows:

Under 12 digits | Barcode symbol is not generated. Error message appears on the control.
12 digits | Check digit is calculated automatically (modulus 10/ weight 3). The barcode symbol is generated once the 13th digit is added.
13 digits or above | Strings with 13 digits or above are ignored and check digit is calculated automatically till the 12th digit. The barcode symbol is generated once the 13th digit is added.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.CheckSumEnabled = true;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.CheckSumEnabled = True
End Sub
See Also

Reference

Barcode Class
Barcode Members


Code128 Property

Code128 Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Code128 Property
Gets or sets the Code128Options for the barcode control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Code128 As Code128Options
public Code128Options Code128 {get; set;}
Example
To insert FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at runtime.
  • C#
private void detail_Format(object sender, EventArgs e)
{
    this.barcode1.Style = BarCodeStyle.EAN128FNC1;
    // "\n" is encoded as FNC1 character and displayed none in caption.
    this.barcode1.Text = "12\n3456\n78";
    this.barcode1.Code128.Dpi = 300;
    this.barcode1.Code128.BarAdjust = +1;
    this.barcode1.Code128.ModuleSize = 2;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.Style = BarCodeStyle.EAN128FNC1
    ' vbLf is encoded as FNC1 character and displayed none in caption.
    Me.Barcode1.Text="12” & vbLf & "3456" & vbLf &"78"
    Me.Barcode1.Code128.Dpi = 300
    Me.Barcode1.Code128.BarAdjust = +1
    Me.Barcode1.Code128.ModuleSize = 2
End Sub
See Also

Reference

Barcode Class
Barcode Members


Code49 Property

Code49 Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Code49 Property
Gets or sets the Code49Options for the barcode control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Code49 As Code49Options
public Code49Options Code49 {get; set;}
Remarks

Code 49 is a high-density stacked symbology containing two to eight rows of eight characters each. Each row has a start code and a stop code.

Code49 Options include Grouping and Group. If Grouping is set to True, the Group property may be set to a number between 0 and 8. The default values are False and 0, respectively.

Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.Code49.Grouping = true;
    this.barcode1.Code49.Group = 4;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.Code49.Grouping = True
    Me.Barcode1.Code49.Group = 4
End Sub
See Also

Reference

Barcode Class
Barcode Members
ActiveReports6~GrapeCity.ActiveReports.Options.Code49Options


DataField Property (Barcode)

DataField Property (Barcode)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : DataField Property
Gets or sets the name of the field used to　bind the data source records.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Property DataField As System.String
public override System.string DataField {get; set;}

Property Value

Name of the data bound field. Default is an empty string; the control is not bound.
Remarks

When the DataField property is set to a field contained within the DataSource, ActiveReports binds the field's data from each record to the control. The recordset data is first saved into the Value property. It then converts to any output format and is set as the control's text.

The DataField property can also be used to perform calculations using a scripting expression beginning with an equals sign (=). This allows fields to be set up to display calculated results. For example, field control or data field's group field section can be set to an expression such as "=UnitPrice * Qty" or "=CompanyName.Trim()" where UnitPrice, Qty and CompanyName are members of the report's Fields collection.

Add an equals sign (=) at the beginning when using parameters in a DataField property.

When using XML, the DataField must be set to a valid XPath expression.

Requirements

See Also

Reference

Barcode Class
Barcode Members


DataMatrix Property

DataMatrix Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : DataMatrix Property
DataMatrix options include EccMode, Ecc200SymbolSize, Ecc200EncodingMode, Ecc000_140SymbolSize, StructuredAppend, StructureNumber, FileIdentifier, and Encoding. Select from supplied values, or enter a number for the StructureNumber and FileIdentifier.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataMatrix As DataMatrixOptions
public DataMatrixOptions DataMatrix {get; set;}
See Also

Reference

Barcode Class
Barcode Members


Font Property (Barcode)

Font Property (Barcode)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Font Property
Gets or returns the font object used to print the control's caption.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Font As Font
public Font Font {get; set;}
Example
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.Font = New System.Drawing.Font(Me.TextBox2.Font, FontStyle.Bold)
End Sub
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.Font = new System.Drawing.Font(this.TextBox2.Font, System.Drawing.FontStyle.Bold);
}
See Also

Reference

Barcode Class
Barcode Members


ForeColor Property (Barcode)

ForeColor Property (Barcode)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : ForeColor Property
Gets or returns the foreground color of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ForeColor As Color
public Color ForeColor {get; set;}

Property Value

System.Drawing.Color
Remarks
This color applies to both the barcode symbol and any caption.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.ForeColor = System.Drawing.Color.Green;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.ForeColor = System.Drawing.Color.Green
End Sub
See Also

Reference

Barcode Class
Barcode Members


GS1Composite Property

GS1Composite Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : GS1Composite Property
Gets or sets the GS1CompositeOptions for the barcode control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GS1Composite As GS1CompositeOptions
public GS1CompositeOptions GS1Composite {get; set;}
See Also

Reference

Barcode Class
Barcode Members


MicroPDF417 Property

MicroPDF417 Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : MicroPDF417 Property
Gets or sets the MicroPDF417Options for the barcode control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MicroPDF417 As MicroPDF417Options
public MicroPDF417Options MicroPDF417 {get; set;}
See Also

Reference

Barcode Class
Barcode Members


NarrowBarWidth Property

NarrowBarWidth Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : NarrowBarWidth Property

Also known as the X dimension, this is a value defining the width of the narrowest part of the barcode. Before using an extremely small value for this width, ensure that the scanner can read it.

This value is in pixel for SectionReports and in point/inch/cm for PageReports.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NarrowBarWidth As System.Single
public System.float NarrowBarWidth {get; set;}
See Also

Reference

Barcode Class
Barcode Members


NWRatio Property

NWRatio Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : NWRatio Property
Also known as the N dimension, this is a value defining the multiple of the ratio between the narrow and wide bars in symbologies that contain bars in only two widths. For example, if it is a 3 to 1 ratio, this value is 3.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NWRatio As System.Single
public System.float NWRatio {get; set;}
Remarks

Commonly used values are 2, 2.5, 2.75, and 3.

Some barcodes that use only two bar widths are Code39, Code25intlv, and MSI.

See Also

Reference

Barcode Class
Barcode Members


PDF417 Property

PDF417 Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : PDF417 Property
Gets or sets the PDF417Options for the barcode control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PDF417 As PDF417Options
public PDF417Options PDF417 {get; set;}
Remarks

PDF417 is a multi-row variable-length symbology that has ten error correction levels and three data compaction modes: Text, Byte, and Numeric. This symbology can encode up to 1,850 alphanumeric characters or 2,710 numeric characters.

PDF417 Options include Column, ErrorLevel, Row, and Type.

Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.PDF417.Column = 2;
    this.barcode1.PDF417.Row = -1;
    this.barcode1.PDF417.Type = GrapeCity.ActiveReports.Options.PDF417Type.Simple;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.PDF417.Column = 2
    Me.Barcode1.PDF417.Row = -1
    Me.Barcode1.PDF417.Type = GrapeCity.ActiveReports.Options.PDF417Type.Simple
End Sub
See Also

Reference

Barcode Class
Barcode Members
ActiveReports6~GrapeCity.ActiveReports.Options.PDF417Options


QRCode Property

QRCode Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : QRCode Property
Gets or sets the QRCodeOptions for the barcode control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property QRCode As QRCodeOptions
public QRCodeOptions QRCode {get; set;}
Remarks
QRCode is a two-dimensional symbology that is capable of handling numeric, alphanumeric and byte data as well as Japanese kanji and kana characters. This symbology can encode up to 7,366 characters.
Example
Paste into the Detail Format event.
  • C#
private void detail1_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.QRCode.Connection = false;
    this.barcode1.QRCode.ConnectionNumber = 0;
    this.barcode1.QRCode.ErrorLevel = GrapeCity.GrapeCity.ActiveReports.v10.Options.QRCodeErrorLevel.Q;
    this.barcode1.QRCode.Mask = GrapeCity.GrapeCity.ActiveReports.v10.Options.QRCodeMask.Mask111;
    this.barcode1.QRCode.Model = GrapeCity.GrapeCity.ActiveReports.v10.Options.QRCodeModel.Model2;
    this.barcode1.QRCode.Version = 3;
}
Paste into the Detail Format event.
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.QRCode.Connection = False
    Me.Barcode1.QRCode.ConnectionNumber = 0
    Me.Barcode1.QRCode.ErrorLevel = Options.QRCodeErrorLevel.Q
    Me.Barcode1.QRCode.Mask = Options.QRCodeMask.Mask111
    Me.Barcode1.QRCode.Model = Options.QRCodeModel.Model2
    Me.Barcode1.QRCode.Version = 3
End Sub
See Also

Reference

Barcode Class
Barcode Members
ActiveReports6~GrapeCity.ActiveReports.Options.QRCodeOptions


QuietZoneBottom Property

QuietZoneBottom Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : QuietZoneBottom Property
Gets or sets the bottom quiet zone of the barcode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property QuietZoneBottom As System.Single
public System.float QuietZoneBottom {get; set;}
See Also

Reference

Barcode Class
Barcode Members


QuietZoneLeft Property

QuietZoneLeft Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : QuietZoneLeft Property
Gets or sets the left quiet zone of the barcode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property QuietZoneLeft As System.Single
public System.float QuietZoneLeft {get; set;}
See Also

Reference

Barcode Class
Barcode Members


QuietZoneRight Property

QuietZoneRight Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : QuietZoneRight Property
Gets or sets the right quiet zone of the barcode
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property QuietZoneRight As System.Single
public System.float QuietZoneRight {get; set;}
See Also

Reference

Barcode Class
Barcode Members


QuietZoneTop Property

QuietZoneTop Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : QuietZoneTop Property
Gets or sets the top quiet zone of the barcode
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property QuietZoneTop As System.Single
public System.float QuietZoneTop {get; set;}
See Also

Reference

Barcode Class
Barcode Members


Rotation Property (Barcode)

Rotation Property (Barcode)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Rotation Property
Gets or sets the angle the barcode should be rotated to.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Rotation As Rotation
public Rotation Rotation {get; set;}

Property Value

The rotation.
See Also

Reference

Barcode Class
Barcode Members


RssExpandedStacked Property

RssExpandedStacked Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : RssExpandedStacked Property
When you set the Barcode Style property to RssExpandedStacked, this property allows you to control, via the RowCount property, the number of stacks of segments in which to display the code. You can specify two to eleven rows. Displaying an RSS Expanded barcode in stacks may be more appropriate for certain packaging requirements, as it reduces the length of a barcode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RssExpandedStacked As RssExpandedStackedOptions
public RssExpandedStackedOptions RssExpandedStacked {get; set;}
Remarks
If the RowCount property is set to 1, the RSS Expanded Stacked barcode style becomes the same symbol as the RSS Expanded barcode style.

There is a relation between the RowCount property and the Text property of an RSS Expanded Stacked barcode. This means that a barcode symbol is displayed using the number of rows that is determined, based on the value in the Text property against the value in the RowCount property.
See Also

Reference

Barcode Class
Barcode Members


Style Property (Barcode)

Style Property (Barcode)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Style Property

Gets or sets the barcode symbology used to render the barcode text.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As BarCodeStyle
public BarCodeStyle Style {get; set;}

Property Value

Current barcode symbology. Default is BarCodeStyle.Ansi39
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.Style = BarCodeStyle.Code49;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.Style = BarCodeStyle.Code49
End Sub
See Also

Reference

Barcode Class
Barcode Members
ActiveReports6~GrapeCity.ActiveReports.BarCodeStyle


SupplementBarHeight Property

SupplementBarHeight Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : SupplementBarHeight Property
The height of a bar in the supplement barcode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SupplementBarHeight As System.Single
public System.float SupplementBarHeight {get; set;}
Remarks
Supplement is 2/5-digit addons for EAN/UPC symbologies.
See Also

Reference

Barcode Class
Barcode Members


SupplementCaptionPosition Property

SupplementCaptionPosition Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : SupplementCaptionPosition Property
Defines how to display the barcode caption.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SupplementCaptionPosition As BarCodeCaptionPosition
public BarCodeCaptionPosition SupplementCaptionPosition {get; set;}
Remarks
Supplement is 2/5-digit addons for EAN/UPC symbologies.
See Also

Reference

Barcode Class
Barcode Members


SupplementDataField Property

SupplementDataField Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : SupplementDataField Property
The supplement for barcode data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SupplementDataField As System.String
public System.string SupplementDataField {get; set;}
Remarks
Supplement is 2/5-digit addons for EAN/UPC symbologies.
See Also

Reference

Barcode Class
Barcode Members


SupplementSpacing Property

SupplementSpacing Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : SupplementSpacing Property
The spacing between main and supplement barcodes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SupplementSpacing As System.Single
public System.float SupplementSpacing {get; set;}
Remarks
Supplement is 2/5-digit addons for EAN/UPC symbologies.
See Also

Reference

Barcode Class
Barcode Members


SupplementText Property

SupplementText Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : SupplementText Property
The supplement for barcode data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SupplementText As System.String
public System.string SupplementText {get; set;}
Remarks
Supplement is 2/5-digit addons for EAN/UPC symbologies.
See Also

Reference

Barcode Class
Barcode Members


Text Property (Barcode)

Text Property (Barcode)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : Text Property
Gets or sets the barcode text value to be printed as a barcode symbol and caption of the barcode in applicable symbologies.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Text As System.String
public System.string Text {get; set;}

Property Value

Current text string. Default is an empty string.

Remarks

ActiveReports fills this value from the bound data field if the control is bound to the data source.

Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.barcode1.Text = "Barcode";
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Barcode1.Text = "Barcode"
End Sub
See Also

Reference

Barcode Class
Barcode Members


ValueBinary Property

ValueBinary Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Barcode Class : ValueBinary Property
Special property to pass binary data to barcode. Exists primary for QR Code barcode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ValueBinary As System.Byte()
public System.byte[] ValueBinary {get; set;}
See Also

Reference

Barcode Class
Barcode Members


ChartControl Class

ChartControl Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ChartControl Class
Renders a chart on the report.
Object Model
ChartControl Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ChartControl
   Inherits ARControl
public sealed class ChartControl : ARControl
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.ChartControl

See Also

Reference

ChartControl Members
GrapeCity.ActiveReports.SectionReportModel Namespace


ChartControl Class Members

ChartControl Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ChartControl Class

The following tables list the members exposed by ChartControl.

Public Constructors
 | Name | Description
Public Constructor | ChartControl Constructor | Initializes a new instance of the ChartControl class.
Top
Public Properties
 | Name | Description
Public Property | AutoRefresh | Gets or sets a value indicating whether the chart will be automatically refreshed (redrawn) for every property change.
Public Property | Backdrop | Gets or sets the BackdropItem used for the background of the chart control.
Public Property | BlackAndWhiteMode | Gets or sets a value indicating whether the chart will be drawn in black and white using hatch patterns and line dashing to designate colors.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | ChartAreas | A collection of ChartArea objects drawn in the chart control.
Public Property | ChartBorder | Gets or sets the border used to draw around the chart.
Public Property | ColorPalette | Gets or sets the color palette enumeration used for the series.
Public Property | Culture | Gets or sets the culture for the chart control.
Public Property | DataSource | Gets or sets the global data source for the chart.
Public Property | GridLayout | Gets or sets the GridLayout object for the chart.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | ImageType | Sets or returns the type of image to which the chart will be rendered on the report.
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Legends | Gets or sets the legend object for the chart control.
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | RightToLeft | Gets or sets a value indicating whether the control's elements are aligned to support locales using right-to-left fonts.
Public Property | Series | Gets the series collection for the chart object.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Titles | Gets the titles collection for the SharpGraph object.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | UIOptions | Gets or sets specific user interface features for the chart.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose | Releases the control instance from memory.
Public Method | Load | Reconstructs a chart object from the specified file.
Public Method | Restart | Resets the chart data source and restarts chart processing.
Public Method | Save | Creates an XML encoding of the chart object and its current state (without data).
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
Public Events
 | Name | Description
Public Event | DataSourceChanged | Raised when the data source of the chart changes.
Top
See Also

Reference

ChartControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ChartControl Constructor

ChartControl Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : ChartControl Constructor
Initializes a new instance of the ChartControl class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ChartControl()
See Also

Reference

ChartControl Class
ChartControl Members


ChartControl Class Methods

ChartControl Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ChartControl Class

For a list of all members of this type, see ChartControl members.

Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose | Releases the control instance from memory.
Public Method | Load | Reconstructs a chart object from the specified file.
Public Method | Restart | Resets the chart data source and restarts chart processing.
Public Method | Save | Creates an XML encoding of the chart object and its current state (without data).
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

ChartControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Dispose() Method
Releases the control instance from memory.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Sub Dispose()
public new void Dispose()
See Also

Reference

ChartControl Class
ChartControl Members


Load Method (ChartControl)

Load Method (ChartControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Load Method
The name of the file from which to load the chart.
Reconstructs a chart object from the specified file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Load( _
   ByVal filename As System.String _
)
public void Load(
   System.string filename
)

Parameters

filename
The name of the file from which to load the chart.
See Also

Reference

ChartControl Class
ChartControl Members


Restart Method (ChartControl)

Restart Method (ChartControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Restart Method
Resets the chart data source and restarts chart processing.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Restart()
public void Restart()
Remarks

This method is obsolete.

See Also

Reference

ChartControl Class
ChartControl Members


Save Method (ChartControl)

Save Method (ChartControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Save Method
The name of the file to which the chart is to be saved.
Creates an XML encoding of the chart object and its current state (without data).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Save( _
   ByVal filename As System.String _
)
public void Save(
   System.string filename
)

Parameters

filename
The name of the file to which the chart is to be saved.
See Also

Reference

ChartControl Class
ChartControl Members


ChartControl Class Properties

ChartControl Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ChartControl Class

For a list of all members of this type, see ChartControl members.

Public Properties
 | Name | Description
Public Property | AutoRefresh | Gets or sets a value indicating whether the chart will be automatically refreshed (redrawn) for every property change.
Public Property | Backdrop | Gets or sets the BackdropItem used for the background of the chart control.
Public Property | BlackAndWhiteMode | Gets or sets a value indicating whether the chart will be drawn in black and white using hatch patterns and line dashing to designate colors.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | ChartAreas | A collection of ChartArea objects drawn in the chart control.
Public Property | ChartBorder | Gets or sets the border used to draw around the chart.
Public Property | ColorPalette | Gets or sets the color palette enumeration used for the series.
Public Property | Culture | Gets or sets the culture for the chart control.
Public Property | DataSource | Gets or sets the global data source for the chart.
Public Property | GridLayout | Gets or sets the GridLayout object for the chart.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | ImageType | Sets or returns the type of image to which the chart will be rendered on the report.
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Legends | Gets or sets the legend object for the chart control.
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | RightToLeft | Gets or sets a value indicating whether the control's elements are aligned to support locales using right-to-left fonts.
Public Property | Series | Gets the series collection for the chart object.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Titles | Gets the titles collection for the SharpGraph object.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | UIOptions | Gets or sets specific user interface features for the chart.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

ChartControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


AutoRefresh Property (ChartControl)

AutoRefresh Property (ChartControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : AutoRefresh Property
Gets or sets a value indicating whether the chart will be automatically refreshed (redrawn) for every property change.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoRefresh As System.Boolean
public System.bool AutoRefresh {get; set;}
See Also

Reference

ChartControl Class
ChartControl Members


Backdrop Property (ChartControl)

Backdrop Property (ChartControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Backdrop Property
Gets or sets the BackdropItem used for the background of the chart control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Backdrop As Backdrop
public Backdrop Backdrop {get; set;}
See Also

Reference

ChartControl Class
ChartControl Members


BlackAndWhiteMode Property

BlackAndWhiteMode Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : BlackAndWhiteMode Property
Gets or sets a value indicating whether the chart will be drawn in black and white using hatch patterns and line dashing to designate colors.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BlackAndWhiteMode As System.Boolean
public System.bool BlackAndWhiteMode {get; set;}

Property Value

A Boolean value. The default value is False.
See Also

Reference

ChartControl Class
ChartControl Members


ChartAreas Property (ChartControl)

ChartAreas Property (ChartControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : ChartAreas Property
A collection of ChartArea objects drawn in the chart control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ChartAreas As ChartAreasCollection
public ChartAreasCollection ChartAreas {get;}

Property Value

The chart areas.
Remarks
By default, one ChartArea is included in the ChartAreas collection.
See Also

Reference

ChartControl Class
ChartControl Members


ChartBorder Property

ChartBorder Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : ChartBorder Property
Gets or sets the border used to draw around the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ChartBorder As Border
public Border ChartBorder {get; set;}
See Also

Reference

ChartControl Class
ChartControl Members


ColorPalette Property (ChartControl)

ColorPalette Property (ChartControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : ColorPalette Property
Gets or sets the color palette enumeration used for the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ColorPalette As ColorPalette
public ColorPalette ColorPalette {get; set;}
See Also

Reference

ChartControl Class
ChartControl Members
ColorPalette Enumeration


Culture Property (ChartControl)

Culture Property (ChartControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Culture Property
Gets or sets the culture for the chart control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Culture As System.Globalization.CultureInfo
public System.Globalization.CultureInfo Culture {get; set;}
See Also

Reference

ChartControl Class
ChartControl Members


DataSource Property (ChartControl)

DataSource Property (ChartControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : DataSource Property
Gets or sets the global data source for the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataSource As System.Object
public System.object DataSource {get; set;}
See Also

Reference

ChartControl Class
ChartControl Members


GridLayout Property (ChartControl)

GridLayout Property (ChartControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : GridLayout Property
Gets or sets the GridLayout object for the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GridLayout As GridLayout
public GridLayout GridLayout {get; set;}

Property Value

The grid layout.
See Also

Reference

ChartControl Class
ChartControl Members


ImageType Property (ChartControl)

ImageType Property (ChartControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : ImageType Property
Sets or returns the type of image to which the chart will be rendered on the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ImageType As ImageTypes
public ImageTypes ImageType {get; set;}

Property Value

An ImageTypes enumeration. The default value is Metafile. The alternate value is PNG.
Remarks
Some images can be a problem when exported as a metafile due to some graphic commands which are not supported. If you are noticing problems with images not exporting to PDF, set the ImageType to PNG.
See Also

Reference

ChartControl Class
ChartControl Members
ActiveReports6~GrapeCity.ActiveReports.ImageTypes


ImeMode Property (ChartControl)

ImeMode Property (ChartControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : ImeMode Property
Gets or sets the Input Method Editor (IME) mode of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ImeMode As System.Windows.Forms.ImeMode
public System.Windows.Forms.ImeMode ImeMode {get; set;}

Property Value

The IME mode.
See Also

Reference

ChartControl Class
ChartControl Members


Legends Property (ChartControl)

Legends Property (ChartControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Legends Property
Gets or sets the legend object for the chart control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Legends As LegendsCollection
public LegendsCollection Legends {get;}
See Also

Reference

ChartControl Class
ChartControl Members


RightToLeft Property (ChartControl)

RightToLeft Property (ChartControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : RightToLeft Property
Gets or sets a value indicating whether the control's elements are aligned to support locales using right-to-left fonts.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RightToLeft As System.Windows.Forms.RightToLeft
public System.Windows.Forms.RightToLeft RightToLeft {get; set;}
See Also

Reference

ChartControl Class
ChartControl Members


Series Property (ChartControl)

Series Property (ChartControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Series Property
Gets the series collection for the chart object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Series As SeriesCollection
public SeriesCollection Series {get;}
See Also

Reference

ChartControl Class
ChartControl Members


Titles Property (ChartControl)

Titles Property (ChartControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Titles Property
Gets the titles collection for the SharpGraph object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Titles As TitlesCollection
public TitlesCollection Titles {get;}
See Also

Reference

ChartControl Class
ChartControl Members


UIOptions Property (ChartControl)

UIOptions Property (ChartControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : UIOptions Property
Gets or sets specific user interface features for the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UIOptions As UIOptions
public UIOptions UIOptions {get; set;}
See Also

Reference

ChartControl Class
ChartControl Members


ChartControl Class Events

ChartControl Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ChartControl Class

For a list of all members of this type, see ChartControl members.

Public Events
 | Name | Description
Public Event | DataSourceChanged | Raised when the data source of the chart changes.
Top
See Also

Reference

ChartControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


DataSourceChanged Event (ChartControl)

DataSourceChanged Event (ChartControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : DataSourceChanged Event
Raised when the data source of the chart changes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DataSourceChanged As System.EventHandler
public event System.EventHandler DataSourceChanged
See Also

Reference

ChartControl Class
ChartControl Members


CheckBox Class

CheckBox Class
Members Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CheckBox Class
Checkbox is used to print Boolean values as checked or unchecked.
Object Model
CheckBox Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class CheckBox
   Inherits ARControl
public sealed class CheckBox : ARControl
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.BackColor = System.Drawing.Color.LightBlue;
    this.checkBox1.CheckAlignment = System.Drawing.ContentAlignment.MiddleLeft;
    this.checkBox1.Checked = true;
    this.checkBox1.ClassName = "Normal";
    this.checkBox1.Font = new System.Drawing.Font("Arial",12);
    this.checkBox1.ForeColor = System.Drawing.Color.Navy;
    this.checkBox1.Text = "CheckBox";
    this.checkBox1.WrapMode = GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap;
    //With the properties above set, the Style string would be:
    //this.checkBox1.Style = color: Navy; background-color: LightBlue; font-size: 12pt;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.BackColor = System.Drawing.Color.LightBlue
   Me.CheckBox1.CheckAlignment = System.Drawing.ContentAlignment.MiddleLeft
   Me.CheckBox1.Checked = True
   Me.CheckBox1.ClassName = "Normal"
   Me.CheckBox1.Font = New System.Drawing.Font("Arial", 12)
   Me.CheckBox1.ForeColor = System.Drawing.Color.Navy
   Me.CheckBox1.Text = "CheckBox"
   Me.CheckBox1.WrapMode = GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap
   'With the properties above set, the Style string would be:
   'Me.CheckBox1.Style = color: Navy; background-color: LightBlue; font-size: 12pt;
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.CheckBox

See Also

Reference

CheckBox Members
GrapeCity.ActiveReports.SectionReportModel Namespace


CheckBox Class Members

CheckBox Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CheckBox Class

The following tables list the members exposed by CheckBox.

Public Constructors
 | Name | Description
Public Constructor | CheckBox Constructor | Initializes a new instance of the CheckBox class.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the control's background color or fill color.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | CheckAlignment | Gets or sets the alignment of the checkbox text within the control drawing area.
Public Property | Checked | Gets or sets a value indicating the state of the checkbox.
Public Property | ClassName | Gets or sets a style rule class name. The style rule is used to format the control.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Font | Gets or returns the font object used to print the control's text.
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Padding | Gets or sets the number of points of padding to use on each side of the control.
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Style | Gets or sets a style string for the checkbox.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Text | Gets or sets the printed caption of the checkbox.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | WrapMode | Sets/gets control's wrap mode using CSS.
Top
Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

CheckBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CheckBox Constructor

CheckBox Constructor
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : CheckBox Constructor
Initializes a new instance of the CheckBox class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public CheckBox()
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.BackColor = System.Drawing.Color.LightBlue;
    this.checkBox1.CheckAlignment = System.Drawing.ContentAlignment.MiddleLeft;
    this.checkBox1.Checked = true;
    this.checkBox1.ClassName = "Normal";
    this.checkBox1.Font = new System.Drawing.Font("Arial",12);
    this.checkBox1.ForeColor = System.Drawing.Color.Navy;
    this.checkBox1.Text = "CheckBox";
    this.checkBox1.WrapMode = GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap;
    //With the properties above set, the Style string would be:
    //this.checkBox1.Style = color: Navy; background-color: LightBlue; font-size: 12pt;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.CheckBox1.BackColor = System.Drawing.Color.LightBlue
    Me.CheckBox1.CheckAlignment = System.Drawing.ContentAlignment.MiddleLeft
    Me.CheckBox1.Checked = True
    Me.CheckBox1.ClassName = "Normal"
    Me.CheckBox1.Font = New System.Drawing.Font("Arial", 12)
    Me.CheckBox1.ForeColor = System.Drawing.Color.Navy
    Me.CheckBox1.Text = "CheckBox"
    Me.CheckBox1.WrapMode = GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap
    'With the properties above set, the Style string would be:
    'Me.CheckBox1.Style = color: Navy; background-color: LightBlue; font-size: 12pt;
End Sub
See Also

Reference

CheckBox Class
CheckBox Members


CheckBox Class Properties

CheckBox Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CheckBox Class

For a list of all members of this type, see CheckBox members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the control's background color or fill color.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | CheckAlignment | Gets or sets the alignment of the checkbox text within the control drawing area.
Public Property | Checked | Gets or sets a value indicating the state of the checkbox.
Public Property | ClassName | Gets or sets a style rule class name. The style rule is used to format the control.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Font | Gets or returns the font object used to print the control's text.
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Padding | Gets or sets the number of points of padding to use on each side of the control.
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Style | Gets or sets a style string for the checkbox.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Text | Gets or sets the printed caption of the checkbox.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | WrapMode | Sets/gets control's wrap mode using CSS.
Top
See Also

Reference

CheckBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


BackColor Property (CheckBox)

BackColor Property (CheckBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : BackColor Property
Gets or sets the control's background color or fill color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackColor As Color
public Color BackColor {get; set;}

Property Value

System.Drawing.Color
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.BackColor = System.Drawing.Color.LightBlue;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.BackColor = System.Drawing.Color.LightBlue
End Sub
See Also

Reference

CheckBox Class
CheckBox Members


CheckAlignment Property (CheckBox)

CheckAlignment Property (CheckBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : CheckAlignment Property
Gets or sets the alignment of the checkbox text within the control drawing area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CheckAlignment As System.Drawing.ContentAlignment
public System.Drawing.ContentAlignment CheckAlignment {get; set;}

Property Value

Current alignment setting. Default is System.Drawing.ContentAlignment.MiddleLeft.

Possible values are:

  • System.Drawing.ContentAlignment.BottomCenter
  • System.Drawing.ContentAlignment.BottomLeft
  • System.Drawing.ContentAlignment.BottomRight
  • System.Drawing.ContentAlignment.MiddleCenter
  • System.Drawing.ContentAlignment.MiddleLeft
  • System.Drawing.ContentAlignment.MiddleRight
  • System.Drawing.ContentAlignment.TopCenter
  • System.Drawing.ContentAlignment.TopLeft
  • System.Drawing.ContentAlignment.TopRight
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.CheckAlignment = System.Drawing.ContentAlignment.MiddleLeft;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.CheckAlignment = System.Drawing.ContentAlignment.MiddleLeft
End Sub
See Also

Reference

CheckBox Class
CheckBox Members


Checked Property (CheckBox)

Checked Property (CheckBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : Checked Property
Gets or sets a value indicating the state of the checkbox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Checked As System.Boolean
public System.bool Checked {get; set;}

Property Value

Boolean. True if the check box is in the checked state; otherwise, False. The default value is False.

Remarks
When the value is True, the check box portion of the control displays a check mark.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.Checked = true;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.Checked = True
End Sub
See Also

Reference

CheckBox Class
CheckBox Members


ClassName Property (CheckBox)

ClassName Property (CheckBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : ClassName Property
Gets or sets a style rule class name. The style rule is used to format the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ClassName As System.String
public System.string ClassName {get; set;}

Property Value

String. Style class name. Default value is "Normal".
Remarks
Style classes are defined in the report's Stylesheet.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.ClassName = "Normal";
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.ClassName = "Normal"
End Sub
See Also

Reference

CheckBox Class
CheckBox Members
StyleSheet Property


Font Property (CheckBox)

Font Property (CheckBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : Font Property
Gets or returns the font object used to print the control's text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Font As Font
public Font Font {get; set;}

Property Value

System.Drawing.Font
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.Font = new System.Drawing.Font("Arial",12);
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.Font = New System.Drawing.Font("Arial", 12)
End Sub
See Also

Reference

CheckBox Class
CheckBox Members


ForeColor Property (CheckBox)

ForeColor Property (CheckBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : ForeColor Property
Gets or returns the foreground (font) color of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ForeColor As Color
public Color ForeColor {get; set;}

Property Value

System.Drawing.Color
Remarks
This property sets the color for both the text and the checkbox in the control.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.ForeColor = System.Drawing.Color.Navy;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.ForeColor = System.Drawing.Color.Navy
End Sub
See Also

Reference

CheckBox Class
CheckBox Members


Padding Property (CheckBox)

Padding Property (CheckBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : Padding Property
Gets or sets the number of points of padding to use on each side of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Padding As PaddingEx
public PaddingEx Padding {get; set;}
See Also

Reference

CheckBox Class
CheckBox Members
Padding Class


Style Property (CheckBox)

Style Property (CheckBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : Style Property
Gets or sets a style string for the checkbox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As System.String
public System.string Style {get; set;}

Property Value

String. CSS syntax of the control style.
Remarks

The style string overrides the global style rules specified in the ClassName property.

Style string syntax is based on Cascading Style Sheets syntax.

Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.BackColor = System.Drawing.Color.LightBlue;
    this.checkBox1.ClassName = "Normal";
    this.checkBox1.Font = new System.Drawing.Font("Arial",12);
    this.checkBox1.ForeColor = System.Drawing.Color.Navy;
    //With the properties above set, the Style string would be:
    //this.checkBox1.Style = color: Navy; background-color: LightBlue; font-size: 12pt;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.BackColor = System.Drawing.Color.LightBlue
   Me.CheckBox1.ClassName = "Normal"
   Me.CheckBox1.Font = New System.Drawing.Font("Arial", 12)
   Me.CheckBox1.ForeColor = System.Drawing.Color.Navy
   'With the properties above set, the Style string would be:
   'Me.CheckBox1.Style = color: Navy; background-color: LightBlue; font-size: 12pt;
End Sub
See Also

Reference

CheckBox Class
CheckBox Members
ActiveReports6~GrapeCity.ActiveReports.CheckBox~ClassName


Text Property (CheckBox)

Text Property (CheckBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : Text Property
Gets or sets the printed caption of the checkbox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Text As System.String
public System.string Text {get; set;}

Property Value

String. Current caption of the checkbox.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.checkBox1.Text = "CheckBox";
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.CheckBox1.Text = "CheckBox"
End Sub
See Also

Reference

CheckBox Class
CheckBox Members


WrapMode Property (CheckBox)

WrapMode Property (CheckBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CheckBox Class : WrapMode Property
Sets/gets control's wrap mode using CSS.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WrapMode As WrapMode
public WrapMode WrapMode {get; set;}
See Also

Reference

CheckBox Class
CheckBox Members


ControlCollection Class

ControlCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ControlCollection Class
Represents a collection of ARControl objects.
Object Model
ControlCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ControlCollection
   Inherits System.Collections.CollectionBase
public class ControlCollection : System.Collections.CollectionBase
Remarks
The Add and Remove methods enable you to add or remove controls from the collection. You can also use the AddRange or Clear methods to add or remove all controls from the collection.
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ControlCollection

See Also

Reference

ControlCollection Members
GrapeCity.ActiveReports.SectionReportModel Namespace


ControlCollection Class Members

ControlCollection Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ControlCollection Class

The following tables list the members exposed by ControlCollection.

Public Constructors
 | Name | Description
Public Constructor | ControlCollection Constructor | Initializes a new instance of the ControlCollection class.
Top
Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Returns a control in the collection at the specified index or with a specified name.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds the specified control to the control collection.
Public Method | AddRange | Adds an array of ARControl objects to the collection.
Public Method | Clear | Removes all controls which were added to the collection using the Add method.
Public Method | Contains | Determines whether the specified control is a member of the collection.
Public Method | CopyTo | Copies the controls collection from the specified report to a controls collection at the specified index.
Public Method | Dispose | Releases an instance of the control from the memory.
Public Method | IndexOf | Retrieves the index of the specified control in the control collection.
Public Method | Insert | Inserts the control specified in the value parameter at the specified index.
Public Method | Remove | Removes the specified control from the control collection.
Public Method | RemoveAt | Removes the control from the collection at the specified index.
Top
Public Events
 | Name | Description
Public Event | Changed | Raised when an ARControl is added to or removed from the collection.
Top
See Also

Reference

ControlCollection Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ControlCollection Constructor

ControlCollection Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : ControlCollection Constructor
The report section in which the control collection resides.
Initializes a new instance of the ControlCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal section As Section _
)
public ControlCollection(
   Section section
)

Parameters

section
The report section in which the control collection resides.
See Also

Reference

ControlCollection Class
ControlCollection Members


ControlCollection Class Methods

ControlCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ControlCollection Class

For a list of all members of this type, see ControlCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds the specified control to the control collection.
Public Method | AddRange | Adds an array of ARControl objects to the collection.
Public Method | Clear | Removes all controls which were added to the collection using the Add method.
Public Method | Contains | Determines whether the specified control is a member of the collection.
Public Method | CopyTo | Copies the controls collection from the specified report to a controls collection at the specified index.
Public Method | Dispose | Releases an instance of the control from the memory.
Public Method | IndexOf | Retrieves the index of the specified control in the control collection.
Public Method | Insert | Inserts the control specified in the value parameter at the specified index.
Public Method | Remove | Removes the specified control from the control collection.
Public Method | RemoveAt | Removes the control from the collection at the specified index.
Top
See Also

Reference

ControlCollection Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Add Method (ControlCollection)

Add Method (ControlCollection)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Add Method
The ARControl to add to the collection.
Adds the specified control to the control collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Add( _
   ByVal control As ARControl _
)
public void Add(
   ARControl control
)

Parameters

control
The ARControl to add to the collection.
Remarks
The Add method adds the control to the end of the collection.
Example
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    GrapeCity.ActiveReports.SectionReportModel.TextBox t = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
    t.Text="Insert text here.";
    this.Sections[0].Controls.Add (t);
}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Dim t As New GrapeCity.ActiveReports.SectionReportModel.TextBox
    t.Text = "Insert text here."
    Me.Sections(0).Controls.Add(t)
End Sub
See Also

Reference

ControlCollection Class
ControlCollection Members
ActiveReports6~GrapeCity.ActiveReports.ControlCollection~AddRange


AddRange Method (ControlCollection)

AddRange Method (ControlCollection)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : AddRange Method
An array of ARControl objects to add to the collection.
Adds an array of ARControl objects to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddRange( _
   ByVal controls() As ARControl _
)
public void AddRange(
   ARControl[] controls
)

Parameters

controls
An array of ARControl objects to add to the collection.
Remarks
The ARControl objects in the array are appended to the end of the collection.
Example
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    //create an array of controls
    //array initialization is one-based, while array access is zero-based
    ARControl[] arr = new ARControl[3];
    GrapeCity.ActiveReports.SectionReportModel.CheckBox c = new GrapeCity.ActiveReports.SectionReportModel.CheckBox();
    GrapeCity.ActiveReports.SectionReportModel.Label l = new GrapeCity.ActiveReports.SectionReportModel.Label();
    GrapeCity.ActiveReports.SectionReportModel.TextBox t = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
    //set some properties for the controls
    c.Text = "Checkbox";
    l.Left = 1;
    l.Value = "LabelValue";
    t.Left = 2;
    t.Text = "TextBox";
    //assign the controls to the array
    arr[0] = c;
    arr[1] = l;
    arr[2] = t;
    //add the range of controls to the first section of the report
    this.Sections[0].Controls.AddRange(arr);
}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    'create an array of controls
    Dim arr(2) As ARControl
    Dim c As New GrapeCity.ActiveReports.SectionReportModel.CheckBox
    Dim l As New GrapeCity.ActiveReports.SectionReportModel.Label
    Dim t As New GrapeCity.ActiveReports.SectionReportModel.TextBox
    'set some properties for the controls
    c.Text = "Checkbox"
    l.Left = 1
    l.Text = "Label"
    t.Left = 2
    t.Text = "TextBox"
    'assign the controls to the array
    arr(0) = c
    arr(1) = l
    arr(2) = t
    'add the range of controls to the first section of the report
    Me.Sections(0).Controls.AddRange(arr)
End Sub
See Also

Reference

ControlCollection Class
ControlCollection Members
ActiveReports6~GrapeCity.ActiveReports.ControlCollection~Add


Clear Method (ControlCollection)

Clear Method (ControlCollection)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Clear Method
Removes all controls which were added to the collection using the Add method.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Sub Clear()
public new void Clear()
Remarks
To remove individual controls from the collection, use the Remove method.
Example
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.Sections[0].Controls.Clear();
}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Sections(0).Controls.Clear()
End Sub
See Also

Reference

ControlCollection Class
ControlCollection Members


Contains Method (ControlCollection)

Contains Method (ControlCollection)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Contains Method
The control to locate in the collection.
Determines whether the specified control is a member of the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal control As ARControl _
) As System.Boolean
public System.bool Contains(
   ARControl control
)

Parameters

control
The control to locate in the collection.

Return Value

Boolean. Returns True if the control is a member of the collection; otherwise, False.
Example
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    GrapeCity.ActiveReports.SectionReportModel.TextBox t = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
    t.Text="Insert text here.";
    this.Sections[0].Controls.Add (t);

    if (this.Sections[0].Controls.Contains(t))
    {
        System.Windows.Forms.MessageBox.Show("t");
    }
}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Dim t As New GrapeCity.ActiveReports.SectionReportModel.TextBox
    t.Text = "Insert text here."
    Me.Sections(0).Controls.Add(t)
    If Me.Sections(0).Controls.Contains(t) Then
        MessageBox.Show("t")
    End If
End Sub
See Also

Reference

ControlCollection Class
ControlCollection Members


CopyTo Method (ControlCollection)

CopyTo Method (ControlCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : CopyTo Method
The array containing the copied controls.

The insertion index in the collection.

Copies the controls collection from the specified report to a controls collection at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal values() As ARControl, _
   ByVal index As System.Integer _
)
public void CopyTo(
   ARControl[] values,
   System.int index
)

Parameters

values
The array containing the copied controls.
index

The insertion index in the collection.

See Also

Reference

ControlCollection Class
ControlCollection Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Dispose() Method
Releases an instance of the control from the memory.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

ControlCollection Class
ControlCollection Members


IndexOf Method (ControlCollection)

IndexOf Method (ControlCollection)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : IndexOf Method
The control to locate in the collection.
Retrieves the index of the specified control in the control collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal control As ARControl _
) As System.Integer
public System.int IndexOf(
   ARControl control
)

Parameters

control
The control to locate in the collection.

Return Value

A zero-based value that represents the position of the specified control in the collection.
Example
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    GrapeCity.ActiveReports.SectionReportModel.TextBox t = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
    t.Text="Insert text here.";
    this.Sections[0].Controls.Add (t);
    System.Windows.Forms.MessageBox.Show (this.Sections[0].Controls.IndexOf(t).ToString());
}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Dim t As New GrapeCity.ActiveReports.SectionReportModel.TextBox
    t.Text = "Insert text here."
    Me.Sections(0).Controls.Add(t)
    MessageBox.Show(Me.Sections(0).Controls.IndexOf(t))
End Sub
See Also

Reference

ControlCollection Class
ControlCollection Members


Insert Method (ControlCollection)

Insert Method (ControlCollection)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Insert Method
Index to which the control should be inserted.
Control to be inserted.
Inserts the control specified in the value parameter at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal control As ARControl _
)
public void Insert(
   System.int index,
   ARControl control
)

Parameters

index
Index to which the control should be inserted.
control
Control to be inserted.
Example
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    GrapeCity.ActiveReports.SectionReportModel.TextBox t = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
    GrapeCity.ActiveReports.SectionReportModel.TextBox t2 = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
    t.Text="Insert text here.";
    t2.Text="Insert some more text here.";
    t2.Left=1;
    this.Sections[0].Controls.Add (t);
    this.Sections[0].Controls.Insert(1,t2);
}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Dim t As New GrapeCity.ActiveReports.SectionReportModel.TextBox
    Dim t2 As New GrapeCity.ActiveReports.SectionReportModel.TextBox
    t.Text = "Insert text here."
    t2.Text = "Insert some more text here."
    t2.Left = 1
    Me.Sections(0).Controls.Add(t)
    Me.Sections(0).Controls.Insert(0, t2)
End Sub
See Also

Reference

ControlCollection Class
ControlCollection Members


Remove Method (ControlCollection)

Remove Method (ControlCollection)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Remove Method
The control to be removed from the collection.
Removes the specified control from the control collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal control As ARControl _
)
public void Remove(
   ARControl control
)

Parameters

control
The control to be removed from the collection.
Example
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    //create an array of controls
    ARControl[] arr = new ARControl[3];
    GrapeCity.ActiveReports.SectionReportModel.CheckBox c = new GrapeCity.ActiveReports.SectionReportModel.CheckBox();
    GrapeCity.ActiveReports.SectionReportModel.Label l = new GrapeCity.ActiveReports.SectionReportModel.Label();
    GrapeCity.ActiveReports.SectionReportModel.TextBox t = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
    //set some properties for the controls
    c.Text = "Checkbox";
    l.Left = 1;
    l.Value = "LabelValue";
    t.Left = 2;
    t.Text = "TextBox";
    //assign the controls to the array
    arr[0] = c;
    arr[1] = l;
    arr[2] = t;
    //add the range of controls to the first section of the report
    this.Sections[0].Controls.AddRange(arr);
    //remove the checkbox
    this.Sections[0].Controls.Remove(arr[0]);
}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    'create an array of controls
    Dim arr(2) As ARControl
    Dim c As New GrapeCity.ActiveReports.SectionReportModel.CheckBox
    Dim l As New GrapeCity.ActiveReports.SectionReportModel.Label
    Dim t As New GrapeCity.ActiveReports.SectionReportModel.TextBox
    'set some properties for the controls
    c.Text = "Checkbox"
    l.Left = 1
    l.Text = "Label"
    t.Left = 2
    t.Text = "TextBox"
    'assign the controls to the array
    arr(0) = c
    arr(1) = l
    arr(2) = t
    'add the range of controls to the first section of the report
    Me.Sections(0).Controls.AddRange(arr)
    'remove the specified control
    Me.Sections(0).Controls.Remove(c)
End Sub
See Also

Reference

ControlCollection Class
ControlCollection Members


RemoveAt Method (ControlCollection)

RemoveAt Method (ControlCollection)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : RemoveAt Method
The index of the control to be removed.
Removes the control from the collection at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Sub RemoveAt( _
   ByVal index As System.Integer _
)
public new void RemoveAt(
   System.int index
)

Parameters

index
The index of the control to be removed.
Example
  • C#
private void arReport_ReportStart(object sender, System.EventArgs eArgs)
{
    //create an array of controls
    ARControl[] arr = new ARControl[3];
    GrapeCity.ActiveReports.SectionReportModel.CheckBox c = new GrapeCity.ActiveReports.SectionReportModel.CheckBox();
    GrapeCity.ActiveReports.SectionReportModel.Label l = new GrapeCity.ActiveReports.SectionReportModel.Label();
    GrapeCity.ActiveReports.SectionReportModel.TextBox t = new GrapeCity.ActiveReports.SectionReportModel.TextBox();
    //set some properties for the controls
    c.Text = "Checkbox";
    l.Left = 1;
    l.Value = "LabelValue";
    t.Left = 2;
    t.Text = "TextBox";
    //assign the controls to the array
    arr[0] = c;
    arr[1] = l;
    arr[2] = t;
    //add the range of controls to the first section of the report
    this.Sections[0].Controls.AddRange(arr);
    //remove a control from a specified location
    this.Sections[0].Controls.RemoveAt(1);
}
  • Visual Basic
Private Sub rptReport_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    'create an array of controls
    Dim arr(2) As ARControl
    Dim c As New GrapeCity.ActiveReports.SectionReportModel.CheckBox
    Dim l As New GrapeCity.ActiveReports.SectionReportModel.Label
    Dim t As New GrapeCity.ActiveReports.SectionReportModel.TextBox
    'set some properties for the controls
    c.Text = "Checkbox"
    l.Left = 1
    l.Text = "Label"
    t.Left = 2
    t.Text = "TextBox"
    'assign the controls to the array
    arr(0) = c
    arr(1) = l
    arr(2) = t
    'add the range of controls to the first section of the report
    Me.Sections(0).Controls.AddRange(arr)
    'remove a control from the specified location
    Me.Sections(0).Controls.RemoveAt(1)
End Sub
See Also

Reference

ControlCollection Class
ControlCollection Members


ControlCollection Class Properties

ControlCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ControlCollection Class

For a list of all members of this type, see ControlCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Returns a control in the collection at the specified index or with a specified name.
Top
See Also

Reference

ControlCollection Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Item Property (ControlCollection)

Item Property (ControlCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Item Property
Returns a control in the collection at the specified index or with a specified name.
Overload List
Overload | Description
Item(Int32) | Gets the Control object at the specified indexed location in the ControlCollection.
Item(String) | Gets the Control object with the specified name in the ControlCollection.
See Also

Reference

ControlCollection Class
ControlCollection Members


Item(Int32) Property

Item(Int32) Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class > Item Property : Item(Int32) Property
The indexed location of the Control in the collection.
Gets the Control object at the specified indexed location in the ControlCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal index As System.Integer _
) As ARControl
public ARControl Item(
   System.int index
) {get;}

Parameters

index
The indexed location of the Control in the collection.
See Also

Reference

ControlCollection Class
ControlCollection Members
Overload List


Item(String) Property

Item(String) Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class > Item Property : Item(String) Property
The name of the Control in the collection.
Gets the Control object with the specified name in the ControlCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal name As System.String _
) As ARControl
public ARControl Item(
   System.string name
) {get;}

Parameters

name
The name of the Control in the collection.
See Also

Reference

ControlCollection Class
ControlCollection Members
Overload List


ControlCollection Class Events

ControlCollection Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ControlCollection Class

For a list of all members of this type, see ControlCollection members.

Public Events
 | Name | Description
Public Event | Changed | Raised when an ARControl is added to or removed from the collection.
Top
See Also

Reference

ControlCollection Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Changed Event (ControlCollection)

Changed Event (ControlCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Changed Event
Raised when an ARControl is added to or removed from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Changed As System.EventHandler
public event System.EventHandler Changed
See Also

Reference

ControlCollection Class
ControlCollection Members


CrossSectionBox Class

CrossSectionBox Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionBox Class

The CrossSectionBox control renders a rectangular outline with its corners where you place them in the header and footer sections, and its vertical lines growing with intervening sections.

Object Model
CrossSectionBox Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class CrossSectionBox
   Inherits CrossSectionControl
public sealed class CrossSectionBox : CrossSectionControl
Remarks

The background color of the CrossSectionBox control is rendered on the report page before any other sections and controls. This means that the background color is visible on transparent sections only.

Unlike the background color, the border of the CrossSectionBox control is rendered after all other controls on the page.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl
GrapeCity.ActiveReports.SectionReportModel.CrossSectionBox

See Also

Reference

CrossSectionBox Members
GrapeCity.ActiveReports.SectionReportModel Namespace


CrossSectionBox Class Members

CrossSectionBox Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionBox Class

The following tables list the members exposed by CrossSectionBox.

Public Constructors
 | Name | Description
Public Constructor | CrossSectionBox Constructor | Initializes a new instance of the CrossSectionBox class.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the control's background color or fill color.
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | End | The ending position of the cross section control in the footer section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | LineColor | Gets or sets the color of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | LineStyle | Gets or sets the pen style used to draw the line. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | LineWeight | Gets or sets the pen width of the line in pixels. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Radius | Set the Radius property to control the degree of rounding on the corners of the box.
Public Property | Start | Gets or sets the starting position of the cross section control in the header section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Top
Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | GetDoubleRadius | Gets the run-time value of the radius property.
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

CrossSectionBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CrossSectionBox Constructor

CrossSectionBox Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionBox Class : CrossSectionBox Constructor
Initializes a new instance of the CrossSectionBox class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public CrossSectionBox()
See Also

Reference

CrossSectionBox Class
CrossSectionBox Members


CrossSectionBox Class Methods

CrossSectionBox Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionBox Class

For a list of all members of this type, see CrossSectionBox members.

Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | GetDoubleRadius | Gets the run-time value of the radius property.
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

CrossSectionBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


GetDoubleRadius Method

GetDoubleRadius Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionBox Class : GetDoubleRadius Method
Gets the run-time value of the radius property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetDoubleRadius() As System.Single
public System.float GetDoubleRadius()

Return Value

A Single or float value in pixels.
See Also

Reference

CrossSectionBox Class
CrossSectionBox Members


CrossSectionBox Class Properties

CrossSectionBox Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionBox Class

For a list of all members of this type, see CrossSectionBox members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the control's background color or fill color.
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | End | The ending position of the cross section control in the footer section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | LineColor | Gets or sets the color of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | LineStyle | Gets or sets the pen style used to draw the line. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | LineWeight | Gets or sets the pen width of the line in pixels. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Radius | Set the Radius property to control the degree of rounding on the corners of the box.
Public Property | Start | Gets or sets the starting position of the cross section control in the header section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Top
See Also

Reference

CrossSectionBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


BackColor Property (CrossSectionBox)

BackColor Property (CrossSectionBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionBox Class : BackColor Property
Gets or sets the control's background color or fill color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackColor As Color
public Color BackColor {get; set;}
Remarks

The background color of the CrossSectionBox control is rendered on the report page before any other sections and controls. This means that the background color is visible on transparent sections only.

Unlike the background color, the border of the CrossSectionBox control is rendered after all other controls on the page.

See Also

Reference

CrossSectionBox Class
CrossSectionBox Members


Radius Property

Radius Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionBox Class : Radius Property
Set the Radius property to control the degree of rounding on the corners of the box.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Radius As CornersRadius
public CornersRadius Radius {get; set;}

Property Value

An integer value in points.
Requirements

See Also

Reference

CrossSectionBox Class
CrossSectionBox Members


CrossSectionControl Class

CrossSectionControl Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionControl Class
ARControl is the base class for ActiveReports CrossSection controls. You should not need to use this class in your application.
Object Model
CrossSectionControl Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class CrossSectionControl
   Inherits ARControl
public abstract class CrossSectionControl : ARControl
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl
GrapeCity.ActiveReports.SectionReportModel.CrossSectionBox
GrapeCity.ActiveReports.SectionReportModel.CrossSectionLine

See Also

Reference

CrossSectionControl Members
GrapeCity.ActiveReports.SectionReportModel Namespace


CrossSectionControl Class Members

CrossSectionControl Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionControl Class

The following tables list the members exposed by CrossSectionControl.

Public Properties
 | Name | Description
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | End | The ending position of the cross section control in the footer section.
Public Property | Height | Gets or sets the height of the control in inches. This value changes as the detail section and any other intervening sections grow at run time. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches.
Public Property | LineColor | Gets or sets the color of the control.
Public Property | LineStyle | Gets or sets the pen style used to draw the line.
Public Property | LineWeight | Gets or sets the pen width of the line in pixels.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Start | Gets or sets the starting position of the cross section control in the header section.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches.
Top
Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

CrossSectionControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CrossSectionControl Class Properties

CrossSectionControl Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionControl Class

For a list of all members of this type, see CrossSectionControl members.

Public Properties
 | Name | Description
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | End | The ending position of the cross section control in the footer section.
Public Property | Height | Gets or sets the height of the control in inches. This value changes as the detail section and any other intervening sections grow at run time. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches.
Public Property | LineColor | Gets or sets the color of the control.
Public Property | LineStyle | Gets or sets the pen style used to draw the line.
Public Property | LineWeight | Gets or sets the pen width of the line in pixels.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Start | Gets or sets the starting position of the cross section control in the header section.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches.
Top
See Also

Reference

CrossSectionControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


End Property (CrossSectionControl)

End Property (CrossSectionControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionControl Class : End Property
The ending position of the cross section control in the footer section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property End As PointF
public PointF End {get; set;}
See Also

Reference

CrossSectionControl Class
CrossSectionControl Members


Left Property (CrossSectionControl)

Left Property (CrossSectionControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionControl Class : Left Property

Gets or sets the left position of the control in inches.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Property Left As System.Single
public new System.float Left {get; set;}
See Also

Reference

CrossSectionControl Class
CrossSectionControl Members


LineColor Property (CrossSectionControl)

LineColor Property (CrossSectionControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionControl Class : LineColor Property
Gets or sets the color of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineColor As Color
public Color LineColor {get; set;}

Property Value

A System.Drawing.Color value that represents the current color of the line. The default value is Color.Black.
See Also

Reference

CrossSectionControl Class
CrossSectionControl Members


LineStyle Property (CrossSectionControl)

LineStyle Property (CrossSectionControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionControl Class : LineStyle Property
Gets or sets the pen style used to draw the line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineStyle As LineStyle
public LineStyle LineStyle {get; set;}

Property Value

LineStyle enumeration. The default value is LineStyle.Solid. Possible values are:

  • LineStyle.Dash
  • LineStyle.DashDot
  • LineStyle.DashDotDot
  • LineStyle.Dot
  • LineStyle.Solid
  • LineStyle.Transparent
See Also

Reference

CrossSectionControl Class
CrossSectionControl Members


LineWeight Property (CrossSectionControl)

LineWeight Property (CrossSectionControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionControl Class : LineWeight Property
Gets or sets the pen width of the line in pixels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineWeight As System.Single
public System.float LineWeight {get; set;}

Property Value

Float value that represents the current weight of the line in pixels. Default is 1.0f.
See Also

Reference

CrossSectionControl Class
CrossSectionControl Members


Start Property (CrossSectionControl)

Start Property (CrossSectionControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionControl Class : Start Property
Gets or sets the starting position of the cross section control in the header section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Start As PointF
public PointF Start {get; set;}
See Also

Reference

CrossSectionControl Class
CrossSectionControl Members


Top Property (CrossSectionControl)

Top Property (CrossSectionControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionControl Class : Top Property
Gets or sets, in inches, the top position of the control relative to the section that contains it.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Property Top As System.Single
public new System.float Top {get; set;}
See Also

Reference

CrossSectionControl Class
CrossSectionControl Members


Width Property (CrossSectionControl)

Width Property (CrossSectionControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionControl Class : Width Property
Gets or sets the width of the control in inches.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Property Width As System.Single
public new System.float Width {get; set;}

Property Value

A float or Single value in inches.
See Also

Reference

CrossSectionControl Class
CrossSectionControl Members


CrossSectionLine Class

CrossSectionLine Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionLine Class
The CrossSectionLine control renders a vertical line that begins where you place it in a header section, grows with any intervening sections, and ends where you place it in the related footer section.
Object Model
CrossSectionLine Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class CrossSectionLine
   Inherits CrossSectionControl
public sealed class CrossSectionLine : CrossSectionControl
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl
GrapeCity.ActiveReports.SectionReportModel.CrossSectionLine

See Also

Reference

CrossSectionLine Members
GrapeCity.ActiveReports.SectionReportModel Namespace


CrossSectionLine Class Members

CrossSectionLine Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionLine Class

The following tables list the members exposed by CrossSectionLine.

Public Constructors
 | Name | Description
Public Constructor | CrossSectionLine Constructor | Initializes a new instance of the CrossSectionLine class.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | End | The ending position of the cross section control in the footer section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | LineColor | Gets or sets the color of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | LineStyle | Gets or sets the pen style used to draw the line. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | LineWeight | Gets or sets the pen width of the line in pixels. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Start | The starting position of the cross section control in the header section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Top
Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

CrossSectionLine Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CrossSectionLine Constructor

CrossSectionLine Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CrossSectionLine Class : CrossSectionLine Constructor
Initializes a new instance of the CrossSectionLine class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public CrossSectionLine()
See Also

Reference

CrossSectionLine Class
CrossSectionLine Members


CustomControl Class

CustomControl Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CustomControl Class
CustomControl is a wrapper class that allows you to print .NET controls that inherit from System.Windows.Forms.Control
Object Model
CustomControl Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class CustomControl
   Inherits ARControl
public sealed class CustomControl : ARControl
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.CustomControl

See Also

Reference

CustomControl Members
GrapeCity.ActiveReports.SectionReportModel Namespace


CustomControl Class Members

CustomControl Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CustomControl Class

The following tables list the members exposed by CustomControl.

Public Constructors
 | Name | Description
Public Constructor | CustomControl Constructor | Overloaded. Initializes a new instance of the CustomControl class.
Top
Public Properties
 | Name | Description
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Control | Gets or sets a reference to the hosted control.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | ImageType | Sets or returns the type of image to which the chart will be rendered on the report.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Type | Sets or returns the type of the custom control.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose() | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

CustomControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CustomControl Constructor

CustomControl Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CustomControl Class : CustomControl Constructor
Initializes a new instance of the CustomControl class.
Overload List
Overload | Description
CustomControl Constructor(Type) | Initializes a new instance of the specified type of CustomControl class.
CustomControl Constructor() | Initializes a new instance of the CustomControl class.
See Also

Reference

CustomControl Class
CustomControl Members


CustomControl Constructor(Type)

CustomControl Constructor(Type)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CustomControl Class > CustomControl Constructor : CustomControl Constructor(Type)
Specifies the type of the control to be created.
Initializes a new instance of the specified type of CustomControl class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal type As System.Type _
)
public CustomControl(
   System.Type type
)

Parameters

type
Specifies the type of the control to be created.
See Also

Reference

CustomControl Class
CustomControl Members
Overload List


CustomControl Constructor()

CustomControl Constructor()

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CustomControl Class > CustomControl Constructor : CustomControl Constructor()
Initializes a new instance of the CustomControl class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public CustomControl()
See Also

Reference

CustomControl Class
CustomControl Members
Overload List


CustomControl Class Properties

CustomControl Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CustomControl Class

For a list of all members of this type, see CustomControl members.

Public Properties
 | Name | Description
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Control | Gets or sets a reference to the hosted control.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | ImageType | Sets or returns the type of image to which the chart will be rendered on the report.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Type | Sets or returns the type of the custom control.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

CustomControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Control Property (CustomControl)

Control Property (CustomControl)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CustomControl Class : Control Property
Gets or sets a reference to the hosted control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Control As System.Windows.Forms.Control
public System.Windows.Forms.Control Control {get;}
Example
  • C#
private void Detail1_Format(object sender,System.EventArgs e)
{
 DataTable dt = new DataTable();
 dt.Columns.Add("Name", typeof(string));
 dt.Columns.Add("Age", typeof(int));
 dt.Rows.Add("Name1", 23);
 dt.Rows.Add("Name2", 34);
 System.Windows.Forms.DataGridView gridView = ((System.Windows.Forms.DataGridView)this.customControl1.Control);
 gridView.DataSource = dt;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
Dim dt As New DataTable()
dt.Columns.Add("Name", GetType(String))
dt.Columns.Add("Age", GetType(Integer))
dt.Rows.Add("Name1", 23)
dt.Rows.Add("Name2", 34)
Dim gridView As System.Windows.Forms.DataGridView = DirectCast(Me.customControl1.Control, System.Windows.Forms.DataGridView)
gridView.DataSource = dt
End Sub
See Also

Reference

CustomControl Class
CustomControl Members

How To

Use Custom Controls on Reports (TreeView)


ImageType Property (CustomControl)

ImageType Property (CustomControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CustomControl Class : ImageType Property
Sets or returns the type of image to which the chart will be rendered on the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ImageType As ImageTypes
public ImageTypes ImageType {get; set;}

Property Value

An ImageTypes enumeration. The default value is Metafile. The alternate value is PNG.
Remarks
Some images can be a problem when exported as a metafile due to some graphic commands that are not supported. If you are noticing problems with images not exporting to PDF, set the ImageType to PNG.
See Also

Reference

CustomControl Class
CustomControl Members
ActiveReports6~GrapeCity.ActiveReports.ImageTypes


Type Property (CustomControl)

Type Property (CustomControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CustomControl Class : Type Property
Sets or returns the type of the custom control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Type As System.Type
public System.Type Type {get; set;}
See Also

Reference

CustomControl Class
CustomControl Members


Detail Class

Detail Class
Members Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Detail Class
Detail section is the main section in a report. It is printed once for each record in the data source.
Object Model
Detail Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Detail
   Inherits Section
public class Detail : Section
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.ColumnCount = 1;
    this.detail.ColumnDirection = ColumnDirection.DownAcross;
    this.detail.ColumnSpacing = 1;
    this.detail.KeepTogether = true;
    this.detail.NewColumn = NewColumn.After;
    this.detail.NewPage = NewPage.Before;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Detail1.ColumnCount = 1
   Me.Detail1.ColumnDirection = ColumnDirection.DownAcross
   Me.Detail1.ColumnSpacing = 1
   Me.Detail1.KeepTogether = True
   Me.Detail1.NewColumn = NewColumn.After
   Me.Detail1.NewPage = NewPage.Before
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.Detail

See Also

Reference

Detail Members
GrapeCity.ActiveReports.SectionReportModel Namespace


Detail Class Members

Detail Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Detail Class

The following tables list the members exposed by Detail.

Public Constructors
 | Name | Description
Public Constructor | Detail Constructor | Initializes a new instance of the Detail class.
Top
Public Properties
Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property CanGrow

Indicates whether the section height should grow when its controls extend beyond its original height.

(Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property CanShrink

Indicates whether the section height should be adjusted to the exact total height of its controls.

(Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | ColumnCount | Gets or sets a value that specifies the number of newspaper columns in the report.
Public Property | ColumnDirection | Determines how ActiveReports should print the detail section in a multi-column report.
Public Property | ColumnSpacing | Sets or returns the space between columns in a multi-column report.
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Height | Gets or sets the height of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | KeepTogether | Gets or sets a value that determines whether the section should be printed on a single page.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | NewColumn | Gets or sets a value that determines whether a new column should be started before and/or after printing the section.
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property RepeatToFill

Gets or sets a value that determines whether the section's formatting should print to fill the page when there is not enough data to fill it.

The RepeatToFill property allows you to fill each page with the same number of formatted rows, regardless of whether there is enough data to fill them. This is especially useful for reports such as invoices in which you want consistent formatting like lines or green bars or back colors to fill each page down to the Footer section at the bottom.

Note: You cannot use the RepeatToFill property if you are using the PageBreak or SubReport control in the Detail section, or if you have set the NewPage or NewColumn property to any value other than None. When you use this property in a report where two groups are present, the ReportFooter section prints on the next page. This property processes correctly only with single grouping.

Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property Visible

Specifies whether the section should be printed or not.

(Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
Public Methods
 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | Dispose | Releases the section instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
Public Events
 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

Detail Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Detail Constructor

Detail Constructor
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Detail Class : Detail Constructor
Initializes a new instance of the Detail class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Detail()
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.ColumnCount = 1;
    this.detail.ColumnDirection = ColumnDirection.DownAcross;
    this.detail.ColumnSpacing = 1;
    this.detail.KeepTogether = true;
    this.detail.NewColumn = NewColumn.None;
    this.detail.NewPage = NewPage.None;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.ColumnCount = 1
    Me.Detail1.ColumnDirection = ColumnDirection.DownAcross
    Me.Detail1.ColumnSpacing = 1
    Me.Detail1.KeepTogether = True
    Me.Detail1.NewColumn = NewColumn.None
    Me.Detail1.NewPage = NewPage.None
End Sub
See Also

Reference

Detail Class
Detail Members


Detail Class Properties

Detail Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Detail Class

For a list of all members of this type, see Detail members.

Public Properties
Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property CanGrow

Indicates whether the section height should grow when its controls extend beyond its original height.

(Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property CanShrink

Indicates whether the section height should be adjusted to the exact total height of its controls.

(Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | ColumnCount | Gets or sets a value that specifies the number of newspaper columns in the report.
Public Property | ColumnDirection | Determines how ActiveReports should print the detail section in a multi-column report.
Public Property | ColumnSpacing | Sets or returns the space between columns in a multi-column report.
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Height | Gets or sets the height of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | KeepTogether | Gets or sets a value that determines whether the section should be printed on a single page.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | NewColumn | Gets or sets a value that determines whether a new column should be started before and/or after printing the section.
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property RepeatToFill

Gets or sets a value that determines whether the section's formatting should print to fill the page when there is not enough data to fill it.

The RepeatToFill property allows you to fill each page with the same number of formatted rows, regardless of whether there is enough data to fill them. This is especially useful for reports such as invoices in which you want consistent formatting like lines or green bars or back colors to fill each page down to the Footer section at the bottom.

Note: You cannot use the RepeatToFill property if you are using the PageBreak or SubReport control in the Detail section, or if you have set the NewPage or NewColumn property to any value other than None. When you use this property in a report where two groups are present, the ReportFooter section prints on the next page. This property processes correctly only with single grouping.

Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property Visible

Specifies whether the section should be printed or not.

(Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

Detail Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ColumnCount Property (Detail)

ColumnCount Property (Detail)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Detail Class : ColumnCount Property
Gets or sets a value that specifies the number of newspaper columns in the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ColumnCount As System.Integer
public System.int ColumnCount {get; set;}

Property Value

Integer value that represents the current number of columns in the report; default is 1.

Remarks
This property can be used to print labels or phonebook-style listings. The width of each column equals the PrintWidth of the report divided by the number of columns.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.ColumnCount = 1;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Detail.ColumnCount = 1
End Sub
See Also

Reference

Detail Class
Detail Members
ActiveReports6~GrapeCity.ActiveReports.GroupHeader~ColumnLayout
ActiveReports6~GrapeCity.ActiveReports.Detail~ColumnDirection
ActiveReports6~GrapeCity.ActiveReports.Detail~ColumnSpacing


ColumnDirection Property

ColumnDirection Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Detail Class : ColumnDirection Property
Determines how ActiveReports should print the detail section in a multi-column report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ColumnDirection As ColumnDirection
public ColumnDirection ColumnDirection {get; set;}

Property Value

ColumnDirection enumeration value that specifies whether the report will be printed across or down; default is ColumnDirection.DownAcross.

Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.ColumnCount = 3;
    this.detail.ColumnDirection = ColumnDirection.AcrossDown;
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.Detail1.ColumnCount = 3
   Me.Detail1.ColumnDirection = ColumnDirection.AcrossDown
End Sub
See Also

Reference

Detail Class
Detail Members
ActiveReports6~GrapeCity.ActiveReports.Detail~ColumnCount
ActiveReports6~GrapeCity.ActiveReports.Detail~ColumnSpacing
ActiveReports6~GrapeCity.ActiveReports.GroupHeader~ColumnLayout


ColumnSpacing Property (Detail)

ColumnSpacing Property (Detail)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Detail Class : ColumnSpacing Property
Sets or returns the space between columns in a multi-column report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ColumnSpacing As System.Single
public System.float ColumnSpacing {get; set;}

Property Value

A single value that represents the space between columns.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.ColumnCount = 3;
    this.detail.ColumnSpacing = 1;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Detail1.ColumnCount = 3
   Me.Detail1.ColumnSpacing = 1
End Sub
See Also

Reference

Detail Class
Detail Members


KeepTogether Property (Detail)

KeepTogether Property (Detail)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Detail Class : KeepTogether Property
Gets or sets a value that determines whether the section should be printed on a single page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property KeepTogether As System.Boolean
public System.bool KeepTogether {get; set;}

Property Value

A Boolean value. True if the section will print on a single page if its contents permit; otherwise, False.
Remarks

When this property is set to True, ActiveReports will attempt to print the section on the current page. If the contents do not fit on the current page and the current page is not a new page, the section will be moved to the next page. If the section does not fit on the following page, it will be moved back to the original position and the contents will be split across multiple pages.

Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.KeepTogether = true;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Detail1.KeepTogether = True
End Sub
See Also

Reference

Detail Class
Detail Members


NewColumn Property (Detail)

NewColumn Property (Detail)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Detail Class : NewColumn Property
Gets or sets a value that determines whether a new column should be started before and/or after printing the section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NewColumn As NewColumn
public NewColumn NewColumn {get; set;}

Property Value

NewColumn Enumeration. Possible values are:

  • NewColumn.After
  • NewColumn.Before
  • NewColumn.BeforeAfter
  • NewColumn.None
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.NewColumn = NewColumn.BeforeAfter;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Detail1.NewColumn = NewColumn.BeforeAfter
End Sub
See Also

Reference

Detail Class
Detail Members


NewPage Property (Detail)

NewPage Property (Detail)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Detail Class : NewPage Property
Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NewPage As NewPage
public NewPage NewPage {get; set;}

Property Value

NewPage Enumeration. Possible values are:

  • NewPage.After
  • NewPage.Before
  • NewPage.BeforeAfter
  • NewPage.None
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.NewPage = NewPage.BeforeAfter;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Detail1.NewPage = NewPage.BeforeAfter
End Sub
See Also

Reference

Detail Class
Detail Members


RepeatToFill Property (Detail)

RepeatToFill Property (Detail)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Detail Class : RepeatToFill Property

Gets or sets a value that determines whether the section's formatting should print to fill the page when there is not enough data to fill it.

The RepeatToFill property allows you to fill each page with the same number of formatted rows, regardless of whether there is enough data to fill them. This is especially useful for reports such as invoices in which you want consistent formatting like lines or green bars or back colors to fill each page down to the Footer section at the bottom.

Note: You cannot use the RepeatToFill property if you are using the PageBreak or SubReport control in the Detail section, or if you have set the NewPage or NewColumn property to any value other than None. When you use this property in a report where two groups are present, the ReportFooter section prints on the next page. This property processes correctly only with single grouping.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RepeatToFill As System.Boolean
public System.bool RepeatToFill {get; set;}

Property Value

A Boolean value. True if the section will print formatting to fill the page if its contents permit; otherwise, False.
Remarks

Note: The RepeatToFill property cannot be used if the PageBreak or SubReport control is used in the Detail section, or if the NewPage or NewColumn property is set to any value other than None.

When you use this property when two groups are present, the second GroupFooter section is always on the next page. It processes correctly only with a single grouping. The ReportFooter section also prints on the next page when you set this property to True.

See Also

Reference

Detail Class
Detail Members


GroupFooter Class

GroupFooter Class
Members Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupFooter Class
The GroupFooter section is directly related to the Detail section and its matching group header. It prints once each time a group of similar records (as defined in the GroupHeader.DataField property) ends. A GroupFooter section cannot exist without a matching GroupHeader section.
Object Model
GroupFooter Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class GroupFooter
   Inherits Section
public class GroupFooter : Section
Example
  • C#
private void groupFooter1_Format(object sender, System.EventArgs eArgs)
{
    this.groupFooter1.ColumnLayout = true;
    this.groupFooter1.KeepTogether = true;
    this.groupFooter1.NewColumn = NewColumn.None;
    this.groupFooter1.NewPage = NewPage.None;
    this.groupFooter1.PrintAtBottom = true;
}
  • Visual Basic
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
   Me.GroupFooter1.ColumnLayout = True
   Me.GroupFooter1.KeepTogether = True
   Me.GroupFooter1.NewColumn = NewColumn.None
   Me.GroupFooter1.NewPage = NewPage.None
   Me.GroupFooter1.PrintAtBottom = True
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.GroupFooter

See Also

Reference

GroupFooter Members
GrapeCity.ActiveReports.SectionReportModel Namespace


GroupFooter Class Members

GroupFooter Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupFooter Class

The following tables list the members exposed by GroupFooter.

Public Constructors
 | Name | Description
Public Constructor | GroupFooter Constructor | Initializes a new instance of the GroupFooter class.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | ColumnLayout | Gets or sets a value to determine whether the section should use the same column layout of its detail section.
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Height | Gets or sets the height of the group footer.
Public Property | KeepTogether | Gets or sets a value that determines whether the section should be printed on a single page.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | NewColumn | Gets or sets a value that determines whether a new column should be started before and/or after printing the section.
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property | PrintAtBottom | Gets or sets a value that specifies whether the section should be printed at the bottom of the page immediately before any page footer section.
Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Visible | Specifies whether the section should be printed or not. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
Public Methods
 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | Dispose | Releases the section instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
Public Events
 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

GroupFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


GroupFooter Constructor

GroupFooter Constructor
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupFooter Class : GroupFooter Constructor
Initializes a new instance of the GroupFooter class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public GroupFooter()
Example
  • C#
private void groupFooter1_Format(object sender, System.EventArgs eArgs)
{
    this.groupFooter1.ColumnLayout = true;
    this.groupFooter1.KeepTogether = true;
    this.groupFooter1.NewColumn = NewColumn.None;
    this.groupFooter1.NewPage = NewPage.None;
    this.groupFooter1.PrintAtBottom = true;
}
  • Visual Basic
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
    Me.GroupFooter1.ColumnLayout = True
    Me.GroupFooter1.KeepTogether = True
    Me.GroupFooter1.NewColumn = NewColumn.None
    Me.GroupFooter1.NewPage = NewPage.None
    Me.GroupFooter1.PrintAtBottom = True
End Sub
See Also

Reference

GroupFooter Class
GroupFooter Members


GroupFooter Class Properties

GroupFooter Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupFooter Class

For a list of all members of this type, see GroupFooter members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | ColumnLayout | Gets or sets a value to determine whether the section should use the same column layout of its detail section.
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Height | Gets or sets the height of the group footer.
Public Property | KeepTogether | Gets or sets a value that determines whether the section should be printed on a single page.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | NewColumn | Gets or sets a value that determines whether a new column should be started before and/or after printing the section.
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property | PrintAtBottom | Gets or sets a value that specifies whether the section should be printed at the bottom of the page immediately before any page footer section.
Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Visible | Specifies whether the section should be printed or not. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

GroupFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ColumnLayout Property (GroupFooter)

ColumnLayout Property (GroupFooter)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupFooter Class : ColumnLayout Property
Gets or sets a value to determine whether the section should use the same column layout of its detail section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ColumnLayout As System.Boolean
public System.bool ColumnLayout {get; set;}

Property Value

A Boolean value. True if the section will have the same number of columns as its detail section. False if the section will have a single column.
Example
  • C#
private void groupFooter1_Format(object sender, System.EventArgs eArgs)
{
    this.groupFooter1.ColumnLayout = true;
}
  • Visual Basic
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
   Me.GroupFooter1.ColumnLayout = True
End Sub
See Also

Reference

GroupFooter Class
GroupFooter Members
ActiveReports6~GrapeCity.ActiveReports.Detail~ColumnCount


Height Property (GroupFooter)

Height Property (GroupFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupFooter Class : Height Property
Gets or sets the height of the group footer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Property Height As System.Single
public new System.float Height {get; set;}
See Also

Reference

GroupFooter Class
GroupFooter Members


KeepTogether Property (GroupFooter)

KeepTogether Property (GroupFooter)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupFooter Class : KeepTogether Property
Gets or sets a value that determines whether the section should be printed on a single page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property KeepTogether As System.Boolean
public System.bool KeepTogether {get; set;}

Property Value

A Boolean value. True if the section will print on a single page if its contents permit; otherwise, False.
Remarks

When this property is set to True, ActiveReports will attempt to print the section on the current page. If the contents do not fit on the current page and the current page is not a new page, the section will be moved to the next page. If the section does not fit on the following page, it will be moved back to the original position and the contents will be split across multiple pages.

Example
  • C#
private void groupFooter1_Format(object sender, System.EventArgs eArgs)
{
    this.groupFooter1.KeepTogether = true;
}
  • Visual Basic
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
   Me.GroupFooter1.KeepTogether = True
End Sub
See Also

Reference

GroupFooter Class
GroupFooter Members


NewColumn Property (GroupFooter)

NewColumn Property (GroupFooter)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupFooter Class : NewColumn Property
Gets or sets a value that determines whether a new column should be started before and/or after printing the section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NewColumn As NewColumn
public NewColumn NewColumn {get; set;}

Property Value

NewColumn Enumeration. Possible values are:

  • NewColumn.After
  • NewColumn.Before
  • NewColumn.BeforeAfter
  • NewColumn.None
Example
  • C#
private void groupFooter1_Format(object sender, System.EventArgs eArgs)
{
    this.groupFooter1.ColumnLayout = true;
    this.groupFooter1.NewColumn = NewColumn.After;
}
  • Visual Basic
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
   Me.GroupFooter1.ColumnLayout = True
   Me.GroupFooter1.NewColumn = NewColumn.After
End Sub
See Also

Reference

GroupFooter Class
GroupFooter Members


NewPage Property (GroupFooter)

NewPage Property (GroupFooter)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupFooter Class : NewPage Property
Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NewPage As NewPage
public NewPage NewPage {get; set;}

Property Value

NewPage Enumeration. Possible values are:

  • NewPage.After
  • NewPage.Before
  • NewPage.BeforeAfter
  • NewPage.None
Example
  • C#
private void groupFooter1_Format(object sender, System.EventArgs eArgs)
{
    this.groupFooter1.NewPage = NewPage.Before;
}
  • Visual Basic
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
   Me.GroupFooter1.NewPage = NewPage.Before
End Sub
See Also

Reference

GroupFooter Class
GroupFooter Members


PrintAtBottom Property (GroupFooter)

PrintAtBottom Property (GroupFooter)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupFooter Class : PrintAtBottom Property
Gets or sets a value that specifies whether the section should be printed at the bottom of the page immediately before any page footer section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrintAtBottom As System.Boolean
public System.bool PrintAtBottom {get; set;}

Property Value

A Boolean value. True if the footer section will be printed at the bottom of the page; otherwise, False.
Remarks
Setting more than one group footer section in a report layout to print at the bottom of the page will cause subsequent group footer sections to print on separate pages.
Example
  • C#
private void groupFooter1_Format(object sender, System.EventArgs eArgs)
{
    this.groupFooter1.PrintAtBottom = true;
}
  • Visual Basic
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
   Me.GroupFooter1.PrintAtBottom = True
End Sub
See Also

Reference

GroupFooter Class
GroupFooter Members


GroupHeader Class

GroupHeader Class
Members Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupHeader Class

The GroupHeader section prints once for every data group defined using the field specified in DataField property. A GroupHeader section requires a matching GroupFooter section.

Object Model
GroupHeader Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class GroupHeader
   Inherits Section
public class GroupHeader : Section
Remarks
Since ActiveReports does not sort the data before grouping it, your data source should be sorted on all the data fields that you have specified in group header sections. For example, for a report to properly create two groups on Country and City data fields you must sort the data by those data fields in the specified order. If your data is not sorted you end up with the same group appearing multiple times in the report at different locations (i.e. the report is NOT grouped).
Example
  • C#
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.ColumnLayout = true;
    this.groupHeader1.DataField = "Country";
    this.groupHeader1.GroupKeepTogether = GroupKeepTogether.None;
    this.groupHeader1.KeepTogether = true;
    this.groupHeader1.NewColumn = NewColumn.None;
    this.groupHeader1.NewPage = NewPage.None;
    this.groupHeader1.RepeatStyle =  RepeatStyle.None;
    this.groupHeader1.UnderlayNext = true;
}
  • Visual Basic
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.ColumnLayout = True
   Me.GroupHeader1.DataField = "Country"
   Me.GroupHeader1.GroupKeepTogether = GroupKeepTogether.None
   Me.GroupHeader1.KeepTogether = True
   Me.GroupHeader1.NewColumn = NewColumn.None
   Me.GroupHeader1.NewPage = NewPage.None
   Me.GroupHeader1.RepeatStyle = RepeatStyle.None
   Me.GroupHeader1.UnderlayNext = True
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.GroupHeader

See Also

Reference

GroupHeader Members
GrapeCity.ActiveReports.SectionReportModel Namespace


GroupHeader Class Members

GroupHeader Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupHeader Class

The following tables list the members exposed by GroupHeader.

Public Constructors
 | Name | Description
Public Constructor | GroupHeader Constructor | Initializes a new instance of the GroupHeader class.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | ColumnGroupKeepTogether | Gets or sets a value that specifies whether the group will print as a single block in the same column.
Public Property | ColumnLayout | Gets or sets a value to determine whether the section should use the same column layout as its detail section.
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | DataField | Gets or sets the name of the field used to group the data source records.
Public Property | GroupKeepTogether | Gets or sets a value that specifies whether the section and its footer will print as a single block on the same page.
Public Property | Height | Gets or sets the height of the group header.
Public Property | KeepTogether | Gets or sets a value that determines whether the section should be printed on a single page.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | NewColumn | Gets or sets a value that determines whether a new column (in a multi-column report) should be started before and/or after printing the section.
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property | RepeatStyle | Gets or sets a value that specifies whether the section should print with every column or page on which the Detail section or associated footer is printed.
Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | UnderlayNext | Gets or sets a value that specifies whether the section should print underneath the following section.
Public Property | Visible | Specifies whether the section should be printed or not. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
Public Methods
 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | Dispose | Releases the section instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
Public Events
 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

GroupHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


GroupHeader Constructor

GroupHeader Constructor
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : GroupHeader Constructor
Initializes a new instance of the GroupHeader class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public GroupHeader()
Example
  • C#
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.ColumnLayout = true;
    this.groupHeader1.DataField = "Country";
    this.groupHeader1.GroupKeepTogether = GroupKeepTogether.None;
    this.groupHeader1.KeepTogether = true;
    this.groupHeader1.NewColumn = NewColumn.None;
    this.groupHeader1.NewPage = NewPage.None;
    this.groupHeader1.RepeatStyle =  RepeatStyle.None;
    this.groupHeader1.UnderlayNext = true;
}
  • Visual Basic
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
    Me.GroupHeader1.ColumnLayout = True
    Me.GroupHeader1.DataField = "Country"
    Me.GroupHeader1.GroupKeepTogether = GroupKeepTogether.None
    Me.GroupHeader1.KeepTogether = True
    Me.GroupHeader1.NewColumn = NewColumn.None
    Me.GroupHeader1.NewPage = NewPage.None
    Me.GroupHeader1.RepeatStyle = RepeatStyle.None
    Me.GroupHeader1.UnderlayNext = True
End Sub
See Also

Reference

GroupHeader Class
GroupHeader Members


GroupHeader Class Properties

GroupHeader Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupHeader Class

For a list of all members of this type, see GroupHeader members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | ColumnGroupKeepTogether | Gets or sets a value that specifies whether the group will print as a single block in the same column.
Public Property | ColumnLayout | Gets or sets a value to determine whether the section should use the same column layout as its detail section.
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | DataField | Gets or sets the name of the field used to group the data source records.
Public Property | GroupKeepTogether | Gets or sets a value that specifies whether the section and its footer will print as a single block on the same page.
Public Property | Height | Gets or sets the height of the group header.
Public Property | KeepTogether | Gets or sets a value that determines whether the section should be printed on a single page.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | NewColumn | Gets or sets a value that determines whether a new column (in a multi-column report) should be started before and/or after printing the section.
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property | RepeatStyle | Gets or sets a value that specifies whether the section should print with every column or page on which the Detail section or associated footer is printed.
Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | UnderlayNext | Gets or sets a value that specifies whether the section should print underneath the following section.
Public Property | Visible | Specifies whether the section should be printed or not. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

GroupHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ColumnGroupKeepTogether Property

ColumnGroupKeepTogether Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : ColumnGroupKeepTogether Property
Gets or sets a value that specifies whether the group will print as a single block in the same column.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ColumnGroupKeepTogether As System.Boolean
public System.bool ColumnGroupKeepTogether {get; set;}

Property Value

Boolean.
Remarks

The Boolean ColumnGroupKeepTogether property will only be implemented when the GroupHeader's GroupKeepTogether property is set to All.

The purpose of this property is to prevent a group from splitting across columns. If the group will not fit in the current column, ActiveReports will attempt to render the full group in the next column. If the group is too large to fit in a single column, this property will be ignored.

Example
  • C#
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.ColumnLayout = true;
    this.groupHeader1.GroupKeepTogether = GroupKeepTogether.All;
    this.groupHeader1.ColumnGroupKeepTogether = true;
}
  • Visual Basic
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.ColumnLayout = True
   Me.GroupHeader1.GroupKeepTogether = GroupKeepTogether.All
   Me.GroupHeader1.ColumnGroupKeepTogether = True
End Sub
See Also

Reference

GroupHeader Class
GroupHeader Members


ColumnLayout Property (GroupHeader)

ColumnLayout Property (GroupHeader)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : ColumnLayout Property
Gets or sets a value to determine whether the section should use the same column layout as its detail section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ColumnLayout As System.Boolean
public System.bool ColumnLayout {get; set;}

Property Value

A Boolean value. True if the section will have the same number of columns as its detail section. False if the section will have a single column.
Example
  • C#
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.ColumnLayout = true;
}
  • Visual Basic
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.ColumnLayout = True
End Sub
See Also

Reference

GroupHeader Class
GroupHeader Members


DataField Property (GroupHeader)

DataField Property (GroupHeader)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : DataField Property

Gets or sets the name of the field used to group the data source records.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataField As System.String
public System.string DataField {get; set;}

Property Value

A string value that represents the name of the field to be grouped.
Remarks

ActiveReports checks for any changes in the value of the specified field and starts a new group when the value changes. Current groups are ended (i.e. the group footer section is printed) before the new group is started.

The specified field can originate from the data source or an unbound field added to the Fields collection in the DataInitialize event.

Example
  • C#
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.ColumnLayout = true;
    this.groupHeader1.DataField = "Country";
}
  • Visual Basic
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.ColumnLayout = True
   Me.GroupHeader1.DataField = "Country"
End Sub
See Also

Reference

GroupHeader Class
GroupHeader Members


GroupKeepTogether Property

GroupKeepTogether Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : GroupKeepTogether Property
Gets or sets a value that specifies whether the section and its footer will print as a single block on the same page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GroupKeepTogether As GroupKeepTogether
public GroupKeepTogether GroupKeepTogether {get; set;}

Property Value

GroupKeepTogether enumeration. Default is GroupKeepTogether.None. Possible values are:

  • GroupKeepTogether.All
  • GroupKeepTogether.FirstDetail
  • GroupKeepTogether.None
Example
  • C#
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.GroupKeepTogether = GroupKeepTogether.FirstDetail;
}
  • Visual Basic
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.GroupKeepTogether = GroupKeepTogether.FirstDetail
End Sub
See Also

Reference

GroupHeader Class
GroupHeader Members
ActiveReports6~GrapeCity.ActiveReports.GroupHeader~KeepTogether


Height Property (GroupHeader)

Height Property (GroupHeader)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : Height Property
Gets or sets the height of the group header.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Property Height As System.Single
public new System.float Height {get; set;}
See Also

Reference

GroupHeader Class
GroupHeader Members


KeepTogether Property (GroupHeader)

KeepTogether Property (GroupHeader)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : KeepTogether Property
Gets or sets a value that determines whether the section should be printed on a single page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property KeepTogether As System.Boolean
public System.bool KeepTogether {get; set;}

Property Value

A Boolean value. True if the section will print on a single page if its contents permit; otherwise, False.
Remarks

When this property is set to True, ActiveReports will attempt to print the section on the current page. If the contents do not fit on the current page and the current page is not a new page, the section will be moved to the next page. If the section does not fit on the following page, it will be moved back to the original position and the contents will be split across multiple pages.

Example
  • C#
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.KeepTogether = true;
}
  • Visual Basic
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.KeepTogether = True
End Sub
See Also

Reference

GroupHeader Class
GroupHeader Members
ActiveReports6~GrapeCity.ActiveReports.GroupHeader~GroupKeepTogether


NewColumn Property (GroupHeader)

NewColumn Property (GroupHeader)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : NewColumn Property
Gets or sets a value that determines whether a new column (in a multi-column report) should be started before and/or after printing the section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NewColumn As NewColumn
public NewColumn NewColumn {get; set;}

Property Value

A NewColumn enumeration value that determines the behavior of column breaks before or after printing the section. The default value is NewColumn.None. Possible values are:

  • NewColumn.After
  • NewColumn.Before
  • NewColumn.BeforeAfter
  • NewColumn.None
Example
  • C#
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.ColumnLayout = true;
    this.groupHeader1.NewColumn = NewColumn.None;
}
  • Visual Basic
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.ColumnLayout = True
   Me.GroupHeader1.NewColumn = NewColumn.None
End Sub
See Also

Reference

GroupHeader Class
GroupHeader Members


NewPage Property (GroupHeader)

NewPage Property (GroupHeader)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : NewPage Property
Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NewPage As NewPage
public NewPage NewPage {get; set;}

Property Value

NewPage Enumeration. Possible values are:

  • NewPage.After
  • NewPage.Before
  • NewPage.BeforeAfter
  • NewPage.None
Example
  • C#
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.NewPage = NewPage.None;
}
  • Visual Basic
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.NewPage = NewPage.None
End Sub
See Also

Reference

GroupHeader Class
GroupHeader Members


RepeatStyle Property

RepeatStyle Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : RepeatStyle Property
Gets or sets a value that specifies whether the section should print with every column or page on which the Detail section or associated footer is printed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RepeatStyle As RepeatStyle
public RepeatStyle RepeatStyle {get; set;}

Property Value

A RepeatStyle enumeration. The default value is RepeatStyle.None. Possible values are:

  • RepeatStyle.All
  • RepeatStyle.None
  • RepeatStyle.OnColumn
  • RepeatStyle.OnPage
  • RepeatStyle.OnPageIncludeNoDetail (prevents orphaned footers)
Example
  • C#
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.RepeatStyle =  RepeatStyle.OnPageIncludeNoDetail;
}
  • Visual Basic
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.RepeatStyle = RepeatStyle.OnPageIncludeNoDetail
End Sub
See Also

Reference

GroupHeader Class
GroupHeader Members


UnderlayNext Property

UnderlayNext Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > GroupHeader Class : UnderlayNext Property

Gets or sets a value that specifies whether the section should print underneath the following section.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UnderlayNext As System.Boolean
public System.bool UnderlayNext {get; set;}

Property Value

A Boolean value. True if the following section will start rendering at the top of this section; otherwise, False.
Remarks
If this property is set to True, be sure that the next section's BackColor is set to System.Drawing.Color.Transparent. Otherwise, the GroupHeader will be hidden behind the next section.
Example
  • C#
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    this.groupHeader1.UnderlayNext = true;
}
  • Visual Basic
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
   Me.GroupHeader1.UnderlayNext = True
End Sub
See Also

Reference

GroupHeader Class
GroupHeader Members


Label Class

Label Class
Members Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Label Class

Prints static text on the report.

Object Model
Label Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Label
   Inherits ARControl
public sealed class Label : ARControl
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.Alignment = TextAlignment.Left;
    this.label1.Angle = 0;
    this.label1.BackColor = System.Drawing.Color.BlanchedAlmond;
    this.label1.ClassName = "Normal";
    this.label1.Font = new System.Drawing.Font("Arial",12);
    this.label1.ForeColor = System.Drawing.Color.Brown;
    this.label1.HyperLink = "mailto:support@company.com";
    this.label1.MultiLine = false;
    this.label1.Text = "Label";
    this.label1.VerticalAlignment = VerticalTextAlignment.Top;
    this.label1.WrapMode = GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap;
    //With the properties above set, the Style string would be:
    //this.label1.Style = color: Brown; background-color: BlanchedAlmond; font-size: 12pt;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.Alignment = TextAlignment.Left
   Me.Label1.Angle = 0
   Me.Label1.BackColor = System.Drawing.Color.BlanchedAlmond
   Me.Label1.ClassName = "Normal"
   Me.Label1.Font = New System.Drawing.Font("Arial", 12)
   Me.Label1.ForeColor = System.Drawing.Color.Brown
   Me.Label1.HyperLink = "mailto:support@company.com"
   Me.Label1.MultiLine = False
   Me.Label1.Text = "Label"
   Me.Label1.VerticalAlignment = VerticalTextAlignment.Top
   Me.Label1.WrapMode = GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap
   'With the properties above set, the Style string would be:
   'this.Label1.Style = color: Brown; background-color: BlanchedAlmond; font-size: 12pt;
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.Label

See Also

Reference

Label Members
GrapeCity.ActiveReports.SectionReportModel Namespace


Label Class Members

Label Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Label Class

The following tables list the members exposed by Label.

Public Constructors
 | Name | Description
Public Constructor | Label Constructor | Initializes a new instance of the Label class.
Top
Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the alignment of text within the bounds of the control.
Public Property | Angle | Gets or sets the angle (slope) of the text within the control area.
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | CharacterSpacing | Gets or sets the distance in points between individual characters in the label control.
Public Property | ClassName | Gets or sets a style rule class name. The style rule is used to format the control.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Font | Gets or returns the font object used to print the control text.
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | HyperLink | Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | LineSpacing | Gets or sets the spacing in points between the lines of text within the label control.
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | MultiLine | Gets or sets a value indicating whether this is a multi-line label control.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Padding | Gets or sets padding within the control.
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | RightToLeft | Sets or returns a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Public Property | ShrinkToFit | Gets ot sets the value indicating whether the label should decrease the font size in order to fit the content.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Style | Gets or sets a style string for the label.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Text | Gets or sets the text of the label to be printed.
Public Property | TextJustify | Gets or sets the type of justification to use when the Alignment property is set to Justify.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Value | Gets or sets the current Value of the Label control.
Public Property | VerticalAlignment | Gets or sets the position of the label's text vertically within the bounds of the control.
Public Property | VerticalText | Gets or sets whether the control's text is rendered according to the vertical layout rules.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | WrapMode | Sets/gets control's wrap mode using CSS.
Top
Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

Label Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Label Constructor

Label Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : Label Constructor
Initializes a new instance of the Label class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Label()
See Also

Reference

Label Class
Label Members


Label Class Properties

Label Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Label Class

For a list of all members of this type, see Label members.

Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the alignment of text within the bounds of the control.
Public Property | Angle | Gets or sets the angle (slope) of the text within the control area.
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | CharacterSpacing | Gets or sets the distance in points between individual characters in the label control.
Public Property | ClassName | Gets or sets a style rule class name. The style rule is used to format the control.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Font | Gets or returns the font object used to print the control text.
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | HyperLink | Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | LineSpacing | Gets or sets the spacing in points between the lines of text within the label control.
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | MultiLine | Gets or sets a value indicating whether this is a multi-line label control.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Padding | Gets or sets padding within the control.
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | RightToLeft | Sets or returns a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Public Property | ShrinkToFit | Gets ot sets the value indicating whether the label should decrease the font size in order to fit the content.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Style | Gets or sets a style string for the label.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Text | Gets or sets the text of the label to be printed.
Public Property | TextJustify | Gets or sets the type of justification to use when the Alignment property is set to Justify.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Value | Gets or sets the current Value of the Label control.
Public Property | VerticalAlignment | Gets or sets the position of the label's text vertically within the bounds of the control.
Public Property | VerticalText | Gets or sets whether the control's text is rendered according to the vertical layout rules.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | WrapMode | Sets/gets control's wrap mode using CSS.
Top
See Also

Reference

Label Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Alignment Property (Label)

Alignment Property (Label)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : Alignment Property
Gets or sets the alignment of text within the bounds of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Alignment As TextAlignment
public TextAlignment Alignment {get; set;}

Property Value

TextAlignment enum. The default value is TextAlignment.Left. Possible values are:

  • TextAlignment.Center
  • TextAlignment.Justify
  • TextAlignment.Left
  • TextAlignment.Right
Remarks
The Justify text alignment option is not supported in edit mode. The text alignment automatically changes from Justify to Left (default value) when the control is in edit mode, and then back to Justify after exiting edit mode.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.Alignment = TextAlignment.Left;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.Alignment = TextAlignment.Left
End Sub
See Also

Reference

Label Class
Label Members
VerticalAlignment Property
TextAlignment Property


Angle Property (Label)

Angle Property (Label)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : Angle Property
Gets or sets the angle (slope) of the text within the control area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Angle As System.Integer
public System.int Angle {get; set;}

Property Value

Angle value in 1/10 of a degree. Default value is 0.
Remarks
To set a label's angle to 90 degrees, set the Angle property to 900, and be sure the height of the control will accommodate the text, as labels do not grow automatically.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.Angle = 900;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.Angle = 900
End Sub
See Also

Reference

Label Class
Label Members


BackColor Property (Label)

BackColor Property (Label)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : BackColor Property
Gets or sets the background color of the control area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackColor As Color
public Color BackColor {get; set;}

Property Value

System.Drawing.Color. The default value is Color.Transparent.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.BackColor = System.Drawing.Color.BlanchedAlmond;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.BackColor = System.Drawing.Color.BlanchedAlmond
End Sub
See Also

Reference

Label Class
Label Members
ActiveReports6~GrapeCity.ActiveReports.Label~ForeColor


CharacterSpacing Property (Label)

CharacterSpacing Property (Label)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : CharacterSpacing Property
Gets or sets the distance in points between individual characters in the label control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CharacterSpacing As System.Single
public System.float CharacterSpacing {get; set;}
Remarks
The integrity of character spacing cannot be guaranteed to correctly duplicate your settings when exporting reports in XLS, RTF, and TEXT formats.
Example
  • C#
private void detail1_Format(object sender, EventArgs e)
{
   this.label1.MultiLine = true;
   this.label1.CharacterSpacing = 2;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.label1.MultiLine = True
   Me.label1.CharacterSpacing = 2
End Sub
See Also

Reference

Label Class
Label Members


ClassName Property (Label)

ClassName Property (Label)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : ClassName Property
Gets or sets a style rule class name. The style rule is used to format the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ClassName As System.String
public System.string ClassName {get; set;}

Property Value

String value that represents the style class name used to format the control's appearance. Default is Normal.
Remarks
You can use predefined styles in the report's stylesheet or add new ones to it.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.ClassName = "Normal";
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.ClassName = "Normal"
End Sub
See Also

Reference

Label Class
Label Members
ActiveReports6~GrapeCity.ActiveReports.Label~Style
ActiveReports6~GrapeCity.ActiveReports.StyleSheet


Font Property (Label)

Font Property (Label)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : Font Property
Gets or returns the font object used to print the control text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Font As Font
public Font Font {get; set;}

Property Value

System.Drawing.Font. Current Font object used to render the control's text.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.BackColor = System.Drawing.Color.BlanchedAlmond;
    this.label1.Font = new System.Drawing.Font("Arial",12);
    this.label1.ForeColor = System.Drawing.Color.Brown;
    //With the properties above set, the Style string would be:
    //this.label1.Style = color: Brown; background-color: BlanchedAlmond; font-size: 12pt;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.BackColor = System.Drawing.Color.BlanchedAlmond
   Me.Label1.Font = New System.Drawing.Font("Arial", 12)
   Me.Label1.ForeColor = System.Drawing.Color.Brown
   'With the properties above set, the Style string would be:
   'this.Label1.Style = color: Brown; background-color: BlanchedAlmond; font-size: 12pt;
End Sub
See Also

Reference

Label Class
Label Members


ForeColor Property (Label)

ForeColor Property (Label)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : ForeColor Property
Gets or returns the foreground (font) color of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ForeColor As Color
public Color ForeColor {get; set;}

Property Value

System.Drawing.Color. Default is Color.Black.
Example
  • C#
private void dDetail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.ForeColor = System.Drawing.Color.Brown;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.ForeColor = System.Drawing.Color.Brown
End Sub
See Also

Reference

Label Class
Label Members
ActiveReports6~GrapeCity.ActiveReports.Label~BackColor


HyperLink Property (Label)

HyperLink Property (Label)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : HyperLink Property

Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HyperLink As System.String
public System.string HyperLink {get; set;}
Remarks

Note: When using the HtmlViewer, the RawHtml, the Flash Viewer or the Silverlight Viewer to display a report, you should indicate the full URL address (for example, "http://www.grapecity.com") for this property.

Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.HyperLink = "mailto:support@company.com";
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.HyperLink = "mailto:support@company.com"
End Sub
See Also

Reference

Label Class
Label Members
HyperLinkEventArgs


LineSpacing Property (Label)

LineSpacing Property (Label)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : LineSpacing Property
Gets or sets the spacing in points between the lines of text within the label control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineSpacing As System.Single
public System.float LineSpacing {get; set;}
Example
  • C#
private void detail_Format(object sender, EventArgs e)
{
   this.lblInfo.MultiLine = true;
   this.lblInfo.LineSpacing = 2;
}
  • VB.NET
Private Sub detail_Format(sender As Object, e As EventArgs)
    Me.lblInfo.MultiLine = True
    Me.lblInfo.LineSpacing = 2
End Sub
See Also

Reference

Label Class
Label Members


MultiLine Property (Label)

MultiLine Property (Label)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : MultiLine Property
Gets or sets a value indicating whether this is a multi-line label control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MultiLine As System.Boolean
public System.bool MultiLine {get; set;}

Property Value

A Boolean value. True if the label control is multiline; otherwise, False.
Remarks
A multi-line label control renders the label's text on more than one line. If the WordWrap property is set to True, long lines will be wrapped to the following line. If the WordWrap property is set to False, the text will print on a new line only when a new line character is encountered.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.MultiLine = false;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.MultiLine = False
End Sub
See Also

Reference

Label Class
Label Members
ActiveReports6~GrapeCity.ActiveReports.Label~WordWrap


Padding Property (Label)

Padding Property (Label)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : Padding Property
Gets or sets padding within the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Padding As PaddingEx
public PaddingEx Padding {get; set;}
Remarks
This property has five settings at design time: All, Left, Top, Right, and Bottom. More settings, like Vertical and Horizontal, are available in code. The All property has a default value of -1, which means that all of the Padding values are not equal. Change this value to 10, and a space ten pixels wide is left around the text on all sides. The Left, Top, Right, and Bottom properties are 0, 0, 0, 0 by default.
See Also

Reference

Label Class
Label Members


RightToLeft Property (Label)

RightToLeft Property (Label)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : RightToLeft Property
Sets or returns a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RightToLeft As System.Boolean
public System.bool RightToLeft {get; set;}
See Also

Reference

Label Class
Label Members


ShrinkToFit Property (Label)

ShrinkToFit Property (Label)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : ShrinkToFit Property
Gets ot sets the value indicating whether the label should decrease the font size in order to fit the content.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShrinkToFit As System.Boolean
public System.bool ShrinkToFit {get; set;}
See Also

Reference

Label Class
Label Members


Style Property (Label)

Style Property (Label)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : Style Property
Gets or sets a style string for the label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As System.String
public System.string Style {get; set;}

Property Value

String. CSS syntax of the control style.
Remarks

The style string overrides the global style rules specified in the ClassName property.

Style string syntax is based on Cascading Style Sheets syntax.

Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.BackColor = System.Drawing.Color.BlanchedAlmond;
    this.label1.Font = new System.Drawing.Font("Arial",12);
    this.label1.ForeColor = System.Drawing.Color.Brown;
    //With the properties above set, the Style string would be:
    //this.label1.Style = color: Brown; background-color: BlanchedAlmond; font-size: 12pt;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.BackColor = System.Drawing.Color.BlanchedAlmond
   Me.Label1.Font = New System.Drawing.Font("Arial", 12)
   Me.Label1.ForeColor = System.Drawing.Color.Brown
   'With the properties above set, the Style string would be:
   'this.Label1.Style = color: Brown; background-color: BlanchedAlmond; font-size: 12pt;
End Sub
See Also

Reference

Label Class
Label Members
ActiveReports6~GrapeCity.ActiveReports.Label
ActiveReports6~GrapeCity.ActiveReports.Style
ActiveReports6~GrapeCity.ActiveReports.StyleSheet


Text Property (Label)

Text Property (Label)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : Text Property
Gets or sets the text of the label to be printed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Text As System.String
public System.string Text {get; set;}
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.Text = "Label";
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.Label1.Text = "Label"
End Sub
See Also

Reference

Label Class
Label Members


TextJustify Property (Label)

TextJustify Property (Label)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : TextJustify Property
Gets or sets the type of justification to use when the Alignment property is set to Justify.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TextJustify As TextJustify
public TextJustify TextJustify {get; set;}

Property Value

TextJustify enum. The default value is Auto. Possible values are:

  • Auto
  • Distribute
  • DistributeAllLines
Remarks
When you set the Alignment property to Justify, this property extends your justification options.
See Also

Reference

Label Class
Label Members


Value Property (Label)

Value Property (Label)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : Value Property

Gets or sets the current Value of the Label control.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As System.Object
public System.object Value {get; set;}

Property Value

Object.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.Value="Title";
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Label1.Value = "Title"
End Sub
See Also

Reference

Label Class
Label Members


VerticalAlignment Property (Label)

VerticalAlignment Property (Label)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : VerticalAlignment Property
Gets or sets the position of the label's text vertically within the bounds of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property VerticalAlignment As VerticalTextAlignment
public VerticalTextAlignment VerticalAlignment {get; set;}

Property Value

Current vertical alignment of the label's text. Default is VerticalTextAlignment.Top. Possible values are:

  • VerticalTextAlignment.Bottom
  • VerticalTextAlignment.Middle
  • VerticalTextAlignment.Top
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.label1.VerticalAlignment = VerticalTextAlignment.Top;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Label1.VerticalAlignment = VerticalTextAlignment.Top
End Sub
See Also

Reference

Label Class
Label Members
ActiveReports6~GrapeCity.ActiveReports.Label~Alignment


VerticalText Property (Label)

VerticalText Property (Label)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : VerticalText Property
Gets or sets whether the control's text is rendered according to the vertical layout rules.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property VerticalText As System.Boolean
public System.bool VerticalText {get; set;}
Remarks
In case of the HTML export filter, the vertical text is supported just for the DynamicHtml output type and works with Microsoft Internet Explorer only.
See Also

Reference

Label Class
Label Members


WrapMode Property (Label)

WrapMode Property (Label)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Label Class : WrapMode Property
Sets/gets control's wrap mode using CSS.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WrapMode As WrapMode
public WrapMode WrapMode {get; set;}
See Also

Reference

Label Class
Label Members


Line Class

Line Class
Members Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Line Class
Prints a line on the report.
Object Model
Line Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Line
   Inherits ARControl
public sealed class Line : ARControl
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.line1.LineColor = System.Drawing.Color.Blue;
    this.line1.LineStyle = LineStyle.DashDot;
    this.line1.LineWeight = 2.0f;
    this.line1.X1 = 1.0f;
    this.line1.X2 = 4.0f;
    this.line1.Y1 = 0.5f;
    this.line1.Y2 = 0.5f;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Line1.LineColor = System.Drawing.Color.Blue
    Me.Line1.LineStyle = LineStyle.DashDot
    Me.Line1.LineWeight = 2.0F
    Me.Line1.X1 = 1.0F
    Me.Line1.X2 = 4.0F
    Me.Line1.Y1 = 0.5F
    Me.Line1.Y2 = 0.5F
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.Line

See Also

Reference

Line Members
GrapeCity.ActiveReports.SectionReportModel Namespace


Line Class Members

Line Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Line Class

The following tables list the members exposed by Line.

Public Constructors
 | Name | Description
Public Constructor | Line Constructor | Initializes a new instance of the Line class.
Top
Public Properties
 | Name | Description
Public Property | AnchorBottom | Anchors the line to the bottom of the containing section.
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | LineColor | Gets or sets the color of the line control.
Public Property | LineStyle | Gets or sets the pen style used to draw the line.
Public Property | LineWeight | Gets or sets the pen width of the line in pixels.
Public Property | Location | Overridden. Gets or sets the location of the control in inches.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Size | Overridden. Gets or sets the size of the control in inches.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | X1 | Gets or sets the horizontal coordinate of the line's starting point.
Public Property | X2 | Gets or sets the horizontal coordinate of the line's end point.
Public Property | Y1 | Gets or sets the vertical coordinate of the line's starting point.
Public Property | Y2 | Gets or sets the vertical coordinate of the line's end point.
Top
Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

Line Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Line Constructor

Line Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : Line Constructor
Initializes a new instance of the Line class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Line()
See Also

Reference

Line Class
Line Members


Line Class Properties

Line Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Line Class

For a list of all members of this type, see Line members.

Public Properties
 | Name | Description
Public Property | AnchorBottom | Anchors the line to the bottom of the containing section.
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | LineColor | Gets or sets the color of the line control.
Public Property | LineStyle | Gets or sets the pen style used to draw the line.
Public Property | LineWeight | Gets or sets the pen width of the line in pixels.
Public Property | Location | Overridden. Gets or sets the location of the control in inches.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Size | Overridden. Gets or sets the size of the control in inches.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | X1 | Gets or sets the horizontal coordinate of the line's starting point.
Public Property | X2 | Gets or sets the horizontal coordinate of the line's end point.
Public Property | Y1 | Gets or sets the vertical coordinate of the line's starting point.
Public Property | Y2 | Gets or sets the vertical coordinate of the line's end point.
Top
See Also

Reference

Line Class
GrapeCity.ActiveReports.SectionReportModel Namespace


AnchorBottom Property

AnchorBottom Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : AnchorBottom Property
Anchors the line to the bottom of the containing section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AnchorBottom As System.Boolean
public System.bool AnchorBottom {get; set;}

Property Value

Boolean.
Remarks
When set to True, this property will create a continuous line from line controls in adjacent sections.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.line1.AnchorBottom = true;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Line1.AnchorBottom = True
End Sub
See Also

Reference

Line Class
Line Members


LineColor Property (Line)

LineColor Property (Line)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : LineColor Property
Gets or sets the color of the line control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineColor As Color
public Color LineColor {get; set;}

Property Value

A System.Drawing.Color value that represents the current color of the line. The default value is Color.Black.
Example
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.Line1.LineColor = System.Drawing.Color.Blue;
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.Line1.LineColor = System.Drawing.Color.Blue
End Sub
See Also

Reference

Line Class
Line Members
ActiveReports6~GrapeCity.ActiveReports.Line~LineStyle
ActiveReports6~GrapeCity.ActiveReports.Line~LineWeight


LineStyle Property (Line)

LineStyle Property (Line)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : LineStyle Property
Gets or sets the pen style used to draw the line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineStyle As LineStyle
public LineStyle LineStyle {get; set;}

Property Value

LineStyle enumeration. The default value is LineStyle.Solid. Possible values are:

  • LineStyle.Dash
  • LineStyle.DashDot
  • LineStyle.DashDotDot
  • LineStyle.Dot
  • LineStyle.Solid
  • LineStyle.Transparent
Example
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.Line1.LineStyle = LineStyle.DashDot;
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.Line1.LineStyle = LineStyle.DashDot
End Sub
See Also

Reference

Line Class
Line Members
ActiveReports6~GrapeCity.ActiveReports.Line~LineColor
ActiveReports6~GrapeCity.ActiveReports.Line~LineWeight


LineWeight Property (Line)

LineWeight Property (Line)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : LineWeight Property
Gets or sets the pen width of the line in pixels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineWeight As System.Single
public System.float LineWeight {get; set;}

Property Value

Float value that represents the current weight of the line in pixels. Default is 1.0f.
Example
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.Line1.LineWeight = 2.0f;
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.Line1.LineWeight = 2.0F
End Sub
See Also

Reference

Line Class
Line Members
ActiveReports6~GrapeCity.ActiveReports.Line~LineColor
ActiveReports6~GrapeCity.ActiveReports.Line~LineStyle


Location Property (Line)

Location Property (Line)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : Location Property
Gets or sets the location of the control in inches.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Property Location As PointF
public override PointF Location {get; set;}
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    System.Drawing.PointF p = new System.Drawing.PointF();
    p.X = 0.5f;
    p.Y = 0.5f;
    this.line1.Location = p;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Dim p As System.Drawing.PointF
    p.X = 0.5
    p.Y = 0.5
    Me.Line1.Location = p
End Sub
See Also

Reference

Line Class
Line Members


Size Property (Line)

Size Property (Line)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : Size Property
Gets or sets the size of the control in inches.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Property Size As SizeF
public override SizeF Size {get; set;}
See Also

Reference

Line Class
Line Members


X1 Property

X1 Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : X1 Property
Gets or sets the horizontal coordinate of the line's starting point.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property X1 As System.Single
public System.float X1 {get; set;}
Remarks
Line coordinates are relative to the section's top left corner. Coordinate units using the API are in inches. You can use the ActiveReport.CmToInch and ActiveReport.InchToCm methods to convert to metric units. The designer supports both metric and inch units.
Example
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.Line1.X1 = 1.0f;
    this.Line1.X2 = 4.0f;
    this.Line1.Y1 = 0.5f;
    this.Line1.Y2 = 0.5f;
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.Line1.X1 = 1.0F
    Me.Line1.X2 = 4.0F
    Me.Line1.Y1 = 0.5F
    Me.Line1.Y2 = 0.5F
End Sub
See Also

Reference

Line Class
Line Members
ActiveReports6~GrapeCity.ActiveReports.Line~X2
ActiveReports6~GrapeCity.ActiveReports.Line~Y1
ActiveReports6~GrapeCity.ActiveReports.Line~Y2


X2 Property

X2 Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : X2 Property
Gets or sets the horizontal coordinate of the line's end point.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property X2 As System.Single
public System.float X2 {get; set;}
Remarks
Line coordinates are relative to the section's top left corner. Coordinate units using the API are in inches. You can use the ActiveReport.CmToInch and ActiveReport.InchToCm methods to convert to metric units. The designer supports both metric and inch units.
Example
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.Line1.X1 = 1.0f;
    this.Line1.X2 = 4.0f;
    this.Line1.Y1 = 0.5f;
    this.Line1.Y2 = 0.5f;
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.Line1.X1 = 1.0F
    Me.Line1.X2 = 4.0F
    Me.Line1.Y1 = 0.5F
    Me.Line1.Y2 = 0.5F
End Sub
See Also

Reference

Line Class
Line Members
ActiveReports6~GrapeCity.ActiveReports.Line~X1
ActiveReports6~GrapeCity.ActiveReports.Line~Y1
ActiveReports6~GrapeCity.ActiveReports.Line~Y2


Y1 Property

Y1 Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : Y1 Property
Gets or sets the vertical coordinate of the line's starting point.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Y1 As System.Single
public System.float Y1 {get; set;}
Remarks
Line coordinates are relative to the section's top left corner. Coordinate units using the API are in inches. You can use the ActiveReport.CmToInch and ActiveReport.InchToCm methods to convert to metric units. The designer supports both metric and inch units.
Example
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.Line1.X1 = 1.0f;
    this.Line1.X2 = 4.0f;
    this.Line1.Y1 = 0.5f;
    this.Line1.Y2 = 0.5f;
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.Line1.X1 = 1.0F
    Me.Line1.X2 = 4.0F
    Me.Line1.Y1 = 0.5F
    Me.Line1.Y2 = 0.5F
End Sub
See Also

Reference

Line Class
Line Members
ActiveReports6~GrapeCity.ActiveReports.Line~X1
ActiveReports6~GrapeCity.ActiveReports.Line~X2
ActiveReports6~GrapeCity.ActiveReports.Line~Y2


Y2 Property

Y2 Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Line Class : Y2 Property
Gets or sets the vertical coordinate of the line's end point.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Y2 As System.Single
public System.float Y2 {get; set;}
Remarks
Line coordinates are relative to the section's top left corner. Coordinate units using the API are in inches. You can use the ActiveReport.CmToInch and ActiveReport.InchToCm methods to convert to metric units. The designer supports both metric and inch units.
Example
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.Line1.X1 = 1.0f;
    this.Line1.X2 = 4.0f;
    this.Line1.Y1 = 0.5f;
    this.Line1.Y2 = 0.5f;
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.Line1.X1 = 1.0F
    Me.Line1.X2 = 4.0F
    Me.Line1.Y1 = 0.5F
    Me.Line1.Y2 = 0.5F
End Sub
See Also

Reference

Line Class
Line Members
ActiveReports6~GrapeCity.ActiveReports.Line~X1
ActiveReports6~GrapeCity.ActiveReports.Line~X2
ActiveReports6~GrapeCity.ActiveReports.Line~Y1


OleObject Class

OleObject Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : OleObject Class
OleObject is a wrapper class for printing OLE objects.
Object Model
OleObject Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class OleObject
   Inherits ARControl
public sealed class OleObject : ARControl
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.OleObject

See Also

Reference

OleObject Members
GrapeCity.ActiveReports.SectionReportModel Namespace


OleObject Class Members

OleObject Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : OleObject Class

The following tables list the members exposed by OleObject.

Public Constructors
 | Name | Description
Public Constructor | OleObject Constructor | Initializes a new instance of the OleObject class.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Class | Specifies the class name of the Ole object.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | HyperLink | Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | PictureAlignment | Gets or sets the position of the object's content within the control area.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | SizeMode | Gets or sets a value that determines how the image is sized to fit the OleObject control area.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | CreateFrom | Creates an Ole Object to embed in the control from the specified file.
Public Method | Dispose() | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Edit | Invokes the Ole server to edit the current embedded instance.
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

OleObject Class
GrapeCity.ActiveReports.SectionReportModel Namespace


OleObject Constructor

OleObject Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : OleObject Constructor
Initializes a new instance of the OleObject class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public OleObject()
See Also

Reference

OleObject Class
OleObject Members


OleObject Class Methods

OleObject Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : OleObject Class

For a list of all members of this type, see OleObject members.

Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | CreateFrom | Creates an Ole Object to embed in the control from the specified file.
Public Method | Dispose() | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Edit | Invokes the Ole server to edit the current embedded instance.
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

OleObject Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CreateFrom Method

CreateFrom Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : CreateFrom Method
Specifies the file to be used to create an embedded Ole object. A valid Ole server for the specified file type should be installed to handle the file instance.
Creates an Ole Object to embed in the control from the specified file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CreateFrom( _
   ByVal fileName As System.String _
)
public void CreateFrom(
   System.string fileName
)

Parameters

fileName
Specifies the file to be used to create an embedded Ole object. A valid Ole server for the specified file type should be installed to handle the file instance.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.OleObject1.CreateFrom("C:\\MailAliases.xls");
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.OleObject1.CreateFrom("C:\MailAliases.xls")
End Sub
See Also

Reference

OleObject Class
OleObject Members


Edit Method

Edit Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : Edit Method
Specifies the parent window of the Ole object instance.

Invokes the Ole server to edit the current embedded instance.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Edit( _
   ByVal parentWindow As System.Windows.Forms.IWin32Window _
)
public void Edit(
   System.Windows.Forms.IWin32Window parentWindow
)

Parameters

parentWindow
Specifies the parent window of the Ole object instance.
Remarks
End user report designer use only.
See Also

Reference

OleObject Class
OleObject Members


OleObject Class Properties

OleObject Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : OleObject Class

For a list of all members of this type, see OleObject members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Class | Specifies the class name of the Ole object.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | HyperLink | Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | PictureAlignment | Gets or sets the position of the object's content within the control area.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | SizeMode | Gets or sets a value that determines how the image is sized to fit the OleObject control area.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

OleObject Class
GrapeCity.ActiveReports.SectionReportModel Namespace


BackColor Property (OleObject)

BackColor Property (OleObject)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : BackColor Property
Gets or sets the background color of the control area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackColor As Color
public Color BackColor {get; set;}

Property Value

System.Drawing.Color.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.OleObject1.CreateFrom("C:\\MailAliases.xls");
    this.OleObject1.BackColor=System.Drawing.Color.OrangeRed;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.OleObject1.CreateFrom("C:\MailAliases.xls")
    Me.OleObject1.BackColor = System.Drawing.Color.CornflowerBlue
End Sub
See Also

Reference

OleObject Class
OleObject Members


Class Property

Class Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : Class Property
Specifies the class name of the Ole object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Class As System.String
public System.string Class {get; set;}

Property Value

String.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.OleObject1.CreateFrom("C:\\MailAliases.xls");
    System.Windows.Forms.MessageBox.Show(this.OleObject1.Class.ToString());
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.OleObject1.CreateFrom("C:\MailAliases.xls")
    MessageBox.Show(Me.OleObject1.Class.ToString())
End Sub
See Also

Reference

OleObject Class
OleObject Members


HyperLink Property (OleObject)

HyperLink Property (OleObject)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : HyperLink Property
Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HyperLink As System.String
public System.string HyperLink {get; set;}
Remarks
Note: When using the HtmlViewer, the RawHtml, the Flash Viewer or the Silverlight Viewer to display a report, you should indicate the full URL address (for example, "http://www.grapecity.com") for this property.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.OleObject1.CreateFrom("C:\\MailAliases.xls");
    this.OleObject1.HyperLink = "www.grapecity.com";
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.OleObject1.CreateFrom("C:\MailAliases.xls")
    Me.OleObject1.HyperLink = "www.grapecity.com"
End Sub
See Also

Reference

OleObject Class
OleObject Members


PictureAlignment Property (OleObject)

PictureAlignment Property (OleObject)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : PictureAlignment Property
Gets or sets the position of the object's content within the control area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PictureAlignment As PictureAlignment
public PictureAlignment PictureAlignment {get; set;}
Remarks
A PictureAlignment enumeration member that specifies the alignment of the content.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.OleObject1.CreateFrom("C:\\MailAliases.xls");
    this.OleObject1.PictureAlignment = PictureAlignment.BottomLeft;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.OleObject1.CreateFrom("C:\MailAliases.xls")
    Me.OleObject1.PictureAlignment = PictureAlignment.BottomLeft
End Sub
See Also

Reference

OleObject Class
OleObject Members
ActiveReports6~GrapeCity.ActiveReports.PictureAlignment


SizeMode Property (OleObject)

SizeMode Property (OleObject)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : SizeMode Property
Gets or sets a value that determines how the image is sized to fit the OleObject control area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SizeMode As SizeModes
public SizeModes SizeMode {get; set;}

Property Value

A SizeModes enumeration value. The default value is SizeModes.Clip.

Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.OleObject1.CreateFrom("C:\\MailAliases.xls");
    this.OleObject1.SizeMode = SizeModes.Zoom;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.OleObject1.CreateFrom("C:\MailAliases.xls")
    Me.OleObject1.SizeMode = SizeModes.Zoom
End Sub
See Also

Reference

OleObject Class
OleObject Members
ActiveReports6~GrapeCity.ActiveReports.SizeModes


PageBreak Class

PageBreak Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageBreak Class
PageBreak ends the current page and starts a new page at the control's location on the page.
Object Model
PageBreak Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class PageBreak
   Inherits ARControl
public sealed class PageBreak : ARControl
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.PageBreak

See Also

Reference

PageBreak Members
GrapeCity.ActiveReports.SectionReportModel Namespace


PageBreak Class Members

PageBreak Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageBreak Class

The following tables list the members exposed by PageBreak.

Public Constructors
 | Name | Description
Public Constructor | PageBreak Constructor | Initializes a new instance of the PageBreak class.
Top
Public Properties
 | Name | Description
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Enabled | Determines whether the PageBreak is currently enabled.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Overridden. Gets or sets the location of the control in inches.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

PageBreak Class
GrapeCity.ActiveReports.SectionReportModel Namespace


PageBreak Constructor

PageBreak Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > PageBreak Class : PageBreak Constructor
Initializes a new instance of the PageBreak class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public PageBreak()
See Also

Reference

PageBreak Class
PageBreak Members


PageBreak Class Properties

PageBreak Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageBreak Class

For a list of all members of this type, see PageBreak members.

Public Properties
 | Name | Description
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Enabled | Determines whether the PageBreak is currently enabled.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Overridden. Gets or sets the location of the control in inches.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

PageBreak Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Enabled Property (PageBreak)

Enabled Property (PageBreak)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > PageBreak Class : Enabled Property
Determines whether the PageBreak is currently enabled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Enabled As System.Boolean
public System.bool Enabled {get; set;}

Property Value

Boolean. True if the control is enabled and should create a page break at the specified position; otherwise False.

Example
  • C#
private void groupFooter1_Format(object sender, System.EventArgs eArgs)
{
    this.pageBreak1.Enabled = false;
}
  • Visual Basic
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
    Me.PageBreak1.Enabled = False
End Sub
See Also

Reference

PageBreak Class
PageBreak Members


Location Property (PageBreak)

Location Property (PageBreak)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > PageBreak Class : Location Property
Gets or sets the location of the control in inches.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Property Location As PointF
public override PointF Location {get; set;}
Example
  • C#
private void detail_Format(object sender, System.EventArgs e)
{
    System.Drawing.PointF p = new System.Drawing.PointF();
    p.X = 0f;
    p.Y = 5f;

    if(this.detail.Height > 5)
    {
        this.pageBreak1.Enabled = true;
        this.pageBreak1.Location = p;
    }
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Dim p As System.Drawing.PointF
   p.X = 0
   p.Y = 5
   If Me.Detail1.Height > 5 Then
      Me.PageBreak1.Enabled = True
      Me.PageBreak1.Location = p
   End If
End Sub
See Also

Reference

PageBreak Class
PageBreak Members


PageFooter Class

PageFooter Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageFooter Class
The PageFooter section prints once at the bottom of every page in the report.
Object Model
PageFooter Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class PageFooter
   Inherits Section
public class PageFooter : Section
Remarks

The PageFooter section is rendered last on each page after all content has been rendered, thus, unlike other sections, its height cannot be changed in the Format event.

Bound controls are not supported in this section, or in the PageHeader section. The data displayed in a bound control in one of these sections may not be in synch with the data displayed in other sections on the page.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.PageFooter

See Also

Reference

PageFooter Members
GrapeCity.ActiveReports.SectionReportModel Namespace


PageFooter Class Members

PageFooter Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageFooter Class

The following tables list the members exposed by PageFooter.

Public Constructors
 | Name | Description
Public Constructor | PageFooter Constructor | Initializes a new instance of the PageFooter class.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Height | Gets or sets the height of the page footer.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Visible | Specifies whether the section should be printed or not. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
Public Methods
 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | Dispose | Releases the section instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
Public Events
 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

PageFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


PageFooter Constructor

PageFooter Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > PageFooter Class : PageFooter Constructor
Initializes a new instance of the PageFooter class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public PageFooter()
See Also

Reference

PageFooter Class
PageFooter Members


PageFooter Class Properties

PageFooter Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageFooter Class

For a list of all members of this type, see PageFooter members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Height | Gets or sets the height of the page footer.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Visible | Specifies whether the section should be printed or not. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

PageFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Height Property (PageFooter)

Height Property (PageFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > PageFooter Class : Height Property
Gets or sets the height of the page footer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Property Height As System.Single
public new System.float Height {get; set;}
See Also

Reference

PageFooter Class
PageFooter Members


PageHeader Class

PageHeader Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageHeader Class

The PageHeader section prints once at the top of every page in the report.

Object Model
PageHeader Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class PageHeader
   Inherits Section
public class PageHeader : Section
Remarks

Bound controls are not supported in this section, or in the PageFooter section. The data displayed in a bound control in one of these sections may not be in sync with the data displayed in other sections on the page.

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.PageHeader

See Also

Reference

PageHeader Members
GrapeCity.ActiveReports.SectionReportModel Namespace


PageHeader Class Members

PageHeader Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageHeader Class

The following tables list the members exposed by PageHeader.

Public Constructors
 | Name | Description
Public Constructor | PageHeader Constructor | Initializes a new instance of the PageHeader class.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Height | Gets or sets the height of the page header.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Visible | Specifies whether the section should be printed or not. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
Public Methods
 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | Dispose | Releases the section instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
Public Events
 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

PageHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


PageHeader Constructor

PageHeader Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > PageHeader Class : PageHeader Constructor
Initializes a new instance of the PageHeader class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public PageHeader()
See Also

Reference

PageHeader Class
PageHeader Members


PageHeader Class Properties

PageHeader Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageHeader Class

For a list of all members of this type, see PageHeader members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Height | Gets or sets the height of the page header.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Visible | Specifies whether the section should be printed or not. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

PageHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Height Property (PageHeader)

Height Property (PageHeader)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > PageHeader Class : Height Property
Gets or sets the height of the page header.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Property Height As System.Single
public new System.float Height {get; set;}
See Also

Reference

PageHeader Class
PageHeader Members


Parameter Class

Parameter Class
Members Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Parameter Class
A Parameter is used to substitute values for parameter placeholders in the report's data source SQL query text.
Object Model
Parameter Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Parameter
public class Parameter
Example
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.Parameters[0].DefaultValue = "Germany";
    this.Parameters[0].Key = "country";
    this.Parameters[0].Prompt = "Country: ";
    this.Parameters[0].Tag = "some extra data";
    this.Parameters[0].Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String;
}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Parameters(0).DefaultValue = "Germany"
    Me.Parameters(0).Key = "country"
    Me.Parameters(0).Prompt = "Country: "
    Me.Parameters(0).Tag = "Some extra data"
    Me.Parameters(0).Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Parameter

See Also

Reference

Parameter Members
GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.ParameterCollection
Parameters Property


Parameter Class Members

Parameter Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Parameter Class

The following tables list the members exposed by Parameter.

Public Constructors
 | Name | Description
Public Constructor | Parameter Constructor | Initializes a new instance of the Parameter class.
Top
Public Properties
 | Name | Description
Public Property | DefaultValue | Gets or sets a value to be used as the default value in the parameters input dialog.
Public Property | Key | Unique name of the parameter.
Public Property | Prompt | Parameter caption used in the parameters input dialog to prompt the user to input a parameter value.
Public Property | PromptUser | Determines whether to prompt the user to input a parameter value.
Public Property | QueryCreated | Determines whether the query is created from the data source query string or user created.
Public Property | Tag | User-defined value.
Public Property | Type | Gets or sets a value that determines the type of input control to be created to collect the parameter value from the user.
Public Property | Value | Gets or sets the value of the parameter to be used in parameter placeholder substitution.
Top
Public Methods
 | Name | Description
Public Method | Clone | Creates a clone of the Parameter object.
Public Method | Dispose | Releases the parameter from memory.
Public Method | ReadXml | Reads the parameter from an XmlElement.
Public Method | ToString | Returns a string that represents the Parameter object.
Public Method | WriteXml | Writes the parameter from an XmlElement.
Top
Public Events
 | Name | Description
Public Event | Disposed | Adds an event handler to listen to the Disposed event on the component.
Top
See Also

Reference

Parameter Class
GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.ParameterCollection
Parameters Property


Parameter Constructor

Parameter Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Parameter Constructor
Initializes a new instance of the Parameter class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Parameter()
See Also

Reference

Parameter Class
Parameter Members


Parameter Class Methods

Parameter Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Parameter Class

For a list of all members of this type, see Parameter members.

Public Methods
 | Name | Description
Public Method | Clone | Creates a clone of the Parameter object.
Public Method | Dispose | Releases the parameter from memory.
Public Method | ReadXml | Reads the parameter from an XmlElement.
Public Method | ToString | Returns a string that represents the Parameter object.
Public Method | WriteXml | Writes the parameter from an XmlElement.
Top
See Also

Reference

Parameter Class
GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.ParameterCollection
Parameters Property


Clone Method (Parameter)

Clone Method (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Clone Method
Creates a clone of the Parameter object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Clone() As Parameter
public Parameter Clone()
See Also

Reference

Parameter Class
Parameter Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Dispose() Method
Releases the parameter from memory.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Parameter Class
Parameter Members


ReadXml Method (Parameter)

ReadXml Method (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : ReadXml Method
The base node of the XML element.
Reads the parameter from an XmlElement.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ReadXml( _
   ByVal baseNode As System.Xml.XmlNode _
) As System.Boolean
public System.bool ReadXml(
   System.Xml.XmlNode baseNode
)

Parameters

baseNode
The base node of the XML element.
See Also

Reference

Parameter Class
Parameter Members


ToString Method (Parameter)

ToString Method (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : ToString Method
Returns a string that represents the Parameter object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()

Return Value

A System.String that represents this instance.
See Also

Reference

Parameter Class
Parameter Members


WriteXml Method (Parameter)

WriteXml Method (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : WriteXml Method
The base node of the XML element.
Writes the parameter from an XmlElement.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function WriteXml( _
   ByVal baseNode As System.Xml.XmlElement _
) As System.Boolean
public System.bool WriteXml(
   System.Xml.XmlElement baseNode
)

Parameters

baseNode
The base node of the XML element.
See Also

Reference

Parameter Class
Parameter Members


Parameter Class Properties

Parameter Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Parameter Class

For a list of all members of this type, see Parameter members.

Public Properties
 | Name | Description
Public Property | DefaultValue | Gets or sets a value to be used as the default value in the parameters input dialog.
Public Property | Key | Unique name of the parameter.
Public Property | Prompt | Parameter caption used in the parameters input dialog to prompt the user to input a parameter value.
Public Property | PromptUser | Determines whether to prompt the user to input a parameter value.
Public Property | QueryCreated | Determines whether the query is created from the data source query string or user created.
Public Property | Tag | User-defined value.
Public Property | Type | Gets or sets a value that determines the type of input control to be created to collect the parameter value from the user.
Public Property | Value | Gets or sets the value of the parameter to be used in parameter placeholder substitution.
Top
See Also

Reference

Parameter Class
GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.ParameterCollection
Parameters Property


DefaultValue Property (Parameter)

DefaultValue Property (Parameter)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : DefaultValue Property
Gets or sets a value to be used as the default value in the parameters input dialog.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultValue As System.String
public System.string DefaultValue {get; set;}

Property Value

A string value specifying the default value of the parameter.
Remarks
If the user does not specify a value, the DefaultValue will be used.
Example
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.Parameters[0].DefaultValue = "Germany";
    this.Parameters[0].Key = "country";
    this.Parameters[0].Prompt = "Country: ";
    this.Parameters[0].Tag = "some extra data";
    this.Parameters[0].Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String;
}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Parameters(0).DefaultValue = "Germany"
    Me.Parameters(0).Key = "country"
    Me.Parameters(0).Prompt = "Country: "
    Me.Parameters(0).Tag = "Some extra data"
    Me.Parameters(0).Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String
End Sub
See Also

Reference

Parameter Class
Parameter Members


Key Property (Parameter)

Key Property (Parameter)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Key Property
Unique name of the parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Key As System.String
public System.string Key {get; set;}

Property Value

A string value that represents the unique name of the parameter.
Remarks
Used to reference the parameter in the parameters collection and to locate the different placeholder locations in the SQL query where the parameter value will be inserted.
Example
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.Parameters[0].DefaultValue = "Germany";
    this.Parameters[0].Key = "country";
    this.Parameters[0].Prompt = "Country: ";
    this.Parameters[0].Tag = "some extra data";
    this.Parameters[0].Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String;
}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Parameters(0).DefaultValue = "Germany"
    Me.Parameters(0).Key = "country"
    Me.Parameters(0).Prompt = "Country: "
    Me.Parameters(0).Tag = "Some extra data"
    Me.Parameters(0).Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String
End Sub
See Also

Reference

Parameter Class
Parameter Members


Prompt Property (Parameter)

Prompt Property (Parameter)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Prompt Property
Parameter caption used in the parameters input dialog to prompt the user to input a parameter value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Prompt As System.String
public System.string Prompt {get; set;}

Property Value

A string value used to prompt the user for a parameter value.
Example
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.Parameters[0].DefaultValue = "Germany";
    this.Parameters[0].Key = "country";
    this.Parameters[0].Prompt = "Country: ";
    this.Parameters[0].Tag = "some extra data";
    this.Parameters[0].Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String;
}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Parameters(0).DefaultValue = "Germany"
    Me.Parameters(0).Key = "country"
    Me.Parameters(0).Prompt = "Country: "
    Me.Parameters(0).Tag = "Some extra data"
    Me.Parameters(0).Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String
End Sub
See Also

Reference

Parameter Class
Parameter Members


PromptUser Property (Parameter)

PromptUser Property (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : PromptUser Property
Determines whether to prompt the user to input a parameter value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PromptUser As System.Boolean
public System.bool PromptUser {get; set;}
Remarks
The default value is True. If the value is set to False, the Prompt property is ignored.
See Also

Reference

Parameter Class
Parameter Members


QueryCreated Property

QueryCreated Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : QueryCreated Property
Determines whether the query is created from the data source query string or user created.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property QueryCreated As System.Boolean
public System.bool QueryCreated {get; set;}

Property Value

True if created from the data source SQL query string; False if user created.
See Also

Reference

Parameter Class
Parameter Members


Tag Property (Parameter)

Tag Property (Parameter)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Tag Property
User-defined value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Tag As System.Object
public System.object Tag {get; set;}
Remarks
Use for your own purposes.
Example
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.Parameters[0].DefaultValue = "Germany";
    this.Parameters[0].Key = "country";
    this.Parameters[0].Prompt = "Country: ";
    this.Parameters[0].Tag = "some extra data";
    this.Parameters[0].Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String;
}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Parameters(0).DefaultValue = "Germany"
    Me.Parameters(0).Key = "country"
    Me.Parameters(0).Prompt = "Country: "
    Me.Parameters(0).Tag = "Some extra data"
    Me.Parameters(0).Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String
End Sub
See Also

Reference

Parameter Class
Parameter Members


Type Property (Parameter)

Type Property (Parameter)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Type Property

Gets or sets a value that determines the type of input control to be created to collect the parameter value from the user.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Type As Parameter.DataType
public Parameter.DataType Type {get; set;}

Property Value

A DataType enumeration value that determines the type of control to be created for the parameters input dialog.
Remarks
ActiveReports creates the parameters intput dialog for the user dynamically based on the number of parameters and their type. By default, all parameters are considered strings. You can specify a Boolean control (checkbox) or a Date (calendar) control instead of a standard textbox.
Example
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.Parameters[0].DefaultValue = "Germany";
    this.Parameters[0].Key = "country";
    this.Parameters[0].Prompt = "Country: ";
    this.Parameters[0].Tag = "some extra data";
    this.Parameters[0].Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String;
}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
    Me.Parameters(0).DefaultValue = "Germany"
    Me.Parameters(0).Key = "country"
    Me.Parameters(0).Prompt = "Country: "
    Me.Parameters(0).Tag = "Some extra data"
    Me.Parameters(0).Type = GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType.String
End Sub
See Also

Reference

Parameter Class
Parameter Members
ActiveReports6~GrapeCity.ActiveReports.Parameter+DataType


Value Property (Parameter)

Value Property (Parameter)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Value Property
Gets or sets the value of the parameter to be used in parameter placeholder substitution.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As System.String
public System.string Value {get; set;}

Property Value

A string value that is used to replace the parameter placeholder text in the report's data source SQL query.
Example
  • C#
private void button1_Click(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Parameters["country"].Value = "Germany";
    rpt.Run();
    arv.Document = rpt.Document;
}
  • Visual Basic
Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
    Dim rpt As New SectionReport1
    rpt.Parameters("country").Value = "Germany"
    rpt.Run()
    arv.Document = rpt.Document
End Sub
See Also

Reference

Parameter Class
Parameter Members


Parameter Class Events

Parameter Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Parameter Class

For a list of all members of this type, see Parameter members.

Public Events
 | Name | Description
Public Event | Disposed | Adds an event handler to listen to the Disposed event on the component.
Top
See Also

Reference

Parameter Class
GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.ParameterCollection
Parameters Property


Disposed Event (Parameter)

Disposed Event (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Disposed Event
Adds an event handler to listen to the Disposed event on the component.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Parameter Class
Parameter Members


ParameterCollection Class

ParameterCollection Class
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ParameterCollection Class
Represents the collection of parameters that ActiveReports parses from the parameter placeholders in the data source SQL query.
Object Model
ParameterCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ParameterCollection
   Inherits System.Collections.CollectionBase
public class ParameterCollection : System.Collections.CollectionBase
Remarks

ActiveReports parses the data source SQL query for the following parameters placeholder syntax, and it uses that syntax to create the parameters collection before the data source is accessed. Only the Name is required.

<%Name | PromptString | DefaultValue | DataType | PromptUser%>

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ParameterCollection

See Also

Reference

ParameterCollection Members
GrapeCity.ActiveReports.SectionReportModel Namespace
Parameters Property


ParameterCollection Class Members

ParameterCollection Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ParameterCollection Class

The following tables list the members exposed by ParameterCollection.

Public Constructors
 | Name | Description
Public Constructor | ParameterCollection Constructor | Initializes a new instance of the ParameterCollection class.
Top
Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Returns a reference to the specified Parameter.
Public Property | ParseResult | Returns the results of parsing the report's parameter values.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a Parameter object to the Parameter collection.
Public Method | AddRange | Overloaded. Adds a range of Parameter objects to the Parameter collection.
Public Method | AtLeastOneNeedsPrompt | Determines whether the prompt is needed. If the PromptUser property of one of the parameters in the collection is set to true, the prompt is returned.
Public Method | AtLeastOneQueryCreated | Determines whether a query for the parameters in the collection has been created.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the collection contains the specified parameter.
Public Method | Dispose | Releases the ParameterCollection from memory.
Public Method | IndexOf | Returns the index of the specified Parameter object in the collection.
Public Method | Insert | Inserts a Parameter object into the collection at the specified index.
Public Method | Remove | Removes a parameter from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
Public Events
 | Name | Description
Public Event | Modified | Is raised when the Parameter collection is modified.
Top
See Also

Reference

ParameterCollection Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Parameters Property


ParameterCollection Constructor

ParameterCollection Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : ParameterCollection Constructor
The parent object of the parameter collection.
Initializes a new instance of the ParameterCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal parent As System.ComponentModel.IComponent _
)
public ParameterCollection(
   System.ComponentModel.IComponent parent
)

Parameters

parent
The parent object of the parameter collection.
See Also

Reference

ParameterCollection Class
ParameterCollection Members


ParameterCollection Class Methods

ParameterCollection Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ParameterCollection Class

For a list of all members of this type, see ParameterCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a Parameter object to the Parameter collection.
Public Method | AddRange | Overloaded. Adds a range of Parameter objects to the Parameter collection.
Public Method | AtLeastOneNeedsPrompt | Determines whether the prompt is needed. If the PromptUser property of one of the parameters in the collection is set to true, the prompt is returned.
Public Method | AtLeastOneQueryCreated | Determines whether a query for the parameters in the collection has been created.
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether the collection contains the specified parameter.
Public Method | Dispose | Releases the ParameterCollection from memory.
Public Method | IndexOf | Returns the index of the specified Parameter object in the collection.
Public Method | Insert | Inserts a Parameter object into the collection at the specified index.
Public Method | Remove | Removes a parameter from the collection.
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ParameterCollection Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Parameters Property


Add Method (ParameterCollection)

Add Method (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Add Method
The parameter object to be added to the collection.
Adds a Parameter object to the Parameter collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal parameter As Parameter _
) As System.Integer
public System.int Add(
   Parameter parameter
)

Parameters

parameter
The parameter object to be added to the collection.
See Also

Reference

ParameterCollection Class
ParameterCollection Members


AddRange Method (ParameterCollection)

AddRange Method (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : AddRange Method
Adds a range of Parameter objects to the Parameter collection.
Adds a range of Parameter objects to the Parameter collection.
Overload List
Overload | Description
AddRange(Parameter[]) | Adds a range of Parameter objects to the Parameter collection.
AddRange(ParameterCollection) | Adds a ParameterCollection object to the Parameter collection.
See Also

Reference

ParameterCollection Class
ParameterCollection Members


AddRange(Parameter[]) Method

AddRange(Parameter[]) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class > AddRange Method : AddRange(Parameter[]) Method
The range of parameters to add.
Adds a range of Parameter objects to the Parameter collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddRange( _
   ByVal parameters() As Parameter _
)
public void AddRange(
   Parameter[] parameters
)

Parameters

parameters
The range of parameters to add.
See Also

Reference

ParameterCollection Class
ParameterCollection Members
Overload List


AddRange(ParameterCollection) Method

AddRange(ParameterCollection) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class > AddRange Method : AddRange(ParameterCollection) Method
The ParameterCollection object to add.
Adds a ParameterCollection object to the Parameter collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddRange( _
   ByVal parameters As ParameterCollection _
)
public void AddRange(
   ParameterCollection parameters
)

Parameters

parameters
The ParameterCollection object to add.
See Also

Reference

ParameterCollection Class
ParameterCollection Members
Overload List


AtLeastOneNeedsPrompt Method

AtLeastOneNeedsPrompt Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : AtLeastOneNeedsPrompt Method
Determines whether the prompt is needed. If the PromptUser property of one of the parameters in the collection is set to true, the prompt is returned.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function AtLeastOneNeedsPrompt() As System.Boolean
public System.bool AtLeastOneNeedsPrompt()
See Also

Reference

ParameterCollection Class
ParameterCollection Members


AtLeastOneQueryCreated Method

AtLeastOneQueryCreated Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : AtLeastOneQueryCreated Method
Determines whether a query for the parameters in the collection has been created.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function AtLeastOneQueryCreated() As System.Boolean
public System.bool AtLeastOneQueryCreated()
See Also

Reference

ParameterCollection Class
ParameterCollection Members


Contains Method (ParameterCollection)

Contains Method (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Contains Method
The parameter to find in the collection.
Determines whether the collection contains the specified parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal parameter As Parameter _
) As System.Boolean
public System.bool Contains(
   Parameter parameter
)

Parameters

parameter
The parameter to find in the collection.

Return Value

True if the collection contains the parameter; otherwise, False.
See Also

Reference

ParameterCollection Class
ParameterCollection Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Dispose() Method
Releases the ParameterCollection from memory.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

ParameterCollection Class
ParameterCollection Members


IndexOf Method (ParameterCollection)

IndexOf Method (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : IndexOf Method
Specifies the Parameter object for which to search.
Returns the index of the specified Parameter object in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal parameter As Parameter _
) As System.Integer
public System.int IndexOf(
   Parameter parameter
)

Parameters

parameter
Specifies the Parameter object for which to search.

Return Value

An integer specifying the index of the specified Parameter.
See Also

Reference

ParameterCollection Class
ParameterCollection Members


Insert Method (ParameterCollection)

Insert Method (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Insert Method
The index at which the parameter is inserted
The parameter to insert.
Inserts a Parameter object into the collection at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal parameter As Parameter _
)
public void Insert(
   System.int index,
   Parameter parameter
)

Parameters

index
The index at which the parameter is inserted
parameter
The parameter to insert.
See Also

Reference

ParameterCollection Class
ParameterCollection Members


Remove Method (ParameterCollection)

Remove Method (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Remove Method
The parameter to be removed.
Removes a parameter from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal parameter As Parameter _
)
public void Remove(
   Parameter parameter
)

Parameters

parameter
The parameter to be removed.
See Also

Reference

ParameterCollection Class
ParameterCollection Members


ParameterCollection Class Properties

ParameterCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ParameterCollection Class

For a list of all members of this type, see ParameterCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Returns a reference to the specified Parameter.
Public Property | ParseResult | Returns the results of parsing the report's parameter values.
Top
See Also

Reference

ParameterCollection Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Parameters Property


Item Property (ParameterCollection)

Item Property (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Item Property
Returns a reference to the specified Parameter.
Overload List
Overload | Description
Item(Int32) | Gets the Parameters object at the specified indexed location in the Parameters collection.
Item(String) | Gets the Parameter object with the specified key in the Parameters collection.
See Also

Reference

ParameterCollection Class
ParameterCollection Members


Item(Int32) Property

Item(Int32) Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class > Item Property : Item(Int32) Property
Specifies the index of the requested parameter in the collection.
Gets the Parameters object at the specified indexed location in the Parameters collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal index As System.Integer _
) As Parameter
public Parameter Item(
   System.int index
) {get;}

Parameters

index
Specifies the index of the requested parameter in the collection.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    System.Windows.Forms.MessageBox.Show (rpt.Parameters[0].Type.ToString());
    rpt.Run();
    this.arv.Document = rpt.Document;
}
  • Visual Basic
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    MsgBox(rpt.Parameters.Item(0).Type.ToString)
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
End Sub
See Also

Reference

ParameterCollection Class
ParameterCollection Members
Overload List


Item(String) Property

Item(String) Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class > Item Property : Item(String) Property
Specifies the key of the requested parameter.
Gets the Parameter object with the specified key in the Parameters collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal key As System.String _
) As Parameter
public Parameter Item(
   System.string key
) {get;}

Parameters

key
Specifies the key of the requested parameter.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    System.Windows.Forms.MessageBox.Show (rpt.Parameters["country"].Type.ToString());
    rpt.Run();
    this.arv.Document = rpt.Document;
}
  • Visual Basic
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    MsgBox(rpt.Parameters.Item("country").Type.ToString)
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
End Sub
See Also

Reference

ParameterCollection Class
ParameterCollection Members
Overload List


ParseResult Property

ParseResult Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : ParseResult Property
Returns the results of parsing the report's parameter values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ParseResult As ParameterCollection.ParseResultCode
public ParameterCollection.ParseResultCode ParseResult {get;}

Property Value

Parameters.ParseResultCode enumeration.
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Run();
    if (rpt.Parameters.ParseResult == GrapeCity.ActiveReports.SectionReportModel.ParameterCollection.ParseResultCode.Success)
    {
        System.Windows.Forms.MessageBox.Show("success!");
    }
    else if (rpt.Parameters.ParseResult == GrapeCity.ActiveReports.SectionReportModel.ParameterCollection.ParseResultCode.MissingCloseParam)
    {
        System.Windows.Forms.MessageBox.Show("missingCloseParam");
    }
    else if (rpt.Parameters.ParseResult == GrapeCity.ActiveReports.SectionReportModel.ParameterCollection.ParseResultCode.MissingParamName)
    {
        System.Windows.Forms.MessageBox.Show("missingCloseParamName");
    }
    this.arv.Document = rpt.Document;
}
  • Visual Basic
Private Sub Viewer1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Viewer1.Load
    Dim rpt As New SectionReport1
    rpt.Run()
    If rpt.Parameters.ParseResult = rpt.ParameterCollection.ParseResultCode.Success Then
        MessageBox.Show("success!")
    ElseIf rpt.Parameters.ParseResult = rpt.ParameterCollection.ParseResultCode.MissingCloseParam Then
        MessageBox.Show("missingCloseParam")
    ElseIf rpt.Parameters.ParseResult = rpt.ParameterCollection.ParseResultCode.MissingParamName Then
        MessageBox.Show("missingCloseParamName")
    End If
    Me.Viewer1.Document = rpt.Document
End Sub
See Also

Reference

ParameterCollection Class
ParameterCollection Members
ActiveReports6~GrapeCity.ActiveReports.ParameterCollection~ParseResult


ParameterCollection Class Events

ParameterCollection Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ParameterCollection Class

For a list of all members of this type, see ParameterCollection members.

Public Events
 | Name | Description
Public Event | Modified | Is raised when the Parameter collection is modified.
Top
See Also

Reference

ParameterCollection Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Parameters Property


Modified Event

Modified Event

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Modified Event
Is raised when the Parameter collection is modified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Modified As System.EventHandler
public event System.EventHandler Modified
See Also

Reference

ParameterCollection Class
ParameterCollection Members


Picture Class

Picture Class
Members Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Picture Class
Prints an image on the report.
Object Model
Picture Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Picture
   Inherits ARControl
public sealed class Picture : ARControl
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.BackColor = System.Drawing.Color.Transparent;
    this.picture1.HyperLink = "mailto:support@company.com";
    this.picture1.Image = System.Drawing.Image.FromFile("\\mycompany.gif");
    this.picture1.LineColor = System.Drawing.Color.Navy;
    this.picture1.LineStyle = LineStyle.Solid;
    this.picture1.LineWeight = 2.0f;
    this.picture1.PictureAlignment = PictureAlignment.Center;
    this.picture1.SizeMode = SizeModes.Clip;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.BackColor = System.Drawing.Color.Transparent
   Me.Picture1.HyperLink = "mailto:support@company.com"
   Me.Picture1.Image = System.Drawing.Image.FromFile("c:\mycompany.gif")
   Me.Picture1.LineColor = System.Drawing.Color.Navy
   Me.Picture1.LineStyle = LineStyle.Solid
   Me.Picture1.LineWeight = 2.0F
   Me.Picture1.PictureAlignment = PictureAlignment.Center
   Me.Picture1.SizeMode = SizeModes.Clip
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.Picture

See Also

Reference

Picture Members
GrapeCity.ActiveReports.SectionReportModel Namespace


Picture Class Members

Picture Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Picture Class

The following tables list the members exposed by Picture.

Public Constructors
 | Name | Description
Public Constructor | Picture Constructor | Initializes a new instance of the Picture class.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Description | Gets or sets the alternate description for the picture. Used in the Html Export for the "alt" img tag property.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | HyperLink | Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Public Property | Image | Gets or sets the Image to be printed in the Picture control.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | LineColor | Gets or sets the border line color around the picture control.
Public Property | LineStyle | Gets or sets the pen style used to paint the border around the picture control.
Public Property | LineWeight | Gets or sets the pen width of the line in pixels.
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | PictureAlignment | Gets or sets the position of the image within the control area.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | SizeMode | Gets or sets a value that determines how the image is sized to fit the Picture control area.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Title | Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose() | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | ResetImage | Sets the current image to null.
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

Picture Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Picture Constructor

Picture Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : Picture Constructor
Initializes a new instance of the Picture class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Picture()
See Also

Reference

Picture Class
Picture Members


Picture Class Methods

Picture Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Picture Class

For a list of all members of this type, see Picture members.

Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose() | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | ResetImage | Sets the current image to null.
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

Picture Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ResetImage Method

ResetImage Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : ResetImage Method
Sets the current image to null.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ResetImage()
public void ResetImage()
Example
  • C#
private void groupHeader1_Format(object sender, System.EventArgs eArgs)
{
    if (this.txtCountry.Value.ToString() == "France")
    {
        this.picture1.ResetImage();
    }
    else
    {
        this.picture1.Image = System.Drawing.Image.FromFile("c:\\DSCF2183.JPG");
    }
}
  • Visual Basic
Private Sub GroupHeader1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupHeader1.Format
    If Me.txtCountry.Value.ToString = "France" Then
        Me.Picture1.ResetImage()
    Else
        Me.Picture1.Image = System.Drawing.Image.FromFile("c:\DSCF2183.JPG")
    End If
End Sub
See Also

Reference

Picture Class
Picture Members
ActiveReports6~GrapeCity.ActiveReports.Picture~Image


Picture Class Properties

Picture Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Picture Class

For a list of all members of this type, see Picture members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Description | Gets or sets the alternate description for the picture. Used in the Html Export for the "alt" img tag property.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | HyperLink | Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Public Property | Image | Gets or sets the Image to be printed in the Picture control.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | LineColor | Gets or sets the border line color around the picture control.
Public Property | LineStyle | Gets or sets the pen style used to paint the border around the picture control.
Public Property | LineWeight | Gets or sets the pen width of the line in pixels.
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | PictureAlignment | Gets or sets the position of the image within the control area.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | SizeMode | Gets or sets a value that determines how the image is sized to fit the Picture control area.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Title | Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

Picture Class
GrapeCity.ActiveReports.SectionReportModel Namespace


BackColor Property (Picture)

BackColor Property (Picture)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : BackColor Property
Gets or sets the background color of the control area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackColor As Color
public Color BackColor {get; set;}

Property Value

System.Drawing.Color. The default value is Color.Transparent.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.BackColor = System.Drawing.Color.Transparent;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.BackColor = System.Drawing.Color.Transparent
End Sub
See Also

Reference

Picture Class
Picture Members


Description Property (Picture)

Description Property (Picture)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : Description Property
Gets or sets the alternate description for the picture. Used in the Html Export for the "alt" img tag property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Description As System.String
public System.string Description {get; set;}
See Also

Reference

Picture Class
Picture Members


HyperLink Property (Picture)

HyperLink Property (Picture)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : HyperLink Property
Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HyperLink As System.String
public System.string HyperLink {get; set;}
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.HyperLink = "mailto:support@company.com";
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.HyperLink = "mailto:support@company.com"
End Sub
Requirements
Note: When using the HtmlViewer, the RawHtml, the Flash Viewer or the Silverlight Viewer to display a report, you should indicate the full URL address (for example, "http://www.grapecity.com/") for this property.
See Also

Reference

Picture Class
Picture Members
HyperLinkEventArgs


Image Property (Picture)

Image Property (Picture)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : Image Property
Gets or sets the Image to be printed in the Picture control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Image As Image
public Image Image {get; set;}

Property Value

A System.Drawing.Image value that represents the image to be printed in the Picture control.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.Image = System.Drawing.Image.FromFile("\\mycompany.gif");
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.Image = System.Drawing.Image.FromFile("c:\mycompany.gif")
End Sub
See Also

Reference

Picture Class
Picture Members


LineColor Property (Picture)

LineColor Property (Picture)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : LineColor Property
Gets or sets the border line color around the picture control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineColor As Color
public Color LineColor {get; set;}

Property Value

A System.Drawing.Color value that represents the color used to paint the picture border. Default value is Color.Transparent.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.LineColor = System.Drawing.Color.Navy;
    this.picture1.LineStyle = LineStyle.Solid;
    this.picture1.LineWeight = 2.0f;
}
  • Visual Basic
Private Sub Detai1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.LineColor = System.Drawing.Color.Navy
   Me.Picture1.LineStyle = LineStyle.Solid
   Me.Picture1.LineWeight = 2.0F
End Sub
See Also

Reference

Picture Class
Picture Members
ActiveReports6~GrapeCity.ActiveReports.Picture~LineStyle
ActiveReports6~GrapeCity.ActiveReports.Picture~LineWeight


LineStyle Property (Picture)

LineStyle Property (Picture)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : LineStyle Property
Gets or sets the pen style used to paint the border around the picture control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineStyle As LineStyle
public LineStyle LineStyle {get; set;}

Property Value

A LineStyle enumeration value. Default is LineStyle.Transparent.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.LineColor = System.Drawing.Color.Navy;
    this.picture1.LineStyle = LineStyle.Solid;
    this.picture1.LineWeight = 2.0f;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.LineColor = System.Drawing.Color.Navy
   Me.Picture1.LineStyle = LineStyle.Solid
   Me.Picture1.LineWeight = 2.0F
End Sub
See Also

Reference

Picture Class
Picture Members
ActiveReports6~GrapeCity.ActiveReports.LineStyle
ActiveReports6~GrapeCity.ActiveReports.Picture~LineColor
ActiveReports6~GrapeCity.ActiveReports.Picture~LineWeight


LineWeight Property (Picture)

LineWeight Property (Picture)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : LineWeight Property
Gets or sets the pen width of the line in pixels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineWeight As System.Single
public System.float LineWeight {get; set;}

Property Value

Float value that represents the current width of the line in pixels.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.LineColor = System.Drawing.Color.Navy;
    this.picture1.LineStyle = LineStyle.Solid;
    this.picture1.LineWeight = 2.0f;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.LineColor = System.Drawing.Color.Navy
   Me.Picture1.LineStyle = LineStyle.Solid
   Me.Picture1.LineWeight = 2.0F
End Sub
See Also

Reference

Picture Class
Picture Members


PictureAlignment Property (Picture)

PictureAlignment Property (Picture)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : PictureAlignment Property
Gets or sets the position of the image within the control area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PictureAlignment As PictureAlignment
public PictureAlignment PictureAlignment {get; set;}

Property Value

A PictureAlignment enumeration member that specifies the alignment of the picture.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.PictureAlignment = PictureAlignment.Center;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.PictureAlignment = PictureAlignment.Center
End Sub
See Also

Reference

Picture Class
Picture Members


SizeMode Property (Picture)

SizeMode Property (Picture)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : SizeMode Property
Gets or sets a value that determines how the image is sized to fit the Picture control area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SizeMode As SizeModes
public SizeModes SizeMode {get; set;}

Property Value

A SizeModes enumeration value. The default value is SizeModes.Clip
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.picture1.SizeMode = SizeModes.Clip;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Picture1.SizeMode = SizeModes.Clip
End Sub
See Also

Reference

Picture Class
Picture Members


Title Property (Picture)

Title Property (Picture)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : Title Property
Gets or sets a URL address that can be used in the viewer's HyperLink event to navigate to the specified location. The URL is automatically converted into an anchor tag or a hyperlink in HTML and PDF exports.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Title As System.String
public System.string Title {get; set;}
See Also

Reference

Picture Class
Picture Members


ReportFooter Class

ReportFooter Class
Members Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportFooter Class
The ReportFooter section prints once at the end of the report.
Object Model
ReportFooter Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ReportFooter
   Inherits Section
public class ReportFooter : Section
Remarks
Use this section to print the summary of the report and include any grand summary calculations.
Example
  • C#
private void ReportFooter_Format(object sender, System.EventArgs eArgs)
{
    this.reportFooter1.KeepTogether = true;
    this.reportFooter1.NewPage = NewPage.None;
    this.reportFooter1.PrintAtBottom = true;
}
  • Visual Basic
Private Sub ReportFooter_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ReportFooter.Format
    Me.ReportFooter.KeepTogether = True
    Me.ReportFooter.NewPage = NewPage.None
    Me.ReportFooter.PrintAtBottom = True
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.ReportFooter

See Also

Reference

ReportFooter Members
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportFooter Class Members

ReportFooter Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportFooter Class

The following tables list the members exposed by ReportFooter.

Public Constructors
 | Name | Description
Public Constructor | ReportFooter Constructor | Initializes a new instance of the ReportFooter class.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Height | Gets ot sets the height of the report footer section.
Public Property | KeepTogether | Gets or sets a value that determines whether the section should be printed on a single page.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property | PrintAtBottom | Gets or sets a value that specifies whether the section should be printed at the bottom of the page immediately before any page footer section.
Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Visible | Specifies whether the section should be printed or not. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
Public Methods
 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | Dispose | Releases the section instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
Public Events
 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

ReportFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportFooter Constructor

ReportFooter Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportFooter Class : ReportFooter Constructor
Initializes a new instance of the ReportFooter class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ReportFooter()
See Also

Reference

ReportFooter Class
ReportFooter Members


ReportFooter Class Properties

ReportFooter Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportFooter Class

For a list of all members of this type, see ReportFooter members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Height | Gets ot sets the height of the report footer section.
Public Property | KeepTogether | Gets or sets a value that determines whether the section should be printed on a single page.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property | PrintAtBottom | Gets or sets a value that specifies whether the section should be printed at the bottom of the page immediately before any page footer section.
Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Visible | Specifies whether the section should be printed or not. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

ReportFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Height Property (ReportFooter)

Height Property (ReportFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportFooter Class : Height Property
Gets ot sets the height of the report footer section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Property Height As System.Single
public new System.float Height {get; set;}

Property Value

The height.
See Also

Reference

ReportFooter Class
ReportFooter Members


KeepTogether Property (ReportFooter)

KeepTogether Property (ReportFooter)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportFooter Class : KeepTogether Property
Gets or sets a value that determines whether the section should be printed on a single page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property KeepTogether As System.Boolean
public System.bool KeepTogether {get; set;}

Property Value

A Boolean value. True--if the section will print on a single page if its contents permit; otherwise, False.
Remarks

When this property is set to True, ActiveReports will attempt to print the section on the current page. If the contents do not fit on the current page and the current page is not a new page, the section will be moved to the next page. If the section does not fit on the following page, it will be moved back to the its original position and the contents will be split across multiple pages.

Example
  • C#
private void ReportFooter_Format(object sender, System.EventArgs eArgs)
{
    this.reportFooter1.KeepTogether = true;
}
  • Visual Basic
Private Sub ReportFooter_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ReportFooter.Format
    Me.ReportFooter.KeepTogether = True
End Sub
See Also

Reference

ReportFooter Class
ReportFooter Members


NewPage Property (ReportFooter)

NewPage Property (ReportFooter)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportFooter Class : NewPage Property
Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NewPage As NewPage
public NewPage NewPage {get; set;}

Property Value

NewPage Enumeration. Possible values are:

  • NewPage.After
  • NewPage.Before
  • NewPage.BeforeAfter
  • NewPage.None
Example
  • C#
private void ReportFooter_Format(object sender, System.EventArgs eArgs)
{
    this.reportFooter1.NewPage = NewPage.None;
}
  • Visual Basic
Private Sub ReportFooter_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ReportFooter.Format
    Me.ReportFooter.NewPage = NewPage.None
End Sub
See Also

Reference

ReportFooter Class
ReportFooter Members


PrintAtBottom Property (ReportFooter)

PrintAtBottom Property (ReportFooter)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportFooter Class : PrintAtBottom Property
Gets or sets a value that specifies whether the section should be printed at the bottom of the page immediately before any page footer section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrintAtBottom As System.Boolean
public System.bool PrintAtBottom {get; set;}

Property Value

A Boolean value. True-- if the footer section will be printed at the bottom of the page; otherwise, False.
Example
  • C#
private void ReportFooter_Format(object sender, System.EventArgs eArgs)
{
    this.reportFooter1.PrintAtBottom = true;
}
  • Visual Basic
Private Sub ReportFooter_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ReportFooter.Format
    Me.ReportFooter.PrintAtBottom = True
End Sub
See Also

Reference

ReportFooter Class
ReportFooter Members


ReportHeader Class

ReportHeader Class
Members Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportHeader Class
The ReportHeader section is printed once at the beginning of the report.
Object Model
ReportHeader Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ReportHeader
   Inherits Section
public class ReportHeader : Section
Example
  • C#
private void ReportHeader_Format(object sender, System.EventArgs eArgs)
{
    this.reportHeader1.NewPage = NewPage.None;
}
  • Visual Basic
Private Sub ReportHeader_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ReportHeader.Format
   Me.ReportHeader.NewPage = NewPage.None
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.ReportHeader

See Also

Reference

ReportHeader Members
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportHeader Class Members

ReportHeader Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportHeader Class

The following tables list the members exposed by ReportHeader.

Public Constructors
 | Name | Description
Public Constructor | ReportHeader Constructor | Initializes a new instance of the ReportHeader class.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Height | Gets ot sets the height of the report header section.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Visible | Specifies whether the section should be printed or not. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
Public Methods
 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | Dispose | Releases the section instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
Public Events
 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

ReportHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportHeader Constructor

ReportHeader Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportHeader Class : ReportHeader Constructor
Initializes a new instance of the ReportHeader class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ReportHeader()
See Also

Reference

ReportHeader Class
ReportHeader Members


ReportHeader Class Properties

ReportHeader Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportHeader Class

For a list of all members of this type, see ReportHeader members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Controls | Gets a collection of all controls contained in the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Height | Gets ot sets the height of the report header section.
Public Property | Name | Gets or sets the name of the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | NewPage | Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Public Property | Tag | Gets or sets user-defined information to be persisted with the section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Type | Gets the section's type. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Property | Visible | Specifies whether the section should be printed or not. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

ReportHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Height Property (ReportHeader)

Height Property (ReportHeader)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportHeader Class : Height Property
Gets ot sets the height of the report header section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Property Height As System.Single
public new System.float Height {get; set;}

Property Value

The height.
See Also

Reference

ReportHeader Class
ReportHeader Members


NewPage Property (ReportHeader)

NewPage Property (ReportHeader)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportHeader Class : NewPage Property
Gets or sets a value that determines whether a new page should be inserted before and/or after printing the section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NewPage As NewPage
public NewPage NewPage {get; set;}

Property Value

NewPage Enumeration. Possible values are:

  • NewPage.After
  • NewPage.Before
  • NewPage.BeforeAfter
  • NewPage.None
Example
  • C#
private void ReportHeader_Format(object sender, System.EventArgs eArgs)
{
    this.reportHeader1.NewPage = NewPage.None;
}
  • Visual Basic
Private Sub ReportHeader_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ReportHeader.Format
   Me.ReportHeader.NewPage = NewPage.None
End Sub
See Also

Reference

ReportHeader Class
ReportHeader Members


ReportInfo Class

ReportInfo Class
Members Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportInfo Class
The ReportInfo control displays the information specified in the FormatString property.
Object Model
ReportInfo Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ReportInfo
   Inherits ARControl
public sealed class ReportInfo : ARControl
Remarks
Included format strings supply Page N of M and report run date information.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.Font = new System.Drawing.Font("Arial", 10.0f);
    this.reportInfo1.FormatString = "Page {PageNumber} of {PageCount} on {RunDateTime}";
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.ReportInfo1.Font = New System.Drawing.Font("Arial", 10.0f)
    Me.ReportInfo1.FormatString = "Page {PageNumber} of {PageCount} on {RunDateTime}"
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.ReportInfo

See Also

Reference

ReportInfo Members
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportInfo Class Members

ReportInfo Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportInfo Class

The following tables list the members exposed by ReportInfo.

Public Constructors
 | Name | Description
Public Constructor | ReportInfo Constructor | Initializes a new instance of the ReportInfo class.
Top
Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the alignment of text within the bounds of the control.
Public Property | BackColor | Gets or sets the control's background color or fill color.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | CanShrink | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | ClassName | Gets or sets a style rule class name. The style rule is used to format the control.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Font | Gets or returns the font object used to print the control text
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | FormatString | Gets or sets the mask string used to format the text property before placing it in the Text property.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | MultiLine | Gets or sets a value indicating whether the ReportInfo control is multiline enabled.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | RightToLeft | Determines whether text will be displayed in right-to-left order for this control.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Style | Gets or sets a style string for the ReportInfo control.
Public Property | SummaryGroup | Gets or sets the name of the group header section that is used to reset the summary value when calculating subtotals.
Public Property | SummaryRunning | Gets or sets a value that determines whether the data field summary value will be accumulated or reset for each level (detail, group or page).
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Text | Returns the FormatString format associated with the control.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | VerticalAlignment | Gets or sets the position of the control's text vertically within the bounds of the control.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | WrapMode | Sets/gets control's wrap mode using CSS.
Top
Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

ReportInfo Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportInfo Constructor

ReportInfo Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : ReportInfo Constructor
Initializes a new instance of the ReportInfo class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ReportInfo()
See Also

Reference

ReportInfo Class
ReportInfo Members


ReportInfo Class Properties

ReportInfo Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportInfo Class

For a list of all members of this type, see ReportInfo members.

Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the alignment of text within the bounds of the control.
Public Property | BackColor | Gets or sets the control's background color or fill color.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | CanShrink | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | ClassName | Gets or sets a style rule class name. The style rule is used to format the control.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Font | Gets or returns the font object used to print the control text
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | FormatString | Gets or sets the mask string used to format the text property before placing it in the Text property.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | MultiLine | Gets or sets a value indicating whether the ReportInfo control is multiline enabled.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | RightToLeft | Determines whether text will be displayed in right-to-left order for this control.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Style | Gets or sets a style string for the ReportInfo control.
Public Property | SummaryGroup | Gets or sets the name of the group header section that is used to reset the summary value when calculating subtotals.
Public Property | SummaryRunning | Gets or sets a value that determines whether the data field summary value will be accumulated or reset for each level (detail, group or page).
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Text | Returns the FormatString format associated with the control.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | VerticalAlignment | Gets or sets the position of the control's text vertically within the bounds of the control.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | WrapMode | Sets/gets control's wrap mode using CSS.
Top
See Also

Reference

ReportInfo Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Alignment Property (ReportInfo)

Alignment Property (ReportInfo)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : Alignment Property
Gets or sets the alignment of text within the bounds of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Alignment As TextAlignment
public TextAlignment Alignment {get; set;}
See Also

Reference

ReportInfo Class
ReportInfo Members


BackColor Property (ReportInfo)

BackColor Property (ReportInfo)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : BackColor Property
Gets or sets the control's background color or fill color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackColor As Color
public Color BackColor {get; set;}
Example
  • C#
private void detail_Format(object sender, System.EventArgs e)
{
    this.reportInfo1.BackColor = Color.Coral;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ReportInfo1.BackColor = Color.Coral
End Sub
See Also

Reference

ReportInfo Class
ReportInfo Members


CanGrow Property (ReportInfo)

CanGrow Property (ReportInfo)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : CanGrow Property
Determines whether ActiveReports should increase the height of the control based on its content.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CanGrow As System.Boolean
public System.bool CanGrow {get; set;}

Property Value

A Boolean value that determines the behavior of the control. If False, ActiveReports clips the text to fit within the control's predefined height. If True, ActiveReports increases the height of the control and shifts all controls below it to account for the increase in height.
Example
  • C#
private void detail_Format(object sender, System.EventArgs e)
{
    this.reportInfo1.BackColor = Color.Coral;
    this.reportInfo1.CanGrow = true;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ReportInfo1.BackColor = Color.Coral
   Me.ReportInfo1.CanGrow = True
End Sub
See Also

Reference

ReportInfo Class
ReportInfo Members


CanShrink Property (ReportInfo)

CanShrink Property (ReportInfo)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : CanShrink Property
Determines whether ActiveReports should increase the height of the control based on its content.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CanShrink As System.Boolean
public System.bool CanShrink {get; set;}

Property Value

A Boolean value that determines the behavior. If False, ActiveReports does not change the height of the control based on the size of its content. If True, ActiveReports decreases the height of the control and shifts all controls below it to account for the decrease in height.
Example
  • C#
private void detail_Format(object sender, System.EventArgs e)
{
    this.reportInfo1.BackColor = Color.Coral;
    this.reportInfo1.CanGrow = true;
    this.reportInfo1.CanShrink = true;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ReportInfo1.BackColor = Color.Coral
   Me.ReportInfo1.CanGrow = True
   Me.ReportInfo1.CanShrink = True
End Sub
See Also

Reference

ReportInfo Class
ReportInfo Members


ClassName Property (ReportInfo)

ClassName Property (ReportInfo)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : ClassName Property
Gets or sets a style rule class name. The style rule is used to format the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ClassName As System.String
public System.string ClassName {get; set;}

Property Value

String. Style class name. Default value is "Normal".
Remarks
Style classes are defined in the report's Stylesheet.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.ClassName = "Normal";
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ReportInfo1.ClassName = "Normal"
End Sub
See Also

Reference

ReportInfo Class
ReportInfo Members


Font Property (ReportInfo)

Font Property (ReportInfo)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : Font Property
Gets or returns the font object used to print the control text
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Font As Font
public Font Font {get; set;}
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.Font = new System.Drawing.Font("Arial", 10);
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ReportInfo1.Font = New System.Drawing.Font("Arial", 10)
End Sub
See Also

Reference

ReportInfo Class
ReportInfo Members


ForeColor Property (ReportInfo)

ForeColor Property (ReportInfo)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : ForeColor Property
Gets or returns the foreground (font) color of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ForeColor As Color
public Color ForeColor {get; set;}
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.ForeColor = System.Drawing.Color.Firebrick;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.ReportInfo1.ForeColor = System.Drawing.Color.Firebrick
End Sub
See Also

Reference

ReportInfo Class
ReportInfo Members


FormatString Property

FormatString Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : FormatString Property
Gets or sets the mask string used to format the text property before placing it in the Text property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FormatString As System.String
public System.string FormatString {get; set;}
Remarks
The formatting mask can only be used to format numbers and dates. There is no support for formatting alphanumeric strings. The ReportInfo control will display variations of report Page and RunDateTime information.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.Font = New System.Drawing.Font("Arial", 10.0f);
    this.reportInfo1.FormatString = "Page {PageNumber} of {PageCount} on {RunDateTime}";
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.ReportInfo1.Font = New System.Drawing.Font("Arial", 10.0f)
    Me.ReportInfo1.FormatString = "Page {PageNumber} of {PageCount} on {RunDateTime}"
End Sub
See Also

Reference

ReportInfo Class
ReportInfo Members


MultiLine Property (ReportInfo)

MultiLine Property (ReportInfo)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : MultiLine Property
Gets or sets a value indicating whether the ReportInfo control is multiline enabled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MultiLine As System.Boolean
public System.bool MultiLine {get; set;}
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.FormatString = "{RunDateTime:M/d/yy h:mm}";
    this.reportInfo1.MultiLine = true;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.ReportInfo1.FormatString = "{RunDateTime:M/d/yy h:mm}"
    Me.ReportInfo1.MultiLine = True
End Sub
See Also

Reference

ReportInfo Class
ReportInfo Members


RightToLeft Property (ReportInfo)

RightToLeft Property (ReportInfo)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : RightToLeft Property
Determines whether text will be displayed in right-to-left order for this control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RightToLeft As System.Boolean
public System.bool RightToLeft {get; set;}
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.RightToLeft = false;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.ReportInfo1.RightToLeft = False
End Sub
See Also

Reference

ReportInfo Class
ReportInfo Members


Style Property (ReportInfo)

Style Property (ReportInfo)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : Style Property
Gets or sets a style string for the ReportInfo control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As System.String
public System.string Style {get; set;}
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.Style = "color: Firebrick; text-align: center;";
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.ReportInfo1.Style = "color: FireBrick; text-align: center;"
End Sub
See Also

Reference

ReportInfo Class
ReportInfo Members


SummaryGroup Property (ReportInfo)

SummaryGroup Property (ReportInfo)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : SummaryGroup Property
Gets or sets the name of the group header section that is used to reset the summary value when calculating subtotals.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SummaryGroup As System.String
public System.string SummaryGroup {get; set;}

Property Value

The summary group.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.SummaryGroup = null;
    this.reportInfo1.SummaryRunning = SummaryRunning.None;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ReportInfo1.SummaryGroup = Nothing
   Me.ReportInfo1.SummaryRunning = SummaryRunning.None
End Sub
See Also

Reference

ReportInfo Class
ReportInfo Members


SummaryRunning Property (ReportInfo)

SummaryRunning Property (ReportInfo)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : SummaryRunning Property
Gets or sets a value that determines whether the data field summary value will be accumulated or reset for each level (detail, group or page).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SummaryRunning As SummaryRunning
public SummaryRunning SummaryRunning {get; set;}
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.SummaryGroup = null;
    this.reportInfo1.SummaryRunning = SummaryRunning.None;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ReportInfo1.SummaryGroup = Nothing
   Me.ReportInfo1.SummaryRunning = SummaryRunning.None
End Sub
See Also

Reference

ReportInfo Class
ReportInfo Members


Text Property (ReportInfo)

Text Property (ReportInfo)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : Text Property
Returns the FormatString format associated with the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Text As System.String
public System.string Text {get;}
See Also

Reference

ReportInfo Class
ReportInfo Members


VerticalAlignment Property (ReportInfo)

VerticalAlignment Property (ReportInfo)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : VerticalAlignment Property
Gets or sets the position of the control's text vertically within the bounds of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property VerticalAlignment As VerticalTextAlignment
public VerticalTextAlignment VerticalAlignment {get; set;}

Property Value

VerticalTextAlignment enumeration value that represents the vertical alignment of the control's text. Default is VerticalTextAlignment.Top.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.reportInfo1.VerticalAlignment = VerticalTextAlignment.Top;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.ReportInfo1.VerticalAlignment = VerticalTextAlignment.Top
End Sub
See Also

Reference

ReportInfo Class
ReportInfo Members


WrapMode Property (ReportInfo)

WrapMode Property (ReportInfo)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ReportInfo Class : WrapMode Property
Sets/gets control's wrap mode using CSS.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WrapMode As WrapMode
public WrapMode WrapMode {get; set;}
See Also

Reference

ReportInfo Class
ReportInfo Members


RichTextBox Class

RichTextBox Class
Members Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RichTextBox Class
Prints text formatted as Rich Text (RTF) on the report.
Object Model
RichTextBox Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class RichTextBox
   Inherits ARControl
public sealed class RichTextBox : ARControl
Example
  • C#
private void ghCustomerID_Format(object sender, System.EventArgs eArgs)
{
    this.rtf.BackColor = System.Drawing.Color.RosyBrown;
    this.rtf.BulletIndent = 0.5f;
    this.rtf.CanGrow = true;
    this.rtf.CanShrink = false;
    this.rtf.Clear(); //Clears the content of the RichTextBox;
    this.rtf.Find("Germany");
    this.rtf.ForeColor = System.Drawing.Color.Black;
    this.rtf.InsertField("Phone");
    this.rtf.LoadFile(System.Windows.Forms.Application.StartupPath + " \\Letter.rtf"); //Loads the specified file into the RTF control
    this.rtf.MaxLength = 0;
    this.rtf.Multiline = true;
    this.rtf.RTF = "RTF Contents";
    this.rtf.SelectedText.ToString();
    this.rtf.SelectionAlignment = TextAlignment.Left;
    this.rtf.SelectionBackColor = System.Drawing.Color.RosyBrown;
    this.rtf.SelectionBullet = false;
    this.rtf.SelectionCharOffset = 0;
    this.rtf.SelectionColor = System.Drawing.Color.Blue;
    this.rtf.SelectionFont.ToString();
    this.rtf.SelectionHangingIndent = 3;
    this.rtf.SelectionIndent = 0;
    this.rtf.SelectionLength.ToString();
    this.rtf.SelectionRightIndent = 3;
    this.rtf.SelectionStart = 5;
    this.rtf.Text = "RTF Text";
}
  • Visual Basic
Private Sub ghCustomerID_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ghCustomerID.Format
    Me.rtf.BackColor = System.Drawing.Color.RosyBrown
    Me.rtf.BulletIndent = 0.5
    Me.rtf.CanGrow = True
    Me.rtf.CanShrink = False
    Me.rtf.Clear() 'Clears the content of the RichTextBox
    Me.rtf.Find("Germany")
    Me.rtf.ForeColor = System.Drawing.Color.Black
    Me.rtf.InsertField("Phone")
    Me.rtf.LoadFile(Application.StartupPath + " \Letter.rtf") 'Loads the specified file into the RTF control
    Me.rtf.MaxLength = 0
    Me.rtf.Multiline = True
    Me.rtf.RTF = "RTF Contents"
    Me.rtf.SelectedText.ToString()
    Me.rtf.SelectionAlignment = TextAlignment.Left
    Me.rtf.SelectionBackColor = System.Drawing.Color.RosyBrown
    Me.rtf.SelectionBullet = False
    Me.rtf.SelectionCharOffset = 0
    Me.rtf.SelectionColor = System.Drawing.Color.Blue
    Me.rtf.SelectionFont.ToString()
    Me.rtf.SelectionHangingIndent = 3
    Me.rtf.SelectionIndent = 0
    Me.rtf.SelectionLength.ToString()
    Me.rtf.SelectionRightIndent = 3
    Me.rtf.SelectionStart = 5
    Me.rtf.Text = "RTF Text"
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.RichTextBox

See Also

Reference

RichTextBox Members
GrapeCity.ActiveReports.SectionReportModel Namespace


RichTextBox Class Members

RichTextBox Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RichTextBox Class

The following tables list the members exposed by RichTextBox.

Public Constructors
 | Name | Description
Public Constructor | RichTextBox Constructor | Initializes a new instance of the RichTextBox class.
Top
Public Properties
 | Name | Description
Public Property | AutoReplaceFields | Gets or sets a value that indicates whether ActiveReports should automatically replace fields in the RichTextBox with matching fields in the data source.
Public Property | BackColor | Gets or sets the control's background color or fill color.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | BulletIndent | Gets or sets the indentation used in the control when the bullet style is applied to the text.
Public Property | CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | CanShrink | Determines whether ActiveReports should decrease the height of the field based on its value.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Font | Gets or returns the font object used to print the control text. For design time use only.
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Html | Sets or returns the hypertext to be rendered in the control.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | MaxLength | Gets or sets the maximum number of characters in the control for the End-User Report Designer.
Public Property | Multiline | Gets or sets a value that determines whether the RichTextBox prints multiple lines or single line.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | RTF | Gets or sets the rich text content of the control.
Public Property | SelectedText | Gets or sets the current selected text in the control.
Public Property | SelectionAlignment | Gets or sets the alignment to apply to the current selection or insertion point.
Public Property | SelectionBackColor | Gets or sets the background color of the current text selection.
Public Property | SelectionBullet | Gets or sets a value indicating whether the bullet style is applied to the current selection.
Public Property | SelectionCharOffset | Gets or sets a value indicating where text in the control appears on the baseline, as a superscript or as a subscript below the baseline.
Public Property | SelectionColor | Gets or sets the text color of the current text selection.
Public Property | SelectionFont | Gets or sets the font of the current text selection.
Public Property | SelectionHangingIndent | Gets or sets the distance between the left edge of the first line of text in the selected paragraph and the left edge of subsequent lines in the same paragraph. Renders the selected text the specified number of inches to the left of the RichTextBox.
Public Property | SelectionIndent | Gets or sets the distance in inches between the left edge of the RichTextBox and the left edge of the current text selection. Renders the selected text the specified number of inches to the right of the RichTextBox.
Public Property | SelectionLength | Gets or sets the number of characters selected in control.
Public Property | SelectionRightIndent | The distance (in inches) between the right edge of the RichTextBox control and the right edge of the text that is selected.
Public Property | SelectionStart | Gets or sets the starting point of text selected in the text box.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Text | Gets or sets the current text in the RichTextBox.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Clear | Clears the content of the RichTextBox control.
Public Method | Dispose() | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Find | Overloaded. Searches for text in the content of the RichTextBox control.
Public Method | InsertField | Inserts a RichTextBox merge field into the current location in the text.
Public Method | Load | Loads a stream of Rtf, Text or Html file.
Public Method | LoadFile | Overloaded. Loads an HTML or RTF file.
Public Method | ReplaceField | Merges the contents of the RTF stream with the field values specified.
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

RichTextBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


RichTextBox Constructor

RichTextBox Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : RichTextBox Constructor
Initializes a new instance of the RichTextBox class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public RichTextBox()
See Also

Reference

RichTextBox Class
RichTextBox Members


RichTextBox Class Methods

RichTextBox Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RichTextBox Class

For a list of all members of this type, see RichTextBox members.

Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Clear | Clears the content of the RichTextBox control.
Public Method | Dispose() | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Find | Overloaded. Searches for text in the content of the RichTextBox control.
Public Method | InsertField | Inserts a RichTextBox merge field into the current location in the text.
Public Method | Load | Loads a stream of Rtf, Text or Html file.
Public Method | LoadFile | Overloaded. Loads an HTML or RTF file.
Public Method | ReplaceField | Merges the contents of the RTF stream with the field values specified.
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

RichTextBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Clear Method (RichTextBox)

Clear Method (RichTextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : Clear Method
Clears the content of the RichTextBox control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
Example
  • C#
private void ghCustomerID_Format(object sender, System.EventArgs eArgs)
{
    //Clears the content of the RichTextBox
    this.rtf.Clear();
    //Loads the specified file into the RTF control
    this.rtf.LoadFile(System.Windows.Forms.Application.StartupPath + " \\Letter.rtf");
}
  • Visual Basic
Private Sub ghCustomerID_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ghCustomerID.Format
    'Clears the content of the RichTextBox
    Me.rtf.Clear()
    'Loads the specified file into the RTF control
    Me.rtf.LoadFile(Application.StartupPath + " \Letter.rtf")
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members


Find Method (RichTextBox)

Find Method (RichTextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : Find Method
Searches for text in the content of the RichTextBox control.
Overload List
Overload | Description
Find(Char[]) | Searches the text of a RichTextBox control for the first instance of a character from a list of characters.
Find(String) | Searches the text of the RichTextBox control for a string.
Find(String,Int32) | Searches the text in the RichTextBox control for a specified string starting at a specified location.
Find(String,Int32,FindOptions) | Searches the text in the RichTextBox control for a specified string starting at a specified location and with specific options applied to the search.
Example
  • C#
Private void Detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.RichTextBox1.Find("past due")!= -1)
    {
        this.txtPayNow.Visible=true;
    }
    else
    {
        this.txtPayNow.Visible=false;
    }
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    If Not Me.RichTextBox1.Find("past due") = -1 Then
        Me.txtPayNow.Visible = True
    Else
        Me.txtPayNow.Visible = False
    End If
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members


Find(Char[]) Method

Find(Char[]) Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class > Find Method : Find(Char[]) Method
The array of characters for which to search.
Searches the text of a RichTextBox control for the first instance of a character from a list of characters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Find( _
   ByVal characterSet() As System.Char _
) As System.Integer
public System.int Find(
   System.char[] characterSet
)

Parameters

characterSet
The array of characters for which to search.

Return Value

The location within the control where the search characters were found or a negative one (-1) if the search characters are not found or an empty search character set is specified in the char parameter.

Remarks

This version of the Find method searches for the first instance of a character from a list of characters specified in the characterSet parameter and returns the location of the character. For example, you pass an array of characters containing the character 'Q'. If the control contained the text "The Quick Brown Fox", the Find method would return the value of four. An upper case character and a lower case character are considered different values in the search.

If the property returns a negative value, the characters being searched for were not found within the contents of the control. You can use this method to search for a group of characters within the control. This version of the Find method assumes that the entire document contained in the control is searched for the characters. If a character from the character list provided in the method's characterSet parameter is found, the value returned by this method is a zero-based index of the character's position in the control. A space is considered a character by the method when determining the location of a character.

Example
  • C#
private void ReportHeader_Format(object sender, System.EventArgs eArgs)
{
    char[] ch = {'q'};
    if (!(this.rtbActiveReport.Find(ch) == -1))
    {
        this.rtbActiveReport.SelectionStart = this.rtbActiveReport.Find(ch);
        this.rtbActiveReport.SelectionLength = 2;
        this.rtbActiveReport.SelectionColor = System.Drawing.Color.Crimson;
    }
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Dim ch As New Char
    ch = "q"
    If Not Me.RichTextBox1.Find(ch) = -1 Then
        Me.RichTextBox1.SelectionStart = Me.RichTextBox1.Find(ch)
        Me.RichTextBox1.SelectionLength = 2
        Me.RichTextBox1.SelectionColor = System.Drawing.Color.Crimson
    End If
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members
Overload List


Find(String) Method

Find(String) Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class > Find Method : Find(String) Method

The text to locate in the control.

Searches the text of the RichTextBox control for a string.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Find( _
   ByVal str As System.String _
) As System.Integer
public System.int Find(
   System.string str
)

Parameters

str

The text to locate in the control.

Return Value

The location within the control where the search text was found or a negative one (-1) if the search string is not found or an empty search string is specified in the str parameter.

Remarks

The Find method searches for the text specified in the str parameter and returns the location of the first character within the control. If the property returns a negative value, the text string being searched for was not found within the contents of the control.

Note The Find methods that accept a string as a parameter cannot find text that is contained on more than one line of text within the RichTextBox. Performing such a search will return a value of negative one (-1).
Example
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.RichTextBox1.Find("past due")!= -1)
    {
        this.txtPayNow.Visible=true;
    }
    else
    {
        this.txtPayNow.Visible=false;
    }
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    If Not Me.RichTextBox1.Find("past due") = -1 Then
        Me.txtPayNow.Visible = True
    Else
        Me.txtPayNow.Visible = False
    End If
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members
Overload List


Find(String,Int32) Method

Find(String,Int32) Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class > Find Method : Find(String,Int32) Method
The text to locate in the control.
The location within the control's text at which to begin searching.
Searches the text in the RichTextBox control for a specified string starting at a specified location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Find( _
   ByVal str As System.String, _
   ByVal start As System.Integer _
) As System.Integer
public System.int Find(
   System.string str,
   System.int start
)

Parameters

str
The text to locate in the control.
start
The location within the control's text at which to begin searching.

Return Value

The location within the control where the search text was found.
Remarks

The Find method searches for the text specified in the str parameter and returns the location of the first character within the control. If the property returns a negative value, the text string being searched for was not found within the contents of the control.

Note The Find methods that accept a string as a parameter cannot find text that is contained on more than one line of text within the RichTextBox. Performing such a search will return a value of negative one (-1).
Example
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.RichTextBox1.Find("excellent", 15)!= -1)
    {
        this.txtAward.Visible=true;
    }
    else
    {
        this.txtAward.Visible=false;
    }
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    If Not Me.RichTextBox1.Find("excellent", 15) = -1 Then
        Me.txtAward.Visible = True
    Else
        Me.txtAward.Visible = False
    End If
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members
Overload List


Find(String,Int32,FindOptions) Method

Find(String,Int32,FindOptions) Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class > Find Method : Find(String,Int32,FindOptions) Method
The text to locate in the control.
The location within the control's text at which to begin searching.
A bitwise combination of the FindOptions values.
Searches the text in the RichTextBox control for a specified string starting at a specified location and with specific options applied to the search.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Find( _
   ByVal str As System.String, _
   ByVal start As System.Integer, _
   ByVal findOptions As RichTextBox.FindOptions _
) As System.Integer
public System.int Find(
   System.string str,
   System.int start,
   RichTextBox.FindOptions findOptions
)

Parameters

str
The text to locate in the control.
start
The location within the control's text at which to begin searching.
findOptions
A bitwise combination of the FindOptions values.

Return Value

The location within the control where the search text was found.
Remarks

The Find method searches for the text specified in the str parameter and returns the location of the first character within the control. If the property returns a negative value, the text string being searched for was not found within the contents of the control.

With this version of the Find method, you can specify options that enable you to expand or narrow your search. You can specify options that enable you to match the casing of the search word or to search for entire words instead of partial words. By specifying the FindOptions.Reverse enumeration in the options parameter, you can search for text from the bottom of the document to the top instead of the default top to bottom search method. This version of the Find method also enables you to narrow the search for text by selecting a specific starting position within the control's text. This feature can enable you to avoid text that might have already been searched or where the specific text you are searching for is known not to exist. When the FindOptions.Reverse value is specified in the options parameter, the value of the start parameter indicates the position where the reverse search will end since the search will start at the bottom of the document when using this version of the Find method.

Note The Find methods that accept a string as a parameter cannot find text that is contained on more than one line of text within the RichTextBox. Performing such a search will return a value of negative one (-1).
Example
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.RichTextBox1.Find("expires", 1, RichTextBox.FindOptions.None)!= -1)
    {
        this.RichTextBox1.SelectionStart = this.RichTextBox1.Find("expires", 1, RichTextBox.FindOptions.None);
        this.RichTextBox1.SelectionLength = 7;
        this.RichTextBox1.SelectionColor = System.Drawing.Color.Crimson;
    }
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    If Not Me.RichTextBox1.Find("expires", 1, RichTextBox.FindOptions.None) = -1 Then
        Me.RichTextBox1.SelectionStart = Me.RichTextBox1.Find("expires", 1, RichTextBox.FindOptions.None)
        Me.RichTextBox1.SelectionLength = 7
        Me.RichTextBox1.SelectionColor = System.Drawing.Color.Crimson
    End If
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members
Overload List


InsertField Method

InsertField Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : InsertField Method
Specifies a unique name to be used when to reference this field in the ReplaceField method.
Inserts a RichTextBox merge field into the current location in the text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub InsertField( _
   ByVal fieldName As System.String _
)
public void InsertField(
   System.string fieldName
)

Parameters

fieldName
Specifies a unique name to be used when to reference this field in the ReplaceField method.
Remarks

You can use the InsertField method to create mail-merged content when the text is added to the RichTextBox control at run time. Inserting a mail-merge field adds brackets around the field name and sets the text to protected.

Example
  • C#
private void ghCustomerID_Format(object sender, System.EventArgs eArgs)
{
    this.rtf.ReplaceField("CompanyName", "m_companyName");
    this.rtf.ReplaceField("ContactName", "m_contactName");
    this.rtf.ReplaceField("AddressLine", "m_addressLine");
    this.rtf.ReplaceField("City", "m_city");
    this.rtf.ReplaceField("Region", "m_region");
    this.rtf.ReplaceField("Country", "m_country");
    this.rtf.ReplaceField("PostalCode", "m_postalCode");
    this.rtf.ReplaceField("Date", System.DateTime.Today.Date.ToString());
    this.rtf.InsertField("CustomerID");
}
  • Visual Basic
Private Sub ghCustomerID_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ghCustomerID.Format
    Me.rtf.ReplaceField("CompanyName", "m_companyName")
    Me.rtf.ReplaceField("ContactName", "m_contactName")
    Me.rtf.ReplaceField("AddressLine", "m_addressLine")
    Me.rtf.ReplaceField("City", "m_city")
    Me.rtf.ReplaceField("Region", "m_region")
    Me.rtf.ReplaceField("Country", "m_country")
    Me.rtf.ReplaceField("PostalCode", "m_postalCode")
    Me.rtf.ReplaceField("Date", System.DateTime.Today.Date)
    Me.rtf.InsertField("CustomerID")
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~ReplaceField


Load(Stream,RichTextType) Method

Load(Stream,RichTextType) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : Load(Stream,RichTextType) Method
Stream with content
RichText type; one of rtf, html or text
Loads a stream of Rtf, Text or Html file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Load( _
   ByVal stream As System.IO.Stream, _
   ByVal type As RichTextType _
)
public void Load(
   System.IO.Stream stream,
   RichTextType type
)

Parameters

stream
Stream with content
type
RichText type; one of rtf, html or text
See Also

Reference

RichTextBox Class
RichTextBox Members


LoadFile Method

LoadFile Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : LoadFile Method
Loads an HTML or RTF file.
Obsolete. Included only for backward compatibility.
Overload List
Overload | Description
LoadFile(String) | Loads an HTML or RTF file.
LoadFile(Stream) | Loads an HTML or RTF stream.
Remarks
This method has been deprecated. Please use Load(Stream stream, RichTextType type).
See Also

Reference

RichTextBox Class
RichTextBox Members


LoadFile(String) Method

LoadFile(String) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class > LoadFile Method : LoadFile(String) Method
file name to load the RichTextBox content from
Loads an HTML or RTF file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadFile( _
   ByVal fileName As System.String _
)
public void LoadFile(
   System.string fileName
)

Parameters

fileName
file name to load the RichTextBox content from
See Also

Reference

RichTextBox Class
RichTextBox Members
Overload List


LoadFile(Stream) Method

LoadFile(Stream) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class > LoadFile Method : LoadFile(Stream) Method
stream to load the RichTextBox content from
Loads an HTML or RTF stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadFile( _
   ByVal stream As System.IO.Stream _
)
public void LoadFile(
   System.IO.Stream stream
)

Parameters

stream
stream to load the RichTextBox content from
See Also

Reference

RichTextBox Class
RichTextBox Members
Overload List


ReplaceField Method

ReplaceField Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : ReplaceField Method
Name of the merge field to be replaced with the specified text.
The value used to replace the specified field.
Merges the contents of the RTF stream with the field values specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ReplaceField( _
   ByVal fieldName As System.String, _
   ByVal replaceText As System.String _
)
public void ReplaceField(
   System.string fieldName,
   System.string replaceText
)

Parameters

fieldName
Name of the merge field to be replaced with the specified text.
replaceText
The value used to replace the specified field.
Remarks

A merge field is created using the InsertField method.

You can use this method to create mail-merge RTF content in your report. The control will replace all occurrences of the field with the specified value.

Example
  • C#
private void ghCustomerID_Format(object sender, System.EventArgs eArgs)
{
    this.rtf.ReplaceField("CompanyName", "m_companyName");
    this.rtf.ReplaceField("ContactName", "m_contactName");
    this.rtf.ReplaceField("AddressLine", "m_addressLine");
    this.rtf.ReplaceField("City", "m_city");
    this.rtf.ReplaceField("Region", "m_region");
    this.rtf.ReplaceField("Country", "m_country");
    this.rtf.ReplaceField("PostalCode", "m_postalCode");
    this.rtf.ReplaceField("Date", System.DateTime.Today.Date.ToString());
}
  • Visual Basic
Private Sub ghCustomerID_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles ghCustomerID.Format
    Me.rtf.ReplaceField("CompanyName", "m_companyName")
    Me.rtf.ReplaceField("ContactName", "m_contactName")
    Me.rtf.ReplaceField("AddressLine", "m_addressLine")
    Me.rtf.ReplaceField("City", "m_city")
    Me.rtf.ReplaceField("Region", "m_region")
    Me.rtf.ReplaceField("Country", "m_country")
    Me.rtf.ReplaceField("PostalCode", "m_postalCode")
    Me.rtf.ReplaceField("Date", System.DateTime.Today.Date)
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members
InsertField Method

Walkthroughs

Mail Merge with RichText


RichTextBox Class Properties

RichTextBox Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RichTextBox Class

For a list of all members of this type, see RichTextBox members.

Public Properties
 | Name | Description
Public Property | AutoReplaceFields | Gets or sets a value that indicates whether ActiveReports should automatically replace fields in the RichTextBox with matching fields in the data source.
Public Property | BackColor | Gets or sets the control's background color or fill color.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | BulletIndent | Gets or sets the indentation used in the control when the bullet style is applied to the text.
Public Property | CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | CanShrink | Determines whether ActiveReports should decrease the height of the field based on its value.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Font | Gets or returns the font object used to print the control text. For design time use only.
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Html | Sets or returns the hypertext to be rendered in the control.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | MaxLength | Gets or sets the maximum number of characters in the control for the End-User Report Designer.
Public Property | Multiline | Gets or sets a value that determines whether the RichTextBox prints multiple lines or single line.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | RTF | Gets or sets the rich text content of the control.
Public Property | SelectedText | Gets or sets the current selected text in the control.
Public Property | SelectionAlignment | Gets or sets the alignment to apply to the current selection or insertion point.
Public Property | SelectionBackColor | Gets or sets the background color of the current text selection.
Public Property | SelectionBullet | Gets or sets a value indicating whether the bullet style is applied to the current selection.
Public Property | SelectionCharOffset | Gets or sets a value indicating where text in the control appears on the baseline, as a superscript or as a subscript below the baseline.
Public Property | SelectionColor | Gets or sets the text color of the current text selection.
Public Property | SelectionFont | Gets or sets the font of the current text selection.
Public Property | SelectionHangingIndent | Gets or sets the distance between the left edge of the first line of text in the selected paragraph and the left edge of subsequent lines in the same paragraph. Renders the selected text the specified number of inches to the left of the RichTextBox.
Public Property | SelectionIndent | Gets or sets the distance in inches between the left edge of the RichTextBox and the left edge of the current text selection. Renders the selected text the specified number of inches to the right of the RichTextBox.
Public Property | SelectionLength | Gets or sets the number of characters selected in control.
Public Property | SelectionRightIndent | The distance (in inches) between the right edge of the RichTextBox control and the right edge of the text that is selected.
Public Property | SelectionStart | Gets or sets the starting point of text selected in the text box.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Text | Gets or sets the current text in the RichTextBox.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

RichTextBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


AutoReplaceFields Property

AutoReplaceFields Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : AutoReplaceFields Property
Gets or sets a value that indicates whether ActiveReports should automatically replace fields in the RichTextBox with matching fields in the data source.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoReplaceFields As System.Boolean
public System.bool AutoReplaceFields {get; set;}

Property Value

Boolean.
See Also

Reference

RichTextBox Class
RichTextBox Members


BackColor Property (RichTextBox)

BackColor Property (RichTextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : BackColor Property
Gets or sets the control's background color or fill color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackColor As Color
public Color BackColor {get; set;}

Property Value

System.Drawing.Color.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.rtbActiveReport.BackColor = System.Drawing.Color.DarkGoldenrod;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.rtbActiveReport.BackColor = System.Drawing.Color.DarkGoldenrod
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members


BulletIndent Property

BulletIndent Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : BulletIndent Property
Gets or sets the indentation used in the control when the bullet style is applied to the text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BulletIndent As System.Single
public System.float BulletIndent {get; set;}

Property Value

Float value that is the current bullet indent value in inches. Default is 0.5 inch.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.rtbActiveReport.BulletIndent = .25f;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.rtbActiveReport.BulletIndent = 0.25
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members


CanGrow Property (RichTextBox)

CanGrow Property (RichTextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : CanGrow Property
Determines whether ActiveReports should increase the height of the control based on its content.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CanGrow As System.Boolean
public System.bool CanGrow {get; set;}

Property Value

A Boolean value that determines the behavior of the control. If False, ActiveReports clips the text to fit within the control's predefined height. If True, ActiveReports increases the height of the control and shifts all controls below it to account for the increase in height.
Remarks
The increase in height might cause the section height to increase. The section's CanGrow property should also be set to True to avoid clipping the section.
Example
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    this.rtbActiveReport.CanGrow = false;
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.rtbActiveReport.CanGrow = False
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.Section~CanGrow
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~CanShrink


CanShrink Property (RichTextBox)

CanShrink Property (RichTextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : CanShrink Property
Determines whether ActiveReports should decrease the height of the field based on its value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CanShrink As System.Boolean
public System.bool CanShrink {get; set;}

Property Value

A Boolean value that determines the behavior. If False, ActiveReports does not change the height of the control based on the size of its content. If True, ActiveReports decreases the height of the control and shifts all controls below it to account for the decrease in height.
Remarks
The decrease in height might cause the section height to decrease when the section's CanShrink property is set to True. ActiveReports does not shift any controls below the shrinking control unless there are no intersecting controls along the shifting path.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.rtbActiveReport.CanShrink = true;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.rtbActiveReport.CanShrink = True
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.Section~CanShrink
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~CanGrow


Font Property (RichTextBox)

Font Property (RichTextBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : Font Property
Gets or returns the font object used to print the control text. For design time use only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Font As Font
public Font Font {get; set;}

Property Value

Current System.Drawing.Font object used to render the control's text.
Remarks
The Font property is for design-time use only. To set the font at run time, use the SelectionFont property.
See Also

Reference

RichTextBox Class
RichTextBox Members
SelectionFont Property


ForeColor Property (RichTextBox)

ForeColor Property (RichTextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : ForeColor Property
Gets or returns the foreground (font) color of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ForeColor As Color
public Color ForeColor {get; set;}

Property Value

Current font System.Drawing.Color. Default is Color.Black.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.rtbActiveReport.ForeColor = System.Drawing.Color.DarkGoldenrod;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.rtbActiveReport.ForeColor = System.Drawing.Color.DarkGoldenrod
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~BackColor


Html Property

Html Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : Html Property
Sets or returns the hypertext to be rendered in the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Html As System.String
public System.string Html {get; set;}

Property Value

Valid hypertext with tags which will be rendered in the control.
Remarks
\n" + this.RichTextBox1.Text;}
Example
  • C#
private void reportHeader1_Format(object sender, System.EventArgs e)
{
    RichTextBox1.Html = RichTextBox1.Text;
}
  • Visual Basic
Private Sub ReportHeader1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ReportHeader1.Format
    RichTextBox1.Html = RichTextBox1.Text
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members


MaxLength Property

MaxLength Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : MaxLength Property
Gets or sets the maximum number of characters in the control for the End-User Report Designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaxLength As System.Integer
public System.int MaxLength {get; set;}

Property Value

An integer value that specifies the maximum number of characters. The default value is 0, which allows an unlimited number of characters.
Remarks
This property can only be used with the End-User Report Designer.
See Also

Reference

RichTextBox Class
RichTextBox Members


Multiline Property (RichTextBox)

Multiline Property (RichTextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : Multiline Property
Gets or sets a value that determines whether the RichTextBox prints multiple lines or single line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Multiline As System.Boolean
public System.bool Multiline {get; set;}

Property Value

A Boolean value. True prints a content on multiple lines; if False, the control is limited to single lines.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.rtbActiveReport.Multiline = false;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.rtbActiveReport.Multiline = False
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members


RTF Property

RTF Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : RTF Property
Gets or sets the rich text content of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RTF As System.String
public System.string RTF {get; set;}

Property Value

A string value. Contents of the RichTextBox control.
Remarks
The RichTextBox control is limited in its support for advanced RTF features such as the ones supported by Microsoft Word. In general, the features supported by WordPad are supported in this control. Tables are now supported as well.
Example
The following example sets the contents of the RichTextBox to a formatted Rich Text string.
  • C#
this.RichTextBox1.RTF = @"{\rtf1\ansi\ansicpg1252\deff0{\fonttbl{\f0\fnil\fcharset0 MS Sans Serif;}}\viewkind4\uc1\pard\lang1033\f0\fs17 Rich Text\par }";
  • Visual Basic
Me.RichTextBox1.RTF = "{\rtf1\ansi\ansicpg1252\deff0{\fonttbl{\f0\fnil\fcharset0 MS Sans Serif;}}\viewkind4\uc1\pard\lang1033\f0\fs17 Rich Text\par }"
See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~Text


SelectedText Property

SelectedText Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : SelectedText Property
Gets or sets the current selected text in the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SelectedText As System.String
public System.string SelectedText {get; set;}

Property Value

A string that represents the selected text in the control.
Remarks
To set this property, first set the SelectionStart and SelectionLength properties.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.rtbActiveReport.Find("terrorizing") != -1)
    {
        this.rtbActiveReport.SelectionStart = this.rtbActiveReport.Find("terrorizing");
        this.rtbActiveReport.SelectionLength = 11;
        this.rtbActiveReport.SelectedText = "TERRORIZING";
        this.rtbActiveReport.SelectionColor = System.Drawing.Color.Crimson;
    }
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    If Not Me.rtbActiveReport.Find("terrorizing") = -1 Then
        Me.rtbActiveReport.SelectionStart = Me.rtbActiveReport.Find("terrorizing")
        Me.rtbActiveReport.SelectionLength = 11
        Me.rtbActiveReport.SelectedText = "TERRORIZING"
        Me.rtbActiveReport.SelectionColor = System.Drawing.Color.Crimson
    End If
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~RTF
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~Text
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~SelectionStart
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~SelectionLength


SelectionAlignment Property

SelectionAlignment Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : SelectionAlignment Property
Gets or sets the alignment to apply to the current selection or insertion point.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SelectionAlignment As TextAlignment
public TextAlignment SelectionAlignment {get; set;}

Property Value

TextAlignment enumeration.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.rtbActiveReport.Find("Title") != -1)
    {
        this.rtbActiveReport.SelectionStart = this.rtbActiveReport.Find("Title");
        this.rtbActiveReport.SelectionLength = 5;
        this.rtbActiveReport.SelectionAlignment = TextAlignment.Center;
    }
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    If Not Me.rtbActiveReport.Find("Title") = -1 Then
        Me.rtbActiveReport.SelectionStart = Me.rtbActiveReport.Find("Title")
        Me.rtbActiveReport.SelectionLength = 5
        Me.rtbActiveReport.SelectionAlignment = TextAlignment.Center
    End If
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members


SelectionBackColor Property

SelectionBackColor Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : SelectionBackColor Property
Gets or sets the background color of the current text selection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SelectionBackColor As Color
public Color SelectionBackColor {get; set;}

Property Value

A System.Drawing.Color value that represents the background color to apply to the current text selection.
Remarks
If the current text selection has more than one color specified, this property returns Color.Empty.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.rtbActiveReport.Find("Title") != -1)
    {
        this.rtbActiveReport.SelectionStart = this.rtbActiveReport.Find("Title");
        this.rtbActiveReport.SelectionLength = 5;
        this.rtbActiveReport.SelectionBackColor = System.Drawing.Color.Chocolate;
    }
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    If Not Me.rtbActiveReport.Find("Title") = -1 Then
        Me.rtbActiveReport.SelectionStart = Me.rtbActiveReport.Find("Title")
        Me.rtbActiveReport.SelectionLength = 5
        Me.rtbActiveReport.SelectionBackColor = System.Drawing.Color.Chocolate
    End If
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members


SelectionBullet Property

SelectionBullet Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : SelectionBullet Property
Gets or sets a value indicating whether the bullet style is applied to the current selection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SelectionBullet As System.Boolean
public System.bool SelectionBullet {get; set;}

Property Value

True if the current selection has the bullet style applied; otherwise, False.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.rtbActiveReport.Find("List") != -1)
    {
        this.rtbActiveReport.SelectionStart = this.rtbActiveReport.Find("List") + 5;
        this.rtbActiveReport.SelectionBullet = true;
    }
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    If Not Me.rtbActiveReport.Find("List") = -1 Then
        Me.rtbActiveReport.SelectionStart = Me.rtbActiveReport.Find("List") + 5
        Me.rtbActiveReport.SelectionBullet = True
    End If
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~BulletIndent


SelectionCharOffset Property

SelectionCharOffset Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : SelectionCharOffset Property
Gets or sets a value indicating where text in the control appears on the baseline, as a superscript or as a subscript below the baseline.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SelectionCharOffset As System.Single
public System.float SelectionCharOffset {get; set;}

Property Value

A number that specifies the character offset in inches.

The value of this property must be between -2000 and 2000.

If this property is set to zero, the text appears on the baseline. If it is a positive number, the number specifies the number of inches by which to raise the text selection above the baseline. If it is a negative number, this number specifies the number of inches by which to subscript the text selection. You can use this property to specify text as superscript or subscript.

Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.rtbActiveReport.Find("footnote") != -1)
    {
        this.rtbActiveReport.SelectionStart = this.rtbActiveReport.Find("footnote");
        this.rtbActiveReport.SelectionLength = 11;
        this.rtbActiveReport.SelectionCharOffset = .05f;
    }
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    If Not Me.rtbActiveReport.Find("footnote") = -1 Then
        Me.rtbActiveReport.SelectionStart = Me.rtbActiveReport.Find("footnote")
        Me.rtbActiveReport.SelectionLength = 11
        Me.rtbActiveReport.SelectionCharOffset = 0.05
    End If
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members


SelectionColor Property

SelectionColor Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : SelectionColor Property
Gets or sets the text color of the current text selection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SelectionColor As Color
public Color SelectionColor {get; set;}

Property Value

A System.Drawing.Color value that represents the color to apply to the current text selection.
Remarks
If the current text selection has more than one color specified, this property returns Color.Empty.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.rtbActiveReport.Find("footnote") != -1)
    {
        this.rtbActiveReport.SelectionStart = this.rtbActiveReport.Find("footnote");
        this.rtbActiveReport.SelectionLength = 11;
        this.rtbActiveReport.SelectionCharOffset = .05f;
        this.rtbActiveReport.SelectionColor = System.Drawing.Color.CornflowerBlue;
    }
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    If Not Me.rtbActiveReport.Find("footnote") = -1 Then
        Me.rtbActiveReport.SelectionStart = Me.rtbActiveReport.Find("footnote")
        Me.rtbActiveReport.SelectionLength = 11
        Me.rtbActiveReport.SelectionCharOffset = 0.05
        Me.rtbActiveReport.SelectionColor = System.Drawing.Color.CornflowerBlue
    End If
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~SelectionBackColor


SelectionFont Property

SelectionFont Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : SelectionFont Property
Gets or sets the font of the current text selection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SelectionFont As Font
public Font SelectionFont {get; set;}

Property Value

A System.Drawing.Font value that represents the font to apply to the current text selection.
Remarks
If the current text selection has more than one font specified, this property is a null reference (Nothing in Visual Basic).
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.rtbActiveReport.Find("footnote") != -1)
    {
        this.rtbActiveReport.SelectionStart = this.rtbActiveReport.Find("footnote");
        this.rtbActiveReport.SelectionLength = 8;
        this.rtbActiveReport.SelectionCharOffset = .05f;
        this.rtbActiveReport.SelectionFont = new System.Drawing.Font("Tahoma", 8, System.Drawing.FontStyle.Italic);
    }
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    If Not Me.rtbActiveReport.Find("footnote") = -1 Then
        Me.rtbActiveReport.SelectionStart = Me.rtbActiveReport.Find("footnote")
        Me.rtbActiveReport.SelectionLength = 8
        Me.rtbActiveReport.SelectionCharOffset = 0.05
        Me.rtbActiveReport.SelectionFont = New System.Drawing.Font("Tahoma", 8, FontStyle.Italic)
    End If
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members


SelectionHangingIndent Property

SelectionHangingIndent Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : SelectionHangingIndent Property

Gets or sets the distance between the left edge of the first line of text in the selected paragraph and the left edge of subsequent lines in the same paragraph. Renders the selected text the specified number of inches to the left of the RichTextBox.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SelectionHangingIndent As System.Single
public System.float SelectionHangingIndent {get; set;}

Property Value

An integer value that represents the distance, in inches, for the hanging indent applied to the current text selection.

Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.rtbActiveReport.Find("List") != -1)
    {
        this.rtbActiveReport.SelectionStart = this.rtbActiveReport.Find("List");
        this.rtbActiveReport.SelectionLength = 4;
        this.rtbActiveReport.SelectionHangingIndent = 0.5f;
    }
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    If Not Me.rtbActiveReport.Find("List") = -1 Then
        Me.rtbActiveReport.SelectionStart = Me.rtbActiveReport.Find("List")
        Me.rtbActiveReport.SelectionLength = 4
        Me.rtbActiveReport.SelectionHangingIndent = 0.5
    End If
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~SelectionIndent
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~SelectionRightIndent


SelectionIndent Property

SelectionIndent Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : SelectionIndent Property
Gets or sets the distance in inches between the left edge of the RichTextBox and the left edge of the current text selection. Renders the selected text the specified number of inches to the right of the RichTextBox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SelectionIndent As System.Single
public System.float SelectionIndent {get; set;}

Property Value

An integer value that represents the current distance, in inches, of the indentation applied to the left of the current text selection.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.rtbActiveReport.Find("List") != -1)
    {
        this.rtbActiveReport.SelectionStart = this.rtbActiveReport.Find("List");
        this.rtbActiveReport.SelectionLength = 4;
        this.rtbActiveReport.SelectionIndent = 0.5f;
    }
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    If Not Me.rtbActiveReport.Find("List") = -1 Then
        Me.rtbActiveReport.SelectionStart = Me.rtbActiveReport.Find("List")
        Me.rtbActiveReport.SelectionLength = 4
        Me.rtbActiveReport.SelectionIndent = 0.5
    End If
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~SelectionHangingIndent
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~SelectionRightIndent


SelectionLength Property

SelectionLength Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : SelectionLength Property
Gets or sets the number of characters selected in control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SelectionLength As System.Integer
public System.int SelectionLength {get; set;}

Property Value

The number of characters selected in the text box.
Remarks
You can use this property to determine if any characters are currently selected in the text box control before performing operations on the selected text.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.rtbActiveReport.Find("List") != -1)
    {
        this.rtbActiveReport.SelectionStart = this.rtbActiveReport.Find("List");
        this.rtbActiveReport.SelectionLength = 4;
        this.rtbActiveReport.SelectionIndent = 0.5f;
    }
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    If Not Me.rtbActiveReport.Find("List") = -1 Then
        Me.rtbActiveReport.SelectionStart = Me.rtbActiveReport.Find("List")
        Me.rtbActiveReport.SelectionLength = 4
        Me.rtbActiveReport.SelectionIndent = 0.5
    End If
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~SelectionStart


SelectionRightIndent Property

SelectionRightIndent Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : SelectionRightIndent Property
The distance (in inches) between the right edge of the RichTextBox control and the right edge of the text that is selected.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SelectionRightIndent As System.Single
public System.float SelectionRightIndent {get; set;}

Property Value

The indentation space, in inches, at the right of the current selection or insertion point.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.rtbActiveReport.SelectionStart = 0;
    this.rtbActiveReport.SelectionLength = 100;
    this.rtbActiveReport.SelectionRightIndent = 1;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.rtbActiveReport.SelectionStart = 0
    Me.rtbActiveReport.SelectionLength = 100
    Me.rtbActiveReport.SelectionRightIndent = 0.5
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~SelectionHangingIndent
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~SelectionIndent


SelectionStart Property

SelectionStart Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : SelectionStart Property
Gets or sets the starting point of text selected in the text box.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SelectionStart As System.Integer
public System.int SelectionStart {get; set;}

Property Value

The starting position of text selected in the text box.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.rtbActiveReport.SelectionStart = 0;
    this.rtbActiveReport.SelectionLength = 100;
    this.rtbActiveReport.SelectionRightIndent = 1;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.rtbActiveReport.SelectionStart = 0
    Me.rtbActiveReport.SelectionLength = 100
    Me.rtbActiveReport.SelectionRightIndent = 0.5
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~SelectionLength


Text Property (RichTextBox)

Text Property (RichTextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : Text Property
Gets or sets the current text in the RichTextBox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Text As System.String
public System.string Text {get; set;}

Property Value

The text displayed in the control.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.rtbActiveReport.Text = "Confidential";
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.rtbActiveReport.Text = "Confidential"
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members


Section Class

Section Class
Members Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Section Class
Section is the base class of all ActiveReports section types.
Object Model
Section Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Section
public class Section
Remarks
Use this class to access, add or modify section controls and set section properties. You can add sections to a report using the Sections property of the report object and the SectionCollection class.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.AddBookmark("Products");
    this.detail.BackColor = System.Drawing.Color.Transparent;
    this.detail.CanGrow = true;
    this.detail.CanShrink = false;
    this.detail.Controls.Clear();
    this.detail.Height = 2.0f;
    this.detail.Name = "Products";
    this.detail.Visible = true;
    this.detail.SizeToFit();
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.AddBookmark("Products")
    Me.Detail1.BackColor = System.Drawing.Color.Transparent
    Me.Detail1.CanGrow = True
    Me.Detail1.CanShrink = False
    Me.Detail1.Controls.Clear()
    Me.Detail1.Height = 2.0F
    Me.Detail1.Name = "Products"
    Me.Detail1.Visible = True
    Me.Detail1.SizeToFit()
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.Detail
GrapeCity.ActiveReports.SectionReportModel.GroupFooter
GrapeCity.ActiveReports.SectionReportModel.GroupHeader
GrapeCity.ActiveReports.SectionReportModel.PageFooter
GrapeCity.ActiveReports.SectionReportModel.PageHeader
GrapeCity.ActiveReports.SectionReportModel.ReportFooter
GrapeCity.ActiveReports.SectionReportModel.ReportHeader

See Also

Reference

Section Members
GrapeCity.ActiveReports.SectionReportModel Namespace


Section Class Members

Section Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Section Class

The following tables list the members exposed by Section.

Public Constructors
 | Name | Description
Public Constructor | Section Constructor | Initializes a new instance of the Section class.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section.
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height.
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls.
Public Property | Controls | Gets a collection of all controls contained in the section.
Public Property | Height | Gets or sets the height of the section.
Public Property | Name | Gets or sets the name of the section.
Public Property | Tag | Gets or sets user-defined information to be persisted with the section.
Public Property | Type | Gets the section's type.
Public Property | Visible | Specifies whether the section should be printed or not.
Top
Public Methods
 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview.
Public Method | Dispose | Releases the section instance from memory.
Public Method | SizeToFit | Overloaded. The SizeToFit method is used by the end-user report designer to size a section so that all contained controls are visible.
Top
Public Events
 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page.
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page.
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas.
Top
See Also

Reference

Section Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Section Constructor

Section Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Section Constructor
Initializes a new instance of the Section class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Section()
See Also

Reference

Section Class
Section Members


Section Class Methods

Section Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Section Class

For a list of all members of this type, see Section members.

Public Methods
 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview.
Public Method | Dispose | Releases the section instance from memory.
Public Method | SizeToFit | Overloaded. The SizeToFit method is used by the end-user report designer to size a section so that all contained controls are visible.
Top
See Also

Reference

Section Class
GrapeCity.ActiveReports.SectionReportModel Namespace


AddBookmark(String) Method

AddBookmark(String) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : AddBookmark(String) Method
The bookmark text.
Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddBookmark( _
   ByVal text As System.String _
)
public void AddBookmark(
   System.string text
)

Parameters

text
The bookmark text.
See Also

Reference

Section Class
Section Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Dispose() Method
Releases the section instance from memory.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Section Class
Section Members


SizeToFit Method

SizeToFit Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : SizeToFit Method
The SizeToFit method is used by the end-user report designer to size a section so that all contained controls are visible.
Overload List
Overload | Description
SizeToFit() | Sizes the section to fit the contained controls.
SizeToFit(Boolean) | Sizes the section to fit the contained controls and optionally allows the section to shrink to fit the contained controls.
Remarks
Using this method, a user could add several controls to a section at run time and then size the section to the proper height.
See Also

Reference

Section Class
Section Members


SizeToFit() Method

SizeToFit() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class > SizeToFit Method : SizeToFit() Method
Sizes the section to fit the contained controls.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SizeToFit()
public void SizeToFit()
See Also

Reference

Section Class
Section Members
Overload List


SizeToFit(Boolean) Method

SizeToFit(Boolean) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class > SizeToFit Method : SizeToFit(Boolean) Method
Set to True to allow the section to shrink to fit the contained controls.
Sizes the section to fit the contained controls and optionally allows the section to shrink to fit the contained controls.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SizeToFit( _
   ByVal bAllowShrink As System.Boolean _
)
public void SizeToFit(
   System.bool bAllowShrink
)

Parameters

bAllowShrink
Set to True to allow the section to shrink to fit the contained controls.
See Also

Reference

Section Class
Section Members
Overload List


Section Class Properties

Section Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Section Class

For a list of all members of this type, see Section members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the section.
Public Property | CanGrow | Indicates whether the section height should grow when its controls extend beyond its original height.
Public Property | CanShrink | Indicates whether the section height should be adjusted to the exact total height of its controls.
Public Property | Controls | Gets a collection of all controls contained in the section.
Public Property | Height | Gets or sets the height of the section.
Public Property | Name | Gets or sets the name of the section.
Public Property | Tag | Gets or sets user-defined information to be persisted with the section.
Public Property | Type | Gets the section's type.
Public Property | Visible | Specifies whether the section should be printed or not.
Top
See Also

Reference

Section Class
GrapeCity.ActiveReports.SectionReportModel Namespace


BackColor Property (Section)

BackColor Property (Section)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : BackColor Property
Gets or sets the background color of the section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackColor As Color
public Color BackColor {get; set;}

Property Value

System.Drawing.Color value used to paint the section background. Default is Color.Transparent.

Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.Detail.BackColor = System.Drawing.Color.Transparent;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail.BackColor = System.Drawing.Color.Transparent
End Sub
See Also

Reference

Section Class
Section Members


CanGrow Property (Section)

CanGrow Property (Section)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : CanGrow Property

Indicates whether the section height should grow when its controls extend beyond its original height.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CanGrow As System.Boolean
public System.bool CanGrow {get; set;}

Property Value

Boolean. True if the section should grow to fit its controls, False if the controls should be clipped to the section's height. Default is True.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.CanGrow = true;
    this.detail.CanShrink = false;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.CanGrow = True
    Me.Detail1.CanShrink = False
End Sub
See Also

Reference

Section Class
Section Members
ActiveReports6~GrapeCity.ActiveReports.Section~CanShrink


CanShrink Property (Section)

CanShrink Property (Section)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : CanShrink Property

Indicates whether the section height should be adjusted to the exact total height of its controls.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CanShrink As System.Boolean
public System.bool CanShrink {get; set;}

Property Value

Boolean. True if the section should shrink to fit its controls; False, otherwise. Default is False.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.CanGrow = true;
    this.detail.CanShrink = false;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.CanGrow = True
    Me.Detail1.CanShrink = False
End Sub
See Also

Reference

Section Class
Section Members
ActiveReports6~GrapeCity.ActiveReports.Section~CanGrow


Controls Property (Section)

Controls Property (Section)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Controls Property
Gets a collection of all controls contained in the section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Controls As ControlCollection
public ControlCollection Controls {get;}

Property Value

A ControlCollection object representing all controls contained within the section.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.Controls.Clear();
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.Controls.Clear()
End Sub
See Also

Reference

Section Class
Section Members


Height Property (Section)

Height Property (Section)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Height Property
Gets or sets the height of the section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As System.Single
public System.float Height {get; set;}

Property Value

Height of the section in inches. Default is 2 inches.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.Height = 2.0f;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.Height = 2.0F
End Sub
See Also

Reference

Section Class
Section Members


Name Property (Section)

Name Property (Section)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Name Property
Gets or sets the name of the section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}

Property Value

String. Unique name of the section.
Remarks
The section name is used as a key in the report Sections collection.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.Name = "Products";
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.Name = "Products"
End Sub
See Also

Reference

Section Class
Section Members


Tag Property (Section)

Tag Property (Section)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Tag Property
Gets or sets user-defined information to be persisted with the section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Tag As System.Object
public System.object Tag {get; set;}

Property Value

See Also

Reference

Section Class
Section Members


Type Property (Section)

Type Property (Section)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Type Property
Gets the section's type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Type As SectionType
public SectionType Type {get;}

Property Value

SectionType enumeration specifying the type of the section. Default is SectionType.Detail.
Remarks
ActiveReports has seven section types that determine how the section is processed and rendered. Report header and footer sections print at the beginning and end of the report. Page header and footer sections print at the top and bottom of each page. Group header and footer sections print at the beginning and end of each data grouping. A Detail section is printed for each data record in the data source.
See Also

Reference

Section Class
Section Members


Visible Property (Section)

Visible Property (Section)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Visible Property

Specifies whether the section should be printed or not.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}

Property Value

Boolean value that specifies whether the section will be printed or not. Default is true.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.Visible = true;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail.Visible = True
End Sub
See Also

Reference

Section Class
Section Members


Section Class Events

Section Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Section Class

For a list of all members of this type, see Section members.

Public Events
 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page.
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page.
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas.
Top
See Also

Reference

Section Class
GrapeCity.ActiveReports.SectionReportModel Namespace


AfterPrint Event

AfterPrint Event
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : AfterPrint Event
Occurs after the section has been rendered to the page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event AfterPrint As System.EventHandler
public event System.EventHandler AfterPrint
Remarks
This event allows you to draw directly to the canvas after the section has been rendered. It is not recommended to use this event to manage any data or variables because the sequence of the event relative to the other section events is not guaranteed.
Example
  • C#
Private void reportHeader1_AfterPrint(object sender, System.EventArgs eArgs)
{
    this.CurrentPage.DrawRect(1,1,3,1);
}
  • Visual Basic
Private Sub ReportHeader1_AfterPrint(ByVal sender As Object, ByVal e As System.EventArgs) Handles ReportHeader1.AfterPrint
    Me.CurrentPage.DrawRect(1, 1, 3, 1)
End Sub
See Also

Reference

Section Class
Section Members
ActiveReports6~GrapeCity.ActiveReports.Section~BeforePrint_EV
ActiveReports6~GrapeCity.ActiveReports.Section~Format_EV


BeforePrint Event

BeforePrint Event
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : BeforePrint Event
Occurs immediately before the section is rendered to the page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BeforePrint As System.EventHandler
public event System.EventHandler BeforePrint
Remarks

When this event occurs the section layout has been finalized and is ready to render. Any changes that might affect the size of the section (such as changing the section Height property) will be ignored.

Example
  • C#
private void ghCustomerID_BeforePrint(object sender, System.EventArgs eArgs)
{
    this.rtf.ReplaceField("TotalOrders",this.txtTotalOrders.Text);
}
  • Visual Basic
Private Sub ghCustomerID_BeforePrint(ByVal sender As Object, ByVal e As System.EventArgs) Handles _    ghCustomerID.BeforePrint
        Me.rtf.ReplaceField("TotalOrders", Me.txtTotalOrders.Text)
End Sub
See Also

Reference

Section Class
Section Members
ActiveReports6~GrapeCity.ActiveReports.Section~AfterPrint_EV
ActiveReports6~GrapeCity.ActiveReports.Section~Format_EV


Format Event

Format Event
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Format Event

Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Format As System.EventHandler
public event System.EventHandler Format
Remarks

The format event is the only event where the section's height may be changed. This event may be used to set or change the properties of any controls, or load subreport controls with subreports.

If the CanGrow or CanShrink property of any child control or the section itself is set to True, all of the growing and shrinking of child controls and the section itself takes place in this event. Because of this, information about a control or section's height would not be accurate since ActiveReports might modify the value immediately after the event to account for any layout or data changes.

Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.detail.AddBookmark("Products");
    this.detail.BackColor = System.Drawing.Color.Transparent;
    this.detail.CanGrow = true;
    this.detail.CanShrink = false;
    this.detail.Controls.Clear();
    this.detail.Height = 2.0f;
    this.detail.Name = "Products";
    this.detail.Visible = true;
    this.detail.SizeToFit();
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.Detail1.AddBookmark("Products")
    Me.Detail1.BackColor = System.Drawing.Color.Transparent
    Me.Detail1.CanGrow = True
    Me.Detail1.CanShrink = False
    Me.Detail1.Controls.Clear()
    Me.Detail1.Height = 2.0F
    Me.Detail1.Name = "Products"
    Me.Detail1.Visible = True
    Me.Detail1.SizeToFit()
End Sub
See Also

Reference

Section Class
Section Members


Shape Class

Shape Class
Members Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Shape Class
Prints a rectangular or oval shape on the report.
Object Model
Shape Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Shape
   Inherits ARControl
public sealed class Shape : ARControl
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.shape1.BackColor = System.Drawing.Color.LightSteelBlue;
    this.shape1.LineColor = System.Drawing.Color.Navy;
    this.shape1.LineStyle = LineStyle.Solid;
    this.shape1.LineWeight = 2.0f;
    this.shape1.Style = ShapeType.Ellipse;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Shape1.BackColor = System.Drawing.Color.LightSteelBlue
   Me.Shape1.LineColor = System.Drawing.Color.Navy
   Me.Shape1.LineStyle = LineStyle.Solid
   Me.Shape1.LineWeight = 2.0F
   Me.Shape1.Style = ShapeType.Ellipse
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.Shape

See Also

Reference

Shape Members
GrapeCity.ActiveReports.SectionReportModel Namespace


Shape Class Members

Shape Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Shape Class

The following tables list the members exposed by Shape.

Public Constructors
 | Name | Description
Public Constructor | Shape Constructor | Initializes a new instance of the Shape class.
Top
Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | LineColor | Gets or sets the color of the shape's lines.
Public Property | LineStyle | Gets or sets the pen style used to draw the line.
Public Property | LineWeight | Gets or sets the pen width in pixels used to draw the shape.
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | RoundingRadius | Gets or sets the radius as a percentage value for each corner of the RoundRect shape control.
Public Property | Size | Gets or sets the size of the Shape control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Style | Gets or sets the shape type to be printed.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

Shape Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Shape Constructor

Shape Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : Shape Constructor
Initializes a new instance of the Shape class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Shape()
See Also

Reference

Shape Class
Shape Members


Shape Class Properties

Shape Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Shape Class

For a list of all members of this type, see Shape members.

Public Properties
 | Name | Description
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | LineColor | Gets or sets the color of the shape's lines.
Public Property | LineStyle | Gets or sets the pen style used to draw the line.
Public Property | LineWeight | Gets or sets the pen width in pixels used to draw the shape.
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | RoundingRadius | Gets or sets the radius as a percentage value for each corner of the RoundRect shape control.
Public Property | Size | Gets or sets the size of the Shape control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Style | Gets or sets the shape type to be printed.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

Shape Class
GrapeCity.ActiveReports.SectionReportModel Namespace


BackColor Property (Shape)

BackColor Property (Shape)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : BackColor Property
Gets or sets the background color of the control area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackColor As Color
public Color BackColor {get; set;}

Property Value

System.Drawing.Color.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.shape1.BackColor = System.Drawing.Color.LightSteelBlue;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Shape1.BackColor = System.Drawing.Color.LightSteelBlue
End Sub
See Also

Reference

Shape Class
Shape Members


LineColor Property (Shape)

LineColor Property (Shape)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : LineColor Property
Gets or sets the color of the shape's lines.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineColor As Color
public Color LineColor {get; set;}

Property Value

A System.Drawing.Color value that represents the current color of the shape's lines. Default is Color.Black.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.shape1.LineColor = System.Drawing.Color.Navy;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Shape1.LineColor = System.Drawing.Color.Navy
End Sub
See Also

Reference

Shape Class
Shape Members
ActiveReports6~GrapeCity.ActiveReports.Shape~LineStyle
ActiveReports6~GrapeCity.ActiveReports.Shape~LineWeight


LineStyle Property (Shape)

LineStyle Property (Shape)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : LineStyle Property
Gets or sets the pen style used to draw the line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineStyle As LineStyle
public LineStyle LineStyle {get; set;}

Property Value

Current LineStyle value. Default is LineStyle.Solid.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.shape1.LineStyle = LineStyle.Solid;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Shape1.LineStyle = LineStyle.Solid
End Sub
See Also

Reference

Shape Class
Shape Members
ActiveReports6~GrapeCity.ActiveReports.Shape~LineColor
ActiveReports6~GrapeCity.ActiveReports.Shape~LineWeight


LineWeight Property (Shape)

LineWeight Property (Shape)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : LineWeight Property
Gets or sets the pen width in pixels used to draw the shape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineWeight As System.Single
public System.float LineWeight {get; set;}

Property Value

Float value that represents the current pen width in pixels. Default is 1.0f.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.shape1.LineWeight = 2.0f;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Shape1.LineWeight = 2.0F
End Sub
See Also

Reference

Shape Class
Shape Members
ActiveReports6~GrapeCity.ActiveReports.Shape~LineColor
ActiveReports6~GrapeCity.ActiveReports.Shape~LineStyle


RoundingRadius Property (Shape)

RoundingRadius Property (Shape)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : RoundingRadius Property
Gets or sets the radius as a percentage value for each corner of the RoundRect shape control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RoundingRadius As CornersRadius
public CornersRadius RoundingRadius {get; set;}
Remarks
The default value is 10%; valid values range from 0% to 100%.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.shape1.BackColor = System.Drawing.Color.LightSteelBlue;
    this.shape1.LineColor = System.Drawing.Color.Navy;
    this.shape1.LineStyle = LineStyle.Solid;
    this.shape1.LineWeight = 2.0f;
    this.shape1.Style = ShapeType.RoundRect;
    this.shape1.RoundingRadius = 20f;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Shape1.BackColor = System.Drawing.Color.LightSteelBlue
   Me.Shape1.LineColor = System.Drawing.Color.Navy
   Me.Shape1.LineStyle = LineStyle.Solid
   Me.Shape1.LineWeight = 2.0F
   Me.Shape1.Style = ShapeType.RoundRect
   Me.Shape1.RoundingRadius = 20F
End Sub
See Also

Reference

Shape Class
Shape Members


Style Property (Shape)

Style Property (Shape)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Shape Class : Style Property
Gets or sets the shape type to be printed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As ShapeType
public ShapeType Style {get; set;}

Property Value

A ShapeType enumeration value that determines the shape to be printed.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.shape1.Style = ShapeType.Ellipse;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.Shape1.Style = ShapeType.Ellipse
End Sub
See Also

Reference

Shape Class
Shape Members


Style Class

Style Class
Members Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Style Class
Represents the formatting properties of a control.
Object Model
Style Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Style
public class Style
Remarks

The Style class encapsulates the properties that control the appearance of a control and can be applied to multiple controls to provide a common appearance.

Style properties can be cascaded using inheritance. When creating a new style you can set the values of unset properties to inherit from a parent style. For example, if you have a style named "Normal", you can create a new style named "NormalBold" and set only the Parent property to "Normal" and the FontBold property to true. The remaining properties will be set the same as the parent style.

ActiveReports has a set of built-in styles that are defined in the StyleSheet class.

Example
Paste inside the ReportStart event.
  • C#
private void rptGrapeCity_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = 10.5;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = 10.5
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.Style

See Also

Reference

Style Members
GrapeCity.ActiveReports.SectionReportModel Namespace
Label Class
ClassName Property
StyleSheet Class

How To

Use External Style Sheets


Style Class Members

Style Class Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Style Class

The following tables list the members exposed by Style.

Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the horizontal text alignment of the control to which the style is applied.
Public Property | BackColor | Gets or sets the background color of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Public Property | CharacterSet | Gets or sets the CharacterSet of the control. The value must be cast as a byte.
Public Property | FontBold | Gets or sets the Font.Bold property of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Public Property | FontItalic | Gets or sets the Font.Italic property of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Public Property | FontName | Gets or sets the Font.Name property of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Public Property | FontSize | Gets or sets the size of the font used to render the control.
Public Property | FontStrikeThrough | Gets or sets the Font.StrikeThrough property of the control.
Public Property | FontUnderline | Gets or sets the Font.Underline property of the control.
Public Property | FontVertical | Gets or sets the Font.Vertical property of the control.
Public Property | ForeColor | Gets or sets the text color of the control.
Public Property | Name | Gets or sets the unique name of the style.
Public Property | Parent | Gets or sets the name of the parent style.
Public Property | Value | Gets or sets a Cascading Style Sheets (CSS) string representation of the Style properties.
Public Property | VerticalAlignment | Gets or sets the vertical alignment of text within the bounds of the control.
Top
See Also

Reference

Style Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Label Class
ClassName Property
StyleSheet Class

How To

Use External Style Sheets


Style Class Properties

Style Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Style Class

For a list of all members of this type, see Style members.

Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the horizontal text alignment of the control to which the style is applied.
Public Property | BackColor | Gets or sets the background color of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Public Property | CharacterSet | Gets or sets the CharacterSet of the control. The value must be cast as a byte.
Public Property | FontBold | Gets or sets the Font.Bold property of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Public Property | FontItalic | Gets or sets the Font.Italic property of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Public Property | FontName | Gets or sets the Font.Name property of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Public Property | FontSize | Gets or sets the size of the font used to render the control.
Public Property | FontStrikeThrough | Gets or sets the Font.StrikeThrough property of the control.
Public Property | FontUnderline | Gets or sets the Font.Underline property of the control.
Public Property | FontVertical | Gets or sets the Font.Vertical property of the control.
Public Property | ForeColor | Gets or sets the text color of the control.
Public Property | Name | Gets or sets the unique name of the style.
Public Property | Parent | Gets or sets the name of the parent style.
Public Property | Value | Gets or sets a Cascading Style Sheets (CSS) string representation of the Style properties.
Public Property | VerticalAlignment | Gets or sets the vertical alignment of text within the bounds of the control.
Top
See Also

Reference

Style Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Label Class
ClassName Property
StyleSheet Class

How To

Use External Style Sheets


Alignment Property (Style)

Alignment Property (Style)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : Alignment Property
Gets or sets the horizontal text alignment of the control to which the style is applied.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Alignment As System.Object
public System.object Alignment {get; set;}

Property Value

An enumeration value that specifies the horizontal text alignment.
Example
Paste inside the ReportStart event.
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub
See Also

Reference

Style Class
Style Members


BackColor Property (Style)

BackColor Property (Style)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : BackColor Property
Gets or sets the background color of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackColor As System.Object
public System.object BackColor {get; set;}

Property Value

A System.Drawing.Color that represents the background color of the control.
Example
Paste inside the ReportStart event.
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub
See Also

Reference

Style Class
Style Members


CharacterSet Property (Style)

CharacterSet Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : CharacterSet Property
Gets or sets the CharacterSet of the control. The value must be cast as a byte.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CharacterSet As System.Object
public System.object CharacterSet {get; set;}
See Also

Reference

Style Class
Style Members


FontBold Property (Style)

FontBold Property (Style)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : FontBold Property
Gets or sets the Font.Bold property of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontBold As System.Object
public System.object FontBold {get; set;}

Property Value

A Boolean value. True if the control font should be set to bold; False otherwise.
Example
Paste inside the ReportStart event.
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If
End Sub
See Also

Reference

Style Class
Style Members


FontItalic Property (Style)

FontItalic Property (Style)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : FontItalic Property
Gets or sets the Font.Italic property of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontItalic As System.Object
public System.object FontItalic {get; set;}

Property Value

A Boolean value. True if the control font should be set to italic; False otherwise.
Example
Paste inside the ReportStart event.
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub
See Also

Reference

Style Class
Style Members


FontName Property (Style)

FontName Property (Style)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : FontName Property
Gets or sets the Font.Name property of the control. Null if the property is inherited from the Style parent or not to be set on the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontName As System.Object
public System.object FontName {get; set;}

Property Value

The name of the font that should be used to render the control text.

Example
Paste inside the ReportStart event.
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub
See Also

Reference

Style Class
Style Members


FontSize Property (Style)

FontSize Property (Style)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : FontSize Property

Gets or sets the size of the font used to render the control.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontSize As System.Object
public System.object FontSize {get; set;}

Property Value

Float font size in points or null if the property is inherited from the Style parent or not to be set on the control.

Example
Paste inside the ReportStart event.
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = 10.5;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = 10.5
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub
See Also

Reference

Style Class
Style Members


FontStrikeThrough Property

FontStrikeThrough Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : FontStrikeThrough Property
Gets or sets the Font.StrikeThrough property of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontStrikeThrough As System.Object
public System.object FontStrikeThrough {get; set;}

Property Value

A Boolean value. True if the control font should be set to strikethrough; False otherwise. Null if the property is inherited from the Style parent or not to be set on the control.
Example
Paste inside the ReportStart event.
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub
See Also

Reference

Style Class
Style Members


FontUnderline Property

FontUnderline Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : FontUnderline Property
Gets or sets the Font.Underline property of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontUnderline As System.Object
public System.object FontUnderline {get; set;}

Property Value

A Boolean value. True if the control font should be set to underline; False otherwise. Null if the property is inherited from the Style parent or not to be set on the control.
Example
Paste inside the ReportStart event.
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub
See Also

Reference

Style Class
Style Members


FontVertical Property

FontVertical Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : FontVertical Property
Gets or sets the Font.Vertical property of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontVertical As System.Object
public System.object FontVertical {get; set;}
See Also

Reference

Style Class
Style Members


ForeColor Property (Style)

ForeColor Property (Style)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : ForeColor Property
Gets or sets the text color of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ForeColor As System.Object
public System.object ForeColor {get; set;}

Property Value

A System.Drawing.Color value that represents the color used to render the control text. Null if the property is inherited from the Style parent or not to be set on the control.
Example
Paste inside the ReportStart event.
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub
See Also

Reference

Style Class
Style Members


Name Property (Style)

Name Property (Style)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : Name Property
Gets or sets the unique name of the style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Name As System.String
public System.string Name {get;}

Property Value

A string name of the style.
Example
Paste inside the ReportStart event.
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If
End Sub
See Also

Reference

Style Class
Style Members


Parent Property (Style)

Parent Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : Parent Property
Gets or sets the name of the parent style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Parent As Style
public Style Parent {get;}

Property Value

A string name of the Style from which this Style object inherits its properties.
See Also

Reference

Style Class
Style Members


Value Property (Style)

Value Property (Style)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : Value Property
Gets or sets a Cascading Style Sheets (CSS) string representation of the Style properties.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As System.String
public System.string Value {get; set;}

Property Value

String.
See Also

Reference

Style Class
Style Members


VerticalAlignment Property (Style)

VerticalAlignment Property (Style)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Style Class : VerticalAlignment Property
Gets or sets the vertical alignment of text within the bounds of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property VerticalAlignment As System.Object
public System.object VerticalAlignment {get; set;}

Property Value

A VerticalTextAlignment value that represents the alignment to be applied to the control's content. Null if the property is inherited from the Style parent.
Example
Paste inside the ReportStart event.
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
Paste inside the ReportStart event.
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub
See Also

Reference

Style Class
Style Members


StyleSheet Class

StyleSheet Class
Members Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : StyleSheet Class
Represents the collection of Style objects used to format controls.
Object Model
StyleSheet Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class StyleSheet
public sealed class StyleSheet
Remarks
You can use this collection to add or modify the styles used in the report and globally modify the formatting of controls in your report.
Example
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.StyleSheet

See Also

Reference

StyleSheet Members
GrapeCity.ActiveReports.SectionReportModel Namespace
Style Class
Label Class
ClassName Property

How To

Use External Style Sheets


StyleSheet Class Members

StyleSheet Class Members
Properties Methods Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : StyleSheet Class

The following tables list the members exposed by StyleSheet.

Public Properties
 | Name | Description
Public Property | Count | Returns the number of Style objects in the collection.
Public Property | Item | Overloaded. Returns a reference to a Style object in the collection.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a new Style object to the collection.
Public Method | Clear | Removes the SytleSheet object from the collection.
Public Method | Contains | Determines whether the StyleSheet object contains the specified object.
Public Method | CopyTo | Copies the Style object to the indicated location.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts the specified StyleSheet into the collection at the specified index.
Public Method | Remove | Overloaded. Removes a style from the collection.
Public Method | RemoveAt | Removes the StyleSheet object at the specified location from the collection.
Top
Public Events
 | Name | Description
Public Event | Changed | Occurs when the members of the StyleSheet have changed.
Top
See Also

Reference

StyleSheet Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Style Class
Label Class
ClassName Property

How To

Use External Style Sheets


StyleSheet Class Methods

StyleSheet Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : StyleSheet Class

For a list of all members of this type, see StyleSheet members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a new Style object to the collection.
Public Method | Clear | Removes the SytleSheet object from the collection.
Public Method | Contains | Determines whether the StyleSheet object contains the specified object.
Public Method | CopyTo | Copies the Style object to the indicated location.
Public Method | IndexOf | Returns the index of the first occurrence of a value in the collection.
Public Method | Insert | Inserts the specified StyleSheet into the collection at the specified index.
Public Method | Remove | Overloaded. Removes a style from the collection.
Public Method | RemoveAt | Removes the StyleSheet object at the specified location from the collection.
Top
See Also

Reference

StyleSheet Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Style Class
Label Class
ClassName Property

How To

Use External Style Sheets


Add Method (StyleSheet)

Add Method (StyleSheet)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : Add Method
Adds a new Style object to the collection.
Overload List
Overload | Description
Add(String) | Adds a new Style object with the specified name to the collection.
Add(String,String) | Adds a new Style object to the collection and sets its parent style to the specified parent Style.
Example
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub
See Also

Reference

StyleSheet Class
StyleSheet Members


Add(String) Method

Add(String) Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class > Add Method : Add(String) Method
Specifies the name of the new style. Used as a key to access the style.
Adds a new Style object with the specified name to the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal name As System.String _
)
public void Add(
   System.string name
)

Parameters

name
Specifies the name of the new style. Used as a key to access the style.
Example
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Add(String,String) Method

Add(String,String) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class > Add Method : Add(String,String) Method
Specifies the name of the new Style object.
Specifies the parent Style whose properties will be inherited by the new Style.
Adds a new Style object to the collection and sets its parent style to the specified parent Style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal name As System.String, _
   ByVal nameOfParent As System.String _
)
public void Add(
   System.string name,
   System.string nameOfParent
)

Parameters

name
Specifies the name of the new Style object.
nameOfParent
Specifies the parent Style whose properties will be inherited by the new Style.
Remarks
Styles are cascaded. Any properties not specified in the child Style are inherited from the parent Style.
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Clear Method (StyleSheet)

Clear Method (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : Clear Method
Removes the SytleSheet object from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

StyleSheet Class
StyleSheet Members


Contains Method (StyleSheet)

Contains Method (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : Contains Method
The value to check.
Determines whether the StyleSheet object contains the specified object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal value As System.Object _
) As System.Boolean
public System.bool Contains(
   System.object value
)

Parameters

value
The value to check.

Return Value

Boolean. Returns True if the collection contains the value; otherwise False
See Also

Reference

StyleSheet Class
StyleSheet Members


CopyTo Method (StyleSheet)

CopyTo Method (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : CopyTo Method
The one-dimensional Array that is the destination of the elements copied from StyleSheet. The Array must have zero-based indexing.
The zero-based index in array at which copying begins.
Copies the Style object to the indicated location.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal array As System.Array, _
   ByVal index As System.Integer _
)
public void CopyTo(
   System.Array array,
   System.int index
)

Parameters

array
The one-dimensional Array that is the destination of the elements copied from StyleSheet. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.
See Also

Reference

StyleSheet Class
StyleSheet Members


IndexOf Method (StyleSheet)

IndexOf Method (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : IndexOf Method

The StyleSheet object to locate in the collection.

Returns the index of the first occurrence of a value in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal value As System.Object _
) As System.Integer
public System.int IndexOf(
   System.object value
)

Parameters

value

The StyleSheet object to locate in the collection.

Return Value

The index of value if found in the list; otherwise, -1.
See Also

Reference

StyleSheet Class
StyleSheet Members


Insert Method (StyleSheet)

Insert Method (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : Insert Method
The index at which to insert the StyleSheet object.
The StyleSheet to insert.
Inserts the specified StyleSheet into the collection at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal value As System.Object _
)
public void Insert(
   System.int index,
   System.object value
)

Parameters

index
The index at which to insert the StyleSheet object.
value
The StyleSheet to insert.
See Also

Reference

StyleSheet Class
StyleSheet Members


Remove Method (StyleSheet)

Remove Method (StyleSheet)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : Remove Method
Removes a style from the collection.
Removes the Style object from the collection.
Overload List
Overload | Description
Remove(Int32) | Removes the Style object at the specified index.
Remove(String) | Removes the Style object with the specified name.
Example
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub
See Also

Reference

StyleSheet Class
StyleSheet Members


Remove(Int32) Method

Remove(Int32) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class > Remove Method : Remove(Int32) Method
Specifies the index of the Style object to be removed from the collection.
Removes the Style object at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Remove( _
   ByVal index As System.Integer _
)
public void Remove(
   System.int index
)

Parameters

index
Specifies the index of the Style object to be removed from the collection.
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Remove(String) Method

Remove(String) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class > Remove Method : Remove(String) Method
Specified the name of the Style to be removed from the collection.
Removes the Style object with the specified name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Remove( _
   ByVal name As System.String _
)
public void Remove(
   System.string name
)

Parameters

name
Specified the name of the Style to be removed from the collection.
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


RemoveAt Method (StyleSheet)

RemoveAt Method (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : RemoveAt Method
The index of the StyleSheet to remove.
Removes the StyleSheet object at the specified location from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The index of the StyleSheet to remove.
See Also

Reference

StyleSheet Class
StyleSheet Members


StyleSheet Class Properties

StyleSheet Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : StyleSheet Class

For a list of all members of this type, see StyleSheet members.

Public Properties
 | Name | Description
Public Property | Count | Returns the number of Style objects in the collection.
Public Property | Item | Overloaded. Returns a reference to a Style object in the collection.
Top
See Also

Reference

StyleSheet Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Style Class
Label Class
ClassName Property

How To

Use External Style Sheets


Count Property (StyleSheet)

Count Property (StyleSheet)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : Count Property
Returns the number of Style objects in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}

Property Value

An integer value that represents the total number of styles in the collection.
Example
  • C#
private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = true;
    this.StyleSheet["MyStyle"].FontItalic = false;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = false;
    this.StyleSheet["MyStyle"].FontUnderline = false;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    if (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Console.WriteLine("contains " & Me.StyleSheet.Count.ToString & " stylesheets")
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub
See Also

Reference

StyleSheet Class
StyleSheet Members


Item Property (StyleSheet)

Item Property (StyleSheet)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : Item Property
Returns a reference to a Style object in the collection.
Overload List
Overload | Description
Item(Int32) | Gets the StyleSheet object at the specified indexed location in the StyleSheetCollection.
Item(String) | Gets the StyleSheet object with the specified name in the StyleSheetCollection.
Example
  • C#
Private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = True;
    this.StyleSheet["MyStyle"].FontItalic = False;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = False;
    this.StyleSheet["MyStyle"].FontUnderline = False;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    If (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub
See Also

Reference

StyleSheet Class
StyleSheet Members


Item(Int32) Property

Item(Int32) Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class > Item Property : Item(Int32) Property
Specifies the index of the Style to be returned.
Gets the StyleSheet object at the specified indexed location in the StyleSheetCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal index As System.Integer _
) As Style
public Style Item(
   System.int index
) {get;}

Parameters

index
Specifies the index of the Style to be returned.
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Item(String) Property

Item(String) Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class > Item Property : Item(String) Property
Specifies the name of the Style object to be returned.
Gets the StyleSheet object with the specified name in the StyleSheetCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal name As System.String _
) As Style
public Style Item(
   System.string name
) {get;}

Parameters

name
Specifies the name of the Style object to be returned.
Example
  • C#
Private void SectionReport1_ReportStart(object sender, System.EventArgs eArgs)
{
    this.StyleSheet.Add("MyStyle");
    this.StyleSheet["MyStyle"].Alignment = TextAlignment.Center;
    this.StyleSheet["MyStyle"].BackColor = System.Drawing.Color.White;
    this.StyleSheet["MyStyle"].FontBold = True;
    this.StyleSheet["MyStyle"].FontItalic = False;
    this.StyleSheet["MyStyle"].FontName = "Arial";
    this.StyleSheet["MyStyle"].FontSize = null;
    this.StyleSheet["MyStyle"].FontStrikeThrough = False;
    this.StyleSheet["MyStyle"].FontUnderline = False;
    this.StyleSheet["MyStyle"].ForeColor = System.Drawing.Color.YellowGreen;
    Console.WriteLine(this.StyleSheet["MyStyle"].Name.ToString());
    Console.WriteLine(this.StyleSheet["MyStyle"].Value.ToString());
    this.StyleSheet["MyStyle"].VerticalAlignment = VerticalTextAlignment.Middle;

    Label1.ClassName = "MyStyle";

    If (this.StyleSheet.Count > 10)
    {
        this.StyleSheet.Remove("MyStyle");
    }
}
  • Visual Basic
Private Sub SectionReport1_ReportStart(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportStart
   Me.StyleSheet.Add("MyStyle")
   Me.StyleSheet("MyStyle").Alignment = TextAlignment.Center
   Me.StyleSheet("MyStyle").BackColor = System.Drawing.Color.White
   Me.StyleSheet("MyStyle").FontBold = True
   Me.StyleSheet("MyStyle").FontItalic = False
   Me.StyleSheet("MyStyle").FontName = "Arial"
   Me.StyleSheet("MyStyle").FontSize = Nothing
   Me.StyleSheet("MyStyle").FontStrikeThrough = False
   Me.StyleSheet("MyStyle").FontUnderline = False
   Me.StyleSheet("MyStyle").ForeColor = System.Drawing.Color.YellowGreen
   Console.WriteLine(Me.StyleSheet("MyStyle").Name.ToString())
   Console.WriteLine(Me.StyleSheet("MyStyle").Value.ToString())
   Me.StyleSheet("MyStyle").VerticalAlignment = VerticalTextAlignment.Middle

   Label1.ClassName = "MyStyle"

   If Me.StyleSheet.Count > 10 Then
       Me.StyleSheet.Remove("MyStyle")
   End If

End Sub
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


StyleSheet Class Events

StyleSheet Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : StyleSheet Class

For a list of all members of this type, see StyleSheet members.

Public Events
 | Name | Description
Public Event | Changed | Occurs when the members of the StyleSheet have changed.
Top
See Also

Reference

StyleSheet Class
GrapeCity.ActiveReports.SectionReportModel Namespace
Style Class
Label Class
ClassName Property

How To

Use External Style Sheets


Changed Event (StyleSheet)

Changed Event (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > StyleSheet Class : Changed Event
Occurs when the members of the StyleSheet have changed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Changed As System.EventHandler
public event System.EventHandler Changed
See Also

Reference

StyleSheet Class
StyleSheet Members


SubReport Class

SubReport Class
Members Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : SubReport Class
Prints a linked report object as part of the current report. Subreports are linked using the Report property.
Object Model
SubReport Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class SubReport
   Inherits ARControl
public sealed class SubReport : ARControl
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.SubReport1.CanGrow = true;
    this.SubReport1.CanShrink = false;
    this.SubReport1.ReportName = "Subreport1";

    SectionReport1 rpt = new SectionReport1();
    this.SubReport1.Report = rpt;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.SubReport1.CanGrow = True
   Me.SubReport1.CanShrink = False
   Me.SubReport1.ReportName = "Subreport1"

   Dim rpt As New rptSub1()
   Me.SubReport1.Report = rpt
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.SubReport

See Also

Reference

SubReport Members
GrapeCity.ActiveReports.SectionReportModel Namespace


SubReport Class Members

SubReport Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : SubReport Class

The following tables list the members exposed by SubReport.

Public Constructors
 | Name | Description
Public Constructor | SubReport Constructor | Initializes a new instance of the SubReport class.
Top
Public Properties
 | Name | Description
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | CanShrink | Determines whether ActiveReports should decrease the height of the field based on its value.
Public Property | CloseBorder | Determines whether or not subreport borders will be closed on every page on which the subreport is rendered.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Report | Gets or sets a reference to the instance of the report that this control will embed and render as part of the containing section.
Public Property | ReportName | Specifies the name of the subreport.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose() | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

SubReport Class
GrapeCity.ActiveReports.SectionReportModel Namespace


SubReport Constructor

SubReport Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > SubReport Class : SubReport Constructor
Initializes a new instance of the SubReport class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public SubReport()
See Also

Reference

SubReport Class
SubReport Members


SubReport Class Properties

SubReport Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : SubReport Class

For a list of all members of this type, see SubReport members.

Public Properties
 | Name | Description
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | CanShrink | Determines whether ActiveReports should decrease the height of the field based on its value.
Public Property | CloseBorder | Determines whether or not subreport borders will be closed on every page on which the subreport is rendered.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Report | Gets or sets a reference to the instance of the report that this control will embed and render as part of the containing section.
Public Property | ReportName | Specifies the name of the subreport.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

SubReport Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CanGrow Property (SubReport)

CanGrow Property (SubReport)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > SubReport Class : CanGrow Property
Determines whether ActiveReports should increase the height of the control based on its content.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CanGrow As System.Boolean
public System.bool CanGrow {get; set;}

Property Value

A Boolean value that determines the behavior. If False, ActiveReports clips the text to fit within the control's predefined height. If True, ActiveReports increases the height of the controls and shifts all controls below it to account for the increase in height.
Remarks
The increase in height might cause the section height to increase. The section's CanGrow property should be set to True to avoid clipping the section.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.subReport1.CanGrow = true;
    this.subReport1.CanShrink = false;
    this.subReport1.ReportName = "Subreport1";

    rptSub1 rpt = new rptSub1();
    this.subReport1.Report = rpt;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.SubReport1.CanGrow = True
   Me.SubReport1.CanShrink = False
   Me.SubReport1.ReportName = "Subreport1"

   Dim rpt As New rptSub1()
   Me.SubReport1.Report = rpt
End Sub
See Also

Reference

SubReport Class
SubReport Members
ActiveReports6~GrapeCity.ActiveReports.SubReport~CanShrink


CanShrink Property (SubReport)

CanShrink Property (SubReport)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > SubReport Class : CanShrink Property
Determines whether ActiveReports should decrease the height of the field based on its value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CanShrink As System.Boolean
public System.bool CanShrink {get; set;}

Property Value

A Boolean value that determines the behavior. If False, ActiveReports does not change the height of the control based on the size of its content. If True, ActiveReports decreases the height of the control and shifts all controls below it to account for the decrease in height.
Remarks
The decrease in height might cause the section height to decrease when the section's CanShrink property is set to True. ActiveReports does not shift any controls below the shrinking control unless there are not intersecting controls along the shifting path.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.subReport1.CanGrow = true;
    this.subReport1.CanShrink = false;
    this.subReport1.ReportName = "Subreport1";

    rptSub1 rpt = new rptSub1();
    this.subReport1.Report = rpt;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.SubReport1.CanGrow = True
   Me.SubReport1.CanShrink = False
   Me.SubReport1.ReportName = "Subreport1"

   Dim rpt As New rptSub1()
   Me.SubReport1.Report = rpt
End Sub
See Also

Reference

SubReport Class
SubReport Members
ActiveReports6~GrapeCity.ActiveReports.SubReport~CanGrow


CloseBorder Property

CloseBorder Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > SubReport Class : CloseBorder Property
Determines whether or not subreport borders will be closed on every page on which the subreport is rendered.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CloseBorder As System.Boolean
public System.bool CloseBorder {get; set;}

Property Value

A Boolean value. If True, the subreport borders will be closed on every page on which the subreport is rendered. The default value is False.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.subReport1.CanGrow = true;
    this.subReport1.CanShrink = false;
    this.subReport1.CloseBorder = true;
    this.subReport1.ReportName = "Subreport1";

    rptSub1 rpt = new rptSub1();
    this.subReport1.Report = rpt;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.SubReport1.CanGrow = True
   Me.SubReport1.CanShrink = False
   Me.SubReport1.CloseBorder = True
   Me.SubReport1.ReportName = "Subreport1"

   Dim rpt As New rptSub1()
   Me.SubReport1.Report = rpt
End Sub
See Also

Reference

SubReport Class
SubReport Members


Report Property (SubReport)

Report Property (SubReport)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > SubReport Class : Report Property
Gets or sets a reference to the instance of the report that this control will embed and render as part of the containing section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Report As SectionReport
public SectionReport Report {get; set;}
Remarks
You should set this property to a new instance of the report you want to render in the ReportStart event of the parent report.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.subReport1.CanGrow = true;
    this.subReport1.CanShrink = false;
    this.subReport1.ReportName = "Subreport1";

    rptSub1 rpt = new rptSub1();
    this.subReport1.Report = rpt;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.SubReport1.CanGrow = True
   Me.SubReport1.CanShrink = False
   Me.SubReport1.ReportName = "Subreport1"

   Dim rpt As New rptSub1()
   Me.SubReport1.Report = rpt
End Sub
See Also

Reference

SubReport Class
SubReport Members


ReportName Property (SubReport)

ReportName Property (SubReport)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > SubReport Class : ReportName Property
Specifies the name of the subreport.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportName As System.String
public System.string ReportName {get; set;}
Remarks
This property has no effect. It is informational only. You can use it for your own purposes.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.subReport1.CanGrow = true;
    this.subReport1.CanShrink = false;
    this.subReport1.ReportName = "Subreport1";

    rptSub1 rpt = new rptSub1();
    this.subReport1.Report = rpt;
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
   Me.SubReport1.CanGrow = True
   Me.SubReport1.CanShrink = False
   Me.SubReport1.ReportName = "Subreport1"

   Dim rpt As New rptSub1()
   Me.SubReport1.Report = rpt
End Sub
See Also

Reference

SubReport Class
SubReport Members


TextBox Class

TextBox Class
Members Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : TextBox Class
Prints a formatted text value, bound or unbound.
Object Model
TextBox Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class TextBox
   Inherits ARControl
public sealed class TextBox : ARControl
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Alignment = TextAlignment.Center;
    this.textBox1.BackColor = System.Drawing.Color.Transparent;
    this.textBox1.CanGrow = true;
    this.textBox1.CanShrink = false;
    this.textBox1.ClassName = "Normal";
    this.textBox1.DistinctField = null;
    this.textBox1.ForeColor = System.Drawing.Color.Black;
    this.textBox1.HyperLink = "mailto:support@company.com";
    this.textBox1.MultiLine = true;
    this.textBox1.OutputFormat = null;
    this.textBox1.SummaryFunc = SummaryFunc.Sum;
    this.textBox1.SummaryGroup = null;
    this.textBox1.SummaryRunning = SummaryRunning.None;
    this.textBox1.SummaryType = SummaryType.None;
    this.textBox1.Text = "TextBox";
    this.textBox1.VerticalAlignment = VerticalTextAlignment.Top;
    this.textBox1.WrapMode = GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.Alignment = TextAlignment.Center
   Me.TextBox1.BackColor = System.Drawing.Color.Transparent
   Me.TextBox1.CanGrow = True
   Me.TextBox1.CanShrink = False
   Me.TextBox1.ClassName = "Normal"
   Me.TextBox1.DistinctField = Nothing
   Me.TextBox1.ForeColor = System.Drawing.Color.Black
   Me.TextBox1.HyperLink = "mailto:support@company.com"
   Me.TextBox1.MultiLine = True
   Me.TextBox1.OutputFormat = Nothing
   Me.TextBox1.SummaryFunc = SummaryFunc.Sum
   Me.TextBox1.SummaryGroup = Nothing
   Me.TextBox1.SummaryRunning = SummaryRunning.None
   Me.TextBox1.SummaryType = SummaryType.None
   Me.TextBox1.Text = "TextBox"
   Me.TextBox1.VerticalAlignment = VerticalTextAlignment.Top
   Me.TextBox1.WrapMode = GrapeCity.ActiveReports.Document.Section.WrapMode.NoWrap
End Sub
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.TextBox

See Also

Reference

TextBox Members
GrapeCity.ActiveReports.SectionReportModel Namespace


TextBox Class Members

TextBox Class Members
Properties Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : TextBox Class

The following tables list the members exposed by TextBox.

Public Constructors
 | Name | Description
Public Constructor | TextBox Constructor | Initializes a new instance of the TextBox class.
Top
Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the alignment of text within the bounds of the control.
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | CanShrink | Determines whether ActiveReports should decrease the height of the field based on its value.
Public Property | CharacterSpacing | Gets or sets the distance in points between individual characters in the textbox control.
Public Property | ClassName | Gets or sets a style rule class name. The style rule is used to format the control.
Public Property | CountNullValues | Determines whether DBNull values should be included as zeroes in summary fields.
Public Property | Culture | Gets or sets the culture for the text control.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | DistinctField | Gets or sets the name of the data field used in a distinct summary function.
Public Property | Font | Gets or returns the font object used to print the control text.
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | HyperLink | Gets or sets a hyperlink for the text control.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | LineSpacing | Gets or sets the spacing in points between the lines of text within the textbox.
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | MultiLine | Gets or sets a value indicating whether this is a multiline textbox control.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | OutputFormat | Gets or sets the mask string used to format the Value property before placing it in the Text property.
Public Property | Padding | Gets or sets padding within the control.
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | RightToLeft | Sets or returns a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Public Property | ShrinkToFit | Gets ot sets the value indicating whether the TextBox should decrease the font size in order to fit the content.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Style | Gets or sets a style string for the textbox.
Public Property | SummaryFunc | Gets or sets the summary function type used to process the DataField values.
Public Property | SummaryGroup | Gets or sets the name of the group header section that is used to reset the summary value when calculating subtotals.
Public Property | SummaryRunning | Gets or sets a value that determines whether the data field summary value will be accumulated or reset for each level (detail, group or page).
Public Property | SummaryType | Gets or sets a value that determines the summary type to be performed.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Text | Gets or sets the formatted text value to be rendered in the control.
Public Property | TextJustify | Gets or sets the type of justification to use when the Alignment property is set to Justify.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Value | Gets or sets the value of the control before formatting.
Public Property | VerticalAlignment | Gets or sets the position of the control's text vertically within the bounds of the control.
Public Property | VerticalText | Gets or sets whether the control's text is rendered according to the vertical layout rules.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | WrapMode | Indicates how and whether a multi-line text control automatically wraps words to the beginning of the next line when necessary.
Top
Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

TextBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


TextBox Constructor

TextBox Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : TextBox Constructor
Initializes a new instance of the TextBox class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public TextBox()
See Also

Reference

TextBox Class
TextBox Members


TextBox Class Properties

TextBox Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : TextBox Class

For a list of all members of this type, see TextBox members.

Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the alignment of text within the bounds of the control.
Public Property | BackColor | Gets or sets the background color of the control area.
Public Property | Border | Gets a border object that defines the border style for each edge of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | CanGrow | Determines whether ActiveReports should increase the height of the control based on its content.
Public Property | CanShrink | Determines whether ActiveReports should decrease the height of the field based on its value.
Public Property | CharacterSpacing | Gets or sets the distance in points between individual characters in the textbox control.
Public Property | ClassName | Gets or sets a style rule class name. The style rule is used to format the control.
Public Property | CountNullValues | Determines whether DBNull values should be included as zeroes in summary fields.
Public Property | Culture | Gets or sets the culture for the text control.
Public Property | DataField | Gets or sets the field name from the data source to bind to the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | DistinctField | Gets or sets the name of the data field used in a distinct summary function.
Public Property | Font | Gets or returns the font object used to print the control text.
Public Property | ForeColor | Gets or returns the foreground (font) color of the control.
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | HyperLink | Gets or sets a hyperlink for the text control.
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | LineSpacing | Gets or sets the spacing in points between the lines of text within the textbox.
Public Property | Location | Gets or sets the location of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | MultiLine | Gets or sets a value indicating whether this is a multiline textbox control.
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | OutputFormat | Gets or sets the mask string used to format the Value property before placing it in the Text property.
Public Property | Padding | Gets or sets padding within the control.
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | RightToLeft | Sets or returns a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Public Property | ShrinkToFit | Gets ot sets the value indicating whether the TextBox should decrease the font size in order to fit the content.
Public Property | Size | Gets or sets the size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Style | Gets or sets a style string for the textbox.
Public Property | SummaryFunc | Gets or sets the summary function type used to process the DataField values.
Public Property | SummaryGroup | Gets or sets the name of the group header section that is used to reset the summary value when calculating subtotals.
Public Property | SummaryRunning | Gets or sets a value that determines whether the data field summary value will be accumulated or reset for each level (detail, group or page).
Public Property | SummaryType | Gets or sets a value that determines the summary type to be performed.
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Text | Gets or sets the formatted text value to be rendered in the control.
Public Property | TextJustify | Gets or sets the type of justification to use when the Alignment property is set to Justify.
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Value | Gets or sets the value of the control before formatting.
Public Property | VerticalAlignment | Gets or sets the position of the control's text vertically within the bounds of the control.
Public Property | VerticalText | Gets or sets whether the control's text is rendered according to the vertical layout rules.
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | WrapMode | Indicates how and whether a multi-line text control automatically wraps words to the beginning of the next line when necessary.
Top
See Also

Reference

TextBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Alignment Property (TextBox)

Alignment Property (TextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : Alignment Property
Gets or sets the alignment of text within the bounds of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Alignment As TextAlignment
public TextAlignment Alignment {get; set;}

Property Value

TextAlignment enumeration. The default value is TextAlignment.Left.
Remarks
The Justify text alignment option is not supported in edit mode. The text alignment automatically changes from Justify to Left (default value) when the control is in edit mode, and then back to Justify after exiting edit mode.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Alignment = TextAlignment.Center;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.Alignment = TextAlignment.Center
End Sub
See Also

Reference

TextBox Class
TextBox Members


BackColor Property (TextBox)

BackColor Property (TextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : BackColor Property
Gets or sets the background color of the control area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackColor As Color
public Color BackColor {get; set;}

Property Value

System.Drawing.Color.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.BackColor = System.Drawing.Color.Transparent;
    this.textBox1.ForeColor = System.Drawing.Color.Black;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.BackColor = System.Drawing.Color.Transparent
   Me.TextBox1.ForeColor = System.Drawing.Color.Black
End Sub
See Also

Reference

TextBox Class
TextBox Members


CanGrow Property (TextBox)

CanGrow Property (TextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : CanGrow Property
Determines whether ActiveReports should increase the height of the control based on its content.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CanGrow As System.Boolean
public System.bool CanGrow {get; set;}

Property Value

A Boolean value that determines the behavior. If False, ActiveReports clips the text to fit within the control's predefined height. If True, ActiveReports increases the height of the controls and shifts all controls below it to account for the increase in height.
Remarks
The increase in height might cause the section height to increase. The section's CanGrow property should be set to True to avoid clipping the section.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.CanGrow = true;
    this.textBox1.CanShrink = false;
    this.textBox1.MultiLine = true;
    this.textBox1.WordWrap = true;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.CanGrow = True
   Me.TextBox1.CanShrink = False
   Me.TextBox1.MultiLine = True
   Me.TextBox1.WordWrap = True
End Sub
See Also

Reference

TextBox Class
TextBox Members
ActiveReports6~GrapeCity.ActiveReports.TextBox~CanShrink


CanShrink Property (TextBox)

CanShrink Property (TextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : CanShrink Property
Determines whether ActiveReports should decrease the height of the field based on its value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CanShrink As System.Boolean
public System.bool CanShrink {get; set;}

Property Value

A Boolean value that determines the behavior. If False, ActiveReports does not change the height of the control based on the size of its content. If True, ActiveReports decreases the height of the control and shifts all controls below it to account for the decrease in height.
Remarks
The decrease in height might cause the section height to decrease when the section's CanShrink property is set to True. ActiveReports does not shift any controls below the shrinking control unless there are not intersecting controls along the shifting path.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.CanGrow = true;
    this.textBox1.CanShrink = false;
    this.textBox1.MultiLine = true;
    this.textBox1.WordWrap = true;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.CanGrow = True
   Me.TextBox1.CanShrink = False
   Me.TextBox1.MultiLine = True
   Me.TextBox1.WordWrap = True
End Sub
See Also

Reference

TextBox Class
TextBox Members
ActiveReports6~GrapeCity.ActiveReports.TextBox~CanGrow
ActiveReports6~GrapeCity.ActiveReports.Section~CanShrink


CharacterSpacing Property (TextBox)

CharacterSpacing Property (TextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : CharacterSpacing Property
Gets or sets the distance in points between individual characters in the textbox control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CharacterSpacing As System.Single
public System.float CharacterSpacing {get; set;}
Remarks
The integrity of character spacing cannot be guaranteed to correctly duplicate your settings when exporting reports in XLS, RTF, and TEXT formats.
Example
  • C#
private void detail_Format(object sender, EventArgs e)
{
   this.textBox1.CanGrow = true;
   this.textBox1.MultiLine = true;
   this.textBox1.CharacterSpacing = 2;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.CanGrow = True
   Me.TextBox1.MultiLine = True
   Me.TextBox1.CharacterSpacing = 2
End Sub
See Also

Reference

TextBox Class
TextBox Members


ClassName Property (TextBox)

ClassName Property (TextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : ClassName Property
Gets or sets a style rule class name. The style rule is used to format the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ClassName As System.String
public System.string ClassName {get; set;}

Property Value

String value that represents the style class name used to format the control's appearance. Default is Normal.
Remarks
You can use predefined styles in the report's stylesheet or add new ones to it.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.ClassName = "Normal";
    this.textBox1.OutputFormat = null;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.ClassName = "Normal"
   Me.TextBox1.OutputFormat = Nothing
End Sub
See Also

Reference

TextBox Class
TextBox Members
ActiveReports6~GrapeCity.ActiveReports.TextBox~Style
ActiveReports6~GrapeCity.ActiveReports.Style
ActiveReports6~GrapeCity.ActiveReports.StyleSheet


CountNullValues Property

CountNullValues Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : CountNullValues Property
Determines whether DBNull values should be included as zeroes in summary fields.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CountNullValues As System.Boolean
public System.bool CountNullValues {get; set;}

Property Value

Boolean. The default value is False.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.ClassName = "Normal";
    this.textBox1.OutputFormat = null;
    this.textBox1.CountNullValues = true;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.ClassName = "Normal"
   Me.TextBox1.OutputFormat = Nothing
   TextBox1.CountNullValues = True;
End Sub
See Also

Reference

TextBox Class
TextBox Members


Culture Property (TextBox)

Culture Property (TextBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : Culture Property
Gets or sets the culture for the text control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Culture As System.Globalization.CultureInfo
public System.Globalization.CultureInfo Culture {get; set;}
See Also

Reference

TextBox Class
TextBox Members


DistinctField Property

DistinctField Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : DistinctField Property

Gets or sets the name of the data field used in a distinct summary function.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DistinctField As System.String
public System.string DistinctField {get; set;}

Property Value

A string value that represents the field name to be used as a distinct field in the summary calculation.
Remarks

The summary function will process DataField values based on the distinct value of this field.

This property is used only when the SummaryFunc value is one of Distinct Summary Functions. When using the summary functions with a field, the CanGrow and CanShrink properties are disabled for the field.

Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.DistinctField = null;
    this.textBox1.SummaryFunc = SummaryFunc.Sum;
    this.textBox1.SummaryGroup = null;
    this.textBox1.SummaryRunning = SummaryRunning.None;
    this.textBox1.SummaryType = SummaryType.None;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.DistinctField = Nothing
   Me.TextBox1.SummaryFunc = SummaryFunc.Sum
   Me.TextBox1.SummaryGroup = Nothing
   Me.TextBox1.SummaryRunning = SummaryRunning.None
   Me.TextBox1.SummaryType = SummaryType.None
End Sub
See Also

Reference

TextBox Class
TextBox Members
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryFunc


Font Property (TextBox)

Font Property (TextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : Font Property
Gets or returns the font object used to print the control text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Font As Font
public Font Font {get; set;}

Property Value

Current Font object used to render the control's text.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.Font = new System.Drawing.Font("Times New Roman", 14, System.Drawing.FontStyle.Bold);
}
  • Visual Basic
Private Sub GroupFooter1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles GroupFooter1.Format
    Me.TextBox1.Font = New System.Drawing.Font("Times New Roman", 14, FontStyle.Bold)
End Sub
See Also

Reference

TextBox Class
TextBox Members


ForeColor Property (TextBox)

ForeColor Property (TextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : ForeColor Property
Gets or returns the foreground (font) color of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ForeColor As Color
public Color ForeColor {get; set;}

Property Value

Current font color. Default is Color.Black.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.BackColor = System.Drawing.Color.Transparent;
    this.textBox1.ForeColor = System.Drawing.Color.Black;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.BackColor = System.Drawing.Color.Transparent
   Me.TextBox1.ForeColor = System.Drawing.Color.Black
End Sub
See Also

Reference

TextBox Class
TextBox Members
ActiveReports6~GrapeCity.ActiveReports.TextBox~BackColor


HyperLink Property (TextBox)

HyperLink Property (TextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : HyperLink Property
Gets or sets a hyperlink for the text control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HyperLink As System.String
public System.string HyperLink {get; set;}

Property Value

A string value that specifies the target of the hyperlink.
Remarks

Hyperlinks can be used in the viewer control to allow users to link to a bookmark in the report "toc://bookmark" or to a properly formatted internet target location (http, ftp, etc).

Clicking a hyperlink in the viewer control raises the HyperLink event.

Note: When using the HtmlViewer, the RawHtml, the Flash Viewer or the Silverlight Viewer to display a report, you should indicate the full URL address (for example, "http://grapecity.com") for this property.

Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.HyperLink = "mailto:support@company.com";
    this.textBox1.Text = "Email support.";
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.HyperLink = "mailto:support@company.com"
   Me.TextBox1.Text = "Email support."
End Sub
See Also

Reference

TextBox Class
TextBox Members


LineSpacing Property (TextBox)

LineSpacing Property (TextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : LineSpacing Property
Gets or sets the spacing in points between the lines of text within the textbox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineSpacing As System.Single
public System.float LineSpacing {get; set;}
Example
  • C#
private void detail_Format(object sender, EventArgs e)
{
   this.textBox1.CanGrow = True;
   this.textBox1.MultiLine = True;
   this.textBox1.LineSpacing = 5;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.CanGrow = True
   Me.TextBox1.MultiLine = True
   Me.TextBox1.LineSpacing = 5
End Sub
See Also

Reference

TextBox Class
TextBox Members


MultiLine Property (TextBox)

MultiLine Property (TextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : MultiLine Property
Gets or sets a value indicating whether this is a multiline textbox control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MultiLine As System.Boolean
public System.bool MultiLine {get; set;}

Property Value

A Boolean value. True if the textbox control is multi-line; otherwise, False.
Remarks
A multiline textbox control renders its text on more than one line. If the WordWrap property is set to True, long lines will be wrapped to the following line. If the WordWrap property is set to False, the text will print on a new line only when a newline character is encountered.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.CanGrow = true;
    this.TextBox1.CanShrink = false;
    this.TextBox1.MultiLine = true;
    this.TextBox1.WordWrap = true;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.CanGrow = True
   Me.TextBox1.CanShrink = False
   Me.TextBox1.MultiLine = True
   Me.TextBox1.WordWrap = True
End Sub
See Also

Reference

TextBox Class
TextBox Members
ActiveReports6~GrapeCity.ActiveReports.TextBox~WordWrap


OutputFormat Property

OutputFormat Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : OutputFormat Property
Gets or sets the mask string used to format the Value property before placing it in the Text property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OutputFormat As System.String
public System.string OutputFormat {get; set;}
Remarks

The formatting mask can only be used to format numbers and dates. There is no support for formatting alphanumeric strings.

Setting the OutputFormat in the Format event of a control's section does not catch the first record. The reason for this behaviour is that the database values are applied to the the control BEFORE the Format event. If you change the OutputFormat in the Format event, set Control.Value=Control.Value so that the OutputFormat gets reapplied.

Underscore (_) keycode can be used in OutputFormat property to skip the width of the next character. This code is commonly used as _) to leave space for a closing parenthesis in a positive number format when the negative number format includes parentheses. This allows both positive and negative values to line up at the decimal point.

The OutputFormat property of the TextBox control includes four sections delimited by a semicolon. Each section contains the format specifications for a different type of number:

  • The first section provides the format for positive numbers.
  • The second section provides the format for negative numbers.
  • The third section provides the format for Zero values.
  • The fourth section provides the format for Null or System.DBNull values.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.txtShippedDate.OutputFormat = "MMMM";
    this.txtShippedDate.Value = this.txtShippedDate.Value;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.txtShippedDate.OutputFormat = "MMMM"
    Me.txtShippedDate.Value = Me.txtShippedDate.Value
End Sub
See Also

Reference

TextBox Class
TextBox Members

Concepts

Date, Time, and Number Formatting


Padding Property (TextBox)

Padding Property (TextBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : Padding Property
Gets or sets padding within the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Padding As PaddingEx
public PaddingEx Padding {get; set;}
Remarks
This property has five settings at design time: All, Left, Top, Right, and Bottom. More settings, like Vertical and Horizontal, are available in code. The All property has a default value of -1, which means that all of the Padding values are not equal. Change this value to 10, and a space ten pixels wide is left around the text on all sides. The Left, Top, Right, and Bottom properties are 0, 0, 0, 0 by default.
See Also

Reference

TextBox Class
TextBox Members


RightToLeft Property (TextBox)

RightToLeft Property (TextBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : RightToLeft Property
Sets or returns a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RightToLeft As System.Boolean
public System.bool RightToLeft {get; set;}

Property Value

true if [right to left]; otherwise, false.
See Also

Reference

TextBox Class
TextBox Members


ShrinkToFit Property (TextBox)

ShrinkToFit Property (TextBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : ShrinkToFit Property
Gets ot sets the value indicating whether the TextBox should decrease the font size in order to fit the content.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShrinkToFit As System.Boolean
public System.bool ShrinkToFit {get; set;}
See Also

Reference

TextBox Class
TextBox Members


Style Property (TextBox)

Style Property (TextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : Style Property
Gets or sets a style string for the textbox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As System.String
public System.string Style {get; set;}

Property Value

String. CSS syntax of the control style.
Remarks

The style string overrides the global style rules specified in ClassName property.

Style string syntax is based on Cascading Style Sheets syntax.

Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.txtShippedDate.Style = "text-align: center; font-weight: bold; font-size: 14pt;";
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
    Me.txtShippedDate.Style = "text-align: center; font-weight: bold; font-size: 14pt;"
End Sub
See Also

Reference

TextBox Class
TextBox Members
ActiveReports6~GrapeCity.ActiveReports.TextBox~ClassName
ActiveReports6~GrapeCity.ActiveReports.Style
ActiveReports6~GrapeCity.ActiveReports.StyleSheet


SummaryFunc Property

SummaryFunc Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : SummaryFunc Property
Gets or sets the summary function type used to process the DataField values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SummaryFunc As SummaryFunc
public SummaryFunc SummaryFunc {get; set;}

Property Value

SummaryFunc enumeration value that specifies the type of summarization to be performed on the field. Default is SummaryFunc.Sum
Remarks

You can use this function to create subtotals, grand totals and other summary values. SummaryFunc has no effect unless the SummaryType property is set to either SubTotal or GrandTotal.

Note: When a summary function is used on a control, the CanGrow and CanShrink properties will have no effect since the summary is calculated after the control height has been determined and finalized.

Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.SummaryFunc = SummaryFunc.Sum;
    this.TextBox1.SummaryGroup = null;
    this.TextBox1.SummaryRunning = SummaryRunning.None;
    this.TextBox1.SummaryType = SummaryType.None;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.SummaryFunc = SummaryFunc.Sum
   Me.TextBox1.SummaryGroup = Nothing
   Me.TextBox1.SummaryRunning = SummaryRunning.None
   Me.TextBox1.SummaryType = SummaryType.None
End Sub
See Also

Reference

TextBox Class
TextBox Members
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryGroup
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryRunning
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryType


SummaryGroup Property (TextBox)

SummaryGroup Property (TextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : SummaryGroup Property
Gets or sets the name of the group header section that is used to reset the summary value when calculating subtotals.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SummaryGroup As System.String
public System.string SummaryGroup {get; set;}
Remarks

For example, setting a sum of Price for an Order group header will reset the sum to zero for each order group. The property is only used when SummaryType is set to SummaryType.SubTotal

Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.textBox1.SummaryGroup = null;
    this.textBox1.SummaryRunning = SummaryRunning.None;
    this.textBox1.SummaryType = SummaryType.None;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.SummaryGroup = Nothing
   Me.TextBox1.SummaryRunning = SummaryRunning.None
   Me.TextBox1.SummaryType = SummaryType.None
End Sub
See Also

Reference

TextBox Class
TextBox Members
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryFunc
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryRunning
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryType


SummaryRunning Property (TextBox)

SummaryRunning Property (TextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : SummaryRunning Property
Gets or sets a value that determines whether the data field summary value will be accumulated or reset for each level (detail, group or page).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SummaryRunning As SummaryRunning
public SummaryRunning SummaryRunning {get; set;}

Property Value

SummaryRunning enumeration that determines the summarization behavior. Default is SummaryRunning.None.
Remarks

Setting this property to Group or All will make ActiveReports print a running summary of the field at the group or report level.

When used with Groups this property should only be set when SummaryType is GrandTotal or PageTotal, otherwise it should be set to None.

Example
  • C#
Private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.SummaryFunc = SummaryFunc.Sum;
    this.TextBox1.SummaryGroup = null;
    this.TextBox1.SummaryRunning = SummaryRunning.None;
    this.TextBox1.SummaryType = SummaryType.None;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.SummaryFunc = SummaryFunc.Sum
   Me.TextBox1.SummaryGroup = Nothing
   Me.TextBox1.SummaryRunning = SummaryRunning.None
   Me.TextBox1.SummaryType = SummaryType.None
End Sub
See Also

Reference

TextBox Class
TextBox Members
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryFunc
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryGroup
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryType


SummaryType Property

SummaryType Property
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : SummaryType Property
Gets or sets a value that determines the summary type to be performed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SummaryType As SummaryType
public SummaryType SummaryType {get; set;}

Property Value

A SummaryType enumeration value that determines the type of summary to be performed. Default is SummaryType.None.
Remarks

ActiveReports can summarize the field as:

  • Subtotal (group level; reset for each group),
  • Grand total (report level; do not reset until all records are processed),
  • Page total (page level; reset for each page),
  • or a page count, which is the total number of pages printed.

If the summarized field is placed ahead of its summary level, (for example, placing a page total in the page header or a report grand total in the report header), the containing section and the following sections will not be printed until the summary value is resolved (calculated). When using the summary functions with a field, the CanGrow and CanShrink properties are disabled for the field.

Example
  • C#
Private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.SummaryFunc = SummaryFunc.Sum;
    this.TextBox1.SummaryGroup = null;
    this.TextBox1.SummaryRunning = SummaryRunning.None;
    this.TextBox1.SummaryType = SummaryType.None;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.SummaryFunc = SummaryFunc.Sum
   Me.TextBox1.SummaryGroup = Nothing
   Me.TextBox1.SummaryRunning = SummaryRunning.None
   Me.TextBox1.SummaryType = SummaryType.None
End Sub
See Also

Reference

TextBox Class
TextBox Members
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryFunc
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryGroup
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryRunning


Text Property (TextBox)

Text Property (TextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : Text Property
Gets or sets the formatted text value to be rendered in the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Text As System.String
public System.string Text {get; set;}

Property Value

String value that represents the text to be rendered in the control.
Remarks
Use the Value property to modify the control's content, the Value will be formatted using OutputFormat into the Text property.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.Text = "TextBox";
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.Text = "TextBox"
End Sub
See Also

Reference

TextBox Class
TextBox Members


TextJustify Property (TextBox)

TextJustify Property (TextBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : TextJustify Property
Gets or sets the type of justification to use when the Alignment property is set to Justify.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TextJustify As TextJustify
public TextJustify TextJustify {get; set;}

Property Value

TextJustify enum. The default value is Auto. Possible values are:

  • Auto
  • Distribute
  • DistributeAllLines
Remarks
When you set the Alignment property to Justify, this property extends your justification options.
See Also

Reference

TextBox Class
TextBox Members


Value Property (TextBox)

Value Property (TextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : Value Property
Gets or sets the value of the control before formatting.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As System.Object
public System.object Value {get; set;}

Property Value

An object that represents the current value of the control.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    if (this.TextBox1.Value.ToString() == "10249")
    {
        this.txtShippedDate.OutputFormat = "MMMM";
        this.txtShippedDate.ForeColor = System.Drawing.Color.Crimson;
    }
    else
    {
        this.txtShippedDate.OutputFormat = "MMM";
        this.txtShippedDate.ForeColor = System.Drawing.Color.Black;
    }
    //use the following lines to be sure that the OutputFormat
    //is applied to every record
    this.TextBox1.Value = this.TextBox1.Value;
    this.txtShippedDate.Value = this.txtShippedDate.Value;
}
  • Visual Basic
Private Sub detail_Format(sender As Object, eArgs As System.EventArgs)
    If Me.TextBox1.Value.ToString() = "10249" Then
        Me.txtShippedDate.OutputFormat = "MMMM"
        Me.txtShippedDate.ForeColor = System.Drawing.Color.Crimson
    Else
        Me.txtShippedDate.OutputFormat = "MMM"
        Me.txtShippedDate.ForeColor = System.Drawing.Color.Black
    End If
    'use the following lines to be sure that the OutputFormat
    'is applied to every record
    Me.TextBox1.Value = Me.TextBox1.Value
    Me.txtShippedDate.Value = Me.txtShippedDate.Value
End Sub
See Also

Reference

TextBox Class
TextBox Members


VerticalAlignment Property (TextBox)

VerticalAlignment Property (TextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : VerticalAlignment Property
Gets or sets the position of the control's text vertically within the bounds of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property VerticalAlignment As VerticalTextAlignment
public VerticalTextAlignment VerticalAlignment {get; set;}

Property Value

VerticalTextAlignment enumeration value that represents the vertical alignment of the control's text. Default is VerticalTextAlignment.Top.
Example
  • C#
private void detail_Format(object sender, System.EventArgs eArgs)
{
    this.TextBox1.VerticalAlignment = VerticalTextAlignment.Top;
}
  • Visual Basic
Private Sub Detail1_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail1.Format
   Me.TextBox1.VerticalAlignment = VerticalTextAlignment.Top
End Sub
See Also

Reference

TextBox Class
TextBox Members


VerticalText Property (TextBox)

VerticalText Property (TextBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : VerticalText Property
Gets or sets whether the control's text is rendered according to the vertical layout rules.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property VerticalText As System.Boolean
public System.bool VerticalText {get; set;}
Remarks
In case of the HTML export filter, the vertical text is supported just for the DynamicHtml output type and works with Microsoft Internet Explorer only.
See Also

Reference

TextBox Class
TextBox Members


WrapMode Property (TextBox)

WrapMode Property (TextBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > TextBox Class : WrapMode Property
Indicates how and whether a multi-line text control automatically wraps words to the beginning of the next line when necessary.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WrapMode As WrapMode
public WrapMode WrapMode {get; set;}
See Also

Reference

TextBox Class
TextBox Members


BarCodeCaptionPosition Enumeration

BarCodeCaptionPosition Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : BarCodeCaptionPosition Enumeration
Specifies the barcode caption position relative to the barcode symbol.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum BarCodeCaptionPosition
   Inherits System.Enum
public enum BarCodeCaptionPosition : System.Enum
Members
Member | Description
Above | Caption is printed above the barcode symbol.
Below | Caption is printed below the barcode symbol.
None | Caption is not printed.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.BarCodeCaptionPosition

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.Barcode~CaptionPosition


BarCodeDirection Enumeration

BarCodeDirection Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : BarCodeDirection Enumeration
Specifies the print direction of the barcode symbol.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum BarCodeDirection
   Inherits System.Enum
public enum BarCodeDirection : System.Enum
Members
Member | Description
BottomToTop | The barcode symbol is printed bottom to top.
LeftToRight | The barcode symbol is printed left to right (default).
RightToLeft | The barcode symbol is printed right to left.
TopToBottom | The barcode symbol is printed top to bottom.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.BarCodeDirection

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.Barcode~Direction


BarCodeStyle Enumeration

BarCodeStyle Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : BarCodeStyle Enumeration

Type of code, or symbology, the barcode control will use to generate the barcode.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum BarCodeStyle
   Inherits System.Enum
public enum BarCodeStyle : System.Enum
Members
Member | Description
Ansi39 | ANSI 3 of 9 (Code 39) uses upper case, numbers, - , * $ / + %.
Ansi39x | ANSI Extended 3 of 9 (Extended Code 39) uses the complete ASCII character set.
Codabar | Codabar uses A B C D + - : , / and numbers.
Code_128_A | Code 128 A uses control characters, numbers, punctuation, and upper case.
Code_128_B | Code 128 B uses punctuation, numbers, upper case and lower case.
Code_128_C | Code 128 C uses only numbers.
Code_128auto | Code 128 Auto uses the complete ASCII character set. Automatically selects between Code 128 A, B and C to give the smallest barcode.
Code_2_of_5 | Code 2 of 5 uses only numbers.
Code_93 | Code 93 uses uppercase, % $ * / , + -, and numbers.
Code25intlv | Interleaved 2 of 5 uses only numbers.
Code39 | Code 39 uses numbers, % * $ /. , - +, and upper case.
Code39x | Extended Code 39 uses the complete ASCII character set.
Code49 | Code 49 is a 2D high-density stacked barcode. Encodes the complete ASCII character set.
Code93x | Extended Code 93 uses the complete ASCII character set.
DataMatrix | Data Matrix is a high density, two-dimensional barcode with square modules arranged in a square or rectangular matrix pattern.
EAN_13 | EAN-13 uses only numbers (12 numbers and a check digit). If there are only 12 numbers in the string, it calculates a checksum and adds it to the thirteenth position. If there are 13, it validates the checksum and throws an error if it is incorrect.
EAN_8 | EAN-8 uses only numbers (7 numbers and a check digit).
EAN128FNC1

EAN-128 is an alphanumeric one-dimensional representation of Application Identifier data. It is not meant for point-of-sales use, but for marking containers in the shipping industry.

This type of bar code contains the following sections:

  • Leading quiet zone (blank area)
  • Code 128 start character
    • A allows standard alphanumeric plus control and special characters
    • B allows standard alphanumeric plus lower case alpha and special characters
    • C allows a set of 100 digit pairs from 00 to 99
  • FNC (function) 1 character which allows scanners to identify this as an EAN-128 barcode
  • Data (AI or Application Identifier plus data field)
  • Symbol check character (Start code value plus product of each character position plus value of each character divided by 103. The checksum is the remainder value.)
  • Stop character
  • Trailing quiet zone (blank area)

The AI or Application Identifier in the Data section sets the type of the data to follow (i.e. ID, dates, quantity, measurements, etc.). There is a specific data structure for each type of data. This AI is what distinguishes the EAN-128 code from Code 128.

Multiple AIs (along with their data) can be combined into a single bar code.

EAN128FNC1 is a UCC/EAN-128 (EAN128) type barcode that allows you to insert FNC1 character at any place and adjust the bar size etc, which is not available in UCC/EAN-128.

To insert FNC1 character, set “\n” for C#, or “vbLf” for VB to Text property at runtime.

IntelligentMail | Intelligent Mail, formerly known as the 4-State Customer Barcode, is a 65-bar code used for domestic mail in the U.S.
JapanesePostal | This is the barcode used by the Japanese Postal system. Encodes alpha and numeric characters consisting of 18 digits including a 7-digit postal code number, optionally followed by block and house number information. The data to be encoded can include hyphens.
Matrix_2_of_5 | Matrix 2 of 5 is a higher density barcode consisting of 3 black bars and 2 white bars. Matrix_2_of_5 uses only numbers.
MicroPDF417 | MicroPDF417 is two-dimensional (2D), multi-row symbology, derived from PDF417. Micro-PDF417 is designed for applications that need to encode data in a two-dimensional (2D) symbol (up to 150 bytes, 250 alphanumeric characters, or 366 numeric digits) with the minimal symbol size.
MSI | MSI Code uses only numbers.
None | None.
Pdf417 | Pdf417 is a popular high-density 2-dimensional symbology that encodes up to 1108 bytes of information. This barcode consists of a stacked set of smaller barcodes. Encodes the full ASCII character set. Capable of encoding as many as 2725 data characters.
PostNet | PostNet uses only numbers with a check digit.
QRCode | QRCode is a 2D symbology that is capable of handling numeric, alphanumeric and byte data as well as Japanese kanji and kana characters. This symbology can encode up to 7,366 characters.
RM4SCC | Royal Mail RM4SCC uses only letters and numbers (with a check digit). This is the barcode used by the Royal Mail in the United Kingdom.
RSS14 | RSS14 is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is a 14-digit EAN.UCC item identification for use with omnidirectional point-of-sale scanners.
RSS14Stacked | RSS14Stacked is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is the same as RSS14Truncated, but stacked in two rows when RSS14Truncated is too wide.
RSS14StackedOmnidirectional | RSS14StackedOmnidirectional is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is the same as RSS14, but stacked in two rows when RSS14 is too wide.
RSS14Truncated | RSS14Truncated is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is a 14-digit EAN.UCC item identification plus Indicator digits for use on small items, not for point-of-sale scanners.
RSSExpanded | RSSExpanded is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is a 14-digit EAN.UCC item identification plus AI element strings (expiration date, weight, etc.) for use with omnidirectional point-of-sale scanners.
RSSExpandedStacked | RSSExpandedStacked is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is the same as RSSExpanded, but stacked in two rows when RSSExpanded is too wide.
RSSLimited | RSS Limited is a Reduced Space Symbology that encodes Composite Component (CC) extended EAN and UPC information in less space. This version is a 14-digit EAN.UCC item identification with indicator digits of 0 or 1 in a small symbol that is not scanned by point-of-sale scanners.
UCCEAN128 | UCC/EAN –128 uses the complete ASCII character Set. This is a special version of Code 128 used in HIBC applications.
UPC_A | UPC-A uses only numbers (11 numbers and a check digit).
UPC_E0 | UPC-E0 uses only numbers. Used for zero-compression UPC symbols. For the Caption property, you may enter either a six-digit UPC-E code or a complete 11-digit (includes code type, which must be 0 (zero)) UPC-A code. If an 11-digit code is entered, the Barcode control will convert it to a six-digit UPC-E code, if possible. If it is not possible to convert from the 11-digit code to the six-digit code, nothing is displayed.
UPC_E1 | UPC-E1 uses only numbers. Used typically for shelf labeling in the retail environment. The length of the input string for U.P.C. E1 is six numeric characters.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.BarCodeStyle

Requirements

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.Barcode~Style


ChartControl.UIAction Enumeration

ChartControl.UIAction Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ChartControl.UIAction Enumeration
Specifies the action to perform on the chart control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ChartControl.UIAction
   Inherits System.Enum
public enum ChartControl.UIAction : System.Enum
Members
Member | Description
Clear | Replace the selected Chart control with a new Chart. Please note that this clears all properties set on the Chart and restores all default values. (Same as clicking the "New Chart" link below the Properties Window.)
Customize | Shows the Chart Designer dialog.
OpenXml | Shows a File Open dialog from which you can choose a chart XML file to load into the control.
SaveXml | Shows a File Save As dialog from which you can save the current chart's settings to a chart XML file.
Wizard | Shows the Chart Wizard dialog.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.ChartControl.UIAction

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.ChartControl~ExecuteAction


ColumnDirection Enumeration

ColumnDirection Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ColumnDirection Enumeration
Specifies the direction of columns in a multi-column report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ColumnDirection
   Inherits System.Enum
public enum ColumnDirection : System.Enum
Members
Member | Description
AcrossDown | Print a row of details across all the columns before beginning a second row below it, and so on.
DownAcross | Prints a column of details down the first column before moving on to the next column to its right.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.ColumnDirection

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.Detail~ColumnDirection


GroupKeepTogether Enumeration

GroupKeepTogether Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupKeepTogether Enumeration
Specifies whether a group header and footer pair with associated details will print as a single block on the same page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum GroupKeepTogether
   Inherits System.Enum
public enum GroupKeepTogether : System.Enum
Members
Member | Description
All | The group header, detail and group footer sections will print together on the same page.
FirstDetail | The group header will print with at least the first detail section on the same page or column.
None | A page can be broken immediately after a group header.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.GroupKeepTogether

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.GroupHeader~GroupKeepTogether


ImageTypes Enumeration

ImageTypes Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ImageTypes Enumeration
Specifies the type of image to be used for a chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ImageTypes
   Inherits System.Enum
public enum ImageTypes : System.Enum
Members
Member | Description
Metafile | This is the default value. A metafile is used.
PNG | A PNG file is used.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.ImageTypes

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace


LineStyle Enumeration

LineStyle Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : LineStyle Enumeration
Specifies the pen style used to draw a line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LineStyle
   Inherits System.Enum
public enum LineStyle : System.Enum
Members
Member | Description
Dash | Dashes.
DashDot | Alternating dashes and dots.
DashDotDot | Alternating dashes and two dots.
Dot | Dots.
Solid | Solid line.
Transparent | No line.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.LineStyle

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.Picture~LineStyle
ActiveReports6~GrapeCity.ActiveReports.Line~LineStyle
ActiveReports6~GrapeCity.ActiveReports.Shape~LineStyle


NewColumn Enumeration

NewColumn Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : NewColumn Enumeration
Specifies whether a new column will be started before or after a section.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum NewColumn
   Inherits System.Enum
public enum NewColumn : System.Enum
Members
Member | Description
After | The report will break to a new column after each instance of the section.
Before | The report will break to a new column before each instance of the section.
BeforeAfter | The report will break to a new column before and after each instance of the section.
None | Sections will continue printing in the same column until they've run out of space.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.NewColumn

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.Detail~NewColumn
ActiveReports6~GrapeCity.ActiveReports.GroupFooter~NewColumn
ActiveReports6~GrapeCity.ActiveReports.GroupHeader~NewColumn


NewPage Enumeration

NewPage Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : NewPage Enumeration

Specifies whether a new page will be started before or after a section.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum NewPage
   Inherits System.Enum
public enum NewPage : System.Enum
Members
Member | Description
After | The report will break to a new page after each instance of the section.
Before | The report will break to a new page before each instance of the section.
BeforeAfter | The report will break to a new page before and after each instance of the section.
None | Sections will continue printing on the same page until they've run out of space.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.NewPage

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.Detail~NewPage
ActiveReports6~GrapeCity.ActiveReports.GroupFooter~NewPage
ActiveReports6~GrapeCity.ActiveReports.GroupHeader~NewPage
ActiveReports6~GrapeCity.ActiveReports.ReportFooter~NewPage
ActiveReports6~GrapeCity.ActiveReports.ReportHeader~NewPage


Parameter.DataType Enumeration

Parameter.DataType Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Parameter.DataType Enumeration
Specifies the data type used to create the input control for collection of report parameter values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Parameter.DataType
   Inherits System.Enum
public enum Parameter.DataType : System.Enum
Members
Member | Description
Boolean | Create a checkbox to collect the parameter value as a Boolean.
Date | Create a month calendar drop-down dialog to collect the parameter value as a date.
String | Create a textbox to collect the parameter value as a string.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.Parameter.DataType

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.Parameter~Type


ParameterCollection.ParseResultCode Enumeration

ParameterCollection.ParseResultCode Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ParameterCollection.ParseResultCode Enumeration
Specifies the results of parsing the report's parameter values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ParameterCollection.ParseResultCode
   Inherits System.Enum
public enum ParameterCollection.ParseResultCode : System.Enum
Members
Member | Description
MissingCloseParam | Indicates that the Parameter value is missing the parameter close.
MissingParamName | Indicates that the Parameter value is missing the parameter name.
Success | Indicates that the Parameter value is successful.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.ParameterCollection.ParseResultCode

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.ParameterCollection


PictureAlignment Enumeration

PictureAlignment Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PictureAlignment Enumeration
Determines the position of the picture within the control area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PictureAlignment
   Inherits System.Enum
public enum PictureAlignment : System.Enum
Members
Member | Description
BottomLeft | The picture will print in the bottom left corner of the control.
BottomRight | The picture will print in the bottom right corner of the control.
Center | The picture will be centered within the control.
TopLeft | The picture will print in the top left corner of the control.
TopRight | The picture will print in the top right corner of the control.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.PictureAlignment

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.OleObject~PictureAlignment
ActiveReports6~GrapeCity.ActiveReports.Picture~PictureAlignment
GrapeCity.ActiveReports.v10~GrapeCity.ActiveReports.SectionReportModel~WatermarkAlignment


RepeatStyle Enumeration

RepeatStyle Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RepeatStyle Enumeration

Specifies whether a group header section will be repeated with subsequent detail pages.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum RepeatStyle
   Inherits System.Enum
public enum RepeatStyle : System.Enum
Members
Member | Description
All | Repeat the group header section on every page or column.
None | The group header will not be repeated when the associated detail sections print on a new page.
OnColumn | Repeat the group header section with every new column.
OnPage | Repeat the group header section with every new page.
OnPageIncludeNoDetail | Repeat the group header section on every page that includes an associated detail section or a group footer section. This setting prevents orphaned group footer sections.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.RepeatStyle

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.GroupHeader~RepeatStyle


RichTextBox.FindOptions Enumeration

RichTextBox.FindOptions Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RichTextBox.FindOptions Enumeration

Specifies how a text search is carried out in a RichTextBox control.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum RichTextBox.FindOptions
   Inherits System.Enum
public enum RichTextBox.FindOptions : System.Enum
Members
Member | Description
MatchCase | Locate only instances of the search text that have the exact casing.
None | Locate all instances of the search text to determine whether the instances found in the search are whole words or not.
Reverse | Starts the search at the end of the control's document and searches to the beginning of the document.
WholeWord | Locate only instances of the search text that are whole words.
Remarks

An application locates text in the RichTextBox control by calling the Find method of the RichTextBox control. This enumeration enables you to specify how the search is performed when the Find method is called. You can combine one or more values from this enumeration to specify more than one search option when calling the Find method.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.RichTextBox.FindOptions

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~Find(String,Int32,FindOptions)


RichTextBox.RichTextStreamType Enumeration

RichTextBox.RichTextStreamType Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RichTextBox.RichTextStreamType Enumeration
Determines the RichText control's content type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum RichTextBox.RichTextStreamType
   Inherits System.Enum
public enum RichTextBox.RichTextStreamType : System.Enum
Members
Member | Description
PlainText | The RichText control contains a plain text stream that includes spaces in place of Object Linking and Embedding (OLE) objects.
RichText | The RichText control contains a Rich Text Format (RTF) stream.
UnicodePlainText | The RichText control contains a text stream that contains spaces in place of Object Linking and Embedding (OLE) objects. The text is encoded in Unicode.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.RichTextBox.RichTextStreamType

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.RichTextBox


RichTextType Enumeration

RichTextType Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : RichTextType Enumeration
Determines the type of stream to load into the RichTextBox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum RichTextType
   Inherits System.Enum
public enum RichTextType : System.Enum
Members
Member | Description
Html | Loads an html stream into the RichTextBox control.
Rtf | Loads an rtf stream into the RichTextBox control.
Text | Loads a plain text stream into the RichTextBox control.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.RichTextType

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~Load


ShapeType Enumeration

ShapeType Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ShapeType Enumeration
Specifies the type of shape that the shape control should print.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ShapeType
   Inherits System.Enum
public enum ShapeType : System.Enum
Members
Member | Description
Ellipse | Print an elliptical shape.
Rectangle | Print a rectangular shape.
RoundRect | Print a rounded rectangular shape.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.ShapeType

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.Shape~Style


SizeModes Enumeration

SizeModes Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : SizeModes Enumeration
Determines how a picture should be sized within the control area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum SizeModes
   Inherits System.Enum
public enum SizeModes : System.Enum
Members
Member | Description
Clip | The image is clipped to fit within the control area.
Stretch | The image is stretched to fit the control area.
Zoom | The image is scaled until it fits horizontally and vertically within the control area.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.SizeModes

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.OleObject~SizeMode
ActiveReports6~GrapeCity.ActiveReports.Picture~SizeMode
GrapeCity.ActiveReports.v10~GrapeCity.ActiveReports.SectionReportModel~WatermarkSizeMode


SummaryFunc Enumeration

SummaryFunc Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : SummaryFunc Enumeration
Determines the summary calculation function performed on the field value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum SummaryFunc
   Inherits System.Enum
public enum SummaryFunc : System.Enum
Members
Member | Description
Avg | Calculates the average of all values within the specified summary region (group, page or report).
Count | Calculates the count of all values within the specified summary region (group, page or report).
DAvg | Calculates the average based on the distinct values of another field within the specified summary region (group, page or report).
DCount | Calculates the distinct count based on the distinct values of another field within the specified summary region (group, page or report).
DStdDev | Calculates the standard deviation based on the distinct values of another field within the specified summary region (group, page or report).
DStdDevP | Calculates the population standard deviation based on the distinct values of another field within the specified summary region (group, page or report).
DSum | Calculates the total based on the distinct values of another field within the specified summary region (group, page or report).
DVar | Calculates the variance based on the distinct values of another field within the specified summary region (group, page or report).
DVarP | Calculates the population distinct variance based on the distinct values of another field within the specified summary region (group, page or report).
Max | Calculates the maximum of all values within the specified summary region (group, page or report).
Min | Calculates the minimum of all values within the specified summary region (group, page or report).
StdDev | Calculates the standard deviation of all values within the specified summary region (group, page or report).
StdDevP | Calculates the population standard deviation of all values within the specified summary region (group, page or report).
Sum | Calculates the total of all values within the specified summary region (group, page or report).
Var | Calculates the variance of all values within the specified summary region (group, page or report).
VarP | Calculates the population variance of all values within the specified summary region (group, page or report).
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.SummaryFunc

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryFunc


SummaryRunning Enumeration

SummaryRunning Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : SummaryRunning Enumeration
Determines whether summary values will be accumulated or reset based on the specified level.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum SummaryRunning
   Inherits System.Enum
public enum SummaryRunning : System.Enum
Members
Member | Description
All | Calculates a running summary for all values.
Group | Calculates a running summary (each value is the sum of the current value and all preceding values) within the same group level.
None | Summary values are not accumulated.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.SummaryRunning

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryRunning


SummaryType Enumeration

SummaryType Enumeration

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : SummaryType Enumeration
Determines the type of field summary.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum SummaryType
   Inherits System.Enum
public enum SummaryType : System.Enum
Members
Member | Description
GrandTotal | Evaluate the specified summary function for all records in the report.
None | No summarization.
PageCount | Print the page count or page number. Use with SummaryRunning set to All to print the page number.
PageTotal | Evaluate the specified summary function for all records on each page.
SubTotal | Evaluate the specified summary function for all records in each group level.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.SectionReportModel.SummaryType

See Also

Reference

GrapeCity.ActiveReports.SectionReportModel Namespace
ActiveReports6~GrapeCity.ActiveReports.TextBox~SummaryType


GrapeCity.BI.Data.DataProviders Namespace

GrapeCity.BI.Data.DataProviders Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.BI.Data.DataProviders Namespace
The GrapeCity.BI.Data.DataProviders namespace contains the DataProviderInfo class.
Structures
 | Structure | Description
Structure | DataProviderInfo | Specifies the information about a configured data provider.
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


DataProviderInfo Structure

DataProviderInfo Structure
Members

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.BI.Data.DataProviders Namespace : DataProviderInfo Structure
Specifies the information about a configured data provider.
Object Model
DataProviderInfo Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure DataProviderInfo
   Inherits System.ValueType
public struct DataProviderInfo : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.BI.Data.DataProviders.DataProviderInfo

See Also

Reference

DataProviderInfo Members
GrapeCity.BI.Data.DataProviders Namespace


DataProviderInfo Structure Members

DataProviderInfo Structure Members
Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.BI.Data.DataProviders Namespace : DataProviderInfo Structure

The following tables list the members exposed by DataProviderInfo.

Public Properties
 | Name | Description
Public Property | AssemblyQualifiedName | Fully assembly-qualified name of the class that implements GrapeCity.ActiveReports.Extensibility.Data.DataProviderFactory for this provider.
Public Property | HumanReadableName | A human-readable name for the data provider.
Public Property | InvariantName | The name that can be used to refer to the data provider in reports.
Public Property | QueryDesignerSupported | True if query designer supports this data provider
Top
See Also

Reference

DataProviderInfo Structure
GrapeCity.BI.Data.DataProviders Namespace


DataProviderInfo Structure Properties

DataProviderInfo Structure Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.BI.Data.DataProviders Namespace : DataProviderInfo Structure

For a list of all members of this type, see DataProviderInfo members.

Public Properties
 | Name | Description
Public Property | AssemblyQualifiedName | Fully assembly-qualified name of the class that implements GrapeCity.ActiveReports.Extensibility.Data.DataProviderFactory for this provider.
Public Property | HumanReadableName | A human-readable name for the data provider.
Public Property | InvariantName | The name that can be used to refer to the data provider in reports.
Public Property | QueryDesignerSupported | True if query designer supports this data provider
Top
See Also

Reference

DataProviderInfo Structure
GrapeCity.BI.Data.DataProviders Namespace


AssemblyQualifiedName Property (DataProviderInfo)

AssemblyQualifiedName Property (DataProviderInfo)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.BI.Data.DataProviders Namespace > DataProviderInfo Structure : AssemblyQualifiedName Property
Fully assembly-qualified name of the class that implements GrapeCity.ActiveReports.Extensibility.Data.DataProviderFactory for this provider.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property AssemblyQualifiedName As System.String
public System.string AssemblyQualifiedName {get;}
See Also

Reference

DataProviderInfo Structure
DataProviderInfo Members


HumanReadableName Property

HumanReadableName Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.BI.Data.DataProviders Namespace > DataProviderInfo Structure : HumanReadableName Property
A human-readable name for the data provider.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HumanReadableName As System.String
public System.string HumanReadableName {get;}
Remarks
An empty human readable name will prevent it from being displayed in UI.
See Also

Reference

DataProviderInfo Structure
DataProviderInfo Members


InvariantName Property

InvariantName Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.BI.Data.DataProviders Namespace > DataProviderInfo Structure : InvariantName Property
The name that can be used to refer to the data provider in reports.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InvariantName As System.String
public System.string InvariantName {get;}
See Also

Reference

DataProviderInfo Structure
DataProviderInfo Members


QueryDesignerSupported Property

QueryDesignerSupported Property

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.BI.Data.DataProviders Namespace > DataProviderInfo Structure : QueryDesignerSupported Property
True if query designer supports this data provider
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property QueryDesignerSupported As System.Boolean
public System.bool QueryDesignerSupported {get;}
See Also

Reference

DataProviderInfo Structure
DataProviderInfo Members


GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports.Viewer.Silverlight.v10)

GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports.Viewer.Silverlight.v10)
Inheritance Hierarchy
GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly : GrapeCity.ActiveReports Namespace
The GrapeCity.ActiveReports namespace contains the viewer class and its details.
Classes
 | Class | Description
Class | HyperLinkEventArgs | Provides data for the HyperLink event.
Class | Viewer | Represents the base class of a silverlight viewer component.
Delegates
 | Delegate | Description
Delegate | HyperLinkEventHandler | Represents the method that will handle the HyperLink click event.
Remarks

See Also

Reference

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly


HyperLinkEventArgs Class

HyperLinkEventArgs Class
Members

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace : HyperLinkEventArgs Class
Provides data for the HyperLink event.
Object Model
HyperLinkEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class HyperLinkEventArgs
   Inherits System.EventArgs
public sealed class HyperLinkEventArgs : System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.HyperLinkEventArgs

See Also

Reference

HyperLinkEventArgs Members
GrapeCity.ActiveReports Namespace


HyperLinkEventArgs Class Members

HyperLinkEventArgs Class Members
Properties

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace : HyperLinkEventArgs Class

The following tables list the members exposed by HyperLinkEventArgs.

Public Constructors
 | Name | Description
Public Constructor | HyperLinkEventArgs Constructor | Initializes a new instance of the HyperLinkEventArgs class and sets the specified values to the Button and HyperLink properties.
Top
Public Properties
 | Name | Description
Public Property | Handled | Sets or returns a value indicating whether the HyperLinkEvent is handled. If the value for this property is set to true, the hyperlink is not opened. The default value is false.
Public Property | HyperLink | Gets or sets the target URL of the hyperlink that was clicked.
Top
See Also

Reference

HyperLinkEventArgs Class
GrapeCity.ActiveReports Namespace


HyperLinkEventArgs Constructor

HyperLinkEventArgs Constructor

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > HyperLinkEventArgs Class : HyperLinkEventArgs Constructor
The hyperlink target.
Initializes a new instance of the HyperLinkEventArgs class and sets the specified values to the Button and HyperLink properties.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal hyperLink As System.String _
)
public HyperLinkEventArgs(
   System.string hyperLink
)

Parameters

hyperLink
The hyperlink target.
See Also

Reference

HyperLinkEventArgs Class
HyperLinkEventArgs Members


HyperLinkEventArgs Class Properties

HyperLinkEventArgs Class Properties

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace : HyperLinkEventArgs Class

For a list of all members of this type, see HyperLinkEventArgs members.

Public Properties
 | Name | Description
Public Property | Handled | Sets or returns a value indicating whether the HyperLinkEvent is handled. If the value for this property is set to true, the hyperlink is not opened. The default value is false.
Public Property | HyperLink | Gets or sets the target URL of the hyperlink that was clicked.
Top
See Also

Reference

HyperLinkEventArgs Class
GrapeCity.ActiveReports Namespace


Handled Property (HyperLinkEventArgs)

Handled Property (HyperLinkEventArgs)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > HyperLinkEventArgs Class : Handled Property
Sets or returns a value indicating whether the HyperLinkEvent is handled. If the value for this property is set to true, the hyperlink is not opened. The default value is false.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Handled As System.Boolean
public System.bool Handled {get; set;}
See Also

Reference

HyperLinkEventArgs Class
HyperLinkEventArgs Members


HyperLink Property (HyperLinkEventArgs)

HyperLink Property (HyperLinkEventArgs)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > HyperLinkEventArgs Class : HyperLink Property
Gets or sets the target URL of the hyperlink that was clicked.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HyperLink As System.String
public System.string HyperLink {get; set;}
See Also

Reference

HyperLinkEventArgs Class
HyperLinkEventArgs Members


Viewer Class

Viewer Class
Members

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace : Viewer Class
Represents the base class of a silverlight viewer component.
Object Model
Viewer Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Viewer
   Inherits System.Windows.Controls.Control
public class Viewer : System.Windows.Controls.Control
Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
GrapeCity.ActiveReports.Viewer

Requirements

See Also

Reference

Viewer Members
GrapeCity.ActiveReports Namespace


Viewer Class Members

Viewer Class Members
Fields Properties Methods Events

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace : Viewer Class

The following tables list the members exposed by Viewer.

Public Constructors
 | Name | Description
Public Constructor | Viewer Constructor | Initializes a new instance of the Viewer class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | ReportServiceUriProperty | ReportServiceUri binding property
Top
Public Properties
 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | AllowDrop | (Inherited from System.Windows.UIElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | (Inherited from System.Windows.UIElement)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | Effect | (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | PdfPrint | Enables or disables PDF printing mode.
Public Property | Projection | (Inherited from System.Windows.UIElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | ReportServiceUri | Endpoint address to web service
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | SecurityMode | Specifies the types of security that can be used with the system-provided BasicHttpBinding. None by default. Set to Transport to use with HTTPS.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | UseLayoutRounding | (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top
Public Methods
 | Name | Description
Public Method | AddHandler | (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | (Inherited from System.Windows.Controls.Control)
Public Method | Arrange | (Inherited from System.Windows.UIElement)
Public Method | CaptureMouse | (Inherited from System.Windows.UIElement)
Public Method | ClearValue | (Inherited from System.Windows.DependencyObject)
Public Method | FindName | (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | GetAnimationBaseValue | (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateArrange | (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | (Inherited from System.Windows.UIElement)
Public Method | Measure | (Inherited from System.Windows.UIElement)
Public Method | OnApplyTemplate | (Inherited from System.Windows.FrameworkElement)
Public Method | ReadLocalValue | (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | (Inherited from System.Windows.UIElement)
Public Method | SetBinding | (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | TransformToVisual | (Inherited from System.Windows.UIElement)
Public Method | UpdateLayout | (Inherited from System.Windows.UIElement)
Top
Public Events
 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | (Inherited from System.Windows.UIElement)
Public Event | DragLeave | (Inherited from System.Windows.UIElement)
Public Event | DragOver | (Inherited from System.Windows.UIElement)
Public Event | Drop | (Inherited from System.Windows.UIElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | HyperLink | HyperLink Event allows you to capture Hyperlink click in Silverlight Viewer. HyperLinkEventArgs event intializes a new instance of the HyperLinkEventArgs class and sets the specified values to the Handled and HyperLink properties.
Public Event | IsEnabledChanged | (Inherited from System.Windows.Controls.Control)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | (Inherited from System.Windows.UIElement)
Public Event | Unloaded | (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

Viewer Class
GrapeCity.ActiveReports Namespace


Viewer Constructor

Viewer Constructor

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Viewer Constructor
Initializes a new instance of the Viewer class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Viewer()
Requirements

See Also

Reference

Viewer Class
Viewer Members


Viewer Class Properties

Viewer Class Properties

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace : Viewer Class

For a list of all members of this type, see Viewer members.

Public Properties
 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | AllowDrop | (Inherited from System.Windows.UIElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | (Inherited from System.Windows.UIElement)
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.DependencyObject)
Public Property | Effect | (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | IsEnabled | (Inherited from System.Windows.Controls.Control)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | PdfPrint | Enables or disables PDF printing mode.
Public Property | Projection | (Inherited from System.Windows.UIElement)
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | ReportServiceUri | Endpoint address to web service
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | SecurityMode | Specifies the types of security that can be used with the system-provided BasicHttpBinding. None by default. Set to Transport to use with HTTPS.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TabNavigation | (Inherited from System.Windows.Controls.Control)
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | UseLayoutRounding | (Inherited from System.Windows.UIElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

Viewer Class
GrapeCity.ActiveReports Namespace


PdfPrint Property

PdfPrint Property

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : PdfPrint Property
Enables or disables PDF printing mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PdfPrint As System.Boolean
public System.bool PdfPrint {get; set;}
Requirements

See Also

Reference

Viewer Class
Viewer Members


ReportServiceUri Property

ReportServiceUri Property

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : ReportServiceUri Property
Endpoint address to web service
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportServiceUri As System.String
public System.string ReportServiceUri {get; set;}
Remarks
The default value of ReportServiceUri would be "../ActiveReports.ReportService.asmx" which indicates that *.xap file is located in the "ClientBin" folder of the hosting application (or web-site) and ActiveReports.ReportService.asmx is in the root of the hosting application (or web-site).
Requirements

See Also

Reference

Viewer Class
Viewer Members


SecurityMode Property

SecurityMode Property

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : SecurityMode Property
Specifies the types of security that can be used with the system-provided BasicHttpBinding. None by default. Set to Transport to use with HTTPS.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SecurityMode As System.ServiceModel.BasicHttpSecurityMode
public System.ServiceModel.BasicHttpSecurityMode SecurityMode {get; set;}

Property Value

None : The SOAP message is not secured during transfer. This is the default behavior.

Transport : Security is provided using HTTPS. The service must be configured with SSL certificates. The SOAP message is protected as a whole using HTTPS. The service is authenticated by the client using the service’s SSL certificate. The client authentication is controlled through the ClientCredentialType.

TransportCredentialOnly : This mode does not provide message integrity and confidentiality. It provides only HTTP-based client authentication. Use this mode with caution. It should be used in environments where the transfer security is being provided by other means (such as IPSec) and only client authentication is provided by the Windows Communication Foundation (WCF) infrastructure.

TransportWithMessageCredential : Integrity, confidentiality and server authentication are provided by HTTPS. The service must be configured with a certificate. Client authentication is provided by means of SOAP message security. This mode is applicable when the user is authenticating with a UserName or Certificate credential and there is an existing HTTPS deployment for securing message transfer.

Remarks
Security in this context means message protection (integrity and confidentiality) as well as client and service authentication.
Actual protection requirements (the specific parts of SOAP messages that must be signed or signed and encrypted) are controlled through attributes on the service contract or through properties in the contract description. Properties on the binding do not control what is being signed or encrypted: a binding only delivers the general capability of signing and encrypting.
Requirements

See Also

Reference

Viewer Class
Viewer Members


Viewer Class Fields

Viewer Class Fields

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace : Viewer Class

For a list of all members of this type, see Viewer members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | ReportServiceUriProperty | ReportServiceUri binding property
Top
See Also

Reference

Viewer Class
GrapeCity.ActiveReports Namespace


ReportServiceUriProperty Field

ReportServiceUriProperty Field

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : ReportServiceUriProperty Field
ReportServiceUri binding property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly ReportServiceUriProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty ReportServiceUriProperty
Requirements

See Also

Reference

Viewer Class
Viewer Members


Viewer Class Events

Viewer Class Events

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace : Viewer Class

For a list of all members of this type, see Viewer members.

Public Events
 | Name | Description
Public Event | BindingValidationError | (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | (Inherited from System.Windows.UIElement)
Public Event | DragLeave | (Inherited from System.Windows.UIElement)
Public Event | DragOver | (Inherited from System.Windows.UIElement)
Public Event | Drop | (Inherited from System.Windows.UIElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | HyperLink | HyperLink Event allows you to capture Hyperlink click in Silverlight Viewer. HyperLinkEventArgs event intializes a new instance of the HyperLinkEventArgs class and sets the specified values to the Handled and HyperLink properties.
Public Event | IsEnabledChanged | (Inherited from System.Windows.Controls.Control)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | (Inherited from System.Windows.UIElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | (Inherited from System.Windows.UIElement)
Public Event | TextInputStart | (Inherited from System.Windows.UIElement)
Public Event | TextInputUpdate | (Inherited from System.Windows.UIElement)
Public Event | Unloaded | (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

Viewer Class
GrapeCity.ActiveReports Namespace


HyperLink Event (Viewer)

HyperLink Event (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : HyperLink Event
HyperLink Event allows you to capture Hyperlink click in Silverlight Viewer. HyperLinkEventArgs event intializes a new instance of the HyperLinkEventArgs class and sets the specified values to the Handled and HyperLink properties.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event HyperLink As HyperLinkEventHandler
public event HyperLinkEventHandler HyperLink
Event Data

The event handler receives an argument of type HyperLinkEventArgs containing data related to this event. The following HyperLinkEventArgs properties provide information specific to this event.

Property | Description
Handled | Sets or returns a value indicating whether the HyperLinkEvent is handled. If the value for this property is set to true, the hyperlink is not opened. The default value is false.
HyperLink | Gets or sets the target URL of the hyperlink that was clicked.
See Also

Reference

Viewer Class
Viewer Members


HyperLinkEventHandler Delegate

HyperLinkEventHandler Delegate

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace : HyperLinkEventHandler Delegate
A HyperLinkEventArgs that contains the event data.
The source of the event.
Represents the method that will handle the HyperLink click event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub HyperLinkEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As HyperLinkEventArgs _
)
public delegate void HyperLinkEventHandler(
   System.object sender,
   HyperLinkEventArgs e
)

Parameters

sender
A HyperLinkEventArgs that contains the event data.
e
The source of the event.
See Also

Reference

HyperLinkEventHandler Members
GrapeCity.ActiveReports Namespace


GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports.Viewer.Win.v10)

GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports.Viewer.Win.v10)
Inheritance Hierarchy
GrapeCity.ActiveReports.Viewer.Win.v10 Assembly : GrapeCity.ActiveReports Namespace
The GrapeCity.ActiveReports Namespace contains the PrintExtension class.
Classes
 | Class | Description
Class | PrintExtension | Provides the print methods for page and section documents.
See Also

Reference

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly


PrintExtension Class

PrintExtension Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports Namespace : PrintExtension Class
Provides the print methods for page and section documents.
Object Model
PrintExtension Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit NotInheritable Class PrintExtension
public static class PrintExtension
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.PrintExtension

See Also

Reference

PrintExtension Members
GrapeCity.ActiveReports Namespace


PrintExtension Class Members

PrintExtension Class Members
Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports Namespace : PrintExtension Class

The following tables list the members exposed by PrintExtension.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Print | Overloaded. Prints the section-based document.
Top
See Also

Reference

PrintExtension Class
GrapeCity.ActiveReports Namespace


PrintExtension Class Methods

PrintExtension Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports Namespace : PrintExtension Class

For a list of all members of this type, see PrintExtension members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Print | Overloaded. Prints the section-based document.
Top
See Also

Reference

PrintExtension Class
GrapeCity.ActiveReports Namespace


Print Method (PrintExtension)

Print Method (PrintExtension)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports Namespace > PrintExtension Class : Print Method
Prints the section-based document.
Overload List
Overload | Description
Print(SectionDocument) | Prints the section-based document.
Print(SectionDocument,Boolean) | Prints the section-based document.
Print(SectionDocument,Boolean,Boolean) | Prints the section-based document.
Print(SectionDocument,PrintingSettings) | Print the section-based document.
Print(SectionDocument,Boolean,Boolean,Boolean) | Prints the section-based document.
Print(PageDocument) | Prints Page-based document
Print(PageDocument,Boolean) | Prints Page-based document
Print(PageDocument,Boolean,Boolean) | Prints Page-based document
Print(PageDocument,Boolean,Boolean,Boolean) | Print the page based document.
Print(PageDocument,PrintingSettings) | Print the page based document.
See Also

Reference

PrintExtension Class
PrintExtension Members


Print(SectionDocument) Method

Print(SectionDocument) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports Namespace > PrintExtension Class > Print Method : Print(SectionDocument) Method
Document to be printed.
Prints the section-based document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Print( _
   ByVal sectionDocument As SectionDocument _
) As System.Boolean
public static System.bool Print(
   SectionDocument sectionDocument
)

Parameters

sectionDocument
Document to be printed.
See Also

Reference

PrintExtension Class
PrintExtension Members
Overload List


Print(SectionDocument,Boolean) Method

Print(SectionDocument,Boolean) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports Namespace > PrintExtension Class > Print Method : Print(SectionDocument,Boolean) Method
Document to be printed.
If True the Print-dialog will be shown.
Prints the section-based document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Print( _
   ByVal sectionDocument As SectionDocument, _
   ByVal showPrintDialog As System.Boolean _
) As System.Boolean
public static System.bool Print(
   SectionDocument sectionDocument,
   System.bool showPrintDialog
)

Parameters

sectionDocument
Document to be printed.
showPrintDialog
If True the Print-dialog will be shown.
See Also

Reference

PrintExtension Class
PrintExtension Members
Overload List


Print(SectionDocument,Boolean,Boolean) Method

Print(SectionDocument,Boolean,Boolean) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports Namespace > PrintExtension Class > Print Method : Print(SectionDocument,Boolean,Boolean) Method
Document to be printed.
If True the Print-dialog will be shown.
If True the dialog with printing state information will be shown.
Prints the section-based document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Print( _
   ByVal sectionDocument As SectionDocument, _
   ByVal showPrintDialog As System.Boolean, _
   ByVal showPrintProgressDialog As System.Boolean _
) As System.Boolean
public static System.bool Print(
   SectionDocument sectionDocument,
   System.bool showPrintDialog,
   System.bool showPrintProgressDialog
)

Parameters

sectionDocument
Document to be printed.
showPrintDialog
If True the Print-dialog will be shown.
showPrintProgressDialog
If True the dialog with printing state information will be shown.
See Also

Reference

PrintExtension Class
PrintExtension Members
Overload List


Print(SectionDocument,PrintingSettings) Method

Print(SectionDocument,PrintingSettings) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports Namespace > PrintExtension Class > Print Method : Print(SectionDocument,PrintingSettings) Method
Document to be printed.
Print the section-based document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Print( _
   ByVal sectionDocument As SectionDocument, _
   ByVal settings As PrintingSettings _
) As System.Boolean
public static System.bool Print(
   SectionDocument sectionDocument,
   PrintingSettings settings
)

Parameters

sectionDocument
Document to be printed.
settings
See Also

Reference

PrintExtension Class
PrintExtension Members
Overload List


Print(SectionDocument,Boolean,Boolean,Boolean) Method

Print(SectionDocument,Boolean,Boolean,Boolean) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports Namespace > PrintExtension Class > Print Method : Print(SectionDocument,Boolean,Boolean,Boolean) Method
Document to be printed.
If True the Print-dialog will be shown.
If True the dialog with printing state information will be shown.
If True the printing will be run in new thread.
Prints the section-based document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Print( _
   ByVal sectionDocument As SectionDocument, _
   ByVal showPrintDialog As System.Boolean, _
   ByVal showPrintProgressDialog As System.Boolean, _
   ByVal usePrintingThread As System.Boolean _
) As System.Boolean
public static System.bool Print(
   SectionDocument sectionDocument,
   System.bool showPrintDialog,
   System.bool showPrintProgressDialog,
   System.bool usePrintingThread
)

Parameters

sectionDocument
Document to be printed.
showPrintDialog
If True the Print-dialog will be shown.
showPrintProgressDialog
If True the dialog with printing state information will be shown.
usePrintingThread
If True the printing will be run in new thread.
See Also

Reference

PrintExtension Class
PrintExtension Members
Overload List


Print(PageDocument) Method

Print(PageDocument) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports Namespace > PrintExtension Class > Print Method : Print(PageDocument) Method
Document to be printed.
Prints Page-based document
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Print( _
   ByVal pageDocument As PageDocument _
) As System.Boolean
public static System.bool Print(
   PageDocument pageDocument
)

Parameters

pageDocument
Document to be printed.
See Also

Reference

PrintExtension Class
PrintExtension Members
Overload List


Print(PageDocument,Boolean) Method

Print(PageDocument,Boolean) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports Namespace > PrintExtension Class > Print Method : Print(PageDocument,Boolean) Method
Document to be printed.
If True the Print-dialog will be shown.
Prints Page-based document
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Print( _
   ByVal pageDocument As PageDocument, _
   ByVal showPrintDialog As System.Boolean _
) As System.Boolean
public static System.bool Print(
   PageDocument pageDocument,
   System.bool showPrintDialog
)

Parameters

pageDocument
Document to be printed.
showPrintDialog
If True the Print-dialog will be shown.
See Also

Reference

PrintExtension Class
PrintExtension Members
Overload List


Print(PageDocument,Boolean,Boolean) Method

Print(PageDocument,Boolean,Boolean) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports Namespace > PrintExtension Class > Print Method : Print(PageDocument,Boolean,Boolean) Method
Document to be printed.
If True the Print-dialog will be shown.
If True the dialog with printing state information will be shown.
Prints Page-based document
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Print( _
   ByVal pageDocument As PageDocument, _
   ByVal showPrintDialog As System.Boolean, _
   ByVal showPrintProgressDialog As System.Boolean _
) As System.Boolean
public static System.bool Print(
   PageDocument pageDocument,
   System.bool showPrintDialog,
   System.bool showPrintProgressDialog
)

Parameters

pageDocument
Document to be printed.
showPrintDialog
If True the Print-dialog will be shown.
showPrintProgressDialog
If True the dialog with printing state information will be shown.
See Also

Reference

PrintExtension Class
PrintExtension Members
Overload List


Print(PageDocument,Boolean,Boolean,Boolean) Method

Print(PageDocument,Boolean,Boolean,Boolean) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports Namespace > PrintExtension Class > Print Method : Print(PageDocument,Boolean,Boolean,Boolean) Method
Document to be printed.
If True the Print-dialog will be shown.
If True the dialog with printing state information will be shown.
If True the printing will be run in new thread.
Print the page based document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Print( _
   ByVal pageDocument As PageDocument, _
   ByVal showPrintDialog As System.Boolean, _
   ByVal showPrintProgressDialog As System.Boolean, _
   ByVal usePrintingThread As System.Boolean _
) As System.Boolean
public static System.bool Print(
   PageDocument pageDocument,
   System.bool showPrintDialog,
   System.bool showPrintProgressDialog,
   System.bool usePrintingThread
)

Parameters

pageDocument
Document to be printed.
showPrintDialog
If True the Print-dialog will be shown.
showPrintProgressDialog
If True the dialog with printing state information will be shown.
usePrintingThread
If True the printing will be run in new thread.
See Also

Reference

PrintExtension Class
PrintExtension Members
Overload List


Print(PageDocument,PrintingSettings) Method

Print(PageDocument,PrintingSettings) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports Namespace > PrintExtension Class > Print Method : Print(PageDocument,PrintingSettings) Method
Document to be printed.
Print the page based document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Print( _
   ByVal pageDocument As PageDocument, _
   ByVal settings As PrintingSettings _
) As System.Boolean
public static System.bool Print(
   PageDocument pageDocument,
   PrintingSettings settings
)

Parameters

pageDocument
Document to be printed.
settings
See Also

Reference

PrintExtension Class
PrintExtension Members
Overload List


GrapeCity.ActiveReports.ArsClient Namespace

GrapeCity.ActiveReports.ArsClient Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Viewer.Win.v10 Assembly : GrapeCity.ActiveReports.ArsClient Namespace
Classes
 | Class | Description
Class | RemoteReportDescriptor | Describes remote ARS report.
Class | ViewerExtension | Extends GrapeCity.ActiveReports.Viewer.Win.Viewer type.
See Also

Reference

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly


RemoteReportDescriptor Class

RemoteReportDescriptor Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.ArsClient Namespace : RemoteReportDescriptor Class
Describes remote ARS report.
Object Model
RemoteReportDescriptor Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class RemoteReportDescriptor
public class RemoteReportDescriptor
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ArsClient.RemoteReportDescriptor

See Also

Reference

RemoteReportDescriptor Members
GrapeCity.ActiveReports.ArsClient Namespace


RemoteReportDescriptor Class Members

RemoteReportDescriptor Class Members
Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.ArsClient Namespace : RemoteReportDescriptor Class

The following tables list the members exposed by RemoteReportDescriptor.

Public Constructors
 | Name | Description
Public Constructor | RemoteReportDescriptor Constructor | Initializes a new instance of the RemoteReportDescriptor class.
Top
Public Properties
 | Name | Description
Public Property | AuthToken | Gets or sets the authentication token used to connect to report server.
Public Property | IsParametrized |
Public Property | ParametersValues | Gets or sets the values of the report parameters to be used for a report run.
Public Property | Password | Gets or sets the password to be used for connection to report server.
Public Property | ReportId | Gets or sets the report id on the server.
Public Property | ReportName | Gets or sets the report name on the server.
Public Property | ReportServerUrl | Gets or sets the URL for the report server.
Public Property | RevisionNumber | Gets or sets the revision number of the report on the server.
Public Property | Timeout | Gets or sets the number of milliseconds to wait for server communications.
Public Property | UseCache | Gets or sets the value indicating whether the report rendering result shall be read from cache or not. Default is true.
Public Property | UserName | Gets or sets the user name to be used for connection to report server.
Top
See Also

Reference

RemoteReportDescriptor Class
GrapeCity.ActiveReports.ArsClient Namespace


RemoteReportDescriptor Constructor

RemoteReportDescriptor Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.ArsClient Namespace > RemoteReportDescriptor Class : RemoteReportDescriptor Constructor
Initializes a new instance of the RemoteReportDescriptor class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public RemoteReportDescriptor()
See Also

Reference

RemoteReportDescriptor Class
RemoteReportDescriptor Members


RemoteReportDescriptor Class Properties

RemoteReportDescriptor Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.ArsClient Namespace : RemoteReportDescriptor Class

For a list of all members of this type, see RemoteReportDescriptor members.

Public Properties
 | Name | Description
Public Property | AuthToken | Gets or sets the authentication token used to connect to report server.
Public Property | IsParametrized |
Public Property | ParametersValues | Gets or sets the values of the report parameters to be used for a report run.
Public Property | Password | Gets or sets the password to be used for connection to report server.
Public Property | ReportId | Gets or sets the report id on the server.
Public Property | ReportName | Gets or sets the report name on the server.
Public Property | ReportServerUrl | Gets or sets the URL for the report server.
Public Property | RevisionNumber | Gets or sets the revision number of the report on the server.
Public Property | Timeout | Gets or sets the number of milliseconds to wait for server communications.
Public Property | UseCache | Gets or sets the value indicating whether the report rendering result shall be read from cache or not. Default is true.
Public Property | UserName | Gets or sets the user name to be used for connection to report server.
Top
See Also

Reference

RemoteReportDescriptor Class
GrapeCity.ActiveReports.ArsClient Namespace


AuthToken Property

AuthToken Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.ArsClient Namespace > RemoteReportDescriptor Class : AuthToken Property
Gets or sets the authentication token used to connect to report server.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AuthToken As System.String
public System.string AuthToken {get; set;}
See Also

Reference

RemoteReportDescriptor Class
RemoteReportDescriptor Members


IsParametrized Property

IsParametrized Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.ArsClient Namespace > RemoteReportDescriptor Class : IsParametrized Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsParametrized As System.Boolean
public System.bool IsParametrized {get; set;}
See Also

Reference

RemoteReportDescriptor Class
RemoteReportDescriptor Members


ParametersValues Property

ParametersValues Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.ArsClient Namespace > RemoteReportDescriptor Class : ParametersValues Property
Gets or sets the values of the report parameters to be used for a report run.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ParametersValues As System.Collections.Generic.IEnumerable(Of IParameter)
public System.Collections.Generic.IEnumerable<IParameter> ParametersValues {get; set;}
See Also

Reference

RemoteReportDescriptor Class
RemoteReportDescriptor Members


Password Property (RemoteReportDescriptor)

Password Property (RemoteReportDescriptor)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.ArsClient Namespace > RemoteReportDescriptor Class : Password Property
Gets or sets the password to be used for connection to report server.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Password As System.String
public System.string Password {get; set;}
See Also

Reference

RemoteReportDescriptor Class
RemoteReportDescriptor Members


ReportId Property

ReportId Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.ArsClient Namespace > RemoteReportDescriptor Class : ReportId Property
Gets or sets the report id on the server.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportId As System.String
public System.string ReportId {get; set;}
See Also

Reference

RemoteReportDescriptor Class
RemoteReportDescriptor Members


ReportName Property (RemoteReportDescriptor)

ReportName Property (RemoteReportDescriptor)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.ArsClient Namespace > RemoteReportDescriptor Class : ReportName Property
Gets or sets the report name on the server.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportName As System.String
public System.string ReportName {get; set;}
See Also

Reference

RemoteReportDescriptor Class
RemoteReportDescriptor Members


ReportServerUrl Property

ReportServerUrl Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.ArsClient Namespace > RemoteReportDescriptor Class : ReportServerUrl Property
Gets or sets the URL for the report server.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportServerUrl As System.String
public System.string ReportServerUrl {get; set;}
See Also

Reference

RemoteReportDescriptor Class
RemoteReportDescriptor Members


RevisionNumber Property

RevisionNumber Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.ArsClient Namespace > RemoteReportDescriptor Class : RevisionNumber Property
Gets or sets the revision number of the report on the server.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RevisionNumber As System.Nullable(Of Integer)
public System.Nullable<int> RevisionNumber {get; set;}
See Also

Reference

RemoteReportDescriptor Class
RemoteReportDescriptor Members


Timeout Property (RemoteReportDescriptor)

Timeout Property (RemoteReportDescriptor)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.ArsClient Namespace > RemoteReportDescriptor Class : Timeout Property
Gets or sets the number of milliseconds to wait for server communications.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Timeout As System.Long
public System.long Timeout {get; set;}
See Also

Reference

RemoteReportDescriptor Class
RemoteReportDescriptor Members


UseCache Property

UseCache Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.ArsClient Namespace > RemoteReportDescriptor Class : UseCache Property
Gets or sets the value indicating whether the report rendering result shall be read from cache or not. Default is true.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseCache As System.Boolean
public System.bool UseCache {get; set;}
See Also

Reference

RemoteReportDescriptor Class
RemoteReportDescriptor Members


UserName Property (RemoteReportDescriptor)

UserName Property (RemoteReportDescriptor)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.ArsClient Namespace > RemoteReportDescriptor Class : UserName Property
Gets or sets the user name to be used for connection to report server.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UserName As System.String
public System.string UserName {get; set;}
See Also

Reference

RemoteReportDescriptor Class
RemoteReportDescriptor Members


ViewerExtension Class

ViewerExtension Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.ArsClient Namespace : ViewerExtension Class
Extends GrapeCity.ActiveReports.Viewer.Win.Viewer type.
Object Model
ViewerExtension Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit NotInheritable Class ViewerExtension
public static class ViewerExtension
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.ArsClient.ViewerExtension

See Also

Reference

ViewerExtension Members
GrapeCity.ActiveReports.ArsClient Namespace


ViewerExtension Class Members

ViewerExtension Class Members
Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.ArsClient Namespace : ViewerExtension Class

The following tables list the members exposed by ViewerExtension.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | LoadDocument | Load remote report from Active Reports Server.
Top
See Also

Reference

ViewerExtension Class
GrapeCity.ActiveReports.ArsClient Namespace


ViewerExtension Class Methods

ViewerExtension Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.ArsClient Namespace : ViewerExtension Class

For a list of all members of this type, see ViewerExtension members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | LoadDocument | Load remote report from Active Reports Server.
Top
See Also

Reference

ViewerExtension Class
GrapeCity.ActiveReports.ArsClient Namespace


LoadDocument Method (ViewerExtension)

LoadDocument Method (ViewerExtension)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.ArsClient Namespace > ViewerExtension Class : LoadDocument Method
The viewer to load report.
Remote report descriptor.
Load remote report from Active Reports Server.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Sub LoadDocument( _
   ByVal viewer As Viewer, _
   ByVal remoteReport As RemoteReportDescriptor _
)
public static void LoadDocument(
   Viewer viewer,
   RemoteReportDescriptor remoteReport
)

Parameters

viewer
The viewer to load report.
remoteReport
Remote report descriptor.
See Also

Reference

ViewerExtension Class
ViewerExtension Members


GrapeCity.ActiveReports.Viewer.Win Namespace

GrapeCity.ActiveReports.Viewer.Win Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Viewer.Win.v10 Assembly : GrapeCity.ActiveReports.Viewer.Win Namespace
The GrapeCity.ActiveReports.Viewer.Win namespace, contains the Viewer that is used to control the viewer, TocPanel, and other classes.
Classes
 | Class | Description
Class | FindEventArgs | Provides data for the Find event.
Class | HyperLinkEventArgs | Provides data for the HyperLink event.
Class | ParametersPanel | Represents the parameter panel of the Viewer.
Class | ReportParameter | Represents a report parameter.
Class | SearchPanel | Represents the search panel of the Viewer.
Class | Sidebar | Exposes Viewer's public API.
Class | ThumbnailsPanel | Represents the thumbnail panel of the Viewer.
Class | TocPanel | Shows the panel of parameters of the Viewer control.
Class | Viewer | The Viewer control is used to preview report documents on the screen.
Class | Viewer.ActionEventArgs | Provides data for Action event.
Class | Viewer.ViewerToolbar | Gets the viewer toolbar object, allowing you to add and remove items on each of the component ToolStrips, and to implement tool click events for added items.
Class | ZoomChangedEventArgs | Provides data for the ZoomChanged event.
Delegates
 | Delegate | Description
Delegate | FindEventHandler | Represents the method that will handle the Find click event.
Delegate | HyperLinkEventHandler | Represents the method that will handle the HyperLink click event.
Delegate | ZoomChangedEventHandler | Represents the method that will handle the zoom click event.
Enumerations
 | Enumeration | Description
Enumeration | TargetView | Determines the current active view in the viewer.
See Also

Reference

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly


FindEventArgs Class

FindEventArgs Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : FindEventArgs Class
Provides data for the Find event.
Object Model
FindEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class FindEventArgs
   Inherits System.EventArgs
public sealed class FindEventArgs : System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Viewer.Win.FindEventArgs

See Also

Reference

FindEventArgs Members
GrapeCity.ActiveReports.Viewer.Win Namespace


FindEventArgs Class Members

FindEventArgs Class Members
Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : FindEventArgs Class

The following tables list the members exposed by FindEventArgs.

Public Constructors
 | Name | Description
Public Constructor | FindEventArgs Constructor | Overloaded. Initializes a new instance of the FindEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Found | Gets the value that determines whether the text was found.
Public Property | PageIndex | Gets the page number where the text was found.
Top
See Also

Reference

FindEventArgs Class
GrapeCity.ActiveReports.Viewer.Win Namespace


FindEventArgs Constructor

FindEventArgs Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > FindEventArgs Class : FindEventArgs Constructor
Initializes a new instance of the FindEventArgs class.
Overload List
Overload | Description
FindEventArgs Constructor(Boolean,Int32) | Initializes a new instance of the FindEventArgs class and sets the Found and PageIndex properties.
FindEventArgs Constructor() | Initializes a new instance of the FindEventArgs class.
See Also

Reference

FindEventArgs Class
FindEventArgs Members


FindEventArgs Constructor(Boolean,Int32)

FindEventArgs Constructor(Boolean,Int32)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > FindEventArgs Class > FindEventArgs Constructor : FindEventArgs Constructor(Boolean,Int32)
Specifies whether the text was found.
Specifies the page number where the text was found.
Initializes a new instance of the FindEventArgs class and sets the Found and PageIndex properties.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal found As System.Boolean, _
   ByVal pageIndex As System.Integer _
)
public FindEventArgs(
   System.bool found,
   System.int pageIndex
)

Parameters

found
Specifies whether the text was found.
pageIndex
Specifies the page number where the text was found.
See Also

Reference

FindEventArgs Class
FindEventArgs Members
Overload List


FindEventArgs Constructor()

FindEventArgs Constructor()

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > FindEventArgs Class > FindEventArgs Constructor : FindEventArgs Constructor()
Initializes a new instance of the FindEventArgs class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public FindEventArgs()
See Also

Reference

FindEventArgs Class
FindEventArgs Members
Overload List


FindEventArgs Class Properties

FindEventArgs Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : FindEventArgs Class

For a list of all members of this type, see FindEventArgs members.

Public Properties
 | Name | Description
Public Property | Found | Gets the value that determines whether the text was found.
Public Property | PageIndex | Gets the page number where the text was found.
Top
See Also

Reference

FindEventArgs Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Found Property

Found Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > FindEventArgs Class : Found Property
Gets the value that determines whether the text was found.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Found As System.Boolean
public System.bool Found {get;}
See Also

Reference

FindEventArgs Class
FindEventArgs Members


PageIndex Property (FindEventArgs)

PageIndex Property (FindEventArgs)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > FindEventArgs Class : PageIndex Property
Gets the page number where the text was found.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PageIndex As System.Integer
public System.int PageIndex {get;}
See Also

Reference

FindEventArgs Class
FindEventArgs Members


HyperLinkEventArgs Class

HyperLinkEventArgs Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : HyperLinkEventArgs Class
Provides data for the HyperLink event.
Object Model
HyperLinkEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class HyperLinkEventArgs
   Inherits System.EventArgs
public sealed class HyperLinkEventArgs : System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Viewer.Win.HyperLinkEventArgs

See Also

Reference

HyperLinkEventArgs Members
GrapeCity.ActiveReports.Viewer.Win Namespace


HyperLinkEventArgs Class Members

HyperLinkEventArgs Class Members
Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : HyperLinkEventArgs Class

The following tables list the members exposed by HyperLinkEventArgs.

Public Constructors
 | Name | Description
Public Constructor | HyperLinkEventArgs Constructor | Initializes a new instance of the HyperLinkEventArgs class and sets the specified values to the Button and HyperLink properties.
Top
Public Properties
 | Name | Description
Public Property | Button | Gets the mouse button that the user clicked to raise the event.
Public Property | CreateNewTab | Gets or sets a value indicating whether a new tab has been created.
Public Property | Handled | Sets or returns a value indicating whether the HyperLinkEvent is handled.
Public Property | HyperLink | Gets the hyperlink target.
Top
See Also

Reference

HyperLinkEventArgs Class
GrapeCity.ActiveReports.Viewer.Win Namespace


HyperLinkEventArgs Constructor

HyperLinkEventArgs Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > HyperLinkEventArgs Class : HyperLinkEventArgs Constructor
The mouse button clicked.
The hyperlink target.
Initializes a new instance of the HyperLinkEventArgs class and sets the specified values to the Button and HyperLink properties.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal button As System.Windows.Forms.MouseButtons, _
   ByVal hyperLink As System.String _
)
public HyperLinkEventArgs(
   System.Windows.Forms.MouseButtons button,
   System.string hyperLink
)

Parameters

button
The mouse button clicked.
hyperLink
The hyperlink target.
See Also

Reference

HyperLinkEventArgs Class
HyperLinkEventArgs Members


HyperLinkEventArgs Class Properties

HyperLinkEventArgs Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : HyperLinkEventArgs Class

For a list of all members of this type, see HyperLinkEventArgs members.

Public Properties
 | Name | Description
Public Property | Button | Gets the mouse button that the user clicked to raise the event.
Public Property | CreateNewTab | Gets or sets a value indicating whether a new tab has been created.
Public Property | Handled | Sets or returns a value indicating whether the HyperLinkEvent is handled.
Public Property | HyperLink | Gets the hyperlink target.
Top
See Also

Reference

HyperLinkEventArgs Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Button Property (HyperLinkEventArgs)

Button Property (HyperLinkEventArgs)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > HyperLinkEventArgs Class : Button Property
Gets the mouse button that the user clicked to raise the event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Button As System.Windows.Forms.MouseButtons
public System.Windows.Forms.MouseButtons Button {get;}

Property Value

System.Windows.MouseButtons value that represents the button that has fired this event.
See Also

Reference

HyperLinkEventArgs Class
HyperLinkEventArgs Members


CreateNewTab Property

CreateNewTab Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > HyperLinkEventArgs Class : CreateNewTab Property
Gets or sets a value indicating whether a new tab has been created.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CreateNewTab As System.Boolean
public System.bool CreateNewTab {get; set;}
See Also

Reference

HyperLinkEventArgs Class
HyperLinkEventArgs Members


Handled Property (HyperLinkEventArgs)

Handled Property (HyperLinkEventArgs)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > HyperLinkEventArgs Class : Handled Property
Sets or returns a value indicating whether the HyperLinkEvent is handled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Handled As System.Boolean
public System.bool Handled {get; set;}
See Also

Reference

HyperLinkEventArgs Class
HyperLinkEventArgs Members


HyperLink Property (HyperLinkEventArgs)

HyperLink Property (HyperLinkEventArgs)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > HyperLinkEventArgs Class : HyperLink Property
Gets the hyperlink target.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HyperLink As System.String
public System.string HyperLink {get; set;}

Property Value

Character string value that represents the target of the hyperlink.
See Also

Reference

HyperLinkEventArgs Class
HyperLinkEventArgs Members


ParametersPanel Class

ParametersPanel Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ParametersPanel Class
Represents the parameter panel of the Viewer.
Object Model
ParametersPanel Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ParametersPanel
   Inherits SidebarPanel
public sealed class ParametersPanel : SidebarPanel
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Viewer.Win.ParametersPanel

See Also

Reference

ParametersPanel Members
GrapeCity.ActiveReports.Viewer.Win Namespace


ParametersPanel Class Members

ParametersPanel Class Members
Properties Methods Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ParametersPanel Class

The following tables list the members exposed by ParametersPanel.

Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Overridden. Gets or sets the caption of parameters panel.
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Overridden. Refreshes the Parameters panel.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

ParametersPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


ParametersPanel Class Methods

ParametersPanel Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ParametersPanel Class

For a list of all members of this type, see ParametersPanel members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Overridden. Refreshes the Parameters panel.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

ParametersPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Refresh Method (ParametersPanel)

Refresh Method (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ParametersPanel Class : Refresh Method
Refreshes the Parameters panel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Sub Refresh()
public override void Refresh()
See Also

Reference

ParametersPanel Class
ParametersPanel Members


ParametersPanel Class Properties

ParametersPanel Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ParametersPanel Class

For a list of all members of this type, see ParametersPanel members.

Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Overridden. Gets or sets the caption of parameters panel.
Top
See Also

Reference

ParametersPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Text Property (ParametersPanel)

Text Property (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ParametersPanel Class : Text Property
Gets or sets the caption of parameters panel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Property Text As System.String
public override System.string Text {get; set;}

Property Value

The caption text.
Requirements

See Also

Reference

ParametersPanel Class
ParametersPanel Members


ReportParameter Class

ReportParameter Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ReportParameter Class
Represents a report parameter.
Object Model
ReportParameter Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ReportParameter
   Implements GrapeCity.Viewer.Common.IParameter
public sealed class ReportParameter : GrapeCity.Viewer.Common.IParameter
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Viewer.Win.ReportParameter

See Also

Reference

ReportParameter Members
GrapeCity.ActiveReports.Viewer.Win Namespace


ReportParameter Class Members

ReportParameter Class Members
Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ReportParameter Class

The following tables list the members exposed by ReportParameter.

Public Constructors
 | Name | Description
Public Constructor | ReportParameter Constructor | Overloaded. Initializes a new instance of ReportParameter class.
Top
Public Properties
 | Name | Description
Public Property | Name | Gets the name of the report parameter.
Public Property | Values | Gets the collection of zero or more values for the report parameter.
Top
See Also

Reference

ReportParameter Class
GrapeCity.ActiveReports.Viewer.Win Namespace


ReportParameter Constructor

ReportParameter Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ReportParameter Class : ReportParameter Constructor
Initializes a new instance of ReportParameter class.
Overload List
Overload | Description
ReportParameter Constructor(String,Object) | Initializes a new instance with a single value.
ReportParameter Constructor(String,ICollection<Object>) | Initializes a new instance multiple values.
ReportParameter Constructor(String) | Initializes a new instance without a value.
See Also

Reference

ReportParameter Class
ReportParameter Members


ReportParameter Constructor(String,Object)

ReportParameter Constructor(String,Object)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ReportParameter Class > ReportParameter Constructor : ReportParameter Constructor(String,Object)
Parameter name.
Parameter value.
Initializes a new instance with a single value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As System.String, _
   ByVal value As System.Object _
)
public ReportParameter(
   System.string name,
   System.object value
)

Parameters

name
Parameter name.
value
Parameter value.
See Also

Reference

ReportParameter Class
ReportParameter Members
Overload List


ReportParameter Constructor(String,ICollection<Object>)

ReportParameter Constructor(String,ICollection<Object>)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ReportParameter Class > ReportParameter Constructor : ReportParameter Constructor(String,ICollection<Object>)
Parameter Name.
Collection of parameter values.
Initializes a new instance multiple values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As System.String, _
   ByVal values As System.Collections.Generic.ICollection(Of Object) _
)
public ReportParameter(
   System.string name,
   System.Collections.Generic.ICollection<object> values
)

Parameters

name
Parameter Name.
values
Collection of parameter values.
See Also

Reference

ReportParameter Class
ReportParameter Members
Overload List


ReportParameter Constructor(String)

ReportParameter Constructor(String)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ReportParameter Class > ReportParameter Constructor : ReportParameter Constructor(String)
Parameter Name.
Initializes a new instance without a value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As System.String _
)
public ReportParameter(
   System.string name
)

Parameters

name
Parameter Name.
See Also

Reference

ReportParameter Class
ReportParameter Members
Overload List


ReportParameter Class Properties

ReportParameter Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ReportParameter Class

For a list of all members of this type, see ReportParameter members.

Public Properties
 | Name | Description
Public Property | Name | Gets the name of the report parameter.
Public Property | Values | Gets the collection of zero or more values for the report parameter.
Top
See Also

Reference

ReportParameter Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Name Property (ReportParameter)

Name Property (ReportParameter)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ReportParameter Class : Name Property
Gets the name of the report parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Name As System.String
public System.string Name {get;}
See Also

Reference

ReportParameter Class
ReportParameter Members


Values Property (ReportParameter)

Values Property (ReportParameter)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ReportParameter Class : Values Property
Gets the collection of zero or more values for the report parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Values As System.Collections.Generic.IEnumerable(Of Object)
public System.Collections.Generic.IEnumerable<object> Values {get;}
See Also

Reference

ReportParameter Class
ReportParameter Members


SearchPanel Class

SearchPanel Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : SearchPanel Class
Represents the search panel of the Viewer.
Object Model
SearchPanel Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class SearchPanel
   Inherits SidebarPanel
public sealed class SearchPanel : SidebarPanel
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Viewer.Win.SearchPanel

See Also

Reference

SearchPanel Members
GrapeCity.ActiveReports.Viewer.Win Namespace


SearchPanel Class Members

SearchPanel Class Members
Properties Methods Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : SearchPanel Class

The following tables list the members exposed by SearchPanel.

Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Overridden. Gets or sets the caption of search panel.
Top
Public Methods
 | Name | Description
Public Method | Clear | Overridden. Clears the search panel UI, resets the search parameters and clears the search result.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

SearchPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


SearchPanel Class Methods

SearchPanel Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : SearchPanel Class

For a list of all members of this type, see SearchPanel members.

Public Methods
 | Name | Description
Public Method | Clear | Overridden. Clears the search panel UI, resets the search parameters and clears the search result.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

SearchPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Clear Method (SearchPanel)

Clear Method (SearchPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > SearchPanel Class : Clear Method
Clears the search panel UI, resets the search parameters and clears the search result.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Sub Clear()
public override void Clear()
See Also

Reference

SearchPanel Class
SearchPanel Members


SearchPanel Class Properties

SearchPanel Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : SearchPanel Class

For a list of all members of this type, see SearchPanel members.

Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Overridden. Gets or sets the caption of search panel.
Top
See Also

Reference

SearchPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Text Property (SearchPanel)

Text Property (SearchPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > SearchPanel Class : Text Property
Gets or sets the caption of search panel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Property Text As System.String
public override System.string Text {get; set;}

Property Value

The caption text.
Requirements

See Also

Reference

SearchPanel Class
SearchPanel Members


Sidebar Class

Sidebar Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Sidebar Class
Exposes Viewer's public API.
Object Model
Sidebar Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Sidebar
   Inherits System.ComponentModel.Component
public sealed class Sidebar : System.ComponentModel.Component
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Viewer.Win.Sidebar

See Also

Reference

Sidebar Members
GrapeCity.ActiveReports.Viewer.Win Namespace


Sidebar Class Members

Sidebar Class Members
Properties Methods Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Sidebar Class

The following tables list the members exposed by Sidebar.

Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ParametersPanel | Gets the parameters panel object.
Public Property | SearchPanel | Gets the search panel object.
Public Property | SelectedIndex | Gets or Sets the index of the selected panel.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | ThumbnailsPanel | Gets the thumbnails panel object.
Public Property | TocPanel | Gets the Toc panel object.
Public Property | Visible | Gets or sets the value indicating whether the sidebar is visible.
Public Property | Width | Gets or Sets the width of the sidebar.
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToggleVisibility | Toggles the Sidebar visibility.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | SelectedIndexChanged | Raises when the index of the selected panel changes.
Top
See Also

Reference

Sidebar Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Sidebar Class Methods

Sidebar Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Sidebar Class

For a list of all members of this type, see Sidebar members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToggleVisibility | Toggles the Sidebar visibility.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Sidebar Class
GrapeCity.ActiveReports.Viewer.Win Namespace


ToggleVisibility Method (Sidebar)

ToggleVisibility Method (Sidebar)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : ToggleVisibility Method
Toggles the Sidebar visibility.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ToggleVisibility()
public void ToggleVisibility()
See Also

Reference

Sidebar Class
Sidebar Members


Sidebar Class Properties

Sidebar Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Sidebar Class

For a list of all members of this type, see Sidebar members.

Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ParametersPanel | Gets the parameters panel object.
Public Property | SearchPanel | Gets the search panel object.
Public Property | SelectedIndex | Gets or Sets the index of the selected panel.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | ThumbnailsPanel | Gets the thumbnails panel object.
Public Property | TocPanel | Gets the Toc panel object.
Public Property | Visible | Gets or sets the value indicating whether the sidebar is visible.
Public Property | Width | Gets or Sets the width of the sidebar.
Top
See Also

Reference

Sidebar Class
GrapeCity.ActiveReports.Viewer.Win Namespace


ParametersPanel Property (Sidebar)

ParametersPanel Property (Sidebar)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : ParametersPanel Property
Gets the parameters panel object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ParametersPanel As ParametersPanel
public ParametersPanel ParametersPanel {get;}

Property Value

The parameters panel.
See Also

Reference

Sidebar Class
Sidebar Members


SearchPanel Property (Sidebar)

SearchPanel Property (Sidebar)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : SearchPanel Property
Gets the search panel object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property SearchPanel As SearchPanel
public SearchPanel SearchPanel {get;}

Property Value

The search panel.
See Also

Reference

Sidebar Class
Sidebar Members


SelectedIndex Property (Sidebar)

SelectedIndex Property (Sidebar)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : SelectedIndex Property
Gets or Sets the index of the selected panel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SelectedIndex As System.Integer
public System.int SelectedIndex {get; set;}

Property Value

The index of the selected panel.
See Also

Reference

Sidebar Class
Sidebar Members


ThumbnailsPanel Property (Sidebar)

ThumbnailsPanel Property (Sidebar)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : ThumbnailsPanel Property
Gets the thumbnails panel object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ThumbnailsPanel As ThumbnailsPanel
public ThumbnailsPanel ThumbnailsPanel {get;}

Property Value

The thumbnails panel.
See Also

Reference

Sidebar Class
Sidebar Members


TocPanel Property (Sidebar)

TocPanel Property (Sidebar)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : TocPanel Property
Gets the Toc panel object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TocPanel As TocPanel
public TocPanel TocPanel {get;}

Property Value

The toc panel.
See Also

Reference

Sidebar Class
Sidebar Members


Visible Property (Sidebar)

Visible Property (Sidebar)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : Visible Property
Gets or sets the value indicating whether the sidebar is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}

Property Value

true if visible; otherwise, false.
See Also

Reference

Sidebar Class
Sidebar Members


Width Property (Sidebar)

Width Property (Sidebar)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : Width Property
Gets or Sets the width of the sidebar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As System.Integer
public System.int Width {get; set;}

Property Value

The width.
See Also

Reference

Sidebar Class
Sidebar Members


Sidebar Class Events

Sidebar Class Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Sidebar Class

For a list of all members of this type, see Sidebar members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | SelectedIndexChanged | Raises when the index of the selected panel changes.
Top
See Also

Reference

Sidebar Class
GrapeCity.ActiveReports.Viewer.Win Namespace


SelectedIndexChanged Event (Sidebar)

SelectedIndexChanged Event (Sidebar)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : SelectedIndexChanged Event
Raises when the index of the selected panel changes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event SelectedIndexChanged As System.EventHandler
public event System.EventHandler SelectedIndexChanged
See Also

Reference

Sidebar Class
Sidebar Members


ThumbnailsPanel Class

ThumbnailsPanel Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ThumbnailsPanel Class
Represents the thumbnail panel of the Viewer.
Object Model
ThumbnailsPanel Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ThumbnailsPanel
   Inherits SidebarPanel
public sealed class ThumbnailsPanel : SidebarPanel
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Viewer.Win.ThumbnailsPanel

See Also

Reference

ThumbnailsPanel Members
GrapeCity.ActiveReports.Viewer.Win Namespace


ThumbnailsPanel Class Members

ThumbnailsPanel Class Members
Properties Methods Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ThumbnailsPanel Class

The following tables list the members exposed by ThumbnailsPanel.

Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Overridden. Gets or sets the caption of thumbnails panel.
Public Property | Zoom | Gets or sets the zoom level of items in the ThumbnailsPanel.
Top
Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ZoomChanged | Occurs when the zoom level changes in the ThumbnailsPanel.
Top
See Also

Reference

ThumbnailsPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


ThumbnailsPanel Class Properties

ThumbnailsPanel Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ThumbnailsPanel Class

For a list of all members of this type, see ThumbnailsPanel members.

Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Overridden. Gets or sets the caption of thumbnails panel.
Public Property | Zoom | Gets or sets the zoom level of items in the ThumbnailsPanel.
Top
See Also

Reference

ThumbnailsPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Text Property (ThumbnailsPanel)

Text Property (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ThumbnailsPanel Class : Text Property
Gets or sets the caption of thumbnails panel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Property Text As System.String
public override System.string Text {get; set;}

Property Value

The caption text.
Requirements

See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


Zoom Property (ThumbnailsPanel)

Zoom Property (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ThumbnailsPanel Class : Zoom Property
Gets or sets the zoom level of items in the ThumbnailsPanel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Zoom As System.Double
public System.double Zoom {get; set;}

Property Value

The zoom level.
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


ThumbnailsPanel Class Events

ThumbnailsPanel Class Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ThumbnailsPanel Class

For a list of all members of this type, see ThumbnailsPanel members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | ZoomChanged | Occurs when the zoom level changes in the ThumbnailsPanel.
Top
See Also

Reference

ThumbnailsPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


ZoomChanged Event (ThumbnailsPanel)

ZoomChanged Event (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ThumbnailsPanel Class : ZoomChanged Event
Occurs when the zoom level changes in the ThumbnailsPanel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ZoomChanged As ZoomChangedEventHandler
public event ZoomChangedEventHandler ZoomChanged
Event Data

The event handler receives an argument of type ZoomChangedEventArgs containing data related to this event. The following ZoomChangedEventArgs properties provide information specific to this event.

Property | Description
Zoom | Returns the viewer's new Zoom value.
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


TocPanel Class

TocPanel Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : TocPanel Class
Shows the panel of parameters of the Viewer control.
Object Model
TocPanel Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class TocPanel
   Inherits SidebarPanel
public sealed class TocPanel : SidebarPanel
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Viewer.Win.TocPanel

See Also

Reference

TocPanel Members
GrapeCity.ActiveReports.Viewer.Win Namespace


TocPanel Class Members

TocPanel Class Members
Properties Methods Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : TocPanel Class

The following tables list the members exposed by TocPanel.

Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContextMenu | Overridden. Gets or sets a context menu when the user right clicks on the toc panel.
Public Property | Expanded | Gets or sets a value that indicates whether the TocPanel is expanded.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Overridden. Gets or sets the caption of table of content panel.
Top
Public Methods
 | Name | Description
Public Method | Clear | Overridden. Clears the table of contents panel.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Overridden. Forces the table of contents panel to invalidate its client area and immediately redraw itself and any child controls.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

TocPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


TocPanel Class Methods

TocPanel Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : TocPanel Class

For a list of all members of this type, see TocPanel members.

Public Methods
 | Name | Description
Public Method | Clear | Overridden. Clears the table of contents panel.
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Overridden. Forces the table of contents panel to invalidate its client area and immediately redraw itself and any child controls.
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

TocPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Clear Method (TocPanel)

Clear Method (TocPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : Clear Method
Clears the table of contents panel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Sub Clear()
public override void Clear()
See Also

Reference

TocPanel Class
TocPanel Members


Refresh Method (TocPanel)

Refresh Method (TocPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : Refresh Method
Forces the table of contents panel to invalidate its client area and immediately redraw itself and any child controls.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Sub Refresh()
public override void Refresh()
See Also

Reference

TocPanel Class
TocPanel Members


TocPanel Class Properties

TocPanel Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : TocPanel Class

For a list of all members of this type, see TocPanel members.

Public Properties
 | Name | Description
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContextMenu | Overridden. Gets or sets a context menu when the user right clicks on the toc panel.
Public Property | Expanded | Gets or sets a value that indicates whether the TocPanel is expanded.
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Overridden. Gets or sets the caption of table of content panel.
Top
See Also

Reference

TocPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


ContextMenu Property (TocPanel)

ContextMenu Property (TocPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : ContextMenu Property
Gets or sets a context menu when the user right clicks on the toc panel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Property ContextMenu As System.Windows.Forms.ContextMenu
public override System.Windows.Forms.ContextMenu ContextMenu {get; set;}

Property Value

The context menu.
See Also

Reference

TocPanel Class
TocPanel Members


Expanded Property (TocPanel)

Expanded Property (TocPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : Expanded Property
Gets or sets a value that indicates whether the TocPanel is expanded.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Expanded As System.Boolean
public System.bool Expanded {get; set;}
See Also

Reference

TocPanel Class
TocPanel Members


Text Property (TocPanel)

Text Property (TocPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : Text Property
Gets or sets the caption of table of content panel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Property Text As System.String
public override System.string Text {get; set;}

Property Value

The caption text.
Requirements

See Also

Reference

TocPanel Class
TocPanel Members


Viewer Class

Viewer Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Viewer Class
The Viewer control is used to preview report documents on the screen.
Object Model
Viewer Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Viewer
   Inherits System.Windows.Forms.UserControl
public class Viewer : System.Windows.Forms.UserControl
Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
GrapeCity.ActiveReports.Viewer.Win.Viewer

Requirements

See Also

Reference

Viewer Members
GrapeCity.ActiveReports.Viewer.Win Namespace


Viewer Class Members

Viewer Class Members
Properties Methods Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Viewer Class

The following tables list the members exposed by Viewer.

Public Constructors
 | Name | Description
Public Constructor | Viewer Constructor | Initializes a new instance of Viewer class.
Top
Public Properties
 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | AllowSplitter | Gets or sets a value that determines whether the user is allowed to split the view.
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AnnotationDropDownVisible | Gets or Sets the dropdown of annotation toolbar.
Public Property | AnnotationToolbarVisible | Gets or Sets the annotation toolbar's visibility.
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanExport | Indicates whether the currently loaded report can be exported.
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | CurrentPage | Gets or sets the number of the current document page displayed in the viewer. 1 based. Returns 0 if no report is loaded. Affects History.
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Document | Gets or sets the Active Reports document to be displayed on the Viewer control.
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | GalleyMode | Gets or sets GalleyMode of report
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | History | Public API for history manipulation.
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | HyperlinkBackColor | Gets or sets the background color of the controls that hosts a hyperlink. The default is transparent. For SectionReports only.
Public Property | HyperlinkForeColor | Gets or sets the color of the text within a control that hosts a hyperlink. The default is Blue. For SectionReports only.
Public Property | HyperlinkUnderline | Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true. For SectionReports only.
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MouseMode | Gets or sets the mouse mode of the viewer.
Public Property | MouseModeButtonsVisible | Indicates whether the "Pan", "Selection Mode" and "Snapshot" buttons are visible in the viewer toolbar.
Public Property | MultiplePageCols | Gets or sets the number of horizontal pages to display when the viewer is in MultiPageMode.
Public Property | MultiplePageRows | Gets or sets the number of pages displayed vertically when the viewer is in MultiPageMode.
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | PageOffset | Specifies the location of the page in the viewer.
Public Property | PagesBackColor | Public API for background color of report pane.
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | PreviewPages | Pages to load. Pass value less or equal to 0 to load all Applicable only for loading from SectionReport or PageDocument instances
Public Property | PrintingSettings | Gets or sets printing settings
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | RepositionPage | Determines whether the viewer will reposition the view to the top of the page when a user goes to another page after scrolling downward in a page.
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | ScrollbarEnabled | Public API. Show or hide scrolls within report pane.
Public Property | SearchResultsBackColor | Gets or sets the background color of the highlighted text when using the Viewer control's Find functionality.
Public Property | SearchResultsForeColor | Gets or sets the color of the highlighted text when using the Viewer control's Find functionality.
Public Property | Sidebar | Gets the sidebar component of the viewer control.
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | SplitView | Gets or sets a value that determines whether the viewer is split into two views.
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TableOfContents | Gets or sets a reference to the TableOfContentsObject.
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | TargetView | Gets or sets a value that specifies the current target view when SplitView is true.
Public Property | Toolbar | Gets the reference to ToolbarObject of the control.
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | TouchContextMenuStrip | Get or sets the context menu of touch enabled Viewer.
Public Property | TouchMode | Enable touch mode or not.
Public Property | TouchModeButtonVisibility | Display Touch mode button on viewer's toolbar or not.
Public Property | TouchModeToolbar | Pubilc API for touch mode Toolbar manipulation.
Public Property | UseHyperlinkSettings | Gets or sets whether to apply the hyperlink settings when hyperlinks are displayed in the Viewer. For SectionReports only.
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ViewType | Gets or sets a value that determines how the viewer shows pages(single/multi/continous).
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Public Property | Zoom | Gets or sets the viewer's zoom level. 1 for FitWidth mode 2 for Fit Whole Page mode. Throws ArgumentOutOfRangeException on invalid value.
Top
Public Methods
 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | Export | Overloaded. Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | HandleError | Reports about runtime error
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | LoadDocument | Overloaded. Loads a report.
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | Print | Overloaded. Prints the currently opened document (section or page).
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | Render | Exports the specified loaded report to the specified file (or group of files) by using the specified export extension. Note: for page report only.
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetParametersValues | Loads the specified remote report. Sets values of parameters for the report that is shown.
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | ShowFindDialog | Displays Find Dialog
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top
Public Events
 | Name | Description
Public Event | Action | This event fires when report item with specified action was clicked in the report preview control.
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | Find | Occurs when the Find dialog finds the requested text in the document.
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | HyperLink | Occurs when the user clicks on text or an image that has a hyperlink assigned to it.
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.UserControl)
Public Event | LoadCompleted | Occurs after all the viewer pages have been fully loaded.
Public Event | LocateCredentials | Fires when the PageReport to view generates LocateCredentials event.
Public Event | LocateDataSource | Fires when the PageReport to view generates LocateDataSource event.
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TableOfContentsAfterSelect | Occurs after an item is selected in the table of contents treeview.
Public Event | TableOfContentsClick | Occurs when the user clicks an item in the table of contents treeview.
Public Event | TableOfContentsSelectedIndexChanged | Occurs when the index of the currently selected item in the table of contents changes.
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ZoomChanged | Occurs when the zoom has changed in the viewer.
Top
See Also

Reference

Viewer Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Viewer Constructor

Viewer Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Viewer Constructor
Initializes a new instance of Viewer class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Viewer()
See Also

Reference

Viewer Class
Viewer Members


Viewer Class Methods

Viewer Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Viewer Class

For a list of all members of this type, see Viewer members.

Public Methods
 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | Export | Overloaded. Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | HandleError | Reports about runtime error
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | LoadDocument | Overloaded. Loads a report.
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | Print | Overloaded. Prints the currently opened document (section or page).
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | Render | Exports the specified loaded report to the specified file (or group of files) by using the specified export extension. Note: for page report only.
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetParametersValues | Loads the specified remote report. Sets values of parameters for the report that is shown.
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | ShowFindDialog | Displays Find Dialog
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top
See Also

Reference

Viewer Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Export Method (Viewer)

Export Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Export Method
Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.
Overload List
Overload | Description
Export(IDocumentExportEx,FileInfo) | Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.
Export(IDocumentExportEx,FileInfo,String) | Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.
Export(IDocumentExportEx,Stream) | Exports the specified page range of the currently loaded report to the specified stream by using the specified export filter.
Export(IDocumentExportEx,Stream,String) | Exports the specified page range of the currently loaded report to the specified stream by using the specified export filter.
See Also

Reference

Viewer Class
Viewer Members


Export(IDocumentExportEx,FileInfo) Method

Export(IDocumentExportEx,FileInfo) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Export Method : Export(IDocumentExportEx,FileInfo) Method
The filter that will export the currently loaded report.
The file to which the exported result will be saved.
Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal filter As IDocumentExportEx, _
   ByVal file As System.IO.FileInfo _
)
public void Export(
   IDocumentExportEx filter,
   System.IO.FileInfo file
)

Parameters

filter
The filter that will export the currently loaded report.
file
The file to which the exported result will be saved.
See Also

Reference

Viewer Class
Viewer Members
Overload List


Export(IDocumentExportEx,FileInfo,String) Method

Export(IDocumentExportEx,FileInfo,String) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Export Method : Export(IDocumentExportEx,FileInfo,String) Method
The filter that will export the currently loaded report.
The file to which the exported result will be saved.
A range of page numbers to export separated by a comma. Between each comma you can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range."
Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal filter As IDocumentExportEx, _
   ByVal file As System.IO.FileInfo, _
   ByVal pageRange As System.String _
)
public void Export(
   IDocumentExportEx filter,
   System.IO.FileInfo file,
   System.string pageRange
)

Parameters

filter
The filter that will export the currently loaded report.
file
The file to which the exported result will be saved.
pageRange
A range of page numbers to export separated by a comma. Between each comma you can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range."
See Also

Reference

Viewer Class
Viewer Members
Overload List


Export(IDocumentExportEx,Stream) Method

Export(IDocumentExportEx,Stream) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Export Method : Export(IDocumentExportEx,Stream) Method
The filter that will export the currently loaded report.

The System.IO.Stream to which to save the exported result
Exports the specified page range of the currently loaded report to the specified stream by using the specified export filter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal filter As IDocumentExportEx, _
   ByVal stream As System.IO.Stream _
)
public void Export(
   IDocumentExportEx filter,
   System.IO.Stream stream
)

Parameters

filter
The filter that will export the currently loaded report.
stream

The System.IO.Stream to which to save the exported result
See Also

Reference

Viewer Class
Viewer Members
Overload List


Export(IDocumentExportEx,Stream,String) Method

Export(IDocumentExportEx,Stream,String) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Export Method : Export(IDocumentExportEx,Stream,String) Method
the filter that will export the currently loaded report.
The System.IO.Stream to which to save the exported result.
A range of page numbers to export separated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
Exports the specified page range of the currently loaded report to the specified stream by using the specified export filter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal filter As IDocumentExportEx, _
   ByVal stream As System.IO.Stream, _
   ByVal pageRange As System.String _
)
public void Export(
   IDocumentExportEx filter,
   System.IO.Stream stream,
   System.string pageRange
)

Parameters

filter
the filter that will export the currently loaded report.
stream
The System.IO.Stream to which to save the exported result.
pageRange
A range of page numbers to export separated by a comma. Between each comma can have a single page number, or range of pages with a hyphen between the starting and ending page numbers in the range.
See Also

Reference

Viewer Class
Viewer Members
Overload List


HandleError Method (Viewer)

HandleError Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : HandleError Method
The exception to report.
Reports about runtime error
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub HandleError( _
   ByVal ex As System.Exception _
)
public void HandleError(
   System.Exception ex
)

Parameters

ex
The exception to report.
See Also

Reference

Viewer Class
Viewer Members


LoadDocument Method (Viewer)

LoadDocument Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : LoadDocument Method
Loads a report.
Overload List
Overload | Description
LoadDocument(Stream,DocumentFormat) | Loads a document from a stream in the specified binary or XML report format.
LoadDocument(String) | Load the report from a specified file path.
LoadDocument(PageDocument) | Load the specified static page report document.
LoadDocument(SectionReport) | Load the specified section report object during run-time.
LoadDocument(SectionDocument) | Load the specified static section report document.
See Also

Reference

Viewer Class
Viewer Members


LoadDocument(Stream,DocumentFormat) Method

LoadDocument(Stream,DocumentFormat) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > LoadDocument Method : LoadDocument(Stream,DocumentFormat) Method
The System.IO.Stream to load the report from.
Specify the DocumentFormat of the report to be loaded.
Loads a document from a stream in the specified binary or XML report format.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadDocument( _
   ByVal stream As System.IO.Stream, _
   ByVal format As DocumentFormat _
)
public void LoadDocument(
   System.IO.Stream stream,
   DocumentFormat format
)

Parameters

stream
The System.IO.Stream to load the report from.
format
Specify the DocumentFormat of the report to be loaded.
See Also

Reference

Viewer Class
Viewer Members
Overload List


LoadDocument(String) Method

LoadDocument(String) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > LoadDocument Method : LoadDocument(String) Method

The path to the file to load the report form.

Load the report from a specified file path.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadDocument( _
   ByVal filePath As System.String _
)
public void LoadDocument(
   System.string filePath
)

Parameters

filePath

The path to the file to load the report form.

See Also

Reference

Viewer Class
Viewer Members
Overload List


LoadDocument(PageDocument) Method

LoadDocument(PageDocument) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > LoadDocument Method : LoadDocument(PageDocument) Method

The page report to open in the viewer.

Load the specified static page report document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadDocument( _
   ByVal pageDocument As PageDocument _
)
public void LoadDocument(
   PageDocument pageDocument
)

Parameters

pageDocument

The page report to open in the viewer.

See Also

Reference

Viewer Class
Viewer Members
Overload List


LoadDocument(SectionReport) Method

LoadDocument(SectionReport) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > LoadDocument Method : LoadDocument(SectionReport) Method

The section report to view in the viewer.

Load the specified section report object during run-time.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadDocument( _
   ByVal report As SectionReport _
)
public void LoadDocument(
   SectionReport report
)

Parameters

report

The section report to view in the viewer.

See Also

Reference

Viewer Class
Viewer Members
Overload List


LoadDocument(SectionDocument) Method

LoadDocument(SectionDocument) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > LoadDocument Method : LoadDocument(SectionDocument) Method
the section document to open in the viewer.
Load the specified static section report document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadDocument( _
   ByVal document As SectionDocument _
)
public void LoadDocument(
   SectionDocument document
)

Parameters

document
the section document to open in the viewer.
See Also

Reference

Viewer Class
Viewer Members
Overload List


Print Method (Viewer)

Print Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Print Method
Prints the currently opened document (section or page).
Overload List
Overload | Description
Print(Boolean) | Prints the currently opened document(section or page)
Print(Boolean,Boolean) | Prints the currently opened document(section or page)
Print(Boolean,Boolean,Boolean) | Prints the currently opened document(section or page)
Print(PrintingSettings) | Prints the currently opened document(section or page)
See Also

Reference

Viewer Class
Viewer Members


Print(Boolean) Method

Print(Boolean) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Print Method : Print(Boolean) Method
Specifies whether or not the Print dialog should be shown.
Prints the currently opened document(section or page)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Print( _
   ByVal showPrintDialog As System.Boolean _
) As System.Boolean
public System.bool Print(
   System.bool showPrintDialog
)

Parameters

showPrintDialog
Specifies whether or not the Print dialog should be shown.
See Also

Reference

Viewer Class
Viewer Members
Overload List


Print(Boolean,Boolean) Method

Print(Boolean,Boolean) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Print Method : Print(Boolean,Boolean) Method
Specifies whether or not the Print dialog should be shown.
Specifies whether or not the PrintProgress dialog should be shown.
Prints the currently opened document(section or page)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Print( _
   ByVal showPrintDialog As System.Boolean, _
   ByVal showPrintProgressDialog As System.Boolean _
) As System.Boolean
public System.bool Print(
   System.bool showPrintDialog,
   System.bool showPrintProgressDialog
)

Parameters

showPrintDialog
Specifies whether or not the Print dialog should be shown.
showPrintProgressDialog
Specifies whether or not the PrintProgress dialog should be shown.
See Also

Reference

Viewer Class
Viewer Members
Overload List


Print(Boolean,Boolean,Boolean) Method

Print(Boolean,Boolean,Boolean) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Print Method : Print(Boolean,Boolean,Boolean) Method
If this property is set to True, then a dialog in which the user can set the printer options beforethe document contents are sent to the printer, is displayed.
If this property is set to True, then a print progress dialog, in which the user can cancel the printing job, is displayed.
Specifies whether printing should be performed for individual threads or not.
Prints the currently opened document(section or page)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Print( _
   ByVal showPrintDialog As System.Boolean, _
   ByVal showPrintProgressDialog As System.Boolean, _
   ByVal usePrintingThread As System.Boolean _
) As System.Boolean
public System.bool Print(
   System.bool showPrintDialog,
   System.bool showPrintProgressDialog,
   System.bool usePrintingThread
)

Parameters

showPrintDialog
If this property is set to True, then a dialog in which the user can set the printer options beforethe document contents are sent to the printer, is displayed.
showPrintProgressDialog
If this property is set to True, then a print progress dialog, in which the user can cancel the printing job, is displayed.
usePrintingThread
Specifies whether printing should be performed for individual threads or not.
See Also

Reference

Viewer Class
Viewer Members
Overload List


Print(PrintingSettings) Method

Print(PrintingSettings) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Print Method : Print(PrintingSettings) Method
Prints the currently opened document(section or page)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Print( _
   ByVal settings As PrintingSettings _
) As System.Boolean
public System.bool Print(
   PrintingSettings settings
)

Parameters

settings
See Also

Reference

Viewer Class
Viewer Members
Overload List


Render Method (Viewer)

Render Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Render Method
The rendering extension to render the currently loaded report.
The stream provider to store the render output.
The rendering extension settings.
Exports the specified loaded report to the specified file (or group of files) by using the specified export extension. Note: for page report only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Render( _
   ByVal extension As IRenderingExtension, _
   ByVal streamProvider As StreamProvider, _
   ByVal settings As System.Collections.Specialized.NameValueCollection _
)
public void Render(
   IRenderingExtension extension,
   StreamProvider streamProvider,
   System.Collections.Specialized.NameValueCollection settings
)

Parameters

extension
The rendering extension to render the currently loaded report.
streamProvider
The stream provider to store the render output.
settings
The rendering extension settings.
See Also

Reference

Viewer Class
Viewer Members


SetParametersValues Method (Viewer)

SetParametersValues Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : SetParametersValues Method
Values of parameters to be set
Loads the specified remote report. Sets values of parameters for the report that is shown.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetParametersValues( _
   ByVal parameters As System.Collections.Generic.IEnumerable(Of IParameter) _
)
public void SetParametersValues(
   System.Collections.Generic.IEnumerable<IParameter> parameters
)

Parameters

parameters
Values of parameters to be set
See Also

Reference

Viewer Class
Viewer Members


ShowFindDialog Method

ShowFindDialog Method
Example

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ShowFindDialog Method
Displays Find Dialog
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ShowFindDialog()
public void ShowFindDialog()
Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    rptDD rpt = new rptDD();
    rpt.Run();
    arv.Document = rpt.Document;
    arv.ShowFindDialog();
}
  • VB.NET
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New rptDD
    rpt.Run()
    arv.Document = rpt.Document
    arv.ShowFindDialog()
End Sub
See Also

Reference

Viewer Class
Viewer Members


Viewer Class Properties

Viewer Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Viewer Class

For a list of all members of this type, see Viewer members.

Public Properties
 | Name | Description
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | AllowSplitter | Gets or sets a value that determines whether the user is allowed to split the view.
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AnnotationDropDownVisible | Gets or Sets the dropdown of annotation toolbar.
Public Property | AnnotationToolbarVisible | Gets or Sets the annotation toolbar's visibility.
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.UserControl)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.UserControl)
Public Property | BackColor | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | BorderStyle | (Inherited from System.Windows.Forms.UserControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CanExport | Indicates whether the currently loaded report can be exported.
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | CurrentPage | Gets or sets the number of the current document page displayed in the viewer. 1 based. Returns 0 if no report is loaded. Affects History.
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Document | Gets or sets the Active Reports document to be displayed on the Viewer control.
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | GalleyMode | Gets or sets GalleyMode of report
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | History | Public API for history manipulation.
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | HyperlinkBackColor | Gets or sets the background color of the controls that hosts a hyperlink. The default is transparent. For SectionReports only.
Public Property | HyperlinkForeColor | Gets or sets the color of the text within a control that hosts a hyperlink. The default is Blue. For SectionReports only.
Public Property | HyperlinkUnderline | Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true. For SectionReports only.
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Control)
Public Property | Margin | (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Control)
Public Property | MouseMode | Gets or sets the mouse mode of the viewer.
Public Property | MouseModeButtonsVisible | Indicates whether the "Pan", "Selection Mode" and "Snapshot" buttons are visible in the viewer toolbar.
Public Property | MultiplePageCols | Gets or sets the number of horizontal pages to display when the viewer is in MultiPageMode.
Public Property | MultiplePageRows | Gets or sets the number of pages displayed vertically when the viewer is in MultiPageMode.
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | PageOffset | Specifies the location of the page in the viewer.
Public Property | PagesBackColor | Public API for background color of report pane.
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | PreviewPages | Pages to load. Pass value less or equal to 0 to load all Applicable only for loading from SectionReport or PageDocument instances
Public Property | PrintingSettings | Gets or sets printing settings
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | RepositionPage | Determines whether the viewer will reposition the view to the top of the page when a user goes to another page after scrolling downward in a page.
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | ScrollbarEnabled | Public API. Show or hide scrolls within report pane.
Public Property | SearchResultsBackColor | Gets or sets the background color of the highlighted text when using the Viewer control's Find functionality.
Public Property | SearchResultsForeColor | Gets or sets the color of the highlighted text when using the Viewer control's Find functionality.
Public Property | Sidebar | Gets the sidebar component of the viewer control.
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Control)
Public Property | SplitView | Gets or sets a value that determines whether the viewer is split into two views.
Public Property | TabIndex | (Inherited from System.Windows.Forms.Control)
Public Property | TableOfContents | Gets or sets a reference to the TableOfContentsObject.
Public Property | TabStop | (Inherited from System.Windows.Forms.Control)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | TargetView | Gets or sets a value that specifies the current target view when SplitView is true.
Public Property | Toolbar | Gets the reference to ToolbarObject of the control.
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | TouchContextMenuStrip | Get or sets the context menu of touch enabled Viewer.
Public Property | TouchMode | Enable touch mode or not.
Public Property | TouchModeButtonVisibility | Display Touch mode button on viewer's toolbar or not.
Public Property | TouchModeToolbar | Pubilc API for touch mode Toolbar manipulation.
Public Property | UseHyperlinkSettings | Gets or sets whether to apply the hyperlink settings when hyperlinks are displayed in the Viewer. For SectionReports only.
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | ViewType | Gets or sets a value that determines how the viewer shows pages(single/multi/continous).
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Public Property | Zoom | Gets or sets the viewer's zoom level. 1 for FitWidth mode 2 for Fit Whole Page mode. Throws ArgumentOutOfRangeException on invalid value.
Top
See Also

Reference

Viewer Class
GrapeCity.ActiveReports.Viewer.Win Namespace


AllowSplitter Property (Viewer)

AllowSplitter Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AllowSplitter Property
Gets or sets a value that determines whether the user is allowed to split the view.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AllowSplitter As System.Boolean
public System.bool AllowSplitter {get; set;}
See Also

Reference

Viewer Class
Viewer Members


AnnotationDropDownVisible Property

AnnotationDropDownVisible Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AnnotationDropDownVisible Property
Gets or Sets the dropdown of annotation toolbar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AnnotationDropDownVisible As System.Boolean
public System.bool AnnotationDropDownVisible {get; set;}
Remarks
It only takes effect in mouse mode toolbar.
See Also

Reference

Viewer Class
Viewer Members


AnnotationToolbarVisible Property

AnnotationToolbarVisible Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AnnotationToolbarVisible Property
Gets or Sets the annotation toolbar's visibility.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AnnotationToolbarVisible As System.Boolean
public System.bool AnnotationToolbarVisible {get; set;}
See Also

Reference

Viewer Class
Viewer Members


CanExport Property (Viewer)

CanExport Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CanExport Property

Indicates whether the currently loaded report can be exported.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CanExport As System.Boolean
public System.bool CanExport {get;}
See Also

Reference

Viewer Class
Viewer Members


CurrentPage Property (Viewer)

CurrentPage Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CurrentPage Property
Gets or sets the number of the current document page displayed in the viewer. 1 based. Returns 0 if no report is loaded. Affects History.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CurrentPage As System.Integer
public System.int CurrentPage {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Document Property (Viewer)

Document Property (Viewer)
Example

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Document Property
Gets or sets the Active Reports document to be displayed on the Viewer control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Document As SectionDocument
public SectionDocument Document {get; set;}

Property Value

Document value that represents the document currently displayed on the Viewer.
Example
  • C#
private void Form1_Load(object sender, System.EventArgs e)
{
    ResourceManager res = new ResourceManager("rptLocalize.localization", this.GetType().Assembly);
    this.viewer1.Localize = res;
    rptLocalize rpt = new rptLocalize();
    viewer1.Document = rpt.Document;
    rpt.Run(true);
}
  • VB.NET
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim res As New ResourceManager("rptLocalize.localization", Me.GetType().Assembly)
    Me.Viewer1.Localize = res
    Dim rpt As New rptLocalize()
    Viewer1.Document = rpt.Document
    rpt.Run(True)
End Sub
See Also

Reference

Viewer Class
Viewer Members


GalleyMode Property (Viewer)

GalleyMode Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : GalleyMode Property
Gets or sets GalleyMode of report
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GalleyMode As System.Boolean
public System.bool GalleyMode {get; set;}
See Also

Reference

Viewer Class
Viewer Members


History Property (Viewer)

History Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : History Property
Public API for history manipulation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property History As IHistoryApi
public IHistoryApi History {get;}
See Also

Reference

Viewer Class
Viewer Members


HyperlinkBackColor Property (Viewer)

HyperlinkBackColor Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : HyperlinkBackColor Property
Gets or sets the background color of the controls that hosts a hyperlink. The default is transparent. For SectionReports only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HyperlinkBackColor As Color
public Color HyperlinkBackColor {get; set;}
See Also

Reference

Viewer Class
Viewer Members


HyperlinkForeColor Property (Viewer)

HyperlinkForeColor Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : HyperlinkForeColor Property
Gets or sets the color of the text within a control that hosts a hyperlink. The default is Blue. For SectionReports only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HyperlinkForeColor As Color
public Color HyperlinkForeColor {get; set;}
See Also

Reference

Viewer Class
Viewer Members


HyperlinkUnderline Property (Viewer)

HyperlinkUnderline Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : HyperlinkUnderline Property
Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true. For SectionReports only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HyperlinkUnderline As System.Boolean
public System.bool HyperlinkUnderline {get; set;}
See Also

Reference

Viewer Class
Viewer Members


MouseMode Property (Viewer)

MouseMode Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MouseMode Property
Gets or sets the mouse mode of the viewer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MouseMode As MouseMode
public MouseMode MouseMode {get; set;}
See Also

Reference

Viewer Class
Viewer Members


MouseModeButtonsVisible Property

MouseModeButtonsVisible Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MouseModeButtonsVisible Property
Indicates whether the "Pan", "Selection Mode" and "Snapshot" buttons are visible in the viewer toolbar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MouseModeButtonsVisible As System.Boolean
public System.bool MouseModeButtonsVisible {get; set;}
Remarks
It only takes effect in mouse mode toolbar.
See Also

Reference

Viewer Class
Viewer Members


MultiplePageCols Property

MultiplePageCols Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MultiplePageCols Property
Gets or sets the number of horizontal pages to display when the viewer is in MultiPageMode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MultiplePageCols As System.Integer
public System.int MultiplePageCols {get; set;}
See Also

Reference

Viewer Class
Viewer Members


MultiplePageRows Property

MultiplePageRows Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MultiplePageRows Property
Gets or sets the number of pages displayed vertically when the viewer is in MultiPageMode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MultiplePageRows As System.Integer
public System.int MultiplePageRows {get; set;}
See Also

Reference

Viewer Class
Viewer Members


PageOffset Property (Viewer)

PageOffset Property (Viewer)
Example

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PageOffset Property
Specifies the location of the page in the viewer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageOffset As Point
public Point PageOffset {get; set;}
Example
  • C#
private void Form1_Load(System.Object sender, System.EventArgs e)
{
    Viewer1.LoadDocument(new SectionReport1());
}

private void  Viewer1_LoadCompleted(System.Object sender, System.EventArgs e)
{
    Viewer1.PageOffset = new System.Drawing.Point(100, 200);
}
  • VB.NET
Private Sub Form1_Load(sender As System.Object, e As System.EventArgs) Handles MyBase.Load
        Viewer1.LoadDocument(New SectionReport1())
End Sub

Private Sub Viewer1_LoadCompleted(sender As System.Object, e As System.EventArgs) Handles Viewer1.LoadCompleted
        Viewer1.PageOffset = New System.Drawing.Point(100, 200)
End Sub
See Also

Reference

Viewer Class
Viewer Members


PagesBackColor Property (Viewer)

PagesBackColor Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PagesBackColor Property
Public API for background color of report pane.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PagesBackColor As Color
public Color PagesBackColor {get; set;}
See Also

Reference

Viewer Class
Viewer Members


PreviewPages Property (Viewer)

PreviewPages Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PreviewPages Property
Pages to load. Pass value less or equal to 0 to load all Applicable only for loading from SectionReport or PageDocument instances
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PreviewPages As System.Integer
public System.int PreviewPages {get; set;}
See Also

Reference

Viewer Class
Viewer Members


PrintingSettings Property (Viewer)

PrintingSettings Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PrintingSettings Property
Gets or sets printing settings
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrintingSettings As PrintingSettings
public PrintingSettings PrintingSettings {get; set;}
See Also

Reference

Viewer Class
Viewer Members


RepositionPage Property (Viewer)

RepositionPage Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : RepositionPage Property
Determines whether the viewer will reposition the view to the top of the page when a user goes to another page after scrolling downward in a page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RepositionPage As System.Boolean
public System.bool RepositionPage {get; set;}
See Also

Reference

Viewer Class
Viewer Members


ScrollbarEnabled Property (Viewer)

ScrollbarEnabled Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ScrollbarEnabled Property
Public API. Show or hide scrolls within report pane.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ScrollbarEnabled As System.Boolean
public System.bool ScrollbarEnabled {get; set;}
See Also

Reference

Viewer Class
Viewer Members


SearchResultsBackColor Property (Viewer)

SearchResultsBackColor Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : SearchResultsBackColor Property
Gets or sets the background color of the highlighted text when using the Viewer control's Find functionality.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SearchResultsBackColor As Color
public Color SearchResultsBackColor {get; set;}
See Also

Reference

Viewer Class
Viewer Members


SearchResultsForeColor Property (Viewer)

SearchResultsForeColor Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : SearchResultsForeColor Property
Gets or sets the color of the highlighted text when using the Viewer control's Find functionality.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SearchResultsForeColor As Color
public Color SearchResultsForeColor {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Sidebar Property (Viewer)

Sidebar Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Sidebar Property
Gets the sidebar component of the viewer control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Sidebar As Sidebar
public Sidebar Sidebar {get;}
See Also

Reference

Viewer Class
Viewer Members


SplitView Property (Viewer)

SplitView Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : SplitView Property
Gets or sets a value that determines whether the viewer is split into two views.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SplitView As System.Boolean
public System.bool SplitView {get; set;}
See Also

Reference

Viewer Class
Viewer Members


TableOfContents Property (Viewer)

TableOfContents Property (Viewer)
Example

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TableOfContents Property

Gets or sets a reference to the TableOfContentsObject.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TableOfContents As TocPanel
public TocPanel TableOfContents {get;}

Property Value

TableOfContentsObject value which is used in setting the tree view option of the Viewer's heading list.
Remarks

This property is used in setting the option of TableOfContentsObject component of the control.

Example
  • C#
private void arv_Load(object sender, System.EventArgs e)
{
    SectionReport1 rpt = new SectionReport1();
    rpt.Run();
    arv.Document = rpt.Document;

    arv.TableOfContents.Enabled = true;
    arv.TableOfContents.Text = "Country";
    arv.TableOfContents.Visible = true;
    arv.TableOfContents.Width = 150;
}
  • VB.NET
Private Sub arv_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles arv.Load
    Dim rpt As New SectionReport1
    rpt.Run()
    arv.Document = rpt.Document

    arv.TableOfContents.Enabled = True
    arv.TableOfContents.Text = "Country"
    arv.TableOfContents.Visible = True
    arv.TableOfContents.Width = 150
End Sub
See Also

Reference

Viewer Class
Viewer Members


TargetView Property (Viewer)

TargetView Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TargetView Property
Gets or sets a value that specifies the current target view when SplitView is true.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TargetView As TargetView
public TargetView TargetView {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Toolbar Property

Toolbar Property
Example

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Toolbar Property
Gets the reference to ToolbarObject of the control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Toolbar As Viewer.ViewerToolbar
public Viewer.ViewerToolbar Toolbar {get;}

Property Value

ToolbarObject used for setting tool bar options of view.
Example
  • C#
private ToolStripButton tsbPrint = new System.Windows.Forms.ToolStripButton();

        private void Form1_Load(object sender, EventArgs e)
        {
            System.Windows.Forms.ToolStrip toolStrip;
            System.Windows.Forms.ToolStripItem orgItem;
            System.Windows.Forms.ToolStripButton orgBtn = null;

            // Get the standard Print button, to get the image.
            toolStrip = this.viewer1.Toolbar.ToolStrip;
            orgItem = toolStrip.Items[2];
            if (orgItem is System.Windows.Forms.ToolStripButton)
            {
                orgBtn = (System.Windows.Forms.ToolStripButton)orgItem;
            }

            // Delete the standard Print button.
            toolStrip.Items.RemoveAt(2);

            // Add the Custom button, in place of the standard Print button.
            if (orgBtn == null)
            {
                tsbPrint.Text = "Print";
                tsbPrint.ToolTipText = "Print";
            }
            else
            {
                tsbPrint.Text = orgBtn.Text;
                tsbPrint.ToolTipText = orgBtn.ToolTipText;
                tsbPrint.Image = orgBtn.Image;
            }
            tsbPrint.Enabled = false;

            // Set the event handler of the Custom button.
            tsbPrint.Click += this.PrintButtonClick;

            // Add the custom button to the tool bar.
            toolStrip.Items.Insert(2, tsbPrint);
        }

        //Event to be called when the report is loaded in the Viewer.
        private void viewer1_LoadCompleted(object sender, EventArgs e)

        {
            // Enable the Custom button.
            tsbPrint.Enabled = true;
        }

        // Event to be called when the Custom button is clicked.
        private void PrintButtonClick(System.Object sender, System.EventArgs e)
        {
            // Perform the print processing.
            this.viewer1.Print(true, true, false);
        }
    }
}
  • VB.NET
Private tsbPrint As New System.Windows.Forms.ToolStripButton

Private Sub Form1_Load(...) Handles MyBase.Load
    Dim toolStrip As System.Windows.Forms.ToolStrip
    Dim orgBtn As System.Windows.Forms.ToolStripButton = Nothing
    Dim orgItem As System.Windows.Forms.ToolStripItem

    ' Get the standard Print button, to get the image.
    toolStrip = Me.Viewer1.Toolbar.ToolStrip
    orgItem = toolStrip.Items(2)
    If TypeOf orgItem Is System.Windows.Forms.ToolStripButton Then
        orgBtn = CType(orgItem, ToolStripButton)
    End If

    ' Delete the standard Print button.。
    toolStrip.Items.RemoveAt(2)

    ' Add the Custom button, in place of the standard Print button.
    If orgBtn Is Nothing Then
        tsbPrint.Text = "Print"
        tsbPrint.ToolTipText = "Print"
    Else
        tsbPrint.Text = orgBtn.Text
        tsbPrint.ToolTipText = orgBtn.ToolTipText
        tsbPrint.Image = orgBtn.Image
    End If
    tsbPrint.Enabled = False

    ' Set the event handler of the Custom button.
    AddHandler tsbPrint.Click, AddressOf Me.PrintButtonClick

    ' Add the custom button to the tool bar.
    toolStrip.Items.Insert(2, tsbPrint)

End Sub

' Event to be called when the report is loaded in the Viewer.
Private Sub Viewer1_LoadCompleted(...) Handles Viewer1.LoadCompleted
    'Enable the Custom button.
    tsbPrint.Enabled = True
End Sub

' Event to be called when the Custom button is clicked.
Private Sub PrintButtonClick(ByVal sender As Object, ByVal e As System.EventArgs)
    ' Perform the print processing.
    Me.Viewer1.Print(True, True, False)
End Sub
See Also

Reference

Viewer Class
Viewer Members


TouchContextMenuStrip Property

TouchContextMenuStrip Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TouchContextMenuStrip Property
Get or sets the context menu of touch enabled Viewer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TouchContextMenuStrip As System.Windows.Forms.ToolStripDropDown
public System.Windows.Forms.ToolStripDropDown TouchContextMenuStrip {get; set;}
Remarks
This property provides the ability to customize the context menu of the touch enabled Viewer.
Requirements

See Also

Reference

Viewer Class
Viewer Members


TouchMode Property

TouchMode Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TouchMode Property
Enable touch mode or not.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TouchMode As TouchMode
public TouchMode TouchMode {get; set;}
See Also

Reference

Viewer Class
Viewer Members


TouchModeButtonVisibility Property

TouchModeButtonVisibility Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TouchModeButtonVisibility Property
Display Touch mode button on viewer's toolbar or not.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TouchModeButtonVisibility As TouchModeButtonVisibility
public TouchModeButtonVisibility TouchModeButtonVisibility {get; set;}
See Also

Reference

Viewer Class
Viewer Members


TouchModeToolbar Property

TouchModeToolbar Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TouchModeToolbar Property
Pubilc API for touch mode Toolbar manipulation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TouchModeToolbar As Viewer.ViewerToolbar
public Viewer.ViewerToolbar TouchModeToolbar {get;}
See Also

Reference

Viewer Class
Viewer Members


UseHyperlinkSettings Property (Viewer)

UseHyperlinkSettings Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : UseHyperlinkSettings Property
Gets or sets whether to apply the hyperlink settings when hyperlinks are displayed in the Viewer. For SectionReports only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseHyperlinkSettings As System.Boolean
public System.bool UseHyperlinkSettings {get; set;}
See Also

Reference

Viewer Class
Viewer Members


ViewType Property (Viewer)

ViewType Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ViewType Property
Gets or sets a value that determines how the viewer shows pages(single/multi/continous).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ViewType As ViewType
public ViewType ViewType {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Zoom Property (Viewer)

Zoom Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Zoom Property
Gets or sets the viewer's zoom level. 1 for FitWidth mode 2 for Fit Whole Page mode. Throws ArgumentOutOfRangeException on invalid value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Zoom As System.Single
public System.float Zoom {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Viewer Class Events

Viewer Class Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Viewer Class

For a list of all members of this type, see Viewer members.

Public Events
 | Name | Description
Public Event | Action | This event fires when report item with specified action was clicked in the report preview control.
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | Find | Occurs when the Find dialog finds the requested text in the document.
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | HyperLink | Occurs when the user clicks on text or an image that has a hyperlink assigned to it.
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.UserControl)
Public Event | LoadCompleted | Occurs after all the viewer pages have been fully loaded.
Public Event | LocateCredentials | Fires when the PageReport to view generates LocateCredentials event.
Public Event | LocateDataSource | Fires when the PageReport to view generates LocateDataSource event.
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TableOfContentsAfterSelect | Occurs after an item is selected in the table of contents treeview.
Public Event | TableOfContentsClick | Occurs when the user clicks an item in the table of contents treeview.
Public Event | TableOfContentsSelectedIndexChanged | Occurs when the index of the currently selected item in the table of contents changes.
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ZoomChanged | Occurs when the zoom has changed in the viewer.
Top
See Also

Reference

Viewer Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Action Event (Viewer)

Action Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Action Event
This event fires when report item with specified action was clicked in the report preview control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Action As System.EventHandler(Of Viewer.ActionEventArgs)
public event System.EventHandler<Viewer.ActionEventArgs> Action
Event Data

The event handler receives an argument of type Viewer.ActionEventArgs containing data related to this event. The following Viewer.ActionEventArgs properties provide information specific to this event.

Property | Description
Action | Specifies the action that should be performed in response to this event.
Cancel | (Inherited from System.ComponentModel.CancelEventArgs) (Inherited from System.ComponentModel.CancelEventArgs)
PageNumber | Specifies the page number in current layout tree that should be navigated to.
See Also

Reference

Viewer Class
Viewer Members


Find Event

Find Event

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Find Event
Occurs when the Find dialog finds the requested text in the document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Find As FindEventHandler
public event FindEventHandler Find
Event Data

The event handler receives an argument of type FindEventArgs containing data related to this event. The following FindEventArgs properties provide information specific to this event.

Property | Description
Found | Gets the value that determines whether the text was found.
PageIndex | Gets the page number where the text was found.
See Also

Reference

Viewer Class
Viewer Members


HyperLink Event (Viewer)

HyperLink Event (Viewer)
Example

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : HyperLink Event
Occurs when the user clicks on text or an image that has a hyperlink assigned to it.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event HyperLink As HyperLinkEventHandler
public event HyperLinkEventHandler HyperLink
Event Data

The event handler receives an argument of type HyperLinkEventArgs containing data related to this event. The following HyperLinkEventArgs properties provide information specific to this event.

Property | Description
Button | Gets the mouse button that the user clicked to raise the event.
CreateNewTab | Gets or sets a value indicating whether a new tab has been created.
Handled | Sets or returns a value indicating whether the HyperLinkEvent is handled.
HyperLink | Gets the hyperlink target.
Example
  • C#
private void viewer1_HyperLink(object sender, GrapeCity.ActiveReports.Viewer.Win.HyperLinkEventArgs e)
{
    rptDrillDown1 rpt2 = new rptDrillDown1();
    frmViewDrillDown1 frm2 = new frmViewDrillDown1();
    rpt2.Parameters["customerID"].Value = e.HyperLink.ToString();
    rpt2.Run();
    frm2.viewer1.Document = rpt2.Document;
    frm2.ShowDialog(this);
}
  • Visual Basic
Private Sub Viewer1_HyperLink(ByVal sender As Object, ByVal e As GrapeCity.ActiveReports.Viewer.Win _
    HyperLinkEventArgs) Handles Viewer1.HyperLink
    Dim rpt2 As New rptDrillDown1()
    Dim frm2 As New frmViewDrillDown1()
    rpt2.Parameters("customerID").Value = e.HyperLink.ToString
    Console.WriteLine(rpt2.ds.SQL.ToString)
    rpt2.Run()
    frm2.Viewer1.Document = rpt2.Document
    frm2.ShowDialog(Me)
End Sub
See Also

Reference

Viewer Class
Viewer Members


LoadCompleted Event (Viewer)

LoadCompleted Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : LoadCompleted Event
Occurs after all the viewer pages have been fully loaded.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LoadCompleted As LoadCompletedEventHandler
public event LoadCompletedEventHandler LoadCompleted
See Also

Reference

Viewer Class
Viewer Members


LocateCredentials Event (Viewer)

LocateCredentials Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : LocateCredentials Event
Fires when the PageReport to view generates LocateCredentials event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LocateCredentials As LocateCredentialsEventHandler
public event LocateCredentialsEventHandler LocateCredentials
Event Data

The event handler receives an argument of type LocateCredentialsEventArgs containing data related to this event. The following LocateCredentialsEventArgs properties provide information specific to this event.

Property | Description
DataSourceName | Gets the name of the data source to locate credentials for.
Password | Gets ot sets the password of the credentials to be located.
PromptText | Gets the text of prompt of the locate credentials request.
ReportPath | Gets the name of the report to locate credentials for.
UserName | Gets ot sets the user name of the credentials to be located.
See Also

Reference

Viewer Class
Viewer Members


LocateDataSource Event (Viewer)

LocateDataSource Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : LocateDataSource Event
Fires when the PageReport to view generates LocateDataSource event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LocateDataSource As LocateDataSourceEventHandler
public event LocateDataSourceEventHandler LocateDataSource
Event Data

The event handler receives an argument of type LocateDataSourceEventArgs containing data related to this event. The following LocateDataSourceEventArgs properties provide information specific to this event.

Property | Description
Data | The data returned by the event handler.
DataSetName | Gets the name of data set to be located.
DataSourceName | Gets the name of data source that contains the data set to be located.
Report | Gets the Report that is trying to locate the data set.
See Also

Reference

Viewer Class
Viewer Members


TableOfContentsAfterSelect Event

TableOfContentsAfterSelect Event

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TableOfContentsAfterSelect Event
Occurs after an item is selected in the table of contents treeview.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TableOfContentsAfterSelect As System.Windows.Forms.TreeViewEventHandler
public event System.Windows.Forms.TreeViewEventHandler TableOfContentsAfterSelect
Event Data

The event handler receives an argument of type System.Windows.Forms.TreeViewEventArgs containing data related to this event. The following TreeViewEventArgs properties provide information specific to this event.

Property | Description
Action | Gets the type of action that raised the event.
Node | Gets the tree node that has been checked, expanded, collapsed, or selected.
See Also

Reference

Viewer Class
Viewer Members


TableOfContentsClick Event

TableOfContentsClick Event
Example

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TableOfContentsClick Event
Occurs when the user clicks an item in the table of contents treeview.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TableOfContentsClick As System.EventHandler
public event System.EventHandler TableOfContentsClick
Example
  • C#
private void arv_TableOfContentsClick(object sender, System.EventArgs e)
{
    int toc;
    toc = arv.Document.Bookmarks.CurrentBookmark;
    MessageBox.Show("Boomark is on page" + arv.Document.Bookmarks[toc].PageNumber.ToString + "at a distance of" + arv.Document.Bookmarks[toc].Offset.ToString + "inches from the top.");
}
  • Visual Basic
Private Sub arv_TableOfContentsClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles arv.TableOfContentsClick
    Dim toc As Integer
    toc = arv.Document.Bookmarks.CurrentBookmark
    MessageBox.Show("Boomark is on page" & arv.Document.Bookmarks(toc).PageNumber.ToString　& "at a distance of"　& arv.Document.Bookmarks(toc).Offset.ToString & "inches from the top.")
End Sub
See Also

Reference

Viewer Class
Viewer Members


TableOfContentsSelectedIndexChanged Event

TableOfContentsSelectedIndexChanged Event

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TableOfContentsSelectedIndexChanged Event
Occurs when the index of the currently selected item in the table of contents changes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TableOfContentsSelectedIndexChanged As System.EventHandler
public event System.EventHandler TableOfContentsSelectedIndexChanged
See Also

Reference

Viewer Class
Viewer Members


ZoomChanged Event (Viewer)

ZoomChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ZoomChanged Event
Occurs when the zoom has changed in the viewer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ZoomChanged As ZoomChangedEventHandler
public event ZoomChangedEventHandler ZoomChanged
Event Data

The event handler receives an argument of type ZoomChangedEventArgs containing data related to this event. The following ZoomChangedEventArgs properties provide information specific to this event.

Property | Description
Zoom | Returns the viewer's new Zoom value.
See Also

Reference

Viewer Class
Viewer Members


Viewer.ActionEventArgs Class

Viewer.ActionEventArgs Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Viewer.ActionEventArgs Class
Provides data for Action event.
Object Model
Viewer.ActionEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Viewer.ActionEventArgs
   Inherits System.ComponentModel.CancelEventArgs
public class Viewer.ActionEventArgs : System.ComponentModel.CancelEventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
GrapeCity.ActiveReports.Viewer.Win.Viewer.ActionEventArgs

See Also

Reference

Viewer.ActionEventArgs Members
GrapeCity.ActiveReports.Viewer.Win Namespace


Viewer.ActionEventArgs Class Members

Viewer.ActionEventArgs Class Members
Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Viewer.ActionEventArgs Class

The following tables list the members exposed by Viewer.ActionEventArgs.

Public Constructors
 | Name | Description
Public Constructor | Viewer.ActionEventArgs Constructor | Overloaded. Initializes a new instance of Viewer.ActionEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Action | Specifies the action that should be performed in response to this event.
Public Property | Cancel | (Inherited from System.ComponentModel.CancelEventArgs) (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | PageNumber | Specifies the page number in current layout tree that should be navigated to.
Top
See Also

Reference

Viewer.ActionEventArgs Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Viewer.ActionEventArgs Constructor

Viewer.ActionEventArgs Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer.ActionEventArgs Class : Viewer.ActionEventArgs Constructor
Initializes a new instance of Viewer.ActionEventArgs class.
Overload List
Overload | Description
Viewer.ActionEventArgs Constructor() | Default ctor.
Viewer.ActionEventArgs Constructor(IAction) | Initalizes rendering event data with Action
Viewer.ActionEventArgs Constructor(IAction,Int32) | Initalizes rendering event data with Action
See Also

Reference

Viewer.ActionEventArgs Class
Viewer.ActionEventArgs Members


Viewer.ActionEventArgs Constructor()

Viewer.ActionEventArgs Constructor()

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer.ActionEventArgs Class > Viewer.ActionEventArgs Constructor : Viewer.ActionEventArgs Constructor()
Default ctor.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Viewer.ActionEventArgs()
See Also

Reference

Viewer.ActionEventArgs Class
Viewer.ActionEventArgs Members
Overload List


Viewer.ActionEventArgs Constructor(IAction)

Viewer.ActionEventArgs Constructor(IAction)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer.ActionEventArgs Class > Viewer.ActionEventArgs Constructor : Viewer.ActionEventArgs Constructor(IAction)
Action that should be performed in response to this event.
Initalizes rendering event data with Action
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal action As IAction _
)
public Viewer.ActionEventArgs(
   IAction action
)

Parameters

action
Action that should be performed in response to this event.
See Also

Reference

Viewer.ActionEventArgs Class
Viewer.ActionEventArgs Members
Overload List


Viewer.ActionEventArgs Constructor(IAction,Int32)

Viewer.ActionEventArgs Constructor(IAction,Int32)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer.ActionEventArgs Class > Viewer.ActionEventArgs Constructor : Viewer.ActionEventArgs Constructor(IAction,Int32)
Action that should be performed in response to this event.
The page number in current layout tree that should be navigated to.
Initalizes rendering event data with Action
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal action As IAction, _
   ByVal pageNumber As System.Integer _
)
public Viewer.ActionEventArgs(
   IAction action,
   System.int pageNumber
)

Parameters

action
Action that should be performed in response to this event.
pageNumber
The page number in current layout tree that should be navigated to.
See Also

Reference

Viewer.ActionEventArgs Class
Viewer.ActionEventArgs Members
Overload List


Viewer.ActionEventArgs Class Properties

Viewer.ActionEventArgs Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Viewer.ActionEventArgs Class

For a list of all members of this type, see Viewer.ActionEventArgs members.

Public Properties
 | Name | Description
Public Property | Action | Specifies the action that should be performed in response to this event.
Public Property | Cancel | (Inherited from System.ComponentModel.CancelEventArgs) (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | PageNumber | Specifies the page number in current layout tree that should be navigated to.
Top
See Also

Reference

Viewer.ActionEventArgs Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Action Property (Viewer.ActionEventArgs)

Action Property (Viewer.ActionEventArgs)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer.ActionEventArgs Class : Action Property
Specifies the action that should be performed in response to this event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Action As IAction
public IAction Action {get;}
Remarks
There could be no action defined for the event in that case PageNumber specifies page which should be activated.
See Also

Reference

Viewer.ActionEventArgs Class
Viewer.ActionEventArgs Members


PageNumber Property (Viewer.ActionEventArgs)

PageNumber Property (Viewer.ActionEventArgs)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer.ActionEventArgs Class : PageNumber Property
Specifies the page number in current layout tree that should be navigated to.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PageNumber As System.Integer
public System.int PageNumber {get;}
See Also

Reference

Viewer.ActionEventArgs Class
Viewer.ActionEventArgs Members


Viewer.ViewerToolbar Class

Viewer.ViewerToolbar Class
Members Example

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Viewer.ViewerToolbar Class
Gets the viewer toolbar object, allowing you to add and remove items on each of the component ToolStrips, and to implement tool click events for added items.
Object Model
Viewer.ViewerToolbar Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Viewer.ViewerToolbar
public class Viewer.ViewerToolbar
Remarks
Also see the System.Windows.Forms.ToolStripItemClickedEventArgs class and ClickedItem property on MSDN for more information on working with ToolStrips.
Example
To implement tool click events, use code like the following in the Form Load event of the form that contains the Viewer control, and then drop down the IntelliSense Generate Method Stub arrow to generate method stubs for the events.
C# code to use in the Form Load event
  • C#
this.viewer1.Toolbar.NavigationBar.ItemClicked +=new ToolStripItemClickedEventHandler(NavigationBar_ItemClicked);
this.viewer1.Toolbar.MainBar.ItemClicked += new ToolStripItemClickedEventHandler(MainBar_ItemClicked);
this.viewer1.Toolbar.MouseModeBar.ItemClicked += new ToolStripItemClickedEventHandler(MouseModeBar_ItemClicked);
Visual Basic code to use in the Form Load event
  • VB.NET
AddHandler me.Viewer1.Toolbar.NavigationBar.ItemClicked, AddressOf NavigationBar_ItemClicked
AddHandler me.Viewer1.Toolbar.MainBar.ItemClicked, AddressOf MainBar_ItemClicked
AddHandler me.Viewer1.Toolbar.MouseModeBar.ItemClicked, AddressOf MouseModeBar_ItemClicked
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Viewer.Win.Viewer.ViewerToolbar

See Also

Reference

Viewer.ViewerToolbar Members
GrapeCity.ActiveReports.Viewer.Win Namespace
Customize the Viewer ToolStrip
Customize the Viewer Control


Viewer.ViewerToolbar Class Members

Viewer.ViewerToolbar Class Members
Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Viewer.ViewerToolbar Class

The following tables list the members exposed by Viewer.ViewerToolbar.

Public Properties
 | Name | Description
Public Property | MainBar | The main tool strip in the Windows Forms Viewer control.
Public Property | MouseModeBar | The mouse mode tool strip in the Windows Forms Viewer control.
Public Property | NavigationBar | The navigation tool strip in the Windows Forms Viewer control.
Public Property | ToolStrip | Reference to the ToolStrip.
Top
See Also

Reference

Viewer.ViewerToolbar Class
GrapeCity.ActiveReports.Viewer.Win Namespace
Customize the Viewer ToolStrip
Customize the Viewer Control


Viewer.ViewerToolbar Class Properties

Viewer.ViewerToolbar Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : Viewer.ViewerToolbar Class

For a list of all members of this type, see Viewer.ViewerToolbar members.

Public Properties
 | Name | Description
Public Property | MainBar | The main tool strip in the Windows Forms Viewer control.
Public Property | MouseModeBar | The mouse mode tool strip in the Windows Forms Viewer control.
Public Property | NavigationBar | The navigation tool strip in the Windows Forms Viewer control.
Public Property | ToolStrip | Reference to the ToolStrip.
Top
See Also

Reference

Viewer.ViewerToolbar Class
GrapeCity.ActiveReports.Viewer.Win Namespace
Customize the Viewer ToolStrip
Customize the Viewer Control


MainBar Property

MainBar Property
Example

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer.ViewerToolbar Class : MainBar Property
The main tool strip in the Windows Forms Viewer control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MainBar As System.Windows.Forms.ToolStrip
public System.Windows.Forms.ToolStrip MainBar {get;}
Remarks

Items on this toolstrip and their index numbers:

  • 0 Toggle sidebar
  • 1 Separator
  • 2 Print
  • 3 Galley mode
  • 4 Separator
  • 5 Copy
  • 6 Find
  • 7 Separator
  • 8 Zoom out
  • 9 Current zoom
  • 10 Zoom in
  • 11 Separator
  • 12 Fit width
  • 13 Fit page
  • 14 Separator
  • 15 Single page view
  • 16 Continuous view
  • 17 Multipage view
  • 18 Refresh
  • 19 Cancel

You can access these items by index with the Insert and RemoveAt methods. Other methods are described in the System.Windows.Forms.ToolStripItemCollection documentation on MSDN.

Example
This code removes the print button and replaces it with one that calls a custom print dialog.
  • C#
private void Form1_Load(object sender, EventArgs e)
      {
          //Remove the print button.
          viewer1.Toolbar.MainBar.Items.RemoveAt(2);
          //Remove the extra separator.
          viewer1.Toolbar.MainBar.Items.RemoveAt(1);
          //Add a new button to the end of the main bar with the caption "Print."
          ToolStripButton tsbPrint = new ToolStripButton("Print");
          viewer1.Toolbar.MainBar.Items.Add(tsbPrint);
          //Create a click event handler for the button.
          tsbPrint.Click += new EventHandler(tsbPrint_Click);

          SectionReport1 rpt = new SectionReport1();
          viewer1.LoadDocument(rpt);

      }

      //Call the custom dialog from the new button's click event.
      void tsbPrint_Click(object sender, EventArgs e)
      {
          this.CustomPrint();
      }

//Call the custom print dialog.
      private void CustomPrint()
      {
          frmPrintDlg _printForm = new frmPrintDlg();
          _printForm.ShowDialog(this);
      }
  • VB.NET
Private Sub Form1_Load(sender As System.Object, e As System.EventArgs) Handles MyBase.Load
    Dim rpt As New SectionReport1
    Viewer1.LoadDocument(rpt)

    'Remove the print button.
    Viewer1.Toolbar.MainBar.Items.RemoveAt(2)
    'Remove the extra separator.
    Viewer1.Toolbar.MainBar.Items.RemoveAt(1)
    'Add a new button to the end of the main bar with the caption "Print."
    Dim tsbPrint As New ToolStripButton("Print")
    Viewer1.Toolbar.MainBar.Items.Add(tsbPrint)
    'Create a click event handler for the button.
    AddHandler tsbPrint.Click, AddressOf tsbPrint_Click
End Sub

'Call the custom dialog from the new button's click event.
Private Sub tsbPrint_Click(sender As Object, e As EventArgs)
    Me.CustomPrint()
End Sub

'Call the custom print dialog.
Private Sub CustomPrint()
    Dim _printForm As New frmPrintDlg()
    _printForm.ShowDialog(Me)
End Sub
See Also

Reference

Viewer.ViewerToolbar Class
Viewer.ViewerToolbar Members


MouseModeBar Property

MouseModeBar Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer.ViewerToolbar Class : MouseModeBar Property
The mouse mode tool strip in the Windows Forms Viewer control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MouseModeBar As System.Windows.Forms.ToolStrip
public System.Windows.Forms.ToolStrip MouseModeBar {get;}
Remarks

Items on this toolstrip and their index numbers:

  • 0 Default
  • 1 Pan mode
  • 2 Selection mode

You can access these items by index with the Insert and RemoveAt methods. Other methods are described in the System.Windows.Forms.ToolStripItemCollection documentation on MSDN.

See Also

Reference

Viewer.ViewerToolbar Class
Viewer.ViewerToolbar Members


NavigationBar Property

NavigationBar Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer.ViewerToolbar Class : NavigationBar Property
The navigation tool strip in the Windows Forms Viewer control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property NavigationBar As System.Windows.Forms.ToolStrip
public System.Windows.Forms.ToolStrip NavigationBar {get;}
Remarks

Items on this toolstrip and their index numbers:

  • 0 First page
  • 1 Previous page
  • 2 Current page
  • 3 Next page
  • 4 Last page
  • 5 Separator
  • 6 Backward
  • 7 Forward
  • 8 Separator
  • 9 Back to parent report

You can access these items by index with the Insert and RemoveAt methods. Other methods are described in the System.Windows.Forms.ToolStripItemCollection documentation on MSDN.

See Also

Reference

Viewer.ViewerToolbar Class
Viewer.ViewerToolbar Members


ToolStrip Property

ToolStrip Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer.ViewerToolbar Class : ToolStrip Property
Reference to the ToolStrip.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ToolStrip As System.Windows.Forms.ToolStrip
public System.Windows.Forms.ToolStrip ToolStrip {get;}
Remarks
It is only for mouse mode toolbar.
See Also

Reference

Viewer.ViewerToolbar Class
Viewer.ViewerToolbar Members


ZoomChangedEventArgs Class

ZoomChangedEventArgs Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ZoomChangedEventArgs Class
Provides data for the ZoomChanged event.
Object Model
ZoomChangedEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ZoomChangedEventArgs
   Inherits System.EventArgs
public sealed class ZoomChangedEventArgs : System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.ActiveReports.Viewer.Win.ZoomChangedEventArgs

See Also

Reference

ZoomChangedEventArgs Members
GrapeCity.ActiveReports.Viewer.Win Namespace


ZoomChangedEventArgs Class Members

ZoomChangedEventArgs Class Members
Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ZoomChangedEventArgs Class

The following tables list the members exposed by ZoomChangedEventArgs.

Public Constructors
 | Name | Description
Public Constructor | ZoomChangedEventArgs Constructor | Overloaded. Initializes a new instance of ZoomChangedEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Zoom | Returns the viewer's new Zoom value.
Top
See Also

Reference

ZoomChangedEventArgs Class
GrapeCity.ActiveReports.Viewer.Win Namespace


ZoomChangedEventArgs Constructor

ZoomChangedEventArgs Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ZoomChangedEventArgs Class : ZoomChangedEventArgs Constructor
Initializes a new instance of ZoomChangedEventArgs class.
Overload List
Overload | Description
ZoomChangedEventArgs Constructor(Double) | Initializes an instance of the ZoomChangedEventArgs class and sets the Zoom property value.
ZoomChangedEventArgs Constructor() | Initializes a new instance of the ZoomChangedEventArgs class.
See Also

Reference

ZoomChangedEventArgs Class
ZoomChangedEventArgs Members


ZoomChangedEventArgs Constructor(Double)

ZoomChangedEventArgs Constructor(Double)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ZoomChangedEventArgs Class > ZoomChangedEventArgs Constructor : ZoomChangedEventArgs Constructor(Double)
Specifies the new zoom value.
Initializes an instance of the ZoomChangedEventArgs class and sets the Zoom property value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal zoom As System.Double _
)
public ZoomChangedEventArgs(
   System.double zoom
)

Parameters

zoom
Specifies the new zoom value.
See Also

Reference

ZoomChangedEventArgs Class
ZoomChangedEventArgs Members
Overload List


ZoomChangedEventArgs Constructor()

ZoomChangedEventArgs Constructor()

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ZoomChangedEventArgs Class > ZoomChangedEventArgs Constructor : ZoomChangedEventArgs Constructor()
Initializes a new instance of the ZoomChangedEventArgs class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ZoomChangedEventArgs()
See Also

Reference

ZoomChangedEventArgs Class
ZoomChangedEventArgs Members
Overload List


ZoomChangedEventArgs Class Properties

ZoomChangedEventArgs Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ZoomChangedEventArgs Class

For a list of all members of this type, see ZoomChangedEventArgs members.

Public Properties
 | Name | Description
Public Property | Zoom | Returns the viewer's new Zoom value.
Top
See Also

Reference

ZoomChangedEventArgs Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Zoom Property (ZoomChangedEventArgs)

Zoom Property (ZoomChangedEventArgs)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ZoomChangedEventArgs Class : Zoom Property
Returns the viewer's new Zoom value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Zoom As System.Double
public System.double Zoom {get;}
See Also

Reference

ZoomChangedEventArgs Class
ZoomChangedEventArgs Members


TargetView Enumeration

TargetView Enumeration

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : TargetView Enumeration
Determines the current active view in the viewer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TargetView
   Inherits System.Enum
public enum TargetView : System.Enum
Members
Member | Description
Primary | The primary (Bottom) view is the active view.
Secondary | The secondary (Upper) view is the active view.
Remarks
The viewer can be split into two views using the splitter. This enumeration determines which view will be effected by methods and property calls.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Viewer.Win.TargetView

See Also

Reference

GrapeCity.ActiveReports.Viewer.Win Namespace


FindEventHandler Delegate

FindEventHandler Delegate

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : FindEventHandler Delegate
The source of the event.
A FindEventArgs that contains the event data.
Represents the method that will handle the Find click event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub FindEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As FindEventArgs _
)
public delegate void FindEventHandler(
   System.object sender,
   FindEventArgs e
)

Parameters

sender
The source of the event.
e
A FindEventArgs that contains the event data.
See Also

Reference

FindEventHandler Members
GrapeCity.ActiveReports.Viewer.Win Namespace


HyperLinkEventHandler Delegate

HyperLinkEventHandler Delegate

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : HyperLinkEventHandler Delegate
The source of the event.
A HyperLinkEventArgs that contains the event data.
Represents the method that will handle the HyperLink click event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub HyperLinkEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As HyperLinkEventArgs _
)
public delegate void HyperLinkEventHandler(
   System.object sender,
   HyperLinkEventArgs e
)

Parameters

sender
The source of the event.
e
A HyperLinkEventArgs that contains the event data.
See Also

Reference

HyperLinkEventHandler Members
GrapeCity.ActiveReports.Viewer.Win Namespace


ZoomChangedEventHandler Delegate

ZoomChangedEventHandler Delegate

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ZoomChangedEventHandler Delegate
The source of the event.
A ZoomChangedEventArgs that contains the event data.
Represents the method that will handle the zoom click event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub ZoomChangedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As ZoomChangedEventArgs _
)
public delegate void ZoomChangedEventHandler(
   System.object sender,
   ZoomChangedEventArgs e
)

Parameters

sender
The source of the event.
e
A ZoomChangedEventArgs that contains the event data.
See Also

Reference

ZoomChangedEventHandler Members
GrapeCity.ActiveReports.Viewer.Win Namespace


GrapeCity.Viewer.Common Namespace (GrapeCity.ActiveReports.Viewer.Win.v10)

GrapeCity.Viewer.Common Namespace (GrapeCity.ActiveReports.Viewer.Win.v10)
Inheritance Hierarchy
GrapeCity.ActiveReports.Viewer.Win.v10 Assembly : GrapeCity.Viewer.Common Namespace
Classes
 | Class | Description
Class | CachedPageView | Base class for page views with caching
Class | DelegateCommand | Parameterless command delegate
Class | DelegateCommand<TParm> | DelegateCommand implementation
Class | DisposablesCollection | Utility class to redirect Dispose call to its inner items
Class | DocumentRendererAttribute | Allows to specified document renderer type for class.
Class | DocumentSearchService | Search service implementation for ISearchableDocument
Class | DoubleDelegateCommand | Command that delegates implementation to another delegate command
Class | EnumerableExtensions |
Class | NotifyCollectionChangedEventArgs | Describes the action that caused a System.Collections.Specialized.INotifyCollectionChanged.CollectionChanged event.
Class | NullDelegateCommand |
Class | NullRenderer | Null-object implementation for IDocumentRenderer interface
Class | NullRenderer.Factory | IDocumentRenderer factory.
Class | ObservableCollection<T> | Wrapped System.Collections.ObjectModel observable collection
Class | PageView | Base abstract class for concrete page renderers.
Class | RectExtensions | Extends Rect struct with helper methods.
Class | StreamDocumentLoader |
Interfaces
 | Interface | Description
Interface | IApplicationContext | Provides access to different services and factories
Interface | ICommand | Defines the contract for commanding, using the same contract as used in WPF.
Interface | ICopySelectionService | Base interface for copy operations
Interface | IDelegateCommand | Delegated command interface
Interface | IDocumentLoader |
Interface | IDocumentRenderer | Base interface for Document renderers
Interface | IDocumentRendererFactory | IDocumentRenderer factory interface.
Interface | IHistoryApi | This is public interface for user to work with HistoryService
Interface | ILoadableFromFileAndStream |
Interface | INotifyCollectionChanged | Notifies listeners of dynamic changes to a collection, such as when items are added and removed, or the entire collection object is reset.
Interface | IOrientedPageView | Interface to access orientation of the report page.
Interface | IParameter | Defines an object that can be used as a report parameter.
Interface | IPrintService |
Interface | ISearchService | Base interface for search
Interface | IServiceContainer | Provides a container for services.
Structures
 | Structure | Description
Structure | Color | Platform independent color implementation
Structure | Margin | Stores page margins
Structure | Point | Platform independent point
Structure | Rect | Platform aware rectangle structure
Structure | Size | Platform aware Size structure
Delegates
 | Delegate | Description
Delegate | NotifyCollectionChangedEventHandler | Represents the method that handles events that implement the System.Collections.Specialized.INotifyCollectionChanged.CollectionChanged event.
Enumerations
 | Enumeration | Description
Enumeration | DeviceKind | Defines enumeration of possible target devices for view.
Enumeration | DocumentFormat | Specifies possible document formats
Enumeration | LoadState | Possible loading states
Enumeration | NotifyCollectionChangedAction | Enum NotifyCollectionChangedAction
Enumeration | PrintingSettings | Print process settings
See Also

Reference

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly


CachedPageView Class

CachedPageView Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : CachedPageView Class
Base class for page views with caching
Object Model
CachedPageView Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class CachedPageView
   Inherits PageView
public abstract class CachedPageView : PageView
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.CachedPageView

See Also

Reference

CachedPageView Members
GrapeCity.Viewer.Common Namespace


CachedPageView Class Members

CachedPageView Class Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : CachedPageView Class

The following tables list the members exposed by CachedPageView.

Public Properties
 | Name | Description
Public Property | Device | Gets the device kind. (Inherited from GrapeCity.Viewer.Common.PageView)
Public Property | Size | Gets the page view size. (Inherited from GrapeCity.Viewer.Common.PageView)
Top
Public Methods
 | Name | Description
Public Method | AsCachable | Convert to CachedPageView. (Inherited from GrapeCity.Viewer.Common.PageView)
Public Method | Dispose |
Top
See Also

Reference

CachedPageView Class
GrapeCity.Viewer.Common Namespace


CachedPageView Class Methods

CachedPageView Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : CachedPageView Class

For a list of all members of this type, see CachedPageView members.

Public Methods
 | Name | Description
Public Method | AsCachable | Convert to CachedPageView. (Inherited from GrapeCity.Viewer.Common.PageView)
Public Method | Dispose |
Top
See Also

Reference

CachedPageView Class
GrapeCity.Viewer.Common Namespace


Dispose Method (CachedPageView)

Dispose Method (CachedPageView)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > CachedPageView Class : Dispose Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Sub Dispose()
public abstract void Dispose()
See Also

Reference

CachedPageView Class
CachedPageView Members


DelegateCommand Class

DelegateCommand Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand Class
Parameterless command delegate
Object Model
DelegateCommand Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DelegateCommand
   Inherits GrapeCity.Viewer.Common.DelegateCommand(Of Object)
   Implements ICommand, IDelegateCommand
public sealed class DelegateCommand : GrapeCity.Viewer.Common.DelegateCommand<object>, ICommand, IDelegateCommand
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.DelegateCommand

See Also

Reference

DelegateCommand Members
GrapeCity.Viewer.Common Namespace


DelegateCommand Class Members

DelegateCommand Class Members
Fields Methods Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand Class

The following tables list the members exposed by DelegateCommand.

Public Constructors
 | Name | Description
Public Constructor | DelegateCommand Constructor | Overloaded.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | NullCommand | Gets "Null" command instance which does nothing and is always disabled
Top
Public Methods
 | Name | Description
Public Method | CanExecute | Defines the method that determines whether the command can execute in its current state. (Inherited from GrapeCity.Viewer.Common.DelegateCommand<object>)
Public Method | Execute | Defines the method to be called when the command is invoked. (Inherited from GrapeCity.Viewer.Common.DelegateCommand<object>)
Public Method | RaiseCanExecuteChanged | Raise CanExecuteChanged event from external code. (Inherited from GrapeCity.Viewer.Common.DelegateCommand<object>)
Top
Public Events
 | Name | Description
Public Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute. (Inherited from GrapeCity.Viewer.Common.DelegateCommand<object>)
Top
See Also

Reference

DelegateCommand Class
GrapeCity.Viewer.Common Namespace


DelegateCommand Constructor

DelegateCommand Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand Class : DelegateCommand Constructor
Overload List
Overload | Description
DelegateCommand Constructor(Action,Func<Boolean>) |
DelegateCommand Constructor(Action) |
See Also

Reference

DelegateCommand Class
DelegateCommand Members


DelegateCommand Constructor(Action,Func<Boolean>)

DelegateCommand Constructor(Action,Func<Boolean>)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand Class > DelegateCommand Constructor : DelegateCommand Constructor(Action,Func<Boolean>)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal executeAction As System.Action, _
   ByVal canExecute As System.Func(Of Boolean) _
)
public DelegateCommand(
   System.Action executeAction,
   System.Func<bool> canExecute
)

Parameters

executeAction
canExecute
See Also

Reference

DelegateCommand Class
DelegateCommand Members
Overload List


DelegateCommand Constructor(Action)

DelegateCommand Constructor(Action)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand Class > DelegateCommand Constructor : DelegateCommand Constructor(Action)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal executeAction As System.Action _
)
public DelegateCommand(
   System.Action executeAction
)

Parameters

executeAction
See Also

Reference

DelegateCommand Class
DelegateCommand Members
Overload List


DelegateCommand Class Fields

DelegateCommand Class Fields

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand Class

For a list of all members of this type, see DelegateCommand members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | NullCommand | Gets "Null" command instance which does nothing and is always disabled
Top
See Also

Reference

DelegateCommand Class
GrapeCity.Viewer.Common Namespace


NullCommand Field (DelegateCommand)

NullCommand Field (DelegateCommand)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand Class : NullCommand Field
Gets "Null" command instance which does nothing and is always disabled
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly NullCommand As IDelegateCommand
public static readonly IDelegateCommand NullCommand
See Also

Reference

DelegateCommand Class
DelegateCommand Members


DelegateCommand<TParm> Class

DelegateCommand<TParm> Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand<TParm> Class
DelegateCommand implementation
Object Model
DelegateCommand<TParm> Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DelegateCommand(Of TParm)
   Implements ICommand, IDelegateCommand
public class DelegateCommand<TParm> : ICommand, IDelegateCommand
Type Parameters
TParm
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.DelegateCommand<TParm>

See Also

Reference

DelegateCommand<TParm> Members
GrapeCity.Viewer.Common Namespace


DelegateCommand<TParm> Class Members

DelegateCommand<TParm> Class Members
Methods Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand<TParm> Class

The following tables list the members exposed by DelegateCommand<TParm>.

Public Constructors
 | Name | Description
Public Constructor | DelegateCommand<TParm> Constructor | Overloaded.
Top
Public Methods
 | Name | Description
Public Method | CanExecute | Defines the method that determines whether the command can execute in its current state.
Public Method | Execute | Defines the method to be called when the command is invoked.
Public Method | RaiseCanExecuteChanged | Raise CanExecuteChanged event from external code.
Top
Public Events
 | Name | Description
Public Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute.
Top
See Also

Reference

DelegateCommand<TParm> Class
GrapeCity.Viewer.Common Namespace


DelegateCommand<TParm> Constructor

DelegateCommand<TParm> Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand<TParm> Class : DelegateCommand<TParm> Constructor
Overload List
Overload | Description
DelegateCommand<TParm> Constructor(Action<TParm>,Predicate<TParm>) | Initializes a new instance of the DelegateCommand<TParm> class.
DelegateCommand<TParm> Constructor(Action<TParm>) | Initializes a new instance of the DelegateCommand<TParm> class.
See Also

Reference

DelegateCommand<TParm> Class
DelegateCommand<TParm> Members


DelegateCommand<TParm> Constructor(Action<TParm>,Predicate<TParm>)

DelegateCommand<TParm> Constructor(Action<TParm>,Predicate<TParm>)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand<TParm> Class > DelegateCommand<TParm> Constructor : DelegateCommand<TParm> Constructor(Action<TParm>,Predicate<TParm>)
Initializes a new instance of the DelegateCommand<TParm> class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal executeAction As System.Action(Of TParm), _
   ByVal canExecute As System.Predicate(Of TParm) _
)
public DelegateCommand<TParm>(
   System.Action<TParm> executeAction,
   System.Predicate<TParm> canExecute
)

Parameters

executeAction
canExecute
See Also

Reference

DelegateCommand<TParm> Class
DelegateCommand<TParm> Members
Overload List


DelegateCommand<TParm> Constructor(Action<TParm>)

DelegateCommand<TParm> Constructor(Action<TParm>)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand<TParm> Class > DelegateCommand<TParm> Constructor : DelegateCommand<TParm> Constructor(Action<TParm>)
Initializes a new instance of the DelegateCommand<TParm> class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal executeAction As System.Action(Of TParm) _
)
public DelegateCommand<TParm>(
   System.Action<TParm> executeAction
)

Parameters

executeAction
See Also

Reference

DelegateCommand<TParm> Class
DelegateCommand<TParm> Members
Overload List


DelegateCommand<TParm> Class Methods

DelegateCommand<TParm> Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand<TParm> Class

For a list of all members of this type, see DelegateCommand<TParm> members.

Public Methods
 | Name | Description
Public Method | CanExecute | Defines the method that determines whether the command can execute in its current state.
Public Method | Execute | Defines the method to be called when the command is invoked.
Public Method | RaiseCanExecuteChanged | Raise CanExecuteChanged event from external code.
Top
See Also

Reference

DelegateCommand<TParm> Class
GrapeCity.Viewer.Common Namespace


CanExecute Method (DelegateCommand<TParm>)

CanExecute Method (DelegateCommand<TParm>)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand<TParm> Class : CanExecute Method
Data used by the command. If the command does not require data to be passed, this object can be set to null.
Defines the method that determines whether the command can execute in its current state.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CanExecute( _
   ByVal parameter As System.Object _
) As System.Boolean
public System.bool CanExecute(
   System.object parameter
)

Parameters

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.

Return Value

true if this instance can execute the specified parameter; otherwise, false.
See Also

Reference

DelegateCommand<TParm> Class
DelegateCommand<TParm> Members


Execute Method (DelegateCommand<TParm>)

Execute Method (DelegateCommand<TParm>)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand<TParm> Class : Execute Method
Data used by the command. If the command does not require data to be passed, this object can be set to null.
Defines the method to be called when the command is invoked.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Execute( _
   ByVal parameter As System.Object _
)
public void Execute(
   System.object parameter
)

Parameters

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.
See Also

Reference

DelegateCommand<TParm> Class
DelegateCommand<TParm> Members


RaiseCanExecuteChanged Method (DelegateCommand<TParm>)

RaiseCanExecuteChanged Method (DelegateCommand<TParm>)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand<TParm> Class : RaiseCanExecuteChanged Method
Raise CanExecuteChanged event from external code.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RaiseCanExecuteChanged()
public void RaiseCanExecuteChanged()
See Also

Reference

DelegateCommand<TParm> Class
DelegateCommand<TParm> Members


DelegateCommand<TParm> Class Events

DelegateCommand<TParm> Class Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand<TParm> Class

For a list of all members of this type, see DelegateCommand<TParm> members.

Public Events
 | Name | Description
Public Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute.
Top
See Also

Reference

DelegateCommand<TParm> Class
GrapeCity.Viewer.Common Namespace


CanExecuteChanged Event (DelegateCommand<TParm>)

CanExecuteChanged Event (DelegateCommand<TParm>)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand<TParm> Class : CanExecuteChanged Event
Occurs when changes occur that affect whether the command should execute.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event CanExecuteChanged As System.EventHandler
public event System.EventHandler CanExecuteChanged
See Also

Reference

DelegateCommand<TParm> Class
DelegateCommand<TParm> Members


DisposablesCollection Class

DisposablesCollection Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DisposablesCollection Class
Utility class to redirect Dispose call to its inner items
Object Model
DisposablesCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DisposablesCollection
public sealed class DisposablesCollection
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.DisposablesCollection

See Also

Reference

DisposablesCollection Members
GrapeCity.Viewer.Common Namespace


DisposablesCollection Class Members

DisposablesCollection Class Members
Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DisposablesCollection Class

The following tables list the members exposed by DisposablesCollection.

Public Constructors
 | Name | Description
Public Constructor | DisposablesCollection Constructor |
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Registers object to be disposed on this collection disposal
Public Method | Dispose |
static (Shared in Visual Basic) | From | Overloaded. Initialized new collection for another list of disposables
Top
See Also

Reference

DisposablesCollection Class
GrapeCity.Viewer.Common Namespace


DisposablesCollection Constructor

DisposablesCollection Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class : DisposablesCollection Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DisposablesCollection()
See Also

Reference

DisposablesCollection Class
DisposablesCollection Members


DisposablesCollection Class Methods

DisposablesCollection Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DisposablesCollection Class

For a list of all members of this type, see DisposablesCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Registers object to be disposed on this collection disposal
Public Method | Dispose |
static (Shared in Visual Basic) | From | Overloaded. Initialized new collection for another list of disposables
Top
See Also

Reference

DisposablesCollection Class
GrapeCity.Viewer.Common Namespace


Add Method (DisposablesCollection)

Add Method (DisposablesCollection)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class : Add Method
Registers object to be disposed on this collection disposal
Overload List
Overload | Description
Add(IDisposable[]) | Registers object to be disposed on this collection disposal
Add(IDisposable) | Registers action to be invoked on object dispose
Add(Action[]) | Registers action to be invoked on object dispose
See Also

Reference

DisposablesCollection Class
DisposablesCollection Members


Add(IDisposable[]) Method

Add(IDisposable[]) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class > Add Method : Add(IDisposable[]) Method
Registers object to be disposed on this collection disposal
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal ParamArray disposables() As System.IDisposable _
)
public void Add(
   params System.IDisposable[] disposables
)

Parameters

disposables
See Also

Reference

DisposablesCollection Class
DisposablesCollection Members
Overload List


Add(IDisposable) Method

Add(IDisposable) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class > Add Method : Add(IDisposable) Method
Registers action to be invoked on object dispose
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal disposable As System.IDisposable _
)
public void Add(
   System.IDisposable disposable
)

Parameters

disposable
See Also

Reference

DisposablesCollection Class
DisposablesCollection Members
Overload List


Add(Action[]) Method

Add(Action[]) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class > Add Method : Add(Action[]) Method
Registers action to be invoked on object dispose
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal ParamArray disposables() As System.Action _
)
public void Add(
   params System.Action[] disposables
)

Parameters

disposables
See Also

Reference

DisposablesCollection Class
DisposablesCollection Members
Overload List


Dispose Method (DisposablesCollection)

Dispose Method (DisposablesCollection)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class : Dispose Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

DisposablesCollection Class
DisposablesCollection Members


From Method (DisposablesCollection)

From Method (DisposablesCollection)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class : From Method
Initialized new collection for another list of disposables
Overload List
Overload | Description
From(IDisposable[]) | Initialized new collection for another list of disposables
From(Action[]) | Initialized new collection for another list of actions
See Also

Reference

DisposablesCollection Class
DisposablesCollection Members


From(IDisposable[]) Method

From(IDisposable[]) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class > From Method : From(IDisposable[]) Method
Initialized new collection for another list of disposables
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function From( _
   ByVal ParamArray disposables() As System.IDisposable _
) As DisposablesCollection
public static DisposablesCollection From(
   params System.IDisposable[] disposables
)

Parameters

disposables
See Also

Reference

DisposablesCollection Class
DisposablesCollection Members
Overload List


From(Action[]) Method

From(Action[]) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class > From Method : From(Action[]) Method
Initialized new collection for another list of actions
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function From( _
   ByVal ParamArray actions() As System.Action _
) As DisposablesCollection
public static DisposablesCollection From(
   params System.Action[] actions
)

Parameters

actions
See Also

Reference

DisposablesCollection Class
DisposablesCollection Members
Overload List


DocumentRendererAttribute Class

DocumentRendererAttribute Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DocumentRendererAttribute Class
Allows to specified document renderer type for class.
Object Model
DocumentRendererAttribute Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DocumentRendererAttribute
   Inherits System.Attribute
public class DocumentRendererAttribute : System.Attribute
Inheritance Hierarchy

System.Object
System.Attribute
GrapeCity.Viewer.Common.DocumentRendererAttribute

See Also

Reference

DocumentRendererAttribute Members
GrapeCity.Viewer.Common Namespace


DocumentRendererAttribute Class Members

DocumentRendererAttribute Class Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DocumentRendererAttribute Class

The following tables list the members exposed by DocumentRendererAttribute.

Public Constructors
 | Name | Description
Public Constructor | DocumentRendererAttribute Constructor | Initializes a new instance of the DocumentRendererAttribute class.
Top
Public Properties
 | Name | Description
Public Property | RendererType | Gets the type of the renderer.
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

DocumentRendererAttribute Class
GrapeCity.Viewer.Common Namespace


DocumentRendererAttribute Constructor

DocumentRendererAttribute Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DocumentRendererAttribute Class : DocumentRendererAttribute Constructor
Type of the renderer.
Initializes a new instance of the DocumentRendererAttribute class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal rendererType As System.Type _
)
public DocumentRendererAttribute(
   System.Type rendererType
)

Parameters

rendererType
Type of the renderer.
See Also

Reference

DocumentRendererAttribute Class
DocumentRendererAttribute Members


DocumentRendererAttribute Class Properties

DocumentRendererAttribute Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DocumentRendererAttribute Class

For a list of all members of this type, see DocumentRendererAttribute members.

Public Properties
 | Name | Description
Public Property | RendererType | Gets the type of the renderer.
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

DocumentRendererAttribute Class
GrapeCity.Viewer.Common Namespace


RendererType Property (DocumentRendererAttribute)

RendererType Property (DocumentRendererAttribute)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DocumentRendererAttribute Class : RendererType Property
Gets the type of the renderer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property RendererType As System.Type
public System.Type RendererType {get;}
See Also

Reference

DocumentRendererAttribute Class
DocumentRendererAttribute Members


DocumentSearchService Class

DocumentSearchService Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DocumentSearchService Class
Search service implementation for ISearchableDocument
Object Model
DocumentSearchService Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DocumentSearchService
   Implements ISearchService
public sealed class DocumentSearchService : ISearchService
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.DocumentSearchService

See Also

Reference

DocumentSearchService Members
GrapeCity.Viewer.Common Namespace


DocumentSearchService Class Members

DocumentSearchService Class Members
Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DocumentSearchService Class

The following tables list the members exposed by DocumentSearchService.

Public Constructors
 | Name | Description
Public Constructor | DocumentSearchService Constructor |
Top
Public Methods
 | Name | Description
Public Method | Find | Searches the document according to find options.
Top
See Also

Reference

DocumentSearchService Class
GrapeCity.Viewer.Common Namespace


DocumentSearchService Constructor

DocumentSearchService Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DocumentSearchService Class : DocumentSearchService Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DocumentSearchService()
See Also

Reference

DocumentSearchService Class
DocumentSearchService Members


DocumentSearchService Class Methods

DocumentSearchService Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DocumentSearchService Class

For a list of all members of this type, see DocumentSearchService members.

Public Methods
 | Name | Description
Public Method | Find | Searches the document according to find options.
Top
See Also

Reference

DocumentSearchService Class
GrapeCity.Viewer.Common Namespace


Find Method (DocumentSearchService)

Find Method (DocumentSearchService)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DocumentSearchService Class : Find Method
Searches the document according to find options.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Find( _
   ByVal document As DocumentModel, _
   ByVal findOptions As FindOptions, _
   ByVal startFrom As SearchResult, _
   ByVal maxCount As System.Integer, _
   ByVal handler As System.Action(Of DocumentModel,IEnumerable(Of SearchResult)) _
)
public void Find(
   DocumentModel document,
   FindOptions findOptions,
   SearchResult startFrom,
   System.int maxCount,
   System.Action<DocumentModel,IEnumerable<SearchResult>> handler
)

Parameters

document
findOptions
startFrom
maxCount
handler
See Also

Reference

DocumentSearchService Class
DocumentSearchService Members


DoubleDelegateCommand Class

DoubleDelegateCommand Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DoubleDelegateCommand Class
Command that delegates implementation to another delegate command
Object Model
DoubleDelegateCommand Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DoubleDelegateCommand
   Implements ICommand, IDelegateCommand
public sealed class DoubleDelegateCommand : ICommand, IDelegateCommand
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.DoubleDelegateCommand

See Also

Reference

DoubleDelegateCommand Members
GrapeCity.Viewer.Common Namespace


DoubleDelegateCommand Class Members

DoubleDelegateCommand Class Members
Properties Methods Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DoubleDelegateCommand Class

The following tables list the members exposed by DoubleDelegateCommand.

Public Constructors
 | Name | Description
Public Constructor | DoubleDelegateCommand Constructor |
Top
Public Properties
 | Name | Description
Public Property | Command | Gets or sets the command.
Top
Public Methods
 | Name | Description
Public Method | CanExecute | Defines the method that determines whether the command can execute in its current state.
Public Method | Dispose |
Public Method | Execute | Defines the method to be called when the command is invoked.
Public Method | RaiseCanExecuteChanged | Raises CanExecuteChanged event.
Top
Public Events
 | Name | Description
Public Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute.
Top
See Also

Reference

DoubleDelegateCommand Class
GrapeCity.Viewer.Common Namespace


DoubleDelegateCommand Constructor

DoubleDelegateCommand Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DoubleDelegateCommand Class : DoubleDelegateCommand Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DoubleDelegateCommand()
See Also

Reference

DoubleDelegateCommand Class
DoubleDelegateCommand Members


DoubleDelegateCommand Class Methods

DoubleDelegateCommand Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DoubleDelegateCommand Class

For a list of all members of this type, see DoubleDelegateCommand members.

Public Methods
 | Name | Description
Public Method | CanExecute | Defines the method that determines whether the command can execute in its current state.
Public Method | Dispose |
Public Method | Execute | Defines the method to be called when the command is invoked.
Public Method | RaiseCanExecuteChanged | Raises CanExecuteChanged event.
Top
See Also

Reference

DoubleDelegateCommand Class
GrapeCity.Viewer.Common Namespace


CanExecute Method (DoubleDelegateCommand)

CanExecute Method (DoubleDelegateCommand)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DoubleDelegateCommand Class : CanExecute Method
Data used by the command. If the command does not require data to be passed, this object can be set to null.
Defines the method that determines whether the command can execute in its current state.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CanExecute( _
   ByVal parameter As System.Object _
) As System.Boolean
public System.bool CanExecute(
   System.object parameter
)

Parameters

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.

Return Value

true if this instance can execute the specified parameter; otherwise, false.
See Also

Reference

DoubleDelegateCommand Class
DoubleDelegateCommand Members


Dispose Method (DoubleDelegateCommand)

Dispose Method (DoubleDelegateCommand)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DoubleDelegateCommand Class : Dispose Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

DoubleDelegateCommand Class
DoubleDelegateCommand Members


Execute Method (DoubleDelegateCommand)

Execute Method (DoubleDelegateCommand)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DoubleDelegateCommand Class : Execute Method
Data used by the command. If the command does not require data to be passed, this object can be set to null.
Defines the method to be called when the command is invoked.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Execute( _
   ByVal parameter As System.Object _
)
public void Execute(
   System.object parameter
)

Parameters

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.
See Also

Reference

DoubleDelegateCommand Class
DoubleDelegateCommand Members


RaiseCanExecuteChanged Method (DoubleDelegateCommand)

RaiseCanExecuteChanged Method (DoubleDelegateCommand)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DoubleDelegateCommand Class : RaiseCanExecuteChanged Method
Raises CanExecuteChanged event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RaiseCanExecuteChanged()
public void RaiseCanExecuteChanged()
See Also

Reference

DoubleDelegateCommand Class
DoubleDelegateCommand Members


DoubleDelegateCommand Class Properties

DoubleDelegateCommand Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DoubleDelegateCommand Class

For a list of all members of this type, see DoubleDelegateCommand members.

Public Properties
 | Name | Description
Public Property | Command | Gets or sets the command.
Top
See Also

Reference

DoubleDelegateCommand Class
GrapeCity.Viewer.Common Namespace


Command Property (DoubleDelegateCommand)

Command Property (DoubleDelegateCommand)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DoubleDelegateCommand Class : Command Property
Gets or sets the command.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Command As IDelegateCommand
public IDelegateCommand Command {get; set;}
See Also

Reference

DoubleDelegateCommand Class
DoubleDelegateCommand Members


DoubleDelegateCommand Class Events

DoubleDelegateCommand Class Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DoubleDelegateCommand Class

For a list of all members of this type, see DoubleDelegateCommand members.

Public Events
 | Name | Description
Public Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute.
Top
See Also

Reference

DoubleDelegateCommand Class
GrapeCity.Viewer.Common Namespace


CanExecuteChanged Event (DoubleDelegateCommand)

CanExecuteChanged Event (DoubleDelegateCommand)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DoubleDelegateCommand Class : CanExecuteChanged Event
Occurs when changes occur that affect whether the command should execute.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event CanExecuteChanged As System.EventHandler
public event System.EventHandler CanExecuteChanged
See Also

Reference

DoubleDelegateCommand Class
DoubleDelegateCommand Members


EnumerableExtensions Class

EnumerableExtensions Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : EnumerableExtensions Class
Object Model
EnumerableExtensions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit NotInheritable Class EnumerableExtensions
public static class EnumerableExtensions
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.EnumerableExtensions

See Also

Reference

EnumerableExtensions Members
GrapeCity.Viewer.Common Namespace


EnumerableExtensions Class Members

EnumerableExtensions Class Members
Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : EnumerableExtensions Class

The following tables list the members exposed by EnumerableExtensions.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | ForEach<T> | Executes action for each sequence item
static (Shared in Visual Basic) | GetRecursive<T> | Extract all descendants recursively
static (Shared in Visual Basic) | ZipEx<TSource1,TSource2,TResult> | Gets the result of combination of two sequences. Result sequence is as short as shortest source sequences
Top
See Also

Reference

EnumerableExtensions Class
GrapeCity.Viewer.Common Namespace


EnumerableExtensions Class Methods

EnumerableExtensions Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : EnumerableExtensions Class

For a list of all members of this type, see EnumerableExtensions members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | ForEach<T> | Executes action for each sequence item
static (Shared in Visual Basic) | GetRecursive<T> | Extract all descendants recursively
static (Shared in Visual Basic) | ZipEx<TSource1,TSource2,TResult> | Gets the result of combination of two sequences. Result sequence is as short as shortest source sequences
Top
See Also

Reference

EnumerableExtensions Class
GrapeCity.Viewer.Common Namespace


ForEach<T> Method (EnumerableExtensions)

ForEach<T> Method (EnumerableExtensions)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > EnumerableExtensions Class : ForEach<T> Method
Executes action for each sequence item
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Sub ForEach(Of T)( _
   ByVal source As System.Collections.Generic.IEnumerable(Of T), _
   ByVal action As System.Action(Of T) _
)
public static void ForEach<T>(
   System.Collections.Generic.IEnumerable<T> source,
   System.Action<T> action
)

Parameters

source
action

Type Parameters

T
See Also

Reference

EnumerableExtensions Class
EnumerableExtensions Members


GetRecursive<T> Method (EnumerableExtensions)

GetRecursive<T> Method (EnumerableExtensions)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > EnumerableExtensions Class : GetRecursive<T> Method
Extract all descendants recursively
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function GetRecursive(Of T)( _
   ByVal source As System.Collections.Generic.IEnumerable(Of T), _
   ByVal selector As System.Func(Of T,IEnumerable(Of T)) _
) As System.Collections.Generic.IEnumerable(Of T)
public static System.Collections.Generic.IEnumerable<T> GetRecursive<T>(
   System.Collections.Generic.IEnumerable<T> source,
   System.Func<T,IEnumerable<T>> selector
)

Parameters

source
selector

Type Parameters

T
See Also

Reference

EnumerableExtensions Class
EnumerableExtensions Members


ZipEx<TSource1,TSource2,TResult> Method (EnumerableExtensions)

ZipEx<TSource1,TSource2,TResult> Method (EnumerableExtensions)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > EnumerableExtensions Class : ZipEx<TSource1,TSource2,TResult> Method
Gets the result of combination of two sequences. Result sequence is as short as shortest source sequences
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function ZipEx
    (Of TSource1,TSource2,TResult)( _
   ByVal source1 As System.Collections.Generic.IEnumerable(Of TSource1), _
   ByVal source2 As System.Collections.Generic.IEnumerable(Of TSource2), _
   ByVal selector As System.Func(Of TSource1,TSource2,TResult) _
) As System.Collections.Generic.IEnumerable(Of TResult)
public static System.Collections.Generic.IEnumerable<TResult> ZipEx<TSource1,TSource2,TResult>(
   System.Collections.Generic.IEnumerable<TSource1> source1,
   System.Collections.Generic.IEnumerable<TSource2> source2,
   System.Func<TSource1,TSource2,TResult> selector
)

Parameters

source1
source2
selector

Type Parameters

TSource1
TSource2
TResult
See Also

Reference

EnumerableExtensions Class
EnumerableExtensions Members


NotifyCollectionChangedEventArgs Class

NotifyCollectionChangedEventArgs Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : NotifyCollectionChangedEventArgs Class
Describes the action that caused a System.Collections.Specialized.INotifyCollectionChanged.CollectionChanged event.
Object Model
NotifyCollectionChangedEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class NotifyCollectionChangedEventArgs
   Inherits System.EventArgs
public sealed class NotifyCollectionChangedEventArgs : System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.Viewer.Common.NotifyCollectionChangedEventArgs

See Also

Reference

NotifyCollectionChangedEventArgs Members
GrapeCity.Viewer.Common Namespace


NotifyCollectionChangedEventArgs Class Members

NotifyCollectionChangedEventArgs Class Members
Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : NotifyCollectionChangedEventArgs Class

The following tables list the members exposed by NotifyCollectionChangedEventArgs.

Public Constructors
 | Name | Description
Public Constructor | NotifyCollectionChangedEventArgs Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets the action type.
Public Property | NewItems | Gets the new items.
Public Property | NewStartingIndex | Gets the index of the starting of new items.
Public Property | OldItems | Gets the old items.
Public Property | OldStartingIndex | Gets the index of the starting of old items.
Top
See Also

Reference

NotifyCollectionChangedEventArgs Class
GrapeCity.Viewer.Common Namespace


NotifyCollectionChangedEventArgs Constructor

NotifyCollectionChangedEventArgs Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class : NotifyCollectionChangedEventArgs Constructor
Overload List
Overload | Description
NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction,Object,Object,Int32) | Initializes a new instance of the NotifyCollectionChangedEventArgs class.
NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction,Object,Int32) | Initializes a new instance of the NotifyCollectionChangedEventArgs class.
NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction) | Initializes a new instance of the NotifyCollectionChangedEventArgs class.
See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members


NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction,Object,Object,Int32)

NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction,Object,Object,Int32)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class > NotifyCollectionChangedEventArgs Constructor : NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction,Object,Object,Int32)
Initializes a new instance of the NotifyCollectionChangedEventArgs class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal action As NotifyCollectionChangedAction, _
   ByVal newItem As System.Object, _
   ByVal oldItem As System.Object, _
   ByVal index As System.Integer _
)
public NotifyCollectionChangedEventArgs(
   NotifyCollectionChangedAction action,
   System.object newItem,
   System.object oldItem,
   System.int index
)

Parameters

action
newItem
oldItem
index
See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members
Overload List


NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction,Object,Int32)

NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction,Object,Int32)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class > NotifyCollectionChangedEventArgs Constructor : NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction,Object,Int32)
Initializes a new instance of the NotifyCollectionChangedEventArgs class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal action As NotifyCollectionChangedAction, _
   ByVal changedItem As System.Object, _
   ByVal index As System.Integer _
)
public NotifyCollectionChangedEventArgs(
   NotifyCollectionChangedAction action,
   System.object changedItem,
   System.int index
)

Parameters

action
changedItem
index
See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members
Overload List


NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction)

NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class > NotifyCollectionChangedEventArgs Constructor : NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction)
Initializes a new instance of the NotifyCollectionChangedEventArgs class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal action As NotifyCollectionChangedAction _
)
public NotifyCollectionChangedEventArgs(
   NotifyCollectionChangedAction action
)

Parameters

action
See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members
Overload List


NotifyCollectionChangedEventArgs Class Properties

NotifyCollectionChangedEventArgs Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : NotifyCollectionChangedEventArgs Class

For a list of all members of this type, see NotifyCollectionChangedEventArgs members.

Public Properties
 | Name | Description
Public Property | Action | Gets the action type.
Public Property | NewItems | Gets the new items.
Public Property | NewStartingIndex | Gets the index of the starting of new items.
Public Property | OldItems | Gets the old items.
Public Property | OldStartingIndex | Gets the index of the starting of old items.
Top
See Also

Reference

NotifyCollectionChangedEventArgs Class
GrapeCity.Viewer.Common Namespace


Action Property (NotifyCollectionChangedEventArgs)

Action Property (NotifyCollectionChangedEventArgs)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class : Action Property
Gets the action type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Action As NotifyCollectionChangedAction
public NotifyCollectionChangedAction Action {get;}
See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members


NewItems Property (NotifyCollectionChangedEventArgs)

NewItems Property (NotifyCollectionChangedEventArgs)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class : NewItems Property
Gets the new items.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property NewItems As System.Collections.IList
public System.Collections.IList NewItems {get;}
See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members


NewStartingIndex Property (NotifyCollectionChangedEventArgs)

NewStartingIndex Property (NotifyCollectionChangedEventArgs)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class : NewStartingIndex Property
Gets the index of the starting of new items.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property NewStartingIndex As System.Integer
public System.int NewStartingIndex {get;}
See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members


OldItems Property (NotifyCollectionChangedEventArgs)

OldItems Property (NotifyCollectionChangedEventArgs)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class : OldItems Property
Gets the old items.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property OldItems As System.Collections.IList
public System.Collections.IList OldItems {get;}
See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members


OldStartingIndex Property (NotifyCollectionChangedEventArgs)

OldStartingIndex Property (NotifyCollectionChangedEventArgs)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class : OldStartingIndex Property
Gets the index of the starting of old items.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property OldStartingIndex As System.Integer
public System.int OldStartingIndex {get;}
See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members


NullDelegateCommand Class

NullDelegateCommand Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : NullDelegateCommand Class
Object Model
NullDelegateCommand Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class NullDelegateCommand
   Implements ICommand, IDelegateCommand
public sealed class NullDelegateCommand : ICommand, IDelegateCommand
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.NullDelegateCommand

See Also

Reference

NullDelegateCommand Members
GrapeCity.Viewer.Common Namespace


NullDelegateCommand Class Members

NullDelegateCommand Class Members
Methods Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : NullDelegateCommand Class

The following tables list the members exposed by NullDelegateCommand.

Public Constructors
 | Name | Description
Public Constructor | NullDelegateCommand Constructor |
Top
Public Methods
 | Name | Description
Public Method | CanExecute |
Public Method | Execute |
Public Method | RaiseCanExecuteChanged |
Top
Public Events
 | Name | Description
Public Event | CanExecuteChanged |
Top
See Also

Reference

NullDelegateCommand Class
GrapeCity.Viewer.Common Namespace


NullDelegateCommand Constructor

NullDelegateCommand Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > NullDelegateCommand Class : NullDelegateCommand Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public NullDelegateCommand()
See Also

Reference

NullDelegateCommand Class
NullDelegateCommand Members


NullDelegateCommand Class Methods

NullDelegateCommand Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : NullDelegateCommand Class

For a list of all members of this type, see NullDelegateCommand members.

Public Methods
 | Name | Description
Public Method | CanExecute |
Public Method | Execute |
Public Method | RaiseCanExecuteChanged |
Top
See Also

Reference

NullDelegateCommand Class
GrapeCity.Viewer.Common Namespace


CanExecute Method (NullDelegateCommand)

CanExecute Method (NullDelegateCommand)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > NullDelegateCommand Class : CanExecute Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CanExecute( _
   ByVal parameter As System.Object _
) As System.Boolean
public System.bool CanExecute(
   System.object parameter
)

Parameters

parameter
See Also

Reference

NullDelegateCommand Class
NullDelegateCommand Members


Execute Method (NullDelegateCommand)

Execute Method (NullDelegateCommand)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > NullDelegateCommand Class : Execute Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Execute( _
   ByVal parameter As System.Object _
)
public void Execute(
   System.object parameter
)

Parameters

parameter
See Also

Reference

NullDelegateCommand Class
NullDelegateCommand Members


RaiseCanExecuteChanged Method (NullDelegateCommand)

RaiseCanExecuteChanged Method (NullDelegateCommand)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > NullDelegateCommand Class : RaiseCanExecuteChanged Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RaiseCanExecuteChanged()
public void RaiseCanExecuteChanged()
See Also

Reference

NullDelegateCommand Class
NullDelegateCommand Members


NullDelegateCommand Class Events

NullDelegateCommand Class Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : NullDelegateCommand Class

For a list of all members of this type, see NullDelegateCommand members.

Public Events
 | Name | Description
Public Event | CanExecuteChanged |
Top
See Also

Reference

NullDelegateCommand Class
GrapeCity.Viewer.Common Namespace


CanExecuteChanged Event (NullDelegateCommand)

CanExecuteChanged Event (NullDelegateCommand)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > NullDelegateCommand Class : CanExecuteChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event CanExecuteChanged As System.EventHandler
public event System.EventHandler CanExecuteChanged
See Also

Reference

NullDelegateCommand Class
NullDelegateCommand Members


NullRenderer Class

NullRenderer Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : NullRenderer Class
Null-object implementation for IDocumentRenderer interface
Object Model
NullRenderer Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class NullRenderer
   Implements IDocumentRenderer
public sealed class NullRenderer : IDocumentRenderer
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.NullRenderer

See Also

Reference

NullRenderer Members
GrapeCity.Viewer.Common Namespace


NullRenderer Class Members

NullRenderer Class Members
Fields Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : NullRenderer Class

The following tables list the members exposed by NullRenderer.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Instance | The NullRenderer instance
Top
Public Methods
 | Name | Description
Public Method | RenderPage | Renders page from current document
Top
See Also

Reference

NullRenderer Class
GrapeCity.Viewer.Common Namespace


NullRenderer Class Methods

NullRenderer Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : NullRenderer Class

For a list of all members of this type, see NullRenderer members.

Public Methods
 | Name | Description
Public Method | RenderPage | Renders page from current document
Top
See Also

Reference

NullRenderer Class
GrapeCity.Viewer.Common Namespace


RenderPage Method (NullRenderer)

RenderPage Method (NullRenderer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > NullRenderer Class : RenderPage Method
Index of the page to render
Renders page from current document
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function RenderPage( _
   ByVal index As System.Integer _
) As PageView
public PageView RenderPage(
   System.int index
)

Parameters

index
Index of the page to render

Return Value

Rendered page view
See Also

Reference

NullRenderer Class
NullRenderer Members


NullRenderer Class Fields

NullRenderer Class Fields

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : NullRenderer Class

For a list of all members of this type, see NullRenderer members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Instance | The NullRenderer instance
Top
See Also

Reference

NullRenderer Class
GrapeCity.Viewer.Common Namespace


Instance Field (NullRenderer)

Instance Field (NullRenderer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > NullRenderer Class : Instance Field
The NullRenderer instance
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Instance As IDocumentRenderer
public static readonly IDocumentRenderer Instance
See Also

Reference

NullRenderer Class
NullRenderer Members


NullRenderer.Factory Class

NullRenderer.Factory Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : NullRenderer.Factory Class
IDocumentRenderer factory.
Object Model
NullRenderer.Factory Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class NullRenderer.Factory
   Implements IDocumentRendererFactory
public sealed class NullRenderer.Factory : IDocumentRendererFactory
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.NullRenderer.Factory

See Also

Reference

NullRenderer.Factory Members
GrapeCity.Viewer.Common Namespace


NullRenderer.Factory Class Members

NullRenderer.Factory Class Members
Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : NullRenderer.Factory Class

The following tables list the members exposed by NullRenderer.Factory.

Public Constructors
 | Name | Description
Public Constructor | NullRenderer.Factory Constructor |
Top
Public Methods
 | Name | Description
Public Method | Create | Overloaded. Returns MullRenderer.Instance object.
Top
See Also

Reference

NullRenderer.Factory Class
GrapeCity.Viewer.Common Namespace


NullRenderer.Factory Constructor

NullRenderer.Factory Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > NullRenderer.Factory Class : NullRenderer.Factory Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public NullRenderer.Factory()
See Also

Reference

NullRenderer.Factory Class
NullRenderer.Factory Members


NullRenderer.Factory Class Methods

NullRenderer.Factory Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : NullRenderer.Factory Class

For a list of all members of this type, see NullRenderer.Factory members.

Public Methods
 | Name | Description
Public Method | Create | Overloaded. Returns MullRenderer.Instance object.
Top
See Also

Reference

NullRenderer.Factory Class
GrapeCity.Viewer.Common Namespace


Create Method (NullRenderer.Factory)

Create Method (NullRenderer.Factory)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > NullRenderer.Factory Class : Create Method
Returns MullRenderer.Instance object.
Overload List
Overload | Description
Create(IApplicationContext,DocumentModel) | Returns MullRenderer.Instance object.
Create(IApplicationContext,DocumentModel,DeviceKind) | Returns MullRenderer.Instance object.
See Also

Reference

NullRenderer.Factory Class
NullRenderer.Factory Members


Create(IApplicationContext,DocumentModel) Method

Create(IApplicationContext,DocumentModel) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > NullRenderer.Factory Class > Create Method : Create(IApplicationContext,DocumentModel) Method
Returns MullRenderer.Instance object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Create( _
   ByVal context As IApplicationContext, _
   ByVal document As DocumentModel _
) As IDocumentRenderer
public IDocumentRenderer Create(
   IApplicationContext context,
   DocumentModel document
)

Parameters

context
document
See Also

Reference

NullRenderer.Factory Class
NullRenderer.Factory Members
Overload List


Create(IApplicationContext,DocumentModel,DeviceKind) Method

Create(IApplicationContext,DocumentModel,DeviceKind) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > NullRenderer.Factory Class > Create Method : Create(IApplicationContext,DocumentModel,DeviceKind) Method
Returns MullRenderer.Instance object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Create( _
   ByVal context As IApplicationContext, _
   ByVal document As DocumentModel, _
   ByVal device As DeviceKind _
) As IDocumentRenderer
public IDocumentRenderer Create(
   IApplicationContext context,
   DocumentModel document,
   DeviceKind device
)

Parameters

context
document
device
See Also

Reference

NullRenderer.Factory Class
NullRenderer.Factory Members
Overload List


ObservableCollection<T> Class

ObservableCollection<T> Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : ObservableCollection<T> Class
Wrapped System.Collections.ObjectModel observable collection
Object Model
ObservableCollection<T> Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ObservableCollection(Of T)
   Inherits System.Collections.ObjectModel.Collection(Of T)
   Implements INotifyCollectionChanged
public class ObservableCollection<T> : System.Collections.ObjectModel.Collection<T>, INotifyCollectionChanged
Type Parameters
T
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.Viewer.Common.ObservableCollection<T>

See Also

Reference

ObservableCollection<T> Members
GrapeCity.Viewer.Common Namespace


ObservableCollection<T> Class Members

ObservableCollection<T> Class Members
Properties Methods Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : ObservableCollection<T> Class

The following tables list the members exposed by ObservableCollection<T>.

Public Constructors
 | Name | Description
Public Constructor | ObservableCollection<T> Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<T>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<T>)
Top
Public Events
 | Name | Description
Public Event | CollectionChanged |
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ObservableCollection<T> Class
GrapeCity.Viewer.Common Namespace


ObservableCollection<T> Constructor

ObservableCollection<T> Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : ObservableCollection<T> Constructor
Overload List
Overload | Description
ObservableCollection<T> Constructor(IList<T>) | Initializes a new instance of the ObservableCollection<T> class.
ObservableCollection<T> Constructor() | Initializes a new instance of the ObservableCollection<T> class.
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


ObservableCollection<T> Constructor(IList<T>)

ObservableCollection<T> Constructor(IList<T>)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class > ObservableCollection<T> Constructor : ObservableCollection<T> Constructor(IList<T>)
The initial items list.
Initializes a new instance of the ObservableCollection<T> class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal data As System.Collections.Generic.IList(Of T) _
)
public ObservableCollection<T>(
   System.Collections.Generic.IList<T> data
)

Parameters

data
The initial items list.
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members
Overload List


ObservableCollection<T> Constructor()

ObservableCollection<T> Constructor()

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class > ObservableCollection<T> Constructor : ObservableCollection<T> Constructor()
Initializes a new instance of the ObservableCollection<T> class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ObservableCollection<T>()
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members
Overload List


ObservableCollection<T> Class Events

ObservableCollection<T> Class Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : ObservableCollection<T> Class

For a list of all members of this type, see ObservableCollection<T> members.

Public Events
 | Name | Description
Public Event | CollectionChanged |
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ObservableCollection<T> Class
GrapeCity.Viewer.Common Namespace


CollectionChanged Event (ObservableCollection<T>)

CollectionChanged Event (ObservableCollection<T>)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : CollectionChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event CollectionChanged As NotifyCollectionChangedEventHandler
public event NotifyCollectionChangedEventHandler CollectionChanged
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


PropertyChanged Event (ObservableCollection<T>)

PropertyChanged Event (ObservableCollection<T>)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : PropertyChanged Event
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PropertyChanged As System.ComponentModel.PropertyChangedEventHandler
public event System.ComponentModel.PropertyChangedEventHandler PropertyChanged
Event Data

The event handler receives an argument of type System.ComponentModel.PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


PageView Class

PageView Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : PageView Class
Base abstract class for concrete page renderers.
Object Model
PageView Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class PageView
public abstract class PageView
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.PageView

See Also

Reference

PageView Members
GrapeCity.Viewer.Common Namespace


PageView Class Members

PageView Class Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : PageView Class

The following tables list the members exposed by PageView.

Public Properties
 | Name | Description
Public Property | Device | Gets the device kind.
Public Property | Size | Gets the page view size.
Top
Public Methods
 | Name | Description
Public Method | AsCachable | Convert to CachedPageView.
Top
See Also

Reference

PageView Class
GrapeCity.Viewer.Common Namespace


PageView Class Methods

PageView Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : PageView Class

For a list of all members of this type, see PageView members.

Public Methods
 | Name | Description
Public Method | AsCachable | Convert to CachedPageView.
Top
See Also

Reference

PageView Class
GrapeCity.Viewer.Common Namespace


AsCachable Method (PageView)

AsCachable Method (PageView)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > PageView Class : AsCachable Method
Convert to CachedPageView.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Function AsCachable( _
   ByVal format As CacheFormat _
) As CachedPageView
public abstract CachedPageView AsCachable(
   CacheFormat format
)

Parameters

format
See Also

Reference

PageView Class
PageView Members


PageView Class Properties

PageView Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : PageView Class

For a list of all members of this type, see PageView members.

Public Properties
 | Name | Description
Public Property | Device | Gets the device kind.
Public Property | Size | Gets the page view size.
Top
See Also

Reference

PageView Class
GrapeCity.Viewer.Common Namespace


Device Property (PageView)

Device Property (PageView)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > PageView Class : Device Property
Gets the device kind.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Device As DeviceKind
public DeviceKind Device {get;}
See Also

Reference

PageView Class
PageView Members


Size Property (PageView)

Size Property (PageView)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > PageView Class : Size Property
Gets the page view size.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property Size As Size
public abstract Size Size {get;}
See Also

Reference

PageView Class
PageView Members


RectExtensions Class

RectExtensions Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : RectExtensions Class
Extends Rect struct with helper methods.
Object Model
RectExtensions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit NotInheritable Class RectExtensions
public static class RectExtensions
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.RectExtensions

See Also

Reference

RectExtensions Members
GrapeCity.Viewer.Common Namespace


RectExtensions Class Members

RectExtensions Class Members
Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : RectExtensions Class

The following tables list the members exposed by RectExtensions.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Round | Rounds the coordinates and size of the rectangle.
Top
See Also

Reference

RectExtensions Class
GrapeCity.Viewer.Common Namespace


RectExtensions Class Methods

RectExtensions Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : RectExtensions Class

For a list of all members of this type, see RectExtensions members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Round | Rounds the coordinates and size of the rectangle.
Top
See Also

Reference

RectExtensions Class
GrapeCity.Viewer.Common Namespace


Round Method (RectExtensions)

Round Method (RectExtensions)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > RectExtensions Class : Round Method
Rounds the coordinates and size of the rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function Round( _
   ByVal rect As Rect, _
   ByVal digits As System.Integer _
) As Rect
public static Rect Round(
   Rect rect,
   System.int digits
)

Parameters

rect
digits
See Also

Reference

RectExtensions Class
RectExtensions Members


StreamDocumentLoader Class

StreamDocumentLoader Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : StreamDocumentLoader Class
Object Model
StreamDocumentLoader Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class StreamDocumentLoader
   Implements IDocumentLoader
public class StreamDocumentLoader : IDocumentLoader
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.StreamDocumentLoader

See Also

Reference

StreamDocumentLoader Members
GrapeCity.Viewer.Common Namespace


StreamDocumentLoader Class Members

StreamDocumentLoader Class Members
Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : StreamDocumentLoader Class

The following tables list the members exposed by StreamDocumentLoader.

Public Constructors
 | Name | Description
Public Constructor | StreamDocumentLoader Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | DocumentFormat |
Top
See Also

Reference

StreamDocumentLoader Class
GrapeCity.Viewer.Common Namespace


StreamDocumentLoader Constructor

StreamDocumentLoader Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > StreamDocumentLoader Class : StreamDocumentLoader Constructor
Overload List
Overload | Description
StreamDocumentLoader Constructor(Stream,DocumentFormat) |
StreamDocumentLoader Constructor(Stream,Uri,DocumentFormat) |
See Also

Reference

StreamDocumentLoader Class
StreamDocumentLoader Members


StreamDocumentLoader Constructor(Stream,DocumentFormat)

StreamDocumentLoader Constructor(Stream,DocumentFormat)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > StreamDocumentLoader Class > StreamDocumentLoader Constructor : StreamDocumentLoader Constructor(Stream,DocumentFormat)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal s As System.IO.Stream, _
   ByVal format As DocumentFormat _
)
public StreamDocumentLoader(
   System.IO.Stream s,
   DocumentFormat format
)

Parameters

s
format
See Also

Reference

StreamDocumentLoader Class
StreamDocumentLoader Members
Overload List


StreamDocumentLoader Constructor(Stream,Uri,DocumentFormat)

StreamDocumentLoader Constructor(Stream,Uri,DocumentFormat)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > StreamDocumentLoader Class > StreamDocumentLoader Constructor : StreamDocumentLoader Constructor(Stream,Uri,DocumentFormat)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal s As System.IO.Stream, _
   ByVal baseUri As System.Uri, _
   ByVal format As DocumentFormat _
)
public StreamDocumentLoader(
   System.IO.Stream s,
   System.Uri baseUri,
   DocumentFormat format
)

Parameters

s
baseUri
format
See Also

Reference

StreamDocumentLoader Class
StreamDocumentLoader Members
Overload List


StreamDocumentLoader Class Properties

StreamDocumentLoader Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : StreamDocumentLoader Class

For a list of all members of this type, see StreamDocumentLoader members.

Public Properties
 | Name | Description
Public Property | DocumentFormat |
Top
See Also

Reference

StreamDocumentLoader Class
GrapeCity.Viewer.Common Namespace


DocumentFormat Property (StreamDocumentLoader)

DocumentFormat Property (StreamDocumentLoader)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > StreamDocumentLoader Class : DocumentFormat Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DocumentFormat As DocumentFormat
public DocumentFormat DocumentFormat {get;}
See Also

Reference

StreamDocumentLoader Class
StreamDocumentLoader Members


DeviceKind Enumeration

DeviceKind Enumeration

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DeviceKind Enumeration
Defines enumeration of possible target devices for view.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DeviceKind
   Inherits System.Enum
public enum DeviceKind : System.Enum
Members
Member | Description
Export | Output to Export target device
Paper | Output to Paper target device
Screen | Output to Screen target device
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.DeviceKind

See Also

Reference

GrapeCity.Viewer.Common Namespace


DocumentFormat Enumeration

DocumentFormat Enumeration

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DocumentFormat Enumeration
Specifies possible document formats
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DocumentFormat
   Inherits System.Enum
public enum DocumentFormat : System.Enum
Members
Member | Description
Ddf | DDF document, binary format
Rdf | AR document, binary format
Rdlx | DDR document, xml format
Rpx | AR document, xml format
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.DocumentFormat

See Also

Reference

GrapeCity.Viewer.Common Namespace


LoadState Enumeration

LoadState Enumeration

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : LoadState Enumeration
Possible loading states
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LoadState
   Inherits System.Enum
public enum LoadState : System.Enum
Members
Member | Description
Cancelled |
Cancelling |
Completed |
Error |
InProgress |
NotStarted |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.LoadState

See Also

Reference

GrapeCity.Viewer.Common Namespace


NotifyCollectionChangedAction Enumeration

NotifyCollectionChangedAction Enumeration

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : NotifyCollectionChangedAction Enumeration
Enum NotifyCollectionChangedAction
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum NotifyCollectionChangedAction
   Inherits System.Enum
public enum NotifyCollectionChangedAction : System.Enum
Members
Member | Description
Add |
Remove |
Replace |
Reset |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.NotifyCollectionChangedAction

See Also

Reference

GrapeCity.Viewer.Common Namespace


PrintingSettings Enumeration

PrintingSettings Enumeration

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : PrintingSettings Enumeration
Print process settings
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PrintingSettings
   Inherits System.Enum
public enum PrintingSettings : System.Enum
Members
Member | Description
None |
ShowPrintDialog | If set the Print-dialog will be shown.
ShowPrintProgressDialog | If set the dialog with printing state information will be shown.
UsePrintingThread | If set the printing will be run in new thread.
UseStandardDialog | If set the printing will use standard PrintDialog
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.PrintingSettings

See Also

Reference

GrapeCity.Viewer.Common Namespace


Color Structure

Color Structure
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : Color Structure
Platform independent color implementation
Object Model
Color Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure Color
   Inherits System.ValueType
public struct Color : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Viewer.Common.Color

See Also

Reference

Color Members
GrapeCity.Viewer.Common Namespace


Color Structure Members

Color Structure Members
Fields Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : Color Structure

The following tables list the members exposed by Color.

Public Constructors
 | Name | Description
Public Constructor | Color Constructor | Initializes a new instance of the Color struct.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | Black |
static (Shared in Visual Basic) | Blue |
static (Shared in Visual Basic) | DarkBlue |
static (Shared in Visual Basic) | Empty |
static (Shared in Visual Basic) | Gray |
static (Shared in Visual Basic) | Red |
static (Shared in Visual Basic) | Transparent |
static (Shared in Visual Basic) | White |
Top
Public Properties
 | Name | Description
Public Property | A | Gets the A color component.
Public Property | B | Gets the B color component.
Public Property | G | Gets the G color component.
Public Property | IsEmpty | Gets a value indicating whether this instance is empty.
Public Property | R | Gets the R color component.
Public Property | Value | Gets the value.
Top
Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified System.Object is equal to this instance.
static (Shared in Visual Basic) | FromArgb | Overloaded. Creates new color from color components.
Public Method | GetHashCode |
Public Method | ToArgb | Gets ARGB value of the color.
Top
Public Operators
public Operator Equality | Implements the operator ==.
public Operator Implicit Type Conversion | Performs an implicit conversion from Color to System.UInt32.
public Operator Inequality | Implements the operator !=.
Top
See Also

Reference

Color Structure
GrapeCity.Viewer.Common Namespace


Color Constructor

Color Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Color Constructor
The value.
Initializes a new instance of the Color struct.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal value As System.Long _
)
public Color(
   System.long value
)

Parameters

value
The value.
See Also

Reference

Color Structure
Color Members


Color Structure Methods

Color Structure Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : Color Structure

For a list of all members of this type, see Color members.

Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified System.Object is equal to this instance.
static (Shared in Visual Basic) | FromArgb | Overloaded. Creates new color from color components.
Public Method | GetHashCode |
Public Method | ToArgb | Gets ARGB value of the color.
Top
See Also

Reference

Color Structure
GrapeCity.Viewer.Common Namespace


Equals Method (Color)

Equals Method (Color)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Equals Method
Determines whether the specified System.Object is equal to this instance.
Overload List
Overload | Description
Equals(Color) |
Equals(Object) | Determines whether the specified System.Object is equal to this instance.
See Also

Reference

Color Structure
Color Members


Equals(Color) Method

Equals(Color) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure > Equals Method : Equals(Color) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Equals( _
   ByVal obj As Color _
) As System.Boolean
public System.bool Equals(
   Color obj
)

Parameters

obj
See Also

Reference

Color Structure
Color Members
Overload List


Equals(Object) Method

Equals(Object) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure > Equals Method : Equals(Object) Method
Determines whether the specified System.Object is equal to this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
See Also

Reference

Color Structure
Color Members
Overload List


FromArgb Method (Color)

FromArgb Method (Color)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : FromArgb Method
Creates new color from color components.
Overload List
Overload | Description
FromArgb(Int32) | Creates new color from color components.
FromArgb(Int32,Color) | Creates new color from color components.
FromArgb(Byte,Byte,Byte,Byte) | Creates new color from color components.
FromArgb(Int32,Int32,Int32) | Creates new color from color components.
FromArgb(Int32,Int32,Int32,Int32) | Creates new color from color components.
See Also

Reference

Color Structure
Color Members


FromArgb(Int32) Method

FromArgb(Int32) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure > FromArgb Method : FromArgb(Int32) Method
The value.
Creates new color from color components.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromArgb( _
   ByVal value As System.Integer _
) As Color
public static Color FromArgb(
   System.int value
)

Parameters

value
The value.
See Also

Reference

Color Structure
Color Members
Overload List


FromArgb(Int32,Color) Method

FromArgb(Int32,Color) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure > FromArgb Method : FromArgb(Int32,Color) Method
A.
The c.
Creates new color from color components.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromArgb( _
   ByVal a As System.Integer, _
   ByVal c As Color _
) As Color
public static Color FromArgb(
   System.int a,
   Color c
)

Parameters

a
A.
c
The c.
See Also

Reference

Color Structure
Color Members
Overload List


FromArgb(Byte,Byte,Byte,Byte) Method

FromArgb(Byte,Byte,Byte,Byte) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure > FromArgb Method : FromArgb(Byte,Byte,Byte,Byte) Method
A.
The r.
The g.
The b.
Creates new color from color components.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromArgb( _
   ByVal a As System.Byte, _
   ByVal r As System.Byte, _
   ByVal g As System.Byte, _
   ByVal b As System.Byte _
) As Color
public static Color FromArgb(
   System.byte a,
   System.byte r,
   System.byte g,
   System.byte b
)

Parameters

a
A.
r
The r.
g
The g.
b
The b.
See Also

Reference

Color Structure
Color Members
Overload List


FromArgb(Int32,Int32,Int32) Method

FromArgb(Int32,Int32,Int32) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure > FromArgb Method : FromArgb(Int32,Int32,Int32) Method
Creates new color from color components.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromArgb( _
   ByVal r As System.Integer, _
   ByVal g As System.Integer, _
   ByVal b As System.Integer _
) As Color
public static Color FromArgb(
   System.int r,
   System.int g,
   System.int b
)

Parameters

r
g
b
See Also

Reference

Color Structure
Color Members
Overload List


FromArgb(Int32,Int32,Int32,Int32) Method

FromArgb(Int32,Int32,Int32,Int32) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure > FromArgb Method : FromArgb(Int32,Int32,Int32,Int32) Method
Creates new color from color components.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromArgb( _
   ByVal a As System.Integer, _
   ByVal r As System.Integer, _
   ByVal g As System.Integer, _
   ByVal b As System.Integer _
) As Color
public static Color FromArgb(
   System.int a,
   System.int r,
   System.int g,
   System.int b
)

Parameters

a
r
g
b
See Also

Reference

Color Structure
Color Members
Overload List


GetHashCode Method (Color)

GetHashCode Method (Color)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : GetHashCode Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()
See Also

Reference

Color Structure
Color Members


ToArgb Method (Color)

ToArgb Method (Color)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : ToArgb Method
Gets ARGB value of the color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToArgb() As System.Integer
public System.int ToArgb()
See Also

Reference

Color Structure
Color Members


Color Structure Properties

Color Structure Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : Color Structure

For a list of all members of this type, see Color members.

Public Properties
 | Name | Description
Public Property | A | Gets the A color component.
Public Property | B | Gets the B color component.
Public Property | G | Gets the G color component.
Public Property | IsEmpty | Gets a value indicating whether this instance is empty.
Public Property | R | Gets the R color component.
Public Property | Value | Gets the value.
Top
See Also

Reference

Color Structure
GrapeCity.Viewer.Common Namespace


A Property (Color)

A Property (Color)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : A Property
Gets the A color component.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property A As System.Byte
public System.byte A {get;}
See Also

Reference

Color Structure
Color Members


B Property (Color)

B Property (Color)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : B Property
Gets the B color component.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property B As System.Byte
public System.byte B {get;}
See Also

Reference

Color Structure
Color Members


G Property (Color)

G Property (Color)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : G Property
Gets the G color component.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property G As System.Byte
public System.byte G {get;}
See Also

Reference

Color Structure
Color Members


IsEmpty Property (Color)

IsEmpty Property (Color)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : IsEmpty Property
Gets a value indicating whether this instance is empty.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsEmpty As System.Boolean
public System.bool IsEmpty {get;}

Property Value

true if this instance is empty; otherwise, false.
See Also

Reference

Color Structure
Color Members


R Property (Color)

R Property (Color)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : R Property
Gets the R color component.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property R As System.Byte
public System.byte R {get;}
See Also

Reference

Color Structure
Color Members


Value Property (Color)

Value Property (Color)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Value Property
Gets the value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Value As System.Long
public System.long Value {get;}
See Also

Reference

Color Structure
Color Members


Color Structure Fields

Color Structure Fields

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : Color Structure

For a list of all members of this type, see Color members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Black |
static (Shared in Visual Basic) | Blue |
static (Shared in Visual Basic) | DarkBlue |
static (Shared in Visual Basic) | Empty |
static (Shared in Visual Basic) | Gray |
static (Shared in Visual Basic) | Red |
static (Shared in Visual Basic) | Transparent |
static (Shared in Visual Basic) | White |
Top
See Also

Reference

Color Structure
GrapeCity.Viewer.Common Namespace


Black Field (Color)

Black Field (Color)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Black Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Black As Color
public static readonly Color Black
See Also

Reference

Color Structure
Color Members


Blue Field (Color)

Blue Field (Color)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Blue Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Blue As Color
public static readonly Color Blue
See Also

Reference

Color Structure
Color Members


DarkBlue Field (Color)

DarkBlue Field (Color)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : DarkBlue Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly DarkBlue As Color
public static readonly Color DarkBlue
See Also

Reference

Color Structure
Color Members


Empty Field (Color)

Empty Field (Color)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Empty Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Empty As Color
public static readonly Color Empty
See Also

Reference

Color Structure
Color Members


Gray Field (Color)

Gray Field (Color)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Gray Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Gray As Color
public static readonly Color Gray
See Also

Reference

Color Structure
Color Members


Red Field (Color)

Red Field (Color)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Red Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Red As Color
public static readonly Color Red
See Also

Reference

Color Structure
Color Members


Transparent Field (Color)

Transparent Field (Color)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Transparent Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Transparent As Color
public static readonly Color Transparent
See Also

Reference

Color Structure
Color Members


White Field (Color)

White Field (Color)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : White Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly White As Color
public static readonly Color White
See Also

Reference

Color Structure
Color Members


Equality Operator (Color)

Equality Operator (Color)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Equality Operator
The color1.
The color2.
Implements the operator ==.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator =( _
   ByVal color1 As Color, _
   ByVal color2 As Color _
) As System.Boolean
public System.bool operator ==(
   Color color1,
   Color color2
)

Parameters

color1
The color1.
color2
The color2.

Return Value

The result of the operator.
See Also

Reference

Color Structure
Color Members


Implicit Type Conversion Operator (Color)

Implicit Type Conversion Operator (Color)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Implicit Type Conversion Operator
The color.
Performs an implicit conversion from Color to System.UInt32.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator Widening CType( _
   ByVal color As Color _
) As System.UInteger
public System.uint operator implicit(
   Color color
)

Parameters

color
The color.

Return Value

The result of the conversion.
See Also

Reference

Color Structure
Color Members


Inequality Operator (Color)

Inequality Operator (Color)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Inequality Operator
The color1.
The color2.
Implements the operator !=.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator <>( _
   ByVal color1 As Color, _
   ByVal color2 As Color _
) As System.Boolean
public System.bool operator !=(
   Color color1,
   Color color2
)

Parameters

color1
The color1.
color2
The color2.

Return Value

The result of the operator.
See Also

Reference

Color Structure
Color Members


Margin Structure

Margin Structure
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : Margin Structure
Stores page margins
Object Model
Margin Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure Margin
   Inherits System.ValueType
public struct Margin : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Viewer.Common.Margin

See Also

Reference

Margin Members
GrapeCity.Viewer.Common Namespace


Margin Structure Members

Margin Structure Members
Fields Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : Margin Structure

The following tables list the members exposed by Margin.

Public Constructors
 | Name | Description
Public Constructor | Margin Constructor | Ctor
Top
Public Fields
 | Name | Description
Public Field | Bottom |
static (Shared in Visual Basic) | Empty |
Public Field | Left |
Public Field | Right |
Public Field | Top |
Top
Public Properties
 | Name | Description
Public Property | Horizontal |
Public Property | Vertical |
Top
Public Methods
 | Name | Description
Public Method | Equals |
Top
See Also

Reference

Margin Structure
GrapeCity.Viewer.Common Namespace


Margin Constructor

Margin Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Margin Constructor
Left margin
Right margin
Top margin
Bottom margin
Ctor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal left As System.Single, _
   ByVal right As System.Single, _
   ByVal top As System.Single, _
   ByVal bottom As System.Single _
)
public Margin(
   System.float left,
   System.float right,
   System.float top,
   System.float bottom
)

Parameters

left
Left margin
right
Right margin
top
Top margin
bottom
Bottom margin
See Also

Reference

Margin Structure
Margin Members


Margin Structure Methods

Margin Structure Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : Margin Structure

For a list of all members of this type, see Margin members.

Public Methods
 | Name | Description
Public Method | Equals |
Top
See Also

Reference

Margin Structure
GrapeCity.Viewer.Common Namespace


Equals Method (Margin)

Equals Method (Margin)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Equals Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
See Also

Reference

Margin Structure
Margin Members


Margin Structure Properties

Margin Structure Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : Margin Structure

For a list of all members of this type, see Margin members.

Public Properties
 | Name | Description
Public Property | Horizontal |
Public Property | Vertical |
Top
See Also

Reference

Margin Structure
GrapeCity.Viewer.Common Namespace


Horizontal Property (Margin)

Horizontal Property (Margin)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Horizontal Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Horizontal As System.Single
public System.float Horizontal {get;}
See Also

Reference

Margin Structure
Margin Members


Vertical Property (Margin)

Vertical Property (Margin)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Vertical Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Vertical As System.Single
public System.float Vertical {get;}
See Also

Reference

Margin Structure
Margin Members


Margin Structure Fields

Margin Structure Fields

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : Margin Structure

For a list of all members of this type, see Margin members.

Public Fields
 | Name | Description
Public Field | Bottom |
static (Shared in Visual Basic) | Empty |
Public Field | Left |
Public Field | Right |
Public Field | Top |
Top
See Also

Reference

Margin Structure
GrapeCity.Viewer.Common Namespace


Bottom Field (Margin)

Bottom Field (Margin)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Bottom Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Bottom As System.Single
public readonly System.float Bottom
See Also

Reference

Margin Structure
Margin Members


Empty Field (Margin)

Empty Field (Margin)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Empty Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Empty As Margin
public static Margin Empty
See Also

Reference

Margin Structure
Margin Members


Left Field (Margin)

Left Field (Margin)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Left Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Left As System.Single
public readonly System.float Left
See Also

Reference

Margin Structure
Margin Members


Right Field (Margin)

Right Field (Margin)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Right Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Right As System.Single
public readonly System.float Right
See Also

Reference

Margin Structure
Margin Members


Top Field (Margin)

Top Field (Margin)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Top Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Top As System.Single
public readonly System.float Top
See Also

Reference

Margin Structure
Margin Members


Point Structure

Point Structure
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : Point Structure
Platform independent point
Object Model
Point Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure Point
   Inherits System.ValueType
public struct Point : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Viewer.Common.Point

See Also

Reference

Point Members
GrapeCity.Viewer.Common Namespace


Point Structure Members

Point Structure Members
Fields Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : Point Structure

The following tables list the members exposed by Point.

Public Constructors
 | Name | Description
Public Constructor | Point Constructor | Initializes a new instance of the Point class with the specified coordinates.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | Represents a Point that has X and Y values set to zero
Top
Public Properties
 | Name | Description
Public Property | X | Gets or sets the x-coordinate of this Point.
Public Property | Y | Gets or sets the y-coordinate of this Point.
Top
Public Methods
 | Name | Description
Public Method | Equals | Determines whether the specified System.Object is equal to this instance.
Public Method | GetHashCode | Returns a hash code for this instance.
Public Method | Offset | Overloaded. Adjusts the location of this rectangle by the specified amount.
Public Method | ToString | Returns a System.String that represents this instance.
Top
Public Operators
public Operator Addition | Translates a Point by a given Size.
public Operator Unary Negation | Multiplies the point coordinates by -1.
Top
See Also

Reference

Point Structure
GrapeCity.Viewer.Common Namespace


Point Constructor

Point Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : Point Constructor
The horizontal position of the point.
The vertical position of the point.
Initializes a new instance of the Point class with the specified coordinates.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal x As System.Double, _
   ByVal y As System.Double _
)
public Point(
   System.double x,
   System.double y
)

Parameters

x
The horizontal position of the point.
y
The vertical position of the point.
See Also

Reference

Point Structure
Point Members


Point Structure Methods

Point Structure Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : Point Structure

For a list of all members of this type, see Point members.

Public Methods
 | Name | Description
Public Method | Equals | Determines whether the specified System.Object is equal to this instance.
Public Method | GetHashCode | Returns a hash code for this instance.
Public Method | Offset | Overloaded. Adjusts the location of this rectangle by the specified amount.
Public Method | ToString | Returns a System.String that represents this instance.
Top
See Also

Reference

Point Structure
GrapeCity.Viewer.Common Namespace


Equals Method (Point)

Equals Method (Point)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : Equals Method
Determines whether the specified System.Object is equal to this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
See Also

Reference

Point Structure
Point Members


GetHashCode Method (Point)

GetHashCode Method (Point)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : GetHashCode Method
Returns a hash code for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()
See Also

Reference

Point Structure
Point Members


Offset Method (Point)

Offset Method (Point)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : Offset Method
Adjusts the location of this rectangle by the specified amount.
Overload List
Overload | Description
Offset(Double,Double) | Adjusts the location of this rectangle by the specified amount.
Offset(Size) | Adjusts the location of this rectangle by the specified amount.
See Also

Reference

Point Structure
Point Members


Offset(Double,Double) Method

Offset(Double,Double) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Point Structure > Offset Method : Offset(Double,Double) Method
The horizontal offset.
The vertical offset.
Adjusts the location of this rectangle by the specified amount.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Offset( _
   ByVal x As System.Double, _
   ByVal y As System.Double _
) As Point
public Point Offset(
   System.double x,
   System.double y
)

Parameters

x
The horizontal offset.
y
The vertical offset.
See Also

Reference

Point Structure
Point Members
Overload List


Offset(Size) Method

Offset(Size) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Point Structure > Offset Method : Offset(Size) Method
Amount to offset the location.
Adjusts the location of this rectangle by the specified amount.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Offset( _
   ByVal offset As Size _
) As Point
public Point Offset(
   Size offset
)

Parameters

offset
Amount to offset the location.
See Also

Reference

Point Structure
Point Members
Overload List


ToString Method (Point)

ToString Method (Point)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : ToString Method
Returns a System.String that represents this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()

Return Value

A System.String that represents this instance.
See Also

Reference

Point Structure
Point Members


Point Structure Properties

Point Structure Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : Point Structure

For a list of all members of this type, see Point members.

Public Properties
 | Name | Description
Public Property | X | Gets or sets the x-coordinate of this Point.
Public Property | Y | Gets or sets the y-coordinate of this Point.
Top
See Also

Reference

Point Structure
GrapeCity.Viewer.Common Namespace


X Property (Point)

X Property (Point)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : X Property
Gets or sets the x-coordinate of this Point.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property X As System.Double
public System.double X {get;}
See Also

Reference

Point Structure
Point Members


Y Property (Point)

Y Property (Point)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : Y Property
Gets or sets the y-coordinate of this Point.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Y As System.Double
public System.double Y {get;}
See Also

Reference

Point Structure
Point Members


Point Structure Fields

Point Structure Fields

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : Point Structure

For a list of all members of this type, see Point members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | Represents a Point that has X and Y values set to zero
Top
See Also

Reference

Point Structure
GrapeCity.Viewer.Common Namespace


Empty Field (Point)

Empty Field (Point)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : Empty Field
Represents a Point that has X and Y values set to zero
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Empty As Point
public static readonly Point Empty
See Also

Reference

Point Structure
Point Members


Addition Operator (Point)

Addition Operator (Point)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : Addition Operator
The Point to translate.
A Size that specifies the pair of numbers to add to the coordinates of pt.
Translates a Point by a given Size.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator +( _
   ByVal p1 As Point, _
   ByVal sz As Size _
) As Point
public Point operator +(
   Point p1,
   Size sz
)

Parameters

p1
The Point to translate.
sz
A Size that specifies the pair of numbers to add to the coordinates of pt.

Return Value

The translated Point.
See Also

Reference

Point Structure
Point Members


Unary Negation Operator (Point)

Unary Negation Operator (Point)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : Unary Negation Operator
Multiplies the point coordinates by -1.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator -( _
   ByVal pt As Point _
) As Point
public Point operator -(
   Point pt
)

Parameters

pt
See Also

Reference

Point Structure
Point Members


Rect Structure

Rect Structure
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : Rect Structure
Platform aware rectangle structure
Object Model
Rect Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure Rect
   Inherits System.ValueType
public struct Rect : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Viewer.Common.Rect

See Also

Reference

Rect Members
GrapeCity.Viewer.Common Namespace


Rect Structure Members

Rect Structure Members
Fields Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : Rect Structure

The following tables list the members exposed by Rect.

Public Constructors
 | Name | Description
Public Constructor | Rect Constructor | Overloaded.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty |
Top
Public Properties
 | Name | Description
Public Property | Bottom | Gets the y-coordinate of the bottom edge of this rectangle.
Public Property | Height | Gets or sets the height of this rectangle.
Public Property | IsEmpty | Tests whether the size of this rectangle less or equal 0.
Public Property | Left | Gets the x-coordinate of the left edge of this rectangle.
Public Property | Location | Gets or sets the coordinates of the upper-left corner of this rectangle.
Public Property | Right | Gets the x-coordinate of the right edge of this rectangle.
Public Property | Size | Gets or sets the size of this rectangle.
Public Property | Top | Gets the y-coordinate of the top edge of this rectangle.
Public Property | Width | Gets or sets the width of this rectangle.
Public Property | X | Gets or sets the x-coordinate of the upper-left corner of this rectangle.
Public Property | Y | Gets or sets the y-coordinate of the upper-left corner of this rectangle.
Top
Public Methods
 | Name | Description
Public Method | Contains | Overloaded. Determines if the specified point is contained within this rectangle.
Public Method | Equals | Determines whether the specified System.Object is equal to this instance.
static (Shared in Visual Basic) | FromLTRB | Creates a Rect with the specified edge locations.
Public Method | GetHashCode | Returns a hash code for this instance.
Public Method | Inflate | Overloaded. Enlarges this Rect by the specified amount.
Public Method | Intersect | Overloaded. Replaces this Rect with the intersection of itself and the specified Rect.
Public Method | IntersectsWith | Determines if this rectangle intersects with specified rectangle.
Public Method | Offset | Overloaded. Adjusts the location of this rectangle by the specified amount.
Public Method | Scale | Overloaded. Scales the rectangle by specified scale factor.
Public Method | ToString | Returns a System.String that represents this instance.
static (Shared in Visual Basic) | Union | Creates a Rect structure that contains the union of two Rect structures.
Top
See Also

Reference

Rect Structure
GrapeCity.Viewer.Common Namespace


Rect Constructor

Rect Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Rect Constructor
Overload List
Overload | Description
Rect Constructor(Double,Double,Double,Double) | Initializes a new instance of the Rect class with the specified location and size.
Rect Constructor(Point,Size) | Initializes a new instance of the Rect class with the specified location and size.
See Also

Reference

Rect Structure
Rect Members


Rect Constructor(Double,Double,Double,Double)

Rect Constructor(Double,Double,Double,Double)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Rect Constructor : Rect Constructor(Double,Double,Double,Double)
The x-coordinate of the upper-left corner of the rectangle.
The y-coordinate of the upper-left corner of the rectangle.
The width of the rectangle.
The height of the rectangle.
Initializes a new instance of the Rect class with the specified location and size.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal x As System.Double, _
   ByVal y As System.Double, _
   ByVal width As System.Double, _
   ByVal height As System.Double _
)
public Rect(
   System.double x,
   System.double y,
   System.double width,
   System.double height
)

Parameters

x
The x-coordinate of the upper-left corner of the rectangle.
y
The y-coordinate of the upper-left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.
See Also

Reference

Rect Structure
Rect Members
Overload List


Rect Constructor(Point,Size)

Rect Constructor(Point,Size)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Rect Constructor : Rect Constructor(Point,Size)
A Point that represents the upper-left corner of the rectangle.
A Rect.Size that represents the width and height of the rectangle.
Initializes a new instance of the Rect class with the specified location and size.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal location As Point, _
   ByVal size As Size _
)
public Rect(
   Point location,
   Size size
)

Parameters

location
A Point that represents the upper-left corner of the rectangle.
size
A Rect.Size that represents the width and height of the rectangle.
See Also

Reference

Rect Structure
Rect Members
Overload List


Rect Structure Methods

Rect Structure Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : Rect Structure

For a list of all members of this type, see Rect members.

Public Methods
 | Name | Description
Public Method | Contains | Overloaded. Determines if the specified point is contained within this rectangle.
Public Method | Equals | Determines whether the specified System.Object is equal to this instance.
static (Shared in Visual Basic) | FromLTRB | Creates a Rect with the specified edge locations.
Public Method | GetHashCode | Returns a hash code for this instance.
Public Method | Inflate | Overloaded. Enlarges this Rect by the specified amount.
Public Method | Intersect | Overloaded. Replaces this Rect with the intersection of itself and the specified Rect.
Public Method | IntersectsWith | Determines if this rectangle intersects with specified rectangle.
Public Method | Offset | Overloaded. Adjusts the location of this rectangle by the specified amount.
Public Method | Scale | Overloaded. Scales the rectangle by specified scale factor.
Public Method | ToString | Returns a System.String that represents this instance.
static (Shared in Visual Basic) | Union | Creates a Rect structure that contains the union of two Rect structures.
Top
See Also

Reference

Rect Structure
GrapeCity.Viewer.Common Namespace


Contains Method (Rect)

Contains Method (Rect)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Contains Method
Determines if the specified point is contained within this rectangle.
Overload List
Overload | Description
Contains(Double,Double) | Determines if the specified point is contained within this rectangle.
Contains(Point) | Determines if the specified point is contained within this rectangle.
Contains(Rect) | Determines if the rectangular region represented by rect is entirely contained within this rectangle.
See Also

Reference

Rect Structure
Rect Members


Contains(Double,Double) Method

Contains(Double,Double) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Contains Method : Contains(Double,Double) Method
The x-coordinate of the point to test.
The y-coordinate of the point to test.
Determines if the specified point is contained within this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Contains( _
   ByVal x As System.Double, _
   ByVal y As System.Double _
) As System.Boolean
public System.bool Contains(
   System.double x,
   System.double y
)

Parameters

x
The x-coordinate of the point to test.
y
The y-coordinate of the point to test.
See Also

Reference

Rect Structure
Rect Members
Overload List


Contains(Point) Method

Contains(Point) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Contains Method : Contains(Point) Method
The Point to test.
Determines if the specified point is contained within this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Contains( _
   ByVal pt As Point _
) As System.Boolean
public System.bool Contains(
   Point pt
)

Parameters

pt
The Point to test.
See Also

Reference

Rect Structure
Rect Members
Overload List


Contains(Rect) Method

Contains(Rect) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Contains Method : Contains(Rect) Method
The Rect to test.
Determines if the rectangular region represented by rect is entirely contained within this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Contains( _
   ByVal rect As Rect _
) As System.Boolean
public System.bool Contains(
   Rect rect
)

Parameters

rect
The Rect to test.
See Also

Reference

Rect Structure
Rect Members
Overload List


Equals Method (Rect)

Equals Method (Rect)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Equals Method
Another object to compare to.
Determines whether the specified System.Object is equal to this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
Another object to compare to.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.
See Also

Reference

Rect Structure
Rect Members


FromLTRB Method (Rect)

FromLTRB Method (Rect)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : FromLTRB Method
The x-coordinate of the upper-left corner of the rectangle.
The y-coordinate of the upper-left corner of the rectangle.
The x-coordinate of the lower-right corner of the rectangle.
The y-coordinate of the lower-right corner of the rectangle
Creates a Rect with the specified edge locations.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function FromLTRB( _
   ByVal left As System.Double, _
   ByVal top As System.Double, _
   ByVal right As System.Double, _
   ByVal bottom As System.Double _
) As Rect
public static Rect FromLTRB(
   System.double left,
   System.double top,
   System.double right,
   System.double bottom
)

Parameters

left
The x-coordinate of the upper-left corner of the rectangle.
top
The y-coordinate of the upper-left corner of the rectangle.
right
The x-coordinate of the lower-right corner of the rectangle.
bottom
The y-coordinate of the lower-right corner of the rectangle
See Also

Reference

Rect Structure
Rect Members


GetHashCode Method (Rect)

GetHashCode Method (Rect)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : GetHashCode Method
Returns a hash code for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()
See Also

Reference

Rect Structure
Rect Members


Inflate Method (Rect)

Inflate Method (Rect)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Inflate Method
Enlarges this Rect by the specified amount.
Overload List
Overload | Description
Inflate(Double,Double) | Enlarges this Rect by the specified amount.
Inflate(Size) | Enlarges this Rect by the specified amount.
Inflate(Rect,Single,Single) | Creates and returns an enlarged copy of the specified Rect structure. The copy is enlarged by the specified amount. The original Rect structure remains unmodified.
See Also

Reference

Rect Structure
Rect Members


Inflate(Double,Double) Method

Inflate(Double,Double) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Inflate Method : Inflate(Double,Double) Method
The amount to inflate this Rect horizontally.
The amount to inflate this Rect vertically.
Enlarges this Rect by the specified amount.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Inflate( _
   ByVal x As System.Double, _
   ByVal y As System.Double _
) As Rect
public Rect Inflate(
   System.double x,
   System.double y
)

Parameters

x
The amount to inflate this Rect horizontally.
y
The amount to inflate this Rect vertically.
See Also

Reference

Rect Structure
Rect Members
Overload List


Inflate(Size) Method

Inflate(Size) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Inflate Method : Inflate(Size) Method
The amount to inflate this rectangle.
Enlarges this Rect by the specified amount.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Inflate( _
   ByVal size As Size _
) As Rect
public Rect Inflate(
   Size size
)

Parameters

size
The amount to inflate this rectangle.
See Also

Reference

Rect Structure
Rect Members
Overload List


Inflate(Rect,Single,Single) Method

Inflate(Rect,Single,Single) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Inflate Method : Inflate(Rect,Single,Single) Method
The Rect with which to start. This rectangle is not modified.
The amount to inflate the rectangle horizontally.
The amount to inflate the rectangle vertically.
Creates and returns an enlarged copy of the specified Rect structure. The copy is enlarged by the specified amount. The original Rect structure remains unmodified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Inflate( _
   ByVal rect As Rect, _
   ByVal x As System.Single, _
   ByVal y As System.Single _
) As Rect
public static Rect Inflate(
   Rect rect,
   System.float x,
   System.float y
)

Parameters

rect
The Rect with which to start. This rectangle is not modified.
x
The amount to inflate the rectangle horizontally.
y
The amount to inflate the rectangle vertically.

Return Value

Rect.
See Also

Reference

Rect Structure
Rect Members
Overload List


Intersect Method (Rect)

Intersect Method (Rect)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Intersect Method
Replaces this Rect with the intersection of itself and the specified Rect.
Overload List
Overload | Description
Intersect(Rect) | Replaces this Rect with the intersection of itself and the specified Rect.
Intersect(Rect,Rect) | Returns a third Rect structure that represents the intersection of two other Rect structures. If there is no intersection, an empty Rect is returned.
See Also

Reference

Rect Structure
Rect Members


Intersect(Rect) Method

Intersect(Rect) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Intersect Method : Intersect(Rect) Method
The Rect with which to intersect.
Replaces this Rect with the intersection of itself and the specified Rect.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Intersect( _
   ByVal rect As Rect _
) As Rect
public Rect Intersect(
   Rect rect
)

Parameters

rect
The Rect with which to intersect.
See Also

Reference

Rect Structure
Rect Members
Overload List


Intersect(Rect,Rect) Method

Intersect(Rect,Rect) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Intersect Method : Intersect(Rect,Rect) Method
A rectangle to intersect.
A rectangle to intersect.
Returns a third Rect structure that represents the intersection of two other Rect structures. If there is no intersection, an empty Rect is returned.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Intersect( _
   ByVal a As Rect, _
   ByVal b As Rect _
) As Rect
public static Rect Intersect(
   Rect a,
   Rect b
)

Parameters

a
A rectangle to intersect.
b
A rectangle to intersect.

Return Value

Rect.
See Also

Reference

Rect Structure
Rect Members
Overload List


IntersectsWith Method (Rect)

IntersectsWith Method (Rect)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : IntersectsWith Method
The rectangle to test.
Determines if this rectangle intersects with specified rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IntersectsWith( _
   ByVal rect As Rect _
) As System.Boolean
public System.bool IntersectsWith(
   Rect rect
)

Parameters

rect
The rectangle to test.

Return Value

This method returns true if there is any intersection, otherwise false.
See Also

Reference

Rect Structure
Rect Members


Offset Method (Rect)

Offset Method (Rect)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Offset Method
Adjusts the location of this rectangle by the specified amount.
Overload List
Overload | Description
Offset(Point) | Adjusts the location of this rectangle by the specified amount.
Offset(Double,Double) | Adjusts the location of this rectangle by the specified amount.
See Also

Reference

Rect Structure
Rect Members


Offset(Point) Method

Offset(Point) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Offset Method : Offset(Point) Method
Amount to offset the location.
Adjusts the location of this rectangle by the specified amount.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Offset( _
   ByVal pos As Point _
) As Rect
public Rect Offset(
   Point pos
)

Parameters

pos
Amount to offset the location.

Return Value

Rect.
See Also

Reference

Rect Structure
Rect Members
Overload List


Offset(Double,Double) Method

Offset(Double,Double) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Offset Method : Offset(Double,Double) Method
The horizontal offset.
The vertical offset.
Adjusts the location of this rectangle by the specified amount.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Offset( _
   ByVal x As System.Double, _
   ByVal y As System.Double _
) As Rect
public Rect Offset(
   System.double x,
   System.double y
)

Parameters

x
The horizontal offset.
y
The vertical offset.
See Also

Reference

Rect Structure
Rect Members
Overload List


Scale Method (Rect)

Scale Method (Rect)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Scale Method
Scales the rectangle by specified scale factor.
Overload List
Overload | Description
Scale(Double) | Scales the rectangle by specified scale factor.
Scale(Double,Double) | Scales the rectangle by specified scale factors.
See Also

Reference

Rect Structure
Rect Members


Scale(Double) Method

Scale(Double) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Scale Method : Scale(Double) Method
Scales the rectangle by specified scale factor.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Scale( _
   ByVal scaleFactor As System.Double _
) As Rect
public Rect Scale(
   System.double scaleFactor
)

Parameters

scaleFactor
See Also

Reference

Rect Structure
Rect Members
Overload List


Scale(Double,Double) Method

Scale(Double,Double) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Scale Method : Scale(Double,Double) Method
Scales the rectangle by specified scale factors.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Scale( _
   ByVal scaleX As System.Double, _
   ByVal scaleY As System.Double _
) As Rect
public Rect Scale(
   System.double scaleX,
   System.double scaleY
)

Parameters

scaleX
scaleY
See Also

Reference

Rect Structure
Rect Members
Overload List


ToString Method (Rect)

ToString Method (Rect)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : ToString Method
Returns a System.String that represents this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()
See Also

Reference

Rect Structure
Rect Members


Union Method (Rect)

Union Method (Rect)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Union Method
A rectangle to union.
A rectangle to union.
Creates a Rect structure that contains the union of two Rect structures.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function Union( _
   ByVal a As Rect, _
   ByVal b As Rect _
) As Rect
public static Rect Union(
   Rect a,
   Rect b
)

Parameters

a
A rectangle to union.
b
A rectangle to union.

Return Value

A rectangle that bounds the union of the two rectangles.
See Also

Reference

Rect Structure
Rect Members


Rect Structure Properties

Rect Structure Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : Rect Structure

For a list of all members of this type, see Rect members.

Public Properties
 | Name | Description
Public Property | Bottom | Gets the y-coordinate of the bottom edge of this rectangle.
Public Property | Height | Gets or sets the height of this rectangle.
Public Property | IsEmpty | Tests whether the size of this rectangle less or equal 0.
Public Property | Left | Gets the x-coordinate of the left edge of this rectangle.
Public Property | Location | Gets or sets the coordinates of the upper-left corner of this rectangle.
Public Property | Right | Gets the x-coordinate of the right edge of this rectangle.
Public Property | Size | Gets or sets the size of this rectangle.
Public Property | Top | Gets the y-coordinate of the top edge of this rectangle.
Public Property | Width | Gets or sets the width of this rectangle.
Public Property | X | Gets or sets the x-coordinate of the upper-left corner of this rectangle.
Public Property | Y | Gets or sets the y-coordinate of the upper-left corner of this rectangle.
Top
See Also

Reference

Rect Structure
GrapeCity.Viewer.Common Namespace


Bottom Property (Rect)

Bottom Property (Rect)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Bottom Property
Gets the y-coordinate of the bottom edge of this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Bottom As System.Double
public System.double Bottom {get;}
See Also

Reference

Rect Structure
Rect Members


Height Property (Rect)

Height Property (Rect)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Height Property
Gets or sets the height of this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Height As System.Double
public System.double Height {get;}
See Also

Reference

Rect Structure
Rect Members


IsEmpty Property (Rect)

IsEmpty Property (Rect)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : IsEmpty Property
Tests whether the size of this rectangle less or equal 0.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsEmpty As System.Boolean
public System.bool IsEmpty {get;}
See Also

Reference

Rect Structure
Rect Members


Left Property (Rect)

Left Property (Rect)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Left Property
Gets the x-coordinate of the left edge of this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Left As System.Double
public System.double Left {get;}
See Also

Reference

Rect Structure
Rect Members


Location Property (Rect)

Location Property (Rect)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Location Property
Gets or sets the coordinates of the upper-left corner of this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Location As Point
public Point Location {get;}

Property Value

The location.
See Also

Reference

Rect Structure
Rect Members


Right Property (Rect)

Right Property (Rect)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Right Property
Gets the x-coordinate of the right edge of this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Right As System.Double
public System.double Right {get;}
See Also

Reference

Rect Structure
Rect Members


Size Property (Rect)

Size Property (Rect)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Size Property
Gets or sets the size of this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Size As Size
public Size Size {get;}

Property Value

The size.
See Also

Reference

Rect Structure
Rect Members


Top Property (Rect)

Top Property (Rect)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Top Property
Gets the y-coordinate of the top edge of this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Top As System.Double
public System.double Top {get;}
See Also

Reference

Rect Structure
Rect Members


Width Property (Rect)

Width Property (Rect)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Width Property
Gets or sets the width of this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Width As System.Double
public System.double Width {get;}
See Also

Reference

Rect Structure
Rect Members


X Property (Rect)

X Property (Rect)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : X Property
Gets or sets the x-coordinate of the upper-left corner of this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property X As System.Double
public System.double X {get;}

Property Value

The x.
See Also

Reference

Rect Structure
Rect Members


Y Property (Rect)

Y Property (Rect)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Y Property
Gets or sets the y-coordinate of the upper-left corner of this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Y As System.Double
public System.double Y {get;}

Property Value

The y.
See Also

Reference

Rect Structure
Rect Members


Rect Structure Fields

Rect Structure Fields

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : Rect Structure

For a list of all members of this type, see Rect members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty |
Top
See Also

Reference

Rect Structure
GrapeCity.Viewer.Common Namespace


Empty Field (Rect)

Empty Field (Rect)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Empty Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Empty As Rect
public static readonly Rect Empty
See Also

Reference

Rect Structure
Rect Members


Size Structure

Size Structure
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : Size Structure
Platform aware Size structure
Object Model
Size Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure Size
   Inherits System.ValueType
public struct Size : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Viewer.Common.Size

See Also

Reference

Size Members
GrapeCity.Viewer.Common Namespace


Size Structure Members

Size Structure Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : Size Structure

The following tables list the members exposed by Size.

Public Constructors
 | Name | Description
Public Constructor | Size Constructor | Initializes a new instance of the Size struct.
Top
Public Properties
 | Name | Description
static (Shared in Visual Basic) | Empty | Gets the size with zero width and height.
Public Property | Height | Gets the height.
Public Property | Width | Gets the width.
Top
Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Checks whether this size equals to specified.
Public Method | GetHashCode | Returns a hash code for this instance.
Public Method | Scale | Scales the size by specified values.
Public Method | ToString | Returns a System.String that represents this instance.
Top
Public Operators
public Operator Addition | Enlarge the size by specified value.
public Operator Equality | Checks whether the two sizes are equals.
public Operator Inequality | Check whether the two sizes are not equals.
public Operator Multiplication | Scales the size by specified value
Top
See Also

Reference

Size Structure
GrapeCity.Viewer.Common Namespace


Size Constructor

Size Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Size Constructor
Initializes a new instance of the Size struct.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal width As System.Double, _
   ByVal height As System.Double _
)
public Size(
   System.double width,
   System.double height
)

Parameters

width
height
See Also

Reference

Size Structure
Size Members


Size Structure Methods

Size Structure Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : Size Structure

For a list of all members of this type, see Size members.

Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Checks whether this size equals to specified.
Public Method | GetHashCode | Returns a hash code for this instance.
Public Method | Scale | Scales the size by specified values.
Public Method | ToString | Returns a System.String that represents this instance.
Top
See Also

Reference

Size Structure
GrapeCity.Viewer.Common Namespace


Equals Method (Size)

Equals Method (Size)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Equals Method
Checks whether this size equals to specified.
Overload List
Overload | Description
Equals(Object) |
Equals(Size) | Checks whether this size equals to specified.
See Also

Reference

Size Structure
Size Members


Equals(Object) Method

Equals(Object) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure > Equals Method : Equals(Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
See Also

Reference

Size Structure
Size Members
Overload List


Equals(Size) Method

Equals(Size) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure > Equals Method : Equals(Size) Method
Checks whether this size equals to specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Equals( _
   ByVal other As Size _
) As System.Boolean
public System.bool Equals(
   Size other
)

Parameters

other
See Also

Reference

Size Structure
Size Members
Overload List


GetHashCode Method (Size)

GetHashCode Method (Size)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : GetHashCode Method
Returns a hash code for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

Size Structure
Size Members


Scale Method (Size)

Scale Method (Size)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Scale Method
The width scaling factor.
The height scaling factor.
Scales the size by specified values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Scale( _
   ByVal factorX As System.Double, _
   ByVal factorY As System.Double _
) As Size
public Size Scale(
   System.double factorX,
   System.double factorY
)

Parameters

factorX
The width scaling factor.
factorY
The height scaling factor.

Return Value

Size.
See Also

Reference

Size Structure
Size Members


ToString Method (Size)

ToString Method (Size)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : ToString Method
Returns a System.String that represents this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()
See Also

Reference

Size Structure
Size Members


Size Structure Properties

Size Structure Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : Size Structure

For a list of all members of this type, see Size members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | Empty | Gets the size with zero width and height.
Public Property | Height | Gets the height.
Public Property | Width | Gets the width.
Top
See Also

Reference

Size Structure
GrapeCity.Viewer.Common Namespace


Empty Property (Size)

Empty Property (Size)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Empty Property
Gets the size with zero width and height.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property Empty As Size
public static Size Empty {get;}
See Also

Reference

Size Structure
Size Members


Height Property (Size)

Height Property (Size)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Height Property
Gets the height.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Height As System.Double
public System.double Height {get;}
See Also

Reference

Size Structure
Size Members


Width Property (Size)

Width Property (Size)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Width Property
Gets the width.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Width As System.Double
public System.double Width {get;}
See Also

Reference

Size Structure
Size Members


Addition Operator (Size)

Addition Operator (Size)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Addition Operator
The size to enlarge.
The offset.
Enlarge the size by specified value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator +( _
   ByVal size As Size, _
   ByVal offset As Size _
) As Size
public Size operator +(
   Size size,
   Size offset
)

Parameters

size
The size to enlarge.
offset
The offset.
See Also

Reference

Size Structure
Size Members


Equality Operator (Size)

Equality Operator (Size)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Equality Operator
Checks whether the two sizes are equals.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator =( _
   ByVal s1 As Size, _
   ByVal s2 As Size _
) As System.Boolean
public System.bool operator ==(
   Size s1,
   Size s2
)

Parameters

s1
s2
See Also

Reference

Size Structure
Size Members


Inequality Operator (Size)

Inequality Operator (Size)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Inequality Operator
Check whether the two sizes are not equals.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator <>( _
   ByVal s1 As Size, _
   ByVal s2 As Size _
) As System.Boolean
public System.bool operator !=(
   Size s1,
   Size s2
)

Parameters

s1
s2
See Also

Reference

Size Structure
Size Members


Multiplication Operator (Size)

Multiplication Operator (Size)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Multiplication Operator
Scales the size by specified value
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator *( _
   ByVal size As Size, _
   ByVal factor As System.Double _
) As Size
public Size operator *(
   Size size,
   System.double factor
)

Parameters

size
factor
See Also

Reference

Size Structure
Size Members


IApplicationContext Interface

IApplicationContext Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IApplicationContext Interface
Provides access to different services and factories
Object Model
IApplicationContext Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IApplicationContext
public interface IApplicationContext
See Also

Reference

IApplicationContext Members
GrapeCity.Viewer.Common Namespace


IApplicationContext Interface Members

IApplicationContext Interface Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IApplicationContext Interface

The following tables list the members exposed by IApplicationContext.

Public Properties
 | Name | Description
Property | Context | Gets the synchronization context.
Property | ServiceContainer | Gets service container
Top
Public Methods
 | Name | Description
Method | CreateRenderer | Overloaded. Creates page renderer for specific document
Method | CreateReport | Creates loader for documents with specific formats
Top
See Also

Reference

IApplicationContext Interface
GrapeCity.Viewer.Common Namespace


IApplicationContext Interface Methods

IApplicationContext Interface Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IApplicationContext Interface

For a list of all members of this type, see IApplicationContext members.

Public Methods
 | Name | Description
Method | CreateRenderer | Overloaded. Creates page renderer for specific document
Method | CreateReport | Creates loader for documents with specific formats
Top
See Also

Reference

IApplicationContext Interface
GrapeCity.Viewer.Common Namespace


CreateRenderer Method (IApplicationContext)

CreateRenderer Method (IApplicationContext)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IApplicationContext Interface : CreateRenderer Method
Creates page renderer for specific document
Overload List
Overload | Description
CreateRenderer(DocumentModel) | Creates page renderer for specific document
CreateRenderer(DocumentModel,DeviceKind) | Creates the renderer for specific document considering specific target device kind.
See Also

Reference

IApplicationContext Interface
IApplicationContext Members


CreateRenderer(DocumentModel) Method

CreateRenderer(DocumentModel) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IApplicationContext Interface > CreateRenderer Method : CreateRenderer(DocumentModel) Method
Document for rendering
Creates page renderer for specific document
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function CreateRenderer( _
   ByVal document As DocumentModel _
) As IDocumentRenderer
IDocumentRenderer CreateRenderer(
   DocumentModel document
)

Parameters

document
Document for rendering

Return Value

Newly created renderer
See Also

Reference

IApplicationContext Interface
IApplicationContext Members
Overload List


CreateRenderer(DocumentModel,DeviceKind) Method

CreateRenderer(DocumentModel,DeviceKind) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IApplicationContext Interface > CreateRenderer Method : CreateRenderer(DocumentModel,DeviceKind) Method
The document model.
The target device kind.
Creates the renderer for specific document considering specific target device kind.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function CreateRenderer( _
   ByVal document As DocumentModel, _
   ByVal device As DeviceKind _
) As IDocumentRenderer
IDocumentRenderer CreateRenderer(
   DocumentModel document,
   DeviceKind device
)

Parameters

document
The document model.
device
The target device kind.
See Also

Reference

IApplicationContext Interface
IApplicationContext Members
Overload List


CreateReport Method (IApplicationContext)

CreateReport Method (IApplicationContext)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IApplicationContext Interface : CreateReport Method
Format of the document
Creates loader for documents with specific formats
Syntax
  • Visual Basic
  • C#
'Declaration

Function CreateReport( _
   ByVal format As DocumentFormat _
) As ReportModelBase
ReportModelBase CreateReport(
   DocumentFormat format
)

Parameters

format
Format of the document

Return Value

Created loader
See Also

Reference

IApplicationContext Interface
IApplicationContext Members


IApplicationContext Interface Properties

IApplicationContext Interface Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IApplicationContext Interface

For a list of all members of this type, see IApplicationContext members.

Public Properties
 | Name | Description
Property | Context | Gets the synchronization context.
Property | ServiceContainer | Gets service container
Top
See Also

Reference

IApplicationContext Interface
GrapeCity.Viewer.Common Namespace


Context Property (IApplicationContext)

Context Property (IApplicationContext)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IApplicationContext Interface : Context Property
Gets the synchronization context.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Context As System.Threading.SynchronizationContext
System.Threading.SynchronizationContext Context {get;}
See Also

Reference

IApplicationContext Interface
IApplicationContext Members


ServiceContainer Property (IApplicationContext)

ServiceContainer Property (IApplicationContext)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IApplicationContext Interface : ServiceContainer Property
Gets service container
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ServiceContainer As IServiceContainer
IServiceContainer ServiceContainer {get;}
See Also

Reference

IApplicationContext Interface
IApplicationContext Members


ICommand Interface

ICommand Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : ICommand Interface
Defines the contract for commanding, using the same contract as used in WPF.
Object Model
ICommand Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ICommand
public interface ICommand
See Also

Reference

ICommand Members
GrapeCity.Viewer.Common Namespace


ICommand Interface Members

ICommand Interface Members
Methods Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : ICommand Interface

The following tables list the members exposed by ICommand.

Public Methods
 | Name | Description
Method | CanExecute | Defines the method that determines whether the command can execute in its current state.
Method | Execute | Defines the method to be called when the command is invoked.
Top
Public Events
 | Name | Description
Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute.
Top
See Also

Reference

ICommand Interface
GrapeCity.Viewer.Common Namespace


ICommand Interface Methods

ICommand Interface Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : ICommand Interface

For a list of all members of this type, see ICommand members.

Public Methods
 | Name | Description
Method | CanExecute | Defines the method that determines whether the command can execute in its current state.
Method | Execute | Defines the method to be called when the command is invoked.
Top
See Also

Reference

ICommand Interface
GrapeCity.Viewer.Common Namespace


CanExecute Method (ICommand)

CanExecute Method (ICommand)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ICommand Interface : CanExecute Method
Data used by the command. If the command does not require data to be passed, this object can be set to null.
Defines the method that determines whether the command can execute in its current state.
Syntax
  • Visual Basic
  • C#
'Declaration

Function CanExecute( _
   ByVal parameter As System.Object _
) As System.Boolean
System.bool CanExecute(
   System.object parameter
)

Parameters

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.
See Also

Reference

ICommand Interface
ICommand Members


Execute Method (ICommand)

Execute Method (ICommand)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ICommand Interface : Execute Method
Data used by the command. If the command does not require data to be passed, this object can be set to null.
Defines the method to be called when the command is invoked.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Execute( _
   ByVal parameter As System.Object _
)
void Execute(
   System.object parameter
)

Parameters

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.
See Also

Reference

ICommand Interface
ICommand Members


ICommand Interface Events

ICommand Interface Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : ICommand Interface

For a list of all members of this type, see ICommand members.

Public Events
 | Name | Description
Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute.
Top
See Also

Reference

ICommand Interface
GrapeCity.Viewer.Common Namespace


CanExecuteChanged Event (ICommand)

CanExecuteChanged Event (ICommand)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ICommand Interface : CanExecuteChanged Event
Occurs when changes occur that affect whether the command should execute.
Syntax
  • Visual Basic
  • C#
'Declaration

Event CanExecuteChanged As System.EventHandler
event System.EventHandler CanExecuteChanged
See Also

Reference

ICommand Interface
ICommand Members


ICopySelectionService Interface

ICopySelectionService Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : ICopySelectionService Interface
Base interface for copy operations
Object Model
ICopySelectionService Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ICopySelectionService
public interface ICopySelectionService
See Also

Reference

ICopySelectionService Members
GrapeCity.Viewer.Common Namespace


ICopySelectionService Interface Members

ICopySelectionService Interface Members
Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : ICopySelectionService Interface

The following tables list the members exposed by ICopySelectionService.

Public Methods
 | Name | Description
Method | CopySelection | Copies given selection into platform specific storage
Method | CopyToClipBoard | Copies given text into clipboard
Top
See Also

Reference

ICopySelectionService Interface
GrapeCity.Viewer.Common Namespace


ICopySelectionService Interface Methods

ICopySelectionService Interface Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : ICopySelectionService Interface

For a list of all members of this type, see ICopySelectionService members.

Public Methods
 | Name | Description
Method | CopySelection | Copies given selection into platform specific storage
Method | CopyToClipBoard | Copies given text into clipboard
Top
See Also

Reference

ICopySelectionService Interface
GrapeCity.Viewer.Common Namespace


CopySelection Method (ICopySelectionService)

CopySelection Method (ICopySelectionService)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ICopySelectionService Interface : CopySelection Method
Copies given selection into platform specific storage
Syntax
  • Visual Basic
  • C#
'Declaration

Sub CopySelection( _
   ByVal selection As DocumentSelection _
)
void CopySelection(
   DocumentSelection selection
)

Parameters

selection
See Also

Reference

ICopySelectionService Interface
ICopySelectionService Members


CopyToClipBoard Method (ICopySelectionService)

CopyToClipBoard Method (ICopySelectionService)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ICopySelectionService Interface : CopyToClipBoard Method
Copies given text into clipboard
Syntax
  • Visual Basic
  • C#
'Declaration

Sub CopyToClipBoard( _
   ByVal text As System.String _
)
void CopyToClipBoard(
   System.string text
)

Parameters

text
See Also

Reference

ICopySelectionService Interface
ICopySelectionService Members


IDelegateCommand Interface

IDelegateCommand Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDelegateCommand Interface
Delegated command interface
Object Model
IDelegateCommand Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDelegateCommand
   Inherits ICommand
public interface IDelegateCommand : ICommand
See Also

Reference

IDelegateCommand Members
GrapeCity.Viewer.Common Namespace


IDelegateCommand Interface Members

IDelegateCommand Interface Members
Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDelegateCommand Interface

The following tables list the members exposed by IDelegateCommand.

Public Methods
 | Name | Description
Method | CanExecute | Defines the method that determines whether the command can execute in its current state. (Inherited from GrapeCity.Viewer.Common.ICommand)
Method | Execute | Defines the method to be called when the command is invoked. (Inherited from GrapeCity.Viewer.Common.ICommand)
Method | RaiseCanExecuteChanged | Raises CanExecuteChanged event
Top
See Also

Reference

IDelegateCommand Interface
GrapeCity.Viewer.Common Namespace


IDelegateCommand Interface Methods

IDelegateCommand Interface Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDelegateCommand Interface

For a list of all members of this type, see IDelegateCommand members.

Public Methods
 | Name | Description
Method | CanExecute | Defines the method that determines whether the command can execute in its current state. (Inherited from GrapeCity.Viewer.Common.ICommand)
Method | Execute | Defines the method to be called when the command is invoked. (Inherited from GrapeCity.Viewer.Common.ICommand)
Method | RaiseCanExecuteChanged | Raises CanExecuteChanged event
Top
See Also

Reference

IDelegateCommand Interface
GrapeCity.Viewer.Common Namespace


RaiseCanExecuteChanged Method (IDelegateCommand)

RaiseCanExecuteChanged Method (IDelegateCommand)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IDelegateCommand Interface : RaiseCanExecuteChanged Method
Raises CanExecuteChanged event
Syntax
  • Visual Basic
  • C#
'Declaration

Sub RaiseCanExecuteChanged()
void RaiseCanExecuteChanged()
See Also

Reference

IDelegateCommand Interface
IDelegateCommand Members


IDocumentLoader Interface

IDocumentLoader Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDocumentLoader Interface
Object Model
IDocumentLoader Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDocumentLoader
public interface IDocumentLoader
See Also

Reference

IDocumentLoader Members
GrapeCity.Viewer.Common Namespace


IDocumentLoader Interface Members

IDocumentLoader Interface Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDocumentLoader Interface

The following tables list the members exposed by IDocumentLoader.

Public Properties
 | Name | Description
Property | DocumentFormat |
Top
Public Methods
 | Name | Description
Method | Load |
Top
See Also

Reference

IDocumentLoader Interface
GrapeCity.Viewer.Common Namespace


IDocumentLoader Interface Methods

IDocumentLoader Interface Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDocumentLoader Interface

For a list of all members of this type, see IDocumentLoader members.

Public Methods
 | Name | Description
Method | Load |
Top
See Also

Reference

IDocumentLoader Interface
GrapeCity.Viewer.Common Namespace


Load Method (IDocumentLoader)

Load Method (IDocumentLoader)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IDocumentLoader Interface : Load Method
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Load( _
   ByVal obj As ILoadableFromFileAndStream _
)
void Load(
   ILoadableFromFileAndStream obj
)

Parameters

obj
See Also

Reference

IDocumentLoader Interface
IDocumentLoader Members


IDocumentLoader Interface Properties

IDocumentLoader Interface Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDocumentLoader Interface

For a list of all members of this type, see IDocumentLoader members.

Public Properties
 | Name | Description
Property | DocumentFormat |
Top
See Also

Reference

IDocumentLoader Interface
GrapeCity.Viewer.Common Namespace


DocumentFormat Property (IDocumentLoader)

DocumentFormat Property (IDocumentLoader)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IDocumentLoader Interface : DocumentFormat Property
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DocumentFormat As DocumentFormat
DocumentFormat DocumentFormat {get;}
See Also

Reference

IDocumentLoader Interface
IDocumentLoader Members


IDocumentRenderer Interface

IDocumentRenderer Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDocumentRenderer Interface
Base interface for Document renderers
Object Model
IDocumentRenderer Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDocumentRenderer
public interface IDocumentRenderer
See Also

Reference

IDocumentRenderer Members
GrapeCity.Viewer.Common Namespace


IDocumentRenderer Interface Members

IDocumentRenderer Interface Members
Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDocumentRenderer Interface

The following tables list the members exposed by IDocumentRenderer.

Public Methods
 | Name | Description
Method | RenderPage | Renders page from current document
Top
See Also

Reference

IDocumentRenderer Interface
GrapeCity.Viewer.Common Namespace


IDocumentRenderer Interface Methods

IDocumentRenderer Interface Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDocumentRenderer Interface

For a list of all members of this type, see IDocumentRenderer members.

Public Methods
 | Name | Description
Method | RenderPage | Renders page from current document
Top
See Also

Reference

IDocumentRenderer Interface
GrapeCity.Viewer.Common Namespace


RenderPage Method (IDocumentRenderer)

RenderPage Method (IDocumentRenderer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IDocumentRenderer Interface : RenderPage Method
Index of the page to render
Renders page from current document
Syntax
  • Visual Basic
  • C#
'Declaration

Function RenderPage( _
   ByVal index As System.Integer _
) As PageView
PageView RenderPage(
   System.int index
)

Parameters

index
Index of the page to render

Return Value

Rendered page view
See Also

Reference

IDocumentRenderer Interface
IDocumentRenderer Members


IDocumentRendererFactory Interface

IDocumentRendererFactory Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDocumentRendererFactory Interface
IDocumentRenderer factory interface.
Object Model
IDocumentRendererFactory Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDocumentRendererFactory
public interface IDocumentRendererFactory
See Also

Reference

IDocumentRendererFactory Members
GrapeCity.Viewer.Common Namespace


IDocumentRendererFactory Interface Members

IDocumentRendererFactory Interface Members
Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDocumentRendererFactory Interface

The following tables list the members exposed by IDocumentRendererFactory.

Public Methods
 | Name | Description
Method | Create | Overloaded. Creates the IDocumentRenderer for specified document with specified context.
Top
See Also

Reference

IDocumentRendererFactory Interface
GrapeCity.Viewer.Common Namespace


IDocumentRendererFactory Interface Methods

IDocumentRendererFactory Interface Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDocumentRendererFactory Interface

For a list of all members of this type, see IDocumentRendererFactory members.

Public Methods
 | Name | Description
Method | Create | Overloaded. Creates the IDocumentRenderer for specified document with specified context.
Top
See Also

Reference

IDocumentRendererFactory Interface
GrapeCity.Viewer.Common Namespace


Create Method (IDocumentRendererFactory)

Create Method (IDocumentRendererFactory)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IDocumentRendererFactory Interface : Create Method
Creates the IDocumentRenderer for specified document with specified context.
Overload List
Overload | Description
Create(IApplicationContext,DocumentModel) | Creates the IDocumentRenderer for specified document with specified context.
Create(IApplicationContext,DocumentModel,DeviceKind) | Creates the IDocumentRenderer for specified document with specified context and target device kind.
See Also

Reference

IDocumentRendererFactory Interface
IDocumentRendererFactory Members


Create(IApplicationContext,DocumentModel) Method

Create(IApplicationContext,DocumentModel) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IDocumentRendererFactory Interface > Create Method : Create(IApplicationContext,DocumentModel) Method
The application context.
The document model.
Creates the IDocumentRenderer for specified document with specified context.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function Create( _
   ByVal context As IApplicationContext, _
   ByVal document As DocumentModel _
) As IDocumentRenderer
IDocumentRenderer Create(
   IApplicationContext context,
   DocumentModel document
)

Parameters

context
The application context.
document
The document model.
See Also

Reference

IDocumentRendererFactory Interface
IDocumentRendererFactory Members
Overload List


Create(IApplicationContext,DocumentModel,DeviceKind) Method

Create(IApplicationContext,DocumentModel,DeviceKind) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IDocumentRendererFactory Interface > Create Method : Create(IApplicationContext,DocumentModel,DeviceKind) Method
The application context.
The document model.
The target device.
Creates the IDocumentRenderer for specified document with specified context and target device kind.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function Create( _
   ByVal context As IApplicationContext, _
   ByVal document As DocumentModel, _
   ByVal device As DeviceKind _
) As IDocumentRenderer
IDocumentRenderer Create(
   IApplicationContext context,
   DocumentModel document,
   DeviceKind device
)

Parameters

context
The application context.
document
The document model.
device
The target device.
See Also

Reference

IDocumentRendererFactory Interface
IDocumentRendererFactory Members
Overload List


IHistoryApi Interface

IHistoryApi Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IHistoryApi Interface
This is public interface for user to work with HistoryService
Object Model
IHistoryApi Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IHistoryApi
public interface IHistoryApi
See Also

Reference

IHistoryApi Members
GrapeCity.Viewer.Common Namespace


IHistoryApi Interface Members

IHistoryApi Interface Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IHistoryApi Interface

The following tables list the members exposed by IHistoryApi.

Public Properties
 | Name | Description
Property | Count | Returns the number of page views in the history.
Property | Position | Gets the current page's position in the navigation history.
Top
Public Methods
 | Name | Description
Method | Clear | Clears the page views from the history.
Method | MoveNext | Navigates to the next page in the history.
Method | MovePrev | Navigates to the previous page in the view history.
Top
See Also

Reference

IHistoryApi Interface
GrapeCity.Viewer.Common Namespace


IHistoryApi Interface Methods

IHistoryApi Interface Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IHistoryApi Interface

For a list of all members of this type, see IHistoryApi members.

Public Methods
 | Name | Description
Method | Clear | Clears the page views from the history.
Method | MoveNext | Navigates to the next page in the history.
Method | MovePrev | Navigates to the previous page in the view history.
Top
See Also

Reference

IHistoryApi Interface
GrapeCity.Viewer.Common Namespace


Clear Method (IHistoryApi)

Clear Method (IHistoryApi)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IHistoryApi Interface : Clear Method
Clears the page views from the history.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Clear()
void Clear()
See Also

Reference

IHistoryApi Interface
IHistoryApi Members


MoveNext Method (IHistoryApi)

MoveNext Method (IHistoryApi)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IHistoryApi Interface : MoveNext Method
Navigates to the next page in the history.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub MoveNext()
void MoveNext()
See Also

Reference

IHistoryApi Interface
IHistoryApi Members


MovePrev Method (IHistoryApi)

MovePrev Method (IHistoryApi)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IHistoryApi Interface : MovePrev Method
Navigates to the previous page in the view history.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub MovePrev()
void MovePrev()
See Also

Reference

IHistoryApi Interface
IHistoryApi Members


IHistoryApi Interface Properties

IHistoryApi Interface Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IHistoryApi Interface

For a list of all members of this type, see IHistoryApi members.

Public Properties
 | Name | Description
Property | Count | Returns the number of page views in the history.
Property | Position | Gets the current page's position in the navigation history.
Top
See Also

Reference

IHistoryApi Interface
GrapeCity.Viewer.Common Namespace


Count Property (IHistoryApi)

Count Property (IHistoryApi)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IHistoryApi Interface : Count Property
Returns the number of page views in the history.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Count As System.Integer
System.int Count {get;}
See Also

Reference

IHistoryApi Interface
IHistoryApi Members


Position Property (IHistoryApi)

Position Property (IHistoryApi)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IHistoryApi Interface : Position Property
Gets the current page's position in the navigation history.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Position As System.Integer
System.int Position {get;}
See Also

Reference

IHistoryApi Interface
IHistoryApi Members


ILoadableFromFileAndStream Interface

ILoadableFromFileAndStream Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : ILoadableFromFileAndStream Interface
Object Model
ILoadableFromFileAndStream Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ILoadableFromFileAndStream
public interface ILoadableFromFileAndStream
See Also

Reference

ILoadableFromFileAndStream Members
GrapeCity.Viewer.Common Namespace


ILoadableFromFileAndStream Interface Members

ILoadableFromFileAndStream Interface Members
Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : ILoadableFromFileAndStream Interface

The following tables list the members exposed by ILoadableFromFileAndStream.

Public Methods
 | Name | Description
Method | LoadFromFile |
Method | LoadFromStream | Overloaded.
Top
See Also

Reference

ILoadableFromFileAndStream Interface
GrapeCity.Viewer.Common Namespace


ILoadableFromFileAndStream Interface Methods

ILoadableFromFileAndStream Interface Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : ILoadableFromFileAndStream Interface

For a list of all members of this type, see ILoadableFromFileAndStream members.

Public Methods
 | Name | Description
Method | LoadFromFile |
Method | LoadFromStream | Overloaded.
Top
See Also

Reference

ILoadableFromFileAndStream Interface
GrapeCity.Viewer.Common Namespace


LoadFromFile Method (ILoadableFromFileAndStream)

LoadFromFile Method (ILoadableFromFileAndStream)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ILoadableFromFileAndStream Interface : LoadFromFile Method
Syntax
  • Visual Basic
  • C#
'Declaration

Sub LoadFromFile( _
   ByVal f As System.IO.FileInfo _
)
void LoadFromFile(
   System.IO.FileInfo f
)

Parameters

f
See Also

Reference

ILoadableFromFileAndStream Interface
ILoadableFromFileAndStream Members


LoadFromStream Method (ILoadableFromFileAndStream)

LoadFromStream Method (ILoadableFromFileAndStream)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ILoadableFromFileAndStream Interface : LoadFromStream Method
Overload List
Overload | Description
LoadFromStream(Stream) |
LoadFromStream(Stream,Uri) |
See Also

Reference

ILoadableFromFileAndStream Interface
ILoadableFromFileAndStream Members


LoadFromStream(Stream) Method

LoadFromStream(Stream) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ILoadableFromFileAndStream Interface > LoadFromStream Method : LoadFromStream(Stream) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub LoadFromStream( _
   ByVal s As System.IO.Stream _
)
void LoadFromStream(
   System.IO.Stream s
)

Parameters

s
See Also

Reference

ILoadableFromFileAndStream Interface
ILoadableFromFileAndStream Members
Overload List


LoadFromStream(Stream,Uri) Method

LoadFromStream(Stream,Uri) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ILoadableFromFileAndStream Interface > LoadFromStream Method : LoadFromStream(Stream,Uri) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub LoadFromStream( _
   ByVal s As System.IO.Stream, _
   ByVal baseUri As System.Uri _
)
void LoadFromStream(
   System.IO.Stream s,
   System.Uri baseUri
)

Parameters

s
baseUri
See Also

Reference

ILoadableFromFileAndStream Interface
ILoadableFromFileAndStream Members
Overload List


INotifyCollectionChanged Interface

INotifyCollectionChanged Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : INotifyCollectionChanged Interface
Notifies listeners of dynamic changes to a collection, such as when items are added and removed, or the entire collection object is reset.
Object Model
INotifyCollectionChanged Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface INotifyCollectionChanged
public interface INotifyCollectionChanged
See Also

Reference

INotifyCollectionChanged Members
GrapeCity.Viewer.Common Namespace


INotifyCollectionChanged Interface Members

INotifyCollectionChanged Interface Members
Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : INotifyCollectionChanged Interface

The following tables list the members exposed by INotifyCollectionChanged.

Public Events
 | Name | Description
Event | CollectionChanged | Occurs when the items list of the collection has changed, or the collection is reset.
Top
See Also

Reference

INotifyCollectionChanged Interface
GrapeCity.Viewer.Common Namespace


INotifyCollectionChanged Interface Events

INotifyCollectionChanged Interface Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : INotifyCollectionChanged Interface

For a list of all members of this type, see INotifyCollectionChanged members.

Public Events
 | Name | Description
Event | CollectionChanged | Occurs when the items list of the collection has changed, or the collection is reset.
Top
See Also

Reference

INotifyCollectionChanged Interface
GrapeCity.Viewer.Common Namespace


CollectionChanged Event (INotifyCollectionChanged)

CollectionChanged Event (INotifyCollectionChanged)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > INotifyCollectionChanged Interface : CollectionChanged Event
Occurs when the items list of the collection has changed, or the collection is reset.
Syntax
  • Visual Basic
  • C#
'Declaration

Event CollectionChanged As NotifyCollectionChangedEventHandler
event NotifyCollectionChangedEventHandler CollectionChanged
See Also

Reference

INotifyCollectionChanged Interface
INotifyCollectionChanged Members


IOrientedPageView Interface

IOrientedPageView Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IOrientedPageView Interface
Interface to access orientation of the report page.
Object Model
IOrientedPageView Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IOrientedPageView
public interface IOrientedPageView
See Also

Reference

IOrientedPageView Members
GrapeCity.Viewer.Common Namespace


IOrientedPageView Interface Members

IOrientedPageView Interface Members
Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IOrientedPageView Interface

The following tables list the members exposed by IOrientedPageView.

Public Properties
 | Name | Description
Property | Orientation |
Top
See Also

Reference

IOrientedPageView Interface
GrapeCity.Viewer.Common Namespace


IOrientedPageView Interface Properties

IOrientedPageView Interface Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IOrientedPageView Interface

For a list of all members of this type, see IOrientedPageView members.

Public Properties
 | Name | Description
Property | Orientation |
Top
See Also

Reference

IOrientedPageView Interface
GrapeCity.Viewer.Common Namespace


Orientation Property (IOrientedPageView)

Orientation Property (IOrientedPageView)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IOrientedPageView Interface : Orientation Property
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Orientation As System.Nullable(Of Orientation)
System.Nullable<Orientation> Orientation {get;}
See Also

Reference

IOrientedPageView Interface
IOrientedPageView Members


IParameter Interface

IParameter Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IParameter Interface
Defines an object that can be used as a report parameter.
Object Model
IParameter Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IParameter
public interface IParameter
See Also

Reference

IParameter Members
GrapeCity.Viewer.Common Namespace


IParameter Interface Members

IParameter Interface Members
Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IParameter Interface

The following tables list the members exposed by IParameter.

Public Properties
 | Name | Description
Property | Name | Gets the name of the report parameter.
Property | Values | Gets the collection of zero or more values for the report parameter.
Top
See Also

Reference

IParameter Interface
GrapeCity.Viewer.Common Namespace


IParameter Interface Properties

IParameter Interface Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IParameter Interface

For a list of all members of this type, see IParameter members.

Public Properties
 | Name | Description
Property | Name | Gets the name of the report parameter.
Property | Values | Gets the collection of zero or more values for the report parameter.
Top
See Also

Reference

IParameter Interface
GrapeCity.Viewer.Common Namespace


Name Property (IParameter)

Name Property (IParameter)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IParameter Interface : Name Property
Gets the name of the report parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Name As System.String
System.string Name {get;}
See Also

Reference

IParameter Interface
IParameter Members


Values Property (IParameter)

Values Property (IParameter)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IParameter Interface : Values Property
Gets the collection of zero or more values for the report parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Values As System.Collections.Generic.IEnumerable(Of Object)
System.Collections.Generic.IEnumerable<object> Values {get;}
See Also

Reference

IParameter Interface
IParameter Members


IPrintService Interface

IPrintService Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IPrintService Interface
Object Model
IPrintService Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IPrintService
public interface IPrintService
See Also

Reference

IPrintService Members
GrapeCity.Viewer.Common Namespace


IPrintService Interface Members

IPrintService Interface Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IPrintService Interface

The following tables list the members exposed by IPrintService.

Public Properties
 | Name | Description
Property | CanPrint |
Top
Public Methods
 | Name | Description
Method | Print | Overloaded.
Top
See Also

Reference

IPrintService Interface
GrapeCity.Viewer.Common Namespace


IPrintService Interface Methods

IPrintService Interface Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IPrintService Interface

For a list of all members of this type, see IPrintService members.

Public Methods
 | Name | Description
Method | Print | Overloaded.
Top
See Also

Reference

IPrintService Interface
GrapeCity.Viewer.Common Namespace


Print Method (IPrintService)

Print Method (IPrintService)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IPrintService Interface : Print Method
Overload List
Overload | Description
Print(DocumentModel,ReportModelBase,IApplicationContext,Boolean,Boolean,Boolean) |
Print(DocumentModel,ReportModelBase,IApplicationContext,PrintingSettings) |
See Also

Reference

IPrintService Interface
IPrintService Members


Print(DocumentModel,ReportModelBase,IApplicationContext,Boolean,Boolean,Boolean) Method

Print(DocumentModel,ReportModelBase,IApplicationContext,Boolean,Boolean,Boolean) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IPrintService Interface > Print Method : Print(DocumentModel,ReportModelBase,IApplicationContext,Boolean,Boolean,Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function Print( _
   ByVal documentModel As DocumentModel, _
   ByVal reportModel As ReportModelBase, _
   ByVal context As IApplicationContext, _
   ByVal showPrintDialog As System.Boolean, _
   ByVal showPrintProgressDialog As System.Boolean, _
   ByVal usePrintingThread As System.Boolean _
) As System.Boolean
System.bool Print(
   DocumentModel documentModel,
   ReportModelBase reportModel,
   IApplicationContext context,
   System.bool showPrintDialog,
   System.bool showPrintProgressDialog,
   System.bool usePrintingThread
)

Parameters

documentModel
reportModel
context
showPrintDialog
showPrintProgressDialog
usePrintingThread
See Also

Reference

IPrintService Interface
IPrintService Members
Overload List


Print(DocumentModel,ReportModelBase,IApplicationContext,PrintingSettings) Method

Print(DocumentModel,ReportModelBase,IApplicationContext,PrintingSettings) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IPrintService Interface > Print Method : Print(DocumentModel,ReportModelBase,IApplicationContext,PrintingSettings) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function Print( _
   ByVal documentModel As DocumentModel, _
   ByVal reportModel As ReportModelBase, _
   ByVal context As IApplicationContext, _
   ByVal settings As PrintingSettings _
) As System.Boolean
System.bool Print(
   DocumentModel documentModel,
   ReportModelBase reportModel,
   IApplicationContext context,
   PrintingSettings settings
)

Parameters

documentModel
reportModel
context
settings
See Also

Reference

IPrintService Interface
IPrintService Members
Overload List


IPrintService Interface Properties

IPrintService Interface Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IPrintService Interface

For a list of all members of this type, see IPrintService members.

Public Properties
 | Name | Description
Property | CanPrint |
Top
See Also

Reference

IPrintService Interface
GrapeCity.Viewer.Common Namespace


CanPrint Property (IPrintService)

CanPrint Property (IPrintService)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IPrintService Interface : CanPrint Property
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CanPrint As System.Boolean
System.bool CanPrint {get;}
See Also

Reference

IPrintService Interface
IPrintService Members


ISearchService Interface

ISearchService Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : ISearchService Interface
Base interface for search
Object Model
ISearchService Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ISearchService
public interface ISearchService
See Also

Reference

ISearchService Members
GrapeCity.Viewer.Common Namespace


ISearchService Interface Members

ISearchService Interface Members
Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : ISearchService Interface

The following tables list the members exposed by ISearchService.

Public Methods
 | Name | Description
Method | Find | Searches the document according to find options.
Top
See Also

Reference

ISearchService Interface
GrapeCity.Viewer.Common Namespace


ISearchService Interface Methods

ISearchService Interface Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : ISearchService Interface

For a list of all members of this type, see ISearchService members.

Public Methods
 | Name | Description
Method | Find | Searches the document according to find options.
Top
See Also

Reference

ISearchService Interface
GrapeCity.Viewer.Common Namespace


Find Method (ISearchService)

Find Method (ISearchService)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ISearchService Interface : Find Method
Searches the document according to find options.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Find( _
   ByVal document As DocumentModel, _
   ByVal findOptions As FindOptions, _
   ByVal startFrom As SearchResult, _
   ByVal maxCount As System.Integer, _
   ByVal handler As System.Action(Of DocumentModel,IEnumerable(Of SearchResult)) _
)
void Find(
   DocumentModel document,
   FindOptions findOptions,
   SearchResult startFrom,
   System.int maxCount,
   System.Action<DocumentModel,IEnumerable<SearchResult>> handler
)

Parameters

document
findOptions
startFrom
maxCount
handler
See Also

Reference

ISearchService Interface
ISearchService Members


IServiceContainer Interface

IServiceContainer Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IServiceContainer Interface
Provides a container for services.
Object Model
IServiceContainer Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IServiceContainer
public interface IServiceContainer
See Also

Reference

IServiceContainer Members
GrapeCity.Viewer.Common Namespace


IServiceContainer Interface Members

IServiceContainer Interface Members
Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IServiceContainer Interface

The following tables list the members exposed by IServiceContainer.

Public Methods
 | Name | Description
Method | AddService<T> | Adds the specified service to the service container.
Method | GetService<T> | Gets service from container
Method | RemoveService<T> | Removes the specified service type from the service container
Top
See Also

Reference

IServiceContainer Interface
GrapeCity.Viewer.Common Namespace


IServiceContainer Interface Methods

IServiceContainer Interface Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : IServiceContainer Interface

For a list of all members of this type, see IServiceContainer members.

Public Methods
 | Name | Description
Method | AddService<T> | Adds the specified service to the service container.
Method | GetService<T> | Gets service from container
Method | RemoveService<T> | Removes the specified service type from the service container
Top
See Also

Reference

IServiceContainer Interface
GrapeCity.Viewer.Common Namespace


AddService<T> Method (IServiceContainer)

AddService<T> Method (IServiceContainer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IServiceContainer Interface : AddService<T> Method
The type of service to add.
An instance of the service type to add. This object must implement or inherit from the type indicated by the serviceType parameter.
Adds the specified service to the service container.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub AddService(Of T)( _
   ByVal serviceInstance As T _
)
void AddService<T>(
   T serviceInstance
)

Parameters

serviceInstance
An instance of the service type to add. This object must implement or inherit from the type indicated by the serviceType parameter.

Type Parameters

T
The type of service to add.
See Also

Reference

IServiceContainer Interface
IServiceContainer Members


GetService<T> Method (IServiceContainer)

GetService<T> Method (IServiceContainer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IServiceContainer Interface : GetService<T> Method
Gets service from container
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService(Of T)() As T
T GetService<T>()

Type Parameters

T

Return Value

Service or null if service is not found
See Also

Reference

IServiceContainer Interface
IServiceContainer Members


RemoveService<T> Method (IServiceContainer)

RemoveService<T> Method (IServiceContainer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > IServiceContainer Interface : RemoveService<T> Method
The type of service to remove.
Removes the specified service type from the service container
Syntax
  • Visual Basic
  • C#
'Declaration

Sub RemoveService(Of T)()
void RemoveService<T>()

Type Parameters

T
The type of service to remove.
See Also

Reference

IServiceContainer Interface
IServiceContainer Members


NotifyCollectionChangedEventHandler Delegate

NotifyCollectionChangedEventHandler Delegate

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : NotifyCollectionChangedEventHandler Delegate
Represents the method that handles events that implement the System.Collections.Specialized.INotifyCollectionChanged.CollectionChanged event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub NotifyCollectionChangedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As NotifyCollectionChangedEventArgs _
)
public delegate void NotifyCollectionChangedEventHandler(
   System.object sender,
   NotifyCollectionChangedEventArgs e
)

Parameters

sender
e
See Also

Reference

NotifyCollectionChangedEventHandler Members
GrapeCity.Viewer.Common Namespace


GrapeCity.Viewer.Common.Model Namespace

GrapeCity.Viewer.Common.Model Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Viewer.Win.v10 Assembly : GrapeCity.Viewer.Common.Model Namespace
Classes
 | Class | Description
Class | ActiveModel | Base class for all active (notifies subscriber on state change) models
Class | ActiveModelListenExtensions | Implements notification propagation helpers
Class | BaseDocumentModelImpl | Base implementation of DocumentModel with ISearchableDocument and ISelectableDocument interfaces for page-based documents
Class | BitmapCachedDocumentModel | Aggresively caches pages in bitmaps
Class | DocumentModel | Represents base structure and behaviour for document models
Class | DocumentModel.TextItem | Base implementation for text item
Class | ExportFormatInfo | Export format info
Class | ExportOptions | Represents export settings
Class | FindOptions | Represents text-based search settings
Class | HighlightDocumentViewModel | Implement document-wise highlighting model.
Class | HighlightPage | Immutable page highlight view model
Class | ObservableExtensions | Extends Observable<T> by helper methods.
Class | ParameterizedReportExtensions | Helpers for reports with parameters.
Class | RelativeDatePart | Defines part of relative date for DateTime parameters
Class | ReportModelBase | Represents report instance
Class | ReportPaneModel | Model for report pane Model for report pane. This is a partial class contains only _zooms fild which has different definition in WPF project.
Class | RunOptions | "Run" command options
Class | SearchResult | Represents text search result. The instances of the class are immutable and do not implement INotifyPropertyChanged then
Class | TocTreeNode | Represents bookmarks tree node
Interfaces
 | Interface | Description
Interface | DocumentModel.IImageItem | Base implementation for image item
Interface | DocumentModel.IPage | Defines interface for document page
Interface | DocumentModel.IPageItem | Minimal part of report page
Interface | IDocumentConsumer |
Interface | IErrorHandler |
Interface | IExportableDocument | Allows document to support exports facility
Interface | IExportableReport | Report which supports the export
Interface | IPageDocument | Provides access to document structures
Interface | IParameterizedReport | Report with parameters
Interface | IReportParameter | Defines interface to report parameters
Interface | IReportParameterValue | Interface for report parameter value
Interface | IReportParameterWithRelativeDate | Defines interface to report parameters supported relative date
Interface | ISearchableDocument | Allows document to support text search facility
Interface | ISelectableDocument | Allows document to expose items that could be selected/highlighted/copied
Structures
 | Structure | Description
Structure | Bookmark | Represents bookmark
Structure | DocumentModel.PaperInfo | Represents paper information
Structure | DocumentSelection | Represents selected document items. Immutable object! This implementation is somewhat implementation bound since it treats selection as a collection of "page items" on particular page
Structure | ErrorInfo | Represents information about errors/exceptions
Structure | Frame | Represents selection area
Structure | HighlightArea | Identifies highlight area within a report page
Structure | Range | Arbitrary range implementation
Enumerations
 | Enumeration | Description
Enumeration | Dock | Specifies item alignment
Enumeration | ErrorInfo.Level |
Enumeration | ErrorState | Defines current parameter state
Enumeration | ExportType | Export types enum
Enumeration | HighlightArea.Type | Area type. Areas are rendered a bit differently depending on type
Enumeration | MouseMode | Specifies possible mouse modes
Enumeration | ReportParameterType | Gets the parameter's value data type
Enumeration | SidebarTabs | For reference only. Defined position of sidebar panel within sidebar (either tab index or accordion pane index)
Enumeration | TouchMode | Enable touch mode or not.
Enumeration | TouchModeButtonVisibility | Display Touch mode button on viewer's toolbar or not.
Enumeration | ViewType | Possible view modes of the viewer control
Enumeration | ZoomMode | Defined Zoom mode
See Also

Reference

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly


ActiveModel Class

ActiveModel Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ActiveModel Class
Base class for all active (notifies subscriber on state change) models
Object Model
ActiveModel Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class ActiveModel
public abstract class ActiveModel
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.Model.ActiveModel

See Also

Reference

ActiveModel Members
GrapeCity.Viewer.Common.Model Namespace


ActiveModel Class Members

ActiveModel Class Members
Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ActiveModel Class

The following tables list the members exposed by ActiveModel.

Public Events
 | Name | Description
Public Event | PropertyChanged |
Top
See Also

Reference

ActiveModel Class
GrapeCity.Viewer.Common.Model Namespace


ActiveModel Class Events

ActiveModel Class Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ActiveModel Class

For a list of all members of this type, see ActiveModel members.

Public Events
 | Name | Description
Public Event | PropertyChanged |
Top
See Also

Reference

ActiveModel Class
GrapeCity.Viewer.Common.Model Namespace


PropertyChanged Event (ActiveModel)

PropertyChanged Event (ActiveModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ActiveModel Class : PropertyChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PropertyChanged As System.ComponentModel.PropertyChangedEventHandler
public event System.ComponentModel.PropertyChangedEventHandler PropertyChanged
Event Data

The event handler receives an argument of type System.ComponentModel.PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
See Also

Reference

ActiveModel Class
ActiveModel Members


ActiveModelListenExtensions Class

ActiveModelListenExtensions Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ActiveModelListenExtensions Class
Implements notification propagation helpers
Object Model
ActiveModelListenExtensions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit NotInheritable Class ActiveModelListenExtensions
public static class ActiveModelListenExtensions
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.Model.ActiveModelListenExtensions

See Also

Reference

ActiveModelListenExtensions Members
GrapeCity.Viewer.Common.Model Namespace


ActiveModelListenExtensions Class Members

ActiveModelListenExtensions Class Members
Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ActiveModelListenExtensions Class

The following tables list the members exposed by ActiveModelListenExtensions.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | GetPropertyName<TI,TR> | Gets property name
static (Shared in Visual Basic) | Listen | Overloaded. Listens to any property changes
static (Shared in Visual Basic) | ListenCollection | Overloaded. Performs specific action on particular CollectionChanged event
static (Shared in Visual Basic) | Observe | Overloaded. More sofisticated changes listener implementation
static (Shared in Visual Basic) | ObserveList | Overloaded. Observed modifyable collection
static (Shared in Visual Basic) | ObserveRange<T> | Observes modifyable range of modifyable collection.
static (Shared in Visual Basic) | ObserveRangeOnStaticCollection<T> | Observes modifyable range of regulat items collection.
Top
See Also

Reference

ActiveModelListenExtensions Class
GrapeCity.Viewer.Common.Model Namespace


ActiveModelListenExtensions Class Methods

ActiveModelListenExtensions Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ActiveModelListenExtensions Class

For a list of all members of this type, see ActiveModelListenExtensions members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | GetPropertyName<TI,TR> | Gets property name
static (Shared in Visual Basic) | Listen | Overloaded. Listens to any property changes
static (Shared in Visual Basic) | ListenCollection | Overloaded. Performs specific action on particular CollectionChanged event
static (Shared in Visual Basic) | Observe | Overloaded. More sofisticated changes listener implementation
static (Shared in Visual Basic) | ObserveList | Overloaded. Observed modifyable collection
static (Shared in Visual Basic) | ObserveRange<T> | Observes modifyable range of modifyable collection.
static (Shared in Visual Basic) | ObserveRangeOnStaticCollection<T> | Observes modifyable range of regulat items collection.
Top
See Also

Reference

ActiveModelListenExtensions Class
GrapeCity.Viewer.Common.Model Namespace


GetPropertyName<TI,TR> Method

GetPropertyName<TI,TR> Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ActiveModelListenExtensions Class : GetPropertyName<TI,TR> Method
Gets property name
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function GetPropertyName
    (Of TI,TR)( _
   ByVal instance As TI, _
   ByVal propertyGetter As System.Linq.Expressions.Expression(Of Func(Of TI,TR)) _
) As System.String
public static System.string GetPropertyName<TI,TR>(
   TI instance,
   System.Linq.Expressions.Expression<Func<TI,TR>> propertyGetter
)

Parameters

instance
propertyGetter

Type Parameters

TI
TR
See Also

Reference

ActiveModelListenExtensions Class
ActiveModelListenExtensions Members


Listen Method

Listen Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ActiveModelListenExtensions Class : Listen Method
Listens to any property changes
Overload List
Overload | Description
Listen<TModel>(TModel,Action<String>) | Listens to any property changes
Listen<TModel,TValue>(TModel,Expression<Func<TModel,TValue>>,Action) | Performs specific action on particular property change
Listen<TModel,TValue>(TModel,Expression<Func<TModel,TValue>>,Action<TModel>) | Performs specific action on particular property change
Listen<TModel1,TModel2,TValue>(TModel1,Expression<Func<TModel1,TModel2>>,Expression<Func<TModel2,TValue>>,Action) | Performs specific action on particular property change with nested property support
Listen<TModel1,TModel2,TModel3,TValue>(TModel1,Expression<Func<TModel1,TModel2>>,Expression<Func<TModel2,TModel3>>,Expression<Func<TModel3,TValue>>,Action) |
See Also

Reference

ActiveModelListenExtensions Class
ActiveModelListenExtensions Members


Listen<TModel>(TModel,Action<String>) Method

Listen<TModel>(TModel,Action<String>) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ActiveModelListenExtensions Class > Listen Method : Listen<TModel>(TModel,Action<String>) Method
Listens to any property changes
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Listen(Of TModel As System.ComponentModel.INotifyPropertyChanged)( _
   ByVal model As TModel, _
   ByVal action As System.Action(Of String) _
) As System.IDisposable
public static System.IDisposable Listen<TModel>(
   TModel model,
   System.Action<string> action
)
where TModel: System.ComponentModel.INotifyPropertyChanged

Parameters

model
action

Type Parameters

TModel
See Also

Reference

ActiveModelListenExtensions Class
ActiveModelListenExtensions Members
Overload List


Listen<TModel,TValue>(TModel,Expression<Func<TModel,TValue>>,Action) Method

Listen<TModel,TValue>(TModel,Expression<Func<TModel,TValue>>,Action) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ActiveModelListenExtensions Class > Listen Method : Listen<TModel,TValue>(TModel,Expression<Func<TModel,TValue>>,Action) Method
Performs specific action on particular property change
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Listen
    (Of TModel As System.ComponentModel.INotifyPropertyChanged,
     TValue)( _
   ByVal model As TModel, _
   ByVal getter1 As System.Linq.Expressions.Expression(Of Func(Of TModel,TValue)), _
   ByVal action As System.Action _
) As System.IDisposable
public static System.IDisposable Listen<TModel,TValue>(
   TModel model,
   System.Linq.Expressions.Expression<Func<TModel,TValue>> getter1,
   System.Action action
)
where TModel: System.ComponentModel.INotifyPropertyChanged

Parameters

model
getter1
action

Type Parameters

TModel
TValue

Return Value

IDisposable instance that unsibscribes events on Dispose
See Also

Reference

ActiveModelListenExtensions Class
ActiveModelListenExtensions Members
Overload List


Listen<TModel,TValue>(TModel,Expression<Func<TModel,TValue>>,Action<TModel>) Method

Listen<TModel,TValue>(TModel,Expression<Func<TModel,TValue>>,Action<TModel>) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ActiveModelListenExtensions Class > Listen Method : Listen<TModel,TValue>(TModel,Expression<Func<TModel,TValue>>,Action<TModel>) Method
Performs specific action on particular property change
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Listen
    (Of TModel As System.ComponentModel.INotifyPropertyChanged,
     TValue)( _
   ByVal model As TModel, _
   ByVal getter1 As System.Linq.Expressions.Expression(Of Func(Of TModel,TValue)), _
   ByVal action As System.Action(Of TModel) _
) As System.IDisposable
public static System.IDisposable Listen<TModel,TValue>(
   TModel model,
   System.Linq.Expressions.Expression<Func<TModel,TValue>> getter1,
   System.Action<TModel> action
)
where TModel: System.ComponentModel.INotifyPropertyChanged

Parameters

model
getter1
action

Type Parameters

TModel
TValue

Return Value

IDisposable instance that unsibscribes events on Dispose
See Also

Reference

ActiveModelListenExtensions Class
ActiveModelListenExtensions Members
Overload List


Listen<TModel1,TModel2,TValue>(TModel1,Expression<Func<TModel1,TModel2>>,Expression<Func<TModel2,TValue>>,Action) Method

Listen<TModel1,TModel2,TValue>(TModel1,Expression<Func<TModel1,TModel2>>,Expression<Func<TModel2,TValue>>,Action) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ActiveModelListenExtensions Class > Listen Method : Listen<TModel1,TModel2,TValue>(TModel1,Expression<Func<TModel1,TModel2>>,Expression<Func<TModel2,TValue>>,Action) Method
Type of model the property references to
Gets first level property
Gets nested property
The action to perform on property change
Performs specific action on particular property change with nested property support
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Listen
    (Of TModel1 As {Class, System.ComponentModel.INotifyPropertyChanged},
     TModel2 As {Class, System.ComponentModel.INotifyPropertyChanged},
     TValue)( _
   ByVal model As TModel1, _
   ByVal getter1 As System.Linq.Expressions.Expression(Of Func(Of TModel1,TModel2)), _
   ByVal getter2 As System.Linq.Expressions.Expression(Of Func(Of TModel2,TValue)), _
   ByVal action As System.Action _
) As System.IDisposable
public static System.IDisposable Listen<TModel1,TModel2,TValue>(
   TModel1 model,
   System.Linq.Expressions.Expression<Func<TModel1,TModel2>> getter1,
   System.Linq.Expressions.Expression<Func<TModel2,TValue>> getter2,
   System.Action action
)
where TModel1: class, System.ComponentModel.INotifyPropertyChanged
where TModel2: class, System.ComponentModel.INotifyPropertyChanged

Parameters

model
getter1
Gets first level property
getter2
Gets nested property
action
The action to perform on property change

Type Parameters

TModel1
TModel2
Type of model the property references to
TValue
See Also

Reference

ActiveModelListenExtensions Class
ActiveModelListenExtensions Members
Overload List


Listen<TModel1,TModel2,TModel3,TValue>(TModel1,Expression<Func<TModel1,TModel2>>,Expression<Func<TModel2,TModel3>>,Expression<Func<TModel3,TValue>>,Action) Method

Listen<TModel1,TModel2,TModel3,TValue>(TModel1,Expression<Func<TModel1,TModel2>>,Expression<Func<TModel2,TModel3>>,Expression<Func<TModel3,TValue>>,Action) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ActiveModelListenExtensions Class > Listen Method : Listen<TModel1,TModel2,TModel3,TValue>(TModel1,Expression<Func<TModel1,TModel2>>,Expression<Func<TModel2,TModel3>>,Expression<Func<TModel3,TValue>>,Action) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Listen
    (Of TModel1 As {Class, System.ComponentModel.INotifyPropertyChanged},
     TModel2 As {Class, System.ComponentModel.INotifyPropertyChanged},
     TModel3 As {Class, System.ComponentModel.INotifyPropertyChanged},
     TValue)( _
   ByVal model As TModel1, _
   ByVal getter1 As System.Linq.Expressions.Expression(Of Func(Of TModel1,TModel2)), _
   ByVal getter2 As System.Linq.Expressions.Expression(Of Func(Of TModel2,TModel3)), _
   ByVal getter3 As System.Linq.Expressions.Expression(Of Func(Of TModel3,TValue)), _
   ByVal action As System.Action _
) As System.IDisposable
public static System.IDisposable Listen<TModel1,TModel2,TModel3,TValue>(
   TModel1 model,
   System.Linq.Expressions.Expression<Func<TModel1,TModel2>> getter1,
   System.Linq.Expressions.Expression<Func<TModel2,TModel3>> getter2,
   System.Linq.Expressions.Expression<Func<TModel3,TValue>> getter3,
   System.Action action
)
where TModel1: class, System.ComponentModel.INotifyPropertyChanged
where TModel2: class, System.ComponentModel.INotifyPropertyChanged
where TModel3: class, System.ComponentModel.INotifyPropertyChanged

Parameters

model
getter1
getter2
getter3
action

Type Parameters

TModel1
TModel2
TModel3
TValue
See Also

Reference

ActiveModelListenExtensions Class
ActiveModelListenExtensions Members
Overload List


ListenCollection Method

ListenCollection Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ActiveModelListenExtensions Class : ListenCollection Method
Performs specific action on particular CollectionChanged event
Overload List
Overload | Description
ListenCollection<TModel,TValue>(TModel,Expression<Func<TModel,TValue>>,Action<NotifyCollectionChangedEventArgs>) | Performs specific action on particular CollectionChanged event
ListenCollection<TModel1,TModel2,TValue>(TModel1,Expression<Func<TModel1,TModel2>>,Expression<Func<TModel2,TValue>>,Action<NotifyCollectionChangedEventArgs>) |
See Also

Reference

ActiveModelListenExtensions Class
ActiveModelListenExtensions Members


ListenCollection<TModel,TValue>(TModel,Expression<Func<TModel,TValue>>,Action<NotifyCollectionChangedEventArgs>) Method

ListenCollection<TModel,TValue>(TModel,Expression<Func<TModel,TValue>>,Action<NotifyCollectionChangedEventArgs>) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ActiveModelListenExtensions Class > ListenCollection Method : ListenCollection<TModel,TValue>(TModel,Expression<Func<TModel,TValue>>,Action<NotifyCollectionChangedEventArgs>) Method
Performs specific action on particular CollectionChanged event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ListenCollection
    (Of TModel As {Class, System.ComponentModel.INotifyPropertyChanged},
     TValue As {Class, INotifyCollectionChanged})( _
   ByVal model As TModel, _
   ByVal getter1 As System.Linq.Expressions.Expression(Of Func(Of TModel,TValue)), _
   ByVal action As System.Action(Of NotifyCollectionChangedEventArgs) _
) As System.IDisposable
public static System.IDisposable ListenCollection<TModel,TValue>(
   TModel model,
   System.Linq.Expressions.Expression<Func<TModel,TValue>> getter1,
   System.Action<NotifyCollectionChangedEventArgs> action
)
where TModel: class, System.ComponentModel.INotifyPropertyChanged
where TValue: class, INotifyCollectionChanged

Parameters

model
getter1
action

Type Parameters

TModel
TValue
See Also

Reference

ActiveModelListenExtensions Class
ActiveModelListenExtensions Members
Overload List


ListenCollection<TModel1,TModel2,TValue>(TModel1,Expression<Func<TModel1,TModel2>>,Expression<Func<TModel2,TValue>>,Action<NotifyCollectionChangedEventArgs>) Method

ListenCollection<TModel1,TModel2,TValue>(TModel1,Expression<Func<TModel1,TModel2>>,Expression<Func<TModel2,TValue>>,Action<NotifyCollectionChangedEventArgs>) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ActiveModelListenExtensions Class > ListenCollection Method : ListenCollection<TModel1,TModel2,TValue>(TModel1,Expression<Func<TModel1,TModel2>>,Expression<Func<TModel2,TValue>>,Action<NotifyCollectionChangedEventArgs>) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ListenCollection
    (Of TModel1 As {Class, System.ComponentModel.INotifyPropertyChanged},
     TModel2 As {Class, System.ComponentModel.INotifyPropertyChanged},
     TValue As {Class, INotifyCollectionChanged})( _
   ByVal model As TModel1, _
   ByVal getter1 As System.Linq.Expressions.Expression(Of Func(Of TModel1,TModel2)), _
   ByVal getter2 As System.Linq.Expressions.Expression(Of Func(Of TModel2,TValue)), _
   ByVal action As System.Action(Of NotifyCollectionChangedEventArgs) _
) As System.IDisposable
public static System.IDisposable ListenCollection<TModel1,TModel2,TValue>(
   TModel1 model,
   System.Linq.Expressions.Expression<Func<TModel1,TModel2>> getter1,
   System.Linq.Expressions.Expression<Func<TModel2,TValue>> getter2,
   System.Action<NotifyCollectionChangedEventArgs> action
)
where TModel1: class, System.ComponentModel.INotifyPropertyChanged
where TModel2: class, System.ComponentModel.INotifyPropertyChanged
where TValue: class, INotifyCollectionChanged

Parameters

model
getter1
getter2
action

Type Parameters

TModel1
TModel2
TValue
See Also

Reference

ActiveModelListenExtensions Class
ActiveModelListenExtensions Members
Overload List


Observe Method

Observe Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ActiveModelListenExtensions Class : Observe Method
More sofisticated changes listener implementation
Overload List
Overload | Description
Observe<T,TI>(T,Expression<Func<T,TI>>,Action<TI>,Action<TI>) | More sofisticated changes listener implementation
Observe<T,TI>(T,Expression<Func<T,TI>>,Func<TI,IDisposable>) | Observe implementation for container property
See Also

Reference

ActiveModelListenExtensions Class
ActiveModelListenExtensions Members


Observe<T,TI>(T,Expression<Func<T,TI>>,Action<TI>,Action<TI>) Method

Observe<T,TI>(T,Expression<Func<T,TI>>,Action<TI>,Action<TI>) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ActiveModelListenExtensions Class > Observe Method : Observe<T,TI>(T,Expression<Func<T,TI>>,Action<TI>,Action<TI>) Method
Action for old value
Action for new value
More sofisticated changes listener implementation
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Observe
    (Of T As System.ComponentModel.INotifyPropertyChanged,
     TI)( _
   ByVal obj As T, _
   ByVal getterExpr As System.Linq.Expressions.Expression(Of Func(Of T,TI)), _
   ByVal leave As System.Action(Of TI), _
   ByVal enter As System.Action(Of TI) _
) As System.IDisposable
public static System.IDisposable Observe<T,TI>(
   T obj,
   System.Linq.Expressions.Expression<Func<T,TI>> getterExpr,
   System.Action<TI> leave,
   System.Action<TI> enter
)
where T: System.ComponentModel.INotifyPropertyChanged

Parameters

obj
getterExpr
leave
Action for old value
enter
Action for new value

Type Parameters

T
TI
See Also

Reference

ActiveModelListenExtensions Class
ActiveModelListenExtensions Members
Overload List


Observe<T,TI>(T,Expression<Func<T,TI>>,Func<TI,IDisposable>) Method

Observe<T,TI>(T,Expression<Func<T,TI>>,Func<TI,IDisposable>) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ActiveModelListenExtensions Class > Observe Method : Observe<T,TI>(T,Expression<Func<T,TI>>,Func<TI,IDisposable>) Method
Subscribed to nested properties
Observe implementation for container property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Observe
    (Of T As System.ComponentModel.INotifyPropertyChanged,
     TI)( _
   ByVal obj As T, _
   ByVal getterExpr As System.Linq.Expressions.Expression(Of Func(Of T,TI)), _
   ByVal subscribe As System.Func(Of TI,IDisposable) _
) As System.IDisposable
public static System.IDisposable Observe<T,TI>(
   T obj,
   System.Linq.Expressions.Expression<Func<T,TI>> getterExpr,
   System.Func<TI,IDisposable> subscribe
)
where T: System.ComponentModel.INotifyPropertyChanged

Parameters

obj
getterExpr
subscribe
Subscribed to nested properties

Type Parameters

T
TI
See Also

Reference

ActiveModelListenExtensions Class
ActiveModelListenExtensions Members
Overload List


ObserveList Method

ObserveList Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ActiveModelListenExtensions Class : ObserveList Method
Observed modifyable collection
Overload List
Overload | Description
ObserveList<TI>(INotificationCollection<TI>,Func<TI,Int32,IDisposable>) | Observed modifyable collection
ObserveList<TI>(INotificationCollection<TI>,Func<TI,Int32,IDisposable>,Action<TI>) | Observed modifyable collection
ObserveList<TI>(IEnumerable<TI>,Func<TI,IDisposable>) | Observes all items in readonly collection.
See Also

Reference

ActiveModelListenExtensions Class
ActiveModelListenExtensions Members


ObserveList<TI>(INotificationCollection<TI>,Func<TI,Int32,IDisposable>) Method

ObserveList<TI>(INotificationCollection<TI>,Func<TI,Int32,IDisposable>) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ActiveModelListenExtensions Class > ObserveList Method : ObserveList<TI>(INotificationCollection<TI>,Func<TI,Int32,IDisposable>) Method
Observed modifyable collection
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ObserveList(Of TI)( _
   ByVal list As INotificationCollection(Of TI), _
   ByVal subscribeItem As System.Func(Of TI,Integer,IDisposable) _
) As System.IDisposable
public static System.IDisposable ObserveList<TI>(
   INotificationCollection<TI> list,
   System.Func<TI,int,IDisposable> subscribeItem
)

Parameters

list
subscribeItem

Type Parameters

TI
See Also

Reference

ActiveModelListenExtensions Class
ActiveModelListenExtensions Members
Overload List


ObserveList<TI>(INotificationCollection<TI>,Func<TI,Int32,IDisposable>,Action<TI>) Method

ObserveList<TI>(INotificationCollection<TI>,Func<TI,Int32,IDisposable>,Action<TI>) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ActiveModelListenExtensions Class > ObserveList Method : ObserveList<TI>(INotificationCollection<TI>,Func<TI,Int32,IDisposable>,Action<TI>) Method
Observed modifyable collection
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ObserveList(Of TI)( _
   ByVal list As INotificationCollection(Of TI), _
   ByVal subscribeItem As System.Func(Of TI,Integer,IDisposable), _
   ByVal removedAction As System.Action(Of TI) _
) As System.IDisposable
public static System.IDisposable ObserveList<TI>(
   INotificationCollection<TI> list,
   System.Func<TI,int,IDisposable> subscribeItem,
   System.Action<TI> removedAction
)

Parameters

list
subscribeItem
removedAction

Type Parameters

TI
See Also

Reference

ActiveModelListenExtensions Class
ActiveModelListenExtensions Members
Overload List


ObserveList<TI>(IEnumerable<TI>,Func<TI,IDisposable>) Method

ObserveList<TI>(IEnumerable<TI>,Func<TI,IDisposable>) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ActiveModelListenExtensions Class > ObserveList Method : ObserveList<TI>(IEnumerable<TI>,Func<TI,IDisposable>) Method
Observes all items in readonly collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ObserveList(Of TI)( _
   ByVal list As System.Collections.Generic.IEnumerable(Of TI), _
   ByVal subscribeItem As System.Func(Of TI,IDisposable) _
) As System.IDisposable
public static System.IDisposable ObserveList<TI>(
   System.Collections.Generic.IEnumerable<TI> list,
   System.Func<TI,IDisposable> subscribeItem
)

Parameters

list
subscribeItem

Type Parameters

TI
See Also

Reference

ActiveModelListenExtensions Class
ActiveModelListenExtensions Members
Overload List


ObserveRange<T> Method

ObserveRange<T> Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ActiveModelListenExtensions Class : ObserveRange<T> Method
Type of collection element.
The collection to observe.
The item handler.
Floating range to observe elements within.
Observes modifyable range of modifyable collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function ObserveRange(Of T)( _
   ByVal list As INotificationCollection(Of T), _
   ByVal subscribeItem As System.Func(Of T,Integer,IDisposable), _
   ByVal range As Observable(Of Range) _
) As System.IDisposable
public static System.IDisposable ObserveRange<T>(
   INotificationCollection<T> list,
   System.Func<T,int,IDisposable> subscribeItem,
   Observable<Range> range
)

Parameters

list
The collection to observe.
subscribeItem
The item handler.
range
Floating range to observe elements within.

Type Parameters

T
Type of collection element.
See Also

Reference

ActiveModelListenExtensions Class
ActiveModelListenExtensions Members


ObserveRangeOnStaticCollection<T> Method

ObserveRangeOnStaticCollection<T> Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ActiveModelListenExtensions Class : ObserveRangeOnStaticCollection<T> Method
Type of collection element.
The collection to observe.
Floating range to observe elements within.
The item handler.
Observes modifyable range of regulat items collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function ObserveRangeOnStaticCollection(Of T)( _
   ByVal list As IItemCollection(Of T), _
   ByVal observedRange As Observable(Of Range), _
   ByVal subscribeItem As System.Func(Of T,Integer,IDisposable) _
) As System.IDisposable
public static System.IDisposable ObserveRangeOnStaticCollection<T>(
   IItemCollection<T> list,
   Observable<Range> observedRange,
   System.Func<T,int,IDisposable> subscribeItem
)

Parameters

list
The collection to observe.
observedRange
Floating range to observe elements within.
subscribeItem
The item handler.

Type Parameters

T
Type of collection element.
See Also

Reference

ActiveModelListenExtensions Class
ActiveModelListenExtensions Members


BaseDocumentModelImpl Class

BaseDocumentModelImpl Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : BaseDocumentModelImpl Class
Base implementation of DocumentModel with ISearchableDocument and ISelectableDocument interfaces for page-based documents
Object Model
BaseDocumentModelImpl Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class BaseDocumentModelImpl
   Inherits DocumentModel
   Implements IPageDocument, ISearchableDocument, ISelectableDocument
public abstract class BaseDocumentModelImpl : DocumentModel, IPageDocument, ISearchableDocument, ISelectableDocument
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.Model.BaseDocumentModelImpl

See Also

Reference

BaseDocumentModelImpl Members
GrapeCity.Viewer.Common.Model Namespace


BaseDocumentModelImpl Class Members

BaseDocumentModelImpl Class Members
Properties Methods Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : BaseDocumentModelImpl Class

The following tables list the members exposed by BaseDocumentModelImpl.

Public Properties
 | Name | Description
Public Property | Annotations | Gets the annotations. (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | AnnotationsDocument | Gets the document to store annotations to (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | Bookmarks | Gets/sets document's bookmarks collection (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | CurrentSelection | (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | HighlightSearchResult | Gets or sets currently highlighted search result (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | MaxPageSize | Gets maximum page size (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | NotifySearchResult | Gets or sets currently notification search result (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | PageCount | Gets loaded pages count (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | PaperSize | Gets the default paper size of the document. In fact SectionReport allows variable pages while it's not implemented in model. PaperSize is then considered immutable. You can read it at any time and assume it's not changed anymore. (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | TotalPageCount | Returns number of total pages in document. This number can be higher then number of pages currently available. (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Top
Public Methods
 | Name | Description
Public Method | ClearSelection | (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Method | CreateAnnotationsRenderer | (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Method | Find | Overridden.
Public Method | GetItemText | Overridden.
Public Method | GetPage |
Public Method | SelectItems | Overridden.
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | (Inherited from GrapeCity.Viewer.Common.Model.ActiveModel)
Top
See Also

Reference

BaseDocumentModelImpl Class
GrapeCity.Viewer.Common.Model Namespace


BaseDocumentModelImpl Class Methods

BaseDocumentModelImpl Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : BaseDocumentModelImpl Class

For a list of all members of this type, see BaseDocumentModelImpl members.

Public Methods
 | Name | Description
Public Method | ClearSelection | (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Method | CreateAnnotationsRenderer | (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Method | Find | Overridden.
Public Method | GetItemText | Overridden.
Public Method | GetPage |
Public Method | SelectItems | Overridden.
Top
See Also

Reference

BaseDocumentModelImpl Class
GrapeCity.Viewer.Common.Model Namespace


Find Method (BaseDocumentModelImpl)

Find Method (BaseDocumentModelImpl)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > BaseDocumentModelImpl Class : Find Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Find( _
   ByVal options As FindOptions, _
   ByVal startFrom As SearchResult _
) As System.Collections.Generic.IEnumerable(Of SearchResult)
public override System.Collections.Generic.IEnumerable<SearchResult> Find(
   FindOptions options,
   SearchResult startFrom
)

Parameters

options
startFrom
See Also

Reference

BaseDocumentModelImpl Class
BaseDocumentModelImpl Members


GetItemText(SearchResult) Method

GetItemText(SearchResult) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > BaseDocumentModelImpl Class : GetItemText(SearchResult) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetItemText( _
   ByVal result As SearchResult _
) As System.String
public override System.string GetItemText(
   SearchResult result
)

Parameters

result
See Also

Reference

BaseDocumentModelImpl Class
BaseDocumentModelImpl Members


GetPage Method (BaseDocumentModelImpl)

GetPage Method (BaseDocumentModelImpl)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > BaseDocumentModelImpl Class : GetPage Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Function GetPage( _
   ByVal pageIndex As System.Integer _
) As DocumentModel.IPage
public abstract DocumentModel.IPage GetPage(
   System.int pageIndex
)

Parameters

pageIndex
See Also

Reference

BaseDocumentModelImpl Class
BaseDocumentModelImpl Members


SelectItems Method (BaseDocumentModelImpl)

SelectItems Method (BaseDocumentModelImpl)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > BaseDocumentModelImpl Class : SelectItems Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Sub SelectItems( _
   ByVal pageIndex As System.Integer, _
   ByVal frame As Rect _
)
public override void SelectItems(
   System.int pageIndex,
   Rect frame
)

Parameters

pageIndex
frame
See Also

Reference

BaseDocumentModelImpl Class
BaseDocumentModelImpl Members


BitmapCachedDocumentModel Class

BitmapCachedDocumentModel Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : BitmapCachedDocumentModel Class
Aggresively caches pages in bitmaps
Object Model
BitmapCachedDocumentModel Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class BitmapCachedDocumentModel
   Inherits DocumentModel
   Implements IPageDocument, ISearchableDocument, ISelectableDocument
public class BitmapCachedDocumentModel : DocumentModel, IPageDocument, ISearchableDocument, ISelectableDocument
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.Model.BitmapCachedDocumentModel

See Also

Reference

BitmapCachedDocumentModel Members
GrapeCity.Viewer.Common.Model Namespace


BitmapCachedDocumentModel Class Members

BitmapCachedDocumentModel Class Members
Properties Methods Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : BitmapCachedDocumentModel Class

The following tables list the members exposed by BitmapCachedDocumentModel.

Public Constructors
 | Name | Description
Public Constructor | BitmapCachedDocumentModel Constructor |
Top
Public Properties
 | Name | Description
Public Property | Annotations | Gets the annotations. (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | AnnotationsDocument | Overridden.
Public Property | Bookmarks | Gets/sets document's bookmarks collection (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | CurrentSelection | (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | HighlightSearchResult | Gets or sets currently highlighted search result (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | MaxPageSize | Gets maximum page size (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | NotifySearchResult | Gets or sets currently notification search result (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | PageCount | Gets loaded pages count (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | PaperSize | Overridden.
Public Property | TotalPageCount | Returns number of total pages in document. This number can be higher then number of pages currently available. (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Top
Public Methods
 | Name | Description
Public Method | ClearSelection | (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Method | CreateAnnotationsRenderer | (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Method | Dispose |
Public Method | Find | Overridden.
Public Method | GetItemText | Overridden.
Public Method | GetPage |
Public Method | SelectItems | Overridden.
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | (Inherited from GrapeCity.Viewer.Common.Model.ActiveModel)
Top
See Also

Reference

BitmapCachedDocumentModel Class
GrapeCity.Viewer.Common.Model Namespace


BitmapCachedDocumentModel Constructor

BitmapCachedDocumentModel Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > BitmapCachedDocumentModel Class : BitmapCachedDocumentModel Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal sourceModel As DocumentModel _
)
public BitmapCachedDocumentModel(
   DocumentModel sourceModel
)

Parameters

sourceModel
See Also

Reference

BitmapCachedDocumentModel Class
BitmapCachedDocumentModel Members


BitmapCachedDocumentModel Class Methods

BitmapCachedDocumentModel Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : BitmapCachedDocumentModel Class

For a list of all members of this type, see BitmapCachedDocumentModel members.

Public Methods
 | Name | Description
Public Method | ClearSelection | (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Method | CreateAnnotationsRenderer | (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Method | Dispose |
Public Method | Find | Overridden.
Public Method | GetItemText | Overridden.
Public Method | GetPage |
Public Method | SelectItems | Overridden.
Top
See Also

Reference

BitmapCachedDocumentModel Class
GrapeCity.Viewer.Common.Model Namespace


Dispose Method (BitmapCachedDocumentModel)

Dispose Method (BitmapCachedDocumentModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > BitmapCachedDocumentModel Class : Dispose Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

BitmapCachedDocumentModel Class
BitmapCachedDocumentModel Members


Find Method (BitmapCachedDocumentModel)

Find Method (BitmapCachedDocumentModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > BitmapCachedDocumentModel Class : Find Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Find( _
   ByVal options As FindOptions, _
   ByVal startFrom As SearchResult _
) As System.Collections.Generic.IEnumerable(Of SearchResult)
public override System.Collections.Generic.IEnumerable<SearchResult> Find(
   FindOptions options,
   SearchResult startFrom
)

Parameters

options
startFrom
See Also

Reference

BitmapCachedDocumentModel Class
BitmapCachedDocumentModel Members


GetItemText Method (BitmapCachedDocumentModel)

GetItemText Method (BitmapCachedDocumentModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > BitmapCachedDocumentModel Class : GetItemText Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetItemText( _
   ByVal result As SearchResult _
) As System.String
public override System.string GetItemText(
   SearchResult result
)

Parameters

result
See Also

Reference

BitmapCachedDocumentModel Class
BitmapCachedDocumentModel Members


GetPage Method (BitmapCachedDocumentModel)

GetPage Method (BitmapCachedDocumentModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > BitmapCachedDocumentModel Class : GetPage Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetPage( _
   ByVal pageIndex As System.Integer _
) As DocumentModel.IPage
public DocumentModel.IPage GetPage(
   System.int pageIndex
)

Parameters

pageIndex
See Also

Reference

BitmapCachedDocumentModel Class
BitmapCachedDocumentModel Members


SelectItems Method (BitmapCachedDocumentModel)

SelectItems Method (BitmapCachedDocumentModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > BitmapCachedDocumentModel Class : SelectItems Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Sub SelectItems( _
   ByVal pageIndex As System.Integer, _
   ByVal frame As Rect _
)
public override void SelectItems(
   System.int pageIndex,
   Rect frame
)

Parameters

pageIndex
frame
See Also

Reference

BitmapCachedDocumentModel Class
BitmapCachedDocumentModel Members


BitmapCachedDocumentModel Class Properties

BitmapCachedDocumentModel Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : BitmapCachedDocumentModel Class

For a list of all members of this type, see BitmapCachedDocumentModel members.

Public Properties
 | Name | Description
Public Property | Annotations | Gets the annotations. (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | AnnotationsDocument | Overridden.
Public Property | Bookmarks | Gets/sets document's bookmarks collection (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | CurrentSelection | (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | HighlightSearchResult | Gets or sets currently highlighted search result (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | MaxPageSize | Gets maximum page size (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | NotifySearchResult | Gets or sets currently notification search result (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | PageCount | Gets loaded pages count (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | PaperSize | Overridden.
Public Property | TotalPageCount | Returns number of total pages in document. This number can be higher then number of pages currently available. (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Top
See Also

Reference

BitmapCachedDocumentModel Class
GrapeCity.Viewer.Common.Model Namespace


AnnotationsDocument Property (BitmapCachedDocumentModel)

AnnotationsDocument Property (BitmapCachedDocumentModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > BitmapCachedDocumentModel Class : AnnotationsDocument Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property AnnotationsDocument As DocumentModel
public override DocumentModel AnnotationsDocument {get;}
See Also

Reference

BitmapCachedDocumentModel Class
BitmapCachedDocumentModel Members


PaperSize Property (BitmapCachedDocumentModel)

PaperSize Property (BitmapCachedDocumentModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > BitmapCachedDocumentModel Class : PaperSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides ReadOnly Property PaperSize As Size
public override Size PaperSize {get;}
See Also

Reference

BitmapCachedDocumentModel Class
BitmapCachedDocumentModel Members


DocumentModel Class

DocumentModel Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel Class
Represents base structure and behaviour for document models
Object Model
DocumentModel Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class DocumentModel
   Inherits ActiveModel
   Implements ISearchableDocument, ISelectableDocument
public abstract class DocumentModel : ActiveModel, ISearchableDocument, ISelectableDocument
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.Model.DocumentModel

See Also

Reference

DocumentModel Members
GrapeCity.Viewer.Common.Model Namespace


DocumentModel Class Members

DocumentModel Class Members
Fields Properties Methods Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel Class

The following tables list the members exposed by DocumentModel.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | NullInstance | Gets null document instance
Top
Public Properties
 | Name | Description
Public Property | Annotations | Gets the annotations.
Public Property | AnnotationsDocument | Gets the document to store annotations to
Public Property | Bookmarks | Gets/sets document's bookmarks collection
Public Property | CurrentSelection |
Public Property | HighlightSearchResult | Gets or sets currently highlighted search result
Public Property | MaxPageSize | Gets maximum page size
Public Property | NotifySearchResult | Gets or sets currently notification search result
Public Property | PageCount | Gets loaded pages count
Public Property | PaperSize | Gets the default paper size of the document. In fact SectionReport allows variable pages while it's not implemented in model. PaperSize is then considered immutable. You can read it at any time and assume it's not changed anymore.
Public Property | TotalPageCount | Returns number of total pages in document. This number can be higher then number of pages currently available.
Top
Public Methods
 | Name | Description
Public Method | ClearSelection |
Public Method | CreateAnnotationsRenderer |
Public Method | Find |
Public Method | GetItemText | Gets element text to display/highlight range within a list of results
Public Method | SelectItems |
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | (Inherited from GrapeCity.Viewer.Common.Model.ActiveModel)
Top
See Also

Reference

DocumentModel Class
GrapeCity.Viewer.Common.Model Namespace


DocumentModel Class Methods

DocumentModel Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel Class

For a list of all members of this type, see DocumentModel members.

Public Methods
 | Name | Description
Public Method | ClearSelection |
Public Method | CreateAnnotationsRenderer |
Public Method | Find |
Public Method | GetItemText | Gets element text to display/highlight range within a list of results
Public Method | SelectItems |
Top
See Also

Reference

DocumentModel Class
GrapeCity.Viewer.Common.Model Namespace


ClearSelection Method (DocumentModel)

ClearSelection Method (DocumentModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel Class : ClearSelection Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ClearSelection()
public void ClearSelection()
See Also

Reference

DocumentModel Class
DocumentModel Members


CreateAnnotationsRenderer Method

CreateAnnotationsRenderer Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel Class : CreateAnnotationsRenderer Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function CreateAnnotationsRenderer() As IDocumentRenderer
public virtual IDocumentRenderer CreateAnnotationsRenderer()
See Also

Reference

DocumentModel Class
DocumentModel Members


Find Method (DocumentModel)

Find Method (DocumentModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel Class : Find Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Function Find( _
   ByVal options As FindOptions, _
   ByVal startFrom As SearchResult _
) As System.Collections.Generic.IEnumerable(Of SearchResult)
public abstract System.Collections.Generic.IEnumerable<SearchResult> Find(
   FindOptions options,
   SearchResult startFrom
)

Parameters

options
startFrom
See Also

Reference

DocumentModel Class
DocumentModel Members


GetItemText Method (DocumentModel)

GetItemText Method (DocumentModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel Class : GetItemText Method
The search result.
Gets element text to display/highlight range within a list of results
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Function GetItemText( _
   ByVal result As SearchResult _
) As System.String
public abstract System.string GetItemText(
   SearchResult result
)

Parameters

result
The search result.
See Also

Reference

DocumentModel Class
DocumentModel Members


SelectItems Method (DocumentModel)

SelectItems Method (DocumentModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel Class : SelectItems Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Sub SelectItems( _
   ByVal pageIndex As System.Integer, _
   ByVal frame As Rect _
)
public abstract void SelectItems(
   System.int pageIndex,
   Rect frame
)

Parameters

pageIndex
frame
See Also

Reference

DocumentModel Class
DocumentModel Members


DocumentModel Class Properties

DocumentModel Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel Class

For a list of all members of this type, see DocumentModel members.

Public Properties
 | Name | Description
Public Property | Annotations | Gets the annotations.
Public Property | AnnotationsDocument | Gets the document to store annotations to
Public Property | Bookmarks | Gets/sets document's bookmarks collection
Public Property | CurrentSelection |
Public Property | HighlightSearchResult | Gets or sets currently highlighted search result
Public Property | MaxPageSize | Gets maximum page size
Public Property | NotifySearchResult | Gets or sets currently notification search result
Public Property | PageCount | Gets loaded pages count
Public Property | PaperSize | Gets the default paper size of the document. In fact SectionReport allows variable pages while it's not implemented in model. PaperSize is then considered immutable. You can read it at any time and assume it's not changed anymore.
Public Property | TotalPageCount | Returns number of total pages in document. This number can be higher then number of pages currently available.
Top
See Also

Reference

DocumentModel Class
GrapeCity.Viewer.Common.Model Namespace


Annotations Property (DocumentModel)

Annotations Property (DocumentModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel Class : Annotations Property
Gets the annotations.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Annotations As AnnotationBook
public virtual AnnotationBook Annotations {get;}
See Also

Reference

DocumentModel Class
DocumentModel Members


AnnotationsDocument Property (DocumentModel)

AnnotationsDocument Property (DocumentModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel Class : AnnotationsDocument Property
Gets the document to store annotations to
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property AnnotationsDocument As DocumentModel
public virtual DocumentModel AnnotationsDocument {get;}
See Also

Reference

DocumentModel Class
DocumentModel Members


Bookmarks Property (DocumentModel)

Bookmarks Property (DocumentModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel Class : Bookmarks Property
Gets/sets document's bookmarks collection
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Bookmarks As TocTreeNode
public TocTreeNode Bookmarks {get; set;}
See Also

Reference

DocumentModel Class
DocumentModel Members


CurrentSelection Property (DocumentModel)

CurrentSelection Property (DocumentModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel Class : CurrentSelection Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CurrentSelection As DocumentSelection
public DocumentSelection CurrentSelection {get;}
See Also

Reference

DocumentModel Class
DocumentModel Members


HighlightSearchResult Property (DocumentModel)

HighlightSearchResult Property (DocumentModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel Class : HighlightSearchResult Property
Gets or sets currently highlighted search result
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HighlightSearchResult As SearchResult
public SearchResult HighlightSearchResult {get; set;}

Property Value

The highlight search result.
See Also

Reference

DocumentModel Class
DocumentModel Members


MaxPageSize Property

MaxPageSize Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel Class : MaxPageSize Property
Gets maximum page size
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property MaxPageSize As Size
public virtual Size MaxPageSize {get; set;}
See Also

Reference

DocumentModel Class
DocumentModel Members


NotifySearchResult Property (DocumentModel)

NotifySearchResult Property (DocumentModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel Class : NotifySearchResult Property
Gets or sets currently notification search result
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NotifySearchResult As SearchResult
public SearchResult NotifySearchResult {get; set;}
See Also

Reference

DocumentModel Class
DocumentModel Members


PageCount Property (DocumentModel)

PageCount Property (DocumentModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel Class : PageCount Property
Gets loaded pages count
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property PageCount As System.Nullable(Of Integer)
public virtual System.Nullable<int> PageCount {get; set;}
See Also

Reference

DocumentModel Class
DocumentModel Members


PaperSize Property (DocumentModel)

PaperSize Property (DocumentModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel Class : PaperSize Property
Gets the default paper size of the document. In fact SectionReport allows variable pages while it's not implemented in model. PaperSize is then considered immutable. You can read it at any time and assume it's not changed anymore.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property PaperSize As Size
public abstract Size PaperSize {get;}
See Also

Reference

DocumentModel Class
DocumentModel Members


TotalPageCount Property

TotalPageCount Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel Class : TotalPageCount Property
Returns number of total pages in document. This number can be higher then number of pages currently available.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property TotalPageCount As System.Nullable(Of Integer)
public virtual System.Nullable<int> TotalPageCount {get; set;}
See Also

Reference

DocumentModel Class
DocumentModel Members


DocumentModel Class Fields

DocumentModel Class Fields

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel Class

For a list of all members of this type, see DocumentModel members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | NullInstance | Gets null document instance
Top
See Also

Reference

DocumentModel Class
GrapeCity.Viewer.Common.Model Namespace


NullInstance Field

NullInstance Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel Class : NullInstance Field
Gets null document instance
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly NullInstance As DocumentModel
public static readonly DocumentModel NullInstance
See Also

Reference

DocumentModel Class
DocumentModel Members


DocumentModel.TextItem Class

DocumentModel.TextItem Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel.TextItem Class
Base implementation for text item
Object Model
DocumentModel.TextItem Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class DocumentModel.TextItem
   Implements DocumentModel.IPageItem
public abstract class DocumentModel.TextItem : DocumentModel.IPageItem
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.Model.DocumentModel.TextItem

See Also

Reference

DocumentModel.TextItem Members
GrapeCity.Viewer.Common.Model Namespace


DocumentModel.TextItem Class Members

DocumentModel.TextItem Class Members
Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel.TextItem Class

The following tables list the members exposed by DocumentModel.TextItem.

Public Properties
 | Name | Description
Public Property | Bounds | Gets item boundaries within a page
Public Property | ItemIndex | Uniquely identifies item within a page
Public Property | Text | Gets the text.
Top
See Also

Reference

DocumentModel.TextItem Class
GrapeCity.Viewer.Common.Model Namespace


DocumentModel.TextItem Class Properties

DocumentModel.TextItem Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel.TextItem Class

For a list of all members of this type, see DocumentModel.TextItem members.

Public Properties
 | Name | Description
Public Property | Bounds | Gets item boundaries within a page
Public Property | ItemIndex | Uniquely identifies item within a page
Public Property | Text | Gets the text.
Top
See Also

Reference

DocumentModel.TextItem Class
GrapeCity.Viewer.Common.Model Namespace


Bounds Property (DocumentModel.TextItem)

Bounds Property (DocumentModel.TextItem)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel.TextItem Class : Bounds Property
Gets item boundaries within a page
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Bounds As Rect
public Rect Bounds {get;}

Property Value

The bounds.
See Also

Reference

DocumentModel.TextItem Class
DocumentModel.TextItem Members


ItemIndex Property (DocumentModel.TextItem)

ItemIndex Property (DocumentModel.TextItem)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel.TextItem Class : ItemIndex Property
Uniquely identifies item within a page
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ItemIndex As System.Integer
public System.int ItemIndex {get;}

Property Value

The index of the item.
See Also

Reference

DocumentModel.TextItem Class
DocumentModel.TextItem Members


Text Property (DocumentModel.TextItem)

Text Property (DocumentModel.TextItem)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel.TextItem Class : Text Property
Gets the text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property Text As System.String
public abstract System.string Text {get;}

Property Value

The text.
See Also

Reference

DocumentModel.TextItem Class
DocumentModel.TextItem Members


ExportFormatInfo Class

ExportFormatInfo Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ExportFormatInfo Class
Export format info
Object Model
ExportFormatInfo Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ExportFormatInfo
public class ExportFormatInfo
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.Model.ExportFormatInfo

See Also

Reference

ExportFormatInfo Members
GrapeCity.Viewer.Common.Model Namespace


ExportFormatInfo Class Members

ExportFormatInfo Class Members
Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ExportFormatInfo Class

The following tables list the members exposed by ExportFormatInfo.

Public Constructors
 | Name | Description
Public Constructor | ExportFormatInfo Constructor | Export Format Info
Top
Public Properties
 | Name | Description
Public Property | DisplayName | Display Name
Public Property | ExportType | Export type
Public Property | Extension | Extension
Public Property | FilterString | Gets filter string
Top
See Also

Reference

ExportFormatInfo Class
GrapeCity.Viewer.Common.Model Namespace


ExportFormatInfo Constructor

ExportFormatInfo Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ExportFormatInfo Class : ExportFormatInfo Constructor
export type
display export name
extension
Export Format Info
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal exportType As ExportType, _
   ByVal displayName As System.String, _
   ByVal extension As System.String _
)
public ExportFormatInfo(
   ExportType exportType,
   System.string displayName,
   System.string extension
)

Parameters

exportType
export type
displayName
display export name
extension
extension
See Also

Reference

ExportFormatInfo Class
ExportFormatInfo Members


ExportFormatInfo Class Properties

ExportFormatInfo Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ExportFormatInfo Class

For a list of all members of this type, see ExportFormatInfo members.

Public Properties
 | Name | Description
Public Property | DisplayName | Display Name
Public Property | ExportType | Export type
Public Property | Extension | Extension
Public Property | FilterString | Gets filter string
Top
See Also

Reference

ExportFormatInfo Class
GrapeCity.Viewer.Common.Model Namespace


DisplayName Property (ExportFormatInfo)

DisplayName Property (ExportFormatInfo)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ExportFormatInfo Class : DisplayName Property
Display Name
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DisplayName As System.String
public System.string DisplayName {get;}
See Also

Reference

ExportFormatInfo Class
ExportFormatInfo Members


ExportType Property

ExportType Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ExportFormatInfo Class : ExportType Property
Export type
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ExportType As ExportType
public ExportType ExportType {get;}
See Also

Reference

ExportFormatInfo Class
ExportFormatInfo Members


Extension Property

Extension Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ExportFormatInfo Class : Extension Property
Extension
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Extension As System.String
public System.string Extension {get;}
See Also

Reference

ExportFormatInfo Class
ExportFormatInfo Members


FilterString Property

FilterString Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ExportFormatInfo Class : FilterString Property
Gets filter string
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property FilterString As System.String
public System.string FilterString {get;}

Property Value

filter string
See Also

Reference

ExportFormatInfo Class
ExportFormatInfo Members


ExportOptions Class

ExportOptions Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ExportOptions Class
Represents export settings
Object Model
ExportOptions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ExportOptions
public class ExportOptions
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.Model.ExportOptions

See Also

Reference

ExportOptions Members
GrapeCity.Viewer.Common.Model Namespace


ExportOptions Class Members

ExportOptions Class Members
Fields

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ExportOptions Class

The following tables list the members exposed by ExportOptions.

Public Constructors
 | Name | Description
Public Constructor | ExportOptions Constructor | Overloaded.
Top
Public Fields
 | Name | Description
Public Field | Settings |
Public Field | Type |
Top
See Also

Reference

ExportOptions Class
GrapeCity.Viewer.Common.Model Namespace


ExportOptions Constructor

ExportOptions Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ExportOptions Class : ExportOptions Constructor
Overload List
Overload | Description
ExportOptions Constructor(ExportType) |
ExportOptions Constructor(ExportType,IDictionary<String,String>) |
See Also

Reference

ExportOptions Class
ExportOptions Members


ExportOptions Constructor(ExportType)

ExportOptions Constructor(ExportType)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ExportOptions Class > ExportOptions Constructor : ExportOptions Constructor(ExportType)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal type As ExportType _
)
public ExportOptions(
   ExportType type
)

Parameters

type
See Also

Reference

ExportOptions Class
ExportOptions Members
Overload List


ExportOptions Constructor(ExportType,IDictionary<String,String>)

ExportOptions Constructor(ExportType,IDictionary<String,String>)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ExportOptions Class > ExportOptions Constructor : ExportOptions Constructor(ExportType,IDictionary<String,String>)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal type As ExportType, _
   ByVal settings As System.Collections.Generic.IDictionary(Of String,String) _
)
public ExportOptions(
   ExportType type,
   System.Collections.Generic.IDictionary<string,string> settings
)

Parameters

type
settings
See Also

Reference

ExportOptions Class
ExportOptions Members
Overload List


ExportOptions Class Fields

ExportOptions Class Fields

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ExportOptions Class

For a list of all members of this type, see ExportOptions members.

Public Fields
 | Name | Description
Public Field | Settings |
Public Field | Type |
Top
See Also

Reference

ExportOptions Class
GrapeCity.Viewer.Common.Model Namespace


Settings Field (ExportOptions)

Settings Field (ExportOptions)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ExportOptions Class : Settings Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Settings As System.Collections.Generic.IDictionary(Of String,String)
public readonly System.Collections.Generic.IDictionary<string,string> Settings
See Also

Reference

ExportOptions Class
ExportOptions Members


Type Field

Type Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ExportOptions Class : Type Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Type As ExportType
public readonly ExportType Type
See Also

Reference

ExportOptions Class
ExportOptions Members


FindOptions Class

FindOptions Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : FindOptions Class
Represents text-based search settings
Object Model
FindOptions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class FindOptions
public sealed class FindOptions
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.Model.FindOptions

See Also

Reference

FindOptions Members
GrapeCity.Viewer.Common.Model Namespace


FindOptions Class Members

FindOptions Class Members
Fields Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : FindOptions Class

The following tables list the members exposed by FindOptions.

Public Constructors
 | Name | Description
Public Constructor | FindOptions Constructor | Overloaded.
Top
Public Fields
 | Name | Description
Public Field | MatchCase | Specifies whether the search is case sensitive.
Public Field | SearchBackward | Specifies whether the search should be done in backward order.
Public Field | Text | The text to search.
Public Field | WholeWord | Specifies whether to search only the specified whole word.
Top
Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified System.Object is equal to this instance.
Public Method | GetHashCode | Returns a hash code for this instance.
Public Method | ToString | Returns a System.String that represents this instance.
Top
See Also

Reference

FindOptions Class
GrapeCity.Viewer.Common.Model Namespace


FindOptions Constructor

FindOptions Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > FindOptions Class : FindOptions Constructor
Overload List
Overload | Description
FindOptions Constructor(String) | Initializes a new instance of the FindOptions class.
FindOptions Constructor(String,Boolean,Boolean,Boolean) | Initializes a new instance of the FindOptions class.
See Also

Reference

FindOptions Class
FindOptions Members


FindOptions Constructor(String)

FindOptions Constructor(String)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > FindOptions Class > FindOptions Constructor : FindOptions Constructor(String)
The text.
Initializes a new instance of the FindOptions class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal text As System.String _
)
public FindOptions(
   System.string text
)

Parameters

text
The text.
See Also

Reference

FindOptions Class
FindOptions Members
Overload List


FindOptions Constructor(String,Boolean,Boolean,Boolean)

FindOptions Constructor(String,Boolean,Boolean,Boolean)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > FindOptions Class > FindOptions Constructor : FindOptions Constructor(String,Boolean,Boolean,Boolean)
Initializes a new instance of the FindOptions class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal text As System.String, _
   ByVal matchCase As System.Boolean, _
   ByVal wholeWord As System.Boolean, _
   ByVal searchBackward As System.Boolean _
)
public FindOptions(
   System.string text,
   System.bool matchCase,
   System.bool wholeWord,
   System.bool searchBackward
)

Parameters

text
matchCase
wholeWord
searchBackward
See Also

Reference

FindOptions Class
FindOptions Members
Overload List


FindOptions Class Methods

FindOptions Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : FindOptions Class

For a list of all members of this type, see FindOptions members.

Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified System.Object is equal to this instance.
Public Method | GetHashCode | Returns a hash code for this instance.
Public Method | ToString | Returns a System.String that represents this instance.
Top
See Also

Reference

FindOptions Class
GrapeCity.Viewer.Common.Model Namespace


Equals Method (FindOptions)

Equals Method (FindOptions)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > FindOptions Class : Equals Method
Determines whether the specified System.Object is equal to this instance.
Overload List
Overload | Description
Equals(Object) | Determines whether the specified System.Object is equal to this instance.
Equals(FindOptions) | Determines whether the specified FindOptions is equal to this instance.
See Also

Reference

FindOptions Class
FindOptions Members


Equals(Object) Method

Equals(Object) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > FindOptions Class > Equals Method : Equals(Object) Method
The System.Object to compare with this instance.
Determines whether the specified System.Object is equal to this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overrides Function Equals( _
   ByVal o As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object o
)

Parameters

o
The System.Object to compare with this instance.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.
See Also

Reference

FindOptions Class
FindOptions Members
Overload List


Equals(FindOptions) Method

Equals(FindOptions) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > FindOptions Class > Equals Method : Equals(FindOptions) Method
Determines whether the specified FindOptions is equal to this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Equals( _
   ByVal other As FindOptions _
) As System.Boolean
public System.bool Equals(
   FindOptions other
)

Parameters

other
See Also

Reference

FindOptions Class
FindOptions Members
Overload List


GetHashCode Method (FindOptions)

GetHashCode Method (FindOptions)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > FindOptions Class : GetHashCode Method
Returns a hash code for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()
See Also

Reference

FindOptions Class
FindOptions Members


ToString Method (FindOptions)

ToString Method (FindOptions)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > FindOptions Class : ToString Method
Returns a System.String that represents this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()
See Also

Reference

FindOptions Class
FindOptions Members


FindOptions Class Fields

FindOptions Class Fields

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : FindOptions Class

For a list of all members of this type, see FindOptions members.

Public Fields
 | Name | Description
Public Field | MatchCase | Specifies whether the search is case sensitive.
Public Field | SearchBackward | Specifies whether the search should be done in backward order.
Public Field | Text | The text to search.
Public Field | WholeWord | Specifies whether to search only the specified whole word.
Top
See Also

Reference

FindOptions Class
GrapeCity.Viewer.Common.Model Namespace


MatchCase Field

MatchCase Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > FindOptions Class : MatchCase Field
Specifies whether the search is case sensitive.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly MatchCase As System.Boolean
public readonly System.bool MatchCase
See Also

Reference

FindOptions Class
FindOptions Members


SearchBackward Field

SearchBackward Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > FindOptions Class : SearchBackward Field
Specifies whether the search should be done in backward order.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly SearchBackward As System.Boolean
public readonly System.bool SearchBackward
See Also

Reference

FindOptions Class
FindOptions Members


Text Field

Text Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > FindOptions Class : Text Field
The text to search.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Text As System.String
public readonly System.string Text
See Also

Reference

FindOptions Class
FindOptions Members


WholeWord Field

WholeWord Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > FindOptions Class : WholeWord Field
Specifies whether to search only the specified whole word.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly WholeWord As System.Boolean
public readonly System.bool WholeWord
See Also

Reference

FindOptions Class
FindOptions Members


HighlightDocumentViewModel Class

HighlightDocumentViewModel Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : HighlightDocumentViewModel Class
Implement document-wise highlighting model.
Object Model
HighlightDocumentViewModel Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class HighlightDocumentViewModel
   Inherits ActiveModel
   Implements GrapeCity.Viewer.Common.INotifyCollectionChanged
public class HighlightDocumentViewModel : ActiveModel, GrapeCity.Viewer.Common.INotifyCollectionChanged
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.Model.HighlightDocumentViewModel

See Also

Reference

HighlightDocumentViewModel Members
GrapeCity.Viewer.Common.Model Namespace


HighlightDocumentViewModel Class Members

HighlightDocumentViewModel Class Members
Properties Methods Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : HighlightDocumentViewModel Class

The following tables list the members exposed by HighlightDocumentViewModel.

Public Constructors
 | Name | Description
Public Constructor | HighlightDocumentViewModel Constructor |
Top
Public Properties
 | Name | Description
Public Property | Item |
Top
Public Methods
 | Name | Description
Public Method | Dispose |
Top
Public Events
 | Name | Description
Public Event | CollectionChanged |
Public Event | PropertyChanged | (Inherited from GrapeCity.Viewer.Common.Model.ActiveModel)
Top
See Also

Reference

HighlightDocumentViewModel Class
GrapeCity.Viewer.Common.Model Namespace


HighlightDocumentViewModel Constructor

HighlightDocumentViewModel Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > HighlightDocumentViewModel Class : HighlightDocumentViewModel Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal doc As DocumentModel, _
   ByVal pane As ReportPaneModel _
)
public HighlightDocumentViewModel(
   DocumentModel doc,
   ReportPaneModel pane
)

Parameters

doc
pane
See Also

Reference

HighlightDocumentViewModel Class
HighlightDocumentViewModel Members


HighlightDocumentViewModel Class Methods

HighlightDocumentViewModel Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : HighlightDocumentViewModel Class

For a list of all members of this type, see HighlightDocumentViewModel members.

Public Methods
 | Name | Description
Public Method | Dispose |
Top
See Also

Reference

HighlightDocumentViewModel Class
GrapeCity.Viewer.Common.Model Namespace


Dispose Method (HighlightDocumentViewModel)

Dispose Method (HighlightDocumentViewModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > HighlightDocumentViewModel Class : Dispose Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

HighlightDocumentViewModel Class
HighlightDocumentViewModel Members


HighlightDocumentViewModel Class Properties

HighlightDocumentViewModel Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : HighlightDocumentViewModel Class

For a list of all members of this type, see HighlightDocumentViewModel members.

Public Properties
 | Name | Description
Public Property | Item |
Top
See Also

Reference

HighlightDocumentViewModel Class
GrapeCity.Viewer.Common.Model Namespace


Item Property (HighlightDocumentViewModel)

Item Property (HighlightDocumentViewModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > HighlightDocumentViewModel Class : Item Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Default Property Item( _
   ByVal pageIndex As System.Integer _
) As HighlightPage
public HighlightPage this[
   System.int pageIndex
]; {get;}

Parameters

pageIndex
See Also

Reference

HighlightDocumentViewModel Class
HighlightDocumentViewModel Members


HighlightDocumentViewModel Class Events

HighlightDocumentViewModel Class Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : HighlightDocumentViewModel Class

For a list of all members of this type, see HighlightDocumentViewModel members.

Public Events
 | Name | Description
Public Event | CollectionChanged |
Public Event | PropertyChanged | (Inherited from GrapeCity.Viewer.Common.Model.ActiveModel)
Top
See Also

Reference

HighlightDocumentViewModel Class
GrapeCity.Viewer.Common.Model Namespace


CollectionChanged Event (HighlightDocumentViewModel)

CollectionChanged Event (HighlightDocumentViewModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > HighlightDocumentViewModel Class : CollectionChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event CollectionChanged As NotifyCollectionChangedEventHandler
public event NotifyCollectionChangedEventHandler CollectionChanged
See Also

Reference

HighlightDocumentViewModel Class
HighlightDocumentViewModel Members


HighlightPage Class

HighlightPage Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : HighlightPage Class
Immutable page highlight view model
Object Model
HighlightPage Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class HighlightPage
public class HighlightPage
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.Model.HighlightPage

See Also

Reference

HighlightPage Members
GrapeCity.Viewer.Common.Model Namespace


HighlightPage Class Members

HighlightPage Class Members
Fields Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : HighlightPage Class

The following tables list the members exposed by HighlightPage.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | Gets highlight layer with no items
Top
Public Properties
 | Name | Description
Public Property | Areas | Gets all highlight areas withing layer
Public Property | IsEmpty | Gets true if there's nothing on layer
Top
See Also

Reference

HighlightPage Class
GrapeCity.Viewer.Common.Model Namespace


HighlightPage Class Properties

HighlightPage Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : HighlightPage Class

For a list of all members of this type, see HighlightPage members.

Public Properties
 | Name | Description
Public Property | Areas | Gets all highlight areas withing layer
Public Property | IsEmpty | Gets true if there's nothing on layer
Top
See Also

Reference

HighlightPage Class
GrapeCity.Viewer.Common.Model Namespace


Areas Property

Areas Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > HighlightPage Class : Areas Property
Gets all highlight areas withing layer
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Areas As System.Collections.Generic.IEnumerable(Of HighlightArea)
public System.Collections.Generic.IEnumerable<HighlightArea> Areas {get;}
See Also

Reference

HighlightPage Class
HighlightPage Members


IsEmpty Property (HighlightPage)

IsEmpty Property (HighlightPage)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > HighlightPage Class : IsEmpty Property
Gets true if there's nothing on layer
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsEmpty As System.Boolean
public System.bool IsEmpty {get;}
See Also

Reference

HighlightPage Class
HighlightPage Members


HighlightPage Class Fields

HighlightPage Class Fields

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : HighlightPage Class

For a list of all members of this type, see HighlightPage members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | Gets highlight layer with no items
Top
See Also

Reference

HighlightPage Class
GrapeCity.Viewer.Common.Model Namespace


Empty Field (HighlightPage)

Empty Field (HighlightPage)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > HighlightPage Class : Empty Field
Gets highlight layer with no items
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Empty As HighlightPage
public static readonly HighlightPage Empty
See Also

Reference

HighlightPage Class
HighlightPage Members


ObservableExtensions Class

ObservableExtensions Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ObservableExtensions Class
Extends Observable<T> by helper methods.
Object Model
ObservableExtensions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit NotInheritable Class ObservableExtensions
public static class ObservableExtensions
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.Model.ObservableExtensions

See Also

Reference

ObservableExtensions Members
GrapeCity.Viewer.Common.Model Namespace


ObservableExtensions Class Members

ObservableExtensions Class Members
Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ObservableExtensions Class

The following tables list the members exposed by ObservableExtensions.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | AsObservable<T> | Wraps the type to observable value.
static (Shared in Visual Basic) | AsObservableCollection<T> | Wraps the list to observable collection.
Top
See Also

Reference

ObservableExtensions Class
GrapeCity.Viewer.Common.Model Namespace


ObservableExtensions Class Methods

ObservableExtensions Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ObservableExtensions Class

For a list of all members of this type, see ObservableExtensions members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | AsObservable<T> | Wraps the type to observable value.
static (Shared in Visual Basic) | AsObservableCollection<T> | Wraps the list to observable collection.
Top
See Also

Reference

ObservableExtensions Class
GrapeCity.Viewer.Common.Model Namespace


AsObservable<T> Method

AsObservable<T> Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ObservableExtensions Class : AsObservable<T> Method
Wraps the type to observable value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function AsObservable(Of T)( _
   ByVal value As T _
) As Observable(Of T)
public static Observable<T> AsObservable<T>(
   T value
)

Parameters

value

Type Parameters

T
See Also

Reference

ObservableExtensions Class
ObservableExtensions Members


AsObservableCollection<T> Method

AsObservableCollection<T> Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ObservableExtensions Class : AsObservableCollection<T> Method
Wraps the list to observable collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function AsObservableCollection(Of T)( _
   ByVal list As System.Collections.Generic.IList(Of T) _
) As ObservableCollection(Of T)
public static ObservableCollection<T> AsObservableCollection<T>(
   System.Collections.Generic.IList<T> list
)

Parameters

list

Type Parameters

T
See Also

Reference

ObservableExtensions Class
ObservableExtensions Members


ParameterizedReportExtensions Class

ParameterizedReportExtensions Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ParameterizedReportExtensions Class
Helpers for reports with parameters.
Object Model
ParameterizedReportExtensions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit NotInheritable Class ParameterizedReportExtensions
public static class ParameterizedReportExtensions
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.Model.ParameterizedReportExtensions

See Also

Reference

ParameterizedReportExtensions Members
GrapeCity.Viewer.Common.Model Namespace


ParameterizedReportExtensions Class Members

ParameterizedReportExtensions Class Members
Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ParameterizedReportExtensions Class

The following tables list the members exposed by ParameterizedReportExtensions.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | SetParameter | Updates the value of a parameter in the report.
Top
See Also

Reference

ParameterizedReportExtensions Class
GrapeCity.Viewer.Common.Model Namespace


ParameterizedReportExtensions Class Methods

ParameterizedReportExtensions Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ParameterizedReportExtensions Class

For a list of all members of this type, see ParameterizedReportExtensions members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | SetParameter | Updates the value of a parameter in the report.
Top
See Also

Reference

ParameterizedReportExtensions Class
GrapeCity.Viewer.Common.Model Namespace


SetParameter Method

SetParameter Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ParameterizedReportExtensions Class : SetParameter Method
The report with the parameters to update.
The name of the parameter to update.
The new value of the parameter.
Updates the value of a parameter in the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Sub SetParameter( _
   ByVal parameterizedReport As IParameterizedReport, _
   ByVal name As System.String, _
   ByVal values As System.Collections.Generic.IEnumerable(Of Object) _
)
public static void SetParameter(
   IParameterizedReport parameterizedReport,
   System.string name,
   System.Collections.Generic.IEnumerable<object> values
)

Parameters

parameterizedReport
The report with the parameters to update.
name
The name of the parameter to update.
values
The new value of the parameter.
See Also

Reference

ParameterizedReportExtensions Class
ParameterizedReportExtensions Members


RelativeDatePart Class

RelativeDatePart Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : RelativeDatePart Class
Defines part of relative date for DateTime parameters
Object Model
RelativeDatePart Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class RelativeDatePart
public sealed class RelativeDatePart
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.Model.RelativeDatePart

See Also

Reference

RelativeDatePart Members
GrapeCity.Viewer.Common.Model Namespace


RelativeDatePart Class Members

RelativeDatePart Class Members
Fields Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : RelativeDatePart Class

The following tables list the members exposed by RelativeDatePart.

Public Constructors
 | Name | Description
Public Constructor | RelativeDatePart Constructor | Initializes a new instance of the RelativeDatePart class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | DateRangeValues |
static (Shared in Visual Basic) | DateShiftValues |
static (Shared in Visual Basic) | DateStartValues |
static (Shared in Visual Basic) | RangeDay |
static (Shared in Visual Basic) | RangeMonth |
static (Shared in Visual Basic) | RangeQuarter |
static (Shared in Visual Basic) | RangeWeek |
static (Shared in Visual Basic) | RangeYear |
static (Shared in Visual Basic) | ShiftCurrent |
static (Shared in Visual Basic) | ShiftNext |
static (Shared in Visual Basic) | ShiftPrevius |
static (Shared in Visual Basic) | StartBegining |
static (Shared in Visual Basic) | StartEnd |
Top
Public Properties
 | Name | Description
Public Property | Label |
Public Property | Value |
Top
Public Methods
 | Name | Description
Public Method | Equals |
Public Method | GetHashCode |
Public Method | ToString |
Top
See Also

Reference

RelativeDatePart Class
GrapeCity.Viewer.Common.Model Namespace


RelativeDatePart Constructor

RelativeDatePart Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > RelativeDatePart Class : RelativeDatePart Constructor
Initializes a new instance of the RelativeDatePart class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal value As System.String, _
   ByVal label As System.String _
)
public RelativeDatePart(
   System.string value,
   System.string label
)

Parameters

value
label
See Also

Reference

RelativeDatePart Class
RelativeDatePart Members


RelativeDatePart Class Methods

RelativeDatePart Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : RelativeDatePart Class

For a list of all members of this type, see RelativeDatePart members.

Public Methods
 | Name | Description
Public Method | Equals |
Public Method | GetHashCode |
Public Method | ToString |
Top
See Also

Reference

RelativeDatePart Class
GrapeCity.Viewer.Common.Model Namespace


Equals Method (RelativeDatePart)

Equals Method (RelativeDatePart)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > RelativeDatePart Class : Equals Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
See Also

Reference

RelativeDatePart Class
RelativeDatePart Members


GetHashCode Method (RelativeDatePart)

GetHashCode Method (RelativeDatePart)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > RelativeDatePart Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()
See Also

Reference

RelativeDatePart Class
RelativeDatePart Members


ToString Method (RelativeDatePart)

ToString Method (RelativeDatePart)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > RelativeDatePart Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()
See Also

Reference

RelativeDatePart Class
RelativeDatePart Members


RelativeDatePart Class Properties

RelativeDatePart Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : RelativeDatePart Class

For a list of all members of this type, see RelativeDatePart members.

Public Properties
 | Name | Description
Public Property | Label |
Public Property | Value |
Top
See Also

Reference

RelativeDatePart Class
GrapeCity.Viewer.Common.Model Namespace


Label Property (RelativeDatePart)

Label Property (RelativeDatePart)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > RelativeDatePart Class : Label Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Label As System.String
public System.string Label {get;}
See Also

Reference

RelativeDatePart Class
RelativeDatePart Members


Value Property (RelativeDatePart)

Value Property (RelativeDatePart)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > RelativeDatePart Class : Value Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Value As System.String
public System.string Value {get;}
See Also

Reference

RelativeDatePart Class
RelativeDatePart Members


RelativeDatePart Class Fields

RelativeDatePart Class Fields

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : RelativeDatePart Class

For a list of all members of this type, see RelativeDatePart members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | DateRangeValues |
static (Shared in Visual Basic) | DateShiftValues |
static (Shared in Visual Basic) | DateStartValues |
static (Shared in Visual Basic) | RangeDay |
static (Shared in Visual Basic) | RangeMonth |
static (Shared in Visual Basic) | RangeQuarter |
static (Shared in Visual Basic) | RangeWeek |
static (Shared in Visual Basic) | RangeYear |
static (Shared in Visual Basic) | ShiftCurrent |
static (Shared in Visual Basic) | ShiftNext |
static (Shared in Visual Basic) | ShiftPrevius |
static (Shared in Visual Basic) | StartBegining |
static (Shared in Visual Basic) | StartEnd |
Top
See Also

Reference

RelativeDatePart Class
GrapeCity.Viewer.Common.Model Namespace


DateRangeValues Field

DateRangeValues Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > RelativeDatePart Class : DateRangeValues Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly DateRangeValues As RelativeDatePart()
public static readonly RelativeDatePart[] DateRangeValues
See Also

Reference

RelativeDatePart Class
RelativeDatePart Members


DateShiftValues Field

DateShiftValues Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > RelativeDatePart Class : DateShiftValues Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly DateShiftValues As RelativeDatePart()
public static readonly RelativeDatePart[] DateShiftValues
See Also

Reference

RelativeDatePart Class
RelativeDatePart Members


DateStartValues Field

DateStartValues Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > RelativeDatePart Class : DateStartValues Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly DateStartValues As RelativeDatePart()
public static readonly RelativeDatePart[] DateStartValues
See Also

Reference

RelativeDatePart Class
RelativeDatePart Members


RangeDay Field

RangeDay Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > RelativeDatePart Class : RangeDay Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly RangeDay As RelativeDatePart
public static readonly RelativeDatePart RangeDay
See Also

Reference

RelativeDatePart Class
RelativeDatePart Members


RangeMonth Field

RangeMonth Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > RelativeDatePart Class : RangeMonth Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly RangeMonth As RelativeDatePart
public static readonly RelativeDatePart RangeMonth
See Also

Reference

RelativeDatePart Class
RelativeDatePart Members


RangeQuarter Field

RangeQuarter Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > RelativeDatePart Class : RangeQuarter Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly RangeQuarter As RelativeDatePart
public static readonly RelativeDatePart RangeQuarter
See Also

Reference

RelativeDatePart Class
RelativeDatePart Members


RangeWeek Field

RangeWeek Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > RelativeDatePart Class : RangeWeek Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly RangeWeek As RelativeDatePart
public static readonly RelativeDatePart RangeWeek
See Also

Reference

RelativeDatePart Class
RelativeDatePart Members


RangeYear Field

RangeYear Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > RelativeDatePart Class : RangeYear Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly RangeYear As RelativeDatePart
public static readonly RelativeDatePart RangeYear
See Also

Reference

RelativeDatePart Class
RelativeDatePart Members


ShiftCurrent Field

ShiftCurrent Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > RelativeDatePart Class : ShiftCurrent Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly ShiftCurrent As RelativeDatePart
public static readonly RelativeDatePart ShiftCurrent
See Also

Reference

RelativeDatePart Class
RelativeDatePart Members


ShiftNext Field

ShiftNext Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > RelativeDatePart Class : ShiftNext Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly ShiftNext As RelativeDatePart
public static readonly RelativeDatePart ShiftNext
See Also

Reference

RelativeDatePart Class
RelativeDatePart Members


ShiftPrevius Field

ShiftPrevius Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > RelativeDatePart Class : ShiftPrevius Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly ShiftPrevius As RelativeDatePart
public static readonly RelativeDatePart ShiftPrevius
See Also

Reference

RelativeDatePart Class
RelativeDatePart Members


StartBegining Field

StartBegining Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > RelativeDatePart Class : StartBegining Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly StartBegining As RelativeDatePart
public static readonly RelativeDatePart StartBegining
See Also

Reference

RelativeDatePart Class
RelativeDatePart Members


StartEnd Field

StartEnd Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > RelativeDatePart Class : StartEnd Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly StartEnd As RelativeDatePart
public static readonly RelativeDatePart StartEnd
See Also

Reference

RelativeDatePart Class
RelativeDatePart Members


ReportModelBase Class

ReportModelBase Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ReportModelBase Class
Represents report instance
Object Model
ReportModelBase Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class ReportModelBase
   Inherits ActiveModel
public abstract class ReportModelBase : ActiveModel
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.Model.ReportModelBase

See Also

Reference

ReportModelBase Members
GrapeCity.Viewer.Common.Model Namespace


ReportModelBase Class Members

ReportModelBase Class Members
Fields Properties Methods Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ReportModelBase Class

The following tables list the members exposed by ReportModelBase.

Public Fields
 | Name | Description
Public Field | GracefulShutdownTimeoutMs | Time span given to reports to stop loading report, after which they will be forced to comply
Public Field | MaxTotalPageCount | The maximum total page count
Top
Public Properties
 | Name | Description
Public Property | AllowBackToParent | Gets true if report has the BackToParent capability
Public Property | AllowGalleyMode | Gets true if report has the GalleyMode option
Public Property | AllParametersValid | Gets true if all parameters got valid values and report could be executed
Public Property | AutoRun | Gets true is report should be executed after loading
Public Property | Cancel | Returns "Cancel loading" command
Public Property | DisableRefreshCancel | Disables Refresh/Cancel button as non-applicable (e.g. .Document is assigned in runtime).
Public Property | Error | Non-null if LoadState is LoadState.Error, null otherwise. Second class property: you will not be notified on this property change.
Public Property | GalleyMode | Gets true if report should be rendered in GalleyMode
Public Property | HasParameters | Indicates, that report has parameters. Non-volatile.
Public Property | LoadState | Gets current report execution/loading state
Public Property | ReportCulture | Culture of the report. Null if report don't have such information.
Public Property | Run | Gets "Execute" command
Top
Public Methods
 | Name | Description
Public Method | ClearBookmarks |
Public Method | Dispose |
Public Method | Load | Loads data into report. Must be implemented in descedants.
Public Method | RefreshBookmarks |
Public Method | SetupExecutionContext | HACK Temporary stub method to pass execution context back to report
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | (Inherited from GrapeCity.Viewer.Common.Model.ActiveModel)
Top
See Also

Reference

ReportModelBase Class
GrapeCity.Viewer.Common.Model Namespace


ReportModelBase Class Methods

ReportModelBase Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ReportModelBase Class

For a list of all members of this type, see ReportModelBase members.

Public Methods
 | Name | Description
Public Method | ClearBookmarks |
Public Method | Dispose |
Public Method | Load | Loads data into report. Must be implemented in descedants.
Public Method | RefreshBookmarks |
Public Method | SetupExecutionContext | HACK Temporary stub method to pass execution context back to report
Top
See Also

Reference

ReportModelBase Class
GrapeCity.Viewer.Common.Model Namespace


ClearBookmarks Method

ClearBookmarks Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportModelBase Class : ClearBookmarks Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ClearBookmarks()
public void ClearBookmarks()
See Also

Reference

ReportModelBase Class
ReportModelBase Members


Dispose Method (ReportModelBase)

Dispose Method (ReportModelBase)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportModelBase Class : Dispose Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub Dispose()
public virtual void Dispose()
See Also

Reference

ReportModelBase Class
ReportModelBase Members


Load Method (ReportModelBase)

Load Method (ReportModelBase)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportModelBase Class : Load Method
Loader that defines loading strategy
Loads data into report. Must be implemented in descedants.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Sub Load( _
   ByVal input As IDocumentLoader _
)
public abstract void Load(
   IDocumentLoader input
)

Parameters

input
Loader that defines loading strategy
See Also

Reference

ReportModelBase Class
ReportModelBase Members


RefreshBookmarks Method

RefreshBookmarks Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportModelBase Class : RefreshBookmarks Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RefreshBookmarks()
public void RefreshBookmarks()
See Also

Reference

ReportModelBase Class
ReportModelBase Members


SetupExecutionContext Method

SetupExecutionContext Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportModelBase Class : SetupExecutionContext Method
HACK Temporary stub method to pass execution context back to report
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub SetupExecutionContext( _
   ByVal context As System.Threading.SynchronizationContext, _
   ByVal consumer As IDocumentConsumer _
)
public virtual void SetupExecutionContext(
   System.Threading.SynchronizationContext context,
   IDocumentConsumer consumer
)

Parameters

context
consumer
See Also

Reference

ReportModelBase Class
ReportModelBase Members


ReportModelBase Class Properties

ReportModelBase Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ReportModelBase Class

For a list of all members of this type, see ReportModelBase members.

Public Properties
 | Name | Description
Public Property | AllowBackToParent | Gets true if report has the BackToParent capability
Public Property | AllowGalleyMode | Gets true if report has the GalleyMode option
Public Property | AllParametersValid | Gets true if all parameters got valid values and report could be executed
Public Property | AutoRun | Gets true is report should be executed after loading
Public Property | Cancel | Returns "Cancel loading" command
Public Property | DisableRefreshCancel | Disables Refresh/Cancel button as non-applicable (e.g. .Document is assigned in runtime).
Public Property | Error | Non-null if LoadState is LoadState.Error, null otherwise. Second class property: you will not be notified on this property change.
Public Property | GalleyMode | Gets true if report should be rendered in GalleyMode
Public Property | HasParameters | Indicates, that report has parameters. Non-volatile.
Public Property | LoadState | Gets current report execution/loading state
Public Property | ReportCulture | Culture of the report. Null if report don't have such information.
Public Property | Run | Gets "Execute" command
Top
See Also

Reference

ReportModelBase Class
GrapeCity.Viewer.Common.Model Namespace


AllowBackToParent Property

AllowBackToParent Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportModelBase Class : AllowBackToParent Property
Gets true if report has the BackToParent capability
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property AllowBackToParent As System.Boolean
public virtual System.bool AllowBackToParent {get;}
See Also

Reference

ReportModelBase Class
ReportModelBase Members


AllowGalleyMode Property

AllowGalleyMode Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportModelBase Class : AllowGalleyMode Property
Gets true if report has the GalleyMode option
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property AllowGalleyMode As System.Boolean
public virtual System.bool AllowGalleyMode {get;}
See Also

Reference

ReportModelBase Class
ReportModelBase Members


AllParametersValid Property

AllParametersValid Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportModelBase Class : AllParametersValid Property
Gets true if all parameters got valid values and report could be executed
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property AllParametersValid As System.Boolean
public System.bool AllParametersValid {get;}
See Also

Reference

ReportModelBase Class
ReportModelBase Members


AutoRun Property

AutoRun Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportModelBase Class : AutoRun Property
Gets true is report should be executed after loading
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property AutoRun As System.Boolean
public virtual System.bool AutoRun {get;}
See Also

Reference

ReportModelBase Class
ReportModelBase Members


Cancel Property (ReportModelBase)

Cancel Property (ReportModelBase)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportModelBase Class : Cancel Property
Returns "Cancel loading" command
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Cancel As IDelegateCommand
public IDelegateCommand Cancel {get;}
See Also

Reference

ReportModelBase Class
ReportModelBase Members


DisableRefreshCancel Property

DisableRefreshCancel Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportModelBase Class : DisableRefreshCancel Property
Disables Refresh/Cancel button as non-applicable (e.g. .Document is assigned in runtime).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DisableRefreshCancel As System.Boolean
public System.bool DisableRefreshCancel {get; set;}
See Also

Reference

ReportModelBase Class
ReportModelBase Members


Error Property

Error Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportModelBase Class : Error Property
Non-null if LoadState is LoadState.Error, null otherwise. Second class property: you will not be notified on this property change.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Error As System.Exception
public System.Exception Error {get;}
See Also

Reference

ReportModelBase Class
ReportModelBase Members


GalleyMode Property (ReportModelBase)

GalleyMode Property (ReportModelBase)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportModelBase Class : GalleyMode Property
Gets true if report should be rendered in GalleyMode
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GalleyMode As System.Boolean
public System.bool GalleyMode {get; set;}
See Also

Reference

ReportModelBase Class
ReportModelBase Members


HasParameters Property

HasParameters Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportModelBase Class : HasParameters Property
Indicates, that report has parameters. Non-volatile.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HasParameters As System.Boolean
public System.bool HasParameters {get;}
See Also

Reference

ReportModelBase Class
ReportModelBase Members


LoadState Property

LoadState Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportModelBase Class : LoadState Property
Gets current report execution/loading state
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property LoadState As LoadState
public LoadState LoadState {get;}
See Also

Reference

ReportModelBase Class
ReportModelBase Members


ReportCulture Property

ReportCulture Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportModelBase Class : ReportCulture Property
Culture of the report. Null if report don't have such information.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ReportCulture As System.Globalization.CultureInfo
public System.Globalization.CultureInfo ReportCulture {get;}
See Also

Reference

ReportModelBase Class
ReportModelBase Members


Run Property

Run Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportModelBase Class : Run Property
Gets "Execute" command
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Run As IDelegateCommand
public IDelegateCommand Run {get;}
See Also

Reference

ReportModelBase Class
ReportModelBase Members


ReportModelBase Class Fields

ReportModelBase Class Fields

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ReportModelBase Class

For a list of all members of this type, see ReportModelBase members.

Public Fields
 | Name | Description
Public Field | GracefulShutdownTimeoutMs | Time span given to reports to stop loading report, after which they will be forced to comply
Public Field | MaxTotalPageCount | The maximum total page count
Top
See Also

Reference

ReportModelBase Class
GrapeCity.Viewer.Common.Model Namespace


GracefulShutdownTimeoutMs Field

GracefulShutdownTimeoutMs Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportModelBase Class : GracefulShutdownTimeoutMs Field
Time span given to reports to stop loading report, after which they will be forced to comply
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const GracefulShutdownTimeoutMs As System.Integer
public const System.int GracefulShutdownTimeoutMs
See Also

Reference

ReportModelBase Class
ReportModelBase Members


MaxTotalPageCount Field

MaxTotalPageCount Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportModelBase Class : MaxTotalPageCount Field
The maximum total page count
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const MaxTotalPageCount As System.Integer
public const System.int MaxTotalPageCount
See Also

Reference

ReportModelBase Class
ReportModelBase Members


ReportPaneModel Class

ReportPaneModel Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ReportPaneModel Class
Model for report pane Model for report pane. This is a partial class contains only _zooms fild which has different definition in WPF project.
Object Model
ReportPaneModel Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ReportPaneModel
   Inherits ActiveModel
public sealed class ReportPaneModel : ActiveModel
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.Model.ReportPaneModel

See Also

Reference

ReportPaneModel Members
GrapeCity.Viewer.Common.Model Namespace


ReportPaneModel Class Members

ReportPaneModel Class Members
Fields Properties Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ReportPaneModel Class

The following tables list the members exposed by ReportPaneModel.

Public Constructors
 | Name | Description
Public Constructor | ReportPaneModel Constructor |
Top
Public Fields
 | Name | Description
Public Field | MaxZoomValue | The maximum zoom value
Public Field | MinZoomValue | The minimum zoom value
Top
Public Properties
 | Name | Description
Public Property | ColumnsCount | Gets columns count for multipage view
Public Property | CurrentPageIndex | Gets/sets current page index
Public Property | History | Provides history for current report pane
Public Property | IsActive | Gets/sets value, indicating that current report pane is active
Public Property | MouseMode | Gets/sets current mouse mode
Public Property | PageOffset | ar6 public api legacy
Public Property | RowsCount | Gets rows count for multipage view
Public Property | ScrollArea | Notification property specifying the area within a current page that should be visible at the time of property assigned
Public Property | ScrollPositionGetter |
Public Property | ScrollPositionSetter |
Public Property | SelectionFrame | Gets or sets selection frame
Public Property | ViewType | Gets/sets view type for current document
Public Property | ZoomMode | Gets/sets current zoom mode
Public Property | ZoomValue | Gets/sets explicit zoom value
Top
Public Events
 | Name | Description
Public Event | PropertyChanged | (Inherited from GrapeCity.Viewer.Common.Model.ActiveModel)
Top
See Also

Reference

ReportPaneModel Class
GrapeCity.Viewer.Common.Model Namespace


ReportPaneModel Constructor

ReportPaneModel Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportPaneModel Class : ReportPaneModel Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal viewerModel As ViewerModel _
)
public ReportPaneModel(
   ViewerModel viewerModel
)

Parameters

viewerModel
See Also

Reference

ReportPaneModel Class
ReportPaneModel Members


ReportPaneModel Class Properties

ReportPaneModel Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ReportPaneModel Class

For a list of all members of this type, see ReportPaneModel members.

Public Properties
 | Name | Description
Public Property | ColumnsCount | Gets columns count for multipage view
Public Property | CurrentPageIndex | Gets/sets current page index
Public Property | History | Provides history for current report pane
Public Property | IsActive | Gets/sets value, indicating that current report pane is active
Public Property | MouseMode | Gets/sets current mouse mode
Public Property | PageOffset | ar6 public api legacy
Public Property | RowsCount | Gets rows count for multipage view
Public Property | ScrollArea | Notification property specifying the area within a current page that should be visible at the time of property assigned
Public Property | ScrollPositionGetter |
Public Property | ScrollPositionSetter |
Public Property | SelectionFrame | Gets or sets selection frame
Public Property | ViewType | Gets/sets view type for current document
Public Property | ZoomMode | Gets/sets current zoom mode
Public Property | ZoomValue | Gets/sets explicit zoom value
Top
See Also

Reference

ReportPaneModel Class
GrapeCity.Viewer.Common.Model Namespace


ColumnsCount Property

ColumnsCount Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportPaneModel Class : ColumnsCount Property
Gets columns count for multipage view
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ColumnsCount As System.Integer
public System.int ColumnsCount {get; set;}
See Also

Reference

ReportPaneModel Class
ReportPaneModel Members


CurrentPageIndex Property

CurrentPageIndex Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportPaneModel Class : CurrentPageIndex Property
Gets/sets current page index
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CurrentPageIndex As System.Nullable(Of Integer)
public System.Nullable<int> CurrentPageIndex {get; set;}
See Also

Reference

ReportPaneModel Class
ReportPaneModel Members


History Property (ReportPaneModel)

History Property (ReportPaneModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportPaneModel Class : History Property
Provides history for current report pane
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property History As HistoryService
public HistoryService History {get;}
See Also

Reference

ReportPaneModel Class
ReportPaneModel Members


IsActive Property

IsActive Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportPaneModel Class : IsActive Property
Gets/sets value, indicating that current report pane is active
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsActive As System.Boolean
public System.bool IsActive {get; set;}
See Also

Reference

ReportPaneModel Class
ReportPaneModel Members


MouseMode Property (ReportPaneModel)

MouseMode Property (ReportPaneModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportPaneModel Class : MouseMode Property
Gets/sets current mouse mode
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MouseMode As MouseMode
public MouseMode MouseMode {get; set;}
See Also

Reference

ReportPaneModel Class
ReportPaneModel Members


PageOffset Property (ReportPaneModel)

PageOffset Property (ReportPaneModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportPaneModel Class : PageOffset Property
ar6 public api legacy
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageOffset As Point
public Point PageOffset {get; set;}
See Also

Reference

ReportPaneModel Class
ReportPaneModel Members


RowsCount Property (ReportPaneModel)

RowsCount Property (ReportPaneModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportPaneModel Class : RowsCount Property
Gets rows count for multipage view
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RowsCount As System.Integer
public System.int RowsCount {get; set;}
See Also

Reference

ReportPaneModel Class
ReportPaneModel Members


ScrollArea Property

ScrollArea Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportPaneModel Class : ScrollArea Property
Notification property specifying the area within a current page that should be visible at the time of property assigned
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ScrollArea As Rect
public Rect ScrollArea {get;}
See Also

Reference

ReportPaneModel Class
ReportPaneModel Members


ScrollPositionGetter Property

ScrollPositionGetter Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportPaneModel Class : ScrollPositionGetter Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ScrollPositionGetter As System.Func(Of Point)
public System.Func<Point> ScrollPositionGetter {get; set;}
See Also

Reference

ReportPaneModel Class
ReportPaneModel Members


ScrollPositionSetter Property

ScrollPositionSetter Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportPaneModel Class : ScrollPositionSetter Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ScrollPositionSetter As System.Action(Of Point)
public System.Action<Point> ScrollPositionSetter {get; set;}
See Also

Reference

ReportPaneModel Class
ReportPaneModel Members


SelectionFrame Property

SelectionFrame Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportPaneModel Class : SelectionFrame Property
Gets or sets selection frame
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SelectionFrame As Frame
public Frame SelectionFrame {get; set;}
See Also

Reference

ReportPaneModel Class
ReportPaneModel Members


ViewType Property (ReportPaneModel)

ViewType Property (ReportPaneModel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportPaneModel Class : ViewType Property
Gets/sets view type for current document
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ViewType As ViewType
public ViewType ViewType {get; set;}
See Also

Reference

ReportPaneModel Class
ReportPaneModel Members


ZoomMode Property

ZoomMode Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportPaneModel Class : ZoomMode Property
Gets/sets current zoom mode
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ZoomMode As ZoomMode
public ZoomMode ZoomMode {get; set;}
See Also

Reference

ReportPaneModel Class
ReportPaneModel Members


ZoomValue Property

ZoomValue Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportPaneModel Class : ZoomValue Property
Gets/sets explicit zoom value
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ZoomValue As System.Double
public System.double ZoomValue {get; set;}
See Also

Reference

ReportPaneModel Class
ReportPaneModel Members


ReportPaneModel Class Fields

ReportPaneModel Class Fields

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ReportPaneModel Class

For a list of all members of this type, see ReportPaneModel members.

Public Fields
 | Name | Description
Public Field | MaxZoomValue | The maximum zoom value
Public Field | MinZoomValue | The minimum zoom value
Top
See Also

Reference

ReportPaneModel Class
GrapeCity.Viewer.Common.Model Namespace


MaxZoomValue Field

MaxZoomValue Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportPaneModel Class : MaxZoomValue Field
The maximum zoom value
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const MaxZoomValue As System.Double
public const System.double MaxZoomValue
See Also

Reference

ReportPaneModel Class
ReportPaneModel Members


MinZoomValue Field

MinZoomValue Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ReportPaneModel Class : MinZoomValue Field
The minimum zoom value
Syntax
  • Visual Basic
  • C#
'Declaration

Public Const MinZoomValue As System.Double
public const System.double MinZoomValue
See Also

Reference

ReportPaneModel Class
ReportPaneModel Members


RunOptions Class

RunOptions Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : RunOptions Class
"Run" command options
Object Model
RunOptions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class RunOptions
public sealed class RunOptions
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.Model.RunOptions

See Also

Reference

RunOptions Members
GrapeCity.Viewer.Common.Model Namespace


RunOptions Class Members

RunOptions Class Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : RunOptions Class

The following tables list the members exposed by RunOptions.

Public Constructors
 | Name | Description
Public Constructor | RunOptions Constructor |
Top
Public Properties
 | Name | Description
Public Property | ForceDataRefresh |
Public Property | LoadCompleteCallback |
Public Property | StreamProvider |
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateDefault |
Top
See Also

Reference

RunOptions Class
GrapeCity.Viewer.Common.Model Namespace


RunOptions Constructor

RunOptions Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > RunOptions Class : RunOptions Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public RunOptions()
See Also

Reference

RunOptions Class
RunOptions Members


RunOptions Class Methods

RunOptions Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : RunOptions Class

For a list of all members of this type, see RunOptions members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CreateDefault |
Top
See Also

Reference

RunOptions Class
GrapeCity.Viewer.Common.Model Namespace


CreateDefault Method (RunOptions)

CreateDefault Method (RunOptions)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > RunOptions Class : CreateDefault Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function CreateDefault() As RunOptions
public static RunOptions CreateDefault()
See Also

Reference

RunOptions Class
RunOptions Members


RunOptions Class Properties

RunOptions Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : RunOptions Class

For a list of all members of this type, see RunOptions members.

Public Properties
 | Name | Description
Public Property | ForceDataRefresh |
Public Property | LoadCompleteCallback |
Public Property | StreamProvider |
Top
See Also

Reference

RunOptions Class
GrapeCity.Viewer.Common.Model Namespace


ForceDataRefresh Property

ForceDataRefresh Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > RunOptions Class : ForceDataRefresh Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ForceDataRefresh As System.Boolean
public System.bool ForceDataRefresh {get; set;}
See Also

Reference

RunOptions Class
RunOptions Members


LoadCompleteCallback Property

LoadCompleteCallback Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > RunOptions Class : LoadCompleteCallback Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LoadCompleteCallback As System.Action
public System.Action LoadCompleteCallback {get; set;}
See Also

Reference

RunOptions Class
RunOptions Members


StreamProvider Property

StreamProvider Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > RunOptions Class : StreamProvider Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StreamProvider As System.Object
public System.object StreamProvider {get; set;}
See Also

Reference

RunOptions Class
RunOptions Members


SearchResult Class

SearchResult Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : SearchResult Class
Represents text search result. The instances of the class are immutable and do not implement INotifyPropertyChanged then
Object Model
SearchResult Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class SearchResult
public class SearchResult
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.Model.SearchResult

See Also

Reference

SearchResult Members
GrapeCity.Viewer.Common.Model Namespace


SearchResult Class Members

SearchResult Class Members
Fields Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : SearchResult Class

The following tables list the members exposed by SearchResult.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | BeforeBegin | Special result value for Find method to begin searching from the beginning of the document/page
Public Field | DisplayText | Text to display
Public Field | ItemArea | Whole text item area coordinates
Public Field | ItemIndex | Logical page item number (for subsequent searches, ordered)
Public Field | PageIndex | The index of the page where occurence found.
static (Shared in Visual Basic) | PastEnd | Result indicating search is finished
Public Field | Range | Selection text range
Top
Public Properties
 | Name | Description
Public Property | IsValid | Ensures that SearchResult is not PastEnd or BeforeBegin (auxiliary values)
Top
Public Methods
 | Name | Description
Public Method | CompareTo |
static (Shared in Visual Basic) | Create | Overloaded. Creates new SearchResult instance
Public Method | Equals |
Public Method | GetHashCode |
Public Method | ToString |
Top
Public Operators
public Operator Equality
public Operator Inequality
Top
See Also

Reference

SearchResult Class
GrapeCity.Viewer.Common.Model Namespace


SearchResult Class Methods

SearchResult Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : SearchResult Class

For a list of all members of this type, see SearchResult members.

Public Methods
 | Name | Description
Public Method | CompareTo |
static (Shared in Visual Basic) | Create | Overloaded. Creates new SearchResult instance
Public Method | Equals |
Public Method | GetHashCode |
Public Method | ToString |
Top
See Also

Reference

SearchResult Class
GrapeCity.Viewer.Common.Model Namespace


CompareTo Method (SearchResult)

CompareTo Method (SearchResult)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > SearchResult Class : CompareTo Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CompareTo( _
   ByVal another As SearchResult _
) As System.Integer
public System.int CompareTo(
   SearchResult another
)

Parameters

another
See Also

Reference

SearchResult Class
SearchResult Members


Create Method (SearchResult)

Create Method (SearchResult)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > SearchResult Class : Create Method
Creates new SearchResult instance
Overload List
Overload | Description
Create(Int32,Int32,Range,String,Rect) | Creates new SearchResult instance
Create(Int32,Int32,Range) | Creates new SearchResult instance
See Also

Reference

SearchResult Class
SearchResult Members


Create(Int32,Int32,Range,String,Rect) Method

Create(Int32,Int32,Range,String,Rect) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > SearchResult Class > Create Method : Create(Int32,Int32,Range,String,Rect) Method
Creates new SearchResult instance
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Create( _
   ByVal pageNumber As System.Integer, _
   ByVal itemIndex As System.Integer, _
   ByVal range As Range, _
   ByVal displayText As System.String, _
   ByVal itemArea As Rect _
) As SearchResult
public static SearchResult Create(
   System.int pageNumber,
   System.int itemIndex,
   Range range,
   System.string displayText,
   Rect itemArea
)

Parameters

pageNumber
itemIndex
range
displayText
itemArea
See Also

Reference

SearchResult Class
SearchResult Members
Overload List


Create(Int32,Int32,Range) Method

Create(Int32,Int32,Range) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > SearchResult Class > Create Method : Create(Int32,Int32,Range) Method
Creates new SearchResult instance
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Create( _
   ByVal pageNumber As System.Integer, _
   ByVal itemIndex As System.Integer, _
   ByVal range As Range _
) As SearchResult
public static SearchResult Create(
   System.int pageNumber,
   System.int itemIndex,
   Range range
)

Parameters

pageNumber
itemIndex
range
See Also

Reference

SearchResult Class
SearchResult Members
Overload List


Equals Method (SearchResult)

Equals Method (SearchResult)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > SearchResult Class : Equals Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal o As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object o
)

Parameters

o
See Also

Reference

SearchResult Class
SearchResult Members


GetHashCode Method (SearchResult)

GetHashCode Method (SearchResult)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > SearchResult Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()
See Also

Reference

SearchResult Class
SearchResult Members


ToString Method (SearchResult)

ToString Method (SearchResult)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > SearchResult Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()
See Also

Reference

SearchResult Class
SearchResult Members


SearchResult Class Properties

SearchResult Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : SearchResult Class

For a list of all members of this type, see SearchResult members.

Public Properties
 | Name | Description
Public Property | IsValid | Ensures that SearchResult is not PastEnd or BeforeBegin (auxiliary values)
Top
See Also

Reference

SearchResult Class
GrapeCity.Viewer.Common.Model Namespace


IsValid Property (SearchResult)

IsValid Property (SearchResult)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > SearchResult Class : IsValid Property
Ensures that SearchResult is not PastEnd or BeforeBegin (auxiliary values)
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsValid As System.Boolean
public System.bool IsValid {get;}
See Also

Reference

SearchResult Class
SearchResult Members


SearchResult Class Fields

SearchResult Class Fields

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : SearchResult Class

For a list of all members of this type, see SearchResult members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | BeforeBegin | Special result value for Find method to begin searching from the beginning of the document/page
Public Field | DisplayText | Text to display
Public Field | ItemArea | Whole text item area coordinates
Public Field | ItemIndex | Logical page item number (for subsequent searches, ordered)
Public Field | PageIndex | The index of the page where occurence found.
static (Shared in Visual Basic) | PastEnd | Result indicating search is finished
Public Field | Range | Selection text range
Top
See Also

Reference

SearchResult Class
GrapeCity.Viewer.Common.Model Namespace


BeforeBegin Field

BeforeBegin Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > SearchResult Class : BeforeBegin Field
Special result value for Find method to begin searching from the beginning of the document/page
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly BeforeBegin As SearchResult
public static readonly SearchResult BeforeBegin
See Also

Reference

SearchResult Class
SearchResult Members


DisplayText Field

DisplayText Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > SearchResult Class : DisplayText Field
Text to display
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly DisplayText As System.String
public readonly System.string DisplayText
See Also

Reference

SearchResult Class
SearchResult Members


ItemArea Field

ItemArea Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > SearchResult Class : ItemArea Field
Whole text item area coordinates
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly ItemArea As Rect
public readonly Rect ItemArea
See Also

Reference

SearchResult Class
SearchResult Members


ItemIndex Field

ItemIndex Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > SearchResult Class : ItemIndex Field
Logical page item number (for subsequent searches, ordered)
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly ItemIndex As System.Integer
public readonly System.int ItemIndex
See Also

Reference

SearchResult Class
SearchResult Members


PageIndex Field (SearchResult)

PageIndex Field (SearchResult)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > SearchResult Class : PageIndex Field
The index of the page where occurence found.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly PageIndex As System.Integer
public readonly System.int PageIndex
See Also

Reference

SearchResult Class
SearchResult Members


PastEnd Field

PastEnd Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > SearchResult Class : PastEnd Field
Result indicating search is finished
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly PastEnd As SearchResult
public static readonly SearchResult PastEnd
See Also

Reference

SearchResult Class
SearchResult Members


Range Field

Range Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > SearchResult Class : Range Field
Selection text range
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Range As Range
public readonly Range Range
See Also

Reference

SearchResult Class
SearchResult Members


Equality Operator (SearchResult)

Equality Operator (SearchResult)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > SearchResult Class : Equality Operator
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator =( _
   ByVal result1 As SearchResult, _
   ByVal result2 As SearchResult _
) As System.Boolean
public System.bool operator ==(
   SearchResult result1,
   SearchResult result2
)

Parameters

result1
result2
See Also

Reference

SearchResult Class
SearchResult Members


Inequality Operator (SearchResult)

Inequality Operator (SearchResult)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > SearchResult Class : Inequality Operator
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator <>( _
   ByVal result1 As SearchResult, _
   ByVal result2 As SearchResult _
) As System.Boolean
public System.bool operator !=(
   SearchResult result1,
   SearchResult result2
)

Parameters

result1
result2
See Also

Reference

SearchResult Class
SearchResult Members


TocTreeNode Class

TocTreeNode Class
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : TocTreeNode Class
Represents bookmarks tree node
Object Model
TocTreeNode Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class TocTreeNode
   Implements GrapeCity.Viewer.Common.INotifyCollectionChanged
public sealed class TocTreeNode : GrapeCity.Viewer.Common.INotifyCollectionChanged
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.Model.TocTreeNode

See Also

Reference

TocTreeNode Members
GrapeCity.Viewer.Common.Model Namespace


TocTreeNode Class Members

TocTreeNode Class Members
Properties Methods Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : TocTreeNode Class

The following tables list the members exposed by TocTreeNode.

Public Constructors
 | Name | Description
Public Constructor | TocTreeNode Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bookmark | Gets bookmark instance the node contains
Public Property | IsLeaf | Gets true if node is leaf
Public Property | Nodes | Gets the nested toc nodes or empty list for leaf node
Top
Public Methods
 | Name | Description
Public Method | Add | Adds new node into collection
Top
Public Events
 | Name | Description
Public Event | CollectionChanged | Occurs when the items list of the collection has changed, or the collection is reset.
Top
See Also

Reference

TocTreeNode Class
GrapeCity.Viewer.Common.Model Namespace


TocTreeNode Constructor

TocTreeNode Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > TocTreeNode Class : TocTreeNode Constructor
Overload List
Overload | Description
TocTreeNode Constructor() | Just for serialization needs
TocTreeNode Constructor(Bookmark) | Initializes a new instance of the TocTreeNode class
TocTreeNode Constructor(Bookmark,IEnumerable<TocTreeNode>) | Initializes a new instance of the TocTreeNode class
See Also

Reference

TocTreeNode Class
TocTreeNode Members


TocTreeNode Constructor()

TocTreeNode Constructor()

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > TocTreeNode Class > TocTreeNode Constructor : TocTreeNode Constructor()
Just for serialization needs
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public TocTreeNode()
See Also

Reference

TocTreeNode Class
TocTreeNode Members
Overload List


TocTreeNode Constructor(Bookmark)

TocTreeNode Constructor(Bookmark)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > TocTreeNode Class > TocTreeNode Constructor : TocTreeNode Constructor(Bookmark)
Initializes a new instance of the TocTreeNode class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal bookmark As Bookmark _
)
public TocTreeNode(
   Bookmark bookmark
)

Parameters

bookmark
See Also

Reference

TocTreeNode Class
TocTreeNode Members
Overload List


TocTreeNode Constructor(Bookmark,IEnumerable<TocTreeNode>)

TocTreeNode Constructor(Bookmark,IEnumerable<TocTreeNode>)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > TocTreeNode Class > TocTreeNode Constructor : TocTreeNode Constructor(Bookmark,IEnumerable<TocTreeNode>)
Initializes a new instance of the TocTreeNode class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal bookmark As Bookmark, _
   ByVal nodes As System.Collections.Generic.IEnumerable(Of TocTreeNode) _
)
public TocTreeNode(
   Bookmark bookmark,
   System.Collections.Generic.IEnumerable<TocTreeNode> nodes
)

Parameters

bookmark
nodes
See Also

Reference

TocTreeNode Class
TocTreeNode Members
Overload List


TocTreeNode Class Methods

TocTreeNode Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : TocTreeNode Class

For a list of all members of this type, see TocTreeNode members.

Public Methods
 | Name | Description
Public Method | Add | Adds new node into collection
Top
See Also

Reference

TocTreeNode Class
GrapeCity.Viewer.Common.Model Namespace


Add Method (TocTreeNode)

Add Method (TocTreeNode)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > TocTreeNode Class : Add Method
Adds new node into collection
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal bookmark As Bookmark _
) As TocTreeNode
public TocTreeNode Add(
   Bookmark bookmark
)

Parameters

bookmark
See Also

Reference

TocTreeNode Class
TocTreeNode Members


TocTreeNode Class Properties

TocTreeNode Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : TocTreeNode Class

For a list of all members of this type, see TocTreeNode members.

Public Properties
 | Name | Description
Public Property | Bookmark | Gets bookmark instance the node contains
Public Property | IsLeaf | Gets true if node is leaf
Public Property | Nodes | Gets the nested toc nodes or empty list for leaf node
Top
See Also

Reference

TocTreeNode Class
GrapeCity.Viewer.Common.Model Namespace


Bookmark Property (TocTreeNode)

Bookmark Property (TocTreeNode)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > TocTreeNode Class : Bookmark Property
Gets bookmark instance the node contains
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Bookmark As Bookmark
public Bookmark Bookmark {get;}
See Also

Reference

TocTreeNode Class
TocTreeNode Members


IsLeaf Property

IsLeaf Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > TocTreeNode Class : IsLeaf Property
Gets true if node is leaf
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsLeaf As System.Boolean
public System.bool IsLeaf {get;}
See Also

Reference

TocTreeNode Class
TocTreeNode Members


Nodes Property

Nodes Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > TocTreeNode Class : Nodes Property
Gets the nested toc nodes or empty list for leaf node
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Nodes As System.Collections.Generic.List(Of TocTreeNode)
public System.Collections.Generic.List<TocTreeNode> Nodes {get;}
See Also

Reference

TocTreeNode Class
TocTreeNode Members


TocTreeNode Class Events

TocTreeNode Class Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : TocTreeNode Class

For a list of all members of this type, see TocTreeNode members.

Public Events
 | Name | Description
Public Event | CollectionChanged | Occurs when the items list of the collection has changed, or the collection is reset.
Top
See Also

Reference

TocTreeNode Class
GrapeCity.Viewer.Common.Model Namespace


CollectionChanged Event (TocTreeNode)

CollectionChanged Event (TocTreeNode)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > TocTreeNode Class : CollectionChanged Event
Occurs when the items list of the collection has changed, or the collection is reset.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event CollectionChanged As NotifyCollectionChangedEventHandler
public event NotifyCollectionChangedEventHandler CollectionChanged
See Also

Reference

TocTreeNode Class
TocTreeNode Members


Dock Enumeration

Dock Enumeration

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : Dock Enumeration
Specifies item alignment
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Dock
   Inherits System.Enum
public enum Dock : System.Enum
Members
Member | Description
Bottom | Control will be aligned to the bottom side
Left | Control will be aligned to the left side
Right | Control will be aligned to the right side
Top | Control will be aligned to the top side
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.Model.Dock

See Also

Reference

GrapeCity.Viewer.Common.Model Namespace


ErrorInfo.Level Enumeration

ErrorInfo.Level Enumeration

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ErrorInfo.Level Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ErrorInfo.Level
   Inherits System.Enum
public enum ErrorInfo.Level : System.Enum
Members
Member | Description
Error |
Info |
Warning |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.Model.ErrorInfo.Level

See Also

Reference

GrapeCity.Viewer.Common.Model Namespace


ErrorState Enumeration

ErrorState Enumeration

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ErrorState Enumeration
Defines current parameter state
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ErrorState
   Inherits System.Enum
public enum ErrorState : System.Enum
Members
Member | Description
Communicating |
DynamicValuesUnavailable |
ExpectValue |
HasOutstandingDependencies |
IsValidation |
Ok |
ValidationFailed |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.Model.ErrorState

See Also

Reference

GrapeCity.Viewer.Common.Model Namespace


ExportType Enumeration

ExportType Enumeration

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ExportType Enumeration
Export types enum
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ExportType
   Inherits System.Enum
public enum ExportType : System.Enum
Members
Member | Description
Html |
Image |
None |
Pdf |
Word |
Xls |
Xml |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.Model.ExportType

See Also

Reference

GrapeCity.Viewer.Common.Model Namespace


HighlightArea.Type Enumeration

HighlightArea.Type Enumeration

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : HighlightArea.Type Enumeration
Area type. Areas are rendered a bit differently depending on type
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum HighlightArea.Type
   Inherits System.Enum
public enum HighlightArea.Type : System.Enum
Members
Member | Description
Search | Search area type
Selection | Selection area type
SelectionFrame | Selectin frame area type
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.Model.HighlightArea.Type

See Also

Reference

GrapeCity.Viewer.Common.Model Namespace


MouseMode Enumeration

MouseMode Enumeration

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : MouseMode Enumeration
Specifies possible mouse modes
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum MouseMode
   Inherits System.Enum
public enum MouseMode : System.Enum
Members
Member | Description
CopySelect | In this mode it is allowed to copy selected area
Default | Default mode
Pan | Pan mode, allows to move page
Snapshot | In this mode snapshot of selected area is created
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.Model.MouseMode

See Also

Reference

GrapeCity.Viewer.Common.Model Namespace


ReportParameterType Enumeration

ReportParameterType Enumeration

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ReportParameterType Enumeration
Gets the parameter's value data type
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ReportParameterType
   Inherits System.Enum
public enum ReportParameterType : System.Enum
Members
Member | Description
Bool | Specifies the bool parameter type
DateTime | Specifies the DateTime parameter type
Float | Specifies the float parameter type
Int | Specifies the int parameter type
String | Specifies the string parameter type
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.Model.ReportParameterType

See Also

Reference

GrapeCity.Viewer.Common.Model Namespace


SidebarTabs Enumeration

SidebarTabs Enumeration

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : SidebarTabs Enumeration
For reference only. Defined position of sidebar panel within sidebar (either tab index or accordion pane index)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum SidebarTabs
   Inherits System.Enum
public enum SidebarTabs : System.Enum
Members
Member | Description
Parameters | Parameters pane
Search | Search pane
Thumbs | Thumbnails pane
Toc | Table of Content pane
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.Model.SidebarTabs

See Also

Reference

GrapeCity.Viewer.Common.Model Namespace


TouchMode Enumeration

TouchMode Enumeration

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : TouchMode Enumeration
Enable touch mode or not.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TouchMode
   Inherits System.Enum
public enum TouchMode : System.Enum
Members
Member | Description
Auto | Detects end-user environment automatically. If end-user environment supports touch, TouchMode works as True. Otherwise, TouchMode works as False.
False | Disable touch mode.
True | Enable touch mode.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.Model.TouchMode

See Also

Reference

GrapeCity.Viewer.Common.Model Namespace


TouchModeButtonVisibility Enumeration

TouchModeButtonVisibility Enumeration

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : TouchModeButtonVisibility Enumeration
Display Touch mode button on viewer's toolbar or not.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TouchModeButtonVisibility
   Inherits System.Enum
public enum TouchModeButtonVisibility : System.Enum
Members
Member | Description
Auto | Detects end-user environment automatically. When application is in touch-supported environment, the touch mode button is displayed. Otherwize, it is not displayed.
Hidden | Hide Touch mode button.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.Model.TouchModeButtonVisibility

See Also

Reference

GrapeCity.Viewer.Common.Model Namespace


ViewType Enumeration

ViewType Enumeration

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ViewType Enumeration
Possible view modes of the viewer control
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ViewType
   Inherits System.Enum
public enum ViewType : System.Enum
Members
Member | Description
Continuous | Multiple pages in one row will be shown
MultiPage | Multiple pages will be shown
SinglePage | Only one page will be shown
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.Model.ViewType

See Also

Reference

GrapeCity.Viewer.Common.Model Namespace


ZoomMode Enumeration

ZoomMode Enumeration

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ZoomMode Enumeration
Defined Zoom mode
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ZoomMode
   Inherits System.Enum
public enum ZoomMode : System.Enum
Members
Member | Description
FitGrid | Sets zoom value according to columns and rows count
FitPage | Sets zoom value to fit control both vertically and horizontally
FitWidth | Sets zoom value automatically to fit control horizontally
Free | Zoom value is specified explicitly
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.Model.ZoomMode

See Also

Reference

GrapeCity.Viewer.Common.Model Namespace


Bookmark Structure

Bookmark Structure
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : Bookmark Structure
Represents bookmark
Object Model
Bookmark Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure Bookmark
   Inherits System.ValueType
public struct Bookmark : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Viewer.Common.Model.Bookmark

See Also

Reference

Bookmark Members
GrapeCity.Viewer.Common.Model Namespace


Bookmark Structure Members

Bookmark Structure Members
Fields Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : Bookmark Structure

The following tables list the members exposed by Bookmark.

Public Constructors
 | Name | Description
Public Constructor | Bookmark Constructor | Overloaded.
Top
Public Fields
 | Name | Description
Public Field | Area | "Hot area" within a page
static (Shared in Visual Basic) | Empty | Gets empty bookmark instance (null-object)
Public Field | PageIndex | Index of bookmarked page
Top
Public Properties
 | Name | Description
Public Property | IsEmpty |
Public Property | Name | Name of the bookmark
Top
Public Methods
 | Name | Description
Public Method | Equals |
Public Method | GetHashCode |
Top
Public Operators
public Operator Equality
public Operator Inequality
Top
See Also

Reference

Bookmark Structure
GrapeCity.Viewer.Common.Model Namespace


Bookmark Constructor

Bookmark Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Bookmark Structure : Bookmark Constructor
Overload List
Overload | Description
Bookmark Constructor(String,Int32) |
Bookmark Constructor(String,Int32,Rect) |
See Also

Reference

Bookmark Structure
Bookmark Members


Bookmark Constructor(String,Int32)

Bookmark Constructor(String,Int32)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Bookmark Structure > Bookmark Constructor : Bookmark Constructor(String,Int32)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As System.String, _
   ByVal pageIndex As System.Integer _
)
public Bookmark(
   System.string name,
   System.int pageIndex
)

Parameters

name
pageIndex
See Also

Reference

Bookmark Structure
Bookmark Members
Overload List


Bookmark Constructor(String,Int32,Rect)

Bookmark Constructor(String,Int32,Rect)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Bookmark Structure > Bookmark Constructor : Bookmark Constructor(String,Int32,Rect)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As System.String, _
   ByVal pageIndex As System.Integer, _
   ByVal area As Rect _
)
public Bookmark(
   System.string name,
   System.int pageIndex,
   Rect area
)

Parameters

name
pageIndex
area
See Also

Reference

Bookmark Structure
Bookmark Members
Overload List


Bookmark Structure Methods

Bookmark Structure Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : Bookmark Structure

For a list of all members of this type, see Bookmark members.

Public Methods
 | Name | Description
Public Method | Equals |
Public Method | GetHashCode |
Top
See Also

Reference

Bookmark Structure
GrapeCity.Viewer.Common.Model Namespace


Equals Method (Bookmark)

Equals Method (Bookmark)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Bookmark Structure : Equals Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
See Also

Reference

Bookmark Structure
Bookmark Members


GetHashCode Method (Bookmark)

GetHashCode Method (Bookmark)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Bookmark Structure : GetHashCode Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()
See Also

Reference

Bookmark Structure
Bookmark Members


Bookmark Structure Properties

Bookmark Structure Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : Bookmark Structure

For a list of all members of this type, see Bookmark members.

Public Properties
 | Name | Description
Public Property | IsEmpty |
Public Property | Name | Name of the bookmark
Top
See Also

Reference

Bookmark Structure
GrapeCity.Viewer.Common.Model Namespace


IsEmpty Property (Bookmark)

IsEmpty Property (Bookmark)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Bookmark Structure : IsEmpty Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsEmpty As System.Boolean
public System.bool IsEmpty {get;}
See Also

Reference

Bookmark Structure
Bookmark Members


Name Property (Bookmark)

Name Property (Bookmark)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Bookmark Structure : Name Property
Name of the bookmark
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Name As System.String
public System.string Name {get;}
See Also

Reference

Bookmark Structure
Bookmark Members


Bookmark Structure Fields

Bookmark Structure Fields

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : Bookmark Structure

For a list of all members of this type, see Bookmark members.

Public Fields
 | Name | Description
Public Field | Area | "Hot area" within a page
static (Shared in Visual Basic) | Empty | Gets empty bookmark instance (null-object)
Public Field | PageIndex | Index of bookmarked page
Top
See Also

Reference

Bookmark Structure
GrapeCity.Viewer.Common.Model Namespace


Area Field

Area Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Bookmark Structure : Area Field
"Hot area" within a page
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Area As Rect
public readonly Rect Area
See Also

Reference

Bookmark Structure
Bookmark Members


Empty Field (Bookmark)

Empty Field (Bookmark)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Bookmark Structure : Empty Field
Gets empty bookmark instance (null-object)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Empty As Bookmark
public static readonly Bookmark Empty
See Also

Reference

Bookmark Structure
Bookmark Members


PageIndex Field (Bookmark)

PageIndex Field (Bookmark)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Bookmark Structure : PageIndex Field
Index of bookmarked page
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly PageIndex As System.Integer
public readonly System.int PageIndex
See Also

Reference

Bookmark Structure
Bookmark Members


Equality Operator (Bookmark)

Equality Operator (Bookmark)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Bookmark Structure : Equality Operator
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator =( _
   ByVal a As Bookmark, _
   ByVal b As Bookmark _
) As System.Boolean
public System.bool operator ==(
   Bookmark a,
   Bookmark b
)

Parameters

a
b
See Also

Reference

Bookmark Structure
Bookmark Members


Inequality Operator (Bookmark)

Inequality Operator (Bookmark)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Bookmark Structure : Inequality Operator
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator <>( _
   ByVal a As Bookmark, _
   ByVal b As Bookmark _
) As System.Boolean
public System.bool operator !=(
   Bookmark a,
   Bookmark b
)

Parameters

a
b
See Also

Reference

Bookmark Structure
Bookmark Members


DocumentModel.PaperInfo Structure

DocumentModel.PaperInfo Structure
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel.PaperInfo Structure
Represents paper information
Object Model
DocumentModel.PaperInfo Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure DocumentModel.PaperInfo
   Inherits System.ValueType
public struct DocumentModel.PaperInfo : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Viewer.Common.Model.DocumentModel.PaperInfo

See Also

Reference

DocumentModel.PaperInfo Members
GrapeCity.Viewer.Common.Model Namespace


DocumentModel.PaperInfo Structure Members

DocumentModel.PaperInfo Structure Members
Fields Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel.PaperInfo Structure

The following tables list the members exposed by DocumentModel.PaperInfo.

Public Constructors
 | Name | Description
Public Constructor | DocumentModel.PaperInfo Constructor | Initializes a new instance of the DocumentModel.PaperInfo struct.
Top
Public Fields
 | Name | Description
Public Field | IsLandscape | Whether the paper is ladscape
Public Field | SizeIn | Gets page size in device independent units (inches)
Top
Public Properties
 | Name | Description
static (Shared in Visual Basic) | Empty | Gets the empty instance.
Top
Public Methods
 | Name | Description
Public Method | Equals | Overloaded.
Public Method | GetHashCode |
Top
Public Operators
public Operator Equality
public Operator Inequality
Top
See Also

Reference

DocumentModel.PaperInfo Structure
GrapeCity.Viewer.Common.Model Namespace


DocumentModel.PaperInfo Constructor

DocumentModel.PaperInfo Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel.PaperInfo Structure : DocumentModel.PaperInfo Constructor
The size in inches.
Initializes a new instance of the DocumentModel.PaperInfo struct.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal sizeIn As Size, _
   ByVal isLandscape As System.Boolean _
)
public DocumentModel.PaperInfo(
   Size sizeIn,
   System.bool isLandscape
)

Parameters

sizeIn
The size in inches.
isLandscape
See Also

Reference

DocumentModel.PaperInfo Structure
DocumentModel.PaperInfo Members


DocumentModel.PaperInfo Structure Methods

DocumentModel.PaperInfo Structure Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel.PaperInfo Structure

For a list of all members of this type, see DocumentModel.PaperInfo members.

Public Methods
 | Name | Description
Public Method | Equals | Overloaded.
Public Method | GetHashCode |
Top
See Also

Reference

DocumentModel.PaperInfo Structure
GrapeCity.Viewer.Common.Model Namespace


Equals Method (DocumentModel.PaperInfo)

Equals Method (DocumentModel.PaperInfo)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel.PaperInfo Structure : Equals Method
Overload List
Overload | Description
Equals(Object) |
Equals(PaperInfo) |
See Also

Reference

DocumentModel.PaperInfo Structure
DocumentModel.PaperInfo Members


Equals(Object) Method

Equals(Object) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel.PaperInfo Structure > Equals Method : Equals(Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
See Also

Reference

DocumentModel.PaperInfo Structure
DocumentModel.PaperInfo Members
Overload List


Equals(PaperInfo) Method

Equals(PaperInfo) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel.PaperInfo Structure > Equals Method : Equals(PaperInfo) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Equals( _
   ByVal other As DocumentModel.PaperInfo _
) As System.Boolean
public System.bool Equals(
   DocumentModel.PaperInfo other
)

Parameters

other
See Also

Reference

DocumentModel.PaperInfo Structure
DocumentModel.PaperInfo Members
Overload List


GetHashCode Method (DocumentModel.PaperInfo)

GetHashCode Method (DocumentModel.PaperInfo)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel.PaperInfo Structure : GetHashCode Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()
See Also

Reference

DocumentModel.PaperInfo Structure
DocumentModel.PaperInfo Members


DocumentModel.PaperInfo Structure Properties

DocumentModel.PaperInfo Structure Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel.PaperInfo Structure

For a list of all members of this type, see DocumentModel.PaperInfo members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | Empty | Gets the empty instance.
Top
See Also

Reference

DocumentModel.PaperInfo Structure
GrapeCity.Viewer.Common.Model Namespace


Empty Property (DocumentModel.PaperInfo)

Empty Property (DocumentModel.PaperInfo)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel.PaperInfo Structure : Empty Property
Gets the empty instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property Empty As DocumentModel.PaperInfo
public static DocumentModel.PaperInfo Empty {get;}
See Also

Reference

DocumentModel.PaperInfo Structure
DocumentModel.PaperInfo Members


DocumentModel.PaperInfo Structure Fields

DocumentModel.PaperInfo Structure Fields

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel.PaperInfo Structure

For a list of all members of this type, see DocumentModel.PaperInfo members.

Public Fields
 | Name | Description
Public Field | IsLandscape | Whether the paper is ladscape
Public Field | SizeIn | Gets page size in device independent units (inches)
Top
See Also

Reference

DocumentModel.PaperInfo Structure
GrapeCity.Viewer.Common.Model Namespace


IsLandscape Field

IsLandscape Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel.PaperInfo Structure : IsLandscape Field
Whether the paper is ladscape
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly IsLandscape As System.Boolean
public readonly System.bool IsLandscape
See Also

Reference

DocumentModel.PaperInfo Structure
DocumentModel.PaperInfo Members


SizeIn Field

SizeIn Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel.PaperInfo Structure : SizeIn Field
Gets page size in device independent units (inches)
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly SizeIn As Size
public readonly Size SizeIn
See Also

Reference

DocumentModel.PaperInfo Structure
DocumentModel.PaperInfo Members


Equality Operator (DocumentModel.PaperInfo)

Equality Operator (DocumentModel.PaperInfo)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel.PaperInfo Structure : Equality Operator
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator =( _
   ByVal s1 As DocumentModel.PaperInfo, _
   ByVal s2 As DocumentModel.PaperInfo _
) As System.Boolean
public System.bool operator ==(
   DocumentModel.PaperInfo s1,
   DocumentModel.PaperInfo s2
)

Parameters

s1
s2
See Also

Reference

DocumentModel.PaperInfo Structure
DocumentModel.PaperInfo Members


Inequality Operator (DocumentModel.PaperInfo)

Inequality Operator (DocumentModel.PaperInfo)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel.PaperInfo Structure : Inequality Operator
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator <>( _
   ByVal s1 As DocumentModel.PaperInfo, _
   ByVal s2 As DocumentModel.PaperInfo _
) As System.Boolean
public System.bool operator !=(
   DocumentModel.PaperInfo s1,
   DocumentModel.PaperInfo s2
)

Parameters

s1
s2
See Also

Reference

DocumentModel.PaperInfo Structure
DocumentModel.PaperInfo Members


DocumentSelection Structure

DocumentSelection Structure
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentSelection Structure
Represents selected document items. Immutable object! This implementation is somewhat implementation bound since it treats selection as a collection of "page items" on particular page
Object Model
DocumentSelection Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure DocumentSelection
   Inherits System.ValueType
public struct DocumentSelection : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Viewer.Common.Model.DocumentSelection

See Also

Reference

DocumentSelection Members
GrapeCity.Viewer.Common.Model Namespace


DocumentSelection Structure Members

DocumentSelection Structure Members
Fields Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentSelection Structure

The following tables list the members exposed by DocumentSelection.

Public Constructors
 | Name | Description
Public Constructor | DocumentSelection Constructor | Initializes a new instance of the Selection class
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | Gets empty instance
Top
Public Properties
 | Name | Description
Public Property | IsEmpty | Gets true if selection is empty
Public Property | Items | Gets currently selected items
Public Property | PageIndex | Gets the page the selection items belongs to
Top
Public Methods
 | Name | Description
Public Method | Append | Returns new selection as a current
Public Method | Equals | Overloaded.
Top
See Also

Reference

DocumentSelection Structure
GrapeCity.Viewer.Common.Model Namespace


DocumentSelection Constructor

DocumentSelection Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentSelection Structure : DocumentSelection Constructor
Initializes a new instance of the Selection class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal pageIndex As System.Integer, _
   ByVal items As System.Collections.Generic.IEnumerable(Of DocumentModel.IPageItem) _
)
public DocumentSelection(
   System.int pageIndex,
   System.Collections.Generic.IEnumerable<DocumentModel.IPageItem> items
)

Parameters

pageIndex
items
See Also

Reference

DocumentSelection Structure
DocumentSelection Members


DocumentSelection Structure Methods

DocumentSelection Structure Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentSelection Structure

For a list of all members of this type, see DocumentSelection members.

Public Methods
 | Name | Description
Public Method | Append | Returns new selection as a current
Public Method | Equals | Overloaded.
Top
See Also

Reference

DocumentSelection Structure
GrapeCity.Viewer.Common.Model Namespace


Append Method

Append Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentSelection Structure : Append Method
Returns new selection as a current
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Append( _
   ByVal items As System.Collections.Generic.IEnumerable(Of DocumentModel.IPageItem) _
) As DocumentSelection
public DocumentSelection Append(
   System.Collections.Generic.IEnumerable<DocumentModel.IPageItem> items
)

Parameters

items
See Also

Reference

DocumentSelection Structure
DocumentSelection Members


Equals Method (DocumentSelection)

Equals Method (DocumentSelection)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentSelection Structure : Equals Method
Overload List
Overload | Description
Equals(DocumentSelection) |
See Also

Reference

DocumentSelection Structure
DocumentSelection Members


Equals(DocumentSelection) Method

Equals(DocumentSelection) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentSelection Structure > Equals Method : Equals(DocumentSelection) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Equals( _
   ByVal other As DocumentSelection _
) As System.Boolean
public System.bool Equals(
   DocumentSelection other
)

Parameters

other
See Also

Reference

DocumentSelection Structure
DocumentSelection Members
Overload List


DocumentSelection Structure Properties

DocumentSelection Structure Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentSelection Structure

For a list of all members of this type, see DocumentSelection members.

Public Properties
 | Name | Description
Public Property | IsEmpty | Gets true if selection is empty
Public Property | Items | Gets currently selected items
Public Property | PageIndex | Gets the page the selection items belongs to
Top
See Also

Reference

DocumentSelection Structure
GrapeCity.Viewer.Common.Model Namespace


IsEmpty Property (DocumentSelection)

IsEmpty Property (DocumentSelection)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentSelection Structure : IsEmpty Property
Gets true if selection is empty
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsEmpty As System.Boolean
public System.bool IsEmpty {get;}
See Also

Reference

DocumentSelection Structure
DocumentSelection Members


Items Property

Items Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentSelection Structure : Items Property
Gets currently selected items
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Items As System.Collections.Generic.IList(Of DocumentModel.IPageItem)
public System.Collections.Generic.IList<DocumentModel.IPageItem> Items {get;}
See Also

Reference

DocumentSelection Structure
DocumentSelection Members


PageIndex Property (DocumentSelection)

PageIndex Property (DocumentSelection)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentSelection Structure : PageIndex Property
Gets the page the selection items belongs to
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PageIndex As System.Integer
public System.int PageIndex {get;}
See Also

Reference

DocumentSelection Structure
DocumentSelection Members


DocumentSelection Structure Fields

DocumentSelection Structure Fields

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentSelection Structure

For a list of all members of this type, see DocumentSelection members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | Gets empty instance
Top
See Also

Reference

DocumentSelection Structure
GrapeCity.Viewer.Common.Model Namespace


Empty Field (DocumentSelection)

Empty Field (DocumentSelection)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentSelection Structure : Empty Field
Gets empty instance
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Empty As DocumentSelection
public static DocumentSelection Empty
See Also

Reference

DocumentSelection Structure
DocumentSelection Members


ErrorInfo Structure

ErrorInfo Structure
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ErrorInfo Structure
Represents information about errors/exceptions
Object Model
ErrorInfo Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure ErrorInfo
   Inherits System.ValueType
public struct ErrorInfo : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Viewer.Common.Model.ErrorInfo

See Also

Reference

ErrorInfo Members
GrapeCity.Viewer.Common.Model Namespace


ErrorInfo Structure Members

ErrorInfo Structure Members
Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ErrorInfo Structure

The following tables list the members exposed by ErrorInfo.

Public Constructors
 | Name | Description
Public Constructor | ErrorInfo Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Exception | Gets the exception.
Public Property | Info | Gets the error information.
Public Property | Severity | Gets the error level.
Top
See Also

Reference

ErrorInfo Structure
GrapeCity.Viewer.Common.Model Namespace


ErrorInfo Constructor

ErrorInfo Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ErrorInfo Structure : ErrorInfo Constructor
Overload List
Overload | Description
ErrorInfo Constructor(Exception) | Initializes a new instance of the ErrorInfo struct.
ErrorInfo Constructor(Level,String) | Initializes a new instance of the ErrorInfo struct.
See Also

Reference

ErrorInfo Structure
ErrorInfo Members


ErrorInfo Constructor(Exception)

ErrorInfo Constructor(Exception)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ErrorInfo Structure > ErrorInfo Constructor : ErrorInfo Constructor(Exception)
Initializes a new instance of the ErrorInfo struct.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal exception As System.Exception _
)
public ErrorInfo(
   System.Exception exception
)

Parameters

exception
See Also

Reference

ErrorInfo Structure
ErrorInfo Members
Overload List


ErrorInfo Constructor(Level,String)

ErrorInfo Constructor(Level,String)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ErrorInfo Structure > ErrorInfo Constructor : ErrorInfo Constructor(Level,String)
Initializes a new instance of the ErrorInfo struct.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal level As ErrorInfo.Level, _
   ByVal info As System.String _
)
public ErrorInfo(
   ErrorInfo.Level level,
   System.string info
)

Parameters

level
info
See Also

Reference

ErrorInfo Structure
ErrorInfo Members
Overload List


ErrorInfo Structure Properties

ErrorInfo Structure Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ErrorInfo Structure

For a list of all members of this type, see ErrorInfo members.

Public Properties
 | Name | Description
Public Property | Exception | Gets the exception.
Public Property | Info | Gets the error information.
Public Property | Severity | Gets the error level.
Top
See Also

Reference

ErrorInfo Structure
GrapeCity.Viewer.Common.Model Namespace


Exception Property (ErrorInfo)

Exception Property (ErrorInfo)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ErrorInfo Structure : Exception Property
Gets the exception.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Exception As System.Exception
public System.Exception Exception {get;}
See Also

Reference

ErrorInfo Structure
ErrorInfo Members


Info Property

Info Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ErrorInfo Structure : Info Property
Gets the error information.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Info As System.String
public System.string Info {get;}
See Also

Reference

ErrorInfo Structure
ErrorInfo Members


Severity Property (ErrorInfo)

Severity Property (ErrorInfo)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ErrorInfo Structure : Severity Property
Gets the error level.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Severity As ErrorInfo.Level
public ErrorInfo.Level Severity {get;}
See Also

Reference

ErrorInfo Structure
ErrorInfo Members


Frame Structure

Frame Structure
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : Frame Structure
Represents selection area
Object Model
Frame Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure Frame
   Inherits System.ValueType
public struct Frame : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Viewer.Common.Model.Frame

See Also

Reference

Frame Members
GrapeCity.Viewer.Common.Model Namespace


Frame Structure Members

Frame Structure Members
Fields Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : Frame Structure

The following tables list the members exposed by Frame.

Public Constructors
 | Name | Description
Public Constructor | Frame Constructor | Initializes a new instance of the Frame struct.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty |
Top
Public Properties
 | Name | Description
Public Property | Bounds | Gets or sets the frame within page coordinates
Public Property | IsEmpty | Gets true is selection is empty
Public Property | PageIndex | Gets or sets the page containing selection
Top
See Also

Reference

Frame Structure
GrapeCity.Viewer.Common.Model Namespace


Frame Constructor

Frame Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Frame Structure : Frame Constructor
Index of the page.
The frame.
Initializes a new instance of the Frame struct.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal pageIndex As System.Integer, _
   ByVal frame As Rect _
)
public Frame(
   System.int pageIndex,
   Rect frame
)

Parameters

pageIndex
Index of the page.
frame
The frame.
See Also

Reference

Frame Structure
Frame Members


Frame Structure Properties

Frame Structure Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : Frame Structure

For a list of all members of this type, see Frame members.

Public Properties
 | Name | Description
Public Property | Bounds | Gets or sets the frame within page coordinates
Public Property | IsEmpty | Gets true is selection is empty
Public Property | PageIndex | Gets or sets the page containing selection
Top
See Also

Reference

Frame Structure
GrapeCity.Viewer.Common.Model Namespace


Bounds Property (Frame)

Bounds Property (Frame)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Frame Structure : Bounds Property
Gets or sets the frame within page coordinates
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Bounds As Rect
public Rect Bounds {get;}
See Also

Reference

Frame Structure
Frame Members


IsEmpty Property (Frame)

IsEmpty Property (Frame)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Frame Structure : IsEmpty Property
Gets true is selection is empty
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsEmpty As System.Boolean
public System.bool IsEmpty {get;}
See Also

Reference

Frame Structure
Frame Members


PageIndex Property (Frame)

PageIndex Property (Frame)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Frame Structure : PageIndex Property
Gets or sets the page containing selection
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PageIndex As System.Integer
public System.int PageIndex {get;}
See Also

Reference

Frame Structure
Frame Members


Frame Structure Fields

Frame Structure Fields

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : Frame Structure

For a list of all members of this type, see Frame members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty |
Top
See Also

Reference

Frame Structure
GrapeCity.Viewer.Common.Model Namespace


Empty Field (Frame)

Empty Field (Frame)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Frame Structure : Empty Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Empty As Frame
public static readonly Frame Empty
See Also

Reference

Frame Structure
Frame Members


HighlightArea Structure

HighlightArea Structure
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : HighlightArea Structure
Identifies highlight area within a report page
Object Model
HighlightArea Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure HighlightArea
   Inherits System.ValueType
public struct HighlightArea : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Viewer.Common.Model.HighlightArea

See Also

Reference

HighlightArea Members
GrapeCity.Viewer.Common.Model Namespace


HighlightArea Structure Members

HighlightArea Structure Members
Fields

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : HighlightArea Structure

The following tables list the members exposed by HighlightArea.

Public Fields
 | Name | Description
Public Field | AreaType | Gets area type (it might be rendered with a different color)
Public Field | Bounds | Gets area bounds
Top
See Also

Reference

HighlightArea Structure
GrapeCity.Viewer.Common.Model Namespace


HighlightArea Structure Fields

HighlightArea Structure Fields

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : HighlightArea Structure

For a list of all members of this type, see HighlightArea members.

Public Fields
 | Name | Description
Public Field | AreaType | Gets area type (it might be rendered with a different color)
Public Field | Bounds | Gets area bounds
Top
See Also

Reference

HighlightArea Structure
GrapeCity.Viewer.Common.Model Namespace


AreaType Field

AreaType Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > HighlightArea Structure : AreaType Field
Gets area type (it might be rendered with a different color)
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly AreaType As HighlightArea.Type
public readonly HighlightArea.Type AreaType
See Also

Reference

HighlightArea Structure
HighlightArea Members


Bounds Field

Bounds Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > HighlightArea Structure : Bounds Field
Gets area bounds
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Bounds As Rect
public readonly Rect Bounds
See Also

Reference

HighlightArea Structure
HighlightArea Members


Range Structure

Range Structure
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : Range Structure
Arbitrary range implementation
Object Model
Range Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure Range
   Inherits System.ValueType
public struct Range : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Viewer.Common.Model.Range

See Also

Reference

Range Members
GrapeCity.Viewer.Common.Model Namespace


Range Structure Members

Range Structure Members
Fields Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : Range Structure

The following tables list the members exposed by Range.

Public Constructors
 | Name | Description
Public Constructor | Range Constructor | Overloaded.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | Gets empty range
Public Field | Length | The length of the Range
Public Field | Start | The start of the Range
Top
Public Properties
 | Name | Description
Public Property | End | Gets the first position past the end of range
Public Property | IsEmpty | Gets true if range represents empty one
Public Property | IsEndOpen | Gets a value indicating whether the end of this Range equals to int.MaxValue.
Top
Public Methods
 | Name | Description
Public Method | Contains | Gets true if range contains specific item
Public Method | Equals | Overloaded. Determines whether the specified System.Object is equal to this instance.
static (Shared in Visual Basic) | For | Initializes a new range from start and end points.
Public Method | GetHashCode | Returns a hash code for this instance.
static (Shared in Visual Basic) | Parse | Parses string input to Range
Public Method | ToString | Returns a System.String that represents this instance in 'Start - End' format.
static (Shared in Visual Basic) | Translate | Translates range by shift value, OpenEnd wise.
Top
See Also

Reference

Range Structure
GrapeCity.Viewer.Common.Model Namespace


Range Constructor

Range Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Range Structure : Range Constructor
Overload List
Overload | Description
Range Constructor(Int32) | Initializes a new instance of the Range struct.
Range Constructor(Int32,Nullable<Int32>) | Initializes a new instance of the Range struct.
See Also

Reference

Range Structure
Range Members


Range Constructor(Int32)

Range Constructor(Int32)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Range Structure > Range Constructor : Range Constructor(Int32)
The start of the Range.
Initializes a new instance of the Range struct.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal value As System.Integer _
)
public Range(
   System.int value
)

Parameters

value
The start of the Range.
See Also

Reference

Range Structure
Range Members
Overload List


Range Constructor(Int32,Nullable<Int32>)

Range Constructor(Int32,Nullable<Int32>)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Range Structure > Range Constructor : Range Constructor(Int32,Nullable<Int32>)
The start of the range.
The length of the range.
Initializes a new instance of the Range struct.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal start As System.Integer, _
   ByVal length As System.Nullable(Of Integer) _
)
public Range(
   System.int start,
   System.Nullable<int> length
)

Parameters

start
The start of the range.
length
The length of the range.
See Also

Reference

Range Structure
Range Members
Overload List


Range Structure Methods

Range Structure Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : Range Structure

For a list of all members of this type, see Range members.

Public Methods
 | Name | Description
Public Method | Contains | Gets true if range contains specific item
Public Method | Equals | Overloaded. Determines whether the specified System.Object is equal to this instance.
static (Shared in Visual Basic) | For | Initializes a new range from start and end points.
Public Method | GetHashCode | Returns a hash code for this instance.
static (Shared in Visual Basic) | Parse | Parses string input to Range
Public Method | ToString | Returns a System.String that represents this instance in 'Start - End' format.
static (Shared in Visual Basic) | Translate | Translates range by shift value, OpenEnd wise.
Top
See Also

Reference

Range Structure
GrapeCity.Viewer.Common.Model Namespace


Contains Method (Range)

Contains Method (Range)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Range Structure : Contains Method
Gets true if range contains specific item
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal value As System.Integer _
) As System.Boolean
public System.bool Contains(
   System.int value
)

Parameters

value
See Also

Reference

Range Structure
Range Members


Equals Method (Range)

Equals Method (Range)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Range Structure : Equals Method
Determines whether the specified System.Object is equal to this instance.
Overload List
Overload | Description
Equals(Object) | Determines whether the specified System.Object is equal to this instance.
Equals(Range) | Determines whether the specified Range is equal to this instance.
See Also

Reference

Range Structure
Range Members


Equals(Object) Method

Equals(Object) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Range Structure > Equals Method : Equals(Object) Method
Determines whether the specified System.Object is equal to this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overrides Function Equals( _
   ByVal o As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object o
)

Parameters

o
See Also

Reference

Range Structure
Range Members
Overload List


Equals(Range) Method

Equals(Range) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Range Structure > Equals Method : Equals(Range) Method
Determines whether the specified Range is equal to this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Equals( _
   ByVal other As Range _
) As System.Boolean
public System.bool Equals(
   Range other
)

Parameters

other
See Also

Reference

Range Structure
Range Members
Overload List


For Method

For Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Range Structure : For Method
Initializes a new range from start and end points.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function For( _
   ByVal start As System.Integer, _
   ByVal end As System.Integer _
) As Range
public static Range For(
   System.int start,
   System.int end
)

Parameters

start
end
See Also

Reference

Range Structure
Range Members


GetHashCode Method (Range)

GetHashCode Method (Range)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Range Structure : GetHashCode Method
Returns a hash code for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()
See Also

Reference

Range Structure
Range Members


Parse Method (Range)

Parse Method (Range)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Range Structure : Parse Method
true, if starts with zero
Parses string input to Range
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function Parse( _
   ByVal input As System.String, _
   ByVal isZeroBased As System.Boolean _
) As Range
public static Range Parse(
   System.string input,
   System.bool isZeroBased
)

Parameters

input
isZeroBased
true, if starts with zero
See Also

Reference

Range Structure
Range Members


ToString Method (Range)

ToString Method (Range)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Range Structure : ToString Method
Returns a System.String that represents this instance in 'Start - End' format.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()
See Also

Reference

Range Structure
Range Members


Translate Method (Range)

Translate Method (Range)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Range Structure : Translate Method
Translates range by shift value, OpenEnd wise.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function Translate( _
   ByVal original As Range, _
   ByVal shift As System.Integer _
) As Range
public static Range Translate(
   Range original,
   System.int shift
)

Parameters

original
shift
See Also

Reference

Range Structure
Range Members


Range Structure Properties

Range Structure Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : Range Structure

For a list of all members of this type, see Range members.

Public Properties
 | Name | Description
Public Property | End | Gets the first position past the end of range
Public Property | IsEmpty | Gets true if range represents empty one
Public Property | IsEndOpen | Gets a value indicating whether the end of this Range equals to int.MaxValue.
Top
See Also

Reference

Range Structure
GrapeCity.Viewer.Common.Model Namespace


End Property (Range)

End Property (Range)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Range Structure : End Property
Gets the first position past the end of range
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property End As System.Integer
public System.int End {get;}
See Also

Reference

Range Structure
Range Members


IsEmpty Property (Range)

IsEmpty Property (Range)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Range Structure : IsEmpty Property
Gets true if range represents empty one
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsEmpty As System.Boolean
public System.bool IsEmpty {get;}
See Also

Reference

Range Structure
Range Members


IsEndOpen Property

IsEndOpen Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Range Structure : IsEndOpen Property
Gets a value indicating whether the end of this Range equals to int.MaxValue.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsEndOpen As System.Boolean
public System.bool IsEndOpen {get;}

Property Value

true if this instance is end open; otherwise, false.
See Also

Reference

Range Structure
Range Members


Range Structure Fields

Range Structure Fields

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : Range Structure

For a list of all members of this type, see Range members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | Gets empty range
Public Field | Length | The length of the Range
Public Field | Start | The start of the Range
Top
See Also

Reference

Range Structure
GrapeCity.Viewer.Common.Model Namespace


Empty Field (Range)

Empty Field (Range)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Range Structure : Empty Field
Gets empty range
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Empty As Range
public static readonly Range Empty
See Also

Reference

Range Structure
Range Members


Length Field (Range)

Length Field (Range)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Range Structure : Length Field
The length of the Range
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Length As System.Integer
public readonly System.int Length
See Also

Reference

Range Structure
Range Members


Start Field

Start Field

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > Range Structure : Start Field
The start of the Range
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Start As System.Integer
public readonly System.int Start
See Also

Reference

Range Structure
Range Members


DocumentModel.IImageItem Interface

DocumentModel.IImageItem Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel.IImageItem Interface
Base implementation for image item
Object Model
DocumentModel.IImageItem Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface DocumentModel.IImageItem
   Inherits DocumentModel.IPageItem
public interface DocumentModel.IImageItem : DocumentModel.IPageItem
See Also

Reference

DocumentModel.IImageItem Members
GrapeCity.Viewer.Common.Model Namespace


DocumentModel.IImageItem Interface Members

DocumentModel.IImageItem Interface Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel.IImageItem Interface

The following tables list the members exposed by DocumentModel.IImageItem.

Public Properties
 | Name | Description
Property | Bounds | Gets item boundaries within a page (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel.IPageItem)
Property | ItemIndex | Uniquely identifies item within a page (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel.IPageItem)
Top
Public Methods
 | Name | Description
Method | GetImage | Gets the image.
Top
See Also

Reference

DocumentModel.IImageItem Interface
GrapeCity.Viewer.Common.Model Namespace


DocumentModel.IImageItem Interface Methods

DocumentModel.IImageItem Interface Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel.IImageItem Interface

For a list of all members of this type, see DocumentModel.IImageItem members.

Public Methods
 | Name | Description
Method | GetImage | Gets the image.
Top
See Also

Reference

DocumentModel.IImageItem Interface
GrapeCity.Viewer.Common.Model Namespace


GetImage Method (DocumentModel.IImageItem)

GetImage Method (DocumentModel.IImageItem)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel.IImageItem Interface : GetImage Method
The horizontal resolution.
The vertical resolution.
Gets the image.
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetImage( _
   ByVal dpiX As System.Single, _
   ByVal dpiY As System.Single _
) As System.IDisposable
System.IDisposable GetImage(
   System.float dpiX,
   System.float dpiY
)

Parameters

dpiX
The horizontal resolution.
dpiY
The vertical resolution.

Return Value

IDisposable.
See Also

Reference

DocumentModel.IImageItem Interface
DocumentModel.IImageItem Members


DocumentModel.IPage Interface

DocumentModel.IPage Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel.IPage Interface
Defines interface for document page
Object Model
DocumentModel.IPage Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface DocumentModel.IPage
public interface DocumentModel.IPage
See Also

Reference

DocumentModel.IPage Members
GrapeCity.Viewer.Common.Model Namespace


DocumentModel.IPage Interface Members

DocumentModel.IPage Interface Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel.IPage Interface

The following tables list the members exposed by DocumentModel.IPage.

Public Properties
 | Name | Description
Property | PaperInfo |
Top
Public Methods
 | Name | Description
Method | GetItem | Gets page item
Method | GetItems | Gets page items
Top
See Also

Reference

DocumentModel.IPage Interface
GrapeCity.Viewer.Common.Model Namespace


DocumentModel.IPage Interface Methods

DocumentModel.IPage Interface Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel.IPage Interface

For a list of all members of this type, see DocumentModel.IPage members.

Public Methods
 | Name | Description
Method | GetItem | Gets page item
Method | GetItems | Gets page items
Top
See Also

Reference

DocumentModel.IPage Interface
GrapeCity.Viewer.Common.Model Namespace


GetItem Method

GetItem Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel.IPage Interface : GetItem Method
Gets page item
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetItem( _
   ByVal itemIndex As System.Integer _
) As DocumentModel.IPageItem
DocumentModel.IPageItem GetItem(
   System.int itemIndex
)

Parameters

itemIndex
See Also

Reference

DocumentModel.IPage Interface
DocumentModel.IPage Members


GetItems Method

GetItems Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel.IPage Interface : GetItems Method
Gets page items
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetItems() As System.Collections.Generic.IList(Of DocumentModel.IPageItem)
System.Collections.Generic.IList<DocumentModel.IPageItem> GetItems()
See Also

Reference

DocumentModel.IPage Interface
DocumentModel.IPage Members


DocumentModel.IPage Interface Properties

DocumentModel.IPage Interface Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel.IPage Interface

For a list of all members of this type, see DocumentModel.IPage members.

Public Properties
 | Name | Description
Property | PaperInfo |
Top
See Also

Reference

DocumentModel.IPage Interface
GrapeCity.Viewer.Common.Model Namespace


PaperInfo Property

PaperInfo Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel.IPage Interface : PaperInfo Property
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property PaperInfo As DocumentModel.PaperInfo
DocumentModel.PaperInfo PaperInfo {get;}
See Also

Reference

DocumentModel.IPage Interface
DocumentModel.IPage Members


DocumentModel.IPageItem Interface

DocumentModel.IPageItem Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel.IPageItem Interface
Minimal part of report page
Object Model
DocumentModel.IPageItem Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface DocumentModel.IPageItem
public interface DocumentModel.IPageItem
See Also

Reference

DocumentModel.IPageItem Members
GrapeCity.Viewer.Common.Model Namespace


DocumentModel.IPageItem Interface Members

DocumentModel.IPageItem Interface Members
Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel.IPageItem Interface

The following tables list the members exposed by DocumentModel.IPageItem.

Public Properties
 | Name | Description
Property | Bounds | Gets item boundaries within a page
Property | ItemIndex | Uniquely identifies item within a page
Top
See Also

Reference

DocumentModel.IPageItem Interface
GrapeCity.Viewer.Common.Model Namespace


DocumentModel.IPageItem Interface Properties

DocumentModel.IPageItem Interface Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel.IPageItem Interface

For a list of all members of this type, see DocumentModel.IPageItem members.

Public Properties
 | Name | Description
Property | Bounds | Gets item boundaries within a page
Property | ItemIndex | Uniquely identifies item within a page
Top
See Also

Reference

DocumentModel.IPageItem Interface
GrapeCity.Viewer.Common.Model Namespace


Bounds Property (DocumentModel.IPageItem)

Bounds Property (DocumentModel.IPageItem)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel.IPageItem Interface : Bounds Property
Gets item boundaries within a page
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Bounds As Rect
Rect Bounds {get;}
See Also

Reference

DocumentModel.IPageItem Interface
DocumentModel.IPageItem Members


ItemIndex Property (DocumentModel.IPageItem)

ItemIndex Property (DocumentModel.IPageItem)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > DocumentModel.IPageItem Interface : ItemIndex Property
Uniquely identifies item within a page
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ItemIndex As System.Integer
System.int ItemIndex {get;}
See Also

Reference

DocumentModel.IPageItem Interface
DocumentModel.IPageItem Members


IDocumentConsumer Interface

IDocumentConsumer Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IDocumentConsumer Interface
Object Model
IDocumentConsumer Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDocumentConsumer
   Inherits IErrorHandler
public interface IDocumentConsumer : IErrorHandler
See Also

Reference

IDocumentConsumer Members
GrapeCity.Viewer.Common.Model Namespace


IDocumentConsumer Interface Members

IDocumentConsumer Interface Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IDocumentConsumer Interface

The following tables list the members exposed by IDocumentConsumer.

Public Properties
 | Name | Description
Property | Document | Get/sets source document. Unlike the Document it's loaded document without any processing applied
Property | ShowWaitMessage | Sets whether to show the please wait message
Top
Public Methods
 | Name | Description
Method | HandleError | Report about runtime error (Inherited from GrapeCity.Viewer.Common.Model.IErrorHandler)
Top
See Also

Reference

IDocumentConsumer Interface
GrapeCity.Viewer.Common.Model Namespace


IDocumentConsumer Interface Properties

IDocumentConsumer Interface Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IDocumentConsumer Interface

For a list of all members of this type, see IDocumentConsumer members.

Public Properties
 | Name | Description
Property | Document | Get/sets source document. Unlike the Document it's loaded document without any processing applied
Property | ShowWaitMessage | Sets whether to show the please wait message
Top
See Also

Reference

IDocumentConsumer Interface
GrapeCity.Viewer.Common.Model Namespace


Document Property (IDocumentConsumer)

Document Property (IDocumentConsumer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IDocumentConsumer Interface : Document Property
Get/sets source document. Unlike the Document it's loaded document without any processing applied
Syntax
  • Visual Basic
  • C#
'Declaration

Property Document As DocumentModel
DocumentModel Document {get; set;}
See Also

Reference

IDocumentConsumer Interface
IDocumentConsumer Members


ShowWaitMessage Property

ShowWaitMessage Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IDocumentConsumer Interface : ShowWaitMessage Property
Sets whether to show the please wait message
Syntax
  • Visual Basic
  • C#
'Declaration

Property ShowWaitMessage As System.Boolean
System.bool ShowWaitMessage {get; set;}
See Also

Reference

IDocumentConsumer Interface
IDocumentConsumer Members


IErrorHandler Interface

IErrorHandler Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IErrorHandler Interface
Object Model
IErrorHandler Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IErrorHandler
public interface IErrorHandler
See Also

Reference

IErrorHandler Members
GrapeCity.Viewer.Common.Model Namespace


IErrorHandler Interface Members

IErrorHandler Interface Members
Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IErrorHandler Interface

The following tables list the members exposed by IErrorHandler.

Public Methods
 | Name | Description
Method | HandleError | Overloaded. Report about runtime error
Top
See Also

Reference

IErrorHandler Interface
GrapeCity.Viewer.Common.Model Namespace


IErrorHandler Interface Methods

IErrorHandler Interface Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IErrorHandler Interface

For a list of all members of this type, see IErrorHandler members.

Public Methods
 | Name | Description
Method | HandleError | Overloaded. Report about runtime error
Top
See Also

Reference

IErrorHandler Interface
GrapeCity.Viewer.Common.Model Namespace


HandleError Method (IErrorHandler)

HandleError Method (IErrorHandler)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IErrorHandler Interface : HandleError Method
Report about runtime error
Overload List
Overload | Description
HandleError(Exception) | Report about runtime error
HandleError(ErrorInfo) | Reports error, warning or information message
See Also

Reference

IErrorHandler Interface
IErrorHandler Members


HandleError(Exception) Method

HandleError(Exception) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IErrorHandler Interface > HandleError Method : HandleError(Exception) Method
Report about runtime error
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub HandleError( _
   ByVal exception As System.Exception _
)
void HandleError(
   System.Exception exception
)

Parameters

exception
See Also

Reference

IErrorHandler Interface
IErrorHandler Members
Overload List


HandleError(ErrorInfo) Method

HandleError(ErrorInfo) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IErrorHandler Interface > HandleError Method : HandleError(ErrorInfo) Method
Reports error, warning or information message
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub HandleError( _
   ByVal error As ErrorInfo _
)
void HandleError(
   ErrorInfo error
)

Parameters

error
See Also

Reference

IErrorHandler Interface
IErrorHandler Members
Overload List


IExportableDocument Interface

IExportableDocument Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IExportableDocument Interface
Allows document to support exports facility
Object Model
IExportableDocument Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IExportableDocument
public interface IExportableDocument
See Also

Reference

IExportableDocument Members
GrapeCity.Viewer.Common.Model Namespace


IExportableDocument Interface Members

IExportableDocument Interface Members
Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IExportableDocument Interface

The following tables list the members exposed by IExportableDocument.

Public Methods
 | Name | Description
Method | Export | Performs export
Top
See Also

Reference

IExportableDocument Interface
GrapeCity.Viewer.Common.Model Namespace


IExportableDocument Interface Methods

IExportableDocument Interface Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IExportableDocument Interface

For a list of all members of this type, see IExportableDocument members.

Public Methods
 | Name | Description
Method | Export | Performs export
Top
See Also

Reference

IExportableDocument Interface
GrapeCity.Viewer.Common.Model Namespace


Export Method (IExportableDocument)

Export Method (IExportableDocument)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IExportableDocument Interface : Export Method
Performs export
Syntax
  • Visual Basic
  • C#
'Declaration

Function Export( _
   ByVal options As ExportOptions, _
   ByVal stream As System.IO.Stream _
) As System.Boolean
System.bool Export(
   ExportOptions options,
   System.IO.Stream stream
)

Parameters

options
stream
See Also

Reference

IExportableDocument Interface
IExportableDocument Members


IExportableReport Interface

IExportableReport Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IExportableReport Interface
Report which supports the export
Object Model
IExportableReport Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IExportableReport
public interface IExportableReport
See Also

Reference

IExportableReport Members
GrapeCity.Viewer.Common.Model Namespace


IExportableReport Interface Members

IExportableReport Interface Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IExportableReport Interface

The following tables list the members exposed by IExportableReport.

Public Properties
 | Name | Description
Property | ExportFormats | Supported export formats
Top
Public Methods
 | Name | Description
Method | ExportToStream | Export report to stream
Top
See Also

Reference

IExportableReport Interface
GrapeCity.Viewer.Common.Model Namespace


IExportableReport Interface Methods

IExportableReport Interface Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IExportableReport Interface

For a list of all members of this type, see IExportableReport members.

Public Methods
 | Name | Description
Method | ExportToStream | Export report to stream
Top
See Also

Reference

IExportableReport Interface
GrapeCity.Viewer.Common.Model Namespace


ExportToStream Method

ExportToStream Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IExportableReport Interface : ExportToStream Method
export type
write stream
Export report to stream
Syntax
  • Visual Basic
  • C#
'Declaration

Sub ExportToStream( _
   ByVal type As ExportType, _
   ByVal toStream As System.IO.Stream _
)
void ExportToStream(
   ExportType type,
   System.IO.Stream toStream
)

Parameters

type
export type
toStream
write stream
See Also

Reference

IExportableReport Interface
IExportableReport Members


IExportableReport Interface Properties

IExportableReport Interface Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IExportableReport Interface

For a list of all members of this type, see IExportableReport members.

Public Properties
 | Name | Description
Property | ExportFormats | Supported export formats
Top
See Also

Reference

IExportableReport Interface
GrapeCity.Viewer.Common.Model Namespace


ExportFormats Property

ExportFormats Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IExportableReport Interface : ExportFormats Property
Supported export formats
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ExportFormats As System.Collections.Generic.IEnumerable(Of ExportFormatInfo)
System.Collections.Generic.IEnumerable<ExportFormatInfo> ExportFormats {get;}
See Also

Reference

IExportableReport Interface
IExportableReport Members


IPageDocument Interface

IPageDocument Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IPageDocument Interface
Provides access to document structures
Object Model
IPageDocument Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IPageDocument
public interface IPageDocument
See Also

Reference

IPageDocument Members
GrapeCity.Viewer.Common.Model Namespace


IPageDocument Interface Members

IPageDocument Interface Members
Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IPageDocument Interface

The following tables list the members exposed by IPageDocument.

Public Methods
 | Name | Description
Method | GetPage | Gets page document
Top
See Also

Reference

IPageDocument Interface
GrapeCity.Viewer.Common.Model Namespace


IPageDocument Interface Methods

IPageDocument Interface Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IPageDocument Interface

For a list of all members of this type, see IPageDocument members.

Public Methods
 | Name | Description
Method | GetPage | Gets page document
Top
See Also

Reference

IPageDocument Interface
GrapeCity.Viewer.Common.Model Namespace


GetPage Method (IPageDocument)

GetPage Method (IPageDocument)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IPageDocument Interface : GetPage Method
Gets page document
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetPage( _
   ByVal pageIndex As System.Integer _
) As DocumentModel.IPage
DocumentModel.IPage GetPage(
   System.int pageIndex
)

Parameters

pageIndex
See Also

Reference

IPageDocument Interface
IPageDocument Members


IParameterizedReport Interface

IParameterizedReport Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IParameterizedReport Interface
Report with parameters
Object Model
IParameterizedReport Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IParameterizedReport
public interface IParameterizedReport
See Also

Reference

IParameterizedReport Members
GrapeCity.Viewer.Common.Model Namespace


IParameterizedReport Interface Members

IParameterizedReport Interface Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IParameterizedReport Interface

The following tables list the members exposed by IParameterizedReport.

Public Properties
 | Name | Description
Property | Parameters | Collection of report parameters
Top
Public Methods
 | Name | Description
Method | Refresh | Resets parameters to default state
Top
See Also

Reference

IParameterizedReport Interface
GrapeCity.Viewer.Common.Model Namespace


IParameterizedReport Interface Methods

IParameterizedReport Interface Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IParameterizedReport Interface

For a list of all members of this type, see IParameterizedReport members.

Public Methods
 | Name | Description
Method | Refresh | Resets parameters to default state
Top
See Also

Reference

IParameterizedReport Interface
GrapeCity.Viewer.Common.Model Namespace


Refresh Method (IParameterizedReport)

Refresh Method (IParameterizedReport)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IParameterizedReport Interface : Refresh Method
Resets parameters to default state
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Refresh()
void Refresh()
See Also

Reference

IParameterizedReport Interface
IParameterizedReport Members


IParameterizedReport Interface Properties

IParameterizedReport Interface Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IParameterizedReport Interface

For a list of all members of this type, see IParameterizedReport members.

Public Properties
 | Name | Description
Property | Parameters | Collection of report parameters
Top
See Also

Reference

IParameterizedReport Interface
GrapeCity.Viewer.Common.Model Namespace


Parameters Property (IParameterizedReport)

Parameters Property (IParameterizedReport)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IParameterizedReport Interface : Parameters Property
Collection of report parameters
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Parameters As System.Collections.Generic.IList(Of IReportParameter)
System.Collections.Generic.IList<IReportParameter> Parameters {get;}
See Also

Reference

IParameterizedReport Interface
IParameterizedReport Members


IReportParameter Interface

IReportParameter Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IReportParameter Interface
Defines interface to report parameters
Object Model
IReportParameter Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IReportParameter
public interface IReportParameter
See Also

Reference

IReportParameter Members
GrapeCity.Viewer.Common.Model Namespace


IReportParameter Interface Members

IReportParameter Interface Members
Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IReportParameter Interface

The following tables list the members exposed by IReportParameter.

Public Properties
 | Name | Description
Property | AllowEmpty | True if parameter is String and it accepts String.Empty.
Property | AvailableValues | List of available values for multivalue parameter
Property | DateOnly | If parameter is DateTime specifies whether user should be prompted for both date and time or only the date.
Property | DependantParameters | Dependant parameters
Property | ExtendedInfo | Gets extended error parameter
Property | MultiLine | Gets true if text field is multiline
Property | MultiValue | Specifies whether parameter allows entering multiple values
Property | Name | Gets parameter's name
Property | Nullable | Gets true if nullable checkbox should be displayed
Property | ParameterType | Gets parameter type
Property | Prompt | Gets parameter caption
Property | SelectAll | Special the parameter value in case multivalue parameter (select all Values)
Property | State | Parameter state
Property | Value | Gets or sets parameter value
Property | Values | Gets the parameter value in case of multivalue parameter
Top
See Also

Reference

IReportParameter Interface
GrapeCity.Viewer.Common.Model Namespace


IReportParameter Interface Properties

IReportParameter Interface Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IReportParameter Interface

For a list of all members of this type, see IReportParameter members.

Public Properties
 | Name | Description
Property | AllowEmpty | True if parameter is String and it accepts String.Empty.
Property | AvailableValues | List of available values for multivalue parameter
Property | DateOnly | If parameter is DateTime specifies whether user should be prompted for both date and time or only the date.
Property | DependantParameters | Dependant parameters
Property | ExtendedInfo | Gets extended error parameter
Property | MultiLine | Gets true if text field is multiline
Property | MultiValue | Specifies whether parameter allows entering multiple values
Property | Name | Gets parameter's name
Property | Nullable | Gets true if nullable checkbox should be displayed
Property | ParameterType | Gets parameter type
Property | Prompt | Gets parameter caption
Property | SelectAll | Special the parameter value in case multivalue parameter (select all Values)
Property | State | Parameter state
Property | Value | Gets or sets parameter value
Property | Values | Gets the parameter value in case of multivalue parameter
Top
See Also

Reference

IReportParameter Interface
GrapeCity.Viewer.Common.Model Namespace


AllowEmpty Property

AllowEmpty Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IReportParameter Interface : AllowEmpty Property
True if parameter is String and it accepts String.Empty.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property AllowEmpty As System.Boolean
System.bool AllowEmpty {get;}
See Also

Reference

IReportParameter Interface
IReportParameter Members


AvailableValues Property

AvailableValues Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IReportParameter Interface : AvailableValues Property
List of available values for multivalue parameter
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property AvailableValues As System.Collections.Generic.IList(Of IReportParameterValue)
System.Collections.Generic.IList<IReportParameterValue> AvailableValues {get;}
See Also

Reference

IReportParameter Interface
IReportParameter Members


DateOnly Property (IReportParameter)

DateOnly Property (IReportParameter)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IReportParameter Interface : DateOnly Property
If parameter is DateTime specifies whether user should be prompted for both date and time or only the date.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DateOnly As System.Boolean
System.bool DateOnly {get;}
See Also

Reference

IReportParameter Interface
IReportParameter Members


DependantParameters Property

DependantParameters Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IReportParameter Interface : DependantParameters Property
Dependant parameters
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DependantParameters As System.Collections.Generic.IList(Of IReportParameter)
System.Collections.Generic.IList<IReportParameter> DependantParameters {get;}
See Also

Reference

IReportParameter Interface
IReportParameter Members


ExtendedInfo Property

ExtendedInfo Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IReportParameter Interface : ExtendedInfo Property
Gets extended error parameter
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ExtendedInfo As System.String
System.string ExtendedInfo {get;}
See Also

Reference

IReportParameter Interface
IReportParameter Members


MultiLine Property (IReportParameter)

MultiLine Property (IReportParameter)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IReportParameter Interface : MultiLine Property
Gets true if text field is multiline
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MultiLine As System.Boolean
System.bool MultiLine {get;}
See Also

Reference

IReportParameter Interface
IReportParameter Members


MultiValue Property (IReportParameter)

MultiValue Property (IReportParameter)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IReportParameter Interface : MultiValue Property
Specifies whether parameter allows entering multiple values
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property MultiValue As System.Boolean
System.bool MultiValue {get;}
See Also

Reference

IReportParameter Interface
IReportParameter Members


Name Property (IReportParameter)

Name Property (IReportParameter)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IReportParameter Interface : Name Property
Gets parameter's name
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Name As System.String
System.string Name {get;}
See Also

Reference

IReportParameter Interface
IReportParameter Members


Nullable Property (IReportParameter)

Nullable Property (IReportParameter)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IReportParameter Interface : Nullable Property
Gets true if nullable checkbox should be displayed
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Nullable As System.Boolean
System.bool Nullable {get;}
See Also

Reference

IReportParameter Interface
IReportParameter Members


ParameterType Property

ParameterType Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IReportParameter Interface : ParameterType Property
Gets parameter type
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ParameterType As ReportParameterType
ReportParameterType ParameterType {get;}
See Also

Reference

IReportParameter Interface
IReportParameter Members


Prompt Property (IReportParameter)

Prompt Property (IReportParameter)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IReportParameter Interface : Prompt Property
Gets parameter caption
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Prompt As System.String
System.string Prompt {get;}
See Also

Reference

IReportParameter Interface
IReportParameter Members


SelectAll Property

SelectAll Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IReportParameter Interface : SelectAll Property
Special the parameter value in case multivalue parameter (select all Values)
Syntax
  • Visual Basic
  • C#
'Declaration

Property SelectAll As System.Boolean
System.bool SelectAll {get; set;}
See Also

Reference

IReportParameter Interface
IReportParameter Members


State Property (IReportParameter)

State Property (IReportParameter)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IReportParameter Interface : State Property
Parameter state
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property State As ErrorState
ErrorState State {get;}
See Also

Reference

IReportParameter Interface
IReportParameter Members


Value Property (IReportParameter)

Value Property (IReportParameter)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IReportParameter Interface : Value Property
Gets or sets parameter value
Syntax
  • Visual Basic
  • C#
'Declaration

Property Value As System.Object
System.object Value {get; set;}
See Also

Reference

IReportParameter Interface
IReportParameter Members


Values Property (IReportParameter)

Values Property (IReportParameter)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IReportParameter Interface : Values Property
Gets the parameter value in case of multivalue parameter
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Values As System.Collections.Generic.IList(Of IReportParameterValue)
System.Collections.Generic.IList<IReportParameterValue> Values {get;}
See Also

Reference

IReportParameter Interface
IReportParameter Members


IReportParameterValue Interface

IReportParameterValue Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IReportParameterValue Interface
Interface for report parameter value
Object Model
IReportParameterValue Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IReportParameterValue
public interface IReportParameterValue
See Also

Reference

IReportParameterValue Members
GrapeCity.Viewer.Common.Model Namespace


IReportParameterValue Interface Members

IReportParameterValue Interface Members
Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IReportParameterValue Interface

The following tables list the members exposed by IReportParameterValue.

Public Properties
 | Name | Description
Property | Index | Parameter uniqual index
Property | Label | Parameter Label
Property | Value | Parameter Value
Top
See Also

Reference

IReportParameterValue Interface
GrapeCity.Viewer.Common.Model Namespace


IReportParameterValue Interface Properties

IReportParameterValue Interface Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IReportParameterValue Interface

For a list of all members of this type, see IReportParameterValue members.

Public Properties
 | Name | Description
Property | Index | Parameter uniqual index
Property | Label | Parameter Label
Property | Value | Parameter Value
Top
See Also

Reference

IReportParameterValue Interface
GrapeCity.Viewer.Common.Model Namespace


Index Property (IReportParameterValue)

Index Property (IReportParameterValue)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IReportParameterValue Interface : Index Property
Parameter uniqual index
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Index As System.Integer
System.int Index {get;}
See Also

Reference

IReportParameterValue Interface
IReportParameterValue Members


Label Property (IReportParameterValue)

Label Property (IReportParameterValue)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IReportParameterValue Interface : Label Property
Parameter Label
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Label As System.String
System.string Label {get;}
See Also

Reference

IReportParameterValue Interface
IReportParameterValue Members


Value Property (IReportParameterValue)

Value Property (IReportParameterValue)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IReportParameterValue Interface : Value Property
Parameter Value
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Value As System.Object
System.object Value {get;}
See Also

Reference

IReportParameterValue Interface
IReportParameterValue Members


IReportParameterWithRelativeDate Interface

IReportParameterWithRelativeDate Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IReportParameterWithRelativeDate Interface
Defines interface to report parameters supported relative date
Object Model
IReportParameterWithRelativeDate Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IReportParameterWithRelativeDate
   Inherits IReportParameter
public interface IReportParameterWithRelativeDate : IReportParameter
See Also

Reference

IReportParameterWithRelativeDate Members
GrapeCity.Viewer.Common.Model Namespace


IReportParameterWithRelativeDate Interface Members

IReportParameterWithRelativeDate Interface Members
Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IReportParameterWithRelativeDate Interface

The following tables list the members exposed by IReportParameterWithRelativeDate.

Public Properties
 | Name | Description
Property | AllowEmpty | True if parameter is String and it accepts String.Empty. (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | AvailableValues | List of available values for multivalue parameter (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | DateOnly | If parameter is DateTime specifies whether user should be prompted for both date and time or only the date. (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | DependantParameters | Dependant parameters (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | ExtendedInfo | Gets extended error parameter (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | IsRelativeDate | True if we enter relative date value
Property | MultiLine | Gets true if text field is multiline (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | MultiValue | Specifies whether parameter allows entering multiple values (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | Name | Gets parameter's name (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | Nullable | Gets true if nullable checkbox should be displayed (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | ParameterType | Gets parameter type (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | Prompt | Gets parameter caption (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | RangeDatePart | Value of range part of relative date
Property | SelectAll | Special the parameter value in case multivalue parameter (select all Values) (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | ShiftDatePart | Value of shift part of relative date
Property | StartDatePart | Value of start part of relative date
Property | State | Parameter state (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | Value | Gets or sets parameter value (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | Values | Gets the parameter value in case of multivalue parameter (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Top
See Also

Reference

IReportParameterWithRelativeDate Interface
GrapeCity.Viewer.Common.Model Namespace


IReportParameterWithRelativeDate Interface Properties

IReportParameterWithRelativeDate Interface Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IReportParameterWithRelativeDate Interface

For a list of all members of this type, see IReportParameterWithRelativeDate members.

Public Properties
 | Name | Description
Property | AllowEmpty | True if parameter is String and it accepts String.Empty. (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | AvailableValues | List of available values for multivalue parameter (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | DateOnly | If parameter is DateTime specifies whether user should be prompted for both date and time or only the date. (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | DependantParameters | Dependant parameters (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | ExtendedInfo | Gets extended error parameter (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | IsRelativeDate | True if we enter relative date value
Property | MultiLine | Gets true if text field is multiline (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | MultiValue | Specifies whether parameter allows entering multiple values (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | Name | Gets parameter's name (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | Nullable | Gets true if nullable checkbox should be displayed (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | ParameterType | Gets parameter type (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | Prompt | Gets parameter caption (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | RangeDatePart | Value of range part of relative date
Property | SelectAll | Special the parameter value in case multivalue parameter (select all Values) (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | ShiftDatePart | Value of shift part of relative date
Property | StartDatePart | Value of start part of relative date
Property | State | Parameter state (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | Value | Gets or sets parameter value (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Property | Values | Gets the parameter value in case of multivalue parameter (Inherited from GrapeCity.Viewer.Common.Model.IReportParameter)
Top
See Also

Reference

IReportParameterWithRelativeDate Interface
GrapeCity.Viewer.Common.Model Namespace


IsRelativeDate Property

IsRelativeDate Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IReportParameterWithRelativeDate Interface : IsRelativeDate Property
True if we enter relative date value
Syntax
  • Visual Basic
  • C#
'Declaration

Property IsRelativeDate As System.Boolean
System.bool IsRelativeDate {get; set;}
See Also

Reference

IReportParameterWithRelativeDate Interface
IReportParameterWithRelativeDate Members


RangeDatePart Property

RangeDatePart Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IReportParameterWithRelativeDate Interface : RangeDatePart Property
Value of range part of relative date
Syntax
  • Visual Basic
  • C#
'Declaration

Property RangeDatePart As RelativeDatePart
RelativeDatePart RangeDatePart {get; set;}
See Also

Reference

IReportParameterWithRelativeDate Interface
IReportParameterWithRelativeDate Members


ShiftDatePart Property

ShiftDatePart Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IReportParameterWithRelativeDate Interface : ShiftDatePart Property
Value of shift part of relative date
Syntax
  • Visual Basic
  • C#
'Declaration

Property ShiftDatePart As RelativeDatePart
RelativeDatePart ShiftDatePart {get; set;}
See Also

Reference

IReportParameterWithRelativeDate Interface
IReportParameterWithRelativeDate Members


StartDatePart Property

StartDatePart Property

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > IReportParameterWithRelativeDate Interface : StartDatePart Property
Value of start part of relative date
Syntax
  • Visual Basic
  • C#
'Declaration

Property StartDatePart As RelativeDatePart
RelativeDatePart StartDatePart {get; set;}
See Also

Reference

IReportParameterWithRelativeDate Interface
IReportParameterWithRelativeDate Members


ISearchableDocument Interface

ISearchableDocument Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ISearchableDocument Interface
Allows document to support text search facility
Object Model
ISearchableDocument Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ISearchableDocument
public interface ISearchableDocument
See Also

Reference

ISearchableDocument Members
GrapeCity.Viewer.Common.Model Namespace


ISearchableDocument Interface Members

ISearchableDocument Interface Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ISearchableDocument Interface

The following tables list the members exposed by ISearchableDocument.

Public Properties
 | Name | Description
Property | HighlightSearchResult | Gets or sets currently highlighted search result
Property | NotifySearchResult | Gets or sets currently notification search result
Top
Public Methods
 | Name | Description
Method | Find | Performs text string lookup
Method | GetItemText | Gets text element text to display/highlight range within a list of results
Top
See Also

Reference

ISearchableDocument Interface
GrapeCity.Viewer.Common.Model Namespace


ISearchableDocument Interface Methods

ISearchableDocument Interface Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ISearchableDocument Interface

For a list of all members of this type, see ISearchableDocument members.

Public Methods
 | Name | Description
Method | Find | Performs text string lookup
Method | GetItemText | Gets text element text to display/highlight range within a list of results
Top
See Also

Reference

ISearchableDocument Interface
GrapeCity.Viewer.Common.Model Namespace


Find Method (ISearchableDocument)

Find Method (ISearchableDocument)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ISearchableDocument Interface : Find Method
Performs text string lookup
Syntax
  • Visual Basic
  • C#
'Declaration

Function Find( _
   ByVal options As FindOptions, _
   ByVal startFrom As SearchResult _
) As System.Collections.Generic.IEnumerable(Of SearchResult)
System.Collections.Generic.IEnumerable<SearchResult> Find(
   FindOptions options,
   SearchResult startFrom
)

Parameters

options
startFrom
See Also

Reference

ISearchableDocument Interface
ISearchableDocument Members


GetItemText Method (ISearchableDocument)

GetItemText Method (ISearchableDocument)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ISearchableDocument Interface : GetItemText Method
Gets text element text to display/highlight range within a list of results
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetItemText( _
   ByVal result As SearchResult _
) As System.String
System.string GetItemText(
   SearchResult result
)

Parameters

result
See Also

Reference

ISearchableDocument Interface
ISearchableDocument Members


ISearchableDocument Interface Properties

ISearchableDocument Interface Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ISearchableDocument Interface

For a list of all members of this type, see ISearchableDocument members.

Public Properties
 | Name | Description
Property | HighlightSearchResult | Gets or sets currently highlighted search result
Property | NotifySearchResult | Gets or sets currently notification search result
Top
See Also

Reference

ISearchableDocument Interface
GrapeCity.Viewer.Common.Model Namespace


HighlightSearchResult Property (ISearchableDocument)

HighlightSearchResult Property (ISearchableDocument)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ISearchableDocument Interface : HighlightSearchResult Property
Gets or sets currently highlighted search result
Syntax
  • Visual Basic
  • C#
'Declaration

Property HighlightSearchResult As SearchResult
SearchResult HighlightSearchResult {get; set;}
See Also

Reference

ISearchableDocument Interface
ISearchableDocument Members


NotifySearchResult Property (ISearchableDocument)

NotifySearchResult Property (ISearchableDocument)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ISearchableDocument Interface : NotifySearchResult Property
Gets or sets currently notification search result
Syntax
  • Visual Basic
  • C#
'Declaration

Property NotifySearchResult As SearchResult
SearchResult NotifySearchResult {get; set;}
See Also

Reference

ISearchableDocument Interface
ISearchableDocument Members


ISelectableDocument Interface

ISelectableDocument Interface
Members

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ISelectableDocument Interface
Allows document to expose items that could be selected/highlighted/copied
Object Model
ISelectableDocument Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ISelectableDocument
public interface ISelectableDocument
See Also

Reference

ISelectableDocument Members
GrapeCity.Viewer.Common.Model Namespace


ISelectableDocument Interface Members

ISelectableDocument Interface Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ISelectableDocument Interface

The following tables list the members exposed by ISelectableDocument.

Public Properties
 | Name | Description
Property | CurrentSelection | Gets current selection
Top
Public Methods
 | Name | Description
Method | ClearSelection | Clears selection
Method | SelectItems | Adds items within specific frame on particular page to current selection
Top
See Also

Reference

ISelectableDocument Interface
GrapeCity.Viewer.Common.Model Namespace


ISelectableDocument Interface Methods

ISelectableDocument Interface Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ISelectableDocument Interface

For a list of all members of this type, see ISelectableDocument members.

Public Methods
 | Name | Description
Method | ClearSelection | Clears selection
Method | SelectItems | Adds items within specific frame on particular page to current selection
Top
See Also

Reference

ISelectableDocument Interface
GrapeCity.Viewer.Common.Model Namespace


ClearSelection Method (ISelectableDocument)

ClearSelection Method (ISelectableDocument)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ISelectableDocument Interface : ClearSelection Method
Clears selection
Syntax
  • Visual Basic
  • C#
'Declaration

Sub ClearSelection()
void ClearSelection()
See Also

Reference

ISelectableDocument Interface
ISelectableDocument Members


SelectItems Method (ISelectableDocument)

SelectItems Method (ISelectableDocument)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ISelectableDocument Interface : SelectItems Method
Adds items within specific frame on particular page to current selection
Syntax
  • Visual Basic
  • C#
'Declaration

Sub SelectItems( _
   ByVal pageIndex As System.Integer, _
   ByVal frame As Rect _
)
void SelectItems(
   System.int pageIndex,
   Rect frame
)

Parameters

pageIndex
frame
See Also

Reference

ISelectableDocument Interface
ISelectableDocument Members


ISelectableDocument Interface Properties

ISelectableDocument Interface Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ISelectableDocument Interface

For a list of all members of this type, see ISelectableDocument members.

Public Properties
 | Name | Description
Property | CurrentSelection | Gets current selection
Top
See Also

Reference

ISelectableDocument Interface
GrapeCity.Viewer.Common.Model Namespace


CurrentSelection Property (ISelectableDocument)

CurrentSelection Property (ISelectableDocument)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > ISelectableDocument Interface : CurrentSelection Property
Gets current selection
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CurrentSelection As DocumentSelection
DocumentSelection CurrentSelection {get;}
See Also

Reference

ISelectableDocument Interface
ISelectableDocument Members


GrapeCity.ActiveReports.Viewer.Wpf Namespace

GrapeCity.ActiveReports.Viewer.Wpf Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly : GrapeCity.ActiveReports.Viewer.Wpf Namespace
The GrapeCity.ActiveReports.Viewer.Wpf namepace contains the WPF viewer control and related types.
Classes
 | Class | Description
Class | ParametersPanel | Manages the viewer's parameters panel properties.
Class | SearchPanel | Manages the viewer's search panel properties.
Class | Sidebar | Represents the sidebar of the Viewer.
Class | SidebarPanel | Exposes public properties of the sidebar panels.
Class | ThumbnailsPanel | Manages the viewer's thumbnails panel properties.
Class | TocPanel | Manages the viewer's table of contents panel properties.
Class | Viewer | The WPF based report Viewer control. The WPF Viewer control is used to preivew report documents.
Class | Viewer.ActionEventArgs | Provides data for Action event.
Enumerations
 | Enumeration | Description
Enumeration | TargetView | Determines the current active view in the viewer.
See Also

Reference

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly


ParametersPanel Class

ParametersPanel Class
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : ParametersPanel Class
Manages the viewer's parameters panel properties.
Object Model
ParametersPanel Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ParametersPanel
   Inherits SidebarPanel
public sealed class ParametersPanel : SidebarPanel
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel
GrapeCity.ActiveReports.Viewer.Wpf.ParametersPanel

See Also

Reference

ParametersPanel Members
GrapeCity.ActiveReports.Viewer.Wpf Namespace


ParametersPanel Class Members

ParametersPanel Class Members
Fields Properties Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : ParametersPanel Class

The following tables list the members exposed by ParametersPanel.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | EnabledProperty | Gets or sets the value that determines whether the viewer's parameters panel is enabled.
static (Shared in Visual Basic) | VisibleProperty | Gets or sets the value that determines whether the viewer's parameters panel is visible.
Top
Public Properties
 | Name | Description
Public Property | DependencyObjectType | (Inherited from System.Windows.DependencyObject)
Public Property | Dispatcher | (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | Enabled | Gets or sets the value that determines whether the viewer's parameters panel is enabled.
Public Property | IsSealed | (Inherited from System.Windows.DependencyObject)
Public Property | Text | Overridden. Gets or sets the text.
Public Property | Visible | Gets or sets a value that determines whether the viewer's panel of parameters is visible.
Top
Public Methods
 | Name | Description
Public Method | Clear | Clears the sidebar panel. (Inherited from GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel)
Public Method | ClearValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Overridden. Releases the resources used by the parameters panel.
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | GetHashCode | (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateProperty | (Inherited from System.Windows.DependencyObject)
Public Method | ReadLocalValue | (Inherited from System.Windows.DependencyObject)
Public Method | Refresh | Overridden. Forces the panel of parameters to invalidate its client area and immediately redraw itself and any child controls.
Public Method | SetCurrentValue | (Inherited from System.Windows.DependencyObject)
Public Method | SetValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Top
See Also

Reference

ParametersPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


ParametersPanel Class Methods

ParametersPanel Class Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : ParametersPanel Class

For a list of all members of this type, see ParametersPanel members.

Public Methods
 | Name | Description
Public Method | Clear | Clears the sidebar panel. (Inherited from GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel)
Public Method | ClearValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Overridden. Releases the resources used by the parameters panel.
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | GetHashCode | (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateProperty | (Inherited from System.Windows.DependencyObject)
Public Method | ReadLocalValue | (Inherited from System.Windows.DependencyObject)
Public Method | Refresh | Overridden. Forces the panel of parameters to invalidate its client area and immediately redraw itself and any child controls.
Public Method | SetCurrentValue | (Inherited from System.Windows.DependencyObject)
Public Method | SetValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Top
See Also

Reference

ParametersPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Dispose Method (ParametersPanel)

Dispose Method (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : Dispose Method
Releases the resources used by the parameters panel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Sub Dispose()
public override void Dispose()
See Also

Reference

ParametersPanel Class
ParametersPanel Members


Refresh Method (ParametersPanel)

Refresh Method (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : Refresh Method
Forces the panel of parameters to invalidate its client area and immediately redraw itself and any child controls.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Sub Refresh()
public override void Refresh()
See Also

Reference

ParametersPanel Class
ParametersPanel Members


ParametersPanel Class Properties

ParametersPanel Class Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : ParametersPanel Class

For a list of all members of this type, see ParametersPanel members.

Public Properties
 | Name | Description
Public Property | DependencyObjectType | (Inherited from System.Windows.DependencyObject)
Public Property | Dispatcher | (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | Enabled | Gets or sets the value that determines whether the viewer's parameters panel is enabled.
Public Property | IsSealed | (Inherited from System.Windows.DependencyObject)
Public Property | Text | Overridden. Gets or sets the text.
Public Property | Visible | Gets or sets a value that determines whether the viewer's panel of parameters is visible.
Top
See Also

Reference

ParametersPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Enabled Property (ParametersPanel)

Enabled Property (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : Enabled Property
Gets or sets the value that determines whether the viewer's parameters panel is enabled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Enabled As System.Boolean
public System.bool Enabled {get; set;}

Property Value

true if enabled; otherwise, false.
See Also

Reference

ParametersPanel Class
ParametersPanel Members


Text Property (ParametersPanel)

Text Property (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : Text Property
Gets or sets the text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Property Text As System.String
public override System.string Text {get; set;}

Property Value

The text.
See Also

Reference

ParametersPanel Class
ParametersPanel Members


Visible Property (ParametersPanel)

Visible Property (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : Visible Property
Gets or sets a value that determines whether the viewer's panel of parameters is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}

Property Value

true if visible; otherwise, false.
See Also

Reference

ParametersPanel Class
ParametersPanel Members


ParametersPanel Class Fields

ParametersPanel Class Fields

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : ParametersPanel Class

For a list of all members of this type, see ParametersPanel members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | EnabledProperty | Gets or sets the value that determines whether the viewer's parameters panel is enabled.
static (Shared in Visual Basic) | VisibleProperty | Gets or sets the value that determines whether the viewer's parameters panel is visible.
Top
See Also

Reference

ParametersPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


EnabledProperty Field (ParametersPanel)

EnabledProperty Field (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : EnabledProperty Field
Gets or sets the value that determines whether the viewer's parameters panel is enabled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly EnabledProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty EnabledProperty
See Also

Reference

ParametersPanel Class
ParametersPanel Members


VisibleProperty Field (ParametersPanel)

VisibleProperty Field (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : VisibleProperty Field
Gets or sets the value that determines whether the viewer's parameters panel is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly VisibleProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty VisibleProperty
See Also

Reference

ParametersPanel Class
ParametersPanel Members


SearchPanel Class

SearchPanel Class
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : SearchPanel Class
Manages the viewer's search panel properties.
Object Model
SearchPanel Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class SearchPanel
   Inherits SidebarPanel
public sealed class SearchPanel : SidebarPanel
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel
GrapeCity.ActiveReports.Viewer.Wpf.SearchPanel

See Also

Reference

SearchPanel Members
GrapeCity.ActiveReports.Viewer.Wpf Namespace


SearchPanel Class Members

SearchPanel Class Members
Fields Properties Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : SearchPanel Class

The following tables list the members exposed by SearchPanel.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | EnabledProperty | Gets or sets the value that determines whether the viewer's search panel is enabled.
static (Shared in Visual Basic) | VisibleProperty | Gets or sets the value that determines whether the viewer's search panel is visible.
Top
Public Properties
 | Name | Description
Public Property | DependencyObjectType | (Inherited from System.Windows.DependencyObject)
Public Property | Dispatcher | (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | Enabled | Gets or sets the value that determines whether the viewer's search panel is enabled.
Public Property | IsSealed | (Inherited from System.Windows.DependencyObject)
Public Property | Text | Overridden. Gets or sets the text.
Public Property | Visible | Gets or sets the value that determines whether the viewer's search panel is visible.
Top
Public Methods
 | Name | Description
Public Method | Clear | Overridden. Clears the search panel.
Public Method | ClearValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Overridden. Releases the resources used by the search panel.
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | GetHashCode | (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateProperty | (Inherited from System.Windows.DependencyObject)
Public Method | ReadLocalValue | (Inherited from System.Windows.DependencyObject)
Public Method | Refresh | Forces the sidebar to invalidate its client area and immediately redraw itself and any child controls. (Inherited from GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel)
Public Method | SetCurrentValue | (Inherited from System.Windows.DependencyObject)
Public Method | SetValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Top
See Also

Reference

SearchPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


SearchPanel Class Methods

SearchPanel Class Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : SearchPanel Class

For a list of all members of this type, see SearchPanel members.

Public Methods
 | Name | Description
Public Method | Clear | Overridden. Clears the search panel.
Public Method | ClearValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Overridden. Releases the resources used by the search panel.
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | GetHashCode | (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateProperty | (Inherited from System.Windows.DependencyObject)
Public Method | ReadLocalValue | (Inherited from System.Windows.DependencyObject)
Public Method | Refresh | Forces the sidebar to invalidate its client area and immediately redraw itself and any child controls. (Inherited from GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel)
Public Method | SetCurrentValue | (Inherited from System.Windows.DependencyObject)
Public Method | SetValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Top
See Also

Reference

SearchPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Clear Method (SearchPanel)

Clear Method (SearchPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : Clear Method
Clears the search panel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Sub Clear()
public override void Clear()
See Also

Reference

SearchPanel Class
SearchPanel Members


Dispose Method (SearchPanel)

Dispose Method (SearchPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : Dispose Method
Releases the resources used by the search panel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Sub Dispose()
public override void Dispose()
See Also

Reference

SearchPanel Class
SearchPanel Members


SearchPanel Class Properties

SearchPanel Class Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : SearchPanel Class

For a list of all members of this type, see SearchPanel members.

Public Properties
 | Name | Description
Public Property | DependencyObjectType | (Inherited from System.Windows.DependencyObject)
Public Property | Dispatcher | (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | Enabled | Gets or sets the value that determines whether the viewer's search panel is enabled.
Public Property | IsSealed | (Inherited from System.Windows.DependencyObject)
Public Property | Text | Overridden. Gets or sets the text.
Public Property | Visible | Gets or sets the value that determines whether the viewer's search panel is visible.
Top
See Also

Reference

SearchPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Enabled Property (SearchPanel)

Enabled Property (SearchPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : Enabled Property
Gets or sets the value that determines whether the viewer's search panel is enabled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Enabled As System.Boolean
public System.bool Enabled {get; set;}

Property Value

true if enabled; otherwise, false.
See Also

Reference

SearchPanel Class
SearchPanel Members


Text Property (SearchPanel)

Text Property (SearchPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : Text Property
Gets or sets the text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Property Text As System.String
public override System.string Text {get; set;}
See Also

Reference

SearchPanel Class
SearchPanel Members


Visible Property (SearchPanel)

Visible Property (SearchPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : Visible Property
Gets or sets the value that determines whether the viewer's search panel is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}

Property Value

true if visible; otherwise, false.
See Also

Reference

SearchPanel Class
SearchPanel Members


SearchPanel Class Fields

SearchPanel Class Fields

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : SearchPanel Class

For a list of all members of this type, see SearchPanel members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | EnabledProperty | Gets or sets the value that determines whether the viewer's search panel is enabled.
static (Shared in Visual Basic) | VisibleProperty | Gets or sets the value that determines whether the viewer's search panel is visible.
Top
See Also

Reference

SearchPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


EnabledProperty Field (SearchPanel)

EnabledProperty Field (SearchPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : EnabledProperty Field
Gets or sets the value that determines whether the viewer's search panel is enabled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly EnabledProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty EnabledProperty
See Also

Reference

SearchPanel Class
SearchPanel Members


VisibleProperty Field (SearchPanel)

VisibleProperty Field (SearchPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : VisibleProperty Field
Gets or sets the value that determines whether the viewer's search panel is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly VisibleProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty VisibleProperty
See Also

Reference

SearchPanel Class
SearchPanel Members


Sidebar Class

Sidebar Class
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Sidebar Class
Represents the sidebar of the Viewer.
Object Model
Sidebar Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class Sidebar
   Inherits System.Windows.DependencyObject
public sealed class Sidebar : System.Windows.DependencyObject
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
GrapeCity.ActiveReports.Viewer.Wpf.Sidebar

See Also

Reference

Sidebar Members
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Sidebar Class Members

Sidebar Class Members
Fields Properties Methods Events

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Sidebar Class

The following tables list the members exposed by Sidebar.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | SelectedIndexProperty | Sets or returns the index of the currently selected panel of the sidebar.
static (Shared in Visual Basic) | WidthProperty | Gets or sets the width of the sidebar, in pixels.
Top
Public Properties
 | Name | Description
Public Property | DependencyObjectType | (Inherited from System.Windows.DependencyObject)
Public Property | Dispatcher | (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | IsSealed | (Inherited from System.Windows.DependencyObject)
Public Property | ParametersPanel | Gets the parameters panel component of sidebar.
Public Property | SearchPanel | Gets the search panel component of sidebar.
Public Property | SelectedIndex | Sets or returns the index of the currently selected panel of the sidebar.
Public Property | ThumbnailsPanel | Gets the thumbnail panel component of sidebar.
Public Property | TocPanel | Gets the table of content panel component of sidebar.
Public Property | Width | Gets or sets the width of the sidebar, in pixels.
Top
Public Methods
 | Name | Description
Public Method | ClearValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Releases the resources used by the sidebar.
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | GetHashCode | (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateProperty | (Inherited from System.Windows.DependencyObject)
Public Method | ReadLocalValue | (Inherited from System.Windows.DependencyObject)
Public Method | SetCurrentValue | (Inherited from System.Windows.DependencyObject)
Public Method | SetValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Public Method | ToggleVisibility | Toggles the visibility of the viewer's sidebar.
Top
Public Events
 | Name | Description
Public Event | SelectedIndexChanged | Raises when the selected panel of the sidebar is changed.
Top
See Also

Reference

Sidebar Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Sidebar Class Methods

Sidebar Class Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Sidebar Class

For a list of all members of this type, see Sidebar members.

Public Methods
 | Name | Description
Public Method | ClearValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Releases the resources used by the sidebar.
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | GetHashCode | (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateProperty | (Inherited from System.Windows.DependencyObject)
Public Method | ReadLocalValue | (Inherited from System.Windows.DependencyObject)
Public Method | SetCurrentValue | (Inherited from System.Windows.DependencyObject)
Public Method | SetValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Public Method | ToggleVisibility | Toggles the visibility of the viewer's sidebar.
Top
See Also

Reference

Sidebar Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Dispose Method (Sidebar)

Dispose Method (Sidebar)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : Dispose Method
Releases the resources used by the sidebar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Sidebar Class
Sidebar Members


ToggleVisibility Method (Sidebar)

ToggleVisibility Method (Sidebar)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : ToggleVisibility Method
Toggles the visibility of the viewer's sidebar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ToggleVisibility()
public void ToggleVisibility()
See Also

Reference

Sidebar Class
Sidebar Members


Sidebar Class Properties

Sidebar Class Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Sidebar Class

For a list of all members of this type, see Sidebar members.

Public Properties
 | Name | Description
Public Property | DependencyObjectType | (Inherited from System.Windows.DependencyObject)
Public Property | Dispatcher | (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | IsSealed | (Inherited from System.Windows.DependencyObject)
Public Property | ParametersPanel | Gets the parameters panel component of sidebar.
Public Property | SearchPanel | Gets the search panel component of sidebar.
Public Property | SelectedIndex | Sets or returns the index of the currently selected panel of the sidebar.
Public Property | ThumbnailsPanel | Gets the thumbnail panel component of sidebar.
Public Property | TocPanel | Gets the table of content panel component of sidebar.
Public Property | Width | Gets or sets the width of the sidebar, in pixels.
Top
See Also

Reference

Sidebar Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


ParametersPanel Property (Sidebar)

ParametersPanel Property (Sidebar)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : ParametersPanel Property
Gets the parameters panel component of sidebar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ParametersPanel As ParametersPanel
public ParametersPanel ParametersPanel {get;}
See Also

Reference

Sidebar Class
Sidebar Members


SearchPanel Property (Sidebar)

SearchPanel Property (Sidebar)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : SearchPanel Property
Gets the search panel component of sidebar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property SearchPanel As SearchPanel
public SearchPanel SearchPanel {get;}
See Also

Reference

Sidebar Class
Sidebar Members


SelectedIndex Property (Sidebar)

SelectedIndex Property (Sidebar)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : SelectedIndex Property
Sets or returns the index of the currently selected panel of the sidebar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SelectedIndex As System.Integer
public System.int SelectedIndex {get; set;}
See Also

Reference

Sidebar Class
Sidebar Members


ThumbnailsPanel Property (Sidebar)

ThumbnailsPanel Property (Sidebar)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : ThumbnailsPanel Property
Gets the thumbnail panel component of sidebar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ThumbnailsPanel As ThumbnailsPanel
public ThumbnailsPanel ThumbnailsPanel {get;}
See Also

Reference

Sidebar Class
Sidebar Members


TocPanel Property (Sidebar)

TocPanel Property (Sidebar)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : TocPanel Property
Gets the table of content panel component of sidebar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TocPanel As TocPanel
public TocPanel TocPanel {get;}
See Also

Reference

Sidebar Class
Sidebar Members


Width Property (Sidebar)

Width Property (Sidebar)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : Width Property
Gets or sets the width of the sidebar, in pixels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As System.Integer
public System.int Width {get; set;}

Property Value

The width.
See Also

Reference

Sidebar Class
Sidebar Members


Sidebar Class Fields

Sidebar Class Fields

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Sidebar Class

For a list of all members of this type, see Sidebar members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | SelectedIndexProperty | Sets or returns the index of the currently selected panel of the sidebar.
static (Shared in Visual Basic) | WidthProperty | Gets or sets the width of the sidebar, in pixels.
Top
See Also

Reference

Sidebar Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


SelectedIndexProperty Field

SelectedIndexProperty Field

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : SelectedIndexProperty Field
Sets or returns the index of the currently selected panel of the sidebar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly SelectedIndexProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty SelectedIndexProperty
See Also

Reference

Sidebar Class
Sidebar Members


WidthProperty Field

WidthProperty Field

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : WidthProperty Field
Gets or sets the width of the sidebar, in pixels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly WidthProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty WidthProperty
See Also

Reference

Sidebar Class
Sidebar Members


Sidebar Class Events

Sidebar Class Events

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Sidebar Class

For a list of all members of this type, see Sidebar members.

Public Events
 | Name | Description
Public Event | SelectedIndexChanged | Raises when the selected panel of the sidebar is changed.
Top
See Also

Reference

Sidebar Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


SelectedIndexChanged Event (Sidebar)

SelectedIndexChanged Event (Sidebar)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : SelectedIndexChanged Event
Raises when the selected panel of the sidebar is changed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event SelectedIndexChanged As System.EventHandler
public event System.EventHandler SelectedIndexChanged
See Also

Reference

Sidebar Class
Sidebar Members


SidebarPanel Class

SidebarPanel Class
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : SidebarPanel Class
Exposes public properties of the sidebar panels.
Object Model
SidebarPanel Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class SidebarPanel
   Inherits System.Windows.DependencyObject
public abstract class SidebarPanel : System.Windows.DependencyObject
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel
GrapeCity.ActiveReports.Viewer.Wpf.ParametersPanel
GrapeCity.ActiveReports.Viewer.Wpf.SearchPanel
GrapeCity.ActiveReports.Viewer.Wpf.ThumbnailsPanel
GrapeCity.ActiveReports.Viewer.Wpf.TocPanel

See Also

Reference

SidebarPanel Members
GrapeCity.ActiveReports.Viewer.Wpf Namespace


SidebarPanel Class Members

SidebarPanel Class Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : SidebarPanel Class

The following tables list the members exposed by SidebarPanel.

Public Properties
 | Name | Description
Public Property | DependencyObjectType | (Inherited from System.Windows.DependencyObject)
Public Property | Dispatcher | (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | IsSealed | (Inherited from System.Windows.DependencyObject)
Public Property | Text | Gets or sets the text to be displayed in sidebar.
Top
Public Methods
 | Name | Description
Public Method | Clear | Clears the sidebar panel.
Public Method | ClearValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Releases the resources used by the sidebar panel.
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | GetHashCode | (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateProperty | (Inherited from System.Windows.DependencyObject)
Public Method | ReadLocalValue | (Inherited from System.Windows.DependencyObject)
Public Method | Refresh | Forces the sidebar to invalidate its client area and immediately redraw itself and any child controls.
Public Method | SetCurrentValue | (Inherited from System.Windows.DependencyObject)
Public Method | SetValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Top
See Also

Reference

SidebarPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


SidebarPanel Class Methods

SidebarPanel Class Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : SidebarPanel Class

For a list of all members of this type, see SidebarPanel members.

Public Methods
 | Name | Description
Public Method | Clear | Clears the sidebar panel.
Public Method | ClearValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Releases the resources used by the sidebar panel.
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | GetHashCode | (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateProperty | (Inherited from System.Windows.DependencyObject)
Public Method | ReadLocalValue | (Inherited from System.Windows.DependencyObject)
Public Method | Refresh | Forces the sidebar to invalidate its client area and immediately redraw itself and any child controls.
Public Method | SetCurrentValue | (Inherited from System.Windows.DependencyObject)
Public Method | SetValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Top
See Also

Reference

SidebarPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Clear Method (SidebarPanel)

Clear Method (SidebarPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : Clear Method
Clears the sidebar panel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub Clear()
public virtual void Clear()
See Also

Reference

SidebarPanel Class
SidebarPanel Members


Dispose Method (SidebarPanel)

Dispose Method (SidebarPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : Dispose Method
Releases the resources used by the sidebar panel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Sub Dispose()
public abstract void Dispose()
See Also

Reference

SidebarPanel Class
SidebarPanel Members


Refresh Method (SidebarPanel)

Refresh Method (SidebarPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : Refresh Method
Forces the sidebar to invalidate its client area and immediately redraw itself and any child controls.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub Refresh()
public virtual void Refresh()
See Also

Reference

SidebarPanel Class
SidebarPanel Members


SidebarPanel Class Properties

SidebarPanel Class Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : SidebarPanel Class

For a list of all members of this type, see SidebarPanel members.

Public Properties
 | Name | Description
Public Property | DependencyObjectType | (Inherited from System.Windows.DependencyObject)
Public Property | Dispatcher | (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | IsSealed | (Inherited from System.Windows.DependencyObject)
Public Property | Text | Gets or sets the text to be displayed in sidebar.
Top
See Also

Reference

SidebarPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Text Property (SidebarPanel)

Text Property (SidebarPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : Text Property
Gets or sets the text to be displayed in sidebar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Text As System.String
public virtual System.string Text {get; set;}
See Also

Reference

SidebarPanel Class
SidebarPanel Members


ThumbnailsPanel Class

ThumbnailsPanel Class
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : ThumbnailsPanel Class
Manages the viewer's thumbnails panel properties.
Object Model
ThumbnailsPanel Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ThumbnailsPanel
   Inherits SidebarPanel
public sealed class ThumbnailsPanel : SidebarPanel
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel
GrapeCity.ActiveReports.Viewer.Wpf.ThumbnailsPanel

See Also

Reference

ThumbnailsPanel Members
GrapeCity.ActiveReports.Viewer.Wpf Namespace


ThumbnailsPanel Class Members

ThumbnailsPanel Class Members
Fields Properties Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : ThumbnailsPanel Class

The following tables list the members exposed by ThumbnailsPanel.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | EnabledProperty | Gets or sets the value that determines whether the viewer's thumbnails panel is enabled.
static (Shared in Visual Basic) | VisibleProperty | Gets or sets the value that determines whether the viewer's thumbnails panel is visible.
Top
Public Properties
 | Name | Description
Public Property | DependencyObjectType | (Inherited from System.Windows.DependencyObject)
Public Property | Dispatcher | (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | Enabled | Gets or sets the value that determines whether the viewer's thumbnails panel is enabled.
Public Property | IsSealed | (Inherited from System.Windows.DependencyObject)
Public Property | Text | Overridden. Gets or sets the text of the panel.
Public Property | Visible | Gets or sets the value that determines whether the viewer's thumbnails panel is visible.
Top
Public Methods
 | Name | Description
Public Method | Clear | Clears the sidebar panel. (Inherited from GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel)
Public Method | ClearValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Overridden. Releases the resources used by the thumbnails panel.
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | GetHashCode | (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateProperty | (Inherited from System.Windows.DependencyObject)
Public Method | ReadLocalValue | (Inherited from System.Windows.DependencyObject)
Public Method | Refresh | Forces the sidebar to invalidate its client area and immediately redraw itself and any child controls. (Inherited from GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel)
Public Method | SetCurrentValue | (Inherited from System.Windows.DependencyObject)
Public Method | SetValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Top
See Also

Reference

ThumbnailsPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


ThumbnailsPanel Class Methods

ThumbnailsPanel Class Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : ThumbnailsPanel Class

For a list of all members of this type, see ThumbnailsPanel members.

Public Methods
 | Name | Description
Public Method | Clear | Clears the sidebar panel. (Inherited from GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel)
Public Method | ClearValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Overridden. Releases the resources used by the thumbnails panel.
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | GetHashCode | (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateProperty | (Inherited from System.Windows.DependencyObject)
Public Method | ReadLocalValue | (Inherited from System.Windows.DependencyObject)
Public Method | Refresh | Forces the sidebar to invalidate its client area and immediately redraw itself and any child controls. (Inherited from GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel)
Public Method | SetCurrentValue | (Inherited from System.Windows.DependencyObject)
Public Method | SetValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Top
See Also

Reference

ThumbnailsPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Dispose Method (ThumbnailsPanel)

Dispose Method (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : Dispose Method
Releases the resources used by the thumbnails panel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Sub Dispose()
public override void Dispose()
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


ThumbnailsPanel Class Properties

ThumbnailsPanel Class Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : ThumbnailsPanel Class

For a list of all members of this type, see ThumbnailsPanel members.

Public Properties
 | Name | Description
Public Property | DependencyObjectType | (Inherited from System.Windows.DependencyObject)
Public Property | Dispatcher | (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | Enabled | Gets or sets the value that determines whether the viewer's thumbnails panel is enabled.
Public Property | IsSealed | (Inherited from System.Windows.DependencyObject)
Public Property | Text | Overridden. Gets or sets the text of the panel.
Public Property | Visible | Gets or sets the value that determines whether the viewer's thumbnails panel is visible.
Top
See Also

Reference

ThumbnailsPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Enabled Property (ThumbnailsPanel)

Enabled Property (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : Enabled Property
Gets or sets the value that determines whether the viewer's thumbnails panel is enabled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Enabled As System.Boolean
public System.bool Enabled {get; set;}

Property Value

true if enabled; otherwise, false.
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


Text Property (ThumbnailsPanel)

Text Property (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : Text Property
Gets or sets the text of the panel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Property Text As System.String
public override System.string Text {get; set;}
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


Visible Property (ThumbnailsPanel)

Visible Property (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : Visible Property
Gets or sets the value that determines whether the viewer's thumbnails panel is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}

Property Value

true if visible; otherwise, false.
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


ThumbnailsPanel Class Fields

ThumbnailsPanel Class Fields

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : ThumbnailsPanel Class

For a list of all members of this type, see ThumbnailsPanel members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | EnabledProperty | Gets or sets the value that determines whether the viewer's thumbnails panel is enabled.
static (Shared in Visual Basic) | VisibleProperty | Gets or sets the value that determines whether the viewer's thumbnails panel is visible.
Top
See Also

Reference

ThumbnailsPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


EnabledProperty Field (ThumbnailsPanel)

EnabledProperty Field (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : EnabledProperty Field
Gets or sets the value that determines whether the viewer's thumbnails panel is enabled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly EnabledProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty EnabledProperty
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


VisibleProperty Field (ThumbnailsPanel)

VisibleProperty Field (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : VisibleProperty Field
Gets or sets the value that determines whether the viewer's thumbnails panel is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly VisibleProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty VisibleProperty
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


TocPanel Class

TocPanel Class
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : TocPanel Class
Manages the viewer's table of contents panel properties.
Object Model
TocPanel Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class TocPanel
   Inherits SidebarPanel
public sealed class TocPanel : SidebarPanel
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel
GrapeCity.ActiveReports.Viewer.Wpf.TocPanel

See Also

Reference

TocPanel Members
GrapeCity.ActiveReports.Viewer.Wpf Namespace


TocPanel Class Members

TocPanel Class Members
Fields Properties Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : TocPanel Class

The following tables list the members exposed by TocPanel.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | EnabledProperty | Gets or sets the value determines whether the viewer's table of contents panel is enabled.
static (Shared in Visual Basic) | ExpandedProperty | Expanded binding property
static (Shared in Visual Basic) | VisibleProperty | Gets or sets the value determines whether the viewer's table of contents panel is visible.
Top
Public Properties
 | Name | Description
Public Property | DependencyObjectType | (Inherited from System.Windows.DependencyObject)
Public Property | Dispatcher | (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | Enabled | Gets or sets the value determines whether the viewer's table of contents panel is enabled.
Public Property | Expanded | Gets or sets a value that indicates whether the TocPanel is expanded.
Public Property | IsSealed | (Inherited from System.Windows.DependencyObject)
Public Property | SelectedItem | Sets or returns the currently selected item in the table of contents.
Public Property | Text | Overridden. Gets or sets the text of the panel.
Public Property | Visible | Gets or sets the value determines whether the viewer's table of contents panel is visible.
Top
Public Methods
 | Name | Description
Public Method | Clear | Overridden. Clears the table of contents panel.
Public Method | ClearValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Overridden. Releases the resources used by the table of contents panel.
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | GetHashCode | (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateProperty | (Inherited from System.Windows.DependencyObject)
Public Method | ReadLocalValue | (Inherited from System.Windows.DependencyObject)
Public Method | Refresh | Overridden. Forces the table of contents panel to invalidate its client area and immediately redraw itself and any child controls.
Public Method | SetCurrentValue | (Inherited from System.Windows.DependencyObject)
Public Method | SetValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Top
See Also

Reference

TocPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


TocPanel Class Methods

TocPanel Class Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : TocPanel Class

For a list of all members of this type, see TocPanel members.

Public Methods
 | Name | Description
Public Method | Clear | Overridden. Clears the table of contents panel.
Public Method | ClearValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Overridden. Releases the resources used by the table of contents panel.
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | GetHashCode | (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateProperty | (Inherited from System.Windows.DependencyObject)
Public Method | ReadLocalValue | (Inherited from System.Windows.DependencyObject)
Public Method | Refresh | Overridden. Forces the table of contents panel to invalidate its client area and immediately redraw itself and any child controls.
Public Method | SetCurrentValue | (Inherited from System.Windows.DependencyObject)
Public Method | SetValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Top
See Also

Reference

TocPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Clear Method (TocPanel)

Clear Method (TocPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : Clear Method
Clears the table of contents panel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Sub Clear()
public override void Clear()
See Also

Reference

TocPanel Class
TocPanel Members


Dispose Method (TocPanel)

Dispose Method (TocPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : Dispose Method
Releases the resources used by the table of contents panel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Sub Dispose()
public override void Dispose()
See Also

Reference

TocPanel Class
TocPanel Members


Refresh Method (TocPanel)

Refresh Method (TocPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : Refresh Method
Forces the table of contents panel to invalidate its client area and immediately redraw itself and any child controls.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Sub Refresh()
public override void Refresh()
See Also

Reference

TocPanel Class
TocPanel Members


TocPanel Class Properties

TocPanel Class Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : TocPanel Class

For a list of all members of this type, see TocPanel members.

Public Properties
 | Name | Description
Public Property | DependencyObjectType | (Inherited from System.Windows.DependencyObject)
Public Property | Dispatcher | (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | Enabled | Gets or sets the value determines whether the viewer's table of contents panel is enabled.
Public Property | Expanded | Gets or sets a value that indicates whether the TocPanel is expanded.
Public Property | IsSealed | (Inherited from System.Windows.DependencyObject)
Public Property | SelectedItem | Sets or returns the currently selected item in the table of contents.
Public Property | Text | Overridden. Gets or sets the text of the panel.
Public Property | Visible | Gets or sets the value determines whether the viewer's table of contents panel is visible.
Top
See Also

Reference

TocPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Enabled Property (TocPanel)

Enabled Property (TocPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : Enabled Property
Gets or sets the value determines whether the viewer's table of contents panel is enabled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Enabled As System.Boolean
public System.bool Enabled {get; set;}

Property Value

true if enabled; otherwise, false.
See Also

Reference

TocPanel Class
TocPanel Members


Expanded Property (TocPanel)

Expanded Property (TocPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : Expanded Property
Gets or sets a value that indicates whether the TocPanel is expanded.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Expanded As System.Boolean
public System.bool Expanded {get; set;}

Property Value

true if expanded; otherwise, false.
See Also

Reference

TocPanel Class
TocPanel Members


SelectedItem Property

SelectedItem Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : SelectedItem Property
Sets or returns the currently selected item in the table of contents.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property SelectedItem As System.Object
public System.object SelectedItem {get;}
See Also

Reference

TocPanel Class
TocPanel Members


Text Property (TocPanel)

Text Property (TocPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : Text Property
Gets or sets the text of the panel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Property Text As System.String
public override System.string Text {get; set;}

Property Value

The text.
See Also

Reference

TocPanel Class
TocPanel Members


Visible Property (TocPanel)

Visible Property (TocPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : Visible Property
Gets or sets the value determines whether the viewer's table of contents panel is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}

Property Value

true if visible; otherwise, false.
See Also

Reference

TocPanel Class
TocPanel Members


TocPanel Class Fields

TocPanel Class Fields

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : TocPanel Class

For a list of all members of this type, see TocPanel members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | EnabledProperty | Gets or sets the value determines whether the viewer's table of contents panel is enabled.
static (Shared in Visual Basic) | ExpandedProperty | Expanded binding property
static (Shared in Visual Basic) | VisibleProperty | Gets or sets the value determines whether the viewer's table of contents panel is visible.
Top
See Also

Reference

TocPanel Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


EnabledProperty Field (TocPanel)

EnabledProperty Field (TocPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : EnabledProperty Field
Gets or sets the value determines whether the viewer's table of contents panel is enabled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly EnabledProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty EnabledProperty
See Also

Reference

TocPanel Class
TocPanel Members


ExpandedProperty Field

ExpandedProperty Field

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : ExpandedProperty Field
Expanded binding property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly ExpandedProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty ExpandedProperty
See Also

Reference

TocPanel Class
TocPanel Members


VisibleProperty Field (TocPanel)

VisibleProperty Field (TocPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : VisibleProperty Field
Gets or sets the value determines whether the viewer's table of contents panel is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly VisibleProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty VisibleProperty
See Also

Reference

TocPanel Class
TocPanel Members


Viewer Class

Viewer Class
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Viewer Class
The WPF based report Viewer control. The WPF Viewer control is used to preivew report documents.
Object Model
Viewer Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Viewer
   Inherits System.Windows.Controls.Control
public class Viewer : System.Windows.Controls.Control
Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
GrapeCity.ActiveReports.Viewer.Wpf.Viewer

See Also

Reference

Viewer Members
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Viewer Class Members

Viewer Class Members
Fields Properties Methods Events

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Viewer Class

The following tables list the members exposed by Viewer.

Public Constructors
 | Name | Description
Public Constructor | Viewer Constructor | Initializes the new instance of Viewer class.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | AllowSplitterProperty | Gets or sets a value that determines whether the user is allowed to split the view.
static (Shared in Visual Basic) | HyperlinkBackColorProperty | Gets or sets the background color of the controls that hosts a hyperlink. The default is transparent. For SectionReports only.
static (Shared in Visual Basic) | HyperlinkForeColorProperty | Gets or sets the color of the text within a control that hosts a hyperlink. The default is Blue. For SectionReports only.
static (Shared in Visual Basic) | HyperlinkUnderlineProperty | Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true. For SectionReports only.
static (Shared in Visual Basic) | PageOffsetProperty | Gets or sets the location of the page in the viewer.
static (Shared in Visual Basic) | PagesBackColorProperty | Public API for background color of report pane.
static (Shared in Visual Basic) | PreviewPagesProperty | Pages to load. Pass value less or equal to 0 to load all Applicable only for loading from SectionReport or PageDocument instances.
static (Shared in Visual Basic) | PrintingSettingsProperty | DesignPrintingSettings binding property
static (Shared in Visual Basic) | RepositionPageProperty | Determines whether the viewer will reposition the view to the top of the page when a user goes to another page after scrolling downward in a page.
static (Shared in Visual Basic) | ScrollbarEnabledProperty | Public API. Show or hide scrolls within report pane.
static (Shared in Visual Basic) | SearchResultsBackColorProperty | Gets or sets the background color of the highlighted text when using the Viewer control's Find functionality.
static (Shared in Visual Basic) | SearchResultsForeColorProperty | Gets or sets the color of the highlighted text when using the Viewer control's Find functionality.
static (Shared in Visual Basic) | SplitViewProperty | Gets or sets a value that determines whether the viewer is split into two views.
static (Shared in Visual Basic) | TargetViewProperty | Gets or sets a value that specifies the current target view when SplitView is true.
static (Shared in Visual Basic) | UseHyperlinkSettingsProperty | Gets or sets whether to apply the hyperlink settings when hyperlinks are displayed in the Viewer. For SectionReports only.
static (Shared in Visual Basic) | ZoomProperty | Gets or sets the viewer's zoom level. -1 for FitWidth mode -2 for Fit Whole Page mode. Throws ArgumentOutOfRangeException on invalid value.
Top
Public Properties
 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | AllowDrop | (Inherited from System.Windows.UIElement)
Public Property | AllowSplitter | Gets or sets a value that determines whether the user is allowed to split the view.
Public Property | AreAnyTouchesCaptured | (Inherited from System.Windows.UIElement)
Public Property | AreAnyTouchesCapturedWithin | (Inherited from System.Windows.UIElement)
Public Property | AreAnyTouchesDirectlyOver | (Inherited from System.Windows.UIElement)
Public Property | AreAnyTouchesOver | (Inherited from System.Windows.UIElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BindingGroup | (Inherited from System.Windows.FrameworkElement)
Public Property | BitmapEffect | (Inherited from System.Windows.UIElement)
Public Property | BitmapEffectInput | (Inherited from System.Windows.UIElement)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | (Inherited from System.Windows.UIElement)
Public Property | CanExport | Indicates whether the loaded report can be exported or not. Returns "false" if export is not permitted.
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | ClipToBounds | (Inherited from System.Windows.UIElement)
Public Property | CommandBindings | (Inherited from System.Windows.UIElement)
Public Property | ContextMenu | (Inherited from System.Windows.FrameworkElement)
Public Property | CurrentPage | Gets or sets the number of the current document page displayed in the viewer. 1 based. Returns 0 if no report is loaded. Affects History.
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DependencyObjectType | (Inherited from System.Windows.DependencyObject)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | Effect | (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | (Inherited from System.Windows.FrameworkElement)
Public Property | Focusable | (Inherited from System.Windows.UIElement)
Public Property | FocusVisualStyle | (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | ForceCursor | (Inherited from System.Windows.FrameworkElement)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | GalleyMode | Gets or sets GalleyMode of report
Public Property | HasAnimatedProperties | (Inherited from System.Windows.UIElement)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | History | Public API for history manipulation.
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | HyperlinkBackColor | Gets or sets the background color of the controls that hosts a hyperlink. The default is transparent. For SectionReports only.
Public Property | HyperlinkForeColor | Gets or sets the color of the text within a control that hosts a hyperlink. The default is Blue. For SectionReports only.
Public Property | HyperlinkUnderline | Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true. For SectionReports only.
Public Property | InputBindings | (Inherited from System.Windows.UIElement)
Public Property | InputScope | (Inherited from System.Windows.FrameworkElement)
Public Property | IsArrangeValid | (Inherited from System.Windows.UIElement)
Public Property | IsEnabled | (Inherited from System.Windows.UIElement)
Public Property | IsFocused | (Inherited from System.Windows.UIElement)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsInitialized | (Inherited from System.Windows.FrameworkElement)
Public Property | IsInputMethodEnabled | (Inherited from System.Windows.UIElement)
Public Property | IsKeyboardFocused | (Inherited from System.Windows.UIElement)
Public Property | IsKeyboardFocusWithin | (Inherited from System.Windows.UIElement)
Public Property | IsLoaded | (Inherited from System.Windows.FrameworkElement)
Public Property | IsManipulationEnabled | (Inherited from System.Windows.UIElement)
Public Property | IsMeasureValid | (Inherited from System.Windows.UIElement)
Public Property | IsMouseCaptured | (Inherited from System.Windows.UIElement)
Public Property | IsMouseCaptureWithin | (Inherited from System.Windows.UIElement)
Public Property | IsMouseDirectlyOver | (Inherited from System.Windows.UIElement)
Public Property | IsMouseOver | (Inherited from System.Windows.UIElement)
Public Property | IsSealed | (Inherited from System.Windows.DependencyObject)
Public Property | IsStylusCaptured | (Inherited from System.Windows.UIElement)
Public Property | IsStylusCaptureWithin | (Inherited from System.Windows.UIElement)
Public Property | IsStylusDirectlyOver | (Inherited from System.Windows.UIElement)
Public Property | IsStylusOver | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsVisible | (Inherited from System.Windows.UIElement)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | LayoutTransform | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | OverridesDefaultStyle | (Inherited from System.Windows.FrameworkElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | PageOffset | Gets or sets the location of the page in the viewer.
Public Property | PagesBackColor | Public API for background color of report pane.
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | PersistId | (Inherited from System.Windows.UIElement)
Public Property | PreviewPages | Pages to load. Pass value less or equal to 0 to load all Applicable only for loading from SectionReport or PageDocument instances
Public Property | PrintingSettings | Gets or sets printing settings
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | RepositionPage | Determines whether the viewer will reposition the view to the top of the page when a user goes to another page after scrolling downward in a page.
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | ScrollbarEnabled | Public API. Show or hide scrolls within report pane.
Public Property | SearchResultsBackColor | Gets or sets the background color of the highlighted text when using the Viewer control's Find functionality.
Public Property | SearchResultsForeColor | Gets or sets the color of the highlighted text when using the Viewer control's Find functionality.
Public Property | Sidebar | Gets the sidebar component of the viewer control.
Public Property | SnapsToDevicePixels | (Inherited from System.Windows.UIElement)
Public Property | SplitView | Gets or sets a value that determines whether the viewer is split into two views.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TableOfContents | Gets the table of contents panel component of sidebar component.
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | TargetView | Gets or sets a value that specifies the current target view when SplitView is true.
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TemplatedParent | (Inherited from System.Windows.FrameworkElement)
Public Property | ToolTip | (Inherited from System.Windows.FrameworkElement)
Public Property | TouchesCaptured | (Inherited from System.Windows.UIElement)
Public Property | TouchesCapturedWithin | (Inherited from System.Windows.UIElement)
Public Property | TouchesDirectlyOver | (Inherited from System.Windows.UIElement)
Public Property | TouchesOver | (Inherited from System.Windows.UIElement)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | Uid | (Inherited from System.Windows.UIElement)
Public Property | UseHyperlinkSettings | Gets or sets whether to apply the hyperlink settings when hyperlinks are displayed in the Viewer. For SectionReports only.
Public Property | UseLayoutRounding | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Public Property | Zoom | Gets or sets the viewer's zoom level. -1 for FitWidth mode -2 for Fit Whole Page mode. Throws ArgumentOutOfRangeException on invalid value.
Top
Public Methods
 | Name | Description
Public Method | AddHandler | Overloaded. (Inherited from System.Windows.UIElement)
Public Method | AddToEventRoute | (Inherited from System.Windows.UIElement)
Public Method | ApplyAnimationClock | Overloaded. (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | (Inherited from System.Windows.FrameworkElement)
Public Method | Arrange | (Inherited from System.Windows.UIElement)
Public Method | BeginAnimation | Overloaded. (Inherited from System.Windows.UIElement)
Public Method | BeginInit | (Inherited from System.Windows.FrameworkElement)
Public Method | BeginStoryboard | Overloaded. (Inherited from System.Windows.FrameworkElement)
Public Method | BringIntoView | Overloaded. (Inherited from System.Windows.FrameworkElement)
Public Method | CaptureMouse | (Inherited from System.Windows.UIElement)
Public Method | CaptureStylus | (Inherited from System.Windows.UIElement)
Public Method | CaptureTouch | (Inherited from System.Windows.UIElement)
Public Method | ClearValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Releases the resources used by Viewer control.
Public Method | EndInit | (Inherited from System.Windows.FrameworkElement)
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | Export | Overloaded. Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.
Public Method | FindCommonVisualAncestor | (Inherited from System.Windows.Media.Visual)
Public Method | FindName | (Inherited from System.Windows.FrameworkElement)
Public Method | FindResource | (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | (Inherited from System.Windows.UIElement)
Public Method | GetAnimationBaseValue | (Inherited from System.Windows.UIElement)
Public Method | GetBindingExpression | (Inherited from System.Windows.FrameworkElement)
Public Method | GetHashCode | (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | (Inherited from System.Windows.DependencyObject)
Public Method | HandleError | Reports about runtime error
Public Method | InputHitTest | (Inherited from System.Windows.UIElement)
Public Method | InvalidateArrange | (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | (Inherited from System.Windows.UIElement)
Public Method | InvalidateProperty | (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateVisual | (Inherited from System.Windows.UIElement)
Public Method | IsAncestorOf | (Inherited from System.Windows.Media.Visual)
Public Method | IsDescendantOf | (Inherited from System.Windows.Media.Visual)
Public Method | LoadDocument | Overloaded. Loads a report.
Public Method | Measure | (Inherited from System.Windows.UIElement)
Public Method | MoveFocus | (Inherited from System.Windows.FrameworkElement)
Public Method | PointFromScreen | (Inherited from System.Windows.Media.Visual)
Public Method | PointToScreen | (Inherited from System.Windows.Media.Visual)
Public Method | PredictFocus | (Inherited from System.Windows.FrameworkElement)
Public Method | Print | Overloaded. Prints the currently opened document(section or page)
Public Method | RaiseEvent | (Inherited from System.Windows.UIElement)
Public Method | ReadLocalValue | (Inherited from System.Windows.DependencyObject)
Public Method | RegisterName | (Inherited from System.Windows.FrameworkElement)
Public Method | ReleaseAllTouchCaptures | (Inherited from System.Windows.UIElement)
Public Method | ReleaseMouseCapture | (Inherited from System.Windows.UIElement)
Public Method | ReleaseStylusCapture | (Inherited from System.Windows.UIElement)
Public Method | ReleaseTouchCapture | (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | (Inherited from System.Windows.UIElement)
Public Method | Render | Exports the specified loaded report to the specified file (or group of files) by using the specified export extension. Note: for page report only.
Public Method | SetBinding | Overloaded. (Inherited from System.Windows.FrameworkElement)
Public Method | SetCurrentValue | (Inherited from System.Windows.DependencyObject)
Public Method | SetParametersValues | Sets values of parameters for the report that is shown.
Public Method | SetResourceReference | (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Public Method | ToString | (Inherited from System.Windows.Controls.Control)
Public Method | TransformToAncestor | Overloaded. (Inherited from System.Windows.Media.Visual)
Public Method | TransformToDescendant | (Inherited from System.Windows.Media.Visual)
Public Method | TransformToVisual | (Inherited from System.Windows.Media.Visual)
Public Method | TranslatePoint | (Inherited from System.Windows.UIElement)
Public Method | TryFindResource | (Inherited from System.Windows.FrameworkElement)
Public Method | UnregisterName | (Inherited from System.Windows.FrameworkElement)
Public Method | UpdateDefaultStyle | (Inherited from System.Windows.FrameworkElement)
Public Method | UpdateLayout | (Inherited from System.Windows.UIElement)
Top
Public Events
 | Name | Description
Public Event | Action | This event fires when report item with specified action was clicked in the report preview control.
Public Event | ContextMenuClosing | (Inherited from System.Windows.FrameworkElement)
Public Event | ContextMenuOpening | (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | (Inherited from System.Windows.UIElement)
Public Event | DragLeave | (Inherited from System.Windows.UIElement)
Public Event | DragOver | (Inherited from System.Windows.UIElement)
Public Event | Drop | (Inherited from System.Windows.UIElement)
Public Event | FocusableChanged | (Inherited from System.Windows.UIElement)
Public Event | GiveFeedback | (Inherited from System.Windows.UIElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | GotKeyboardFocus | (Inherited from System.Windows.UIElement)
Public Event | GotMouseCapture | (Inherited from System.Windows.UIElement)
Public Event | GotStylusCapture | (Inherited from System.Windows.UIElement)
Public Event | GotTouchCapture | (Inherited from System.Windows.UIElement)
Public Event | HyperLink | Occurs when the user clicks on text or an image that has a hyperlink assigned to it.
Public Event | Initialized | (Inherited from System.Windows.FrameworkElement)
Public Event | IsEnabledChanged | (Inherited from System.Windows.UIElement)
Public Event | IsHitTestVisibleChanged | (Inherited from System.Windows.UIElement)
Public Event | IsKeyboardFocusedChanged | (Inherited from System.Windows.UIElement)
Public Event | IsKeyboardFocusWithinChanged | (Inherited from System.Windows.UIElement)
Public Event | IsMouseCapturedChanged | (Inherited from System.Windows.UIElement)
Public Event | IsMouseCaptureWithinChanged | (Inherited from System.Windows.UIElement)
Public Event | IsMouseDirectlyOverChanged | (Inherited from System.Windows.UIElement)
Public Event | IsStylusCapturedChanged | (Inherited from System.Windows.UIElement)
Public Event | IsStylusCaptureWithinChanged | (Inherited from System.Windows.UIElement)
Public Event | IsStylusDirectlyOverChanged | (Inherited from System.Windows.UIElement)
Public Event | IsVisibleChanged | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.UIElement)
Public Event | LoadCompleted | Occurs after all the viewer pages have been fully loaded.
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LocateCredentials | Fires when the PageReport to view generates LocateCredentials event.
Public Event | LocateDataSource | Fires when the PageReport to view generates LocateDataSource event.
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | LostKeyboardFocus | (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | (Inherited from System.Windows.UIElement)
Public Event | LostStylusCapture | (Inherited from System.Windows.UIElement)
Public Event | LostTouchCapture | (Inherited from System.Windows.UIElement)
Public Event | ManipulationBoundaryFeedback | (Inherited from System.Windows.UIElement)
Public Event | ManipulationCompleted | (Inherited from System.Windows.UIElement)
Public Event | ManipulationDelta | (Inherited from System.Windows.UIElement)
Public Event | ManipulationInertiaStarting | (Inherited from System.Windows.UIElement)
Public Event | ManipulationStarted | (Inherited from System.Windows.UIElement)
Public Event | ManipulationStarting | (Inherited from System.Windows.UIElement)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Controls.Control)
Public Event | MouseDown | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseUp | (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | (Inherited from System.Windows.UIElement)
Public Event | PreviewDragEnter | (Inherited from System.Windows.UIElement)
Public Event | PreviewDragLeave | (Inherited from System.Windows.UIElement)
Public Event | PreviewDragOver | (Inherited from System.Windows.UIElement)
Public Event | PreviewDrop | (Inherited from System.Windows.UIElement)
Public Event | PreviewGiveFeedback | (Inherited from System.Windows.UIElement)
Public Event | PreviewGotKeyboardFocus | (Inherited from System.Windows.UIElement)
Public Event | PreviewKeyDown | (Inherited from System.Windows.UIElement)
Public Event | PreviewKeyUp | (Inherited from System.Windows.UIElement)
Public Event | PreviewLostKeyboardFocus | (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseDoubleClick | (Inherited from System.Windows.Controls.Control)
Public Event | PreviewMouseDown | (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseMove | (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseRightButtonDown | (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseRightButtonUp | (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseUp | (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseWheel | (Inherited from System.Windows.UIElement)
Public Event | PreviewQueryContinueDrag | (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusButtonDown | (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusButtonUp | (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusDown | (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusInAirMove | (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusInRange | (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusMove | (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusOutOfRange | (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusSystemGesture | (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusUp | (Inherited from System.Windows.UIElement)
Public Event | PreviewTextInput | (Inherited from System.Windows.UIElement)
Public Event | PreviewTouchDown | (Inherited from System.Windows.UIElement)
Public Event | PreviewTouchMove | (Inherited from System.Windows.UIElement)
Public Event | PreviewTouchUp | (Inherited from System.Windows.UIElement)
Public Event | QueryContinueDrag | (Inherited from System.Windows.UIElement)
Public Event | QueryCursor | (Inherited from System.Windows.UIElement)
Public Event | RequestBringIntoView | (Inherited from System.Windows.FrameworkElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | SourceUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | StylusButtonDown | (Inherited from System.Windows.UIElement)
Public Event | StylusButtonUp | (Inherited from System.Windows.UIElement)
Public Event | StylusDown | (Inherited from System.Windows.UIElement)
Public Event | StylusEnter | (Inherited from System.Windows.UIElement)
Public Event | StylusInAirMove | (Inherited from System.Windows.UIElement)
Public Event | StylusInRange | (Inherited from System.Windows.UIElement)
Public Event | StylusLeave | (Inherited from System.Windows.UIElement)
Public Event | StylusMove | (Inherited from System.Windows.UIElement)
Public Event | StylusOutOfRange | (Inherited from System.Windows.UIElement)
Public Event | StylusSystemGesture | (Inherited from System.Windows.UIElement)
Public Event | StylusUp | (Inherited from System.Windows.UIElement)
Public Event | TargetUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | (Inherited from System.Windows.UIElement)
Public Event | ToolTipClosing | (Inherited from System.Windows.FrameworkElement)
Public Event | ToolTipOpening | (Inherited from System.Windows.FrameworkElement)
Public Event | TouchDown | (Inherited from System.Windows.UIElement)
Public Event | TouchEnter | (Inherited from System.Windows.UIElement)
Public Event | TouchLeave | (Inherited from System.Windows.UIElement)
Public Event | TouchMove | (Inherited from System.Windows.UIElement)
Public Event | TouchUp | (Inherited from System.Windows.UIElement)
Public Event | Unloaded | (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

Viewer Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Viewer Constructor

Viewer Constructor

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Viewer Constructor
Initializes the new instance of Viewer class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Viewer()
See Also

Reference

Viewer Class
Viewer Members


Viewer Class Methods

Viewer Class Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Viewer Class

For a list of all members of this type, see Viewer members.

Public Methods
 | Name | Description
Public Method | AddHandler | Overloaded. (Inherited from System.Windows.UIElement)
Public Method | AddToEventRoute | (Inherited from System.Windows.UIElement)
Public Method | ApplyAnimationClock | Overloaded. (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | (Inherited from System.Windows.FrameworkElement)
Public Method | Arrange | (Inherited from System.Windows.UIElement)
Public Method | BeginAnimation | Overloaded. (Inherited from System.Windows.UIElement)
Public Method | BeginInit | (Inherited from System.Windows.FrameworkElement)
Public Method | BeginStoryboard | Overloaded. (Inherited from System.Windows.FrameworkElement)
Public Method | BringIntoView | Overloaded. (Inherited from System.Windows.FrameworkElement)
Public Method | CaptureMouse | (Inherited from System.Windows.UIElement)
Public Method | CaptureStylus | (Inherited from System.Windows.UIElement)
Public Method | CaptureTouch | (Inherited from System.Windows.UIElement)
Public Method | ClearValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Public Method | CoerceValue | (Inherited from System.Windows.DependencyObject)
Public Method | Dispose | Releases the resources used by Viewer control.
Public Method | EndInit | (Inherited from System.Windows.FrameworkElement)
Public Method | Equals | (Inherited from System.Windows.DependencyObject)
Public Method | Export | Overloaded. Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.
Public Method | FindCommonVisualAncestor | (Inherited from System.Windows.Media.Visual)
Public Method | FindName | (Inherited from System.Windows.FrameworkElement)
Public Method | FindResource | (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | (Inherited from System.Windows.UIElement)
Public Method | GetAnimationBaseValue | (Inherited from System.Windows.UIElement)
Public Method | GetBindingExpression | (Inherited from System.Windows.FrameworkElement)
Public Method | GetHashCode | (Inherited from System.Windows.DependencyObject)
Public Method | GetValue | (Inherited from System.Windows.DependencyObject)
Public Method | HandleError | Reports about runtime error
Public Method | InputHitTest | (Inherited from System.Windows.UIElement)
Public Method | InvalidateArrange | (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | (Inherited from System.Windows.UIElement)
Public Method | InvalidateProperty | (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateVisual | (Inherited from System.Windows.UIElement)
Public Method | IsAncestorOf | (Inherited from System.Windows.Media.Visual)
Public Method | IsDescendantOf | (Inherited from System.Windows.Media.Visual)
Public Method | LoadDocument | Overloaded. Loads a report.
Public Method | Measure | (Inherited from System.Windows.UIElement)
Public Method | MoveFocus | (Inherited from System.Windows.FrameworkElement)
Public Method | PointFromScreen | (Inherited from System.Windows.Media.Visual)
Public Method | PointToScreen | (Inherited from System.Windows.Media.Visual)
Public Method | PredictFocus | (Inherited from System.Windows.FrameworkElement)
Public Method | Print | Overloaded. Prints the currently opened document(section or page)
Public Method | RaiseEvent | (Inherited from System.Windows.UIElement)
Public Method | ReadLocalValue | (Inherited from System.Windows.DependencyObject)
Public Method | RegisterName | (Inherited from System.Windows.FrameworkElement)
Public Method | ReleaseAllTouchCaptures | (Inherited from System.Windows.UIElement)
Public Method | ReleaseMouseCapture | (Inherited from System.Windows.UIElement)
Public Method | ReleaseStylusCapture | (Inherited from System.Windows.UIElement)
Public Method | ReleaseTouchCapture | (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | (Inherited from System.Windows.UIElement)
Public Method | Render | Exports the specified loaded report to the specified file (or group of files) by using the specified export extension. Note: for page report only.
Public Method | SetBinding | Overloaded. (Inherited from System.Windows.FrameworkElement)
Public Method | SetCurrentValue | (Inherited from System.Windows.DependencyObject)
Public Method | SetParametersValues | Sets values of parameters for the report that is shown.
Public Method | SetResourceReference | (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | Overloaded. (Inherited from System.Windows.DependencyObject)
Public Method | ToString | (Inherited from System.Windows.Controls.Control)
Public Method | TransformToAncestor | Overloaded. (Inherited from System.Windows.Media.Visual)
Public Method | TransformToDescendant | (Inherited from System.Windows.Media.Visual)
Public Method | TransformToVisual | (Inherited from System.Windows.Media.Visual)
Public Method | TranslatePoint | (Inherited from System.Windows.UIElement)
Public Method | TryFindResource | (Inherited from System.Windows.FrameworkElement)
Public Method | UnregisterName | (Inherited from System.Windows.FrameworkElement)
Public Method | UpdateDefaultStyle | (Inherited from System.Windows.FrameworkElement)
Public Method | UpdateLayout | (Inherited from System.Windows.UIElement)
Top
See Also

Reference

Viewer Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Dispose Method (Viewer)

Dispose Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Dispose Method
Releases the resources used by Viewer control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Viewer Class
Viewer Members


Export Method (Viewer)

Export Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Export Method
Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.
Overload List
Overload | Description
Export(IDocumentExportEx,FileInfo) | Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.
Export(IDocumentExportEx,FileInfo,String) | Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.
Export(IDocumentExportEx,Stream) | Exports the specified page range of the currently loaded report to the specified stream by using the specified export filter.
Export(IDocumentExportEx,Stream,String) | Exports the specified page range of the currently loaded report to the specified stream by using the specified export filter.
See Also

Reference

Viewer Class
Viewer Members


Export(IDocumentExportEx,FileInfo) Method

Export(IDocumentExportEx,FileInfo) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > Export Method : Export(IDocumentExportEx,FileInfo) Method
The export filter component to export the currently displayed report with.
The file to write the output to.
Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal filter As IDocumentExportEx, _
   ByVal file As System.IO.FileInfo _
)
public void Export(
   IDocumentExportEx filter,
   System.IO.FileInfo file
)

Parameters

filter
The export filter component to export the currently displayed report with.
file
The file to write the output to.
See Also

Reference

Viewer Class
Viewer Members
Overload List


Export(IDocumentExportEx,FileInfo,String) Method

Export(IDocumentExportEx,FileInfo,String) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > Export Method : Export(IDocumentExportEx,FileInfo,String) Method
The export filter component to export the currently displayed report with; file.
The file to write the output to.
The page range of the report to export.
Exports the specified page range of the currently loaded report to the specified file by using the specified export filter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal filter As IDocumentExportEx, _
   ByVal file As System.IO.FileInfo, _
   ByVal pageRange As System.String _
)
public void Export(
   IDocumentExportEx filter,
   System.IO.FileInfo file,
   System.string pageRange
)

Parameters

filter
The export filter component to export the currently displayed report with; file.
file
The file to write the output to.
pageRange
The page range of the report to export.
See Also

Reference

Viewer Class
Viewer Members
Overload List


Export(IDocumentExportEx,Stream) Method

Export(IDocumentExportEx,Stream) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > Export Method : Export(IDocumentExportEx,Stream) Method
The export filter component to export the currently displayed report with.
The stream to write the output to.
Exports the specified page range of the currently loaded report to the specified stream by using the specified export filter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal filter As IDocumentExportEx, _
   ByVal stream As System.IO.Stream _
)
public void Export(
   IDocumentExportEx filter,
   System.IO.Stream stream
)

Parameters

filter
The export filter component to export the currently displayed report with.
stream
The stream to write the output to.
See Also

Reference

Viewer Class
Viewer Members
Overload List


Export(IDocumentExportEx,Stream,String) Method

Export(IDocumentExportEx,Stream,String) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > Export Method : Export(IDocumentExportEx,Stream,String) Method
The export filter component to export the currently displayed report with.
The stream to write the output to.
The page range of the report to export.
Exports the specified page range of the currently loaded report to the specified stream by using the specified export filter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Export( _
   ByVal filter As IDocumentExportEx, _
   ByVal stream As System.IO.Stream, _
   ByVal pageRange As System.String _
)
public void Export(
   IDocumentExportEx filter,
   System.IO.Stream stream,
   System.string pageRange
)

Parameters

filter
The export filter component to export the currently displayed report with.
stream
The stream to write the output to.
pageRange
The page range of the report to export.
See Also

Reference

Viewer Class
Viewer Members
Overload List


HandleError Method (Viewer)

HandleError Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : HandleError Method
The exception to report.
Reports about runtime error
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub HandleError( _
   ByVal ex As System.Exception _
)
public void HandleError(
   System.Exception ex
)

Parameters

ex
The exception to report.
See Also

Reference

Viewer Class
Viewer Members


LoadDocument Method (Viewer)

LoadDocument Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : LoadDocument Method
Loads a report.
Overload List
Overload | Description
LoadDocument(Stream,DocumentFormat) | Loads the document from stream.
LoadDocument(String) | Loads a report from the specified file path.
LoadDocument(PageDocument) | Loads the specified page document.
LoadDocument(SectionReport) | Loads the specified section report.
LoadDocument(SectionDocument) | Loads the specified section document.
LoadDocument(RemoteReportDescriptor) | Loads the specified remote document from ActiveReports Server.
See Also

Reference

Viewer Class
Viewer Members


LoadDocument(Stream,DocumentFormat) Method

LoadDocument(Stream,DocumentFormat) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > LoadDocument Method : LoadDocument(Stream,DocumentFormat) Method
Stream to load from. Note: Page report with master file should contains full path to master file.
The format of the report to load.
Loads the document from stream.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadDocument( _
   ByVal stream As System.IO.Stream, _
   ByVal format As DocumentFormat _
)
public void LoadDocument(
   System.IO.Stream stream,
   DocumentFormat format
)

Parameters

stream
Stream to load from. Note: Page report with master file should contains full path to master file.
format
The format of the report to load.
See Also

Reference

Viewer Class
Viewer Members
Overload List


LoadDocument(String) Method

LoadDocument(String) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > LoadDocument Method : LoadDocument(String) Method
The file to load.
Loads a report from the specified file path.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadDocument( _
   ByVal filePath As System.String _
)
public void LoadDocument(
   System.string filePath
)

Parameters

filePath
The file to load.
See Also

Reference

Viewer Class
Viewer Members
Overload List


LoadDocument(PageDocument) Method

LoadDocument(PageDocument) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > LoadDocument Method : LoadDocument(PageDocument) Method
The page document to load.
Loads the specified page document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadDocument( _
   ByVal pageDocument As PageDocument _
)
public void LoadDocument(
   PageDocument pageDocument
)

Parameters

pageDocument
The page document to load.
See Also

Reference

Viewer Class
Viewer Members
Overload List


LoadDocument(SectionReport) Method

LoadDocument(SectionReport) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > LoadDocument Method : LoadDocument(SectionReport) Method
The section report to load.
Loads the specified section report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadDocument( _
   ByVal report As SectionReport _
)
public void LoadDocument(
   SectionReport report
)

Parameters

report
The section report to load.
See Also

Reference

Viewer Class
Viewer Members
Overload List


LoadDocument(SectionDocument) Method

LoadDocument(SectionDocument) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > LoadDocument Method : LoadDocument(SectionDocument) Method
The section document top load.
Loads the specified section document.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadDocument( _
   ByVal document As SectionDocument _
)
public void LoadDocument(
   SectionDocument document
)

Parameters

document
The section document top load.
See Also

Reference

Viewer Class
Viewer Members
Overload List


LoadDocument(RemoteReportDescriptor) Method

LoadDocument(RemoteReportDescriptor) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > LoadDocument Method : LoadDocument(RemoteReportDescriptor) Method
The remote ARS report descriptor.
Loads the specified remote document from ActiveReports Server.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadDocument( _
   ByVal report As RemoteReportDescriptor _
)
public void LoadDocument(
   RemoteReportDescriptor report
)

Parameters

report
The remote ARS report descriptor.
See Also

Reference

Viewer Class
Viewer Members
Overload List


Print Method (Viewer)

Print Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Print Method
Prints the currently opened document(section or page)
Overload List
Overload | Description
Print(Boolean) | Prints the currently opened document(section or page)
Print(Boolean,Boolean) | Prints the currently opened document(section or page)
Print(Boolean,Boolean,Boolean) | Prints the currently opened document(section or page)
Print(PrintingSettings) | Prints the currently opened document(section or page)
See Also

Reference

Viewer Class
Viewer Members


Print(Boolean) Method

Print(Boolean) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > Print Method : Print(Boolean) Method

Specifies whether or not the Print dialog should be shown.

Prints the currently opened document(section or page)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Print( _
   ByVal showPrintDialog As System.Boolean _
) As System.Boolean
public System.bool Print(
   System.bool showPrintDialog
)

Parameters

showPrintDialog

Specifies whether or not the Print dialog should be shown.

See Also

Reference

Viewer Class
Viewer Members
Overload List


Print(Boolean,Boolean) Method

Print(Boolean,Boolean) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > Print Method : Print(Boolean,Boolean) Method

Specifies whether or not the Print dialog should be shown.

Specifies whether or not the PrintProgress dialog should be shown.

Prints the currently opened document(section or page)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Print( _
   ByVal showPrintDialog As System.Boolean, _
   ByVal showPrintProgressDialog As System.Boolean _
) As System.Boolean
public System.bool Print(
   System.bool showPrintDialog,
   System.bool showPrintProgressDialog
)

Parameters

showPrintDialog

Specifies whether or not the Print dialog should be shown.

showPrintProgressDialog

Specifies whether or not the PrintProgress dialog should be shown.

See Also

Reference

Viewer Class
Viewer Members
Overload List


Print(Boolean,Boolean,Boolean) Method

Print(Boolean,Boolean,Boolean) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > Print Method : Print(Boolean,Boolean,Boolean) Method

Specifies whether or not the Print dialog should be shown.

Specifies whether or not the PrintProgress dialog should be shown.

If True the printing will run in new thread.

Prints the currently opened document(section or page)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Print( _
   ByVal showPrintDialog As System.Boolean, _
   ByVal showPrintProgressDialog As System.Boolean, _
   ByVal usePrintingThread As System.Boolean _
) As System.Boolean
public System.bool Print(
   System.bool showPrintDialog,
   System.bool showPrintProgressDialog,
   System.bool usePrintingThread
)

Parameters

showPrintDialog

Specifies whether or not the Print dialog should be shown.

showPrintProgressDialog

Specifies whether or not the PrintProgress dialog should be shown.

usePrintingThread

If True the printing will run in new thread.

See Also

Reference

Viewer Class
Viewer Members
Overload List


Print(PrintingSettings) Method

Print(PrintingSettings) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > Print Method : Print(PrintingSettings) Method
Prints the currently opened document(section or page)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Print( _
   ByVal settings As PrintingSettings _
) As System.Boolean
public System.bool Print(
   PrintingSettings settings
)

Parameters

settings
See Also

Reference

Viewer Class
Viewer Members
Overload List


Render(IRenderingExtension,StreamProvider,NameValueCollection) Method

Render(IRenderingExtension,StreamProvider,NameValueCollection) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Render(IRenderingExtension,StreamProvider,NameValueCollection) Method
Rendering extension used to render a report.

The stream provider to store the render output.

The rendering extension settings.

Exports the specified loaded report to the specified file (or group of files) by using the specified export extension. Note: for page report only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Render( _
   ByVal extension As IRenderingExtension, _
   ByVal streamProvider As StreamProvider, _
   ByVal settings As System.Collections.Specialized.NameValueCollection _
)
public void Render(
   IRenderingExtension extension,
   StreamProvider streamProvider,
   System.Collections.Specialized.NameValueCollection settings
)

Parameters

extension
Rendering extension used to render a report.
streamProvider

The stream provider to store the render output.

settings

The rendering extension settings.

See Also

Reference

Viewer Class
Viewer Members


SetParametersValues Method (Viewer)

SetParametersValues Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SetParametersValues Method
Values of parameters to be set.
Sets values of parameters for the report that is shown.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetParametersValues( _
   ByVal parameters As System.Collections.Generic.IEnumerable(Of IParameter) _
)
public void SetParametersValues(
   System.Collections.Generic.IEnumerable<IParameter> parameters
)

Parameters

parameters
Values of parameters to be set.
See Also

Reference

Viewer Class
Viewer Members


Viewer Class Properties

Viewer Class Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Viewer Class

For a list of all members of this type, see Viewer members.

Public Properties
 | Name | Description
Public Property | ActualHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | ActualWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | AllowDrop | (Inherited from System.Windows.UIElement)
Public Property | AllowSplitter | Gets or sets a value that determines whether the user is allowed to split the view.
Public Property | AreAnyTouchesCaptured | (Inherited from System.Windows.UIElement)
Public Property | AreAnyTouchesCapturedWithin | (Inherited from System.Windows.UIElement)
Public Property | AreAnyTouchesDirectlyOver | (Inherited from System.Windows.UIElement)
Public Property | AreAnyTouchesOver | (Inherited from System.Windows.UIElement)
Public Property | Background | (Inherited from System.Windows.Controls.Control)
Public Property | BindingGroup | (Inherited from System.Windows.FrameworkElement)
Public Property | BitmapEffect | (Inherited from System.Windows.UIElement)
Public Property | BitmapEffectInput | (Inherited from System.Windows.UIElement)
Public Property | BorderBrush | (Inherited from System.Windows.Controls.Control)
Public Property | BorderThickness | (Inherited from System.Windows.Controls.Control)
Public Property | CacheMode | (Inherited from System.Windows.UIElement)
Public Property | CanExport | Indicates whether the loaded report can be exported or not. Returns "false" if export is not permitted.
Public Property | Clip | (Inherited from System.Windows.UIElement)
Public Property | ClipToBounds | (Inherited from System.Windows.UIElement)
Public Property | CommandBindings | (Inherited from System.Windows.UIElement)
Public Property | ContextMenu | (Inherited from System.Windows.FrameworkElement)
Public Property | CurrentPage | Gets or sets the number of the current document page displayed in the viewer. 1 based. Returns 0 if no report is loaded. Affects History.
Public Property | Cursor | (Inherited from System.Windows.FrameworkElement)
Public Property | DataContext | (Inherited from System.Windows.FrameworkElement)
Public Property | DependencyObjectType | (Inherited from System.Windows.DependencyObject)
Public Property | DesiredSize | (Inherited from System.Windows.UIElement)
Public Property | Dispatcher | (Inherited from System.Windows.Threading.DispatcherObject)
Public Property | Effect | (Inherited from System.Windows.UIElement)
Public Property | FlowDirection | (Inherited from System.Windows.FrameworkElement)
Public Property | Focusable | (Inherited from System.Windows.UIElement)
Public Property | FocusVisualStyle | (Inherited from System.Windows.FrameworkElement)
Public Property | FontFamily | (Inherited from System.Windows.Controls.Control)
Public Property | FontSize | (Inherited from System.Windows.Controls.Control)
Public Property | FontStretch | (Inherited from System.Windows.Controls.Control)
Public Property | FontStyle | (Inherited from System.Windows.Controls.Control)
Public Property | FontWeight | (Inherited from System.Windows.Controls.Control)
Public Property | ForceCursor | (Inherited from System.Windows.FrameworkElement)
Public Property | Foreground | (Inherited from System.Windows.Controls.Control)
Public Property | GalleyMode | Gets or sets GalleyMode of report
Public Property | HasAnimatedProperties | (Inherited from System.Windows.UIElement)
Public Property | Height | (Inherited from System.Windows.FrameworkElement)
Public Property | History | Public API for history manipulation.
Public Property | HorizontalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | HorizontalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | HyperlinkBackColor | Gets or sets the background color of the controls that hosts a hyperlink. The default is transparent. For SectionReports only.
Public Property | HyperlinkForeColor | Gets or sets the color of the text within a control that hosts a hyperlink. The default is Blue. For SectionReports only.
Public Property | HyperlinkUnderline | Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true. For SectionReports only.
Public Property | InputBindings | (Inherited from System.Windows.UIElement)
Public Property | InputScope | (Inherited from System.Windows.FrameworkElement)
Public Property | IsArrangeValid | (Inherited from System.Windows.UIElement)
Public Property | IsEnabled | (Inherited from System.Windows.UIElement)
Public Property | IsFocused | (Inherited from System.Windows.UIElement)
Public Property | IsHitTestVisible | (Inherited from System.Windows.UIElement)
Public Property | IsInitialized | (Inherited from System.Windows.FrameworkElement)
Public Property | IsInputMethodEnabled | (Inherited from System.Windows.UIElement)
Public Property | IsKeyboardFocused | (Inherited from System.Windows.UIElement)
Public Property | IsKeyboardFocusWithin | (Inherited from System.Windows.UIElement)
Public Property | IsLoaded | (Inherited from System.Windows.FrameworkElement)
Public Property | IsManipulationEnabled | (Inherited from System.Windows.UIElement)
Public Property | IsMeasureValid | (Inherited from System.Windows.UIElement)
Public Property | IsMouseCaptured | (Inherited from System.Windows.UIElement)
Public Property | IsMouseCaptureWithin | (Inherited from System.Windows.UIElement)
Public Property | IsMouseDirectlyOver | (Inherited from System.Windows.UIElement)
Public Property | IsMouseOver | (Inherited from System.Windows.UIElement)
Public Property | IsSealed | (Inherited from System.Windows.DependencyObject)
Public Property | IsStylusCaptured | (Inherited from System.Windows.UIElement)
Public Property | IsStylusCaptureWithin | (Inherited from System.Windows.UIElement)
Public Property | IsStylusDirectlyOver | (Inherited from System.Windows.UIElement)
Public Property | IsStylusOver | (Inherited from System.Windows.UIElement)
Public Property | IsTabStop | (Inherited from System.Windows.Controls.Control)
Public Property | IsVisible | (Inherited from System.Windows.UIElement)
Public Property | Language | (Inherited from System.Windows.FrameworkElement)
Public Property | LayoutTransform | (Inherited from System.Windows.FrameworkElement)
Public Property | Margin | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MaxWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | MinHeight | (Inherited from System.Windows.FrameworkElement)
Public Property | MinWidth | (Inherited from System.Windows.FrameworkElement)
Public Property | Name | (Inherited from System.Windows.FrameworkElement)
Public Property | Opacity | (Inherited from System.Windows.UIElement)
Public Property | OpacityMask | (Inherited from System.Windows.UIElement)
Public Property | OverridesDefaultStyle | (Inherited from System.Windows.FrameworkElement)
Public Property | Padding | (Inherited from System.Windows.Controls.Control)
Public Property | PageOffset | Gets or sets the location of the page in the viewer.
Public Property | PagesBackColor | Public API for background color of report pane.
Public Property | Parent | (Inherited from System.Windows.FrameworkElement)
Public Property | PersistId | (Inherited from System.Windows.UIElement)
Public Property | PreviewPages | Pages to load. Pass value less or equal to 0 to load all Applicable only for loading from SectionReport or PageDocument instances
Public Property | PrintingSettings | Gets or sets printing settings
Public Property | RenderSize | (Inherited from System.Windows.UIElement)
Public Property | RenderTransform | (Inherited from System.Windows.UIElement)
Public Property | RenderTransformOrigin | (Inherited from System.Windows.UIElement)
Public Property | RepositionPage | Determines whether the viewer will reposition the view to the top of the page when a user goes to another page after scrolling downward in a page.
Public Property | Resources | (Inherited from System.Windows.FrameworkElement)
Public Property | ScrollbarEnabled | Public API. Show or hide scrolls within report pane.
Public Property | SearchResultsBackColor | Gets or sets the background color of the highlighted text when using the Viewer control's Find functionality.
Public Property | SearchResultsForeColor | Gets or sets the color of the highlighted text when using the Viewer control's Find functionality.
Public Property | Sidebar | Gets the sidebar component of the viewer control.
Public Property | SnapsToDevicePixels | (Inherited from System.Windows.UIElement)
Public Property | SplitView | Gets or sets a value that determines whether the viewer is split into two views.
Public Property | Style | (Inherited from System.Windows.FrameworkElement)
Public Property | TabIndex | (Inherited from System.Windows.Controls.Control)
Public Property | TableOfContents | Gets the table of contents panel component of sidebar component.
Public Property | Tag | (Inherited from System.Windows.FrameworkElement)
Public Property | TargetView | Gets or sets a value that specifies the current target view when SplitView is true.
Public Property | Template | (Inherited from System.Windows.Controls.Control)
Public Property | TemplatedParent | (Inherited from System.Windows.FrameworkElement)
Public Property | ToolTip | (Inherited from System.Windows.FrameworkElement)
Public Property | TouchesCaptured | (Inherited from System.Windows.UIElement)
Public Property | TouchesCapturedWithin | (Inherited from System.Windows.UIElement)
Public Property | TouchesDirectlyOver | (Inherited from System.Windows.UIElement)
Public Property | TouchesOver | (Inherited from System.Windows.UIElement)
Public Property | Triggers | (Inherited from System.Windows.FrameworkElement)
Public Property | Uid | (Inherited from System.Windows.UIElement)
Public Property | UseHyperlinkSettings | Gets or sets whether to apply the hyperlink settings when hyperlinks are displayed in the Viewer. For SectionReports only.
Public Property | UseLayoutRounding | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalAlignment | (Inherited from System.Windows.FrameworkElement)
Public Property | VerticalContentAlignment | (Inherited from System.Windows.Controls.Control)
Public Property | Visibility | (Inherited from System.Windows.UIElement)
Public Property | Width | (Inherited from System.Windows.FrameworkElement)
Public Property | Zoom | Gets or sets the viewer's zoom level. -1 for FitWidth mode -2 for Fit Whole Page mode. Throws ArgumentOutOfRangeException on invalid value.
Top
See Also

Reference

Viewer Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


AllowSplitter Property (Viewer)

AllowSplitter Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : AllowSplitter Property
Gets or sets a value that determines whether the user is allowed to split the view.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AllowSplitter As System.Boolean
public System.bool AllowSplitter {get; set;}
See Also

Reference

Viewer Class
Viewer Members


CanExport Property (Viewer)

CanExport Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : CanExport Property
Indicates whether the loaded report can be exported or not. Returns "false" if export is not permitted.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CanExport As System.Boolean
public System.bool CanExport {get;}
See Also

Reference

Viewer Class
Viewer Members


CurrentPage Property (Viewer)

CurrentPage Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : CurrentPage Property
Gets or sets the number of the current document page displayed in the viewer. 1 based. Returns 0 if no report is loaded. Affects History.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CurrentPage As System.Integer
public System.int CurrentPage {get; set;}
See Also

Reference

Viewer Class
Viewer Members


GalleyMode Property (Viewer)

GalleyMode Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : GalleyMode Property
Gets or sets GalleyMode of report
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GalleyMode As System.Boolean
public System.bool GalleyMode {get; set;}
See Also

Reference

Viewer Class
Viewer Members


History Property (Viewer)

History Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : History Property
Public API for history manipulation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property History As IHistoryApi
public IHistoryApi History {get;}
See Also

Reference

Viewer Class
Viewer Members


HyperlinkBackColor Property (Viewer)

HyperlinkBackColor Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : HyperlinkBackColor Property
Gets or sets the background color of the controls that hosts a hyperlink. The default is transparent. For SectionReports only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HyperlinkBackColor As System.Windows.Media.Color
public System.Windows.Media.Color HyperlinkBackColor {get; set;}
See Also

Reference

Viewer Class
Viewer Members


HyperlinkForeColor Property (Viewer)

HyperlinkForeColor Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : HyperlinkForeColor Property
Gets or sets the color of the text within a control that hosts a hyperlink. The default is Blue. For SectionReports only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HyperlinkForeColor As System.Windows.Media.Color
public System.Windows.Media.Color HyperlinkForeColor {get; set;}
See Also

Reference

Viewer Class
Viewer Members


HyperlinkUnderline Property (Viewer)

HyperlinkUnderline Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : HyperlinkUnderline Property
Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true. For SectionReports only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HyperlinkUnderline As System.Boolean
public System.bool HyperlinkUnderline {get; set;}
See Also

Reference

Viewer Class
Viewer Members


PageOffset Property (Viewer)

PageOffset Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PageOffset Property
Gets or sets the location of the page in the viewer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageOffset As System.Windows.Point
public System.Windows.Point PageOffset {get; set;}
See Also

Reference

Viewer Class
Viewer Members


PagesBackColor Property (Viewer)

PagesBackColor Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PagesBackColor Property
Public API for background color of report pane.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PagesBackColor As System.Windows.Media.Color
public System.Windows.Media.Color PagesBackColor {get; set;}
See Also

Reference

Viewer Class
Viewer Members


PreviewPages Property (Viewer)

PreviewPages Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewPages Property
Pages to load. Pass value less or equal to 0 to load all Applicable only for loading from SectionReport or PageDocument instances
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PreviewPages As System.Integer
public System.int PreviewPages {get; set;}
See Also

Reference

Viewer Class
Viewer Members


PrintingSettings Property (Viewer)

PrintingSettings Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PrintingSettings Property
Gets or sets printing settings
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrintingSettings As PrintingSettings
public PrintingSettings PrintingSettings {get; set;}
See Also

Reference

Viewer Class
Viewer Members


RepositionPage Property (Viewer)

RepositionPage Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : RepositionPage Property
Determines whether the viewer will reposition the view to the top of the page when a user goes to another page after scrolling downward in a page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RepositionPage As System.Boolean
public System.bool RepositionPage {get; set;}
See Also

Reference

Viewer Class
Viewer Members


ScrollbarEnabled Property (Viewer)

ScrollbarEnabled Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ScrollbarEnabled Property
Public API. Show or hide scrolls within report pane.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ScrollbarEnabled As System.Boolean
public System.bool ScrollbarEnabled {get; set;}
See Also

Reference

Viewer Class
Viewer Members


SearchResultsBackColor Property (Viewer)

SearchResultsBackColor Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SearchResultsBackColor Property
Gets or sets the background color of the highlighted text when using the Viewer control's Find functionality.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SearchResultsBackColor As System.Windows.Media.Color
public System.Windows.Media.Color SearchResultsBackColor {get; set;}
See Also

Reference

Viewer Class
Viewer Members


SearchResultsForeColor Property (Viewer)

SearchResultsForeColor Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SearchResultsForeColor Property
Gets or sets the color of the highlighted text when using the Viewer control's Find functionality.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SearchResultsForeColor As System.Windows.Media.Color
public System.Windows.Media.Color SearchResultsForeColor {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Sidebar Property (Viewer)

Sidebar Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Sidebar Property
Gets the sidebar component of the viewer control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Sidebar As Sidebar
public Sidebar Sidebar {get;}
See Also

Reference

Viewer Class
Viewer Members


SplitView Property (Viewer)

SplitView Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SplitView Property
Gets or sets a value that determines whether the viewer is split into two views.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SplitView As System.Boolean
public System.bool SplitView {get; set;}
See Also

Reference

Viewer Class
Viewer Members


TableOfContents Property (Viewer)

TableOfContents Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TableOfContents Property
Gets the table of contents panel component of sidebar component.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TableOfContents As TocPanel
public TocPanel TableOfContents {get;}
See Also

Reference

Viewer Class
Viewer Members


TargetView Property (Viewer)

TargetView Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TargetView Property
Gets or sets a value that specifies the current target view when SplitView is true.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TargetView As TargetView
public TargetView TargetView {get; set;}
See Also

Reference

Viewer Class
Viewer Members


UseHyperlinkSettings Property (Viewer)

UseHyperlinkSettings Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : UseHyperlinkSettings Property
Gets or sets whether to apply the hyperlink settings when hyperlinks are displayed in the Viewer. For SectionReports only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseHyperlinkSettings As System.Boolean
public System.bool UseHyperlinkSettings {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Zoom Property (Viewer)

Zoom Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Zoom Property
Gets or sets the viewer's zoom level. -1 for FitWidth mode -2 for Fit Whole Page mode. Throws ArgumentOutOfRangeException on invalid value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Zoom As System.Single
public System.float Zoom {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Viewer Class Fields

Viewer Class Fields

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Viewer Class

For a list of all members of this type, see Viewer members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | AllowSplitterProperty | Gets or sets a value that determines whether the user is allowed to split the view.
static (Shared in Visual Basic) | HyperlinkBackColorProperty | Gets or sets the background color of the controls that hosts a hyperlink. The default is transparent. For SectionReports only.
static (Shared in Visual Basic) | HyperlinkForeColorProperty | Gets or sets the color of the text within a control that hosts a hyperlink. The default is Blue. For SectionReports only.
static (Shared in Visual Basic) | HyperlinkUnderlineProperty | Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true. For SectionReports only.
static (Shared in Visual Basic) | PageOffsetProperty | Gets or sets the location of the page in the viewer.
static (Shared in Visual Basic) | PagesBackColorProperty | Public API for background color of report pane.
static (Shared in Visual Basic) | PreviewPagesProperty | Pages to load. Pass value less or equal to 0 to load all Applicable only for loading from SectionReport or PageDocument instances.
static (Shared in Visual Basic) | PrintingSettingsProperty | DesignPrintingSettings binding property
static (Shared in Visual Basic) | RepositionPageProperty | Determines whether the viewer will reposition the view to the top of the page when a user goes to another page after scrolling downward in a page.
static (Shared in Visual Basic) | ScrollbarEnabledProperty | Public API. Show or hide scrolls within report pane.
static (Shared in Visual Basic) | SearchResultsBackColorProperty | Gets or sets the background color of the highlighted text when using the Viewer control's Find functionality.
static (Shared in Visual Basic) | SearchResultsForeColorProperty | Gets or sets the color of the highlighted text when using the Viewer control's Find functionality.
static (Shared in Visual Basic) | SplitViewProperty | Gets or sets a value that determines whether the viewer is split into two views.
static (Shared in Visual Basic) | TargetViewProperty | Gets or sets a value that specifies the current target view when SplitView is true.
static (Shared in Visual Basic) | UseHyperlinkSettingsProperty | Gets or sets whether to apply the hyperlink settings when hyperlinks are displayed in the Viewer. For SectionReports only.
static (Shared in Visual Basic) | ZoomProperty | Gets or sets the viewer's zoom level. -1 for FitWidth mode -2 for Fit Whole Page mode. Throws ArgumentOutOfRangeException on invalid value.
Top
See Also

Reference

Viewer Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


AllowSplitterProperty Field

AllowSplitterProperty Field

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : AllowSplitterProperty Field
Gets or sets a value that determines whether the user is allowed to split the view.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly AllowSplitterProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty AllowSplitterProperty
See Also

Reference

Viewer Class
Viewer Members


HyperlinkBackColorProperty Field

HyperlinkBackColorProperty Field

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : HyperlinkBackColorProperty Field
Gets or sets the background color of the controls that hosts a hyperlink. The default is transparent. For SectionReports only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly HyperlinkBackColorProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty HyperlinkBackColorProperty
See Also

Reference

Viewer Class
Viewer Members


HyperlinkForeColorProperty Field

HyperlinkForeColorProperty Field

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : HyperlinkForeColorProperty Field
Gets or sets the color of the text within a control that hosts a hyperlink. The default is Blue. For SectionReports only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly HyperlinkForeColorProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty HyperlinkForeColorProperty
See Also

Reference

Viewer Class
Viewer Members


HyperlinkUnderlineProperty Field

HyperlinkUnderlineProperty Field

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : HyperlinkUnderlineProperty Field
Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true. For SectionReports only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly HyperlinkUnderlineProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty HyperlinkUnderlineProperty
See Also

Reference

Viewer Class
Viewer Members


PageOffsetProperty Field

PageOffsetProperty Field

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PageOffsetProperty Field
Gets or sets the location of the page in the viewer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly PageOffsetProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty PageOffsetProperty
See Also

Reference

Viewer Class
Viewer Members


PagesBackColorProperty Field

PagesBackColorProperty Field

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PagesBackColorProperty Field
Public API for background color of report pane.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly PagesBackColorProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty PagesBackColorProperty
See Also

Reference

Viewer Class
Viewer Members


PreviewPagesProperty Field

PreviewPagesProperty Field

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewPagesProperty Field
Pages to load. Pass value less or equal to 0 to load all Applicable only for loading from SectionReport or PageDocument instances.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly PreviewPagesProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty PreviewPagesProperty
See Also

Reference

Viewer Class
Viewer Members


PrintingSettingsProperty Field

PrintingSettingsProperty Field

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PrintingSettingsProperty Field
DesignPrintingSettings binding property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly PrintingSettingsProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty PrintingSettingsProperty
See Also

Reference

Viewer Class
Viewer Members


RepositionPageProperty Field

RepositionPageProperty Field

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : RepositionPageProperty Field
Determines whether the viewer will reposition the view to the top of the page when a user goes to another page after scrolling downward in a page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly RepositionPageProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty RepositionPageProperty
See Also

Reference

Viewer Class
Viewer Members


ScrollbarEnabledProperty Field

ScrollbarEnabledProperty Field

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ScrollbarEnabledProperty Field
Public API. Show or hide scrolls within report pane.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly ScrollbarEnabledProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty ScrollbarEnabledProperty
See Also

Reference

Viewer Class
Viewer Members


SearchResultsBackColorProperty Field

SearchResultsBackColorProperty Field

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SearchResultsBackColorProperty Field
Gets or sets the background color of the highlighted text when using the Viewer control's Find functionality.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly SearchResultsBackColorProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty SearchResultsBackColorProperty
See Also

Reference

Viewer Class
Viewer Members


SearchResultsForeColorProperty Field

SearchResultsForeColorProperty Field

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SearchResultsForeColorProperty Field
Gets or sets the color of the highlighted text when using the Viewer control's Find functionality.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly SearchResultsForeColorProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty SearchResultsForeColorProperty
See Also

Reference

Viewer Class
Viewer Members


SplitViewProperty Field

SplitViewProperty Field

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SplitViewProperty Field
Gets or sets a value that determines whether the viewer is split into two views.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly SplitViewProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty SplitViewProperty
See Also

Reference

Viewer Class
Viewer Members


TargetViewProperty Field

TargetViewProperty Field

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TargetViewProperty Field
Gets or sets a value that specifies the current target view when SplitView is true.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly TargetViewProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty TargetViewProperty
See Also

Reference

Viewer Class
Viewer Members


UseHyperlinkSettingsProperty Field

UseHyperlinkSettingsProperty Field

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : UseHyperlinkSettingsProperty Field
Gets or sets whether to apply the hyperlink settings when hyperlinks are displayed in the Viewer. For SectionReports only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly UseHyperlinkSettingsProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty UseHyperlinkSettingsProperty
See Also

Reference

Viewer Class
Viewer Members


ZoomProperty Field

ZoomProperty Field

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ZoomProperty Field
Gets or sets the viewer's zoom level. -1 for FitWidth mode -2 for Fit Whole Page mode. Throws ArgumentOutOfRangeException on invalid value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly ZoomProperty As System.Windows.DependencyProperty
public static readonly System.Windows.DependencyProperty ZoomProperty
See Also

Reference

Viewer Class
Viewer Members


Viewer Class Events

Viewer Class Events

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Viewer Class

For a list of all members of this type, see Viewer members.

Public Events
 | Name | Description
Public Event | Action | This event fires when report item with specified action was clicked in the report preview control.
Public Event | ContextMenuClosing | (Inherited from System.Windows.FrameworkElement)
Public Event | ContextMenuOpening | (Inherited from System.Windows.FrameworkElement)
Public Event | DataContextChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | DragEnter | (Inherited from System.Windows.UIElement)
Public Event | DragLeave | (Inherited from System.Windows.UIElement)
Public Event | DragOver | (Inherited from System.Windows.UIElement)
Public Event | Drop | (Inherited from System.Windows.UIElement)
Public Event | FocusableChanged | (Inherited from System.Windows.UIElement)
Public Event | GiveFeedback | (Inherited from System.Windows.UIElement)
Public Event | GotFocus | (Inherited from System.Windows.UIElement)
Public Event | GotKeyboardFocus | (Inherited from System.Windows.UIElement)
Public Event | GotMouseCapture | (Inherited from System.Windows.UIElement)
Public Event | GotStylusCapture | (Inherited from System.Windows.UIElement)
Public Event | GotTouchCapture | (Inherited from System.Windows.UIElement)
Public Event | HyperLink | Occurs when the user clicks on text or an image that has a hyperlink assigned to it.
Public Event | Initialized | (Inherited from System.Windows.FrameworkElement)
Public Event | IsEnabledChanged | (Inherited from System.Windows.UIElement)
Public Event | IsHitTestVisibleChanged | (Inherited from System.Windows.UIElement)
Public Event | IsKeyboardFocusedChanged | (Inherited from System.Windows.UIElement)
Public Event | IsKeyboardFocusWithinChanged | (Inherited from System.Windows.UIElement)
Public Event | IsMouseCapturedChanged | (Inherited from System.Windows.UIElement)
Public Event | IsMouseCaptureWithinChanged | (Inherited from System.Windows.UIElement)
Public Event | IsMouseDirectlyOverChanged | (Inherited from System.Windows.UIElement)
Public Event | IsStylusCapturedChanged | (Inherited from System.Windows.UIElement)
Public Event | IsStylusCaptureWithinChanged | (Inherited from System.Windows.UIElement)
Public Event | IsStylusDirectlyOverChanged | (Inherited from System.Windows.UIElement)
Public Event | IsVisibleChanged | (Inherited from System.Windows.UIElement)
Public Event | KeyDown | (Inherited from System.Windows.UIElement)
Public Event | KeyUp | (Inherited from System.Windows.UIElement)
Public Event | LayoutUpdated | (Inherited from System.Windows.UIElement)
Public Event | LoadCompleted | Occurs after all the viewer pages have been fully loaded.
Public Event | Loaded | (Inherited from System.Windows.FrameworkElement)
Public Event | LocateCredentials | Fires when the PageReport to view generates LocateCredentials event.
Public Event | LocateDataSource | Fires when the PageReport to view generates LocateDataSource event.
Public Event | LostFocus | (Inherited from System.Windows.UIElement)
Public Event | LostKeyboardFocus | (Inherited from System.Windows.UIElement)
Public Event | LostMouseCapture | (Inherited from System.Windows.UIElement)
Public Event | LostStylusCapture | (Inherited from System.Windows.UIElement)
Public Event | LostTouchCapture | (Inherited from System.Windows.UIElement)
Public Event | ManipulationBoundaryFeedback | (Inherited from System.Windows.UIElement)
Public Event | ManipulationCompleted | (Inherited from System.Windows.UIElement)
Public Event | ManipulationDelta | (Inherited from System.Windows.UIElement)
Public Event | ManipulationInertiaStarting | (Inherited from System.Windows.UIElement)
Public Event | ManipulationStarted | (Inherited from System.Windows.UIElement)
Public Event | ManipulationStarting | (Inherited from System.Windows.UIElement)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Controls.Control)
Public Event | MouseDown | (Inherited from System.Windows.UIElement)
Public Event | MouseEnter | (Inherited from System.Windows.UIElement)
Public Event | MouseLeave | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseMove | (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonDown | (Inherited from System.Windows.UIElement)
Public Event | MouseRightButtonUp | (Inherited from System.Windows.UIElement)
Public Event | MouseUp | (Inherited from System.Windows.UIElement)
Public Event | MouseWheel | (Inherited from System.Windows.UIElement)
Public Event | PreviewDragEnter | (Inherited from System.Windows.UIElement)
Public Event | PreviewDragLeave | (Inherited from System.Windows.UIElement)
Public Event | PreviewDragOver | (Inherited from System.Windows.UIElement)
Public Event | PreviewDrop | (Inherited from System.Windows.UIElement)
Public Event | PreviewGiveFeedback | (Inherited from System.Windows.UIElement)
Public Event | PreviewGotKeyboardFocus | (Inherited from System.Windows.UIElement)
Public Event | PreviewKeyDown | (Inherited from System.Windows.UIElement)
Public Event | PreviewKeyUp | (Inherited from System.Windows.UIElement)
Public Event | PreviewLostKeyboardFocus | (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseDoubleClick | (Inherited from System.Windows.Controls.Control)
Public Event | PreviewMouseDown | (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseLeftButtonDown | (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseLeftButtonUp | (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseMove | (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseRightButtonDown | (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseRightButtonUp | (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseUp | (Inherited from System.Windows.UIElement)
Public Event | PreviewMouseWheel | (Inherited from System.Windows.UIElement)
Public Event | PreviewQueryContinueDrag | (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusButtonDown | (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusButtonUp | (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusDown | (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusInAirMove | (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusInRange | (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusMove | (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusOutOfRange | (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusSystemGesture | (Inherited from System.Windows.UIElement)
Public Event | PreviewStylusUp | (Inherited from System.Windows.UIElement)
Public Event | PreviewTextInput | (Inherited from System.Windows.UIElement)
Public Event | PreviewTouchDown | (Inherited from System.Windows.UIElement)
Public Event | PreviewTouchMove | (Inherited from System.Windows.UIElement)
Public Event | PreviewTouchUp | (Inherited from System.Windows.UIElement)
Public Event | QueryContinueDrag | (Inherited from System.Windows.UIElement)
Public Event | QueryCursor | (Inherited from System.Windows.UIElement)
Public Event | RequestBringIntoView | (Inherited from System.Windows.FrameworkElement)
Public Event | SizeChanged | (Inherited from System.Windows.FrameworkElement)
Public Event | SourceUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | StylusButtonDown | (Inherited from System.Windows.UIElement)
Public Event | StylusButtonUp | (Inherited from System.Windows.UIElement)
Public Event | StylusDown | (Inherited from System.Windows.UIElement)
Public Event | StylusEnter | (Inherited from System.Windows.UIElement)
Public Event | StylusInAirMove | (Inherited from System.Windows.UIElement)
Public Event | StylusInRange | (Inherited from System.Windows.UIElement)
Public Event | StylusLeave | (Inherited from System.Windows.UIElement)
Public Event | StylusMove | (Inherited from System.Windows.UIElement)
Public Event | StylusOutOfRange | (Inherited from System.Windows.UIElement)
Public Event | StylusSystemGesture | (Inherited from System.Windows.UIElement)
Public Event | StylusUp | (Inherited from System.Windows.UIElement)
Public Event | TargetUpdated | (Inherited from System.Windows.FrameworkElement)
Public Event | TextInput | (Inherited from System.Windows.UIElement)
Public Event | ToolTipClosing | (Inherited from System.Windows.FrameworkElement)
Public Event | ToolTipOpening | (Inherited from System.Windows.FrameworkElement)
Public Event | TouchDown | (Inherited from System.Windows.UIElement)
Public Event | TouchEnter | (Inherited from System.Windows.UIElement)
Public Event | TouchLeave | (Inherited from System.Windows.UIElement)
Public Event | TouchMove | (Inherited from System.Windows.UIElement)
Public Event | TouchUp | (Inherited from System.Windows.UIElement)
Public Event | Unloaded | (Inherited from System.Windows.FrameworkElement)
Top
See Also

Reference

Viewer Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Action Event (Viewer)

Action Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Action Event
This event fires when report item with specified action was clicked in the report preview control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Action As System.EventHandler(Of Viewer.ActionEventArgs)
public event System.EventHandler<Viewer.ActionEventArgs> Action
Event Data

The event handler receives an argument of type Viewer.ActionEventArgs containing data related to this event. The following Viewer.ActionEventArgs properties provide information specific to this event.

Property | Description
Action | Gets the Action that caused the event.
Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
PageNumber | Gets the page number the action happened on.
See Also

Reference

Viewer Class
Viewer Members


HyperLink Event (Viewer)

HyperLink Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : HyperLink Event
Occurs when the user clicks on text or an image that has a hyperlink assigned to it.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event HyperLink As HyperLinkEventHandler
public event HyperLinkEventHandler HyperLink
Event Data

The event handler receives an argument of type HyperLinkEventArgs containing data related to this event. The following HyperLinkEventArgs properties provide information specific to this event.

Property | Description
Button | Gets the mouse button that the user clicked to raise the event.
CreateNewTab | Gets or sets a value indicating whether a new tab has been created.
Handled | Sets or returns a value indicating whether the HyperLinkEvent is handled.
HyperLink | Gets the hyperlink target.
See Also

Reference

Viewer Class
Viewer Members


LoadCompleted Event (Viewer)

LoadCompleted Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : LoadCompleted Event
Occurs after all the viewer pages have been fully loaded.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LoadCompleted As LoadCompletedEventHandler
public event LoadCompletedEventHandler LoadCompleted
See Also

Reference

Viewer Class
Viewer Members


LocateCredentials Event (Viewer)

LocateCredentials Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : LocateCredentials Event
Fires when the PageReport to view generates LocateCredentials event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LocateCredentials As LocateCredentialsEventHandler
public event LocateCredentialsEventHandler LocateCredentials
Event Data

The event handler receives an argument of type LocateCredentialsEventArgs containing data related to this event. The following LocateCredentialsEventArgs properties provide information specific to this event.

Property | Description
DataSourceName | Gets the name of the data source to locate credentials for.
Password | Gets ot sets the password of the credentials to be located.
PromptText | Gets the text of prompt of the locate credentials request.
ReportPath | Gets the name of the report to locate credentials for.
UserName | Gets ot sets the user name of the credentials to be located.
See Also

Reference

Viewer Class
Viewer Members


LocateDataSource Event (Viewer)

LocateDataSource Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : LocateDataSource Event
Fires when the PageReport to view generates LocateDataSource event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LocateDataSource As LocateDataSourceEventHandler
public event LocateDataSourceEventHandler LocateDataSource
Event Data

The event handler receives an argument of type LocateDataSourceEventArgs containing data related to this event. The following LocateDataSourceEventArgs properties provide information specific to this event.

Property | Description
Data | The data returned by the event handler.
DataSetName | Gets the name of data set to be located.
DataSourceName | Gets the name of data source that contains the data set to be located.
Report | Gets the Report that is trying to locate the data set.
See Also

Reference

Viewer Class
Viewer Members


Viewer.ActionEventArgs Class

Viewer.ActionEventArgs Class
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Viewer.ActionEventArgs Class
Provides data for Action event.
Object Model
Viewer.ActionEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Viewer.ActionEventArgs
   Inherits System.ComponentModel.CancelEventArgs
public class Viewer.ActionEventArgs : System.ComponentModel.CancelEventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
GrapeCity.ActiveReports.Viewer.Wpf.Viewer.ActionEventArgs

See Also

Reference

Viewer.ActionEventArgs Members
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Viewer.ActionEventArgs Class Members

Viewer.ActionEventArgs Class Members
Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Viewer.ActionEventArgs Class

The following tables list the members exposed by Viewer.ActionEventArgs.

Public Constructors
 | Name | Description
Public Constructor | Viewer.ActionEventArgs Constructor | Initializes the new instance of ActionEventArgs class.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets the Action that caused the event.
Public Property | Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | PageNumber | Gets the page number the action happened on.
Top
See Also

Reference

Viewer.ActionEventArgs Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Viewer.ActionEventArgs Constructor()

Viewer.ActionEventArgs Constructor()

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer.ActionEventArgs Class > Viewer.ActionEventArgs Constructor : Viewer.ActionEventArgs Constructor()
Initializes the new instance of ActionEventArgs class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public Viewer.ActionEventArgs()
See Also

Reference

Viewer.ActionEventArgs Class
Viewer.ActionEventArgs Members
Overload List


Viewer.ActionEventArgs Class Properties

Viewer.ActionEventArgs Class Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : Viewer.ActionEventArgs Class

For a list of all members of this type, see Viewer.ActionEventArgs members.

Public Properties
 | Name | Description
Public Property | Action | Gets the Action that caused the event.
Public Property | Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | PageNumber | Gets the page number the action happened on.
Top
See Also

Reference

Viewer.ActionEventArgs Class
GrapeCity.ActiveReports.Viewer.Wpf Namespace


Action Property (Viewer.ActionEventArgs)

Action Property (Viewer.ActionEventArgs)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer.ActionEventArgs Class : Action Property
Gets the Action that caused the event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Action As IAction
public IAction Action {get;}

Property Value

The action.
See Also

Reference

Viewer.ActionEventArgs Class
Viewer.ActionEventArgs Members


PageNumber Property (Viewer.ActionEventArgs)

PageNumber Property (Viewer.ActionEventArgs)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer.ActionEventArgs Class : PageNumber Property
Gets the page number the action happened on.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PageNumber As System.Integer
public System.int PageNumber {get;}

Property Value

The page number.
See Also

Reference

Viewer.ActionEventArgs Class
Viewer.ActionEventArgs Members


TargetView Enumeration

TargetView Enumeration

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace : TargetView Enumeration
Determines the current active view in the viewer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TargetView
   Inherits System.Enum
public enum TargetView : System.Enum
Members
Member | Description
Primary | The primary (Bottom) view is the active view.
Secondary | The secondary (Upper) view is the active view.
Remarks
The viewer can be split into two views using the splitter. This enumeration determines which view will be effected by methods and property calls.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Viewer.Wpf.TargetView

See Also

Reference

GrapeCity.ActiveReports.Viewer.Wpf Namespace


GrapeCity.Viewer.Common Namespace (GrapeCity.ActiveReports.Viewer.Wpf.v10)

GrapeCity.Viewer.Common Namespace (GrapeCity.ActiveReports.Viewer.Wpf.v10)
Inheritance Hierarchy
GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly : GrapeCity.Viewer.Common Namespace
The GrapeCity.Viewer.Common Namespace contains the IHistoryApi interface.
Classes
 | Class | Description
Class | CachedPageView | Base class for page views with caching
Class | DelegateCommand | Parameterless command delegate
Class | DelegateCommand<TParm> | DelegateCommand implementation
Class | DisposablesCollection | Utility class to redirect Dispose call to its inner items
Class | DocumentRendererAttribute | Allows to specified document renderer type for class.
Class | DocumentSearchService | Search service implementation for ISearchableDocument
Class | DoubleDelegateCommand | Command that delegates implementation to another delegate command
Class | EnumerableExtensions |
Class | NotifyCollectionChangedEventArgs | Describes the action that caused a System.Collections.Specialized.INotifyCollectionChanged.CollectionChanged event.
Class | NullDelegateCommand |
Class | NullRenderer | Null-object implementation for IDocumentRenderer interface
Class | NullRenderer.Factory | IDocumentRenderer factory.
Class | ObservableCollection<T> | Wrapped System.Collections.ObjectModel observable collection
Class | PageView | Base abstract class for concrete page renderers.
Class | RectExtensions | Extends Rect struct with helper methods.
Class | StreamDocumentLoader |
Interfaces
 | Interface | Description
Interface | IApplicationContext | Provides access to different services and factories
Interface | ICommand | Defines the contract for commanding, using the same contract as used in WPF.
Interface | ICopySelectionService | Base interface for copy operations
Interface | IDelegateCommand | Delegated command interface
Interface | IDocumentLoader |
Interface | IDocumentRenderer | Base interface for Document renderers
Interface | IDocumentRendererFactory | IDocumentRenderer factory interface.
Interface | IHistoryApi | This is public interface for user to work with HistoryService.
Interface | ILoadableFromFileAndStream |
Interface | INotifyCollectionChanged | Notifies listeners of dynamic changes to a collection, such as when items are added and removed, or the entire collection object is reset.
Interface | IOrientedPageView | Interface to access orientation of the report page.
Interface | IParameter | Defines an object that can be used as a report parameter.
Interface | IPrintService |
Interface | IRasteredPageView |
Interface | IRasteredRenderer | Interface for rastered document renderer
Interface | ISearchService | Base interface for search
Interface | IServiceContainer | Provides a container for services.
Structures
 | Structure | Description
Structure | Color | Platform independent color implementation
Structure | Margin | Stores page margins
Structure | Point | Platform independent point
Structure | Rect | Platform aware rectangle structure
Structure | Size | Platform aware Size structure
Delegates
 | Delegate | Description
Delegate | NotifyCollectionChangedEventHandler | Represents the method that handles events that implement the System.Collections.Specialized.INotifyCollectionChanged.CollectionChanged event.
Enumerations
 | Enumeration | Description
Enumeration | DeviceKind | Defines enumeration of possible target devices for view.
Enumeration | DocumentFormat | Specifies possible document formats
Enumeration | LoadState | Possible loading states
Enumeration | NotifyCollectionChangedAction | Enum NotifyCollectionChangedAction
Enumeration | PrintingSettings | Print process settings
See Also

Reference

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly


CachedPageView Class

CachedPageView Class
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : CachedPageView Class
Base class for page views with caching
Object Model
CachedPageView Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class CachedPageView
   Inherits PageView
public abstract class CachedPageView : PageView
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.CachedPageView

See Also

Reference

CachedPageView Members
GrapeCity.Viewer.Common Namespace


CachedPageView Class Members

CachedPageView Class Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : CachedPageView Class

The following tables list the members exposed by CachedPageView.

Public Properties
 | Name | Description
Public Property | Device | Gets the device kind. (Inherited from GrapeCity.Viewer.Common.PageView)
Public Property | Size | Gets the page view size. (Inherited from GrapeCity.Viewer.Common.PageView)
Top
Public Methods
 | Name | Description
Public Method | AsCachable | Convert to CachedPageView. (Inherited from GrapeCity.Viewer.Common.PageView)
Public Method | Dispose |
Top
See Also

Reference

CachedPageView Class
GrapeCity.Viewer.Common Namespace


CachedPageView Class Methods

CachedPageView Class Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : CachedPageView Class

For a list of all members of this type, see CachedPageView members.

Public Methods
 | Name | Description
Public Method | AsCachable | Convert to CachedPageView. (Inherited from GrapeCity.Viewer.Common.PageView)
Public Method | Dispose |
Top
See Also

Reference

CachedPageView Class
GrapeCity.Viewer.Common Namespace


Dispose Method (CachedPageView)

Dispose Method (CachedPageView)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > CachedPageView Class : Dispose Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Sub Dispose()
public abstract void Dispose()
See Also

Reference

CachedPageView Class
CachedPageView Members


DelegateCommand Class

DelegateCommand Class
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand Class
Parameterless command delegate
Object Model
DelegateCommand Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DelegateCommand
   Inherits GrapeCity.Viewer.Common.DelegateCommand(Of Object)
   Implements ICommand, IDelegateCommand
public sealed class DelegateCommand : GrapeCity.Viewer.Common.DelegateCommand<object>, ICommand, IDelegateCommand
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.DelegateCommand

See Also

Reference

DelegateCommand Members
GrapeCity.Viewer.Common Namespace


DelegateCommand Class Members

DelegateCommand Class Members
Fields Methods Events

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand Class

The following tables list the members exposed by DelegateCommand.

Public Constructors
 | Name | Description
Public Constructor | DelegateCommand Constructor | Overloaded.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | NullCommand | Gets "Null" command instance which does nothing and is always disabled
Top
Public Methods
 | Name | Description
Public Method | CanExecute | Defines the method that determines whether the command can execute in its current state. (Inherited from GrapeCity.Viewer.Common.DelegateCommand<object>)
Public Method | Execute | Defines the method to be called when the command is invoked. (Inherited from GrapeCity.Viewer.Common.DelegateCommand<object>)
Public Method | RaiseCanExecuteChanged | Raise CanExecuteChanged event from external code. (Inherited from GrapeCity.Viewer.Common.DelegateCommand<object>)
Top
Public Events
 | Name | Description
Public Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute. (Inherited from GrapeCity.Viewer.Common.DelegateCommand<object>)
Top
See Also

Reference

DelegateCommand Class
GrapeCity.Viewer.Common Namespace


DelegateCommand Constructor

DelegateCommand Constructor

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand Class : DelegateCommand Constructor
Overload List
Overload | Description
DelegateCommand Constructor(Action,Func<Boolean>) |
DelegateCommand Constructor(Action) |
See Also

Reference

DelegateCommand Class
DelegateCommand Members


DelegateCommand Constructor(Action,Func<Boolean>)

DelegateCommand Constructor(Action,Func<Boolean>)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand Class > DelegateCommand Constructor : DelegateCommand Constructor(Action,Func<Boolean>)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal executeAction As System.Action, _
   ByVal canExecute As System.Func(Of Boolean) _
)
public DelegateCommand(
   System.Action executeAction,
   System.Func<bool> canExecute
)

Parameters

executeAction
canExecute
See Also

Reference

DelegateCommand Class
DelegateCommand Members
Overload List


DelegateCommand Constructor(Action)

DelegateCommand Constructor(Action)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand Class > DelegateCommand Constructor : DelegateCommand Constructor(Action)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal executeAction As System.Action _
)
public DelegateCommand(
   System.Action executeAction
)

Parameters

executeAction
See Also

Reference

DelegateCommand Class
DelegateCommand Members
Overload List


DelegateCommand Class Fields

DelegateCommand Class Fields

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand Class

For a list of all members of this type, see DelegateCommand members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | NullCommand | Gets "Null" command instance which does nothing and is always disabled
Top
See Also

Reference

DelegateCommand Class
GrapeCity.Viewer.Common Namespace


NullCommand Field (DelegateCommand)

NullCommand Field (DelegateCommand)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand Class : NullCommand Field
Gets "Null" command instance which does nothing and is always disabled
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly NullCommand As IDelegateCommand
public static readonly IDelegateCommand NullCommand
See Also

Reference

DelegateCommand Class
DelegateCommand Members


DelegateCommand<TParm> Class

DelegateCommand<TParm> Class
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand<TParm> Class
DelegateCommand implementation
Object Model
DelegateCommand<TParm> Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DelegateCommand(Of TParm)
   Implements ICommand, IDelegateCommand
public class DelegateCommand<TParm> : ICommand, IDelegateCommand
Type Parameters
TParm
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.DelegateCommand<TParm>

See Also

Reference

DelegateCommand<TParm> Members
GrapeCity.Viewer.Common Namespace


DelegateCommand<TParm> Class Members

DelegateCommand<TParm> Class Members
Methods Events

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand<TParm> Class

The following tables list the members exposed by DelegateCommand<TParm>.

Public Constructors
 | Name | Description
Public Constructor | DelegateCommand<TParm> Constructor | Overloaded.
Top
Public Methods
 | Name | Description
Public Method | CanExecute | Defines the method that determines whether the command can execute in its current state.
Public Method | Execute | Defines the method to be called when the command is invoked.
Public Method | RaiseCanExecuteChanged | Raise CanExecuteChanged event from external code.
Top
Public Events
 | Name | Description
Public Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute.
Top
See Also

Reference

DelegateCommand<TParm> Class
GrapeCity.Viewer.Common Namespace


DelegateCommand<TParm> Constructor

DelegateCommand<TParm> Constructor

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand<TParm> Class : DelegateCommand<TParm> Constructor
Overload List
Overload | Description
DelegateCommand<TParm> Constructor(Action<TParm>,Predicate<TParm>) | Initializes a new instance of the DelegateCommand<TParm> class.
DelegateCommand<TParm> Constructor(Action<TParm>) | Initializes a new instance of the DelegateCommand<TParm> class.
See Also

Reference

DelegateCommand<TParm> Class
DelegateCommand<TParm> Members


DelegateCommand<TParm> Constructor(Action<TParm>,Predicate<TParm>)

DelegateCommand<TParm> Constructor(Action<TParm>,Predicate<TParm>)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand<TParm> Class > DelegateCommand<TParm> Constructor : DelegateCommand<TParm> Constructor(Action<TParm>,Predicate<TParm>)
Initializes a new instance of the DelegateCommand<TParm> class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal executeAction As System.Action(Of TParm), _
   ByVal canExecute As System.Predicate(Of TParm) _
)
public DelegateCommand<TParm>(
   System.Action<TParm> executeAction,
   System.Predicate<TParm> canExecute
)

Parameters

executeAction
canExecute
See Also

Reference

DelegateCommand<TParm> Class
DelegateCommand<TParm> Members
Overload List


DelegateCommand<TParm> Constructor(Action<TParm>)

DelegateCommand<TParm> Constructor(Action<TParm>)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand<TParm> Class > DelegateCommand<TParm> Constructor : DelegateCommand<TParm> Constructor(Action<TParm>)
Initializes a new instance of the DelegateCommand<TParm> class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal executeAction As System.Action(Of TParm) _
)
public DelegateCommand<TParm>(
   System.Action<TParm> executeAction
)

Parameters

executeAction
See Also

Reference

DelegateCommand<TParm> Class
DelegateCommand<TParm> Members
Overload List


DelegateCommand<TParm> Class Methods

DelegateCommand<TParm> Class Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand<TParm> Class

For a list of all members of this type, see DelegateCommand<TParm> members.

Public Methods
 | Name | Description
Public Method | CanExecute | Defines the method that determines whether the command can execute in its current state.
Public Method | Execute | Defines the method to be called when the command is invoked.
Public Method | RaiseCanExecuteChanged | Raise CanExecuteChanged event from external code.
Top
See Also

Reference

DelegateCommand<TParm> Class
GrapeCity.Viewer.Common Namespace


CanExecute Method (DelegateCommand<TParm>)

CanExecute Method (DelegateCommand<TParm>)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand<TParm> Class : CanExecute Method
Data used by the command. If the command does not require data to be passed, this object can be set to null.
Defines the method that determines whether the command can execute in its current state.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CanExecute( _
   ByVal parameter As System.Object _
) As System.Boolean
public System.bool CanExecute(
   System.object parameter
)

Parameters

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.

Return Value

true if this instance can execute the specified parameter; otherwise, false.
See Also

Reference

DelegateCommand<TParm> Class
DelegateCommand<TParm> Members


Execute Method (DelegateCommand<TParm>)

Execute Method (DelegateCommand<TParm>)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand<TParm> Class : Execute Method
Data used by the command. If the command does not require data to be passed, this object can be set to null.
Defines the method to be called when the command is invoked.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Execute( _
   ByVal parameter As System.Object _
)
public void Execute(
   System.object parameter
)

Parameters

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.
See Also

Reference

DelegateCommand<TParm> Class
DelegateCommand<TParm> Members


RaiseCanExecuteChanged Method (DelegateCommand<TParm>)

RaiseCanExecuteChanged Method (DelegateCommand<TParm>)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand<TParm> Class : RaiseCanExecuteChanged Method
Raise CanExecuteChanged event from external code.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RaiseCanExecuteChanged()
public void RaiseCanExecuteChanged()
See Also

Reference

DelegateCommand<TParm> Class
DelegateCommand<TParm> Members


DelegateCommand<TParm> Class Events

DelegateCommand<TParm> Class Events

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand<TParm> Class

For a list of all members of this type, see DelegateCommand<TParm> members.

Public Events
 | Name | Description
Public Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute.
Top
See Also

Reference

DelegateCommand<TParm> Class
GrapeCity.Viewer.Common Namespace


CanExecuteChanged Event (DelegateCommand<TParm>)

CanExecuteChanged Event (DelegateCommand<TParm>)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DelegateCommand<TParm> Class : CanExecuteChanged Event
Occurs when changes occur that affect whether the command should execute.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event CanExecuteChanged As System.EventHandler
public event System.EventHandler CanExecuteChanged
See Also

Reference

DelegateCommand<TParm> Class
DelegateCommand<TParm> Members


DisposablesCollection Class

DisposablesCollection Class
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DisposablesCollection Class
Utility class to redirect Dispose call to its inner items
Object Model
DisposablesCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DisposablesCollection
public sealed class DisposablesCollection
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.DisposablesCollection

See Also

Reference

DisposablesCollection Members
GrapeCity.Viewer.Common Namespace


DisposablesCollection Class Members

DisposablesCollection Class Members
Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DisposablesCollection Class

The following tables list the members exposed by DisposablesCollection.

Public Constructors
 | Name | Description
Public Constructor | DisposablesCollection Constructor |
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Registers object to be disposed on this collection disposal
Public Method | Dispose |
static (Shared in Visual Basic) | From | Overloaded. Initialized new collection for another list of disposables
Top
See Also

Reference

DisposablesCollection Class
GrapeCity.Viewer.Common Namespace


DisposablesCollection Constructor

DisposablesCollection Constructor

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class : DisposablesCollection Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DisposablesCollection()
See Also

Reference

DisposablesCollection Class
DisposablesCollection Members


DisposablesCollection Class Methods

DisposablesCollection Class Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DisposablesCollection Class

For a list of all members of this type, see DisposablesCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Registers object to be disposed on this collection disposal
Public Method | Dispose |
static (Shared in Visual Basic) | From | Overloaded. Initialized new collection for another list of disposables
Top
See Also

Reference

DisposablesCollection Class
GrapeCity.Viewer.Common Namespace


Add Method (DisposablesCollection)

Add Method (DisposablesCollection)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class : Add Method
Registers object to be disposed on this collection disposal
Overload List
Overload | Description
Add(IDisposable[]) | Registers object to be disposed on this collection disposal
Add(IDisposable) | Registers action to be invoked on object dispose
Add(Action[]) | Registers action to be invoked on object dispose
See Also

Reference

DisposablesCollection Class
DisposablesCollection Members


Add(IDisposable[]) Method

Add(IDisposable[]) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class > Add Method : Add(IDisposable[]) Method
Registers object to be disposed on this collection disposal
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal ParamArray disposables() As System.IDisposable _
)
public void Add(
   params System.IDisposable[] disposables
)

Parameters

disposables
See Also

Reference

DisposablesCollection Class
DisposablesCollection Members
Overload List


Add(IDisposable) Method

Add(IDisposable) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class > Add Method : Add(IDisposable) Method
Registers action to be invoked on object dispose
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal disposable As System.IDisposable _
)
public void Add(
   System.IDisposable disposable
)

Parameters

disposable
See Also

Reference

DisposablesCollection Class
DisposablesCollection Members
Overload List


Add(Action[]) Method

Add(Action[]) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class > Add Method : Add(Action[]) Method
Registers action to be invoked on object dispose
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal ParamArray disposables() As System.Action _
)
public void Add(
   params System.Action[] disposables
)

Parameters

disposables
See Also

Reference

DisposablesCollection Class
DisposablesCollection Members
Overload List


Dispose Method (DisposablesCollection)

Dispose Method (DisposablesCollection)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class : Dispose Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

DisposablesCollection Class
DisposablesCollection Members


From Method (DisposablesCollection)

From Method (DisposablesCollection)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class : From Method
Initialized new collection for another list of disposables
Overload List
Overload | Description
From(IDisposable[]) | Initialized new collection for another list of disposables
From(Action[]) | Initialized new collection for another list of actions
See Also

Reference

DisposablesCollection Class
DisposablesCollection Members


From(IDisposable[]) Method

From(IDisposable[]) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class > From Method : From(IDisposable[]) Method
Initialized new collection for another list of disposables
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function From( _
   ByVal ParamArray disposables() As System.IDisposable _
) As DisposablesCollection
public static DisposablesCollection From(
   params System.IDisposable[] disposables
)

Parameters

disposables
See Also

Reference

DisposablesCollection Class
DisposablesCollection Members
Overload List


From(Action[]) Method

From(Action[]) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DisposablesCollection Class > From Method : From(Action[]) Method
Initialized new collection for another list of actions
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function From( _
   ByVal ParamArray actions() As System.Action _
) As DisposablesCollection
public static DisposablesCollection From(
   params System.Action[] actions
)

Parameters

actions
See Also

Reference

DisposablesCollection Class
DisposablesCollection Members
Overload List


DocumentRendererAttribute Class

DocumentRendererAttribute Class
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DocumentRendererAttribute Class
Allows to specified document renderer type for class.
Object Model
DocumentRendererAttribute Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DocumentRendererAttribute
   Inherits System.Attribute
public class DocumentRendererAttribute : System.Attribute
Inheritance Hierarchy

System.Object
System.Attribute
GrapeCity.Viewer.Common.DocumentRendererAttribute

See Also

Reference

DocumentRendererAttribute Members
GrapeCity.Viewer.Common Namespace


DocumentRendererAttribute Class Members

DocumentRendererAttribute Class Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DocumentRendererAttribute Class

The following tables list the members exposed by DocumentRendererAttribute.

Public Constructors
 | Name | Description
Public Constructor | DocumentRendererAttribute Constructor | Initializes a new instance of the DocumentRendererAttribute class.
Top
Public Properties
 | Name | Description
Public Property | RendererType | Gets the type of the renderer.
Public Property | TypeId | (Inherited from System.Attribute)
Top
Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

DocumentRendererAttribute Class
GrapeCity.Viewer.Common Namespace


DocumentRendererAttribute Constructor

DocumentRendererAttribute Constructor

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DocumentRendererAttribute Class : DocumentRendererAttribute Constructor
Type of the renderer.
Initializes a new instance of the DocumentRendererAttribute class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal rendererType As System.Type _
)
public DocumentRendererAttribute(
   System.Type rendererType
)

Parameters

rendererType
Type of the renderer.
See Also

Reference

DocumentRendererAttribute Class
DocumentRendererAttribute Members


DocumentRendererAttribute Class Properties

DocumentRendererAttribute Class Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DocumentRendererAttribute Class

For a list of all members of this type, see DocumentRendererAttribute members.

Public Properties
 | Name | Description
Public Property | RendererType | Gets the type of the renderer.
Public Property | TypeId | (Inherited from System.Attribute)
Top
See Also

Reference

DocumentRendererAttribute Class
GrapeCity.Viewer.Common Namespace


RendererType Property (DocumentRendererAttribute)

RendererType Property (DocumentRendererAttribute)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DocumentRendererAttribute Class : RendererType Property
Gets the type of the renderer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property RendererType As System.Type
public System.Type RendererType {get;}
See Also

Reference

DocumentRendererAttribute Class
DocumentRendererAttribute Members


DocumentSearchService Class

DocumentSearchService Class
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DocumentSearchService Class
Search service implementation for ISearchableDocument
Object Model
DocumentSearchService Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DocumentSearchService
   Implements ISearchService
public sealed class DocumentSearchService : ISearchService
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.DocumentSearchService

See Also

Reference

DocumentSearchService Members
GrapeCity.Viewer.Common Namespace


DocumentSearchService Class Members

DocumentSearchService Class Members
Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DocumentSearchService Class

The following tables list the members exposed by DocumentSearchService.

Public Constructors
 | Name | Description
Public Constructor | DocumentSearchService Constructor |
Top
Public Methods
 | Name | Description
Public Method | Find | Searches the document according to find options.
Top
See Also

Reference

DocumentSearchService Class
GrapeCity.Viewer.Common Namespace


DocumentSearchService Constructor

DocumentSearchService Constructor

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DocumentSearchService Class : DocumentSearchService Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DocumentSearchService()
See Also

Reference

DocumentSearchService Class
DocumentSearchService Members


DocumentSearchService Class Methods

DocumentSearchService Class Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DocumentSearchService Class

For a list of all members of this type, see DocumentSearchService members.

Public Methods
 | Name | Description
Public Method | Find | Searches the document according to find options.
Top
See Also

Reference

DocumentSearchService Class
GrapeCity.Viewer.Common Namespace


Find Method (DocumentSearchService)

Find Method (DocumentSearchService)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DocumentSearchService Class : Find Method
Searches the document according to find options.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Find( _
   ByVal document As DocumentModel, _
   ByVal findOptions As FindOptions, _
   ByVal startFrom As SearchResult, _
   ByVal maxCount As System.Integer, _
   ByVal handler As System.Action(Of DocumentModel,IEnumerable(Of SearchResult)) _
)
public void Find(
   DocumentModel document,
   FindOptions findOptions,
   SearchResult startFrom,
   System.int maxCount,
   System.Action<DocumentModel,IEnumerable<SearchResult>> handler
)

Parameters

document
findOptions
startFrom
maxCount
handler
See Also

Reference

DocumentSearchService Class
DocumentSearchService Members


DoubleDelegateCommand Class

DoubleDelegateCommand Class
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DoubleDelegateCommand Class
Command that delegates implementation to another delegate command
Object Model
DoubleDelegateCommand Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class DoubleDelegateCommand
   Implements ICommand, IDelegateCommand
public sealed class DoubleDelegateCommand : ICommand, IDelegateCommand
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.DoubleDelegateCommand

See Also

Reference

DoubleDelegateCommand Members
GrapeCity.Viewer.Common Namespace


DoubleDelegateCommand Class Members

DoubleDelegateCommand Class Members
Properties Methods Events

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DoubleDelegateCommand Class

The following tables list the members exposed by DoubleDelegateCommand.

Public Constructors
 | Name | Description
Public Constructor | DoubleDelegateCommand Constructor |
Top
Public Properties
 | Name | Description
Public Property | Command | Gets or sets the command.
Top
Public Methods
 | Name | Description
Public Method | CanExecute | Defines the method that determines whether the command can execute in its current state.
Public Method | Dispose |
Public Method | Execute | Defines the method to be called when the command is invoked.
Public Method | RaiseCanExecuteChanged | Raises CanExecuteChanged event.
Top
Public Events
 | Name | Description
Public Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute.
Top
See Also

Reference

DoubleDelegateCommand Class
GrapeCity.Viewer.Common Namespace


DoubleDelegateCommand Constructor

DoubleDelegateCommand Constructor

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DoubleDelegateCommand Class : DoubleDelegateCommand Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public DoubleDelegateCommand()
See Also

Reference

DoubleDelegateCommand Class
DoubleDelegateCommand Members


DoubleDelegateCommand Class Methods

DoubleDelegateCommand Class Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DoubleDelegateCommand Class

For a list of all members of this type, see DoubleDelegateCommand members.

Public Methods
 | Name | Description
Public Method | CanExecute | Defines the method that determines whether the command can execute in its current state.
Public Method | Dispose |
Public Method | Execute | Defines the method to be called when the command is invoked.
Public Method | RaiseCanExecuteChanged | Raises CanExecuteChanged event.
Top
See Also

Reference

DoubleDelegateCommand Class
GrapeCity.Viewer.Common Namespace


CanExecute Method (DoubleDelegateCommand)

CanExecute Method (DoubleDelegateCommand)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DoubleDelegateCommand Class : CanExecute Method
Data used by the command. If the command does not require data to be passed, this object can be set to null.
Defines the method that determines whether the command can execute in its current state.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CanExecute( _
   ByVal parameter As System.Object _
) As System.Boolean
public System.bool CanExecute(
   System.object parameter
)

Parameters

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.

Return Value

true if this instance can execute the specified parameter; otherwise, false.
See Also

Reference

DoubleDelegateCommand Class
DoubleDelegateCommand Members


Dispose Method (DoubleDelegateCommand)

Dispose Method (DoubleDelegateCommand)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DoubleDelegateCommand Class : Dispose Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

DoubleDelegateCommand Class
DoubleDelegateCommand Members


Execute Method (DoubleDelegateCommand)

Execute Method (DoubleDelegateCommand)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DoubleDelegateCommand Class : Execute Method
Data used by the command. If the command does not require data to be passed, this object can be set to null.
Defines the method to be called when the command is invoked.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Execute( _
   ByVal parameter As System.Object _
)
public void Execute(
   System.object parameter
)

Parameters

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.
See Also

Reference

DoubleDelegateCommand Class
DoubleDelegateCommand Members


RaiseCanExecuteChanged Method (DoubleDelegateCommand)

RaiseCanExecuteChanged Method (DoubleDelegateCommand)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DoubleDelegateCommand Class : RaiseCanExecuteChanged Method
Raises CanExecuteChanged event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RaiseCanExecuteChanged()
public void RaiseCanExecuteChanged()
See Also

Reference

DoubleDelegateCommand Class
DoubleDelegateCommand Members


DoubleDelegateCommand Class Properties

DoubleDelegateCommand Class Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DoubleDelegateCommand Class

For a list of all members of this type, see DoubleDelegateCommand members.

Public Properties
 | Name | Description
Public Property | Command | Gets or sets the command.
Top
See Also

Reference

DoubleDelegateCommand Class
GrapeCity.Viewer.Common Namespace


Command Property (DoubleDelegateCommand)

Command Property (DoubleDelegateCommand)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DoubleDelegateCommand Class : Command Property
Gets or sets the command.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Command As IDelegateCommand
public IDelegateCommand Command {get; set;}
See Also

Reference

DoubleDelegateCommand Class
DoubleDelegateCommand Members


DoubleDelegateCommand Class Events

DoubleDelegateCommand Class Events

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DoubleDelegateCommand Class

For a list of all members of this type, see DoubleDelegateCommand members.

Public Events
 | Name | Description
Public Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute.
Top
See Also

Reference

DoubleDelegateCommand Class
GrapeCity.Viewer.Common Namespace


CanExecuteChanged Event (DoubleDelegateCommand)

CanExecuteChanged Event (DoubleDelegateCommand)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DoubleDelegateCommand Class : CanExecuteChanged Event
Occurs when changes occur that affect whether the command should execute.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event CanExecuteChanged As System.EventHandler
public event System.EventHandler CanExecuteChanged
See Also

Reference

DoubleDelegateCommand Class
DoubleDelegateCommand Members


EnumerableExtensions Class

EnumerableExtensions Class
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : EnumerableExtensions Class
Object Model
EnumerableExtensions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit NotInheritable Class EnumerableExtensions
public static class EnumerableExtensions
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.EnumerableExtensions

See Also

Reference

EnumerableExtensions Members
GrapeCity.Viewer.Common Namespace


EnumerableExtensions Class Members

EnumerableExtensions Class Members
Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : EnumerableExtensions Class

The following tables list the members exposed by EnumerableExtensions.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | ForEach<T> | Executes action for each sequence item
static (Shared in Visual Basic) | GetRecursive<T> | Extract all descendants recursively
static (Shared in Visual Basic) | ZipEx<TSource1,TSource2,TResult> | Gets the result of combination of two sequences. Result sequence is as short as shortest source sequences
Top
See Also

Reference

EnumerableExtensions Class
GrapeCity.Viewer.Common Namespace


EnumerableExtensions Class Methods

EnumerableExtensions Class Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : EnumerableExtensions Class

For a list of all members of this type, see EnumerableExtensions members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | ForEach<T> | Executes action for each sequence item
static (Shared in Visual Basic) | GetRecursive<T> | Extract all descendants recursively
static (Shared in Visual Basic) | ZipEx<TSource1,TSource2,TResult> | Gets the result of combination of two sequences. Result sequence is as short as shortest source sequences
Top
See Also

Reference

EnumerableExtensions Class
GrapeCity.Viewer.Common Namespace


ForEach<T> Method (EnumerableExtensions)

ForEach<T> Method (EnumerableExtensions)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > EnumerableExtensions Class : ForEach<T> Method
Executes action for each sequence item
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Sub ForEach(Of T)( _
   ByVal source As System.Collections.Generic.IEnumerable(Of T), _
   ByVal action As System.Action(Of T) _
)
public static void ForEach<T>(
   System.Collections.Generic.IEnumerable<T> source,
   System.Action<T> action
)

Parameters

source
action

Type Parameters

T
See Also

Reference

EnumerableExtensions Class
EnumerableExtensions Members


GetRecursive<T> Method (EnumerableExtensions)

GetRecursive<T> Method (EnumerableExtensions)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > EnumerableExtensions Class : GetRecursive<T> Method
Extract all descendants recursively
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function GetRecursive(Of T)( _
   ByVal source As System.Collections.Generic.IEnumerable(Of T), _
   ByVal selector As System.Func(Of T,IEnumerable(Of T)) _
) As System.Collections.Generic.IEnumerable(Of T)
public static System.Collections.Generic.IEnumerable<T> GetRecursive<T>(
   System.Collections.Generic.IEnumerable<T> source,
   System.Func<T,IEnumerable<T>> selector
)

Parameters

source
selector

Type Parameters

T
See Also

Reference

EnumerableExtensions Class
EnumerableExtensions Members


ZipEx<TSource1,TSource2,TResult> Method (EnumerableExtensions)

ZipEx<TSource1,TSource2,TResult> Method (EnumerableExtensions)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > EnumerableExtensions Class : ZipEx<TSource1,TSource2,TResult> Method
Gets the result of combination of two sequences. Result sequence is as short as shortest source sequences
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function ZipEx
    (Of TSource1,TSource2,TResult)( _
   ByVal source1 As System.Collections.Generic.IEnumerable(Of TSource1), _
   ByVal source2 As System.Collections.Generic.IEnumerable(Of TSource2), _
   ByVal selector As System.Func(Of TSource1,TSource2,TResult) _
) As System.Collections.Generic.IEnumerable(Of TResult)
public static System.Collections.Generic.IEnumerable<TResult> ZipEx<TSource1,TSource2,TResult>(
   System.Collections.Generic.IEnumerable<TSource1> source1,
   System.Collections.Generic.IEnumerable<TSource2> source2,
   System.Func<TSource1,TSource2,TResult> selector
)

Parameters

source1
source2
selector

Type Parameters

TSource1
TSource2
TResult
See Also

Reference

EnumerableExtensions Class
EnumerableExtensions Members


NotifyCollectionChangedEventArgs Class

NotifyCollectionChangedEventArgs Class
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : NotifyCollectionChangedEventArgs Class
Describes the action that caused a System.Collections.Specialized.INotifyCollectionChanged.CollectionChanged event.
Object Model
NotifyCollectionChangedEventArgs Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class NotifyCollectionChangedEventArgs
   Inherits System.EventArgs
public sealed class NotifyCollectionChangedEventArgs : System.EventArgs
Inheritance Hierarchy

System.Object
System.EventArgs
GrapeCity.Viewer.Common.NotifyCollectionChangedEventArgs

See Also

Reference

NotifyCollectionChangedEventArgs Members
GrapeCity.Viewer.Common Namespace


NotifyCollectionChangedEventArgs Class Members

NotifyCollectionChangedEventArgs Class Members
Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : NotifyCollectionChangedEventArgs Class

The following tables list the members exposed by NotifyCollectionChangedEventArgs.

Public Constructors
 | Name | Description
Public Constructor | NotifyCollectionChangedEventArgs Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Action | Gets the action type.
Public Property | NewItems | Gets the new items.
Public Property | NewStartingIndex | Gets the index of the starting of new items.
Public Property | OldItems | Gets the old items.
Public Property | OldStartingIndex | Gets the index of the starting of old items.
Top
See Also

Reference

NotifyCollectionChangedEventArgs Class
GrapeCity.Viewer.Common Namespace


NotifyCollectionChangedEventArgs Constructor

NotifyCollectionChangedEventArgs Constructor

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class : NotifyCollectionChangedEventArgs Constructor
Overload List
Overload | Description
NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction,Object,Object,Int32) | Initializes a new instance of the NotifyCollectionChangedEventArgs class.
NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction,Object,Int32) | Initializes a new instance of the NotifyCollectionChangedEventArgs class.
NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction) | Initializes a new instance of the NotifyCollectionChangedEventArgs class.
See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members


NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction,Object,Object,Int32)

NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction,Object,Object,Int32)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class > NotifyCollectionChangedEventArgs Constructor : NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction,Object,Object,Int32)
Initializes a new instance of the NotifyCollectionChangedEventArgs class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal action As NotifyCollectionChangedAction, _
   ByVal newItem As System.Object, _
   ByVal oldItem As System.Object, _
   ByVal index As System.Integer _
)
public NotifyCollectionChangedEventArgs(
   NotifyCollectionChangedAction action,
   System.object newItem,
   System.object oldItem,
   System.int index
)

Parameters

action
newItem
oldItem
index
See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members
Overload List


NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction,Object,Int32)

NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction,Object,Int32)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class > NotifyCollectionChangedEventArgs Constructor : NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction,Object,Int32)
Initializes a new instance of the NotifyCollectionChangedEventArgs class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal action As NotifyCollectionChangedAction, _
   ByVal changedItem As System.Object, _
   ByVal index As System.Integer _
)
public NotifyCollectionChangedEventArgs(
   NotifyCollectionChangedAction action,
   System.object changedItem,
   System.int index
)

Parameters

action
changedItem
index
See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members
Overload List


NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction)

NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class > NotifyCollectionChangedEventArgs Constructor : NotifyCollectionChangedEventArgs Constructor(NotifyCollectionChangedAction)
Initializes a new instance of the NotifyCollectionChangedEventArgs class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal action As NotifyCollectionChangedAction _
)
public NotifyCollectionChangedEventArgs(
   NotifyCollectionChangedAction action
)

Parameters

action
See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members
Overload List


NotifyCollectionChangedEventArgs Class Properties

NotifyCollectionChangedEventArgs Class Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : NotifyCollectionChangedEventArgs Class

For a list of all members of this type, see NotifyCollectionChangedEventArgs members.

Public Properties
 | Name | Description
Public Property | Action | Gets the action type.
Public Property | NewItems | Gets the new items.
Public Property | NewStartingIndex | Gets the index of the starting of new items.
Public Property | OldItems | Gets the old items.
Public Property | OldStartingIndex | Gets the index of the starting of old items.
Top
See Also

Reference

NotifyCollectionChangedEventArgs Class
GrapeCity.Viewer.Common Namespace


Action Property (NotifyCollectionChangedEventArgs)

Action Property (NotifyCollectionChangedEventArgs)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class : Action Property
Gets the action type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Action As NotifyCollectionChangedAction
public NotifyCollectionChangedAction Action {get;}
See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members


NewItems Property (NotifyCollectionChangedEventArgs)

NewItems Property (NotifyCollectionChangedEventArgs)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class : NewItems Property
Gets the new items.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property NewItems As System.Collections.IList
public System.Collections.IList NewItems {get;}
See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members


NewStartingIndex Property (NotifyCollectionChangedEventArgs)

NewStartingIndex Property (NotifyCollectionChangedEventArgs)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class : NewStartingIndex Property
Gets the index of the starting of new items.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property NewStartingIndex As System.Integer
public System.int NewStartingIndex {get;}
See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members


OldItems Property (NotifyCollectionChangedEventArgs)

OldItems Property (NotifyCollectionChangedEventArgs)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class : OldItems Property
Gets the old items.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property OldItems As System.Collections.IList
public System.Collections.IList OldItems {get;}
See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members


OldStartingIndex Property (NotifyCollectionChangedEventArgs)

OldStartingIndex Property (NotifyCollectionChangedEventArgs)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > NotifyCollectionChangedEventArgs Class : OldStartingIndex Property
Gets the index of the starting of old items.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property OldStartingIndex As System.Integer
public System.int OldStartingIndex {get;}
See Also

Reference

NotifyCollectionChangedEventArgs Class
NotifyCollectionChangedEventArgs Members


NullDelegateCommand Class

NullDelegateCommand Class
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : NullDelegateCommand Class
Object Model
NullDelegateCommand Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class NullDelegateCommand
   Implements ICommand, IDelegateCommand
public sealed class NullDelegateCommand : ICommand, IDelegateCommand
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.NullDelegateCommand

See Also

Reference

NullDelegateCommand Members
GrapeCity.Viewer.Common Namespace


NullDelegateCommand Class Members

NullDelegateCommand Class Members
Methods Events

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : NullDelegateCommand Class

The following tables list the members exposed by NullDelegateCommand.

Public Constructors
 | Name | Description
Public Constructor | NullDelegateCommand Constructor |
Top
Public Methods
 | Name | Description
Public Method | CanExecute |
Public Method | Execute |
Public Method | RaiseCanExecuteChanged |
Top
Public Events
 | Name | Description
Public Event | CanExecuteChanged |
Top
See Also

Reference

NullDelegateCommand Class
GrapeCity.Viewer.Common Namespace


NullDelegateCommand Constructor

NullDelegateCommand Constructor

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > NullDelegateCommand Class : NullDelegateCommand Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public NullDelegateCommand()
See Also

Reference

NullDelegateCommand Class
NullDelegateCommand Members


NullDelegateCommand Class Methods

NullDelegateCommand Class Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : NullDelegateCommand Class

For a list of all members of this type, see NullDelegateCommand members.

Public Methods
 | Name | Description
Public Method | CanExecute |
Public Method | Execute |
Public Method | RaiseCanExecuteChanged |
Top
See Also

Reference

NullDelegateCommand Class
GrapeCity.Viewer.Common Namespace


CanExecute Method (NullDelegateCommand)

CanExecute Method (NullDelegateCommand)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > NullDelegateCommand Class : CanExecute Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CanExecute( _
   ByVal parameter As System.Object _
) As System.Boolean
public System.bool CanExecute(
   System.object parameter
)

Parameters

parameter
See Also

Reference

NullDelegateCommand Class
NullDelegateCommand Members


Execute Method (NullDelegateCommand)

Execute Method (NullDelegateCommand)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > NullDelegateCommand Class : Execute Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Execute( _
   ByVal parameter As System.Object _
)
public void Execute(
   System.object parameter
)

Parameters

parameter
See Also

Reference

NullDelegateCommand Class
NullDelegateCommand Members


RaiseCanExecuteChanged Method (NullDelegateCommand)

RaiseCanExecuteChanged Method (NullDelegateCommand)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > NullDelegateCommand Class : RaiseCanExecuteChanged Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RaiseCanExecuteChanged()
public void RaiseCanExecuteChanged()
See Also

Reference

NullDelegateCommand Class
NullDelegateCommand Members


NullDelegateCommand Class Events

NullDelegateCommand Class Events

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : NullDelegateCommand Class

For a list of all members of this type, see NullDelegateCommand members.

Public Events
 | Name | Description
Public Event | CanExecuteChanged |
Top
See Also

Reference

NullDelegateCommand Class
GrapeCity.Viewer.Common Namespace


CanExecuteChanged Event (NullDelegateCommand)

CanExecuteChanged Event (NullDelegateCommand)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > NullDelegateCommand Class : CanExecuteChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event CanExecuteChanged As System.EventHandler
public event System.EventHandler CanExecuteChanged
See Also

Reference

NullDelegateCommand Class
NullDelegateCommand Members


NullRenderer Class

NullRenderer Class
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : NullRenderer Class
Null-object implementation for IDocumentRenderer interface
Object Model
NullRenderer Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class NullRenderer
   Implements IDocumentRenderer
public sealed class NullRenderer : IDocumentRenderer
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.NullRenderer

See Also

Reference

NullRenderer Members
GrapeCity.Viewer.Common Namespace


NullRenderer Class Members

NullRenderer Class Members
Fields Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : NullRenderer Class

The following tables list the members exposed by NullRenderer.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Instance | The NullRenderer instance
Top
Public Methods
 | Name | Description
Public Method | RenderPage | Renders page from current document
Top
See Also

Reference

NullRenderer Class
GrapeCity.Viewer.Common Namespace


NullRenderer Class Methods

NullRenderer Class Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : NullRenderer Class

For a list of all members of this type, see NullRenderer members.

Public Methods
 | Name | Description
Public Method | RenderPage | Renders page from current document
Top
See Also

Reference

NullRenderer Class
GrapeCity.Viewer.Common Namespace


RenderPage Method (NullRenderer)

RenderPage Method (NullRenderer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > NullRenderer Class : RenderPage Method
Index of the page to render
Renders page from current document
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function RenderPage( _
   ByVal index As System.Integer _
) As PageView
public PageView RenderPage(
   System.int index
)

Parameters

index
Index of the page to render

Return Value

Rendered page view
See Also

Reference

NullRenderer Class
NullRenderer Members


NullRenderer Class Fields

NullRenderer Class Fields

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : NullRenderer Class

For a list of all members of this type, see NullRenderer members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Instance | The NullRenderer instance
Top
See Also

Reference

NullRenderer Class
GrapeCity.Viewer.Common Namespace


Instance Field (NullRenderer)

Instance Field (NullRenderer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > NullRenderer Class : Instance Field
The NullRenderer instance
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Instance As IDocumentRenderer
public static readonly IDocumentRenderer Instance
See Also

Reference

NullRenderer Class
NullRenderer Members


NullRenderer.Factory Class

NullRenderer.Factory Class
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : NullRenderer.Factory Class
IDocumentRenderer factory.
Object Model
NullRenderer.Factory Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class NullRenderer.Factory
   Implements IDocumentRendererFactory
public sealed class NullRenderer.Factory : IDocumentRendererFactory
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.NullRenderer.Factory

See Also

Reference

NullRenderer.Factory Members
GrapeCity.Viewer.Common Namespace


NullRenderer.Factory Class Members

NullRenderer.Factory Class Members
Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : NullRenderer.Factory Class

The following tables list the members exposed by NullRenderer.Factory.

Public Constructors
 | Name | Description
Public Constructor | NullRenderer.Factory Constructor |
Top
Public Methods
 | Name | Description
Public Method | Create | Overloaded. Returns MullRenderer.Instance object.
Top
See Also

Reference

NullRenderer.Factory Class
GrapeCity.Viewer.Common Namespace


NullRenderer.Factory Constructor

NullRenderer.Factory Constructor

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > NullRenderer.Factory Class : NullRenderer.Factory Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public NullRenderer.Factory()
See Also

Reference

NullRenderer.Factory Class
NullRenderer.Factory Members


NullRenderer.Factory Class Methods

NullRenderer.Factory Class Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : NullRenderer.Factory Class

For a list of all members of this type, see NullRenderer.Factory members.

Public Methods
 | Name | Description
Public Method | Create | Overloaded. Returns MullRenderer.Instance object.
Top
See Also

Reference

NullRenderer.Factory Class
GrapeCity.Viewer.Common Namespace


Create Method (NullRenderer.Factory)

Create Method (NullRenderer.Factory)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > NullRenderer.Factory Class : Create Method
Returns MullRenderer.Instance object.
Overload List
Overload | Description
Create(IApplicationContext,DocumentModel) | Returns MullRenderer.Instance object.
Create(IApplicationContext,DocumentModel,DeviceKind) | Returns MullRenderer.Instance object.
See Also

Reference

NullRenderer.Factory Class
NullRenderer.Factory Members


Create(IApplicationContext,DocumentModel) Method

Create(IApplicationContext,DocumentModel) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > NullRenderer.Factory Class > Create Method : Create(IApplicationContext,DocumentModel) Method
Returns MullRenderer.Instance object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Create( _
   ByVal context As IApplicationContext, _
   ByVal document As DocumentModel _
) As IDocumentRenderer
public IDocumentRenderer Create(
   IApplicationContext context,
   DocumentModel document
)

Parameters

context
document
See Also

Reference

NullRenderer.Factory Class
NullRenderer.Factory Members
Overload List


Create(IApplicationContext,DocumentModel,DeviceKind) Method

Create(IApplicationContext,DocumentModel,DeviceKind) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > NullRenderer.Factory Class > Create Method : Create(IApplicationContext,DocumentModel,DeviceKind) Method
Returns MullRenderer.Instance object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Create( _
   ByVal context As IApplicationContext, _
   ByVal document As DocumentModel, _
   ByVal device As DeviceKind _
) As IDocumentRenderer
public IDocumentRenderer Create(
   IApplicationContext context,
   DocumentModel document,
   DeviceKind device
)

Parameters

context
document
device
See Also

Reference

NullRenderer.Factory Class
NullRenderer.Factory Members
Overload List


ObservableCollection<T> Class

ObservableCollection<T> Class
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : ObservableCollection<T> Class
Wrapped System.Collections.ObjectModel observable collection
Object Model
ObservableCollection<T> Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ObservableCollection(Of T)
   Inherits System.Collections.ObjectModel.Collection(Of T)
   Implements INotifyCollectionChanged
public class ObservableCollection<T> : System.Collections.ObjectModel.Collection<T>, INotifyCollectionChanged
Type Parameters
T
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.Viewer.Common.ObservableCollection<T>

See Also

Reference

ObservableCollection<T> Members
GrapeCity.Viewer.Common Namespace


ObservableCollection<T> Class Members

ObservableCollection<T> Class Members
Properties Methods Events

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : ObservableCollection<T> Class

The following tables list the members exposed by ObservableCollection<T>.

Public Constructors
 | Name | Description
Public Constructor | ObservableCollection<T> Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<T>)
Top
Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<T>)
Top
Public Events
 | Name | Description
Public Event | CollectionChanged |
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ObservableCollection<T> Class
GrapeCity.Viewer.Common Namespace


ObservableCollection<T> Constructor

ObservableCollection<T> Constructor

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : ObservableCollection<T> Constructor
Overload List
Overload | Description
ObservableCollection<T> Constructor(IList<T>) | Initializes a new instance of the ObservableCollection<T> class.
ObservableCollection<T> Constructor() | Initializes a new instance of the ObservableCollection<T> class.
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


ObservableCollection<T> Constructor(IList<T>)

ObservableCollection<T> Constructor(IList<T>)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class > ObservableCollection<T> Constructor : ObservableCollection<T> Constructor(IList<T>)
The initial items list.
Initializes a new instance of the ObservableCollection<T> class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal data As System.Collections.Generic.IList(Of T) _
)
public ObservableCollection<T>(
   System.Collections.Generic.IList<T> data
)

Parameters

data
The initial items list.
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members
Overload List


ObservableCollection<T> Constructor()

ObservableCollection<T> Constructor()

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class > ObservableCollection<T> Constructor : ObservableCollection<T> Constructor()
Initializes a new instance of the ObservableCollection<T> class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ObservableCollection<T>()
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members
Overload List


ObservableCollection<T> Class Events

ObservableCollection<T> Class Events

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : ObservableCollection<T> Class

For a list of all members of this type, see ObservableCollection<T> members.

Public Events
 | Name | Description
Public Event | CollectionChanged |
Public Event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ObservableCollection<T> Class
GrapeCity.Viewer.Common Namespace


CollectionChanged Event (ObservableCollection<T>)

CollectionChanged Event (ObservableCollection<T>)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : CollectionChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event CollectionChanged As NotifyCollectionChangedEventHandler
public event NotifyCollectionChangedEventHandler CollectionChanged
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


PropertyChanged Event (ObservableCollection<T>)

PropertyChanged Event (ObservableCollection<T>)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : PropertyChanged Event
Occurs when a property value changes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PropertyChanged As System.ComponentModel.PropertyChangedEventHandler
public event System.ComponentModel.PropertyChangedEventHandler PropertyChanged
Event Data

The event handler receives an argument of type System.ComponentModel.PropertyChangedEventArgs containing data related to this event. The following PropertyChangedEventArgs properties provide information specific to this event.

Property | Description
PropertyName |
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


PageView Class

PageView Class
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : PageView Class
Base abstract class for concrete page renderers.
Object Model
PageView Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class PageView
public abstract class PageView
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.PageView

See Also

Reference

PageView Members
GrapeCity.Viewer.Common Namespace


PageView Class Members

PageView Class Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : PageView Class

The following tables list the members exposed by PageView.

Public Properties
 | Name | Description
Public Property | Device | Gets the device kind.
Public Property | Size | Gets the page view size.
Top
Public Methods
 | Name | Description
Public Method | AsCachable | Convert to CachedPageView.
Top
See Also

Reference

PageView Class
GrapeCity.Viewer.Common Namespace


PageView Class Methods

PageView Class Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : PageView Class

For a list of all members of this type, see PageView members.

Public Methods
 | Name | Description
Public Method | AsCachable | Convert to CachedPageView.
Top
See Also

Reference

PageView Class
GrapeCity.Viewer.Common Namespace


AsCachable Method (PageView)

AsCachable Method (PageView)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > PageView Class : AsCachable Method
Convert to CachedPageView.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Function AsCachable( _
   ByVal format As CacheFormat _
) As CachedPageView
public abstract CachedPageView AsCachable(
   CacheFormat format
)

Parameters

format
See Also

Reference

PageView Class
PageView Members


PageView Class Properties

PageView Class Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : PageView Class

For a list of all members of this type, see PageView members.

Public Properties
 | Name | Description
Public Property | Device | Gets the device kind.
Public Property | Size | Gets the page view size.
Top
See Also

Reference

PageView Class
GrapeCity.Viewer.Common Namespace


Device Property (PageView)

Device Property (PageView)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > PageView Class : Device Property
Gets the device kind.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Device As DeviceKind
public DeviceKind Device {get;}
See Also

Reference

PageView Class
PageView Members


Size Property (PageView)

Size Property (PageView)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > PageView Class : Size Property
Gets the page view size.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride ReadOnly Property Size As Size
public abstract Size Size {get;}
See Also

Reference

PageView Class
PageView Members


RectExtensions Class

RectExtensions Class
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : RectExtensions Class
Extends Rect struct with helper methods.
Object Model
RectExtensions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit NotInheritable Class RectExtensions
public static class RectExtensions
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.RectExtensions

See Also

Reference

RectExtensions Members
GrapeCity.Viewer.Common Namespace


RectExtensions Class Members

RectExtensions Class Members
Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : RectExtensions Class

The following tables list the members exposed by RectExtensions.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Round | Rounds the coordinates and size of the rectangle.
Top
See Also

Reference

RectExtensions Class
GrapeCity.Viewer.Common Namespace


RectExtensions Class Methods

RectExtensions Class Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : RectExtensions Class

For a list of all members of this type, see RectExtensions members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Round | Rounds the coordinates and size of the rectangle.
Top
See Also

Reference

RectExtensions Class
GrapeCity.Viewer.Common Namespace


Round Method (RectExtensions)

Round Method (RectExtensions)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > RectExtensions Class : Round Method
Rounds the coordinates and size of the rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function Round( _
   ByVal rect As Rect, _
   ByVal digits As System.Integer _
) As Rect
public static Rect Round(
   Rect rect,
   System.int digits
)

Parameters

rect
digits
See Also

Reference

RectExtensions Class
RectExtensions Members


StreamDocumentLoader Class

StreamDocumentLoader Class
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : StreamDocumentLoader Class
Object Model
StreamDocumentLoader Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class StreamDocumentLoader
   Implements IDocumentLoader
public class StreamDocumentLoader : IDocumentLoader
Inheritance Hierarchy

System.Object
GrapeCity.Viewer.Common.StreamDocumentLoader

See Also

Reference

StreamDocumentLoader Members
GrapeCity.Viewer.Common Namespace


StreamDocumentLoader Class Members

StreamDocumentLoader Class Members
Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : StreamDocumentLoader Class

The following tables list the members exposed by StreamDocumentLoader.

Public Constructors
 | Name | Description
Public Constructor | StreamDocumentLoader Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | DocumentFormat |
Top
See Also

Reference

StreamDocumentLoader Class
GrapeCity.Viewer.Common Namespace


StreamDocumentLoader Constructor

StreamDocumentLoader Constructor

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > StreamDocumentLoader Class : StreamDocumentLoader Constructor
Overload List
Overload | Description
StreamDocumentLoader Constructor(Stream,DocumentFormat) |
StreamDocumentLoader Constructor(Stream,Uri,DocumentFormat) |
See Also

Reference

StreamDocumentLoader Class
StreamDocumentLoader Members


StreamDocumentLoader Constructor(Stream,DocumentFormat)

StreamDocumentLoader Constructor(Stream,DocumentFormat)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > StreamDocumentLoader Class > StreamDocumentLoader Constructor : StreamDocumentLoader Constructor(Stream,DocumentFormat)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal s As System.IO.Stream, _
   ByVal format As DocumentFormat _
)
public StreamDocumentLoader(
   System.IO.Stream s,
   DocumentFormat format
)

Parameters

s
format
See Also

Reference

StreamDocumentLoader Class
StreamDocumentLoader Members
Overload List


StreamDocumentLoader Constructor(Stream,Uri,DocumentFormat)

StreamDocumentLoader Constructor(Stream,Uri,DocumentFormat)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > StreamDocumentLoader Class > StreamDocumentLoader Constructor : StreamDocumentLoader Constructor(Stream,Uri,DocumentFormat)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal s As System.IO.Stream, _
   ByVal baseUri As System.Uri, _
   ByVal format As DocumentFormat _
)
public StreamDocumentLoader(
   System.IO.Stream s,
   System.Uri baseUri,
   DocumentFormat format
)

Parameters

s
baseUri
format
See Also

Reference

StreamDocumentLoader Class
StreamDocumentLoader Members
Overload List


StreamDocumentLoader Class Properties

StreamDocumentLoader Class Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : StreamDocumentLoader Class

For a list of all members of this type, see StreamDocumentLoader members.

Public Properties
 | Name | Description
Public Property | DocumentFormat |
Top
See Also

Reference

StreamDocumentLoader Class
GrapeCity.Viewer.Common Namespace


DocumentFormat Property (StreamDocumentLoader)

DocumentFormat Property (StreamDocumentLoader)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > StreamDocumentLoader Class : DocumentFormat Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DocumentFormat As DocumentFormat
public DocumentFormat DocumentFormat {get;}
See Also

Reference

StreamDocumentLoader Class
StreamDocumentLoader Members


DeviceKind Enumeration

DeviceKind Enumeration

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DeviceKind Enumeration
Defines enumeration of possible target devices for view.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DeviceKind
   Inherits System.Enum
public enum DeviceKind : System.Enum
Members
Member | Description
Export | Output to Export target device
Paper | Output to Paper target device
Screen | Output to Screen target device
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.DeviceKind

See Also

Reference

GrapeCity.Viewer.Common Namespace


DocumentFormat Enumeration

DocumentFormat Enumeration

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DocumentFormat Enumeration
Specifies possible document formats
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DocumentFormat
   Inherits System.Enum
public enum DocumentFormat : System.Enum
Members
Member | Description
Ddf | DDF document, binary format
Rdf | AR document, binary format
Rdlx | DDR document, xml format
Rpx | AR document, xml format
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.DocumentFormat

See Also

Reference

GrapeCity.Viewer.Common Namespace


LoadState Enumeration

LoadState Enumeration

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : LoadState Enumeration
Possible loading states
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LoadState
   Inherits System.Enum
public enum LoadState : System.Enum
Members
Member | Description
Cancelled |
Cancelling |
Completed |
Error |
InProgress |
NotStarted |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.LoadState

See Also

Reference

GrapeCity.Viewer.Common Namespace


NotifyCollectionChangedAction Enumeration

NotifyCollectionChangedAction Enumeration

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : NotifyCollectionChangedAction Enumeration
Enum NotifyCollectionChangedAction
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum NotifyCollectionChangedAction
   Inherits System.Enum
public enum NotifyCollectionChangedAction : System.Enum
Members
Member | Description
Add |
Remove |
Replace |
Reset |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.NotifyCollectionChangedAction

See Also

Reference

GrapeCity.Viewer.Common Namespace


PrintingSettings Enumeration

PrintingSettings Enumeration

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : PrintingSettings Enumeration
Print process settings
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PrintingSettings
   Inherits System.Enum
public enum PrintingSettings : System.Enum
Members
Member | Description
None |
ShowPrintDialog | If set the Print-dialog will be shown.
ShowPrintProgressDialog | If set the dialog with printing state information will be shown.
UsePrintingThread | If set the printing will be run in new thread.
UseStandardDialog | If set the printing will use standard PrintDialog
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.Viewer.Common.PrintingSettings

See Also

Reference

GrapeCity.Viewer.Common Namespace


Color Structure

Color Structure
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : Color Structure
Platform independent color implementation
Object Model
Color Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure Color
   Inherits System.ValueType
public struct Color : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Viewer.Common.Color

See Also

Reference

Color Members
GrapeCity.Viewer.Common Namespace


Color Structure Members

Color Structure Members
Fields Properties Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : Color Structure

The following tables list the members exposed by Color.

Public Constructors
 | Name | Description
Public Constructor | Color Constructor | Initializes a new instance of the Color struct.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | Black |
static (Shared in Visual Basic) | Blue |
static (Shared in Visual Basic) | DarkBlue |
static (Shared in Visual Basic) | Empty |
static (Shared in Visual Basic) | Gray |
static (Shared in Visual Basic) | Red |
static (Shared in Visual Basic) | Transparent |
static (Shared in Visual Basic) | White |
Top
Public Properties
 | Name | Description
Public Property | A | Gets the A color component.
Public Property | B | Gets the B color component.
Public Property | G | Gets the G color component.
Public Property | IsEmpty | Gets a value indicating whether this instance is empty.
Public Property | R | Gets the R color component.
Public Property | Value | Gets the value.
Top
Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified System.Object is equal to this instance.
static (Shared in Visual Basic) | FromArgb | Overloaded. Creates new color from color components.
Public Method | GetHashCode |
Public Method | ToArgb | Gets ARGB value of the color.
Top
Public Operators
public Operator Equality | Implements the operator ==.
public Operator Implicit Type Conversion | Performs an implicit conversion from Color to System.UInt32.
public Operator Inequality | Implements the operator !=.
Top
See Also

Reference

Color Structure
GrapeCity.Viewer.Common Namespace


Color Constructor

Color Constructor

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Color Constructor
The value.
Initializes a new instance of the Color struct.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal value As System.Long _
)
public Color(
   System.long value
)

Parameters

value
The value.
See Also

Reference

Color Structure
Color Members


Color Structure Methods

Color Structure Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : Color Structure

For a list of all members of this type, see Color members.

Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Determines whether the specified System.Object is equal to this instance.
static (Shared in Visual Basic) | FromArgb | Overloaded. Creates new color from color components.
Public Method | GetHashCode |
Public Method | ToArgb | Gets ARGB value of the color.
Top
See Also

Reference

Color Structure
GrapeCity.Viewer.Common Namespace


Equals Method (Color)

Equals Method (Color)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Equals Method
Determines whether the specified System.Object is equal to this instance.
Overload List
Overload | Description
Equals(Color) |
Equals(Object) | Determines whether the specified System.Object is equal to this instance.
See Also

Reference

Color Structure
Color Members


Equals(Color) Method

Equals(Color) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure > Equals Method : Equals(Color) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Equals( _
   ByVal obj As Color _
) As System.Boolean
public System.bool Equals(
   Color obj
)

Parameters

obj
See Also

Reference

Color Structure
Color Members
Overload List


Equals(Object) Method

Equals(Object) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure > Equals Method : Equals(Object) Method
Determines whether the specified System.Object is equal to this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
See Also

Reference

Color Structure
Color Members
Overload List


FromArgb Method (Color)

FromArgb Method (Color)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : FromArgb Method
Creates new color from color components.
Overload List
Overload | Description
FromArgb(Int32) | Creates new color from color components.
FromArgb(Int32,Color) | Creates new color from color components.
FromArgb(Byte,Byte,Byte,Byte) | Creates new color from color components.
FromArgb(Int32,Int32,Int32) | Creates new color from color components.
FromArgb(Int32,Int32,Int32,Int32) | Creates new color from color components.
See Also

Reference

Color Structure
Color Members


FromArgb(Int32) Method

FromArgb(Int32) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure > FromArgb Method : FromArgb(Int32) Method
The value.
Creates new color from color components.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromArgb( _
   ByVal value As System.Integer _
) As Color
public static Color FromArgb(
   System.int value
)

Parameters

value
The value.
See Also

Reference

Color Structure
Color Members
Overload List


FromArgb(Int32,Color) Method

FromArgb(Int32,Color) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure > FromArgb Method : FromArgb(Int32,Color) Method
A.
The c.
Creates new color from color components.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromArgb( _
   ByVal a As System.Integer, _
   ByVal c As Color _
) As Color
public static Color FromArgb(
   System.int a,
   Color c
)

Parameters

a
A.
c
The c.
See Also

Reference

Color Structure
Color Members
Overload List


FromArgb(Byte,Byte,Byte,Byte) Method

FromArgb(Byte,Byte,Byte,Byte) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure > FromArgb Method : FromArgb(Byte,Byte,Byte,Byte) Method
A.
The r.
The g.
The b.
Creates new color from color components.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromArgb( _
   ByVal a As System.Byte, _
   ByVal r As System.Byte, _
   ByVal g As System.Byte, _
   ByVal b As System.Byte _
) As Color
public static Color FromArgb(
   System.byte a,
   System.byte r,
   System.byte g,
   System.byte b
)

Parameters

a
A.
r
The r.
g
The g.
b
The b.
See Also

Reference

Color Structure
Color Members
Overload List


FromArgb(Int32,Int32,Int32) Method

FromArgb(Int32,Int32,Int32) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure > FromArgb Method : FromArgb(Int32,Int32,Int32) Method
Creates new color from color components.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromArgb( _
   ByVal r As System.Integer, _
   ByVal g As System.Integer, _
   ByVal b As System.Integer _
) As Color
public static Color FromArgb(
   System.int r,
   System.int g,
   System.int b
)

Parameters

r
g
b
See Also

Reference

Color Structure
Color Members
Overload List


FromArgb(Int32,Int32,Int32,Int32) Method

FromArgb(Int32,Int32,Int32,Int32) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure > FromArgb Method : FromArgb(Int32,Int32,Int32,Int32) Method
Creates new color from color components.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromArgb( _
   ByVal a As System.Integer, _
   ByVal r As System.Integer, _
   ByVal g As System.Integer, _
   ByVal b As System.Integer _
) As Color
public static Color FromArgb(
   System.int a,
   System.int r,
   System.int g,
   System.int b
)

Parameters

a
r
g
b
See Also

Reference

Color Structure
Color Members
Overload List


GetHashCode Method (Color)

GetHashCode Method (Color)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : GetHashCode Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()
See Also

Reference

Color Structure
Color Members


ToArgb Method (Color)

ToArgb Method (Color)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : ToArgb Method
Gets ARGB value of the color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToArgb() As System.Integer
public System.int ToArgb()
See Also

Reference

Color Structure
Color Members


Color Structure Properties

Color Structure Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : Color Structure

For a list of all members of this type, see Color members.

Public Properties
 | Name | Description
Public Property | A | Gets the A color component.
Public Property | B | Gets the B color component.
Public Property | G | Gets the G color component.
Public Property | IsEmpty | Gets a value indicating whether this instance is empty.
Public Property | R | Gets the R color component.
Public Property | Value | Gets the value.
Top
See Also

Reference

Color Structure
GrapeCity.Viewer.Common Namespace


A Property (Color)

A Property (Color)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : A Property
Gets the A color component.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property A As System.Byte
public System.byte A {get;}
See Also

Reference

Color Structure
Color Members


B Property (Color)

B Property (Color)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : B Property
Gets the B color component.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property B As System.Byte
public System.byte B {get;}
See Also

Reference

Color Structure
Color Members


G Property (Color)

G Property (Color)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : G Property
Gets the G color component.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property G As System.Byte
public System.byte G {get;}
See Also

Reference

Color Structure
Color Members


IsEmpty Property (Color)

IsEmpty Property (Color)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : IsEmpty Property
Gets a value indicating whether this instance is empty.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsEmpty As System.Boolean
public System.bool IsEmpty {get;}

Property Value

true if this instance is empty; otherwise, false.
See Also

Reference

Color Structure
Color Members


R Property (Color)

R Property (Color)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : R Property
Gets the R color component.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property R As System.Byte
public System.byte R {get;}
See Also

Reference

Color Structure
Color Members


Value Property (Color)

Value Property (Color)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Value Property
Gets the value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Value As System.Long
public System.long Value {get;}
See Also

Reference

Color Structure
Color Members


Color Structure Fields

Color Structure Fields

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : Color Structure

For a list of all members of this type, see Color members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Black |
static (Shared in Visual Basic) | Blue |
static (Shared in Visual Basic) | DarkBlue |
static (Shared in Visual Basic) | Empty |
static (Shared in Visual Basic) | Gray |
static (Shared in Visual Basic) | Red |
static (Shared in Visual Basic) | Transparent |
static (Shared in Visual Basic) | White |
Top
See Also

Reference

Color Structure
GrapeCity.Viewer.Common Namespace


Black Field (Color)

Black Field (Color)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Black Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Black As Color
public static readonly Color Black
See Also

Reference

Color Structure
Color Members


Blue Field (Color)

Blue Field (Color)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Blue Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Blue As Color
public static readonly Color Blue
See Also

Reference

Color Structure
Color Members


DarkBlue Field (Color)

DarkBlue Field (Color)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : DarkBlue Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly DarkBlue As Color
public static readonly Color DarkBlue
See Also

Reference

Color Structure
Color Members


Empty Field (Color)

Empty Field (Color)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Empty Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Empty As Color
public static readonly Color Empty
See Also

Reference

Color Structure
Color Members


Gray Field (Color)

Gray Field (Color)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Gray Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Gray As Color
public static readonly Color Gray
See Also

Reference

Color Structure
Color Members


Red Field (Color)

Red Field (Color)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Red Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Red As Color
public static readonly Color Red
See Also

Reference

Color Structure
Color Members


Transparent Field (Color)

Transparent Field (Color)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Transparent Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Transparent As Color
public static readonly Color Transparent
See Also

Reference

Color Structure
Color Members


White Field (Color)

White Field (Color)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : White Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly White As Color
public static readonly Color White
See Also

Reference

Color Structure
Color Members


Equality Operator (Color)

Equality Operator (Color)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Equality Operator
The color1.
The color2.
Implements the operator ==.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator =( _
   ByVal color1 As Color, _
   ByVal color2 As Color _
) As System.Boolean
public System.bool operator ==(
   Color color1,
   Color color2
)

Parameters

color1
The color1.
color2
The color2.

Return Value

The result of the operator.
See Also

Reference

Color Structure
Color Members


Implicit Type Conversion Operator (Color)

Implicit Type Conversion Operator (Color)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Implicit Type Conversion Operator
The color.
Performs an implicit conversion from Color to System.UInt32.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator Widening CType( _
   ByVal color As Color _
) As System.UInteger
public System.uint operator implicit(
   Color color
)

Parameters

color
The color.

Return Value

The result of the conversion.
See Also

Reference

Color Structure
Color Members


Inequality Operator (Color)

Inequality Operator (Color)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Inequality Operator
The color1.
The color2.
Implements the operator !=.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator <>( _
   ByVal color1 As Color, _
   ByVal color2 As Color _
) As System.Boolean
public System.bool operator !=(
   Color color1,
   Color color2
)

Parameters

color1
The color1.
color2
The color2.

Return Value

The result of the operator.
See Also

Reference

Color Structure
Color Members


Margin Structure

Margin Structure
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : Margin Structure
Stores page margins
Object Model
Margin Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure Margin
   Inherits System.ValueType
public struct Margin : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Viewer.Common.Margin

See Also

Reference

Margin Members
GrapeCity.Viewer.Common Namespace


Margin Structure Members

Margin Structure Members
Fields Properties Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : Margin Structure

The following tables list the members exposed by Margin.

Public Constructors
 | Name | Description
Public Constructor | Margin Constructor | Ctor
Top
Public Fields
 | Name | Description
Public Field | Bottom |
static (Shared in Visual Basic) | Empty |
Public Field | Left |
Public Field | Right |
Public Field | Top |
Top
Public Properties
 | Name | Description
Public Property | Horizontal |
Public Property | Vertical |
Top
Public Methods
 | Name | Description
Public Method | Equals |
Top
See Also

Reference

Margin Structure
GrapeCity.Viewer.Common Namespace


Margin Constructor

Margin Constructor

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Margin Constructor
Left margin
Right margin
Top margin
Bottom margin
Ctor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal left As System.Single, _
   ByVal right As System.Single, _
   ByVal top As System.Single, _
   ByVal bottom As System.Single _
)
public Margin(
   System.float left,
   System.float right,
   System.float top,
   System.float bottom
)

Parameters

left
Left margin
right
Right margin
top
Top margin
bottom
Bottom margin
See Also

Reference

Margin Structure
Margin Members


Margin Structure Methods

Margin Structure Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : Margin Structure

For a list of all members of this type, see Margin members.

Public Methods
 | Name | Description
Public Method | Equals |
Top
See Also

Reference

Margin Structure
GrapeCity.Viewer.Common Namespace


Equals Method (Margin)

Equals Method (Margin)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Equals Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
See Also

Reference

Margin Structure
Margin Members


Margin Structure Properties

Margin Structure Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : Margin Structure

For a list of all members of this type, see Margin members.

Public Properties
 | Name | Description
Public Property | Horizontal |
Public Property | Vertical |
Top
See Also

Reference

Margin Structure
GrapeCity.Viewer.Common Namespace


Horizontal Property (Margin)

Horizontal Property (Margin)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Horizontal Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Horizontal As System.Single
public System.float Horizontal {get;}
See Also

Reference

Margin Structure
Margin Members


Vertical Property (Margin)

Vertical Property (Margin)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Vertical Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Vertical As System.Single
public System.float Vertical {get;}
See Also

Reference

Margin Structure
Margin Members


Margin Structure Fields

Margin Structure Fields

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : Margin Structure

For a list of all members of this type, see Margin members.

Public Fields
 | Name | Description
Public Field | Bottom |
static (Shared in Visual Basic) | Empty |
Public Field | Left |
Public Field | Right |
Public Field | Top |
Top
See Also

Reference

Margin Structure
GrapeCity.Viewer.Common Namespace


Bottom Field (Margin)

Bottom Field (Margin)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Bottom Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Bottom As System.Single
public readonly System.float Bottom
See Also

Reference

Margin Structure
Margin Members


Empty Field (Margin)

Empty Field (Margin)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Empty Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Empty As Margin
public static Margin Empty
See Also

Reference

Margin Structure
Margin Members


Left Field (Margin)

Left Field (Margin)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Left Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Left As System.Single
public readonly System.float Left
See Also

Reference

Margin Structure
Margin Members


Right Field (Margin)

Right Field (Margin)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Right Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Right As System.Single
public readonly System.float Right
See Also

Reference

Margin Structure
Margin Members


Top Field (Margin)

Top Field (Margin)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Margin Structure : Top Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Top As System.Single
public readonly System.float Top
See Also

Reference

Margin Structure
Margin Members


Point Structure

Point Structure
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : Point Structure
Platform independent point
Object Model
Point Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure Point
   Inherits System.ValueType
public struct Point : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Viewer.Common.Point

See Also

Reference

Point Members
GrapeCity.Viewer.Common Namespace


Point Structure Members

Point Structure Members
Fields Properties Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : Point Structure

The following tables list the members exposed by Point.

Public Constructors
 | Name | Description
Public Constructor | Point Constructor | Initializes a new instance of the Point class with the specified coordinates.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | Represents a Point that has X and Y values set to zero
Top
Public Properties
 | Name | Description
Public Property | X | Gets or sets the x-coordinate of this Point.
Public Property | Y | Gets or sets the y-coordinate of this Point.
Top
Public Methods
 | Name | Description
Public Method | Equals | Determines whether the specified System.Object is equal to this instance.
Public Method | GetHashCode | Returns a hash code for this instance.
Public Method | Offset | Overloaded. Adjusts the location of this rectangle by the specified amount.
Public Method | ToString | Returns a System.String that represents this instance.
Top
Public Operators
public Operator Addition | Translates a Point by a given Size.
public Operator Unary Negation | Multiplies the point coordinates by -1.
Top
See Also

Reference

Point Structure
GrapeCity.Viewer.Common Namespace


Point Constructor

Point Constructor

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : Point Constructor
The horizontal position of the point.
The vertical position of the point.
Initializes a new instance of the Point class with the specified coordinates.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal x As System.Double, _
   ByVal y As System.Double _
)
public Point(
   System.double x,
   System.double y
)

Parameters

x
The horizontal position of the point.
y
The vertical position of the point.
See Also

Reference

Point Structure
Point Members


Point Structure Methods

Point Structure Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : Point Structure

For a list of all members of this type, see Point members.

Public Methods
 | Name | Description
Public Method | Equals | Determines whether the specified System.Object is equal to this instance.
Public Method | GetHashCode | Returns a hash code for this instance.
Public Method | Offset | Overloaded. Adjusts the location of this rectangle by the specified amount.
Public Method | ToString | Returns a System.String that represents this instance.
Top
See Also

Reference

Point Structure
GrapeCity.Viewer.Common Namespace


Equals Method (Point)

Equals Method (Point)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : Equals Method
Determines whether the specified System.Object is equal to this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
See Also

Reference

Point Structure
Point Members


GetHashCode Method (Point)

GetHashCode Method (Point)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : GetHashCode Method
Returns a hash code for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()
See Also

Reference

Point Structure
Point Members


Offset Method (Point)

Offset Method (Point)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : Offset Method
Adjusts the location of this rectangle by the specified amount.
Overload List
Overload | Description
Offset(Double,Double) | Adjusts the location of this rectangle by the specified amount.
Offset(Size) | Adjusts the location of this rectangle by the specified amount.
See Also

Reference

Point Structure
Point Members


Offset(Double,Double) Method

Offset(Double,Double) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Point Structure > Offset Method : Offset(Double,Double) Method
The horizontal offset.
The vertical offset.
Adjusts the location of this rectangle by the specified amount.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Offset( _
   ByVal x As System.Double, _
   ByVal y As System.Double _
) As Point
public Point Offset(
   System.double x,
   System.double y
)

Parameters

x
The horizontal offset.
y
The vertical offset.
See Also

Reference

Point Structure
Point Members
Overload List


Offset(Size) Method

Offset(Size) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Point Structure > Offset Method : Offset(Size) Method
Amount to offset the location.
Adjusts the location of this rectangle by the specified amount.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Offset( _
   ByVal offset As Size _
) As Point
public Point Offset(
   Size offset
)

Parameters

offset
Amount to offset the location.
See Also

Reference

Point Structure
Point Members
Overload List


ToString Method (Point)

ToString Method (Point)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : ToString Method
Returns a System.String that represents this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()

Return Value

A System.String that represents this instance.
See Also

Reference

Point Structure
Point Members


Point Structure Properties

Point Structure Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : Point Structure

For a list of all members of this type, see Point members.

Public Properties
 | Name | Description
Public Property | X | Gets or sets the x-coordinate of this Point.
Public Property | Y | Gets or sets the y-coordinate of this Point.
Top
See Also

Reference

Point Structure
GrapeCity.Viewer.Common Namespace


X Property (Point)

X Property (Point)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : X Property
Gets or sets the x-coordinate of this Point.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property X As System.Double
public System.double X {get;}
See Also

Reference

Point Structure
Point Members


Y Property (Point)

Y Property (Point)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : Y Property
Gets or sets the y-coordinate of this Point.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Y As System.Double
public System.double Y {get;}
See Also

Reference

Point Structure
Point Members


Point Structure Fields

Point Structure Fields

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : Point Structure

For a list of all members of this type, see Point members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty | Represents a Point that has X and Y values set to zero
Top
See Also

Reference

Point Structure
GrapeCity.Viewer.Common Namespace


Empty Field (Point)

Empty Field (Point)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : Empty Field
Represents a Point that has X and Y values set to zero
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Empty As Point
public static readonly Point Empty
See Also

Reference

Point Structure
Point Members


Addition Operator (Point)

Addition Operator (Point)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : Addition Operator
The Point to translate.
A Size that specifies the pair of numbers to add to the coordinates of pt.
Translates a Point by a given Size.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator +( _
   ByVal p1 As Point, _
   ByVal sz As Size _
) As Point
public Point operator +(
   Point p1,
   Size sz
)

Parameters

p1
The Point to translate.
sz
A Size that specifies the pair of numbers to add to the coordinates of pt.

Return Value

The translated Point.
See Also

Reference

Point Structure
Point Members


Unary Negation Operator (Point)

Unary Negation Operator (Point)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Point Structure : Unary Negation Operator
Multiplies the point coordinates by -1.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator -( _
   ByVal pt As Point _
) As Point
public Point operator -(
   Point pt
)

Parameters

pt
See Also

Reference

Point Structure
Point Members


Rect Structure

Rect Structure
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : Rect Structure
Platform aware rectangle structure
Object Model
Rect Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure Rect
   Inherits System.ValueType
public struct Rect : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Viewer.Common.Rect

See Also

Reference

Rect Members
GrapeCity.Viewer.Common Namespace


Rect Structure Members

Rect Structure Members
Fields Properties Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : Rect Structure

The following tables list the members exposed by Rect.

Public Constructors
 | Name | Description
Public Constructor | Rect Constructor | Overloaded.
Top
Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty |
Top
Public Properties
 | Name | Description
Public Property | Bottom | Gets the y-coordinate of the bottom edge of this rectangle.
Public Property | Height | Gets or sets the height of this rectangle.
Public Property | IsEmpty | Tests whether the size of this rectangle less or equal 0.
Public Property | Left | Gets the x-coordinate of the left edge of this rectangle.
Public Property | Location | Gets or sets the coordinates of the upper-left corner of this rectangle.
Public Property | Right | Gets the x-coordinate of the right edge of this rectangle.
Public Property | Size | Gets or sets the size of this rectangle.
Public Property | Top | Gets the y-coordinate of the top edge of this rectangle.
Public Property | Width | Gets or sets the width of this rectangle.
Public Property | X | Gets or sets the x-coordinate of the upper-left corner of this rectangle.
Public Property | Y | Gets or sets the y-coordinate of the upper-left corner of this rectangle.
Top
Public Methods
 | Name | Description
Public Method | Contains | Overloaded. Determines if the specified point is contained within this rectangle.
Public Method | Equals | Determines whether the specified System.Object is equal to this instance.
static (Shared in Visual Basic) | FromLTRB | Creates a Rect with the specified edge locations.
Public Method | GetHashCode | Returns a hash code for this instance.
Public Method | Inflate | Overloaded. Enlarges this Rect by the specified amount.
Public Method | Intersect | Overloaded. Replaces this Rect with the intersection of itself and the specified Rect.
Public Method | IntersectsWith | Determines if this rectangle intersects with specified rectangle.
Public Method | Offset | Overloaded. Adjusts the location of this rectangle by the specified amount.
Public Method | Scale | Overloaded. Scales the rectangle by specified scale factor.
Public Method | ToString | Returns a System.String that represents this instance.
static (Shared in Visual Basic) | Union | Creates a Rect structure that contains the union of two Rect structures.
Top
See Also

Reference

Rect Structure
GrapeCity.Viewer.Common Namespace


Rect Constructor

Rect Constructor

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Rect Constructor
Overload List
Overload | Description
Rect Constructor(Double,Double,Double,Double) | Initializes a new instance of the Rect class with the specified location and size.
Rect Constructor(Point,Size) | Initializes a new instance of the Rect class with the specified location and size.
See Also

Reference

Rect Structure
Rect Members


Rect Constructor(Double,Double,Double,Double)

Rect Constructor(Double,Double,Double,Double)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Rect Constructor : Rect Constructor(Double,Double,Double,Double)
The x-coordinate of the upper-left corner of the rectangle.
The y-coordinate of the upper-left corner of the rectangle.
The width of the rectangle.
The height of the rectangle.
Initializes a new instance of the Rect class with the specified location and size.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal x As System.Double, _
   ByVal y As System.Double, _
   ByVal width As System.Double, _
   ByVal height As System.Double _
)
public Rect(
   System.double x,
   System.double y,
   System.double width,
   System.double height
)

Parameters

x
The x-coordinate of the upper-left corner of the rectangle.
y
The y-coordinate of the upper-left corner of the rectangle.
width
The width of the rectangle.
height
The height of the rectangle.
See Also

Reference

Rect Structure
Rect Members
Overload List


Rect Constructor(Point,Size)

Rect Constructor(Point,Size)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Rect Constructor : Rect Constructor(Point,Size)
A Point that represents the upper-left corner of the rectangle.
A Rect.Size that represents the width and height of the rectangle.
Initializes a new instance of the Rect class with the specified location and size.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal location As Point, _
   ByVal size As Size _
)
public Rect(
   Point location,
   Size size
)

Parameters

location
A Point that represents the upper-left corner of the rectangle.
size
A Rect.Size that represents the width and height of the rectangle.
See Also

Reference

Rect Structure
Rect Members
Overload List


Rect Structure Methods

Rect Structure Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : Rect Structure

For a list of all members of this type, see Rect members.

Public Methods
 | Name | Description
Public Method | Contains | Overloaded. Determines if the specified point is contained within this rectangle.
Public Method | Equals | Determines whether the specified System.Object is equal to this instance.
static (Shared in Visual Basic) | FromLTRB | Creates a Rect with the specified edge locations.
Public Method | GetHashCode | Returns a hash code for this instance.
Public Method | Inflate | Overloaded. Enlarges this Rect by the specified amount.
Public Method | Intersect | Overloaded. Replaces this Rect with the intersection of itself and the specified Rect.
Public Method | IntersectsWith | Determines if this rectangle intersects with specified rectangle.
Public Method | Offset | Overloaded. Adjusts the location of this rectangle by the specified amount.
Public Method | Scale | Overloaded. Scales the rectangle by specified scale factor.
Public Method | ToString | Returns a System.String that represents this instance.
static (Shared in Visual Basic) | Union | Creates a Rect structure that contains the union of two Rect structures.
Top
See Also

Reference

Rect Structure
GrapeCity.Viewer.Common Namespace


Contains Method (Rect)

Contains Method (Rect)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Contains Method
Determines if the specified point is contained within this rectangle.
Overload List
Overload | Description
Contains(Double,Double) | Determines if the specified point is contained within this rectangle.
Contains(Point) | Determines if the specified point is contained within this rectangle.
Contains(Rect) | Determines if the rectangular region represented by rect is entirely contained within this rectangle.
See Also

Reference

Rect Structure
Rect Members


Contains(Double,Double) Method

Contains(Double,Double) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Contains Method : Contains(Double,Double) Method
The x-coordinate of the point to test.
The y-coordinate of the point to test.
Determines if the specified point is contained within this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Contains( _
   ByVal x As System.Double, _
   ByVal y As System.Double _
) As System.Boolean
public System.bool Contains(
   System.double x,
   System.double y
)

Parameters

x
The x-coordinate of the point to test.
y
The y-coordinate of the point to test.
See Also

Reference

Rect Structure
Rect Members
Overload List


Contains(Point) Method

Contains(Point) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Contains Method : Contains(Point) Method
The Point to test.
Determines if the specified point is contained within this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Contains( _
   ByVal pt As Point _
) As System.Boolean
public System.bool Contains(
   Point pt
)

Parameters

pt
The Point to test.
See Also

Reference

Rect Structure
Rect Members
Overload List


Contains(Rect) Method

Contains(Rect) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Contains Method : Contains(Rect) Method
The Rect to test.
Determines if the rectangular region represented by rect is entirely contained within this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Contains( _
   ByVal rect As Rect _
) As System.Boolean
public System.bool Contains(
   Rect rect
)

Parameters

rect
The Rect to test.
See Also

Reference

Rect Structure
Rect Members
Overload List


Equals Method (Rect)

Equals Method (Rect)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Equals Method
Another object to compare to.
Determines whether the specified System.Object is equal to this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
Another object to compare to.

Return Value

true if the specified System.Object is equal to this instance; otherwise, false.
See Also

Reference

Rect Structure
Rect Members


FromLTRB Method (Rect)

FromLTRB Method (Rect)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : FromLTRB Method
The x-coordinate of the upper-left corner of the rectangle.
The y-coordinate of the upper-left corner of the rectangle.
The x-coordinate of the lower-right corner of the rectangle.
The y-coordinate of the lower-right corner of the rectangle
Creates a Rect with the specified edge locations.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function FromLTRB( _
   ByVal left As System.Double, _
   ByVal top As System.Double, _
   ByVal right As System.Double, _
   ByVal bottom As System.Double _
) As Rect
public static Rect FromLTRB(
   System.double left,
   System.double top,
   System.double right,
   System.double bottom
)

Parameters

left
The x-coordinate of the upper-left corner of the rectangle.
top
The y-coordinate of the upper-left corner of the rectangle.
right
The x-coordinate of the lower-right corner of the rectangle.
bottom
The y-coordinate of the lower-right corner of the rectangle
See Also

Reference

Rect Structure
Rect Members


GetHashCode Method (Rect)

GetHashCode Method (Rect)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : GetHashCode Method
Returns a hash code for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()
See Also

Reference

Rect Structure
Rect Members


Inflate Method (Rect)

Inflate Method (Rect)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Inflate Method
Enlarges this Rect by the specified amount.
Overload List
Overload | Description
Inflate(Double,Double) | Enlarges this Rect by the specified amount.
Inflate(Size) | Enlarges this Rect by the specified amount.
Inflate(Rect,Single,Single) | Creates and returns an enlarged copy of the specified Rect structure. The copy is enlarged by the specified amount. The original Rect structure remains unmodified.
See Also

Reference

Rect Structure
Rect Members


Inflate(Double,Double) Method

Inflate(Double,Double) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Inflate Method : Inflate(Double,Double) Method
The amount to inflate this Rect horizontally.
The amount to inflate this Rect vertically.
Enlarges this Rect by the specified amount.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Inflate( _
   ByVal x As System.Double, _
   ByVal y As System.Double _
) As Rect
public Rect Inflate(
   System.double x,
   System.double y
)

Parameters

x
The amount to inflate this Rect horizontally.
y
The amount to inflate this Rect vertically.
See Also

Reference

Rect Structure
Rect Members
Overload List


Inflate(Size) Method

Inflate(Size) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Inflate Method : Inflate(Size) Method
The amount to inflate this rectangle.
Enlarges this Rect by the specified amount.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Inflate( _
   ByVal size As Size _
) As Rect
public Rect Inflate(
   Size size
)

Parameters

size
The amount to inflate this rectangle.
See Also

Reference

Rect Structure
Rect Members
Overload List


Inflate(Rect,Single,Single) Method

Inflate(Rect,Single,Single) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Inflate Method : Inflate(Rect,Single,Single) Method
The Rect with which to start. This rectangle is not modified.
The amount to inflate the rectangle horizontally.
The amount to inflate the rectangle vertically.
Creates and returns an enlarged copy of the specified Rect structure. The copy is enlarged by the specified amount. The original Rect structure remains unmodified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Inflate( _
   ByVal rect As Rect, _
   ByVal x As System.Single, _
   ByVal y As System.Single _
) As Rect
public static Rect Inflate(
   Rect rect,
   System.float x,
   System.float y
)

Parameters

rect
The Rect with which to start. This rectangle is not modified.
x
The amount to inflate the rectangle horizontally.
y
The amount to inflate the rectangle vertically.

Return Value

Rect.
See Also

Reference

Rect Structure
Rect Members
Overload List


Intersect Method (Rect)

Intersect Method (Rect)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Intersect Method
Replaces this Rect with the intersection of itself and the specified Rect.
Overload List
Overload | Description
Intersect(Rect) | Replaces this Rect with the intersection of itself and the specified Rect.
Intersect(Rect,Rect) | Returns a third Rect structure that represents the intersection of two other Rect structures. If there is no intersection, an empty Rect is returned.
See Also

Reference

Rect Structure
Rect Members


Intersect(Rect) Method

Intersect(Rect) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Intersect Method : Intersect(Rect) Method
The Rect with which to intersect.
Replaces this Rect with the intersection of itself and the specified Rect.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Intersect( _
   ByVal rect As Rect _
) As Rect
public Rect Intersect(
   Rect rect
)

Parameters

rect
The Rect with which to intersect.
See Also

Reference

Rect Structure
Rect Members
Overload List


Intersect(Rect,Rect) Method

Intersect(Rect,Rect) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Intersect Method : Intersect(Rect,Rect) Method
A rectangle to intersect.
A rectangle to intersect.
Returns a third Rect structure that represents the intersection of two other Rect structures. If there is no intersection, an empty Rect is returned.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Intersect( _
   ByVal a As Rect, _
   ByVal b As Rect _
) As Rect
public static Rect Intersect(
   Rect a,
   Rect b
)

Parameters

a
A rectangle to intersect.
b
A rectangle to intersect.

Return Value

Rect.
See Also

Reference

Rect Structure
Rect Members
Overload List


IntersectsWith Method (Rect)

IntersectsWith Method (Rect)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : IntersectsWith Method
The rectangle to test.
Determines if this rectangle intersects with specified rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IntersectsWith( _
   ByVal rect As Rect _
) As System.Boolean
public System.bool IntersectsWith(
   Rect rect
)

Parameters

rect
The rectangle to test.

Return Value

This method returns true if there is any intersection, otherwise false.
See Also

Reference

Rect Structure
Rect Members


Offset Method (Rect)

Offset Method (Rect)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Offset Method
Adjusts the location of this rectangle by the specified amount.
Overload List
Overload | Description
Offset(Point) | Adjusts the location of this rectangle by the specified amount.
Offset(Double,Double) | Adjusts the location of this rectangle by the specified amount.
See Also

Reference

Rect Structure
Rect Members


Offset(Point) Method

Offset(Point) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Offset Method : Offset(Point) Method
Amount to offset the location.
Adjusts the location of this rectangle by the specified amount.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Offset( _
   ByVal pos As Point _
) As Rect
public Rect Offset(
   Point pos
)

Parameters

pos
Amount to offset the location.

Return Value

Rect.
See Also

Reference

Rect Structure
Rect Members
Overload List


Offset(Double,Double) Method

Offset(Double,Double) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Offset Method : Offset(Double,Double) Method
The horizontal offset.
The vertical offset.
Adjusts the location of this rectangle by the specified amount.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Offset( _
   ByVal x As System.Double, _
   ByVal y As System.Double _
) As Rect
public Rect Offset(
   System.double x,
   System.double y
)

Parameters

x
The horizontal offset.
y
The vertical offset.
See Also

Reference

Rect Structure
Rect Members
Overload List


Scale Method (Rect)

Scale Method (Rect)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Scale Method
Scales the rectangle by specified scale factor.
Overload List
Overload | Description
Scale(Double) | Scales the rectangle by specified scale factor.
Scale(Double,Double) | Scales the rectangle by specified scale factors.
See Also

Reference

Rect Structure
Rect Members


Scale(Double) Method

Scale(Double) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Scale Method : Scale(Double) Method
Scales the rectangle by specified scale factor.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Scale( _
   ByVal scaleFactor As System.Double _
) As Rect
public Rect Scale(
   System.double scaleFactor
)

Parameters

scaleFactor
See Also

Reference

Rect Structure
Rect Members
Overload List


Scale(Double,Double) Method

Scale(Double,Double) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure > Scale Method : Scale(Double,Double) Method
Scales the rectangle by specified scale factors.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Scale( _
   ByVal scaleX As System.Double, _
   ByVal scaleY As System.Double _
) As Rect
public Rect Scale(
   System.double scaleX,
   System.double scaleY
)

Parameters

scaleX
scaleY
See Also

Reference

Rect Structure
Rect Members
Overload List


ToString Method (Rect)

ToString Method (Rect)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : ToString Method
Returns a System.String that represents this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()
See Also

Reference

Rect Structure
Rect Members


Union Method (Rect)

Union Method (Rect)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Union Method
A rectangle to union.
A rectangle to union.
Creates a Rect structure that contains the union of two Rect structures.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function Union( _
   ByVal a As Rect, _
   ByVal b As Rect _
) As Rect
public static Rect Union(
   Rect a,
   Rect b
)

Parameters

a
A rectangle to union.
b
A rectangle to union.

Return Value

A rectangle that bounds the union of the two rectangles.
See Also

Reference

Rect Structure
Rect Members


Rect Structure Properties

Rect Structure Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : Rect Structure

For a list of all members of this type, see Rect members.

Public Properties
 | Name | Description
Public Property | Bottom | Gets the y-coordinate of the bottom edge of this rectangle.
Public Property | Height | Gets or sets the height of this rectangle.
Public Property | IsEmpty | Tests whether the size of this rectangle less or equal 0.
Public Property | Left | Gets the x-coordinate of the left edge of this rectangle.
Public Property | Location | Gets or sets the coordinates of the upper-left corner of this rectangle.
Public Property | Right | Gets the x-coordinate of the right edge of this rectangle.
Public Property | Size | Gets or sets the size of this rectangle.
Public Property | Top | Gets the y-coordinate of the top edge of this rectangle.
Public Property | Width | Gets or sets the width of this rectangle.
Public Property | X | Gets or sets the x-coordinate of the upper-left corner of this rectangle.
Public Property | Y | Gets or sets the y-coordinate of the upper-left corner of this rectangle.
Top
See Also

Reference

Rect Structure
GrapeCity.Viewer.Common Namespace


Bottom Property (Rect)

Bottom Property (Rect)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Bottom Property
Gets the y-coordinate of the bottom edge of this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Bottom As System.Double
public System.double Bottom {get;}
See Also

Reference

Rect Structure
Rect Members


Height Property (Rect)

Height Property (Rect)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Height Property
Gets or sets the height of this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Height As System.Double
public System.double Height {get;}
See Also

Reference

Rect Structure
Rect Members


IsEmpty Property (Rect)

IsEmpty Property (Rect)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : IsEmpty Property
Tests whether the size of this rectangle less or equal 0.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsEmpty As System.Boolean
public System.bool IsEmpty {get;}
See Also

Reference

Rect Structure
Rect Members


Left Property (Rect)

Left Property (Rect)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Left Property
Gets the x-coordinate of the left edge of this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Left As System.Double
public System.double Left {get;}
See Also

Reference

Rect Structure
Rect Members


Location Property (Rect)

Location Property (Rect)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Location Property
Gets or sets the coordinates of the upper-left corner of this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Location As Point
public Point Location {get;}

Property Value

The location.
See Also

Reference

Rect Structure
Rect Members


Right Property (Rect)

Right Property (Rect)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Right Property
Gets the x-coordinate of the right edge of this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Right As System.Double
public System.double Right {get;}
See Also

Reference

Rect Structure
Rect Members


Size Property (Rect)

Size Property (Rect)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Size Property
Gets or sets the size of this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Size As Size
public Size Size {get;}

Property Value

The size.
See Also

Reference

Rect Structure
Rect Members


Top Property (Rect)

Top Property (Rect)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Top Property
Gets the y-coordinate of the top edge of this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Top As System.Double
public System.double Top {get;}
See Also

Reference

Rect Structure
Rect Members


Width Property (Rect)

Width Property (Rect)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Width Property
Gets or sets the width of this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Width As System.Double
public System.double Width {get;}
See Also

Reference

Rect Structure
Rect Members


X Property (Rect)

X Property (Rect)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : X Property
Gets or sets the x-coordinate of the upper-left corner of this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property X As System.Double
public System.double X {get;}

Property Value

The x.
See Also

Reference

Rect Structure
Rect Members


Y Property (Rect)

Y Property (Rect)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Y Property
Gets or sets the y-coordinate of the upper-left corner of this rectangle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Y As System.Double
public System.double Y {get;}

Property Value

The y.
See Also

Reference

Rect Structure
Rect Members


Rect Structure Fields

Rect Structure Fields

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : Rect Structure

For a list of all members of this type, see Rect members.

Public Fields
 | Name | Description
static (Shared in Visual Basic) | Empty |
Top
See Also

Reference

Rect Structure
GrapeCity.Viewer.Common Namespace


Empty Field (Rect)

Empty Field (Rect)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Rect Structure : Empty Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Empty As Rect
public static readonly Rect Empty
See Also

Reference

Rect Structure
Rect Members


Size Structure

Size Structure
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : Size Structure
Platform aware Size structure
Object Model
Size Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure Size
   Inherits System.ValueType
public struct Size : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
GrapeCity.Viewer.Common.Size

See Also

Reference

Size Members
GrapeCity.Viewer.Common Namespace


Size Structure Members

Size Structure Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : Size Structure

The following tables list the members exposed by Size.

Public Constructors
 | Name | Description
Public Constructor | Size Constructor | Initializes a new instance of the Size struct.
Top
Public Properties
 | Name | Description
static (Shared in Visual Basic) | Empty | Gets the size with zero width and height.
Public Property | Height | Gets the height.
Public Property | Width | Gets the width.
Top
Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Checks whether this size equals to specified.
Public Method | GetHashCode | Returns a hash code for this instance.
Public Method | Scale | Scales the size by specified values.
Public Method | ToString | Returns a System.String that represents this instance.
Top
Public Operators
public Operator Addition | Enlarge the size by specified value.
public Operator Equality | Checks whether the two sizes are equals.
public Operator Inequality | Check whether the two sizes are not equals.
public Operator Multiplication | Scales the size by specified value
Top
See Also

Reference

Size Structure
GrapeCity.Viewer.Common Namespace


Size Constructor

Size Constructor

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Size Constructor
Initializes a new instance of the Size struct.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal width As System.Double, _
   ByVal height As System.Double _
)
public Size(
   System.double width,
   System.double height
)

Parameters

width
height
See Also

Reference

Size Structure
Size Members


Size Structure Methods

Size Structure Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : Size Structure

For a list of all members of this type, see Size members.

Public Methods
 | Name | Description
Public Method | Equals | Overloaded. Checks whether this size equals to specified.
Public Method | GetHashCode | Returns a hash code for this instance.
Public Method | Scale | Scales the size by specified values.
Public Method | ToString | Returns a System.String that represents this instance.
Top
See Also

Reference

Size Structure
GrapeCity.Viewer.Common Namespace


Equals Method (Size)

Equals Method (Size)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Equals Method
Checks whether this size equals to specified.
Overload List
Overload | Description
Equals(Object) |
Equals(Size) | Checks whether this size equals to specified.
See Also

Reference

Size Structure
Size Members


Equals(Object) Method

Equals(Object) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure > Equals Method : Equals(Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overrides Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public override System.bool Equals(
   System.object obj
)

Parameters

obj
See Also

Reference

Size Structure
Size Members
Overload List


Equals(Size) Method

Equals(Size) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure > Equals Method : Equals(Size) Method
Checks whether this size equals to specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Equals( _
   ByVal other As Size _
) As System.Boolean
public System.bool Equals(
   Size other
)

Parameters

other
See Also

Reference

Size Structure
Size Members
Overload List


GetHashCode Method (Size)

GetHashCode Method (Size)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : GetHashCode Method
Returns a hash code for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function GetHashCode() As System.Integer
public override System.int GetHashCode()

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

Size Structure
Size Members


Scale Method (Size)

Scale Method (Size)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Scale Method
The width scaling factor.
The height scaling factor.
Scales the size by specified values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Scale( _
   ByVal factorX As System.Double, _
   ByVal factorY As System.Double _
) As Size
public Size Scale(
   System.double factorX,
   System.double factorY
)

Parameters

factorX
The width scaling factor.
factorY
The height scaling factor.

Return Value

Size.
See Also

Reference

Size Structure
Size Members


ToString Method (Size)

ToString Method (Size)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : ToString Method
Returns a System.String that represents this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As System.String
public override System.string ToString()
See Also

Reference

Size Structure
Size Members


Size Structure Properties

Size Structure Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : Size Structure

For a list of all members of this type, see Size members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | Empty | Gets the size with zero width and height.
Public Property | Height | Gets the height.
Public Property | Width | Gets the width.
Top
See Also

Reference

Size Structure
GrapeCity.Viewer.Common Namespace


Empty Property (Size)

Empty Property (Size)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Empty Property
Gets the size with zero width and height.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property Empty As Size
public static Size Empty {get;}
See Also

Reference

Size Structure
Size Members


Height Property (Size)

Height Property (Size)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Height Property
Gets the height.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Height As System.Double
public System.double Height {get;}
See Also

Reference

Size Structure
Size Members


Width Property (Size)

Width Property (Size)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Width Property
Gets the width.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Width As System.Double
public System.double Width {get;}
See Also

Reference

Size Structure
Size Members


Addition Operator (Size)

Addition Operator (Size)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Addition Operator
The size to enlarge.
The offset.
Enlarge the size by specified value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator +( _
   ByVal size As Size, _
   ByVal offset As Size _
) As Size
public Size operator +(
   Size size,
   Size offset
)

Parameters

size
The size to enlarge.
offset
The offset.
See Also

Reference

Size Structure
Size Members


Equality Operator (Size)

Equality Operator (Size)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Equality Operator
Checks whether the two sizes are equals.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator =( _
   ByVal s1 As Size, _
   ByVal s2 As Size _
) As System.Boolean
public System.bool operator ==(
   Size s1,
   Size s2
)

Parameters

s1
s2
See Also

Reference

Size Structure
Size Members


Inequality Operator (Size)

Inequality Operator (Size)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Inequality Operator
Check whether the two sizes are not equals.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator <>( _
   ByVal s1 As Size, _
   ByVal s2 As Size _
) As System.Boolean
public System.bool operator !=(
   Size s1,
   Size s2
)

Parameters

s1
s2
See Also

Reference

Size Structure
Size Members


Multiplication Operator (Size)

Multiplication Operator (Size)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Size Structure : Multiplication Operator
Scales the size by specified value
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator *( _
   ByVal size As Size, _
   ByVal factor As System.Double _
) As Size
public Size operator *(
   Size size,
   System.double factor
)

Parameters

size
factor
See Also

Reference

Size Structure
Size Members


IApplicationContext Interface

IApplicationContext Interface
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IApplicationContext Interface
Provides access to different services and factories
Object Model
IApplicationContext Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IApplicationContext
public interface IApplicationContext
See Also

Reference

IApplicationContext Members
GrapeCity.Viewer.Common Namespace


IApplicationContext Interface Members

IApplicationContext Interface Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IApplicationContext Interface

The following tables list the members exposed by IApplicationContext.

Public Properties
 | Name | Description
Property | Context | Gets the synchronization context.
Property | ServiceContainer | Gets service container
Top
Public Methods
 | Name | Description
Method | CreateRenderer | Overloaded. Creates page renderer for specific document
Method | CreateReport | Creates loader for documents with specific formats
Top
See Also

Reference

IApplicationContext Interface
GrapeCity.Viewer.Common Namespace


IApplicationContext Interface Methods

IApplicationContext Interface Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IApplicationContext Interface

For a list of all members of this type, see IApplicationContext members.

Public Methods
 | Name | Description
Method | CreateRenderer | Overloaded. Creates page renderer for specific document
Method | CreateReport | Creates loader for documents with specific formats
Top
See Also

Reference

IApplicationContext Interface
GrapeCity.Viewer.Common Namespace


CreateRenderer Method (IApplicationContext)

CreateRenderer Method (IApplicationContext)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IApplicationContext Interface : CreateRenderer Method
Creates page renderer for specific document
Overload List
Overload | Description
CreateRenderer(DocumentModel) | Creates page renderer for specific document
CreateRenderer(DocumentModel,DeviceKind) | Creates the renderer for specific document considering specific target device kind.
See Also

Reference

IApplicationContext Interface
IApplicationContext Members


CreateRenderer(DocumentModel) Method

CreateRenderer(DocumentModel) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IApplicationContext Interface > CreateRenderer Method : CreateRenderer(DocumentModel) Method
Document for rendering
Creates page renderer for specific document
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function CreateRenderer( _
   ByVal document As DocumentModel _
) As IDocumentRenderer
IDocumentRenderer CreateRenderer(
   DocumentModel document
)

Parameters

document
Document for rendering

Return Value

Newly created renderer
See Also

Reference

IApplicationContext Interface
IApplicationContext Members
Overload List


CreateRenderer(DocumentModel,DeviceKind) Method

CreateRenderer(DocumentModel,DeviceKind) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IApplicationContext Interface > CreateRenderer Method : CreateRenderer(DocumentModel,DeviceKind) Method
The document model.
The target device kind.
Creates the renderer for specific document considering specific target device kind.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function CreateRenderer( _
   ByVal document As DocumentModel, _
   ByVal device As DeviceKind _
) As IDocumentRenderer
IDocumentRenderer CreateRenderer(
   DocumentModel document,
   DeviceKind device
)

Parameters

document
The document model.
device
The target device kind.
See Also

Reference

IApplicationContext Interface
IApplicationContext Members
Overload List


CreateReport Method (IApplicationContext)

CreateReport Method (IApplicationContext)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IApplicationContext Interface : CreateReport Method
Format of the document
Creates loader for documents with specific formats
Syntax
  • Visual Basic
  • C#
'Declaration

Function CreateReport( _
   ByVal format As DocumentFormat _
) As ReportModelBase
ReportModelBase CreateReport(
   DocumentFormat format
)

Parameters

format
Format of the document

Return Value

Created loader
See Also

Reference

IApplicationContext Interface
IApplicationContext Members


IApplicationContext Interface Properties

IApplicationContext Interface Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IApplicationContext Interface

For a list of all members of this type, see IApplicationContext members.

Public Properties
 | Name | Description
Property | Context | Gets the synchronization context.
Property | ServiceContainer | Gets service container
Top
See Also

Reference

IApplicationContext Interface
GrapeCity.Viewer.Common Namespace


Context Property (IApplicationContext)

Context Property (IApplicationContext)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IApplicationContext Interface : Context Property
Gets the synchronization context.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Context As System.Threading.SynchronizationContext
System.Threading.SynchronizationContext Context {get;}
See Also

Reference

IApplicationContext Interface
IApplicationContext Members


ServiceContainer Property (IApplicationContext)

ServiceContainer Property (IApplicationContext)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IApplicationContext Interface : ServiceContainer Property
Gets service container
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property ServiceContainer As IServiceContainer
IServiceContainer ServiceContainer {get;}
See Also

Reference

IApplicationContext Interface
IApplicationContext Members


ICommand Interface

ICommand Interface
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : ICommand Interface
Defines the contract for commanding, using the same contract as used in WPF.
Object Model
ICommand Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ICommand
public interface ICommand
See Also

Reference

ICommand Members
GrapeCity.Viewer.Common Namespace


ICommand Interface Members

ICommand Interface Members
Methods Events

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : ICommand Interface

The following tables list the members exposed by ICommand.

Public Methods
 | Name | Description
Method | CanExecute | Defines the method that determines whether the command can execute in its current state.
Method | Execute | Defines the method to be called when the command is invoked.
Top
Public Events
 | Name | Description
Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute.
Top
See Also

Reference

ICommand Interface
GrapeCity.Viewer.Common Namespace


ICommand Interface Methods

ICommand Interface Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : ICommand Interface

For a list of all members of this type, see ICommand members.

Public Methods
 | Name | Description
Method | CanExecute | Defines the method that determines whether the command can execute in its current state.
Method | Execute | Defines the method to be called when the command is invoked.
Top
See Also

Reference

ICommand Interface
GrapeCity.Viewer.Common Namespace


CanExecute Method (ICommand)

CanExecute Method (ICommand)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ICommand Interface : CanExecute Method
Data used by the command. If the command does not require data to be passed, this object can be set to null.
Defines the method that determines whether the command can execute in its current state.
Syntax
  • Visual Basic
  • C#
'Declaration

Function CanExecute( _
   ByVal parameter As System.Object _
) As System.Boolean
System.bool CanExecute(
   System.object parameter
)

Parameters

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.
See Also

Reference

ICommand Interface
ICommand Members


Execute Method (ICommand)

Execute Method (ICommand)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ICommand Interface : Execute Method
Data used by the command. If the command does not require data to be passed, this object can be set to null.
Defines the method to be called when the command is invoked.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Execute( _
   ByVal parameter As System.Object _
)
void Execute(
   System.object parameter
)

Parameters

parameter
Data used by the command. If the command does not require data to be passed, this object can be set to null.
See Also

Reference

ICommand Interface
ICommand Members


ICommand Interface Events

ICommand Interface Events

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : ICommand Interface

For a list of all members of this type, see ICommand members.

Public Events
 | Name | Description
Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute.
Top
See Also

Reference

ICommand Interface
GrapeCity.Viewer.Common Namespace


CanExecuteChanged Event (ICommand)

CanExecuteChanged Event (ICommand)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ICommand Interface : CanExecuteChanged Event
Occurs when changes occur that affect whether the command should execute.
Syntax
  • Visual Basic
  • C#
'Declaration

Event CanExecuteChanged As System.EventHandler
event System.EventHandler CanExecuteChanged
See Also

Reference

ICommand Interface
ICommand Members


ICopySelectionService Interface

ICopySelectionService Interface
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : ICopySelectionService Interface
Base interface for copy operations
Object Model
ICopySelectionService Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ICopySelectionService
public interface ICopySelectionService
See Also

Reference

ICopySelectionService Members
GrapeCity.Viewer.Common Namespace


ICopySelectionService Interface Members

ICopySelectionService Interface Members
Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : ICopySelectionService Interface

The following tables list the members exposed by ICopySelectionService.

Public Methods
 | Name | Description
Method | CopySelection | Copies given selection into platform specific storage
Method | CopyToClipBoard | Copies given text into clipboard
Top
See Also

Reference

ICopySelectionService Interface
GrapeCity.Viewer.Common Namespace


ICopySelectionService Interface Methods

ICopySelectionService Interface Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : ICopySelectionService Interface

For a list of all members of this type, see ICopySelectionService members.

Public Methods
 | Name | Description
Method | CopySelection | Copies given selection into platform specific storage
Method | CopyToClipBoard | Copies given text into clipboard
Top
See Also

Reference

ICopySelectionService Interface
GrapeCity.Viewer.Common Namespace


CopySelection Method (ICopySelectionService)

CopySelection Method (ICopySelectionService)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ICopySelectionService Interface : CopySelection Method
Copies given selection into platform specific storage
Syntax
  • Visual Basic
  • C#
'Declaration

Sub CopySelection( _
   ByVal selection As DocumentSelection _
)
void CopySelection(
   DocumentSelection selection
)

Parameters

selection
See Also

Reference

ICopySelectionService Interface
ICopySelectionService Members


CopyToClipBoard Method (ICopySelectionService)

CopyToClipBoard Method (ICopySelectionService)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ICopySelectionService Interface : CopyToClipBoard Method
Copies given text into clipboard
Syntax
  • Visual Basic
  • C#
'Declaration

Sub CopyToClipBoard( _
   ByVal text As System.String _
)
void CopyToClipBoard(
   System.string text
)

Parameters

text
See Also

Reference

ICopySelectionService Interface
ICopySelectionService Members


IDelegateCommand Interface

IDelegateCommand Interface
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDelegateCommand Interface
Delegated command interface
Object Model
IDelegateCommand Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDelegateCommand
   Inherits ICommand
public interface IDelegateCommand : ICommand
See Also

Reference

IDelegateCommand Members
GrapeCity.Viewer.Common Namespace


IDelegateCommand Interface Members

IDelegateCommand Interface Members
Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDelegateCommand Interface

The following tables list the members exposed by IDelegateCommand.

Public Methods
 | Name | Description
Method | CanExecute | Defines the method that determines whether the command can execute in its current state. (Inherited from GrapeCity.Viewer.Common.ICommand)
Method | Execute | Defines the method to be called when the command is invoked. (Inherited from GrapeCity.Viewer.Common.ICommand)
Method | RaiseCanExecuteChanged | Raises CanExecuteChanged event
Top
See Also

Reference

IDelegateCommand Interface
GrapeCity.Viewer.Common Namespace


IDelegateCommand Interface Methods

IDelegateCommand Interface Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDelegateCommand Interface

For a list of all members of this type, see IDelegateCommand members.

Public Methods
 | Name | Description
Method | CanExecute | Defines the method that determines whether the command can execute in its current state. (Inherited from GrapeCity.Viewer.Common.ICommand)
Method | Execute | Defines the method to be called when the command is invoked. (Inherited from GrapeCity.Viewer.Common.ICommand)
Method | RaiseCanExecuteChanged | Raises CanExecuteChanged event
Top
See Also

Reference

IDelegateCommand Interface
GrapeCity.Viewer.Common Namespace


RaiseCanExecuteChanged Method (IDelegateCommand)

RaiseCanExecuteChanged Method (IDelegateCommand)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IDelegateCommand Interface : RaiseCanExecuteChanged Method
Raises CanExecuteChanged event
Syntax
  • Visual Basic
  • C#
'Declaration

Sub RaiseCanExecuteChanged()
void RaiseCanExecuteChanged()
See Also

Reference

IDelegateCommand Interface
IDelegateCommand Members


IDocumentLoader Interface

IDocumentLoader Interface
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDocumentLoader Interface
Object Model
IDocumentLoader Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDocumentLoader
public interface IDocumentLoader
See Also

Reference

IDocumentLoader Members
GrapeCity.Viewer.Common Namespace


IDocumentLoader Interface Members

IDocumentLoader Interface Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDocumentLoader Interface

The following tables list the members exposed by IDocumentLoader.

Public Properties
 | Name | Description
Property | DocumentFormat |
Top
Public Methods
 | Name | Description
Method | Load |
Top
See Also

Reference

IDocumentLoader Interface
GrapeCity.Viewer.Common Namespace


IDocumentLoader Interface Methods

IDocumentLoader Interface Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDocumentLoader Interface

For a list of all members of this type, see IDocumentLoader members.

Public Methods
 | Name | Description
Method | Load |
Top
See Also

Reference

IDocumentLoader Interface
GrapeCity.Viewer.Common Namespace


Load Method (IDocumentLoader)

Load Method (IDocumentLoader)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IDocumentLoader Interface : Load Method
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Load( _
   ByVal obj As ILoadableFromFileAndStream _
)
void Load(
   ILoadableFromFileAndStream obj
)

Parameters

obj
See Also

Reference

IDocumentLoader Interface
IDocumentLoader Members


IDocumentLoader Interface Properties

IDocumentLoader Interface Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDocumentLoader Interface

For a list of all members of this type, see IDocumentLoader members.

Public Properties
 | Name | Description
Property | DocumentFormat |
Top
See Also

Reference

IDocumentLoader Interface
GrapeCity.Viewer.Common Namespace


DocumentFormat Property (IDocumentLoader)

DocumentFormat Property (IDocumentLoader)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IDocumentLoader Interface : DocumentFormat Property
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property DocumentFormat As DocumentFormat
DocumentFormat DocumentFormat {get;}
See Also

Reference

IDocumentLoader Interface
IDocumentLoader Members


IDocumentRenderer Interface

IDocumentRenderer Interface
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDocumentRenderer Interface
Base interface for Document renderers
Object Model
IDocumentRenderer Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDocumentRenderer
public interface IDocumentRenderer
See Also

Reference

IDocumentRenderer Members
GrapeCity.Viewer.Common Namespace


IDocumentRenderer Interface Members

IDocumentRenderer Interface Members
Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDocumentRenderer Interface

The following tables list the members exposed by IDocumentRenderer.

Public Methods
 | Name | Description
Method | RenderPage | Renders page from current document
Top
See Also

Reference

IDocumentRenderer Interface
GrapeCity.Viewer.Common Namespace


IDocumentRenderer Interface Methods

IDocumentRenderer Interface Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDocumentRenderer Interface

For a list of all members of this type, see IDocumentRenderer members.

Public Methods
 | Name | Description
Method | RenderPage | Renders page from current document
Top
See Also

Reference

IDocumentRenderer Interface
GrapeCity.Viewer.Common Namespace


RenderPage Method (IDocumentRenderer)

RenderPage Method (IDocumentRenderer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IDocumentRenderer Interface : RenderPage Method
Index of the page to render
Renders page from current document
Syntax
  • Visual Basic
  • C#
'Declaration

Function RenderPage( _
   ByVal index As System.Integer _
) As PageView
PageView RenderPage(
   System.int index
)

Parameters

index
Index of the page to render

Return Value

Rendered page view
See Also

Reference

IDocumentRenderer Interface
IDocumentRenderer Members


IDocumentRendererFactory Interface

IDocumentRendererFactory Interface
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDocumentRendererFactory Interface
IDocumentRenderer factory interface.
Object Model
IDocumentRendererFactory Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IDocumentRendererFactory
public interface IDocumentRendererFactory
See Also

Reference

IDocumentRendererFactory Members
GrapeCity.Viewer.Common Namespace


IDocumentRendererFactory Interface Members

IDocumentRendererFactory Interface Members
Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDocumentRendererFactory Interface

The following tables list the members exposed by IDocumentRendererFactory.

Public Methods
 | Name | Description
Method | Create | Overloaded. Creates the IDocumentRenderer for specified document with specified context.
Top
See Also

Reference

IDocumentRendererFactory Interface
GrapeCity.Viewer.Common Namespace


IDocumentRendererFactory Interface Methods

IDocumentRendererFactory Interface Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IDocumentRendererFactory Interface

For a list of all members of this type, see IDocumentRendererFactory members.

Public Methods
 | Name | Description
Method | Create | Overloaded. Creates the IDocumentRenderer for specified document with specified context.
Top
See Also

Reference

IDocumentRendererFactory Interface
GrapeCity.Viewer.Common Namespace


Create Method (IDocumentRendererFactory)

Create Method (IDocumentRendererFactory)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IDocumentRendererFactory Interface : Create Method
Creates the IDocumentRenderer for specified document with specified context.
Overload List
Overload | Description
Create(IApplicationContext,DocumentModel) | Creates the IDocumentRenderer for specified document with specified context.
Create(IApplicationContext,DocumentModel,DeviceKind) | Creates the IDocumentRenderer for specified document with specified context and target device kind.
See Also

Reference

IDocumentRendererFactory Interface
IDocumentRendererFactory Members


Create(IApplicationContext,DocumentModel) Method

Create(IApplicationContext,DocumentModel) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IDocumentRendererFactory Interface > Create Method : Create(IApplicationContext,DocumentModel) Method
The application context.
The document model.
Creates the IDocumentRenderer for specified document with specified context.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function Create( _
   ByVal context As IApplicationContext, _
   ByVal document As DocumentModel _
) As IDocumentRenderer
IDocumentRenderer Create(
   IApplicationContext context,
   DocumentModel document
)

Parameters

context
The application context.
document
The document model.
See Also

Reference

IDocumentRendererFactory Interface
IDocumentRendererFactory Members
Overload List


Create(IApplicationContext,DocumentModel,DeviceKind) Method

Create(IApplicationContext,DocumentModel,DeviceKind) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IDocumentRendererFactory Interface > Create Method : Create(IApplicationContext,DocumentModel,DeviceKind) Method
The application context.
The document model.
The target device.
Creates the IDocumentRenderer for specified document with specified context and target device kind.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function Create( _
   ByVal context As IApplicationContext, _
   ByVal document As DocumentModel, _
   ByVal device As DeviceKind _
) As IDocumentRenderer
IDocumentRenderer Create(
   IApplicationContext context,
   DocumentModel document,
   DeviceKind device
)

Parameters

context
The application context.
document
The document model.
device
The target device.
See Also

Reference

IDocumentRendererFactory Interface
IDocumentRendererFactory Members
Overload List


IHistoryApi Interface

IHistoryApi Interface
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IHistoryApi Interface
This is public interface for user to work with HistoryService.
Object Model
IHistoryApi Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IHistoryApi
public interface IHistoryApi
See Also

Reference

IHistoryApi Members
GrapeCity.Viewer.Common Namespace


IHistoryApi Interface Members

IHistoryApi Interface Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IHistoryApi Interface

The following tables list the members exposed by IHistoryApi.

Public Properties
 | Name | Description
Property | Count | Returns the number of page views in the history.
Property | Position | Gets the current page's position in the navigation history.
Top
Public Methods
 | Name | Description
Method | Clear | Clears the page views from the history.
Method | MoveNext | Navigates to the next page in the history.
Method | MovePrev | Navigates to the previous page in the view history.
Top
See Also

Reference

IHistoryApi Interface
GrapeCity.Viewer.Common Namespace


IHistoryApi Interface Methods

IHistoryApi Interface Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IHistoryApi Interface

For a list of all members of this type, see IHistoryApi members.

Public Methods
 | Name | Description
Method | Clear | Clears the page views from the history.
Method | MoveNext | Navigates to the next page in the history.
Method | MovePrev | Navigates to the previous page in the view history.
Top
See Also

Reference

IHistoryApi Interface
GrapeCity.Viewer.Common Namespace


Clear Method (IHistoryApi)

Clear Method (IHistoryApi)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IHistoryApi Interface : Clear Method
Clears the page views from the history.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Clear()
void Clear()
See Also

Reference

IHistoryApi Interface
IHistoryApi Members


MoveNext Method (IHistoryApi)

MoveNext Method (IHistoryApi)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IHistoryApi Interface : MoveNext Method
Navigates to the next page in the history.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub MoveNext()
void MoveNext()
See Also

Reference

IHistoryApi Interface
IHistoryApi Members


MovePrev Method (IHistoryApi)

MovePrev Method (IHistoryApi)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IHistoryApi Interface : MovePrev Method
Navigates to the previous page in the view history.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub MovePrev()
void MovePrev()
See Also

Reference

IHistoryApi Interface
IHistoryApi Members


IHistoryApi Interface Properties

IHistoryApi Interface Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IHistoryApi Interface

For a list of all members of this type, see IHistoryApi members.

Public Properties
 | Name | Description
Property | Count | Returns the number of page views in the history.
Property | Position | Gets the current page's position in the navigation history.
Top
See Also

Reference

IHistoryApi Interface
GrapeCity.Viewer.Common Namespace


Count Property (IHistoryApi)

Count Property (IHistoryApi)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IHistoryApi Interface : Count Property
Returns the number of page views in the history.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Count As System.Integer
System.int Count {get;}
See Also

Reference

IHistoryApi Interface
IHistoryApi Members


Position Property (IHistoryApi)

Position Property (IHistoryApi)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IHistoryApi Interface : Position Property
Gets the current page's position in the navigation history.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Position As System.Integer
System.int Position {get;}
See Also

Reference

IHistoryApi Interface
IHistoryApi Members


ILoadableFromFileAndStream Interface

ILoadableFromFileAndStream Interface
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : ILoadableFromFileAndStream Interface
Object Model
ILoadableFromFileAndStream Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ILoadableFromFileAndStream
public interface ILoadableFromFileAndStream
See Also

Reference

ILoadableFromFileAndStream Members
GrapeCity.Viewer.Common Namespace


ILoadableFromFileAndStream Interface Members

ILoadableFromFileAndStream Interface Members
Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : ILoadableFromFileAndStream Interface

The following tables list the members exposed by ILoadableFromFileAndStream.

Public Methods
 | Name | Description
Method | LoadFromFile |
Method | LoadFromStream | Overloaded.
Top
See Also

Reference

ILoadableFromFileAndStream Interface
GrapeCity.Viewer.Common Namespace


ILoadableFromFileAndStream Interface Methods

ILoadableFromFileAndStream Interface Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : ILoadableFromFileAndStream Interface

For a list of all members of this type, see ILoadableFromFileAndStream members.

Public Methods
 | Name | Description
Method | LoadFromFile |
Method | LoadFromStream | Overloaded.
Top
See Also

Reference

ILoadableFromFileAndStream Interface
GrapeCity.Viewer.Common Namespace


LoadFromFile Method (ILoadableFromFileAndStream)

LoadFromFile Method (ILoadableFromFileAndStream)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ILoadableFromFileAndStream Interface : LoadFromFile Method
Syntax
  • Visual Basic
  • C#
'Declaration

Sub LoadFromFile( _
   ByVal f As System.IO.FileInfo _
)
void LoadFromFile(
   System.IO.FileInfo f
)

Parameters

f
See Also

Reference

ILoadableFromFileAndStream Interface
ILoadableFromFileAndStream Members


LoadFromStream Method (ILoadableFromFileAndStream)

LoadFromStream Method (ILoadableFromFileAndStream)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ILoadableFromFileAndStream Interface : LoadFromStream Method
Overload List
Overload | Description
LoadFromStream(Stream) |
LoadFromStream(Stream,Uri) |
See Also

Reference

ILoadableFromFileAndStream Interface
ILoadableFromFileAndStream Members


LoadFromStream(Stream) Method

LoadFromStream(Stream) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ILoadableFromFileAndStream Interface > LoadFromStream Method : LoadFromStream(Stream) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub LoadFromStream( _
   ByVal s As System.IO.Stream _
)
void LoadFromStream(
   System.IO.Stream s
)

Parameters

s
See Also

Reference

ILoadableFromFileAndStream Interface
ILoadableFromFileAndStream Members
Overload List


LoadFromStream(Stream,Uri) Method

LoadFromStream(Stream,Uri) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ILoadableFromFileAndStream Interface > LoadFromStream Method : LoadFromStream(Stream,Uri) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Sub LoadFromStream( _
   ByVal s As System.IO.Stream, _
   ByVal baseUri As System.Uri _
)
void LoadFromStream(
   System.IO.Stream s,
   System.Uri baseUri
)

Parameters

s
baseUri
See Also

Reference

ILoadableFromFileAndStream Interface
ILoadableFromFileAndStream Members
Overload List


INotifyCollectionChanged Interface

INotifyCollectionChanged Interface
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : INotifyCollectionChanged Interface
Notifies listeners of dynamic changes to a collection, such as when items are added and removed, or the entire collection object is reset.
Object Model
INotifyCollectionChanged Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface INotifyCollectionChanged
public interface INotifyCollectionChanged
See Also

Reference

INotifyCollectionChanged Members
GrapeCity.Viewer.Common Namespace


INotifyCollectionChanged Interface Members

INotifyCollectionChanged Interface Members
Events

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : INotifyCollectionChanged Interface

The following tables list the members exposed by INotifyCollectionChanged.

Public Events
 | Name | Description
Event | CollectionChanged | Occurs when the items list of the collection has changed, or the collection is reset.
Top
See Also

Reference

INotifyCollectionChanged Interface
GrapeCity.Viewer.Common Namespace


INotifyCollectionChanged Interface Events

INotifyCollectionChanged Interface Events

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : INotifyCollectionChanged Interface

For a list of all members of this type, see INotifyCollectionChanged members.

Public Events
 | Name | Description
Event | CollectionChanged | Occurs when the items list of the collection has changed, or the collection is reset.
Top
See Also

Reference

INotifyCollectionChanged Interface
GrapeCity.Viewer.Common Namespace


CollectionChanged Event (INotifyCollectionChanged)

CollectionChanged Event (INotifyCollectionChanged)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > INotifyCollectionChanged Interface : CollectionChanged Event
Occurs when the items list of the collection has changed, or the collection is reset.
Syntax
  • Visual Basic
  • C#
'Declaration

Event CollectionChanged As NotifyCollectionChangedEventHandler
event NotifyCollectionChangedEventHandler CollectionChanged
See Also

Reference

INotifyCollectionChanged Interface
INotifyCollectionChanged Members


IOrientedPageView Interface

IOrientedPageView Interface
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IOrientedPageView Interface
Interface to access orientation of the report page.
Object Model
IOrientedPageView Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IOrientedPageView
public interface IOrientedPageView
See Also

Reference

IOrientedPageView Members
GrapeCity.Viewer.Common Namespace


IOrientedPageView Interface Members

IOrientedPageView Interface Members
Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IOrientedPageView Interface

The following tables list the members exposed by IOrientedPageView.

Public Properties
 | Name | Description
Property | Orientation |
Top
See Also

Reference

IOrientedPageView Interface
GrapeCity.Viewer.Common Namespace


IOrientedPageView Interface Properties

IOrientedPageView Interface Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IOrientedPageView Interface

For a list of all members of this type, see IOrientedPageView members.

Public Properties
 | Name | Description
Property | Orientation |
Top
See Also

Reference

IOrientedPageView Interface
GrapeCity.Viewer.Common Namespace


Orientation Property (IOrientedPageView)

Orientation Property (IOrientedPageView)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IOrientedPageView Interface : Orientation Property
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Orientation As System.Nullable(Of Orientation)
System.Nullable<Orientation> Orientation {get;}
See Also

Reference

IOrientedPageView Interface
IOrientedPageView Members


IParameter Interface

IParameter Interface
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IParameter Interface
Defines an object that can be used as a report parameter.
Object Model
IParameter Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IParameter
public interface IParameter
See Also

Reference

IParameter Members
GrapeCity.Viewer.Common Namespace


IParameter Interface Members

IParameter Interface Members
Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IParameter Interface

The following tables list the members exposed by IParameter.

Public Properties
 | Name | Description
Property | Name | Gets the name of the report parameter.
Property | Values | Gets the collection of zero or more values for the report parameter.
Top
See Also

Reference

IParameter Interface
GrapeCity.Viewer.Common Namespace


IParameter Interface Properties

IParameter Interface Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IParameter Interface

For a list of all members of this type, see IParameter members.

Public Properties
 | Name | Description
Property | Name | Gets the name of the report parameter.
Property | Values | Gets the collection of zero or more values for the report parameter.
Top
See Also

Reference

IParameter Interface
GrapeCity.Viewer.Common Namespace


Name Property (IParameter)

Name Property (IParameter)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IParameter Interface : Name Property
Gets the name of the report parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Name As System.String
System.string Name {get;}
See Also

Reference

IParameter Interface
IParameter Members


Values Property (IParameter)

Values Property (IParameter)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IParameter Interface : Values Property
Gets the collection of zero or more values for the report parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Values As System.Collections.Generic.IEnumerable(Of Object)
System.Collections.Generic.IEnumerable<object> Values {get;}
See Also

Reference

IParameter Interface
IParameter Members


IPrintService Interface

IPrintService Interface
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IPrintService Interface
Object Model
IPrintService Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IPrintService
public interface IPrintService
See Also

Reference

IPrintService Members
GrapeCity.Viewer.Common Namespace


IPrintService Interface Members

IPrintService Interface Members
Properties Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IPrintService Interface

The following tables list the members exposed by IPrintService.

Public Properties
 | Name | Description
Property | CanPrint |
Top
Public Methods
 | Name | Description
Method | Print | Overloaded.
Top
See Also

Reference

IPrintService Interface
GrapeCity.Viewer.Common Namespace


IPrintService Interface Methods

IPrintService Interface Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IPrintService Interface

For a list of all members of this type, see IPrintService members.

Public Methods
 | Name | Description
Method | Print | Overloaded.
Top
See Also

Reference

IPrintService Interface
GrapeCity.Viewer.Common Namespace


Print Method (IPrintService)

Print Method (IPrintService)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IPrintService Interface : Print Method
Overload List
Overload | Description
Print(DocumentModel,ReportModelBase,IApplicationContext,Boolean,Boolean,Boolean) |
Print(DocumentModel,ReportModelBase,IApplicationContext,PrintingSettings) |
See Also

Reference

IPrintService Interface
IPrintService Members


Print(DocumentModel,ReportModelBase,IApplicationContext,Boolean,Boolean,Boolean) Method

Print(DocumentModel,ReportModelBase,IApplicationContext,Boolean,Boolean,Boolean) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IPrintService Interface > Print Method : Print(DocumentModel,ReportModelBase,IApplicationContext,Boolean,Boolean,Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function Print( _
   ByVal documentModel As DocumentModel, _
   ByVal reportModel As ReportModelBase, _
   ByVal context As IApplicationContext, _
   ByVal showPrintDialog As System.Boolean, _
   ByVal showPrintProgressDialog As System.Boolean, _
   ByVal usePrintingThread As System.Boolean _
) As System.Boolean
System.bool Print(
   DocumentModel documentModel,
   ReportModelBase reportModel,
   IApplicationContext context,
   System.bool showPrintDialog,
   System.bool showPrintProgressDialog,
   System.bool usePrintingThread
)

Parameters

documentModel
reportModel
context
showPrintDialog
showPrintProgressDialog
usePrintingThread
See Also

Reference

IPrintService Interface
IPrintService Members
Overload List


Print(DocumentModel,ReportModelBase,IApplicationContext,PrintingSettings) Method

Print(DocumentModel,ReportModelBase,IApplicationContext,PrintingSettings) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IPrintService Interface > Print Method : Print(DocumentModel,ReportModelBase,IApplicationContext,PrintingSettings) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Function Print( _
   ByVal documentModel As DocumentModel, _
   ByVal reportModel As ReportModelBase, _
   ByVal context As IApplicationContext, _
   ByVal settings As PrintingSettings _
) As System.Boolean
System.bool Print(
   DocumentModel documentModel,
   ReportModelBase reportModel,
   IApplicationContext context,
   PrintingSettings settings
)

Parameters

documentModel
reportModel
context
settings
See Also

Reference

IPrintService Interface
IPrintService Members
Overload List


IPrintService Interface Properties

IPrintService Interface Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IPrintService Interface

For a list of all members of this type, see IPrintService members.

Public Properties
 | Name | Description
Property | CanPrint |
Top
See Also

Reference

IPrintService Interface
GrapeCity.Viewer.Common Namespace


CanPrint Property (IPrintService)

CanPrint Property (IPrintService)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IPrintService Interface : CanPrint Property
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property CanPrint As System.Boolean
System.bool CanPrint {get;}
See Also

Reference

IPrintService Interface
IPrintService Members


IRasteredPageView Interface

IRasteredPageView Interface
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IRasteredPageView Interface
Object Model
IRasteredPageView Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IRasteredPageView
public interface IRasteredPageView
See Also

Reference

IRasteredPageView Members
GrapeCity.Viewer.Common Namespace


IRasteredPageView Interface Members

IRasteredPageView Interface Members
Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IRasteredPageView Interface

The following tables list the members exposed by IRasteredPageView.

Public Properties
 | Name | Description
Property | Resolution |
Top
See Also

Reference

IRasteredPageView Interface
GrapeCity.Viewer.Common Namespace


IRasteredPageView Interface Properties

IRasteredPageView Interface Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IRasteredPageView Interface

For a list of all members of this type, see IRasteredPageView members.

Public Properties
 | Name | Description
Property | Resolution |
Top
See Also

Reference

IRasteredPageView Interface
GrapeCity.Viewer.Common Namespace


Resolution Property

Resolution Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IRasteredPageView Interface : Resolution Property
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Resolution As Point
Point Resolution {get;}
See Also

Reference

IRasteredPageView Interface
IRasteredPageView Members


IRasteredRenderer Interface

IRasteredRenderer Interface
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IRasteredRenderer Interface
Interface for rastered document renderer
Object Model
IRasteredRenderer Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IRasteredRenderer
   Inherits IDocumentRenderer
public interface IRasteredRenderer : IDocumentRenderer
See Also

Reference

IRasteredRenderer Members
GrapeCity.Viewer.Common Namespace


IRasteredRenderer Interface Members

IRasteredRenderer Interface Members
Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IRasteredRenderer Interface

The following tables list the members exposed by IRasteredRenderer.

Public Methods
 | Name | Description
Method | RenderPage | Renders the page.
Top
See Also

Reference

IRasteredRenderer Interface
GrapeCity.Viewer.Common Namespace


IRasteredRenderer Interface Methods

IRasteredRenderer Interface Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IRasteredRenderer Interface

For a list of all members of this type, see IRasteredRenderer members.

Public Methods
 | Name | Description
Method | RenderPage | Renders the page.
Top
See Also

Reference

IRasteredRenderer Interface
GrapeCity.Viewer.Common Namespace


RenderPage Method (IRasteredRenderer)

RenderPage Method (IRasteredRenderer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IRasteredRenderer Interface : RenderPage Method
The page index to render.
The screen dpi factor.
Renders the page.
Syntax
  • Visual Basic
  • C#
'Declaration

Function RenderPage( _
   ByVal index As System.Integer, _
   ByVal screenDpiFactor As System.Double _
) As PageView
PageView RenderPage(
   System.int index,
   System.double screenDpiFactor
)

Parameters

index
The page index to render.
screenDpiFactor
The screen dpi factor.
See Also

Reference

IRasteredRenderer Interface
IRasteredRenderer Members


ISearchService Interface

ISearchService Interface
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : ISearchService Interface
Base interface for search
Object Model
ISearchService Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface ISearchService
public interface ISearchService
See Also

Reference

ISearchService Members
GrapeCity.Viewer.Common Namespace


ISearchService Interface Members

ISearchService Interface Members
Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : ISearchService Interface

The following tables list the members exposed by ISearchService.

Public Methods
 | Name | Description
Method | Find | Searches the document according to find options.
Top
See Also

Reference

ISearchService Interface
GrapeCity.Viewer.Common Namespace


ISearchService Interface Methods

ISearchService Interface Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : ISearchService Interface

For a list of all members of this type, see ISearchService members.

Public Methods
 | Name | Description
Method | Find | Searches the document according to find options.
Top
See Also

Reference

ISearchService Interface
GrapeCity.Viewer.Common Namespace


Find Method (ISearchService)

Find Method (ISearchService)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ISearchService Interface : Find Method
Searches the document according to find options.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Find( _
   ByVal document As DocumentModel, _
   ByVal findOptions As FindOptions, _
   ByVal startFrom As SearchResult, _
   ByVal maxCount As System.Integer, _
   ByVal handler As System.Action(Of DocumentModel,IEnumerable(Of SearchResult)) _
)
void Find(
   DocumentModel document,
   FindOptions findOptions,
   SearchResult startFrom,
   System.int maxCount,
   System.Action<DocumentModel,IEnumerable<SearchResult>> handler
)

Parameters

document
findOptions
startFrom
maxCount
handler
See Also

Reference

ISearchService Interface
ISearchService Members


IServiceContainer Interface

IServiceContainer Interface
Members

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IServiceContainer Interface
Provides a container for services.
Object Model
IServiceContainer Interface
Syntax
  • Visual Basic
  • C#
'Declaration

Public Interface IServiceContainer
public interface IServiceContainer
See Also

Reference

IServiceContainer Members
GrapeCity.Viewer.Common Namespace


IServiceContainer Interface Members

IServiceContainer Interface Members
Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IServiceContainer Interface

The following tables list the members exposed by IServiceContainer.

Public Methods
 | Name | Description
Method | AddService<T> | Adds the specified service to the service container.
Method | GetService<T> | Gets service from container
Method | RemoveService<T> | Removes the specified service type from the service container
Top
See Also

Reference

IServiceContainer Interface
GrapeCity.Viewer.Common Namespace


IServiceContainer Interface Methods

IServiceContainer Interface Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : IServiceContainer Interface

For a list of all members of this type, see IServiceContainer members.

Public Methods
 | Name | Description
Method | AddService<T> | Adds the specified service to the service container.
Method | GetService<T> | Gets service from container
Method | RemoveService<T> | Removes the specified service type from the service container
Top
See Also

Reference

IServiceContainer Interface
GrapeCity.Viewer.Common Namespace


AddService<T> Method (IServiceContainer)

AddService<T> Method (IServiceContainer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IServiceContainer Interface : AddService<T> Method
The type of service to add.
An instance of the service type to add. This object must implement or inherit from the type indicated by the serviceType parameter.
Adds the specified service to the service container.
Syntax
  • Visual Basic
  • C#
'Declaration

Sub AddService(Of T)( _
   ByVal serviceInstance As T _
)
void AddService<T>(
   T serviceInstance
)

Parameters

serviceInstance
An instance of the service type to add. This object must implement or inherit from the type indicated by the serviceType parameter.

Type Parameters

T
The type of service to add.
See Also

Reference

IServiceContainer Interface
IServiceContainer Members


GetService<T> Method (IServiceContainer)

GetService<T> Method (IServiceContainer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IServiceContainer Interface : GetService<T> Method
Gets service from container
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService(Of T)() As T
T GetService<T>()

Type Parameters

T

Return Value

Service or null if service is not found
See Also

Reference

IServiceContainer Interface
IServiceContainer Members


RemoveService<T> Method (IServiceContainer)

RemoveService<T> Method (IServiceContainer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > IServiceContainer Interface : RemoveService<T> Method
The type of service to remove.
Removes the specified service type from the service container
Syntax
  • Visual Basic
  • C#
'Declaration

Sub RemoveService(Of T)()
void RemoveService<T>()

Type Parameters

T
The type of service to remove.
See Also

Reference

IServiceContainer Interface
IServiceContainer Members


NotifyCollectionChangedEventHandler Delegate

NotifyCollectionChangedEventHandler Delegate

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : NotifyCollectionChangedEventHandler Delegate
Represents the method that handles events that implement the System.Collections.Specialized.INotifyCollectionChanged.CollectionChanged event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub NotifyCollectionChangedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As NotifyCollectionChangedEventArgs _
)
public delegate void NotifyCollectionChangedEventHandler(
   System.object sender,
   NotifyCollectionChangedEventArgs e
)

Parameters

sender
e
See Also

Reference

NotifyCollectionChangedEventHandler Members
GrapeCity.Viewer.Common Namespace


GrapeCity.ActiveReports.Web Namespace

GrapeCity.ActiveReports.Web Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Web.v10 Assembly : GrapeCity.ActiveReports.Web Namespace
The GrapeCity.ActiveReports.Web namespace contains the WebViewer class.
Classes
 | Class | Description
Class | WebViewer | The ActiveReports viewer for ASP.NET Web Forms. In addition to providing an easy way to deploy and view reports under ASP.NET, this control provides report caching functionality that reduces the number of times a report executes per user session as the user navigates between pages in the report document.
Enumerations
 | Enumeration | Description
Enumeration | OutputFormat | An enumeration of output formats available with the WebViewer control.
Enumeration | ViewerType | An enumeration of viewing options for the ActiveReports WebForms WebViewer server control for ASP.NET.
See Also

Reference

GrapeCity.ActiveReports.Web.v10 Assembly


WebViewer Class

WebViewer Class
Members

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace : WebViewer Class
The ActiveReports viewer for ASP.NET Web Forms. In addition to providing an easy way to deploy and view reports under ASP.NET, this control provides report caching functionality that reduces the number of times a report executes per user session as the user navigates between pages in the report document.
Object Model
WebViewer Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class WebViewer
   Inherits System.Web.UI.WebControls.WebControl
public class WebViewer : System.Web.UI.WebControls.WebControl
Remarks

Implements INamingContainer (a marker interface with no members) so that contained controls are in a new namespace in which all child control ID attributes are guaranteed to be unique within an entire application. You can add controls to this control, and they'll always get a unique name on the client.

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
GrapeCity.ActiveReports.Web.WebViewer

See Also

Reference

WebViewer Members
GrapeCity.ActiveReports.Web Namespace


WebViewer Class Members

WebViewer Class Members
Properties Methods Events

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace : WebViewer Class

The following tables list the members exposed by WebViewer.

Public Constructors
 | Name | Description
Public Constructor | WebViewer Constructor | Initializes a new instance of the WebViewer class.
Top
Public Properties
 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | FlashViewerOptions | Gets the FlashViewerOptions object to use with the FlashViewer.
Public Property | FlashViewerToolBar | Gets the ToolBarObject to use as the toolbar in the FlashViewer.
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HtmlExportOptions | Returns an HtmlExportOptions object to set HTML-specific properties when you use the HTML ViewerType in the WebViewer control.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | MaxReportRunTime | The maximum number of seconds that a request for a report's output should wait for the report to finish executing.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | PdfExportOptions | Returns a PdfExportOptions object to set PDF-specific properties when you use the PDF ViewerType in the WebViewer control.
Public Property | RenderingCompatibility | (Inherited from System.Web.UI.Control)
Public Property | Report | Specifies the report object to display to the client.
Public Property | ReportName | Specifies the name of the report object to display to the client.
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SlidingExpirationInterval | The interval in seconds between the time the report was last retrieved and when the report will be removed from the ASP.NET WebCache.
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportsDisabledAttribute | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewerType | Determines the type of viewer that will be used to show the report in the client machine's browser.
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top
Public Methods
 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | Overridden. Releases the WebViewer instance from memory.
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | Extracts the style attribute from the outer div or table tag when using Acrobat and uses a percentage of the width or height. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top
Public Events
 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | LocateCredentials | Fires when the PageReport to view generates LocateCredentials event.
Public Event | LocateDataSource | Fires when the PageReport to view generates LocateDataSource event.
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top
See Also

Reference

WebViewer Class
GrapeCity.ActiveReports.Web Namespace


WebViewer Constructor

WebViewer Constructor

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : WebViewer Constructor
Initializes a new instance of the WebViewer class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public WebViewer()
See Also

Reference

WebViewer Class
WebViewer Members


WebViewer Class Methods

WebViewer Class Methods

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace : WebViewer Class

For a list of all members of this type, see WebViewer members.

Public Methods
 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | (Inherited from System.Web.UI.Control)
Public Method | Dispose | Overridden. Releases the WebViewer instance from memory.
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderBeginTag | Extracts the style attribute from the outer div or table tag when using Acrobat and uses a percentage of the width or height. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Top
See Also

Reference

WebViewer Class
GrapeCity.ActiveReports.Web Namespace


Dispose Method (WebViewer)

Dispose Method (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Dispose Method
Releases the WebViewer instance from memory.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Sub Dispose()
public override void Dispose()
See Also

Reference

WebViewer Class
WebViewer Members


WebViewer Class Properties

WebViewer Class Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace : WebViewer Class

For a list of all members of this type, see WebViewer members.

Public Properties
 | Name | Description
Public Property | AccessKey | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Enabled | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from System.Web.UI.Control)
Public Property | FlashViewerOptions | Gets the FlashViewerOptions object to use with the FlashViewer.
Public Property | FlashViewerToolBar | Gets the ToolBarObject to use as the toolbar in the FlashViewer.
Public Property | Font | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HtmlExportOptions | Returns an HtmlExportOptions object to set HTML-specific properties when you use the HTML ViewerType in the WebViewer control.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | MaxReportRunTime | The maximum number of seconds that a request for a report's output should wait for the report to finish executing.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from System.Web.UI.Control)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | PdfExportOptions | Returns a PdfExportOptions object to set PDF-specific properties when you use the PDF ViewerType in the WebViewer control.
Public Property | RenderingCompatibility | (Inherited from System.Web.UI.Control)
Public Property | Report | Specifies the report object to display to the client.
Public Property | ReportName | Specifies the name of the report object to display to the client.
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SlidingExpirationInterval | The interval in seconds between the time the report was last retrieved and when the report will be removed from the ASP.NET WebCache.
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportsDisabledAttribute | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TabIndex | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewerType | Determines the type of viewer that will be used to show the report in the client machine's browser.
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | Visible | (Inherited from System.Web.UI.Control)
Public Property | Width | (Inherited from System.Web.UI.WebControls.WebControl)
Top
See Also

Reference

WebViewer Class
GrapeCity.ActiveReports.Web Namespace


FlashViewerOptions Property

FlashViewerOptions Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : FlashViewerOptions Property
Gets the FlashViewerOptions object to use with the FlashViewer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property FlashViewerOptions As FlashViewerOptions
public FlashViewerOptions FlashViewerOptions {get;}

Property Value

A FlashViewerOptions object.
See Also

Reference

WebViewer Class
WebViewer Members


FlashViewerToolBar Property

FlashViewerToolBar Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : FlashViewerToolBar Property
Gets the ToolBarObject to use as the toolbar in the FlashViewer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property FlashViewerToolBar As ToolBarObject
public ToolBarObject FlashViewerToolBar {get;}

Property Value

A ToolBarObject.
Remarks
Use this property to specify a customized toolbar that you have created.
See Also

Reference

WebViewer Class
WebViewer Members
ToolBarObject Class


HtmlExportOptions Property

HtmlExportOptions Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : HtmlExportOptions Property
Returns an HtmlExportOptions object to set HTML-specific properties when you use the HTML ViewerType in the WebViewer control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HtmlExportOptions As HtmlExportOptions
public HtmlExportOptions HtmlExportOptions {get;}
See Also

Reference

WebViewer Class
WebViewer Members


MaxReportRunTime Property

MaxReportRunTime Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : MaxReportRunTime Property
The maximum number of seconds that a request for a report's output should wait for the report to finish executing.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaxReportRunTime As System.TimeSpan
public System.TimeSpan MaxReportRunTime {get; set;}

Property Value

The default value is 10 seconds.
Remarks
If a report takes longer to run than the value of this property, the control will make subsequent requests at 5 second intervals for the report to see when it is finished executing.
See Also

Reference

WebViewer Class
WebViewer Members


PdfExportOptions Property

PdfExportOptions Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : PdfExportOptions Property
Returns a PdfExportOptions object to set PDF-specific properties when you use the PDF ViewerType in the WebViewer control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PdfExportOptions As PdfExportOptions
public PdfExportOptions PdfExportOptions {get;}
See Also

Reference

WebViewer Class
WebViewer Members


Report Property (WebViewer)

Report Property (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Report Property

Specifies the report object to display to the client.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Report As System.Object
public System.object Report {get; set;}

Property Value

An ActiveReport object.
Remarks

If the control is being loaded in response to a client postback ( ) the property will not use the specified report. Instead the control uses a previously cached copy of the report's Document in the WebCache service to supply speedy responses to clients.

Requirements

See Also

Reference

WebViewer Class
WebViewer Members


ReportName Property (WebViewer)

ReportName Property (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ReportName Property

Specifies the name of the report object to display to the client.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReportName As System.String
public System.string ReportName {get; set;}

Property Value

A string.
Remarks
This property is set from the property window of WebViewer control.
See Also

Reference

WebViewer Class
WebViewer Members


SlidingExpirationInterval Property

SlidingExpirationInterval Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : SlidingExpirationInterval Property
The interval in seconds between the time the report was last retrieved and when the report will be removed from the ASP.NET WebCache.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SlidingExpirationInterval As System.TimeSpan
public System.TimeSpan SlidingExpirationInterval {get; set;}
Remarks

By using this property, you can advance the retention period for the reports that are stored in the cache. For the reports that have exceeded the retention period, they are not necessarily always destroyed at that very moment, and the timing for that depends on the garbage collection.

In particular, if the report to be generated does not change every time, then there is no need to retain it in the cache for a long time, therefore efficiency can be achieved by setting just the minimum value of the generation time of the report.

See Also

Reference

WebViewer Class
WebViewer Members


ViewerType Property

ViewerType Property
Example

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ViewerType Property
Determines the type of viewer that will be used to show the report in the client machine's browser.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ViewerType As ViewerType
public ViewerType ViewerType {get; set;}
Example
  • C#
private void cboViewerType_SelectedIndexChanged(object sender, System.EventArgs e)
{
    // Set the Viewer Type from the dropdown list in the Viewer type property
    string selection = this.cboViewerType.Items[this.cboViewerType.SelectedIndex].Text;
    switch (selection)
    {
                case "AcrobatReader":  //Acrobat Reader was chosen as the viewer type
                    this.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.AcrobatReader;
                    break;
                case "HtmlViewer":  //HTML Viewer was chosen as the viewer type
                    this.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.HtmlViewer;
                    break;
                case "RawHtml":  //Raw HTML was chosen as the viewer type
                    this.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.RawHtml;
                    break;
                case "FlashViewer":  //Flash Viewer was chosen as the viewer type
                    this.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.FlashViewer;
            break;
    }
}
  • Visual Basic
Private Sub cboViewerType_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles cboViewerType.SelectedIndexChanged
    ' Set the Viewer Type from the dropdown list to the ActiveReports WebViewer
    Dim selection As String = Me.cboViewerType.Items(Me.cboViewerType.SelectedIndex).Text
    Select Case selection
        Case "AcrobatReader" 'Acrobat Reader was chosen as the viewer type
            Me.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.AcrobatReader
        Case "HtmlViewer" 'HTML Viewer was chosen as the viewer type
            Me.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.HtmlViewer
        Case "RawHtml" 'Raw HTML was chosen as the viewer type
            Me.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.RawHtml
        Case "FlashViewer" 'Flash Viewer was chosen as the viewer type
            Me.arvWebMain.ViewerType = GrapeCity.ActiveReports.Web.ViewerType.FlashViewer
    End Select
End Sub
See Also

Reference

WebViewer Class
WebViewer Members


WebViewer Class Events

WebViewer Class Events

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace : WebViewer Class

For a list of all members of this type, see WebViewer members.

Public Events
 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | LocateCredentials | Fires when the PageReport to view generates LocateCredentials event.
Public Event | LocateDataSource | Fires when the PageReport to view generates LocateDataSource event.
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top
See Also

Reference

WebViewer Class
GrapeCity.ActiveReports.Web Namespace


LocateCredentials Event (WebViewer)

LocateCredentials Event (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : LocateCredentials Event
Fires when the PageReport to view generates LocateCredentials event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LocateCredentials As LocateCredentialsEventHandler
public event LocateCredentialsEventHandler LocateCredentials
Event Data

The event handler receives an argument of type LocateCredentialsEventArgs containing data related to this event. The following LocateCredentialsEventArgs properties provide information specific to this event.

Property | Description
DataSourceName | Gets the name of the data source to locate credentials for.
Password | Gets ot sets the password of the credentials to be located.
PromptText | Gets the text of prompt of the locate credentials request.
ReportPath | Gets the name of the report to locate credentials for.
UserName | Gets ot sets the user name of the credentials to be located.
See Also

Reference

WebViewer Class
WebViewer Members


LocateDataSource Event (WebViewer)

LocateDataSource Event (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : LocateDataSource Event
Fires when the PageReport to view generates LocateDataSource event.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LocateDataSource As LocateDataSourceEventHandler
public event LocateDataSourceEventHandler LocateDataSource
Event Data

The event handler receives an argument of type LocateDataSourceEventArgs containing data related to this event. The following LocateDataSourceEventArgs properties provide information specific to this event.

Property | Description
Data | The data returned by the event handler.
DataSetName | Gets the name of data set to be located.
DataSourceName | Gets the name of data source that contains the data set to be located.
Report | Gets the Report that is trying to locate the data set.
See Also

Reference

WebViewer Class
WebViewer Members


OutputFormat Enumeration

OutputFormat Enumeration

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace : OutputFormat Enumeration
An enumeration of output formats available with the WebViewer control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum OutputFormat
   Inherits System.Enum
public enum OutputFormat : System.Enum
Members
Member | Description
Ddf | ActiveReports 10 RDLX binary file format.
Html | Browser compatible HTML Format.
Pdf | Portable Document Format (PDF). Good for printing and exact WYSIWYG layout.
Rdf2 | ActiveReports 2.0 (COM) native file format. It provides precise output, and the comprehensive ActiveReports features (such as table of contents and hyperlinks).
Rdf3 | ActiveReports.NET native file format. This format is used with the ActiveReports .NET WinForms Viewer control. It provides precise output, and the comprehensive ActiveReports features (such as table of contents and hyperlinks).
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Web.OutputFormat

Requirements

See Also

Reference

GrapeCity.ActiveReports.Web Namespace


ViewerType Enumeration

ViewerType Enumeration

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace : ViewerType Enumeration
An enumeration of viewing options for the ActiveReports WebForms WebViewer server control for ASP.NET.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ViewerType
   Inherits System.Enum
public enum ViewerType : System.Enum
Members
Member Description
AcrobatReader

Returns output as a PDF document viewable in Acrobat Reader.

Client requirements: Adobe Acrobat Reader.

FlashViewer

Interactive report viewer that provides printing options (including one-touch printing), custom look and more. Requires ActiveReports.FlashViewer.swf for viewing reports in any internet browser.

Client requirements: Adobe Flash Player 10 and above, ActiveReports.FlashViewer.swf (this file must be copied into every FlashViewer project; the original copy of this file is stored in C:\Program Files\GrapeCity\ActiveReports 10\Deployment).

HtmlViewer

Provides a scrollable view of a single page of the report at a time. Downloads only HTML and javascript to the client browser. Not preferable for printable output.

Client Requirements: Internet Explorer 3.x, or Netscape browsers 3.x and above.

RawHtml

Shows all pages in the report document as a single continuous HTML page. Provides a static view of the entire report document, and usually decent printable output, although under some circumstances, pagination is not preserved.

Client Requirements: Internet Explorer 3.x, or Netscape browsers 3.x and above.

Remarks

Some barcode types may render incorrectly and contain white lines in the Html and RawHtml views. However, this limitation does not affect printing and scanning. These barcodes are:

  • Code49
  • QRCode
  • Pdf417
  • RSSExpandedStacked
  • RSS14Stacked
  • RSS14StackedOmnidirectional
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Web.ViewerType

See Also

Reference

GrapeCity.ActiveReports.Web Namespace


GrapeCity.ActiveReports.Web.Controls Namespace

GrapeCity.ActiveReports.Web.Controls Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Web.v10 Assembly : GrapeCity.ActiveReports.Web.Controls Namespace
The GrapeCity.ActiveReports.Web.Controls namespace contains the customizable toolbar object and tools that can be used with the FlashViewer ViewerType of the WebViewer.
Classes
 | Class | Description
Class | Tool | Represents tools that can be added to the customizable toolbar object for the FlashViewer.
Class | ToolBarObject | A customizable toolbar object to be used with the FlashViewer.
Class | ToolBase | Represents the toolbox items that can be used with the FlashViewer.
Class | ToolButton | Represents a tool button for use with the customizable FlashViewer ToolBarObject.
Class | ToolsCollection | Represents a collection of tools for use with the customizable FlashViewer ToolBarObject.
Class | ToolSeparator | Represents a separator that places space between controls in the FlashViewer toolbar.
Enumerations
 | Enumeration | Description
Enumeration | ToolsCollection.ToolCommands | An enumeration of all default toolbar commands.
See Also

Reference

GrapeCity.ActiveReports.Web.v10 Assembly


Tool Class

Tool Class
Members

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : Tool Class
Represents tools that can be added to the customizable toolbar object for the FlashViewer.
Object Model
Tool Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class Tool
   Inherits ToolBase
public abstract class Tool : ToolBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Controls.ToolBase
GrapeCity.ActiveReports.Web.Controls.Tool
GrapeCity.ActiveReports.Web.Controls.ToolButton

See Also

Reference

Tool Members
GrapeCity.ActiveReports.Web.Controls Namespace


Tool Class Members

Tool Class Members
Properties Methods

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : Tool Class

The following tables list the members exposed by Tool.

Public Properties
 | Name | Description
Public Property | Enabled | Gets or sets a value indicating whether to enable the tool.
Public Property | Name | Gets or sets the name of the tool. (Inherited from GrapeCity.ActiveReports.Web.Controls.ToolBase)
Public Property | ToolTip | Gets or sets the text to display when the users hovers the pointer over the tool.
Public Property | Visible | Gets or sets a value indicating whether to display the tool. (Inherited from GrapeCity.ActiveReports.Web.Controls.ToolBase)
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | Create | Creates standard commands.
static (Shared in Visual Basic) | CreateButton | Creates custom buttons.
static (Shared in Visual Basic) | CreateSeparator | Overloaded. Creates the tool separator.
Top
See Also

Reference

Tool Class
GrapeCity.ActiveReports.Web.Controls Namespace


Tool Class Methods

Tool Class Methods

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : Tool Class

For a list of all members of this type, see Tool members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Create | Creates standard commands.
static (Shared in Visual Basic) | CreateButton | Creates custom buttons.
static (Shared in Visual Basic) | CreateSeparator | Overloaded. Creates the tool separator.
Top
See Also

Reference

Tool Class
GrapeCity.ActiveReports.Web.Controls Namespace


Create Method (Tool)

Create Method (Tool)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > Tool Class : Create Method
Creates standard commands.
Creates standard commands.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function Create( _
   ByVal command As ToolsCollection.ToolCommands _
) As Tool
public static Tool Create(
   ToolsCollection.ToolCommands command
)

Parameters

command
Creates standard commands.
See Also

Reference

Tool Class
Tool Members


CreateButton Method

CreateButton Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > Tool Class : CreateButton Method
Name of the custom button.
Creates custom buttons.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function CreateButton( _
   ByVal name As System.String _
) As ToolButton
public static ToolButton CreateButton(
   System.string name
)

Parameters

name
Name of the custom button.
See Also

Reference

Tool Class
Tool Members


CreateSeparator Method

CreateSeparator Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > Tool Class : CreateSeparator Method
Creates the tool separator.
Overload List
Overload | Description
CreateSeparator() | Creates the tool separator.
CreateSeparator(String) | Creates the tool separator with a given name.
See Also

Reference

Tool Class
Tool Members


CreateSeparator() Method

CreateSeparator() Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > Tool Class > CreateSeparator Method : CreateSeparator() Method
Creates the tool separator.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CreateSeparator() As ToolSeparator
public static ToolSeparator CreateSeparator()

Return Value

Created separator
Remarks
Guid will be used as separator name
See Also

Reference

Tool Class
Tool Members
Overload List


CreateSeparator(String) Method

CreateSeparator(String) Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > Tool Class > CreateSeparator Method : CreateSeparator(String) Method
Name of the separator
Creates the tool separator with a given name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CreateSeparator( _
   ByVal name As System.String _
) As ToolSeparator
public static ToolSeparator CreateSeparator(
   System.string name
)

Parameters

name
Name of the separator

Return Value

Created separator
See Also

Reference

Tool Class
Tool Members
Overload List


Tool Class Properties

Tool Class Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : Tool Class

For a list of all members of this type, see Tool members.

Public Properties
 | Name | Description
Public Property | Enabled | Gets or sets a value indicating whether to enable the tool.
Public Property | Name | Gets or sets the name of the tool. (Inherited from GrapeCity.ActiveReports.Web.Controls.ToolBase)
Public Property | ToolTip | Gets or sets the text to display when the users hovers the pointer over the tool.
Public Property | Visible | Gets or sets a value indicating whether to display the tool. (Inherited from GrapeCity.ActiveReports.Web.Controls.ToolBase)
Top
See Also

Reference

Tool Class
GrapeCity.ActiveReports.Web.Controls Namespace


Enabled Property (Tool)

Enabled Property (Tool)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > Tool Class : Enabled Property
Gets or sets a value indicating whether to enable the tool.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Enabled As System.Boolean
public System.bool Enabled {get; set;}
See Also

Reference

Tool Class
Tool Members


ToolTip Property (Tool)

ToolTip Property (Tool)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > Tool Class : ToolTip Property
Gets or sets the text to display when the users hovers the pointer over the tool.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ToolTip As System.String
public System.string ToolTip {get; set;}
See Also

Reference

Tool Class
Tool Members


ToolBarObject Class

ToolBarObject Class
Members

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolBarObject Class
A customizable toolbar object to be used with the FlashViewer.
Object Model
ToolBarObject Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ToolBarObject
public sealed class ToolBarObject
Remarks
Once you create a custom toolbar, specify this object in the WebViewer's FlashViewerToolBar property.
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Controls.ToolBarObject

See Also

Reference

ToolBarObject Members
GrapeCity.ActiveReports.Web.Controls Namespace
FlashViewerToolBar Property


ToolBarObject Class Members

ToolBarObject Class Members
Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolBarObject Class

The following tables list the members exposed by ToolBarObject.

Public Constructors
 | Name | Description
Public Constructor | ToolBarObject Constructor | Initializes a new instance of the ToolBarObject class.
Top
Public Properties
 | Name | Description
Public Property | Tools | Gets or sets the collection of tools to display in the toolbar.
Public Property | Visible | Gets or sets a value indicating whether the ToolBarObject is visible.
Top
See Also

Reference

ToolBarObject Class
GrapeCity.ActiveReports.Web.Controls Namespace
FlashViewerToolBar Property


ToolBarObject Constructor

ToolBarObject Constructor

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolBarObject Class : ToolBarObject Constructor
Initializes a new instance of the ToolBarObject class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ToolBarObject()
See Also

Reference

ToolBarObject Class
ToolBarObject Members


ToolBarObject Class Properties

ToolBarObject Class Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolBarObject Class

For a list of all members of this type, see ToolBarObject members.

Public Properties
 | Name | Description
Public Property | Tools | Gets or sets the collection of tools to display in the toolbar.
Public Property | Visible | Gets or sets a value indicating whether the ToolBarObject is visible.
Top
See Also

Reference

ToolBarObject Class
GrapeCity.ActiveReports.Web.Controls Namespace
FlashViewerToolBar Property


Tools Property

Tools Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolBarObject Class : Tools Property
Gets or sets the collection of tools to display in the toolbar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Tools As ToolsCollection
public ToolsCollection Tools {get;}

Property Value

A ToolsCollection object.
See Also

Reference

ToolBarObject Class
ToolBarObject Members


Visible Property (ToolBarObject)

Visible Property (ToolBarObject)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolBarObject Class : Visible Property
Gets or sets a value indicating whether the ToolBarObject is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}

Property Value

A Boolean value. The default value is True.
See Also

Reference

ToolBarObject Class
ToolBarObject Members


ToolBase Class

ToolBase Class
Members

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolBase Class
Represents the toolbox items that can be used with the FlashViewer.
Object Model
ToolBase Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class ToolBase
public abstract class ToolBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Controls.ToolBase
GrapeCity.ActiveReports.Web.Controls.Tool
GrapeCity.ActiveReports.Web.Controls.ToolSeparator

See Also

Reference

ToolBase Members
GrapeCity.ActiveReports.Web.Controls Namespace


ToolBase Class Members

ToolBase Class Members
Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolBase Class

The following tables list the members exposed by ToolBase.

Public Properties
 | Name | Description
Public Property | Name | Gets the name of the toolbox item.
Public Property | Visible | Gets or sets the toolbox item's visibility.
Top
See Also

Reference

ToolBase Class
GrapeCity.ActiveReports.Web.Controls Namespace


ToolBase Class Properties

ToolBase Class Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolBase Class

For a list of all members of this type, see ToolBase members.

Public Properties
 | Name | Description
Public Property | Name | Gets the name of the toolbox item.
Public Property | Visible | Gets or sets the toolbox item's visibility.
Top
See Also

Reference

ToolBase Class
GrapeCity.ActiveReports.Web.Controls Namespace


Name Property (ToolBase)

Name Property (ToolBase)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolBase Class : Name Property
Gets the name of the toolbox item.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Name As System.String
public System.string Name {get;}
See Also

Reference

ToolBase Class
ToolBase Members


Visible Property (ToolBase)

Visible Property (ToolBase)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolBase Class : Visible Property
Gets or sets the toolbox item's visibility.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}
See Also

Reference

ToolBase Class
ToolBase Members


ToolButton Class

ToolButton Class
Members

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolButton Class
Represents a tool button for use with the customizable FlashViewer ToolBarObject.
Object Model
ToolButton Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ToolButton
   Inherits Tool
public sealed class ToolButton : Tool
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Controls.ToolBase
GrapeCity.ActiveReports.Web.Controls.Tool
GrapeCity.ActiveReports.Web.Controls.ToolButton

See Also

Reference

ToolButton Members
GrapeCity.ActiveReports.Web.Controls Namespace


ToolButton Class Members

ToolButton Class Members
Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolButton Class

The following tables list the members exposed by ToolButton.

Public Properties
 | Name | Description
Public Property | Caption | Gets or sets the caption for a button.
Public Property | ClickNavigateTo | Gets or sets a string value that specifies a URL that the button opens in a new browser window.
Public Property | Enabled | Gets or sets a value indicating whether to enable the tool. (Inherited from GrapeCity.ActiveReports.Web.Controls.Tool)
Public Property | Name | Gets the name of the toolbox item. (Inherited from GrapeCity.ActiveReports.Web.Controls.ToolBase)
Public Property | ToolTip | Gets or sets the text to display when the users hovers the pointer over the tool. (Inherited from GrapeCity.ActiveReports.Web.Controls.Tool)
Public Property | Visible | Gets or sets the toolbox item's visibility. (Inherited from GrapeCity.ActiveReports.Web.Controls.ToolBase)
Top
See Also

Reference

ToolButton Class
GrapeCity.ActiveReports.Web.Controls Namespace


ToolButton Class Properties

ToolButton Class Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolButton Class

For a list of all members of this type, see ToolButton members.

Public Properties
 | Name | Description
Public Property | Caption | Gets or sets the caption for a button.
Public Property | ClickNavigateTo | Gets or sets a string value that specifies a URL that the button opens in a new browser window.
Public Property | Enabled | Gets or sets a value indicating whether to enable the tool. (Inherited from GrapeCity.ActiveReports.Web.Controls.Tool)
Public Property | Name | Gets the name of the toolbox item. (Inherited from GrapeCity.ActiveReports.Web.Controls.ToolBase)
Public Property | ToolTip | Gets or sets the text to display when the users hovers the pointer over the tool. (Inherited from GrapeCity.ActiveReports.Web.Controls.Tool)
Public Property | Visible | Gets or sets the toolbox item's visibility. (Inherited from GrapeCity.ActiveReports.Web.Controls.ToolBase)
Top
See Also

Reference

ToolButton Class
GrapeCity.ActiveReports.Web.Controls Namespace


Caption Property (ToolButton)

Caption Property (ToolButton)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolButton Class : Caption Property
Gets or sets the caption for a button.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Caption As System.String
public System.string Caption {get; set;}
See Also

Reference

ToolButton Class
ToolButton Members


ClickNavigateTo Property

ClickNavigateTo Property
Example

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolButton Class : ClickNavigateTo Property
Gets or sets a string value that specifies a URL that the button opens in a new browser window.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ClickNavigateTo As System.String
public System.string ClickNavigateTo {get; set;}

Property Value

A string URL.
Example
  • C#
GrapeCity.ActiveReports.Web.Controls.ToolButton button = new GrapeCity.ActiveReports.Web.Controls.ToolButton();
button.ClickNavigateTo = "http://www.grapecity.com";
button.ToolTip = "Test tooltip";
WebViewer1.FlashViewerToolBar.Tools.Add(button);
  • Visual Basic
Dim button As New GrapeCity.ActiveReports.Web.Controls.ToolButton()
button.ClickNavigateTo = "http://www.grapecity.com"
button.ToolTip = "Test tooltip"
WebViewer1.FlashViewerToolBar.Tools.Add(button)
See Also

Reference

ToolButton Class
ToolButton Members


ToolsCollection Class

ToolsCollection Class
Members

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolsCollection Class
Represents a collection of tools for use with the customizable FlashViewer ToolBarObject.
Object Model
ToolsCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ToolsCollection
   Inherits System.Collections.ObjectModel.Collection(Of ToolBase)
public sealed class ToolsCollection : System.Collections.ObjectModel.Collection<ToolBase>
Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.Web.Controls.ToolsCollection

See Also

Reference

ToolsCollection Members
GrapeCity.ActiveReports.Web.Controls Namespace


ToolsCollection Class Members

ToolsCollection Class Members
Properties Methods

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolsCollection Class

The following tables list the members exposed by ToolsCollection.

Public Constructors
 | Name | Description
Public Constructor | ToolsCollection Constructor | Initializes a new instance of the ToolsCollection class.
Top
Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Property | Item | The Tool object to remove from the collection.
Top
Public Methods
 | Name | Description
Public Method | Add | Add the specified tool to the tools collection. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | Clear | Clears all tools from the collection. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | Remove | Removes the specified tool from the collection. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | RemoveAt | Removes the tool in the specified position from the collection. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Top
See Also

Reference

ToolsCollection Class
GrapeCity.ActiveReports.Web.Controls Namespace


ToolsCollection Constructor

ToolsCollection Constructor

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolsCollection Class : ToolsCollection Constructor
Initializes a new instance of the ToolsCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ToolsCollection()
See Also

Reference

ToolsCollection Class
ToolsCollection Members


ToolsCollection Class Properties

ToolsCollection Class Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolsCollection Class

For a list of all members of this type, see ToolsCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Property | Item | The Tool object to remove from the collection.
Top
See Also

Reference

ToolsCollection Class
GrapeCity.ActiveReports.Web.Controls Namespace


Item Property (ToolsCollection)

Item Property (ToolsCollection)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolsCollection Class : Item Property
The name of the item.
The Tool object to remove from the collection.
The Tool object to remove from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows ReadOnly Default Property Item( _
   ByVal name As System.String _
) As ToolBase
public new ToolBase this[
   System.string name
]; {get;}

Parameters

name
The name of the item.
See Also

Reference

ToolsCollection Class
ToolsCollection Members


ToolSeparator Class

ToolSeparator Class
Members Example

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolSeparator Class
Represents a separator that places space between controls in the FlashViewer toolbar.
Object Model
ToolSeparator Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ToolSeparator
   Inherits ToolBase
public sealed class ToolSeparator : ToolBase
Example
  • C#
GrapeCity.ActiveReports.Web.Controls.ToolSeparator ts;
ts = GrapeCity.ActiveReports.Web.Controls.Tool.CreateSeparator("SomeName");
  • Visual Basic
Dim ts As GrapeCity.ActiveReports.Web.Controls.ToolSeparator
ts = GrapeCity.ActiveReports.Web.Controls.Tool.CreateSeparator("SomeName")
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Controls.ToolBase
GrapeCity.ActiveReports.Web.Controls.ToolSeparator

See Also

Reference

ToolSeparator Members
GrapeCity.ActiveReports.Web.Controls Namespace


ToolSeparator Class Members

ToolSeparator Class Members
Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolSeparator Class

The following tables list the members exposed by ToolSeparator.

Public Properties
 | Name | Description
Public Property | Name | Gets the name of the toolbox item. (Inherited from GrapeCity.ActiveReports.Web.Controls.ToolBase)
Public Property | Visible | Gets or sets the toolbox item's visibility. (Inherited from GrapeCity.ActiveReports.Web.Controls.ToolBase)
Top
See Also

Reference

ToolSeparator Class
GrapeCity.ActiveReports.Web.Controls Namespace


ToolsCollection.ToolCommands Enumeration

ToolsCollection.ToolCommands Enumeration

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolsCollection.ToolCommands Enumeration
An enumeration of all default toolbar commands.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ToolsCollection.ToolCommands
   Inherits System.Enum
public enum ToolsCollection.ToolCommands : System.Enum
Members
Member | Description
BackwardButton | Navigates backward.
ContinuousViewButton | Displays the report in the continuous view mode.
CurPageTextArea | Displays the page index.
ForwardButton | Navigates forward.
MultiPageBox | Shows multiple pages of the report.
NextPageButton | Takes to the next page of the report.
PageRangeButton | Sets the page range for printing the report.
PreviousPageButton | Takes to the previous page of the report.
PrintButton | Prints the report.
SearchButton | Shows the Find dialog.
SinglePageViewButton | Displays the report as a single page.
TOCButton | Displays the table of contents pane.
ZoomBox | Sets the zoom level at which to display the report.
ZoomInButton | Increases the zoom level for displaying the report, with 800% as the highest level.
ZoomOutButton | Decreases the zoom level for displaying the report, with 10% as the lowest level.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Web.Controls.ToolsCollection.ToolCommands

See Also

Reference

GrapeCity.ActiveReports.Web.Controls Namespace


GrapeCity.ActiveReports.Web.ExportOptions Namespace

GrapeCity.ActiveReports.Web.ExportOptions Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Web.v10 Assembly : GrapeCity.ActiveReports.Web.ExportOptions Namespace
The GrapeCity.ActiveReports.Web.ExportOptions namespace contains the HtmlExport and PdfExport classes.
Classes
 | Class | Description
Class | FlashViewerOptions | Allows you to set options for the FlashViewer ViewerType of the WebViewer control.
Class | FlashViewerOptions.FlashViewerPrintOptions | Allows you to set printing options for the FlashViewer ViewerType of the WebViewer control.
Class | HtmlExportOptions | Allows you to set options when using the HTML ViewerType.
Class | PdfExportOptions | Allows you to set options when using the PDF ViewerType.
Class | TocPanelOptions | Allows you to set options for the table of contents pane for the FlashViewer ViewerType of the WebViewer control.
Enumerations
 | Enumeration | Description
Enumeration | FlashViewerOptions.PaperOrientationOptions | An enumeration of values indicating whether and how to adjust paper orientation in the FlashViewer.
Enumeration | FlashViewerOptions.ScalePagesOptions | An enumeration of values indicating whether and how to scale pages in the FlashViewer.
Enumeration | TocPanelAlignment | Specifies the position of the table of contents pane.
Enumeration | ViewType | Specifies the page view type.
Enumeration | WindowMode | An enumeration of window mode options for the ActiveReports WebForms WebViewer server control for ASP.NET.
See Also

Reference

GrapeCity.ActiveReports.Web.v10 Assembly


FlashViewerOptions Class

FlashViewerOptions Class
Members Example

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : FlashViewerOptions Class
Allows you to set options for the FlashViewer ViewerType of the WebViewer control.
Object Model
FlashViewerOptions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class FlashViewerOptions
public class FlashViewerOptions
Example
This code is a snippet from the Professional Edition Web Sample in the FlashViewer.aspx Page Load event.
  • Visual Basic
WebViewer.FlashViewerOptions.ResourceLocale = Request.Form("LanguageDropDownList")
WebViewer.FlashViewerOptions.ThemeUrl = Request.Form("ThemesDropDownList")
WebViewer.FlashViewerOptions.ShowSplitter = GetBooleanValueFromForm(Request.Form("ShowSplitter"))
WebViewer.FlashViewerOptions.TocPanelOptions.ShowThumbnails = GetBooleanValueFromForm(Request.Form("ShowThumbnails"))
WebViewer.FlashViewerOptions.TocPanelOptions.ShowToc = GetBooleanValueFromForm(Request.Form("ShowTOC"))
  • C#
WebViewer.FlashViewerOptions.ResourceLocale = Request.Form["LanguageDropDownList"];
WebViewer.FlashViewerOptions.ThemeUrl = Request.Form["ThemesDropDownList"];
WebViewer.FlashViewerOptions.ShowSplitter = GetBooleanValueFromForm(Request.Form["ShowSplitter"]);
WebViewer.FlashViewerOptions.TocPanelOptions.ShowThumbnails = GetBooleanValueFromForm(Request.Form["ShowThumbnails"]);
WebViewer.FlashViewerOptions.TocPanelOptions.ShowToc = GetBooleanValueFromForm(Request.Form["ShowTOC"]);
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.ExportOptions.FlashViewerOptions

See Also

Reference

FlashViewerOptions Members
GrapeCity.ActiveReports.Web.ExportOptions Namespace


FlashViewerOptions Class Members

FlashViewerOptions Class Members
Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : FlashViewerOptions Class

The following tables list the members exposed by FlashViewerOptions.

Public Properties
 | Name | Description
Public Property | DisplayTransparency | Gets or sets a value indicating whether to render transparent objects in a way that is suitable for printing.
Public Property | HyperLinkBackColor | Gets or sets the background color of the controls that host a hyperlink. The default value is transparent.
Public Property | HyperLinkForeColor | Gets or sets the color of the text within a control that hosts a hyperlink. The default color is Blue.
Public Property | HyperLinkUnderline | Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true.
Public Property | MultiPageViewColumns | Gets or sets the amount of columns to display in the Multiple page view type. The number of columns cannot be greater than 6 and less than 1.
Public Property | MultiPageViewRows | Gets or sets the amount of rows to display in the Multiple page view type. The number of rows cannot be greater than 5 and less than 1.
Public Property | PageNumber | Gets or sets the number of the page to display initially in the FlashViewer.
Public Property | PrintOptions | Gets or sets the printing options to use in the FlashViewer.
Public Property | ResourceLocale | Gets or sets the resource locale to use in the FlashViewer.
Public Property | ResourceUrl | Gets or sets a relative URL value that specifies the location of the ActiveReports.FlashViewer.Resources.swf file that contains localized resources.
Public Property | SearchResultsBackColor | Gets or sets the background color of the highlighted text when using the WebViewer control's Find dialog. The default color is Blue.
Public Property | SearchResultsForeColor | Gets or sets the color of the highlighted text when using the WebViewer control's Find dialog. The default color is White.
Public Property | ShowSplitter | Gets or sets a value indicating whether to include a splitter that allows the user to display the report in two sections.
Public Property | ThemeUrl | Gets or sets a value specifying the relative URL of a skin to use on the FlashViewer.
Public Property | TocPanelOptions | Gets or sets the FlashViewer table of contents pane settings.
Public Property | Url | Gets or sets a relative URL value that specifies the location of the ActiveReports.FlashViewer.swf file that contains the FlashViewer object.
Public Property | UseClientApi | Gets or sets whether to use the client API in the FlashViewer.
Public Property | ViewType | Gets or sets the view type of the FlashViewer.
Public Property | WindowMode | Sets the Window Mode property of the Flash Viewer control for transparency, layering, and positioning in the browser.
Public Property | Zoom | Gets or sets a value that specifies the zoom level at which to display the report.
Top
See Also

Reference

FlashViewerOptions Class
GrapeCity.ActiveReports.Web.ExportOptions Namespace


FlashViewerOptions Class Properties

FlashViewerOptions Class Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : FlashViewerOptions Class

For a list of all members of this type, see FlashViewerOptions members.

Public Properties
 | Name | Description
Public Property | DisplayTransparency | Gets or sets a value indicating whether to render transparent objects in a way that is suitable for printing.
Public Property | HyperLinkBackColor | Gets or sets the background color of the controls that host a hyperlink. The default value is transparent.
Public Property | HyperLinkForeColor | Gets or sets the color of the text within a control that hosts a hyperlink. The default color is Blue.
Public Property | HyperLinkUnderline | Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true.
Public Property | MultiPageViewColumns | Gets or sets the amount of columns to display in the Multiple page view type. The number of columns cannot be greater than 6 and less than 1.
Public Property | MultiPageViewRows | Gets or sets the amount of rows to display in the Multiple page view type. The number of rows cannot be greater than 5 and less than 1.
Public Property | PageNumber | Gets or sets the number of the page to display initially in the FlashViewer.
Public Property | PrintOptions | Gets or sets the printing options to use in the FlashViewer.
Public Property | ResourceLocale | Gets or sets the resource locale to use in the FlashViewer.
Public Property | ResourceUrl | Gets or sets a relative URL value that specifies the location of the ActiveReports.FlashViewer.Resources.swf file that contains localized resources.
Public Property | SearchResultsBackColor | Gets or sets the background color of the highlighted text when using the WebViewer control's Find dialog. The default color is Blue.
Public Property | SearchResultsForeColor | Gets or sets the color of the highlighted text when using the WebViewer control's Find dialog. The default color is White.
Public Property | ShowSplitter | Gets or sets a value indicating whether to include a splitter that allows the user to display the report in two sections.
Public Property | ThemeUrl | Gets or sets a value specifying the relative URL of a skin to use on the FlashViewer.
Public Property | TocPanelOptions | Gets or sets the FlashViewer table of contents pane settings.
Public Property | Url | Gets or sets a relative URL value that specifies the location of the ActiveReports.FlashViewer.swf file that contains the FlashViewer object.
Public Property | UseClientApi | Gets or sets whether to use the client API in the FlashViewer.
Public Property | ViewType | Gets or sets the view type of the FlashViewer.
Public Property | WindowMode | Sets the Window Mode property of the Flash Viewer control for transparency, layering, and positioning in the browser.
Public Property | Zoom | Gets or sets a value that specifies the zoom level at which to display the report.
Top
See Also

Reference

FlashViewerOptions Class
GrapeCity.ActiveReports.Web.ExportOptions Namespace


DisplayTransparency Property

DisplayTransparency Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions Class : DisplayTransparency Property
Gets or sets a value indicating whether to render transparent objects in a way that is suitable for printing.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DisplayTransparency As System.Boolean
public System.bool DisplayTransparency {get; set;}

Property Value

A Boolean value. False by default.
Remarks
Setting this value to True causes image quality degradation and a notable memory footprint.
See Also

Reference

FlashViewerOptions Class
FlashViewerOptions Members


HyperLinkBackColor Property (FlashViewerOptions)

HyperLinkBackColor Property (FlashViewerOptions)
Example

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions Class : HyperLinkBackColor Property
Gets or sets the background color of the controls that host a hyperlink. The default value is transparent.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HyperLinkBackColor As Color
public Color HyperLinkBackColor {get; set;}
Example
  • Visual Basic
WebViewer.FlashViewerOptions.HyperLinkBackColor = System.Drawing.Color.White
  • C#
WebViewer.FlashViewerOptions.HyperLinkBackColor = System.Drawing.Color.White;
See Also

Reference

FlashViewerOptions Class
FlashViewerOptions Members


HyperLinkForeColor Property (FlashViewerOptions)

HyperLinkForeColor Property (FlashViewerOptions)
Example

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions Class : HyperLinkForeColor Property
Gets or sets the color of the text within a control that hosts a hyperlink. The default color is Blue.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HyperLinkForeColor As Color
public Color HyperLinkForeColor {get; set;}
Example
  • Visual Basic
WebViewer.FlashViewerOptions.HyperLinkForeColor = System.Drawing.Color.DarkGreen
  • C#
WebViewer.FlashViewerOptions.HyperLinkForeColor = System.Drawing.Color.DarkGreen;
See Also

Reference

FlashViewerOptions Class
FlashViewerOptions Members


HyperLinkUnderline Property (FlashViewerOptions)

HyperLinkUnderline Property (FlashViewerOptions)
Example

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions Class : HyperLinkUnderline Property
Gets or sets a value determining whether the text in a control that hosts a hyperlink is underlined. The default value is true.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HyperLinkUnderline As System.Boolean
public System.bool HyperLinkUnderline {get; set;}
Example
  • Visual Basic
WebViewer.FlashViewerOptions.HyperLinkUnderline = False
  • C#
WebViewer.FlashViewerOptions.HyperLinkUnderline = false;
See Also

Reference

FlashViewerOptions Class
FlashViewerOptions Members


MultiPageViewColumns Property

MultiPageViewColumns Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions Class : MultiPageViewColumns Property
Gets or sets the amount of columns to display in the Multiple page view type. The number of columns cannot be greater than 6 and less than 1.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MultiPageViewColumns As System.Short
public System.short MultiPageViewColumns {get; set;}
See Also

Reference

FlashViewerOptions Class
FlashViewerOptions Members


MultiPageViewRows Property

MultiPageViewRows Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions Class : MultiPageViewRows Property
Gets or sets the amount of rows to display in the Multiple page view type. The number of rows cannot be greater than 5 and less than 1.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MultiPageViewRows As System.Short
public System.short MultiPageViewRows {get; set;}
See Also

Reference

FlashViewerOptions Class
FlashViewerOptions Members


PageNumber Property (FlashViewerOptions)

PageNumber Property (FlashViewerOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions Class : PageNumber Property
Gets or sets the number of the page to display initially in the FlashViewer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PageNumber As System.Integer
public System.int PageNumber {get; set;}

Property Value

An integer representing a page number within the report.
See Also

Reference

FlashViewerOptions Class
FlashViewerOptions Members


PrintOptions Property (FlashViewerOptions)

PrintOptions Property (FlashViewerOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions Class : PrintOptions Property
Gets or sets the printing options to use in the FlashViewer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrintOptions As FlashViewerOptions.FlashViewerPrintOptions
public FlashViewerOptions.FlashViewerPrintOptions PrintOptions {get; set;}

Property Value

A FlashViewerOptions.FlashViewerPrintOptions object that may contain any of the following:

  • An enumerated AdjustPaperOrientation value.
  • An enumerated ScalePages value.
  • A Boolean StartPrint value.
See Also

Reference

FlashViewerOptions Class
FlashViewerOptions Members


ResourceLocale Property

ResourceLocale Property
Example

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions Class : ResourceLocale Property
Gets or sets the resource locale to use in the FlashViewer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ResourceLocale As System.String
public System.string ResourceLocale {get; set;}

Property Value

A string value representing a valid resource locale for which a resource file is included in the project folder (or at a URL specified in the ResourceUrl property).
Remarks

The following resource locales are included with ActiveReports in the ActiveReports.FlashViewer.Resources.swf file (located in the Deployment folder):

  • en_US U.S. English (default)
  • ru_RU Russian
  • ja_JP Japanese
  • zh_CN Chinese (Simplified)
  • pt_BR Portuguese (Brazil)
  • de_DE German

You can create your own localization resources and send them to GrapeCity support for signing.

Example
  • C#
WebViewer.FlashViewerOptions.ResourceLocale = Request.Form["LanguageDropDownList"];
  • Visual Basic
WebViewer.FlashViewerOptions.ResourceLocale = Request.Form("LanguageDropDownList")
See Also

Reference

FlashViewerOptions Class
FlashViewerOptions Members


ResourceUrl Property

ResourceUrl Property
Example

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions Class : ResourceUrl Property
Gets or sets a relative URL value that specifies the location of the ActiveReports.FlashViewer.Resources.swf file that contains localized resources.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ResourceUrl As System.String
public System.string ResourceUrl {get; set;}

Property Value

A string URL value. The default value is an empty string, indicating that the FlashViewer supplies the ActiveReports.FlashViewer.Resources.swf file in the same folder.
Remarks
You can specify a comma-separated list of URLs for partial localization.
Example
  • Visual Basic
WebViewer.FlashViewerOptions.ResourceUrl = "FlashViewerFolder/ActiveReports.FlashViewer.Resources.swf"
  • C#
WebViewer.FlashViewerOptions.ResourceUrl = "FlashViewerFolder/ActiveReports.FlashViewer.Resources.swf";
See Also

Reference

FlashViewerOptions Class
FlashViewerOptions Members


SearchResultsBackColor Property (FlashViewerOptions)

SearchResultsBackColor Property (FlashViewerOptions)
Example

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions Class : SearchResultsBackColor Property
Gets or sets the background color of the highlighted text when using the WebViewer control's Find dialog. The default color is Blue.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SearchResultsBackColor As Color
public Color SearchResultsBackColor {get; set;}
Example
  • Visual Basic
WebViewer.FlashViewerOptions.SearchResultsBackColor = System.Drawing.Color.Red
  • C#
WebViewer.FlashViewerOptions.SearchResultsBackColor = System.Drawing.Color.Red;
See Also

Reference

FlashViewerOptions Class
FlashViewerOptions Members


SearchResultsForeColor Property (FlashViewerOptions)

SearchResultsForeColor Property (FlashViewerOptions)
Example

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions Class : SearchResultsForeColor Property
Gets or sets the color of the highlighted text when using the WebViewer control's Find dialog. The default color is White.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SearchResultsForeColor As Color
public Color SearchResultsForeColor {get; set;}
Example
  • Visual Basic
WebViewer.FlashViewerOptions.SearchResultsForeColor = System.Drawing.Color.Yellow
  • C#
WebViewer.FlashViewerOptions.SearchResultsForeColor = System.Drawing.Color.Yellow;
See Also

Reference

FlashViewerOptions Class
FlashViewerOptions Members


ShowSplitter Property

ShowSplitter Property
Example

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions Class : ShowSplitter Property
Gets or sets a value indicating whether to include a splitter that allows the user to display the report in two sections.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShowSplitter As System.Boolean
public System.bool ShowSplitter {get; set;}

Property Value

A Boolean value. True by default.
Remarks
When the FlashViewer is split in two sections, the user can compare two different sections of the same report in the top and bottom panes.
Example
  • C#
WebViewer.FlashViewerOptions.ShowSplitter = GetBooleanValueFromForm(Request.Form["ShowSplitter"]);
  • Visual Basic
WebViewer.FlashViewerOptions.ShowSplitter = GetBooleanValueFromForm(Request.Form("ShowSplitter"))
See Also

Reference

FlashViewerOptions Class
FlashViewerOptions Members


ThemeUrl Property

ThemeUrl Property
Example

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions Class : ThemeUrl Property
Gets or sets a value specifying the relative URL of a skin to use on the FlashViewer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ThemeUrl As System.String
public System.string ThemeUrl {get; set;}

Property Value

A string relative URL value.
Remarks
The following skins are included in the Deployment folder:
  • FluorescentBlue.swf
  • Office.swf
  • OliveGreen.swf
  • Orange.swf
  • VistaAero.swf
  • WindowsClassic.swf
  • XP.swf
Example
  • C#
WebViewer.FlashViewerOptions.ThemeUrl = Request.Form["ThemesDropDownList"];
  • Visual Basic
WebViewer.FlashViewerOptions.ThemeUrl = Request.Form("ThemesDropDownList")
See Also

Reference

FlashViewerOptions Class
FlashViewerOptions Members


TocPanelOptions Property

TocPanelOptions Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions Class : TocPanelOptions Property
Gets or sets the FlashViewer table of contents pane settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TocPanelOptions As TocPanelOptions
public TocPanelOptions TocPanelOptions {get; set;}
See Also

Reference

FlashViewerOptions Class
FlashViewerOptions Members


Url Property

Url Property
Example

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions Class : Url Property
Gets or sets a relative URL value that specifies the location of the ActiveReports.FlashViewer.swf file that contains the FlashViewer object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Url As System.String
public System.string Url {get; set;}

Property Value

A relative URL string.
Remarks
Use this property for ease of deployment when you have multiple ActiveReports applications on a Web server and want to use a single ActiveReports.FlashViewer.swf file in a shared directory.
Example
  • Visual Basic
WebViewer.FlashViewerOptions.Url = "FlashViewerFolder/ActiveReports.FlashViewer.swf"
  • C#
WebViewer.FlashViewerOptions.Url = "FlashViewerFolder/ActiveReports.FlashViewer.swf";
See Also

Reference

FlashViewerOptions Class
FlashViewerOptions Members


UseClientApi Property

UseClientApi Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions Class : UseClientApi Property
Gets or sets whether to use the client API in the FlashViewer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseClientApi As System.Boolean
public System.bool UseClientApi {get; set;}
See Also

Reference

FlashViewerOptions Class
FlashViewerOptions Members


ViewType Property (FlashViewerOptions)

ViewType Property (FlashViewerOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions Class : ViewType Property
Gets or sets the view type of the FlashViewer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ViewType As ViewType
public ViewType ViewType {get; set;}
See Also

Reference

FlashViewerOptions Class
FlashViewerOptions Members


WindowMode Property

WindowMode Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions Class : WindowMode Property
Sets the Window Mode property of the Flash Viewer control for transparency, layering, and positioning in the browser.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WindowMode As WindowMode
public WindowMode WindowMode {get; set;}
See Also

Reference

FlashViewerOptions Class
FlashViewerOptions Members


Zoom Property (FlashViewerOptions)

Zoom Property (FlashViewerOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions Class : Zoom Property
Gets or sets a value that specifies the zoom level at which to display the report.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Zoom As System.Integer
public System.int Zoom {get; set;}

Property Value

An integer value between 10% and 800%.
See Also

Reference

FlashViewerOptions Class
FlashViewerOptions Members


FlashViewerOptions.FlashViewerPrintOptions Class

FlashViewerOptions.FlashViewerPrintOptions Class
Members

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : FlashViewerOptions.FlashViewerPrintOptions Class
Allows you to set printing options for the FlashViewer ViewerType of the WebViewer control.
Object Model
FlashViewerOptions.FlashViewerPrintOptions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class FlashViewerOptions.FlashViewerPrintOptions
public sealed class FlashViewerOptions.FlashViewerPrintOptions
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.ExportOptions.FlashViewerOptions.FlashViewerPrintOptions

See Also

Reference

FlashViewerOptions.FlashViewerPrintOptions Members
GrapeCity.ActiveReports.Web.ExportOptions Namespace


FlashViewerOptions.FlashViewerPrintOptions Class Members

FlashViewerOptions.FlashViewerPrintOptions Class Members
Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : FlashViewerOptions.FlashViewerPrintOptions Class

The following tables list the members exposed by FlashViewerOptions.FlashViewerPrintOptions.

Public Constructors
 | Name | Description
Public Constructor | FlashViewerOptions.FlashViewerPrintOptions Constructor | Overloaded. Initializes an instance of the FlashViewerPrintOptions class.
Top
Public Properties
 | Name | Description
Public Property | AdjustPaperOrientation | Gets or sets an enumerated PaperOrientationOptions value indicating whether and how to adjust paper orientation in the FlashViewer.
Public Property | ScalePages | Gets or sets an enumerated ScalePagesOptions value indicating whether and how to scale pages in the FlashViewer.
Public Property | StartPrint | Gets or sets a value indicating whether to display the Print dialog to the user immediately when the report is opened in the FlashViewer
Top
See Also

Reference

FlashViewerOptions.FlashViewerPrintOptions Class
GrapeCity.ActiveReports.Web.ExportOptions Namespace


FlashViewerOptions.FlashViewerPrintOptions Constructor

FlashViewerOptions.FlashViewerPrintOptions Constructor

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions.FlashViewerPrintOptions Class : FlashViewerOptions.FlashViewerPrintOptions Constructor
Initializes an instance of the FlashViewerPrintOptions class.
Overload List
Overload | Description
FlashViewerOptions.FlashViewerPrintOptions Constructor() | Initializes an instance of the FlashViewerPrintOptions class.
FlashViewerOptions.FlashViewerPrintOptions Constructor(PaperOrientationOptions,ScalePagesOptions,Boolean) | Initializes an instance of the FlashViewerPrintOptions class.
See Also

Reference

FlashViewerOptions.FlashViewerPrintOptions Class
FlashViewerOptions.FlashViewerPrintOptions Members


FlashViewerOptions.FlashViewerPrintOptions Constructor()

FlashViewerOptions.FlashViewerPrintOptions Constructor()

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions.FlashViewerPrintOptions Class > FlashViewerOptions.FlashViewerPrintOptions Constructor : FlashViewerOptions.FlashViewerPrintOptions Constructor()
Initializes an instance of the FlashViewerPrintOptions class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public FlashViewerOptions.FlashViewerPrintOptions()
See Also

Reference

FlashViewerOptions.FlashViewerPrintOptions Class
FlashViewerOptions.FlashViewerPrintOptions Members
Overload List


FlashViewerOptions.FlashViewerPrintOptions Constructor(PaperOrientationOptions,ScalePagesOptions,Boolean)

FlashViewerOptions.FlashViewerPrintOptions Constructor(PaperOrientationOptions,ScalePagesOptions,Boolean)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions.FlashViewerPrintOptions Class > FlashViewerOptions.FlashViewerPrintOptions Constructor : FlashViewerOptions.FlashViewerPrintOptions Constructor(PaperOrientationOptions,ScalePagesOptions,Boolean)
An enumerated PaperOrientationOptions value.
An enumerated ScalePagesOptions value.
A Boolean value indicating whether to display the Print dialog to the user immediately when the report is opened in the FlashViewer
Initializes an instance of the FlashViewerPrintOptions class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal paperOrientation As FlashViewerOptions.PaperOrientationOptions, _
   ByVal scalePages As FlashViewerOptions.ScalePagesOptions, _
   ByVal startPrint As System.Boolean _
)
public FlashViewerOptions.FlashViewerPrintOptions(
   FlashViewerOptions.PaperOrientationOptions paperOrientation,
   FlashViewerOptions.ScalePagesOptions scalePages,
   System.bool startPrint
)

Parameters

paperOrientation
An enumerated PaperOrientationOptions value.
scalePages
An enumerated ScalePagesOptions value.
startPrint
A Boolean value indicating whether to display the Print dialog to the user immediately when the report is opened in the FlashViewer
See Also

Reference

FlashViewerOptions.FlashViewerPrintOptions Class
FlashViewerOptions.FlashViewerPrintOptions Members
Overload List


FlashViewerOptions.FlashViewerPrintOptions Class Properties

FlashViewerOptions.FlashViewerPrintOptions Class Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : FlashViewerOptions.FlashViewerPrintOptions Class

For a list of all members of this type, see FlashViewerOptions.FlashViewerPrintOptions members.

Public Properties
 | Name | Description
Public Property | AdjustPaperOrientation | Gets or sets an enumerated PaperOrientationOptions value indicating whether and how to adjust paper orientation in the FlashViewer.
Public Property | ScalePages | Gets or sets an enumerated ScalePagesOptions value indicating whether and how to scale pages in the FlashViewer.
Public Property | StartPrint | Gets or sets a value indicating whether to display the Print dialog to the user immediately when the report is opened in the FlashViewer
Top
See Also

Reference

FlashViewerOptions.FlashViewerPrintOptions Class
GrapeCity.ActiveReports.Web.ExportOptions Namespace


AdjustPaperOrientation Property

AdjustPaperOrientation Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions.FlashViewerPrintOptions Class : AdjustPaperOrientation Property
Gets or sets an enumerated PaperOrientationOptions value indicating whether and how to adjust paper orientation in the FlashViewer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AdjustPaperOrientation As FlashViewerOptions.PaperOrientationOptions
public FlashViewerOptions.PaperOrientationOptions AdjustPaperOrientation {get; set;}

Property Value

An enumerated value.
See Also

Reference

FlashViewerOptions.FlashViewerPrintOptions Class
FlashViewerOptions.FlashViewerPrintOptions Members


ScalePages Property

ScalePages Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions.FlashViewerPrintOptions Class : ScalePages Property
Gets or sets an enumerated ScalePagesOptions value indicating whether and how to scale pages in the FlashViewer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ScalePages As FlashViewerOptions.ScalePagesOptions
public FlashViewerOptions.ScalePagesOptions ScalePages {get; set;}

Property Value

An enumerated value.
See Also

Reference

FlashViewerOptions.FlashViewerPrintOptions Class
FlashViewerOptions.FlashViewerPrintOptions Members


StartPrint Property

StartPrint Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > FlashViewerOptions.FlashViewerPrintOptions Class : StartPrint Property
Gets or sets a value indicating whether to display the Print dialog to the user immediately when the report is opened in the FlashViewer
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartPrint As System.Boolean
public System.bool StartPrint {get; set;}
See Also

Reference

FlashViewerOptions.FlashViewerPrintOptions Class
FlashViewerOptions.FlashViewerPrintOptions Members


HtmlExportOptions Class

HtmlExportOptions Class
Members

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : HtmlExportOptions Class
Allows you to set options when using the HTML ViewerType.
Object Model
HtmlExportOptions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class HtmlExportOptions
public class HtmlExportOptions
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.ExportOptions.HtmlExportOptions

See Also

Reference

HtmlExportOptions Members
GrapeCity.ActiveReports.Web.ExportOptions Namespace


HtmlExportOptions Class Members

HtmlExportOptions Class Members
Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : HtmlExportOptions Class

The following tables list the members exposed by HtmlExportOptions.

Public Properties
 | Name | Description
Public Property | BookmarkStyle | Specifies a BookmarkStyle to use when exporting to an HTML format.
Public Property | CharacterSet | Specifies the HTML character set to use when exporting to an HTML format.
Public Property | CreateFramesetPage | Specifies if a Frameset page should be created when exporting to an HTML format.
Public Property | IncludeHtmlHeader | Specifies if an HTML header section should be created when exporting to an HTML format.
Public Property | IncludePageMargins | Specifies if the report margins should be used when exporting to an HTML format.
Public Property | MultiPage | Specifies if the report should be exported to multiple pages when exporting to an HTML format.
Public Property | OutputType | Specifies the HTML output type to be used with exporting to an HTML viewer type.
Public Property | RemoveVerticalSpace | Specifies if vertical spacing should be removed when exporting to an HTML viewer type.
Public Property | Title | Specifies the text used in the HTML tags of the exported document when using an HTML viewer type.
Top
See Also

Reference

HtmlExportOptions Class
GrapeCity.ActiveReports.Web.ExportOptions Namespace


HtmlExportOptions Class Properties

HtmlExportOptions Class Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : HtmlExportOptions Class

For a list of all members of this type, see HtmlExportOptions members.

Public Properties
 | Name | Description
Public Property | BookmarkStyle | Specifies a BookmarkStyle to use when exporting to an HTML format.
Public Property | CharacterSet | Specifies the HTML character set to use when exporting to an HTML format.
Public Property | CreateFramesetPage | Specifies if a Frameset page should be created when exporting to an HTML format.
Public Property | IncludeHtmlHeader | Specifies if an HTML header section should be created when exporting to an HTML format.
Public Property | IncludePageMargins | Specifies if the report margins should be used when exporting to an HTML format.
Public Property | MultiPage | Specifies if the report should be exported to multiple pages when exporting to an HTML format.
Public Property | OutputType | Specifies the HTML output type to be used with exporting to an HTML viewer type.
Public Property | RemoveVerticalSpace | Specifies if vertical spacing should be removed when exporting to an HTML viewer type.
Public Property | Title | Specifies the text used in the HTML tags of the exported document when using an HTML viewer type.
Top
See Also

Reference

HtmlExportOptions Class
GrapeCity.ActiveReports.Web.ExportOptions Namespace


BookmarkStyle Property (HtmlExportOptions)

BookmarkStyle Property (HtmlExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > HtmlExportOptions Class : BookmarkStyle Property
Specifies a BookmarkStyle to use when exporting to an HTML format.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BookmarkStyle As BookmarkStyle
public BookmarkStyle BookmarkStyle {get; set;}
See Also

Reference

HtmlExportOptions Class
HtmlExportOptions Members


CharacterSet Property (HtmlExportOptions)

CharacterSet Property (HtmlExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > HtmlExportOptions Class : CharacterSet Property
Specifies the HTML character set to use when exporting to an HTML format.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CharacterSet As HtmlCharacterSet
public HtmlCharacterSet CharacterSet {get; set;}
See Also

Reference

HtmlExportOptions Class
HtmlExportOptions Members


CreateFramesetPage Property (HtmlExportOptions)

CreateFramesetPage Property (HtmlExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > HtmlExportOptions Class : CreateFramesetPage Property
Specifies if a Frameset page should be created when exporting to an HTML format.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CreateFramesetPage As System.Boolean
public System.bool CreateFramesetPage {get; set;}
See Also

Reference

HtmlExportOptions Class
HtmlExportOptions Members


IncludeHtmlHeader Property (HtmlExportOptions)

IncludeHtmlHeader Property (HtmlExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > HtmlExportOptions Class : IncludeHtmlHeader Property
Specifies if an HTML header section should be created when exporting to an HTML format.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IncludeHtmlHeader As System.Boolean
public System.bool IncludeHtmlHeader {get; set;}
See Also

Reference

HtmlExportOptions Class
HtmlExportOptions Members


IncludePageMargins Property (HtmlExportOptions)

IncludePageMargins Property (HtmlExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > HtmlExportOptions Class : IncludePageMargins Property
Specifies if the report margins should be used when exporting to an HTML format.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IncludePageMargins As System.Boolean
public System.bool IncludePageMargins {get; set;}
See Also

Reference

HtmlExportOptions Class
HtmlExportOptions Members


MultiPage Property (HtmlExportOptions)

MultiPage Property (HtmlExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > HtmlExportOptions Class : MultiPage Property
Specifies if the report should be exported to multiple pages when exporting to an HTML format.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MultiPage As System.Boolean
public System.bool MultiPage {get; set;}
See Also

Reference

HtmlExportOptions Class
HtmlExportOptions Members


OutputType Property (HtmlExportOptions)

OutputType Property (HtmlExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > HtmlExportOptions Class : OutputType Property
Specifies the HTML output type to be used with exporting to an HTML viewer type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OutputType As HtmlOutputType
public HtmlOutputType OutputType {get; set;}
See Also

Reference

HtmlExportOptions Class
HtmlExportOptions Members


RemoveVerticalSpace Property (HtmlExportOptions)

RemoveVerticalSpace Property (HtmlExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > HtmlExportOptions Class : RemoveVerticalSpace Property
Specifies if vertical spacing should be removed when exporting to an HTML viewer type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RemoveVerticalSpace As System.Boolean
public System.bool RemoveVerticalSpace {get; set;}
See Also

Reference

HtmlExportOptions Class
HtmlExportOptions Members


Title Property (HtmlExportOptions)

Title Property (HtmlExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > HtmlExportOptions Class : Title Property
Specifies the text used in the HTML tags of the exported document when using an HTML viewer type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Title As System.String
public System.string Title {get; set;}
See Also

Reference

HtmlExportOptions Class
HtmlExportOptions Members


PdfExportOptions Class

PdfExportOptions Class
Members

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : PdfExportOptions Class
Allows you to set options when using the PDF ViewerType.
Object Model
PdfExportOptions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class PdfExportOptions
public class PdfExportOptions
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.ExportOptions.PdfExportOptions

See Also

Reference

PdfExportOptions Members
GrapeCity.ActiveReports.Web.ExportOptions Namespace


PdfExportOptions Class Members

PdfExportOptions Class Members
Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : PdfExportOptions Class

The following tables list the members exposed by PdfExportOptions.

Public Properties
 | Name | Description
Public Property | Application | Specifies the Application used to produce the PDF when using the PDF Viewer type.
Public Property | Author | Specifies the Author of the PDF when using the PDF Viewer type.
Public Property | CenterWindow | Specifies if the export should include the CenterWindow flag in the PDF document when using the PDF Viewer type.
Public Property | ConvertMetaToPng | Specifies if the PDF Export should convert WMF/EMF images into PNG for the PDF Viewer type.
Public Property | DisplayMode | Specifies the PDF DisplayMode when using the PDF Viewer type.
Public Property | DisplayTitle | Specifies the PDF DisplayTitle when using the PDF Viewer type.
Public Property | Encrypt | Specifies if the export should encrypt the PDF when using the PDF Viewer type.
Public Property | ExportBookmarks | Specifies if the PDF Export should export bookmarks for the PDF Viewer type.
Public Property | FileName | Gets or sets the name of an exported file in the Save file dialog.
Public Property | FitWindow | Specifies if the export should use the FitWindow flag when using the PDF Viewer type.
Public Property | FontFallback | Gets or sets a comma-delimited string of font families that will be used to lookup glyphs that are missing in the original font (Professional Edition).
Public Property | HideMenubar | Specifies if the export should use the hideMenubar flag when using the PDF Viewer type.
Public Property | HideToolbar | Specifies if the export should use the HideToolbar flag when using the PDF Viewer type.
Public Property | HideWindowUI | Specifies if the export should use the HideWindowUI flag when using the PDF Viewer type.
Public Property | ImageQuality | Specifies the ImageQuality the PDF Export should use for the PDF Viewer type.
Public Property | ImageResolution | Specifies the ImageResolution the PDF Export should use for the PDF Viewer type.
Public Property | Keywords | Specifies the Keywords the export will embed in the PDF when using the PDF Viewer type.
Public Property | NeverEmbedFonts | Specifies the fonts the PDF Export should not embed for the PDF Viewer type.
Public Property | OnlyForPrint | Gets or sets a value indicating whether the PDF is only for print.
Public Property | OwnerPassword | Specifies the PDF Owner's password when using the PDF Viewer type and the Encrypt property is set to true. If this value is left null or empty, the user is not granted full permissions to the pdf file security settings.
Public Property | Permissions | Specifies the PDF permissions when using the PDF Viewer type and the Encrypt property is set to true.
Public Property | Subject | Specifies the Subject the export will use when using the PDF Viewer type.
Public Property | Title | Specifies the Title the export will use when using the PDF Viewer type.
Public Property | Use128Bit | Specifies if the export should use 128Bit encryption when using the PDF Viewer type and the Encrypt property is set to true.
Public Property | UserPassword | Specifies the PDF User's password when using the PDF Viewer type and the Encrypt property is set to true.
Public Property | Version | Specifies the PDF Version to use when using the PDF Viewer type.
Top
See Also

Reference

PdfExportOptions Class
GrapeCity.ActiveReports.Web.ExportOptions Namespace


PdfExportOptions Class Properties

PdfExportOptions Class Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : PdfExportOptions Class

For a list of all members of this type, see PdfExportOptions members.

Public Properties
 | Name | Description
Public Property | Application | Specifies the Application used to produce the PDF when using the PDF Viewer type.
Public Property | Author | Specifies the Author of the PDF when using the PDF Viewer type.
Public Property | CenterWindow | Specifies if the export should include the CenterWindow flag in the PDF document when using the PDF Viewer type.
Public Property | ConvertMetaToPng | Specifies if the PDF Export should convert WMF/EMF images into PNG for the PDF Viewer type.
Public Property | DisplayMode | Specifies the PDF DisplayMode when using the PDF Viewer type.
Public Property | DisplayTitle | Specifies the PDF DisplayTitle when using the PDF Viewer type.
Public Property | Encrypt | Specifies if the export should encrypt the PDF when using the PDF Viewer type.
Public Property | ExportBookmarks | Specifies if the PDF Export should export bookmarks for the PDF Viewer type.
Public Property | FileName | Gets or sets the name of an exported file in the Save file dialog.
Public Property | FitWindow | Specifies if the export should use the FitWindow flag when using the PDF Viewer type.
Public Property | FontFallback | Gets or sets a comma-delimited string of font families that will be used to lookup glyphs that are missing in the original font (Professional Edition).
Public Property | HideMenubar | Specifies if the export should use the hideMenubar flag when using the PDF Viewer type.
Public Property | HideToolbar | Specifies if the export should use the HideToolbar flag when using the PDF Viewer type.
Public Property | HideWindowUI | Specifies if the export should use the HideWindowUI flag when using the PDF Viewer type.
Public Property | ImageQuality | Specifies the ImageQuality the PDF Export should use for the PDF Viewer type.
Public Property | ImageResolution | Specifies the ImageResolution the PDF Export should use for the PDF Viewer type.
Public Property | Keywords | Specifies the Keywords the export will embed in the PDF when using the PDF Viewer type.
Public Property | NeverEmbedFonts | Specifies the fonts the PDF Export should not embed for the PDF Viewer type.
Public Property | OnlyForPrint | Gets or sets a value indicating whether the PDF is only for print.
Public Property | OwnerPassword | Specifies the PDF Owner's password when using the PDF Viewer type and the Encrypt property is set to true. If this value is left null or empty, the user is not granted full permissions to the pdf file security settings.
Public Property | Permissions | Specifies the PDF permissions when using the PDF Viewer type and the Encrypt property is set to true.
Public Property | Subject | Specifies the Subject the export will use when using the PDF Viewer type.
Public Property | Title | Specifies the Title the export will use when using the PDF Viewer type.
Public Property | Use128Bit | Specifies if the export should use 128Bit encryption when using the PDF Viewer type and the Encrypt property is set to true.
Public Property | UserPassword | Specifies the PDF User's password when using the PDF Viewer type and the Encrypt property is set to true.
Public Property | Version | Specifies the PDF Version to use when using the PDF Viewer type.
Top
See Also

Reference

PdfExportOptions Class
GrapeCity.ActiveReports.Web.ExportOptions Namespace


Application Property (PdfExportOptions)

Application Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : Application Property
Specifies the Application used to produce the PDF when using the PDF Viewer type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Application As System.String
public System.string Application {get; set;}
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


Author Property (PdfExportOptions)

Author Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : Author Property
Specifies the Author of the PDF when using the PDF Viewer type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Author As System.String
public System.string Author {get; set;}
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


CenterWindow Property (PdfExportOptions)

CenterWindow Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : CenterWindow Property
Specifies if the export should include the CenterWindow flag in the PDF document when using the PDF Viewer type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CenterWindow As System.Boolean
public System.bool CenterWindow {get; set;}
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


ConvertMetaToPng Property (PdfExportOptions)

ConvertMetaToPng Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : ConvertMetaToPng Property
Specifies if the PDF Export should convert WMF/EMF images into PNG for the PDF Viewer type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ConvertMetaToPng As System.Boolean
public System.bool ConvertMetaToPng {get; set;}
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


DisplayMode Property (PdfExportOptions)

DisplayMode Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : DisplayMode Property
Specifies the PDF DisplayMode when using the PDF Viewer type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DisplayMode As DisplayMode
public DisplayMode DisplayMode {get; set;}
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


DisplayTitle Property (PdfExportOptions)

DisplayTitle Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : DisplayTitle Property
Specifies the PDF DisplayTitle when using the PDF Viewer type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DisplayTitle As System.Boolean
public System.bool DisplayTitle {get; set;}
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


Encrypt Property (PdfExportOptions)

Encrypt Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : Encrypt Property
Specifies if the export should encrypt the PDF when using the PDF Viewer type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Encrypt As System.Boolean
public System.bool Encrypt {get; set;}
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


ExportBookmarks Property (PdfExportOptions)

ExportBookmarks Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : ExportBookmarks Property
Specifies if the PDF Export should export bookmarks for the PDF Viewer type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ExportBookmarks As System.Boolean
public System.bool ExportBookmarks {get; set;}
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


FileName Property (PdfExportOptions)

FileName Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : FileName Property
Gets or sets the name of an exported file in the Save file dialog.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FileName As System.String
public System.string FileName {get; set;}

Property Value

The name of the file.
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


FitWindow Property (PdfExportOptions)

FitWindow Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : FitWindow Property
Specifies if the export should use the FitWindow flag when using the PDF Viewer type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FitWindow As System.Boolean
public System.bool FitWindow {get; set;}
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


FontFallback Property (PdfExportOptions)

FontFallback Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : FontFallback Property
Gets or sets a comma-delimited string of font families that will be used to lookup glyphs that are missing in the original font (Professional Edition).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontFallback As System.String
public System.string FontFallback {get; set;}
Remarks

This feature is for use with the Professional Edition license only.

Note: The value of this property is ignored when used with the Standard Edition license. Some characters are not guaranteed to render correctly in the generated PDF.

See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


HideMenubar Property (PdfExportOptions)

HideMenubar Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : HideMenubar Property
Specifies if the export should use the hideMenubar flag when using the PDF Viewer type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HideMenubar As System.Boolean
public System.bool HideMenubar {get; set;}
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


HideToolbar Property (PdfExportOptions)

HideToolbar Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : HideToolbar Property
Specifies if the export should use the HideToolbar flag when using the PDF Viewer type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HideToolbar As System.Boolean
public System.bool HideToolbar {get; set;}
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


HideWindowUI Property (PdfExportOptions)

HideWindowUI Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : HideWindowUI Property
Specifies if the export should use the HideWindowUI flag when using the PDF Viewer type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HideWindowUI As System.Boolean
public System.bool HideWindowUI {get; set;}
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


ImageQuality Property (PdfExportOptions)

ImageQuality Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : ImageQuality Property
Specifies the ImageQuality the PDF Export should use for the PDF Viewer type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ImageQuality As ImageQuality
public ImageQuality ImageQuality {get; set;}
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


ImageResolution Property (PdfExportOptions)

ImageResolution Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : ImageResolution Property
Specifies the ImageResolution the PDF Export should use for the PDF Viewer type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ImageResolution As System.Integer
public System.int ImageResolution {get; set;}
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


Keywords Property (PdfExportOptions)

Keywords Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : Keywords Property
Specifies the Keywords the export will embed in the PDF when using the PDF Viewer type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Keywords As System.String
public System.string Keywords {get; set;}
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


NeverEmbedFonts Property (PdfExportOptions)

NeverEmbedFonts Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : NeverEmbedFonts Property
Specifies the fonts the PDF Export should not embed for the PDF Viewer type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NeverEmbedFonts As System.String
public System.string NeverEmbedFonts {get; set;}
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


OnlyForPrint Property (PdfExportOptions)

OnlyForPrint Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : OnlyForPrint Property
Gets or sets a value indicating whether the PDF is only for print.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OnlyForPrint As System.Boolean
public System.bool OnlyForPrint {get; set;}
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


OwnerPassword Property (PdfExportOptions)

OwnerPassword Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : OwnerPassword Property
Specifies the PDF Owner's password when using the PDF Viewer type and the Encrypt property is set to true. If this value is left null or empty, the user is not granted full permissions to the pdf file security settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OwnerPassword As System.String
public System.string OwnerPassword {get; set;}
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


Permissions Property (PdfExportOptions)

Permissions Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : Permissions Property
Specifies the PDF permissions when using the PDF Viewer type and the Encrypt property is set to true.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Permissions As PdfPermissions
public PdfPermissions Permissions {get; set;}
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


Subject Property (PdfExportOptions)

Subject Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : Subject Property
Specifies the Subject the export will use when using the PDF Viewer type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Subject As System.String
public System.string Subject {get; set;}
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


Title Property (PdfExportOptions)

Title Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : Title Property
Specifies the Title the export will use when using the PDF Viewer type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Title As System.String
public System.string Title {get; set;}
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


Use128Bit Property (PdfExportOptions)

Use128Bit Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : Use128Bit Property
Specifies if the export should use 128Bit encryption when using the PDF Viewer type and the Encrypt property is set to true.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Use128Bit As System.Boolean
public System.bool Use128Bit {get; set;}
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


UserPassword Property (PdfExportOptions)

UserPassword Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : UserPassword Property
Specifies the PDF User's password when using the PDF Viewer type and the Encrypt property is set to true.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UserPassword As System.String
public System.string UserPassword {get; set;}
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


Version Property (PdfExportOptions)

Version Property (PdfExportOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > PdfExportOptions Class : Version Property
Specifies the PDF Version to use when using the PDF Viewer type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Version As PdfVersion
public PdfVersion Version {get; set;}
See Also

Reference

PdfExportOptions Class
PdfExportOptions Members


TocPanelOptions Class

TocPanelOptions Class
Members

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : TocPanelOptions Class
Allows you to set options for the table of contents pane for the FlashViewer ViewerType of the WebViewer control.
Object Model
TocPanelOptions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class TocPanelOptions
public sealed class TocPanelOptions
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.ExportOptions.TocPanelOptions

See Also

Reference

TocPanelOptions Members
GrapeCity.ActiveReports.Web.ExportOptions Namespace


TocPanelOptions Class Members

TocPanelOptions Class Members
Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : TocPanelOptions Class

The following tables list the members exposed by TocPanelOptions.

Public Constructors
 | Name | Description
Public Constructor | TocPanelOptions Constructor | Initializes a new instance of the TocPanelOptions class.
Top
Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the alignment of the table of contents pane.
Public Property | ShowThumbnails | Gets or sets the visibility of the pane with thumbnail views of pages in the FlashViewer.
Public Property | ShowToc | Gets or sets the visibility of the table of contents pane in the FlashViewer.
Public Property | Visible | Gets or sets a value indicating whether the control's table of contents pane is displayed.
Public Property | Width | Gets or sets the starting width value of the table of contents pane, in pixels.
Top
See Also

Reference

TocPanelOptions Class
GrapeCity.ActiveReports.Web.ExportOptions Namespace


TocPanelOptions Constructor

TocPanelOptions Constructor

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > TocPanelOptions Class : TocPanelOptions Constructor
Initializes a new instance of the TocPanelOptions class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public TocPanelOptions()
See Also

Reference

TocPanelOptions Class
TocPanelOptions Members


TocPanelOptions Class Properties

TocPanelOptions Class Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : TocPanelOptions Class

For a list of all members of this type, see TocPanelOptions members.

Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the alignment of the table of contents pane.
Public Property | ShowThumbnails | Gets or sets the visibility of the pane with thumbnail views of pages in the FlashViewer.
Public Property | ShowToc | Gets or sets the visibility of the table of contents pane in the FlashViewer.
Public Property | Visible | Gets or sets a value indicating whether the control's table of contents pane is displayed.
Public Property | Width | Gets or sets the starting width value of the table of contents pane, in pixels.
Top
See Also

Reference

TocPanelOptions Class
GrapeCity.ActiveReports.Web.ExportOptions Namespace


Alignment Property (TocPanelOptions)

Alignment Property (TocPanelOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > TocPanelOptions Class : Alignment Property
Gets or sets the alignment of the table of contents pane.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Alignment As TocPanelAlignment
public TocPanelAlignment Alignment {get; set;}
See Also

Reference

TocPanelOptions Class
TocPanelOptions Members


ShowThumbnails Property

ShowThumbnails Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > TocPanelOptions Class : ShowThumbnails Property
Gets or sets the visibility of the pane with thumbnail views of pages in the FlashViewer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShowThumbnails As System.Boolean
public System.bool ShowThumbnails {get; set;}
See Also

Reference

TocPanelOptions Class
TocPanelOptions Members


ShowToc Property

ShowToc Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > TocPanelOptions Class : ShowToc Property
Gets or sets the visibility of the table of contents pane in the FlashViewer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShowToc As System.Boolean
public System.bool ShowToc {get; set;}
See Also

Reference

TocPanelOptions Class
TocPanelOptions Members


Visible Property (TocPanelOptions)

Visible Property (TocPanelOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > TocPanelOptions Class : Visible Property
Gets or sets a value indicating whether the control's table of contents pane is displayed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}

Property Value

true if visible; otherwise, false.
See Also

Reference

TocPanelOptions Class
TocPanelOptions Members


Width Property (TocPanelOptions)

Width Property (TocPanelOptions)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace > TocPanelOptions Class : Width Property
Gets or sets the starting width value of the table of contents pane, in pixels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As System.Short
public System.short Width {get; set;}
Remarks
The default value is 160 px.
See Also

Reference

TocPanelOptions Class
TocPanelOptions Members


FlashViewerOptions.PaperOrientationOptions Enumeration

FlashViewerOptions.PaperOrientationOptions Enumeration

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : FlashViewerOptions.PaperOrientationOptions Enumeration
An enumeration of values indicating whether and how to adjust paper orientation in the FlashViewer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum FlashViewerOptions.PaperOrientationOptions
   Inherits System.Enum
public enum FlashViewerOptions.PaperOrientationOptions : System.Enum
Members
Member | Description
AdjustByFirstPage | The FlashViewer checks the first page, and if the orientation does not match that of the printer, adjusts the entire report without checking additional pages.
Auto | The FlashViewer checks every page and if necessary, rotates it 90 degrees so its orientation fits the paper.
None | Paper orientation is not adjusted in the FlashViewer.
Remarks
These settings only take effect in cases where, for example, the printer's orientation is Landscape while the report's orientation is Portrait.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Web.ExportOptions.FlashViewerOptions.PaperOrientationOptions

See Also

Reference

GrapeCity.ActiveReports.Web.ExportOptions Namespace


FlashViewerOptions.ScalePagesOptions Enumeration

FlashViewerOptions.ScalePagesOptions Enumeration

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : FlashViewerOptions.ScalePagesOptions Enumeration
An enumeration of values indicating whether and how to scale pages in the FlashViewer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum FlashViewerOptions.ScalePagesOptions
   Inherits System.Enum
public enum FlashViewerOptions.ScalePagesOptions : System.Enum
Members
Member | Description
AllowScaleUp | Pages scale up as well as down to best fit paper.
Auto | Pages are scaled down if they do not fit on the paper.
None | Pages are not scaled.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Web.ExportOptions.FlashViewerOptions.ScalePagesOptions

See Also

Reference

GrapeCity.ActiveReports.Web.ExportOptions Namespace


TocPanelAlignment Enumeration

TocPanelAlignment Enumeration

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : TocPanelAlignment Enumeration
Specifies the position of the table of contents pane.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TocPanelAlignment
   Inherits System.Enum
public enum TocPanelAlignment : System.Enum
Members
Member | Description
Left | The table of contents pane is aligned to the left edge of the viewer.
Right | The table of contents pane is aligned to the right edge of the viewer.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Web.ExportOptions.TocPanelAlignment

See Also

Reference

GrapeCity.ActiveReports.Web.ExportOptions Namespace


ViewType Enumeration

ViewType Enumeration

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : ViewType Enumeration
Specifies the page view type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ViewType
   Inherits System.Enum
public enum ViewType : System.Enum
Members
Member | Description
Continuous | The continuous page view.
MultiPage | The multiple page view.
Single | The single page view.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Web.ExportOptions.ViewType

See Also

Reference

GrapeCity.ActiveReports.Web.ExportOptions Namespace


WindowMode Enumeration

WindowMode Enumeration

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.ExportOptions Namespace : WindowMode Enumeration
An enumeration of window mode options for the ActiveReports WebForms WebViewer server control for ASP.NET.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum WindowMode
   Inherits System.Enum
public enum WindowMode : System.Enum
Members
Member | Description
Opaque | Filled background, the page background will not show through FlashViewer.
Transparent | Background of the HTML page is transparent, objects in the background will show through FlashViewer. This mode may slow the animation performance.
Window | FlashViewer is displayed in its own rectangular window on a web page.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
GrapeCity.ActiveReports.Web.ExportOptions.WindowMode

See Also

Reference

GrapeCity.ActiveReports.Web.ExportOptions Namespace


GrapeCity.ActiveReports.Web.Handlers Namespace

GrapeCity.ActiveReports.Web.Handlers Namespace
Inheritance Hierarchy
GrapeCity.ActiveReports.Web.v10 Assembly : GrapeCity.ActiveReports.Web.Handlers Namespace
The GrapeCity.ActiveReports.Web.Handlers namespace contains the classes which handle the report types for web consumption.
Classes
 | Class | Description
Class | ArHandlerBase | This component supports the ActiveReports.Web infrastructure and is not intended to be used directly from your code. This is a base class that contains some methods used between the report processing HttpHandlers for ActiveReports.
Class | CompiledReportHandler | By default the handler is registered with the *.ActiveReport file extension to pick up any request for an ActiveReport that has been compiled into a CLR/.NET assembly. The handler loads the ActiveReport from the specified assembly, runs and exports it to a specified format, defaulting to HTML.
Class | RdlxHandler | Should be registered with the *.rdlx file extension to pick up any request for an rdlx file and process it. The handler loads the rdlx file into ActiveReport, runs and exports it to a specified format, defaulting to HTML.
Class | ReportBinariesStreamer | Responsible for intercepting requests for "*.arXX".
Class | RpxHandler | Should be registered with the *.rpx file extension to pick up and process any request for an rpx file. The handler loads the rpx file into ActiveReports, runs and exports it to a specified format, defaulting to HTML.
Class | WebCacheAccessHandler | This component supports the ActiveReports.Web infrastructure and is not intended to be used directly from your code.
See Also

Reference

GrapeCity.ActiveReports.Web.v10 Assembly


ArHandlerBase Class

ArHandlerBase Class
Members

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : ArHandlerBase Class
This component supports the ActiveReports.Web infrastructure and is not intended to be used directly from your code. This is a base class that contains some methods used between the report processing HttpHandlers for ActiveReports.
Object Model
ArHandlerBase Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustInherit Class ArHandlerBase
public abstract class ArHandlerBase
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Handlers.ArHandlerBase
GrapeCity.ActiveReports.Web.Handlers.CompiledReportHandler
GrapeCity.ActiveReports.Web.Handlers.RdlxHandler
GrapeCity.ActiveReports.Web.Handlers.RpxHandler

See Also

Reference

ArHandlerBase Members
GrapeCity.ActiveReports.Web.Handlers Namespace


ArHandlerBase Class Members

ArHandlerBase Class Members
Properties Methods

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : ArHandlerBase Class

The following tables list the members exposed by ArHandlerBase.

Public Properties
 | Name | Description
Public Property | IsReusable | Returns a value indicating whether the class can be pooled.
Top
Public Methods
 | Name | Description
Public Method | ProcessRequest | This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Top
See Also

Reference

ArHandlerBase Class
GrapeCity.ActiveReports.Web.Handlers Namespace


ArHandlerBase Class Methods

ArHandlerBase Class Methods

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : ArHandlerBase Class

For a list of all members of this type, see ArHandlerBase members.

Public Methods
 | Name | Description
Public Method | ProcessRequest | This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Top
See Also

Reference

ArHandlerBase Class
GrapeCity.ActiveReports.Web.Handlers Namespace


ProcessRequest Method (ArHandlerBase)

ProcessRequest Method (ArHandlerBase)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > ArHandlerBase Class : ProcessRequest Method
Provides references to the intrinsic server objects (for example, Request, Response, Session, and Server) used to service HTTP requests.
This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Syntax
  • Visual Basic
  • C#
'Declaration

Public MustOverride Sub ProcessRequest( _
   ByVal context As System.Web.HttpContext _
)
public abstract void ProcessRequest(
   System.Web.HttpContext context
)

Parameters

context
Provides references to the intrinsic server objects (for example, Request, Response, Session, and Server) used to service HTTP requests.
See Also

Reference

ArHandlerBase Class
ArHandlerBase Members


ArHandlerBase Class Properties

ArHandlerBase Class Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : ArHandlerBase Class

For a list of all members of this type, see ArHandlerBase members.

Public Properties
 | Name | Description
Public Property | IsReusable | Returns a value indicating whether the class can be pooled.
Top
See Also

Reference

ArHandlerBase Class
GrapeCity.ActiveReports.Web.Handlers Namespace


IsReusable Property (ArHandlerBase)

IsReusable Property (ArHandlerBase)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > ArHandlerBase Class : IsReusable Property
Returns a value indicating whether the class can be pooled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsReusable As System.Boolean
public System.bool IsReusable {get;}

Property Value

True if the class can be pooled. The default value is true.
See Also

Reference

ArHandlerBase Class
ArHandlerBase Members


CompiledReportHandler Class

CompiledReportHandler Class
Members

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : CompiledReportHandler Class
By default the handler is registered with the *.ActiveReport file extension to pick up any request for an ActiveReport that has been compiled into a CLR/.NET assembly. The handler loads the ActiveReport from the specified assembly, runs and exports it to a specified format, defaulting to HTML.
Object Model
CompiledReportHandler Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class CompiledReportHandler
   Inherits ArHandlerBase
public sealed class CompiledReportHandler : ArHandlerBase
Remarks

Uses reflection to load the assembly and the specified report class; executes, and exports the report.

Assembly is to be specified as the first folder, and report class name as the subfolder. For example: http://localhost/MyAssemblyName/ActiveReport1.ActiveReport where MyAssemblyName.dll is the actual assembly filename, and ActiveReport1 the report class name. The special folder name indicating the assembly is evaluated from right to left, so if there are multiple folder levels, the folder name directly preceding the file name is always the assembly name.

For example, this would allow the following URL to be used: http://localhost/AnyFolder/AnySubFolder/MyAssemblyName/ActiveReport1.ActiveReport

You may also set any parameters you've added to the report's Parameters collection via the DataSource icon in the URL. For example:

http://localhost/AnyFolder/AnySubFolder/MyAssemblyName/ActiveReport1.ActiveReport?Country=USA

To use this handler you must enter the following into your web.config file (making sure to use the correct Version):

<httpHandlers>
<add verb="*" path="*.ActiveReport" type="GrapeCity.ActiveReports.Web.Handlers.CompiledReportHandler, GrapeCity.ActiveReports.Web.v10" />
</httpHandlers>

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Handlers.ArHandlerBase
GrapeCity.ActiveReports.Web.Handlers.CompiledReportHandler

See Also

Reference

CompiledReportHandler Members
GrapeCity.ActiveReports.Web.Handlers Namespace


CompiledReportHandler Class Members

CompiledReportHandler Class Members
Properties Methods

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : CompiledReportHandler Class

The following tables list the members exposed by CompiledReportHandler.

Public Constructors
 | Name | Description
Public Constructor | CompiledReportHandler Constructor | Initializes a new instance of the CompiledReportHandler class.
Top
Public Properties
 | Name | Description
Public Property | IsReusable | Returns a value indicating whether the class can be pooled. (Inherited from GrapeCity.ActiveReports.Web.Handlers.ArHandlerBase)
Top
Public Methods
 | Name | Description
Public Method | ProcessRequest | Overridden. This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Top
See Also

Reference

CompiledReportHandler Class
GrapeCity.ActiveReports.Web.Handlers Namespace


CompiledReportHandler Constructor

CompiledReportHandler Constructor

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > CompiledReportHandler Class : CompiledReportHandler Constructor
Initializes a new instance of the CompiledReportHandler class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public CompiledReportHandler()
See Also

Reference

CompiledReportHandler Class
CompiledReportHandler Members


CompiledReportHandler Class Methods

CompiledReportHandler Class Methods

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : CompiledReportHandler Class

For a list of all members of this type, see CompiledReportHandler members.

Public Methods
 | Name | Description
Public Method | ProcessRequest | Overridden. This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Top
See Also

Reference

CompiledReportHandler Class
GrapeCity.ActiveReports.Web.Handlers Namespace


ProcessRequest Method (CompiledReportHandler)

ProcessRequest Method (CompiledReportHandler)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > CompiledReportHandler Class : ProcessRequest Method
Provides references to the intrinsic server objects (for example, Request, Response, Session, and Server) used to service HTTP requests.
This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Sub ProcessRequest( _
   ByVal context As System.Web.HttpContext _
)
public override void ProcessRequest(
   System.Web.HttpContext context
)

Parameters

context
Provides references to the intrinsic server objects (for example, Request, Response, Session, and Server) used to service HTTP requests.
See Also

Reference

CompiledReportHandler Class
CompiledReportHandler Members


RdlxHandler Class

RdlxHandler Class
Members

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : RdlxHandler Class
Should be registered with the *.rdlx file extension to pick up any request for an rdlx file and process it. The handler loads the rdlx file into ActiveReport, runs and exports it to a specified format, defaulting to HTML.
Object Model
RdlxHandler Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class RdlxHandler
   Inherits ArHandlerBase
public sealed class RdlxHandler : ArHandlerBase
Remarks
To use this handler you must enter the following into your web.config file:
<httpHandlers>
<add verb="*" path="*.rdlx" type="GrapeCity.ActiveReports.Web.Handlers.RdlxHandler, GrapeCity.ActiveReports.Web.v10" />
</httpHandlers>
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Handlers.ArHandlerBase
GrapeCity.ActiveReports.Web.Handlers.RdlxHandler

See Also

Reference

RdlxHandler Members
GrapeCity.ActiveReports.Web.Handlers Namespace


RdlxHandler Class Members

RdlxHandler Class Members
Properties Methods

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : RdlxHandler Class

The following tables list the members exposed by RdlxHandler.

Public Constructors
 | Name | Description
Public Constructor | RdlxHandler Constructor | Initializes an instance of the RdlxHandler class.
Top
Public Properties
 | Name | Description
Public Property | IsReusable | Returns a value indicating whether the class can be pooled. (Inherited from GrapeCity.ActiveReports.Web.Handlers.ArHandlerBase)
Top
Public Methods
 | Name | Description
Public Method | ProcessRequest | Overridden. This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Top
See Also

Reference

RdlxHandler Class
GrapeCity.ActiveReports.Web.Handlers Namespace


RdlxHandler Constructor

RdlxHandler Constructor

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > RdlxHandler Class : RdlxHandler Constructor
Initializes an instance of the RdlxHandler class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public RdlxHandler()
See Also

Reference

RdlxHandler Class
RdlxHandler Members


RdlxHandler Class Methods

RdlxHandler Class Methods

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : RdlxHandler Class

For a list of all members of this type, see RdlxHandler members.

Public Methods
 | Name | Description
Public Method | ProcessRequest | Overridden. This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Top
See Also

Reference

RdlxHandler Class
GrapeCity.ActiveReports.Web.Handlers Namespace


ProcessRequest Method (RdlxHandler)

ProcessRequest Method (RdlxHandler)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > RdlxHandler Class : ProcessRequest Method
Provides references to the intrinsic server objects (for example, Request, Response, Session, and Server) used to service HTTP requests.
This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Sub ProcessRequest( _
   ByVal context As System.Web.HttpContext _
)
public override void ProcessRequest(
   System.Web.HttpContext context
)

Parameters

context
Provides references to the intrinsic server objects (for example, Request, Response, Session, and Server) used to service HTTP requests.
See Also

Reference

RdlxHandler Class
RdlxHandler Members


ReportBinariesStreamer Class

ReportBinariesStreamer Class
Members

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : ReportBinariesStreamer Class
Responsible for intercepting requests for "*.arXX".
Object Model
ReportBinariesStreamer Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ReportBinariesStreamer
public class ReportBinariesStreamer
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Handlers.ReportBinariesStreamer

See Also

Reference

ReportBinariesStreamer Members
GrapeCity.ActiveReports.Web.Handlers Namespace


ReportBinariesStreamer Class Members

ReportBinariesStreamer Class Members
Properties Methods

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : ReportBinariesStreamer Class

The following tables list the members exposed by ReportBinariesStreamer.

Public Constructors
 | Name | Description
Public Constructor | ReportBinariesStreamer Constructor | Initializes a new instance of the ReportBinariesStreamer class.
Top
Public Properties
 | Name | Description
Public Property | IsReusable | Returns a value indicating whether the class can be pooled.
Top
Public Methods
 | Name | Description
Public Method | ProcessRequest | This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Top
See Also

Reference

ReportBinariesStreamer Class
GrapeCity.ActiveReports.Web.Handlers Namespace


ReportBinariesStreamer Constructor

ReportBinariesStreamer Constructor

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > ReportBinariesStreamer Class : ReportBinariesStreamer Constructor
Initializes a new instance of the ReportBinariesStreamer class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public ReportBinariesStreamer()
See Also

Reference

ReportBinariesStreamer Class
ReportBinariesStreamer Members


ReportBinariesStreamer Class Methods

ReportBinariesStreamer Class Methods

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : ReportBinariesStreamer Class

For a list of all members of this type, see ReportBinariesStreamer members.

Public Methods
 | Name | Description
Public Method | ProcessRequest | This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Top
See Also

Reference

ReportBinariesStreamer Class
GrapeCity.ActiveReports.Web.Handlers Namespace


ProcessRequest Method (ReportBinariesStreamer)

ProcessRequest Method (ReportBinariesStreamer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > ReportBinariesStreamer Class : ProcessRequest Method
Provides references to the intrinsic server objects (for example, Request, Response, Session, and Server) used to service HTTP requests.
This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ProcessRequest( _
   ByVal context As System.Web.HttpContext _
)
public void ProcessRequest(
   System.Web.HttpContext context
)

Parameters

context
Provides references to the intrinsic server objects (for example, Request, Response, Session, and Server) used to service HTTP requests.
See Also

Reference

ReportBinariesStreamer Class
ReportBinariesStreamer Members


ReportBinariesStreamer Class Properties

ReportBinariesStreamer Class Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : ReportBinariesStreamer Class

For a list of all members of this type, see ReportBinariesStreamer members.

Public Properties
 | Name | Description
Public Property | IsReusable | Returns a value indicating whether the class can be pooled.
Top
See Also

Reference

ReportBinariesStreamer Class
GrapeCity.ActiveReports.Web.Handlers Namespace


IsReusable Property (ReportBinariesStreamer)

IsReusable Property (ReportBinariesStreamer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > ReportBinariesStreamer Class : IsReusable Property
Returns a value indicating whether the class can be pooled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsReusable As System.Boolean
public System.bool IsReusable {get;}

Property Value

True if the class can be pooled. The default value is true.
See Also

Reference

ReportBinariesStreamer Class
ReportBinariesStreamer Members


RpxHandler Class

RpxHandler Class
Members

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : RpxHandler Class
Should be registered with the *.rpx file extension to pick up and process any request for an rpx file. The handler loads the rpx file into ActiveReports, runs and exports it to a specified format, defaulting to HTML.
Object Model
RpxHandler Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class RpxHandler
   Inherits ArHandlerBase
public sealed class RpxHandler : ArHandlerBase
Remarks

To use this handler you must enter the following into your web.config file (making sure that the Version is correct):

<httpHandlers>
<add verb="*" path="*.rpx" type="GrapeCity.ActiveReports.Web.Handlers.RpxHandler, ActiveReports.Web, Version=5.0.0.105, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" />
</httpHandlers>

You may also set any parameters you've added to the report's Parameters collection via the DataSource icon in the URL. For example:

http://localhost/AnyFolder/AnySubFolder/MyAssemblyName/ActiveReport1.rpx?Country=USA

Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Handlers.ArHandlerBase
GrapeCity.ActiveReports.Web.Handlers.RpxHandler

See Also

Reference

RpxHandler Members
GrapeCity.ActiveReports.Web.Handlers Namespace


RpxHandler Class Members

RpxHandler Class Members
Properties Methods

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : RpxHandler Class

The following tables list the members exposed by RpxHandler.

Public Constructors
 | Name | Description
Public Constructor | RpxHandler Constructor | Initializes a new instance of the RpxHandler class.
Top
Public Properties
 | Name | Description
Public Property | IsReusable | Returns a value indicating whether the class can be pooled. (Inherited from GrapeCity.ActiveReports.Web.Handlers.ArHandlerBase)
Top
Public Methods
 | Name | Description
Public Method | ProcessRequest | Overridden. This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Top
See Also

Reference

RpxHandler Class
GrapeCity.ActiveReports.Web.Handlers Namespace


RpxHandler Constructor

RpxHandler Constructor

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > RpxHandler Class : RpxHandler Constructor
Initializes a new instance of the RpxHandler class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public RpxHandler()
See Also

Reference

RpxHandler Class
RpxHandler Members


RpxHandler Class Methods

RpxHandler Class Methods

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : RpxHandler Class

For a list of all members of this type, see RpxHandler members.

Public Methods
 | Name | Description
Public Method | ProcessRequest | Overridden. This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Top
See Also

Reference

RpxHandler Class
GrapeCity.ActiveReports.Web.Handlers Namespace


ProcessRequest Method (RpxHandler)

ProcessRequest Method (RpxHandler)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > RpxHandler Class : ProcessRequest Method
Provides references to the intrinsic server objects (for example, Request, Response, Session, and Server) used to service HTTP requests.
This is the method that ASP.NET will use to allow the handler to handle a request. Essentially all handler work begins with this method.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides NotOverridable Sub ProcessRequest( _
   ByVal context As System.Web.HttpContext _
)
public override void ProcessRequest(
   System.Web.HttpContext context
)

Parameters

context
Provides references to the intrinsic server objects (for example, Request, Response, Session, and Server) used to service HTTP requests.
See Also

Reference

RpxHandler Class
RpxHandler Members


WebCacheAccessHandler Class

WebCacheAccessHandler Class
Members

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : WebCacheAccessHandler Class
This component supports the ActiveReports.Web infrastructure and is not intended to be used directly from your code.
Object Model
WebCacheAccessHandler Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class WebCacheAccessHandler
public sealed class WebCacheAccessHandler
Inheritance Hierarchy

System.Object
GrapeCity.ActiveReports.Web.Handlers.WebCacheAccessHandler

See Also

Reference

WebCacheAccessHandler Members
GrapeCity.ActiveReports.Web.Handlers Namespace


WebCacheAccessHandler Class Members

WebCacheAccessHandler Class Members
Properties Methods

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : WebCacheAccessHandler Class

The following tables list the members exposed by WebCacheAccessHandler.

Public Constructors
 | Name | Description
Public Constructor | WebCacheAccessHandler Constructor | Initializes a new instance of the WebCacheAccessHandler class.
Top
Public Properties
 | Name | Description
Public Property | IsReusable | An implementation of IHttpHandler.IsReusable.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | GenCacheKey | Generates a WebCache key for the items being cached.
Public Method | ProcessRequest | An implementation of IHttpHandler.ProcessRequest.
Top
See Also

Reference

WebCacheAccessHandler Class
GrapeCity.ActiveReports.Web.Handlers Namespace


WebCacheAccessHandler Constructor

WebCacheAccessHandler Constructor

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > WebCacheAccessHandler Class : WebCacheAccessHandler Constructor
Initializes a new instance of the WebCacheAccessHandler class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
public WebCacheAccessHandler()
See Also

Reference

WebCacheAccessHandler Class
WebCacheAccessHandler Members


WebCacheAccessHandler Class Methods

WebCacheAccessHandler Class Methods

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : WebCacheAccessHandler Class

For a list of all members of this type, see WebCacheAccessHandler members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | GenCacheKey | Generates a WebCache key for the items being cached.
Public Method | ProcessRequest | An implementation of IHttpHandler.ProcessRequest.
Top
See Also

Reference

WebCacheAccessHandler Class
GrapeCity.ActiveReports.Web.Handlers Namespace


GenCacheKey Method

GenCacheKey Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > WebCacheAccessHandler Class : GenCacheKey Method
Generates a WebCache key for the items being cached.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function GenCacheKey() As System.String
public static System.string GenCacheKey()
See Also

Reference

WebCacheAccessHandler Class
WebCacheAccessHandler Members


ProcessRequest Method (WebCacheAccessHandler)

ProcessRequest Method (WebCacheAccessHandler)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > WebCacheAccessHandler Class : ProcessRequest Method
An HttpContext object that provides references to the intrinsic server objects
An implementation of IHttpHandler.ProcessRequest.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ProcessRequest( _
   ByVal context As System.Web.HttpContext _
)
public void ProcessRequest(
   System.Web.HttpContext context
)

Parameters

context
An HttpContext object that provides references to the intrinsic server objects
See Also

Reference

WebCacheAccessHandler Class
WebCacheAccessHandler Members


WebCacheAccessHandler Class Properties

WebCacheAccessHandler Class Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : WebCacheAccessHandler Class

For a list of all members of this type, see WebCacheAccessHandler members.

Public Properties
 | Name | Description
Public Property | IsReusable | An implementation of IHttpHandler.IsReusable.
Top
See Also

Reference

WebCacheAccessHandler Class
GrapeCity.ActiveReports.Web.Handlers Namespace


IsReusable Property (WebCacheAccessHandler)

IsReusable Property (WebCacheAccessHandler)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace > WebCacheAccessHandler Class : IsReusable Property
An implementation of IHttpHandler.IsReusable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsReusable As System.Boolean
public System.bool IsReusable {get;}
See Also

Reference

WebCacheAccessHandler Class
WebCacheAccessHandler Members


API

API

Learn about the samples that fall under the API category.

This section contains:

Custom Resource Locator
This Custom Resource Locator sample showcases a custom implementation of the resource locator to load pictures from the user's "My Pictures" directory.
See Also
Data


Layout Files with Embedded Script

Layout Files with Embedded Script

ActiveReports allows you to embed script in reports so that code becomes portable when you save a report layout to XML-based RPX format. This characteristic allows the options of stand-alone reporting and web reporting without the need to distribute related .vb or .cs files.

By embedding script when the report is saved as an RPX file, it can later by loaded, run and displayed directly to the viewer control without using the designer. Script can also be used in conjunction with RPX files to allow distributed reports to be updated without recompiling the Visual Studio project.

Script for Simple Reports
Describes how to embed script in a simple stand-alone report.
Script for Subreports
Describes how to embed script to pass a parameter to a subreport.
See Also

How To

Add Code to Layouts Using Script


Subreport Walkthroughs

Subreport Walkthroughs

Follow step-by-step tutorials as you create Visual Studio projects using the ActiveReports Subreport control. You can use the subreport control to embed a report within another report. Subreports are executed each time the parent section (i.e. the section in which the Subreport control is placed) is printed. Some ways to use subreports include:

  • Repeating a group of relational data (for example, a list of orders in the main report, with ordered items in the subreport)
  • Using multiple data sources within a report
  • Creating multiple detail sections within a report
Subreports with Run-Time Data Sources
Learn how to embed a subreport in a main report, passing the data source from the main report to the subreport at run time.
Subreports with XML Data
Learn how to use XML data with subreports.


Run Time or Ad Hoc Reporting

Run Time or Ad Hoc Reporting

ActiveReports allows objects, controls and the data source to be completely accessible at run time. These properties can be modified to provide a dynamic view of your report.

Run Time Layouts
Describes how to create and modify report layouts dynamically.
Run Time Data Sources
Describes how to change the report data source at run time using the ReportStart event.


Web Services

Web Services

ActiveReports provides support for web services to be used to return a dataset as a data source for a report or to return an ActiveReport document to show in a Windows Forms viewer. The following walkthroughs show how to create a simple web service for each scenario and how to create a Windows client application for each web service.

DataSet Web Service
Describes how to set up a simple web service that returns a dataset.
DataSet Windows Application
Describes how to set up a Windows client application for the dataset Web Service.
Document Web Service
Describes how to set up a simple web service that returns an ActiveReports document.
Document Windows Application
Describes how to set up a Windows client application for the ActiveReports Document Web Service.
Important: In order to consume Web services in your Windows applications, you must set permissions to allow the ASP.NET user to consume the services. Ask your server administrator for help with this.


Overflow Data in a Single Page

Overflow Data in a Single Page
Show All Show All
Hide All Hide All

In a Page report, ActiveReports allows you to arrange the OverflowPlaceHolder controls at any location on the same page along with the host data region to build a rich report layout. The following walkthrough demonstrates this by using a Table data region and three OverflowPlaceHolder controls on a single page to create a columnar display.

This walkthrough is split into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting to a the data source
  • Adding a dataset
  • Creating a columnar layout
  • Viewing the report
Note: This topic uses the Movie table in the Reels database. By default, in ActiveReports, the Reels.mdb file is located at [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\Reels.mdb.

When you complete this walkthrough, you get a report that looks similar to the following:

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 Page Report and in the Name field, rename the file as rptColumnarLayout.
  4. Click the Add button to open a new fixed page report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialogthat appears, select the General page and in the Name field, enter a name like ColumnData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as MovieList. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query
    Copy Code
    SELECT * FROM Movie
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.

  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To create a layout for the report

  1. In the Visual Studio toolbox, go to ActiveReports 10 Page Report tab and drag a TextBox control onto the design surface.
  2. Select the TextBox control and go to the properties window to set the following properties. This TextBox functions as the title in the report layout.
    Property Name | Property Value
    Location | 0in, 0in
    BackgroundColor | DarkCyan
    Font | Normal, Arial, 20pt, Bold
    Size | 6.5in, 0.5in
    TextAlign | Center
    Value | Movie Database
    VerticalAlign | Middle
  3. From the Visual Studio toolbox, drag and drop a Table data region onto the design surface and set its following properties in the properties window.
    Property Name | Property Value
    Location | 0.125in, 1in
    BackgroundColor | Azure
    RepeatHeaderOnNewPage | True
    Size | 3in, 0.66in
    FixedSize | 3in, 3.5in
    OverflowName OverflowPlaceHolder1
    Note: Set this property after you add the OverflowPlaceHolder1 to the design surface in the next step, to handle the data that exceeds the fixed size of the Table data region.
  4. In the table details row, add the following fields using the field selection adorner:
    Cell | Field Name
    Left | Title
    Center | YearReleased
    Right | UserRating
  5. In the table details row, select the left cell containing the Title field and go to the Properties window to set the ShrinkToFit property to True. This will avoid clipping of longer movie titles and fit the string in the same cell in a smaller font size.
  6. In the design view, select the following rows of the Table data region by clicking the table handle to the left of the row and go to the Properties window to set the following properties:
    Row Property Name
    TableHeader BackgroundColor: PaleTurquoise
    BorderStyle: Solid
    FontSize: 10pt
    FontWeight: Bold
    TextAlign: Left
    TableDetail BorderStyle: Solid
    TextAlign: Left
    FontSize: 9pt
  7. From the Visual Studio toolbox, drag and drop three OverflowPlaceHolder controls onto the design surface and the set the following properties in the Properties window for each of them so that the data appears in a columnar format.
    Control Name | Property
    OverflowPlaceHolder1 Location: 3.375in, 1in
    OverflowName: OverflowPalceHolder2
    Note: Set this property after you add the OverflowPlaceHolder2 to the design surface.
    OverflowPlaceHolder2 Location: 0.125in, 5in
    OverflowName: OverflowPlaceHolder3
    Note: Set this property after you add the OverflowPlaceHolder3 to the design surface.
    OverflowPlaceHolder3 | Location: 3.375in, 5in
    Note: Notice that the OverflowName property is set to link each OverflowPlaceHolder control to the next one.

Once you have completed the steps above, you get a layout that looks similar to the following at design time. This is the same layout that you see on preview or at runtime.

To view the Report

  • Click the preview tab to view the report.

OR

  • See Windows Forms Viewer to display report in the Viewer at runtime.

Notice that the report layout is similar to the one you saw at design time except for the data which is added to the report on preview or at runtime.

See Also
Connect to a Data Source
Add a Dataset

Concepts

OverflowPlaceHolder


Data

Data

Learn about the sample that fall under the Data category.

This section contains:

DataSet DataSource
The PageUnboundData sample demonstrates how to connect a page report to an unbound data source at runtime, using the DataSet provider with the LocateDataSource event.
See Also
API


Data Types

Data Types


Development Steps

Development Steps


Glossary

Glossary
A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z | 累

A

ActiveReports Server
ActiveReports Server is a reporting server that gives you a secure place to deploy and execute reports. Server administrators use the Administrator dashboard to manage reports, data, and user permissions. End users use the report portal to locate, view, and export reports.

D

data region
Data regions are report controls (Table, List, Banded List, Tablix and Chart) in page reports that can contain other report controls.

design surface
Part of the report design view that lets you create or edit report layouts using controls or data regions in Visual Studio or Stand-Alone Designer Application.

Design View

designer buttons
Buttons located at the bottom of the report designer tabs adjacent to the designer surface.

Designer tab
Default tab that is used to create layouts, connect to a data source or implement other design time features.

designer tabs
Designer, Script and Preview tabs located at the bottom of the report designer surface.

detail

The only required section in a section-based report. This section repeats once for every row of data in the report.

document map
A table of contents for the report in the viewer. When a user clicks an item in the document map, the viewer jumps to that item in the report.

E

ESRI shapefile
An ESRI Shapefile is a collection of files, where a .shp file defines the geographical or geometrical shapes and the .dbf file provides attributes for the shapes in the .shp file. To successfully add spatial data using this option, both files (.shp and .dbf) must be copied to the same folder. ESRI files are available on public domain data sources on the Web, including government and university sites. For more information, go to www.census.gov/geo/maps-data/data/tiger.html.

F

field selection adorner
An icon that appears when you hover over a textbox. It is used to quickly bind the textbox to a field from the DataSet. Selecting a field through this adorner adds a field expression similar to the one that is added when you drag a field into a control from the ReportExplorer.

fixed page
Refers to a page in the Page report represented by the Page node in the Report Explorer.

FixedPage dialog
Dialog that contains the properties to be set for the fixed page in a Page report. You can access this dialog when you right-click on the gray area of the report designer and select Fixed Layout Settings... from the context menu. Alternatively, with the Page selected on the report, right-click and open the Properties window to select the Property dialog... link at the bottom.

FixedSize
FixedSize property expands the area of a data region upto a set size in case of excessive data. You can use the Properties Window to enter the property value manually, or you can also set the FixedSize by dragging the grey adorners that appears at the bottom and on the right side of a data region.

G

Group Editor
Group Editor window is specifically designed to manage the tablix structure. It consists of a Row Groups pane and a Column Groups pane. The Group Editor window displays the row and column groups for the currently selected Tablix data region on the design surface.

group footer
Section inserted below the detail section in a section report, where grouping is set.

group header
Section inserted above the detail section in a section report, where grouping is set.

L

Layers
Layers are a named group of controls.

layers pane
The area labeled "Right click to add the new layer." that appears at the bottom of the Map data region. It display the list of layers that are defined for the map. Use this pane to add, delete or edit a layer.

P

page footer
Section that appears at the bottom of each page of a section report. You can also add a page footer to a page report if you convert it to RDL.

page header
Section that appears at the top of each page of a section report. You can also add a page header to a page report if you convert it to RDL.

page layout
Report layout type where designing is done on a page to provide a dynamic layout environment.

Page report
Report type where designing is done on a page to provide a dynamic layout environmennt. This type allows you to create forms and other layouts that do not allow report controls to change sizes based on the data.

Page Report
Report type where designing is done on a page to provide a dynamic layout environmennt. This type allows you to create forms and other layouts that do not allow report controls to change sizes based on the data.

polygon center points
Markers that gets displayed at the center of each polygon

preview
Tab to view the report without actually running the application containing the report.

Preview tab
Tab to view the report without actually running the application containing the report.

Professional Edition
This is a license for ActiveReports that includes all of the features of the Standard Edition, plus the WebViewer control, the Silverlight Viewer control, HTTP Handlers, the Designer control, the ReportExplorer control, the Toolbox control, and advanced PDF and Font features.

properties window

R

RDL

Report Definition Layout (RDL) is a report type that allows report controls to increase in size to accommodate your data.

RDL report
Report Definition Layout (RDL) is a report type that allows report controls to increase in size to accommodate your data.

RDLX
Report Definition Language Extended file. This is a layout file for page reports and RDL reports.

RDLX-master
Report Definition Language Extended Master file. This is a layout file for RDL reports that allows you to specify standard elements to apply to all content reports that use it.

remote report
Remote reports are stored and executed on an instance of ActiveReports Server.

remote reports
Remote reports are stored and executed on an instance of ActiveReports Server.

report layout
Layouts available in ActiveReports for designing reports. The two layout types are, Section Layout and Page Layout.

report list
In ActiveReports Server, all the reports are displayed under Report List on the Report Portal. Users can preview, design or delete and more from the Report List. Report List is managed by the server end users.

RPX
Report XML file. This is a layout file for section-based reports. It can contain VB.NET or C# script, but does not contain code that may have been added behind the report.

S

Scope
A parameter for functions, which the grouping, data region, or dataset to be considered when calculating the aggregate or other function.

Script tab
Tab used to add VB.NET or C# functionality through script.

section layout
Report layout type where designing is done in banded sections. There is always a detail section present, while header and footer sections (report, page, or group) can be added or removed as you require.

Section Report
Report type where designing is done in banded sections. There is always a detail section present, while header and footer sections(report, page, or group) can be added or removed as you require.

snap lines
Helper lines to show relative position of the control with other controls.

snap to grid
Feature to move controls and data regions from one grid line to another on the report design surface.

Stand-alone Designer Application
Refers to GrapeCity.ActiveReports.Designer.exe bundled with ActiveReports. This application provides major features of the Designer to create or save reports and works on systems which do not have Visual Studio installed.

Standard Edition
This is a license for ActiveReports that includes the Windows Forms Viewer control, all of the exports, and the Visual Studio report designer.

T

table details
Middle row of the Table data region, that functions as the detail row for the table. When you drag a field into a cell in the table detail row, a label is added automatically in the table header row.

Tablix
A Tablix data region provides enhanced layout capabilities ranging from creation of simple tables to complex grid layouts in Page and RDL reports.

Transitional

The Excel file generated by scheduled task execution using Strict (the default value of OpenXMLStandard) cannot be viewed on IOS devices. To change the default value of OpenXMLStandard, add following configuration settings in GrapeCity.ActiveReports.config file:

<ReportingConfiguration>
  <Extensions>
    <Render>
      <Extension Name="Excel" Type="GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtension, GrapeCity.ActiveReports.Export.Excel.v10, Culture=neutral, PublicKeyToken=cc4967777c49a3ff" >
        <Settings>
          <Property Name="OpenXmlStandard" Value="Transitional" Type="GrapeCity.ActiveReports.Export.Excel.Page.OpenXmlStandard, GrapeCity.ActiveReports.Export.Excel.v10, Culture=neutral, PublicKeyToken=cc4967777c49a3ff"/>
        </Settings>
      </Extension>
    </Render>
  </Extensions>
</ReportingConfiguration>

V

View Pane

View Pane display the view center keys and zoom level slider for the map viewport. Use the arrow keys to adjust the view center and the slider to adjust the zoom level.

Viewer
A stand-alone application where you can preview your report.

累

累積ページ数
Refers to number of pages in a report that contains custom themes. Setting an additional theme in a report doubles the total number of pages. Cumulative page numbering is applied on each set of themes separately, where one set of report pages show the result on applying the default theme and while the other set of report pages show the result of applying the custom theme. In effect, the number of Cumulative Total Pages are half of Total Page number in a report with two themes.


GrapeCity.ActiveReports.Chart.v10 Assembly

GrapeCity.ActiveReports.Chart.v10 Assembly
Namespaces
Namespace | Description
GrapeCity.ActiveReports.Chart | The GrapeCity.ActiveReports.Chart namespace contains the chart classes.
GrapeCity.ActiveReports.Chart.Annotations | The GrapeCity.ActiveReports.Chart.Annotations namespace contains the chart annotations classes.
GrapeCity.ActiveReports.Chart.Graphics | The GrapeCity.ActiveReports.Chart.Graphics namespace contains the chart graphics components and settings.


GrapeCity.ActiveReports.Chart.Annotations Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Chart.Annotations Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Chart.v10 Assembly : GrapeCity.ActiveReports.Chart.Annotations Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Chart.Item
GrapeCity.ActiveReports.Chart.DrawCustomizableItem
GrapeCity.ActiveReports.Chart.MouseEnabledItem
GrapeCity.ActiveReports.Chart.MouseEnabledComponent
GrapeCity.ActiveReports.Chart.Annotations.Annotation
GrapeCity.ActiveReports.Chart.Annotations.AnnotationLine
GrapeCity.ActiveReports.Chart.Annotations.AnnotationTextBar
System.Collections.CollectionBase
GrapeCity.ActiveReports.Chart.Annotations.AnnotationsCollection
See Also

Reference

GrapeCity.ActiveReports.Chart.v10 Assembly


Clear Method (AxesCollection)

Clear Method (AxesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class : Clear Method
Clears all axes from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

AxesCollection Class
AxesCollection Members


RemoveAt Method (AxesCollection)

RemoveAt Method (AxesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > AxesCollection Class : RemoveAt Method

The index of the axis to remove.

Removes the specified axis from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index

The index of the axis to remove.

See Also

Reference

AxesCollection Class
AxesCollection Members


Capacity Property (ChartAreasCollection)

Capacity Property (ChartAreasCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : Capacity Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


Count Property (ChartAreasCollection)

Count Property (ChartAreasCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : Count Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


RemoveAt Method (ChartAreasCollection)

RemoveAt Method (ChartAreasCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > ChartAreasCollection Class : RemoveAt Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
See Also

Reference

ChartAreasCollection Class
ChartAreasCollection Members


Clear Method (DataPointsCollection)

Clear Method (DataPointsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : Clear Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


RemoveAt Method (DataPointsCollection)

RemoveAt Method (DataPointsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > DataPointsCollection Class : RemoveAt Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
See Also

Reference

DataPointsCollection Class
DataPointsCollection Members


GrapeCity.ActiveReports.Chart.Graphics Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Chart.Graphics Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Chart.v10 Assembly : GrapeCity.ActiveReports.Chart.Graphics Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Chart.Item
GrapeCity.ActiveReports.Chart.DrawCustomizableItem
GrapeCity.ActiveReports.Chart.Graphics.Backdrop
GrapeCity.ActiveReports.Chart.BackdropItem
GrapeCity.ActiveReports.Chart.Graphics.Line
GrapeCity.ActiveReports.Chart.Graphics.Point2d
GrapeCity.ActiveReports.Chart.Graphics.Point3d
System.ValueType
GrapeCity.ActiveReports.Chart.Graphics.Bar
See Also

Reference

GrapeCity.ActiveReports.Chart.v10 Assembly


Button Property (GraphMouseEventArgs)

Button Property (GraphMouseEventArgs)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphMouseEventArgs Class : Button Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Button As System.Windows.Forms.MouseButtons
public System.Windows.Forms.MouseButtons Button {get;}
See Also

Reference

GraphMouseEventArgs Class
GraphMouseEventArgs Members


Clicks Property (GraphMouseEventArgs)

Clicks Property (GraphMouseEventArgs)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphMouseEventArgs Class : Clicks Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Clicks As System.Integer
public System.int Clicks {get;}
See Also

Reference

GraphMouseEventArgs Class
GraphMouseEventArgs Members


Delta Property

Delta Property

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphMouseEventArgs Class : Delta Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Delta As System.Integer
public System.int Delta {get;}
See Also

Reference

GraphMouseEventArgs Class
GraphMouseEventArgs Members


Location Property (GraphMouseEventArgs)

Location Property (GraphMouseEventArgs)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphMouseEventArgs Class : Location Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Location As Point
public Point Location {get;}
See Also

Reference

GraphMouseEventArgs Class
GraphMouseEventArgs Members


X Property (GraphMouseEventArgs)

X Property (GraphMouseEventArgs)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphMouseEventArgs Class : X Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property X As System.Integer
public System.int X {get;}
See Also

Reference

GraphMouseEventArgs Class
GraphMouseEventArgs Members


Y Property (GraphMouseEventArgs)

Y Property (GraphMouseEventArgs)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > GraphMouseEventArgs Class : Y Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Y As System.Integer
public System.int Y {get;}
See Also

Reference

GraphMouseEventArgs Class
GraphMouseEventArgs Members


LegendItemsCollection Constructor

LegendItemsCollection Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : LegendItemsCollection Constructor
Initializes a new instance of the LegendItemsCollection class.
Overload List
Overload | Description
LegendItemsCollection Constructor | Initializes new instance of the LegendItemsCollection class
See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


Clear Method (LegendItemsCollection)

Clear Method (LegendItemsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : Clear Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


RemoveAt Method (LegendItemsCollection)

RemoveAt Method (LegendItemsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendItemsCollection Class : RemoveAt Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
See Also

Reference

LegendItemsCollection Class
LegendItemsCollection Members


Capacity Property (LegendsCollection)

Capacity Property (LegendsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : Capacity Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

LegendsCollection Class
LegendsCollection Members


Count Property (LegendsCollection)

Count Property (LegendsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : Count Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

LegendsCollection Class
LegendsCollection Members


RemoveAt Method (LegendsCollection)

RemoveAt Method (LegendsCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > LegendsCollection Class : RemoveAt Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
See Also

Reference

LegendsCollection Class
LegendsCollection Members


Capacity Property (SeriesCollection)

Capacity Property (SeriesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : Capacity Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

SeriesCollection Class
SeriesCollection Members


Clear Method (SeriesCollection)

Clear Method (SeriesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : Clear Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

SeriesCollection Class
SeriesCollection Members


Count Property (SeriesCollection)

Count Property (SeriesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : Count Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

SeriesCollection Class
SeriesCollection Members


RemoveAt Method (SeriesCollection)

RemoveAt Method (SeriesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SeriesCollection Class : RemoveAt Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
See Also

Reference

SeriesCollection Class
SeriesCollection Members


SharpGraph Class Events

SharpGraph Class Events

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace : SharpGraph Class

For a list of all members of this type, see SharpGraph members.

Public Events
 | Name | Description
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

SharpGraph Class
GrapeCity.ActiveReports.Chart Namespace


AccessibilityObject Property (SharpGraph)

AccessibilityObject Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : AccessibilityObject Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property AccessibilityObject As System.Windows.Forms.AccessibleObject
public System.Windows.Forms.AccessibleObject AccessibilityObject {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


AccessibleDefaultActionDescription Property (SharpGraph)

AccessibleDefaultActionDescription Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : AccessibleDefaultActionDescription Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AccessibleDefaultActionDescription As System.String
public System.string AccessibleDefaultActionDescription {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


AllowDrop Property (SharpGraph)

AllowDrop Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : AllowDrop Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AllowDrop As System.Boolean
public System.bool AllowDrop {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


Anchor Property (SharpGraph)

Anchor Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Anchor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Anchor As System.Windows.Forms.AnchorStyles
public System.Windows.Forms.AnchorStyles Anchor {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


AutoScrollOffset Property (SharpGraph)

AutoScrollOffset Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : AutoScrollOffset Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScrollOffset As Point
public Point AutoScrollOffset {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


BackColorChanged Event (SharpGraph)

BackColorChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : BackColorChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BackColorChanged As System.EventHandler
public event System.EventHandler BackColorChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


BackgroundImageChanged Event (SharpGraph)

BackgroundImageChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : BackgroundImageChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BackgroundImageChanged As System.EventHandler
public event System.EventHandler BackgroundImageChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


BackgroundImageLayout Property (SharpGraph)

BackgroundImageLayout Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : BackgroundImageLayout Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackgroundImageLayout As System.Windows.Forms.ImageLayout
public System.Windows.Forms.ImageLayout BackgroundImageLayout {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


BackgroundImageLayoutChanged Event (SharpGraph)

BackgroundImageLayoutChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : BackgroundImageLayoutChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BackgroundImageLayoutChanged As System.EventHandler
public event System.EventHandler BackgroundImageLayoutChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


BeginInvoke Method (SharpGraph)

BeginInvoke Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : BeginInvoke Method
Overload List
Overload | Description
BeginInvoke(Delegate) | (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

SharpGraph Class
SharpGraph Members


BeginInvoke(Delegate) Method

BeginInvoke(Delegate) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class > BeginInvoke Method : BeginInvoke(Delegate) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function BeginInvoke( _
   ByVal method As System.Delegate _
) As System.IAsyncResult
public System.IAsyncResult BeginInvoke(
   System.Delegate method
)

Parameters

method
See Also

Reference

SharpGraph Class
SharpGraph Members
Overload List


BeginInvoke(Delegate,Object[]) Method

BeginInvoke(Delegate,Object[]) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function BeginInvoke( _
   ByVal method As System.Delegate, _
   ByVal ParamArray args() As System.Object _
) As System.IAsyncResult
public System.IAsyncResult BeginInvoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
args
See Also

Reference

SharpGraph Class
SharpGraph Members
Overload List


BindingContext Property (SharpGraph)

BindingContext Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : BindingContext Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BindingContext As System.Windows.Forms.BindingContext
public System.Windows.Forms.BindingContext BindingContext {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


BindingContextChanged Event (SharpGraph)

BindingContextChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : BindingContextChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BindingContextChanged As System.EventHandler
public event System.EventHandler BindingContextChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


Bottom Property (SharpGraph)

Bottom Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Bottom Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Bottom As System.Integer
public System.int Bottom {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


Bounds Property (SharpGraph)

Bounds Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Bounds Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Bounds As Rectangle
public Rectangle Bounds {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


BringToFront Method (SharpGraph)

BringToFront Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : BringToFront Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub BringToFront()
public void BringToFront()
See Also

Reference

SharpGraph Class
SharpGraph Members


CanFocus Property (SharpGraph)

CanFocus Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : CanFocus Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CanFocus As System.Boolean
public System.bool CanFocus {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


CanSelect Property (SharpGraph)

CanSelect Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : CanSelect Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CanSelect As System.Boolean
public System.bool CanSelect {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


Capture Property (SharpGraph)

Capture Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Capture Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capture As System.Boolean
public System.bool Capture {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


CausesValidationChanged Event (SharpGraph)

CausesValidationChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : CausesValidationChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event CausesValidationChanged As System.EventHandler
public event System.EventHandler CausesValidationChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


ChangeUICues Event (SharpGraph)

ChangeUICues Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : ChangeUICues Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ChangeUICues As System.Windows.Forms.UICuesEventHandler
public event System.Windows.Forms.UICuesEventHandler ChangeUICues
Event Data

The event handler receives an argument of type System.Windows.Forms.UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.
See Also

Reference

SharpGraph Class
SharpGraph Members


Click Event (SharpGraph)

Click Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Click Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Click As System.EventHandler
public event System.EventHandler Click
See Also

Reference

SharpGraph Class
SharpGraph Members


ClientRectangle Property (SharpGraph)

ClientRectangle Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : ClientRectangle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ClientRectangle As Rectangle
public Rectangle ClientRectangle {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


ClientSize Property (SharpGraph)

ClientSize Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : ClientSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ClientSize As Size
public Size ClientSize {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


ClientSizeChanged Event (SharpGraph)

ClientSizeChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : ClientSizeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ClientSizeChanged As System.EventHandler
public event System.EventHandler ClientSizeChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


CompanyName Property (SharpGraph)

CompanyName Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : CompanyName Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CompanyName As System.String
public System.string CompanyName {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


Container Property (SharpGraph)

Container Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


Contains Method (SharpGraph)

Contains Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Contains Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal ctl As System.Windows.Forms.Control _
) As System.Boolean
public System.bool Contains(
   System.Windows.Forms.Control ctl
)

Parameters

ctl
See Also

Reference

SharpGraph Class
SharpGraph Members


ContainsFocus Property (SharpGraph)

ContainsFocus Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : ContainsFocus Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ContainsFocus As System.Boolean
public System.bool ContainsFocus {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


ContextMenu Property (SharpGraph)

ContextMenu Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : ContextMenu Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ContextMenu As System.Windows.Forms.ContextMenu
public System.Windows.Forms.ContextMenu ContextMenu {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


ContextMenuChanged Event (SharpGraph)

ContextMenuChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : ContextMenuChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ContextMenuChanged As System.EventHandler
public event System.EventHandler ContextMenuChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


ContextMenuStrip Property (SharpGraph)

ContextMenuStrip Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : ContextMenuStrip Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ContextMenuStrip As System.Windows.Forms.ContextMenuStrip
public System.Windows.Forms.ContextMenuStrip ContextMenuStrip {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


ContextMenuStripChanged Event (SharpGraph)

ContextMenuStripChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : ContextMenuStripChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ContextMenuStripChanged As System.EventHandler
public event System.EventHandler ContextMenuStripChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


ControlAdded Event (SharpGraph)

ControlAdded Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : ControlAdded Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ControlAdded As System.Windows.Forms.ControlEventHandler
public event System.Windows.Forms.ControlEventHandler ControlAdded
Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.
See Also

Reference

SharpGraph Class
SharpGraph Members


ControlRemoved Event (SharpGraph)

ControlRemoved Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : ControlRemoved Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ControlRemoved As System.Windows.Forms.ControlEventHandler
public event System.Windows.Forms.ControlEventHandler ControlRemoved
Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.
See Also

Reference

SharpGraph Class
SharpGraph Members


Controls Property (SharpGraph)

Controls Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Controls Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Controls As System.Windows.Forms.Control.ControlCollection
public System.Windows.Forms.Control.ControlCollection Controls {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


CreateControl Method (SharpGraph)

CreateControl Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : CreateControl Method
Overload List
Overload | Description
CreateControl | (Inherited from System.Windows.Forms.Control)
See Also

Reference

SharpGraph Class
SharpGraph Members


CreateControl() Method

CreateControl() Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : CreateControl() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CreateControl()
public void CreateControl()
See Also

Reference

SharpGraph Class
SharpGraph Members


Created Property (SharpGraph)

Created Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Created Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Created As System.Boolean
public System.bool Created {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


CreateGraphics Method (SharpGraph)

CreateGraphics Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : CreateGraphics Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateGraphics() As Graphics
public Graphics CreateGraphics()
See Also

Reference

SharpGraph Class
SharpGraph Members


CreateObjRef Method (SharpGraph)

CreateObjRef Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

SharpGraph Class
SharpGraph Members


CursorChanged Event (SharpGraph)

CursorChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : CursorChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event CursorChanged As System.EventHandler
public event System.EventHandler CursorChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


DataBindings Property (SharpGraph)

DataBindings Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : DataBindings Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DataBindings As System.Windows.Forms.ControlBindingsCollection
public System.Windows.Forms.ControlBindingsCollection DataBindings {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


DisplayRectangle Property (SharpGraph)

DisplayRectangle Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : DisplayRectangle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DisplayRectangle As Rectangle
public Rectangle DisplayRectangle {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


Dispose Method (SharpGraph)

Dispose Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Dispose Method
Releases the SharpGraph object from memory.
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

SharpGraph Class
SharpGraph Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

SharpGraph Class
SharpGraph Members


Disposed Event (SharpGraph)

Disposed Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

SharpGraph Class
SharpGraph Members


Disposing Property (SharpGraph)

Disposing Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Disposing Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Disposing As System.Boolean
public System.bool Disposing {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


Dock Property (SharpGraph)

Dock Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Dock Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Dock As System.Windows.Forms.DockStyle
public System.Windows.Forms.DockStyle Dock {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


DockChanged Event (SharpGraph)

DockChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : DockChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DockChanged As System.EventHandler
public event System.EventHandler DockChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


DoDragDrop Method (SharpGraph)

DoDragDrop Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : DoDragDrop Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function DoDragDrop( _
   ByVal data As System.Object, _
   ByVal allowedEffects As System.Windows.Forms.DragDropEffects _
) As System.Windows.Forms.DragDropEffects
public System.Windows.Forms.DragDropEffects DoDragDrop(
   System.object data,
   System.Windows.Forms.DragDropEffects allowedEffects
)

Parameters

data
allowedEffects
See Also

Reference

SharpGraph Class
SharpGraph Members


DoubleClick Event (SharpGraph)

DoubleClick Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : DoubleClick Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DoubleClick As System.EventHandler
public event System.EventHandler DoubleClick
See Also

Reference

SharpGraph Class
SharpGraph Members


DragDrop Event (SharpGraph)

DragDrop Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : DragDrop Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragDrop As System.Windows.Forms.DragEventHandler
public event System.Windows.Forms.DragEventHandler DragDrop
Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.
See Also

Reference

SharpGraph Class
SharpGraph Members


DragEnter Event (SharpGraph)

DragEnter Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : DragEnter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragEnter As System.Windows.Forms.DragEventHandler
public event System.Windows.Forms.DragEventHandler DragEnter
Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.
See Also

Reference

SharpGraph Class
SharpGraph Members


DragLeave Event (SharpGraph)

DragLeave Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : DragLeave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragLeave As System.EventHandler
public event System.EventHandler DragLeave
See Also

Reference

SharpGraph Class
SharpGraph Members


DragOver Event (SharpGraph)

DragOver Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : DragOver Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragOver As System.Windows.Forms.DragEventHandler
public event System.Windows.Forms.DragEventHandler DragOver
Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.
See Also

Reference

SharpGraph Class
SharpGraph Members


DrawToBitmap Method (SharpGraph)

DrawToBitmap Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : DrawToBitmap Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub DrawToBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal targetBounds As Rectangle _
)
public void DrawToBitmap(
   Bitmap bitmap,
   Rectangle targetBounds
)

Parameters

bitmap
targetBounds
See Also

Reference

SharpGraph Class
SharpGraph Members


Enabled Property (SharpGraph)

Enabled Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Enabled Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Enabled As System.Boolean
public System.bool Enabled {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


EnabledChanged Event (SharpGraph)

EnabledChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : EnabledChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event EnabledChanged As System.EventHandler
public event System.EventHandler EnabledChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


EndInvoke Method (SharpGraph)

EndInvoke Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : EndInvoke Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function EndInvoke( _
   ByVal asyncResult As System.IAsyncResult _
) As System.Object
public System.object EndInvoke(
   System.IAsyncResult asyncResult
)

Parameters

asyncResult
See Also

Reference

SharpGraph Class
SharpGraph Members


Enter Event (SharpGraph)

Enter Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Enter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Enter As System.EventHandler
public event System.EventHandler Enter
See Also

Reference

SharpGraph Class
SharpGraph Members


FindForm Method (SharpGraph)

FindForm Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : FindForm Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function FindForm() As System.Windows.Forms.Form
public System.Windows.Forms.Form FindForm()
See Also

Reference

SharpGraph Class
SharpGraph Members


Focus Method (SharpGraph)

Focus Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Focus Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Focus() As System.Boolean
public System.bool Focus()
See Also

Reference

SharpGraph Class
SharpGraph Members


Focused Property (SharpGraph)

Focused Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Focused Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Focused As System.Boolean
public System.bool Focused {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


FontChanged Event (SharpGraph)

FontChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : FontChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event FontChanged As System.EventHandler
public event System.EventHandler FontChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


ForeColorChanged Event (SharpGraph)

ForeColorChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : ForeColorChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ForeColorChanged As System.EventHandler
public event System.EventHandler ForeColorChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


GetChildAtPoint Method (SharpGraph)

GetChildAtPoint Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : GetChildAtPoint Method
Overload List
Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

SharpGraph Class
SharpGraph Members


GetChildAtPoint(Point) Method

GetChildAtPoint(Point) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point _
) As System.Windows.Forms.Control
public System.Windows.Forms.Control GetChildAtPoint(
   Point pt
)

Parameters

pt
See Also

Reference

SharpGraph Class
SharpGraph Members
Overload List


GetChildAtPoint(Point,GetChildAtPointSkip) Method

GetChildAtPoint(Point,GetChildAtPointSkip) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point, _
   ByVal skipValue As System.Windows.Forms.GetChildAtPointSkip _
) As System.Windows.Forms.Control
public System.Windows.Forms.Control GetChildAtPoint(
   Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)

Parameters

pt
skipValue
See Also

Reference

SharpGraph Class
SharpGraph Members
Overload List


GetContainerControl Method (SharpGraph)

GetContainerControl Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : GetContainerControl Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetContainerControl() As System.Windows.Forms.IContainerControl
public System.Windows.Forms.IContainerControl GetContainerControl()
See Also

Reference

SharpGraph Class
SharpGraph Members


GetLifetimeService Method (SharpGraph)

GetLifetimeService Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

SharpGraph Class
SharpGraph Members


GetNextControl Method (SharpGraph)

GetNextControl Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : GetNextControl Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetNextControl( _
   ByVal ctl As System.Windows.Forms.Control, _
   ByVal forward As System.Boolean _
) As System.Windows.Forms.Control
public System.Windows.Forms.Control GetNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward
)

Parameters

ctl
forward
See Also

Reference

SharpGraph Class
SharpGraph Members


GetPreferredSize Method (SharpGraph)

GetPreferredSize Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : GetPreferredSize Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetPreferredSize( _
   ByVal proposedSize As Size _
) As Size
public Size GetPreferredSize(
   Size proposedSize
)

Parameters

proposedSize
See Also

Reference

SharpGraph Class
SharpGraph Members


GiveFeedback Event (SharpGraph)

GiveFeedback Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : GiveFeedback Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event GiveFeedback As System.Windows.Forms.GiveFeedbackEventHandler
public event System.Windows.Forms.GiveFeedbackEventHandler GiveFeedback
Event Data

The event handler receives an argument of type System.Windows.Forms.GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.
See Also

Reference

SharpGraph Class
SharpGraph Members


GotFocus Event (SharpGraph)

GotFocus Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : GotFocus Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event GotFocus As System.EventHandler
public event System.EventHandler GotFocus
See Also

Reference

SharpGraph Class
SharpGraph Members


Handle Property (SharpGraph)

Handle Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Handle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Handle As System.IntPtr
public System.IntPtr Handle {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


HandleCreated Event (SharpGraph)

HandleCreated Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : HandleCreated Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event HandleCreated As System.EventHandler
public event System.EventHandler HandleCreated
See Also

Reference

SharpGraph Class
SharpGraph Members


HandleDestroyed Event (SharpGraph)

HandleDestroyed Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : HandleDestroyed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event HandleDestroyed As System.EventHandler
public event System.EventHandler HandleDestroyed
See Also

Reference

SharpGraph Class
SharpGraph Members


HasChildren Property (SharpGraph)

HasChildren Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : HasChildren Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HasChildren As System.Boolean
public System.bool HasChildren {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


Height Property (SharpGraph)

Height Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Height Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As System.Integer
public System.int Height {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


HelpRequested Event (SharpGraph)

HelpRequested Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : HelpRequested Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event HelpRequested As System.Windows.Forms.HelpEventHandler
public event System.Windows.Forms.HelpEventHandler HelpRequested
Event Data

The event handler receives an argument of type System.Windows.Forms.HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.
See Also

Reference

SharpGraph Class
SharpGraph Members


Hide Method (SharpGraph)

Hide Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Hide Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Hide()
public void Hide()
See Also

Reference

SharpGraph Class
SharpGraph Members


ImeModeChanged Event (SharpGraph)

ImeModeChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : ImeModeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ImeModeChanged As System.EventHandler
public event System.EventHandler ImeModeChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


InitializeLifetimeService Method (SharpGraph)

InitializeLifetimeService Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

SharpGraph Class
SharpGraph Members


Invalidate Method (SharpGraph)

Invalidate Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Invalidate Method
Overload List
Overload | Description
Invalidate(Region) | (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | (Inherited from System.Windows.Forms.Control)
Invalidate() | (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

SharpGraph Class
SharpGraph Members


Invalidate() Method

Invalidate() Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class > Invalidate Method : Invalidate() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate()
public void Invalidate()
See Also

Reference

SharpGraph Class
SharpGraph Members
Overload List


Invalidate(Boolean) Method

Invalidate(Boolean) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class > Invalidate Method : Invalidate(Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal invalidateChildren As System.Boolean _
)
public void Invalidate(
   System.bool invalidateChildren
)

Parameters

invalidateChildren
See Also

Reference

SharpGraph Class
SharpGraph Members
Overload List


Invalidate(Rectangle) Method

Invalidate(Rectangle) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class > Invalidate Method : Invalidate(Rectangle) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle _
)
public void Invalidate(
   Rectangle rc
)

Parameters

rc
See Also

Reference

SharpGraph Class
SharpGraph Members
Overload List


Invalidate(Rectangle,Boolean) Method

Invalidate(Rectangle,Boolean) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle, _
   ByVal invalidateChildren As System.Boolean _
)
public void Invalidate(
   Rectangle rc,
   System.bool invalidateChildren
)

Parameters

rc
invalidateChildren
See Also

Reference

SharpGraph Class
SharpGraph Members
Overload List


Invalidate(Region) Method

Invalidate(Region) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class > Invalidate Method : Invalidate(Region) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal region As Region _
)
public void Invalidate(
   Region region
)

Parameters

region
See Also

Reference

SharpGraph Class
SharpGraph Members
Overload List


Invalidate(Region,Boolean) Method

Invalidate(Region,Boolean) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class > Invalidate Method : Invalidate(Region,Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal region As Region, _
   ByVal invalidateChildren As System.Boolean _
)
public void Invalidate(
   Region region,
   System.bool invalidateChildren
)

Parameters

region
invalidateChildren
See Also

Reference

SharpGraph Class
SharpGraph Members
Overload List


Invalidated Event (SharpGraph)

Invalidated Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Invalidated Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Invalidated As System.Windows.Forms.InvalidateEventHandler
public event System.Windows.Forms.InvalidateEventHandler Invalidated
Event Data

The event handler receives an argument of type System.Windows.Forms.InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.
See Also

Reference

SharpGraph Class
SharpGraph Members


Invoke Method (SharpGraph)

Invoke Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Invoke Method
Overload List
Overload | Description
Invoke(Delegate) | (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

SharpGraph Class
SharpGraph Members


Invoke(Delegate) Method

Invoke(Delegate) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class > Invoke Method : Invoke(Delegate) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Invoke( _
   ByVal method As System.Delegate _
) As System.Object
public System.object Invoke(
   System.Delegate method
)

Parameters

method
See Also

Reference

SharpGraph Class
SharpGraph Members
Overload List


Invoke(Delegate,Object[]) Method

Invoke(Delegate,Object[]) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class > Invoke Method : Invoke(Delegate,Object[]) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Invoke( _
   ByVal method As System.Delegate, _
   ByVal ParamArray args() As System.Object _
) As System.Object
public System.object Invoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
args
See Also

Reference

SharpGraph Class
SharpGraph Members
Overload List


InvokeRequired Property (SharpGraph)

InvokeRequired Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : InvokeRequired Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InvokeRequired As System.Boolean
public System.bool InvokeRequired {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


IsAccessible Property (SharpGraph)

IsAccessible Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : IsAccessible Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsAccessible As System.Boolean
public System.bool IsAccessible {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


IsDisposed Property (SharpGraph)

IsDisposed Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : IsDisposed Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsDisposed As System.Boolean
public System.bool IsDisposed {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


IsHandleCreated Property (SharpGraph)

IsHandleCreated Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : IsHandleCreated Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsHandleCreated As System.Boolean
public System.bool IsHandleCreated {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


IsMirrored Property (SharpGraph)

IsMirrored Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : IsMirrored Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsMirrored As System.Boolean
public System.bool IsMirrored {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


KeyDown Event (SharpGraph)

KeyDown Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : KeyDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event KeyDown As System.Windows.Forms.KeyEventHandler
public event System.Windows.Forms.KeyEventHandler KeyDown
Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.
See Also

Reference

SharpGraph Class
SharpGraph Members


KeyPress Event (SharpGraph)

KeyPress Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : KeyPress Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event KeyPress As System.Windows.Forms.KeyPressEventHandler
public event System.Windows.Forms.KeyPressEventHandler KeyPress
Event Data

The event handler receives an argument of type System.Windows.Forms.KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.
See Also

Reference

SharpGraph Class
SharpGraph Members


KeyUp Event (SharpGraph)

KeyUp Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : KeyUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event KeyUp As System.Windows.Forms.KeyEventHandler
public event System.Windows.Forms.KeyEventHandler KeyUp
Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.
See Also

Reference

SharpGraph Class
SharpGraph Members


Layout Event (SharpGraph)

Layout Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Layout Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Layout As System.Windows.Forms.LayoutEventHandler
public event System.Windows.Forms.LayoutEventHandler Layout
Event Data

The event handler receives an argument of type System.Windows.Forms.LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.
See Also

Reference

SharpGraph Class
SharpGraph Members


LayoutEngine Property (SharpGraph)

LayoutEngine Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : LayoutEngine Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property LayoutEngine As System.Windows.Forms.Layout.LayoutEngine
public System.Windows.Forms.Layout.LayoutEngine LayoutEngine {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


Leave Event (SharpGraph)

Leave Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Leave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Leave As System.EventHandler
public event System.EventHandler Leave
See Also

Reference

SharpGraph Class
SharpGraph Members


Left Property (SharpGraph)

Left Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Left Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Left As System.Integer
public System.int Left {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


Location Property (SharpGraph)

Location Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Location Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Location As Point
public Point Location {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


LocationChanged Event (SharpGraph)

LocationChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : LocationChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LocationChanged As System.EventHandler
public event System.EventHandler LocationChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


LostFocus Event (SharpGraph)

LostFocus Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : LostFocus Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LostFocus As System.EventHandler
public event System.EventHandler LostFocus
See Also

Reference

SharpGraph Class
SharpGraph Members


Margin Property (SharpGraph)

Margin Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Margin Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Margin As System.Windows.Forms.Padding
public System.Windows.Forms.Padding Margin {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


MarginChanged Event (SharpGraph)

MarginChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : MarginChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MarginChanged As System.EventHandler
public event System.EventHandler MarginChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


MaximumSize Property (SharpGraph)

MaximumSize Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : MaximumSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaximumSize As Size
public Size MaximumSize {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


MinimumSize Property (SharpGraph)

MinimumSize Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : MinimumSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinimumSize As Size
public Size MinimumSize {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


MouseCaptureChanged Event (SharpGraph)

MouseCaptureChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : MouseCaptureChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseCaptureChanged As System.EventHandler
public event System.EventHandler MouseCaptureChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


MouseClick Event (SharpGraph)

MouseClick Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : MouseClick Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseClick As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseClick
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

SharpGraph Class
SharpGraph Members


MouseDoubleClick Event (SharpGraph)

MouseDoubleClick Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : MouseDoubleClick Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseDoubleClick As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseDoubleClick
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

SharpGraph Class
SharpGraph Members


MouseDown Event (SharpGraph)

MouseDown Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : MouseDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseDown As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseDown
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

SharpGraph Class
SharpGraph Members


MouseEnter Event (SharpGraph)

MouseEnter Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : MouseEnter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseEnter As System.EventHandler
public event System.EventHandler MouseEnter
See Also

Reference

SharpGraph Class
SharpGraph Members


MouseHover Event (SharpGraph)

MouseHover Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : MouseHover Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseHover As System.EventHandler
public event System.EventHandler MouseHover
See Also

Reference

SharpGraph Class
SharpGraph Members


MouseLeave Event (SharpGraph)

MouseLeave Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : MouseLeave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseLeave As System.EventHandler
public event System.EventHandler MouseLeave
See Also

Reference

SharpGraph Class
SharpGraph Members


MouseMove Event (SharpGraph)

MouseMove Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : MouseMove Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseMove As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseMove
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

SharpGraph Class
SharpGraph Members


MouseUp Event (SharpGraph)

MouseUp Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : MouseUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseUp As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseUp
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

SharpGraph Class
SharpGraph Members


MouseWheel Event (SharpGraph)

MouseWheel Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : MouseWheel Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseWheel As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseWheel
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

SharpGraph Class
SharpGraph Members


Move Event (SharpGraph)

Move Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Move Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Move As System.EventHandler
public event System.EventHandler Move
See Also

Reference

SharpGraph Class
SharpGraph Members


Name Property (SharpGraph)

Name Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Name Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


Padding Property (SharpGraph)

Padding Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Padding Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Padding As System.Windows.Forms.Padding
public System.Windows.Forms.Padding Padding {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


PaddingChanged Event (SharpGraph)

PaddingChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : PaddingChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PaddingChanged As System.EventHandler
public event System.EventHandler PaddingChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


Paint Event (SharpGraph)

Paint Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Paint Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Paint As System.Windows.Forms.PaintEventHandler
public event System.Windows.Forms.PaintEventHandler Paint
Event Data

The event handler receives an argument of type System.Windows.Forms.PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.
See Also

Reference

SharpGraph Class
SharpGraph Members


Parent Property (SharpGraph)

Parent Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Parent Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Parent As System.Windows.Forms.Control
public System.Windows.Forms.Control Parent {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


ParentChanged Event (SharpGraph)

ParentChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : ParentChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ParentChanged As System.EventHandler
public event System.EventHandler ParentChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


PerformLayout Method (SharpGraph)

PerformLayout Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : PerformLayout Method
Overload List
Overload | Description
PerformLayout() | (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

SharpGraph Class
SharpGraph Members


PerformLayout() Method

PerformLayout() Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class > PerformLayout Method : PerformLayout() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub PerformLayout()
public void PerformLayout()
See Also

Reference

SharpGraph Class
SharpGraph Members
Overload List


PerformLayout(Control,String) Method

PerformLayout(Control,String) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class > PerformLayout Method : PerformLayout(Control,String) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub PerformLayout( _
   ByVal affectedControl As System.Windows.Forms.Control, _
   ByVal affectedProperty As System.String _
)
public void PerformLayout(
   System.Windows.Forms.Control affectedControl,
   System.string affectedProperty
)

Parameters

affectedControl
affectedProperty
See Also

Reference

SharpGraph Class
SharpGraph Members
Overload List


PointToClient Method (SharpGraph)

PointToClient Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : PointToClient Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PointToClient( _
   ByVal p As Point _
) As Point
public Point PointToClient(
   Point p
)

Parameters

p
See Also

Reference

SharpGraph Class
SharpGraph Members


PointToScreen Method (SharpGraph)

PointToScreen Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : PointToScreen Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PointToScreen( _
   ByVal p As Point _
) As Point
public Point PointToScreen(
   Point p
)

Parameters

p
See Also

Reference

SharpGraph Class
SharpGraph Members


PreferredSize Property (SharpGraph)

PreferredSize Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : PreferredSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PreferredSize As Size
public Size PreferredSize {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


PreProcessControlMessage Method (SharpGraph)

PreProcessControlMessage Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : PreProcessControlMessage Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PreProcessControlMessage( _
   ByRef msg As System.Windows.Forms.Message _
) As System.Windows.Forms.PreProcessControlState
public System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
See Also

Reference

SharpGraph Class
SharpGraph Members


PreProcessMessage Method (SharpGraph)

PreProcessMessage Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : PreProcessMessage Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PreProcessMessage( _
   ByRef msg As System.Windows.Forms.Message _
) As System.Boolean
public System.bool PreProcessMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
See Also

Reference

SharpGraph Class
SharpGraph Members


PreviewKeyDown Event (SharpGraph)

PreviewKeyDown Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : PreviewKeyDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewKeyDown As System.Windows.Forms.PreviewKeyDownEventHandler
public event System.Windows.Forms.PreviewKeyDownEventHandler PreviewKeyDown
Event Data

The event handler receives an argument of type System.Windows.Forms.PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.
See Also

Reference

SharpGraph Class
SharpGraph Members


ProductName Property (SharpGraph)

ProductName Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : ProductName Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ProductName As System.String
public System.string ProductName {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


ProductVersion Property (SharpGraph)

ProductVersion Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : ProductVersion Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ProductVersion As System.String
public System.string ProductVersion {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


QueryAccessibilityHelp Event (SharpGraph)

QueryAccessibilityHelp Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : QueryAccessibilityHelp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event QueryAccessibilityHelp As System.Windows.Forms.QueryAccessibilityHelpEventHandler
public event System.Windows.Forms.QueryAccessibilityHelpEventHandler QueryAccessibilityHelp
Event Data

The event handler receives an argument of type System.Windows.Forms.QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.
See Also

Reference

SharpGraph Class
SharpGraph Members


QueryContinueDrag Event (SharpGraph)

QueryContinueDrag Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : QueryContinueDrag Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event QueryContinueDrag As System.Windows.Forms.QueryContinueDragEventHandler
public event System.Windows.Forms.QueryContinueDragEventHandler QueryContinueDrag
Event Data

The event handler receives an argument of type System.Windows.Forms.QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.
See Also

Reference

SharpGraph Class
SharpGraph Members


RecreatingHandle Property (SharpGraph)

RecreatingHandle Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : RecreatingHandle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property RecreatingHandle As System.Boolean
public System.bool RecreatingHandle {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


RectangleToClient Method (SharpGraph)

RectangleToClient Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : RectangleToClient Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function RectangleToClient( _
   ByVal r As Rectangle _
) As Rectangle
public Rectangle RectangleToClient(
   Rectangle r
)

Parameters

r
See Also

Reference

SharpGraph Class
SharpGraph Members


RectangleToScreen Method (SharpGraph)

RectangleToScreen Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : RectangleToScreen Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function RectangleToScreen( _
   ByVal r As Rectangle _
) As Rectangle
public Rectangle RectangleToScreen(
   Rectangle r
)

Parameters

r
See Also

Reference

SharpGraph Class
SharpGraph Members


Refresh Method (SharpGraph)

Refresh Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Refresh Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Refresh()
public void Refresh()
See Also

Reference

SharpGraph Class
SharpGraph Members


Region Property (SharpGraph)

Region Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Region Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Region As Region
public Region Region {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


RegionChanged Event (SharpGraph)

RegionChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : RegionChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event RegionChanged As System.EventHandler
public event System.EventHandler RegionChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


ResetText Method (SharpGraph)

ResetText Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : ResetText Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ResetText()
public void ResetText()
See Also

Reference

SharpGraph Class
SharpGraph Members


Resize Event (SharpGraph)

Resize Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Resize Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Resize As System.EventHandler
public event System.EventHandler Resize
See Also

Reference

SharpGraph Class
SharpGraph Members


ResumeLayout Method (SharpGraph)

ResumeLayout Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : ResumeLayout Method
Overload List
Overload | Description
ResumeLayout() | (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

SharpGraph Class
SharpGraph Members


ResumeLayout() Method

ResumeLayout() Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class > ResumeLayout Method : ResumeLayout() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ResumeLayout()
public void ResumeLayout()
See Also

Reference

SharpGraph Class
SharpGraph Members
Overload List


ResumeLayout(Boolean) Method

ResumeLayout(Boolean) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class > ResumeLayout Method : ResumeLayout(Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ResumeLayout( _
   ByVal performLayout As System.Boolean _
)
public void ResumeLayout(
   System.bool performLayout
)

Parameters

performLayout
See Also

Reference

SharpGraph Class
SharpGraph Members
Overload List


Right Property (SharpGraph)

Right Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Right Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Right As System.Integer
public System.int Right {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


RightToLeftChanged Event (SharpGraph)

RightToLeftChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : RightToLeftChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event RightToLeftChanged As System.EventHandler
public event System.EventHandler RightToLeftChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


Scale Method (SharpGraph)

Scale Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Scale Method
Overload List
Overload | Description
Scale | (Inherited from System.Windows.Forms.Control)
See Also

Reference

SharpGraph Class
SharpGraph Members


Scale(SizeF) Method

Scale(SizeF) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class > Scale Method : Scale(SizeF) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Scale( _
   ByVal factor As SizeF _
)
public void Scale(
   SizeF factor
)

Parameters

factor
See Also

Reference

SharpGraph Class
SharpGraph Members
Overload List


Select Method (SharpGraph)

Select Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Select Method
Overload List
Overload | Description
Select | (Inherited from System.Windows.Forms.Control)
See Also

Reference

SharpGraph Class
SharpGraph Members


Select() Method

Select() Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Select() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Select()
public void Select()
See Also

Reference

SharpGraph Class
SharpGraph Members


SelectNextControl Method (SharpGraph)

SelectNextControl Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : SelectNextControl Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function SelectNextControl( _
   ByVal ctl As System.Windows.Forms.Control, _
   ByVal forward As System.Boolean, _
   ByVal tabStopOnly As System.Boolean, _
   ByVal nested As System.Boolean, _
   ByVal wrap As System.Boolean _
) As System.Boolean
public System.bool SelectNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)

Parameters

ctl
forward
tabStopOnly
nested
wrap
See Also

Reference

SharpGraph Class
SharpGraph Members


SendToBack Method (SharpGraph)

SendToBack Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : SendToBack Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SendToBack()
public void SendToBack()
See Also

Reference

SharpGraph Class
SharpGraph Members


SetBounds Method (SharpGraph)

SetBounds Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : SetBounds Method
Overload List
Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

SharpGraph Class
SharpGraph Members


SetBounds(Int32,Int32,Int32,Int32) Method

SetBounds(Int32,Int32,Int32,Int32) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer _
)
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

x
y
width
height
See Also

Reference

SharpGraph Class
SharpGraph Members
Overload List


SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer, _
   ByVal specified As System.Windows.Forms.BoundsSpecified _
)
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)

Parameters

x
y
width
height
specified
See Also

Reference

SharpGraph Class
SharpGraph Members
Overload List


Show Method (SharpGraph)

Show Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Show Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Show()
public void Show()
See Also

Reference

SharpGraph Class
SharpGraph Members


Site Property (SharpGraph)

Site Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


Size Property (SharpGraph)

Size Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Size Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Size As Size
public Size Size {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


SizeChanged Event (SharpGraph)

SizeChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : SizeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event SizeChanged As System.EventHandler
public event System.EventHandler SizeChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


StyleChanged Event (SharpGraph)

StyleChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : StyleChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event StyleChanged As System.EventHandler
public event System.EventHandler StyleChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


SuspendLayout Method (SharpGraph)

SuspendLayout Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : SuspendLayout Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SuspendLayout()
public void SuspendLayout()
See Also

Reference

SharpGraph Class
SharpGraph Members


SystemColorsChanged Event (SharpGraph)

SystemColorsChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : SystemColorsChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event SystemColorsChanged As System.EventHandler
public event System.EventHandler SystemColorsChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


TabIndex Property (SharpGraph)

TabIndex Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : TabIndex Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TabIndex As System.Integer
public System.int TabIndex {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


TabIndexChanged Event (SharpGraph)

TabIndexChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : TabIndexChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TabIndexChanged As System.EventHandler
public event System.EventHandler TabIndexChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


TabStop Property (SharpGraph)

TabStop Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : TabStop Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TabStop As System.Boolean
public System.bool TabStop {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


TabStopChanged Event (SharpGraph)

TabStopChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : TabStopChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TabStopChanged As System.EventHandler
public event System.EventHandler TabStopChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


Tag Property (SharpGraph)

Tag Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Tag Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Tag As System.Object
public System.object Tag {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


TextChanged Event

TextChanged Event

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : TextChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TextChanged As System.EventHandler
public event System.EventHandler TextChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


Top Property (SharpGraph)

Top Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Top Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Top As System.Integer
public System.int Top {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


TopLevelControl Property (SharpGraph)

TopLevelControl Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : TopLevelControl Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TopLevelControl As System.Windows.Forms.Control
public System.Windows.Forms.Control TopLevelControl {get;}
See Also

Reference

SharpGraph Class
SharpGraph Members


ToString Method (SharpGraph)

ToString Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

SharpGraph Class
SharpGraph Members


Update Method (SharpGraph)

Update Method (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Update Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Update()
public void Update()
See Also

Reference

SharpGraph Class
SharpGraph Members


UseWaitCursor Property (SharpGraph)

UseWaitCursor Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : UseWaitCursor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseWaitCursor As System.Boolean
public System.bool UseWaitCursor {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


Validated Event (SharpGraph)

Validated Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Validated Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Validated As System.EventHandler
public event System.EventHandler Validated
See Also

Reference

SharpGraph Class
SharpGraph Members


Validating Event (SharpGraph)

Validating Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Validating Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Validating As System.ComponentModel.CancelEventHandler
public event System.ComponentModel.CancelEventHandler Validating
Event Data

The event handler receives an argument of type System.ComponentModel.CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |
See Also

Reference

SharpGraph Class
SharpGraph Members


Visible Property (SharpGraph)

Visible Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Visible Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


VisibleChanged Event (SharpGraph)

VisibleChanged Event (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : VisibleChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event VisibleChanged As System.EventHandler
public event System.EventHandler VisibleChanged
See Also

Reference

SharpGraph Class
SharpGraph Members


Width Property (SharpGraph)

Width Property (SharpGraph)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > SharpGraph Class : Width Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As System.Integer
public System.int Width {get; set;}
See Also

Reference

SharpGraph Class
SharpGraph Members


Capacity Property (TitlesCollection)

Capacity Property (TitlesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : Capacity Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

TitlesCollection Class
TitlesCollection Members


Clear Method (TitlesCollection)

Clear Method (TitlesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : Clear Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

TitlesCollection Class
TitlesCollection Members


Count Property (TitlesCollection)

Count Property (TitlesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : Count Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

TitlesCollection Class
TitlesCollection Members


RemoveAt Method (TitlesCollection)

RemoveAt Method (TitlesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > TitlesCollection Class : RemoveAt Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
See Also

Reference

TitlesCollection Class
TitlesCollection Members


Title Constructor

Title Constructor

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > Title Class : Title Constructor
Initializes a new instance of the Title class.
Overload List
Overload | Description
Title Constructor | Initializes new instance of the Title object.
See Also

Reference

Title Class
Title Members


Clear Method (WallRangesCollection)

Clear Method (WallRangesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class : Clear Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

WallRangesCollection Class
WallRangesCollection Members


RemoveAt Method (WallRangesCollection)

RemoveAt Method (WallRangesCollection)

GrapeCity.ActiveReports.Chart.v10 Assembly > GrapeCity.ActiveReports.Chart Namespace > WallRangesCollection Class : RemoveAt Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
See Also

Reference

WallRangesCollection Class
WallRangesCollection Members


GrapeCity.ActiveReports.Chart Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Chart Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Chart.v10 Assembly : GrapeCity.ActiveReports.Chart Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Chart.BorderSizes
GrapeCity.ActiveReports.Chart.ChartTypeConfig
GrapeCity.ActiveReports.Chart.HitTest
GrapeCity.ActiveReports.Chart.Item
GrapeCity.ActiveReports.Chart.Border
GrapeCity.ActiveReports.Chart.CustomProperties
GrapeCity.ActiveReports.Chart.DataPoint
GrapeCity.ActiveReports.Chart.DoubleArray
GrapeCity.ActiveReports.Chart.DrawCustomizableItem
GrapeCity.ActiveReports.Chart.DrawCustomizableComponent
GrapeCity.ActiveReports.Chart.ChartArea
GrapeCity.ActiveReports.Chart.Legend
GrapeCity.ActiveReports.Chart.Graphics.Backdrop
GrapeCity.ActiveReports.Chart.BackdropItem
GrapeCity.ActiveReports.Chart.LabelInfo
GrapeCity.ActiveReports.Chart.MouseEnabledItem
GrapeCity.ActiveReports.Chart.Marker
GrapeCity.ActiveReports.Chart.MouseEnabledComponent
GrapeCity.ActiveReports.Chart.AxisBase
GrapeCity.ActiveReports.Chart.Axis
GrapeCity.ActiveReports.Chart.CustomAxis
GrapeCity.ActiveReports.Chart.Series
GrapeCity.ActiveReports.Chart.Title
GrapeCity.ActiveReports.Chart.WallRange
GrapeCity.ActiveReports.Chart.PlaneItem
GrapeCity.ActiveReports.Chart.FontInfo
GrapeCity.ActiveReports.Chart.GridLayout
GrapeCity.ActiveReports.Chart.ItemComponent
GrapeCity.ActiveReports.Chart.AxisScroll
GrapeCity.ActiveReports.Chart.LegendItem
GrapeCity.ActiveReports.Chart.Light
GrapeCity.ActiveReports.Chart.Projection
GrapeCity.ActiveReports.Chart.Tick
GrapeCity.ActiveReports.Chart.KeyValuePair
GrapeCity.ActiveReports.Chart.LabelsCollection
GrapeCity.ActiveReports.Chart.XmlDataProvider
System.Collections.CollectionBase
GrapeCity.ActiveReports.Chart.AxesCollection
GrapeCity.ActiveReports.Chart.ChartAreasCollection
GrapeCity.ActiveReports.Chart.DataPointsCollection
GrapeCity.ActiveReports.Chart.LegendItemsCollection
GrapeCity.ActiveReports.Chart.LegendsCollection
GrapeCity.ActiveReports.Chart.SeriesCollection
GrapeCity.ActiveReports.Chart.TitlesCollection
GrapeCity.ActiveReports.Chart.WallRangesCollection
System.EventArgs
GrapeCity.ActiveReports.Chart.CustomDrawEventArgs
System.Windows.Forms.MouseEventArgs
GrapeCity.ActiveReports.Chart.GraphMouseEventArgs
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
GrapeCity.ActiveReports.Chart.SharpGraph
System.ValueType
GrapeCity.ActiveReports.Chart.Padding
See Also

Reference

GrapeCity.ActiveReports.Chart.v10 Assembly


GrapeCity.ActiveReports.Design.Win.v10 Assembly

GrapeCity.ActiveReports.Design.Win.v10 Assembly
Namespaces
Namespace | Description
GrapeCity.ActiveReports.Design | The GrapeCity.ActiveReports.Design namespace contains the designer classes and designer controls.
GrapeCity.ActiveReports.Design.ReportExplorer | The GrapeCity.ActiveReports.Design.ReportExplorer namespace includes the ReportExplorer class which is the base class for the ReportExplorer control.
GrapeCity.ActiveReports.Design.Toolbox | The GrapeCity.ActiveReports.Design.Toolbox namespace contains classes for adding controls to the designer toolbox.


Designer Constructor

Designer Constructor

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Designer Constructor
Initializes a new instance of the Designer class.
Overload List
Overload | Description
Designer Constructor | Creates a new Instance of Designer class.
See Also

Reference

Designer Class
Designer Members


AccessibilityObject Property (Designer)

AccessibilityObject Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AccessibilityObject Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property AccessibilityObject As System.Windows.Forms.AccessibleObject
public System.Windows.Forms.AccessibleObject AccessibilityObject {get;}
See Also

Reference

Designer Class
Designer Members


AccessibleDefaultActionDescription Property (Designer)

AccessibleDefaultActionDescription Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AccessibleDefaultActionDescription Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AccessibleDefaultActionDescription As System.String
public System.string AccessibleDefaultActionDescription {get; set;}
See Also

Reference

Designer Class
Designer Members


AccessibleDescription Property (Designer)

AccessibleDescription Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AccessibleDescription Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AccessibleDescription As System.String
public System.string AccessibleDescription {get; set;}
See Also

Reference

Designer Class
Designer Members


AccessibleName Property (Designer)

AccessibleName Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AccessibleName Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AccessibleName As System.String
public System.string AccessibleName {get; set;}
See Also

Reference

Designer Class
Designer Members


AccessibleRole Property (Designer)

AccessibleRole Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AccessibleRole Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AccessibleRole As System.Windows.Forms.AccessibleRole
public System.Windows.Forms.AccessibleRole AccessibleRole {get; set;}
See Also

Reference

Designer Class
Designer Members


ActiveControl Property (Designer)

ActiveControl Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ActiveControl Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ActiveControl As System.Windows.Forms.Control
public System.Windows.Forms.Control ActiveControl {get; set;}
See Also

Reference

Designer Class
Designer Members


AllowDrop Property (Designer)

AllowDrop Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AllowDrop Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property AllowDrop As System.Boolean
public virtual System.bool AllowDrop {get; set;}
See Also

Reference

Designer Class
Designer Members


Anchor Property (Designer)

Anchor Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Anchor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Anchor As System.Windows.Forms.AnchorStyles
public virtual System.Windows.Forms.AnchorStyles Anchor {get; set;}
See Also

Reference

Designer Class
Designer Members


AutoScaleDimensions Property (Designer)

AutoScaleDimensions Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AutoScaleDimensions Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScaleDimensions As SizeF
public SizeF AutoScaleDimensions {get; set;}
See Also

Reference

Designer Class
Designer Members


AutoScaleMode Property (Designer)

AutoScaleMode Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AutoScaleMode Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScaleMode As System.Windows.Forms.AutoScaleMode
public System.Windows.Forms.AutoScaleMode AutoScaleMode {get; set;}
See Also

Reference

Designer Class
Designer Members


AutoScroll Property (Designer)

AutoScroll Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AutoScroll Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property AutoScroll As System.Boolean
public virtual System.bool AutoScroll {get; set;}
See Also

Reference

Designer Class
Designer Members


AutoScrollMargin Property (Designer)

AutoScrollMargin Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AutoScrollMargin Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScrollMargin As Size
public Size AutoScrollMargin {get; set;}
See Also

Reference

Designer Class
Designer Members


AutoScrollMinSize Property (Designer)

AutoScrollMinSize Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AutoScrollMinSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScrollMinSize As Size
public Size AutoScrollMinSize {get; set;}
See Also

Reference

Designer Class
Designer Members


AutoScrollOffset Property (Designer)

AutoScrollOffset Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AutoScrollOffset Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property AutoScrollOffset As Point
public virtual Point AutoScrollOffset {get; set;}
See Also

Reference

Designer Class
Designer Members


AutoScrollPosition Property (Designer)

AutoScrollPosition Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AutoScrollPosition Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScrollPosition As Point
public Point AutoScrollPosition {get; set;}
See Also

Reference

Designer Class
Designer Members


AutoSize Property (Designer)

AutoSize Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AutoSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property AutoSize As System.Boolean
public virtual System.bool AutoSize {get; set;}
See Also

Reference

Designer Class
Designer Members


AutoSizeChanged Event (Designer)

AutoSizeChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AutoSizeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event AutoSizeChanged As System.EventHandler
public event System.EventHandler AutoSizeChanged
See Also

Reference

Designer Class
Designer Members


AutoSizeMode Property (Designer)

AutoSizeMode Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AutoSizeMode Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoSizeMode As System.Windows.Forms.AutoSizeMode
public System.Windows.Forms.AutoSizeMode AutoSizeMode {get; set;}
See Also

Reference

Designer Class
Designer Members


AutoValidate Property (Designer)

AutoValidate Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AutoValidate Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property AutoValidate As System.Windows.Forms.AutoValidate
public virtual System.Windows.Forms.AutoValidate AutoValidate {get; set;}
See Also

Reference

Designer Class
Designer Members


AutoValidateChanged Event (Designer)

AutoValidateChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : AutoValidateChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event AutoValidateChanged As System.EventHandler
public event System.EventHandler AutoValidateChanged
See Also

Reference

Designer Class
Designer Members


BackColor Property (Designer)

BackColor Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : BackColor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property BackColor As Color
public virtual Color BackColor {get; set;}
See Also

Reference

Designer Class
Designer Members


BackColorChanged Event (Designer)

BackColorChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : BackColorChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BackColorChanged As System.EventHandler
public event System.EventHandler BackColorChanged
See Also

Reference

Designer Class
Designer Members


BackgroundImage Property (Designer)

BackgroundImage Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : BackgroundImage Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property BackgroundImage As Image
public virtual Image BackgroundImage {get; set;}
See Also

Reference

Designer Class
Designer Members


BackgroundImageChanged Event (Designer)

BackgroundImageChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : BackgroundImageChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BackgroundImageChanged As System.EventHandler
public event System.EventHandler BackgroundImageChanged
See Also

Reference

Designer Class
Designer Members


BackgroundImageLayout Property (Designer)

BackgroundImageLayout Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : BackgroundImageLayout Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property BackgroundImageLayout As System.Windows.Forms.ImageLayout
public virtual System.Windows.Forms.ImageLayout BackgroundImageLayout {get; set;}
See Also

Reference

Designer Class
Designer Members


BackgroundImageLayoutChanged Event (Designer)

BackgroundImageLayoutChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : BackgroundImageLayoutChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BackgroundImageLayoutChanged As System.EventHandler
public event System.EventHandler BackgroundImageLayoutChanged
See Also

Reference

Designer Class
Designer Members


BeginInvoke Method (Designer)

BeginInvoke Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : BeginInvoke Method
Overload List
Overload | Description
BeginInvoke(Delegate) | (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Designer Class
Designer Members


BeginInvoke(Delegate) Method

BeginInvoke(Delegate) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > BeginInvoke Method : BeginInvoke(Delegate) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function BeginInvoke( _
   ByVal method As System.Delegate _
) As System.IAsyncResult
public System.IAsyncResult BeginInvoke(
   System.Delegate method
)

Parameters

method
See Also

Reference

Designer Class
Designer Members
Overload List


BeginInvoke(Delegate,Object[]) Method

BeginInvoke(Delegate,Object[]) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function BeginInvoke( _
   ByVal method As System.Delegate, _
   ByVal ParamArray args() As System.Object _
) As System.IAsyncResult
public System.IAsyncResult BeginInvoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
args
See Also

Reference

Designer Class
Designer Members
Overload List


BindingContext Property (Designer)

BindingContext Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : BindingContext Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property BindingContext As System.Windows.Forms.BindingContext
public virtual System.Windows.Forms.BindingContext BindingContext {get; set;}
See Also

Reference

Designer Class
Designer Members


BindingContextChanged Event (Designer)

BindingContextChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : BindingContextChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BindingContextChanged As System.EventHandler
public event System.EventHandler BindingContextChanged
See Also

Reference

Designer Class
Designer Members


BorderStyle Property (Designer)

BorderStyle Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : BorderStyle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BorderStyle As System.Windows.Forms.BorderStyle
public System.Windows.Forms.BorderStyle BorderStyle {get; set;}
See Also

Reference

Designer Class
Designer Members


Bottom Property (Designer)

Bottom Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Bottom Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Bottom As System.Integer
public System.int Bottom {get;}
See Also

Reference

Designer Class
Designer Members


Bounds Property (Designer)

Bounds Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Bounds Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Bounds As Rectangle
public Rectangle Bounds {get; set;}
See Also

Reference

Designer Class
Designer Members


BringToFront Method (Designer)

BringToFront Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : BringToFront Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub BringToFront()
public void BringToFront()
See Also

Reference

Designer Class
Designer Members


CanFocus Property (Designer)

CanFocus Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CanFocus Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CanFocus As System.Boolean
public System.bool CanFocus {get;}
See Also

Reference

Designer Class
Designer Members


CanSelect Property (Designer)

CanSelect Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CanSelect Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CanSelect As System.Boolean
public System.bool CanSelect {get;}
See Also

Reference

Designer Class
Designer Members


Capture Property (Designer)

Capture Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Capture Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capture As System.Boolean
public System.bool Capture {get; set;}
See Also

Reference

Designer Class
Designer Members


CausesValidation Property (Designer)

CausesValidation Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CausesValidation Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CausesValidation As System.Boolean
public System.bool CausesValidation {get; set;}
See Also

Reference

Designer Class
Designer Members


CausesValidationChanged Event (Designer)

CausesValidationChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CausesValidationChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event CausesValidationChanged As System.EventHandler
public event System.EventHandler CausesValidationChanged
See Also

Reference

Designer Class
Designer Members


ChangeUICues Event (Designer)

ChangeUICues Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ChangeUICues Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ChangeUICues As System.Windows.Forms.UICuesEventHandler
public event System.Windows.Forms.UICuesEventHandler ChangeUICues
Event Data

The event handler receives an argument of type System.Windows.Forms.UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.
See Also

Reference

Designer Class
Designer Members


Click Event (Designer)

Click Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Click Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Click As System.EventHandler
public event System.EventHandler Click
See Also

Reference

Designer Class
Designer Members


ClientRectangle Property (Designer)

ClientRectangle Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ClientRectangle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ClientRectangle As Rectangle
public Rectangle ClientRectangle {get;}
See Also

Reference

Designer Class
Designer Members


ClientSize Property (Designer)

ClientSize Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ClientSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ClientSize As Size
public Size ClientSize {get; set;}
See Also

Reference

Designer Class
Designer Members


ClientSizeChanged Event (Designer)

ClientSizeChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ClientSizeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ClientSizeChanged As System.EventHandler
public event System.EventHandler ClientSizeChanged
See Also

Reference

Designer Class
Designer Members


CompanyName Property (Designer)

CompanyName Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CompanyName Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CompanyName As System.String
public System.string CompanyName {get;}
See Also

Reference

Designer Class
Designer Members


ConnectToServer Method

ConnectToServer Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ConnectToServer Method
Shows ConnectToServer dialog.
Overload List
Overload | Description
ConnectToServer | Shows ConnectToServer dialog.
See Also

Reference

Designer Class
Designer Members


Container Property (Designer)

Container Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

Designer Class
Designer Members


Contains Method (Designer)

Contains Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Contains Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal ctl As System.Windows.Forms.Control _
) As System.Boolean
public System.bool Contains(
   System.Windows.Forms.Control ctl
)

Parameters

ctl
See Also

Reference

Designer Class
Designer Members


ContainsFocus Property (Designer)

ContainsFocus Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ContainsFocus Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ContainsFocus As System.Boolean
public System.bool ContainsFocus {get;}
See Also

Reference

Designer Class
Designer Members


ContextMenu Property (Designer)

ContextMenu Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ContextMenu Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property ContextMenu As System.Windows.Forms.ContextMenu
public virtual System.Windows.Forms.ContextMenu ContextMenu {get; set;}
See Also

Reference

Designer Class
Designer Members


ContextMenuChanged Event (Designer)

ContextMenuChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ContextMenuChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ContextMenuChanged As System.EventHandler
public event System.EventHandler ContextMenuChanged
See Also

Reference

Designer Class
Designer Members


ContextMenuStrip Property (Designer)

ContextMenuStrip Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ContextMenuStrip Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property ContextMenuStrip As System.Windows.Forms.ContextMenuStrip
public virtual System.Windows.Forms.ContextMenuStrip ContextMenuStrip {get; set;}
See Also

Reference

Designer Class
Designer Members


ContextMenuStripChanged Event (Designer)

ContextMenuStripChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ContextMenuStripChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ContextMenuStripChanged As System.EventHandler
public event System.EventHandler ContextMenuStripChanged
See Also

Reference

Designer Class
Designer Members


ControlAdded Event (Designer)

ControlAdded Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ControlAdded Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ControlAdded As System.Windows.Forms.ControlEventHandler
public event System.Windows.Forms.ControlEventHandler ControlAdded
Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.
See Also

Reference

Designer Class
Designer Members


ControlRemoved Event (Designer)

ControlRemoved Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ControlRemoved Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ControlRemoved As System.Windows.Forms.ControlEventHandler
public event System.Windows.Forms.ControlEventHandler ControlRemoved
Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.
See Also

Reference

Designer Class
Designer Members


Controls Property (Designer)

Controls Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Controls Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Controls As System.Windows.Forms.Control.ControlCollection
public System.Windows.Forms.Control.ControlCollection Controls {get;}
See Also

Reference

Designer Class
Designer Members


CreateControl Method (Designer)

CreateControl Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CreateControl Method
Overload List
Overload | Description
CreateControl | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Designer Class
Designer Members


CreateControl() Method

CreateControl() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CreateControl() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CreateControl()
public void CreateControl()
See Also

Reference

Designer Class
Designer Members


Created Property (Designer)

Created Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Created Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Created As System.Boolean
public System.bool Created {get;}
See Also

Reference

Designer Class
Designer Members


CreateGraphics Method (Designer)

CreateGraphics Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CreateGraphics Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateGraphics() As Graphics
public Graphics CreateGraphics()
See Also

Reference

Designer Class
Designer Members


CreateObjRef Method (Designer)

CreateObjRef Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

Designer Class
Designer Members


CurrentAutoScaleDimensions Property (Designer)

CurrentAutoScaleDimensions Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CurrentAutoScaleDimensions Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CurrentAutoScaleDimensions As SizeF
public SizeF CurrentAutoScaleDimensions {get;}
See Also

Reference

Designer Class
Designer Members


Cursor Property (Designer)

Cursor Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Cursor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Cursor As System.Windows.Forms.Cursor
public virtual System.Windows.Forms.Cursor Cursor {get; set;}
See Also

Reference

Designer Class
Designer Members


CursorChanged Event (Designer)

CursorChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : CursorChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event CursorChanged As System.EventHandler
public event System.EventHandler CursorChanged
See Also

Reference

Designer Class
Designer Members


DataBindings Property (Designer)

DataBindings Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DataBindings Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DataBindings As System.Windows.Forms.ControlBindingsCollection
public System.Windows.Forms.ControlBindingsCollection DataBindings {get;}
See Also

Reference

Designer Class
Designer Members


DisconnectFromServer Method

DisconnectFromServer Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DisconnectFromServer Method
Disconnects from server
Overload List
Overload | Description
DisconnectFromServer | Disconnects from server
See Also

Reference

Designer Class
Designer Members


DisplayRectangle Property (Designer)

DisplayRectangle Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DisplayRectangle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property DisplayRectangle As Rectangle
public virtual Rectangle DisplayRectangle {get;}
See Also

Reference

Designer Class
Designer Members


Dispose Method (Designer)

Dispose Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Dispose Method
Clears the Designer from memory.
Overload List
Overload | Description
Dispose | Disposes objects referenced by the designer. (Inherited from System.ComponentModel.Component)
See Also

Reference

Designer Class
Designer Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Dispose() Method
Disposes objects referenced by the designer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Designer Class
Designer Members


Disposed Event (Designer)

Disposed Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Designer Class
Designer Members


Disposing Property (Designer)

Disposing Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Disposing Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Disposing As System.Boolean
public System.bool Disposing {get;}
See Also

Reference

Designer Class
Designer Members


Dock Property (Designer)

Dock Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Dock Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Dock As System.Windows.Forms.DockStyle
public virtual System.Windows.Forms.DockStyle Dock {get; set;}
See Also

Reference

Designer Class
Designer Members


DockChanged Event (Designer)

DockChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DockChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DockChanged As System.EventHandler
public event System.EventHandler DockChanged
See Also

Reference

Designer Class
Designer Members


DoDragDrop Method (Designer)

DoDragDrop Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DoDragDrop Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function DoDragDrop( _
   ByVal data As System.Object, _
   ByVal allowedEffects As System.Windows.Forms.DragDropEffects _
) As System.Windows.Forms.DragDropEffects
public System.Windows.Forms.DragDropEffects DoDragDrop(
   System.object data,
   System.Windows.Forms.DragDropEffects allowedEffects
)

Parameters

data
allowedEffects
See Also

Reference

Designer Class
Designer Members


DoubleClick Event (Designer)

DoubleClick Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DoubleClick Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DoubleClick As System.EventHandler
public event System.EventHandler DoubleClick
See Also

Reference

Designer Class
Designer Members


DragDrop Event (Designer)

DragDrop Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DragDrop Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragDrop As System.Windows.Forms.DragEventHandler
public event System.Windows.Forms.DragEventHandler DragDrop
Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.
See Also

Reference

Designer Class
Designer Members


DragEnter Event (Designer)

DragEnter Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DragEnter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragEnter As System.Windows.Forms.DragEventHandler
public event System.Windows.Forms.DragEventHandler DragEnter
Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.
See Also

Reference

Designer Class
Designer Members


DragLeave Event (Designer)

DragLeave Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DragLeave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragLeave As System.EventHandler
public event System.EventHandler DragLeave
See Also

Reference

Designer Class
Designer Members


DragOver Event (Designer)

DragOver Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DragOver Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragOver As System.Windows.Forms.DragEventHandler
public event System.Windows.Forms.DragEventHandler DragOver
Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.
See Also

Reference

Designer Class
Designer Members


DrawToBitmap Method (Designer)

DrawToBitmap Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : DrawToBitmap Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub DrawToBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal targetBounds As Rectangle _
)
public void DrawToBitmap(
   Bitmap bitmap,
   Rectangle targetBounds
)

Parameters

bitmap
targetBounds
See Also

Reference

Designer Class
Designer Members


Enabled Property (Designer)

Enabled Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Enabled Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Enabled As System.Boolean
public System.bool Enabled {get; set;}
See Also

Reference

Designer Class
Designer Members


EnabledChanged Event (Designer)

EnabledChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : EnabledChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event EnabledChanged As System.EventHandler
public event System.EventHandler EnabledChanged
See Also

Reference

Designer Class
Designer Members


EndInvoke Method (Designer)

EndInvoke Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : EndInvoke Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function EndInvoke( _
   ByVal asyncResult As System.IAsyncResult _
) As System.Object
public System.object EndInvoke(
   System.IAsyncResult asyncResult
)

Parameters

asyncResult
See Also

Reference

Designer Class
Designer Members


Enter Event (Designer)

Enter Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Enter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Enter As System.EventHandler
public event System.EventHandler Enter
See Also

Reference

Designer Class
Designer Members


FindForm Method (Designer)

FindForm Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : FindForm Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function FindForm() As System.Windows.Forms.Form
public System.Windows.Forms.Form FindForm()
See Also

Reference

Designer Class
Designer Members


Focus Method (Designer)

Focus Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Focus Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Focus() As System.Boolean
public System.bool Focus()
See Also

Reference

Designer Class
Designer Members


Focused Property (Designer)

Focused Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Focused Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Focused As System.Boolean
public virtual System.bool Focused {get;}
See Also

Reference

Designer Class
Designer Members


Font Property (Designer)

Font Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Font Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Font As Font
public virtual Font Font {get; set;}
See Also

Reference

Designer Class
Designer Members


FontChanged Event (Designer)

FontChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : FontChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event FontChanged As System.EventHandler
public event System.EventHandler FontChanged
See Also

Reference

Designer Class
Designer Members


ForeColor Property (Designer)

ForeColor Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ForeColor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property ForeColor As Color
public virtual Color ForeColor {get; set;}
See Also

Reference

Designer Class
Designer Members


ForeColorChanged Event (Designer)

ForeColorChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ForeColorChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ForeColorChanged As System.EventHandler
public event System.EventHandler ForeColorChanged
See Also

Reference

Designer Class
Designer Members


GetChildAtPoint Method (Designer)

GetChildAtPoint Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : GetChildAtPoint Method
Overload List
Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Designer Class
Designer Members


GetChildAtPoint(Point) Method

GetChildAtPoint(Point) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point _
) As System.Windows.Forms.Control
public System.Windows.Forms.Control GetChildAtPoint(
   Point pt
)

Parameters

pt
See Also

Reference

Designer Class
Designer Members
Overload List


GetChildAtPoint(Point,GetChildAtPointSkip) Method

GetChildAtPoint(Point,GetChildAtPointSkip) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point, _
   ByVal skipValue As System.Windows.Forms.GetChildAtPointSkip _
) As System.Windows.Forms.Control
public System.Windows.Forms.Control GetChildAtPoint(
   Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)

Parameters

pt
skipValue
See Also

Reference

Designer Class
Designer Members
Overload List


GetContainerControl Method (Designer)

GetContainerControl Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : GetContainerControl Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetContainerControl() As System.Windows.Forms.IContainerControl
public System.Windows.Forms.IContainerControl GetContainerControl()
See Also

Reference

Designer Class
Designer Members


GetLifetimeService Method (Designer)

GetLifetimeService Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

Designer Class
Designer Members


GetNextControl Method (Designer)

GetNextControl Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : GetNextControl Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetNextControl( _
   ByVal ctl As System.Windows.Forms.Control, _
   ByVal forward As System.Boolean _
) As System.Windows.Forms.Control
public System.Windows.Forms.Control GetNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward
)

Parameters

ctl
forward
See Also

Reference

Designer Class
Designer Members


GetPreferredSize Method (Designer)

GetPreferredSize Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : GetPreferredSize Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetPreferredSize( _
   ByVal proposedSize As Size _
) As Size
public virtual Size GetPreferredSize(
   Size proposedSize
)

Parameters

proposedSize
See Also

Reference

Designer Class
Designer Members


GiveFeedback Event (Designer)

GiveFeedback Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : GiveFeedback Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event GiveFeedback As System.Windows.Forms.GiveFeedbackEventHandler
public event System.Windows.Forms.GiveFeedbackEventHandler GiveFeedback
Event Data

The event handler receives an argument of type System.Windows.Forms.GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.
See Also

Reference

Designer Class
Designer Members


GotFocus Event (Designer)

GotFocus Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : GotFocus Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event GotFocus As System.EventHandler
public event System.EventHandler GotFocus
See Also

Reference

Designer Class
Designer Members


Handle Property (Designer)

Handle Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Handle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Handle As System.IntPtr
public System.IntPtr Handle {get;}
See Also

Reference

Designer Class
Designer Members


HandleCreated Event (Designer)

HandleCreated Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : HandleCreated Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event HandleCreated As System.EventHandler
public event System.EventHandler HandleCreated
See Also

Reference

Designer Class
Designer Members


HandleDestroyed Event (Designer)

HandleDestroyed Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : HandleDestroyed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event HandleDestroyed As System.EventHandler
public event System.EventHandler HandleDestroyed
See Also

Reference

Designer Class
Designer Members


HasChildren Property (Designer)

HasChildren Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : HasChildren Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HasChildren As System.Boolean
public System.bool HasChildren {get;}
See Also

Reference

Designer Class
Designer Members


Height Property (Designer)

Height Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Height Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As System.Integer
public System.int Height {get; set;}
See Also

Reference

Designer Class
Designer Members


HelpRequested Event (Designer)

HelpRequested Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : HelpRequested Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event HelpRequested As System.Windows.Forms.HelpEventHandler
public event System.Windows.Forms.HelpEventHandler HelpRequested
Event Data

The event handler receives an argument of type System.Windows.Forms.HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.
See Also

Reference

Designer Class
Designer Members


Hide Method (Designer)

Hide Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Hide Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Hide()
public void Hide()
See Also

Reference

Designer Class
Designer Members


HorizontalScroll Property (Designer)

HorizontalScroll Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : HorizontalScroll Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HorizontalScroll As System.Windows.Forms.HScrollProperties
public System.Windows.Forms.HScrollProperties HorizontalScroll {get;}
See Also

Reference

Designer Class
Designer Members


ImeMode Property (Designer)

ImeMode Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ImeMode Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ImeMode As System.Windows.Forms.ImeMode
public System.Windows.Forms.ImeMode ImeMode {get; set;}
See Also

Reference

Designer Class
Designer Members


ImeModeChanged Event (Designer)

ImeModeChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ImeModeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ImeModeChanged As System.EventHandler
public event System.EventHandler ImeModeChanged
See Also

Reference

Designer Class
Designer Members


InitializeLifetimeService Method (Designer)

InitializeLifetimeService Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
public virtual System.object InitializeLifetimeService()
See Also

Reference

Designer Class
Designer Members


Invalidate Method (Designer)

Invalidate Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Invalidate Method
Overload List
Overload | Description
Invalidate(Region) | (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | (Inherited from System.Windows.Forms.Control)
Invalidate() | (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Designer Class
Designer Members


Invalidate() Method

Invalidate() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > Invalidate Method : Invalidate() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate()
public void Invalidate()
See Also

Reference

Designer Class
Designer Members
Overload List


Invalidate(Boolean) Method

Invalidate(Boolean) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > Invalidate Method : Invalidate(Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal invalidateChildren As System.Boolean _
)
public void Invalidate(
   System.bool invalidateChildren
)

Parameters

invalidateChildren
See Also

Reference

Designer Class
Designer Members
Overload List


Invalidate(Rectangle) Method

Invalidate(Rectangle) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > Invalidate Method : Invalidate(Rectangle) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle _
)
public void Invalidate(
   Rectangle rc
)

Parameters

rc
See Also

Reference

Designer Class
Designer Members
Overload List


Invalidate(Rectangle,Boolean) Method

Invalidate(Rectangle,Boolean) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle, _
   ByVal invalidateChildren As System.Boolean _
)
public void Invalidate(
   Rectangle rc,
   System.bool invalidateChildren
)

Parameters

rc
invalidateChildren
See Also

Reference

Designer Class
Designer Members
Overload List


Invalidate(Region) Method

Invalidate(Region) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > Invalidate Method : Invalidate(Region) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal region As Region _
)
public void Invalidate(
   Region region
)

Parameters

region
See Also

Reference

Designer Class
Designer Members
Overload List


Invalidate(Region,Boolean) Method

Invalidate(Region,Boolean) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > Invalidate Method : Invalidate(Region,Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal region As Region, _
   ByVal invalidateChildren As System.Boolean _
)
public void Invalidate(
   Region region,
   System.bool invalidateChildren
)

Parameters

region
invalidateChildren
See Also

Reference

Designer Class
Designer Members
Overload List


Invalidated Event (Designer)

Invalidated Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Invalidated Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Invalidated As System.Windows.Forms.InvalidateEventHandler
public event System.Windows.Forms.InvalidateEventHandler Invalidated
Event Data

The event handler receives an argument of type System.Windows.Forms.InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.
See Also

Reference

Designer Class
Designer Members


Invoke Method (Designer)

Invoke Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Invoke Method
Overload List
Overload | Description
Invoke(Delegate) | (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Designer Class
Designer Members


Invoke(Delegate) Method

Invoke(Delegate) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > Invoke Method : Invoke(Delegate) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Invoke( _
   ByVal method As System.Delegate _
) As System.Object
public System.object Invoke(
   System.Delegate method
)

Parameters

method
See Also

Reference

Designer Class
Designer Members
Overload List


Invoke(Delegate,Object[]) Method

Invoke(Delegate,Object[]) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > Invoke Method : Invoke(Delegate,Object[]) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Invoke( _
   ByVal method As System.Delegate, _
   ByVal ParamArray args() As System.Object _
) As System.Object
public System.object Invoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
args
See Also

Reference

Designer Class
Designer Members
Overload List


InvokeRequired Property (Designer)

InvokeRequired Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : InvokeRequired Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InvokeRequired As System.Boolean
public System.bool InvokeRequired {get;}
See Also

Reference

Designer Class
Designer Members


IsAccessible Property (Designer)

IsAccessible Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : IsAccessible Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsAccessible As System.Boolean
public System.bool IsAccessible {get; set;}
See Also

Reference

Designer Class
Designer Members


IsDisposed Property (Designer)

IsDisposed Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : IsDisposed Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsDisposed As System.Boolean
public System.bool IsDisposed {get;}
See Also

Reference

Designer Class
Designer Members


IsHandleCreated Property (Designer)

IsHandleCreated Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : IsHandleCreated Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsHandleCreated As System.Boolean
public System.bool IsHandleCreated {get;}
See Also

Reference

Designer Class
Designer Members


IsMirrored Property (Designer)

IsMirrored Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : IsMirrored Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsMirrored As System.Boolean
public System.bool IsMirrored {get;}
See Also

Reference

Designer Class
Designer Members


KeyDown Event (Designer)

KeyDown Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : KeyDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event KeyDown As System.Windows.Forms.KeyEventHandler
public event System.Windows.Forms.KeyEventHandler KeyDown
Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.
See Also

Reference

Designer Class
Designer Members


KeyPress Event (Designer)

KeyPress Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : KeyPress Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event KeyPress As System.Windows.Forms.KeyPressEventHandler
public event System.Windows.Forms.KeyPressEventHandler KeyPress
Event Data

The event handler receives an argument of type System.Windows.Forms.KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.
See Also

Reference

Designer Class
Designer Members


KeyUp Event (Designer)

KeyUp Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : KeyUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event KeyUp As System.Windows.Forms.KeyEventHandler
public event System.Windows.Forms.KeyEventHandler KeyUp
Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.
See Also

Reference

Designer Class
Designer Members


Layout Event (Designer)

Layout Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Layout Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Layout As System.Windows.Forms.LayoutEventHandler
public event System.Windows.Forms.LayoutEventHandler Layout
Event Data

The event handler receives an argument of type System.Windows.Forms.LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.
See Also

Reference

Designer Class
Designer Members


LayoutEngine Property (Designer)

LayoutEngine Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LayoutEngine Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property LayoutEngine As System.Windows.Forms.Layout.LayoutEngine
public virtual System.Windows.Forms.Layout.LayoutEngine LayoutEngine {get;}
See Also

Reference

Designer Class
Designer Members


Leave Event (Designer)

Leave Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Leave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Leave As System.EventHandler
public event System.EventHandler Leave
See Also

Reference

Designer Class
Designer Members


Left Property (Designer)

Left Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Left Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Left As System.Integer
public System.int Left {get; set;}
See Also

Reference

Designer Class
Designer Members


Load Event (Designer)

Load Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Load Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Load As System.EventHandler
public event System.EventHandler Load
See Also

Reference

Designer Class
Designer Members


Location Property (Designer)

Location Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Location Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Location As Point
public Point Location {get; set;}
See Also

Reference

Designer Class
Designer Members


LocationChanged Event (Designer)

LocationChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LocationChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LocationChanged As System.EventHandler
public event System.EventHandler LocationChanged
See Also

Reference

Designer Class
Designer Members


LostFocus Event (Designer)

LostFocus Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : LostFocus Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LostFocus As System.EventHandler
public event System.EventHandler LostFocus
See Also

Reference

Designer Class
Designer Members


Margin Property (Designer)

Margin Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Margin Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Margin As System.Windows.Forms.Padding
public System.Windows.Forms.Padding Margin {get; set;}
See Also

Reference

Designer Class
Designer Members


MarginChanged Event (Designer)

MarginChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MarginChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MarginChanged As System.EventHandler
public event System.EventHandler MarginChanged
See Also

Reference

Designer Class
Designer Members


MaximumSize Property (Designer)

MaximumSize Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MaximumSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property MaximumSize As Size
public virtual Size MaximumSize {get; set;}
See Also

Reference

Designer Class
Designer Members


MinimumSize Property (Designer)

MinimumSize Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MinimumSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property MinimumSize As Size
public virtual Size MinimumSize {get; set;}
See Also

Reference

Designer Class
Designer Members


MouseCaptureChanged Event (Designer)

MouseCaptureChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MouseCaptureChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseCaptureChanged As System.EventHandler
public event System.EventHandler MouseCaptureChanged
See Also

Reference

Designer Class
Designer Members


MouseClick Event (Designer)

MouseClick Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MouseClick Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseClick As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseClick
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

Designer Class
Designer Members


MouseDoubleClick Event (Designer)

MouseDoubleClick Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MouseDoubleClick Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseDoubleClick As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseDoubleClick
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

Designer Class
Designer Members


MouseDown Event (Designer)

MouseDown Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MouseDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseDown As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseDown
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

Designer Class
Designer Members


MouseEnter Event (Designer)

MouseEnter Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MouseEnter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseEnter As System.EventHandler
public event System.EventHandler MouseEnter
See Also

Reference

Designer Class
Designer Members


MouseHover Event (Designer)

MouseHover Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MouseHover Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseHover As System.EventHandler
public event System.EventHandler MouseHover
See Also

Reference

Designer Class
Designer Members


MouseLeave Event (Designer)

MouseLeave Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MouseLeave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseLeave As System.EventHandler
public event System.EventHandler MouseLeave
See Also

Reference

Designer Class
Designer Members


MouseMove Event (Designer)

MouseMove Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MouseMove Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseMove As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseMove
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

Designer Class
Designer Members


MouseUp Event (Designer)

MouseUp Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MouseUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseUp As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseUp
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

Designer Class
Designer Members


MouseWheel Event (Designer)

MouseWheel Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : MouseWheel Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseWheel As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseWheel
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

Designer Class
Designer Members


Move Event (Designer)

Move Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Move Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Move As System.EventHandler
public event System.EventHandler Move
See Also

Reference

Designer Class
Designer Members


Name Property (Designer)

Name Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Name Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}
See Also

Reference

Designer Class
Designer Members


Padding Property (Designer)

Padding Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Padding Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Padding As System.Windows.Forms.Padding
public System.Windows.Forms.Padding Padding {get; set;}
See Also

Reference

Designer Class
Designer Members


PaddingChanged Event (Designer)

PaddingChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PaddingChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PaddingChanged As System.EventHandler
public event System.EventHandler PaddingChanged
See Also

Reference

Designer Class
Designer Members


Paint Event (Designer)

Paint Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Paint Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Paint As System.Windows.Forms.PaintEventHandler
public event System.Windows.Forms.PaintEventHandler Paint
Event Data

The event handler receives an argument of type System.Windows.Forms.PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.
See Also

Reference

Designer Class
Designer Members


Parent Property (Designer)

Parent Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Parent Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Parent As System.Windows.Forms.Control
public System.Windows.Forms.Control Parent {get; set;}
See Also

Reference

Designer Class
Designer Members


ParentChanged Event (Designer)

ParentChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ParentChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ParentChanged As System.EventHandler
public event System.EventHandler ParentChanged
See Also

Reference

Designer Class
Designer Members


ParentForm Property (Designer)

ParentForm Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ParentForm Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ParentForm As System.Windows.Forms.Form
public System.Windows.Forms.Form ParentForm {get;}
See Also

Reference

Designer Class
Designer Members


PerformAutoScale Method (Designer)

PerformAutoScale Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PerformAutoScale Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub PerformAutoScale()
public void PerformAutoScale()
See Also

Reference

Designer Class
Designer Members


PerformLayout Method (Designer)

PerformLayout Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PerformLayout Method
Overload List
Overload | Description
PerformLayout() | (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Designer Class
Designer Members


PerformLayout() Method

PerformLayout() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > PerformLayout Method : PerformLayout() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub PerformLayout()
public void PerformLayout()
See Also

Reference

Designer Class
Designer Members
Overload List


PerformLayout(Control,String) Method

PerformLayout(Control,String) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > PerformLayout Method : PerformLayout(Control,String) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub PerformLayout( _
   ByVal affectedControl As System.Windows.Forms.Control, _
   ByVal affectedProperty As System.String _
)
public void PerformLayout(
   System.Windows.Forms.Control affectedControl,
   System.string affectedProperty
)

Parameters

affectedControl
affectedProperty
See Also

Reference

Designer Class
Designer Members
Overload List


PointToClient Method (Designer)

PointToClient Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PointToClient Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PointToClient( _
   ByVal p As Point _
) As Point
public Point PointToClient(
   Point p
)

Parameters

p
See Also

Reference

Designer Class
Designer Members


PointToScreen Method (Designer)

PointToScreen Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PointToScreen Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PointToScreen( _
   ByVal p As Point _
) As Point
public Point PointToScreen(
   Point p
)

Parameters

p
See Also

Reference

Designer Class
Designer Members


PreferredSize Property (Designer)

PreferredSize Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PreferredSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PreferredSize As Size
public Size PreferredSize {get;}
See Also

Reference

Designer Class
Designer Members


PreProcessControlMessage Method (Designer)

PreProcessControlMessage Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PreProcessControlMessage Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PreProcessControlMessage( _
   ByRef msg As System.Windows.Forms.Message _
) As System.Windows.Forms.PreProcessControlState
public System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
See Also

Reference

Designer Class
Designer Members


PreProcessMessage Method (Designer)

PreProcessMessage Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PreProcessMessage Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function PreProcessMessage( _
   ByRef msg As System.Windows.Forms.Message _
) As System.Boolean
public virtual System.bool PreProcessMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
See Also

Reference

Designer Class
Designer Members


PreviewKeyDown Event (Designer)

PreviewKeyDown Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : PreviewKeyDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewKeyDown As System.Windows.Forms.PreviewKeyDownEventHandler
public event System.Windows.Forms.PreviewKeyDownEventHandler PreviewKeyDown
Event Data

The event handler receives an argument of type System.Windows.Forms.PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.
See Also

Reference

Designer Class
Designer Members


ProductName Property (Designer)

ProductName Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ProductName Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ProductName As System.String
public System.string ProductName {get;}
See Also

Reference

Designer Class
Designer Members


ProductVersion Property (Designer)

ProductVersion Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ProductVersion Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ProductVersion As System.String
public System.string ProductVersion {get;}
See Also

Reference

Designer Class
Designer Members


QueryAccessibilityHelp Event (Designer)

QueryAccessibilityHelp Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : QueryAccessibilityHelp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event QueryAccessibilityHelp As System.Windows.Forms.QueryAccessibilityHelpEventHandler
public event System.Windows.Forms.QueryAccessibilityHelpEventHandler QueryAccessibilityHelp
Event Data

The event handler receives an argument of type System.Windows.Forms.QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.
See Also

Reference

Designer Class
Designer Members


QueryContinueDrag Event (Designer)

QueryContinueDrag Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : QueryContinueDrag Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event QueryContinueDrag As System.Windows.Forms.QueryContinueDragEventHandler
public event System.Windows.Forms.QueryContinueDragEventHandler QueryContinueDrag
Event Data

The event handler receives an argument of type System.Windows.Forms.QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.
See Also

Reference

Designer Class
Designer Members


RecreatingHandle Property (Designer)

RecreatingHandle Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : RecreatingHandle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property RecreatingHandle As System.Boolean
public System.bool RecreatingHandle {get;}
See Also

Reference

Designer Class
Designer Members


RectangleToClient Method (Designer)

RectangleToClient Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : RectangleToClient Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function RectangleToClient( _
   ByVal r As Rectangle _
) As Rectangle
public Rectangle RectangleToClient(
   Rectangle r
)

Parameters

r
See Also

Reference

Designer Class
Designer Members


RectangleToScreen Method (Designer)

RectangleToScreen Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : RectangleToScreen Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function RectangleToScreen( _
   ByVal r As Rectangle _
) As Rectangle
public Rectangle RectangleToScreen(
   Rectangle r
)

Parameters

r
See Also

Reference

Designer Class
Designer Members


Refresh Method (Designer)

Refresh Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Refresh Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub Refresh()
public virtual void Refresh()
See Also

Reference

Designer Class
Designer Members


Region Property (Designer)

Region Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Region Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Region As Region
public Region Region {get; set;}
See Also

Reference

Designer Class
Designer Members


RegionChanged Event (Designer)

RegionChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : RegionChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event RegionChanged As System.EventHandler
public event System.EventHandler RegionChanged
See Also

Reference

Designer Class
Designer Members


ResetText Method (Designer)

ResetText Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ResetText Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub ResetText()
public virtual void ResetText()
See Also

Reference

Designer Class
Designer Members


Resize Event (Designer)

Resize Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Resize Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Resize As System.EventHandler
public event System.EventHandler Resize
See Also

Reference

Designer Class
Designer Members


ResumeLayout Method (Designer)

ResumeLayout Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ResumeLayout Method
Overload List
Overload | Description
ResumeLayout() | (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Designer Class
Designer Members


ResumeLayout() Method

ResumeLayout() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > ResumeLayout Method : ResumeLayout() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ResumeLayout()
public void ResumeLayout()
See Also

Reference

Designer Class
Designer Members
Overload List


ResumeLayout(Boolean) Method

ResumeLayout(Boolean) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > ResumeLayout Method : ResumeLayout(Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ResumeLayout( _
   ByVal performLayout As System.Boolean _
)
public void ResumeLayout(
   System.bool performLayout
)

Parameters

performLayout
See Also

Reference

Designer Class
Designer Members
Overload List


Right Property (Designer)

Right Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Right Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Right As System.Integer
public System.int Right {get;}
See Also

Reference

Designer Class
Designer Members


RightToLeft Property (Designer)

RightToLeft Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : RightToLeft Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property RightToLeft As System.Windows.Forms.RightToLeft
public virtual System.Windows.Forms.RightToLeft RightToLeft {get; set;}
See Also

Reference

Designer Class
Designer Members


RightToLeftChanged Event (Designer)

RightToLeftChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : RightToLeftChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event RightToLeftChanged As System.EventHandler
public event System.EventHandler RightToLeftChanged
See Also

Reference

Designer Class
Designer Members


Scale Method (Designer)

Scale Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Scale Method
Overload List
Overload | Description
Scale | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Designer Class
Designer Members


Scale(SizeF) Method

Scale(SizeF) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > Scale Method : Scale(SizeF) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Scale( _
   ByVal factor As SizeF _
)
public void Scale(
   SizeF factor
)

Parameters

factor
See Also

Reference

Designer Class
Designer Members
Overload List


Scroll Event (Designer)

Scroll Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Scroll Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Scroll As System.Windows.Forms.ScrollEventHandler
public event System.Windows.Forms.ScrollEventHandler Scroll
Event Data

The event handler receives an argument of type System.Windows.Forms.ScrollEventArgs containing data related to this event. The following ScrollEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets or sets the new System.Windows.Forms.ScrollBar.Value of the scroll bar.
OldValue | Gets the old System.Windows.Forms.ScrollBar.Value of the scroll bar.
ScrollOrientation | Gets the scroll bar orientation that raised the Scroll event.
Type | Gets the type of scroll event that occurred.
See Also

Reference

Designer Class
Designer Members


ScrollControlIntoView Method (Designer)

ScrollControlIntoView Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ScrollControlIntoView Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ScrollControlIntoView( _
   ByVal activeControl As System.Windows.Forms.Control _
)
public void ScrollControlIntoView(
   System.Windows.Forms.Control activeControl
)

Parameters

activeControl
See Also

Reference

Designer Class
Designer Members


Select Method (Designer)

Select Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Select Method
Overload List
Overload | Description
Select | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Designer Class
Designer Members


Select() Method

Select() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Select() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Select()
public void Select()
See Also

Reference

Designer Class
Designer Members


SelectNextControl Method (Designer)

SelectNextControl Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SelectNextControl Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function SelectNextControl( _
   ByVal ctl As System.Windows.Forms.Control, _
   ByVal forward As System.Boolean, _
   ByVal tabStopOnly As System.Boolean, _
   ByVal nested As System.Boolean, _
   ByVal wrap As System.Boolean _
) As System.Boolean
public System.bool SelectNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)

Parameters

ctl
forward
tabStopOnly
nested
wrap
See Also

Reference

Designer Class
Designer Members


SendToBack Method (Designer)

SendToBack Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SendToBack Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SendToBack()
public void SendToBack()
See Also

Reference

Designer Class
Designer Members


SetAutoScrollMargin Method (Designer)

SetAutoScrollMargin Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SetAutoScrollMargin Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetAutoScrollMargin( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer _
)
public void SetAutoScrollMargin(
   System.int x,
   System.int y
)

Parameters

x
y
See Also

Reference

Designer Class
Designer Members


SetBounds Method (Designer)

SetBounds Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SetBounds Method
Overload List
Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Designer Class
Designer Members


SetBounds(Int32,Int32,Int32,Int32) Method

SetBounds(Int32,Int32,Int32,Int32) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer _
)
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

x
y
width
height
See Also

Reference

Designer Class
Designer Members
Overload List


SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer, _
   ByVal specified As System.Windows.Forms.BoundsSpecified _
)
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)

Parameters

x
y
width
height
specified
See Also

Reference

Designer Class
Designer Members
Overload List


Show Method (Designer)

Show Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Show Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Show()
public void Show()
See Also

Reference

Designer Class
Designer Members


Site Property (Designer)

Site Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
public virtual System.ComponentModel.ISite Site {get; set;}
See Also

Reference

Designer Class
Designer Members


Size Property (Designer)

Size Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Size Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Size As Size
public Size Size {get; set;}
See Also

Reference

Designer Class
Designer Members


SizeChanged Event (Designer)

SizeChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SizeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event SizeChanged As System.EventHandler
public event System.EventHandler SizeChanged
See Also

Reference

Designer Class
Designer Members


StyleChanged Event (Designer)

StyleChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : StyleChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event StyleChanged As System.EventHandler
public event System.EventHandler StyleChanged
See Also

Reference

Designer Class
Designer Members


SuspendLayout Method (Designer)

SuspendLayout Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SuspendLayout Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SuspendLayout()
public void SuspendLayout()
See Also

Reference

Designer Class
Designer Members


SystemColorsChanged Event (Designer)

SystemColorsChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : SystemColorsChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event SystemColorsChanged As System.EventHandler
public event System.EventHandler SystemColorsChanged
See Also

Reference

Designer Class
Designer Members


TabIndex Property (Designer)

TabIndex Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : TabIndex Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TabIndex As System.Integer
public System.int TabIndex {get; set;}
See Also

Reference

Designer Class
Designer Members


TabIndexChanged Event (Designer)

TabIndexChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : TabIndexChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TabIndexChanged As System.EventHandler
public event System.EventHandler TabIndexChanged
See Also

Reference

Designer Class
Designer Members


TabStop Property (Designer)

TabStop Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : TabStop Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TabStop As System.Boolean
public System.bool TabStop {get; set;}
See Also

Reference

Designer Class
Designer Members


TabStopChanged Event (Designer)

TabStopChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : TabStopChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TabStopChanged As System.EventHandler
public event System.EventHandler TabStopChanged
See Also

Reference

Designer Class
Designer Members


Tag Property (Designer)

Tag Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Tag Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Tag As System.Object
public System.object Tag {get; set;}
See Also

Reference

Designer Class
Designer Members


Top Property (Designer)

Top Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Top Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Top As System.Integer
public System.int Top {get; set;}
See Also

Reference

Designer Class
Designer Members


TopLevelControl Property (Designer)

TopLevelControl Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : TopLevelControl Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TopLevelControl As System.Windows.Forms.Control
public System.Windows.Forms.Control TopLevelControl {get;}
See Also

Reference

Designer Class
Designer Members


ToString Method (Designer)

ToString Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

Designer Class
Designer Members


Update Method (Designer)

Update Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Update Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Update()
public void Update()
See Also

Reference

Designer Class
Designer Members


UseWaitCursor Property (Designer)

UseWaitCursor Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : UseWaitCursor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseWaitCursor As System.Boolean
public System.bool UseWaitCursor {get; set;}
See Also

Reference

Designer Class
Designer Members


Validate Method (Designer)

Validate Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Validate Method
Overload List
Overload | Description
Validate() | (Inherited from System.Windows.Forms.ContainerControl)
Validate(Boolean) | (Inherited from System.Windows.Forms.ContainerControl)
See Also

Reference

Designer Class
Designer Members


Validate() Method

Validate() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > Validate Method : Validate() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Validate() As System.Boolean
public System.bool Validate()
See Also

Reference

Designer Class
Designer Members
Overload List


Validate(Boolean) Method

Validate(Boolean) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > Validate Method : Validate(Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Validate( _
   ByVal checkAutoValidate As System.Boolean _
) As System.Boolean
public System.bool Validate(
   System.bool checkAutoValidate
)

Parameters

checkAutoValidate
See Also

Reference

Designer Class
Designer Members
Overload List


ValidateChildren Method (Designer)

ValidateChildren Method (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : ValidateChildren Method
Overload List
Overload | Description
ValidateChildren() | (Inherited from System.Windows.Forms.UserControl)
ValidateChildren(ValidationConstraints) | (Inherited from System.Windows.Forms.UserControl)
See Also

Reference

Designer Class
Designer Members


ValidateChildren() Method

ValidateChildren() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > ValidateChildren Method : ValidateChildren() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overridable Function ValidateChildren() As System.Boolean
public virtual System.bool ValidateChildren()
See Also

Reference

Designer Class
Designer Members
Overload List


ValidateChildren(ValidationConstraints) Method

ValidateChildren(ValidationConstraints) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class > ValidateChildren Method : ValidateChildren(ValidationConstraints) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overridable Function ValidateChildren( _
   ByVal validationConstraints As System.Windows.Forms.ValidationConstraints _
) As System.Boolean
public virtual System.bool ValidateChildren(
   System.Windows.Forms.ValidationConstraints validationConstraints
)

Parameters

validationConstraints
See Also

Reference

Designer Class
Designer Members
Overload List


Validated Event (Designer)

Validated Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Validated Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Validated As System.EventHandler
public event System.EventHandler Validated
See Also

Reference

Designer Class
Designer Members


Validating Event (Designer)

Validating Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Validating Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Validating As System.ComponentModel.CancelEventHandler
public event System.ComponentModel.CancelEventHandler Validating
Event Data

The event handler receives an argument of type System.ComponentModel.CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |
See Also

Reference

Designer Class
Designer Members


VerticalScroll Property (Designer)

VerticalScroll Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : VerticalScroll Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property VerticalScroll As System.Windows.Forms.VScrollProperties
public System.Windows.Forms.VScrollProperties VerticalScroll {get;}
See Also

Reference

Designer Class
Designer Members


Visible Property (Designer)

Visible Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Visible Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}
See Also

Reference

Designer Class
Designer Members


VisibleChanged Event (Designer)

VisibleChanged Event (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : VisibleChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event VisibleChanged As System.EventHandler
public event System.EventHandler VisibleChanged
See Also

Reference

Designer Class
Designer Members


Width Property (Designer)

Width Property (Designer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > Designer Class : Width Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As System.Integer
public System.int Width {get; set;}
See Also

Reference

Designer Class
Designer Members


LayerList Class Methods

LayerList Class Methods

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace : LayerList Class

For a list of all members of this type, see LayerList members.

Public Methods
 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top
See Also

Reference

LayerList Class
GrapeCity.ActiveReports.Design Namespace


AccessibilityObject Property (LayerList)

AccessibilityObject Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AccessibilityObject Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property AccessibilityObject As System.Windows.Forms.AccessibleObject
public System.Windows.Forms.AccessibleObject AccessibilityObject {get;}
See Also

Reference

LayerList Class
LayerList Members


AccessibleDefaultActionDescription Property (LayerList)

AccessibleDefaultActionDescription Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AccessibleDefaultActionDescription Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AccessibleDefaultActionDescription As System.String
public System.string AccessibleDefaultActionDescription {get; set;}
See Also

Reference

LayerList Class
LayerList Members


AccessibleDescription Property (LayerList)

AccessibleDescription Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AccessibleDescription Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AccessibleDescription As System.String
public System.string AccessibleDescription {get; set;}
See Also

Reference

LayerList Class
LayerList Members


AccessibleName Property (LayerList)

AccessibleName Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AccessibleName Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AccessibleName As System.String
public System.string AccessibleName {get; set;}
See Also

Reference

LayerList Class
LayerList Members


AccessibleRole Property (LayerList)

AccessibleRole Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AccessibleRole Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AccessibleRole As System.Windows.Forms.AccessibleRole
public System.Windows.Forms.AccessibleRole AccessibleRole {get; set;}
See Also

Reference

LayerList Class
LayerList Members


ActiveControl Property (LayerList)

ActiveControl Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ActiveControl Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ActiveControl As System.Windows.Forms.Control
public System.Windows.Forms.Control ActiveControl {get; set;}
See Also

Reference

LayerList Class
LayerList Members


AllowDrop Property (LayerList)

AllowDrop Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AllowDrop Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AllowDrop As System.Boolean
public System.bool AllowDrop {get; set;}
See Also

Reference

LayerList Class
LayerList Members


Anchor Property (LayerList)

Anchor Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Anchor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Anchor As System.Windows.Forms.AnchorStyles
public System.Windows.Forms.AnchorStyles Anchor {get; set;}
See Also

Reference

LayerList Class
LayerList Members


AutoScaleDimensions Property (LayerList)

AutoScaleDimensions Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AutoScaleDimensions Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScaleDimensions As SizeF
public SizeF AutoScaleDimensions {get; set;}
See Also

Reference

LayerList Class
LayerList Members


AutoScaleMode Property (LayerList)

AutoScaleMode Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AutoScaleMode Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScaleMode As System.Windows.Forms.AutoScaleMode
public System.Windows.Forms.AutoScaleMode AutoScaleMode {get; set;}
See Also

Reference

LayerList Class
LayerList Members


AutoScroll Property (LayerList)

AutoScroll Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AutoScroll Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScroll As System.Boolean
public System.bool AutoScroll {get; set;}
See Also

Reference

LayerList Class
LayerList Members


AutoScrollMargin Property (LayerList)

AutoScrollMargin Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AutoScrollMargin Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScrollMargin As Size
public Size AutoScrollMargin {get; set;}
See Also

Reference

LayerList Class
LayerList Members


AutoScrollMinSize Property (LayerList)

AutoScrollMinSize Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AutoScrollMinSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScrollMinSize As Size
public Size AutoScrollMinSize {get; set;}
See Also

Reference

LayerList Class
LayerList Members


AutoScrollOffset Property (LayerList)

AutoScrollOffset Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AutoScrollOffset Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScrollOffset As Point
public Point AutoScrollOffset {get; set;}
See Also

Reference

LayerList Class
LayerList Members


AutoScrollPosition Property (LayerList)

AutoScrollPosition Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AutoScrollPosition Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScrollPosition As Point
public Point AutoScrollPosition {get; set;}
See Also

Reference

LayerList Class
LayerList Members


AutoSize Property (LayerList)

AutoSize Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AutoSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoSize As System.Boolean
public System.bool AutoSize {get; set;}
See Also

Reference

LayerList Class
LayerList Members


AutoSizeChanged Event (LayerList)

AutoSizeChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AutoSizeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event AutoSizeChanged As System.EventHandler
public event System.EventHandler AutoSizeChanged
See Also

Reference

LayerList Class
LayerList Members


AutoSizeMode Property (LayerList)

AutoSizeMode Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AutoSizeMode Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoSizeMode As System.Windows.Forms.AutoSizeMode
public System.Windows.Forms.AutoSizeMode AutoSizeMode {get; set;}
See Also

Reference

LayerList Class
LayerList Members


AutoValidate Property (LayerList)

AutoValidate Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AutoValidate Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoValidate As System.Windows.Forms.AutoValidate
public System.Windows.Forms.AutoValidate AutoValidate {get; set;}
See Also

Reference

LayerList Class
LayerList Members


AutoValidateChanged Event (LayerList)

AutoValidateChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : AutoValidateChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event AutoValidateChanged As System.EventHandler
public event System.EventHandler AutoValidateChanged
See Also

Reference

LayerList Class
LayerList Members


BackColor Property (LayerList)

BackColor Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : BackColor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackColor As Color
public Color BackColor {get; set;}
See Also

Reference

LayerList Class
LayerList Members


BackColorChanged Event (LayerList)

BackColorChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : BackColorChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BackColorChanged As System.EventHandler
public event System.EventHandler BackColorChanged
See Also

Reference

LayerList Class
LayerList Members


BackgroundImage Property (LayerList)

BackgroundImage Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : BackgroundImage Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackgroundImage As Image
public Image BackgroundImage {get; set;}
See Also

Reference

LayerList Class
LayerList Members


BackgroundImageChanged Event (LayerList)

BackgroundImageChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : BackgroundImageChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BackgroundImageChanged As System.EventHandler
public event System.EventHandler BackgroundImageChanged
See Also

Reference

LayerList Class
LayerList Members


BackgroundImageLayout Property (LayerList)

BackgroundImageLayout Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : BackgroundImageLayout Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackgroundImageLayout As System.Windows.Forms.ImageLayout
public System.Windows.Forms.ImageLayout BackgroundImageLayout {get; set;}
See Also

Reference

LayerList Class
LayerList Members


BackgroundImageLayoutChanged Event (LayerList)

BackgroundImageLayoutChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : BackgroundImageLayoutChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BackgroundImageLayoutChanged As System.EventHandler
public event System.EventHandler BackgroundImageLayoutChanged
See Also

Reference

LayerList Class
LayerList Members


BeginInvoke Method (LayerList)

BeginInvoke Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : BeginInvoke Method
Overload List
Overload | Description
BeginInvoke(Delegate) | (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

LayerList Class
LayerList Members


BeginInvoke(Delegate) Method

BeginInvoke(Delegate) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > BeginInvoke Method : BeginInvoke(Delegate) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function BeginInvoke( _
   ByVal method As System.Delegate _
) As System.IAsyncResult
public System.IAsyncResult BeginInvoke(
   System.Delegate method
)

Parameters

method
See Also

Reference

LayerList Class
LayerList Members
Overload List


BeginInvoke(Delegate,Object[]) Method

BeginInvoke(Delegate,Object[]) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function BeginInvoke( _
   ByVal method As System.Delegate, _
   ByVal ParamArray args() As System.Object _
) As System.IAsyncResult
public System.IAsyncResult BeginInvoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
args
See Also

Reference

LayerList Class
LayerList Members
Overload List


BindingContext Property (LayerList)

BindingContext Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : BindingContext Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BindingContext As System.Windows.Forms.BindingContext
public System.Windows.Forms.BindingContext BindingContext {get; set;}
See Also

Reference

LayerList Class
LayerList Members


BindingContextChanged Event (LayerList)

BindingContextChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : BindingContextChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BindingContextChanged As System.EventHandler
public event System.EventHandler BindingContextChanged
See Also

Reference

LayerList Class
LayerList Members


BorderStyle Property (LayerList)

BorderStyle Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : BorderStyle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BorderStyle As System.Windows.Forms.BorderStyle
public System.Windows.Forms.BorderStyle BorderStyle {get; set;}
See Also

Reference

LayerList Class
LayerList Members


Bottom Property (LayerList)

Bottom Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Bottom Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Bottom As System.Integer
public System.int Bottom {get;}
See Also

Reference

LayerList Class
LayerList Members


Bounds Property (LayerList)

Bounds Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Bounds Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Bounds As Rectangle
public Rectangle Bounds {get; set;}
See Also

Reference

LayerList Class
LayerList Members


BringToFront Method (LayerList)

BringToFront Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : BringToFront Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub BringToFront()
public void BringToFront()
See Also

Reference

LayerList Class
LayerList Members


CanFocus Property (LayerList)

CanFocus Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : CanFocus Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CanFocus As System.Boolean
public System.bool CanFocus {get;}
See Also

Reference

LayerList Class
LayerList Members


CanSelect Property (LayerList)

CanSelect Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : CanSelect Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CanSelect As System.Boolean
public System.bool CanSelect {get;}
See Also

Reference

LayerList Class
LayerList Members


Capture Property (LayerList)

Capture Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Capture Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capture As System.Boolean
public System.bool Capture {get; set;}
See Also

Reference

LayerList Class
LayerList Members


CausesValidation Property (LayerList)

CausesValidation Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : CausesValidation Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CausesValidation As System.Boolean
public System.bool CausesValidation {get; set;}
See Also

Reference

LayerList Class
LayerList Members


CausesValidationChanged Event (LayerList)

CausesValidationChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : CausesValidationChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event CausesValidationChanged As System.EventHandler
public event System.EventHandler CausesValidationChanged
See Also

Reference

LayerList Class
LayerList Members


ChangeUICues Event (LayerList)

ChangeUICues Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ChangeUICues Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ChangeUICues As System.Windows.Forms.UICuesEventHandler
public event System.Windows.Forms.UICuesEventHandler ChangeUICues
Event Data

The event handler receives an argument of type System.Windows.Forms.UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.
See Also

Reference

LayerList Class
LayerList Members


Click Event (LayerList)

Click Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Click Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Click As System.EventHandler
public event System.EventHandler Click
See Also

Reference

LayerList Class
LayerList Members


ClientRectangle Property (LayerList)

ClientRectangle Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ClientRectangle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ClientRectangle As Rectangle
public Rectangle ClientRectangle {get;}
See Also

Reference

LayerList Class
LayerList Members


ClientSize Property (LayerList)

ClientSize Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ClientSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ClientSize As Size
public Size ClientSize {get; set;}
See Also

Reference

LayerList Class
LayerList Members


ClientSizeChanged Event (LayerList)

ClientSizeChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ClientSizeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ClientSizeChanged As System.EventHandler
public event System.EventHandler ClientSizeChanged
See Also

Reference

LayerList Class
LayerList Members


CompanyName Property (LayerList)

CompanyName Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : CompanyName Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CompanyName As System.String
public System.string CompanyName {get;}
See Also

Reference

LayerList Class
LayerList Members


Container Property (LayerList)

Container Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

LayerList Class
LayerList Members


Contains Method (LayerList)

Contains Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Contains Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal ctl As System.Windows.Forms.Control _
) As System.Boolean
public System.bool Contains(
   System.Windows.Forms.Control ctl
)

Parameters

ctl
See Also

Reference

LayerList Class
LayerList Members


ContainsFocus Property (LayerList)

ContainsFocus Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ContainsFocus Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ContainsFocus As System.Boolean
public System.bool ContainsFocus {get;}
See Also

Reference

LayerList Class
LayerList Members


ContextMenu Property (LayerList)

ContextMenu Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ContextMenu Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ContextMenu As System.Windows.Forms.ContextMenu
public System.Windows.Forms.ContextMenu ContextMenu {get; set;}
See Also

Reference

LayerList Class
LayerList Members


ContextMenuChanged Event (LayerList)

ContextMenuChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ContextMenuChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ContextMenuChanged As System.EventHandler
public event System.EventHandler ContextMenuChanged
See Also

Reference

LayerList Class
LayerList Members


ContextMenuStrip Property (LayerList)

ContextMenuStrip Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ContextMenuStrip Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ContextMenuStrip As System.Windows.Forms.ContextMenuStrip
public System.Windows.Forms.ContextMenuStrip ContextMenuStrip {get; set;}
See Also

Reference

LayerList Class
LayerList Members


ContextMenuStripChanged Event (LayerList)

ContextMenuStripChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ContextMenuStripChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ContextMenuStripChanged As System.EventHandler
public event System.EventHandler ContextMenuStripChanged
See Also

Reference

LayerList Class
LayerList Members


ControlAdded Event (LayerList)

ControlAdded Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ControlAdded Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ControlAdded As System.Windows.Forms.ControlEventHandler
public event System.Windows.Forms.ControlEventHandler ControlAdded
Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.
See Also

Reference

LayerList Class
LayerList Members


ControlRemoved Event (LayerList)

ControlRemoved Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ControlRemoved Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ControlRemoved As System.Windows.Forms.ControlEventHandler
public event System.Windows.Forms.ControlEventHandler ControlRemoved
Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.
See Also

Reference

LayerList Class
LayerList Members


Controls Property (LayerList)

Controls Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Controls Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Controls As System.Windows.Forms.Control.ControlCollection
public System.Windows.Forms.Control.ControlCollection Controls {get;}
See Also

Reference

LayerList Class
LayerList Members


CreateControl Method (LayerList)

CreateControl Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : CreateControl Method
Overload List
Overload | Description
CreateControl | (Inherited from System.Windows.Forms.Control)
See Also

Reference

LayerList Class
LayerList Members


CreateControl() Method

CreateControl() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : CreateControl() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CreateControl()
public void CreateControl()
See Also

Reference

LayerList Class
LayerList Members


Created Property (LayerList)

Created Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Created Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Created As System.Boolean
public System.bool Created {get;}
See Also

Reference

LayerList Class
LayerList Members


CreateGraphics Method (LayerList)

CreateGraphics Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : CreateGraphics Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateGraphics() As Graphics
public Graphics CreateGraphics()
See Also

Reference

LayerList Class
LayerList Members


CreateObjRef Method (LayerList)

CreateObjRef Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

LayerList Class
LayerList Members


CurrentAutoScaleDimensions Property (LayerList)

CurrentAutoScaleDimensions Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : CurrentAutoScaleDimensions Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CurrentAutoScaleDimensions As SizeF
public SizeF CurrentAutoScaleDimensions {get;}
See Also

Reference

LayerList Class
LayerList Members


Cursor Property (LayerList)

Cursor Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Cursor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Cursor As System.Windows.Forms.Cursor
public System.Windows.Forms.Cursor Cursor {get; set;}
See Also

Reference

LayerList Class
LayerList Members


CursorChanged Event (LayerList)

CursorChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : CursorChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event CursorChanged As System.EventHandler
public event System.EventHandler CursorChanged
See Also

Reference

LayerList Class
LayerList Members


DataBindings Property (LayerList)

DataBindings Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : DataBindings Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DataBindings As System.Windows.Forms.ControlBindingsCollection
public System.Windows.Forms.ControlBindingsCollection DataBindings {get;}
See Also

Reference

LayerList Class
LayerList Members


DisplayRectangle Property (LayerList)

DisplayRectangle Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : DisplayRectangle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DisplayRectangle As Rectangle
public Rectangle DisplayRectangle {get;}
See Also

Reference

LayerList Class
LayerList Members


Dispose Method (LayerList)

Dispose Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

LayerList Class
LayerList Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

LayerList Class
LayerList Members


Disposed Event (LayerList)

Disposed Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

LayerList Class
LayerList Members


Disposing Property (LayerList)

Disposing Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Disposing Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Disposing As System.Boolean
public System.bool Disposing {get;}
See Also

Reference

LayerList Class
LayerList Members


Dock Property (LayerList)

Dock Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Dock Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Dock As System.Windows.Forms.DockStyle
public System.Windows.Forms.DockStyle Dock {get; set;}
See Also

Reference

LayerList Class
LayerList Members


DockChanged Event (LayerList)

DockChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : DockChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DockChanged As System.EventHandler
public event System.EventHandler DockChanged
See Also

Reference

LayerList Class
LayerList Members


DoDragDrop Method (LayerList)

DoDragDrop Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : DoDragDrop Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function DoDragDrop( _
   ByVal data As System.Object, _
   ByVal allowedEffects As System.Windows.Forms.DragDropEffects _
) As System.Windows.Forms.DragDropEffects
public System.Windows.Forms.DragDropEffects DoDragDrop(
   System.object data,
   System.Windows.Forms.DragDropEffects allowedEffects
)

Parameters

data
allowedEffects
See Also

Reference

LayerList Class
LayerList Members


DoubleClick Event (LayerList)

DoubleClick Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : DoubleClick Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DoubleClick As System.EventHandler
public event System.EventHandler DoubleClick
See Also

Reference

LayerList Class
LayerList Members


DragDrop Event (LayerList)

DragDrop Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : DragDrop Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragDrop As System.Windows.Forms.DragEventHandler
public event System.Windows.Forms.DragEventHandler DragDrop
Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.
See Also

Reference

LayerList Class
LayerList Members


DragEnter Event (LayerList)

DragEnter Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : DragEnter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragEnter As System.Windows.Forms.DragEventHandler
public event System.Windows.Forms.DragEventHandler DragEnter
Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.
See Also

Reference

LayerList Class
LayerList Members


DragLeave Event (LayerList)

DragLeave Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : DragLeave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragLeave As System.EventHandler
public event System.EventHandler DragLeave
See Also

Reference

LayerList Class
LayerList Members


DragOver Event (LayerList)

DragOver Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : DragOver Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragOver As System.Windows.Forms.DragEventHandler
public event System.Windows.Forms.DragEventHandler DragOver
Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.
See Also

Reference

LayerList Class
LayerList Members


DrawToBitmap Method (LayerList)

DrawToBitmap Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : DrawToBitmap Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub DrawToBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal targetBounds As Rectangle _
)
public void DrawToBitmap(
   Bitmap bitmap,
   Rectangle targetBounds
)

Parameters

bitmap
targetBounds
See Also

Reference

LayerList Class
LayerList Members


Enabled Property (LayerList)

Enabled Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Enabled Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Enabled As System.Boolean
public System.bool Enabled {get; set;}
See Also

Reference

LayerList Class
LayerList Members


EnabledChanged Event (LayerList)

EnabledChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : EnabledChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event EnabledChanged As System.EventHandler
public event System.EventHandler EnabledChanged
See Also

Reference

LayerList Class
LayerList Members


EndInvoke Method (LayerList)

EndInvoke Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : EndInvoke Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function EndInvoke( _
   ByVal asyncResult As System.IAsyncResult _
) As System.Object
public System.object EndInvoke(
   System.IAsyncResult asyncResult
)

Parameters

asyncResult
See Also

Reference

LayerList Class
LayerList Members


Enter Event (LayerList)

Enter Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Enter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Enter As System.EventHandler
public event System.EventHandler Enter
See Also

Reference

LayerList Class
LayerList Members


FindForm Method (LayerList)

FindForm Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : FindForm Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function FindForm() As System.Windows.Forms.Form
public System.Windows.Forms.Form FindForm()
See Also

Reference

LayerList Class
LayerList Members


Focus Method (LayerList)

Focus Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Focus Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Focus() As System.Boolean
public System.bool Focus()
See Also

Reference

LayerList Class
LayerList Members


Focused Property (LayerList)

Focused Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Focused Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Focused As System.Boolean
public System.bool Focused {get;}
See Also

Reference

LayerList Class
LayerList Members


Font Property (LayerList)

Font Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Font Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Font As Font
public Font Font {get; set;}
See Also

Reference

LayerList Class
LayerList Members


FontChanged Event (LayerList)

FontChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : FontChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event FontChanged As System.EventHandler
public event System.EventHandler FontChanged
See Also

Reference

LayerList Class
LayerList Members


ForeColor Property (LayerList)

ForeColor Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ForeColor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ForeColor As Color
public Color ForeColor {get; set;}
See Also

Reference

LayerList Class
LayerList Members


ForeColorChanged Event (LayerList)

ForeColorChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ForeColorChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ForeColorChanged As System.EventHandler
public event System.EventHandler ForeColorChanged
See Also

Reference

LayerList Class
LayerList Members


GetChildAtPoint Method (LayerList)

GetChildAtPoint Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : GetChildAtPoint Method
Overload List
Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

LayerList Class
LayerList Members


GetChildAtPoint(Point) Method

GetChildAtPoint(Point) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point _
) As System.Windows.Forms.Control
public System.Windows.Forms.Control GetChildAtPoint(
   Point pt
)

Parameters

pt
See Also

Reference

LayerList Class
LayerList Members
Overload List


GetChildAtPoint(Point,GetChildAtPointSkip) Method

GetChildAtPoint(Point,GetChildAtPointSkip) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point, _
   ByVal skipValue As System.Windows.Forms.GetChildAtPointSkip _
) As System.Windows.Forms.Control
public System.Windows.Forms.Control GetChildAtPoint(
   Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)

Parameters

pt
skipValue
See Also

Reference

LayerList Class
LayerList Members
Overload List


GetContainerControl Method (LayerList)

GetContainerControl Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : GetContainerControl Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetContainerControl() As System.Windows.Forms.IContainerControl
public System.Windows.Forms.IContainerControl GetContainerControl()
See Also

Reference

LayerList Class
LayerList Members


GetLifetimeService Method (LayerList)

GetLifetimeService Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

LayerList Class
LayerList Members


GetNextControl Method (LayerList)

GetNextControl Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : GetNextControl Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetNextControl( _
   ByVal ctl As System.Windows.Forms.Control, _
   ByVal forward As System.Boolean _
) As System.Windows.Forms.Control
public System.Windows.Forms.Control GetNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward
)

Parameters

ctl
forward
See Also

Reference

LayerList Class
LayerList Members


GetPreferredSize Method (LayerList)

GetPreferredSize Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : GetPreferredSize Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetPreferredSize( _
   ByVal proposedSize As Size _
) As Size
public Size GetPreferredSize(
   Size proposedSize
)

Parameters

proposedSize
See Also

Reference

LayerList Class
LayerList Members


GiveFeedback Event (LayerList)

GiveFeedback Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : GiveFeedback Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event GiveFeedback As System.Windows.Forms.GiveFeedbackEventHandler
public event System.Windows.Forms.GiveFeedbackEventHandler GiveFeedback
Event Data

The event handler receives an argument of type System.Windows.Forms.GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.
See Also

Reference

LayerList Class
LayerList Members


GotFocus Event (LayerList)

GotFocus Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : GotFocus Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event GotFocus As System.EventHandler
public event System.EventHandler GotFocus
See Also

Reference

LayerList Class
LayerList Members


Handle Property (LayerList)

Handle Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Handle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Handle As System.IntPtr
public System.IntPtr Handle {get;}
See Also

Reference

LayerList Class
LayerList Members


HandleCreated Event (LayerList)

HandleCreated Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : HandleCreated Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event HandleCreated As System.EventHandler
public event System.EventHandler HandleCreated
See Also

Reference

LayerList Class
LayerList Members


HandleDestroyed Event (LayerList)

HandleDestroyed Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : HandleDestroyed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event HandleDestroyed As System.EventHandler
public event System.EventHandler HandleDestroyed
See Also

Reference

LayerList Class
LayerList Members


HasChildren Property (LayerList)

HasChildren Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : HasChildren Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HasChildren As System.Boolean
public System.bool HasChildren {get;}
See Also

Reference

LayerList Class
LayerList Members


Height Property (LayerList)

Height Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Height Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As System.Integer
public System.int Height {get; set;}
See Also

Reference

LayerList Class
LayerList Members


HelpRequested Event (LayerList)

HelpRequested Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : HelpRequested Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event HelpRequested As System.Windows.Forms.HelpEventHandler
public event System.Windows.Forms.HelpEventHandler HelpRequested
Event Data

The event handler receives an argument of type System.Windows.Forms.HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.
See Also

Reference

LayerList Class
LayerList Members


Hide Method (LayerList)

Hide Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Hide Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Hide()
public void Hide()
See Also

Reference

LayerList Class
LayerList Members


HorizontalScroll Property (LayerList)

HorizontalScroll Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : HorizontalScroll Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HorizontalScroll As System.Windows.Forms.HScrollProperties
public System.Windows.Forms.HScrollProperties HorizontalScroll {get;}
See Also

Reference

LayerList Class
LayerList Members


ImeMode Property (LayerList)

ImeMode Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ImeMode Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ImeMode As System.Windows.Forms.ImeMode
public System.Windows.Forms.ImeMode ImeMode {get; set;}
See Also

Reference

LayerList Class
LayerList Members


ImeModeChanged Event (LayerList)

ImeModeChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ImeModeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ImeModeChanged As System.EventHandler
public event System.EventHandler ImeModeChanged
See Also

Reference

LayerList Class
LayerList Members


InitializeLifetimeService Method (LayerList)

InitializeLifetimeService Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

LayerList Class
LayerList Members


Invalidate Method (LayerList)

Invalidate Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Invalidate Method
Overload List
Overload | Description
Invalidate(Region) | (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | (Inherited from System.Windows.Forms.Control)
Invalidate() | (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

LayerList Class
LayerList Members


Invalidate() Method

Invalidate() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > Invalidate Method : Invalidate() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate()
public void Invalidate()
See Also

Reference

LayerList Class
LayerList Members
Overload List


Invalidate(Boolean) Method

Invalidate(Boolean) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > Invalidate Method : Invalidate(Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal invalidateChildren As System.Boolean _
)
public void Invalidate(
   System.bool invalidateChildren
)

Parameters

invalidateChildren
See Also

Reference

LayerList Class
LayerList Members
Overload List


Invalidate(Rectangle) Method

Invalidate(Rectangle) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > Invalidate Method : Invalidate(Rectangle) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle _
)
public void Invalidate(
   Rectangle rc
)

Parameters

rc
See Also

Reference

LayerList Class
LayerList Members
Overload List


Invalidate(Rectangle,Boolean) Method

Invalidate(Rectangle,Boolean) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle, _
   ByVal invalidateChildren As System.Boolean _
)
public void Invalidate(
   Rectangle rc,
   System.bool invalidateChildren
)

Parameters

rc
invalidateChildren
See Also

Reference

LayerList Class
LayerList Members
Overload List


Invalidate(Region) Method

Invalidate(Region) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > Invalidate Method : Invalidate(Region) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal region As Region _
)
public void Invalidate(
   Region region
)

Parameters

region
See Also

Reference

LayerList Class
LayerList Members
Overload List


Invalidate(Region,Boolean) Method

Invalidate(Region,Boolean) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > Invalidate Method : Invalidate(Region,Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal region As Region, _
   ByVal invalidateChildren As System.Boolean _
)
public void Invalidate(
   Region region,
   System.bool invalidateChildren
)

Parameters

region
invalidateChildren
See Also

Reference

LayerList Class
LayerList Members
Overload List


Invalidated Event (LayerList)

Invalidated Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Invalidated Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Invalidated As System.Windows.Forms.InvalidateEventHandler
public event System.Windows.Forms.InvalidateEventHandler Invalidated
Event Data

The event handler receives an argument of type System.Windows.Forms.InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.
See Also

Reference

LayerList Class
LayerList Members


Invoke Method (LayerList)

Invoke Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Invoke Method
Overload List
Overload | Description
Invoke(Delegate) | (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

LayerList Class
LayerList Members


Invoke(Delegate) Method

Invoke(Delegate) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > Invoke Method : Invoke(Delegate) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Invoke( _
   ByVal method As System.Delegate _
) As System.Object
public System.object Invoke(
   System.Delegate method
)

Parameters

method
See Also

Reference

LayerList Class
LayerList Members
Overload List


Invoke(Delegate,Object[]) Method

Invoke(Delegate,Object[]) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > Invoke Method : Invoke(Delegate,Object[]) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Invoke( _
   ByVal method As System.Delegate, _
   ByVal ParamArray args() As System.Object _
) As System.Object
public System.object Invoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
args
See Also

Reference

LayerList Class
LayerList Members
Overload List


InvokeRequired Property (LayerList)

InvokeRequired Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : InvokeRequired Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InvokeRequired As System.Boolean
public System.bool InvokeRequired {get;}
See Also

Reference

LayerList Class
LayerList Members


IsAccessible Property (LayerList)

IsAccessible Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : IsAccessible Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsAccessible As System.Boolean
public System.bool IsAccessible {get; set;}
See Also

Reference

LayerList Class
LayerList Members


IsDisposed Property (LayerList)

IsDisposed Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : IsDisposed Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsDisposed As System.Boolean
public System.bool IsDisposed {get;}
See Also

Reference

LayerList Class
LayerList Members


IsHandleCreated Property (LayerList)

IsHandleCreated Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : IsHandleCreated Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsHandleCreated As System.Boolean
public System.bool IsHandleCreated {get;}
See Also

Reference

LayerList Class
LayerList Members


IsMirrored Property (LayerList)

IsMirrored Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : IsMirrored Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsMirrored As System.Boolean
public System.bool IsMirrored {get;}
See Also

Reference

LayerList Class
LayerList Members


KeyDown Event (LayerList)

KeyDown Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : KeyDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event KeyDown As System.Windows.Forms.KeyEventHandler
public event System.Windows.Forms.KeyEventHandler KeyDown
Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.
See Also

Reference

LayerList Class
LayerList Members


KeyPress Event (LayerList)

KeyPress Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : KeyPress Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event KeyPress As System.Windows.Forms.KeyPressEventHandler
public event System.Windows.Forms.KeyPressEventHandler KeyPress
Event Data

The event handler receives an argument of type System.Windows.Forms.KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.
See Also

Reference

LayerList Class
LayerList Members


KeyUp Event (LayerList)

KeyUp Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : KeyUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event KeyUp As System.Windows.Forms.KeyEventHandler
public event System.Windows.Forms.KeyEventHandler KeyUp
Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.
See Also

Reference

LayerList Class
LayerList Members


Layout Event (LayerList)

Layout Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Layout Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Layout As System.Windows.Forms.LayoutEventHandler
public event System.Windows.Forms.LayoutEventHandler Layout
Event Data

The event handler receives an argument of type System.Windows.Forms.LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.
See Also

Reference

LayerList Class
LayerList Members


LayoutEngine Property (LayerList)

LayoutEngine Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : LayoutEngine Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property LayoutEngine As System.Windows.Forms.Layout.LayoutEngine
public System.Windows.Forms.Layout.LayoutEngine LayoutEngine {get;}
See Also

Reference

LayerList Class
LayerList Members


Leave Event (LayerList)

Leave Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Leave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Leave As System.EventHandler
public event System.EventHandler Leave
See Also

Reference

LayerList Class
LayerList Members


Left Property (LayerList)

Left Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Left Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Left As System.Integer
public System.int Left {get; set;}
See Also

Reference

LayerList Class
LayerList Members


Load Event (LayerList)

Load Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Load Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Load As System.EventHandler
public event System.EventHandler Load
See Also

Reference

LayerList Class
LayerList Members


Location Property (LayerList)

Location Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Location Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Location As Point
public Point Location {get; set;}
See Also

Reference

LayerList Class
LayerList Members


LocationChanged Event (LayerList)

LocationChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : LocationChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LocationChanged As System.EventHandler
public event System.EventHandler LocationChanged
See Also

Reference

LayerList Class
LayerList Members


LostFocus Event (LayerList)

LostFocus Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : LostFocus Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LostFocus As System.EventHandler
public event System.EventHandler LostFocus
See Also

Reference

LayerList Class
LayerList Members


Margin Property (LayerList)

Margin Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Margin Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Margin As System.Windows.Forms.Padding
public System.Windows.Forms.Padding Margin {get; set;}
See Also

Reference

LayerList Class
LayerList Members


MarginChanged Event (LayerList)

MarginChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MarginChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MarginChanged As System.EventHandler
public event System.EventHandler MarginChanged
See Also

Reference

LayerList Class
LayerList Members


MaximumSize Property (LayerList)

MaximumSize Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MaximumSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaximumSize As Size
public Size MaximumSize {get; set;}
See Also

Reference

LayerList Class
LayerList Members


MinimumSize Property (LayerList)

MinimumSize Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MinimumSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinimumSize As Size
public Size MinimumSize {get; set;}
See Also

Reference

LayerList Class
LayerList Members


MouseCaptureChanged Event (LayerList)

MouseCaptureChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MouseCaptureChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseCaptureChanged As System.EventHandler
public event System.EventHandler MouseCaptureChanged
See Also

Reference

LayerList Class
LayerList Members


MouseClick Event (LayerList)

MouseClick Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MouseClick Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseClick As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseClick
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

LayerList Class
LayerList Members


MouseDoubleClick Event (LayerList)

MouseDoubleClick Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MouseDoubleClick Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseDoubleClick As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseDoubleClick
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

LayerList Class
LayerList Members


MouseDown Event (LayerList)

MouseDown Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MouseDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseDown As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseDown
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

LayerList Class
LayerList Members


MouseEnter Event (LayerList)

MouseEnter Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MouseEnter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseEnter As System.EventHandler
public event System.EventHandler MouseEnter
See Also

Reference

LayerList Class
LayerList Members


MouseHover Event (LayerList)

MouseHover Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MouseHover Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseHover As System.EventHandler
public event System.EventHandler MouseHover
See Also

Reference

LayerList Class
LayerList Members


MouseLeave Event (LayerList)

MouseLeave Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MouseLeave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseLeave As System.EventHandler
public event System.EventHandler MouseLeave
See Also

Reference

LayerList Class
LayerList Members


MouseMove Event (LayerList)

MouseMove Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MouseMove Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseMove As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseMove
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

LayerList Class
LayerList Members


MouseUp Event (LayerList)

MouseUp Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MouseUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseUp As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseUp
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

LayerList Class
LayerList Members


MouseWheel Event (LayerList)

MouseWheel Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : MouseWheel Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseWheel As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseWheel
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

LayerList Class
LayerList Members


Move Event (LayerList)

Move Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Move Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Move As System.EventHandler
public event System.EventHandler Move
See Also

Reference

LayerList Class
LayerList Members


Name Property (LayerList)

Name Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Name Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}
See Also

Reference

LayerList Class
LayerList Members


Padding Property (LayerList)

Padding Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Padding Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Padding As System.Windows.Forms.Padding
public System.Windows.Forms.Padding Padding {get; set;}
See Also

Reference

LayerList Class
LayerList Members


PaddingChanged Event (LayerList)

PaddingChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : PaddingChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PaddingChanged As System.EventHandler
public event System.EventHandler PaddingChanged
See Also

Reference

LayerList Class
LayerList Members


Paint Event (LayerList)

Paint Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Paint Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Paint As System.Windows.Forms.PaintEventHandler
public event System.Windows.Forms.PaintEventHandler Paint
Event Data

The event handler receives an argument of type System.Windows.Forms.PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.
See Also

Reference

LayerList Class
LayerList Members


Parent Property (LayerList)

Parent Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Parent Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Parent As System.Windows.Forms.Control
public System.Windows.Forms.Control Parent {get; set;}
See Also

Reference

LayerList Class
LayerList Members


ParentChanged Event (LayerList)

ParentChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ParentChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ParentChanged As System.EventHandler
public event System.EventHandler ParentChanged
See Also

Reference

LayerList Class
LayerList Members


ParentForm Property (LayerList)

ParentForm Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ParentForm Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ParentForm As System.Windows.Forms.Form
public System.Windows.Forms.Form ParentForm {get;}
See Also

Reference

LayerList Class
LayerList Members


PerformAutoScale Method (LayerList)

PerformAutoScale Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : PerformAutoScale Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub PerformAutoScale()
public void PerformAutoScale()
See Also

Reference

LayerList Class
LayerList Members


PerformLayout Method (LayerList)

PerformLayout Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : PerformLayout Method
Overload List
Overload | Description
PerformLayout() | (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

LayerList Class
LayerList Members


PerformLayout() Method

PerformLayout() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > PerformLayout Method : PerformLayout() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub PerformLayout()
public void PerformLayout()
See Also

Reference

LayerList Class
LayerList Members
Overload List


PerformLayout(Control,String) Method

PerformLayout(Control,String) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > PerformLayout Method : PerformLayout(Control,String) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub PerformLayout( _
   ByVal affectedControl As System.Windows.Forms.Control, _
   ByVal affectedProperty As System.String _
)
public void PerformLayout(
   System.Windows.Forms.Control affectedControl,
   System.string affectedProperty
)

Parameters

affectedControl
affectedProperty
See Also

Reference

LayerList Class
LayerList Members
Overload List


PointToClient Method (LayerList)

PointToClient Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : PointToClient Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PointToClient( _
   ByVal p As Point _
) As Point
public Point PointToClient(
   Point p
)

Parameters

p
See Also

Reference

LayerList Class
LayerList Members


PointToScreen Method (LayerList)

PointToScreen Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : PointToScreen Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PointToScreen( _
   ByVal p As Point _
) As Point
public Point PointToScreen(
   Point p
)

Parameters

p
See Also

Reference

LayerList Class
LayerList Members


PreferredSize Property (LayerList)

PreferredSize Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : PreferredSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PreferredSize As Size
public Size PreferredSize {get;}
See Also

Reference

LayerList Class
LayerList Members


PreProcessControlMessage Method (LayerList)

PreProcessControlMessage Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : PreProcessControlMessage Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PreProcessControlMessage( _
   ByRef msg As System.Windows.Forms.Message _
) As System.Windows.Forms.PreProcessControlState
public System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
See Also

Reference

LayerList Class
LayerList Members


PreProcessMessage Method (LayerList)

PreProcessMessage Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : PreProcessMessage Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PreProcessMessage( _
   ByRef msg As System.Windows.Forms.Message _
) As System.Boolean
public System.bool PreProcessMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
See Also

Reference

LayerList Class
LayerList Members


PreviewKeyDown Event (LayerList)

PreviewKeyDown Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : PreviewKeyDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewKeyDown As System.Windows.Forms.PreviewKeyDownEventHandler
public event System.Windows.Forms.PreviewKeyDownEventHandler PreviewKeyDown
Event Data

The event handler receives an argument of type System.Windows.Forms.PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.
See Also

Reference

LayerList Class
LayerList Members


ProductName Property (LayerList)

ProductName Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ProductName Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ProductName As System.String
public System.string ProductName {get;}
See Also

Reference

LayerList Class
LayerList Members


ProductVersion Property (LayerList)

ProductVersion Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ProductVersion Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ProductVersion As System.String
public System.string ProductVersion {get;}
See Also

Reference

LayerList Class
LayerList Members


QueryAccessibilityHelp Event (LayerList)

QueryAccessibilityHelp Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : QueryAccessibilityHelp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event QueryAccessibilityHelp As System.Windows.Forms.QueryAccessibilityHelpEventHandler
public event System.Windows.Forms.QueryAccessibilityHelpEventHandler QueryAccessibilityHelp
Event Data

The event handler receives an argument of type System.Windows.Forms.QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.
See Also

Reference

LayerList Class
LayerList Members


QueryContinueDrag Event (LayerList)

QueryContinueDrag Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : QueryContinueDrag Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event QueryContinueDrag As System.Windows.Forms.QueryContinueDragEventHandler
public event System.Windows.Forms.QueryContinueDragEventHandler QueryContinueDrag
Event Data

The event handler receives an argument of type System.Windows.Forms.QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.
See Also

Reference

LayerList Class
LayerList Members


RecreatingHandle Property (LayerList)

RecreatingHandle Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : RecreatingHandle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property RecreatingHandle As System.Boolean
public System.bool RecreatingHandle {get;}
See Also

Reference

LayerList Class
LayerList Members


RectangleToClient Method (LayerList)

RectangleToClient Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : RectangleToClient Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function RectangleToClient( _
   ByVal r As Rectangle _
) As Rectangle
public Rectangle RectangleToClient(
   Rectangle r
)

Parameters

r
See Also

Reference

LayerList Class
LayerList Members


RectangleToScreen Method (LayerList)

RectangleToScreen Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : RectangleToScreen Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function RectangleToScreen( _
   ByVal r As Rectangle _
) As Rectangle
public Rectangle RectangleToScreen(
   Rectangle r
)

Parameters

r
See Also

Reference

LayerList Class
LayerList Members


Refresh Method (LayerList)

Refresh Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Refresh Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Refresh()
public void Refresh()
See Also

Reference

LayerList Class
LayerList Members


Region Property (LayerList)

Region Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Region Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Region As Region
public Region Region {get; set;}
See Also

Reference

LayerList Class
LayerList Members


RegionChanged Event (LayerList)

RegionChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : RegionChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event RegionChanged As System.EventHandler
public event System.EventHandler RegionChanged
See Also

Reference

LayerList Class
LayerList Members


ResetText Method (LayerList)

ResetText Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ResetText Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ResetText()
public void ResetText()
See Also

Reference

LayerList Class
LayerList Members


Resize Event (LayerList)

Resize Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Resize Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Resize As System.EventHandler
public event System.EventHandler Resize
See Also

Reference

LayerList Class
LayerList Members


ResumeLayout Method (LayerList)

ResumeLayout Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ResumeLayout Method
Overload List
Overload | Description
ResumeLayout() | (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

LayerList Class
LayerList Members


ResumeLayout() Method

ResumeLayout() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > ResumeLayout Method : ResumeLayout() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ResumeLayout()
public void ResumeLayout()
See Also

Reference

LayerList Class
LayerList Members
Overload List


ResumeLayout(Boolean) Method

ResumeLayout(Boolean) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > ResumeLayout Method : ResumeLayout(Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ResumeLayout( _
   ByVal performLayout As System.Boolean _
)
public void ResumeLayout(
   System.bool performLayout
)

Parameters

performLayout
See Also

Reference

LayerList Class
LayerList Members
Overload List


Right Property (LayerList)

Right Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Right Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Right As System.Integer
public System.int Right {get;}
See Also

Reference

LayerList Class
LayerList Members


RightToLeft Property (LayerList)

RightToLeft Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : RightToLeft Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RightToLeft As System.Windows.Forms.RightToLeft
public System.Windows.Forms.RightToLeft RightToLeft {get; set;}
See Also

Reference

LayerList Class
LayerList Members


RightToLeftChanged Event (LayerList)

RightToLeftChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : RightToLeftChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event RightToLeftChanged As System.EventHandler
public event System.EventHandler RightToLeftChanged
See Also

Reference

LayerList Class
LayerList Members


Scale Method (LayerList)

Scale Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Scale Method
Overload List
Overload | Description
Scale | (Inherited from System.Windows.Forms.Control)
See Also

Reference

LayerList Class
LayerList Members


Scale(SizeF) Method

Scale(SizeF) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > Scale Method : Scale(SizeF) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Scale( _
   ByVal factor As SizeF _
)
public void Scale(
   SizeF factor
)

Parameters

factor
See Also

Reference

LayerList Class
LayerList Members
Overload List


Scroll Event (LayerList)

Scroll Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Scroll Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Scroll As System.Windows.Forms.ScrollEventHandler
public event System.Windows.Forms.ScrollEventHandler Scroll
Event Data

The event handler receives an argument of type System.Windows.Forms.ScrollEventArgs containing data related to this event. The following ScrollEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets or sets the new System.Windows.Forms.ScrollBar.Value of the scroll bar.
OldValue | Gets the old System.Windows.Forms.ScrollBar.Value of the scroll bar.
ScrollOrientation | Gets the scroll bar orientation that raised the Scroll event.
Type | Gets the type of scroll event that occurred.
See Also

Reference

LayerList Class
LayerList Members


ScrollControlIntoView Method (LayerList)

ScrollControlIntoView Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ScrollControlIntoView Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ScrollControlIntoView( _
   ByVal activeControl As System.Windows.Forms.Control _
)
public void ScrollControlIntoView(
   System.Windows.Forms.Control activeControl
)

Parameters

activeControl
See Also

Reference

LayerList Class
LayerList Members


Select Method (LayerList)

Select Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Select Method
Overload List
Overload | Description
Select | (Inherited from System.Windows.Forms.Control)
See Also

Reference

LayerList Class
LayerList Members


Select() Method

Select() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Select() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Select()
public void Select()
See Also

Reference

LayerList Class
LayerList Members


SelectNextControl Method (LayerList)

SelectNextControl Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : SelectNextControl Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function SelectNextControl( _
   ByVal ctl As System.Windows.Forms.Control, _
   ByVal forward As System.Boolean, _
   ByVal tabStopOnly As System.Boolean, _
   ByVal nested As System.Boolean, _
   ByVal wrap As System.Boolean _
) As System.Boolean
public System.bool SelectNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)

Parameters

ctl
forward
tabStopOnly
nested
wrap
See Also

Reference

LayerList Class
LayerList Members


SendToBack Method (LayerList)

SendToBack Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : SendToBack Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SendToBack()
public void SendToBack()
See Also

Reference

LayerList Class
LayerList Members


SetAutoScrollMargin Method (LayerList)

SetAutoScrollMargin Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : SetAutoScrollMargin Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetAutoScrollMargin( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer _
)
public void SetAutoScrollMargin(
   System.int x,
   System.int y
)

Parameters

x
y
See Also

Reference

LayerList Class
LayerList Members


SetBounds Method (LayerList)

SetBounds Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : SetBounds Method
Overload List
Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

LayerList Class
LayerList Members


SetBounds(Int32,Int32,Int32,Int32) Method

SetBounds(Int32,Int32,Int32,Int32) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer _
)
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

x
y
width
height
See Also

Reference

LayerList Class
LayerList Members
Overload List


SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer, _
   ByVal specified As System.Windows.Forms.BoundsSpecified _
)
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)

Parameters

x
y
width
height
specified
See Also

Reference

LayerList Class
LayerList Members
Overload List


Show Method (LayerList)

Show Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Show Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Show()
public void Show()
See Also

Reference

LayerList Class
LayerList Members


Site Property (LayerList)

Site Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

LayerList Class
LayerList Members


Size Property (LayerList)

Size Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Size Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Size As Size
public Size Size {get; set;}
See Also

Reference

LayerList Class
LayerList Members


SizeChanged Event (LayerList)

SizeChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : SizeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event SizeChanged As System.EventHandler
public event System.EventHandler SizeChanged
See Also

Reference

LayerList Class
LayerList Members


StyleChanged Event (LayerList)

StyleChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : StyleChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event StyleChanged As System.EventHandler
public event System.EventHandler StyleChanged
See Also

Reference

LayerList Class
LayerList Members


SuspendLayout Method (LayerList)

SuspendLayout Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : SuspendLayout Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SuspendLayout()
public void SuspendLayout()
See Also

Reference

LayerList Class
LayerList Members


SystemColorsChanged Event (LayerList)

SystemColorsChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : SystemColorsChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event SystemColorsChanged As System.EventHandler
public event System.EventHandler SystemColorsChanged
See Also

Reference

LayerList Class
LayerList Members


TabIndex Property (LayerList)

TabIndex Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : TabIndex Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TabIndex As System.Integer
public System.int TabIndex {get; set;}
See Also

Reference

LayerList Class
LayerList Members


TabIndexChanged Event (LayerList)

TabIndexChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : TabIndexChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TabIndexChanged As System.EventHandler
public event System.EventHandler TabIndexChanged
See Also

Reference

LayerList Class
LayerList Members


TabStop Property (LayerList)

TabStop Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : TabStop Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TabStop As System.Boolean
public System.bool TabStop {get; set;}
See Also

Reference

LayerList Class
LayerList Members


TabStopChanged Event (LayerList)

TabStopChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : TabStopChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TabStopChanged As System.EventHandler
public event System.EventHandler TabStopChanged
See Also

Reference

LayerList Class
LayerList Members


Tag Property (LayerList)

Tag Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Tag Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Tag As System.Object
public System.object Tag {get; set;}
See Also

Reference

LayerList Class
LayerList Members


Top Property (LayerList)

Top Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Top Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Top As System.Integer
public System.int Top {get; set;}
See Also

Reference

LayerList Class
LayerList Members


TopLevelControl Property (LayerList)

TopLevelControl Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : TopLevelControl Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TopLevelControl As System.Windows.Forms.Control
public System.Windows.Forms.Control TopLevelControl {get;}
See Also

Reference

LayerList Class
LayerList Members


ToString Method (LayerList)

ToString Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

LayerList Class
LayerList Members


Update Method (LayerList)

Update Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Update Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Update()
public void Update()
See Also

Reference

LayerList Class
LayerList Members


UseWaitCursor Property (LayerList)

UseWaitCursor Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : UseWaitCursor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseWaitCursor As System.Boolean
public System.bool UseWaitCursor {get; set;}
See Also

Reference

LayerList Class
LayerList Members


Validate Method (LayerList)

Validate Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Validate Method
Overload List
Overload | Description
Validate() | (Inherited from System.Windows.Forms.ContainerControl)
Validate(Boolean) | (Inherited from System.Windows.Forms.ContainerControl)
See Also

Reference

LayerList Class
LayerList Members


Validate() Method

Validate() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > Validate Method : Validate() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Validate() As System.Boolean
public System.bool Validate()
See Also

Reference

LayerList Class
LayerList Members
Overload List


Validate(Boolean) Method

Validate(Boolean) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > Validate Method : Validate(Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Validate( _
   ByVal checkAutoValidate As System.Boolean _
) As System.Boolean
public System.bool Validate(
   System.bool checkAutoValidate
)

Parameters

checkAutoValidate
See Also

Reference

LayerList Class
LayerList Members
Overload List


ValidateChildren Method (LayerList)

ValidateChildren Method (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : ValidateChildren Method
Overload List
Overload | Description
ValidateChildren() | (Inherited from System.Windows.Forms.UserControl)
ValidateChildren(ValidationConstraints) | (Inherited from System.Windows.Forms.UserControl)
See Also

Reference

LayerList Class
LayerList Members


ValidateChildren() Method

ValidateChildren() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > ValidateChildren Method : ValidateChildren() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function ValidateChildren() As System.Boolean
public System.bool ValidateChildren()
See Also

Reference

LayerList Class
LayerList Members
Overload List


ValidateChildren(ValidationConstraints) Method

ValidateChildren(ValidationConstraints) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class > ValidateChildren Method : ValidateChildren(ValidationConstraints) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function ValidateChildren( _
   ByVal validationConstraints As System.Windows.Forms.ValidationConstraints _
) As System.Boolean
public System.bool ValidateChildren(
   System.Windows.Forms.ValidationConstraints validationConstraints
)

Parameters

validationConstraints
See Also

Reference

LayerList Class
LayerList Members
Overload List


Validated Event (LayerList)

Validated Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Validated Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Validated As System.EventHandler
public event System.EventHandler Validated
See Also

Reference

LayerList Class
LayerList Members


Validating Event (LayerList)

Validating Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Validating Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Validating As System.ComponentModel.CancelEventHandler
public event System.ComponentModel.CancelEventHandler Validating
Event Data

The event handler receives an argument of type System.ComponentModel.CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |
See Also

Reference

LayerList Class
LayerList Members


VerticalScroll Property (LayerList)

VerticalScroll Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : VerticalScroll Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property VerticalScroll As System.Windows.Forms.VScrollProperties
public System.Windows.Forms.VScrollProperties VerticalScroll {get;}
See Also

Reference

LayerList Class
LayerList Members


Visible Property (LayerList)

Visible Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Visible Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}
See Also

Reference

LayerList Class
LayerList Members


VisibleChanged Event (LayerList)

VisibleChanged Event (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : VisibleChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event VisibleChanged As System.EventHandler
public event System.EventHandler VisibleChanged
See Also

Reference

LayerList Class
LayerList Members


Width Property (LayerList)

Width Property (LayerList)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design Namespace > LayerList Class : Width Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As System.Integer
public System.int Width {get; set;}
See Also

Reference

LayerList Class
LayerList Members


ReportExplorer Class Methods

ReportExplorer Class Methods

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace : ReportExplorer Class

For a list of all members of this type, see ReportExplorer members.

Public Methods
 | Name | Description
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Show | (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.UserControl)
Top
See Also

Reference

ReportExplorer Class
GrapeCity.ActiveReports.Design.ReportExplorer Namespace


AccessibilityObject Property (ReportExplorer)

AccessibilityObject Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AccessibilityObject Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property AccessibilityObject As System.Windows.Forms.AccessibleObject
public System.Windows.Forms.AccessibleObject AccessibilityObject {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


AccessibleDefaultActionDescription Property (ReportExplorer)

AccessibleDefaultActionDescription Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AccessibleDefaultActionDescription Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AccessibleDefaultActionDescription As System.String
public System.string AccessibleDefaultActionDescription {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


AccessibleDescription Property (ReportExplorer)

AccessibleDescription Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AccessibleDescription Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AccessibleDescription As System.String
public System.string AccessibleDescription {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


AccessibleName Property (ReportExplorer)

AccessibleName Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AccessibleName Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AccessibleName As System.String
public System.string AccessibleName {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


AccessibleRole Property (ReportExplorer)

AccessibleRole Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AccessibleRole Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AccessibleRole As System.Windows.Forms.AccessibleRole
public System.Windows.Forms.AccessibleRole AccessibleRole {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ActiveControl Property (ReportExplorer)

ActiveControl Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ActiveControl Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ActiveControl As System.Windows.Forms.Control
public System.Windows.Forms.Control ActiveControl {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


AllowDrop Property (ReportExplorer)

AllowDrop Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AllowDrop Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property AllowDrop As System.Boolean
public virtual System.bool AllowDrop {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Anchor Property (ReportExplorer)

Anchor Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Anchor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Anchor As System.Windows.Forms.AnchorStyles
public virtual System.Windows.Forms.AnchorStyles Anchor {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


AutoScaleDimensions Property (ReportExplorer)

AutoScaleDimensions Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AutoScaleDimensions Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScaleDimensions As SizeF
public SizeF AutoScaleDimensions {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


AutoScaleMode Property (ReportExplorer)

AutoScaleMode Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AutoScaleMode Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScaleMode As System.Windows.Forms.AutoScaleMode
public System.Windows.Forms.AutoScaleMode AutoScaleMode {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


AutoScroll Property (ReportExplorer)

AutoScroll Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AutoScroll Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property AutoScroll As System.Boolean
public virtual System.bool AutoScroll {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


AutoScrollMargin Property (ReportExplorer)

AutoScrollMargin Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AutoScrollMargin Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScrollMargin As Size
public Size AutoScrollMargin {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


AutoScrollMinSize Property (ReportExplorer)

AutoScrollMinSize Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AutoScrollMinSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScrollMinSize As Size
public Size AutoScrollMinSize {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


AutoScrollOffset Property (ReportExplorer)

AutoScrollOffset Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AutoScrollOffset Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property AutoScrollOffset As Point
public virtual Point AutoScrollOffset {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


AutoScrollPosition Property (ReportExplorer)

AutoScrollPosition Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AutoScrollPosition Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScrollPosition As Point
public Point AutoScrollPosition {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


AutoSize Property (ReportExplorer)

AutoSize Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AutoSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property AutoSize As System.Boolean
public virtual System.bool AutoSize {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


AutoSizeChanged Event (ReportExplorer)

AutoSizeChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AutoSizeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event AutoSizeChanged As System.EventHandler
public event System.EventHandler AutoSizeChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


AutoSizeMode Property (ReportExplorer)

AutoSizeMode Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AutoSizeMode Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoSizeMode As System.Windows.Forms.AutoSizeMode
public System.Windows.Forms.AutoSizeMode AutoSizeMode {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


AutoValidate Property (ReportExplorer)

AutoValidate Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AutoValidate Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property AutoValidate As System.Windows.Forms.AutoValidate
public virtual System.Windows.Forms.AutoValidate AutoValidate {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


AutoValidateChanged Event (ReportExplorer)

AutoValidateChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : AutoValidateChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event AutoValidateChanged As System.EventHandler
public event System.EventHandler AutoValidateChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


BackColor Property (ReportExplorer)

BackColor Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : BackColor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property BackColor As Color
public virtual Color BackColor {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


BackColorChanged Event (ReportExplorer)

BackColorChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : BackColorChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BackColorChanged As System.EventHandler
public event System.EventHandler BackColorChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


BackgroundImage Property (ReportExplorer)

BackgroundImage Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : BackgroundImage Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property BackgroundImage As Image
public virtual Image BackgroundImage {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


BackgroundImageChanged Event (ReportExplorer)

BackgroundImageChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : BackgroundImageChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BackgroundImageChanged As System.EventHandler
public event System.EventHandler BackgroundImageChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


BackgroundImageLayout Property (ReportExplorer)

BackgroundImageLayout Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : BackgroundImageLayout Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property BackgroundImageLayout As System.Windows.Forms.ImageLayout
public virtual System.Windows.Forms.ImageLayout BackgroundImageLayout {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


BackgroundImageLayoutChanged Event (ReportExplorer)

BackgroundImageLayoutChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : BackgroundImageLayoutChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BackgroundImageLayoutChanged As System.EventHandler
public event System.EventHandler BackgroundImageLayoutChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


BeginInvoke Method (ReportExplorer)

BeginInvoke Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : BeginInvoke Method
Overload List
Overload | Description
BeginInvoke(Delegate) | (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

ReportExplorer Class
ReportExplorer Members


BeginInvoke(Delegate) Method

BeginInvoke(Delegate) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > BeginInvoke Method : BeginInvoke(Delegate) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function BeginInvoke( _
   ByVal method As System.Delegate _
) As System.IAsyncResult
public System.IAsyncResult BeginInvoke(
   System.Delegate method
)

Parameters

method
See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


BeginInvoke(Delegate,Object[]) Method

BeginInvoke(Delegate,Object[]) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function BeginInvoke( _
   ByVal method As System.Delegate, _
   ByVal ParamArray args() As System.Object _
) As System.IAsyncResult
public System.IAsyncResult BeginInvoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
args
See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


BindingContext Property (ReportExplorer)

BindingContext Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : BindingContext Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property BindingContext As System.Windows.Forms.BindingContext
public virtual System.Windows.Forms.BindingContext BindingContext {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


BindingContextChanged Event (ReportExplorer)

BindingContextChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : BindingContextChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BindingContextChanged As System.EventHandler
public event System.EventHandler BindingContextChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


BorderStyle Property (ReportExplorer)

BorderStyle Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : BorderStyle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BorderStyle As System.Windows.Forms.BorderStyle
public System.Windows.Forms.BorderStyle BorderStyle {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Bottom Property (ReportExplorer)

Bottom Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Bottom Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Bottom As System.Integer
public System.int Bottom {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Bounds Property (ReportExplorer)

Bounds Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Bounds Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Bounds As Rectangle
public Rectangle Bounds {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


BringToFront Method (ReportExplorer)

BringToFront Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : BringToFront Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub BringToFront()
public void BringToFront()
See Also

Reference

ReportExplorer Class
ReportExplorer Members


CanFocus Property (ReportExplorer)

CanFocus Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : CanFocus Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CanFocus As System.Boolean
public System.bool CanFocus {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


CanSelect Property (ReportExplorer)

CanSelect Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : CanSelect Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CanSelect As System.Boolean
public System.bool CanSelect {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Capture Property (ReportExplorer)

Capture Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Capture Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capture As System.Boolean
public System.bool Capture {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


CausesValidation Property (ReportExplorer)

CausesValidation Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : CausesValidation Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CausesValidation As System.Boolean
public System.bool CausesValidation {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


CausesValidationChanged Event (ReportExplorer)

CausesValidationChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : CausesValidationChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event CausesValidationChanged As System.EventHandler
public event System.EventHandler CausesValidationChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ChangeUICues Event (ReportExplorer)

ChangeUICues Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ChangeUICues Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ChangeUICues As System.Windows.Forms.UICuesEventHandler
public event System.Windows.Forms.UICuesEventHandler ChangeUICues
Event Data

The event handler receives an argument of type System.Windows.Forms.UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Click Event (ReportExplorer)

Click Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Click Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Click As System.EventHandler
public event System.EventHandler Click
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ClientRectangle Property (ReportExplorer)

ClientRectangle Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ClientRectangle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ClientRectangle As Rectangle
public Rectangle ClientRectangle {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ClientSize Property (ReportExplorer)

ClientSize Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ClientSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ClientSize As Size
public Size ClientSize {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ClientSizeChanged Event (ReportExplorer)

ClientSizeChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ClientSizeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ClientSizeChanged As System.EventHandler
public event System.EventHandler ClientSizeChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


CompanyName Property (ReportExplorer)

CompanyName Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : CompanyName Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CompanyName As System.String
public System.string CompanyName {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Container Property (ReportExplorer)

Container Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Contains Method (ReportExplorer)

Contains Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Contains Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal ctl As System.Windows.Forms.Control _
) As System.Boolean
public System.bool Contains(
   System.Windows.Forms.Control ctl
)

Parameters

ctl
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ContainsFocus Property (ReportExplorer)

ContainsFocus Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ContainsFocus Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ContainsFocus As System.Boolean
public System.bool ContainsFocus {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ContextMenu Property (ReportExplorer)

ContextMenu Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ContextMenu Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property ContextMenu As System.Windows.Forms.ContextMenu
public virtual System.Windows.Forms.ContextMenu ContextMenu {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ContextMenuChanged Event (ReportExplorer)

ContextMenuChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ContextMenuChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ContextMenuChanged As System.EventHandler
public event System.EventHandler ContextMenuChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ContextMenuStrip Property (ReportExplorer)

ContextMenuStrip Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ContextMenuStrip Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property ContextMenuStrip As System.Windows.Forms.ContextMenuStrip
public virtual System.Windows.Forms.ContextMenuStrip ContextMenuStrip {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ContextMenuStripChanged Event (ReportExplorer)

ContextMenuStripChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ContextMenuStripChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ContextMenuStripChanged As System.EventHandler
public event System.EventHandler ContextMenuStripChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ControlAdded Event (ReportExplorer)

ControlAdded Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ControlAdded Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ControlAdded As System.Windows.Forms.ControlEventHandler
public event System.Windows.Forms.ControlEventHandler ControlAdded
Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ControlRemoved Event (ReportExplorer)

ControlRemoved Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ControlRemoved Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ControlRemoved As System.Windows.Forms.ControlEventHandler
public event System.Windows.Forms.ControlEventHandler ControlRemoved
Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Controls Property (ReportExplorer)

Controls Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Controls Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Controls As System.Windows.Forms.Control.ControlCollection
public System.Windows.Forms.Control.ControlCollection Controls {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


CreateControl Method (ReportExplorer)

CreateControl Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : CreateControl Method
Overload List
Overload | Description
CreateControl | (Inherited from System.Windows.Forms.Control)
See Also

Reference

ReportExplorer Class
ReportExplorer Members


CreateControl() Method

CreateControl() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : CreateControl() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CreateControl()
public void CreateControl()
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Created Property (ReportExplorer)

Created Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Created Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Created As System.Boolean
public System.bool Created {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


CreateGraphics Method (ReportExplorer)

CreateGraphics Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : CreateGraphics Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateGraphics() As Graphics
public Graphics CreateGraphics()
See Also

Reference

ReportExplorer Class
ReportExplorer Members


CreateObjRef Method (ReportExplorer)

CreateObjRef Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

ReportExplorer Class
ReportExplorer Members


CurrentAutoScaleDimensions Property (ReportExplorer)

CurrentAutoScaleDimensions Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : CurrentAutoScaleDimensions Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CurrentAutoScaleDimensions As SizeF
public SizeF CurrentAutoScaleDimensions {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Cursor Property (ReportExplorer)

Cursor Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Cursor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Cursor As System.Windows.Forms.Cursor
public virtual System.Windows.Forms.Cursor Cursor {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


CursorChanged Event (ReportExplorer)

CursorChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : CursorChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event CursorChanged As System.EventHandler
public event System.EventHandler CursorChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


DataBindings Property (ReportExplorer)

DataBindings Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : DataBindings Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DataBindings As System.Windows.Forms.ControlBindingsCollection
public System.Windows.Forms.ControlBindingsCollection DataBindings {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


DisplayRectangle Property (ReportExplorer)

DisplayRectangle Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : DisplayRectangle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property DisplayRectangle As Rectangle
public virtual Rectangle DisplayRectangle {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Dispose Method (ReportExplorer)

Dispose Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Dispose Method
Clears the ReportExplorer from memory.
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Disposed Event (ReportExplorer)

Disposed Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Disposing Property (ReportExplorer)

Disposing Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Disposing Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Disposing As System.Boolean
public System.bool Disposing {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Dock Property (ReportExplorer)

Dock Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Dock Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Dock As System.Windows.Forms.DockStyle
public virtual System.Windows.Forms.DockStyle Dock {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


DockChanged Event (ReportExplorer)

DockChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : DockChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DockChanged As System.EventHandler
public event System.EventHandler DockChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


DoDragDrop Method (ReportExplorer)

DoDragDrop Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : DoDragDrop Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function DoDragDrop( _
   ByVal data As System.Object, _
   ByVal allowedEffects As System.Windows.Forms.DragDropEffects _
) As System.Windows.Forms.DragDropEffects
public System.Windows.Forms.DragDropEffects DoDragDrop(
   System.object data,
   System.Windows.Forms.DragDropEffects allowedEffects
)

Parameters

data
allowedEffects
See Also

Reference

ReportExplorer Class
ReportExplorer Members


DoubleClick Event (ReportExplorer)

DoubleClick Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : DoubleClick Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DoubleClick As System.EventHandler
public event System.EventHandler DoubleClick
See Also

Reference

ReportExplorer Class
ReportExplorer Members


DragDrop Event (ReportExplorer)

DragDrop Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : DragDrop Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragDrop As System.Windows.Forms.DragEventHandler
public event System.Windows.Forms.DragEventHandler DragDrop
Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


DragEnter Event (ReportExplorer)

DragEnter Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : DragEnter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragEnter As System.Windows.Forms.DragEventHandler
public event System.Windows.Forms.DragEventHandler DragEnter
Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


DragLeave Event (ReportExplorer)

DragLeave Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : DragLeave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragLeave As System.EventHandler
public event System.EventHandler DragLeave
See Also

Reference

ReportExplorer Class
ReportExplorer Members


DragOver Event (ReportExplorer)

DragOver Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : DragOver Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragOver As System.Windows.Forms.DragEventHandler
public event System.Windows.Forms.DragEventHandler DragOver
Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


DrawToBitmap Method (ReportExplorer)

DrawToBitmap Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : DrawToBitmap Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub DrawToBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal targetBounds As Rectangle _
)
public void DrawToBitmap(
   Bitmap bitmap,
   Rectangle targetBounds
)

Parameters

bitmap
targetBounds
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Enabled Property (ReportExplorer)

Enabled Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Enabled Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Enabled As System.Boolean
public System.bool Enabled {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


EnabledChanged Event (ReportExplorer)

EnabledChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : EnabledChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event EnabledChanged As System.EventHandler
public event System.EventHandler EnabledChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


EndInvoke Method (ReportExplorer)

EndInvoke Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : EndInvoke Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function EndInvoke( _
   ByVal asyncResult As System.IAsyncResult _
) As System.Object
public System.object EndInvoke(
   System.IAsyncResult asyncResult
)

Parameters

asyncResult
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Enter Event (ReportExplorer)

Enter Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Enter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Enter As System.EventHandler
public event System.EventHandler Enter
See Also

Reference

ReportExplorer Class
ReportExplorer Members


FindForm Method (ReportExplorer)

FindForm Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : FindForm Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function FindForm() As System.Windows.Forms.Form
public System.Windows.Forms.Form FindForm()
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Focus Method (ReportExplorer)

Focus Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Focus Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Focus() As System.Boolean
public System.bool Focus()
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Focused Property (ReportExplorer)

Focused Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Focused Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Focused As System.Boolean
public virtual System.bool Focused {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Font Property (ReportExplorer)

Font Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Font Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Font As Font
public virtual Font Font {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


FontChanged Event (ReportExplorer)

FontChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : FontChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event FontChanged As System.EventHandler
public event System.EventHandler FontChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ForeColor Property (ReportExplorer)

ForeColor Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ForeColor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property ForeColor As Color
public virtual Color ForeColor {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ForeColorChanged Event (ReportExplorer)

ForeColorChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ForeColorChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ForeColorChanged As System.EventHandler
public event System.EventHandler ForeColorChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


GetChildAtPoint Method (ReportExplorer)

GetChildAtPoint Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : GetChildAtPoint Method
Overload List
Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

ReportExplorer Class
ReportExplorer Members


GetChildAtPoint(Point) Method

GetChildAtPoint(Point) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point _
) As System.Windows.Forms.Control
public System.Windows.Forms.Control GetChildAtPoint(
   Point pt
)

Parameters

pt
See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


GetChildAtPoint(Point,GetChildAtPointSkip) Method

GetChildAtPoint(Point,GetChildAtPointSkip) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point, _
   ByVal skipValue As System.Windows.Forms.GetChildAtPointSkip _
) As System.Windows.Forms.Control
public System.Windows.Forms.Control GetChildAtPoint(
   Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)

Parameters

pt
skipValue
See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


GetContainerControl Method (ReportExplorer)

GetContainerControl Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : GetContainerControl Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetContainerControl() As System.Windows.Forms.IContainerControl
public System.Windows.Forms.IContainerControl GetContainerControl()
See Also

Reference

ReportExplorer Class
ReportExplorer Members


GetLifetimeService Method (ReportExplorer)

GetLifetimeService Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

ReportExplorer Class
ReportExplorer Members


GetNextControl Method (ReportExplorer)

GetNextControl Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : GetNextControl Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetNextControl( _
   ByVal ctl As System.Windows.Forms.Control, _
   ByVal forward As System.Boolean _
) As System.Windows.Forms.Control
public System.Windows.Forms.Control GetNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward
)

Parameters

ctl
forward
See Also

Reference

ReportExplorer Class
ReportExplorer Members


GetPreferredSize Method (ReportExplorer)

GetPreferredSize Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : GetPreferredSize Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetPreferredSize( _
   ByVal proposedSize As Size _
) As Size
public virtual Size GetPreferredSize(
   Size proposedSize
)

Parameters

proposedSize
See Also

Reference

ReportExplorer Class
ReportExplorer Members


GiveFeedback Event (ReportExplorer)

GiveFeedback Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : GiveFeedback Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event GiveFeedback As System.Windows.Forms.GiveFeedbackEventHandler
public event System.Windows.Forms.GiveFeedbackEventHandler GiveFeedback
Event Data

The event handler receives an argument of type System.Windows.Forms.GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


GotFocus Event (ReportExplorer)

GotFocus Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : GotFocus Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event GotFocus As System.EventHandler
public event System.EventHandler GotFocus
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Handle Property (ReportExplorer)

Handle Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Handle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Handle As System.IntPtr
public System.IntPtr Handle {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


HandleCreated Event (ReportExplorer)

HandleCreated Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : HandleCreated Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event HandleCreated As System.EventHandler
public event System.EventHandler HandleCreated
See Also

Reference

ReportExplorer Class
ReportExplorer Members


HandleDestroyed Event (ReportExplorer)

HandleDestroyed Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : HandleDestroyed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event HandleDestroyed As System.EventHandler
public event System.EventHandler HandleDestroyed
See Also

Reference

ReportExplorer Class
ReportExplorer Members


HasChildren Property (ReportExplorer)

HasChildren Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : HasChildren Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HasChildren As System.Boolean
public System.bool HasChildren {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Height Property (ReportExplorer)

Height Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Height Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As System.Integer
public System.int Height {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


HelpRequested Event (ReportExplorer)

HelpRequested Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : HelpRequested Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event HelpRequested As System.Windows.Forms.HelpEventHandler
public event System.Windows.Forms.HelpEventHandler HelpRequested
Event Data

The event handler receives an argument of type System.Windows.Forms.HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Hide Method (ReportExplorer)

Hide Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Hide Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Hide()
public void Hide()
See Also

Reference

ReportExplorer Class
ReportExplorer Members


HorizontalScroll Property (ReportExplorer)

HorizontalScroll Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : HorizontalScroll Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HorizontalScroll As System.Windows.Forms.HScrollProperties
public System.Windows.Forms.HScrollProperties HorizontalScroll {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ImeMode Property (ReportExplorer)

ImeMode Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ImeMode Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ImeMode As System.Windows.Forms.ImeMode
public System.Windows.Forms.ImeMode ImeMode {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ImeModeChanged Event (ReportExplorer)

ImeModeChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ImeModeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ImeModeChanged As System.EventHandler
public event System.EventHandler ImeModeChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


InitializeLifetimeService Method (ReportExplorer)

InitializeLifetimeService Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
public virtual System.object InitializeLifetimeService()
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Invalidate Method (ReportExplorer)

Invalidate Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Invalidate Method
Overload List
Overload | Description
Invalidate(Region) | (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | (Inherited from System.Windows.Forms.Control)
Invalidate() | (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Invalidate() Method

Invalidate() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > Invalidate Method : Invalidate() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate()
public void Invalidate()
See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


Invalidate(Boolean) Method

Invalidate(Boolean) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > Invalidate Method : Invalidate(Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal invalidateChildren As System.Boolean _
)
public void Invalidate(
   System.bool invalidateChildren
)

Parameters

invalidateChildren
See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


Invalidate(Rectangle) Method

Invalidate(Rectangle) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > Invalidate Method : Invalidate(Rectangle) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle _
)
public void Invalidate(
   Rectangle rc
)

Parameters

rc
See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


Invalidate(Rectangle,Boolean) Method

Invalidate(Rectangle,Boolean) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle, _
   ByVal invalidateChildren As System.Boolean _
)
public void Invalidate(
   Rectangle rc,
   System.bool invalidateChildren
)

Parameters

rc
invalidateChildren
See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


Invalidate(Region) Method

Invalidate(Region) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > Invalidate Method : Invalidate(Region) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal region As Region _
)
public void Invalidate(
   Region region
)

Parameters

region
See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


Invalidate(Region,Boolean) Method

Invalidate(Region,Boolean) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > Invalidate Method : Invalidate(Region,Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal region As Region, _
   ByVal invalidateChildren As System.Boolean _
)
public void Invalidate(
   Region region,
   System.bool invalidateChildren
)

Parameters

region
invalidateChildren
See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


Invalidated Event (ReportExplorer)

Invalidated Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Invalidated Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Invalidated As System.Windows.Forms.InvalidateEventHandler
public event System.Windows.Forms.InvalidateEventHandler Invalidated
Event Data

The event handler receives an argument of type System.Windows.Forms.InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Invoke Method (ReportExplorer)

Invoke Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Invoke Method
Overload List
Overload | Description
Invoke(Delegate) | (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Invoke(Delegate) Method

Invoke(Delegate) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > Invoke Method : Invoke(Delegate) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Invoke( _
   ByVal method As System.Delegate _
) As System.Object
public System.object Invoke(
   System.Delegate method
)

Parameters

method
See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


Invoke(Delegate,Object[]) Method

Invoke(Delegate,Object[]) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > Invoke Method : Invoke(Delegate,Object[]) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Invoke( _
   ByVal method As System.Delegate, _
   ByVal ParamArray args() As System.Object _
) As System.Object
public System.object Invoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
args
See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


InvokeRequired Property (ReportExplorer)

InvokeRequired Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : InvokeRequired Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InvokeRequired As System.Boolean
public System.bool InvokeRequired {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


IsAccessible Property (ReportExplorer)

IsAccessible Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : IsAccessible Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsAccessible As System.Boolean
public System.bool IsAccessible {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


IsDisposed Property (ReportExplorer)

IsDisposed Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : IsDisposed Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsDisposed As System.Boolean
public System.bool IsDisposed {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


IsHandleCreated Property (ReportExplorer)

IsHandleCreated Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : IsHandleCreated Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsHandleCreated As System.Boolean
public System.bool IsHandleCreated {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


IsMirrored Property (ReportExplorer)

IsMirrored Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : IsMirrored Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsMirrored As System.Boolean
public System.bool IsMirrored {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


KeyDown Event (ReportExplorer)

KeyDown Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : KeyDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event KeyDown As System.Windows.Forms.KeyEventHandler
public event System.Windows.Forms.KeyEventHandler KeyDown
Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


KeyPress Event (ReportExplorer)

KeyPress Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : KeyPress Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event KeyPress As System.Windows.Forms.KeyPressEventHandler
public event System.Windows.Forms.KeyPressEventHandler KeyPress
Event Data

The event handler receives an argument of type System.Windows.Forms.KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


KeyUp Event (ReportExplorer)

KeyUp Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : KeyUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event KeyUp As System.Windows.Forms.KeyEventHandler
public event System.Windows.Forms.KeyEventHandler KeyUp
Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Layout Event (ReportExplorer)

Layout Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Layout Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Layout As System.Windows.Forms.LayoutEventHandler
public event System.Windows.Forms.LayoutEventHandler Layout
Event Data

The event handler receives an argument of type System.Windows.Forms.LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


LayoutEngine Property (ReportExplorer)

LayoutEngine Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : LayoutEngine Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property LayoutEngine As System.Windows.Forms.Layout.LayoutEngine
public virtual System.Windows.Forms.Layout.LayoutEngine LayoutEngine {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Leave Event (ReportExplorer)

Leave Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Leave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Leave As System.EventHandler
public event System.EventHandler Leave
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Left Property (ReportExplorer)

Left Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Left Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Left As System.Integer
public System.int Left {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Load Event (ReportExplorer)

Load Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Load Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Load As System.EventHandler
public event System.EventHandler Load
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Location Property (ReportExplorer)

Location Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Location Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Location As Point
public Point Location {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


LocationChanged Event (ReportExplorer)

LocationChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : LocationChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LocationChanged As System.EventHandler
public event System.EventHandler LocationChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


LostFocus Event (ReportExplorer)

LostFocus Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : LostFocus Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LostFocus As System.EventHandler
public event System.EventHandler LostFocus
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Margin Property (ReportExplorer)

Margin Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Margin Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Margin As System.Windows.Forms.Padding
public System.Windows.Forms.Padding Margin {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


MarginChanged Event (ReportExplorer)

MarginChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MarginChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MarginChanged As System.EventHandler
public event System.EventHandler MarginChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


MaximumSize Property (ReportExplorer)

MaximumSize Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MaximumSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property MaximumSize As Size
public virtual Size MaximumSize {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


MinimumSize Property (ReportExplorer)

MinimumSize Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MinimumSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property MinimumSize As Size
public virtual Size MinimumSize {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


MouseCaptureChanged Event (ReportExplorer)

MouseCaptureChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MouseCaptureChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseCaptureChanged As System.EventHandler
public event System.EventHandler MouseCaptureChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


MouseClick Event (ReportExplorer)

MouseClick Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MouseClick Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseClick As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseClick
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


MouseDoubleClick Event (ReportExplorer)

MouseDoubleClick Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MouseDoubleClick Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseDoubleClick As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseDoubleClick
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


MouseDown Event (ReportExplorer)

MouseDown Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MouseDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseDown As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseDown
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


MouseEnter Event (ReportExplorer)

MouseEnter Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MouseEnter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseEnter As System.EventHandler
public event System.EventHandler MouseEnter
See Also

Reference

ReportExplorer Class
ReportExplorer Members


MouseHover Event (ReportExplorer)

MouseHover Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MouseHover Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseHover As System.EventHandler
public event System.EventHandler MouseHover
See Also

Reference

ReportExplorer Class
ReportExplorer Members


MouseLeave Event (ReportExplorer)

MouseLeave Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MouseLeave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseLeave As System.EventHandler
public event System.EventHandler MouseLeave
See Also

Reference

ReportExplorer Class
ReportExplorer Members


MouseMove Event (ReportExplorer)

MouseMove Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MouseMove Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseMove As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseMove
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


MouseUp Event (ReportExplorer)

MouseUp Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MouseUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseUp As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseUp
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


MouseWheel Event (ReportExplorer)

MouseWheel Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : MouseWheel Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseWheel As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseWheel
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Move Event (ReportExplorer)

Move Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Move Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Move As System.EventHandler
public event System.EventHandler Move
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Name Property (ReportExplorer)

Name Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Name Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Padding Property (ReportExplorer)

Padding Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Padding Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Padding As System.Windows.Forms.Padding
public System.Windows.Forms.Padding Padding {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


PaddingChanged Event (ReportExplorer)

PaddingChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : PaddingChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PaddingChanged As System.EventHandler
public event System.EventHandler PaddingChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Paint Event (ReportExplorer)

Paint Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Paint Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Paint As System.Windows.Forms.PaintEventHandler
public event System.Windows.Forms.PaintEventHandler Paint
Event Data

The event handler receives an argument of type System.Windows.Forms.PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Parent Property (ReportExplorer)

Parent Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Parent Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Parent As System.Windows.Forms.Control
public System.Windows.Forms.Control Parent {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ParentChanged Event (ReportExplorer)

ParentChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ParentChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ParentChanged As System.EventHandler
public event System.EventHandler ParentChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ParentForm Property (ReportExplorer)

ParentForm Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ParentForm Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ParentForm As System.Windows.Forms.Form
public System.Windows.Forms.Form ParentForm {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


PerformAutoScale Method (ReportExplorer)

PerformAutoScale Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : PerformAutoScale Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub PerformAutoScale()
public void PerformAutoScale()
See Also

Reference

ReportExplorer Class
ReportExplorer Members


PerformLayout Method (ReportExplorer)

PerformLayout Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : PerformLayout Method
Overload List
Overload | Description
PerformLayout() | (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

ReportExplorer Class
ReportExplorer Members


PerformLayout() Method

PerformLayout() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > PerformLayout Method : PerformLayout() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub PerformLayout()
public void PerformLayout()
See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


PerformLayout(Control,String) Method

PerformLayout(Control,String) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > PerformLayout Method : PerformLayout(Control,String) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub PerformLayout( _
   ByVal affectedControl As System.Windows.Forms.Control, _
   ByVal affectedProperty As System.String _
)
public void PerformLayout(
   System.Windows.Forms.Control affectedControl,
   System.string affectedProperty
)

Parameters

affectedControl
affectedProperty
See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


PointToClient Method (ReportExplorer)

PointToClient Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : PointToClient Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PointToClient( _
   ByVal p As Point _
) As Point
public Point PointToClient(
   Point p
)

Parameters

p
See Also

Reference

ReportExplorer Class
ReportExplorer Members


PointToScreen Method (ReportExplorer)

PointToScreen Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : PointToScreen Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PointToScreen( _
   ByVal p As Point _
) As Point
public Point PointToScreen(
   Point p
)

Parameters

p
See Also

Reference

ReportExplorer Class
ReportExplorer Members


PreferredSize Property (ReportExplorer)

PreferredSize Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : PreferredSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PreferredSize As Size
public Size PreferredSize {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


PreProcessControlMessage Method (ReportExplorer)

PreProcessControlMessage Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : PreProcessControlMessage Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PreProcessControlMessage( _
   ByRef msg As System.Windows.Forms.Message _
) As System.Windows.Forms.PreProcessControlState
public System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
See Also

Reference

ReportExplorer Class
ReportExplorer Members


PreProcessMessage Method (ReportExplorer)

PreProcessMessage Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : PreProcessMessage Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function PreProcessMessage( _
   ByRef msg As System.Windows.Forms.Message _
) As System.Boolean
public virtual System.bool PreProcessMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
See Also

Reference

ReportExplorer Class
ReportExplorer Members


PreviewKeyDown Event (ReportExplorer)

PreviewKeyDown Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : PreviewKeyDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewKeyDown As System.Windows.Forms.PreviewKeyDownEventHandler
public event System.Windows.Forms.PreviewKeyDownEventHandler PreviewKeyDown
Event Data

The event handler receives an argument of type System.Windows.Forms.PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ProductName Property (ReportExplorer)

ProductName Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ProductName Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ProductName As System.String
public System.string ProductName {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ProductVersion Property (ReportExplorer)

ProductVersion Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ProductVersion Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ProductVersion As System.String
public System.string ProductVersion {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


QueryAccessibilityHelp Event (ReportExplorer)

QueryAccessibilityHelp Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : QueryAccessibilityHelp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event QueryAccessibilityHelp As System.Windows.Forms.QueryAccessibilityHelpEventHandler
public event System.Windows.Forms.QueryAccessibilityHelpEventHandler QueryAccessibilityHelp
Event Data

The event handler receives an argument of type System.Windows.Forms.QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


QueryContinueDrag Event (ReportExplorer)

QueryContinueDrag Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : QueryContinueDrag Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event QueryContinueDrag As System.Windows.Forms.QueryContinueDragEventHandler
public event System.Windows.Forms.QueryContinueDragEventHandler QueryContinueDrag
Event Data

The event handler receives an argument of type System.Windows.Forms.QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


RecreatingHandle Property (ReportExplorer)

RecreatingHandle Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : RecreatingHandle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property RecreatingHandle As System.Boolean
public System.bool RecreatingHandle {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


RectangleToClient Method (ReportExplorer)

RectangleToClient Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : RectangleToClient Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function RectangleToClient( _
   ByVal r As Rectangle _
) As Rectangle
public Rectangle RectangleToClient(
   Rectangle r
)

Parameters

r
See Also

Reference

ReportExplorer Class
ReportExplorer Members


RectangleToScreen Method (ReportExplorer)

RectangleToScreen Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : RectangleToScreen Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function RectangleToScreen( _
   ByVal r As Rectangle _
) As Rectangle
public Rectangle RectangleToScreen(
   Rectangle r
)

Parameters

r
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Refresh Method (ReportExplorer)

Refresh Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Refresh Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub Refresh()
public virtual void Refresh()
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Region Property (ReportExplorer)

Region Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Region Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Region As Region
public Region Region {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


RegionChanged Event (ReportExplorer)

RegionChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : RegionChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event RegionChanged As System.EventHandler
public event System.EventHandler RegionChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ResetText Method (ReportExplorer)

ResetText Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ResetText Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub ResetText()
public virtual void ResetText()
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Resize Event (ReportExplorer)

Resize Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Resize Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Resize As System.EventHandler
public event System.EventHandler Resize
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ResumeLayout Method (ReportExplorer)

ResumeLayout Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ResumeLayout Method
Overload List
Overload | Description
ResumeLayout() | (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ResumeLayout() Method

ResumeLayout() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > ResumeLayout Method : ResumeLayout() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ResumeLayout()
public void ResumeLayout()
See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


ResumeLayout(Boolean) Method

ResumeLayout(Boolean) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > ResumeLayout Method : ResumeLayout(Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ResumeLayout( _
   ByVal performLayout As System.Boolean _
)
public void ResumeLayout(
   System.bool performLayout
)

Parameters

performLayout
See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


Right Property (ReportExplorer)

Right Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Right Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Right As System.Integer
public System.int Right {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


RightToLeft Property (ReportExplorer)

RightToLeft Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : RightToLeft Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property RightToLeft As System.Windows.Forms.RightToLeft
public virtual System.Windows.Forms.RightToLeft RightToLeft {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


RightToLeftChanged Event (ReportExplorer)

RightToLeftChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : RightToLeftChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event RightToLeftChanged As System.EventHandler
public event System.EventHandler RightToLeftChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Scale Method (ReportExplorer)

Scale Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Scale Method
Overload List
Overload | Description
Scale | (Inherited from System.Windows.Forms.Control)
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Scale(SizeF) Method

Scale(SizeF) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > Scale Method : Scale(SizeF) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Scale( _
   ByVal factor As SizeF _
)
public void Scale(
   SizeF factor
)

Parameters

factor
See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


Scroll Event (ReportExplorer)

Scroll Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Scroll Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Scroll As System.Windows.Forms.ScrollEventHandler
public event System.Windows.Forms.ScrollEventHandler Scroll
Event Data

The event handler receives an argument of type System.Windows.Forms.ScrollEventArgs containing data related to this event. The following ScrollEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets or sets the new System.Windows.Forms.ScrollBar.Value of the scroll bar.
OldValue | Gets the old System.Windows.Forms.ScrollBar.Value of the scroll bar.
ScrollOrientation | Gets the scroll bar orientation that raised the Scroll event.
Type | Gets the type of scroll event that occurred.
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ScrollControlIntoView Method (ReportExplorer)

ScrollControlIntoView Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ScrollControlIntoView Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ScrollControlIntoView( _
   ByVal activeControl As System.Windows.Forms.Control _
)
public void ScrollControlIntoView(
   System.Windows.Forms.Control activeControl
)

Parameters

activeControl
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Select Method (ReportExplorer)

Select Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Select Method
Overload List
Overload | Description
Select | (Inherited from System.Windows.Forms.Control)
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Select() Method

Select() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Select() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Select()
public void Select()
See Also

Reference

ReportExplorer Class
ReportExplorer Members


SelectNextControl Method (ReportExplorer)

SelectNextControl Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : SelectNextControl Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function SelectNextControl( _
   ByVal ctl As System.Windows.Forms.Control, _
   ByVal forward As System.Boolean, _
   ByVal tabStopOnly As System.Boolean, _
   ByVal nested As System.Boolean, _
   ByVal wrap As System.Boolean _
) As System.Boolean
public System.bool SelectNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)

Parameters

ctl
forward
tabStopOnly
nested
wrap
See Also

Reference

ReportExplorer Class
ReportExplorer Members


SendToBack Method (ReportExplorer)

SendToBack Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : SendToBack Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SendToBack()
public void SendToBack()
See Also

Reference

ReportExplorer Class
ReportExplorer Members


SetAutoScrollMargin Method (ReportExplorer)

SetAutoScrollMargin Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : SetAutoScrollMargin Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetAutoScrollMargin( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer _
)
public void SetAutoScrollMargin(
   System.int x,
   System.int y
)

Parameters

x
y
See Also

Reference

ReportExplorer Class
ReportExplorer Members


SetBounds Method (ReportExplorer)

SetBounds Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : SetBounds Method
Overload List
Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

ReportExplorer Class
ReportExplorer Members


SetBounds(Int32,Int32,Int32,Int32) Method

SetBounds(Int32,Int32,Int32,Int32) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer _
)
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

x
y
width
height
See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer, _
   ByVal specified As System.Windows.Forms.BoundsSpecified _
)
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)

Parameters

x
y
width
height
specified
See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


Show Method (ReportExplorer)

Show Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Show Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Show()
public void Show()
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Site Property (ReportExplorer)

Site Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
public virtual System.ComponentModel.ISite Site {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Size Property (ReportExplorer)

Size Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Size Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Size As Size
public Size Size {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


SizeChanged Event (ReportExplorer)

SizeChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : SizeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event SizeChanged As System.EventHandler
public event System.EventHandler SizeChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


StyleChanged Event (ReportExplorer)

StyleChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : StyleChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event StyleChanged As System.EventHandler
public event System.EventHandler StyleChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


SuspendLayout Method (ReportExplorer)

SuspendLayout Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : SuspendLayout Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SuspendLayout()
public void SuspendLayout()
See Also

Reference

ReportExplorer Class
ReportExplorer Members


SystemColorsChanged Event (ReportExplorer)

SystemColorsChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : SystemColorsChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event SystemColorsChanged As System.EventHandler
public event System.EventHandler SystemColorsChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


TabIndex Property (ReportExplorer)

TabIndex Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : TabIndex Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TabIndex As System.Integer
public System.int TabIndex {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


TabIndexChanged Event (ReportExplorer)

TabIndexChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : TabIndexChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TabIndexChanged As System.EventHandler
public event System.EventHandler TabIndexChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


TabStop Property (ReportExplorer)

TabStop Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : TabStop Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TabStop As System.Boolean
public System.bool TabStop {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


TabStopChanged Event (ReportExplorer)

TabStopChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : TabStopChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TabStopChanged As System.EventHandler
public event System.EventHandler TabStopChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Tag Property (ReportExplorer)

Tag Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Tag Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Tag As System.Object
public System.object Tag {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Top Property (ReportExplorer)

Top Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Top Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Top As System.Integer
public System.int Top {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


TopLevelControl Property (ReportExplorer)

TopLevelControl Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : TopLevelControl Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TopLevelControl As System.Windows.Forms.Control
public System.Windows.Forms.Control TopLevelControl {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ToString Method (ReportExplorer)

ToString Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Update Method (ReportExplorer)

Update Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Update Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Update()
public void Update()
See Also

Reference

ReportExplorer Class
ReportExplorer Members


UseWaitCursor Property (ReportExplorer)

UseWaitCursor Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : UseWaitCursor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseWaitCursor As System.Boolean
public System.bool UseWaitCursor {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Validate Method (ReportExplorer)

Validate Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Validate Method
Overload List
Overload | Description
Validate() | (Inherited from System.Windows.Forms.ContainerControl)
Validate(Boolean) | (Inherited from System.Windows.Forms.ContainerControl)
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Validate() Method

Validate() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > Validate Method : Validate() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Validate() As System.Boolean
public System.bool Validate()
See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


Validate(Boolean) Method

Validate(Boolean) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > Validate Method : Validate(Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Validate( _
   ByVal checkAutoValidate As System.Boolean _
) As System.Boolean
public System.bool Validate(
   System.bool checkAutoValidate
)

Parameters

checkAutoValidate
See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


ValidateChildren Method (ReportExplorer)

ValidateChildren Method (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : ValidateChildren Method
Overload List
Overload | Description
ValidateChildren() | (Inherited from System.Windows.Forms.UserControl)
ValidateChildren(ValidationConstraints) | (Inherited from System.Windows.Forms.UserControl)
See Also

Reference

ReportExplorer Class
ReportExplorer Members


ValidateChildren() Method

ValidateChildren() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > ValidateChildren Method : ValidateChildren() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overridable Function ValidateChildren() As System.Boolean
public virtual System.bool ValidateChildren()
See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


ValidateChildren(ValidationConstraints) Method

ValidateChildren(ValidationConstraints) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class > ValidateChildren Method : ValidateChildren(ValidationConstraints) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overridable Function ValidateChildren( _
   ByVal validationConstraints As System.Windows.Forms.ValidationConstraints _
) As System.Boolean
public virtual System.bool ValidateChildren(
   System.Windows.Forms.ValidationConstraints validationConstraints
)

Parameters

validationConstraints
See Also

Reference

ReportExplorer Class
ReportExplorer Members
Overload List


Validated Event (ReportExplorer)

Validated Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Validated Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Validated As System.EventHandler
public event System.EventHandler Validated
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Validating Event (ReportExplorer)

Validating Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Validating Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Validating As System.ComponentModel.CancelEventHandler
public event System.ComponentModel.CancelEventHandler Validating
Event Data

The event handler receives an argument of type System.ComponentModel.CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |
See Also

Reference

ReportExplorer Class
ReportExplorer Members


VerticalScroll Property (ReportExplorer)

VerticalScroll Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : VerticalScroll Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property VerticalScroll As System.Windows.Forms.VScrollProperties
public System.Windows.Forms.VScrollProperties VerticalScroll {get;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Visible Property (ReportExplorer)

Visible Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Visible Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


VisibleChanged Event (ReportExplorer)

VisibleChanged Event (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : VisibleChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event VisibleChanged As System.EventHandler
public event System.EventHandler VisibleChanged
See Also

Reference

ReportExplorer Class
ReportExplorer Members


Width Property (ReportExplorer)

Width Property (ReportExplorer)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.ReportExplorer Namespace > ReportExplorer Class : Width Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As System.Integer
public System.int Width {get; set;}
See Also

Reference

ReportExplorer Class
ReportExplorer Members


GrapeCity.ActiveReports.Design.ReportExplorer Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Design.ReportExplorer Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Design.Win.v10 Assembly : GrapeCity.ActiveReports.Design.ReportExplorer Namespace
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
GrapeCity.ActiveReports.Design.ReportExplorer.ReportExplorer
See Also

Reference

GrapeCity.ActiveReports.Design.Win.v10 Assembly


Group Class Events

Group Class Events

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : Group Class

For a list of all members of this type, see Group members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Group Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


Group Class Methods

Group Class Methods

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : Group Class

For a list of all members of this type, see Group members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Group Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


Container Property (Group)

Container Property (Group)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Group Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

Group Class
Group Members


CreateObjRef Method (Group)

CreateObjRef Method (Group)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Group Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

Group Class
Group Members


Dispose Method (Group)

Dispose Method (Group)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Group Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

Group Class
Group Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Group Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Group Class
Group Members


Disposed Event (Group)

Disposed Event (Group)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Group Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Group Class
Group Members


GetLifetimeService Method (Group)

GetLifetimeService Method (Group)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Group Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

Group Class
Group Members


InitializeLifetimeService Method (Group)

InitializeLifetimeService Method (Group)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Group Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

Group Class
Group Members


Site Property (Group)

Site Property (Group)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Group Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

Group Class
Group Members


ToString Method (Group)

ToString Method (Group)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Group Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

Group Class
Group Members


Toolbox Class Events

Toolbox Class Events

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace : Toolbox Class

For a list of all members of this type, see Toolbox members.

Public Events
 | Name | Description
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.UserControl)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.UserControl)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top
See Also

Reference

Toolbox Class
GrapeCity.ActiveReports.Design.Toolbox Namespace


Toolbox Constructor

Toolbox Constructor

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Toolbox Constructor
Overload List
Overload | Description
Toolbox Constructor | Initializes a new instance of the Toolbox class.
See Also

Reference

Toolbox Class
Toolbox Members


AccessibilityObject Property (Toolbox)

AccessibilityObject Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AccessibilityObject Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property AccessibilityObject As System.Windows.Forms.AccessibleObject
public System.Windows.Forms.AccessibleObject AccessibilityObject {get;}
See Also

Reference

Toolbox Class
Toolbox Members


AccessibleDefaultActionDescription Property (Toolbox)

AccessibleDefaultActionDescription Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AccessibleDefaultActionDescription Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AccessibleDefaultActionDescription As System.String
public System.string AccessibleDefaultActionDescription {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


AccessibleDescription Property (Toolbox)

AccessibleDescription Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AccessibleDescription Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AccessibleDescription As System.String
public System.string AccessibleDescription {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


AccessibleName Property (Toolbox)

AccessibleName Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AccessibleName Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AccessibleName As System.String
public System.string AccessibleName {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


AccessibleRole Property (Toolbox)

AccessibleRole Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AccessibleRole Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AccessibleRole As System.Windows.Forms.AccessibleRole
public System.Windows.Forms.AccessibleRole AccessibleRole {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


ActiveControl Property (Toolbox)

ActiveControl Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ActiveControl Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ActiveControl As System.Windows.Forms.Control
public System.Windows.Forms.Control ActiveControl {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


AllowDrop Property (Toolbox)

AllowDrop Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AllowDrop Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AllowDrop As System.Boolean
public System.bool AllowDrop {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


Anchor Property (Toolbox)

Anchor Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Anchor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Anchor As System.Windows.Forms.AnchorStyles
public System.Windows.Forms.AnchorStyles Anchor {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


AutoScaleDimensions Property (Toolbox)

AutoScaleDimensions Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AutoScaleDimensions Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScaleDimensions As SizeF
public SizeF AutoScaleDimensions {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


AutoScaleMode Property (Toolbox)

AutoScaleMode Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AutoScaleMode Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScaleMode As System.Windows.Forms.AutoScaleMode
public System.Windows.Forms.AutoScaleMode AutoScaleMode {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


AutoScroll Property (Toolbox)

AutoScroll Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AutoScroll Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScroll As System.Boolean
public System.bool AutoScroll {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


AutoScrollMargin Property (Toolbox)

AutoScrollMargin Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AutoScrollMargin Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScrollMargin As Size
public Size AutoScrollMargin {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


AutoScrollMinSize Property (Toolbox)

AutoScrollMinSize Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AutoScrollMinSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScrollMinSize As Size
public Size AutoScrollMinSize {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


AutoScrollOffset Property (Toolbox)

AutoScrollOffset Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AutoScrollOffset Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScrollOffset As Point
public Point AutoScrollOffset {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


AutoScrollPosition Property (Toolbox)

AutoScrollPosition Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AutoScrollPosition Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScrollPosition As Point
public Point AutoScrollPosition {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


AutoSize Property (Toolbox)

AutoSize Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AutoSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoSize As System.Boolean
public System.bool AutoSize {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


AutoSizeChanged Event (Toolbox)

AutoSizeChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AutoSizeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event AutoSizeChanged As System.EventHandler
public event System.EventHandler AutoSizeChanged
See Also

Reference

Toolbox Class
Toolbox Members


AutoSizeMode Property (Toolbox)

AutoSizeMode Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AutoSizeMode Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoSizeMode As System.Windows.Forms.AutoSizeMode
public System.Windows.Forms.AutoSizeMode AutoSizeMode {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


AutoValidate Property (Toolbox)

AutoValidate Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AutoValidate Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoValidate As System.Windows.Forms.AutoValidate
public System.Windows.Forms.AutoValidate AutoValidate {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


AutoValidateChanged Event (Toolbox)

AutoValidateChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : AutoValidateChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event AutoValidateChanged As System.EventHandler
public event System.EventHandler AutoValidateChanged
See Also

Reference

Toolbox Class
Toolbox Members


BackColor Property (Toolbox)

BackColor Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : BackColor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackColor As Color
public Color BackColor {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


BackColorChanged Event (Toolbox)

BackColorChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : BackColorChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BackColorChanged As System.EventHandler
public event System.EventHandler BackColorChanged
See Also

Reference

Toolbox Class
Toolbox Members


BackgroundImage Property (Toolbox)

BackgroundImage Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : BackgroundImage Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackgroundImage As Image
public Image BackgroundImage {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


BackgroundImageChanged Event (Toolbox)

BackgroundImageChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : BackgroundImageChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BackgroundImageChanged As System.EventHandler
public event System.EventHandler BackgroundImageChanged
See Also

Reference

Toolbox Class
Toolbox Members


BackgroundImageLayout Property (Toolbox)

BackgroundImageLayout Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : BackgroundImageLayout Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BackgroundImageLayout As System.Windows.Forms.ImageLayout
public System.Windows.Forms.ImageLayout BackgroundImageLayout {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


BackgroundImageLayoutChanged Event (Toolbox)

BackgroundImageLayoutChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : BackgroundImageLayoutChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BackgroundImageLayoutChanged As System.EventHandler
public event System.EventHandler BackgroundImageLayoutChanged
See Also

Reference

Toolbox Class
Toolbox Members


BeginInvoke Method (Toolbox)

BeginInvoke Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : BeginInvoke Method
Overload List
Overload | Description
BeginInvoke(Delegate) | (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Toolbox Class
Toolbox Members


BeginInvoke(Delegate) Method

BeginInvoke(Delegate) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > BeginInvoke Method : BeginInvoke(Delegate) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function BeginInvoke( _
   ByVal method As System.Delegate _
) As System.IAsyncResult
public System.IAsyncResult BeginInvoke(
   System.Delegate method
)

Parameters

method
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


BeginInvoke(Delegate,Object[]) Method

BeginInvoke(Delegate,Object[]) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function BeginInvoke( _
   ByVal method As System.Delegate, _
   ByVal ParamArray args() As System.Object _
) As System.IAsyncResult
public System.IAsyncResult BeginInvoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
args
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


BindingContext Property (Toolbox)

BindingContext Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : BindingContext Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BindingContext As System.Windows.Forms.BindingContext
public System.Windows.Forms.BindingContext BindingContext {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


BindingContextChanged Event (Toolbox)

BindingContextChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : BindingContextChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BindingContextChanged As System.EventHandler
public event System.EventHandler BindingContextChanged
See Also

Reference

Toolbox Class
Toolbox Members


Bottom Property (Toolbox)

Bottom Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Bottom Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Bottom As System.Integer
public System.int Bottom {get;}
See Also

Reference

Toolbox Class
Toolbox Members


Bounds Property (Toolbox)

Bounds Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Bounds Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Bounds As Rectangle
public Rectangle Bounds {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


BringToFront Method (Toolbox)

BringToFront Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : BringToFront Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub BringToFront()
public void BringToFront()
See Also

Reference

Toolbox Class
Toolbox Members


CanFocus Property (Toolbox)

CanFocus Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : CanFocus Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CanFocus As System.Boolean
public System.bool CanFocus {get;}
See Also

Reference

Toolbox Class
Toolbox Members


CanSelect Property (Toolbox)

CanSelect Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : CanSelect Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CanSelect As System.Boolean
public System.bool CanSelect {get;}
See Also

Reference

Toolbox Class
Toolbox Members


Capture Property (Toolbox)

Capture Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Capture Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capture As System.Boolean
public System.bool Capture {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


CausesValidation Property (Toolbox)

CausesValidation Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : CausesValidation Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CausesValidation As System.Boolean
public System.bool CausesValidation {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


CausesValidationChanged Event (Toolbox)

CausesValidationChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : CausesValidationChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event CausesValidationChanged As System.EventHandler
public event System.EventHandler CausesValidationChanged
See Also

Reference

Toolbox Class
Toolbox Members


ChangeUICues Event (Toolbox)

ChangeUICues Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ChangeUICues Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ChangeUICues As System.Windows.Forms.UICuesEventHandler
public event System.Windows.Forms.UICuesEventHandler ChangeUICues
Event Data

The event handler receives an argument of type System.Windows.Forms.UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.
See Also

Reference

Toolbox Class
Toolbox Members


Click Event (Toolbox)

Click Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Click Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Click As System.EventHandler
public event System.EventHandler Click
See Also

Reference

Toolbox Class
Toolbox Members


ClientRectangle Property (Toolbox)

ClientRectangle Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ClientRectangle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ClientRectangle As Rectangle
public Rectangle ClientRectangle {get;}
See Also

Reference

Toolbox Class
Toolbox Members


ClientSize Property (Toolbox)

ClientSize Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ClientSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ClientSize As Size
public Size ClientSize {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


ClientSizeChanged Event (Toolbox)

ClientSizeChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ClientSizeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ClientSizeChanged As System.EventHandler
public event System.EventHandler ClientSizeChanged
See Also

Reference

Toolbox Class
Toolbox Members


CompanyName Property (Toolbox)

CompanyName Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : CompanyName Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CompanyName As System.String
public System.string CompanyName {get;}
See Also

Reference

Toolbox Class
Toolbox Members


Container Property (Toolbox)

Container Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

Toolbox Class
Toolbox Members


Contains Method (Toolbox)

Contains Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Contains Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal ctl As System.Windows.Forms.Control _
) As System.Boolean
public System.bool Contains(
   System.Windows.Forms.Control ctl
)

Parameters

ctl
See Also

Reference

Toolbox Class
Toolbox Members


ContainsFocus Property (Toolbox)

ContainsFocus Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ContainsFocus Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ContainsFocus As System.Boolean
public System.bool ContainsFocus {get;}
See Also

Reference

Toolbox Class
Toolbox Members


ContextMenu Property (Toolbox)

ContextMenu Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ContextMenu Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ContextMenu As System.Windows.Forms.ContextMenu
public System.Windows.Forms.ContextMenu ContextMenu {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


ContextMenuChanged Event (Toolbox)

ContextMenuChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ContextMenuChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ContextMenuChanged As System.EventHandler
public event System.EventHandler ContextMenuChanged
See Also

Reference

Toolbox Class
Toolbox Members


ContextMenuStrip Property (Toolbox)

ContextMenuStrip Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ContextMenuStrip Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ContextMenuStrip As System.Windows.Forms.ContextMenuStrip
public System.Windows.Forms.ContextMenuStrip ContextMenuStrip {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


ContextMenuStripChanged Event (Toolbox)

ContextMenuStripChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ContextMenuStripChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ContextMenuStripChanged As System.EventHandler
public event System.EventHandler ContextMenuStripChanged
See Also

Reference

Toolbox Class
Toolbox Members


ControlAdded Event (Toolbox)

ControlAdded Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ControlAdded Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ControlAdded As System.Windows.Forms.ControlEventHandler
public event System.Windows.Forms.ControlEventHandler ControlAdded
Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.
See Also

Reference

Toolbox Class
Toolbox Members


ControlRemoved Event (Toolbox)

ControlRemoved Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ControlRemoved Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ControlRemoved As System.Windows.Forms.ControlEventHandler
public event System.Windows.Forms.ControlEventHandler ControlRemoved
Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.
See Also

Reference

Toolbox Class
Toolbox Members


Controls Property (Toolbox)

Controls Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Controls Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Controls As System.Windows.Forms.Control.ControlCollection
public System.Windows.Forms.Control.ControlCollection Controls {get;}
See Also

Reference

Toolbox Class
Toolbox Members


CreateControl Method (Toolbox)

CreateControl Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : CreateControl Method
Overload List
Overload | Description
CreateControl | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Toolbox Class
Toolbox Members


CreateControl() Method

CreateControl() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : CreateControl() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CreateControl()
public void CreateControl()
See Also

Reference

Toolbox Class
Toolbox Members


Created Property (Toolbox)

Created Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Created Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Created As System.Boolean
public System.bool Created {get;}
See Also

Reference

Toolbox Class
Toolbox Members


CreateGraphics Method (Toolbox)

CreateGraphics Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : CreateGraphics Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateGraphics() As Graphics
public Graphics CreateGraphics()
See Also

Reference

Toolbox Class
Toolbox Members


CreateObjRef Method (Toolbox)

CreateObjRef Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

Toolbox Class
Toolbox Members


CurrentAutoScaleDimensions Property (Toolbox)

CurrentAutoScaleDimensions Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : CurrentAutoScaleDimensions Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CurrentAutoScaleDimensions As SizeF
public SizeF CurrentAutoScaleDimensions {get;}
See Also

Reference

Toolbox Class
Toolbox Members


Cursor Property (Toolbox)

Cursor Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Cursor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Cursor As System.Windows.Forms.Cursor
public System.Windows.Forms.Cursor Cursor {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


CursorChanged Event (Toolbox)

CursorChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : CursorChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event CursorChanged As System.EventHandler
public event System.EventHandler CursorChanged
See Also

Reference

Toolbox Class
Toolbox Members


DataBindings Property (Toolbox)

DataBindings Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DataBindings Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DataBindings As System.Windows.Forms.ControlBindingsCollection
public System.Windows.Forms.ControlBindingsCollection DataBindings {get;}
See Also

Reference

Toolbox Class
Toolbox Members


DisplayRectangle Property (Toolbox)

DisplayRectangle Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DisplayRectangle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DisplayRectangle As Rectangle
public Rectangle DisplayRectangle {get;}
See Also

Reference

Toolbox Class
Toolbox Members


Dispose Method (Toolbox)

Dispose Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Dispose Method
Clean up any CommonResources being used.
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

Toolbox Class
Toolbox Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Toolbox Class
Toolbox Members


Disposed Event (Toolbox)

Disposed Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Toolbox Class
Toolbox Members


Disposing Property (Toolbox)

Disposing Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Disposing Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Disposing As System.Boolean
public System.bool Disposing {get;}
See Also

Reference

Toolbox Class
Toolbox Members


DockChanged Event (Toolbox)

DockChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DockChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DockChanged As System.EventHandler
public event System.EventHandler DockChanged
See Also

Reference

Toolbox Class
Toolbox Members


DoDragDrop Method (Toolbox)

DoDragDrop Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DoDragDrop Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function DoDragDrop( _
   ByVal data As System.Object, _
   ByVal allowedEffects As System.Windows.Forms.DragDropEffects _
) As System.Windows.Forms.DragDropEffects
public System.Windows.Forms.DragDropEffects DoDragDrop(
   System.object data,
   System.Windows.Forms.DragDropEffects allowedEffects
)

Parameters

data
allowedEffects
See Also

Reference

Toolbox Class
Toolbox Members


DoubleClick Event (Toolbox)

DoubleClick Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DoubleClick Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DoubleClick As System.EventHandler
public event System.EventHandler DoubleClick
See Also

Reference

Toolbox Class
Toolbox Members


DragDrop Event (Toolbox)

DragDrop Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DragDrop Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragDrop As System.Windows.Forms.DragEventHandler
public event System.Windows.Forms.DragEventHandler DragDrop
Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.
See Also

Reference

Toolbox Class
Toolbox Members


DragEnter Event (Toolbox)

DragEnter Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DragEnter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragEnter As System.Windows.Forms.DragEventHandler
public event System.Windows.Forms.DragEventHandler DragEnter
Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.
See Also

Reference

Toolbox Class
Toolbox Members


DragLeave Event (Toolbox)

DragLeave Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DragLeave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragLeave As System.EventHandler
public event System.EventHandler DragLeave
See Also

Reference

Toolbox Class
Toolbox Members


DragOver Event (Toolbox)

DragOver Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DragOver Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragOver As System.Windows.Forms.DragEventHandler
public event System.Windows.Forms.DragEventHandler DragOver
Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.
See Also

Reference

Toolbox Class
Toolbox Members


DrawToBitmap Method (Toolbox)

DrawToBitmap Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : DrawToBitmap Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub DrawToBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal targetBounds As Rectangle _
)
public void DrawToBitmap(
   Bitmap bitmap,
   Rectangle targetBounds
)

Parameters

bitmap
targetBounds
See Also

Reference

Toolbox Class
Toolbox Members


Enabled Property (Toolbox)

Enabled Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Enabled Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Enabled As System.Boolean
public System.bool Enabled {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


EnabledChanged Event (Toolbox)

EnabledChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : EnabledChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event EnabledChanged As System.EventHandler
public event System.EventHandler EnabledChanged
See Also

Reference

Toolbox Class
Toolbox Members


EndInvoke Method (Toolbox)

EndInvoke Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : EndInvoke Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function EndInvoke( _
   ByVal asyncResult As System.IAsyncResult _
) As System.Object
public System.object EndInvoke(
   System.IAsyncResult asyncResult
)

Parameters

asyncResult
See Also

Reference

Toolbox Class
Toolbox Members


Enter Event (Toolbox)

Enter Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Enter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Enter As System.EventHandler
public event System.EventHandler Enter
See Also

Reference

Toolbox Class
Toolbox Members


FindForm Method (Toolbox)

FindForm Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : FindForm Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function FindForm() As System.Windows.Forms.Form
public System.Windows.Forms.Form FindForm()
See Also

Reference

Toolbox Class
Toolbox Members


Focus Method (Toolbox)

Focus Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Focus Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Focus() As System.Boolean
public System.bool Focus()
See Also

Reference

Toolbox Class
Toolbox Members


Focused Property (Toolbox)

Focused Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Focused Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Focused As System.Boolean
public System.bool Focused {get;}
See Also

Reference

Toolbox Class
Toolbox Members


Font Property (Toolbox)

Font Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Font Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Font As Font
public Font Font {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


FontChanged Event (Toolbox)

FontChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : FontChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event FontChanged As System.EventHandler
public event System.EventHandler FontChanged
See Also

Reference

Toolbox Class
Toolbox Members


ForeColor Property (Toolbox)

ForeColor Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ForeColor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ForeColor As Color
public Color ForeColor {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


ForeColorChanged Event (Toolbox)

ForeColorChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ForeColorChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ForeColorChanged As System.EventHandler
public event System.EventHandler ForeColorChanged
See Also

Reference

Toolbox Class
Toolbox Members


GetChildAtPoint Method (Toolbox)

GetChildAtPoint Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : GetChildAtPoint Method
Overload List
Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Toolbox Class
Toolbox Members


GetChildAtPoint(Point) Method

GetChildAtPoint(Point) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point _
) As System.Windows.Forms.Control
public System.Windows.Forms.Control GetChildAtPoint(
   Point pt
)

Parameters

pt
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


GetChildAtPoint(Point,GetChildAtPointSkip) Method

GetChildAtPoint(Point,GetChildAtPointSkip) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point, _
   ByVal skipValue As System.Windows.Forms.GetChildAtPointSkip _
) As System.Windows.Forms.Control
public System.Windows.Forms.Control GetChildAtPoint(
   Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)

Parameters

pt
skipValue
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


GetContainerControl Method (Toolbox)

GetContainerControl Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : GetContainerControl Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetContainerControl() As System.Windows.Forms.IContainerControl
public System.Windows.Forms.IContainerControl GetContainerControl()
See Also

Reference

Toolbox Class
Toolbox Members


GetLifetimeService Method (Toolbox)

GetLifetimeService Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

Toolbox Class
Toolbox Members


GetNextControl Method (Toolbox)

GetNextControl Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : GetNextControl Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetNextControl( _
   ByVal ctl As System.Windows.Forms.Control, _
   ByVal forward As System.Boolean _
) As System.Windows.Forms.Control
public System.Windows.Forms.Control GetNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward
)

Parameters

ctl
forward
See Also

Reference

Toolbox Class
Toolbox Members


GetPreferredSize Method (Toolbox)

GetPreferredSize Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : GetPreferredSize Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetPreferredSize( _
   ByVal proposedSize As Size _
) As Size
public Size GetPreferredSize(
   Size proposedSize
)

Parameters

proposedSize
See Also

Reference

Toolbox Class
Toolbox Members


GiveFeedback Event (Toolbox)

GiveFeedback Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : GiveFeedback Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event GiveFeedback As System.Windows.Forms.GiveFeedbackEventHandler
public event System.Windows.Forms.GiveFeedbackEventHandler GiveFeedback
Event Data

The event handler receives an argument of type System.Windows.Forms.GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.
See Also

Reference

Toolbox Class
Toolbox Members


GotFocus Event (Toolbox)

GotFocus Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : GotFocus Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event GotFocus As System.EventHandler
public event System.EventHandler GotFocus
See Also

Reference

Toolbox Class
Toolbox Members


Handle Property (Toolbox)

Handle Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Handle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Handle As System.IntPtr
public System.IntPtr Handle {get;}
See Also

Reference

Toolbox Class
Toolbox Members


HandleCreated Event (Toolbox)

HandleCreated Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : HandleCreated Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event HandleCreated As System.EventHandler
public event System.EventHandler HandleCreated
See Also

Reference

Toolbox Class
Toolbox Members


HandleDestroyed Event (Toolbox)

HandleDestroyed Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : HandleDestroyed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event HandleDestroyed As System.EventHandler
public event System.EventHandler HandleDestroyed
See Also

Reference

Toolbox Class
Toolbox Members


HasChildren Property (Toolbox)

HasChildren Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : HasChildren Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HasChildren As System.Boolean
public System.bool HasChildren {get;}
See Also

Reference

Toolbox Class
Toolbox Members


Height Property (Toolbox)

Height Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Height Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As System.Integer
public System.int Height {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


HelpRequested Event (Toolbox)

HelpRequested Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : HelpRequested Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event HelpRequested As System.Windows.Forms.HelpEventHandler
public event System.Windows.Forms.HelpEventHandler HelpRequested
Event Data

The event handler receives an argument of type System.Windows.Forms.HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.
See Also

Reference

Toolbox Class
Toolbox Members


Hide Method (Toolbox)

Hide Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Hide Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Hide()
public void Hide()
See Also

Reference

Toolbox Class
Toolbox Members


HorizontalScroll Property (Toolbox)

HorizontalScroll Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : HorizontalScroll Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HorizontalScroll As System.Windows.Forms.HScrollProperties
public System.Windows.Forms.HScrollProperties HorizontalScroll {get;}
See Also

Reference

Toolbox Class
Toolbox Members


ImeMode Property (Toolbox)

ImeMode Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ImeMode Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ImeMode As System.Windows.Forms.ImeMode
public System.Windows.Forms.ImeMode ImeMode {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


ImeModeChanged Event (Toolbox)

ImeModeChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ImeModeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ImeModeChanged As System.EventHandler
public event System.EventHandler ImeModeChanged
See Also

Reference

Toolbox Class
Toolbox Members


InitializeLifetimeService Method (Toolbox)

InitializeLifetimeService Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

Toolbox Class
Toolbox Members


Invalidate Method (Toolbox)

Invalidate Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Invalidate Method
Overload List
Overload | Description
Invalidate(Region) | (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | (Inherited from System.Windows.Forms.Control)
Invalidate() | (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Toolbox Class
Toolbox Members


Invalidate() Method

Invalidate() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > Invalidate Method : Invalidate() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate()
public void Invalidate()
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


Invalidate(Boolean) Method

Invalidate(Boolean) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > Invalidate Method : Invalidate(Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal invalidateChildren As System.Boolean _
)
public void Invalidate(
   System.bool invalidateChildren
)

Parameters

invalidateChildren
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


Invalidate(Rectangle) Method

Invalidate(Rectangle) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > Invalidate Method : Invalidate(Rectangle) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle _
)
public void Invalidate(
   Rectangle rc
)

Parameters

rc
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


Invalidate(Rectangle,Boolean) Method

Invalidate(Rectangle,Boolean) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle, _
   ByVal invalidateChildren As System.Boolean _
)
public void Invalidate(
   Rectangle rc,
   System.bool invalidateChildren
)

Parameters

rc
invalidateChildren
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


Invalidate(Region) Method

Invalidate(Region) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > Invalidate Method : Invalidate(Region) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal region As Region _
)
public void Invalidate(
   Region region
)

Parameters

region
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


Invalidate(Region,Boolean) Method

Invalidate(Region,Boolean) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > Invalidate Method : Invalidate(Region,Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal region As Region, _
   ByVal invalidateChildren As System.Boolean _
)
public void Invalidate(
   Region region,
   System.bool invalidateChildren
)

Parameters

region
invalidateChildren
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


Invalidated Event (Toolbox)

Invalidated Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Invalidated Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Invalidated As System.Windows.Forms.InvalidateEventHandler
public event System.Windows.Forms.InvalidateEventHandler Invalidated
Event Data

The event handler receives an argument of type System.Windows.Forms.InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.
See Also

Reference

Toolbox Class
Toolbox Members


Invoke Method (Toolbox)

Invoke Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Invoke Method
Overload List
Overload | Description
Invoke(Delegate) | (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Toolbox Class
Toolbox Members


Invoke(Delegate) Method

Invoke(Delegate) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > Invoke Method : Invoke(Delegate) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Invoke( _
   ByVal method As System.Delegate _
) As System.Object
public System.object Invoke(
   System.Delegate method
)

Parameters

method
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


Invoke(Delegate,Object[]) Method

Invoke(Delegate,Object[]) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > Invoke Method : Invoke(Delegate,Object[]) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Invoke( _
   ByVal method As System.Delegate, _
   ByVal ParamArray args() As System.Object _
) As System.Object
public System.object Invoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
args
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


InvokeRequired Property (Toolbox)

InvokeRequired Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : InvokeRequired Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InvokeRequired As System.Boolean
public System.bool InvokeRequired {get;}
See Also

Reference

Toolbox Class
Toolbox Members


IsAccessible Property (Toolbox)

IsAccessible Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : IsAccessible Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsAccessible As System.Boolean
public System.bool IsAccessible {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


IsDisposed Property (Toolbox)

IsDisposed Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : IsDisposed Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsDisposed As System.Boolean
public System.bool IsDisposed {get;}
See Also

Reference

Toolbox Class
Toolbox Members


IsHandleCreated Property (Toolbox)

IsHandleCreated Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : IsHandleCreated Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsHandleCreated As System.Boolean
public System.bool IsHandleCreated {get;}
See Also

Reference

Toolbox Class
Toolbox Members


IsMirrored Property (Toolbox)

IsMirrored Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : IsMirrored Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsMirrored As System.Boolean
public System.bool IsMirrored {get;}
See Also

Reference

Toolbox Class
Toolbox Members


KeyDown Event (Toolbox)

KeyDown Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : KeyDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event KeyDown As System.Windows.Forms.KeyEventHandler
public event System.Windows.Forms.KeyEventHandler KeyDown
Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.
See Also

Reference

Toolbox Class
Toolbox Members


KeyPress Event (Toolbox)

KeyPress Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : KeyPress Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event KeyPress As System.Windows.Forms.KeyPressEventHandler
public event System.Windows.Forms.KeyPressEventHandler KeyPress
Event Data

The event handler receives an argument of type System.Windows.Forms.KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.
See Also

Reference

Toolbox Class
Toolbox Members


KeyUp Event (Toolbox)

KeyUp Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : KeyUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event KeyUp As System.Windows.Forms.KeyEventHandler
public event System.Windows.Forms.KeyEventHandler KeyUp
Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.
See Also

Reference

Toolbox Class
Toolbox Members


Layout Event (Toolbox)

Layout Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Layout Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Layout As System.Windows.Forms.LayoutEventHandler
public event System.Windows.Forms.LayoutEventHandler Layout
Event Data

The event handler receives an argument of type System.Windows.Forms.LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.
See Also

Reference

Toolbox Class
Toolbox Members


LayoutEngine Property (Toolbox)

LayoutEngine Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : LayoutEngine Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property LayoutEngine As System.Windows.Forms.Layout.LayoutEngine
public System.Windows.Forms.Layout.LayoutEngine LayoutEngine {get;}
See Also

Reference

Toolbox Class
Toolbox Members


Leave Event (Toolbox)

Leave Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Leave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Leave As System.EventHandler
public event System.EventHandler Leave
See Also

Reference

Toolbox Class
Toolbox Members


Left Property (Toolbox)

Left Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Left Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Left As System.Integer
public System.int Left {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


Load Event (Toolbox)

Load Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Load Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Load As System.EventHandler
public event System.EventHandler Load
See Also

Reference

Toolbox Class
Toolbox Members


Location Property (Toolbox)

Location Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Location Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Location As Point
public Point Location {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


LocationChanged Event (Toolbox)

LocationChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : LocationChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LocationChanged As System.EventHandler
public event System.EventHandler LocationChanged
See Also

Reference

Toolbox Class
Toolbox Members


LostFocus Event (Toolbox)

LostFocus Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : LostFocus Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LostFocus As System.EventHandler
public event System.EventHandler LostFocus
See Also

Reference

Toolbox Class
Toolbox Members


Margin Property (Toolbox)

Margin Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Margin Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Margin As System.Windows.Forms.Padding
public System.Windows.Forms.Padding Margin {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


MarginChanged Event (Toolbox)

MarginChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MarginChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MarginChanged As System.EventHandler
public event System.EventHandler MarginChanged
See Also

Reference

Toolbox Class
Toolbox Members


MaximumSize Property (Toolbox)

MaximumSize Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MaximumSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaximumSize As Size
public Size MaximumSize {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


MinimumSize Property (Toolbox)

MinimumSize Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MinimumSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinimumSize As Size
public Size MinimumSize {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


MouseCaptureChanged Event (Toolbox)

MouseCaptureChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MouseCaptureChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseCaptureChanged As System.EventHandler
public event System.EventHandler MouseCaptureChanged
See Also

Reference

Toolbox Class
Toolbox Members


MouseClick Event (Toolbox)

MouseClick Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MouseClick Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseClick As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseClick
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

Toolbox Class
Toolbox Members


MouseDoubleClick Event (Toolbox)

MouseDoubleClick Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MouseDoubleClick Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseDoubleClick As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseDoubleClick
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

Toolbox Class
Toolbox Members


MouseDown Event (Toolbox)

MouseDown Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MouseDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseDown As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseDown
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

Toolbox Class
Toolbox Members


MouseEnter Event (Toolbox)

MouseEnter Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MouseEnter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseEnter As System.EventHandler
public event System.EventHandler MouseEnter
See Also

Reference

Toolbox Class
Toolbox Members


MouseHover Event (Toolbox)

MouseHover Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MouseHover Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseHover As System.EventHandler
public event System.EventHandler MouseHover
See Also

Reference

Toolbox Class
Toolbox Members


MouseLeave Event (Toolbox)

MouseLeave Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MouseLeave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseLeave As System.EventHandler
public event System.EventHandler MouseLeave
See Also

Reference

Toolbox Class
Toolbox Members


MouseMove Event (Toolbox)

MouseMove Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MouseMove Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseMove As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseMove
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

Toolbox Class
Toolbox Members


MouseUp Event (Toolbox)

MouseUp Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MouseUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseUp As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseUp
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

Toolbox Class
Toolbox Members


MouseWheel Event (Toolbox)

MouseWheel Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : MouseWheel Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseWheel As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseWheel
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

Toolbox Class
Toolbox Members


Move Event (Toolbox)

Move Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Move Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Move As System.EventHandler
public event System.EventHandler Move
See Also

Reference

Toolbox Class
Toolbox Members


Name Property (Toolbox)

Name Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Name Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


Padding Property (Toolbox)

Padding Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Padding Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Padding As System.Windows.Forms.Padding
public System.Windows.Forms.Padding Padding {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


PaddingChanged Event (Toolbox)

PaddingChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : PaddingChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PaddingChanged As System.EventHandler
public event System.EventHandler PaddingChanged
See Also

Reference

Toolbox Class
Toolbox Members


Paint Event (Toolbox)

Paint Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Paint Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Paint As System.Windows.Forms.PaintEventHandler
public event System.Windows.Forms.PaintEventHandler Paint
Event Data

The event handler receives an argument of type System.Windows.Forms.PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.
See Also

Reference

Toolbox Class
Toolbox Members


Parent Property (Toolbox)

Parent Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Parent Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Parent As System.Windows.Forms.Control
public System.Windows.Forms.Control Parent {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


ParentChanged Event (Toolbox)

ParentChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ParentChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ParentChanged As System.EventHandler
public event System.EventHandler ParentChanged
See Also

Reference

Toolbox Class
Toolbox Members


ParentForm Property (Toolbox)

ParentForm Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ParentForm Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ParentForm As System.Windows.Forms.Form
public System.Windows.Forms.Form ParentForm {get;}
See Also

Reference

Toolbox Class
Toolbox Members


PerformAutoScale Method (Toolbox)

PerformAutoScale Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : PerformAutoScale Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub PerformAutoScale()
public void PerformAutoScale()
See Also

Reference

Toolbox Class
Toolbox Members


PerformLayout Method (Toolbox)

PerformLayout Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : PerformLayout Method
Overload List
Overload | Description
PerformLayout() | (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Toolbox Class
Toolbox Members


PerformLayout() Method

PerformLayout() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > PerformLayout Method : PerformLayout() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub PerformLayout()
public void PerformLayout()
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


PerformLayout(Control,String) Method

PerformLayout(Control,String) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > PerformLayout Method : PerformLayout(Control,String) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub PerformLayout( _
   ByVal affectedControl As System.Windows.Forms.Control, _
   ByVal affectedProperty As System.String _
)
public void PerformLayout(
   System.Windows.Forms.Control affectedControl,
   System.string affectedProperty
)

Parameters

affectedControl
affectedProperty
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


PointToClient Method (Toolbox)

PointToClient Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : PointToClient Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PointToClient( _
   ByVal p As Point _
) As Point
public Point PointToClient(
   Point p
)

Parameters

p
See Also

Reference

Toolbox Class
Toolbox Members


PointToScreen Method (Toolbox)

PointToScreen Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : PointToScreen Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PointToScreen( _
   ByVal p As Point _
) As Point
public Point PointToScreen(
   Point p
)

Parameters

p
See Also

Reference

Toolbox Class
Toolbox Members


PreferredSize Property (Toolbox)

PreferredSize Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : PreferredSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PreferredSize As Size
public Size PreferredSize {get;}
See Also

Reference

Toolbox Class
Toolbox Members


PreProcessControlMessage Method (Toolbox)

PreProcessControlMessage Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : PreProcessControlMessage Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PreProcessControlMessage( _
   ByRef msg As System.Windows.Forms.Message _
) As System.Windows.Forms.PreProcessControlState
public System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
See Also

Reference

Toolbox Class
Toolbox Members


PreProcessMessage Method (Toolbox)

PreProcessMessage Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : PreProcessMessage Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PreProcessMessage( _
   ByRef msg As System.Windows.Forms.Message _
) As System.Boolean
public System.bool PreProcessMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
See Also

Reference

Toolbox Class
Toolbox Members


PreviewKeyDown Event (Toolbox)

PreviewKeyDown Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : PreviewKeyDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewKeyDown As System.Windows.Forms.PreviewKeyDownEventHandler
public event System.Windows.Forms.PreviewKeyDownEventHandler PreviewKeyDown
Event Data

The event handler receives an argument of type System.Windows.Forms.PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.
See Also

Reference

Toolbox Class
Toolbox Members


ProductName Property (Toolbox)

ProductName Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ProductName Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ProductName As System.String
public System.string ProductName {get;}
See Also

Reference

Toolbox Class
Toolbox Members


ProductVersion Property (Toolbox)

ProductVersion Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ProductVersion Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ProductVersion As System.String
public System.string ProductVersion {get;}
See Also

Reference

Toolbox Class
Toolbox Members


QueryAccessibilityHelp Event (Toolbox)

QueryAccessibilityHelp Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : QueryAccessibilityHelp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event QueryAccessibilityHelp As System.Windows.Forms.QueryAccessibilityHelpEventHandler
public event System.Windows.Forms.QueryAccessibilityHelpEventHandler QueryAccessibilityHelp
Event Data

The event handler receives an argument of type System.Windows.Forms.QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.
See Also

Reference

Toolbox Class
Toolbox Members


QueryContinueDrag Event (Toolbox)

QueryContinueDrag Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : QueryContinueDrag Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event QueryContinueDrag As System.Windows.Forms.QueryContinueDragEventHandler
public event System.Windows.Forms.QueryContinueDragEventHandler QueryContinueDrag
Event Data

The event handler receives an argument of type System.Windows.Forms.QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.
See Also

Reference

Toolbox Class
Toolbox Members


RecreatingHandle Property (Toolbox)

RecreatingHandle Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : RecreatingHandle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property RecreatingHandle As System.Boolean
public System.bool RecreatingHandle {get;}
See Also

Reference

Toolbox Class
Toolbox Members


RectangleToClient Method (Toolbox)

RectangleToClient Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : RectangleToClient Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function RectangleToClient( _
   ByVal r As Rectangle _
) As Rectangle
public Rectangle RectangleToClient(
   Rectangle r
)

Parameters

r
See Also

Reference

Toolbox Class
Toolbox Members


RectangleToScreen Method (Toolbox)

RectangleToScreen Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : RectangleToScreen Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function RectangleToScreen( _
   ByVal r As Rectangle _
) As Rectangle
public Rectangle RectangleToScreen(
   Rectangle r
)

Parameters

r
See Also

Reference

Toolbox Class
Toolbox Members


Refresh Method (Toolbox)

Refresh Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Refresh Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Refresh()
public void Refresh()
See Also

Reference

Toolbox Class
Toolbox Members


Region Property (Toolbox)

Region Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Region Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Region As Region
public Region Region {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


RegionChanged Event (Toolbox)

RegionChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : RegionChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event RegionChanged As System.EventHandler
public event System.EventHandler RegionChanged
See Also

Reference

Toolbox Class
Toolbox Members


ResetText Method (Toolbox)

ResetText Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ResetText Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ResetText()
public void ResetText()
See Also

Reference

Toolbox Class
Toolbox Members


Resize Event (Toolbox)

Resize Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Resize Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Resize As System.EventHandler
public event System.EventHandler Resize
See Also

Reference

Toolbox Class
Toolbox Members


ResumeLayout Method (Toolbox)

ResumeLayout Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ResumeLayout Method
Overload List
Overload | Description
ResumeLayout() | (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Toolbox Class
Toolbox Members


ResumeLayout() Method

ResumeLayout() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > ResumeLayout Method : ResumeLayout() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ResumeLayout()
public void ResumeLayout()
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


ResumeLayout(Boolean) Method

ResumeLayout(Boolean) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > ResumeLayout Method : ResumeLayout(Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ResumeLayout( _
   ByVal performLayout As System.Boolean _
)
public void ResumeLayout(
   System.bool performLayout
)

Parameters

performLayout
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


Right Property (Toolbox)

Right Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Right Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Right As System.Integer
public System.int Right {get;}
See Also

Reference

Toolbox Class
Toolbox Members


RightToLeft Property (Toolbox)

RightToLeft Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : RightToLeft Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RightToLeft As System.Windows.Forms.RightToLeft
public System.Windows.Forms.RightToLeft RightToLeft {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


RightToLeftChanged Event (Toolbox)

RightToLeftChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : RightToLeftChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event RightToLeftChanged As System.EventHandler
public event System.EventHandler RightToLeftChanged
See Also

Reference

Toolbox Class
Toolbox Members


Scale Method (Toolbox)

Scale Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Scale Method
Overload List
Overload | Description
Scale | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Toolbox Class
Toolbox Members


Scale(SizeF) Method

Scale(SizeF) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > Scale Method : Scale(SizeF) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Scale( _
   ByVal factor As SizeF _
)
public void Scale(
   SizeF factor
)

Parameters

factor
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


Scroll Event (Toolbox)

Scroll Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Scroll Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Scroll As System.Windows.Forms.ScrollEventHandler
public event System.Windows.Forms.ScrollEventHandler Scroll
Event Data

The event handler receives an argument of type System.Windows.Forms.ScrollEventArgs containing data related to this event. The following ScrollEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets or sets the new System.Windows.Forms.ScrollBar.Value of the scroll bar.
OldValue | Gets the old System.Windows.Forms.ScrollBar.Value of the scroll bar.
ScrollOrientation | Gets the scroll bar orientation that raised the Scroll event.
Type | Gets the type of scroll event that occurred.
See Also

Reference

Toolbox Class
Toolbox Members


ScrollControlIntoView Method (Toolbox)

ScrollControlIntoView Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ScrollControlIntoView Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ScrollControlIntoView( _
   ByVal activeControl As System.Windows.Forms.Control _
)
public void ScrollControlIntoView(
   System.Windows.Forms.Control activeControl
)

Parameters

activeControl
See Also

Reference

Toolbox Class
Toolbox Members


Select Method (Toolbox)

Select Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Select Method
Overload List
Overload | Description
Select | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Toolbox Class
Toolbox Members


Select() Method

Select() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Select() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Select()
public void Select()
See Also

Reference

Toolbox Class
Toolbox Members


SelectNextControl Method (Toolbox)

SelectNextControl Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : SelectNextControl Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function SelectNextControl( _
   ByVal ctl As System.Windows.Forms.Control, _
   ByVal forward As System.Boolean, _
   ByVal tabStopOnly As System.Boolean, _
   ByVal nested As System.Boolean, _
   ByVal wrap As System.Boolean _
) As System.Boolean
public System.bool SelectNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)

Parameters

ctl
forward
tabStopOnly
nested
wrap
See Also

Reference

Toolbox Class
Toolbox Members


SendToBack Method (Toolbox)

SendToBack Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : SendToBack Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SendToBack()
public void SendToBack()
See Also

Reference

Toolbox Class
Toolbox Members


SetAutoScrollMargin Method (Toolbox)

SetAutoScrollMargin Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : SetAutoScrollMargin Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetAutoScrollMargin( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer _
)
public void SetAutoScrollMargin(
   System.int x,
   System.int y
)

Parameters

x
y
See Also

Reference

Toolbox Class
Toolbox Members


SetBounds Method (Toolbox)

SetBounds Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : SetBounds Method
Overload List
Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Toolbox Class
Toolbox Members


SetBounds(Int32,Int32,Int32,Int32) Method

SetBounds(Int32,Int32,Int32,Int32) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer _
)
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

x
y
width
height
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer, _
   ByVal specified As System.Windows.Forms.BoundsSpecified _
)
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)

Parameters

x
y
width
height
specified
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


Show Method (Toolbox)

Show Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Show Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Show()
public void Show()
See Also

Reference

Toolbox Class
Toolbox Members


Site Property (Toolbox)

Site Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


Size Property (Toolbox)

Size Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Size Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Size As Size
public Size Size {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


SizeChanged Event (Toolbox)

SizeChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : SizeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event SizeChanged As System.EventHandler
public event System.EventHandler SizeChanged
See Also

Reference

Toolbox Class
Toolbox Members


StyleChanged Event (Toolbox)

StyleChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : StyleChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event StyleChanged As System.EventHandler
public event System.EventHandler StyleChanged
See Also

Reference

Toolbox Class
Toolbox Members


SuspendLayout Method (Toolbox)

SuspendLayout Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : SuspendLayout Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SuspendLayout()
public void SuspendLayout()
See Also

Reference

Toolbox Class
Toolbox Members


SystemColorsChanged Event (Toolbox)

SystemColorsChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : SystemColorsChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event SystemColorsChanged As System.EventHandler
public event System.EventHandler SystemColorsChanged
See Also

Reference

Toolbox Class
Toolbox Members


TabIndex Property (Toolbox)

TabIndex Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : TabIndex Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TabIndex As System.Integer
public System.int TabIndex {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


TabIndexChanged Event (Toolbox)

TabIndexChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : TabIndexChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TabIndexChanged As System.EventHandler
public event System.EventHandler TabIndexChanged
See Also

Reference

Toolbox Class
Toolbox Members


TabStop Property (Toolbox)

TabStop Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : TabStop Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TabStop As System.Boolean
public System.bool TabStop {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


TabStopChanged Event (Toolbox)

TabStopChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : TabStopChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TabStopChanged As System.EventHandler
public event System.EventHandler TabStopChanged
See Also

Reference

Toolbox Class
Toolbox Members


Tag Property (Toolbox)

Tag Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Tag Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Tag As System.Object
public System.object Tag {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


Top Property (Toolbox)

Top Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Top Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Top As System.Integer
public System.int Top {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


TopLevelControl Property (Toolbox)

TopLevelControl Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : TopLevelControl Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TopLevelControl As System.Windows.Forms.Control
public System.Windows.Forms.Control TopLevelControl {get;}
See Also

Reference

Toolbox Class
Toolbox Members


ToString Method (Toolbox)

ToString Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

Toolbox Class
Toolbox Members


Update Method (Toolbox)

Update Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Update Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Update()
public void Update()
See Also

Reference

Toolbox Class
Toolbox Members


UseWaitCursor Property (Toolbox)

UseWaitCursor Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : UseWaitCursor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseWaitCursor As System.Boolean
public System.bool UseWaitCursor {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


Validate Method (Toolbox)

Validate Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Validate Method
Overload List
Overload | Description
Validate() | (Inherited from System.Windows.Forms.ContainerControl)
Validate(Boolean) | (Inherited from System.Windows.Forms.ContainerControl)
See Also

Reference

Toolbox Class
Toolbox Members


Validate() Method

Validate() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > Validate Method : Validate() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Validate() As System.Boolean
public System.bool Validate()
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


Validate(Boolean) Method

Validate(Boolean) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > Validate Method : Validate(Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Validate( _
   ByVal checkAutoValidate As System.Boolean _
) As System.Boolean
public System.bool Validate(
   System.bool checkAutoValidate
)

Parameters

checkAutoValidate
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


ValidateChildren Method (Toolbox)

ValidateChildren Method (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : ValidateChildren Method
Overload List
Overload | Description
ValidateChildren() | (Inherited from System.Windows.Forms.UserControl)
ValidateChildren(ValidationConstraints) | (Inherited from System.Windows.Forms.UserControl)
See Also

Reference

Toolbox Class
Toolbox Members


ValidateChildren() Method

ValidateChildren() Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > ValidateChildren Method : ValidateChildren() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function ValidateChildren() As System.Boolean
public System.bool ValidateChildren()
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


ValidateChildren(ValidationConstraints) Method

ValidateChildren(ValidationConstraints) Method

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class > ValidateChildren Method : ValidateChildren(ValidationConstraints) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function ValidateChildren( _
   ByVal validationConstraints As System.Windows.Forms.ValidationConstraints _
) As System.Boolean
public System.bool ValidateChildren(
   System.Windows.Forms.ValidationConstraints validationConstraints
)

Parameters

validationConstraints
See Also

Reference

Toolbox Class
Toolbox Members
Overload List


Validated Event (Toolbox)

Validated Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Validated Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Validated As System.EventHandler
public event System.EventHandler Validated
See Also

Reference

Toolbox Class
Toolbox Members


Validating Event (Toolbox)

Validating Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Validating Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Validating As System.ComponentModel.CancelEventHandler
public event System.ComponentModel.CancelEventHandler Validating
Event Data

The event handler receives an argument of type System.ComponentModel.CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |
See Also

Reference

Toolbox Class
Toolbox Members


VerticalScroll Property (Toolbox)

VerticalScroll Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : VerticalScroll Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property VerticalScroll As System.Windows.Forms.VScrollProperties
public System.Windows.Forms.VScrollProperties VerticalScroll {get;}
See Also

Reference

Toolbox Class
Toolbox Members


Visible Property (Toolbox)

Visible Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Visible Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


VisibleChanged Event (Toolbox)

VisibleChanged Event (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : VisibleChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event VisibleChanged As System.EventHandler
public event System.EventHandler VisibleChanged
See Also

Reference

Toolbox Class
Toolbox Members


Width Property (Toolbox)

Width Property (Toolbox)

GrapeCity.ActiveReports.Design.Win.v10 Assembly > GrapeCity.ActiveReports.Design.Toolbox Namespace > Toolbox Class : Width Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As System.Integer
public System.int Width {get; set;}
See Also

Reference

Toolbox Class
Toolbox Members


GrapeCity.ActiveReports.Design.Toolbox Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Design.Toolbox Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Design.Win.v10 Assembly : GrapeCity.ActiveReports.Design.Toolbox Namespace
Inheritance Hierarchy
System.Object
System.EventArgs
GrapeCity.ActiveReports.Design.Toolbox.GroupChangedEventArgs
GrapeCity.ActiveReports.Design.Toolbox.ToolClickEventArgs
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Design.Toolbox.Group
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
GrapeCity.ActiveReports.Design.Toolbox.GroupListbar
GrapeCity.ActiveReports.Design.Toolbox.Toolbox
See Also

Reference

GrapeCity.ActiveReports.Design.Win.v10 Assembly


GrapeCity.ActiveReports.Design Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Design Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Design.Win.v10 Assembly : GrapeCity.ActiveReports.Design Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Design.OpenFileDialogExtension
GrapeCity.ActiveReports.Design.Selection
GrapeCity.ActiveReports.Design.UndoManager
System.EventArgs
GrapeCity.ActiveReports.Design.ChartDataSourceClickedEventArgs
GrapeCity.ActiveReports.Design.ContextMenuOpenArgs
GrapeCity.ActiveReports.Design.DataSourceIconClickedEventArgs
GrapeCity.ActiveReports.Design.DataSourceIconClickEventArgs
GrapeCity.ActiveReports.Design.DesignerTabChangedEventArgs
GrapeCity.ActiveReports.Design.EditModeEnteringEventArgs
GrapeCity.ActiveReports.Design.EditModeExitEventArgs
GrapeCity.ActiveReports.Design.LayerSelectionChangedEventArgs
GrapeCity.ActiveReports.Design.LayoutChangedArgs
GrapeCity.ActiveReports.Design.LayoutChangingArgs
GrapeCity.ActiveReports.Design.ServerConnectionChangedEventArgs
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
GrapeCity.ActiveReports.Design.Designer
GrapeCity.ActiveReports.Design.LayerList
See Also

Reference

GrapeCity.ActiveReports.Design.Win.v10 Assembly


GrapeCity.ActiveReports.Document.v10 Assembly

GrapeCity.ActiveReports.Document.v10 Assembly
Namespaces
Namespace | Description
GrapeCity.ActiveReports | The GrapeCity.ActiveReports namespace contains the Border class and its settings.
GrapeCity.ActiveReports.Document | The GrapeCity.ActiveReports.Document namespace contains many classes which give control over various aspects of the final output of the report.
GrapeCity.ActiveReports.Document.Section | The GrapeCity.ActiveReports.Document.Section Namespace contains various classes that can be set in the report document.
GrapeCity.ActiveReports.Document.Section.Annotations | The GrapeCity.ActiveReports.Document.Section.Annotations namespace contains the Annotations classes and its settings.
GrapeCity.ActiveReports.Export | The GrapeCity.ActiveReports.Export namespace contains the common interface for all the export filters.
GrapeCity.ActiveReports.Export.Html | The GrapeCity.ActiveReports.Export.Html namespace contains the class which gives control over the HTML output of the report.


ActiveReportPrintControllerWithStatusDialog Class Properties

ActiveReportPrintControllerWithStatusDialog Class Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace : ActiveReportPrintControllerWithStatusDialog Class

For a list of all members of this type, see ActiveReportPrintControllerWithStatusDialog members.

Public Properties
 | Name | Description
Public Property | IsPreview | (Inherited from System.Drawing.Printing.PrintController)
Top
See Also

Reference

ActiveReportPrintControllerWithStatusDialog Class
GrapeCity.ActiveReports.Document.Section Namespace


IsPreview Property

IsPreview Property

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > ActiveReportPrintControllerWithStatusDialog Class : IsPreview Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property IsPreview As System.Boolean
public virtual System.bool IsPreview {get;}
See Also

Reference

ActiveReportPrintControllerWithStatusDialog Class
ActiveReportPrintControllerWithStatusDialog Members


Annotation Class Events

Annotation Class Events

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : Annotation Class

For a list of all members of this type, see Annotation members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Annotation Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationArrow Class Events

AnnotationArrow Class Events

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationArrow Class

For a list of all members of this type, see AnnotationArrow members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

AnnotationArrow Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationArrow Class Methods

AnnotationArrow Class Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationArrow Class

For a list of all members of this type, see AnnotationArrow members.

Public Methods
 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

AnnotationArrow Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Container Property (AnnotationArrow)

Container Property (AnnotationArrow)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


CreateObjRef Method (AnnotationArrow)

CreateObjRef Method (AnnotationArrow)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


Dispose Method (AnnotationArrow)

Dispose Method (AnnotationArrow)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : Dispose Method
Releases the unmanaged resources used by the System.ComponentModel.Component and optionally releases the managed resources.
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


Disposed Event (AnnotationArrow)

Disposed Event (AnnotationArrow)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


GetLifetimeService Method (AnnotationArrow)

GetLifetimeService Method (AnnotationArrow)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


InitializeLifetimeService Method (AnnotationArrow)

InitializeLifetimeService Method (AnnotationArrow)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


Site Property (AnnotationArrow)

Site Property (AnnotationArrow)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


ToString Method (AnnotationArrow)

ToString Method (AnnotationArrow)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationArrow Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

AnnotationArrow Class
AnnotationArrow Members


AnnotationBalloon Class Events

AnnotationBalloon Class Events

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBalloon Class

For a list of all members of this type, see AnnotationBalloon members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

AnnotationBalloon Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationBalloon Class Methods

AnnotationBalloon Class Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBalloon Class

For a list of all members of this type, see AnnotationBalloon members.

Public Methods
 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

AnnotationBalloon Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Container Property (AnnotationBalloon)

Container Property (AnnotationBalloon)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


CreateObjRef Method (AnnotationBalloon)

CreateObjRef Method (AnnotationBalloon)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


Dispose Method (AnnotationBalloon)

Dispose Method (AnnotationBalloon)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : Dispose Method
Releases the unmanaged resources used by the System.ComponentModel.Component and optionally releases the managed resources.
Releases the AnnotationBalloon instance from memory.
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


Disposed Event (AnnotationBalloon)

Disposed Event (AnnotationBalloon)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


GetLifetimeService Method (AnnotationBalloon)

GetLifetimeService Method (AnnotationBalloon)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


InitializeLifetimeService Method (AnnotationBalloon)

InitializeLifetimeService Method (AnnotationBalloon)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


Site Property (AnnotationBalloon)

Site Property (AnnotationBalloon)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


ToString Method (AnnotationBalloon)

ToString Method (AnnotationBalloon)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBalloon Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

AnnotationBalloon Class
AnnotationBalloon Members


AnnotationBaseText Class Events

AnnotationBaseText Class Events

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBaseText Class

For a list of all members of this type, see AnnotationBaseText members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

AnnotationBaseText Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationBaseText Class Methods

AnnotationBaseText Class Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationBaseText Class

For a list of all members of this type, see AnnotationBaseText members.

Public Methods
 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

AnnotationBaseText Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Container Property (AnnotationBaseText)

Container Property (AnnotationBaseText)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


CreateObjRef Method (AnnotationBaseText)

CreateObjRef Method (AnnotationBaseText)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


Dispose Method (AnnotationBaseText)

Dispose Method (AnnotationBaseText)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


Disposed Event (AnnotationBaseText)

Disposed Event (AnnotationBaseText)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


GetLifetimeService Method (AnnotationBaseText)

GetLifetimeService Method (AnnotationBaseText)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


InitializeLifetimeService Method (AnnotationBaseText)

InitializeLifetimeService Method (AnnotationBaseText)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
public virtual System.object InitializeLifetimeService()
See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


Site Property (AnnotationBaseText)

Site Property (AnnotationBaseText)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
public virtual System.ComponentModel.ISite Site {get; set;}
See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


ToString Method (AnnotationBaseText)

ToString Method (AnnotationBaseText)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationBaseText Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

AnnotationBaseText Class
AnnotationBaseText Members


AnnotationCircle Class Events

AnnotationCircle Class Events

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCircle Class

For a list of all members of this type, see AnnotationCircle members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

AnnotationCircle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationCircle Class Methods

AnnotationCircle Class Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCircle Class

For a list of all members of this type, see AnnotationCircle members.

Public Methods
 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

AnnotationCircle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationCircle Class Properties

AnnotationCircle Class Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationCircle Class

For a list of all members of this type, see AnnotationCircle members.

Public Properties
 | Name | Description
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top
See Also

Reference

AnnotationCircle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Container Property (AnnotationCircle)

Container Property (AnnotationCircle)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


CreateObjRef Method (AnnotationCircle)

CreateObjRef Method (AnnotationCircle)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


Dispose Method (AnnotationCircle)

Dispose Method (AnnotationCircle)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


Disposed Event (AnnotationCircle)

Disposed Event (AnnotationCircle)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


GetLifetimeService Method (AnnotationCircle)

GetLifetimeService Method (AnnotationCircle)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


InitializeLifetimeService Method (AnnotationCircle)

InitializeLifetimeService Method (AnnotationCircle)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


Site Property (AnnotationCircle)

Site Property (AnnotationCircle)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


ToString Method (AnnotationCircle)

ToString Method (AnnotationCircle)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCircle Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

AnnotationCircle Class
AnnotationCircle Members


Capacity Property (AnnotationCollection)

Capacity Property (AnnotationCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : Capacity Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


Clear Method (AnnotationCollection)

Clear Method (AnnotationCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : Clear Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


Count Property (AnnotationCollection)

Count Property (AnnotationCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : Count Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


RemoveAt Method (AnnotationCollection)

RemoveAt Method (AnnotationCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationCollection Class : RemoveAt Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


AnnotationImage Class Events

AnnotationImage Class Events

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationImage Class

For a list of all members of this type, see AnnotationImage members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

AnnotationImage Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationImage Class Methods

AnnotationImage Class Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationImage Class

For a list of all members of this type, see AnnotationImage members.

Public Methods
 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

AnnotationImage Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Container Property (AnnotationImage)

Container Property (AnnotationImage)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

AnnotationImage Class
AnnotationImage Members


CreateObjRef Method (AnnotationImage)

CreateObjRef Method (AnnotationImage)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

AnnotationImage Class
AnnotationImage Members


Dispose Method (AnnotationImage)

Dispose Method (AnnotationImage)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

AnnotationImage Class
AnnotationImage Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

AnnotationImage Class
AnnotationImage Members


Disposed Event (AnnotationImage)

Disposed Event (AnnotationImage)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

AnnotationImage Class
AnnotationImage Members


GetLifetimeService Method (AnnotationImage)

GetLifetimeService Method (AnnotationImage)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

AnnotationImage Class
AnnotationImage Members


InitializeLifetimeService Method (AnnotationImage)

InitializeLifetimeService Method (AnnotationImage)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

AnnotationImage Class
AnnotationImage Members


Site Property (AnnotationImage)

Site Property (AnnotationImage)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

AnnotationImage Class
AnnotationImage Members


ToString Method (AnnotationImage)

ToString Method (AnnotationImage)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationImage Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

AnnotationImage Class
AnnotationImage Members


AnnotationLine Class Events

AnnotationLine Class Events

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationLine Class

For a list of all members of this type, see AnnotationLine members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

AnnotationLine Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationLine Class Methods

AnnotationLine Class Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationLine Class

For a list of all members of this type, see AnnotationLine members.

Public Methods
 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

AnnotationLine Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Container Property (AnnotationLine)

Container Property (AnnotationLine)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

AnnotationLine Class
AnnotationLine Members


CreateObjRef Method (AnnotationLine)

CreateObjRef Method (AnnotationLine)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

AnnotationLine Class
AnnotationLine Members


Dispose Method (AnnotationLine)

Dispose Method (AnnotationLine)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

AnnotationLine Class
AnnotationLine Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

AnnotationLine Class
AnnotationLine Members


Disposed Event (AnnotationLine)

Disposed Event (AnnotationLine)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

AnnotationLine Class
AnnotationLine Members


GetLifetimeService Method (AnnotationLine)

GetLifetimeService Method (AnnotationLine)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

AnnotationLine Class
AnnotationLine Members


InitializeLifetimeService Method (AnnotationLine)

InitializeLifetimeService Method (AnnotationLine)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

AnnotationLine Class
AnnotationLine Members


Site Property (AnnotationLine)

Site Property (AnnotationLine)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

AnnotationLine Class
AnnotationLine Members


ToString Method (AnnotationLine)

ToString Method (AnnotationLine)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationLine Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

AnnotationLine Class
AnnotationLine Members


AnnotationRectangle Class Events

AnnotationRectangle Class Events

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationRectangle Class

For a list of all members of this type, see AnnotationRectangle members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

AnnotationRectangle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationRectangle Class Methods

AnnotationRectangle Class Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationRectangle Class

For a list of all members of this type, see AnnotationRectangle members.

Public Methods
 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

AnnotationRectangle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationRectangle Class Properties

AnnotationRectangle Class Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationRectangle Class

For a list of all members of this type, see AnnotationRectangle members.

Public Properties
 | Name | Description
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top
See Also

Reference

AnnotationRectangle Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Container Property (AnnotationRectangle)

Container Property (AnnotationRectangle)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


CreateObjRef Method (AnnotationRectangle)

CreateObjRef Method (AnnotationRectangle)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


Dispose Method (AnnotationRectangle)

Dispose Method (AnnotationRectangle)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


Disposed Event (AnnotationRectangle)

Disposed Event (AnnotationRectangle)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


GetLifetimeService Method (AnnotationRectangle)

GetLifetimeService Method (AnnotationRectangle)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


InitializeLifetimeService Method (AnnotationRectangle)

InitializeLifetimeService Method (AnnotationRectangle)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


Site Property (AnnotationRectangle)

Site Property (AnnotationRectangle)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


ToString Method (AnnotationRectangle)

ToString Method (AnnotationRectangle)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationRectangle Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

AnnotationRectangle Class
AnnotationRectangle Members


AnnotationText Class Events

AnnotationText Class Events

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationText Class

For a list of all members of this type, see AnnotationText members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

AnnotationText Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationText Class Methods

AnnotationText Class Methods

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationText Class

For a list of all members of this type, see AnnotationText members.

Public Methods
 | Name | Description
Public Method | Attach | Sets the top left most coordinates for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Refresh | Refreshes the display of the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

AnnotationText Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


AnnotationText Class Properties

AnnotationText Class Properties

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace : AnnotationText Class

For a list of all members of this type, see AnnotationText members.

Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the horizontal alignment of the text within the bounds of an annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Alpha | Gets or sets the opacity of the Annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Border | Gets the border for the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Color | Gets or sets the color that is used to fill the annotation object. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Font | Gets or sets the text font associated with the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Height | Gets or sets the height of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | LineAligment | Gets or sets the vertical alignment of the text within the bounds of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | PageRectangle | Gets or sets the rectangular area of the page on which the annotation is drawn. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Text | Gets or sets the text to be rendered in the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | TextColor | Gets or sets the color of the text that is rendered with the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText)
Public Property | Width | Gets or sets the width of the annotation object, in inches. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | X | Gets or sets the value in inches of the horizontal location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Public Property | Y | Gets or sets the value in inches of the vertical location of the annotation. (Inherited from GrapeCity.ActiveReports.Document.Section.Annotations.Annotation)
Top
See Also

Reference

AnnotationText Class
GrapeCity.ActiveReports.Document.Section.Annotations Namespace


Container Property (AnnotationText)

Container Property (AnnotationText)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

AnnotationText Class
AnnotationText Members


CreateObjRef Method (AnnotationText)

CreateObjRef Method (AnnotationText)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

AnnotationText Class
AnnotationText Members


Dispose Method (AnnotationText)

Dispose Method (AnnotationText)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

AnnotationText Class
AnnotationText Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

AnnotationText Class
AnnotationText Members


Disposed Event (AnnotationText)

Disposed Event (AnnotationText)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

AnnotationText Class
AnnotationText Members


GetLifetimeService Method (AnnotationText)

GetLifetimeService Method (AnnotationText)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

AnnotationText Class
AnnotationText Members


InitializeLifetimeService Method (AnnotationText)

InitializeLifetimeService Method (AnnotationText)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
public virtual System.object InitializeLifetimeService()
See Also

Reference

AnnotationText Class
AnnotationText Members


Site Property (AnnotationText)

Site Property (AnnotationText)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
public virtual System.ComponentModel.ISite Site {get; set;}
See Also

Reference

AnnotationText Class
AnnotationText Members


ToString Method (AnnotationText)

ToString Method (AnnotationText)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > AnnotationText Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

AnnotationText Class
AnnotationText Members


Container Property (Annotation)

Container Property (Annotation)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

Annotation Class
Annotation Members


CreateObjRef Method (Annotation)

CreateObjRef Method (Annotation)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

Annotation Class
Annotation Members


Dispose Method (Annotation)

Dispose Method (Annotation)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

Annotation Class
Annotation Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Annotation Class
Annotation Members


Disposed Event (Annotation)

Disposed Event (Annotation)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Annotation Class
Annotation Members


GetLifetimeService Method (Annotation)

GetLifetimeService Method (Annotation)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

Annotation Class
Annotation Members


InitializeLifetimeService Method (Annotation)

InitializeLifetimeService Method (Annotation)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
public virtual System.object InitializeLifetimeService()
See Also

Reference

Annotation Class
Annotation Members


Site Property (Annotation)

Site Property (Annotation)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
public virtual System.ComponentModel.ISite Site {get; set;}
See Also

Reference

Annotation Class
Annotation Members


ToString Method (Annotation)

ToString Method (Annotation)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section.Annotations Namespace > Annotation Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

Annotation Class
Annotation Members


GrapeCity.ActiveReports.Document.Section.Annotations Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Document.Section.Annotations Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Document.v10 Assembly : GrapeCity.ActiveReports.Document.Section.Annotations Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Document.Section.Annotations.Border
GrapeCity.ActiveReports.Document.Section.Annotations.BorderCircle
GrapeCity.ActiveReports.Document.Section.Annotations.BorderRectangle
System.Collections.CollectionBase
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationCollection
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Document.Section.Annotations.Annotation
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBaseText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationText
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationArrow
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationBalloon
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationImage
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationCircle
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationLine
GrapeCity.ActiveReports.Document.Section.Annotations.AnnotationRectangle
See Also

Reference

GrapeCity.ActiveReports.Document.v10 Assembly


BookmarksCollection Constructor

BookmarksCollection Constructor

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : BookmarksCollection Constructor
Initializes a new instance of the BookmarksCollection class.
Overload List
Overload | Description
BookmarksCollection Constructor | Creates a new instance of the BookmarkCollection class.
See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Capacity Property (BookmarksCollection)

Capacity Property (BookmarksCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Capacity Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Count Property (BookmarksCollection)

Count Property (BookmarksCollection)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : Count Property
Gets the number of Bookmark objects in the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
Example
  • C#
private void btnClearTOC_Click(object sender, System.EventArgs e)
{
    MessageBox.Show ("Clearing " + arv.Document.Bookmarks.Count.ToString() + " bookmarks.");
    arv.Document.Bookmarks.Clear();
    arv.TableOfContents.Clear();
}
  • Visual Basic
Private Sub btnClearTOC_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnClearTOC.Click
    MsgBox("Clearing " & arv.Document.Bookmarks.Count.ToString & " bookmarks.")
    arv.Document.Bookmarks.Clear()
    arv.TableOfContents.Clear()
End Sub
See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


RemoveAt Method (BookmarksCollection)

RemoveAt Method (BookmarksCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > BookmarksCollection Class : RemoveAt Method
Specifies the index of the Bookmark object to be removed from the collection.
Removes the Bookmark object at the specified index from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
Specifies the index of the Bookmark object to be removed from the collection.
See Also

Reference

BookmarksCollection Class
BookmarksCollection Members


Bookmark Constructor

Bookmark Constructor

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Bookmark Class : Bookmark Constructor
Creates a new instance of the Bookmark class.
Overload List
Overload | Description
Bookmark Constructor | Creates a new instance of the Bookmark class.
See Also

Reference

Bookmark Class
Bookmark Members


Dispose Method (PagesCollection)

Dispose Method (PagesCollection)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > PagesCollection Class : Dispose Method
Releases the PagesCollection instance from memory.
Overload List
Overload | Description
Dispose | Releases the PagesCollection instance from memory.
See Also

Reference

PagesCollection Class
PagesCollection Members


AddBookmark Method (Page)

AddBookmark Method (Page)
Example

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : AddBookmark Method
Adds a bookmark to the page at the specified offset.
Overload List
Overload | Description
AddBookmark | Summary description for AddBookmark.
Remarks
Bookmarks appear in the viewer's table of contents.
Example
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    for(int i = 0; i<Document.Pages.Count;i++)
    {
        this.Document.Pages[i].AddBookmark("New Bookmark", 25);
    }
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Dim i As Integer
    Try
        For i = 0 To Me.Document.Pages.Count - 1
            Me.Document.Pages(1).AddBookmark("New Bookmark", 8)
        Next
    Catch ex As Exception
    End Try
End Sub
See Also

Reference

Page Class
Page Members

How To

Add Bookmarks


Dispose Method (Page)

Dispose Method (Page)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Dispose Method
Releases the Page instance from memory.
Overload List
Overload | Description
Dispose | Releases the Page instance from memory.
See Also

Reference

Page Class
Page Members


Draw Method

Draw Method

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document.Section Namespace > Page Class : Draw Method
Renders the page's content to the specified Graphics object at the specified coordinates.
Overload List
Overload | Description
Draw | Renders the page's content to the specified Graphics object at the specified coordinates.
Remarks
You can use this method to render the page content scaled to a rectangle. This allows you to create thumbnail images of the pages or print multiple pages on a single sheet of paper.
See Also

Reference

Page Class
Page Members


GrapeCity.ActiveReports.Document.Section Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Document.Section Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Document.v10 Assembly : GrapeCity.ActiveReports.Document.Section Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Document.Section.Bookmark
GrapeCity.ActiveReports.Document.Section.Margins
GrapeCity.ActiveReports.Document.Section.Page
GrapeCity.ActiveReports.Document.Section.PagesCollection
GrapeCity.ActiveReports.Document.Section.RText.TabStop
GrapeCity.ActiveReports.Document.Section.StringFormatProvider
GrapeCity.ActiveReports.Document.Section.UserPreferences
System.Collections.CollectionBase
GrapeCity.ActiveReports.Document.Section.BookmarksCollection
System.Drawing.Printing.PrintController
System.Drawing.Printing.StandardPrintController
GrapeCity.ActiveReports.Document.Section.ActiveReportPrintControllerWithStatusDialog
System.EventArgs
GrapeCity.ActiveReports.Document.Section.UrlErrorEventArgs
See Also

Reference

GrapeCity.ActiveReports.Document.v10 Assembly


Dispose Method (SectionDocument)

Dispose Method (SectionDocument)

GrapeCity.ActiveReports.Document.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > SectionDocument Class : Dispose Method
Releases the Document instance from memory.
Overload List
Overload | Description
Dispose | If you call dispose on this level that means that you are not suppose to use anything that is contained below this level. That means no pages, no fonts, etc.
Remarks
Calling Dispose() on the Document object disposes of all objects contained in that Document object. Therefore, it is necessary to remove any items which will still need to be used prior to calling the Dispose() method. Similarly, to obtain access to any Pages in the Document object's Pages collection, those Pages need to be removed from the Pages collection prior to calling the Dispose() method of the Document object.
See Also

Reference

SectionDocument Class
SectionDocument Members


GrapeCity.ActiveReports.Document Namespace (GrapeCity.ActiveReports.Document.v10) Inheritance Hierarchy

GrapeCity.ActiveReports.Document Namespace (GrapeCity.ActiveReports.Document.v10) Inheritance Hierarchy
GrapeCity.ActiveReports.Document.v10 Assembly : GrapeCity.ActiveReports.Document Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Document.SectionDocument
See Also

Reference

GrapeCity.ActiveReports.Document.v10 Assembly


GrapeCity.ActiveReports.Export.Html Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Html Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Document.v10 Assembly : GrapeCity.ActiveReports.Export.Html Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Export.Html.HtmlOutputInfoArgs
See Also

Reference

GrapeCity.ActiveReports.Document.v10 Assembly


GrapeCity.ActiveReports.Export Namespace (GrapeCity.ActiveReports.Document.v10) Inheritance Hierarchy

GrapeCity.ActiveReports.Export Namespace (GrapeCity.ActiveReports.Document.v10) Inheritance Hierarchy
GrapeCity.ActiveReports.Document.v10 Assembly : GrapeCity.ActiveReports.Export Namespace
Inheritance Hierarchy
System.Object
See Also

Reference

GrapeCity.ActiveReports.Document.v10 Assembly


GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports.Document.v10) Inheritance Hierarchy

GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports.Document.v10) Inheritance Hierarchy
GrapeCity.ActiveReports.Document.v10 Assembly : GrapeCity.ActiveReports Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Border
GrapeCity.ActiveReports.Border.BorderMargins
System.ValueType
GrapeCity.ActiveReports.PaddingEx
See Also

Reference

GrapeCity.ActiveReports.Document.v10 Assembly


GrapeCity.ActiveReports.Export.Excel.v10 Assembly

GrapeCity.ActiveReports.Export.Excel.v10 Assembly
Namespaces
Namespace | Description
GrapeCity.ActiveReports.Export.Excel |
GrapeCity.ActiveReports.Export.Excel.Page |
GrapeCity.ActiveReports.Export.Excel.Section | The GrapeCity.ActiveReports.Export.Excel.Section namespace provides Excel Export functionality for ActiveReports for .NET.
GrapeCity.SpreadBuilder | The GrapeCity.SpreadBuilder namespace contains the Column, Row, Sheet and Workbook classes used for building Excel spreadsheets.
GrapeCity.SpreadBuilder.Cells | The GrapeCity.SpreadBuilder.Cells namespace contains the DDCell class.
GrapeCity.SpreadBuilder.Imaging | The GrapeCity.SpreadBuilder.Imaging namespace contains the LineInfo class.
GrapeCity.SpreadBuilder.Printing | The GrapeCity.SpreadBuilder.Printing namespace contains the PageSetup class.
GrapeCity.SpreadBuilder.Style | The GrapeCity.SpreadBuilder.Style namespace contains various style enumerations.


Dispose Method (ExcelRenderingExtension)

Dispose Method (ExcelRenderingExtension)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelRenderingExtension Class : Dispose Method
Implements the dispose logic of HtmlRenderingExtension class.
Overload List
Overload | Description
Dispose | Implements the dispose logic of HtmlRenderingExtension class.
See Also

Reference

ExcelRenderingExtension Class
ExcelRenderingExtension Members


GetSupportedSettings Method (ExcelTransformationDevice)

GetSupportedSettings Method (ExcelTransformationDevice)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Page Namespace > ExcelTransformationDevice Class : GetSupportedSettings Method
Gets the settings that are supported for rendering a report to Excel.
Overload List
Overload | Description
GetSupportedSettings | Gets the settings that are supported for rendering a report to Excel.
See Also

Reference

ExcelTransformationDevice Class
ExcelTransformationDevice Members


GrapeCity.ActiveReports.Export.Excel.Page Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Excel.Page Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Excel.v10 Assembly : GrapeCity.ActiveReports.Export.Excel.Page Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtension
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionPageSettings
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionSecurity
GrapeCity.ActiveReports.Export.Excel.Page.ExcelRenderingExtensionSettings
GrapeCity.ActiveReports.Export.Excel.Page.ExcelTransformationDevice
GrapeCity.ActiveReports.Export.Excel.Page.Settings
See Also

Reference

GrapeCity.ActiveReports.Export.Excel.v10 Assembly


XlsExport Class Events

XlsExport Class Events

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsExport Class

For a list of all members of this type, see XlsExport members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

XlsExport Class
GrapeCity.ActiveReports.Export.Excel.Section Namespace


XlsExportException Class Methods

XlsExportException Class Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsExportException Class

For a list of all members of this type, see XlsExportException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

XlsExportException Class
GrapeCity.ActiveReports.Export.Excel.Section Namespace


XlsExportException Class Properties

XlsExportException Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace : XlsExportException Class

For a list of all members of this type, see XlsExportException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

XlsExportException Class
GrapeCity.ActiveReports.Export.Excel.Section Namespace


Data Property (XlsExportException)

Data Property (XlsExportException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : Data Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Data As System.Collections.IDictionary
public virtual System.Collections.IDictionary Data {get;}
See Also

Reference

XlsExportException Class
XlsExportException Members


GetBaseException Method (XlsExportException)

GetBaseException Method (XlsExportException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetBaseException() As System.Exception
public virtual System.Exception GetBaseException()
See Also

Reference

XlsExportException Class
XlsExportException Members


GetObjectData Method (XlsExportException)

GetObjectData Method (XlsExportException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
See Also

Reference

XlsExportException Class
XlsExportException Members


GetType Method (XlsExportException)

GetType Method (XlsExportException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
See Also

Reference

XlsExportException Class
XlsExportException Members


GetType() Method

GetType() Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetType() As System.Type
public System.Type GetType()
See Also

Reference

XlsExportException Class
XlsExportException Members


HelpLink Property (XlsExportException)

HelpLink Property (XlsExportException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property HelpLink As System.String
public virtual System.string HelpLink {get; set;}
See Also

Reference

XlsExportException Class
XlsExportException Members


HResult Property (XlsExportException)

HResult Property (XlsExportException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : HResult Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HResult As System.Integer
public System.int HResult {get;}
See Also

Reference

XlsExportException Class
XlsExportException Members


InnerException Property (XlsExportException)

InnerException Property (XlsExportException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InnerException As System.Exception
public System.Exception InnerException {get;}
See Also

Reference

XlsExportException Class
XlsExportException Members


Message Property (XlsExportException)

Message Property (XlsExportException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : Message Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Message As System.String
public virtual System.string Message {get;}
See Also

Reference

XlsExportException Class
XlsExportException Members


Source Property (XlsExportException)

Source Property (XlsExportException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : Source Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Source As System.String
public virtual System.string Source {get; set;}
See Also

Reference

XlsExportException Class
XlsExportException Members


StackTrace Property (XlsExportException)

StackTrace Property (XlsExportException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property StackTrace As System.String
public virtual System.string StackTrace {get;}
See Also

Reference

XlsExportException Class
XlsExportException Members


TargetSite Property (XlsExportException)

TargetSite Property (XlsExportException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
public System.Reflection.MethodBase TargetSite {get;}
See Also

Reference

XlsExportException Class
XlsExportException Members


ToString Method (XlsExportException)

ToString Method (XlsExportException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExportException Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

XlsExportException Class
XlsExportException Members


Container Property (XlsExport)

Container Property (XlsExport)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

XlsExport Class
XlsExport Members


CreateObjRef Method (XlsExport)

CreateObjRef Method (XlsExport)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

XlsExport Class
XlsExport Members


Dispose Method (XlsExport)

Dispose Method (XlsExport)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

XlsExport Class
XlsExport Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

XlsExport Class
XlsExport Members


Disposed Event (XlsExport)

Disposed Event (XlsExport)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

XlsExport Class
XlsExport Members


GetLifetimeService Method (XlsExport)

GetLifetimeService Method (XlsExport)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

XlsExport Class
XlsExport Members


InitializeLifetimeService Method (XlsExport)

InitializeLifetimeService Method (XlsExport)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

XlsExport Class
XlsExport Members


Site Property (XlsExport)

Site Property (XlsExport)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

XlsExport Class
XlsExport Members


ToString Method (XlsExport)

ToString Method (XlsExport)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.ActiveReports.Export.Excel.Section Namespace > XlsExport Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

XlsExport Class
XlsExport Members


GrapeCity.ActiveReports.Export.Excel.Section Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Excel.Section Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Excel.v10 Assembly : GrapeCity.ActiveReports.Export.Excel.Section Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Export.Excel.Section.XlsPageSettings
GrapeCity.ActiveReports.Export.Excel.Section.XlsSecurity
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.Export.Excel.Section.XlsExportException
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Export.Excel.Section.XlsExport
See Also

Reference

GrapeCity.ActiveReports.Export.Excel.v10 Assembly


GrapeCity.ActiveReports.Export.Excel Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Excel Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Excel.v10 Assembly : GrapeCity.ActiveReports.Export.Excel Namespace
Inheritance Hierarchy
System.Object
See Also

Reference

GrapeCity.ActiveReports.Export.Excel.v10 Assembly


GrapeCity.SpreadBuilder.Cells Namespace Inheritance Hierarchy

GrapeCity.SpreadBuilder.Cells Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Excel.v10 Assembly : GrapeCity.SpreadBuilder.Cells Namespace
Inheritance Hierarchy
System.Object
GrapeCity.SpreadBuilder.Cells.DDCell
GrapeCity.SpreadBuilder.Cells.DDCells
System.ValueType
GrapeCity.SpreadBuilder.Cells.MergeArea
See Also

Reference

GrapeCity.ActiveReports.Export.Excel.v10 Assembly


ColumnCountOutOfRangeException Class Methods

ColumnCountOutOfRangeException Class Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : ColumnCountOutOfRangeException Class

For a list of all members of this type, see ColumnCountOutOfRangeException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

ColumnCountOutOfRangeException Class
GrapeCity.SpreadBuilder Namespace


ColumnCountOutOfRangeException Class Properties

ColumnCountOutOfRangeException Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : ColumnCountOutOfRangeException Class

For a list of all members of this type, see ColumnCountOutOfRangeException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

ColumnCountOutOfRangeException Class
GrapeCity.SpreadBuilder Namespace


Data Property (ColumnCountOutOfRangeException)

Data Property (ColumnCountOutOfRangeException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : Data Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Data As System.Collections.IDictionary
public virtual System.Collections.IDictionary Data {get;}
See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


GetBaseException Method (ColumnCountOutOfRangeException)

GetBaseException Method (ColumnCountOutOfRangeException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetBaseException() As System.Exception
public virtual System.Exception GetBaseException()
See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


GetObjectData Method (ColumnCountOutOfRangeException)

GetObjectData Method (ColumnCountOutOfRangeException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


GetType Method (ColumnCountOutOfRangeException)

GetType Method (ColumnCountOutOfRangeException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


GetType() Method

GetType() Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetType() As System.Type
public System.Type GetType()
See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


HelpLink Property (ColumnCountOutOfRangeException)

HelpLink Property (ColumnCountOutOfRangeException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property HelpLink As System.String
public virtual System.string HelpLink {get; set;}
See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


HResult Property (ColumnCountOutOfRangeException)

HResult Property (ColumnCountOutOfRangeException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : HResult Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HResult As System.Integer
public System.int HResult {get;}
See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


InnerException Property (ColumnCountOutOfRangeException)

InnerException Property (ColumnCountOutOfRangeException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InnerException As System.Exception
public System.Exception InnerException {get;}
See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


Message Property (ColumnCountOutOfRangeException)

Message Property (ColumnCountOutOfRangeException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : Message Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Message As System.String
public virtual System.string Message {get;}
See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


Source Property (ColumnCountOutOfRangeException)

Source Property (ColumnCountOutOfRangeException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : Source Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Source As System.String
public virtual System.string Source {get; set;}
See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


StackTrace Property (ColumnCountOutOfRangeException)

StackTrace Property (ColumnCountOutOfRangeException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property StackTrace As System.String
public virtual System.string StackTrace {get;}
See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


TargetSite Property (ColumnCountOutOfRangeException)

TargetSite Property (ColumnCountOutOfRangeException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
public System.Reflection.MethodBase TargetSite {get;}
See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


ToString Method (ColumnCountOutOfRangeException)

ToString Method (ColumnCountOutOfRangeException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > ColumnCountOutOfRangeException Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

ColumnCountOutOfRangeException Class
ColumnCountOutOfRangeException Members


CompressionException Class Methods

CompressionException Class Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : CompressionException Class

For a list of all members of this type, see CompressionException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

CompressionException Class
GrapeCity.SpreadBuilder Namespace


CompressionException Class Properties

CompressionException Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : CompressionException Class

For a list of all members of this type, see CompressionException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

CompressionException Class
GrapeCity.SpreadBuilder Namespace


Data Property (CompressionException)

Data Property (CompressionException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : Data Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Data As System.Collections.IDictionary
public virtual System.Collections.IDictionary Data {get;}
See Also

Reference

CompressionException Class
CompressionException Members


GetBaseException Method (CompressionException)

GetBaseException Method (CompressionException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetBaseException() As System.Exception
public virtual System.Exception GetBaseException()
See Also

Reference

CompressionException Class
CompressionException Members


GetObjectData Method (CompressionException)

GetObjectData Method (CompressionException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
See Also

Reference

CompressionException Class
CompressionException Members


GetType Method (CompressionException)

GetType Method (CompressionException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
See Also

Reference

CompressionException Class
CompressionException Members


GetType() Method

GetType() Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetType() As System.Type
public System.Type GetType()
See Also

Reference

CompressionException Class
CompressionException Members


HelpLink Property (CompressionException)

HelpLink Property (CompressionException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property HelpLink As System.String
public virtual System.string HelpLink {get; set;}
See Also

Reference

CompressionException Class
CompressionException Members


HResult Property (CompressionException)

HResult Property (CompressionException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : HResult Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HResult As System.Integer
public System.int HResult {get;}
See Also

Reference

CompressionException Class
CompressionException Members


InnerException Property (CompressionException)

InnerException Property (CompressionException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InnerException As System.Exception
public System.Exception InnerException {get;}
See Also

Reference

CompressionException Class
CompressionException Members


Message Property (CompressionException)

Message Property (CompressionException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : Message Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Message As System.String
public virtual System.string Message {get;}
See Also

Reference

CompressionException Class
CompressionException Members


Source Property (CompressionException)

Source Property (CompressionException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : Source Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Source As System.String
public virtual System.string Source {get; set;}
See Also

Reference

CompressionException Class
CompressionException Members


StackTrace Property (CompressionException)

StackTrace Property (CompressionException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property StackTrace As System.String
public virtual System.string StackTrace {get;}
See Also

Reference

CompressionException Class
CompressionException Members


TargetSite Property (CompressionException)

TargetSite Property (CompressionException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
public System.Reflection.MethodBase TargetSite {get;}
See Also

Reference

CompressionException Class
CompressionException Members


ToString Method (CompressionException)

ToString Method (CompressionException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > CompressionException Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

CompressionException Class
CompressionException Members


DDSheetNameAlreadyExistsException Class Methods

DDSheetNameAlreadyExistsException Class Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : DDSheetNameAlreadyExistsException Class

For a list of all members of this type, see DDSheetNameAlreadyExistsException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.ArgumentException)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

DDSheetNameAlreadyExistsException Class
GrapeCity.SpreadBuilder Namespace


DDSheetNameAlreadyExistsException Class Properties

DDSheetNameAlreadyExistsException Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : DDSheetNameAlreadyExistsException Class

For a list of all members of this type, see DDSheetNameAlreadyExistsException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.ArgumentException)
Public Property | ParamName | (Inherited from System.ArgumentException)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

DDSheetNameAlreadyExistsException Class
GrapeCity.SpreadBuilder Namespace


Data Property (DDSheetNameAlreadyExistsException)

Data Property (DDSheetNameAlreadyExistsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : Data Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Data As System.Collections.IDictionary
public virtual System.Collections.IDictionary Data {get;}
See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


GetBaseException Method (DDSheetNameAlreadyExistsException)

GetBaseException Method (DDSheetNameAlreadyExistsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetBaseException() As System.Exception
public virtual System.Exception GetBaseException()
See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


GetObjectData Method (DDSheetNameAlreadyExistsException)

GetObjectData Method (DDSheetNameAlreadyExistsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


GetType Method (DDSheetNameAlreadyExistsException)

GetType Method (DDSheetNameAlreadyExistsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


GetType() Method

GetType() Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetType() As System.Type
public System.Type GetType()
See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


HelpLink Property (DDSheetNameAlreadyExistsException)

HelpLink Property (DDSheetNameAlreadyExistsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property HelpLink As System.String
public virtual System.string HelpLink {get; set;}
See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


HResult Property (DDSheetNameAlreadyExistsException)

HResult Property (DDSheetNameAlreadyExistsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : HResult Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HResult As System.Integer
public System.int HResult {get;}
See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


InnerException Property (DDSheetNameAlreadyExistsException)

InnerException Property (DDSheetNameAlreadyExistsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InnerException As System.Exception
public System.Exception InnerException {get;}
See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


Message Property (DDSheetNameAlreadyExistsException)

Message Property (DDSheetNameAlreadyExistsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : Message Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Message As System.String
public virtual System.string Message {get;}
See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


ParamName Property (DDSheetNameAlreadyExistsException)

ParamName Property (DDSheetNameAlreadyExistsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : ParamName Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property ParamName As System.String
public virtual System.string ParamName {get;}
See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


Source Property (DDSheetNameAlreadyExistsException)

Source Property (DDSheetNameAlreadyExistsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : Source Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Source As System.String
public virtual System.string Source {get; set;}
See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


StackTrace Property (DDSheetNameAlreadyExistsException)

StackTrace Property (DDSheetNameAlreadyExistsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property StackTrace As System.String
public virtual System.string StackTrace {get;}
See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


TargetSite Property (DDSheetNameAlreadyExistsException)

TargetSite Property (DDSheetNameAlreadyExistsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
public System.Reflection.MethodBase TargetSite {get;}
See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


ToString Method (DDSheetNameAlreadyExistsException)

ToString Method (DDSheetNameAlreadyExistsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheetNameAlreadyExistsException Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

DDSheetNameAlreadyExistsException Class
DDSheetNameAlreadyExistsException Members


AddImage Method

AddImage Method
Example

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > DDSheet Class : AddImage Method
Adds the specified image (stored in PNG format) to the sheet at the specified location with the specified settings.
Overload List
Overload | Description
AddImage | Adds the specified image (currently stored as PNG format) to this sheet with the specified location, and settings.
Example
  • C#

  • Visual Basic
    •

See Also
Reference
DDSheet Class

DDSheet Members


LineInfo Constructor

LineInfo Constructor

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder.Imaging Namespace > LineInfo Class : LineInfo Constructor
Initializes a new instance of the LineInfo class.
Overload List
Overload | Description
LineInfo Constructor | Initializes a new instance of the LineInfo class.
See Also

Reference

LineInfo Class
LineInfo Members


GrapeCity.SpreadBuilder.Imaging Namespace Inheritance Hierarchy

GrapeCity.SpreadBuilder.Imaging Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Excel.v10 Assembly : GrapeCity.SpreadBuilder.Imaging Namespace
Inheritance Hierarchy
System.Object
GrapeCity.SpreadBuilder.Imaging.Biff7PictureRecord
GrapeCity.SpreadBuilder.Imaging.LineInfo
System.ValueType
GrapeCity.SpreadBuilder.Imaging.ImageInfo
See Also

Reference

GrapeCity.ActiveReports.Export.Excel.v10 Assembly


InvalidDDSheetNameException Class Methods

InvalidDDSheetNameException Class Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : InvalidDDSheetNameException Class

For a list of all members of this type, see InvalidDDSheetNameException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.ArgumentException)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

InvalidDDSheetNameException Class
GrapeCity.SpreadBuilder Namespace


InvalidDDSheetNameException Class Properties

InvalidDDSheetNameException Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : InvalidDDSheetNameException Class

For a list of all members of this type, see InvalidDDSheetNameException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.ArgumentException)
Public Property | ParamName | (Inherited from System.ArgumentException)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

InvalidDDSheetNameException Class
GrapeCity.SpreadBuilder Namespace


Data Property (InvalidDDSheetNameException)

Data Property (InvalidDDSheetNameException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : Data Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Data As System.Collections.IDictionary
public virtual System.Collections.IDictionary Data {get;}
See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


GetBaseException Method (InvalidDDSheetNameException)

GetBaseException Method (InvalidDDSheetNameException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetBaseException() As System.Exception
public virtual System.Exception GetBaseException()
See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


GetObjectData Method (InvalidDDSheetNameException)

GetObjectData Method (InvalidDDSheetNameException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


GetType Method (InvalidDDSheetNameException)

GetType Method (InvalidDDSheetNameException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


GetType() Method

GetType() Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetType() As System.Type
public System.Type GetType()
See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


HelpLink Property (InvalidDDSheetNameException)

HelpLink Property (InvalidDDSheetNameException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property HelpLink As System.String
public virtual System.string HelpLink {get; set;}
See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


HResult Property (InvalidDDSheetNameException)

HResult Property (InvalidDDSheetNameException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : HResult Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HResult As System.Integer
public System.int HResult {get;}
See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


InnerException Property (InvalidDDSheetNameException)

InnerException Property (InvalidDDSheetNameException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InnerException As System.Exception
public System.Exception InnerException {get;}
See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


Message Property (InvalidDDSheetNameException)

Message Property (InvalidDDSheetNameException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : Message Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Message As System.String
public virtual System.string Message {get;}
See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


ParamName Property (InvalidDDSheetNameException)

ParamName Property (InvalidDDSheetNameException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : ParamName Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property ParamName As System.String
public virtual System.string ParamName {get;}
See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


Source Property (InvalidDDSheetNameException)

Source Property (InvalidDDSheetNameException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : Source Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Source As System.String
public virtual System.string Source {get; set;}
See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


StackTrace Property (InvalidDDSheetNameException)

StackTrace Property (InvalidDDSheetNameException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property StackTrace As System.String
public virtual System.string StackTrace {get;}
See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


TargetSite Property (InvalidDDSheetNameException)

TargetSite Property (InvalidDDSheetNameException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
public System.Reflection.MethodBase TargetSite {get;}
See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


ToString Method (InvalidDDSheetNameException)

ToString Method (InvalidDDSheetNameException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidDDSheetNameException Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

InvalidDDSheetNameException Class
InvalidDDSheetNameException Members


InvalidPasswordException Class Methods

InvalidPasswordException Class Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : InvalidPasswordException Class

For a list of all members of this type, see InvalidPasswordException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

InvalidPasswordException Class
GrapeCity.SpreadBuilder Namespace


InvalidPasswordException Class Properties

InvalidPasswordException Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : InvalidPasswordException Class

For a list of all members of this type, see InvalidPasswordException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

InvalidPasswordException Class
GrapeCity.SpreadBuilder Namespace


Data Property (InvalidPasswordException)

Data Property (InvalidPasswordException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : Data Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Data As System.Collections.IDictionary
public virtual System.Collections.IDictionary Data {get;}
See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


GetBaseException Method (InvalidPasswordException)

GetBaseException Method (InvalidPasswordException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetBaseException() As System.Exception
public virtual System.Exception GetBaseException()
See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


GetObjectData Method (InvalidPasswordException)

GetObjectData Method (InvalidPasswordException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


GetType Method (InvalidPasswordException)

GetType Method (InvalidPasswordException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


GetType() Method

GetType() Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetType() As System.Type
public System.Type GetType()
See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


HelpLink Property (InvalidPasswordException)

HelpLink Property (InvalidPasswordException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property HelpLink As System.String
public virtual System.string HelpLink {get; set;}
See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


HResult Property (InvalidPasswordException)

HResult Property (InvalidPasswordException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : HResult Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HResult As System.Integer
public System.int HResult {get;}
See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


InnerException Property (InvalidPasswordException)

InnerException Property (InvalidPasswordException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InnerException As System.Exception
public System.Exception InnerException {get;}
See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


Message Property (InvalidPasswordException)

Message Property (InvalidPasswordException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : Message Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Message As System.String
public virtual System.string Message {get;}
See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


Source Property (InvalidPasswordException)

Source Property (InvalidPasswordException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : Source Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Source As System.String
public virtual System.string Source {get; set;}
See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


StackTrace Property (InvalidPasswordException)

StackTrace Property (InvalidPasswordException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property StackTrace As System.String
public virtual System.string StackTrace {get;}
See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


TargetSite Property (InvalidPasswordException)

TargetSite Property (InvalidPasswordException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
public System.Reflection.MethodBase TargetSite {get;}
See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


ToString Method (InvalidPasswordException)

ToString Method (InvalidPasswordException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > InvalidPasswordException Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

InvalidPasswordException Class
InvalidPasswordException Members


NoDDSheetsException Class Methods

NoDDSheetsException Class Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : NoDDSheetsException Class

For a list of all members of this type, see NoDDSheetsException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

NoDDSheetsException Class
GrapeCity.SpreadBuilder Namespace


NoDDSheetsException Constructor

NoDDSheetsException Constructor

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : NoDDSheetsException Constructor
Initializes an instance of the NoDDSheetsException class.
Overload List
Overload | Description
NoDDSheetsException Constructor | Initializes an instance of the NoDDSheetsException class.
See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


Data Property (NoDDSheetsException)

Data Property (NoDDSheetsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : Data Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Data As System.Collections.IDictionary
public virtual System.Collections.IDictionary Data {get;}
See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


GetBaseException Method (NoDDSheetsException)

GetBaseException Method (NoDDSheetsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetBaseException() As System.Exception
public virtual System.Exception GetBaseException()
See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


GetObjectData Method (NoDDSheetsException)

GetObjectData Method (NoDDSheetsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


GetType Method (NoDDSheetsException)

GetType Method (NoDDSheetsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


GetType() Method

GetType() Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetType() As System.Type
public System.Type GetType()
See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


HelpLink Property (NoDDSheetsException)

HelpLink Property (NoDDSheetsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property HelpLink As System.String
public virtual System.string HelpLink {get; set;}
See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


HResult Property (NoDDSheetsException)

HResult Property (NoDDSheetsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : HResult Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HResult As System.Integer
public System.int HResult {get;}
See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


InnerException Property (NoDDSheetsException)

InnerException Property (NoDDSheetsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InnerException As System.Exception
public System.Exception InnerException {get;}
See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


Source Property (NoDDSheetsException)

Source Property (NoDDSheetsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : Source Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Source As System.String
public virtual System.string Source {get; set;}
See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


StackTrace Property (NoDDSheetsException)

StackTrace Property (NoDDSheetsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property StackTrace As System.String
public virtual System.string StackTrace {get;}
See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


TargetSite Property (NoDDSheetsException)

TargetSite Property (NoDDSheetsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
public System.Reflection.MethodBase TargetSite {get;}
See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


ToString Method (NoDDSheetsException)

ToString Method (NoDDSheetsException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > NoDDSheetsException Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

NoDDSheetsException Class
NoDDSheetsException Members


GrapeCity.SpreadBuilder.Printing Namespace Inheritance Hierarchy

GrapeCity.SpreadBuilder.Printing Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Excel.v10 Assembly : GrapeCity.SpreadBuilder.Printing Namespace
Inheritance Hierarchy
System.Object
GrapeCity.SpreadBuilder.Printing.PageSetup
See Also

Reference

GrapeCity.ActiveReports.Export.Excel.v10 Assembly


RowCountOutOfRangeException Class Methods

RowCountOutOfRangeException Class Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : RowCountOutOfRangeException Class

For a list of all members of this type, see RowCountOutOfRangeException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

RowCountOutOfRangeException Class
GrapeCity.SpreadBuilder Namespace


RowCountOutOfRangeException Class Properties

RowCountOutOfRangeException Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : RowCountOutOfRangeException Class

For a list of all members of this type, see RowCountOutOfRangeException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

RowCountOutOfRangeException Class
GrapeCity.SpreadBuilder Namespace


Data Property (RowCountOutOfRangeException)

Data Property (RowCountOutOfRangeException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : Data Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Data As System.Collections.IDictionary
public virtual System.Collections.IDictionary Data {get;}
See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


GetBaseException Method (RowCountOutOfRangeException)

GetBaseException Method (RowCountOutOfRangeException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetBaseException() As System.Exception
public virtual System.Exception GetBaseException()
See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


GetObjectData Method (RowCountOutOfRangeException)

GetObjectData Method (RowCountOutOfRangeException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


GetType Method (RowCountOutOfRangeException)

GetType Method (RowCountOutOfRangeException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


GetType() Method

GetType() Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetType() As System.Type
public System.Type GetType()
See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


HelpLink Property (RowCountOutOfRangeException)

HelpLink Property (RowCountOutOfRangeException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property HelpLink As System.String
public virtual System.string HelpLink {get; set;}
See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


HResult Property (RowCountOutOfRangeException)

HResult Property (RowCountOutOfRangeException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : HResult Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HResult As System.Integer
public System.int HResult {get;}
See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


InnerException Property (RowCountOutOfRangeException)

InnerException Property (RowCountOutOfRangeException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InnerException As System.Exception
public System.Exception InnerException {get;}
See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


Message Property (RowCountOutOfRangeException)

Message Property (RowCountOutOfRangeException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : Message Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Message As System.String
public virtual System.string Message {get;}
See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


Source Property (RowCountOutOfRangeException)

Source Property (RowCountOutOfRangeException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : Source Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Source As System.String
public virtual System.string Source {get; set;}
See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


StackTrace Property (RowCountOutOfRangeException)

StackTrace Property (RowCountOutOfRangeException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property StackTrace As System.String
public virtual System.string StackTrace {get;}
See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


TargetSite Property (RowCountOutOfRangeException)

TargetSite Property (RowCountOutOfRangeException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
public System.Reflection.MethodBase TargetSite {get;}
See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


ToString Method (RowCountOutOfRangeException)

ToString Method (RowCountOutOfRangeException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > RowCountOutOfRangeException Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

RowCountOutOfRangeException Class
RowCountOutOfRangeException Members


SpreadBuilderException Class Methods

SpreadBuilderException Class Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : SpreadBuilderException Class

For a list of all members of this type, see SpreadBuilderException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

SpreadBuilderException Class
GrapeCity.SpreadBuilder Namespace


SpreadBuilderException Class Properties

SpreadBuilderException Class Properties

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : SpreadBuilderException Class

For a list of all members of this type, see SpreadBuilderException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

SpreadBuilderException Class
GrapeCity.SpreadBuilder Namespace


Data Property (SpreadBuilderException)

Data Property (SpreadBuilderException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : Data Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Data As System.Collections.IDictionary
public virtual System.Collections.IDictionary Data {get;}
See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


GetBaseException Method (SpreadBuilderException)

GetBaseException Method (SpreadBuilderException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetBaseException() As System.Exception
public virtual System.Exception GetBaseException()
See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


GetObjectData Method (SpreadBuilderException)

GetObjectData Method (SpreadBuilderException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


GetType Method (SpreadBuilderException)

GetType Method (SpreadBuilderException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


GetType() Method

GetType() Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetType() As System.Type
public System.Type GetType()
See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


HelpLink Property (SpreadBuilderException)

HelpLink Property (SpreadBuilderException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property HelpLink As System.String
public virtual System.string HelpLink {get; set;}
See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


HResult Property (SpreadBuilderException)

HResult Property (SpreadBuilderException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : HResult Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HResult As System.Integer
public System.int HResult {get;}
See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


InnerException Property (SpreadBuilderException)

InnerException Property (SpreadBuilderException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InnerException As System.Exception
public System.Exception InnerException {get;}
See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


Message Property (SpreadBuilderException)

Message Property (SpreadBuilderException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : Message Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Message As System.String
public virtual System.string Message {get;}
See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


Source Property (SpreadBuilderException)

Source Property (SpreadBuilderException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : Source Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Source As System.String
public virtual System.string Source {get; set;}
See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


StackTrace Property (SpreadBuilderException)

StackTrace Property (SpreadBuilderException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property StackTrace As System.String
public virtual System.string StackTrace {get;}
See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


TargetSite Property (SpreadBuilderException)

TargetSite Property (SpreadBuilderException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
public System.Reflection.MethodBase TargetSite {get;}
See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


ToString Method (SpreadBuilderException)

ToString Method (SpreadBuilderException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > SpreadBuilderException Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

SpreadBuilderException Class
SpreadBuilderException Members


GrapeCity.SpreadBuilder.Style Namespace Inheritance Hierarchy

GrapeCity.SpreadBuilder.Style Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Excel.v10 Assembly : GrapeCity.SpreadBuilder.Style Namespace
Inheritance Hierarchy
System.Object
See Also

Reference

GrapeCity.ActiveReports.Export.Excel.v10 Assembly


VersionNotImplementedException Class Methods

VersionNotImplementedException Class Methods

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace : VersionNotImplementedException Class

For a list of all members of this type, see VersionNotImplementedException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

VersionNotImplementedException Class
GrapeCity.SpreadBuilder Namespace


Data Property (VersionNotImplementedException)

Data Property (VersionNotImplementedException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : Data Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Data As System.Collections.IDictionary
public virtual System.Collections.IDictionary Data {get;}
See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


GetBaseException Method (VersionNotImplementedException)

GetBaseException Method (VersionNotImplementedException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetBaseException() As System.Exception
public virtual System.Exception GetBaseException()
See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


GetObjectData Method (VersionNotImplementedException)

GetObjectData Method (VersionNotImplementedException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


GetType Method (VersionNotImplementedException)

GetType Method (VersionNotImplementedException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


GetType() Method

GetType() Method

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetType() As System.Type
public System.Type GetType()
See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


HelpLink Property (VersionNotImplementedException)

HelpLink Property (VersionNotImplementedException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property HelpLink As System.String
public virtual System.string HelpLink {get; set;}
See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


HResult Property (VersionNotImplementedException)

HResult Property (VersionNotImplementedException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : HResult Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HResult As System.Integer
public System.int HResult {get;}
See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


InnerException Property (VersionNotImplementedException)

InnerException Property (VersionNotImplementedException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InnerException As System.Exception
public System.Exception InnerException {get;}
See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


Source Property (VersionNotImplementedException)

Source Property (VersionNotImplementedException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : Source Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Source As System.String
public virtual System.string Source {get; set;}
See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


StackTrace Property (VersionNotImplementedException)

StackTrace Property (VersionNotImplementedException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property StackTrace As System.String
public virtual System.string StackTrace {get;}
See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


TargetSite Property (VersionNotImplementedException)

TargetSite Property (VersionNotImplementedException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
public System.Reflection.MethodBase TargetSite {get;}
See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


ToString Method (VersionNotImplementedException)

ToString Method (VersionNotImplementedException)

GrapeCity.ActiveReports.Export.Excel.v10 Assembly > GrapeCity.SpreadBuilder Namespace > VersionNotImplementedException Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

VersionNotImplementedException Class
VersionNotImplementedException Members


ActiveReports 10


GrapeCity.SpreadBuilder Namespace Inheritance Hierarchy

GrapeCity.SpreadBuilder Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Excel.v10 Assembly : GrapeCity.SpreadBuilder Namespace
Inheritance Hierarchy
System.Object
GrapeCity.SpreadBuilder.DDColumn
GrapeCity.SpreadBuilder.DDRow
GrapeCity.SpreadBuilder.DDSecurity
GrapeCity.SpreadBuilder.DDSheet
GrapeCity.SpreadBuilder.DDSheets
GrapeCity.SpreadBuilder.Workbook
System.Exception
System.ApplicationException
GrapeCity.SpreadBuilder.SpreadBuilderException
GrapeCity.SpreadBuilder.ColumnCountOutOfRangeException
GrapeCity.SpreadBuilder.CompressionException
GrapeCity.SpreadBuilder.InvalidPasswordException
GrapeCity.SpreadBuilder.NoDDSheetsException
GrapeCity.SpreadBuilder.RowCountOutOfRangeException
GrapeCity.SpreadBuilder.VersionNotImplementedException
System.SystemException
System.ArgumentException
GrapeCity.SpreadBuilder.DDSheetNameAlreadyExistsException
GrapeCity.SpreadBuilder.InvalidDDSheetNameException
See Also

Reference

GrapeCity.ActiveReports.Export.Excel.v10 Assembly


GrapeCity.ActiveReports.Export.Html.v10 Assembly

GrapeCity.ActiveReports.Export.Html.v10 Assembly
The ActiveReports.HtmlExport Assembly contains the GrapeCity.ActiveReports.Export.Html Namespace.
Namespaces
Namespace | Description
GrapeCity.ActiveReports.Export.Html.Page | The GrapeCity.ActiveReports.Export.Html.Page namespace contains the information related to HTML rendering extensions and settings.
GrapeCity.ActiveReports.Export.Html.Section | The GrapeCity.ActiveReports.Export.Html.Section namespace contains the Html export component.


Dispose Method (EmailRenderingExtension)

Dispose Method (EmailRenderingExtension)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > EmailRenderingExtension Class : Dispose Method
Implements the Dispose logic of the EmailRenderingExtension Class.
Overload List
Overload | Description
Dispose | Implements the Dispose logic of the EmailRenderingExtension Class.
See Also

Reference

EmailRenderingExtension Class
EmailRenderingExtension Members


Dispose Method (HtmlRenderingExtension)

Dispose Method (HtmlRenderingExtension)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > HtmlRenderingExtension Class : Dispose Method
Implements the dispose logic of HtmlRenderingExtension class.
Overload List
Overload | Description
Dispose | Implements the dispose logic of HtmlRenderingExtension class.
See Also

Reference

HtmlRenderingExtension Class
HtmlRenderingExtension Members


Settings Constructor

Settings Constructor

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Page Namespace > Settings Class : Settings Constructor
Overload List
Overload | Description
Settings Constructor | Initializes a new instance of the Settings class.
See Also

Reference

Settings Class
Settings Members


GrapeCity.ActiveReports.Export.Html.Page Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Html.Page Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Html.v10 Assembly : GrapeCity.ActiveReports.Export.Html.Page Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Export.Html.Page.EmailRenderingExtension
GrapeCity.ActiveReports.Export.Html.Page.HtmlRenderingExtension
GrapeCity.ActiveReports.Export.Html.Page.Settings
See Also

Reference

GrapeCity.ActiveReports.Export.Html.v10 Assembly


HtmlExport Class Events

HtmlExport Class Events

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace : HtmlExport Class

For a list of all members of this type, see HtmlExport members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

HtmlExport Class
GrapeCity.ActiveReports.Export.Html.Section Namespace

Walkthroughs

Custom HTML Outputter


HtmlExportException Class Methods

HtmlExportException Class Methods

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace : HtmlExportException Class

For a list of all members of this type, see HtmlExportException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

HtmlExportException Class
GrapeCity.ActiveReports.Export.Html.Section Namespace


HtmlExportException Class Properties

HtmlExportException Class Properties

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace : HtmlExportException Class

For a list of all members of this type, see HtmlExportException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

HtmlExportException Class
GrapeCity.ActiveReports.Export.Html.Section Namespace


Data Property (HtmlExportException)

Data Property (HtmlExportException)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExportException Class : Data Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Data As System.Collections.IDictionary
public virtual System.Collections.IDictionary Data {get;}
See Also

Reference

HtmlExportException Class
HtmlExportException Members


GetBaseException Method (HtmlExportException)

GetBaseException Method (HtmlExportException)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExportException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetBaseException() As System.Exception
public virtual System.Exception GetBaseException()
See Also

Reference

HtmlExportException Class
HtmlExportException Members


GetObjectData Method (HtmlExportException)

GetObjectData Method (HtmlExportException)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExportException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
See Also

Reference

HtmlExportException Class
HtmlExportException Members


GetType Method (HtmlExportException)

GetType Method (HtmlExportException)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExportException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
See Also

Reference

HtmlExportException Class
HtmlExportException Members


GetType() Method

GetType() Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExportException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetType() As System.Type
public System.Type GetType()
See Also

Reference

HtmlExportException Class
HtmlExportException Members


HelpLink Property (HtmlExportException)

HelpLink Property (HtmlExportException)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExportException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property HelpLink As System.String
public virtual System.string HelpLink {get; set;}
See Also

Reference

HtmlExportException Class
HtmlExportException Members


HResult Property (HtmlExportException)

HResult Property (HtmlExportException)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExportException Class : HResult Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HResult As System.Integer
public System.int HResult {get;}
See Also

Reference

HtmlExportException Class
HtmlExportException Members


InnerException Property (HtmlExportException)

InnerException Property (HtmlExportException)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExportException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InnerException As System.Exception
public System.Exception InnerException {get;}
See Also

Reference

HtmlExportException Class
HtmlExportException Members


Message Property (HtmlExportException)

Message Property (HtmlExportException)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExportException Class : Message Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Message As System.String
public virtual System.string Message {get;}
See Also

Reference

HtmlExportException Class
HtmlExportException Members


Source Property (HtmlExportException)

Source Property (HtmlExportException)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExportException Class : Source Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Source As System.String
public virtual System.string Source {get; set;}
See Also

Reference

HtmlExportException Class
HtmlExportException Members


StackTrace Property (HtmlExportException)

StackTrace Property (HtmlExportException)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExportException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property StackTrace As System.String
public virtual System.string StackTrace {get;}
See Also

Reference

HtmlExportException Class
HtmlExportException Members


TargetSite Property (HtmlExportException)

TargetSite Property (HtmlExportException)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExportException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
public System.Reflection.MethodBase TargetSite {get;}
See Also

Reference

HtmlExportException Class
HtmlExportException Members


ToString Method (HtmlExportException)

ToString Method (HtmlExportException)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExportException Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

HtmlExportException Class
HtmlExportException Members


Container Property (HtmlExport)

Container Property (HtmlExport)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

HtmlExport Class
HtmlExport Members


CreateObjRef Method (HtmlExport)

CreateObjRef Method (HtmlExport)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

HtmlExport Class
HtmlExport Members


Dispose Method (HtmlExport)

Dispose Method (HtmlExport)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

HtmlExport Class
HtmlExport Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

HtmlExport Class
HtmlExport Members


Disposed Event (HtmlExport)

Disposed Event (HtmlExport)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

HtmlExport Class
HtmlExport Members


GetLifetimeService Method (HtmlExport)

GetLifetimeService Method (HtmlExport)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

HtmlExport Class
HtmlExport Members


InitializeLifetimeService Method (HtmlExport)

InitializeLifetimeService Method (HtmlExport)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

HtmlExport Class
HtmlExport Members


Site Property (HtmlExport)

Site Property (HtmlExport)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

HtmlExport Class
HtmlExport Members


ToString Method (HtmlExport)

ToString Method (HtmlExport)

GrapeCity.ActiveReports.Export.Html.v10 Assembly > GrapeCity.ActiveReports.Export.Html.Section Namespace > HtmlExport Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

HtmlExport Class
HtmlExport Members


GrapeCity.ActiveReports.Export.Html.Section Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Html.Section Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Html.v10 Assembly : GrapeCity.ActiveReports.Export.Html.Section Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Export.Html.Section.OutputHtmlFiles
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.Export.Html.Section.HtmlExportException
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Export.Html.Section.HtmlExport
See Also

Reference

GrapeCity.ActiveReports.Export.Html.v10 Assembly


GrapeCity.ActiveReports.Export.Image.v10 Assembly

GrapeCity.ActiveReports.Export.Image.v10 Assembly
Namespaces
Namespace | Description
GrapeCity.ActiveReports.Export.Image.Page | The GrapeCity.ActiveReports.Export.Image.Page contains Image export classes for page layout.
GrapeCity.ActiveReports.Export.Image.Page.Renderers | The GrapeCity.ActiveReports.Export.Page.Renderers namespace contains the information on images to be rendered.
GrapeCity.ActiveReports.Export.Image.Tiff.Section | The GrapeCity.ActiveReports.Export.Tiff.Section namespace contains the TIFF export classes.


GrapeCity.ActiveReports.Export.Image.Page.Renderers Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Image.Page.Renderers Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Image.v10 Assembly : GrapeCity.ActiveReports.Export.Image.Page.Renderers Namespace
Inheritance Hierarchy
System.Object
See Also

Reference

GrapeCity.ActiveReports.Export.Image.v10 Assembly


GrapeCity.ActiveReports.Export.Image.Page Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Image.Page Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Image.v10 Assembly : GrapeCity.ActiveReports.Export.Image.Page Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Export.Image.Page.ImageRenderingExtension
GrapeCity.ActiveReports.Export.Image.Page.Settings
See Also

Reference

GrapeCity.ActiveReports.Export.Image.v10 Assembly


TiffExport Class Events

TiffExport Class Events

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace : TiffExport Class

For a list of all members of this type, see TiffExport members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

TiffExport Class
GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace


TiffExportException Class Methods

TiffExportException Class Methods

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace : TiffExportException Class

For a list of all members of this type, see TiffExportException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

TiffExportException Class
GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace


TiffExportException Class Properties

TiffExportException Class Properties

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace : TiffExportException Class

For a list of all members of this type, see TiffExportException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

TiffExportException Class
GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace


Data Property (TiffExportException)

Data Property (TiffExportException)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : Data Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Data As System.Collections.IDictionary
public virtual System.Collections.IDictionary Data {get;}
See Also

Reference

TiffExportException Class
TiffExportException Members


GetBaseException Method (TiffExportException)

GetBaseException Method (TiffExportException)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetBaseException() As System.Exception
public virtual System.Exception GetBaseException()
See Also

Reference

TiffExportException Class
TiffExportException Members


GetObjectData Method (TiffExportException)

GetObjectData Method (TiffExportException)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
See Also

Reference

TiffExportException Class
TiffExportException Members


GetType Method (TiffExportException)

GetType Method (TiffExportException)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
See Also

Reference

TiffExportException Class
TiffExportException Members


GetType() Method

GetType() Method

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetType() As System.Type
public System.Type GetType()
See Also

Reference

TiffExportException Class
TiffExportException Members


HelpLink Property (TiffExportException)

HelpLink Property (TiffExportException)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property HelpLink As System.String
public virtual System.string HelpLink {get; set;}
See Also

Reference

TiffExportException Class
TiffExportException Members


HResult Property (TiffExportException)

HResult Property (TiffExportException)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : HResult Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HResult As System.Integer
public System.int HResult {get;}
See Also

Reference

TiffExportException Class
TiffExportException Members


InnerException Property (TiffExportException)

InnerException Property (TiffExportException)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InnerException As System.Exception
public System.Exception InnerException {get;}
See Also

Reference

TiffExportException Class
TiffExportException Members


Message Property (TiffExportException)

Message Property (TiffExportException)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : Message Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Message As System.String
public virtual System.string Message {get;}
See Also

Reference

TiffExportException Class
TiffExportException Members


Source Property (TiffExportException)

Source Property (TiffExportException)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : Source Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Source As System.String
public virtual System.string Source {get; set;}
See Also

Reference

TiffExportException Class
TiffExportException Members


StackTrace Property (TiffExportException)

StackTrace Property (TiffExportException)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property StackTrace As System.String
public virtual System.string StackTrace {get;}
See Also

Reference

TiffExportException Class
TiffExportException Members


TargetSite Property (TiffExportException)

TargetSite Property (TiffExportException)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
public System.Reflection.MethodBase TargetSite {get;}
See Also

Reference

TiffExportException Class
TiffExportException Members


ToString Method (TiffExportException)

ToString Method (TiffExportException)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExportException Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

TiffExportException Class
TiffExportException Members


Container Property (TiffExport)

Container Property (TiffExport)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

TiffExport Class
TiffExport Members


CreateObjRef Method (TiffExport)

CreateObjRef Method (TiffExport)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

TiffExport Class
TiffExport Members


Dispose Method (TiffExport)

Dispose Method (TiffExport)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

TiffExport Class
TiffExport Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

TiffExport Class
TiffExport Members


Disposed Event (TiffExport)

Disposed Event (TiffExport)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

TiffExport Class
TiffExport Members


GetLifetimeService Method (TiffExport)

GetLifetimeService Method (TiffExport)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

TiffExport Class
TiffExport Members


InitializeLifetimeService Method (TiffExport)

InitializeLifetimeService Method (TiffExport)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
public virtual System.object InitializeLifetimeService()
See Also

Reference

TiffExport Class
TiffExport Members


Site Property (TiffExport)

Site Property (TiffExport)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
public virtual System.ComponentModel.ISite Site {get; set;}
See Also

Reference

TiffExport Class
TiffExport Members


ToString Method (TiffExport)

ToString Method (TiffExport)

GrapeCity.ActiveReports.Export.Image.v10 Assembly > GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace > TiffExport Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

TiffExport Class
TiffExport Members


GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Image.v10 Assembly : GrapeCity.ActiveReports.Export.Image.Tiff.Section Namespace
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExportException
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Export.Image.Tiff.Section.TiffExport
See Also

Reference

GrapeCity.ActiveReports.Export.Image.v10 Assembly


GrapeCity.ActiveReports.Export.Pdf.v10 Assembly

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly
Namespaces
Namespace | Description
GrapeCity.ActiveReports.Export.Pdf | The GrapeCity.ActiveReports.Export.Pdf namespace includes the Enums.ImageInterpolation enumeration.
GrapeCity.ActiveReports.Export.Pdf.Page | The GrapeCity.ActiveReports.Export.Pdf.Page namspace includes the PDF export controls.
GrapeCity.ActiveReports.Export.Pdf.Section | The GrapeCity.ActiveReports.Export.Pdf Section namespace includes PDF export filters.
GrapeCity.ActiveReports.Export.Pdf.Section.Signing | This function is only supported in the Professional version. In the Standard version, a banner indicating that a Professional license is required to output the PDF, is displayed.


GrapeCity.ActiveReports.Export.Pdf.Page Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Pdf.Page Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Pdf.v10 Assembly : GrapeCity.ActiveReports.Export.Pdf.Page Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Export.Pdf.Page.PdfRenderingExtension
GrapeCity.ActiveReports.Export.Pdf.Page.Settings
See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly


PdfExport Class Events

PdfExport Class Events

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfExport Class

For a list of all members of this type, see PdfExport members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

PdfExport Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfExportException Class Methods

PdfExportException Class Methods

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfExportException Class

For a list of all members of this type, see PdfExportException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

PdfExportException Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfExportException Class Properties

PdfExportException Class Properties

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfExportException Class

For a list of all members of this type, see PdfExportException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

PdfExportException Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


Data Property (PdfExportException)

Data Property (PdfExportException)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : Data Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Data As System.Collections.IDictionary
public virtual System.Collections.IDictionary Data {get;}
See Also

Reference

PdfExportException Class
PdfExportException Members


GetBaseException Method (PdfExportException)

GetBaseException Method (PdfExportException)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetBaseException() As System.Exception
public virtual System.Exception GetBaseException()
See Also

Reference

PdfExportException Class
PdfExportException Members


GetObjectData Method (PdfExportException)

GetObjectData Method (PdfExportException)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
See Also

Reference

PdfExportException Class
PdfExportException Members


GetType Method (PdfExportException)

GetType Method (PdfExportException)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
See Also

Reference

PdfExportException Class
PdfExportException Members


GetType() Method

GetType() Method

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetType() As System.Type
public System.Type GetType()
See Also

Reference

PdfExportException Class
PdfExportException Members


HelpLink Property (PdfExportException)

HelpLink Property (PdfExportException)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property HelpLink As System.String
public virtual System.string HelpLink {get; set;}
See Also

Reference

PdfExportException Class
PdfExportException Members


HResult Property (PdfExportException)

HResult Property (PdfExportException)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : HResult Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HResult As System.Integer
public System.int HResult {get;}
See Also

Reference

PdfExportException Class
PdfExportException Members


InnerException Property (PdfExportException)

InnerException Property (PdfExportException)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InnerException As System.Exception
public System.Exception InnerException {get;}
See Also

Reference

PdfExportException Class
PdfExportException Members


Message Property (PdfExportException)

Message Property (PdfExportException)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : Message Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Message As System.String
public virtual System.string Message {get;}
See Also

Reference

PdfExportException Class
PdfExportException Members


Source Property (PdfExportException)

Source Property (PdfExportException)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : Source Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Source As System.String
public virtual System.string Source {get; set;}
See Also

Reference

PdfExportException Class
PdfExportException Members


StackTrace Property (PdfExportException)

StackTrace Property (PdfExportException)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property StackTrace As System.String
public virtual System.string StackTrace {get;}
See Also

Reference

PdfExportException Class
PdfExportException Members


TargetSite Property (PdfExportException)

TargetSite Property (PdfExportException)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
public System.Reflection.MethodBase TargetSite {get;}
See Also

Reference

PdfExportException Class
PdfExportException Members


ToString Method (PdfExportException)

ToString Method (PdfExportException)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExportException Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

PdfExportException Class
PdfExportException Members


PdfExport Constructor

PdfExport Constructor

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : PdfExport Constructor
Overload List
Overload | Description
PdfExport Constructor | Initializes a new instance of the PdfExport class.
See Also

Reference

PdfExport Class
PdfExport Members


Container Property (PdfExport)

Container Property (PdfExport)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

PdfExport Class
PdfExport Members


CreateObjRef Method (PdfExport)

CreateObjRef Method (PdfExport)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

PdfExport Class
PdfExport Members


Dispose Method (PdfExport)

Dispose Method (PdfExport)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : Dispose Method
Disposes the engine.
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

PdfExport Class
PdfExport Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

PdfExport Class
PdfExport Members


Disposed Event (PdfExport)

Disposed Event (PdfExport)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

PdfExport Class
PdfExport Members


GetLifetimeService Method (PdfExport)

GetLifetimeService Method (PdfExport)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

PdfExport Class
PdfExport Members


InitializeLifetimeService Method (PdfExport)

InitializeLifetimeService Method (PdfExport)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

PdfExport Class
PdfExport Members


Site Property (PdfExport)

Site Property (PdfExport)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

PdfExport Class
PdfExport Members


ToString Method (PdfExport)

ToString Method (PdfExport)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfExport Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

PdfExport Class
PdfExport Members


PdfSigningException Class Methods

PdfSigningException Class Methods

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfSigningException Class

For a list of all members of this type, see PdfSigningException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

PdfSigningException Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


PdfSigningException Class Properties

PdfSigningException Class Properties

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace : PdfSigningException Class

For a list of all members of this type, see PdfSigningException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

PdfSigningException Class
GrapeCity.ActiveReports.Export.Pdf.Section Namespace


Data Property (PdfSigningException)

Data Property (PdfSigningException)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : Data Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Data As System.Collections.IDictionary
public virtual System.Collections.IDictionary Data {get;}
See Also

Reference

PdfSigningException Class
PdfSigningException Members


GetBaseException Method (PdfSigningException)

GetBaseException Method (PdfSigningException)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetBaseException() As System.Exception
public virtual System.Exception GetBaseException()
See Also

Reference

PdfSigningException Class
PdfSigningException Members


GetObjectData Method (PdfSigningException)

GetObjectData Method (PdfSigningException)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
See Also

Reference

PdfSigningException Class
PdfSigningException Members


GetType Method (PdfSigningException)

GetType Method (PdfSigningException)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
See Also

Reference

PdfSigningException Class
PdfSigningException Members


GetType() Method

GetType() Method

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetType() As System.Type
public System.Type GetType()
See Also

Reference

PdfSigningException Class
PdfSigningException Members


HelpLink Property (PdfSigningException)

HelpLink Property (PdfSigningException)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property HelpLink As System.String
public virtual System.string HelpLink {get; set;}
See Also

Reference

PdfSigningException Class
PdfSigningException Members


HResult Property (PdfSigningException)

HResult Property (PdfSigningException)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : HResult Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HResult As System.Integer
public System.int HResult {get;}
See Also

Reference

PdfSigningException Class
PdfSigningException Members


InnerException Property (PdfSigningException)

InnerException Property (PdfSigningException)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InnerException As System.Exception
public System.Exception InnerException {get;}
See Also

Reference

PdfSigningException Class
PdfSigningException Members


Message Property (PdfSigningException)

Message Property (PdfSigningException)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : Message Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Message As System.String
public virtual System.string Message {get;}
See Also

Reference

PdfSigningException Class
PdfSigningException Members


Source Property (PdfSigningException)

Source Property (PdfSigningException)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : Source Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Source As System.String
public virtual System.string Source {get; set;}
See Also

Reference

PdfSigningException Class
PdfSigningException Members


StackTrace Property (PdfSigningException)

StackTrace Property (PdfSigningException)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property StackTrace As System.String
public virtual System.string StackTrace {get;}
See Also

Reference

PdfSigningException Class
PdfSigningException Members


TargetSite Property (PdfSigningException)

TargetSite Property (PdfSigningException)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
public System.Reflection.MethodBase TargetSite {get;}
See Also

Reference

PdfSigningException Class
PdfSigningException Members


ToString Method (PdfSigningException)

ToString Method (PdfSigningException)

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly > GrapeCity.ActiveReports.Export.Pdf.Section Namespace > PdfSigningException Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

PdfSigningException Class
PdfSigningException Members


GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Pdf.v10 Assembly : GrapeCity.ActiveReports.Export.Pdf.Section.Signing Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Export.Pdf.Section.Signing.PdfSignature
GrapeCity.ActiveReports.Export.Pdf.Section.Signing.PdfStamp
GrapeCity.ActiveReports.Export.Pdf.Section.Signing.SignatureField<T>
GrapeCity.ActiveReports.Export.Pdf.Section.Signing.TimeStamp
See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly


GrapeCity.ActiveReports.Export.Pdf.Section Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Pdf.Section Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Pdf.v10 Assembly : GrapeCity.ActiveReports.Export.Pdf.Section Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Export.Pdf.Section.PdfDocumentOptions
GrapeCity.ActiveReports.Export.Pdf.Section.PdfSecurity
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExportException
GrapeCity.ActiveReports.Export.Pdf.Section.PdfSigningException
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport
See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly


GrapeCity.ActiveReports.Export.Pdf Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Pdf Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Pdf.v10 Assembly : GrapeCity.ActiveReports.Export.Pdf Namespace
Inheritance Hierarchy
System.Object
See Also

Reference

GrapeCity.ActiveReports.Export.Pdf.v10 Assembly


GrapeCity.ActiveReports.Export.Word.v10 Assembly

GrapeCity.ActiveReports.Export.Word.v10 Assembly
Namespaces
Namespace | Description
GrapeCity.ActiveReports.Export.Word.Page | The GrapeCity.ActiveReports.Export.Word.Page namespace includes information related to Settings and Word Rendering Extension.
GrapeCity.ActiveReports.Export.Word.Section | The GrapeCity.ActiveReports.Export.Word.Section namespace contains the RTF (Rich Text Format) export classes.


GrapeCity.ActiveReports.Export.Word.Page Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Word.Page Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Word.v10 Assembly : GrapeCity.ActiveReports.Export.Word.Page Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Export.Word.Page.Settings
GrapeCity.ActiveReports.Export.Word.Page.WordRenderingExtension
See Also

Reference

GrapeCity.ActiveReports.Export.Word.v10 Assembly


RtfExport Class Events

RtfExport Class Events

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace : RtfExport Class

For a list of all members of this type, see RtfExport members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

RtfExport Class
GrapeCity.ActiveReports.Export.Word.Section Namespace


RtfExportException Class Methods

RtfExportException Class Methods

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace : RtfExportException Class

For a list of all members of this type, see RtfExportException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

RtfExportException Class
GrapeCity.ActiveReports.Export.Word.Section Namespace


RtfExportException Class Properties

RtfExportException Class Properties

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace : RtfExportException Class

For a list of all members of this type, see RtfExportException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

RtfExportException Class
GrapeCity.ActiveReports.Export.Word.Section Namespace


Data Property (RtfExportException)

Data Property (RtfExportException)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : Data Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Data As System.Collections.IDictionary
public virtual System.Collections.IDictionary Data {get;}
See Also

Reference

RtfExportException Class
RtfExportException Members


GetBaseException Method (RtfExportException)

GetBaseException Method (RtfExportException)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetBaseException() As System.Exception
public virtual System.Exception GetBaseException()
See Also

Reference

RtfExportException Class
RtfExportException Members


GetObjectData Method (RtfExportException)

GetObjectData Method (RtfExportException)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
See Also

Reference

RtfExportException Class
RtfExportException Members


GetType Method (RtfExportException)

GetType Method (RtfExportException)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
See Also

Reference

RtfExportException Class
RtfExportException Members


GetType() Method

GetType() Method

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetType() As System.Type
public System.Type GetType()
See Also

Reference

RtfExportException Class
RtfExportException Members


HelpLink Property (RtfExportException)

HelpLink Property (RtfExportException)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property HelpLink As System.String
public virtual System.string HelpLink {get; set;}
See Also

Reference

RtfExportException Class
RtfExportException Members


HResult Property (RtfExportException)

HResult Property (RtfExportException)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : HResult Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HResult As System.Integer
public System.int HResult {get;}
See Also

Reference

RtfExportException Class
RtfExportException Members


InnerException Property (RtfExportException)

InnerException Property (RtfExportException)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InnerException As System.Exception
public System.Exception InnerException {get;}
See Also

Reference

RtfExportException Class
RtfExportException Members


Message Property (RtfExportException)

Message Property (RtfExportException)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : Message Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Message As System.String
public virtual System.string Message {get;}
See Also

Reference

RtfExportException Class
RtfExportException Members


Source Property (RtfExportException)

Source Property (RtfExportException)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : Source Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Source As System.String
public virtual System.string Source {get; set;}
See Also

Reference

RtfExportException Class
RtfExportException Members


StackTrace Property (RtfExportException)

StackTrace Property (RtfExportException)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property StackTrace As System.String
public virtual System.string StackTrace {get;}
See Also

Reference

RtfExportException Class
RtfExportException Members


TargetSite Property (RtfExportException)

TargetSite Property (RtfExportException)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
public System.Reflection.MethodBase TargetSite {get;}
See Also

Reference

RtfExportException Class
RtfExportException Members


ToString Method (RtfExportException)

ToString Method (RtfExportException)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExportException Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

RtfExportException Class
RtfExportException Members


Container Property (RtfExport)

Container Property (RtfExport)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

RtfExport Class
RtfExport Members


CreateObjRef Method (RtfExport)

CreateObjRef Method (RtfExport)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

RtfExport Class
RtfExport Members


Dispose Method (RtfExport)

Dispose Method (RtfExport)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

RtfExport Class
RtfExport Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

RtfExport Class
RtfExport Members


Disposed Event (RtfExport)

Disposed Event (RtfExport)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

RtfExport Class
RtfExport Members


GetLifetimeService Method (RtfExport)

GetLifetimeService Method (RtfExport)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

RtfExport Class
RtfExport Members


InitializeLifetimeService Method (RtfExport)

InitializeLifetimeService Method (RtfExport)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

RtfExport Class
RtfExport Members


Site Property (RtfExport)

Site Property (RtfExport)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

RtfExport Class
RtfExport Members


ToString Method (RtfExport)

ToString Method (RtfExport)

GrapeCity.ActiveReports.Export.Word.v10 Assembly > GrapeCity.ActiveReports.Export.Word.Section Namespace > RtfExport Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

RtfExport Class
RtfExport Members


GrapeCity.ActiveReports.Export.Word.Section Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Word.Section Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Word.v10 Assembly : GrapeCity.ActiveReports.Export.Word.Section Namespace
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.Export.Word.Section.RtfExportException
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Export.Word.Section.RtfExport
See Also

Reference

GrapeCity.ActiveReports.Export.Word.v10 Assembly


GrapeCity.ActiveReports.Export.Xml.v10 Assembly

GrapeCity.ActiveReports.Export.Xml.v10 Assembly
Namespaces
Namespace | Description
GrapeCity.ActiveReports.Export.Xml.Page | The GrapeCity.ActiveReports.Export.Xml.Page namespace includes information related to Settings and XML Rendering Extension.
GrapeCity.ActiveReports.Export.Xml.Section | The GrapeCity.ActiveReports.Export.Xml.Section namespace contains the Text export classes.


GetSupportedSettings Method (XmlRenderingExtension)

GetSupportedSettings Method (XmlRenderingExtension)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Page Namespace > XmlRenderingExtension Class : GetSupportedSettings Method
Gets supported settings of XmlRenderingExtension.
Overload List
Overload | Description
GetSupportedSettings | Gets supported settings of XmlRenderingExtension.
See Also

Reference

XmlRenderingExtension Class
XmlRenderingExtension Members


GrapeCity.ActiveReports.Export.Xml.Page Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Xml.Page Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Xml.v10 Assembly : GrapeCity.ActiveReports.Export.Xml.Page Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Export.Xml.Page.Settings
GrapeCity.ActiveReports.Export.Xml.Page.XmlRenderingExtension
See Also

Reference

GrapeCity.ActiveReports.Export.Xml.v10 Assembly


TextExport Class Events

TextExport Class Events

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace : TextExport Class

For a list of all members of this type, see TextExport members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

TextExport Class
GrapeCity.ActiveReports.Export.Xml.Section Namespace


TextExportException Class Methods

TextExportException Class Methods

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace : TextExportException Class

For a list of all members of this type, see TextExportException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

TextExportException Class
GrapeCity.ActiveReports.Export.Xml.Section Namespace


TextExportException Class Properties

TextExportException Class Properties

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace : TextExportException Class

For a list of all members of this type, see TextExportException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

TextExportException Class
GrapeCity.ActiveReports.Export.Xml.Section Namespace


Data Property (TextExportException)

Data Property (TextExportException)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : Data Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Data As System.Collections.IDictionary
public virtual System.Collections.IDictionary Data {get;}
See Also

Reference

TextExportException Class
TextExportException Members


GetBaseException Method (TextExportException)

GetBaseException Method (TextExportException)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetBaseException() As System.Exception
public virtual System.Exception GetBaseException()
See Also

Reference

TextExportException Class
TextExportException Members


GetObjectData Method (TextExportException)

GetObjectData Method (TextExportException)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
See Also

Reference

TextExportException Class
TextExportException Members


GetType Method (TextExportException)

GetType Method (TextExportException)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
See Also

Reference

TextExportException Class
TextExportException Members


GetType() Method

GetType() Method

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetType() As System.Type
public System.Type GetType()
See Also

Reference

TextExportException Class
TextExportException Members


HelpLink Property (TextExportException)

HelpLink Property (TextExportException)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property HelpLink As System.String
public virtual System.string HelpLink {get; set;}
See Also

Reference

TextExportException Class
TextExportException Members


HResult Property (TextExportException)

HResult Property (TextExportException)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : HResult Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HResult As System.Integer
public System.int HResult {get;}
See Also

Reference

TextExportException Class
TextExportException Members


InnerException Property (TextExportException)

InnerException Property (TextExportException)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InnerException As System.Exception
public System.Exception InnerException {get;}
See Also

Reference

TextExportException Class
TextExportException Members


Message Property (TextExportException)

Message Property (TextExportException)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : Message Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Message As System.String
public virtual System.string Message {get;}
See Also

Reference

TextExportException Class
TextExportException Members


Source Property (TextExportException)

Source Property (TextExportException)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : Source Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Source As System.String
public virtual System.string Source {get; set;}
See Also

Reference

TextExportException Class
TextExportException Members


StackTrace Property (TextExportException)

StackTrace Property (TextExportException)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property StackTrace As System.String
public virtual System.string StackTrace {get;}
See Also

Reference

TextExportException Class
TextExportException Members


TargetSite Property (TextExportException)

TargetSite Property (TextExportException)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
public System.Reflection.MethodBase TargetSite {get;}
See Also

Reference

TextExportException Class
TextExportException Members


ToString Method (TextExportException)

ToString Method (TextExportException)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExportException Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

TextExportException Class
TextExportException Members


Container Property (TextExport)

Container Property (TextExport)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

TextExport Class
TextExport Members


CreateObjRef Method (TextExport)

CreateObjRef Method (TextExport)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

TextExport Class
TextExport Members


Dispose Method (TextExport)

Dispose Method (TextExport)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

TextExport Class
TextExport Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

TextExport Class
TextExport Members


Disposed Event (TextExport)

Disposed Event (TextExport)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

TextExport Class
TextExport Members


GetLifetimeService Method (TextExport)

GetLifetimeService Method (TextExport)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

TextExport Class
TextExport Members


InitializeLifetimeService Method (TextExport)

InitializeLifetimeService Method (TextExport)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

TextExport Class
TextExport Members


Site Property (TextExport)

Site Property (TextExport)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

TextExport Class
TextExport Members


ToString Method (TextExport)

ToString Method (TextExport)

GrapeCity.ActiveReports.Export.Xml.v10 Assembly > GrapeCity.ActiveReports.Export.Xml.Section Namespace > TextExport Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

TextExport Class
TextExport Members


GrapeCity.ActiveReports.Export.Xml.Section Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Export.Xml.Section Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Export.Xml.v10 Assembly : GrapeCity.ActiveReports.Export.Xml.Section Namespace
Inheritance Hierarchy
System.Object
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.Export.Xml.Section.TextExportException
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Export.Xml.Section.TextExport
See Also

Reference

GrapeCity.ActiveReports.Export.Xml.v10 Assembly


GrapeCity.ActiveReports.Extensibility.v10 Assembly

GrapeCity.ActiveReports.Extensibility.v10 Assembly
Namespaces
Namespace | Description
GrapeCity.ActiveReports.Extensibility | The GrapeCity.ActiveReports.Extensibility namespace includes IExtension interface.
GrapeCity.ActiveReports.Extensibility.Data | The GrapeCity.ActiveReports.Extensibility.Data namespace contains the types for describing the report runtime components.
GrapeCity.ActiveReports.Extensibility.Definition.Components | The GrapeCity.ActiveReports.Extensibility.Definition.Components namespace contains the types for describing the report runtime components.
GrapeCity.ActiveReports.Extensibility.Drawing | The GrapeCity.ActiveReports.Extensibility.Drawing namespace includes classes that extend rendering.
GrapeCity.ActiveReports.Extensibility.Layout | The GrapeCity.ActiveReports.Extensibility.Layout namespace includes the classes that are used at the time of creating layouts for reports.
GrapeCity.ActiveReports.Extensibility.Layout.Areas | The GrapeCity.ActiveReports.Extensibility.Layout.Areas namespace includes members that are used when the section reports layout is used.
GrapeCity.ActiveReports.Extensibility.Printing | The GrapeCity.ActiveReports.Extensibility.Printing namespace includes classes that are used when printing reports.
GrapeCity.ActiveReports.Extensibility.Rendering | The GrapeCity.ActiveReports.Extensibility.Rendering namespace includes classes that are used when rendering reports.
GrapeCity.ActiveReports.Extensibility.Rendering.Components | The GrapeCity.ActiveReports.Extensibility.Rendering.Components namespace includes the description of the components that are required for rendering reports.
GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList | The GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList namespace includes the IBandedList interface.
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart | The GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart namespace includes the interfaces that are used when creating graphs.
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map |
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData |
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix | The GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix namespace includes the interfaces that are used when creating Matrix.
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table | The GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table namespace includes the interfaces that are used when creating Table.
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing | The GrapeCity.ActiveReports.Extensibility.Rendering.Drawing namespace includes functions that are required when rendering reports.
GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity | The GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity namespace includes members to add interactive features in the report.
GrapeCity.ActiveReports.Extensibility.Rendering.IO | The GrapeCity.ActiveReports.Extensibility.Rendering.IO namespace includes StreamInfo and StreamProvider class.


IDataReader Interface Properties

IDataReader Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDataReader Interface

For a list of all members of this type, see IDataReader members.

Public Properties
 | Name | Description
Property | FieldCount | Returns the number of fields in the current row. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDataRecord)
Top
See Also

Reference

IDataReader Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


Dispose Method (IDataReader)

Dispose Method (IDataReader)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDataReader Interface : Dispose Method
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Dispose()
void Dispose()
See Also

Reference

IDataReader Interface
IDataReader Members


Dispose Method (IDbCommand)

Dispose Method (IDbCommand)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbCommand Interface : Dispose Method
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Dispose()
void Dispose()
See Also

Reference

IDbCommand Interface
IDbCommand Members


IDbConnectionExtension Interface Methods

IDbConnectionExtension Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbConnectionExtension Interface

For a list of all members of this type, see IDbConnectionExtension members.

Public Methods
 | Name | Description
Method | BeginTransaction | Begins a transaction at the data source. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDbConnection)
Method | Close | Closes the connection. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDbConnection)
Method | CreateCommand | Returns an initialized command object associated with this connection. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDbConnection)
Method | Dispose | (Inherited from System.IDisposable)
Method | Open | Opens the connection. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDbConnection)
Method | SetConfiguration | Specifies any configuration information for this extension. (Inherited from GrapeCity.ActiveReports.Extensibility.IExtension)
Top
See Also

Reference

IDbConnectionExtension Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


Dispose Method (IDbConnectionExtension)

Dispose Method (IDbConnectionExtension)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbConnectionExtension Interface : Dispose Method
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Dispose()
void Dispose()
See Also

Reference

IDbConnectionExtension Interface
IDbConnectionExtension Members


Dispose Method (IDbConnection)

Dispose Method (IDbConnection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbConnection Interface : Dispose Method
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Dispose()
void Dispose()
See Also

Reference

IDbConnection Interface
IDbConnection Members


IDbTransactionExtension Interface Methods

IDbTransactionExtension Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace : IDbTransactionExtension Interface

For a list of all members of this type, see IDbTransactionExtension members.

Public Methods
 | Name | Description
Method | Commit | Commits this transaction. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDbTransaction)
Method | Dispose | (Inherited from System.IDisposable)
Method | Rollback | Rolls back this transaction. (Inherited from GrapeCity.ActiveReports.Extensibility.Data.IDbTransaction)
Top
See Also

Reference

IDbTransactionExtension Interface
GrapeCity.ActiveReports.Extensibility.Data Namespace


Dispose Method (IDbTransactionExtension)

Dispose Method (IDbTransactionExtension)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbTransactionExtension Interface : Dispose Method
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Dispose()
void Dispose()
See Also

Reference

IDbTransactionExtension Interface
IDbTransactionExtension Members


Dispose Method (IDbTransaction)

Dispose Method (IDbTransaction)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Data Namespace > IDbTransaction Interface : Dispose Method
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Dispose()
void Dispose()
See Also

Reference

IDbTransaction Interface
IDbTransaction Members


GrapeCity.ActiveReports.Extensibility.Data Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Extensibility.Data Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Data Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Extensibility.Data.DataProviderFactory
GrapeCity.ActiveReports.Extensibility.Data.DataRow
GrapeCity.ActiveReports.Extensibility.Data.DataTable
System.ValueType
GrapeCity.ActiveReports.Extensibility.Data.DataColumn
GrapeCity.ActiveReports.Extensibility.Data.LoginPasswordCredentials
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Definition.Components Namespace
Inheritance Hierarchy
System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Definition.Components.Length
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


GrapeCity.ActiveReports.Extensibility.Drawing Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Extensibility.Drawing Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Drawing Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Extensibility.Drawing.BlendEx
GrapeCity.ActiveReports.Extensibility.Drawing.ColorBlendEx
GrapeCity.ActiveReports.Extensibility.Drawing.MatrixEx
GrapeCity.ActiveReports.Extensibility.Drawing.RectangleEx
System.ValueType
GrapeCity.ActiveReports.Extensibility.Drawing.ColorEx
GrapeCity.ActiveReports.Extensibility.Drawing.PointFEx
GrapeCity.ActiveReports.Extensibility.Drawing.RectangleFEx
GrapeCity.ActiveReports.Extensibility.Drawing.SizeFEx
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


GrapeCity.ActiveReports.Extensibility.Layout.Areas Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Extensibility.Layout.Areas Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Layout.Areas Namespace
Inheritance Hierarchy
System.Object
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


Dispose Method (ILayoutEngine)

Dispose Method (ILayoutEngine)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutEngine Interface : Dispose Method
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Dispose()
void Dispose()
See Also

Reference

ILayoutEngine Interface
ILayoutEngine Members


ILayoutSection Interface Methods

ILayoutSection Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutSection Interface

For a list of all members of this type, see ILayoutSection members.

Public Methods
 | Name | Description
Method | HitTest | Tries to find area corresponding to the specifed point. (Inherited from GrapeCity.ActiveReports.Extensibility.Layout.ILayoutArea)
Top
See Also

Reference

ILayoutSection Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


ILayoutTree Interface Methods

ILayoutTree Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : ILayoutTree Interface

For a list of all members of this type, see ILayoutTree members.

Public Methods
 | Name | Description
Method | Dispose | (Inherited from System.IDisposable)
Top
See Also

Reference

ILayoutTree Interface
GrapeCity.ActiveReports.Extensibility.Layout Namespace


Dispose Method (ILayoutTree)

Dispose Method (ILayoutTree)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > ILayoutTree Interface : Dispose Method
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Dispose()
void Dispose()
See Also

Reference

ILayoutTree Interface
ILayoutTree Members


LayoutInfo Constructor

LayoutInfo Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutInfo Structure : LayoutInfo Constructor
Initializes the new instance of LayoutInfo class.
Overload List
Overload | Description
LayoutInfo Constructor | Initializes the new instance of LayoutInfo class.
See Also

Reference

LayoutInfo Structure
LayoutInfo Members


LayoutManagerAttribute Class Methods

LayoutManagerAttribute Class Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace : LayoutManagerAttribute Class

For a list of all members of this type, see LayoutManagerAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

LayoutManagerAttribute Class
GrapeCity.ActiveReports.Extensibility.Layout Namespace


Equals Method (LayoutManagerAttribute)

Equals Method (LayoutManagerAttribute)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutManagerAttribute Class : Equals Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public System.bool Equals(
   System.object obj
)

Parameters

obj
See Also

Reference

LayoutManagerAttribute Class
LayoutManagerAttribute Members


GetHashCode Method (LayoutManagerAttribute)

GetHashCode Method (LayoutManagerAttribute)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutManagerAttribute Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetHashCode() As System.Integer
public System.int GetHashCode()
See Also

Reference

LayoutManagerAttribute Class
LayoutManagerAttribute Members


IsDefaultAttribute Method (LayoutManagerAttribute)

IsDefaultAttribute Method (LayoutManagerAttribute)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutManagerAttribute Class : IsDefaultAttribute Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IsDefaultAttribute() As System.Boolean
public System.bool IsDefaultAttribute()
See Also

Reference

LayoutManagerAttribute Class
LayoutManagerAttribute Members


Match Method (LayoutManagerAttribute)

Match Method (LayoutManagerAttribute)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutManagerAttribute Class : Match Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Match( _
   ByVal obj As System.Object _
) As System.Boolean
public System.bool Match(
   System.object obj
)

Parameters

obj
See Also

Reference

LayoutManagerAttribute Class
LayoutManagerAttribute Members


TypeId Property (LayoutManagerAttribute)

TypeId Property (LayoutManagerAttribute)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Layout Namespace > LayoutManagerAttribute Class : TypeId Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TypeId As System.Object
public System.object TypeId {get;}
See Also

Reference

LayoutManagerAttribute Class
LayoutManagerAttribute Members


GrapeCity.ActiveReports.Extensibility.Layout Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Extensibility.Layout Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Layout Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Extensibility.Layout.ColumnInfo
GrapeCity.ActiveReports.Extensibility.Layout.ContentRange
GrapeCity.ActiveReports.Extensibility.Layout.SupportedPageInfo
System.Attribute
GrapeCity.ActiveReports.Extensibility.Layout.LayoutManagerAttribute
System.ValueType
GrapeCity.ActiveReports.Extensibility.Layout.CellSpan
GrapeCity.ActiveReports.Extensibility.Layout.DeviceCapabilities
GrapeCity.ActiveReports.Extensibility.Layout.HitTestInfo
GrapeCity.ActiveReports.Extensibility.Layout.LayoutContext
GrapeCity.ActiveReports.Extensibility.Layout.LayoutInfo
GrapeCity.ActiveReports.Extensibility.Layout.LayoutResult
GrapeCity.ActiveReports.Extensibility.Layout.LayoutState
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


Printer Class Events

Printer Class Events

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace : Printer Class

For a list of all members of this type, see Printer members.

Public Events
 | Name | Description
Public Event | BeginPrint | (Inherited from System.Drawing.Printing.PrintDocument)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | EndPrint | (Inherited from System.Drawing.Printing.PrintDocument)
Public Event | PrintPage | (Inherited from System.Drawing.Printing.PrintDocument)
Public Event | QueryPageSettings | (Inherited from System.Drawing.Printing.PrintDocument)
Top
See Also

Reference

Printer Class
GrapeCity.ActiveReports.Extensibility.Printing Namespace


Printer Constructor

Printer Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : Printer Constructor
Returns the instance of Margin class when all the values are set to 0.
Overload List
Overload | Description
Printer Constructor | Initializes a new instance of the Printer class.
See Also

Reference

Printer Class
Printer Members


BeginPrint Event

BeginPrint Event

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : BeginPrint Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BeginPrint As System.Drawing.Printing.PrintEventHandler
public event System.Drawing.Printing.PrintEventHandler BeginPrint
Event Data

The event handler receives an argument of type System.Drawing.Printing.PrintEventArgs containing data related to this event. The following PrintEventArgs properties provide information specific to this event.

Property | Description
Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
PrintAction | Returns System.Drawing.Printing.PrintAction.PrintToFile in all cases.
See Also

Reference

Printer Class
Printer Members


Container Property (Printer)

Container Property (Printer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

Printer Class
Printer Members


CreateObjRef Method (Printer)

CreateObjRef Method (Printer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

Printer Class
Printer Members


DefaultPageSettings Property

DefaultPageSettings Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : DefaultPageSettings Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultPageSettings As System.Drawing.Printing.PageSettings
public System.Drawing.Printing.PageSettings DefaultPageSettings {get; set;}
See Also

Reference

Printer Class
Printer Members


Dispose Method (Printer)

Dispose Method (Printer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : Dispose Method
Releases the unmanaged resources used by the System.ComponentModel.Component and optionally releases the managed resources.
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

Printer Class
Printer Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Printer Class
Printer Members


Disposed Event (Printer)

Disposed Event (Printer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Printer Class
Printer Members


DocumentName Property

DocumentName Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : DocumentName Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DocumentName As System.String
public System.string DocumentName {get; set;}
See Also

Reference

Printer Class
Printer Members


EndPrint Event

EndPrint Event

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : EndPrint Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event EndPrint As System.Drawing.Printing.PrintEventHandler
public event System.Drawing.Printing.PrintEventHandler EndPrint
Event Data

The event handler receives an argument of type System.Drawing.Printing.PrintEventArgs containing data related to this event. The following PrintEventArgs properties provide information specific to this event.

Property | Description
Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
PrintAction | Returns System.Drawing.Printing.PrintAction.PrintToFile in all cases.
See Also

Reference

Printer Class
Printer Members


GetLifetimeService Method (Printer)

GetLifetimeService Method (Printer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

Printer Class
Printer Members


InitializeLifetimeService Method (Printer)

InitializeLifetimeService Method (Printer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
public virtual System.object InitializeLifetimeService()
See Also

Reference

Printer Class
Printer Members


OriginAtMargins Property

OriginAtMargins Property

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : OriginAtMargins Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OriginAtMargins As System.Boolean
public System.bool OriginAtMargins {get; set;}
See Also

Reference

Printer Class
Printer Members


Print Method (Printer)

Print Method (Printer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : Print Method
Starts the document's printing process.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Print()
public void Print()
Requirements

See Also

Reference

Printer Class
Printer Members


PrinterSettings Property (Printer)

PrinterSettings Property (Printer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : PrinterSettings Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrinterSettings As System.Drawing.Printing.PrinterSettings
public System.Drawing.Printing.PrinterSettings PrinterSettings {get; set;}
See Also

Reference

Printer Class
Printer Members


PrintPage Event

PrintPage Event

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : PrintPage Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PrintPage As System.Drawing.Printing.PrintPageEventHandler
public event System.Drawing.Printing.PrintPageEventHandler PrintPage
Event Data

The event handler receives an argument of type System.Drawing.Printing.PrintPageEventArgs containing data related to this event. The following PrintPageEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a value indicating whether the print job should be canceled.
Graphics | Gets the System.Drawing.Graphics used to paint the page.
HasMorePages | Gets or sets a value indicating whether an additional page should be printed.
MarginBounds | Gets the rectangular area that represents the portion of the page inside the margins.
PageBounds | Gets the rectangular area that represents the total area of the page.
PageSettings | Gets the page settings for the current page.
See Also

Reference

Printer Class
Printer Members


QueryPageSettings Event

QueryPageSettings Event

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : QueryPageSettings Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event QueryPageSettings As System.Drawing.Printing.QueryPageSettingsEventHandler
public event System.Drawing.Printing.QueryPageSettingsEventHandler QueryPageSettings
Event Data

The event handler receives an argument of type System.Drawing.Printing.QueryPageSettingsEventArgs containing data related to this event. The following QueryPageSettingsEventArgs properties provide information specific to this event.

Property | Description
Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
PageSettings | Gets or sets the page settings for the page to be printed.
PrintAction | (Inherited from System.Drawing.Printing.PrintEventArgs)
See Also

Reference

Printer Class
Printer Members


Site Property (Printer)

Site Property (Printer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
public virtual System.ComponentModel.ISite Site {get; set;}
See Also

Reference

Printer Class
Printer Members


ToString Method (Printer)

ToString Method (Printer)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Printing Namespace > Printer Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

Printer Class
Printer Members


GrapeCity.ActiveReports.Extensibility.Printing Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Extensibility.Printing Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Printing Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Extensibility.Printing.Margin
GrapeCity.ActiveReports.Extensibility.Printing.PrintOptions
GrapeCity.ActiveReports.Extensibility.Printing.WatermarkOptions
System.EventArgs
GrapeCity.ActiveReports.Extensibility.Printing.PrintingThreadErrorEventArgs
GrapeCity.ActiveReports.Extensibility.Printing.PrintProgressEventArgs
System.MarshalByRefObject
System.ComponentModel.Component
System.Drawing.Printing.PrintDocument
GrapeCity.ActiveReports.Extensibility.Printing.Printer
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Rendering.Components.BandedList Namespace
Inheritance Hierarchy
System.Object
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


GetService Method (IChart)

GetService Method (IChart)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace > IChart Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

IChart Interface
IChart Members


GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart Namespace
Inheritance Hierarchy
System.Object
System.ValueType
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Chart.PaletteEntry
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


IBand Interface Methods

IBand Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IBand Interface

For a list of all members of this type, see IBand members.

Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IBand Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IBandedList Interface Methods

IBandedList Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IBandedList Interface

For a list of all members of this type, see IBandedList members.

Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IBandedList Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetService Method (IBandedList)

GetService Method (IBandedList)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBandedList Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

IBandedList Interface
IBandedList Members


GetService Method (IBand)

GetService Method (IBand)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IBand Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

IBand Interface
IBand Members


ICheckBox Interface Methods

ICheckBox Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ICheckBox Interface

For a list of all members of this type, see ICheckBox members.

Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

ICheckBox Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetService Method (ICheckBox)

GetService Method (ICheckBox)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ICheckBox Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

ICheckBox Interface
ICheckBox Members


GetService Method (ICustomReportItem)

GetService Method (ICustomReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ICustomReportItem Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

ICustomReportItem Interface
ICustomReportItem Members


IDataRegion Interface Methods

IDataRegion Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDataRegion Interface

For a list of all members of this type, see IDataRegion members.

Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IDataRegion Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IDataRegionOverflow Interface Methods

IDataRegionOverflow Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IDataRegionOverflow Interface

For a list of all members of this type, see IDataRegionOverflow members.

Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IDataRegionOverflow Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetService Method (IDataRegionOverflow)

GetService Method (IDataRegionOverflow)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDataRegionOverflow Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

IDataRegionOverflow Interface
IDataRegionOverflow Members


GetService Method (IDataRegion)

GetService Method (IDataRegion)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDataRegion Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

IDataRegion Interface
IDataRegion Members


GetService Method (IDataScope)

GetService Method (IDataScope)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IDataScope Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

IDataScope Interface
IDataScope Members


GetService Method (IFixedPage)

GetService Method (IFixedPage)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IFixedPage Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

IFixedPage Interface
IFixedPage Members


IFooterBand Interface Methods

IFooterBand Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IFooterBand Interface

For a list of all members of this type, see IFooterBand members.

Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IFooterBand Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetService Method (IFooterBand)

GetService Method (IFooterBand)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IFooterBand Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

IFooterBand Interface
IFooterBand Members


IHeaderBand Interface Methods

IHeaderBand Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IHeaderBand Interface

For a list of all members of this type, see IHeaderBand members.

Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IHeaderBand Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetService Method (IHeaderBand)

GetService Method (IHeaderBand)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IHeaderBand Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

IHeaderBand Interface
IHeaderBand Members


GetService Method (IImage)

GetService Method (IImage)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IImage Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

IImage Interface
IImage Members


IList Interface Methods

IList Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IList Interface

For a list of all members of this type, see IList members.

Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IList Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IListContentCollection Interface Properties

IListContentCollection Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IListContentCollection Interface

For a list of all members of this type, see IListContentCollection members.

Public Properties
 | Name | Description
Property | Count | Gets number of items in the collection. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<IListContent>)
Property | Item | Gets the T at the specified index. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<IListContent>)
Top
See Also

Reference

IListContentCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetService Method (IList)

GetService Method (IList)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IList Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

IList Interface
IList Members


IOverflowItem Interface Methods

IOverflowItem Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IOverflowItem Interface

For a list of all members of this type, see IOverflowItem members.

Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IOverflowItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetService Method (IOverflowItem)

GetService Method (IOverflowItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IOverflowItem Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

IOverflowItem Interface
IOverflowItem Members


IPageRegion Interface Methods

IPageRegion Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IPageRegion Interface

For a list of all members of this type, see IPageRegion members.

Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IPageRegion Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetService Method (IPageRegion)

GetService Method (IPageRegion)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IPageRegion Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

IPageRegion Interface
IPageRegion Members


IRectangle Interface Methods

IRectangle Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IRectangle Interface

For a list of all members of this type, see IRectangle members.

Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IRectangle Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetService Method (IRectangle)

GetService Method (IRectangle)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IRectangle Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

IRectangle Interface
IRectangle Members


IRenderComponent Interface Methods

IRenderComponent Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IRenderComponent Interface

For a list of all members of this type, see IRenderComponent members.

Public Methods
 | Name | Description
Method | GetService | (Inherited from System.IServiceProvider)
Top
See Also

Reference

IRenderComponent Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetService Method (IRenderComponent)

GetService Method (IRenderComponent)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IRenderComponent Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

IRenderComponent Interface
IRenderComponent Members


GetService Method (IReportItem)

GetService Method (IReportItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReportItem Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

IReportItem Interface
IReportItem Members


GetService Method (IReport)

GetService Method (IReport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IReport Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

IReport Interface
IReport Members


IShape Interface Methods

IShape Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IShape Interface

For a list of all members of this type, see IShape members.

Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IShape Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetService Method (IShape)

GetService Method (IShape)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IShape Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

IShape Interface
IShape Members


IStaticItem Interface Methods

IStaticItem Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IStaticItem Interface

For a list of all members of this type, see IStaticItem members.

Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IStaticItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


IStaticItem Interface Properties

IStaticItem Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : IStaticItem Interface

For a list of all members of this type, see IStaticItem members.

Public Properties
 | Name | Description
Property | Action | The Action object of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Bookmark | Specifies a bookmark that can be linked to via a Bookmark action. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementName | The name to use for the data element or attribute for this report item when rendered via a data oriented rendering extension (e.g. XML). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | DataElementOutput | Indicates how this item should appear when rendered with a data oriented rendering device. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Height | Height of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Hidden | Indicates if this report item should be hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | IsDynamicallyHidden | Determines if this item has dynamic visiblity and is hidden. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | KeepTogether | Gets a value indicating whether the report item is kept together on one page if possible. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Label | Gets document map label. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IDocumentMapItem)
Property | Left | The distance of the item from the left of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Name | The name of this report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | OwnHidden | Indicates this report item own hidden state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Parent | Sets or returns a reference to this object's parent. If the parent is unavailable null is returned. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | RenderComponents | Returns a collection of render components. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IRenderComponent)
Property | Style | Returns style of the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | StyleName | Specifies style name. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | TargetDevice | Defines output kinds in which report item is present (Screen, Export tec.) (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToggleItem | Specifies a report item that users can click toggle the visibility of this item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ToolTip | Contains a textual label for the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Top | The distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | Width | Width of the item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Property | ZIndex | Specifies drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IStaticItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetService Method (IStaticItem)

GetService Method (IStaticItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > IStaticItem Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

IStaticItem Interface
IStaticItem Members


ISubreport Interface Methods

ISubreport Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ISubreport Interface

For a list of all members of this type, see ISubreport members.

Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

ISubreport Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetService Method (ISubreport)

GetService Method (ISubreport)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ISubreport Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

ISubreport Interface
ISubreport Members


ITextBox Interface Methods

ITextBox Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITextBox Interface

For a list of all members of this type, see ITextBox members.

Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

ITextBox Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetService Method (ITextBox)

GetService Method (ITextBox)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITextBox Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

ITextBox Interface
ITextBox Members


ITextItem Interface Methods

ITextItem Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITextItem Interface

For a list of all members of this type, see ITextItem members.

Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

ITextItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetService Method (ITextItem)

GetService Method (ITextItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITextItem Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

ITextItem Interface
ITextItem Members


ITocItem Interface Methods

ITocItem Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITocItem Interface

For a list of all members of this type, see ITocItem members.

Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

ITocItem Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetService Method (ITocItem)

GetService Method (ITocItem)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocItem Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

ITocItem Interface
ITocItem Members


ITocList Interface Methods

ITocList Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace : ITocList Interface

For a list of all members of this type, see ITocList members.

Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

ITocList Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace


GetService Method (ITocList)

GetService Method (ITocList)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace > ITocList Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

ITocList Interface
ITocList Members


GeoCurve Class Properties

GeoCurve Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoCurve Class

For a list of all members of this type, see GeoCurve members.

Public Properties
 | Name | Description
Public Property | Bounds | Returns the bounds of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Center | Gets the centroid of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Is3D | Returns true if the shape has z-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | IsEmpty | Returns the value indicating whether the shape is empty geometry. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | IsMeasured | Returns true if the shape has m-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | PointsCount | Returns the number of points used in a shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoCurve Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoGeometryCollection Constructor

GeoGeometryCollection Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoGeometryCollection Class : GeoGeometryCollection Constructor
Overload List
Overload | Description
GeoGeometryCollection Constructor | Initializes a new instance of the GeoGeometryCollection class.
See Also

Reference

GeoGeometryCollection Class
GeoGeometryCollection Members


GeoLine Class Properties

GeoLine Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoLine Class

For a list of all members of this type, see GeoLine members.

Public Properties
 | Name | Description
Public Property | Bounds | Returns the bounds of the line shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString)
Public Property | Center | Gets the centroid of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Is3D | Returns true if any point in collection has z-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString)
Public Property | IsEmpty | Returns the value indicating whether the collection of line points is empty. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString)
Public Property | IsMeasured | Returns true if any point in collection has m-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString)
Public Property | Points | Gets the line points. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString)
Public Property | PointsCount | Returns the points count. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString)
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoLine Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoPolygon Constructor

GeoPolygon Constructor

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace > GeoPolygon Class : GeoPolygon Constructor
Overload List
Overload | Description
GeoPolygon Constructor | Initializes new instance of GeoPolygon.
See Also

Reference

GeoPolygon Class
GeoPolygon Members


GeoSurface Class Properties

GeoSurface Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoSurface Class

For a list of all members of this type, see GeoSurface members.

Public Properties
 | Name | Description
Public Property | Bounds | Returns the bounds of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Center | Gets the centroid of the shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Is3D | Returns true if the shape has z-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | IsEmpty | Returns the value indicating whether the shape is empty geometry. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | IsMeasured | Returns true if the shape has m-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | PointsCount | Returns the number of points used in a shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoSurface Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GeoTriangle Class Properties

GeoTriangle Class Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace : GeoTriangle Class

For a list of all members of this type, see GeoTriangle members.

Public Properties
 | Name | Description
Public Property | Bounds | Returns the bounds of the polygon shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon)
Public Property | Center | Gets the centroid of the polygon shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon)
Public Property | ExteriorRing | Exterior ring of the polygon shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon)
Public Property | InteriorRings | Interior rings of the polygon shape. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon)
Public Property | Is3D | Returns true if any ring in collection has z-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon)
Public Property | IsEmpty | Returns value indicating whether the ExterorRing null or empty. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon)
Public Property | IsMeasured | Returns true if any ring in collection has m-coordinate values. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon)
Public Property | PointsCount | Returns sum of rings points count. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon)
Public Property | Rings | Gets the polygon rings. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon)
Public Property | Type | Gets the geometry type. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape)
Top
See Also

Reference

GeoTriangle Class
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace


GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoShape
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoCurve
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLineString
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLine
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoLinearRing
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoGeometryCollection
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoMultiLineString
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoMultiPoint
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoMultiPolygon
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPoint
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoSurface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolygon
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoTriangle
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoPolyhedralSurface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.GeoTin
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePoint
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePointM
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePointZ
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.GeoData.ShapePointZM
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


IMap Interface Methods

IMap Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace : IMap Interface

For a list of all members of this type, see IMap members.

Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IMap Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace


GetService Method (IMap)

GetService Method (IMap)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace > IMap Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

IMap Interface
IMap Members


GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapLocation
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapSize
System.ValueType
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Map.MapTileKey
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


IMatrix Interface Methods

IMatrix Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrix Interface

For a list of all members of this type, see IMatrix members.

Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

IMatrix Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


IMatrixCell Interface Methods

IMatrixCell Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace : IMatrixCell Interface

For a list of all members of this type, see IMatrixCell members.

Public Methods
 | Name | Description
Method | GetService | (Inherited from System.IServiceProvider)
Top
See Also

Reference

IMatrixCell Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace


GetService Method (IMatrixCell)

GetService Method (IMatrixCell)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrixCell Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

IMatrixCell Interface
IMatrixCell Members


GetService Method (IMatrix)

GetService Method (IMatrix)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace > IMatrix Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

IMatrix Interface
IMatrix Members


GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Matrix.MatrixGroupingDefinition
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


ITable Interface Methods

ITable Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITable Interface

For a list of all members of this type, see ITable members.

Public Methods
 | Name | Description
Method | GetRenderer | Gets a renderer of the specified type that can render this component. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Initialize | Initializes the report item. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnClick | The wrapper for the OnClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnDoubleClick | The wrapper for the OnDoubleClick event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnMove | The wrapper for the OnMove event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Method | OnValueChange | The wrapper for the ValueChange event. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IReportItem)
Top
See Also

Reference

ITable Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableCell Interface Methods

ITableCell Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableCell Interface

For a list of all members of this type, see ITableCell members.

Public Methods
 | Name | Description
Method | GetService | (Inherited from System.IServiceProvider)
Top
See Also

Reference

ITableCell Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableCellCollection Interface Properties

ITableCellCollection Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableCellCollection Interface

For a list of all members of this type, see ITableCellCollection members.

Public Properties
 | Name | Description
Property | Count | Gets number of items in the collection. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableCell>)
Property | Item | Gets the T at the specified index. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableCell>)
Top
See Also

Reference

ITableCellCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


GetService Method (ITableCell)

GetService Method (ITableCell)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableCell Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

ITableCell Interface
ITableCell Members


ITableColumn Interface Methods

ITableColumn Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableColumn Interface

For a list of all members of this type, see ITableColumn members.

Public Methods
 | Name | Description
Method | ChangeVisibility | Toggles visibility state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Method | Subscribe | Looks for the toggle controller and registers this instance with it (if there is any). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Top
See Also

Reference

ITableColumn Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableColumnCollection Interface Methods

ITableColumnCollection Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableColumnCollection Interface

For a list of all members of this type, see ITableColumnCollection members.

Public Methods
 | Name | Description
Method | CopyTo | (Inherited from System.Collections.ICollection)
Top
See Also

Reference

ITableColumnCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


CopyTo Method (ITableColumnCollection)

CopyTo Method (ITableColumnCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableColumnCollection Interface : CopyTo Method
Syntax
  • Visual Basic
  • C#
'Declaration

Sub CopyTo( _
   ByVal array As System.Array, _
   ByVal index As System.Integer _
)
void CopyTo(
   System.Array array,
   System.int index
)

Parameters

array
index
See Also

Reference

ITableColumnCollection Interface
ITableColumnCollection Members


Count Property (ITableColumnCollection)

Count Property (ITableColumnCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableColumnCollection Interface : Count Property
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property Count As System.Integer
System.int Count {get;}
See Also

Reference

ITableColumnCollection Interface
ITableColumnCollection Members


IsSynchronized Property (ITableColumnCollection)

IsSynchronized Property (ITableColumnCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableColumnCollection Interface : IsSynchronized Property
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property IsSynchronized As System.Boolean
System.bool IsSynchronized {get;}
See Also

Reference

ITableColumnCollection Interface
ITableColumnCollection Members


SyncRoot Property (ITableColumnCollection)

SyncRoot Property (ITableColumnCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableColumnCollection Interface : SyncRoot Property
Syntax
  • Visual Basic
  • C#
'Declaration

ReadOnly Property SyncRoot As System.Object
System.object SyncRoot {get;}
See Also

Reference

ITableColumnCollection Interface
ITableColumnCollection Members


ITableDetail Interface Methods

ITableDetail Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableDetail Interface

For a list of all members of this type, see ITableDetail members.

Public Methods
 | Name | Description
Method | ChangeVisibility | Toggles visibility state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Method | GetService | (Inherited from System.IServiceProvider)
Method | Subscribe | Looks for the toggle controller and registers this instance with it (if there is any). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Top
See Also

Reference

ITableDetail Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableDetailCollection Interface Properties

ITableDetailCollection Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableDetailCollection Interface

For a list of all members of this type, see ITableDetailCollection members.

Public Properties
 | Name | Description
Property | Count | Gets number of items in the collection. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableDetail>)
Property | Item | Gets the T at the specified index. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableDetail>)
Top
See Also

Reference

ITableDetailCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


GetService Method (ITableDetail)

GetService Method (ITableDetail)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITableDetail Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

ITableDetail Interface
ITableDetail Members


ITableGroup Interface Methods

ITableGroup Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableGroup Interface

For a list of all members of this type, see ITableGroup members.

Public Methods
 | Name | Description
Method | ChangeVisibility | Toggles visibility state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Method | Subscribe | Looks for the toggle controller and registers this instance with it (if there is any). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Top
See Also

Reference

ITableGroup Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableGroupCollection Interface Properties

ITableGroupCollection Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableGroupCollection Interface

For a list of all members of this type, see ITableGroupCollection members.

Public Properties
 | Name | Description
Property | Count | Gets number of items in the collection. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableGroup>)
Property | Item | Gets the T at the specified index. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableGroup>)
Top
See Also

Reference

ITableGroupCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableRow Interface Methods

ITableRow Interface Methods

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableRow Interface

For a list of all members of this type, see ITableRow members.

Public Methods
 | Name | Description
Method | ChangeVisibility | Toggles visibility state. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Method | Subscribe | Looks for the toggle controller and registers this instance with it (if there is any). (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IToggleReceiver)
Top
See Also

Reference

ITableRow Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


ITableRowCollection Interface Properties

ITableRowCollection Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace : ITableRowCollection Interface

For a list of all members of this type, see ITableRowCollection members.

Public Properties
 | Name | Description
Property | Count | Gets number of items in the collection. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableRow>)
Property | Item | Gets the T at the specified index. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<ITableRow>)
Top
See Also

Reference

ITableRowCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace


GetService Method (ITable)

GetService Method (ITable)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace > ITable Interface : GetService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Function GetService( _
   ByVal serviceType As System.Type _
) As System.Object
System.object GetService(
   System.Type serviceType
)

Parameters

serviceType
See Also

Reference

ITable Interface
ITable Members


GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Rendering.Components.Table Namespace
Inheritance Hierarchy
System.Object
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Rendering.Components Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ItemCollectionExtensions
System.ValueType
GrapeCity.ActiveReports.Extensibility.Rendering.Components.ChangeResult
GrapeCity.ActiveReports.Extensibility.Rendering.Components.DrillthroughParameter
GrapeCity.ActiveReports.Extensibility.Rendering.Components.TabStop
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


CreateObjRef Method (BrushEx)

CreateObjRef Method (BrushEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > BrushEx Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

BrushEx Class
BrushEx Members


Dispose Method (BrushEx)

Dispose Method (BrushEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > BrushEx Class : Dispose Method
Releases unmanaged and - optionally - managed resources.
Overload List
Overload | Description
Dispose | Releases all resources used by this BrushEx object.
See Also

Reference

BrushEx Class
BrushEx Members


GetLifetimeService Method (BrushEx)

GetLifetimeService Method (BrushEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > BrushEx Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

BrushEx Class
BrushEx Members


InitializeLifetimeService Method (BrushEx)

InitializeLifetimeService Method (BrushEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > BrushEx Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
public virtual System.object InitializeLifetimeService()
See Also

Reference

BrushEx Class
BrushEx Members


CreateObjRef Method (FontEx)

CreateObjRef Method (FontEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > FontEx Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

FontEx Class
FontEx Members


Dispose Method (FontEx)

Dispose Method (FontEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > FontEx Class : Dispose Method
Releases unmanaged and - optionally - managed resources.
Overload List
Overload | Description
Dispose | Releases all resources used by this FontEx object.
See Also

Reference

FontEx Class
FontEx Members


GetLifetimeService Method (FontEx)

GetLifetimeService Method (FontEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > FontEx Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

FontEx Class
FontEx Members


InitializeLifetimeService Method (FontEx)

InitializeLifetimeService Method (FontEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > FontEx Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
public virtual System.object InitializeLifetimeService()
See Also

Reference

FontEx Class
FontEx Members


CreateTextureBrush Method

CreateTextureBrush Method

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IDrawingCanvas Interface : CreateTextureBrush Method
Initializes a new BrushEx brush using the specified image.
Overload List
Overload | Description
CreateTextureBrush | Initializes a new BrushEx brush using the specified image data.
See Also

Reference

IDrawingCanvas Interface
IDrawingCanvas Members


Dispose Method (IFontInfo)

Dispose Method (IFontInfo)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IFontInfo Interface : Dispose Method
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Dispose()
void Dispose()
See Also

Reference

IFontInfo Interface
IFontInfo Members


CreateObjRef Method (ImageEx)

CreateObjRef Method (ImageEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > ImageEx Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

ImageEx Class
ImageEx Members


Dispose Method (ImageEx)

Dispose Method (ImageEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > ImageEx Class : Dispose Method
Releases unmanaged and - optionally - managed resources.
Overload List
Overload | Description
Dispose | Releases all resources used by this ImageEx object.
See Also

Reference

ImageEx Class
ImageEx Members


GetLifetimeService Method (ImageEx)

GetLifetimeService Method (ImageEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > ImageEx Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

ImageEx Class
ImageEx Members


InitializeLifetimeService Method (ImageEx)

InitializeLifetimeService Method (ImageEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > ImageEx Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
public virtual System.object InitializeLifetimeService()
See Also

Reference

ImageEx Class
ImageEx Members


Dispose Method (IPathEx)

Dispose Method (IPathEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > IPathEx Interface : Dispose Method
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Dispose()
void Dispose()
See Also

Reference

IPathEx Interface
IPathEx Members


CreateObjRef Method (PenEx)

CreateObjRef Method (PenEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > PenEx Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

PenEx Class
PenEx Members


Dispose Method (PenEx)

Dispose Method (PenEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > PenEx Class : Dispose Method
Releases unmanaged and - optionally - managed resources.
Overload List
Overload | Description
Dispose | Releases all resources used by this PenEx object.
See Also

Reference

PenEx Class
PenEx Members


GetLifetimeService Method (PenEx)

GetLifetimeService Method (PenEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > PenEx Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

PenEx Class
PenEx Members


InitializeLifetimeService Method (PenEx)

InitializeLifetimeService Method (PenEx)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace > PenEx Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
public virtual System.object InitializeLifetimeService()
See Also

Reference

PenEx Class
PenEx Members


GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Rendering.Drawing Namespace
Inheritance Hierarchy
System.Object
System.MarshalByRefObject
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing.BrushEx
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing.FontEx
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing.ImageEx
GrapeCity.ActiveReports.Extensibility.Rendering.Drawing.PenEx
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


GetSupportedSettings Method (IConfigurable)

GetSupportedSettings Method (IConfigurable)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > IConfigurable Interface : GetSupportedSettings Method
Returns the settings supported by a rendering extension.
Overload List
Overload | Description
GetSupportedSettings | Returns the settings supported by a rendering extension.
See Also

Reference

IConfigurable Interface
IConfigurable Members


Capacity Property (ImageMapAreaCollection)

Capacity Property (ImageMapAreaCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ImageMapAreaCollection Class : Capacity Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

ImageMapAreaCollection Class
ImageMapAreaCollection Members


Clear Method (ImageMapAreaCollection)

Clear Method (ImageMapAreaCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ImageMapAreaCollection Class : Clear Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

ImageMapAreaCollection Class
ImageMapAreaCollection Members


Count Property (ImageMapAreaCollection)

Count Property (ImageMapAreaCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ImageMapAreaCollection Class : Count Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

ImageMapAreaCollection Class
ImageMapAreaCollection Members


RemoveAt Method (ImageMapAreaCollection)

RemoveAt Method (ImageMapAreaCollection)

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace > ImageMapAreaCollection Class : RemoveAt Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
See Also

Reference

ImageMapAreaCollection Class
ImageMapAreaCollection Members


GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Rendering.Interactivity Namespace
Inheritance Hierarchy
System.Object
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Rendering.IO Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamInfo
GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


IReadOnlyReportItemCollection Interface Properties

IReadOnlyReportItemCollection Interface Properties

GrapeCity.ActiveReports.Extensibility.v10 Assembly > GrapeCity.ActiveReports.Extensibility.Rendering Namespace : IReadOnlyReportItemCollection Interface

For a list of all members of this type, see IReadOnlyReportItemCollection members.

Public Properties
 | Name | Description
Property | Count | Gets number of items in the collection. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<IReportItem>)
Property | Item | Gets the T at the specified index. (Inherited from GrapeCity.ActiveReports.Extensibility.Rendering.Components.IItemCollection<IReportItem>)
Top
See Also

Reference

IReadOnlyReportItemCollection Interface
GrapeCity.ActiveReports.Extensibility.Rendering Namespace


GrapeCity.ActiveReports.Extensibility.Rendering Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Extensibility.Rendering Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility.Rendering Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.CustomData
GrapeCity.ActiveReports.Extensibility.Rendering.CustomProperty
GrapeCity.ActiveReports.Extensibility.Rendering.DataMember
System.Collections.CollectionBase
GrapeCity.ActiveReports.Extensibility.Rendering.ImageMapAreaCollection
System.EventArgs
GrapeCity.ActiveReports.Extensibility.Rendering.RenderingPageEventArgs
System.ValueType
GrapeCity.ActiveReports.Extensibility.Rendering.ImageInfo
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


GrapeCity.ActiveReports.Extensibility Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Extensibility Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Extensibility.v10 Assembly : GrapeCity.ActiveReports.Extensibility Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Extensibility.ResourceLocator
System.ValueType
GrapeCity.ActiveReports.Extensibility.Resource
GrapeCity.ActiveReports.Extensibility.ResourceInfo
See Also

Reference

GrapeCity.ActiveReports.Extensibility.v10 Assembly


GrapeCity.ActiveReports.v10 Assembly

GrapeCity.ActiveReports.v10 Assembly
The GrapeCity.ActiveReports assembly contains the reporting engine classes and report controls.
Namespaces
Namespace | Description
GrapeCity.ActiveReports | The GrapeCity.ActiveReports namespace contains the report, control, and section classes that are the basis of all reports.
GrapeCity.ActiveReports.Configuration | The GrapeCity.ActiveReports.Configuration namespace consists of classes that configure the report.
GrapeCity.ActiveReports.Data | The GrapeCity.ActiveReports.Data namespace contains the classes used for section report data binding in section reports.
GrapeCity.ActiveReports.Document | The Grape.ActiveReports.Document namespace contains many classes which give control over various aspects of the final output of the report.
GrapeCity.ActiveReports.Export | The GrapeCity.ActiveReports.Export namespace contains the common interface for all the export filters.
GrapeCity.ActiveReports.Expressions | The GrapeCity.ActiveReports.Expressions namespace includes classes having information of expressions etc.
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel | The GrapeCity.ActiveReports.Expression.ExpressionObjectModel namespace includes parameter related classes.
GrapeCity.ActiveReports.Options | The GrapeCity.ActiveReports.Options namespace contains the barcode options classes for Code49, PDF417, and QRCode barcodes.
GrapeCity.ActiveReports.PageReportModel | The GrapeCity.ActiveReports.PageReportModel namespace includes classes that can be used in page reports.
GrapeCity.ActiveReports.Rendering.IO | The GrapeCity.ActiveReports.Rendering.IO Namespace includes FileStreamProvider class and MemoryStreamProvider class.
GrapeCity.ActiveReports.ReportsCore.Configuration |
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders |
GrapeCity.ActiveReports.SectionReportModel | The GrapeCity.ActiveReports.SectionReportModel namespace includes classes that can be used in section reports.
GrapeCity.BI.Data.DataProviders | The GrapeCity.BI.Data.DataProviders namespace contains the DataProviderInfo class.


Capacity Property (RenderingExtensionInfoCollection)

Capacity Property (RenderingExtensionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : Capacity Property

Gets or sets the number of elements that the RenderingExtensionInfoCollection can contain.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


Clear Method (RenderingExtensionInfoCollection)

Clear Method (RenderingExtensionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : Clear Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


Count Property (RenderingExtensionInfoCollection)

Count Property (RenderingExtensionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : Count Property
Gets the number of elements contained in the RenderingExtensionInfoCollection instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


RemoveAt Method (RenderingExtensionInfoCollection)

RemoveAt Method (RenderingExtensionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Configuration Namespace > RenderingExtensionInfoCollection Class : RemoveAt Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
See Also

Reference

RenderingExtensionInfoCollection Class
RenderingExtensionInfoCollection Members


GrapeCity.ActiveReports.Configuration Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Configuration Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports.Configuration Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Configuration.CustomDesignerConfigurationDictionary
GrapeCity.ActiveReports.Configuration.DefaultConfigurationProvider
GrapeCity.ActiveReports.Configuration.PropertyElement
GrapeCity.ActiveReports.Configuration.RenderingExtensionInfo
GrapeCity.ActiveReports.Configuration.ReportItemsConfigurationDictionary
GrapeCity.ActiveReports.Configuration.ToolboxItemConfig
System.Collections.CollectionBase
GrapeCity.ActiveReports.Configuration.RenderingExtensionInfoCollection
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


FieldCollection Constructor

FieldCollection Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : FieldCollection Constructor
Initializes a new instance of the FieldCollection class.
Overload List
Overload | Description
FieldCollection Constructor | Initializes a new instance of the FieldCollection class.
See Also

Reference

FieldCollection Class
FieldCollection Members


Capacity Property (FieldCollection)

Capacity Property (FieldCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : Capacity Property
Gets or sets the number of elements that the FieldCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

FieldCollection Class
FieldCollection Members


Clear Method (FieldCollection)

Clear Method (FieldCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : Clear Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

FieldCollection Class
FieldCollection Members


Count Property (FieldCollection)

Count Property (FieldCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : Count Property
Gets the number of elements contained in the FieldCollection instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

FieldCollection Class
FieldCollection Members


Dispose Method (FieldCollection)

Dispose Method (FieldCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : Dispose Method
Releases the fields collection from memory.
Overload List
Overload | Description
Dispose | Releases the fields collection from memory.
See Also

Reference

FieldCollection Class
FieldCollection Members


IndexOf Method (FieldCollection)

IndexOf Method (FieldCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : IndexOf Method
Finds the index number of the field with specified name in the collection.
Finds the index number of the specified field in the collection.
Overload List
Overload | Description
IndexOf | Finds the index number of the specified field in the collection.
See Also

Reference

FieldCollection Class
FieldCollection Members


RemoveAt Method (FieldCollection)

RemoveAt Method (FieldCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > FieldCollection Class : RemoveAt Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
See Also

Reference

FieldCollection Class
FieldCollection Members


Field Constructor

Field Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : Field Constructor
Initializes a new instance of the Field class.
Overload List
Overload | Description
Field Constructor | Initializes a new instance of the Field class.
See Also

Reference

Field Class
Field Members


Dispose Method (Field)

Dispose Method (Field)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Data Namespace > Field Class : Dispose Method
Release the instance of the Field object from memory.
Overload List
Overload | Description
Dispose | Release the instance of the Field object from memory.
See Also

Reference

Field Class
Field Members


GrapeCity.ActiveReports.Data Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Data Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports.Data Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Data.Field
GrapeCity.ActiveReports.Data.ListDataSource
GrapeCity.ActiveReports.Data.OdbcDataSource
GrapeCity.ActiveReports.Data.OleDBDataSource
GrapeCity.ActiveReports.Data.SqlDBDataSource
GrapeCity.ActiveReports.Data.XMLDataSource
System.Collections.CollectionBase
GrapeCity.ActiveReports.Data.FieldCollection
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


PageDocument Constructor

PageDocument Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Document Namespace > PageDocument Class : PageDocument Constructor
Initializes a new instance of PageDocument Class.
Overload List
Overload | Description
PageDocument Constructor | Initializes a new instance of PageDocument Class.
See Also

Reference

PageDocument Class
PageDocument Members


GrapeCity.ActiveReports.Document Namespace (GrapeCity.ActiveReports.v10) Inheritance Hierarchy

GrapeCity.ActiveReports.Document Namespace (GrapeCity.ActiveReports.v10) Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports.Document Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Document.PageDocument
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


GrapeCity.ActiveReports.Export Namespace (GrapeCity.ActiveReports.v10) Inheritance Hierarchy

GrapeCity.ActiveReports.Export Namespace (GrapeCity.ActiveReports.v10) Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports.Export Namespace
Inheritance Hierarchy
System.Object
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


Capacity Property (ExpressionInfoCollection)

Capacity Property (ExpressionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfoCollection Class : Capacity Property

Gets or sets the number of elements that the ExpressionInfoCollection can contain.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

ExpressionInfoCollection Class
ExpressionInfoCollection Members


Clear Method (ExpressionInfoCollection)

Clear Method (ExpressionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfoCollection Class : Clear Method
Removes all objects from the ExpressionInfoCollection instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

ExpressionInfoCollection Class
ExpressionInfoCollection Members


Count Property (ExpressionInfoCollection)

Count Property (ExpressionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfoCollection Class : Count Property

Gets the number of elements contained in the ExpressionInfoCollection instance.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

ExpressionInfoCollection Class
ExpressionInfoCollection Members


RemoveAt Method (ExpressionInfoCollection)

RemoveAt Method (ExpressionInfoCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfoCollection Class : RemoveAt Method
Removes the ExpressionInfo at the specified index of the ExpressionInfoCollection instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
See Also

Reference

ExpressionInfoCollection Class
ExpressionInfoCollection Members


Parse Method (ExpressionInfo)

Parse Method (ExpressionInfo)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions Namespace > ExpressionInfo Class : Parse Method
Parses the specified expression string and returns an ExpressionInfo object that represents the specified expression.
Overload List
Overload | Description
Parse | Parses the specified expression string and returns an ExpressionInfo object that represents the specified expression.
See Also

Reference

ExpressionInfo Class
ExpressionInfo Members


Capacity Property (ParameterCollection)

Capacity Property (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterCollection Class : Capacity Property
Gets or sets the number of elements that the ParameterCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

ParameterCollection Class
ParameterCollection Members


Clear Method (ParameterCollection)

Clear Method (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterCollection Class : Clear Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

ParameterCollection Class
ParameterCollection Members


Count Property (ParameterCollection)

Count Property (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterCollection Class : Count Property
Gets the number of elements contained in the ParameterCollection instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

ParameterCollection Class
ParameterCollection Members


RemoveAt Method (ParameterCollection)

RemoveAt Method (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterCollection Class : RemoveAt Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
See Also

Reference

ParameterCollection Class
ParameterCollection Members


Capacity Property (ParameterValueCollection)

Capacity Property (ParameterValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterValueCollection Class : Capacity Property

Gets or sets the number of elements that the ParameterValueCollection can contain.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


Clear Method (ParameterValueCollection)

Clear Method (ParameterValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterValueCollection Class : Clear Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


Count Property (ParameterValueCollection)

Count Property (ParameterValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterValueCollection Class : Count Property
Gets the number of elements contained in the ParameterValueCollection instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


RemoveAt Method (ParameterValueCollection)

RemoveAt Method (ParameterValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ParameterValueCollection Class : RemoveAt Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


ReportParameterException Class Methods

ReportParameterException Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace : ReportParameterException Class

For a list of all members of this type, see ReportParameterException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

ReportParameterException Class
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace


ReportParameterException Class Properties

ReportParameterException Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace : ReportParameterException Class

For a list of all members of this type, see ReportParameterException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Error code for future detail processing. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | ErrorData | Error data, depends on error code. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

ReportParameterException Class
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace


Data Property (ReportParameterException)

Data Property (ReportParameterException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ReportParameterException Class : Data Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Data As System.Collections.IDictionary
public virtual System.Collections.IDictionary Data {get;}
See Also

Reference

ReportParameterException Class
ReportParameterException Members


GetBaseException Method (ReportParameterException)

GetBaseException Method (ReportParameterException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ReportParameterException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetBaseException() As System.Exception
public virtual System.Exception GetBaseException()
See Also

Reference

ReportParameterException Class
ReportParameterException Members


GetObjectData Method (ReportParameterException)

GetObjectData Method (ReportParameterException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ReportParameterException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
See Also

Reference

ReportParameterException Class
ReportParameterException Members


GetType Method (ReportParameterException)

GetType Method (ReportParameterException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ReportParameterException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
See Also

Reference

ReportParameterException Class
ReportParameterException Members


GetType() Method

GetType() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ReportParameterException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetType() As System.Type
public System.Type GetType()
See Also

Reference

ReportParameterException Class
ReportParameterException Members


HelpLink Property (ReportParameterException)

HelpLink Property (ReportParameterException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ReportParameterException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property HelpLink As System.String
public virtual System.string HelpLink {get; set;}
See Also

Reference

ReportParameterException Class
ReportParameterException Members


HResult Property (ReportParameterException)

HResult Property (ReportParameterException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ReportParameterException Class : HResult Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HResult As System.Integer
public System.int HResult {get;}
See Also

Reference

ReportParameterException Class
ReportParameterException Members


InnerException Property (ReportParameterException)

InnerException Property (ReportParameterException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ReportParameterException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InnerException As System.Exception
public System.Exception InnerException {get;}
See Also

Reference

ReportParameterException Class
ReportParameterException Members


Message Property (ReportParameterException)

Message Property (ReportParameterException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ReportParameterException Class : Message Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Message As System.String
public virtual System.string Message {get;}
See Also

Reference

ReportParameterException Class
ReportParameterException Members


Source Property (ReportParameterException)

Source Property (ReportParameterException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ReportParameterException Class : Source Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Source As System.String
public virtual System.string Source {get; set;}
See Also

Reference

ReportParameterException Class
ReportParameterException Members


StackTrace Property (ReportParameterException)

StackTrace Property (ReportParameterException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ReportParameterException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property StackTrace As System.String
public virtual System.string StackTrace {get;}
See Also

Reference

ReportParameterException Class
ReportParameterException Members


TargetSite Property (ReportParameterException)

TargetSite Property (ReportParameterException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ReportParameterException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
public System.Reflection.MethodBase TargetSite {get;}
See Also

Reference

ReportParameterException Class
ReportParameterException Members


ToString Method (ReportParameterException)

ToString Method (ReportParameterException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace > ReportParameterException Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

ReportParameterException Class
ReportParameterException Members


GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports.Expressions.ExpressionObjectModel Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel.Parameter
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel.ParameterValue
System.Collections.CollectionBase
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel.ParameterCollection
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel.ParameterValueCollection
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.ReportException
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel.ReportParameterException
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


GrapeCity.ActiveReports.Expressions Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Expressions Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports.Expressions Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Expressions.ExpressionInfo
System.Collections.CollectionBase
GrapeCity.ActiveReports.Expressions.ExpressionInfoCollection
System.EventArgs
GrapeCity.ActiveReports.Expressions.ExpressionInfoCollectionEventArgs
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


InvalidReportDefinitionException Class Methods

InvalidReportDefinitionException Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : InvalidReportDefinitionException Class

For a list of all members of this type, see InvalidReportDefinitionException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

InvalidReportDefinitionException Class
GrapeCity.ActiveReports Namespace


InvalidReportDefinitionException Class Properties

InvalidReportDefinitionException Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : InvalidReportDefinitionException Class

For a list of all members of this type, see InvalidReportDefinitionException members.

Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorCode | Error code for future detail processing. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | ErrorData | Error data, depends on error code. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
See Also

Reference

InvalidReportDefinitionException Class
GrapeCity.ActiveReports Namespace


Data Property (InvalidReportDefinitionException)

Data Property (InvalidReportDefinitionException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > InvalidReportDefinitionException Class : Data Property

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Data As System.Collections.IDictionary
public virtual System.Collections.IDictionary Data {get;}
See Also

Reference

InvalidReportDefinitionException Class
InvalidReportDefinitionException Members


GetBaseException Method (InvalidReportDefinitionException)

GetBaseException Method (InvalidReportDefinitionException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > InvalidReportDefinitionException Class : GetBaseException Method

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetBaseException() As System.Exception
public virtual System.Exception GetBaseException()
See Also

Reference

InvalidReportDefinitionException Class
InvalidReportDefinitionException Members


GetObjectData Method (InvalidReportDefinitionException)

GetObjectData Method (InvalidReportDefinitionException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > InvalidReportDefinitionException Class : GetObjectData Method

When overridden in a derived class, sets the SerializationInfo with information about the exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
See Also

Reference

InvalidReportDefinitionException Class
InvalidReportDefinitionException Members


GetType Method (InvalidReportDefinitionException)

GetType Method (InvalidReportDefinitionException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > InvalidReportDefinitionException Class : GetType Method
Gets the runtime type of the current instance.
Overload List
Overload | Description
GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
See Also

Reference

InvalidReportDefinitionException Class
InvalidReportDefinitionException Members


GetType() Method

GetType() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > InvalidReportDefinitionException Class : GetType() Method
Gets the runtime type of the current instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetType() As System.Type
public System.Type GetType()
See Also

Reference

InvalidReportDefinitionException Class
InvalidReportDefinitionException Members


HelpLink Property (InvalidReportDefinitionException)

HelpLink Property (InvalidReportDefinitionException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > InvalidReportDefinitionException Class : HelpLink Property

Gets or sets a link to the help file associated with this exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property HelpLink As System.String
public virtual System.string HelpLink {get; set;}
See Also

Reference

InvalidReportDefinitionException Class
InvalidReportDefinitionException Members


HResult Property (InvalidReportDefinitionException)

HResult Property (InvalidReportDefinitionException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > InvalidReportDefinitionException Class : HResult Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HResult As System.Integer
public System.int HResult {get;}
See Also

Reference

InvalidReportDefinitionException Class
InvalidReportDefinitionException Members


InnerException Property (InvalidReportDefinitionException)

InnerException Property (InvalidReportDefinitionException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > InvalidReportDefinitionException Class : InnerException Property

Gets the Exception instance that caused the current exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InnerException As System.Exception
public System.Exception InnerException {get;}
See Also

Reference

InvalidReportDefinitionException Class
InvalidReportDefinitionException Members


Message Property (InvalidReportDefinitionException)

Message Property (InvalidReportDefinitionException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > InvalidReportDefinitionException Class : Message Property

Gets a message that describes the current exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Message As System.String
public virtual System.string Message {get;}
See Also

Reference

InvalidReportDefinitionException Class
InvalidReportDefinitionException Members


Source Property (InvalidReportDefinitionException)

Source Property (InvalidReportDefinitionException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > InvalidReportDefinitionException Class : Source Property

Gets or sets the name of the application or the object that causes the error.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Source As System.String
public virtual System.string Source {get; set;}
See Also

Reference

InvalidReportDefinitionException Class
InvalidReportDefinitionException Members


StackTrace Property (InvalidReportDefinitionException)

StackTrace Property (InvalidReportDefinitionException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > InvalidReportDefinitionException Class : StackTrace Property

Gets a string representation of the immediate frames on the call stack.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property StackTrace As System.String
public virtual System.string StackTrace {get;}
See Also

Reference

InvalidReportDefinitionException Class
InvalidReportDefinitionException Members


TargetSite Property (InvalidReportDefinitionException)

TargetSite Property (InvalidReportDefinitionException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > InvalidReportDefinitionException Class : TargetSite Property

Gets the method that throws the current exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
public System.Reflection.MethodBase TargetSite {get;}
See Also

Reference

InvalidReportDefinitionException Class
InvalidReportDefinitionException Members


ToString Method (InvalidReportDefinitionException)

ToString Method (InvalidReportDefinitionException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > InvalidReportDefinitionException Class : ToString Method

Creates and returns a string representation of the current exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

InvalidReportDefinitionException Class
InvalidReportDefinitionException Members


BarCodeException Class Methods

BarCodeException Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace : BarCodeException Class

For a list of all members of this type, see BarCodeException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the BarCodeException that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, it sets the information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

BarCodeException Class
GrapeCity.ActiveReports.Options Namespace


Data Property (BarCodeException)

Data Property (BarCodeException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > BarCodeException Class : Data Property

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Data As System.Collections.IDictionary
public virtual System.Collections.IDictionary Data {get;}
See Also

Reference

BarCodeException Class
BarCodeException Members


GetBaseException Method (BarCodeException)

GetBaseException Method (BarCodeException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > BarCodeException Class : GetBaseException Method

When overridden in a derived class, returns the BarCodeException that is the root cause of one or more subsequent exceptions.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetBaseException() As System.Exception
public virtual System.Exception GetBaseException()
See Also

Reference

BarCodeException Class
BarCodeException Members


GetObjectData Method (BarCodeException)

GetObjectData Method (BarCodeException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > BarCodeException Class : GetObjectData Method

When overridden in a derived class, it sets the information about the exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
See Also

Reference

BarCodeException Class
BarCodeException Members


GetType Method (BarCodeException)

GetType Method (BarCodeException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > BarCodeException Class : GetType Method

Gets the runtime type of the current instance.

Overload List
Overload | Description
GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
See Also

Reference

BarCodeException Class
BarCodeException Members


GetType() Method

GetType() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > BarCodeException Class : GetType() Method

Gets the runtime type of the current instance.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetType() As System.Type
public System.Type GetType()
See Also

Reference

BarCodeException Class
BarCodeException Members


HelpLink Property (BarCodeException)

HelpLink Property (BarCodeException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > BarCodeException Class : HelpLink Property

Gets or sets a link to the help file associated with this exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property HelpLink As System.String
public virtual System.string HelpLink {get; set;}
See Also

Reference

BarCodeException Class
BarCodeException Members


HResult Property (BarCodeException)

HResult Property (BarCodeException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > BarCodeException Class : HResult Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HResult As System.Integer
public System.int HResult {get;}
See Also

Reference

BarCodeException Class
BarCodeException Members


InnerException Property (BarCodeException)

InnerException Property (BarCodeException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > BarCodeException Class : InnerException Property

Gets the BarCodeException instance that caused the current exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InnerException As System.Exception
public System.Exception InnerException {get;}
See Also

Reference

BarCodeException Class
BarCodeException Members


Source Property (BarCodeException)

Source Property (BarCodeException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > BarCodeException Class : Source Property

Gets or sets the name of the object that causes the error.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Source As System.String
public virtual System.string Source {get; set;}
See Also

Reference

BarCodeException Class
BarCodeException Members


StackTrace Property (BarCodeException)

StackTrace Property (BarCodeException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > BarCodeException Class : StackTrace Property

Gets a string representation of the immediate frames on the call stack.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property StackTrace As System.String
public virtual System.string StackTrace {get;}
See Also

Reference

BarCodeException Class
BarCodeException Members


TargetSite Property (BarCodeException)

TargetSite Property (BarCodeException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > BarCodeException Class : TargetSite Property

Gets the method that throws the current exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
public System.Reflection.MethodBase TargetSite {get;}
See Also

Reference

BarCodeException Class
BarCodeException Members


ToString Method (BarCodeException)

ToString Method (BarCodeException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > BarCodeException Class : ToString Method

Creates and returns a string representation of the current exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

BarCodeException Class
BarCodeException Members


Code49Options Constructor

Code49Options Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > Code49Options Class : Code49Options Constructor
Initializes a new instance of the Code49Options class.
Overload List
Overload | Description
Code49Options Constructor | Initializes a new instance of the Code49Options class.
See Also

Reference

Code49Options Class
Code49Options Members


Code128Options Constructor

Code128Options Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > Code128Options Class : Code128Options Constructor
Initializes a new instance of the Code128Options class.
Overload List
Overload | Description
Code128Options Constructor | Initializes a new instance of the Code128Options class.
See Also

Reference

Code128Options Class
Code128Options Members


GS1CompositeOptions Constructor

GS1CompositeOptions Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > GS1CompositeOptions Class : GS1CompositeOptions Constructor
Initializes a new instance of the GS1CompositeOptions class.
Overload List
Overload | Description
GS1CompositeOptions Constructor | Initializes a new instance of the GS1CompositeOptions class.
See Also

Reference

GS1CompositeOptions Class
GS1CompositeOptions Members


PDF417Options Constructor

PDF417Options Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > PDF417Options Class : PDF417Options Constructor
Initializes a new instance of PDF417Options class.
Overload List
Overload | Description
PDF417Options Constructor | Initializes a new instance of PDF417Options class.
See Also

Reference

PDF417Options Class
PDF417Options Members


QRCodeOptions Constructor

QRCodeOptions Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > QRCodeOptions Class : QRCodeOptions Constructor
Initializes a new instance of QRCodeOptions class.
Overload List
Overload | Description
QRCodeOptions Constructor | Initializes a new instance of QRCodeOptions class.
See Also

Reference

QRCodeOptions Class
QRCodeOptions Members


RssExpandedStackedOptions Constructor

RssExpandedStackedOptions Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.Options Namespace > RssExpandedStackedOptions Class : RssExpandedStackedOptions Constructor
Initializes a new instance of the RssExpandedStackedOptions class.
Overload List
Overload | Description
RssExpandedStackedOptions Constructor | Initializes a new instance of the RssExpandedStackedOptions class.
See Also

Reference

RssExpandedStackedOptions Class
RssExpandedStackedOptions Members


GrapeCity.ActiveReports.Options Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Options Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports.Options Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Options.BarCodeOptionsBase
GrapeCity.ActiveReports.Options.Code128Options
GrapeCity.ActiveReports.Options.Code49Options
GrapeCity.ActiveReports.Options.DataMatrixOptions
GrapeCity.ActiveReports.Options.GS1CompositeOptions
GrapeCity.ActiveReports.Options.MicroPDF417Options
GrapeCity.ActiveReports.Options.PDF417Options
GrapeCity.ActiveReports.Options.QRCodeOptions
GrapeCity.ActiveReports.Options.RssExpandedStackedOptions
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.Options.BarCodeException
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


PageReport Class Events

PageReport Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : PageReport Class

For a list of all members of this type, see PageReport members.

Public Events
 | Name | Description
Public Event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

PageReport Class
GrapeCity.ActiveReports Namespace


Body Class Events

Body Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Body Class

For a list of all members of this type, see Body members.

Public Events
 | Name | Description
Public Event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Body Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Property (Body)

Container Property (Body)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Body Class : Container Property
Gets the IContainer that contains the Body.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

Body Class
Body Members


CreateObjRef Method (Body)

CreateObjRef Method (Body)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Body Class : CreateObjRef Method
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.
See Also

Reference

Body Class
Body Members


Dispose Method (Body)

Dispose Method (Body)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Body Class : Dispose Method
Releases the resources used by the Body.
Overload List
Overload | Description
Dispose | Releases the resources used by the Body. (Inherited from System.ComponentModel.Component)
See Also

Reference

Body Class
Body Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Body Class : Dispose() Method
Releases the resources used by the Body.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Body Class
Body Members


Disposed Event (Body)

Disposed Event (Body)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Body Class : Disposed Event
Occurs when the component is disposed by a call to the Dispose method.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Body Class
Body Members


GetLifetimeService Method (Body)

GetLifetimeService Method (Body)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Body Class : GetLifetimeService Method
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.
See Also

Reference

Body Class
Body Members


InitializeLifetimeService Method (Body)

InitializeLifetimeService Method (Body)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Body Class : InitializeLifetimeService Method
Obtains a lifetime service object to control the lifetime policy for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.
See Also

Reference

Body Class
Body Members


Site Property (Body)

Site Property (Body)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Body Class : Site Property
Gets or sets the ISite of the Body.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

Body Class
Body Members


ToString Method (Body)

ToString Method (Body)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Body Class : ToString Method

Returns a String containing the name of the Body, if any. This method should not be overridden.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

Body Class
Body Members


CategoryGrouping Class Events

CategoryGrouping Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CategoryGrouping Class

For a list of all members of this type, see CategoryGrouping members.

Public Events
 | Name | Description
Public Event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

CategoryGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


Capacity Property (CategoryGroupingCollection)

Capacity Property (CategoryGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGroupingCollection Class : Capacity Property
Gets or sets the number of elements that the CategoryGroupingCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

CategoryGroupingCollection Class
CategoryGroupingCollection Members


Clear Method (CategoryGroupingCollection)

Clear Method (CategoryGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGroupingCollection Class : Clear Method
Clears all CategoryGrouping objects from the CategoryGroupingCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

CategoryGroupingCollection Class
CategoryGroupingCollection Members


Count Property (CategoryGroupingCollection)

Count Property (CategoryGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGroupingCollection Class : Count Property
Gets the number of elements contained in the CategoryGroupingCollection instance. This property cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

CategoryGroupingCollection Class
CategoryGroupingCollection Members


RemoveAt Method (CategoryGroupingCollection)

RemoveAt Method (CategoryGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGroupingCollection Class : RemoveAt Method
Removes the specified CategoryGrouping object from the CategoryGroupingCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
See Also

Reference

CategoryGroupingCollection Class
CategoryGroupingCollection Members


Container Property (CategoryGrouping)

Container Property (CategoryGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGrouping Class : Container Property
Gets the IContainer that contains the CategoryGrouping.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

CategoryGrouping Class
CategoryGrouping Members


CreateObjRef Method (CategoryGrouping)

CreateObjRef Method (CategoryGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGrouping Class : CreateObjRef Method
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.
See Also

Reference

CategoryGrouping Class
CategoryGrouping Members


Dispose Method (CategoryGrouping)

Dispose Method (CategoryGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGrouping Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

CategoryGrouping Class
CategoryGrouping Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGrouping Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

CategoryGrouping Class
CategoryGrouping Members


Disposed Event (CategoryGrouping)

Disposed Event (CategoryGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGrouping Class : Disposed Event

Occurs when the component is disposed by a call to the Dispose method.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

CategoryGrouping Class
CategoryGrouping Members


GetLifetimeService Method (CategoryGrouping)

GetLifetimeService Method (CategoryGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGrouping Class : GetLifetimeService Method
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.
See Also

Reference

CategoryGrouping Class
CategoryGrouping Members


InitializeLifetimeService Method (CategoryGrouping)

InitializeLifetimeService Method (CategoryGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGrouping Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

CategoryGrouping Class
CategoryGrouping Members


Site Property (CategoryGrouping)

Site Property (CategoryGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGrouping Class : Site Property
Gets or sets the ISite of the CategoryGrouping.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

CategoryGrouping Class
CategoryGrouping Members


ToString Method (CategoryGrouping)

ToString Method (CategoryGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CategoryGrouping Class : ToString Method

Returns a String containing the name of the CategoryGrouping, if any. This method should not be overridden.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

CategoryGrouping Class
CategoryGrouping Members


Chart Class Events

Chart Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Chart Class

For a list of all members of this type, see Chart members.

Public Events
 | Name | Description
Public Event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Chart Class
GrapeCity.ActiveReports.PageReportModel Namespace


Capacity Property (ChartSeriesCollection)

Capacity Property (ChartSeriesCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartSeriesCollection Class : Capacity Property

Gets or sets the number of elements that the ChartSeriesCollection can contain.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


Clear Method (ChartSeriesCollection)

Clear Method (ChartSeriesCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartSeriesCollection Class : Clear Method
Clears all ChartSeries objects from the ChartSeriesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


Count Property (ChartSeriesCollection)

Count Property (ChartSeriesCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartSeriesCollection Class : Count Property
Gets the number of elements contained in the ChartSeriesCollection instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


RemoveAt Method (ChartSeriesCollection)

RemoveAt Method (ChartSeriesCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ChartSeriesCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the CollectionBase instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

ChartSeriesCollection Class
ChartSeriesCollection Members


Container Property (Chart)

Container Property (Chart)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : Container Property
Gets the IContainer that contains the Chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

Chart Class
Chart Members


CreateObjRef Method (Chart)

CreateObjRef Method (Chart)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : CreateObjRef Method
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.
See Also

Reference

Chart Class
Chart Members


Dispose Method (Chart)

Dispose Method (Chart)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : Dispose Method
Releases the resources used by the Chart.
Overload List
Overload | Description
Dispose | Releases the resources used by the Chart. (Inherited from System.ComponentModel.Component)
See Also

Reference

Chart Class
Chart Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : Dispose() Method
Releases the resources used by the Chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Chart Class
Chart Members


Disposed Event (Chart)

Disposed Event (Chart)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : Disposed Event

Occurs when the component is disposed by a call to the Dispose method.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Chart Class
Chart Members


GetLifetimeService Method (Chart)

GetLifetimeService Method (Chart)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : GetLifetimeService Method
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.
See Also

Reference

Chart Class
Chart Members


InitializeLifetimeService Method (Chart)

InitializeLifetimeService Method (Chart)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : InitializeLifetimeService Method
Obtains a lifetime service object to control the lifetime policy for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.
See Also

Reference

Chart Class
Chart Members


Site Property (Chart)

Site Property (Chart)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : Site Property
Gets or sets the ISite of the Chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

Chart Class
Chart Members


ToString Method (Chart)

ToString Method (Chart)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Chart Class : ToString Method

Returns a String containing the name of the Chart, if any. This method should not be overridden.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

Chart Class
Chart Members


CheckBox Class Events

CheckBox Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CheckBox Class

For a list of all members of this type, see CheckBox members.

Public Events
 | Name | Description
Public Event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

CheckBox Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Property (CheckBox)

Container Property (CheckBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CheckBox Class : Container Property
Gets the IContainer that contains the CheckBox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

CheckBox Class
CheckBox Members


CreateObjRef Method (CheckBox)

CreateObjRef Method (CheckBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CheckBox Class : CreateObjRef Method
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.
See Also

Reference

CheckBox Class
CheckBox Members


Dispose Method (CheckBox)

Dispose Method (CheckBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CheckBox Class : Dispose Method
Releases the resources used by the CheckBox.
Overload List
Overload | Description
Dispose | Releases the resources used by the CheckBox. (Inherited from System.ComponentModel.Component)
See Also

Reference

CheckBox Class
CheckBox Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CheckBox Class : Dispose() Method
Releases the resources used by the CheckBox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

CheckBox Class
CheckBox Members


Disposed Event (CheckBox)

Disposed Event (CheckBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CheckBox Class : Disposed Event
Occurs when the component is disposed by a call to the Dispose method.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

CheckBox Class
CheckBox Members


GetLifetimeService Method (CheckBox)

GetLifetimeService Method (CheckBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CheckBox Class : GetLifetimeService Method
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.
See Also

Reference

CheckBox Class
CheckBox Members


InitializeLifetimeService Method (CheckBox)

InitializeLifetimeService Method (CheckBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CheckBox Class : InitializeLifetimeService Method
Obtains a lifetime service object to control the lifetime policy for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.
See Also

Reference

CheckBox Class
CheckBox Members


Site Property (CheckBox)

Site Property (CheckBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CheckBox Class : Site Property
Gets or sets the ISite of the CheckBox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

CheckBox Class
CheckBox Members


ToString Method (CheckBox)

ToString Method (CheckBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CheckBox Class : ToString Method

Returns a String containing the name of the CheckBox, if any. This method should not be overridden.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

CheckBox Class
CheckBox Members


Capacity Property (CodeClassCollection)

Capacity Property (CodeClassCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CodeClassCollection Class : Capacity Property
Gets or sets the number of elements that the CodeClassCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

CodeClassCollection Class
CodeClassCollection Members


Clear Method (CodeClassCollection)

Clear Method (CodeClassCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CodeClassCollection Class : Clear Method
Clears all CodeClass objects from the CodeClassCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

CodeClassCollection Class
CodeClassCollection Members


Count Property (CodeClassCollection)

Count Property (CodeClassCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CodeClassCollection Class : Count Property
Gets the number of elements contained in the CodeClassCollection instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

CodeClassCollection Class
CodeClassCollection Members


RemoveAt Method (CodeClassCollection)

RemoveAt Method (CodeClassCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CodeClassCollection Class : RemoveAt Method
Removes the specified CodeClass object from the CodeClassCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
See Also

Reference

CodeClassCollection Class
CodeClassCollection Members


ColumnGrouping Class Events

ColumnGrouping Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ColumnGrouping Class

For a list of all members of this type, see ColumnGrouping members.

Public Events
 | Name | Description
Public Event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

ColumnGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


Capacity Property (ColumnGroupingCollection)

Capacity Property (ColumnGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGroupingCollection Class : Capacity Property
Gets or sets the number of elements that the ColumnGroupingCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

ColumnGroupingCollection Class
ColumnGroupingCollection Members


Clear Method (ColumnGroupingCollection)

Clear Method (ColumnGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGroupingCollection Class : Clear Method
Removes all objects from the ColumnGroupingCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

ColumnGroupingCollection Class
ColumnGroupingCollection Members


Count Property (ColumnGroupingCollection)

Count Property (ColumnGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGroupingCollection Class : Count Property
Gets the number of elements contained in the ColumnGroupingCollection instance. This property cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

ColumnGroupingCollection Class
ColumnGroupingCollection Members


RemoveAt Method (ColumnGroupingCollection)

RemoveAt Method (ColumnGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGroupingCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the ColumnGroupingCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

ColumnGroupingCollection Class
ColumnGroupingCollection Members


Container Property (ColumnGrouping)

Container Property (ColumnGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGrouping Class : Container Property

Gets the IContainer that contains the ColumnGrouping.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

ColumnGrouping Class
ColumnGrouping Members


CreateObjRef Method (ColumnGrouping)

CreateObjRef Method (ColumnGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGrouping Class : CreateObjRef Method
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.
See Also

Reference

ColumnGrouping Class
ColumnGrouping Members


Dispose Method (ColumnGrouping)

Dispose Method (ColumnGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGrouping Class : Dispose Method
Releases the resources used by the ColumnGrouping.
Overload List
Overload | Description
Dispose | Releases the resources used by the ColumnGrouping. (Inherited from System.ComponentModel.Component)
See Also

Reference

ColumnGrouping Class
ColumnGrouping Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGrouping Class : Dispose() Method
Releases the resources used by the ColumnGrouping.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

ColumnGrouping Class
ColumnGrouping Members


Disposed Event (ColumnGrouping)

Disposed Event (ColumnGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGrouping Class : Disposed Event

Occurs when the component is disposed by a call to the Dispose method.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

ColumnGrouping Class
ColumnGrouping Members


GetLifetimeService Method (ColumnGrouping)

GetLifetimeService Method (ColumnGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGrouping Class : GetLifetimeService Method
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.
See Also

Reference

ColumnGrouping Class
ColumnGrouping Members


InitializeLifetimeService Method (ColumnGrouping)

InitializeLifetimeService Method (ColumnGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGrouping Class : InitializeLifetimeService Method
Obtains a lifetime service object to control the lifetime policy for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.
See Also

Reference

ColumnGrouping Class
ColumnGrouping Members


Site Property (ColumnGrouping)

Site Property (ColumnGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGrouping Class : Site Property
Gets or sets the ISite of the ColumnGrouping.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

ColumnGrouping Class
ColumnGrouping Members


ToString Method (ColumnGrouping)

ToString Method (ColumnGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ColumnGrouping Class : ToString Method

Returns a String containing the name of the ColumnGrouping, if any. This method should not be overridden.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

ColumnGrouping Class
ColumnGrouping Members


Container Class Events

Container Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Container Class

For a list of all members of this type, see Container members.

Public Events
 | Name | Description
Public Event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Container Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Property (Container)

Container Property (Container)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : Container Property
Gets the IContainer that contains the Container.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

Container Class
Container Members


CreateObjRef Method (Container)

CreateObjRef Method (Container)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : CreateObjRef Method
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.
See Also

Reference

Container Class
Container Members


Dispose Method (Container)

Dispose Method (Container)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : Dispose Method
Releases the resources used by the Container.
Overload List
Overload | Description
Dispose | Releases the resources used by the Container. (Inherited from System.ComponentModel.Component)
See Also

Reference

Container Class
Container Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : Dispose() Method
Releases the resources used by the Container.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Container Class
Container Members


Disposed Event (Container)

Disposed Event (Container)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : Disposed Event

Occurs when the component is disposed by a call to the Dispose method.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Container Class
Container Members


GetLifetimeService Method (Container)

GetLifetimeService Method (Container)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : GetLifetimeService Method
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.
See Also

Reference

Container Class
Container Members


InitializeLifetimeService Method (Container)

InitializeLifetimeService Method (Container)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : InitializeLifetimeService Method
Obtains a lifetime service object to control the lifetime policy for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.
See Also

Reference

Container Class
Container Members


Site Property (Container)

Site Property (Container)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : Site Property
Gets or sets the ISite of the Container.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

Container Class
Container Members


ToString Method (Container)

ToString Method (Container)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Container Class : ToString Method

Returns a String containing the name of the Container, if any. This method should not be overridden.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

Container Class
Container Members


Corner Class Events

Corner Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Corner Class

For a list of all members of this type, see Corner members.

Public Events
 | Name | Description
Public Event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Corner Class
GrapeCity.ActiveReports.PageReportModel Namespace


Corner Class Properties

Corner Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Corner Class

For a list of all members of this type, see Corner members.

Public Properties
 | Name | Description
Public Property | Components | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportComponentCollection containing all the ReportComponents in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Container | Gets the IContainer that contains the Corner. (Inherited from System.ComponentModel.Component)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportItems | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportItemCollection containing all the ReportItems in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Site | Gets or sets the ISite of the Corner. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Corner Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Property (Corner)

Container Property (Corner)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Corner Class : Container Property
Gets the IContainer that contains the Corner.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

Corner Class
Corner Members


CreateObjRef Method (Corner)

CreateObjRef Method (Corner)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Corner Class : CreateObjRef Method
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.
See Also

Reference

Corner Class
Corner Members


Dispose Method (Corner)

Dispose Method (Corner)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Corner Class : Dispose Method
Releases the resources used by the Corner.
Overload List
Overload | Description
Dispose | Releases the resources used by the Corner. (Inherited from System.ComponentModel.Component)
See Also

Reference

Corner Class
Corner Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Corner Class : Dispose() Method
Releases the resources used by the Corner.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Corner Class
Corner Members


Disposed Event (Corner)

Disposed Event (Corner)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Corner Class : Disposed Event

Occurs when the component is disposed by a call to the Dispose method.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Corner Class
Corner Members


GetLifetimeService Method (Corner)

GetLifetimeService Method (Corner)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Corner Class : GetLifetimeService Method
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.
See Also

Reference

Corner Class
Corner Members


InitializeLifetimeService Method (Corner)

InitializeLifetimeService Method (Corner)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Corner Class : InitializeLifetimeService Method
Obtains a lifetime service object to control the lifetime policy for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.
See Also

Reference

Corner Class
Corner Members


Site Property (Corner)

Site Property (Corner)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Corner Class : Site Property
Gets or sets the ISite of the Corner.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

Corner Class
Corner Members


ToString Method (Corner)

ToString Method (Corner)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Corner Class : ToString Method

Returns a String containing the name of the Corner, if any. This method should not be overridden.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

Corner Class
Corner Members


Capacity Property (CustomPropertyDefinitionCollection)

Capacity Property (CustomPropertyDefinitionCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPropertyDefinitionCollection Class : Capacity Property
Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

CustomPropertyDefinitionCollection Class
CustomPropertyDefinitionCollection Members


Clear Method (CustomPropertyDefinitionCollection)

Clear Method (CustomPropertyDefinitionCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPropertyDefinitionCollection Class : Clear Method
Removes all objects from the CustomPropertyDefinitionCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

CustomPropertyDefinitionCollection Class
CustomPropertyDefinitionCollection Members


Count Property (CustomPropertyDefinitionCollection)

Count Property (CustomPropertyDefinitionCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPropertyDefinitionCollection Class : Count Property
Gets the number of elements contained in the CustomPropertyDefinitionCollection instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

CustomPropertyDefinitionCollection Class
CustomPropertyDefinitionCollection Members


RemoveAt Method (CustomPropertyDefinitionCollection)

RemoveAt Method (CustomPropertyDefinitionCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomPropertyDefinitionCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the CustomPropertyDefinitionCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

CustomPropertyDefinitionCollection Class
CustomPropertyDefinitionCollection Members


CustomReportItem Class Events

CustomReportItem Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : CustomReportItem Class

For a list of all members of this type, see CustomReportItem members.

Public Events
 | Name | Description
Public Event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

CustomReportItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Property (CustomReportItem)

Container Property (CustomReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : Container Property
Gets the IContainer that contains the CustomReportItem.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

CustomReportItem Class
CustomReportItem Members


CreateObjRef Method (CustomReportItem)

CreateObjRef Method (CustomReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : CreateObjRef Method
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.
See Also

Reference

CustomReportItem Class
CustomReportItem Members


Dispose Method (CustomReportItem)

Dispose Method (CustomReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : Dispose Method
Releases the resources used by the CustomReportItem.
Overload List
Overload | Description
Dispose | Releases the resources used by the CustomReportItem. (Inherited from System.ComponentModel.Component)
See Also

Reference

CustomReportItem Class
CustomReportItem Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : Dispose() Method
Releases the resources used by the CustomReportItem.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

CustomReportItem Class
CustomReportItem Members


Disposed Event (CustomReportItem)

Disposed Event (CustomReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : Disposed Event

Occurs when the component is disposed by a call to the Dispose method.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

CustomReportItem Class
CustomReportItem Members


GetLifetimeService Method (CustomReportItem)

GetLifetimeService Method (CustomReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : GetLifetimeService Method
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.
See Also

Reference

CustomReportItem Class
CustomReportItem Members


InitializeLifetimeService Method (CustomReportItem)

InitializeLifetimeService Method (CustomReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : InitializeLifetimeService Method
Obtains a lifetime service object to control the lifetime policy for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.
See Also

Reference

CustomReportItem Class
CustomReportItem Members


Site Property (CustomReportItem)

Site Property (CustomReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : Site Property
Gets or sets the ISite of the CustomReportItem.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

CustomReportItem Class
CustomReportItem Members


ToString Method (CustomReportItem)

ToString Method (CustomReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > CustomReportItem Class : ToString Method

Returns a String containing the name of the CustomReportItem, if any. This method should not be overridden.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

CustomReportItem Class
CustomReportItem Members


Capacity Property (DataCellCollection)

Capacity Property (DataCellCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataCellCollection Class : Capacity Property
Gets or sets the number of elements that the DataCellCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

DataCellCollection Class
DataCellCollection Members


Clear Method (DataCellCollection)

Clear Method (DataCellCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataCellCollection Class : Clear Method
Removes all objects from the DataCellCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

DataCellCollection Class
DataCellCollection Members


Count Property (DataCellCollection)

Count Property (DataCellCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataCellCollection Class : Count Property
Gets the number of elements contained in the DataCellCollection instance. This property cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

DataCellCollection Class
DataCellCollection Members


RemoveAt Method (DataCellCollection)

RemoveAt Method (DataCellCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataCellCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the DataCellCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

DataCellCollection Class
DataCellCollection Members


Capacity Property (DataGroupingCollection)

Capacity Property (DataGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGroupingCollection Class : Capacity Property
Gets or sets the number of elements that the DataGroupingCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

DataGroupingCollection Class
DataGroupingCollection Members


Clear Method (DataGroupingCollection)

Clear Method (DataGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGroupingCollection Class : Clear Method
Removes all objects from the DataGroupingCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

DataGroupingCollection Class
DataGroupingCollection Members


Count Property (DataGroupingCollection)

Count Property (DataGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGroupingCollection Class : Count Property
Gets the number of elements contained in the DataGroupingCollection instance. This property cannot be overridden.`
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

DataGroupingCollection Class
DataGroupingCollection Members


RemoveAt Method (DataGroupingCollection)

RemoveAt Method (DataGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGroupingCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the DataGroupingCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

DataGroupingCollection Class
DataGroupingCollection Members


DataGrouping Constructor

DataGrouping Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataGrouping Class : DataGrouping Constructor
Initializes a new instance of DataGrouping class.
Overload List
Overload | Description
DataGrouping Constructor | Initializes a new instance of the DataGrouping class.
See Also

Reference

DataGrouping Class
DataGrouping Members


Capacity Property (DataPointCollection)

Capacity Property (DataPointCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPointCollection Class : Capacity Property
Gets or sets the number of elements that the DataPointCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

DataPointCollection Class
DataPointCollection Members


Clear Method (DataPointCollection)

Clear Method (DataPointCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPointCollection Class : Clear Method
Removes all objects from the DataPointCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

DataPointCollection Class
DataPointCollection Members


Count Property (DataPointCollection)

Count Property (DataPointCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPointCollection Class : Count Property
Gets the number of elements contained in the DataPointCollection instance. This property cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

DataPointCollection Class
DataPointCollection Members


RemoveAt Method (DataPointCollection)

RemoveAt Method (DataPointCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataPointCollection Class : RemoveAt Method
The zero-based index of the element to remove.

Removes the element at the specified index of the DataPointCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

DataPointCollection Class
DataPointCollection Members


DataRegion Class Events

DataRegion Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DataRegion Class

For a list of all members of this type, see DataRegion members.

Public Events
 | Name | Description
Public Event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

DataRegion Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Property (DataRegion)

Container Property (DataRegion)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : Container Property
Gets the IContainer that contains the DataRegion.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

DataRegion Class
DataRegion Members


CreateObjRef Method (DataRegion)

CreateObjRef Method (DataRegion)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : CreateObjRef Method
The System.Type of the object that rthe new System.Runtime.Remoting.ObjRef will reference.
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
The System.Type of the object that rthe new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.
See Also

Reference

DataRegion Class
DataRegion Members


Dispose Method (DataRegion)

Dispose Method (DataRegion)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : Dispose Method
Releases the resources used by the DataRegion.
Overload List
Overload | Description
Dispose | Releases the resources used by the DataRegion. (Inherited from System.ComponentModel.Component)
See Also

Reference

DataRegion Class
DataRegion Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : Dispose() Method
Releases the resources used by the DataRegion.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

DataRegion Class
DataRegion Members


Disposed Event (DataRegion)

Disposed Event (DataRegion)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : Disposed Event

Occurs when the component is disposed by a call to the Dispose method.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

DataRegion Class
DataRegion Members


GetLifetimeService Method (DataRegion)

GetLifetimeService Method (DataRegion)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : GetLifetimeService Method
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.
See Also

Reference

DataRegion Class
DataRegion Members


InitializeLifetimeService Method (DataRegion)

InitializeLifetimeService Method (DataRegion)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : InitializeLifetimeService Method
Obtains a lifetime service object to control the lifetime policy for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
public virtual System.object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.
See Also

Reference

DataRegion Class
DataRegion Members


Site Property (DataRegion)

Site Property (DataRegion)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : Site Property
Gets or sets the ISite of the DataRegion.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
public virtual System.ComponentModel.ISite Site {get; set;}
See Also

Reference

DataRegion Class
DataRegion Members


ToString Method (DataRegion)

ToString Method (DataRegion)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRegion Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

DataRegion Class
DataRegion Members


Capacity Property (DataRowCollection)

Capacity Property (DataRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRowCollection Class : Capacity Property
Gets or sets the number of elements that the DataRowCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

DataRowCollection Class
DataRowCollection Members


Clear Method (DataRowCollection)

Clear Method (DataRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRowCollection Class : Clear Method
Removes all objects from the DataRowCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

DataRowCollection Class
DataRowCollection Members


Count Property (DataRowCollection)

Count Property (DataRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRowCollection Class : Count Property
Gets the number of elements contained in the DataRowCollection instance. This property cannot be overridden.`
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

DataRowCollection Class
DataRowCollection Members


RemoveAt Method (DataRowCollection)

RemoveAt Method (DataRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataRowCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the DataRowCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

DataRowCollection Class
DataRowCollection Members


Capacity Property (DataSetCollection)

Capacity Property (DataSetCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSetCollection Class : Capacity Property
Gets or sets the number of elements that the DataSetCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

DataSetCollection Class
DataSetCollection Members


Clear Method (DataSetCollection)

Clear Method (DataSetCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSetCollection Class : Clear Method
Removes all objects from the DataSetCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

DataSetCollection Class
DataSetCollection Members


Count Property (DataSetCollection)

Count Property (DataSetCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSetCollection Class : Count Property
Gets the number of elements contained in the DataSetCollection instance. This property cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

DataSetCollection Class
DataSetCollection Members


RemoveAt Method (DataSetCollection)

RemoveAt Method (DataSetCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSetCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the DataSetCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

DataSetCollection Class
DataSetCollection Members


Capacity Property (DataSourceCollection)

Capacity Property (DataSourceCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSourceCollection Class : Capacity Property
Gets or sets the number of elements that the DataSourceCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

DataSourceCollection Class
DataSourceCollection Members


Clear Method (DataSourceCollection)

Clear Method (DataSourceCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSourceCollection Class : Clear Method
Removes all objects from the DataSourceCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

DataSourceCollection Class
DataSourceCollection Members


Count Property (DataSourceCollection)

Count Property (DataSourceCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSourceCollection Class : Count Property
Gets the number of elements contained in the DataSourceCollection instance. This property cannot be overridden.`
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

DataSourceCollection Class
DataSourceCollection Members


RemoveAt Method (DataSourceCollection)

RemoveAt Method (DataSourceCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataSourceCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the DataSourceCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

DataSourceCollection Class
DataSourceCollection Members


Capacity Property (DataValueCollection)

Capacity Property (DataValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataValueCollection Class : Capacity Property
Gets or sets the number of elements that the DataValueCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

DataValueCollection Class
DataValueCollection Members


Clear Method (DataValueCollection)

Clear Method (DataValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataValueCollection Class : Clear Method
Removes all objects from the DataValueCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

DataValueCollection Class
DataValueCollection Members


Count Property (DataValueCollection)

Count Property (DataValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataValueCollection Class : Count Property
Gets the number of elements contained in the DataValueCollection instance. This property cannot be overridden.`
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

DataValueCollection Class
DataValueCollection Members


RemoveAt Method (DataValueCollection)

RemoveAt Method (DataValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DataValueCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the DataValueCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

DataValueCollection Class
DataValueCollection Members


Details Class Events

Details Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Details Class

For a list of all members of this type, see Details members.

Public Events
 | Name | Description
Public Event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Details Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Property (Details)

Container Property (Details)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Details Class : Container Property
Gets the IContainer that contains the Details.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

Details Class
Details Members


CreateObjRef Method (Details)

CreateObjRef Method (Details)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Details Class : CreateObjRef Method
The System.Type of the object that rthe new System.Runtime.Remoting.ObjRef will reference.
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
The System.Type of the object that rthe new System.Runtime.Remoting.ObjRef will reference.
See Also

Reference

Details Class
Details Members


Dispose Method (Details)

Dispose Method (Details)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Details Class : Dispose Method
Releases the resources used by the Details.
Overload List
Overload | Description
Dispose | Releases the resources used by the Details. (Inherited from System.ComponentModel.Component)
See Also

Reference

Details Class
Details Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Details Class : Dispose() Method
Releases the resources used by the Details.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Details Class
Details Members


Disposed Event (Details)

Disposed Event (Details)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Details Class : Disposed Event

Occurs when the component is disposed by a call to the Dispose method.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Details Class
Details Members


GetLifetimeService Method (Details)

GetLifetimeService Method (Details)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Details Class : GetLifetimeService Method
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.
See Also

Reference

Details Class
Details Members


InitializeLifetimeService Method (Details)

InitializeLifetimeService Method (Details)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Details Class : InitializeLifetimeService Method
Obtains a lifetime service object to control the lifetime policy for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

Details Class
Details Members


Site Property (Details)

Site Property (Details)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Details Class : Site Property
Gets or sets the ISite of the Details.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

Details Class
Details Members


ToString Method (Details)

ToString Method (Details)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Details Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

Details Class
Details Members


DynamicColumnsRows Class Events

DynamicColumnsRows Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : DynamicColumnsRows Class

For a list of all members of this type, see DynamicColumnsRows members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

DynamicColumnsRows Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Property (DynamicColumnsRows)

Container Property (DynamicColumnsRows)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicColumnsRows Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

DynamicColumnsRows Class
DynamicColumnsRows Members


CreateObjRef Method (DynamicColumnsRows)

CreateObjRef Method (DynamicColumnsRows)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicColumnsRows Class : CreateObjRef Method
The System.Type of the object that rthe new System.Runtime.Remoting.ObjRef will reference.
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
The System.Type of the object that rthe new System.Runtime.Remoting.ObjRef will reference.
See Also

Reference

DynamicColumnsRows Class
DynamicColumnsRows Members


Dispose Method (DynamicColumnsRows)

Dispose Method (DynamicColumnsRows)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicColumnsRows Class : Dispose Method
Releases the resources used by the DynamicColumnsRows.
Overload List
Overload | Description
Dispose | Releases the resources used by the DynamicColumnsRows. (Inherited from System.ComponentModel.Component)
See Also

Reference

DynamicColumnsRows Class
DynamicColumnsRows Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicColumnsRows Class : Dispose() Method
Releases the resources used by the DynamicColumnsRows.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

DynamicColumnsRows Class
DynamicColumnsRows Members


Disposed Event (DynamicColumnsRows)

Disposed Event (DynamicColumnsRows)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicColumnsRows Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

DynamicColumnsRows Class
DynamicColumnsRows Members


GetLifetimeService Method (DynamicColumnsRows)

GetLifetimeService Method (DynamicColumnsRows)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicColumnsRows Class : GetLifetimeService Method
Retrieves the current lifetime service object that controls the lifetime policy for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.
See Also

Reference

DynamicColumnsRows Class
DynamicColumnsRows Members


InitializeLifetimeService Method (DynamicColumnsRows)

InitializeLifetimeService Method (DynamicColumnsRows)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicColumnsRows Class : InitializeLifetimeService Method
Obtains a lifetime service object to control the lifetime policy for this instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

DynamicColumnsRows Class
DynamicColumnsRows Members


Site Property (DynamicColumnsRows)

Site Property (DynamicColumnsRows)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicColumnsRows Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

DynamicColumnsRows Class
DynamicColumnsRows Members


ToString Method (DynamicColumnsRows)

ToString Method (DynamicColumnsRows)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > DynamicColumnsRows Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

DynamicColumnsRows Class
DynamicColumnsRows Members


Capacity Property (EmbeddedImageCollection)

Capacity Property (EmbeddedImageCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedImageCollection Class : Capacity Property
Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

EmbeddedImageCollection Class
EmbeddedImageCollection Members


Clear Method (EmbeddedImageCollection)

Clear Method (EmbeddedImageCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedImageCollection Class : Clear Method
Removes all objects from the DataGroupingCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

EmbeddedImageCollection Class
EmbeddedImageCollection Members


Count Property (EmbeddedImageCollection)

Count Property (EmbeddedImageCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedImageCollection Class : Count Property
Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.`
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

EmbeddedImageCollection Class
EmbeddedImageCollection Members


RemoveAt Method (EmbeddedImageCollection)

RemoveAt Method (EmbeddedImageCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedImageCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the DataCellCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

EmbeddedImageCollection Class
EmbeddedImageCollection Members


EmbeddedStyleSheet Constructor

EmbeddedStyleSheet Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > EmbeddedStyleSheet Class : EmbeddedStyleSheet Constructor
Overload List
Overload | Description
EmbeddedStyleSheet Constructor | Initializes a new instance of the EmbeddedStyleSheet class.
See Also

Reference

EmbeddedStyleSheet Class
EmbeddedStyleSheet Members


Capacity Property (FieldCollection)

Capacity Property (FieldCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > FieldCollection Class : Capacity Property
Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

FieldCollection Class
FieldCollection Members


Clear Method (FieldCollection)

Clear Method (FieldCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > FieldCollection Class : Clear Method
Removes all objects from the DataGroupingCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

FieldCollection Class
FieldCollection Members


Count Property (FieldCollection)

Count Property (FieldCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > FieldCollection Class : Count Property
Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.`
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

FieldCollection Class
FieldCollection Members


RemoveAt Method (FieldCollection)

RemoveAt Method (FieldCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > FieldCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the DataCellCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

FieldCollection Class
FieldCollection Members


Footer Class Events

Footer Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Footer Class

For a list of all members of this type, see Footer members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Footer Class
GrapeCity.ActiveReports.PageReportModel Namespace


Footer Class Methods

Footer Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Footer Class

For a list of all members of this type, see Footer members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the HeaderFooter. (Inherited from GrapeCity.ActiveReports.PageReportModel.HeaderFooter)
Top
See Also

Reference

Footer Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Property (Footer)

Container Property (Footer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Footer Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

Footer Class
Footer Members


CreateObjRef Method (Footer)

CreateObjRef Method (Footer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Footer Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

Footer Class
Footer Members


Dispose Method (Footer)

Dispose Method (Footer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Footer Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

Footer Class
Footer Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Footer Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Footer Class
Footer Members


Disposed Event (Footer)

Disposed Event (Footer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Footer Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Footer Class
Footer Members


GetLifetimeService Method (Footer)

GetLifetimeService Method (Footer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Footer Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

Footer Class
Footer Members


InitializeLifetimeService Method (Footer)

InitializeLifetimeService Method (Footer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Footer Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

Footer Class
Footer Members


Site Property (Footer)

Site Property (Footer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Footer Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

Footer Class
Footer Members


ToString Method (Footer)

ToString Method (Footer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Footer Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

Footer Class
Footer Members


Header Class Events

Header Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Header Class

For a list of all members of this type, see Header members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Header Class
GrapeCity.ActiveReports.PageReportModel Namespace


Header Class Methods

Header Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Header Class

For a list of all members of this type, see Header members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the HeaderFooter. (Inherited from GrapeCity.ActiveReports.PageReportModel.HeaderFooter)
Top
See Also

Reference

Header Class
GrapeCity.ActiveReports.PageReportModel Namespace


HeaderFooter Class Events

HeaderFooter Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : HeaderFooter Class

For a list of all members of this type, see HeaderFooter members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

HeaderFooter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Property (HeaderFooter)

Container Property (HeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > HeaderFooter Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

HeaderFooter Class
HeaderFooter Members


CreateObjRef Method (HeaderFooter)

CreateObjRef Method (HeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > HeaderFooter Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

HeaderFooter Class
HeaderFooter Members


Dispose Method (HeaderFooter)

Dispose Method (HeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > HeaderFooter Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

HeaderFooter Class
HeaderFooter Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > HeaderFooter Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

HeaderFooter Class
HeaderFooter Members


Disposed Event (HeaderFooter)

Disposed Event (HeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > HeaderFooter Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

HeaderFooter Class
HeaderFooter Members


GetLifetimeService Method (HeaderFooter)

GetLifetimeService Method (HeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > HeaderFooter Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

HeaderFooter Class
HeaderFooter Members


InitializeLifetimeService Method (HeaderFooter)

InitializeLifetimeService Method (HeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > HeaderFooter Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
public virtual System.object InitializeLifetimeService()
See Also

Reference

HeaderFooter Class
HeaderFooter Members


Site Property (HeaderFooter)

Site Property (HeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > HeaderFooter Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
public virtual System.ComponentModel.ISite Site {get; set;}
See Also

Reference

HeaderFooter Class
HeaderFooter Members


ToString Method (HeaderFooter)

ToString Method (HeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > HeaderFooter Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

HeaderFooter Class
HeaderFooter Members


Container Property (Header)

Container Property (Header)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Header Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

Header Class
Header Members


CreateObjRef Method (Header)

CreateObjRef Method (Header)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Header Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

Header Class
Header Members


Dispose Method (Header)

Dispose Method (Header)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Header Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

Header Class
Header Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Header Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Header Class
Header Members


Disposed Event (Header)

Disposed Event (Header)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Header Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Header Class
Header Members


GetLifetimeService Method (Header)

GetLifetimeService Method (Header)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Header Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

Header Class
Header Members


InitializeLifetimeService Method (Header)

InitializeLifetimeService Method (Header)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Header Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

Header Class
Header Members


Site Property (Header)

Site Property (Header)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Header Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

Header Class
Header Members


ToString Method (Header)

ToString Method (Header)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Header Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

Header Class
Header Members


IDataSet Interface Methods

IDataSet Interface Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IDataSet Interface

For a list of all members of this type, see IDataSet members.

Public Methods
 | Name | Description
Method | Dispose | (Inherited from System.IDisposable)
Top
See Also

Reference

IDataSet Interface
GrapeCity.ActiveReports.PageReportModel Namespace


Dispose Method (IDataSet)

Dispose Method (IDataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IDataSet Interface : Dispose Method
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Dispose()
void Dispose()
See Also

Reference

IDataSet Interface
IDataSet Members


Site Property (IDataSet)

Site Property (IDataSet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IDataSet Interface : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Property Site As System.ComponentModel.ISite
System.ComponentModel.ISite Site {get; set;}
See Also

Reference

IDataSet Interface
IDataSet Members


Image Class Events

Image Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Image Class

For a list of all members of this type, see Image members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Image Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Property (Image)

Container Property (Image)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

Image Class
Image Members


CreateObjRef Method (Image)

CreateObjRef Method (Image)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

Image Class
Image Members


Dispose Method (Image)

Dispose Method (Image)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

Image Class
Image Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Image Class
Image Members


Disposed Event (Image)

Disposed Event (Image)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Image Class
Image Members


GetLifetimeService Method (Image)

GetLifetimeService Method (Image)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

Image Class
Image Members


InitializeLifetimeService Method (Image)

InitializeLifetimeService Method (Image)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

Image Class
Image Members


Site Property (Image)

Site Property (Image)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

Image Class
Image Members


ToString Method (Image)

ToString Method (Image)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Image Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

Image Class
Image Members


IRdlContainer Interface Methods

IRdlContainer Interface Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IRdlContainer Interface

For a list of all members of this type, see IRdlContainer members.

Public Methods
 | Name | Description
Method | Dispose | (Inherited from System.IDisposable)
Top
See Also

Reference

IRdlContainer Interface
GrapeCity.ActiveReports.PageReportModel Namespace


Dispose Method (IRdlContainer)

Dispose Method (IRdlContainer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IRdlContainer Interface : Dispose Method
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Dispose()
void Dispose()
See Also

Reference

IRdlContainer Interface
IRdlContainer Members


Site Property (IRdlContainer)

Site Property (IRdlContainer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IRdlContainer Interface : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Property Site As System.ComponentModel.ISite
System.ComponentModel.ISite Site {get; set;}
See Also

Reference

IRdlContainer Interface
IRdlContainer Members


IReportComponent Interface Methods

IReportComponent Interface Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IReportComponent Interface

For a list of all members of this type, see IReportComponent members.

Public Methods
 | Name | Description
Method | Dispose | (Inherited from System.IDisposable)
Top
See Also

Reference

IReportComponent Interface
GrapeCity.ActiveReports.PageReportModel Namespace


IReportComponentContainer Interface Methods

IReportComponentContainer Interface Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : IReportComponentContainer Interface

For a list of all members of this type, see IReportComponentContainer members.

Public Methods
 | Name | Description
Method | Dispose | (Inherited from System.IDisposable)
Top
See Also

Reference

IReportComponentContainer Interface
GrapeCity.ActiveReports.PageReportModel Namespace


Dispose Method (IReportComponentContainer)

Dispose Method (IReportComponentContainer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IReportComponentContainer Interface : Dispose Method
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Dispose()
void Dispose()
See Also

Reference

IReportComponentContainer Interface
IReportComponentContainer Members


Site Property (IReportComponentContainer)

Site Property (IReportComponentContainer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IReportComponentContainer Interface : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Property Site As System.ComponentModel.ISite
System.ComponentModel.ISite Site {get; set;}
See Also

Reference

IReportComponentContainer Interface
IReportComponentContainer Members


Dispose Method (IReportComponent)

Dispose Method (IReportComponent)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IReportComponent Interface : Dispose Method
Syntax
  • Visual Basic
  • C#
'Declaration

Sub Dispose()
void Dispose()
See Also

Reference

IReportComponent Interface
IReportComponent Members


Site Property (IReportComponent)

Site Property (IReportComponent)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > IReportComponent Interface : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Property Site As System.ComponentModel.ISite
System.ComponentModel.ISite Site {get; set;}
See Also

Reference

IReportComponent Interface
IReportComponent Members


Capacity Property (LayerCollection)

Capacity Property (LayerCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : Capacity Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

LayerCollection Class
LayerCollection Members


Clear Method (LayerCollection)

Clear Method (LayerCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : Clear Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

LayerCollection Class
LayerCollection Members


Count Property (LayerCollection)

Count Property (LayerCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : Count Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

LayerCollection Class
LayerCollection Members


RemoveAt Method (LayerCollection)

RemoveAt Method (LayerCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > LayerCollection Class : RemoveAt Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
See Also

Reference

LayerCollection Class
LayerCollection Members


Layer Constructor

Layer Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Layer Class : Layer Constructor
Overload List
Overload | Description
Layer Constructor | Initializes a new layer.
See Also

Reference

Layer Class
Layer Members


Line Class Events

Line Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Line Class

For a list of all members of this type, see Line members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Line Class
GrapeCity.ActiveReports.PageReportModel Namespace


Line Class Methods

Line Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Line Class

For a list of all members of this type, see Line members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the ReportItem object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
See Also

Reference

Line Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Property (Line)

Container Property (Line)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Line Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

Line Class
Line Members


CreateObjRef Method (Line)

CreateObjRef Method (Line)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Line Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

Line Class
Line Members


Dispose Method (Line)

Dispose Method (Line)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Line Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

Line Class
Line Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Line Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Line Class
Line Members


Disposed Event (Line)

Disposed Event (Line)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Line Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Line Class
Line Members


GetLifetimeService Method (Line)

GetLifetimeService Method (Line)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Line Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

Line Class
Line Members


InitializeLifetimeService Method (Line)

InitializeLifetimeService Method (Line)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Line Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

Line Class
Line Members


Site Property (Line)

Site Property (Line)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Line Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

Line Class
Line Members


ToString Method (Line)

ToString Method (Line)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Line Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

Line Class
Line Members


List Class Events

List Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : List Class

For a list of all members of this type, see List members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

List Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Property (List)

Container Property (List)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

List Class
List Members


CreateObjRef Method (List)

CreateObjRef Method (List)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

List Class
List Members


Dispose Method (List)

Dispose Method (List)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

List Class
List Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

List Class
List Members


Disposed Event (List)

Disposed Event (List)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

List Class
List Members


GetLifetimeService Method (List)

GetLifetimeService Method (List)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

List Class
List Members


InitializeLifetimeService Method (List)

InitializeLifetimeService Method (List)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

List Class
List Members


Site Property (List)

Site Property (List)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

List Class
List Members


ToString Method (List)

ToString Method (List)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > List Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

List Class
List Members


Map Class Events

Map Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Map Class

For a list of all members of this type, see Map members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Map Class
GrapeCity.ActiveReports.PageReportModel Namespace


Map Class Methods

Map Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Map Class

For a list of all members of this type, see Map members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the ReportItem object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
See Also

Reference

Map Class
GrapeCity.ActiveReports.PageReportModel Namespace


MapDataBoundView Class Properties

MapDataBoundView Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MapDataBoundView Class

For a list of all members of this type, see MapDataBoundView members.

Public Properties
 | Name | Description
Public Property | Zoom | Gets or sets the viewport zoom level. Automatically calculated if omitted based on the MapView type. An expression should evaluate to a System.Double. (Inherited from GrapeCity.ActiveReports.PageReportModel.MapView)
Top
See Also

Reference

MapDataBoundView Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Property (Map)

Container Property (Map)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

Map Class
Map Members


CreateObjRef Method (Map)

CreateObjRef Method (Map)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

Map Class
Map Members


Dispose Method (Map)

Dispose Method (Map)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

Map Class
Map Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Map Class
Map Members


Disposed Event (Map)

Disposed Event (Map)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Map Class
Map Members


GetLifetimeService Method (Map)

GetLifetimeService Method (Map)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

Map Class
Map Members


InitializeLifetimeService Method (Map)

InitializeLifetimeService Method (Map)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

Map Class
Map Members


Site Property (Map)

Site Property (Map)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

Map Class
Map Members


ToString Method (Map)

ToString Method (Map)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Map Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

Map Class
Map Members


MasterReportNotFoundException Class Methods

MasterReportNotFoundException Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MasterReportNotFoundException Class

For a list of all members of this type, see MasterReportNotFoundException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)
Top
See Also

Reference

MasterReportNotFoundException Class
GrapeCity.ActiveReports.PageReportModel Namespace


MasterReportNotFoundException Class Properties

MasterReportNotFoundException Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MasterReportNotFoundException Class

For a list of all members of this type, see MasterReportNotFoundException members.

Public Properties
 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Error code for future detail processing. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | ErrorData | Error data, depends on error code. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)
Top
See Also

Reference

MasterReportNotFoundException Class
GrapeCity.ActiveReports.PageReportModel Namespace


MasterReportNotFoundException Constructor

MasterReportNotFoundException Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterReportNotFoundException Class : MasterReportNotFoundException Constructor
Overload List
Overload | Description
MasterReportNotFoundException Constructor | Initializes a new instance of the MasterReportNotFoundException class.
See Also

Reference

MasterReportNotFoundException Class
MasterReportNotFoundException Members


Data Property (MasterReportNotFoundException)

Data Property (MasterReportNotFoundException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterReportNotFoundException Class : Data Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Data As System.Collections.IDictionary
public virtual System.Collections.IDictionary Data {get;}
See Also

Reference

MasterReportNotFoundException Class
MasterReportNotFoundException Members


GetBaseException Method (MasterReportNotFoundException)

GetBaseException Method (MasterReportNotFoundException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterReportNotFoundException Class : GetBaseException Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetBaseException() As System.Exception
public virtual System.Exception GetBaseException()
See Also

Reference

MasterReportNotFoundException Class
MasterReportNotFoundException Members


GetObjectData Method (MasterReportNotFoundException)

GetObjectData Method (MasterReportNotFoundException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterReportNotFoundException Class : GetObjectData Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
See Also

Reference

MasterReportNotFoundException Class
MasterReportNotFoundException Members


GetType Method (MasterReportNotFoundException)

GetType Method (MasterReportNotFoundException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterReportNotFoundException Class : GetType Method
Overload List
Overload | Description
GetType | (Inherited from System.Exception)
See Also

Reference

MasterReportNotFoundException Class
MasterReportNotFoundException Members


GetType() Method

GetType() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterReportNotFoundException Class : GetType() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetType() As System.Type
public System.Type GetType()
See Also

Reference

MasterReportNotFoundException Class
MasterReportNotFoundException Members


HelpLink Property (MasterReportNotFoundException)

HelpLink Property (MasterReportNotFoundException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterReportNotFoundException Class : HelpLink Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property HelpLink As System.String
public virtual System.string HelpLink {get; set;}
See Also

Reference

MasterReportNotFoundException Class
MasterReportNotFoundException Members


HResult Property (MasterReportNotFoundException)

HResult Property (MasterReportNotFoundException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterReportNotFoundException Class : HResult Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HResult As System.Integer
public System.int HResult {get;}
See Also

Reference

MasterReportNotFoundException Class
MasterReportNotFoundException Members


InnerException Property (MasterReportNotFoundException)

InnerException Property (MasterReportNotFoundException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterReportNotFoundException Class : InnerException Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InnerException As System.Exception
public System.Exception InnerException {get;}
See Also

Reference

MasterReportNotFoundException Class
MasterReportNotFoundException Members


Message Property (MasterReportNotFoundException)

Message Property (MasterReportNotFoundException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterReportNotFoundException Class : Message Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Message As System.String
public virtual System.string Message {get;}
See Also

Reference

MasterReportNotFoundException Class
MasterReportNotFoundException Members


Source Property (MasterReportNotFoundException)

Source Property (MasterReportNotFoundException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterReportNotFoundException Class : Source Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Source As System.String
public virtual System.string Source {get; set;}
See Also

Reference

MasterReportNotFoundException Class
MasterReportNotFoundException Members


StackTrace Property (MasterReportNotFoundException)

StackTrace Property (MasterReportNotFoundException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterReportNotFoundException Class : StackTrace Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property StackTrace As System.String
public virtual System.string StackTrace {get;}
See Also

Reference

MasterReportNotFoundException Class
MasterReportNotFoundException Members


TargetSite Property (MasterReportNotFoundException)

TargetSite Property (MasterReportNotFoundException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterReportNotFoundException Class : TargetSite Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
public System.Reflection.MethodBase TargetSite {get;}
See Also

Reference

MasterReportNotFoundException Class
MasterReportNotFoundException Members


ToString Method (MasterReportNotFoundException)

ToString Method (MasterReportNotFoundException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MasterReportNotFoundException Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

MasterReportNotFoundException Class
MasterReportNotFoundException Members


Matrix Class Events

Matrix Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Matrix Class

For a list of all members of this type, see Matrix members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Matrix Class
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixCell Class Events

MatrixCell Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixCell Class

For a list of all members of this type, see MatrixCell members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

MatrixCell Class
GrapeCity.ActiveReports.PageReportModel Namespace


MatrixCell Class Properties

MatrixCell Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixCell Class

For a list of all members of this type, see MatrixCell members.

Public Properties
 | Name | Description
Public Property | Components | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportComponentCollection containing all the ReportComponents in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportItems | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportItemCollection containing all the ReportItems in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

MatrixCell Class
GrapeCity.ActiveReports.PageReportModel Namespace


Capacity Property (MatrixCellCollection)

Capacity Property (MatrixCellCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixCellCollection Class : Capacity Property
Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

MatrixCellCollection Class
MatrixCellCollection Members


Clear Method (MatrixCellCollection)

Clear Method (MatrixCellCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixCellCollection Class : Clear Method
Removes all objects from the DataGroupingCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

MatrixCellCollection Class
MatrixCellCollection Members


Count Property (MatrixCellCollection)

Count Property (MatrixCellCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixCellCollection Class : Count Property
Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.`
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

MatrixCellCollection Class
MatrixCellCollection Members


RemoveAt Method (MatrixCellCollection)

RemoveAt Method (MatrixCellCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixCellCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the DataCellCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

MatrixCellCollection Class
MatrixCellCollection Members


Container Property (MatrixCell)

Container Property (MatrixCell)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixCell Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

MatrixCell Class
MatrixCell Members


CreateObjRef Method (MatrixCell)

CreateObjRef Method (MatrixCell)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixCell Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

MatrixCell Class
MatrixCell Members


Dispose Method (MatrixCell)

Dispose Method (MatrixCell)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixCell Class : Dispose Method
Disposes the class
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

MatrixCell Class
MatrixCell Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixCell Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

MatrixCell Class
MatrixCell Members


Disposed Event (MatrixCell)

Disposed Event (MatrixCell)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixCell Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

MatrixCell Class
MatrixCell Members


GetLifetimeService Method (MatrixCell)

GetLifetimeService Method (MatrixCell)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixCell Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

MatrixCell Class
MatrixCell Members


InitializeLifetimeService Method (MatrixCell)

InitializeLifetimeService Method (MatrixCell)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixCell Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

MatrixCell Class
MatrixCell Members


Site Property (MatrixCell)

Site Property (MatrixCell)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixCell Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

MatrixCell Class
MatrixCell Members


ToString Method (MatrixCell)

ToString Method (MatrixCell)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixCell Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

MatrixCell Class
MatrixCell Members


MatrixColumnCollection Class Properties

MatrixColumnCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixColumnCollection Class

For a list of all members of this type, see MatrixColumnCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.` (Inherited from System.Collections.ObjectModel.Collection<MatrixColumn>)
Public Property | Item | Gets or sets a specific MatrixColumn object in the MatrixColumnCollection by position. (Inherited from System.Collections.ObjectModel.Collection<MatrixColumn>)
Top
See Also

Reference

MatrixColumnCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (MatrixColumnCollection)

Add Method (MatrixColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixColumnCollection Class : Add Method
Adds a MatrixColumn object to the MatrixColumnCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Add( _
   ByVal item As MatrixColumn _
)
public void Add(
   MatrixColumn item
)

Parameters

item

Return Value

A new MatrixColumn object.
See Also

Reference

MatrixColumnCollection Class
MatrixColumnCollection Members


Clear Method (MatrixColumnCollection)

Clear Method (MatrixColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixColumnCollection Class : Clear Method
Removes all objects from the DataGroupingCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

MatrixColumnCollection Class
MatrixColumnCollection Members


Contains Method (MatrixColumnCollection)

Contains Method (MatrixColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixColumnCollection Class : Contains Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal item As MatrixColumn _
) As System.Boolean
public System.bool Contains(
   MatrixColumn item
)

Parameters

item
See Also

Reference

MatrixColumnCollection Class
MatrixColumnCollection Members


CopyTo Method (MatrixColumnCollection)

CopyTo Method (MatrixColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixColumnCollection Class : CopyTo Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal array() As MatrixColumn, _
   ByVal index As System.Integer _
)
public void CopyTo(
   MatrixColumn[] array,
   System.int index
)

Parameters

array
index
See Also

Reference

MatrixColumnCollection Class
MatrixColumnCollection Members


Count Property (MatrixColumnCollection)

Count Property (MatrixColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixColumnCollection Class : Count Property
Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.`
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

MatrixColumnCollection Class
MatrixColumnCollection Members


IndexOf Method (MatrixColumnCollection)

IndexOf Method (MatrixColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixColumnCollection Class : IndexOf Method
Determines the index of a specific MatrixColumn object in the MatrixColumnCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal item As MatrixColumn _
) As System.Integer
public System.int IndexOf(
   MatrixColumn item
)

Parameters

item
See Also

Reference

MatrixColumnCollection Class
MatrixColumnCollection Members


Insert Method (MatrixColumnCollection)

Insert Method (MatrixColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixColumnCollection Class : Insert Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As MatrixColumn _
)
public void Insert(
   System.int index,
   MatrixColumn item
)

Parameters

index
item
See Also

Reference

MatrixColumnCollection Class
MatrixColumnCollection Members


Item Property (MatrixColumnCollection)

Item Property (MatrixColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixColumnCollection Class : Item Property
Gets or sets a specific MatrixColumn object in the MatrixColumnCollection by position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As MatrixColumn
public MatrixColumn this[
   System.int index
]; {get; set;}

Parameters

index
See Also

Reference

MatrixColumnCollection Class
MatrixColumnCollection Members


Remove Method (MatrixColumnCollection)

Remove Method (MatrixColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixColumnCollection Class : Remove Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Remove( _
   ByVal item As MatrixColumn _
) As System.Boolean
public System.bool Remove(
   MatrixColumn item
)

Parameters

item
See Also

Reference

MatrixColumnCollection Class
MatrixColumnCollection Members


RemoveAt Method (MatrixColumnCollection)

RemoveAt Method (MatrixColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixColumnCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the DataCellCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

MatrixColumnCollection Class
MatrixColumnCollection Members


MatrixRow Class Events

MatrixRow Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : MatrixRow Class

For a list of all members of this type, see MatrixRow members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

MatrixRow Class
GrapeCity.ActiveReports.PageReportModel Namespace


Capacity Property (MatrixRowCollection)

Capacity Property (MatrixRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRowCollection Class : Capacity Property
Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

MatrixRowCollection Class
MatrixRowCollection Members


Clear Method (MatrixRowCollection)

Clear Method (MatrixRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRowCollection Class : Clear Method
Removes all objects from the DataGroupingCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

MatrixRowCollection Class
MatrixRowCollection Members


Count Property (MatrixRowCollection)

Count Property (MatrixRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRowCollection Class : Count Property
Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

MatrixRowCollection Class
MatrixRowCollection Members


RemoveAt Method (MatrixRowCollection)

RemoveAt Method (MatrixRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRowCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the DataCellCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

MatrixRowCollection Class
MatrixRowCollection Members


Container Property (MatrixRow)

Container Property (MatrixRow)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRow Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

MatrixRow Class
MatrixRow Members


CreateObjRef Method (MatrixRow)

CreateObjRef Method (MatrixRow)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRow Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

MatrixRow Class
MatrixRow Members


Dispose Method (MatrixRow)

Dispose Method (MatrixRow)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRow Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

MatrixRow Class
MatrixRow Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRow Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

MatrixRow Class
MatrixRow Members


Disposed Event (MatrixRow)

Disposed Event (MatrixRow)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRow Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

MatrixRow Class
MatrixRow Members


GetLifetimeService Method (MatrixRow)

GetLifetimeService Method (MatrixRow)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRow Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

MatrixRow Class
MatrixRow Members


InitializeLifetimeService Method (MatrixRow)

InitializeLifetimeService Method (MatrixRow)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRow Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

MatrixRow Class
MatrixRow Members


Site Property (MatrixRow)

Site Property (MatrixRow)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRow Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

MatrixRow Class
MatrixRow Members


ToString Method (MatrixRow)

ToString Method (MatrixRow)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > MatrixRow Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

MatrixRow Class
MatrixRow Members


Container Property (Matrix)

Container Property (Matrix)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

Matrix Class
Matrix Members


CreateObjRef Method (Matrix)

CreateObjRef Method (Matrix)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

Matrix Class
Matrix Members


Dispose Method (Matrix)

Dispose Method (Matrix)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

Matrix Class
Matrix Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Matrix Class
Matrix Members


Disposed Event (Matrix)

Disposed Event (Matrix)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Matrix Class
Matrix Members


GetLifetimeService Method (Matrix)

GetLifetimeService Method (Matrix)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

Matrix Class
Matrix Members


InitializeLifetimeService Method (Matrix)

InitializeLifetimeService Method (Matrix)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

Matrix Class
Matrix Members


Site Property (Matrix)

Site Property (Matrix)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

Matrix Class
Matrix Members


ToString Method (Matrix)

ToString Method (Matrix)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Matrix Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

Matrix Class
Matrix Members


OverflowPlaceHolder Class Events

OverflowPlaceHolder Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : OverflowPlaceHolder Class

For a list of all members of this type, see OverflowPlaceHolder members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

OverflowPlaceHolder Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Property (OverflowPlaceHolder)

Container Property (OverflowPlaceHolder)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > OverflowPlaceHolder Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

OverflowPlaceHolder Class
OverflowPlaceHolder Members


CreateObjRef Method (OverflowPlaceHolder)

CreateObjRef Method (OverflowPlaceHolder)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > OverflowPlaceHolder Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

OverflowPlaceHolder Class
OverflowPlaceHolder Members


Dispose Method (OverflowPlaceHolder)

Dispose Method (OverflowPlaceHolder)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > OverflowPlaceHolder Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

OverflowPlaceHolder Class
OverflowPlaceHolder Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > OverflowPlaceHolder Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

OverflowPlaceHolder Class
OverflowPlaceHolder Members


Disposed Event (OverflowPlaceHolder)

Disposed Event (OverflowPlaceHolder)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > OverflowPlaceHolder Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

OverflowPlaceHolder Class
OverflowPlaceHolder Members


GetLifetimeService Method (OverflowPlaceHolder)

GetLifetimeService Method (OverflowPlaceHolder)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > OverflowPlaceHolder Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

OverflowPlaceHolder Class
OverflowPlaceHolder Members


InitializeLifetimeService Method (OverflowPlaceHolder)

InitializeLifetimeService Method (OverflowPlaceHolder)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > OverflowPlaceHolder Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

OverflowPlaceHolder Class
OverflowPlaceHolder Members


Site Property (OverflowPlaceHolder)

Site Property (OverflowPlaceHolder)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > OverflowPlaceHolder Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

OverflowPlaceHolder Class
OverflowPlaceHolder Members


ToString Method (OverflowPlaceHolder)

ToString Method (OverflowPlaceHolder)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > OverflowPlaceHolder Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

OverflowPlaceHolder Class
OverflowPlaceHolder Members


Page Class Events

Page Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Page Class

For a list of all members of this type, see Page members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Page Class
GrapeCity.ActiveReports.PageReportModel Namespace


Page Class Methods

Page Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Page Class

For a list of all members of this type, see Page members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Page Class
GrapeCity.ActiveReports.PageReportModel Namespace


PageHeaderFooter Class Events

PageHeaderFooter Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : PageHeaderFooter Class

For a list of all members of this type, see PageHeaderFooter members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

PageHeaderFooter Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Property (PageHeaderFooter)

Container Property (PageHeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageHeaderFooter Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

PageHeaderFooter Class
PageHeaderFooter Members


CreateObjRef Method (PageHeaderFooter)

CreateObjRef Method (PageHeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageHeaderFooter Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

PageHeaderFooter Class
PageHeaderFooter Members


Dispose Method (PageHeaderFooter)

Dispose Method (PageHeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageHeaderFooter Class : Dispose Method
Disposes the class
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

PageHeaderFooter Class
PageHeaderFooter Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageHeaderFooter Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

PageHeaderFooter Class
PageHeaderFooter Members


Disposed Event (PageHeaderFooter)

Disposed Event (PageHeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageHeaderFooter Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

PageHeaderFooter Class
PageHeaderFooter Members


GetLifetimeService Method (PageHeaderFooter)

GetLifetimeService Method (PageHeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageHeaderFooter Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

PageHeaderFooter Class
PageHeaderFooter Members


InitializeLifetimeService Method (PageHeaderFooter)

InitializeLifetimeService Method (PageHeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageHeaderFooter Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

PageHeaderFooter Class
PageHeaderFooter Members


Site Property (PageHeaderFooter)

Site Property (PageHeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageHeaderFooter Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

PageHeaderFooter Class
PageHeaderFooter Members


ToString Method (PageHeaderFooter)

ToString Method (PageHeaderFooter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PageHeaderFooter Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

PageHeaderFooter Class
PageHeaderFooter Members


Container Property (Page)

Container Property (Page)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

Page Class
Page Members


CreateObjRef Method (Page)

CreateObjRef Method (Page)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

Page Class
Page Members


Dispose Method (Page)

Dispose Method (Page)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : Dispose Method
Disposes the class
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

Page Class
Page Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Page Class
Page Members


Disposed Event (Page)

Disposed Event (Page)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Page Class
Page Members


GetLifetimeService Method (Page)

GetLifetimeService Method (Page)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

Page Class
Page Members


InitializeLifetimeService Method (Page)

InitializeLifetimeService Method (Page)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

Page Class
Page Members


ToString Method (Page)

ToString Method (Page)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Page Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

Page Class
Page Members


Capacity Property (ParameterCollection)

Capacity Property (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterCollection Class : Capacity Property
Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

ParameterCollection Class
ParameterCollection Members


Clear Method (ParameterCollection)

Clear Method (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterCollection Class : Clear Method
Removes all objects from the DataGroupingCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

ParameterCollection Class
ParameterCollection Members


Count Property (ParameterCollection)

Count Property (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterCollection Class : Count Property
Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.`
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

ParameterCollection Class
ParameterCollection Members


RemoveAt Method (ParameterCollection)

RemoveAt Method (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the DataCellCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

ParameterCollection Class
ParameterCollection Members


Capacity Property (ParameterValueCollection)

Capacity Property (ParameterValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterValueCollection Class : Capacity Property
Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


Clear Method (ParameterValueCollection)

Clear Method (ParameterValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterValueCollection Class : Clear Method
Removes all objects from the DataGroupingCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


Count Property (ParameterValueCollection)

Count Property (ParameterValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterValueCollection Class : Count Property
Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


RemoveAt Method (ParameterValueCollection)

RemoveAt Method (ParameterValueCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ParameterValueCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the DataCellCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

ParameterValueCollection Class
ParameterValueCollection Members


Capacity Property (PropertyCollection)

Capacity Property (PropertyCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PropertyCollection Class : Capacity Property
Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

PropertyCollection Class
PropertyCollection Members


Clear Method (PropertyCollection)

Clear Method (PropertyCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PropertyCollection Class : Clear Method
Removes all objects from the DataGroupingCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

PropertyCollection Class
PropertyCollection Members


Count Property (PropertyCollection)

Count Property (PropertyCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PropertyCollection Class : Count Property
Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

PropertyCollection Class
PropertyCollection Members


RemoveAt Method (PropertyCollection)

RemoveAt Method (PropertyCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > PropertyCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the DataCellCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

PropertyCollection Class
PropertyCollection Members


Capacity Property (QueryParameterCollection)

Capacity Property (QueryParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > QueryParameterCollection Class : Capacity Property
Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

QueryParameterCollection Class
QueryParameterCollection Members


Clear Method (QueryParameterCollection)

Clear Method (QueryParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > QueryParameterCollection Class : Clear Method
Removes all objects from the DataGroupingCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

QueryParameterCollection Class
QueryParameterCollection Members


Count Property (QueryParameterCollection)

Count Property (QueryParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > QueryParameterCollection Class : Count Property
Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

QueryParameterCollection Class
QueryParameterCollection Members


RemoveAt Method (QueryParameterCollection)

RemoveAt Method (QueryParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > QueryParameterCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the DataCellCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

QueryParameterCollection Class
QueryParameterCollection Members


Report Class Events

Report Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Report Class

For a list of all members of this type, see Report members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Report Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportComponent Class Events

ReportComponent Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponent Class

For a list of all members of this type, see ReportComponent members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

ReportComponent Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportComponent Class Methods

ReportComponent Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponent Class

For a list of all members of this type, see ReportComponent members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

ReportComponent Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportComponentContainer Class Events

ReportComponentContainer Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponentContainer Class

For a list of all members of this type, see ReportComponentContainer members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

ReportComponentContainer Class
GrapeCity.ActiveReports.PageReportModel Namespace


ReportComponentContainer Class Methods

ReportComponentContainer Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportComponentContainer Class

For a list of all members of this type, see ReportComponentContainer members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

ReportComponentContainer Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Property (ReportComponentContainer)

Container Property (ReportComponentContainer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponentContainer Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

ReportComponentContainer Class
ReportComponentContainer Members


CreateObjRef Method (ReportComponentContainer)

CreateObjRef Method (ReportComponentContainer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponentContainer Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

ReportComponentContainer Class
ReportComponentContainer Members


Dispose Method (ReportComponentContainer)

Dispose Method (ReportComponentContainer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponentContainer Class : Dispose Method
Disposes the class
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

ReportComponentContainer Class
ReportComponentContainer Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponentContainer Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

ReportComponentContainer Class
ReportComponentContainer Members


Disposed Event (ReportComponentContainer)

Disposed Event (ReportComponentContainer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponentContainer Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

ReportComponentContainer Class
ReportComponentContainer Members


GetLifetimeService Method (ReportComponentContainer)

GetLifetimeService Method (ReportComponentContainer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponentContainer Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

ReportComponentContainer Class
ReportComponentContainer Members


InitializeLifetimeService Method (ReportComponentContainer)

InitializeLifetimeService Method (ReportComponentContainer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponentContainer Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
public virtual System.object InitializeLifetimeService()
See Also

Reference

ReportComponentContainer Class
ReportComponentContainer Members


Site Property (ReportComponentContainer)

Site Property (ReportComponentContainer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponentContainer Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
public virtual System.ComponentModel.ISite Site {get; set;}
See Also

Reference

ReportComponentContainer Class
ReportComponentContainer Members


ToString Method (ReportComponentContainer)

ToString Method (ReportComponentContainer)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponentContainer Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

ReportComponentContainer Class
ReportComponentContainer Members


Container Property (ReportComponent)

Container Property (ReportComponent)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponent Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

ReportComponent Class
ReportComponent Members


CreateObjRef Method (ReportComponent)

CreateObjRef Method (ReportComponent)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponent Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

ReportComponent Class
ReportComponent Members


Dispose Method (ReportComponent)

Dispose Method (ReportComponent)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponent Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

ReportComponent Class
ReportComponent Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponent Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

ReportComponent Class
ReportComponent Members


Disposed Event (ReportComponent)

Disposed Event (ReportComponent)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponent Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

ReportComponent Class
ReportComponent Members


GetLifetimeService Method (ReportComponent)

GetLifetimeService Method (ReportComponent)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponent Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

ReportComponent Class
ReportComponent Members


InitializeLifetimeService Method (ReportComponent)

InitializeLifetimeService Method (ReportComponent)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponent Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
public virtual System.object InitializeLifetimeService()
See Also

Reference

ReportComponent Class
ReportComponent Members


Site Property (ReportComponent)

Site Property (ReportComponent)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponent Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
public virtual System.ComponentModel.ISite Site {get; set;}
See Also

Reference

ReportComponent Class
ReportComponent Members


ToString Method (ReportComponent)

ToString Method (ReportComponent)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportComponent Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

ReportComponent Class
ReportComponent Members


ReportItem Class Events

ReportItem Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : ReportItem Class

For a list of all members of this type, see ReportItem members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

ReportItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Property (ReportItem)

Container Property (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

ReportItem Class
ReportItem Members


CreateObjRef Method (ReportItem)

CreateObjRef Method (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

ReportItem Class
ReportItem Members


Dispose Method (ReportItem)

Dispose Method (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

ReportItem Class
ReportItem Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

ReportItem Class
ReportItem Members


Disposed Event (ReportItem)

Disposed Event (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

ReportItem Class
ReportItem Members


GetLifetimeService Method (ReportItem)

GetLifetimeService Method (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

ReportItem Class
ReportItem Members


InitializeLifetimeService Method (ReportItem)

InitializeLifetimeService Method (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
public virtual System.object InitializeLifetimeService()
See Also

Reference

ReportItem Class
ReportItem Members


Site Property (ReportItem)

Site Property (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
public virtual System.ComponentModel.ISite Site {get; set;}
See Also

Reference

ReportItem Class
ReportItem Members


ToString Method (ReportItem)

ToString Method (ReportItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportItem Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

ReportItem Class
ReportItem Members


Capacity Property (ReportParameterCollection)

Capacity Property (ReportParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameterCollection Class : Capacity Property
Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

ReportParameterCollection Class
ReportParameterCollection Members


Clear Method (ReportParameterCollection)

Clear Method (ReportParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameterCollection Class : Clear Method
Removes all objects from the DataGroupingCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

ReportParameterCollection Class
ReportParameterCollection Members


Count Property (ReportParameterCollection)

Count Property (ReportParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameterCollection Class : Count Property
Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

ReportParameterCollection Class
ReportParameterCollection Members


RemoveAt Method (ReportParameterCollection)

RemoveAt Method (ReportParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > ReportParameterCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the DataCellCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

ReportParameterCollection Class
ReportParameterCollection Members


Container Property (Report)

Container Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

Report Class
Report Members


CreateObjRef Method (Report)

CreateObjRef Method (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

Report Class
Report Members


Dispose Method (Report)

Dispose Method (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

Report Class
Report Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Report Class
Report Members


Disposed Event (Report)

Disposed Event (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Report Class
Report Members


GetLifetimeService Method (Report)

GetLifetimeService Method (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

Report Class
Report Members


InitializeLifetimeService Method (Report)

InitializeLifetimeService Method (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

Report Class
Report Members


Site Property (Report)

Site Property (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

Report Class
Report Members


ToString Method (Report)

ToString Method (Report)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Report Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

Report Class
Report Members


RowGrouping Class Events

RowGrouping Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : RowGrouping Class

For a list of all members of this type, see RowGrouping members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

RowGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


Capacity Property (RowGroupingCollection)

Capacity Property (RowGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGroupingCollection Class : Capacity Property
Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

RowGroupingCollection Class
RowGroupingCollection Members


Clear Method (RowGroupingCollection)

Clear Method (RowGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGroupingCollection Class : Clear Method
Removes all objects from the DataGroupingCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

RowGroupingCollection Class
RowGroupingCollection Members


Count Property (RowGroupingCollection)

Count Property (RowGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGroupingCollection Class : Count Property
Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

RowGroupingCollection Class
RowGroupingCollection Members


RemoveAt Method (RowGroupingCollection)

RemoveAt Method (RowGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGroupingCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the DataCellCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

RowGroupingCollection Class
RowGroupingCollection Members


Container Property (RowGrouping)

Container Property (RowGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGrouping Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

RowGrouping Class
RowGrouping Members


CreateObjRef Method (RowGrouping)

CreateObjRef Method (RowGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGrouping Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

RowGrouping Class
RowGrouping Members


Dispose Method (RowGrouping)

Dispose Method (RowGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGrouping Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

RowGrouping Class
RowGrouping Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGrouping Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

RowGrouping Class
RowGrouping Members


Disposed Event (RowGrouping)

Disposed Event (RowGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGrouping Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

RowGrouping Class
RowGrouping Members


GetLifetimeService Method (RowGrouping)

GetLifetimeService Method (RowGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGrouping Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

RowGrouping Class
RowGrouping Members


InitializeLifetimeService Method (RowGrouping)

InitializeLifetimeService Method (RowGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGrouping Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

RowGrouping Class
RowGrouping Members


Site Property (RowGrouping)

Site Property (RowGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGrouping Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

RowGrouping Class
RowGrouping Members


ToString Method (RowGrouping)

ToString Method (RowGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > RowGrouping Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

RowGrouping Class
RowGrouping Members


SeriesGrouping Class Events

SeriesGrouping Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SeriesGrouping Class

For a list of all members of this type, see SeriesGrouping members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

SeriesGrouping Class
GrapeCity.ActiveReports.PageReportModel Namespace


Capacity Property (SeriesGroupingCollection)

Capacity Property (SeriesGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGroupingCollection Class : Capacity Property
Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

SeriesGroupingCollection Class
SeriesGroupingCollection Members


Clear Method (SeriesGroupingCollection)

Clear Method (SeriesGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGroupingCollection Class : Clear Method
Removes all objects from the DataGroupingCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

SeriesGroupingCollection Class
SeriesGroupingCollection Members


Count Property (SeriesGroupingCollection)

Count Property (SeriesGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGroupingCollection Class : Count Property
Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

SeriesGroupingCollection Class
SeriesGroupingCollection Members


RemoveAt Method (SeriesGroupingCollection)

RemoveAt Method (SeriesGroupingCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGroupingCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the DataCellCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

SeriesGroupingCollection Class
SeriesGroupingCollection Members


Container Property (SeriesGrouping)

Container Property (SeriesGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGrouping Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

SeriesGrouping Class
SeriesGrouping Members


CreateObjRef Method (SeriesGrouping)

CreateObjRef Method (SeriesGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGrouping Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

SeriesGrouping Class
SeriesGrouping Members


Dispose Method (SeriesGrouping)

Dispose Method (SeriesGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGrouping Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

SeriesGrouping Class
SeriesGrouping Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGrouping Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

SeriesGrouping Class
SeriesGrouping Members


Disposed Event (SeriesGrouping)

Disposed Event (SeriesGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGrouping Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

SeriesGrouping Class
SeriesGrouping Members


GetLifetimeService Method (SeriesGrouping)

GetLifetimeService Method (SeriesGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGrouping Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

SeriesGrouping Class
SeriesGrouping Members


InitializeLifetimeService Method (SeriesGrouping)

InitializeLifetimeService Method (SeriesGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGrouping Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

SeriesGrouping Class
SeriesGrouping Members


Site Property (SeriesGrouping)

Site Property (SeriesGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGrouping Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

SeriesGrouping Class
SeriesGrouping Members


ToString Method (SeriesGrouping)

ToString Method (SeriesGrouping)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SeriesGrouping Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

SeriesGrouping Class
SeriesGrouping Members


Shape Class Events

Shape Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Shape Class

For a list of all members of this type, see Shape members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Shape Class
GrapeCity.ActiveReports.PageReportModel Namespace


Shape Class Methods

Shape Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Shape Class

For a list of all members of this type, see Shape members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the ReportItem object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
See Also

Reference

Shape Class
GrapeCity.ActiveReports.PageReportModel Namespace


Shape Class Properties

Shape Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Shape Class

For a list of all members of this type, see Shape members.

Public Properties
 | Name | Description
Public Property | Action | Gets or sets an action (e.g. hyperlink) to perform when the report item is clicked. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Bookmark | Gets or sets a bookmark that can be linked via a Bookmark action. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Custom | Gets or sets custom information to be passed to a report output component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementName | Gets or sets the name to use for the data element or attribute for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | DataElementOutput | Gets or sets a value indicating whether the item appears in a data rendering. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Height | Gets or sets the height of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | KeepTogether | Gets or sets a value indicating whether a data region is kept together on a single page where possible. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Label | Gets or sets a label to identify an instance of a report item within the client UI (to provide a user-friendly label for searching or to appear in the Document Map). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LayerName | The name of layer to which this report item belongs. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Left | Gets or sets the distance of the item from the left edge of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | LinkToChild | Gets or sets the name of the report item contained directly within the report item that is the target location for the Document Map label (if any). (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Name | Gets or sets the name of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Public Property | Style | Gets or sets the the style settings for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ToolTip | Gets or sets a textual label for the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Top | Gets or sets the distance of the item from the top of the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Visibility | Gets or sets a value indicating whether the items are hidden. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | Width | Gets or sets the width of the report item. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Public Property | ZIndex | Gets or sets the drawing order of the report item within the containing object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
See Also

Reference

Shape Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Property (Shape)

Container Property (Shape)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Shape Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

Shape Class
Shape Members


CreateObjRef Method (Shape)

CreateObjRef Method (Shape)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Shape Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

Shape Class
Shape Members


Dispose Method (Shape)

Dispose Method (Shape)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Shape Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

Shape Class
Shape Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Shape Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Shape Class
Shape Members


Disposed Event (Shape)

Disposed Event (Shape)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Shape Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Shape Class
Shape Members


GetLifetimeService Method (Shape)

GetLifetimeService Method (Shape)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Shape Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

Shape Class
Shape Members


InitializeLifetimeService Method (Shape)

InitializeLifetimeService Method (Shape)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Shape Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

Shape Class
Shape Members


Site Property (Shape)

Site Property (Shape)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Shape Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

Shape Class
Shape Members


ToString Method (Shape)

ToString Method (Shape)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Shape Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

Shape Class
Shape Members


SortByCollection Class Properties

SortByCollection Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : SortByCollection Class

For a list of all members of this type, see SortByCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden. (Inherited from System.Collections.ObjectModel.Collection<SortBy>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<SortBy>)
Top
See Also

Reference

SortByCollection Class
GrapeCity.ActiveReports.PageReportModel Namespace


Add Method (SortByCollection)

Add Method (SortByCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortByCollection Class : Add Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Add( _
   ByVal item As SortBy _
)
public void Add(
   SortBy item
)

Parameters

item
See Also

Reference

SortByCollection Class
SortByCollection Members


Clear Method (SortByCollection)

Clear Method (SortByCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortByCollection Class : Clear Method
Removes all objects from the DataGroupingCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

SortByCollection Class
SortByCollection Members


Contains Method (SortByCollection)

Contains Method (SortByCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortByCollection Class : Contains Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal item As SortBy _
) As System.Boolean
public System.bool Contains(
   SortBy item
)

Parameters

item
See Also

Reference

SortByCollection Class
SortByCollection Members


CopyTo Method (SortByCollection)

CopyTo Method (SortByCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortByCollection Class : CopyTo Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal array() As SortBy, _
   ByVal index As System.Integer _
)
public void CopyTo(
   SortBy[] array,
   System.int index
)

Parameters

array
index
See Also

Reference

SortByCollection Class
SortByCollection Members


Count Property (SortByCollection)

Count Property (SortByCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortByCollection Class : Count Property
Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

SortByCollection Class
SortByCollection Members


IndexOf Method (SortByCollection)

IndexOf Method (SortByCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortByCollection Class : IndexOf Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal item As SortBy _
) As System.Integer
public System.int IndexOf(
   SortBy item
)

Parameters

item
See Also

Reference

SortByCollection Class
SortByCollection Members


Insert Method (SortByCollection)

Insert Method (SortByCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortByCollection Class : Insert Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As SortBy _
)
public void Insert(
   System.int index,
   SortBy item
)

Parameters

index
item
See Also

Reference

SortByCollection Class
SortByCollection Members


Item Property (SortByCollection)

Item Property (SortByCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortByCollection Class : Item Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As SortBy
public SortBy this[
   System.int index
]; {get; set;}

Parameters

index
See Also

Reference

SortByCollection Class
SortByCollection Members


Remove Method (SortByCollection)

Remove Method (SortByCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortByCollection Class : Remove Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Remove( _
   ByVal item As SortBy _
) As System.Boolean
public System.bool Remove(
   SortBy item
)

Parameters

item
See Also

Reference

SortByCollection Class
SortByCollection Members


RemoveAt Method (SortByCollection)

RemoveAt Method (SortByCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > SortByCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the DataCellCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

SortByCollection Class
SortByCollection Members


Capacity Property (StaticMemberCollection)

Capacity Property (StaticMemberCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticMemberCollection Class : Capacity Property
Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

StaticMemberCollection Class
StaticMemberCollection Members


Clear Method (StaticMemberCollection)

Clear Method (StaticMemberCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticMemberCollection Class : Clear Method
Removes all objects from the DataGroupingCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

StaticMemberCollection Class
StaticMemberCollection Members


Count Property (StaticMemberCollection)

Count Property (StaticMemberCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticMemberCollection Class : Count Property
Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

StaticMemberCollection Class
StaticMemberCollection Members


RemoveAt Method (StaticMemberCollection)

RemoveAt Method (StaticMemberCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticMemberCollection Class : RemoveAt Method
The zero-based index of the element to remove.

Removes the element at the specified index of the DataCellCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

StaticMemberCollection Class
StaticMemberCollection Members


StaticRowColumn Class Events

StaticRowColumn Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticRowColumn Class

For a list of all members of this type, see StaticRowColumn members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

StaticRowColumn Class
GrapeCity.ActiveReports.PageReportModel Namespace


StaticRowColumn Class Properties

StaticRowColumn Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : StaticRowColumn Class

For a list of all members of this type, see StaticRowColumn members.

Public Properties
 | Name | Description
Public Property | Components | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportComponentCollection containing all the ReportComponents in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | Parent | Gets or sets an IReportComponentContainer interface representing the parent hosting the component. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponent)
Public Property | ReportItems | Gets a GrapeCity.ActiveReports.ReportObjectModel.ReportItemCollection containing all the ReportItems in the container. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer)
Public Property | Site | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

StaticRowColumn Class
GrapeCity.ActiveReports.PageReportModel Namespace


Capacity Property (StaticRowColumnCollection)

Capacity Property (StaticRowColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticRowColumnCollection Class : Capacity Property
Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

StaticRowColumnCollection Class
StaticRowColumnCollection Members


Clear Method (StaticRowColumnCollection)

Clear Method (StaticRowColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticRowColumnCollection Class : Clear Method
Removes all objects from the DataGroupingCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

StaticRowColumnCollection Class
StaticRowColumnCollection Members


Count Property (StaticRowColumnCollection)

Count Property (StaticRowColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticRowColumnCollection Class : Count Property
Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

StaticRowColumnCollection Class
StaticRowColumnCollection Members


RemoveAt Method (StaticRowColumnCollection)

RemoveAt Method (StaticRowColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticRowColumnCollection Class : RemoveAt Method
The zero-based index of the element to remove.

Removes the element at the specified index of the DataCellCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

StaticRowColumnCollection Class
StaticRowColumnCollection Members


Container Property (StaticRowColumn)

Container Property (StaticRowColumn)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticRowColumn Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

StaticRowColumn Class
StaticRowColumn Members


CreateObjRef Method (StaticRowColumn)

CreateObjRef Method (StaticRowColumn)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticRowColumn Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

StaticRowColumn Class
StaticRowColumn Members


Dispose Method (StaticRowColumn)

Dispose Method (StaticRowColumn)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticRowColumn Class : Dispose Method
Disposes the class
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

StaticRowColumn Class
StaticRowColumn Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticRowColumn Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

StaticRowColumn Class
StaticRowColumn Members


Disposed Event (StaticRowColumn)

Disposed Event (StaticRowColumn)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticRowColumn Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

StaticRowColumn Class
StaticRowColumn Members


GetLifetimeService Method (StaticRowColumn)

GetLifetimeService Method (StaticRowColumn)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticRowColumn Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

StaticRowColumn Class
StaticRowColumn Members


InitializeLifetimeService Method (StaticRowColumn)

InitializeLifetimeService Method (StaticRowColumn)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticRowColumn Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

StaticRowColumn Class
StaticRowColumn Members


Site Property (StaticRowColumn)

Site Property (StaticRowColumn)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticRowColumn Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

StaticRowColumn Class
StaticRowColumn Members


ToString Method (StaticRowColumn)

ToString Method (StaticRowColumn)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StaticRowColumn Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

StaticRowColumn Class
StaticRowColumn Members


Add Method (StyleSheet)

Add Method (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : Add Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Add( _
   ByVal item As Style _
)
public void Add(
   Style item
)

Parameters

item
See Also

Reference

StyleSheet Class
StyleSheet Members


AddRange Method (StyleSheet)

AddRange Method (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : AddRange Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddRange( _
   ByVal collection As System.Collections.Generic.IEnumerable(Of Style) _
)
public void AddRange(
   System.Collections.Generic.IEnumerable<Style> collection
)

Parameters

collection
See Also

Reference

StyleSheet Class
StyleSheet Members


AsReadOnly Method

AsReadOnly Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : AsReadOnly Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function AsReadOnly() As System.Collections.ObjectModel.ReadOnlyCollection(Of Style)
public System.Collections.ObjectModel.ReadOnlyCollection<Style> AsReadOnly()
See Also

Reference

StyleSheet Class
StyleSheet Members


BinarySearch Method

BinarySearch Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : BinarySearch Method
Overload List
Overload | Description
BinarySearch(Int32,Int32,Style,IComparer<Style>) | (Inherited from System.Collections.Generic.List<Style>)
BinarySearch(Style) | (Inherited from System.Collections.Generic.List<Style>)
BinarySearch(Style,IComparer<Style>) | (Inherited from System.Collections.Generic.List<Style>)
See Also

Reference

StyleSheet Class
StyleSheet Members


BinarySearch(Int32,Int32,Style,IComparer<Style>) Method

BinarySearch(Int32,Int32,Style,IComparer<Style>) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > BinarySearch Method : BinarySearch(Int32,Int32,Style,IComparer<Style>) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function BinarySearch( _
   ByVal index As System.Integer, _
   ByVal count As System.Integer, _
   ByVal item As Style, _
   ByVal comparer As System.Collections.Generic.IComparer(Of Style) _
) As System.Integer
public System.int BinarySearch(
   System.int index,
   System.int count,
   Style item,
   System.Collections.Generic.IComparer<Style> comparer
)

Parameters

index
count
item
comparer
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


BinarySearch(Style) Method

BinarySearch(Style) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > BinarySearch Method : BinarySearch(Style) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function BinarySearch( _
   ByVal item As Style _
) As System.Integer
public System.int BinarySearch(
   Style item
)

Parameters

item
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


BinarySearch(Style,IComparer<Style>) Method

BinarySearch(Style,IComparer<Style>) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > BinarySearch Method : BinarySearch(Style,IComparer<Style>) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function BinarySearch( _
   ByVal item As Style, _
   ByVal comparer As System.Collections.Generic.IComparer(Of Style) _
) As System.Integer
public System.int BinarySearch(
   Style item,
   System.Collections.Generic.IComparer<Style> comparer
)

Parameters

item
comparer
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Capacity Property (StyleSheet)

Capacity Property (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : Capacity Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

StyleSheet Class
StyleSheet Members


Clear Method (StyleSheet)

Clear Method (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : Clear Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

StyleSheet Class
StyleSheet Members


Contains Method (StyleSheet)

Contains Method (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : Contains Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal item As Style _
) As System.Boolean
public System.bool Contains(
   Style item
)

Parameters

item
See Also

Reference

StyleSheet Class
StyleSheet Members


ConvertAll<TOutput> Method

ConvertAll<TOutput> Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : ConvertAll<TOutput> Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ConvertAll(Of TOutput)( _
   ByVal converter As Converter(Of Style,TOutput) _
) As System.Collections.Generic.List(Of TOutput)
public System.Collections.Generic.List<TOutput> ConvertAll<TOutput>(
   Converter<Style,TOutput> converter
)

Parameters

converter

Type Parameters

TOutput
See Also

Reference

StyleSheet Class
StyleSheet Members


CopyTo Method (StyleSheet)

CopyTo Method (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : CopyTo Method
Overload List
Overload | Description
CopyTo(Style[]) | (Inherited from System.Collections.Generic.List<Style>)
CopyTo(Int32,Style[],Int32,Int32) | (Inherited from System.Collections.Generic.List<Style>)
CopyTo(Style[],Int32) | (Inherited from System.Collections.Generic.List<Style>)
See Also

Reference

StyleSheet Class
StyleSheet Members


CopyTo(Int32,Style[],Int32,Int32) Method

CopyTo(Int32,Style[],Int32,Int32) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > CopyTo Method : CopyTo(Int32,Style[],Int32,Int32) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub CopyTo( _
   ByVal index As System.Integer, _
   ByVal array() As Style, _
   ByVal arrayIndex As System.Integer, _
   ByVal count As System.Integer _
)
public void CopyTo(
   System.int index,
   Style[] array,
   System.int arrayIndex,
   System.int count
)

Parameters

index
array
arrayIndex
count
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


CopyTo(Style[]) Method

CopyTo(Style[]) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > CopyTo Method : CopyTo(Style[]) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub CopyTo( _
   ByVal array() As Style _
)
public void CopyTo(
   Style[] array
)

Parameters

array
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


CopyTo(Style[],Int32) Method

CopyTo(Style[],Int32) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > CopyTo Method : CopyTo(Style[],Int32) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub CopyTo( _
   ByVal array() As Style, _
   ByVal arrayIndex As System.Integer _
)
public void CopyTo(
   Style[] array,
   System.int arrayIndex
)

Parameters

array
arrayIndex
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Count Property (StyleSheet)

Count Property (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : Count Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

StyleSheet Class
StyleSheet Members


Exists Method

Exists Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : Exists Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Exists( _
   ByVal match As System.Predicate(Of Style) _
) As System.Boolean
public System.bool Exists(
   System.Predicate<Style> match
)

Parameters

match
See Also

Reference

StyleSheet Class
StyleSheet Members


Find Method (StyleSheet)

Find Method (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : Find Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Find( _
   ByVal match As System.Predicate(Of Style) _
) As Style
public Style Find(
   System.Predicate<Style> match
)

Parameters

match
See Also

Reference

StyleSheet Class
StyleSheet Members


FindAll Method

FindAll Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : FindAll Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function FindAll( _
   ByVal match As System.Predicate(Of Style) _
) As System.Collections.Generic.List(Of Style)
public System.Collections.Generic.List<Style> FindAll(
   System.Predicate<Style> match
)

Parameters

match
See Also

Reference

StyleSheet Class
StyleSheet Members


FindIndex Method

FindIndex Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : FindIndex Method
Overload List
Overload | Description
FindIndex(Predicate<Style>) | (Inherited from System.Collections.Generic.List<Style>)
FindIndex(Int32,Predicate<Style>) | (Inherited from System.Collections.Generic.List<Style>)
FindIndex(Int32,Int32,Predicate<Style>) | (Inherited from System.Collections.Generic.List<Style>)
See Also

Reference

StyleSheet Class
StyleSheet Members


FindIndex(Int32,Int32,Predicate<Style>) Method

FindIndex(Int32,Int32,Predicate<Style>) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > FindIndex Method : FindIndex(Int32,Int32,Predicate<Style>) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function FindIndex( _
   ByVal startIndex As System.Integer, _
   ByVal count As System.Integer, _
   ByVal match As System.Predicate(Of Style) _
) As System.Integer
public System.int FindIndex(
   System.int startIndex,
   System.int count,
   System.Predicate<Style> match
)

Parameters

startIndex
count
match
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


FindIndex(Int32,Predicate<Style>) Method

FindIndex(Int32,Predicate<Style>) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > FindIndex Method : FindIndex(Int32,Predicate<Style>) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function FindIndex( _
   ByVal startIndex As System.Integer, _
   ByVal match As System.Predicate(Of Style) _
) As System.Integer
public System.int FindIndex(
   System.int startIndex,
   System.Predicate<Style> match
)

Parameters

startIndex
match
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


FindIndex(Predicate<Style>) Method

FindIndex(Predicate<Style>) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > FindIndex Method : FindIndex(Predicate<Style>) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function FindIndex( _
   ByVal match As System.Predicate(Of Style) _
) As System.Integer
public System.int FindIndex(
   System.Predicate<Style> match
)

Parameters

match
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


FindLast Method

FindLast Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : FindLast Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function FindLast( _
   ByVal match As System.Predicate(Of Style) _
) As Style
public Style FindLast(
   System.Predicate<Style> match
)

Parameters

match
See Also

Reference

StyleSheet Class
StyleSheet Members


FindLastIndex Method

FindLastIndex Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : FindLastIndex Method
Overload List
Overload | Description
FindLastIndex(Predicate<Style>) | (Inherited from System.Collections.Generic.List<Style>)
FindLastIndex(Int32,Predicate<Style>) | (Inherited from System.Collections.Generic.List<Style>)
FindLastIndex(Int32,Int32,Predicate<Style>) | (Inherited from System.Collections.Generic.List<Style>)
See Also

Reference

StyleSheet Class
StyleSheet Members


FindLastIndex(Int32,Int32,Predicate<Style>) Method

FindLastIndex(Int32,Int32,Predicate<Style>) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > FindLastIndex Method : FindLastIndex(Int32,Int32,Predicate<Style>) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function FindLastIndex( _
   ByVal startIndex As System.Integer, _
   ByVal count As System.Integer, _
   ByVal match As System.Predicate(Of Style) _
) As System.Integer
public System.int FindLastIndex(
   System.int startIndex,
   System.int count,
   System.Predicate<Style> match
)

Parameters

startIndex
count
match
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


FindLastIndex(Int32,Predicate<Style>) Method

FindLastIndex(Int32,Predicate<Style>) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > FindLastIndex Method : FindLastIndex(Int32,Predicate<Style>) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function FindLastIndex( _
   ByVal startIndex As System.Integer, _
   ByVal match As System.Predicate(Of Style) _
) As System.Integer
public System.int FindLastIndex(
   System.int startIndex,
   System.Predicate<Style> match
)

Parameters

startIndex
match
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


FindLastIndex(Predicate<Style>) Method

FindLastIndex(Predicate<Style>) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > FindLastIndex Method : FindLastIndex(Predicate<Style>) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function FindLastIndex( _
   ByVal match As System.Predicate(Of Style) _
) As System.Integer
public System.int FindLastIndex(
   System.Predicate<Style> match
)

Parameters

match
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


ForEach Method (StyleSheet)

ForEach Method (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : ForEach Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ForEach( _
   ByVal action As System.Action(Of Style) _
)
public void ForEach(
   System.Action<Style> action
)

Parameters

action
See Also

Reference

StyleSheet Class
StyleSheet Members


GetRange Method (StyleSheet)

GetRange Method (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : GetRange Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetRange( _
   ByVal index As System.Integer, _
   ByVal count As System.Integer _
) As System.Collections.Generic.List(Of Style)
public System.Collections.Generic.List<Style> GetRange(
   System.int index,
   System.int count
)

Parameters

index
count
See Also

Reference

StyleSheet Class
StyleSheet Members


IndexOf Method (StyleSheet)

IndexOf Method (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : IndexOf Method
Overload List
Overload | Description
IndexOf(Style) | (Inherited from System.Collections.Generic.List<Style>)
IndexOf(Style,Int32) | (Inherited from System.Collections.Generic.List<Style>)
IndexOf(Style,Int32,Int32) | (Inherited from System.Collections.Generic.List<Style>)
See Also

Reference

StyleSheet Class
StyleSheet Members


IndexOf(Style) Method

IndexOf(Style) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > IndexOf Method : IndexOf(Style) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function IndexOf( _
   ByVal item As Style _
) As System.Integer
public System.int IndexOf(
   Style item
)

Parameters

item
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


IndexOf(Style,Int32) Method

IndexOf(Style,Int32) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > IndexOf Method : IndexOf(Style,Int32) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function IndexOf( _
   ByVal item As Style, _
   ByVal index As System.Integer _
) As System.Integer
public System.int IndexOf(
   Style item,
   System.int index
)

Parameters

item
index
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


IndexOf(Style,Int32,Int32) Method

IndexOf(Style,Int32,Int32) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > IndexOf Method : IndexOf(Style,Int32,Int32) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function IndexOf( _
   ByVal item As Style, _
   ByVal index As System.Integer, _
   ByVal count As System.Integer _
) As System.Integer
public System.int IndexOf(
   Style item,
   System.int index,
   System.int count
)

Parameters

item
index
count
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Insert Method (StyleSheet)

Insert Method (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : Insert Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As Style _
)
public void Insert(
   System.int index,
   Style item
)

Parameters

index
item
See Also

Reference

StyleSheet Class
StyleSheet Members


InsertRange Method (StyleSheet)

InsertRange Method (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : InsertRange Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub InsertRange( _
   ByVal index As System.Integer, _
   ByVal collection As System.Collections.Generic.IEnumerable(Of Style) _
)
public void InsertRange(
   System.int index,
   System.Collections.Generic.IEnumerable<Style> collection
)

Parameters

index
collection
See Also

Reference

StyleSheet Class
StyleSheet Members


LastIndexOf Method

LastIndexOf Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : LastIndexOf Method
Overload List
Overload | Description
LastIndexOf(Style) | (Inherited from System.Collections.Generic.List<Style>)
LastIndexOf(Style,Int32) | (Inherited from System.Collections.Generic.List<Style>)
LastIndexOf(Style,Int32,Int32) | (Inherited from System.Collections.Generic.List<Style>)
See Also

Reference

StyleSheet Class
StyleSheet Members


LastIndexOf(Style) Method

LastIndexOf(Style) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > LastIndexOf Method : LastIndexOf(Style) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function LastIndexOf( _
   ByVal item As Style _
) As System.Integer
public System.int LastIndexOf(
   Style item
)

Parameters

item
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


LastIndexOf(Style,Int32) Method

LastIndexOf(Style,Int32) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > LastIndexOf Method : LastIndexOf(Style,Int32) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function LastIndexOf( _
   ByVal item As Style, _
   ByVal index As System.Integer _
) As System.Integer
public System.int LastIndexOf(
   Style item,
   System.int index
)

Parameters

item
index
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


LastIndexOf(Style,Int32,Int32) Method

LastIndexOf(Style,Int32,Int32) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > LastIndexOf Method : LastIndexOf(Style,Int32,Int32) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function LastIndexOf( _
   ByVal item As Style, _
   ByVal index As System.Integer, _
   ByVal count As System.Integer _
) As System.Integer
public System.int LastIndexOf(
   Style item,
   System.int index,
   System.int count
)

Parameters

item
index
count
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Remove Method (StyleSheet)

Remove Method (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : Remove Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Remove( _
   ByVal item As Style _
) As System.Boolean
public System.bool Remove(
   Style item
)

Parameters

item
See Also

Reference

StyleSheet Class
StyleSheet Members


RemoveAll Method

RemoveAll Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : RemoveAll Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function RemoveAll( _
   ByVal match As System.Predicate(Of Style) _
) As System.Integer
public System.int RemoveAll(
   System.Predicate<Style> match
)

Parameters

match
See Also

Reference

StyleSheet Class
StyleSheet Members


RemoveAt Method (StyleSheet)

RemoveAt Method (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : RemoveAt Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
See Also

Reference

StyleSheet Class
StyleSheet Members


RemoveRange Method

RemoveRange Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : RemoveRange Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveRange( _
   ByVal index As System.Integer, _
   ByVal count As System.Integer _
)
public void RemoveRange(
   System.int index,
   System.int count
)

Parameters

index
count
See Also

Reference

StyleSheet Class
StyleSheet Members


Reverse Method

Reverse Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : Reverse Method
Overload List
Overload | Description
Reverse() | (Inherited from System.Collections.Generic.List<Style>)
Reverse(Int32,Int32) | (Inherited from System.Collections.Generic.List<Style>)
See Also

Reference

StyleSheet Class
StyleSheet Members


Reverse() Method

Reverse() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > Reverse Method : Reverse() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Reverse()
public void Reverse()
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Reverse(Int32,Int32) Method

Reverse(Int32,Int32) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > Reverse Method : Reverse(Int32,Int32) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Reverse( _
   ByVal index As System.Integer, _
   ByVal count As System.Integer _
)
public void Reverse(
   System.int index,
   System.int count
)

Parameters

index
count
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Sort Method

Sort Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : Sort Method
Overload List
Overload | Description
Sort() | (Inherited from System.Collections.Generic.List<Style>)
Sort(IComparer<Style>) | (Inherited from System.Collections.Generic.List<Style>)
Sort(Int32,Int32,IComparer<Style>) | (Inherited from System.Collections.Generic.List<Style>)
Sort(Comparison<Style>) | (Inherited from System.Collections.Generic.List<Style>)
See Also

Reference

StyleSheet Class
StyleSheet Members


Sort() Method

Sort() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > Sort Method : Sort() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Sort()
public void Sort()
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Sort(Comparison<Style>) Method

Sort(Comparison<Style>) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > Sort Method : Sort(Comparison<Style>) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Sort( _
   ByVal comparison As System.Comparison(Of Style) _
)
public void Sort(
   System.Comparison<Style> comparison
)

Parameters

comparison
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Sort(IComparer<Style>) Method

Sort(IComparer<Style>) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > Sort Method : Sort(IComparer<Style>) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Sort( _
   ByVal comparer As System.Collections.Generic.IComparer(Of Style) _
)
public void Sort(
   System.Collections.Generic.IComparer<Style> comparer
)

Parameters

comparer
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


Sort(Int32,Int32,IComparer<Style>) Method

Sort(Int32,Int32,IComparer<Style>) Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class > Sort Method : Sort(Int32,Int32,IComparer<Style>) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Sort( _
   ByVal index As System.Integer, _
   ByVal count As System.Integer, _
   ByVal comparer As System.Collections.Generic.IComparer(Of Style) _
)
public void Sort(
   System.int index,
   System.int count,
   System.Collections.Generic.IComparer<Style> comparer
)

Parameters

index
count
comparer
See Also

Reference

StyleSheet Class
StyleSheet Members
Overload List


ToArray Method (StyleSheet)

ToArray Method (StyleSheet)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : ToArray Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToArray() As Style()
public Style[] ToArray()
See Also

Reference

StyleSheet Class
StyleSheet Members


TrimExcess Method

TrimExcess Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : TrimExcess Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub TrimExcess()
public void TrimExcess()
See Also

Reference

StyleSheet Class
StyleSheet Members


TrueForAll Method

TrueForAll Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > StyleSheet Class : TrueForAll Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function TrueForAll( _
   ByVal match As System.Predicate(Of Style) _
) As System.Boolean
public System.bool TrueForAll(
   System.Predicate<Style> match
)

Parameters

match
See Also

Reference

StyleSheet Class
StyleSheet Members


Subreport Class Events

Subreport Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Subreport Class

For a list of all members of this type, see Subreport members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Subreport Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Property (Subreport)

Container Property (Subreport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

Subreport Class
Subreport Members


CreateObjRef Method (Subreport)

CreateObjRef Method (Subreport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

Subreport Class
Subreport Members


Dispose Method (Subreport)

Dispose Method (Subreport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

Subreport Class
Subreport Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Subreport Class
Subreport Members


Disposed Event (Subreport)

Disposed Event (Subreport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Subreport Class
Subreport Members


GetLifetimeService Method (Subreport)

GetLifetimeService Method (Subreport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

Subreport Class
Subreport Members


InitializeLifetimeService Method (Subreport)

InitializeLifetimeService Method (Subreport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

Subreport Class
Subreport Members


Site Property (Subreport)

Site Property (Subreport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

Subreport Class
Subreport Members


ToString Method (Subreport)

ToString Method (Subreport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subreport Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

Subreport Class
Subreport Members


Subtotal Class Events

Subtotal Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Subtotal Class

For a list of all members of this type, see Subtotal members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Subtotal Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Property (Subtotal)

Container Property (Subtotal)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subtotal Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

Subtotal Class
Subtotal Members


CreateObjRef Method (Subtotal)

CreateObjRef Method (Subtotal)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subtotal Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

Subtotal Class
Subtotal Members


Dispose Method (Subtotal)

Dispose Method (Subtotal)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subtotal Class : Dispose Method
Disposes the class
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

Subtotal Class
Subtotal Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subtotal Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Subtotal Class
Subtotal Members


Disposed Event (Subtotal)

Disposed Event (Subtotal)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subtotal Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Subtotal Class
Subtotal Members


GetLifetimeService Method (Subtotal)

GetLifetimeService Method (Subtotal)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subtotal Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

Subtotal Class
Subtotal Members


InitializeLifetimeService Method (Subtotal)

InitializeLifetimeService Method (Subtotal)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subtotal Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

Subtotal Class
Subtotal Members


Site Property (Subtotal)

Site Property (Subtotal)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subtotal Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

Subtotal Class
Subtotal Members


ToString Method (Subtotal)

ToString Method (Subtotal)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Subtotal Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

Subtotal Class
Subtotal Members


Table Class Events

Table Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : Table Class

For a list of all members of this type, see Table members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

Table Class
GrapeCity.ActiveReports.PageReportModel Namespace


TableCell Class Events

TableCell Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableCell Class

For a list of all members of this type, see TableCell members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

TableCell Class
GrapeCity.ActiveReports.PageReportModel Namespace


Capacity Property (TableCellCollection)

Capacity Property (TableCellCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCellCollection Class : Capacity Property
Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

TableCellCollection Class
TableCellCollection Members


Clear Method (TableCellCollection)

Clear Method (TableCellCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCellCollection Class : Clear Method
Removes all objects from the DataGroupingCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

TableCellCollection Class
TableCellCollection Members


Count Property (TableCellCollection)

Count Property (TableCellCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCellCollection Class : Count Property
Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

TableCellCollection Class
TableCellCollection Members


RemoveAt Method (TableCellCollection)

RemoveAt Method (TableCellCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCellCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the DataCellCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

TableCellCollection Class
TableCellCollection Members


Container Property (TableCell)

Container Property (TableCell)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCell Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

TableCell Class
TableCell Members


CreateObjRef Method (TableCell)

CreateObjRef Method (TableCell)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCell Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

TableCell Class
TableCell Members


Dispose Method (TableCell)

Dispose Method (TableCell)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCell Class : Dispose Method
Disposes the class
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

TableCell Class
TableCell Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCell Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

TableCell Class
TableCell Members


Disposed Event (TableCell)

Disposed Event (TableCell)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCell Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

TableCell Class
TableCell Members


GetLifetimeService Method (TableCell)

GetLifetimeService Method (TableCell)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCell Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

TableCell Class
TableCell Members


InitializeLifetimeService Method (TableCell)

InitializeLifetimeService Method (TableCell)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCell Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

TableCell Class
TableCell Members


Site Property (TableCell)

Site Property (TableCell)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCell Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

TableCell Class
TableCell Members


ToString Method (TableCell)

ToString Method (TableCell)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableCell Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

TableCell Class
TableCell Members


Capacity Property (TableColumnCollection)

Capacity Property (TableColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableColumnCollection Class : Capacity Property
Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

TableColumnCollection Class
TableColumnCollection Members


Clear Method (TableColumnCollection)

Clear Method (TableColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableColumnCollection Class : Clear Method
Removes all objects from the DataGroupingCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

TableColumnCollection Class
TableColumnCollection Members


Count Property (TableColumnCollection)

Count Property (TableColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableColumnCollection Class : Count Property
Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

TableColumnCollection Class
TableColumnCollection Members


RemoveAt Method (TableColumnCollection)

RemoveAt Method (TableColumnCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableColumnCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the DataCellCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

TableColumnCollection Class
TableColumnCollection Members


TableGroup Class Events

TableGroup Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableGroup Class

For a list of all members of this type, see TableGroup members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

TableGroup Class
GrapeCity.ActiveReports.PageReportModel Namespace


Capacity Property (TableGroupCollection)

Capacity Property (TableGroupCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroupCollection Class : Capacity Property
Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

TableGroupCollection Class
TableGroupCollection Members


Clear Method (TableGroupCollection)

Clear Method (TableGroupCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroupCollection Class : Clear Method
Removes all objects from the DataGroupingCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

TableGroupCollection Class
TableGroupCollection Members


Count Property (TableGroupCollection)

Count Property (TableGroupCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroupCollection Class : Count Property
Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

TableGroupCollection Class
TableGroupCollection Members


RemoveAt Method (TableGroupCollection)

RemoveAt Method (TableGroupCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroupCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the DataCellCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

TableGroupCollection Class
TableGroupCollection Members


Container Property (TableGroup)

Container Property (TableGroup)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

TableGroup Class
TableGroup Members


CreateObjRef Method (TableGroup)

CreateObjRef Method (TableGroup)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

TableGroup Class
TableGroup Members


Dispose Method (TableGroup)

Dispose Method (TableGroup)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

TableGroup Class
TableGroup Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

TableGroup Class
TableGroup Members


Disposed Event (TableGroup)

Disposed Event (TableGroup)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

TableGroup Class
TableGroup Members


GetLifetimeService Method (TableGroup)

GetLifetimeService Method (TableGroup)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

TableGroup Class
TableGroup Members


InitializeLifetimeService Method (TableGroup)

InitializeLifetimeService Method (TableGroup)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

TableGroup Class
TableGroup Members


Site Property (TableGroup)

Site Property (TableGroup)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

TableGroup Class
TableGroup Members


ToString Method (TableGroup)

ToString Method (TableGroup)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableGroup Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

TableGroup Class
TableGroup Members


TableOfContents Class Events

TableOfContents Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableOfContents Class

For a list of all members of this type, see TableOfContents members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

TableOfContents Class
GrapeCity.ActiveReports.PageReportModel Namespace


TableOfContents Class Methods

TableOfContents Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableOfContents Class

For a list of all members of this type, see TableOfContents members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the ReportItem object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
See Also

Reference

TableOfContents Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Property (TableOfContents)

Container Property (TableOfContents)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

TableOfContents Class
TableOfContents Members


CreateObjRef Method (TableOfContents)

CreateObjRef Method (TableOfContents)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

TableOfContents Class
TableOfContents Members


Dispose Method (TableOfContents)

Dispose Method (TableOfContents)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

TableOfContents Class
TableOfContents Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

TableOfContents Class
TableOfContents Members


Disposed Event (TableOfContents)

Disposed Event (TableOfContents)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

TableOfContents Class
TableOfContents Members


GetLifetimeService Method (TableOfContents)

GetLifetimeService Method (TableOfContents)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

TableOfContents Class
TableOfContents Members


InitializeLifetimeService Method (TableOfContents)

InitializeLifetimeService Method (TableOfContents)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

TableOfContents Class
TableOfContents Members


Site Property (TableOfContents)

Site Property (TableOfContents)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

TableOfContents Class
TableOfContents Members


ToString Method (TableOfContents)

ToString Method (TableOfContents)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableOfContents Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

TableOfContents Class
TableOfContents Members


TableRow Class Events

TableRow Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TableRow Class

For a list of all members of this type, see TableRow members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

TableRow Class
GrapeCity.ActiveReports.PageReportModel Namespace


Capacity Property (TableRowCollection)

Capacity Property (TableRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRowCollection Class : Capacity Property
Gets or sets the number of elements that the CustomPropertyDefinitionCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

TableRowCollection Class
TableRowCollection Members


Clear Method (TableRowCollection)

Clear Method (TableRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRowCollection Class : Clear Method
Removes all objects from the DataGroupingCollection instance. This method cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

TableRowCollection Class
TableRowCollection Members


Count Property (TableRowCollection)

Count Property (TableRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRowCollection Class : Count Property
Gets the number of elements contained in the CustomPropertyDefinitionCollection instance. This property cannot be overridden.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

TableRowCollection Class
TableRowCollection Members


RemoveAt Method (TableRowCollection)

RemoveAt Method (TableRowCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRowCollection Class : RemoveAt Method
The zero-based index of the element to remove.
Removes the element at the specified index of the DataCellCollection instance. This method is not overridable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.
See Also

Reference

TableRowCollection Class
TableRowCollection Members


Container Property (TableRow)

Container Property (TableRow)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRow Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

TableRow Class
TableRow Members


CreateObjRef Method (TableRow)

CreateObjRef Method (TableRow)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRow Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

TableRow Class
TableRow Members


Dispose Method (TableRow)

Dispose Method (TableRow)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRow Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

TableRow Class
TableRow Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRow Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

TableRow Class
TableRow Members


Disposed Event (TableRow)

Disposed Event (TableRow)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRow Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

TableRow Class
TableRow Members


GetLifetimeService Method (TableRow)

GetLifetimeService Method (TableRow)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRow Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

TableRow Class
TableRow Members


InitializeLifetimeService Method (TableRow)

InitializeLifetimeService Method (TableRow)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRow Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

TableRow Class
TableRow Members


Site Property (TableRow)

Site Property (TableRow)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRow Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

TableRow Class
TableRow Members


ToString Method (TableRow)

ToString Method (TableRow)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TableRow Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

TableRow Class
TableRow Members


Container Property (Table)

Container Property (Table)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

Table Class
Table Members


CreateObjRef Method (Table)

CreateObjRef Method (Table)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

Table Class
Table Members


Dispose Method (Table)

Dispose Method (Table)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

Table Class
Table Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Table Class
Table Members


Disposed Event (Table)

Disposed Event (Table)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Table Class
Table Members


GetLifetimeService Method (Table)

GetLifetimeService Method (Table)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

Table Class
Table Members


InitializeLifetimeService Method (Table)

InitializeLifetimeService Method (Table)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

Table Class
Table Members


Site Property (Table)

Site Property (Table)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

Table Class
Table Members


ToString Method (Table)

ToString Method (Table)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > Table Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

Table Class
Table Members


TextBox Class Events

TextBox Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextBox Class

For a list of all members of this type, see TextBox members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

TextBox Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Property (TextBox)

Container Property (TextBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

TextBox Class
TextBox Members


CreateObjRef Method (TextBox)

CreateObjRef Method (TextBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

TextBox Class
TextBox Members


Dispose Method (TextBox)

Dispose Method (TextBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

TextBox Class
TextBox Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

TextBox Class
TextBox Members


Disposed Event (TextBox)

Disposed Event (TextBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

TextBox Class
TextBox Members


GetLifetimeService Method (TextBox)

GetLifetimeService Method (TextBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

TextBox Class
TextBox Members


InitializeLifetimeService Method (TextBox)

InitializeLifetimeService Method (TextBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

TextBox Class
TextBox Members


Site Property (TextBox)

Site Property (TextBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

TextBox Class
TextBox Members


ToString Method (TextBox)

ToString Method (TextBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextBox Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

TextBox Class
TextBox Members


TextItem Class Events

TextItem Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextItem Class

For a list of all members of this type, see TextItem members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

TextItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


TextItem Class Methods

TextItem Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace : TextItem Class

For a list of all members of this type, see TextItem members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Validate | Validates the information in each property of the ReportItem object. (Inherited from GrapeCity.ActiveReports.PageReportModel.ReportItem)
Top
See Also

Reference

TextItem Class
GrapeCity.ActiveReports.PageReportModel Namespace


Container Property (TextItem)

Container Property (TextItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextItem Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

TextItem Class
TextItem Members


CreateObjRef Method (TextItem)

CreateObjRef Method (TextItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextItem Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

TextItem Class
TextItem Members


Dispose Method (TextItem)

Dispose Method (TextItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextItem Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

TextItem Class
TextItem Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextItem Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

TextItem Class
TextItem Members


Disposed Event (TextItem)

Disposed Event (TextItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextItem Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

TextItem Class
TextItem Members


GetLifetimeService Method (TextItem)

GetLifetimeService Method (TextItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextItem Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

TextItem Class
TextItem Members


InitializeLifetimeService Method (TextItem)

InitializeLifetimeService Method (TextItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextItem Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
public virtual System.object InitializeLifetimeService()
See Also

Reference

TextItem Class
TextItem Members


Site Property (TextItem)

Site Property (TextItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextItem Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
public virtual System.ComponentModel.ISite Site {get; set;}
See Also

Reference

TextItem Class
TextItem Members


ToString Method (TextItem)

ToString Method (TextItem)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.PageReportModel Namespace > TextItem Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

TextItem Class
TextItem Members


GrapeCity.ActiveReports.PageReportModel Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.PageReportModel Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports.PageReportModel Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.PageReportModel.Action
GrapeCity.ActiveReports.PageReportModel.ActionInfo
GrapeCity.ActiveReports.PageReportModel.Axis
GrapeCity.ActiveReports.PageReportModel.BackgroundImage
GrapeCity.ActiveReports.PageReportModel.Border
GrapeCity.ActiveReports.PageReportModel.BorderColor
GrapeCity.ActiveReports.PageReportModel.BorderStyle
GrapeCity.ActiveReports.PageReportModel.BorderWidth
GrapeCity.ActiveReports.PageReportModel.ChartSeries
GrapeCity.ActiveReports.PageReportModel.CodeClass
GrapeCity.ActiveReports.PageReportModel.ConnectionProperties
GrapeCity.ActiveReports.PageReportModel.Custom
GrapeCity.ActiveReports.PageReportModel.CustomData
GrapeCity.ActiveReports.PageReportModel.CustomPropertyDefinition
GrapeCity.ActiveReports.PageReportModel.DataGrouping
GrapeCity.ActiveReports.PageReportModel.DataLabel
GrapeCity.ActiveReports.PageReportModel.DataPoint
GrapeCity.ActiveReports.PageReportModel.DataSet
GrapeCity.ActiveReports.PageReportModel.DataSetReference
GrapeCity.ActiveReports.PageReportModel.DataSource
GrapeCity.ActiveReports.PageReportModel.DataSourcePrompt
GrapeCity.ActiveReports.PageReportModel.DataValue
GrapeCity.ActiveReports.PageReportModel.DefaultValue
GrapeCity.ActiveReports.PageReportModel.DocumentMap
GrapeCity.ActiveReports.PageReportModel.DocumentMapLevel
GrapeCity.ActiveReports.PageReportModel.Drillthrough
GrapeCity.ActiveReports.PageReportModel.DynamicCategoriesSeries
GrapeCity.ActiveReports.PageReportModel.EmbeddedImage
GrapeCity.ActiveReports.PageReportModel.EmbeddedStyleSheet
GrapeCity.ActiveReports.PageReportModel.Field
GrapeCity.ActiveReports.PageReportModel.Filter
GrapeCity.ActiveReports.PageReportModel.GridLines
GrapeCity.ActiveReports.PageReportModel.Grouping
GrapeCity.ActiveReports.PageReportModel.Layer
GrapeCity.ActiveReports.PageReportModel.Legend
GrapeCity.ActiveReports.PageReportModel.LocalizationResource
GrapeCity.ActiveReports.PageReportModel.MapAppearanceRule
GrapeCity.ActiveReports.PageReportModel.MapColorRule
GrapeCity.ActiveReports.PageReportModel.MapColorPaletteRule
GrapeCity.ActiveReports.PageReportModel.MapColorRangeRule
GrapeCity.ActiveReports.PageReportModel.MapCustomColorRule
GrapeCity.ActiveReports.PageReportModel.MapMarkerRule
GrapeCity.ActiveReports.PageReportModel.MapSizeRule
GrapeCity.ActiveReports.PageReportModel.MapBindingFieldPair
GrapeCity.ActiveReports.PageReportModel.MapBorderSkin
GrapeCity.ActiveReports.PageReportModel.MapBucket
GrapeCity.ActiveReports.PageReportModel.MapColorScaleTitle
GrapeCity.ActiveReports.PageReportModel.MapDataRegion
GrapeCity.ActiveReports.PageReportModel.MapField
GrapeCity.ActiveReports.PageReportModel.MapFieldDefinition
GrapeCity.ActiveReports.PageReportModel.MapGridLines
GrapeCity.ActiveReports.PageReportModel.MapLayer
GrapeCity.ActiveReports.PageReportModel.MapTileLayer
GrapeCity.ActiveReports.PageReportModel.MapVectorLayer
GrapeCity.ActiveReports.PageReportModel.MapLineLayer
GrapeCity.ActiveReports.PageReportModel.MapPointLayer
GrapeCity.ActiveReports.PageReportModel.MapPolygonLayer
GrapeCity.ActiveReports.PageReportModel.MapLegendTitle
GrapeCity.ActiveReports.PageReportModel.MapLimits
GrapeCity.ActiveReports.PageReportModel.MapLineRules
GrapeCity.ActiveReports.PageReportModel.MapLocation
GrapeCity.ActiveReports.PageReportModel.MapMarker
GrapeCity.ActiveReports.PageReportModel.MapMarkerImage
GrapeCity.ActiveReports.PageReportModel.MapMember
GrapeCity.ActiveReports.PageReportModel.MapPointRules
GrapeCity.ActiveReports.PageReportModel.MapPolygonRules
GrapeCity.ActiveReports.PageReportModel.MapSize
GrapeCity.ActiveReports.PageReportModel.MapSpatialData
GrapeCity.ActiveReports.PageReportModel.MapShapefile
GrapeCity.ActiveReports.PageReportModel.MapSpatialDataRegion
GrapeCity.ActiveReports.PageReportModel.MapSpatialDataSet
GrapeCity.ActiveReports.PageReportModel.MapSpatialElement
GrapeCity.ActiveReports.PageReportModel.MapLine
GrapeCity.ActiveReports.PageReportModel.MapPoint
GrapeCity.ActiveReports.PageReportModel.MapPolygon
GrapeCity.ActiveReports.PageReportModel.MapSpatialElementTemplate
GrapeCity.ActiveReports.PageReportModel.MapLineTemplate
GrapeCity.ActiveReports.PageReportModel.MapPointTemplate
GrapeCity.ActiveReports.PageReportModel.MapMarkerTemplate
GrapeCity.ActiveReports.PageReportModel.MapPolygonTemplate
GrapeCity.ActiveReports.PageReportModel.MapSubItem
GrapeCity.ActiveReports.PageReportModel.MapDockableSubItem
GrapeCity.ActiveReports.PageReportModel.MapColorScale
GrapeCity.ActiveReports.PageReportModel.MapDistanceScale
GrapeCity.ActiveReports.PageReportModel.MapLegend
GrapeCity.ActiveReports.PageReportModel.MapTitle
GrapeCity.ActiveReports.PageReportModel.MapViewport
GrapeCity.ActiveReports.PageReportModel.MapTile
GrapeCity.ActiveReports.PageReportModel.MapView
GrapeCity.ActiveReports.PageReportModel.MapCustomView
GrapeCity.ActiveReports.PageReportModel.MapDataBoundView
GrapeCity.ActiveReports.PageReportModel.MapElementView
GrapeCity.ActiveReports.PageReportModel.Marker
GrapeCity.ActiveReports.PageReportModel.MatrixColumn
GrapeCity.ActiveReports.PageReportModel.NameValidator
GrapeCity.ActiveReports.PageReportModel.PageBreak
GrapeCity.ActiveReports.PageReportModel.PageCollection
GrapeCity.ActiveReports.PageReportModel.Parameter
GrapeCity.ActiveReports.PageReportModel.ParameterValue
GrapeCity.ActiveReports.PageReportModel.PlotArea
GrapeCity.ActiveReports.PageReportModel.Property
GrapeCity.ActiveReports.PageReportModel.Query
GrapeCity.ActiveReports.PageReportModel.QueryParameter
GrapeCity.ActiveReports.PageReportModel.ReferenceLine
GrapeCity.ActiveReports.PageReportModel.ReportComponentCollection
GrapeCity.ActiveReports.PageReportModel.ReportItemCollection
GrapeCity.ActiveReports.PageReportModel.ReportParameter
GrapeCity.ActiveReports.PageReportModel.RoundingRadius
GrapeCity.ActiveReports.PageReportModel.SharedDataSet
GrapeCity.ActiveReports.PageReportModel.SortBy
GrapeCity.ActiveReports.PageReportModel.StaticMember
GrapeCity.ActiveReports.PageReportModel.Style
GrapeCity.ActiveReports.PageReportModel.StyleExpressionExtensions
GrapeCity.ActiveReports.PageReportModel.TableColumn
GrapeCity.ActiveReports.PageReportModel.TableOfContentsLevel
GrapeCity.ActiveReports.PageReportModel.ThreeDProperties
GrapeCity.ActiveReports.PageReportModel.Title
GrapeCity.ActiveReports.PageReportModel.ToggleImage
GrapeCity.ActiveReports.PageReportModel.UserSort
GrapeCity.ActiveReports.PageReportModel.ValidationContext
GrapeCity.ActiveReports.PageReportModel.ValidationEntry
GrapeCity.ActiveReports.PageReportModel.Validator
GrapeCity.ActiveReports.PageReportModel.ValidValues
GrapeCity.ActiveReports.PageReportModel.ValueCategoryAxis
GrapeCity.ActiveReports.PageReportModel.Variable
GrapeCity.ActiveReports.PageReportModel.Visibility
System.Collections.CollectionBase
GrapeCity.ActiveReports.PageReportModel.CategoryGroupingCollection
GrapeCity.ActiveReports.PageReportModel.ChartSeriesCollection
GrapeCity.ActiveReports.PageReportModel.CodeClassCollection
GrapeCity.ActiveReports.PageReportModel.ColumnGroupingCollection
GrapeCity.ActiveReports.PageReportModel.CustomPropertyDefinitionCollection
GrapeCity.ActiveReports.PageReportModel.DataCellCollection
GrapeCity.ActiveReports.PageReportModel.DataGroupingCollection
GrapeCity.ActiveReports.PageReportModel.DataPointCollection
GrapeCity.ActiveReports.PageReportModel.DataRowCollection
GrapeCity.ActiveReports.PageReportModel.DataSetCollection
GrapeCity.ActiveReports.PageReportModel.DataSourceCollection
GrapeCity.ActiveReports.PageReportModel.DataValueCollection
GrapeCity.ActiveReports.PageReportModel.EmbeddedImageCollection
GrapeCity.ActiveReports.PageReportModel.FieldCollection
GrapeCity.ActiveReports.PageReportModel.LayerCollection
GrapeCity.ActiveReports.PageReportModel.MatrixCellCollection
GrapeCity.ActiveReports.PageReportModel.MatrixRowCollection
GrapeCity.ActiveReports.PageReportModel.ParameterCollection
GrapeCity.ActiveReports.PageReportModel.ParameterValueCollection
GrapeCity.ActiveReports.PageReportModel.PropertyCollection
GrapeCity.ActiveReports.PageReportModel.QueryParameterCollection
GrapeCity.ActiveReports.PageReportModel.ReportParameterCollection
GrapeCity.ActiveReports.PageReportModel.RowGroupingCollection
GrapeCity.ActiveReports.PageReportModel.SeriesGroupingCollection
GrapeCity.ActiveReports.PageReportModel.StaticMemberCollection
GrapeCity.ActiveReports.PageReportModel.StaticRowColumnCollection
GrapeCity.ActiveReports.PageReportModel.TableCellCollection
GrapeCity.ActiveReports.PageReportModel.TableColumnCollection
GrapeCity.ActiveReports.PageReportModel.TableGroupCollection
GrapeCity.ActiveReports.PageReportModel.TableRowCollection
System.Collections.Generic.List<T>
GrapeCity.ActiveReports.PageReportModel.StyleSheet
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.PageReportModel.MatrixColumnCollection
GrapeCity.ActiveReports.PageReportModel.SortByCollection
System.EventArgs
GrapeCity.ActiveReports.PageReportModel.PageCollectionEventArgs
GrapeCity.ActiveReports.PageReportModel.ReportItemCollectionEventArgs
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.ReportException
GrapeCity.ActiveReports.PageReportModel.MasterReportNotFoundException
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReportModel.ReportComponent
GrapeCity.ActiveReports.PageReportModel.CategoryGrouping
GrapeCity.ActiveReports.PageReportModel.ColumnGrouping
GrapeCity.ActiveReports.PageReportModel.Details
GrapeCity.ActiveReports.PageReportModel.HeaderFooter
GrapeCity.ActiveReports.PageReportModel.Footer
GrapeCity.ActiveReports.PageReportModel.Header
GrapeCity.ActiveReports.PageReportModel.MatrixRow
GrapeCity.ActiveReports.PageReportModel.Report
GrapeCity.ActiveReports.PageReportModel.ReportComponentContainer
GrapeCity.ActiveReports.PageReportModel.Body
GrapeCity.ActiveReports.PageReportModel.Corner
GrapeCity.ActiveReports.PageReportModel.DynamicColumnsRows
GrapeCity.ActiveReports.PageReportModel.MatrixCell
GrapeCity.ActiveReports.PageReportModel.Page
GrapeCity.ActiveReports.PageReportModel.PageHeaderFooter
GrapeCity.ActiveReports.PageReportModel.StaticRowColumn
GrapeCity.ActiveReports.PageReportModel.Subtotal
GrapeCity.ActiveReports.PageReportModel.TableCell
GrapeCity.ActiveReports.PageReportModel.ReportItem
GrapeCity.ActiveReports.PageReportModel.CustomReportItem
GrapeCity.ActiveReports.PageReportModel.DataRegion
GrapeCity.ActiveReports.PageReportModel.Chart
GrapeCity.ActiveReports.PageReportModel.List
GrapeCity.ActiveReports.PageReportModel.Matrix
GrapeCity.ActiveReports.PageReportModel.Table
GrapeCity.ActiveReports.PageReportModel.Image
GrapeCity.ActiveReports.PageReportModel.Line
GrapeCity.ActiveReports.PageReportModel.Map
GrapeCity.ActiveReports.PageReportModel.OverflowPlaceHolder
GrapeCity.ActiveReports.PageReportModel.ShapeBase
GrapeCity.ActiveReports.PageReportModel.Container
GrapeCity.ActiveReports.PageReportModel.Shape
GrapeCity.ActiveReports.PageReportModel.Subreport
GrapeCity.ActiveReports.PageReportModel.TableOfContents
GrapeCity.ActiveReports.PageReportModel.TextItem
GrapeCity.ActiveReports.PageReportModel.CheckBox
GrapeCity.ActiveReports.PageReportModel.TextBox
GrapeCity.ActiveReports.PageReportModel.RowGrouping
GrapeCity.ActiveReports.PageReportModel.SeriesGrouping
GrapeCity.ActiveReports.PageReportModel.TableGroup
GrapeCity.ActiveReports.PageReportModel.TableRow
System.ValueType
GrapeCity.ActiveReports.PageReportModel.MasterContentCode
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


Container Property (PageReport)

Container Property (PageReport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Container Property

Gets the IContainer that contains the Component.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

PageReport Class
PageReport Members


CreateObjRef Method (PageReport)

CreateObjRef Method (PageReport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : CreateObjRef Method
The Type of the object that the new ObjRef will reference.

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
The Type of the object that the new ObjRef will reference.
See Also

Reference

PageReport Class
PageReport Members


Dispose Method (PageReport)

Dispose Method (PageReport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Dispose Method

Releases the resources used by the Component.

Overload List
Overload | Description
Dispose | Releases the resources used by the Component. (Inherited from System.ComponentModel.Component)
See Also

Reference

PageReport Class
PageReport Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Dispose() Method

Releases the resources used by the Component.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

PageReport Class
PageReport Members


Disposed Event (PageReport)

Disposed Event (PageReport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Disposed Event

Occurs when the component is disposed by a call to the Dispose method.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

PageReport Class
PageReport Members


GetLifetimeService Method (PageReport)

GetLifetimeService Method (PageReport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : GetLifetimeService Method

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

PageReport Class
PageReport Members


InitializeLifetimeService Method (PageReport)

InitializeLifetimeService Method (PageReport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : InitializeLifetimeService Method

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

PageReport Class
PageReport Members


Site Property (PageReport)

Site Property (PageReport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : Site Property

Gets or sets the ISite of the Component.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

PageReport Class
PageReport Members


ToString Method (PageReport)

ToString Method (PageReport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageReport Class : ToString Method

Returns a String containing the name of the Component, if any.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
Remarks
This method should not be overridden.
See Also

Reference

PageReport Class
PageReport Members


Dispose Method (PageSettings)

Dispose Method (PageSettings)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > PageSettings Class : Dispose Method
Releases unmanaged and - optionally - managed resources.
Releases the PageSettings object from memory.
Overload List
Overload | Description
Dispose | Releases the PageSettings object from memory.
See Also

Reference

PageSettings Class
PageSettings Members


GrapeCity.ActiveReports.Rendering.IO Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Rendering.IO Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports.Rendering.IO Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Extensibility.Rendering.IO.StreamProvider
GrapeCity.ActiveReports.Rendering.IO.FileStreamProvider
GrapeCity.ActiveReports.Rendering.IO.MemoryStreamProvider
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


ReportDataException Class Methods

ReportDataException Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : ReportDataException Class

For a list of all members of this type, see ReportDataException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the Info with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

ReportDataException Class
GrapeCity.ActiveReports Namespace


ReportDataException Class Properties

ReportDataException Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : ReportDataException Class

For a list of all members of this type, see ReportDataException members.

Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorCode | Error code for future detail processing. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | ErrorData | Error data, depends on error code. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
See Also

Reference

ReportDataException Class
GrapeCity.ActiveReports Namespace


Data Property (ReportDataException)

Data Property (ReportDataException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : Data Property

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Data As System.Collections.IDictionary
public virtual System.Collections.IDictionary Data {get;}
See Also

Reference

ReportDataException Class
ReportDataException Members


GetBaseException Method (ReportDataException)

GetBaseException Method (ReportDataException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : GetBaseException Method

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetBaseException() As System.Exception
public virtual System.Exception GetBaseException()
See Also

Reference

ReportDataException Class
ReportDataException Members


GetObjectData Method (ReportDataException)

GetObjectData Method (ReportDataException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : GetObjectData Method

When overridden in a derived class, sets the Info with information about the exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
See Also

Reference

ReportDataException Class
ReportDataException Members


GetType Method (ReportDataException)

GetType Method (ReportDataException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : GetType Method

Gets the runtime type of the current instance.

Overload List
Overload | Description
GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
See Also

Reference

ReportDataException Class
ReportDataException Members


GetType() Method

GetType() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : GetType() Method

Gets the runtime type of the current instance.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetType() As System.Type
public System.Type GetType()
See Also

Reference

ReportDataException Class
ReportDataException Members


HelpLink Property (ReportDataException)

HelpLink Property (ReportDataException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : HelpLink Property

Gets or sets a link to the help file associated with this exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property HelpLink As System.String
public virtual System.string HelpLink {get; set;}
See Also

Reference

ReportDataException Class
ReportDataException Members


HResult Property (ReportDataException)

HResult Property (ReportDataException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : HResult Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HResult As System.Integer
public System.int HResult {get;}
See Also

Reference

ReportDataException Class
ReportDataException Members


InnerException Property (ReportDataException)

InnerException Property (ReportDataException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : InnerException Property

Gets the Exception instance that caused the current exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InnerException As System.Exception
public System.Exception InnerException {get;}
See Also

Reference

ReportDataException Class
ReportDataException Members


Message Property (ReportDataException)

Message Property (ReportDataException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : Message Property

Gets a message that describes the current exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Message As System.String
public virtual System.string Message {get;}
See Also

Reference

ReportDataException Class
ReportDataException Members


Source Property (ReportDataException)

Source Property (ReportDataException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : Source Property

Gets or sets the name of the application or the object that causes the error.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Source As System.String
public virtual System.string Source {get; set;}
See Also

Reference

ReportDataException Class
ReportDataException Members


StackTrace Property (ReportDataException)

StackTrace Property (ReportDataException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : StackTrace Property

Gets a string representation of the immediate frames on the call stack.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property StackTrace As System.String
public virtual System.string StackTrace {get;}
See Also

Reference

ReportDataException Class
ReportDataException Members


TargetSite Property (ReportDataException)

TargetSite Property (ReportDataException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : TargetSite Property

Gets the method that throws the current exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
public System.Reflection.MethodBase TargetSite {get;}
See Also

Reference

ReportDataException Class
ReportDataException Members


ToString Method (ReportDataException)

ToString Method (ReportDataException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportDataException Class : ToString Method

Creates and returns a string representation of the current exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

ReportDataException Class
ReportDataException Members


ReportException Class Methods

ReportException Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : ReportException Class

For a list of all members of this type, see ReportException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the Info with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

ReportException Class
GrapeCity.ActiveReports Namespace


Data Property (ReportException)

Data Property (ReportException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : Data Property

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Data As System.Collections.IDictionary
public virtual System.Collections.IDictionary Data {get;}
See Also

Reference

ReportException Class
ReportException Members


GetBaseException Method (ReportException)

GetBaseException Method (ReportException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : GetBaseException Method

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetBaseException() As System.Exception
public virtual System.Exception GetBaseException()
See Also

Reference

ReportException Class
ReportException Members


GetObjectData Method (ReportException)

GetObjectData Method (ReportException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : GetObjectData Method

When overridden in a derived class, sets the Info with information about the exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context
See Also

Reference

ReportException Class
ReportException Members


GetType Method (ReportException)

GetType Method (ReportException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : GetType Method

Gets the runtime type of the current instance.

Overload List
Overload | Description
GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
See Also

Reference

ReportException Class
ReportException Members


GetType() Method

GetType() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : GetType() Method

Gets the runtime type of the current instance.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetType() As System.Type
public System.Type GetType()
See Also

Reference

ReportException Class
ReportException Members


HelpLink Property (ReportException)

HelpLink Property (ReportException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : HelpLink Property

Gets or sets a link to the help file associated with this exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property HelpLink As System.String
public virtual System.string HelpLink {get; set;}
See Also

Reference

ReportException Class
ReportException Members


HResult Property (ReportException)

HResult Property (ReportException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : HResult Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HResult As System.Integer
public System.int HResult {get;}
See Also

Reference

ReportException Class
ReportException Members


InnerException Property (ReportException)

InnerException Property (ReportException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : InnerException Property

Gets the Exception instance that caused the current exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InnerException As System.Exception
public System.Exception InnerException {get;}
See Also

Reference

ReportException Class
ReportException Members


Message Property (ReportException)

Message Property (ReportException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : Message Property

Gets a message that describes the current exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Message As System.String
public virtual System.string Message {get;}
See Also

Reference

ReportException Class
ReportException Members


Source Property (ReportException)

Source Property (ReportException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : Source Property

Gets or sets the name of the application or the object that causes the error.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Source As System.String
public virtual System.string Source {get; set;}
See Also

Reference

ReportException Class
ReportException Members


StackTrace Property (ReportException)

StackTrace Property (ReportException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : StackTrace Property

Gets a string representation of the immediate frames on the call stack.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property StackTrace As System.String
public virtual System.string StackTrace {get;}
See Also

Reference

ReportException Class
ReportException Members


TargetSite Property (ReportException)

TargetSite Property (ReportException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : TargetSite Property

Gets the method that throws the current exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
public System.Reflection.MethodBase TargetSite {get;}
See Also

Reference

ReportException Class
ReportException Members


ToString Method (ReportException)

ToString Method (ReportException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportException Class : ToString Method

Creates and returns a string representation of the current exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

ReportException Class
ReportException Members


GrapeCity.ActiveReports.ReportsCore.Configuration Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.ReportsCore.Configuration Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports.ReportsCore.Configuration Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.ReportsCore.Configuration.MapTileServerConfiguration
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.ReportsCore.Rendering.Components.Map.TileProviders.TileProviderInfo
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


ReportScriptException Class Methods

ReportScriptException Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : ReportScriptException Class

For a list of all members of this type, see ReportScriptException members.

Public Methods
 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the Info with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top
See Also

Reference

ReportScriptException Class
GrapeCity.ActiveReports Namespace
GrapeCity.ActiveReports.v10~GrapeCity.ActiveReports.ActiveReport~Script


ReportScriptException Class Properties

ReportScriptException Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace : ReportScriptException Class

For a list of all members of this type, see ReportScriptException members.

Public Properties
 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from System.Exception)
Public Property | ErrorCode | Error code for future detail processing. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | ErrorData | Error data, depends on error code. (Inherited from GrapeCity.ActiveReports.ReportException)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top
See Also

Reference

ReportScriptException Class
GrapeCity.ActiveReports Namespace
GrapeCity.ActiveReports.v10~GrapeCity.ActiveReports.ActiveReport~Script


Data Property (ReportScriptException)

Data Property (ReportScriptException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : Data Property

Gets a collection of key/value pairs that provide additional user-defined information about the exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Data As System.Collections.IDictionary
public virtual System.Collections.IDictionary Data {get;}
See Also

Reference

ReportScriptException Class
ReportScriptException Members


GetBaseException Method (ReportScriptException)

GetBaseException Method (ReportScriptException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : GetBaseException Method

When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetBaseException() As System.Exception
public virtual System.Exception GetBaseException()
See Also

Reference

ReportScriptException Class
ReportScriptException Members


GetObjectData Method (ReportScriptException)

GetObjectData Method (ReportScriptException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : GetObjectData Method
SerializationInfo.
StreamingContext.

When overridden in a derived class, sets the Info with information about the exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
SerializationInfo.
context
StreamingContext.
See Also

Reference

ReportScriptException Class
ReportScriptException Members


GetType Method (ReportScriptException)

GetType Method (ReportScriptException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : GetType Method

Gets the runtime type of the current instance.

Overload List
Overload | Description
GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
See Also

Reference

ReportScriptException Class
ReportScriptException Members


GetType() Method

GetType() Method

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : GetType() Method

Gets the runtime type of the current instance.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetType() As System.Type
public System.Type GetType()
See Also

Reference

ReportScriptException Class
ReportScriptException Members


HelpLink Property (ReportScriptException)

HelpLink Property (ReportScriptException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : HelpLink Property

Gets or sets a link to the help file associated with this exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property HelpLink As System.String
public virtual System.string HelpLink {get; set;}
See Also

Reference

ReportScriptException Class
ReportScriptException Members


HResult Property (ReportScriptException)

HResult Property (ReportScriptException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : HResult Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HResult As System.Integer
public System.int HResult {get;}
See Also

Reference

ReportScriptException Class
ReportScriptException Members


InnerException Property (ReportScriptException)

InnerException Property (ReportScriptException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : InnerException Property

Gets the Exception instance that caused the current exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InnerException As System.Exception
public System.Exception InnerException {get;}
See Also

Reference

ReportScriptException Class
ReportScriptException Members


Message Property (ReportScriptException)

Message Property (ReportScriptException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : Message Property

Gets a message that describes the current exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Message As System.String
public virtual System.string Message {get;}
See Also

Reference

ReportScriptException Class
ReportScriptException Members


Source Property (ReportScriptException)

Source Property (ReportScriptException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : Source Property

Gets or sets the name of the application or the object that causes the error.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Source As System.String
public virtual System.string Source {get; set;}
See Also

Reference

ReportScriptException Class
ReportScriptException Members


StackTrace Property (ReportScriptException)

StackTrace Property (ReportScriptException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : StackTrace Property

Gets a string representation of the immediate frames on the call stack.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property StackTrace As System.String
public virtual System.string StackTrace {get;}
See Also

Reference

ReportScriptException Class
ReportScriptException Members


TargetSite Property (ReportScriptException)

TargetSite Property (ReportScriptException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : TargetSite Property

Gets the method that throws the current exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TargetSite As System.Reflection.MethodBase
public System.Reflection.MethodBase TargetSite {get;}
See Also

Reference

ReportScriptException Class
ReportScriptException Members


ToString Method (ReportScriptException)

ToString Method (ReportScriptException)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > ReportScriptException Class : ToString Method

Creates and returns a string representation of the current exception.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

ReportScriptException Class
ReportScriptException Members


Capacity Property (SectionCollection)

Capacity Property (SectionCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Capacity Property
Gets or sets the number of elements that the SectionCollection can contain.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

SectionCollection Class
SectionCollection Members


Count Property (SectionCollection)

Count Property (SectionCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : Count Property
Gets the number of elements contained in the SectionCollection instance.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

SectionCollection Class
SectionCollection Members


IndexOf Method (SectionCollection)

IndexOf Method (SectionCollection)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : IndexOf Method

Determines the specific index of the specified section in the collection.

Overload List
Overload | Description
IndexOf | Determines the specific index of the specified section in the collection.
Example
  • C#
private void rpt_ReportEnd(object sender, System.EventArgs eArgs)
{
    System.Windows.Forms.MessageBox.Show(this.Sections.IndexOf(this.Sections["detail"]).ToString());
}
  • Visual Basic
Private Sub rpt_ReportEnd(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.ReportEnd
    MsgBox(Me.Sections.IndexOf(Me.Sections("Detail1")).ToString)
End Sub
See Also

Reference

SectionCollection Class
SectionCollection Members


InsertPageHF Method

InsertPageHF Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : InsertPageHF Method
Inserts a page header and a matching page footer into the SectionCollection.
Overload List
Overload | Description
InsertPageHF | Inserts a page header and a page matching footer into the SectionCollection with the default names PageHeader1, PageFooter1; where 1 is an order number.
Remarks
Only one PageHeader and one PageFooter section are allowed in a report layout.
Example
  • C#
GrapeCity.ActiveReports.SectionReport rpt = New GrapeCity.ActiveReports.SectionReport();
    rpt.Sections.Add(GrapeCity.ActiveReports.SectionReport.SectionType.Detail,"Detail");
    rpt.Sections.InsertPageHF();
    rpt.Sections[0].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Sections[1].BackColor = System.Drawing.Color.Orchid;
    rpt.Sections[2].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
  • Visual Basic
Dim rpt As New GrapeCity.ActiveReports.SectionReport
    rpt.Sections.Add(GrapeCity.ActiveReports.SectionReport.SectionType.Detail, "Detail")
    rpt.Sections.InsertPageHF()
    rpt.Sections(0).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Sections(1).BackColor = System.Drawing.Color.Orchid
    rpt.Sections(2).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
See Also

Reference

SectionCollection Class
SectionCollection Members
PageHeader Class
PageFooter Class
Section Class


InsertReportHF Method

InsertReportHF Method
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : InsertReportHF Method
Inserts a report header and a matching report footer into the SectionCollection.
Overload List
Overload | Description
InsertReportHF | Inserts a report header and a matching report footer into the SectionCollection.
Remarks
Only one ReportHeader and one ReportFooter section are allowed in a report layout.
Example
  • C#
GrapeCity.ActiveReports.SectionReport rpt = New GrapeCity.SectionReports.ActiveReport();
    rpt.Sections.Add(GrapeCity.ActiveReports.SectionReport.SectionType.Detail,"Detail");
    rpt.Sections.InsertReportHF();
    rpt.Sections[0].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Sections[1].BackColor = System.Drawing.Color.Orchid;
    rpt.Sections[2].BackColor = System.Drawing.Color.DarkOrchid;
    rpt.Run();
    this.Viewer1.Document = rpt.Document;
  • Visual Basic
Dim rpt As New GrapeCity.ActiveReports.SectionReport
    rpt.Sections.Add(GrapeCity.ActiveReports.SectionReport.SectionType.Detail, "Detail")
    rpt.Sections.InsertReportHF()
    rpt.Sections(0).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Sections(1).BackColor = System.Drawing.Color.Orchid
    rpt.Sections(2).BackColor = System.Drawing.Color.DarkOrchid
    rpt.Run()
    Me.Viewer1.Document = rpt.Document
See Also

Reference

SectionCollection Class
SectionCollection Members
ReportHeader Class
ReportFooter Class
Section Class


RemoveAt Method (SectionCollection)

RemoveAt Method (SectionCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionCollection Class : RemoveAt Method
Inherited from System.Collections.CollectionBase.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
See Also

Reference

SectionCollection Class
SectionCollection Members


Dispose Method (ARControl)

Dispose Method (ARControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ARControl Class : Dispose Method
Releases the control instance from memory.
Overload List
Overload | Description
Dispose | Releases the control instance from memory.
See Also

Reference

ARControl Class
ARControl Members


Barcode Class Methods

Barcode Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Barcode Class

For a list of all members of this type, see Barcode members.

Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

Barcode Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Dispose Method (ChartControl)

Dispose Method (ChartControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ChartControl Class : Dispose Method
Releases the control instance from memory.
Overload List
Overload | Description
Dispose | Releases the control instance from memory.
See Also

Reference

ChartControl Class
ChartControl Members


CheckBox Class Methods

CheckBox Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CheckBox Class

For a list of all members of this type, see CheckBox members.

Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

CheckBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Capacity Property (ControlCollection)

Capacity Property (ControlCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Capacity Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

ControlCollection Class
ControlCollection Members


Count Property (ControlCollection)

Count Property (ControlCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Count Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

ControlCollection Class
ControlCollection Members


Dispose Method (ControlCollection)

Dispose Method (ControlCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ControlCollection Class : Dispose Method
Releases an instance of the control from the memory.
Overload List
Overload | Description
Dispose | Releases an instance of the control from the memory.
See Also

Reference

ControlCollection Class
ControlCollection Members


CrossSectionControl Class Methods

CrossSectionControl Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionControl Class

For a list of all members of this type, see CrossSectionControl members.

Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

CrossSectionControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CrossSectionLine Class Methods

CrossSectionLine Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionLine Class

For a list of all members of this type, see CrossSectionLine members.

Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

CrossSectionLine Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CrossSectionLine Class Properties

CrossSectionLine Class Properties

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CrossSectionLine Class

For a list of all members of this type, see CrossSectionLine members.

Public Properties
 | Name | Description
Public Property | Bounds | Sets or returns a rectangle that defines the location and size of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | End | The ending position of the cross section control in the footer section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Height | Gets or sets the height of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Left | Gets or sets the left position of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | LineColor | Gets or sets the color of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | LineStyle | Gets or sets the pen style used to draw the line. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | LineWeight | Gets or sets the pen width of the line in pixels. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Name | Gets or sets the name of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Parent | Gets a reference to the parent section of the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Start | The starting position of the cross section control in the header section. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Tag | Gets or sets user-defined information to be persisted with the control. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Top | Gets or sets, in inches, the top position of the control relative to the section that contains it. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Public Property | Visible | Sets or returns a value indicating whether the control will be printed. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Property | Width | Gets or sets the width of the control in inches. (Inherited from GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl)
Top
See Also

Reference

CrossSectionLine Class
GrapeCity.ActiveReports.SectionReportModel Namespace


CustomControl Class Methods

CustomControl Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : CustomControl Class

For a list of all members of this type, see CustomControl members.

Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose() | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

CustomControl Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Dispose Method (CustomControl)

Dispose Method (CustomControl)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > CustomControl Class : Dispose Method
Releases unmanaged and - optionally - managed resources.
Releases the instance of the CustomControl from memory.
Overload List
Overload | Description
Dispose() | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
See Also

Reference

CustomControl Class
CustomControl Members


Detail Class Events

Detail Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Detail Class

For a list of all members of this type, see Detail members.

Public Events
 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

Detail Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Detail Class Methods

Detail Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Detail Class

For a list of all members of this type, see Detail members.

Public Methods
 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | Dispose | Releases the section instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

Detail Class
GrapeCity.ActiveReports.SectionReportModel Namespace


GroupFooter Class Events

GroupFooter Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupFooter Class

For a list of all members of this type, see GroupFooter members.

Public Events
 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

GroupFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


GroupFooter Class Methods

GroupFooter Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupFooter Class

For a list of all members of this type, see GroupFooter members.

Public Methods
 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | Dispose | Releases the section instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

GroupFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


GroupHeader Class Events

GroupHeader Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupHeader Class

For a list of all members of this type, see GroupHeader members.

Public Events
 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

GroupHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


GroupHeader Class Methods

GroupHeader Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : GroupHeader Class

For a list of all members of this type, see GroupHeader members.

Public Methods
 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | Dispose | Releases the section instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

GroupHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Label Class Methods

Label Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Label Class

For a list of all members of this type, see Label members.

Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

Label Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Line Class Methods

Line Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Line Class

For a list of all members of this type, see Line members.

Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

Line Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Dispose Method (OleObject)

Dispose Method (OleObject)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > OleObject Class : Dispose Method
Releases unmanaged and - optionally - managed resources.
Removes the instance of the OleObject from memory.
Overload List
Overload | Description
Dispose() | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
See Also

Reference

OleObject Class
OleObject Members


PageBreak Class Methods

PageBreak Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageBreak Class

For a list of all members of this type, see PageBreak members.

Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

PageBreak Class
GrapeCity.ActiveReports.SectionReportModel Namespace


PageFooter Class Events

PageFooter Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageFooter Class

For a list of all members of this type, see PageFooter members.

Public Events
 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

PageFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


PageFooter Class Methods

PageFooter Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageFooter Class

For a list of all members of this type, see PageFooter members.

Public Methods
 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | Dispose | Releases the section instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

PageFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


PageHeader Class Events

PageHeader Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageHeader Class

For a list of all members of this type, see PageHeader members.

Public Events
 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

PageHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


PageHeader Class Methods

PageHeader Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : PageHeader Class

For a list of all members of this type, see PageHeader members.

Public Methods
 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | Dispose | Releases the section instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

PageHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Capacity Property (ParameterCollection)

Capacity Property (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Capacity Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capacity As System.Integer
public System.int Capacity {get; set;}
See Also

Reference

ParameterCollection Class
ParameterCollection Members


Clear Method (ParameterCollection)

Clear Method (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Clear Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

ParameterCollection Class
ParameterCollection Members


Count Property (ParameterCollection)

Count Property (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Count Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

ParameterCollection Class
ParameterCollection Members


Dispose Method (ParameterCollection)

Dispose Method (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : Dispose Method
Releases the ParameterCollection from memory.
Releases the ParameterCollection from memory.
Overload List
Overload | Description
Dispose | Releases the ParameterCollection from memory.
See Also

Reference

ParameterCollection Class
ParameterCollection Members


RemoveAt Method (ParameterCollection)

RemoveAt Method (ParameterCollection)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > ParameterCollection Class : RemoveAt Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
See Also

Reference

ParameterCollection Class
ParameterCollection Members


Dispose Method (Parameter)

Dispose Method (Parameter)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Parameter Class : Dispose Method
Releases the parameter from memory.
Releases the parameter from memory.
Overload List
Overload | Description
Dispose | Releases the parameter from memory.
See Also

Reference

Parameter Class
Parameter Members


Dispose Method (Picture)

Dispose Method (Picture)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Picture Class : Dispose Method
Releases unmanaged and - optionally - managed resources.
Releases the control instance from memory.
Overload List
Overload | Description
Dispose() | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
See Also

Reference

Picture Class
Picture Members


ReportFooter Class Events

ReportFooter Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportFooter Class

For a list of all members of this type, see ReportFooter members.

Public Events
 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

ReportFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportFooter Class Methods

ReportFooter Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportFooter Class

For a list of all members of this type, see ReportFooter members.

Public Methods
 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | Dispose | Releases the section instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

ReportFooter Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportHeader Class Events

ReportHeader Class Events

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportHeader Class

For a list of all members of this type, see ReportHeader members.

Public Events
 | Name | Description
Public Event | AfterPrint | Occurs after the section has been rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | BeforePrint | Occurs immediately before the section is rendered to the page. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Event | Format | Occurs after the section's data is loaded and bound to the section's controls, but before the section is rendered to the canvas. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

ReportHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportHeader Class Methods

ReportHeader Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportHeader Class

For a list of all members of this type, see ReportHeader members.

Public Methods
 | Name | Description
Public Method | AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | Dispose | Releases the section instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Public Method | SizeToFit | Overloaded. Sizes the section to fit the contained controls. (Inherited from GrapeCity.ActiveReports.SectionReportModel.Section)
Top
See Also

Reference

ReportHeader Class
GrapeCity.ActiveReports.SectionReportModel Namespace


ReportInfo Class Methods

ReportInfo Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : ReportInfo Class

For a list of all members of this type, see ReportInfo members.

Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

ReportInfo Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Dispose Method (RichTextBox)

Dispose Method (RichTextBox)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : Dispose Method
Releases unmanaged and - optionally - managed resources.
Releases the control instance from memory.
Overload List
Overload | Description
Dispose() | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
See Also

Reference

RichTextBox Class
RichTextBox Members


Load Method (RichTextBox)

Load Method (RichTextBox)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > RichTextBox Class : Load Method
Loads the contents of a stream into the RichTextBox control.
Overload List
Overload | Description
Load | Loads a stream of Rtf, Text or Html file.
Remarks

The data loaded from the stream replaces the existing text in the RichTextBox.

Example
To use this sample code, you will need a sample.rtf file and a sample.html file as well as two RichTextBox controls on an ActiveReport.
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    System.IO.FileStream streamR = new System.IO.FileStream(System.Windows.Forms.Application.StartupPath + "\\sample.rtf", System.IO.FileMode.Open);
    rtfRTF.Load(streamR, RichTextType.Rtf);

    System.IO.FileStream streamH = new System.IO.FileStream(System.Windows.Forms.Application.StartupPath + "\\sample.html", System.IO.FileMode.Open);
    rtfHTML.Load(streamH, RichTextType.Html);
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Dim streamR As New System.IO.FileStream(Application.StartupPath & "\sample.rtf", IO.FileMode.Open)
    rtfRTF.Load(streamR, RichTextType.Rtf)
    Dim streamH As New System.IO.FileStream(Application.StartupPath & "\sample.html", IO.FileMode.Open)
    rtfHTML.Load(streamH, RichTextType.Html)
End Sub
See Also

Reference

RichTextBox Class
RichTextBox Members
ActiveReports6~GrapeCity.ActiveReports.RichTextBox~Clear
ActiveReports6~GrapeCity.ActiveReports.RichTextType


Section Constructor

Section Constructor

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Section Constructor
Initializes a new instance of the Section class.
Overload List
Overload | Description
Section Constructor | Initializes a new instance of the Section class.
See Also

Reference

Section Class
Section Members


AddBookmark Method (Section)

AddBookmark Method (Section)
Example

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : AddBookmark Method
Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event.
Overload List
Overload | Description
AddBookmark | Adds a bookmark in the report's table of contents. The bookmark will position the view at the start of the section if the bookmark is added in the section's Format event. Bookmark text to be displayed in the table of contents treeview.
Remarks

This method is used while the report is running. The method should be called in either the section's Format or BeforePrint events.

Calling this method in the Format event of the section creates a bookmark at the top of the section. Calling the method in the BeforePrint event of the section creates a bookmark at the bottom of the section.

Example
  • C#
private void Detail_Format(object sender, System.EventArgs eArgs)
{
    Detail.AddBookmark(txtCategoryName.Text + "\\" + txtProductName.Text);
}
  • Visual Basic
Private Sub Detail_Format(ByVal sender As Object, ByVal e As System.EventArgs) Handles Detail.Format
    Me.Detail.AddBookmark(txtCategoryName.Text + "\" + txtProductName.Text)
End Sub
See Also

Reference

Section Class
Section Members

How To

Add Bookmarks


Dispose Method (Section)

Dispose Method (Section)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > Section Class : Dispose Method
Releases the section instance from memory.
Releases the section instance from memory.
Overload List
Overload | Description
Dispose | Releases the section instance from memory.
See Also

Reference

Section Class
Section Members


Shape Class Methods

Shape Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : Shape Class

For a list of all members of this type, see Shape members.

Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

Shape Class
GrapeCity.ActiveReports.SectionReportModel Namespace


SubReport Class Methods

SubReport Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : SubReport Class

For a list of all members of this type, see SubReport members.

Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose() | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

SubReport Class
GrapeCity.ActiveReports.SectionReportModel Namespace


Dispose Method (SubReport)

Dispose Method (SubReport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace > SubReport Class : Dispose Method
Releases unmanaged and - optionally - managed resources.
Releases the SubReport object from memory.
Overload List
Overload | Description
Dispose() | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
See Also

Reference

SubReport Class
SubReport Members


TextBox Class Methods

TextBox Class Methods

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports.SectionReportModel Namespace : TextBox Class

For a list of all members of this type, see TextBox members.

Public Methods
 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | Dispose | Releases the control instance from memory. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Public Method | SetBounds | Sets the bounds of the control to the specified rectangle. (Inherited from GrapeCity.ActiveReports.SectionReportModel.ARControl)
Top
See Also

Reference

TextBox Class
GrapeCity.ActiveReports.SectionReportModel Namespace


GrapeCity.ActiveReports.SectionReportModel Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.SectionReportModel Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports.SectionReportModel Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.SectionReportModel.ARControl
GrapeCity.ActiveReports.SectionReportModel.Barcode
GrapeCity.ActiveReports.SectionReportModel.ChartControl
GrapeCity.ActiveReports.SectionReportModel.CheckBox
GrapeCity.ActiveReports.SectionReportModel.CrossSectionControl
GrapeCity.ActiveReports.SectionReportModel.CrossSectionBox
GrapeCity.ActiveReports.SectionReportModel.CrossSectionLine
GrapeCity.ActiveReports.SectionReportModel.CustomControl
GrapeCity.ActiveReports.SectionReportModel.Label
GrapeCity.ActiveReports.SectionReportModel.Line
GrapeCity.ActiveReports.SectionReportModel.OleObject
GrapeCity.ActiveReports.SectionReportModel.PageBreak
GrapeCity.ActiveReports.SectionReportModel.Picture
GrapeCity.ActiveReports.SectionReportModel.ReportInfo
GrapeCity.ActiveReports.SectionReportModel.RichTextBox
GrapeCity.ActiveReports.SectionReportModel.Shape
GrapeCity.ActiveReports.SectionReportModel.SubReport
GrapeCity.ActiveReports.SectionReportModel.TextBox
GrapeCity.ActiveReports.SectionReportModel.Parameter
GrapeCity.ActiveReports.SectionReportModel.Section
GrapeCity.ActiveReports.SectionReportModel.Detail
GrapeCity.ActiveReports.SectionReportModel.GroupFooter
GrapeCity.ActiveReports.SectionReportModel.GroupHeader
GrapeCity.ActiveReports.SectionReportModel.PageFooter
GrapeCity.ActiveReports.SectionReportModel.PageHeader
GrapeCity.ActiveReports.SectionReportModel.ReportFooter
GrapeCity.ActiveReports.SectionReportModel.ReportHeader
GrapeCity.ActiveReports.SectionReportModel.Style
GrapeCity.ActiveReports.SectionReportModel.StyleSheet
System.Collections.CollectionBase
GrapeCity.ActiveReports.SectionReportModel.ControlCollection
GrapeCity.ActiveReports.SectionReportModel.ParameterCollection
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


CreateObjRef Method (SectionReport)

CreateObjRef Method (SectionReport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : CreateObjRef Method

Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

SectionReport Class
SectionReport Members


Dispose Method (SectionReport)

Dispose Method (SectionReport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : Dispose Method
Releases the report instance from memory.
Overload List
Overload | Description
Dispose | Releases the report instance from memory.
See Also

Reference

SectionReport Class
SectionReport Members


GetLifetimeService Method (SectionReport)

GetLifetimeService Method (SectionReport)

GrapeCity.ActiveReports.v10 Assembly > GrapeCity.ActiveReports Namespace > SectionReport Class : GetLifetimeService Method

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

SectionReport Class
SectionReport Members


GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports.v10) Inheritance Hierarchy

GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports.v10) Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.ActiveReports Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.PageSettings
GrapeCity.ActiveReports.SystemPrinter
System.Collections.CollectionBase
GrapeCity.ActiveReports.SectionCollection
System.EventArgs
GrapeCity.ActiveReports.LocateCredentialsEventArgs
GrapeCity.ActiveReports.LocateDataSourceEventArgs
GrapeCity.ActiveReports.SectionReport.FetchEventArgs
System.Exception
System.ApplicationException
GrapeCity.ActiveReports.ReportException
GrapeCity.ActiveReports.Expressions.ExpressionObjectModel.ReportParameterException
GrapeCity.ActiveReports.InvalidReportDefinitionException
GrapeCity.ActiveReports.PageReportModel.MasterReportNotFoundException
GrapeCity.ActiveReports.ReportDataException
GrapeCity.ActiveReports.ReportScriptException
System.MarshalByRefObject
GrapeCity.ActiveReports.SectionReport
System.ComponentModel.Component
GrapeCity.ActiveReports.PageReport
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


GrapeCity.BI.Data.DataProviders Namespace Inheritance Hierarchy

GrapeCity.BI.Data.DataProviders Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.v10 Assembly : GrapeCity.BI.Data.DataProviders Namespace
Inheritance Hierarchy
System.Object
System.ValueType
GrapeCity.BI.Data.DataProviders.DataProviderInfo
See Also

Reference

GrapeCity.ActiveReports.v10 Assembly


GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly
Namespaces
Namespace | Description
GrapeCity.ActiveReports | The GrapeCity.ActiveReports namespace contains the viewer class and its details.


Viewer Class Methods

Viewer Class Methods

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace : Viewer Class

For a list of all members of this type, see Viewer members.

Public Methods
 | Name | Description
Public Method | AddHandler | (Inherited from System.Windows.UIElement)
Public Method | ApplyTemplate | (Inherited from System.Windows.Controls.Control)
Public Method | Arrange | (Inherited from System.Windows.UIElement)
Public Method | CaptureMouse | (Inherited from System.Windows.UIElement)
Public Method | ClearValue | (Inherited from System.Windows.DependencyObject)
Public Method | FindName | (Inherited from System.Windows.FrameworkElement)
Public Method | Focus | (Inherited from System.Windows.Controls.Control)
Public Method | GetAnimationBaseValue | (Inherited from System.Windows.DependencyObject)
Public Method | GetBindingExpression | (Inherited from System.Windows.FrameworkElement)
Public Method | GetValue | (Inherited from System.Windows.DependencyObject)
Public Method | InvalidateArrange | (Inherited from System.Windows.UIElement)
Public Method | InvalidateMeasure | (Inherited from System.Windows.UIElement)
Public Method | Measure | (Inherited from System.Windows.UIElement)
Public Method | OnApplyTemplate | (Inherited from System.Windows.FrameworkElement)
Public Method | ReadLocalValue | (Inherited from System.Windows.DependencyObject)
Public Method | ReleaseMouseCapture | (Inherited from System.Windows.UIElement)
Public Method | RemoveHandler | (Inherited from System.Windows.UIElement)
Public Method | SetBinding | (Inherited from System.Windows.FrameworkElement)
Public Method | SetValue | (Inherited from System.Windows.DependencyObject)
Public Method | TransformToVisual | (Inherited from System.Windows.UIElement)
Public Method | UpdateLayout | (Inherited from System.Windows.UIElement)
Top
See Also

Reference

Viewer Class
GrapeCity.ActiveReports Namespace


ActualHeight Property (Viewer)

ActualHeight Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : ActualHeight Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ActualHeight As System.Double
public System.double ActualHeight {get;}
See Also

Reference

Viewer Class
Viewer Members


ActualWidth Property (Viewer)

ActualWidth Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : ActualWidth Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ActualWidth As System.Double
public System.double ActualWidth {get;}
See Also

Reference

Viewer Class
Viewer Members


AddHandler Method (Viewer)

AddHandler Method (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : AddHandler Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddHandler( _
   ByVal routedEvent As System.Windows.RoutedEvent, _
   ByVal handler As System.Delegate, _
   ByVal handledEventsToo As System.Boolean _
)
public void AddHandler(
   System.Windows.RoutedEvent routedEvent,
   System.Delegate handler,
   System.bool handledEventsToo
)

Parameters

routedEvent
handler
handledEventsToo
See Also

Reference

Viewer Class
Viewer Members


AllowDrop Property (Viewer)

AllowDrop Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : AllowDrop Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AllowDrop As System.Boolean
public System.bool AllowDrop {get; set;}
See Also

Reference

Viewer Class
Viewer Members


ApplyTemplate Method (Viewer)

ApplyTemplate Method (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : ApplyTemplate Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ApplyTemplate() As System.Boolean
public System.bool ApplyTemplate()
See Also

Reference

Viewer Class
Viewer Members


Arrange Method (Viewer)

Arrange Method (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Arrange Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Arrange( _
   ByVal finalRect As System.Windows.Rect _
)
public void Arrange(
   System.Windows.Rect finalRect
)

Parameters

finalRect
See Also

Reference

Viewer Class
Viewer Members


Background Property (Viewer)

Background Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Background Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Background As System.Windows.Media.Brush
public System.Windows.Media.Brush Background {get; set;}
See Also

Reference

Viewer Class
Viewer Members


BindingValidationError Event

BindingValidationError Event

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : BindingValidationError Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BindingValidationError As System.EventHandler(Of ValidationErrorEventArgs)
public event System.EventHandler<ValidationErrorEventArgs> BindingValidationError
Event Data

The event handler receives an argument of type System.Windows.Controls.ValidationErrorEventArgs containing data related to this event. The following ValidationErrorEventArgs properties provide information specific to this event.

Property | Description
Action | Gets the state of the validation error.
Error | Gets the validation error that caused the System.Windows.FrameworkElement.BindingValidationError event.
Handled | Gets or sets the value that marks the routed event as handled.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
See Also

Reference

Viewer Class
Viewer Members


BorderBrush Property (Viewer)

BorderBrush Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : BorderBrush Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BorderBrush As System.Windows.Media.Brush
public System.Windows.Media.Brush BorderBrush {get; set;}
See Also

Reference

Viewer Class
Viewer Members


BorderThickness Property (Viewer)

BorderThickness Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : BorderThickness Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BorderThickness As System.Windows.Thickness
public System.Windows.Thickness BorderThickness {get; set;}
See Also

Reference

Viewer Class
Viewer Members


CacheMode Property (Viewer)

CacheMode Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : CacheMode Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CacheMode As System.Windows.Media.CacheMode
public System.Windows.Media.CacheMode CacheMode {get; set;}
See Also

Reference

Viewer Class
Viewer Members


CaptureMouse Method (Viewer)

CaptureMouse Method (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : CaptureMouse Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CaptureMouse() As System.Boolean
public System.bool CaptureMouse()
See Also

Reference

Viewer Class
Viewer Members


ClearValue Method (Viewer)

ClearValue Method (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : ClearValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ClearValue( _
   ByVal dp As System.Windows.DependencyProperty _
)
public void ClearValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

Viewer Class
Viewer Members


Clip Property (Viewer)

Clip Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Clip Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Clip As System.Windows.Media.Geometry
public System.Windows.Media.Geometry Clip {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Cursor Property (Viewer)

Cursor Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Cursor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Cursor As System.Windows.Input.Cursor
public System.Windows.Input.Cursor Cursor {get; set;}
See Also

Reference

Viewer Class
Viewer Members


DataContext Property (Viewer)

DataContext Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : DataContext Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataContext As System.Object
public System.object DataContext {get; set;}
See Also

Reference

Viewer Class
Viewer Members


DesiredSize Property (Viewer)

DesiredSize Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : DesiredSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DesiredSize As System.Windows.Size
public System.Windows.Size DesiredSize {get;}
See Also

Reference

Viewer Class
Viewer Members


Dispatcher Property (Viewer)

Dispatcher Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Dispatcher Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Dispatcher As System.Windows.Threading.Dispatcher
public System.Windows.Threading.Dispatcher Dispatcher {get;}
See Also

Reference

Viewer Class
Viewer Members


DragEnter Event (Viewer)

DragEnter Event (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : DragEnter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragEnter As System.Windows.DragEventHandler
public event System.Windows.DragEventHandler DragEnter
Event Data

The event handler receives an argument of type System.Windows.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
Data | Gets a data object (implements System.Windows.IDataObject) that contains the data associated with the corresponding drag event. This value is not useful in all event cases; see Remarks.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
See Also

Reference

Viewer Class
Viewer Members


DragLeave Event (Viewer)

DragLeave Event (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : DragLeave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragLeave As System.Windows.DragEventHandler
public event System.Windows.DragEventHandler DragLeave
Event Data

The event handler receives an argument of type System.Windows.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
Data | Gets a data object (implements System.Windows.IDataObject) that contains the data associated with the corresponding drag event. This value is not useful in all event cases; see Remarks.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
See Also

Reference

Viewer Class
Viewer Members


DragOver Event (Viewer)

DragOver Event (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : DragOver Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragOver As System.Windows.DragEventHandler
public event System.Windows.DragEventHandler DragOver
Event Data

The event handler receives an argument of type System.Windows.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
Data | Gets a data object (implements System.Windows.IDataObject) that contains the data associated with the corresponding drag event. This value is not useful in all event cases; see Remarks.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
See Also

Reference

Viewer Class
Viewer Members


Drop Event (Viewer)

Drop Event (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Drop Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Drop As System.Windows.DragEventHandler
public event System.Windows.DragEventHandler Drop
Event Data

The event handler receives an argument of type System.Windows.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
Data | Gets a data object (implements System.Windows.IDataObject) that contains the data associated with the corresponding drag event. This value is not useful in all event cases; see Remarks.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
See Also

Reference

Viewer Class
Viewer Members


Effect Property (Viewer)

Effect Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Effect Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Effect As System.Windows.Media.Effects.Effect
public System.Windows.Media.Effects.Effect Effect {get; set;}
See Also

Reference

Viewer Class
Viewer Members


FindName Method (Viewer)

FindName Method (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : FindName Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function FindName( _
   ByVal name As System.String _
) As System.Object
public System.object FindName(
   System.string name
)

Parameters

name
See Also

Reference

Viewer Class
Viewer Members


FlowDirection Property (Viewer)

FlowDirection Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : FlowDirection Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FlowDirection As System.Windows.FlowDirection
public System.Windows.FlowDirection FlowDirection {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Focus Method (Viewer)

Focus Method (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Focus Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Focus() As System.Boolean
public System.bool Focus()
See Also

Reference

Viewer Class
Viewer Members


FontFamily Property (Viewer)

FontFamily Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : FontFamily Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontFamily As System.Windows.Media.FontFamily
public System.Windows.Media.FontFamily FontFamily {get; set;}
See Also

Reference

Viewer Class
Viewer Members


FontSize Property (Viewer)

FontSize Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : FontSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontSize As System.Double
public System.double FontSize {get; set;}
See Also

Reference

Viewer Class
Viewer Members


FontStretch Property (Viewer)

FontStretch Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : FontStretch Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontStretch As System.Windows.FontStretch
public System.Windows.FontStretch FontStretch {get; set;}
See Also

Reference

Viewer Class
Viewer Members


FontStyle Property (Viewer)

FontStyle Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : FontStyle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontStyle As System.Windows.FontStyle
public System.Windows.FontStyle FontStyle {get; set;}
See Also

Reference

Viewer Class
Viewer Members


FontWeight Property (Viewer)

FontWeight Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : FontWeight Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontWeight As System.Windows.FontWeight
public System.Windows.FontWeight FontWeight {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Foreground Property (Viewer)

Foreground Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Foreground Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Foreground As System.Windows.Media.Brush
public System.Windows.Media.Brush Foreground {get; set;}
See Also

Reference

Viewer Class
Viewer Members


GetAnimationBaseValue Method (Viewer)

GetAnimationBaseValue Method (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : GetAnimationBaseValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetAnimationBaseValue( _
   ByVal dp As System.Windows.DependencyProperty _
) As System.Object
public System.object GetAnimationBaseValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

Viewer Class
Viewer Members


GetBindingExpression Method (Viewer)

GetBindingExpression Method (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : GetBindingExpression Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetBindingExpression( _
   ByVal dp As System.Windows.DependencyProperty _
) As System.Windows.Data.BindingExpression
public System.Windows.Data.BindingExpression GetBindingExpression(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

Viewer Class
Viewer Members


GetValue Method (Viewer)

GetValue Method (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : GetValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetValue( _
   ByVal dp As System.Windows.DependencyProperty _
) As System.Object
public System.object GetValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

Viewer Class
Viewer Members


GotFocus Event (Viewer)

GotFocus Event (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : GotFocus Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event GotFocus As System.Windows.RoutedEventHandler
public event System.Windows.RoutedEventHandler GotFocus
Event Data

The event handler receives an argument of type System.Windows.RoutedEventArgs containing data related to this event. The following RoutedEventArgs properties provide information specific to this event.

Property | Description
OriginalSource | Gets a reference to the object that raised the event.
See Also

Reference

Viewer Class
Viewer Members


Height Property (Viewer)

Height Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Height Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As System.Double
public System.double Height {get; set;}
See Also

Reference

Viewer Class
Viewer Members


HorizontalAlignment Property (Viewer)

HorizontalAlignment Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : HorizontalAlignment Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HorizontalAlignment As System.Windows.HorizontalAlignment
public System.Windows.HorizontalAlignment HorizontalAlignment {get; set;}
See Also

Reference

Viewer Class
Viewer Members


HorizontalContentAlignment Property (Viewer)

HorizontalContentAlignment Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : HorizontalContentAlignment Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HorizontalContentAlignment As System.Windows.HorizontalAlignment
public System.Windows.HorizontalAlignment HorizontalContentAlignment {get; set;}
See Also

Reference

Viewer Class
Viewer Members


InvalidateArrange Method (Viewer)

InvalidateArrange Method (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : InvalidateArrange Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub InvalidateArrange()
public void InvalidateArrange()
See Also

Reference

Viewer Class
Viewer Members


InvalidateMeasure Method (Viewer)

InvalidateMeasure Method (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : InvalidateMeasure Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub InvalidateMeasure()
public void InvalidateMeasure()
See Also

Reference

Viewer Class
Viewer Members


IsEnabled Property (Viewer)

IsEnabled Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : IsEnabled Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsEnabled As System.Boolean
public System.bool IsEnabled {get; set;}
See Also

Reference

Viewer Class
Viewer Members


IsEnabledChanged Event (Viewer)

IsEnabledChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : IsEnabledChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event IsEnabledChanged As System.Windows.DependencyPropertyChangedEventHandler
public event System.Windows.DependencyPropertyChangedEventHandler IsEnabledChanged
Event Data

The event handler receives an argument of type System.Windows.DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.
See Also

Reference

Viewer Class
Viewer Members


IsHitTestVisible Property (Viewer)

IsHitTestVisible Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : IsHitTestVisible Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsHitTestVisible As System.Boolean
public System.bool IsHitTestVisible {get; set;}
See Also

Reference

Viewer Class
Viewer Members


IsTabStop Property (Viewer)

IsTabStop Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : IsTabStop Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsTabStop As System.Boolean
public System.bool IsTabStop {get; set;}
See Also

Reference

Viewer Class
Viewer Members


KeyDown Event (Viewer)

KeyDown Event (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : KeyDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event KeyDown As System.Windows.Input.KeyEventHandler
public event System.Windows.Input.KeyEventHandler KeyDown
Event Data

The event handler receives an argument of type System.Windows.Input.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled. A true value for Handled prevents most handlers along the event route from handling the same event again.
Key | Gets the keyboard key associated with the event.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
PlatformKeyCode | Gets an integer value that represents the key that is pressed or released (depending on which event is raised). This value is the nonportable key code, which is operating system–specific.
See Also

Reference

Viewer Class
Viewer Members


KeyUp Event (Viewer)

KeyUp Event (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : KeyUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event KeyUp As System.Windows.Input.KeyEventHandler
public event System.Windows.Input.KeyEventHandler KeyUp
Event Data

The event handler receives an argument of type System.Windows.Input.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled. A true value for Handled prevents most handlers along the event route from handling the same event again.
Key | Gets the keyboard key associated with the event.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
PlatformKeyCode | Gets an integer value that represents the key that is pressed or released (depending on which event is raised). This value is the nonportable key code, which is operating system–specific.
See Also

Reference

Viewer Class
Viewer Members


Language Property (Viewer)

Language Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Language Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Language As System.Windows.Markup.XmlLanguage
public System.Windows.Markup.XmlLanguage Language {get; set;}
See Also

Reference

Viewer Class
Viewer Members


LayoutUpdated Event (Viewer)

LayoutUpdated Event (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : LayoutUpdated Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LayoutUpdated As System.EventHandler
public event System.EventHandler LayoutUpdated
See Also

Reference

Viewer Class
Viewer Members


Loaded Event (Viewer)

Loaded Event (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Loaded Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Loaded As System.Windows.RoutedEventHandler
public event System.Windows.RoutedEventHandler Loaded
Event Data

The event handler receives an argument of type System.Windows.RoutedEventArgs containing data related to this event. The following RoutedEventArgs properties provide information specific to this event.

Property | Description
OriginalSource | Gets a reference to the object that raised the event.
See Also

Reference

Viewer Class
Viewer Members


LostFocus Event (Viewer)

LostFocus Event (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : LostFocus Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LostFocus As System.Windows.RoutedEventHandler
public event System.Windows.RoutedEventHandler LostFocus
Event Data

The event handler receives an argument of type System.Windows.RoutedEventArgs containing data related to this event. The following RoutedEventArgs properties provide information specific to this event.

Property | Description
OriginalSource | Gets a reference to the object that raised the event.
See Also

Reference

Viewer Class
Viewer Members


LostMouseCapture Event (Viewer)

LostMouseCapture Event (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : LostMouseCapture Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LostMouseCapture As System.Windows.Input.MouseEventHandler
public event System.Windows.Input.MouseEventHandler LostMouseCapture
Event Data

The event handler receives an argument of type System.Windows.Input.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets an object that reports stylus device information, such as the collection of stylus points associated with the input.
See Also

Reference

Viewer Class
Viewer Members


Margin Property (Viewer)

Margin Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Margin Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Margin As System.Windows.Thickness
public System.Windows.Thickness Margin {get; set;}
See Also

Reference

Viewer Class
Viewer Members


MaxHeight Property (Viewer)

MaxHeight Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : MaxHeight Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaxHeight As System.Double
public System.double MaxHeight {get; set;}
See Also

Reference

Viewer Class
Viewer Members


MaxWidth Property (Viewer)

MaxWidth Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : MaxWidth Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaxWidth As System.Double
public System.double MaxWidth {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Measure Method (Viewer)

Measure Method (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Measure Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Measure( _
   ByVal availableSize As System.Windows.Size _
)
public void Measure(
   System.Windows.Size availableSize
)

Parameters

availableSize
See Also

Reference

Viewer Class
Viewer Members


MinHeight Property (Viewer)

MinHeight Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : MinHeight Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinHeight As System.Double
public System.double MinHeight {get; set;}
See Also

Reference

Viewer Class
Viewer Members


MinWidth Property (Viewer)

MinWidth Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : MinWidth Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinWidth As System.Double
public System.double MinWidth {get; set;}
See Also

Reference

Viewer Class
Viewer Members


MouseEnter Event (Viewer)

MouseEnter Event (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : MouseEnter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseEnter As System.Windows.Input.MouseEventHandler
public event System.Windows.Input.MouseEventHandler MouseEnter
Event Data

The event handler receives an argument of type System.Windows.Input.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets an object that reports stylus device information, such as the collection of stylus points associated with the input.
See Also

Reference

Viewer Class
Viewer Members


MouseLeave Event (Viewer)

MouseLeave Event (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : MouseLeave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseLeave As System.Windows.Input.MouseEventHandler
public event System.Windows.Input.MouseEventHandler MouseLeave
Event Data

The event handler receives an argument of type System.Windows.Input.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets an object that reports stylus device information, such as the collection of stylus points associated with the input.
See Also

Reference

Viewer Class
Viewer Members


MouseLeftButtonDown Event (Viewer)

MouseLeftButtonDown Event (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : MouseLeftButtonDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseLeftButtonDown As System.Windows.Input.MouseButtonEventHandler
public event System.Windows.Input.MouseButtonEventHandler MouseLeftButtonDown
Event Data

The event handler receives an argument of type System.Windows.Input.MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled. A true value for Handled prevents most handlers along the event route from handling the same event again.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.MouseEventArgs)
See Also

Reference

Viewer Class
Viewer Members


MouseLeftButtonUp Event (Viewer)

MouseLeftButtonUp Event (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : MouseLeftButtonUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseLeftButtonUp As System.Windows.Input.MouseButtonEventHandler
public event System.Windows.Input.MouseButtonEventHandler MouseLeftButtonUp
Event Data

The event handler receives an argument of type System.Windows.Input.MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled. A true value for Handled prevents most handlers along the event route from handling the same event again.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.MouseEventArgs)
See Also

Reference

Viewer Class
Viewer Members


MouseMove Event (Viewer)

MouseMove Event (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : MouseMove Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseMove As System.Windows.Input.MouseEventHandler
public event System.Windows.Input.MouseEventHandler MouseMove
Event Data

The event handler receives an argument of type System.Windows.Input.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets an object that reports stylus device information, such as the collection of stylus points associated with the input.
See Also

Reference

Viewer Class
Viewer Members


MouseRightButtonDown Event (Viewer)

MouseRightButtonDown Event (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : MouseRightButtonDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseRightButtonDown As System.Windows.Input.MouseButtonEventHandler
public event System.Windows.Input.MouseButtonEventHandler MouseRightButtonDown
Event Data

The event handler receives an argument of type System.Windows.Input.MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled. A true value for Handled prevents most handlers along the event route from handling the same event again.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.MouseEventArgs)
See Also

Reference

Viewer Class
Viewer Members


MouseRightButtonUp Event (Viewer)

MouseRightButtonUp Event (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : MouseRightButtonUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseRightButtonUp As System.Windows.Input.MouseButtonEventHandler
public event System.Windows.Input.MouseButtonEventHandler MouseRightButtonUp
Event Data

The event handler receives an argument of type System.Windows.Input.MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled. A true value for Handled prevents most handlers along the event route from handling the same event again.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.MouseEventArgs)
See Also

Reference

Viewer Class
Viewer Members


MouseWheel Event (Viewer)

MouseWheel Event (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : MouseWheel Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseWheel As System.Windows.Input.MouseWheelEventHandler
public event System.Windows.Input.MouseWheelEventHandler MouseWheel
Event Data

The event handler receives an argument of type System.Windows.Input.MouseWheelEventArgs containing data related to this event. The following MouseWheelEventArgs properties provide information specific to this event.

Property | Description
Delta | Gets a value that indicates the amount that the mouse wheel rotated relative to its starting state or to the last occurrence of the event.
Handled | Gets or sets a value that marks the routed event as handled, and prevents most handlers along the event route from rehandling the same event.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.MouseEventArgs)
See Also

Reference

Viewer Class
Viewer Members


Name Property (Viewer)

Name Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Name Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}
See Also

Reference

Viewer Class
Viewer Members


OnApplyTemplate Method

OnApplyTemplate Method

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : OnApplyTemplate Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub OnApplyTemplate()
public virtual void OnApplyTemplate()
See Also

Reference

Viewer Class
Viewer Members


Opacity Property (Viewer)

Opacity Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Opacity Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Opacity As System.Double
public System.double Opacity {get; set;}
See Also

Reference

Viewer Class
Viewer Members


OpacityMask Property (Viewer)

OpacityMask Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : OpacityMask Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OpacityMask As System.Windows.Media.Brush
public System.Windows.Media.Brush OpacityMask {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Padding Property (Viewer)

Padding Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Padding Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Padding As System.Windows.Thickness
public System.Windows.Thickness Padding {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Parent Property (Viewer)

Parent Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Parent Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Parent As System.Windows.DependencyObject
public System.Windows.DependencyObject Parent {get;}
See Also

Reference

Viewer Class
Viewer Members


Projection Property (Viewer)

Projection Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Projection Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Projection As System.Windows.Media.Projection
public System.Windows.Media.Projection Projection {get; set;}
See Also

Reference

Viewer Class
Viewer Members


ReadLocalValue Method (Viewer)

ReadLocalValue Method (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : ReadLocalValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ReadLocalValue( _
   ByVal dp As System.Windows.DependencyProperty _
) As System.Object
public System.object ReadLocalValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

Viewer Class
Viewer Members


ReleaseMouseCapture Method (Viewer)

ReleaseMouseCapture Method (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : ReleaseMouseCapture Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ReleaseMouseCapture()
public void ReleaseMouseCapture()
See Also

Reference

Viewer Class
Viewer Members


RemoveHandler Method (Viewer)

RemoveHandler Method (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : RemoveHandler Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveHandler( _
   ByVal routedEvent As System.Windows.RoutedEvent, _
   ByVal handler As System.Delegate _
)
public void RemoveHandler(
   System.Windows.RoutedEvent routedEvent,
   System.Delegate handler
)

Parameters

routedEvent
handler
See Also

Reference

Viewer Class
Viewer Members


RenderSize Property (Viewer)

RenderSize Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : RenderSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property RenderSize As System.Windows.Size
public System.Windows.Size RenderSize {get;}
See Also

Reference

Viewer Class
Viewer Members


RenderTransform Property (Viewer)

RenderTransform Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : RenderTransform Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RenderTransform As System.Windows.Media.Transform
public System.Windows.Media.Transform RenderTransform {get; set;}
See Also

Reference

Viewer Class
Viewer Members


RenderTransformOrigin Property (Viewer)

RenderTransformOrigin Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : RenderTransformOrigin Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RenderTransformOrigin As System.Windows.Point
public System.Windows.Point RenderTransformOrigin {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Resources Property (Viewer)

Resources Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Resources Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Resources As System.Windows.ResourceDictionary
public System.Windows.ResourceDictionary Resources {get; set;}
See Also

Reference

Viewer Class
Viewer Members


SetBinding Method (Viewer)

SetBinding Method (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : SetBinding Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function SetBinding( _
   ByVal dp As System.Windows.DependencyProperty, _
   ByVal binding As System.Windows.Data.Binding _
) As System.Windows.Data.BindingExpressionBase
public System.Windows.Data.BindingExpressionBase SetBinding(
   System.Windows.DependencyProperty dp,
   System.Windows.Data.Binding binding
)

Parameters

dp
binding
See Also

Reference

Viewer Class
Viewer Members


SetValue Method (Viewer)

SetValue Method (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : SetValue Method
Overload List
Overload | Description
SetValue | (Inherited from System.Windows.DependencyObject)
See Also

Reference

Viewer Class
Viewer Members


SetValue(DependencyProperty,Object) Method

SetValue(DependencyProperty,Object) Method

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : SetValue(DependencyProperty,Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetValue( _
   ByVal dp As System.Windows.DependencyProperty, _
   ByVal value As System.Object _
)
public void SetValue(
   System.Windows.DependencyProperty dp,
   System.object value
)

Parameters

dp
value
See Also

Reference

Viewer Class
Viewer Members


SizeChanged Event (Viewer)

SizeChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : SizeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event SizeChanged As System.Windows.SizeChangedEventHandler
public event System.Windows.SizeChangedEventHandler SizeChanged
Event Data

The event handler receives an argument of type System.Windows.SizeChangedEventArgs containing data related to this event. The following SizeChangedEventArgs properties provide information specific to this event.

Property | Description
NewSize | Gets the new size of the object reporting the size change.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
PreviousSize | Gets the previous size of the object reporting the size change.
See Also

Reference

Viewer Class
Viewer Members


Style Property (Viewer)

Style Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Style Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As System.Windows.Style
public System.Windows.Style Style {get; set;}
See Also

Reference

Viewer Class
Viewer Members


TabIndex Property (Viewer)

TabIndex Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : TabIndex Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TabIndex As System.Integer
public System.int TabIndex {get; set;}
See Also

Reference

Viewer Class
Viewer Members


TabNavigation Property

TabNavigation Property

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : TabNavigation Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TabNavigation As System.Windows.Input.KeyboardNavigationMode
public System.Windows.Input.KeyboardNavigationMode TabNavigation {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Tag Property (Viewer)

Tag Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Tag Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Tag As System.Object
public System.object Tag {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Template Property (Viewer)

Template Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Template Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Template As System.Windows.Controls.ControlTemplate
public System.Windows.Controls.ControlTemplate Template {get; set;}
See Also

Reference

Viewer Class
Viewer Members


TextInput Event (Viewer)

TextInput Event (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : TextInput Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TextInput As System.Windows.Input.TextCompositionEventHandler
public event System.Windows.Input.TextCompositionEventHandler TextInput
Event Data

The event handler receives an argument of type System.Windows.Input.TextCompositionEventArgs containing data related to this event. The following TextCompositionEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled, and prevents most handlers along the event route from handling the same event again.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
Text | Gets or sets the text string that of the text composition.
TextComposition | Gets or sets the text in the composition as a System.Windows.Input.TextComposition object.
See Also

Reference

Viewer Class
Viewer Members


TextInputStart Event

TextInputStart Event

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : TextInputStart Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TextInputStart As System.Windows.Input.TextCompositionEventHandler
public event System.Windows.Input.TextCompositionEventHandler TextInputStart
Event Data

The event handler receives an argument of type System.Windows.Input.TextCompositionEventArgs containing data related to this event. The following TextCompositionEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled, and prevents most handlers along the event route from handling the same event again.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
Text | Gets or sets the text string that of the text composition.
TextComposition | Gets or sets the text in the composition as a System.Windows.Input.TextComposition object.
See Also

Reference

Viewer Class
Viewer Members


TextInputUpdate Event

TextInputUpdate Event

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : TextInputUpdate Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TextInputUpdate As System.Windows.Input.TextCompositionEventHandler
public event System.Windows.Input.TextCompositionEventHandler TextInputUpdate
Event Data

The event handler receives an argument of type System.Windows.Input.TextCompositionEventArgs containing data related to this event. The following TextCompositionEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled, and prevents most handlers along the event route from handling the same event again.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
Text | Gets or sets the text string that of the text composition.
TextComposition | Gets or sets the text in the composition as a System.Windows.Input.TextComposition object.
See Also

Reference

Viewer Class
Viewer Members


TransformToVisual Method (Viewer)

TransformToVisual Method (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : TransformToVisual Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function TransformToVisual( _
   ByVal visual As System.Windows.UIElement _
) As System.Windows.Media.GeneralTransform
public System.Windows.Media.GeneralTransform TransformToVisual(
   System.Windows.UIElement visual
)

Parameters

visual
See Also

Reference

Viewer Class
Viewer Members


Triggers Property (Viewer)

Triggers Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Triggers Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Triggers As System.Windows.TriggerCollection
public System.Windows.TriggerCollection Triggers {get;}
See Also

Reference

Viewer Class
Viewer Members


Unloaded Event (Viewer)

Unloaded Event (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Unloaded Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Unloaded As System.Windows.RoutedEventHandler
public event System.Windows.RoutedEventHandler Unloaded
Event Data

The event handler receives an argument of type System.Windows.RoutedEventArgs containing data related to this event. The following RoutedEventArgs properties provide information specific to this event.

Property | Description
OriginalSource | Gets a reference to the object that raised the event.
See Also

Reference

Viewer Class
Viewer Members


UpdateLayout Method (Viewer)

UpdateLayout Method (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : UpdateLayout Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub UpdateLayout()
public void UpdateLayout()
See Also

Reference

Viewer Class
Viewer Members


UseLayoutRounding Property (Viewer)

UseLayoutRounding Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : UseLayoutRounding Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseLayoutRounding As System.Boolean
public System.bool UseLayoutRounding {get; set;}
See Also

Reference

Viewer Class
Viewer Members


VerticalAlignment Property (Viewer)

VerticalAlignment Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : VerticalAlignment Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property VerticalAlignment As System.Windows.VerticalAlignment
public System.Windows.VerticalAlignment VerticalAlignment {get; set;}
See Also

Reference

Viewer Class
Viewer Members


VerticalContentAlignment Property (Viewer)

VerticalContentAlignment Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : VerticalContentAlignment Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property VerticalContentAlignment As System.Windows.VerticalAlignment
public System.Windows.VerticalAlignment VerticalContentAlignment {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Visibility Property (Viewer)

Visibility Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Visibility Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visibility As System.Windows.Visibility
public System.Windows.Visibility Visibility {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Width Property (Viewer)

Width Property (Viewer)

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly > GrapeCity.ActiveReports Namespace > Viewer Class : Width Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As System.Double
public System.double Width {get; set;}
See Also

Reference

Viewer Class
Viewer Members


GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports.Viewer.Silverlight.v10) Inheritance Hierarchy

GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports.Viewer.Silverlight.v10) Inheritance Hierarchy
GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly : GrapeCity.ActiveReports Namespace
Inheritance Hierarchy
System.Object
System.EventArgs
GrapeCity.ActiveReports.HyperLinkEventArgs
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
GrapeCity.ActiveReports.Viewer
See Also

Reference

GrapeCity.ActiveReports.Viewer.Silverlight.v10 Assembly


GrapeCity.ActiveReports.Viewer.Win.v10 Assembly

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly
Namespaces
Namespace | Description
GrapeCity.ActiveReports | The GrapeCity.ActiveReports Namespace contains the PrintExtension class.
GrapeCity.ActiveReports.ArsClient |
GrapeCity.ActiveReports.Viewer.Win | The GrapeCity.ActiveReports.Viewer.Win namespace, contains the Viewer that is used to control the viewer, TocPanel, and other classes.
GrapeCity.Viewer.Common |
GrapeCity.Viewer.Common.Model |


GrapeCity.ActiveReports.ArsClient Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.ArsClient Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Viewer.Win.v10 Assembly : GrapeCity.ActiveReports.ArsClient Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.ArsClient.RemoteReportDescriptor
GrapeCity.ActiveReports.ArsClient.ViewerExtension
See Also

Reference

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly


ParametersPanel Class Events

ParametersPanel Class Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ParametersPanel Class

For a list of all members of this type, see ParametersPanel members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

ParametersPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Container Property (ParametersPanel)

Container Property (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ParametersPanel Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

ParametersPanel Class
ParametersPanel Members


CreateObjRef Method (ParametersPanel)

CreateObjRef Method (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ParametersPanel Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

ParametersPanel Class
ParametersPanel Members


Dispose Method (ParametersPanel)

Dispose Method (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ParametersPanel Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

ParametersPanel Class
ParametersPanel Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ParametersPanel Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

ParametersPanel Class
ParametersPanel Members


Disposed Event (ParametersPanel)

Disposed Event (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ParametersPanel Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

ParametersPanel Class
ParametersPanel Members


GetLifetimeService Method (ParametersPanel)

GetLifetimeService Method (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ParametersPanel Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

ParametersPanel Class
ParametersPanel Members


InitializeLifetimeService Method (ParametersPanel)

InitializeLifetimeService Method (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ParametersPanel Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

ParametersPanel Class
ParametersPanel Members


Site Property (ParametersPanel)

Site Property (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ParametersPanel Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

ParametersPanel Class
ParametersPanel Members


ToString Method (ParametersPanel)

ToString Method (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ParametersPanel Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

ParametersPanel Class
ParametersPanel Members


SearchPanel Class Events

SearchPanel Class Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : SearchPanel Class

For a list of all members of this type, see SearchPanel members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

SearchPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Container Property (SearchPanel)

Container Property (SearchPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > SearchPanel Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

SearchPanel Class
SearchPanel Members


CreateObjRef Method (SearchPanel)

CreateObjRef Method (SearchPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > SearchPanel Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

SearchPanel Class
SearchPanel Members


Dispose Method (SearchPanel)

Dispose Method (SearchPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > SearchPanel Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

SearchPanel Class
SearchPanel Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > SearchPanel Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

SearchPanel Class
SearchPanel Members


Disposed Event (SearchPanel)

Disposed Event (SearchPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > SearchPanel Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

SearchPanel Class
SearchPanel Members


GetLifetimeService Method (SearchPanel)

GetLifetimeService Method (SearchPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > SearchPanel Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

SearchPanel Class
SearchPanel Members


InitializeLifetimeService Method (SearchPanel)

InitializeLifetimeService Method (SearchPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > SearchPanel Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

SearchPanel Class
SearchPanel Members


Site Property (SearchPanel)

Site Property (SearchPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > SearchPanel Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

SearchPanel Class
SearchPanel Members


ToString Method (SearchPanel)

ToString Method (SearchPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > SearchPanel Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

SearchPanel Class
SearchPanel Members


Container Property (Sidebar)

Container Property (Sidebar)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

Sidebar Class
Sidebar Members


CreateObjRef Method (Sidebar)

CreateObjRef Method (Sidebar)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

Sidebar Class
Sidebar Members


Dispose Method (Sidebar)

Dispose Method (Sidebar)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

Sidebar Class
Sidebar Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Sidebar Class
Sidebar Members


Disposed Event (Sidebar)

Disposed Event (Sidebar)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Sidebar Class
Sidebar Members


GetLifetimeService Method (Sidebar)

GetLifetimeService Method (Sidebar)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

Sidebar Class
Sidebar Members


InitializeLifetimeService Method (Sidebar)

InitializeLifetimeService Method (Sidebar)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

Sidebar Class
Sidebar Members


Site Property (Sidebar)

Site Property (Sidebar)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

Sidebar Class
Sidebar Members


ToString Method (Sidebar)

ToString Method (Sidebar)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Sidebar Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

Sidebar Class
Sidebar Members


ThumbnailsPanel Class Methods

ThumbnailsPanel Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : ThumbnailsPanel Class

For a list of all members of this type, see ThumbnailsPanel members.

Public Methods
 | Name | Description
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | (Inherited from System.ComponentModel.Component)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

ThumbnailsPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Container Property (ThumbnailsPanel)

Container Property (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ThumbnailsPanel Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


CreateObjRef Method (ThumbnailsPanel)

CreateObjRef Method (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ThumbnailsPanel Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


Dispose Method (ThumbnailsPanel)

Dispose Method (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ThumbnailsPanel Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ThumbnailsPanel Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


Disposed Event (ThumbnailsPanel)

Disposed Event (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ThumbnailsPanel Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


GetLifetimeService Method (ThumbnailsPanel)

GetLifetimeService Method (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ThumbnailsPanel Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


InitializeLifetimeService Method (ThumbnailsPanel)

InitializeLifetimeService Method (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ThumbnailsPanel Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


Site Property (ThumbnailsPanel)

Site Property (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ThumbnailsPanel Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


ToString Method (ThumbnailsPanel)

ToString Method (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > ThumbnailsPanel Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


TocPanel Class Events

TocPanel Class Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace : TocPanel Class

For a list of all members of this type, see TocPanel members.

Public Events
 | Name | Description
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Top
See Also

Reference

TocPanel Class
GrapeCity.ActiveReports.Viewer.Win Namespace


Container Property (TocPanel)

Container Property (TocPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

TocPanel Class
TocPanel Members


CreateObjRef Method (TocPanel)

CreateObjRef Method (TocPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

TocPanel Class
TocPanel Members


Dispose Method (TocPanel)

Dispose Method (TocPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : Dispose Method
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

TocPanel Class
TocPanel Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

TocPanel Class
TocPanel Members


Disposed Event (TocPanel)

Disposed Event (TocPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

TocPanel Class
TocPanel Members


GetLifetimeService Method (TocPanel)

GetLifetimeService Method (TocPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

TocPanel Class
TocPanel Members


InitializeLifetimeService Method (TocPanel)

InitializeLifetimeService Method (TocPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InitializeLifetimeService() As System.Object
public System.object InitializeLifetimeService()
See Also

Reference

TocPanel Class
TocPanel Members


Site Property (TocPanel)

Site Property (TocPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

TocPanel Class
TocPanel Members


ToString Method (TocPanel)

ToString Method (TocPanel)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > TocPanel Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ToString() As System.String
public System.string ToString()
See Also

Reference

TocPanel Class
TocPanel Members


Cancel Property (Viewer.ActionEventArgs)

Cancel Property (Viewer.ActionEventArgs)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer.ActionEventArgs Class : Cancel Property
(Inherited from System.ComponentModel.CancelEventArgs)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Cancel As System.Boolean
public System.bool Cancel {get; set;}
See Also

Reference

Viewer.ActionEventArgs Class
Viewer.ActionEventArgs Members


AccessibilityObject Property (Viewer)

AccessibilityObject Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AccessibilityObject Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property AccessibilityObject As System.Windows.Forms.AccessibleObject
public System.Windows.Forms.AccessibleObject AccessibilityObject {get;}
See Also

Reference

Viewer Class
Viewer Members


AccessibleDefaultActionDescription Property (Viewer)

AccessibleDefaultActionDescription Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AccessibleDefaultActionDescription Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AccessibleDefaultActionDescription As System.String
public System.string AccessibleDefaultActionDescription {get; set;}
See Also

Reference

Viewer Class
Viewer Members


AccessibleDescription Property (Viewer)

AccessibleDescription Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AccessibleDescription Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AccessibleDescription As System.String
public System.string AccessibleDescription {get; set;}
See Also

Reference

Viewer Class
Viewer Members


AccessibleName Property (Viewer)

AccessibleName Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AccessibleName Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AccessibleName As System.String
public System.string AccessibleName {get; set;}
See Also

Reference

Viewer Class
Viewer Members


AccessibleRole Property (Viewer)

AccessibleRole Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AccessibleRole Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AccessibleRole As System.Windows.Forms.AccessibleRole
public System.Windows.Forms.AccessibleRole AccessibleRole {get; set;}
See Also

Reference

Viewer Class
Viewer Members


ActiveControl Property (Viewer)

ActiveControl Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ActiveControl Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ActiveControl As System.Windows.Forms.Control
public System.Windows.Forms.Control ActiveControl {get; set;}
See Also

Reference

Viewer Class
Viewer Members


AllowDrop Property (Viewer)

AllowDrop Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AllowDrop Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property AllowDrop As System.Boolean
public virtual System.bool AllowDrop {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Anchor Property (Viewer)

Anchor Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Anchor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Anchor As System.Windows.Forms.AnchorStyles
public virtual System.Windows.Forms.AnchorStyles Anchor {get; set;}
See Also

Reference

Viewer Class
Viewer Members


AutoScaleDimensions Property (Viewer)

AutoScaleDimensions Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AutoScaleDimensions Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScaleDimensions As SizeF
public SizeF AutoScaleDimensions {get; set;}
See Also

Reference

Viewer Class
Viewer Members


AutoScaleMode Property (Viewer)

AutoScaleMode Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AutoScaleMode Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScaleMode As System.Windows.Forms.AutoScaleMode
public System.Windows.Forms.AutoScaleMode AutoScaleMode {get; set;}
See Also

Reference

Viewer Class
Viewer Members


AutoScroll Property (Viewer)

AutoScroll Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AutoScroll Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property AutoScroll As System.Boolean
public virtual System.bool AutoScroll {get; set;}
See Also

Reference

Viewer Class
Viewer Members


AutoScrollMargin Property (Viewer)

AutoScrollMargin Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AutoScrollMargin Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScrollMargin As Size
public Size AutoScrollMargin {get; set;}
See Also

Reference

Viewer Class
Viewer Members


AutoScrollMinSize Property (Viewer)

AutoScrollMinSize Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AutoScrollMinSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScrollMinSize As Size
public Size AutoScrollMinSize {get; set;}
See Also

Reference

Viewer Class
Viewer Members


AutoScrollOffset Property (Viewer)

AutoScrollOffset Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AutoScrollOffset Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property AutoScrollOffset As Point
public virtual Point AutoScrollOffset {get; set;}
See Also

Reference

Viewer Class
Viewer Members


AutoScrollPosition Property (Viewer)

AutoScrollPosition Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AutoScrollPosition Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoScrollPosition As Point
public Point AutoScrollPosition {get; set;}
See Also

Reference

Viewer Class
Viewer Members


AutoSize Property (Viewer)

AutoSize Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AutoSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property AutoSize As System.Boolean
public virtual System.bool AutoSize {get; set;}
See Also

Reference

Viewer Class
Viewer Members


AutoSizeChanged Event (Viewer)

AutoSizeChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AutoSizeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event AutoSizeChanged As System.EventHandler
public event System.EventHandler AutoSizeChanged
See Also

Reference

Viewer Class
Viewer Members


AutoSizeMode Property (Viewer)

AutoSizeMode Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AutoSizeMode Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoSizeMode As System.Windows.Forms.AutoSizeMode
public System.Windows.Forms.AutoSizeMode AutoSizeMode {get; set;}
See Also

Reference

Viewer Class
Viewer Members


AutoValidate Property (Viewer)

AutoValidate Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AutoValidate Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property AutoValidate As System.Windows.Forms.AutoValidate
public virtual System.Windows.Forms.AutoValidate AutoValidate {get; set;}
See Also

Reference

Viewer Class
Viewer Members


AutoValidateChanged Event (Viewer)

AutoValidateChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : AutoValidateChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event AutoValidateChanged As System.EventHandler
public event System.EventHandler AutoValidateChanged
See Also

Reference

Viewer Class
Viewer Members


BackColor Property (Viewer)

BackColor Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : BackColor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property BackColor As Color
public virtual Color BackColor {get; set;}
See Also

Reference

Viewer Class
Viewer Members


BackColorChanged Event (Viewer)

BackColorChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : BackColorChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BackColorChanged As System.EventHandler
public event System.EventHandler BackColorChanged
See Also

Reference

Viewer Class
Viewer Members


BackgroundImage Property (Viewer)

BackgroundImage Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : BackgroundImage Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property BackgroundImage As Image
public virtual Image BackgroundImage {get; set;}
See Also

Reference

Viewer Class
Viewer Members


BackgroundImageChanged Event (Viewer)

BackgroundImageChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : BackgroundImageChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BackgroundImageChanged As System.EventHandler
public event System.EventHandler BackgroundImageChanged
See Also

Reference

Viewer Class
Viewer Members


BackgroundImageLayout Property (Viewer)

BackgroundImageLayout Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : BackgroundImageLayout Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property BackgroundImageLayout As System.Windows.Forms.ImageLayout
public virtual System.Windows.Forms.ImageLayout BackgroundImageLayout {get; set;}
See Also

Reference

Viewer Class
Viewer Members


BackgroundImageLayoutChanged Event (Viewer)

BackgroundImageLayoutChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : BackgroundImageLayoutChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BackgroundImageLayoutChanged As System.EventHandler
public event System.EventHandler BackgroundImageLayoutChanged
See Also

Reference

Viewer Class
Viewer Members


BeginInvoke Method (Viewer)

BeginInvoke Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : BeginInvoke Method
Overload List
Overload | Description
BeginInvoke(Delegate) | (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Viewer Class
Viewer Members


BeginInvoke(Delegate) Method

BeginInvoke(Delegate) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > BeginInvoke Method : BeginInvoke(Delegate) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function BeginInvoke( _
   ByVal method As System.Delegate _
) As System.IAsyncResult
public System.IAsyncResult BeginInvoke(
   System.Delegate method
)

Parameters

method
See Also

Reference

Viewer Class
Viewer Members
Overload List


BeginInvoke(Delegate,Object[]) Method

BeginInvoke(Delegate,Object[]) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function BeginInvoke( _
   ByVal method As System.Delegate, _
   ByVal ParamArray args() As System.Object _
) As System.IAsyncResult
public System.IAsyncResult BeginInvoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
args
See Also

Reference

Viewer Class
Viewer Members
Overload List


BindingContext Property (Viewer)

BindingContext Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : BindingContext Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property BindingContext As System.Windows.Forms.BindingContext
public virtual System.Windows.Forms.BindingContext BindingContext {get; set;}
See Also

Reference

Viewer Class
Viewer Members


BindingContextChanged Event (Viewer)

BindingContextChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : BindingContextChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event BindingContextChanged As System.EventHandler
public event System.EventHandler BindingContextChanged
See Also

Reference

Viewer Class
Viewer Members


BorderStyle Property (Viewer)

BorderStyle Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : BorderStyle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BorderStyle As System.Windows.Forms.BorderStyle
public System.Windows.Forms.BorderStyle BorderStyle {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Bottom Property (Viewer)

Bottom Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Bottom Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Bottom As System.Integer
public System.int Bottom {get;}
See Also

Reference

Viewer Class
Viewer Members


Bounds Property (Viewer)

Bounds Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Bounds Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Bounds As Rectangle
public Rectangle Bounds {get; set;}
See Also

Reference

Viewer Class
Viewer Members


BringToFront Method (Viewer)

BringToFront Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : BringToFront Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub BringToFront()
public void BringToFront()
See Also

Reference

Viewer Class
Viewer Members


CanFocus Property (Viewer)

CanFocus Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CanFocus Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CanFocus As System.Boolean
public System.bool CanFocus {get;}
See Also

Reference

Viewer Class
Viewer Members


CanSelect Property (Viewer)

CanSelect Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CanSelect Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CanSelect As System.Boolean
public System.bool CanSelect {get;}
See Also

Reference

Viewer Class
Viewer Members


Capture Property (Viewer)

Capture Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Capture Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Capture As System.Boolean
public System.bool Capture {get; set;}
See Also

Reference

Viewer Class
Viewer Members


CausesValidation Property (Viewer)

CausesValidation Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CausesValidation Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CausesValidation As System.Boolean
public System.bool CausesValidation {get; set;}
See Also

Reference

Viewer Class
Viewer Members


CausesValidationChanged Event (Viewer)

CausesValidationChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CausesValidationChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event CausesValidationChanged As System.EventHandler
public event System.EventHandler CausesValidationChanged
See Also

Reference

Viewer Class
Viewer Members


ChangeUICues Event (Viewer)

ChangeUICues Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ChangeUICues Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ChangeUICues As System.Windows.Forms.UICuesEventHandler
public event System.Windows.Forms.UICuesEventHandler ChangeUICues
Event Data

The event handler receives an argument of type System.Windows.Forms.UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.
See Also

Reference

Viewer Class
Viewer Members


Click Event (Viewer)

Click Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Click Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Click As System.EventHandler
public event System.EventHandler Click
See Also

Reference

Viewer Class
Viewer Members


ClientRectangle Property (Viewer)

ClientRectangle Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ClientRectangle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ClientRectangle As Rectangle
public Rectangle ClientRectangle {get;}
See Also

Reference

Viewer Class
Viewer Members


ClientSize Property (Viewer)

ClientSize Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ClientSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ClientSize As Size
public Size ClientSize {get; set;}
See Also

Reference

Viewer Class
Viewer Members


ClientSizeChanged Event (Viewer)

ClientSizeChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ClientSizeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ClientSizeChanged As System.EventHandler
public event System.EventHandler ClientSizeChanged
See Also

Reference

Viewer Class
Viewer Members


CompanyName Property (Viewer)

CompanyName Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CompanyName Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CompanyName As System.String
public System.string CompanyName {get;}
See Also

Reference

Viewer Class
Viewer Members


Container Property (Viewer)

Container Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Container Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Container As System.ComponentModel.IContainer
public System.ComponentModel.IContainer Container {get;}
See Also

Reference

Viewer Class
Viewer Members


Contains Method (Viewer)

Contains Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Contains Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal ctl As System.Windows.Forms.Control _
) As System.Boolean
public System.bool Contains(
   System.Windows.Forms.Control ctl
)

Parameters

ctl
See Also

Reference

Viewer Class
Viewer Members


ContainsFocus Property (Viewer)

ContainsFocus Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ContainsFocus Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ContainsFocus As System.Boolean
public System.bool ContainsFocus {get;}
See Also

Reference

Viewer Class
Viewer Members


ContextMenu Property (Viewer)

ContextMenu Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ContextMenu Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property ContextMenu As System.Windows.Forms.ContextMenu
public virtual System.Windows.Forms.ContextMenu ContextMenu {get; set;}
See Also

Reference

Viewer Class
Viewer Members


ContextMenuChanged Event (Viewer)

ContextMenuChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ContextMenuChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ContextMenuChanged As System.EventHandler
public event System.EventHandler ContextMenuChanged
See Also

Reference

Viewer Class
Viewer Members


ContextMenuStrip Property (Viewer)

ContextMenuStrip Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ContextMenuStrip Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property ContextMenuStrip As System.Windows.Forms.ContextMenuStrip
public virtual System.Windows.Forms.ContextMenuStrip ContextMenuStrip {get; set;}
See Also

Reference

Viewer Class
Viewer Members


ContextMenuStripChanged Event (Viewer)

ContextMenuStripChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ContextMenuStripChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ContextMenuStripChanged As System.EventHandler
public event System.EventHandler ContextMenuStripChanged
See Also

Reference

Viewer Class
Viewer Members


ControlAdded Event (Viewer)

ControlAdded Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ControlAdded Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ControlAdded As System.Windows.Forms.ControlEventHandler
public event System.Windows.Forms.ControlEventHandler ControlAdded
Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.
See Also

Reference

Viewer Class
Viewer Members


ControlRemoved Event (Viewer)

ControlRemoved Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ControlRemoved Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ControlRemoved As System.Windows.Forms.ControlEventHandler
public event System.Windows.Forms.ControlEventHandler ControlRemoved
Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.
See Also

Reference

Viewer Class
Viewer Members


Controls Property (Viewer)

Controls Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Controls Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Controls As System.Windows.Forms.Control.ControlCollection
public System.Windows.Forms.Control.ControlCollection Controls {get;}
See Also

Reference

Viewer Class
Viewer Members


CreateControl Method (Viewer)

CreateControl Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CreateControl Method
Overload List
Overload | Description
CreateControl | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Viewer Class
Viewer Members


CreateControl() Method

CreateControl() Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CreateControl() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CreateControl()
public void CreateControl()
See Also

Reference

Viewer Class
Viewer Members


Created Property (Viewer)

Created Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Created Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Created As System.Boolean
public System.bool Created {get;}
See Also

Reference

Viewer Class
Viewer Members


CreateGraphics Method (Viewer)

CreateGraphics Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CreateGraphics Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CreateGraphics() As Graphics
public Graphics CreateGraphics()
See Also

Reference

Viewer Class
Viewer Members


CreateObjRef Method (Viewer)

CreateObjRef Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CreateObjRef Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
See Also

Reference

Viewer Class
Viewer Members


CurrentAutoScaleDimensions Property (Viewer)

CurrentAutoScaleDimensions Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CurrentAutoScaleDimensions Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CurrentAutoScaleDimensions As SizeF
public SizeF CurrentAutoScaleDimensions {get;}
See Also

Reference

Viewer Class
Viewer Members


Cursor Property (Viewer)

Cursor Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Cursor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Cursor As System.Windows.Forms.Cursor
public virtual System.Windows.Forms.Cursor Cursor {get; set;}
See Also

Reference

Viewer Class
Viewer Members


CursorChanged Event (Viewer)

CursorChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : CursorChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event CursorChanged As System.EventHandler
public event System.EventHandler CursorChanged
See Also

Reference

Viewer Class
Viewer Members


DataBindings Property (Viewer)

DataBindings Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : DataBindings Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DataBindings As System.Windows.Forms.ControlBindingsCollection
public System.Windows.Forms.ControlBindingsCollection DataBindings {get;}
See Also

Reference

Viewer Class
Viewer Members


DisplayRectangle Property (Viewer)

DisplayRectangle Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : DisplayRectangle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property DisplayRectangle As Rectangle
public virtual Rectangle DisplayRectangle {get;}
See Also

Reference

Viewer Class
Viewer Members


Dispose Method (Viewer)

Dispose Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Dispose Method
Clean up any resources being used.
Overload List
Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)
See Also

Reference

Viewer Class
Viewer Members


Dispose() Method

Dispose() Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
public void Dispose()
See Also

Reference

Viewer Class
Viewer Members


Disposed Event (Viewer)

Disposed Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

Viewer Class
Viewer Members


Disposing Property (Viewer)

Disposing Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Disposing Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Disposing As System.Boolean
public System.bool Disposing {get;}
See Also

Reference

Viewer Class
Viewer Members


Dock Property (Viewer)

Dock Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Dock Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Dock As System.Windows.Forms.DockStyle
public virtual System.Windows.Forms.DockStyle Dock {get; set;}
See Also

Reference

Viewer Class
Viewer Members


DockChanged Event (Viewer)

DockChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : DockChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DockChanged As System.EventHandler
public event System.EventHandler DockChanged
See Also

Reference

Viewer Class
Viewer Members


DoDragDrop Method (Viewer)

DoDragDrop Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : DoDragDrop Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function DoDragDrop( _
   ByVal data As System.Object, _
   ByVal allowedEffects As System.Windows.Forms.DragDropEffects _
) As System.Windows.Forms.DragDropEffects
public System.Windows.Forms.DragDropEffects DoDragDrop(
   System.object data,
   System.Windows.Forms.DragDropEffects allowedEffects
)

Parameters

data
allowedEffects
See Also

Reference

Viewer Class
Viewer Members


DoubleClick Event (Viewer)

DoubleClick Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : DoubleClick Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DoubleClick As System.EventHandler
public event System.EventHandler DoubleClick
See Also

Reference

Viewer Class
Viewer Members


DragDrop Event (Viewer)

DragDrop Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : DragDrop Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragDrop As System.Windows.Forms.DragEventHandler
public event System.Windows.Forms.DragEventHandler DragDrop
Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.
See Also

Reference

Viewer Class
Viewer Members


DragEnter Event (Viewer)

DragEnter Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : DragEnter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragEnter As System.Windows.Forms.DragEventHandler
public event System.Windows.Forms.DragEventHandler DragEnter
Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.
See Also

Reference

Viewer Class
Viewer Members


DragLeave Event (Viewer)

DragLeave Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : DragLeave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragLeave As System.EventHandler
public event System.EventHandler DragLeave
See Also

Reference

Viewer Class
Viewer Members


DragOver Event (Viewer)

DragOver Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : DragOver Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragOver As System.Windows.Forms.DragEventHandler
public event System.Windows.Forms.DragEventHandler DragOver
Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.
See Also

Reference

Viewer Class
Viewer Members


DrawToBitmap Method (Viewer)

DrawToBitmap Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : DrawToBitmap Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub DrawToBitmap( _
   ByVal bitmap As Bitmap, _
   ByVal targetBounds As Rectangle _
)
public void DrawToBitmap(
   Bitmap bitmap,
   Rectangle targetBounds
)

Parameters

bitmap
targetBounds
See Also

Reference

Viewer Class
Viewer Members


Enabled Property (Viewer)

Enabled Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Enabled Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Enabled As System.Boolean
public System.bool Enabled {get; set;}
See Also

Reference

Viewer Class
Viewer Members


EnabledChanged Event (Viewer)

EnabledChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : EnabledChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event EnabledChanged As System.EventHandler
public event System.EventHandler EnabledChanged
See Also

Reference

Viewer Class
Viewer Members


EndInvoke Method (Viewer)

EndInvoke Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : EndInvoke Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function EndInvoke( _
   ByVal asyncResult As System.IAsyncResult _
) As System.Object
public System.object EndInvoke(
   System.IAsyncResult asyncResult
)

Parameters

asyncResult
See Also

Reference

Viewer Class
Viewer Members


Enter Event (Viewer)

Enter Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Enter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Enter As System.EventHandler
public event System.EventHandler Enter
See Also

Reference

Viewer Class
Viewer Members


FindForm Method (Viewer)

FindForm Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : FindForm Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function FindForm() As System.Windows.Forms.Form
public System.Windows.Forms.Form FindForm()
See Also

Reference

Viewer Class
Viewer Members


Focus Method (Viewer)

Focus Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Focus Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Focus() As System.Boolean
public System.bool Focus()
See Also

Reference

Viewer Class
Viewer Members


Focused Property (Viewer)

Focused Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Focused Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Focused As System.Boolean
public virtual System.bool Focused {get;}
See Also

Reference

Viewer Class
Viewer Members


Font Property (Viewer)

Font Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Font Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Font As Font
public virtual Font Font {get; set;}
See Also

Reference

Viewer Class
Viewer Members


FontChanged Event (Viewer)

FontChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : FontChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event FontChanged As System.EventHandler
public event System.EventHandler FontChanged
See Also

Reference

Viewer Class
Viewer Members


ForeColor Property (Viewer)

ForeColor Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ForeColor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property ForeColor As Color
public virtual Color ForeColor {get; set;}
See Also

Reference

Viewer Class
Viewer Members


ForeColorChanged Event (Viewer)

ForeColorChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ForeColorChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ForeColorChanged As System.EventHandler
public event System.EventHandler ForeColorChanged
See Also

Reference

Viewer Class
Viewer Members


GetChildAtPoint Method (Viewer)

GetChildAtPoint Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : GetChildAtPoint Method
Overload List
Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Viewer Class
Viewer Members


GetChildAtPoint(Point) Method

GetChildAtPoint(Point) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point _
) As System.Windows.Forms.Control
public System.Windows.Forms.Control GetChildAtPoint(
   Point pt
)

Parameters

pt
See Also

Reference

Viewer Class
Viewer Members
Overload List


GetChildAtPoint(Point,GetChildAtPointSkip) Method

GetChildAtPoint(Point,GetChildAtPointSkip) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetChildAtPoint( _
   ByVal pt As Point, _
   ByVal skipValue As System.Windows.Forms.GetChildAtPointSkip _
) As System.Windows.Forms.Control
public System.Windows.Forms.Control GetChildAtPoint(
   Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)

Parameters

pt
skipValue
See Also

Reference

Viewer Class
Viewer Members
Overload List


GetContainerControl Method (Viewer)

GetContainerControl Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : GetContainerControl Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetContainerControl() As System.Windows.Forms.IContainerControl
public System.Windows.Forms.IContainerControl GetContainerControl()
See Also

Reference

Viewer Class
Viewer Members


GetLifetimeService Method (Viewer)

GetLifetimeService Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : GetLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLifetimeService() As System.Object
public System.object GetLifetimeService()
See Also

Reference

Viewer Class
Viewer Members


GetNextControl Method (Viewer)

GetNextControl Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : GetNextControl Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetNextControl( _
   ByVal ctl As System.Windows.Forms.Control, _
   ByVal forward As System.Boolean _
) As System.Windows.Forms.Control
public System.Windows.Forms.Control GetNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward
)

Parameters

ctl
forward
See Also

Reference

Viewer Class
Viewer Members


GetPreferredSize Method (Viewer)

GetPreferredSize Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : GetPreferredSize Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetPreferredSize( _
   ByVal proposedSize As Size _
) As Size
public virtual Size GetPreferredSize(
   Size proposedSize
)

Parameters

proposedSize
See Also

Reference

Viewer Class
Viewer Members


GiveFeedback Event (Viewer)

GiveFeedback Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : GiveFeedback Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event GiveFeedback As System.Windows.Forms.GiveFeedbackEventHandler
public event System.Windows.Forms.GiveFeedbackEventHandler GiveFeedback
Event Data

The event handler receives an argument of type System.Windows.Forms.GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.
See Also

Reference

Viewer Class
Viewer Members


GotFocus Event (Viewer)

GotFocus Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : GotFocus Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event GotFocus As System.EventHandler
public event System.EventHandler GotFocus
See Also

Reference

Viewer Class
Viewer Members


Handle Property (Viewer)

Handle Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Handle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Handle As System.IntPtr
public System.IntPtr Handle {get;}
See Also

Reference

Viewer Class
Viewer Members


HandleCreated Event (Viewer)

HandleCreated Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : HandleCreated Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event HandleCreated As System.EventHandler
public event System.EventHandler HandleCreated
See Also

Reference

Viewer Class
Viewer Members


HandleDestroyed Event (Viewer)

HandleDestroyed Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : HandleDestroyed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event HandleDestroyed As System.EventHandler
public event System.EventHandler HandleDestroyed
See Also

Reference

Viewer Class
Viewer Members


HasChildren Property (Viewer)

HasChildren Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : HasChildren Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HasChildren As System.Boolean
public System.bool HasChildren {get;}
See Also

Reference

Viewer Class
Viewer Members


Height Property (Viewer)

Height Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Height Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As System.Integer
public System.int Height {get; set;}
See Also

Reference

Viewer Class
Viewer Members


HelpRequested Event (Viewer)

HelpRequested Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : HelpRequested Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event HelpRequested As System.Windows.Forms.HelpEventHandler
public event System.Windows.Forms.HelpEventHandler HelpRequested
Event Data

The event handler receives an argument of type System.Windows.Forms.HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.
See Also

Reference

Viewer Class
Viewer Members


Hide Method (Viewer)

Hide Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Hide Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Hide()
public void Hide()
See Also

Reference

Viewer Class
Viewer Members


HorizontalScroll Property (Viewer)

HorizontalScroll Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : HorizontalScroll Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HorizontalScroll As System.Windows.Forms.HScrollProperties
public System.Windows.Forms.HScrollProperties HorizontalScroll {get;}
See Also

Reference

Viewer Class
Viewer Members


ImeMode Property (Viewer)

ImeMode Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ImeMode Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ImeMode As System.Windows.Forms.ImeMode
public System.Windows.Forms.ImeMode ImeMode {get; set;}
See Also

Reference

Viewer Class
Viewer Members


ImeModeChanged Event (Viewer)

ImeModeChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ImeModeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ImeModeChanged As System.EventHandler
public event System.EventHandler ImeModeChanged
See Also

Reference

Viewer Class
Viewer Members


InitializeLifetimeService Method (Viewer)

InitializeLifetimeService Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : InitializeLifetimeService Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function InitializeLifetimeService() As System.Object
public virtual System.object InitializeLifetimeService()
See Also

Reference

Viewer Class
Viewer Members


Invalidate Method (Viewer)

Invalidate Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Invalidate Method
Overload List
Overload | Description
Invalidate(Region) | (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | (Inherited from System.Windows.Forms.Control)
Invalidate() | (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Viewer Class
Viewer Members


Invalidate() Method

Invalidate() Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Invalidate Method : Invalidate() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate()
public void Invalidate()
See Also

Reference

Viewer Class
Viewer Members
Overload List


Invalidate(Boolean) Method

Invalidate(Boolean) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Invalidate Method : Invalidate(Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal invalidateChildren As System.Boolean _
)
public void Invalidate(
   System.bool invalidateChildren
)

Parameters

invalidateChildren
See Also

Reference

Viewer Class
Viewer Members
Overload List


Invalidate(Rectangle) Method

Invalidate(Rectangle) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Invalidate Method : Invalidate(Rectangle) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle _
)
public void Invalidate(
   Rectangle rc
)

Parameters

rc
See Also

Reference

Viewer Class
Viewer Members
Overload List


Invalidate(Rectangle,Boolean) Method

Invalidate(Rectangle,Boolean) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal rc As Rectangle, _
   ByVal invalidateChildren As System.Boolean _
)
public void Invalidate(
   Rectangle rc,
   System.bool invalidateChildren
)

Parameters

rc
invalidateChildren
See Also

Reference

Viewer Class
Viewer Members
Overload List


Invalidate(Region) Method

Invalidate(Region) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Invalidate Method : Invalidate(Region) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal region As Region _
)
public void Invalidate(
   Region region
)

Parameters

region
See Also

Reference

Viewer Class
Viewer Members
Overload List


Invalidate(Region,Boolean) Method

Invalidate(Region,Boolean) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Invalidate Method : Invalidate(Region,Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Invalidate( _
   ByVal region As Region, _
   ByVal invalidateChildren As System.Boolean _
)
public void Invalidate(
   Region region,
   System.bool invalidateChildren
)

Parameters

region
invalidateChildren
See Also

Reference

Viewer Class
Viewer Members
Overload List


Invalidated Event (Viewer)

Invalidated Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Invalidated Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Invalidated As System.Windows.Forms.InvalidateEventHandler
public event System.Windows.Forms.InvalidateEventHandler Invalidated
Event Data

The event handler receives an argument of type System.Windows.Forms.InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.
See Also

Reference

Viewer Class
Viewer Members


Invoke Method (Viewer)

Invoke Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Invoke Method
Overload List
Overload | Description
Invoke(Delegate) | (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Viewer Class
Viewer Members


Invoke(Delegate) Method

Invoke(Delegate) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Invoke Method : Invoke(Delegate) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Invoke( _
   ByVal method As System.Delegate _
) As System.Object
public System.object Invoke(
   System.Delegate method
)

Parameters

method
See Also

Reference

Viewer Class
Viewer Members
Overload List


Invoke(Delegate,Object[]) Method

Invoke(Delegate,Object[]) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Invoke Method : Invoke(Delegate,Object[]) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Invoke( _
   ByVal method As System.Delegate, _
   ByVal ParamArray args() As System.Object _
) As System.Object
public System.object Invoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
args
See Also

Reference

Viewer Class
Viewer Members
Overload List


InvokeRequired Property (Viewer)

InvokeRequired Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : InvokeRequired Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InvokeRequired As System.Boolean
public System.bool InvokeRequired {get;}
See Also

Reference

Viewer Class
Viewer Members


IsAccessible Property (Viewer)

IsAccessible Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : IsAccessible Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsAccessible As System.Boolean
public System.bool IsAccessible {get; set;}
See Also

Reference

Viewer Class
Viewer Members


IsDisposed Property (Viewer)

IsDisposed Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : IsDisposed Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsDisposed As System.Boolean
public System.bool IsDisposed {get;}
See Also

Reference

Viewer Class
Viewer Members


IsHandleCreated Property (Viewer)

IsHandleCreated Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : IsHandleCreated Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsHandleCreated As System.Boolean
public System.bool IsHandleCreated {get;}
See Also

Reference

Viewer Class
Viewer Members


IsMirrored Property (Viewer)

IsMirrored Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : IsMirrored Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsMirrored As System.Boolean
public System.bool IsMirrored {get;}
See Also

Reference

Viewer Class
Viewer Members


KeyDown Event (Viewer)

KeyDown Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : KeyDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event KeyDown As System.Windows.Forms.KeyEventHandler
public event System.Windows.Forms.KeyEventHandler KeyDown
Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.
See Also

Reference

Viewer Class
Viewer Members


KeyPress Event (Viewer)

KeyPress Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : KeyPress Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event KeyPress As System.Windows.Forms.KeyPressEventHandler
public event System.Windows.Forms.KeyPressEventHandler KeyPress
Event Data

The event handler receives an argument of type System.Windows.Forms.KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.
See Also

Reference

Viewer Class
Viewer Members


KeyUp Event (Viewer)

KeyUp Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : KeyUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event KeyUp As System.Windows.Forms.KeyEventHandler
public event System.Windows.Forms.KeyEventHandler KeyUp
Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.
See Also

Reference

Viewer Class
Viewer Members


Layout Event (Viewer)

Layout Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Layout Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Layout As System.Windows.Forms.LayoutEventHandler
public event System.Windows.Forms.LayoutEventHandler Layout
Event Data

The event handler receives an argument of type System.Windows.Forms.LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.
See Also

Reference

Viewer Class
Viewer Members


LayoutEngine Property (Viewer)

LayoutEngine Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : LayoutEngine Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property LayoutEngine As System.Windows.Forms.Layout.LayoutEngine
public virtual System.Windows.Forms.Layout.LayoutEngine LayoutEngine {get;}
See Also

Reference

Viewer Class
Viewer Members


Leave Event (Viewer)

Leave Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Leave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Leave As System.EventHandler
public event System.EventHandler Leave
See Also

Reference

Viewer Class
Viewer Members


Left Property (Viewer)

Left Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Left Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Left As System.Integer
public System.int Left {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Load Event (Viewer)

Load Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Load Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Load As System.EventHandler
public event System.EventHandler Load
See Also

Reference

Viewer Class
Viewer Members


Location Property (Viewer)

Location Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Location Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Location As Point
public Point Location {get; set;}
See Also

Reference

Viewer Class
Viewer Members


LocationChanged Event (Viewer)

LocationChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : LocationChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LocationChanged As System.EventHandler
public event System.EventHandler LocationChanged
See Also

Reference

Viewer Class
Viewer Members


LostFocus Event (Viewer)

LostFocus Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : LostFocus Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LostFocus As System.EventHandler
public event System.EventHandler LostFocus
See Also

Reference

Viewer Class
Viewer Members


Margin Property (Viewer)

Margin Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Margin Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Margin As System.Windows.Forms.Padding
public System.Windows.Forms.Padding Margin {get; set;}
See Also

Reference

Viewer Class
Viewer Members


MarginChanged Event (Viewer)

MarginChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MarginChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MarginChanged As System.EventHandler
public event System.EventHandler MarginChanged
See Also

Reference

Viewer Class
Viewer Members


MaximumSize Property (Viewer)

MaximumSize Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MaximumSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property MaximumSize As Size
public virtual Size MaximumSize {get; set;}
See Also

Reference

Viewer Class
Viewer Members


MinimumSize Property (Viewer)

MinimumSize Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MinimumSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property MinimumSize As Size
public virtual Size MinimumSize {get; set;}
See Also

Reference

Viewer Class
Viewer Members


MouseCaptureChanged Event (Viewer)

MouseCaptureChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MouseCaptureChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseCaptureChanged As System.EventHandler
public event System.EventHandler MouseCaptureChanged
See Also

Reference

Viewer Class
Viewer Members


MouseClick Event (Viewer)

MouseClick Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MouseClick Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseClick As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseClick
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

Viewer Class
Viewer Members


MouseDoubleClick Event (Viewer)

MouseDoubleClick Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MouseDoubleClick Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseDoubleClick As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseDoubleClick
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

Viewer Class
Viewer Members


MouseDown Event (Viewer)

MouseDown Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MouseDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseDown As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseDown
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

Viewer Class
Viewer Members


MouseEnter Event (Viewer)

MouseEnter Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MouseEnter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseEnter As System.EventHandler
public event System.EventHandler MouseEnter
See Also

Reference

Viewer Class
Viewer Members


MouseHover Event (Viewer)

MouseHover Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MouseHover Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseHover As System.EventHandler
public event System.EventHandler MouseHover
See Also

Reference

Viewer Class
Viewer Members


MouseLeave Event (Viewer)

MouseLeave Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MouseLeave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseLeave As System.EventHandler
public event System.EventHandler MouseLeave
See Also

Reference

Viewer Class
Viewer Members


MouseMove Event (Viewer)

MouseMove Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MouseMove Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseMove As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseMove
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

Viewer Class
Viewer Members


MouseUp Event (Viewer)

MouseUp Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MouseUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseUp As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseUp
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

Viewer Class
Viewer Members


MouseWheel Event (Viewer)

MouseWheel Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : MouseWheel Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseWheel As System.Windows.Forms.MouseEventHandler
public event System.Windows.Forms.MouseEventHandler MouseWheel
Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.
See Also

Reference

Viewer Class
Viewer Members


Move Event (Viewer)

Move Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Move Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Move As System.EventHandler
public event System.EventHandler Move
See Also

Reference

Viewer Class
Viewer Members


Name Property (Viewer)

Name Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Name Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Padding Property (Viewer)

Padding Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Padding Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Padding As System.Windows.Forms.Padding
public System.Windows.Forms.Padding Padding {get; set;}
See Also

Reference

Viewer Class
Viewer Members


PaddingChanged Event (Viewer)

PaddingChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PaddingChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PaddingChanged As System.EventHandler
public event System.EventHandler PaddingChanged
See Also

Reference

Viewer Class
Viewer Members


Paint Event (Viewer)

Paint Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Paint Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Paint As System.Windows.Forms.PaintEventHandler
public event System.Windows.Forms.PaintEventHandler Paint
Event Data

The event handler receives an argument of type System.Windows.Forms.PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.
See Also

Reference

Viewer Class
Viewer Members


Parent Property (Viewer)

Parent Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Parent Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Parent As System.Windows.Forms.Control
public System.Windows.Forms.Control Parent {get; set;}
See Also

Reference

Viewer Class
Viewer Members


ParentChanged Event (Viewer)

ParentChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ParentChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ParentChanged As System.EventHandler
public event System.EventHandler ParentChanged
See Also

Reference

Viewer Class
Viewer Members


ParentForm Property (Viewer)

ParentForm Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ParentForm Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ParentForm As System.Windows.Forms.Form
public System.Windows.Forms.Form ParentForm {get;}
See Also

Reference

Viewer Class
Viewer Members


PerformAutoScale Method (Viewer)

PerformAutoScale Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PerformAutoScale Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub PerformAutoScale()
public void PerformAutoScale()
See Also

Reference

Viewer Class
Viewer Members


PerformLayout Method (Viewer)

PerformLayout Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PerformLayout Method
Overload List
Overload | Description
PerformLayout() | (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Viewer Class
Viewer Members


PerformLayout() Method

PerformLayout() Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > PerformLayout Method : PerformLayout() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub PerformLayout()
public void PerformLayout()
See Also

Reference

Viewer Class
Viewer Members
Overload List


PerformLayout(Control,String) Method

PerformLayout(Control,String) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > PerformLayout Method : PerformLayout(Control,String) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub PerformLayout( _
   ByVal affectedControl As System.Windows.Forms.Control, _
   ByVal affectedProperty As System.String _
)
public void PerformLayout(
   System.Windows.Forms.Control affectedControl,
   System.string affectedProperty
)

Parameters

affectedControl
affectedProperty
See Also

Reference

Viewer Class
Viewer Members
Overload List


PointToClient Method (Viewer)

PointToClient Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PointToClient Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PointToClient( _
   ByVal p As Point _
) As Point
public Point PointToClient(
   Point p
)

Parameters

p
See Also

Reference

Viewer Class
Viewer Members


PointToScreen Method (Viewer)

PointToScreen Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PointToScreen Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PointToScreen( _
   ByVal p As Point _
) As Point
public Point PointToScreen(
   Point p
)

Parameters

p
See Also

Reference

Viewer Class
Viewer Members


PreferredSize Property (Viewer)

PreferredSize Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PreferredSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PreferredSize As Size
public Size PreferredSize {get;}
See Also

Reference

Viewer Class
Viewer Members


PreProcessControlMessage Method (Viewer)

PreProcessControlMessage Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PreProcessControlMessage Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PreProcessControlMessage( _
   ByRef msg As System.Windows.Forms.Message _
) As System.Windows.Forms.PreProcessControlState
public System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
See Also

Reference

Viewer Class
Viewer Members


PreProcessMessage Method (Viewer)

PreProcessMessage Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PreProcessMessage Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function PreProcessMessage( _
   ByRef msg As System.Windows.Forms.Message _
) As System.Boolean
public virtual System.bool PreProcessMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
See Also

Reference

Viewer Class
Viewer Members


PreviewKeyDown Event (Viewer)

PreviewKeyDown Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : PreviewKeyDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewKeyDown As System.Windows.Forms.PreviewKeyDownEventHandler
public event System.Windows.Forms.PreviewKeyDownEventHandler PreviewKeyDown
Event Data

The event handler receives an argument of type System.Windows.Forms.PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.
See Also

Reference

Viewer Class
Viewer Members


ProductName Property (Viewer)

ProductName Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ProductName Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ProductName As System.String
public System.string ProductName {get;}
See Also

Reference

Viewer Class
Viewer Members


ProductVersion Property (Viewer)

ProductVersion Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ProductVersion Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ProductVersion As System.String
public System.string ProductVersion {get;}
See Also

Reference

Viewer Class
Viewer Members


QueryAccessibilityHelp Event (Viewer)

QueryAccessibilityHelp Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : QueryAccessibilityHelp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event QueryAccessibilityHelp As System.Windows.Forms.QueryAccessibilityHelpEventHandler
public event System.Windows.Forms.QueryAccessibilityHelpEventHandler QueryAccessibilityHelp
Event Data

The event handler receives an argument of type System.Windows.Forms.QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.
See Also

Reference

Viewer Class
Viewer Members


QueryContinueDrag Event (Viewer)

QueryContinueDrag Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : QueryContinueDrag Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event QueryContinueDrag As System.Windows.Forms.QueryContinueDragEventHandler
public event System.Windows.Forms.QueryContinueDragEventHandler QueryContinueDrag
Event Data

The event handler receives an argument of type System.Windows.Forms.QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.
See Also

Reference

Viewer Class
Viewer Members


RecreatingHandle Property (Viewer)

RecreatingHandle Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : RecreatingHandle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property RecreatingHandle As System.Boolean
public System.bool RecreatingHandle {get;}
See Also

Reference

Viewer Class
Viewer Members


RectangleToClient Method (Viewer)

RectangleToClient Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : RectangleToClient Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function RectangleToClient( _
   ByVal r As Rectangle _
) As Rectangle
public Rectangle RectangleToClient(
   Rectangle r
)

Parameters

r
See Also

Reference

Viewer Class
Viewer Members


RectangleToScreen Method (Viewer)

RectangleToScreen Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : RectangleToScreen Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function RectangleToScreen( _
   ByVal r As Rectangle _
) As Rectangle
public Rectangle RectangleToScreen(
   Rectangle r
)

Parameters

r
See Also

Reference

Viewer Class
Viewer Members


Refresh Method (Viewer)

Refresh Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Refresh Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub Refresh()
public virtual void Refresh()
See Also

Reference

Viewer Class
Viewer Members


Region Property (Viewer)

Region Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Region Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Region As Region
public Region Region {get; set;}
See Also

Reference

Viewer Class
Viewer Members


RegionChanged Event (Viewer)

RegionChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : RegionChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event RegionChanged As System.EventHandler
public event System.EventHandler RegionChanged
See Also

Reference

Viewer Class
Viewer Members


ResetText Method (Viewer)

ResetText Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ResetText Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub ResetText()
public virtual void ResetText()
See Also

Reference

Viewer Class
Viewer Members


Resize Event (Viewer)

Resize Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Resize Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Resize As System.EventHandler
public event System.EventHandler Resize
See Also

Reference

Viewer Class
Viewer Members


ResumeLayout Method (Viewer)

ResumeLayout Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ResumeLayout Method
Overload List
Overload | Description
ResumeLayout() | (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Viewer Class
Viewer Members


ResumeLayout() Method

ResumeLayout() Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > ResumeLayout Method : ResumeLayout() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ResumeLayout()
public void ResumeLayout()
See Also

Reference

Viewer Class
Viewer Members
Overload List


ResumeLayout(Boolean) Method

ResumeLayout(Boolean) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > ResumeLayout Method : ResumeLayout(Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ResumeLayout( _
   ByVal performLayout As System.Boolean _
)
public void ResumeLayout(
   System.bool performLayout
)

Parameters

performLayout
See Also

Reference

Viewer Class
Viewer Members
Overload List


Right Property (Viewer)

Right Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Right Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Right As System.Integer
public System.int Right {get;}
See Also

Reference

Viewer Class
Viewer Members


RightToLeft Property (Viewer)

RightToLeft Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : RightToLeft Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property RightToLeft As System.Windows.Forms.RightToLeft
public virtual System.Windows.Forms.RightToLeft RightToLeft {get; set;}
See Also

Reference

Viewer Class
Viewer Members


RightToLeftChanged Event (Viewer)

RightToLeftChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : RightToLeftChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event RightToLeftChanged As System.EventHandler
public event System.EventHandler RightToLeftChanged
See Also

Reference

Viewer Class
Viewer Members


Scale Method (Viewer)

Scale Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Scale Method
Overload List
Overload | Description
Scale | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Viewer Class
Viewer Members


Scale(SizeF) Method

Scale(SizeF) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Scale Method : Scale(SizeF) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Scale( _
   ByVal factor As SizeF _
)
public void Scale(
   SizeF factor
)

Parameters

factor
See Also

Reference

Viewer Class
Viewer Members
Overload List


Scroll Event (Viewer)

Scroll Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Scroll Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Scroll As System.Windows.Forms.ScrollEventHandler
public event System.Windows.Forms.ScrollEventHandler Scroll
Event Data

The event handler receives an argument of type System.Windows.Forms.ScrollEventArgs containing data related to this event. The following ScrollEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets or sets the new System.Windows.Forms.ScrollBar.Value of the scroll bar.
OldValue | Gets the old System.Windows.Forms.ScrollBar.Value of the scroll bar.
ScrollOrientation | Gets the scroll bar orientation that raised the Scroll event.
Type | Gets the type of scroll event that occurred.
See Also

Reference

Viewer Class
Viewer Members


ScrollControlIntoView Method (Viewer)

ScrollControlIntoView Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ScrollControlIntoView Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ScrollControlIntoView( _
   ByVal activeControl As System.Windows.Forms.Control _
)
public void ScrollControlIntoView(
   System.Windows.Forms.Control activeControl
)

Parameters

activeControl
See Also

Reference

Viewer Class
Viewer Members


Select Method (Viewer)

Select Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Select Method
Overload List
Overload | Description
Select | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Viewer Class
Viewer Members


Select() Method

Select() Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Select() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Select()
public void Select()
See Also

Reference

Viewer Class
Viewer Members


SelectNextControl Method (Viewer)

SelectNextControl Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : SelectNextControl Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function SelectNextControl( _
   ByVal ctl As System.Windows.Forms.Control, _
   ByVal forward As System.Boolean, _
   ByVal tabStopOnly As System.Boolean, _
   ByVal nested As System.Boolean, _
   ByVal wrap As System.Boolean _
) As System.Boolean
public System.bool SelectNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)

Parameters

ctl
forward
tabStopOnly
nested
wrap
See Also

Reference

Viewer Class
Viewer Members


SendToBack Method (Viewer)

SendToBack Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : SendToBack Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SendToBack()
public void SendToBack()
See Also

Reference

Viewer Class
Viewer Members


SetAutoScrollMargin Method (Viewer)

SetAutoScrollMargin Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : SetAutoScrollMargin Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetAutoScrollMargin( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer _
)
public void SetAutoScrollMargin(
   System.int x,
   System.int y
)

Parameters

x
y
See Also

Reference

Viewer Class
Viewer Members


SetBounds Method (Viewer)

SetBounds Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : SetBounds Method
Overload List
Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | (Inherited from System.Windows.Forms.Control)
See Also

Reference

Viewer Class
Viewer Members


SetBounds(Int32,Int32,Int32,Int32) Method

SetBounds(Int32,Int32,Int32,Int32) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer _
)
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

x
y
width
height
See Also

Reference

Viewer Class
Viewer Members
Overload List


SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer, _
   ByVal specified As System.Windows.Forms.BoundsSpecified _
)
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)

Parameters

x
y
width
height
specified
See Also

Reference

Viewer Class
Viewer Members
Overload List


Show Method (Viewer)

Show Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Show Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Show()
public void Show()
See Also

Reference

Viewer Class
Viewer Members


Site Property (Viewer)

Site Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Site As System.ComponentModel.ISite
public virtual System.ComponentModel.ISite Site {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Size Property (Viewer)

Size Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Size Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Size As Size
public Size Size {get; set;}
See Also

Reference

Viewer Class
Viewer Members


SizeChanged Event (Viewer)

SizeChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : SizeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event SizeChanged As System.EventHandler
public event System.EventHandler SizeChanged
See Also

Reference

Viewer Class
Viewer Members


StyleChanged Event (Viewer)

StyleChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : StyleChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event StyleChanged As System.EventHandler
public event System.EventHandler StyleChanged
See Also

Reference

Viewer Class
Viewer Members


SuspendLayout Method (Viewer)

SuspendLayout Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : SuspendLayout Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SuspendLayout()
public void SuspendLayout()
See Also

Reference

Viewer Class
Viewer Members


SystemColorsChanged Event (Viewer)

SystemColorsChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : SystemColorsChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event SystemColorsChanged As System.EventHandler
public event System.EventHandler SystemColorsChanged
See Also

Reference

Viewer Class
Viewer Members


TabIndex Property (Viewer)

TabIndex Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TabIndex Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TabIndex As System.Integer
public System.int TabIndex {get; set;}
See Also

Reference

Viewer Class
Viewer Members


TabIndexChanged Event (Viewer)

TabIndexChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TabIndexChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TabIndexChanged As System.EventHandler
public event System.EventHandler TabIndexChanged
See Also

Reference

Viewer Class
Viewer Members


TabStop Property (Viewer)

TabStop Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TabStop Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TabStop As System.Boolean
public System.bool TabStop {get; set;}
See Also

Reference

Viewer Class
Viewer Members


TabStopChanged Event (Viewer)

TabStopChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TabStopChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TabStopChanged As System.EventHandler
public event System.EventHandler TabStopChanged
See Also

Reference

Viewer Class
Viewer Members


Tag Property (Viewer)

Tag Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Tag Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Tag As System.Object
public System.object Tag {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Top Property (Viewer)

Top Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Top Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Top As System.Integer
public System.int Top {get; set;}
See Also

Reference

Viewer Class
Viewer Members


TopLevelControl Property (Viewer)

TopLevelControl Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : TopLevelControl Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TopLevelControl As System.Windows.Forms.Control
public System.Windows.Forms.Control TopLevelControl {get;}
See Also

Reference

Viewer Class
Viewer Members


ToString Method (Viewer)

ToString Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

Viewer Class
Viewer Members


Update Method (Viewer)

Update Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Update Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Update()
public void Update()
See Also

Reference

Viewer Class
Viewer Members


UseWaitCursor Property (Viewer)

UseWaitCursor Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : UseWaitCursor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseWaitCursor As System.Boolean
public System.bool UseWaitCursor {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Validate Method (Viewer)

Validate Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Validate Method
Overload List
Overload | Description
Validate() | (Inherited from System.Windows.Forms.ContainerControl)
Validate(Boolean) | (Inherited from System.Windows.Forms.ContainerControl)
See Also

Reference

Viewer Class
Viewer Members


Validate() Method

Validate() Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Validate Method : Validate() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Validate() As System.Boolean
public System.bool Validate()
See Also

Reference

Viewer Class
Viewer Members
Overload List


Validate(Boolean) Method

Validate(Boolean) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > Validate Method : Validate(Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Validate( _
   ByVal checkAutoValidate As System.Boolean _
) As System.Boolean
public System.bool Validate(
   System.bool checkAutoValidate
)

Parameters

checkAutoValidate
See Also

Reference

Viewer Class
Viewer Members
Overload List


ValidateChildren Method (Viewer)

ValidateChildren Method (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : ValidateChildren Method
Overload List
Overload | Description
ValidateChildren() | (Inherited from System.Windows.Forms.UserControl)
ValidateChildren(ValidationConstraints) | (Inherited from System.Windows.Forms.UserControl)
See Also

Reference

Viewer Class
Viewer Members


ValidateChildren() Method

ValidateChildren() Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > ValidateChildren Method : ValidateChildren() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overridable Function ValidateChildren() As System.Boolean
public virtual System.bool ValidateChildren()
See Also

Reference

Viewer Class
Viewer Members
Overload List


ValidateChildren(ValidationConstraints) Method

ValidateChildren(ValidationConstraints) Method

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class > ValidateChildren Method : ValidateChildren(ValidationConstraints) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Overridable Function ValidateChildren( _
   ByVal validationConstraints As System.Windows.Forms.ValidationConstraints _
) As System.Boolean
public virtual System.bool ValidateChildren(
   System.Windows.Forms.ValidationConstraints validationConstraints
)

Parameters

validationConstraints
See Also

Reference

Viewer Class
Viewer Members
Overload List


Validated Event (Viewer)

Validated Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Validated Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Validated As System.EventHandler
public event System.EventHandler Validated
See Also

Reference

Viewer Class
Viewer Members


Validating Event (Viewer)

Validating Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Validating Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Validating As System.ComponentModel.CancelEventHandler
public event System.ComponentModel.CancelEventHandler Validating
Event Data

The event handler receives an argument of type System.ComponentModel.CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |
See Also

Reference

Viewer Class
Viewer Members


VerticalScroll Property (Viewer)

VerticalScroll Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : VerticalScroll Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property VerticalScroll As System.Windows.Forms.VScrollProperties
public System.Windows.Forms.VScrollProperties VerticalScroll {get;}
See Also

Reference

Viewer Class
Viewer Members


Visible Property (Viewer)

Visible Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Visible Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As System.Boolean
public System.bool Visible {get; set;}
See Also

Reference

Viewer Class
Viewer Members


VisibleChanged Event (Viewer)

VisibleChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : VisibleChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event VisibleChanged As System.EventHandler
public event System.EventHandler VisibleChanged
See Also

Reference

Viewer Class
Viewer Members


Width Property (Viewer)

Width Property (Viewer)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.ActiveReports.Viewer.Win Namespace > Viewer Class : Width Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As System.Integer
public System.int Width {get; set;}
See Also

Reference

Viewer Class
Viewer Members


GrapeCity.ActiveReports.Viewer.Win Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Viewer.Win Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Viewer.Win.v10 Assembly : GrapeCity.ActiveReports.Viewer.Win Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Viewer.Win.ReportParameter
GrapeCity.ActiveReports.Viewer.Win.Viewer.ViewerToolbar
System.EventArgs
GrapeCity.ActiveReports.Viewer.Win.FindEventArgs
GrapeCity.ActiveReports.Viewer.Win.HyperLinkEventArgs
GrapeCity.ActiveReports.Viewer.Win.ZoomChangedEventArgs
System.ComponentModel.CancelEventArgs
GrapeCity.ActiveReports.Viewer.Win.Viewer.ActionEventArgs
System.MarshalByRefObject
System.ComponentModel.Component
GrapeCity.ActiveReports.Viewer.Win.Sidebar
GrapeCity.ActiveReports.Viewer.Win.SidebarPanel
GrapeCity.ActiveReports.Viewer.Win.ParametersPanel
GrapeCity.ActiveReports.Viewer.Win.SearchPanel
GrapeCity.ActiveReports.Viewer.Win.ThumbnailsPanel
GrapeCity.ActiveReports.Viewer.Win.TocPanel
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
GrapeCity.ActiveReports.Viewer.Win.Viewer
See Also

Reference

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly


GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports.Viewer.Win.v10) Inheritance Hierarchy

GrapeCity.ActiveReports Namespace (GrapeCity.ActiveReports.Viewer.Win.v10) Inheritance Hierarchy
GrapeCity.ActiveReports.Viewer.Win.v10 Assembly : GrapeCity.ActiveReports Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.PrintExtension
See Also

Reference

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly


CachedPageView Class Properties

CachedPageView Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : CachedPageView Class

For a list of all members of this type, see CachedPageView members.

Public Properties
 | Name | Description
Public Property | Device | Gets the device kind. (Inherited from GrapeCity.Viewer.Common.PageView)
Public Property | Size | Gets the page view size. (Inherited from GrapeCity.Viewer.Common.PageView)
Top
See Also

Reference

CachedPageView Class
GrapeCity.Viewer.Common Namespace


Color Constructor

Color Constructor

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Color Constructor
Overload List
Overload | Description
Color Constructor | Initializes a new instance of the Color struct.
See Also

Reference

Color Structure
Color Members


DelegateCommand Class Events

DelegateCommand Class Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand Class

For a list of all members of this type, see DelegateCommand members.

Public Events
 | Name | Description
Public Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute. (Inherited from GrapeCity.Viewer.Common.DelegateCommand<object>)
Top
See Also

Reference

DelegateCommand Class
GrapeCity.Viewer.Common Namespace


DelegateCommand Class Methods

DelegateCommand Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand Class

For a list of all members of this type, see DelegateCommand members.

Public Methods
 | Name | Description
Public Method | CanExecute | Defines the method that determines whether the command can execute in its current state. (Inherited from GrapeCity.Viewer.Common.DelegateCommand<object>)
Public Method | Execute | Defines the method to be called when the command is invoked. (Inherited from GrapeCity.Viewer.Common.DelegateCommand<object>)
Public Method | RaiseCanExecuteChanged | Raise CanExecuteChanged event from external code. (Inherited from GrapeCity.Viewer.Common.DelegateCommand<object>)
Top
See Also

Reference

DelegateCommand Class
GrapeCity.Viewer.Common Namespace


DocumentRendererAttribute Class Methods

DocumentRendererAttribute Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : DocumentRendererAttribute Class

For a list of all members of this type, see DocumentRendererAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

DocumentRendererAttribute Class
GrapeCity.Viewer.Common Namespace


Equals Method (DocumentRendererAttribute)

Equals Method (DocumentRendererAttribute)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DocumentRendererAttribute Class : Equals Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public virtual System.bool Equals(
   System.object obj
)

Parameters

obj
See Also

Reference

DocumentRendererAttribute Class
DocumentRendererAttribute Members


GetHashCode Method (DocumentRendererAttribute)

GetHashCode Method (DocumentRendererAttribute)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DocumentRendererAttribute Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetHashCode() As System.Integer
public virtual System.int GetHashCode()
See Also

Reference

DocumentRendererAttribute Class
DocumentRendererAttribute Members


IsDefaultAttribute Method (DocumentRendererAttribute)

IsDefaultAttribute Method (DocumentRendererAttribute)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DocumentRendererAttribute Class : IsDefaultAttribute Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function IsDefaultAttribute() As System.Boolean
public virtual System.bool IsDefaultAttribute()
See Also

Reference

DocumentRendererAttribute Class
DocumentRendererAttribute Members


Match Method (DocumentRendererAttribute)

Match Method (DocumentRendererAttribute)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DocumentRendererAttribute Class : Match Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function Match( _
   ByVal obj As System.Object _
) As System.Boolean
public virtual System.bool Match(
   System.object obj
)

Parameters

obj
See Also

Reference

DocumentRendererAttribute Class
DocumentRendererAttribute Members


TypeId Property (DocumentRendererAttribute)

TypeId Property (DocumentRendererAttribute)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > DocumentRendererAttribute Class : TypeId Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property TypeId As System.Object
public virtual System.object TypeId {get;}
See Also

Reference

DocumentRendererAttribute Class
DocumentRendererAttribute Members


BaseDocumentModelImpl Class Events

BaseDocumentModelImpl Class Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : BaseDocumentModelImpl Class

For a list of all members of this type, see BaseDocumentModelImpl members.

Public Events
 | Name | Description
Public Event | PropertyChanged | (Inherited from GrapeCity.Viewer.Common.Model.ActiveModel)
Top
See Also

Reference

BaseDocumentModelImpl Class
GrapeCity.Viewer.Common.Model Namespace


BaseDocumentModelImpl Class Properties

BaseDocumentModelImpl Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : BaseDocumentModelImpl Class

For a list of all members of this type, see BaseDocumentModelImpl members.

Public Properties
 | Name | Description
Public Property | Annotations | Gets the annotations. (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | AnnotationsDocument | Gets the document to store annotations to (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | Bookmarks | Gets/sets document's bookmarks collection (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | CurrentSelection | (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | HighlightSearchResult | Gets or sets currently highlighted search result (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | MaxPageSize | Gets maximum page size (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | NotifySearchResult | Gets or sets currently notification search result (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | PageCount | Gets loaded pages count (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | PaperSize | Gets the default paper size of the document. In fact SectionReport allows variable pages while it's not implemented in model. PaperSize is then considered immutable. You can read it at any time and assume it's not changed anymore. (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Public Property | TotalPageCount | Returns number of total pages in document. This number can be higher then number of pages currently available. (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel)
Top
See Also

Reference

BaseDocumentModelImpl Class
GrapeCity.Viewer.Common.Model Namespace


GetItemText Method (BaseDocumentModelImpl)

GetItemText Method (BaseDocumentModelImpl)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace > BaseDocumentModelImpl Class : GetItemText Method
Overload List
Overload | Description
GetItemText |
See Also

Reference

BaseDocumentModelImpl Class
BaseDocumentModelImpl Members


BitmapCachedDocumentModel Class Events

BitmapCachedDocumentModel Class Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : BitmapCachedDocumentModel Class

For a list of all members of this type, see BitmapCachedDocumentModel members.

Public Events
 | Name | Description
Public Event | PropertyChanged | (Inherited from GrapeCity.Viewer.Common.Model.ActiveModel)
Top
See Also

Reference

BitmapCachedDocumentModel Class
GrapeCity.Viewer.Common.Model Namespace


DocumentModel.IImageItem Interface Properties

DocumentModel.IImageItem Interface Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel.IImageItem Interface

For a list of all members of this type, see DocumentModel.IImageItem members.

Public Properties
 | Name | Description
Property | Bounds | Gets item boundaries within a page (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel.IPageItem)
Property | ItemIndex | Uniquely identifies item within a page (Inherited from GrapeCity.Viewer.Common.Model.DocumentModel.IPageItem)
Top
See Also

Reference

DocumentModel.IImageItem Interface
GrapeCity.Viewer.Common.Model Namespace


DocumentModel Class Events

DocumentModel Class Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : DocumentModel Class

For a list of all members of this type, see DocumentModel members.

Public Events
 | Name | Description
Public Event | PropertyChanged | (Inherited from GrapeCity.Viewer.Common.Model.ActiveModel)
Top
See Also

Reference

DocumentModel Class
GrapeCity.Viewer.Common.Model Namespace


IDocumentConsumer Interface Methods

IDocumentConsumer Interface Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : IDocumentConsumer Interface

For a list of all members of this type, see IDocumentConsumer members.

Public Methods
 | Name | Description
Method | HandleError | Report about runtime error (Inherited from GrapeCity.Viewer.Common.Model.IErrorHandler)
Top
See Also

Reference

IDocumentConsumer Interface
GrapeCity.Viewer.Common.Model Namespace


ReportModelBase Class Events

ReportModelBase Class Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ReportModelBase Class

For a list of all members of this type, see ReportModelBase members.

Public Events
 | Name | Description
Public Event | PropertyChanged | (Inherited from GrapeCity.Viewer.Common.Model.ActiveModel)
Top
See Also

Reference

ReportModelBase Class
GrapeCity.Viewer.Common.Model Namespace


ReportPaneModel Class Events

ReportPaneModel Class Events

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common.Model Namespace : ReportPaneModel Class

For a list of all members of this type, see ReportPaneModel members.

Public Events
 | Name | Description
Public Event | PropertyChanged | (Inherited from GrapeCity.Viewer.Common.Model.ActiveModel)
Top
See Also

Reference

ReportPaneModel Class
GrapeCity.Viewer.Common.Model Namespace


GrapeCity.Viewer.Common.Model Namespace Inheritance Hierarchy

GrapeCity.Viewer.Common.Model Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Viewer.Win.v10 Assembly : GrapeCity.Viewer.Common.Model Namespace
Inheritance Hierarchy
System.Object
GrapeCity.Viewer.Common.Model.ActiveModel
GrapeCity.Viewer.Common.Model.DocumentModel
GrapeCity.Viewer.Common.Model.BaseDocumentModelImpl
GrapeCity.Viewer.Common.Model.BitmapCachedDocumentModel
GrapeCity.Viewer.Common.Model.HighlightDocumentViewModel
GrapeCity.Viewer.Common.Model.ReportModelBase
GrapeCity.Viewer.Common.Model.ReportPaneModel
GrapeCity.Viewer.Common.Model.ActiveModelListenExtensions
GrapeCity.Viewer.Common.Model.DocumentModel.TextItem
GrapeCity.Viewer.Common.Model.ExportFormatInfo
GrapeCity.Viewer.Common.Model.ExportOptions
GrapeCity.Viewer.Common.Model.FindOptions
GrapeCity.Viewer.Common.Model.HighlightPage
GrapeCity.Viewer.Common.Model.ObservableExtensions
GrapeCity.Viewer.Common.Model.ParameterizedReportExtensions
GrapeCity.Viewer.Common.Model.RelativeDatePart
GrapeCity.Viewer.Common.Model.RunOptions
GrapeCity.Viewer.Common.Model.SearchResult
GrapeCity.Viewer.Common.Model.TocTreeNode
System.ValueType
GrapeCity.Viewer.Common.Model.Bookmark
GrapeCity.Viewer.Common.Model.DocumentModel.PaperInfo
GrapeCity.Viewer.Common.Model.DocumentSelection
GrapeCity.Viewer.Common.Model.ErrorInfo
GrapeCity.Viewer.Common.Model.Frame
GrapeCity.Viewer.Common.Model.HighlightArea
GrapeCity.Viewer.Common.Model.Range
See Also

Reference

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly


ObservableCollection<T> Class Methods

ObservableCollection<T> Class Methods

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : ObservableCollection<T> Class

For a list of all members of this type, see ObservableCollection<T> members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<T>)
Top
See Also

Reference

ObservableCollection<T> Class
GrapeCity.Viewer.Common Namespace


ObservableCollection<T> Class Properties

ObservableCollection<T> Class Properties

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace : ObservableCollection<T> Class

For a list of all members of this type, see ObservableCollection<T> members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<T>)
Top
See Also

Reference

ObservableCollection<T> Class
GrapeCity.Viewer.Common Namespace


Add Method (ObservableCollection<T>)

Add Method (ObservableCollection<T>)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : Add Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Add( _
   ByVal item As T _
)
public void Add(
   T item
)

Parameters

item
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


Clear Method (ObservableCollection<T>)

Clear Method (ObservableCollection<T>)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : Clear Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


Contains Method (ObservableCollection<T>)

Contains Method (ObservableCollection<T>)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : Contains Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal item As T _
) As System.Boolean
public System.bool Contains(
   T item
)

Parameters

item
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


CopyTo Method (ObservableCollection<T>)

CopyTo Method (ObservableCollection<T>)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : CopyTo Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal array() As T, _
   ByVal index As System.Integer _
)
public void CopyTo(
   T[] array,
   System.int index
)

Parameters

array
index
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


Count Property (ObservableCollection<T>)

Count Property (ObservableCollection<T>)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : Count Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


IndexOf Method (ObservableCollection<T>)

IndexOf Method (ObservableCollection<T>)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : IndexOf Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal item As T _
) As System.Integer
public System.int IndexOf(
   T item
)

Parameters

item
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


Insert Method (ObservableCollection<T>)

Insert Method (ObservableCollection<T>)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : Insert Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As T _
)
public void Insert(
   System.int index,
   T item
)

Parameters

index
item
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


Item Property (ObservableCollection<T>)

Item Property (ObservableCollection<T>)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : Item Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As T
public T this[
   System.int index
]; {get; set;}

Parameters

index
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


Remove Method (ObservableCollection<T>)

Remove Method (ObservableCollection<T>)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : Remove Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Remove( _
   ByVal item As T _
) As System.Boolean
public System.bool Remove(
   T item
)

Parameters

item
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


RemoveAt Method (ObservableCollection<T>)

RemoveAt Method (ObservableCollection<T>)

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : RemoveAt Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


GrapeCity.Viewer.Common Namespace (GrapeCity.ActiveReports.Viewer.Win.v10) Inheritance Hierarchy

GrapeCity.Viewer.Common Namespace (GrapeCity.ActiveReports.Viewer.Win.v10) Inheritance Hierarchy
GrapeCity.ActiveReports.Viewer.Win.v10 Assembly : GrapeCity.Viewer.Common Namespace
Inheritance Hierarchy
System.Object
GrapeCity.Viewer.Common.DelegateCommand<TParm>
GrapeCity.Viewer.Common.DelegateCommand
GrapeCity.Viewer.Common.DisposablesCollection
GrapeCity.Viewer.Common.DocumentSearchService
GrapeCity.Viewer.Common.DoubleDelegateCommand
GrapeCity.Viewer.Common.EnumerableExtensions
GrapeCity.Viewer.Common.NullDelegateCommand
GrapeCity.Viewer.Common.NullRenderer
GrapeCity.Viewer.Common.NullRenderer.Factory
GrapeCity.Viewer.Common.PageView
GrapeCity.Viewer.Common.CachedPageView
GrapeCity.Viewer.Common.RectExtensions
GrapeCity.Viewer.Common.StreamDocumentLoader
System.Attribute
GrapeCity.Viewer.Common.DocumentRendererAttribute
System.Collections.ObjectModel.Collection<T>
GrapeCity.Viewer.Common.ObservableCollection<T>
System.EventArgs
GrapeCity.Viewer.Common.NotifyCollectionChangedEventArgs
System.ValueType
GrapeCity.Viewer.Common.Color
GrapeCity.Viewer.Common.Margin
GrapeCity.Viewer.Common.Point
GrapeCity.Viewer.Common.Rect
GrapeCity.Viewer.Common.Size
See Also

Reference

GrapeCity.ActiveReports.Viewer.Win.v10 Assembly


GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly
Namespaces
Namespace | Description
GrapeCity.ActiveReports.Viewer.Wpf | The GrapeCity.ActiveReports.Viewer.Wpf namepace contains the WPF viewer control and related types.
GrapeCity.Viewer.Common | The GrapeCity.Viewer.Common Namespace contains the IHistoryApi interface.


ClearValue Method (ParametersPanel)

ClearValue Method (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : ClearValue Method
Overload List
Overload | Description
ClearValue(DependencyProperty) | (Inherited from System.Windows.DependencyObject)
ClearValue(DependencyPropertyKey) | (Inherited from System.Windows.DependencyObject)
See Also

Reference

ParametersPanel Class
ParametersPanel Members


ClearValue(DependencyProperty) Method

ClearValue(DependencyProperty) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class > ClearValue Method : ClearValue(DependencyProperty) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ClearValue( _
   ByVal dp As System.Windows.DependencyProperty _
)
public void ClearValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

ParametersPanel Class
ParametersPanel Members
Overload List


ClearValue(DependencyPropertyKey) Method

ClearValue(DependencyPropertyKey) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class > ClearValue Method : ClearValue(DependencyPropertyKey) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ClearValue( _
   ByVal key As System.Windows.DependencyPropertyKey _
)
public void ClearValue(
   System.Windows.DependencyPropertyKey key
)

Parameters

key
See Also

Reference

ParametersPanel Class
ParametersPanel Members
Overload List


CoerceValue Method (ParametersPanel)

CoerceValue Method (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : CoerceValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CoerceValue( _
   ByVal dp As System.Windows.DependencyProperty _
)
public void CoerceValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

ParametersPanel Class
ParametersPanel Members


DependencyObjectType Property (ParametersPanel)

DependencyObjectType Property (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : DependencyObjectType Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DependencyObjectType As System.Windows.DependencyObjectType
public System.Windows.DependencyObjectType DependencyObjectType {get;}
See Also

Reference

ParametersPanel Class
ParametersPanel Members


Dispatcher Property (ParametersPanel)

Dispatcher Property (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : Dispatcher Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Dispatcher As System.Windows.Threading.Dispatcher
public System.Windows.Threading.Dispatcher Dispatcher {get;}
See Also

Reference

ParametersPanel Class
ParametersPanel Members


Equals Method (ParametersPanel)

Equals Method (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : Equals Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public System.bool Equals(
   System.object obj
)

Parameters

obj
See Also

Reference

ParametersPanel Class
ParametersPanel Members


GetHashCode Method (ParametersPanel)

GetHashCode Method (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetHashCode() As System.Integer
public System.int GetHashCode()
See Also

Reference

ParametersPanel Class
ParametersPanel Members


GetValue Method (ParametersPanel)

GetValue Method (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : GetValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetValue( _
   ByVal dp As System.Windows.DependencyProperty _
) As System.Object
public System.object GetValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

ParametersPanel Class
ParametersPanel Members


InvalidateProperty Method (ParametersPanel)

InvalidateProperty Method (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : InvalidateProperty Method
Overload List
Overload | Description
InvalidateProperty | (Inherited from System.Windows.DependencyObject)
See Also

Reference

ParametersPanel Class
ParametersPanel Members


InvalidateProperty(DependencyProperty) Method

InvalidateProperty(DependencyProperty) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : InvalidateProperty(DependencyProperty) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub InvalidateProperty( _
   ByVal dp As System.Windows.DependencyProperty _
)
public void InvalidateProperty(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

ParametersPanel Class
ParametersPanel Members


IsSealed Property (ParametersPanel)

IsSealed Property (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : IsSealed Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsSealed As System.Boolean
public System.bool IsSealed {get;}
See Also

Reference

ParametersPanel Class
ParametersPanel Members


ReadLocalValue Method (ParametersPanel)

ReadLocalValue Method (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : ReadLocalValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ReadLocalValue( _
   ByVal dp As System.Windows.DependencyProperty _
) As System.Object
public System.object ReadLocalValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

ParametersPanel Class
ParametersPanel Members


SetCurrentValue Method (ParametersPanel)

SetCurrentValue Method (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : SetCurrentValue Method
Overload List
Overload | Description
SetCurrentValue | (Inherited from System.Windows.DependencyObject)
See Also

Reference

ParametersPanel Class
ParametersPanel Members


SetCurrentValue(DependencyProperty,Object) Method

SetCurrentValue(DependencyProperty,Object) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : SetCurrentValue(DependencyProperty,Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetCurrentValue( _
   ByVal dp As System.Windows.DependencyProperty, _
   ByVal value As System.Object _
)
public void SetCurrentValue(
   System.Windows.DependencyProperty dp,
   System.object value
)

Parameters

dp
value
See Also

Reference

ParametersPanel Class
ParametersPanel Members


SetValue Method (ParametersPanel)

SetValue Method (ParametersPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class : SetValue Method
Overload List
Overload | Description
SetValue(DependencyProperty,Object) | (Inherited from System.Windows.DependencyObject)
SetValue(DependencyPropertyKey,Object) | (Inherited from System.Windows.DependencyObject)
See Also

Reference

ParametersPanel Class
ParametersPanel Members


SetValue(DependencyProperty,Object) Method

SetValue(DependencyProperty,Object) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class > SetValue Method : SetValue(DependencyProperty,Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetValue( _
   ByVal dp As System.Windows.DependencyProperty, _
   ByVal value As System.Object _
)
public void SetValue(
   System.Windows.DependencyProperty dp,
   System.object value
)

Parameters

dp
value
See Also

Reference

ParametersPanel Class
ParametersPanel Members
Overload List


SetValue(DependencyPropertyKey,Object) Method

SetValue(DependencyPropertyKey,Object) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ParametersPanel Class > SetValue Method : SetValue(DependencyPropertyKey,Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetValue( _
   ByVal key As System.Windows.DependencyPropertyKey, _
   ByVal value As System.Object _
)
public void SetValue(
   System.Windows.DependencyPropertyKey key,
   System.object value
)

Parameters

key
value
See Also

Reference

ParametersPanel Class
ParametersPanel Members
Overload List


ClearValue Method (SearchPanel)

ClearValue Method (SearchPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : ClearValue Method
Overload List
Overload | Description
ClearValue(DependencyProperty) | (Inherited from System.Windows.DependencyObject)
ClearValue(DependencyPropertyKey) | (Inherited from System.Windows.DependencyObject)
See Also

Reference

SearchPanel Class
SearchPanel Members


ClearValue(DependencyProperty) Method

ClearValue(DependencyProperty) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class > ClearValue Method : ClearValue(DependencyProperty) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ClearValue( _
   ByVal dp As System.Windows.DependencyProperty _
)
public void ClearValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

SearchPanel Class
SearchPanel Members
Overload List


ClearValue(DependencyPropertyKey) Method

ClearValue(DependencyPropertyKey) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class > ClearValue Method : ClearValue(DependencyPropertyKey) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ClearValue( _
   ByVal key As System.Windows.DependencyPropertyKey _
)
public void ClearValue(
   System.Windows.DependencyPropertyKey key
)

Parameters

key
See Also

Reference

SearchPanel Class
SearchPanel Members
Overload List


CoerceValue Method (SearchPanel)

CoerceValue Method (SearchPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : CoerceValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CoerceValue( _
   ByVal dp As System.Windows.DependencyProperty _
)
public void CoerceValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

SearchPanel Class
SearchPanel Members


DependencyObjectType Property (SearchPanel)

DependencyObjectType Property (SearchPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : DependencyObjectType Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DependencyObjectType As System.Windows.DependencyObjectType
public System.Windows.DependencyObjectType DependencyObjectType {get;}
See Also

Reference

SearchPanel Class
SearchPanel Members


Dispatcher Property (SearchPanel)

Dispatcher Property (SearchPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : Dispatcher Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Dispatcher As System.Windows.Threading.Dispatcher
public System.Windows.Threading.Dispatcher Dispatcher {get;}
See Also

Reference

SearchPanel Class
SearchPanel Members


Equals Method (SearchPanel)

Equals Method (SearchPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : Equals Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public System.bool Equals(
   System.object obj
)

Parameters

obj
See Also

Reference

SearchPanel Class
SearchPanel Members


GetHashCode Method (SearchPanel)

GetHashCode Method (SearchPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetHashCode() As System.Integer
public System.int GetHashCode()
See Also

Reference

SearchPanel Class
SearchPanel Members


GetValue Method (SearchPanel)

GetValue Method (SearchPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : GetValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetValue( _
   ByVal dp As System.Windows.DependencyProperty _
) As System.Object
public System.object GetValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

SearchPanel Class
SearchPanel Members


InvalidateProperty Method (SearchPanel)

InvalidateProperty Method (SearchPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : InvalidateProperty Method
Overload List
Overload | Description
InvalidateProperty | (Inherited from System.Windows.DependencyObject)
See Also

Reference

SearchPanel Class
SearchPanel Members


InvalidateProperty(DependencyProperty) Method

InvalidateProperty(DependencyProperty) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : InvalidateProperty(DependencyProperty) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub InvalidateProperty( _
   ByVal dp As System.Windows.DependencyProperty _
)
public void InvalidateProperty(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

SearchPanel Class
SearchPanel Members


IsSealed Property (SearchPanel)

IsSealed Property (SearchPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : IsSealed Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsSealed As System.Boolean
public System.bool IsSealed {get;}
See Also

Reference

SearchPanel Class
SearchPanel Members


ReadLocalValue Method (SearchPanel)

ReadLocalValue Method (SearchPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : ReadLocalValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ReadLocalValue( _
   ByVal dp As System.Windows.DependencyProperty _
) As System.Object
public System.object ReadLocalValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

SearchPanel Class
SearchPanel Members


SetCurrentValue Method (SearchPanel)

SetCurrentValue Method (SearchPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : SetCurrentValue Method
Overload List
Overload | Description
SetCurrentValue | (Inherited from System.Windows.DependencyObject)
See Also

Reference

SearchPanel Class
SearchPanel Members


SetCurrentValue(DependencyProperty,Object) Method

SetCurrentValue(DependencyProperty,Object) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : SetCurrentValue(DependencyProperty,Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetCurrentValue( _
   ByVal dp As System.Windows.DependencyProperty, _
   ByVal value As System.Object _
)
public void SetCurrentValue(
   System.Windows.DependencyProperty dp,
   System.object value
)

Parameters

dp
value
See Also

Reference

SearchPanel Class
SearchPanel Members


SetValue Method (SearchPanel)

SetValue Method (SearchPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class : SetValue Method
Overload List
Overload | Description
SetValue(DependencyProperty,Object) | (Inherited from System.Windows.DependencyObject)
SetValue(DependencyPropertyKey,Object) | (Inherited from System.Windows.DependencyObject)
See Also

Reference

SearchPanel Class
SearchPanel Members


SetValue(DependencyProperty,Object) Method

SetValue(DependencyProperty,Object) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class > SetValue Method : SetValue(DependencyProperty,Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetValue( _
   ByVal dp As System.Windows.DependencyProperty, _
   ByVal value As System.Object _
)
public void SetValue(
   System.Windows.DependencyProperty dp,
   System.object value
)

Parameters

dp
value
See Also

Reference

SearchPanel Class
SearchPanel Members
Overload List


SetValue(DependencyPropertyKey,Object) Method

SetValue(DependencyPropertyKey,Object) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SearchPanel Class > SetValue Method : SetValue(DependencyPropertyKey,Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetValue( _
   ByVal key As System.Windows.DependencyPropertyKey, _
   ByVal value As System.Object _
)
public void SetValue(
   System.Windows.DependencyPropertyKey key,
   System.object value
)

Parameters

key
value
See Also

Reference

SearchPanel Class
SearchPanel Members
Overload List


ClearValue Method (SidebarPanel)

ClearValue Method (SidebarPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : ClearValue Method
Overload List
Overload | Description
ClearValue(DependencyProperty) | (Inherited from System.Windows.DependencyObject)
ClearValue(DependencyPropertyKey) | (Inherited from System.Windows.DependencyObject)
See Also

Reference

SidebarPanel Class
SidebarPanel Members


ClearValue(DependencyProperty) Method

ClearValue(DependencyProperty) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class > ClearValue Method : ClearValue(DependencyProperty) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ClearValue( _
   ByVal dp As System.Windows.DependencyProperty _
)
public void ClearValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

SidebarPanel Class
SidebarPanel Members
Overload List


ClearValue(DependencyPropertyKey) Method

ClearValue(DependencyPropertyKey) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class > ClearValue Method : ClearValue(DependencyPropertyKey) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ClearValue( _
   ByVal key As System.Windows.DependencyPropertyKey _
)
public void ClearValue(
   System.Windows.DependencyPropertyKey key
)

Parameters

key
See Also

Reference

SidebarPanel Class
SidebarPanel Members
Overload List


CoerceValue Method (SidebarPanel)

CoerceValue Method (SidebarPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : CoerceValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CoerceValue( _
   ByVal dp As System.Windows.DependencyProperty _
)
public void CoerceValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

SidebarPanel Class
SidebarPanel Members


DependencyObjectType Property (SidebarPanel)

DependencyObjectType Property (SidebarPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : DependencyObjectType Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DependencyObjectType As System.Windows.DependencyObjectType
public System.Windows.DependencyObjectType DependencyObjectType {get;}
See Also

Reference

SidebarPanel Class
SidebarPanel Members


Dispatcher Property (SidebarPanel)

Dispatcher Property (SidebarPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : Dispatcher Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Dispatcher As System.Windows.Threading.Dispatcher
public System.Windows.Threading.Dispatcher Dispatcher {get;}
See Also

Reference

SidebarPanel Class
SidebarPanel Members


Equals Method (SidebarPanel)

Equals Method (SidebarPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : Equals Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public System.bool Equals(
   System.object obj
)

Parameters

obj
See Also

Reference

SidebarPanel Class
SidebarPanel Members


GetHashCode Method (SidebarPanel)

GetHashCode Method (SidebarPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetHashCode() As System.Integer
public System.int GetHashCode()
See Also

Reference

SidebarPanel Class
SidebarPanel Members


GetValue Method (SidebarPanel)

GetValue Method (SidebarPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : GetValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetValue( _
   ByVal dp As System.Windows.DependencyProperty _
) As System.Object
public System.object GetValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

SidebarPanel Class
SidebarPanel Members


InvalidateProperty Method (SidebarPanel)

InvalidateProperty Method (SidebarPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : InvalidateProperty Method
Overload List
Overload | Description
InvalidateProperty | (Inherited from System.Windows.DependencyObject)
See Also

Reference

SidebarPanel Class
SidebarPanel Members


InvalidateProperty(DependencyProperty) Method

InvalidateProperty(DependencyProperty) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : InvalidateProperty(DependencyProperty) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub InvalidateProperty( _
   ByVal dp As System.Windows.DependencyProperty _
)
public void InvalidateProperty(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

SidebarPanel Class
SidebarPanel Members


IsSealed Property (SidebarPanel)

IsSealed Property (SidebarPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : IsSealed Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsSealed As System.Boolean
public System.bool IsSealed {get;}
See Also

Reference

SidebarPanel Class
SidebarPanel Members


ReadLocalValue Method (SidebarPanel)

ReadLocalValue Method (SidebarPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : ReadLocalValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ReadLocalValue( _
   ByVal dp As System.Windows.DependencyProperty _
) As System.Object
public System.object ReadLocalValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

SidebarPanel Class
SidebarPanel Members


SetCurrentValue Method (SidebarPanel)

SetCurrentValue Method (SidebarPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : SetCurrentValue Method
Overload List
Overload | Description
SetCurrentValue | (Inherited from System.Windows.DependencyObject)
See Also

Reference

SidebarPanel Class
SidebarPanel Members


SetCurrentValue(DependencyProperty,Object) Method

SetCurrentValue(DependencyProperty,Object) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : SetCurrentValue(DependencyProperty,Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetCurrentValue( _
   ByVal dp As System.Windows.DependencyProperty, _
   ByVal value As System.Object _
)
public void SetCurrentValue(
   System.Windows.DependencyProperty dp,
   System.object value
)

Parameters

dp
value
See Also

Reference

SidebarPanel Class
SidebarPanel Members


SetValue Method (SidebarPanel)

SetValue Method (SidebarPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class : SetValue Method
Overload List
Overload | Description
SetValue(DependencyProperty,Object) | (Inherited from System.Windows.DependencyObject)
SetValue(DependencyPropertyKey,Object) | (Inherited from System.Windows.DependencyObject)
See Also

Reference

SidebarPanel Class
SidebarPanel Members


SetValue(DependencyProperty,Object) Method

SetValue(DependencyProperty,Object) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class > SetValue Method : SetValue(DependencyProperty,Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetValue( _
   ByVal dp As System.Windows.DependencyProperty, _
   ByVal value As System.Object _
)
public void SetValue(
   System.Windows.DependencyProperty dp,
   System.object value
)

Parameters

dp
value
See Also

Reference

SidebarPanel Class
SidebarPanel Members
Overload List


SetValue(DependencyPropertyKey,Object) Method

SetValue(DependencyPropertyKey,Object) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > SidebarPanel Class > SetValue Method : SetValue(DependencyPropertyKey,Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetValue( _
   ByVal key As System.Windows.DependencyPropertyKey, _
   ByVal value As System.Object _
)
public void SetValue(
   System.Windows.DependencyPropertyKey key,
   System.object value
)

Parameters

key
value
See Also

Reference

SidebarPanel Class
SidebarPanel Members
Overload List


ClearValue Method (Sidebar)

ClearValue Method (Sidebar)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : ClearValue Method
Overload List
Overload | Description
ClearValue(DependencyProperty) | (Inherited from System.Windows.DependencyObject)
ClearValue(DependencyPropertyKey) | (Inherited from System.Windows.DependencyObject)
See Also

Reference

Sidebar Class
Sidebar Members


ClearValue(DependencyProperty) Method

ClearValue(DependencyProperty) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class > ClearValue Method : ClearValue(DependencyProperty) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ClearValue( _
   ByVal dp As System.Windows.DependencyProperty _
)
public void ClearValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

Sidebar Class
Sidebar Members
Overload List


ClearValue(DependencyPropertyKey) Method

ClearValue(DependencyPropertyKey) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class > ClearValue Method : ClearValue(DependencyPropertyKey) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ClearValue( _
   ByVal key As System.Windows.DependencyPropertyKey _
)
public void ClearValue(
   System.Windows.DependencyPropertyKey key
)

Parameters

key
See Also

Reference

Sidebar Class
Sidebar Members
Overload List


CoerceValue Method (Sidebar)

CoerceValue Method (Sidebar)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : CoerceValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CoerceValue( _
   ByVal dp As System.Windows.DependencyProperty _
)
public void CoerceValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

Sidebar Class
Sidebar Members


DependencyObjectType Property (Sidebar)

DependencyObjectType Property (Sidebar)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : DependencyObjectType Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DependencyObjectType As System.Windows.DependencyObjectType
public System.Windows.DependencyObjectType DependencyObjectType {get;}
See Also

Reference

Sidebar Class
Sidebar Members


Dispatcher Property (Sidebar)

Dispatcher Property (Sidebar)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : Dispatcher Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Dispatcher As System.Windows.Threading.Dispatcher
public System.Windows.Threading.Dispatcher Dispatcher {get;}
See Also

Reference

Sidebar Class
Sidebar Members


Equals Method (Sidebar)

Equals Method (Sidebar)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : Equals Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public System.bool Equals(
   System.object obj
)

Parameters

obj
See Also

Reference

Sidebar Class
Sidebar Members


GetHashCode Method (Sidebar)

GetHashCode Method (Sidebar)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetHashCode() As System.Integer
public System.int GetHashCode()
See Also

Reference

Sidebar Class
Sidebar Members


GetValue Method (Sidebar)

GetValue Method (Sidebar)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : GetValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetValue( _
   ByVal dp As System.Windows.DependencyProperty _
) As System.Object
public System.object GetValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

Sidebar Class
Sidebar Members


InvalidateProperty Method (Sidebar)

InvalidateProperty Method (Sidebar)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : InvalidateProperty Method
Overload List
Overload | Description
InvalidateProperty | (Inherited from System.Windows.DependencyObject)
See Also

Reference

Sidebar Class
Sidebar Members


InvalidateProperty(DependencyProperty) Method

InvalidateProperty(DependencyProperty) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : InvalidateProperty(DependencyProperty) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub InvalidateProperty( _
   ByVal dp As System.Windows.DependencyProperty _
)
public void InvalidateProperty(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

Sidebar Class
Sidebar Members


IsSealed Property (Sidebar)

IsSealed Property (Sidebar)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : IsSealed Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsSealed As System.Boolean
public System.bool IsSealed {get;}
See Also

Reference

Sidebar Class
Sidebar Members


ReadLocalValue Method (Sidebar)

ReadLocalValue Method (Sidebar)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : ReadLocalValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ReadLocalValue( _
   ByVal dp As System.Windows.DependencyProperty _
) As System.Object
public System.object ReadLocalValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

Sidebar Class
Sidebar Members


SetCurrentValue Method (Sidebar)

SetCurrentValue Method (Sidebar)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : SetCurrentValue Method
Overload List
Overload | Description
SetCurrentValue | (Inherited from System.Windows.DependencyObject)
See Also

Reference

Sidebar Class
Sidebar Members


SetCurrentValue(DependencyProperty,Object) Method

SetCurrentValue(DependencyProperty,Object) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : SetCurrentValue(DependencyProperty,Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetCurrentValue( _
   ByVal dp As System.Windows.DependencyProperty, _
   ByVal value As System.Object _
)
public void SetCurrentValue(
   System.Windows.DependencyProperty dp,
   System.object value
)

Parameters

dp
value
See Also

Reference

Sidebar Class
Sidebar Members


SetValue Method (Sidebar)

SetValue Method (Sidebar)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class : SetValue Method
Overload List
Overload | Description
SetValue(DependencyProperty,Object) | (Inherited from System.Windows.DependencyObject)
SetValue(DependencyPropertyKey,Object) | (Inherited from System.Windows.DependencyObject)
See Also

Reference

Sidebar Class
Sidebar Members


SetValue(DependencyProperty,Object) Method

SetValue(DependencyProperty,Object) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class > SetValue Method : SetValue(DependencyProperty,Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetValue( _
   ByVal dp As System.Windows.DependencyProperty, _
   ByVal value As System.Object _
)
public void SetValue(
   System.Windows.DependencyProperty dp,
   System.object value
)

Parameters

dp
value
See Also

Reference

Sidebar Class
Sidebar Members
Overload List


SetValue(DependencyPropertyKey,Object) Method

SetValue(DependencyPropertyKey,Object) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Sidebar Class > SetValue Method : SetValue(DependencyPropertyKey,Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetValue( _
   ByVal key As System.Windows.DependencyPropertyKey, _
   ByVal value As System.Object _
)
public void SetValue(
   System.Windows.DependencyPropertyKey key,
   System.object value
)

Parameters

key
value
See Also

Reference

Sidebar Class
Sidebar Members
Overload List


ClearValue Method (ThumbnailsPanel)

ClearValue Method (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : ClearValue Method
Overload List
Overload | Description
ClearValue(DependencyProperty) | (Inherited from System.Windows.DependencyObject)
ClearValue(DependencyPropertyKey) | (Inherited from System.Windows.DependencyObject)
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


ClearValue(DependencyProperty) Method

ClearValue(DependencyProperty) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class > ClearValue Method : ClearValue(DependencyProperty) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ClearValue( _
   ByVal dp As System.Windows.DependencyProperty _
)
public void ClearValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members
Overload List


ClearValue(DependencyPropertyKey) Method

ClearValue(DependencyPropertyKey) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class > ClearValue Method : ClearValue(DependencyPropertyKey) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ClearValue( _
   ByVal key As System.Windows.DependencyPropertyKey _
)
public void ClearValue(
   System.Windows.DependencyPropertyKey key
)

Parameters

key
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members
Overload List


CoerceValue Method (ThumbnailsPanel)

CoerceValue Method (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : CoerceValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CoerceValue( _
   ByVal dp As System.Windows.DependencyProperty _
)
public void CoerceValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


DependencyObjectType Property (ThumbnailsPanel)

DependencyObjectType Property (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : DependencyObjectType Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DependencyObjectType As System.Windows.DependencyObjectType
public System.Windows.DependencyObjectType DependencyObjectType {get;}
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


Dispatcher Property (ThumbnailsPanel)

Dispatcher Property (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : Dispatcher Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Dispatcher As System.Windows.Threading.Dispatcher
public System.Windows.Threading.Dispatcher Dispatcher {get;}
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


Equals Method (ThumbnailsPanel)

Equals Method (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : Equals Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public System.bool Equals(
   System.object obj
)

Parameters

obj
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


GetHashCode Method (ThumbnailsPanel)

GetHashCode Method (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetHashCode() As System.Integer
public System.int GetHashCode()
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


GetValue Method (ThumbnailsPanel)

GetValue Method (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : GetValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetValue( _
   ByVal dp As System.Windows.DependencyProperty _
) As System.Object
public System.object GetValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


InvalidateProperty Method (ThumbnailsPanel)

InvalidateProperty Method (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : InvalidateProperty Method
Overload List
Overload | Description
InvalidateProperty | (Inherited from System.Windows.DependencyObject)
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


InvalidateProperty(DependencyProperty) Method

InvalidateProperty(DependencyProperty) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : InvalidateProperty(DependencyProperty) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub InvalidateProperty( _
   ByVal dp As System.Windows.DependencyProperty _
)
public void InvalidateProperty(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


IsSealed Property (ThumbnailsPanel)

IsSealed Property (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : IsSealed Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsSealed As System.Boolean
public System.bool IsSealed {get;}
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


ReadLocalValue Method (ThumbnailsPanel)

ReadLocalValue Method (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : ReadLocalValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ReadLocalValue( _
   ByVal dp As System.Windows.DependencyProperty _
) As System.Object
public System.object ReadLocalValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


SetCurrentValue Method (ThumbnailsPanel)

SetCurrentValue Method (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : SetCurrentValue Method
Overload List
Overload | Description
SetCurrentValue | (Inherited from System.Windows.DependencyObject)
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


SetCurrentValue(DependencyProperty,Object) Method

SetCurrentValue(DependencyProperty,Object) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : SetCurrentValue(DependencyProperty,Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetCurrentValue( _
   ByVal dp As System.Windows.DependencyProperty, _
   ByVal value As System.Object _
)
public void SetCurrentValue(
   System.Windows.DependencyProperty dp,
   System.object value
)

Parameters

dp
value
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


SetValue Method (ThumbnailsPanel)

SetValue Method (ThumbnailsPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class : SetValue Method
Overload List
Overload | Description
SetValue(DependencyProperty,Object) | (Inherited from System.Windows.DependencyObject)
SetValue(DependencyPropertyKey,Object) | (Inherited from System.Windows.DependencyObject)
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members


SetValue(DependencyProperty,Object) Method

SetValue(DependencyProperty,Object) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class > SetValue Method : SetValue(DependencyProperty,Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetValue( _
   ByVal dp As System.Windows.DependencyProperty, _
   ByVal value As System.Object _
)
public void SetValue(
   System.Windows.DependencyProperty dp,
   System.object value
)

Parameters

dp
value
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members
Overload List


SetValue(DependencyPropertyKey,Object) Method

SetValue(DependencyPropertyKey,Object) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > ThumbnailsPanel Class > SetValue Method : SetValue(DependencyPropertyKey,Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetValue( _
   ByVal key As System.Windows.DependencyPropertyKey, _
   ByVal value As System.Object _
)
public void SetValue(
   System.Windows.DependencyPropertyKey key,
   System.object value
)

Parameters

key
value
See Also

Reference

ThumbnailsPanel Class
ThumbnailsPanel Members
Overload List


ClearValue Method (TocPanel)

ClearValue Method (TocPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : ClearValue Method
Overload List
Overload | Description
ClearValue(DependencyProperty) | (Inherited from System.Windows.DependencyObject)
ClearValue(DependencyPropertyKey) | (Inherited from System.Windows.DependencyObject)
See Also

Reference

TocPanel Class
TocPanel Members


ClearValue(DependencyProperty) Method

ClearValue(DependencyProperty) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class > ClearValue Method : ClearValue(DependencyProperty) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ClearValue( _
   ByVal dp As System.Windows.DependencyProperty _
)
public void ClearValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

TocPanel Class
TocPanel Members
Overload List


ClearValue(DependencyPropertyKey) Method

ClearValue(DependencyPropertyKey) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class > ClearValue Method : ClearValue(DependencyPropertyKey) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ClearValue( _
   ByVal key As System.Windows.DependencyPropertyKey _
)
public void ClearValue(
   System.Windows.DependencyPropertyKey key
)

Parameters

key
See Also

Reference

TocPanel Class
TocPanel Members
Overload List


CoerceValue Method (TocPanel)

CoerceValue Method (TocPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : CoerceValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CoerceValue( _
   ByVal dp As System.Windows.DependencyProperty _
)
public void CoerceValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

TocPanel Class
TocPanel Members


DependencyObjectType Property (TocPanel)

DependencyObjectType Property (TocPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : DependencyObjectType Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DependencyObjectType As System.Windows.DependencyObjectType
public System.Windows.DependencyObjectType DependencyObjectType {get;}
See Also

Reference

TocPanel Class
TocPanel Members


Dispatcher Property (TocPanel)

Dispatcher Property (TocPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : Dispatcher Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Dispatcher As System.Windows.Threading.Dispatcher
public System.Windows.Threading.Dispatcher Dispatcher {get;}
See Also

Reference

TocPanel Class
TocPanel Members


Equals Method (TocPanel)

Equals Method (TocPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : Equals Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public System.bool Equals(
   System.object obj
)

Parameters

obj
See Also

Reference

TocPanel Class
TocPanel Members


GetHashCode Method (TocPanel)

GetHashCode Method (TocPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetHashCode() As System.Integer
public System.int GetHashCode()
See Also

Reference

TocPanel Class
TocPanel Members


GetValue Method (TocPanel)

GetValue Method (TocPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : GetValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetValue( _
   ByVal dp As System.Windows.DependencyProperty _
) As System.Object
public System.object GetValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

TocPanel Class
TocPanel Members


InvalidateProperty Method (TocPanel)

InvalidateProperty Method (TocPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : InvalidateProperty Method
Overload List
Overload | Description
InvalidateProperty | (Inherited from System.Windows.DependencyObject)
See Also

Reference

TocPanel Class
TocPanel Members


InvalidateProperty(DependencyProperty) Method

InvalidateProperty(DependencyProperty) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : InvalidateProperty(DependencyProperty) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub InvalidateProperty( _
   ByVal dp As System.Windows.DependencyProperty _
)
public void InvalidateProperty(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

TocPanel Class
TocPanel Members


IsSealed Property (TocPanel)

IsSealed Property (TocPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : IsSealed Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsSealed As System.Boolean
public System.bool IsSealed {get;}
See Also

Reference

TocPanel Class
TocPanel Members


ReadLocalValue Method (TocPanel)

ReadLocalValue Method (TocPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : ReadLocalValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ReadLocalValue( _
   ByVal dp As System.Windows.DependencyProperty _
) As System.Object
public System.object ReadLocalValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

TocPanel Class
TocPanel Members


SetCurrentValue Method (TocPanel)

SetCurrentValue Method (TocPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : SetCurrentValue Method
Overload List
Overload | Description
SetCurrentValue | (Inherited from System.Windows.DependencyObject)
See Also

Reference

TocPanel Class
TocPanel Members


SetCurrentValue(DependencyProperty,Object) Method

SetCurrentValue(DependencyProperty,Object) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : SetCurrentValue(DependencyProperty,Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetCurrentValue( _
   ByVal dp As System.Windows.DependencyProperty, _
   ByVal value As System.Object _
)
public void SetCurrentValue(
   System.Windows.DependencyProperty dp,
   System.object value
)

Parameters

dp
value
See Also

Reference

TocPanel Class
TocPanel Members


SetValue Method (TocPanel)

SetValue Method (TocPanel)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class : SetValue Method
Overload List
Overload | Description
SetValue(DependencyProperty,Object) | (Inherited from System.Windows.DependencyObject)
SetValue(DependencyPropertyKey,Object) | (Inherited from System.Windows.DependencyObject)
See Also

Reference

TocPanel Class
TocPanel Members


SetValue(DependencyProperty,Object) Method

SetValue(DependencyProperty,Object) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class > SetValue Method : SetValue(DependencyProperty,Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetValue( _
   ByVal dp As System.Windows.DependencyProperty, _
   ByVal value As System.Object _
)
public void SetValue(
   System.Windows.DependencyProperty dp,
   System.object value
)

Parameters

dp
value
See Also

Reference

TocPanel Class
TocPanel Members
Overload List


SetValue(DependencyPropertyKey,Object) Method

SetValue(DependencyPropertyKey,Object) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > TocPanel Class > SetValue Method : SetValue(DependencyPropertyKey,Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetValue( _
   ByVal key As System.Windows.DependencyPropertyKey, _
   ByVal value As System.Object _
)
public void SetValue(
   System.Windows.DependencyPropertyKey key,
   System.object value
)

Parameters

key
value
See Also

Reference

TocPanel Class
TocPanel Members
Overload List


Viewer.ActionEventArgs Constructor

Viewer.ActionEventArgs Constructor

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer.ActionEventArgs Class : Viewer.ActionEventArgs Constructor
Initializes the new instance of Viewer.ActionEventArgs class.
Overload List
Overload | Description
Viewer.ActionEventArgs Constructor | Initializes the new instance of ActionEventArgs class.
Requirements

See Also

Reference

Viewer.ActionEventArgs Class
Viewer.ActionEventArgs Members


Cancel Property (Viewer.ActionEventArgs)

Cancel Property (Viewer.ActionEventArgs)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer.ActionEventArgs Class : Cancel Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Cancel As System.Boolean
public System.bool Cancel {get; set;}
See Also

Reference

Viewer.ActionEventArgs Class
Viewer.ActionEventArgs Members


ActualHeight Property (Viewer)

ActualHeight Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ActualHeight Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ActualHeight As System.Double
public System.double ActualHeight {get;}
See Also

Reference

Viewer Class
Viewer Members


ActualWidth Property (Viewer)

ActualWidth Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ActualWidth Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ActualWidth As System.Double
public System.double ActualWidth {get;}
See Also

Reference

Viewer Class
Viewer Members


AddHandler Method (Viewer)

AddHandler Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : AddHandler Method
Overload List
Overload | Description
AddHandler(RoutedEvent,Delegate) | (Inherited from System.Windows.UIElement)
AddHandler(RoutedEvent,Delegate,Boolean) | (Inherited from System.Windows.UIElement)
See Also

Reference

Viewer Class
Viewer Members


AddHandler(RoutedEvent,Delegate) Method

AddHandler(RoutedEvent,Delegate) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > AddHandler Method : AddHandler(RoutedEvent,Delegate) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddHandler( _
   ByVal routedEvent As System.Windows.RoutedEvent, _
   ByVal handler As System.Delegate _
)
public void AddHandler(
   System.Windows.RoutedEvent routedEvent,
   System.Delegate handler
)

Parameters

routedEvent
handler
See Also

Reference

Viewer Class
Viewer Members
Overload List


AddHandler(RoutedEvent,Delegate,Boolean) Method

AddHandler(RoutedEvent,Delegate,Boolean) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > AddHandler Method : AddHandler(RoutedEvent,Delegate,Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddHandler( _
   ByVal routedEvent As System.Windows.RoutedEvent, _
   ByVal handler As System.Delegate, _
   ByVal handledEventsToo As System.Boolean _
)
public void AddHandler(
   System.Windows.RoutedEvent routedEvent,
   System.Delegate handler,
   System.bool handledEventsToo
)

Parameters

routedEvent
handler
handledEventsToo
See Also

Reference

Viewer Class
Viewer Members
Overload List


AddToEventRoute Method

AddToEventRoute Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : AddToEventRoute Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddToEventRoute( _
   ByVal route As System.Windows.EventRoute, _
   ByVal e As System.Windows.RoutedEventArgs _
)
public void AddToEventRoute(
   System.Windows.EventRoute route,
   System.Windows.RoutedEventArgs e
)

Parameters

route
e
See Also

Reference

Viewer Class
Viewer Members


AllowDrop Property (Viewer)

AllowDrop Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : AllowDrop Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AllowDrop As System.Boolean
public System.bool AllowDrop {get; set;}
See Also

Reference

Viewer Class
Viewer Members


ApplyAnimationClock Method

ApplyAnimationClock Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ApplyAnimationClock Method
Overload List
Overload | Description
ApplyAnimationClock(DependencyProperty,AnimationClock) | (Inherited from System.Windows.UIElement)
ApplyAnimationClock(DependencyProperty,AnimationClock,HandoffBehavior) | (Inherited from System.Windows.UIElement)
See Also

Reference

Viewer Class
Viewer Members


ApplyAnimationClock(DependencyProperty,AnimationClock) Method

ApplyAnimationClock(DependencyProperty,AnimationClock) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > ApplyAnimationClock Method : ApplyAnimationClock(DependencyProperty,AnimationClock) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ApplyAnimationClock( _
   ByVal dp As System.Windows.DependencyProperty, _
   ByVal clock As System.Windows.Media.Animation.AnimationClock _
)
public void ApplyAnimationClock(
   System.Windows.DependencyProperty dp,
   System.Windows.Media.Animation.AnimationClock clock
)

Parameters

dp
clock
See Also

Reference

Viewer Class
Viewer Members
Overload List


ApplyAnimationClock(DependencyProperty,AnimationClock,HandoffBehavior) Method

ApplyAnimationClock(DependencyProperty,AnimationClock,HandoffBehavior) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > ApplyAnimationClock Method : ApplyAnimationClock(DependencyProperty,AnimationClock,HandoffBehavior) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ApplyAnimationClock( _
   ByVal dp As System.Windows.DependencyProperty, _
   ByVal clock As System.Windows.Media.Animation.AnimationClock, _
   ByVal handoffBehavior As System.Windows.Media.Animation.HandoffBehavior _
)
public void ApplyAnimationClock(
   System.Windows.DependencyProperty dp,
   System.Windows.Media.Animation.AnimationClock clock,
   System.Windows.Media.Animation.HandoffBehavior handoffBehavior
)

Parameters

dp
clock
handoffBehavior
See Also

Reference

Viewer Class
Viewer Members
Overload List


ApplyTemplate Method (Viewer)

ApplyTemplate Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ApplyTemplate Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ApplyTemplate() As System.Boolean
public System.bool ApplyTemplate()
See Also

Reference

Viewer Class
Viewer Members


AreAnyTouchesCaptured Property

AreAnyTouchesCaptured Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : AreAnyTouchesCaptured Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property AreAnyTouchesCaptured As System.Boolean
public System.bool AreAnyTouchesCaptured {get;}
See Also

Reference

Viewer Class
Viewer Members


AreAnyTouchesCapturedWithin Property

AreAnyTouchesCapturedWithin Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : AreAnyTouchesCapturedWithin Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property AreAnyTouchesCapturedWithin As System.Boolean
public System.bool AreAnyTouchesCapturedWithin {get;}
See Also

Reference

Viewer Class
Viewer Members


AreAnyTouchesDirectlyOver Property

AreAnyTouchesDirectlyOver Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : AreAnyTouchesDirectlyOver Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property AreAnyTouchesDirectlyOver As System.Boolean
public System.bool AreAnyTouchesDirectlyOver {get;}
See Also

Reference

Viewer Class
Viewer Members


AreAnyTouchesOver Property

AreAnyTouchesOver Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : AreAnyTouchesOver Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property AreAnyTouchesOver As System.Boolean
public System.bool AreAnyTouchesOver {get;}
See Also

Reference

Viewer Class
Viewer Members


Arrange Method (Viewer)

Arrange Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Arrange Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Arrange( _
   ByVal finalRect As System.Windows.Rect _
)
public void Arrange(
   System.Windows.Rect finalRect
)

Parameters

finalRect
See Also

Reference

Viewer Class
Viewer Members


Background Property (Viewer)

Background Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Background Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Background As System.Windows.Media.Brush
public System.Windows.Media.Brush Background {get; set;}
See Also

Reference

Viewer Class
Viewer Members


BeginAnimation Method

BeginAnimation Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : BeginAnimation Method
Overload List
Overload | Description
BeginAnimation(DependencyProperty,AnimationTimeline) | (Inherited from System.Windows.UIElement)
BeginAnimation(DependencyProperty,AnimationTimeline,HandoffBehavior) | (Inherited from System.Windows.UIElement)
See Also

Reference

Viewer Class
Viewer Members


BeginAnimation(DependencyProperty,AnimationTimeline) Method

BeginAnimation(DependencyProperty,AnimationTimeline) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > BeginAnimation Method : BeginAnimation(DependencyProperty,AnimationTimeline) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub BeginAnimation( _
   ByVal dp As System.Windows.DependencyProperty, _
   ByVal animation As System.Windows.Media.Animation.AnimationTimeline _
)
public void BeginAnimation(
   System.Windows.DependencyProperty dp,
   System.Windows.Media.Animation.AnimationTimeline animation
)

Parameters

dp
animation
See Also

Reference

Viewer Class
Viewer Members
Overload List


BeginAnimation(DependencyProperty,AnimationTimeline,HandoffBehavior) Method

BeginAnimation(DependencyProperty,AnimationTimeline,HandoffBehavior) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > BeginAnimation Method : BeginAnimation(DependencyProperty,AnimationTimeline,HandoffBehavior) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub BeginAnimation( _
   ByVal dp As System.Windows.DependencyProperty, _
   ByVal animation As System.Windows.Media.Animation.AnimationTimeline, _
   ByVal handoffBehavior As System.Windows.Media.Animation.HandoffBehavior _
)
public void BeginAnimation(
   System.Windows.DependencyProperty dp,
   System.Windows.Media.Animation.AnimationTimeline animation,
   System.Windows.Media.Animation.HandoffBehavior handoffBehavior
)

Parameters

dp
animation
handoffBehavior
See Also

Reference

Viewer Class
Viewer Members
Overload List


BeginInit Method

BeginInit Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : BeginInit Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub BeginInit()
public virtual void BeginInit()
See Also

Reference

Viewer Class
Viewer Members


BeginStoryboard Method

BeginStoryboard Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : BeginStoryboard Method
Overload List
Overload | Description
BeginStoryboard(Storyboard) | (Inherited from System.Windows.FrameworkElement)
BeginStoryboard(Storyboard,HandoffBehavior) | (Inherited from System.Windows.FrameworkElement)
BeginStoryboard(Storyboard,HandoffBehavior,Boolean) | (Inherited from System.Windows.FrameworkElement)
See Also

Reference

Viewer Class
Viewer Members


BeginStoryboard(Storyboard) Method

BeginStoryboard(Storyboard) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > BeginStoryboard Method : BeginStoryboard(Storyboard) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub BeginStoryboard( _
   ByVal storyboard As System.Windows.Media.Animation.Storyboard _
)
public void BeginStoryboard(
   System.Windows.Media.Animation.Storyboard storyboard
)

Parameters

storyboard
See Also

Reference

Viewer Class
Viewer Members
Overload List


BeginStoryboard(Storyboard,HandoffBehavior) Method

BeginStoryboard(Storyboard,HandoffBehavior) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > BeginStoryboard Method : BeginStoryboard(Storyboard,HandoffBehavior) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub BeginStoryboard( _
   ByVal storyboard As System.Windows.Media.Animation.Storyboard, _
   ByVal handoffBehavior As System.Windows.Media.Animation.HandoffBehavior _
)
public void BeginStoryboard(
   System.Windows.Media.Animation.Storyboard storyboard,
   System.Windows.Media.Animation.HandoffBehavior handoffBehavior
)

Parameters

storyboard
handoffBehavior
See Also

Reference

Viewer Class
Viewer Members
Overload List


BeginStoryboard(Storyboard,HandoffBehavior,Boolean) Method

BeginStoryboard(Storyboard,HandoffBehavior,Boolean) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > BeginStoryboard Method : BeginStoryboard(Storyboard,HandoffBehavior,Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub BeginStoryboard( _
   ByVal storyboard As System.Windows.Media.Animation.Storyboard, _
   ByVal handoffBehavior As System.Windows.Media.Animation.HandoffBehavior, _
   ByVal isControllable As System.Boolean _
)
public void BeginStoryboard(
   System.Windows.Media.Animation.Storyboard storyboard,
   System.Windows.Media.Animation.HandoffBehavior handoffBehavior,
   System.bool isControllable
)

Parameters

storyboard
handoffBehavior
isControllable
See Also

Reference

Viewer Class
Viewer Members
Overload List


BindingGroup Property

BindingGroup Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : BindingGroup Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BindingGroup As System.Windows.Data.BindingGroup
public System.Windows.Data.BindingGroup BindingGroup {get; set;}
See Also

Reference

Viewer Class
Viewer Members


BitmapEffect Property

BitmapEffect Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : BitmapEffect Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BitmapEffect As System.Windows.Media.Effects.BitmapEffect
public System.Windows.Media.Effects.BitmapEffect BitmapEffect {get; set;}
See Also

Reference

Viewer Class
Viewer Members


BitmapEffectInput Property

BitmapEffectInput Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : BitmapEffectInput Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BitmapEffectInput As System.Windows.Media.Effects.BitmapEffectInput
public System.Windows.Media.Effects.BitmapEffectInput BitmapEffectInput {get; set;}
See Also

Reference

Viewer Class
Viewer Members


BorderBrush Property (Viewer)

BorderBrush Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : BorderBrush Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BorderBrush As System.Windows.Media.Brush
public System.Windows.Media.Brush BorderBrush {get; set;}
See Also

Reference

Viewer Class
Viewer Members


BorderThickness Property (Viewer)

BorderThickness Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : BorderThickness Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BorderThickness As System.Windows.Thickness
public System.Windows.Thickness BorderThickness {get; set;}
See Also

Reference

Viewer Class
Viewer Members


BringIntoView Method

BringIntoView Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : BringIntoView Method
Overload List
Overload | Description
BringIntoView() | (Inherited from System.Windows.FrameworkElement)
BringIntoView(Rect) | (Inherited from System.Windows.FrameworkElement)
See Also

Reference

Viewer Class
Viewer Members


BringIntoView() Method

BringIntoView() Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > BringIntoView Method : BringIntoView() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub BringIntoView()
public void BringIntoView()
See Also

Reference

Viewer Class
Viewer Members
Overload List


BringIntoView(Rect) Method

BringIntoView(Rect) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > BringIntoView Method : BringIntoView(Rect) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub BringIntoView( _
   ByVal targetRectangle As System.Windows.Rect _
)
public void BringIntoView(
   System.Windows.Rect targetRectangle
)

Parameters

targetRectangle
See Also

Reference

Viewer Class
Viewer Members
Overload List


CacheMode Property (Viewer)

CacheMode Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : CacheMode Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CacheMode As System.Windows.Media.CacheMode
public System.Windows.Media.CacheMode CacheMode {get; set;}
See Also

Reference

Viewer Class
Viewer Members


CaptureMouse Method (Viewer)

CaptureMouse Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : CaptureMouse Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CaptureMouse() As System.Boolean
public System.bool CaptureMouse()
See Also

Reference

Viewer Class
Viewer Members


CaptureStylus Method

CaptureStylus Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : CaptureStylus Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CaptureStylus() As System.Boolean
public System.bool CaptureStylus()
See Also

Reference

Viewer Class
Viewer Members


CaptureTouch Method

CaptureTouch Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : CaptureTouch Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CaptureTouch( _
   ByVal touchDevice As System.Windows.Input.TouchDevice _
) As System.Boolean
public System.bool CaptureTouch(
   System.Windows.Input.TouchDevice touchDevice
)

Parameters

touchDevice
See Also

Reference

Viewer Class
Viewer Members


ClearValue Method (Viewer)

ClearValue Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ClearValue Method
Overload List
Overload | Description
ClearValue(DependencyProperty) | (Inherited from System.Windows.DependencyObject)
ClearValue(DependencyPropertyKey) | (Inherited from System.Windows.DependencyObject)
See Also

Reference

Viewer Class
Viewer Members


ClearValue(DependencyProperty) Method

ClearValue(DependencyProperty) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > ClearValue Method : ClearValue(DependencyProperty) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ClearValue( _
   ByVal dp As System.Windows.DependencyProperty _
)
public void ClearValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

Viewer Class
Viewer Members
Overload List


ClearValue(DependencyPropertyKey) Method

ClearValue(DependencyPropertyKey) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > ClearValue Method : ClearValue(DependencyPropertyKey) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub ClearValue( _
   ByVal key As System.Windows.DependencyPropertyKey _
)
public void ClearValue(
   System.Windows.DependencyPropertyKey key
)

Parameters

key
See Also

Reference

Viewer Class
Viewer Members
Overload List


Clip Property (Viewer)

Clip Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Clip Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Clip As System.Windows.Media.Geometry
public System.Windows.Media.Geometry Clip {get; set;}
See Also

Reference

Viewer Class
Viewer Members


ClipToBounds Property

ClipToBounds Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ClipToBounds Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ClipToBounds As System.Boolean
public System.bool ClipToBounds {get; set;}
See Also

Reference

Viewer Class
Viewer Members


CoerceValue Method (Viewer)

CoerceValue Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : CoerceValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CoerceValue( _
   ByVal dp As System.Windows.DependencyProperty _
)
public void CoerceValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

Viewer Class
Viewer Members


CommandBindings Property

CommandBindings Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : CommandBindings Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CommandBindings As System.Windows.Input.CommandBindingCollection
public System.Windows.Input.CommandBindingCollection CommandBindings {get;}
See Also

Reference

Viewer Class
Viewer Members


ContextMenu Property (Viewer)

ContextMenu Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ContextMenu Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ContextMenu As System.Windows.Controls.ContextMenu
public System.Windows.Controls.ContextMenu ContextMenu {get; set;}
See Also

Reference

Viewer Class
Viewer Members


ContextMenuClosing Event

ContextMenuClosing Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ContextMenuClosing Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ContextMenuClosing As System.Windows.Controls.ContextMenuEventHandler
public event System.Windows.Controls.ContextMenuEventHandler ContextMenuClosing
Event Data

The event handler receives an argument of type System.Windows.Controls.ContextMenuEventArgs containing data related to this event. The following ContextMenuEventArgs properties provide information specific to this event.

Property | Description
CursorLeft | Gets the horizontal position of the mouse.
CursorTop | Gets the vertical position of the mouse.
Handled | (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
See Also

Reference

Viewer Class
Viewer Members


ContextMenuOpening Event

ContextMenuOpening Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ContextMenuOpening Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ContextMenuOpening As System.Windows.Controls.ContextMenuEventHandler
public event System.Windows.Controls.ContextMenuEventHandler ContextMenuOpening
Event Data

The event handler receives an argument of type System.Windows.Controls.ContextMenuEventArgs containing data related to this event. The following ContextMenuEventArgs properties provide information specific to this event.

Property | Description
CursorLeft | Gets the horizontal position of the mouse.
CursorTop | Gets the vertical position of the mouse.
Handled | (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
See Also

Reference

Viewer Class
Viewer Members


Cursor Property (Viewer)

Cursor Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Cursor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Cursor As System.Windows.Input.Cursor
public System.Windows.Input.Cursor Cursor {get; set;}
See Also

Reference

Viewer Class
Viewer Members


DataContext Property (Viewer)

DataContext Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : DataContext Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataContext As System.Object
public System.object DataContext {get; set;}
See Also

Reference

Viewer Class
Viewer Members


DataContextChanged Event

DataContextChanged Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : DataContextChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DataContextChanged As System.Windows.DependencyPropertyChangedEventHandler
public event System.Windows.DependencyPropertyChangedEventHandler DataContextChanged
Event Data

The event handler receives an argument of type System.Windows.DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.
See Also

Reference

Viewer Class
Viewer Members


DependencyObjectType Property (Viewer)

DependencyObjectType Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : DependencyObjectType Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DependencyObjectType As System.Windows.DependencyObjectType
public System.Windows.DependencyObjectType DependencyObjectType {get;}
See Also

Reference

Viewer Class
Viewer Members


DesiredSize Property (Viewer)

DesiredSize Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : DesiredSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DesiredSize As System.Windows.Size
public System.Windows.Size DesiredSize {get;}
See Also

Reference

Viewer Class
Viewer Members


Dispatcher Property (Viewer)

Dispatcher Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Dispatcher Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Dispatcher As System.Windows.Threading.Dispatcher
public System.Windows.Threading.Dispatcher Dispatcher {get;}
See Also

Reference

Viewer Class
Viewer Members


DragEnter Event (Viewer)

DragEnter Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : DragEnter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragEnter As System.Windows.DragEventHandler
public event System.Windows.DragEventHandler DragEnter
Event Data

The event handler receives an argument of type System.Windows.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
Data | Gets a data object (implements System.Windows.IDataObject) that contains the data associated with the corresponding drag event. This value is not useful in all event cases; see Remarks.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
See Also

Reference

Viewer Class
Viewer Members


DragLeave Event (Viewer)

DragLeave Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : DragLeave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragLeave As System.Windows.DragEventHandler
public event System.Windows.DragEventHandler DragLeave
Event Data

The event handler receives an argument of type System.Windows.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
Data | Gets a data object (implements System.Windows.IDataObject) that contains the data associated with the corresponding drag event. This value is not useful in all event cases; see Remarks.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
See Also

Reference

Viewer Class
Viewer Members


DragOver Event (Viewer)

DragOver Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : DragOver Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DragOver As System.Windows.DragEventHandler
public event System.Windows.DragEventHandler DragOver
Event Data

The event handler receives an argument of type System.Windows.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
Data | Gets a data object (implements System.Windows.IDataObject) that contains the data associated with the corresponding drag event. This value is not useful in all event cases; see Remarks.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
See Also

Reference

Viewer Class
Viewer Members


Drop Event (Viewer)

Drop Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Drop Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Drop As System.Windows.DragEventHandler
public event System.Windows.DragEventHandler Drop
Event Data

The event handler receives an argument of type System.Windows.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
Data | Gets a data object (implements System.Windows.IDataObject) that contains the data associated with the corresponding drag event. This value is not useful in all event cases; see Remarks.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
See Also

Reference

Viewer Class
Viewer Members


Effect Property (Viewer)

Effect Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Effect Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Effect As System.Windows.Media.Effects.Effect
public System.Windows.Media.Effects.Effect Effect {get; set;}
See Also

Reference

Viewer Class
Viewer Members


EndInit Method

EndInit Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : EndInit Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub EndInit()
public virtual void EndInit()
See Also

Reference

Viewer Class
Viewer Members


Equals Method (Viewer)

Equals Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Equals Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public System.bool Equals(
   System.object obj
)

Parameters

obj
See Also

Reference

Viewer Class
Viewer Members


FindCommonVisualAncestor Method

FindCommonVisualAncestor Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : FindCommonVisualAncestor Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function FindCommonVisualAncestor( _
   ByVal otherVisual As System.Windows.DependencyObject _
) As System.Windows.DependencyObject
public System.Windows.DependencyObject FindCommonVisualAncestor(
   System.Windows.DependencyObject otherVisual
)

Parameters

otherVisual
See Also

Reference

Viewer Class
Viewer Members


FindName Method (Viewer)

FindName Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : FindName Method
Overload List
Overload | Description
FindName | (Inherited from System.Windows.FrameworkElement)
See Also

Reference

Viewer Class
Viewer Members


FindName(String) Method

FindName(String) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : FindName(String) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function FindName( _
   ByVal name As System.String _
) As System.Object
public System.object FindName(
   System.string name
)

Parameters

name
See Also

Reference

Viewer Class
Viewer Members


FindResource Method

FindResource Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : FindResource Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function FindResource( _
   ByVal resourceKey As System.Object _
) As System.Object
public System.object FindResource(
   System.object resourceKey
)

Parameters

resourceKey
See Also

Reference

Viewer Class
Viewer Members


FlowDirection Property (Viewer)

FlowDirection Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : FlowDirection Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FlowDirection As System.Windows.FlowDirection
public System.Windows.FlowDirection FlowDirection {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Focus Method (Viewer)

Focus Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Focus Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Focus() As System.Boolean
public System.bool Focus()
See Also

Reference

Viewer Class
Viewer Members


Focusable Property

Focusable Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Focusable Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Focusable As System.Boolean
public System.bool Focusable {get; set;}
See Also

Reference

Viewer Class
Viewer Members


FocusableChanged Event

FocusableChanged Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : FocusableChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event FocusableChanged As System.Windows.DependencyPropertyChangedEventHandler
public event System.Windows.DependencyPropertyChangedEventHandler FocusableChanged
Event Data

The event handler receives an argument of type System.Windows.DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.
See Also

Reference

Viewer Class
Viewer Members


FocusVisualStyle Property

FocusVisualStyle Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : FocusVisualStyle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FocusVisualStyle As System.Windows.Style
public System.Windows.Style FocusVisualStyle {get; set;}
See Also

Reference

Viewer Class
Viewer Members


FontFamily Property (Viewer)

FontFamily Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : FontFamily Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontFamily As System.Windows.Media.FontFamily
public System.Windows.Media.FontFamily FontFamily {get; set;}
See Also

Reference

Viewer Class
Viewer Members


FontSize Property (Viewer)

FontSize Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : FontSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontSize As System.Double
public System.double FontSize {get; set;}
See Also

Reference

Viewer Class
Viewer Members


FontStretch Property (Viewer)

FontStretch Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : FontStretch Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontStretch As System.Windows.FontStretch
public System.Windows.FontStretch FontStretch {get; set;}
See Also

Reference

Viewer Class
Viewer Members


FontStyle Property (Viewer)

FontStyle Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : FontStyle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontStyle As System.Windows.FontStyle
public System.Windows.FontStyle FontStyle {get; set;}
See Also

Reference

Viewer Class
Viewer Members


FontWeight Property (Viewer)

FontWeight Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : FontWeight Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FontWeight As System.Windows.FontWeight
public System.Windows.FontWeight FontWeight {get; set;}
See Also

Reference

Viewer Class
Viewer Members


ForceCursor Property

ForceCursor Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ForceCursor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ForceCursor As System.Boolean
public System.bool ForceCursor {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Foreground Property (Viewer)

Foreground Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Foreground Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Foreground As System.Windows.Media.Brush
public System.Windows.Media.Brush Foreground {get; set;}
See Also

Reference

Viewer Class
Viewer Members


GetAnimationBaseValue Method (Viewer)

GetAnimationBaseValue Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : GetAnimationBaseValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetAnimationBaseValue( _
   ByVal dp As System.Windows.DependencyProperty _
) As System.Object
public System.object GetAnimationBaseValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

Viewer Class
Viewer Members


GetBindingExpression Method (Viewer)

GetBindingExpression Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : GetBindingExpression Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetBindingExpression( _
   ByVal dp As System.Windows.DependencyProperty _
) As System.Windows.Data.BindingExpression
public System.Windows.Data.BindingExpression GetBindingExpression(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

Viewer Class
Viewer Members


GetHashCode Method (Viewer)

GetHashCode Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetHashCode() As System.Integer
public System.int GetHashCode()
See Also

Reference

Viewer Class
Viewer Members


GetValue Method (Viewer)

GetValue Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : GetValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetValue( _
   ByVal dp As System.Windows.DependencyProperty _
) As System.Object
public System.object GetValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

Viewer Class
Viewer Members


GiveFeedback Event (Viewer)

GiveFeedback Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : GiveFeedback Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event GiveFeedback As System.Windows.GiveFeedbackEventHandler
public event System.Windows.GiveFeedbackEventHandler GiveFeedback
Event Data

The event handler receives an argument of type System.Windows.GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effects | Gets a value that indicates the effects of drag-and-drop operation.
Handled | (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
UseDefaultCursors | Gets or sets a Boolean value indicating whether default cursor feedback behavior should be used for the associated drag-and-drop operation.
See Also

Reference

Viewer Class
Viewer Members


GotFocus Event (Viewer)

GotFocus Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : GotFocus Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event GotFocus As System.Windows.RoutedEventHandler
public event System.Windows.RoutedEventHandler GotFocus
Event Data

The event handler receives an argument of type System.Windows.RoutedEventArgs containing data related to this event. The following RoutedEventArgs properties provide information specific to this event.

Property | Description
OriginalSource | Gets a reference to the object that raised the event.
See Also

Reference

Viewer Class
Viewer Members


GotKeyboardFocus Event

GotKeyboardFocus Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : GotKeyboardFocus Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event GotKeyboardFocus As System.Windows.Input.KeyboardFocusChangedEventHandler
public event System.Windows.Input.KeyboardFocusChangedEventHandler GotKeyboardFocus
Event Data

The event handler receives an argument of type System.Windows.Input.KeyboardFocusChangedEventArgs containing data related to this event. The following KeyboardFocusChangedEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
KeyboardDevice | (Inherited from System.Windows.Input.KeyboardEventArgs)
NewFocus | Gets the element that focus has moved to.
OldFocus | Gets the element that previously had focus.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


GotMouseCapture Event

GotMouseCapture Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : GotMouseCapture Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event GotMouseCapture As System.Windows.Input.MouseEventHandler
public event System.Windows.Input.MouseEventHandler GotMouseCapture
Event Data

The event handler receives an argument of type System.Windows.Input.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets an object that reports stylus device information, such as the collection of stylus points associated with the input.
See Also

Reference

Viewer Class
Viewer Members


GotStylusCapture Event

GotStylusCapture Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : GotStylusCapture Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event GotStylusCapture As System.Windows.Input.StylusEventHandler
public event System.Windows.Input.StylusEventHandler GotStylusCapture
Event Data

The event handler receives an argument of type System.Windows.Input.StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


GotTouchCapture Event

GotTouchCapture Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : GotTouchCapture Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event GotTouchCapture As System.EventHandler(Of TouchEventArgs)
public event System.EventHandler<TouchEventArgs> GotTouchCapture
Event Data

The event handler receives an argument of type System.Windows.Input.TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
TouchDevice | Gets the touch that generated the event.
See Also

Reference

Viewer Class
Viewer Members


HasAnimatedProperties Property

HasAnimatedProperties Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : HasAnimatedProperties Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HasAnimatedProperties As System.Boolean
public System.bool HasAnimatedProperties {get;}
See Also

Reference

Viewer Class
Viewer Members


Height Property (Viewer)

Height Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Height Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As System.Double
public System.double Height {get; set;}
See Also

Reference

Viewer Class
Viewer Members


HorizontalAlignment Property (Viewer)

HorizontalAlignment Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : HorizontalAlignment Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HorizontalAlignment As System.Windows.HorizontalAlignment
public System.Windows.HorizontalAlignment HorizontalAlignment {get; set;}
See Also

Reference

Viewer Class
Viewer Members


HorizontalContentAlignment Property (Viewer)

HorizontalContentAlignment Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : HorizontalContentAlignment Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HorizontalContentAlignment As System.Windows.HorizontalAlignment
public System.Windows.HorizontalAlignment HorizontalContentAlignment {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Initialized Event

Initialized Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Initialized Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Initialized As System.EventHandler
public event System.EventHandler Initialized
See Also

Reference

Viewer Class
Viewer Members


InputBindings Property

InputBindings Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : InputBindings Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property InputBindings As System.Windows.Input.InputBindingCollection
public System.Windows.Input.InputBindingCollection InputBindings {get;}
See Also

Reference

Viewer Class
Viewer Members


InputHitTest Method

InputHitTest Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : InputHitTest Method
Overload List
Overload | Description
InputHitTest | (Inherited from System.Windows.UIElement)
See Also

Reference

Viewer Class
Viewer Members


InputHitTest(Point) Method

InputHitTest(Point) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : InputHitTest(Point) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function InputHitTest( _
   ByVal point As System.Windows.Point _
) As System.Windows.IInputElement
public System.Windows.IInputElement InputHitTest(
   System.Windows.Point point
)

Parameters

point
See Also

Reference

Viewer Class
Viewer Members


InputScope Property

InputScope Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : InputScope Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property InputScope As InputScope
public InputScope InputScope {get; set;}
See Also

Reference

Viewer Class
Viewer Members


InvalidateArrange Method (Viewer)

InvalidateArrange Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : InvalidateArrange Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub InvalidateArrange()
public void InvalidateArrange()
See Also

Reference

Viewer Class
Viewer Members


InvalidateMeasure Method (Viewer)

InvalidateMeasure Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : InvalidateMeasure Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub InvalidateMeasure()
public void InvalidateMeasure()
See Also

Reference

Viewer Class
Viewer Members


InvalidateProperty Method (Viewer)

InvalidateProperty Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : InvalidateProperty Method
Overload List
Overload | Description
InvalidateProperty | (Inherited from System.Windows.DependencyObject)
See Also

Reference

Viewer Class
Viewer Members


InvalidateProperty(DependencyProperty) Method

InvalidateProperty(DependencyProperty) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : InvalidateProperty(DependencyProperty) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub InvalidateProperty( _
   ByVal dp As System.Windows.DependencyProperty _
)
public void InvalidateProperty(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

Viewer Class
Viewer Members


InvalidateVisual Method

InvalidateVisual Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : InvalidateVisual Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub InvalidateVisual()
public void InvalidateVisual()
See Also

Reference

Viewer Class
Viewer Members


IsAncestorOf Method

IsAncestorOf Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsAncestorOf Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IsAncestorOf( _
   ByVal descendant As System.Windows.DependencyObject _
) As System.Boolean
public System.bool IsAncestorOf(
   System.Windows.DependencyObject descendant
)

Parameters

descendant
See Also

Reference

Viewer Class
Viewer Members


IsArrangeValid Property

IsArrangeValid Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsArrangeValid Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsArrangeValid As System.Boolean
public System.bool IsArrangeValid {get;}
See Also

Reference

Viewer Class
Viewer Members


IsDescendantOf Method

IsDescendantOf Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsDescendantOf Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IsDescendantOf( _
   ByVal ancestor As System.Windows.DependencyObject _
) As System.Boolean
public System.bool IsDescendantOf(
   System.Windows.DependencyObject ancestor
)

Parameters

ancestor
See Also

Reference

Viewer Class
Viewer Members


IsEnabled Property (Viewer)

IsEnabled Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsEnabled Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsEnabled As System.Boolean
public System.bool IsEnabled {get; set;}
See Also

Reference

Viewer Class
Viewer Members


IsEnabledChanged Event (Viewer)

IsEnabledChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsEnabledChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event IsEnabledChanged As System.Windows.DependencyPropertyChangedEventHandler
public event System.Windows.DependencyPropertyChangedEventHandler IsEnabledChanged
Event Data

The event handler receives an argument of type System.Windows.DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.
See Also

Reference

Viewer Class
Viewer Members


IsFocused Property

IsFocused Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsFocused Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsFocused As System.Boolean
public System.bool IsFocused {get;}
See Also

Reference

Viewer Class
Viewer Members


IsHitTestVisible Property (Viewer)

IsHitTestVisible Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsHitTestVisible Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsHitTestVisible As System.Boolean
public System.bool IsHitTestVisible {get; set;}
See Also

Reference

Viewer Class
Viewer Members


IsHitTestVisibleChanged Event

IsHitTestVisibleChanged Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsHitTestVisibleChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event IsHitTestVisibleChanged As System.Windows.DependencyPropertyChangedEventHandler
public event System.Windows.DependencyPropertyChangedEventHandler IsHitTestVisibleChanged
Event Data

The event handler receives an argument of type System.Windows.DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.
See Also

Reference

Viewer Class
Viewer Members


IsInitialized Property

IsInitialized Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsInitialized Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsInitialized As System.Boolean
public System.bool IsInitialized {get;}
See Also

Reference

Viewer Class
Viewer Members


IsInputMethodEnabled Property

IsInputMethodEnabled Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsInputMethodEnabled Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsInputMethodEnabled As System.Boolean
public System.bool IsInputMethodEnabled {get;}
See Also

Reference

Viewer Class
Viewer Members


IsKeyboardFocused Property

IsKeyboardFocused Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsKeyboardFocused Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsKeyboardFocused As System.Boolean
public System.bool IsKeyboardFocused {get;}
See Also

Reference

Viewer Class
Viewer Members


IsKeyboardFocusedChanged Event

IsKeyboardFocusedChanged Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsKeyboardFocusedChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event IsKeyboardFocusedChanged As System.Windows.DependencyPropertyChangedEventHandler
public event System.Windows.DependencyPropertyChangedEventHandler IsKeyboardFocusedChanged
Event Data

The event handler receives an argument of type System.Windows.DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.
See Also

Reference

Viewer Class
Viewer Members


IsKeyboardFocusWithin Property

IsKeyboardFocusWithin Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsKeyboardFocusWithin Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsKeyboardFocusWithin As System.Boolean
public System.bool IsKeyboardFocusWithin {get;}
See Also

Reference

Viewer Class
Viewer Members


IsKeyboardFocusWithinChanged Event

IsKeyboardFocusWithinChanged Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsKeyboardFocusWithinChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event IsKeyboardFocusWithinChanged As System.Windows.DependencyPropertyChangedEventHandler
public event System.Windows.DependencyPropertyChangedEventHandler IsKeyboardFocusWithinChanged
Event Data

The event handler receives an argument of type System.Windows.DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.
See Also

Reference

Viewer Class
Viewer Members


IsLoaded Property

IsLoaded Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsLoaded Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsLoaded As System.Boolean
public System.bool IsLoaded {get;}
See Also

Reference

Viewer Class
Viewer Members


IsManipulationEnabled Property

IsManipulationEnabled Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsManipulationEnabled Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsManipulationEnabled As System.Boolean
public System.bool IsManipulationEnabled {get; set;}
See Also

Reference

Viewer Class
Viewer Members


IsMeasureValid Property

IsMeasureValid Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsMeasureValid Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsMeasureValid As System.Boolean
public System.bool IsMeasureValid {get;}
See Also

Reference

Viewer Class
Viewer Members


IsMouseCaptured Property

IsMouseCaptured Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsMouseCaptured Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsMouseCaptured As System.Boolean
public System.bool IsMouseCaptured {get;}
See Also

Reference

Viewer Class
Viewer Members


IsMouseCapturedChanged Event

IsMouseCapturedChanged Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsMouseCapturedChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event IsMouseCapturedChanged As System.Windows.DependencyPropertyChangedEventHandler
public event System.Windows.DependencyPropertyChangedEventHandler IsMouseCapturedChanged
Event Data

The event handler receives an argument of type System.Windows.DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.
See Also

Reference

Viewer Class
Viewer Members


IsMouseCaptureWithin Property

IsMouseCaptureWithin Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsMouseCaptureWithin Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsMouseCaptureWithin As System.Boolean
public System.bool IsMouseCaptureWithin {get;}
See Also

Reference

Viewer Class
Viewer Members


IsMouseCaptureWithinChanged Event

IsMouseCaptureWithinChanged Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsMouseCaptureWithinChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event IsMouseCaptureWithinChanged As System.Windows.DependencyPropertyChangedEventHandler
public event System.Windows.DependencyPropertyChangedEventHandler IsMouseCaptureWithinChanged
Event Data

The event handler receives an argument of type System.Windows.DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.
See Also

Reference

Viewer Class
Viewer Members


IsMouseDirectlyOver Property

IsMouseDirectlyOver Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsMouseDirectlyOver Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsMouseDirectlyOver As System.Boolean
public System.bool IsMouseDirectlyOver {get;}
See Also

Reference

Viewer Class
Viewer Members


IsMouseDirectlyOverChanged Event

IsMouseDirectlyOverChanged Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsMouseDirectlyOverChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event IsMouseDirectlyOverChanged As System.Windows.DependencyPropertyChangedEventHandler
public event System.Windows.DependencyPropertyChangedEventHandler IsMouseDirectlyOverChanged
Event Data

The event handler receives an argument of type System.Windows.DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.
See Also

Reference

Viewer Class
Viewer Members


IsMouseOver Property

IsMouseOver Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsMouseOver Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsMouseOver As System.Boolean
public System.bool IsMouseOver {get;}
See Also

Reference

Viewer Class
Viewer Members


IsSealed Property (Viewer)

IsSealed Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsSealed Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsSealed As System.Boolean
public System.bool IsSealed {get;}
See Also

Reference

Viewer Class
Viewer Members


IsStylusCaptured Property

IsStylusCaptured Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsStylusCaptured Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsStylusCaptured As System.Boolean
public System.bool IsStylusCaptured {get;}
See Also

Reference

Viewer Class
Viewer Members


IsStylusCapturedChanged Event

IsStylusCapturedChanged Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsStylusCapturedChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event IsStylusCapturedChanged As System.Windows.DependencyPropertyChangedEventHandler
public event System.Windows.DependencyPropertyChangedEventHandler IsStylusCapturedChanged
Event Data

The event handler receives an argument of type System.Windows.DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.
See Also

Reference

Viewer Class
Viewer Members


IsStylusCaptureWithin Property

IsStylusCaptureWithin Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsStylusCaptureWithin Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsStylusCaptureWithin As System.Boolean
public System.bool IsStylusCaptureWithin {get;}
See Also

Reference

Viewer Class
Viewer Members


IsStylusCaptureWithinChanged Event

IsStylusCaptureWithinChanged Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsStylusCaptureWithinChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event IsStylusCaptureWithinChanged As System.Windows.DependencyPropertyChangedEventHandler
public event System.Windows.DependencyPropertyChangedEventHandler IsStylusCaptureWithinChanged
Event Data

The event handler receives an argument of type System.Windows.DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.
See Also

Reference

Viewer Class
Viewer Members


IsStylusDirectlyOver Property

IsStylusDirectlyOver Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsStylusDirectlyOver Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsStylusDirectlyOver As System.Boolean
public System.bool IsStylusDirectlyOver {get;}
See Also

Reference

Viewer Class
Viewer Members


IsStylusDirectlyOverChanged Event

IsStylusDirectlyOverChanged Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsStylusDirectlyOverChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event IsStylusDirectlyOverChanged As System.Windows.DependencyPropertyChangedEventHandler
public event System.Windows.DependencyPropertyChangedEventHandler IsStylusDirectlyOverChanged
Event Data

The event handler receives an argument of type System.Windows.DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.
See Also

Reference

Viewer Class
Viewer Members


IsStylusOver Property

IsStylusOver Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsStylusOver Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsStylusOver As System.Boolean
public System.bool IsStylusOver {get;}
See Also

Reference

Viewer Class
Viewer Members


IsTabStop Property (Viewer)

IsTabStop Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsTabStop Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IsTabStop As System.Boolean
public System.bool IsTabStop {get; set;}
See Also

Reference

Viewer Class
Viewer Members


IsVisible Property

IsVisible Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsVisible Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsVisible As System.Boolean
public System.bool IsVisible {get;}
See Also

Reference

Viewer Class
Viewer Members


IsVisibleChanged Event

IsVisibleChanged Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : IsVisibleChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event IsVisibleChanged As System.Windows.DependencyPropertyChangedEventHandler
public event System.Windows.DependencyPropertyChangedEventHandler IsVisibleChanged
Event Data

The event handler receives an argument of type System.Windows.DependencyPropertyChangedEventArgs containing data related to this event. The following DependencyPropertyChangedEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets the value of the property after the change.
OldValue | Gets the value of the property before the change.
Property | Gets the identifier for the dependency property where the value change occurred.
See Also

Reference

Viewer Class
Viewer Members


KeyDown Event (Viewer)

KeyDown Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : KeyDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event KeyDown As System.Windows.Input.KeyEventHandler
public event System.Windows.Input.KeyEventHandler KeyDown
Event Data

The event handler receives an argument of type System.Windows.Input.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled. A true value for Handled prevents most handlers along the event route from handling the same event again.
Key | Gets the keyboard key associated with the event.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
PlatformKeyCode | Gets an integer value that represents the key that is pressed or released (depending on which event is raised). This value is the nonportable key code, which is operating system–specific.
See Also

Reference

Viewer Class
Viewer Members


KeyUp Event (Viewer)

KeyUp Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : KeyUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event KeyUp As System.Windows.Input.KeyEventHandler
public event System.Windows.Input.KeyEventHandler KeyUp
Event Data

The event handler receives an argument of type System.Windows.Input.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled. A true value for Handled prevents most handlers along the event route from handling the same event again.
Key | Gets the keyboard key associated with the event.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
PlatformKeyCode | Gets an integer value that represents the key that is pressed or released (depending on which event is raised). This value is the nonportable key code, which is operating system–specific.
See Also

Reference

Viewer Class
Viewer Members


Language Property (Viewer)

Language Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Language Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Language As System.Windows.Markup.XmlLanguage
public System.Windows.Markup.XmlLanguage Language {get; set;}
See Also

Reference

Viewer Class
Viewer Members


LayoutTransform Property

LayoutTransform Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : LayoutTransform Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LayoutTransform As System.Windows.Media.Transform
public System.Windows.Media.Transform LayoutTransform {get; set;}
See Also

Reference

Viewer Class
Viewer Members


LayoutUpdated Event (Viewer)

LayoutUpdated Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : LayoutUpdated Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LayoutUpdated As System.EventHandler
public event System.EventHandler LayoutUpdated
See Also

Reference

Viewer Class
Viewer Members


Loaded Event (Viewer)

Loaded Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Loaded Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Loaded As System.Windows.RoutedEventHandler
public event System.Windows.RoutedEventHandler Loaded
Event Data

The event handler receives an argument of type System.Windows.RoutedEventArgs containing data related to this event. The following RoutedEventArgs properties provide information specific to this event.

Property | Description
OriginalSource | Gets a reference to the object that raised the event.
See Also

Reference

Viewer Class
Viewer Members


LostFocus Event (Viewer)

LostFocus Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : LostFocus Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LostFocus As System.Windows.RoutedEventHandler
public event System.Windows.RoutedEventHandler LostFocus
Event Data

The event handler receives an argument of type System.Windows.RoutedEventArgs containing data related to this event. The following RoutedEventArgs properties provide information specific to this event.

Property | Description
OriginalSource | Gets a reference to the object that raised the event.
See Also

Reference

Viewer Class
Viewer Members


LostKeyboardFocus Event

LostKeyboardFocus Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : LostKeyboardFocus Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LostKeyboardFocus As System.Windows.Input.KeyboardFocusChangedEventHandler
public event System.Windows.Input.KeyboardFocusChangedEventHandler LostKeyboardFocus
Event Data

The event handler receives an argument of type System.Windows.Input.KeyboardFocusChangedEventArgs containing data related to this event. The following KeyboardFocusChangedEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
KeyboardDevice | (Inherited from System.Windows.Input.KeyboardEventArgs)
NewFocus | Gets the element that focus has moved to.
OldFocus | Gets the element that previously had focus.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


LostMouseCapture Event (Viewer)

LostMouseCapture Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : LostMouseCapture Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LostMouseCapture As System.Windows.Input.MouseEventHandler
public event System.Windows.Input.MouseEventHandler LostMouseCapture
Event Data

The event handler receives an argument of type System.Windows.Input.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets an object that reports stylus device information, such as the collection of stylus points associated with the input.
See Also

Reference

Viewer Class
Viewer Members


LostStylusCapture Event

LostStylusCapture Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : LostStylusCapture Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LostStylusCapture As System.Windows.Input.StylusEventHandler
public event System.Windows.Input.StylusEventHandler LostStylusCapture
Event Data

The event handler receives an argument of type System.Windows.Input.StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


LostTouchCapture Event

LostTouchCapture Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : LostTouchCapture Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event LostTouchCapture As System.EventHandler(Of TouchEventArgs)
public event System.EventHandler<TouchEventArgs> LostTouchCapture
Event Data

The event handler receives an argument of type System.Windows.Input.TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
TouchDevice | Gets the touch that generated the event.
See Also

Reference

Viewer Class
Viewer Members


ManipulationBoundaryFeedback Event

ManipulationBoundaryFeedback Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ManipulationBoundaryFeedback Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ManipulationBoundaryFeedback As System.EventHandler(Of ManipulationBoundaryFeedbackEventArgs)
public event System.EventHandler<ManipulationBoundaryFeedbackEventArgs> ManipulationBoundaryFeedback
Event Data

The event handler receives an argument of type System.Windows.Input.ManipulationBoundaryFeedbackEventArgs containing data related to this event. The following ManipulationBoundaryFeedbackEventArgs properties provide information specific to this event.

Property | Description
BoundaryFeedback | Gets the unused portion of the direct manipulation.
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
ManipulationContainer | Gets the container that the System.Windows.Input.ManipulationBoundaryFeedbackEventArgs.BoundaryFeedback property is relative to.
Manipulators | Gets a collection of objects that represents the touch contacts for the manipulation.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


ManipulationCompleted Event

ManipulationCompleted Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ManipulationCompleted Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ManipulationCompleted As System.EventHandler(Of ManipulationCompletedEventArgs)
public event System.EventHandler<ManipulationCompletedEventArgs> ManipulationCompleted
See Also

Reference

Viewer Class
Viewer Members


ManipulationDelta Event

ManipulationDelta Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ManipulationDelta Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ManipulationDelta As System.EventHandler(Of ManipulationDeltaEventArgs)
public event System.EventHandler<ManipulationDeltaEventArgs> ManipulationDelta
See Also

Reference

Viewer Class
Viewer Members


ManipulationInertiaStarting Event

ManipulationInertiaStarting Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ManipulationInertiaStarting Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ManipulationInertiaStarting As System.EventHandler(Of ManipulationInertiaStartingEventArgs)
public event System.EventHandler<ManipulationInertiaStartingEventArgs> ManipulationInertiaStarting
Event Data

The event handler receives an argument of type System.Windows.Input.ManipulationInertiaStartingEventArgs containing data related to this event. The following ManipulationInertiaStartingEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
ExpansionBehavior | Get or sets the rate of slowdown of expansion inertial movement.
Handled | (Inherited from System.Windows.RoutedEventArgs)
InitialVelocities | Gets the rates of changes to the manipulation that occur before inertia starts.
ManipulationContainer | Gets the container that the System.Windows.Input.ManipulationStartedEventArgs.ManipulationOrigin property is relative to.
ManipulationOrigin | Gets or sets the point from which the manipulation originated.
Manipulators | Gets a collection of objects that represents the touch contacts for the manipulation.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RotationBehavior | Gets or sets the rate of slowdown of rotational inertial movement.
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
TranslationBehavior | Gets and sets the rate of slowdown of linear inertial movement.
See Also

Reference

Viewer Class
Viewer Members


ManipulationStarted Event

ManipulationStarted Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ManipulationStarted Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ManipulationStarted As System.EventHandler(Of ManipulationStartedEventArgs)
public event System.EventHandler<ManipulationStartedEventArgs> ManipulationStarted
See Also

Reference

Viewer Class
Viewer Members


ManipulationStarting Event

ManipulationStarting Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ManipulationStarting Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ManipulationStarting As System.EventHandler(Of ManipulationStartingEventArgs)
public event System.EventHandler<ManipulationStartingEventArgs> ManipulationStarting
Event Data

The event handler receives an argument of type System.Windows.Input.ManipulationStartingEventArgs containing data related to this event. The following ManipulationStartingEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
IsSingleTouchEnabled | Gets or sets whether one finger can start a manipulation.
ManipulationContainer | Gets or sets the container that all manipulation events and calculations are relative to.
Manipulators | Gets a collection of objects that represents the touch contacts for the manipulation.
Mode | Gets or sets which types of manipulations are possible.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
Pivot | Gets or sets an object that describes the pivot for a single-point manipulation.
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


Margin Property (Viewer)

Margin Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Margin Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Margin As System.Windows.Thickness
public System.Windows.Thickness Margin {get; set;}
See Also

Reference

Viewer Class
Viewer Members


MaxHeight Property (Viewer)

MaxHeight Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MaxHeight Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaxHeight As System.Double
public System.double MaxHeight {get; set;}
See Also

Reference

Viewer Class
Viewer Members


MaxWidth Property (Viewer)

MaxWidth Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MaxWidth Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaxWidth As System.Double
public System.double MaxWidth {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Measure Method (Viewer)

Measure Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Measure Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Measure( _
   ByVal availableSize As System.Windows.Size _
)
public void Measure(
   System.Windows.Size availableSize
)

Parameters

availableSize
See Also

Reference

Viewer Class
Viewer Members


MinHeight Property (Viewer)

MinHeight Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MinHeight Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinHeight As System.Double
public System.double MinHeight {get; set;}
See Also

Reference

Viewer Class
Viewer Members


MinWidth Property (Viewer)

MinWidth Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MinWidth Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinWidth As System.Double
public System.double MinWidth {get; set;}
See Also

Reference

Viewer Class
Viewer Members


MouseDoubleClick Event (Viewer)

MouseDoubleClick Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MouseDoubleClick Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseDoubleClick As System.Windows.Input.MouseButtonEventHandler
public event System.Windows.Input.MouseButtonEventHandler MouseDoubleClick
Event Data

The event handler receives an argument of type System.Windows.Input.MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled. A true value for Handled prevents most handlers along the event route from handling the same event again.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.MouseEventArgs)
See Also

Reference

Viewer Class
Viewer Members


MouseDown Event (Viewer)

MouseDown Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MouseDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseDown As System.Windows.Input.MouseButtonEventHandler
public event System.Windows.Input.MouseButtonEventHandler MouseDown
Event Data

The event handler receives an argument of type System.Windows.Input.MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled. A true value for Handled prevents most handlers along the event route from handling the same event again.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.MouseEventArgs)
See Also

Reference

Viewer Class
Viewer Members


MouseEnter Event (Viewer)

MouseEnter Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MouseEnter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseEnter As System.Windows.Input.MouseEventHandler
public event System.Windows.Input.MouseEventHandler MouseEnter
Event Data

The event handler receives an argument of type System.Windows.Input.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets an object that reports stylus device information, such as the collection of stylus points associated with the input.
See Also

Reference

Viewer Class
Viewer Members


MouseLeave Event (Viewer)

MouseLeave Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MouseLeave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseLeave As System.Windows.Input.MouseEventHandler
public event System.Windows.Input.MouseEventHandler MouseLeave
Event Data

The event handler receives an argument of type System.Windows.Input.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets an object that reports stylus device information, such as the collection of stylus points associated with the input.
See Also

Reference

Viewer Class
Viewer Members


MouseLeftButtonDown Event (Viewer)

MouseLeftButtonDown Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MouseLeftButtonDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseLeftButtonDown As System.Windows.Input.MouseButtonEventHandler
public event System.Windows.Input.MouseButtonEventHandler MouseLeftButtonDown
Event Data

The event handler receives an argument of type System.Windows.Input.MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled. A true value for Handled prevents most handlers along the event route from handling the same event again.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.MouseEventArgs)
See Also

Reference

Viewer Class
Viewer Members


MouseLeftButtonUp Event (Viewer)

MouseLeftButtonUp Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MouseLeftButtonUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseLeftButtonUp As System.Windows.Input.MouseButtonEventHandler
public event System.Windows.Input.MouseButtonEventHandler MouseLeftButtonUp
Event Data

The event handler receives an argument of type System.Windows.Input.MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled. A true value for Handled prevents most handlers along the event route from handling the same event again.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.MouseEventArgs)
See Also

Reference

Viewer Class
Viewer Members


MouseMove Event (Viewer)

MouseMove Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MouseMove Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseMove As System.Windows.Input.MouseEventHandler
public event System.Windows.Input.MouseEventHandler MouseMove
Event Data

The event handler receives an argument of type System.Windows.Input.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets an object that reports stylus device information, such as the collection of stylus points associated with the input.
See Also

Reference

Viewer Class
Viewer Members


MouseRightButtonDown Event (Viewer)

MouseRightButtonDown Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MouseRightButtonDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseRightButtonDown As System.Windows.Input.MouseButtonEventHandler
public event System.Windows.Input.MouseButtonEventHandler MouseRightButtonDown
Event Data

The event handler receives an argument of type System.Windows.Input.MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled. A true value for Handled prevents most handlers along the event route from handling the same event again.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.MouseEventArgs)
See Also

Reference

Viewer Class
Viewer Members


MouseRightButtonUp Event (Viewer)

MouseRightButtonUp Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MouseRightButtonUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseRightButtonUp As System.Windows.Input.MouseButtonEventHandler
public event System.Windows.Input.MouseButtonEventHandler MouseRightButtonUp
Event Data

The event handler receives an argument of type System.Windows.Input.MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled. A true value for Handled prevents most handlers along the event route from handling the same event again.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.MouseEventArgs)
See Also

Reference

Viewer Class
Viewer Members


MouseUp Event (Viewer)

MouseUp Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MouseUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseUp As System.Windows.Input.MouseButtonEventHandler
public event System.Windows.Input.MouseButtonEventHandler MouseUp
Event Data

The event handler receives an argument of type System.Windows.Input.MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled. A true value for Handled prevents most handlers along the event route from handling the same event again.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.MouseEventArgs)
See Also

Reference

Viewer Class
Viewer Members


MouseWheel Event (Viewer)

MouseWheel Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MouseWheel Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event MouseWheel As System.Windows.Input.MouseWheelEventHandler
public event System.Windows.Input.MouseWheelEventHandler MouseWheel
Event Data

The event handler receives an argument of type System.Windows.Input.MouseWheelEventArgs containing data related to this event. The following MouseWheelEventArgs properties provide information specific to this event.

Property | Description
Delta | Gets a value that indicates the amount that the mouse wheel rotated relative to its starting state or to the last occurrence of the event.
Handled | Gets or sets a value that marks the routed event as handled, and prevents most handlers along the event route from rehandling the same event.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.MouseEventArgs)
See Also

Reference

Viewer Class
Viewer Members


MoveFocus Method

MoveFocus Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : MoveFocus Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function MoveFocus( _
   ByVal request As System.Windows.Input.TraversalRequest _
) As System.Boolean
public System.bool MoveFocus(
   System.Windows.Input.TraversalRequest request
)

Parameters

request
See Also

Reference

Viewer Class
Viewer Members


Name Property (Viewer)

Name Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Name Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As System.String
public System.string Name {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Opacity Property (Viewer)

Opacity Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Opacity Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Opacity As System.Double
public System.double Opacity {get; set;}
See Also

Reference

Viewer Class
Viewer Members


OpacityMask Property (Viewer)

OpacityMask Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : OpacityMask Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OpacityMask As System.Windows.Media.Brush
public System.Windows.Media.Brush OpacityMask {get; set;}
See Also

Reference

Viewer Class
Viewer Members


OverridesDefaultStyle Property

OverridesDefaultStyle Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : OverridesDefaultStyle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OverridesDefaultStyle As System.Boolean
public System.bool OverridesDefaultStyle {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Padding Property (Viewer)

Padding Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Padding Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Padding As System.Windows.Thickness
public System.Windows.Thickness Padding {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Parent Property (Viewer)

Parent Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Parent Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Parent As System.Windows.DependencyObject
public System.Windows.DependencyObject Parent {get;}
See Also

Reference

Viewer Class
Viewer Members


PersistId Property

PersistId Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PersistId Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property PersistId As System.Integer
public System.int PersistId {get;}
See Also

Reference

Viewer Class
Viewer Members


PointFromScreen Method

PointFromScreen Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PointFromScreen Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PointFromScreen( _
   ByVal point As System.Windows.Point _
) As System.Windows.Point
public System.Windows.Point PointFromScreen(
   System.Windows.Point point
)

Parameters

point
See Also

Reference

Viewer Class
Viewer Members


PointToScreen Method (Viewer)

PointToScreen Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PointToScreen Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PointToScreen( _
   ByVal point As System.Windows.Point _
) As System.Windows.Point
public System.Windows.Point PointToScreen(
   System.Windows.Point point
)

Parameters

point
See Also

Reference

Viewer Class
Viewer Members


PredictFocus Method

PredictFocus Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PredictFocus Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function PredictFocus( _
   ByVal direction As System.Windows.Input.FocusNavigationDirection _
) As System.Windows.DependencyObject
public System.Windows.DependencyObject PredictFocus(
   System.Windows.Input.FocusNavigationDirection direction
)

Parameters

direction
See Also

Reference

Viewer Class
Viewer Members


PreviewDragEnter Event

PreviewDragEnter Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewDragEnter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewDragEnter As System.Windows.DragEventHandler
public event System.Windows.DragEventHandler PreviewDragEnter
Event Data

The event handler receives an argument of type System.Windows.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
Data | Gets a data object (implements System.Windows.IDataObject) that contains the data associated with the corresponding drag event. This value is not useful in all event cases; see Remarks.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
See Also

Reference

Viewer Class
Viewer Members


PreviewDragLeave Event

PreviewDragLeave Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewDragLeave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewDragLeave As System.Windows.DragEventHandler
public event System.Windows.DragEventHandler PreviewDragLeave
Event Data

The event handler receives an argument of type System.Windows.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
Data | Gets a data object (implements System.Windows.IDataObject) that contains the data associated with the corresponding drag event. This value is not useful in all event cases; see Remarks.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
See Also

Reference

Viewer Class
Viewer Members


PreviewDragOver Event

PreviewDragOver Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewDragOver Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewDragOver As System.Windows.DragEventHandler
public event System.Windows.DragEventHandler PreviewDragOver
Event Data

The event handler receives an argument of type System.Windows.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
Data | Gets a data object (implements System.Windows.IDataObject) that contains the data associated with the corresponding drag event. This value is not useful in all event cases; see Remarks.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
See Also

Reference

Viewer Class
Viewer Members


PreviewDrop Event

PreviewDrop Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewDrop Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewDrop As System.Windows.DragEventHandler
public event System.Windows.DragEventHandler PreviewDrop
Event Data

The event handler receives an argument of type System.Windows.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
Data | Gets a data object (implements System.Windows.IDataObject) that contains the data associated with the corresponding drag event. This value is not useful in all event cases; see Remarks.
Handled | Gets or sets a value that indicates the present state of the event handling for a routed event as it travels the route.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
See Also

Reference

Viewer Class
Viewer Members


PreviewGiveFeedback Event

PreviewGiveFeedback Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewGiveFeedback Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewGiveFeedback As System.Windows.GiveFeedbackEventHandler
public event System.Windows.GiveFeedbackEventHandler PreviewGiveFeedback
Event Data

The event handler receives an argument of type System.Windows.GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effects | Gets a value that indicates the effects of drag-and-drop operation.
Handled | (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
UseDefaultCursors | Gets or sets a Boolean value indicating whether default cursor feedback behavior should be used for the associated drag-and-drop operation.
See Also

Reference

Viewer Class
Viewer Members


PreviewGotKeyboardFocus Event

PreviewGotKeyboardFocus Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewGotKeyboardFocus Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewGotKeyboardFocus As System.Windows.Input.KeyboardFocusChangedEventHandler
public event System.Windows.Input.KeyboardFocusChangedEventHandler PreviewGotKeyboardFocus
Event Data

The event handler receives an argument of type System.Windows.Input.KeyboardFocusChangedEventArgs containing data related to this event. The following KeyboardFocusChangedEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
KeyboardDevice | (Inherited from System.Windows.Input.KeyboardEventArgs)
NewFocus | Gets the element that focus has moved to.
OldFocus | Gets the element that previously had focus.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


PreviewKeyDown Event (Viewer)

PreviewKeyDown Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewKeyDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewKeyDown As System.Windows.Input.KeyEventHandler
public event System.Windows.Input.KeyEventHandler PreviewKeyDown
Event Data

The event handler receives an argument of type System.Windows.Input.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled. A true value for Handled prevents most handlers along the event route from handling the same event again.
Key | Gets the keyboard key associated with the event.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
PlatformKeyCode | Gets an integer value that represents the key that is pressed or released (depending on which event is raised). This value is the nonportable key code, which is operating system–specific.
See Also

Reference

Viewer Class
Viewer Members


PreviewKeyUp Event

PreviewKeyUp Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewKeyUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewKeyUp As System.Windows.Input.KeyEventHandler
public event System.Windows.Input.KeyEventHandler PreviewKeyUp
Event Data

The event handler receives an argument of type System.Windows.Input.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled. A true value for Handled prevents most handlers along the event route from handling the same event again.
Key | Gets the keyboard key associated with the event.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
PlatformKeyCode | Gets an integer value that represents the key that is pressed or released (depending on which event is raised). This value is the nonportable key code, which is operating system–specific.
See Also

Reference

Viewer Class
Viewer Members


PreviewLostKeyboardFocus Event

PreviewLostKeyboardFocus Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewLostKeyboardFocus Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewLostKeyboardFocus As System.Windows.Input.KeyboardFocusChangedEventHandler
public event System.Windows.Input.KeyboardFocusChangedEventHandler PreviewLostKeyboardFocus
Event Data

The event handler receives an argument of type System.Windows.Input.KeyboardFocusChangedEventArgs containing data related to this event. The following KeyboardFocusChangedEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
KeyboardDevice | (Inherited from System.Windows.Input.KeyboardEventArgs)
NewFocus | Gets the element that focus has moved to.
OldFocus | Gets the element that previously had focus.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


PreviewMouseDoubleClick Event

PreviewMouseDoubleClick Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewMouseDoubleClick Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewMouseDoubleClick As System.Windows.Input.MouseButtonEventHandler
public event System.Windows.Input.MouseButtonEventHandler PreviewMouseDoubleClick
Event Data

The event handler receives an argument of type System.Windows.Input.MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled. A true value for Handled prevents most handlers along the event route from handling the same event again.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.MouseEventArgs)
See Also

Reference

Viewer Class
Viewer Members


PreviewMouseDown Event

PreviewMouseDown Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewMouseDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewMouseDown As System.Windows.Input.MouseButtonEventHandler
public event System.Windows.Input.MouseButtonEventHandler PreviewMouseDown
Event Data

The event handler receives an argument of type System.Windows.Input.MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled. A true value for Handled prevents most handlers along the event route from handling the same event again.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.MouseEventArgs)
See Also

Reference

Viewer Class
Viewer Members


PreviewMouseLeftButtonDown Event

PreviewMouseLeftButtonDown Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewMouseLeftButtonDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewMouseLeftButtonDown As System.Windows.Input.MouseButtonEventHandler
public event System.Windows.Input.MouseButtonEventHandler PreviewMouseLeftButtonDown
Event Data

The event handler receives an argument of type System.Windows.Input.MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled. A true value for Handled prevents most handlers along the event route from handling the same event again.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.MouseEventArgs)
See Also

Reference

Viewer Class
Viewer Members


PreviewMouseLeftButtonUp Event

PreviewMouseLeftButtonUp Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewMouseLeftButtonUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewMouseLeftButtonUp As System.Windows.Input.MouseButtonEventHandler
public event System.Windows.Input.MouseButtonEventHandler PreviewMouseLeftButtonUp
Event Data

The event handler receives an argument of type System.Windows.Input.MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled. A true value for Handled prevents most handlers along the event route from handling the same event again.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.MouseEventArgs)
See Also

Reference

Viewer Class
Viewer Members


PreviewMouseMove Event

PreviewMouseMove Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewMouseMove Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewMouseMove As System.Windows.Input.MouseEventHandler
public event System.Windows.Input.MouseEventHandler PreviewMouseMove
Event Data

The event handler receives an argument of type System.Windows.Input.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets an object that reports stylus device information, such as the collection of stylus points associated with the input.
See Also

Reference

Viewer Class
Viewer Members


PreviewMouseRightButtonDown Event

PreviewMouseRightButtonDown Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewMouseRightButtonDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewMouseRightButtonDown As System.Windows.Input.MouseButtonEventHandler
public event System.Windows.Input.MouseButtonEventHandler PreviewMouseRightButtonDown
Event Data

The event handler receives an argument of type System.Windows.Input.MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled. A true value for Handled prevents most handlers along the event route from handling the same event again.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.MouseEventArgs)
See Also

Reference

Viewer Class
Viewer Members


PreviewMouseRightButtonUp Event

PreviewMouseRightButtonUp Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewMouseRightButtonUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewMouseRightButtonUp As System.Windows.Input.MouseButtonEventHandler
public event System.Windows.Input.MouseButtonEventHandler PreviewMouseRightButtonUp
Event Data

The event handler receives an argument of type System.Windows.Input.MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled. A true value for Handled prevents most handlers along the event route from handling the same event again.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.MouseEventArgs)
See Also

Reference

Viewer Class
Viewer Members


PreviewMouseUp Event

PreviewMouseUp Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewMouseUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewMouseUp As System.Windows.Input.MouseButtonEventHandler
public event System.Windows.Input.MouseButtonEventHandler PreviewMouseUp
Event Data

The event handler receives an argument of type System.Windows.Input.MouseButtonEventArgs containing data related to this event. The following MouseButtonEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled. A true value for Handled prevents most handlers along the event route from handling the same event again.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.MouseEventArgs)
See Also

Reference

Viewer Class
Viewer Members


PreviewMouseWheel Event

PreviewMouseWheel Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewMouseWheel Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewMouseWheel As System.Windows.Input.MouseWheelEventHandler
public event System.Windows.Input.MouseWheelEventHandler PreviewMouseWheel
Event Data

The event handler receives an argument of type System.Windows.Input.MouseWheelEventArgs containing data related to this event. The following MouseWheelEventArgs properties provide information specific to this event.

Property | Description
Delta | Gets a value that indicates the amount that the mouse wheel rotated relative to its starting state or to the last occurrence of the event.
Handled | Gets or sets a value that marks the routed event as handled, and prevents most handlers along the event route from rehandling the same event.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.MouseEventArgs)
See Also

Reference

Viewer Class
Viewer Members


PreviewQueryContinueDrag Event

PreviewQueryContinueDrag Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewQueryContinueDrag Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewQueryContinueDrag As System.Windows.QueryContinueDragEventHandler
public event System.Windows.QueryContinueDragEventHandler PreviewQueryContinueDrag
Event Data

The event handler receives an argument of type System.Windows.QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the current status of the associated drag-and-drop operation.
EscapePressed | Gets a Boolean value indicating whether the ESC key has been pressed.
Handled | (Inherited from System.Windows.RoutedEventArgs)
KeyStates | Gets a flag enumeration indicating the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
See Also

Reference

Viewer Class
Viewer Members


PreviewStylusButtonDown Event

PreviewStylusButtonDown Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewStylusButtonDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewStylusButtonDown As System.Windows.Input.StylusButtonEventHandler
public event System.Windows.Input.StylusButtonEventHandler PreviewStylusButtonDown
Event Data

The event handler receives an argument of type System.Windows.Input.StylusButtonEventArgs containing data related to this event. The following StylusButtonEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
InAir | (Inherited from System.Windows.Input.StylusEventArgs)
Inverted | (Inherited from System.Windows.Input.StylusEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
StylusButton | Gets the System.Windows.Input.StylusButton that raises this event.
StylusDevice | (Inherited from System.Windows.Input.StylusEventArgs)
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


PreviewStylusButtonUp Event

PreviewStylusButtonUp Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewStylusButtonUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewStylusButtonUp As System.Windows.Input.StylusButtonEventHandler
public event System.Windows.Input.StylusButtonEventHandler PreviewStylusButtonUp
Event Data

The event handler receives an argument of type System.Windows.Input.StylusButtonEventArgs containing data related to this event. The following StylusButtonEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
InAir | (Inherited from System.Windows.Input.StylusEventArgs)
Inverted | (Inherited from System.Windows.Input.StylusEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
StylusButton | Gets the System.Windows.Input.StylusButton that raises this event.
StylusDevice | (Inherited from System.Windows.Input.StylusEventArgs)
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


PreviewStylusDown Event

PreviewStylusDown Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewStylusDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewStylusDown As System.Windows.Input.StylusDownEventHandler
public event System.Windows.Input.StylusDownEventHandler PreviewStylusDown
Event Data

The event handler receives an argument of type System.Windows.Input.StylusDownEventArgs containing data related to this event. The following StylusDownEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
InAir | (Inherited from System.Windows.Input.StylusEventArgs)
Inverted | (Inherited from System.Windows.Input.StylusEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.StylusEventArgs)
TapCount | Gets the number of times the tablet pen was tapped.
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


PreviewStylusInAirMove Event

PreviewStylusInAirMove Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewStylusInAirMove Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewStylusInAirMove As System.Windows.Input.StylusEventHandler
public event System.Windows.Input.StylusEventHandler PreviewStylusInAirMove
Event Data

The event handler receives an argument of type System.Windows.Input.StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


PreviewStylusInRange Event

PreviewStylusInRange Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewStylusInRange Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewStylusInRange As System.Windows.Input.StylusEventHandler
public event System.Windows.Input.StylusEventHandler PreviewStylusInRange
Event Data

The event handler receives an argument of type System.Windows.Input.StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


PreviewStylusMove Event

PreviewStylusMove Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewStylusMove Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewStylusMove As System.Windows.Input.StylusEventHandler
public event System.Windows.Input.StylusEventHandler PreviewStylusMove
Event Data

The event handler receives an argument of type System.Windows.Input.StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


PreviewStylusOutOfRange Event

PreviewStylusOutOfRange Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewStylusOutOfRange Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewStylusOutOfRange As System.Windows.Input.StylusEventHandler
public event System.Windows.Input.StylusEventHandler PreviewStylusOutOfRange
Event Data

The event handler receives an argument of type System.Windows.Input.StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


PreviewStylusSystemGesture Event

PreviewStylusSystemGesture Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewStylusSystemGesture Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewStylusSystemGesture As System.Windows.Input.StylusSystemGestureEventHandler
public event System.Windows.Input.StylusSystemGestureEventHandler PreviewStylusSystemGesture
Event Data

The event handler receives an argument of type System.Windows.Input.StylusSystemGestureEventArgs containing data related to this event. The following StylusSystemGestureEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
InAir | (Inherited from System.Windows.Input.StylusEventArgs)
Inverted | (Inherited from System.Windows.Input.StylusEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.StylusEventArgs)
SystemGesture | Gets the System.Windows.Input.SystemGesture that raises the event.
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


PreviewStylusUp Event

PreviewStylusUp Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewStylusUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewStylusUp As System.Windows.Input.StylusEventHandler
public event System.Windows.Input.StylusEventHandler PreviewStylusUp
Event Data

The event handler receives an argument of type System.Windows.Input.StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


PreviewTextInput Event

PreviewTextInput Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewTextInput Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewTextInput As System.Windows.Input.TextCompositionEventHandler
public event System.Windows.Input.TextCompositionEventHandler PreviewTextInput
Event Data

The event handler receives an argument of type System.Windows.Input.TextCompositionEventArgs containing data related to this event. The following TextCompositionEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled, and prevents most handlers along the event route from handling the same event again.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
Text | Gets or sets the text string that of the text composition.
TextComposition | Gets or sets the text in the composition as a System.Windows.Input.TextComposition object.
See Also

Reference

Viewer Class
Viewer Members


PreviewTouchDown Event

PreviewTouchDown Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewTouchDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewTouchDown As System.EventHandler(Of TouchEventArgs)
public event System.EventHandler<TouchEventArgs> PreviewTouchDown
Event Data

The event handler receives an argument of type System.Windows.Input.TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
TouchDevice | Gets the touch that generated the event.
See Also

Reference

Viewer Class
Viewer Members


PreviewTouchMove Event

PreviewTouchMove Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewTouchMove Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewTouchMove As System.EventHandler(Of TouchEventArgs)
public event System.EventHandler<TouchEventArgs> PreviewTouchMove
Event Data

The event handler receives an argument of type System.Windows.Input.TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
TouchDevice | Gets the touch that generated the event.
See Also

Reference

Viewer Class
Viewer Members


PreviewTouchUp Event

PreviewTouchUp Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : PreviewTouchUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreviewTouchUp As System.EventHandler(Of TouchEventArgs)
public event System.EventHandler<TouchEventArgs> PreviewTouchUp
Event Data

The event handler receives an argument of type System.Windows.Input.TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
TouchDevice | Gets the touch that generated the event.
See Also

Reference

Viewer Class
Viewer Members


QueryContinueDrag Event (Viewer)

QueryContinueDrag Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : QueryContinueDrag Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event QueryContinueDrag As System.Windows.QueryContinueDragEventHandler
public event System.Windows.QueryContinueDragEventHandler QueryContinueDrag
Event Data

The event handler receives an argument of type System.Windows.QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the current status of the associated drag-and-drop operation.
EscapePressed | Gets a Boolean value indicating whether the ESC key has been pressed.
Handled | (Inherited from System.Windows.RoutedEventArgs)
KeyStates | Gets a flag enumeration indicating the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
See Also

Reference

Viewer Class
Viewer Members


QueryCursor Event

QueryCursor Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : QueryCursor Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event QueryCursor As System.Windows.Input.QueryCursorEventHandler
public event System.Windows.Input.QueryCursorEventHandler QueryCursor
Event Data

The event handler receives an argument of type System.Windows.Input.QueryCursorEventArgs containing data related to this event. The following QueryCursorEventArgs properties provide information specific to this event.

Property | Description
Cursor | Gets or sets the cursor associated with this event.
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
LeftButton | (Inherited from System.Windows.Input.MouseEventArgs)
MiddleButton | (Inherited from System.Windows.Input.MouseEventArgs)
MouseDevice | (Inherited from System.Windows.Input.MouseEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RightButton | (Inherited from System.Windows.Input.MouseEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.MouseEventArgs)
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
XButton1 | (Inherited from System.Windows.Input.MouseEventArgs)
XButton2 | (Inherited from System.Windows.Input.MouseEventArgs)
See Also

Reference

Viewer Class
Viewer Members


RaiseEvent Method

RaiseEvent Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : RaiseEvent Method
Overload List
Overload | Description
RaiseEvent | (Inherited from System.Windows.UIElement)
See Also

Reference

Viewer Class
Viewer Members


RaiseEvent(RoutedEventArgs) Method

RaiseEvent(RoutedEventArgs) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : RaiseEvent(RoutedEventArgs) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RaiseEvent( _
   ByVal e As System.Windows.RoutedEventArgs _
)
public void RaiseEvent(
   System.Windows.RoutedEventArgs e
)

Parameters

e
See Also

Reference

Viewer Class
Viewer Members


ReadLocalValue Method (Viewer)

ReadLocalValue Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ReadLocalValue Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ReadLocalValue( _
   ByVal dp As System.Windows.DependencyProperty _
) As System.Object
public System.object ReadLocalValue(
   System.Windows.DependencyProperty dp
)

Parameters

dp
See Also

Reference

Viewer Class
Viewer Members


RegisterName Method

RegisterName Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : RegisterName Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RegisterName( _
   ByVal name As System.String, _
   ByVal scopedElement As System.Object _
)
public void RegisterName(
   System.string name,
   System.object scopedElement
)

Parameters

name
scopedElement
See Also

Reference

Viewer Class
Viewer Members


ReleaseAllTouchCaptures Method

ReleaseAllTouchCaptures Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ReleaseAllTouchCaptures Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ReleaseAllTouchCaptures()
public void ReleaseAllTouchCaptures()
See Also

Reference

Viewer Class
Viewer Members


ReleaseMouseCapture Method (Viewer)

ReleaseMouseCapture Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ReleaseMouseCapture Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ReleaseMouseCapture()
public void ReleaseMouseCapture()
See Also

Reference

Viewer Class
Viewer Members


ReleaseStylusCapture Method

ReleaseStylusCapture Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ReleaseStylusCapture Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ReleaseStylusCapture()
public void ReleaseStylusCapture()
See Also

Reference

Viewer Class
Viewer Members


ReleaseTouchCapture Method

ReleaseTouchCapture Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ReleaseTouchCapture Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ReleaseTouchCapture( _
   ByVal touchDevice As System.Windows.Input.TouchDevice _
) As System.Boolean
public System.bool ReleaseTouchCapture(
   System.Windows.Input.TouchDevice touchDevice
)

Parameters

touchDevice
See Also

Reference

Viewer Class
Viewer Members


RemoveHandler Method (Viewer)

RemoveHandler Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : RemoveHandler Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveHandler( _
   ByVal routedEvent As System.Windows.RoutedEvent, _
   ByVal handler As System.Delegate _
)
public void RemoveHandler(
   System.Windows.RoutedEvent routedEvent,
   System.Delegate handler
)

Parameters

routedEvent
handler
See Also

Reference

Viewer Class
Viewer Members


Render Method (Viewer)

Render Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Render Method
Exports the specified loaded report to the specified file (or group of files) by using the specified export extension. Note: for page report only.
Overload List
Overload | Description
Render | Exports the specified loaded report to the specified file (or group of files) by using the specified export extension. Note: for page report only.
See Also

Reference

Viewer Class
Viewer Members


RenderSize Property (Viewer)

RenderSize Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : RenderSize Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RenderSize As System.Windows.Size
public System.Windows.Size RenderSize {get; set;}
See Also

Reference

Viewer Class
Viewer Members


RenderTransform Property (Viewer)

RenderTransform Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : RenderTransform Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RenderTransform As System.Windows.Media.Transform
public System.Windows.Media.Transform RenderTransform {get; set;}
See Also

Reference

Viewer Class
Viewer Members


RenderTransformOrigin Property (Viewer)

RenderTransformOrigin Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : RenderTransformOrigin Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RenderTransformOrigin As System.Windows.Point
public System.Windows.Point RenderTransformOrigin {get; set;}
See Also

Reference

Viewer Class
Viewer Members


RequestBringIntoView Event

RequestBringIntoView Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : RequestBringIntoView Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event RequestBringIntoView As System.Windows.RequestBringIntoViewEventHandler
public event System.Windows.RequestBringIntoViewEventHandler RequestBringIntoView
Event Data

The event handler receives an argument of type System.Windows.RequestBringIntoViewEventArgs containing data related to this event. The following RequestBringIntoViewEventArgs properties provide information specific to this event.

Property | Description
Handled | (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
TargetObject | Gets the object that should be made visible in response to the event.
TargetRect | Gets the rectangular region in the object's coordinate space which should be made visible.
See Also

Reference

Viewer Class
Viewer Members


Resources Property (Viewer)

Resources Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Resources Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Resources As System.Windows.ResourceDictionary
public System.Windows.ResourceDictionary Resources {get; set;}
See Also

Reference

Viewer Class
Viewer Members


SetBinding Method (Viewer)

SetBinding Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SetBinding Method
Overload List
Overload | Description
SetBinding(DependencyProperty,BindingBase) | (Inherited from System.Windows.FrameworkElement)
SetBinding(DependencyProperty,String) | (Inherited from System.Windows.FrameworkElement)
See Also

Reference

Viewer Class
Viewer Members


SetBinding(DependencyProperty,BindingBase) Method

SetBinding(DependencyProperty,BindingBase) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > SetBinding Method : SetBinding(DependencyProperty,BindingBase) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function SetBinding( _
   ByVal dp As System.Windows.DependencyProperty, _
   ByVal binding As System.Windows.Data.BindingBase _
) As System.Windows.Data.BindingExpressionBase
public System.Windows.Data.BindingExpressionBase SetBinding(
   System.Windows.DependencyProperty dp,
   System.Windows.Data.BindingBase binding
)

Parameters

dp
binding
See Also

Reference

Viewer Class
Viewer Members
Overload List


SetBinding(DependencyProperty,String) Method

SetBinding(DependencyProperty,String) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > SetBinding Method : SetBinding(DependencyProperty,String) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function SetBinding( _
   ByVal dp As System.Windows.DependencyProperty, _
   ByVal path As System.String _
) As System.Windows.Data.BindingExpression
public System.Windows.Data.BindingExpression SetBinding(
   System.Windows.DependencyProperty dp,
   System.string path
)

Parameters

dp
path
See Also

Reference

Viewer Class
Viewer Members
Overload List


SetCurrentValue Method (Viewer)

SetCurrentValue Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SetCurrentValue Method
Overload List
Overload | Description
SetCurrentValue | (Inherited from System.Windows.DependencyObject)
See Also

Reference

Viewer Class
Viewer Members


SetCurrentValue(DependencyProperty,Object) Method

SetCurrentValue(DependencyProperty,Object) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SetCurrentValue(DependencyProperty,Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetCurrentValue( _
   ByVal dp As System.Windows.DependencyProperty, _
   ByVal value As System.Object _
)
public void SetCurrentValue(
   System.Windows.DependencyProperty dp,
   System.object value
)

Parameters

dp
value
See Also

Reference

Viewer Class
Viewer Members


SetResourceReference Method

SetResourceReference Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SetResourceReference Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetResourceReference( _
   ByVal dp As System.Windows.DependencyProperty, _
   ByVal name As System.Object _
)
public void SetResourceReference(
   System.Windows.DependencyProperty dp,
   System.object name
)

Parameters

dp
name
See Also

Reference

Viewer Class
Viewer Members


SetValue Method (Viewer)

SetValue Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SetValue Method
Overload List
Overload | Description
SetValue(DependencyProperty,Object) | (Inherited from System.Windows.DependencyObject)
SetValue(DependencyPropertyKey,Object) | (Inherited from System.Windows.DependencyObject)
See Also

Reference

Viewer Class
Viewer Members


SetValue(DependencyProperty,Object) Method

SetValue(DependencyProperty,Object) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > SetValue Method : SetValue(DependencyProperty,Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetValue( _
   ByVal dp As System.Windows.DependencyProperty, _
   ByVal value As System.Object _
)
public void SetValue(
   System.Windows.DependencyProperty dp,
   System.object value
)

Parameters

dp
value
See Also

Reference

Viewer Class
Viewer Members
Overload List


SetValue(DependencyPropertyKey,Object) Method

SetValue(DependencyPropertyKey,Object) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > SetValue Method : SetValue(DependencyPropertyKey,Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SetValue( _
   ByVal key As System.Windows.DependencyPropertyKey, _
   ByVal value As System.Object _
)
public void SetValue(
   System.Windows.DependencyPropertyKey key,
   System.object value
)

Parameters

key
value
See Also

Reference

Viewer Class
Viewer Members
Overload List


SizeChanged Event (Viewer)

SizeChanged Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SizeChanged Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event SizeChanged As System.Windows.SizeChangedEventHandler
public event System.Windows.SizeChangedEventHandler SizeChanged
Event Data

The event handler receives an argument of type System.Windows.SizeChangedEventArgs containing data related to this event. The following SizeChangedEventArgs properties provide information specific to this event.

Property | Description
NewSize | Gets the new size of the object reporting the size change.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
PreviousSize | Gets the previous size of the object reporting the size change.
See Also

Reference

Viewer Class
Viewer Members


SnapsToDevicePixels Property

SnapsToDevicePixels Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SnapsToDevicePixels Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SnapsToDevicePixels As System.Boolean
public System.bool SnapsToDevicePixels {get; set;}
See Also

Reference

Viewer Class
Viewer Members


SourceUpdated Event

SourceUpdated Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : SourceUpdated Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event SourceUpdated As System.EventHandler(Of DataTransferEventArgs)
public event System.EventHandler<DataTransferEventArgs> SourceUpdated
Event Data

The event handler receives an argument of type System.Windows.Data.DataTransferEventArgs containing data related to this event. The following DataTransferEventArgs properties provide information specific to this event.

Property | Description
Handled | (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
Property | Gets the specific binding target property that is involved in the data transfer event.
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
TargetObject | Gets the binding target object of the binding that raised the event.
See Also

Reference

Viewer Class
Viewer Members


Style Property (Viewer)

Style Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Style Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As System.Windows.Style
public System.Windows.Style Style {get; set;}
See Also

Reference

Viewer Class
Viewer Members


StylusButtonDown Event

StylusButtonDown Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : StylusButtonDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event StylusButtonDown As System.Windows.Input.StylusButtonEventHandler
public event System.Windows.Input.StylusButtonEventHandler StylusButtonDown
Event Data

The event handler receives an argument of type System.Windows.Input.StylusButtonEventArgs containing data related to this event. The following StylusButtonEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
InAir | (Inherited from System.Windows.Input.StylusEventArgs)
Inverted | (Inherited from System.Windows.Input.StylusEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
StylusButton | Gets the System.Windows.Input.StylusButton that raises this event.
StylusDevice | (Inherited from System.Windows.Input.StylusEventArgs)
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


StylusButtonUp Event

StylusButtonUp Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : StylusButtonUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event StylusButtonUp As System.Windows.Input.StylusButtonEventHandler
public event System.Windows.Input.StylusButtonEventHandler StylusButtonUp
Event Data

The event handler receives an argument of type System.Windows.Input.StylusButtonEventArgs containing data related to this event. The following StylusButtonEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
InAir | (Inherited from System.Windows.Input.StylusEventArgs)
Inverted | (Inherited from System.Windows.Input.StylusEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
StylusButton | Gets the System.Windows.Input.StylusButton that raises this event.
StylusDevice | (Inherited from System.Windows.Input.StylusEventArgs)
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


StylusDown Event

StylusDown Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : StylusDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event StylusDown As System.Windows.Input.StylusDownEventHandler
public event System.Windows.Input.StylusDownEventHandler StylusDown
Event Data

The event handler receives an argument of type System.Windows.Input.StylusDownEventArgs containing data related to this event. The following StylusDownEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
InAir | (Inherited from System.Windows.Input.StylusEventArgs)
Inverted | (Inherited from System.Windows.Input.StylusEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.StylusEventArgs)
TapCount | Gets the number of times the tablet pen was tapped.
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


StylusEnter Event

StylusEnter Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : StylusEnter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event StylusEnter As System.Windows.Input.StylusEventHandler
public event System.Windows.Input.StylusEventHandler StylusEnter
Event Data

The event handler receives an argument of type System.Windows.Input.StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


StylusInAirMove Event

StylusInAirMove Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : StylusInAirMove Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event StylusInAirMove As System.Windows.Input.StylusEventHandler
public event System.Windows.Input.StylusEventHandler StylusInAirMove
Event Data

The event handler receives an argument of type System.Windows.Input.StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


StylusInRange Event

StylusInRange Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : StylusInRange Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event StylusInRange As System.Windows.Input.StylusEventHandler
public event System.Windows.Input.StylusEventHandler StylusInRange
Event Data

The event handler receives an argument of type System.Windows.Input.StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


StylusLeave Event

StylusLeave Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : StylusLeave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event StylusLeave As System.Windows.Input.StylusEventHandler
public event System.Windows.Input.StylusEventHandler StylusLeave
Event Data

The event handler receives an argument of type System.Windows.Input.StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


StylusMove Event

StylusMove Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : StylusMove Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event StylusMove As System.Windows.Input.StylusEventHandler
public event System.Windows.Input.StylusEventHandler StylusMove
Event Data

The event handler receives an argument of type System.Windows.Input.StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


StylusOutOfRange Event

StylusOutOfRange Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : StylusOutOfRange Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event StylusOutOfRange As System.Windows.Input.StylusEventHandler
public event System.Windows.Input.StylusEventHandler StylusOutOfRange
Event Data

The event handler receives an argument of type System.Windows.Input.StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


StylusSystemGesture Event

StylusSystemGesture Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : StylusSystemGesture Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event StylusSystemGesture As System.Windows.Input.StylusSystemGestureEventHandler
public event System.Windows.Input.StylusSystemGestureEventHandler StylusSystemGesture
Event Data

The event handler receives an argument of type System.Windows.Input.StylusSystemGestureEventArgs containing data related to this event. The following StylusSystemGestureEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
InAir | (Inherited from System.Windows.Input.StylusEventArgs)
Inverted | (Inherited from System.Windows.Input.StylusEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | (Inherited from System.Windows.Input.StylusEventArgs)
SystemGesture | Gets the System.Windows.Input.SystemGesture that raises the event.
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


StylusUp Event

StylusUp Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : StylusUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event StylusUp As System.Windows.Input.StylusEventHandler
public event System.Windows.Input.StylusEventHandler StylusUp
Event Data

The event handler receives an argument of type System.Windows.Input.StylusEventArgs containing data related to this event. The following StylusEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
InAir | Gets a value that indicates whether the stylus is in proximity to, but not touching, the digitizer.
Inverted | Gets a value that indicates whether the stylus in inverted.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
StylusDevice | Gets the System.Windows.Input.StylusDevice that represents the stylus.
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
See Also

Reference

Viewer Class
Viewer Members


TabIndex Property (Viewer)

TabIndex Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TabIndex Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TabIndex As System.Integer
public System.int TabIndex {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Tag Property (Viewer)

Tag Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Tag Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Tag As System.Object
public System.object Tag {get; set;}
See Also

Reference

Viewer Class
Viewer Members


TargetUpdated Event

TargetUpdated Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TargetUpdated Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TargetUpdated As System.EventHandler(Of DataTransferEventArgs)
public event System.EventHandler<DataTransferEventArgs> TargetUpdated
Event Data

The event handler receives an argument of type System.Windows.Data.DataTransferEventArgs containing data related to this event. The following DataTransferEventArgs properties provide information specific to this event.

Property | Description
Handled | (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
Property | Gets the specific binding target property that is involved in the data transfer event.
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
TargetObject | Gets the binding target object of the binding that raised the event.
See Also

Reference

Viewer Class
Viewer Members


Template Property (Viewer)

Template Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Template Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Template As System.Windows.Controls.ControlTemplate
public System.Windows.Controls.ControlTemplate Template {get; set;}
See Also

Reference

Viewer Class
Viewer Members


TemplatedParent Property

TemplatedParent Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TemplatedParent Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TemplatedParent As System.Windows.DependencyObject
public System.Windows.DependencyObject TemplatedParent {get;}
See Also

Reference

Viewer Class
Viewer Members


TextInput Event (Viewer)

TextInput Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TextInput Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TextInput As System.Windows.Input.TextCompositionEventHandler
public event System.Windows.Input.TextCompositionEventHandler TextInput
Event Data

The event handler receives an argument of type System.Windows.Input.TextCompositionEventArgs containing data related to this event. The following TextCompositionEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value that marks the routed event as handled, and prevents most handlers along the event route from handling the same event again.
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
Text | Gets or sets the text string that of the text composition.
TextComposition | Gets or sets the text in the composition as a System.Windows.Input.TextComposition object.
See Also

Reference

Viewer Class
Viewer Members


ToolTip Property (Viewer)

ToolTip Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ToolTip Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ToolTip As System.Object
public System.object ToolTip {get; set;}
See Also

Reference

Viewer Class
Viewer Members


ToolTipClosing Event

ToolTipClosing Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ToolTipClosing Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ToolTipClosing As System.Windows.Controls.ToolTipEventHandler
public event System.Windows.Controls.ToolTipEventHandler ToolTipClosing
Event Data

The event handler receives an argument of type System.Windows.Controls.ToolTipEventArgs containing data related to this event. The following ToolTipEventArgs properties provide information specific to this event.

Property | Description
Handled | (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
See Also

Reference

Viewer Class
Viewer Members


ToolTipOpening Event

ToolTipOpening Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ToolTipOpening Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ToolTipOpening As System.Windows.Controls.ToolTipEventHandler
public event System.Windows.Controls.ToolTipEventHandler ToolTipOpening
Event Data

The event handler receives an argument of type System.Windows.Controls.ToolTipEventArgs containing data related to this event. The following ToolTipEventArgs properties provide information specific to this event.

Property | Description
Handled | (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
See Also

Reference

Viewer Class
Viewer Members


ToString Method (Viewer)

ToString Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : ToString Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function ToString() As System.String
public virtual System.string ToString()
See Also

Reference

Viewer Class
Viewer Members


TouchDown Event

TouchDown Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TouchDown Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TouchDown As System.EventHandler(Of TouchEventArgs)
public event System.EventHandler<TouchEventArgs> TouchDown
Event Data

The event handler receives an argument of type System.Windows.Input.TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
TouchDevice | Gets the touch that generated the event.
See Also

Reference

Viewer Class
Viewer Members


TouchEnter Event

TouchEnter Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TouchEnter Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TouchEnter As System.EventHandler(Of TouchEventArgs)
public event System.EventHandler<TouchEventArgs> TouchEnter
Event Data

The event handler receives an argument of type System.Windows.Input.TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
TouchDevice | Gets the touch that generated the event.
See Also

Reference

Viewer Class
Viewer Members


TouchesCaptured Property

TouchesCaptured Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TouchesCaptured Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TouchesCaptured As System.Collections.Generic.IEnumerable(Of TouchDevice)
public System.Collections.Generic.IEnumerable<TouchDevice> TouchesCaptured {get;}
See Also

Reference

Viewer Class
Viewer Members


TouchesCapturedWithin Property

TouchesCapturedWithin Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TouchesCapturedWithin Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TouchesCapturedWithin As System.Collections.Generic.IEnumerable(Of TouchDevice)
public System.Collections.Generic.IEnumerable<TouchDevice> TouchesCapturedWithin {get;}
See Also

Reference

Viewer Class
Viewer Members


TouchesDirectlyOver Property

TouchesDirectlyOver Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TouchesDirectlyOver Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TouchesDirectlyOver As System.Collections.Generic.IEnumerable(Of TouchDevice)
public System.Collections.Generic.IEnumerable<TouchDevice> TouchesDirectlyOver {get;}
See Also

Reference

Viewer Class
Viewer Members


TouchesOver Property

TouchesOver Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TouchesOver Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TouchesOver As System.Collections.Generic.IEnumerable(Of TouchDevice)
public System.Collections.Generic.IEnumerable<TouchDevice> TouchesOver {get;}
See Also

Reference

Viewer Class
Viewer Members


TouchLeave Event

TouchLeave Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TouchLeave Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TouchLeave As System.EventHandler(Of TouchEventArgs)
public event System.EventHandler<TouchEventArgs> TouchLeave
Event Data

The event handler receives an argument of type System.Windows.Input.TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
TouchDevice | Gets the touch that generated the event.
See Also

Reference

Viewer Class
Viewer Members


TouchMove Event

TouchMove Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TouchMove Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TouchMove As System.EventHandler(Of TouchEventArgs)
public event System.EventHandler<TouchEventArgs> TouchMove
Event Data

The event handler receives an argument of type System.Windows.Input.TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
TouchDevice | Gets the touch that generated the event.
See Also

Reference

Viewer Class
Viewer Members


TouchUp Event

TouchUp Event

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TouchUp Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event TouchUp As System.EventHandler(Of TouchEventArgs)
public event System.EventHandler<TouchEventArgs> TouchUp
Event Data

The event handler receives an argument of type System.Windows.Input.TouchEventArgs containing data related to this event. The following TouchEventArgs properties provide information specific to this event.

Property | Description
Device | (Inherited from System.Windows.Input.InputEventArgs)
Handled | (Inherited from System.Windows.RoutedEventArgs)
OriginalSource | (Inherited from System.Windows.RoutedEventArgs)
RoutedEvent | (Inherited from System.Windows.RoutedEventArgs)
Source | (Inherited from System.Windows.RoutedEventArgs)
Timestamp | (Inherited from System.Windows.Input.InputEventArgs)
TouchDevice | Gets the touch that generated the event.
See Also

Reference

Viewer Class
Viewer Members


TransformToAncestor Method

TransformToAncestor Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TransformToAncestor Method
Overload List
Overload | Description
TransformToAncestor(Visual) | (Inherited from System.Windows.Media.Visual)
TransformToAncestor(Visual3D) | (Inherited from System.Windows.Media.Visual)
See Also

Reference

Viewer Class
Viewer Members


TransformToAncestor(Visual3D) Method

TransformToAncestor(Visual3D) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > TransformToAncestor Method : TransformToAncestor(Visual3D) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function TransformToAncestor( _
   ByVal ancestor As System.Windows.Media.Media3D.Visual3D _
) As System.Windows.Media.Media3D.GeneralTransform2DTo3D
public System.Windows.Media.Media3D.GeneralTransform2DTo3D TransformToAncestor(
   System.Windows.Media.Media3D.Visual3D ancestor
)

Parameters

ancestor
See Also

Reference

Viewer Class
Viewer Members
Overload List


TransformToAncestor(Visual) Method

TransformToAncestor(Visual) Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class > TransformToAncestor Method : TransformToAncestor(Visual) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function TransformToAncestor( _
   ByVal ancestor As System.Windows.Media.Visual _
) As System.Windows.Media.GeneralTransform
public System.Windows.Media.GeneralTransform TransformToAncestor(
   System.Windows.Media.Visual ancestor
)

Parameters

ancestor
See Also

Reference

Viewer Class
Viewer Members
Overload List


TransformToDescendant Method

TransformToDescendant Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TransformToDescendant Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function TransformToDescendant( _
   ByVal descendant As System.Windows.Media.Visual _
) As System.Windows.Media.GeneralTransform
public System.Windows.Media.GeneralTransform TransformToDescendant(
   System.Windows.Media.Visual descendant
)

Parameters

descendant
See Also

Reference

Viewer Class
Viewer Members


TransformToVisual Method (Viewer)

TransformToVisual Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TransformToVisual Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function TransformToVisual( _
   ByVal visual As System.Windows.Media.Visual _
) As System.Windows.Media.GeneralTransform
public System.Windows.Media.GeneralTransform TransformToVisual(
   System.Windows.Media.Visual visual
)

Parameters

visual
See Also

Reference

Viewer Class
Viewer Members


TranslatePoint Method

TranslatePoint Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TranslatePoint Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function TranslatePoint( _
   ByVal point As System.Windows.Point, _
   ByVal relativeTo As System.Windows.UIElement _
) As System.Windows.Point
public System.Windows.Point TranslatePoint(
   System.Windows.Point point,
   System.Windows.UIElement relativeTo
)

Parameters

point
relativeTo
See Also

Reference

Viewer Class
Viewer Members


Triggers Property (Viewer)

Triggers Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Triggers Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Triggers As System.Windows.TriggerCollection
public System.Windows.TriggerCollection Triggers {get;}
See Also

Reference

Viewer Class
Viewer Members


TryFindResource Method

TryFindResource Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : TryFindResource Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function TryFindResource( _
   ByVal resourceKey As System.Object _
) As System.Object
public System.object TryFindResource(
   System.object resourceKey
)

Parameters

resourceKey
See Also

Reference

Viewer Class
Viewer Members


Uid Property

Uid Property

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Uid Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Uid As System.String
public System.string Uid {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Unloaded Event (Viewer)

Unloaded Event (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Unloaded Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Unloaded As System.Windows.RoutedEventHandler
public event System.Windows.RoutedEventHandler Unloaded
Event Data

The event handler receives an argument of type System.Windows.RoutedEventArgs containing data related to this event. The following RoutedEventArgs properties provide information specific to this event.

Property | Description
OriginalSource | Gets a reference to the object that raised the event.
See Also

Reference

Viewer Class
Viewer Members


UnregisterName Method

UnregisterName Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : UnregisterName Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub UnregisterName( _
   ByVal name As System.String _
)
public void UnregisterName(
   System.string name
)

Parameters

name
See Also

Reference

Viewer Class
Viewer Members


UpdateDefaultStyle Method

UpdateDefaultStyle Method

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : UpdateDefaultStyle Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub UpdateDefaultStyle()
public void UpdateDefaultStyle()
See Also

Reference

Viewer Class
Viewer Members


UpdateLayout Method (Viewer)

UpdateLayout Method (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : UpdateLayout Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub UpdateLayout()
public void UpdateLayout()
See Also

Reference

Viewer Class
Viewer Members


UseLayoutRounding Property (Viewer)

UseLayoutRounding Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : UseLayoutRounding Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseLayoutRounding As System.Boolean
public System.bool UseLayoutRounding {get; set;}
See Also

Reference

Viewer Class
Viewer Members


VerticalAlignment Property (Viewer)

VerticalAlignment Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : VerticalAlignment Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property VerticalAlignment As System.Windows.VerticalAlignment
public System.Windows.VerticalAlignment VerticalAlignment {get; set;}
See Also

Reference

Viewer Class
Viewer Members


VerticalContentAlignment Property (Viewer)

VerticalContentAlignment Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : VerticalContentAlignment Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property VerticalContentAlignment As System.Windows.VerticalAlignment
public System.Windows.VerticalAlignment VerticalContentAlignment {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Visibility Property (Viewer)

Visibility Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Visibility Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visibility As System.Windows.Visibility
public System.Windows.Visibility Visibility {get; set;}
See Also

Reference

Viewer Class
Viewer Members


Width Property (Viewer)

Width Property (Viewer)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.ActiveReports.Viewer.Wpf Namespace > Viewer Class : Width Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As System.Double
public System.double Width {get; set;}
See Also

Reference

Viewer Class
Viewer Members


GrapeCity.ActiveReports.Viewer.Wpf Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Viewer.Wpf Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly : GrapeCity.ActiveReports.Viewer.Wpf Namespace
Inheritance Hierarchy
System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
GrapeCity.ActiveReports.Viewer.Wpf.Viewer.ActionEventArgs
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
GrapeCity.ActiveReports.Viewer.Wpf.Sidebar
GrapeCity.ActiveReports.Viewer.Wpf.SidebarPanel
GrapeCity.ActiveReports.Viewer.Wpf.ParametersPanel
GrapeCity.ActiveReports.Viewer.Wpf.SearchPanel
GrapeCity.ActiveReports.Viewer.Wpf.ThumbnailsPanel
GrapeCity.ActiveReports.Viewer.Wpf.TocPanel
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
GrapeCity.ActiveReports.Viewer.Wpf.Viewer
See Also

Reference

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly


CachedPageView Class Properties

CachedPageView Class Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : CachedPageView Class

For a list of all members of this type, see CachedPageView members.

Public Properties
 | Name | Description
Public Property | Device | Gets the device kind. (Inherited from GrapeCity.Viewer.Common.PageView)
Public Property | Size | Gets the page view size. (Inherited from GrapeCity.Viewer.Common.PageView)
Top
See Also

Reference

CachedPageView Class
GrapeCity.Viewer.Common Namespace


Color Constructor

Color Constructor

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > Color Structure : Color Constructor
Overload List
Overload | Description
Color Constructor | Initializes a new instance of the Color struct.
See Also

Reference

Color Structure
Color Members


DelegateCommand Class Events

DelegateCommand Class Events

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand Class

For a list of all members of this type, see DelegateCommand members.

Public Events
 | Name | Description
Public Event | CanExecuteChanged | Occurs when changes occur that affect whether the command should execute. (Inherited from GrapeCity.Viewer.Common.DelegateCommand<object>)
Top
See Also

Reference

DelegateCommand Class
GrapeCity.Viewer.Common Namespace


DelegateCommand Class Methods

DelegateCommand Class Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DelegateCommand Class

For a list of all members of this type, see DelegateCommand members.

Public Methods
 | Name | Description
Public Method | CanExecute | Defines the method that determines whether the command can execute in its current state. (Inherited from GrapeCity.Viewer.Common.DelegateCommand<object>)
Public Method | Execute | Defines the method to be called when the command is invoked. (Inherited from GrapeCity.Viewer.Common.DelegateCommand<object>)
Public Method | RaiseCanExecuteChanged | Raise CanExecuteChanged event from external code. (Inherited from GrapeCity.Viewer.Common.DelegateCommand<object>)
Top
See Also

Reference

DelegateCommand Class
GrapeCity.Viewer.Common Namespace


DocumentRendererAttribute Class Methods

DocumentRendererAttribute Class Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : DocumentRendererAttribute Class

For a list of all members of this type, see DocumentRendererAttribute members.

Public Methods
 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)
Top
See Also

Reference

DocumentRendererAttribute Class
GrapeCity.Viewer.Common Namespace


Equals Method (DocumentRendererAttribute)

Equals Method (DocumentRendererAttribute)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DocumentRendererAttribute Class : Equals Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function Equals( _
   ByVal obj As System.Object _
) As System.Boolean
public virtual System.bool Equals(
   System.object obj
)

Parameters

obj
See Also

Reference

DocumentRendererAttribute Class
DocumentRendererAttribute Members


GetHashCode Method (DocumentRendererAttribute)

GetHashCode Method (DocumentRendererAttribute)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DocumentRendererAttribute Class : GetHashCode Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function GetHashCode() As System.Integer
public virtual System.int GetHashCode()
See Also

Reference

DocumentRendererAttribute Class
DocumentRendererAttribute Members


IsDefaultAttribute Method (DocumentRendererAttribute)

IsDefaultAttribute Method (DocumentRendererAttribute)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DocumentRendererAttribute Class : IsDefaultAttribute Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function IsDefaultAttribute() As System.Boolean
public virtual System.bool IsDefaultAttribute()
See Also

Reference

DocumentRendererAttribute Class
DocumentRendererAttribute Members


Match Method (DocumentRendererAttribute)

Match Method (DocumentRendererAttribute)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DocumentRendererAttribute Class : Match Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function Match( _
   ByVal obj As System.Object _
) As System.Boolean
public virtual System.bool Match(
   System.object obj
)

Parameters

obj
See Also

Reference

DocumentRendererAttribute Class
DocumentRendererAttribute Members


TypeId Property (DocumentRendererAttribute)

TypeId Property (DocumentRendererAttribute)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > DocumentRendererAttribute Class : TypeId Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property TypeId As System.Object
public virtual System.object TypeId {get;}
See Also

Reference

DocumentRendererAttribute Class
DocumentRendererAttribute Members


ObservableCollection<T> Class Methods

ObservableCollection<T> Class Methods

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : ObservableCollection<T> Class

For a list of all members of this type, see ObservableCollection<T> members.

Public Methods
 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<T>)
Top
See Also

Reference

ObservableCollection<T> Class
GrapeCity.Viewer.Common Namespace


ObservableCollection<T> Class Properties

ObservableCollection<T> Class Properties

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace : ObservableCollection<T> Class

For a list of all members of this type, see ObservableCollection<T> members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<T>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<T>)
Top
See Also

Reference

ObservableCollection<T> Class
GrapeCity.Viewer.Common Namespace


Add Method (ObservableCollection<T>)

Add Method (ObservableCollection<T>)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : Add Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Add( _
   ByVal item As T _
)
public void Add(
   T item
)

Parameters

item
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


Clear Method (ObservableCollection<T>)

Clear Method (ObservableCollection<T>)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : Clear Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


Contains Method (ObservableCollection<T>)

Contains Method (ObservableCollection<T>)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : Contains Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal item As T _
) As System.Boolean
public System.bool Contains(
   T item
)

Parameters

item
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


CopyTo Method (ObservableCollection<T>)

CopyTo Method (ObservableCollection<T>)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : CopyTo Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal array() As T, _
   ByVal index As System.Integer _
)
public void CopyTo(
   T[] array,
   System.int index
)

Parameters

array
index
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


Count Property (ObservableCollection<T>)

Count Property (ObservableCollection<T>)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : Count Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


IndexOf Method (ObservableCollection<T>)

IndexOf Method (ObservableCollection<T>)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : IndexOf Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal item As T _
) As System.Integer
public System.int IndexOf(
   T item
)

Parameters

item
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


Insert Method (ObservableCollection<T>)

Insert Method (ObservableCollection<T>)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : Insert Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As T _
)
public void Insert(
   System.int index,
   T item
)

Parameters

index
item
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


Item Property (ObservableCollection<T>)

Item Property (ObservableCollection<T>)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : Item Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As System.Integer _
) As T
public T this[
   System.int index
]; {get; set;}

Parameters

index
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


Remove Method (ObservableCollection<T>)

Remove Method (ObservableCollection<T>)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : Remove Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Remove( _
   ByVal item As T _
) As System.Boolean
public System.bool Remove(
   T item
)

Parameters

item
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


RemoveAt Method (ObservableCollection<T>)

RemoveAt Method (ObservableCollection<T>)

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly > GrapeCity.Viewer.Common Namespace > ObservableCollection<T> Class : RemoveAt Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
See Also

Reference

ObservableCollection<T> Class
ObservableCollection<T> Members


GrapeCity.Viewer.Common Namespace (GrapeCity.ActiveReports.Viewer.Wpf.v10) Inheritance Hierarchy

GrapeCity.Viewer.Common Namespace (GrapeCity.ActiveReports.Viewer.Wpf.v10) Inheritance Hierarchy
GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly : GrapeCity.Viewer.Common Namespace
Inheritance Hierarchy
System.Object
GrapeCity.Viewer.Common.DelegateCommand<TParm>
GrapeCity.Viewer.Common.DelegateCommand
GrapeCity.Viewer.Common.DisposablesCollection
GrapeCity.Viewer.Common.DocumentSearchService
GrapeCity.Viewer.Common.DoubleDelegateCommand
GrapeCity.Viewer.Common.EnumerableExtensions
GrapeCity.Viewer.Common.NullDelegateCommand
GrapeCity.Viewer.Common.NullRenderer
GrapeCity.Viewer.Common.NullRenderer.Factory
GrapeCity.Viewer.Common.PageView
GrapeCity.Viewer.Common.CachedPageView
GrapeCity.Viewer.Common.RectExtensions
GrapeCity.Viewer.Common.StreamDocumentLoader
System.Attribute
GrapeCity.Viewer.Common.DocumentRendererAttribute
System.Collections.ObjectModel.Collection<T>
GrapeCity.Viewer.Common.ObservableCollection<T>
System.EventArgs
GrapeCity.Viewer.Common.NotifyCollectionChangedEventArgs
System.ValueType
GrapeCity.Viewer.Common.Color
GrapeCity.Viewer.Common.Margin
GrapeCity.Viewer.Common.Point
GrapeCity.Viewer.Common.Rect
GrapeCity.Viewer.Common.Size
See Also

Reference

GrapeCity.ActiveReports.Viewer.Wpf.v10 Assembly


GrapeCity.ActiveReports.Web.v10 Assembly

GrapeCity.ActiveReports.Web.v10 Assembly
Namespaces
Namespace | Description
GrapeCity.ActiveReports.Web | The GrapeCity.ActiveReports.Web namespace contains the WebViewer class.
GrapeCity.ActiveReports.Web.Controls | The GrapeCity.ActiveReports.Web.Controls namespace contains the customizable toolbar object and tools that can be used with the FlashViewer ViewerType of the WebViewer.
GrapeCity.ActiveReports.Web.ExportOptions | The GrapeCity.ActiveReports.Web.ExportOptions namespace contains the HtmlExport and PdfExport classes.
GrapeCity.ActiveReports.Web.Handlers | The GrapeCity.ActiveReports.Web.Handlers namespace contains the classes which handle the report types for web consumption.


ToolsCollection Class Methods

ToolsCollection Class Methods

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolsCollection Class

For a list of all members of this type, see ToolsCollection members.

Public Methods
 | Name | Description
Public Method | Add | Add the specified tool to the tools collection. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | Clear | Clears all tools from the collection. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | Remove | Removes the specified tool from the collection. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Public Method | RemoveAt | Removes the tool in the specified position from the collection. (Inherited from System.Collections.ObjectModel.Collection<ToolBase>)
Top
See Also

Reference

ToolsCollection Class
GrapeCity.ActiveReports.Web.Controls Namespace


Add Method (ToolsCollection)

Add Method (ToolsCollection)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolsCollection Class : Add Method
The Tool object to add to the collection.
Add the specified tool to the tools collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Add( _
   ByVal item As ToolBase _
)
public void Add(
   ToolBase item
)

Parameters

item
The Tool object to add to the collection.
See Also

Reference

ToolsCollection Class
ToolsCollection Members
Tool Class


Clear Method (ToolsCollection)

Clear Method (ToolsCollection)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolsCollection Class : Clear Method
Clears all tools from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
public void Clear()
See Also

Reference

ToolsCollection Class
ToolsCollection Members


Contains Method (ToolsCollection)

Contains Method (ToolsCollection)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolsCollection Class : Contains Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal item As ToolBase _
) As System.Boolean
public System.bool Contains(
   ToolBase item
)

Parameters

item
See Also

Reference

ToolsCollection Class
ToolsCollection Members


CopyTo Method (ToolsCollection)

CopyTo Method (ToolsCollection)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolsCollection Class : CopyTo Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyTo( _
   ByVal array() As ToolBase, _
   ByVal index As System.Integer _
)
public void CopyTo(
   ToolBase[] array,
   System.int index
)

Parameters

array
index
See Also

Reference

ToolsCollection Class
ToolsCollection Members


Count Property (ToolsCollection)

Count Property (ToolsCollection)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolsCollection Class : Count Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Count As System.Integer
public System.int Count {get;}
See Also

Reference

ToolsCollection Class
ToolsCollection Members


IndexOf Method (ToolsCollection)

IndexOf Method (ToolsCollection)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolsCollection Class : IndexOf Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal item As ToolBase _
) As System.Integer
public System.int IndexOf(
   ToolBase item
)

Parameters

item
See Also

Reference

ToolsCollection Class
ToolsCollection Members


Insert Method (ToolsCollection)

Insert Method (ToolsCollection)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolsCollection Class : Insert Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ToolBase _
)
public void Insert(
   System.int index,
   ToolBase item
)

Parameters

index
item
See Also

Reference

ToolsCollection Class
ToolsCollection Members


Remove Method (ToolsCollection)

Remove Method (ToolsCollection)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolsCollection Class : Remove Method
The Tool object to remove from the collection.
Removes the specified tool from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Remove( _
   ByVal item As ToolBase _
) As System.Boolean
public System.bool Remove(
   ToolBase item
)

Parameters

item
The Tool object to remove from the collection.
See Also

Reference

ToolsCollection Class
ToolsCollection Members


RemoveAt Method (ToolsCollection)

RemoveAt Method (ToolsCollection)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace > ToolsCollection Class : RemoveAt Method
The zero-based indexed position of the tool to remove from the toolbar.
Removes the tool in the specified position from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based indexed position of the tool to remove from the toolbar.
See Also

Reference

ToolsCollection Class
ToolsCollection Members


ToolSeparator Class Properties

ToolSeparator Class Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Controls Namespace : ToolSeparator Class

For a list of all members of this type, see ToolSeparator members.

Public Properties
 | Name | Description
Public Property | Name | Gets the name of the toolbox item. (Inherited from GrapeCity.ActiveReports.Web.Controls.ToolBase)
Public Property | Visible | Gets or sets the toolbox item's visibility. (Inherited from GrapeCity.ActiveReports.Web.Controls.ToolBase)
Top
See Also

Reference

ToolSeparator Class
GrapeCity.ActiveReports.Web.Controls Namespace


GrapeCity.ActiveReports.Web.Controls Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Web.Controls Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Web.v10 Assembly : GrapeCity.ActiveReports.Web.Controls Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Web.Controls.ToolBarObject
GrapeCity.ActiveReports.Web.Controls.ToolBase
GrapeCity.ActiveReports.Web.Controls.Tool
GrapeCity.ActiveReports.Web.Controls.ToolButton
GrapeCity.ActiveReports.Web.Controls.ToolSeparator
System.Collections.ObjectModel.Collection<T>
GrapeCity.ActiveReports.Web.Controls.ToolsCollection
See Also

Reference

GrapeCity.ActiveReports.Web.v10 Assembly


GrapeCity.ActiveReports.Web.ExportOptions Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Web.ExportOptions Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Web.v10 Assembly : GrapeCity.ActiveReports.Web.ExportOptions Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Web.ExportOptions.FlashViewerOptions
GrapeCity.ActiveReports.Web.ExportOptions.FlashViewerOptions.FlashViewerPrintOptions
GrapeCity.ActiveReports.Web.ExportOptions.HtmlExportOptions
GrapeCity.ActiveReports.Web.ExportOptions.PdfExportOptions
GrapeCity.ActiveReports.Web.ExportOptions.TocPanelOptions
See Also

Reference

GrapeCity.ActiveReports.Web.v10 Assembly


CompiledReportHandler Class Properties

CompiledReportHandler Class Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : CompiledReportHandler Class

For a list of all members of this type, see CompiledReportHandler members.

Public Properties
 | Name | Description
Public Property | IsReusable | Returns a value indicating whether the class can be pooled. (Inherited from GrapeCity.ActiveReports.Web.Handlers.ArHandlerBase)
Top
See Also

Reference

CompiledReportHandler Class
GrapeCity.ActiveReports.Web.Handlers Namespace


RdlxHandler Class Properties

RdlxHandler Class Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : RdlxHandler Class

For a list of all members of this type, see RdlxHandler members.

Public Properties
 | Name | Description
Public Property | IsReusable | Returns a value indicating whether the class can be pooled. (Inherited from GrapeCity.ActiveReports.Web.Handlers.ArHandlerBase)
Top
See Also

Reference

RdlxHandler Class
GrapeCity.ActiveReports.Web.Handlers Namespace


RpxHandler Class Properties

RpxHandler Class Properties

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web.Handlers Namespace : RpxHandler Class

For a list of all members of this type, see RpxHandler members.

Public Properties
 | Name | Description
Public Property | IsReusable | Returns a value indicating whether the class can be pooled. (Inherited from GrapeCity.ActiveReports.Web.Handlers.ArHandlerBase)
Top
See Also

Reference

RpxHandler Class
GrapeCity.ActiveReports.Web.Handlers Namespace


GrapeCity.ActiveReports.Web.Handlers Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Web.Handlers Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Web.v10 Assembly : GrapeCity.ActiveReports.Web.Handlers Namespace
Inheritance Hierarchy
System.Object
GrapeCity.ActiveReports.Web.Handlers.ArHandlerBase
GrapeCity.ActiveReports.Web.Handlers.CompiledReportHandler
GrapeCity.ActiveReports.Web.Handlers.RdlxHandler
GrapeCity.ActiveReports.Web.Handlers.RpxHandler
GrapeCity.ActiveReports.Web.Handlers.ReportBinariesStreamer
GrapeCity.ActiveReports.Web.Handlers.WebCacheAccessHandler
See Also

Reference

GrapeCity.ActiveReports.Web.v10 Assembly


AccessKey Property

AccessKey Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : AccessKey Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property AccessKey As System.String
public virtual System.string AccessKey {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


ApplyStyle Method

ApplyStyle Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ApplyStyle Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s
See Also

Reference

WebViewer Class
WebViewer Members


ApplyStyleSheetSkin Method

ApplyStyleSheetSkin Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ApplyStyleSheetSkin Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)

Parameters

page
See Also

Reference

WebViewer Class
WebViewer Members


AppRelativeTemplateSourceDirectory Property

AppRelativeTemplateSourceDirectory Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : AppRelativeTemplateSourceDirectory Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AppRelativeTemplateSourceDirectory As System.String
public System.string AppRelativeTemplateSourceDirectory {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


Attributes Property

Attributes Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Attributes Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Attributes As System.Web.UI.AttributeCollection
public System.Web.UI.AttributeCollection Attributes {get;}
See Also

Reference

WebViewer Class
WebViewer Members


BackColor Property (WebViewer)

BackColor Property (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : BackColor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property BackColor As Color
public virtual Color BackColor {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


BorderColor Property (WebViewer)

BorderColor Property (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : BorderColor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property BorderColor As Color
public virtual Color BorderColor {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


BorderStyle Property (WebViewer)

BorderStyle Property (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : BorderStyle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property BorderStyle As System.Web.UI.WebControls.BorderStyle
public virtual System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


BorderWidth Property (WebViewer)

BorderWidth Property (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : BorderWidth Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property BorderWidth As System.Web.UI.WebControls.Unit
public virtual System.Web.UI.WebControls.Unit BorderWidth {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


ClientID Property

ClientID Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ClientID Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property ClientID As System.String
public virtual System.string ClientID {get;}
See Also

Reference

WebViewer Class
WebViewer Members


ClientIDMode Property

ClientIDMode Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ClientIDMode Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


Controls Property (WebViewer)

Controls Property (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Controls Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Controls As System.Web.UI.ControlCollection
public virtual System.Web.UI.ControlCollection Controls {get;}
See Also

Reference

WebViewer Class
WebViewer Members


ControlStyle Property

ControlStyle Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ControlStyle Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ControlStyle As System.Web.UI.WebControls.Style
public System.Web.UI.WebControls.Style ControlStyle {get;}
See Also

Reference

WebViewer Class
WebViewer Members


ControlStyleCreated Property

ControlStyleCreated Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ControlStyleCreated Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ControlStyleCreated As System.Boolean
public System.bool ControlStyleCreated {get;}
See Also

Reference

WebViewer Class
WebViewer Members


CopyBaseAttributes Method

CopyBaseAttributes Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : CopyBaseAttributes Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)

Parameters

controlSrc
See Also

Reference

WebViewer Class
WebViewer Members


CssClass Property

CssClass Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : CssClass Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property CssClass As System.String
public virtual System.string CssClass {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


DataBind Method

DataBind Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : DataBind Method
Overload List
Overload | Description
DataBind | (Inherited from System.Web.UI.Control)
See Also

Reference

WebViewer Class
WebViewer Members


DataBind() Method

DataBind() Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : DataBind() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub DataBind()
public virtual void DataBind()
See Also

Reference

WebViewer Class
WebViewer Members


DataBinding Event

DataBinding Event

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : DataBinding Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event DataBinding As System.EventHandler
public event System.EventHandler DataBinding
See Also

Reference

WebViewer Class
WebViewer Members


Disposed Event (WebViewer)

Disposed Event (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Disposed Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Disposed As System.EventHandler
public event System.EventHandler Disposed
See Also

Reference

WebViewer Class
WebViewer Members


Enabled Property (WebViewer)

Enabled Property (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Enabled Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Enabled As System.Boolean
public virtual System.bool Enabled {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


EnableTheming Property

EnableTheming Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : EnableTheming Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property EnableTheming As System.Boolean
public virtual System.bool EnableTheming {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


EnableViewState Property

EnableViewState Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : EnableViewState Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property EnableViewState As System.Boolean
public virtual System.bool EnableViewState {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


FindControl Method

FindControl Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : FindControl Method
Overload List
Overload | Description
FindControl | (Inherited from System.Web.UI.Control)
See Also

Reference

WebViewer Class
WebViewer Members


FindControl(String) Method

FindControl(String) Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : FindControl(String) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
public virtual System.Web.UI.Control FindControl(
   System.string id
)

Parameters

id
See Also

Reference

WebViewer Class
WebViewer Members


Focus Method (WebViewer)

Focus Method (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Focus Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub Focus()
public virtual void Focus()
See Also

Reference

WebViewer Class
WebViewer Members


Font Property (WebViewer)

Font Property (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Font Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
public virtual System.Web.UI.WebControls.FontInfo Font {get;}
See Also

Reference

WebViewer Class
WebViewer Members


ForeColor Property (WebViewer)

ForeColor Property (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ForeColor Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property ForeColor As Color
public virtual Color ForeColor {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


GetRouteUrl Method

GetRouteUrl Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : GetRouteUrl Method
Overload List
Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)
See Also

Reference

WebViewer Class
WebViewer Members


GetRouteUrl(Object) Method

GetRouteUrl(Object) Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class > GetRouteUrl Method : GetRouteUrl(Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
public System.string GetRouteUrl(
   System.object routeParameters
)

Parameters

routeParameters
See Also

Reference

WebViewer Class
WebViewer Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

GetRouteUrl(RouteValueDictionary) Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeParameters
See Also

Reference

WebViewer Class
WebViewer Members
Overload List


GetRouteUrl(String,Object) Method

GetRouteUrl(String,Object) Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)

Parameters

routeName
routeParameters
See Also

Reference

WebViewer Class
WebViewer Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

GetRouteUrl(String,RouteValueDictionary) Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)

Parameters

routeName
routeParameters
See Also

Reference

WebViewer Class
WebViewer Members
Overload List


GetUniqueIDRelativeTo Method

GetUniqueIDRelativeTo Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : GetUniqueIDRelativeTo Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)

Parameters

control
See Also

Reference

WebViewer Class
WebViewer Members


HasAttributes Property

HasAttributes Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : HasAttributes Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HasAttributes As System.Boolean
public System.bool HasAttributes {get;}
See Also

Reference

WebViewer Class
WebViewer Members


HasControls Method

HasControls Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : HasControls Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Function HasControls() As System.Boolean
public virtual System.bool HasControls()
See Also

Reference

WebViewer Class
WebViewer Members


Height Property (WebViewer)

Height Property (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Height Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Height As System.Web.UI.WebControls.Unit
public virtual System.Web.UI.WebControls.Unit Height {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


ID Property (WebViewer)

ID Property (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ID Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property ID As System.String
public virtual System.string ID {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


Init Event

Init Event

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Init Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Init As System.EventHandler
public event System.EventHandler Init
See Also

Reference

WebViewer Class
WebViewer Members


Load Event (WebViewer)

Load Event (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Load Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Load As System.EventHandler
public event System.EventHandler Load
See Also

Reference

WebViewer Class
WebViewer Members


MergeStyle Method

MergeStyle Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : MergeStyle Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)

Parameters

s
See Also

Reference

WebViewer Class
WebViewer Members


NamingContainer Property

NamingContainer Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : NamingContainer Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property NamingContainer As System.Web.UI.Control
public virtual System.Web.UI.Control NamingContainer {get;}
See Also

Reference

WebViewer Class
WebViewer Members


Page Property (WebViewer)

Page Property (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Page Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Page As System.Web.UI.Page
public virtual System.Web.UI.Page Page {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


Parent Property (WebViewer)

Parent Property (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Parent Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property Parent As System.Web.UI.Control
public virtual System.Web.UI.Control Parent {get;}
See Also

Reference

WebViewer Class
WebViewer Members


PreRender Event

PreRender Event

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : PreRender Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PreRender As System.EventHandler
public event System.EventHandler PreRender
See Also

Reference

WebViewer Class
WebViewer Members


RenderBeginTag Method

RenderBeginTag Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : RenderBeginTag Method
HtmlTextWriter.
Extracts the style attribute from the outer div or table tag when using Acrobat and uses a percentage of the width or height.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer
HtmlTextWriter.
Remarks
The width or height being specified as 100% on both the div and the object or iframe causes problems.
See Also

Reference

WebViewer Class
WebViewer Members


RenderControl Method

RenderControl Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : RenderControl Method
Overload List
Overload | Description
RenderControl | (Inherited from System.Web.UI.Control)
See Also

Reference

WebViewer Class
WebViewer Members


RenderControl(HtmlTextWriter) Method

RenderControl(HtmlTextWriter) Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : RenderControl(HtmlTextWriter) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer
See Also

Reference

WebViewer Class
WebViewer Members


RenderEndTag Method

RenderEndTag Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : RenderEndTag Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
public virtual void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)

Parameters

writer
See Also

Reference

WebViewer Class
WebViewer Members


RenderingCompatibility Property

RenderingCompatibility Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : RenderingCompatibility Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property RenderingCompatibility As System.Version
public virtual System.Version RenderingCompatibility {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


ResolveClientUrl Method

ResolveClientUrl Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ResolveClientUrl Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
public System.string ResolveClientUrl(
   System.string relativeUrl
)

Parameters

relativeUrl
See Also

Reference

WebViewer Class
WebViewer Members


ResolveUrl Method

ResolveUrl Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ResolveUrl Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
public System.string ResolveUrl(
   System.string relativeUrl
)

Parameters

relativeUrl
See Also

Reference

WebViewer Class
WebViewer Members


SetRenderMethodDelegate Method

SetRenderMethodDelegate Method

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : SetRenderMethodDelegate Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)

Parameters

renderMethod
See Also

Reference

WebViewer Class
WebViewer Members


Site Property (WebViewer)

Site Property (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Site Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Site As System.ComponentModel.ISite
public System.ComponentModel.ISite Site {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


SkinID Property

SkinID Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : SkinID Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property SkinID As System.String
public virtual System.string SkinID {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


Style Property (WebViewer)

Style Property (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Style Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Style As System.Web.UI.CssStyleCollection
public System.Web.UI.CssStyleCollection Style {get;}
See Also

Reference

WebViewer Class
WebViewer Members


SupportsDisabledAttribute Property

SupportsDisabledAttribute Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : SupportsDisabledAttribute Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property SupportsDisabledAttribute As System.Boolean
public virtual System.bool SupportsDisabledAttribute {get;}
See Also

Reference

WebViewer Class
WebViewer Members


TabIndex Property (WebViewer)

TabIndex Property (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : TabIndex Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property TabIndex As System.Short
public virtual System.short TabIndex {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


TemplateControl Property

TemplateControl Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : TemplateControl Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TemplateControl As System.Web.UI.TemplateControl
public System.Web.UI.TemplateControl TemplateControl {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


TemplateSourceDirectory Property

TemplateSourceDirectory Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : TemplateSourceDirectory Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property TemplateSourceDirectory As System.String
public virtual System.string TemplateSourceDirectory {get;}
See Also

Reference

WebViewer Class
WebViewer Members


ToolTip Property (WebViewer)

ToolTip Property (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ToolTip Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property ToolTip As System.String
public virtual System.string ToolTip {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


UniqueID Property

UniqueID Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : UniqueID Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable ReadOnly Property UniqueID As System.String
public virtual System.string UniqueID {get;}
See Also

Reference

WebViewer Class
WebViewer Members


Unload Event

Unload Event

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Unload Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event Unload As System.EventHandler
public event System.EventHandler Unload
See Also

Reference

WebViewer Class
WebViewer Members


ValidateRequestMode Property

ValidateRequestMode Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ValidateRequestMode Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


ViewStateMode Property

ViewStateMode Property

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : ViewStateMode Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


Visible Property (WebViewer)

Visible Property (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Visible Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Visible As System.Boolean
public virtual System.bool Visible {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


Width Property (WebViewer)

Width Property (WebViewer)

GrapeCity.ActiveReports.Web.v10 Assembly > GrapeCity.ActiveReports.Web Namespace > WebViewer Class : Width Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Width As System.Web.UI.WebControls.Unit
public virtual System.Web.UI.WebControls.Unit Width {get; set;}
See Also

Reference

WebViewer Class
WebViewer Members


GrapeCity.ActiveReports.Web Namespace Inheritance Hierarchy

GrapeCity.ActiveReports.Web Namespace Inheritance Hierarchy
GrapeCity.ActiveReports.Web.v10 Assembly : GrapeCity.ActiveReports.Web Namespace
Inheritance Hierarchy
System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
GrapeCity.ActiveReports.Web.WebViewer
See Also

Reference

GrapeCity.ActiveReports.Web.v10 Assembly


JPWLK Layers

JPWLK Layers


Layer

Layer


License Authentication

License Authentication


New Topic 3

New Topic 3


New Topic 4

New Topic 4


New Topic 5

New Topic 5


New Topic 11

New Topic 11


Print

Print


Reports on Web

Reports on Web
Show All Show All
Hide All Hide All

The Page Reports On Web sample demonstrates how to use the ActiveReports WebViewer control on the ASPX page to display reports. The sample offers two drop-down lists of RDL reports and WebViewer types.

Sample Location

Visual Basic.NET

<User Folder>\GrapeCity Samples\ActiveReports 10\Page Reports\RDL\Web\VB.NET\PageReportsOnWeb

C#

<User Folder>\GrapeCity Samples\ActiveReports 10\Page Reports\RDL\Web\C#\PageReportsOnWeb

Runtime Features

When you run this sample, a webpage with two drop-down lists, one with RDL reports and the other with viewer types, appears. Select a report and the viewer type from the drop-down lists and click the Show button to see the report appear in the selected viewer type.

Project Details

Images folder

This folder contains two image files - bg.jpg and grapecity_logo.jpg, that are displayed on the Default.aspx page at runtime.

ActiveReports.ReportService.asmx

The report web service required for the proper functioning of the Web Viewer. The ActiveReports.ReportService.asmx is added automatically to the project when you place the WebViewer control on the form. You can also add this service by using Add New Item in the Visual Studio 2010 Project menu.

For the information on how to use the WebViewer control, see Getting Started with the Web Viewer.

Default.aspx

This is the main page that appears at runtime. This ASPX page contains drop-down lists to collect user input, a button to send the collected values to the WebViewer control.

Right-click the ASPX page and select View Code to see the code used to find the reports in the Reels folder installed along with the sample. To learn more about the RDL reports that you can select on this page, see RDL Report Loader. It also contains code that displays the selected report and sets the WebViewer type selected by the user.

The Source tab of the ASPX page contains the marquee tag to display a floating message below the WebViewer.

ErrorSelection.rdlx

This is the report that appears at runtime when you have clicked the Show button without selecting any specific report from the drop-down list. It contains a TextBox control that displays the error message.

Main.rdlx

This is the default report that appears in the WebViewer when you run this sample. It contains a FormattedText control with the HTML property set to the welcome message text. This text is displayed when you run this sample.

Web.config

The configuration file that contains the httpHandlers that allow ActiveReports to process reports on the Web.

Note that you need to manually update version information here when you update your version of ActiveReports.

See Also

Getting Started

Web Viewer (ASP.NET)


Web

Web

Learn to display a section report at client side.

This section contains:

Standard Edition Web
Demonstrates exporting an ActiveReports report to the HTML or PDF format in your Web application.
See Also
Data
Layout
Preview
Summary
WPF


Tablix Reports

Tablix Reports
Show All Show All
Hide All Hide All

This walkthrough illustrates a step-by-step implementation for creating a report which uses the Tablix data region to display regional product sales.

The walkthrough is split into the following activities:

  • Adding an ActiveReport to a Visual Studio project
  • Connecting the report to a data source
  • Adding a dataset
  • Creating a layout for the report
  • Adding subtotals to the Tablix
  • Enhancing the appearance of the report
  • Viewing the report
Note:
  • This walkthrough uses the Reels database. By default, in ActiveReports, the Reels.mdb file is located in the [User Documents folder]\GrapeCity Samples\ActiveReports 10\Data folder.
  • Although this walkthrough uses RDL reports, you can also implement this using page reports.

When you complete this walkthrough you get a layout looks similar to the following at design time and at runtime.

Design Time Layout

Runtime Layout

To add an ActiveReport to the Visual Studio project

  1. Create a new Visual Studio project.
  2. From the Project menu, select Add New Item.
  3. In the Add New Item dialog that appears, select ActiveReports 10 RDL Report Application and in the Name field, rename the file as rptTablix.
  4. Click the Add button to open a new RDL report in the designer.

See Adding an ActiveReport to a Project for information on adding different report layouts.

To connect the report to a data source

  1. In the Report Explorer, right-click the Data Sources node and select the Add Data Source option or select Data Source from the Add button.
  2. In the Report Data Source Dialog that appears, select the General page and in the Name field, enter a name like ReportData.
  3. On this page, create a connection to the Reels database. See Connect to a Data Source for information on connecting to a data source.

To add a dataset

  1. In the Report Explorer, right-click the data source node and select the Add Data Set option or select Data Set from the Add button.
  2. In the DataSet Dialog that appears, select the General page and enter the name of the dataset as RegionSalesData. This name appears as a child node to the data source icon in the Report Explorer.
  3. On the Query page of this dialog, in the Query field enter the following SQL query.
    SQL Query
    Copy Code
    SELECT Sale.SaleDate, Sale.TotalAmount, MediaType.Description, MediaType.MediaID, Sale.SalesID, Sale.Store, Store.StoreName
FROM Store INNER JOIN (Sale INNER JOIN (MediaType INNER JOIN (MovieProduct INNER JOIN SaleDetails ON MovieProduct.ProductID = SaleDetails.ProductID) ON MediaType.MediaID = MovieProduct.MediaType) ON Sale.SalesID = SaleDetails.SaleID) ON Store.StoreID = Sale.Store;
  4. Click the Validate DataSet icon at the top right hand corner above the Query box to validate the query.
  5. Click OK to close the dialog. Your data set and queried fields appear as nodes in the Report Explorer.

To create a layout for the report

  1. Click gray area below the design surface to select the report. Go to the Properties Window, expand the PageSize property and set Width to 10in and Height to 11in.
  2. From the toolbox, drag a Tablix data region onto the $designer surface$ of the report.
  3. Drag and drop StoreSales.Region field from the Report Explorer to the column group area (top right corner) of the Tablix data region. This is the column header, and dragging a field into it automatically adds a column group.
  4. Right-click the column header cell where StoreSales.Region field is added in the Tablix data region, select Add Column Group, and then select the Child Group option. The child group is added below the column header and is listed under the Group Editor window.
  5. Drag and drop StoreSales.District field from the Report Explorer to the new column group cell below the StoreSales.Region field.
  6. Right-click the new column group cell where StoreSales.District field is added in the Tablix data region, select Add Column Group, and then select the Child Group option. The child group is added below the new column group and is listed under the Group Editor window.
  7. Drag and drop the SaleYear field from the Report Explorer to the new column group cell created below the StoreSales.District field.
  8. Drag and drop StoreSales.StoreName field from the Report Explorer to the row group area (bottom left corner) of the Tablix data region. This is the row header, and dragging a field into it automatically adds a row group.
  9. Drag and drop GrossSales field from the Report Explorer to the body area (bottom right corner) of the Tablix data region.
  10. With the GrossSales cell selected, in the Properties window set the Format property to Currency.

To add subtotals to the Tablix

  1. Right-click the row group area, select Add Total, and then click After. A new row appears at the bottom with the text Total. This row automatically sets the expression of the cell to =Sum(Fields!GrossSales.Value).
  2. With the =Sum(Fields!GrossSales.Value) cell selected, in the Properties window set the Format property to Currency.

To enhance the appearance of the report

When you preview the report at this point, you will notice the data from the fields is displayed in the Tablix data region. Let us now work on the report appearance to further enhance the layout of the Tablix data region.

  1. In the Tablix data region, select the textbox that contains the following fields and go to the Properties Window to set the following properties:
    Field Name | Property Name | Property Value
    =Fields.Item("StoreSales.Region").Value | BackgroundColor | LightGray
    BorderStyle | Solid
    FontWeight | Bold
    TextAlign | Center
    =Fields.Item("StoreSales.District").Value | BackgroundColor | LightSteelBlue
    BorderStyle | Solid
    FontWeight | Bold
    TextAlign | Center
    =Fields!SaleYear.Value | BackgroundColor | Azure
    BorderStyle | Solid
    TextAlign | Center
    =Fields!GrossSales.Value | BorderStyle | Solid
    =Fields.Item("StoreSales.StoreName").Value | BackgroundColor | LightGray
    BorderStyle | Solid
    TextAlign | Center
    Total | BackgroundColor | DarkGray
    BorderStyle | Solid
    TextAlign | Center
    =Sum(Fields!GrossSales.Value) | BackgroundColor | DarkGray
    BorderStyle | Solid
    FontWeight | Bold
  2. Select the three empty cells that are present in the corner area (top left corner), right-click the selected area, and then Select Merge Cells option to merge the cells.
  3. With the merged cell selected, in the Properties window set the Value property to Regional Product Sales. This is the heading for the report.
  4. In the Tablix data region, select the textbox that contains Regional Product Sales text and go to the Properties Window to set the following properties.
    Property Name | Property Value
    BackgroundColor | SkyBlue
    BorderStyle | Solid
    FontSize | 16pt
    FontWeight | Bold
    TextAlign | Center
  5. Select the Tablix data region and go to the Properties window to set the following properties.
    Property Name | Property Value
    Location | 0in, 0.5in
    Size | 3.7in, 2in

To view the report

  • Click the preview tab to view the report at design time.

OR

  • Open the report in the Viewer. See Windows Forms Viewer for further information.


Using Script in a Section Report (XML-based)

Using Script in a Section Report (XML-based)
Show All Show All
Hide All Hide All

In a section report (xml-based), a user can connect to a data source, access report controls and sections and set their properties using scripting. Go through the sections below to learn using the scripts in a xml based section report.

To use a script to create a data connection

Go to the Script tab and add a scripting code like the following:

To write the script in Visual Basic.NET

Visual Basic.NET script. Paste in the script editor window.
Copy Code
Private Shared m_cnn As System.Data.OleDb.OleDbConnection

Public Sub ActiveReport_ReportStart()
  'Set up a data connection for the report
  Dim connString As String = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=[User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb"
  Dim sqlString As String = "SELECT * FROM products"

  m_cnn = new System.Data.OleDb.OleDbConnection(connString)
  Dim m_Cmd As System.Data.OleDb.OleDbCommand = new System.Data.OleDb.OleDbCommand(sqlString, m_cnn)

  If m_cnn.State = System.Data.ConnectionState.Closed Then
     m_cnn.Open
  End If
  rpt.DataSource = m_Cmd.ExecuteReader
End Sub

Public Sub ActiveReport_ReportEnd()
  'Close the data reader and connection
  m_cnn.Close
End Sub

To write the script in C#

C# script. Paste in the script editor window.
Copy Code
private static System.Data.OleDb.OleDbConnection m_cnn;

public void ActiveReport_ReportStart()
{
    //Set up a data connection for the report
    string m_cnnString = @"Provider=Microsoft.Jet.OLEDB.4.0;Data Source=[User Documents folder]\GrapeCity Samples\ActiveReports 10\Data\NWIND.mdb";
    string sqlString = "SELECT * FROM products";
    m_cnn = new System.Data.OleDb.OleDbConnection(m_cnnString);
    System.Data.OleDb.OleDbCommand m_Cmd = new System.Data.OleDb.OleDbCommand(sqlString, m_cnn);

    if(m_cnn.State == System.Data.ConnectionState.Closed)
    {
        m_cnn.Open();
    }
    rpt.DataSource = m_Cmd.ExecuteReader();
}

public void ActiveReport_ReportEnd()
{
    //Close the data reader and connection
    m_cnn.Close();
}
Warning: Do not access the Fields collection outside the DataInitialize and FetchData events. Accessing the Fields collection outside of these events is not supported, and has unpredictable results.

To add scripting to apply alternate colors in the detail section

Go to the Script tab and add a scripting code like the following:

To write the script in Visual Basic.NET

Visual Basic.NET script. Paste in the script editor window.
Copy Code
Dim b as boolean = true

Sub Detail1_Format
 if b then
  Me.Detail1.BackColor = Color.AliceBlue
  b= false
  else
  me.Detail1.BackColor = Color.Cyan
  b = true
 End If
End Sub

To write the script in C#

C# script. Paste in the script editor window.
Copy Code
bool color = true;
public void Detail1_Format()
{
  if(color)
  {
      this.Detail1.BackColor = System.Drawing.Color.AliceBlue;
      color = false;
  }
  else
  {
      this.Detail1.BackColor = System.Drawing.Color.Cyan;
      color = true;
  }
}


Windows Form Viewer

Windows Form Viewer

In this documentation

Using the Viewer
Explore the ways that the Viewer control can save you time.
Customize the Viewer ToolStrip
Learn about various interactive features that affect your report output.
Customize the Viewer Control
Learn how to customize the touch mode toolbar and the mouse mode toolbar of the Viewer control.
Localize the Viewer Control
Learn how to localize strings and images for the ActiveReports Viewer control.


WPF Viewer

WPF Viewer

Learn to display a report in the WPF Viewer.

This section contains:

WPF Viewer
Demonstrates the WPF Viewer and its options to view rdlx and rpx reports.
See Also
Data
Layout
Preview
Summary
Web